Introduction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Introduction

What is an API?

For those of you who are new to customizing applications by writing programs, the first question might be: what is an API? API, or Application Programming Interface, is a term used to describe the functionality exposed by an application that allows it to be used through a program. For example, you can use Autodesk Inventor's API to write a program that will perform the same types of operations you can perform when using Autodesk Inventor interactively.

Having an API is important because it allows you to add functionality to Autodesk Inventor that is specific to your needs. Autodesk Inventor, by necessity, is a general CAD system, meaning that it's not aimed at any specific industry or used to model only certain types of products. By providing an API, Autodesk Inventor allows you to add additional functionality and optimize repetitive operations to make it more productive for your individual needs.

By providing an API, Autodesk Inventor also provides you the ability to better integrate Autodesk Inventor into your overall Enterprise process. For example, you might write a program that interfaces with your company's inventory database to obtain the current price for components so that the price shown in a part list is always up-to-date. You might also write a program that extracts data from assemblies to provide MRP systems with their required information. All of this can be done manually, but by automating it using a program you're able to significantly increase productivity and minimize errors.

An API is also important for the reason that it allows third-party applications to integrate with Autodesk Inventor. It's through the API that products for PDM, NC, and FEM are able to interact with Autodesk Inventor.

Please Note: Developers are strongly cautioned against using any Inventor API object, method, property, event or constant that is marked as hidden, unsupported or for internal use only. These objects have been created or maintained for Autodesk's internal use, and there is no guarantee that they will continue to exist (or to function similarly) from release to release.

Next page | How Do I Access the API?
1, 2, 3, 4

Disclaimer


Introduction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Introduction

How Do I Access the API?

Autodesk Inventor's API is exposed using technology from Microsoft called "Automation." (This was previously referred to by Microsoft as "OLE Automation.") Automation interfaces are common among applications written for Windows. For example, Microsoft Word and Excel expose Automation interfaces to allow you to customize them. AutoCAD and Mechanical Desktop also expose Automation interfaces. (They refer to them as ActiveX interfaces.)

There are some significant advantages to providing an API through an Automation interface. First, it allows you to use almost any of the currently popular programming languages: Visual Basic, Visual C++, Delphi, Perl, Java, etc. Second, if designed correctly, it exposes the functionality using standard concepts. This means that if you already have experience programming a well-designed Automation interface like Word or Excel, you already understand many of the concepts that are used by the Autodesk Inventor API. Finally, it exposes the application's functionality in an object-oriented manner. Once the general concepts of how an object-oriented API works are understood, this type of API is easier to learn and use than function-oriented APIs.

Autodesk Inventor exposes its set of functionality through the API, but there are different ways to access the API. All of them are useful in certain cases, so it's important to have a basic understanding of the ways to connect to the API so you can make the best decision about how to write your program. The diagram below illustrates the different ways of accessing Autodesk Inventor's API. A brief overview of each of the methods follows. Detailed information about these is provided in sections devoted to each method: VBA, Add-Ins, and Apprentice Server.

First, a quick explanation of the figure below. The white boxes represent components that provide the API. These are Autodesk Inventor and "Apprentice Server." We'll talk about Apprentice more in a minute. The blue cylinder at the bottom represents the Autodesk Inventor data you're accessing, i.e. parts, assemblies, etc. All of the yellow boxes represent programs that you write. When one box encloses another box this indicates that the enclosed box is running in the same process as the box enclosing it. For example, VBA runs in the same process as Autodesk Inventor. An "in-process" program will run significantly faster than a program running out of process. There's a significant overhead caused by the need for out-of-process programs to communicate with each other.

Types of API implementations

VBA

VBA, or Visual Basic for Applications, is a programming environment that is accessed from within Autodesk Inventor. Programs written using VBA are frequently referred to as "macros." VBA is typically used by end-users to write small programs to automate repetitive tasks, although it is certainly not limited to this. A VBA program has the same access to all of the features of the API as any of the other methods of accessing the API (with the exception of Add-Ins, which we'll discuss later).

When deciding which method to use when programming Autodesk Inventor, there are a few advantages of using VBA to consider. First, VBA is delivered with Autodesk Inventor and does not require you to purchase an additional programming language. Second, you are able to embed programs within Autodesk Inventor documents. If you have a program that is data-specific, this is a convenient way to keep the program with the data it is designed to use. (You're not forced to save your programs in Autodesk Inventor documents. You can also save programs in separate files so they can be shared among users and documents.) Third, VBA runs in the same process as Autodesk Inventor so you gain the performance advantages of being in the same process.

Add-Ins

Add-Ins are a special type of Autodesk Inventor program. An Add-In is able to do two things that none of the other methods of accessing the API is able to do. First, Autodesk Inventor starts the Add-In automatically whenever Autodesk Inventor is run. Second, an Add-In is able to create commands. Other than these two features, it has the same access and uses the API in the same way as programs written using any of the other API access methods.

The fact that Add-Ins can be started automatically whenever Autodesk Inventor is run is an extremely important capability for many programs. Most applications that want to provide a seamless integration with Autodesk Inventor will be implemented as Add-Ins because that way their functionality will be available to the user whenever Autodesk Inventor is running.

A command is the functionality that allows you to create a new button on a menu, control the contents of that button, and be notified when the user clicks the button. The ability to create commands is also very important for an integrated application.

You'll notice in the diagram above that Add-In is listed twice: once as a DLL and once as an EXE. With an Add-In, you have the choice of creating a DLL, which will run in the same process as Autodesk Inventor, or an EXE, which will run in a separate process. Almost all Add-Ins will be written as DLLs for increased performance benefits. The ability to have Add-Ins that are EXEs is primarily beneficial for debugging.

Add-Ins can be written using any language that supports the creation of ActiveX EXEs or DLLs, such as Visual C++ and Visual Basic. Add-Ins cannot be created with VBA.

Standalone EXE

A standalone EXE is a program that runs on its own and connects to Autodesk Inventor. This type of program is typically used in the case where you have a program that uses Autodesk Inventor but has its own interface and doesn't require the user to interactively work with Autodesk Inventor. For example, a batch plot utility is typically a standalone EXE. The plot utility can be an EXE that runs independently of Autodesk Inventor and might monitor a database watching for new records to be added. The records describe documents that need to be plotted. When a new record is created in the database, the standalone EXE starts Autodesk Inventor, if it's not already running, opens the desired document and plots it, all without any user interaction.

Standalone EXEs run out-of-process to Autodesk Inventor, so there is some performance penalty, but since they are not usually used for interactive processes it's rarely an issue.

You also run in a standalone EXE mode when you write programs within another application's VBA. For example, if you write a program within Excel's VBA that connects to Autodesk Inventor, your VBA program is running in the process space of Excel.

Apprentice Server

Apprentice is an ActiveX server that can be used within other applications to provide access to Autodesk Inventor data. Apprentice is essentially a subset of Inventor that runs in process with other applications. Apprentice doesn't have a user interface. The only way to interact with Apprentice is through its API. Apprentice provides access to the assembly structure, B-Rep, geometry, and file properties. Most access to information through Apprentice is read-only; (a couple of exceptions to this are document properties and file references).

Apprentice is useful in any standalone application that needs access to information contained within Autodesk Inventor documents. The alternative is to use Autodesk Inventor. Using Apprentice is much more efficient than using Autodesk Inventor to perform the same operations because Apprentice is able to run in the same process as your application. Also, since it doesn't have a user interface it can perform many operations faster.

Apprentice Server is also available at no cost since it is delivered as part of Design Tracking, which is available on the public Autodesk website. More detailed information about Apprentice can be found in the Apprentice Server section.

Using .Net with Inventor's API

From Inventor 2009, a Primary Interop Assembly (PIA) is supplied. This provides the .Net compatible interface to Inventor's API. The .Net languages require a .Net compatible programming interface but Inventor's API is a COM Automation interface. An Interop assembly provides a .Net compatible interface to a COM Automation API. In all previous versions of Inventor you had to create your own interop assembly. Visual Studio does this automatically whenever you reference a COM type library. The fact that every .Net program had its own interop assembly resulted in additional memory being consumed, and because of the way .Net resolves these assemblies, unexpected behavior could have also resulted in some cases.

A primary interop is one created by Autodesk and delivered for all clients to use. The PIA is delivered into the Global Assembly Cache (GAC) where everyone has access to it. All clients that are writing code using any of the .Net languages should now use this primary interop assembly.

Although the PIA is delivered into the GAC when Inventor is installed, it is only usable by existing applications. .Net does not allow you to directly reference the PIA that is in the GAC but requires you to select a PIA outside of the GAC. This will still result in using the PIA in the GAC. The external version of Inventor's PIA is delivered as part of the new Developer Tools install in the SDK. Once you've installed the DeveloperTools.msi you'll see "Autodesk.Inventor.Interop" in the .Net tab of the "Add Reference" dialog within Visual Studio.

For Inventor 2009 the PIA is version 13.0.0.0. Going forward we will continue to deliver a PIA for each release. They are versioned with respect to the Inventor version. When you begin developing for future Inventor versions, you will need to update your reference to use the appropriate version PIA.

In most cases all that will be required in order to use the PIA is to change the reference and recompile. However, there are some differences between the PIA and the interop assembly automatically generated when referencing the Inventor type library. The difference provides for more correct type information in the PIA. The primary change is that instead of arrays being declared as generic System.Array types, they are now type specific, i.e. Double(). This change will require edits to your code, but they're easily corrected, and appropriate messages will appear at compile time.

Next page | Automation Programming Basics
1, 2, 3, 4

Disclaimer


VBA in Autodesk Inventor - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

VBA in Autodesk Inventor

Microsoft's Visual Basic for Applications (VBA) is integrated into Autodesk Inventor. VBA is a powerful development tool for customizing Autodesk Inventor and integrating Autodesk Inventor with other applications and data. If you're not familiar with VBA or any of the Visual Basic family of development tools a quick overview may be useful. Below are the different members of the Visual Basic family as defined by Microsoft.

Visual Basic

Visual Basic, and it's successor, VB.Net, is the world's most widely used rapid application development tool for creating standalone software components, including executable programs, ActiveX controls and COM components. Visual Basic was available in three editions: Learning edition, Professional edition, and Enterprise edition. The Professional and Enterprise editions are both suitable for programming Autodesk Inventor. Some functionality is excluded from the Learning edition that will preclude you from taking full advantage of the Autodesk Inventor API. Since the introduction of VB.Net, Visual Basic is only available through special arrangement or via MSDN (Microsoft Developer Network).

Visual Basic for Applications (VBA)

VBA takes the functionality available through the Visual Basic programming system and provides it through a development environment that is integrated into Autodesk Inventor. VBA is delivered with Autodesk Inventor so it is provided to you at no additional cost. VBA does not create standalone applications, but always runs from within Autodesk Inventor. VBA is the programming language used for Microsoft Office and hundreds more popular applications. If you've used VBA to write programs for other applications you already know the VBA language and programming environment in Autodesk Inventor and will need to learn only the Autodesk Inventor API. If you haven't used VBA in other applications, learning it within Autodesk Inventor gives you a head start on customizing other VBA-enabled applications.

Visual Basic Scripting Edition

VBA Script is designed to offer lightweight scripting capabilities for low-memory environments such as Web browsers and is most commonly used in creating HTML Web pages. VB Script is not very well suited for programming Autodesk Inventor.

Autodesk Inventor's VBA

VBA is provided by Microsoft and integrated into Autodesk Inventor. Although VBA is generic, it can be customized somewhat to meet the needs of the specific application it is integrated with. This section will discuss the things that are unique to the Autodesk Inventor integration of VBA. Information about the general functionality of VBA can be found in the VBA help provided by Microsoft.

VBA, like Visual Basic, allows you to create forms, class modules, and code modules. These modules are contained within projects. In Visual Basic, a project contains all of the source code that is used to create a single standalone component. Because VBA doesn't create standalone components, projects are used a bit differently. A VBA project is just a container for the various modules. Because of this, a single VBA project can contain a lot of unrelated functionality. Any number of functions can be written within a single project and executed independently.

Autodesk Inventor's VBA supports three types of projects: document, application, and user. The primary difference between these types of projects is the location in which the VBA project is stored. Document projects are stored within Autodesk Inventor documents. Application and user projects are stored in external files. Because Autodesk Inventor supports saving VBA projects within Autodesk Inventor documents or in external files, you can decide which approach is better for your particular situation. Below are some of the factors to consider when making this decision.

Document Projects (Saving in the Document)

  • Allows you to easily deliver any associated code with a document. For example, if you have a standard part that is used to create specific members of a family of parts, you can write a program that sets the parameters of the part to create the various family members. It can be convenient to embed this program in the Autodesk Inventor document so that the program will always be available along with the part document.

Application and User Projects (Saving in an external .ivb file)

  • Allows programs to be more easily shared between documents. Frequently programs are written to automate repetitive tasks. The usefulness of these programs is not isolated to a single document. With an application or user project, these programs become available to all documents.
  • Allows code to be easily shared with other users. One person can write a program, which might consist of several functions and forms, and send the project to anyone else, who can then load the project and access the functionality. No additional work is required. By contrast, if you want to share a document project with other users, you need to send them the Autodesk Inventor document that contains the embedded program and they must copy and paste the code into the desired Autodesk Inventor document. Or you can export each of the modules as .frm, .bas, and .cls files and send them. These can then be imported into the VBA environment of the Autodesk Inventor document where they're needed. As you can see, application and user projects provide a much simpler mechanism for code sharing and reuse.
  • Allows easier management of source code. All of the code is contained within a single file, which makes updates much easier. In the case of document projects, every document that needs the functionality has the program embedded within it. As the program is updated and bugs are fixed it can be very difficult to keep track of which documents contain the program and which version of the program they contain.

So far, all of the behavior we have discussed makes it appear that application and user projects are the same. This is largely true, but the key difference between them is how they get loaded into the VBA environment. Autodesk Inventor loads application projects automatically whenever the user starts Inventor. This makes macros within an application project always available. Only one project can be defined to be the application project. The project file that serves as the application project is defined using Autodesk Inventor's Application Options dialog, as shown below. The "Default VBA Project" field on the File tab defines which user project to use as the application project.

Application options dialog

User projects are not automatically loaded but must be loaded manually using the "Load Project?" command in the Autodesk Inventor VBA File menu (In Autodesk Inventor, choose the Tools tab, then VBA Editor, then File | Load Project...). New user projects can also be created using the "New Project" command in the VBA Files menu. There is no limit to the number of user projects that can be loaded.

Inventor's VBA interface is accessed within Inventor by clicking "VBA Editor". The two commands, "Macros?" and "VBA Editor", are also available using the Alt+F8 and Alt+F11 keyboard shortcuts.

Before going any further let's define our terms. A Sub procedure is a series of Visual Basic statements enclosed by the Sub and EndSub statements that performs actions but doesn't return a value. A Sub can take arguments that are passed by the calling procedure. Technically, a macro is a Sub that doesn't have any arguments. Any Subs without arguments will be considered macros. For example, the following code will be treated by VBA as a macro.

Public Sub SampleMacro()
    MsgBox "This is a sample."
End Sub

Choosing "Macros" in Autodesk Inventor displays the dialog shown below. This dialog displays a list of all of the macros currently available. This list can be filtered using the "Macros in" combo box. This allows you to list the macros contained in a particular project (document, user or application project), or to list all of the macros in all of the loaded projects.

Macro dialog box

When a macro is selected from the list, its name is displayed in the "Macro name" field at the top of the dialog and a description is displayed in the "Description" field at the bottom of the dialog. The description can be edited by modifying the text in the text box.

When a macro is selected from the list, all of the buttons on the right, except one, are enabled. The following describes the behavior of each of the buttons.

Run
The selected macro is executed without displaying the VBA programming environment.
Cancel
Dismisses the dialog.
Step Into
Opens the VBA programming environment and begins running the selected macro by stepping into the function. This is useful when debugging a macro.
Edit
Opens the VBA programming environment with the cursor positioned at the top line of the selected macro.
Create
If an existing macro is selected, this button is disabled. If a new name is entered into the "Macro name" field, this button becomes enabled and when clicked will cause a macro of the specified name to be created.
Delete
Deletes the selected macro. This will remove the sub from the project.

Choosing "VB Editor" in Autodesk Inventor opens the VBA programming environment. This is commonly known as the "Integrated Development Environment" or IDE. Within the VBA IDE is the "Project Explorer" which provides a browser-like view of the currently open projects, as shown below.

Open projects dialog

Several important concepts of Autodesk Inventor's VBA integration are illustrated in the Project Explorer. The first of these is the "Application" project. As discussed earlier, this is a project file that is stored in an external file and is loaded automatically whenever Autodesk Inventor is run. The name of the project file is shown in parentheses next to the project's name.

The second project in the list is a document project. The name of the document in which the project is embedded is shown in parentheses next to the project's name. Document projects are shown for the documents currently open in Autodesk Inventor. One difference between user and document projects that's apparent when looking at the Project Explorer is that the document project exposes the "ThisDocument" object. This represents the document that contains the macro. Writing code within the ThisDocument module give you direct access to the Inventor document. For example, the following code is valid within the ThisDocument module.

Public Sub DocDisplayName()
    Dim sDocDisplayName As String
    sDocDisplayName = DisplayName
End Sub

DisplayName is a property of the Document object. When writing code within the ThisDocument module, the methods and properties of the document are directly available. The document is also available within other modules of the project by using the ThisDocument global variable. For example, the code below can be used in other modules of a Document project.

Public Sub DocDisplayName ()
    Dim sDocDisplayName As String
    sDocDisplayName = ThisDocument.DisplayName
End Sub

The ThisDocument global variable is not available in application and user projects. In these projects, and in document projects, you can use the "ThisApplication" global variable. This provides direct access to the Inventor Application object. This sample can be used in both user and application projects to get the display name of the currently active document.

Public Sub DocDisplayName ()
    Dim sDocDisplayName As String
    sDocDisplayName = ThisApplication.ActiveDocument.DisplayName
End Sub

Next page | Back to the Overviews
Disclaimer


Addins - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Addins

Introduction

As discussed in the introductory section, an Add-In provides one of several ways to connect to the Autodesk Inventor API. An Add-In is the most powerful way to connect to Autodesk Inventor because it provides some capabilities that are not provided through any of the other connection methods: the Add-In automatically starts whenever Autodesk Inventor is started, and the Add-In has the ability to create commands. The fact that an Add-In provides some additional functionality also makes it slightly more complex to use than the other connection methods.

The first step in creating an Add-In is to create an ActiveX EXE or ActiveX DLL component. An ActiveX component acts as a server that provides services to a client. Typically we think of Autodesk Inventor behaving as the server and providing services to your program, which is acting as the client. This role is reversed using the initial startup of an Add-In. When Autodesk Inventor is started it finds the Autodesk Inventor Add-Ins using the registry and starts the Add-In. During this startup process it passes the Add-In some information, including a reference to the Autodesk Inventor Application object. The Add-In now has access to the entire Autodesk Inventor API and can now drive Autodesk Inventor. Once connected the Add-in behaves like a client and Autodesk Inventor as the server. However, Autodesk Inventor will continue to communicate Add-In-specific information with the Add-In.

Note for .Net users: The .Net runtime reserves 100 megabytes of address space for its managed heap. This takes 100 megabytes of address space away from Autodesk Inventor. In the 2 gigabyte address space this is only about 5%, but if you are running close to capacity, that could impact users of large assemblies. So Addin's implemented with .Net could have an impact on large assembly capacity in Autodesk Inventor.

Note for VB6 / MS Windows Vista users: It is possible to use VB6 to create an Add-In on Windows Vista, but user rights must be sufficient. If you experience problems creating a DLL, or see an error message about DLL registration or access to the system registry, you likely need to run VB6 with Administrator rights.

Note: The Add-in registration technique described in this overview is still supported and will continue to be supported as a legacy mechanism for several product releases. However, starting with Autodesk Inventor 2011, a simpler manifest-based registration mechanism is also supported, and developers are encouraged to adopt this new method. Please refer to the Add-in Registration overview for details.

Next page | Add-In Creation
1, 2, 3, 4, 5

Disclaimer


Symbol Reference

Autodesk Inventor 2012 COM API Reference
Send Feedback
Symbol Reference
Libraries
Name | Description
Inventor | This is namespace Inventor.
InventorStudioLib | This is namespace InventorStudioLib.
You are here: Symbol Reference
Copyright (c) Autodesk Inc. 2011. All rights reserved.


Inventor Library

Inventor Library
Summary

This is namespace Inventor.

Objects
Name | Description
AliasFreeformFeature | The feature that's created as a result of the user using the Alias Design for Inventor application to edit an Inventor model.
AliasFreeformFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the AliasFreeFormFeature object.
AliasFreeformFeatures | The AliasFreeFormFeatures collection object provides access to existing AliasFreeFormFeature objects.
AddInAutomation | IUnknown of its Automation interface that an AddIn may return. Enables other applications to get at it.
AnalysisManager | The AnalysisManager object provides access to all types of surface analysis in a part document.
AnalyticEdgeWorkAxisDef | Object that allows you to get and set the information that specifies a work axis using an analytic edge.
AngleConstraint | Object that represents an angle assembly constraint.
AngleConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the AngleConstraint object.
AngleExtent | The AngleExtent object provides access to the information that defines the extent for a feature using an angle.
AngleiMateDefinition | The AngleiMateDefinition object represents an angle iMate definition. It is derived from the iMateDefinition object.
AngleiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the AngleiMateDefinition object.
AngularGeneralDimension | The AngularGeneralDimension object represents an angular general dimension placed on a sheet.
Application | Autodesk Inventor Application object.
ApplicationAddIn | Object that represents an Application AddIn inside Autodesk Inventor.
ApplicationAddIns | Object that holds a collection of interfaces.
ApplicationAddInServer | Object required to be supported by Server to qualify as an Autodesk Inventor AddIn.
ApplicationAddInSite | The ApplicationAddInSite object is an object that is only available through the Activate method of the ApplicationAddInServer interface.
ApplicationEvents | The ApplicationEvents object provides application event notifications.
ApplicationEventsObject | The ApplicationEvents object provides application event notifications.
ApplicationEventsSink | The ApplicationEvents object provides application event notifications.
ApprenticeDrawingPrintManager | The ApprenticeDrawingPrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print job.
ApprenticePrintManager | The ApprenticePrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print job.
ApprenticeServer | Standalone mini component allowing limited access to an Inventor File. Refer to the Apprentice Server overview article.
ApprenticeServerComponent | Standalone mini component allowing limited access to an Inventor File. Refer to the Apprentice Server overview article.
ApprenticeServerDocument | The ApprenticeServerDocument object represents an in-memory Inventor document.
ApprenticeServerDocuments | Provides access to a list of objects.
ApprenticeServerDrawingDocument | The ApprenticeServerDrawingDocument object represents the drawing document within an Apprentice context, and provides access to the Sheets in the drawing.
Arc2d | The Arc2d object is a mathematical representation of a 2d arc.
Arc3d | The Arc3d object is a mathematical representation of a 3d arc.
AssemblyComponentDefinition | The AssemblyComponentDefinition object supports the RigidBodyAnalysis method which is the way to get the rigid body results of the assembly.
AssemblyComponentDefinitions | Provides access to the objects within the assembly document.
AssemblyConstraint | Object that represents the base class of an assembly constraint.
AssemblyConstraints | Provides access to the collection in the top level of the assembly.
AssemblyConstraintsEnumerator | Provides access to the constraints acting directly on a particular occurrence.
AssemblyDocument | The AssemblyDocument object represents an in-memory Inventor assembly document.
AssemblyEvents | The AssemblyEvents object provides notification of assembly events including change, delete and constraint.
AssemblyEventsObject | The AssemblyEvents object provides notification of assembly events including change, delete and constraint.
AssemblyEventsSink | The AssemblyEvents object provides notification of assembly events including change, delete and constraint.
AssemblyOptions | The AssemblyOptions object provides access to properties that provide read and write access of the assembly related application options. This is somewhat equivalent to the Assembly tab of the Application Options dialog.
AssemblyWorkAxisDef | The AssemblyWorkAxisDef object allows you to get and set the information that specifies a fixed work axis.
AssemblyWorkPlaneDef | The AssemblyWorkPlaneDef object allows you to access the information specific to work planes in an assembly.
AssemblyWorkPointDef | The AssemblyWorkPointDef object allows you to get and set the information that specifies a fixed work point.
Attribute | The Attribute object stores a name and value and belongs to a specific attribute set.
AttributeManager | Dynamic attributes provide the ability for a programmer to add any arbitrary data to any persistent object within Autodesk Inventor.
AttributesEnumerator | The AttributesEnumerator object provides access to a list of Attribute objects. See the article in the overviews section.
AttributeSet | The AttributeSet object provides the ability to create new attributes and access existing attributes. See the article in the overviews section.
AttributeSets | Provides access to the objects associated with a specific object and provides the ability to create additional sets on the object. See the article in the overviews section.
AttributeSetsEnumerator | The AttributeSetsEnumerator object provides access to a list of objects. See the article in the overviews section.
AutoCADBlock | The AutoCADBlock object represents an instance of an AutoCAD block definition on a sheet.
AutoCADBlockDefinition | The AutoCADBlockDefinition object represents an AutoCAD block definition.
AutoCADBlockDefinitions | The AutoCADBlockDefinitions collection object provides access to all the existing AutoCADBlockDefinition objects in a (DWG) drawing document and provides methods to import additional definitions.
AutoCADBlockDefinitionsEnumerator | The AutoCADBlockDefinitionsEnumerator object enumerates AutoCADBlockDefinition objects
AutoCADBlocks | The AutoCADBlocks collection object provides access to the instances of the blocks on a specific sheet. It also provides the ability to place blocks onto a sheet.
AutomatedCenterlineSettings | The AutomatedCenterlineSettings object provides access to all of the settings that are used when automatically generating centerlines and center marks.
Balloon | The Balloon object provides the ability to access existing balloons.
Balloons | The Balloons collection object provides access to all of the objects on a sheet. This collection is available via the Balloons property of the Sheet object.
BalloonStyle | The BalloonStyle object represents a balloon style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
BalloonStylesEnumerator | The BalloonStylesEnumerator object provides access to the existing BalloonStyle objects.
BalloonTipObject | This object provides access to a BalloonTip object.
BalloonTips | This object provides access to the BalloonTip objects. This collection only contains the user created balloon tip objects.
BalloonTipSink | This is class Inventor::BalloonTipSink.
BalloonValueSet | The BalloonValueSet object allows for setting and overriding of balloon content.
BalloonValueSets | The BalloonValueSets object represents a collection of objects. Note that this collection does not yet support an Add method. See the article in the overviews section.
BaselineDimensionSet | The BaselineDimensionSet object represents a baseline dimension set placed on a sheet.
BaselineDimensionSets | The BaselineDimensionSets collection object provides access to all of the baseline dimension sets on the sheet.
Bend | The Bend object represents a bend in a sheet metal part.
BendConstraint | The BendConstraint object represents a bend constraint within a 3D sketch.
BendConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BendConstraint object.
BendDefinition | The BendDefinition object represents all of the information that defines a bend.
BendFeature | The BendFeature object represents a sheet metal bend feature.
BendFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BendFeature object.
BendFeatures | The BendFeatures collection object provides access to all of the objects in a sheet metal component definition. It"s also through the BendFeatures object that you create new BendFeature objects.
BendNote | The BendNote object represents a bend note on a sheet and derives from the LeaderNote object.
BendNotes | The BendNotes collection object provides access to all of the bend notes on the sheet.
BendOptions | The BendOptions object defines the settings that influence the creation of a bend in a sheet metal part.
BendPartFeature | The BendPartFeature object represents an existing bend part feature in an Inventor part document.
BendPartFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BendPartFeature object.
BendPartFeatures | The BendPartFeatures collection object provides access to existing bend part features and supports the ability to create new bend part features.
BendsEnumerator | The BendsEnumerator object represents all of the bends in a sheet metal part.
BIMCableTrayConnectorDefinition | Object that represents the various settings that can be defined for a cable tray connector.
BIMComponent | Object that provides access to all of the BIM related information associated with an Inventor document.
BIMComponentDescription | Object that provides access to component description of the document.
BIMComponentProperty | Object that represents a single BIM property.
BIMComponentPropertySet | Collection object that provides access to all of the BIM properties associated with this BIM property set.
BIMComponentPropertySets | Collection object that provides access to all of the BIM property sets associated with this component.
BIMConduitConnectorDefinition | Object that represents the various settings that can be defined for a conduit connector.
BIMConnector | Base class object for all of the various BIM connector objects.
BIMConnectorDefinition | Base class object for all of the various BIM connector definition objects.
BIMConnectorLink | Object that represents a link between two BIM connectors.
BIMConnectorLinks | Collection object that provides access to all of the links between connectors and supports the ability to create new links.
BIMConnectors | Collection object that provides access to all of the BIM connectors within a document.
BIMDuctConnectorDefinition | Object that represents the various settings that can be defined for a duct connector.
BIMElectricalConnectorDefinition | Object that represents the various settings that can be defined for an electrical connector.
BIMExchangeServer | Object returned by the BIM Exchange add-in through the Automation property.
BIMPipeConnectorDefinition | Object that represents the various settings that can be defined for a pipe connector.
BOM | The BOM object represents the Bill Of Materials (BOM) data of a document.
BOMQuantity | This object provides methods and properties allowing the BOM row unit quantity to be computed.
BOMRow | The BOMRow object represents an item in the BOM based on the parent BOMView.
BOMRowsEnumerator | The BOMRowsEnumerator object provides access to BOMRow objects.
BOMView | The BOMView object represents a view (or an ordering scheme) of the BOM.
BOMViews | The BOMViews collection object provides access to the existing BOMView objects.
Border | The Border object represents the instance of a border on a sheet.
BorderDefinition | The BorderDefinition object represents a border definition.
BorderDefinitions | The BorderDefinitions collection object provides access to all the existing objects in a drawing document and provides methods to create additional border definitions.
BossFeature | The BossFeature object represents a boss feature within the model.
BossFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BossFeature object.
BossFeatures | The BossFeatures collection object provides access to existing boss features.
BossSet | The BossSet object contains the definition for a boss for the rib feature.
BossSets | The BossSets collection object contains all the boss definitions for the parent feature.
BoundaryPatchDefinition | The BoundaryPatchDefinition object is used to define the input required for creating boundary patch features.
BoundaryPatchFeature | This is the Part BoundaryPatchFeature object. A BoundaryPatchFeature is produced by the creation of a planar surface within the specified boundary.
BoundaryPatchFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BoundaryPatchFeature object.
BoundaryPatchFeatures | The BoundaryPatchFeatures collection object provides access to all of the objects in a part component definition and provides methods to create additional BoundaryPatchFeatures.
BoundaryPatchLoop | The BoundaryPatchLoop object is used to define a boundary loop for a boundary patch feature.
BoundaryPatchLoops | The BoundaryPatchLoops object is used to define the boundary loops for a boundary patch feature.
Box | The Box object is a mathematical utility object that represents a rectangular box whose faces are always parallel to the model XYZ planes. A common use of the Box object is as a means of passing the range box information of an entity and interacting with that range box.
Box2d | The Box2d object is a mathematical utility object that represents a rectangle whose edges are always parallel to the x-y axes. A common use of the Box2d object is as a means of passing the range box information of a 2d entity and interacting with that range box.
BreakOperation | A BreakOperation object represents a break applied to a drawing view. Editing or deleting this BreakOperation object will modify all affected views.
BreakOperations | The BreakOperations collection object contains information about all the break operations applied to a drawing view as well as methods to add breaks to the view.
BreakOutOperation | A BreakOutOperation object represents a break out applied to a drawing view. Editing or deleting this BreakOutOperation object will modify all affected views.
BreakOutOperations | The BreakOutOperations collection object contains information about all the break out operations applied to a drawing view as well as methods to add break outs to the view.
BrowserFolder | The BrowserFolder object represents a folder in the browser.
BrowserFoldersEnumerator | The BrowserFoldersEnumerator object provides access to all browser folders directly under a browser node.
BrowserNode | The BrowserNode object represents a node in the browser.
BrowserNodeDefinition | The BrowserNodeDefinition object contains the definition of a node in the browser.
BrowserNodeDefinitionSink | The BrowserNodeDefinition object contains the definition of a node in the browser.
BrowserNodesEnumerator | This object provides access to the individual objects in a collection of nodes; for example the nested children of a given .
BrowserPane | The BrowserPane object represents an independent window or panel inside the browser that is currently associated with the active document.
BrowserPaneObject | The object represents an independent window or panel inside the Browser that is currently associatedwith the active Document.
BrowserPanes | The BrowserPanes object provides access to the existing objects of the browser and allows you to create additional panes. See the article in the overviews section.
BrowserPanesEvents | Object providing event notification for browser events.
BrowserPanesEventsObject | Object providing event notification for browser events.
BrowserPaneSink | The BrowserPane object represents an independent window or panel inside the browser that is currently associated with the active document.
BrowserPanesSink | The BrowserPanes object provides access to the existing objects of the browser and allows you to create additional panes. See the article in the overviews section.
BSplineCurve | The BSplineCurve object is a mathematical utility object that represents a NURBS curve. It is a transient object that is never shown graphically or saved in the Inventor document
BSplineCurve2d | The BSplineCurve2d object. For more information, see the Transient Geometry overview.
BSplineCurve2dDefinition | The BSplineCurve2dDefinition object is a transient object. It is a convenient way to define a spline, perhaps to then create a BSplineCurve2D object. For more information, see the Transient Geometry overview.
BSplineCurveDefinition | The BSplineCurveDefinition object is a transient object. It is a convenient way to define a spline, perhaps to then create a BSplineCurve object. For more information, see the Transient Geometry overview.
BSplineSurface | The BSplineSurface object represent a surface curved according to BSpline poles, order, weights, and knots.
ButtonDefinition | The ButtonDefinition object represents any command whose user interface is a button.
ButtonDefinitionObject | The ButtonDefinition object represents any command whose user interface is a button.
ButtonDefinitionSink | The ButtonDefinition object represents any command whose user interface is a button.
Camera | The Camera defines the view of the model shown within the window.
CameraEventsObject | The CameraEvents object supports a set of properties and events used to work with a camera object.
CameraEventsSink | The CameraEvents object supports a set of properties and events used to work with a camera object.
Cell | The Cell object represents an individual cell in the table. A cell is the intersection between a column and a row. See the Custom Tables article in the overviews section for more information.
CenteredWidthExtent | The CenteredWidthExtent is used by sheet metal features when the width of the feature is defined using an explicit width and the width is centered along the selected edge.
Centerline | The Centerline object represents a centerline on a sheet.
Centerlines | The Centerlines collection object provides access to all the centerlines on a sheet.
Centermark | The Centermark object represents a center mark on a sheet.
Centermarks | The Centermarks collection object provides access to all the center marks on a sheet and provides functionality to create new center marks.
CentermarkStyle | The CentermarkStyle object represents a center mark style in a drawing.
CentermarkStylesEnumerator | The CentermarkStylesEnumerator object provides access to the existing CentermarkStyle objects.
CentroidWorkPointDef | Object that allows you to get and set the information that specifies a work point at the centroid of the input entities.
ChainDimensionSet | The ChainDimensionSet object represents a chain dimension set placed on a sheet.
ChainDimensionSets | The ChainDimensionSets collection object provides access to all of the chain dimension sets on the sheet.
ChamferDefinition | The ChamferDefinition object is the base class that defines the variables for chamfer features
ChamferFeature | The ChamferFeature object represents chamfered modeling features.
ChamferFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ChamferFeature object.
ChamferFeatures | The ChamferFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional ChamferFeature objects.
ChamferNote | The ChamferNote object represents a chamfer note with an attached leader on a sheet and derives from the LeaderNote object.
ChamferNotes | The ChamferNotes collection object provides access to all of the chamfer notes on the sheet.
ChangeDefinition | The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.
ChangeDefinitionObject | The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.
ChangeDefinitions | The ChangeDefinitions collection object provides access to all the objects created by a particular client and provides a method to create additional ChangeDefinitions. See the topic in the overview section.
ChangeDefinitionSink | The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.
ChangeManager | The ChangeManager object manages the processes involved in making changes to data and recording the change process.
ChangeProcessor | The ChangeProcessor object is at the heart of Inventor's transaction and transcripting mechanism, exposed via its public API.
ChangeProcessorObject | The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.
ChangeProcessorSink | The ChangeProcessor object is at the heart of Inventor's transaction and transcripting mechanism, exposed via its public API.
CheckPoint | The CheckPoint object serves as a bookmark within a transaction. See the article in the overviews section.
CheckPointsEnumerator | Provides access to a list of CheckPoint objects.
Circle | The mathematical Circle object, one of the transient geometry objects.
Circle2d | The mathematical Circle2d object - one of the transient objects.
CircularOccurrencePattern | The CircularOccurrencePattern object represents a circular pattern of assembly occurrences.
CircularOccurrencePatternProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CircularOccurrencePattern object.
CircularPatternFeature | The CircularPatternFeature object represents circular pattern feature objects.
CircularPatternFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CircularPatternFeature object.
CircularPatternFeatures | The CircularPatternFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional CircularPatternFeature objects.
ClientApplication | ClientApplication object. Reserved - for future use.
ClientBrowserNodeDefinition | The ClientBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a client-created node in the browser.
ClientBrowserNodeDefinitionObject | The ClientBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a client-created node in the browser.
ClientBrowserNodeDefinitionSink | The ClientBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a client-created node in the browser.
ClientFeature | The ClientFeature object represents a client feature in a part or an assembly document. A client feature is stored in Inventor's data model, and it's behaviors are provided jointly by Inventor and the client. It is an object that can composite other objects, and it can persist client graphics with a document.
ClientFeatureDefinition | The ClientFeatureDefinition object is used to define and query all the inputs of a ClientFeature.
ClientFeatureElement | Represents a composited Inventor object within a ClientFeature.
ClientFeatureElementProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ClientFeatureElement object.
ClientFeatureElements | Provides access to the composited elements within a ClientFeature and provides methods to add elements.
ClientFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ClientFeature object.
ClientFeatures | The ClientFeatures collection object provides access to client features and provides methods to create additional client features.
ClientGraphics | The ClientGraphics object is a collection of objects.
ClientGraphicsCollection | The ClientGraphicsCollection object provides access to all of the existing objects associated with a graphics container.
ClientNodeResource | This object is accessible through the BrowserPane. But it is in fact, just the one associated with the Document. In other words, all of the ClientNodeResource objects that are used inside the various BrowserPanes of this Document are to be found here.
ClientNodeResources | This object is accessible through the . But it is in fact, just the one associated with the Document. In other words, all of the ClientNodeResource objects that are used inside the various BrowserPanes of this Document are to be found here.
ClientView | The ClientView object represents a view of the document/drawing sheet attached to a user-specified window handle. See the article in the overviews section.
ClientViews | The ClientViews collection object represents the collection of objects for a document/drawing sheet, along with the ability to add new views to the collection. See the article in the overviews section.
CoilFeature | The CoilFeature object represents coil modeling features.
CoilFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoilFeature object.
CoilFeatures | The CoilFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional CoilFeature objects.
CoincidentConstraint | The CoincidentConstraint object represents a coincident constraint within a sketch.
CoincidentConstraint3D | The CoincidentConstraint3D object represents a coincident constraint within a 3D sketch.
CoincidentConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoincidentConstraint3D object.
CoincidentConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoincidentConstraint object.
CollinearConstraint | The CollinearConstraint object represents a collinear constraint within a sketch.
CollinearConstraint3D | The CollinearConstraint3D object represents a collinear constraint within a 3D sketch. The constraint can be applied between two 3D sketch lines, or between a 3D sketch line and a work axis.
CollinearConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CollinearConstraint3D object.
CollinearConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CollinearConstraint object.
Color | The Color object provides access to all of the components defining a color.
ColorScheme | The ColorScheme object represents a single color scheme. It provides access to the various components that make up a color scheme.
ColorSchemes | The ColorSchemes object provides access to all of the existing objects. This is somewhat equivalent to the Color tab of the Application Options dialog.
Column | The Column object represents a single column in this custom table.See the Custom Tables overview for more information.
Columns | The Columns collection object represents the collection of objects for this table.See the Custom Tables overview for more information.
CombineFeature | The CombineFeature object represents an existing combine feature in an Inventor part document.
CombineFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CombineFeature object.
CombineFeatures | The CombineFeatures collection object provides access to existing combine features and supports the ability to create new combine features.
ComboBoxDefinition | The ComboBoxDefinition object represents any command whose user interface is a combo box.
ComboBoxDefinitionObject | The ComboBoxDefinition object represents any command whose user interface is a combo box.
ComboBoxDefinitionSink | The ComboBoxDefinition object represents any command whose user interface is a combo box.
CommandBar | The CommandBar object represents an individual command bar. See the article in the overviews section.
CommandBarControl | The CommandBarControl object is the base class for all command bar control objects. See the article in the overviews section.
CommandBarControls | The CommandBarControls collection object provides access to all of the source objects in Autodesk Inventor, along with the ability to add new CommandBarControl objects. The command bars represent all of the menus and toolbars.
CommandBarList | The CommandBarList object defines a list of objects that are displayed to the users in various contexts.
CommandBars | The CommandBars collection object provides access to all of the objects in Autodesk Inventor.
CommandCategories | The CommandCategories collection object provides access to all existing objects and provides methods to create additional categories. See the article in the overviews section.
CommandCategory | The CommandCategory object represents the list of commands that are displayed in the Customize dialog. Command categories serve as a logical grouping of commands to allow the user to more easily find a specific command. See the article in the overviews section.
CommandControl | A CommandControl object represents a user interface control (button, combobox, split button, etc.).
CommandControls | The CommandControls collection object provides access to a collection of user interface controls and provides methods to create additional controls.
CommandControlsEnumerator | The CommandControlsEnumerator object provides access to a list of CommandControl objects.
CommandManager | The CommandManager object provides functionality that interacts with the various user interaction events. See here for an overview.
ComponentDefinition | The ComponentDefinition object is the base class for the PartComponentDefinition, AssemblyComponentDefinition and the FlatPattern objects.
ComponentDefinitions | Object that holds a collection of objects.
ComponentDefinitionsEnumerator | Provides access to a list of objects.
ComponentGraphics | The ComponentGraphics object defines a graphics object created using a ComponentDefinition.
ComponentOccurrence | This object represents an individual occurrence within an assembly. An occurrence can be either a part or subassembly. Information obtained from the occurrence is returned in the context of the component definition that served as the starting point to access the occurrence.
ComponentOccurrenceProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ComponentOccurrence object.
ComponentOccurrences | Provides access to the objects within an assembly and supports methods to create new occurrences.
ComponentOccurrencesEnumerator | Provides access to a list of objects.
CompositeiMateDefinition | The CompositeiMateDefinition object represents a composite iMate definition. It is derived from the iMateDefinition object.
CompositeiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CompositeiMateDefinition object.
ConcentricConstraint | The Sketch ConcentricConstraint object represents a concentric constraint within a sketch. Makes a circle, arc, ellipse, or elliptical arc concentric to another circle, arc, ellipse, or elliptical arc.
ConcentricConstraint3D | The Sketch ConcentricConstraint3D object represents a concentric constraint within a sketch3D.
ConcentricConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ConcentricConstraint3D object.
ConcentricConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ConcentricConstraint object.
ConcentricHolePlacementDefinition | The ConcentricHolePlacementDefinition object defines the placement of a hole feature with a circular edge or a cylindrical face.
Cone | The Cone object. The object is a transient mathematical object and is not displayed graphically.
ConstraintLimits | The ConstraintLimits object provides access to various limits related settings for assembly constraints and iMate definitions.
ContentCenter | The ContentCenter object provides the API interface to the Content Center functionality.
ContentCenterOptions | The ContentCenterOptions object provides access to properties that provide read and write access of the content center related application options.
ContentFamiliesEnumerator | Object allowing enumeration of ContentFamily objects.
ContentFamily | The ContentFamily object represents a content center family and provides access to the information associated with a family.
ContentTableCell | The ContentTableCell object represents a specific cell with a content center family table.
ContentTableColumn | The ContentTableColumn object represents the column of the table associated with a particular content center family.
ContentTableColumns | The ContentTableColumns object is a collection that provides access to the columns of the table associated with a particular content center family.
ContentTableRow | The ContentTableRow object represents the row of the table associated with a particular content center family.
ContentTableRows | The ContentTableRows object is a collection that provides access to the rows of the table associated with a particular content center family.
ContentTreeViewNode | The ContentTreeViewNode object represents nodes within the Content Center tree structure.
ContentTreeViewNodesEnumerator | The ContentFamiliesEnumerator is a collection object that provides access to a group of ContentFamily objects.
ContourFlangeDefinition | The ContourFlangeDefinition object represents all of the information that defines a contour flange feature.
ContourFlangeFeature | The ContourFlangeFeature object represents a sheet metal contour flange feature.
ContourFlangeFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ContourFlangeFeature object.
ContourFlangeFeatures | The ContourFlangeFeatures collection object provides access to the ContourFlangeFeature objects. It"s also through the ContourFlangeFeatures object that you create new ContourFlangeFeature objects.
ContourRollFeature | The ContourRollFeature object represents a contour roll sheet metal feature.
ContourRollFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ContourRollFeature object.
ContourRollFeatures | The ContourRollFeatures collection object provides access to the ContourRollFeature objects.
ControlDefinition | The ControlDefinition object is the base class for all other command definition types. This includes the following objects: ButtonDefinition, ComboBoxDefinition, and MacroControlDefinition.
ControlDefinitionEvents | The ControlDefinitionEvents object supports a set of properties and events used to work with command inputs.
ControlDefinitionEventsObject | The ControlDefinitionEvents object supports a set of properties and events used to work with command inputs.
ControlDefinitionEventsSink | The ControlDefinitionEvents object supports a set of properties and events used to work with command inputs.
ControlDefinitions | The ControlDefinitions collection object provides access to existing objects.
CoreCavityDefinition | The CoreCavityDefinition object represents all of the information that defines a core-cavity feature. The CoreCavityDefinition object is used in two ways. First it is used as input when creating a core-cavity feature. Second it is used to query and edit existing core-cavity features.
CoreCavityFeature | The CoreCavityFeature object represents a modeling feature for generating core/cavity surface bodies.
CoreCavityFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoreCavityFeature object.
CoreCavityFeatures | This CoreCavityFeatures collection provides access to existing CoreCavityFeature objects. It's also through the CoreCavityFeatures object that you create new CoreCavityFeature objects.
CornerChamferDefinition | The CornerChamferDefinition object is a utility object used for creating, querying, and editing sheet metal corner chamfer features.
CornerChamferFeature | The CornerChamferFeature object represents a sheet metal corner chamfer feature.
CornerChamferFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CornerChamferFeature object.
CornerChamferFeatures | The CornerChamferFeatures collection object provides access to all of the objects in a sheet metal component definition.
CornerDefinition | The CornerDefinition object represents all of the information that defines a corner feature.
CornerFeature | The CornerSeamFeature object represents a sheet metal corner seam feature.
CornerFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CornerFeature object.
CornerFeatures | The CornerFeatures collection object provides access to all of the objects in a sheet metal component definition.
CornerOptions | The CornerOptions object defines the settings that influence the creation of a corner in a sheet metal part.
CornerRoundDefinition | The CornerRoundDefinition object is a utility object used for creating, querying, and editing sheet metal corner round features.
CornerRoundEdgeSet | The CornerRoundEdgeSet object represents a set of edges and an associated fillet radius.
CornerRoundFeature | The CornerRoundFeature object represents a sheet metal corner round feature.
CornerRoundFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CornerRoundFeature object.
CornerRoundFeatures | The CornerRoundFeatures collection object provides access to all of the objects in a sheet metal component definition.
CosmeticBendFeature | The CosmeticBendFeature object represents a cosmetic bend within a flat pattern.
CosmeticBendFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CosmeticBendFeature object.
CosmeticBendFeatures | The CosmeticBendFeatures collection object provides access to the CosmeticBendFeature objects that have been created within a flat pattern.
CosmeticWeld | The CosmeticWeld object represents a cosmetic weld within an assembly. The CosmeticWeld object is derived from the Weld object.
CosmeticWelds | The CosmeticWelds object provides access to all the existing objects within a weldment.
Curve2dEvaluator | The Curve2dEvaluator object. See the article in the overviews section.
CurveAndEntityWorkPointDef | The CurveAndEntityWorkPointDefinition object that allows you to get and set the information that specifies a work point defined by a curve and another entity.
CurveEvaluator | The CurveEvaluator object. See the article in the overviews section.
CurveGraphics | The CurveGraphics object defines a graphics object created using a transient curve.
CustomConstraint | The CustomConstraint object represents a custom constraint for a sketch entity.
CustomConstraint3D | The CustomConstraint3D object represents a custom constraint for a 3D sketch entity.
CustomConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CustomConstraint3D object.
CustomConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CustomConstraint object.
CustomParameterGroup | The CustomParameterGroup object represents a grouping of certain parameters in the parameters dialog. These groups serve as a logical grouping of parameters to allow the user to more easily find a specific parameter.
CustomParameterGroups | The CustomParameterGroups collection object provides access to all existing custom parameter groups and provides methods to create additional groups
CustomPropertyFormat | The CustomPropertyFormat provides control over how the parameter value is formatted when it is exposed as a custom iProperty.
CustomTable | The CustomTable object allows the creation of user-defined tables with the specified number of rows and columns, headings, content, and so on. See the Custom Tables overview for more information.
CustomTables | The CustomTables object contains the collection of objects for a given Sheet. See the Custom Tables overview for more information.
CutAcrossBendsExtent | The CutAcrossBendsExtent object represents the extent definition for a sheet metal cut feature that cuts across the bends of the part.
CutDefinition | The CutDefinition object represents all of the information that defines a cut feature.
CutFeature | The CutFeature object represents a sheet metal cut feature.
CutFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CutFeature object.
CutFeatures | The CutFeatures collection object provides access to the CutFeature objects. It"s also through the CutFeatures object that you create new CutFeature objects.
Cylinder | The Cylinder object. The object created is a transient mathematical object and is not displayed graphically
DataIO | Generic object that handles input and output of formatted data. IDataObject-style functionality that's IDispatch-compatible and simplified.
DataMedium | The DataMedium object is used when exporting/importing to various formats using the TranslatorAddIn APIs. See the 'export' samples under TranslatorAddin for examples of its use.
DecalFeature | The DecalFeature object represents a decal feature on a part.
DecalFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DecalFeature object.
DecalFeatures | The DecalFeatures collection object provides access to all of the DecalFeature objects.
DefaultBorder | The DefaultBorder object represents an instance of the default border.
DeleteFaceFeature | The DeleteFaceFeature object represents a delete face feature on a part. A delete face feature is created interactively by using the Delete Face tool on the Feature toolbar--see Autodesk Inventor user interface help for further information about delete face features.
DeleteFaceFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DeleteFaceFeature object.
DeleteFaceFeatures | The DeleteFaceFeatures object represents a collection of objects on a part.
DerivedAliasComponent | The DerivedAliasComponent object represents a specific derived Alias instance.
DerivedAliasComponentProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DerivedAliasComponent object.
DerivedAliasComponents | The DerivedAliasComponents collection object provides access to all of the existing DerivedAliasComponent objects in a part and provides methods to create additional derived components.
DerivedAssemblyComponent | The DerivedAssemblyComponent object represents a specific derived assembly instance.
DerivedAssemblyComponentProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DerivedAssemblyComponent object.
DerivedAssemblyComponents | The DerivedAssemblyComponents collection object provides access to all of the existing objects in a part and provides methods to create additional derived assembly components.
DerivedAssemblyDefinition | The DerivedAssemblyDefinition object is used to describe which parts in an assembly will be used during the creation of the DerivedAssemblyComponent. It is also used when querying and editing an existing derived assembly.
DerivedAssemblyOccurrence | The DerivedAssemblyOccurrence object defines the behavior of an occurrence within a derived assembly.
DerivedAssemblyOccurrences | The DerivedAssemblyOccurrences collection object provides access to the objects associated with a specific DerivedAssemblyDefinition object. The DerivedAssemblyOccurrence objects contained within the collection represent the top-level occurrences within the assembly you obtained the collection from.
DerivedParameter | Object that represents a parameter that was created automatically by Inventor as the result of deriving a component or due to the creation of a DerivedParameterTable by linking to an Inventor document.
DerivedParameters | Provides access to the derived parameters associated with the DerivedParameterTable object the collection was obtained from.
DerivedParameterTable | The DerivedParameterTable object represents the connection to an Inventor document.
DerivedParameterTables | Creates and provides access to the parameters that reference parameters in another Inventor document.
DerivedPartComponent | The DerivedPartComponent object represents a specific derived part instance.
DerivedPartComponentProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DerivedPartComponent object.
DerivedPartComponents | The DerivedPartComponents collection object provides access to all of the existing objects in a part and provides methods to create additional derived components.
DerivedPartCoordinateSystemDef | The DerivedPartCoordinateSystemDef object allows you to query and define the coordinate system for a derived part, as well as to include and exclude elements and characteristics from the base part to the part to be derived.
DerivedPartDefinition | The DerivedPartDefinition object is used to describe which entities within a part will be used during the creation of the DerivedPartComponent. It is also used when querying and editing an existing derived part.
DerivedPartEntities | The DerivedPartEntities collection object provides access to all of the objects associated with a specific DerivedPartDefinition object.
DerivedPartEntity | The DerivedPartEntity object contains the information associated with an entity being derived.
DerivedPartTransformDef | The DerivedPartCoordinateSystemDef object allows you to define the transformation for a derived part, as well as to include and exclude elements from the base part to the part to be derived.
DerivedPartUniformScaleDef | The DerivedPartUniformScaleDef object allows you to query and define the uniform scale for a derived part, as well as to include and exclude elements and characteristics from the base part to the part to be derived.
DesignProject | The DesignProject object represents an Inventor project file (.ipj).
DesignProjectManager | The DesignProjectManager object provides access to project files related functionality in Inventor.
DesignProjects | The DesignProjects collection object provides access to all the existing projects and provides methods to create additional projects.
DesignViewRepresentation | The DesignViewRepresentation object represents a design view representation in parts and assemblies.
DesignViewRepresentations | The DesignViewRepresentations collection object provides access to all the design view representations in parts and assemblies and provides methods to create new ones.
DetailDrawingView | For information on this object, please refer to DrawingView, which provides identical or very similar functionality.
DiameterDimConstraint | The DiameterDimConstraint object represents a constraint that controls the diameter of a circle or arc.
DiameterDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DiameterDimConstraint object.
DiameterGeneralDimension | The DiameterGeneralDimension object represents a diameter dimension placed on a sheet.
DimensionConstraint | The DimensionConstraint object represents the base class of all dimension constraints.
DimensionConstraint3D | The DimensionConstraint3D object represents the base class of all 3D sketch dimension constraints.
DimensionConstraints | The DimensionConstraints object provides access to all the dimension sketch constraints ( objects) in a sketch and provides methods to create additional dimension sketch constraints.
DimensionConstraints3D | The DimensionConstraints3D object provides access to all the dimension sketch constraints in a 3D sketch and provides methods to create additional dimension sketch constraints.
DimensionStyle | The DimensionStyle object represents a dimension style in a drawing.
DimensionStylesEnumerator | The DimensionStylesEnumerator collection object provides access to the existing objects.
DimensionText | The DimensionText object represents text in a dimension placed on a sheet.
DirectionAndDistanceMoveDefinition | The DirectionAndDistanceMoveDefinition object defines all of the inputs that are unique to a move face feature defined using a direction vector and a distance.
DisabledCommandList | This object represents a list of commands that are disabled in the given context. For example, a DisabledCommandList collection in the document context lists all commands disabled at the document level, while a DisabledCommandList collection at the environment level list commands disabled in a given environment. This collection object compliments the Enabled property of the ControlDefinition object.
DisplayOptions | The DisplayOptions object provides access to properties that provide read and write access of the display related application options. This is somewhat equivalent to the Display tab of the Application Options dialog.
DisplaySettings | The DisplaySettings object provides access to properties that provide read and write access of the display appearance related document settings. This is somewhat equivalent to the Display Appearance tab of the Document Settings dialog.
DistanceAndAngleChamferDef | The DistanceAndAngleChamferDef object provides access to the information that defines the variables for a chamfer feature created using a distance and an angle.
DistanceChamferDef | The DistanceChamferDef object provides access to the information that defines the variables for a chamfer feature created using a distance.
DistanceExtent | The DistanceExtent object defines an extent given by a specified distance value.
DistanceHeightExtent | The DistanceHeightExtent is used by the FlangeFeature object when the height extent type is defined as a distance extent.
DockableWindow | A DockableWindow object represents a window that can be docked on to the Inventor application window by the user.
DockableWindows | The DockableWindows collection object provides access to all existing dockable windows and provides methods to create additional ones.
DockableWindowsEventsObject | The DockableWindowsEvents object contains events related to dockable windows.
DockableWindowsEventsSink | This is class Inventor::DockableWindowsEventsSink.
Document | The Document object represents an in-memory Inventor document.
DocumentDescriptor | The DocumentDescriptor object represents a native document reference.
DocumentDescriptorsEnumerator | The DocumentDescriptorsEnumerator object provides information about native document references held.
DocumentEvents | The DocumentEvents object provides notification of events that take place at the document level, such as activating, closing and saving particular documents.
DocumentEventsObject | The DocumentEvents object provides notification of events that take place at the document level, such as activating, closing and saving particular documents.
DocumentEventsSink | The DocumentEvents object provides notification of events that take place at the document level, such as activating, closing and saving particular documents.
DocumentInterest | Provides a means for an application to register an interest in a document. In order words, to flag the document as containing application-specific data, and to set the data version (for example, so Inventor can determine whether data migration is required and so fire the appropriate event).
DocumentInterests | Description of the collection object. Below are some common methods and properties.
Documents | The Document collection object contains all in-memory Inventor documents.
DocumentsEnumerator | Provides access to a list of objects.
DoubleHemDefinition | The DoubleHemDefinition defines all of the inputs that are unique to a double style of hem feature.
DraftAnalyses | The DraftAnalyses collection object provides access to existing draft analyses and supports the ability to create new draft analysis.
DraftAnalysis | The DraftAnalysis object represents an existing draft analysis feature in a part document.
DraftingStandard | The DraftingStandard object represent the currently applied drafting standard, and indicates whether the standard has been customized.
DragContext | The DragContext object provides methods that allow a user to move an object similar to the standard Inventor Assembly Drag.
DrawingBOM | The DrawingBOM object represents a locally stored BOM. This is the equivalent of the table displayed when the 'Attach Balloon From List' command in the context menu of a balloon is invoked.
DrawingBOMCell | The DrawingBOMCell object represents a cell within the drawing BOM.
DrawingBOMColumn | The DrawingBOMColumn object represents a column within the drawing BOM.
DrawingBOMColumns | The DrawingBOMColumns collection object represents the collection of all columns of a drawing BOM.
DrawingBOMRow | The DrawingBOMRow object represents a row within the drawing BOM.
DrawingBOMRows | The DrawingBOMRows collection object represents the collection of all rows of a drawing BOM.
DrawingBOMs | The DrawingBOMs collection object returns the collection of all locally stored BOMs in the drawing document.
DrawingCurve | The DrawingCurve object represents a curve within a drawing view that resulted from a model (including sketch entities).
DrawingCurveSegment | The DrawingCurveSegment object represents a single segment of a drawing curve.
DrawingCurveSegments | The DrawingCurveSegments object provides access to the segments of a drawing curve.
DrawingCurvesEnumerator | The DrawingCurvesEnumerator object provides access to drawing view curves.
DrawingDimension | The DrawingDimension object is the base class for all dimensions placed on a sheet.
DrawingDimensions | The DrawingDimensions object provides access to all of the dimensions ( objects) on the sheet.
DrawingDocument | The DrawingDocument object provides methods and properties to create, activate, save, and query many properties of individual drawing documents.
DrawingEvents | The DrawingEvents object provides drawing event notification, such as onRetrieveDimensions.
DrawingEventsObject | The DrawingEvents object provides drawing event notification, such as onRetrieveDimensions.
DrawingEventsSink | The DrawingEvents object provides drawing event notification, such as onRetrieveDimensions.
DrawingNote | The DrawingNote object is the base class for all the drawing notes on a sheet.
DrawingNotes | The DrawingNotes collection object provides access to all of the drawing notes on the sheet.
DrawingOptions | The DrawingOptions object provides access to properties that provide read and write access of the drawing related application options. This is somewhat equivalent to the Drawing tab of the Application Options dialog.
DrawingPrintManager | The DrawingPrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print.
DrawingSettings | The DrawingSettings object provides access to properties that provide read and write access of the various drawing document specific settings. This is somewhat equivalent to the Drawing tab of the Document Settings dialog.
DrawingSketch | The DrawingSketch object represents a sketch within a drawing.
DrawingSketches | The DrawingSketches collection object provides access to the objects associated with the object the collection was obtained from.
DrawingStandardStyle | The DrawingStandardStyle object represents a drawing standard.
DrawingStandardStylesEnumerator | The DrawingStandardStylesEnumerator object provides access to the existing objects.
DrawingStylesManager | The DrawingStylesManager object provides utilities to manage the various styles in a drawing document.
DrawingView | The DrawingView object represents a drawing view on a sheet. It allows access to information about drawing views. See the article in the overviews section.
DrawingViewEvents | Call-back or 'outgoing' sink interface through which Inventor fires the DrawingView Events. See the article in the overviews section.
DrawingViewEventsObject | Call-back or 'outgoing' sink interface through which Inventor fires the DrawingView Events. See the article in the overviews section.
DrawingViewEventsSink | Call-back or 'outgoing' sink interface through which Inventor fires the DrawingView Events. See the article in the overviews section.
DrawingViewLabel | The DrawingViewLabel object represents the text in a drawing view label.
DrawingViews | The DrawingViews collection object provides access to the objects associated with the sheet the collection was obtained from. It also provides method to create new drawing views.
DriveConstraintSettingsObject | The DriveConstraintSettings object provides access to various drive constraint related settings for assembly constraints.
DriveConstraintSettingsSink | This is class Inventor::DriveConstraintSettingsSink.
Edge | The Edge object. See the Boundary Representation article in the overviews section.
EdgeCollection | The EdgeCollection object provides access to all of the and EdgeCollection objects in a collection and provides methods to add Edge and EdgeCollection objects to the collection.
EdgeDefinition | The EdgeDefinition represents a transient definition of an Edge object.
EdgeDefinitions | The EdgeDefinitions collection provides access to existing EdgeDefinition objects and allows creation of new EdgeDefinition objects.
EdgeLoop | The EdgeLoop object. See the article in the overviews section.
EdgeLoopDefinition | The FaceDefinition represents a transient definition of a Face object.
EdgeLoopDefinitions | The EdgeLoopsDefinitions collection provides access to existing EdgeLoopDefinition objects and allows creation of new EdgeLoopDefinition objects.
EdgeLoopProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EdgeLoop object.
EdgeLoops | The EdgeLoops object is a collection of objects. See the article in the overviews section.
EdgeProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Edge object.
Edges | The Edges object is a collection of objects. See the article in the overviews section.
EdgeUse | The EdgeUse object. See the article in the overviews section.
EdgeUseDefinition | The FaceDefinition represents a transient definition of a Face object.
EdgeUseDefinitions | The EdgeUseDefinitions collection object provides access to existing EdgeUseDefinition objects, and allows creation of new EdgeUseDefinition objects.
EdgeUseProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EdgeUse object.
EdgeUses | The EdgeUses object is a collection of objects. See the article in the overviews section.
EdgeWidthExtent | The EdgeWidthExtent is used by sheet metal features when the width of the feature is defined by an edge.
EllipseFull | The EllipseFull object. The object created is a transient mathematical object and is not displayed graphically
EllipseFull2d | The EllipseFull2d object. The object is a transient mathematical object and is not displayed graphically.
EllipseRadiusDimConstraint | The EllipseRadiusDimConstraint object represents a constraint that controls either the major or minor radius of an ellipse.
EllipseRadiusDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EllipseRadiusDimConstraint object.
EllipticalArc | The EllipticalArc object. The object created is a transient mathematical object and is not displayed graphically
EllipticalArc2d | The EllipticalArc2d object. The object created is a transient mathematical object and is not displayed graphically.
EllipticalCone | The EllipticalCone object. The object created is a transient mathematical object and is not displayed graphically.
EllipticalCylinder | The EllipticalCylinder object. The object created is a transient mathematical object and is not displayed graphically.
EmbossFeature | The EmbossFeature object represents an emboss feature on a part.
EmbossFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EmbossFeature object.
EmbossFeatures | The EmbossFeatures object represents a collection of objects on a part.
EndOfFeatures | This object represents the End of Part marker in the browser. When traversing through the browser hierarchy, this is one of the nodes that is encountered, indicating the position of the marker in the browser.
EnumType | Enum Type Wrapper Object.
Environment | The Environment object represents any Autodesk Inventor environment. Example environments are Part, Assembly, Sketch, etc. The Environment represents the current state of an environment. See the UI customization and Environments overviews for more information.
EnvironmentList | The EnvironmentList object defines a list of environments that are displayed to the user in various contexts. For more information, refer to the Environments overview.
EnvironmentManager | This object provides methods and properties to get and set the base and override environments for this document. For more information, refer to the Environments overview.
Environments | The Environments collection object provides access to all of the existing objects, and allows creation of new ones. See the UI customization overview and the Environments overview for more information.
EqualLengthConstraint | The EqualLengthConstraint object represents a constraint that makes two lines equal in length.
EqualLengthConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EqualLengthConstraint object.
EqualRadiusConstraint | The EqualRadiusConstraint object represents a constraint that makes the radius of two circular entities equal.
EqualRadiusConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EqualRadiusConstraint object.
ErrorManager | The ErrorManager object contains methods and properties to get errors and warnings that occurred during an API call, add to Inventor's errors or to display them.
ExpressionLimits | The ExpressionLimits object provides access to the various range values that can be specified when defining a custom expression for a column.
ExpressionList | The ExpressionList provides access to a list of possible expressions that can be used for the associated parameter.
ExtendFeature | For information on this object, please refer to PartFeature, which provides identical or very similar functionality.
ExtendFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ExtendFeature object.
ExtendFeatures | For information on this object, please refer to PartFeatures, which provides identical or very similar functionality.
ExtrudeDefinition | The ExtrudeDefinition object represents all of the information that defines an Extrude feature.
ExtrudeFeature | The ExtrudeFeature object represents extruded modeling features.
ExtrudeFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ExtrudeFeature object.
ExtrudeFeatures | The ExtrudeFeatures collection object provides access to all of the ExtrudeFeature object in a part component definition and provides methods to create additional ExtrudeFeatures.
Face | The Face object. See the article in the overviews section.
FaceCollection | The FaceCollection object is a transient object created by the CreateFaceCollection method of the TransientObjects object. Typically used when creating a ShellFeature, FaceDraftFeature, etc.
FaceDefinition | The FaceDefinition represents a transient definition of a Face object.
FaceDefinitions | The FaceDefinitions collection provides access to exisitng FaceDefinition objects and allows creation of new FaceDefinition objects.
FaceDraftFeature | The FaceDraftFeature object represents a face draft on a part..
FaceDraftFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FaceDraftFeature object.
FaceDraftFeatures | The FaceDraftFeatures object represents a collection of face draft features ( objects) on a part.
FaceFeature | The FaceFeature object represents a sheet metal face feature.
FaceFeatureDefinition | The FaceFeatureDefinition object represents all of the information that defines a face feature.
FaceFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FaceFeature object.
FaceFeatures | The FaceFeatures collection object provides access to all of the objects in a sheet metal component definition.
FaceProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Face object.
Faces | The Faces object represents a collection of objects. See the article in the overviews section.
FaceShell | The FaceShell object. See the article in the overviews section.
FaceShellDefinition | The FaceShellDefinition represents a transient definition of a FaceShell object.
FaceShellDefinitions | The FaceShellDefinitions object represents a collection of FaceShellDefinition objects.
FaceShellProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FaceShell object.
FaceShells | The FaceShells object represents a collection of objects. See the article in the overviews section.
FactoryOptions |
FeatureBasedOccurrencePattern | The FeatureBasedOccurrencePattern object represents a feature-based occurrence pattern.
FeatureBasedOccurrencePatternProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FeatureBasedOccurrencePattern object.
FeatureControlFrame | The FeatureControlFrame object represents a feature control frame symbol on a sheet.
FeatureControlFrameRow | The FeatureControlFrameRow object represents a row within a feature control frame symbol.
FeatureControlFrameRows | The FeatureControlFrameRows object provides access to all rows of a feature control frame.
FeatureControlFrames | The FeatureControlFrames collection object provides access to all the feature control frame symbols on a sheet and provides methods to create additional ones.
FeatureControlFrameStyle | The FeatureControlFrameStyle object represents a feature control frame style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
FeatureControlFrameStylesEnumerator | The FeatureControlFrameStylesEnumerator object provides access to the existing FeatureControlFrameStyle objects.
FeatureDimension | A FeatureDimension object represents a dimension associated with a feature.
FeatureDimensionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FeatureDimension object.
FeatureDimensions | The FeatureDimensions collection object contains all the dimensions that are associated with a feature. These do not include the dimensions within sketches used by the feature.
FeaturePatternElement | Represents a single instance within a feature pattern.
FeaturePatternElementProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FeaturePatternElement object.
FeaturePatternElements | Provides access to the instances ( objects) that result from the creation of a feature pattern.
Features | Represents the collection of features in the assembly context. The API does not yet support addition of assembly features.
File | The File object represents an Inventor file on disk.
FileAccessEvents | The FileAccessEvents object supports a set of properties and events used to get access to files.
FileAccessEventsObject | The FileAccessEvents object supports a set of properties and events used to get access to files.
FileAccessEventsSink | The FileAccessEvents object supports a set of properties and events used to get access to files.
FileDescriptor | The FileDescriptor object represents a reference to an Autodesk Inventor file or a foreign file.
FileDescriptorsEnumerator | The FileDescriptorsEnumerator object provides information about file references held, both native and foreign.
FileDialog | The FileDialog object represents the Inventor dialogs that are displayed when the user invokes the Place Component or Save As command. In the API, the FileDialog object provides the ability to use these same dialogs when a filename is needed from the user. It is very similar in concept to the Microsoft common file control.
FileDialogEvents | The FileDialogEvents object hosts events related to the FileDialog.
FileDialogEventsObject | The FileDialogEvents object hosts events related to the FileDialog.
FileDialogEventsSink | The FileDialogEvents object hosts events related to the FileDialog.
FileLocations |
FileManager | The FileManager object provides access to file-related utility functions.
FileManagerEvents | The FileManagerEvents object provides access to file events, such as file deletion.
FileManagerEventsObject | The FileManagerEvents object provides access to file events, such as file deletion.
FileManagerEventsSink | The FileManagerEvents object provides access to file events, such as file deletion.
FileMetadata | A container object for defining the name and file properties for an Inventor file.
FileOpenOptions | The FileOpenOptions object provides access to options affecting the opening of files.
FileOptions | The FileOptions object provides access to properties that provide read and write access of the file related application options.
FileSaveAs | Custom interface to access management information about a particular file version.
FilesEnumerator | The FilesEnumerator object provides access to all Inventor files.
FileUIEvents | The FileUIEvents object supports a set of events that are fired when the user is creating, inserting, opening and saving files.
FileUIEventsObject | The FileUIEvents object supports a set of events that are fired when the user is creating, inserting, opening and saving files.
FileUIEventsSink | The FileUIEvents object supports a set of events that are fired when the user is creating, inserting, opening and saving files.
FilletConstantRadiusEdgeSet | The ConstantRadiusEdgeSet object provides access the edges and their associated radii for a constant radius fillet.
FilletConstantRadiusFaceSet | The ConstantRadiusFaceSet object provides access to the faces for a constant radius fillet.
FilletDefinition | The FilletDefinition object is used to define all of the input required for fillet features. It is also used to query and edit existing fillet features.
FilletFeature | The FilletFeature object represents the fillet modeling feature.
FilletFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FilletFeature object.
FilletFeatures | The FilletFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional FilletFeature objects.
FilletFullRoundSet | The FilletFullRoundSet object provides access to the inputs used to create a full round fillet feature.
FilletIntermediateRadius | The FilletIntermediateRadius object represents the information needed to define the radius at a point along an edge for a variable radius fillet.
FilletRadiusEdgeSet | The FilletRadiusEdgeSet object is the base class for FilletConstantRadiusEdgeSet and FilletVariableRadiusEdgeSet objects.
FilletSetback | The FilletSetback object provides access to an edge and its setback value.
FilletSetbackVertex | The FilletSetbackVertex object provides access to a vertex that is valid to define fillet setbacks for. It also provides access to the edges connected to the vertex and each edge's associated setback value.
FilletVariableRadiusEdgeSet | The FilletVariableRadiusEdgeSet object provides methods to specify the radius for variable radius fillet features.
FixedWorkAxisDef | Object that allows you to get and set the information that specifies a fixed work axis.
FixedWorkPlaneDef | Object that allows you to get and set the information that specifies a fixed work plane.
FixedWorkPointDef | Object that allows you to get and set the information that specifies a fixed work point.
FlangeDefinition | The FlangeDefinition object represents the information that defines a flange feature, not a flange feature.
FlangeFeature | The FlangeFeature object represents a sheet metal flange feature.
FlangeFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FlangeFeature object.
FlangeFeatures | The FlangeFeatures collection object provides access to all of the objects in a sheet metal component definition.
FlatBendResult | The FlatBendResult object represents a single bend instance in the flat. A bend instance can result from a feature placed either in the folded model or in the flat pattern. A bend feature may define multiple bends, and every one of the resulting bend instances is represented by a FlatBendResult object.
FlatBendResults | The FlatBendResults collection object contains information about all the resulting bends in the flat pattern.
FlatPattern | The FlatPattern object represents the unfolded model in a sheet metal document.
FlatPatternFeatures | The FlatPatternFeatures object represents a collection of FlatPatternFeature objects.
FlatPunchResult | The FlatPunchResult object represents a single punch instance in the flat. A punch instance can result from a punch tool feature placed either in the folded model or in the flat pattern. A punch tool feature may define multiple punches, and every one of the resulting punch instances is represented by a FlatPunchResult object.
FlatPunchResults | The FlatPunchResults collection object contains information about all the resulting punches in the flat pattern.
FlushConstraint | Object that represents a flush assembly constraint.
FlushConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FlushConstraint object.
FlushiMateDefinition | The FlushiMateDefinition object represents a flush iMate definition. It is derived from the iMateDefinition object.
FlushiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FlushiMateDefinition object.
FoldDefinition | The FoldDefinition object represents all of the information that defines a fold feature.
FoldFeature | The FoldFeature object represents a sheet metal fold feature.
FoldFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FoldFeature object.
FoldFeatures | The FoldFeatures collection object provides access to all of the objects in a sheet metal component definition.
FreeMoveDefinition | The FreeMoveDefinition object defines all of the inputs that are unique to a move face feature defined using a transform.
FromToExtent | The FromToExtent object provides access to the information that defines the extent for a feature using 'from' and 'to' faces to define the extent.
FromToWidthExtent | The FromToWidthExtent is used by sheet metal features when the width of the feature is defined from one entity to another entity.
FullSweepExtent | The FullSweepExtent object suggests that a full, 360-degree sweep about an axis, is the definition of the extents on this feature.
GeneralDimension | The GeneralDimension object represents a general dimension placed on a sheet.
GeneralDimensions | The GeneralDimensions collection object provides access to all of the general dimensions ( objects) on the sheet.
GeneralDimensionsEnumerator | The GeneralDimensionsEnumerator object provides access to the existing objects.
GeneralNote | The GeneralNote object represents a general note on a sheet and derives from the DrawingNote object.
GeneralNotes | GeneralNotes collection object provides access to all of the general notes on the sheet.
GeneralOptions | The GeneralOptions object provides access to properties that provide read and write access of the general application options. This is somewhat equivalent to the General tab of the Application Options dialog.
GeneralPreferences | The GeneralPreferences object provides the ability to store information about users' preferences, such as what template directory to use when creating new files, whether the Multi-User facility is on or off, etc.
GenericObject | Generic object. Weakly-typed (IDispatch).
GeometricConstraint | The GeomtricConstraint object represents the base class of all geometric constraints.
GeometricConstraint3D | The GeometricConstraint3D object represents the base class of all 3D geometric constraints.
GeometricConstraints | The GeometricConstraints object provides access to all the geometric sketch constraints ( objects) in a sketch and provides methods to create additional geometric sketch constraints.
GeometricConstraints3D | The GeometricConstraints3D object provides access to all the geometric sketch constraints ( objects) in a 3D sketch and provides methods to create additional geometric sketch constraints.
GeometryIntent | The GeometryIntent object represents a geometry intent for use in various annotation and view creations.
GraphicsColorMapper | The GraphicsColorMapper object maps scalar values to colors. Use methods provided on the object to define the scalar values and colors. The same object can be used to define the mapping for multiple graphics primitives using the ColorMapper property on the primitives.
GraphicsColorSet | The GraphicsColorSet object contains a list of colors. This object can be referenced by any number of graphic primitives to use in defining triangle or vertex specific colors to use when rendering.
GraphicsCoordinateSet | The GraphicsCoordinateSet object contains a list of coordinate values. This object can be referenced by any number of graphic primitives to use in defining their coordinates.
GraphicsDataSet | The GraphicsDataSet object is the base class for the various utility objects used for creating custom graphics.
GraphicsDataSets | The GrahicsDataSets object supports methods to create the various graphics-related data objects.
GraphicsDataSetsCollection | The ClientGraphicsCollection object allows you to create new objects and supports access to existing GraphicsDataSets objects. See the article in the overview section for more information.
GraphicsImageSet | The GraphicsImageSet defines images that can be used when displaying client graphics objects that support images. Currently this is limited to the GraphicsPoint object.
GraphicsIndexSet | The GraphicsIndexSet object contains a list of indices. This object can be referenced by any number of graphic primitives to use in defining the list of indices that index into a coordinate set.
GraphicsNode | The GraphicsNode object provides a logical grouping of Client graphics. It is the lowest level of detail the user will see when selecting objects.
GraphicsNodeProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GraphicsNode object.
GraphicsNormalSet | The GraphicsNormalSet object contains a list of normals. This object can be referenced by any number of graphic primitives to help define the normals to be used when rendering.
GraphicsPreferences | The GraphicsPreferences object represents preference options for the graphical environment.
GraphicsPrimitive | The GraphicsPrimitive object is the base class for all the various primitive types of client graphics.
GraphicsTextureCoordinateSet | The GraphicsTextureCoordinateSet object contains a list of coordinate values
GrillFeature | The GrillFeature object represents a grill feature within the model.
GrillFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GrillFeature object.
GrillFeatures | The GrillFeatures collection object provides access to existing grill features.
GripSnapOptions | The GripSnapOptions object provides access to various grip snap related application level options. This object is obtained from the GeneralOptions.GripSnapOptions property.
GroundConstraint | The GroundConstraint object represents a constraint that grounds an entity.
GroundConstraint3D | The GroundConstraint3D object represents a constraint that grounds an entity.
GroundConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GroundConstraint3D object.
GroundConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GroundConstraint object.
GroundPlaneSettings |
HardwareOptions | The HardwareOptions object provides access to properties that provide read and write access of the hardware related application options. This is somewhat equivalent to the Hardware tab of the Application Options dialog.
HeadsUpDisplayOptions |
HelicalConstraint3D | This object represents a helix-based constraint.
HelicalConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HelicalConstraint3D object.
HelpEventsObject | This object provides access to Help related events.
HelpEventsSink | This is class Inventor::HelpEventsSink.
HelpManager | The HelpManager object encapsulates all of the help functionality.
HemDefinition | The HemDefinition object represents all of the information that defines a hem feature.
HemFeature | The HemFeature object represents a sheet metal hem feature.
HemFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HemFeature object.
HemFeatures | The HemFeatures collection object provides access to all of the objects in a sheet metal component definition.
HighlightSet | The HighlightSet object defines a set of objects and an associated color to display them with.
HighlightSets |
HoleFeature | The HoleFeature object represents hole modeling features.
HoleFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HoleFeature object.
HoleFeatures | The HoleFeatures object provides access to all of the objects in a component definition and provides methods to create additional HoleFeature objects.
HolePlacementDefinition | The HolePlacementDefinition object is the base class that defines the placement method for hole features.
HoleTable | A hole table contains information for some or all holes in a drawing view. A hole tag is associated with each hole and a corresponding row in the table. If an existing hole is changed, the hole table is updated when the drawing updates.
HoleTableCell | The HoleTableCell object represents an individual cell in the hole table.
HoleTableColumn | The HoleTableColumn object defines a column within the hole table, including the column width.
HoleTableColumns | The HoleTableColumns collection object provides access to the existing collection of HoleTableColumn objects.
HoleTableRow | The HoleTableRow object defines a row within the hole table, including the row height.
HoleTableRows | The HoleTableRows collection object provides access to the existing collection of HoleTableRow objects.
HoleTables | The HoleTables collection object represents all the hole tables on a sheet.
HoleTableStyle | The HoleTableStyle object represents a hole table style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
HoleTableStylesEnumerator | The HoleTableStylesEnumerator object provides access to the existing HoleTableStyle objects.
HoleTag | The HoleTag object represents a hole tag associated with a hole table row.
HoleTapInfo | This object is really a StandardThreadInfo object with the addition of the property specifying which of the various diameter dimensions to use to model the cylindrical surface of the hole.
HoleThreadNote | The HoleThreadNote object represents either a hole note or a thread note on a sheet and derives from the DiameterGeneralDimension object.
HoleThreadNotes | The HoleThreadNotes collection object provides access to all of the hole and thread notes on the sheet.
HorizontalAlignConstraint | The HorizontalAlignConstraint object represents a constraint that makes two sketch points align horizontally.
HorizontalAlignConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HorizontalAlignConstraint object.
HorizontalConstraint | The HorizontalConstraint object represents a horizontal constraint within a sketch.
HorizontalConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HorizontalConstraint object.
iAssemblyFactory | The iAssemblyFactory object provides access to the iAssembly table and provides methods to create iAssembly members.
iAssemblyMember | The iAssemblyMember object provides access to a member of an iAssembly.
iAssemblyTableCell | The iAssemblyTableCell object represents an individual cell in the iAssembly factory table.
iAssemblyTableColumn | The iAssemblyTableColumn object represents a column in the iAssembly factory table.
iAssemblyTableColumns | The iAssemblyTableColumns collection object provides access to all existing iAssemblyTableColumn objects in the iAssembly factory table.
iAssemblyTableRow | The iAssemblyTableRow object represents a row in the iAssembly factory table.
iAssemblyTableRows | The iAssemblyTableRows collection object provides access to all existing iAssemblyTableRow objects in the iAssembly factory table.
iFeature | The iFeature object represents the instance of a placed iFeature.
iFeatureDefinition | The iFeatureDefinition object represents the positional and parameter information of an iFeature.
iFeatureEntityInput | The iFeatureEntityInput object represents the positional information of an iFeature. The iFeatureEntityInput object is used both to describe and specify the geometry necessary for the placement of an iFeature.
iFeatureInput | The iFeatureInput object is the base class for iFeatureParameterInput, iFeatureEntityInput, iFeatureSketchPlaneInput, iFeatureWorkPlaneInput and iFeatureVectorInput.
iFeatureInputs | The iFeatureInputs collection object provides access to all of the / iFeatureParameterInput objects associated with a specific iFeatureDefinition object.
iFeatureOptions | The iFeatureOptions object provides access to properties that provide read and write access of the iFeature related application options. This is somewhat equivalent to the iFeature tab of the Application Options dialog.
iFeatureParameterInput | The iFeatureParameterInput object contains the information associated with a parameter of an iFeature.
iFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the iFeature object.
iFeatures | The iFeatures collection object provides access to all of the iFeature objects in a part component definition and provides methods to create additional iFeatures..
iFeatureSketchPlaneInput | The iFeatureSketchPlaneInput object represents the sketch plane input information of an iFeature. The iFeatureSketchPlaneInput object is used specify the geometry's and other data necessary for the sketch plane input of an iFeature.
iFeatureTable | The iFeatureTable object represents the table associated with a table driven iFeature. This object provides access to the contents of the table and provides information about the default and active rows.
iFeatureTableCell | The iFeatureTableCell object represents a single cell within a table associated with a table driven iFeature.
iFeatureTableColumn | The iFeatureTableColumn object represents a single column of a table associated with a table driven iFeature.
iFeatureTableColumns | The iFeatureTableColumns collection object provides access to the columns of an iFeature table.
iFeatureTableRow | The iFeatureTableRow object represents a single row of a table associated with a table driven iFeature.
iFeatureTableRows | The iFeatureTableRows collection object provides access to the rows of an iFeature table.
iFeatureTemplateDescriptor | The iFeatureTemplateDescriptor object describes the iFeature file that was used to create the iFeature.
iFeatureTemplateDescriptors | The iFeatureTemplateDescriptors collection object provides access to all of the objects in a document.
iFeatureVectorInput | The iFeatureVectorInput object represents the vector input information of an iFeature.
iFeatureWorkPlaneInput | The iFeatureWorkPlaneInput object represents the work plane input information of an iFeature.
iMateDefinition | The iMateDefinition object is the base class for all iMate definition objects.
iMateDefinitions | The iMateDefinitions collection provides access to all of the objects in a part or assembly.
iMateDefinitionsEnumerator | Object that represents an iMateDefinitionsEnumerator. Presents a snapshot of the set of objects.
iMateResult | The iMateResult object represents the result of using an iMate in an assembly.
iMateResultProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the iMateResult object.
iMateResults | The iMateResults collection provides access to all of the objects in an assembly. It also supports the methods that allow the creation of iMateResult objects.
iMateResultsEnumerator | Object that represents an iMateResultsEnumerator. Presents a snapshot of the set of objects.
InsertConstraint | Object that represents an insert assembly constraint.
InsertConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the InsertConstraint object.
InsertiMateDefinition | The InsertiMateDefinition object represents an insert iMate definition. It is derived from the iMateDefinition object.
InsertiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the InsertiMateDefinition object.
InteractionEvents | The InteractionEvents object provides the ability to obtain input from the user. This includes selecting objects, various mouse inputs, and using the keyboard.
InteractionEventsObject | The InteractionEvents object provides the ability to obtain input from the user. This includes selecting objects, various mouse inputs, and using the keyboard.
InteractionEventsSink | The InteractionEvents object provides the ability to obtain input from the user. This includes selecting objects, various mouse inputs, and using the keyboard.
InteractionGraphics | Inventor supports the creation of preview and overlay graphics.
InterferenceResult | In an assembly, two or more components cannot occupy the same space at the same time. To detect such errors, you can analyze assemblies for interference.
InterferenceResults | In an assembly, two or more components cannot occupy the same space at the same time. To detect such errors, you can analyze assemblies for interference.
InventorServer | The top-level object in the server environment, equivalent to the Application object in previous versions of Inventor.
InventorVBAArgument | Represents a VBAArgument object.
InventorVBAArguments | Represents a collection of objects in an InventorVBAMember.
InventorVBAComponent | The InventorVBAComponent object represents a code, class or form module.
InventorVBAComponents | The InventorVBAComponents collection object represents a collection of objects in an InventorVBAProject, and provides methods to create new InventorVBAComponent objects.
InventorVBAMember | Represents a member within a InventorVBAComponent.
InventorVBAMembers | Represents a collection of objects in an InventorVBAComponent object.
InventorVBAProject | Represents Autodesk Inventor's VBA project.
InventorVBAProjects | A collection of Autodesk Inventor's VBA projects ( objects).
iPartFactory | The iPartFactory object provides access to the iPart table and provides methods to create additional iPart members ( objects).
iPartMember | The iPartMember object provides access to the iPart.
iPartTableCell | The iPartTableCell object represents an individual cell in the iPart factory table.
iPartTableColumn | The iPartTableColumn object represents a column in the iPart factory table.
iPartTableColumns | The iPartTableColumns collection object provides access to all existing objects in the iPart factory table.
iPartTableRow | The iPartTableRow object represents a row in the iPart factory table.
iPartTableRows | TheiPartTableRows collection object provides access to all existing objects in the iPart factory table.
KeyboardEvents | The KeyboardEvents object supports a set of events that can be received by the client when a key on the keyboard is pressed while the InteractionEvents object has been started AND the InteractionDisabled flag is set to False.
KeyboardEventsObject | The KeyboardEvents object supports a set of events that can be received by the client when a key on the keyboard is pressed while the InteractionEvents object has been started AND the InteractionDisabled flag is set to False.
KeyboardEventsSink | The KeyboardEvents object supports a set of events that can be received by the client when a key on the keyboard is pressed while the InteractionEvents object has been started AND the InteractionDisabled flag is set to False.
KnitFeature | The KnitFeature object represents a knit feature on a part. Knit features connect edge-matched surfaces together to create a quilt.
KnitFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the KnitFeature object.
KnitFeatures | The KnitFeatures object represents a collection of knit features ( objects) on a part. Knit features connect edge-matched surfaces together to create a quilt.
LanguageTools | The LanguageTools object provides a means of determining the logical boolean value of iPart/iComponent table strings.
Layer | The Layer object represents a layer in a drawing document.
LayersEnumerator | The LayersEnumerator object provides access to the existing Layer objects.
LayoutConstraint | The LayoutConstraint object represents a layout constraint within an assembly.
LayoutConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LayoutConstraint object.
Leader | The Leader object represents a leader associated with a drawing annotation.
LeaderNode | The LeaderNode object represents a node in a leader.
LeaderNodesEnumerator | The LeaderNodesEnumerator object provides an enumeration of LeaderNode objects.
LeaderNote | The LeaderNote object represents a note with an attached leader on a sheet and derives from the DrawingNote object. The properties and methods listed below are in addition to those supported by the DrawingNote object.
LeaderNotes | The LeaderNotes collection object provides access to all of the leader notes on the sheet.
LeaderStyle | The LeaderStyle object represents a leader style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
LeaderStylesEnumerator | The LeaderStylesEnumerator object provides access to the existing LeaderStyle objects.
LegacyDistanceHeightExtent | The LegacyDistanceHeightExtent is used by the FlangeFeature object when the 'Old Method' is specified in the Flange feature dialog.
LevelOfDetailRepresentation | The LevelOfDetailRepresentation object represents a positional representation in the assembly.
LevelOfDetailRepresentations | The LevelOfDetailRepresentations collection object provides access to all the LOD (Level Of Detail) representations in the assembly and provides methods to create new ones.
Light | The Light object provides access to all of the properties that define a specific light source.
LightingStyle | The LightingStyle object provides access to all of the properties that define a specific lighting style.
LightingStyles | The LightingStyles collection object allows for the creation of new LightingStyle objects and provides access to existing LightingStyle objects.
Lights | The Lights collection object allows for the creation of new Light objects and provides access to existing model space and view space lights.
Line | The Line object. The object created is a transient mathematical object and is not displayed graphically. For more information, see the Transient Geometry article in the overview section.
Line2d | The Line2d object. A Line2d object is infinite. The object created is a transient mathematical object and is not displayed graphically.
LineAndPlaneWorkAxisDef | Object that allows you to get and set the information that specifies a work axis that is along a line defined by projecting a line onto a plane along the plane normal.
LineAndPointWorkAxisDef | Object that allows you to get and set the information that specifies a work axis that is along a line and passes through a point.
LineAndTangentWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane that passes through a line and is tangent to a surface.
LinearGeneralDimension | The LinearGeneralDimension object represents a linear general dimension placed on a sheet.
LinearHolePlacementDefinition | The LinearHolePlacementDefinition object defines the placement of a hole feature with respect to two linear entities.
LineGraphics | The LineGraphics object defines one or more disconnected lines.
LineLengthDimConstraint3D | The LineLengthDimConstraint3D object represents a constraint that controls the length of a 3D sketch line.
LineLengthDimConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LineLengthDimConstraint3D object.
LinePlaneAndAngleWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane that passes through a line and is a specified angle to a plane.
LineSegment | The LineSegment object represents a line segment. The object created is a transient mathematical object and is not displayed graphically.
LineSegment2d | The LineSegment2d object. The object is a transient mathematical object and is not displayed graphically.
LineStripGraphics | The LineStripGraphics Object. The LineStripGraphics object defines a set of connected lines.
LineWorkAxisDef | Object that allows you to get and set the information that specifies a work axis along a line.
LipFeature | The LipFeature object represents a lip feature within the model.
LipFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LipFeature object.
LipFeatures | The LipFeatures collection object provides access to existing Lip features.
LoftDefinition | The LoftDefinition object is used to define additional input required for creating loft features.
LoftedFlangeDefinition | The LoftedFlangeDefinition object represents all of the information that defines a lofted flange feature. The LoftedFlangeDefinition object is used in two ways. First it is used as input when creating a lofted flange feature. Second it is used to query and edit existing lofted flange features.
LoftedFlangeFeature | The LoftedFlangeFeature object represents a lofted flange sheet metal feature.
LoftedFlangeFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LoftedFlangeFeature object.
LoftedFlangeFeatures | The LoftedFlangeFeatures collection object provides access to the LoftedFlangeFeature objects.
LoftFeature | The LoftFeature object represents an existing loft in an Autodesk Inventor part document. The LoftFeature is derived from the PartFeature object and inherits all of its methods and properties.
LoftFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LoftFeature object.
LoftFeatures | The LoftFeatures collection object provides access to existing loft features and supports the ability to create new loft features.
LoftRail | The LoftRail object is used to define a rail in a loft feature.
LoftRails | The LoftRails object is used to define the rails and their conditions in a loft feature.
LoftSectionDimension | The LoftSectionDimension object is used to define the position and area for a placed section of an area-graph type loft.
LoftSectionDimensions | The LoftSectionDimensions object is used to define the placed section dimensions for an area-graph type loft.
LumpDefinition | The LumpDefinition represents a transient definition of a lump. A lump represents a bounded area of space. It can consist of one or more FaceShell objects.
LumpDefinitions |
Machining | Allows editing for environment-specific features.
MacroControlDefinition | The MacroControlDefinition object represents a command that causes a macro to run.
MapPointCurve | The MapPointCurve object is used to define a set of mapping points between sections in a loft feature.
MapPointCurves | The MapPointCurves object represents a collection of objects, used to define mapping points between sections in a loft feature.
MassProperties | The MassProperties object provides access to properties that provide read and write access to various mass property information.
MateConstraint | Object that represents a mate assembly constraint.
MateConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MateConstraint object.
MateiMateDefinition | The MateiMateDefinition object represents a mate iMate definition. It is derived from the iMateDefinition object.
MateiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MateiMateDefinition object.
Material | The Material object provides access to all of the properties that define a specific material.
Materials | The Materials collection object allows for the creation of new objects and provides access to existing Material objects.
MaterialsEnumerator | Enumerates through the available Materials.
Matrix | A 4x4 Matrix object. For more information, see the Transient Geometry article in the overviews section.
Matrix2d | A 3x3 Matrix2d object. For more information, see the Transient Geometry article on the overviews section.
MeasureEvents | The MeasureEvents object provides the ability to invoke the measure and show dimension commands during InteractionEvents.
MeasureEventsObject | The MeasureEvents object provides the ability to invoke the measure and show dimension commands during InteractionEvents.
MeasureEventsSink | The MeasureEvents object provides the ability to invoke the measure and show dimension commands during InteractionEvents.
MeasureTools | The MeasureTools object provides methods for various measurement related utilities.
MessageSection | A MessageSection object can be used to clear, adopt or retain error/warning messages created during the section.
MidpointConstraint | The MidpointConstraint object represents a constraint that connects a sketch point to the midpoint of a sketch line.
MidpointConstraint3D | The MidpointConstraint3D object represents a constraint that connects a sketch point to the midpoint of a sketch line.
MidpointConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MidpointConstraint3D object.
MidpointConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MidpointConstraint object.
MidPointWorkPointDef | Object that allows you to get and set the information that specifies a work point defined to be at the midpoint of an edge.
MiniToolbarButtonObject | The MiniToolbarButton object represents a button control within a MiniToolbar.
MiniToolbarButtonSink | This is class Inventor::MiniToolbarButtonSink.
MiniToolbarCheckBoxObject | The MiniToolbarCheckBox object represents a check box control within a MiniToolbar.
MiniToolbarCheckBoxSink | This is class Inventor::MiniToolbarCheckBoxSink.
MiniToolbarComboBoxObject | The MiniToolbarComboBox object represents a combobox control within a MiniToolbar.
MiniToolbarComboBoxSink | This is class Inventor::MiniToolbarComboBoxSink.
MiniToolbarControl | The MiniToolbarControl object is the base class for all controls within a MiniToolbar.
MiniToolbarControls | The MiniToolbarControls object contains the controls within a minitoolbar and methods to create new controls.
MiniToolbarDropdownObject | The MiniToolbarDropdown object represents a dropdown control within a MiniToolbar.
MiniToolbarDropdownSink | This is class Inventor::MiniToolbarDropdownSink.
MiniToolbarListItem | The MiniToolbarListItem object represents an item in either a MiniToolBarComboBox or a MiniToolBarDropdown object.
MiniToolbarObject | The MiniToolbar object provides the ability to create and display in-canvas controls for user interaction.
MiniToolbarSink | This is class Inventor::MiniToolbarSink.
MiniToolbarValueEditorObject | The MiniToolbarValueEditor object represents a value edit control within a MiniToolbar.
MiniToolbarValueEditorSink | This is class Inventor::MiniToolbarValueEditorSink.
MirrorFeature | The MirrorFeature object represents mirror pattern feature objects.
MirrorFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MirrorFeature object.
MirrorFeatures | The MirrorFeatures object provides access to all of the objects in a component definition and provides methods to create additional MirrorFeature objects.
ModelingEvents | The ModelingEvents object provides notification of modeling events including new feature, feature delete, changed feature, client feature or new/changed parameters.
ModelingEventsObject | The ModelingEvents object provides notification of modeling events including new feature, feature delete, changed feature, client feature or new/changed parameters.
ModelingEventsSink | The ModelingEvents object provides notification of modeling events including new feature, feature delete, changed feature, client feature or new/changed parameters.
ModelingSettings | The ModelingSettings object provides access to properties that provide read and write access of the various modeling related document specific settings. This is somewhat equivalent to the Modeling tab of the Document Settings dialog.
ModelParameter | Object that represents a parameter that was created automatically by Autodesk Inventor as the result of creating an object that is dependent on a parameter. For example, when a placing a driving dimension constraint a ModelParameter is automatically created to control the dimension.
ModelParameters | Provides access to the model parameters ( objects) associated with the object the collection was obtained from.
MouseEvents | The MouseEvents object supports a set of events that can be received by clients who are interested in mouse input from the end-user.
MouseEventsObject | The MouseEvents object supports a set of events that can be received by clients who are interested in mouse input from the end-user.
MouseEventsSink | The MouseEvents object supports a set of events that can be received by clients who are interested in mouse input from the end-user.
MoveFaceDefinition |
MoveFaceFeature | The MoveFaceFeature provides the ability to move any face of a part along it's normal.
MoveFaceFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MoveFaceFeature object.
MoveFaceFeatures | The MoveFaceFeatures object provides access to all of the objects in a component definition and provides methods to create additional MoveFaceFeature objects.
MoveFeature | Use a MoveFeature object to drag an extrude, revolve, or sweep feature to a new location by supplying a transformation matrix.
MoveFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MoveFeature object.
MoveFeatures | The MoveFeatures object provides access to all of the MoveFeature objects in a part.
NameValueMap | The NameValueMap object. This object provides context-specific information, usually the context in which an event occurred. For more information, see the Event Context Information article in the overview section.
NativeBrowserNodeDefinition | The BrowserNodeDefinition object contains the definition of a node in the browser.
NativeBrowserNodeDefinitionObject | The NativeBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a native-created node in the browser. The properties, methods and events listed below are in addition to those supported by the BrowserNodeDefinition object.
NonLinearEdgeWorkPointDef | Object that allows you to get and set the information that specifies a work point using a non-linear edge.
NonParametricBaseFeature | The NonParametricBaseFeature object represents the feature that is created when a foreign file is translated into an Autodesk Inventor part file. If the foreign file defines a solid, it is read in and used to define the base feature.
NonParametricBaseFeatureDefinition | The NonParametricBaseFeatureDefinition is a utility object used for creating, querying, and editing non-parametric base features. A NonParametricBaseFeatureDefinition object can be created using the CreateDefinition method of the NonParametricBaseFeatures collection object. They can also be obtained from existing NonParametricBaseFeature objects.
NonParametricBaseFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the NonParametricBaseFeature object.
NonParametricBaseFeatures | The object represented the base solid that was created when a file was imported into Autodesk Inventor.
NormalToCurveWorkPlaneDef | The NormalToCurveWorkPlaneDef object that allows you to get and set the information that specifies a work plane defined as normal to a curve and through a point.
NormalToSurfaceWorkAxisDef | Object that allows you to get and set the information that specifies a work axis defined normal to a surface and through a point.
NotebookOptions | The NotebookOptions object provides access to properties that provide read and write access of the notebook related application options. This is somewhat equivalent to the Notebook tab of the Application Options dialog.
ObjectCollection | Generic collection of weakly-typed objects (IDispatch).
ObjectCollectionByVariant | Generic collection of weakly-typed objects (IDispatch).
ObjectDefaultsStyle | The Object Defaults style is a sub-style of the active standard style. In a drawing document, after a standard is selected, the active Object Default style specifies which layer and object style provides the format definition for a particular object.
ObjectDefaultsStylesEnumerator | The ObjectDefaultsStylesEnumerator object allows iteration through the collection.
ObjectsEnumerator | Generic enumerator for a group of objects. This enumerator will also support the IEnumxxx-style interface (IEnumUnknown, unless otherwise specified).
ObjectsEnumeratorByVariant | Generic enumerator for a group of objects. This enumerator will also support the IEnumxxx-style interface (IEnumUnknown, unless otherwise specified).
ObjectVisibility |
OccurrencePattern | The OccurrencePattern object is the base class for the FeatureBasedOccurrencePattern, RectangularOccurrencePattern, and CircularOccurrencePattern objects.
OccurrencePatternElement | The OccurrencePatternElement object represents a single instance within an occurrence pattern.
OccurrencePatternElementProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OccurrencePatternElement object.
OccurrencePatternElements | The OccurrencePatternElements collection object provides access to the instances ( objects) that result from the creation of a pattern.
OccurrencePatterns | The OccurrencePatterns collection object provides access to the existing assembly patterns ( objects) and supports methods to create new patterns.
OffsetConstraint | The OffsetConstraint object represents a constraint that defines an offset of two entities from two other entities.
OffsetConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OffsetConstraint object.
OffsetDimConstraint | The OffsetDimConstraint object represents a constraint that controls the distance between two parallel lines or a line and a point.
OffsetDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OffsetDimConstraint object.
OffsetSplineDimConstraint | The OffsetSplineDimConstraint is automatically created when offset spline dimensions are created. The OffsetDimConstraint object represents a constraint that controls the distance between two parallel lines or a line and a point. This constraint cannot be explicitly deleted.
OffsetSplineDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OffsetSplineDimConstraint object.
OffsetWidthExtent | The OffsetWidthExtent is used by sheet metal features when the width of the feature is defined with respect to two entities.
OrdinateDimension | The OrdinateDimension object represents an ordinate dimension placed on a sheet. The properties and methods listed below are in addition to those supported by the DrawingDimension object.
OrdinateDimensions | The OrdinateDimensions collection object provides access to all of the ordinate dimensions on the sheet.
OrdinateDimensionsEnumerator | Allows iteration of available OrdinateDimension objects.
OrdinateDimensionSet | The OrdinateDimensionSet object represents an ordinate dimension set placed on a sheet.
OutOfProcessInventorServer | This is class Inventor::OutOfProcessInventorServer.
OrdinateDimensionSets | The OrdinateDimensionSets collection object provides access to all of the ordinate dimension sets on the sheet.
OriginIndicator | The OriginIndicator object represents an origin indicator for ordinate dimensions and hole tables placed on a drawing view.
PanelBar | The PanelBar object represents the panel window in an environment. See the article in the overviews section.
PanelBarEventsSink | The PanelBar object represents the panel window in an environment.
PanelBarObject | The PanelBar object represents the panel window in an environment.
ParallelConstraint | The ParallelConstraint object represents a parallel constraint within a sketch.
ParallelConstraint3D | The ParallelConstraint3D object represents a parallel constraint within a 3D sketch.
ParallelConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ParallelConstraint3D object.
ParallelConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ParallelConstraint object.
Parameter | General parameter type that serves as the base class for all types of parameters. This object is returned when accessing parameters using the Item method of the Parameters collection object.
Parameters | Provides access to the objects associated with the object the collection was obtained from. Using the properties supported by the collection you can access the all of the parameters as a set or by type.
ParametersEnumerator | The ParametersEnumerator object allows enumeration through available parameters.
ParameterTable | The ParameterTable object represents the connection to a spreadsheet. From the ParameterTable object you can access the spreadsheet and the properties that define how the spreadsheet is read. In addition, the ParameterTable object provides access to the parameters that were created as a result of reading in the spreadsheet.
ParameterTables | Creates and provides access to the parameters that were created as a result of reading in a spreadsheet.
PartComponentDefinition | The PartComponentDefinition object that provides access to the Part.
PartComponentDefinitions | The Part ComponentDefinitions object represents a collection of objects.
PartDocument | The PartDocument object is derived from the Document object.
PartEvents | The PartEvents object provides notification of part events including changes to surface bodies.
PartEventsObject | The PartEvents object provides notification of part events including changes to surface bodies.
PartEventsSink | The PartEvents object provides notification of part events including changes to surface bodies.
PartFeature | The PartFeature object is the base class for all part modeling features.
PartFeatureExtent | The PartFeatureExtent object is the base class that defines the extent for certain part features--those that are profile-based.
PartFeatures | The PartFeatures collection object. Presents the current view of objects and allows their creation.
PartFeaturesEnumerator | The PartFeaturesEnumerator object. Presents a snapshot of the set of objects.
PartOptions | The PartOptions object provides access to properties that provide read and write access of the part related application options. This is somewhat equivalent to the Part tab of the Application Options dialog.
PartsList | The PartsList object represents a parts list in a drawing sheet.
PartsListCell | The PartsListCell object represents an individual cell in the parts list table.
PartsListColumn | The PartsListColumn object represents a column in a parts list table.
PartsListColumns | The PartsListColumns collection object provides access to all existing objects in the parts list.
PartsListRow | The PartsListRow object represents a row in a parts list table.
PartsListRows | The PartsListRows collection object provides access to all existing objects in the parts list.
PartsLists | The PartsLists collection object provides access to all existing objects on the sheet.
PartsListStyle | The PartsListStyle object represents a parts list style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
PartsListStylesEnumerator | The PartsListStylesEnumerator object provides access to the existing PartsListStyle objects.
Path | The Path object represents a single set of connected curves. The order of the objects within the collection is the same as the connection order of the entities.
PathAndGuideRailSweepDef | The PathAndGuideRailSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and a guide rail.
PathAndGuideSurfaceSweepDef | The PathAndGuideSurfaceSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and a guide surface.
PathAndSectionTwistsSweepDef | The PathAndSectionTwistsSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and twist sections.
PathEntity | The PathEntity object represents a curve within a path.
PathEntityProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PathEntity object.
PathProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Path object.
PathSweepDef | The PathSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and profile orientation constant.
PatternConstraint | The PatternConstraint object represents a constraint placed between elements of a pattern to make these elements associative.
PatternConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PatternConstraint object.
PerpendicularConstraint | The PerpendicularConstraint object represents a perpendicular constraint within a sketch.
PerpendicularConstraint3D | The PerpendicularConstraint3D object represents a perpendicular constraint within a 3D sketch. The constraint can be applied between a 3D sketch line and another 3D sketch line, a work axis, linear edge, work plane or a surface (face).
PerpendicularConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PerpendicularConstraint3D object.
PerpendicularConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PerpendicularConstraint object.
PitchAndHeightCoilExtent | The PitchAndHeightExtent object provides access to the information that defines the variables for a coil feature created using pitch and height values.
PitchAndRevolutionCoilExtent | The PitchAndRevolutionExtent object provides access to the information that defines the variables for a coil feature created using pitch and revolution values.
PlanarMoveDefinition | The PlanarMoveDefinition object defines all of the inputs that are unique to a move face feature defined using two planar points.
PlanarSketch | The PlanarSketch object, situated in 3D space. See the overview articles.
PlanarSketches | The PlanarSketches collection object provides access to all of the objects and provides methods to create additional PlanarSketch objects. See the article in the overviews section.
PlanarSketchProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PlanarSketch object.
Plane | The Plane object. A plane object is infinite. The object created is a transient mathematical object and is not displayed graphically. For more information, see the Transient Geometry article in the overviews section.
PlaneAndOffsetWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane that is parallel to an existing plane and offset a specified distance.
PlaneAndPointWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane that is parallel to an existing plane and passes through an existing point.
PlaneAndTangentWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane that is parallel to a plane and tangent to a surface.
Point | The Point object. The object is a transient mathematical object and is not displayed graphically. For more information see the Transient Geometry article in the overviews section.
Point2d | The Point2d object. The object created is a transient mathematical object and is not displayed graphically. Also, for more information see the Transient Geometry article in the overview section.
PointAndPlaneDistanceDimConstraint3D | The PointAndPlaneDistanceDimConstraint3D object represents a constraint that controls the distance between a 3D sketch point and a planar face or workplane.
PointAndPlaneDistanceDimConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PointAndPlaneDistanceDimConstraint3D object.
PointAndPlaneWorkAxisDef | Object that allows you to get and set the information that specifies a work axis that is normal to a plane and passes through a point.
PointAndTangentWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane that passes through a point and is tangent to a surface.
PointGraphics | The PointGraphics object defines a set of points. Each coordinate provided defines a point.
PointHolePlacementDefinition | The PointHolePlacementDefinition object defines the placement of a hole feature using a work point.
PointInference | The PointInference object provides access to information that defines how the current point is being inferred.
PointInferenceEnumerator | This object returns all of the information gleaned by Autodesk Inventor's inferencing facility applied to a mouse position. This object is returned via the MouseEvents object.
PointToPointRipTypeDef | The PointToPointRipTypeDef object defines the inputs unique to a point to point rip feature.
PointWorkPointDef | Object that allows you to get and set the information that specifies a work point defined to be coincident to a point.
Polyline2d | The Polyline2d object is a mathematical utility object that represents a set of connected line segments in a two dimension space. It is a transient object that is never shown graphically or saved in the Inventor document.
Polyline3d | The Polyline3d object is a mathematical utility object that represents a set of connected line segments. It is a transient object that is never shown graphically or saved in the Inventor document.
PositionalRepresentation | The PositionalRepresentation object represents a positional representation in the assembly.
PositionalRepresentations | The PositionalRepresentations collection object provides access to all the positional representations in the assembly and provides methods to create new ones.
Preparations | Represents the Preparations environment in a weldment assembly.
PresentationDocument | The PresentationDocument object respesents a presentation document in Inventor.
PresentationExplodedView | The PresentationExplodedView object represents an exploded view within a presentation document.
PresentationExplodedViews | The collection of PresentationExplodedView objects.
PresentationOptions | The PresentationOptions object provides access to properties that provide read and write access of the presentation related application options.
PrintManager | The PrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print job.
Profile | The Profile object defines a set of connected curves used as input for a feature. See the article in the overviews section.
Profile3D | The Profile3D object defines a set of connected curves within a 3D sketch. The Profile3D object is used as input for various features that support 3D sketches as input, such as sweep and loft. See the article in the overviews section.
Profile3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Profile3D object.
ProfileEntity | The ProfileEntity object represents a curve within a profile path.
ProfileEntity3D | The ProfileEntity3D object represents a curve within a 3D profile path.
ProfileEntity3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfileEntity3D object.
ProfileEntityProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfileEntity object.
ProfilePath | The ProfilePath object represents a single set of connected curves or a text box. The order of the collection defines the connected order of the entities. See the article in the overviews section.
ProfilePath3D | The ProfilePath3D object represents a single set of connected 3D curves. The order of the collection defines the connected order of the entities.
ProfilePath3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfilePath3D object.
ProfilePathProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfilePath object.
ProfileProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Profile object.
Profiles | Provides access to all of the objects owned by a particular X and supports the methods to create additional Profiles. See the article in the overviews section.
Profiles3D | Provides access to all of the 3d profiles owned by a particular 3d sketch and supports the methods to create additional 3d profiles.
ProgressBar | The ProgressBar object represents an Inventor dialog to show the progress of a certain operation or a series of operations.
ProgressBarObject | The ProgressBar object represents an Inventor dialog to show the progress of a certain operation or a series of operations.
ProgressBarSink | The ProgressBar object represents an Inventor dialog to show the progress of a certain operation or a series of operations.
ProgressiveToolTip | A ProgressiveToolTip object provides access to enhanced tooltip display for controls in the ribbon interface.
ProjectedCut | The ProjectedCut object represents a set of projected cut edges on the sketch.
ProjectedCutProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProjectedCut object.
ProjectedCuts | The ProjectedCuts object provides access to all of the projected cut edges on the sketch.
ProjectPath | The ProjectPath object represents a folder path for a library, workspace or a workgroup.
ProjectPaths | The ProjectPaths collection object provides access to a list of folder paths and provides ability to add/remove paths.
Property | Object that represents a Property. See the article in the overviews section.
PropertySet | Object that represents a PropertySet. This is a collection of related Properties. See the article in the overviews section.
PropertySets | Object that manages the collection of objects and provides the ability to add new property sets to the collection. See the article in the overviews section.
PunchNote | The PunchNote object represents a punch note with an attached leader on a sheet and derives from the LeaderNote object.
PunchNotes | The PunchNotes collection object provides access to all of the punch notes on the sheet.
PunchToolFeature | The PunchToolFeature object represents the instance of a placed punch tool feature.
PunchToolFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PunchToolFeature object.
PunchToolFeatures | The PunchToolFeatures collection object provides access to all of the objects in a sheet metal component definition.
RadialMarkingMenu | The RadialMarkingMenu object provides access to the contents of the radial marking menu (displayed when the user right clicks).
RadiusDimConstraint | The RadiusDimConstraint object represents a constraint that controls the radius of a circle or arc.
RadiusDimConstraint3D | The RadiusDimConstraint3D object represents a constraint that controls the radius of a circle or an arc. The picture below illustrates the use of this constraint.
RadiusDimConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RadiusDimConstraint3D object.
RadiusDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RadiusDimConstraint object.
RadiusGeneralDimension | The RadiusGeneralDimension object represents a radial general dimension placed on a sheet.
RectangularOccurrencePattern | The RectangularOccurrencePattern object represents a rectangular pattern of assembly occurrences.
RectangularOccurrencePatternProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RectangularOccurrencePattern object.
RectangularPatternFeature | The RectangularPatternFeature object represents rectangular pattern feature objects.
RectangularPatternFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RectangularPatternFeature object.
RectangularPatternFeatures | The RectangularPatternFeatures object provides access to all of the objects in a component definition and provides methods to create additional RectangularPatternFeature objects.
ReferenceComponent | The ReferenceComponent object is the base class for the DerivedPartComponent and DerivedAssemblyComponent objects.
ReferenceComponents | Provides access to all of the objects that are owned by a particular PartComponentDefinition and have an external file reference.
ReferencedOLEFileDescriptor | The ReferencedOLEFileDescriptor object represents an OLE reference to another file.
ReferencedOLEFileDescriptors | The ReferencedOLEFileDescriptors collection object contains information about all linked and embedded files within a document. Embeddings are not accessible in Apprentice.
ReferenceFeature | The ReferenceFeature object currently supports all of the methods and properties of the base PartFeature class.
ReferenceFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ReferenceFeature object.
ReferenceFeatures | The ReferenceFeatures collection object provides access to all of the existing objects in a part component definition.
ReferenceFeaturesEnumerator | The ReferenceFeaturesEnumerator object enumerates through the objects.
ReferenceKeyEventsObject | Provides access to events associated with custom reference keys.
ReferenceKeyEventsSink | This is class Inventor::ReferenceKeyEventsSink.
ReferenceKeyManager | Reference key manager object. This object provides methods to create and save reference key contexts as well as bind reference keys to their targets.
ReferenceParameter | Object that represents a parameter that was created automatically by Autodesk Inventor as the result of creating an driven dimension.
ReferenceParameters | Provides access to the objects of the component definition the collection was obtained from.
RefoldFeature | The RefoldFeature object (together with it's complementary UnfoldFeature object) allows sheet metal features to be added when the model is flat (unfolded) and then the model can be refolded.
RefoldFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RefoldFeature object.
RefoldFeatures | Object allowing iteration of the collection of RefoldFeature objects, and allows creation of RefoldFeature objects.
RegionProperties | The RegionProperties object. This object provides information relating to a profile region, including centroid, perimeter, rotation angle, moments of inertia, and axes.
RenderStyle | The RenderStyle object provides access to all of the properties that define a specific rendering style.
RenderStyles | The RenderStyles collection object allows for the creation of new objects and provides access to existing RenderStyle objects.
ReplaceFaceFeature | The ReplaceFaceFeature object represents a Replace Face feature, which is created interactively by using the Replace Face command on the Part Features menu.
ReplaceFaceFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ReplaceFaceFeature object.
ReplaceFaceFeatures | The ReplaceFaceFeatures collection object represents a collection of objects.
RepresentationEvents | The RepresentationEvents object provides notification of representation events including creation, activation or deletion of design views, level of detail or positional representations.
RepresentationEventsObject | The RepresentationEvents object provides notification of representation events including creation, activation or deletion of design views, level of detail or positional representations.
RepresentationEventsSink | The RepresentationEvents object provides notification of representation events including creation, activation or deletion of design views, level of detail or positional representations.
RepresentationsManager | The RepresentationsManager object provides access to all types of representations in an assembly, and design view representations in a part.
RestFeature | The RestFeature object represents a Rest sheet metal feature.
RestFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RestFeature object.
RestFeatures | The RestFeatures collection object provides access to the RestFeature objects.
RevisionTable | This object represent a revision table.
RevisionTableCell | The RevisionTableCell object represents an individual cell in the revision table.
RevisionTableColumn | This object represent a column in the revision table.
RevisionTableColumns | This collection object represents the column objects in a revision table.
RevisionTableRow | This object represents a row in the revision table.
RevisionTableRows | This collection object represents row objects in the revision table.
RevisionTables | The RevisionTables collection object represents all the revision history tables on a sheet and provides methods to create additional tables.
RevisionTableStyle | The RevisionTableStyle object represents a revision table style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
RevisionTableStylesEnumerator | The RevisionTableStylesEnumerator object provides access to the existing RevisionTableStyle objects.
RevolutionAndHeightCoilExtent | The RevolutionAndHeightExtent object provides access to the information that defines the variables for a coil feature created using revolution and height values.
RevolvedFaceWorkAxisDef | Object that allows you to get and set the information that specifies a work axis at the axis of a revolved face.
RevolveFeature | The RevolveFeature object represents revolved modeling features. The properties and methods listed below are in addition to those supported by the Feature object.
RevolveFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RevolveFeature object.
RevolveFeatures | The RevolveFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional RevolveFeatures.
Ribbon | The Ribbon object represents the user interface containing a collection of tabs.
RibbonPanel | A RibbonPanel object represents a panel within a ribbon tab.
RibbonPanels | The RibbonPanels collection object provides access to all existing panels within a ribbon tab and provides methods to create additional panels.
Ribbons | The Ribbons collection object provides access to all existing ribbons in Inventor.
RibbonTab | A RibbonTab object represents a tab within a ribbon.
RibbonTabs | The RibbonTabs collection object provides access to all existing tabs within a ribbon and provides methods to create additional tabs.
RibDefinition | The RibDefinition object represents all of the information that defines a Rib feature.
RibFeature | The Part RibFeature object.
RibFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RibFeature object.
RibFeatures | The Part RibFeatures collection object. A is a closed, thin-walled support shape.
RipDefinition | The RipDefinition object represents all of the information that defines a rip feature. The RipDefinition object is used in two ways. First it is used as input when creating a rip feature. Second it is used to query and edit existing rip features.
RipFeature | The RepFeature object represents a rip sheet metal feature.
RipFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RipFeature object.
RipFeatures | The RipFeatures collection object provides access to the RipFeature objects
RolledHemDefinition | The RolledHemDefinition object defines all of the inputs that are unique to a rolled style of hem feature.
RotateRotateConstraint | Object that represents a rotation motion constraint.
RotateRotateConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateRotateConstraint object.
RotateRotateiMateDefinition | The RotateRotateiMateDefinition object represents a rotate iMate definition. It is derived from the iMateDefinition object.
RotateRotateiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateRotateiMateDefinition object.
RotateTranslateConstraint | Object that represents a rotation-translate motion constraint.
RotateTranslateConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateTranslateConstraint object.
RotateTranslateiMateDefinition | The RotateTranslateiMateDefinition object represents a rotate translate iMate definition. It is derived from the iMateDefinition object.
RotateTranslateiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateTranslateiMateDefinition object.
Row | The Row object represents a single row in this custom table. See the Custom Tables overview for more information.
Rows | The Rows collection object represents all the objects contained by this custom table. See the Custom Tables overview for more information.
RuleFilletFeature | The RuleFilletFeature object represents a rule fillet sheet metal feature.
RuleFilletFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RuleFilletFeature object.
RuleFilletFeatures | The RuleFilletFeatures collection object provides access to the RuleFilletFeature objects
RunoffSurfaceDefinition | This object represents a runoff surface definition.
SaveOptions | The SaveOptions object provides access to properties that provide read and write access of the save related application options. This is somewhat equivalent to the Save tab of the Application Options dialog.
SculptFeature | The SculptFeature object represents sculpt modeling features.
SculptFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SculptFeature object.
SculptFeatures | The SculptFeatures collection object provides access to all of the SculptFeature objects in a part component definition and provides methods to create additional SculptFeatures.
SculptSurface | The SculptSurface object provides access to a sculpt surface and its associated direction. The surface defines a boundary of the sculpt feature and the associated direction defines the side of the surface used to create the sculpt feature.
SectionDrawingView | The SectionDrawingView object represents a section view within a drawing. See the article in the overviews section.
SelectEvents | The SelectEvents object supports a set of events that are fired when the user is selecting geometry. These events are fired when the user is selecting items from various UI elements such as the graphics window or the browser.
SelectEventsObject | The SelectEvents object supports a set of events that are fired when the user is selecting geometry. These events are fired when the user is selecting items from various UI elements such as the graphics window or the browser.
SelectEventsSink | The SelectEvents object supports a set of events that are fired when the user is selecting geometry. These events are fired when the user is selecting items from various UI elements such as the graphics window or the browser.
SelectSet | The SelectSet object acts as a container for all of the objects that are currently selected using the Select command. See the article in the overviews section.
ShadedDisplayOptions | The ShadedDisplayOptions object provides access to properties that provide read and write access of the shaded display related application options. This is equivalent to the Shaded Display Mode section of the Display tab on the Application Options dialog.
Sheet | The Sheet object represents a sheet in a drawing document. See here for an overview on drawing views.
SheetFormat | The SheetFormat object represents a sheet format in a drawing.
SheetFormats | The SheetFormats collection object provides access to all the existing SheetFormat objects in a drawing document and provides methods to create additional sheet formats.
SheetMetalComponentDefinition | The SheetMetalComponentDefinition object derives from the PartComponentDefinition object. It adds the sheet metal-specific behavior to the PartComponentDefinition.
SheetMetalFeatures | The SheetMetalFeaturesFeatures collection object provides access to all of the SheetMetalFeature objects in a sheet metal component definition.
SheetMetalStyle | The SheetMetalStyle object contains all of the information about a particular sheet metal style (these are also referred to as sheet metal rules).
SheetMetalStyles | The SheetMetalStyles collection object provides access to all of the objects in a part component definition and provides methods to create additional sheet metal styles.
Sheets | The Sheets collection object provides access to all the existing objects in a drawing document and provides methods to create additional sheets. See here for an overview on drawing views.
SheetSettings | The SheetSettings object provides access to properties that provide read and write access of the various sheet related document specific settings. This is somewhat equivalent to the Sheet tab of the Document Settings dialog.
ShellDefinition | The ShellDefinition object is used to define all of the input required for fillet features. It is also used to query and edit existing shell features.
ShellFeature | The ShellFeature object represents the shell modeling feature.
ShellFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ShellFeature object.
ShellFeatures | The ShellFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional ShellFeatures.
ShellThicknessFaceSet | The ShellThicknessFaceSet object provides access to the faces and their associated thickness for a shell.
SilhouetteCurve | The SilhouetteCurve object represents the results of creating a silhouette curve calculation. It consists of one or more sketch entities that represent the silhouette of the original input face(s) or body.
SilhouetteCurves | The SilhouetteCurves object provides access to all the silhouette curve results in a 3D sketch and supports the ability to create new silhouette curves.
SingleHemDefinition | The SingleHemDefinition object defines all of the inputs that are unique to a single style of hem feature.
SinglePointRipTypeDef | The SinglePointRipTypeDef object defines the inputs unique to a single point rip feature.
Sketch | The generic Sketch object. All types of Sketch objects derive from this object. See the article in the overviews section.
Sketch3D | The Sketch3D object provides access to the current contents of a specific 3D sketch and its related properties and methods. See the article in the overviews section.
Sketch3DOptions | The Sketch3DOptions object provides access to properties that provide read and write access of the 3D sketch related application options. This is somewhat equivalent to the 3D Sketch portion on the Sketch tab of the Application Options dialog.
Sketch3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Sketch3D object.
Sketch3DSettings | The Sketch3DSettings object provides access to properties that provide read and write access of the various 3D sketch related document specific settings. This is somewhat equivalent to the 3D sketch related properties on Sketch tab of the Document Settings dialog.
SketchArc | The SketchArc object represents an arc within a sketch. See the article in the overviews section.
SketchArc3D | The SketchArc3D object represents an arc within a 3D sketch. See the article in the overviews section.
SketchArc3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchArc3D object.
SketchArcProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchArc object.
SketchArcs | The SketchArcs object provides access to all the objects in a sketch and provides methods to create additional sketch arcs. See the article in the overviews section.
SketchArcs3D | The SketchArcs3D object provides access to all the sketch arcs ( objects, including bends) in a 3D sketch and provides methods to create additional bends. See the article in the overviews section.
SketchBlock | The SketchBlock object represents a sketch block instance within a sketch.
SketchBlockDefinition | The SketchBlockDefinition object represents a sketch block definition.
SketchBlockDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchBlockDefinition object.
SketchBlockDefinitions | The SketchBlockDefinitions collection object provides access to all sketch block definitions and provides methods to create additional definitions.
SketchBlockDefinitionsEnumerator | The SketchBlockDefinitionsEnumerator allows iteration of available sketchBlockDefinition objects.
SketchBlockProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchBlock object.
SketchBlocks | The SketchBlocks collection object provides access to all sketch block instances within a sketch and provides methods to create additional block instances.
SketchBlocksEnumerator | The SketchBlocksEnumerator allows iteration of available SketchBlock objects.
SketchCircle | The SketchCircle object represents a circle within a sketch. See the article in the overviews section.
SketchCircle3D | The SketchCircle3D object represents a circle within a 3D sketch. See the article in the overviews section.
SketchCircle3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchCircle3D object.
SketchCircleProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchCircle object.
SketchCircles | The SketchCircles object provides access to all the objects in a sketch and provides methods to create additional sketch circles. See the article in the overviews section.
SketchCircles3D | The SketchCircles3D object provides access to all the objects in a sketch. See the article in the overviews section.
SketchConstraints3DEnumerator | The SketchConstraints3DEnumerator object provides access to a list of SketchConstraint objects in a specific 3D sketch. See the article in the overviews section.
SketchConstraintsEnumerator | The SketchConstraintEnumerator object provides access to a list of SketchConstraint objects. See the article in the overviews section.
SketchedSymbol | The SketchedSymbol object represents the instance of a SketchedSymbolDefinition on a sheet. See the article in the overviews section.
SketchedSymbolDefinition | The SketchedSymbolDefinition object represents a sketched symbol definition. See the article in the overviews section.
SketchedSymbolDefinitions | The SketchedSymbolDefinitions collection object provides access to all the existing objects in a drawing document and provides methods to create additional sketched symbol definitions. See the article in the overviews section.
SketchedSymbols | The SketchedSymbols collection object provides access to the objects on a specific sheet. It also provides the ability to place sketched symbols onto a sheet. See the article in the overviews section.
SketchEllipse | The SketchEllipse object represents an ellipse within a sketch. See the article in the overviews section.
SketchEllipse3D | The SketchEllipse3D object represents an ellipse within a 3D sketch. See the article in the overviews section.
SketchEllipse3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipse3D object.
SketchEllipseProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipse object.
SketchEllipses | The SketchEllipses object provides access to all the objects in a sketch and provides methods to create additional sketch ellipses. See the article in the overviews section.
SketchEllipses3D | The SketchEllipses3D object provides access to all the objects in a sketch. See the article in the overviews section.
SketchEllipticalArc | The SketchEllipticalArc object represents an elliptical arc within a sketch. See the article in the overviews section.
SketchEllipticalArc3D | The SketchEllipticalArc3D object represents an elliptical arc within a 3D sketch. See the article in the overviews section.
SketchEllipticalArc3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipticalArc3D object.
SketchEllipticalArcProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipticalArc object.
SketchEllipticalArcs | The SketchEllipticalArcs object provides access to all the objects in a sketch. See the article in the overviews section.
SketchEllipticalArcs3D | The SketchEllipticalArcs3D object provides access to all the objects in a sketch.
SketchEntities3DEnumerator | The SketchEntities3DEnumerator object provides access to a set of 3D sketch entities. See the article in the overviews section.
SketchEntitiesEnumerator | The SketchEntitiesEnumerator object provides access to all of the geometric entities on the sketch regardless of their type. See the article in the overviews section.
SketchEntity | The SketchEntity object is the base class for all geometric sketch entities. See the article in the overviews section.
SketchEntity3D | The SketchEntity object is the base class for all geometric sketch entities. See the article in the overviews section.
Sketches3D | Provides access to all of the objects owned by a particular PartComponentDefinition. See the article in the overviews section.
Sketches3DEnumerator | The Sketches3DEnumerator allows iteration of available Sketch3D objects.
SketchesEnumerator | The SketchesEnumerator object. See the article in the overviews section.
SketchEvents | The SketchEvents object provides notification of sketch events including new, changed, solved or deleted sketches.
SketchEventsObject | The SketchEvents object provides notification of sketch events including new, changed, solved or deleted sketches.
SketchEventsSink | The SketchEvents object provides notification of sketch events including new, changed, solved or deleted sketches.
SketchFillRegion | An object representing a color-filled region in a drawing sketch.
SketchFillRegions | A collection of SketchFillRegion objects.
SketchFixedSpline | The SketchFixedSpline object represents a fixed spline within a sketch. These splines are created using the geometry definition (BSplineCurve2d). See the article in the overviews section.
SketchFixedSpline3D | The SketchFixedSpline3D object represents a fixed spline within a sketch. These splines are created using the geometry definition (BSplineCurve). See the article in the overviews section.
SketchFixedSpline3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchFixedSpline3D object.
SketchFixedSplineProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchFixedSpline object.
SketchFixedSplines | SketchFixedSplines object provides access to all the objects in a sketch. See the article in the overviews section.
SketchFixedSplines3D | The SketchFixedSplines3D object provides access to all the objects in a 3D sketch. See the article in the overviews section.
SketchHolePlacementDefinition | The SketchHolePlacementDefinition object defines the placement of a hole feature using sketch points.
SketchImage | The SketchImage object represents an image within a sketch.
SketchImageProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchImage object.
SketchImages | The SketchImages collection object provides access to all the images in a sketch.
SketchLine | The SketchLine object represents a line within a sketch. See the article in the overviews section.
SketchLine3D | The SketchLine3D object represents a line within a 3D sketch. See the article in the overviews section.
SketchLine3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchLine3D object.
SketchLineProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchLine object.
SketchLines | The SketchLines object provides access to all of the objects in a sketch and provides methods to create additional sketch lines. See the article in the overviews section.
SketchLines3D | The SketchLines3D object provides access to all of the objects in a sketch and provides methods to create additional sketch lines. See the article in the overviews section.
SketchOffsetSpline | The SketchOffsetSpline object represents an offset spline within a sketch. These special splines are created as a result of offsetting splines and ellipses in a sketch. See the article in the overviews section.
SketchOffsetSplineProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchOffsetSpline object.
SketchOffsetSplines | The SketchOffsetSplines object provides access to all the objects in a sketch. See the article in the overviews section.
SketchOptions | The SketchOptions object provides access to properties that provide read and write access of the 2D sketch related application options. This is somewhat equivalent to the 2D Sketch portion on the Sketch tab of the Application Options dialog.
SketchPoint | The SketchPoint object represents a point within a sketch. See the article in the overviews section.
SketchPoint3D | The SketchPoint3D object represents a point within a 3D sketch. See the article in the overviews section.
SketchPoint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchPoint3D object.
SketchPointProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchPoint object.
SketchPoints | The SketchPoints object provides access to all the objects in a sketch and provides methods to create additional sketch points. See the article in the overviews section.
SketchPoints3D | The SketchPoints3D object provides access to all the objects in a sketch. See the article in the overviews section.
SketchSettings | The SketchSettings object provides access to properties that provide read and write access to the various sketch related document specific settings. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.
SketchSpline | The SketchSpline object represents a spline within a sketch. See the article in the overviews section.
SketchSpline3D | The SketchSpline3D object represents a spline within a 3D sketch. See the article in the overviews section.
SketchSpline3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSpline3D object.
SketchSplineHandle | The SketchSplineHandle object represents a spline handle within a sketch at a spline fit point.
SketchSplineHandle3D | The SketchSplineHandle3D object represents a spline handle within a 3D sketch at a spline fit point.
SketchSplineHandle3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSplineHandle3D object.
SketchSplineHandleProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSplineHandle object.
SketchSplineProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSpline object.
SketchSplines | The SketchSplines object provides access to all the objects in a sketch and provides methods to create additional sketch splines. See the article in the overviews section.
SketchSplines3D | The SketchSplines3D object provides access to all the objects in a sketch and provides methods to create additional sketch splines. See the article in the overviews section.
SmoothConstraint | The SmoothConstraint object represents a smooth (G2-continuous) constraint within a sketch.
SmoothConstraint3D | The SmoothConstraint3D object represents a smooth (G2-continuous) constraint within a 3d sketch.
SmoothConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SmoothConstraint3D object.
SmoothConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SmoothConstraint object.
SnapFitFeature | The SnapFitFeature object represents a snap fit feature within the model.
SnapFitFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SnapFitFeature object.
SnapFitFeatures | The SnapFitFeatures collection object provides access to existing snap fit features.
SoftwareVersion | Object that encapsulates a given software version. Used in various contexts.
Sphere | The Sphere object. The object created is a transient mathematical object and is not displayed graphically.
SpiralCoilExtent | The SpiralCoilExtent object provides access to the information that defines the variables for a spiral coil feature.
SplineFitPointConstraint | The SplineFitPointConstraint object represents a constraint that makes a spline fit through a specified sketch point. This constraint is created automatically when a spline is created or when new fit points are added to a spline.
SplineFitPointConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SplineFitPointConstraint object.
SplineFitPointsConstraint3D | The SplineFitPointsConstraint3D object represents a constraint that makes a spline fit through a series of specified sketch points. This constraint is created automatically when a spline is created.
SplineFitPointsConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SplineFitPointsConstraint3D object.
SplitFeature | The Part SplitFeature object.
SplitFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SplitFeature object.
SplitFeatures | The Part SplitFeatures object represents a collection of objects.
StandardThreadInfo | The StandardThreadInfo object defines the thread information that is used by the Hole and Thread features. For tapered threads the TaperedThreadInfo object is used.
Style | The Style object is the base class for all the drawing styles and contains methods/properties common to all the styles.
StyleEvents | The StyleEvents object provides notification of style events including new, activated, changed or deleted styles.
StyleEventsObject | The StyleEvents object provides notification of style events including new, activated, changed or deleted styles.
StyleEventsSink | The StyleEvents object provides notification of style events including new, activated, changed or deleted styles.
Styles | The Styles collection object provides access to all the Style objects.
StylesManager | The StylesManager object provides utilities to manage the various styles in a document.
SurfaceBodies | The SurfaceBodies object represents a collection of SurfaceBody objects. See the article in the overviews section.
SurfaceBody | The SurfaceBody object. See the article in the overviews section.
SurfaceBodyDefinition | The SurfaceBodyDefinition represents a transient definition of a B-Rep object.
SurfaceBodyProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SurfaceBody object.
SurfaceEvaluator | The SurfaceEvaluator object. See the article in the overviews section.
SurfaceGraphics | The SurfaceGraphics object defines a graphics object created using a body.
SurfaceGraphicsEdge | The SurfaceGraphicsEdge represents an individual edge displayed by the SurfaceGraphics object.
SurfaceGraphicsEdgeList | The SurfaceGraphicsEdgeList object contains a list of edges currently displayed by a SurfaceGraphics primitive and allows you to add edges to the list.
SurfaceGraphicsFace | The SurfaceGraphicsFace represents an individual face displayed by the SurfaceGraphics object.
SurfaceGraphicsFaceList | The SurfaceGraphicsFaceList object contains a list of faces currently displayed by a SurfaceGraphics primitive and allows you to add faces to the list.
SurfaceTextureStyle | The SurfaceTextureStyle object represents a surface texture style in a drawing.
SurfaceTextureStylesEnumerator | The SurfaceTextureStylesEnumerator object provides access to the existing SurfaceTextureStyle objects.
SurfaceTextureSymbol | The SurfaceTextureSymbol object represents a surface texture symbol on a sheet.
SurfaceTextureSymbols | The SurfaceTextureSymbols collection object provides access to all the surface texture symbols on a sheet and provides methods to create additional ones.
SweepDefinition | The SweepDefinition object is the base class that defines the variables for sweep features.
SweepFeature | The SweepFeature object represents swept modeling features. The properties and methods listed below are in addition to those supported by the Feature object.
SweepFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SweepFeature object.
SweepFeatures | The SweepFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional SweepFeature objects.
SymmetryConstraint | The SymmetryConstraint object represents a symmetry constraint within a sketch.
SymmetryConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SymmetryConstraint object.
TableFormat | The TableFormat object contains values for the various overrides of the table's appearance.
TableParameter | Object that represents a parameter that was created automatically by Autodesk Inventor as the result of reading a spreadsheet.
TableParameters | Provides access to the objects associated with the ParameterTable object the collection was obtained from.
TableStyle | The TableStyle object represents a general (custom) table style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.
TableStylesEnumerator | The TableStylesEnumerator object provides access to the existing TableStyle objects.
TangentConstraint | Object that represents a tangent assembly constraint.
TangentConstraint3D | The TangentConstraint3D object represents a tangent constraint within a sketch.
TangentConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentConstraint3D object.
TangentConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentConstraint object.
TangentDistanceDimConstraint | The TangentDistanceDimConstraint object represents a constraint that controls the distance to a circle or arc at the tangent location.
TangentDistanceDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentDistanceDimConstraint object.
TangentiMateDefinition | The TangentiMateDefinition object represents a tangent iMate definition. It is derived from the iMateDefinition object.
TangentiMateDefinitionProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentiMateDefinition object.
TangentSketchConstraint | The TangentSketchConstraint object represents a tangent constraint within a sketch.
TangentSketchConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentSketchConstraint object.
TaperedThreadInfo | The TaperedThreadInfo object defines the thread information that is used by the Hole and Thread features. For standard threads the StandardThreadInfo object is used.
TeardropHemDefinition | The TeardropHemDefinition object defines all of the inputs that are unique to a tear drop style of hem feature.
TextBox | The TextBox object represents text on a sheet or sketch.
TextBoxConstraint | The TextBoxConstraint is automatically created when a text box is created. This constraint cannot be explicitly deleted.
TextBoxConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TextBoxConstraint object.
TextBoxes | The TextBoxes collection object provides access to all the existing objects in a drawing document and supports methods to create new TextBox objects.
TextBoxProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TextBox object.
TextGraphics | The TextGraphics object defines a set of text strings that are displayed within the model. Each coordinate provided defines a new TextGraphics object. For each coordinate you must also provide a text string.
TextStyle | The TextStyle object represents a text style in a drawing.
TextStyles | The TextStyles collection object provides access to all the existing objects in a drawing document.
TextStylesEnumerator | The TextStylesEnumerator Collection Object allows iteration of the available text styles.
TextureCoordinateSet | A TextureCoordinateSet defines the coordinates of the map on the face. The TextureMap.Transformation matrix defines how the coordinates map to the actual face coordinates. Several TextureMaps could reference a single TextureCoordinateSet.
TextureMap | Each TextureMap references a TextureCoordinateSet that defines the coordinates of the map on the face. Several TextureMaps could reference a single TextureCoordinateSet.
TextureMaps | The TextureMaps collection returns all the texture maps applied to a face. There could be multiple maps that are 'wrapped' around a face.
ThickenFeature | The ThickenFeature object represents a thicken feature, which is created interactively using the Thicken/Offset tool on the Part features toolbar. A thicken operation adds or removes volume from parts or adds thickness to surfaces to create parts.
ThickenFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ThickenFeature object.
ThickenFeatures | The ThickenFeatures collection object represents a collection of objects on a part.
ThreadFeature | The ThreadFeature object represents thread modeling features.
ThreadFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ThreadFeature object.
ThreadFeatures | The ThreadFeatures object provides access to all of the objects in a component definition and provides methods to create additional ThreadFeature objects.
ThreadInfo | This is a common base object from which the rest of the concrete objects that hold thread information are derived. It contains the generally applicable properties of threads.
ThreadTableQuery | The ThreadTableQuery object has methods to query the thread table data contained in the Thread.xls spreadsheet.
ThreePlanesWorkPointDef | Object that allows you to get and set the information that specifies a work point defined by the intersection of three planes.
ThreePointAngleDimConstraint | The ThreePointAngleDimConstraint object represents a constraint that controls the angle defined by three points.
ThreePointAngleDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ThreePointAngleDimConstraint object.
ThreePointsWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane defined by three points.
ThroughAllExtent | The ThroughAllExtent object provides access to the information that defines the extent for a feature using through all extent.
TitleBlock | The TitleBlock object represents the instance of a title block on a sheet.
TitleBlockDefinition | The TitleBlockDefinition object represents a title block definition.
TitleBlockDefinitions | The TitleBlockDefinitions collection object provides access to all the existing objects in a drawing document and provides methods to create additional title block definitions.
ToExtent | The ToExtent object defines the feature extent type where the feature extent is defined up to a specified entity.
ToHeightExtent | The ToHeightExtent is used by the FlangeFeature object when the height extent type is defined as a 'To' extent.
Tolerance | The Tolerance object represents information about tolerance.
ToNextExtent | The ToNextExtent object provides access to the information that defines the extent for a feature that's extent is determined by extruding up to the closest set of faces that the feature completely intersects.
Torus | The Torus object. The object created is a transient mathematical object and is not displayed graphically.
TorusCenterPointWorkPointDef | Object that allows you to get and set the information that specifies a work point defined to be at the center of a torus.
TorusMidPlaneWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane defined to be at the mid-plane of a torus.
Trail | The Trail object represents the path of an occurrence from its initial to the final position in the exploded view as a result of the tweaks applied to it.
TrailSegment | The TrailSegment object represents a portion of a trail created by one particular tweak operation.
TrailsEnumerator | Object that enumerates presentation view trails.
Transaction | The Transaction object that stands for a single transaction. See the article in the overviews section.
TransactionEvents | The TransactionEvents object provides notification of events including transaction abort, commit, delete, redo and undo.
TransactionEventsObject | The TransactionEvents object provides notification of events including transaction abort, commit, delete, redo and undo.
TransactionEventsSink | The TransactionEvents object provides notification of events including transaction abort, commit, delete, redo and undo.
TransactionManager | The TransactionManager object encapsulates all of the transaction-based functionality. See the article in the overviews section.
TransactionsEnumerator | Provides access to a list of objects. See the article in the overviews section.
TransientBRep | The TransientBRep object is used to create and manipulate B-Rep objects within a transient space.
TransientGeometry | Object through which all transient geometry objects are constructed. For more information, see the Transient Geometry overview.
TransientObjects | Object through which all general transient objects are constructed.
TransitionalConstraint | Object that represents a transition assembly constraint.
TransitionalConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TransitionalConstraint object.
TranslateTranslateConstraint | The TranslateTranslate assembly motion constraint object.
TranslateTranslateConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TranslateTranslateConstraint object.
TranslationContext | The TranslationContext object is used in TranslatorAddin workflows.
TranslatorAddIn | Object that represents an Translator AddIn inside Autodesk Inventor.
TranslatorAddInServer | Object required to be supported by Server to qualify as an Autodesk Inventor Translator AddIn.
TriadEvents | Event object that provides Triad (3D Move/Rotate tool) events.
TriadEventsObject | Event object that provides Triad (3D Move/Rotate tool) events.
TriadEventsSink | Event object that provides Triad (3D Move/Rotate tool) events.
TriangleFanGraphics | The TriangleFanGraphics object defines a set of connected triangles. The first three coordinates define a triangle and the next coordinate defines another triangle using two previous coordinates.
TriangleGraphics | The TriangleGraphics object defines a set of disconnected triangles. Each set of three coordinates defines a triangle.
TriangleStripGraphics | The TriangleStripGraphics object defines a set of connected triangles. The first three coordinates define a triangle and the next coordinate defines another triangle using the previous two coordinates.
TrimFeature |
TrimFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TrimFeature object.
TrimFeatures | The TrimFeatures collection provides access to all of the TrimFeature objects in a component definition.
TwoDistancesChamferDef | The TwoDistancesChamferDef object provides access to the information that defines the variables for a chamfer feature created using two distances.
TwoLineAngleDimConstraint | The TwoLineAngleDimConstraint object represents a constraint that controls the angle between two lines.
TwoLineAngleDimConstraint3D | The TwoLineAngleDimConstraint3D object represents a constraint that controls the angle between two 3D sketch lines.
TwoLineAngleDimConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoLineAngleDimConstraint3D object.
TwoLineAngleDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoLineAngleDimConstraint object.
TwoLinesWorkPlaneDef | Object that allows you to get and set the information that specifies a work plane defined by two lines.
TwoLinesWorkPointDef | Object that allows you to get and set the information that specifies a work point defined by the intersection of two lines.
TwoPlanesWorkAxisDef | Object that allows you to get and set the information that specifies a work axis along a line.
TwoPlanesWorkPlaneDef | The TwoPlanesWorkPlaneDef object that allows you to get and set the information that specifies a work a work plane defined by two planes.
TwoPointDistanceDimConstraint | The TwoPointDistanceDimConstraint object represents a constraint that controls the distance between two points. The vertical, horizontal, or true distance can be controlled.
TwoPointDistanceDimConstraint3D | The TwoPointDistanceDimConstraint3D object represents a constraint that controls the distance between two 3D sketch points.
TwoPointDistanceDimConstraint3DProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoPointDistanceDimConstraint3D object.
TwoPointDistanceDimConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoPointDistanceDimConstraint object.
TwoPointsWorkAxisDef | Object that allows you to get and set the information that specifies a work axis along a line.
UnfoldFeature | The UnfoldFeature object (together with it's complementary RefoldFeature object) allows sheet metal features to be added when the model is flat (unfolded) and then the model can be refolded.
UnfoldFeatureProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the UnfoldFeature object.
UnfoldFeatures | Object allowing iteration of the collection of UnfoldFeature objects, and allows creation of UnfoldFeature objects.
UnfoldMethod | The UnfoldMethod object provides access to the information associated with a specific unfold method. This object derives from the Style object.
UnfoldMethods | Provides access to the unfold method list (collection of UnfoldMethod objects) for a particular sheet metal style.
UnitsOfMeasure | The UnitsOfMeasure object supports various functions to allow you to interact with the units associated with the document.
UnitVector | The UnitVector object. For more information, see the [image] Transient Geometry overview.
UnitVector2d | The UnitVector2d object. For more information, see the [image] Transient Geometry overview.
UserCoordinateSystem | The UserCoordinateSystem object represents a user coordinate system.
UserCoordinateSystemDefinition | The UserCoordinateSystemDefinition object represents the information that defines a coordinate system. You can use this object as input to the UserCoordinateSystems.Add method to create the actual coordinate system.
UserCoordinateSystemProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the UserCoordinateSystem object.
UserCoordinateSystems | The UserCoordinateSystems collection object contains all user coordinate systems within the document and provides methods to create additional ones.
UserCoordinateSystemSettings | The UserCoordinateSystemSettings object provides access to various UCS related document level settings. This object is obtained from the ModelingSettings.UserCoordinateSystemSettings property.
UserInputEvents | The UserInputEvents object provides input event notification. For example, use of the context menu.
UserInputEventsObject | The UserInputEvents object provides input event notification. For example, use of the context menu.
UserInputEventsSink | The UserInputEvents object provides input event notification. For example, use of the context menu.
UserInterfaceEvents | This object provides notification of environment and command bar reset events.
UserInterfaceEventsObject | This object provides notification of environment and command bar reset events.
UserInterfaceEventsSink | This object provides notification of environment and command bar reset events.
UserInterfaceManager | The UserInterfaceManager object, through which all UI customization objects can be accessed. See [image] here for an overview.
UserParameter | Object that represents a parameter that was created by the user.
UserParameters | Provides access to the user parameters ( UserParameter objects) associated with the object the collection was obtained from.
VbaApplication | The VBAApplication object represents the currently available VBA application.
Vector | The Vector object. For more information, see the [image] Transient Geometry overview.
Vector2d | The Vector2d object. For more information, see the [image] Transient Geometry overview.
Vertex | The Vertex object represents a transient point in boundary representation data.
VertexDefinition |
VertexDefinitions |
VertexProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Vertex object.
VerticalAlignConstraint | The VeticalAlignConstraint object represents a constraint the makes two sketch points align vertically.
VerticalAlignConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the VerticalAlignConstraint object.
VerticalConstraint | The VerticalConstraint object represents a vertical constraint within a sketch.
VerticalConstraintProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the VerticalConstraint object.
Vertices | The Vertices object represents a collection of Vertex objects.
View | The View object represents a view in a document.
ViewList | A ViewList object is a collection of View objects.
Views | The Views collection object provides access to all of the graphic View objects associated with a particular document. It also provides functionality to create new views.
ViewsEnumerator | The ViewsEnumerator object provides access to a list of View objects.
VirtualComponentDefinition | This object derives from the ComponentDefinition object. It represents a ComponentDefinition that exists solely for the BOM.
Weld | The Weld object represents a weld within an assembly. The Weld object is a base class of the CosmeticWeld and WeldBead objects. kAssemblyFeatureGroup : General assembly group. kPreperationsFeatureGroup : Preparations group. kWeldsFeatureGroup : Welds group. kMachiningFeatureGroup : Machining group.
WeldBead | The WeldBead object represents a weld bead within an assembly. The WeldBead object is derived from the Weld object.
WeldBeads | The WeldBeads object provides access to all the existing WeldBead objects within a weldment.
WeldmentComponentDefinition | The WeldmentComponentDefinition object provides access to all of the assembly and weldment information of a weldment assembly.
Welds | The Welds object provides access to all of the existing welds within a weldment.
WeldsComponentDefinition | The WeldsComponentDefinition object derives from the PartComponentDefinition object. It adds weld-specific behavior to the PartComponentDefinition.
WidthOffsetWidthExtent | The WidthOffsetWidthExtent is used by sheet metal features when the position of a width defined feature is relative to another entity.
Wire | Non-faceted representation of edges of a body. Typical uses include representing bend lines on sheet metal.
WireframeDisplayOptions | The WireframeDisplayOptions object provides access to properties that provide read and write access of the wireframe display related application options. This is equivalent to the Wireframe Display Mode section of the Display tab on the Application Options dialog.
Wires | The Wires collection object provides access to a set of Wire objects.
WorkAxes | The WorkAxes collection object provides access to all of the WorkAxis objects in the parent document and provides methods to create new work axes.
WorkAxis | Represents a work axis. See [image] here for an overview.
WorkAxisProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkAxis object.
WorkPlane | Represents a work plane. See [image] here for an overview.
WorkPlaneProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkPlane object.
WorkPlanes | The WorkPlanes collection object provides access to all of the WorkPlane objects in the parent document and provides methods to create new work planes.
WorkPoint | Represents a work point. See [image] here for an overview.
WorkPointProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkPoint object.
WorkSurface | The WorkSurface object represents a work surface, which is a type of work feature.
WorkSurfaceProxy | This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkSurface object.
WorkSurfaces | The WorkSurfaces collection object represents all of the WorkSurface objects associated with this part or component.
Enums
Name | Description
AccuracyEnum | This is record Inventor::AccuracyEnum.
ActionTypeEnum | Bit field describing the various action types
AddInLicenseStatusEnum | This is record Inventor::AddInLicenseStatusEnum.
AddInLoadBehaviorEnum | This is record Inventor::AddInLoadBehaviorEnum.
AlignmentTypeEnum | This is record Inventor::AlignmentTypeEnum.
AlternateUnitsDisplayTypeEnum | This is record Inventor::AlternateUnitsDisplayTypeEnum.
AnalysisTypeEnum | This is record Inventor::AnalysisTypeEnum.
AngleConstraintSolutionTypeEnum | This is record Inventor::AngleConstraintSolutionTypeEnum.
AngularPrecisionEnum | Enum specifying the precision for angular dimensions
ApplicationAddInTypeEnum | Constants enumerating the ApplicationAddIn types.
ApplicationFrameColorTypeEnum | This is record Inventor::ApplicationFrameColorTypeEnum.
ArcDimensionTypeEnum | This is record Inventor::ArcDimensionTypeEnum.
ArrowheadTypeEnum | This is record Inventor::ArrowheadTypeEnum.
BackgroundTypeEnum | This is record Inventor::BackgroundTypeEnum.
BalloonDirectionEnum | Balloon Direction Enum
BalloonTypeEnum | Balloon Type Enum
BarControlTypeEnum | Constants enumerating bar control types.
BaseFeatureOutputTypeEnum | This is record Inventor::BaseFeatureOutputTypeEnum.
BendAngleTypeEnum | This is record Inventor::BendAngleTypeEnum.
BendLocationEnum | This is record Inventor::BendLocationEnum.
BendOrderSourceTypeEnum | This is record Inventor::BendOrderSourceTypeEnum.
BendPartTypeEnum | This is record Inventor::BendPartTypeEnum.
BendPositionEnum | This is record Inventor::BendPositionEnum.
BendReliefShapeEnum | Constants identifying the bend relief shape.
BendTransitionEnum | Constants identifying Bend Transition.
BIMCableTrayConnectionTypeEnum | This is record Inventor::BIMCableTrayConnectionTypeEnum.
BIMConduitConnectionTypeEnum | This is record Inventor::BIMConduitConnectionTypeEnum.
BIMConnectorDefinitionTypeEnum | This is record Inventor::BIMConnectorDefinitionTypeEnum.
BIMConnectorShapeEnum | This is record Inventor::BIMConnectorShapeEnum.
BIMDuctConnectionTypeEnum | This is record Inventor::BIMDuctConnectionTypeEnum.
BIMDuctFlowConfigurationEnum | This is record Inventor::BIMDuctFlowConfigurationEnum.
BIMDuctLossMethodEnum | This is record Inventor::BIMDuctLossMethodEnum.
BIMDuctSystemTypeEnum | This is record Inventor::BIMDuctSystemTypeEnum.
BIMElectricalPowerFactorStateEnum | This is record Inventor::BIMElectricalPowerFactorStateEnum.
BIMElectricalSystemTypeEnum | This is record Inventor::BIMElectricalSystemTypeEnum.
BIMFlowDirectionEnum | This is record Inventor::BIMFlowDirectionEnum.
BIMPipeConnectionTypeEnum | This is record Inventor::BIMPipeConnectionTypeEnum.
BIMPipeFlowConfigurationEnum | This is record Inventor::BIMPipeFlowConfigurationEnum.
BIMPipeLossMethodEnum | This is record Inventor::BIMPipeLossMethodEnum.
BIMPipeSystemTypeEnum | This is record Inventor::BIMPipeSystemTypeEnum.
BOMQuantityTypeEnum | This is record Inventor::BOMQuantityTypeEnum.
BOMStructureEnum | This is record Inventor::BOMStructureEnum.
BOMViewTypeEnum | This is record Inventor::BOMViewTypeEnum.
BooleanTypeEnum | This is record Inventor::BooleanTypeEnum.
BorderLabelModeEnum | Constants identifying the label mode of the zones in a drawing border.
BoreLine | Structure to hold an attributed ray for entity selection. More accurately, this is a selection cylinder, with a front and a back-plane and a radius.
BossTypeEnum | This is record Inventor::BossTypeEnum.
BoundaryPatchConditionEnum | This is record Inventor::BoundaryPatchConditionEnum.
BreakOrientationEnum | This is record Inventor::BreakOrientationEnum.
BreakOutDepthTypeEnum | This is record Inventor::BreakOutDepthTypeEnum.
BreakStyleEnum | This is record Inventor::BreakStyleEnum.
BrowserNodeDisplayStateEnum | Browser node display state
ButtonDisplayEnum | Button Display Style
ButtonTypeEnum | This is record Inventor::ButtonTypeEnum.
CenterlineTypeEnum | This is record Inventor::CenterlineTypeEnum.
CentermarkTypeEnum | This is record Inventor::CentermarkTypeEnum.
ChamferDefinitionTypeEnum | Constants identifying the definition type of a chamfer.
CircleDimensionTypeEnum | This is record Inventor::CircleDimensionTypeEnum.
ClientGraphicsTypeEnum | Property that gets the type of the ClientGraphics.
ColorBindingEnum | Constants identifying kind of application of the colors in the associated color-set.
ColorSourceTypeEnum | This is record Inventor::ColorSourceTypeEnum.
CommandBarTypeEnum | Command Bar Type
CommandIDEnum | This is record Inventor::CommandIDEnum.
CommandTypesEnum | Constants enumerating the various command types.
ComparisonTypeEnum | This is record Inventor::ComparisonTypeEnum.
ConstraintIncrementTypeEnum | Enum used to define the increment type for driving constraints.
ConstraintPriorityEnum | Constants indicating the preferred constraint type for automatic placement of constraints
ConstraintStatusEnum | This is record Inventor::ConstraintStatusEnum.
ContainmentEnum | Constants identifying containment of a point.
ContentCenterAccessOptionEnum | This is record Inventor::ContentCenterAccessOptionEnum.
ContentCenterInstanceStatusEnum | This is record Inventor::ContentCenterInstanceStatusEnum.
ContentCenterRSCResultEnum | This is record Inventor::ContentCenterRSCResultEnum.
ContentFamilyTypeEnum | This is record Inventor::ContentFamilyTypeEnum.
ContentItemTypeEnum | This is record Inventor::ContentItemTypeEnum.
ContentLibraryComponentTypeBits | Bits indicating the relationship of the model to data directly stored in the library.
ContentMemberRefreshEnum | This is record Inventor::ContentMemberRefreshEnum.
ContentUserRoleEnum | This is record Inventor::ContentUserRoleEnum.
ContinuityTypeEnum | This is record Inventor::ContinuityTypeEnum.
ControlDefinitionTypeEnum | Enum specifying the type of controldefinition
ControlTypeEnum | ControlType
CoordinateSystemPlaneEnum | This is record Inventor::CoordinateSystemPlaneEnum.
CornerDefinitionTypeEnum | This is record Inventor::CornerDefinitionTypeEnum.
CornerReliefShapeEnum | Constants identifying the corner relief shape.
CornerTypeEnum | This is record Inventor::CornerTypeEnum.
CursorHotSpotEnum | Interaction event Cursor hot spot enum
CursorTypeEnum | Interaction event Cursor Type enum
Curve2dTypeEnum | Constants enumerating the types of 2D curves.
CurveGeometryFormEnum | Constants enumerating the form of the curve geometry.
CurveTypeEnum | Constants enumerating the curve types.
CustomPropertyPrecisionEnum | This is record Inventor::CustomPropertyPrecisionEnum.
CustomPropertyTypeEnum | This is record Inventor::CustomPropertyTypeEnum.
DebugWatchType | This is record Inventor::DebugWatchType.
DecimalMarkerTypeEnum | Enum specifying the Decimal Marker type
DefaultDrawingFileTypeEnum | This is record Inventor::DefaultDrawingFileTypeEnum.
DefaultLayerStyleEnum | This is record Inventor::DefaultLayerStyleEnum.
DefaultNonInventorDWGFileOpenBehaviorEnum | This is record Inventor::DefaultNonInventorDWGFileOpenBehaviorEnum.
DefaultObjectStyleEnum | This is record Inventor::DefaultObjectStyleEnum.
DerivedComponentOptionEnum | Constants identifying inclusion for derived components.
DerivedComponentStyleEnum | This is record Inventor::DerivedComponentStyleEnum.
DerivedGeometryRemovalEnum | This is record Inventor::DerivedGeometryRemovalEnum.
DerivedHolePatchEnum | This is record Inventor::DerivedHolePatchEnum.
DerivedPartMirrorPlaneEnum | Constants identifying mirror plane.
DerivedPropertyTypeEnum | Constants identifying the type of derived property specified in formatted text objects.
DesignViewTypeEnum | This is record Inventor::DesignViewTypeEnum.
DialogStyleEnum | This is record Inventor::DialogStyleEnum.
DimensionAlignmentTypeEnum | Constants indicating the various types of dimension alignment
DimensionConstraintsRelaxationEnum | This is record Inventor::DimensionConstraintsRelaxationEnum.
DimensionDisplayTypeEnum | Constants enumerating the dimension display styles.
DimensionOrientationEnum | Constants identifying dimension orientation types.
DimensionStyleFormatEnum | Enum specifying the dimension style format
DimensionTextAlignmentEnum | This is record Inventor::DimensionTextAlignmentEnum.
DimensionTypeEnum | This is record Inventor::DimensionTypeEnum.
DirectionEnum | Constants identifying feature direction orientations.
DisplayFormatEnum | This is record Inventor::DisplayFormatEnum.
DisplayModeEnum | This is record Inventor::DisplayModeEnum.
DisplayModeSourceTypeEnum | This is record Inventor::DisplayModeSourceTypeEnum.
DisplayQualityEnum | This is record Inventor::DisplayQualityEnum.
DisplayTransformBehaviorEnum | Optional display options for Client Graphics primitives.
DockingStateEnum |
DocumentInterestTypeEnum | This is record Inventor::DocumentInterestTypeEnum.
DocumentTypeEnum | Constants enumerating document types.
DoubleBendTypeEnum | This is record Inventor::DoubleBendTypeEnum.
DraftingStandardEnum | Constants that enumerate the drafting standards currently known to Autodesk Inventor.
DragStateEnum | Enumeration of the conditions of the drag
DrawingEdgeTypeEnum | This is record Inventor::DrawingEdgeTypeEnum.
DrawingSheetSizeEnum | Constants that enumerate the drawing sheet sizes supported by Autodesk Inventor.
DrawingSheetStatusBits | Bits indicating out-of-date status of a drawing sheet.
DrawingViewAlignmentEnum | This is record Inventor::DrawingViewAlignmentEnum.
DrawingViewStyleEnum | Constants enumerating the drawing view style type.
DrawingViewTypeEnum | Constants that enumerate the drawing view types.
DWFPublishModeEnum | This is record Inventor::DWFPublishModeEnum.
DWGFileVersionEnum | This is record Inventor::DWGFileVersionEnum.
EdgeCollectionEnum | Constants identifying the collection type of edges.
EmbossTypeEnum | This is record Inventor::EmbossTypeEnum.
EnvironmentStateEnum | This is record Inventor::EnvironmentStateEnum.
EventTimingEnum | Codes specifying exactly when a particular event was fired (Before/After).
ExitTypeEnum | This is record Inventor::ExitTypeEnum.
FaceCollectionEnum | Constants identifying the collection type of faces
FactoryOptionsMemberNameTypeEnum | This is record Inventor::FactoryOptionsMemberNameTypeEnum.
FactoryOptionsPartNumberTypeEnum | This is record Inventor::FactoryOptionsPartNumberTypeEnum.
FamilyParameterValueTypeEnum | This is record Inventor::FamilyParameterValueTypeEnum.
FeatureApproximationTypeEnum | This is record Inventor::FeatureApproximationTypeEnum.
FeatureDimensionTypeEnum | This is record Inventor::FeatureDimensionTypeEnum.
FileFormatEnum | This is record Inventor::FileFormatEnum.
FileManagementEnum | Bits indicating valid entity types for iFeature input.
FileOwnershipEnum | This is record Inventor::FileOwnershipEnum.
FileTypeEnum | This is record Inventor::FileTypeEnum.
FileVersionEnum | This is record Inventor::FileVersionEnum.
FilletTypeEnum | This is record Inventor::FilletTypeEnum.
FlatPatternEdgeTypeEnum | This is record Inventor::FlatPatternEdgeTypeEnum.
FrontViewPlaneEnum | This is record Inventor::FrontViewPlaneEnum.
GeneralDataTypeEnum | This is record Inventor::GeneralDataTypeEnum.
GeneralDimensionTypeEnum | This is record Inventor::GeneralDimensionTypeEnum.
GeometricCharacteristicEnum | This is record Inventor::GeometricCharacteristicEnum.
GeometricConstraintsBreakageEnum | This is record Inventor::GeometricConstraintsBreakageEnum.
GeometryMoveableStatusEnum | This is record Inventor::GeometryMoveableStatusEnum.
GraphicsDriverTypeEnum | This is record Inventor::GraphicsDriverTypeEnum.
GraphicsLevelsOfDetailEnum | Bits indicating the levels of detail in the graphics system. It controls the fineness of the facets generated on the surfaces.
GraphicsOptimizationEnum | This is record Inventor::GraphicsOptimizationEnum.
GraphicsSelectabilityEnum | Indicates whether some, all, or none of the client graphics are selectable.
GraphicsSettingTypeEnum | This is record Inventor::GraphicsSettingTypeEnum.
GraphicsVisibilityEnum | Indicates whether some, all, or none of the client graphics are visible.
GroundShadowEnum | This is record Inventor::GroundShadowEnum.
HandlingCodeEnum | Codes returned from some events' methods.
HeadingPlacementEnum | HeadingPlacement
HealthStatusEnum | Constants signifying the state of the object.
HeightDatumTypeEnum | This is record Inventor::HeightDatumTypeEnum.
HemTypeEnum | This is record Inventor::HemTypeEnum.
HoleNoteQuantityEnum | This is record Inventor::HoleNoteQuantityEnum.
HolePlacementTypeEnum | Hole Placement Type enum
HolePropertyEnum |
HoleTableTypeEnum |
HoleTypeEnum | Constants identifying the type of treatment given to the start of the hole.
HorizontalTextAlignmentEnum | Constants identifying the horizontal positioning of text about a given point coordinate.
iComponentColumnTypeEnum | This is record Inventor::iComponentColumnTypeEnum.
IconsColorTypeEnum | This is record Inventor::IconsColorTypeEnum.
iFeatureEntityInputTypeEnum | Bits indicating valid entity types for iFeature input.
iFeatureParamLimitTypeEnum | Constants identifying the parameter limit type.
InferredTypeEnum | Constants that define the types of geometry that can be inferred from different faces.
InspectionDimensionShapeEnum | This is record Inventor::InspectionDimensionShapeEnum.
IntentTypeEnum | This is record Inventor::IntentTypeEnum.
InteractionEventsEnum | Constants identifying which events are active during interaction.
InteractiveContactAnalysisEnum | This is record Inventor::InteractiveContactAnalysisEnum.
InteractiveContactSurfacesEnum | This is record Inventor::InteractiveContactSurfacesEnum.
InterfaceStyleEnum | This is record Inventor::InterfaceStyleEnum.
IOMechanismEnum | Constants identifying the type of an input-output operation.
LayDirectionTypeEnum | This is record Inventor::LayDirectionTypeEnum.
LevelOfDetailEnum | This is record Inventor::LevelOfDetailEnum.
LightDefinitionTypeEnum | This is record Inventor::LightDefinitionTypeEnum.
LightTypeEnum | This is record Inventor::LightTypeEnum.
LinearDimensionTypeEnum | This is record Inventor::LinearDimensionTypeEnum.
LinearPrecisionEnum | Enum specifying the precision for linear dimensions
LineDefinitionSpaceEnum | Enum indicating various line font definition space types
LineSpacingEnum | LineSpacing
LineTypeEnum | Enum indicating various color source types
LineWeightTypeEnum | This is record Inventor::LineWeightTypeEnum.
LinkStatusEnum | This is record Inventor::LinkStatusEnum.
LocationTypeEnum | Constants that enumerate file location types.
LoftConditionEnum | Constants identifying the loft condition.
LoftedFlangeOutputTypeEnum | This is record Inventor::LoftedFlangeOutputTypeEnum.
LoftTypeEnum | This is record Inventor::LoftTypeEnum.
MassPropertiesAccuracyEnum | Constants specifying the different computational accuracies of the mass property calculations.
MaterialRemovalModifierEnum | This is record Inventor::MaterialRemovalModifierEnum.
MeasureTypeEnum | This is record Inventor::MeasureTypeEnum.
MediumTypeEnum | This is record Inventor::MediumTypeEnum.
MemberEditScopeEnum | This is record Inventor::MemberEditScopeEnum.
MemberManagerErrorsEnum | This is record Inventor::MemberManagerErrorsEnum.
MemberTypeEnum | Autodesk Inventor's VBA Member Type.
MemorySavingModeEnum | This is record Inventor::MemorySavingModeEnum.
MiniToolbarControlTypeEnum | Specifies the MiniToolbar control type. kButton kCheckBox kComboBox kDropdown kLabel kNewLine kSeparator kValueEditor
ModelDiameterFromThreadEnum | Constants identifying the specific diameter out of the thread definition that is to be used for modeling.
ModelValueTypeEnum | Settings for computing model value of a parameter.
MouseButtonEnum | Enumeration of the buttons on a mouse.
MouseDragStateEnum | Enumeration of the conditions of the mouse drag.
MoveFaceTypeEnum | Defines the constants used to specify the type of move face.
MultiUserModeEnum | Constants indicating various multi-user modes
NormalBindingEnum | Constants identifying the kind of application of the normals in the associated normal-set.
NumberingSchemeEnum | This is record Inventor::NumberingSchemeEnum.
OccurrenceDOFStateEnum | This is record Inventor::OccurrenceDOFStateEnum.
OfflineImageFidelityEnum | Enum indicating the printing quality for a shaded drawing view when defer updates is active
OLEDocumentTypeEnum | Constants that enumerate OLE document types.
OLEVerbEnum | Constants that enumerate actions that can be performed on an OLE attachment.
OrbitTypeEnum | This is record Inventor::OrbitTypeEnum.
OverConstrainedDimensionBehaviorEnum | Constants indicating the preferred behavior when placing dimensions on overconstrained sketches
PageOrientationTypeEnum | Constants that enumerate the page orientation styles.
PaperSizeEnum | Constants enumerating the various sizes of paper to be used for printing.
ParameterDisplayFormatEnum | This is record Inventor::ParameterDisplayFormatEnum.
ParameterTypeEnum | Constants that enumerate parameter types.
PartFeatureExtentDirectionEnum | Constants identifying the direction in which a feature extension needs to take place.
PartFeatureExtentEnum | Constants identifying the type of Boolean operation to be performed during this feature placement.
PartFeatureOperationEnum | Constants identifying the type of Boolean operation to be performed during this feature placement.
PartsListFileFormatEnum | PartsList File Format Enum
PartsListLevelEnum | PartsListLevel
PatternComputeTypeEnum | Constants identifying the pattern compute type
PatternOrientationEnum | Constants identifying the pattern orientation method.
PatternSpacingTypeEnum | Constants identifying the pattern spacing type.
PhysicalPropertyEnum | This is record Inventor::PhysicalPropertyEnum.
PointInferenceEnum | Constants identifying the enumerations of the PointInference object.
PointIntentEnum | This is record Inventor::PointIntentEnum.
PointRenderStyleEnum | Constants identifying the type of rendering to be performed on a point graphics primitive.
PrefixAndSuffixOrderEnum | Enum specifying the location of prefix and suffix
PrintColorModeEnum | Constants denoting the color mode being used.
PrintOrientationEnum | Constants denoting the orientation of the print.
PrintRangeEnum | Constants enumerating the methods of specifying the range of sheets to be printed.
PrintScaleModeEnum | Constants enumerating the methods of specifying the scale of the print.
PrivateEventTypeEnum | Semantic description of data on Autodesk Inventor's private event queue.
ProductEditionEnum | This is record Inventor::ProductEditionEnum.
ProjectionTypeEnum | This is record Inventor::ProjectionTypeEnum.
PromptMessageRestrictionsEnum | This is record Inventor::PromptMessageRestrictionsEnum.
PropertyTypeEnum | PropertyType
PunchNoteQuantityEnum | This is record Inventor::PunchNoteQuantityEnum.
PunchRepresentationTypeEnum | This is record Inventor::PunchRepresentationTypeEnum.
RayTracingQualityEnum | This is record Inventor::RayTracingQualityEnum.
ReferenceMonitoringEnum | This is record Inventor::ReferenceMonitoringEnum.
ReferenceStatusEnum | Constants signifying the state of the File Reference
RevisionTablePropertyEnum | This is record Inventor::RevisionTablePropertyEnum.
RevisionTagShapeEnum | This is record Inventor::RevisionTagShapeEnum.
RibbonAppearanceEnum | This is record Inventor::RibbonAppearanceEnum.
RibbonDockingStateEnum | This is record Inventor::RibbonDockingStateEnum.
RibbonStateEnum | This is record Inventor::RibbonStateEnum.
RibFeatureExtentEnum | This is record Inventor::RibFeatureExtentEnum.
RibThicknessPlaneEnum | This is record Inventor::RibThicknessPlaneEnum.
RigidBodyJointTypeEnum | This is record Inventor::RigidBodyJointTypeEnum.
RipTypeEnum | This is record Inventor::RipTypeEnum.
RowMergeTypeEnum | This is record Inventor::RowMergeTypeEnum.
SelectionDeviceEnum | Enumeration of the kind of UI used to select object.
SelectionFilterEnum | Enumeration of the selection filters.
SelectionPriorityEnum | This is record Inventor::SelectionPriorityEnum.
SelectPrism | DMAC structure to hold an attributed selection prism for entity selection.
SelectType | DMAC list of bit-fields that are used to specify the selection region relative to a shape.
ShadowDirectionEnum | This is record Inventor::ShadowDirectionEnum.
SheetMetalPropertyEnum | This is record Inventor::SheetMetalPropertyEnum.
ShellDirectionEnum | Enum specifying the shell boundary relative to the part face
ShiftStateEnum | Enumeration of the 'shift' key (SHIFT, CTRL and ALT) combination.
ShortcutTypeEnum | This is record Inventor::ShortcutTypeEnum.
SketchCreationOnNewPartEnum | This is record Inventor::SketchCreationOnNewPartEnum.
SolutionNatureEnum | Type that characterizes the result of a solution search.
SplineFitMethodEnum | Constants identifying the fit type of a spline.
SplitToolTypeEnum | Constants identifying the kind of split tool.
SplitTypeEnum | Constants identifying the kind of split.
StandardPartsSectionBehaviorEnum | This is record Inventor::StandardPartsSectionBehaviorEnum.
StartupActionTypeEnum | This is record Inventor::StartupActionTypeEnum.
StartupHelpFocusTopicEnum | This is record Inventor::StartupHelpFocusTopicEnum.
StorageTypeEnum | Type to indicate the kind of storage medium being referred to.
StyleLocationEnum | Enum for the different style location types
StylesLibraryAccessEnum | This is record Inventor::StylesLibraryAccessEnum.
StyleSourceTypeEnum | Render style source type
StyleTypeEnum | This is record Inventor::StyleTypeEnum.
SurfaceGeometryFormEnum | Constants enumerating forms of surface geometry.
SurfaceTextureTypeEnum | This is record Inventor::SurfaceTextureTypeEnum.
SurfaceTypeEnum | Constants enumerating the surface types.
SweepDefinitionTypeEnum | This is record Inventor::SweepDefinitionTypeEnum.
SweepProfileOrientationEnum | This is record Inventor::SweepProfileOrientationEnum.
SweepProfileScalingEnum | This is record Inventor::SweepProfileScalingEnum.
SystemOfMeasureEnum | Constants that enumerate the types of measurement systems (Metric, English, etc.).
TableDirectionEnum | TableDirection
TableSourceTypeEnum | This is record Inventor::TableSourceTypeEnum.
TextureDimensionEnum | This is record Inventor::TextureDimensionEnum.
TextLineSpacingTypeEnum | Constants identifying the line spacing type.
ThreadTypeEnum | Constants identifying the kind of thread.
ThumbnailSaveOptionEnum | This is record Inventor::ThumbnailSaveOptionEnum.
TitleBlockAlignmentEnum | This is record Inventor::TitleBlockAlignmentEnum.
TitleBlockLocationEnum | Constants identifying the position of the title block on the sheet.
ToleranceTypeEnum | Constants identifying tolerance types.
TransactionPointEnum | Symbolic indicators to specific points in the transaction sequence.
TransactionStateEnum | Enum indicating various transaction states
TransparencyTypeEnum | This is record Inventor::TransparencyTypeEnum.
TriadMoveTypeEnum | Enum indicating various actions that cause a triad move
TriadSegmentEnum | Triad segment type enum
UCSDefinitionTypeEnum | This is record Inventor::UCSDefinitionTypeEnum.
UnfoldMethodEquationTypeEnum | This is record Inventor::UnfoldMethodEquationTypeEnum.
UnfoldMethodTypeEnum | Constants identifying the UnfoldMethod Type.
UniqueOccurrencesBehaviorEnum | Defines the unique behaviors that can be assigned to specific occurrences to define how that occurrence is treated during the rigid body analysis. The values of the enums can be used as a bit mask so that these various options can be combined into a single value.
UnitsTypeEnum | Units Types. Each signifies a specific unit in a particular dimension or category of measurement.
UpdatePropertiesOnSaveForFileTypeEnum | This is record Inventor::UpdatePropertiesOnSaveForFileTypeEnum.
ValueTypeEnum | Constants enumerating the various types of values.
ValueUnitsTypeEnum | Specifies the units type. kAngleUnits kAngularVelocityUnits kAreaUnits kCurrentUnits kForceUnits kLengthUnits kMassUnits kPowerUnits kPressureUnits kSpeedUnits kTemperatureUnits kTimeUnits kUnitless kVoltageUnits kVolumeUnits kWorkUnits
VBAProjectTypeEnum | Autodesk Inventor's VBA Project Type.
VerticalTextAlignmentEnum | Constants identifying the vertical positioning of text about a given point coordinate.
ViewBlockInsertionPointEnum | This is record Inventor::ViewBlockInsertionPointEnum.
ViewJustificationEnum | This is record Inventor::ViewJustificationEnum.
ViewLayoutEnum | View-relative enum
ViewOperationTypeEnum | View operation type.
ViewOrientationTypeEnum | View orientation type.
ViewPreviewTypeEnum | This is record Inventor::ViewPreviewTypeEnum.
ViewTypeEnum | Constants that enumerate view types.
WeldmentFeatureGroupEnum | Constants that enumerate weldment feature group types.
WeldmentStateEnum | This is record Inventor::WeldmentStateEnum.
WindowsSizeEnum | Constants that enumerate window size.
WorkAxisDefinitionEnum | Constants identifying work axis definition types.
WorkPlaneDefinitionEnum | Constants identifying work plane definition types.
WorkPointDefinitionEnum | Constants identifying work point definition types.
ZoomTargetComponentWithiMateEnum | This is record Inventor::ZoomTargetComponentWithiMateEnum.
You are here: Symbol Reference > Inventor Library


AliasFreeformFeature Interface

AliasFreeformFeature Interface
Summary

The feature that's created as a result of the user using the Alias Design for Inventor application to edit an Inventor model.

Class Hierarchy
Inventor::PartFeature
    Inventor::AliasFreeformFeature
        Inventor::AliasFreeformFeatureProxy
Visual Basic
Public Interface AliasFreeformFeature
Inherits PartFeature
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeature Interface


AliasFreeformFeature Methods

AliasFreeformFeature Methods
Summary

The methods of the AliasFreeformFeature class are listed here.

Methods
Methods
Name | Description
_Redefine | This is _Redefine, a member of class AliasFreeformFeature.
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeature Interface > AliasFreeformFeature Methods


AliasFreeformFeature._Redefine Method

AliasFreeformFeature._Redefine Method
Summary

This is _Redefine, a member of class AliasFreeformFeature.

Visual Basic
Sub _Redefine( As SurfaceBody)
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeature Interface > AliasFreeformFeature Methods > AliasFreeformFeature._Redefine Method


AliasFreeformFeatureProxy Interface

AliasFreeformFeatureProxy Interface
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the AliasFreeFormFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::AliasFreeformFeature
        Inventor::AliasFreeformFeatureProxy
Visual Basic
Public Interface AliasFreeformFeatureProxy
Inherits AliasFreeformFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatureProxy Interface


AliasFreeformFeatures Interface

AliasFreeformFeatures Interface
Summary

The AliasFreeFormFeatures collection object provides access to existing AliasFreeFormFeature objects.

Class Hierarchy
Inventor::AliasFreeformFeatures
Visual Basic
Public Interface AliasFreeformFeatures
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface


AliasFreeformFeatures Methods

AliasFreeformFeatures Methods
Summary

The methods of the AliasFreeformFeatures class are listed here.

Methods
Methods
Name | Description
_Add | This is _Add, a member of class AliasFreeformFeatures.
Item |
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Methods


AliasFreeformFeatures._Add Method

AliasFreeformFeatures._Add Method
Summary

This is _Add, a member of class AliasFreeformFeatures.

Visual Basic
Sub _Add(BaseBody As SurfaceBody, Result As [out, retval] AliasFreeformFeature*)
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Methods > AliasFreeformFeatures._Add Method


AliasFreeformFeatures.Item Method

AliasFreeformFeatures.Item Method
Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] AliasFreeformFeature*)
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Methods > AliasFreeformFeatures.Item Method


AliasFreeformFeatures Properties

AliasFreeformFeatures Properties
Summary

The properties of the AliasFreeformFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Properties


AliasFreeformFeatures.Application Property

AliasFreeformFeatures.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Properties > AliasFreeformFeatures.Application Property


AliasFreeformFeatures.Count Property

AliasFreeformFeatures.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Properties > AliasFreeformFeatures.Count Property


AliasFreeformFeatures.Type Property

AliasFreeformFeatures.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AliasFreeformFeatures Interface > AliasFreeformFeatures Properties > AliasFreeformFeatures.Type Property


AddInAutomation CoClass

AddInAutomation CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

IUnknown of its Automation interface that an AddIn may return. Enables other applications to get at it.

Class Hierarchy
Inventor::AddInAutomation
Visual Basic
Public Class AddInAutomation
Remarks

See the Addins overview articles for more information.

You are here: Symbol Reference > Inventor Library > Objects > AddInAutomation CoClass


AnalysisManager Interface

AnalysisManager Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The AnalysisManager object provides access to all types of surface analysis in a part document.

Class Hierarchy
Inventor::AnalysisManager
Visual Basic
Public Interface AnalysisManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DraftAnalysis.Parent

PartComponentDefinition.AnalysisManager

You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface


AnalysisManager Properties

AnalysisManager Properties
Summary

The properties of the AnalysisManager class are listed here.

Properties
Name | Description
ActiveAnalysis | Property that returns the active analysis object.
ActiveAnalysisType | Property that returns the enum indicating the type of the currently active analysis.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DraftAnalyses | Property that returns the DraftAnalyses collection object.
IsAnalysisVisible | Boolean property that gets and sets whether the analysis visibility is turned on.
Parent | Property that returns the parent ComponentDefinition object.
Type | Property returning kAnalysisManagerObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties


AnalysisManager.ActiveAnalysis Property

AnalysisManager.ActiveAnalysis Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the active analysis object.

Visual Basic
Property ActiveAnalysis() As IDispatch**
Remarks

Since this property only returns a generic object, the exact type of the object can be determined by querying the ActiveAnalysisType property which returns an enum indicating the type of the active analysis (draft analysis, zebra analysis etc.). This property will return Nothing if no analysis has been created. This property will return the active analysis object irrespective of whether the analysis visibility is turned on or off.

Notes

Currently, the API only supports draft analysis objects. Therefore, if a draft analysis is currently active, then this property will return a draft analysis object. If any other type of analysis is active, then this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.ActiveAnalysis Property


AnalysisManager.ActiveAnalysisType Property

AnalysisManager.ActiveAnalysisType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the enum indicating the type of the currently active analysis.

Visual Basic
Property ActiveAnalysisType() As AnalysisTypeEnum*
Remarks

The value returned by this property indicates the type of object returned by the ActiveAnalysis property. The valid return values are kCrossSectionAnalysis, kCurvatureAnalysis, kDraftAnalysis, kSurfaceAnalysis, kZebraAnalysis and kNoAnalysis. If no analysis is active, then this property will return kNoAnalysis and the ActiveAnalysis object will return Nothing. This property will return the type of active analysis irrespective of whether the analysis visibility is turned on or off.

You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.ActiveAnalysisType Property


AnalysisManager.Application Property

AnalysisManager.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.Application Property


AnalysisManager.DraftAnalyses Property

AnalysisManager.DraftAnalyses Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the DraftAnalyses collection object.

Visual Basic
Property DraftAnalyses() As DraftAnalyses**
You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.DraftAnalyses Property


AnalysisManager.IsAnalysisVisible Property

AnalysisManager.IsAnalysisVisible Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Boolean property that gets and sets whether the analysis visibility is turned on.

Visual Basic
Property IsAnalysisVisible() As VARIANT_BOOL
Remarks

Setting this property to True will turn on the visibility for the currently active analysis. The ActiveAnalysis property returns the analysis object that represents the currently active analysis.

You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.IsAnalysisVisible Property


AnalysisManager.Parent Property

AnalysisManager.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.Parent Property


AnalysisManager.Type Property

AnalysisManager.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kAnalysisManagerObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AnalysisManager Interface > AnalysisManager Properties > AnalysisManager.Type Property


AnalyticEdgeWorkAxisDef Interface

AnalyticEdgeWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Object that allows you to get and set the information that specifies a work axis using an analytic edge.

Class Hierarchy
Inventor::AnalyticEdgeWorkAxisDef
Visual Basic
Public Interface AnalyticEdgeWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > AnalyticEdgeWorkAxisDef Interface


AnalyticEdgeWorkAxisDef Properties

AnalyticEdgeWorkAxisDef Properties
Summary

The properties of the AnalyticEdgeWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Edge | Property that returns an Edge object that can be a circle, arc, or an ellipse.
Parent | Property that returns the parent WorkAxis object.
Type | Property that returns kAnalyticEdgeWorkAxisDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > AnalyticEdgeWorkAxisDef Interface > AnalyticEdgeWorkAxisDef Properties


AnalyticEdgeWorkAxisDef.Application Property

AnalyticEdgeWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AnalyticEdgeWorkAxisDef Interface > AnalyticEdgeWorkAxisDef Properties > AnalyticEdgeWorkAxisDef.Application Property


AnalyticEdgeWorkAxisDef.Edge Property

AnalyticEdgeWorkAxisDef.Edge Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an Edge object that can be a circle, arc, or an ellipse.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > AnalyticEdgeWorkAxisDef Interface > AnalyticEdgeWorkAxisDef Properties > AnalyticEdgeWorkAxisDef.Edge Property


AnalyticEdgeWorkAxisDef.Parent Property

AnalyticEdgeWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > AnalyticEdgeWorkAxisDef Interface > AnalyticEdgeWorkAxisDef Properties > AnalyticEdgeWorkAxisDef.Parent Property


AnalyticEdgeWorkAxisDef.Type Property

AnalyticEdgeWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns kAnalyticEdgeWorkAxisDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AnalyticEdgeWorkAxisDef Interface > AnalyticEdgeWorkAxisDef Properties > AnalyticEdgeWorkAxisDef.Type Property


AngleConstraint Interface

AngleConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents an angle assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::AngleConstraint
        Inventor::AngleConstraintProxy
Visual Basic
Public Interface AngleConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AngleConstraintProxy.NativeObject

AssemblyConstraint.ConvertToAngleConstraint

AssemblyConstraints.AddAngleConstraint

LayoutConstraint.ZAngleConstraint

You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface


AngleConstraint Methods

AngleConstraint Methods
Summary

The methods of the AngleConstraint class are listed here.

Methods
Methods
Name | Description
Directed | Property that controls whether the angle constraint results in a single solution. Directed (true) means the solution always applies the right-hand-rule. Undirected (false) allows either orientation.
DirectionOneReversed | Property that gets the vector direction of the first entity.
DirectionTwoReversed | Property that gets the vector direction of the second entity.
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Methods


AngleConstraint.Directed Method

AngleConstraint.Directed Method Available in Inventor Available in Server
Summary

Property that controls whether the angle constraint results in a single solution. Directed (true) means the solution always applies the right-hand-rule. Undirected (false) allows either orientation.

Visual Basic
Sub Directed(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Methods > AngleConstraint.Directed Method


AngleConstraint.DirectionOneReversed Method

AngleConstraint.DirectionOneReversed Method Available in Inventor Available in Server
Summary

Property that gets the vector direction of the first entity.

Visual Basic
Sub DirectionOneReversed(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Methods > AngleConstraint.DirectionOneReversed Method


AngleConstraint.DirectionTwoReversed Method

AngleConstraint.DirectionTwoReversed Method Available in Inventor Available in Server
Summary

Property that gets the vector direction of the second entity.

Visual Basic
Sub DirectionTwoReversed(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Methods > AngleConstraint.DirectionTwoReversed Method


AngleConstraint Properties

AngleConstraint Properties
Summary

The properties of the AngleConstraint class are listed here.

Properties
Name | Description
Angle | Property that returns the object that controls the angle of the constraint.
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.
ReferenceVectorEntity | Property that returns the third (reference vector) entity the constraint it tied to.
SolutionType | Property that returns the solution type.
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Properties


AngleConstraint.Angle Property

AngleConstraint.Angle Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the object that controls the angle of the constraint.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Properties > AngleConstraint.Angle Property


AngleConstraint.ConstraintLimits Property

AngleConstraint.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Properties > AngleConstraint.ConstraintLimits Property


AngleConstraint.ReferenceVectorEntity Property

AngleConstraint.ReferenceVectorEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the third (reference vector) entity the constraint it tied to.

Visual Basic
Property ReferenceVectorEntity() As IDispatch**
Remarks

This property returns Nothing if the SolutionType property is not kReferenceVectorSolution.

You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Properties > AngleConstraint.ReferenceVectorEntity Property


AngleConstraint.SolutionType Property

AngleConstraint.SolutionType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the solution type.

Visual Basic
Property SolutionType() As AngleConstraintSolutionTypeEnum*
Remarks

This can return kDirectedSolution (if the angle is calculated with the right hand rule), kUndirectedSolution (if the solution allows either orientation, thus resolving situations where component orientation flips during a constraint drive or drag) or kReferenceVectorSolution (if a third entity is specified). If the property returns kReferenceVectorSolution, the ReferenceVectorEntity property can be used to query the third (reference vector) entity.

You are here: Symbol Reference > Inventor Library > Objects > AngleConstraint Interface > AngleConstraint Properties > AngleConstraint.SolutionType Property


AngleConstraintProxy Interface

AngleConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the AngleConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::AngleConstraint
        Inventor::AngleConstraintProxy
Visual Basic
Public Interface AngleConstraintProxy
Inherits AngleConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > AngleConstraintProxy Interface


AngleConstraintProxy Properties

AngleConstraintProxy Properties
Summary

The properties of the AngleConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence |
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > AngleConstraintProxy Interface > AngleConstraintProxy Properties


AngleConstraintProxy.ContainingOccurrence Property

AngleConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Notes

For information on this item, please refer to CollinearConstraintProxy::ContainingOccurrence, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > AngleConstraintProxy Interface > AngleConstraintProxy Properties > AngleConstraintProxy.ContainingOccurrence Property


AngleConstraintProxy.NativeObject Property

AngleConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As AngleConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > AngleConstraintProxy Interface > AngleConstraintProxy Properties > AngleConstraintProxy.NativeObject Property


AngleExtent Interface

AngleExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The AngleExtent object provides access to the information that defines the extent for a feature using an angle.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::AngleExtent
Visual Basic
Public Interface AngleExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > AngleExtent Interface


AngleExtent Properties

AngleExtent Properties
Summary

The properties of the AngleExtent class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter that controls the sweep angle of the revolution.
Direction | Property that indicates the distance direction of the feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
You are here: Symbol Reference > Inventor Library > Objects > AngleExtent Interface > AngleExtent Properties


AngleExtent.Angle Property

AngleExtent.Angle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that controls the sweep angle of the revolution.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > AngleExtent Interface > AngleExtent Properties > AngleExtent.Angle Property


AngleExtent.Direction Property

AngleExtent.Direction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates the distance direction of the feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > AngleExtent Interface > AngleExtent Properties > AngleExtent.Direction Property


AngleiMateDefinition Interface

AngleiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The AngleiMateDefinition object represents an angle iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::AngleiMateDefinition
        Inventor::AngleiMateDefinitionProxy
Visual Basic
Public Interface AngleiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddAngleiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinition Interface


AngleiMateDefinition Properties

AngleiMateDefinition Properties
Summary

The properties of the AngleiMateDefinition class are listed here.

Properties
Name | Description
Angle | Property that returns the Parameter object that controls the angle of the angle iMate definition.
DirectionOneReversed | Property that gets whether the direction is reversed.
Entity | Property that returns the entity used for the iMate definition.
You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinition Interface > AngleiMateDefinition Properties


AngleiMateDefinition.Angle Property

AngleiMateDefinition.Angle Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the angle of the angle iMate definition.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinition Interface > AngleiMateDefinition Properties > AngleiMateDefinition.Angle Property


AngleiMateDefinition.DirectionOneReversed Property

AngleiMateDefinition.DirectionOneReversed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets whether the direction is reversed.

Visual Basic
Property DirectionOneReversed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinition Interface > AngleiMateDefinition Properties > AngleiMateDefinition.DirectionOneReversed Property


AngleiMateDefinition.Entity Property

AngleiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinition Interface > AngleiMateDefinition Properties > AngleiMateDefinition.Entity Property


AngleiMateDefinitionProxy Interface

AngleiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the AngleiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::AngleiMateDefinition
        Inventor::AngleiMateDefinitionProxy
Visual Basic
Public Interface AngleiMateDefinitionProxy
Inherits AngleiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinitionProxy Interface


AngleiMateDefinitionProxy Properties

AngleiMateDefinitionProxy Properties
Summary

The properties of the AngleiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether the iMateDefinition is consumed in the context of the active assembly.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinitionProxy Interface > AngleiMateDefinitionProxy Properties


AngleiMateDefinitionProxy.ContainingOccurrence Property

AngleiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinitionProxy Interface > AngleiMateDefinitionProxy Properties > AngleiMateDefinitionProxy.ContainingOccurrence Property


AngleiMateDefinitionProxy.IsConsumed Property

AngleiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether the iMateDefinition is consumed in the context of the active assembly.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinitionProxy Interface > AngleiMateDefinitionProxy Properties > AngleiMateDefinitionProxy.IsConsumed Property


AngleiMateDefinitionProxy.NativeObject Property

AngleiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > AngleiMateDefinitionProxy Interface > AngleiMateDefinitionProxy Properties > AngleiMateDefinitionProxy.NativeObject Property


AngularGeneralDimension Interface

AngularGeneralDimension Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The AngularGeneralDimension object represents an angular general dimension placed on a sheet.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
        Inventor::AngularGeneralDimension
Visual Basic
Public Interface AngularGeneralDimension
Inherits GeneralDimension
Notes

Members through which this object may be accessed include:

GeneralDimensions.AddAngular

See Also

Center Dimension Text sample

You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface


AngularGeneralDimension Methods

AngularGeneralDimension Methods
Summary

The methods of the AngularGeneralDimension class are listed here.

Methods
Methods
Name | Description
CenterText | Method that centers the dimension text on the dimension line.
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Methods


AngularGeneralDimension.CenterText Method

AngularGeneralDimension.CenterText Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that centers the dimension text on the dimension line.

Visual Basic
Sub CenterText()
Example

"Center Dimension Text"

"This sample demonstrates how to center the text of all dimensions on the active sheet in a drawing. Only linear and angular general dimensions are supported. Open a drawing document that contains several dimensions and run the sample."

Public Sub CenterAllDimensions()

    ' Set a reference to the active drawing document
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet
    Dim oSheet As Sheet
    Set oSheet = oDoc.ActiveSheet

    Dim oDrawingDim As DrawingDimension

    ' Iterate over all dimensions in the drawing and
    ' center them if they are linear or angular.

    For Each oDrawingDim In oSheet.DrawingDimensions
        If TypeOf oDrawingDim Is LinearGeneralDimension Or _
           TypeOf oDrawingDim Is AngularGeneralDimension Then
            Call oDrawingDim.CenterText
        End If
    Next

End Sub
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Methods > AngularGeneralDimension.CenterText Method


AngularGeneralDimension Properties

AngularGeneralDimension Properties
Summary

The properties of the AngularGeneralDimension class are listed here.

Properties
Name | Description
AngularPrecision | Property that gets and sets the number of decimal places displayed for angular dimension. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.
ExtensionLineOne | Property that returns the first extension line of the dimension.
ExtensionLineOneVisible | Property that gets and sets whether the first extension line is visible.
ExtensionLineTwo | Property that returns the second extension line of the dimension.
ExtensionLineTwoVisible | Property that gets and sets whether the second extension line is visible.
IntentOne | Property that gets and sets the first geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IntentTwo | Property that gets and sets the second geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IntentThree | Property that gets and sets the third geometry associated with the dimension. This may return Nothing in some cases where two edges or two arc end points were used for the dimension creation. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
OppositeAngle | Property that gets and sets whether to dimension the opposite angle.
ShowLeader | Property that gets and sets whether to display a leader line for the dimension text.
ToleranceAngularPrecision | Property that gets and sets the number of decimal places displayed for this angular dimension's tolerance. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.
UseQuadrant | Property that gets and sets whether to use the quadrant in which the input text point lies to decide which angle to dimension. This property is read-only for angular dimensions created with a single (arc) intent.
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties


AngularGeneralDimension.AngularPrecision Property

AngularGeneralDimension.AngularPrecision Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the number of decimal places displayed for angular dimension. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

Visual Basic
Property AngularPrecision() As AngularPrecisionEnum
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.AngularPrecision Property


AngularGeneralDimension.ExtensionLineOne Property

AngularGeneralDimension.ExtensionLineOne Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the first extension line of the dimension.

Visual Basic
Property ExtensionLineOne() As IDispatch**
Remarks

This property may return Nothing in cases where there are no extension lines. The object returned by this property is a LineSegment2d in sheet space for projected dimensions and LineSegment in model space for true (iso) dimensions.

You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.ExtensionLineOne Property


AngularGeneralDimension.ExtensionLineOneVisible Property

AngularGeneralDimension.ExtensionLineOneVisible Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the first extension line is visible.

Visual Basic
Property ExtensionLineOneVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.ExtensionLineOneVisible Property


AngularGeneralDimension.ExtensionLineTwo Property

AngularGeneralDimension.ExtensionLineTwo Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the second extension line of the dimension.

Visual Basic
Property ExtensionLineTwo() As IDispatch**
Remarks

This property may return Nothing in cases where there are no extension lines. The object returned by this property is a LineSegment2d in sheet space for projected dimensions and LineSegment in model space for true (iso) dimensions.

You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.ExtensionLineTwo Property


AngularGeneralDimension.ExtensionLineTwoVisible Property

AngularGeneralDimension.ExtensionLineTwoVisible Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the second extension line is visible.

Visual Basic
Property ExtensionLineTwoVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.ExtensionLineTwoVisible Property


AngularGeneralDimension.IntentOne Property

AngularGeneralDimension.IntentOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the first geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property IntentOne() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.IntentOne Property


AngularGeneralDimension.IntentTwo Property

AngularGeneralDimension.IntentTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the second geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property IntentTwo() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.IntentTwo Property


AngularGeneralDimension.IntentThree Property

AngularGeneralDimension.IntentThree Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the third geometry associated with the dimension. This may return Nothing in some cases where two edges or two arc end points were used for the dimension creation. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property IntentThree() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.IntentThree Property


AngularGeneralDimension.OppositeAngle Property

AngularGeneralDimension.OppositeAngle Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to dimension the opposite angle.

Visual Basic
Property OppositeAngle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.OppositeAngle Property


AngularGeneralDimension.ShowLeader Property

AngularGeneralDimension.ShowLeader Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to display a leader line for the dimension text.

Visual Basic
Property ShowLeader() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.ShowLeader Property


AngularGeneralDimension.ToleranceAngularPrecision Property

AngularGeneralDimension.ToleranceAngularPrecision Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the number of decimal places displayed for this angular dimension's tolerance. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

Visual Basic
Property ToleranceAngularPrecision() As AngularPrecisionEnum
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.ToleranceAngularPrecision Property


AngularGeneralDimension.UseQuadrant Property

AngularGeneralDimension.UseQuadrant Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to use the quadrant in which the input text point lies to decide which angle to dimension. This property is read-only for angular dimensions created with a single (arc) intent.

Visual Basic
Property UseQuadrant() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AngularGeneralDimension Interface > AngularGeneralDimension Properties > AngularGeneralDimension.UseQuadrant Property


Application Interface

Application Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Autodesk Inventor Application object.

Class Hierarchy
Inventor::Application
Visual Basic
Public Interface Application
Inherits InventorServerObject
Notes

Members through which this object may be accessed include:

ApplicationAddInSite.Application

BrowserFoldersEnumerator.Application

BrowserNodesEnumerator.Application

CommandBar.Application

CommandBar.Parent

CommandBarBaseCollection.Application

CommandBarControl.Application

CommandBarControls.Application

CommandBarList.Application

CommandBars.Application

CommandCategories.Application

CommandCategory.Application

CommandControl.Application

CommandControls.Application

CommandControlsEnumerator.Application

CommandManager.Parent

ContentCenter.Parent

ControlDefinition.Application

ControlDefinitionEventsObject.Application

ControlDefinitions.Application

DisabledCommandList.Application

Environment.Application

Environment.Parent

EnvironmentBase.Application

EnvironmentBase.Parent

EnvironmentBaseCollection.Application

EnvironmentList.Application

EnvironmentManager.Application

Environments.Application

FileUIEventsObject.Application

FileUIEventsObject.Parent

HelpManager.Parent

InteractionEventsObject.Application

InventorVBAProject.Parent

InventorVBAProjects.Parent

KeyboardEventsObject.Application

MeasureEventsObject.Application

MouseEventsObject.Application

PanelBarObject.Application

ProgressiveToolTip.Application

Ribbon.Application

RibbonPanel.Application

RibbonPanels.Application

Ribbons.Application

RibbonTab.Application

RibbonTabs.Application

SelectEventsObject.Application

TriadEventsObject.Application

UserInputEventsObject.Application

UserInterfaceEventsObject.Application

UserInterfaceManager.Application

UserInterfaceManager.Parent

VbaApplication.ThisApplication

You are here: Symbol Reference > Inventor Library > Objects > Application Interface


Application Methods

Application Methods
Summary

The methods of the Application class are listed here.

Methods
Methods
Name | Description
Login | This is Login, a member of class Application.
CreateFileDialog | Method that creates a new FileDialog object. The FileDialog object is similar to the Microsoft common dialog control and allows you to reuse the Inventor open an save dialogs.
CreateProgressBar | Method that creates a new ProgressBar object. The progress bar is not immediately displayed. Calling the UpdateProgress method for the first time causes the bar to display.
GetAppFrameExtents | Obtains the position and size of the application's main frame window.
Move | Method that moves the frame window.
Quit | Shuts down the application.
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods


Application.Login Method

Application.Login Method
Summary

This is Login, a member of class Application.

Visual Basic
Sub Login(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods > Application.Login Method


Application.CreateFileDialog Method

Application.CreateFileDialog Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new FileDialog object. The FileDialog object is similar to the Microsoft common dialog control and allows you to reuse the Inventor open an save dialogs.

Visual Basic
Sub CreateFileDialog(ByRef Dialog As FileDialog*)
Parameters
Parameters | Description
Dialog | Output FileDialog object.
See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods > Application.CreateFileDialog Method


Application.CreateProgressBar Method

Application.CreateProgressBar Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new ProgressBar object. The progress bar is not immediately displayed. Calling the UpdateProgress method for the first time causes the bar to display.

Visual Basic
Sub CreateProgressBar(DisplayInStatusBar As VARIANT_BOOL, NumberOfSteps As long, Title As String, ByRef AllowCancel As [defaultvalue(0)] VARIANT_BOOL, ByRef HWND As [defaultvalue(0)] long, Result As [out, retval] ProgressBar*)
Parameters
Parameters | Description
DisplayInStatusBar | Input Boolean that specifies whether the progress bar should be displayed in the status bar or as a dialog.
NumberOfSteps | Input long that specifies the number of steps for the progress bar. The ProgressBar.UpdateProgress method should be called as many times as this value.
Title | Input String that specifies the title for the progress bar.
AllowCancel | Optional input Boolean that specifies whether the progress bar should display a cancel button for the user to cancel the operation. If specified to be True, the ProgressBar.OnCancel event is fired when the user chooses to cancel the operation. The client should abort their operation and close the progress bar when this event is fired.
HWND | Optional input Long that specifies the hwnd of the parent dialog that is launching the progress bar. If not specified, the active Inventor application's hwnd is used. This argument is not applicable if the DisplayInStatusBar argument is set to True.
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods > Application.CreateProgressBar Method


Application.GetAppFrameExtents Method

Application.GetAppFrameExtents Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains the position and size of the application's main frame window.

Visual Basic
Sub GetAppFrameExtents(ByRef Top As long, ByRef Left As long, ByRef Height As long, ByRef Width As long)
Parameters
Parameters | Description
Top | Output Long that specifies the top of the application's main frame window.
Left | Output Long that specifies the left position of the application's main frame window.
height | Output that indicates how you are handling the event.
width | Output Long that specifies the width of the application's main frame window.
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods > Application.GetAppFrameExtents Method


Application.Move Method

Application.Move Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that moves the frame window.

Visual Basic
Sub Move(Top As long, Left As long, Height As long, Width As long)
Parameters
Parameters | Description
Top | Input argument that specifies the position to which to move the top of the frame window.
Left | Input argument that specifies the position to which to move the left of the frame window.
height | Input argument that specifies the height of the frame window.
width | Input argument that specifies the width of the frame window.
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods > Application.Move Method


Application.Quit Method

Application.Quit Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Shuts down the application.

Visual Basic
Sub Quit()
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Methods > Application.Quit Method


Application Properties

Application Properties
Summary

The properties of the Application class are listed here.

Properties
Name | Description
ActiveColorScheme | Property that returns the ColorScheme that is currently active.
ActiveDocument | This is ActiveDocument, a member of class Application.
ActiveDocumentType | Gets the type of the active document.
ActiveEditDocument | Property that returns the current in-place editing document.
ActiveEditObject | Gets the object that is currently open for edit within the Autodesk Inventor user interface.
ActiveView | Gets the active view.
CameraEvents | This is CameraEvents, a member of class Application.
Caption | Gets/sets the caption on the application's frame window.
ColorSchemes | Property that returns the ColorSchemes object. The ColorSchemes object provides access to the color schemes. This is somewhat equivalent to the Colors tab of the Application Options dialog.
CommandManager | Property that returns the CommandManager object.
FileUIEvents | Property that returns the FileUIEvents object. This object supports a set of events that are fired in reaction to certain user interface actions.
HardwareOptions | Property that returns the HardwareOptions object. The HardwareOptions object provides access to various hardware related application level options. This is somewhat equivalent to the Hardware tab of the Application Options dialog.
Height | Property that indicates the height of the edge of the frame window.
HelpManager | Gets the HelpManager object that provides access to the help-related activity taking place in the system.
Left | Property that indicates the distance between the left edge of the screen and left edge of the frame window.
MainFrameHWND | Gets the Application main window's HWND.
MRUDisplay | Gets/Sets the property that turns display of the application's MRU list on and off.
OpenDocumentsDisplay | This is OpenDocumentsDisplay, a member of class Application.
MRUEnabled | Gets/sets the property that deals with the application's ability to add files to the MRU list.
ScreenUpdating | Gets and sets whether the screen is updated (redrawn) during a series of actions. Turn off screen updating while a series of actions are performed so that the screen is not redrawn after each action. Remember to turn screen updating on to update the screen.
SilentOperation | Gets/sets the Boolean flag that controls whether an operation will proceed without prompting (if that gets required...e.g.: error message dismissal). If Autodesk Inventor is running visible, this property is FALSE by default.
StatusBarText | Gets/sets the Status Bar text in first pane of the Application's Main frame.
Top | Property that indicates the distance between the top of the screen and top of the frame window.
UserInterfaceManager | Gets the UserInterfaceManager object. The UserInterfaceManager object is the starting point for UI and environment control, providing access to available environments, command bars, browsers, panel bars, toolbars etc.
Views | Gets all the open Views in a collection.
Visible | Gets/sets the visibility of this application.
Width | Property that indicates the width the frame window.
WindowState | Property that indicates a constant that specifies the frame window's state (maximized, minimized, or normal).
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties


Application.ActiveColorScheme Property

Application.ActiveColorScheme Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ColorScheme that is currently active.

Visual Basic
Property ActiveColorScheme() As ColorScheme**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ActiveColorScheme Property


Application.ActiveDocument Property

Application.ActiveDocument Property
Summary

This is ActiveDocument, a member of class Application.

Visual Basic
Property ActiveDocument() As Document**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ActiveDocument Property


Application.ActiveDocumentType Property

Application.ActiveDocumentType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the type of the active document.

Visual Basic
Property ActiveDocumentType() As DocumentTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ActiveDocumentType Property


Application.ActiveEditDocument Property

Application.ActiveEditDocument Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the current in-place editing document.

Visual Basic
Property ActiveEditDocument() As Document**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ActiveEditDocument Property


Application.ActiveEditObject Property

Application.ActiveEditObject Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object that is currently open for edit within the Autodesk Inventor user interface.

Visual Basic
Property ActiveEditObject() As IDispatch**
See Also

Move sketch entities sample

Finding Bend Extent (Tangent) Edges sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ActiveEditObject Property


Application.ActiveView Property

Application.ActiveView Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the active view.

Visual Basic
Property ActiveView() As View**
See Also

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ActiveView Property


Application.CameraEvents Property

Application.CameraEvents Property
Summary

This is CameraEvents, a member of class Application.

Visual Basic
Property CameraEvents() As CameraEvents**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.CameraEvents Property


Application.Caption Property

Application.Caption Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the caption on the application's frame window.

Visual Basic
Property Caption() As String
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Caption Property


Application.ColorSchemes Property

Application.ColorSchemes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ColorSchemes object. The ColorSchemes object provides access to the color schemes. This is somewhat equivalent to the Colors tab of the Application Options dialog.

Visual Basic
Property ColorSchemes() As ColorSchemes**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ColorSchemes Property


Application.CommandManager Property

Application.CommandManager Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the CommandManager object.

Visual Basic
Property CommandManager() As CommandManager**
See Also

Using measure events sample

InteractionGraphics sample

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.CommandManager Property


Application.FileUIEvents Property

Application.FileUIEvents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the FileUIEvents object. This object supports a set of events that are fired in reaction to certain user interface actions.

Visual Basic
Property FileUIEvents() As FileUIEvents**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.FileUIEvents Property


Application.HardwareOptions Property

Application.HardwareOptions Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the HardwareOptions object. The HardwareOptions object provides access to various hardware related application level options. This is somewhat equivalent to the Hardware tab of the Application Options dialog.

Visual Basic
Property HardwareOptions() As HardwareOptions**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.HardwareOptions Property


Application.Height Property

Application.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates the height of the edge of the frame window.

Visual Basic
Property Height() As long
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Height Property


Application.HelpManager Property

Application.HelpManager Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the HelpManager object that provides access to the help-related activity taking place in the system.

Visual Basic
Property HelpManager() As HelpManager**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.HelpManager Property


Application.Left Property

Application.Left Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the distance between the left edge of the screen and left edge of the frame window.

Visual Basic
Property Left() As long
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Left Property


Application.MainFrameHWND Property

Application.MainFrameHWND Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Application main window's HWND.

Visual Basic
Property MainFrameHWND() As long*
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.MainFrameHWND Property


Application.MRUDisplay Property

Application.MRUDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets/Sets the property that turns display of the application's MRU list on and off.

Visual Basic
Property MRUDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.MRUDisplay Property


Application.OpenDocumentsDisplay Property

Application.OpenDocumentsDisplay Property
Summary

This is OpenDocumentsDisplay, a member of class Application.

Visual Basic
Property OpenDocumentsDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.OpenDocumentsDisplay Property


Application.MRUEnabled Property

Application.MRUEnabled Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the property that deals with the application's ability to add files to the MRU list.

Visual Basic
Property MRUEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.MRUEnabled Property


Application.ScreenUpdating Property

Application.ScreenUpdating Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets and sets whether the screen is updated (redrawn) during a series of actions. Turn off screen updating while a series of actions are performed so that the screen is not redrawn after each action. Remember to turn screen updating on to update the screen.

Visual Basic
Property ScreenUpdating() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.ScreenUpdating Property


Application.SilentOperation Property

Application.SilentOperation Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the Boolean flag that controls whether an operation will proceed without prompting (if that gets required...e.g.: error message dismissal). If Autodesk Inventor is running visible, this property is FALSE by default.

Visual Basic
Property SilentOperation() As VARIANT_BOOL
See Also

Shrink wrap substitute in assembly sample

You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.SilentOperation Property


Application.StatusBarText Property

Application.StatusBarText Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets/sets the Status Bar text in first pane of the Application's Main frame.

Visual Basic
Property StatusBarText() As String
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.StatusBarText Property


Application.Top Property

Application.Top Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the distance between the top of the screen and top of the frame window.

Visual Basic
Property Top() As long
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Top Property


Application.Views Property

Application.Views Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets all the open Views in a collection.

Visual Basic
Property Views() As ViewsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Views Property


Application.Visible Property

Application.Visible Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the visibility of this application.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Visible Property


Application.Width Property

Application.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates the width the frame window.

Visual Basic
Property Width() As long
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.Width Property


Application.WindowState Property

Application.WindowState Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates a constant that specifies the frame window's state (maximized, minimized, or normal).

Visual Basic
Property WindowState() As WindowsSizeEnum
You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.WindowState Property


ApplicationAddIn Interface

ApplicationAddIn Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents an Application AddIn inside Autodesk Inventor.

Class Hierarchy
Inventor::ApplicationAddIn
    Inventor::TranslatorAddIn
Visual Basic
Public Interface ApplicationAddIn
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ApplicationAddIns.Item

ApplicationAddIns.ItemById

ApplicationAddInSite.Parent

See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface


ApplicationAddIn Methods

ApplicationAddIn Methods
Summary

The methods of the ApplicationAddIn class are listed here.

Methods
Methods
Name | Description
Activate | Creates and initializes the AddIn. No effect if AddIn already active.
Deactivate | Invokes the shutdown sequence on the AddIn. No effect if AddIn inactive.
StartUpEnabled | Gets/sets a Boolean flag indicating whether this AddIn will be enabled unconditionally at Autodesk Inventor startup.
Version | Property that returns the version number of the Add-in. Retired in favor of UserInterfaceVersion.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Methods


ApplicationAddIn.Activate Method

ApplicationAddIn.Activate Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Creates and initializes the AddIn. No effect if AddIn already active.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Methods > ApplicationAddIn.Activate Method


ApplicationAddIn.Deactivate Method

ApplicationAddIn.Deactivate Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Invokes the shutdown sequence on the AddIn. No effect if AddIn inactive.

Visual Basic
Sub Deactivate()
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Methods > ApplicationAddIn.Deactivate Method


ApplicationAddIn.StartUpEnabled Method

ApplicationAddIn.StartUpEnabled Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets a Boolean flag indicating whether this AddIn will be enabled unconditionally at Autodesk Inventor startup.

Visual Basic
Sub StartUpEnabled(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Methods > ApplicationAddIn.StartUpEnabled Method


ApplicationAddIn.Version Method

ApplicationAddIn.Version Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the version number of the Add-in. Retired in favor of UserInterfaceVersion.

Visual Basic
Sub Version(Result As [out, retval] long)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Methods > ApplicationAddIn.Version Method


ApplicationAddIn Properties

ApplicationAddIn Properties
Summary

The properties of the ApplicationAddIn class are listed here.

Properties
Name | Description
Activated | Gets a Boolean flag indicating whether this AddIn is currently active in the session.
AddInType | Gets the constant that indicates the type of this AddIn.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Automation | Property that returns the Add-in's automation interface (if any). Fails if the Add-in is currently inactive.
ClassIdString | Gets the CLSID of the AddIn as the string used in the class moniker.
ClientId | Property that returns a GUID in string format that uniquely identifies this Add-in. This GUID is used as an identifier when creating Add-in specific objects such as user interface elements, client features, etc.
DataVersion | Property that indicates the current data version of the AddIn. This value corresponds to the value of the registry entry called 'DataVersion' in the following location: HKEY_CLASSES_ROOT\CLSID\{CLSID}\Settings
Description | Gets the description of the AddIn.
DisplayName | Gets the displayable name of the AddIn.
Hidden | Property indicating whether the Addin is hidden. A hidden Addin will not be displayed (by default) in the Addin Manager dialog box. Any third party display or usage of the Addin should also honor this property.
LicenseStatus | Gets the license status of the AddIn.
LoadAutomatically | This is LoadAutomatically, a member of class ApplicationAddIn.
LoadBehavior | This is LoadBehavior, a member of class ApplicationAddIn.
Location | Property that returns the full file name of the dll associated with this Add-in.
Parent | Property that returns the parent Application object.
ProgId | Gets the ProgID of the AddIn.
ShortDisplayName | Property that returns the short display name of the Add-in. Used in places to succinctly identify the AddIn inside Inventor's UI.
Type | Returns an ObjectTypeEnum indicating this object's type.
UserInterfaceVersion | Property that returns the version of the user interface of the add-in. Incrementing this version results in all of the add-in"s UI getting cleaned up during Inventor start-up.
UserUnloadable | Property indicating whether the AddIn can be unloaded by the user.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties


ApplicationAddIn.Activated Property

ApplicationAddIn.Activated Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets a Boolean flag indicating whether this AddIn is currently active in the session.

Visual Basic
Property Activated() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Activated Property


ApplicationAddIn.AddInType Property

ApplicationAddIn.AddInType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the constant that indicates the type of this AddIn.

Visual Basic
Property AddInType() As ApplicationAddInTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.AddInType Property


ApplicationAddIn.Application Property

ApplicationAddIn.Application Property Available in Apprentice
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Application Property


ApplicationAddIn.Automation Property

ApplicationAddIn.Automation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Add-in's automation interface (if any). Fails if the Add-in is currently inactive.

Visual Basic
Property Automation() As IDispatch**
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Automation Property


ApplicationAddIn.ClassIdString Property

ApplicationAddIn.ClassIdString Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the CLSID of the AddIn as the string used in the class moniker.

Visual Basic
Property ClassIdString() As BSTR*
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.ClassIdString Property


ApplicationAddIn.ClientId Property

ApplicationAddIn.ClientId Property Available in Apprentice
Summary

Property that returns a GUID in string format that uniquely identifies this Add-in. This GUID is used as an identifier when creating Add-in specific objects such as user interface elements, client features, etc.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.ClientId Property


ApplicationAddIn.DataVersion Property

ApplicationAddIn.DataVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the current data version of the AddIn. This value corresponds to the value of the registry entry called 'DataVersion' in the following location:

HKEY_CLASSES_ROOT\CLSID\{CLSID}\Settings

Visual Basic
Property DataVersion() As long
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.DataVersion Property


ApplicationAddIn.Description Property

ApplicationAddIn.Description Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the description of the AddIn.

Visual Basic
Property Description() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Description Property


ApplicationAddIn.DisplayName Property

ApplicationAddIn.DisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the displayable name of the AddIn.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.DisplayName Property


ApplicationAddIn.Hidden Property

ApplicationAddIn.Hidden Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property indicating whether the Addin is hidden. A hidden Addin will not be displayed (by default) in the Addin Manager dialog box. Any third party display or usage of the Addin should also honor this property.

Visual Basic
Property Hidden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Hidden Property


ApplicationAddIn.LicenseStatus Property

ApplicationAddIn.LicenseStatus Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the license status of the AddIn.

Visual Basic
Property LicenseStatus() As AddInLicenseStatusEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.LicenseStatus Property


ApplicationAddIn.LoadAutomatically Property

ApplicationAddIn.LoadAutomatically Property
Summary

This is LoadAutomatically, a member of class ApplicationAddIn.

Visual Basic
Property LoadAutomatically() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.LoadAutomatically Property


ApplicationAddIn.LoadBehavior Property

ApplicationAddIn.LoadBehavior Property
Summary

This is LoadBehavior, a member of class ApplicationAddIn.

Visual Basic
Property LoadBehavior() As AddInLoadBehaviorEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.LoadBehavior Property


ApplicationAddIn.Location Property

ApplicationAddIn.Location Property Available in Apprentice
Summary

Property that returns the full file name of the dll associated with this Add-in.

Visual Basic
Property Location() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Location Property


ApplicationAddIn.Parent Property

ApplicationAddIn.Parent Property Available in Apprentice
Summary

Property that returns the parent Application object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Parent Property


ApplicationAddIn.ProgId Property

ApplicationAddIn.ProgId Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the ProgID of the AddIn.

Visual Basic
Property ProgId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.ProgId Property


ApplicationAddIn.ShortDisplayName Property

ApplicationAddIn.ShortDisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the short display name of the Add-in. Used in places to succinctly identify the AddIn inside Inventor's UI.

Visual Basic
Property ShortDisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.ShortDisplayName Property


ApplicationAddIn.Type Property

ApplicationAddIn.Type Property Available in Apprentice
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.Type Property


ApplicationAddIn.UserUnloadable Property

ApplicationAddIn.UserUnloadable Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property indicating whether the AddIn can be unloaded by the user.

Visual Basic
Property UserUnloadable() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.UserUnloadable Property


ApplicationAddIns Interface

ApplicationAddIns Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that holds a collection of interfaces.

Class Hierarchy
Inventor::ApplicationAddIns
Visual Basic
Public Interface ApplicationAddIns
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ApprenticeServer.ApplicationAddIns

Application.ApplicationAddIns

See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface


ApplicationAddIns Methods

ApplicationAddIns Methods
Summary

The methods of the ApplicationAddIns class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
ItemById | Property that returns the specified ApplicationAddIn object from the collection. Retrieves an ApplicationAddIn object based on the Client Id.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface > ApplicationAddIns Methods


ApplicationAddIns.Item Method

ApplicationAddIns.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ApplicationAddIn*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface > ApplicationAddIns Methods > ApplicationAddIns.Item Method


ApplicationAddIns.ItemById Method

ApplicationAddIns.ItemById Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified ApplicationAddIn object from the collection. Retrieves an ApplicationAddIn object based on the Client Id.

Visual Basic
Sub ItemById(ClientId As String, Result As [out, retval] ApplicationAddIn*)
Parameters
Parameters | Description
ClientId | Input String that specifies the ApplicationAddIn to return. This is a string indicating either the ClassId of the Add-in or the unique ClientId associated with the Add-in.
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface > ApplicationAddIns Methods > ApplicationAddIns.ItemById Method


ApplicationAddIns Properties

ApplicationAddIns Properties
Summary

The properties of the ApplicationAddIns class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface > ApplicationAddIns Properties


ApplicationAddIns.Count Property

ApplicationAddIns.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface > ApplicationAddIns Properties > ApplicationAddIns.Count Property


ApplicationAddIns.Type Property

ApplicationAddIns.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIns Interface > ApplicationAddIns Properties > ApplicationAddIns.Type Property


ApplicationAddInServer Interface

ApplicationAddInServer Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object required to be supported by Server to qualify as an Autodesk Inventor AddIn.

Class Hierarchy
Inventor::ApplicationAddInServer
    Inventor::TranslatorAddInServer
Visual Basic
Public Interface ApplicationAddInServer
Inherits IDispatch
Remarks

See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface


ApplicationAddInServer Methods

ApplicationAddInServer Methods
Summary

The methods of the ApplicationAddInServer class are listed here.

Methods
Methods
Name | Description
Activate | Invoked by Autodesk Inventor after creating the AddIn. AddIn should initialize within this call.
Deactivate | Invoked by Autodesk Inventor to shut down the AddIn. AddIn should complete shutdown within this call.
ExecuteCommand | Invoked by Autodesk Inventor in response to user requesting the execution of an AddIn-supplied command. AddIn must perform the command within this call.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface > ApplicationAddInServer Methods


ApplicationAddInServer.Activate Method

ApplicationAddInServer.Activate Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Invoked by Autodesk Inventor after creating the AddIn. AddIn should initialize within this call.

Visual Basic
Sub Activate(AddInSiteObject As ApplicationAddInSite, FirstTime As VARIANT_BOOL)
Parameters
Parameters | Description
AddInSiteObject | Input argument that specifies the object, which provides access to the Autodesk Inventor Application object.
FirstTime | The FirstTime flag, if True, indicates to the Addin that this is the first time it is being loaded and to take some specific action. It does not take these actions when this flag is False. Typically, when the flag is True, the AddIn proceeds to create all of the objects under the UserInterfaceManager that it needs - Environments, CommandBars and Controls. These objects are persistent, but if this is the first time the Addin is loaded, they need to be created from scratch. When the FirstTime flag is False, meaning the Addin has already been loaded, it only needs to create the objects under the CommandManager - CommandCategories and ControlDefinitions.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface > ApplicationAddInServer Methods > ApplicationAddInServer.Activate Method


ApplicationAddInServer.Deactivate Method

ApplicationAddInServer.Deactivate Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Invoked by Autodesk Inventor to shut down the AddIn. AddIn should complete shutdown within this call.

Visual Basic
Sub Deactivate()
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface > ApplicationAddInServer Methods > ApplicationAddInServer.Deactivate Method


ApplicationAddInServer.ExecuteCommand Method

ApplicationAddInServer.ExecuteCommand Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Invoked by Autodesk Inventor in response to user requesting the execution of an AddIn-supplied command. AddIn must perform the command within this call.

Visual Basic
Sub ExecuteCommand(CommandID As long)
Parameters
Parameters | Description
CommandID | Input Long that specifies the command to execute.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface > ApplicationAddInServer Methods > ApplicationAddInServer.ExecuteCommand Method


ApplicationAddInServer Properties

ApplicationAddInServer Properties
Summary

The properties of the ApplicationAddInServer class are listed here.

Properties
Name | Description
Automation | Gets the IUnknown of the object implemented inside the AddIn that supports AddIn-specific API.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface > ApplicationAddInServer Properties


ApplicationAddInServer.Automation Property

ApplicationAddInServer.Automation Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the IUnknown of the object implemented inside the AddIn that supports AddIn-specific API.

Visual Basic
Property Automation() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInServer Interface > ApplicationAddInServer Properties > ApplicationAddInServer.Automation Property


ApplicationAddInSite Interface

ApplicationAddInSite Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ApplicationAddInSite object is an object that is only available through the Activate method of the ApplicationAddInServer interface.

Class Hierarchy
Inventor::ApplicationAddInSite
Visual Basic
Public Interface ApplicationAddInSite
Inherits IDispatch
Remarks

Add-Ins implement the ApplicationAddInServer interface and Autodesk Inventor calls the Activate method when the Add-In is started. One of the arguments provides the ApplicationAddInSite object that is specific to that Add-In. The ApplicationAddInSite object provides access to methods that are private to that specific Add-in since the ApplicationAddInSite object is not available anywhere else. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface


ApplicationAddInSite Methods

ApplicationAddInSite Methods
Summary

The methods of the ApplicationAddInSite class are listed here.

Methods
Methods
Name | Description
InventorServer | Returns the InventorServer object.
LicenseChallenge | This is LicenseChallenge, a member of class ApplicationAddInSite.
LicenseResponse | This is LicenseResponse, a member of class ApplicationAddInSite.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Methods


ApplicationAddInSite.InventorServer Method

ApplicationAddInSite.InventorServer Method
Summary

Returns the InventorServer object.

Visual Basic
Sub InventorServer(Result As [out, retval] InventorServer*)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Methods > ApplicationAddInSite.InventorServer Method


ApplicationAddInSite.LicenseChallenge Method

ApplicationAddInSite.LicenseChallenge Method
Summary

This is LicenseChallenge, a member of class ApplicationAddInSite.

Visual Basic
Sub LicenseChallenge(Result As [out, retval] BSTR)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Methods > ApplicationAddInSite.LicenseChallenge Method


ApplicationAddInSite.LicenseResponse Method

ApplicationAddInSite.LicenseResponse Method
Summary

This is LicenseResponse, a member of class ApplicationAddInSite.

Visual Basic
Sub LicenseResponse(Response As String, Result As [out, retval] AddInLicenseStatusEnum)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Methods > ApplicationAddInSite.LicenseResponse Method


ApplicationAddInSite Properties

ApplicationAddInSite Properties
Summary

The properties of the ApplicationAddInSite class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent ApplicationAddIn object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Properties


ApplicationAddInSite.Application Property

ApplicationAddInSite.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Properties > ApplicationAddInSite.Application Property


ApplicationAddInSite.Parent Property

ApplicationAddInSite.Parent Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the parent ApplicationAddIn object.

Visual Basic
Property Parent() As ApplicationAddIn**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Properties > ApplicationAddInSite.Parent Property


ApplicationAddInSite.Type Property

ApplicationAddInSite.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddInSite Interface > ApplicationAddInSite Properties > ApplicationAddInSite.Type Property


ApplicationEvents CoClass

ApplicationEvents CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ApplicationEvents object provides application event notifications.

Class Hierarchy
Inventor::ApplicationEvents
Visual Basic
Public Class ApplicationEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEvents CoClass


ApplicationEventsObject Interface

ApplicationEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ApplicationEvents object provides application event notifications.

Class Hierarchy
Inventor::ApplicationEventsObject
Visual Basic
Public Interface ApplicationEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsObject Interface


ApplicationEventsObject Properties

ApplicationEventsObject Properties
Summary

The properties of the ApplicationEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsObject Interface > ApplicationEventsObject Properties


ApplicationEventsObject.Application Property

ApplicationEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsObject Interface > ApplicationEventsObject Properties > ApplicationEventsObject.Application Property


ApplicationEventsObject.Parent Property

ApplicationEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsObject Interface > ApplicationEventsObject Properties > ApplicationEventsObject.Parent Property


ApplicationEventsObject.Type Property

ApplicationEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsObject Interface > ApplicationEventsObject Properties > ApplicationEventsObject.Type Property


ApplicationEventsSink Interface

ApplicationEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ApplicationEvents object provides application event notifications.

Class Hierarchy
Inventor::ApplicationEventsSink
Visual Basic
Public Interface ApplicationEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface


ApplicationEventsSink Methods

ApplicationEventsSink Methods
Summary

The methods of the ApplicationEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivateDocument | Event that is fired whenever a document is activated.
OnActivateView | Event that fires just after a view is activated.
OnActiveProjectChanged | Fires just before and soon after the active project is changed, supplying the context in which this action is being taken.
OnApplicationOptionChange | Fires just before and soon after application options are modified.
OnCloseDocument | Event that is fired whenever a document is closed.
OnCloseView | The OnCloseView event notifies a client when a view is closed. An API view is equivalent to an Inventor graphics window.
OnDeactivateDocument | The OnDeactivateDocument event notifies a client when a document is deactivated.
OnDeactivateView | Fires just after a view is deactivated.
OnDisplayModeChange | The OnDisplayModeChange event notifies a client when the display mode of a view has changed.
OnDocumentChange | Fires just before the document is changed, supplying the reasons for change and the context in which this action is being taken.
OnInitializeDocument | Event that is fired whenever a document is initialized. At the time this event fires, the document is not open yet. Calling methods or properties on the document will force it to open.
OnMigrateDocument | Event that is fired whenever a document is being explicitly migrated.
OnNewDocument | Event that is fired whenever a new document is created.
OnNewEditObject | The OnNewEditObject event notifies a client when the edit object is changing.
OnNewView | The OnNewView event notifies a client when a new View object is created. An API "View" object is equivalent to an Inventor graphics window.
OnOpenDocument | The OnOpenDocument event notifies a client when a document is opened.
OnQuit | The OnQuit event notifies a client when Inventor is being shut down.
OnReady | The OnReady event notifies a client when Inventor has completely initialized and is ready for interactive use.
OnRestart32BitHost | This event is not implemented in the 32-bit version of Autodesk Inventor.
OnSaveDocument | The OnSaveDocument notifies a client whenever a document is saved.
OnTerminateDocument | The OnTerminateDocument event notifies a client when a document is being terminated. Termination of a document is a complete close of the document. A document terminate corresponds with a document initialize.
OnTranslateDocument | The OnTranslateDocument event notifies a client whenever a file is translated into Inventor.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods


ApplicationEventsSink.OnActivateDocument Method

ApplicationEventsSink.OnActivateDocument Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Event that is fired whenever a document is activated.

Visual Basic
Sub OnActivateDocument(DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input object that is being activated.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the document is activated. Notification is sent before and after the document is activated.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

The OnActivateDocument event notifies a client when a document is activated. The definition of an active document is the top-level document that is being displayed in the active window. The title of a window also indicates the active document for that window. It's also important to understand that the document currently being edited is not necessarily the active document. This happens in the case of in-place editing in the context of an assembly. When you open an assembly document, the assembly is the active document. If you in-place edit a part within the assembly, the assembly is still the active document. The part being edited is the active edit object. The ApplicationEvents.OnNewEditObject event provides notification when the active edit object changes and the Application.ActiveEditObject property returns the current active edit object.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnActivateDocument Method


ApplicationEventsSink.OnActivateView Method

ApplicationEventsSink.OnActivateView Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Event that fires just after a view is activated.

Visual Basic
Sub OnActivateView(ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ViewObject | The view that has been activated.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the view is activated. This notification is currently only provided after the view has been activated. To protect yourself against possible future changes to this event you should write your code so that you only respond to kAfter, as shown below. Private Sub ApplicationEvents_OnActivateView(...) If BeforeOrAfter = kAfter Then ' Your code in reaction to the notification. End If End Sub
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
Remarks

The OnActivateView event notifies a client when a view is activated. An API View object is equivalent to an Inventor window. When the end-user clicks on a window to work in it, it becomes the active window. The OnActivateView event is fired at this time.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnActivateView Method


ApplicationEventsSink.OnActiveProjectChanged Method

ApplicationEventsSink.OnActiveProjectChanged Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Fires just before and soon after the active project is changed, supplying the context in which this action is being taken.

Visual Basic
Sub OnActiveProjectChanged(ProjectObject As DesignProject, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ProjectObject | The object that has been activated.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the document is activated. Notification is sent before and after the active project is changed.
Context | Input object that can be used to determine the context of why the event fired. This event provides additional information through the Context argument as described below: Name = "FileName". Value = Full filename of the ipj file that is being activated. Name = "Reason". Value = The reason the notification was made. Can be one of the following values: "ProjectActivated" or "ProjectSaved".
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
Remarks

The OnActiveProjectChanged event notifies a client when a change has been made to the active project. The notification is sent for two different actions that are related to projects; a new project is activated and the active project is saved. This event provides the DesignProject object as a representative of the project. At this time, the DesignProject object is limited in the functionality it provides. In cases where you need more information about the project you may want to use the FileLocations object.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnActiveProjectChanged Method


ApplicationEventsSink.OnApplicationOptionChange Method

ApplicationEventsSink.OnApplicationOptionChange Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Fires just before and soon after application options are modified.

Visual Basic
Sub OnApplicationOptionChange(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnApplicationOptionChange Method


ApplicationEventsSink.OnCloseDocument Method

ApplicationEventsSink.OnCloseDocument Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Event that is fired whenever a document is closed.

Visual Basic
Sub OnCloseDocument(DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
The Document object that is being closed. The document being closed is provided for both the kBefore and kAfter cases. This is because the Document is still available after it's closed, although in a limited sense, until it is terminated. One of the useful things you can do with a document in this state is to compare it's identity with a reference previously saved (usually during kBefore). For example: Private m_oClosingDoc As Object Private Sub oAppEvents_OnClose(ByVal DocumentObject As Document, ..., ByVal BeforeOrAfter As EventTimingEnum, ...) If BeforeOrAfter = kBefore Then ' Check to see if the Document being closed is an interesting one. If Interesting(DocumentObject) Then ' Save a reference to the object. Set m_oClosingDoc = DocumentObject End If Else ' Now we're either after the close or it's been aborted. Check to see if the document is the interesting one. If DocumentObject Is m_oClosingDoc Then If BeforeOrAfter = kAfter then ' The document was closed. ElseIf BeforeOrAfter = kAbort Then ' The close was aborted. End If End If End Sub
FullDocumentName
Output string that specifies the fully qualified name of the document being closed. This is supplied both before and after.
BeforeOrAfter
Input indicating if the event is being fired before (kBefore) or after (kAfter) the document is closed. Notification is sent before and after the document is closed. In the case where this event is canceled the value of this argument will be kAbort.
Context
Input object that can be used to determine the context of why the event fired. This event provides additional information through the Context argument as described below: Name = "HealthStatusEnum", Value = The health status of the document. If this value is anything other than kUpToDateHealth you know the Document object returned is not in a state where you can use most of its methods or properties.
HandlingCode
This event supports the ability to cancel the close. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the close. When the close is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.
Notes

The OnOpenDocument and OnCloseDocument events fire when the document is initially opened and finally closed. This means if the file is referenced from an assembly, OnOpenDocument will not fire if a loaded file referenced in an open assembly is opened again, as internally this file is already open. Conversely, if a document is closed, the document is not really closed unless that was the final view and the document is not referenced by any other open documents. To Veto the OnCloseDocument event. When a document is about to be closed, the OnCloseDocument Application event is fired with the BeforeOrAfter argument set to kBefore. If the event handler returns HandlingCode argument set to kEventCancelled, the close operation is cancelled. Inventor then fires a corresponding kAbort event. For example:

Private Sub objAppEvents_OnCloseDocument(ByVal DocumentObject As Document, ByVal FullFileName As String, ByVal BeforeOrAfter As EventTimingEnum, ByVal Context As NameValueMap, HandlingCode As HandlingCodeEnum) If BeforeOrAfter = kBefore Then Debug.Print "OnCloseDocument event vetoed" HandlingCode = kEventCanceled End If End Sub

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnCloseDocument Method


ApplicationEventsSink.OnCloseView Method

ApplicationEventsSink.OnCloseView Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnCloseView event notifies a client when a view is closed. An API view is equivalent to an Inventor graphics window.

Visual Basic
Sub OnCloseView(ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ViewObject | The view that is about to be closed.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the view is closed. This notification is currently only provided before the view has been closed. To protect yourself against possible future changes to this event you should write your code so that you only respond to kBefore, as shown below. Private Sub ApplicationEvents_OnCloseView(...) If BeforeOrAfter = kBefore Then ' Your code in reaction to the notification. End If End Sub
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnCloseView Method


ApplicationEventsSink.OnDeactivateDocument Method

ApplicationEventsSink.OnDeactivateDocument Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnDeactivateDocument event notifies a client when a document is deactivated.

Visual Basic
Sub OnDeactivateDocument(DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The object that is being deactivated.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the document is deactivated. Notification is sent before and after the document is deactivated.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event. This argument is ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnDeactivateDocument Method


ApplicationEventsSink.OnDeactivateView Method

ApplicationEventsSink.OnDeactivateView Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Fires just after a view is deactivated.

Visual Basic
Sub OnDeactivateView(ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ViewObject | The view that has been deactivated.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the view is deactivated.
Context | Input object that can be used to determine the context of why the event fired.
HandlingCode | Output that indicates how you are handling the event.
Remarks

The OnDeactivateView is not currently supported and no notification is sent when a view is deactivated.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnDeactivateView Method


ApplicationEventsSink.OnDisplayModeChange Method

ApplicationEventsSink.OnDisplayModeChange Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

The OnDisplayModeChange event notifies a client when the display mode of a view has changed.

Visual Basic
Sub OnDisplayModeChange(ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ViewObject | The View object whose display mode is being changed.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the view mode is changed. Notification is sent before and after the display mode is changed.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event. This argument is ignored for this event.
Remarks

The display mode defines whether the view is displayed as wireframe, shaded with hidden edges, or shaded with no hidden edges shown. The current display mode of the view can be determined by using the DisplayMode property of the View object returned by the ViewObject argument.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnDisplayModeChange Method


ApplicationEventsSink.OnDocumentChange Method

ApplicationEventsSink.OnDocumentChange Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Fires just before the document is changed, supplying the reasons for change and the context in which this action is being taken.

Visual Basic
Sub OnDocumentChange(DocumentObject As Document, BeforeOrAfter As EventTimingEnum, ReasonsForChange As CommandTypesEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
The Document object the change is occurring within.
BeforeOrAfter
Input EventTimingEnum indicating when the event is being fired. This argument specifies if the notification is being sent before a change is made (kBefore), after a change is made (kAfter), or when a change has been aborted (kAbort).
ReasonsForChange
This argument indicates the type of change that occurred. The value is from the CommandTypesEnum list, which represents the different categories of changes that can be made. Typically this will be a single value from the list but it can represent multiple values that have been combined together so you need to use bitwise operations to check for a specific change.
Context
Input object that can be used to determine the context of why the event fired. This argument provides additional information as described below: Name = 'DisplayName', Value = The display name of the command that caused the change. This name will change based on the language currently being used for Inventor. Name = 'InternalName', Value = The internal name of the command that caused the change. This name will be consistent regardless of the current language. Name = 'InternalNamesList', Value = When the internal name is 'CompositeChange' this value is returned. Some commands result in making several changes but combine or composite them into a single command. The individual changes that were composited into the single command are provided through this value. It is an array of strings that consist of the internal names of the individual changes made. For example, if you drag a sketch point that connects two lines, the display name is "Drag Sketch Inference", the internal name is "CompositeChange" and the internal names list is an array of the following three stringsModify Point", "Modify Line", and "Modify Line". Name = "ConsideredDirty", Value = "". If this name appears in the context list then the change made is one that causes the document to be dirty.
HandlingCode
Output that indicates how you are handling the event. This event supports the ability to cancel the change. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the change. When the change is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.
Remarks

The OnDocumentChange event notifies a client when an action occurs that causes any change to a document. The context information can be used to determine what the change is. The notification is not sent for commands that do not change the document, i.e. measure and view commands. Care needs to be taken when using this event because changes to the document are made so frequently that depending on what you do in response to the event it can degrade the performance of Inventor. You should perform simple checks first to see if the change is one that you're interested in before you perform more expensive operations. Whenever possible you should use more specific events instead of this general change event. For example, if you're interested in knowing when a parameter value changes you can listen to the ModelingEvents.OnParameterChange event instead. This is both simpler for you and more efficient, but not all actions that can occur within Inventor have corresponding events so in many cases using the OnDocumentChange event is the only solution. When an object is deleted from the document, it is possible to find out what that object is by querying Document.SelectSet while in the kBefore state of this event.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnDocumentChange Method


ApplicationEventsSink.OnInitializeDocument Method

ApplicationEventsSink.OnInitializeDocument Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever a document is initialized. At the time this event fires, the document is not open yet. Calling methods or properties on the document will force it to open.

Visual Basic
Sub OnInitializeDocument(DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object that is being initialized.
FullDocumentName | Output string that specifies the fully qualified name of the document being initialized. This is supplied both before and after.
BeforeOrAfter | Output EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the document is initialized. Notification is sent before and after the document is initialized.
Context | Output NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. This argument is ignored for this event.
Remarks

The OnInitializeDocument event notifies a client when a document is being initialized. Initialization of a document is essentially a low-level open. A portion of the document is opened to determine other related files but the majority of the data is not opened and loaded. For example, when you open a drawing, the referenced documents are initialized but are not fully loaded. If you perform an action within the drawing that requires access to the data within any of the referenced documents then they are automatically fully opened at that time. API calls on a document that is only initialized will also cause the document to be fully opened. When a document is opened it is always initialized, but a document can be initialized without being opened, if the additional data in the document is not needed.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnInitializeDocument Method


ApplicationEventsSink.OnMigrateDocument Method

ApplicationEventsSink.OnMigrateDocument Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Event that is fired whenever a document is being explicitly migrated.

Visual Basic
Sub OnMigrateDocument(DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that is being migrated.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the document is migrated.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. This argument is ignored for this event.
Remarks

Explicit migration can occur in one of the following situations:

  • User selects the Migrate command thru the user interface.
  • The Document.Migrate method is called via the API on a document needing migration.
  • A document needing migration is saved. The event fires after Inventor has completed migration of core data.

This event provides an opportunity for client AddIns to migrate their data. The OnMigrateDocument event notifies a client when a document is being fully migrated. Migration is the process of updating the data within a document created in an older version of Inventor to the data format of the current version. With delayed migration, documents created in Inventor version 11 and newer are not fully migrated until a modified document is saved or the end-user executes the Migrate command. This event is intended to be used by applications that are storing application specific data within the Inventor document and may also need to migrate their data from one version to another. They can use this event as one trigger to migrate. Other triggers, besides this event, may be when the end-user attempts to modify their data or runs one of their commands that needs up to date data to operate on.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnMigrateDocument Method


ApplicationEventsSink.OnNewDocument Method

ApplicationEventsSink.OnNewDocument Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Event that is fired whenever a new document is created.

Visual Basic
Sub OnNewDocument(DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input object that was just created. When the BeforeOrAfter argument is kBefore this argument will be Nothing because the document does not yet exist.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the document is created. Notification is sent before and after the document is created.
Context | Input object that can be used to determine the context of why the event fired. This event provides additional information through the Context argument as described below: Name = "TemplateFilename", Value = The full filename of the file used as the template when creating the new document. Name = "NewFileName", Value = The full filename of the new file. In most cases this value will be an empty string because the filename of a new document is not specified until it is saved for the first time. The exception to this is when the Create Component command is used in an Assembly to create a new part. In this case the filename is specified as part of the command.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnNewDocument Method


ApplicationEventsSink.OnNewEditObject Method

ApplicationEventsSink.OnNewEditObject Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

The OnNewEditObject event notifies a client when the edit object is changing.

Visual Basic
Sub OnNewEditObject(EditObject As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
EditObject | The new edit object. When the BeforeOrAfter argument is kBefore this is the object that will become the edit object. When the argument is kAfter this is the current edit object.
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) there is a new edit object. Notification is sent before and after the edit object change is made.
Context | Input object that can be used to determine the context of why the event fired. When an object is activated for edit within the context of an assembly some additional information is provided through the Context argument, as described below: Name = "ActiveDocument", Value = The AssemblyDocument object that the edit is within the context of. Name = "ActiveEditObject", Value = The ComponentOccurrence object in the assembly the edit is through.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
Remarks

This event is useful in many cases but is particularly critical when adding additional tabs to the browser. This event serves as the notification of when to add the browser tab. The OnOpenDocument event is not satisfactory for this case because this event is fired for documents that are opened as a result of being referenced in an assembly. In this context, most of the documents will not be directly edited, so adding the browser information is a waste of resources. The OnActivateDocument event is also unsatisfactory because when a document is edited in the context of an assembly, it is not activated. The assembly remains the active document. What does change is the current edit object. The edit object is the container object that is being edited by the end-user. For example when an assembly document is opened, the assembly document is the active document and the active edit object. If the end-user in-place activates a part in the assembly, the part becomes the active edit object, although the assembly is still the active document because the edit is taking place in the context of the assembly. If the end-user creates or edits a sketch within the part, the sketch becomes the active edit object. Valid objects for edit objects are documents, 2d and 3d sketches, and drawing sheets.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnNewEditObject Method


ApplicationEventsSink.OnNewView Method

ApplicationEventsSink.OnNewView Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnNewView event notifies a client when a new View object is created. An API "View" object is equivalent to an Inventor graphics window.

Visual Basic
Sub OnNewView(ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ViewObject | The View object that was created. When the BeforeOrAfter argument is kBefore this argument will be Nothing because the view does not yet exist.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the view is created. Notification is sent before and after the view is created.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnNewView Method


ApplicationEventsSink.OnOpenDocument Method

ApplicationEventsSink.OnOpenDocument Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnOpenDocument event notifies a client when a document is opened.

Visual Basic
Sub OnOpenDocument(DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object being opened. When the BeforeOrAfter argument is kBefore, this argument will be nothing because the document does not yet exist.
FullDocumentName | Output string that specifies the fully qualified name of the document being opened. This is supplied both before and after.
BeforeOrAfter | Output EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the document is opened. Notification is sent before and after the document is opened.
Context | Output NameValueMap object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of how the document is being opened. Name = "TopLevelFilename", Value = The full filename of the top-level file that was opened that's causing this file to be opened. For example, if an assembly is opened and a document referenced by that assembly is opened as a result, the TopLevelFilename will be the full filename of the assembly. This value can be the same as the FullDocumentName argument which indicates this document was opened by itself.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Documents are opened directly by the end-user using the Open command, but they are also opened indirectly as a result of being referenced by another document. For example, if an assembly is opened all of the documents referenced by the assembly are also opened. This notification is sent in all cases. The Context argument provides information that can help determine the context of the open.

You should not assume that the events will always arrive in the same sequence.

As an example, let us say you are writing an Addin that listens to both the OnOpenDocument event and the OnDocumentChange event. You are interested in a document called MyFavoriteDocument.

Your Addin assumes that the OnOpenDocument event will arrive before the OnDocumentChange event. In its OnOpenDocument event handler it checks for MyFavoriteDocument and sets a global variable MyFavoriteDocumentIsOpen as true. In the OnDocumentChange event handler, it first checks whether MyFavoriteDocumentIsOpen is true, and only then takes any action.

In your testing that code may work, but fail on a customer's machine. This can happen when another Addin receives the OnOpenDocument event before your Addin, and in its event handler makes a change to the document - causing an OnDocumentChange event to be fired. So you will get OnDocumentChange event before you get an OnOpenDocument event.

So in this instance, the assumption that OnOpenDocument event will always arrive before OnDocumentChange event on the same document, results in a very hard to find problem. As a general rule, it's safer not to make any assumption about the order in which these events will be received.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnOpenDocument Method


ApplicationEventsSink.OnQuit Method

ApplicationEventsSink.OnQuit Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnQuit event notifies a client when Inventor is being shut down.

Visual Basic
Sub OnQuit(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input . This notification is only provided before Inventor has shut down so the value of this argument will always be kBefore.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnQuit Method


ApplicationEventsSink.OnReady Method

ApplicationEventsSink.OnReady Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

The OnReady event notifies a client when Inventor has completely initialized and is ready for interactive use.

Visual Basic
Sub OnReady(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) initialization is complete. This notification is only provided after Inventor has initialized so the value of this argument will always be kAfter.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

This event fires (only once) after Inventor has completed its initialization. This includes initialization of all the Add-ins loaded at startup. This event should be used in conjunction with the Application.Ready property. This event is intended to be used by Add-Ins. When an Add-In is activated by inventor, Inventor itself is still initializing at that point so there are a few limitations to what an Add-In can do. An example is an Add-In that needs to access another Add-In or see what other Add-Ins have been loaded. When the Add-In is activated, Inventor is in the process of activating each Add-In and it's likely not all of the Add-Ins have been activated yet. By listening to the OnReady event the Add-In can perform these types of tasks once Inventor is in completely loaded state.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnReady Method


ApplicationEventsSink.OnRestart32BitHost Method

ApplicationEventsSink.OnRestart32BitHost Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This event is not implemented in the 32-bit version of Autodesk Inventor.

Visual Basic
Sub OnRestart32BitHost(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnRestart32BitHost Method


ApplicationEventsSink.OnSaveDocument Method

ApplicationEventsSink.OnSaveDocument Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnSaveDocument notifies a client whenever a document is saved.

Visual Basic
Sub OnSaveDocument(DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
Input object that is being saved.
BeforeOrAfter
Input indicating if the notification is being sent before the document is saved (kBefore), after a change is made (kAfter), or when a change has been aborted (kAbort).
Context
Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the save. Either SaveCopyAsFilename or SaveFileName is provided depending on whether the end-user executed the Save or Save Copy As command. The TopLevelSaveFileName is always provided but in some cases will have an empty string as the value. Name = SaveCopyAsFilename, Value = The full filename of the new document being created. Name = SaveFileName, Value = The full filename of the document being saved. Name = TopLevelSaveFileName, Value = Different values are returned depending on the context of the save. When a document is saved in the context of another document (for example, a part is saved when the assembly it is in is saved) this will return the name of the top-level assembly. When the notification is made for a save copy as operation this value is the full filename of the original document that is being saved to a new name. When the notification is made for a standard save this value is the filename of the document being saved. When a document is saved for the first time, this value will be "" for the kBefore timing and the filename of the document in the kAfter timing.
HandlingCode
Output that indicates how you are handling the event. This event supports the ability to cancel the save. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the save. When the save is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.
Remarks

The notification is made when the standard Save and the Save Copy As commands are invoked. When assemblies are saved this can also cause the dependent documents to be saved and this event is also fired in those cases.

You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnSaveDocument Method


ApplicationEventsSink.OnTerminateDocument Method

ApplicationEventsSink.OnTerminateDocument Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnTerminateDocument event notifies a client when a document is being terminated. Termination of a document is a complete close of the document. A document terminate corresponds with a document initialize.

Visual Basic
Sub OnTerminateDocument(DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | When the BeforeOrAfter argument is kBefore this returns the Document object that is being terminated. When BeforeOrAfter is kAfter this returns Nothing since the document is no longer available.
FullDocumentName | Output string that specifies the fully qualified name of the document being terminated. This is supplied both before and after.
BeforeOrAfter | Output EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the document is terminated. Notification is sent before and after the document is terminated.
Context | Output NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnTerminateDocument Method


ApplicationEventsSink.OnTranslateDocument Method

ApplicationEventsSink.OnTranslateDocument Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The OnTranslateDocument event notifies a client whenever a file is translated into Inventor.

Visual Basic
Sub OnTranslateDocument(TranslatingIn As VARIANT_BOOL, DocumentObject As Document, FullFileName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
TranslatingIn | Input Boolean that specifies whether the document is being translated into Autodesk Inventor. This argument is currently always True since this notification is only supported when translating files into Inventor. This could change in the future so it is important to check the value of this argument and only handle translations into Inventor.
DocumentObject | The object that is created as a result of the translation. When the BeforOrAfter argument is kBefore the value of this argument will be Nothing because the document has not been created yet.
FullFileName | The full filename of the document being translated.
BeforeOrAfter | Input that specifies whether to fire event before or after processing. Notification is sent before and after the document is translated.
Context | Input that specifies the context for the translation. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ApplicationEventsSink Interface > ApplicationEventsSink Methods > ApplicationEventsSink.OnTranslateDocument Method


ApprenticeDrawingPrintManager Interface

ApprenticeDrawingPrintManager Interface Available in Apprentice Introduced in Inventor 9
Summary

The ApprenticeDrawingPrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print job.

Class Hierarchy
Inventor::ApprenticePrintManager
    Inventor::ApprenticeDrawingPrintManager
Visual Basic
Public Interface ApprenticeDrawingPrintManager
Inherits ApprenticePrintManager
Remarks

This object is used for drawing document types only.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface


ApprenticeDrawingPrintManager Methods

ApprenticeDrawingPrintManager Methods
Summary

The methods of the ApprenticeDrawingPrintManager class are listed here.

Methods
Methods
Name | Description
GetSheetRange | Method that gets the sheet range to print. The sheet range is only used when the PrintRange property is set to kPrintSheetRange.
SetSheetRange | Property to indicate the range of Sheets to be printed. Valid only when PrintRange is set to kPrintSheetRange.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Methods


ApprenticeDrawingPrintManager.GetSheetRange Method

ApprenticeDrawingPrintManager.GetSheetRange Method Available in Apprentice Introduced in Inventor 9
Summary

Method that gets the sheet range to print. The sheet range is only used when the PrintRange property is set to kPrintSheetRange.

Visual Basic
Sub GetSheetRange(ByRef FromSheet As long, ByRef ToSheet As long)
Parameters
Parameters | Description
FromSheet | Output Long value that specifies the first sheet of the range to print.
ToSheet | Output Long value that specifies the last sheet of the range to print.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Methods > ApprenticeDrawingPrintManager.GetSheetRange Method


ApprenticeDrawingPrintManager.SetSheetRange Method

ApprenticeDrawingPrintManager.SetSheetRange Method Available in Apprentice Introduced in Inventor 9
Summary

Property to indicate the range of Sheets to be printed. Valid only when PrintRange is set to kPrintSheetRange.

Visual Basic
Sub SetSheetRange(FromSheet As long, ToSheet As long)
Parameters
Parameters | Description
FromSheet | Specifies the first sheet of the range to print.
ToSheet | Specifies the last sheet of the range to print.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Methods > ApprenticeDrawingPrintManager.SetSheetRange Method


ApprenticeDrawingPrintManager Properties

ApprenticeDrawingPrintManager Properties
Summary

The properties of the ApprenticeDrawingPrintManager class are listed here.

Properties
Name | Description
AllColorsAsBlack | This property indicates the Boolean flag indicating whether all the Drawing colors should be printed in black only.
PrintExcludedSheets | Property indicating whether excluded sheets (i.e. when PrintRange is set to kPrintAllSheets or kPrintSheetRange) should be printed. Defaults to False.
PrintRange | Property indicating which sheets are to be printed. Defaults to kPrintCurrentSheet.
RemoveLineWeights | Property indicating whether the Drawing line weights should be removed in the print.
Rotate90Degrees | Property that indicates whether the drawing should be rotated 90 degrees when printed. This property only applies to drawing documents. It is initialized to False.
Scale | Property that indicates the scale of the plot. This property is only valid when the Scalemode property is set to kCustomScale.
ScaleMode | Property that indicates how the scale of the print is defined. The options below can be used in drawing documents. All other documents always print using the best fit option.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties


ApprenticeDrawingPrintManager.AllColorsAsBlack Property

ApprenticeDrawingPrintManager.AllColorsAsBlack Property Available in Apprentice Introduced in Inventor 9
Summary

This property indicates the Boolean flag indicating whether all the Drawing colors should be printed in black only.

Visual Basic
Property AllColorsAsBlack() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.AllColorsAsBlack Property


ApprenticeDrawingPrintManager.PrintExcludedSheets Property

ApprenticeDrawingPrintManager.PrintExcludedSheets Property Available in Apprentice Introduced in Inventor 9
Summary

Property indicating whether excluded sheets (i.e. when PrintRange is set to kPrintAllSheets or kPrintSheetRange) should be printed. Defaults to False.

Visual Basic
Property PrintExcludedSheets() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.PrintExcludedSheets Property


ApprenticeDrawingPrintManager.PrintRange Property

ApprenticeDrawingPrintManager.PrintRange Property Available in Apprentice Introduced in Inventor 9
Summary

Property indicating which sheets are to be printed. Defaults to kPrintCurrentSheet.

Visual Basic
Property PrintRange() As PrintRangeEnum
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.PrintRange Property


ApprenticeDrawingPrintManager.RemoveLineWeights Property

ApprenticeDrawingPrintManager.RemoveLineWeights Property Available in Apprentice Introduced in Inventor 9
Summary

Property indicating whether the Drawing line weights should be removed in the print.

Visual Basic
Property RemoveLineWeights() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.RemoveLineWeights Property


ApprenticeDrawingPrintManager.Rotate90Degrees Property

ApprenticeDrawingPrintManager.Rotate90Degrees Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates whether the drawing should be rotated 90 degrees when printed. This property only applies to drawing documents. It is initialized to False.

Visual Basic
Property Rotate90Degrees() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.Rotate90Degrees Property


ApprenticeDrawingPrintManager.Scale Property

ApprenticeDrawingPrintManager.Scale Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the scale of the plot. This property is only valid when the Scalemode property is set to kCustomScale.

Visual Basic
Property Scale() As double
Remarks

The scale is specified in a decimal form. For example if you need to plot as drawing as 1/4 scale, this property should be set to 0.25. If you need to plot at twice the scale this property should be set to 2. If the paper is smaller than the specified sheet size, a portion of the sheet will not print. Please note: because "Scale" is a reserved word in Visual Basic and Visual Basic for Applications, you must enclose it in brackets in your code (e.g. Set oDrawingPrintManager.[Scale] = 1)

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.Scale Property


ApprenticeDrawingPrintManager.ScaleMode Property

ApprenticeDrawingPrintManager.ScaleMode Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates how the scale of the print is defined. The options below can be used in drawing documents. All other documents always print using the best fit option.

Visual Basic
Property ScaleMode() As PrintScaleModeEnum
Remarks

This property is initialized to kPrintBestFitScale. If this property is set to kPrintFullScale then the plot is printed at full scale. If the paper is smaller than the specified sheet size, a portion of the sheet will not print. If this property is set to kPrintBestFitScale the sheet will be scaled to fit on the current paper size. This is the only valid option when printing from anything but a drawing document. If this property is set to kCustomScale, you can use the Scale property to specify a precise scale. If the paper is smaller than the specified sheet size, a portion of the sheet will not print. If this property is set to kPrintCurrentWindow the contents displayed within the currently active window are printed using a best-fit scale. Any graphics outside the window are not printed.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeDrawingPrintManager Interface > ApprenticeDrawingPrintManager Properties > ApprenticeDrawingPrintManager.ScaleMode Property


ApprenticePrintManager Interface

ApprenticePrintManager Interface Available in Apprentice Introduced in Inventor 9
Summary

The ApprenticePrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print job.

Class Hierarchy
Inventor::ApprenticePrintManager
    Inventor::ApprenticeDrawingPrintManager
Visual Basic
Public Interface ApprenticePrintManager
Inherits IDispatch
Remarks

This object is used for all document types besides drawings.

Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.PrintManager

You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface


ApprenticePrintManager Methods

ApprenticePrintManager Methods
Summary

The methods of the ApprenticePrintManager class are listed here.

Methods
Methods
Name | Description
PrintToFile | Method that prints to the specified file using the current property settings defined by the ApprenticePrintManager object.
SetCurrentView | Property to set the current view, to be used for printing.
SubmitPrint | Method that prints using the current property settings defined by the ApprenticePrintManager object.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Methods


ApprenticePrintManager.PrintToFile Method

ApprenticePrintManager.PrintToFile Method Available in Apprentice Introduced in Inventor 9
Summary

Method that prints to the specified file using the current property settings defined by the ApprenticePrintManager object.

Visual Basic
Sub PrintToFile(FileName As String)
Parameters
Parameters | Description
FileName | Input String that specifies the full path of the file to write the print information to. If the specified file already exists it will be overwritten.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Methods > ApprenticePrintManager.PrintToFile Method


ApprenticePrintManager.SetCurrentView Method

ApprenticePrintManager.SetCurrentView Method Available in Apprentice Introduced in Inventor 9
Summary

Property to set the current view, to be used for printing.

Visual Basic
Sub SetCurrentView(CurrentView As ClientView)
Parameters
Parameters | Description
pCurrentView | ClientView object to set the current view to.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Methods > ApprenticePrintManager.SetCurrentView Method


ApprenticePrintManager.SubmitPrint Method

ApprenticePrintManager.SubmitPrint Method Available in Apprentice Introduced in Inventor 9
Summary

Method that prints using the current property settings defined by the ApprenticePrintManager object.

Visual Basic
Sub SubmitPrint()
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Methods > ApprenticePrintManager.SubmitPrint Method


ApprenticePrintManager Properties

ApprenticePrintManager Properties
Summary

The properties of the ApprenticePrintManager class are listed here.

Properties
Name | Description
ColorMode | Property that indicates the color mode for printing. This is initialized with kPrintGrayScale.
NumberOfCopies | Property that indicates the number of copies to print. This is initialized with a value of 1.
Orientation | Property that indicates the orientation of the print. This is initialized with the default orientation of the current printer.
PaperHeight | Property that indicates the height of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.
PaperSize | Property that indicates the size of the paper. This is initialized with the default paper size of the current printer. If this property is set kPaperSizeCustom then the PaperHeight and PaperWidth properties can be used to define any paper size.
PaperSource | Property that indicates the location of the paper to use when printing. Different printer models support different paper sources, such as upper tray, envelope feed, cassette, and manual feed.
PaperWidth | Property that indicates the width of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.
Printer | Property that indicates the name of the printing device. This is initialized with the name of the default printer.
PrinterDeviceContext | Property indicating the handle to the Windows device context that is used when printing.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties


ApprenticePrintManager.ColorMode Property

ApprenticePrintManager.ColorMode Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the color mode for printing. This is initialized with kPrintGrayScale.

Visual Basic
Property ColorMode() As PrintColorModeEnum
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.ColorMode Property


ApprenticePrintManager.NumberOfCopies Property

ApprenticePrintManager.NumberOfCopies Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the number of copies to print. This is initialized with a value of 1.

Visual Basic
Property NumberOfCopies() As long
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.NumberOfCopies Property


ApprenticePrintManager.Orientation Property

ApprenticePrintManager.Orientation Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the orientation of the print. This is initialized with the default orientation of the current printer.

Visual Basic
Property Orientation() As PrintOrientationEnum
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.Orientation Property


ApprenticePrintManager.PaperHeight Property

ApprenticePrintManager.PaperHeight Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the height of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.

Visual Basic
Property PaperHeight() As double
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.PaperHeight Property


ApprenticePrintManager.PaperSize Property

ApprenticePrintManager.PaperSize Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the size of the paper. This is initialized with the default paper size of the current printer. If this property is set kPaperSizeCustom then the PaperHeight and PaperWidth properties can be used to define any paper size.

Visual Basic
Property PaperSize() As PaperSizeEnum
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.PaperSize Property


ApprenticePrintManager.PaperSource Property

ApprenticePrintManager.PaperSource Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the location of the paper to use when printing. Different printer models support different paper sources, such as upper tray, envelope feed, cassette, and manual feed.

Visual Basic
Property PaperSource() As long
Remarks

This property is initialized to -1, which indicates the printer should use the paper tray that supports the paper size you have selected. All other options are printer-dependent and are specified by using an index. What value applies to what paper source will need to be determined by trial and error testing.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.PaperSource Property


ApprenticePrintManager.PaperWidth Property

ApprenticePrintManager.PaperWidth Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the width of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.

Visual Basic
Property PaperWidth() As double
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.PaperWidth Property


ApprenticePrintManager.Printer Property

ApprenticePrintManager.Printer Property Available in Apprentice Introduced in Inventor 9
Summary

Property that indicates the name of the printing device. This is initialized with the name of the default printer.

Visual Basic
Property Printer() As String
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.Printer Property


ApprenticePrintManager.PrinterDeviceContext Property

ApprenticePrintManager.PrinterDeviceContext Property Available in Apprentice Introduced in Inventor 9
Summary

Property indicating the handle to the Windows device context that is used when printing.

Visual Basic
Property PrinterDeviceContext() As long
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.PrinterDeviceContext Property


ApprenticePrintManager.Type Property

ApprenticePrintManager.Type Property Available in Apprentice Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticePrintManager Interface > ApprenticePrintManager Properties > ApprenticePrintManager.Type Property


ApprenticeServer Interface

ApprenticeServer Interface Available in Apprentice
Summary

Standalone mini component allowing limited access to an Inventor File.

Refer to the Apprentice Server overview article.

Class Hierarchy
Inventor::ApprenticeServer
Visual Basic
Public Interface ApprenticeServer
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface


ApprenticeServer Methods

ApprenticeServer Methods
Summary

The methods of the ApprenticeServer class are listed here.

Methods
Methods
Name | Description
Close | Closes the current file. After this call there is no top-level Document. An attempt is also made to close the children Documents.
FileAccessEvents | The FileAccessEvents object supports a set of properties and events used to get access to files.
FileLocations | Gets the object that provides access to the File Locations.
Open | Opens a file. It can now be accessed as the top-level Document
OpenWithOptions | Opens a document of the specified file-name with the specified set of options.
ReferenceKeyEvents | This is ReferenceKeyEvents, a member of class ApprenticeServer.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods


ApprenticeServer.Close Method

ApprenticeServer.Close Method Available in Apprentice
Summary

Closes the current file. After this call there is no top-level Document. An attempt is also made to close the children Documents.

Visual Basic
Sub Close()
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods > ApprenticeServer.Close Method


ApprenticeServer.FileAccessEvents Method

ApprenticeServer.FileAccessEvents Method Available in Apprentice
Summary

The FileAccessEvents object supports a set of properties and events used to get access to files.

Visual Basic
Sub FileAccessEvents(Result As [out, retval] FileAccessEvents*)
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods > ApprenticeServer.FileAccessEvents Method


ApprenticeServer.FileLocations Method

ApprenticeServer.FileLocations Method Available in Apprentice
Summary

Gets the object that provides access to the File Locations.

Visual Basic
Sub FileLocations(Result As [out, retval] FileLocations*)
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods > ApprenticeServer.FileLocations Method


ApprenticeServer.Open Method

ApprenticeServer.Open Method Available in Apprentice
Summary

Opens a file. It can now be accessed as the top-level Document

Visual Basic
Sub Open(FullDocumentName As String, Result As [out, retval] ApprenticeServerDocument*)
Parameters
Parameters | Description
FullDocumentName | Specifies the full document name of the document to open. If only the FullFileName is specified for part and assembly documents, the master document within the file is opened.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods > ApprenticeServer.Open Method


ApprenticeServer.OpenWithOptions Method

ApprenticeServer.OpenWithOptions Method Available in Apprentice
Summary

Opens a document of the specified file-name with the specified set of options.

Visual Basic
Sub OpenWithOptions(FullDocumentName As String, Options As NameValueMap, Result As [out, retval] ApprenticeServerDocument*)
Parameters
Parameters | Description
FullDocumentName | Input String that specifies the full document name of the document to open. If only the FullFileName is specified for an assembly, the master document within the file is opened.
Options | Input NameValueMap object that specifies additional options for open. (An empty NameValueMap object can be provided).
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods > ApprenticeServer.OpenWithOptions Method


ApprenticeServer.ReferenceKeyEvents Method

ApprenticeServer.ReferenceKeyEvents Method
Summary

This is ReferenceKeyEvents, a member of class ApprenticeServer.

Visual Basic
Sub ReferenceKeyEvents(Result As [out, retval] ReferenceKeyEvents*)
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Methods > ApprenticeServer.ReferenceKeyEvents Method


ApprenticeServer Properties

ApprenticeServer Properties
Summary

The properties of the ApprenticeServer class are listed here.

Properties
Name | Description
ApplicationAddIns | Gets all the Application AddIns found on this machine in a collection.
DesignProjectManager | Property that returns the DesignProjectManager object.
DisplayAffinity | Indicates the Boolean flag that fine tunes the performance of Apprentice when it is being used to display Inventor files. Defaults to false.
DisplayOptions | Get the DisplayOptions object.
Document | Gets the top-level Apprentice Server Document.
FileManager | Gets the file manager object.
FileOptions | Gets the File Options object.
FileSaveAs | Gets the object that provides access to the helper object that provides the Save As facility.
HardwareOptions | Get the HardwareOptions object.
InstallPath | Property that returns the full path where Inventor/Apprentice is installed.
Locale | Gets the Locale Id currently in use in Inventor.
MultiUserExternallyManaged | Get or set the Boolean flag indicating whether Multi-User facility is managed by Inventor or not.
MultiUserMode | Get or set the enum indicating the Multi-User mode.
SoftwareVersion | Gets the object that encapsulates the version of the current software.
TransientGeometry | Gets the object through which all transient geometry objects can be constructed.
TransientObjects | Property that returns the TransientObjects object.
Type | Gets the constant that indicates the type of this object.
UserName | Get or set the string that identifies the current user. Inventor saves its own copy of this name per user and can thus be manipulated without effecting the rest of the OS.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties


ApprenticeServer.ApplicationAddIns Property

ApprenticeServer.ApplicationAddIns Property Available in Apprentice
Summary

Gets all the Application AddIns found on this machine in a collection.

Visual Basic
Property ApplicationAddIns() As ApplicationAddIns**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.ApplicationAddIns Property


ApprenticeServer.DesignProjectManager Property

ApprenticeServer.DesignProjectManager Property Available in Apprentice
Summary

Property that returns the DesignProjectManager object.

Visual Basic
Property DesignProjectManager() As DesignProjectManager**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.DesignProjectManager Property


ApprenticeServer.DisplayAffinity Property

ApprenticeServer.DisplayAffinity Property Available in Apprentice
Summary

Indicates the Boolean flag that fine tunes the performance of Apprentice when it is being used to display Inventor files. Defaults to false.

Visual Basic
Property DisplayAffinity() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.DisplayAffinity Property


ApprenticeServer.DisplayOptions Property

ApprenticeServer.DisplayOptions Property Available in Apprentice
Summary

Get the DisplayOptions object.

Visual Basic
Property DisplayOptions() As DisplayOptions**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.DisplayOptions Property


ApprenticeServer.Document Property

ApprenticeServer.Document Property Available in Apprentice
Summary

Gets the top-level Apprentice Server Document.

Visual Basic
Property Document() As ApprenticeServerDocument**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.Document Property


ApprenticeServer.FileManager Property

ApprenticeServer.FileManager Property Available in Apprentice
Summary

Gets the file manager object.

Visual Basic
Property FileManager() As FileManager**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.FileManager Property


ApprenticeServer.FileOptions Property

ApprenticeServer.FileOptions Property Available in Apprentice
Summary

Gets the File Options object.

Visual Basic
Property FileOptions() As FileOptions**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.FileOptions Property


ApprenticeServer.FileSaveAs Property

ApprenticeServer.FileSaveAs Property Available in Apprentice
Summary

Gets the object that provides access to the helper object that provides the Save As facility.

Visual Basic
Property FileSaveAs() As FileSaveAs**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.FileSaveAs Property


ApprenticeServer.HardwareOptions Property

ApprenticeServer.HardwareOptions Property Available in Apprentice
Summary

Get the HardwareOptions object.

Visual Basic
Property HardwareOptions() As HardwareOptions**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.HardwareOptions Property


ApprenticeServer.InstallPath Property

ApprenticeServer.InstallPath Property Available in Apprentice
Summary

Property that returns the full path where Inventor/Apprentice is installed.

Visual Basic
Property InstallPath() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.InstallPath Property


ApprenticeServer.Locale Property

ApprenticeServer.Locale Property Available in Apprentice
Summary

Gets the Locale Id currently in use in Inventor.

Visual Basic
Property Locale() As long*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.Locale Property


ApprenticeServer.MultiUserExternallyManaged Property

ApprenticeServer.MultiUserExternallyManaged Property Available in Apprentice
Summary

Get or set the Boolean flag indicating whether Multi-User facility is managed by Inventor or not.

Visual Basic
Property MultiUserExternallyManaged() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.MultiUserExternallyManaged Property


ApprenticeServer.MultiUserMode Property

ApprenticeServer.MultiUserMode Property Available in Apprentice
Summary

Get or set the enum indicating the Multi-User mode.

Visual Basic
Property MultiUserMode() As MultiUserModeEnum
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.MultiUserMode Property


ApprenticeServer.SoftwareVersion Property

ApprenticeServer.SoftwareVersion Property Available in Apprentice
Summary

Gets the object that encapsulates the version of the current software.

Visual Basic
Property SoftwareVersion() As SoftwareVersion**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.SoftwareVersion Property


ApprenticeServer.TransientGeometry Property

ApprenticeServer.TransientGeometry Property Available in Apprentice
Summary

Gets the object through which all transient geometry objects can be constructed.

Visual Basic
Property TransientGeometry() As TransientGeometry**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.TransientGeometry Property


ApprenticeServer.TransientObjects Property

ApprenticeServer.TransientObjects Property Available in Apprentice
Summary

Property that returns the TransientObjects object.

Visual Basic
Property TransientObjects() As TransientObjects**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.TransientObjects Property


ApprenticeServer.Type Property

ApprenticeServer.Type Property Available in Apprentice
Summary

Gets the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.Type Property


ApprenticeServer.UserName Property

ApprenticeServer.UserName Property Available in Apprentice
Summary

Get or set the string that identifies the current user. Inventor saves its own copy of this name per user and can thus be manipulated without effecting the rest of the OS.

Visual Basic
Property UserName() As String
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServer Interface > ApprenticeServer Properties > ApprenticeServer.UserName Property


ApprenticeServerComponent CoClass

ApprenticeServerComponent CoClass Available in Apprentice Introduced in Inventor 4
Summary

Standalone mini component allowing limited access to an Inventor File.

Refer to the Apprentice Server overview article.

Class Hierarchy
Inventor::ApprenticeServerComponent
Visual Basic
Public Class ApprenticeServerComponent
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerComponent CoClass


ApprenticeServerDocument Interface

ApprenticeServerDocument Interface Available in Apprentice Introduced in Inventor 4
Summary

The ApprenticeServerDocument object represents an in-memory Inventor document.

Class Hierarchy
Inventor::ApprenticeServerDocument
    Inventor::ApprenticeServerDrawingDocument
Visual Basic
Public Interface ApprenticeServerDocument
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ApprenticeServer.Document

ApprenticeServer.Open

ApprenticeServer.OpenWithOptions

ApprenticeServerDocuments.Item

ClientView.Document

ComponentDefinition.Document

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface


ApprenticeServerDocument Methods

ApprenticeServerDocument Methods
Summary

The methods of the ApprenticeServerDocument class are listed here.

Methods
Methods
Name | Description
Close | Closes this document.
CreateHighlightSet | Method that creates a new highlight set.
FindWhereUsed | Method that obtains the set of documents that reference the given file within this document.
GetLocationFoundIn | Obtains the name of the location this file was found in.
RevertReservedForWriteByMe | Method that reverts the file checked out by the caller.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Methods


ApprenticeServerDocument.Close Method

ApprenticeServerDocument.Close Method Available in Apprentice Introduced in Inventor 2008
Summary

Closes this document.

Visual Basic
Sub Close()
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Methods > ApprenticeServerDocument.Close Method


ApprenticeServerDocument.CreateHighlightSet Method

ApprenticeServerDocument.CreateHighlightSet Method Available in Apprentice Introduced in Inventor 2008
Summary

Method that creates a new highlight set.

Visual Basic
Sub CreateHighlightSet(Result As [out, retval] HighlightSet*)
Remarks

The returned object is transient in nature and is destroyed when all references to it are lost.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Methods > ApprenticeServerDocument.CreateHighlightSet Method


ApprenticeServerDocument.FindWhereUsed Method

ApprenticeServerDocument.FindWhereUsed Method Available in Apprentice Introduced in Inventor 5
Summary

Method that obtains the set of documents that reference the given file within this document.

Visual Basic
Sub FindWhereUsed(FullFileName As String, Result As [out, retval] ApprenticeServerDocuments*)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of the file to search for references to. to.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Methods > ApprenticeServerDocument.FindWhereUsed Method


ApprenticeServerDocument.GetLocationFoundIn Method

ApprenticeServerDocument.GetLocationFoundIn Method Available in Apprentice Introduced in Inventor 4
Summary

Obtains the name of the location this file was found in.

Visual Basic
Sub GetLocationFoundIn(ByRef LocationName As String, ByRef Type As LocationTypeEnum)
Parameters
Parameters | Description
LocationName | Output String that specifies the name of the location.
Type | Output that specifies the location type.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Methods > ApprenticeServerDocument.GetLocationFoundIn Method


ApprenticeServerDocument.RevertReservedForWriteByMe Method

ApprenticeServerDocument.RevertReservedForWriteByMe Method Available in Apprentice Introduced in Inventor 6
Summary

Method that reverts the file checked out by the caller.

Visual Basic
Sub RevertReservedForWriteByMe()
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Methods > ApprenticeServerDocument.RevertReservedForWriteByMe Method


ApprenticeServerDocument Properties

ApprenticeServerDocument Properties
Summary

The properties of the ApprenticeServerDocument class are listed here.

Properties
Name | Description
ActiveRenderStyle | Property that returns the render style currently being used for the part.
AllReferencedDocuments | Property that returns all the document references of this document along with all of the recursively nested references.
AttributeManager | Returns the AttributeManager object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ClientViews | Property that returns the document's .
Compacted | Gets the Boolean that states whether this file has been processed for compaction since the last save.
ComponentDefinition | Gets the primary that resides in this file.
DatabaseRevisionId | Gets the GUID that represents the last saved revision of database contained in this document. This revision id tracks modifications to the database (such as reference changes, geometry changes, etc.) but does not track file property changes.
Dirty | Gets/Sets a Boolean flag indicating if the Document has been written into, since opened.
DisplayName | Gets/Sets the user-displayable name of this Document. Defaults to file-name.
DocumentInterests | Property that returns the DocumentInterests collection object.
DocumentType | Gets the constant that indicates the type of this document.
File | Property that returns the file (storage) on disk that contains this document.
FileSaveCounter | Gets the number that indicates the number of times the file has been saved.
FullDocumentName | Property that returns the fully qualified name of the document. The string is the full file name concatenated with the document name and is a unique identifier for the document. The document name is returned by the Name property on the Document object.
FullFileName | Gets the fully qualified file-name of this document.
HealthStatus | Property that returns an enum indicating the current state of the object.
InternalName | Gets the Internal Name (a GUID) for this document.
IsModifiable | Property that returns whether this document can be currently modified. One of the reasons a document may be non-modifiable is if any other document belonging to the file containing this document is currently being edited.
IsSubstitutePart | Property that returns whether this part is intended to be used as a substitute part.
NeedsMigrating | Gets the Boolean indicating whether this file needs to be migrated first, using Autodesk Inventor (opened and saved using Autodesk Inventor), before any edits can be performed to the Autodesk Inventor-specific data within this file.
Open | Property that returns whether this document is currently open. If False, the document has only been initialized and calling methods or properties on the document could cause it to open.
PrintManager | Property that returns the object for this document.
PropertySets | Gets the object that manages the File Properties.
ReferencedDocumentDescriptors | Property that returns an enumeration of descriptors that represent the native document references held by this document.
ReferencedDocuments | Property that returns all the documents referenced by this document.
ReferencedOLEFileDescriptors | Property that returns the collection of linked files in the document. Embeddings are not accessible in Apprentice.
ReferenceKeyManager | Gets this Document's ReferenceKeyManager object.
ReferencingDocuments | Property that returns all the documents in memory that reference this document.
RequiresUpdate | Property that returns whether the document requires an update. Note that the document cannot be updated in Apprentice.
ReservedForWrite | Gets the Boolean flag indicating whether this file has been reserved for write by someone.
ReservedForWriteByMe | Gets/Sets the Boolean flag indicating whether this file has been reserved for write by the caller.
ReservedForWriteLogin | Gets the login of the person who currently holds the reservation to write.
ReservedForWriteName | Gets the name of the person who currently holds the reservation to write.
ReservedForWriteTime | Gets the time at which the reservation was made.
ReservedForWriteVersion | Gets the version within this file that has been reserved for write.
RevisionId | Gets the GUID that represents the last saved revision of this file. Works as a stamp of the contents of this file.
SoftwareVersionCreated | Gets the object that encapsulates the version of the software with which this document was first created.
SoftwareVersionSaved | Gets the object that encapsulates the version of the software with which this document was last saved.
SubstitutePartStatus | Property that returns whether this substitute part is up to date with respect to external links.
Thumbnail | Property that returns a bitmap picture of the document.
Type | Property returning an enum indicating this object's type.
UnitsOfMeasure | Property that returns the UnitsOfMeasure object.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties


ApprenticeServerDocument.ActiveRenderStyle Property

ApprenticeServerDocument.ActiveRenderStyle Property Available in Apprentice Introduced in Inventor 5
Summary

Property that returns the render style currently being used for the part.

Visual Basic
Property ActiveRenderStyle() As RenderStyle**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ActiveRenderStyle Property


ApprenticeServerDocument.AllReferencedDocuments Property

ApprenticeServerDocument.AllReferencedDocuments Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns all the document references of this document along with all of the recursively nested references.

Visual Basic
Property AllReferencedDocuments() As ApprenticeServerDocuments**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.AllReferencedDocuments Property


ApprenticeServerDocument.AttributeManager Property

ApprenticeServerDocument.AttributeManager Property Available in Apprentice Introduced in Inventor 5
Summary

Returns the AttributeManager object.

Visual Basic
Property AttributeManager() As AttributeManager**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.AttributeManager Property


ApprenticeServerDocument.AttributeSets Property

ApprenticeServerDocument.AttributeSets Property Available in Apprentice
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.AttributeSets Property


ApprenticeServerDocument.ClientViews Property

ApprenticeServerDocument.ClientViews Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the document's .

Visual Basic
Property ClientViews() As ClientViews**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ClientViews Property


ApprenticeServerDocument.Compacted Property

ApprenticeServerDocument.Compacted Property Available in Apprentice Introduced in Inventor 5
Summary

Gets the Boolean that states whether this file has been processed for compaction since the last save.

Visual Basic
Property Compacted() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.Compacted Property


ApprenticeServerDocument.ComponentDefinition Property

ApprenticeServerDocument.ComponentDefinition Property Available in Apprentice Introduced in Inventor 5
Summary

Gets the primary that resides in this file.

Visual Basic
Property ComponentDefinition() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ComponentDefinition Property


ApprenticeServerDocument.DatabaseRevisionId Property

ApprenticeServerDocument.DatabaseRevisionId Property Available in Apprentice Introduced in Inventor 11
Summary

Gets the GUID that represents the last saved revision of database contained in this document. This revision id tracks modifications to the database (such as reference changes, geometry changes, etc.) but does not track file property changes.

Visual Basic
Property DatabaseRevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.DatabaseRevisionId Property


ApprenticeServerDocument.Dirty Property

ApprenticeServerDocument.Dirty Property Available in Apprentice Introduced in Inventor 4
Summary

Gets/Sets a Boolean flag indicating if the Document has been written into, since opened.

Visual Basic
Property Dirty() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.Dirty Property


ApprenticeServerDocument.DisplayName Property

ApprenticeServerDocument.DisplayName Property Available in Apprentice Introduced in Inventor 4
Summary

Gets/Sets the user-displayable name of this Document. Defaults to file-name.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.DisplayName Property


ApprenticeServerDocument.DocumentInterests Property

ApprenticeServerDocument.DocumentInterests Property Available in Apprentice Introduced in Inventor 2008
Summary

Property that returns the DocumentInterests collection object.

Visual Basic
Property DocumentInterests() As DocumentInterests**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.DocumentInterests Property


ApprenticeServerDocument.DocumentType Property

ApprenticeServerDocument.DocumentType Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the constant that indicates the type of this document.

Visual Basic
Property DocumentType() As DocumentTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.DocumentType Property


ApprenticeServerDocument.File Property

ApprenticeServerDocument.File Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns the file (storage) on disk that contains this document.

Visual Basic
Property File() As File**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.File Property


ApprenticeServerDocument.FileSaveCounter Property

ApprenticeServerDocument.FileSaveCounter Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the number that indicates the number of times the file has been saved.

Visual Basic
Property FileSaveCounter() As long*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.FileSaveCounter Property


ApprenticeServerDocument.FullDocumentName Property

ApprenticeServerDocument.FullDocumentName Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns the fully qualified name of the document. The string is the full file name concatenated with the document name and is a unique identifier for the document. The document name is returned by the Name property on the Document object.

Visual Basic
Property FullDocumentName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.FullDocumentName Property


ApprenticeServerDocument.FullFileName Property

ApprenticeServerDocument.FullFileName Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the fully qualified file-name of this document.

Visual Basic
Property FullFileName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.FullFileName Property


ApprenticeServerDocument.HealthStatus Property

ApprenticeServerDocument.HealthStatus Property Available in Apprentice Introduced in Inventor 5.3
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.HealthStatus Property


ApprenticeServerDocument.InternalName Property

ApprenticeServerDocument.InternalName Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the Internal Name (a GUID) for this document.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.InternalName Property


ApprenticeServerDocument.IsModifiable Property

ApprenticeServerDocument.IsModifiable Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns whether this document can be currently modified. One of the reasons a document may be non-modifiable is if any other document belonging to the file containing this document is currently being edited.

Visual Basic
Property IsModifiable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.IsModifiable Property


ApprenticeServerDocument.IsSubstitutePart Property

ApprenticeServerDocument.IsSubstitutePart Property Available in Apprentice Introduced in Inventor 2009
Summary

Property that returns whether this part is intended to be used as a substitute part.

Visual Basic
Property IsSubstitutePart() As VARIANT_BOOL*
Remarks

This property applies only to part documents and returns False for other document types.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.IsSubstitutePart Property


ApprenticeServerDocument.NeedsMigrating Property

ApprenticeServerDocument.NeedsMigrating Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the Boolean indicating whether this file needs to be migrated first, using Autodesk Inventor (opened and saved using Autodesk Inventor), before any edits can be performed to the Autodesk Inventor-specific data within this file.

Visual Basic
Property NeedsMigrating() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.NeedsMigrating Property


ApprenticeServerDocument.Open Property

ApprenticeServerDocument.Open Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns whether this document is currently open. If False, the document has only been initialized and calling methods or properties on the document could cause it to open.

Visual Basic
Property Open() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.Open Property


ApprenticeServerDocument.PrintManager Property

ApprenticeServerDocument.PrintManager Property Available in Apprentice Introduced in Inventor 9
Summary

Property that returns the object for this document.

Visual Basic
Property PrintManager() As ApprenticePrintManager**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.PrintManager Property


ApprenticeServerDocument.PropertySets Property

ApprenticeServerDocument.PropertySets Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the object that manages the File Properties.

Visual Basic
Property PropertySets() As PropertySets**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.PropertySets Property


ApprenticeServerDocument.ReferencedDocumentDescriptors Property

ApprenticeServerDocument.ReferencedDocumentDescriptors Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns an enumeration of descriptors that represent the native document references held by this document.

Visual Basic
Property ReferencedDocumentDescriptors() As DocumentDescriptorsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReferencedDocumentDescriptors Property


ApprenticeServerDocument.ReferencedDocuments Property

ApprenticeServerDocument.ReferencedDocuments Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns all the documents referenced by this document.

Visual Basic
Property ReferencedDocuments() As ApprenticeServerDocuments**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReferencedDocuments Property


ApprenticeServerDocument.ReferencedOLEFileDescriptors Property

ApprenticeServerDocument.ReferencedOLEFileDescriptors Property Available in Apprentice Introduced in Inventor 4
Summary

Property that returns the collection of linked files in the document. Embeddings are not accessible in Apprentice.

Visual Basic
Property ReferencedOLEFileDescriptors() As ReferencedOLEFileDescriptors**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReferencedOLEFileDescriptors Property


ApprenticeServerDocument.ReferenceKeyManager Property

ApprenticeServerDocument.ReferenceKeyManager Property Available in Apprentice Introduced in Inventor 2010
Summary

Gets this Document's ReferenceKeyManager object.

Visual Basic
Property ReferenceKeyManager() As ReferenceKeyManager**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReferenceKeyManager Property


ApprenticeServerDocument.ReferencingDocuments Property

ApprenticeServerDocument.ReferencingDocuments Property Available in Apprentice Introduced in Inventor 11
Summary

Property that returns all the documents in memory that reference this document.

Visual Basic
Property ReferencingDocuments() As ApprenticeServerDocuments**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReferencingDocuments Property


ApprenticeServerDocument.RequiresUpdate Property

ApprenticeServerDocument.RequiresUpdate Property Available in Apprentice
Summary

Property that returns whether the document requires an update. Note that the document cannot be updated in Apprentice.

Visual Basic
Property RequiresUpdate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.RequiresUpdate Property


ApprenticeServerDocument.ReservedForWrite Property

ApprenticeServerDocument.ReservedForWrite Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the Boolean flag indicating whether this file has been reserved for write by someone.

Visual Basic
Property ReservedForWrite() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReservedForWrite Property


ApprenticeServerDocument.ReservedForWriteByMe Property

ApprenticeServerDocument.ReservedForWriteByMe Property Available in Apprentice Introduced in Inventor 4
Summary

Gets/Sets the Boolean flag indicating whether this file has been reserved for write by the caller.

Visual Basic
Property ReservedForWriteByMe() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReservedForWriteByMe Property


ApprenticeServerDocument.ReservedForWriteLogin Property

ApprenticeServerDocument.ReservedForWriteLogin Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the login of the person who currently holds the reservation to write.

Visual Basic
Property ReservedForWriteLogin() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReservedForWriteLogin Property


ApprenticeServerDocument.ReservedForWriteName Property

ApprenticeServerDocument.ReservedForWriteName Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the name of the person who currently holds the reservation to write.

Visual Basic
Property ReservedForWriteName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReservedForWriteName Property


ApprenticeServerDocument.ReservedForWriteTime Property

ApprenticeServerDocument.ReservedForWriteTime Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the time at which the reservation was made.

Visual Basic
Property ReservedForWriteTime() As DATE*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReservedForWriteTime Property


ApprenticeServerDocument.ReservedForWriteVersion Property

ApprenticeServerDocument.ReservedForWriteVersion Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the version within this file that has been reserved for write.

Visual Basic
Property ReservedForWriteVersion() As long*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.ReservedForWriteVersion Property


ApprenticeServerDocument.RevisionId Property

ApprenticeServerDocument.RevisionId Property Available in Apprentice Introduced in Inventor 5.3
Summary

Gets the GUID that represents the last saved revision of this file. Works as a stamp of the contents of this file.

Visual Basic
Property RevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.RevisionId Property


ApprenticeServerDocument.SoftwareVersionCreated Property

ApprenticeServerDocument.SoftwareVersionCreated Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the object that encapsulates the version of the software with which this document was first created.

Visual Basic
Property SoftwareVersionCreated() As SoftwareVersion**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.SoftwareVersionCreated Property


ApprenticeServerDocument.SoftwareVersionSaved Property

ApprenticeServerDocument.SoftwareVersionSaved Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the object that encapsulates the version of the software with which this document was last saved.

Visual Basic
Property SoftwareVersionSaved() As SoftwareVersion**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.SoftwareVersionSaved Property


ApprenticeServerDocument.SubstitutePartStatus Property

ApprenticeServerDocument.SubstitutePartStatus Property Available in Apprentice Introduced in Inventor 2009
Summary

Property that returns whether this substitute part is up to date with respect to external links.

Visual Basic
Property SubstitutePartStatus() As ReferenceStatusEnum*
Remarks

This property is applicable only if the IsSubstitutePart property returns False. Possible return values are kUpToDateReference, kOutOfDateReference and kMissingReference. The property returns kUnknownReference if the IsSubstitutePart property returns False.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.SubstitutePartStatus Property


ApprenticeServerDocument.Thumbnail Property

ApprenticeServerDocument.Thumbnail Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns a bitmap picture of the document.

Visual Basic
Property Thumbnail() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.Thumbnail Property


ApprenticeServerDocument.Type Property

ApprenticeServerDocument.Type Property Available in Apprentice Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.Type Property


ApprenticeServerDocument.UnitsOfMeasure Property

ApprenticeServerDocument.UnitsOfMeasure Property Available in Apprentice Introduced in Inventor 5
Summary

Property that returns the UnitsOfMeasure object.

Visual Basic
Property UnitsOfMeasure() As UnitsOfMeasure**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocument Interface > ApprenticeServerDocument Properties > ApprenticeServerDocument.UnitsOfMeasure Property


ApprenticeServerDocuments Interface

ApprenticeServerDocuments Interface Available in Apprentice Introduced in Inventor 4
Summary

Provides access to a list of objects.

Class Hierarchy
Inventor::ApprenticeServerDocuments
Visual Basic
Public Interface ApprenticeServerDocuments
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.AllReferencedDocuments

ApprenticeServerDocument.ReferencedDocuments

ApprenticeServerDocument.ReferencingDocuments

ApprenticeServerDocument.AllReferencedFiles

ApprenticeServerDocument.FindWhereUsed

ApprenticeServerDocument.ReferencedFiles

File.AvailableDocuments

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocuments Interface


ApprenticeServerDocuments Methods

ApprenticeServerDocuments Methods
Summary

The methods of the ApprenticeServerDocuments class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified ApprenticeServerDocument object from the collection. This is the default property of the ApprenticeServerDocuments object.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocuments Interface > ApprenticeServerDocuments Methods


ApprenticeServerDocuments.Item Method

ApprenticeServerDocuments.Item Method Available in Apprentice Introduced in Inventor 4
Summary

Property that returns the specified ApprenticeServerDocument object from the collection. This is the default property of the ApprenticeServerDocuments object.

Visual Basic
Sub Item(index As long, Result As [out, retval] ApprenticeServerDocument*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocuments Interface > ApprenticeServerDocuments Methods > ApprenticeServerDocuments.Item Method


ApprenticeServerDocuments Properties

ApprenticeServerDocuments Properties
Summary

The properties of the ApprenticeServerDocuments class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocuments Interface > ApprenticeServerDocuments Properties


ApprenticeServerDocuments.Count Property

ApprenticeServerDocuments.Count Property Available in Apprentice Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocuments Interface > ApprenticeServerDocuments Properties > ApprenticeServerDocuments.Count Property


ApprenticeServerDocuments.Type Property

ApprenticeServerDocuments.Type Property Available in Apprentice Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDocuments Interface > ApprenticeServerDocuments Properties > ApprenticeServerDocuments.Type Property


ApprenticeServerDrawingDocument Interface

ApprenticeServerDrawingDocument Interface Available in Apprentice Introduced in Inventor 4
Summary

The ApprenticeServerDrawingDocument object represents the drawing document within an Apprentice context, and provides access to the Sheets in the drawing.

Class Hierarchy
Inventor::ApprenticeServerDocument
    Inventor::ApprenticeServerDrawingDocument
Visual Basic
Public Interface ApprenticeServerDrawingDocument
Inherits ApprenticeServerDocument
Remarks

See the Apprentice Server article in the overviews section of this help.

You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDrawingDocument Interface


ApprenticeServerDrawingDocument Properties

ApprenticeServerDrawingDocument Properties
Summary

The properties of the ApprenticeServerDrawingDocument class are listed here.

Properties
Name | Description
ActiveStandard | Gets the currently active drafting standard that applies to all of the sheets.
ContainingDWGDocument | Gets the reference to the containing DWG document when this document is stored in a DWG.
IsInventorDWG | Property that returns whether this is an Inventor DWG document.
Sheets | Property that returns the collection of all the sheets making up this document.
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDrawingDocument Interface > ApprenticeServerDrawingDocument Properties


ApprenticeServerDrawingDocument.ActiveStandard Property

ApprenticeServerDrawingDocument.ActiveStandard Property Available in Apprentice Introduced in Inventor 4
Summary

Gets the currently active drafting standard that applies to all of the sheets.

Visual Basic
Property ActiveStandard() As DraftingStandard**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDrawingDocument Interface > ApprenticeServerDrawingDocument Properties > ApprenticeServerDrawingDocument.ActiveStandard Property


ApprenticeServerDrawingDocument.ContainingDWGDocument Property

ApprenticeServerDrawingDocument.ContainingDWGDocument Property Available in Apprentice Introduced in Inventor 2008
Summary

Gets the reference to the containing DWG document when this document is stored in a DWG.

Visual Basic
Property ContainingDWGDocument() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDrawingDocument Interface > ApprenticeServerDrawingDocument Properties > ApprenticeServerDrawingDocument.ContainingDWGDocument Property


ApprenticeServerDrawingDocument.IsInventorDWG Property

ApprenticeServerDrawingDocument.IsInventorDWG Property Available in Apprentice Introduced in Inventor 2008
Summary

Property that returns whether this is an Inventor DWG document.

Visual Basic
Property IsInventorDWG() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDrawingDocument Interface > ApprenticeServerDrawingDocument Properties > ApprenticeServerDrawingDocument.IsInventorDWG Property


ApprenticeServerDrawingDocument.Sheets Property

ApprenticeServerDrawingDocument.Sheets Property Available in Apprentice Introduced in Inventor 4
Summary

Property that returns the collection of all the sheets making up this document.

Visual Basic
Property Sheets() As Sheets**
You are here: Symbol Reference > Inventor Library > Objects > ApprenticeServerDrawingDocument Interface > ApprenticeServerDrawingDocument Properties > ApprenticeServerDrawingDocument.Sheets Property


Arc2d Interface

Arc2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Arc2d object is a mathematical representation of a 2d arc.

Class Hierarchy
Inventor::Arc2d
Visual Basic
Public Interface Arc2d
Inherits IDispatch
Remarks

It is a transient object that is never shown graphically or saved in the Inventor document. The Arc2d object is returned by graphical 2d entities that have an underlying arc shape. Arc2d objects can also be explicitly created using the CreateArc2d method of the TransientGeometry object.

When obtained from an graphical entity, the Arc2d object represents a snapshot of the graphical entity. If the graphical entity is modified it will not affect the Arc2d object. Also, if the Arc2d object is modified it will not affect the graphical entity it was obtained from.

Notes

Members through which this object may be accessed include:

SketchArc.Geometry

TransientGeometry.CreateArc2d

TransientGeometry.CreateArc2dByThreePoints

ProfileEntity.Curve

DrawingDimension.DimensionLine

Centerline.Geometry

You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface


Arc2d Methods

Arc2d Methods
Summary

The methods of the Arc2d class are listed here.

Methods
Methods
Name | Description
GetArcData | Get the data defining this arc.
PutArcData | Method that sets the data defining this arc.
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Methods


Arc2d.GetArcData Method

Arc2d.GetArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Get the data defining this arc.

Visual Basic
Sub GetArcData(ByRef Center As SAFEARRAY(double), ByRef Radius As double, ByRef StartAngle As double, ByRef SweepAngle As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the arc's center.
Radius | Output Double that specifies the radius of the arc.
StartAngle | Output Double that specifies the arc's start angle.
SweepAngle | Output Double that specifies the arc's sweep angle.
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Methods > Arc2d.GetArcData Method


Arc2d.PutArcData Method

Arc2d.PutArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the data defining this arc.

Visual Basic
Sub PutArcData(ByRef Center As SAFEARRAY(double), Radius As double, StartAngle As double, SweepAngle As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the arc's center.
Radius | Input Double that specifies the radius of the arc.
StartAngle | Input Double that specifies the arc's start angle.
SweepAngle | Input Double that specifies the arc's sweep angle.
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Methods > Arc2d.PutArcData Method


Arc2d Properties

Arc2d Properties
Summary

The properties of the Arc2d class are listed here.

Properties
Name | Description
Center | Property that gets and sets the center point of the arc.
EndPoint | Property that returns the end point of the arc.
Evaluator | Property that returns the Curve2dEvaluator for this arc.
Radius | Specifies the radius of the arc.
StartAngle | Specifies the arc's start angle.
StartPoint | Property that gets the start point of the arc.
SweepAngle | Specifies the arc's sweep angle.
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties


Arc2d.Center Property

Arc2d.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the center point of the arc.

Visual Basic
Property Center() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.Center Property


Arc2d.EndPoint Property

Arc2d.EndPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the end point of the arc.

Visual Basic
Property EndPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.EndPoint Property


Arc2d.Evaluator Property

Arc2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Curve2dEvaluator for this arc.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.Evaluator Property


Arc2d.Radius Property

Arc2d.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the radius of the arc.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.Radius Property


Arc2d.StartAngle Property

Arc2d.StartAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the arc's start angle.

Visual Basic
Property StartAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.StartAngle Property


Arc2d.StartPoint Property

Arc2d.StartPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the start point of the arc.

Visual Basic
Property StartPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.StartPoint Property


Arc2d.SweepAngle Property

Arc2d.SweepAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the arc's sweep angle.

Visual Basic
Property SweepAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Arc2d Interface > Arc2d Properties > Arc2d.SweepAngle Property


Arc3d Interface

Arc3d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

The Arc3d object is a mathematical representation of a 3d arc.

Class Hierarchy
Inventor::Arc3d
Visual Basic
Public Interface Arc3d
Inherits IDispatch
Remarks

It is a transient object that is never shown graphically or saved in the Inventor document. The Arc3d object is returned by graphical 3d entities that have an underlying arc shape. Arc3d objects can also be explicitly created using the CreateArc3d method of the TransientGeometry object.

When obtained from an graphical entity, the Arc3d object represents a snapshot of the graphical entity. If the graphical entity is modified it will not affect the Arc3d object. Also, if the Arc3d object is modified it will not affect the graphical entity it was obtained from.

Notes

Members through which this object may be accessed include:

SketchArc3D.Geometry

TransientGeometry.CreateArc3d

TransientGeometry.CreateArc3dByThreePoints

CurveGraphics.Curve

DrawingDimension.DimensionLine

Edge.Geometry

See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface


Arc3d Methods

Arc3d Methods
Summary

The methods of the Arc3d class are listed here.

Methods
Methods
Name | Description
GetArcData | Get the data defining this arc.
PutArcData | Method that sets the data defining this arc.
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Methods


Arc3d.GetArcData Method

Arc3d.GetArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Get the data defining this arc.

Visual Basic
Sub GetArcData(ByRef Center As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef RefVector As SAFEARRAY(double), ByRef Radius As double, ByRef StartAngle As double, ByRef SweepAngle As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the arc's center.
AxisVector | Input/output Double that specifies axis vector.
RefVector | Input/output Double that specifies the reference vector.
Radius | Output Double that specifies the radius of the arc.
StartAngle | Input Double that specifies the elliptical arc's start angle.
SweepAngle | Output Double that specifies the arc's sweep angle.
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Methods > Arc3d.GetArcData Method


Arc3d.PutArcData Method

Arc3d.PutArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the data defining this arc.

Visual Basic
Sub PutArcData(ByRef Center As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef RefVector As SAFEARRAY(double), Radius As double, StartAngle As double, SweepAngle As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the arc's center.
AxisVector | Input/output Double that specifies axis vector.
RefVector | Input/output Double that specifies the reference vector.
Radius | Input Double that specifies the radius of the arc.
StartAngle | Input Double that specifies the arc's start angle.
SweepAngle | Input Double that specifies the arc's sweep angle.
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Methods > Arc3d.PutArcData Method


Arc3d Properties

Arc3d Properties
Summary

The properties of the Arc3d class are listed here.

Properties
Name | Description
Center | Property that gets and sets the center point of the arc.
EndPoint | Property that returns the end point of the arc.
Evaluator | Property that gets the CurveEvaluator for this arc.
Normal | Property that gets and sets the axis vector of the arc.
Radius | Property that gets and sets the radius of the arc.
ReferenceVector | Property that gets and sets the direction that is used as the zero angle when measuring the start and end angles of the arc.
StartAngle | Property that gets and sets the start angle of the arc.
StartPoint | Property that gets the start point of the arc.
SweepAngle | Property that gets and sets the sweep angle of the arc.
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties


Arc3d.Center Property

Arc3d.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the center point of the arc.

Visual Basic
Property Center() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.Center Property


Arc3d.EndPoint Property

Arc3d.EndPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the end point of the arc.

Visual Basic
Property EndPoint() As Point**
See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.EndPoint Property


Arc3d.Evaluator Property

Arc3d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the CurveEvaluator for this arc.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.Evaluator Property


Arc3d.Normal Property

Arc3d.Normal Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the axis vector of the arc.

Visual Basic
Property Normal() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.Normal Property


Arc3d.Radius Property

Arc3d.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the radius of the arc.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.Radius Property


Arc3d.ReferenceVector Property

Arc3d.ReferenceVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the direction that is used as the zero angle when measuring the start and end angles of the arc.

Visual Basic
Property ReferenceVector() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.ReferenceVector Property


Arc3d.StartAngle Property

Arc3d.StartAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the start angle of the arc.

Visual Basic
Property StartAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.StartAngle Property


Arc3d.StartPoint Property

Arc3d.StartPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the start point of the arc.

Visual Basic
Property StartPoint() As Point**
See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.StartPoint Property


Arc3d.SweepAngle Property

Arc3d.SweepAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the sweep angle of the arc.

Visual Basic
Property SweepAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Arc3d Interface > Arc3d Properties > Arc3d.SweepAngle Property


AssemblyComponentDefinition Interface

AssemblyComponentDefinition Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The AssemblyComponentDefinition object supports the RigidBodyAnalysis method which is the way to get the rigid body results of the assembly.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::AssemblyComponentDefinition
        Inventor::WeldmentComponentDefinition
Visual Basic
Public Interface AssemblyComponentDefinition
Inherits ComponentDefinition
Remarks

Execution of this method does not modify the assembly in any way but instead provides a simplified view of the existing assembly. It does this by creating logical groups of occurrences whose constraints fully constrain them to one another. For any motion analysis, each group behaves as a single rigid body. In addition to determining these groups of parts, the analysis also determines which constraints define relationships between the groups. These constraints are presented as joints. In some cases a joint can be the result of more than one assembly constraint, so there is not necessarily a one-to-one relationship between joints and constraints.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinitions.Item

AssemblyConstraint.Parent

AssemblyConstraints.Parent

AssemblyDocument.ComponentDefinition

iAssemblyFactory.Parent

iAssemblyMember.Parent

LayoutConstraint.Parent

OccurrencePattern.Parent

OccurrencePatterns.Parent

RepresentationsManager.Parent

RigidBodyResults.Parent

See Also

Assembly Ground Occurrences sample

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

Mate constraint with limits sample

Assembly Mate Constraint of Work Planes sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface


AssemblyComponentDefinition Methods

AssemblyComponentDefinition Methods
Summary

The methods of the AssemblyComponentDefinition class are listed here.

Methods
Methods
Name | Description
AdjustProxyContext | Returns the specified object proxy scoped into this assembly, trimming any portion of the context from any assembly in which this assembly is a subassembly. In other words, for the given object proxy, this method makes a new object proxy which has this component definition as the context definition.
AnalyzeInterference | Method that analyzes the interference between two components. The input ObjectCollections contain the component occurrences that are to be checked for interference. If only one set is provided then interference checking is performed between all occurrences provided in the set. If two sets are provided then the overlap between the components of the two collections are calculated.
CreateFactory | Method that converts an assembly to an iAssemblyFactory. The newly created iAssemblyFactory object will have an empty excel spreadsheet.
ExportObjects | Method that marks all the input objects as exported.
FindUsingRay | Method that fires a ray through the part or assembly and returns the entities intersected by the ray. The objects intersected by the ray are returned in the order in which they are intersected, with the first entities returned being those closest to the clipping plane.
GetEndOfFeaturesPosition | Gets the current end of Features position in the browser in assembly.
SetEndOfFeaturesToTopOrBottom | Sets the End of Part marker to the top or bottom of the browser.
SuppressFeatures | Property that returns the SurfaceBodies collection. Surface bodies within the assembly is not currently supported by Inventor. The returned SurfaceBodies collection will be a collection of zero.
TransformOccurrences | Method that transforms a collection of occurrences.
UnsuppressFeatures | Method that unsuppresses previously suppressed features.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods


AssemblyComponentDefinition.AdjustProxyContext Method

AssemblyComponentDefinition.AdjustProxyContext Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Returns the specified object proxy scoped into this assembly, trimming any portion of the context from any assembly in which this assembly is a subassembly. In other words, for the given object proxy, this method makes a new object proxy which has this component definition as the context definition.

Visual Basic
Sub AdjustProxyContext(ObjectProxy As IDispatch, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
ObjectProxy | An object representing an Object Proxy - known in earlier versions of Inventor as a Geom Proxy. Each Object Proxy has an associated ComponentOccurrence, which has a property called ContextDefinition. The value of this property is the top level ComponentDefinition.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.AdjustProxyContext Method


AssemblyComponentDefinition.AnalyzeInterference Method

AssemblyComponentDefinition.AnalyzeInterference Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that analyzes the interference between two components. The input ObjectCollections contain the component occurrences that are to be checked for interference. If only one set is provided then interference checking is performed between all occurrences provided in the set. If two sets are provided then the overlap between the components of the two collections are calculated.

Visual Basic
Sub AnalyzeInterference(Set1 As ObjectCollection, ByRef Set2 As [optional] VARIANT, Result As [out, retval] InterferenceResults*)
Parameters
Parameters | Description
Set1 | Input that contains ComponentOccurrenceobjects. If this set is provided without Set2, all occurrences in the set are checked for interference against all other occurrences in the set.
Set2 | Optional input that contains ComponentOccurrence objects. When this set is provided the occurrences in Set1 are checked for interference against the occurrences in Set2.
Example

"Interference Analysis Example "

"This sample demonstrates the functions used to calculate interference analysis in an assembly. To use this sample have an assembly open that contains mutiple parts. Depending on preselected parts when running the sample, you'll get different results. If one part is selected, that one part will be checked against the rest of the assembly. If more than one part is selected you have the choice of checking for interference among the selected parts or checking the selected parts against the rest of the assembly. If no parts are selected it will check every part against every other part."

Public Sub Interference()
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Find all selected occurrences and add them to an ObjectCollection.
    Dim oSelectedOccs As ObjectCollection
    Set oSelectedOccs = ThisApplication.TransientObjects.CreateObjectCollection
    Dim i As Long
    For i = 1 To oDoc.SelectSet.Count
        If oDoc.SelectSet.Item(i).Type = kComponentOccurrenceObject Then
            oSelectedOccs.Add oDoc.SelectSet.Item(i)
        End If
    Next

    ' If no occurrences are selected check for interference of
    ' all parts against all parts.  If one occurrence is selected, check
    ' for interference between that occurrence and the rest of the assembly.
    ' If more than one occurrence is selected let the user decide if it
    ' should check for interference between the parts in the selection or
    ' between the selected parts and the rest of the assembly.
    Dim oResults As InterferenceResults
    Dim oCheckSet As ObjectCollection
    Set oCheckSet = ThisApplication.TransientObjects.CreateObjectCollection
    If oSelectedOccs.Count = 0 Then
        ' Add all occurrences to the object collection
        Dim oOcc As ComponentOccurrence
        For Each oOcc In oDoc.ComponentDefinition.Occurrences
            oCheckSet.Add oOcc
        Next

        ' Get the interference between everything.
        Set oResults = oDoc.ComponentDefinition.AnalyzeInterference(oCheckSet)
    ElseIf oSelectedOccs.Count = 1 Then
        ' Add all occurrences except the selected occurrence to the object collection.
        For Each oOcc In oDoc.ComponentDefinition.Occurrences
            If Not oOcc Is oSelectedOccs.Item(1) Then
                oCheckSet.Add oOcc
            End If
        Next

        ' Get the interference between the selected occurrence everything else.
        Set oResults = oDoc.ComponentDefinition.AnalyzeInterference(oSelectedOccs, oCheckSet)
    Else
        If MsgBox("Check interference between selected occurrences and all other occurrences?", vbYesNo + vbQuestion) = vbYes Then
            ' Add all occurrences except the selected occurrences to the object collection.
            For Each oOcc In oDoc.ComponentDefinition.Occurrences
                ' Check to see if this occurrences is already selected.
                Dim bSelected As Boolean
                bSelected = False
                For i = 1 To oSelectedOccs.Count
                    If oSelectedOccs.Item(i) Is oOcc Then
                        bSelected = True
                        Exit For
                    End If
                Next

                If Not bSelected Then
                    oCheckSet.Add oOcc
                End If
            Next

            ' Check interference between the selected items.
            Set oResults = oDoc.ComponentDefinition.AnalyzeInterference(oSelectedOccs, oCheckSet)
        Else
            ' Check interference between the selected items.
            Set oResults = oDoc.ComponentDefinition.AnalyzeInterference(oSelectedOccs)
        End If
    End If

    If oResults.Count = 1 Then
        MsgBox "There is 1 interference."
    ElseIf oResults.Count > 1 Then
        MsgBox "There are " & oResults.Count & " interferences."
    End If

    If oResults.Count > 0 Then
        Dim oHS1 As HighlightSet
        Set oHS1 = oDoc.HighlightSets.Add
        oHS1.SetColor 255, 0, 0
        Dim oHS2 As HighlightSet
        Set oHS2 = oDoc.HighlightSets.Add
        oHS2.SetColor 0, 255, 0

        For i = 1 To oResults.Count
            oHS1.Clear
            oHS2.Clear
            oHS1.AddItem oResults.Item(i).OccurrenceOne
            oHS2.AddItem oResults.Item(i).OccurrenceTwo
            MsgBox "Occurrences are highlighted from interference " & i
        Next

        oHS1.Clear
        oHS2.Clear
    Else
        MsgBox "There is no interference."
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.AnalyzeInterference Method


AssemblyComponentDefinition.CreateFactory Method

AssemblyComponentDefinition.CreateFactory Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that converts an assembly to an iAssemblyFactory. The newly created iAssemblyFactory object will have an empty excel spreadsheet.

Visual Basic
Sub CreateFactory(Result As [out, retval] iAssemblyFactory*)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.CreateFactory Method


AssemblyComponentDefinition.ExportObjects Method

AssemblyComponentDefinition.ExportObjects Method
Summary

Method that marks all the input objects as exported.

Visual Basic
Sub ExportObjects(Objects As ObjectCollection)
Parameters
Parameters | Description
Objects | Collection of objects to mark as exported.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.ExportObjects Method


AssemblyComponentDefinition.FindUsingRay Method

AssemblyComponentDefinition.FindUsingRay Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that fires a ray through the part or assembly and returns the entities intersected by the ray. The objects intersected by the ray are returned in the order in which they are intersected, with the first entities returned being those closest to the clipping plane.

Visual Basic
Sub FindUsingRay(RayStartPoint As Point, RayDirection As UnitVector, Radius As double, ByRef FoundEntities As ObjectsEnumerator*, ByRef LocationPoints As ObjectsEnumerator*, ByRef FindFirstOnly As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RayStartPoint | Input object that defines the start point of the ray in model space.
RayDirection | Input object that defines the direction of the ray. The ray is infinite in the direction defined.
Radius | Input Double that defines the radius of the ray. This value is specified in centimeters. Defining a radius for a ray allows the intersection to be within a given tolerance. This radius essentially results in the definition of a cylinder whose axis lies along the axis defined by the RayStartPoint and RayDirection. The intersection result is between the cylinder and the model's entities. A value higher than zero is recommended, though not explicitly required.
FoundEntities | Output that returns the entities that were intersected by the ray.
LocationPoints | Output that returns a set of Point objects. One Point object is returned for each entity in the FoundEntities list. The point defines the coordinate of the intersection between the ray and the corresponding entity.
FindFirstOnly | Optional input Boolean that specifies whether to find just the first entity in the ray's path. If False (the default) then all entities found are returned.
Remarks

There is a precedence in the type of entities returned. The entities returned can be Vertex, Edge, or Face objects. The precedence is in that order. If the ray intersects a vertex, then that vertex is returned and none of the edges or faces that connect to that vertex are returned. If the ray intersects an edge, then that edge is returned and none of the faces that connect to the edge are returned. If the ray intersects a face, then that face is returned. If desired, you can use the functionality provided by the B-Rep portion of the API to obtain the various associated objects from the entity returned. For example if you need a face but an edge is returned, you can use the Faces property of the Edge object to get the associated faces. The start point defines the physical starting point from which to determine intersections. Any intersections behind the start point are ignored. However, the ray is infinite from the start point, so all intersections in the direction of the ray will be returned.

Notes

As of Autodesk Inventor 5.3 Service Pack 2, the FindUsingRay method has superseded LocateUsingRay.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.FindUsingRay Method


AssemblyComponentDefinition.GetEndOfFeaturesPosition Method

AssemblyComponentDefinition.GetEndOfFeaturesPosition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the current end of Features position in the browser in assembly.

Visual Basic
Sub GetEndOfFeaturesPosition(ByRef After As IDispatch*, ByRef Before As IDispatch*)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.GetEndOfFeaturesPosition Method


AssemblyComponentDefinition.SetEndOfFeaturesToTopOrBottom Method

AssemblyComponentDefinition.SetEndOfFeaturesToTopOrBottom Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Sets the End of Part marker to the top or bottom of the browser.

Visual Basic
Sub SetEndOfFeaturesToTopOrBottom(SetToTop As VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.SetEndOfFeaturesToTopOrBottom Method


AssemblyComponentDefinition.SuppressFeatures Method

AssemblyComponentDefinition.SuppressFeatures Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the SurfaceBodies collection. Surface bodies within the assembly is not currently supported by Inventor. The returned SurfaceBodies collection will be a collection of zero.

Visual Basic
Sub SuppressFeatures(Features As ObjectCollection)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.SuppressFeatures Method


AssemblyComponentDefinition.TransformOccurrences Method

AssemblyComponentDefinition.TransformOccurrences Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that transforms a collection of occurrences.

Visual Basic
Sub TransformOccurrences(Occurrences As ObjectCollection, Transforms As ObjectCollection, ByRef IgnoreConstraints As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Occurrences | Input ObjectCollection that contains the ComponentOccurrence objects to be transformed. The collection can only contain top level occurrences from the document. An exception is the case of a flexible occurrence within the top level assembly, in which case, deeper level occurrences may be provided.
Transforms | Input ObjectCollection that contains Matrix objects defining the transform for the input occurrences. The collection must have the same number of objects as the number of input occurrences, else the method returns an error. The collection can also contain a single Matrix, in which case all occurrences are transformed similarly using the single Matrix.
IgnoreConstraints | Optional input Boolean which specifies whether to transform the occurrences without re-applying the current assembly constraints. An update of the Assembly will honor the constraints and ignore these transforms. If not specified, a default value of False is used (i.e. constraints are honored).
Notes

For information on this item, please refer to WeldmentComponentDefinition::TransformOccurrences, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.TransformOccurrences Method


AssemblyComponentDefinition.UnsuppressFeatures Method

AssemblyComponentDefinition.UnsuppressFeatures Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that unsuppresses previously suppressed features.

Visual Basic
Sub UnsuppressFeatures(Features As ObjectCollection)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Methods > AssemblyComponentDefinition.UnsuppressFeatures Method


AssemblyComponentDefinition Properties

AssemblyComponentDefinition Properties
Summary

The properties of the AssemblyComponentDefinition class are listed here.

Properties
Name | Description
ActiveOccurrence | Property that returns the that is currently in edit.
AssemblyEvents | Property returning an AssemblyEvents collection object.
BIMComponent | Property that returns the BIMComponent object associated with this component definition.
BOM | Property that returns the BOM object.
Constraints | Property that returns the AssemblyConstraints collection object.
DefaultMaterial | Property that indicates the default material associated with the assembly component. This is the material that is used for newly created virtual components.
Features | Gets the Features collection for this assembly (assembly features).
iAssemblyFactory | Property that returns the iAssemblyFactory object. This property will return Nothing in the case where the assembly is not an iAssembly Factory. You can determine this by using the IsiAssemblyFactory property.
iAssemblyMember | Property that returns the iAssemblyMember object. This property will return Nothing in the case where the assembly is not an iAssembly Member. You can determine this by using the IsiAssemblyMember property.
iMateDefinitions | Property that returns the iMateDefinitions collection object associated with this assembly.
iMateResults | Property that returns the iMateResults collection object associated with this assembly.
IsiAssemblyFactory | Property that returns if the part is an iAssembly Member or not. It returns True in the case where the part is a member. If True, the member can be obtained using the iAssemblyMember property.
IsiAssemblyMember | Property that returns if the part is an iAssembly Member or not. It returns True in the case where the part is a member. If True, the member can be obtained using the iAssemblyMember property.
MassProperties | Property that returns the MassProperties object. This supports performing mass properties calculations for the entire assembly.
OccurrencePatterns | Method that returns the pattern element this occurrence represents.
Parameters | Property that returns the parameters collection.
Parent | Property that returns the parent of the object.
RepresentationsManager | Property that returns the RepresentationsManager object.
Sketches | Gets the Sketches collection for this assembly component.
UserCoordinateSystems | Property that returns the UserCoordinateSystems collection object.
WorkAxes | Property that returns the WorkAxes collection object that encapsulates all of the work axes defined in this ComponentDefinition.
WorkPlanes | Property that returns the WorkPlanes collection object that encapsulates all of the work planes defined in this ComponentDefinition.
WorkPoints | Property that returns the WorkPoints collection object that encapsulates all of the work points defined in this ComponentDefinition.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties


AssemblyComponentDefinition.ActiveOccurrence Property

AssemblyComponentDefinition.ActiveOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that is currently in edit.

Visual Basic
Property ActiveOccurrence() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.ActiveOccurrence Property


AssemblyComponentDefinition.AssemblyEvents Property

AssemblyComponentDefinition.AssemblyEvents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an AssemblyEvents collection object.

Visual Basic
Property AssemblyEvents() As AssemblyEvents**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.AssemblyEvents Property


AssemblyComponentDefinition.BIMComponent Property

AssemblyComponentDefinition.BIMComponent Property Available in Inventor Introduced in Inventor 16
Summary

Property that returns the BIMComponent object associated with this component definition.

Visual Basic
Property BIMComponent() As BIMComponent**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.BIMComponent Property


AssemblyComponentDefinition.BOM Property

AssemblyComponentDefinition.BOM Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the BOM object.

Visual Basic
Property BOM() As BOM**
See Also

Exporting the assembly BOM sample

Using the BOM APIs sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.BOM Property


AssemblyComponentDefinition.Constraints Property

AssemblyComponentDefinition.Constraints Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the AssemblyConstraints collection object.

Visual Basic
Property Constraints() As AssemblyConstraints**
See Also

Assembly Ground Occurrences sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.Constraints Property


AssemblyComponentDefinition.DefaultMaterial Property

AssemblyComponentDefinition.DefaultMaterial Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the default material associated with the assembly component. This is the material that is used for newly created virtual components.

Visual Basic
Property DefaultMaterial() As Material*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.DefaultMaterial Property


AssemblyComponentDefinition.Features Property

AssemblyComponentDefinition.Features Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the Features collection for this assembly (assembly features).

Visual Basic
Property Features() As Features**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.Features Property


AssemblyComponentDefinition.iAssemblyFactory Property

AssemblyComponentDefinition.iAssemblyFactory Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the iAssemblyFactory object. This property will return Nothing in the case where the assembly is not an iAssembly Factory. You can determine this by using the IsiAssemblyFactory property.

Visual Basic
Property iAssemblyFactory() As iAssemblyFactory**
See Also

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.iAssemblyFactory Property


AssemblyComponentDefinition.iAssemblyMember Property

AssemblyComponentDefinition.iAssemblyMember Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the iAssemblyMember object. This property will return Nothing in the case where the assembly is not an iAssembly Member. You can determine this by using the IsiAssemblyMember property.

Visual Basic
Property iAssemblyMember() As iAssemblyMember**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.iAssemblyMember Property


AssemblyComponentDefinition.iMateDefinitions Property

AssemblyComponentDefinition.iMateDefinitions Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iMateDefinitions collection object associated with this assembly.

Visual Basic
Property iMateDefinitions() As iMateDefinitions**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.iMateDefinitions Property


AssemblyComponentDefinition.iMateResults Property

AssemblyComponentDefinition.iMateResults Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iMateResults collection object associated with this assembly.

Visual Basic
Property iMateResults() As iMateResults**
See Also

iMate Result Creation sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.iMateResults Property


AssemblyComponentDefinition.IsiAssemblyFactory Property

AssemblyComponentDefinition.IsiAssemblyFactory Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns if the part is an iAssembly Member or not. It returns True in the case where the part is a member. If True, the member can be obtained using the iAssemblyMember property.

Visual Basic
Property IsiAssemblyFactory() As VARIANT_BOOL*
See Also

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.IsiAssemblyFactory Property


AssemblyComponentDefinition.IsiAssemblyMember Property

AssemblyComponentDefinition.IsiAssemblyMember Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns if the part is an iAssembly Member or not. It returns True in the case where the part is a member. If True, the member can be obtained using the iAssemblyMember property.

Visual Basic
Property IsiAssemblyMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.IsiAssemblyMember Property


AssemblyComponentDefinition.MassProperties Property

AssemblyComponentDefinition.MassProperties Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the MassProperties object. This supports performing mass properties calculations for the entire assembly.

Visual Basic
Property MassProperties() As MassProperties**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.MassProperties Property


AssemblyComponentDefinition.OccurrencePatterns Property

AssemblyComponentDefinition.OccurrencePatterns Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the pattern element this occurrence represents.

Visual Basic
Property OccurrencePatterns() As OccurrencePatterns**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.OccurrencePatterns Property


AssemblyComponentDefinition.Parameters Property

AssemblyComponentDefinition.Parameters Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parameters collection.

Visual Basic
Property Parameters() As Parameters**
See Also

Model Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.Parameters Property


AssemblyComponentDefinition.Parent Property

AssemblyComponentDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyDocument**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.Parent Property


AssemblyComponentDefinition.RepresentationsManager Property

AssemblyComponentDefinition.RepresentationsManager Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the RepresentationsManager object.

Visual Basic
Property RepresentationsManager() As RepresentationsManager**
See Also

Shrink wrap substitute in assembly sample

Create a level of detail representation sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.RepresentationsManager Property


AssemblyComponentDefinition.Sketches Property

AssemblyComponentDefinition.Sketches Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the Sketches collection for this assembly component.

Visual Basic
Property Sketches() As PlanarSketches**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.Sketches Property


AssemblyComponentDefinition.UserCoordinateSystems Property

AssemblyComponentDefinition.UserCoordinateSystems Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the UserCoordinateSystems collection object.

Visual Basic
Property UserCoordinateSystems() As UserCoordinateSystems**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.UserCoordinateSystems Property


AssemblyComponentDefinition.WorkAxes Property

AssemblyComponentDefinition.WorkAxes Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the WorkAxes collection object that encapsulates all of the work axes defined in this ComponentDefinition.

Visual Basic
Property WorkAxes() As WorkAxes**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.WorkAxes Property


AssemblyComponentDefinition.WorkPlanes Property

AssemblyComponentDefinition.WorkPlanes Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the WorkPlanes collection object that encapsulates all of the work planes defined in this ComponentDefinition.

Visual Basic
Property WorkPlanes() As WorkPlanes**
See Also

Projection - project across parts sample

Assembly Mate Constraint of Work Planes sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.WorkPlanes Property


AssemblyComponentDefinition.WorkPoints Property

AssemblyComponentDefinition.WorkPoints Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the WorkPoints collection object that encapsulates all of the work points defined in this ComponentDefinition.

Visual Basic
Property WorkPoints() As WorkPoints**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinition Interface > AssemblyComponentDefinition Properties > AssemblyComponentDefinition.WorkPoints Property


AssemblyComponentDefinitions Interface

AssemblyComponentDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the objects within the assembly document.

Class Hierarchy
Inventor::AssemblyComponentDefinitions
Visual Basic
Public Interface AssemblyComponentDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.ComponentDefinitions

You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface


AssemblyComponentDefinitions Methods

AssemblyComponentDefinitions Methods
Summary

The methods of the AssemblyComponentDefinitions class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection. Currently Autodesk Inventor supports a single component definition within a document, so this collection will always be a collection of one.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Methods


AssemblyComponentDefinitions.Item Method

AssemblyComponentDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified object from the collection. Currently Autodesk Inventor supports a single component definition within a document, so this collection will always be a collection of one.

Visual Basic
Sub Item(index As long, Result As [out, retval] AssemblyComponentDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Methods > AssemblyComponentDefinitions.Item Method


AssemblyComponentDefinitions Properties

AssemblyComponentDefinitions Properties
Summary

The properties of the AssemblyComponentDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent of the object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Properties


AssemblyComponentDefinitions.Application Property

AssemblyComponentDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Properties > AssemblyComponentDefinitions.Application Property


AssemblyComponentDefinitions.Count Property

AssemblyComponentDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Properties > AssemblyComponentDefinitions.Count Property


AssemblyComponentDefinitions.Parent Property

AssemblyComponentDefinitions.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyDocument**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Properties > AssemblyComponentDefinitions.Parent Property


AssemblyComponentDefinitions.Type Property

AssemblyComponentDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyComponentDefinitions Interface > AssemblyComponentDefinitions Properties > AssemblyComponentDefinitions.Type Property


AssemblyConstraint Interface

AssemblyConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents the base class of an assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::AngleConstraint
    Inventor::CustomConstraint
    Inventor::FlushConstraint
    Inventor::InsertConstraint
    Inventor::MateConstraint
    Inventor::RotateRotateConstraint
    Inventor::RotateTranslateConstraint
    Inventor::TangentConstraint
    Inventor::TransitionalConstraint
    Inventor::TranslateTranslateConstraint
Visual Basic
Public Interface AssemblyConstraint
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyConstraints.Item

AssemblyConstraintsEnumerator.Item

See Also

Assembly Ground Occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface


AssemblyConstraint Methods

AssemblyConstraint Methods
Summary

The methods of the AssemblyConstraint class are listed here.

Methods
Methods
Name | Description
ConvertToAngleConstraint | Method that converts the constraint to an angle constraint, and returns the AngleConstraint object. This method can also be used to edit the geometries associated with an angle constraint without changing its type, in which case the same object is returned by the method.
ConvertToCustomConstraint | Method that converts the constraint to a custom constraint, and returns the CustomConstraint object. This method can also be used to edit the geometries associated with a custom constraint without changing its type, in which case the same object is returned by the method.
ConvertToFlushConstraint | Method that converts the constraint to a flush constraint, and returns the FlushConstraint object. This method can also be used to edit the geometries associated with a flush constraint without changing its type, in which case the same object is returned by the method.
ConvertToInsertConstraint | Method that converts the constraint to an insert constraint, and returns the InsertConstraint object. This method can also be used to edit the geometries associated with an insert constraint without changing its type, in which case the same object is returned by the method.
ConvertToMateConstraint | Method that converts the constraint to a mate constraint, and returns the MateConstraint object. This method can also be used to edit the geometries associated with a mate constraint without changing its type, in which case the same object is returned by the method.
ConvertToRotateRotateConstraint | Method that converts the constraint to a rotate-rotate constraint, and returns the RotateRotateConstraint object. This method can also be used to edit the geometries associated with a rotate-rotate constraint without changing its type, in which case the same object is returned by the method.
ConvertToRotateTranslateConstraint | Method that converts the constraint to a rotate-translate constraint, and returns the RotateTranslateConstraint object. This method can also be used to edit the geometries associated with a rotate-translate constraint without changing its type, in which case the same object is returned by the method.
ConvertToTangentConstraint | Method that converts the constraint to a tangent constraint, and returns the TangentConstraint object. This method can also be used to edit the geometries associated with a tangent constraint without changing its type, in which case the same object is returned by the method.
ConvertToTransitionalConstraint | Method that converts the constraint to a transitional constraint, and returns the TransitionalConstraint object. This method can also be used to edit the geometries associated with a transitional constraint without changing its type, in which case the same object is returned by the method.
Delete | Method that deletes the constraint.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods


AssemblyConstraint.ConvertToAngleConstraint Method

AssemblyConstraint.ConvertToAngleConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to an angle constraint, and returns the AngleConstraint object. This method can also be used to edit the geometries associated with an angle constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToAngleConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Angle As VARIANT, ByRef SolutionType As [defaultvalue(kDirectedSolution)] AngleConstraintSolutionTypeEnum, ByRef ReferenceVectorEntity As [optional] VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] AngleConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
EntityTwo | Input object that defines the second object. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
Angle | Input Variant that defines the angle between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input the units can be specified as part of the string or will default to the current angle units of the document.
SolutionType | Optional input AngleConstraintSolutionTypeEnum that specifies the solution type. If specified to be kDirectionSolution, the solution always applies the right hand rule. If specified to be kUndirectionSolution, the solution allows either orientation, thus resolving situations where component orientation flips during a constraint drive or drag. If specified to be kReferenceVectorSolution, the ReferenceVectorEntity argument must be provided with a third entity for the solution. The default value is kDirectionSolution.
ReferenceVectorEntity | Optional input object that provides a third entity to solve the angle constraint. This argument is ignored if the SolutionType argument is not kReferenceVectorSolution. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToAngleConstraint Method


AssemblyConstraint.ConvertToCustomConstraint Method

AssemblyConstraint.ConvertToCustomConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a custom constraint, and returns the CustomConstraint object. This method can also be used to edit the geometries associated with a custom constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToCustomConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, ClientId As String, Result As [out, retval] CustomConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object.
EntityTwo | Input object that defines the second object.
ClientId | Input String that specifies the ClientId, typically the ClassId of the Add-in creating the constraint.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToCustomConstraint Method


AssemblyConstraint.ConvertToFlushConstraint Method

AssemblyConstraint.ConvertToFlushConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a flush constraint, and returns the FlushConstraint object. This method can also be used to edit the geometries associated with a flush constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToFlushConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Offset As VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] FlushConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object. The input object must be either a planar Face object or WorkPlane object.
EntityTwo | Input object that defines the second object. The input object must be either a planar Face object or WorkPlane object
Offset | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToFlushConstraint Method


AssemblyConstraint.ConvertToInsertConstraint Method

AssemblyConstraint.ConvertToInsertConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to an insert constraint, and returns the InsertConstraint object. This method can also be used to edit the geometries associated with an insert constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToInsertConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, AxesOpposed As VARIANT_BOOL, Distance As VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] InsertConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object. This object is a circular edge.
EntityTwo | Input object that defines the second object. This object is a circular edge.
AxesOpposed | Input Boolean that specifies whether the direction of the axies of the input entities are in the same direction or opposed. A value of True indicates they are opposed.
Distance | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToInsertConstraint Method


AssemblyConstraint.ConvertToMateConstraint Method

AssemblyConstraint.ConvertToMateConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a mate constraint, and returns the MateConstraint object. This method can also be used to edit the geometries associated with a mate constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToMateConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Offset As VARIANT, ByRef EntityOneInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef EntityTwoInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] MateConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object.
EntityTwo | Input object that defines the second object.
Offset | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
EntityOneInferredType | Optional input enum that specifies how the geometry of entity one is to be interpreted. Depending on the geometry of the entity one, different options are possible. If entity one is a cylinder this can be either kNoInferrence or kInferredLine. For kNoInferrence to be valid for a cylinder, entity two must also be a cylinder and they must be the same radius. If entity one is a sphere this can be either kNoInferrence or kInferredPoint. For kNoInferrence to be valid for a sphere, entity two must also be a sphere and they must be the same radius. If entity one is a cone this can be either kNoInferrence or kInferredLine. For kNoInferrence to be valid for a cone, entity two must also be a cone and they must have the same taper angle. If entity one is a torus this can be either kInferredLine or kInferredPoint. For a plane, only kNoInferrence is valid.
EntityTwoInferredType | Input enum that specifies how the geometry of entity two is to be interpreted. Depending on the geometry of the entity two, different options are possible. If entity two is a cylinder this can be either kNoInferrence or kInferredLine. For kNoInferrence to be valid for a cylinder, entity one must also be a cylinder and they must be the same radius. If entity two is a sphere this can be either kNoInferrence or kInferredPoint. For kNoInferrence to be valid for a sphere, entity one must also be a sphere and they must be the same radius. If entity two is a cone this can be either kNoInferrence or kInferredLine. For kNoInferrence to be valid for a cone, entity one must also be a cone and they must have the same taper angle. If entity two is a torus this can be either kInferredLine or kInferredPoint. For a plane, only kNoInferrence is valid.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Remarks

The two input entities can be a combination of planar faces, linear edges, vertices, cylindrical faces, conical faces, spherical faces, revolved faces, work planes, work axes, and work points.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToMateConstraint Method


AssemblyConstraint.ConvertToRotateRotateConstraint Method

AssemblyConstraint.ConvertToRotateRotateConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a rotate-rotate constraint, and returns the RotateRotateConstraint object. This method can also be used to edit the geometries associated with a rotate-rotate constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToRotateRotateConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Ratio As VARIANT, ForwardDirection As VARIANT_BOOL, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] RotateRotateConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object and its rotation axis. The input object must be a planar Face, a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the rotation axis is normal to the input face.
EntityTwo | Input object that defines the second object and its rotation axis. The input object must be a planar Face, a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object.
Ratio | Input Variant that defines the rotation ratio between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. The input value is unitless.
ForwardDirection | Input Boolean that defines the direction of rotation of the objects with respect to the axis direction. If the input value is True then both objects will rotate the same direction around their axes. If False, then they will rotate in opposite directions.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToRotateRotateConstraint Method


AssemblyConstraint.ConvertToRotateTranslateConstraint Method

AssemblyConstraint.ConvertToRotateTranslateConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a rotate-translate constraint, and returns the RotateTranslateConstraint object. This method can also be used to edit the geometries associated with a rotate-translate constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToRotateTranslateConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Ratio As VARIANT, ForwardDirection As VARIANT_BOOL, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] RotateTranslateConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object and its rotation axis. The input object must be a planar Face, a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the rotation axis is normal to the input face.
EntityTwo | Input object that defines the second object and its translation axis. The input object must be a planar Face, a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the translation axis is normal to the input face.
Ratio | Input Variant that defines the distance of translation for every revolution of the rotated occurrence. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
ForwardDirection | Input Boolean that defines the direction of translation with respect to the rotation direction relative to the axes directions. If the input value is True then when the rotation object is rotated in a positive direction about its axis, the translation object will move in the positive direction of its vector, If False, it will move in the negative direction.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToRotateTranslateConstraint Method


AssemblyConstraint.ConvertToTangentConstraint Method

AssemblyConstraint.ConvertToTangentConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a tangent constraint, and returns the TangentConstraint object. This method can also be used to edit the geometries associated with a tangent constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToTangentConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, InsideTangency As VARIANT_BOOL, Offset As VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] TangentConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object.
EntityTwo | Input object that defines the second object. This object is a circular edge.
InsideTangency | Input Boolean that specifies the orientation of the surfaces at the tangent contact point of the surfaces.
Offset | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToTangentConstraint Method


AssemblyConstraint.ConvertToTransitionalConstraint Method

AssemblyConstraint.ConvertToTransitionalConstraint Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that converts the constraint to a transitional constraint, and returns the TransitionalConstraint object. This method can also be used to edit the geometries associated with a transitional constraint without changing its type, in which case the same object is returned by the method.

Visual Basic
Sub ConvertToTransitionalConstraint(FaceOne As Face, FaceTwo As Face, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] TransitionalConstraint*)
Parameters
Parameters | Description
FaceOne | First input face that defines the initial face that is used in repositioning the parts. Once the constraint is placed it can move along any of the faces of the part.
FaceTwo | Second input face that defines the initial face that is used in repositioning the parts. Once the constraint is placed it can move along any of the faces of the part.
BiasPointOne | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. For transitional constraints, the bias point defines the position where the transition occurs to adjacent faces. Hence, the bias point must lie within the boundary of the input face. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity. If this point is found not to lie within the face's boundary, a random sample point within the boundary is used.
BiasPointTwo | Optional input Point object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. For transitional constraints, the bias point defines the position where the transition occurs to adjacent faces. Hence, the bias point must lie within the boundary of the input face. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity. If this point is found not to lie within the face's boundary, a random sample point within the boundary is used.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.ConvertToTransitionalConstraint Method


AssemblyConstraint.Delete Method

AssemblyConstraint.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the constraint.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.Delete Method


AssemblyConstraint.GetReferenceKey Method

AssemblyConstraint.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Methods > AssemblyConstraint.GetReferenceKey Method


AssemblyConstraint Properties

AssemblyConstraint Properties
Summary

The properties of the AssemblyConstraint class are listed here.

Properties
Name | Description
AffectedOccurrenceOne | Property that returns the first of the two objects affected by this constraint. This is the same as the owning occurrence obtained from the OccurrenceOne property in the case where the owning assembly is not adaptive. Else, this is the first non-adaptive occurrence in the path leading from the owning occurrence to the occurrence that contains the first of the two geometries that this constraint is between.
AffectedOccurrenceTwo | Property that returns the second of the two objects affected by this constraint. This is the same as the owning occurrence obtained from the OccurrenceTwo property in the case where the owning assembly is not adaptive. Else, this is the first non-adaptive occurrence in the path leading from the owning occurrence to the occurrence that contains the second of the two geometries that this constraint is between.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DriveConstraintSettings | Property that returns the DriveConstraintSettings object for the constraint.
EntityOne | Property that indicates the first of the geometric entities (Face, Axis, Edge, etc.) being constrained.
EntityTwo | Property that indicates the second of the geometric entities (Face, Axis, Edge, etc.) being constrained.
GeometryOne | Property that returns the geometry of the first of the two entities that this constraint is between. The geometry returned is in the space of the assembly and for face or work plane geometries it accounts for the orientation of the face or work plane.
GeometryTwo | Property that returns the geometry of the second of the two entities that this constraint is between. The geometry returned is in the space of the assembly and for face or work plane geometries it accounts for the orientation of the face or work plane.
HealthStatus | Property that returns an enum indicating the current state of the object.
iMateResult | Property that returns the iMateResult object that resulted in the creation of this constraint.
LayoutConstraint | Property that returns the layout constraint this constraint is a member of. Returns Nothing in the case where this constraint is not a member of a layout constraint. You can also determine if a constraint is a member of a layout constraint by using the ResultOfLayoutConstraint property.
Name | Property that allows you to get and set the name of the constraint. This is the name that is displayed in the browser.
OccurrenceOne | Property that returns the first of the two objects this constraint is between.
OccurrenceTwo | Property that returns the second of the two objects this constraint is between.
Parent | Property that returns the parent of the object.
ResultOfiMate | Property that indicates if this iMateResult represents a composite iMate.
ResultOfLayoutConstraint | Property that indicates if this constraint is a member of a layout constraint. If True then it is a member of a layout constraint. The layout constraint can be obtained by using the LayoutConstraint property.
Suppressed | Property that indicates whether the constraint is suppressed or not. A value of True indicates the feature is suppressed.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties


AssemblyConstraint.AffectedOccurrenceOne Property

AssemblyConstraint.AffectedOccurrenceOne Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the first of the two objects affected by this constraint. This is the same as the owning occurrence obtained from the OccurrenceOne property in the case where the owning assembly is not adaptive. Else, this is the first non-adaptive occurrence in the path leading from the owning occurrence to the occurrence that contains the first of the two geometries that this constraint is between.

Visual Basic
Property AffectedOccurrenceOne() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.AffectedOccurrenceOne Property


AssemblyConstraint.AffectedOccurrenceTwo Property

AssemblyConstraint.AffectedOccurrenceTwo Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the second of the two objects affected by this constraint. This is the same as the owning occurrence obtained from the OccurrenceTwo property in the case where the owning assembly is not adaptive. Else, this is the first non-adaptive occurrence in the path leading from the owning occurrence to the occurrence that contains the second of the two geometries that this constraint is between.

Visual Basic
Property AffectedOccurrenceTwo() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.AffectedOccurrenceTwo Property


AssemblyConstraint.Application Property

AssemblyConstraint.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.Application Property


AssemblyConstraint.AttributeSets Property

AssemblyConstraint.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.AttributeSets Property


AssemblyConstraint.DriveConstraintSettings Property

AssemblyConstraint.DriveConstraintSettings Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the DriveConstraintSettings object for the constraint.

Visual Basic
Property DriveConstraintSettings() As DriveConstraintSettings**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.DriveConstraintSettings Property


AssemblyConstraint.EntityOne Property

AssemblyConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the first of the geometric entities (Face, Axis, Edge, etc.) being constrained.

Visual Basic
Property EntityOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.EntityOne Property


AssemblyConstraint.EntityTwo Property

AssemblyConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the second of the geometric entities (Face, Axis, Edge, etc.) being constrained.

Visual Basic
Property EntityTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.EntityTwo Property


AssemblyConstraint.GeometryOne Property

AssemblyConstraint.GeometryOne Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the geometry of the first of the two entities that this constraint is between. The geometry returned is in the space of the assembly and for face or work plane geometries it accounts for the orientation of the face or work plane.

Visual Basic
Property GeometryOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.GeometryOne Property


AssemblyConstraint.GeometryTwo Property

AssemblyConstraint.GeometryTwo Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the geometry of the second of the two entities that this constraint is between. The geometry returned is in the space of the assembly and for face or work plane geometries it accounts for the orientation of the face or work plane.

Visual Basic
Property GeometryTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.GeometryTwo Property


AssemblyConstraint.HealthStatus Property

AssemblyConstraint.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.HealthStatus Property


AssemblyConstraint.iMateResult Property

AssemblyConstraint.iMateResult Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iMateResult object that resulted in the creation of this constraint.

Visual Basic
Property iMateResult() As iMateResult**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.iMateResult Property


AssemblyConstraint.LayoutConstraint Property

AssemblyConstraint.LayoutConstraint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the layout constraint this constraint is a member of. Returns Nothing in the case where this constraint is not a member of a layout constraint. You can also determine if a constraint is a member of a layout constraint by using the ResultOfLayoutConstraint property.

Visual Basic
Property LayoutConstraint() As LayoutConstraint**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.LayoutConstraint Property


AssemblyConstraint.Name Property

AssemblyConstraint.Name Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the name of the constraint. This is the name that is displayed in the browser.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.Name Property


AssemblyConstraint.OccurrenceOne Property

AssemblyConstraint.OccurrenceOne Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the first of the two objects this constraint is between.

Visual Basic
Property OccurrenceOne() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.OccurrenceOne Property


AssemblyConstraint.OccurrenceTwo Property

AssemblyConstraint.OccurrenceTwo Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the second of the two objects this constraint is between.

Visual Basic
Property OccurrenceTwo() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.OccurrenceTwo Property


AssemblyConstraint.Parent Property

AssemblyConstraint.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.Parent Property


AssemblyConstraint.ResultOfiMate Property

AssemblyConstraint.ResultOfiMate Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates if this iMateResult represents a composite iMate.

Visual Basic
Property ResultOfiMate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.ResultOfiMate Property


AssemblyConstraint.ResultOfLayoutConstraint Property

AssemblyConstraint.ResultOfLayoutConstraint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if this constraint is a member of a layout constraint. If True then it is a member of a layout constraint. The layout constraint can be obtained by using the LayoutConstraint property.

Visual Basic
Property ResultOfLayoutConstraint() As VARIANT_BOOL*
Remarks

If a constraint is a member of a layout constraint there are some limitation about what can be performed. For example, you cannot delete the constraint.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.ResultOfLayoutConstraint Property


AssemblyConstraint.Suppressed Property

AssemblyConstraint.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates whether the constraint is suppressed or not. A value of True indicates the feature is suppressed.

Visual Basic
Property Suppressed() As VARIANT_BOOL
See Also

Assembly Ground Occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.Suppressed Property


AssemblyConstraint.Type Property

AssemblyConstraint.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraint Interface > AssemblyConstraint Properties > AssemblyConstraint.Type Property


AssemblyConstraints Interface

AssemblyConstraints Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the collection in the top level of the assembly.

Class Hierarchy
Inventor::AssemblyConstraints
Visual Basic
Public Interface AssemblyConstraints
Inherits IDispatch
Remarks

The items of this object always reflect the current or active state of this set (and not just a snapshot taken at the time this object is obtained).

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.Constraints

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface


AssemblyConstraints Methods

AssemblyConstraints Methods
Summary

The methods of the AssemblyConstraints class are listed here.

Methods
Methods
Name | Description
AddAngleConstraint | Method that creates a new angle assembly constraint.
AddCustomConstraint | Method that creates a new custom constraint on the assembly.
AddFlushConstraint | Method that creates a new flush assembly constraint.
AddInsertConstraint | Method that creates a new insert assembly constraint.
AddMateConstraint | Method that creates a new mate assembly constraint. The two input entities can be a combination of planar faces, linear edges, vertices, cylindrical faces, conical faces, spherical faces, revolved faces, work planes, work axes, and work points. When a cylindrical, conical, or revolved face is input, the axis of the surface is used for the constraint. When a sphere is input, the center point of the sphere is used for the constraint. To use the surface of a cylindrical, conical, or spherical face use the EntityOneInferredType or EntityTwoInferredType arguments.
AddRotateRotateConstraint | Method that creates a new rotation motion constraint.
AddRotateTranslateConstraint | Method that creates a new rotate-translate motion constraint.
AddTangentConstraint | Method that creates a new tangent assembly constraint.
AddTransitionalConstraint | Method that creates a new transitional constraint.
Item | Property that returns the specified AssemblyConstraint object from the collection. This is the default property of the AssemblyConstraints collection object.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods


AssemblyConstraints.AddAngleConstraint Method

AssemblyConstraints.AddAngleConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new angle assembly constraint.

Visual Basic
Sub AddAngleConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Angle As VARIANT, ByRef SolutionType As [defaultvalue(kDirectedSolution)] AngleConstraintSolutionTypeEnum, ByRef ReferenceVectorEntity As [optional] VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] AngleConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
EntityTwo | Input object that defines the second object. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
Angle | Input Variant that defines the angle between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or will default to the current angle units of the document.
SolutionType | Optional input AngleConstraintSolutionTypeEnum that specifies the solution type. If specified to be kDirectionSolution, the solution always applies the right hand rule. If specified to be kUndirectionSolution, the solution allows either orientation, thus resolving situations where component orientation flips during a constraint drive or drag. If specified to be kReferenceVectorSolution, the ReferenceVectorEntity argument must be provided with a third entity for the solution. The default value is kDirectionSolution.
ReferenceVectorEntity | Optional input object that provides a third entity to solve the angle constraint. This argument is ignored if the SolutionType argument is not kReferenceVectorSolution. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used to help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddAngleConstraint Method


AssemblyConstraints.AddCustomConstraint Method

AssemblyConstraints.AddCustomConstraint Method Available in Inventor Available in Server
Summary

Method that creates a new custom constraint on the assembly.

Visual Basic
Sub AddCustomConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, ClientId As String, Result As [out, retval] CustomConstraint*)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddCustomConstraint Method


AssemblyConstraints.AddFlushConstraint Method

AssemblyConstraints.AddFlushConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new flush assembly constraint.

Visual Basic
Sub AddFlushConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Offset As VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] FlushConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object. The input object must be either a planar object or WorkPlane object.
EntityTwo | Input object that defines the second object. The input object must be either a planar object or WorkPlane object
Offset | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddFlushConstraint Method


AssemblyConstraints.AddInsertConstraint Method

AssemblyConstraints.AddInsertConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new insert assembly constraint.

Visual Basic
Sub AddInsertConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, AxesOpposed As VARIANT_BOOL, Distance As VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] InsertConstraint*)
Parameters
Parameters | Description
EntityOne | Object that defines the first object. This object is a circular edge.
EntityTwo | Object that defines the second object. This object is a circular edge.
AxesOpposed | Input Boolean that specifies whether the direction of the axes of the input entities are in the same direction or opposed. A value of True indicates they are opposed.
Distance | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Example

"Assembly Insert Constraint Add Example"

"This sample demonstrates the creation of an assembly insert constraint. Before running the sample, you need to open an assembly that contains at least two parts. Select circular edges on the two parts that will be used for the constraint and run the sample code. (Set the priority of the Select command and use the Shift-Select to select multiple edges.)"

Public Sub InsertConstraint()
    ' Set a reference to the assembly component definintion.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the select set.
    Dim oSelectSet As SelectSet
    Set oSelectSet = ThisApplication.ActiveDocument.SelectSet

    ' Validate the correct data is in the select set.
    If oSelectSet.Count  2 Then
        MsgBox "You must select the two circular edges for the insert."
        Exit Sub
    End If

    If Not TypeOf oSelectSet.Item(1) Is Edge Or Not TypeOf oSelectSet.Item(2) Is Edge Then
        MsgBox "You must select the two circular edges for the insert."
        Exit Sub
    End If

    ' Get the two edges from the select set.
    Dim oEdge1 As Edge
    Dim oEdge2 As Edge
    Set oEdge1 = oSelectSet.Item(1)
    Set oEdge2 = oSelectSet.Item(2)

    ' Create the insert constraint between the parts.
    Dim oInsert As InsertConstraint
    Set oInsert = oAsmCompDef.Constraints.AddInsertConstraint(oEdge1, oEdge2, True, 0)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddInsertConstraint Method


AssemblyConstraints.AddMateConstraint Method

AssemblyConstraints.AddMateConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new mate assembly constraint. The two input entities can be a combination of planar faces, linear edges, vertices, cylindrical faces, conical faces, spherical faces, revolved faces, work planes, work axes, and work points. When a cylindrical, conical, or revolved face is input, the axis of the surface is used for the constraint. When a sphere is input, the center point of the sphere is used for the constraint. To use the surface of a cylindrical, conical, or spherical face use the EntityOneInferredType or EntityTwoInferredType arguments.

Visual Basic
Sub AddMateConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Offset As VARIANT, ByRef EntityOneInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef EntityTwoInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] MateConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object.
EntityTwo | Input object that defines the second object.
Offset | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
EntityOneInferredType | Optional input constant that specifies how the geometry of entity one is to be interpreted. Depending on the geometry of the entity one, different options are possible. If entity one is a cylinder this can be either kNoInference or kInferredLine. For kNoInference to be valid for a cylinder, entity two must also be a cylinder and they must be the same radius. If entity one is a sphere this can be either kNoInference or kInferredPoint. For kNoInference to be valid for a sphere, entity two must also be a sphere and they must be the same radius. If entity one is a cone this can be either kNoInference or kInferredLine. For kNoInference to be valid for a cone, entity two must also be a cone and they must have the same taper angle. If entity one is a torus this can be either kInferredLine or kInferredPoint. For a plane, only kNoInference is valid.
EntityTwoInferredType | Input enum that specifies how the geometry of entity two is to be interpreted. Depending on the geometry of the entity two, different options are possible. If entity two is a cylinder this can be either kNoInference or kInferredLine. For kNoInference to be valid for a cylinder, entity one must also be a cylinder and they must be the same radius. If entity two is a sphere this can be either kNoInference or kInferredPoint. For kNoInference to be valid for a sphere, entity one must also be a sphere and they must be the same radius. If entity two is a cone this can be either kNoInference or kInferredLine. For kNoInference to be valid for a cone, entity one must also be a cone and they must have the same taper angle. If entity two is a torus this can be either kInferredLine or kInferredPoint. For a plane, only kNoInference is valid.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Example 1

Assembly Mate Constraint Add Example

This sample demonstrates the creation of an assembly mate constraint. Before running the sample, you need to open an assembly that contains at least two parts. Select planar faces on the two parts that will be used for the constraint and run the sample code. (Set the priority of the Select command and use the Shift-Select to select multiple faces.)

Public Sub MateConstraint()

    ' Set a reference to the assembly component definintion.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the select set.
    Dim oSelectSet As SelectSet
    Set oSelectSet = ThisApplication.ActiveDocument.SelectSet

    ' Validate the correct data is in the select set.
    If oSelectSet.Count <> 2 Then
        MsgBox "You must select the two entities valid for mate."
        Exit Sub
    End If

    ' Get the two entities from the select set.
    Dim oBrepEnt1 As Object
    Dim oBrepEnt2 As Object
    Set oBrepEnt1 = oSelectSet.Item(1)
    Set oBrepEnt2 = oSelectSet.Item(2)

    ' Create the insert constraint between the parts.
    Dim oMate As MateConstraint
    Set oMate = oAsmCompDef.Constraints.AddMateConstraint(oBrepEnt1, oBrepEnt2, 0)
End Sub
Example 2

Assembly Mate Constraint of Work Planes Example

This sample demonstrates creating a mate constraint between two occurrences using the work planes within those occurrences. To use the sample, have an assembly open that contains at least two occurrences, (part or subassembly), and run the program.

Public Sub MateConstraintOfWorkPlanes()
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Get references to the two occurrences to constrain.
    ' This arbitrarily gets the first and second occurrence.
    Dim oOcc1 As ComponentOccurrence
    Set oOcc1 = oAsmCompDef.Occurrences.Item(1)

    Dim oOcc2 As ComponentOccurrence
    Set oOcc2 = oAsmCompDef.Occurrences.Item(2)

    ' Get the XY plane from each occurrence.  This goes to the
    ' component definition of the part to get this information.
    ' This is the same as accessing the part document directly.
    ' The work plane obtained is in the context of the part,
    ' not the assembly.
    Dim oPartPlane1 As WorkPlane
    Set oPartPlane1 = oOcc1.Definition.WorkPlanes.Item(3)

    Dim oPartPlane2 As WorkPlane
    Set oPartPlane2 = oOcc2.Definition.WorkPlanes.Item(3)

    ' Because we need the work plane in the context of the assembly
    ' we need to create proxies for the work planes.  The proxies
    ' represent the work planes in the context of the assembly.
    Dim oAsmPlane1 As WorkPlaneProxy
    Call oOcc1.CreateGeometryProxy(oPartPlane1, oAsmPlane1)

    Dim oAsmPlane2 As WorkPlaneProxy
    Call oOcc2.CreateGeometryProxy(oPartPlane2, oAsmPlane2)

    ' Create the constraint using the work plane proxies.
    Call oAsmCompDef.Constraints.AddMateConstraint(oAsmPlane1, oAsmPlane2, 0)
End Sub
Example 3

Mate constraint with limits example.

This sample demonstrates the creation of an assembly mate constraint with maximum and minimum limits defined.

Public Sub MateConstraintWithLimits()

    ' Set a reference to the assembly component definintion.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the select set.
    Dim oSelectSet As SelectSet
    Set oSelectSet = ThisApplication.ActiveDocument.SelectSet

    ' Validate the correct data is in the select set.
    If oSelectSet.Count <> 2 Then
        MsgBox "You must select the two entities valid for mate."
        Exit Sub
    End If

    ' Get the two entities from the select set.
    Dim oBrepEnt1 As Object
    Dim oBrepEnt2 As Object
    Set oBrepEnt1 = oSelectSet.Item(1)
    Set oBrepEnt2 = oSelectSet.Item(2)

    ' Create the mate constraint between the parts, with an offset value of 0.
    Dim oMate As MateConstraint
    Set oMate = oAsmCompDef.Constraints.AddMateConstraint(oBrepEnt1, oBrepEnt2, 0)

    ' Set a maximum value of 2 inches
    oMate.ConstraintLimits.MaximumEnabled = True
    oMate.ConstraintLimits.Maximum.Expression = "2 in"

    ' Set a minimum value of -2 inches
    oMate.ConstraintLimits.MinimumEnabled = True
    oMate.ConstraintLimits.Minimum.Expression = "-2 in"
End Sub
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddMateConstraint Method


AssemblyConstraints.AddRotateRotateConstraint Method

AssemblyConstraints.AddRotateRotateConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new rotation motion constraint.

Visual Basic
Sub AddRotateRotateConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Ratio As VARIANT, ForwardDirection As VARIANT_BOOL, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] RotateRotateConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object and its rotation axis. The input object must be a planar , a revolved Point, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the rotation axis is normal to the input face.
EntityTwo | Input object that defines the second object and its rotation axis. The input object must be a planar , a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object.
Ratio | Input Variant that defines the rotation ratio between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. The input value is unitless.
ForwardDirection | Input Boolean that defines the direction of rotation of the objects with respect to the axis direction. If the input value is True then both objects will rotate the same direction around their axes. If False, then they will rotate in opposite directions.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddRotateRotateConstraint Method


AssemblyConstraints.AddRotateTranslateConstraint Method

AssemblyConstraints.AddRotateTranslateConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new rotate-translate motion constraint.

Visual Basic
Sub AddRotateTranslateConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, Ratio As VARIANT, ForwardDirection As VARIANT_BOOL, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] RotateTranslateConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object and its rotation axis. The input object must be a planar , a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the rotation axis is normal to the input face.
EntityTwo | Input object that defines the second object and its translation axis. The input object must be a planar , a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the translation axis is normal to the input face.
Ratio | Input Variant that defines the distance of translation for every revolution of the rotated occurrence. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
ForwardDirection | Input Boolean that defines the direction of translation with respect to the rotation direction relative to the axes directions. If the input value is True then when the rotation object is rotated in a positive direction about its axis, the translation object will move in the positive direction of its vector, If False, it will move in the negative direction.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddRotateTranslateConstraint Method


AssemblyConstraints.AddTangentConstraint Method

AssemblyConstraints.AddTangentConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new tangent assembly constraint.

Visual Basic
Sub AddTangentConstraint(EntityOne As IDispatch, EntityTwo As IDispatch, InsideTangency As VARIANT_BOOL, Offset As VARIANT, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] TangentConstraint*)
Parameters
Parameters | Description
EntityOne | Input object that defines the first object.
EntityTwo | Input object that defines the second object. This object is a circular edge.
InsideTangency | Input Boolean that specifies the orientation of the surfaces at the tangent contact point of the surfaces.
Offset | Input Variant that defines the offset between the two input entities. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddTangentConstraint Method


AssemblyConstraints.AddTransitionalConstraint Method

AssemblyConstraints.AddTransitionalConstraint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new transitional constraint.

Visual Basic
Sub AddTransitionalConstraint(FaceOne As Face, FaceTwo As Face, ByRef BiasPointOne As [optional] VARIANT, ByRef BiasPointTwo As [optional] VARIANT, Result As [out, retval] TransitionalConstraint*)
Parameters
Parameters | Description
FaceOne | Input that defines the initial face on the first occurrence that is used in repositioning the occurrences. Once the constraint is placed, it can move along any of the faces of the part.
FaceTwo | Input that defines the initial face on the second occurrence that is used in repositioning the occurrences. Once the constraint is placed, it can move along any of the faces of the part.
BiasPointOne | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
BiasPointTwo | Optional input object that is used help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the two bias points coincident. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint.
Remarks

For transitional constraints, the bias point defines the position where the transition occurs to adjacent faces. Hence, the bias point must lie within the boundary of the input face. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity. If this point is found not to lie within the face's boundary, a random sample point within the boundary is used.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.AddTransitionalConstraint Method


AssemblyConstraints.Item Method

AssemblyConstraints.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified AssemblyConstraint object from the collection. This is the default property of the AssemblyConstraints collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] AssemblyConstraint*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the constraint name. The name expected is the display name of the constraint. This is the name that is displayed to the user in the assembly browser. If an out of range index or a name of a non-existent constraint name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Methods > AssemblyConstraints.Item Method


AssemblyConstraints Properties

AssemblyConstraints Properties
Summary

The properties of the AssemblyConstraints class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent of the object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Properties


AssemblyConstraints.Application Property

AssemblyConstraints.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Properties > AssemblyConstraints.Application Property


AssemblyConstraints.Count Property

AssemblyConstraints.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Properties > AssemblyConstraints.Count Property


AssemblyConstraints.Parent Property

AssemblyConstraints.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Properties > AssemblyConstraints.Parent Property


AssemblyConstraints.Type Property

AssemblyConstraints.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraints Interface > AssemblyConstraints Properties > AssemblyConstraints.Type Property


AssemblyConstraintsEnumerator Interface

AssemblyConstraintsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the constraints acting directly on a particular occurrence.

Class Hierarchy
Inventor::AssemblyConstraintsEnumerator
Visual Basic
Public Interface AssemblyConstraintsEnumerator
Inherits IDispatch
Remarks

This object may also be used wherever a snapshot of a set of assembly constraints needs to be returned (this is a snapshot taken at the time this object is retrieved).

Notes

Members through which this object may be accessed include:

AssemblyWorkAxisDef.Constraints

AssemblyWorkPlaneDef.Constraints

AssemblyWorkPointDef.Constraints

ComponentOccurrence.Constraints

iMateResult.Constraints

RigidBodyJoint.Constraints

You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraintsEnumerator Interface


AssemblyConstraintsEnumerator Methods

AssemblyConstraintsEnumerator Methods
Summary

The methods of the AssemblyConstraintsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified AssemblyConstraint object from the collection. This is the default property of the AssemblyConstraintsEnumerator collection object.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraintsEnumerator Interface > AssemblyConstraintsEnumerator Methods


AssemblyConstraintsEnumerator.Item Method

AssemblyConstraintsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified AssemblyConstraint object from the collection. This is the default property of the AssemblyConstraintsEnumerator collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] AssemblyConstraint*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the constraint name. The name expected is the display name of the constraint. This is the name that is displayed to the user in the assembly browser. If an out of range index or a name of a non-existent constraint name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraintsEnumerator Interface > AssemblyConstraintsEnumerator Methods > AssemblyConstraintsEnumerator.Item Method


AssemblyConstraintsEnumerator Properties

AssemblyConstraintsEnumerator Properties
Summary

The properties of the AssemblyConstraintsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraintsEnumerator Interface > AssemblyConstraintsEnumerator Properties


AssemblyConstraintsEnumerator.Count Property

AssemblyConstraintsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraintsEnumerator Interface > AssemblyConstraintsEnumerator Properties > AssemblyConstraintsEnumerator.Count Property


AssemblyConstraintsEnumerator.Type Property

AssemblyConstraintsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyConstraintsEnumerator Interface > AssemblyConstraintsEnumerator Properties > AssemblyConstraintsEnumerator.Type Property


AssemblyDocument Interface

AssemblyDocument Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The AssemblyDocument object represents an in-memory Inventor assembly document.

Class Hierarchy
Inventor::Document
    Inventor::AssemblyDocument
Visual Basic
Public Interface AssemblyDocument
Inherits Document
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.Parent

AssemblyComponentDefinitions.Parent

See Also

Derived Parts and Assemblies sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Count Ocurrences sample

Replace content center part sample

Exporting the assembly BOM sample

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface


AssemblyDocument Methods

AssemblyDocument Methods
Summary

The methods of the AssemblyDocument class are listed here.

Methods
Methods
Name | Description
GetSelectedObject | This is GetSelectedObject, a member of class AssemblyDocument.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Methods


AssemblyDocument.GetSelectedObject Method

AssemblyDocument.GetSelectedObject Method
Summary

This is GetSelectedObject, a member of class AssemblyDocument.

Visual Basic
Sub GetSelectedObject(Selection As GenericObject, ByRef ObjectType As ObjectTypeEnum, ByRef AdditionalData As NameValueMap*, ByRef ContainingOccurrence As ComponentOccurrence*, ByRef SelectedObject As [optional] VARIANT)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Methods > AssemblyDocument.GetSelectedObject Method


AssemblyDocument Properties

AssemblyDocument Properties
Summary

The properties of the AssemblyDocument class are listed here.

Properties
Name | Description
ActiveLightingStyle | Property that gets and sets the lighting style to use for the assembly.
ComponentDefinition | Property that returns the object associated with this assembly. For a standard assembly document, an AssemblyComponentDefinition object will be returned. For a weldment assembly, a Weldment object.
DesignViewInfo | Gets the design view information for the document as a String containing XML formatted data. For more information on this XML format see More XML Design View Info...
DisabledCommandList | Property that returns the DisabledCommandList object. This object allows the document to disable specific commands. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.
DisplaySettings | Property that returns the DisplaySettings object. The DisplaySettings object provides access to various display appearance related document settings.
EnvironmentManager | Property that returns the EnvironmentManager object.
LevelOfDetailName | Property that returns the level of detail representation that this document represents.
LightingStyles | Property that returns the LightingStyles collection object.
Materials | Property that returns the Materials object. The Materials object provides access to materials available for assignment - for example, to welds.
ModelingSettings | Property that returns the ModelingSettings object. The ModelingSettings object provides access to various modeling related document options. This is somewhat equivalent to the Modeling tab of the Document Settings dialog.
ObjectVisibility | Property that returns the ObjectVisibility object providing override visibility controls for objects in the document. Changes are not saved with the document.
SketchSettings | Property that returns the SketchSettings object. The SketchSettings object provides access to various sketch related document options. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties


AssemblyDocument.ActiveLightingStyle Property

AssemblyDocument.ActiveLightingStyle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the lighting style to use for the assembly.

Visual Basic
Property ActiveLightingStyle() As LightingStyle*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.ActiveLightingStyle Property


AssemblyDocument.ComponentDefinition Property

AssemblyDocument.ComponentDefinition Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object associated with this assembly. For a standard assembly document, an AssemblyComponentDefinition object will be returned. For a weldment assembly, a Weldment object.

Visual Basic
Property ComponentDefinition() As AssemblyComponentDefinition**
See Also

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

Assembly Count Ocurrences sample

Client Graphics - Draw Range Box sample

Exporting the assembly BOM sample

Mate constraint with limits sample

Assembly Mate Constraint of Work Planes sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.ComponentDefinition Property


AssemblyDocument.DesignViewInfo Property

AssemblyDocument.DesignViewInfo Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets the design view information for the document as a String containing XML formatted data. For more information on this XML format see More XML Design View Info...

Visual Basic
Property DesignViewInfo() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.DesignViewInfo Property


AssemblyDocument.DisabledCommandList Property

AssemblyDocument.DisabledCommandList Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the DisabledCommandList object. This object allows the document to disable specific commands. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.

Visual Basic
Property DisabledCommandList() As DisabledCommandList**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.DisabledCommandList Property


AssemblyDocument.DisplaySettings Property

AssemblyDocument.DisplaySettings Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the DisplaySettings object. The DisplaySettings object provides access to various display appearance related document settings.

Visual Basic
Property DisplaySettings() As DisplaySettings**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.DisplaySettings Property


AssemblyDocument.EnvironmentManager Property

AssemblyDocument.EnvironmentManager Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the EnvironmentManager object.

Visual Basic
Property EnvironmentManager() As EnvironmentManager**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.EnvironmentManager Property


AssemblyDocument.LevelOfDetailName Property

AssemblyDocument.LevelOfDetailName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the level of detail representation that this document represents.

Visual Basic
Property LevelOfDetailName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.LevelOfDetailName Property


AssemblyDocument.LightingStyles Property

AssemblyDocument.LightingStyles Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the LightingStyles collection object.

Visual Basic
Property LightingStyles() As LightingStyles**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.LightingStyles Property


AssemblyDocument.Materials Property

AssemblyDocument.Materials Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the Materials object. The Materials object provides access to materials available for assignment - for example, to welds.

Visual Basic
Property Materials() As Materials**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.Materials Property


AssemblyDocument.ModelingSettings Property

AssemblyDocument.ModelingSettings Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the ModelingSettings object. The ModelingSettings object provides access to various modeling related document options. This is somewhat equivalent to the Modeling tab of the Document Settings dialog.

Visual Basic
Property ModelingSettings() As ModelingSettings**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.ModelingSettings Property


AssemblyDocument.ObjectVisibility Property

AssemblyDocument.ObjectVisibility Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ObjectVisibility object providing override visibility controls for objects in the document. Changes are not saved with the document.

Visual Basic
Property ObjectVisibility() As ObjectVisibility**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.ObjectVisibility Property


AssemblyDocument.SketchSettings Property

AssemblyDocument.SketchSettings Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the SketchSettings object. The SketchSettings object provides access to various sketch related document options. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.

Visual Basic
Property SketchSettings() As SketchSettings**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyDocument Interface > AssemblyDocument Properties > AssemblyDocument.SketchSettings Property


AssemblyEvents CoClass

AssemblyEvents CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

The AssemblyEvents object provides notification of assembly events including change, delete and constraint.

Class Hierarchy
Inventor::AssemblyEvents
Visual Basic
Public Class AssemblyEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.AssemblyEvents

Application.AssemblyEvents

You are here: Symbol Reference > Inventor Library > Objects > AssemblyEvents CoClass


AssemblyEventsObject Interface

AssemblyEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The AssemblyEvents object provides notification of assembly events including change, delete and constraint.

Class Hierarchy
Inventor::AssemblyEventsObject
Visual Basic
Public Interface AssemblyEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.AssemblyEvents

Application.AssemblyEvents

You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsObject Interface


AssemblyEventsObject Properties

AssemblyEventsObject Properties
Summary

The properties of the AssemblyEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Gets the parent object from whom this object can logically be reached.
Type | Property returning kAssemblyEventsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsObject Interface > AssemblyEventsObject Properties


AssemblyEventsObject.Application Property

AssemblyEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsObject Interface > AssemblyEventsObject Properties > AssemblyEventsObject.Application Property


AssemblyEventsObject.Parent Property

AssemblyEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsObject Interface > AssemblyEventsObject Properties > AssemblyEventsObject.Parent Property


AssemblyEventsObject.Type Property

AssemblyEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kAssemblyEventsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsObject Interface > AssemblyEventsObject Properties > AssemblyEventsObject.Type Property


AssemblyEventsSink Interface

AssemblyEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The AssemblyEvents object provides notification of assembly events including change, delete and constraint.

Class Hierarchy
Inventor::AssemblyEventsSink
Visual Basic
Public Interface AssemblyEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.AssemblyEvents

Application.AssemblyEvents

You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface


AssemblyEventsSink Methods

AssemblyEventsSink Methods
Summary

The methods of the AssemblyEventsSink class are listed here.

Methods
Methods
Name | Description
OnAssemblyChange | Event that is fired after any change occurs that impacts the assembly structure.
OnAssemblyChanged | Event that is fired after any change occurs that impacts the assembly structure.
OnDelete | Event that is fired whenever an object within this events set is deleted in a document.
OnNewConstraint | Event that is fired whenever an assembly constraint or an iMate result is created.
OnNewOccurrence | Event that is fired whenever an occurrence is created.
OnOccurrenceChange | Event that is fired whenever an occurrence changes.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods


AssemblyEventsSink.OnAssemblyChange Method

AssemblyEventsSink.OnAssemblyChange Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired after any change occurs that impacts the assembly structure.

Visual Basic
Sub OnAssemblyChange(DocumentObject As AssemblyDocument, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input AssemblyDocument object that indicates the document in which the change occurred.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the assembly is changed.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods > AssemblyEventsSink.OnAssemblyChange Method


AssemblyEventsSink.OnAssemblyChanged Method

AssemblyEventsSink.OnAssemblyChanged Method Available in Inventor Available in Server
Summary

Event that is fired after any change occurs that impacts the assembly structure.

Visual Basic
Sub OnAssemblyChanged(Context As NameValueMap, BeforeOrAfter As EventTimingEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the assembly is changed.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
DocumentObject | Input AssemblyDocument object that indicates the document in which the change occurred.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods > AssemblyEventsSink.OnAssemblyChanged Method


AssemblyEventsSink.OnDelete Method

AssemblyEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever an object within this events set is deleted in a document.

Visual Basic
Sub OnDelete(DocumentObject As Document, Entity As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
Input Document object that indicates the document in which the change occurred.
Entity
Input object that was just deleted.
When the value of the BeforeOrAfter argument is kBefore, the object provided is the object being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved (usually during kBefore). For example: Private m_oDeletedEntity As Object Private Sub oAssemblyEvents_OnDelete(ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...) If BeforeOrAfter = kBefore Then ' Check to see if the Entity being deleted is an interesting one. For example, it could have an attribute attached to it. If Interesting(Entity) Then ' Save a reference to the object. Set m_oDeletedEntity = Entity End If Else ' Now we're either after the delete or it's been aborted. Check to see if the object is the interesting one. If Entity Is m_oDeletedEntity Then If BeforeOrAfter = kAfter then ' The object was deleted. Else If BeforeOrAfter = kAbort Then ' The delete was aborted. End If End If End Sub
BeforeOrAfter
Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the entity is deleted.
Context
Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Assembly objects currently reported are ComponentOccurrence and AssemblyConstraint objects. The Document.OnDelete event can be used if delete notification is needed for other types of objects.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods > AssemblyEventsSink.OnDelete Method


AssemblyEventsSink.OnNewConstraint Method

AssemblyEventsSink.OnNewConstraint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Event that is fired whenever an assembly constraint or an iMate result is created.

Visual Basic
Sub OnNewConstraint(DocumentObject As AssemblyDocument, Constraint As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input AssemblyDocument object that indicates the document in which the change occurred.
Constraint | Input object (either an AssemblyConstraint or an iMateResult) that was just created. Nothing in the kBefore case.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the constraint is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods > AssemblyEventsSink.OnNewConstraint Method


AssemblyEventsSink.OnNewOccurrence Method

AssemblyEventsSink.OnNewOccurrence Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever an occurrence is created.

Visual Basic
Sub OnNewOccurrence(DocumentObject As AssemblyDocument, Occurrence As ComponentOccurrence, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input AssemblyDocument object that indicates the document in which the change occurred.
Occurrence | Input ComponentOccurrence object that was just created. Nothing in the kBefore case.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the occurrence is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods > AssemblyEventsSink.OnNewOccurrence Method


AssemblyEventsSink.OnOccurrenceChange Method

AssemblyEventsSink.OnOccurrenceChange Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever an occurrence changes.

Visual Basic
Sub OnOccurrenceChange(DocumentObject As AssemblyDocument, Occurrence As ComponentOccurrence, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
Input AssemblyDocument object that indicates the document in which the change occurred.
Occurrence
Input ComponentOccurrence object that indicates the occurrence that changed.
BeforeOrAfter
Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the occurrence is changed.
Context
Input NameValueMap object that can be used to determine the context of why the event fired. Information describing the change is passed through the context argument, as described below: Name = "Grounded", Value = True or False. Indicates the grounded state is changing. The value indicates the new grounded state of the occurrence. Name = "Adaptive", Value = True or False. Indicates the adaptive state is changing. The value indicates the new adaptive state of the occurrence. Name = "Visible", Value = True or False. Indicates the visibility state is changing. The value indicates the new visibility state of the occurrence. Name = "Enabled", Value = True or False. Indicates the enabled state is changing. The value indicates the new enabled state of the occurrence. Name = "Suppressed", Value = True or False. Indicates the suppressed state is changing. The value indicates the new suppressed state of the occurrence. Name = "Transformation", Value = Matrix object. Indicates the occurrence is being transformed. The Matrix object provided specifies the new transformation of the occurrence. If the original transformation is needed, you can obtain it using the Transformation property of the ComponentOccurrence object provided by the Occurrence argument of this event when the timing is kBefore.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

The changes reported by this event are if any of the following states of an occurrence change: grounded, adaptive, visible, enabled, suppressed, and repositioned (transformed). The type of change and information related to the change is passed through the context argument.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyEventsSink Interface > AssemblyEventsSink Methods > AssemblyEventsSink.OnOccurrenceChange Method


AssemblyOptions Interface

AssemblyOptions Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The AssemblyOptions object provides access to properties that provide read and write access of the assembly related application options. This is somewhat equivalent to the Assembly tab of the Application Options dialog.

Class Hierarchy
Inventor::AssemblyOptions
Visual Basic
Public Interface AssemblyOptions
Inherits IDispatch
Remarks

This is somewhat equivalent to the Assembly tab of the Application Options dialog.

Notes

Members through which this object may be accessed include:

Application.AssemblyOptions

You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface


AssemblyOptions Methods

AssemblyOptions Methods
Summary

The methods of the AssemblyOptions class are listed here.

Methods
Methods
Name | Description
UseiMate | Property that specifies whether iMates should be automatically used when placing components in an assembly. A value of True indicates that iMates will be automatically used during component placement.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Methods


AssemblyOptions.UseiMate Method

AssemblyOptions.UseiMate Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether iMates should be automatically used when placing components in an assembly. A value of True indicates that iMates will be automatically used during component placement.

Visual Basic
Sub UseiMate(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Methods > AssemblyOptions.UseiMate Method


AssemblyOptions Properties

AssemblyOptions Properties
Summary

The properties of the AssemblyOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ConstraintAudioNotification | Property that enables or disables audio notifications when creating constraints. A value of True enables audio notifications.
DeferUpdate | Property that enables or disables updating assemblies when you edit components. Setting this property to True will defer updates of an assembly until the Update button is clicked or the Update method of the document is called.
DeleteComponentPatternSources | Property that gets and sets the behavior when deleting pattern elements. Setting this property to True will delete the source component when deleting a pattern. A value of False will retain the source component instance(s) when deleting a pattern.
DisplayComponentNamesInConstraints | Property that specifies whether component names should be suffixed to constraint names.
EnableConstraintRedundancyAnalysis | Property that enables or disables analysis of all assembly components for adaptivity adjustments. A value of True enables constraint redundancy analysis.
EnableCrossPartEdgeLoopProjection | Property that enables or disables associative edge/loop geometry projection during in-place modeling. A value of True enables cross part geometry projection.
EnableRelatedConstraintFailureAnalysis | Property that enables or disables performing an analysis to identify all affected constraints and components when constraints fail. A value of True enables the analysis to resolve constraint failures.
FromToExtentsAdaptFeature | Property that enables or disables automatically adapting the in-place feature size or position when the plane on which it is constructed changes. A value of True enables automatic adapting.
FromToExtentsMatePlane | Property that enables or disables automatically creating the feature to the desired size and mating it to the plane. A value of True enables automatic adjustment of feature size and mating it to the plane.
OnlyActiveComponentIsOpaque | Property that specifies which components are displayed opaque and translucent when a component is in-place activated. A value of True causes only the active part to be displayed using an opaque display style, while the rest of the assembly is displayed as translucent. A value of False causes all components to be displayed using an opaque display style.
PartFeaturesInitiallyAdaptive | Property that gets and sets the default adaptive behavior when new features are created. A value of True indicates that new features will be adaptive.
SectionAllParts | Property that enables or disables sectioning of all parts including standard parts in an assembly. A value of True enables sectioning of all parts.
Type | Returns an ObjectTypeEnum indicating this object's type.
UseLastOccurrenceOrientationForPlacement | Property that specifies whether the last used orientation should be applied when placing components interactively. This option does not affect the orientation of occurrences added through the API.
ZoomTargetComponentWithiMate | Property that gets and sets the default zoom behavior for the graphics window when placing components with iMates.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties


AssemblyOptions.Application Property

AssemblyOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.Application Property


AssemblyOptions.ConstraintAudioNotification Property

AssemblyOptions.ConstraintAudioNotification Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables audio notifications when creating constraints. A value of True enables audio notifications.

Visual Basic
Property ConstraintAudioNotification() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.ConstraintAudioNotification Property


AssemblyOptions.DeferUpdate Property

AssemblyOptions.DeferUpdate Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables updating assemblies when you edit components. Setting this property to True will defer updates of an assembly until the Update button is clicked or the Update method of the document is called.

Visual Basic
Property DeferUpdate() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.DeferUpdate Property


AssemblyOptions.DeleteComponentPatternSources Property

AssemblyOptions.DeleteComponentPatternSources Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the behavior when deleting pattern elements. Setting this property to True will delete the source component when deleting a pattern. A value of False will retain the source component instance(s) when deleting a pattern.

Visual Basic
Property DeleteComponentPatternSources() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.DeleteComponentPatternSources Property


AssemblyOptions.DisplayComponentNamesInConstraints Property

AssemblyOptions.DisplayComponentNamesInConstraints Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies whether component names should be suffixed to constraint names.

Visual Basic
Property DisplayComponentNamesInConstraints() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.DisplayComponentNamesInConstraints Property


AssemblyOptions.EnableConstraintRedundancyAnalysis Property

AssemblyOptions.EnableConstraintRedundancyAnalysis Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables analysis of all assembly components for adaptivity adjustments. A value of True enables constraint redundancy analysis.

Visual Basic
Property EnableConstraintRedundancyAnalysis() As VARIANT_BOOL
Remarks

If enabled, a secondary analysis which checks for redundant constraints and analyzes all component degrees of freedom is performed. The degrees of freedom are updated even when the symbols associated with them are not displayed. If disabled, the secondary analysis is skipped and the degrees of freedom are updated only when the symbols are displayed.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.EnableConstraintRedundancyAnalysis Property


AssemblyOptions.EnableCrossPartEdgeLoopProjection Property

AssemblyOptions.EnableCrossPartEdgeLoopProjection Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables associative edge/loop geometry projection during in-place modeling. A value of True enables cross part geometry projection.

Visual Basic
Property EnableCrossPartEdgeLoopProjection() As VARIANT_BOOL
Remarks

If enabled, when creating a new part or feature in an assembly a reference sketch is created by projecting selected geometry from one part into the sketch of another part. The projected geometry is associative and updates when changes are made to the parent part. Projected geometry can be used to create a sketched feature.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.EnableCrossPartEdgeLoopProjection Property


AssemblyOptions.EnableRelatedConstraintFailureAnalysis Property

AssemblyOptions.EnableRelatedConstraintFailureAnalysis Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables performing an analysis to identify all affected constraints and components when constraints fail. A value of True enables the analysis to resolve constraint failures.

Visual Basic
Property EnableRelatedConstraintFailureAnalysis() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.EnableRelatedConstraintFailureAnalysis Property


AssemblyOptions.FromToExtentsAdaptFeature Property

AssemblyOptions.FromToExtentsAdaptFeature Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables automatically adapting the in-place feature size or position when the plane on which it is constructed changes. A value of True enables automatic adapting.

Visual Basic
Property FromToExtentsAdaptFeature() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.FromToExtentsAdaptFeature Property


AssemblyOptions.FromToExtentsMatePlane Property

AssemblyOptions.FromToExtentsMatePlane Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables automatically creating the feature to the desired size and mating it to the plane. A value of True enables automatic adjustment of feature size and mating it to the plane.

Visual Basic
Property FromToExtentsMatePlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.FromToExtentsMatePlane Property


AssemblyOptions.OnlyActiveComponentIsOpaque Property

AssemblyOptions.OnlyActiveComponentIsOpaque Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that specifies which components are displayed opaque and translucent when a component is in-place activated. A value of True causes only the active part to be displayed using an opaque display style, while the rest of the assembly is displayed as translucent. A value of False causes all components to be displayed using an opaque display style.

Visual Basic
Property OnlyActiveComponentIsOpaque() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.OnlyActiveComponentIsOpaque Property


AssemblyOptions.PartFeaturesInitiallyAdaptive Property

AssemblyOptions.PartFeaturesInitiallyAdaptive Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the default adaptive behavior when new features are created. A value of True indicates that new features will be adaptive.

Visual Basic
Property PartFeaturesInitiallyAdaptive() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.PartFeaturesInitiallyAdaptive Property


AssemblyOptions.SectionAllParts Property

AssemblyOptions.SectionAllParts Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables sectioning of all parts including standard parts in an assembly. A value of True enables sectioning of all parts.

Visual Basic
Property SectionAllParts() As VARIANT_BOOL
Remarks

The default behavior for standard parts is that they are not sectioned when the assembly in which they are placed is sectioned. The sectioning behavior for parts can also be explicitly specified using the AllowSectioningThruPart property of the ModelingSettings object. Setting the SectionAllParts property to True overrides the default behavior of standard parts as well as the AllowSectioningThruPart property and forces all parts in the assembly to be sectioned.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.SectionAllParts Property


AssemblyOptions.Type Property

AssemblyOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.Type Property


AssemblyOptions.UseLastOccurrenceOrientationForPlacement Property

AssemblyOptions.UseLastOccurrenceOrientationForPlacement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies whether the last used orientation should be applied when placing components interactively. This option does not affect the orientation of occurrences added through the API.

Visual Basic
Property UseLastOccurrenceOrientationForPlacement() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.UseLastOccurrenceOrientationForPlacement Property


AssemblyOptions.ZoomTargetComponentWithiMate Property

AssemblyOptions.ZoomTargetComponentWithiMate Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the default zoom behavior for the graphics window when placing components with iMates.

Visual Basic
Property ZoomTargetComponentWithiMate() As ZoomTargetComponentWithiMateEnum
Remarks

The valid options are kZoomTargetNone, kZoomTargetPlacedComponent and kZoomTargetAll. Setting this property to kZoomTargetNone leaves the view as it is and no zoom is performed. Setting this property to kZoomTargetPlacedComponent zooms in on the placed part so that it fills the graphics window. Setting this property to kZoomTargetAll zooms the assembly so that all elements in the model fit in the graphics window.

You are here: Symbol Reference > Inventor Library > Objects > AssemblyOptions Interface > AssemblyOptions Properties > AssemblyOptions.ZoomTargetComponentWithiMate Property


AssemblyWorkAxisDef Interface

AssemblyWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The AssemblyWorkAxisDef object allows you to get and set the information that specifies a fixed work axis.

Class Hierarchy
Inventor::AssemblyWorkAxisDef
Visual Basic
Public Interface AssemblyWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface


AssemblyWorkAxisDef Methods

AssemblyWorkAxisDef Methods
Summary

The methods of the AssemblyWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining an assembly work axis.
PutData | Method that sets all of the data defining an assembly work axis.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Methods


AssemblyWorkAxisDef.GetData Method

AssemblyWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that gets all of the data defining an assembly work axis.

Visual Basic
Sub GetData(ByRef OriginPoint As Point*, ByRef Axis As UnitVector*)
Parameters
Parameters | Description
OriginPoint | Output object that defines the origin of the work axis.
Axis | Output object that defines the X-axis vector of the work axis.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Methods > AssemblyWorkAxisDef.GetData Method


AssemblyWorkAxisDef.PutData Method

AssemblyWorkAxisDef.PutData Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that sets all of the data defining an assembly work axis.

Visual Basic
Sub PutData(OriginPoint As Point, Axis As UnitVector)
Parameters
Parameters | Description
OriginPoint | Input object that defines the origin of the work axis.
Axis | Input object that defines the X-axis vector of the work axis.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Methods > AssemblyWorkAxisDef.PutData Method


AssemblyWorkAxisDef Properties

AssemblyWorkAxisDef Properties
Summary

The properties of the AssemblyWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Axis | Property that returns the X-axis vector of the work axis.
Constraints | Property that returns the collection of constraints that are acting on the work axis. This returns all of the constraints, including those returned by the DefinitionConstraints property.
OriginPoint | Property that returns the origin point of the work axis.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties


AssemblyWorkAxisDef.Application Property

AssemblyWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties > AssemblyWorkAxisDef.Application Property


AssemblyWorkAxisDef.Axis Property

AssemblyWorkAxisDef.Axis Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the X-axis vector of the work axis.

Visual Basic
Property Axis() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties > AssemblyWorkAxisDef.Axis Property


AssemblyWorkAxisDef.Constraints Property

AssemblyWorkAxisDef.Constraints Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection of constraints that are acting on the work axis. This returns all of the constraints, including those returned by the DefinitionConstraints property.

Visual Basic
Property Constraints() As AssemblyConstraintsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties > AssemblyWorkAxisDef.Constraints Property


AssemblyWorkAxisDef.OriginPoint Property

AssemblyWorkAxisDef.OriginPoint Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the origin point of the work axis.

Visual Basic
Property OriginPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties > AssemblyWorkAxisDef.OriginPoint Property


AssemblyWorkAxisDef.Parent Property

AssemblyWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties > AssemblyWorkAxisDef.Parent Property


AssemblyWorkAxisDef.Type Property

AssemblyWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkAxisDef Interface > AssemblyWorkAxisDef Properties > AssemblyWorkAxisDef.Type Property


AssemblyWorkPlaneDef Interface

AssemblyWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The AssemblyWorkPlaneDef object allows you to access the information specific to work planes in an assembly.

Class Hierarchy
Inventor::AssemblyWorkPlaneDef
Visual Basic
Public Interface AssemblyWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface


AssemblyWorkPlaneDef Methods

AssemblyWorkPlaneDef Methods
Summary

The methods of the AssemblyWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining an assembly work plane.
PutData | Method that sets all of the data defining an assembly work plane.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Methods


AssemblyWorkPlaneDef.GetData Method

AssemblyWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that gets all of the data defining an assembly work plane.

Visual Basic
Sub GetData(ByRef OriginPoint As Point*, ByRef XAxis As UnitVector*, ByRef YAxis As UnitVector*)
Parameters
Parameters | Description
OriginPoint | Output object that defines the origin of the work plane.
XAxis | Output object that defines the X-axis vector of the work plane.
YAxis | Output object that defines the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Methods > AssemblyWorkPlaneDef.GetData Method


AssemblyWorkPlaneDef.PutData Method

AssemblyWorkPlaneDef.PutData Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that sets all of the data defining an assembly work plane.

Visual Basic
Sub PutData(OriginPoint As Point, XAxis As UnitVector, YAxis As UnitVector)
Parameters
Parameters | Description
OriginPoint | Input object that defines the origin of the work plane.
XAxis | Input object that defines the X-axis vector of the work plane.
YAxis | Input object that defines the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Methods > AssemblyWorkPlaneDef.PutData Method


AssemblyWorkPlaneDef Properties

AssemblyWorkPlaneDef Properties
Summary

The properties of the AssemblyWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Constraints | Property that returns the collection of constraints that are acting on the work plane. This returns all of the constraints, including those returned by the DefinitionConstraints property
OriginPoint | Property that returns the origin point of the work plane.
Parent | Property that returns the parent WorkPlane object.
Type | Property returning an enum indicating this object's type.
XAxis | Property that returns the X-axis vector of the work plane.
YAxis | Property that returns the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties


AssemblyWorkPlaneDef.Application Property

AssemblyWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.Application Property


AssemblyWorkPlaneDef.Constraints Property

AssemblyWorkPlaneDef.Constraints Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection of constraints that are acting on the work plane. This returns all of the constraints, including those returned by the DefinitionConstraints property

Visual Basic
Property Constraints() As AssemblyConstraintsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.Constraints Property


AssemblyWorkPlaneDef.OriginPoint Property

AssemblyWorkPlaneDef.OriginPoint Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the origin point of the work plane.

Visual Basic
Property OriginPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.OriginPoint Property


AssemblyWorkPlaneDef.Parent Property

AssemblyWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.Parent Property


AssemblyWorkPlaneDef.Type Property

AssemblyWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.Type Property


AssemblyWorkPlaneDef.XAxis Property

AssemblyWorkPlaneDef.XAxis Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the X-axis vector of the work plane.

Visual Basic
Property XAxis() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.XAxis Property


AssemblyWorkPlaneDef.YAxis Property

AssemblyWorkPlaneDef.YAxis Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the Y-axis vector of the work plane.

Visual Basic
Property YAxis() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPlaneDef Interface > AssemblyWorkPlaneDef Properties > AssemblyWorkPlaneDef.YAxis Property


AssemblyWorkPointDef Interface

AssemblyWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The AssemblyWorkPointDef object allows you to get and set the information that specifies a fixed work point.

Class Hierarchy
Inventor::AssemblyWorkPointDef
Visual Basic
Public Interface AssemblyWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface


AssemblyWorkPointDef Properties

AssemblyWorkPointDef Properties
Summary

The properties of the AssemblyWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Constraints | Property that returns the collection of constraints that are acting on the work point. This returns all of the constraints, including those returned by the DefinitionConstraints property.
Parent | Property that returns the parent WorkPoint object.
Point | Property that gets and set the origin point of the work point.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface > AssemblyWorkPointDef Properties


AssemblyWorkPointDef.Application Property

AssemblyWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface > AssemblyWorkPointDef Properties > AssemblyWorkPointDef.Application Property


AssemblyWorkPointDef.Constraints Property

AssemblyWorkPointDef.Constraints Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection of constraints that are acting on the work point. This returns all of the constraints, including those returned by the DefinitionConstraints property.

Visual Basic
Property Constraints() As AssemblyConstraintsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface > AssemblyWorkPointDef Properties > AssemblyWorkPointDef.Constraints Property


AssemblyWorkPointDef.Parent Property

AssemblyWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface > AssemblyWorkPointDef Properties > AssemblyWorkPointDef.Parent Property


AssemblyWorkPointDef.Point Property

AssemblyWorkPointDef.Point Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that gets and set the origin point of the work point.

Visual Basic
Property Point() As Point*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface > AssemblyWorkPointDef Properties > AssemblyWorkPointDef.Point Property


AssemblyWorkPointDef.Type Property

AssemblyWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AssemblyWorkPointDef Interface > AssemblyWorkPointDef Properties > AssemblyWorkPointDef.Type Property


Attribute Interface

Attribute Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Attribute object stores a name and value and belongs to a specific attribute set.

Class Hierarchy
Inventor::Attribute
Visual Basic
Public Interface Attribute
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

AttributesEnumerator.Item

AttributeSet.Add

AttributeSet.Item

Example

See AttributeSets for example "AttributeSets Object"

You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface


Attribute Methods

Attribute Methods
Summary

The methods of the Attribute class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the attribute from the attribute set.
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Methods


Attribute.Delete Method

Attribute.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the attribute from the attribute set.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Methods > Attribute.Delete Method


Attribute Properties

Attribute Properties
Summary

The properties of the Attribute class are listed here.

Properties
Name | Description
Name | Property that indicates the name of the attribute.
Parent | Property that returns the parent AttributeSet.
Type | Property returning an enum indicating this object's type.
Value | Property that returns and sets the value of the attribute. The type of this value remains the same. On write, the input variant is coerced if necessary into the value type of this attribute.
ValueType | Property that returns the type of the value stored within this attribute.
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Properties


Attribute.Name Property

Attribute.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates the name of the attribute.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Properties > Attribute.Name Property


Attribute.Parent Property

Attribute.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent AttributeSet.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Properties > Attribute.Parent Property


Attribute.Type Property

Attribute.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Properties > Attribute.Type Property


Attribute.Value Property

Attribute.Value Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns and sets the value of the attribute. The type of this value remains the same. On write, the input variant is coerced if necessary into the value type of this attribute.

Visual Basic
Property Value() As VARIANT
See Also

Dynamic Attributes sample

You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Properties > Attribute.Value Property


Attribute.ValueType Property

Attribute.ValueType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the type of the value stored within this attribute.

Visual Basic
Property ValueType() As ValueTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Attribute Interface > Attribute Properties > Attribute.ValueType Property


AttributeManager Interface

AttributeManager Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Dynamic attributes provide the ability for a programmer to add any arbitrary data to any persistent object within Autodesk Inventor.

Class Hierarchy
Inventor::AttributeManager
Visual Basic
Public Interface AttributeManager
Inherits IDispatch
Remarks

Once the attributes are added to the object, Autodesk Inventor maintains them. The programmer can then retrieve the attribute information from the object at a later time and also query the document to find all objects that have specific attributes associated with them.The ability to associate data with an object is useful in many types of applications and utilities. For example, an application that constructs printed circuit board assemblies might use attributes to attach information to each of the occurrences that represent electrical components. A mold base package might attach attributes to a face to indicate how parting lines should be generated for it. It might also add attribute information to holes to indicate what types of holes they are. For example, a cooling line hole would be machined differently from a hole for a leader pin. By placing this information on the geometry, downstream operations can take advantage of this additional information.The AttributeManager object supports several methods that allow you to perform queries to find attributes that match certain criteria. It also supports a method that allows you to determine if a name is used within the scope of the document. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.AttributeManager

Document.AttributeManager

You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface


AttributeManager Methods

AttributeManager Methods
Summary

The methods of the AttributeManager class are listed here.

Methods
Methods
Name | Description
FindAttributes | Method that returns the Attribute objects that match the search criteria.
FindAttributeSets | Method that returns attribute sets that have the specified names and values.
FindObjects | Method that returns the objects that have the specified attributes.
FindObjectsByPattern | Method that returns the objects whose AttributeSets, if converted to XML, satisfy the specified XSL pattern.
OpenAttributeSets | Finds the AttributeSet of the given name for each object in the object collection. If it does not find one, it creates a new AttributeSet. returns the in the same order as the object collection. Using this method is several times faster than accessing AttributeSets for each object individually. OpenAttributeSets works correctly even if the given collection has degenerate objects such as an edge for the apex of a cone. In such a case, OpenAttributeSets succeeds for all the valid objects, and returns NULL objects for the degenerate objects.
PurgeAttributeSets | Method that finds and deletes the AttributeSets of the specified names whose parent cannot be resolved. If preview flag is true, then instead of deleting these AttributeSets, it returns their collection.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods


AttributeManager.FindAttributes Method

AttributeManager.FindAttributes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the Attribute objects that match the search criteria.

Visual Basic
Sub FindAttributes(ByRef AttributeSetName As [defaultvalue("*")] BSTR, ByRef AttributeName As [defaultvalue("*")] BSTR, ByRef AttributeValue As [optional] VARIANT, Result As [out, retval] AttributesEnumerator*)
Parameters
Parameters | Description
AttributeSetName | Optional input String value that specifies the name of the owning attribute set. An asterisk can be used as a wild card in the string to match partial strings. If this value is not input it will default to "*" which will match all attribute sets. The search is not case sensitive.
AttributeName | Optional input String value that specifies the name of the attribute, including a compound name that contains nested sub-Attributes. An asterisk can be used as a wild card in the string to match partial strings. A dot is used as the delimiter between an attribute and its sub-attribute. If this value is not input it will default to "*" which will match all attributes. The search is not case sensitive. Thus, "Color.Green*" will match an object that has an attribute whose name is "color" with a sub-attribute, "green." The sub-attribute could also be "greenish" as well and the match would succeed. But no match is found if a 'color' object is found with no sub-attributes. On the other hand, a query with simply "Color" will match all objects which may or may not have sub-attributes, but do have the direct attribute, "color."
AttributeValue | Optional input Variant value that specifies the value of the attribute. In the case of attributes that contain string values, an asterisk can be used as a wild card in the string to match partial strings. For other types, exact matches must be made. For some types, the value will be ignored, i.e. arrays. If this argument is not specified it will ignore the value and match based on the AttributeSetName and AttributeName arguments.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods > AttributeManager.FindAttributes Method


AttributeManager.FindAttributeSets Method

AttributeManager.FindAttributeSets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns attribute sets that have the specified names and values.

Visual Basic
Sub FindAttributeSets(ByRef AttributeSetName As [defaultvalue("*")] BSTR, ByRef AttributeName As [defaultvalue("*")] BSTR, ByRef AttributeValue As [optional] VARIANT, Result As [out, retval] AttributeSetsEnumerator*)
Parameters
Parameters | Description
AttributeSetName | Optional input String value that specifies the name of the attribute set. An asterisk can be used as a wild card in the string to match partial strings. If this value is not input it will default to "*" which will match all attribute sets. The search is not case sensitive.
AttributeName | Optional input String value that specifies the name of any attribute within the set, including a compound name that contains nested sub-Attributes. An asterisk can be used as a wild card in the string to match partial strings. A dot is used as the delimiter between an attribute and its sub-attribute. If this value is not input it will default to "*" which will match all attributes. The search is not case sensitive. Thus, "Color.Green*" will match an object that has an attribute whose name is "color" with a sub-attribute, "green." The sub-attribute could also be "greenish" as well and the match would succeed. But no match is found if a 'color' object is found with no sub-attributes. On the other hand, a query with simply "Color" will match all objects which may or may not have sub-attributes, but do have the direct attribute, "color."
AttributeValue | Optional input Variant value that specifies the value of the attribute. In the case of attributes that contain string values, an asterisk can be used as a wild card in the string to match partial strings. For other types, exact matches must be made. For some types, the value will be ignored, i.e. arrays. If this argument is not specified it will ignore the value and match based on the AttributeSetName and AttributeName arguments.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods > AttributeManager.FindAttributeSets Method


AttributeManager.FindObjects Method

AttributeManager.FindObjects Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the objects that have the specified attributes.

Visual Basic
Sub FindObjects(ByRef AttributeSetName As [defaultvalue("*")] BSTR, ByRef AttributeName As [defaultvalue("*")] BSTR, ByRef AttributeValue As [optional] VARIANT, Result As [out, retval] ObjectCollection*)
Parameters
Parameters | Description
AttributeSetName | Optional input String value that specifies the name of the attribute set. An asterisk can be used as a wild card in the string to match partial strings. If this value is not input it will default to "*" which will match all attribute sets. The search is not case sensitive.
AttributeName | Optional input String value that specifies the name of the attribute. An asterisk can be used as a wild card in the string to match partial strings. If this value is not input it will default to "*" which will match all attributes. The search is not case sensitive.
AttributeValue | Optional input Variant value that specifies the value of the attribute. In the case of attributes that contain string values, an asterisk can be used as a wild card in the string to match partial strings. For other types, exact matches must be made. For some types, the value will be ignored, i.e. arrays. If this argument is not specified it will ignore the value and match based on the AttributeSetName and AttributeName arguments.
Remarks

About performance

Using this method improves the performance of subsequent attributes queries. Calling this method populates certain internal caches. Thus the time required to query attributeSets properties on these objects is dramatically reduced. These caches remain valid till you change or close the document(s). This affects only the objects owned by the document. To use this method just for the purpose of populating the cache, you should call it without any arguments.

You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods > AttributeManager.FindObjects Method


AttributeManager.FindObjectsByPattern Method

AttributeManager.FindObjectsByPattern Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the objects whose AttributeSets, if converted to XML, satisfy the specified XSL pattern.

Visual Basic
Sub FindObjectsByPattern(XPath As String, Result As [out, retval] ObjectCollection*)
Parameters
Parameters | Description
xslPattern | Input String that specifies the XSL pattern to match.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods > AttributeManager.FindObjectsByPattern Method


AttributeManager.OpenAttributeSets Method

AttributeManager.OpenAttributeSets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Finds the AttributeSet of the given name for each object in the object collection. If it does not find one, it creates a new AttributeSet. returns the in the same order as the object collection. Using this method is several times faster than accessing AttributeSets for each object individually. OpenAttributeSets works correctly even if the given collection has degenerate objects such as an edge for the apex of a cone. In such a case, OpenAttributeSets succeeds for all the valid objects, and returns NULL objects for the degenerate objects.

Visual Basic
Sub OpenAttributeSets(Objects As ObjectCollection, AttributeSetName As String, Result As [out, retval] AttributeSetsEnumerator*)
Parameters
Parameters | Description
Objects | Input ObjectCollection.
AttributeSetName | Input String that specifies the name of the attribute set to find or create.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods > AttributeManager.OpenAttributeSets Method


AttributeManager.PurgeAttributeSets Method

AttributeManager.PurgeAttributeSets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that finds and deletes the AttributeSets of the specified names whose parent cannot be resolved. If preview flag is true, then instead of deleting these AttributeSets, it returns their collection.

Visual Basic
Sub PurgeAttributeSets(ByRef AttributeSetName As [defaultvalue("*")] BSTR, ByRef Preview As [defaultvalue(0)] VARIANT_BOOL, ByRef PreviewResult As [optional] VARIANT)
Parameters
Parameters | Description
AttributeSetName | Optional input String value that specifies the name of the attribute set. An asterisk can be used as a wild card in the string to match partial strings. If this value is not input it will default to "*" which will match all attribute sets. The search is not case sensitive.
Preview | Optional input Boolean that specifies whether to return the collection of to preview prior to deleting them. A value of False (the default) means that the preview collection is not returned.
PreviewResult | Optional output Variant that contains the collection of to preview if Preview is set to True.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Methods > AttributeManager.PurgeAttributeSets Method


AttributeManager Properties

AttributeManager Properties
Summary

The properties of the AttributeManager class are listed here.

Properties
Name | Description
Parent | Property that returns either the Autodesk Inventor document or the ApprenticeServerDocument.
RevisionId | Gets the GUID that represents the last saved revision of this file. Works as a stamp of the contents of this file.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Properties


AttributeManager.Parent Property

AttributeManager.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns either the Autodesk Inventor document or the ApprenticeServerDocument.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Properties > AttributeManager.Parent Property


AttributeManager.RevisionId Property

AttributeManager.RevisionId Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the GUID that represents the last saved revision of this file. Works as a stamp of the contents of this file.

Visual Basic
Property RevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Properties > AttributeManager.RevisionId Property


AttributeManager.Type Property

AttributeManager.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AttributeManager Interface > AttributeManager Properties > AttributeManager.Type Property


AttributesEnumerator Interface

AttributesEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The AttributesEnumerator object provides access to a list of Attribute objects. See the article in the overviews section.

Class Hierarchy
Inventor::AttributesEnumerator
Visual Basic
Public Interface AttributesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AttributeManager.FindAttributes

AttributeSet.AddAttributes

You are here: Symbol Reference > Inventor Library > Objects > AttributesEnumerator Interface


AttributesEnumerator Methods

AttributesEnumerator Methods
Summary

The methods of the AttributesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > AttributesEnumerator Interface > AttributesEnumerator Methods


AttributesEnumerator.Item Method

AttributesEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Attribute*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > AttributesEnumerator Interface > AttributesEnumerator Methods > AttributesEnumerator.Item Method


AttributesEnumerator Properties

AttributesEnumerator Properties
Summary

The properties of the AttributesEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AttributesEnumerator Interface > AttributesEnumerator Properties


AttributesEnumerator.Count Property

AttributesEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AttributesEnumerator Interface > AttributesEnumerator Properties > AttributesEnumerator.Count Property


AttributesEnumerator.Type Property

AttributesEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AttributesEnumerator Interface > AttributesEnumerator Properties > AttributesEnumerator.Type Property


AttributeSet Interface

AttributeSet Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The AttributeSet object provides the ability to create new attributes and access existing attributes. See the article in the overviews section.

Class Hierarchy
Inventor::AttributeSet
Visual Basic
Public Interface AttributeSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AttributeSet.CopyTo

AttributeSets.Add

AttributeSets.AddTransient

AttributeSets.Item

AttributeSetsEnumerator.Item

See Also

Dynamic Attributes sample

Example

See AttributeSets for example "AttributeSets Object"

You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface


AttributeSet Methods

AttributeSet Methods
Summary

The methods of the AttributeSet class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new attribute in the attribute set. The created Attribute object is returned.
AddAttributes | Adds attributes to the AttributeSet using the arrays that specify the names, valuetypes and values of the desired attributes
CopyTo | Copies the Attribute Set to another object. Returns reference to the copied Attribute Set.
Delete | Method that deletes this AttributeSet.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Property that returns the specified Attribute object from the attribute set. This is the default property of the AttributeSet object.
NameIsUsed | Property that returns whether an existing attribute has the specific name or not. Returns True if the name is already being used.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods


AttributeSet.Add Method

AttributeSet.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new attribute in the attribute set. The created Attribute object is returned.

Visual Basic
Sub Add(AttributeName As String, ValueType As ValueTypeEnum, Value As VARIANT, Result As [out, retval] Attribute*)
Parameters
Parameters | Description
AttributeName | Input String value that specifies the name of the attribute. The name must be unique with respect to the other attributes within this attribute set. If it is not unique, a failure will occur. A failure will also occur if the name contains a space.
ValueType | Input value from that specifies the type of the attribute.
Value | Input Variant value that specifies the value of the attribute.
See Also

Dynamic Attributes sample

You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.Add Method


AttributeSet.AddAttributes Method

AttributeSet.AddAttributes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Adds attributes to the AttributeSet using the arrays that specify the names, valuetypes and values of the desired attributes

Visual Basic
Sub AddAttributes(AttributeNames As SAFEARRAY(BSTR), ValueTypes As SAFEARRAY(ValueTypeEnum), Values As SAFEARRAY(VARIANT), ReplaceExisting As VARIANT_BOOL, Result As [out, retval] AttributesEnumerator*)
Parameters
Parameters | Description
AttributeNames | String array that specifies the names of the attributes.
ValueTypes | Array of ValueTypeEnums that specify the types of the attributes.
Values | Array of Variant values that specify the values of the attributes.
ReplaceExisting | Indicates whether to replace any attributes that already exist.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.AddAttributes Method


AttributeSet.CopyTo Method

AttributeSet.CopyTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Copies the Attribute Set to another object. Returns reference to the copied Attribute Set.

Visual Basic
Sub CopyTo(Object As IDispatch, ByRef ReplaceExisting As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] AttributeSet*)
Parameters
Parameters | Description
Object | The object to copy to.
ReplaceExisting | Indictates whether to replaces an existing attribute set.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.CopyTo Method


AttributeSet.Delete Method

AttributeSet.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes this AttributeSet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.Delete Method


AttributeSet.GetReferenceKey Method

AttributeSet.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.GetReferenceKey Method


AttributeSet.Item Method

AttributeSet.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified Attribute object from the attribute set. This is the default property of the AttributeSet object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Attribute*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the attribute name. If an out-of-range index or a name of a nonexistent attribute is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.Item Method


AttributeSet.NameIsUsed Method

AttributeSet.NameIsUsed Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns whether an existing attribute has the specific name or not. Returns True if the name is already being used.

Visual Basic
Sub NameIsUsed(AttributeName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
AttributeName | Input String value containing the attribute name to check.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Methods > AttributeSet.NameIsUsed Method


AttributeSet Properties

AttributeSet Properties
Summary

The properties of the AttributeSet class are listed here.

Properties
Name | Description
Copy | Property that specifies whether the attribute set should be copied when the object it is associated with is copied or split. If True, the attribute set is copied.
CopyWithOwner | Property that specifies whether the attribute set should be copied with its owner when the object it is associated with is copied or split. If True, the attribute set is copied.
Count | Property that returns the number of attributes within this attribute set.
DataIO | Property that returns the object that allows you to write the contents of the AttributeSet as XML. The DataIO object returned supports the WriteDataToFile and WriteDataToStream methods with the format "XML." The AttributeSet name is used as a tag name in the XML data. Because of this, the name must be a valid XML tag name. This means it must begin with a letter and can contain the following characters '_', '-', '.'. Spaces are not allowed.
Name | Property that returns and sets the name of the attribute set.
Parent | Property that returns the Autodesk Inventor object being attributed with this AttributeSet. If this AttributeSet is being shared by more than one Autodesk Inventor object, then an ObjectCollection is returned that contains all of the Autodesk Inventor objects attributed with this AttributeSet.
Transient | Gets the Boolean flag indicating whether this Attribute set is transient. (Meaning it is available only during this session).
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties


AttributeSet.Copy Property

AttributeSet.Copy Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether the attribute set should be copied when the object it is associated with is copied or split. If True, the attribute set is copied.

Visual Basic
Property Copy() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.Copy Property


AttributeSet.CopyWithOwner Property

AttributeSet.CopyWithOwner Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that specifies whether the attribute set should be copied with its owner when the object it is associated with is copied or split. If True, the attribute set is copied.

Visual Basic
Property CopyWithOwner() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.CopyWithOwner Property


AttributeSet.Count Property

AttributeSet.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of attributes within this attribute set.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.Count Property


AttributeSet.DataIO Property

AttributeSet.DataIO Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object that allows you to write the contents of the AttributeSet as XML. The DataIO object returned supports the WriteDataToFile and WriteDataToStream methods with the format "XML." The AttributeSet name is used as a tag name in the XML data. Because of this, the name must be a valid XML tag name. This means it must begin with a letter and can contain the following characters '_', '-', '.'. Spaces are not allowed.

Visual Basic
Property DataIO() As DataIO**
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.DataIO Property


AttributeSet.Name Property

AttributeSet.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns and sets the name of the attribute set.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.Name Property


AttributeSet.Parent Property

AttributeSet.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Autodesk Inventor object being attributed with this AttributeSet. If this AttributeSet is being shared by more than one Autodesk Inventor object, then an ObjectCollection is returned that contains all of the Autodesk Inventor objects attributed with this AttributeSet.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.Parent Property


AttributeSet.Transient Property

AttributeSet.Transient Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the Boolean flag indicating whether this Attribute set is transient. (Meaning it is available only during this session).

Visual Basic
Property Transient() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.Transient Property


AttributeSet.Type Property

AttributeSet.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSet Interface > AttributeSet Properties > AttributeSet.Type Property


AttributeSets Interface

AttributeSets Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Provides access to the objects associated with a specific object and provides the ability to create additional sets on the object. See the article in the overviews section.

Class Hierarchy
Inventor::AttributeSets
Visual Basic
Public Interface AttributeSets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.AttributeSets

AssemblyConstraint.AttributeSets

AutoCADBlock.AttributeSets

AutoCADBlockDefinition.AttributeSets

Balloon.AttributeSets

BaselineDimensionSet.AttributeSets

BOMRow.AttributeSets

BorderDefinition.AttributeSets

BreakOperation.AttributeSets

BreakOutOperation.AttributeSets

Centerline.AttributeSets

Centermark.AttributeSets

ChainDimensionSet.AttributeSets

ClientBrowserNodeDefinitionObject.AttributeSets

ComponentDefinition.AttributeSets

ComponentOccurrence.AttributeSets

CustomTable.AttributeSets

DerivedParameterTable.AttributeSets

DesignViewRepresentation.AttributeSets

DimensionConstraint.AttributeSets

DimensionConstraint3D.AttributeSets

Document.AttributeSets

DraftAnalysis.AttributeSets

DrawingDimension.AttributeSets

DrawingNote.AttributeSets

DrawingView.AttributeSets

Edge.AttributeSets

EdgeLoop.AttributeSets

Face.AttributeSets

FaceShell.AttributeSets

FeatureControlFrame.AttributeSets

FeaturePatternElement.AttributeSets

GeometricConstraint.AttributeSets

GeometricConstraint3D.AttributeSets

HoleTable.AttributeSets

iAssemblyTableRow.AttributeSets

iMateDefinition.AttributeSets

iMateResult.AttributeSets

iPartTableRow.AttributeSets

LayoutConstraint.AttributeSets

Leader.AttributeSets

LeaderNode.AttributeSets

LevelOfDetailRepresentation.AttributeSets

LightingStyle.AttributeSets

Material.AttributeSets

OccurrencePattern.AttributeSets

OrdinateDimensionSet.AttributeSets

Parameter.AttributeSets

ParameterTable.AttributeSets

PartFeature.AttributeSets

PartsList.AttributeSets

Path.AttributeSets

PositionalRepresentation.AttributeSets

Profile.AttributeSets

Profile3D.AttributeSets

ProfileEntity.AttributeSets

ProfileEntity3D.AttributeSets

ProfilePath.AttributeSets

ProfilePath3D.AttributeSets

ProjectedCut.AttributeSets

ReferenceComponent.AttributeSets

ReferencedOLEFileDescriptor.AttributeSets

RenderStyle.AttributeSets

RevisionTable.AttributeSets

Sheet.AttributeSets

SheetFormat.AttributeSets

Sketch.AttributeSets

Sketch3D.AttributeSets

SketchBlock.AttributeSets

SketchedSymbol.AttributeSets

SketchedSymbolDefinition.AttributeSets

SketchEntity.AttributeSets

SketchEntity3D.AttributeSets

SketchFillRegion.AttributeSets

SketchImage.AttributeSets

SurfaceBody.AttributeSets

SurfaceTextureSymbol.AttributeSets

TextBox.AttributeSets

TitleBlockDefinition.AttributeSets

UserCoordinateSystem.AttributeSets

Vertex.AttributeSets

WorkAxis.AttributeSets

WorkPlane.AttributeSets

WorkPoint.AttributeSets

WorkSurface.AttributeSets

Example

"Dynamic Attributes Example "

This sample demonstrates the basic concept of dynamic attributes. For a selected entity, it creates an attribute set and an attribute. If the selected entity already has the attribute set, it allows you to edit the value of the attribute.

To use this sample select an entity and run the program.

Public Sub SetAndGetAttribute()
    ' Check to make sure a single item is in the select set.
    If ThisApplication.ActiveDocument.SelectSet.Count  1 Then
        MsgBox "A single entity must be selected."
        Exit Sub
    End If

    ' Get the item from the select set.
    Dim oSelectedObject As Object
    Set oSelectedObject = ThisApplication.ActiveDocument.SelectSet.Item(1)

    ' Make sure the selected object supports attributes.
    Dim oAttribSets As AttributeSets
    On Error Resume Next
    Set oAttribSets = oSelectedObject.AttributeSets
    If Err Then
        MsgBox "The selected object does not support attributes."
        Exit Sub
    End If
    On Error GoTo 0

    Dim sNewValue As String
    Dim oAttribSet As AttributeSet
    Dim oAttrib As Inventor.Attribute
    ' Check to see if the object already has an attribute set named "AttribTest".
    If oAttribSets.NameIsUsed("AttribTest") Then
        ' Get a reference to the existing attribute set.
        Set oAttribSet = oAttribSets.Item("AttribTest")

        ' Get a reference to the existing attribute.
        Set oAttrib = oAttribSet.Item("Attrib")

        ' Display the current value and allow the user to specify a new value.
        sNewValue = InputBox("Edit existing value", "Modify Existing Attribute", _
                                oAttrib.Value)

        ' If the value's different, change the value of the attribute.
        If sNewValue <> "" And sNewValue <> oAttrib.Value Then
            oAttrib.Value = sNewValue
        End If
    Else
        ' Get the value to assign to the attribute.
        sNewValue = InputBox("Specify attribute value", "Create Attribute")

        ' If a value was entered, create a new attribute set and attribute.
        If sNewValue <> "" Then
            ' Create a new attribute set with the name "AttribTest".
            Set oAttribSet = oAttribSets.Add("AttribTest")

            ' Create a new attribute named "Attrib" and assign the value.
            Set oAttrib = oAttribSet.Add("Attrib", kStringType, sNewValue)
        End If
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface


AttributeSets Methods

AttributeSets Methods
Summary

The methods of the AttributeSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new for the object the AttributeSets collection was obtained from. The created AttributeSet object is returned.
AddTransient | Adds a transient into this collection. This set is transient as it is available only during this session.
Item | Property that returns the specified object from the collection. This is the default property of the AttributeSets collection object.
NameIsUsed | Property that returns whether an existing attribute set has the specified name or not. Multiple AttributeSets with the same name are not allowed within this collection. Returns True if the name is already being used.
ParentAvailable | Method that returns whether the parent can be found.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Methods


AttributeSets.Add Method

AttributeSets.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new for the object the AttributeSets collection was obtained from. The created AttributeSet object is returned.

Visual Basic
Sub Add(AttributeSetName As String, ByRef CopyWithOwner As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] AttributeSet*)
Parameters
Parameters | Description
AttributeSetName | Input String value that specifies the name of the attribute set. The name must be unique with respect to the other attribute sets attached to this object. If it is not unique, an error will occur.
CopyWithOwner | Property that specifies whether the attribute set should be copied with its owner when the object it is associated with is copied or split. If True, the attribute set is copied.
See Also

Dynamic Attributes sample

You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Methods > AttributeSets.Add Method


AttributeSets.AddTransient Method

AttributeSets.AddTransient Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Adds a transient into this collection. This set is transient as it is available only during this session.

Visual Basic
Sub AddTransient(AttributeSetName As String, ByRef CopyWithOwner As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] AttributeSet*)
Parameters
Parameters | Description
AttributeSetName | Input String value that specifies the name of the attribute set. The name must be unique with respect to the other attribute sets attached to this object. If it is not unique, an error will occur.
CopyWithOwner | Property that specifies whether the attribute set should be copied with its owner when the object it is associated with is copied or split. If True, the attribute set is copied.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Methods > AttributeSets.AddTransient Method


AttributeSets.Item Method

AttributeSets.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection. This is the default property of the AttributeSets collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] AttributeSet*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the attribute set name. If an out-of-range index or a name of a nonexistent attribute set is provided, an error occurs.
See Also

Dynamic Attributes sample

You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Methods > AttributeSets.Item Method


AttributeSets.NameIsUsed Method

AttributeSets.NameIsUsed Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns whether an existing attribute set has the specified name or not. Multiple AttributeSets with the same name are not allowed within this collection. Returns True if the name is already being used.

Visual Basic
Sub NameIsUsed(AttributeSetName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
AttributeSetName | Input String value containing the attribute set name to check.
See Also

Dynamic Attributes sample

You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Methods > AttributeSets.NameIsUsed Method


AttributeSets.ParentAvailable Method

AttributeSets.ParentAvailable Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the parent can be found.

Visual Basic
Sub ParentAvailable(ByRef Parent As IDispatch*, ByRef Context As [optional] VARIANT, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters
Description
Parent
Object that returns the parent. Returns Nothing if the method returns False.
Context
Optional output NameValueMap object. Possible values:

  • ParentSuppressed As Boolean. Indicates whether the parent is in a

suppressed occurrence.

  • ParentMissing As Boolean. Indicates whether the parent is in a missing

(unresolved) occurrence.

  • ParentDeleted As Boolean. Indicates whether the parent is in a deleted

occurrence.

  • KnownOccurrencePath As ComponentOccurrence. Contains the known occurrence

path in which the parent lives.

You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Methods > AttributeSets.ParentAvailable Method


AttributeSets Properties

AttributeSets Properties
Summary

The properties of the AttributeSets class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
DataIO | Property that returns the object that allows you to write the contents of all of the AttributeSets attached to object as XML. The DataIO object returned supports the WriteDataToFile and WriteDataToStream methods with the format "XML." The AttributeSet names are used as the tag names in the XML data. Because of this, the names must be valid XML tag names. This means they must begin with a letter and can contain the following characters '_', '-', '.'. Spaces are not allowed.
Parent | Property that returns the object this attribute set is attached to.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Properties


AttributeSets.Count Property

AttributeSets.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Properties > AttributeSets.Count Property


AttributeSets.DataIO Property

AttributeSets.DataIO Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object that allows you to write the contents of all of the AttributeSets attached to object as XML. The DataIO object returned supports the WriteDataToFile and WriteDataToStream methods with the format "XML." The AttributeSet names are used as the tag names in the XML data. Because of this, the names must be valid XML tag names. This means they must begin with a letter and can contain the following characters '_', '-', '.'. Spaces are not allowed.

Visual Basic
Property DataIO() As DataIO**
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Properties > AttributeSets.DataIO Property


AttributeSets.Parent Property

AttributeSets.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object this attribute set is attached to.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Properties > AttributeSets.Parent Property


AttributeSets.Type Property

AttributeSets.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSets Interface > AttributeSets Properties > AttributeSets.Type Property


AttributeSetsEnumerator Interface

AttributeSetsEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The AttributeSetsEnumerator object provides access to a list of objects. See the article in the overviews section.

Class Hierarchy
Inventor::AttributeSetsEnumerator
Visual Basic
Public Interface AttributeSetsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AttributeManager.FindAttributeSets

AttributeManager.OpenAttributeSets

You are here: Symbol Reference > Inventor Library > Objects > AttributeSetsEnumerator Interface


AttributeSetsEnumerator Methods

AttributeSetsEnumerator Methods
Summary

The methods of the AttributeSetsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSetsEnumerator Interface > AttributeSetsEnumerator Methods


AttributeSetsEnumerator.Item Method

AttributeSetsEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] AttributeSet*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSetsEnumerator Interface > AttributeSetsEnumerator Methods > AttributeSetsEnumerator.Item Method


AttributeSetsEnumerator Properties

AttributeSetsEnumerator Properties
Summary

The properties of the AttributeSetsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AttributeSetsEnumerator Interface > AttributeSetsEnumerator Properties


AttributeSetsEnumerator.Count Property

AttributeSetsEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSetsEnumerator Interface > AttributeSetsEnumerator Properties > AttributeSetsEnumerator.Count Property


AttributeSetsEnumerator.Type Property

AttributeSetsEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AttributeSetsEnumerator Interface > AttributeSetsEnumerator Properties > AttributeSetsEnumerator.Type Property


AutoCADBlock Interface

AutoCADBlock Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The AutoCADBlock object represents an instance of an AutoCAD block definition on a sheet.

Class Hierarchy
Inventor::AutoCADBlock
Visual Basic
Public Interface AutoCADBlock
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AutoCADBlocks.Add

AutoCADBlocks.Item

See Also

AutoCAD block insertion sample

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface


AutoCADBlock Methods

AutoCADBlock Methods
Summary

The methods of the AutoCADBlock class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the AutoCAD block from the sheet.
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
GetPromptTextValues | Method that returns the prompt strings and values (attributes) of the block.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetCustomLineType | Method that sets a custom line type to the symbol from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
SetPromptTextValues | Method that sets the prompt string values (attributes) of the block.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods


AutoCADBlock.Delete Method

AutoCADBlock.Delete Method
Summary

Method that deletes the AutoCAD block from the sheet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods > AutoCADBlock.Delete Method


AutoCADBlock.GetCustomLineType Method

AutoCADBlock.GetCustomLineType Method
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | String that returns the name of the line type.
LineTypeDescription | String that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods > AutoCADBlock.GetCustomLineType Method


AutoCADBlock.GetPromptTextValues Method

AutoCADBlock.GetPromptTextValues Method
Summary

Method that returns the prompt strings and values (attributes) of the block.

Visual Basic
Sub GetPromptTextValues(ByRef PromptTags As VARIANT, ByRef Values As VARIANT)
Parameters
Parameters | Description
PromptTags | String array that returns the prompt tag strings.
Values | String array that returns the corresponding values of the prompt fields.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods > AutoCADBlock.GetPromptTextValues Method


AutoCADBlock.GetReferenceKey Method

AutoCADBlock.GetReferenceKey Method
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods > AutoCADBlock.GetReferenceKey Method


AutoCADBlock.SetCustomLineType Method

AutoCADBlock.SetCustomLineType Method
Summary

Method that sets a custom line type to the symbol from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Specifies the name of the line type.
ReplaceExisting | Specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods > AutoCADBlock.SetCustomLineType Method


AutoCADBlock.SetPromptTextValues Method

AutoCADBlock.SetPromptTextValues Method
Summary

Method that sets the prompt string values (attributes) of the block.

Visual Basic
Sub SetPromptTextValues(PromptTags As VARIANT, Values As VARIANT)
Parameters
Parameters | Description
PromptTags | String array that specifies the unique prompt tag strings.
Values | String array that specifies the corresponding values of the prompt fields.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Methods > AutoCADBlock.SetPromptTextValues Method


AutoCADBlock Properties

AutoCADBlock Properties
Summary

The properties of the AutoCADBlock class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Color | Property that gets and sets the color for the block. Setting the property to Nothing restores the block to the color defined by the layer on which this block resides.
Definition | Property that gets and sets the AutoCADBlockDefinition object referenced by the block.
Layer | Property that gets and sets the layer associated with this object.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent Sheet object.
Position | Property that gets and sets the origin position of the block on the sheet.
Rotation | Property that gets and sets the rotation angle of the block in radians.
Scale | Property that gets and sets the scale of the block.
Static | Property that gets and sets whether to show the scale and rotation grip points on the block. If True, the grip points are disabled.
Transformation | Property that provides the transform that is applied to display the associated AutoCAD block definition in the correct location on the sheet. The matrix defines the sheet to block transform.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties


AutoCADBlock.Application Property

AutoCADBlock.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Application Property


AutoCADBlock.AttributeSets Property

AutoCADBlock.AttributeSets Property
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.AttributeSets Property


AutoCADBlock.Color Property

AutoCADBlock.Color Property
Summary

Property that gets and sets the color for the block. Setting the property to Nothing restores the block to the color defined by the layer on which this block resides.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Color Property


AutoCADBlock.Definition Property

AutoCADBlock.Definition Property
Summary

Property that gets and sets the AutoCADBlockDefinition object referenced by the block.

Visual Basic
Property Definition() As AutoCADBlockDefinition*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Definition Property


AutoCADBlock.Layer Property

AutoCADBlock.Layer Property
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Layer Property


AutoCADBlock.LineType Property

AutoCADBlock.LineType Property
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.LineType Property


AutoCADBlock.LineWeight Property

AutoCADBlock.LineWeight Property
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.LineWeight Property


AutoCADBlock.Name Property

AutoCADBlock.Name Property
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Name Property


AutoCADBlock.Parent Property

AutoCADBlock.Parent Property
Summary

Property that returns the parent Sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Parent Property


AutoCADBlock.Position Property

AutoCADBlock.Position Property
Summary

Property that gets and sets the origin position of the block on the sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Position Property


AutoCADBlock.Rotation Property

AutoCADBlock.Rotation Property
Summary

Property that gets and sets the rotation angle of the block in radians.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Rotation Property


AutoCADBlock.Scale Property

AutoCADBlock.Scale Property
Summary

Property that gets and sets the scale of the block.

Visual Basic
Property Scale() As double
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Scale Property


AutoCADBlock.Static Property

AutoCADBlock.Static Property
Summary

Property that gets and sets whether to show the scale and rotation grip points on the block. If True, the grip points are disabled.

Visual Basic
Property Static() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Static Property


AutoCADBlock.Transformation Property

AutoCADBlock.Transformation Property
Summary

Property that provides the transform that is applied to display the associated AutoCAD block definition in the correct location on the sheet. The matrix defines the sheet to block transform.

Visual Basic
Property Transformation() As Matrix2d**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Transformation Property


AutoCADBlock.Type Property

AutoCADBlock.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlock Interface > AutoCADBlock Properties > AutoCADBlock.Type Property


AutoCADBlockDefinition Interface

AutoCADBlockDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The AutoCADBlockDefinition object represents an AutoCAD block definition.

Class Hierarchy
Inventor::AutoCADBlockDefinition
Visual Basic
Public Interface AutoCADBlockDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AutoCADBlock.Definition

AutoCADBlockDefinition.CopyTo

AutoCADBlockDefinitions.Item

AutoCADBlockDefinitionsEnumerator.Item

See Also

AutoCAD block insertion sample

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface


AutoCADBlockDefinition Methods

AutoCADBlockDefinition Methods
Summary

The methods of the AutoCADBlockDefinition class are listed here.

Methods
Methods
Name | Description
CopyTo | Method that copies the definition to the target drawing document.
Delete | Method that deletes the AutoCADBlockDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.
GetPromptTags | Method that returns the tags and their corresponding prompts for field text (attributes) within the block definition.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Methods


AutoCADBlockDefinition.CopyTo Method

AutoCADBlockDefinition.CopyTo Method
Summary

Method that copies the definition to the target drawing document.

Visual Basic
Sub CopyTo(TargetDocument As DrawingDocument, ByRef ReplaceExisting As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] AutoCADBlockDefinition*)
Parameters
Parameters | Description
TargetDocument | Input DrawingDocument object that specifies the document to copy the definition into. The target document must be an Inventor DWG drawing (not an IDW).
ReplaceExisting | Optional input Boolean that specifies whether to replace or create a new definition with a different name if a definition of the same name exists in the target document. If not specified, the argument
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Methods > AutoCADBlockDefinition.CopyTo Method


AutoCADBlockDefinition.Delete Method

AutoCADBlockDefinition.Delete Method
Summary

Method that deletes the AutoCADBlockDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Methods > AutoCADBlockDefinition.Delete Method


AutoCADBlockDefinition.GetPromptTags Method

AutoCADBlockDefinition.GetPromptTags Method
Summary

Method that returns the tags and their corresponding prompts for field text (attributes) within the block definition.

Visual Basic
Sub GetPromptTags(ByRef Tags As VARIANT, ByRef Prompts As [optional] VARIANT)
Parameters
Parameters | Description
Tags | Output array of Strings that returns the unique tag strings indicating field texts in the block definition.
Prompts | Optional array of Strings that returns the corresponding prompt strings for the tags.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Methods > AutoCADBlockDefinition.GetPromptTags Method


AutoCADBlockDefinition.GetReferenceKey Method

AutoCADBlockDefinition.GetReferenceKey Method
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Methods > AutoCADBlockDefinition.GetReferenceKey Method


AutoCADBlockDefinition Properties

AutoCADBlockDefinition Properties
Summary

The properties of the AutoCADBlockDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
IsReferenced | Property that specifies if the definition is being referenced or not. A definition is referenced when an instance of the definition has been placed on a sheet. A referenced definition cannot be deleted.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent DrawingDocument object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties


AutoCADBlockDefinition.Application Property

AutoCADBlockDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties > AutoCADBlockDefinition.Application Property


AutoCADBlockDefinition.AttributeSets Property

AutoCADBlockDefinition.AttributeSets Property
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties > AutoCADBlockDefinition.AttributeSets Property


AutoCADBlockDefinition.IsReferenced Property

AutoCADBlockDefinition.IsReferenced Property
Summary

Property that specifies if the definition is being referenced or not. A definition is referenced when an instance of the definition has been placed on a sheet. A referenced definition cannot be deleted.

Visual Basic
Property IsReferenced() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties > AutoCADBlockDefinition.IsReferenced Property


AutoCADBlockDefinition.Name Property

AutoCADBlockDefinition.Name Property
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties > AutoCADBlockDefinition.Name Property


AutoCADBlockDefinition.Parent Property

AutoCADBlockDefinition.Parent Property
Summary

Property returning the parent DrawingDocument object.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties > AutoCADBlockDefinition.Parent Property


AutoCADBlockDefinition.Type Property

AutoCADBlockDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinition Interface > AutoCADBlockDefinition Properties > AutoCADBlockDefinition.Type Property


AutoCADBlockDefinitions Interface

AutoCADBlockDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The AutoCADBlockDefinitions collection object provides access to all the existing AutoCADBlockDefinition objects in a (DWG) drawing document and provides methods to import additional definitions.

Class Hierarchy
Inventor::AutoCADBlockDefinitions
Visual Basic
Public Interface AutoCADBlockDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.AutoCADBlockDefinitions

See Also

AutoCAD block insertion sample

AutoCAD block definitions import sample

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface


AutoCADBlockDefinitions Methods

AutoCADBlockDefinitions Methods
Summary

The methods of the AutoCADBlockDefinitions class are listed here.

Methods
Methods
Name | Description
AddFromFile | Method that imports AutoCAD block definitions from an AutoCAD or an Inventor DWG file.
Item | Property that returns the specified AutoCADBlockDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Methods


AutoCADBlockDefinitions.AddFromFile Method

AutoCADBlockDefinitions.AddFromFile Method
Summary

Method that imports AutoCAD block definitions from an AutoCAD or an Inventor DWG file.

Visual Basic
Sub AddFromFile(DWGFullFileName As String, ByRef DefinitionNames As [optional] VARIANT, ByRef ReplaceExisting As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] AutoCADBlockDefinitionsEnumerator*)
Parameters
Parameters | Description
DWGFullFileName | Input String that specifies the full file name of the AutoCAD or Inventor DWG file from which to import the definitions.
DefinitionNames | Optional input array of strings that specifies the names of the definitions to import from the source file. If not specified, all AutoCAD block definitions are imported.
ReplaceExisting | Optional input Boolean that specifies whether to replace or create a new definition with a different name if a definition of the same name exists in the target document. If not specified, the argument defaults to False indicating that a new definition will be created.
Example

AutoCAD block definitions import example.

This sample demonstrates importing AutoCAD block definitions from an external dwg file.

Sub ImportAutoCADBlockDefinitionsFromFile()

    ' Set a reference to the drawing document.
    ' This assumes an Inventor dwg drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Create an array of names of the definitions to import
    Dim oDefNames(1) As String
    oDefNames(0) = "DatumFilled45"
    oDefNames(1) = "Borders Default Border"

    ' Import definitions from an external dwg file
    ' Only the specified definitions will be imported. If you want all definitions
    ' to be imported, you can leave the 2nd argument as unspecified.
    Dim oBlockDefs As AutoCADBlockDefinitionsEnumerator
    Set oBlockDefs = oDrawDoc.AutoCADBlockDefinitions.AddFromFile("C:\temp\acad.dwg", oDefNames)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Methods > AutoCADBlockDefinitions.AddFromFile Method


AutoCADBlockDefinitions.Item Method

AutoCADBlockDefinitions.Item Method
Summary

Property that returns the specified AutoCADBlockDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] AutoCADBlockDefinition*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the AutoCADBlockDefinition to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the AutoCADBlockDefinition name. If an out of range index or a name of a non-existent AutoCADBlockDefinition is provided, an error will occur.
See Also

AutoCAD block insertion sample

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Methods > AutoCADBlockDefinitions.Item Method


AutoCADBlockDefinitions Properties

AutoCADBlockDefinitions Properties
Summary

The properties of the AutoCADBlockDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Properties


AutoCADBlockDefinitions.Application Property

AutoCADBlockDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Properties > AutoCADBlockDefinitions.Application Property


AutoCADBlockDefinitions.Count Property

AutoCADBlockDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Properties > AutoCADBlockDefinitions.Count Property


AutoCADBlockDefinitions.Type Property

AutoCADBlockDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitions Interface > AutoCADBlockDefinitions Properties > AutoCADBlockDefinitions.Type Property


AutoCADBlockDefinitionsEnumerator Interface

AutoCADBlockDefinitionsEnumerator Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The AutoCADBlockDefinitionsEnumerator object enumerates AutoCADBlockDefinition objects

Class Hierarchy
Inventor::AutoCADBlockDefinitionsEnumerator
Visual Basic
Public Interface AutoCADBlockDefinitionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AutoCADBlockDefinitions.AddFromFile

SheetFormat.ReferencedAutoCADBlockDefinitions

See Also

AutoCAD block definitions import sample

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface


AutoCADBlockDefinitionsEnumerator Methods

AutoCADBlockDefinitionsEnumerator Methods
Summary

The methods of the AutoCADBlockDefinitionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified AutoCADBlockDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface > AutoCADBlockDefinitionsEnumerator Methods


AutoCADBlockDefinitionsEnumerator.Item Method

AutoCADBlockDefinitionsEnumerator.Item Method
Summary

Property that returns the specified AutoCADBlockDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] AutoCADBlockDefinition*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the AutoCADBlockDefinition to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the AutoCADBlockDefinition name. If an out of range index or a name of a non-existent AutoCADBlockDefinition is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface > AutoCADBlockDefinitionsEnumerator Methods > AutoCADBlockDefinitionsEnumerator.Item Method


AutoCADBlockDefinitionsEnumerator Properties

AutoCADBlockDefinitionsEnumerator Properties
Summary

The properties of the AutoCADBlockDefinitionsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface > AutoCADBlockDefinitionsEnumerator Properties


AutoCADBlockDefinitionsEnumerator.Application Property

AutoCADBlockDefinitionsEnumerator.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface > AutoCADBlockDefinitionsEnumerator Properties > AutoCADBlockDefinitionsEnumerator.Application Property


AutoCADBlockDefinitionsEnumerator.Count Property

AutoCADBlockDefinitionsEnumerator.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface > AutoCADBlockDefinitionsEnumerator Properties > AutoCADBlockDefinitionsEnumerator.Count Property


AutoCADBlockDefinitionsEnumerator.Type Property

AutoCADBlockDefinitionsEnumerator.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlockDefinitionsEnumerator Interface > AutoCADBlockDefinitionsEnumerator Properties > AutoCADBlockDefinitionsEnumerator.Type Property


AutoCADBlocks Interface

AutoCADBlocks Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The AutoCADBlocks collection object provides access to the instances of the blocks on a specific sheet. It also provides the ability to place blocks onto a sheet.

Class Hierarchy
Inventor::AutoCADBlocks
Visual Basic
Public Interface AutoCADBlocks
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.AutoCADBlocks

See Also

AutoCAD block insertion sample

You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface


AutoCADBlocks Methods

AutoCADBlocks Methods
Summary

The methods of the AutoCADBlocks class are listed here.

Methods
Methods
Name | Description
Add | Method that places an AutoCAD block onto the sheet.
Item | Property that returns the specified AutoCADBlock object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Methods


AutoCADBlocks.Add Method

AutoCADBlocks.Add Method
Summary

Method that places an AutoCAD block onto the sheet.

Visual Basic
Sub Add(Definition As AutoCADBlockDefinition, Position As Point2d, ByRef Rotation As [defaultvalue(0.0)] double, ByRef Scale As [defaultvalue(1.0)] double, ByRef PromptStrings As [optional] VARIANT, ByRef Static As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] AutoCADBlock*)
Parameters
Parameters | Description
Definition | AutoCADBlockDefinition object to use for placing the block.
Position | Point2d that specifies the location on the sheet to place the block instance.
Rotation | Optional input double that specifies the rotation angle in radians.
Scale | Optional input double that specifies the scale.
PromptStrings | Optional input array of strings to use as input for prompted text fields that my be present in the block definition.
Static | Optional input Boolean that indicates whether to show the scale and rotation grip points on the block. If True, the grip points are disabled. If not specified, a value of False is used.
Example

AutoCAD block insertion example.

Open an Inventor dwg file and run the following macro.

Public Sub InsertAutoCADBlockOnSheet()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Obtain a reference to the desired AutoCAD block definition.
    Dim oBlockDef As AutoCADBlockDefinition
    Set oBlockDef = oDrawDoc.AutoCADBlockDefinitions.Item("Filled-1")

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' If the definition contains prompted string inputs...
    'Dim sPromptStrings(1) As String
    'sPromptStrings(0) = "String 1"
    'sPromptStrings(1) = "String 2"

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Add an instance of the block definition to the sheet.
    ' Rotate the instance by 45 degrees and scale by .75 when adding.
    ' The symbol will be inserted at (10,10) on the sheet.
    Dim oAutoCADBlock As AutoCADBlock
    Set oAutoCADBlock = oSheet.AutoCADBlocks.Add(oBlockDef, oTG.CreatePoint2d(10, 10), (3.14159 / 4), 0.75)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Methods > AutoCADBlocks.Add Method


AutoCADBlocks.Item Method

AutoCADBlocks.Item Method
Summary

Property that returns the specified AutoCADBlock object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] AutoCADBlock*)
Parameters
Parameters | Description
Index | Specifies the AutoCADBlock to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the AutoCADBlock name. If an out of range index or a name of a non-existent AutoCADBlock is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Methods > AutoCADBlocks.Item Method


AutoCADBlocks Properties

AutoCADBlocks Properties
Summary

The properties of the AutoCADBlocks class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Properties


AutoCADBlocks.Application Property

AutoCADBlocks.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Properties > AutoCADBlocks.Application Property


AutoCADBlocks.Count Property

AutoCADBlocks.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Properties > AutoCADBlocks.Count Property


AutoCADBlocks.Type Property

AutoCADBlocks.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AutoCADBlocks Interface > AutoCADBlocks Properties > AutoCADBlocks.Type Property


AutomatedCenterlineSettings Interface

AutomatedCenterlineSettings Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The AutomatedCenterlineSettings object provides access to all of the settings that are used when automatically generating centerlines and center marks.

Class Hierarchy
Inventor::AutomatedCenterlineSettings
Visual Basic
Public Interface AutomatedCenterlineSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingSettings.AutomatedCenterlineSettings

You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface


AutomatedCenterlineSettings Properties

AutomatedCenterlineSettings Properties
Summary

The properties of the AutomatedCenterlineSettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ApplyToBends | Property that indicates if centerlines and center marks should be placed on sheet metal Bend features. This value should be ignored when using this object with a sketch.
ApplyToCircularPatterns | Property that indicates if the centerlines and center marks should be placed on circular pattern features. This value should be ignored when using this object with a sketch.
ApplyToCylinders | Property that indicates if centerlines and center marks should be placed on cylindrical faces. This value should be ignored when using this object with a sketch.
ApplyToFillets | Property that indicates if centerlines and center marks should be placed on Fillet features. This value should be ignored when using this object with a sketch.
ApplyToHoles | Property that indicates if centerlines and center marks should be placed on Hole features. This value should be ignored when using this object with a sketch.
ApplyToPunches | Property that indicates if centerlines and center marks should be placed on sheet metal Punch features. This value should be ignored when using this object with a sketch.
ApplyToRectangularPatterns | Property that indicates if the centerlines and center marks should be placed on rectangular pattern features. This value should be ignored when using this object with a sketch.
ApplyToRevolutions | Property that indicates if centerlines and center marks should be placed on Revolved features. This value should be ignored when using this object with a sketch.
ApplyToSketches | Property that indicates if centerlines and center marks should be placed on circular and elliptical geometry within sketches. This value should be ignored when using this object with a sketch.
ApplyToWorkFeatures | Property that indicates if centerlines and center marks should be placed on visible work features. This value should be ignored when using this object with a sketch.
ArcAngleThreshold | Property that specifies the minimum angle for creating a center mark or centerline on circles, arcs, or ellipses. The units for this value is Radians.
CircularEdgeMaximumThreshold | Property that specifies the maximum radius of a circular edge that centerlines and center marks should be placed on. The units for this value is Centimeters.
CircularEdgeMinimumThreshold | Property that specifies the minimum radius of a circular edge that centerlines and center marks should be placed on. The units for this value is Centimeters.
FilletRadiusMaximumThreshold | Property that specifies the maximum radius of a fillet that centerlines and center marks should be placed on. The units for this value is Centimeters.
FilletRadiusMinimumThreshold | Property that specifies the minimum radius of a fillet that centerlines and center marks should be placed on. The units for this value is Centimeters.
ProjectionNormalAxis | Property that indicates if centerlines should be created where the entity axis is normal to the drawing view plane. This value should be ignored when using this object with a sketch.
ProjectionParallelAxis | Property that indicates if centerlines should be created where the entity axis is parallel to the drawing view plane. This value should be ignored when using this object with a sketch.
RadiusThresholdPrecision | Property that specifies the number of decimal accuracy to use for comparing the size of fillets, arcs and circular features to the threshold.
Type | Property returning kCentermarkStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties


AutomatedCenterlineSettings.Application Property

AutomatedCenterlineSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.Application Property


AutomatedCenterlineSettings.ApplyToBends Property

AutomatedCenterlineSettings.ApplyToBends Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on sheet metal Bend features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToBends() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToBends Property


AutomatedCenterlineSettings.ApplyToCircularPatterns Property

AutomatedCenterlineSettings.ApplyToCircularPatterns Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if the centerlines and center marks should be placed on circular pattern features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToCircularPatterns() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToCircularPatterns Property


AutomatedCenterlineSettings.ApplyToCylinders Property

AutomatedCenterlineSettings.ApplyToCylinders Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on cylindrical faces. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToCylinders() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToCylinders Property


AutomatedCenterlineSettings.ApplyToFillets Property

AutomatedCenterlineSettings.ApplyToFillets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on Fillet features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToFillets() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToFillets Property


AutomatedCenterlineSettings.ApplyToHoles Property

AutomatedCenterlineSettings.ApplyToHoles Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on Hole features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToHoles() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToHoles Property


AutomatedCenterlineSettings.ApplyToPunches Property

AutomatedCenterlineSettings.ApplyToPunches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on sheet metal Punch features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToPunches() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToPunches Property


AutomatedCenterlineSettings.ApplyToRectangularPatterns Property

AutomatedCenterlineSettings.ApplyToRectangularPatterns Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if the centerlines and center marks should be placed on rectangular pattern features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToRectangularPatterns() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToRectangularPatterns Property


AutomatedCenterlineSettings.ApplyToRevolutions Property

AutomatedCenterlineSettings.ApplyToRevolutions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on Revolved features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToRevolutions() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToRevolutions Property


AutomatedCenterlineSettings.ApplyToSketches Property

AutomatedCenterlineSettings.ApplyToSketches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on circular and elliptical geometry within sketches. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToSketches() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToSketches Property


AutomatedCenterlineSettings.ApplyToWorkFeatures Property

AutomatedCenterlineSettings.ApplyToWorkFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines and center marks should be placed on visible work features. This value should be ignored when using this object with a sketch.

Visual Basic
Property ApplyToWorkFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ApplyToWorkFeatures Property


AutomatedCenterlineSettings.ArcAngleThreshold Property

AutomatedCenterlineSettings.ArcAngleThreshold Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the minimum angle for creating a center mark or centerline on circles, arcs, or ellipses. The units for this value is Radians.

Visual Basic
Property ArcAngleThreshold() As double
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ArcAngleThreshold Property


AutomatedCenterlineSettings.CircularEdgeMaximumThreshold Property

AutomatedCenterlineSettings.CircularEdgeMaximumThreshold Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the maximum radius of a circular edge that centerlines and center marks should be placed on. The units for this value is Centimeters.

Visual Basic
Property CircularEdgeMaximumThreshold() As double
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.CircularEdgeMaximumThreshold Property


AutomatedCenterlineSettings.CircularEdgeMinimumThreshold Property

AutomatedCenterlineSettings.CircularEdgeMinimumThreshold Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the minimum radius of a circular edge that centerlines and center marks should be placed on. The units for this value is Centimeters.

Visual Basic
Property CircularEdgeMinimumThreshold() As double
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.CircularEdgeMinimumThreshold Property


AutomatedCenterlineSettings.FilletRadiusMaximumThreshold Property

AutomatedCenterlineSettings.FilletRadiusMaximumThreshold Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the maximum radius of a fillet that centerlines and center marks should be placed on. The units for this value is Centimeters.

Visual Basic
Property FilletRadiusMaximumThreshold() As double
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.FilletRadiusMaximumThreshold Property


AutomatedCenterlineSettings.FilletRadiusMinimumThreshold Property

AutomatedCenterlineSettings.FilletRadiusMinimumThreshold Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the minimum radius of a fillet that centerlines and center marks should be placed on. The units for this value is Centimeters.

Visual Basic
Property FilletRadiusMinimumThreshold() As double
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.FilletRadiusMinimumThreshold Property


AutomatedCenterlineSettings.ProjectionNormalAxis Property

AutomatedCenterlineSettings.ProjectionNormalAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines should be created where the entity axis is normal to the drawing view plane. This value should be ignored when using this object with a sketch.

Visual Basic
Property ProjectionNormalAxis() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ProjectionNormalAxis Property


AutomatedCenterlineSettings.ProjectionParallelAxis Property

AutomatedCenterlineSettings.ProjectionParallelAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if centerlines should be created where the entity axis is parallel to the drawing view plane. This value should be ignored when using this object with a sketch.

Visual Basic
Property ProjectionParallelAxis() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.ProjectionParallelAxis Property


AutomatedCenterlineSettings.RadiusThresholdPrecision Property

AutomatedCenterlineSettings.RadiusThresholdPrecision Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the number of decimal accuracy to use for comparing the size of fillets, arcs and circular features to the threshold.

Visual Basic
Property RadiusThresholdPrecision() As long
Remarks

Valid values are 0 to 8 where 0 indicates a full centimeter accuracy and 3 would indicate 0.001 centimeter accuracy. Values outside of this range are adjusted to their closest valid value.

You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.RadiusThresholdPrecision Property


AutomatedCenterlineSettings.Type Property

AutomatedCenterlineSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kCentermarkStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > AutomatedCenterlineSettings Interface > AutomatedCenterlineSettings Properties > AutomatedCenterlineSettings.Type Property


Balloon Interface

Balloon Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Balloon object provides the ability to access existing balloons.

Class Hierarchy
Inventor::Balloon
Visual Basic
Public Interface Balloon
Inherits IDispatch
Remarks

A balloon is an annotation tag, usually used with a parts list where the number in the balloon corresponds with the number of the part in the parts list. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

Balloons.Add

Balloons.Item

BalloonValueSet.Parent

See Also

Find component referenced by balloon sample

Balloons - edit sample

Example

See Balloons for example "Editing balloons"

You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface


Balloon Methods

Balloon Methods
Summary

The methods of the Balloon class are listed here.

Methods
Methods
Name | Description
Delete | Method to delete this Balloon.
GetBalloonType | Method that gets the balloon type.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SaveItemOverridesToBOM | Method that saves any overrides to the item values in the balloon to the model BOM. Only the overrides applies to the BallonValueSet.Value property are saved. The value of the OverrideValue property is ignored.
SetBalloonType | Method that sets the balloon type.
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Methods


Balloon.Delete Method

Balloon.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method to delete this Balloon.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Methods > Balloon.Delete Method


Balloon.GetBalloonType Method

Balloon.GetBalloonType Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that gets the balloon type.

Visual Basic
Sub GetBalloonType(ByRef BalloonType As BalloonTypeEnum, ByRef BalloonTypeData As VARIANT)
Parameters
Parameters | Description
BalloonType | Gets the constant that indicates the balloon type. Valid types are kCircularWithOneEntryBalloonType, kCircularWithTwoEntriesBalloonType, kHexagonBalloonType, kLinearBalloonType, kNoneBalloonType and kSketchedSymbolBalloonType.
BalloonTypeData | Returns the data associated with certain balloon types. If the balloon type is kSketchedSymbolBalloonType, this returns a SketchedSymbol object. Else, this returns Nothing.
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Methods > Balloon.GetBalloonType Method


Balloon.GetReferenceKey Method

Balloon.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Methods > Balloon.GetReferenceKey Method


Balloon.SaveItemOverridesToBOM Method

Balloon.SaveItemOverridesToBOM Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that saves any overrides to the item values in the balloon to the model BOM. Only the overrides applies to the BallonValueSet.Value property are saved. The value of the OverrideValue property is ignored.

Visual Basic
Sub SaveItemOverridesToBOM()
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Methods > Balloon.SaveItemOverridesToBOM Method


Balloon.SetBalloonType Method

Balloon.SetBalloonType Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that sets the balloon type.

Visual Basic
Sub SetBalloonType(BalloonType As BalloonTypeEnum, ByRef BalloonTypeData As [optional] VARIANT)
Parameters
Parameters | Description
BalloonType | Constant that indicates the balloon type. Valid types are kCircularWithOneEntryBalloonType, kCircularWithTwoEntriesBalloonType, kHexagonBalloonType, kLinearBalloonType, kNoneBalloonType and kSketchedSymbolBalloonType. Setting the type to kNoneBalloonType specifies that all the properties chosen in the style will be displayed.
BalloonTypeData | Optional input data associated with certain balloon types. If the balloon type is kSketchedSymbolBalloonType, this argument requires a SketchedSymbolDefinition object. Else, this argument is ignored.
See Also

Balloons - edit sample

Example

See Balloons for example "Editing balloons"

You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Methods > Balloon.SetBalloonType Method


Balloon Properties

Balloon Properties
Summary

The properties of the Balloon class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Attached | Property that returns whether the balloon is attached to a component.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BalloonValueSets | This property gets the collection of objects. See the BalloonValueSets and BalloonValueSet objects for more information.
Layer | Property that gets and sets the layer associated with this object.
Leader | Property that returns the leader associated with the balloon.
Parent | Property returning the parent sheet (the sheet object this balloon is associated with).
ParentView | Property that returns the parent DrawingView object. In other words, the sheet contains a view with which this balloon is associated.
PlacementDirection | Property that gets and sets the direction in which to place attached balloons.
Position | Property that gets and sets the position of the balloon on the Sheet.
Style | Gets and sets the associated BalloonStyle object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties


Balloon.Application Property

Balloon.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Application Property


Balloon.Attached Property

Balloon.Attached Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether the balloon is attached to a component.

Visual Basic
Property Attached() As VARIANT_BOOL*
Remarks

If this property returns False, it indicates that the balloon is sick and is displayed in a pink color in the user interface. It is possible to drag the balloon leader attach point so it is not associated with component geometry. The balloon remains associative to the component in this case and this property still returns True. The value of this property in the three situations is shown below the figures.

You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Attached Property


Balloon.AttributeSets Property

Balloon.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.AttributeSets Property


Balloon.BalloonValueSets Property

Balloon.BalloonValueSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

This property gets the collection of objects. See the BalloonValueSets and BalloonValueSet objects for more information.

Visual Basic
Property BalloonValueSets() As BalloonValueSets**
See Also

Find component referenced by balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.BalloonValueSets Property


Balloon.Layer Property

Balloon.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Layer Property


Balloon.Leader Property

Balloon.Leader Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the leader associated with the balloon.

Visual Basic
Property Leader() As Leader**
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Leader Property


Balloon.Parent Property

Balloon.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning the parent sheet (the sheet object this balloon is associated with).

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Parent Property


Balloon.ParentView Property

Balloon.ParentView Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent DrawingView object. In other words, the sheet contains a view with which this balloon is associated.

Visual Basic
Property ParentView() As DrawingView**
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.ParentView Property


Balloon.PlacementDirection Property

Balloon.PlacementDirection Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the direction in which to place attached balloons.

Visual Basic
Property PlacementDirection() As BalloonDirectionEnum
See Also

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.PlacementDirection Property


Balloon.Position Property

Balloon.Position Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the position of the balloon on the Sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Position Property


Balloon.Style Property

Balloon.Style Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets and sets the associated BalloonStyle object.

Visual Basic
Property Style() As BalloonStyle*
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Style Property


Balloon.Type Property

Balloon.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Balloon Interface > Balloon Properties > Balloon.Type Property


Balloons Interface

Balloons Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Balloons collection object provides access to all of the objects on a sheet. This collection is available via the Balloons property of the Sheet object.

Class Hierarchy
Inventor::Balloons
Visual Basic
Public Interface Balloons
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

Sheet.Balloons

See Also

Find component referenced by balloon sample

Balloons - edit sample

Example

"Balloons - edit Example "

This sample demonstrates the editing of balloons in a drawing.

To run this sample, open a drawing document with the active sheet that has several balloons (including attached balloons) placed on it. This sample modifies the type and values of all the balloons.

Public Sub EditBalloons()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    Dim BalloonCount As Long
    BalloonCount = 1

    Dim oBalloon As Balloon

    ' Iterate over each balloon on the sheet.
    For Each oBalloon In oSheet.Balloons

        ' Change the balloon type
        oBalloon.SetBalloonType (kHexagonBalloonType)

        ' Change balloon placement direction so all the attached
        ' balloons are placed to the right of the previous ones.
        oBalloon.PlacementDirection = kBottomDirection

        Dim ValueSetCount As Long
        ValueSetCount = 1

        Dim oBalloonValueSet As BalloonValueSet

        ' Iterate over each value set (attached balloons) in a balloon.
        For Each oBalloonValueSet In oBalloon.BalloonValueSets

            ' Change the override value.
            oBalloonValueSet.OverrideValue = "Balloon" & BalloonCount & ": ValueSet" & ValueSetCount
            ValueSetCount = ValueSetCount + 1
        Next
        BalloonCount = BalloonCount + 1
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface


Balloons Methods

Balloons Methods
Summary

The methods of the Balloons class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Balloon. The newly created Balloon is returned. The corresponding BOMView in the model is automatically enabled if not already enabled.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Methods


Balloons.Add Method

Balloons.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new Balloon. The newly created Balloon is returned. The corresponding BOMView in the model is automatically enabled if not already enabled.

Visual Basic
Sub Add(LeaderPoints As ObjectCollection, ByRef VirtualComponent As [optional] VARIANT, ByRef Level As [optional] VARIANT, ByRef NumberingScheme As [optional] VARIANT, ByRef BalloonStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] Balloon*)
Parameters
Parameters
Description
LeaderPoints
Input ObjectCollection containing a series of Point2d objects representing the leader originating at the note. The last item in the collection (even if it is the only item) must be a GeometryIntent object indicating a geometry to attach the leader to. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method. The ObjectCollection must contain at least one item (a GeometryIntent), else the method will fail. Note that the component that the balloon will attach to is inferred from the GeometryIntent object.
VirtualComponent
Optional input object that defines the virtual or custom component that this balloon will be attached to. This can either be a ComponentOccurrence / ComponentOccurrenceProxy object representing a virtual component, a BOMRow that represents a virtual component or a custom/virtual DrawingBOMRow.
Level
Optional input PartsListLevelEnum that sets the view type for the parts list. If supplied, this input is only used in the case where the balloon references an assembly document. If this value was previously set as a result of creating a parts list or a balloon in the drawing based on the same model, this argument is ignored. Use the DrawingDocument.DrawingBOMs.IsDrawingBOMDefined method to check whether or not to supply this argument. Valid enums are: kStructured, that creates a 'first level only' parts list in which a simple integer value is assigned to direct children, kStructuredAllLevels that creates an 'all level' parts list with full expanded numbering, and kPartsOnly, that creates a parts list that sequentially numbers all parts in the top level assembly, even if they are contained in subassemblies.
NumberingScheme
Optional input NameValueMap object that specifies the numbering scheme to use for the parts list. This argument is ignored if the numbering schemes have already been set for this model as a result of creating a parts list or a balloon based on the same model. Use the DrawingDocument.DrawingBOMs.IsDrawingBOMDefined method to check whether or not to supply this argument. Also, this argument is ignored if the numbering schemes have been defined in the model BOM views. The NameValueMap can contain the following entries based on the input 'Level' argument:
For kStructured: 'MinimumDigits' As Long
For kStructuredAllLevels: 'Delimiter' As String
For kPartsOnly: 'NumberingScheme' As NumberingSchemeEnum and 'MinimumDigits' As Long
Valid values for NumberingSchemeEnum are kNumericNumbering, kLowercaseAlphaNumbering and kUppercaseAlphaNumbering. This input should be supplied only if the input argument Level is specified to be kPartsOnly. If this argument is not supplied for a 'parts only' parts list, a default value of kNumericNumbering is assumed.
BalloonStyle
Optional input BalloonStyle object that specifies the balloon style to use for the balloon. If not specified, the style defined by the active standard is used.
Layer
Optional input Layer object that specifies the layer to use for the balloon. If not specified, the layer defined by the active standard is used.
Example

"Creation a balloon"

"This sample demonstrates the creation of a balloon. Select a linear drawing curve and run the sample."

Public Sub CreateBalloon()
  ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the drawing curve segment.
    ' This assumes that a drwaing curve is selected.
    Dim oDrawingCurveSegment As DrawingCurveSegment
    Set oDrawingCurveSegment = oDrawDoc.SelectSet.Item(1)

    ' Set a reference to the drawing curve.
    Dim oDrawingCurve As DrawingCurve
    Set oDrawingCurve = oDrawingCurveSegment.Parent

    ' Get the mid point of the selected curve
    ' assuming that the selection curve is linear
    Dim oMidPoint As Point2d
    Set oMidPoint = oDrawingCurve.MidPoint

    ' Set a reference to the TransientGeometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oLeaderPoints As ObjectCollection
    Set oLeaderPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Create a couple of leader points.
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 10))
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 5))

    ' Add the GeometryIntent to the leader points collection.
    ' This is the geometry that the balloon will attach to.
    Dim oGeometryIntent As GeometryIntent
    Set oGeometryIntent = oActiveSheet.CreateGeometryIntent(oDrawingCurve)
    Call oLeaderPoints.Add(oGeometryIntent)

    ' Set a reference to the parent drawing view of the selected curve
    Dim oDrawingView As DrawingView
    Set oDrawingView = oDrawingCurve.Parent

    ' Set a reference to the referenced model document
    Dim oModelDoc As Document
    Set oModelDoc = oDrawingView.ReferencedDocumentDescriptor.ReferencedDocument

    ' Check if a partslist or a balloon has already been created for this model
    Dim IsDrawingBOMDefined As Boolean
    IsDrawingBOMDefined = oDrawDoc.DrawingBOMs.IsDrawingBOMDefined(oModelDoc.FullFileName)

    Dim oBalloon As Balloon

    If IsDrawingBOMDefined Then

        ' Just create the balloon with the leader points
        ' All other arguments can be ignored
        Set oBalloon = oDrawDoc.ActiveSheet.Balloons.Add(oLeaderPoints)
    Else

        ' First check if the 'structured' BOM view has been enabled in the model

        ' Set a reference to the model's BOM object
        Dim oBOM As BOM
        Set oBOM = oModelDoc.ComponentDefinition.BOM

        If oBOM.StructuredViewEnabled Then

            ' Level needs to be specified
            ' Numbering options have already been defined
            ' Get the Level ('All levels' or 'First level only')
            ' from the model BOM view - must use the same here
            Dim Level As PartsListLevelEnum
            If oBOM.StructuredViewFirstLevelOnly Then
                Level = kStructured
            Else
                Level = kStructuredAllLevels
            End If

            ' Create the balloon by specifying just the level
            Set oBalloon = oActiveSheet.Balloons.Add(oLeaderPoints, , Level)
        Else

            ' Level and numbering options must be specified
            ' The corresponding model BOM view will automatically be enabled
            Dim oNumberingScheme As NameValueMap
            Set oNumberingScheme = ThisApplication.TransientObjects.CreateNameValueMap

            ' Add the option for a comma delimiter
            oNumberingScheme.Add "Delimiter", ","

            ' Create the balloon by specifying the level and numbering scheme
            Set oBalloon = oActiveSheet.Balloons.Add(oLeaderPoints, , kStructuredAllLevels, oNumberingScheme)
        End If
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Methods > Balloons.Add Method


Balloons.Item Method

Balloons.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Balloon*)
Parameters
Parameters | Description
index | Input Long value that specifies the index number of the Balloon to return. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Methods > Balloons.Item Method


Balloons Properties

Balloons Properties
Summary

The properties of the Balloons class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Properties


Balloons.Application Property

Balloons.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Properties > Balloons.Application Property


Balloons.Count Property

Balloons.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
Example

See Balloons for example "Balloons Object"

You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Properties > Balloons.Count Property


Balloons.Type Property

Balloons.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Balloons Interface > Balloons Properties > Balloons.Type Property


BalloonStyle Interface

BalloonStyle Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The BalloonStyle object represents a balloon style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::BalloonStyle
Visual Basic
Public Interface BalloonStyle
Inherits Style
Notes

Members through which this object may be accessed include:

Balloon.Style

BalloonStylesEnumerator.Item

ObjectDefaultsStyle.BalloonStyle

You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface


BalloonStyle Properties

BalloonStyle Properties
Summary

The properties of the BalloonStyle class are listed here.

Properties
Name | Description
AlternateLeaderStyle | Property that gets and sets the alternate leader style used for the balloon style. Alternate leader style is used when a balloon termination is dragged away from its associative edge.
BalloonDiameter | Property that gets and sets the balloon diameter. This value is used only if the ScaleToTextHeight property is set to False. This property is not applicable if the balloon type is kNoneBalloonType or kLinearBalloonType.
BalloonType | Property that gets and sets the shape of the balloon. Valid types are kCircularWithOneEntryBalloonType, kCircularWithTwoEntriesBalloonType, kHexagonBalloonType, kLinearBalloonType and kNoneBalloonType.
DefaultOffset | Property that gets and sets the default distance between balloons when they are aligned. Changing this value has no effect on previously created balloons.
LeaderStyle | Property that gets and sets the leader style used for a balloon.
Properties | Property that gets and sets the properties to display in the balloon. The number of properties displayed depends on the balloon shape.
ScaleToTextHeight | Property that gets and sets whether to define the balloon size by text height. This property is not applicable if the balloon type is kNoneBalloonType or kLinearBalloonType.
StretchBalloonToText | Property that gets and sets whether to size the balloon horizontally to accommodate long text strings. If set to False, the balloon is restricted to the defined size. This property is not applicable if the balloon type is kNoneBalloonType or kLinearBalloonType.
TextStyle | Property that gets and sets the text style used to format the text in a balloon.
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties


BalloonStyle.AlternateLeaderStyle Property

BalloonStyle.AlternateLeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the alternate leader style used for the balloon style. Alternate leader style is used when a balloon termination is dragged away from its associative edge.

Visual Basic
Property AlternateLeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.AlternateLeaderStyle Property


BalloonStyle.BalloonDiameter Property

BalloonStyle.BalloonDiameter Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the balloon diameter. This value is used only if the ScaleToTextHeight property is set to False. This property is not applicable if the balloon type is kNoneBalloonType or kLinearBalloonType.

Visual Basic
Property BalloonDiameter() As double
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.BalloonDiameter Property


BalloonStyle.BalloonType Property

BalloonStyle.BalloonType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the shape of the balloon. Valid types are kCircularWithOneEntryBalloonType, kCircularWithTwoEntriesBalloonType, kHexagonBalloonType, kLinearBalloonType and kNoneBalloonType.

Visual Basic
Property BalloonType() As BalloonTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.BalloonType Property


BalloonStyle.DefaultOffset Property

BalloonStyle.DefaultOffset Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the default distance between balloons when they are aligned. Changing this value has no effect on previously created balloons.

Visual Basic
Property DefaultOffset() As double
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.DefaultOffset Property


BalloonStyle.LeaderStyle Property

BalloonStyle.LeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the leader style used for a balloon.

Visual Basic
Property LeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.LeaderStyle Property


BalloonStyle.Properties Property

BalloonStyle.Properties Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the properties to display in the balloon. The number of properties displayed depends on the balloon shape.

Visual Basic
Property Properties() As String
Remarks

The string can contain multiple properties separated by a semicolon (;).

To specify a file property in the drawing document, use the following format:

FormatID='{32853F0F-3444-11d1-9E93-0060B03C1CA6}' PropertyID='29'

To specify a parts list property, use the enum value (long) of PropertyTypeEnum, with a 'PartsListProperty' keyword.

To specify a custom property from the model, use the 'ModelCustomProperty' keyword.

Example:

'FormatID='{32853F0F-3444-11d1-9E93-0060B03C1CA6}' PropertyID='29'; FormatID='{32853F0F-3444-11d1-9E93-0060B03C1CA6}' PropertyID='27'; PartsListProperty='45576'; ModelCustomProperty ='MyProperty''

where 45576 is the enum value corresponding to kBaseQuantityPartsListProperty.

You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.Properties Property


BalloonStyle.ScaleToTextHeight Property

BalloonStyle.ScaleToTextHeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to define the balloon size by text height. This property is not applicable if the balloon type is kNoneBalloonType or kLinearBalloonType.

Visual Basic
Property ScaleToTextHeight() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.ScaleToTextHeight Property


BalloonStyle.StretchBalloonToText Property

BalloonStyle.StretchBalloonToText Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to size the balloon horizontally to accommodate long text strings. If set to False, the balloon is restricted to the defined size. This property is not applicable if the balloon type is kNoneBalloonType or kLinearBalloonType.

Visual Basic
Property StretchBalloonToText() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.StretchBalloonToText Property


BalloonStyle.TextStyle Property

BalloonStyle.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used to format the text in a balloon.

Visual Basic
Property TextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > BalloonStyle Interface > BalloonStyle Properties > BalloonStyle.TextStyle Property


BalloonStylesEnumerator Interface

BalloonStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The BalloonStylesEnumerator object provides access to the existing BalloonStyle objects.

Class Hierarchy
Inventor::BalloonStylesEnumerator
Visual Basic
Public Interface BalloonStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.BalloonStyles

You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface


BalloonStylesEnumerator Methods

BalloonStylesEnumerator Methods
Summary

The methods of the BalloonStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified BalloonStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface > BalloonStylesEnumerator Methods


BalloonStylesEnumerator.Item Method

BalloonStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified BalloonStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BalloonStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the BalloonStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the BalloonStyle name. If an out of range index or a name of a non-existent BalloonStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface > BalloonStylesEnumerator Methods > BalloonStylesEnumerator.Item Method


BalloonStylesEnumerator Properties

BalloonStylesEnumerator Properties
Summary

The properties of the BalloonStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBalloonStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface > BalloonStylesEnumerator Properties


BalloonStylesEnumerator.Application Property

BalloonStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface > BalloonStylesEnumerator Properties > BalloonStylesEnumerator.Application Property


BalloonStylesEnumerator.Count Property

BalloonStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface > BalloonStylesEnumerator Properties > BalloonStylesEnumerator.Count Property


BalloonStylesEnumerator.Type Property

BalloonStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kBalloonStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BalloonStylesEnumerator Interface > BalloonStylesEnumerator Properties > BalloonStylesEnumerator.Type Property


BalloonTipObject Interface

BalloonTipObject Interface Available in Inventor Introduced in Inventor 2012
Summary

This object provides access to a BalloonTip object.

Class Hierarchy
Inventor::BalloonTipObject
Visual Basic
Public Interface BalloonTipObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface


BalloonTipObject Methods

BalloonTipObject Methods
Summary

The methods of the BalloonTipObject class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the BalloonTip object.
Display | Method that displays the BalloonTip object once.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Methods


BalloonTipObject.Delete Method

BalloonTipObject.Delete Method Available in Inventor Introduced in Inventor 16
Summary

Method that deletes the BalloonTip object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Methods > BalloonTipObject.Delete Method


BalloonTipObject.Display Method

BalloonTipObject.Display Method Available in Inventor Introduced in Inventor 16
Summary

Method that displays the BalloonTip object once.

Visual Basic
Sub Display(ByRef Message As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
Message | In Input String to override the default message that specified by message property of BalloonTip. If input Null string then the default message would be used.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Methods > BalloonTipObject.Display Method


BalloonTipObject Properties

BalloonTipObject Properties
Summary

The properties of the BalloonTipObject class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ClientData | Contains some additional data that the client would like to store with the BalloonTip.
Enabled | Property that gets and sets if the BalloonTip object is enabled or not.
InternalName | Property that returns the internal name of the BalloonTip object.
Interval | Property that gets and sets the time interval for displaying the BalloonTip object. The unit is second.
Message | Gets/sets the message of the BalloonTip object.
Parent | Property that returns the parent UserInterfaceManager object.
Type | Property returning kBalloonTipObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties


BalloonTipObject.Application Property

BalloonTipObject.Application Property Available in Inventor Introduced in Inventor 16
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.Application Property


BalloonTipObject.ClientData Property

BalloonTipObject.ClientData Property Available in Inventor Introduced in Inventor 16
Summary

Contains some additional data that the client would like to store with the BalloonTip.

Visual Basic
Property ClientData() As String
Remarks

This string is not interpreted by Inventor. Clients are expected to use the string with extreme economy.

You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.ClientData Property


BalloonTipObject.Enabled Property

BalloonTipObject.Enabled Property Available in Inventor Introduced in Inventor 16
Summary

Property that gets and sets if the BalloonTip object is enabled or not.

Visual Basic
Property Enabled() As VARIANT_BOOL
Remarks

When this is set to True, then the timer is started, and the BalloonTip is displayed according to the Interval.

You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.Enabled Property


BalloonTipObject.InternalName Property

BalloonTipObject.InternalName Property Available in Inventor Introduced in Inventor 16
Summary

Property that returns the internal name of the BalloonTip object.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.InternalName Property


BalloonTipObject.Interval Property

BalloonTipObject.Interval Property Available in Inventor Introduced in Inventor 16
Summary

Property that gets and sets the time interval for displaying the BalloonTip object. The unit is second.

Visual Basic
Property Interval() As long
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.Interval Property


BalloonTipObject.Message Property

BalloonTipObject.Message Property Available in Inventor Introduced in Inventor 16
Summary

Gets/sets the message of the BalloonTip object.

Visual Basic
Property Message() As String
Remarks

This message supports the <Hyperlink></Hyperlink> tag to create a hyper link string.

You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.Message Property


BalloonTipObject.Type Property

BalloonTipObject.Type Property Available in Inventor Introduced in Inventor 16
Summary

Property returning kBalloonTipObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.Type Property


BalloonTips Interface

BalloonTips Interface Available in Inventor Introduced in Inventor 2012
Summary

This object provides access to the BalloonTip objects. This collection only contains the user created balloon tip objects.

Class Hierarchy
Inventor::BalloonTips
Visual Basic
Public Interface BalloonTips
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface


BalloonTips Methods

BalloonTips Methods
Summary

The methods of the BalloonTips class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new BalloonTip object. The new created BalloonTip is returned.
Item | Returns the specified BalloonTip object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Methods


BalloonTips.Add Method

BalloonTips.Add Method Available in Inventor Introduced in Inventor 16
Summary

Method that creates a new BalloonTip object. The new created BalloonTip is returned.

Visual Basic
Sub Add(InternalName As String, Title As String, Message As String, Result As [out, retval] BalloonTip*)
Parameters
Parameters | Description
InternalName | Input String value that specifies the internal name of the BalloonTip.
Title | Input String value that specifies the title of the BalloonTip.
Message | Optional input String value that specifies the message for the BalloonTip. This message supports the <Hyperlink></Hyperlink> tag to create a hyper link string.
Result | _nt_
Remarks

When a BalloonTip object is created, its Interval would be default to 600 seconds.

You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Methods > BalloonTips.Add Method


BalloonTips.Item Method

BalloonTips.Item Method Available in Inventor Introduced in Inventor 16
Summary

Returns the specified BalloonTip object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BalloonTip*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the BalloonTip to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the BalloonTip internal name. If an out of range index or a name of a non-existent BalloonTip is provided, an error will occur.
Result | _nt_
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Methods > BalloonTips.Item Method


BalloonTips Properties

BalloonTips Properties
Summary

The properties of the BalloonTips class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBalloonTipsObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Properties


BalloonTips.Application Property

BalloonTips.Application Property
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Properties > BalloonTips.Application Property


BalloonTips.Count Property

BalloonTips.Count Property
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Properties > BalloonTips.Count Property


BalloonTips.Type Property

BalloonTips.Type Property
Summary

Property returning kBalloonTipsObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BalloonTips Interface > BalloonTips Properties > BalloonTips.Type Property


BalloonTipSink Interface

BalloonTipSink Interface
Summary

This is class Inventor::BalloonTipSink.

Class Hierarchy
Inventor::BalloonTipSink
Visual Basic
Public Interface BalloonTipSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipSink Interface


BalloonTipSink Methods

BalloonTipSink Methods
Summary

The methods of the BalloonTipSink class are listed here.

Methods
Methods
Name | Description
OnClick | Event that fires when the BalloonTip object is clicked on a hyper link.
OnDisplay | Event that fires when the BalloonTip object is being displayed.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipSink Interface > BalloonTipSink Methods


BalloonTipSink.OnClick Method

BalloonTipSink.OnClick Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires when the BalloonTip object is clicked on a hyper link.

Visual Basic
Sub OnClick(Context As NameValueMap)
Parameters
Parameters | Description
Context | Input NameValueMap object that can be used to determine the context of why the event fired. o Name = "HyperlinkIndex", Value = Long. The Index of the hyper link which is clicked. If no hyper link is clicked, this returns 0.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipSink Interface > BalloonTipSink Methods > BalloonTipSink.OnClick Method


BalloonTipSink.OnDisplay Method

BalloonTipSink.OnDisplay Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires when the BalloonTip object is being displayed.

Visual Basic
Sub OnDisplay(ByRef Cancel As VARIANT_BOOL)
Parameters
Parameters | Description
Cancel | Boolean value to indicate if cancel displaying the balloon tip The Cancel argument is an in/out argument, and it is defaulted to false. Leave it set to false and the balloon tip will be displayed. If you want to cancel displaying the balloon tip, set this value to true.
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipSink Interface > BalloonTipSink Methods > BalloonTipSink.OnDisplay Method


BalloonValueSet Interface

BalloonValueSet Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The BalloonValueSet object allows for setting and overriding of balloon content.

Class Hierarchy
Inventor::BalloonValueSet
Visual Basic
Public Interface BalloonValueSet
Inherits IDispatch
Remarks

If the balloon is not associated with a property set (for example, Balloon type is not kPropertyBalloonType) then this object reflects the value of the balloon. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

BalloonValueSets.Add

BalloonValueSets.Item

See Also

Find component referenced by balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface


BalloonValueSet Methods

BalloonValueSet Methods
Summary

The methods of the BalloonValueSet class are listed here.

Methods
Methods
Name | Description
Delete | Deletes this BalloonValueSet object.
ReferencedFiles | Property returning the file referenced by this balloon value set.
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Methods


BalloonValueSet.Delete Method

BalloonValueSet.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Deletes this BalloonValueSet object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Methods > BalloonValueSet.Delete Method


BalloonValueSet.ReferencedFiles Method

BalloonValueSet.ReferencedFiles Method Available in Inventor Available in Server
Summary

Property returning the file referenced by this balloon value set.

Visual Basic
Sub ReferencedFiles(Result As [out, retval] ReferencedFileDescriptors*)
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Methods > BalloonValueSet.ReferencedFiles Method


BalloonValueSet Properties

BalloonValueSet Properties
Summary

The properties of the BalloonValueSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ItemNumber | Property that returns the associated item number.
OverrideValue | Property that gets and sets the override value of the balloon.
Parent | Property returning the parent balloon.
ReferencedRow | Property that returns the referenced DrawingBOMRow object.
Static | Property that gets and sets whether the Value property has been overridden. Setting this property to False clears any overrides on the Value, but does not clear the 'override value.' The override value can be cleared by setting the OverrideValue property to a null string. This property is the equivalent of the PartListCell.Static property.
Type | Property returning an enum indicating this object's type.
Value | Property that gets and sets the value of the balloon. This value corresponds to the item number of a row in a parts list if any have been created.
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties


BalloonValueSet.Application Property

BalloonValueSet.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.Application Property


BalloonValueSet.ItemNumber Property

BalloonValueSet.ItemNumber Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the associated item number.

Visual Basic
Property ItemNumber() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.ItemNumber Property


BalloonValueSet.OverrideValue Property

BalloonValueSet.OverrideValue Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the override value of the balloon.

Visual Basic
Property OverrideValue() As String
See Also

Find component referenced by balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.OverrideValue Property


BalloonValueSet.Parent Property

BalloonValueSet.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning the parent balloon.

Visual Basic
Property Parent() As Balloon**
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.Parent Property


BalloonValueSet.ReferencedRow Property

BalloonValueSet.ReferencedRow Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the referenced DrawingBOMRow object.

Visual Basic
Property ReferencedRow() As DrawingBOMRow**
Example

"Find component referenced by balloon"

"This sample demonstrates how to find the component that a balloon references. Select a balloon in a drawing and run the following sample."

Public Sub GetComponentReferencedByBalloon()
    ' Set a reference to the active drawing document
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Get the selected balloon
    Dim oBalloon As Balloon
    Set oBalloon = oDoc.SelectSet(1)

    Dim oBalloonValueSet As BalloonValueSet
    For Each oBalloonValueSet In oBalloon.BalloonValueSets
        Dim strDisplay As String
        strDisplay = "Balloon Item Number: "

        ' Add the balloon item number (the overridden value if there is one)
        If oBalloonValueSet.OverrideValue = "" Then
            strDisplay = strDisplay & oBalloonValueSet.Value
        Else
            strDisplay = strDisplay & oBalloonValueSet.OverrideValue
        End If

        Dim oDrawingBOMRow As DrawingBOMRow
        Set oDrawingBOMRow = oBalloonValueSet.ReferencedRow

        If oDrawingBOMRow.Custom Then
            ' The referenced item is a custom parts list row.
            strDisplay = strDisplay & vbNewLine & "Referenced Component(s):"
            strDisplay = strDisplay & vbNewLine & "     Custom PartsList Row"
        Else
            Dim oBOMRow As BOMRow
            Set oBOMRow = oDrawingBOMRow.BOMRow

            ' Add the Item Number from the model BOM.
            strDisplay = strDisplay & vbNewLine & "BOM Item Number: " & oBOMRow.ItemNumber

            strDisplay = strDisplay & vbNewLine & "Referenced Component(s):"

            Dim oCompDefs As ComponentDefinitionsEnumerator
            Set oCompDefs = oBOMRow.ComponentDefinitions

            If oDrawingBOMRow.Virtual Then
                ' The referenced item is a virtual component.
                strDisplay = strDisplay & vbNewLine & "     Virtual: " & oCompDefs.Item(1).DisplayName
            Else

                ' Add the document name of the referenced component.
                ' There could be multiple if the balloon references
                ' a merged BOM row in the model.
                Dim oCompDef As ComponentDefinition
                For Each oCompDef In oCompDefs
                    strDisplay = strDisplay & vbNewLine & "     " & oCompDef.Document.FullDocumentName
                Next

            End If
        End If
        MsgBox strDisplay
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.ReferencedRow Property


BalloonValueSet.Static Property

BalloonValueSet.Static Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the Value property has been overridden. Setting this property to False clears any overrides on the Value, but does not clear the 'override value.' The override value can be cleared by setting the OverrideValue property to a null string. This property is the equivalent of the PartListCell.Static property.

Visual Basic
Property Static() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.Static Property


BalloonValueSet.Type Property

BalloonValueSet.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.Type Property


BalloonValueSet.Value Property

BalloonValueSet.Value Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the value of the balloon. This value corresponds to the item number of a row in a parts list if any have been created.

Visual Basic
Property Value() As String
See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSet Interface > BalloonValueSet Properties > BalloonValueSet.Value Property


BalloonValueSets Interface

BalloonValueSets Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The BalloonValueSets object represents a collection of objects. Note that this collection does not yet support an Add method. See the article in the overviews section.

Class Hierarchy
Inventor::BalloonValueSets
Visual Basic
Public Interface BalloonValueSets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Balloon.BalloonValueSets

See Also

Find component referenced by balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface


BalloonValueSets Methods

BalloonValueSets Methods
Summary

The methods of the BalloonValueSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new BalloonValueSet.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Methods


BalloonValueSets.Add Method

BalloonValueSets.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new BalloonValueSet.

Visual Basic
Sub Add(Component As IDispatch, Result As [out, retval] BalloonValueSet*)
Parameters
Parameters | Description
Component | Input object that defines the component that this balloon will be attached to. This can be one of the following: a ComponentOccurrence / ComponentOccurrenceProxy object, or a DrawingBOMRow object.
Remarks

The new created BalloonValueSet is returned. This is the equivalent of the 'Attach Balloon' and 'Attach Balloon From List' commands in the user interface.

You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Methods > BalloonValueSets.Add Method


BalloonValueSets.Item Method

BalloonValueSets.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BalloonValueSet*)
Parameters
Parameters | Description
index | Input Long value that specifies the index number of the BalloonValueSet to return. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Methods > BalloonValueSets.Item Method


BalloonValueSets Properties

BalloonValueSets Properties
Summary

The properties of the BalloonValueSets class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Properties


BalloonValueSets.Application Property

BalloonValueSets.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Properties > BalloonValueSets.Application Property


BalloonValueSets.Count Property

BalloonValueSets.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Properties > BalloonValueSets.Count Property


BalloonValueSets.Type Property

BalloonValueSets.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BalloonValueSets Interface > BalloonValueSets Properties > BalloonValueSets.Type Property


BaselineDimensionSet Interface

BaselineDimensionSet Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BaselineDimensionSet object represents a baseline dimension set placed on a sheet.

Class Hierarchy
Inventor::BaselineDimensionSet
Visual Basic
Public Interface BaselineDimensionSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BaselineDimensionSets.Add

BaselineDimensionSets.Item

LinearGeneralDimension.BaselineDimensionSet

See Also

Baseline dimension sets sample

You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface


BaselineDimensionSet Methods

BaselineDimensionSet Methods
Summary

The methods of the BaselineDimensionSet class are listed here.

Methods
Methods
Name | Description
AddMember | Method that adds a member to the baseline set and returns a LinearGeneralDimension object. If an existing LinearGeneralDimension is input into the method, the same object is returned.
ArrangeText | Method that automatically arranges the text of all members.
Delete | Method that deletes the BaselineDimensionSet.
DetachMember | Method that detaches the member from the set. The member is not deleted, it is merely converted into a vanilla linear general dimension.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Methods


BaselineDimensionSet.AddMember Method

BaselineDimensionSet.AddMember Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds a member to the baseline set and returns a LinearGeneralDimension object. If an existing LinearGeneralDimension is input into the method, the same object is returned.

Visual Basic
Sub AddMember(DimensionOrGeometry As IDispatch, Result As [out, retval] LinearGeneralDimension*)
Parameters
Parameters | Description
DimensionOrGeometry | Input object that specifies the member. This can either be an existing LinearGeneralDimension object or a GeometryIntent object that specifies the geometry to dimension to.
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Methods > BaselineDimensionSet.AddMember Method


BaselineDimensionSet.ArrangeText Method

BaselineDimensionSet.ArrangeText Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that automatically arranges the text of all members.

Visual Basic
Sub ArrangeText()
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Methods > BaselineDimensionSet.ArrangeText Method


BaselineDimensionSet.Delete Method

BaselineDimensionSet.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the BaselineDimensionSet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Methods > BaselineDimensionSet.Delete Method


BaselineDimensionSet.DetachMember Method

BaselineDimensionSet.DetachMember Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that detaches the member from the set. The member is not deleted, it is merely converted into a vanilla linear general dimension.

Visual Basic
Sub DetachMember(Member As LinearGeneralDimension)
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Methods > BaselineDimensionSet.DetachMember Method


BaselineDimensionSet.GetReferenceKey Method

BaselineDimensionSet.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Methods > BaselineDimensionSet.GetReferenceKey Method


BaselineDimensionSet Properties

BaselineDimensionSet Properties
Summary

The properties of the BaselineDimensionSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DimensionType | Property that returns the dimension type of the baseline set. Possible values are kAlignedDimensionType, kHorizontalDimensionType and kVerticalDimensionType.
Layer | Property that gets and sets the layer for the dimension set.
Members | Property that returns all the member LinearGeneralDimension objects.
Origin | Property that gets and sets the origin for the baseline dimension set. When setting the property, this must be a geometry that one of the members is attached to, else the property returns an error.
Parent | Property that returns the parent sheet of the object.
Precision | Property that gets and sets the number of decimal places displayed for all the members in this set. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.
Style | Property that gets and sets the dimension style used for this dimension set. Setting a new style resets all the style-overriding properties on the members.
Type | Property returning kBaselineDimensionSetObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties


BaselineDimensionSet.Application Property

BaselineDimensionSet.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Application Property


BaselineDimensionSet.AttributeSets Property

BaselineDimensionSet.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.AttributeSets Property


BaselineDimensionSet.DimensionType Property

BaselineDimensionSet.DimensionType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the dimension type of the baseline set. Possible values are kAlignedDimensionType, kHorizontalDimensionType and kVerticalDimensionType.

Visual Basic
Property DimensionType() As DimensionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.DimensionType Property


BaselineDimensionSet.Layer Property

BaselineDimensionSet.Layer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the layer for the dimension set.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Layer Property


BaselineDimensionSet.Members Property

BaselineDimensionSet.Members Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns all the member LinearGeneralDimension objects.

Visual Basic
Property Members() As GeneralDimensionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Members Property


BaselineDimensionSet.Origin Property

BaselineDimensionSet.Origin Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the origin for the baseline dimension set. When setting the property, this must be a geometry that one of the members is attached to, else the property returns an error.

Visual Basic
Property Origin() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Origin Property


BaselineDimensionSet.Parent Property

BaselineDimensionSet.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent sheet of the object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Parent Property


BaselineDimensionSet.Precision Property

BaselineDimensionSet.Precision Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the number of decimal places displayed for all the members in this set. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

Visual Basic
Property Precision() As long
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Precision Property


BaselineDimensionSet.Style Property

BaselineDimensionSet.Style Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the dimension style used for this dimension set. Setting a new style resets all the style-overriding properties on the members.

Visual Basic
Property Style() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Style Property


BaselineDimensionSet.Type Property

BaselineDimensionSet.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBaselineDimensionSetObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSet Interface > BaselineDimensionSet Properties > BaselineDimensionSet.Type Property


BaselineDimensionSets Interface

BaselineDimensionSets Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BaselineDimensionSets collection object provides access to all of the baseline dimension sets on the sheet.

Class Hierarchy
Inventor::BaselineDimensionSets
Visual Basic
Public Interface BaselineDimensionSets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDimensions.BaselineDimensionSets

See Also

Baseline dimension sets sample

You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface


BaselineDimensionSets Methods

BaselineDimensionSets Methods
Summary

The methods of the BaselineDimensionSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a baseline dimension set and returns the newly created BaselineDimensionSet object.
Item | Method that returns the specified dimension set object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Methods


BaselineDimensionSets.Add Method

BaselineDimensionSets.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a baseline dimension set and returns the newly created BaselineDimensionSet object.

Visual Basic
Sub Add(GeometryIntents As ObjectCollection, PlacementPoint As Point2d, DimensionType As DimensionTypeEnum, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] BaselineDimensionSet*)
Parameters
Parameters | Description
GeometryIntents | Input ObjectCollection containing GeometryIntent objects. The GeometryIntent objects specify the geometries to use for the dimension. The first geometry in the collection is assumed to be the origin.
PlacementPoint | Input Point2d object that specifies the placement point of the dimension set on the sheet.
DimensionType | ' Input DimensionTypeEnum that specifies the dimension type. Valid values kHorizontalDimensionType, kVerticalDimensionType and kAlignedDimensionType. See Remarks.
DimensionStyle | Optional input DimensionStyle object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Optional input Layer object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
Remarks

The value kAlignedDimensionType for the DimensionType parameter can be specified only if the first geometry specified in the input GeometryIntents collection represents a line which is not parallel to the x or y axes of the sheet. If kAlignedDimensionType is specified, the placement point decides the orientation of the dimension set as demonstrated in the pictures below.

Fig.1 Aligned dimension set: Placement point along the direction of the first geometry with a tolerance of 0.25 cm on either side of the line.

Fig.2. Aligned dimension set: Placement point not along the direction of the first geometry

Example

Baseline dimension sets example.

This sample demonstrates the creation of a baseline set dimension in a drawing. Create a drawing view and select multiple edges in the view before running the sample.

Public Sub CreateBaselineDimensionSet()

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    Dim oIntentCollection As ObjectCollection
    Set oIntentCollection = ThisApplication.TransientObjects.CreateObjectCollection

    ' Get all the selected drawing curve segments.
    Dim oDrawingCurveSegment As DrawingCurveSegment
    Dim oDrawingCurve As DrawingCurve
    For Each oDrawingCurveSegment In oDrawDoc.SelectSet

        ' Set a reference to the drawing curve.
        Set oDrawingCurve = oDrawingCurveSegment.Parent

        Dim oDimIntent As GeometryIntent
        Set oDimIntent = oActiveSheet.CreateGeometryIntent(oDrawingCurve)

        Call oIntentCollection.Add(oDimIntent)
    Next

   ' Set a reference to the view to which the curve belongs.
    Dim oDrawingView As DrawingView
    Set oDrawingView = oDrawingCurve.Parent

    ' Set a reference to the baseline dimension sets collection.
    Dim oBaselineSets As BaselineDimensionSets
    Set oBaselineSets = oActiveSheet.DrawingDimensions.BaselineDimensionSets

    ' Determine the placement point
    Dim oPlacementPoint As Point2d
    Set oPlacementPoint = ThisApplication.TransientGeometry.CreatePoint2d(oDrawingView.Left - 5, oDrawingView.Center.Y)

    ' Create a vertical baseline set dimension.
    Dim oBaselineSet As BaselineDimensionSet
    Set oBaselineSet = oBaselineSets.Add(oIntentCollection, oPlacementPoint, kVerticalDimensionType)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Methods > BaselineDimensionSets.Add Method


BaselineDimensionSets.Item Method

BaselineDimensionSets.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified dimension set object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BaselineDimensionSet*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Methods > BaselineDimensionSets.Item Method


BaselineDimensionSets Properties

BaselineDimensionSets Properties
Summary

The properties of the BaselineDimensionSets class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBaselineDimensionSetsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Properties


BaselineDimensionSets.Application Property

BaselineDimensionSets.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Properties > BaselineDimensionSets.Application Property


BaselineDimensionSets.Count Property

BaselineDimensionSets.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Properties > BaselineDimensionSets.Count Property


BaselineDimensionSets.Type Property

BaselineDimensionSets.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBaselineDimensionSetsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BaselineDimensionSets Interface > BaselineDimensionSets Properties > BaselineDimensionSets.Type Property


Bend Interface

Bend Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The Bend object represents a bend in a sheet metal part.

Class Hierarchy
Inventor::Bend
Visual Basic
Public Interface Bend
Inherits IDispatch
Remarks

These are the logical bends in the part and are not necessarily created using any specific sheet metal features. For example, a sheet metal part imported from a STEP file does not have any Inventor sheet metal features but does have logical bends. The bends returned can be bends in both the bent and flat state.

Notes

Members through which this object may be accessed include:

BendsEnumerator.Item

FlatBendResult.Bend

You are here: Symbol Reference > Inventor Library > Objects > Bend Interface


Bend Properties

Bend Properties
Summary

The properties of the Bend class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BackFaces | Property that returns the collection of front faces in the model that represent this bend.
FrontFaces | Property that returns the collection of faces in the model that represent this bend.
IsFlat | Property that indicates if the bend is in a folded or flat state
Parent | Property that returns the parent SheetMetalComponentDefinition of this Bend object.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties


Bend.Application Property

Bend.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties > Bend.Application Property


Bend.BackFaces Property

Bend.BackFaces Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of front faces in the model that represent this bend.

Visual Basic
Property BackFaces() As Faces**
Remarks

The back faces of a bend are the faces of the bend on the 'back' side of the part. If the bend is folded these will be cylinders and if it's flat they will be planes.

You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties > Bend.BackFaces Property


Bend.FrontFaces Property

Bend.FrontFaces Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of faces in the model that represent this bend.

Visual Basic
Property FrontFaces() As Faces**
Remarks

The front faces of a bend are the faces of the bend on the 'front' side of the part. If the bend is folded these will be cylinders and if it's flat they will be planes.

You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties > Bend.FrontFaces Property


Bend.IsFlat Property

Bend.IsFlat Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if the bend is in a folded or flat state

Visual Basic
Property IsFlat() As VARIANT_BOOL*
Remarks

This property returns True if the bend is flat. A bend can be in a flattened state when an unfold feature has been applied to the bend.

You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties > Bend.IsFlat Property


Bend.Parent Property

Bend.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent SheetMetalComponentDefinition of this Bend object.

Visual Basic
Property Parent() As SheetMetalComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties > Bend.Parent Property


Bend.Type Property

Bend.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Bend Interface > Bend Properties > Bend.Type Property


BendConstraint Interface

BendConstraint Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The BendConstraint object represents a bend constraint within a 3D sketch.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::BendConstraint
        Inventor::BendConstraintProxy
Visual Basic
Public Interface BendConstraint
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

BendConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > BendConstraint Interface


BendConstraint Properties

BendConstraint Properties
Summary

The properties of the BendConstraint class are listed here.

Properties
Name | Description
Arc | Property that returns the SketchArc3D object associated with the bend.
LineOne | Property that returns the Sketch Line used to construct the bend feature.
LineTwo | Property that returns the Sketch Line used to construct the bend feature.
Radius | Property that returns the parameter controlling the radius of the bend.
You are here: Symbol Reference > Inventor Library > Objects > BendConstraint Interface > BendConstraint Properties


BendConstraint.Arc Property

BendConstraint.Arc Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchArc3D object associated with the bend.

Visual Basic
Property Arc() As SketchArc3D**
You are here: Symbol Reference > Inventor Library > Objects > BendConstraint Interface > BendConstraint Properties > BendConstraint.Arc Property


BendConstraint.LineOne Property

BendConstraint.LineOne Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Sketch Line used to construct the bend feature.

Visual Basic
Property LineOne() As SketchLine3D**
You are here: Symbol Reference > Inventor Library > Objects > BendConstraint Interface > BendConstraint Properties > BendConstraint.LineOne Property


BendConstraint.LineTwo Property

BendConstraint.LineTwo Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Sketch Line used to construct the bend feature.

Visual Basic
Property LineTwo() As SketchLine3D**
You are here: Symbol Reference > Inventor Library > Objects > BendConstraint Interface > BendConstraint Properties > BendConstraint.LineTwo Property


BendConstraint.Radius Property

BendConstraint.Radius Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parameter controlling the radius of the bend.

Visual Basic
Property Radius() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > BendConstraint Interface > BendConstraint Properties > BendConstraint.Radius Property


BendConstraintProxy Interface

BendConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BendConstraint object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::BendConstraint
        Inventor::BendConstraintProxy
Visual Basic
Public Interface BendConstraintProxy
Inherits BendConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BendConstraintProxy Interface


BendConstraintProxy Properties

BendConstraintProxy Properties
Summary

The properties of the BendConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > BendConstraintProxy Interface > BendConstraintProxy Properties


BendConstraintProxy.ContainingOccurrence Property

BendConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BendConstraintProxy Interface > BendConstraintProxy Properties > BendConstraintProxy.ContainingOccurrence Property


BendConstraintProxy.NativeObject Property

BendConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As BendConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BendConstraintProxy Interface > BendConstraintProxy Properties > BendConstraintProxy.NativeObject Property


BendDefinition Interface

BendDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The BendDefinition object represents all of the information that defines a bend.

Class Hierarchy
Inventor::BendDefinition
Visual Basic
Public Interface BendDefinition
Inherits IDispatch
Remarks

The BendDefinition object is used in two ways. First it is used as input when creating bend features Second it is used to query and edit existing features that contain bends. There are two ways to get a BendDefinition object; use the BendFeatures.CreateBendDefinition method or get a bend definition from an existing feature that has associated bends.

Notes

Members through which this object may be accessed include:

BendDefinition.Copy

BendFeature.Definition

BendFeatures.CreateBendDefinition

FaceFeatureDefinition.BendDefinition

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface


BendDefinition Methods

BendDefinition Methods
Summary

The methods of the BendDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this BendDefinition object.
You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Methods


BendDefinition.Copy Method

BendDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a copy of this BendDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] BendDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Methods > BendDefinition.Copy Method


BendDefinition Properties

BendDefinition Properties
Summary

The properties of the BendDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BendOptions | Property that gets the BendOptions object that defines the options for a bend.
BendRadius | Property that provides access to the bend radius.
DoubleBendType | Property that specifies if the bend is a double bend or not, and if it is a double bend, what type of double bend.
Edges | Property that gets and sets the set of edges that define the location of this bend.
ExtendFaces | Property that specifies if the existing faces will be extended to the bend or if a perpendicular section should be created to connect to the bend.
IsDoubleBendFirstEdgeFixed | Property that's used in the case of double bends to specify which face remains fixed and which one is extended or trimmed.
IsUnfoldMethodOverridden | Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.
Parent | Property that returns the parent feature of this BendDefinition object.
Type | Property returning enum indicating this objects type.
UnfoldMethod | Property that gets and sets the UnfoldMethod object that defines how this bend is unfolded.
You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties


BendDefinition.Application Property

BendDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.Application Property


BendDefinition.BendOptions Property

BendDefinition.BendOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the BendOptions object that defines the options for a bend.

Visual Basic
Property BendOptions() As BendOptions*
Remarks

The properties of this object can be modified to edit the associated feature. When the BendDefinition is initially created this is initialized to the bend options defined by the active sheet metal style.

The BendOptions object returned remains associated with the BendDefinition object it is obtained from. This means that edits made to the BendOptions object will affect the BendDefinition and the feature, if one exists.

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.BendOptions Property


BendDefinition.BendRadius Property

BendDefinition.BendRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend radius.

Visual Basic
Property BendRadius() As VARIANT
Remarks

This property is writable when the BendDefinition object has been created using the CreateBendDefinition or BendDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendRadius * 2' is valid, assuming there is a parameter named MyBendRadius.

When the BendDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the radius of the bend. In this case, you can use the properties of the parameter object to change the value.

See Also

Create sheet metal face and flange features sample

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.BendRadius Property


BendDefinition.DoubleBendType Property

BendDefinition.DoubleBendType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if the bend is a double bend or not, and if it is a double bend, what type of double bend.

Visual Basic
Property DoubleBendType() As DoubleBendTypeEnum
Remarks

This property is not valid in the case where this bend definition is associated with a feature that does not provide this functionality. For example, a flange feature does not offer this option. In these cases, the value of the property should be ignored.

This property is initialized to different values depending on how many edges are input and the geometry of the input edges. If a single edge is input then this is set to kDoubleBendSingle. If two edges are input there are two possible cases. First, if the normal of the side faces that connect to these edges point in the same direction then this will default to kDoubleBend90Degree and can be changed to kDoubleBendFullRadius. If the normals oppose each other then this will default to kDoubleBend45Degree and can be changed to kDoubleBendFixedEdges. These various results are shown in the pictures below.

kDoubleBendSingle

kDoubleBend90Degree

kDoubleBendFullRadius

kDoubleBend45Degree

kDoubleBendFixedEdges

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.DoubleBendType Property


BendDefinition.Edges Property

BendDefinition.Edges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the set of edges that define the location of this bend.

Visual Basic
Property Edges() As EdgeCollection*
Remarks

This property is not valid in the case where this bend definition is associated with a feature that does not provide access to the edges defining the bend. For example, a flange feature does not offer this option. In these cases, this property will return Nothing.

To best understand what's valid you should try creating the same feature interactively to see what edges can be selected to create a valid bend. It's this same set of edges that should be specified for the bend definition.

This property will often return an empty collection because the edges that were input to create a bend feature are consumed as part of the bend operation. Setting the end of part marker to before the bend feature will allow you to access the input edges.

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.Edges Property


BendDefinition.ExtendFaces Property

BendDefinition.ExtendFaces Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if the existing faces will be extended to the bend or if a perpendicular section should be created to connect to the bend.

Visual Basic
Property ExtendFaces() As VARIANT_BOOL
Remarks

A value of True indicates the existing faces will be extended. When a new BendDefinition object is created this property is initialized to False.

The pictures below illustrate the two results obtained with this option. The picture on the left illustrates the result when ExtendFaces is False. The original faces are left intact and the bend is extended to meet the face. In the picture on the right, the face is extended to meet the face.

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.ExtendFaces Property


BendDefinition.IsDoubleBendFirstEdgeFixed Property

BendDefinition.IsDoubleBendFirstEdgeFixed Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that's used in the case of double bends to specify which face remains fixed and which one is extended or trimmed.

Visual Basic
Property IsDoubleBendFirstEdgeFixed() As VARIANT_BOOL
Remarks

If True, the first edge of the pair of edges is the fixed edge, if False the second edge will be fixed.

This property is not valid in the case where this bend definition is associated with a feature that does not provide this functionality. For example, a flange feature does not offer this option. In these cases, the value of the property should be ignored.

When a new BendDefinition object is created this property is initialized to True so the first input edge will be fixed. In the pictures below, the edge on the lower part is the first edge specified. The picture on the left shows the first edge as fixed and the picture on the right shows the second edge as fixed.

The value of this property is ignored in the case where the bend is a single bend, (when the DoubleBendType argument is kDoubleBendSingle).

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.IsDoubleBendFirstEdgeFixed Property


BendDefinition.IsUnfoldMethodOverridden Property

BendDefinition.IsUnfoldMethodOverridden Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.

Visual Basic
Property IsUnfoldMethodOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.IsUnfoldMethodOverridden Property


BendDefinition.Parent Property

BendDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent feature of this BendDefinition object.

Visual Basic
Property Parent() As IDispatch**
Remarks

In the case where this is a newly created BendDefinition object or it has been copied from an existing BendDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.Parent Property


BendDefinition.Type Property

BendDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning enum indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.Type Property


BendDefinition.UnfoldMethod Property

BendDefinition.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the UnfoldMethod object that defines how this bend is unfolded.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
Remarks

The properties of this object can be modified to edit the associated feature. When the BendDefinition is initially created this is initialized to the active unfold method of the active sheet metal style.

The UnfoldMethod object returned remains associated with the BendDefinition object it is obtained from. This means that edits made to the UnfoldMethod object will affect the BendDefinition, and the feature if one exists. You can use the Copy method of the UnfoldMethod object to create an independent UnfoldMethod object.

You are here: Symbol Reference > Inventor Library > Objects > BendDefinition Interface > BendDefinition Properties > BendDefinition.UnfoldMethod Property


BendFeature Interface

BendFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The BendFeature object represents a sheet metal bend feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::BendFeature
        Inventor::BendFeatureProxy
Visual Basic
Public Interface BendFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

BendFeatures.Add

BendFeatures.Item

ContourFlangeFeature.BendFeature

FaceFeature.BendFeature

FlangeFeature.BendFeature

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > BendFeature Interface


BendFeature Properties

BendFeature Properties
Summary

The properties of the BendFeature class are listed here.

Properties
Name | Description
Definition | Property that gets the BendDefinition object associated with this bend feature.
You are here: Symbol Reference > Inventor Library > Objects > BendFeature Interface > BendFeature Properties


BendFeature.Definition Property

BendFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the BendDefinition object associated with this bend feature.

Visual Basic
Property Definition() As BendDefinition**
Remarks

The BendDefinition object returned remains associated with the feature is was obtained from and any changes made to the BendDefinition object will cause the feature to change.

You are here: Symbol Reference > Inventor Library > Objects > BendFeature Interface > BendFeature Properties > BendFeature.Definition Property


BendFeatureProxy Interface

BendFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BendFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::BendFeature
        Inventor::BendFeatureProxy
Visual Basic
Public Interface BendFeatureProxy
Inherits BendFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BendFeatureProxy Interface


BendFeatures Interface

BendFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The BendFeatures collection object provides access to all of the objects in a sheet metal component definition. It"s also through the BendFeatures object that you create new BendFeature objects.

Class Hierarchy
Inventor::BendFeatures
Visual Basic
Public Interface BendFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.BendFeatures

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface


BendFeatures Methods

BendFeatures Methods
Summary

The methods of the BendFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new bend feature. The newly created BendFeature object is returned.
CreateBendDefinition | Method that creates a new BendDefinition object. This object is not a bend feature but contains the information that defines bend information and can be used to help create a new feature that contains bends or edit the bend of an existing feature.
Item | Property that returns the specified BendFeature object from the collection. This is the default property of the BendFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Methods


BendFeatures.Add Method

BendFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new bend feature. The newly created BendFeature object is returned.

Visual Basic
Sub Add(BendDefinition As BendDefinition, Result As [out, retval] BendFeature*)
Parameters
Parameters | Description
BendDefinition | Input BendDefinition object that defines the bend feature you want to create. A BendDefinition object can be created using the BendFeatures.CreateBendDefinition method. It can also be obtained from an existing feature that has an associated bend.
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Methods > BendFeatures.Add Method


BendFeatures.CreateBendDefinition Method

BendFeatures.CreateBendDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new BendDefinition object. This object is not a bend feature but contains the information that defines bend information and can be used to help create a new feature that contains bends or edit the bend of an existing feature.

Visual Basic
Sub CreateBendDefinition(Edges As EdgeCollection, Result As [out, retval] BendDefinition*)
Parameters
Parameters | Description
Edges | Input EdgeCollection object that defines the existing edges on the sheet metal part that you want to create bends for. The EdgeCollection can contain either one or two edges depending on the geometry where you want to apply the bend and the type of feature the definition is being used with. To best understand what's valid you should try creating the same feature interactively to see what edges can be selected to create a valid bend.
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Methods > BendFeatures.CreateBendDefinition Method


BendFeatures.Item Method

BendFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified BendFeature object from the collection. This is the default property of the BendFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BendFeature*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the attribute set name. If an out-of-range index or a name of a nonexistent attribute set is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Methods > BendFeatures.Item Method


BendFeatures Properties

BendFeatures Properties
Summary

The properties of the BendFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Properties


BendFeatures.Application Property

BendFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Properties > BendFeatures.Application Property


BendFeatures.Count Property

BendFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Properties > BendFeatures.Count Property


BendFeatures.Type Property

BendFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendFeatures Interface > BendFeatures Properties > BendFeatures.Type Property


BendNote Interface

BendNote Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BendNote object represents a bend note on a sheet and derives from the LeaderNote object.

Class Hierarchy
Inventor::DrawingNote
    Inventor::LeaderNote
        Inventor::BendNote
Visual Basic
Public Interface BendNote
Inherits LeaderNote
Notes

Members through which this object may be accessed include:

BendNotes.Add

BendNotes.Item

See Also

Create bend note sample

You are here: Symbol Reference > Inventor Library > Objects > BendNote Interface


BendNote Properties

BendNote Properties
Summary

The properties of the BendNote class are listed here.

Properties
Name | Description
BendEdge | Property that returns the bend edge associated with the note.
FormattedBendNote | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
HideValue | Property that gets and sets whether to display the bend note value in the note.
UsePartUnits | Property that gets and sets whether to use model units or the units specified by dimension style. Model units are used if the property is set to True.
You are here: Symbol Reference > Inventor Library > Objects > BendNote Interface > BendNote Properties


BendNote.BendEdge Property

BendNote.BendEdge Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the bend edge associated with the note.

Visual Basic
Property BendEdge() As DrawingCurve**
You are here: Symbol Reference > Inventor Library > Objects > BendNote Interface > BendNote Properties > BendNote.BendEdge Property


BendNote.FormattedBendNote Property

BendNote.FormattedBendNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedBendNote() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BendNote Interface > BendNote Properties > BendNote.FormattedBendNote Property


BendNote.HideValue Property

BendNote.HideValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display the bend note value in the note.

Visual Basic
Property HideValue() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BendNote Interface > BendNote Properties > BendNote.HideValue Property


BendNote.UsePartUnits Property

BendNote.UsePartUnits Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use model units or the units specified by dimension style. Model units are used if the property is set to True.

Visual Basic
Property UsePartUnits() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BendNote Interface > BendNote Properties > BendNote.UsePartUnits Property


BendNotes Interface

BendNotes Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BendNotes collection object provides access to all of the bend notes on the sheet.

Class Hierarchy
Inventor::BendNotes
Visual Basic
Public Interface BendNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.BendNotes

See Also

Create bend note sample

You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface


BendNotes Methods

BendNotes Methods
Summary

The methods of the BendNotes class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a bend note based on the input bend edge on the sheet. The initial placement of the bend note will be along the bend edge without a leader.
Item | Property that returns the specified BendNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Methods


BendNotes.Add Method

BendNotes.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a bend note based on the input bend edge on the sheet. The initial placement of the bend note will be along the bend edge without a leader.

Visual Basic
Sub Add(BendEdge As DrawingCurve, ByRef DimensionStyle As [optional] VARIANT, Result As [out, retval] BendNote*)
Parameters
Parameters | Description
BendEdge | Input DrawingCurve object that specifies the bend edge to create the note for. If the DrawingCurve does not represent a bend edge, the method returns an error.
DimensionStyle | Optional input Variant that specifies which dimension style to use for the note. The dimension style can be specified by providing the name of an existing style or by supplying a DimensionStyle object.
Example

This sample demonstrates the creation of a bend note on the drawing view of a flat pattern. Select a bend edge on a flat pattern drawing view and run the sample.

Sub AddBendNote()

    ' Assumes that a drawing document is active
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Check to make sure a bend edge is selected.
    If oDoc.SelectSet.Count <> 1 Then
        MsgBox "A single bend edge must be selected."
        Exit Sub
    End If

    If Not TypeOf oDoc.SelectSet(1) Is DrawingCurveSegment Then
        MsgBox "A bend edge must be selected."
        Exit Sub
    End If

    Dim oBendEdge As DrawingCurve
    Set oBendEdge = oDoc.SelectSet(1).Parent

    If Not (oBendEdge.EdgeType = kBendUpEdge Or oBendEdge.EdgeType = kBendDownEdge) Then
        MsgBox "A bend edge must be selected."
        Exit Sub
    End If

    ' Create the bend note
    Dim oBendNote As BendNote
    Set oBendNote = oDoc.ActiveSheet.DrawingNotes.BendNotes.Add(oBendEdge)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Methods > BendNotes.Add Method


BendNotes.Item Method

BendNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified BendNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BendNote*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Methods > BendNotes.Item Method


BendNotes Properties

BendNotes Properties
Summary

The properties of the BendNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBendNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Properties


BendNotes.Application Property

BendNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Properties > BendNotes.Application Property


BendNotes.Count Property

BendNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Properties > BendNotes.Count Property


BendNotes.Type Property

BendNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBendNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendNotes Interface > BendNotes Properties > BendNotes.Type Property


BendOptions Interface

BendOptions Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The BendOptions object defines the settings that influence the creation of a bend in a sheet metal part.

Class Hierarchy
Inventor::BendOptions
Visual Basic
Public Interface BendOptions
Inherits IDispatch
Remarks

This object can be obtained from existing sheet metal features and the properties on the object modified to edit the feature. It can also be created using the SheetMetalFeatures.CreateBendOptions method so that you can define the bend options when creating a new sheet metal feature.

Notes

Members through which this object may be accessed include:

BendDefinition.BendOptions

BendOptions.Copy

ContourFlangeDefinition.BendOptions

CornerDefinition.BendOptions

FlangeDefinition.BendOptions

FoldDefinition.BendOptions

HemDefinition.BendOptions

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface


BendOptions Methods

BendOptions Methods
Summary

The methods of the BendOptions class are listed here.

Methods
Methods
Name | Description
Copy | Function that creates a copy of this BendOptions object.
You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Methods


BendOptions.Copy Method

BendOptions.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Function that creates a copy of this BendOptions object.

Visual Basic
Sub Copy(Result As [out, retval] BendOptions*)
You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Methods > BendOptions.Copy Method


BendOptions Properties

BendOptions Properties
Summary

The properties of the BendOptions class are listed here.

Properties
Name | Description
BendReliefDepth | Property that provides access to the bend relief depth of a sheet metal feature.
BendReliefShape | Property that defines the type of bend relief shape to use for the associated sheet metal feature.
BendReliefWidth | Property that provides access to the bend relief width of a sheet metal feature.
BendTransition | Property that defines the type of bend transition to use for the associated sheet metal feature.
BendTransitionArcRadius | Property that provides access to the radius for an arc bend transition.
MinimumRemnant | Property that provides access to the minimum remnant of a sheet metal feature.
Parent | Property that returns the parent object of this BendOptions object.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties


BendOptions.BendReliefDepth Property

BendOptions.BendReliefDepth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend relief depth of a sheet metal feature.

Visual Basic
Property BendReliefDepth() As VARIANT
Remarks

This property is writable when the BendOptions object is transient (not associated with a feature). The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendReliefDepth * 2' is valid, assuming there is a parameter named MyBendReliefDepth.

When the BendOptions object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend relief depth. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.BendReliefDepth Property


BendOptions.BendReliefShape Property

BendOptions.BendReliefShape Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that defines the type of bend relief shape to use for the associated sheet metal feature.

Visual Basic
Property BendReliefShape() As BendReliefShapeEnum
Remarks

This property is writable when the BendOptions object is transient (not associated with a feature). You can set the desired value before using the BendOptions object as input to create a sheet metal feature. When the BendOptions object has been obtained from an existing feature this property is read-only.

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.BendReliefShape Property


BendOptions.BendReliefWidth Property

BendOptions.BendReliefWidth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend relief width of a sheet metal feature.

Visual Basic
Property BendReliefWidth() As VARIANT
Remarks

This property is writable when the BendOptions object is transient (not associated with a feature). The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendReliefWidth * 2' is valid, assuming there is a parameter named MyBendReliefWidth.

When the BendOptions object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend relief width. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.BendReliefWidth Property


BendOptions.BendTransition Property

BendOptions.BendTransition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that defines the type of bend transition to use for the associated sheet metal feature.

Visual Basic
Property BendTransition() As BendTransitionEnum
You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.BendTransition Property


BendOptions.BendTransitionArcRadius Property

BendOptions.BendTransitionArcRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the radius for an arc bend transition.

Visual Basic
Property BendTransitionArcRadius() As VARIANT
Remarks

This property is only used in the case where the BendTransition property is set to kArcBendTransition, otherwise this property should be ignored. This property is writable when the BendOptions object is transient (not associated with a feature). The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyArcRadius * 2' is valid, assuming there is a parameter named MyArcRadius.

When the BendOptions object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the arc radius. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.BendTransitionArcRadius Property


BendOptions.MinimumRemnant Property

BendOptions.MinimumRemnant Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the minimum remnant of a sheet metal feature.

Visual Basic
Property MinimumRemnant() As VARIANT
Remarks

This property is writable when the BendOptions object is transient (not associated with a feature). The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyMinimumRemnant * 2' is valid, assuming there is a parameter named MyMinimumRemnant.

When the BendOptions object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the minimum remnant size. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.MinimumRemnant Property


BendOptions.Parent Property

BendOptions.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent object of this BendOptions object.

Visual Basic
Property Parent() As IDispatch**
Remarks

In the case where this is a newly created BendOptions object or it has been copied from an existing BendOptions object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.Parent Property


BendOptions.Type Property

BendOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendOptions Interface > BendOptions Properties > BendOptions.Type Property


BendPartFeature Interface

BendPartFeature Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The BendPartFeature object represents an existing bend part feature in an Inventor part document.

Class Hierarchy
Inventor::PartFeature
    Inventor::BendPartFeature
        Inventor::BendPartFeatureProxy
Visual Basic
Public Interface BendPartFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

BendPartFeatureProxy.NativeObject

BendPartFeatures.Add

BendPartFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface


BendPartFeature Methods

BendPartFeature Methods
Summary

The methods of the BendPartFeature class are listed here.

Methods
Methods
Name | Description
Edit | Method that edits the bend part feature using the new inputs.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Methods


BendPartFeature.Edit Method

BendPartFeature.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that edits the bend part feature using the new inputs.

Visual Basic
Sub Edit(BendLine As SketchLine, BendPartType As BendPartTypeEnum, InputOne As VARIANT, InputTwo As VARIANT, BendSide As PartFeatureExtentDirectionEnum, BendInSketchNormalDirection As VARIANT_BOOL, ByRef Body As [optional] VARIANT, ByRef BendMinimum As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
BendLine | Input SketchLine object that represents the bend line.
BendPartType | Input constant that indicates the type of the bend part feature. See Note 1.
InputOne | Input Variant that defines the first input for the bend arc. See Note 2.
InputTwo | Input Variant that defines the second input for the bend arc. See Note 3.
BendSide | Input constant that indicates which side of the model to bend. See Note 4
BendInSketchNormalDirection | Input boolean that indicates the bend direction. If True is specified, the model will be bent in the direction normal to the sketch on which the input bend line (sketch line) exists. If False is specified, the model will be bent in the direction opposite to the sketch normal. If no value is explicitly specified, the default value of True will be used.
BendMinimum | Optional Input boolean that indicates whether minimum bend should be applied. If True is specified, minium bend will be applied. If no value is explicitly specified, the default value of True will be used.
Notes

Note 1.

The BendPartType argument specifies the type of the input values used to define the bend arc. The values specified for the InputOne and InputTwo arguments will depend on the value specified for this argument.

The valid input is one of the constants in BendPartTypeEnum: kArcLengthAndAngleBendPart, kRadiusAndAngleBendPart and kRadiusAndArcLengthBendPart.

The following table describes how this argument determines the values that need to be specified for the InputOne and InputTwo arguments:

BendPartType | InputOne | InputTwo
kArcLengthAndAngleBendPart | Arc Length | Angle
kRadiusAndAngleBendPart | Radius | Angle
kRadiusAndArcLengthBendPart | Radius | Arc Length

For example, if kArcLengthAndAngleBendPart is specified for this argument, then the arc length value should be specified in the InputOne argument and the angle value should be specified in the InputTwo argument.

Note 2.

The InputOne parameter can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.

The type of the input value will be determined by the BendPartType argument. The following table shows what this input value should be based on the BendPartType argument:

BendPartType | InputOne
kArcLengthAndAngleBendPart | Arc Length
kRadiusAndAngleBendPart | Radius
kRadiusAndArcLengthBendPart | Radius

For example, if the bend is defined using the arc length and angle as indicated by the BendPartType argument being kArcLengthAndAngleBendPart, then this argument should be used to specify the arc length of the bend arc. Similarly, if the bend is defined using the radius and angle as indicated by the BendPartType argument being kRadiusAndAngleBendPart, then this argument should be used to specify the radius of the bend arc.

If a value is input, the units are the default database units (centimeters for distance and radians for angle). If a string is input, the units can be specified as part of the string or it will default to the current unit type for the document.

Note 3.

The InputTwo parameter can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.

The type of the input value will be determined by the BendPartType argument. The following table shows what this input value should be based on the BendPartType argument:

BendPartType | InputTwo
kArcLengthAndAngleBendPart | Angle
kRadiusAndAngleBendPart | Angle
kRadiusAndArcLengthBendPart | Arc Length

For example, if the bend is defined using the arc length and angle as indicated by the BendPartType argument being kArcLengthAndAngleBendPart, then this argument should be used to specify the angle of the bend arc. Similarly, if the bend is defined using the radius and arc length as indicated by the BendPartType argument being kRadiusAndArcLengthBendPart, then this argument should be used to specify the arc length of the bend arc. If a value is input, the units are the default database units (centimeters for distance and radians for angle). If a string is input, the units can be specified as part of the string or it will default to the current unit type for the document.

Note 4.

The bend side is specified with respect to the input bend line (sketch line), i.e. whether the model to the left, right or both sides of the bend line should be bent. The left side is the natural normal direction at any point on the sketch line (the cross-product of the vector representing the direction of the sketch line and the vector representing the sketch normal). The right side refers to the direction opposite to that of the natural normal. The following figure demonstrates an example of how the bend side is determined based on the normal direction of the sketch line.

The figure represents a model in which a sketch plane has been drawn on the rectangular side face. The sketch plane consists of a single sketch line which represents the bend line. The sketch plane normal direction is perpendicular to the face and coming out of the model. The direction of the sketch line which can be inferred from the start point and end points of the sketch line is towards the right. Therefore, the normal vector at any point on the sketch line is pointing in the downward direction (imagine standing on the normal side of the sketch plane and viewing in the direction of the sketch line, the normal of the sketch line will be towards your right). For the bend part feature, the left side of the bend corresponds to this normal direction of the sketch line. As indicated by the preview in the figure, when the left side is specified, the model in the normal direction of the sketch line is selected for the bend.

The valid input is one of the constants in PartFeatureExtentDirectionEnum: kNegativeExtentDirection, kPositiveExtentDirection or kSymmetricExtentDirection.

  • If kNegativeExtentDirection is specified, the model on the left side of the input bend line will be bent.
  • If kPositiveExtentDirection is specified, the model on the right side of the input bend line will be bent.
  • If kSymmetricExtentDirection is specified, the model on both sides of the input bend line will be bent.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Methods > BendPartFeature.Edit Method


BendPartFeature Properties

BendPartFeature Properties
Summary

The properties of the BendPartFeature class are listed here.

Properties
Name | Description
BendInSketchNormalDirection | Property that specifies the bend direction.
BendLine | Property that gets and sets the sketch line that represents the bend line.
BendMinimum | Property that indicates whether minimum bend should be applied. If True is specified, minium bend will be applied.
BendPartType | Property that returns the type of the bend part feature. The valid return values are kArcLengthAndAngleBendPart, kRadiusAndAngleBendPart and kRadiusAndArcLengthBendPart.
BendSide | Property that specifies which side of the model to bend.
InputOne | Input Variant that defines the first input for the bend arc.
InputTwo | Input Variant that defines the second input for the bend arc.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties


BendPartFeature.BendInSketchNormalDirection Property

BendPartFeature.BendInSketchNormalDirection Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the bend direction.

Visual Basic
Property BendInSketchNormalDirection() As VARIANT_BOOL
Returns

If True is specified, the model will be bent in the direction normal to the sketch on which the bend line (sketch line) exists. If False is specified, the model will be bent in the direction opposite to the sketch normal.

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.BendInSketchNormalDirection Property


BendPartFeature.BendLine Property

BendPartFeature.BendLine Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the sketch line that represents the bend line.

Visual Basic
Property BendLine() As SketchLine*
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.BendLine Property


BendPartFeature.BendMinimum Property

BendPartFeature.BendMinimum Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates whether minimum bend should be applied. If True is specified, minium bend will be applied.

Visual Basic
Property BendMinimum() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.BendMinimum Property


BendPartFeature.BendPartType Property

BendPartFeature.BendPartType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the type of the bend part feature. The valid return values are kArcLengthAndAngleBendPart, kRadiusAndAngleBendPart and kRadiusAndArcLengthBendPart.

Visual Basic
Property BendPartType() As BendPartTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.BendPartType Property


BendPartFeature.BendSide Property

BendPartFeature.BendSide Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which side of the model to bend.

Visual Basic
Property BendSide() As PartFeatureExtentDirectionEnum
Remarks

The bend side is specified with respect to the bend line (sketch line), i.e. whether the model to the left, right or both sides of the bend line should be bent. The left side is the natural normal direction at any point on the sketch line (the cross-product of the vector representing the direction of the sketch line and the vector representing the sketch normal). The right side refers to the direction opposite to that of the natural normal.

The valid input is one of the constants in PartFeatureExtentDirectionEnum: kNegativeExtentDirection, kPositiveExtentDirection or kSymmetricExtentDirection.

  • If kNegativeExtentDirection is specified, the model on the left side of the bend line will be bent.
  • If kPositiveExtentDirection is specified, the model on the right side of the bend line will be bent.
  • If kSymmetricExtentDirection is specified, the model on both sides of the bend line will be bent.

The figure below represents a model in which a sketch plane has been drawn on the rectangular side face. The sketch plane consists of a single sketch line which represents the bend line. The sketch plane normal direction is perpendicular to the face and coming out of the model. The direction of the sketch line which can be inferred from the start point and end points of the sketch line is towards the right. Therefore, the normal vector at any point on the sketch line is pointing in the downward direction (imagine standing on the normal side of the sketch plane and viewing in the direction of the sketch line, the normal of the sketch line will be towards your right). For the bend part feature, the left side of the bend corresponds to this normal direction of the sketch line. As indicated by the preview in the figure, when the left side is specified, the model in the normal direction of the sketch line is selected for the bend.

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.BendSide Property


BendPartFeature.InputOne Property

BendPartFeature.InputOne Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Input Variant that defines the first input for the bend arc.

Visual Basic
Property InputOne() As Parameter**
Remarks

This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.

The type of the input value will be determined by the BendPartType argument. The following table shows what this input value should be based on the BendPartType argument:

  • kArcLengthAndAngleBendPart where InputOne = Arc Length
  • kRadiusAndAngleBendPart where InputOne = Radius
  • kRadiusAndArcLengthBendPart where InputOne = Radius

For example, if the bend is defined using the arc length and angle as indicated by the BendPartType argument being kArcLengthAndAngleBendPart, then this argument should be used to specify the arc length of the bend arc. Similarly, if the bend is defined using the radius and angle as indicated by the BendPartType argument being kRadiusAndAngleBendPart, then this argument should be used to specify the radius of the bend arc.

If a value is input, the units are the default database units (centimeters for distance and radians for angle). If a string is input, the units can be specified as part of the string or it will default to the current unit type for the document.

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.InputOne Property


BendPartFeature.InputTwo Property

BendPartFeature.InputTwo Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Input Variant that defines the second input for the bend arc.

Visual Basic
Property InputTwo() As Parameter**
Remarks

This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.

The type of the input value will be determined by the BendPartType argument. The following table shows what this input value should be based on the BendPartType argument:

  • kArcLengthAndAngleBendPart where InputTwo = Angle
  • kRadiusAndAngleBendPart where InputTwo = Angle
  • kRadiusAndArcLengthBendPart where InputTwo = Arc Length

For example, if the bend is defined using the arc length and angle as indicated by the BendPartType argument being kArcLengthAndAngleBendPart, then this argument should be used to specify the angle of the bend arc. Similarly, if the bend is defined using the radius and arc length as indicated by the BendPartType argument being kRadiusAndArcLengthBendPart, then this argument should be used to specify the arc length of the bend arc. If a value is input, the units are the default database units (centimeters for distance and radians for angle). If a string is input, the units can be specified as part of the string or it will default to the current unit type for the document.

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeature Interface > BendPartFeature Properties > BendPartFeature.InputTwo Property


BendPartFeatureProxy Interface

BendPartFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BendPartFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::BendPartFeature
        Inventor::BendPartFeatureProxy
Visual Basic
Public Interface BendPartFeatureProxy
Inherits BendPartFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatureProxy Interface


BendPartFeatureProxy Properties

BendPartFeatureProxy Properties
Summary

The properties of the BendPartFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatureProxy Interface > BendPartFeatureProxy Properties


BendPartFeatureProxy.ContainingOccurrence Property

BendPartFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatureProxy Interface > BendPartFeatureProxy Properties > BendPartFeatureProxy.ContainingOccurrence Property


BendPartFeatureProxy.NativeObject Property

BendPartFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As BendPartFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatureProxy Interface > BendPartFeatureProxy Properties > BendPartFeatureProxy.NativeObject Property


BendPartFeatures Interface

BendPartFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The BendPartFeatures collection object provides access to existing bend part features and supports the ability to create new bend part features.

Class Hierarchy
Inventor::BendPartFeatures
Visual Basic
Public Interface BendPartFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.BendPartFeatures

You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface


BendPartFeatures Methods

BendPartFeatures Methods
Summary

The methods of the BendPartFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new bend part feature. If the bend part feature is created successfully, a BendPartFeature object corresponding to the newly created bend part feature is returned.
Item | Returns the specified BendPartFeature object from the collection. This is the default property of the BendPartFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Methods


BendPartFeatures.Add Method

BendPartFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new bend part feature. If the bend part feature is created successfully, a BendPartFeature object corresponding to the newly created bend part feature is returned.

Visual Basic
Sub Add(BendLine As SketchLine, BendPartType As BendPartTypeEnum, InputOne As VARIANT, InputTwo As VARIANT, BendSide As PartFeatureExtentDirectionEnum, BendInSketchNormalDirection As VARIANT_BOOL, ByRef Body As [optional] VARIANT, ByRef BendMinimum As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] BendPartFeature*)
Parameters
Parameters | Description
BendLine | Input SketchLine object that represents the bend line.
BendPartType | Input constant that indicates the type of the bend part feature. See Note 1.
InputOne | Input Variant that defines the first input for the bend arc. See Note 2.
InputTwo | Input Variant that defines the second input for the bend arc. See Note 3.
BendSide | Input constant that indicates which side of the model to bend. See Note 4
BendInSketchNormalDirection | Input boolean that indicates the bend direction. If True is specified, the model will be bent in the direction normal to the sketch on which the input bend line (sketch line) exists. If False is specified, the model will be bent in the direction opposite to the sketch normal. If no value is explicitly specified, the default value of True will be used.
Body | Optional input SurfaceBody object that specifies the solid body to bend. If not specified, a default body is chosen in the case of multi solid body parts.
BendMinimum | Optional Input boolean that indicates whether minimum bend should be applied. If True is specified, minium bend will be applied. If no value is explicitly specified, the default value of True will be used.
Notes

Note 1.

The BendPartType argument specifies the type of the input values used to define the bend arc. The values specified for the InputOne and InputTwo arguments will depend on the value specified for this argument.

The valid input is one of the constants in BendPartTypeEnum: kArcLengthAndAngleBendPart, kRadiusAndAngleBendPart and kRadiusAndArcLengthBendPart.

The following table describes how this argument determines the values that need to be specified for the InputOne and InputTwo arguments:

BendPartType | InputOne | InputTwo
kArcLengthAndAngleBendPart | Arc Length | Angle
kRadiusAndAngleBendPart | Radius | Angle
kRadiusAndArcLengthBendPart | Radius | Arc Length

For example, if kArcLengthAndAngleBendPart is specified for this argument, then the arc length value should be specified in the InputOne argument and the angle value should be specified in the InputTwo argument.

Note 2.

The InputOne parameter can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.

The type of the input value will be determined by the BendPartType argument. The following table shows what this input value should be based on the BendPartType argument:

BendPartType | InputOne
kArcLengthAndAngleBendPart | Arc Length
kRadiusAndAngleBendPart | Radius
kRadiusAndArcLengthBendPart | Radius

For example, if the bend is defined using the arc length and angle as indicated by the BendPartType argument being kArcLengthAndAngleBendPart, then this argument should be used to specify the arc length of the bend arc. Similarly, if the bend is defined using the radius and angle as indicated by the BendPartType argument being kRadiusAndAngleBendPart, then this argument should be used to specify the radius of the bend arc.

If a value is input, the units are the default database units (centimeters for distance and radians for angle). If a string is input, the units can be specified as part of the string or it will default to the current unit type for the document.

Note 3.

The InputTwo parameter can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.

The type of the input value will be determined by the BendPartType argument. The following table shows what this input value should be based on the BendPartType argument:

BendPartType | InputTwo
kArcLengthAndAngleBendPart | Angle
kRadiusAndAngleBendPart | Angle
kRadiusAndArcLengthBendPart | Arc Length

For example, if the bend is defined using the arc length and angle as indicated by the BendPartType argument being kArcLengthAndAngleBendPart, then this argument should be used to specify the angle of the bend arc. Similarly, if the bend is defined using the radius and arc length as indicated by the BendPartType argument being kRadiusAndArcLengthBendPart, then this argument should be used to specify the arc length of the bend arc. If a value is input, the units are the default database units (centimeters for distance and radians for angle). If a string is input, the units can be specified as part of the string or it will default to the current unit type for the document.

Note 4.

The bend side is specified with respect to the input bend line (sketch line), i.e. whether the model to the left, right or both sides of the bend line should be bent. The left side is the natural normal direction at any point on the sketch line (the cross-product of the vector representing the direction of the sketch line and the vector representing the sketch normal). The right side refers to the direction opposite to that of the natural normal. The following figure demonstrates an example of how the bend side is determined based on the normal direction of the sketch line.

The figure represents a model in which a sketch plane has been drawn on the rectangular side face. The sketch plane consists of a single sketch line which represents the bend line. The sketch plane normal direction is perpendicular to the face and coming out of the model. The direction of the sketch line which can be inferred from the start point and end points of the sketch line is towards the right. Therefore, the normal vector at any point on the sketch line is pointing in the downward direction (imagine standing on the normal side of the sketch plane and viewing in the direction of the sketch line, the normal of the sketch line will be towards your right). For the bend part feature, the left side of the bend corresponds to this normal direction of the sketch line. As indicated by the preview in the figure, when the left side is specified, the model in the normal direction of the sketch line is selected for the bend.

The valid input is one of the constants in PartFeatureExtentDirectionEnum: kNegativeExtentDirection, kPositiveExtentDirection or kSymmetricExtentDirection.

  • If kNegativeExtentDirection is specified, the model on the left side of the input bend line will be bent.
  • If kPositiveExtentDirection is specified, the model on the right side of the input bend line will be bent.
  • If kSymmetricExtentDirection is specified, the model on both sides of the input bend line will be bent.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Methods > BendPartFeatures.Add Method


BendPartFeatures.Item Method

BendPartFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns the specified BendPartFeature object from the collection. This is the default property of the BendPartFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BendPartFeature*)
Parameters
Parameters | Description
index | Value that specifies the index of the BendPartFeature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the attribute set name. If an out-of-range index or a name of a nonexistent attribute set is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Methods > BendPartFeatures.Item Method


BendPartFeatures Properties

BendPartFeatures Properties
Summary

The properties of the BendPartFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Properties


BendPartFeatures.Application Property

BendPartFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Properties > BendPartFeatures.Application Property


BendPartFeatures.Count Property

BendPartFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Properties > BendPartFeatures.Count Property


BendPartFeatures.Type Property

BendPartFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendPartFeatures Interface > BendPartFeatures Properties > BendPartFeatures.Type Property


BendsEnumerator Interface

BendsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BendsEnumerator object represents all of the bends in a sheet metal part.

Class Hierarchy
Inventor::BendsEnumerator
Visual Basic
Public Interface BendsEnumerator
Inherits IDispatch
Remarks

These are the logical bends in the part and are not necessarily created using any specific sheet metal features. For example, a sheet metal part imported from a STEP file does not have any Inventor sheet metal features but does have logical bends. The bends returned can be bends in both the bent and flat state.

Notes

Members through which this object may be accessed include:

RefoldFeature.Bends

SheetMetalComponentDefinition.Bends

UnfoldFeature.Bends

You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface


BendsEnumerator Methods

BendsEnumerator Methods
Summary

The methods of the BendsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified Bend object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface > BendsEnumerator Methods


BendsEnumerator.Item Method

BendsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified Bend object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Bend*)
Parameters
Parameters | Description
Index | Input Long or Face object that specifies the Bend object within the collection to return. Inputting a Long indicates the index of the Bend within the collection to return. When a Face object is input the Bend that contains that face is returned. If the index is out of range or the input face is not part of a bend this property will fail.
You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface > BendsEnumerator Methods > BendsEnumerator.Item Method


BendsEnumerator Properties

BendsEnumerator Properties
Summary

The properties of the BendsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of Bend objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface > BendsEnumerator Properties


BendsEnumerator.Application Property

BendsEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface > BendsEnumerator Properties > BendsEnumerator.Application Property


BendsEnumerator.Count Property

BendsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of Bend objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface > BendsEnumerator Properties > BendsEnumerator.Count Property


BendsEnumerator.Type Property

BendsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BendsEnumerator Interface > BendsEnumerator Properties > BendsEnumerator.Type Property


BIMCableTrayConnectorDefinition Interface

BIMCableTrayConnectorDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents the various settings that can be defined for a cable tray connector.

Class Hierarchy
Inventor::BIMConnectorDefinition
    Inventor::BIMCableTrayConnectorDefinition
Visual Basic
Public Interface BIMCableTrayConnectorDefinition
Inherits BIMConnectorDefinition
Remarks

This object doesn’t represent the actual connector but only represents the settings and is used in the creation, query, and edit of a connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface


BIMCableTrayConnectorDefinition Properties

BIMCableTrayConnectorDefinition Properties
Summary

The properties of the BIMCableTrayConnectorDefinition class are listed here.

Properties
Name | Description
ConnectionType | Property that specifies the connection type for this cable tray connector.
Height | Property that provides access to the connector height.
HeightOverride | Property that gets and sets the height override for this connector.
Width | Property that provides access to the connector width.
WidthOverride | Property that gets and sets the width override for this connector.
You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface > BIMCableTrayConnectorDefinition Properties


BIMCableTrayConnectorDefinition.ConnectionType Property

BIMCableTrayConnectorDefinition.ConnectionType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the connection type for this cable tray connector.

Visual Basic
Property ConnectionType() As BIMCableTrayConnectionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface > BIMCableTrayConnectorDefinition Properties > BIMCableTrayConnectorDefinition.ConnectionType Property


BIMCableTrayConnectorDefinition.Height Property

BIMCableTrayConnectorDefinition.Height Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector height.

Visual Basic
Property Height() As VARIANT*
Remarks

When the BIMCableTrayConnectorDefinition object has been created using the CreateCableTrayConnectorDefinition method, this property returns a Double indicating the height, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the height of the connector.

To change the height of an existing connector, you can either edit the geometry that’s controlling the height or set the override height using the HeightOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface > BIMCableTrayConnectorDefinition Properties > BIMCableTrayConnectorDefinition.Height Property


BIMCableTrayConnectorDefinition.HeightOverride Property

BIMCableTrayConnectorDefinition.HeightOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the height override for this connector.

Visual Basic
Property HeightOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the height. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the height.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface > BIMCableTrayConnectorDefinition Properties > BIMCableTrayConnectorDefinition.HeightOverride Property


BIMCableTrayConnectorDefinition.Width Property

BIMCableTrayConnectorDefinition.Width Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector width.

Visual Basic
Property Width() As VARIANT*
Remarks

When the BIMCableTrayConnectorDefinition object has been created using the CreateCableTrayConnectorDefinition method, this property returns a Double indicating the width, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the width of the connector.

To change the width of an existing connector, you can either edit the geometry that’s controlling the width or set the override width using the WidthOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface > BIMCableTrayConnectorDefinition Properties > BIMCableTrayConnectorDefinition.Width Property


BIMCableTrayConnectorDefinition.WidthOverride Property

BIMCableTrayConnectorDefinition.WidthOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the width override for this connector.

Visual Basic
Property WidthOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the width. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the width.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

You are here: Symbol Reference > Inventor Library > Objects > BIMCableTrayConnectorDefinition Interface > BIMCableTrayConnectorDefinition Properties > BIMCableTrayConnectorDefinition.WidthOverride Property


BIMComponent Interface

BIMComponent Interface Available in Inventor Introduced in Inventor 16
Summary

Object that provides access to all of the BIM related information associated with an Inventor document.

Class Hierarchy
Inventor::BIMComponent
Visual Basic
Public Interface BIMComponent
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface


BIMComponent Methods

BIMComponent Methods
Summary

The methods of the BIMComponent class are listed here.

Methods
Methods
Name | Description
ExportBuildingComponent | Method that exports the BIM component as an adsk file.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Methods


BIMComponent.ExportBuildingComponent Method

BIMComponent.ExportBuildingComponent Method
Summary

Method that exports the BIM component as an adsk file.

Visual Basic
Sub ExportBuildingComponent(FullFilename As String)
Parameters
Parameters | Description
FullFilename | Input String that defines the full filename to write the building component to. The filename should have an adsk extension.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Methods > BIMComponent.ExportBuildingComponent Method


BIMComponent Properties

BIMComponent Properties
Summary

The properties of the BIMComponent class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ComponentDefinition | Property that returns the Inventor PartComponentDefinition or AssemblyComponentDefinition that this BIMComponent object is associated with.
ComponentDescription | Property that returns the BIMComponentDescription object associated this document.
ConnectorLinks | Property that returns the collection of connector links for this document.
Connectors | Property that returns the collection of connectors for this document.
Type | Property returning kBIMComponentObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties


BIMComponent.Application Property

BIMComponent.Application Property
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties > BIMComponent.Application Property


BIMComponent.ComponentDefinition Property

BIMComponent.ComponentDefinition Property
Summary

Property that returns the Inventor PartComponentDefinition or AssemblyComponentDefinition that this BIMComponent object is associated with.

Visual Basic
Property ComponentDefinition() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties > BIMComponent.ComponentDefinition Property


BIMComponent.ComponentDescription Property

BIMComponent.ComponentDescription Property
Summary

Property that returns the BIMComponentDescription object associated this document.

Visual Basic
Property ComponentDescription() As BIMComponentDescription**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties > BIMComponent.ComponentDescription Property


BIMComponent.ConnectorLinks Property

BIMComponent.ConnectorLinks Property
Summary

Property that returns the collection of connector links for this document.

Visual Basic
Property ConnectorLinks() As BIMConnectorLinks**
Remarks

Through the returned object you can access all existing links between connectors and create new links between connectors.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties > BIMComponent.ConnectorLinks Property


BIMComponent.Connectors Property

BIMComponent.Connectors Property
Summary

Property that returns the collection of connectors for this document.

Visual Basic
Property Connectors() As BIMConnectors**
Remarks

Through the returned object you can access all existing connectors and create new connectors.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties > BIMComponent.Connectors Property


BIMComponent.Type Property

BIMComponent.Type Property
Summary

Property returning kBIMComponentObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponent Interface > BIMComponent Properties > BIMComponent.Type Property


BIMComponentDescription Interface

BIMComponentDescription Interface Available in Inventor Introduced in Inventor 16
Summary

Object that provides access to component description of the document.

Class Hierarchy
Inventor::BIMComponentDescription
Visual Basic
Public Interface BIMComponentDescription
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface


BIMComponentDescription Methods

BIMComponentDescription Methods
Summary

The methods of the BIMComponentDescription class are listed here.

Methods
Methods
Name | Description
SetCustomThumbnail | Method that lets you set the custom thumbnail by providing the filename of an image file.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Methods


BIMComponentDescription.SetCustomThumbnail Method

BIMComponentDescription.SetCustomThumbnail Method
Summary

Method that lets you set the custom thumbnail by providing the filename of an image file.

Visual Basic
Sub SetCustomThumbnail(FullFilename As String)
Notes

The file should be a bmp, jpg, or png format and should be 256x256 pixels.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Methods > BIMComponentDescription.SetCustomThumbnail Method


BIMComponentDescription Properties

BIMComponentDescription Properties
Summary

The properties of the BIMComponentDescription class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ComponentPropertySets | Property that returns the collection object containing the property sets for a BIM component.
ComponentType | Property that gets and sets the component type.
ModelProperties | Property that gets and sets the standard Inventor iProperties that are exported with this component.
Orientation | Property that defines which coordinate system to use when exporting the component.
Thumbnail | Property that gets and sets the thumbnail for this component.
Type | Property returning kBIMComponentDescription Object indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties


BIMComponentDescription.Application Property

BIMComponentDescription.Application Property
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.Application Property


BIMComponentDescription.ComponentPropertySets Property

BIMComponentDescription.ComponentPropertySets Property
Summary

Property that returns the collection object containing the property sets for a BIM component.

Visual Basic
Property ComponentPropertySets() As BIMComponentPropertySets**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.ComponentPropertySets Property


BIMComponentDescription.ComponentType Property

BIMComponentDescription.ComponentType Property
Summary

Property that gets and sets the component type.

Visual Basic
Property ComponentType() As String
Remarks

A component type is identified by a category ID. The list of available components is defined in the file:

[Design Data]\BIM Exchange\Support\AuthoringTemplates\Categories.xml

An example of a valid component type is “23.30.10.11.24.11”, which specifies the “Structural Doors Sections” category.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.ComponentType Property


BIMComponentDescription.ModelProperties Property

BIMComponentDescription.ModelProperties Property
Summary

Property that gets and sets the standard Inventor iProperties that are exported with this component.

Visual Basic
Property ModelProperties() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.ModelProperties Property


BIMComponentDescription.Orientation Property

BIMComponentDescription.Orientation Property
Summary

Property that defines which coordinate system to use when exporting the component.

Visual Basic
Property Orientation() As UserCoordinateSystem*
Remarks

By default the value of this property is Nothing, which indicates that the model origin is to be used.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.Orientation Property


BIMComponentDescription.Thumbnail Property

BIMComponentDescription.Thumbnail Property
Summary

Property that gets and sets the thumbnail for this component.

Visual Basic
Property Thumbnail() As IPictureDisp*
Remarks

This property can only be used when your application is running in the same process as the Inventor application. If you’re running out of process then you can use the SetCustomThumbnail property to set the thumbnail using a file on disk.

Notes

The bitmap file should be a bmp, jpg, or png format and should be 256x256 pixels. Setting this property to Nothing will result in an automatic thumbnail being generated.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.Thumbnail Property


BIMComponentDescription.Type Property

BIMComponentDescription.Type Property
Summary

Property returning kBIMComponentDescription Object indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentDescription Interface > BIMComponentDescription Properties > BIMComponentDescription.Type Property


BIMComponentProperty Interface

BIMComponentProperty Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents a single BIM property.

Class Hierarchy
Inventor::BIMComponentProperty
Visual Basic
Public Interface BIMComponentProperty
Inherits IDispatch
Remarks

These are the properties shown in the Component Properties area of the Export Building Components dialog.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface


BIMComponentProperty Properties

BIMComponentProperty Properties
Summary

The properties of the BIMComponentProperty class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
InternalName | Property that gets the internal name of this component property.
Name | Property that gets the visible name of this property.
Parent | Property that returns the parent BIMComponentPropertySet object of this object.
Type | Property returning kBIMComponentProperty indicating this object’s type.
Value | Property that gets the value of this BIM property.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties


BIMComponentProperty.Application Property

BIMComponentProperty.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties > BIMComponentProperty.Application Property


BIMComponentProperty.InternalName Property

BIMComponentProperty.InternalName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the internal name of this component property.

Visual Basic
Property InternalName() As BSTR*
Remarks

This name is consistent and can be used as a reliable index for this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties > BIMComponentProperty.InternalName Property


BIMComponentProperty.Name Property

BIMComponentProperty.Name Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the visible name of this property.

Visual Basic
Property Name() As BSTR*
Remarks

This is the name shown to the end-user in the Component Properties list in the Export Building Components dialog. This name is localized and can change for different languages.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties > BIMComponentProperty.Name Property


BIMComponentProperty.Parent Property

BIMComponentProperty.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent BIMComponentPropertySet object of this object.

Visual Basic
Property Parent() As BIMComponentPropertySet**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties > BIMComponentProperty.Parent Property


BIMComponentProperty.Type Property

BIMComponentProperty.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMComponentProperty indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties > BIMComponentProperty.Type Property


BIMComponentProperty.Value Property

BIMComponentProperty.Value Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the value of this BIM property.

Visual Basic
Property Value() As String
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentProperty Interface > BIMComponentProperty Properties > BIMComponentProperty.Value Property


BIMComponentPropertySet Interface

BIMComponentPropertySet Interface Available in Inventor Introduced in Inventor 2012
Summary

Collection object that provides access to all of the BIM properties associated with this BIM property set.

Class Hierarchy
Inventor::BIMComponentPropertySet
Visual Basic
Public Interface BIMComponentPropertySet
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface


BIMComponentPropertySet Properties

BIMComponentPropertySet Properties
Summary

The properties of the BIMComponentPropertySet class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the total number of BIM component property sets this BIM document.
InternalName | Property that gets the internal name of this property set. This name is consistent and can be used as a reliable index for this property set.
Name | Property that gets the visible name of this property set.
Parent | Property that returns the parent BIMComponent object of this object.
Type | Property returning kBIMComponentPropertySet indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties


BIMComponentPropertySet.Application Property

BIMComponentPropertySet.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties > BIMComponentPropertySet.Application Property


BIMComponentPropertySet.Count Property

BIMComponentPropertySet.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the total number of BIM component property sets this BIM document.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties > BIMComponentPropertySet.Count Property


BIMComponentPropertySet.InternalName Property

BIMComponentPropertySet.InternalName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the internal name of this property set. This name is consistent and can be used as a reliable index for this property set.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties > BIMComponentPropertySet.InternalName Property


BIMComponentPropertySet.Name Property

BIMComponentPropertySet.Name Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the visible name of this property set.

Visual Basic
Property Name() As BSTR*
Remarks

This is the name shown to the end-user in the Component Properties list in the Export Building Components dialog. This name is localized and can change for different languages.

You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties > BIMComponentPropertySet.Name Property


BIMComponentPropertySet.Parent Property

BIMComponentPropertySet.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent BIMComponent object of this object.

Visual Basic
Property Parent() As BIMComponent**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties > BIMComponentPropertySet.Parent Property


BIMComponentPropertySet.Type Property

BIMComponentPropertySet.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMComponentPropertySet indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySet Interface > BIMComponentPropertySet Properties > BIMComponentPropertySet.Type Property


BIMComponentPropertySets Interface

BIMComponentPropertySets Interface Available in Inventor Introduced in Inventor 2012
Summary

Collection object that provides access to all of the BIM property sets associated with this component.

Class Hierarchy
Inventor::BIMComponentPropertySets
Visual Basic
Public Interface BIMComponentPropertySets
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySets Interface


BIMComponentPropertySets Properties

BIMComponentPropertySets Properties
Summary

The properties of the BIMComponentPropertySets class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Poperty that returns the total number of BIM component property sets this BIM document.
Type | Property returning kBIMComponentPropertySets indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySets Interface > BIMComponentPropertySets Properties


BIMComponentPropertySets.Application Property

BIMComponentPropertySets.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySets Interface > BIMComponentPropertySets Properties > BIMComponentPropertySets.Application Property


BIMComponentPropertySets.Count Property

BIMComponentPropertySets.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Poperty that returns the total number of BIM component property sets this BIM document.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySets Interface > BIMComponentPropertySets Properties > BIMComponentPropertySets.Count Property


BIMComponentPropertySets.Type Property

BIMComponentPropertySets.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMComponentPropertySets indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMComponentPropertySets Interface > BIMComponentPropertySets Properties > BIMComponentPropertySets.Type Property


BIMConduitConnectorDefinition Interface

BIMConduitConnectorDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents the various settings that can be defined for a conduit connector.

Class Hierarchy
Inventor::BIMConnectorDefinition
    Inventor::BIMConduitConnectorDefinition
Visual Basic
Public Interface BIMConduitConnectorDefinition
Inherits BIMConnectorDefinition
Remarks

This object doesn’t represent the actual connector but only represents the settings and is used in the creation, query, and edit of a connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMConduitConnectorDefinition Interface


BIMConduitConnectorDefinition Properties

BIMConduitConnectorDefinition Properties
Summary

The properties of the BIMConduitConnectorDefinition class are listed here.

Properties
Name | Description
ConnectionType | Property that specifies the connection type for this conduit connector.
Diameter | Property that provides access to the connector diameter.
DiameterOverride | Property that gets and sets the diameter override for this connector.
You are here: Symbol Reference > Inventor Library > Objects > BIMConduitConnectorDefinition Interface > BIMConduitConnectorDefinition Properties


BIMConduitConnectorDefinition.ConnectionType Property

BIMConduitConnectorDefinition.ConnectionType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the connection type for this conduit connector.

Visual Basic
Property ConnectionType() As BIMConduitConnectionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > BIMConduitConnectorDefinition Interface > BIMConduitConnectorDefinition Properties > BIMConduitConnectorDefinition.ConnectionType Property


BIMConduitConnectorDefinition.Diameter Property

BIMConduitConnectorDefinition.Diameter Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector diameter.

Visual Basic
Property Diameter() As VARIANT*
Remarks

When the BIMConduitConnectorDefinition object has been created using the CreateConduitConnectorDefinition method, this property returns a Double indicating the diameter, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the diameter of the connector.

To change the diameter of an existing connector you can either edit the geometry that’s controlling the diameter or set the override diameter using the DiameterOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMConduitConnectorDefinition Interface > BIMConduitConnectorDefinition Properties > BIMConduitConnectorDefinition.Diameter Property


BIMConduitConnectorDefinition.DiameterOverride Property

BIMConduitConnectorDefinition.DiameterOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the diameter override for this connector.

Visual Basic
Property DiameterOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the diameter. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the diameter.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

You are here: Symbol Reference > Inventor Library > Objects > BIMConduitConnectorDefinition Interface > BIMConduitConnectorDefinition Properties > BIMConduitConnectorDefinition.DiameterOverride Property


BIMConnector Interface

BIMConnector Interface Available in Inventor Introduced in Inventor 2012
Summary

Base class object for all of the various BIM connector objects.

Class Hierarchy
Inventor::BIMConnector
Visual Basic
Public Interface BIMConnector
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface


BIMConnector Methods

BIMConnector Methods
Summary

The methods of the BIMConnector class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the connector.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Methods


BIMConnector.Delete Method

BIMConnector.Delete Method Available in Inventor Introduced in Inventor 2012
Summary

Method that deletes the connector.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Methods > BIMConnector.Delete Method


BIMConnector.GetReferenceKey Method

BIMConnector.GetReferenceKey Method
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context is used for B-Rep entities (SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects) but is ignored for other entity types, including BIMConnector objects.
Remarks

A reference key is an array of bytes that can be used as a persistent reference for an entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Methods > BIMConnector.GetReferenceKey Method


BIMConnector Properties

BIMConnector Properties
Summary

The properties of the BIMConnector class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Definition | Property that gets the definition object associated with this connector.
DefinitionType | Property that returns the type of definition associated with this connector.
Name | Property that gets and sets the displayed name of the connector.
Parent | Property that returns the parent BimComponent object.
Suppressed | Property that defines whether the connector is suppressed or not.
Type | Property returning kBIMConnector indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties


BIMConnector.Application Property

BIMConnector.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.Application Property


BIMConnector.Definition Property

BIMConnector.Definition Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the definition object associated with this connector.

Visual Basic
Property Definition() As BIMConnectorDefinition**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.Definition Property


BIMConnector.DefinitionType Property

BIMConnector.DefinitionType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the type of definition associated with this connector.

Visual Basic
Property DefinitionType() As BIMConnectorDefinitionTypeEnum*
Remarks

This property lets you determine what type of connector this object represents.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.DefinitionType Property


BIMConnector.Name Property

BIMConnector.Name Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the displayed name of the connector.

Visual Basic
Property Name() As String
Remarks

This is the name that is visible in the browser and is editable by the end-user.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.Name Property


BIMConnector.Parent Property

BIMConnector.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent BimComponent object.

Visual Basic
Property Parent() As BIMComponent**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.Parent Property


BIMConnector.Suppressed Property

BIMConnector.Suppressed Property Available in Inventor Introduced in Inventor 2012
Summary

Property that defines whether the connector is suppressed or not.

Visual Basic
Property Suppressed() As VARIANT_BOOL
Remarks

A value of True indicates the connector is suppressed.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.Suppressed Property


BIMConnector.Type Property

BIMConnector.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMConnector indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnector Interface > BIMConnector Properties > BIMConnector.Type Property


BIMConnectorDefinition Interface

BIMConnectorDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

Base class object for all of the various BIM connector definition objects.

Class Hierarchy
Inventor::BIMConnectorDefinition
    Inventor::BIMCableTrayConnectorDefinition
    Inventor::BIMConduitConnectorDefinition
    Inventor::BIMDuctConnectorDefinition
    Inventor::BIMElectricalConnectorDefinition
    Inventor::BIMPipeConnectorDefinition
Visual Basic
Public Interface BIMConnectorDefinition
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface


BIMConnectorDefinition Methods

BIMConnectorDefinition Methods
Summary

The methods of the BIMConnectorDefinition class are listed here.

Methods
Methods
Name | Description
ReverseDirection | Method that will reverse the direction of the connection.
SetShape | Property that returns the specified BIMComponentProperty object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Methods


BIMConnectorDefinition.ReverseDirection Method

BIMConnectorDefinition.ReverseDirection Method Available in Inventor Introduced in Inventor 2012
Summary

Method that will reverse the direction of the connection.

Visual Basic
Sub ReverseDirection()
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Methods > BIMConnectorDefinition.ReverseDirection Method


BIMConnectorDefinition.SetShape Method

BIMConnectorDefinition.SetShape Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the specified BIMComponentProperty object from the collection.

Visual Basic
Sub SetShape(Geometry As ObjectCollection, ByRef ConnectorShape As [defaultvalue(kUndefinedShapeConnector)] BIMConnectorShapeEnum)
Parameters
Parameters | Description
Geometry | Input ObjectCollection that specifies the set of geometry used to define the connector position and shape.
ConnectorShape | Input value that indicates the desired shape of the connector and how the geometry is to be evaluated. Valid values for the various types of connectors is shown below. • Cable tray connectors: kRectangularShapeConnector or kUndefinedShapeConnector • Conduit connectors: kCircularShapeConnector or kUndefinedShapeConnector • Duct connectors: kRectangularShapeConnector, kCircularShapeConnector, kOvalShapeConnector or kUndefinedShapeConnector • Electrical connectors: kUndefinedShapeConnector • Pipe connectors: kCircularShapeConnector or kUndefinedShapeConnector The input geometry for the various shapes can be the following: • Circular shape o Single circular face. o Circular edge (it can be an arc) • Rectangular shape o Rectangular planar face. o Four edges that define a rectangle as illustrated below. • Slot shape o Planar face that has a slot shape. o Four edges that define a slot or oval shape, as illustrated below.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Methods > BIMConnectorDefinition.SetShape Method


BIMConnectorDefinition Properties

BIMConnectorDefinition Properties
Summary

The properties of the BIMConnectorDefinition class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ConnectorShape | Property that specifies the shape of the connector.
Direction | Property that indicates the direction of the connection.
Geometry | Property that gets the geometry that defines the shape of the connection.
Parent | Property that returns the parent BIMConnector that this definition is associated with.
Type | Property returning kBIMConnectorDefinition indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties


BIMConnectorDefinition.Application Property

BIMConnectorDefinition.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties > BIMConnectorDefinition.Application Property


BIMConnectorDefinition.ConnectorShape Property

BIMConnectorDefinition.ConnectorShape Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the shape of the connector.

Visual Basic
Property ConnectorShape() As BIMConnectorShapeEnum*
Remarks

To change the shape, use the SetShape method.

This setting affects how the geometry is evaluated to determine the shape of the connector. The following inputs are valid for the various types of connectors:

• Cable tray connectors: kRectangularShapeConnector or kUndefinedShapeConnector

• Conduit connectors: kCircularShapeConnector or kUndefinedShapeConnector

• Duct connectors: kRectangularShapeConnector, kCircularShapeConnector, kOvalShapeConnector or kUndefinedShapeConnector

• Electrical connectors: kUndefinedShapeConnector

• Pipe connectors: kCircularShapeConnector or kUndefinedShapeConnector

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties > BIMConnectorDefinition.ConnectorShape Property


BIMConnectorDefinition.Direction Property

BIMConnectorDefinition.Direction Property Available in Inventor Introduced in Inventor 2012
Summary

Property that indicates the direction of the connection.

Visual Basic
Property Direction() As UnitVector**
Remarks

This property will return Nothing in the case where a valid set of referenced geometries have not yet been defined.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties > BIMConnectorDefinition.Direction Property


BIMConnectorDefinition.Geometry Property

BIMConnectorDefinition.Geometry Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the geometry that defines the shape of the connection.

Visual Basic
Property Geometry() As ObjectCollection**
Remarks

The returned collection is independent of the connector and any changes made to the contents of the collection will not affect the connector. To change the geometry or the shape of the connector use the SetShape method.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties > BIMConnectorDefinition.Geometry Property


BIMConnectorDefinition.Parent Property

BIMConnectorDefinition.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent BIMConnector that this definition is associated with.

Visual Basic
Property Parent() As BIMConnector**
Remarks

If the definition was created using one of the Create methods this property will return Nothing since the definition isn’t associated with a connector yet.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties > BIMConnectorDefinition.Parent Property


BIMConnectorDefinition.Type Property

BIMConnectorDefinition.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMConnectorDefinition indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorDefinition Interface > BIMConnectorDefinition Properties > BIMConnectorDefinition.Type Property


BIMConnectorLink Interface

BIMConnectorLink Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents a link between two BIM connectors.

Class Hierarchy
Inventor::BIMConnectorLink
Visual Basic
Public Interface BIMConnectorLink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface


BIMConnectorLink Methods

BIMConnectorLink Methods
Summary

The methods of the BIMConnectorLink class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this link.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Methods


BIMConnectorLink.Delete Method

BIMConnectorLink.Delete Method Available in Inventor Introduced in Inventor 2012
Summary

Method that deletes this link.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Methods > BIMConnectorLink.Delete Method


BIMConnectorLink.GetReferenceKey Method

BIMConnectorLink.GetReferenceKey Method Available in Inventor Introduced in Inventor 2012
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

A reference key is an array of bytes that can be used as a persistent reference for an entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Methods > BIMConnectorLink.GetReferenceKey Method


BIMConnectorLink Properties

BIMConnectorLink Properties
Summary

The properties of the BIMConnectorLink class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ConnectorOne | Property that gets the first of two connectors that this link is between.
ConnectorTwo | Property that gets the second of two connectors that this link is between.
Name | Property that gets and sets the displayed name of the connector.
Type | Property returning kBIMConnectorLinkObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Properties


BIMConnectorLink.Application Property

BIMConnectorLink.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Properties > BIMConnectorLink.Application Property


BIMConnectorLink.ConnectorOne Property

BIMConnectorLink.ConnectorOne Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the first of two connectors that this link is between.

Visual Basic
Property ConnectorOne() As BIMConnector**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Properties > BIMConnectorLink.ConnectorOne Property


BIMConnectorLink.ConnectorTwo Property

BIMConnectorLink.ConnectorTwo Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the second of two connectors that this link is between.

Visual Basic
Property ConnectorTwo() As BIMConnector**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Properties > BIMConnectorLink.ConnectorTwo Property


BIMConnectorLink.Name Property

BIMConnectorLink.Name Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the displayed name of the connector.

Visual Basic
Property Name() As String
Remarks

This is the name that is visible in the browser and is editable by the end-user.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Properties > BIMConnectorLink.Name Property


BIMConnectorLink.Type Property

BIMConnectorLink.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMConnectorLinkObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLink Interface > BIMConnectorLink Properties > BIMConnectorLink.Type Property


BIMConnectorLinks Interface

BIMConnectorLinks Interface Available in Inventor Introduced in Inventor 2012
Summary

Collection object that provides access to all of the links between connectors and supports the ability to create new links.

Class Hierarchy
Inventor::BIMConnectorLinks
Visual Basic
Public Interface BIMConnectorLinks
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface


BIMConnectorLinks Methods

BIMConnectorLinks Methods
Summary

The methods of the BIMConnectorLinks class are listed here.

Methods
Methods
Name | Description
Add | Property that returns the specified BIMConnectorLink object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Methods


BIMConnectorLinks.Add Method

BIMConnectorLinks.Add Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the specified BIMConnectorLink object from the collection.

Visual Basic
Sub Add(ConnectorOne As BIMConnector, ConnectorTwo As BIMConnector, Result As [out, retval] BIMConnectorLink*)
Parameters
Parameters | Description
ConnectorOne | Input BIMConnector that defines the first of two connectors to be connected by the link.
ConnectorTwo | Input BIMConnector that defines the second of two connectors to be connected by the link.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Methods > BIMConnectorLinks.Add Method


BIMConnectorLinks Properties

BIMConnectorLinks Properties
Summary

The properties of the BIMConnectorLinks class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified BIMConnectorLink object from the collection.
Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the total number of all types of connector links in this BIMDocument.
Type | Property returning kBIMConnectorLinksObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Properties


BIMConnectorLinks.Application Property

BIMConnectorLinks.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Properties > BIMConnectorLinks.Application Property


BIMConnectorLinks.Count Property

BIMConnectorLinks.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the total number of all types of connector links in this BIMDocument.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Properties > BIMConnectorLinks.Count Property


BIMConnectorLinks.Item Method

BIMConnectorLinks.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the specified BIMConnectorLink object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BIMConnectorLink*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the BIM connector link to return. This is the index of the item in the collection where the first item is 1. It can also be the name of the connector. If an out of range value or an unknown name is provided an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Properties > BIMConnectorLinks.Item Method


BIMConnectorLinks.Type Property

BIMConnectorLinks.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMConnectorLinksObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectorLinks Interface > BIMConnectorLinks Properties > BIMConnectorLinks.Type Property


BIMConnectors Interface

BIMConnectors Interface Available in Inventor Introduced in Inventor 2012
Summary

Collection object that provides access to all of the BIM connectors within a document.

Class Hierarchy
Inventor::BIMConnectors
Visual Basic
Public Interface BIMConnectors
Inherits IDispatch
Remarks

Methods on this collection are also used to create new BIM connectors.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface


BIMConnectors Methods

BIMConnectors Methods
Summary

The methods of the BIMConnectors class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new BIMConnector.
CreateCableTrayConnectorDefinition | Method that creates a new cable tray connector definition.
CreateConduitConnectorDefinition | Method that creates a new conduit connector definition.
CreateDuctConnectorDefinition | Method that creates a new duct connector definition.
CreateElectricalConnectorDefinition | Method that creates a new electrical connector definition.
CreatePipeConnectorDefinition | Method that creates a new pipe connector definition.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods


BIMConnectors.Add Method

BIMConnectors.Add Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new BIMConnector.

Visual Basic
Sub Add(Definition As BIMConnectorDefinition, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] BIMConnector*)
Parameters
Parameters | Description
Definition | Input definition object that defines all of the required inputs to create a new connector.
Name | Defines the name of the new connector. It must be unique with respect to all existing connectors. If not provided, or an empty string is supplied then BIM Exchange will generate a default name.
Remarks

The type of connector definition supplied will determine the type of connector created. The new BIMConnector is returned.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods > BIMConnectors.Add Method


BIMConnectors.CreateCableTrayConnectorDefinition Method

BIMConnectors.CreateCableTrayConnectorDefinition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new cable tray connector definition.

Visual Basic
Sub CreateCableTrayConnectorDefinition(Geometry As ObjectCollection, ConnectorShape As BIMConnectorShapeEnum, Result As [out, retval] BIMCableTrayConnectorDefinition*)
Parameters
Parameters | Description
Geometry | Input object collection that contains the geometry that defines the shape of the connector. When the specified shape is rectangular, valid input includes a single rectangular face or four linear edges on a planar face that define a rectangle. These edges do not need to connect but two of them need to be parallel to each other and perpendicular to the other two edge. For example, the picture below illustrates four valid lines and the resulting rectangle. When the specified shape is undefined, valid input includes the input described above for a rectangular shape but also allows a circular planar face, a circular edge (it can be an arc), a planar face that has a slot shape, or four edges that define a slot or oval shape, as illustrated below.
ConnectorShape | Input value that specifies the shape of the connector. This setting affects how the geometry is evaluated to determine the shape of the connector. The following inputs are valid for a cable tray connector: kRectangularShapeConnector or kUndefinedShapeConnector
Remarks

The created definition object defines the inputs to create a cable tray connector and is used as input to the Add method of the BIMConnectors object to create a new connector.

The created definition defaults to a rectangular shape, the height and width are defined by the input geometry, and the connection type is electrically bonded. You can change any of these settings by using the methods and properties on the returned BIMCableTrayConnectorDefinition.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods > BIMConnectors.CreateCableTrayConnectorDefinition Method


BIMConnectors.CreateConduitConnectorDefinition Method

BIMConnectors.CreateConduitConnectorDefinition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new conduit connector definition.

Visual Basic
Sub CreateConduitConnectorDefinition(Geometry As ObjectCollection, ConnectorShape As BIMConnectorShapeEnum, Result As [out, retval] BIMConduitConnectorDefinition*)
Parameters
Parameters | Description
Geometry | Input object collection that contains the geometry that defines the shape of the connector. When the specified shape is circular, valid input includes a single circular face or a circular edge (it can be an arc). When the specified shape is undefined, valid input includes the input described above for a rectangular shape but also allows a rectangular planar face, four edges that define a rectangle as illustrated below, a planar face that has a slot shape, or four edges that define a slot or oval shape, as illustrated below.
ConnectorShape | Input value that specifies the shape of the connector. This setting affects how the geometry is evaluated to determine the shape of the connector. The following inputs are valid for a conduit connector: kCircularShapeConnector or kUndefinedShapeConnector
Remarks

The created definition object defines the inputs to create a conduit connector and is used as input to the Add method of the BIMConnectors object to create a new conduit connector.

The created definition defaults to a circular shape and the diameter is defined by the input geometry. You can change any of these settings by using the methods and properties on the returned BIMConduitConnectorDefinition.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods > BIMConnectors.CreateConduitConnectorDefinition Method


BIMConnectors.CreateDuctConnectorDefinition Method

BIMConnectors.CreateDuctConnectorDefinition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new duct connector definition.

Visual Basic
Sub CreateDuctConnectorDefinition(Geometry As ObjectCollection, ConnectorShape As BIMConnectorShapeEnum, Result As [out, retval] BIMDuctConnectorDefinition*)
Parameters
Parameters | Description
Geometry | Input object collection that contains the geometry that defines the shape of the connector. When the specified shape is rectangular, valid input includes a single rectangular face or four linear edges on a planar face that define a rectangle. These edges do not need to connect but two of them need to be parallel to each other and perpendicular to the other two edge. For example, the picture below illustrates four valid lines and the resulting rectangle. When the specified shape is oval, valid input includes a face that defines an oval or four edges that define an oval as illustrated below. When the specified shape is circular, valid input includes a single circular face or a circular edge (it can be an arc). When the specified shape is undefined, valid input includes any of the above.
ConnectorShape | Input value that specifies the shape of the connector. This setting affects how the geometry is evaluated to determine the shape of the connector. The following inputs are valid for a duct connector: kRectangularShapeConnector, kCircularShapeConnector, kOvalShapeConnector or kUndefinedShapeConnector
Remarks

The created definition object defines the inputs to create a duct connector and is used as input to the Add method of the BIMConnectors object to create a new connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods > BIMConnectors.CreateDuctConnectorDefinition Method


BIMConnectors.CreateElectricalConnectorDefinition Method

BIMConnectors.CreateElectricalConnectorDefinition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new electrical connector definition.

Visual Basic
Sub CreateElectricalConnectorDefinition(Geometry As ObjectCollection, Result As [out, retval] BIMElectricalConnectorDefinition*)
Parameters
Parameters | Description
Geometry | Input object collection that contains the geometry that defines the shape of the connector. Valid input includes: • Single circular face. • Circular edge (it can be an arc) • Rectangular planar face. • Four edges that define a rectangle as illustrated below. • Planar face that has a slot shape. • Four edges that define a slot or oval shape, as illustrated below.
Result | _nt_
Remarks

The created definition object defines the inputs to create a electrical connector and is used as input to the Add method of the BIMConnectors object to create a new connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods > BIMConnectors.CreateElectricalConnectorDefinition Method


BIMConnectors.CreatePipeConnectorDefinition Method

BIMConnectors.CreatePipeConnectorDefinition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new pipe connector definition.

Visual Basic
Sub CreatePipeConnectorDefinition(Geometry As ObjectCollection, ConnectorShape As BIMConnectorShapeEnum, Result As [out, retval] BIMPipeConnectorDefinition*)
Parameters
Parameters | Description
Geometry | Input object collection that contains the geometry that defines the shape of the connector. When the specified shape is circular, valid input includes a single circular face or a circular edge (it can be an arc). When the specified shape is undefined, valid input includes the input described above for a rectangular shape but also allows a rectangular planar face, four edges that define a rectangle as illustrated below, a planar face that has a slot shape, or four edges that define a slot or oval shape, as illustrated below.
ConnectorShape | Input value that specifies the shape of the connector. This setting affects how the geometry is evaluated to determine the shape of the connector. The following inputs are valid for a pipe connector: kCircularShapeConnector or kUndefinedShapeConnector.
Remarks

The created definition object defines the inputs to create a pipe connector and is used as input to the Add method of the BIMConnectors object to create a new connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Methods > BIMConnectors.CreatePipeConnectorDefinition Method


BIMConnectors Properties

BIMConnectors Properties
Summary

The properties of the BIMConnectors class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified BIMConnector object from the collection.
Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the total number of all types of connectors in this BIMDocument.
Type | Property returning kBIMConnectors indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Properties


BIMConnectors.Application Property

BIMConnectors.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Properties > BIMConnectors.Application Property


BIMConnectors.Count Property

BIMConnectors.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the total number of all types of connectors in this BIMDocument.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Properties > BIMConnectors.Count Property


BIMConnectors.Item Method

BIMConnectors.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the specified BIMConnector object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BIMConnector*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the BIM connector to return. This is the index of the item in the collection where the first item is 1. It can also be the name of the connector. If an out of range value or an unknown name is provided an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Properties > BIMConnectors.Item Method


BIMConnectors.Type Property

BIMConnectors.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBIMConnectors indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BIMConnectors Interface > BIMConnectors Properties > BIMConnectors.Type Property


BIMDuctConnectorDefinition Interface

BIMDuctConnectorDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents the various settings that can be defined for a duct connector.

Class Hierarchy
Inventor::BIMConnectorDefinition
    Inventor::BIMDuctConnectorDefinition
Visual Basic
Public Interface BIMDuctConnectorDefinition
Inherits BIMConnectorDefinition
Remarks

This object doesn’t represent the actual connector but only represents the settings and is used in the creation, query, and edit of a connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface


BIMDuctConnectorDefinition Properties

BIMDuctConnectorDefinition Properties
Summary

The properties of the BIMDuctConnectorDefinition class are listed here.

Properties
Name | Description
ConnectionType | Property that specifies the connection type for this duct connector.
Description | Property that gets and sets the description of this connector.
Diameter | Property that provides access to the connector diameter.
DiameterOverride | Property that gets and sets the diameter override for this connector.
FlowConfiguration | Property that gets and sets how the flow is configured for this connector.
FlowDirection | Property that gets and sets the flow direction for this connector.
FlowValue | Property that gets and sets the flow rate or flow factor for this connector.
Height | Property that provides access to the connector height.
HeightOverride | Property that gets and sets the height override for this connector.
LossMethod | Property that gets and sets the loss method defined for this connection.
LossValue | Property that gets and sets the loss value.
SystemType | Property that gets and sets the type of duct system this connection is for.
Width | Property that provides access to the connector width.
WidthOverride | Property that gets and sets the width override for this connector.
You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties


BIMDuctConnectorDefinition.ConnectionType Property

BIMDuctConnectorDefinition.ConnectionType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the connection type for this duct connector.

Visual Basic
Property ConnectionType() As BIMDuctConnectionTypeEnum
Remarks

For a newly created BIMDuctConnectorDefinition object you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.ConnectionType Property


BIMDuctConnectorDefinition.Description Property

BIMDuctConnectorDefinition.Description Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the description of this connector.

Visual Basic
Property Description() As String
Remarks

For a newly created BIMDuctConnectorDefinition object you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.Description Property


BIMDuctConnectorDefinition.Diameter Property

BIMDuctConnectorDefinition.Diameter Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector diameter.

Visual Basic
Property Diameter() As VARIANT*
Remarks

When the BIMDuctConnectorDefinition object has been created using the CreateBIMDuctConnectorDefinition method, this property returns a Double indicating the diameter, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the diameter of the connector.

For a newly created BIMDuctConnectorDefinition object you must first set the SystemType property before setting the value of this property.

To change the diameter of an existing connector you can either edit the geometry that’s controlling the diameter or set the override diameter using the DiameterOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.Diameter Property


BIMDuctConnectorDefinition.DiameterOverride Property

BIMDuctConnectorDefinition.DiameterOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the diameter override for this connector.

Visual Basic
Property DiameterOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the diameter. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the diameter.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

For a newly created BIMDuctConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.DiameterOverride Property


BIMDuctConnectorDefinition.FlowConfiguration Property

BIMDuctConnectorDefinition.FlowConfiguration Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets how the flow is configured for this connector.

Visual Basic
Property FlowConfiguration() As BIMDuctFlowConfigurationEnum
Remarks

For a newly created BIMDuctConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.FlowConfiguration Property


BIMDuctConnectorDefinition.FlowDirection Property

BIMDuctConnectorDefinition.FlowDirection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the flow direction for this connector.

Visual Basic
Property FlowDirection() As BIMFlowDirectionEnum
Remarks

For a newly created BIMDuctConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.FlowDirection Property


BIMDuctConnectorDefinition.FlowValue Property

BIMDuctConnectorDefinition.FlowValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the flow rate or flow factor for this connector.

Visual Basic
Property FlowValue() As double
Remarks

If the FlowConfiguration property returns kCalculatedDuctFlowConfigurationType then this property is ignored. If the FlowConfiguration property returns kPresetDuctFlowConfigurationType then this property defines the flow rate. If the FlowConfiguration property returns kSystemDuctFlowConfigurationType then this property defines the flow factor. The units for the flow are liters per second.

For a newly created BIMDuctConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.FlowValue Property


BIMDuctConnectorDefinition.Height Property

BIMDuctConnectorDefinition.Height Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector height.

Visual Basic
Property Height() As VARIANT*
Remarks

When the BIMDuctConnectorDefinition object has been created using the CreateBIMDuctConnectorDefinition method, this property returns a Double indicating the height, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the height of the connector.

To change the height of an existing connector, you can either edit the geometry that’s controlling the height or set the override height using the HeightOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.Height Property


BIMDuctConnectorDefinition.HeightOverride Property

BIMDuctConnectorDefinition.HeightOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the height override for this connector.

Visual Basic
Property HeightOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the height. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the height.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.HeightOverride Property


BIMDuctConnectorDefinition.LossMethod Property

BIMDuctConnectorDefinition.LossMethod Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the loss method defined for this connection.

Visual Basic
Property LossMethod() As BIMDuctLossMethodEnum
Remarks

For a newly created BIMDuctConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.LossMethod Property


BIMDuctConnectorDefinition.LossValue Property

BIMDuctConnectorDefinition.LossValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the loss value.

Visual Basic
Property LossValue() As double
Remarks

If the LossMethod property returns kNoneDuctLossMethodType then this property is ignored. If the LossMethod property returns kCoefficientDuctLossMethodType then this property defines the loss coefficient. If the LossMethod property returns kSpecificLossDuctLossMethodType then this property defines the pressure loss. This units of pressure used are Pascals.

For a newly created BIMDuctConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.LossValue Property


BIMDuctConnectorDefinition.SystemType Property

BIMDuctConnectorDefinition.SystemType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the type of duct system this connection is for.

Visual Basic
Property SystemType() As BIMDuctSystemTypeEnum
Remarks

When setting the values on a newly created BIMDuctConnectorDefinition, you must set this property first before you can set the values of any of the other properties.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.SystemType Property


BIMDuctConnectorDefinition.Width Property

BIMDuctConnectorDefinition.Width Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector width.

Visual Basic
Property Width() As VARIANT*
Remarks

When the BIMDuctConnectorDefinition object has been created using the CreateBIMDuctConnectorDefinition method, this property returns a Double indicating the width, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the width of the connector.

To change the width of an existing connector, you can either edit the geometry that’s controlling the width or set the override width using the WidthOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.Width Property


BIMDuctConnectorDefinition.WidthOverride Property

BIMDuctConnectorDefinition.WidthOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the width override for this connector.

Visual Basic
Property WidthOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the width. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the width.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

You are here: Symbol Reference > Inventor Library > Objects > BIMDuctConnectorDefinition Interface > BIMDuctConnectorDefinition Properties > BIMDuctConnectorDefinition.WidthOverride Property


BIMElectricalConnectorDefinition Interface

BIMElectricalConnectorDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents the various settings that can be defined for an electrical connector.

Class Hierarchy
Inventor::BIMConnectorDefinition
    Inventor::BIMElectricalConnectorDefinition
Visual Basic
Public Interface BIMElectricalConnectorDefinition
Inherits BIMConnectorDefinition
Remarks

This object doesn’t represent the actual connector but only represents the settings and is used in the creation, query, and edit of a connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface


BIMElectricalConnectorDefinition Properties

BIMElectricalConnectorDefinition Properties
Summary

The properties of the BIMElectricalConnectorDefinition class are listed here.

Properties
Name | Description
ApparentLoad | Property that gets and sets the apparent load associated with this connector.
ApparentLoadPhase1 | Property that gets and sets the phase 1 apparent load associated with this connector.
ApparentLoadPhase2 | Property that gets and sets the phase 2 apparent load associated with this connector.
ApparentLoadPhase3 | Property that gets and sets the phase 3 apparent load associated with this connector.
Description | Property that gets and sets the description of this connector.
HasMotor | Property that gets and sets whether or not there is a motor associated with this connector.
LoadClassification | Property that gets and sets the load classification associated with this connector.
NumberOfPoles | Property that gets and sets the number of poles associated with this connector.
PowerFactor | Property that gets and sets the power factor associated with this connector.
PowerFactorState | Property that gets and sets the power factor associated with this connector.
SystemType | Property that specifies the connection type for this duct connector.
Voltage | Property that gets and sets the voltage associated with this connector.
You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties


BIMElectricalConnectorDefinition.ApparentLoad Property

BIMElectricalConnectorDefinition.ApparentLoad Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the apparent load associated with this connector.

Visual Basic
Property ApparentLoad() As double
Remarks

The units of power are Watts.

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerBalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.ApparentLoad Property


BIMElectricalConnectorDefinition.ApparentLoadPhase1 Property

BIMElectricalConnectorDefinition.ApparentLoadPhase1 Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the phase 1 apparent load associated with this connector.

Visual Basic
Property ApparentLoadPhase1() As double
Remarks

The units of power are Watts.

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.ApparentLoadPhase1 Property


BIMElectricalConnectorDefinition.ApparentLoadPhase2 Property

BIMElectricalConnectorDefinition.ApparentLoadPhase2 Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the phase 2 apparent load associated with this connector.

Visual Basic
Property ApparentLoadPhase2() As double
Remarks

The units of power are Watts.

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.ApparentLoadPhase2 Property


BIMElectricalConnectorDefinition.ApparentLoadPhase3 Property

BIMElectricalConnectorDefinition.ApparentLoadPhase3 Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the phase 3 apparent load associated with this connector.

Visual Basic
Property ApparentLoadPhase3() As double
Remarks

The units of power are Watts.

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.ApparentLoadPhase3 Property


BIMElectricalConnectorDefinition.Description Property

BIMElectricalConnectorDefinition.Description Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the description of this connector.

Visual Basic
Property Description() As String
Remarks

For a newly created BIMElectricalConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.Description Property


BIMElectricalConnectorDefinition.HasMotor Property

BIMElectricalConnectorDefinition.HasMotor Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether or not there is a motor associated with this connector.

Visual Basic
Property HasMotor() As VARIANT_BOOL
Remarks

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerBalancedElectricalSystemType or kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.HasMotor Property


BIMElectricalConnectorDefinition.LoadClassification Property

BIMElectricalConnectorDefinition.LoadClassification Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the load classification associated with this connector.

Visual Basic
Property LoadClassification() As String
Remarks

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerBalancedElectricalSystemType or kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.LoadClassification Property


BIMElectricalConnectorDefinition.NumberOfPoles Property

BIMElectricalConnectorDefinition.NumberOfPoles Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the number of poles associated with this connector.

Visual Basic
Property NumberOfPoles() As long
Remarks

Valid values are 1, 2, or 3.

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerBalancedElectricalSystemType or kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.NumberOfPoles Property


BIMElectricalConnectorDefinition.PowerFactor Property

BIMElectricalConnectorDefinition.PowerFactor Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the power factor associated with this connector.

Visual Basic
Property PowerFactor() As double
Remarks

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.PowerFactor Property


BIMElectricalConnectorDefinition.PowerFactorState Property

BIMElectricalConnectorDefinition.PowerFactorState Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the power factor associated with this connector.

Visual Basic
Property PowerFactorState() As BIMElectricalPowerFactorStateEnum
Remarks

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.PowerFactorState Property


BIMElectricalConnectorDefinition.SystemType Property

BIMElectricalConnectorDefinition.SystemType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the connection type for this duct connector.

Visual Basic
Property SystemType() As BIMElectricalSystemTypeEnum
Remarks

When setting the values on a newly created BIMElectricalConnectorDefinition, you must set this property first before you can set the values of any of the other properties.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.SystemType Property


BIMElectricalConnectorDefinition.Voltage Property

BIMElectricalConnectorDefinition.Voltage Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the voltage associated with this connector.

Visual Basic
Property Voltage() As double
Remarks

The units of voltage is the Volt.

For a newly created BIMElectricalConnectorDefinition object you must first set the SystemType property before setting the value of this property.

This property is only used when the value of the SystemType property is kPowerBalancedElectricalSystemType or kPowerUnbalancedElectricalSystemType and is ignored in all other cases.

You are here: Symbol Reference > Inventor Library > Objects > BIMElectricalConnectorDefinition Interface > BIMElectricalConnectorDefinition Properties > BIMElectricalConnectorDefinition.Voltage Property


BIMExchangeServer Interface

BIMExchangeServer Interface Available in Inventor Introduced in Inventor 2012
Summary

Object returned by the BIM Exchange add-in through the Automation property.

Class Hierarchy
Inventor::BIMExchangeServer
Visual Basic
Public Interface BIMExchangeServer
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BIMExchangeServer Interface


BIMExchangeServer Methods

BIMExchangeServer Methods
Summary

The methods of the BIMExchangeServer class are listed here.

Methods
Methods
Name | Description
GetBIMComponent | Method that returns the BIMComponent associated with the provided Inventor part or assembly component definition.
You are here: Symbol Reference > Inventor Library > Objects > BIMExchangeServer Interface > BIMExchangeServer Methods


BIMExchangeServer.GetBIMComponent Method

BIMExchangeServer.GetBIMComponent Method
Summary

Method that returns the BIMComponent associated with the provided Inventor part or assembly component definition.

Visual Basic
Sub GetBIMComponent(ComponentDefinition As ComponentDefinition, Result As [out, retval] BIMComponent*)
Parameters
Parameters | Description
ComponentDefinition | Input PartComponentDefinition or AssemblyComponentDefinition object that specifies which Inventor part or assembly you want to get the associated BIMComponent for.
You are here: Symbol Reference > Inventor Library > Objects > BIMExchangeServer Interface > BIMExchangeServer Methods > BIMExchangeServer.GetBIMComponent Method


BIMPipeConnectorDefinition Interface

BIMPipeConnectorDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

Object that represents the various settings that can be defined for a pipe connector.

Class Hierarchy
Inventor::BIMConnectorDefinition
    Inventor::BIMPipeConnectorDefinition
Visual Basic
Public Interface BIMPipeConnectorDefinition
Inherits BIMConnectorDefinition
Remarks

This object doesn’t represent the actual connector but only represents the settings and is used in the creation, query, and edit of a connector.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface


BIMPipeConnectorDefinition Properties

BIMPipeConnectorDefinition Properties
Summary

The properties of the BIMPipeConnectorDefinition class are listed here.

Properties
Name | Description
AllowSlopeAdjustment | Property that gets and sets whether or not slope adjustment is allowed for this connector.
ConnectionType | Property that gets and sets the connection type for this connector.
Description | Property that gets and sets the description of this connector.
Diameter | Property that provides access to the connector diameter.
DiameterOverride | Property that gets and sets the diameter override for this connector.
FlowConfiguration | Property that gets and sets the loss method used for this connector.
FlowDirection | Property that gets and sets the flow direction for this pipe connector.
FlowValue | Property that gets and sets the value for the flow.
LossMethod | Property that gets and sets the loss method used for this connector.
LossValue | Property that gets and sets the value for the loss method.
NominalDiameter | Property that provides access to the nominal diameter of the pipe connection.
SystemType | Property that specifies the connection type for this duct connector.
You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties


BIMPipeConnectorDefinition.AllowSlopeAdjustment Property

BIMPipeConnectorDefinition.AllowSlopeAdjustment Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether or not slope adjustment is allowed for this connector.

Visual Basic
Property AllowSlopeAdjustment() As VARIANT_BOOL
Remarks

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.AllowSlopeAdjustment Property


BIMPipeConnectorDefinition.ConnectionType Property

BIMPipeConnectorDefinition.ConnectionType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the connection type for this connector.

Visual Basic
Property ConnectionType() As BIMPipeConnectionTypeEnum
Remarks

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.ConnectionType Property


BIMPipeConnectorDefinition.Description Property

BIMPipeConnectorDefinition.Description Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the description of this connector.

Visual Basic
Property Description() As String
Remarks

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.Description Property


BIMPipeConnectorDefinition.Diameter Property

BIMPipeConnectorDefinition.Diameter Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the connector diameter.

Visual Basic
Property Diameter() As VARIANT*
Remarks

When the BIMPipeConnectorDefinition object has been created using the CreateBIMPipeConnectorDefinition method, this property returns a Double indicating the diameter, (in centimeters), of the connector as defined by the input geometry. After the definition object has been used to create a connector, this property returns a parameter that defines the diameter of the connector.

To change the diameter of an existing connector, you can either edit the geometry that’s controlling the diameter or set the override diameter using the DiameterOverride property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.Diameter Property


BIMPipeConnectorDefinition.DiameterOverride Property

BIMPipeConnectorDefinition.DiameterOverride Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the diameter override for this connector.

Visual Basic
Property DiameterOverride() As VARIANT
Remarks

If the value returned by this property is an empty string (“”), this indicates that there is no override for the diameter. Setting this property to an empty string will remove an override. If there is an override this property will return the expression of the parameter controlling the diameter.

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 / 4” is valid, assuming there is a parameter named d5.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.DiameterOverride Property


BIMPipeConnectorDefinition.FlowConfiguration Property

BIMPipeConnectorDefinition.FlowConfiguration Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the loss method used for this connector.

Visual Basic
Property FlowConfiguration() As BIMPipeFlowConfigurationEnum
Remarks

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.FlowConfiguration Property


BIMPipeConnectorDefinition.FlowDirection Property

BIMPipeConnectorDefinition.FlowDirection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the flow direction for this pipe connector.

Visual Basic
Property FlowDirection() As BIMFlowDirectionEnum
Remarks

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.FlowDirection Property


BIMPipeConnectorDefinition.FlowValue Property

BIMPipeConnectorDefinition.FlowValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the value for the flow.

Visual Basic
Property FlowValue() As double
Remarks

If the value of the FlowConfiguration property is kCalculatedFlowConfigurationType then this value is not used. If the value of the FlowConfiguration property is kPresetFlowConfigurationType then this value defines the flow value. If the value of the FlowConfiguration property is kSystemFlowConfigurationType then this value defines the flow factor. If the value of the FlowConfiguration property is kFixtureUnitsFlowConfigurationType then this value defines the fixture units.

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.FlowValue Property


BIMPipeConnectorDefinition.LossMethod Property

BIMPipeConnectorDefinition.LossMethod Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the loss method used for this connector.

Visual Basic
Property LossMethod() As BIMPipeLossMethodEnum
Remarks

For a newly created BIMPipeConnectorDefinition object. you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.LossMethod Property


BIMPipeConnectorDefinition.LossValue Property

BIMPipeConnectorDefinition.LossValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the value for the loss method.

Visual Basic
Property LossValue() As double
Remarks

If the value of the LossMethod property is kNoneLossMethodType, then this value is not used. If the value of the LossMethod property is kKCoefficientLossMethodType then this value is the K Coefficient value. If the value of the LossMethod property is kSpecificLossLossMethodType then this value is the pressure drop value.

For a newly created BIMPipeConnectorDefinition object, you must first set the SystemType property before setting the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.LossValue Property


BIMPipeConnectorDefinition.NominalDiameter Property

BIMPipeConnectorDefinition.NominalDiameter Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the nominal diameter of the pipe connection.

Visual Basic
Property NominalDiameter() As VARIANT
Remarks

This property is writable when the definition object has been created using the CreateBIMPipeConnectorDefinition method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “d5 * 2” is valid, assuming there is a parameter named d5.

When the BIMPipeConnectorDefinitionobject has been obtained from an existing BimConnector object this property is read-only and returns the Parameter object that defines the nominal diameter. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.NominalDiameter Property


BIMPipeConnectorDefinition.SystemType Property

BIMPipeConnectorDefinition.SystemType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the connection type for this duct connector.

Visual Basic
Property SystemType() As BIMPipeSystemTypeEnum
Remarks

When setting the values on a newly created BIMPipeConnectorDefinition, you must set this property first before you can set the values of any of the other properties.

You are here: Symbol Reference > Inventor Library > Objects > BIMPipeConnectorDefinition Interface > BIMPipeConnectorDefinition Properties > BIMPipeConnectorDefinition.SystemType Property


BOM Interface

BOM Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

The BOM object represents the Bill Of Materials (BOM) data of a document.

Class Hierarchy
Inventor::BOM
Visual Basic
Public Interface BOM
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.BOM

BOMView.Parent

See Also

Exporting the assembly BOM sample

Creation a balloon sample

Example

"Using the BOM APIs"

"This sample demonstrates the Bill of Materials API functionality in assemblies. Have an assembly document open and run the following sample."

Public Sub BOMQuery()
    ' Set a reference to the assembly document.
    ' This assumes an assembly document is active.
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim FirstLevelOnly As Boolean
    If MsgBox("First level only?", vbYesNo) = vbYes Then
        FirstLevelOnly = True
    Else
        FirstLevelOnly = False
    End If

    ' Set a reference to the BOM
    Dim oBOM As BOM
    Set oBOM = oDoc.ComponentDefinition.BOM

    ' Set whether first level only or all levels.
    If FirstLevelOnly Then
        oBOM.StructuredViewFirstLevelOnly = True
    Else
        oBOM.StructuredViewFirstLevelOnly = False
    End If

    ' Make sure that the structured view is enabled.
    oBOM.StructuredViewEnabled = True

    'Set a reference to the "Structured" BOMView
    Dim oBOMView As BOMView
    Set oBOMView = oBOM.BOMViews.Item("Structured")

    Debug.Print "Item"; Tab(15); "Quantity"; Tab(30); "Part Number"; Tab(70); "Description"
    Debug.Print "----------------------------------------------------------------------------------"

    'Initialize the tab for ItemNumber
    Dim ItemTab As Long
    ItemTab = -3
    Call QueryBOMRowProperties(oBOMView.BOMRows, ItemTab)
End Sub

Private Sub QueryBOMRowProperties(oBOMRows As BOMRowsEnumerator, ItemTab As Long)
    ItemTab = ItemTab + 3
    ' Iterate through the contents of the BOM Rows.
    Dim i As Long
    For i = 1 To oBOMRows.Count
        ' Get the current row.
        Dim oRow As BOMRow
        Set oRow = oBOMRows.Item(i)

        'Set a reference to the primary ComponentDefinition of the row
        Dim oCompDef As ComponentDefinition
        Set oCompDef = oRow.ComponentDefinitions.Item(1)

        Dim oPartNumProperty As Property
        Dim oDescripProperty As Property

        If Typeof oCompDef Is VirtualComponentDefinition Then

            'Get the file property that contains the "Part Number"
            'The file property is obtained from the virtual component definition
            Set oPartNumProperty = oCompDef.PropertySets _
                .Item("Design Tracking Properties").Item("Part Number")

            'Get the file property that contains the "Description"
            Set oDescripProperty = oCompDef.PropertySets _
                .Item("Design Tracking Properties").Item("Description")

            Debug.Print Tab(ItemTab); oRow.ItemNumber; Tab(17); oRow.ItemQuantity; Tab(30); _
                oPartNumProperty.Value; Tab(70); oDescripProperty.Value
        Else

            'Get the file property that contains the "Part Number"
            'The file property is obtained from the parent
            'document of the associated ComponentDefinition.
            Set oPartNumProperty = oCompDef.Document.PropertySets _
                .Item("Design Tracking Properties").Item("Part Number")

            'Get the file property that contains the "Description"
            Set oDescripProperty = oCompDef.Document.PropertySets _
                .Item("Design Tracking Properties").Item("Description")

            Debug.Print Tab(ItemTab); oRow.ItemNumber; Tab(17); oRow.ItemQuantity; Tab(30); _
                oPartNumProperty.Value; Tab(70); oDescripProperty.Value

            'Recursively iterate child rows if present.
            If Not oRow.ChildRows Is Nothing Then
                Call QueryBOMRowProperties(oRow.ChildRows, ItemTab)
            End If
        End If
    Next
    ItemTab = ItemTab - 3
End Sub
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface


BOM Methods

BOM Methods
Summary

The methods of the BOM class are listed here.

Methods
Methods
Name | Description
GetPartNumberMergeSettings | Method that gets the part number row merge settings for the BOM.
SetPartNumberMergeSettings | Method that sets the part number row merge settings for the BOM.
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Methods


BOM.GetPartNumberMergeSettings Method

BOM.GetPartNumberMergeSettings Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that gets the part number row merge settings for the BOM.

Visual Basic
Sub GetPartNumberMergeSettings(ByRef MergeEnabled As VARIANT_BOOL, ByRef MergeExcludeList As SAFEARRAY(BSTR))
Parameters
Parameters | Description
MergeEnabled | Boolean that indicates whether the row merging based on part number match is enabled.
MergeExcludeList | Array that returns the strings to exclude when merging based on part number match. This array will contain a minimum of one string ('').
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Methods > BOM.GetPartNumberMergeSettings Method


BOM.SetPartNumberMergeSettings Method

BOM.SetPartNumberMergeSettings Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets the part number row merge settings for the BOM.

Visual Basic
Sub SetPartNumberMergeSettings(MergeEnabled As VARIANT_BOOL, ByRef MergeKeys As [optional] VARIANT)
Parameters
Parameters | Description
MergeEnabled | Boolean that indicates whether the row merging based on part number match is enabled.
MergeKeys | Optional input array that contains the strings to exclude when merging based on part number match. If supplied, this array should contain a minimum of one string ('').
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Methods > BOM.SetPartNumberMergeSettings Method


BOM Properties

BOM Properties
Summary

The properties of the BOM class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BOMViews | Property that gets the BOMViews collection object.
Parent | Property that returns the parent ComponentDefinition object.
PartsOnlyViewEnabled | Property that gets and sets whether the parts-only BOMView is enabled. If enabled, the BOMView appears in the BOMViews collection.
PartsOnlyViewMinimumDigits | Property that gets and sets the minimum number of digits displayed in a parts only view with the PartsOnlyViewNumberingScheme set to kNumericNumbering. For example, if the property is set to 3, the first number assigned is 001.
PartsOnlyViewNumberingScheme | Property that gets and sets the numbering scheme for a 'Parts Only' view. Valid values are kNumericNumbering, kLowercaseAlphaNumbering and kUppercaseAlphaNumbering.
RequiresUpdate | Determines whether the BOM requires an update.
RevisionId | Property that returns the GUID that represents the last saved revision of this BOM.
StructuredViewDelimiter | Property that gets and sets the delimiter to use for numbering. This property applies only for an all-level structured view. This property is only used when the StructuredViewFirstLevelOnly property is False and the structured view is enabled.
StructuredViewEnabled | Property that gets and sets whether the structured BOMView is enabled. If enabled, the BOMView appears in the BOMViews collection.
StructuredViewFirstLevelOnly | Property that gets and sets whether the structured view is an 'all-level' or a 'first level only' view. If the structured view is not enabled, a change to this property takes effect when the view is enabled.
StructuredViewMinimumDigits | Property that gets and sets the minimum number of digits displayed in a 'first level only' structured view. For example, if the property is set to 3, the first number assigned is 001.
Type | Property returning kBOMObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties


BOM.Application Property

BOM.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.Application Property


BOM.BOMViews Property

BOM.BOMViews Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the BOMViews collection object.

Visual Basic
Property BOMViews() As BOMViews**
See Also

Exporting the assembly BOM sample

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.BOMViews Property


BOM.Parent Property

BOM.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.Parent Property


BOM.PartsOnlyViewEnabled Property

BOM.PartsOnlyViewEnabled Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether the parts-only BOMView is enabled. If enabled, the BOMView appears in the BOMViews collection.

Visual Basic
Property PartsOnlyViewEnabled() As VARIANT_BOOL
See Also

Exporting the assembly BOM sample

You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.PartsOnlyViewEnabled Property


BOM.PartsOnlyViewMinimumDigits Property

BOM.PartsOnlyViewMinimumDigits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the minimum number of digits displayed in a parts only view with the PartsOnlyViewNumberingScheme set to kNumericNumbering. For example, if the property is set to 3, the first number assigned is 001.

Visual Basic
Property PartsOnlyViewMinimumDigits() As long
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.PartsOnlyViewMinimumDigits Property


BOM.PartsOnlyViewNumberingScheme Property

BOM.PartsOnlyViewNumberingScheme Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the numbering scheme for a 'Parts Only' view. Valid values are kNumericNumbering, kLowercaseAlphaNumbering and kUppercaseAlphaNumbering.

Visual Basic
Property PartsOnlyViewNumberingScheme() As NumberingSchemeEnum
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.PartsOnlyViewNumberingScheme Property


BOM.RequiresUpdate Property

BOM.RequiresUpdate Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Determines whether the BOM requires an update.

Visual Basic
Property RequiresUpdate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.RequiresUpdate Property


BOM.RevisionId Property

BOM.RevisionId Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the GUID that represents the last saved revision of this BOM.

Visual Basic
Property RevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.RevisionId Property


BOM.StructuredViewDelimiter Property

BOM.StructuredViewDelimiter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the delimiter to use for numbering. This property applies only for an all-level structured view. This property is only used when the StructuredViewFirstLevelOnly property is False and the structured view is enabled.

Visual Basic
Property StructuredViewDelimiter() As String
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.StructuredViewDelimiter Property


BOM.StructuredViewEnabled Property

BOM.StructuredViewEnabled Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the structured BOMView is enabled. If enabled, the BOMView appears in the BOMViews collection.

Visual Basic
Property StructuredViewEnabled() As VARIANT_BOOL
See Also

Exporting the assembly BOM sample

Using the BOM APIs sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.StructuredViewEnabled Property


BOM.StructuredViewFirstLevelOnly Property

BOM.StructuredViewFirstLevelOnly Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the structured view is an 'all-level' or a 'first level only' view. If the structured view is not enabled, a change to this property takes effect when the view is enabled.

Visual Basic
Property StructuredViewFirstLevelOnly() As VARIANT_BOOL
See Also

Exporting the assembly BOM sample

Using the BOM APIs sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.StructuredViewFirstLevelOnly Property


BOM.StructuredViewMinimumDigits Property

BOM.StructuredViewMinimumDigits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the minimum number of digits displayed in a 'first level only' structured view. For example, if the property is set to 3, the first number assigned is 001.

Visual Basic
Property StructuredViewMinimumDigits() As long
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.StructuredViewMinimumDigits Property


BOM.Type Property

BOM.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kBOMObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOM Interface > BOM Properties > BOM.Type Property


BOMQuantity Interface

BOMQuantity Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

This object provides methods and properties allowing the BOM row unit quantity to be computed.

Class Hierarchy
Inventor::BOMQuantity
Visual Basic
Public Interface BOMQuantity
Inherits IDispatch
Remarks

The UnitQuantity property returns the product of the BaseUnits property multiplied by the base quantity value as set by the SetBaseQuantity method.

Notes

Members through which this object may be accessed include:

ComponentDefinition.BOMQuantity

You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface


BOMQuantity Methods

BOMQuantity Methods
Summary

The methods of the BOMQuantity class are listed here.

Methods
Methods
Name | Description
GetBaseQuantity | Method that retrieves the base quantity for the component.
GetEvaluatedBaseQuantity | Method that retrieves the stored base quantity for the component.
SetBaseQuantity | Method that sets the base quantity for the component.
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Methods


BOMQuantity.GetBaseQuantity Method

BOMQuantity.GetBaseQuantity Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that retrieves the base quantity for the component.

Visual Basic
Sub GetBaseQuantity(ByRef QuantityType As BOMQuantityTypeEnum, ByRef Quantity As [optional] VARIANT)
Parameters
Parameters | Description
QuantityType | Output BOMQuantityTypeEnum indicating the quantity type. If kParameterBOMQuantity is returned, the Quantity argument returns the corresponding parameter object.
Quantity | Output Variant returning the quantity. This argument returns a Parameter object if the QuantityType returned is kParameterBOMQuantity.
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Methods > BOMQuantity.GetBaseQuantity Method


BOMQuantity.GetEvaluatedBaseQuantity Method

BOMQuantity.GetEvaluatedBaseQuantity Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that retrieves the stored base quantity for the component.

Visual Basic
Sub GetEvaluatedBaseQuantity(ByRef QuantityType As BOMQuantityTypeEnum, Result As [out, retval] double)
Parameters
Parameters | Description
QuantityType | BOMQuantityTypeEnum indicating the stored quantity type. This can currently return either kEachBOMQuantity or kParameterBOMQuantity. If kParameterBOMQuantity is returned, the Quantity argument returns the evaluated string indicating the base quantity.
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Methods > BOMQuantity.GetEvaluatedBaseQuantity Method


BOMQuantity.SetBaseQuantity Method

BOMQuantity.SetBaseQuantity Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that sets the base quantity for the component.

Visual Basic
Sub SetBaseQuantity(QuantityType As BOMQuantityTypeEnum, ByRef Quantity As [optional] VARIANT)
Parameters
Parameters | Description
QuantityType | Input BOMQuantityTypeEnum indicating the quantity type. If kParameterBOMQuantity is set, a Parameter needs to be specified as the second argument.
Quantity | Input Variant specifying the quantity. If QuantityType is kParameterBOMQuantity, this argument expects a Parameter input, else this argument can be left unspecified. Only such parameters whose units resolve to being a linear length, a volume, or a mass are valid.
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Methods > BOMQuantity.SetBaseQuantity Method


BOMQuantity Properties

BOMQuantity Properties
Summary

The properties of the BOMQuantity class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BaseUnits | Property that gets and sets the true unit that the component is quantified in. It can be a measure of length, volume, or mass. The units are always retrieved as a string, but may be set using a constant from UnitsTypeEnum. This property is ignored if the BaseQuantity is not set to a parameter.
Parent | Property that returns the parent ComponentDefinition object.
Type | Property returning kBOMQuantityObject indicating this objects type.
UnitQuantity | Property that returns the unit quantity derived from two other properties, the BaseQuantity and the BaseUnits.
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Properties


BOMQuantity.Application Property

BOMQuantity.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Properties > BOMQuantity.Application Property


BOMQuantity.BaseUnits Property

BOMQuantity.BaseUnits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the true unit that the component is quantified in. It can be a measure of length, volume, or mass. The units are always retrieved as a string, but may be set using a constant from UnitsTypeEnum. This property is ignored if the BaseQuantity is not set to a parameter.

Visual Basic
Property BaseUnits() As String
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Properties > BOMQuantity.BaseUnits Property


BOMQuantity.Parent Property

BOMQuantity.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Properties > BOMQuantity.Parent Property


BOMQuantity.Type Property

BOMQuantity.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kBOMQuantityObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Properties > BOMQuantity.Type Property


BOMQuantity.UnitQuantity Property

BOMQuantity.UnitQuantity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the unit quantity derived from two other properties, the BaseQuantity and the BaseUnits.

Visual Basic
Property UnitQuantity() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BOMQuantity Interface > BOMQuantity Properties > BOMQuantity.UnitQuantity Property


BOMRow Interface

BOMRow Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

The BOMRow object represents an item in the BOM based on the parent BOMView.

Class Hierarchy
Inventor::BOMRow
Visual Basic
Public Interface BOMRow
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

BOMRowsEnumerator.Item

DrawingBOMRow.BOMRow

See Also

Using the BOM APIs sample

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface


BOMRow Methods

BOMRow Methods
Summary

The methods of the BOMRow class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Methods


BOMRow.GetReferenceKey Method

BOMRow.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Methods > BOMRow.GetReferenceKey Method


BOMRow Properties

BOMRow Properties
Summary

The properties of the BOMRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BOMStructure | Property that gets and sets how the BOM item represented by this row is used/viewed relating to design.
ChildRows | Property that gets the BOMRowsEnumerator object containing the locally-stored rows under this BOMRow. This property will return Nothing for BOMRows in a parts-only view and if there are no sub-rows for this BOMRow.
ComponentDefinitions | Property that returns the ComponentDefinitions associated with this row in the BOM. These could be part, sheet metal, assembly, weldment or a virtual component definitions. This enumerator will return just one component definition unless this row is a merged one, in which case all associated component definitions are returned. The first component definition in the enumerator is always the primary component definition.
ItemNumber | Property that gets the item identifier (i.e. the Detail Id) of the BOM item. This number is based on the active numbering scheme (i.e. the BOM view) of the BOM. For a structure 'all-level' view, changing the item number will also change the base number for all children who's base number matches the previous item number.
ItemNumberLocked | Property that gets and sets whether the item identifier can be edited.
ItemQuantity | Property that gets the number of instances not marked as phantom or reference represented by this BOM row.
Merged | Property that returns whether this row is a result of a merging multiple rows. If true, the ComponentDefinitions property returns all the associated component definitions. This property will return False for all rows in the data BOMView.
Parent | Property that returns the parent BOMView or the BOMRow object.
Promoted | Property that returns whether this row was promoted (for instance, as a result of the parent subassembly being marked phantom). This property will return False for all rows in the data BOMView.
ReferencedFileDescriptor | Gets the FileDescriptor for the component referenced by this row. This only applies to non merged component rows and non local components and immediately referenced components. Therefore this would only be useful in the data view.
RolledUp | Indicates whether this row is a result of rolling up multiple promoted rows of the same ComponentDefinition.
TotalQuantity | Property that gets and sets the total quantity of the BOM item. This is either based on the unit quantity defined in the referenced ComponentDefinition times the ItemQuantity or is the override specified for this row. The TotalQuantityOverridden property can be used to determine whether this value has an override applied to it. Overrides cannot be set for parts only views.
TotalQuantityOverridden | Property that gets and sets whether the TotalQuantity property has been overridden. This property can only be set to False, in which case the override on the value will be removed.
Type | Property returning kBOMRowObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties


BOMRow.Application Property

BOMRow.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.Application Property


BOMRow.AttributeSets Property

BOMRow.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.AttributeSets Property


BOMRow.BOMStructure Property

BOMRow.BOMStructure Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets how the BOM item represented by this row is used/viewed relating to design.

Visual Basic
Property BOMStructure() As BOMStructureEnum
Remarks

Possible values are kDefaultBOMStructure, kNormalBOMStructure, kPhantomBOMStructure, kReferenceBOMStructure, kPurchasedBOMStructure and kInseparableBOMStructure. If the BOMRow represents multiple occurrences with different BOMStructure values, the property returns kVariesBOMStructure.

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.BOMStructure Property


BOMRow.ChildRows Property

BOMRow.ChildRows Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets the BOMRowsEnumerator object containing the locally-stored rows under this BOMRow. This property will return Nothing for BOMRows in a parts-only view and if there are no sub-rows for this BOMRow.

Visual Basic
Property ChildRows() As BOMRowsEnumerator**
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.ChildRows Property


BOMRow.ComponentDefinitions Property

BOMRow.ComponentDefinitions Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the ComponentDefinitions associated with this row in the BOM. These could be part, sheet metal, assembly, weldment or a virtual component definitions. This enumerator will return just one component definition unless this row is a merged one, in which case all associated component definitions are returned. The first component definition in the enumerator is always the primary component definition.

Visual Basic
Property ComponentDefinitions() As ComponentDefinitionsEnumerator**
See Also

Using the BOM APIs sample

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.ComponentDefinitions Property


BOMRow.ItemNumber Property

BOMRow.ItemNumber Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the item identifier (i.e. the Detail Id) of the BOM item. This number is based on the active numbering scheme (i.e. the BOM view) of the BOM. For a structure 'all-level' view, changing the item number will also change the base number for all children who's base number matches the previous item number.

Visual Basic
Property ItemNumber() As String
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.ItemNumber Property


BOMRow.ItemNumberLocked Property

BOMRow.ItemNumberLocked Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the item identifier can be edited.

Visual Basic
Property ItemNumberLocked() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.ItemNumberLocked Property


BOMRow.ItemQuantity Property

BOMRow.ItemQuantity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the number of instances not marked as phantom or reference represented by this BOM row.

Visual Basic
Property ItemQuantity() As long*
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.ItemQuantity Property


BOMRow.Merged Property

BOMRow.Merged Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns whether this row is a result of a merging multiple rows. If true, the ComponentDefinitions property returns all the associated component definitions. This property will return False for all rows in the data BOMView.

Visual Basic
Property Merged() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.Merged Property


BOMRow.Parent Property

BOMRow.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent BOMView or the BOMRow object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.Parent Property


BOMRow.Promoted Property

BOMRow.Promoted Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns whether this row was promoted (for instance, as a result of the parent subassembly being marked phantom). This property will return False for all rows in the data BOMView.

Visual Basic
Property Promoted() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.Promoted Property


BOMRow.ReferencedFileDescriptor Property

BOMRow.ReferencedFileDescriptor Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the FileDescriptor for the component referenced by this row. This only applies to non merged component rows and non local components and immediately referenced components. Therefore this would only be useful in the data view.

Visual Basic
Property ReferencedFileDescriptor() As FileDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.ReferencedFileDescriptor Property


BOMRow.RolledUp Property

BOMRow.RolledUp Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Indicates whether this row is a result of rolling up multiple promoted rows of the same ComponentDefinition.

Visual Basic
Property RolledUp() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.RolledUp Property


BOMRow.TotalQuantity Property

BOMRow.TotalQuantity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the total quantity of the BOM item. This is either based on the unit quantity defined in the referenced ComponentDefinition times the ItemQuantity or is the override specified for this row. The TotalQuantityOverridden property can be used to determine whether this value has an override applied to it. Overrides cannot be set for parts only views.

Visual Basic
Property TotalQuantity() As String
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.TotalQuantity Property


BOMRow.TotalQuantityOverridden Property

BOMRow.TotalQuantityOverridden Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether the TotalQuantity property has been overridden. This property can only be set to False, in which case the override on the value will be removed.

Visual Basic
Property TotalQuantityOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.TotalQuantityOverridden Property


BOMRow.Type Property

BOMRow.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kBOMRowObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOMRow Interface > BOMRow Properties > BOMRow.Type Property


BOMRowsEnumerator Interface

BOMRowsEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The BOMRowsEnumerator object provides access to BOMRow objects.

Class Hierarchy
Inventor::BOMRowsEnumerator
Visual Basic
Public Interface BOMRowsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BOMRow.ChildRows

BOMView.BOMRows

You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface


BOMRowsEnumerator Methods

BOMRowsEnumerator Methods
Summary

The methods of the BOMRowsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns an item in the collection.
You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface > BOMRowsEnumerator Methods


BOMRowsEnumerator.Item Method

BOMRowsEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an item in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BOMRow*)
Parameters
Parameters | Description
index | Value that specifies the BOMRow to return. This is a numeric value indicating the index of the item in the collection. If an out of range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface > BOMRowsEnumerator Methods > BOMRowsEnumerator.Item Method


BOMRowsEnumerator Properties

BOMRowsEnumerator Properties
Summary

The properties of the BOMRowsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning kBOMRowsEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface > BOMRowsEnumerator Properties


BOMRowsEnumerator.Application Property

BOMRowsEnumerator.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface > BOMRowsEnumerator Properties > BOMRowsEnumerator.Application Property


BOMRowsEnumerator.Count Property

BOMRowsEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface > BOMRowsEnumerator Properties > BOMRowsEnumerator.Count Property


BOMRowsEnumerator.Type Property

BOMRowsEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kBOMRowsEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOMRowsEnumerator Interface > BOMRowsEnumerator Properties > BOMRowsEnumerator.Type Property


BOMView Interface

BOMView Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

The BOMView object represents a view (or an ordering scheme) of the BOM.

Class Hierarchy
Inventor::BOMView
Visual Basic
Public Interface BOMView
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

BOMViews.Item

See Also

Exporting the assembly BOM sample

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface


BOMView Methods

BOMView Methods
Summary

The methods of the BOMView class are listed here.

Methods
Methods
Name | Description
Export | Method that saves the BOM as viewed in this BOM view to an external file.
Renumber | Method that renumbers all rows in the BOM view. If the BOMRowsToRenumber argument is provided, only those rows are renumbered. Applies only to structured and parts only views. This method returns a failure for the model data BOM view.
Sort | Method that changes the sort order of items in the BOM view. Applies only to structured and parts only views. This method returns a failure for the model data BOM view.
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Methods


BOMView.Export Method

BOMView.Export Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that saves the BOM as viewed in this BOM view to an external file.

Visual Basic
Sub Export(FileName As String, FileFormat As FileFormatEnum, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
FileName | Input string that specifies the file name to export the BOM to.
FileFormat | Input FileFormatEnum that specifies the file format to save to.
Options | Optional input String that specifies the 'Table Name' for kMicrosoftAccess and kMicrosoftExcel file formats. This is the name of the Excel/Access sheet. If not provided, the name of the file is used as the sheet name. For other formats, this argument is ignored.
Example

Exporting the assembly BOM

This sample demonstrates exporting the Assembly BOM to an external file. This sample exports the structured and parts only views of the active assembly document to an Excel file. Other file formats are also supported.

Public Sub BOMExport()
    ' Set a reference to the assembly document.
    ' This assumes an assembly document is active.
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the BOM
    Dim oBOM As BOM
    Set oBOM = oDoc.ComponentDefinition.BOM

    ' Set the structured view to 'all levels'
    oBOM.StructuredViewFirstLevelOnly = False

    ' Make sure that the structured view is enabled.
    oBOM.StructuredViewEnabled = True

    ' Set a reference to the "Structured" BOMView
    Dim oStructuredBOMView As BOMView
    Set oStructuredBOMView = oBOM.BOMViews.Item("Structured")

    ' Export the BOM view to an Excel file
    oStructuredBOMView.Export "C:\temp\BOM-StructuredAllLevels.xls", kMicrosoftExcelFormat

    ' Make sure that the parts only view is enabled.
    oBOM.PartsOnlyViewEnabled = True

    ' Set a reference to the "Parts Only" BOMView
    Dim oPartsOnlyBOMView As BOMView
    Set oPartsOnlyBOMView = oBOM.BOMViews.Item("Parts Only")

    ' Export the BOM view to an Excel file
    oPartsOnlyBOMView.Export "C:\temp\BOM-PartsOnly.xls", kMicrosoftExcelFormat
End Sub
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Methods > BOMView.Export Method


BOMView.Renumber Method

BOMView.Renumber Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that renumbers all rows in the BOM view. If the BOMRowsToRenumber argument is provided, only those rows are renumbered. Applies only to structured and parts only views. This method returns a failure for the model data BOM view.

Visual Basic
Sub Renumber(ByRef StartValue As [defaultvalue(1)] long, ByRef Increment As [defaultvalue(1)] long, ByRef BOMRowsToRenumber As [optional] VARIANT)
Parameters
Parameters | Description
StartValue | Optional input long that specifies the start value for renumbering. If not specified, this value defaults to 1.
Increment | Optional input long that specifies the increment to use for renumbering. If not specified, this value defaults to 1.
BOMRowsToRenumber | Optional input ObjectCollection of BOMRow objects. If not supplied, all rows in the BOMView are renumbered. If provided, only the input rows are renumbered.
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Methods > BOMView.Renumber Method


BOMView.Sort Method

BOMView.Sort Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that changes the sort order of items in the BOM view. Applies only to structured and parts only views. This method returns a failure for the model data BOM view.

Visual Basic
Sub Sort(PrimaryColumnTitle As String, ByRef PrimaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef SecondaryColumnTitle As [defaultvalue("")] BSTR, ByRef SecondaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef TertiaryColumnTitle As [defaultvalue("")] BSTR, ByRef TertiaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
PrimaryColumnTitle | Input string that specifies the primary column to use for the sorting. If the name of a non-existing column is provided, an error occurs.
PrimaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
SecondaryColumnTitle | Optional input string that specifies the secondary column to use for the sorting. If the name of a non-existing column or the primary column is provided, an error occurs.
SecondaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
TertiaryColumnTitle | Optional input string that specifies the tertiary column to use for the sorting. If the name of a non-existing column, the primary column or the secondary column is provided, an error occurs.
TertiaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Methods > BOMView.Sort Method


BOMView Properties

BOMView Properties
Summary

The properties of the BOMView class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BOMRows | Property that gets the BOMRows enumerator object containing the top level BOM rows.
iAssemblyMemberName | Property that gets and sets the name of the iAssembly member that the BOM view is based on.
Name | Property that gets the name of the BOMView.
Parent | Property that returns the parent BOM object.
RevisionId | Property that returns the GUID that represents the last saved revision of this BOMView.
Type | Property returning kBOMViewObject indicating this objects type.
ViewType | Property that returns the BOM View type. Possible return values are kModelDataBOMViewType (for the 'raw' view), kStructuredBOMViewType (for the structured view) and kPartsOnlyBOMViewType (for the parts-only view).
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties


BOMView.Application Property

BOMView.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.Application Property


BOMView.BOMRows Property

BOMView.BOMRows Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the BOMRows enumerator object containing the top level BOM rows.

Visual Basic
Property BOMRows() As BOMRowsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.BOMRows Property


BOMView.iAssemblyMemberName Property

BOMView.iAssemblyMemberName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the name of the iAssembly member that the BOM view is based on.

Visual Basic
Property iAssemblyMemberName() As String
Remarks

Setting this property fails and the property returns a null string if the assembly document is not an iAssembly factory, or if the BOMView is not the structured view. The ItemQuantity and TotalQuantity properties are affected by setting this property. The property defaults to the name of the active member in the factory, and any changes to this property are temporary (not persisted with the document).

You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.iAssemblyMemberName Property


BOMView.Name Property

BOMView.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the name of the BOMView.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.Name Property


BOMView.Parent Property

BOMView.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent BOM object.

Visual Basic
Property Parent() As BOM**
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.Parent Property


BOMView.RevisionId Property

BOMView.RevisionId Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the GUID that represents the last saved revision of this BOMView.

Visual Basic
Property RevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.RevisionId Property


BOMView.Type Property

BOMView.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kBOMViewObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.Type Property


BOMView.ViewType Property

BOMView.ViewType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the BOM View type. Possible return values are kModelDataBOMViewType (for the 'raw' view), kStructuredBOMViewType (for the structured view) and kPartsOnlyBOMViewType (for the parts-only view).

Visual Basic
Property ViewType() As BOMViewTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOMView Interface > BOMView Properties > BOMView.ViewType Property


BOMViews Interface

BOMViews Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

The BOMViews collection object provides access to the existing BOMView objects.

Class Hierarchy
Inventor::BOMViews
Visual Basic
Public Interface BOMViews
Inherits IDispatch
Remarks

The first BOMView object in the collection represents the data or the assembly structure view of the BOM with no merge or sort rules applied.

Notes

Members through which this object may be accessed include:

BOM.BOMViews

You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface


BOMViews Methods

BOMViews Methods
Summary

The methods of the BOMViews class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified BOMView object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface > BOMViews Methods


BOMViews.Item Method

BOMViews.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified BOMView object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BOMView*)
Parameters
Parameters | Description
index | Input Variant value that specifies the BOMView to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the name of a BOMView. If an out of range index or a name of a non-existent BOMView is provided, an error will occur.
See Also

Exporting the assembly BOM sample

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface > BOMViews Methods > BOMViews.Item Method


BOMViews Properties

BOMViews Properties
Summary

The properties of the BOMViews class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBOMViewsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface > BOMViews Properties


BOMViews.Application Property

BOMViews.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface > BOMViews Properties > BOMViews.Application Property


BOMViews.Count Property

BOMViews.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface > BOMViews Properties > BOMViews.Count Property


BOMViews.Type Property

BOMViews.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kBOMViewsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BOMViews Interface > BOMViews Properties > BOMViews.Type Property


Border Interface

Border Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The Border object represents the instance of a border on a sheet.

Class Hierarchy
Inventor::Border
    Inventor::DefaultBorder
Visual Basic
Public Interface Border
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.Border

Sheet.AddBorder

See Also

Border Insert Default sample

Border Insert sample

Creating a parts list sample

Example

See DrawingDocument::BorderDefinitions for example "Creating and adding a new border"

You are here: Symbol Reference > Inventor Library > Objects > Border Interface


Border Methods

Border Methods
Summary

The methods of the Border class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the title block from the sheet.
GetResultText | Method that returns the text that is currently displayed for a specific text box. This is useful for text boxes that use input form other sources to define their content, i.e. properties and prompted text. The string displayed within this text box is returned.
SetPromptResultText | Method that sets the text that was supplied for a specified border that contains prompted text. The string displayed within this border is changed.
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Methods


Border.Delete Method

Border.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the title block from the sheet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Methods > Border.Delete Method


Border.GetResultText Method

Border.GetResultText Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the text that is currently displayed for a specific text box. This is useful for text boxes that use input form other sources to define their content, i.e. properties and prompted text. The string displayed within this text box is returned.

Visual Basic
Sub GetResultText(DefinitionText As TextBox, Result As [out, retval] BSTR)
Parameters
Parameters | Description
DefinitionText | Input object from the referenced TitleBlockDefinition object. This text box is used as in index to specify which text box in the instance to return the text for.
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Methods > Border.GetResultText Method


Border.SetPromptResultText Method

Border.SetPromptResultText Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that sets the text that was supplied for a specified border that contains prompted text. The string displayed within this border is changed.

Visual Basic
Sub SetPromptResultText(DefinitionText As TextBox, NewValue As String)
Parameters
Parameters | Description
DefinitionText | Input object from the referenced TitleBlockDefinition object. This text box is used to specify which prompted text box to set the text for.
NewValue | Input String that defines the new text to use for the specified prompted text.
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Methods > Border.SetPromptResultText Method


Border Properties

Border Properties
Summary

The properties of the Border class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Definition | Property returning the border definition object that this border is an instance of.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent sheet object.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties


Border.Application Property

Border.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties > Border.Application Property


Border.Definition Property

Border.Definition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the border definition object that this border is an instance of.

Visual Basic
Property Definition() As BorderDefinition**
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties > Border.Definition Property


Border.Name Property

Border.Name Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties > Border.Name Property


Border.Parent Property

Border.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the parent sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties > Border.Parent Property


Border.RangeBox Property

Border.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties > Border.RangeBox Property


Border.Type Property

Border.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Border Interface > Border Properties > Border.Type Property


BorderDefinition Interface

BorderDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The BorderDefinition object represents a border definition.

Class Hierarchy
Inventor::BorderDefinition
Visual Basic
Public Interface BorderDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Border.Definition

BorderDefinition.CopyTo

BorderDefinitions.Add

BorderDefinitions.Item

SheetFormat.ReferencedBorderDefinition

Example

See DrawingDocument::BorderDefinitions for example "Creating and adding a new border"

You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface


BorderDefinition Methods

BorderDefinition Methods
Summary

The methods of the BorderDefinition class are listed here.

Methods
Methods
Name | Description
CopyTo | Method that copies the definition to the target drawing document.
Delete | Method that deletes the BorderDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.
Edit | Method that opens a copy of the border definition's sketch for edit in the Sketch environment.
ExitEdit | Method that closes the currently active sketch (see below for limitations) and depending on the input parameters, replaces the sketch of the border definition with the edited sketch.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Methods


BorderDefinition.CopyTo Method

BorderDefinition.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that copies the definition to the target drawing document.

Visual Basic
Sub CopyTo(TargetDocument As DrawingDocument, ByRef ReplaceExisting As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] BorderDefinition*)
Parameters
Parameters | Description
TargetDocument | Input DrawingDocument object that specifies the document to copy the definition into.
ReplaceExisting | Optional input Boolean that specifies whether to replace or create a new definition with a different name if a definition of the same name exists in the target document. If not specified, the argument defaults to False indicating that a new definition will be created.
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Methods > BorderDefinition.CopyTo Method


BorderDefinition.Delete Method

BorderDefinition.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the BorderDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Methods > BorderDefinition.Delete Method


BorderDefinition.Edit Method

BorderDefinition.Edit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that opens a copy of the border definition's sketch for edit in the Sketch environment.

Visual Basic
Sub Edit(ByRef Sketch As DrawingSketch*)
Parameters
Parameters | Description
Sketch | Output DrawingSketch object. This is a copy of the DrawingSketch associated with the border definition. This new DrawingSketch is opened within the sketch environment.
Remarks

The DrawingSketch returned is a new sketch that Autodesk Inventor creates by copying the sketch associated with the border definition. The new sketch supports all edit operations. The ExitEdit method of the BorderDefinition object can be used to replace the border definition's sketch with the new sketch.

See Also

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Methods > BorderDefinition.Edit Method


BorderDefinition.ExitEdit Method

BorderDefinition.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that closes the currently active sketch (see below for limitations) and depending on the input parameters, replaces the sketch of the border definition with the edited sketch.

Visual Basic
Sub ExitEdit(ByRef SaveChanges As [defaultvalue(-1)] VARIANT_BOOL, ByRef SaveAsName As [optional] VARIANT)
Parameters
Parameters | Description
SaveChanges | Input Boolean that specifies whether to save the changes or not. True indicates to save the changes. Setting this property to False will cause the sketch to close and lose all edits.
SaveAsName | Input String that specifies the name of the new border definition to create. This argument is used in the case where the SaveChanges argument is True. If not specified, or an empty string is supplied, the edited sketch replaces the sketch associated with the border definition being edited. If a string is supplied, a new border definition is created and the edited sketch is used for it. The supplied name must be unique with respect to all other objects in the document.
Remarks

You can also choose to create a new border definition using the edited sketch or close the edited sketch without saving any changes. This method is only valid to be called when a sketch associated with a BorderDefinition object has been opened for edit using the Edit method of the BorderDefinition object, otherwise an error will occur.

See Also

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Methods > BorderDefinition.ExitEdit Method


BorderDefinition.GetReferenceKey Method

BorderDefinition.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Methods > BorderDefinition.GetReferenceKey Method


BorderDefinition Properties

BorderDefinition Properties
Summary

The properties of the BorderDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
IsDefault | Gets if the border definition is default or not.
IsReferenced | Property that specifies if the border definition is being referenced or not. A border definition is referenced whenever it is used on a sheet. A referenced border definition cannot be deleted.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent .
Sketch | Property that returns the sketch associated with the border definition. The DrawingSketch returned by the Sketch property supports all query functionality but cannot be edited. To edit the contents of a border definition, use the Edit method. This creates a copy of the border definition's sketch for edit. The ExitEdit method of the BorderDefinition can then be used to save the edited sketch as the border definition's sketch.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties


BorderDefinition.Application Property

BorderDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.Application Property


BorderDefinition.AttributeSets Property

BorderDefinition.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.AttributeSets Property


BorderDefinition.IsDefault Property

BorderDefinition.IsDefault Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets if the border definition is default or not.

Visual Basic
Property IsDefault() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.IsDefault Property


BorderDefinition.IsReferenced Property

BorderDefinition.IsReferenced Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies if the border definition is being referenced or not. A border definition is referenced whenever it is used on a sheet. A referenced border definition cannot be deleted.

Visual Basic
Property IsReferenced() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.IsReferenced Property


BorderDefinition.Name Property

BorderDefinition.Name Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.Name Property


BorderDefinition.Parent Property

BorderDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the parent .

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.Parent Property


BorderDefinition.Sketch Property

BorderDefinition.Sketch Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the sketch associated with the border definition. The DrawingSketch returned by the Sketch property supports all query functionality but cannot be edited. To edit the contents of a border definition, use the Edit method. This creates a copy of the border definition's sketch for edit. The ExitEdit method of the BorderDefinition can then be used to save the edited sketch as the border definition's sketch.

Visual Basic
Property Sketch() As DrawingSketch**
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.Sketch Property


BorderDefinition.Type Property

BorderDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinition Interface > BorderDefinition Properties > BorderDefinition.Type Property


BorderDefinitions Interface

BorderDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The BorderDefinitions collection object provides access to all the existing objects in a drawing document and provides methods to create additional border definitions.

Class Hierarchy
Inventor::BorderDefinitions
Visual Basic
Public Interface BorderDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.BorderDefinitions

See Also

Border Create and Insert sample

Example

See DrawingDocument::BorderDefinitions for example "Creating and adding a new border"

You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface


BorderDefinitions Methods

BorderDefinitions Methods
Summary

The methods of the BorderDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new border definition. The new BorderDefinition object is returned. This method will fail in the case where a sketch is currently active. You can check for this case using the ActiveEditObject property of the Application object to see if a sketch is active.
Item | Property that returns the specified BorderDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Methods


BorderDefinitions.Add Method

BorderDefinitions.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new border definition. The new BorderDefinition object is returned. This method will fail in the case where a sketch is currently active. You can check for this case using the ActiveEditObject property of the Application object to see if a sketch is active.

Visual Basic
Sub Add(Name As String, Result As [out, retval] BorderDefinition*)
Parameters
Parameters | Description
Name | Input String that defines the name of the new border definition. The name specified must be unique with respect to the other border definitions in the document. If a unique name is not specified, an error will occur.
See Also

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Methods > BorderDefinitions.Add Method


BorderDefinitions.Item Method

BorderDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified BorderDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BorderDefinition*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the border definition's name. If an out-of-range index or a name of a non-existent border definition is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Methods > BorderDefinitions.Item Method


BorderDefinitions Properties

BorderDefinitions Properties
Summary

The properties of the BorderDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Properties


BorderDefinitions.Application Property

BorderDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Properties > BorderDefinitions.Application Property


BorderDefinitions.Count Property

BorderDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Properties > BorderDefinitions.Count Property


BorderDefinitions.Type Property

BorderDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BorderDefinitions Interface > BorderDefinitions Properties > BorderDefinitions.Type Property


BossFeature Interface

BossFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BossFeature object represents a boss feature within the model.

Class Hierarchy
Inventor::PartFeature
    Inventor::BossFeature
        Inventor::BossFeatureProxy
Visual Basic
Public Interface BossFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

BossFeatureProxy.NativeObject

BossFeatures.Item

Most functionality reserved for future implementation.

You are here: Symbol Reference > Inventor Library > Objects > BossFeature Interface


BossFeatureProxy Interface

BossFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BossFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::BossFeature
        Inventor::BossFeatureProxy
Visual Basic
Public Interface BossFeatureProxy
Inherits BossFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BossFeatureProxy Interface


BossFeatureProxy Properties

BossFeatureProxy Properties
Summary

The properties of the BossFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > BossFeatureProxy Interface > BossFeatureProxy Properties


BossFeatureProxy.ContainingOccurrence Property

BossFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BossFeatureProxy Interface > BossFeatureProxy Properties > BossFeatureProxy.ContainingOccurrence Property


BossFeatureProxy.NativeObject Property

BossFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As BossFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BossFeatureProxy Interface > BossFeatureProxy Properties > BossFeatureProxy.NativeObject Property


BossFeatures Interface

BossFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BossFeatures collection object provides access to existing boss features.

Class Hierarchy
Inventor::BossFeatures
Visual Basic
Public Interface BossFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.BossFeatures

You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface


BossFeatures Methods

BossFeatures Methods
Summary

The methods of the BossFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface > BossFeatures Methods


BossFeatures.Item Method

BossFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BossFeature*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface > BossFeatures Methods > BossFeatures.Item Method


BossFeatures Properties

BossFeatures Properties
Summary

The properties of the BossFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface > BossFeatures Properties


BossFeatures.Application Property

BossFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface > BossFeatures Properties > BossFeatures.Application Property


BossFeatures.Count Property

BossFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface > BossFeatures Properties > BossFeatures.Count Property


BossFeatures.Type Property

BossFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BossFeatures Interface > BossFeatures Properties > BossFeatures.Type Property


BossSet Interface

BossSet Interface Available in Inventor Introduced in Inventor 2012
Summary

The BossSet object contains the definition for a boss for the rib feature.

Class Hierarchy
Inventor::BossSet
Visual Basic
Public Interface BossSet
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface


BossSet Methods

BossSet Methods
Summary

The methods of the BossSet class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the BossSet from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Methods


BossSet.Delete Method

BossSet.Delete Method Available in Inventor Introduced in Inventor 2012
Summary

Method that deletes the BossSet from the collection.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Methods > BossSet.Delete Method


BossSet Properties

BossSet Properties
Summary

The properties of the BossSet class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Centers | Property that gets and sets the collection of SketchPoint objects which specify the boss centers.
Diameter | Property that provides access to the boss diameter.
Offset | Property that provides access to the boss offset.
Parent | Property that returns the parent RibDefinition object.
TaperAngle | Property that provides access to the taper angle of the boss.
Type | Property returning kBossSetObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties


BossSet.Application Property

BossSet.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.Application Property


BossSet.Centers Property

BossSet.Centers Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the collection of SketchPoint objects which specify the boss centers.

Visual Basic
Property Centers() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.Centers Property


BossSet.Diameter Property

BossSet.Diameter Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the boss diameter.

Visual Basic
Property Diameter() As VARIANT
Remarks

This property is writable when the RibDefinition object has been created using the RibFeatures.CreateDefinition or RibDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyDiameter * 2” is valid, assuming there is a parameter named MyDiameter.

When the RibDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the diameter. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.Diameter Property


BossSet.Offset Property

BossSet.Offset Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the boss offset.

Visual Basic
Property Offset() As VARIANT
Remarks

This property is writable when the RibDefinition object has been created using the RibFeatures.CreateDefinition or RibDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyOffset * 2” is valid, assuming there is a parameter named MyOffset.

When the RibDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the diameter. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.Offset Property


BossSet.Parent Property

BossSet.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent RibDefinition object.

Visual Basic
Property Parent() As RibDefinition**
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.Parent Property


BossSet.TaperAngle Property

BossSet.TaperAngle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the taper angle of the boss.

Visual Basic
Property TaperAngle() As VARIANT
Remarks

This property is writable when the RibDefinition object has been created using the RibFeatures.CreateDefinition or RibDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyTaperAngle * 2” is valid, assuming there is a parameter named MyTaperAngle.

When the RibDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the diameter. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.TaperAngle Property


BossSet.Type Property

BossSet.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBossSetObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BossSet Interface > BossSet Properties > BossSet.Type Property


BossSets Interface

BossSets Interface Available in Inventor Introduced in Inventor 2012
Summary

The BossSets collection object contains all the boss definitions for the parent feature.

Class Hierarchy
Inventor::BossSets
Visual Basic
Public Interface BossSets
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface


BossSets Methods

BossSets Methods
Summary

The methods of the BossSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new BossSet. The newly created BossSet is returned.
Item | Returns the specified BossSet object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Methods


BossSets.Add Method

BossSets.Add Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new BossSet. The newly created BossSet is returned.

Visual Basic
Sub Add(Centers As ObjectCollection, Type As BossTypeEnum, Diameter As VARIANT, Offset As VARIANT, Taper As VARIANT, Result As [out, retval] BossSet*)
Parameters
Parameters | Description
Centers | Input ObjectCollection containing SketchPoint objects that define boss centers.
Type | Input BossTypeEnum that defines the boss type. This can either be kHeadBossType or kThreadBossType.
Diameter | Input Variant that defines the boss diameter. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Offset | Input Variant that defines the offset value. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Taper | Input Variant that defines the taper angle for the boss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Methods > BossSets.Add Method


BossSets.Item Method

BossSets.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Returns the specified BossSet object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BossSet*)
Parameters
Parameters | Description
Index | Input Long value that specifies the BossSet to return. This is a numeric value indicating the index of the item in the collection. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Methods > BossSets.Item Method


BossSets Properties

BossSets Properties
Summary

The properties of the BossSets class are listed here.

Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class BossSets.
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBossSetsObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Properties


BossSets._NewEnum Property

BossSets._NewEnum Property
Summary

This is _NewEnum, a member of class BossSets.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Properties > BossSets._NewEnum Property


BossSets.Application Property

BossSets.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Properties > BossSets.Application Property


BossSets.Count Property

BossSets.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Properties > BossSets.Count Property


BossSets.Type Property

BossSets.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kBossSetsObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BossSets Interface > BossSets Properties > BossSets.Type Property


BoundaryPatchDefinition Interface

BoundaryPatchDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The BoundaryPatchDefinition object is used to define the input required for creating boundary patch features.

Class Hierarchy
Inventor::BoundaryPatchDefinition
Visual Basic
Public Interface BoundaryPatchDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BoundaryPatchFeature.Definition

BoundaryPatchFeatures.CreateBoundaryPatchDefinition

See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchDefinition Interface


BoundaryPatchDefinition Properties

BoundaryPatchDefinition Properties
Summary

The properties of the BoundaryPatchDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BoundaryPatchLoops | Property that specifies the set of boundary loops used to create the boundary patch feature.
Type | Property that returns kBoundaryPatchDefinitionObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchDefinition Interface > BoundaryPatchDefinition Properties


BoundaryPatchDefinition.Application Property

BoundaryPatchDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchDefinition Interface > BoundaryPatchDefinition Properties > BoundaryPatchDefinition.Application Property


BoundaryPatchDefinition.BoundaryPatchLoops Property

BoundaryPatchDefinition.BoundaryPatchLoops Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the set of boundary loops used to create the boundary patch feature.

Visual Basic
Property BoundaryPatchLoops() As BoundaryPatchLoops**
Remarks

When using this property during the creation of a boundary patch feature, the collection will be initially empty, but the Add method can be used to add boundary loops for the boundary patch feature.

See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchDefinition Interface > BoundaryPatchDefinition Properties > BoundaryPatchDefinition.BoundaryPatchLoops Property


BoundaryPatchDefinition.Type Property

BoundaryPatchDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kBoundaryPatchDefinitionObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchDefinition Interface > BoundaryPatchDefinition Properties > BoundaryPatchDefinition.Type Property


BoundaryPatchFeature Interface

BoundaryPatchFeature Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is the Part BoundaryPatchFeature object. A BoundaryPatchFeature is produced by the creation of a planar surface within the specified boundary.

Class Hierarchy
Inventor::PartFeature
    Inventor::BoundaryPatchFeature
        Inventor::BoundaryPatchFeatureProxy
Visual Basic
Public Interface BoundaryPatchFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

BoundaryPatchFeatureProxy.NativeObject

BoundaryPatchFeatures.Add

BoundaryPatchFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeature Interface


BoundaryPatchFeature Properties

BoundaryPatchFeature Properties
Summary

The properties of the BoundaryPatchFeature class are listed here.

Properties
Name | Description
Definition | Property that returns the BoundaryPatchDefinition object which defines the various input used to create the boundary patch feature.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeature Interface > BoundaryPatchFeature Properties


BoundaryPatchFeature.Definition Property

BoundaryPatchFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the BoundaryPatchDefinition object which defines the various input used to create the boundary patch feature.

Visual Basic
Property Definition() As BoundaryPatchDefinition**
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeature Interface > BoundaryPatchFeature Properties > BoundaryPatchFeature.Definition Property


BoundaryPatchFeatureProxy Interface

BoundaryPatchFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the BoundaryPatchFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::BoundaryPatchFeature
        Inventor::BoundaryPatchFeatureProxy
Visual Basic
Public Interface BoundaryPatchFeatureProxy
Inherits BoundaryPatchFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatureProxy Interface


BoundaryPatchFeatureProxy Properties

BoundaryPatchFeatureProxy Properties
Summary

The properties of the BoundaryPatchFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through. The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatureProxy Interface > BoundaryPatchFeatureProxy Properties


BoundaryPatchFeatureProxy.ContainingOccurrence Property

BoundaryPatchFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that the native object is being referenced through. The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatureProxy Interface > BoundaryPatchFeatureProxy Properties > BoundaryPatchFeatureProxy.ContainingOccurrence Property


BoundaryPatchFeatureProxy.NativeObject Property

BoundaryPatchFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As BoundaryPatchFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatureProxy Interface > BoundaryPatchFeatureProxy Properties > BoundaryPatchFeatureProxy.NativeObject Property


BoundaryPatchFeatures Interface

BoundaryPatchFeatures Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The BoundaryPatchFeatures collection object provides access to all of the objects in a part component definition and provides methods to create additional BoundaryPatchFeatures.

Class Hierarchy
Inventor::BoundaryPatchFeatures
Visual Basic
Public Interface BoundaryPatchFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.BoundaryPatchFeatures

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface


BoundaryPatchFeatures Methods

BoundaryPatchFeatures Methods
Summary

The methods of the BoundaryPatchFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new boundary patch feature.
CreateBoundaryPatchDefinition | Method that creates a BoundaryPatchDefinition object that defines the input definition for a boundary patch feature.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Methods


BoundaryPatchFeatures.Add Method

BoundaryPatchFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new boundary patch feature.

Visual Basic
Sub Add(Definition As BoundaryPatchDefinition, Result As [out, retval] BoundaryPatchFeature*)
Parameters
Parameters | Description
Definition | Input BoundaryPatchDefinition object that defines the input definition for the boundary patch feature. The BoundaryPatchDefinition object can be created using the CreateBoundaryPatchDefinition method of the BoundaryPatchFeatures object. The BoundaryPatchDefinition object defines the boundary loops for creating the boundary patch feature.
Example

This sample demonstrates the creation of Delete Face, Boundary Patch and Stitch features.

Public Sub BoundaryPatchFeature()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Dim oRectangleLines As SketchEntitiesEnumerator
    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a base extrusion 1cm thick.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfile, 1, kNegativeExtentDirection, kJoinOperation)

    ' Get the top face of the extrusion
    Dim oFrontFace As Face
    Set oFrontFace = oExtrude.StartFaces.Item(1)

    Dim oEdgeColl As EdgeCollection
    Set oEdgeColl = ThisApplication.TransientObjects.CreateEdgeCollection

    ' Collect up the edges to create boundary patch.
    Dim oEdge As Edge
    For Each oEdge In oFrontFace.Edges
        oEdgeColl.Add oEdge
    Next

    ' Create a Delete Face feature to delete the top face.
    Dim oFaceColl As FaceCollection
    Set oFaceColl = ThisApplication.TransientObjects.CreateFaceCollection
    Call oFaceColl.Add(oFrontFace)

    Dim oDeleteFace As DeleteFaceFeature
    Set oDeleteFace = oCompDef.Features.DeleteFaceFeatures.Add(oFaceColl)

    Dim oBoundaryPatchDef As BoundaryPatchDefinition
    Set oBoundaryPatchDef = oCompDef.Features.BoundaryPatchFeatures.CreateBoundaryPatchDefinition

    ' Create a boundary patch feature based on the edges of the deleted face.
    Call oBoundaryPatchDef.BoundaryPatchLoops.Add(oEdgeColl)

    Dim oBoundaryPatch As BoundaryPatchFeature
    Set oBoundaryPatch = oCompDef.Features.BoundaryPatchFeatures.Add(oBoundaryPatchDef)

    ' Stitch the boundary patch surface to the original body.
    Dim oSurfaceToStitch As ObjectCollection
    Set oSurfaceToStitch = ThisApplication.TransientObjects.CreateObjectCollection

    Call oSurfaceToStitch.Add(oBoundaryPatch.SurfaceBody)
    Call oSurfaceToStitch.Add(oCompDef.SurfaceBodies.Item(1))

    Dim oStitch As KnitFeature
    Set oStitch = oCompDef.Features.KnitFeatures.Add(oSurfaceToStitch)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Methods > BoundaryPatchFeatures.Add Method


BoundaryPatchFeatures.CreateBoundaryPatchDefinition Method

BoundaryPatchFeatures.CreateBoundaryPatchDefinition Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a BoundaryPatchDefinition object that defines the input definition for a boundary patch feature.

Visual Basic
Sub CreateBoundaryPatchDefinition(Result As [out, retval] BoundaryPatchDefinition*)
Remarks

The functionality provided by the resulting BoundaryPatchDefinition object can be used to define the input data for creating the boundary patch feature which includes the boundary loops that need to be patched.

See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Methods > BoundaryPatchFeatures.CreateBoundaryPatchDefinition Method


BoundaryPatchFeatures.Item Method

BoundaryPatchFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BoundaryPatchFeature*)
Parameters
Parameters | Description
index | Input Variant that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Methods > BoundaryPatchFeatures.Item Method


BoundaryPatchFeatures Properties

BoundaryPatchFeatures Properties
Summary

The properties of the BoundaryPatchFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Properties


BoundaryPatchFeatures.Application Property

BoundaryPatchFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Properties > BoundaryPatchFeatures.Application Property


BoundaryPatchFeatures.Count Property

BoundaryPatchFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Properties > BoundaryPatchFeatures.Count Property


BoundaryPatchFeatures.Type Property

BoundaryPatchFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchFeatures Interface > BoundaryPatchFeatures Properties > BoundaryPatchFeatures.Type Property


BoundaryPatchLoop Interface

BoundaryPatchLoop Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The BoundaryPatchLoop object is used to define a boundary loop for a boundary patch feature.

Class Hierarchy
Inventor::BoundaryPatchLoop
Visual Basic
Public Interface BoundaryPatchLoop
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BoundaryPatchLoops.Add

BoundaryPatchLoops.Item

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface


BoundaryPatchLoop Methods

BoundaryPatchLoop Methods
Summary

The methods of the BoundaryPatchLoop class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this boundary patch loop.
GetBoundaryCondition | Method that gets the boundary condition for the specified boundary path loop entity.
SetBoundaryCondition | Method that sets the boundary condition for the specified boundary path loop entity.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Methods


BoundaryPatchLoop.Delete Method

BoundaryPatchLoop.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes this boundary patch loop.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Methods > BoundaryPatchLoop.Delete Method


BoundaryPatchLoop.GetBoundaryCondition Method

BoundaryPatchLoop.GetBoundaryCondition Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that gets the boundary condition for the specified boundary path loop entity.

Visual Basic
Sub GetBoundaryCondition(BoundaryPathEntity As IDispatch, Result As [out, retval] BoundaryPatchConditionEnum)
Parameters
Parameters
Description
BoundaryPathEntity
Input object that specifies the boundary path loop entity for which the boundary condition needs to be returned. If a boundary condition is not applicable to the boundary path entity, then this method will fail. The valid objects for the boundary path entity depend on the type of the boundary path object, i.e. the object returned by the BoundaryPath property. The following list shows the valid BoundaryPathEntity objects for the corresponding BoundaryPath object:

  • If BoundaryPath object is Profile3D, then the BoundaryPathEntity object can be one of the sketch 3D entities that constitute the Profile3D.
  • If BoundaryPath object is Path, then the BoundaryPathEntity object can be one of the sketch 2D or 3D entities that constitute the Path.
  • If BoundaryPath object is EdgeLoop, then the BoundaryPathEntity object can be one of the edges that constitute the EdgeLoop.
  • If BoundaryPath object is EdgeCollection, then the BoundaryPathEntity object can be one of the edges that belong to the EdgeCollection.
  • If BoundaryPath object is an ObjectCollection that contains SketchEntity, SketchEntity3D or Edge objects, then the BoundaryPathEntity object can be one of the entities that belong to the ObjectCollection.

Remarks

The method returns a constant that indicates the boundary condition that has been applied. The constant is one of the values in BoundaryPatchConditionEnum: kFreeBoundaryPatchCondition or kTangentBoundaryPatchCondition.

Notes

If the boundary path object, i.e. the object returned by the BoundaryPath property is a Profile then the boundary condition does not apply. If the Profile object or one of the sketch 2D entities that constitute the profile is specified for the BoundaryPathEntity argument then, this method will fail.

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Methods > BoundaryPatchLoop.GetBoundaryCondition Method


BoundaryPatchLoop.SetBoundaryCondition Method

BoundaryPatchLoop.SetBoundaryCondition Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the boundary condition for the specified boundary path loop entity.

Visual Basic
Sub SetBoundaryCondition(BoundaryPathEntity As IDispatch, BoundaryPathCondition As BoundaryPatchConditionEnum)
Parameters
Parameters
Description
BoundaryPathEntity
Input object that specifies the boundary path loop entity to which the boundary condition needs to be applied. If a boundary condition is not applicable to the boundary path entity, then this method will fail. The valid objects for the boundary path entity depend on the type of the boundary path object, i.e. the object returned by the BoundaryPath property. The following table lists the valid BoundaryPathEntity objects for the corresponding BoundaryPath object:
If BoundaryPath object is: Then, the BoundaryPathEntity object can be:
Profile3D One of the sketch 3D entities that constitute the Profile3D
Path One of the sketch 2D or 3D entities that constitute the Path
EdgeLoop One of the edges that constitute the EdgeLoop
EdgeCollection One of the edges that belong to the EdgeCollection
ObjectCollection that contains SketchEntity, SketchEntity3D or Edge objects One of the entities that belong to the ObjectCollectionNote: If the boundary path object, i.e. the object returned by the BoundaryPath property is a Profile then the boundary condition does not apply. If the Profile object or one of the sketch 2D entities that constitute the profile is specified for the BoundaryPathEntity argument then, this method will fail.
BoundaryPathCondition
Input constant that specifies the type of boundary condition to apply. Valid input is one of the values in BoundaryPatchConditionEnum: kFreeBoundaryPatchCondition or kTangentBoundaryPatchCondition. If the specified condition cannot be applied to the boundary path entity, then this method will fail.
Notes

If the boundary path object, i.e. the object returned by the BoundaryPath property is a Profile then the boundary condition does not apply. If the Profile object or one of the sketch 2D entities that constitute the profile is specified for the BoundaryPathEntity argument then, this method will fail.

If the specified condition cannot be applied to the boundary path entity, then this method will fail.

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Methods > BoundaryPatchLoop.SetBoundaryCondition Method


BoundaryPatchLoop Properties

BoundaryPatchLoop Properties
Summary

The properties of the BoundaryPatchLoop class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BoundaryPath | Property that gets and sets the boundary path for a boundary patch loop.
Type | Property that returns kBoundaryPatchLoopObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Properties


BoundaryPatchLoop.Application Property

BoundaryPatchLoop.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Properties > BoundaryPatchLoop.Application Property


BoundaryPatchLoop.BoundaryPath Property

BoundaryPatchLoop.BoundaryPath Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the boundary path for a boundary patch loop.

Visual Basic
Property BoundaryPath() As IDispatch*
Remarks

Valid objects for the boundary path can be one of the following types:

' One of the following objects: Path, Profile, Profile3D, EdgeLoop or EdgeCollection.

If this property is set to a Path, Profile or Profile3D object to specify a new boundary path, then it must represent a set of connected sketch entities that form a closed loop, otherwise setting this property will fail. If an EdgeCollection object is specified, then it must contain a set of tangentially connected edges that form a closed loop, otherwise setting this property will fail.

' An ObjectCollection that can contain any combination of SketchEntity, SketchEntity3D and Edge objects.

These objects can be used to specify a set of connected entities that form a closed boundary loop. Also, the order of the objects in the collection must be such that the entities that represent them are end-to-end connected. If the entities do not form a closed loop or if their order in the collection does not represent a set of end-to-end connected entities, then setting this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Properties > BoundaryPatchLoop.BoundaryPath Property


BoundaryPatchLoop.Type Property

BoundaryPatchLoop.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kBoundaryPatchLoopObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoop Interface > BoundaryPatchLoop Properties > BoundaryPatchLoop.Type Property


BoundaryPatchLoops Interface

BoundaryPatchLoops Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The BoundaryPatchLoops object is used to define the boundary loops for a boundary patch feature.

Class Hierarchy
Inventor::BoundaryPatchLoops
Visual Basic
Public Interface BoundaryPatchLoops
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BoundaryPatchDefinition.BoundaryPatchLoops

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface


BoundaryPatchLoops Methods

BoundaryPatchLoops Methods
Summary

The methods of the BoundaryPatchLoops class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new BoundaryPatchLoop object using the specified boundary path.
Item | Method that returns the specified BoundaryPatchLoop object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Methods


BoundaryPatchLoops.Add Method

BoundaryPatchLoops.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new BoundaryPatchLoop object using the specified boundary path.

Visual Basic
Sub Add(BoundaryPath As IDispatch, Result As [out, retval] BoundaryPatchLoop*)
Parameters
Parameters
Description
BoundaryPath
Input Object that defines the boundary path for a boundary patch loop. Valid objects for the boundary path can be one of the following types:
One of the following objects: Path, Profile, Profile3D, EdgeLoop or EdgeCollection If a Path, Profile or Profile3D object is specified, then it must represent a set of connected sketch entities that form a closed loop, otherwise the creation of the boundary loop will fail. If an EdgeCollection object is specified, then it must contain a set of tangentially connected edges that form a closed loop, otherwise the creation of the boundary loop will fail.
An ObjectCollection that can contain any combination of SketchEntity, SketchEntity3D and Edge objects These objects can be used to specify a set of connected entities that form a closed boundary loop. Also, the order of the objects in the collection must be such that the entities that represent them are end-to-end connected. If the entities do not form a closed loop or if their order in the collection does not represent a set of end-to-end connected entities, then the creation of the boundary loop will fail.
Remarks

You can then use functionality provided by the resulting BoundaryPatchLoop object to access the entities that constitute the boundary loop and define the boundary conditions, if applicable, for these boundary entities.

See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Methods > BoundaryPatchLoops.Add Method


BoundaryPatchLoops.Item Method

BoundaryPatchLoops.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the specified BoundaryPatchLoop object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BoundaryPatchLoop*)
Parameters
Parameters | Description
index | Input Long value that specifies the BoundaryPatchLoop to return.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Methods > BoundaryPatchLoops.Item Method


BoundaryPatchLoops Properties

BoundaryPatchLoops Properties
Summary

The properties of the BoundaryPatchLoops class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of BoundaryPatchLoop objects in the collection.
Type | Property that returns kBoundaryPatchLoopsObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Properties


BoundaryPatchLoops.Application Property

BoundaryPatchLoops.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Properties > BoundaryPatchLoops.Application Property


BoundaryPatchLoops.Count Property

BoundaryPatchLoops.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the number of BoundaryPatchLoop objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Properties > BoundaryPatchLoops.Count Property


BoundaryPatchLoops.Type Property

BoundaryPatchLoops.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kBoundaryPatchLoopsObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BoundaryPatchLoops Interface > BoundaryPatchLoops Properties > BoundaryPatchLoops.Type Property


Box Interface

Box Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Box object is a mathematical utility object that represents a rectangular box whose faces are always parallel to the model XYZ planes. A common use of the Box object is as a means of passing the range box information of an entity and interacting with that range box.

Class Hierarchy
Inventor::Box
Visual Basic
Public Interface Box
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ClientGraphics.RangeBox

ComponentDefinition.RangeBox

ComponentOccurrence.RangeBox

CurveEvaluator.RangeBox

EdgeLoop.RangeBox

FaceShell.RangeBox

GraphicsNode.RangeBox

GraphicsPrimitive.RangeBox

PartFeature.RangeBox

SketchEntity3D.RangeBox

SurfaceBody.RangeBox

SurfaceEvaluator.RangeBox

TransientGeometry.CreateBox

See Also

Create primitive BRep sample

Text Using Client Graphics (Multiple fonts and lines) sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > Box Interface


Box Methods

Box Methods
Summary

The methods of the Box class are listed here.

Methods
Methods
Name | Description
Contains | Determines whether the specified point is contained within this Box.
Expand | Expands the Box on all sides by the specified distance.
Extend | Extends the Box to include the specified point.
GetBoxData | Get the data defining this Box.
IsDisjoint | Determines whether this Box does not intersect with the specified Box.
PutBoxData | Method that sets the data defining this Box.
You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods


Box.Contains Method

Box.Contains Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determines whether the specified point is contained within this Box.

Visual Basic
Sub Contains(Point As Point, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Input object that specifies the point.
You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods > Box.Contains Method


Box.Expand Method

Box.Expand Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Expands the Box on all sides by the specified distance.

Visual Basic
Sub Expand(Distance As double)
Parameters
Parameters | Description
Distance | Input Double that defines the distance by which to expand the box.
See Also

Create primitive BRep sample

You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods > Box.Expand Method


Box.Extend Method

Box.Extend Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Extends the Box to include the specified point.

Visual Basic
Sub Extend(Point As Point)
Parameters
Parameters | Description
Point | Input object that specifies the point.
You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods > Box.Extend Method


Box.GetBoxData Method

Box.GetBoxData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this Box.

Visual Basic
Sub GetBoxData(ByRef MinPoint As SAFEARRAY(double), ByRef MaxPoint As SAFEARRAY(double))
Parameters
Parameters | Description
MinPoint | Input Double array that sets the smallest coordinate values for the box.
MaxPoint | Input Double array that sets the largest coordinate values for the box.
See Also

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods > Box.GetBoxData Method


Box.IsDisjoint Method

Box.IsDisjoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determines whether this Box does not intersect with the specified Box.

Visual Basic
Sub IsDisjoint(Box As Box, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Box | Input object to compare.
You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods > Box.IsDisjoint Method


Box.PutBoxData Method

Box.PutBoxData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this Box.

Visual Basic
Sub PutBoxData(ByRef MinPoint As SAFEARRAY(double), ByRef MaxPoint As SAFEARRAY(double))
Parameters
Parameters | Description
MinPoint | Input Double array that sets the smallest coordinate values for the box.
MaxPoint | Input Double array that sets the largest coordinate values for the box.
You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Methods > Box.PutBoxData Method


Box Properties

Box Properties
Summary

The properties of the Box class are listed here.

Properties
Name | Description
MaxPoint | Property that gets and sets the maximum corner of the box.
MinPoint | Property that gets and sets the minimum corner of the box.
You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Properties


Box.MaxPoint Property

Box.MaxPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the maximum corner of the box.

Visual Basic
Property MaxPoint() As Point*
See Also

Text Using Client Graphics (Multiple fonts and lines) sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Properties > Box.MaxPoint Property


Box.MinPoint Property

Box.MinPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the minimum corner of the box.

Visual Basic
Property MinPoint() As Point*
See Also

Text Using Client Graphics (Multiple fonts and lines) sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > Box Interface > Box Properties > Box.MinPoint Property


Box2d Interface

Box2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Box2d object is a mathematical utility object that represents a rectangle whose edges are always parallel to the x-y axes. A common use of the Box2d object is as a means of passing the range box information of a 2d entity and interacting with that range box.

Class Hierarchy
Inventor::Box2d
Visual Basic
Public Interface Box2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Border.RangeBox

Curve2dEvaluator.RangeBox

CustomTable.RangeBox

DimensionText.RangeBox

DrawingNote.RangeBox

DrawingViewLabel.RangeBox

HoleTable.RangeBox

HoleTag.RangeBox

PartsList.RangeBox

RevisionTable.RangeBox

SketchEntity.RangeBox

SurfaceEvaluator.ParamRangeRect

TextBox.RangeBox

TitleBlock.RangeBox

TransientGeometry.CreateBox2d

You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface


Box2d Methods

Box2d Methods
Summary

The methods of the Box2d class are listed here.

Methods
Methods
Name | Description
Contains |
Expand |
Extend |
GetBoxData | Get the data defining this Box.
IsDisjoint |
PutBoxData | Method that sets the data defining this Box.
You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods


Box2d.Contains Method

Box2d.Contains Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub Contains(Point As Point2d, Result As [out, retval] VARIANT_BOOL)
Notes

For information on this item, please refer to Box::Contains, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods > Box2d.Contains Method


Box2d.Expand Method

Box2d.Expand Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub Expand(Distance As double)
Notes

For information on this item, please refer to Box::Expand, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods > Box2d.Expand Method


Box2d.Extend Method

Box2d.Extend Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub Extend(Point As Point2d)
Notes

For information on this item, please refer to Box::Extend, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods > Box2d.Extend Method


Box2d.GetBoxData Method

Box2d.GetBoxData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this Box.

Visual Basic
Sub GetBoxData(ByRef MinPoint As SAFEARRAY(double), ByRef MaxPoint As SAFEARRAY(double))
Parameters
Parameters | Description
MinPoint | Input Double array that sets the smallest coordinate values for the box.
MaxPoint | Input Double array that sets the largest coordinate values for the box.
You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods > Box2d.GetBoxData Method


Box2d.IsDisjoint Method

Box2d.IsDisjoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub IsDisjoint(Box As Box2d, Result As [out, retval] VARIANT_BOOL)
Notes

For information on this item, please refer to Box::IsDisjoint, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods > Box2d.IsDisjoint Method


Box2d.PutBoxData Method

Box2d.PutBoxData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this Box.

Visual Basic
Sub PutBoxData(ByRef MinPoint As SAFEARRAY(double), ByRef MaxPoint As SAFEARRAY(double))
Parameters
Parameters | Description
MinPoint | Input Double array that sets the smallest coordinate values for the box.
MaxPoint | Input Double array that sets the largest coordinate values for the box.
You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Methods > Box2d.PutBoxData Method


Box2d Properties

Box2d Properties
Summary

The properties of the Box2d class are listed here.

Properties
Name | Description
MaxPoint | Property that gets and sets the maximum corner of the box.
MinPoint | Property that gets and sets the minimum corner of the box.
You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Properties


Box2d.MaxPoint Property

Box2d.MaxPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the maximum corner of the box.

Visual Basic
Property MaxPoint() As Point2d*
See Also

Creating a parts list sample

You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Properties > Box2d.MaxPoint Property


Box2d.MinPoint Property

Box2d.MinPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the minimum corner of the box.

Visual Basic
Property MinPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > Box2d Interface > Box2d Properties > Box2d.MinPoint Property


BreakOperation Interface

BreakOperation Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

A BreakOperation object represents a break applied to a drawing view. Editing or deleting this BreakOperation object will modify all affected views.

Class Hierarchy
Inventor::BreakOperation
Visual Basic
Public Interface BreakOperation
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BreakOperation.SourceBreakOperation

BreakOperations.Add

BreakOperations.Item

See Also

Creation of a break operation in a drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface


BreakOperation Methods

BreakOperation Methods
Summary

The methods of the BreakOperation class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the break operation from the drawing view. The break is deleted from all other affected drawing views as well.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Methods


BreakOperation.Delete Method

BreakOperation.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the break operation from the drawing view. The break is deleted from all other affected drawing views as well.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Methods > BreakOperation.Delete Method


BreakOperation.GetReferenceKey Method

BreakOperation.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Methods > BreakOperation.GetReferenceKey Method


BreakOperation Properties

BreakOperation Properties
Summary

The properties of the BreakOperation class are listed here.

Properties
Name | Description
AllAffectedViews | Property that returns all the DrawingView objects affected by this break operation. Multiple drawing views can be affected by a break operation if children views inherit breaks or if the break is propagated up to the parent view.
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BreakStyle | Property that gets and sets the break style. Valid values are kRectangularBreakStyle and kStructuralBreakStyle.
DisplayLevel | Property that gets and sets the appearance of the break lines. Valid range of values is 1 through 10. For rectangular break style, this value controls the quantity or pitch of break edges displayed. For structural break style, this value controls amplitude of break line.
EndPoint | Property that gets and sets the end point of the break in sheet space. For a horizontal break, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.
Gap | Property that gets and sets the gap (in centimeters) between the break lines. This value accounts for the view scale of the parent view.
IsSourceBreakOperation | Property that returns whether this break operation is the source for inherited break operations. The property returns True if there are no related break operations. If the property returns False, use the SourceBreakOperation property to find the source break.
Layer | Property that gets and sets the layer for the break lines.
MidPoint | Property that gets and sets the midpoint of the break in sheet space. Setting this property has the effect of moving the break horizontally for a horizontal break and vertically for a vertical break. For a horizontal break, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.
NumberOfSymbols | Property that gets and sets the number of break symbols to use for a structural style break. Valid values are 1, 2 and 3. This property is not applicable for rectangular style breaks.
Orientation | Property that returns whether the orientation of the break is horizontal or vertical. Possible return values are kHorizontalBreakOrientation and kVerticalBreakOrientation.
Parent | Property that returns the parent drawing view from which this BreakOperation was retrieved.
SourceBreakOperation | Property that returns the source BreakOperation object. For instance, if a projected view inherits the break from the parent base view, this property on the BreakOperation retrieved from the projected view will return the corresponding BreakOperation from the base view. If this BreakOperation itself is the source, the property returns nothing.
StartPoint | Property that gets and sets the start point of the break in sheet space. For a horizontal break, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.
Type | Property returning kBreakOperationObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties


BreakOperation.AllAffectedViews Property

BreakOperation.AllAffectedViews Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns all the DrawingView objects affected by this break operation. Multiple drawing views can be affected by a break operation if children views inherit breaks or if the break is propagated up to the parent view.

Visual Basic
Property AllAffectedViews() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.AllAffectedViews Property


BreakOperation.Application Property

BreakOperation.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.Application Property


BreakOperation.AttributeSets Property

BreakOperation.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.AttributeSets Property


BreakOperation.BreakStyle Property

BreakOperation.BreakStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the break style. Valid values are kRectangularBreakStyle and kStructuralBreakStyle.

Visual Basic
Property BreakStyle() As BreakStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.BreakStyle Property


BreakOperation.DisplayLevel Property

BreakOperation.DisplayLevel Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the appearance of the break lines. Valid range of values is 1 through 10. For rectangular break style, this value controls the quantity or pitch of break edges displayed. For structural break style, this value controls amplitude of break line.

Visual Basic
Property DisplayLevel() As long
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.DisplayLevel Property


BreakOperation.EndPoint Property

BreakOperation.EndPoint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the end point of the break in sheet space. For a horizontal break, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.

Visual Basic
Property EndPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.EndPoint Property


BreakOperation.Gap Property

BreakOperation.Gap Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the gap (in centimeters) between the break lines. This value accounts for the view scale of the parent view.

Visual Basic
Property Gap() As double
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.Gap Property


BreakOperation.IsSourceBreakOperation Property

BreakOperation.IsSourceBreakOperation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether this break operation is the source for inherited break operations. The property returns True if there are no related break operations. If the property returns False, use the SourceBreakOperation property to find the source break.

Visual Basic
Property IsSourceBreakOperation() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.IsSourceBreakOperation Property


BreakOperation.Layer Property

BreakOperation.Layer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the layer for the break lines.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.Layer Property


BreakOperation.MidPoint Property

BreakOperation.MidPoint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the midpoint of the break in sheet space. Setting this property has the effect of moving the break horizontally for a horizontal break and vertically for a vertical break. For a horizontal break, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.

Visual Basic
Property MidPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.MidPoint Property


BreakOperation.NumberOfSymbols Property

BreakOperation.NumberOfSymbols Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the number of break symbols to use for a structural style break. Valid values are 1, 2 and 3. This property is not applicable for rectangular style breaks.

Visual Basic
Property NumberOfSymbols() As long
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.NumberOfSymbols Property


BreakOperation.Orientation Property

BreakOperation.Orientation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the orientation of the break is horizontal or vertical. Possible return values are kHorizontalBreakOrientation and kVerticalBreakOrientation.

Visual Basic
Property Orientation() As BreakOrientationEnum*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.Orientation Property


BreakOperation.Parent Property

BreakOperation.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent drawing view from which this BreakOperation was retrieved.

Visual Basic
Property Parent() As DrawingView**
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.Parent Property


BreakOperation.SourceBreakOperation Property

BreakOperation.SourceBreakOperation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the source BreakOperation object. For instance, if a projected view inherits the break from the parent base view, this property on the BreakOperation retrieved from the projected view will return the corresponding BreakOperation from the base view. If this BreakOperation itself is the source, the property returns nothing.

Visual Basic
Property SourceBreakOperation() As BreakOperation**
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.SourceBreakOperation Property


BreakOperation.StartPoint Property

BreakOperation.StartPoint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the start point of the break in sheet space. For a horizontal break, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.

Visual Basic
Property StartPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.StartPoint Property


BreakOperation.Type Property

BreakOperation.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBreakOperationObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperation Interface > BreakOperation Properties > BreakOperation.Type Property


BreakOperations Interface

BreakOperations Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BreakOperations collection object contains information about all the break operations applied to a drawing view as well as methods to add breaks to the view.

Class Hierarchy
Inventor::BreakOperations
Visual Basic
Public Interface BreakOperations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingView.BreakOperations

See Also

Creation of a break operation in a drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface


BreakOperations Methods

BreakOperations Methods
Summary

The methods of the BreakOperations class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a break to a drawing view. The newly created BreakOperation object is returned.
Item | Method that returns the specified break operation object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Methods


BreakOperations.Add Method

BreakOperations.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds a break to a drawing view. The newly created BreakOperation object is returned.

Visual Basic
Sub Add(Orientation As BreakOrientationEnum, StartPoint As Point2d, EndPoint As Point2d, ByRef BreakStyle As [defaultvalue(kRectangularBreakStyle)] BreakStyleEnum, ByRef DisplayLevel As [defaultvalue(5)] long, ByRef Gap As [defaultvalue(0.0)] double, ByRef NumberOfSymbols As [defaultvalue(1)] long, ByRef PropagateToParentView As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] BreakOperation*)
Parameters
Parameters | Description
Orientation | Input BreakOrientationEnum that specifies whether the orientation of the break is horizontal or vertical. Valid values are kHorizontalBreakOrientation and kVerticalBreakOrientation.
StartPoint | Input Point2d object that specifies the start point of the break in sheet space. For a horizontal break orientation, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.
EndPoint | Input Point2d object that specifies the end point of the break in sheet space. For a horizontal break orientation, only the 'x' component of the point is used and the 'y' component is ignored. For a vertical break, only the 'y' component of the point is used and the 'x' component is ignored.
BreakStyle | Optional input BreakStyleEnum that specifies the break style. Valid values are kRectangularBreakStyle and kStructuralBreakStyle. If not specified, a rectangular style break is created.
DisplayLevel | Optional input Long that specifies the appearance of the break lines. Valid range of values is 1 through 10. For rectangular break style, this value controls the quantity or pitch of break edges displayed. For structural break style, this value controls amplitude of break line. If not specified, a value of 5 is used.
Gap | Optional input Double that specifies the gap (in centimeters) between the break lines. If not specified, a gap value is automatically calculated based on the view size.
NumberOfSymbols | Optional input Long that specifies the number of break symbols to use for a structural style break. Valid values are 1, 2 and 3. This argument is not applicable and is ignored for rectangular style breaks. If not specified, a value of 1 is assumed.
PropagateToParentView | Optional input Boolean that specifies whether to apply this break to the parent view as well. This is not applicable in all situations and is ignored if not applicable. The default value is False.
Example

This sample demonstrates the creation of a break operation in a drawing view. Before running this sample, select a drawing view in the active drawing.

Public Sub CreateBreakoperationInDrawingView()

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Check to make sure a drawing view is selected.
    If Not TypeOf oDrawDoc.SelectSet.Item(1) Is DrawingView Then
        MsgBox "A drawing view must be selected."
        Exit Sub
    End If

    ' Set a reference to the selected drawing. This assumes
    ' that the selected view is not a draft view.
    Dim oDrawingView As DrawingView
    Set oDrawingView = oDrawDoc.SelectSet.Item(1)

    ' Set a reference to the center of the base view.
    Dim oCenter As Point2d
    Set oCenter = oDrawingView.Center

    ' Define the start point of the break
    Dim oStartPoint As Point2d
    Set oStartPoint = ThisApplication.TransientGeometry.CreatePoint2d(oCenter.X - 1, oCenter.Y)

    ' Define the end point of the break
    Dim oEndPoint As Point2d
    Set oEndPoint = ThisApplication.TransientGeometry.CreatePoint2d(oCenter.X + 1, oCenter.Y)

    Dim oBreakOperation As BreakOperation
    Set oBreakOperation = oDrawingView.BreakOperations.Add(kHorizontalBreakOrientation, oStartPoint, oEndPoint, kRectangularBreakStyle, 5)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Methods > BreakOperations.Add Method


BreakOperations.Item Method

BreakOperations.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified break operation object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BreakOperation*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Methods > BreakOperations.Item Method


BreakOperations Properties

BreakOperations Properties
Summary

The properties of the BreakOperations class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBreakOperationsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Properties


BreakOperations.Application Property

BreakOperations.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Properties > BreakOperations.Application Property


BreakOperations.Count Property

BreakOperations.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Properties > BreakOperations.Count Property


BreakOperations.Type Property

BreakOperations.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBreakOperationsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BreakOperations Interface > BreakOperations Properties > BreakOperations.Type Property


BreakOutOperation Interface

BreakOutOperation Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

A BreakOutOperation object represents a break out applied to a drawing view. Editing or deleting this BreakOutOperation object will modify all affected views.

Class Hierarchy
Inventor::BreakOutOperation
Visual Basic
Public Interface BreakOutOperation
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BreakOutOperations.Add

BreakOutOperations.Item

You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface


BreakOutOperation Methods

BreakOutOperation Methods
Summary

The methods of the BreakOutOperation class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the break out operation from the drawing view. The break out is deleted from all other affected drawing views as well.
GetDepth | Method that returns the information controlling the depth of the break out.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetDepth | Method that sets the depth of the break out.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Methods


BreakOutOperation.Delete Method

BreakOutOperation.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the break out operation from the drawing view. The break out is deleted from all other affected drawing views as well.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Methods > BreakOutOperation.Delete Method


BreakOutOperation.GetDepth Method

BreakOutOperation.GetDepth Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the information controlling the depth of the break out.

Visual Basic
Sub GetDepth(ByRef DepthSource As IDispatch*, ByRef DepthValue As double)
Parameters
Parameters
Description
DepthSource
Graphic object that defines the depth of the break out. Several different types of objects can be returned depending on how the depth of the break out has been defined. The DepthType property can be used to know what type(s) of objects will be returned by this method. Based on the depth type here are the object types you can expect to be returned.

kFromPointBreakOutType

  • An Edge or Vertex object from the model being displayed in the view is returned. This is different than the GeometryIntent object that would have been provided during creation. Model geometry is returned in this case because in many cases the drawing curve that defines the depth is not visible, and so does not exist in the view containing the break out.
  • The DepthValue argument is applicable in this case and gives the offset from this point.

kToSketchBreakOutType

  • A DrawingSketch object which is associated with a dependant projected view.

kToHoleBreakOutType

  • A DrawingCurve object that is used to specify a 'hole'. A hole in this case is defined as any geometry from a HoleFeature object or any cylinder or cone in the model. The axis of the hole, cylinder, or cone is parallel to the sheet plane and defines the depth of the hole.

kThroughPartBreakOutType

  • A PartComponentDefinition object indicates that the entire part is cut. This is only applicable when the drawing view contains a part, not an assembly.
  • A ComponentOccurrence (or a ComponentOccurrenceProxy) object in the context of the parent drawing view. The depth is defined by the depth of the associated part.
  • An ObjectCollection containing multiple ComponentOccurrence (or ComponentOccurrenceProxy) objects. The depth is defined by the depths of the associated parts.

DepthValue
This argument is only applicable when the DepthType is kFromPointBreakOutType otherwise it should be ignored. The depth value is always returned as centimeters.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Methods > BreakOutOperation.GetDepth Method


BreakOutOperation.GetReferenceKey Method

BreakOutOperation.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Methods > BreakOutOperation.GetReferenceKey Method


BreakOutOperation.SetDepth Method

BreakOutOperation.SetDepth Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the depth of the break out.

Visual Basic
Sub SetDepth(ByRef DepthSource As [optional] VARIANT, ByRef DepthValue As [defaultvalue(0)] double)
Parameters
Parameters
Description
DepthSource
Graphic object that defines the depth of the break out. This argument is optional in the case where the depth is defined by a point (DepthType property returns kFromPointBreakOutType) and you only want to modify the depth value.
Several different types of objects can be used as input depending on how the depth of the break is to be defined. Here are the various valid inputs.

  1. A GeometryIntent object that represents a point. This specifies the starting point of the break out area. In this case, the DepthValue argument must be specified to indicate the depth of the break out area from the specified point.
  2. A DrawingSketch object which is associated with a dependant projected view.
  3. A DrawingCurve object that is used to specify a 'hole'. A hole in this case is any geometry from a HoleFeature object or any cylinder or cone in the model. The axis of the hole, cylinder, or cone must be parallel to the sheet plane. The axis defines the depth of the hole.
  4. A PartComponentDefinition object to indicate that the entire part is to be cut. This is only applicable when the drawing view contains a part. The PartComponentDefinition supplied must be the component definition of the part in the view.
  5. A ComponentOccurrence (or a ComponentOccurrenceProxy) object in the context of the parent drawing view. The depth is defined by the depth of the associated part. This is only applicable when the drawing view contains an assembly.
  6. An ObjectCollection containing multiple ComponentOccurrence (or ComponentOccurrenceProxy) objects. The depth is defined by the depths of the associated parts. This is only applicable when the drawing view contains an assembly.

DepthValue
This argument is only applicable when the DepthType is already kFromPointBreakOutType or you're setting the depth type to be measured from a point. If it is already kFromPointBreakOutType and you want to use the existing from point you can just provide a new depth value. If you want set or change the depth point then the DepthSource argument must also be used to define the new from point. In all other cases the value of this argument is ignored. The value is always input as centimeters.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Methods > BreakOutOperation.SetDepth Method


BreakOutOperation Properties

BreakOutOperation Properties
Summary

The properties of the BreakOutOperation class are listed here.

Properties
Name | Description
AllAffectedViews | Property that returns all the DrawingView objects affected by this break out operation. Multiple drawing views can be affected by a break out operation if children views inherit break outs.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DepthType | Property returns how the depth of the break out is defined. To change to another type use the DepthSource property.
Parent | Property that returns the parent drawing view from which this BreakOutOperation was retrieved.
Profile | Property that gets and sets the sketch profile used for the break out. Only closed profiles are valid.
SectionAllParts | Property that gets and sets whether to section all parts in the break out area.
Type | Property returning kBreakOutOperationObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties


BreakOutOperation.AllAffectedViews Property

BreakOutOperation.AllAffectedViews Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns all the DrawingView objects affected by this break out operation. Multiple drawing views can be affected by a break out operation if children views inherit break outs.

Visual Basic
Property AllAffectedViews() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.AllAffectedViews Property


BreakOutOperation.Application Property

BreakOutOperation.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.Application Property


BreakOutOperation.AttributeSets Property

BreakOutOperation.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.AttributeSets Property


BreakOutOperation.DepthType Property

BreakOutOperation.DepthType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returns how the depth of the break out is defined. To change to another type use the DepthSource property.

Visual Basic
Property DepthType() As BreakOutDepthTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.DepthType Property


BreakOutOperation.Parent Property

BreakOutOperation.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent drawing view from which this BreakOutOperation was retrieved.

Visual Basic
Property Parent() As DrawingView**
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.Parent Property


BreakOutOperation.Profile Property

BreakOutOperation.Profile Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the sketch profile used for the break out. Only closed profiles are valid.

Visual Basic
Property Profile() As Profile*
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.Profile Property


BreakOutOperation.SectionAllParts Property

BreakOutOperation.SectionAllParts Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to section all parts in the break out area.

Visual Basic
Property SectionAllParts() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.SectionAllParts Property


BreakOutOperation.Type Property

BreakOutOperation.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBreakOutOperationObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperation Interface > BreakOutOperation Properties > BreakOutOperation.Type Property


BreakOutOperations Interface

BreakOutOperations Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The BreakOutOperations collection object contains information about all the break out operations applied to a drawing view as well as methods to add break outs to the view.

Class Hierarchy
Inventor::BreakOutOperations
Visual Basic
Public Interface BreakOutOperations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingView.BreakOutOperations

You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface


BreakOutOperations Methods

BreakOutOperations Methods
Summary

The methods of the BreakOutOperations class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a break out to a drawing view. The newly created BreakOutOperation object is returned.
Item | Method that returns the specified break out operation object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Methods


BreakOutOperations.Add Method

BreakOutOperations.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds a break out to a drawing view. The newly created BreakOutOperation object is returned.

Visual Basic
Sub Add(Profile As Profile, DepthSource As IDispatch, ByRef DepthValue As [defaultvalue(0)] double, ByRef SectionAllParts As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] BreakOutOperation*)
Parameters
Parameters
Description
Profile
Input Profile object that specifies the sketch profile for the break out. This profile must be closed so it should be created using the AddForSolid method of the Profiles object.
DepthSource
Input object that specifies the source for the break out depth. Valid input objects are:

  1. A GeometryIntent object that represents a point. This specifies the starting point of the break out area. In this case, the DepthValue argument must be specified to indicate the depth of the break out area from the specified point.
  2. A DrawingSketch object which is associated with a dependant projected view.
  3. A DrawingCurve object that is used to specify a 'hole'. A hole in this case is any geometry from a HoleFeature object or any cylinder or cone in the model. The axis of the hole, cylinder, or cone must be parallel to the sheet plane. The axis defines the depth of the hole.
  4. A PartComponentDefinition object to indicate that the entire part is to be cut. This is only applicable when the drawing view contains a part. The PartComponentDefinition supplied must be the component definition of the part in the view.
  5. A ComponentOccurrence (or a ComponentOccurrenceProxy) object in the context of the parent drawing view. The depth is defined by the depth of the associated part. This is only applicable when the drawing view contains an assembly.
  6. An ObjectCollection containing multiple ComponentOccurrence (or ComponentOccurrenceProxy) objects. The depth is defined by the depths of the associated parts. This is only applicable when the drawing view contains an assembly.

DepthValue
Optional input Double that specifies the depth value for the break out if the input DepthSource is a point. This argument is ignored if the input source is not a point.
SectionAllParts
Optional input Boolean that specifies whether to section all parts in the break out area. The default value is False indicating that all parts will not be sectioned.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Methods > BreakOutOperations.Add Method


BreakOutOperations.Item Method

BreakOutOperations.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified break out operation object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BreakOutOperation*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Methods > BreakOutOperations.Item Method


BreakOutOperations Properties

BreakOutOperations Properties
Summary

The properties of the BreakOutOperations class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kBreakOutOperationsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Properties


BreakOutOperations.Application Property

BreakOutOperations.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Properties > BreakOutOperations.Application Property


BreakOutOperations.Count Property

BreakOutOperations.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Properties > BreakOutOperations.Count Property


BreakOutOperations.Type Property

BreakOutOperations.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kBreakOutOperationsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BreakOutOperations Interface > BreakOutOperations Properties > BreakOutOperations.Type Property


BrowserFolder Interface

BrowserFolder Interface Available in Inventor Introduced in Inventor 2010
Summary

The BrowserFolder object represents a folder in the browser.

Class Hierarchy
Inventor::BrowserFolder
Visual Basic
Public Interface BrowserFolder
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BrowserFoldersEnumerator.Item

BrowserPaneObject.AddBrowserFolder

See Also

Add assembly occurrences to a new folder sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface


BrowserFolder Methods

BrowserFolder Methods
Summary

The methods of the BrowserFolder class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a node to the folder. The node is automatically reordered in the browser if required. If the node cannot be reordered as needed, the method returns an error.
Delete | Method that deletes the browser folder. The contents of the folder are retained and moved up one level in the browser.
Remove | Method that removes a node from the folder. The node is automatically reordered in the browser if required. If the node cannot be reordered as needed, the method returns an error.
SetEndOfPart | Method that moves the end of part before or after the folder. The method only applies for first level folders in part documents and first level folders in the features portion of the browser in assembly documents. The method returns an error for all other folders.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Methods


BrowserFolder.Add Method

BrowserFolder.Add Method Available in Inventor Introduced in Inventor 2010
Summary

Method that adds a node to the folder. The node is automatically reordered in the browser if required. If the node cannot be reordered as needed, the method returns an error.

Visual Basic
Sub Add(BrowserNode As BrowserNode, ByRef TargetNode As [optional] VARIANT, ByRef Before As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
BrowserNode | Input BrowserNode object that specifies the object to be moved into the folder.
TargetNode | Optional input BrowserNode object that specifies the object within the folder adjacent to which the input node should be positioned. This node should be found directly under the folder, else the method returns an error. If not specified, the node is added to the top of the list in the folder.
Before | Optional input Boolean that specifies whether the input node should be moved before or after the target node. If not specified, the node is positioned after the target node. This argument is ignored if the TargetNode argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Methods > BrowserFolder.Add Method


BrowserFolder.Delete Method

BrowserFolder.Delete Method Available in Inventor Introduced in Inventor 2010
Summary

Method that deletes the browser folder. The contents of the folder are retained and moved up one level in the browser.

Visual Basic
Sub Delete(ByRef Reserved As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
Reserved | Optional input Boolean reserved for future use. The value is currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Methods > BrowserFolder.Delete Method


BrowserFolder.Remove Method

BrowserFolder.Remove Method Available in Inventor Introduced in Inventor 2010
Summary

Method that removes a node from the folder. The node is automatically reordered in the browser if required. If the node cannot be reordered as needed, the method returns an error.

Visual Basic
Sub Remove(BrowserNode As BrowserNode, ByRef TargetNode As [optional] VARIANT, ByRef Before As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
BrowserNode | Input BrowserNode object that specifies the object to be removed from the folder.
TargetNode | Optional input BrowserNode object that specifies the object outside the folder adjacent to which the input node should be positioned. If not specified, the node is positioned adjacent to the folder (either before or after).
Before | Optional input Boolean that specifies whether the input node should be moved before or after the target node. If not specified, the node is positioned after the target node.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Methods > BrowserFolder.Remove Method


BrowserFolder.SetEndOfPart Method

BrowserFolder.SetEndOfPart Method Available in Inventor Introduced in Inventor 2010
Summary

Method that moves the end of part before or after the folder. The method only applies for first level folders in part documents and first level folders in the features portion of the browser in assembly documents. The method returns an error for all other folders.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that specifies whether to move the end of part before or after the folder. True for before.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Methods > BrowserFolder.SetEndOfPart Method


BrowserFolder Properties

BrowserFolder Properties
Summary

The properties of the BrowserFolder class are listed here.

Properties
Name | Description
AllowAddRemove | Property that gets and sets whether items can be added to and removed from the folder by the user. If set to False, the add/remove restriction applies to the user interface only – the contents of folder can still be modified via the API.
AllowDelete | Property that gets and sets whether the folder can be deleted by the user. If set to False, the delete restriction applies to the user interface only - the folder can still be deleted via the API.
AllowRename | Property that gets and sets whether the folder can be renamed by the user. If set to False, the rename restriction applies to the user interface only - the folder can still be renamed via the API.
AllowReorder | Property that gets and sets whether the folder can be reordered in the browser by the user. If set to False, the reorder restriction applies to the user interface only - the folder can still be reordered via the API.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BrowserNode | Property that returns the corresponding browser node for the folder. The contents of the folder (including sub-folders) can be accessed via the browser node.
Name | Property that gets and sets the name of the folder.
Parent | Property that returns the parent browser node for the folder.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties


BrowserFolder.AllowAddRemove Property

BrowserFolder.AllowAddRemove Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether items can be added to and removed from the folder by the user. If set to False, the add/remove restriction applies to the user interface only – the contents of folder can still be modified via the API.

Visual Basic
Property AllowAddRemove() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.AllowAddRemove Property


BrowserFolder.AllowDelete Property

BrowserFolder.AllowDelete Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the folder can be deleted by the user. If set to False, the delete restriction applies to the user interface only - the folder can still be deleted via the API.

Visual Basic
Property AllowDelete() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.AllowDelete Property


BrowserFolder.AllowRename Property

BrowserFolder.AllowRename Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the folder can be renamed by the user. If set to False, the rename restriction applies to the user interface only - the folder can still be renamed via the API.

Visual Basic
Property AllowRename() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.AllowRename Property


BrowserFolder.AllowReorder Property

BrowserFolder.AllowReorder Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the folder can be reordered in the browser by the user. If set to False, the reorder restriction applies to the user interface only - the folder can still be reordered via the API.

Visual Basic
Property AllowReorder() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.AllowReorder Property


BrowserFolder.Application Property

BrowserFolder.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.Application Property


BrowserFolder.BrowserNode Property

BrowserFolder.BrowserNode Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the corresponding browser node for the folder. The contents of the folder (including sub-folders) can be accessed via the browser node.

Visual Basic
Property BrowserNode() As BrowserNode**
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.BrowserNode Property


BrowserFolder.Name Property

BrowserFolder.Name Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the name of the folder.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.Name Property


BrowserFolder.Parent Property

BrowserFolder.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent browser node for the folder.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.Parent Property


BrowserFolder.Type Property

BrowserFolder.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserFolder Interface > BrowserFolder Properties > BrowserFolder.Type Property


BrowserFoldersEnumerator Interface

BrowserFoldersEnumerator Interface Available in Inventor Introduced in Inventor 2010
Summary

The BrowserFoldersEnumerator object provides access to all browser folders directly under a browser node.

Class Hierarchy
Inventor::BrowserFoldersEnumerator
Visual Basic
Public Interface BrowserFoldersEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BrowserNode.BrowserFolders

You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface


BrowserFoldersEnumerator Methods

BrowserFoldersEnumerator Methods
Summary

The methods of the BrowserFoldersEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified BrowserFolder object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface > BrowserFoldersEnumerator Methods


BrowserFoldersEnumerator.Item Method

BrowserFoldersEnumerator.Item Method Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the specified BrowserFolder object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BrowserFolder*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the BrowserFolder to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the BrowserFolder label. If an out of range index or a label of a non-existent BrowserFolder is provided, an error will occur. If multiple folders in the collection share the same label, the first one found will be returned.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface > BrowserFoldersEnumerator Methods > BrowserFoldersEnumerator.Item Method


BrowserFoldersEnumerator Properties

BrowserFoldersEnumerator Properties
Summary

The properties of the BrowserFoldersEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface > BrowserFoldersEnumerator Properties


BrowserFoldersEnumerator.Application Property

BrowserFoldersEnumerator.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface > BrowserFoldersEnumerator Properties > BrowserFoldersEnumerator.Application Property


BrowserFoldersEnumerator.Count Property

BrowserFoldersEnumerator.Count Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface > BrowserFoldersEnumerator Properties > BrowserFoldersEnumerator.Count Property


BrowserFoldersEnumerator.Type Property

BrowserFoldersEnumerator.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserFoldersEnumerator Interface > BrowserFoldersEnumerator Properties > BrowserFoldersEnumerator.Type Property


BrowserNode Interface

BrowserNode Interface Available in Inventor Introduced in Inventor 8
Summary

The BrowserNode object represents a node in the browser.

Class Hierarchy
Inventor::BrowserNode
Visual Basic
Public Interface BrowserNode
Inherits IDispatch
Remarks

A specialization of this object (a derivation of this class) called the ClientBrowserNode object represents the custom browser node, which can be created by a third party. At times a BrowserNode may simply stand in as a reference to the top node of a different browser tree, providing the effect of an integrated browser tree. A good example of this is the way the part features are visible as integrated in the assembly's browser pane.

Notes

Members through which this object may be accessed include:

BrowserFolder.BrowserNode

BrowserNode.AddChild

BrowserNode.InsertChild

BrowserNodesEnumerator.Item

BrowserNodesEnumerator.ItemById

BrowserPaneObject.TopNode

BrowserPaneObject.GetBrowserNodeFromObject

ClientFeature.BrowserNode

See Also

Demote occurence sample

Add assembly occurrences to a new folder sample

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface


BrowserNode Methods

BrowserNode Methods
Summary

The methods of the BrowserNode class are listed here.

Methods
Methods
Name | Description
AddChild | Method that creates a new as a nested child of this one. The new BrowserNode is returned.
AllReferencedNodes | Method that returns all browser nodes referencing the specified BrowserNodeDefinition below this BrowserNode. For instance, in the case of a shared sketch, two browser nodes reference the same definition.
Delete | Method that deletes the browser node. All of its child browser nodes are deleted as well. None of the corresponding browser node definitions nor the client node resources are deleted, however. This method will fail for built-in browser nodes.
DoPreSelect | This method will simulate a mouse hover on the browser node.
DoSelect | This method will simulate a mouse click on the browser node.
EnsureVisible | Method that ensures the BrowserNode object is visible.
InsertChild | Method that creates a new BrowserNode at the specified location. The new BrowserNode is returned.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods


BrowserNode.AddChild Method

BrowserNode.AddChild Method Available in Inventor Introduced in Inventor 8
Summary

Method that creates a new as a nested child of this one. The new BrowserNode is returned.

Visual Basic
Sub AddChild(Definition As BrowserNodeDefinition, Result As [out, retval] BrowserNode*)
Parameters
Parameters | Description
Definition | Input object that specifies the input definition for the browser node.
Remarks

It is not possible to add client nodes to built-in panes.

You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.AddChild Method


BrowserNode.AllReferencedNodes Method

BrowserNode.AllReferencedNodes Method Available in Inventor Introduced in Inventor 11
Summary

Method that returns all browser nodes referencing the specified BrowserNodeDefinition below this BrowserNode. For instance, in the case of a shared sketch, two browser nodes reference the same definition.

Visual Basic
Sub AllReferencedNodes(Definition As BrowserNodeDefinition, Result As [out, retval] BrowserNodesEnumerator*)
Parameters
Parameters | Description
Definition | Input BrowserNodeDefinition object to get the referenced nodes for.
See Also

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.AllReferencedNodes Method


BrowserNode.Delete Method

BrowserNode.Delete Method Available in Inventor Introduced in Inventor 8
Summary

Method that deletes the browser node. All of its child browser nodes are deleted as well. None of the corresponding browser node definitions nor the client node resources are deleted, however. This method will fail for built-in browser nodes.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.Delete Method


BrowserNode.DoPreSelect Method

BrowserNode.DoPreSelect Method Available in Inventor Introduced in Inventor 8
Summary

This method will simulate a mouse hover on the browser node.

Visual Basic
Sub DoPreSelect()
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.DoPreSelect Method


BrowserNode.DoSelect Method

BrowserNode.DoSelect Method Available in Inventor Introduced in Inventor 8
Summary

This method will simulate a mouse click on the browser node.

Visual Basic
Sub DoSelect()
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.DoSelect Method


BrowserNode.EnsureVisible Method

BrowserNode.EnsureVisible Method Available in Inventor Introduced in Inventor 8
Summary

Method that ensures the BrowserNode object is visible.

Visual Basic
Sub EnsureVisible()
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.EnsureVisible Method


BrowserNode.InsertChild Method

BrowserNode.InsertChild Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new BrowserNode at the specified location. The new BrowserNode is returned.

Visual Basic
Sub InsertChild(Definition As BrowserNodeDefinition, TargetNode As BrowserNode, InsertBefore As VARIANT_BOOL, Result As [out, retval] BrowserNode*)
Parameters
Parameters | Description
Definition | Input object that defines the input definition for the browser node.
TargetNode | Input BrowserNode object that specifies the node adjacent to which the new node should be inserted.
InsertBefore | Input Boolean that specifies whether the new node should be inserted before or after the target node.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Methods > BrowserNode.InsertChild Method


BrowserNode Properties

BrowserNode Properties
Summary

The properties of the BrowserNode class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BrowserFolders | Property that returns a collection of all browser folders contained directly under this node in the browser.
BrowserNodeDefinition | Property that returns a object which defines the various inputs that were used to create the browser node.
BrowserNodes | Property that returns a collection of the top level BrowserNode objects contained under this node.
Expanded | Property that specifies if the BrowserNode object is expanded.
FullPath | Gets the fully qualified label of the BrowserNode.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
Parent | Property that returns the parent of the BrowserNode object. This may either be another BrowserNode or a BrowserPane.
Selected | Property that returns whether the object is selected or not.
Type | Property returning an enum indicating this object's type.
Visible | Property that gets and sets whether the browser node is visible or not. Changes to this value will not persist when the document is saved.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties


BrowserNode.Application Property

BrowserNode.Application Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.Application Property


BrowserNode.BrowserFolders Property

BrowserNode.BrowserFolders Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns a collection of all browser folders contained directly under this node in the browser.

Visual Basic
Property BrowserFolders() As BrowserFoldersEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.BrowserFolders Property


BrowserNode.BrowserNodeDefinition Property

BrowserNode.BrowserNodeDefinition Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns a object which defines the various inputs that were used to create the browser node.

Visual Basic
Property BrowserNodeDefinition() As BrowserNodeDefinition**
See Also

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.BrowserNodeDefinition Property


BrowserNode.BrowserNodes Property

BrowserNode.BrowserNodes Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns a collection of the top level BrowserNode objects contained under this node.

Visual Basic
Property BrowserNodes() As BrowserNodesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.BrowserNodes Property


BrowserNode.Expanded Property

BrowserNode.Expanded Property Available in Inventor Introduced in Inventor 8
Summary

Property that specifies if the BrowserNode object is expanded.

Visual Basic
Property Expanded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.Expanded Property


BrowserNode.FullPath Property

BrowserNode.FullPath Property Available in Inventor Introduced in Inventor 8
Summary

Gets the fully qualified label of the BrowserNode.

Visual Basic
Property FullPath() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.FullPath Property


BrowserNode.NativeObject Property

BrowserNode.NativeObject Property Available in Inventor Introduced in Inventor 2009
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As IDispatch**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.NativeObject Property


BrowserNode.Parent Property

BrowserNode.Parent Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns the parent of the BrowserNode object. This may either be another BrowserNode or a BrowserPane.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.Parent Property


BrowserNode.Selected Property

BrowserNode.Selected Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns whether the object is selected or not.

Visual Basic
Property Selected() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.Selected Property


BrowserNode.Type Property

BrowserNode.Type Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.Type Property


BrowserNode.Visible Property

BrowserNode.Visible Property Available in Inventor Introduced in Inventor 8
Summary

Property that gets and sets whether the browser node is visible or not. Changes to this value will not persist when the document is saved.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserNode Interface > BrowserNode Properties > BrowserNode.Visible Property


BrowserNodeDefinition Interface

BrowserNodeDefinition Interface Available in Inventor Introduced in Inventor 8
Summary

The BrowserNodeDefinition object contains the definition of a node in the browser.

Class Hierarchy
Inventor::BrowserNodeDefinition
    Inventor::ClientBrowserNodeDefinitionObject
    Inventor::NativeBrowserNodeDefinitionObject
Visual Basic
Public Interface BrowserNodeDefinition
Inherits IDispatch
Remarks

Note that AttributeSets are not available for a node definition until the definition is used by a node.

Notes

Members through which this object may be accessed include:

BrowserNode.BrowserNodeDefinition

You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface


BrowserNodeDefinition Properties

BrowserNodeDefinition Properties
Summary

The properties of the BrowserNodeDefinition class are listed here.

Properties
Name | Description
AdditionalDisplayState | Gets and sets the additional display state of browsernodes that use this definition.
AdditionalStateIconToolTipText | Gets and sets additional state icon tool tip text on a existing definition object.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that specifies if the node is a standard Autodesk Inventor node or not.
DisplayState | Property that gets and sets the display state of the browser nodes referencing this definition.
Label | Property that gets the label of the BrowserNode. This is the string that is displayed to the user. In the case of BuiltIns, this Label is really a reflection of the corresponding name held by the underlying data - for example, a Sketch or a WorkPlane object. In order to set the Label of a ClientBrowserNodeDefinition, see SetLabel on that object.
Parent | Property that returns the owning of this BrowserNodeDefinition object.
StateIconToolTipText | Property that specifies the tool tip of the state icon. When the user pauses over a state icon, the text of this property will be displayed for the tool tip.
ToolTipText | Property that specifies the tool tip of the BrowserNode. When the user pauses over a node the text of this property will be displayed for the tool tip.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties


BrowserNodeDefinition.AdditionalDisplayState Property

BrowserNodeDefinition.AdditionalDisplayState Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the additional display state of browsernodes that use this definition.

Visual Basic
Property AdditionalDisplayState() As BrowserNodeDisplayStateEnum
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.AdditionalDisplayState Property


BrowserNodeDefinition.AdditionalStateIconToolTipText Property

BrowserNodeDefinition.AdditionalStateIconToolTipText Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets additional state icon tool tip text on a existing definition object.

Visual Basic
Property AdditionalStateIconToolTipText() As String
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.AdditionalStateIconToolTipText Property


BrowserNodeDefinition.Application Property

BrowserNodeDefinition.Application Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.Application Property


BrowserNodeDefinition.BuiltIn Property

BrowserNodeDefinition.BuiltIn Property Available in Inventor Introduced in Inventor 8
Summary

Property that specifies if the node is a standard Autodesk Inventor node or not.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
Remarks

Built-in nodes have restrictions in the edits that can be performed. A non-builtin node's definition is a ClientBrowserNodeDefinition -- a further specialization of this object (derived class).

You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.BuiltIn Property


BrowserNodeDefinition.DisplayState Property

BrowserNodeDefinition.DisplayState Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets the display state of the browser nodes referencing this definition.

Visual Basic
Property DisplayState() As BrowserNodeDisplayStateEnum
Remarks

Valid values are listed below.

Display State | Description | Example
kActivateDisplayState | The activated node has a white background. Rest of the pane turns grey. | Activating an assembly occurrence using double-click.
kRollbackEditDisplayState | The textual contents of all the nodes below this node turn grey. The textual contents of this node become bold. | Editing an extrude feature using right mouse button click and selecting Edit in the context menu.
kSickDisplayState | The 'sick' state icon is applied to this node. | Creating a thread feature with wrong thread specifications.
kComatoseDisplayState | The 'comatose' state icon is applied to this node and the textual contents turn red. | Deleting all the sketch entities of a profile of an extrude feature.
kSuppressDisplayState | The textual contents of the node turn grey and a strike-through line on the node. | Suppressing any part feature using the context menu.
kBoldDisplayState | The textual contents of the node turn bold. | The top (root node) of an assembly always displays in this state.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.DisplayState Property


BrowserNodeDefinition.Label Property

BrowserNodeDefinition.Label Property Available in Inventor Introduced in Inventor 8
Summary

Property that gets the label of the BrowserNode. This is the string that is displayed to the user. In the case of BuiltIns, this Label is really a reflection of the corresponding name held by the underlying data - for example, a Sketch or a WorkPlane object. In order to set the Label of a ClientBrowserNodeDefinition, see SetLabel on that object.

Visual Basic
Property Label() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.Label Property


BrowserNodeDefinition.Parent Property

BrowserNodeDefinition.Parent Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns the owning of this BrowserNodeDefinition object.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.Parent Property


BrowserNodeDefinition.StateIconToolTipText Property

BrowserNodeDefinition.StateIconToolTipText Property Available in Inventor Introduced in Inventor 8
Summary

Property that specifies the tool tip of the state icon. When the user pauses over a state icon, the text of this property will be displayed for the tool tip.

Visual Basic
Property StateIconToolTipText() As String
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.StateIconToolTipText Property


BrowserNodeDefinition.ToolTipText Property

BrowserNodeDefinition.ToolTipText Property Available in Inventor Introduced in Inventor 8
Summary

Property that specifies the tool tip of the BrowserNode. When the user pauses over a node the text of this property will be displayed for the tool tip.

Visual Basic
Property ToolTipText() As String
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.ToolTipText Property


BrowserNodeDefinition.Type Property

BrowserNodeDefinition.Type Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinition Interface > BrowserNodeDefinition Properties > BrowserNodeDefinition.Type Property


BrowserNodeDefinitionSink Interface

BrowserNodeDefinitionSink Interface
Summary

The BrowserNodeDefinition object contains the definition of a node in the browser.

Class Hierarchy
Inventor::BrowserNodeDefinitionSink
Visual Basic
Public Interface BrowserNodeDefinitionSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinitionSink Interface


BrowserNodeDefinitionSink Methods

BrowserNodeDefinitionSink Methods
Summary

The methods of the BrowserNodeDefinitionSink class are listed here.

Methods
Methods
Name | Description
OnLabelEdit | Event that is fired whenever this node is renamed by the user.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinitionSink Interface > BrowserNodeDefinitionSink Methods


BrowserNodeDefinitionSink.OnLabelEdit Method

BrowserNodeDefinitionSink.OnLabelEdit Method
Summary

Event that is fired whenever this node is renamed by the user.

Visual Basic
Sub OnLabelEdit(NewLabel As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
NewLabel | Input string that specifies a new label for the browser node.
BeforeOrAfter | Input enum value. Either a kBefore or kAfter value.
Context | Input object that, if populated, can be used to determine the context of why the event fired.
HandlingCode | Output value that the client can supply indicating any special action that needs to be taken by Inventor. kEventCanceled indicates that this label edit must be aborted.
Remarks

The event is fired twice; once with the kBefore timing and then again with the kAfter. A HandlingCodeEnum of kEventCanceled can be returned in a kBefore firing to suggest that this node cannot be edited through the UI at this time. The NewLabel input argument is only available during the kAfter firing. The client can reject this string as well through a kEventCancel.

You are here: Symbol Reference > Inventor Library > Objects > BrowserNodeDefinitionSink Interface > BrowserNodeDefinitionSink Methods > BrowserNodeDefinitionSink.OnLabelEdit Method


BrowserNodesEnumerator Interface

BrowserNodesEnumerator Interface Available in Inventor Introduced in Inventor 8
Summary

This object provides access to the individual objects in a collection of nodes; for example the nested children of a given .

Class Hierarchy
Inventor::BrowserNodesEnumerator
Visual Basic
Public Interface BrowserNodesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BrowserNode.BrowserNodes

BrowserNode.AllReferencedNodes

See Also

Demote occurence sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface


BrowserNodesEnumerator Methods

BrowserNodesEnumerator Methods
Summary

The methods of the BrowserNodesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
ItemById | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Methods


BrowserNodesEnumerator.Item Method

BrowserNodesEnumerator.Item Method Available in Inventor Introduced in Inventor 8
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BrowserNode*)
Parameters
Parameters | Description
index | Input Variant value that specifies the BrowserNode to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the BrowserNode label. If an out-of-range index or a label of a non-existent BrowserNode is provided, an error will occur. If multiple nodes in the collection share the same label, the first one found will be returned.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Methods > BrowserNodesEnumerator.Item Method


BrowserNodesEnumerator.ItemById Method

BrowserNodesEnumerator.ItemById Method Available in Inventor Introduced in Inventor 8
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub ItemById(Id As long, Result As [out, retval] BrowserNode*)
Parameters
Parameters | Description
Id | Input long value that specifies the unique and custom identifier of a in this collection. The identifier was supplied at creation time of the ClientBrowserNode. If no such ClientBrowserNode is found in the collection, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Methods > BrowserNodesEnumerator.ItemById Method


BrowserNodesEnumerator Properties

BrowserNodesEnumerator Properties
Summary

The properties of the BrowserNodesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection. Only the immediate children are counted.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Properties


BrowserNodesEnumerator.Application Property

BrowserNodesEnumerator.Application Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Properties > BrowserNodesEnumerator.Application Property


BrowserNodesEnumerator.Count Property

BrowserNodesEnumerator.Count Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns the number of items in the collection. Only the immediate children are counted.

Visual Basic
Property Count() As long*
See Also

Demote occurence sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Properties > BrowserNodesEnumerator.Count Property


BrowserNodesEnumerator.Type Property

BrowserNodesEnumerator.Type Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserNodesEnumerator Interface > BrowserNodesEnumerator Properties > BrowserNodesEnumerator.Type Property


BrowserPane CoClass

BrowserPane CoClass Available in Inventor Introduced in Inventor 5
Summary

The BrowserPane object represents an independent window or panel inside the browser that is currently associated with the active document.

Class Hierarchy
Inventor::BrowserPane
Visual Basic
Public Class BrowserPane
Remarks

Each of these panes can be accessed by the end-user via a drop-down control in the frame of the browser, unless the pane is marked as hidden; then the end-user does not have access to it. Only programmatic access is available to such panes. See the topic in the overview section.

Notes

Members through which this object may be accessed include:

BrowserPanes.ActivePane

BrowserPanes.Add

BrowserPanes.AddTransientTreeBrowserPane

BrowserPanes.AddTreeBrowserPane

BrowserPanes.Item

See Also

Promote occurence sample

Demote occurence sample

Add assembly occurrences to a new folder sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPane CoClass


BrowserPaneObject Interface

BrowserPaneObject Interface
Summary

The object represents an independent window or panel inside the Browser that is currently associatedwith the active Document.

Class Hierarchy
Inventor::BrowserPaneObject
Visual Basic
Public Interface BrowserPaneObject
Inherits IDispatch
Remarks

Each of these panes can be accessed by the end-user via a drop-down control in the frame of the Browser, unless the pane is marked as hidden; then the end-user does not see access to it. Only programmatic access is available to such panes.

See Also

Demote occurence sample

Add assembly occurrences to a new folder sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface


BrowserPaneObject Methods

BrowserPaneObject Methods
Summary

The methods of the BrowserPaneObject class are listed here.

Methods
Methods
Name | Description
Activate | Method that causes the pane to become the active browser pane.
AddBrowserFolder | Method that creates a new browser folder at the location specified by the input nodes.
Delete | Method that deletes the browser pane. If this pane is currently active, the default Inventor pane will become active. This method will fail for built-in browser panes.
GetBrowserNodeFromObject | Method that returns the browser node that corresponds to the input object. The method returns an error if no corresponding node is found within this pane. If multiple matches are found, the method returns the first match.
Refresh | Rebuilds assembly browser by incorporating information from sub-doc(s) default browser pane into the top level document's 'Model' pane. Should be used on a top level assembly's 'Model' pane after a sub-doc's default pane is changed via BrowserPane::Default
Reorder | Method that reorders the browser tree by moving browser nodes to the specified position in the browser. An error occurs if the browser cannot be reordered as specified.
Update | Refreshes the browser view. Should be used after changing browser node status (e.g. DisplayState)
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods


BrowserPaneObject.Activate Method

BrowserPaneObject.Activate Method
Summary

Method that causes the pane to become the active browser pane.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.Activate Method


BrowserPaneObject.AddBrowserFolder Method

BrowserPaneObject.AddBrowserFolder Method
Summary

Method that creates a new browser folder at the location specified by the input nodes.

Visual Basic
Sub AddBrowserFolder(ByRef Name As [defaultvalue("")] BSTR, ByRef BrowserNodes As [optional] VARIANT, Result As [out, retval] BrowserFolder*)
Parameters
Parameters | Description
Name | Optional input String that specifies a name for the folder. If not specified, the default naming scheme is used to assign a name to the folder.
BrowserNodes | Optional input ObjectCollection containing BrowserNode objects to create the folder for. If not specified, an empty folder is created as the last node in the browser. The input nodes should be contiguous in the browser. If not contiguous, Inventor attempts to reorder the nodes so they are contiguous before putting them in a folder. Use GetBrowserNodeFromObject method to get corresponding browser nodes for Inventor objects.
Example

This sample demonstrates adding assembly occurrences to a new folder.

Have an assembly with at least one occurrence in it and run the sample.

Public Sub AddOccurrencesToFolder()

    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oDef As AssemblyComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    Dim oPane As BrowserPane
    Set oPane = oDoc.BrowserPanes.ActivePane

    Dim oOccurrenceNodes As ObjectCollection
    Set oOccurrenceNodes = ThisApplication.TransientObjects.CreateObjectCollection

    Dim oOcc As ComponentOccurrence
    For Each oOcc In oDef.Occurrences

        Dim oNode As BrowserNode
        Set oNode = oPane.GetBrowserNodeFromObject(oOcc)

        oOccurrenceNodes.Add oNode
    Next

    Dim oFolder As BrowserFolder
    Set oFolder = oPane.AddBrowserFolder("My Occurrence Folder", oOccurrenceNodes)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.AddBrowserFolder Method


BrowserPaneObject.Delete Method

BrowserPaneObject.Delete Method
Summary

Method that deletes the browser pane. If this pane is currently active, the default Inventor pane will become active. This method will fail for built-in browser panes.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.Delete Method


BrowserPaneObject.GetBrowserNodeFromObject Method

BrowserPaneObject.GetBrowserNodeFromObject Method
Summary

Method that returns the browser node that corresponds to the input object. The method returns an error if no corresponding node is found within this pane. If multiple matches are found, the method returns the first match.

Visual Basic
Sub GetBrowserNodeFromObject(NativeObject As IDispatch, Result As [out, retval] BrowserNode*)
Parameters
Parameters | Description
NativeObject | Input object to return the node for.
See Also

Promote occurence sample

Demote occurence sample

Add assembly occurrences to a new folder sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.GetBrowserNodeFromObject Method


BrowserPaneObject.Refresh Method

BrowserPaneObject.Refresh Method
Summary

Rebuilds assembly browser by incorporating information from sub-doc(s) default browser pane into the top level document's 'Model' pane. Should be used on a top level assembly's 'Model' pane after a sub-doc's default pane is changed via BrowserPane::Default

Visual Basic
Sub Refresh()
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.Refresh Method


BrowserPaneObject.Reorder Method

BrowserPaneObject.Reorder Method
Summary

Method that reorders the browser tree by moving browser nodes to the specified position in the browser. An error occurs if the browser cannot be reordered as specified.

Visual Basic
Sub Reorder(TargetNode As BrowserNode, Before As VARIANT_BOOL, StartNode As BrowserNode, ByRef EndNode As [optional] VARIANT)
Parameters
Parameters | Description
TargetNode | Input BrowserNode object to position the browser nodes next to. An error will occur if the target node is not at the same level in the browser as the node(s) being repositioned. The input node must belong to this pane.
Before | Input Boolean that indicates whether to position the node(s) before or after the target browser node. A value of True indicates that the node(s) will be positioned before the target node.
StartNode | Input BrowserNode object that specifies the node to be repositioned. The input node must belong to this pane.
EndNode | Optional input BrowserNode object. If specified, all the browser node objects from the StartNode to the EndNode, both inclusive, will be repositioned to the specified position in the tree. If not specified, only the StartNode will be repositioned. This argument is currently ignored in drawings.
Remarks

Use the GetBrowserNodeFromObject method to find nodes that correspond to Inventor data objects.

Example 1

Demote occurence example.

This sample demonstrates how to demote a top level occurrence in an assembly into a new sub-assembly occurrence.

Public Sub Demote()

    ' Get the active assembly document
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oDef As AssemblyComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    ' Get the occurrence to be demoted
    Dim oOcc As ComponentOccurrence
    Set oOcc = oDef.Occurrences.Item(1)

    ' Create a new sub-assembly to demote the occurrence into
    Dim oNewSubAssy As AssemblyDocument
    Set oNewSubAssy = ThisApplication.Documents.Add(kAssemblyDocumentObject, , False)

    Dim oMat As Matrix
    Set oMat = ThisApplication.TransientGeometry.CreateMatrix

    ' Create an instance of the new sub-assembly
    Dim oSubAssyOcc As ComponentOccurrence
    Set oSubAssyOcc = oDef.Occurrences.AddByComponentDefinition(oNewSubAssy.ComponentDefinition, oMat)

    ' Get the model browser
    Dim oPane As BrowserPane
    Set oPane = oDoc.BrowserPanes.Item("Model")

    ' Get the browser node that corresponds to the new sub-assembly occurrence
    Dim oSubAssyNode As BrowserNode
    Set oSubAssyNode = oPane.GetBrowserNodeFromObject(oSubAssyOcc)

    ' Get the last visible child node under the sub-assembly occurrence
    Dim oTargetNode As BrowserNode
    Dim i As Long
    For i = oSubAssyNode.BrowserNodes.Count To 1 Step -1
        If oSubAssyNode.BrowserNodes.Item(i).Visible Then
            Set oTargetNode = oSubAssyNode.BrowserNodes.Item(i)
            Exit For
        End If
    Next

    ' Get the browser node that corresponds to the occurrence to be demoted
    Dim oSourceNode As BrowserNode
    Set oSourceNode = oPane.GetBrowserNodeFromObject(oOcc)

    ' Demote the occurrence
    Call oPane.Reorder(oTargetNode, False, oSourceNode)
End Sub
Example 2

Promote occurence example.

This sample demonstrates how to promote an occurrence.

Public Sub Promote()

    ' Get the active assembly document
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oDef As AssemblyComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    ' Get the top level occurrence of an assembly
    Dim oSubAssyOcc As ComponentOccurrence
    Set oSubAssyOcc = oDef.Occurrences.Item(1)

    ' Get the 2nd level occurrence under the assembly occurrence
    Dim oSubOcc As ComponentOccurrenceProxy
    Set oSubOcc = oDef.Occurrences.Item(1).SubOccurrences.Item(1)

    Dim oPane As BrowserPane
    Set oPane = oDoc.BrowserPanes.Item("Model")

    ' Get the browser nodes corresponding to the two occurrences
    Dim oTargetNode As BrowserNode
    Set oTargetNode = oPane.GetBrowserNodeFromObject(oSubAssyOcc)

    Dim oSourceNode As BrowserNode
    Set oSourceNode = oPane.GetBrowserNodeFromObject(oSubOcc)

    ' Reorder the nodes to promote the sub-occurrence to the top level
    Call oPane.Reorder(oTargetNode, True, oSourceNode)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.Reorder Method


BrowserPaneObject.Update Method

BrowserPaneObject.Update Method
Summary

Refreshes the browser view. Should be used after changing browser node status (e.g. DisplayState)

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Methods > BrowserPaneObject.Update Method


BrowserPaneObject Properties

BrowserPaneObject Properties
Summary

The properties of the BrowserPaneObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that specifies if the pane is a standard Inventor pane or not. Built-in panes have restrictions in the edits that can be performed.
Control | Property that returns the ActiveX control that may be associated with the pane. This property will return Nothing in the case this is a Tree Browser Pane.
Default | Property that specifies if this pane is set as the default when the Document is opened.
InternalName | Property that gets either the Control Identifier or the Internal Identifier depending on whether this Browser Pane is one that is an ActiveX control container or an Inventor tree browser.
Name | Property that gets and sets the name of the pane. When setting the name, an error will occur if the name is not unique with respect to the other panes of the document. The name of built-in panes cannot be set.
Parent | Property that returns this object's parent, the Document.
TopNode | Property that gets the single, topmost Browser Node that forms the starting point or root of the browser tree.
TreeBrowser | Property that specifies if the pane hosts 'tree' BrowserNodes constructed by Inventor. Most built-in panes are of this type. Third Parties can also create such browser trees out of BrowserNodes that are custom-created.
Type | Returns an ObjectTypeEnum indicating this object's type.
Visible | Property that gets and sets the Boolean flag which can turn the availability of the BrowserPane in the UI, off or on.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties


BrowserPaneObject.Application Property

BrowserPaneObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Application Property


BrowserPaneObject.BuiltIn Property

BrowserPaneObject.BuiltIn Property
Summary

Property that specifies if the pane is a standard Inventor pane or not. Built-in panes have restrictions in the edits that can be performed.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.BuiltIn Property


BrowserPaneObject.Control Property

BrowserPaneObject.Control Property
Summary

Property that returns the ActiveX control that may be associated with the pane. This property will return Nothing in the case this is a Tree Browser Pane.

Visual Basic
Property Control() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Control Property


BrowserPaneObject.Default Property

BrowserPaneObject.Default Property
Summary

Property that specifies if this pane is set as the default when the Document is opened.

Visual Basic
Property Default() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Default Property


BrowserPaneObject.InternalName Property

BrowserPaneObject.InternalName Property
Summary

Property that gets either the Control Identifier or the Internal Identifier depending on whether this Browser Pane is one that is an ActiveX control container or an Inventor tree browser.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.InternalName Property


BrowserPaneObject.Name Property

BrowserPaneObject.Name Property
Summary

Property that gets and sets the name of the pane. When setting the name, an error will occur if the name is not unique with respect to the other panes of the document. The name of built-in panes cannot be set.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Name Property


BrowserPaneObject.Parent Property

BrowserPaneObject.Parent Property
Summary

Property that returns this object's parent, the Document.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Parent Property


BrowserPaneObject.TopNode Property

BrowserPaneObject.TopNode Property
Summary

Property that gets the single, topmost Browser Node that forms the starting point or root of the browser tree.

Visual Basic
Property TopNode() As BrowserNode**
See Also

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.TopNode Property


BrowserPaneObject.TreeBrowser Property

BrowserPaneObject.TreeBrowser Property
Summary

Property that specifies if the pane hosts 'tree' BrowserNodes constructed by Inventor. Most built-in panes are of this type. Third Parties can also create such browser trees out of BrowserNodes that are custom-created.

Visual Basic
Property TreeBrowser() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.TreeBrowser Property


BrowserPaneObject.Type Property

BrowserPaneObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Type Property


BrowserPaneObject.Visible Property

BrowserPaneObject.Visible Property
Summary

Property that gets and sets the Boolean flag which can turn the availability of the BrowserPane in the UI, off or on.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneObject Interface > BrowserPaneObject Properties > BrowserPaneObject.Visible Property


BrowserPanes Interface

BrowserPanes Interface Available in Inventor Introduced in Inventor 5
Summary

The BrowserPanes object provides access to the existing objects of the browser and allows you to create additional panes. See the article in the overviews section.

Class Hierarchy
Inventor::BrowserPanes
Visual Basic
Public Interface BrowserPanes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Document.BrowserPanes

See Also

Demote occurence sample

Add assembly occurrences to a new folder sample

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface


BrowserPanes Methods

BrowserPanes Methods
Summary

The methods of the BrowserPanes class are listed here.

Methods
Methods
Name | Description
Add | Method that creates and returns a new BrowserPane object. The BrowserPane created is one that is explicitly used to house ActiveX controls.
AddTransientTreeBrowserPane | Method that creates and returns a new transient BrowserPane object.
AddTreeBrowserPane | Method that creates and returns a new BrowserPane object. The BrowserPane created is one in which Inventor's BrowserTreeNodes can be instanced to generate a completely customizable tree view.
CreateBrowserNodeDefinition | Method that creates a new The definition object can then be further used to construct ClientBrowserNodes that make up the tree in a custom tree-browser pane. The new ClientBrowserNodeDefinition is returned. Note that this node definition object is constructed and has an identity within the 'name space' or context of the entire owning document.
GetClientBrowserNodeDefinition | Method that returns the specified ClientBrowserNodeDefinition.
GetNativeBrowserNodeDefinition | Method to obtain the NativeBrowserNodeDefinition object corresponding to a data model object.Also see CreateNativeBrowserNodeDefinition for information on creating a new client browser node definition.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods


BrowserPanes.Add Method

BrowserPanes.Add Method Available in Inventor Introduced in Inventor 5
Summary

Method that creates and returns a new BrowserPane object. The BrowserPane created is one that is explicitly used to house ActiveX controls.

Visual Basic
Sub Add(Name As String, InternalName As String, Result As [out, retval] BrowserPane*)
Parameters
Parameters | Description
Name | Input String that specifies the name of the BrowserPane object. This is the name that will be displayed to the user. The name must be unique with respect to the other browser panes currently created for the document. It can be changed programmatically at any time, and can be localized. It can also be used as an index into the BrowserPanes collection.
InternalName | Input string that identifies the ActiveX control that will be displayed on the pane. This identifier can be either the ProgID or the GUID of the control as a string, (including the braces "{ }"). This string will also be used to uniquely identify the BrowserPane within the collection. This identifier string once provided cannot be changed.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods > BrowserPanes.Add Method


BrowserPanes.AddTransientTreeBrowserPane Method

BrowserPanes.AddTransientTreeBrowserPane Method Available in Inventor
Summary

Method that creates and returns a new transient BrowserPane object.

Visual Basic
Sub AddTransientTreeBrowserPane(Name As String, InternalName As String, TopNodeDefinition As BrowserNodeDefinition, Result As [out, retval] BrowserPane*)
Parameters
Parameters | Description
Name | Input string that specifies the name of the browser pane. This is the name that will be displayed to the user. And thus is expected to be localized. It can be changed, programmatically, at any time. It may also be used to index into the BrowserPanes collection.
InternalName | Input string that uniquely identifies the application. Suggestions are the 'ProgID' of the Add-In creating the pane or the its CLSID in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", although any unique string is valid. If the Add-In is going to create more than one such pane, you would want to further qualify the string by appending a suffix to the CLSID, say '{<CLSID>}:0' and '{<CLSID>}:1', etc.
TopNodeDefinition | Input definition object that will be used to build the single topmost node that starts of the browser tree.
Remarks

The BrowserPane created is one in which Inventor's BrowserTreeNodes can be instanced to generate a completely customizable tree view. This pane is not saved with the document.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods > BrowserPanes.AddTransientTreeBrowserPane Method


BrowserPanes.AddTreeBrowserPane Method

BrowserPanes.AddTreeBrowserPane Method Available in Inventor Introduced in Inventor 8
Summary

Method that creates and returns a new BrowserPane object. The BrowserPane created is one in which Inventor's BrowserTreeNodes can be instanced to generate a completely customizable tree view.

Visual Basic
Sub AddTreeBrowserPane(Name As String, InternalName As String, TopNodeDefinition As BrowserNodeDefinition, Result As [out, retval] BrowserPane*)
Parameters
Parameters | Description
Name | Input string that specifies the name of the browser pane. This is the name that will be displayed to the user. The name must be unique with respect to the other browser panes currently created for the document. It can be changed programmatically at any time, and can be localized. It can also be used as an index into the BrowserPanes collection.
InternalName | Input string that uniquely identifies the application. Suggestions are to use the 'ProgID' of the Add-In creating the pane or its CLSID in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", although any unique string is valid. If the Add-In is going to create more than one such pane, you would want to further qualify the string by appending a suffix to the CLSID, say "{}:0" and "{}:1", etc.
TopNodeDefinition | Input definition object that will be used to build the single topmost node that starts the browser tree.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods > BrowserPanes.AddTreeBrowserPane Method


BrowserPanes.CreateBrowserNodeDefinition Method

BrowserPanes.CreateBrowserNodeDefinition Method Available in Inventor Introduced in Inventor 8
Summary

Method that creates a new The definition object can then be further used to construct ClientBrowserNodes that make up the tree in a custom tree-browser pane. The new ClientBrowserNodeDefinition is returned. Note that this node definition object is constructed and has an identity within the 'name space' or context of the entire owning document.

Visual Basic
Sub CreateBrowserNodeDefinition(Label As String, Id As long, Icon As ClientNodeResource, ByRef ToolTipText As [optional] VARIANT, ByRef ExpandedIcon As [optional] VARIANT, ByRef DisplayState As [optional] VARIANT, ByRef StateIconToolTipText As [optional] VARIANT, Result As [out, retval] ClientBrowserNodeDefinition*)
Parameters
Parameters | Description
Label | Input string that specifies the label of the browser node. This label will be displayed as the text of this resulting browser node.
Id | Input long that uniquely identifies the Client Browser Node Definition within the scope of this Document.
Icon | ClientNodeResource that specifies the bitmap pictures for the node.
ToolTipText | Optional input string that specifies the tool tip to be displayed for the node.
ExpandedIcon | Optional input of a 16X16 pixel image. If this argument is not supplied then the StandardIcon is used for the purpose when the corresponding BrowserNode is to be displayed in an expanded state.
StateIconToolTipText | Optional input string that specifies the tool tip to be displayed for the state icon.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods > BrowserPanes.CreateBrowserNodeDefinition Method


BrowserPanes.GetClientBrowserNodeDefinition Method

BrowserPanes.GetClientBrowserNodeDefinition Method Available in Inventor Introduced in Inventor 11
Summary

Method that returns the specified ClientBrowserNodeDefinition.

Visual Basic
Sub GetClientBrowserNodeDefinition(ClientId As String, Id As long, Result As [out, retval] ClientBrowserNodeDefinition*)
Parameters
Parameters | Description
ClientId | Input string that specifies ClientId associated with the definition.
Id | Input long that uniquely identifies the Client Browser Node Definition within the scope of this Document.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods > BrowserPanes.GetClientBrowserNodeDefinition Method


BrowserPanes.GetNativeBrowserNodeDefinition Method

BrowserPanes.GetNativeBrowserNodeDefinition Method Available in Inventor Introduced in Inventor 9
Summary

Method to obtain the NativeBrowserNodeDefinition object corresponding to a data model object.Also see CreateNativeBrowserNodeDefinition for information on creating a new client browser node definition.

Visual Basic
Sub GetNativeBrowserNodeDefinition(NativeObject As IDispatch, Result As [out, retval] NativeBrowserNodeDefinition*)
Parameters
Parameters | Description
NativeObject | The object for whom to obtain the NativeBrowserNodeDefinition.
Example

"Navigation between browser and data"

"This sample demonstrates the navigation between a browser node and it's corresponding data model object and vice versa. This sample creates a work plane, finds its browser node and gets the work plane object back from the browser node."

Sub DataModelToBrowser()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject)

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new workplane parallel to the XY plane.
    Dim oWorkPlane As WorkPlane
    Set oWorkPlane = oCompDef.WorkPlanes.AddByPlaneAndOffset(oCompDef.WorkPlanes.Item(3), 1)

    ' Get the browser node definition associated with the work plane.
    Dim oNativeBrowserNodeDef As NativeBrowserNodeDefinition
    Set oNativeBrowserNodeDef = oPartDoc.BrowserPanes.GetNativeBrowserNodeDefinition(oWorkPlane)

    ' Get the top browser node of the model pane.
    Dim oTopBrowserNode As BrowserNode
    Set oTopBrowserNode = oPartDoc.BrowserPanes.ActivePane.TopNode

    ' Get the work plane browser node.
    ' This assumes that only one node references the browser node definition.
    ' An example of multiple nodes referencing a single definition is a shared
    ' sketch. The browser may have multiple nodes that represent the same shared
    ' sketch, but all of them reference the same definition.
    Dim oWorkPlaneNode As BrowserNode
    Set oWorkPlaneNode = oTopBrowserNode.AllReferencedNodes(oNativeBrowserNodeDef).Item(1)

    ' Get the browser node definition from the browser node.
    Set oNativeBrowserNodeDef = Nothing
    Set oNativeBrowserNodeDef = oWorkPlaneNode.BrowserNodeDefinition

    ' Get the work plane from the browser node definition.
    Set oWorkPlane = Nothing
    Set oWorkPlane = oNativeBrowserNodeDef.NativeObject

    ' Select the work plane to make sure we have the right object.
    oPartDoc.SelectSet.Select oWorkPlane
End Sub
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Methods > BrowserPanes.GetNativeBrowserNodeDefinition Method


BrowserPanes Properties

BrowserPanes Properties
Summary

The properties of the BrowserPanes class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
Properties
Name | Description
ActivePane | Property that returns the that is currently being displayed.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BrowserPanesEvents | Property that returns the events sink object for the BrowserPanes object.
ClientNodeResources | Property that returns the collection of ClientNodeResource objects. A ClientNodeResource holds the icons necessary to define the open, closed and status images for all of the ClientBrowserNodes associated with this document. The ClientNodeResources collection has a method that allows you to add a new set of images that can then be used to create a new ClientBrowserNodeDefinition.
Count | Property that returns the number of browser panes in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties


BrowserPanes.ActivePane Property

BrowserPanes.ActivePane Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the that is currently being displayed.

Visual Basic
Property ActivePane() As BrowserPane**
See Also

Add assembly occurrences to a new folder sample

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.ActivePane Property


BrowserPanes.Application Property

BrowserPanes.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.Application Property


BrowserPanes.BrowserPanesEvents Property

BrowserPanes.BrowserPanesEvents Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the events sink object for the BrowserPanes object.

Visual Basic
Property BrowserPanesEvents() As BrowserPanesEvents**
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.BrowserPanesEvents Property


BrowserPanes.ClientNodeResources Property

BrowserPanes.ClientNodeResources Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns the collection of ClientNodeResource objects. A ClientNodeResource holds the icons necessary to define the open, closed and status images for all of the ClientBrowserNodes associated with this document. The ClientNodeResources collection has a method that allows you to add a new set of images that can then be used to create a new ClientBrowserNodeDefinition.

Visual Basic
Property ClientNodeResources() As ClientNodeResources**
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.ClientNodeResources Property


BrowserPanes.Count Property

BrowserPanes.Count Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the number of browser panes in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.Count Property


BrowserPanes.Item Method

BrowserPanes.Item Method Available in Inventor Introduced in Inventor 5
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] BrowserPane*)
Parameters
Parameters | Description
index | Input Variant that specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection or a String indicating the name of the . If there is no BrowserPane with this name currently, the function further checks to see if the string supplied is an InternalName of any BrowserPane. If no BrowserPane can be identified, a failure occurs.
See Also

Demote occurence sample

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.Item Method


BrowserPanes.Type Property

BrowserPanes.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanes Interface > BrowserPanes Properties > BrowserPanes.Type Property


BrowserPanesEvents CoClass

BrowserPanesEvents CoClass Available in Inventor Introduced in Inventor 9
Summary

Object providing event notification for browser events.

Class Hierarchy
Inventor::BrowserPanesEvents
Visual Basic
Public Class BrowserPanesEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

BrowserPanes.BrowserPanesEvents

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesEvents CoClass


BrowserPanesEventsObject Interface

BrowserPanesEventsObject Interface Available in Inventor Introduced in Inventor 9
Summary

Object providing event notification for browser events.

Class Hierarchy
Inventor::BrowserPanesEventsObject
Visual Basic
Public Interface BrowserPanesEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesEventsObject Interface


BrowserPaneSink Interface

BrowserPaneSink Interface
Summary

The BrowserPane object represents an independent window or panel inside the browser that is currently associated with the active document.

Class Hierarchy
Inventor::BrowserPaneSink
Visual Basic
Public Interface BrowserPaneSink
Inherits IDispatch
Remarks

Each of these panes can be accessed by the end-user via a drop-down control in the frame of the browser, unless the pane is marked as hidden; then the end-user does not have access to it. Only programmatic access is available to such panes. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneSink Interface


BrowserPaneSink Methods

BrowserPaneSink Methods
Summary

The methods of the BrowserPaneSink class are listed here.

Methods
Methods
Name | Description
OnActivate | The OnActivate event notifies a client when the BrowserPane has become the active pane.
OnDeactivate | The OnDeactivate event notifies a client when a BrowserPane is deactivated.
OnHelp | The OnHelp event notifies a client when the end-user clicks the help button on the browser pane.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneSink Interface > BrowserPaneSink Methods


BrowserPaneSink.OnActivate Method

BrowserPaneSink.OnActivate Method
Summary

The OnActivate event notifies a client when the BrowserPane has become the active pane.

Visual Basic
Sub OnActivate()
Remarks

Typically, this is fired as a result of the end-user switching from one browser pane to another. This event is useful when a client has created a custom pane. By listening for this notification the client can know if the pane is in a state where the end-user can see and interact with it. This method is fired before the pane is displayed, so any changes can be made to the control before the user sees it. This method, in combination with the OnDeactivate event can be used to more efficiently update the data displayed within the browser pane control. By using these events you can choose to only update the control when it is displayed to the user.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneSink Interface > BrowserPaneSink Methods > BrowserPaneSink.OnActivate Method


BrowserPaneSink.OnDeactivate Method

BrowserPaneSink.OnDeactivate Method
Summary

The OnDeactivate event notifies a client when a BrowserPane is deactivated.

Visual Basic
Sub OnDeactivate()
Remarks

This method, in combination with the OnActivate event can be used to more efficiently update the data displayed within the browser pane control. By using these events you can choose to only update the control when it is displayed to the user. A deactivate notification is made when a browser pane is the active pane and the end-user activates another pane. This event is useful when a client has created a custom pane. By listening for this notification the client can know if the pane is in a state where the end-user can see and interact with it.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneSink Interface > BrowserPaneSink Methods > BrowserPaneSink.OnDeactivate Method


BrowserPaneSink.OnHelp Method

BrowserPaneSink.OnHelp Method
Summary

The OnHelp event notifies a client when the end-user clicks the help button on the browser pane.

Visual Basic
Sub OnHelp(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter). This notification is only provided before any help is displayed so the value of this argument will always be kBefore.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. Setting the value of the HandlingCode argument specifies how Inventor is to handle displaying help. If you set this argument to kEventNotHandled or kEventCanceled, Inventor will display some general browser help. Setting the value of this argument to kEventHandled will allow you to handle displaying help to the end-user and Inventor will not display anything. To display help to the end-user you can choose to use whatever help system you want. Inventor's API does not provide support for the actual display of the clients help.
Remarks

By setting the HandlingCode argument, the client can choose to handle displaying help themselves or let Inventor handle displaying some help information.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPaneSink Interface > BrowserPaneSink Methods > BrowserPaneSink.OnHelp Method


BrowserPanesSink Interface

BrowserPanesSink Interface
Summary

The BrowserPanes object provides access to the existing objects of the browser and allows you to create additional panes. See the article in the overviews section.

Class Hierarchy
Inventor::BrowserPanesSink
Visual Basic
Public Interface BrowserPanesSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesSink Interface


BrowserPanesSink Methods

BrowserPanesSink Methods
Summary

The methods of the BrowserPanesSink class are listed here.

Methods
Methods
Name | Description
OnBrowserNodeActivate | The OnBrowserNodeActivate event notifies a client when a browser node is activated (double-clicked).
OnBrowserNodeDeleteEntry | The OnBrowserNodeDeleteEntry event allows a client to control if the Delete option is available on the context menu for custom browser nodes.
OnBrowserNodeGetDisplayObjects | The OnBrowserNodeGetDisplayObjects event notifies a client when the objects associated with a browser node definition need to be highlighted or selected.
OnBrowserNodeLabelEdit | The OnBrowserNodeLabelEdit event notifies a client when the end-user is editing the label of a browser node.
You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesSink Interface > BrowserPanesSink Methods


BrowserPanesSink.OnBrowserNodeActivate Method

BrowserPanesSink.OnBrowserNodeActivate Method
Summary

The OnBrowserNodeActivate event notifies a client when a browser node is activated (double-clicked).

Visual Basic
Sub OnBrowserNodeActivate(BrowserNodeDefinition As IDispatch, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BrowserNodeDefinition | The ClientBrowserNodeDefinition associated with the node just activated.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. This event provides additional information through the Context argument as described below: Name = "Browser Node", Value = The BrowserNode object that the end-user double-clicked on.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. This argument is ignored for this event.
Remarks

This notification is only sent for custom browser nodes (nodes that are associated with a ClientBrowserNodeDefinition object). The activate event is handled by Inventor for browser nodes it creates. In reaction to this event, the client can perform whatever action is associated with an "Activate" for that node. In most cases this should invoke the appropriate edit operation for the associated objects.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesSink Interface > BrowserPanesSink Methods > BrowserPanesSink.OnBrowserNodeActivate Method


BrowserPanesSink.OnBrowserNodeDeleteEntry Method

BrowserPanesSink.OnBrowserNodeDeleteEntry Method
Summary

The OnBrowserNodeDeleteEntry event allows a client to control if the Delete option is available on the context menu for custom browser nodes.

Visual Basic
Sub OnBrowserNodeDeleteEntry(BrowserNodeDefinition As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BrowserNodeDefinition | The ClientBrowserNodeDefinition associated with the node the end-user has right-clicked on.
BeforeOrAfter | When this value is kBefore you are able to control whether the Delete command is available in the context menu or not by setting the appropriate handling code. When this value is kAfter it signals that the end-user has requested that this node and associated objects be deleted.
Context | No context information is provided for this event.
HandlingCode | When the BeforeOrAfter argument is kBefore you can set the HandlingCode argument to kEventCanceled to disable the Delete command from being displayed in the context menu. Any other value for this argument will allow Delete command to be displayed. This argument has no meaning when the BeforeOrAfter argument is kAfter.
Remarks

There are two end-user actions that can cause this notification to be sent. The first is when the end-user right-clicks on a custom browser node. The second is when a custom browser node is selected and the Delete key is pressed.

In the case of a right-click on the browser node this notification is sent with the BeforeOrAfter argument equal to kBefore and it is sent before the context menu is displayed to the end-user. If you set then HandlingCode to kEventCanceled the Delete command is not displayed in the context menu. Any other value for HandlingCode will result in the Delete command being available. If the end-user clicks the Delete command in the context menu then this notification is sent again with the BeforeOrAfter argument equal to kAfter indicating that the end-user has requested that this node and its associated objects should be deleted.

In the case of the Delete key being pressed this notification is sent with the BeforeOrAfter argument equal to kBefore wher you can respond by cancelling or not. If it's not cancelled then the notification is sent again with the BeforeOrAfter argument equal to kAfter signifying that the node and its associated bojects should be deleted.

The deletion of the node and any associated objects is entirely under the control of the client. Inventors only role is the notification that the end-user requested a delete. The actual deletion must be performed by the client.

In the case where multiple items have been selected and then the right-mouse button is clicked, Inventor will send this notification, with BeforeOrAfter equal to kBefore, for each node in the list until one of them does not return kEventCanceled. As long as any one of the selected items will handle delete, Inventor will display the Delete command in the context menu. If the end-user clicks the Delete command in the context menu, then this notification is sent once for each remaining selected item with the BeforeOrAfter argument equal to kBefore. You can determine if that object is deletable or not by setting the handling code just as described above. For each object that is deletable you will receive this notification again with the BeforeOrAfter argument equal to kAfter.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesSink Interface > BrowserPanesSink Methods > BrowserPanesSink.OnBrowserNodeDeleteEntry Method


BrowserPanesSink.OnBrowserNodeGetDisplayObjects Method

BrowserPanesSink.OnBrowserNodeGetDisplayObjects Method
Summary

The OnBrowserNodeGetDisplayObjects event notifies a client when the objects associated with a browser node definition need to be highlighted or selected.

Visual Basic
Sub OnBrowserNodeGetDisplayObjects(BrowserNodeDefinition As IDispatch, ByRef Objects As ObjectCollection*, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BrowserNodeDefinition | The ClientBrowserNodeDefinition associated with the node the mouse is over.
Objects | An Object collection that the client must create and populate with the objects associated with the browser node.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. This event provides additional information through the Context argument as described below: Name = "Browser Node", Value = The BrowserNode object that the mouse is over.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. This argument is ignored for this event.
Remarks

When the end-user moves the mouse over the browser nodes, the associated objects highlight in the graphics window. If the end-user selects a browser node, the associated objects are selected. This event supports this action for client created browser nodes. In response to this event the client can provide Inventor the objects that are logically associated with the browser node. Inventor will handle highlighting and selecting the objects depending on the end-user action.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesSink Interface > BrowserPanesSink Methods > BrowserPanesSink.OnBrowserNodeGetDisplayObjects Method


BrowserPanesSink.OnBrowserNodeLabelEdit Method

BrowserPanesSink.OnBrowserNodeLabelEdit Method
Summary

The OnBrowserNodeLabelEdit event notifies a client when the end-user is editing the label of a browser node.

Visual Basic
Sub OnBrowserNodeLabelEdit(BrowserNodeDefinition As IDispatch, NewLabel As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BrowserNodeDefinition | The ClientBrowserNodeDefinition associated with the node being edited. It's the Label property of this object that will be affected by an edit.
NewLabel | When BeforeOrAfter is kBefore this is the current label of the node. When BeforeOrAFter is kAfter this is the new label of the node.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter). Notification is sent before and after the label edit occurs. When the BeforeOrAfter argument is kBefore you can set the HandlingCode argument to kEventCanceled to abort the edit and prohibit the end-user from editing the label. Any other value for this argument will allow the end-user to edit the label. If the HandlingCode is set to kEventCanceled, this notification is only sent before. For the other cases this notification is also sent after the edit is finished.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. When the BeforeOrAfter argument is kBefore you can set the HandlingCode argument to kEventCanceled to abort the edit and prohibit the end-user from editing the label. Any other value for this argument will allow the end-user to edit the label.
Remarks

If the end-user selects a browser node and then clicks again it will enter a state where the label of the node can be edited. This event allows you to control and monitor this behavior.

You are here: Symbol Reference > Inventor Library > Objects > BrowserPanesSink Interface > BrowserPanesSink Methods > BrowserPanesSink.OnBrowserNodeLabelEdit Method


BSplineCurve Interface

BSplineCurve Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The BSplineCurve object is a mathematical utility object that represents a NURBS curve. It is a transient object that is never shown graphically or saved in the Inventor document

Class Hierarchy
Inventor::BSplineCurve
Visual Basic
Public Interface BSplineCurve
Inherits IDispatch
Remarks

The BSplineCurve object is returned by graphical entities that have an underlying freeform curve shape. BSplineCurve objects can also be explicitly created using the CreateBSplineCurve method of the TransientGeometry object.

When obtained from an graphical entity, the BSplineCurve object represents a snapshot of the graphical entity. If the graphical entity is modified it will not affect the BSplineCurve object. Also, if the BSplineCurve object is modified it will not affect the graphical entity it was obtained from.

Notes

Members through which this object may be accessed include:

SketchFixedSpline3D.Geometry

SketchSpline3D.Geometry

TransientGeometry.CreateBSplineCurve

TransientGeometry.CreateFittedBSplineCurve

CurveGraphics.Curve

Edge.Geometry

You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface


BSplineCurve Methods

BSplineCurve Methods
Summary

The methods of the BSplineCurve class are listed here.

Methods
Methods
Name | Description
GetBSplineData | Get the data defining this B-spline.
GetBSplineInfo | Gets general information about the definition of the spline, including its order, number of poles and knots, and its rational, periodic, closed, and planar states.
PoleAtIndex | Indicates the pole coordinate point at the specified index into the spline's pole vector.
PoleAtIndex | Property that returns the x, y, z position of a specified pole.
PutBSplineInfoAndData | Sets the definition data of the spline.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Methods


BSplineCurve.GetBSplineData Method

BSplineCurve.GetBSplineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this B-spline.

Visual Basic
Sub GetBSplineData(ByRef Poles As SAFEARRAY(double), ByRef Knots As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double))
Parameters
Parameters | Description
Poles | Input/output Double that specifies the poles of the B-Spline.
Knots | Input/output Double that specifies the knots of the B-Spline.
Weights | Input/output Double that specifies the B-spline's weights.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Methods > BSplineCurve.GetBSplineData Method


BSplineCurve.GetBSplineInfo Method

BSplineCurve.GetBSplineInfo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets general information about the definition of the spline, including its order, number of poles and knots, and its rational, periodic, closed, and planar states.

Visual Basic
Sub GetBSplineInfo(ByRef Order As long, ByRef NumPoles As long, ByRef NumKnots As long, ByRef IsRational As VARIANT_BOOL, ByRef IsPeriodic As VARIANT_BOOL, ByRef IsClosed As VARIANT_BOOL, ByRef IsPlanar As VARIANT_BOOL, ByRef PlaneVector As SAFEARRAY(double))
Parameters
Parameters | Description
Order | Output Long that specifies the order of the spline.
NumPoles | Output Long that specifies the number of poles.
NumKnots | Output Long that specifies the number of knots.
IsRational | Output Boolean that specifies whether the B-Spline is rational.
IsPeriodic | Output Boolean that specifies whether the B-Spline is periodic.
IsClosed | Output Boolean that specifies whether the curve is closed.
IsPlanar | Output Boolean that specifies whether the B-Spline is planar.
PlaneVector | Output Double that specifies the B-Spline's plane vector.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Methods > BSplineCurve.GetBSplineInfo Method


BSplineCurve.PoleAtIndex Method ([in] long, [in] Point*)

BSplineCurve.PoleAtIndex Method ([in] long, [in] Point*) Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates the pole coordinate point at the specified index into the spline's pole vector.

Visual Basic
Sub PoleAtIndex(Index As long, Pole As Point)
Parameters
Parameters | Description
index | Input Long that specifies which pole to return the coordinate data for. The pole indices range from 1 to the number of poles in the curve.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Methods > BSplineCurve.PoleAtIndex Method ([in] long, [in] Point*)


BSplineCurve.PoleAtIndex Method ([in] long, [out, retval] Point**)

BSplineCurve.PoleAtIndex Method ([in] long, [out, retval] Point**) Available in Apprentice
Summary

Property that returns the x, y, z position of a specified pole.

Visual Basic
Sub PoleAtIndex(Index As long, Result As [out, retval] Point*)
Parameters
Parameters | Description
Index | Specifies which pole to return the coordinate data for. The pole indices range from 1 to the number of poles in the curve.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Methods > BSplineCurve.PoleAtIndex Method ([in] long, [out, retval] Point**)


BSplineCurve.PutBSplineInfoAndData Method

BSplineCurve.PutBSplineInfoAndData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets the definition data of the spline.

Visual Basic
Sub PutBSplineInfoAndData(Order As long, ByRef Poles As SAFEARRAY(double), ByRef Knots As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double), IsPeriodic As VARIANT_BOOL)
Parameters
Parameters | Description
Order | Input Long that specifies the order of the spline.
Poles | Input/output Double that specifies the poles of the B-Spline.
Knots | Input/output Double that specifies the knots of the B-Spline.
Weights | Input/output Double that specifies the B-spline's weights.
IsPeriodic | Input Boolean that specifies whether the B-Spline is periodic.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Methods > BSplineCurve.PutBSplineInfoAndData Method


BSplineCurve Properties

BSplineCurve Properties
Summary

The properties of the BSplineCurve class are listed here.

Properties
Name | Description
Evaluator | Property that returns an evaluator object for the curve. The evaluator supports general curve evaluation functions.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Properties


BSplineCurve.Evaluator Property

BSplineCurve.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns an evaluator object for the curve. The evaluator supports general curve evaluation functions.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve Interface > BSplineCurve Properties > BSplineCurve.Evaluator Property


BSplineCurve2d Interface

BSplineCurve2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The BSplineCurve2d object. For more information, see the Transient Geometry overview.

Class Hierarchy
Inventor::BSplineCurve2d
Visual Basic
Public Interface BSplineCurve2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchFixedSpline.Geometry

SketchOffsetSpline.Geometry

SketchSpline.Geometry

TransientGeometry.CreateBSplineCurve2d

TransientGeometry.CreateFittedBSplineCurve2d

ProfileEntity.Curve

EdgeUse.Geometry

See Also

Spline - create NURBS sample

You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface


BSplineCurve2d Methods

BSplineCurve2d Methods
Summary

The methods of the BSplineCurve2d class are listed here.

Methods
Methods
Name | Description
GetBSplineData | Get the data defining this B-spline.
GetBSplineInfo | Gets general information about the definition of the spline, including its order, number of poles and knots, and its rational, periodic, closed, and planar states.
PoleAtIndex | Indicates the pole coordinate point at the specified index into the spline's pole vector.
PoleAtIndex | Indicates the pole coordinate point at the specified index into the spline's pole vector.
PutBSplineInfoAndData | Sets the definition data of the spline.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Methods


BSplineCurve2d.GetBSplineData Method

BSplineCurve2d.GetBSplineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this B-spline.

Visual Basic
Sub GetBSplineData(ByRef Poles As SAFEARRAY(double), ByRef Knots As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double))
Parameters
Parameters | Description
Poles | Input/output Double that specifies the poles of the B-Spline.
Knots | Input/output Double that specifies the knots of the B-Spline.
Weights | Input/output Double that specifies the B-spline's weights.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Methods > BSplineCurve2d.GetBSplineData Method


BSplineCurve2d.GetBSplineInfo Method

BSplineCurve2d.GetBSplineInfo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets general information about the definition of the spline, including its order, number of poles and knots, and its rational, periodic, closed, and planar states.

Visual Basic
Sub GetBSplineInfo(ByRef Order As long, ByRef NumPoles As long, ByRef NumKnots As long, ByRef IsRational As VARIANT_BOOL, ByRef IsPeriodic As VARIANT_BOOL, ByRef IsClosed As VARIANT_BOOL)
Parameters
Parameters | Description
Order | Output Long that specifies the order of the spline.
NumPoles | Output Long that specifies the number of poles.
NumKnots | Output Long that specifies the number of knots.
IsRational | Output Boolean that specifies whether the B-Spline is rational.
IsPeriodic | Output Boolean that specifies whether the B-Spline is periodic.
IsClosed | Output Boolean that specifies whether the curve is closed.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Methods > BSplineCurve2d.GetBSplineInfo Method


BSplineCurve2d.PoleAtIndex Method ([in] long, [in] Point2d*)

BSplineCurve2d.PoleAtIndex Method ([in] long, [in] Point2d*) Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates the pole coordinate point at the specified index into the spline's pole vector.

Visual Basic
Sub PoleAtIndex(Index As long, Pole As Point2d)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Methods > BSplineCurve2d.PoleAtIndex Method ([in] long, [in] Point2d*)


BSplineCurve2d.PoleAtIndex Method ([in] long, [out, retval] Point2d**)

BSplineCurve2d.PoleAtIndex Method ([in] long, [out, retval] Point2d**) Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates the pole coordinate point at the specified index into the spline's pole vector.

Visual Basic
Sub PoleAtIndex(Index As long, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the Point to return.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Methods > BSplineCurve2d.PoleAtIndex Method ([in] long, [out, retval] Point2d**)


BSplineCurve2d.PutBSplineInfoAndData Method

BSplineCurve2d.PutBSplineInfoAndData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets the definition data of the spline.

Visual Basic
Sub PutBSplineInfoAndData(Order As long, ByRef Poles As SAFEARRAY(double), ByRef Knots As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double), IsPeriodic As VARIANT_BOOL)
Parameters
Parameters | Description
Order | Input Long array of two elements that specifies the order of the spline in U and V respectively.
Poles | Input/output Double that specifies the poles of the B-Spline.
Knots | Input/output Double that specifies the knots of the B-Spline.
Weights | Input/output Double that specifies the B-spline's weights.
IsPeriodic | Input Boolean that specifies whether the B-Spline is periodic.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Methods > BSplineCurve2d.PutBSplineInfoAndData Method


BSplineCurve2d Properties

BSplineCurve2d Properties
Summary

The properties of the BSplineCurve2d class are listed here.

Properties
Name | Description
Evaluator | Gets the Curve2dEvaluator for this curve.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Properties


BSplineCurve2d.Evaluator Property

BSplineCurve2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Curve2dEvaluator for this curve.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2d Interface > BSplineCurve2d Properties > BSplineCurve2d.Evaluator Property


BSplineCurve2dDefinition Interface

BSplineCurve2dDefinition Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

The BSplineCurve2dDefinition object is a transient object. It is a convenient way to define a spline, perhaps to then create a BSplineCurve2D object. For more information, see the Transient Geometry overview.

Class Hierarchy
Inventor::BSplineCurve2dDefinition
Visual Basic
Public Interface BSplineCurve2dDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateBSplineCurve2dDefinition

You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2dDefinition Interface


BSplineCurve2dDefinition Methods

BSplineCurve2dDefinition Methods
Summary

The methods of the BSplineCurve2dDefinition class are listed here.

Methods
Methods
Name | Description
AddPoint | Method that adds point and its corresponding weight and tangent information to the definition.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2dDefinition Interface > BSplineCurve2dDefinition Methods


BSplineCurve2dDefinition.AddPoint Method

BSplineCurve2dDefinition.AddPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that adds point and its corresponding weight and tangent information to the definition.

Visual Basic
Sub AddPoint(Point As Point2d, ByRef Weight As [defaultvalue(1.0)] double, ByRef Tangent As [optional] VARIANT)
Parameters
Parameters | Description
Point | Input object that specifies the point.
Weight | Optional input double that specifies the weight for the input point. If not specified, a default value of 1 is used.
Tangent | Optional input UnitVector2d object that defines the tangent of the BSpline curve at this point.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2dDefinition Interface > BSplineCurve2dDefinition Methods > BSplineCurve2dDefinition.AddPoint Method


BSplineCurve2dDefinition Properties

BSplineCurve2dDefinition Properties
Summary

The properties of the BSplineCurve2dDefinition class are listed here.

Properties
Name | Description
FitMethod | Property that gets and sets the fit method to be used for spline creation. When the BSplineCurve2dDefinition object is initially created this property is initialized to kSweetSplineFit.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2dDefinition Interface > BSplineCurve2dDefinition Properties


BSplineCurve2dDefinition.FitMethod Property

BSplineCurve2dDefinition.FitMethod Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the fit method to be used for spline creation. When the BSplineCurve2dDefinition object is initially created this property is initialized to kSweetSplineFit.

Visual Basic
Property FitMethod() As SplineFitMethodEnum
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2dDefinition Interface > BSplineCurve2dDefinition Properties > BSplineCurve2dDefinition.FitMethod Property


BSplineCurve2dDefinition.Type Property

BSplineCurve2dDefinition.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurve2dDefinition Interface > BSplineCurve2dDefinition Properties > BSplineCurve2dDefinition.Type Property


BSplineCurveDefinition Interface

BSplineCurveDefinition Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

The BSplineCurveDefinition object is a transient object. It is a convenient way to define a spline, perhaps to then create a BSplineCurve object. For more information, see the Transient Geometry overview.

Class Hierarchy
Inventor::BSplineCurveDefinition
Visual Basic
Public Interface BSplineCurveDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateBSplineCurveDefinition

You are here: Symbol Reference > Inventor Library > Objects > BSplineCurveDefinition Interface


BSplineCurveDefinition Methods

BSplineCurveDefinition Methods
Summary

The methods of the BSplineCurveDefinition class are listed here.

Methods
Methods
Name | Description
AddPoint | Method that adds point and its corresponding weight and tangent information to the definition.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurveDefinition Interface > BSplineCurveDefinition Methods


BSplineCurveDefinition.AddPoint Method

BSplineCurveDefinition.AddPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that adds point and its corresponding weight and tangent information to the definition.

Visual Basic
Sub AddPoint(Point As Point, ByRef Weight As [defaultvalue(1.0)] double, ByRef Tangent As [optional] VARIANT)
Parameters
Parameters | Description
Point | Input object that specifies the point.
Weight | Optional input double that specifies the weight for the input point. If not specified, a default value of 1 is used.
Tangent | Optional input UnitVector object that defines the tangent of the BSpline curve at this point.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurveDefinition Interface > BSplineCurveDefinition Methods > BSplineCurveDefinition.AddPoint Method


BSplineCurveDefinition Properties

BSplineCurveDefinition Properties
Summary

The properties of the BSplineCurveDefinition class are listed here.

Properties
Name | Description
FitMethod | Property that gets and sets the fit method to be used for spline creation. When the BSplineCurveDefinition object is initially created this property is initialized to kSweetSplineFit.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurveDefinition Interface > BSplineCurveDefinition Properties


BSplineCurveDefinition.FitMethod Property

BSplineCurveDefinition.FitMethod Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the fit method to be used for spline creation. When the BSplineCurveDefinition object is initially created this property is initialized to kSweetSplineFit.

Visual Basic
Property FitMethod() As SplineFitMethodEnum
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurveDefinition Interface > BSplineCurveDefinition Properties > BSplineCurveDefinition.FitMethod Property


BSplineCurveDefinition.Type Property

BSplineCurveDefinition.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > BSplineCurveDefinition Interface > BSplineCurveDefinition Properties > BSplineCurveDefinition.Type Property


BSplineSurface Interface

BSplineSurface Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The BSplineSurface object represent a surface curved according to BSpline poles, order, weights, and knots.

Class Hierarchy
Inventor::BSplineSurface
Visual Basic
Public Interface BSplineSurface
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateBSplineSurface

Face.Geometry

FaceDefinition.SurfaceGeometry

You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface


BSplineSurface Methods

BSplineSurface Methods
Summary

The methods of the BSplineSurface class are listed here.

Methods
Methods
Name | Description
GetBSplineData | Get the data defining this B-spline.
GetBSplineInfo | Gets general information about the definition of the spline, including its order, number of poles and knots, and its rational, periodic, closed, and planar states.
PoleAtIndex | Indicates the pole coordinate point at the specified UV indices into the spline's pole array.
PutBSplineInfoAndData | Sets the definition data of the spline surface.
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Methods


BSplineSurface.GetBSplineData Method

BSplineSurface.GetBSplineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this B-spline.

Visual Basic
Sub GetBSplineData(ByRef Poles As SAFEARRAY(double), ByRef KnotsU As SAFEARRAY(double), ByRef KnotsV As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double))
Parameters
Parameters | Description
Poles | Input/output Double that specifies the poles of the B-Spline.
KnotsU | Input/output Double that specifies the knots of the B-Spline in U.
KnotsV | Input/output Double that specifies the knots of the B-Spline in V.
Weights | Input/output Double that specifies the B-spline's weights.
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Methods > BSplineSurface.GetBSplineData Method


BSplineSurface.GetBSplineInfo Method

BSplineSurface.GetBSplineInfo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets general information about the definition of the spline, including its order, number of poles and knots, and its rational, periodic, closed, and planar states.

Visual Basic
Sub GetBSplineInfo(ByRef Order As SAFEARRAY(long), ByRef NumPoles As SAFEARRAY(long), ByRef NumKnots As SAFEARRAY(long), ByRef IsRational As VARIANT_BOOL, ByRef IsPeriodic As SAFEARRAY(VARIANT_BOOL), ByRef IsClosed As SAFEARRAY(VARIANT_BOOL), ByRef IsPlanar As VARIANT_BOOL, ByRef PlaneVector As SAFEARRAY(double))
Parameters
Parameters | Description
Order | Input Long array of two elements that specifies the order of the spline in U and V respectively.
NumPoles | Input/output Long that specifies the number of poles.
NumKnots | Input/output array of Longs that specifies the number of knots.
IsRational | Output Boolean that specifies whether the B-Spline is rational.
IsPeriodic | Input/Output Boolean that specifies whether the B-Spline is periodic.
IsClosed | Input/Output Boolean that specifies whether the curve is closed.
IsPlanar | Output Boolean that specifies whether the B-Spline is planar.
PlaneVector | Output Double that specifies the B-Spline's plane vector.
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Methods > BSplineSurface.GetBSplineInfo Method


BSplineSurface.PoleAtIndex Method

BSplineSurface.PoleAtIndex Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates the pole coordinate point at the specified UV indices into the spline's pole array.

Visual Basic
Sub PoleAtIndex(IndexU As long, IndexV As long, Result As [out, retval] Point*)
Parameters
Parameters | Description
IndexU | Input Long that specifies the U index into the spline's pole array.
IndexV | Input Long that specifies the V index into the spline's pole array.
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Methods > BSplineSurface.PoleAtIndex Method


BSplineSurface.PutBSplineInfoAndData Method

BSplineSurface.PutBSplineInfoAndData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets the definition data of the spline surface.

Visual Basic
Sub PutBSplineInfoAndData(ByRef Order As SAFEARRAY(long), ByRef Poles As SAFEARRAY(double), ByRef KnotsU As SAFEARRAY(double), ByRef KnotsV As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double), ByRef IsPeriodic As SAFEARRAY(VARIANT_BOOL))
Parameters
Parameters | Description
Order | Input Long array of two elements that specifies the order of the spline in U and V respectively.
Poles | Input/output Double that specifies the poles of the B-Spline.
KnotsU | Input/output Double that specifies the knots of the B-Spline in U.
KnotsV | Input/output Double that specifies the knots of the B-Spline in V.
Weights | Input/output Double that specifies the B-spline's weights.
IsPeriodic | Input/Output Boolean that specifies whether the B-Spline is periodic.
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Methods > BSplineSurface.PutBSplineInfoAndData Method


BSplineSurface Properties

BSplineSurface Properties
Summary

The properties of the BSplineSurface class are listed here.

Properties
Name | Description
Evaluator | Gets the surface evaluator for this surface.
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Properties


BSplineSurface.Evaluator Property

BSplineSurface.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this surface.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > BSplineSurface Interface > BSplineSurface Properties > BSplineSurface.Evaluator Property


ButtonDefinition CoClass

ButtonDefinition CoClass Available in Inventor Introduced in Inventor 6
Summary

The ButtonDefinition object represents any command whose user interface is a button.

Class Hierarchy
Inventor::ButtonDefinition
Visual Basic
Public Class ButtonDefinition
Remarks

The ButtonDefinition object does not represent the button, but instead represents the command. The button itself is represented by a CommandBarControl. One or more controls can reference a single ButtonDefinition. The ButtonDefinition object is derived from the ControlDefinition object. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ControlDefinitions.AddButtonDefinition

See Also

Creation of an override environment for a document sample

Adding commands to the application menu sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinition CoClass


ButtonDefinitionObject Interface

ButtonDefinitionObject Interface Available in Inventor Introduced in Inventor 6
Summary

The ButtonDefinition object represents any command whose user interface is a button.

Class Hierarchy
Inventor::ControlDefinition
    Inventor::ButtonDefinitionObject
Visual Basic
Public Interface ButtonDefinitionObject
Inherits ControlDefinition
Remarks

The ButtonDefinition object does not represent the button, but instead represents the command. The button itself is represented by a CommandBarControl. One or more controls can reference a single ButtonDefinition. The ButtonDefinition object is derived from the ControlDefinition object. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionObject Interface


ButtonDefinitionObject Properties

ButtonDefinitionObject Properties
Summary

The properties of the ButtonDefinitionObject class are listed here.

Properties
Name | Description
Pressed | Property that indicates whether the corresponding control is depressed. This property fails for built-in definitions (see the BuiltIn property).
You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionObject Interface > ButtonDefinitionObject Properties


ButtonDefinitionObject.Pressed Property

ButtonDefinitionObject.Pressed Property
Summary

Property that indicates whether the corresponding control is depressed. This property fails for built-in definitions (see the BuiltIn property).

Visual Basic
Property Pressed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionObject Interface > ButtonDefinitionObject Properties > ButtonDefinitionObject.Pressed Property


ButtonDefinitionSink Interface

ButtonDefinitionSink Interface
Summary

The ButtonDefinition object represents any command whose user interface is a button.

Class Hierarchy
Inventor::ButtonDefinitionSink
Visual Basic
Public Interface ButtonDefinitionSink
Inherits IDispatch
Remarks

The ButtonDefinition object does not represent the button, but instead represents the command. The button itself is represented by a CommandBarControl. One or more controls can reference a single ButtonDefinition. The ButtonDefinition object is derived from the ControlDefinition object. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionSink Interface


ButtonDefinitionSink Methods

ButtonDefinitionSink Methods
Summary

The methods of the ButtonDefinitionSink class are listed here.

Methods
Methods
Name | Description
OnExecute | Event that fires when the ButtonDefinition is executed.
OnHelp | Event that is fired when the user selects F1 while the progressive tooltip of this command is being displayed in the ribbon interface.
You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionSink Interface > ButtonDefinitionSink Methods


ButtonDefinitionSink.OnExecute Method

ButtonDefinitionSink.OnExecute Method
Summary

Event that fires when the ButtonDefinition is executed.

Visual Basic
Sub OnExecute(Context As NameValueMap)
Parameters
Parameters | Description
Context | Input object that can be used to determine the context of why the event fired.
You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionSink Interface > ButtonDefinitionSink Methods > ButtonDefinitionSink.OnExecute Method


ButtonDefinitionSink.OnHelp Method

ButtonDefinitionSink.OnHelp Method
Summary

Event that is fired when the user selects F1 while the progressive tooltip of this command is being displayed in the ribbon interface.

Visual Basic
Sub OnHelp(Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. Setting the value of the HandlingCode argument specifies how Inventor is to handle displaying help. If you set this argument to kEventNotHandled or kEventCanceled, Inventor will display some general help. Setting the value of this argument to kEventHandled will allow you to handle displaying help to the end-user and Inventor will not display anything. To display help to the end-user you can choose to use whatever help system you want. Inventor's API does not provide support for the actual display of the clients help.
You are here: Symbol Reference > Inventor Library > Objects > ButtonDefinitionSink Interface > ButtonDefinitionSink Methods > ButtonDefinitionSink.OnHelp Method


Camera Interface

Camera Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Camera defines the view of the model shown within the window.

Class Hierarchy
Inventor::Camera
Visual Basic
Public Interface Camera
Inherits IDispatch
Remarks

The Camera is analogous to a real-world camera. You can define its position in space, the direction in which it is pointed and how it is tipped. You can also control the type of lens by setting the perspective angle. Each time the Camera property of the View is used a new Camera object is returned. The Camera object returned contains the current camera settings of the view. This is important to understand because changing the camera may not behave as expected. For example the following code will result in no changes to the view contents.

Dim oView As View
Set oView = ThisApplication.ActiveView
oView.Camera.ViewOrientationType = kIsoTopRightViewOrientation
oView.Camera.Apply

The reason this doesn't result in changing the contents of the view is because the Apply is called on a camera that hasn't been changed from the current view. In this example, a new Camera is returned for the third and fourth lines. The view orientation is set on a camera and then the Apply is called on a different camera. The following code will create the desired result.

Dim oView As View
Set oView = ThisApplication.ActiveView
Dim oCamera As Camera
Set oCamera = oView.Camera
oCamera.ViewOrientationType = kIsoTopRightViewOrientation
oCamera.Apply

In this case a Camera object is obtained and this single object is used to set the view orientation and apply the changes to the view.

Notes

Members through which this object may be accessed include:

ClientView.Camera

DrawingView.Camera

View.Camera

See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > Camera Interface


Camera Methods

Camera Methods
Summary

The methods of the Camera class are listed here.

Methods
Methods
Name | Description
Apply | Method that causes the changes made to the Camera object to be applied to the actual camera of the view. This will also cause the view to update.
ApplyWithoutTransition | Method that applies the current camera to the View without transition.
ComputeWithMouseInput | Method that changes the view according mouse movement and view operation.
CreateImage | Method that creates an image based on the current camera view.
Fit | Method that fits all the contents of the Document into the view.
GetExtents | Method that gets the current extents of the camera. The camera extents define the area within the model that is visible in the view.
ModelToViewSpace | Method that converts a point in model space to the equivalent point on the view.
SaveAsBitmap | Method that saves the current camera view to the specified file.
SetExtents | Method that sets the current extents of the camera. The camera extents define the area within the model that is visible in the view. Setting the extents results in the camera zooming in or out. The Apply method of the camera must be called before any changes are shown in the view.
ViewToModelSpace | Method that converts a point in view space to the equivalent point in the model.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods


Camera.Apply Method

Camera.Apply Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that causes the changes made to the Camera object to be applied to the actual camera of the view. This will also cause the view to update.

Visual Basic
Sub Apply()
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.Apply Method


Camera.ApplyWithoutTransition Method

Camera.ApplyWithoutTransition Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that applies the current camera to the View without transition.

Visual Basic
Sub ApplyWithoutTransition()
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.ApplyWithoutTransition Method


Camera.ComputeWithMouseInput Method

Camera.ComputeWithMouseInput Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that changes the view according mouse movement and view operation.

Visual Basic
Sub ComputeWithMouseInput(FromPoint As Point2d, ToPoint As Point2d, WheelDelta As long, ViewOperation As ViewOperationTypeEnum)
Parameters
Parameters | Description
FromPoint | Input point that specifies the starting point from which to move the view.
ToPoint | Input point that specifies the destination to which to move the view.
ViewOperation | Input constant that specifies the type of view operation (pan, rotate, or zoom).
wheelDelta | Input Long that specifies the number of clicks (to zoom in or out) that have been made with the center mouse wheel. The WheelDelta is for the middle button wheel on the mouse. We use that for zoom in/out. The WheelDelta should represent the number of clicks that have been made with the wheel.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.ComputeWithMouseInput Method


Camera.CreateImage Method

Camera.CreateImage Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates an image based on the current camera view.

Visual Basic
Sub CreateImage(Width As long, Height As long, ByRef topColor As [optional] VARIANT, ByRef bottomColor As [optional] VARIANT, Result As [out, retval] IPictureDisp*)
Parameters
Parameters | Description
Width | Specifies the number of horizontal pixels in the output image.
Height | Specifies the number of vertical pixels in the output image.
topColor | Optional argument that specifies the background color at the top of the image. If a bottom background color is supplied, then the background will be a gradient between the top and bottom colors. If only a top background color is supplied, the background will be a solid color using this color. If no color is defined a default color will be used.
bottomColor | Optional argument that specified the background color at the bottom of the image. This argument is only valid when the TopBackgroundColor argument has been supplied. This argument defines the color of the background at the bottom of the image and a gradient background is created that varies from the top color to the bottom color.
Remarks

The width and height arguments define the aspect ratio and the number of pixels in the output image. The resulting image is passed back as the return value as an IPictureDisp object. This is similar to the SaveAsBitmap method except it creates the image in memory instead of writing it to disk, which is more efficient if you need to immediately use the image.

You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.CreateImage Method


Camera.Fit Method

Camera.Fit Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that fits all the contents of the Document into the view.

Visual Basic
Sub Fit()
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.Fit Method


Camera.GetExtents Method

Camera.GetExtents Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that gets the current extents of the camera. The camera extents define the area within the model that is visible in the view.

Visual Basic
Sub GetExtents(ByRef Width As double, ByRef Height As double)
Parameters
Parameters | Description
width | Output Double that is the current width of the volume of the model shown within the view. For perspective views, the width is determined at the target point. The value is in centimeters.
height | Output Double that is the current height of the volume of the model shown within the view. For perspective views, the height is determined at the target point. The value is in centimeters.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.GetExtents Method


Camera.ModelToViewSpace Method

Camera.ModelToViewSpace Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that converts a point in model space to the equivalent point on the view.

Visual Basic
Sub ModelToViewSpace(ModelCoordinate As Point, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
ModelCoordinate | Input model space point to convert to view space.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.ModelToViewSpace Method


Camera.SaveAsBitmap Method

Camera.SaveAsBitmap Method Available in Inventor Introduced in Inventor 2012
Summary

Method that saves the current camera view to the specified file.

Visual Basic
Sub SaveAsBitmap(FullFilename As String, Width As long, Height As long, ByRef topColor As [optional] VARIANT, ByRef bottomColor As [optional] VARIANT)
Parameters
Parameters | Description
FullFilename | The full filename (path and filename) of the bitmap to create. The type of image file to create is implied based on the extension of the filename. Valid extensions are bmp, jpg, png, tiff, and gif.
Width | Specifies the number of horizontal pixels in the output image.
Height | Specifies the number of vertical pixels in the output image.
topColor | Optional argument that specifies the background color at the top of the image. If a bottom background color is supplied, then the background will be a gradient between the top and bottom colors. If only a top background color is supplied, the background will be a solid color using this color. If no color is defined a default color will be used.
bottomColor | Optional argument that specified the background color at the bottom of the image. This argument is only valid when the TopBackgroundColor argument has been supplied. This argument defines the color of the background at the bottom of the image and a gradient background is created that varies from the top color to the bottom color.
Remarks

The width and height arguments define the aspect ratio and the number of pixels in the output image.

The CreateImage method is similar to this but instead of writing the image to a file it creates it in memory, which is more efficient than writing and reading if from disk if you need to use the image immediately.

You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.SaveAsBitmap Method


Camera.SetExtents Method

Camera.SetExtents Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that sets the current extents of the camera. The camera extents define the area within the model that is visible in the view. Setting the extents results in the camera zooming in or out. The Apply method of the camera must be called before any changes are shown in the view.

Visual Basic
Sub SetExtents(Width As double, Height As double)
Parameters
Parameters | Description
width | Input Double that specifies the new width of the volume of the model to display within the view. For perspective views, the width is specified at the target point. The value is in centimeters.
height | Input Double that specifies the new height of the volume of the model to display within the view. For perspective views, the height is specified at the target point. The value is in centimeters.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.SetExtents Method


Camera.ViewToModelSpace Method

Camera.ViewToModelSpace Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that converts a point in view space to the equivalent point in the model.

Visual Basic
Sub ViewToModelSpace(ViewCoordinate As Point2d, Result As [out, retval] Point*)
Parameters
Parameters | Description
ViewCoordinate | Input view point to convert to model space.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Methods > Camera.ViewToModelSpace Method


Camera Properties

Camera Properties
Summary

The properties of the Camera class are listed here.

Properties
Name | Description
Eye | Property that gets and sets the position of the camera. The 'Eye' is the position of the viewer. The Apply method of the camera must be called before any changes are shown in the view.
Parent | Property that returns the parent object of the camera.
Perspective | Property that gets and sets whether the camera defines a perspective or parallel view. A value of True indicates the camera defines a perspective view. The Apply method of the camera must be called before any changes are shown in the view.
PerspectiveAngle | Property gets and sets the perspective angle. The angle is defined in radians. The Apply method of the camera must be called before any changes are shown in the view.
SceneObject | Property that specifies what defines the contents of the scene for a camera.
Target | Property gets and sets the target point of the camera. The target defines where the camera is pointed. The Apply method of the camera must be called before any changes are shown in the view.
Type | Property returning an enum indicating this object's type.
UpVector | Property gets and sets the up vector of the camera. Setting the up vector does not change the eye or target points, but rotates the camera about the vector defined by the eye and target points. The Apply method of the camera must be called before any changes are shown in the view.
ViewOrientationType | Property gets and sets position of the camera. This property is used as a convenience for setting the camera to show one of several standard views. Setting this property results in the eye, target, up vector, and extents to be changed.
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties


Camera.Eye Property

Camera.Eye Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the position of the camera. The 'Eye' is the position of the viewer. The Apply method of the camera must be called before any changes are shown in the view.

Visual Basic
Property Eye() As Point*
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.Eye Property


Camera.Parent Property

Camera.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object of the camera.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.Parent Property


Camera.Perspective Property

Camera.Perspective Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the camera defines a perspective or parallel view. A value of True indicates the camera defines a perspective view. The Apply method of the camera must be called before any changes are shown in the view.

Visual Basic
Property Perspective() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.Perspective Property


Camera.PerspectiveAngle Property

Camera.PerspectiveAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property gets and sets the perspective angle. The angle is defined in radians. The Apply method of the camera must be called before any changes are shown in the view.

Visual Basic
Property PerspectiveAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.PerspectiveAngle Property


Camera.SceneObject Property

Camera.SceneObject Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies what defines the contents of the scene for a camera.

Visual Basic
Property SceneObject() As IDispatch*
Remarks

After using the TransientObjects.CreateCamera method to create a camera you use this property to define what the camera is viewing. Valid input is a component definition (PartComponentDefinition, AssemblyComponentDefinition, or SheetMetalComponentDefinition) or a drawing Sheet object. This property can return any of the above objects and also a View object in the case where this camera is associated with a standard Inventor View. In the case where the camera is associated to a view, it cannot be set and setting this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.SceneObject Property


Camera.Target Property

Camera.Target Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property gets and sets the target point of the camera. The target defines where the camera is pointed. The Apply method of the camera must be called before any changes are shown in the view.

Visual Basic
Property Target() As Point*
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.Target Property


Camera.Type Property

Camera.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.Type Property


Camera.UpVector Property

Camera.UpVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property gets and sets the up vector of the camera. Setting the up vector does not change the eye or target points, but rotates the camera about the vector defined by the eye and target points. The Apply method of the camera must be called before any changes are shown in the view.

Visual Basic
Property UpVector() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.UpVector Property


Camera.ViewOrientationType Property

Camera.ViewOrientationType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property gets and sets position of the camera. This property is used as a convenience for setting the camera to show one of several standard views. Setting this property results in the eye, target, up vector, and extents to be changed.

Visual Basic
Property ViewOrientationType() As ViewOrientationTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Camera Interface > Camera Properties > Camera.ViewOrientationType Property


CameraEventsObject Interface

CameraEventsObject Interface
Summary

The CameraEvents object supports a set of properties and events used to work with a camera object.

Class Hierarchy
Inventor::CameraEventsObject
Visual Basic
Public Interface CameraEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > CameraEventsObject Interface


CameraEventsObject Properties

CameraEventsObject Properties
Summary

The properties of the CameraEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the logical parent object of this object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CameraEventsObject Interface > CameraEventsObject Properties


CameraEventsObject.Application Property

CameraEventsObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CameraEventsObject Interface > CameraEventsObject Properties > CameraEventsObject.Application Property


CameraEventsObject.Parent Property

CameraEventsObject.Parent Property
Summary

Property that returns the logical parent object of this object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CameraEventsObject Interface > CameraEventsObject Properties > CameraEventsObject.Parent Property


CameraEventsObject.Type Property

CameraEventsObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CameraEventsObject Interface > CameraEventsObject Properties > CameraEventsObject.Type Property


CameraEventsSink Interface

CameraEventsSink Interface
Summary

The CameraEvents object supports a set of properties and events used to work with a camera object.

Class Hierarchy
Inventor::CameraEventsSink
Visual Basic
Public Interface CameraEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > CameraEventsSink Interface


CameraEventsSink Methods

CameraEventsSink Methods
Summary

The methods of the CameraEventsSink class are listed here.

Methods
Methods
Name | Description
OnCameraChange | Event that fires when the camera of a view has been modified but before the view has been updated. You can modify client graphics in response to this event and the modified client graphics will be drawn when the view is updated.
You are here: Symbol Reference > Inventor Library > Objects > CameraEventsSink Interface > CameraEventsSink Methods


CameraEventsSink.OnCameraChange Method

CameraEventsSink.OnCameraChange Method
Summary

Event that fires when the camera of a view has been modified but before the view has been updated. You can modify client graphics in response to this event and the modified client graphics will be drawn when the view is updated.

Visual Basic
Sub OnCameraChange(view As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap)
Parameters
Parameters | Description
view | The View object that is updating because of its associated camera has changed.
BeforeOrAfter | This notification is only provided after the camera has changed so the value of this argument will always be kAfter.
Context | Input object that can be used to determine the context of why the event fired. No context information is currently provided for this event.
You are here: Symbol Reference > Inventor Library > Objects > CameraEventsSink Interface > CameraEventsSink Methods > CameraEventsSink.OnCameraChange Method


Cell Interface

Cell Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Cell object represents an individual cell in the table. A cell is the intersection between a column and a row.

See the Custom Tables article in the overviews section for more information.

Class Hierarchy
Inventor::Cell
Visual Basic
Public Interface Cell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Row.Item

See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > Cell Interface


Cell Properties

Cell Properties
Summary

The properties of the Cell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent Table object.
Static | Property that specifies the whether or not the contents of this cell are static. This property only applies when the table is linked to a data source file and always returns False otherwise. The contents of a static cell are not updated when the table is updated. Also, when the value of a cell is overridden, the cell is marked as static.
Type | Property returning an enum indicating this object's type.
Value | Property that gets and sets the value of the cell.
You are here: Symbol Reference > Inventor Library > Objects > Cell Interface > Cell Properties


Cell.Application Property

Cell.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Cell Interface > Cell Properties > Cell.Application Property


Cell.Parent Property

Cell.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent Table object.

Visual Basic
Property Parent() As CustomTable**
You are here: Symbol Reference > Inventor Library > Objects > Cell Interface > Cell Properties > Cell.Parent Property


Cell.Static Property

Cell.Static Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the whether or not the contents of this cell are static. This property only applies when the table is linked to a data source file and always returns False otherwise. The contents of a static cell are not updated when the table is updated. Also, when the value of a cell is overridden, the cell is marked as static.

Visual Basic
Property Static() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Cell Interface > Cell Properties > Cell.Static Property


Cell.Type Property

Cell.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Cell Interface > Cell Properties > Cell.Type Property


Cell.Value Property

Cell.Value Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the value of the cell.

Visual Basic
Property Value() As String
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > Cell Interface > Cell Properties > Cell.Value Property


CenteredWidthExtent Interface

CenteredWidthExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CenteredWidthExtent is used by sheet metal features when the width of the feature is defined using an explicit width and the width is centered along the selected edge.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::CenteredWidthExtent
Visual Basic
Public Interface CenteredWidthExtent
Inherits PartFeatureExtent
Remarks

This object is obtained from an existing sheet metal feature object whose width is defined as a 'Width' extent and the type is 'Centered'. The various properties of this object can be used to query and edit the width of an existing feature.

You are here: Symbol Reference > Inventor Library > Objects > CenteredWidthExtent Interface


CenteredWidthExtent Properties

CenteredWidthExtent Properties
Summary

The properties of the CenteredWidthExtent class are listed here.

Properties
Name | Description
Edge | Property that gets the Edge object that the width is defined relative to.
Width | Property that returns the parameter controlling the width of the flange.
You are here: Symbol Reference > Inventor Library > Objects > CenteredWidthExtent Interface > CenteredWidthExtent Properties


CenteredWidthExtent.Edge Property

CenteredWidthExtent.Edge Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the Edge object that the width is defined relative to.

Visual Basic
Property Edge() As Edge**
Remarks

This is the same edge that was selected to create the feature. When querying an existing feature this edge is not available because it was consumed when the sheet metal feature was created. This property returns Nothing in the case where the edge no longer exists in the model. Because of this, the end-of-part marker must be placed above the feature to allow access this edge.

You are here: Symbol Reference > Inventor Library > Objects > CenteredWidthExtent Interface > CenteredWidthExtent Properties > CenteredWidthExtent.Edge Property


CenteredWidthExtent.Width Property

CenteredWidthExtent.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter controlling the width of the flange.

Visual Basic
Property Width() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > CenteredWidthExtent Interface > CenteredWidthExtent Properties > CenteredWidthExtent.Width Property


Centerline Interface

Centerline Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The Centerline object represents a centerline on a sheet.

Class Hierarchy
Inventor::Centerline
Visual Basic
Public Interface Centerline
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Centerlines.Add

Centerlines.AddBisector

Centerlines.AddByWorkFeature

Centerlines.AddCenteredPattern

Centerlines.Item

You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface


Centerline Methods

Centerline Methods
Summary

The methods of the Centerline class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the Centerline.
GetBisectorEntities | Returns the two entities that the centerline bisects. This method is only valid for kBisectorCenterline type centerlines and will fail in all other cases.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Methods


Centerline.Delete Method

Centerline.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes the Centerline.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Methods > Centerline.Delete Method


Centerline.GetBisectorEntities Method

Centerline.GetBisectorEntities Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns the two entities that the centerline bisects. This method is only valid for kBisectorCenterline type centerlines and will fail in all other cases.

Visual Basic
Sub GetBisectorEntities(ByRef EntityOne As GeometryIntent*, ByRef EntityTwo As GeometryIntent*)
Parameters
Parameters | Description
EntityOne | Output GeometryIntent object that provides the first entity.
EntityTwo | Output GeometryIntent object that provides the second entity.
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Methods > Centerline.GetBisectorEntities Method


Centerline.GetReferenceKey Method

Centerline.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Methods > Centerline.GetReferenceKey Method


Centerline Properties

Centerline Properties
Summary

The properties of the Centerline class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Attached | Property that returns whether the centerline is sick. Returns False if the centerline is sick.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
CenterlineType | Property that gets the centerline type. This could return kRegularCenterline, kBisectorCenterline, kCenteredPatternCenterline or kWorkFeatureCenterline. If the property returns kWorkFeatureCenterline, the centerline is associated with a model work feature. The work feature can be obtained using the ModelWorkFeature property.
EndPoint | Property that gets and sets the end point of the centerline.
FitPoints | Property that returns the collection of objects that define the path of the centerline.
Geometry | Property that returns the geometry that defines the shape of the centerline object.
GeometryType | Property that returns the type of the curve used to define the centerline. This property allows you to determine what type of object will be returned by the Geometry.
Layer | Property that gets and sets the layer associated with this object.
ModelWorkFeature | Property that returns the model work feature associated with this centerline. This property returns Nothing if the CenterlineType property is not kWorkFeatureCenterline.
Parent | Property that returns the parent Sheet object.
PatternCenter | Property that returns the geometry the center that defines the center of the centerline pattern. This property is only valid for kCenteredPatternCenterline type centerlines and will return Nothing in all other cases.
StartPoint | Property that gets and sets the start point of the centerline.
Style | Property that gets and sets the style associated with this centerline.
Type | Property returning kCenterlineObject indicating this objects type.
Visible | Property that gets and sets whether the centerline is visible.
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties


Centerline.Application Property

Centerline.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Application Property


Centerline.Attached Property

Centerline.Attached Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the centerline is sick. Returns False if the centerline is sick.

Visual Basic
Property Attached() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Attached Property


Centerline.AttributeSets Property

Centerline.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.AttributeSets Property


Centerline.CenterlineType Property

Centerline.CenterlineType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets the centerline type. This could return kRegularCenterline, kBisectorCenterline, kCenteredPatternCenterline or kWorkFeatureCenterline. If the property returns kWorkFeatureCenterline, the centerline is associated with a model work feature. The work feature can be obtained using the ModelWorkFeature property.

Visual Basic
Property CenterlineType() As CenterlineTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.CenterlineType Property


Centerline.EndPoint Property

Centerline.EndPoint Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the end point of the centerline.

Visual Basic
Property EndPoint() As Point2d*
Remarks

There are three different types of object that can be returned. A Centermark is returned in the case where the centerline is associated to a center mark. A GeometryIntent object is returned in the case where the centerline is associated to geometry in a view or sketch. A Point2d object is returned to indicated the location in the case where the centerline is not associated to any object. The points returned are in order along the centerline starting at the start point.

You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.EndPoint Property


Centerline.FitPoints Property

Centerline.FitPoints Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of objects that define the path of the centerline.

Visual Basic
Property FitPoints() As ObjectsEnumerator**
Remarks

There are three different types of object that can be returned. A Centermark is returned in the case where the centerline is associated to a center mark. A GeometryIntent object is returned in the case where the centerline is associated to geometry in a view or sketch. A Point2d object is returned to indicated the location in the case where the centerline is not associated to any object. The points returned are in order along the centerline starting at the start point.

You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.FitPoints Property


Centerline.Geometry Property

Centerline.Geometry Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the geometry that defines the shape of the centerline object.

Visual Basic
Property Geometry() As IDispatch**
Remarks

The object returned represents a snapshot view of the current state of the centerline. This can return a LineSegment2d, Arc2d, Circle2d, or Polyline2d object. The type that will be returned can be determined using the GeometryType property. Each of these types is illustrated in the examples below.

You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Geometry Property


Centerline.GeometryType Property

Centerline.GeometryType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the type of the curve used to define the centerline. This property allows you to determine what type of object will be returned by the Geometry.

Visual Basic
Property GeometryType() As CurveTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.GeometryType Property


Centerline.Layer Property

Centerline.Layer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Layer Property


Centerline.ModelWorkFeature Property

Centerline.ModelWorkFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the model work feature associated with this centerline. This property returns Nothing if the CenterlineType property is not kWorkFeatureCenterline.

Visual Basic
Property ModelWorkFeature() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.ModelWorkFeature Property


Centerline.Parent Property

Centerline.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent Sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Parent Property


Centerline.PatternCenter Property

Centerline.PatternCenter Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the geometry the center that defines the center of the centerline pattern. This property is only valid for kCenteredPatternCenterline type centerlines and will return Nothing in all other cases.

Visual Basic
Property PatternCenter() As GeometryIntent**
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.PatternCenter Property


Centerline.StartPoint Property

Centerline.StartPoint Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the start point of the centerline.

Visual Basic
Property StartPoint() As Point2d*
Remarks

The position of the start point is partially defined by the geometry the centerline is associated with. Setting this property just changes the length of the start of the centerline. If the input point is not along the centerline or its extension, the point is projected onto the centerline to define the new start point position.

It's possible that this property can return nothing in the case where the centerline has been clipped as the result of a broken view and the start point is not visible in the view.

You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.StartPoint Property


Centerline.Style Property

Centerline.Style Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the style associated with this centerline.

Visual Basic
Property Style() As CentermarkStyle*
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Style Property


Centerline.Type Property

Centerline.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kCenterlineObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Type Property


Centerline.Visible Property

Centerline.Visible Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the centerline is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Centerline Interface > Centerline Properties > Centerline.Visible Property


Centerlines Interface

Centerlines Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The Centerlines collection object provides access to all the centerlines on a sheet.

Class Hierarchy
Inventor::Centerlines
Visual Basic
Public Interface Centerlines
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.Centerlines

You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface


Centerlines Methods

Centerlines Methods
Summary

The methods of the Centerlines class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new centerline. The centerline created with this method is kRegularCenterline type.
AddBisector | Method that creates a new bisector centerline. The centerline created with this method is kBisectorCenterline type.
AddByWorkFeature | Method that creates a center line that represents the work feature within the drawing view.
AddCenteredPattern | Method that creates a new centerline pattern. The centerline created with this method is kCenteredPatternCenterline type.
Item | Method that returns the specified Centerline object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Methods


Centerlines.Add Method

Centerlines.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new centerline. The centerline created with this method is kRegularCenterline type.

Visual Basic
Sub Add(CenterEntities As ObjectCollection, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, ByRef Closed As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] Centerline*)
Parameters
Parameters | Description
CenterEntities | Input ObjectCollection object that contains the set of entities that define the points the centerline passes through. Valid objects for input are GeometryIntent objects that reference circular or elliptical drawing curves, GeometryIntent objects that reference the end or midpoint of linear drawing curves, and center marks. Providing two points will result in a linear centerline. Providing three points will result in a circular centerline. Providing more than three points will result in a linear or a circular centerline depending on whether all of the input points lie on a circle.
CenterMarkStyle | Object that specifies the center mark style to use for the centerline. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the centerline. If not specified, the layer defined by the active standard is used.
Closed | Input Boolean that is only used in the case of a circular centerline. This indicates if it should be closed or not.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Methods > Centerlines.Add Method


Centerlines.AddBisector Method

Centerlines.AddBisector Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new bisector centerline. The centerline created with this method is kBisectorCenterline type.

Visual Basic
Sub AddBisector(EntityOne As GeometryIntent, EntityTwo As GeometryIntent, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] Centerline*)
Parameters
Parameters | Description
EntityOne | Input GeometryIntent that defines the first entity to bisect. This can be a line or a circular entity.
EntityTwo | Input GeometryIntent that defines the second entity to bisect. If the first entity was a line then this must also be a line. If the first entity was a circular entity then this must be a circular entity that is concentric to the first entity.
CenterMarkStyle | Object that specifies the center mark style to use for the centerline. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the centerline. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Methods > Centerlines.AddBisector Method


Centerlines.AddByWorkFeature Method

Centerlines.AddByWorkFeature Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a center line that represents the work feature within the drawing view.

Visual Basic
Sub AddByWorkFeature(WorkFeature As IDispatch, DrawingView As DrawingView, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] Centerline*)
Parameters
Parameters | Description
WorkFeature | Specifies the work feature to create the center line for. This can be a WorkAxis or WorkPlane object. In the case of a WorkPlane object, the work plane must be oriented so it is perpendicular to the plane of the sheet, (only the edge of the work plane is visible within that view). If an work plane is provided that does not meet this criteria the method will fail. When working with an assembly the input WorkAxis or WorkPlane must always be with respect to the top-level. This means that work points or axes that exist within the parts or sub-assemblies must be represented by WorkAxisProxy or WorkPlaneProxy objects.
DrawingView | Specifies the drawing view to create the centerline within.
CenterMarkStyle | Object that specifies the center mark style to use for the centerline. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the centerline. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Methods > Centerlines.AddByWorkFeature Method


Centerlines.AddCenteredPattern Method

Centerlines.AddCenteredPattern Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new centerline pattern. The centerline created with this method is kCenteredPatternCenterline type.

Visual Basic
Sub AddCenteredPattern(PatternCenter As GeometryIntent, CenterEntities As ObjectCollection, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, ByRef Closed As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] Centerline*)
Parameters
Parameters | Description
PatternCenter | Input GeometryIntent that defines the a circular or elliptical drawing curve that defines the center of the pattern.
CenterEntities | Input ObjectCollection object that contains the set of entities that define the points the centerline passes through. Valid objects for input are GeometryIntent objects that reference circular or elliptical drawing curves, and center marks.
CenterMarkStyle | Object that specifies the center mark style to use for the centerline. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the centerline. If not specified, the layer defined by the active standard is used.
Closed | Input Boolean that indicates if the centerline should be closed or not.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Methods > Centerlines.AddCenteredPattern Method


Centerlines.Item Method

Centerlines.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the specified Centerline object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Centerline*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Methods > Centerlines.Item Method


Centerlines Properties

Centerlines Properties
Summary

The properties of the Centerlines class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kCenterlinesObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Properties


Centerlines.Application Property

Centerlines.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Properties > Centerlines.Application Property


Centerlines.Count Property

Centerlines.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Properties > Centerlines.Count Property


Centerlines.Type Property

Centerlines.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kCenterlinesObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Centerlines Interface > Centerlines Properties > Centerlines.Type Property


Centermark Interface

Centermark Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The Centermark object represents a center mark on a sheet.

Class Hierarchy
Inventor::Centermark
Visual Basic
Public Interface Centermark
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Centermarks.Add

Centermarks.AddByCenterOfGravity

Centermarks.AddByWorkFeature

Centermarks.Item

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface


Centermark Methods

Centermark Methods
Summary

The methods of the Centermark class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the Centermark.
GetReferenceKey | Method that generates and returns the reference key for this entity.
ModelWorkFeature | Property that returns the model work feature associated with this center mark. This property returns Nothing if the CentermarkType property is not kWorkFeatureCentermark.
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Methods


Centermark.Delete Method

Centermark.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes the Centermark.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Methods > Centermark.Delete Method


Centermark.GetReferenceKey Method

Centermark.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Methods > Centermark.GetReferenceKey Method


Centermark.ModelWorkFeature Method

Centermark.ModelWorkFeature Method Available in Inventor Available in Server
Summary

Property that returns the model work feature associated with this center mark. This property returns Nothing if the CentermarkType property is not kWorkFeatureCentermark.

Visual Basic
Sub ModelWorkFeature(Result As [out, retval] IDispatch*)
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Methods > Centermark.ModelWorkFeature Method


Centermark Properties

Centermark Properties
Summary

The properties of the Centermark class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Attached | Property that returns whether the centermark is sick. Returns False if the centermark is sick.
AttachedEntity | Property that returns the entity the center mark is associated with.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Centerlines | Property that returns the a collection of associated Centerline objects.
CentermarkType | Property that gets the centermark type.
ExtensionLinesVisible | Property that gets and sets whether the extension lines associated with this center mark are visible or not.
ExtensionPointFour | Property that gets and sets the position of the center mark extension point.
ExtensionPointFourDirection | Property that returns the direction of the extension point. This can be used to understand the direction the fourth extension point can be moved.
ExtensionPointOne | Property that gets and sets the position of the center mark extension point.
ExtensionPointOneDirection | Property that returns the direction of the extension point. This can be used to understand the direction the first extension point can be moved.
ExtensionPointThree | Property that gets and sets the position of the center mark extension point.
ExtensionPointThreeDirection | Property that returns the direction of the extension point. This can be used to understand the direction the third extension point can be moved.
ExtensionPointTwo | Property that gets and sets the position of the center mark extension point.
ExtensionPointTwoDirection | Property that returns the direction of the extension point. This can be used to understand the direction the second extension point can be moved.
Layer | Property that gets and sets the layer associated with this object.
Parent | Property that returns the parent Sheet object.
Position | Property that returns the position of the center of the center mark on the sheet.
Style | Property that gets and sets the style associated with this center mark.
Type | Property returning kCentermarkObject indicating this objects type.
Visible | Property that gets and sets whether the center mark is visible.
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties


Centermark.Application Property

Centermark.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Application Property


Centermark.Attached Property

Centermark.Attached Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the centermark is sick. Returns False if the centermark is sick.

Visual Basic
Property Attached() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Attached Property


Centermark.AttachedEntity Property

Centermark.AttachedEntity Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the entity the center mark is associated with.

Visual Basic
Property AttachedEntity() As IDispatch**
Remarks

For center marks of type kRegularCentermark, or kPunchFeatureCentermarkType this property returns a GeometryIntent object. For center marks of type kWorkFeatureCentermark this property returns the work feature in the model. For center marks of type kCenterOfGravityCentermarkType this property returns the DrawingView object the center mark was created within. For center marks of type kRecoveredPunchFeatureCentermarkType this property returns ?????. The model shown in the drawing view can be obtained using the ReferencedDocumentDescriptor property of the DrawingView object.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.AttachedEntity Property


Centermark.AttributeSets Property

Centermark.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.AttributeSets Property


Centermark.Centerlines Property

Centermark.Centerlines Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the a collection of associated Centerline objects.

Visual Basic
Property Centerlines() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Centerlines Property


Centermark.CentermarkType Property

Centermark.CentermarkType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets the centermark type.

Visual Basic
Property CentermarkType() As CentermarkTypeEnum*
Remarks

The type indicates how the center mark was created and its behavior. The following types can be returned:

  • kRegularCentermark - This type of center mark is created on individual entities using the Center Mark command.
  • kWorkFeatureCentermark - This type of center mark is created by including a work feature from the model using the Include Work Features command. Work points can be used and also a work axis whose orientation is normal to the view plane (the axis appears as a point). The work feature the center mark is associated with can be obtained using the AttachedEntity property.
  • kRecoveredPunchFeatureCentermarkType - This type of center mark is created by having the Punch Centers context option enabled and selecting a drawing curve that represents the edge of a punch feature when using the Center Mark command.
  • kPunchFeatureCentermarkType - This type of center mark is created by selecting the 'Recover Punch Center' option when creating or editing a flat pattern drawing view.
  • kCenterOfGravityCentermarkType - This type of center mark is created by specifying that the center of gravity of the model be shown using the Center Of Gravity command. The model the center of gravity is being display for can be determined by using the ReferencedDocumentDescriptor property of the DrawingView the center mark is associated with, which can be obtained using the AttachedEntity property of the Centermark object.
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.CentermarkType Property


Centermark.ExtensionLinesVisible Property

Centermark.ExtensionLinesVisible Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the extension lines associated with this center mark are visible or not.

Visual Basic
Property ExtensionLinesVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionLinesVisible Property


Centermark.ExtensionPointFour Property

Centermark.ExtensionPointFour Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the center mark extension point.

Visual Basic
Property ExtensionPointFour() As Point2d*
Remarks

This property can return Nothing in the case where the extension lines have been turned off or the end of the extension line is clipped of as the result of a broken view.

For center marks of type kCenterOfGravityCentermarkType, kRegularCentermarkType, kPunchFeatureCentermarkType, and kWorkFeatureCentermarkType that have not been aligned to another entity, (AlignmentEntity property returns Nothing), this is the extension line that extends in the negative y direction of the sheet.

Center marks of type kCenteredPatternCentermarkType and kCenterlineCentermarkType only have one extension line, since the perpendicular line is defined by the centerline. This returns one end of the single extension line and could be oriented in any direction. The orientation can be determined by using the ExtensionPointFourDirection property.

Setting this property has the effect of repositioning the end of the extension line. Since the position and orientation of the center point is controlled by other geometry only the extents of the extension line can be set. This is illustrated in the figure below. In the figure on the left there is an existing center mark and the extension point is being set using the point graphically shown. The extension point is moved such that it is still along the extension line but up to the new position.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointFour Property


Centermark.ExtensionPointFourDirection Property

Centermark.ExtensionPointFourDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the direction of the extension point. This can be used to understand the direction the fourth extension point can be moved.

Visual Basic
Property ExtensionPointFourDirection() As UnitVector2d**
Remarks

If you reposition the extension point in the direction of this vector you will be extending the line. It's possible that this property can return nothing in the case where the center mark has been clipped as the result of a broken view and the extension point is not visible in the view.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointFourDirection Property


Centermark.ExtensionPointOne Property

Centermark.ExtensionPointOne Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the center mark extension point.

Visual Basic
Property ExtensionPointOne() As Point2d*
Remarks

This property can return Nothing in the case where the extension lines have been turned off or the end of the extension line is clipped of as the result of a broken view.

For center marks of type kCenterOfGravityCentermarkType, kRegularCentermarkType, kPunchFeatureCentermarkType, and kWorkFeatureCentermarkType that have not been aligned to another entity, (AlignmentEntity property returns Nothing), this is the extension line that extends in the positive x direction of the sheet.

Center marks of type kCenteredPatternCentermarkType and kCenterlineCentermarkType only have one extension line, since the perpendicular line is defined by the centerline. This returns one end of the single extension line and could be oriented in any direction. The orientation can be determined by using the ExtensionPointOneDirection property.

Setting this property has the effect of repositioning the end of the extension line. Since the position and orientation of the center point is controlled by other geometry only the extents of the extension line can be set. This is illustrated in the figure below. In the figure on the left there is an existing center mark and the extension point is being set using the point graphically shown. The extension point is moved such that it is still along the extension line but up to the new position.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointOne Property


Centermark.ExtensionPointOneDirection Property

Centermark.ExtensionPointOneDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the direction of the extension point. This can be used to understand the direction the first extension point can be moved.

Visual Basic
Property ExtensionPointOneDirection() As UnitVector2d**
Remarks

If you reposition the extension point in the direction of this vector you will be extending the line. It's possible that this property can return nothing in the case where the center mark has been clipped as the result of a broken view and the extension point is not visible in the view.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointOneDirection Property


Centermark.ExtensionPointThree Property

Centermark.ExtensionPointThree Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the center mark extension point.

Visual Basic
Property ExtensionPointThree() As Point2d*
Remarks

This property can return Nothing in the case where the extension lines have been turned off or the end of the extension line is clipped of as the result of a broken view.

For center marks of type kCenterOfGravityCentermarkType, kRegularCentermarkType, kPunchFeatureCentermarkType, and kWorkFeatureCentermarkType that have not been aligned to another entity, (AlignmentEntity property returns Nothing), this is the extension line that extends in the negative x direction of the sheet.

Center marks of type kCenteredPatternCentermarkType and kCenterlineCentermarkType only have one extension line, since the perpendicular line is defined by the centerline. This returns one end of the single extension line and could be oriented in any direction. The orientation can be determined by using the ExtensionPointThreeDirection property.

Setting this property has the effect of repositioning the end of the extension line. Since the position and orientation of the center point is controlled by other geometry only the extents of the extension line can be set. This is illustrated in the figure below. In the figure on the left there is an existing center mark and the extension point is being set using the point graphically shown. The extension point is moved such that it is still along the extension line but up to the new position.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointThree Property


Centermark.ExtensionPointThreeDirection Property

Centermark.ExtensionPointThreeDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the direction of the extension point. This can be used to understand the direction the third extension point can be moved.

Visual Basic
Property ExtensionPointThreeDirection() As UnitVector2d**
Remarks

If you reposition the extension point in the direction of this vector you will be extending the line. It's possible that this property can return nothing in the case where the center mark has been clipped as the result of a broken view and the extension point is not visible in the view.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointThreeDirection Property


Centermark.ExtensionPointTwo Property

Centermark.ExtensionPointTwo Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the center mark extension point.

Visual Basic
Property ExtensionPointTwo() As Point2d*
Remarks

This property can return Nothing in the case where the extension lines have been turned off or the end of the extension line is clipped of as the result of a broken view.

For center marks of type kCenterOfGravityCentermarkType, kRegularCentermarkType, kPunchFeatureCentermarkType, and kWorkFeatureCentermarkType that have not been aligned to another entity, (AlignmentEntity property returns Nothing), this is the extension line that extends in the positive y direction of the sheet.

Center marks of type kCenteredPatternCentermarkType and kCenterlineCentermarkType only have one extension line, since the perpendicular line is defined by the centerline. This returns one end of the single extension line and could be oriented in any direction. The orientation can be determined by using the ExtensionPointTwoDirection property.

Setting this property has the effect of repositioning the end of the extension line. Since the position and orientation of the center point is controlled by other geometry only the extents of the extension line can be set. This is illustrated in the figure below. In the figure on the left there is an existing center mark and the extension point is being set using the point graphically shown. The extension point is moved such that it is still along the extension line but up to the new position.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointTwo Property


Centermark.ExtensionPointTwoDirection Property

Centermark.ExtensionPointTwoDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the direction of the extension point. This can be used to understand the direction the second extension point can be moved.

Visual Basic
Property ExtensionPointTwoDirection() As UnitVector2d**
Remarks

If you reposition the extension point in the direction of this vector you will be extending the line. It's possible that this property can return nothing in the case where the center mark has been clipped as the result of a broken view and the extension point is not visible in the view.

You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.ExtensionPointTwoDirection Property


Centermark.Layer Property

Centermark.Layer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Layer Property


Centermark.Parent Property

Centermark.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent Sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Parent Property


Centermark.Position Property

Centermark.Position Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the position of the center of the center mark on the sheet.

Visual Basic
Property Position() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Position Property


Centermark.Style Property

Centermark.Style Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the style associated with this center mark.

Visual Basic
Property Style() As CentermarkStyle*
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Style Property


Centermark.Type Property

Centermark.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kCentermarkObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Type Property


Centermark.Visible Property

Centermark.Visible Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the center mark is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Centermark Interface > Centermark Properties > Centermark.Visible Property


Centermarks Interface

Centermarks Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The Centermarks collection object provides access to all the center marks on a sheet and provides functionality to create new center marks.

Class Hierarchy
Inventor::Centermarks
Visual Basic
Public Interface Centermarks
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.Centermarks

You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface


Centermarks Methods

Centermarks Methods
Summary

The methods of the Centermarks class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a center mark relative to drawing geometry. This can result in a center mark at the origin of a punch center if the specified geometry is the edge of a punch and the AtPunchCenter argument is true.
AddByCenterOfGravity | Method that creates a center mark at the center of gravity of the model in the input drawing view. This will fail in the case where the view does not contain any solid parts.
AddByWorkFeature | Method that creates a center mark that represents the work feature within the drawing view.
Item | Method that returns the specified Centermark object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Methods


Centermarks.Add Method

Centermarks.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a center mark relative to drawing geometry. This can result in a center mark at the origin of a punch center if the specified geometry is the edge of a punch and the AtPunchCenter argument is true.

Visual Basic
Sub Add(Intent As GeometryIntent, ByRef ExtensionLinesVisible As [defaultvalue(-1)] VARIANT_BOOL, ByRef AtPunchCenter As [defaultvalue(-1)] VARIANT_BOOL, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] Centermark*)
Parameters
Parameters | Description
Intent | Specifies the entity to create the center mark relative to. This is typically a circular or elliptical drawing curve but can be any drawing curve when it's the edge of a punch feature and you're creating the center point at the origin of the punch. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
ExtensionLinesVisible | Optional input Boolean that specifies if the extension lines should be visible in the created center mark.
AtPunchCenter | Optional input Boolean that specifies if the input geometry is the edge of the punch feature the center mark should be created at the origin of the punch feature instead of the center of the input geometry.
CenterMarkStyle | Object that specifies the center mark style to use for the center mark. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the center mark. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Methods > Centermarks.Add Method


Centermarks.AddByCenterOfGravity Method

Centermarks.AddByCenterOfGravity Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a center mark at the center of gravity of the model in the input drawing view. This will fail in the case where the view does not contain any solid parts.

Visual Basic
Sub AddByCenterOfGravity(DrawingView As DrawingView, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] Centermark*)
Parameters
Parameters | Description
DrawingView | Specifies the view to create the center mark for.
CenterMarkStyle | Object that specifies the center mark style to use for the center mark. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the center mark. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Methods > Centermarks.AddByCenterOfGravity Method


Centermarks.AddByWorkFeature Method

Centermarks.AddByWorkFeature Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a center mark that represents the work feature within the drawing view.

Visual Basic
Sub AddByWorkFeature(WorkFeature As IDispatch, DrawingView As DrawingView, ByRef CenterMarkStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] Centermark*)
Parameters
Parameters | Description
WorkFeature | Specifies the work feature to create the center mark for. This can be a WorkPoint or WorkAxis object. In the case of a WorkAxis object, the work axis must be oriented so it is normal to the plane of the sheet. If an work axis is provided that does not meet this criteria the method will fail.
DrawingView | Specifies the drawing view to create the center mark within. When working with an assembly the input WorkPoint or WorkAxis must always be with respect to the top-level. This means that work points or axes that exist within the parts or sub-assemblies must be represented by WorkPointProxy or WorkAxisProxy objects.
CenterMarkStyle | Object that specifies the center mark style to use for the center mark. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the center mark. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Methods > Centermarks.AddByWorkFeature Method


Centermarks.Item Method

Centermarks.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the specified Centermark object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Centermark*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Methods > Centermarks.Item Method


Centermarks Properties

Centermarks Properties
Summary

The properties of the Centermarks class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kCentermarksObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Properties


Centermarks.Application Property

Centermarks.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Properties > Centermarks.Application Property


Centermarks.Count Property

Centermarks.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Properties > Centermarks.Count Property


Centermarks.Type Property

Centermarks.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kCentermarksObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Centermarks Interface > Centermarks Properties > Centermarks.Type Property


CentermarkStyle Interface

CentermarkStyle Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CentermarkStyle object represents a center mark style in a drawing.

Class Hierarchy
Inventor::Style
    Inventor::CentermarkStyle
Visual Basic
Public Interface CentermarkStyle
Inherits Style
Notes

Members through which this object may be accessed include:

Centerline.Style

Centermark.Style

CentermarkStylesEnumerator.Item

ObjectDefaultsStyle.CenterlineStyle

ObjectDefaultsStyle.CentermarkStyle

ObjectDefaultsStyle.CenterOfGravityStyle

ObjectDefaultsStyle.SheetMetalPunchStyle

ObjectDefaultsStyle.WorkAxisStyle

ObjectDefaultsStyle.WorkPlaneStyle

ObjectDefaultsStyle.WorkPointStyle

You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface


CentermarkStyle Properties

CentermarkStyle Properties
Summary

The properties of the CentermarkStyle class are listed here.

Properties
Name | Description
DefaultRadius | Property that gets and sets the size of a sick center mark if it is left detached from geometry. When setting this value it must be greater than zero.
ExtensionLength | Property that gets and sets the minimum length of center mark extension lines. When setting this value it must be greater than zero.
GapDistance | Property that gets and sets the gap distance between the center indicator and the extension line. When setting this value it must be greater than zero.
MarkSize | Property that gets and sets the size of the center indicator mark. When setting this value it must be greater than zero.
OvershootDistance | Property that gets and sets the distance that center mark extension lines extend beyond the edges of the features that they define. When setting this value it must be greater than zero.
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface > CentermarkStyle Properties


CentermarkStyle.DefaultRadius Property

CentermarkStyle.DefaultRadius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the size of a sick center mark if it is left detached from geometry. When setting this value it must be greater than zero.

Visual Basic
Property DefaultRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface > CentermarkStyle Properties > CentermarkStyle.DefaultRadius Property


CentermarkStyle.ExtensionLength Property

CentermarkStyle.ExtensionLength Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the minimum length of center mark extension lines. When setting this value it must be greater than zero.

Visual Basic
Property ExtensionLength() As double
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface > CentermarkStyle Properties > CentermarkStyle.ExtensionLength Property


CentermarkStyle.GapDistance Property

CentermarkStyle.GapDistance Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the gap distance between the center indicator and the extension line. When setting this value it must be greater than zero.

Visual Basic
Property GapDistance() As double
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface > CentermarkStyle Properties > CentermarkStyle.GapDistance Property


CentermarkStyle.MarkSize Property

CentermarkStyle.MarkSize Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the size of the center indicator mark. When setting this value it must be greater than zero.

Visual Basic
Property MarkSize() As double
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface > CentermarkStyle Properties > CentermarkStyle.MarkSize Property


CentermarkStyle.OvershootDistance Property

CentermarkStyle.OvershootDistance Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the distance that center mark extension lines extend beyond the edges of the features that they define. When setting this value it must be greater than zero.

Visual Basic
Property OvershootDistance() As double
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStyle Interface > CentermarkStyle Properties > CentermarkStyle.OvershootDistance Property


CentermarkStylesEnumerator Interface

CentermarkStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CentermarkStylesEnumerator object provides access to the existing CentermarkStyle objects.

Class Hierarchy
Inventor::CentermarkStylesEnumerator
Visual Basic
Public Interface CentermarkStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.CentermarkStyles

You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface


CentermarkStylesEnumerator Methods

CentermarkStylesEnumerator Methods
Summary

The methods of the CentermarkStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified CentermarkStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface > CentermarkStylesEnumerator Methods


CentermarkStylesEnumerator.Item Method

CentermarkStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified CentermarkStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CentermarkStyle*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the CentermarkStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the CentermarkStyle name. If an out of range index or a name of a non-existent CentermarkStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface > CentermarkStylesEnumerator Methods > CentermarkStylesEnumerator.Item Method


CentermarkStylesEnumerator Properties

CentermarkStylesEnumerator Properties
Summary

The properties of the CentermarkStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning kCentermarkStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface > CentermarkStylesEnumerator Properties


CentermarkStylesEnumerator.Application Property

CentermarkStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface > CentermarkStylesEnumerator Properties > CentermarkStylesEnumerator.Application Property


CentermarkStylesEnumerator.Count Property

CentermarkStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface > CentermarkStylesEnumerator Properties > CentermarkStylesEnumerator.Count Property


CentermarkStylesEnumerator.Type Property

CentermarkStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kCentermarkStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CentermarkStylesEnumerator Interface > CentermarkStylesEnumerator Properties > CentermarkStylesEnumerator.Type Property


CentroidWorkPointDef Interface

CentroidWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Object that allows you to get and set the information that specifies a work point at the centroid of the input entities.

Class Hierarchy
Inventor::CentroidWorkPointDef
Visual Basic
Public Interface CentroidWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > CentroidWorkPointDef Interface


CentroidWorkPointDef Properties

CentroidWorkPointDef Properties
Summary

The properties of the CentroidWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Entities | Property that returns either an Edge, an EdgeLoop or an EdgeCollection object.
Parent | Property that returns the parent WorkPoint object.
Type | Property that returns kCentroidWorkPointDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > CentroidWorkPointDef Interface > CentroidWorkPointDef Properties


CentroidWorkPointDef.Application Property

CentroidWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CentroidWorkPointDef Interface > CentroidWorkPointDef Properties > CentroidWorkPointDef.Application Property


CentroidWorkPointDef.Entities Property

CentroidWorkPointDef.Entities Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns either an Edge, an EdgeLoop or an EdgeCollection object.

Visual Basic
Property Entities() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CentroidWorkPointDef Interface > CentroidWorkPointDef Properties > CentroidWorkPointDef.Entities Property


CentroidWorkPointDef.Parent Property

CentroidWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > CentroidWorkPointDef Interface > CentroidWorkPointDef Properties > CentroidWorkPointDef.Parent Property


CentroidWorkPointDef.Type Property

CentroidWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kCentroidWorkPointDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CentroidWorkPointDef Interface > CentroidWorkPointDef Properties > CentroidWorkPointDef.Type Property


ChainDimensionSet Interface

ChainDimensionSet Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The ChainDimensionSet object represents a chain dimension set placed on a sheet.

Class Hierarchy
Inventor::ChainDimensionSet
Visual Basic
Public Interface ChainDimensionSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ChainDimensionSets.Add

ChainDimensionSets.AddUsingBaseDimension

ChainDimensionSets.Item

LinearGeneralDimension.ChainDimensionSet

You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface


ChainDimensionSet Methods

ChainDimensionSet Methods
Summary

The methods of the ChainDimensionSet class are listed here.

Methods
Methods
Name | Description
AddMembers | Method that adds member(s) to the chain set based on the input geometry or dimension and returns the newly created member(s).
Arrange | Method that resets the chain dimension set such that all members are equidistant from the view boundary. Dimensions are aligned to the specified base dimension.
Delete | Method that deletes the ChainDimensionSet.
GetReferenceKey | Method that generates and returns the reference key for this entity.
MergeMembers | Method that merges two members of the set by deleting the second member and healing (modifying) the first member to fill the gap. The input members must be contiguous, else the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Methods


ChainDimensionSet.AddMembers Method

ChainDimensionSet.AddMembers Method Introduced in Inventor 2011
Summary

Method that adds member(s) to the chain set based on the input geometry or dimension and returns the newly created member(s).

Visual Basic
Sub AddMembers(DimensionOrGeometry As IDispatch, Result As [out, retval] GeneralDimensionsEnumerator*)
Parameters
Parameters | Description
DimensionOrGeometry | Input object that specifies the dimension or geometry used to define the chain dimension member(s). Valid input objects are GeometryIntent, LinearGeneralDimension and ChainDimensionSet.
Remarks

Following are the behaviors based on the input object:

  • GeometryIntent object - In this case 0, 1 or 2 new members can be added to the set based on the position and orientation of the selected geometry. The number of members created is equal to the number of point intents specified by the input GeometryIntent that are currently not in use by this chain dimension set. For example, if the GeometryIntent specifies a (currently unused) point intent, a single member is created. If the GeometryIntent specifies an edge, and both the end points are currently unused, two members are created.
  • An existing LinearGeneralDimension object - The specified linear dimension is deleted and the geometries that were attached to the linear dimension are used to create members within this set.
  • An existing ChainDimensionSet object - The specified chain dimension set is deleted and the geometries that were attached to the chain dimension set are used to create members within this set.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Methods > ChainDimensionSet.AddMembers Method


ChainDimensionSet.Arrange Method

ChainDimensionSet.Arrange Method
Summary

Method that resets the chain dimension set such that all members are equidistant from the view boundary. Dimensions are aligned to the specified base dimension.

Visual Basic
Sub Arrange(BaseDimension As LinearGeneralDimension)
Parameters
Parameters | Description
BaseDimension | Input LinearGeneralDimension object that specifies the member of the set. All set members are aligned to this member.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Methods > ChainDimensionSet.Arrange Method


ChainDimensionSet.Delete Method

ChainDimensionSet.Delete Method
Summary

Method that deletes the ChainDimensionSet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Methods > ChainDimensionSet.Delete Method


ChainDimensionSet.GetReferenceKey Method

ChainDimensionSet.GetReferenceKey Method Introduced in Inventor 2011
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Methods > ChainDimensionSet.GetReferenceKey Method


ChainDimensionSet.MergeMembers Method

ChainDimensionSet.MergeMembers Method Introduced in Inventor 2011
Summary

Method that merges two members of the set by deleting the second member and healing (modifying) the first member to fill the gap. The input members must be contiguous, else the method will fail.

Visual Basic
Sub MergeMembers(MemberOne As LinearGeneralDimension, MemberTwo As LinearGeneralDimension)
Parameters
Parameters | Description
MemberOne | Input LinearGeneralDimension object that specifies the first member of the set to merge. This member is retained and modified.
MemberTwo | Input LinearGeneralDimension object that specifies the second member of the set to merge. This member is deleted.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Methods > ChainDimensionSet.MergeMembers Method


ChainDimensionSet Properties

ChainDimensionSet Properties
Summary

The properties of the ChainDimensionSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DimensionType | Property that returns the dimension type of the chain set. Possible values are kAlignedDimensionType, kHorizontalDimensionType and kVerticalDimensionType.
Layer | Property that gets and sets the layer for the dimension set.
Locked | Property that gets and sets the lock status of the dimension set. Unlocked set allows changing the position of each set member individually.
Members | Property that returns all the member LinearGeneralDimension objects.
Parent | Property that returns the parent sheet of the object.
Precision | Property that gets and sets the number of decimal places displayed for all the members in this set. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.
Style | Property that gets and sets the dimension style used for this dimension set. Setting a new style resets all the style-overriding properties on the members.
Type | Property returning kChainDimensionSetObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties


ChainDimensionSet.Application Property

ChainDimensionSet.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Application Property


ChainDimensionSet.AttributeSets Property

ChainDimensionSet.AttributeSets Property Introduced in Inventor 2011
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.AttributeSets Property


ChainDimensionSet.DimensionType Property

ChainDimensionSet.DimensionType Property Introduced in Inventor 2011
Summary

Property that returns the dimension type of the chain set. Possible values are kAlignedDimensionType, kHorizontalDimensionType and kVerticalDimensionType.

Visual Basic
Property DimensionType() As DimensionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.DimensionType Property


ChainDimensionSet.Layer Property

ChainDimensionSet.Layer Property Introduced in Inventor 2011
Summary

Property that gets and sets the layer for the dimension set.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Layer Property


ChainDimensionSet.Locked Property

ChainDimensionSet.Locked Property
Summary

Property that gets and sets the lock status of the dimension set. Unlocked set allows changing the position of each set member individually.

Visual Basic
Property Locked() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Locked Property


ChainDimensionSet.Members Property

ChainDimensionSet.Members Property Introduced in Inventor 2011
Summary

Property that returns all the member LinearGeneralDimension objects.

Visual Basic
Property Members() As GeneralDimensionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Members Property


ChainDimensionSet.Parent Property

ChainDimensionSet.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent sheet of the object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Parent Property


ChainDimensionSet.Precision Property

ChainDimensionSet.Precision Property Introduced in Inventor 2011
Summary

Property that gets and sets the number of decimal places displayed for all the members in this set. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

Visual Basic
Property Precision() As long
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Precision Property


ChainDimensionSet.Style Property

ChainDimensionSet.Style Property Introduced in Inventor 2011
Summary

Property that gets and sets the dimension style used for this dimension set. Setting a new style resets all the style-overriding properties on the members.

Visual Basic
Property Style() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Style Property


ChainDimensionSet.Type Property

ChainDimensionSet.Type Property Introduced in Inventor 2011
Summary

Property returning kChainDimensionSetObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSet Interface > ChainDimensionSet Properties > ChainDimensionSet.Type Property


ChainDimensionSets Interface

ChainDimensionSets Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The ChainDimensionSets collection object provides access to all of the chain dimension sets on the sheet.

Class Hierarchy
Inventor::ChainDimensionSets
Visual Basic
Public Interface ChainDimensionSets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDimensions.ChainDimensionSets

See Also

Chain dimensions sets sample

You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface


ChainDimensionSets Methods

ChainDimensionSets Methods
Summary

The methods of the ChainDimensionSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a chain dimension set using the specified geometries. Returns the newly created ChainDimensionSets object.
AddUsingBaseDimension | Method that creates a chain dimension set based on the specified base dimension and using specified additional geometry. Returns the newly created ChainDimensionSet object.
Item | Method that returns the specified dimension set object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Methods


ChainDimensionSets.Add Method

ChainDimensionSets.Add Method Introduced in Inventor 2011
Summary

Method that creates a chain dimension set using the specified geometries. Returns the newly created ChainDimensionSets object.

Visual Basic
Sub Add(GeometryIntents As ObjectCollection, PlacementPoint As Point2d, DimensionType As DimensionTypeEnum, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] ChainDimensionSet*)
Parameters
Parameters | Description
GeometryIntents | Input ObjectCollection containing GeometryIntent objects. The GeometryIntent objects specify the geometries to use for the dimension set. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method.
PlacementPoint | Input Point2d object that specifies the placement point of the dimension set on the sheet.
DimensionType | Input DimensionTypeEnum that specifies the dimension type. Valid values kHorizontalDimensionType, kVerticalDimensionType and kAlignedDimensionType. The value kAlignedDimensionType can be specified only if the first geometry specified in the input GeometryIntents collection represents a line which is not parallel to the x or y axes of the sheet. If kAlignedDimensionType is specified, the placement point decides the orientation of the dimension set.
DimensionStyle | Optional input DimensionStyle object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Optional input Layer object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
Example

Chain dimensions sets example.

This sample demonstrates the creation of a chain dimension set in a drawing. Create a drawing view and select multiple edges in the view before running the sample.

Public Sub CreateChainDimensionSet()

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    Dim oIntentCollection As ObjectCollection
    Set oIntentCollection = ThisApplication.TransientObjects.CreateObjectCollection

    ' Get all the selected drawing curve segments.
    Dim oDrawingCurveSegment As DrawingCurveSegment
    Dim oDrawingCurve As DrawingCurve
    For Each oDrawingCurveSegment In oDrawDoc.SelectSet

        ' Set a reference to the drawing curve.
        Set oDrawingCurve = oDrawingCurveSegment.Parent

        Dim oDimIntent As GeometryIntent
        Set oDimIntent = oActiveSheet.CreateGeometryIntent(oDrawingCurve)

        Call oIntentCollection.Add(oDimIntent)
    Next

   ' Set a reference to the view to which the curve belongs.
    Dim oDrawingView As DrawingView
    Set oDrawingView = oDrawingCurve.Parent

    ' Set a reference to the chain dimension sets collection.
    Dim oChainDimSets As ChainDimensionSets
    Set oChainDimSets = oActiveSheet.DrawingDimensions.ChainDimensionSets

    ' Determine the placement point
    Dim oPlacementPoint As Point2d
    Set oPlacementPoint = ThisApplication.TransientGeometry.CreatePoint2d(oDrawingView.Center.X, oDrawingView.Top + 5)

    ' Create a horizontal chain dimension set.
    Dim oChainDimSet As ChainDimensionSet
    Set oChainDimSet = oChainDimSets.Add(oIntentCollection, oPlacementPoint, kHorizontalDimensionType)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Methods > ChainDimensionSets.Add Method


ChainDimensionSets.AddUsingBaseDimension Method

ChainDimensionSets.AddUsingBaseDimension Method
Summary

Method that creates a chain dimension set based on the specified base dimension and using specified additional geometry. Returns the newly created ChainDimensionSet object.

Visual Basic
Sub AddUsingBaseDimension(Dimensions As ObjectCollection, GeometryIntents As ObjectCollection, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] ChainDimensionSet*)
Parameters
Parameters | Description
GeometryIntents | Input ObjectCollection containing GeometryIntent objects. The GeometryIntent objects specify the geometries to use for the dimension set. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method.
DimensionStyle | Optional input DimensionStyle object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Optional input Layer object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
BaseDimension | Input LinearGeneralDimension that specifies the base dimension for the chain set. Chain set position and type (horizontal, vertical, aligned) are specified by this dimension. Linear symmetric and linear diameter dimensions cannot be used as a base dimension.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Methods > ChainDimensionSets.AddUsingBaseDimension Method


ChainDimensionSets.Item Method

ChainDimensionSets.Item Method Introduced in Inventor 2011
Summary

Method that returns the specified dimension set object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ChainDimensionSet*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Methods > ChainDimensionSets.Item Method


ChainDimensionSets Properties

ChainDimensionSets Properties
Summary

The properties of the ChainDimensionSets class are listed here.

Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class ChainDimensionSets.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kChainDimensionSetsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Properties


ChainDimensionSets._NewEnum Property

ChainDimensionSets._NewEnum Property
Summary

This is _NewEnum, a member of class ChainDimensionSets.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Properties > ChainDimensionSets._NewEnum Property


ChainDimensionSets.Application Property

ChainDimensionSets.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Properties > ChainDimensionSets.Application Property


ChainDimensionSets.Count Property

ChainDimensionSets.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Properties > ChainDimensionSets.Count Property


ChainDimensionSets.Type Property

ChainDimensionSets.Type Property Introduced in Inventor 2011
Summary

Property returning kChainDimensionSetsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChainDimensionSets Interface > ChainDimensionSets Properties > ChainDimensionSets.Type Property


ChamferDefinition Interface

ChamferDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ChamferDefinition object is the base class that defines the variables for chamfer features

Class Hierarchy
Inventor::ChamferDefinition
    Inventor::DistanceAndAngleChamferDef
    Inventor::DistanceChamferDef
    Inventor::TwoDistancesChamferDef
Visual Basic
Public Interface ChamferDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ChamferFeature.Definition

CornerChamferDefinition.ChamferDefinition

You are here: Symbol Reference > Inventor Library > Objects > ChamferDefinition Interface


ChamferDefinition Properties

ChamferDefinition Properties
Summary

The properties of the ChamferDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent ChamferFeature of the definition.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChamferDefinition Interface > ChamferDefinition Properties


ChamferDefinition.Application Property

ChamferDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChamferDefinition Interface > ChamferDefinition Properties > ChamferDefinition.Application Property


ChamferDefinition.Parent Property

ChamferDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parent ChamferFeature of the definition.

Visual Basic
Property Parent() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > ChamferDefinition Interface > ChamferDefinition Properties > ChamferDefinition.Parent Property


ChamferDefinition.Type Property

ChamferDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChamferDefinition Interface > ChamferDefinition Properties > ChamferDefinition.Type Property


ChamferFeature Interface

ChamferFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ChamferFeature object represents chamfered modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::ChamferFeature
        Inventor::ChamferFeatureProxy
Visual Basic
Public Interface ChamferFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ChamferFeatureProxy.NativeObject

ChamferFeatures.AddUsingDistance

ChamferFeatures.AddUsingDistanceAndAngle

ChamferFeatures.AddUsingTwoDistances

ChamferFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface


ChamferFeature Properties

ChamferFeature Properties
Summary

The properties of the ChamferFeature class are listed here.

Properties
Name | Description
AutomaticEdgeChain | Property that returns whether or not to use all tangentially connected edges. A value of True indicates that automatic edge chaining of tangentially connected edges should be performed.
ChamferedEdges | Property that returns the that are chamfered by this feature. When querying an existing chamfer, the end-of-part marker should be placed above this chamfer feature to allow access this property.
Definition | Property that returns the ChamferDefinition object that defines how the chamfer is defined. The type of definition object that will be returned can be determined by using the DefinitionType property.
DefinitionType | Property that returns an enum indicating how the chamfer was defined. This indicates the type of object returned by the Definition property. The valid return values are kDistance, kDistanceAndAngle and kTwoDistances.
PreserveAllFeatures | Property that specifies whether all other features that intersect with the feature are checked and their intersections calculated during this feature operation. If False, only the objects that are part of this feature operation are calculated.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface > ChamferFeature Properties


ChamferFeature.AutomaticEdgeChain Property

ChamferFeature.AutomaticEdgeChain Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns whether or not to use all tangentially connected edges. A value of True indicates that automatic edge chaining of tangentially connected edges should be performed.

Visual Basic
Property AutomaticEdgeChain() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface > ChamferFeature Properties > ChamferFeature.AutomaticEdgeChain Property


ChamferFeature.ChamferedEdges Property

ChamferFeature.ChamferedEdges Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that are chamfered by this feature. When querying an existing chamfer, the end-of-part marker should be placed above this chamfer feature to allow access this property.

Visual Basic
Property ChamferedEdges() As EdgeCollection**
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface > ChamferFeature Properties > ChamferFeature.ChamferedEdges Property


ChamferFeature.Definition Property

ChamferFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ChamferDefinition object that defines how the chamfer is defined. The type of definition object that will be returned can be determined by using the DefinitionType property.

Visual Basic
Property Definition() As ChamferDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface > ChamferFeature Properties > ChamferFeature.Definition Property


ChamferFeature.DefinitionType Property

ChamferFeature.DefinitionType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns an enum indicating how the chamfer was defined. This indicates the type of object returned by the Definition property. The valid return values are kDistance, kDistanceAndAngle and kTwoDistances.

Visual Basic
Property DefinitionType() As ChamferDefinitionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface > ChamferFeature Properties > ChamferFeature.DefinitionType Property


ChamferFeature.PreserveAllFeatures Property

ChamferFeature.PreserveAllFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies whether all other features that intersect with the feature are checked and their intersections calculated during this feature operation. If False, only the objects that are part of this feature operation are calculated.

Visual Basic
Property PreserveAllFeatures() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeature Interface > ChamferFeature Properties > ChamferFeature.PreserveAllFeatures Property


ChamferFeatureProxy Interface

ChamferFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ChamferFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ChamferFeature
        Inventor::ChamferFeatureProxy
Visual Basic
Public Interface ChamferFeatureProxy
Inherits ChamferFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatureProxy Interface


ChamferFeatureProxy Properties

ChamferFeatureProxy Properties
Summary

The properties of the ChamferFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatureProxy Interface > ChamferFeatureProxy Properties


ChamferFeatureProxy.ContainingOccurrence Property

ChamferFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatureProxy Interface > ChamferFeatureProxy Properties > ChamferFeatureProxy.ContainingOccurrence Property


ChamferFeatureProxy.NativeObject Property

ChamferFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ChamferFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatureProxy Interface > ChamferFeatureProxy Properties > ChamferFeatureProxy.NativeObject Property


ChamferFeatures Interface

ChamferFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ChamferFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional ChamferFeature objects.

Class Hierarchy
Inventor::ChamferFeatures
Visual Basic
Public Interface ChamferFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.ChamferFeatures

FlatPatternFeatures.ChamferFeatures

PartFeatures.ChamferFeatures

You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface


ChamferFeatures Methods

ChamferFeatures Methods
Summary

The methods of the ChamferFeatures class are listed here.

Methods
Methods
Name | Description
AddUsingDistance | Method that creates a new ChamferFeature defined by a specified distance. The new ChamferFeature is returned.
AddUsingDistanceAndAngle | Method that creates a new ChamferFeature that is defined by a distance and at a specified angle to an input face. The new ChamferFeature is returned.
AddUsingTwoDistances | Method that creates a new ChamferFeature that is defined by two distances. The new ChamferFeature is returned.
Item | Method that returns the specified ChamferFeature object from the collection
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Methods


ChamferFeatures.AddUsingDistance Method

ChamferFeatures.AddUsingDistance Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new ChamferFeature defined by a specified distance. The new ChamferFeature is returned.

Visual Basic
Sub AddUsingDistance(Edges As EdgeCollection, Distance As VARIANT, ByRef AutomaticEdgeChain As [defaultvalue(-1)] VARIANT_BOOL, ByRef CornerSetback As [defaultvalue(-1)] VARIANT_BOOL, ByRef PreserveAllFeatures As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ChamferFeature*)
Parameters
Parameters | Description
Edges | Input object that contains the edges to be chamfered.
Distance | Input Variant that defines the distance for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
AutomaticEdgeChain | Optional input Boolean that defines if automatic edge chaining along tangentially connected edges should be performed. The default is True.
CornerSetback | Optional Boolean that defines how any corners will be treated. If True, the corner is joined by a flat intersection. If False, the corner is defined by the intersection of the chamfers. The default is True.
PreserveAllFeatures | Optional Boolean that defines the behavior when the chamfer intersects the body other than at adjacent faces. The default is False.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Methods > ChamferFeatures.AddUsingDistance Method


ChamferFeatures.AddUsingDistanceAndAngle Method

ChamferFeatures.AddUsingDistanceAndAngle Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new ChamferFeature that is defined by a distance and at a specified angle to an input face. The new ChamferFeature is returned.

Visual Basic
Sub AddUsingDistanceAndAngle(Edges As EdgeCollection, Face As Face, Distance As VARIANT, Angle As VARIANT, ByRef AutomaticEdgeChain As [defaultvalue(-1)] VARIANT_BOOL, ByRef PreserveAllFeatures As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ChamferFeature*)
Parameters
Parameters | Description
Edges | Input object that contains the edges to be chamfered.
Face | Input object that is chamfer angle is measured from.
Distance | Input Variant that defines the distance for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
Angle | Input Variant that defines the angle for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
AutomaticEdgeChain | Optional input Boolean that defines if automatic edge chaining along tangentially connected edges should be performed. The default is True.
PreserveAllFeatures | Optional Boolean that defines the behavior when the chamfer intersects the body other than at adjacent faces. The default is False.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Methods > ChamferFeatures.AddUsingDistanceAndAngle Method


ChamferFeatures.AddUsingTwoDistances Method

ChamferFeatures.AddUsingTwoDistances Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new ChamferFeature that is defined by two distances. The new ChamferFeature is returned.

Visual Basic
Sub AddUsingTwoDistances(Edges As EdgeCollection, Face As Face, DistanceOne As VARIANT, DistanceTwo As VARIANT, ByRef AutomaticEdgeChain As [defaultvalue(-1)] VARIANT_BOOL, ByRef PreserveAllFeatures As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ChamferFeature*)
Parameters
Parameters | Description
Edges | Input edges that define the chamfer. This must be either a single edge or a set of tangent continuous edges.
Face | Input object that specifies which face distance one applies to. The first edge in the list of edges must lie on this face.
DistanceOne | Input Variant that defines the first distance for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
DistanceTwo | Input Variant that defines the second distance for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
AutomaticEdgeChain | Optional input Boolean that defines if automatic edge chaining along tangentially connected edges should be performed. The default is True.
PreserveAllFeatures | Optional Boolean that defines the behavior when the chamfer intersects the body other than at adjacent faces. The default is False.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Methods > ChamferFeatures.AddUsingTwoDistances Method


ChamferFeatures.Item Method

ChamferFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the specified ChamferFeature object from the collection

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ChamferFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Methods > ChamferFeatures.Item Method


ChamferFeatures Properties

ChamferFeatures Properties
Summary

The properties of the ChamferFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Properties


ChamferFeatures.Application Property

ChamferFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Properties > ChamferFeatures.Application Property


ChamferFeatures.Count Property

ChamferFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Properties > ChamferFeatures.Count Property


ChamferFeatures.Type Property

ChamferFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChamferFeatures Interface > ChamferFeatures Properties > ChamferFeatures.Type Property


ChamferNote Interface

ChamferNote Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ChamferNote object represents a chamfer note with an attached leader on a sheet and derives from the LeaderNote object.

Class Hierarchy
Inventor::DrawingNote
    Inventor::LeaderNote
        Inventor::ChamferNote
Visual Basic
Public Interface ChamferNote
Inherits LeaderNote
Notes

Members through which this object may be accessed include:

ChamferNotes.Add

ChamferNotes.Item

You are here: Symbol Reference > Inventor Library > Objects > ChamferNote Interface


ChamferNote Properties

ChamferNote Properties
Summary

The properties of the ChamferNote class are listed here.

Properties
Name | Description
ChamferEdgeOne | Property that returns that first chamfer edge. This can either be a linear DrawingCurve object or a SketchLine object from a sheet sketch.
ChamferEdgeTwo | Property that returns that second chamfer edge. This can either be a linear DrawingCurve object or a SketchLine object from a sheet sketch.
FormattedChamferNote | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
HideValue | Property that gets and sets whether to display the chamfer note value in the note.
You are here: Symbol Reference > Inventor Library > Objects > ChamferNote Interface > ChamferNote Properties


ChamferNote.ChamferEdgeOne Property

ChamferNote.ChamferEdgeOne Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns that first chamfer edge. This can either be a linear DrawingCurve object or a SketchLine object from a sheet sketch.

Visual Basic
Property ChamferEdgeOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChamferNote Interface > ChamferNote Properties > ChamferNote.ChamferEdgeOne Property


ChamferNote.ChamferEdgeTwo Property

ChamferNote.ChamferEdgeTwo Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns that second chamfer edge. This can either be a linear DrawingCurve object or a SketchLine object from a sheet sketch.

Visual Basic
Property ChamferEdgeTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChamferNote Interface > ChamferNote Properties > ChamferNote.ChamferEdgeTwo Property


ChamferNote.FormattedChamferNote Property

ChamferNote.FormattedChamferNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedChamferNote() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ChamferNote Interface > ChamferNote Properties > ChamferNote.FormattedChamferNote Property


ChamferNote.HideValue Property

ChamferNote.HideValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display the chamfer note value in the note.

Visual Basic
Property HideValue() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ChamferNote Interface > ChamferNote Properties > ChamferNote.HideValue Property


ChamferNotes Interface

ChamferNotes Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ChamferNotes collection object provides access to all of the chamfer notes on the sheet.

Class Hierarchy
Inventor::ChamferNotes
Visual Basic
Public Interface ChamferNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.ChamferNotes

You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface


ChamferNotes Methods

ChamferNotes Methods
Summary

The methods of the ChamferNotes class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a chamfer note positioned at the specified point on the sheet.
Item | Property that returns the specified ChamferNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Methods


ChamferNotes.Add Method

ChamferNotes.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a chamfer note positioned at the specified point on the sheet.

Visual Basic
Sub Add(Position As Point2d, ChamferEdgeOne As IDispatch, ChamferEdgeTwo As IDispatch, ByRef DimensionStyle As [optional] VARIANT, Result As [out, retval] ChamferNote*)
Parameters
Parameters | Description
Position | Input Point2d that specifies the position of the chamfer note on the sheet.
ChamferEdgeOne | Input object that specifies the first chamfer edge. This can either be a linear DrawingCurve object or a SketchLine object from a sheet sketch. Use the corresponding DrawingCurve objects for view sketch and model sketch entities. The leader of the chamfer note will point to the center of entity.
ChamferEdgeTwo | Input object that specifies the second chamfer edge. This can either be a linear DrawingCurve object or a SketchLine object from a sheet sketch. Use the corresponding DrawingCurve objects for view sketch and model sketch entities. This object must be connected to the first chamfer edge and at an angle other than 90 degrees, else the method will fail.
DimensionStyle | Optional input Variant that specifies which dimension style to use for the note. The dimension style can be specified by providing the name of an existing style or by supplying a DimensionStyle object.
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Methods > ChamferNotes.Add Method


ChamferNotes.Item Method

ChamferNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified ChamferNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ChamferNote*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Methods > ChamferNotes.Item Method


ChamferNotes Properties

ChamferNotes Properties
Summary

The properties of the ChamferNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kChamferNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Properties


ChamferNotes.Application Property

ChamferNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Properties > ChamferNotes.Application Property


ChamferNotes.Count Property

ChamferNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Properties > ChamferNotes.Count Property


ChamferNotes.Type Property

ChamferNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kChamferNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChamferNotes Interface > ChamferNotes Properties > ChamferNotes.Type Property


ChangeDefinition CoClass

ChangeDefinition CoClass Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.

Class Hierarchy
Inventor::ChangeDefinition
Visual Basic
Public Class ChangeDefinition
Remarks

The ChangeDefinition can be thought of as a factory for ChangeProcessor objects. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ChangeDefinitions.Add

ChangeDefinitions.Item

ChangeProcessorObject.Parent

You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinition CoClass


ChangeDefinitionObject Interface

ChangeDefinitionObject Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.

Class Hierarchy
Inventor::ChangeDefinitionObject
Visual Basic
Public Interface ChangeDefinitionObject
Inherits IDispatch
Remarks

The ChangeDefinition can be thought of as a factory for ChangeProcessor objects. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface


ChangeDefinitionObject Methods

ChangeDefinitionObject Methods
Summary

The methods of the ChangeDefinitionObject class are listed here.

Methods
Methods
Name | Description
CreateChangeProcessor | Method that creates a new ChangeProcessor object, based on this ChangeDefinition.
Delete | Deletes this ChangeDefinition.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Methods


ChangeDefinitionObject.CreateChangeProcessor Method

ChangeDefinitionObject.CreateChangeProcessor Method
Summary

Method that creates a new ChangeProcessor object, based on this ChangeDefinition.

Visual Basic
Sub CreateChangeProcessor(Result As [out, retval] ChangeProcessor*)
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Methods > ChangeDefinitionObject.CreateChangeProcessor Method


ChangeDefinitionObject.Delete Method

ChangeDefinitionObject.Delete Method
Summary

Deletes this ChangeDefinition.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Methods > ChangeDefinitionObject.Delete Method


ChangeDefinitionObject Properties

ChangeDefinitionObject Properties
Summary

The properties of the ChangeDefinitionObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ChangeType | Gets and sets the type of change (shape edit, query only, etc.) that this ChangeDefinition represents. Defaults kShapeEditCmdType.
ClientId | Property that returns the value of the ClientId of the ChangeDefinitions collection to which this object belongs.
CommandName | Property that returns the command name associated with this ChangeDefinition. This localized string shows up in the undo list.
InternalName | Property that returns the internal name of the ChangeDefinition. This is a unique string that may be used to reliably retrieve a ChangeDefinition object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties


ChangeDefinitionObject.Application Property

ChangeDefinitionObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.Application Property


ChangeDefinitionObject.ChangeType Property

ChangeDefinitionObject.ChangeType Property
Summary

Gets and sets the type of change (shape edit, query only, etc.) that this ChangeDefinition represents. Defaults kShapeEditCmdType.

Visual Basic
Property ChangeType() As CommandTypesEnum
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.ChangeType Property


ChangeDefinitionObject.ClientId Property

ChangeDefinitionObject.ClientId Property
Summary

Property that returns the value of the ClientId of the ChangeDefinitions collection to which this object belongs.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.ClientId Property


ChangeDefinitionObject.CommandName Property

ChangeDefinitionObject.CommandName Property
Summary

Property that returns the command name associated with this ChangeDefinition. This localized string shows up in the undo list.

Visual Basic
Property CommandName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.CommandName Property


ChangeDefinitionObject.InternalName Property

ChangeDefinitionObject.InternalName Property
Summary

Property that returns the internal name of the ChangeDefinition. This is a unique string that may be used to reliably retrieve a ChangeDefinition object.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.InternalName Property


ChangeDefinitionObject.Parent Property

ChangeDefinitionObject.Parent Property
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As ChangeManager**
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.Parent Property


ChangeDefinitionObject.Type Property

ChangeDefinitionObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionObject Interface > ChangeDefinitionObject Properties > ChangeDefinitionObject.Type Property


ChangeDefinitions Interface

ChangeDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ChangeDefinitions collection object provides access to all the objects created by a particular client and provides a method to create additional ChangeDefinitions. See the topic in the overview section.

Class Hierarchy
Inventor::ChangeDefinitions
Visual Basic
Public Interface ChangeDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ChangeManager.Add

ChangeManager.Item

You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface


ChangeDefinitions Methods

ChangeDefinitions Methods
Summary

The methods of the ChangeDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ChangeDefinition. The newly created ChangeDefinition is returned.
Delete | Method to delete this collection and all objects contained within it.
Item | Property that returns the specified ChangeDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Methods


ChangeDefinitions.Add Method

ChangeDefinitions.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new ChangeDefinition. The newly created ChangeDefinition is returned.

Visual Basic
Sub Add(InternalName As String, CommandName As String, Result As [out, retval] ChangeDefinition*)
Parameters
Parameters | Description
InternalName | Input String that defines the name of the new ChangeDefinition. The name specified must be unique with respect to the other change definitions in the collection. If a unique name is not specified, an error will occur.
CommandName | Input String that defines the localized command name that will show up in the undo list.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Methods > ChangeDefinitions.Add Method


ChangeDefinitions.Delete Method

ChangeDefinitions.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method to delete this collection and all objects contained within it.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Methods > ChangeDefinitions.Delete Method


ChangeDefinitions.Item Method

ChangeDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified ChangeDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ChangeDefinition*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ChangeDefinition to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ChangeDefinition name. If an out of range index or a name of a non-existent ChangeDefinition is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Methods > ChangeDefinitions.Item Method


ChangeDefinitions Properties

ChangeDefinitions Properties
Summary

The properties of the ChangeDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property indicating the Client Id string that uniquely identifies this definitions collection.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Properties


ChangeDefinitions.Application Property

ChangeDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Properties > ChangeDefinitions.Application Property


ChangeDefinitions.ClientId Property

ChangeDefinitions.ClientId Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property indicating the Client Id string that uniquely identifies this definitions collection.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Properties > ChangeDefinitions.ClientId Property


ChangeDefinitions.Count Property

ChangeDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Properties > ChangeDefinitions.Count Property


ChangeDefinitions.Type Property

ChangeDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitions Interface > ChangeDefinitions Properties > ChangeDefinitions.Type Property


ChangeDefinitionSink Interface

ChangeDefinitionSink Interface
Summary

The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.

Class Hierarchy
Inventor::ChangeDefinitionSink
Visual Basic
Public Interface ChangeDefinitionSink
Inherits IDispatch
Remarks

The ChangeDefinition can be thought of as a factory for ChangeProcessor objects. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionSink Interface


ChangeDefinitionSink Methods

ChangeDefinitionSink Methods
Summary

The methods of the ChangeDefinitionSink class are listed here.

Methods
Methods
Name | Description
OnReplay | Event that is fired by Inventor in a script replay scenario. In the handler of this event (typically, written by the client who created this ChangeDefinition), it is expected that a new ChangeProcessor will be generated using the CreateChangeProcessor method of this object, followed by the client proceeding to 'hook up' its ChangeProcessor handler code, and returning this hooked-up processor back. Inventor will then use this returned ChangeProcessor to replay the scripted command.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionSink Interface > ChangeDefinitionSink Methods


ChangeDefinitionSink.OnReplay Method

ChangeDefinitionSink.OnReplay Method
Summary

Event that is fired by Inventor in a script replay scenario. In the handler of this event (typically, written by the client who created this ChangeDefinition), it is expected that a new ChangeProcessor will be generated using the CreateChangeProcessor method of this object, followed by the client proceeding to 'hook up' its ChangeProcessor handler code, and returning this hooked-up processor back. Inventor will then use this returned ChangeProcessor to replay the scripted command.

Visual Basic
Sub OnReplay(Context As NameValueMap, ByRef ResultProcessor As ChangeProcessor*)
Parameters
Parameters | Description
Context | Input object that can be used to determine the context of why the event fired.
ResultProcessor | The client returns this ChangeProcessor which Autodesk Inventor will use to replay the scripted command.
You are here: Symbol Reference > Inventor Library > Objects > ChangeDefinitionSink Interface > ChangeDefinitionSink Methods > ChangeDefinitionSink.OnReplay Method


ChangeManager Interface

ChangeManager Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ChangeManager object manages the processes involved in making changes to data and recording the change process.

Class Hierarchy
Inventor::ChangeManager
Visual Basic
Public Interface ChangeManager
Inherits IDispatch
Remarks

The ChangeManager object is a collection of ChangeDefinitions collection objects and as such has a Count property. This object also allows for the manipulation of ScriptKeys. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ChangeDefinitionObject.Parent

Application.ChangeManager

You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface


ChangeManager Methods

ChangeManager Methods
Summary

The methods of the ChangeManager class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new collection that will house all of the ChangeDefinition objects to be generated by the corresponding client. The newly created ChangeDefinitions object is returned.
GetObjectFromScriptKey | Method that retrieves the object with the specified string. The script key should have been generated using the GetScriptKeyFromObject method and the document should be in the same or similar state as when the script key was generated.
GetScriptKeyFromObject | Method that generates a key (identifier) for the input object. This key is suitable to use in constructing the Inputs argument of the OnWriteToScript event on the ChangeProcessor object. This key is only intended to be able to identify the specified object in the current state of the document (this is not a robust persistent reference key).
Item | Property that returns the specified object in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Methods


ChangeManager.Add Method

ChangeManager.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new collection that will house all of the ChangeDefinition objects to be generated by the corresponding client. The newly created ChangeDefinitions object is returned.

Visual Basic
Sub Add(ClientId As String, Result As [out, retval] ChangeDefinitions*)
Parameters
Parameters | Description
ClientId | Input string that uniquely identifies the client. Suggestions are the 'ProgID' of the Add-In creating the resource or its CLSID in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", although any unique string is valid. If you do not use a CLSID or a ProgID, it is recommended that you add your application name to the ClientId to help eliminate naming conflicts.
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Methods > ChangeManager.Add Method


ChangeManager.GetObjectFromScriptKey Method

ChangeManager.GetObjectFromScriptKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that retrieves the object with the specified string. The script key should have been generated using the GetScriptKeyFromObject method and the document should be in the same or similar state as when the script key was generated.

Visual Basic
Sub GetObjectFromScriptKey(ScriptKey As String, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
ScriptKey | Script key string of object to retrieve.
Remarks

This script key mechanism is not a substitute for the ReferenceKey functionality. This API is specifically intended to enable third party developers to generate reliable transcript keys during transcript creation, and also to bind back to these keys during transcript replay. As a general rule, do not use script key functionality outside the scope of ChangeProcessor.OnWriteToScript and ChangeProcessor.OnReadFromScript.

You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Methods > ChangeManager.GetObjectFromScriptKey Method


ChangeManager.GetScriptKeyFromObject Method

ChangeManager.GetScriptKeyFromObject Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates a key (identifier) for the input object. This key is suitable to use in constructing the Inputs argument of the OnWriteToScript event on the ChangeProcessor object. This key is only intended to be able to identify the specified object in the current state of the document (this is not a robust persistent reference key).

Visual Basic
Sub GetScriptKeyFromObject(Object As IDispatch, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Object | Object from which to generate key.
Remarks

This script key mechanism is not a substitute for the ReferenceKey functionality. This API is specifically intended to enable third party developers to generate reliable transcript keys during transcript creation, and also to bind back to these keys during transcript replay. As a general rule, do not use script key functionality outside the scope of ChangeProcessor.OnWriteToScript and ChangeProcessor.OnReadFromScript.

You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Methods > ChangeManager.GetScriptKeyFromObject Method


ChangeManager.Item Method

ChangeManager.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ChangeDefinitions*)
Parameters
Parameters | Description
index | Input Variant that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Methods > ChangeManager.Item Method


ChangeManager Properties

ChangeManager Properties
Summary

The properties of the ChangeManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the Application object, the parent of the ChangeManager object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Properties


ChangeManager.Application Property

ChangeManager.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Properties > ChangeManager.Application Property


ChangeManager.Count Property

ChangeManager.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Properties > ChangeManager.Count Property


ChangeManager.Parent Property

ChangeManager.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the Application object, the parent of the ChangeManager object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Properties > ChangeManager.Parent Property


ChangeManager.Type Property

ChangeManager.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChangeManager Interface > ChangeManager Properties > ChangeManager.Type Property


ChangeProcessor CoClass

ChangeProcessor CoClass Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ChangeProcessor object is at the heart of Inventor's transaction and transcripting mechanism, exposed via its public API.

Class Hierarchy
Inventor::ChangeProcessor
Visual Basic
Public Class ChangeProcessor
Remarks

When a database change is to be performed, the client will hook up to this object and call Execute on it. In response, Inventor sets up the machinery and fires back the OnExecute event. In it's turn, the client performs the database edits via calls to the Inventor API. The execution of a single ChangeProcessor object amounts to a single transaction. An Undo action on the part of the end-user will undo all of the database edits that have been performed inside this Execute.If the client using the ChangeProcessor handles the OnWriteToScript, Inventor will also transcript out this transaction. When the transcript is replayed, Inventor expects that the OnReadFromTranscript and the OnReplay on the corresponding ChangeDefinition object will be handled by the client appropriately. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ChangeDefinitionObject.CreateChangeProcessor

You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessor CoClass


ChangeProcessorObject Interface

ChangeProcessorObject Interface
Summary

The ChangeDefinition object is obtained from the ChangeManager object. It's purpose is to provide a ChangeProcessor object via the CreateChangeProcessor method, according to the settings of the ChangeDefinition object.

Class Hierarchy
Inventor::ChangeProcessorObject
Visual Basic
Public Interface ChangeProcessorObject
Inherits IDispatch
Remarks

The ChangeDefinition can be thought of as a factory for ChangeProcessor objects. See the article in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface


ChangeProcessorObject Methods

ChangeProcessorObject Methods
Summary

The methods of the ChangeProcessorObject class are listed here.

Methods
Methods
Name | Description
Execute | Method that executes the ChangeProcessor on the specified document.
SetAffectedDocuments | Method that sets the FullDocumentNames of the documents that will be affected by this change, and optionally the nature of changes to each of those documents.
SetMessageDialogOptions | Method that specifies the buttons that should be available on the message dialog.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Methods


ChangeProcessorObject.Execute Method

ChangeProcessorObject.Execute Method
Summary

Method that executes the ChangeProcessor on the specified document.

Visual Basic
Sub Execute(Document As Document)
Parameters
Parameters | Description
Document | Input Document object that specifies the document in which to make the changes.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Methods > ChangeProcessorObject.Execute Method


ChangeProcessorObject.SetAffectedDocuments Method

ChangeProcessorObject.SetAffectedDocuments Method
Summary

Method that sets the FullDocumentNames of the documents that will be affected by this change, and optionally the nature of changes to each of those documents.

Visual Basic
Sub SetAffectedDocuments(FullDocumentNames As SAFEARRAY(BSTR), ByRef ReasonsForChange As [optional] VARIANT)
Parameters
Parameters | Description
FullDocumentNames | Input array of strings that specifies the full document names of all the documents that will be changed as a part of this change process.
ReasonsForChange | Optional input array of CommandTypesEnum (bit-encoded values) that specifies the type of changes being made to the documents. If the size of this array is not the same as the size of the FullDocumentNames array, an error occurs.
Remarks

This method is particularly helpful for PDM applications that listen to the OnFileDirty event. This event will supply, in its context, all the documents for which the OnFileDirty event will follow. So the PDM system can ignore the subsequent OnFileDirty events and put up a single check-out dialog that shows all files that need to be checked out.

You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Methods > ChangeProcessorObject.SetAffectedDocuments Method


ChangeProcessorObject.SetMessageDialogOptions Method

ChangeProcessorObject.SetMessageDialogOptions Method
Summary

Method that specifies the buttons that should be available on the message dialog.

Visual Basic
Sub SetMessageDialogOptions(AllowAccept As VARIANT_BOOL, AllowEdit As VARIANT_BOOL)
Parameters
Parameters | Description
AllowAccept | Input Boolean that indicates whether the 'Accept' button should be available. This user choice implies that the user would like to continue despite any errors/warnings.
AllowEdit | Input Boolean that indicates whether the 'Edit' button should be available. This user choice implies that implies that the user would like to go back into the command to correct the situation.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Methods > ChangeProcessorObject.SetMessageDialogOptions Method


ChangeProcessorObject Properties

ChangeProcessorObject Properties
Summary

The properties of the ChangeProcessorObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ChangeType | Property that gets and sets the bit-encoded value where the bits indicate the type of change (shape edit, query only, etc.) that this ChangeProcessor will make. The value of this property defaults to the value set in the ChangeType property of the parent ChangeDefinition, but can be overridden.
DisplayMessages | Property that gets and sets whether or not to display error/warning messages during the change process. A value of False indicates that all the messages will be suppressed. When the ChangeProcessor object is created this property is initialized to False. This property should be set before the Execute method is called.
GlobalChangeProcess | Property that gets and sets the flag indicating whether or not to execute the change process as a global transaction.
GlobalChangeProcessAborted | Property that gets the flag indicating whether a global change process has been aborted due to an error. If this property returns True, the API is in a read-only state and all operations will fail until the client returns from the OnExecute call.
MergeWithPrevious | Property that gets and sets whether to merge this change process with the previously committed transaction. When the ChangeProcessor object is created this property is initialized to False. This property should be set before the Execute method is called.
MessageDialogUserChoice | Property that returns a ButtonTypeEnum value indicating the user's choice in the message dialog.
Parent | Property that returns the parent of the ChangeProcessor object.
Transact | Property that gets and sets whether to execute the change process as a transacting one. A non-transacting change process cannot be undone or redone. When the ChangeProcessor object is created this property is initialized to True. This property should be set before the Execute method is called.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties


ChangeProcessorObject.Application Property

ChangeProcessorObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.Application Property


ChangeProcessorObject.ChangeType Property

ChangeProcessorObject.ChangeType Property
Summary

Property that gets and sets the bit-encoded value where the bits indicate the type of change (shape edit, query only, etc.) that this ChangeProcessor will make. The value of this property defaults to the value set in the ChangeType property of the parent ChangeDefinition, but can be overridden.

Visual Basic
Property ChangeType() As CommandTypesEnum
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.ChangeType Property


ChangeProcessorObject.DisplayMessages Property

ChangeProcessorObject.DisplayMessages Property
Summary

Property that gets and sets whether or not to display error/warning messages during the change process. A value of False indicates that all the messages will be suppressed. When the ChangeProcessor object is created this property is initialized to False. This property should be set before the Execute method is called.

Visual Basic
Property DisplayMessages() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.DisplayMessages Property


ChangeProcessorObject.GlobalChangeProcess Property

ChangeProcessorObject.GlobalChangeProcess Property
Summary

Property that gets and sets the flag indicating whether or not to execute the change process as a global transaction.

Visual Basic
Property GlobalChangeProcess() As VARIANT_BOOL
Remarks

A global transaction can be viewed as a top-level transaction. A value of False indicates that a global transaction will not be created. When a change process is executed as a global transaction and an error is encountered, the global transaction is aborted and all further operations will fail until the client returns from the OnExecute call. Use the GlobalChangeProcessAborted property in your error handling code to check whether the global change process has been aborted. If not executed as a global transaction, you have the option of continuing with other operations.

When the ChangeProcessor object is created this property is initialized to False. This property should be set before the Execute method is called.

You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.GlobalChangeProcess Property


ChangeProcessorObject.GlobalChangeProcessAborted Property

ChangeProcessorObject.GlobalChangeProcessAborted Property
Summary

Property that gets the flag indicating whether a global change process has been aborted due to an error. If this property returns True, the API is in a read-only state and all operations will fail until the client returns from the OnExecute call.

Visual Basic
Property GlobalChangeProcessAborted() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.GlobalChangeProcessAborted Property


ChangeProcessorObject.MergeWithPrevious Property

ChangeProcessorObject.MergeWithPrevious Property
Summary

Property that gets and sets whether to merge this change process with the previously committed transaction. When the ChangeProcessor object is created this property is initialized to False. This property should be set before the Execute method is called.

Visual Basic
Property MergeWithPrevious() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.MergeWithPrevious Property


ChangeProcessorObject.MessageDialogUserChoice Property

ChangeProcessorObject.MessageDialogUserChoice Property
Summary

Property that returns a ButtonTypeEnum value indicating the user's choice in the message dialog.

Visual Basic
Property MessageDialogUserChoice() As ButtonTypeEnum*
Remarks

The property returns kAcceptButtonType if there were no messages displayed. The property also returns kAcceptButtonType if the messages were suppressed (by setting the DisplayMessages property to False). The return value can be one of the three values listed below and should be handled as described:

  • kCancelButtonType - Implies that the user does not want to continue. Any partial success during the execution is to be aborted. The command would have thus behaved like a no-op.
  • kAcceptButtonType - Implies that the user would like to continue despite the errors/warnings. The entire operation should return success, with the partially successful results committed to the document(s).
  • kEditButtonType - Implies that the user would like to go back into the command to correct the situation. The entire operation should be aborted, including any partial success and control should be returned back to the command.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.MessageDialogUserChoice Property


ChangeProcessorObject.Parent Property

ChangeProcessorObject.Parent Property
Summary

Property that returns the parent of the ChangeProcessor object.

Visual Basic
Property Parent() As ChangeDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.Parent Property


ChangeProcessorObject.Transact Property

ChangeProcessorObject.Transact Property
Summary

Property that gets and sets whether to execute the change process as a transacting one. A non-transacting change process cannot be undone or redone.

When the ChangeProcessor object is created this property is initialized to True. This property should be set before the Execute method is called.

Visual Basic
Property Transact() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.Transact Property


ChangeProcessorObject.Type Property

ChangeProcessorObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorObject Interface > ChangeProcessorObject Properties > ChangeProcessorObject.Type Property


ChangeProcessorSink Interface

ChangeProcessorSink Interface
Summary

The ChangeProcessor object is at the heart of Inventor's transaction and transcripting mechanism, exposed via its public API.

Class Hierarchy
Inventor::ChangeProcessorSink
Visual Basic
Public Interface ChangeProcessorSink
Inherits IDispatch
Remarks

When a database change is to be performed, the client will hook up to this object and call Execute on it. In response, Inventor sets up the machinery and fires back the OnExecute event. In it's turn, the client performs the database edits via calls to the Inventor API. The execution of a single ChangeProcessor object amounts to a single transaction. An Undo action on the part of the end-user will undo all of the database edits that have been performed inside this Execute.If the client using the ChangeProcessor handles the OnWriteToScript, Inventor will also transcript out this transaction. When the transcript is replayed, Inventor expects that the OnReadFromTranscript and the OnReplay on the corresponding ChangeDefinition object will be handled by the client appropriately. Please refer to the topic in the overview section.

You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorSink Interface


ChangeProcessorSink Methods

ChangeProcessorSink Methods
Summary

The methods of the ChangeProcessorSink class are listed here.

Methods
Methods
Name | Description
OnExecute | Event that is fired when Inventor is in a state to accept changes to data. This is the event where the client application executes its logic on the specified document.
OnReadFromScript | Event that is fired in a replay scenario supplying the cached Inputs string. The client application interprets the inputs and converts them into meaningful data for use in the execution of logic in the OnExecute event. This event is always followed by the OnExecute event.
OnTerminate | Event that is fired when this ChangeProcessor is done being used for the current execution.
OnWriteToScript | Event that is fired before the execution of and commit of the change. The return string should be set with a formatted string of the arguments. The string may be persisted for eventual replay, such as a transcript replay. A semicolon (';') character should be considered a reserved character used as a separator between individual arguments. The recommended format would be a variable name value pair separated by an equal character, with arguments separated by semicolons. For example "Argument1Name=Value1;Argument2Name=Value2"
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorSink Interface > ChangeProcessorSink Methods


ChangeProcessorSink.OnExecute Method

ChangeProcessorSink.OnExecute Method
Summary

Event that is fired when Inventor is in a state to accept changes to data. This is the event where the client application executes its logic on the specified document.

Visual Basic
Sub OnExecute(Document As Document, Context As NameValueMap, ByRef Succeeded As VARIANT_BOOL)
Parameters
Parameters | Description
Document | Input Document object that specifies the document in which the client is to make its changes.
Context | Input object that can be used to determine the context of why the event fired.
Succeeded | The Succeeded argument is an in/out argument, and will always have an initial value of True. Leave it set to true and the change will be committed. If your change fails and you want the change's transaction to be aborted, set this value to False.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorSink Interface > ChangeProcessorSink Methods > ChangeProcessorSink.OnExecute Method


ChangeProcessorSink.OnReadFromScript Method

ChangeProcessorSink.OnReadFromScript Method
Summary

Event that is fired in a replay scenario supplying the cached Inputs string. The client application interprets the inputs and converts them into meaningful data for use in the execution of logic in the OnExecute event. This event is always followed by the OnExecute event.

Visual Basic
Sub OnReadFromScript(Document As Document, Inputs As String, Context As NameValueMap)
Parameters
Parameters | Description
Document | Input Document object that specifies the document in which to make the changes.
Context | Input object that can be used to determine the context of why the event fired.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorSink Interface > ChangeProcessorSink Methods > ChangeProcessorSink.OnReadFromScript Method


ChangeProcessorSink.OnTerminate Method

ChangeProcessorSink.OnTerminate Method
Summary

Event that is fired when this ChangeProcessor is done being used for the current execution.

Visual Basic
Sub OnTerminate()
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorSink Interface > ChangeProcessorSink Methods > ChangeProcessorSink.OnTerminate Method


ChangeProcessorSink.OnWriteToScript Method

ChangeProcessorSink.OnWriteToScript Method
Summary

Event that is fired before the execution of and commit of the change. The return string should be set with a formatted string of the arguments. The string may be persisted for eventual replay, such as a transcript replay. A semicolon (';') character should be considered a reserved character used as a separator between individual arguments. The recommended format would be a variable name value pair separated by an equal character, with arguments separated by semicolons. For example "Argument1Name=Value1;Argument2Name=Value2"

Visual Basic
Sub OnWriteToScript(Document As Document, Context As NameValueMap, ByRef ResultInputs As String)
Parameters
Parameters | Description
Document | Input Document object that specifies the document in which to execute the ChangeProcessor.
Context | Input object that can be used to determine the context of why the event fired.
ResultInputs | Return string - most likely a formatted string of the arguments for eventual replay.
You are here: Symbol Reference > Inventor Library > Objects > ChangeProcessorSink Interface > ChangeProcessorSink Methods > ChangeProcessorSink.OnWriteToScript Method


CheckPoint Interface

CheckPoint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CheckPoint object serves as a bookmark within a transaction. See the article in the overviews section.

Class Hierarchy
Inventor::CheckPoint
Visual Basic
Public Interface CheckPoint
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CheckPointsEnumerator.Item

TransactionManager.SetCheckPoint

You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface


CheckPoint Properties

CheckPoint Properties
Summary

The properties of the CheckPoint class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ContainingTransaction | Gets the transaction in which this check point is defined.
DisplayName | Gets the user-friendly display name of this check point.
Id | Gets the numeric identifier of this check point.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties


CheckPoint.Application Property

CheckPoint.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties > CheckPoint.Application Property


CheckPoint.ContainingTransaction Property

CheckPoint.ContainingTransaction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the transaction in which this check point is defined.

Visual Basic
Property ContainingTransaction() As Transaction**
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties > CheckPoint.ContainingTransaction Property


CheckPoint.DisplayName Property

CheckPoint.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the user-friendly display name of this check point.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties > CheckPoint.DisplayName Property


CheckPoint.Id Property

CheckPoint.Id Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the numeric identifier of this check point.

Visual Basic
Property Id() As long*
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties > CheckPoint.Id Property


CheckPoint.Parent Property

CheckPoint.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As TransactionManager**
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties > CheckPoint.Parent Property


CheckPoint.Type Property

CheckPoint.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CheckPoint Interface > CheckPoint Properties > CheckPoint.Type Property


CheckPointsEnumerator Interface

CheckPointsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

Provides access to a list of CheckPoint objects.

Class Hierarchy
Inventor::CheckPointsEnumerator
Visual Basic
Public Interface CheckPointsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Transaction.CheckPoints

You are here: Symbol Reference > Inventor Library > Objects > CheckPointsEnumerator Interface


CheckPointsEnumerator Methods

CheckPointsEnumerator Methods
Summary

The methods of the CheckPointsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > CheckPointsEnumerator Interface > CheckPointsEnumerator Methods


CheckPointsEnumerator.Item Method

CheckPointsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] CheckPoint*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > CheckPointsEnumerator Interface > CheckPointsEnumerator Methods > CheckPointsEnumerator.Item Method


CheckPointsEnumerator Properties

CheckPointsEnumerator Properties
Summary

The properties of the CheckPointsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CheckPointsEnumerator Interface > CheckPointsEnumerator Properties


CheckPointsEnumerator.Count Property

CheckPointsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CheckPointsEnumerator Interface > CheckPointsEnumerator Properties > CheckPointsEnumerator.Count Property


CheckPointsEnumerator.Type Property

CheckPointsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CheckPointsEnumerator Interface > CheckPointsEnumerator Properties > CheckPointsEnumerator.Type Property


Circle Interface

Circle Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The mathematical Circle object, one of the transient geometry objects.

Class Hierarchy
Inventor::Circle
Visual Basic
Public Interface Circle
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchCircle3D.Geometry

TransientGeometry.CreateCircle

TransientGeometry.CreateCircleByThreePoints

CurveGraphics.Curve

Edge.Geometry

See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > Circle Interface


Circle Methods

Circle Methods
Summary

The methods of the Circle class are listed here.

Methods
Methods
Name | Description
GetCircleData | Get the data defining this circle.
PutCircleData | Method that sets the data defining this circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Methods


Circle.GetCircleData Method

Circle.GetCircleData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this circle.

Visual Basic
Sub GetCircleData(ByRef Center As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef Radius As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the circle's center.
AxisVector | Input/output Double that specifies axis vector.
Radius | Output Double that specifies the radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Methods > Circle.GetCircleData Method


Circle.PutCircleData Method

Circle.PutCircleData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this circle.

Visual Basic
Sub PutCircleData(ByRef Center As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), Radius As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the circle's center.
AxisVector | Input/output Double that specifies axis vector.
Radius | Input Double that specifies the radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Methods > Circle.PutCircleData Method


Circle Properties

Circle Properties
Summary

The properties of the Circle class are listed here.

Properties
Name | Description
Center | The center Point of the circle.
Evaluator | Gets the CurveEvaluator for this circle.
Normal | The normal of the circle.
Radius | The radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Properties


Circle.Center Property

Circle.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The center Point of the circle.

Visual Basic
Property Center() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Properties > Circle.Center Property


Circle.Evaluator Property

Circle.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the CurveEvaluator for this circle.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Properties > Circle.Evaluator Property


Circle.Normal Property

Circle.Normal Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The normal of the circle.

Visual Basic
Property Normal() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Properties > Circle.Normal Property


Circle.Radius Property

Circle.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The radius of the circle.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Circle Interface > Circle Properties > Circle.Radius Property


Circle2d Interface

Circle2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The mathematical Circle2d object - one of the transient objects.

Class Hierarchy
Inventor::Circle2d
Visual Basic
Public Interface Circle2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchCircle.Geometry

TransientGeometry.CreateCircle2d

TransientGeometry.CreateCircle2dByThreePoints

ProfileEntity.Curve

Centerline.Geometry

You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface


Circle2d Methods

Circle2d Methods
Summary

The methods of the Circle2d class are listed here.

Methods
Methods
Name | Description
GetCircleData | Get the data defining this circle.
PutCircleData | Method that sets the data defining this circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Methods


Circle2d.GetCircleData Method

Circle2d.GetCircleData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this circle.

Visual Basic
Sub GetCircleData(ByRef Center As SAFEARRAY(double), ByRef Radius As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the circle's center.
Radius | Output Double that specifies the radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Methods > Circle2d.GetCircleData Method


Circle2d.PutCircleData Method

Circle2d.PutCircleData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this circle.

Visual Basic
Sub PutCircleData(ByRef Center As SAFEARRAY(double), Radius As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the circle's center.
Radius | Input Double that specifies the radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Methods > Circle2d.PutCircleData Method


Circle2d Properties

Circle2d Properties
Summary

The properties of the Circle2d class are listed here.

Properties
Name | Description
Center | The center of the 2D circle.
Evaluator | Gets the Curve2dEvaluator for this circle.
Radius | The radius of the 2D circle.
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Properties


Circle2d.Center Property

Circle2d.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The center of the 2D circle.

Visual Basic
Property Center() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Properties > Circle2d.Center Property


Circle2d.Evaluator Property

Circle2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Curve2dEvaluator for this circle.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Properties > Circle2d.Evaluator Property


Circle2d.Radius Property

Circle2d.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The radius of the 2D circle.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Circle2d Interface > Circle2d Properties > Circle2d.Radius Property


CircularOccurrencePattern Interface

CircularOccurrencePattern Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The CircularOccurrencePattern object represents a circular pattern of assembly occurrences.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::CircularOccurrencePattern
        Inventor::CircularOccurrencePatternProxy
Visual Basic
Public Interface CircularOccurrencePattern
Inherits OccurrencePattern
Notes

Members through which this object may be accessed include:

CircularOccurrencePatternProxy.NativeObject

OccurrencePatterns.AddCircularPattern

You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePattern Interface


CircularOccurrencePattern Properties

CircularOccurrencePattern Properties
Summary

The properties of the CircularOccurrencePattern class are listed here.

Properties
Name | Description
AngleOffset | Property returning the Parameter object that controls the angle offset between pattern instances.
AxisEntity | Property returning the proxy object that defines the axis of the pattern. This will be a proxy to a linear edge or a work axis.
AxisEntityNaturalDirection | Property returning a Boolean that specifies if the rotation direction of the pattern uses the natural direction of the axis entity. If True it uses the natural direction which defines the rotation direction using the right hand rule where the thumb is pointed in the direction of the axis. If False the direction is reversed.
ElementCount | Property returning the Parameter object that controls the number of elements in the pattern.
You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePattern Interface > CircularOccurrencePattern Properties


CircularOccurrencePattern.AngleOffset Property

CircularOccurrencePattern.AngleOffset Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the Parameter object that controls the angle offset between pattern instances.

Visual Basic
Property AngleOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePattern Interface > CircularOccurrencePattern Properties > CircularOccurrencePattern.AngleOffset Property


CircularOccurrencePattern.AxisEntity Property

CircularOccurrencePattern.AxisEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the proxy object that defines the axis of the pattern. This will be a proxy to a linear edge or a work axis.

Visual Basic
Property AxisEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePattern Interface > CircularOccurrencePattern Properties > CircularOccurrencePattern.AxisEntity Property


CircularOccurrencePattern.AxisEntityNaturalDirection Property

CircularOccurrencePattern.AxisEntityNaturalDirection Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning a Boolean that specifies if the rotation direction of the pattern uses the natural direction of the axis entity. If True it uses the natural direction which defines the rotation direction using the right hand rule where the thumb is pointed in the direction of the axis. If False the direction is reversed.

Visual Basic
Property AxisEntityNaturalDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePattern Interface > CircularOccurrencePattern Properties > CircularOccurrencePattern.AxisEntityNaturalDirection Property


CircularOccurrencePattern.ElementCount Property

CircularOccurrencePattern.ElementCount Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the Parameter object that controls the number of elements in the pattern.

Visual Basic
Property ElementCount() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePattern Interface > CircularOccurrencePattern Properties > CircularOccurrencePattern.ElementCount Property


CircularOccurrencePatternProxy Interface

CircularOccurrencePatternProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CircularOccurrencePattern object.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::CircularOccurrencePattern
        Inventor::CircularOccurrencePatternProxy
Visual Basic
Public Interface CircularOccurrencePatternProxy
Inherits CircularOccurrencePattern
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePatternProxy Interface


CircularOccurrencePatternProxy Properties

CircularOccurrencePatternProxy Properties
Summary

The properties of the CircularOccurrencePatternProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePatternProxy Interface > CircularOccurrencePatternProxy Properties


CircularOccurrencePatternProxy.ContainingOccurrence Property

CircularOccurrencePatternProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePatternProxy Interface > CircularOccurrencePatternProxy Properties > CircularOccurrencePatternProxy.ContainingOccurrence Property


CircularOccurrencePatternProxy.NativeObject Property

CircularOccurrencePatternProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CircularOccurrencePattern**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CircularOccurrencePatternProxy Interface > CircularOccurrencePatternProxy Properties > CircularOccurrencePatternProxy.NativeObject Property


CircularPatternFeature Interface

CircularPatternFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CircularPatternFeature object represents circular pattern feature objects.

Class Hierarchy
Inventor::PartFeature
    Inventor::CircularPatternFeature
        Inventor::CircularPatternFeatureProxy
Visual Basic
Public Interface CircularPatternFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CircularPatternFeatureProxy.NativeObject

CircularPatternFeatures.Add

CircularPatternFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface


CircularPatternFeature Methods

CircularPatternFeature Methods
Summary

The methods of the CircularPatternFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Method that adds the specified participant to the assembly feature. This method fails for features in a part.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Methods


CircularPatternFeature.AddParticipant Method

CircularPatternFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds the specified participant to the assembly feature. This method fails for features in a part.

Visual Basic
Sub AddParticipant(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | Input ComponentOccurrence object that specifies the participant to be added. An error occurs if the input ComponentOccurrence is not a leaf occurrence.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Methods > CircularPatternFeature.AddParticipant Method


CircularPatternFeature Properties

CircularPatternFeature Properties
Summary

The properties of the CircularPatternFeature class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter that defines the angle of the pattern. How this parameter is used depends on the value of the FitWithinAngle property.
AxisEntity | Property that gets and sets the axis entity. This can be a linear edge, a work axis, or any face that can define an axis (i.e. every face type except planar and spherical).
ComputeType | Property that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation.
Count | Property that returns the parameter that defines the number of instances in the pattern.
FitWithinAngle | Property that gets and sets how the count and angle are used to space the occurrences. If this property is true then the angle specifies the total sweep made by the pattern and the occurrences are evenly spaced within the angle. If it is false then the angle specifies the angular offset between each occurrence.
MidPlanePattern | Property that gets and sets whether the patterned occurrences should fall on either side of the original.
NaturalAxisDirection | Property that gets and sets the flag that indicates if the direction of the axis is in the natural direction of the AxisEntity or reversed. A value of True indicates it is in the natural direction.
NewBodyOperation | Property that gets and sets whether the feature creates new bodies, rather than modifying the existing body. Applies only when a body is patterned (i.e. when PatternOfBody returns True).
ParentFeatures | Property that gets and sets the parent features of the pattern. The ObjectCollection returned by this property is a 'tear off' and does not affect the pattern if its contents are modified. To change the which features are the parents of the pattern you need to use this property to set the parent features by providing an ObjectCollection that contains the desired set of parent features.
PatternElements | Property that returns the collection that contains the elements created by this pattern.
PatternOfBody | Property that gets whether this pattern resulted from patterning the Surface Body.
SurfacesOpaque | Property that gets and sets whether all the resulting surfaces are opaque or transparent. False by default.
SurfacesVisible | Property that gets and sets whether all the resulting surfaces are visible or not. True by default.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties


CircularPatternFeature.Angle Property

CircularPatternFeature.Angle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that defines the angle of the pattern. How this parameter is used depends on the value of the FitWithinAngle property.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.Angle Property


CircularPatternFeature.AxisEntity Property

CircularPatternFeature.AxisEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the axis entity. This can be a linear edge, a work axis, or any face that can define an axis (i.e. every face type except planar and spherical).

Visual Basic
Property AxisEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.AxisEntity Property


CircularPatternFeature.ComputeType Property

CircularPatternFeature.ComputeType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation.

Visual Basic
Property ComputeType() As PatternComputeTypeEnum
Remarks

If kIdenticalCompute is specified, all occurrences in the pattern use an identical termination, regardless of where they intersect another feature. Use this method to efficiently pattern large numbers of features when the feature being duplicated has a distance termination or terminates on a work plane.

If kAdjustToModelCompute is specified, the termination of each occurrence is calculated individually. Computation time can be lengthy for patterns with a large number of occurrences. You must use this method if the parent feature terminates on a model face.

You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.ComputeType Property


CircularPatternFeature.Count Property

CircularPatternFeature.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that defines the number of instances in the pattern.

Visual Basic
Property Count() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.Count Property


CircularPatternFeature.FitWithinAngle Property

CircularPatternFeature.FitWithinAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the count and angle are used to space the occurrences. If this property is true then the angle specifies the total sweep made by the pattern and the occurrences are evenly spaced within the angle. If it is false then the angle specifies the angular offset between each occurrence.

Visual Basic
Property FitWithinAngle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.FitWithinAngle Property


CircularPatternFeature.MidPlanePattern Property

CircularPatternFeature.MidPlanePattern Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the patterned occurrences should fall on either side of the original.

Visual Basic
Property MidPlanePattern() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.MidPlanePattern Property


CircularPatternFeature.NaturalAxisDirection Property

CircularPatternFeature.NaturalAxisDirection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the flag that indicates if the direction of the axis is in the natural direction of the AxisEntity or reversed. A value of True indicates it is in the natural direction.

Visual Basic
Property NaturalAxisDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.NaturalAxisDirection Property


CircularPatternFeature.NewBodyOperation Property

CircularPatternFeature.NewBodyOperation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the feature creates new bodies, rather than modifying the existing body. Applies only when a body is patterned (i.e. when PatternOfBody returns True).

Visual Basic
Property NewBodyOperation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.NewBodyOperation Property


CircularPatternFeature.ParentFeatures Property

CircularPatternFeature.ParentFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the parent features of the pattern. The ObjectCollection returned by this property is a 'tear off' and does not affect the pattern if its contents are modified. To change the which features are the parents of the pattern you need to use this property to set the parent features by providing an ObjectCollection that contains the desired set of parent features.

Visual Basic
Property ParentFeatures() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.ParentFeatures Property


CircularPatternFeature.PatternElements Property

CircularPatternFeature.PatternElements Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the collection that contains the elements created by this pattern.

Visual Basic
Property PatternElements() As FeaturePatternElements**
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.PatternElements Property


CircularPatternFeature.PatternOfBody Property

CircularPatternFeature.PatternOfBody Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether this pattern resulted from patterning the Surface Body.

Visual Basic
Property PatternOfBody() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.PatternOfBody Property


CircularPatternFeature.SurfacesOpaque Property

CircularPatternFeature.SurfacesOpaque Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether all the resulting surfaces are opaque or transparent. False by default.

Visual Basic
Property SurfacesOpaque() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.SurfacesOpaque Property


CircularPatternFeature.SurfacesVisible Property

CircularPatternFeature.SurfacesVisible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether all the resulting surfaces are visible or not. True by default.

Visual Basic
Property SurfacesVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeature Interface > CircularPatternFeature Properties > CircularPatternFeature.SurfacesVisible Property


CircularPatternFeatureProxy Interface

CircularPatternFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CircularPatternFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CircularPatternFeature
        Inventor::CircularPatternFeatureProxy
Visual Basic
Public Interface CircularPatternFeatureProxy
Inherits CircularPatternFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatureProxy Interface


CircularPatternFeatureProxy Properties

CircularPatternFeatureProxy Properties
Summary

The properties of the CircularPatternFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatureProxy Interface > CircularPatternFeatureProxy Properties


CircularPatternFeatureProxy.ContainingOccurrence Property

CircularPatternFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatureProxy Interface > CircularPatternFeatureProxy Properties > CircularPatternFeatureProxy.ContainingOccurrence Property


CircularPatternFeatureProxy.NativeObject Property

CircularPatternFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CircularPatternFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatureProxy Interface > CircularPatternFeatureProxy Properties > CircularPatternFeatureProxy.NativeObject Property


CircularPatternFeatures Interface

CircularPatternFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CircularPatternFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional CircularPatternFeature objects.

Class Hierarchy
Inventor::CircularPatternFeatures
Visual Basic
Public Interface CircularPatternFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.CircularPatternFeatures

FlatPatternFeatures.CircularPatternFeatures

PartFeatures.CircularPatternFeatures

You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface


CircularPatternFeatures Methods

CircularPatternFeatures Methods
Summary

The methods of the CircularPatternFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new CircularPatternFeature object. The new CircularPatternFeature object is returned.
Item | Property that returns the specified CircularPatternFeature object from the collection. This is the default property of the CircularPatternFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Methods


CircularPatternFeatures.Add Method

CircularPatternFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new CircularPatternFeature object. The new CircularPatternFeature object is returned.

Visual Basic
Sub Add(ParentFeatures As ObjectCollection, AxisEntity As IDispatch, NaturalAxisDirection As VARIANT_BOOL, Count As VARIANT, Angle As VARIANT, FitWithinAngle As VARIANT_BOOL, ByRef ComputeType As [defaultvalue(kOptimizedCompute)] PatternComputeTypeEnum, Result As [out, retval] CircularPatternFeature*)
Parameters
Parameters | Description
ParentFeatures | ObjectCollection object that contains the features to be patterned. The collection could contain the various part features, sheet metal features, work planes, work axes, work points, or a SurfaceBody. Only the primary (result) surface body, obtained from ComponentDefinition.SurfaceBodies.Item(1) is a valid input. If a SurfaceBody is supplied, the only other objects that can be in the collection are work features and surface part features.
AxisEntity | Input object that returns the axis entity. This can be a linear edge, a work axis, or any face that can define an axis (i.e. every face type except planar and spherical).
NaturalAxisDirection | Input Boolean that defines if the sketch plane X or Y axis is in the same direction as that defined by the input axis entity. True indicates the axis direction is in the same direction as that of the input entity.
Count | Input Variant that defines the number of instances in the pattern.
Angle | Input Variant that defines the angle of the pattern
FitWithinAngle | Input Boolean that indicates how the count and angle are used to space the occurrences. If this value is true then the angle specifies the total sweep made by the pattern and the occurrences are evenly spaced within the angle. If it is false then the angle specifies the angular offset between each occurrence.
ComputeType | Property that that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation. If kIdenticalCompute is specified, all occurrences in the pattern use an identical termination, regardless of where they intersect another feature. Use this method to efficiently pattern large numbers of features when the feature being duplicated has a distance termination or terminates on a work plane. If kAdjustToModelCompute is specified, the termination of each occurrence is calculated individually. Computation time can be lengthy for patterns with a large number of occurrences. You must use this method if the parent feature terminates on a model face.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Methods > CircularPatternFeatures.Add Method


CircularPatternFeatures.Item Method

CircularPatternFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified CircularPatternFeature object from the collection. This is the default property of the CircularPatternFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CircularPatternFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Methods > CircularPatternFeatures.Item Method


CircularPatternFeatures Properties

CircularPatternFeatures Properties
Summary

The properties of the CircularPatternFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Properties


CircularPatternFeatures.Application Property

CircularPatternFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Properties > CircularPatternFeatures.Application Property


CircularPatternFeatures.Count Property

CircularPatternFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Properties > CircularPatternFeatures.Count Property


CircularPatternFeatures.Type Property

CircularPatternFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CircularPatternFeatures Interface > CircularPatternFeatures Properties > CircularPatternFeatures.Type Property


ClientApplication Interface

ClientApplication Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

ClientApplication object. Reserved - for future use.

Class Hierarchy
Inventor::ClientApplication
Visual Basic
Public Interface ClientApplication
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ClientApplication Interface


ClientApplication Methods

ClientApplication Methods
Summary

The methods of the ClientApplication class are listed here.

Methods
Methods
Name | Description
GetXMLData | Output application specific data as XML . Reserved - for future use.
PutXMLData | Read application specific data from XML . Reserved - for future use.
You are here: Symbol Reference > Inventor Library > Objects > ClientApplication Interface > ClientApplication Methods


ClientApplication.GetXMLData Method

ClientApplication.GetXMLData Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Output application specific data as XML . Reserved - for future use.

Visual Basic
Sub GetXMLData(DocumentName As VARIANT, ControlData As String, ByRef OutputData As String, ByRef Status As String)
Parameters
Parameters | Description
DocumentName | Reserved - for future use.
ControlData | Reserved - for future use.
OutputData | Reserved - for future use.
Status | Reserved - for future use.
You are here: Symbol Reference > Inventor Library > Objects > ClientApplication Interface > ClientApplication Methods > ClientApplication.GetXMLData Method


ClientApplication.PutXMLData Method

ClientApplication.PutXMLData Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Read application specific data from XML . Reserved - for future use.

Visual Basic
Sub PutXMLData(DocumentName As VARIANT, ControlData As String, InputData As String, ByRef Status As String)
Parameters
Parameters | Description
DocumentName | Reserved - for future use.
ControlData | Reserved - for future use.
InputData | Reserved - for future use.
Status | Reserved - for future use.
You are here: Symbol Reference > Inventor Library > Objects > ClientApplication Interface > ClientApplication Methods > ClientApplication.PutXMLData Method


ClientBrowserNodeDefinition CoClass

ClientBrowserNodeDefinition CoClass Available in Inventor Introduced in Inventor 8
Summary

The ClientBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a client-created node in the browser.

Class Hierarchy
Inventor::ClientBrowserNodeDefinition
Visual Basic
Public Class ClientBrowserNodeDefinition
Notes

Members through which this object may be accessed include:

BrowserPanes.CreateBrowserNodeDefinition

BrowserPanes.GetClientBrowserNodeDefinition

You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinition CoClass


ClientBrowserNodeDefinitionObject Interface

ClientBrowserNodeDefinitionObject Interface
Summary

The ClientBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a client-created node in the browser.

Class Hierarchy
Inventor::BrowserNodeDefinition
    Inventor::ClientBrowserNodeDefinitionObject
Visual Basic
Public Interface ClientBrowserNodeDefinitionObject
Inherits BrowserNodeDefinition
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface


ClientBrowserNodeDefinitionObject Methods

ClientBrowserNodeDefinitionObject Methods
Summary

The methods of the ClientBrowserNodeDefinitionObject class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this definition object. Deleting this definition will cause all browser nodes using this definition to be deleted.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetLabel | Method that sets the label of the definition. This is the string that is displayed through the UI.
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Methods


ClientBrowserNodeDefinitionObject.Delete Method

ClientBrowserNodeDefinitionObject.Delete Method
Summary

Method that deletes this definition object. Deleting this definition will cause all browser nodes using this definition to be deleted.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Methods > ClientBrowserNodeDefinitionObject.Delete Method


ClientBrowserNodeDefinitionObject.GetReferenceKey Method

ClientBrowserNodeDefinitionObject.GetReferenceKey Method
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Methods > ClientBrowserNodeDefinitionObject.GetReferenceKey Method


ClientBrowserNodeDefinitionObject.SetLabel Method

ClientBrowserNodeDefinitionObject.SetLabel Method
Summary

Method that sets the label of the definition. This is the string that is displayed through the UI.

Visual Basic
Sub SetLabel(Label As String)
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Methods > ClientBrowserNodeDefinitionObject.SetLabel Method


ClientBrowserNodeDefinitionObject Properties

ClientBrowserNodeDefinitionObject Properties
Summary

The properties of the ClientBrowserNodeDefinitionObject class are listed here.

Properties
Name | Description
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ExpandedIcon | Property that gets and sets the icon that is used when the corresponding BrowserNode is in an expanded state. This may return Nothing. In this case, the expanded state of the BrowserNode uses the Icon.
Icon | Property that gets and sets the icon that is used when the corresponding BrowserNode is in a non-expanded state or collapsed state.
Id | Property that returns the client-supplied id of the ClientBrowserNode.
IsReferenced | Gets whether this ClientBrowserNodeDefinition object is used by any browser nodes.
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Properties


ClientBrowserNodeDefinitionObject.AttributeSets Property

ClientBrowserNodeDefinitionObject.AttributeSets Property
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Properties > ClientBrowserNodeDefinitionObject.AttributeSets Property


ClientBrowserNodeDefinitionObject.ExpandedIcon Property

ClientBrowserNodeDefinitionObject.ExpandedIcon Property
Summary

Property that gets and sets the icon that is used when the corresponding BrowserNode is in an expanded state. This may return Nothing. In this case, the expanded state of the BrowserNode uses the Icon.

Visual Basic
Property ExpandedIcon() As ClientNodeResource*
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Properties > ClientBrowserNodeDefinitionObject.ExpandedIcon Property


ClientBrowserNodeDefinitionObject.Icon Property

ClientBrowserNodeDefinitionObject.Icon Property
Summary

Property that gets and sets the icon that is used when the corresponding BrowserNode is in a non-expanded state or collapsed state.

Visual Basic
Property Icon() As ClientNodeResource*
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Properties > ClientBrowserNodeDefinitionObject.Icon Property


ClientBrowserNodeDefinitionObject.Id Property

ClientBrowserNodeDefinitionObject.Id Property
Summary

Property that returns the client-supplied id of the ClientBrowserNode.

Visual Basic
Property Id() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Properties > ClientBrowserNodeDefinitionObject.Id Property


ClientBrowserNodeDefinitionObject.IsReferenced Property

ClientBrowserNodeDefinitionObject.IsReferenced Property
Summary

Gets whether this ClientBrowserNodeDefinition object is used by any browser nodes.

Visual Basic
Property IsReferenced() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionObject Interface > ClientBrowserNodeDefinitionObject Properties > ClientBrowserNodeDefinitionObject.IsReferenced Property


ClientBrowserNodeDefinitionSink Interface

ClientBrowserNodeDefinitionSink Interface
Summary

The ClientBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a client-created node in the browser.

Class Hierarchy
Inventor::ClientBrowserNodeDefinitionSink
Visual Basic
Public Interface ClientBrowserNodeDefinitionSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ClientBrowserNodeDefinitionSink Interface


ClientFeature Interface

ClientFeature Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The ClientFeature object represents a client feature in a part or an assembly document. A client feature is stored in Inventor's data model, and it's behaviors are provided jointly by Inventor and the client. It is an object that can composite other objects, and it can persist client graphics with a document.

Class Hierarchy
Inventor::PartFeature
    Inventor::ClientFeature
        Inventor::ClientFeatureProxy
Visual Basic
Public Interface ClientFeature
Inherits PartFeature
Remarks

When a client features composites other objects, it can "own" the following objects:

  • Features
  • Work features
  • Sketches
  • 3D Sketches
  • Client graphics
  • Parameters
  • Derived components
  • Other client features

When a client feature owns another object, that object is deleted when the client feature is deleted, but the object cannot be deleted independantly of the client feature. The client feature can be deleted even if the creator of the client feature is not present, but if the creator is present, it may provide an 'explode' behavior.

An object cannot be owned by more than one client feature, and all owned objects must be contiguous in the feature tree (note that all owned objects continue to exist in their original collections). The client feature can be reordered in the browser if the owned objects can be reordered as a set. The "IsOwnedByFeature" and "OwnedBy" properties on objects indicate ownership by a client feature.

Inventor does not provide any edit capabilities, so to provide edit capability, the creator must add the "Edit Feature" command to the context menu of the feature.

A client feature provides the only mechanism to persist client graphics in Inventor, and lets users select and delete unwanted graphics. Either the creator or the user can be given the ability to control the color of client graphics.

The properties and methods listed for the ClientFeature object are derived from the PartFeature object, but please be aware that not all can be applied to Client Features. Trying to use a property or method that does not make sense in a Client Features context will fail.

Notes

Members through which this object may be accessed include:

ClientFeatureDefinition.Parent

ClientFeatureProxy.NativeObject

ClientFeatures.Add

ClientFeatures.Item

Example

"Remove client feature elements"

The simplest way to revert a model with client features to Inventor-only features (so the browser contains only native features) is to iterate through and delete the client feature elements and then delete the client feature, as in this sample. However, to preserve application-specific features, the application should perform any required feature conversions before deleting the client feature.

Sub ExplodeClientFeature()
    Dim doc As PartDocument
    Set doc = ThisApplication.ActiveDocument
    Dim feat As ClientFeature
    For Each feat In doc.ComponentDefinition.Features.ClientFeatures
        Dim featDef As ClientFeatureDefinition
        Set featDef = feat.Definition
        Dim elem As ClientFeatureElement
        For Each elem In featDef.ClientFeatureElements
            elem.Delete
        Next
        feat.Delete
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ClientFeature Interface


ClientFeature Properties

ClientFeature Properties
Summary

The properties of the ClientFeature class are listed here.

Properties
Name | Description
BrowserNode | Property that returns the BrowserNode object in the model browser associated with this client feature.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
Definition | Property that returns the ClientFeatureDefinition object that specifies the various inputs used to create the feature.
HiddenParameters | Property that gets and sets the collection of Parameters that are to be hidden from the user.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeature Interface > ClientFeature Properties


ClientFeature.BrowserNode Property

ClientFeature.BrowserNode Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the BrowserNode object in the model browser associated with this client feature.

Visual Basic
Property BrowserNode() As BrowserNode**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeature Interface > ClientFeature Properties > ClientFeature.BrowserNode Property


ClientFeature.ClientId Property

ClientFeature.ClientId Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeature Interface > ClientFeature Properties > ClientFeature.ClientId Property


ClientFeature.Definition Property

ClientFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ClientFeatureDefinition object that specifies the various inputs used to create the feature.

Visual Basic
Property Definition() As ClientFeatureDefinition**
See Also

Remove client feature elements sample

You are here: Symbol Reference > Inventor Library > Objects > ClientFeature Interface > ClientFeature Properties > ClientFeature.Definition Property


ClientFeature.HiddenParameters Property

ClientFeature.HiddenParameters Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the collection of Parameters that are to be hidden from the user.

Visual Basic
Property HiddenParameters() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeature Interface > ClientFeature Properties > ClientFeature.HiddenParameters Property


ClientFeatureDefinition Interface

ClientFeatureDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The ClientFeatureDefinition object is used to define and query all the inputs of a ClientFeature.

Class Hierarchy
Inventor::ClientFeatureDefinition
Visual Basic
Public Interface ClientFeatureDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ClientFeature.Definition

ClientFeatureElement.Parent

ClientFeatures.CreateDefinition

See Also

Remove client feature elements sample

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface


ClientFeatureDefinition Methods

ClientFeatureDefinition Methods
Summary

The methods of the ClientFeatureDefinition class are listed here.

Methods
Methods
Name | Description
AddDependency | Method that adds an upstream Inventor object as a dependency of the client feature.
RemoveDependency | Method that removes a dependency of the client feature.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Methods


ClientFeatureDefinition.AddDependency Method

ClientFeatureDefinition.AddDependency Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that adds an upstream Inventor object as a dependency of the client feature.

Visual Basic
Sub AddDependency(Dependency As IDispatch)
Parameters
Parameters | Description
Dependency | Input Object that specifies the dependency. This can be any of the following: Parameter, PartFeature, Sketch, Sketch3D, WorkPlane, WorkPoint, WorkAxis, DerivedPartComponent and DerivedAssemblyComponent. If a Parameter is input, the parameter is deleted when the client feature is deleted (unless the parameter has dependents other than the client feature).
Remarks

Calling this method causes the OnClientFeatureSolve event for fire for this client feature if any of the dependents are recomputed. The IsCustomSolved flag must be set to True in order for the event to fire.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Methods > ClientFeatureDefinition.AddDependency Method


ClientFeatureDefinition.RemoveDependency Method

ClientFeatureDefinition.RemoveDependency Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that removes a dependency of the client feature.

Visual Basic
Sub RemoveDependency(Dependency As IDispatch)
Parameters
Parameters | Description
Dependency | Input Object that specifies the dependency. This can be any of the following: Parameter, PartFeature, Sketch, Sketch3D, WorkPlane, WorkPoint, WorkAxis, DerivedPartComponent and DerivedAssemblyComponent.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Methods > ClientFeatureDefinition.RemoveDependency Method


ClientFeatureDefinition Properties

ClientFeatureDefinition Properties
Summary

The properties of the ClientFeatureDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientFeatureElements | Property that returns the ClientFeatureElements collection object that defines the Inventor objects composited by this feature.
ClientGraphicsCollection | Property that returns the ClientGraphicsCollection object. These graphics are persisted with the document.
FeatureInputs | Property that gets and sets the objects that are inputs to the client feature. The inputs are currently limited to 2D & 3D sketches.
FeatureType | Property that defines the naming of the client feature in the browser. This property returns a non-localized string supplied during the creation.
GraphicsDataSetsCollection | This is GraphicsDataSetsCollection, a member of class ClientFeatureDefinition.
HighlightClientGraphicsWithFeature | Property that gets and sets whether client graphics owned by this feature should be pre-highlighted, highlighted or selected with the client feature. The property defaults to a value of True.
Parent | Property that returns the parent ClientFeature object. The property returns Nothing in the forward create scenario (i.e. when the object is created using ClientFeatures.CreateDefinition method).
Type | Property returning kClientFeatureDefinitionObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties


ClientFeatureDefinition.Application Property

ClientFeatureDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.Application Property


ClientFeatureDefinition.ClientFeatureElements Property

ClientFeatureDefinition.ClientFeatureElements Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ClientFeatureElements collection object that defines the Inventor objects composited by this feature.

Visual Basic
Property ClientFeatureElements() As ClientFeatureElements**
See Also

Remove client feature elements sample

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.ClientFeatureElements Property


ClientFeatureDefinition.ClientGraphicsCollection Property

ClientFeatureDefinition.ClientGraphicsCollection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ClientGraphicsCollection object. These graphics are persisted with the document.

Visual Basic
Property ClientGraphicsCollection() As ClientGraphicsCollection**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.ClientGraphicsCollection Property


ClientFeatureDefinition.FeatureInputs Property

ClientFeatureDefinition.FeatureInputs Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the objects that are inputs to the client feature. The inputs are currently limited to 2D & 3D sketches.

Visual Basic
Property FeatureInputs() As ObjectCollection*
Remarks

The inputs must be above the feature in the browser. When sketches are specified as inputs, the behavior is the same as a regular Inventor feature (such as Extrude) consuming a sketch. The sketch appears under the client feature and can be 'shared' by the user so it is usable in other downstream features. The input objects are not 'strongly owned' by the client feature. i.e. when the client feature is deleted, the user has the option to retain the feature inputs. The feature inputs do not highlight with the client feature.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.FeatureInputs Property


ClientFeatureDefinition.FeatureType Property

ClientFeatureDefinition.FeatureType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that defines the naming of the client feature in the browser. This property returns a non-localized string supplied during the creation.

Visual Basic
Property FeatureType() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.FeatureType Property


ClientFeatureDefinition.GraphicsDataSetsCollection Property

ClientFeatureDefinition.GraphicsDataSetsCollection Property
Summary

This is GraphicsDataSetsCollection, a member of class ClientFeatureDefinition.

Visual Basic
Property GraphicsDataSetsCollection() As GraphicsDataSetsCollection**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.GraphicsDataSetsCollection Property


ClientFeatureDefinition.HighlightClientGraphicsWithFeature Property

ClientFeatureDefinition.HighlightClientGraphicsWithFeature Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether client graphics owned by this feature should be pre-highlighted, highlighted or selected with the client feature. The property defaults to a value of True.

Visual Basic
Property HighlightClientGraphicsWithFeature() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.HighlightClientGraphicsWithFeature Property


ClientFeatureDefinition.Parent Property

ClientFeatureDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent ClientFeature object. The property returns Nothing in the forward create scenario (i.e. when the object is created using ClientFeatures.CreateDefinition method).

Visual Basic
Property Parent() As ClientFeature**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.Parent Property


ClientFeatureDefinition.Type Property

ClientFeatureDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kClientFeatureDefinitionObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureDefinition Interface > ClientFeatureDefinition Properties > ClientFeatureDefinition.Type Property


ClientFeatureElement Interface

ClientFeatureElement Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Represents a composited Inventor object within a ClientFeature.

Class Hierarchy
Inventor::ClientFeatureElement
    Inventor::ClientFeatureElementProxy
Visual Basic
Public Interface ClientFeatureElement
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ClientFeatureElementProxy.NativeObject

ClientFeatureElements.Add

ClientFeatureElements.Item

See Also

Remove client feature elements sample

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface


ClientFeatureElement Methods

ClientFeatureElement Methods
Summary

The methods of the ClientFeatureElement class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this element of the client feature
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Methods


ClientFeatureElement.Delete Method

ClientFeatureElement.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes this element of the client feature

Visual Basic
Sub Delete()
Remarks

This method fails if the element is not the first or the last element of the client feature. This method only removes the element from the ClientFeature and does not delete the underlying native object.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Methods > ClientFeatureElement.Delete Method


ClientFeatureElement Properties

ClientFeatureElement Properties
Summary

The properties of the ClientFeatureElement class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BrowserVisible | Property that gets and sets whether this element is visible in the browser under the ClientFeature node. This property defaults to False.
Element |
HighlightWithFeature | Property that gets and sets whether this element should be pre-highlighted, highlighted or selected when the client feature is pre-highlighted, highlighted or selected. This property defaults to True for all elements except for sketches.
Parent |
Type |
UserEditable | Property that gets and sets whether this element can be edited by the user. This property defaults to False.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties


ClientFeatureElement.Application Property

ClientFeatureElement.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.Application Property


ClientFeatureElement.BrowserVisible Property

ClientFeatureElement.BrowserVisible Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether this element is visible in the browser under the ClientFeature node. This property defaults to False.

Visual Basic
Property BrowserVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.BrowserVisible Property


ClientFeatureElement.Element Property

ClientFeatureElement.Element Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property Element() As IDispatch**
Remarks

Property that returns the Inventor object composited by this feature. This can be a PartFeature, DerivedPartComponent, DerivedAssemblyComponent, iFeatureComponent, Sketch, Sketch3D, WorkPoint, WorkPlane, or a WorkAxis.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.Element Property


ClientFeatureElement.HighlightWithFeature Property

ClientFeatureElement.HighlightWithFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether this element should be pre-highlighted, highlighted or selected when the client feature is pre-highlighted, highlighted or selected. This property defaults to True for all elements except for sketches.

Visual Basic
Property HighlightWithFeature() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.HighlightWithFeature Property


ClientFeatureElement.Parent Property

ClientFeatureElement.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property Parent() As ClientFeatureDefinition**
Remarks

Property that returns the parent ClientFeatureDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.Parent Property


ClientFeatureElement.Type Property

ClientFeatureElement.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property Type() As ObjectTypeEnum*
Remarks

Property returning kClientFeatureElementObject indicating this object's type.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.Type Property


ClientFeatureElement.UserEditable Property

ClientFeatureElement.UserEditable Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether this element can be edited by the user. This property defaults to False.

Visual Basic
Property UserEditable() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElement Interface > ClientFeatureElement Properties > ClientFeatureElement.UserEditable Property


ClientFeatureElementProxy Interface

ClientFeatureElementProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ClientFeatureElement object.

Class Hierarchy
Inventor::ClientFeatureElement
    Inventor::ClientFeatureElementProxy
Visual Basic
Public Interface ClientFeatureElementProxy
Inherits ClientFeatureElement
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElementProxy Interface


ClientFeatureElementProxy Properties

ClientFeatureElementProxy Properties
Summary

The properties of the ClientFeatureElementProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElementProxy Interface > ClientFeatureElementProxy Properties


ClientFeatureElementProxy.ContainingOccurrence Property

ClientFeatureElementProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElementProxy Interface > ClientFeatureElementProxy Properties > ClientFeatureElementProxy.ContainingOccurrence Property


ClientFeatureElementProxy.NativeObject Property

ClientFeatureElementProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ClientFeatureElement**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElementProxy Interface > ClientFeatureElementProxy Properties > ClientFeatureElementProxy.NativeObject Property


ClientFeatureElements Interface

ClientFeatureElements Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Provides access to the composited elements within a ClientFeature and provides methods to add elements.

Class Hierarchy
Inventor::ClientFeatureElements
Visual Basic
Public Interface ClientFeatureElements
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ClientFeatureDefinition.ClientFeatureElements

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface


ClientFeatureElements Methods

ClientFeatureElements Methods
Summary

The methods of the ClientFeatureElements class are listed here.

Methods
Methods
Name | Description
Add | Method that adds an element to the client feature definition and returns a ClientFeatureElement object.
Item | Method that returns the specified ClientFeatureElement object from the collection. This is the default method of the ClientFeatureElement collection object.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Methods


ClientFeatureElements.Add Method

ClientFeatureElements.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that adds an element to the client feature definition and returns a ClientFeatureElement object.

Visual Basic
Sub Add(Element As IDispatch, ByRef BrowserVisible As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ClientFeatureElement*)
Parameters
Parameters | Description
Element | Input Object that specifies an object to add to the client feature. The input object must correspond to a node in the browser tree. This method fails if the input object is not adjacent to the client feature in the browser tree in the case where the client feature already composites certain elements. If the ClientFeature does not already composite any native object, the ClientFeature is moved to the position of the element in the browser. This can be a PartFeature, DerivedPartComponent, DerivedAssemblyComponent, iFeatureComponent, Sketch, Sketch3D, WorkPoint, WorkPlane, or a WorkAxis.
BrowserVisible | Optional input Boolean that indicates whether this element is visible in the browser under the client feature node. If not specified, the argument defaults to False.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Methods > ClientFeatureElements.Add Method


ClientFeatureElements.Item Method

ClientFeatureElements.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the specified ClientFeatureElement object from the collection. This is the default method of the ClientFeatureElement collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ClientFeatureElement*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the ClientFeatureElement to return.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Methods > ClientFeatureElements.Item Method


ClientFeatureElements Properties

ClientFeatureElements Properties
Summary

The properties of the ClientFeatureElements class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning kClientFeatureElementsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Properties


ClientFeatureElements.Application Property

ClientFeatureElements.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Properties > ClientFeatureElements.Application Property


ClientFeatureElements.Count Property

ClientFeatureElements.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Properties > ClientFeatureElements.Count Property


ClientFeatureElements.Type Property

ClientFeatureElements.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kClientFeatureElementsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureElements Interface > ClientFeatureElements Properties > ClientFeatureElements.Type Property


ClientFeatureProxy Interface

ClientFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ClientFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ClientFeature
        Inventor::ClientFeatureProxy
Visual Basic
Public Interface ClientFeatureProxy
Inherits ClientFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureProxy Interface


ClientFeatureProxy Properties

ClientFeatureProxy Properties
Summary

The properties of the ClientFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureProxy Interface > ClientFeatureProxy Properties


ClientFeatureProxy.ContainingOccurrence Property

ClientFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureProxy Interface > ClientFeatureProxy Properties > ClientFeatureProxy.ContainingOccurrence Property


ClientFeatureProxy.NativeObject Property

ClientFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ClientFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatureProxy Interface > ClientFeatureProxy Properties > ClientFeatureProxy.NativeObject Property


ClientFeatures Interface

ClientFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The ClientFeatures collection object provides access to client features and provides methods to create additional client features.

Class Hierarchy
Inventor::ClientFeatures
Visual Basic
Public Interface ClientFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.ClientFeatures

PartFeatures.ClientFeatures

You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface


ClientFeatures Methods

ClientFeatures Methods
Summary

The methods of the ClientFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ClientFeature. The newly created ClientFeature is returned.
CreateDefinition | Method that creates a new ClientFeatureDefinition. The newly created ClientFeatureDefinition is returned.
Item | Property that returns the specified ClientFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Methods


ClientFeatures.Add Method

ClientFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new ClientFeature. The newly created ClientFeature is returned.

Visual Basic
Sub Add(Definition As ClientFeatureDefinition, ClientId As String, Result As [out, retval] ClientFeature*)
Parameters
Parameters | Description
Definition | Input ClientFeatureDefinition object created using the CreateDefinition method.
ClientId | Input string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Methods > ClientFeatures.Add Method


ClientFeatures.CreateDefinition Method

ClientFeatures.CreateDefinition Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new ClientFeatureDefinition. The newly created ClientFeatureDefinition is returned.

Visual Basic
Sub CreateDefinition(ByRef FeatureType As [defaultvalue("")] BSTR, ByRef StartElement As [optional] VARIANT, ByRef EndElement As [optional] VARIANT, ByRef FeatureInputs As [optional] VARIANT, Result As [out, retval] ClientFeatureDefinition*)
Parameters
Parameters | Description
FeatureType | Optional input string that defines the naming of the client feature in the browser. If not specified, a default string 'ClientFeature' is used.
StartElement | Optional input object that specifies the first element to be composited in this feature. This object must correspond to a node in the browser. This can be a PartFeature, DerivedPartComponent, DerivedAssemblyComponent, iFeatureComponent, Sketch, Sketch3D, WorkPoint, WorkPlane, or a WorkAxis.
EndElement | Optional input object that specifies the last element to be composited in this feature. This object must correspond to a node in the browser. An error occurs if the EndElement is not at the same level as the StartElement in the browser tree. If the StartElement argument is specified and this argument is not specified, the feature just composites the StartElement. If both StartElement and EndElement arguments are specified and they are the same, the feature just composites the StartElement. This argument is ignored if the StartElement argument is not specified. This can be a PartFeature, DerivedPartComponent, DerivedAssemblyComponent, iFeatureComponent, Sketch, Sketch3D, WorkPoint, WorkPlane, or a WorkAxis.
FeatureInputs | Optional input ObjectCollection that specifies the inputs use to create this feature. The inputs are currently limited to 2D & 3D sketches. The inputs must be above the feature in the browser. When sketches are specified as inputs, the behavior is the same as a regular Inventor feature (such as Extrude) consuming a sketch. The sketch appears under the client feature and can be 'shared' by the user so it is usable in other downstream features. The input objects are not 'strongly owned' by the client feature. i.e. when the client feature is deleted, the user has the option to retain the feature inputs. The feature inputs do not highlight with the client feature.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Methods > ClientFeatures.CreateDefinition Method


ClientFeatures.Item Method

ClientFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified ClientFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ClientFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ClientFeature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ClientFeature name. If an out of range index or a name of a non-existent ClientFeature is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Methods > ClientFeatures.Item Method


ClientFeatures Properties

ClientFeatures Properties
Summary

The properties of the ClientFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kClientFeaturesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Properties


ClientFeatures.Application Property

ClientFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Properties > ClientFeatures.Application Property


ClientFeatures.Count Property

ClientFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Properties > ClientFeatures.Count Property


ClientFeatures.Type Property

ClientFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kClientFeaturesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientFeatures Interface > ClientFeatures Properties > ClientFeatures.Type Property


ClientGraphics Interface

ClientGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ClientGraphics object is a collection of objects.

Class Hierarchy
Inventor::ClientGraphics
Visual Basic
Public Interface ClientGraphics
Inherits IDispatch
Remarks

Each ClientGraphics object is intended to be the single owner of all of a particular client's graphics. This allows you to quickly access all of your graphics among the many possible other client graphics. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ClientGraphicsCollection.Add

ClientGraphicsCollection.Item

GraphicsNode.Parent

InteractionGraphics.OverlayClientGraphics

InteractionGraphics.PreviewClientGraphics

See Also

Client graphics - image in point graphics sample

Create client graphics based on the solid body of the active part sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Transient solid body creation sample

OnDrag Event - dragging a WorkPoint sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Client graphics creation of 3D primitives sample

Client Graphics - Triangle sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

Client graphics from SAT file body sample

Client Graphics - Line sample

Example

"Client Graphics - Draw Range Box Example "

"This sample demonstrates the use of client graphics to draw the range box of selected entities. To run this sample open an assembly or part document and select the item(s) to draw a range box around. Then run the program. If you run it without any graphics selected, it will delete any existing range boxes."

Public Sub DrawRangeBox()
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active document.
    ' This assumes that a part or assembly document is active.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Make sure something is selected.
    If oDoc.SelectSet.Count = 0 Then
        MsgBox "You must select the object(s) to display the range box."

        ' Delete any graphics, if they exist.
        On Error Resume Next
        Dim oExistingGraphicsData As GraphicsDataSets
        Set oExistingGraphicsData = oDoc.GraphicsDataSetsCollection.Item("RangeBoxGraphics")
        If Err.Number = 0 Then
            On Error Goto 0
            Dim oExistingGraphics As ClientGraphics
            Set oExistingGraphics = oCompDef.ClientGraphicsCollection.Item("RangeBoxGraphics")
            oExistingGraphics.Delete
            oExistingGraphicsData.Delete
            ThisApplication.ActiveView.Update
        End If

        Exit Sub
    End If

    Redim aoRanges(1 To oDoc.SelectSet.Count) As Box
    Dim iRangeCount As Long
    Dim i As Long
    On Error Resume Next
    For i = 1 To oDoc.SelectSet.Count
       Dim oBox As Box
        Set oBox = oDoc.SelectSet.Item(i).RangeBox
        If Err Then
            Err.Clear
            ' Special case for B-Rep entities.
            If oDoc.SelectSet.Item(i).Type = kFaceObject Or _
               oDoc.SelectSet.Item(i).Type = kFaceProxyObject Or _
               oDoc.SelectSet.Item(i).Type = kEdgeObject Or _
               oDoc.SelectSet.Item(i).Type = kEdgeProxyObject Then
                ' Get the range from evaluator of the BRep object.
                Set oBox = oDoc.SelectSet.Item(i).Evaluator.RangeBox
                iRangeCount = iRangeCount + 1
                Set aoRanges(iRangeCount) = oBox
            End If
        Else
            iRangeCount = iRangeCount + 1
            Set aoRanges(iRangeCount) = oBox
        End If
    Next
    On Error Goto 0

    If iRangeCount = 0 Then
        MsgBox "You must pick object(s) that support a 3D RangeBox property."
        Exit Sub
    End If

    ' Check to see if range box graphics information already exists.
    On Error Resume Next
    Dim oClientGraphics As ClientGraphics
    Dim oLineGraphics As LineGraphics
    Dim oBoxNode As GraphicsNode
    Dim oGraphicsData As GraphicsDataSets
    Set oGraphicsData = oDoc.GraphicsDataSetsCollection.Item("RangeBoxGraphics")
    If Err Then
        Err.Clear
        On Error Goto 0

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create a graphics data set object. This object contains all of the
        ' information used to define the graphics.
        Dim oDataSets As GraphicsDataSets
        Set oDataSets = oDoc.GraphicsDataSetsCollection.Add("RangeBoxGraphics")

        ' Create a coordinate set.
        Dim oCoordSet As GraphicsCoordinateSet
        Set oCoordSet = oDataSets.CreateCoordinateSet(1)

        ' Create the client graphics for this compdef.
        Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("RangeBoxGraphics")

        ' Create a graphics node.
        Set oBoxNode = oClientGraphics.AddNode(1)
        oBoxNode.Selectable = False

        ' Create line graphics.
        Set oLineGraphics = oBoxNode.AddLineGraphics
        oLineGraphics.CoordinateSet = oCoordSet
    Else
        Set oCoordSet = oGraphicsData.ItemById(1)
        Set oBoxNode = oCompDef.ClientGraphicsCollection.Item("RangeBoxGraphics").ItemById(1)
    End If

    Dim dBoxLines() As Double
    Redim dBoxLines(1 To 12 * 6 * iRangeCount) As Double
    For i = 0 To iRangeCount - 1
        Dim MinPoint(1 To 3) As Double
        Dim MaxPoint(1 To 3) As Double
        Call aoRanges(i + 1).GetBoxData(MinPoint, MaxPoint)

        ' Line 1
        dBoxLines(i * 72 + 1) = MinPoint(1)
        dBoxLines(i * 72 + 2) = MinPoint(2)
        dBoxLines(i * 72 + 3) = MinPoint(3)
        dBoxLines(i * 72 + 4) = MaxPoint(1)
        dBoxLines(i * 72 + 5) = MinPoint(2)
        dBoxLines(i * 72 + 6) = MinPoint(3)

        ' Line 2
        dBoxLines(i * 72 + 7) = MinPoint(1)
        dBoxLines(i * 72 + 8) = MinPoint(2)
        dBoxLines(i * 72 + 9) = MinPoint(3)
        dBoxLines(i * 72 + 10) = MinPoint(1)
        dBoxLines(i * 72 + 11) = MaxPoint(2)
        dBoxLines(i * 72 + 12) = MinPoint(3)

        ' Line 3
        dBoxLines(i * 72 + 13) = MinPoint(1)
        dBoxLines(i * 72 + 14) = MinPoint(2)
        dBoxLines(i * 72 + 15) = MinPoint(3)
        dBoxLines(i * 72 + 16) = MinPoint(1)
        dBoxLines(i * 72 + 17) = MinPoint(2)
        dBoxLines(i * 72 + 18) = MaxPoint(3)

        ' Line 4
        dBoxLines(i * 72 + 19) = MaxPoint(1)
        dBoxLines(i * 72 + 20) = MaxPoint(2)
        dBoxLines(i * 72 + 21) = MaxPoint(3)
        dBoxLines(i * 72 + 22) = MinPoint(1)
        dBoxLines(i * 72 + 23) = MaxPoint(2)
        dBoxLines(i * 72 + 24) = MaxPoint(3)

        ' Line 5
        dBoxLines(i * 72 + 25) = MaxPoint(1)
        dBoxLines(i * 72 + 26) = MaxPoint(2)
        dBoxLines(i * 72 + 27) = MaxPoint(3)
        dBoxLines(i * 72 + 28) = MaxPoint(1)
        dBoxLines(i * 72 + 29) = MinPoint(2)
        dBoxLines(i * 72 + 30) = MaxPoint(3)

        ' Line 6
        dBoxLines(i * 72 + 31) = MaxPoint(1)
        dBoxLines(i * 72 + 32) = MaxPoint(2)
        dBoxLines(i * 72 + 33) = MaxPoint(3)
        dBoxLines(i * 72 + 34) = MaxPoint(1)
        dBoxLines(i * 72 + 35) = MaxPoint(2)
        dBoxLines(i * 72 + 36) = MinPoint(3)

        ' Line 7
        dBoxLines(i * 72 + 37) = MinPoint(1)
        dBoxLines(i * 72 + 38) = MaxPoint(2)
        dBoxLines(i * 72 + 39) = MinPoint(3)
        dBoxLines(i * 72 + 40) = MaxPoint(1)
        dBoxLines(i * 72 + 41) = MaxPoint(2)
        dBoxLines(i * 72 + 42) = MinPoint(3)

        ' Line 8
        dBoxLines(i * 72 + 43) = MinPoint(1)
        dBoxLines(i * 72 + 44) = MaxPoint(2)
        dBoxLines(i * 72 + 45) = MinPoint(3)
        dBoxLines(i * 72 + 46) = MinPoint(1)
        dBoxLines(i * 72 + 47) = MaxPoint(2)
        dBoxLines(i * 72 + 48) = MaxPoint(3)

        ' Line 9
        dBoxLines(i * 72 + 49) = MaxPoint(1)
        dBoxLines(i * 72 + 50) = MinPoint(2)
        dBoxLines(i * 72 + 51) = MaxPoint(3)
        dBoxLines(i * 72 + 52) = MaxPoint(1)
        dBoxLines(i * 72 + 53) = MinPoint(2)
        dBoxLines(i * 72 + 54) = MinPoint(3)

        ' Line 10
        dBoxLines(i * 72 + 55) = MaxPoint(1)
        dBoxLines(i * 72 + 56) = MinPoint(2)
        dBoxLines(i * 72 + 57) = MaxPoint(3)
        dBoxLines(i * 72 + 58) = MinPoint(1)
        dBoxLines(i * 72 + 59) = MinPoint(2)
        dBoxLines(i * 72 + 60) = MaxPoint(3)

        ' Line 11
        dBoxLines(i * 72 + 61) = MinPoint(1)
        dBoxLines(i * 72 + 62) = MinPoint(2)
        dBoxLines(i * 72 + 63) = MaxPoint(3)
        dBoxLines(i * 72 + 64) = MinPoint(1)
        dBoxLines(i * 72 + 65) = MaxPoint(2)
        dBoxLines(i * 72 + 66) = MaxPoint(3)

        ' Line 12
        dBoxLines(i * 72 + 67) = MaxPoint(1)
        dBoxLines(i * 72 + 68) = MinPoint(2)
        dBoxLines(i * 72 + 69) = MinPoint(3)
        dBoxLines(i * 72 + 70) = MaxPoint(1)
        dBoxLines(i * 72 + 71) = MaxPoint(2)
        dBoxLines(i * 72 + 72) = MinPoint(3)
    Next

    ' Assign the points into the coordinate set.
    Call oCoordSet.PutCoordinates(dBoxLines)

    ' Update the display.
    ThisApplication.ActiveView.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface


ClientGraphics Methods

ClientGraphics Methods
Summary

The methods of the ClientGraphics class are listed here.

Methods
Methods
Name | Description
AddNode | Method that creates a new GraphicsNode object.
Delete | Method that deletes this ClientGraphics object. This will delete all of its associated GraphicsNode objects too.
Item | Property that returns the specified object from the collection.
ItemById | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Methods


ClientGraphics.AddNode Method

ClientGraphics.AddNode Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new GraphicsNode object.

Visual Basic
Sub AddNode(NodeId As long, Result As [out, retval] GraphicsNode*)
Parameters
Parameters | Description
NodeId | Input Long that specifies the identifier for the newly created entity. This id needs to be unique with respect to all other objects in this ClientGraphics object.
See Also

Create client graphics based on the solid body of the active part sample

Transient solid body creation sample

OnDrag Event - dragging a WorkPoint sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

InteractionGraphics sample

Client Graphics - Triangle sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

Client graphics from SAT file body sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Methods > ClientGraphics.AddNode Method


ClientGraphics.Delete Method

ClientGraphics.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes this ClientGraphics object. This will delete all of its associated GraphicsNode objects too.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Methods > ClientGraphics.Delete Method


ClientGraphics.Item Method

ClientGraphics.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GraphicsNode*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Methods > ClientGraphics.Item Method


ClientGraphics.ItemById Method

ClientGraphics.ItemById Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub ItemById(NodeId As long, Result As [out, retval] GraphicsNode*)
Parameters
Parameters | Description
NodeId | Input Long that specifies the ID of the within the this ClientGraphics object.
See Also

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Methods > ClientGraphics.ItemById Method


ClientGraphics Properties

ClientGraphics Properties
Summary

The properties of the ClientGraphics class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property that returns the ID of this ClientGraphics object.
Count | Property that returns the number of GraphicsNode objects associated with this ClientGraphics object.
NonTransacting | Property that returns whether the creation of this ClientGraphics object and all its associated data is non-transacting.
Parent | Property returns the logical parent of this object.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Selectable | Property that gets and sets whether all of the GraphicsNode objects within the ClientGraphics object are selectable. When getting this property valid values are kAllGraphicsSelectable, kNoGraphicsSelectable, and kSomeGraphicsSelectable. When setting this property kAllGraphicsSelectable and kNoGraphicsSelectable are valid.
Type | Property returning an enum indicating this object's type.
Visible | Property that gets and sets whether all of the GraphicsNode objects within the ClientGraphics object are visible. When getting this property valid values are kAllGraphicsVisible, kNoGraphicsVisible, and kSomeGraphicsVisible. When setting this property kAllGraphicsVisible and kNoGraphicsVisible are valid.
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties


ClientGraphics.Application Property

ClientGraphics.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.Application Property


ClientGraphics.ClientId Property

ClientGraphics.ClientId Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ID of this ClientGraphics object.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.ClientId Property


ClientGraphics.Count Property

ClientGraphics.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of GraphicsNode objects associated with this ClientGraphics object.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.Count Property


ClientGraphics.NonTransacting Property

ClientGraphics.NonTransacting Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns whether the creation of this ClientGraphics object and all its associated data is non-transacting.

Visual Basic
Property NonTransacting() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.NonTransacting Property


ClientGraphics.Parent Property

ClientGraphics.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returns the logical parent of this object.

Visual Basic
Property Parent() As ClientGraphicsCollection**
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.Parent Property


ClientGraphics.RangeBox Property

ClientGraphics.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.RangeBox Property


ClientGraphics.Selectable Property

ClientGraphics.Selectable Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether all of the GraphicsNode objects within the ClientGraphics object are selectable. When getting this property valid values are kAllGraphicsSelectable, kNoGraphicsSelectable, and kSomeGraphicsSelectable. When setting this property kAllGraphicsSelectable and kNoGraphicsSelectable are valid.

Visual Basic
Property Selectable() As GraphicsSelectabilityEnum
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.Selectable Property


ClientGraphics.Type Property

ClientGraphics.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.Type Property


ClientGraphics.Visible Property

ClientGraphics.Visible Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether all of the GraphicsNode objects within the ClientGraphics object are visible. When getting this property valid values are kAllGraphicsVisible, kNoGraphicsVisible, and kSomeGraphicsVisible. When setting this property kAllGraphicsVisible and kNoGraphicsVisible are valid.

Visual Basic
Property Visible() As GraphicsVisibilityEnum
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphics Interface > ClientGraphics Properties > ClientGraphics.Visible Property


ClientGraphicsCollection Interface

ClientGraphicsCollection Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ClientGraphicsCollection object provides access to all of the existing objects associated with a graphics container.

Class Hierarchy
Inventor::ClientGraphicsCollection
Visual Basic
Public Interface ClientGraphicsCollection
Inherits IDispatch
Remarks

This object also provides the ability to create new ClientGraphics objects. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ClientFeatureDefinition.ClientGraphicsCollection

ClientGraphics.Parent

ComponentDefinition.ClientGraphicsCollection

DrawingView.ClientGraphicsCollection

Sheet.ClientGraphicsCollection

See Also

Client graphics - image in point graphics sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface


ClientGraphicsCollection Methods

ClientGraphicsCollection Methods
Summary

The methods of the ClientGraphicsCollection class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ClientGraphics object. The identifier supplied needs to uniquely identify the client. The method will fail in the case where a ClientGraphics object with this ClientId already exists on the object.
AddNonTransacting | Method that creates a new ClientGraphics object.
Item | Property that returns an existing ClientGraphics object.
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Methods


ClientGraphicsCollection.Add Method

ClientGraphicsCollection.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new ClientGraphics object. The identifier supplied needs to uniquely identify the client. The method will fail in the case where a ClientGraphics object with this ClientId already exists on the object.

Visual Basic
Sub Add(ClientId As String, Result As [out, retval] ClientGraphics*)
Parameters
Parameters | Description
ClientId | Input string that uniquely identifies the application. Suggestion are the 'ProgID' of the Add-In creating the graphics or the its CLSID in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02},"although any unique string is valid.
See Also

Client graphics - image in point graphics sample

Create client graphics based on the solid body of the active part sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Client Graphics - Triangle sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

Client graphics from SAT file body sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Methods > ClientGraphicsCollection.Add Method


ClientGraphicsCollection.AddNonTransacting Method

ClientGraphicsCollection.AddNonTransacting Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new ClientGraphics object.

Visual Basic
Sub AddNonTransacting(ClientId As String, Result As [out, retval] ClientGraphics*)
Parameters
Parameters | Description
ClientId | Input string that uniquely identifies the application. Suggestion are the ‘ProgID’ of the Add-In creating the graphics or the its CLSID in a string form, e.g. “{C9A6C580-3817-11D0-BE4E-080036E87B02}”, although any unique string is valid.
Remarks

The creation of this object and all subsequent data within this object are non-transacted and cannot be undone by the user. The creation does not dirty the document.

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Methods > ClientGraphicsCollection.AddNonTransacting Method


ClientGraphicsCollection.Item Method

ClientGraphicsCollection.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an existing ClientGraphics object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ClientGraphics*)
Parameters
Parameters | Description
index | Specifies which objects to return. This can be an integer, which specifies the index in the collection, or it can be a string, which specifies the Client ID of the object. The property will fail in the case where an Index is provided that does not identify an existing ClientGraphics object.
See Also

Client graphics - image in point graphics sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Client Graphics - Triangle sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Methods > ClientGraphicsCollection.Item Method


ClientGraphicsCollection Properties

ClientGraphicsCollection Properties
Summary

The properties of the ClientGraphicsCollection class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of ClientGraphics objects associated with the graphic container.
Parent | Property returns the logical parent of this object. This could currently be a ComponentDefinition or an AssemblyOccurrence.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Properties


ClientGraphicsCollection.Application Property

ClientGraphicsCollection.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Properties > ClientGraphicsCollection.Application Property


ClientGraphicsCollection.Count Property

ClientGraphicsCollection.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of ClientGraphics objects associated with the graphic container.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Properties > ClientGraphicsCollection.Count Property


ClientGraphicsCollection.Parent Property

ClientGraphicsCollection.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returns the logical parent of this object. This could currently be a ComponentDefinition or an AssemblyOccurrence.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Properties > ClientGraphicsCollection.Parent Property


ClientGraphicsCollection.Type Property

ClientGraphicsCollection.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientGraphicsCollection Interface > ClientGraphicsCollection Properties > ClientGraphicsCollection.Type Property


ClientNodeResource Interface

ClientNodeResource Interface Available in Inventor Introduced in Inventor 8
Summary

This object is accessible through the BrowserPane. But it is in fact, just the one associated with the Document. In other words, all of the ClientNodeResource objects that are used inside the various BrowserPanes of this Document are to be found here.

Class Hierarchy
Inventor::ClientNodeResource
Visual Basic
Public Interface ClientNodeResource
Inherits IDispatch
Remarks

The ClientNodeResource primarily stores the images necessary to define the icon for a new ClientBrowserNodeDefinition or to override the icon of an existing BrowserNodeDefinition (either built-in or client-created).

Notes

Members through which this object may be accessed include:

ClientBrowserNodeDefinitionObject.ExpandedIcon

ClientBrowserNodeDefinitionObject.Icon

ClientBrowserNodeDefinitionObject.StateIcon

ClientNodeResources.Add

ClientNodeResources.Item

ClientNodeResources.ItemById

NativeBrowserNodeDefinitionObject.OverrideExpandedIcon

NativeBrowserNodeDefinitionObject.OverrideIcon

NativeBrowserNodeDefinitionObject.OverrideStateIcon

You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface


ClientNodeResource Methods

ClientNodeResource Methods
Summary

The methods of the ClientNodeResource class are listed here.

Methods
Methods
Name | Description
Delete | Method that gets rid of this object. If it is being used currently by some node definition object, the method fails.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Methods


ClientNodeResource.Delete Method

ClientNodeResource.Delete Method Available in Inventor Introduced in Inventor 8
Summary

Method that gets rid of this object. If it is being used currently by some node definition object, the method fails.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Methods > ClientNodeResource.Delete Method


ClientNodeResource Properties

ClientNodeResource Properties
Summary

The properties of the ClientNodeResource class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property returning the string identifier that stood for the client or AddIn that was supplied during the creation of this resource.
DisabledIcon | Gets and sets the icon to be used when the associated data model object becomes disabled.
ExpandedDisabledIcon | Gets and sets the expanded icon to be used when the associated data model objects becomes disabled.
ExpandedInvisibleIcon | Gets and sets the expanded icon to be used when the associated data model object becomes invisible.
ExpandedSuppressedIcon | Gets and sets the expanded icon to be used when the associated data model object becomes suppressed.
GroundedDisabledIcon | Gets and sets the icon to be used when the associated data model object becomes grounded and disabled.
GroundedIcon | Gets and sets the icon to be used when the associated data model object becomes grounded.
GroundedInvisibleIcon | Gets and sets the icon to be used when the associated data model object becomes grounded and invisible.
GroundedSuppressedIcon | Gets and sets the icon to be used when the associated data model object becomes grounded and suppressed.
Icon | Gets and sets the bitmap picture associated with a ClientNodeResource object.
Id | Property returning the integer identifier that was supplied during the creation of this resource.
InvisibleIcon | Gets and sets the icon to be used when the associated data model object becomes invisible.
Parent | Property that returns the parent of this object. Though this document is reachable from the BrowserPane out of convenience, it's true parent is the Document itself. That is, this object is not BrowserPane specific, rather, it has its scope or influence across all BrowserPanes (of the TreeBrowser kind).
SuppressedIcon | Gets and sets the icon to be used when the associated data model object becomes suppressed.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties


ClientNodeResource.Application Property

ClientNodeResource.Application Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.Application Property


ClientNodeResource.ClientId Property

ClientNodeResource.ClientId Property Available in Inventor Introduced in Inventor 8
Summary

Property returning the string identifier that stood for the client or AddIn that was supplied during the creation of this resource.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.ClientId Property


ClientNodeResource.DisabledIcon Property

ClientNodeResource.DisabledIcon Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the icon to be used when the associated data model object becomes disabled.

Visual Basic
Property DisabledIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.DisabledIcon Property


ClientNodeResource.ExpandedDisabledIcon Property

ClientNodeResource.ExpandedDisabledIcon Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the expanded icon to be used when the associated data model objects becomes disabled.

Visual Basic
Property ExpandedDisabledIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.ExpandedDisabledIcon Property


ClientNodeResource.ExpandedInvisibleIcon Property

ClientNodeResource.ExpandedInvisibleIcon Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the expanded icon to be used when the associated data model object becomes invisible.

Visual Basic
Property ExpandedInvisibleIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.ExpandedInvisibleIcon Property


ClientNodeResource.ExpandedSuppressedIcon Property

ClientNodeResource.ExpandedSuppressedIcon Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the expanded icon to be used when the associated data model object becomes suppressed.

Visual Basic
Property ExpandedSuppressedIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.ExpandedSuppressedIcon Property


ClientNodeResource.GroundedDisabledIcon Property

ClientNodeResource.GroundedDisabledIcon Property Available in Inventor Introduced in Inventor 2010
Summary

Gets and sets the icon to be used when the associated data model object becomes grounded and disabled.

Visual Basic
Property GroundedDisabledIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.GroundedDisabledIcon Property


ClientNodeResource.GroundedIcon Property

ClientNodeResource.GroundedIcon Property Available in Inventor Introduced in Inventor 2010
Summary

Gets and sets the icon to be used when the associated data model object becomes grounded.

Visual Basic
Property GroundedIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.GroundedIcon Property


ClientNodeResource.GroundedInvisibleIcon Property

ClientNodeResource.GroundedInvisibleIcon Property Available in Inventor Introduced in Inventor 2010
Summary

Gets and sets the icon to be used when the associated data model object becomes grounded and invisible.

Visual Basic
Property GroundedInvisibleIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.GroundedInvisibleIcon Property


ClientNodeResource.GroundedSuppressedIcon Property

ClientNodeResource.GroundedSuppressedIcon Property Available in Inventor Introduced in Inventor 2010
Summary

Gets and sets the icon to be used when the associated data model object becomes grounded and suppressed.

Visual Basic
Property GroundedSuppressedIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.GroundedSuppressedIcon Property


ClientNodeResource.Icon Property

ClientNodeResource.Icon Property Available in Inventor Introduced in Inventor 8
Summary

Gets and sets the bitmap picture associated with a ClientNodeResource object.

Visual Basic
Property Icon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.Icon Property


ClientNodeResource.Id Property

ClientNodeResource.Id Property Available in Inventor Introduced in Inventor 8
Summary

Property returning the integer identifier that was supplied during the creation of this resource.

Visual Basic
Property Id() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.Id Property


ClientNodeResource.InvisibleIcon Property

ClientNodeResource.InvisibleIcon Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the icon to be used when the associated data model object becomes invisible.

Visual Basic
Property InvisibleIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.InvisibleIcon Property


ClientNodeResource.Parent Property

ClientNodeResource.Parent Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns the parent of this object. Though this document is reachable from the BrowserPane out of convenience, it's true parent is the Document itself. That is, this object is not BrowserPane specific, rather, it has its scope or influence across all BrowserPanes (of the TreeBrowser kind).

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.Parent Property


ClientNodeResource.SuppressedIcon Property

ClientNodeResource.SuppressedIcon Property Available in Inventor Introduced in Inventor 11
Summary

Gets and sets the icon to be used when the associated data model object becomes suppressed.

Visual Basic
Property SuppressedIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.SuppressedIcon Property


ClientNodeResource.Type Property

ClientNodeResource.Type Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResource Interface > ClientNodeResource Properties > ClientNodeResource.Type Property


ClientNodeResources Interface

ClientNodeResources Interface Available in Inventor Introduced in Inventor 8
Summary

This object is accessible through the . But it is in fact, just the one associated with the Document. In other words, all of the ClientNodeResource objects that are used inside the various BrowserPanes of this Document are to be found here.

Class Hierarchy
Inventor::ClientNodeResources
Visual Basic
Public Interface ClientNodeResources
Inherits IDispatch
Remarks

The ClientNodeResource primarily stores the images necessary to define the icon for a new ClientBrowserNodeDefinition or to override the icon of an existing BrowserNodeDefinition (either built-in or client-created).

Notes

Members through which this object may be accessed include:

BrowserPanes.ClientNodeResources

You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface


ClientNodeResources Methods

ClientNodeResources Methods
Summary

The methods of the ClientNodeResources class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ClientNodeResource. The new ClientNodeResource is returned. If no expanded icon is passed in, the node ending up with this resource will use the standard icon as the icon to use when it is expanded. The state icon is used to prefix the regular icon, typically denoting the dynamic state of the object it represents.
Item | Returns the specified NodeResource object from the collection.
ItemById | Property that returns the specified NodeResource object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Methods


ClientNodeResources.Add Method

ClientNodeResources.Add Method Available in Inventor Introduced in Inventor 8
Summary

Method that creates a new ClientNodeResource. The new ClientNodeResource is returned. If no expanded icon is passed in, the node ending up with this resource will use the standard icon as the icon to use when it is expanded. The state icon is used to prefix the regular icon, typically denoting the dynamic state of the object it represents.

Visual Basic
Sub Add(ClientId As String, Id As long, Icon As IPictureDisp, Result As [out, retval] ClientNodeResource*)
Parameters
Parameters | Description
ClientId | Input string that uniquely identifies the client. Some suggestions might be the 'ProgID' of the Add-In creating the resource, or its CLSID in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", although any unique string is valid.
Id | Identifier that uniquely identifies the resource to the client. This identifier must be unique within the context of this owning document, and within this AddIn. The ClientId and the Id taken together uniquely identify this object.
Icon | Input IPictureDisp of a 16X16 pixel image. Only bitmaps are supported as a valid input type.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Methods > ClientNodeResources.Add Method


ClientNodeResources.Item Method

ClientNodeResources.Item Method Available in Inventor Introduced in Inventor 8
Summary

Returns the specified NodeResource object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ClientNodeResource*)
Parameters
Parameters | Description
index | Value that specifies the NodeResource to return. This is the numeric value indicating the index of the item in the collection. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Methods > ClientNodeResources.Item Method


ClientNodeResources.ItemById Method

ClientNodeResources.ItemById Method Available in Inventor Introduced in Inventor 8
Summary

Property that returns the specified NodeResource object from the collection.

Visual Basic
Sub ItemById(ClientId As String, Id As long, Result As [out, retval] ClientNodeResource*)
Parameters
Parameters | Description
ClientId | String that was specified by the client or AddIn when the resource was created.
Id | Input value that specifies the integer identifier that the client or AddIn had supplied while creating the resource.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Methods > ClientNodeResources.ItemById Method


ClientNodeResources Properties

ClientNodeResources Properties
Summary

The properties of the ClientNodeResources class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Properties


ClientNodeResources.Application Property

ClientNodeResources.Application Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Properties > ClientNodeResources.Application Property


ClientNodeResources.Count Property

ClientNodeResources.Count Property Available in Inventor Introduced in Inventor 8
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Properties > ClientNodeResources.Count Property


ClientNodeResources.Type Property

ClientNodeResources.Type Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientNodeResources Interface > ClientNodeResources Properties > ClientNodeResources.Type Property


ClientView Interface

ClientView Interface Available in Apprentice Introduced in Inventor 6
Summary

The ClientView object represents a view of the document/drawing sheet attached to a user-specified window handle. See the article in the overviews section.

Class Hierarchy
Inventor::ClientView
Visual Basic
Public Interface ClientView
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ClientViews.Add

ClientViews.AddBySubset

ClientViews.Item

You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface


ClientView Methods

ClientView Methods
Summary

The methods of the ClientView class are listed here.

Methods
Methods
Name | Description
Close | Method that closes out the graphics context for the view. The hWnd is not affected.
GetSubsetExtents | Method that returns the extents of the client view within its assigned hWnd.
Update | Method that redraws the view.
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Methods


ClientView.Close Method

ClientView.Close Method Available in Apprentice Introduced in Inventor 6
Summary

Method that closes out the graphics context for the view. The hWnd is not affected.

Visual Basic
Sub Close()
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Methods > ClientView.Close Method


ClientView.GetSubsetExtents Method

ClientView.GetSubsetExtents Method Available in Apprentice Introduced in Inventor 6
Summary

Method that returns the extents of the client view within its assigned hWnd.

Visual Basic
Sub GetSubsetExtents(ByRef Top As long, ByRef Left As long, ByRef Width As long, ByRef Height As long)
Parameters
Parameters | Description
Top | Output Long that specifies the top of the client view.
Left | Output Long that specifies the left position of the client view.
width | Output Long that specifies the width of the client view.
height | Output Long that specifies the height of the client view.
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Methods > ClientView.GetSubsetExtents Method


ClientView.Update Method

ClientView.Update Method Available in Apprentice Introduced in Inventor 6
Summary

Method that redraws the view.

Visual Basic
Sub Update(Interactive As VARIANT_BOOL)
Parameters
Parameters | Description
Interactive | Input Boolean that specifies the type of update to perform. Interactive update should be used when the user is dynamically modifying the view. During interactive update Autodesk Inventor takes steps to optimize the display in an attempt to achieve a higher frame rate. For example it will create simplified displays of parts and eliminate the display of small parts in assemblies. Setting the Interactive argument to True allows Autodesk Inventor to perform these optimizations. Setting this argument to False causes Autodesk Inventor to perform a complete rendering without any optimizations. Typically you will set the Interactive argument to True while the user is dynamically modifying the view (while the mouse button is down). A final update (When the mouse button is released) is performed with the Interactive argument set to False to get an accurate rendering.
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Methods > ClientView.Update Method


ClientView Properties

ClientView Properties
Summary

The properties of the ClientView class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Camera | Property that returns the camera for the view.
DisplayMode | Rendering mode of view (shaded, hidden, hidden line).
Document | Property that returns the document object this is a view of.
GroundShadow | Gets and sets the ground shadow setting on the view!/s window.
HWND | Property that returns the hWnd (the handle assigned by Windows to the current window) of the view.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties


ClientView.Application Property

ClientView.Application Property Available in Apprentice Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.Application Property


ClientView.Camera Property

ClientView.Camera Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the camera for the view.

Visual Basic
Property Camera() As Camera**
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.Camera Property


ClientView.DisplayMode Property

ClientView.DisplayMode Property Available in Apprentice Introduced in Inventor 6
Summary

Rendering mode of view (shaded, hidden, hidden line).

Visual Basic
Property DisplayMode() As DisplayModeEnum
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.DisplayMode Property


ClientView.Document Property

ClientView.Document Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the document object this is a view of.

Visual Basic
Property Document() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.Document Property


ClientView.GroundShadow Property

ClientView.GroundShadow Property Available in Apprentice Introduced in Inventor 2008
Summary

Gets and sets the ground shadow setting on the view!/s window.

Visual Basic
Property GroundShadow() As GroundShadowEnum
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.GroundShadow Property


ClientView.HWND Property

ClientView.HWND Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the hWnd (the handle assigned by Windows to the current window) of the view.

Visual Basic
Property HWND() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.HWND Property


ClientView.Parent Property

ClientView.Parent Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As ClientViews**
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.Parent Property


ClientView.Type Property

ClientView.Type Property Available in Apprentice Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientView Interface > ClientView Properties > ClientView.Type Property


ClientViews Interface

ClientViews Interface Available in Apprentice Introduced in Inventor 6
Summary

The ClientViews collection object represents the collection of objects for a document/drawing sheet, along with the ability to add new views to the collection. See the article in the overviews section.

Class Hierarchy
Inventor::ClientViews
Visual Basic
Public Interface ClientViews
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.ClientViews

ClientView.Parent

Sheet.ClientViews

You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface


ClientViews Methods

ClientViews Methods
Summary

The methods of the ClientViews class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new to the collection.
AddBySubset | Add a new within a rectangular region of a window, identified by its hWnd. This allows multiple views in a single hWnd.
Item | Property that returns the specified object from the collection. This is the default property of the ClientViews collection object.
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Methods


ClientViews.Add Method

ClientViews.Add Method Available in Apprentice Introduced in Inventor 6
Summary

Method that adds a new to the collection.

Visual Basic
Sub Add(HWnd As long, Result As [out, retval] ClientView*)
Parameters
Parameters | Description
HWND | Input Long that defines the hWnd for the window to add.
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Methods > ClientViews.Add Method


ClientViews.AddBySubset Method

ClientViews.AddBySubset Method Available in Apprentice Introduced in Inventor 6
Summary

Add a new within a rectangular region of a window, identified by its hWnd. This allows multiple views in a single hWnd.

Visual Basic
Sub AddBySubset(HWnd As long, Left As long, Top As long, Width As long, Height As long, Result As [out, retval] ClientView*)
Parameters
Parameters | Description
Left | Input Long that specifies the position of the left edge of the view.
Top | Input Long that specifies the position of the top edge of the view.
HWND | Input Long that defines the hWnd for the window to add.
width | Input Long that specifies the width of the view.
height | Input Long that specifies the height of the view.
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Methods > ClientViews.AddBySubset Method


ClientViews.Item Method

ClientViews.Item Method Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the specified object from the collection. This is the default property of the ClientViews collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ClientView*)
Parameters
Parameters | Description
index | Input Long value that specifies the ClientView to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ClientView name. The name expected is the display name of the view. This is the name that is displayed to the user in the assembly browser. If an out-of-range index or a name of a non-existent name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Methods > ClientViews.Item Method


ClientViews Properties

ClientViews Properties
Summary

The properties of the ClientViews class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Properties


ClientViews.Application Property

ClientViews.Application Property Available in Apprentice Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Properties > ClientViews.Application Property


ClientViews.Count Property

ClientViews.Count Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Properties > ClientViews.Count Property


ClientViews.Parent Property

ClientViews.Parent Property Available in Apprentice Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Properties > ClientViews.Parent Property


ClientViews.Type Property

ClientViews.Type Property Available in Apprentice Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ClientViews Interface > ClientViews Properties > ClientViews.Type Property


CoilFeature Interface

CoilFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CoilFeature object represents coil modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::CoilFeature
        Inventor::CoilFeatureProxy
Visual Basic
Public Interface CoilFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CoilFeatureProxy.NativeObject

CoilFeatures.AddByPitchAndHeight

CoilFeatures.AddByPitchAndRevolution

CoilFeatures.AddByRevolutionAndHeight

CoilFeatures.AddSpiral

CoilFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface


CoilFeature Methods

CoilFeature Methods
Summary

The methods of the CoilFeature class are listed here.

Methods
Methods
Name | Description
SetPitchAndHeightExtent | Set coil feature pitch and height extent.
SetPitchAndRevolutionExtent | Set coil feature pitch and revolution extent.
SetRevolutionAndHeightExtent | Set coil feature revolution and height extent.
SetSpiralExtent | Set coil feature spiral extent.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Methods


CoilFeature.SetPitchAndHeightExtent Method

CoilFeature.SetPitchAndHeightExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Set coil feature pitch and height extent.

Visual Basic
Sub SetPitchAndHeightExtent(Pitch As VARIANT, Height As VARIANT, ByRef TaperAngle As [optional] VARIANT)
Parameters
Parameters | Description
Pitch | ut Variant that defines the pitch of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Height | Input Variant that defines the height of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
TaperAngle | Optional input variant that defines the taper angle of the coil feature. If not supplied it defaults to zero.. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Methods > CoilFeature.SetPitchAndHeightExtent Method


CoilFeature.SetPitchAndRevolutionExtent Method

CoilFeature.SetPitchAndRevolutionExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Set coil feature pitch and revolution extent.

Visual Basic
Sub SetPitchAndRevolutionExtent(Pitch As VARIANT, Revolution As VARIANT, ByRef TaperAngle As [optional] VARIANT)
Parameters
Parameters | Description
Pitch | Input Variant that defines the pitch of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Revolution | Input variant that defines the number of revolutions of the coil feature.
TaperAngle | Optional input variant that defines the taper angle of the coil feature. If not supplied it defaults to zero.. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Methods > CoilFeature.SetPitchAndRevolutionExtent Method


CoilFeature.SetRevolutionAndHeightExtent Method

CoilFeature.SetRevolutionAndHeightExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Set coil feature revolution and height extent.

Visual Basic
Sub SetRevolutionAndHeightExtent(Revolution As VARIANT, Height As VARIANT, ByRef TaperAngle As [optional] VARIANT)
Parameters
Parameters | Description
Revolution | Input Variant that defines the number of revolutions of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, it is unitless. If a string is input it must resolve to a unitless value.
Height | Input Variant that defines the height of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
TaperAngle | Optional input variant that defines the taper angle of the coil feature. If not supplied it defaults to zero.. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Methods > CoilFeature.SetRevolutionAndHeightExtent Method


CoilFeature.SetSpiralExtent Method

CoilFeature.SetSpiralExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Set coil feature spiral extent.

Visual Basic
Sub SetSpiralExtent(Pitch As VARIANT, Revolution As VARIANT)
Parameters
Parameters | Description
Pitch | Input Variant that defines the pitch of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Revolution | Input Variant that defines the number of revolutions of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, it is unitless. If a string is input it must resolve to a unitless value.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Methods > CoilFeature.SetSpiralExtent Method


CoilFeature Properties

CoilFeature Properties
Summary

The properties of the CoilFeature class are listed here.

Properties
Name | Description
AxisDirectionReversed | Property that gets and sets whether the axis direction of the coil is reversed.
AxisEntity | Property that gets and sets the entity used to define the axis of the coil. Valid input is either a sketch line or work axis. The axis entity must not intersect the profile.
ClockwiseRotation | Property that gets and sets whether the rotation is clockwise or counter-clockwise. A value of True indicates clockwise rotation.
EndFlatAngle | Property that returns the parameter that controls the flat angle at the end of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatEndType is False.
EndTransitionAngle | Property that returns the parameter that controls the transition angle at the end of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatEndType is False.
Extent | Property that returns the object that defines how the extent of the feature is defined. The type of extent object that this property will return can be determined by using the ExtentType property.
ExtentType | Property that returns an enum indicating how the extent of the feature is defined. This indicates the type of object returned by the Extent property.
FlatEndType | Property that gets and sets the coil end type at the end of the coil feature.
FlatStartType | Property that gets and sets the coil end type at the start of the coil feature.
Operation | Property that indicates the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
Profile | Property that gets and sets the profile that defines the shape of the coil.
StartFlatAngle | Property that returns the parameter that controls the flat angle at the start of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatStartType is False.
StartTransitionAngle | Property that returns the parameter that controls the transition angle at the start of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatStartType is False.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties


CoilFeature.AxisDirectionReversed Property

CoilFeature.AxisDirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the axis direction of the coil is reversed.

Visual Basic
Property AxisDirectionReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.AxisDirectionReversed Property


CoilFeature.AxisEntity Property

CoilFeature.AxisEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the entity used to define the axis of the coil. Valid input is either a sketch line or work axis. The axis entity must not intersect the profile.

Visual Basic
Property AxisEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.AxisEntity Property


CoilFeature.ClockwiseRotation Property

CoilFeature.ClockwiseRotation Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the rotation is clockwise or counter-clockwise. A value of True indicates clockwise rotation.

Visual Basic
Property ClockwiseRotation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.ClockwiseRotation Property


CoilFeature.EndFlatAngle Property

CoilFeature.EndFlatAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the flat angle at the end of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatEndType is False.

Visual Basic
Property EndFlatAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.EndFlatAngle Property


CoilFeature.EndTransitionAngle Property

CoilFeature.EndTransitionAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the transition angle at the end of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatEndType is False.

Visual Basic
Property EndTransitionAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.EndTransitionAngle Property


CoilFeature.Extent Property

CoilFeature.Extent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the object that defines how the extent of the feature is defined. The type of extent object that this property will return can be determined by using the ExtentType property.

Visual Basic
Property Extent() As PartFeatureExtent**
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.Extent Property


CoilFeature.ExtentType Property

CoilFeature.ExtentType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns an enum indicating how the extent of the feature is defined. This indicates the type of object returned by the Extent property.

Visual Basic
Property ExtentType() As PartFeatureExtentEnum*
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.ExtentType Property


CoilFeature.FlatEndType Property

CoilFeature.FlatEndType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the coil end type at the end of the coil feature.

Visual Basic
Property FlatEndType() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.FlatEndType Property


CoilFeature.FlatStartType Property

CoilFeature.FlatStartType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the coil end type at the start of the coil feature.

Visual Basic
Property FlatStartType() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.FlatStartType Property


CoilFeature.Operation Property

CoilFeature.Operation Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.Operation Property


CoilFeature.Profile Property

CoilFeature.Profile Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the profile that defines the shape of the coil.

Visual Basic
Property Profile() As Profile*
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.Profile Property


CoilFeature.StartFlatAngle Property

CoilFeature.StartFlatAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the flat angle at the start of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatStartType is False.

Visual Basic
Property StartFlatAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.StartFlatAngle Property


CoilFeature.StartTransitionAngle Property

CoilFeature.StartTransitionAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the transition angle at the start of the coil feature. This property returns Nothing if ExtentType is kSpiral or FlatStartType is False.

Visual Basic
Property StartTransitionAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CoilFeature Interface > CoilFeature Properties > CoilFeature.StartTransitionAngle Property


CoilFeatureProxy Interface

CoilFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoilFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CoilFeature
        Inventor::CoilFeatureProxy
Visual Basic
Public Interface CoilFeatureProxy
Inherits CoilFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CoilFeatureProxy Interface


CoilFeatureProxy Properties

CoilFeatureProxy Properties
Summary

The properties of the CoilFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatureProxy Interface > CoilFeatureProxy Properties


CoilFeatureProxy.ContainingOccurrence Property

CoilFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CoilFeatureProxy Interface > CoilFeatureProxy Properties > CoilFeatureProxy.ContainingOccurrence Property


CoilFeatureProxy.NativeObject Property

CoilFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CoilFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CoilFeatureProxy Interface > CoilFeatureProxy Properties > CoilFeatureProxy.NativeObject Property


CoilFeatures Interface

CoilFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CoilFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional CoilFeature objects.

Class Hierarchy
Inventor::CoilFeatures
Visual Basic
Public Interface CoilFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.CoilFeatures

You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface


CoilFeatures Methods

CoilFeatures Methods
Summary

The methods of the CoilFeatures class are listed here.

Methods
Methods
Name | Description
AddByPitchAndHeight | Method that creates a new CoilFeature whose extent is defined by specifying pitch and total height. The new CoilFeature is returned.
AddByPitchAndRevolution | Method that creates a new CoilFeature whose extent is defined by specifying the pitch and number of revolutions. The new CoilFeature is returned.
AddByRevolutionAndHeight | Method that creates a new CoilFeature whose extent is defined by specifying the number of revolutions and the total height. The new CoilFeature is returned.
AddSpiral | Method that creates a new CoilFeature that sweeps a specified angle. The new CoilFeature is returned.
Item | Property that returns the specified CoilFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Methods


CoilFeatures.AddByPitchAndHeight Method

CoilFeatures.AddByPitchAndHeight Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new CoilFeature whose extent is defined by specifying pitch and total height. The new CoilFeature is returned.

Visual Basic
Sub AddByPitchAndHeight(Profile As Profile, AxisEntity As IDispatch, Pitch As VARIANT, Height As VARIANT, Operation As PartFeatureOperationEnum, ByRef AxisDirectionReversed As [defaultvalue(0)] VARIANT_BOOL, ByRef ClockwiseRotation As [defaultvalue(0)] VARIANT_BOOL, ByRef TaperAngle As [defaultvalue(0.0)] VARIANT, ByRef FlatStartType As [defaultvalue(0)] VARIANT_BOOL, ByRef StartTransitionAngle As [optional] VARIANT, ByRef StartFlatAngle As [optional] VARIANT, ByRef FlatEndType As [defaultvalue(0)] VARIANT_BOOL, ByRef EndTransitionAngle As [optional] VARIANT, ByRef EndFlatAngle As [optional] VARIANT, Result As [out, retval] CoilFeature*)
Parameters
Parameters | Description
Profile | Input object used to define the shape of the coil.
AxisEntity | Input linear entity that defines the axis of the revolution. Valid input is either a sketch line or work axis. The axis entity must not intersect the input profile.
Pitch | Input Variant that defines the pitch of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
AxisDirectionReversed | Optional input Boolean that indicates a reversal of axis direction. The default is False, which means the axis direction will be in the same direction as the natural direction of the input axis entity.
ClockwiseRotation | Optional input Boolean that defines whether the rotation of the coil is clockwise or counter-clockwise. The default is False, indicating counter-clockwise rotation.
TaperAngle | Optional input Variant that defines the taper angle of the coil feature. If not supplied it defaults to zero. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatStartType | Optional input Boolean that indicates the coil end type. The default is False indicating a natural end type. True indicates a flat start type.
StartTransitionAngle | Optional input Variant that defines the transition angle for the coil's end. This is used only if FlatStartType is True, otherwise this argument is ignored. The default value for this argument is p/2 (90 degrees). This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
StartFlatAngle | Optional input Variant that defines the flat angle for the coil's end. This is used only if FlatStartType is True, otherwise this argument is ignored. The default value for this argument is p/2 (90 degrees). This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatEndType | Optional input Boolean that indicates the coil's end type. The default is False, indicating a natural end type. True indicates a flat end type.
EndTransitionAngle | Optional input Variant that defines the transition angle for the coil's end. This is used only if FlatEndType is True, otherwise this argument is ignored. The default value for this argument is p/2 (90 degrees). This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
EndFlatAngle | Optional input Variant that defines the flat angle for the coil's end. This is used only if FlatEndType is True. The default value for this argument is p/2 (90 degrees). This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
height | Input Variant that defines the height of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Methods > CoilFeatures.AddByPitchAndHeight Method


CoilFeatures.AddByPitchAndRevolution Method

CoilFeatures.AddByPitchAndRevolution Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new CoilFeature whose extent is defined by specifying the pitch and number of revolutions. The new CoilFeature is returned.

Visual Basic
Sub AddByPitchAndRevolution(Profile As Profile, AxisEntity As IDispatch, Pitch As VARIANT, Revolution As VARIANT, Operation As PartFeatureOperationEnum, ByRef AxisDirectionReversed As [defaultvalue(0)] VARIANT_BOOL, ByRef ClockwiseRotation As [defaultvalue(0)] VARIANT_BOOL, ByRef TaperAngle As [defaultvalue(0.0)] VARIANT, ByRef FlatStartType As [defaultvalue(0)] VARIANT_BOOL, ByRef StartTransitionAngle As [optional] VARIANT, ByRef StartFlatAngle As [optional] VARIANT, ByRef FlatEndType As [defaultvalue(0)] VARIANT_BOOL, ByRef EndTransitionAngle As [optional] VARIANT, ByRef EndFlatAngle As [optional] VARIANT, Result As [out, retval] CoilFeature*)
Parameters
Parameters | Description
Profile | Input object used to define the shape of the coil.
AxisEntity | Input linear entity that defines the axis of the revolution. Valid input is either a sketch line or work axis. The axis entity must not intersect the input profile.
Pitch | Input Variant that defines the pitch of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Revolution | Input Variant that defines the number of revolutions of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, it is unitless. If a string is input it must resolve to a unitless value.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
AxisDirectionReversed | Optional input Boolean that indicates a reversal of axis direction. The default is False, which means the axis direction will be in the same direction as the natural direction of the input axis entity.
ClockwiseRotation | Optional input Boolean that defines whether the rotation of the coil is clockwise or counter-clockwise. The default is False, indicating counter-clockwise rotation.
TaperAngle | Optional input Variant that defines the taper angle of the coil feature. If this argument is not supplied it defaults to zero. It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatStartType | Optional input Boolean that indicates the coil end type. The default is False indicating a natural end type. True indicates a flat start type.
StartTransitionAngle | Optional input Variant that defines the transition angle for the coil's end. This argument is used only if the FlatStartType argument is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
StartFlatAngle | Optional input Variant that defines the flat angle for the coil's end. This argument is used only if FlatStartType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatEndType | Optional input Boolean that indicates the coil end type. The default is False indicating a natural end type. True indicates a flat end type.
EndTransitionAngle | Optional input Variant that defines the transition angle for the coil's end. This argument is used only if FlatEndType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
EndFlatAngle | Optional input variant that defines the flat angle for the coil's end. This argument is used only if FlatEndType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Methods > CoilFeatures.AddByPitchAndRevolution Method


CoilFeatures.AddByRevolutionAndHeight Method

CoilFeatures.AddByRevolutionAndHeight Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new CoilFeature whose extent is defined by specifying the number of revolutions and the total height. The new CoilFeature is returned.

Visual Basic
Sub AddByRevolutionAndHeight(Profile As Profile, AxisEntity As IDispatch, Revolution As VARIANT, Height As VARIANT, Operation As PartFeatureOperationEnum, ByRef AxisDirectionReversed As [defaultvalue(0)] VARIANT_BOOL, ByRef ClockwiseRotation As [defaultvalue(0)] VARIANT_BOOL, ByRef TaperAngle As [defaultvalue(0.0)] VARIANT, ByRef FlatStartType As [defaultvalue(0)] VARIANT_BOOL, ByRef StartTransitionAngle As [optional] VARIANT, ByRef StartFlatAngle As [optional] VARIANT, ByRef FlatEndType As [defaultvalue(0)] VARIANT_BOOL, ByRef EndTransitionAngle As [optional] VARIANT, ByRef EndFlatAngle As [optional] VARIANT, Result As [out, retval] CoilFeature*)
Parameters
Parameters | Description
Profile | Input object used to define the shape of the coil.
AxisEntity | Input linear entity that defines the axis of the revolution. Valid input is either a sketch line or work axis. The axis entity must not intersect the input profile.
Revolution | Input Variant that defines the number of revolutions of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, it is unitless. If a string is input it must resolve to a unitless value.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
AxisDirectionReversed | Optional input Boolean that indicates a reversal of axis direction. The default is False, which means the axis direction will be in the same direction as the natural direction of the input axis entity.
ClockwiseRotation | Optional input Boolean that defines whether the rotation of the coil is clockwise or counter-clockwise. The default is False, indicating counter-clockwise rotation.
TaperAngle | Optional input Variant that defines the taper angle of the coil feature. If this argument is not supplied it defaults to zero. It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatStartType | Optional input Boolean that indicates the coil's end type. The default is False indicating a natural end type. True indicates a flat start type.
StartTransitionAngle | Optional input Variant that defines the transition angle for the coil's end. This argument is used only if FlatStartType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
StartFlatAngle | Optional input Variant that defines the flat angle for the coil's end. This argument is used only if FlatStartType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatEndType | Optional input Boolean that indicates the coil's end type. The default is False indicating a natural end type. True indicates a flat end type.
EndTransitionAngle | Optional input Variant that defines the transition angle for the coil's end. This argument is used only if FlatEndType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
EndFlatAngle | Optional input Variant that defines the flat angle for the coil's end. This argument is used only if FlatEndType is True, otherwise it is ignored. The default value for this argument is p/2 (90 degrees). It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
height | Input Variant that defines the height of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Methods > CoilFeatures.AddByRevolutionAndHeight Method


CoilFeatures.AddSpiral Method

CoilFeatures.AddSpiral Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new CoilFeature that sweeps a specified angle. The new CoilFeature is returned.

Visual Basic
Sub AddSpiral(Profile As Profile, AxisEntity As IDispatch, Pitch As VARIANT, Revolution As VARIANT, Operation As PartFeatureOperationEnum, ByRef AxisDirectionReversed As [defaultvalue(0)] VARIANT_BOOL, ByRef ClockwiseRotation As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CoilFeature*)
Parameters
Parameters | Description
Profile | Input object used to define the shape of the coil.
AxisEntity | Input linear entity that defines the axis of the revolution. Valid input is either a sketch line or work axis. The axis entity must not intersect the input profile.
Pitch | Input Variant that defines the pitch of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Revolution | Input Variant that defines the number of revolutions of the coil feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, it is unitless. If a string is input it must resolve to a unitless value.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
AxisDirectionReversed | Optional input Boolean that indicates a reversal of axis direction. The default is False, which means the axis direction will be in the same direction as the natural direction of the input axis entity.
ClockwiseRotation | Optional input Boolean that defines whether the rotation of the coil is clockwise or counter-clockwise. The default is False, indicating counter-clockwise rotation.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Methods > CoilFeatures.AddSpiral Method


CoilFeatures.Item Method

CoilFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified CoilFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CoilFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature's name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Methods > CoilFeatures.Item Method


CoilFeatures Properties

CoilFeatures Properties
Summary

The properties of the CoilFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Properties


CoilFeatures.Application Property

CoilFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Properties > CoilFeatures.Application Property


CoilFeatures.Count Property

CoilFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Properties > CoilFeatures.Count Property


CoilFeatures.Type Property

CoilFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CoilFeatures Interface > CoilFeatures Properties > CoilFeatures.Type Property


CoincidentConstraint Interface

CoincidentConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CoincidentConstraint object represents a coincident constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::CoincidentConstraint
        Inventor::CoincidentConstraintProxy
Visual Basic
Public Interface CoincidentConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

CoincidentConstraintProxy.NativeObject

GeometricConstraints.AddCoincident

For information on this object, please refer to GeometricConstraint, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint Interface


CoincidentConstraint Properties

CoincidentConstraint Properties
Summary

The properties of the CoincidentConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity being constrained.
EntityTwo | Property that returns the sketch entity being constrained.
StartOrEndPointConstraint | Indicates whether the constraint is between the curve and its endpoint.
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint Interface > CoincidentConstraint Properties


CoincidentConstraint.EntityOne Property

CoincidentConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint Interface > CoincidentConstraint Properties > CoincidentConstraint.EntityOne Property


CoincidentConstraint.EntityTwo Property

CoincidentConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint Interface > CoincidentConstraint Properties > CoincidentConstraint.EntityTwo Property


CoincidentConstraint.StartOrEndPointConstraint Property

CoincidentConstraint.StartOrEndPointConstraint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Indicates whether the constraint is between the curve and its endpoint.

Visual Basic
Property StartOrEndPointConstraint() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint Interface > CoincidentConstraint Properties > CoincidentConstraint.StartOrEndPointConstraint Property


CoincidentConstraint3D Interface

CoincidentConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The CoincidentConstraint3D object represents a coincident constraint within a 3D sketch.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::CoincidentConstraint3D
        Inventor::CoincidentConstraint3DProxy
Visual Basic
Public Interface CoincidentConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

CoincidentConstraint3DProxy.NativeObject

GeometricConstraints3D.AddCoincident

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface


CoincidentConstraint3D Methods

CoincidentConstraint3D Methods
Summary

The methods of the CoincidentConstraint3D class are listed here.

Methods
Methods
Name | Description
Disconnect | Method that disconnects the input entity from the coincident constraint. Valid inputs are SketchPoint, Vertex or WorkPoint.
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface > CoincidentConstraint3D Methods


CoincidentConstraint3D.Disconnect Method

CoincidentConstraint3D.Disconnect Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that disconnects the input entity from the coincident constraint. Valid inputs are SketchPoint, Vertex or WorkPoint.

Visual Basic
Sub Disconnect(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input object that specifies which entity to disconnect. Valid inputs are , Vertex or WorkPoint.
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface > CoincidentConstraint3D Methods > CoincidentConstraint3D.Disconnect Method


CoincidentConstraint3D Properties

CoincidentConstraint3D Properties
Summary

The properties of the CoincidentConstraint3D class are listed here.

Properties
Name | Description
ConnectedEntity | Property that returns the entity connected to this constraint. This can be a SketchPoint, Vertex or a WorkPoint. This property returns Nothing in the case where there isn't a connected entity.
EntityOne | Property that returns the first entity being constrained. This can be a SketchPoint3D, SketchLine3D, WorkPlane or a Face.
EntityTwo | Property that returns the second entity being constrained. This can be a SketchPoint3D, SketchLine3D, WorkPlane or a Face.
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface > CoincidentConstraint3D Properties


CoincidentConstraint3D.ConnectedEntity Property

CoincidentConstraint3D.ConnectedEntity Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the entity connected to this constraint. This can be a SketchPoint, Vertex or a WorkPoint. This property returns Nothing in the case where there isn't a connected entity.

Visual Basic
Property ConnectedEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface > CoincidentConstraint3D Properties > CoincidentConstraint3D.ConnectedEntity Property


CoincidentConstraint3D.EntityOne Property

CoincidentConstraint3D.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the first entity being constrained. This can be a SketchPoint3D, SketchLine3D, WorkPlane or a Face.

Visual Basic
Property EntityOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface > CoincidentConstraint3D Properties > CoincidentConstraint3D.EntityOne Property


CoincidentConstraint3D.EntityTwo Property

CoincidentConstraint3D.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the second entity being constrained. This can be a SketchPoint3D, SketchLine3D, WorkPlane or a Face.

Visual Basic
Property EntityTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3D Interface > CoincidentConstraint3D Properties > CoincidentConstraint3D.EntityTwo Property


CoincidentConstraint3DProxy Interface

CoincidentConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoincidentConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::CoincidentConstraint3D
        Inventor::CoincidentConstraint3DProxy
Visual Basic
Public Interface CoincidentConstraint3DProxy
Inherits CoincidentConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3DProxy Interface


CoincidentConstraint3DProxy Properties

CoincidentConstraint3DProxy Properties
Summary

The properties of the CoincidentConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3DProxy Interface > CoincidentConstraint3DProxy Properties


CoincidentConstraint3DProxy.ContainingOccurrence Property

CoincidentConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3DProxy Interface > CoincidentConstraint3DProxy Properties > CoincidentConstraint3DProxy.ContainingOccurrence Property


CoincidentConstraint3DProxy.NativeObject Property

CoincidentConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CoincidentConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraint3DProxy Interface > CoincidentConstraint3DProxy Properties > CoincidentConstraint3DProxy.NativeObject Property


CoincidentConstraintProxy Interface

CoincidentConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoincidentConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::CoincidentConstraint
        Inventor::CoincidentConstraintProxy
Visual Basic
Public Interface CoincidentConstraintProxy
Inherits CoincidentConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraintProxy Interface


CoincidentConstraintProxy Properties

CoincidentConstraintProxy Properties
Summary

The properties of the CoincidentConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraintProxy Interface > CoincidentConstraintProxy Properties


CoincidentConstraintProxy.ContainingOccurrence Property

CoincidentConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraintProxy Interface > CoincidentConstraintProxy Properties > CoincidentConstraintProxy.ContainingOccurrence Property


CoincidentConstraintProxy.NativeObject Property

CoincidentConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CoincidentConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CoincidentConstraintProxy Interface > CoincidentConstraintProxy Properties > CoincidentConstraintProxy.NativeObject Property


CollinearConstraint Interface

CollinearConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The CollinearConstraint object represents a collinear constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::CollinearConstraint
        Inventor::CollinearConstraintProxy
Visual Basic
Public Interface CollinearConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

CollinearConstraintProxy.NativeObject

GeometricConstraints.AddCollinear

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint Interface


CollinearConstraint Properties

CollinearConstraint Properties
Summary

The properties of the CollinearConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the first sketch entity being constrained.
EntityTwo | Property that returns the second sketch entity being constrained.
UseEllipseOneMajorAxis | Property used in the case where the entity returned by the EntityOne property is an ellipse. This property specifies if the major or minor axis of the ellipse is collinear to EntityTwo. True if it is the major axis.
UseEllipseTwoMajorAxis | Property used in the case where the entity returned by the EntityTwo property is an ellipse. This property specifies if the major or minor axis of the ellipse is collinear to EntityOne. True if it is the major axis.
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint Interface > CollinearConstraint Properties


CollinearConstraint.EntityOne Property

CollinearConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first sketch entity being constrained.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint Interface > CollinearConstraint Properties > CollinearConstraint.EntityOne Property


CollinearConstraint.EntityTwo Property

CollinearConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second sketch entity being constrained.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint Interface > CollinearConstraint Properties > CollinearConstraint.EntityTwo Property


CollinearConstraint.UseEllipseOneMajorAxis Property

CollinearConstraint.UseEllipseOneMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the EntityOne property is an ellipse. This property specifies if the major or minor axis of the ellipse is collinear to EntityTwo. True if it is the major axis.

Visual Basic
Property UseEllipseOneMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint Interface > CollinearConstraint Properties > CollinearConstraint.UseEllipseOneMajorAxis Property


CollinearConstraint.UseEllipseTwoMajorAxis Property

CollinearConstraint.UseEllipseTwoMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the EntityTwo property is an ellipse. This property specifies if the major or minor axis of the ellipse is collinear to EntityOne. True if it is the major axis.

Visual Basic
Property UseEllipseTwoMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint Interface > CollinearConstraint Properties > CollinearConstraint.UseEllipseTwoMajorAxis Property


CollinearConstraint3D Interface

CollinearConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The CollinearConstraint3D object represents a collinear constraint within a 3D sketch. The constraint can be applied between two 3D sketch lines, or between a 3D sketch line and a work axis.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::CollinearConstraint3D
        Inventor::CollinearConstraint3DProxy
Visual Basic
Public Interface CollinearConstraint3D
Inherits GeometricConstraint3D
Remarks

The constraint can be applied between:

  • Two 3D sketch lines
  • A 3D sketch line and a work axis.
Notes

Members through which this object may be accessed include:

CollinearConstraint3DProxy.NativeObject

GeometricConstraints3D.AddCollinear

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3D Interface


CollinearConstraint3D Properties

CollinearConstraint3D Properties
Summary

The properties of the CollinearConstraint3D class are listed here.

Properties
Name | Description
EntityOne | Property that returns the first entity being constrained. This can either be a SketchLine3D or a WorkAxis.
EntityTwo | Property that returns the second entity being constrained. This can either be a SketchLine3D or a WorkAxis.
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3D Interface > CollinearConstraint3D Properties


CollinearConstraint3D.EntityOne Property

CollinearConstraint3D.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the first entity being constrained. This can either be a SketchLine3D or a WorkAxis.

Visual Basic
Property EntityOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3D Interface > CollinearConstraint3D Properties > CollinearConstraint3D.EntityOne Property


CollinearConstraint3D.EntityTwo Property

CollinearConstraint3D.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the second entity being constrained. This can either be a SketchLine3D or a WorkAxis.

Visual Basic
Property EntityTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3D Interface > CollinearConstraint3D Properties > CollinearConstraint3D.EntityTwo Property


CollinearConstraint3DProxy Interface

CollinearConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CollinearConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::CollinearConstraint3D
        Inventor::CollinearConstraint3DProxy
Visual Basic
Public Interface CollinearConstraint3DProxy
Inherits CollinearConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3DProxy Interface


CollinearConstraint3DProxy Properties

CollinearConstraint3DProxy Properties
Summary

The properties of the CollinearConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3DProxy Interface > CollinearConstraint3DProxy Properties


CollinearConstraint3DProxy.ContainingOccurrence Property

CollinearConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3DProxy Interface > CollinearConstraint3DProxy Properties > CollinearConstraint3DProxy.ContainingOccurrence Property


CollinearConstraint3DProxy.NativeObject Property

CollinearConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CollinearConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraint3DProxy Interface > CollinearConstraint3DProxy Properties > CollinearConstraint3DProxy.NativeObject Property


CollinearConstraintProxy Interface

CollinearConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CollinearConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::CollinearConstraint
        Inventor::CollinearConstraintProxy
Visual Basic
Public Interface CollinearConstraintProxy
Inherits CollinearConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraintProxy Interface


CollinearConstraintProxy Properties

CollinearConstraintProxy Properties
Summary

The properties of the CollinearConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraintProxy Interface > CollinearConstraintProxy Properties


CollinearConstraintProxy.ContainingOccurrence Property

CollinearConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraintProxy Interface > CollinearConstraintProxy Properties > CollinearConstraintProxy.ContainingOccurrence Property


CollinearConstraintProxy.NativeObject Property

CollinearConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CollinearConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CollinearConstraintProxy Interface > CollinearConstraintProxy Properties > CollinearConstraintProxy.NativeObject Property


Color Interface

Color Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

The Color object provides access to all of the components defining a color.

Class Hierarchy
Inventor::Color
Visual Basic
Public Interface Color
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AutoCADBlock.Color

ColorScheme.BottomScreenColor

ColorScheme.BottomScreenColor2D

ColorScheme.CutPreviewColor

ColorScheme.DOFFixedColor

ColorScheme.DOFFreeColor

ColorScheme.HighlightColor

ColorScheme.HighlightColor2D

ColorScheme.IntersectPreviewColor

ColorScheme.JoinPreviewColor

ColorScheme.PrimarySelectColor

ColorScheme.PrimarySelectColor2D

ColorScheme.ScreenColor

ColorScheme.ScreenColor2D

ColorScheme.SecondarySelectColor

ColorScheme.TertiarySelectColor

ColorScheme.TopScreenColor

ColorScheme.TopScreenColor2D

CurveGraphics.Color

DimensionStyle.Color

DimensionText.Color

DisplayOptions.EdgeColor

DisplayOptions.InactiveComponentsEdgeColor

DisplaySettings.EdgeColor

DrawingCurve.Color

DrawingCurve.OverrideColor

DrawingNote.Color

DrawingSettings.InvalidFeatureBasedAnnotationsColor

DrawingViewLabel.Color

GraphicsColorMapper.Color

GraphicsColorMapper.MappedColor

GraphicsColorSet.Color

GroundPlaneSettings.Color

HighlightSet.Color

HoleTableStyle.InsideLineColor

HoleTableStyle.OutsideLineColor

Layer.Color

LeaderStyle.Color

LeaderStyle.OverrideColor

Light.Color

NotebookOptions.ArrowColor

NotebookOptions.NoteHighlightColor

NotebookOptions.TextBackgroundColor

RevisionTableStyle.InsideLineColor

RevisionTableStyle.OutsideLineColor

ShadedDisplayOptions.EdgeColorForActiveComponents

ShadedDisplayOptions.EdgeColorForEnabledComponents

SheetSettings.SheetColor

SheetSettings.SheetEntityHighlightColor

SheetSettings.SheetEntitySelectionColor

SheetSettings.SheetOutlineColor

Sketch.Color

Sketch3D.OverrideColor

SketchArc.OverrideColor

SketchBlock.Color

SketchCircle.OverrideColor

SketchedSymbol.Color

SketchEllipse.OverrideColor

SketchEllipticalArc.OverrideColor

SketchFillRegion.Color

SketchFixedSpline.OverrideColor

SketchLine.OverrideColor

SketchOffsetSpline.OverrideColor

SketchSpline.OverrideColor

SurfaceGraphics.Color

SurfaceGraphicsEdge.Color

SurfaceGraphicsFace.Color

TableFormat.InsideLineColor

TableFormat.OutsideLineColor

TableStyle.InsideLineColor

TableStyle.OutsideLineColor

TextBox.Color

TextStyle.Color

TextureMap.MaskColor

TransientObjects.CreateColor

See Also

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > Color Interface


Color Methods

Color Methods
Summary

The methods of the Color class are listed here.

Methods
Methods
Name | Description
GetColor | Method that gets the color components of the Color object.
SetColor | Method that sets the color components of the Color object.
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Methods


Color.GetColor Method

Color.GetColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that gets the color components of the Color object.

Visual Basic
Sub GetColor(ByRef Red As BYTE, ByRef Green As BYTE, ByRef Blue As BYTE)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | Output Byte that specifies the blue component of the color. This value will be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Methods > Color.GetColor Method


Color.SetColor Method

Color.SetColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that sets the color components of the Color object.

Visual Basic
Sub SetColor(Red As BYTE, Green As BYTE, Blue As BYTE)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | Input Byte that specifies the blue component of the color. This value must be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Methods > Color.SetColor Method


Color Properties

Color Properties
Summary

The properties of the Color class are listed here.

Properties
Name | Description
Blue | Property that gets and sets the blue component of the color. This color component is defined using a value between 0 and 255.
ColorSourceType | Property that gets and sets the color source type. Valid values are kAutomaticColorSource, kLayerColorSource and kOverrideColorSource. This property always returns kOverrideColorSource for non-drawing related properties as well as for client graphics.
Green | Property that gets and sets the green component of the color. This color component is defined using a value between 0 and 255.
Opacity | Property that gets and sets the opacity. The opacity is defined using a value between 0 and 1. A value of 0 indicates complete translucency while a value of 1 is completely opaque.
Red | Property that gets and sets the red component of the color. This color component is defined using a value between 0 and 255.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties


Color.Blue Property

Color.Blue Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the blue component of the color. This color component is defined using a value between 0 and 255.

Visual Basic
Property Blue() As BYTE
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties > Color.Blue Property


Color.ColorSourceType Property

Color.ColorSourceType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color source type. Valid values are kAutomaticColorSource, kLayerColorSource and kOverrideColorSource. This property always returns kOverrideColorSource for non-drawing related properties as well as for client graphics.

Visual Basic
Property ColorSourceType() As ColorSourceTypeEnum
Remarks

If a Color object is set to an object (say DrawingCurve), the source type is checked. If it is kOverrideColorSource (the default value of this property), the RGB values are used. If any of the other enum values are used, the RGB values are ignored and values from the source (automatic or layer) are used.

Workflow example: Setting the color of an object to 'by layer'

1. A new transient Color object by specifying any RGB values.

2. The Color.ColorSourceType property is set to kLayerColorSource.

3. The color object is set to any object (e.g. oTextBox.Color = oColor).

4. Since color source is specified as kLayerColorSource, RGB values are ignored and the object is set to layer color.

You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties > Color.ColorSourceType Property


Color.Green Property

Color.Green Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the green component of the color. This color component is defined using a value between 0 and 255.

Visual Basic
Property Green() As BYTE
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties > Color.Green Property


Color.Opacity Property

Color.Opacity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the opacity. The opacity is defined using a value between 0 and 1. A value of 0 indicates complete translucency while a value of 1 is completely opaque.

Visual Basic
Property Opacity() As double
See Also

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties > Color.Opacity Property


Color.Red Property

Color.Red Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the red component of the color. This color component is defined using a value between 0 and 255.

Visual Basic
Property Red() As BYTE
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties > Color.Red Property


Color.Type Property

Color.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Color Interface > Color Properties > Color.Type Property


ColorScheme Interface

ColorScheme Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ColorScheme object represents a single color scheme. It provides access to the various components that make up a color scheme.

Class Hierarchy
Inventor::ColorScheme
Visual Basic
Public Interface ColorScheme
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.ActiveColorScheme

ColorSchemes.Item

You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface


ColorScheme Methods

ColorScheme Methods
Summary

The methods of the ColorScheme class are listed here.

Methods
Methods
Name | Description
Activate | Method that causes this color scheme to become the active color scheme.
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Methods


ColorScheme.Activate Method

ColorScheme.Activate Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that causes this color scheme to become the active color scheme.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Methods > ColorScheme.Activate Method


ColorScheme Properties

ColorScheme Properties
Summary

The properties of the ColorScheme class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BottomScreenColor | Property that returns the bottom screen color used when the BackgroundType is set to kGradientBackgroundType.
BottomScreenColor2D | Property that returns the 2D bottom screen color used when the BackgroundType is set to kGradientBackgroundType.
CutPreviewColor | Property that returns the preview color used when using the 'Cut' option during feature creation.
DOFFixedColor | property that returns the DOF fixed color.
DOFFreeColor | Property that returns the DOF free color.
HighlightColor | Color property that returns the highlight .
HighlightColor2D | Property that returns the 2D highlight color.
ImageFullFileName | Property that gets and sets the full file name of the image file to be used as the background. This is used only if the BackgroundType property on the ColorSchemes object is set to kImageBackgroundType.
IntersectPreviewColor | Property that returns the preview color used when using the 'Intersect' option during feature creation.
JoinPreviewColor | Property that returns the preview color used when using the 'Join' option during feature creation.
Name | String property that returns the name of the color scheme.
PrimarySelectColor | Color property that returns the primary selection .
PrimarySelectColor2D | Property that returns the 2D primary selection color.
ScreenColor | Property that returns the background screen color.
ScreenColor2D | Property that returns the 2D background screen color.
SecondarySelectColor | Color property that returns the secondary selection .
TertiarySelectColor | Gets the TertiarySelectColor Color setting.
TopScreenColor | Property that returns the top screen color used when the BackgroundType is set to kGradientBackgroundType.
TopScreenColor2D | Property that returns the 2D top screen color used when the BackgroundType is set to kGradientBackgroundType.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties


ColorScheme.Application Property

ColorScheme.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.Application Property


ColorScheme.BottomScreenColor Property

ColorScheme.BottomScreenColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the bottom screen color used when the BackgroundType is set to kGradientBackgroundType.

Visual Basic
Property BottomScreenColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.BottomScreenColor Property


ColorScheme.BottomScreenColor2D Property

ColorScheme.BottomScreenColor2D Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the 2D bottom screen color used when the BackgroundType is set to kGradientBackgroundType.

Visual Basic
Property BottomScreenColor2D() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.BottomScreenColor2D Property


ColorScheme.CutPreviewColor Property

ColorScheme.CutPreviewColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the preview color used when using the 'Cut' option during feature creation.

Visual Basic
Property CutPreviewColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.CutPreviewColor Property


ColorScheme.DOFFixedColor Property

ColorScheme.DOFFixedColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

property that returns the DOF fixed color.

Visual Basic
Property DOFFixedColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.DOFFixedColor Property


ColorScheme.DOFFreeColor Property

ColorScheme.DOFFreeColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the DOF free color.

Visual Basic
Property DOFFreeColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.DOFFreeColor Property


ColorScheme.HighlightColor Property

ColorScheme.HighlightColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Color property that returns the highlight .

Visual Basic
Property HighlightColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.HighlightColor Property


ColorScheme.HighlightColor2D Property

ColorScheme.HighlightColor2D Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the 2D highlight color.

Visual Basic
Property HighlightColor2D() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.HighlightColor2D Property


ColorScheme.ImageFullFileName Property

ColorScheme.ImageFullFileName Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the full file name of the image file to be used as the background. This is used only if the BackgroundType property on the ColorSchemes object is set to kImageBackgroundType.

Visual Basic
Property ImageFullFileName() As String
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.ImageFullFileName Property


ColorScheme.IntersectPreviewColor Property

ColorScheme.IntersectPreviewColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the preview color used when using the 'Intersect' option during feature creation.

Visual Basic
Property IntersectPreviewColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.IntersectPreviewColor Property


ColorScheme.JoinPreviewColor Property

ColorScheme.JoinPreviewColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the preview color used when using the 'Join' option during feature creation.

Visual Basic
Property JoinPreviewColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.JoinPreviewColor Property


ColorScheme.Name Property

ColorScheme.Name Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

String property that returns the name of the color scheme.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.Name Property


ColorScheme.PrimarySelectColor Property

ColorScheme.PrimarySelectColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Color property that returns the primary selection .

Visual Basic
Property PrimarySelectColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.PrimarySelectColor Property


ColorScheme.PrimarySelectColor2D Property

ColorScheme.PrimarySelectColor2D Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the 2D primary selection color.

Visual Basic
Property PrimarySelectColor2D() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.PrimarySelectColor2D Property


ColorScheme.ScreenColor Property

ColorScheme.ScreenColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the background screen color.

Visual Basic
Property ScreenColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.ScreenColor Property


ColorScheme.ScreenColor2D Property

ColorScheme.ScreenColor2D Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the 2D background screen color.

Visual Basic
Property ScreenColor2D() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.ScreenColor2D Property


ColorScheme.SecondarySelectColor Property

ColorScheme.SecondarySelectColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Color property that returns the secondary selection .

Visual Basic
Property SecondarySelectColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.SecondarySelectColor Property


ColorScheme.TertiarySelectColor Property

ColorScheme.TertiarySelectColor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the TertiarySelectColor Color setting.

Visual Basic
Property TertiarySelectColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.TertiarySelectColor Property


ColorScheme.TopScreenColor Property

ColorScheme.TopScreenColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the top screen color used when the BackgroundType is set to kGradientBackgroundType.

Visual Basic
Property TopScreenColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.TopScreenColor Property


ColorScheme.TopScreenColor2D Property

ColorScheme.TopScreenColor2D Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the 2D top screen color used when the BackgroundType is set to kGradientBackgroundType.

Visual Basic
Property TopScreenColor2D() As Color**
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.TopScreenColor2D Property


ColorScheme.Type Property

ColorScheme.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ColorScheme Interface > ColorScheme Properties > ColorScheme.Type Property


ColorSchemes Interface

ColorSchemes Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ColorSchemes object provides access to all of the existing objects. This is somewhat equivalent to the Color tab of the Application Options dialog.

Class Hierarchy
Inventor::ColorSchemes
Visual Basic
Public Interface ColorSchemes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.ColorSchemes

You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface


ColorSchemes Methods

ColorSchemes Methods
Summary

The methods of the ColorSchemes class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified ColorScheme object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Methods


ColorSchemes.Item Method

ColorSchemes.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified ColorScheme object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ColorScheme*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ColorScheme to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ColorScheme name. If an out of range index or a name of a non-existent ColorScheme is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Methods > ColorSchemes.Item Method


ColorSchemes Properties

ColorSchemes Properties
Summary

The properties of the ColorSchemes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ApplicationFrameColor | Property that gets and sets the color theme for the application frame. Valid values are kLightColorTheme and kDarkColorTheme.
BackgroundType | Gets and sets the type of background.
Count | Property that returns the number of items in the collection.
EnableEnhancedHighlighting | Property that enables or disables enhanced highlighting option. A value of True allows the highlighting or selecting of assembly components to show through other components.
EnablePrehighlight | Property that enables or disables pre-highlighting during selection. A value of True specifies that pre-highlighting should be enabled during selection.
IconsColor | Property that gets and sets the color theme for the icons in the ribbon interface. Valid values are kCobaltColorTheme and kAmberColorTheme.
InterfaceStyle | Property that gets and sets the user interface style. Valid values are kRibbonInterface and kClassicInterface. In order for a change to be applied, Inventor needs to be restarted.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties


ColorSchemes.Application Property

ColorSchemes.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.Application Property


ColorSchemes.ApplicationFrameColor Property

ColorSchemes.ApplicationFrameColor Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color theme for the application frame. Valid values are kLightColorTheme and kDarkColorTheme.

Visual Basic
Property ApplicationFrameColor() As ApplicationFrameColorTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.ApplicationFrameColor Property


ColorSchemes.BackgroundType Property

ColorSchemes.BackgroundType Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets and sets the type of background.

Visual Basic
Property BackgroundType() As BackgroundTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.BackgroundType Property


ColorSchemes.Count Property

ColorSchemes.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.Count Property


ColorSchemes.EnableEnhancedHighlighting Property

ColorSchemes.EnableEnhancedHighlighting Property
Summary

Property that enables or disables enhanced highlighting option. A value of True allows the highlighting or selecting of assembly components to show through other components.

Visual Basic
Property EnableEnhancedHighlighting() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.EnableEnhancedHighlighting Property


ColorSchemes.EnablePrehighlight Property

ColorSchemes.EnablePrehighlight Property
Summary

Property that enables or disables pre-highlighting during selection. A value of True specifies that pre-highlighting should be enabled during selection.

Visual Basic
Property EnablePrehighlight() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.EnablePrehighlight Property


ColorSchemes.IconsColor Property

ColorSchemes.IconsColor Property Introduced in Inventor 2011
Summary

Property that gets and sets the color theme for the icons in the ribbon interface. Valid values are kCobaltColorTheme and kAmberColorTheme.

Visual Basic
Property IconsColor() As IconsColorTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.IconsColor Property


ColorSchemes.Type Property

ColorSchemes.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.Type Property


Column Interface

Column Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Column object represents a single column in this custom table.See the Custom Tables overview for more information.

Class Hierarchy
Inventor::Column
Visual Basic
Public Interface Column
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Columns.Add

Columns.Item

See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > Column Interface


Column Methods

Column Methods
Summary

The methods of the Column class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this Column object.
Reposition | Method that repositions the column within the table.
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Methods


Column.Delete Method

Column.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes this Column object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Methods > Column.Delete Method


Column.Reposition Method

Column.Reposition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that repositions the column within the table.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing column next to which the column will be inserted. The valid range of values is 0 to the number of existing columns in the table. The position remains unchanged if the index of the column being moved is specified. A value of 0 will put the column at the end. If not specified, a default value of 0 is used, indicating that the column will be moved to the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used indicating that the column will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Methods > Column.Reposition Method


Column Properties

Column Properties
Summary

The properties of the Column class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
InternalTitle | Property that returns the internal name of the column title.
Parent | Property that returns the parent Table.
Title | Property that gets and sets the title of the column header.
TitleHorizontalJustification | Property that gets and sets the justification of the column title.
Type | Property returning an enum indicating this object's type.
ValueHorizontalJustification | Property that gets and sets the justification of the values in the column.
Width | Property that gets and sets the width of the column.
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties


Column.Application Property

Column.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.Application Property


Column.InternalTitle Property

Column.InternalTitle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the internal name of the column title.

Visual Basic
Property InternalTitle() As BSTR*
Remarks

This property is useful for bend and configuration tables. If the display title of the column is changed, this property continues to return the original title of the column. For example, this property always returns 'BEND ID' if this is the Bend Id column of a bend table.

You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.InternalTitle Property


Column.Parent Property

Column.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent Table.

Visual Basic
Property Parent() As CustomTable**
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.Parent Property


Column.Title Property

Column.Title Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the title of the column header.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.Title Property


Column.TitleHorizontalJustification Property

Column.TitleHorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the justification of the column title.

Visual Basic
Property TitleHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.TitleHorizontalJustification Property


Column.Type Property

Column.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.Type Property


Column.ValueHorizontalJustification Property

Column.ValueHorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the justification of the values in the column.

Visual Basic
Property ValueHorizontalJustification() As HorizontalTextAlignmentEnum
See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.ValueHorizontalJustification Property


Column.Width Property

Column.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the width of the column.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > Column Interface > Column Properties > Column.Width Property


Columns Interface

Columns Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Columns collection object represents the collection of objects for this table.See the Custom Tables overview for more information.

Class Hierarchy
Inventor::Columns
Visual Basic
Public Interface Columns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CustomTable.Columns

See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > Columns Interface


Columns Methods

Columns Methods
Summary

The methods of the Columns class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Column. The new created Column is returned.
Item | Property that returns the specified Column object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Methods


Columns.Add Method

Columns.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new Column. The new created Column is returned.

Visual Basic
Sub Add(Title As String, ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, ByRef Width As [optional] VARIANT, Result As [out, retval] Column*)
Parameters
Parameters | Description
Title | Input String that specifies the title for the column.
TargetIndex | Optional input Long that specifies the existing column next to which the new column will be inserted. The valid range of values is 0 to the number of existing columns in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the column will be added at the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
width | Optional input Double that specifies the width of the column. If not specified, a default value is used.
You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Methods > Columns.Add Method


Columns.Item Method

Columns.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified Column object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Column*)
Parameters
Parameters | Description
index | Input Variant value that specifies the Column to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string that corresponds to the title of a column header. If an out of range index or a name of a non-existent Column is provided, an error will occur.
See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Methods > Columns.Item Method


Columns Properties

Columns Properties
Summary

The properties of the Columns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Properties


Columns.Application Property

Columns.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Properties > Columns.Application Property


Columns.Count Property

Columns.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Properties > Columns.Count Property


Columns.Type Property

Columns.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Columns Interface > Columns Properties > Columns.Type Property


CombineFeature Interface

CombineFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CombineFeature object represents an existing combine feature in an Inventor part document.

Class Hierarchy
Inventor::PartFeature
    Inventor::CombineFeature
        Inventor::CombineFeatureProxy
Visual Basic
Public Interface CombineFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CombineFeatureProxy.NativeObject

CombineFeatures.Add

CombineFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface


CombineFeature Methods

CombineFeature Methods
Summary

The methods of the CombineFeature class are listed here.

Methods
Methods
Name | Description
Edit | Method that edits an existing combine feature.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface > CombineFeature Methods


CombineFeature.Edit Method

CombineFeature.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that edits an existing combine feature.

Visual Basic
Sub Edit(BaseBody As SurfaceBody, ToolBodies As ObjectCollection, Operation As PartFeatureOperationEnum)
Parameters
Parameters | Description
BaseBody | Input SurfaceBody object that represents the blank body. This must be a solid body.
ToolBodies | Input ObjectCollection containing one or more SurfaceBody objects that represent the tool bodies. All tool bodies must be solid.
Operation | Input constant that indicates the Boolean operation type for combine. Valid input values are kJoinOperation, kCutOperation and kIntersectOperation.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface > CombineFeature Methods > CombineFeature.Edit Method


CombineFeature Properties

CombineFeature Properties
Summary

The properties of the CombineFeature class are listed here.

Properties
Name | Description
KeepToolBodies | Property that returns whether the tool bodies were retained during the creation of the combine feature.
Operation | Property that gets and sets the operation type. Valid values are kJoinOperation, kCutOperation and kIntersectOperation.
ToolBodies | Property that returns the input tool bodies used to create the feature. If the KeepToolBodies property returns False, the end of part marker needs to be moved above this feature in order to query the bodies.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface > CombineFeature Properties


CombineFeature.KeepToolBodies Property

CombineFeature.KeepToolBodies Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the tool bodies were retained during the creation of the combine feature.

Visual Basic
Property KeepToolBodies() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface > CombineFeature Properties > CombineFeature.KeepToolBodies Property


CombineFeature.Operation Property

CombineFeature.Operation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the operation type. Valid values are kJoinOperation, kCutOperation and kIntersectOperation.

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface > CombineFeature Properties > CombineFeature.Operation Property


CombineFeature.ToolBodies Property

CombineFeature.ToolBodies Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the input tool bodies used to create the feature. If the KeepToolBodies property returns False, the end of part marker needs to be moved above this feature in order to query the bodies.

Visual Basic
Property ToolBodies() As SurfaceBodies**
You are here: Symbol Reference > Inventor Library > Objects > CombineFeature Interface > CombineFeature Properties > CombineFeature.ToolBodies Property


CombineFeatureProxy Interface

CombineFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CombineFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CombineFeature
        Inventor::CombineFeatureProxy
Visual Basic
Public Interface CombineFeatureProxy
Inherits CombineFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CombineFeatureProxy Interface


CombineFeatureProxy Properties

CombineFeatureProxy Properties
Summary

The properties of the CombineFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatureProxy Interface > CombineFeatureProxy Properties


CombineFeatureProxy.ContainingOccurrence Property

CombineFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CombineFeatureProxy Interface > CombineFeatureProxy Properties > CombineFeatureProxy.ContainingOccurrence Property


CombineFeatureProxy.NativeObject Property

CombineFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CombineFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CombineFeatureProxy Interface > CombineFeatureProxy Properties > CombineFeatureProxy.NativeObject Property


CombineFeatures Interface

CombineFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CombineFeatures collection object provides access to existing combine features and supports the ability to create new combine features.

Class Hierarchy
Inventor::CombineFeatures
Visual Basic
Public Interface CombineFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.CombineFeatures

You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface


CombineFeatures Methods

CombineFeatures Methods
Summary

The methods of the CombineFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new combine feature. If the combine feature is created successfully, a CombineFeature object corresponding to the newly created combine feature is returned.
Item | Method that returns the specified CombineFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Methods


CombineFeatures.Add Method

CombineFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new combine feature. If the combine feature is created successfully, a CombineFeature object corresponding to the newly created combine feature is returned.

Visual Basic
Sub Add(BaseBody As SurfaceBody, ToolBodies As ObjectCollection, Operation As PartFeatureOperationEnum, ByRef KeepToolBodies As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CombineFeature*)
Parameters
Parameters | Description
BaseBody | Input SurfaceBody object that represents the blank body. This must be a solid body.
ToolBodies | Input ObjectCollection containing one or more SurfaceBody objects that represent the tool bodies. All tool bodies must be solid.
Operation | Input constant that indicates the Boolean operation type for combine. Valid input values are kJoinOperation, kCutOperation and kIntersectOperation.
KeepToolBodies | Optional input Boolean that specifies whether or not to retain the tool bodies. If not specified, the argument defaults to False and the tool bodies are consumed (i.e. not retained).
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Methods > CombineFeatures.Add Method


CombineFeatures.Item Method

CombineFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified CombineFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CombineFeature*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the object to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent combine feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Methods > CombineFeatures.Item Method


CombineFeatures Properties

CombineFeatures Properties
Summary

The properties of the CombineFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Properties


CombineFeatures.Application Property

CombineFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Properties > CombineFeatures.Application Property


CombineFeatures.Count Property

CombineFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Properties > CombineFeatures.Count Property


CombineFeatures.Type Property

CombineFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CombineFeatures Interface > CombineFeatures Properties > CombineFeatures.Type Property


ComboBoxDefinition CoClass

ComboBoxDefinition CoClass Available in Inventor Introduced in Inventor 9
Summary

The ComboBoxDefinition object represents any command whose user interface is a combo box.

Class Hierarchy
Inventor::ComboBoxDefinition
Visual Basic
Public Class ComboBoxDefinition
Remarks

The ComboBoxDefinition object does not represent the combo box, but instead represents the command. The button itself is represented by a CommandBarControl. One or more controls can reference a single ComboBoxDefinition. The ComboBoxDefinition object is derived from the ControlDefinition object.

Notes

Members through which this object may be accessed include:

ControlDefinitions.AddComboBoxDefinition

Example

"UI customization - create combo box control Example "

This sample demonstrates the creation of a combo-box control using the materials list as an example. Note that this sample only demonstrates the creation of the control. The materials drop down does not update when the material is changed using Inventor's UI. To run the sample, have a part document open.

Public oChangeMaterial As clsChangeMaterial

Public Sub CreateComboBox()
    ' Set a reference to the active document.
    ' This assumes that a part document is active.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    On Error Resume Next
    ' Create a combobox definition
    Dim oComboBoxDef As ComboBoxDefinition
    Set oComboBoxDef = oControlDefs.Item("MaterialsComboBox")

    If oComboBoxDef Is Nothing Then
        Set oComboBoxDef = oControlDefs.AddComboBoxDefinition("Materials", "MaterialsComboBox", kNonShapeEditCmdType, 125, , "Materials Combo", "Materials")

        ' Set a reference to the materials collection.
        Dim oMaterials As Materials
        Set oMaterials = oDoc.Materials

        Dim oMaterial As Material

        For Each oMaterial In oMaterials
            ' Add material names to the combo box definition
            oComboBoxDef.AddItem (oMaterial.Name)
        Next

        ' Set a reference to the Part Standard toolbar
        Dim oPartFeatureToolbar As CommandBar
        Set oPartFeatureToolbar = ThisApplication.UserInterfaceManager.CommandBars.Item("PMxPartFeatureCmdBar")

        ' Add a combo box control to the toolbar
        Dim oComboBoxControl As CommandBarControl
        Set oComboBoxControl = oPartFeatureToolbar.Controls.AddComboBox(oComboBoxDef)

    End If

    ' Clear current selection
    oComboBoxDef.ListIndex = 0

    Set oChangeMaterial = New clsChangeMaterial
    oChangeMaterial.Initialize
End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsChangeMaterial".  The name
' can be changed but you'll need to change the declaration in
' the calling function "CreateComboBox" to use the new name.

Option Explicit
Private WithEvents oComboBoxDef As ComboBoxDefinition

Public Sub Initialize()

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    ' Set a reference to the "MaterialsComboBox" combo box definition
    Set oComboBoxDef = oControlDefs.Item("MaterialsComboBox")

End Sub

Private Sub oComboBoxDef_OnSelect(ByVal Context As NameValueMap)

    If oComboBoxDef.ListIndex = 0 Then
        Exit Sub
    End If

    ' Get the selected item
    Dim oMaterialName As String
    oMaterialName = oComboBoxDef.ListItem(oComboBoxDef.ListIndex)

    ' Set a reference to the active part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oPartCompDef As PartComponentDefinition
    Set oPartCompDef = oDoc.ComponentDefinition

    ' Get the selected material
    Dim oMaterial As Material
    Set oMaterial = oDoc.Materials.Item(oMaterialName)

    ' Change the part material
    oPartCompDef.Material = oMaterial
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinition CoClass


ComboBoxDefinitionObject Interface

ComboBoxDefinitionObject Interface
Summary

The ComboBoxDefinition object represents any command whose user interface is a combo box.

Class Hierarchy
Inventor::ControlDefinition
    Inventor::ComboBoxDefinitionObject
Visual Basic
Public Interface ComboBoxDefinitionObject
Inherits ControlDefinition
Remarks

The ComboBoxDefinition object does not represent the combo box, but instead represents the command. The button itself is represented by a CommandBarControl. One or more controls can reference a single ComboBoxDefinition. The ComboBoxDefinition object is derived from the ControlDefinition object.

Example

"UI customization - create combo box control Example "

This sample demonstrates the creation of a combo-box control using the materials list as an example. Note that this sample only demonstrates the creation of the control. The materials drop down does not update when the material is changed using Inventor's UI. To run the sample, have a part document open.

Public oChangeMaterial As clsChangeMaterial

Public Sub CreateComboBox()

    ' Set a reference to the active document.
    ' This assumes that a part document is active.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    On Error Resume Next
    ' Create a combobox definition
    Dim oComboBoxDef As ComboBoxDefinition
    Set oComboBoxDef = oControlDefs.Item("MaterialsComboBox")

    If oComboBoxDef Is Nothing Then
        Set oComboBoxDef = oControlDefs.AddComboBoxDefinition("Materials", "MaterialsComboBox", kNonShapeEditCmdType, 125, , "Materials Combo", "Materials")

       ' Set a reference to the materials collection.
        Dim oMaterials As Materials
        Set oMaterials = oDoc.Materials

        Dim oMaterial As Material

        For Each oMaterial In oMaterials
            ' Add material names to the combo box definition
            oComboBoxDef.AddItem (oMaterial.Name)
        Next

        ' Set a reference to the Part Standard toolbar
        Dim oPartFeatureToolbar As CommandBar
        Set oPartFeatureToolbar = ThisApplication.UserInterfaceManager.CommandBars.Item("PMxPartFeatureCmdBar")

        ' Add a combo box control to the toolbar
        Dim oComboBoxControl As CommandBarControl
        Set oComboBoxControl = oPartFeatureToolbar.Controls.AddComboBox(oComboBoxDef)

    End If

    ' Clear current selection
    oComboBoxDef.ListIndex = 0

    Set oChangeMaterial = New clsChangeMaterial
    oChangeMaterial.Initialize

End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsChangeMaterial".  The name
' can be changed but you'll need to change the declaration in
' the calling function "CreateComboBox" to use the new name.

Option Explicit
Private WithEvents oComboBoxDef As ComboBoxDefinition

Public Sub Initialize()

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    ' Set a reference to the "MaterialsComboBox" combo box definition
    Set oComboBoxDef = oControlDefs.Item("MaterialsComboBox")
End Sub

Private Sub oComboBoxDef_OnSelect(ByVal Context As NameValueMap)
    If oComboBoxDef.ListIndex = 0 Then
        Exit Sub
    End If

    ' Get the selected item
    Dim oMaterialName As String
    oMaterialName = oComboBoxDef.ListItem(oComboBoxDef.ListIndex)

    ' Set a reference to the active part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oPartCompDef As PartComponentDefinition
    Set oPartCompDef = oDoc.ComponentDefinition

    ' Get the selected material
    Dim oMaterial As Material
    Set oMaterial = oDoc.Materials.Item(oMaterialName)

    ' Change the part material
    oPartCompDef.Material = oMaterial
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface


ComboBoxDefinitionObject Methods

ComboBoxDefinitionObject Methods
Summary

The methods of the ComboBoxDefinitionObject class are listed here.

Methods
Methods
Name | Description
AddItem | Method that adds an item to the drop down list.
Clear | Method that clears all the items in the drop down list.
ListItem | Gets the item specified in the combo box. The index is 1 based.
RemoveItem | Method that removes the specified item from the list.
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Methods


ComboBoxDefinitionObject.AddItem Method

ComboBoxDefinitionObject.AddItem Method
Summary

Method that adds an item to the drop down list.

Visual Basic
Sub AddItem(Item As String, ByRef Index As [defaultvalue(0)] long)
Parameters
Parameters | Description
Item | Input String that specifies the content of the item.
Index | Optional input Long that specifies the position of the item in the list. If not specified, the item is added to the end of the list.
See Also

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Methods > ComboBoxDefinitionObject.AddItem Method


ComboBoxDefinitionObject.Clear Method

ComboBoxDefinitionObject.Clear Method
Summary

Method that clears all the items in the drop down list.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Methods > ComboBoxDefinitionObject.Clear Method


ComboBoxDefinitionObject.ListItem Method

ComboBoxDefinitionObject.ListItem Method
Summary

Gets the item specified in the combo box. The index is 1 based.

Visual Basic
Sub ListItem(Index As long, Result As [out, retval] BSTR)
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Methods > ComboBoxDefinitionObject.ListItem Method


ComboBoxDefinitionObject.RemoveItem Method

ComboBoxDefinitionObject.RemoveItem Method
Summary

Method that removes the specified item from the list.

Visual Basic
Sub RemoveItem(Index As long)
Parameters
Parameters | Description
Index | Input Long that specifies the item within the list to remove. The index is 1-based.
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Methods > ComboBoxDefinitionObject.RemoveItem Method


ComboBoxDefinitionObject Properties

ComboBoxDefinitionObject Properties
Summary

The properties of the ComboBoxDefinitionObject class are listed here.

Properties
Name | Description
DropDownWidth | Property that gets and sets the width (in pixels) of the drop-down portion of a combo box.
ListCount | Property that returns the number of items in the list.
ListIndex | Property that gets and sets the index number of the selected item in the list portion of the combo box. If nothing is selected in the list, this property returns 0. Setting this property causes the specified control to select the given item and execute the appropriate action in the application. If set to 0, the current selection is set to a blank.
Text | Property that gets the text in the display or edit portion of the combo box.
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Properties


ComboBoxDefinitionObject.DropDownWidth Property

ComboBoxDefinitionObject.DropDownWidth Property
Summary

Property that gets and sets the width (in pixels) of the drop-down portion of a combo box.

Visual Basic
Property DropDownWidth() As long
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Properties > ComboBoxDefinitionObject.DropDownWidth Property


ComboBoxDefinitionObject.ListCount Property

ComboBoxDefinitionObject.ListCount Property
Summary

Property that returns the number of items in the list.

Visual Basic
Property ListCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Properties > ComboBoxDefinitionObject.ListCount Property


ComboBoxDefinitionObject.ListIndex Property

ComboBoxDefinitionObject.ListIndex Property
Summary

Property that gets and sets the index number of the selected item in the list portion of the combo box. If nothing is selected in the list, this property returns 0. Setting this property causes the specified control to select the given item and execute the appropriate action in the application. If set to 0, the current selection is set to a blank.

Visual Basic
Property ListIndex() As long
See Also

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Properties > ComboBoxDefinitionObject.ListIndex Property


ComboBoxDefinitionObject.Text Property

ComboBoxDefinitionObject.Text Property
Summary

Property that gets the text in the display or edit portion of the combo box.

Visual Basic
Property Text() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionObject Interface > ComboBoxDefinitionObject Properties > ComboBoxDefinitionObject.Text Property


ComboBoxDefinitionSink Interface

ComboBoxDefinitionSink Interface
Summary

The ComboBoxDefinition object represents any command whose user interface is a combo box.

Class Hierarchy
Inventor::ComboBoxDefinitionSink
Visual Basic
Public Interface ComboBoxDefinitionSink
Inherits IDispatch
Remarks

The ComboBoxDefinition object does not represent the combo box, but instead represents the command. The button itself is represented by a CommandBarControl. One or more controls can reference a single ComboBoxDefinition. The ComboBoxDefinition object is derived from the ControlDefinition object.

Example

"UI customization - create combo box control Example "

This sample demonstrates the creation of a combo-box control using the materials list as an example. Note that this sample only demonstrates the creation of the control. The materials drop down does not update when the material is changed using Inventor's UI. To run the sample, have a part document open.

Public oChangeMaterial As clsChangeMaterial

Public Sub CreateComboBox()

    ' Set a reference to the active document.
    ' This assumes that a part document is active.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    On Error Resume Next
    ' Create a combobox definition
    Dim oComboBoxDef As ComboBoxDefinition
    Set oComboBoxDef = oControlDefs.Item("MaterialsComboBox")

    If oComboBoxDef Is Nothing Then
        Set oComboBoxDef = oControlDefs.AddComboBoxDefinition("Materials", "MaterialsComboBox", kNonShapeEditCmdType, 125, , "Materials Combo", "Materials")

       ' Set a reference to the materials collection.
        Dim oMaterials As Materials
        Set oMaterials = oDoc.Materials

        Dim oMaterial As Material

        For Each oMaterial In oMaterials
            ' Add material names to the combo box definition
            oComboBoxDef.AddItem (oMaterial.Name)
        Next

        ' Set a reference to the Part Standard toolbar
        Dim oPartFeatureToolbar As CommandBar
        Set oPartFeatureToolbar = ThisApplication.UserInterfaceManager.CommandBars.Item("PMxPartFeatureCmdBar")

        ' Add a combo box control to the toolbar
        Dim oComboBoxControl As CommandBarControl
        Set oComboBoxControl = oPartFeatureToolbar.Controls.AddComboBox(oComboBoxDef)

    End If

    ' Clear current selection
    oComboBoxDef.ListIndex = 0

    Set oChangeMaterial = New clsChangeMaterial
    oChangeMaterial.Initialize

End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsChangeMaterial".  The name
' can be changed but you'll need to change the declaration in
' the calling function "CreateComboBox" to use the new name.

Option Explicit
Private WithEvents oComboBoxDef As ComboBoxDefinition

Public Sub Initialize()

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    ' Set a reference to the "MaterialsComboBox" combo box definition
    Set oComboBoxDef = oControlDefs.Item("MaterialsComboBox")
End Sub

Private Sub oComboBoxDef_OnSelect(ByVal Context As NameValueMap)
    If oComboBoxDef.ListIndex = 0 Then
        Exit Sub
    End If

    ' Get the selected item
    Dim oMaterialName As String
    oMaterialName = oComboBoxDef.ListItem(oComboBoxDef.ListIndex)

    ' Set a reference to the active part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oPartCompDef As PartComponentDefinition
    Set oPartCompDef = oDoc.ComponentDefinition

    ' Get the selected material
    Dim oMaterial As Material
    Set oMaterial = oDoc.Materials.Item(oMaterialName)

    ' Change the part material
    oPartCompDef.Material = oMaterial
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionSink Interface


ComboBoxDefinitionSink Methods

ComboBoxDefinitionSink Methods
Summary

The methods of the ComboBoxDefinitionSink class are listed here.

Methods
Methods
Name | Description
OnHelp | Event that is fired when the user selects F1 while the progressive tooltip of this command is being displayed in the ribbon interface.
OnSelect | Event that is fired when an end user changes the selection in the combo box or when the selection is changed using the ListIndex property. This event is not fired for built-in definitions.
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionSink Interface > ComboBoxDefinitionSink Methods


ComboBoxDefinitionSink.OnHelp Method

ComboBoxDefinitionSink.OnHelp Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user selects F1 while the progressive tooltip of this command is being displayed in the ribbon interface.

Visual Basic
Sub OnHelp(Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. Setting the value of the HandlingCode argument specifies how Inventor is to handle displaying help. If you set this argument to kEventNotHandled or kEventCanceled, Inventor will display some general help. Setting the value of this argument to kEventHandled will allow you to handle displaying help to the end-user and Inventor will not display anything. To display help to the end-user you can choose to use whatever help system you want. Inventor's API does not provide support for the actual display of the clients help.
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionSink Interface > ComboBoxDefinitionSink Methods > ComboBoxDefinitionSink.OnHelp Method


ComboBoxDefinitionSink.OnSelect Method

ComboBoxDefinitionSink.OnSelect Method
Summary

Event that is fired when an end user changes the selection in the combo box or when the selection is changed using the ListIndex property. This event is not fired for built-in definitions.

Visual Basic
Sub OnSelect(Context As NameValueMap)
Parameters
Parameters | Description
Context | Input object that can be used to determine the context of why the event fired.
You are here: Symbol Reference > Inventor Library > Objects > ComboBoxDefinitionSink Interface > ComboBoxDefinitionSink Methods > ComboBoxDefinitionSink.OnSelect Method


CommandBar Interface

CommandBar Interface Available in Inventor Introduced in Inventor 5
Summary

The CommandBar object represents an individual command bar. See the article in the overviews section.

Class Hierarchy
Inventor::CommandBar
Visual Basic
Public Interface CommandBar
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CommandBar.Copy

CommandBarControl.CommandBar

CommandBarControl.Parent

CommandBarList.Item

CommandBars.Add

CommandBars.Item

Environment.DefaultMenuBar

Environment.DefaultToolBar

PanelBarObject.CurrentCommandBar

PanelBarObject.DefaultCommandBar

See Also

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

Add a button to the context menu sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface


CommandBar Methods

CommandBar Methods
Summary

The methods of the CommandBar class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a by making a copy of this command bar. New command bar controls are created for the copied command bar, but the underlying definitions for the control are the same.
Delete | Method that deletes this CommandBar object.
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Methods


CommandBar.Copy Method

CommandBar.Copy Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a by making a copy of this command bar. New command bar controls are created for the copied command bar, but the underlying definitions for the control are the same.

Visual Basic
Sub Copy(DisplayName As String, InternalName As String, ByRef ClientId As [defaultvalue("")] BSTR, Result As [out, retval] CommandBar*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the copied command bar. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the name of the copied command bar. This is the internal name and is not displayed to the user. The name must be unique with respect to all other command bars and control definitions in Inventor. The name should remain constant in all locales so it can be used to find a specific command bar.
ClientId | Optional input string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}'. If supplied, this string is used at Inventor start up time to determine whether the AddIn that created this command bar has since been uninstalled. If so, the command bar is deleted. Do not use this argument if programming in VBA unless you do not want the command bar to be persisted to the next session.
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Methods > CommandBar.Copy Method


CommandBar.Delete Method

CommandBar.Delete Method Available in Inventor Introduced in Inventor 9
Summary

Method that deletes this CommandBar object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Methods > CommandBar.Delete Method


CommandBar Properties

CommandBar Properties
Summary

The properties of the CommandBar class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that returns whether the command bar is built-in or not. True if it is a standard Autodesk Inventor command bar. A built-in command bar has restrictions on the modifications that can be performed. For example, a built-in command bar cannot be deleted.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
CommandBarType | Property returning the type of the command bar. The possible return values are kRegularCommandBar, kPopupCommandBar, kButtonPopupCommandBar, kSplitButtonCommandBar and kSplitButtonMRUCommandBar.
Controls | Property that returns the collection. This collection provides access to the controls on the command bar.
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
InternalName | Property that returns the name. The name is the internal unique identifier for the CommandBar.
Parent | Property that returns the parent of the CommandBar.
Type | Property returning an enum indicating this object's type.
Visible | Property that specifies if this command bar is visible or not. Setting this property will fail if the CommandBarType is not kRegularCommandBar.
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties


CommandBar.Application Property

CommandBar.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.Application Property


CommandBar.BuiltIn Property

CommandBar.BuiltIn Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns whether the command bar is built-in or not. True if it is a standard Autodesk Inventor command bar. A built-in command bar has restrictions on the modifications that can be performed. For example, a built-in command bar cannot be deleted.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.BuiltIn Property


CommandBar.ClientId Property

CommandBar.ClientId Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.ClientId Property


CommandBar.CommandBarType Property

CommandBar.CommandBarType Property Available in Inventor Introduced in Inventor 9
Summary

Property returning the type of the command bar. The possible return values are kRegularCommandBar, kPopupCommandBar, kButtonPopupCommandBar, kSplitButtonCommandBar and kSplitButtonMRUCommandBar.

Visual Basic
Property CommandBarType() As CommandBarTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.CommandBarType Property


CommandBar.Controls Property

CommandBar.Controls Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the collection. This collection provides access to the controls on the command bar.

Visual Basic
Property Controls() As CommandBarControls**
See Also

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

Add a button to the context menu sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.Controls Property


CommandBar.DisplayName Property

CommandBar.DisplayName Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.DisplayName Property


CommandBar.InternalName Property

CommandBar.InternalName Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the name. The name is the internal unique identifier for the CommandBar.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.InternalName Property


CommandBar.Parent Property

CommandBar.Parent Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the parent of the CommandBar.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.Parent Property


CommandBar.Type Property

CommandBar.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.Type Property


CommandBar.Visible Property

CommandBar.Visible Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies if this command bar is visible or not. Setting this property will fail if the CommandBarType is not kRegularCommandBar.

Visual Basic
Property Visible() As VARIANT_BOOL
See Also

Buttons - add MRU split button sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBar Interface > CommandBar Properties > CommandBar.Visible Property


CommandBarControl Interface

CommandBarControl Interface Available in Inventor Introduced in Inventor 5
Summary

The CommandBarControl object is the base class for all command bar control objects. See the article in the overviews section.

Class Hierarchy
Inventor::CommandBarControl
Visual Basic
Public Interface CommandBarControl
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CommandBarControls.Add

CommandBarControls.AddButton

CommandBarControls.AddButtonPopup

CommandBarControls.AddComboBox

CommandBarControls.AddMacro

CommandBarControls.AddPopup

CommandBarControls.AddSplitButton

CommandBarControls.AddSplitButtonMRU

CommandBarControls.Item

See Also

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

Add a button to the context menu sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface


CommandBarControl Methods

CommandBarControl Methods
Summary

The methods of the CommandBarControl class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this command bar control.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Methods


CommandBarControl.Delete Method

CommandBarControl.Delete Method Available in Inventor Introduced in Inventor 7
Summary

Method that deletes this command bar control.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Methods > CommandBarControl.Delete Method


CommandBarControl Properties

CommandBarControl Properties
Summary

The properties of the CommandBarControl class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that specifies if the control or definition is a standard Autodesk Inventor control or definition. Built-in ones have restrictions in the edits that can be performed.
CommandBar | Property that returns the object associated with this control. If the ControlType of this control is kButtonControl, kMacroControl or kComboBoxControl this property will return Nothing.
ControlDefinition | Property that returns the ControlDefinition object associated with this control. The ControlDefinition object is the public view of the command the ControlDefinitionHandler represents. The ControlDefinition is required as input when creating new command bar controls.
ControlType | Property that returns the style of the control. Valid types for a control are kButtonControl, kComboBoxControl, kMacroControl, kPopupControl, kButtonPopupControl, kSplitButtonMRUControl, kSplitButtonControl and kUnknownControl. An instance where kUnknownControl is returned is when an AddIn that created this control has been unloaded.
DisplayedControl | Property that gets and sets the current ControlDefinition object for kButtonPopupControl, kSplitButtonMRUControl and kSplitButtonControl control types. For other types, this property returns Nothing.
DisplayName | Property that returns the display name. This is the name that is displayed to the user. For kButtonPopupControl, kSplitButtonMRUControl and kSplitButtonControl control types, this returns the display name of the currently displayed control.
GroupBegins | Property that specifies if the control has a dividing bar immediately to its left or has a dividing bar immediately above. If True, a dividing bar will be displayed. Setting this property to True for the first control in a command bar will not have any effect.
Index | Property that returns the index of this control within the parent command bar.
InternalName | Property that returns the internal unique identifier of the control. This is the name that can be used to retrieve a control from a collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties


CommandBarControl.Application Property

CommandBarControl.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.Application Property


CommandBarControl.BuiltIn Property

CommandBarControl.BuiltIn Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies if the control or definition is a standard Autodesk Inventor control or definition. Built-in ones have restrictions in the edits that can be performed.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.BuiltIn Property


CommandBarControl.CommandBar Property

CommandBarControl.CommandBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the object associated with this control. If the ControlType of this control is kButtonControl, kMacroControl or kComboBoxControl this property will return Nothing.

Visual Basic
Property CommandBar() As CommandBar**
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.CommandBar Property


CommandBarControl.ControlDefinition Property

CommandBarControl.ControlDefinition Property Available in Inventor Introduced in Inventor 7
Summary

Property that returns the ControlDefinition object associated with this control. The ControlDefinition object is the public view of the command the ControlDefinitionHandler represents. The ControlDefinition is required as input when creating new command bar controls.

Visual Basic
Property ControlDefinition() As ControlDefinition**
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.ControlDefinition Property


CommandBarControl.ControlType Property

CommandBarControl.ControlType Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the style of the control. Valid types for a control are kButtonControl, kComboBoxControl, kMacroControl, kPopupControl, kButtonPopupControl, kSplitButtonMRUControl, kSplitButtonControl and kUnknownControl. An instance where kUnknownControl is returned is when an AddIn that created this control has been unloaded.

Visual Basic
Property ControlType() As ControlTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.ControlType Property


CommandBarControl.DisplayedControl Property

CommandBarControl.DisplayedControl Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets the current ControlDefinition object for kButtonPopupControl, kSplitButtonMRUControl and kSplitButtonControl control types. For other types, this property returns Nothing.

Visual Basic
Property DisplayedControl() As ControlDefinition*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.DisplayedControl Property


CommandBarControl.DisplayName Property

CommandBarControl.DisplayName Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the display name. This is the name that is displayed to the user. For kButtonPopupControl, kSplitButtonMRUControl and kSplitButtonControl control types, this returns the display name of the currently displayed control.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.DisplayName Property


CommandBarControl.GroupBegins Property

CommandBarControl.GroupBegins Property Available in Inventor Introduced in Inventor 5
Summary

Property that specifies if the control has a dividing bar immediately to its left or has a dividing bar immediately above. If True, a dividing bar will be displayed. Setting this property to True for the first control in a command bar will not have any effect.

Visual Basic
Property GroupBegins() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.GroupBegins Property


CommandBarControl.Index Property

CommandBarControl.Index Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the index of this control within the parent command bar.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.Index Property


CommandBarControl.InternalName Property

CommandBarControl.InternalName Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the internal unique identifier of the control. This is the name that can be used to retrieve a control from a collection.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.InternalName Property


CommandBarControl.Parent Property

CommandBarControl.Parent Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As CommandBar**
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.Parent Property


CommandBarControl.Type Property

CommandBarControl.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControl Interface > CommandBarControl Properties > CommandBarControl.Type Property


CommandBarControls Interface

CommandBarControls Interface Available in Inventor Introduced in Inventor 5
Summary

The CommandBarControls collection object provides access to all of the source objects in Autodesk Inventor, along with the ability to add new CommandBarControl objects. The command bars represent all of the menus and toolbars.

Class Hierarchy
Inventor::CommandBarControls
Visual Basic
Public Interface CommandBarControls
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

CommandBar.Controls

CommandBarBase.Controls

See Also

Buttons - add MRU split button sample

Example

See CommandBarControls::AddSplitButtonMRU for example "AddSplitButtonMRU Method"

You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface


CommandBarControls Methods

CommandBarControls Methods
Summary

The methods of the CommandBarControls class are listed here.

Methods
Methods
Name | Description
AddButton | Method that creates a new button CommandBarControl object.
AddButtonPopup | Method that creates a new popup CommandBarControl object. An example of this type of control is the 'Display Mode' drop down (Shaded, Hidden Edge, Wireframe) available on the standard toolbar in part and assembly environments.
AddComboBox | Method that creates a new combo-box CommandBarControl object.
AddMacro | Method that creates a new macro CommandBarControl object.
AddPopup | Method that creates a new popup CommandBarControl object. An example of this type of control is the 'Help' control on the menu bar.
AddSplitButton | Method that creates a new split button CommandBarControl object. An example of this type of control is the 'New File' split button drop down available on all standard toolbars.
AddSplitButtonMRU | Method that creates a new split button MRU (Most Recently Used) CommandBarControl object. An example of this type of control is the 'Sketch Constraints' drop down in the Sketch toolbar/panel bar.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods


CommandBarControls.AddButton Method

CommandBarControls.AddButton Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new button CommandBarControl object.

Visual Basic
Sub AddButton(ButtonDefinition As ButtonDefinition, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
ButtonDefinition | Input ButtonDefinition object that specifies the object to associate with this control.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
See Also

Buttons - add MRU split button sample

Example

"Add a button to the content menu"

"This sample demonstrates the addition of a control to the context menu."

' Copy the following into a Module.

Option Explicit

Public oClass1 As Class1

Sub AddToMenu()
    Set oClass1 = New Class1
    oClass1.Initialize
End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "Class1".  The name
' can be changed but you'll need to change the declaration in
' the calling function "AddToMenu" to use the new name.

Option Explicit
Private WithEvents oUserInputEvents As UserInputEvents

Public Sub Initialize()

    Set oUserInputEvents = ThisApplication.CommandManager.UserInputEvents

End Sub

Private Sub oUserInputEvents_OnContextMenu(ByVal SelectionDevice As SelectionDeviceEnum, ByVal AdditionalInfo As NameValueMap, ByVal CommandBar As CommandBar)

    On Error Resume Next

    ' Check if the context menu has the 'Home View' (formerly 'Isometric View') command
    Dim oCmdBarControl As CommandBarControl
    Set oCmdBarControl = CommandBar.Controls.Item("AppIsometricViewCmd")

    If Not oCmdBarControl Is Nothing Then

        Dim oCtrlDef As ControlDefinition
        Set oCtrlDef = ThisApplication.CommandManager.ControlDefinitions.Item("AppZoomAllCmd")

        ' Add the "Zoom All" command before the home view command
        Call CommandBar.Controls.AddButton(oCtrlDef, oCmdBarControl.index)

    End If

End Sub
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddButton Method


CommandBarControls.AddButtonPopup Method

CommandBarControls.AddButtonPopup Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new popup CommandBarControl object. An example of this type of control is the 'Display Mode' drop down (Shaded, Hidden Edge, Wireframe) available on the standard toolbar in part and assembly environments.

Visual Basic
Sub AddButtonPopup(CommandBar As CommandBar, ByRef DisplayedControl As [optional] VARIANT, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
CommandBar | Input CommandBar object that specifies the CommandBar to associate with this control. The CommandBarType of the command bar must be kButtonPopupCommandBar, else an error will occur.
DisplayedControl | Optional Input ControlDefinition object that specifies the default control for the control. This is the control that shows on the top of the control when the control is first displayed. If not specified, the first ControlDefinition on the input command bar is used.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddButtonPopup Method


CommandBarControls.AddComboBox Method

CommandBarControls.AddComboBox Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new combo-box CommandBarControl object.

Visual Basic
Sub AddComboBox(ComboBoxDefinition As ComboBoxDefinition, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
ComboBoxDefinition | Input ComboBoxDefinition object that specifies the object to associate with this control.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
See Also

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddComboBox Method


CommandBarControls.AddMacro Method

CommandBarControls.AddMacro Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new macro CommandBarControl object.

Visual Basic
Sub AddMacro(MacroControlDefinition As MacroControlDefinition, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
MacroControlDefinition | Input MacroControlDefinition object that specifies the object to associate with this control.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
Example

"Macro Button - create on toolbar Example"

This sample demonstrates the creation of a Macro button on a toolbar. To run the sample:1. Have a part document open.2. Exit the sketch edit mode.3. Copy the following code into a VBA module named Module1.

Public Sub CreateMacroControl()

    Dim oCommandMgr As CommandManager
    Set oCommandMgr = ThisApplication.CommandManager

    ' Set a reference to the collection of ControlDefinitions
    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = oCommandMgr.ControlDefinitions

    On Error Resume Next
    ' Create a macro definition
    Dim oMacroDef As MacroControlDefinition
    Set oMacroDef = oControlDefs.Item("macro:Module1.DisplayMessage")

    If oMacroDef Is Nothing Then
        Set oMacroDef = oControlDefs.AddMacroControlDefinition("Module1.DisplayMessage")
    End If

    ' Set a reference to the Part Standard toolbar
    Dim oPartStandardToolbar As CommandBar
    Set oPartStandardToolbar = ThisApplication.UserInterfaceManager.CommandBars.Item("PMxPartStandardCmdBar")

    ' Add a macro control to the toolbar
    Dim oMacroControl As CommandBarControl
    Set oMacroControl = oPartStandardToolbar.Controls.AddMacro(oMacroDef)

    ' Enable the control
    oMacroDef.Enabled = True

End Sub

Public Sub DisplayMessage()
    MsgBox "Display Message Macro"
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddMacro Method


CommandBarControls.AddPopup Method

CommandBarControls.AddPopup Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new popup CommandBarControl object. An example of this type of control is the 'Help' control on the menu bar.

Visual Basic
Sub AddPopup(CommandBar As CommandBar, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
CommandBar | Input CommandBar object that specifies the CommandBar to associate with this control. The CommandBarType of the command bar must be kPopupCommandBar, else an error will occur.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddPopup Method


CommandBarControls.AddSplitButton Method

CommandBarControls.AddSplitButton Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new split button CommandBarControl object. An example of this type of control is the 'New File' split button drop down available on all standard toolbars.

Visual Basic
Sub AddSplitButton(CommandBar As CommandBar, ByRef DisplayedControl As [optional] VARIANT, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
CommandBar | Input CommandBar object that specifies the CommandBar to associate with this control. The CommandBarType of the command bar must be kSplitButtonCommandBar, else an error will occur.
DisplayedControl | Optional Input ControlDefinition object that specifies the default control for the control. This is the control that shows on the top of the control when the control is first displayed. This ControlDefinition must be present in the input CommandBar. If not specified, the first ControlDefinition on the input command bar is used.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddSplitButton Method


CommandBarControls.AddSplitButtonMRU Method

CommandBarControls.AddSplitButtonMRU Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new split button MRU (Most Recently Used) CommandBarControl object. An example of this type of control is the 'Sketch Constraints' drop down in the Sketch toolbar/panel bar.

Visual Basic
Sub AddSplitButtonMRU(CommandBar As CommandBar, ByRef DisplayedControl As [optional] VARIANT, ByRef Before As [defaultvalue(0)] long, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
CommandBar | Input CommandBar object that specifies the CommandBar to associate with this control. The CommandBarType of the command bar must be kSplitButtonMRUCommandBar, else an error will occur.
DisplayedControl | Optional Input ControlDefinition object that specifies the default control for the control. This is the control that shows on the top of the control when the control is first displayed. This ControlDefinition must be present in the input CommandBar. If not specified, the first ControlDefinition on the input command bar is used.
Before | Optional input Long that defines the position of the new control on the command bar. The new control will be inserted before the control at this position. If this argument is omitted, the control is added at the end of the specified command bar.
Example

"Buttons - add MRU split button Example "

This sample demonstrates the creation of a MRU (Most Recently Used) split button control on a toolbar.

Run the following sample with a part document open.

Sub SplitButtonControl()
    ' Set a reference to the active document.
    ' This assumes that the active document is a part document.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the Part Features toolbar.
    Dim oFeaturesCmdBar As CommandBar
    Set oFeaturesCmdBar = ThisApplication.UserInterfaceManager.CommandBars.Item("PMxPartFeatureCmdBar")

    ' Create a new empty command bar
    Dim oCustomCmdBar As CommandBar
    Set oCustomCmdBar = ThisApplication.UserInterfaceManager.CommandBars.Add("PartCustom", "PartCustom", kRegularCommandBar)

    Dim oCtrl As CommandBarControl

    ' Create a SplitButtonMRU type command bar.
    Dim oSplitButtonCmdBar As CommandBar
    Set oSplitButtonCmdBar = ThisApplication.UserInterfaceManager.CommandBars.Add("PartSplit", "PartSplit", kSplitButtonMRUCommandBar)

    ' Add the first 10 items of the PartFeatures toolbar.
    Dim count As Long
    count = 1
    For Each oCtrl In oFeaturesCmdBar.Controls

        oSplitButtonCmdBar.Controls.AddButton oCtrl.ControlDefinition

        If count = 10 Then
            Exit For
        End If

        count = count + 1
    Next

    ' Create a MRU (Most Recently Used) split button control.
    Call oCustomCmdBar.Controls.AddSplitButtonMRU(oSplitButtonCmdBar)

    ' Make the toolbar visible.
    oCustomCmdBar.Visible = True
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.AddSplitButtonMRU Method


CommandBarControls.Item Method

CommandBarControls.Item Method Available in Inventor Introduced in Inventor 7
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CommandBarControl*)
Parameters
Parameters | Description
index | Input Variant that specifies the object within the collection to return.
See Also

Add a button to the context menu sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Methods > CommandBarControls.Item Method


CommandBarControls Properties

CommandBarControls Properties
Summary

The properties of the CommandBarControls class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of CommandBarControls in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Properties


CommandBarControls.Application Property

CommandBarControls.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Properties > CommandBarControls.Application Property


CommandBarControls.Count Property

CommandBarControls.Count Property Available in Inventor Introduced in Inventor 7
Summary

Property that returns the number of CommandBarControls in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Properties > CommandBarControls.Count Property


CommandBarControls.Type Property

CommandBarControls.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarControls Interface > CommandBarControls Properties > CommandBarControls.Type Property


CommandBarList Interface

CommandBarList Interface Available in Inventor Introduced in Inventor 6
Summary

The CommandBarList object defines a list of objects that are displayed to the users in various contexts.

Class Hierarchy
Inventor::CommandBarList
Visual Basic
Public Interface CommandBarList
Inherits IDispatch
Remarks

The context that the command bar list is used in is determined by where the CommandBarList object was obtained. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

Environment.ContextMenuList

EnvironmentBase.PanelBarList

PanelBarObject.CommandBarList

You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface


CommandBarList Methods

CommandBarList Methods
Summary

The methods of the CommandBarList class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new CommandBar object to the list.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
Remove | Method that removes the specified CommandBar from the list.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Methods


CommandBarList.Add Method

CommandBarList.Add Method Available in Inventor Introduced in Inventor 6
Summary

Method that adds a new CommandBar object to the list.

Visual Basic
Sub Add(CommandBar As CommandBar)
Parameters
Parameters | Description
CommandBar | Input object to add to the list.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Methods > CommandBarList.Add Method


CommandBarList.Item Method

CommandBarList.Item Method Available in Inventor Introduced in Inventor 9
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As long, Result As [out, retval] CommandBar*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Methods > CommandBarList.Item Method


CommandBarList.Remove Method

CommandBarList.Remove Method Available in Inventor Introduced in Inventor 9
Summary

Method that removes the specified CommandBar from the list.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Methods > CommandBarList.Remove Method


CommandBarList Properties

CommandBarList Properties
Summary

The properties of the CommandBarList class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of command bars currently in the list.
InheritAll | Property that specifies if this list is to inherit all of the command bars from the parent environment.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Properties


CommandBarList.Application Property

CommandBarList.Application Property Available in Inventor Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Properties > CommandBarList.Application Property


CommandBarList.Count Property

CommandBarList.Count Property Available in Inventor Introduced in Inventor 6
Summary

Property that returns the number of command bars currently in the list.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Properties > CommandBarList.Count Property


CommandBarList.InheritAll Property

CommandBarList.InheritAll Property Available in Inventor Introduced in Inventor 10
Summary

Property that specifies if this list is to inherit all of the command bars from the parent environment.

Visual Basic
Property InheritAll() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Properties > CommandBarList.InheritAll Property


CommandBarList.Type Property

CommandBarList.Type Property Available in Inventor Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBarList Interface > CommandBarList Properties > CommandBarList.Type Property


CommandBars Interface

CommandBars Interface Available in Inventor Introduced in Inventor 5
Summary

The CommandBars collection object provides access to all of the objects in Autodesk Inventor.

Class Hierarchy
Inventor::CommandBars
Visual Basic
Public Interface CommandBars
Inherits IDispatch
Remarks

The command bars represent all of the menus and toolbars. The CommandBar object in Autodesk Inventor is slightly different than that in the Office products. It is the same in that you use the CommandBar object to define menus and toolbars, which includes which buttons are present and their order on the bar. What's different is that the CommandBar does not contain any visibility or position information. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

UserInterfaceManager.CommandBars

See Also

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface


CommandBars Methods

CommandBars Methods
Summary

The methods of the CommandBars class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new CommandBar object.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Methods


CommandBars.Add Method

CommandBars.Add Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new CommandBar object.

Visual Basic
Sub Add(DisplayName As String, InternalName As String, ByRef CommandBarType As [defaultvalue(kRegularCommandBar)] CommandBarTypeEnum, ByRef ClientId As [optional] VARIANT, Result As [out, retval] CommandBar*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the command bar. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the name of the command bar. This is the internal name and is not displayed to the user. The name must be unique with respect to all other command bars and control definitions in Inventor. The name should remain constant in all locales so it can be used to find a specific command bar.
CommandBarType | Optional input that specifies the type of command bar to create. Valid inputs are kRegularCommandBar, kPopupCommandBar, kButtonPopupCommandBar, kSplitButtonCommandBar and kSplitButtonMRUCommandBar. Command bars would typically be created as regular toolbars (using the kRegularCommandBar type). If the intention is to use the command bar in a pop-up, a button pop-up, a split button control or an MRU (Most Recently Used) split button control, the type should be specified as kPopupCommandBar, kButtonPopupCommandBar, kSplitButtonCommandBar and kSplitButtonMRUCommandBar, respectively. The default value is kRegularCommandBar.
ClientId | Optional input string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}". If supplied, this string is used at Inventor start up time to determine whether the AddIn that created this command bar has since been uninstalled. If so, the command bar is deleted. Do not use this argument if programming in VBA unless you do not want the command bar to be persisted to the next session.
See Also

Buttons - add MRU split button sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Methods > CommandBars.Add Method


CommandBars.Item Method

CommandBars.Item Method Available in Inventor Introduced in Inventor 9
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CommandBar*)
Parameters
Parameters | Description
index | Input Variant that specifies the index within the collection of the item to return.
See Also

Change the current panel bar sample

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Methods > CommandBars.Item Method


CommandBars Properties

CommandBars Properties
Summary

The properties of the CommandBars class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Properties


CommandBars.Application Property

CommandBars.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Properties > CommandBars.Application Property


CommandBars.Count Property

CommandBars.Count Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Properties > CommandBars.Count Property


CommandBars.Type Property

CommandBars.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandBars Interface > CommandBars Properties > CommandBars.Type Property


CommandCategories Interface

CommandCategories Interface Available in Inventor Introduced in Inventor 9
Summary

The CommandCategories collection object provides access to all existing objects and provides methods to create additional categories. See the article in the overviews section.

Class Hierarchy
Inventor::CommandCategories
Visual Basic
Public Interface CommandCategories
Inherits IDispatch
Remarks

Since Autodesk Inventor now has a "repeat last command" context menu feature, care should be exercised when adding custom commands that should execute only in very specific circumstances. The preferred behavior is for your command to disable itself when the execution context is not appropriate. If this is not done, an alternative is to assign your command to the "Context Menu" category. Commands which are in the Context Menu category will not participate in command repeat or customization.

Notes

Members through which this object may be accessed include:

CommandManager.CommandCategories

You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface


CommandCategories Methods

CommandCategories Methods
Summary

The methods of the CommandCategories class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a .
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Methods


CommandCategories.Add Method

CommandCategories.Add Method Available in Inventor Introduced in Inventor 9
Summary

Method that adds a .

Visual Basic
Sub Add(DisplayName As String, InternalName As String, ByRef ClientId As [optional] VARIANT, Result As [out, retval] CommandCategory*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the command category. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the name of the command category. This is the internal name and is not displayed to the user. The name must be unique with respect to all other command categories. The name should remain constant in all locales to it can be used to find a specific command category.
ClientId | Input string that uniquely identifies the client. Suggestions are the 'ProgID' of the Add-In creating the resource or its CLSID in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", although any unique string is valid. If you do not use a CLSID or a ProgID, it is recommended that you add your application name to the ClientId to help eliminate naming conflicts.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Methods > CommandCategories.Add Method


CommandCategories.Item Method

CommandCategories.Item Method Available in Inventor Introduced in Inventor 9
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] CommandCategory*)
Parameters
Parameters | Description
index | Input Variant that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Methods > CommandCategories.Item Method


CommandCategories Properties

CommandCategories Properties
Summary

The properties of the CommandCategories class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Properties


CommandCategories.Application Property

CommandCategories.Application Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Properties > CommandCategories.Application Property


CommandCategories.Count Property

CommandCategories.Count Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Properties > CommandCategories.Count Property


CommandCategories.Type Property

CommandCategories.Type Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategories Interface > CommandCategories Properties > CommandCategories.Type Property


CommandCategory Interface

CommandCategory Interface Available in Inventor Introduced in Inventor 9
Summary

The CommandCategory object represents the list of commands that are displayed in the Customize dialog. Command categories serve as a logical grouping of commands to allow the user to more easily find a specific command. See the article in the overviews section.

Class Hierarchy
Inventor::CommandCategory
Visual Basic
Public Interface CommandCategory
Inherits IDispatch
Remarks

Since Autodesk Inventor now has a "repeat last command" context menu feature, care should be exercised when adding custom commands that should execute only in very specific circumstances. The preferred behavior is for your command to disable itself when the execution context is not appropriate. If this is not done, an alternative is to assign your command to the "Context Menu" category. Commands which are in the Context Menu category will not participate in command repeat or customization.

Notes

Members through which this object may be accessed include:

CommandCategories.Add

CommandCategories.Item

You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface


CommandCategory Methods

CommandCategory Methods
Summary

The methods of the CommandCategory class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a control definition or a command bar to the command category.
Delete | Method that deletes the command category. If this category contains commands, these are moved to the default command category. This method fails for built-in categories.
Item | Property that returns the specified object in the collection.
Remove | Method that removes a control definition or a command bar from the command category.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Methods


CommandCategory.Add Method

CommandCategory.Add Method Available in Inventor Introduced in Inventor 9
Summary

Method that adds a control definition or a command bar to the command category.

Visual Basic
Sub Add(Command As IDispatch)
Parameters
Parameters | Description
Command | Input object to be added to this command category. This object can either be a ControlDefinition or a CommandBar. An error will occur if a built-in ControlDefinition or CommandBar is supplied.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Methods > CommandCategory.Add Method


CommandCategory.Delete Method

CommandCategory.Delete Method Available in Inventor Introduced in Inventor 9
Summary

Method that deletes the command category. If this category contains commands, these are moved to the default command category. This method fails for built-in categories.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Methods > CommandCategory.Delete Method


CommandCategory.Item Method

CommandCategory.Item Method Available in Inventor Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Methods > CommandCategory.Item Method


CommandCategory.Remove Method

CommandCategory.Remove Method Available in Inventor Introduced in Inventor 9
Summary

Method that removes a control definition or a command bar from the command category.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Methods > CommandCategory.Remove Method


CommandCategory Properties

CommandCategory Properties
Summary

The properties of the CommandCategory class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that specifies if the control or definition is a standard Autodesk Inventor control or definition. Built-in ones have restrictions in the edits that can be performed.
ClientId | Property that returns the string that uniquely identifies the client.
Count | Property that returns the number of commands in this category.
DisplayName | Property that returns the display name of the command category. This is the name displayed to the user and can vary between locales.
InternalName | Property that returns the name of the command category. The name is the internal English name of the command category. This name will remain constant and is not affected by locale. The name is never displayed to the user. The display name is what's shown to the user.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties


CommandCategory.Application Property

CommandCategory.Application Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.Application Property


CommandCategory.BuiltIn Property

CommandCategory.BuiltIn Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies if the control or definition is a standard Autodesk Inventor control or definition. Built-in ones have restrictions in the edits that can be performed.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.BuiltIn Property


CommandCategory.ClientId Property

CommandCategory.ClientId Property Available in Inventor Introduced in Inventor 2008
Summary

Property that returns the string that uniquely identifies the client.

Visual Basic
Property ClientId() As BSTR*
Remarks

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.ClientId Property


CommandCategory.Count Property

CommandCategory.Count Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the number of commands in this category.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.Count Property


CommandCategory.DisplayName Property

CommandCategory.DisplayName Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the display name of the command category. This is the name displayed to the user and can vary between locales.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.DisplayName Property


CommandCategory.InternalName Property

CommandCategory.InternalName Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the name of the command category. The name is the internal English name of the command category. This name will remain constant and is not affected by locale. The name is never displayed to the user. The display name is what's shown to the user.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.InternalName Property


CommandCategory.Parent Property

CommandCategory.Parent Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As CommandManager**
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.Parent Property


CommandCategory.Type Property

CommandCategory.Type Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandCategory Interface > CommandCategory Properties > CommandCategory.Type Property


CommandControl Interface

CommandControl Interface Available in Inventor Introduced in Inventor 2010
Summary

A CommandControl object represents a user interface control (button, combobox, split button, etc.).

Class Hierarchy
Inventor::CommandControl
Visual Basic
Public Interface CommandControl
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CommandControls.AddButton

CommandControls.AddButtonPopup

CommandControls.AddComboBox

CommandControls.AddGallery

CommandControls.AddMacro

CommandControls.AddPopup

CommandControls.AddSeparator

CommandControls.AddSplitButton

CommandControls.AddSplitButtonMRU

CommandControls.AddTogglePopup

CommandControls.Item

CommandControlsEnumerator.Item

See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface


CommandControl Methods

CommandControl Methods
Summary

The methods of the CommandControl class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the CommandControl. This simply removes the control from the panel, but does not delete the underlying ControlDefinition(s).
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Methods


CommandControl.Delete Method

CommandControl.Delete Method Available in Inventor Introduced in Inventor 2010
Summary

Method that deletes the CommandControl. This simply removes the control from the panel, but does not delete the underlying ControlDefinition(s).

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Methods > CommandControl.Delete Method


CommandControl Properties

CommandControl Properties
Summary

The properties of the CommandControl class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ChildControls | Property that returns a CommandControls collection object that provides access to the child controls of this control.
ControlDefinition | Property that returns the ControlDefinition associated with this control.
ControlType | Property that returns the control type.
DisplayedControl | Property that gets and sets the current ControlDefinition object for kPopupControl, kTogglePopupControl, kButtonPopupControl, kSplitButtonMRUControl and kSplitButtonControl control types. For other control types, this property returns Nothing.
DisplayName | Property that returns the display name of the control.
InternalName | Property that returns the unique internal name of the control.
KeyTip | Property that gets and sets the keyboard access key for the control. KeyTips appear on the Ribbon when you press the ALT key.
Parent | Property that returns the parent object. This can either be a RibbonPanel object if the control resides within a panel, or the UserInterfaceManager object if the control resides elsewhere (Quick Access Toolbar, etc.).
ShowText | Property that gets and sets whether to display the text (display name) associated with the control. The 'Ribbon Appearance' user choice overrides this setting.
Type | Returns an ObjectTypeEnum indicating this object's type.
UseLargeIcon | Property that gets and sets whether to display the control in the larger size. The 'Ribbon Appearance' user choice overrides this setting.
Visible | Property that gets and sets whether this control is visible.
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties


CommandControl.Application Property

CommandControl.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.Application Property


CommandControl.ChildControls Property

CommandControl.ChildControls Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns a CommandControls collection object that provides access to the child controls of this control.

Visual Basic
Property ChildControls() As CommandControls**
Remarks

This property applies only if the ControlType of this control is kPopupControl, kTogglePopupControl, kButtonPopupControl, kGalleryControl, kSplitButtonMRUControl or kSplitButtonControl. For other control types, this property returns Nothing. For control types kButtonControl, kComboBoxControl and kMacroControl, use the ControlDefinition property.

You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.ChildControls Property


CommandControl.ControlDefinition Property

CommandControl.ControlDefinition Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the ControlDefinition associated with this control.

Visual Basic
Property ControlDefinition() As ControlDefinition**
Remarks

This property applies only if the ControlType of this control is kButtonControl, kComboBoxControl or kMacroControl. For other control types, this property returns Nothing. For control types kPopupControl, kTogglePopupControl, kButtonPopupControl, kGalleryControl, kSplitButtonMRUControl and kSplitButtonControl, use the ChildControls property.

You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.ControlDefinition Property


CommandControl.ControlType Property

CommandControl.ControlType Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the control type.

Visual Basic
Property ControlType() As ControlTypeEnum*
Remarks

Valid types for a control are kButtonControl, kComboBoxControl, kMacroControl, kPopupControl, kTogglePopupControl, kButtonPopupControl, kGalleryControl, kSplitButtonMRUControl, kSplitButtonControl, kSeparatorControl and kUnknownControl. Examples and descriptions of these control types can be found in the various 'Add' methods of the CommandControls collection object.

See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.ControlType Property


CommandControl.DisplayedControl Property

CommandControl.DisplayedControl Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the current ControlDefinition object for kPopupControl, kTogglePopupControl, kButtonPopupControl, kSplitButtonMRUControl and kSplitButtonControl control types. For other control types, this property returns Nothing.

Visual Basic
Property DisplayedControl() As ControlDefinition*
Remarks
  • For built-in controls, 'Set' is supported only for kSplitButtonControl and kSplitButtonMRUControl. It returns an error for other types.
  • For kSplitButtonMRUControl and kButtonPopupControl controls, the new DisplayedControl must be a child control.
  • For kSplitButtonControl, kPopupControl and kTogglePopupControl controls, the new DisplayedControl can be a child control or any other control.
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.DisplayedControl Property


CommandControl.DisplayName Property

CommandControl.DisplayName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the display name of the control.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.DisplayName Property


CommandControl.InternalName Property

CommandControl.InternalName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the unique internal name of the control.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.InternalName Property


CommandControl.KeyTip Property

CommandControl.KeyTip Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the keyboard access key for the control. KeyTips appear on the Ribbon when you press the ALT key.

Visual Basic
Property KeyTip() As String
Remarks

A KeyTip must have from 1 to 3 characters, and must not contain spaces, tabs, or newline characters. All characters should be upper case. Make sure that the assigned keytip does not conflict with existing keytips.

You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.KeyTip Property


CommandControl.Parent Property

CommandControl.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent object. This can either be a RibbonPanel object if the control resides within a panel, or the UserInterfaceManager object if the control resides elsewhere (Quick Access Toolbar, etc.).

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.Parent Property


CommandControl.ShowText Property

CommandControl.ShowText Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether to display the text (display name) associated with the control. The 'Ribbon Appearance' user choice overrides this setting.

Visual Basic
Property ShowText() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.ShowText Property


CommandControl.Type Property

CommandControl.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.Type Property


CommandControl.UseLargeIcon Property

CommandControl.UseLargeIcon Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether to display the control in the larger size. The 'Ribbon Appearance' user choice overrides this setting.

Visual Basic
Property UseLargeIcon() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.UseLargeIcon Property


CommandControl.Visible Property

CommandControl.Visible Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether this control is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CommandControl Interface > CommandControl Properties > CommandControl.Visible Property


CommandControls Interface

CommandControls Interface Available in Inventor Introduced in Inventor 2010
Summary

The CommandControls collection object provides access to a collection of user interface controls and provides methods to create additional controls.

Class Hierarchy
Inventor::CommandControls
Visual Basic
Public Interface CommandControls
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CommandControl.ChildControls

Ribbon.QuickAccessControls

RibbonPanel.CommandControls

RibbonPanel.SlideoutControls

UserInterfaceManager.FileBrowserControls

UserInterfaceManager.HelpControls

See Also

Creation of an override environment for a document sample

Adding commands to the application menu sample

Adding commands to the application menu sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface


CommandControls Methods

CommandControls Methods
Summary

The methods of the CommandControls class are listed here.

Methods
Methods
Name | Description
AddButton | Method that creates a new button CommandControl object. An example of this type of control is the 'Extrude' feature command button.
AddButtonPopup | Method that creates a new popup CommandControl object. An example of this type of control is the 'Display Mode' drop down (Shaded, Hidden Edge, Wireframe) available on the 'View' tab of the ribbon in parts and assemblies.
AddComboBox | Method that creates a new combo-box CommandControl object.
AddCopy | Method that creates a copy of an existing CommandControl object as a child control of the current CommandControl. This can be used to copy controls between ribbon panels.
AddGallery | Method that creates a new gallery CommandControl object. An example of this type of control is the gallery control available in the Symbols panel of the Annotate tab in drawings.
AddMacro | Method that creates a new macro CommandControl object.
AddPopup | Method that creates a new popup CommandControl object. An example of this type of control is the 'Switch' control available in the Windows panel of the View tab.
AddSeparator | Method that creates a new separator CommandControl object.
AddSplitButton | Method that creates a new split button CommandControl object. An example of this type of control is the 'New File' split button drop down available in the Quick Access Toolbar.
AddSplitButtonMRU | Method that creates a new split button MRU (Most Recently Used) CommandControl object. An example of this type of control is the 'Circle' drop down in the Sketch tab of the ribbon.
AddTogglePopup | Method that creates a new toggle popup CommandControl object. An example of this type of control is the 'Object Visibility' control available in the Visibility panel of the Views tab.
Item | Property that returns the specified CommandControl object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods


CommandControls.AddButton Method

CommandControls.AddButton Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new button CommandControl object. An example of this type of control is the 'Extrude' feature command button.

Visual Basic
Sub AddButton(ButtonDefinition As ButtonDefinition, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
ButtonDefinition | Input ButtonDefinition object that specifies the object to associate with this control.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

Example 1

This sample demonstrates adding commands to the application menu (a.k.a. File Browser)

Sub AddCommandsToFileBrowser()

    ' Get the application menu controls collection
    Dim oFileBrowserControls As CommandControls
    Set oFileBrowserControls = ThisApplication.UserInterfaceManager.FileBrowserControls

    ' Get the "Zoom All" and "Home View" commands
    Dim oDef1 As ButtonDefinition
    Set oDef1 = ThisApplication.CommandManager.ControlDefinitions.Item("AppZoomAllCmd")

    Dim oDef2 As ButtonDefinition
    Set oDef2 = ThisApplication.CommandManager.ControlDefinitions.Item("AppIsometricViewCmd")

    ' Create button controls, positioned before the "Manage" control
    Call oFileBrowserControls.AddButton(oDef1, True, True, "Manage", True)
    Call oFileBrowserControls.AddButton(oDef2, True, True, "Manage", True)
    Call oFileBrowserControls.AddSeparator("Manage", True)

End Sub
Example 2

See the following pages for samples.

RibbonPanels.Add

Environment.AdditionalVisibleRibbonTabs

EnvironmentManager.OverrideEnvironment

Ribbons

You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddButton Method


CommandControls.AddButtonPopup Method

CommandControls.AddButtonPopup Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new popup CommandControl object. An example of this type of control is the 'Display Mode' drop down (Shaded, Hidden Edge, Wireframe) available on the 'View' tab of the ribbon in parts and assemblies.

Visual Basic
Sub AddButtonPopup(ButtonDefinitions As ObjectCollection, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
ButtonDefinitions | Input ObjectCollection containing the ButtonDefinition objects hosted by this control. The first ButtonDefinition is used as the displayed control. Also, the internal and display names of the first definition are used for the control. The internal name of the control remains unchanged regardless of the currently displayed control.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddButtonPopup Method


CommandControls.AddComboBox Method

CommandControls.AddComboBox Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new combo-box CommandControl object.

Visual Basic
Sub AddComboBox(ComboBoxDefinition As ComboBoxDefinition, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
ComboBoxDefinition | Input ComboBoxDefinition object that specifies the object to associate with this control.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddComboBox Method


CommandControls.AddCopy Method

CommandControls.AddCopy Method
Summary

Method that creates a copy of an existing CommandControl object as a child control of the current CommandControl. This can be used to copy controls between ribbon panels.

Visual Basic
Sub AddCopy(commandControl As CommandControl, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
commandControl | CommandControl to copy
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddCopy Method


CommandControls.AddGallery Method

CommandControls.AddGallery Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new gallery CommandControl object. An example of this type of control is the gallery control available in the Symbols panel of the Annotate tab in drawings.

Visual Basic
Sub AddGallery(ButtonDefinitions As ObjectCollection, ByRef DisplayAsComboBox As [defaultvalue(0)] VARIANT_BOOL, ByRef Width As [defaultvalue(200)] long, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
ButtonDefinitions | Input ObjectCollection containing the ButtonDefinition objects hosted by this control. The internal and display names of the first definition are used for the control.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddGallery Method


CommandControls.AddMacro Method

CommandControls.AddMacro Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new macro CommandControl object.

Visual Basic
Sub AddMacro(MacroControlDefinition As MacroControlDefinition, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
MacroControlDefinition | Input MacroControlDefinition object that specifies the object to associate with this control.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddMacro Method


CommandControls.AddPopup Method

CommandControls.AddPopup Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new popup CommandControl object. An example of this type of control is the 'Switch' control available in the Windows panel of the View tab.

Visual Basic
Sub AddPopup(DisplayedControl As ButtonDefinition, ButtonDefinitions As ObjectCollection, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
DisplayedControl | Input ButtonDefinition object that specifies the displayed control for the control. This ButtonDefinition is only used to extract the icons and the display name for the control.
ButtonDefinitions | Input ObjectCollection containing the ButtonDefinition objects hosted by this control.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddPopup Method


CommandControls.AddSeparator Method

CommandControls.AddSeparator Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new separator CommandControl object.

Visual Basic
Sub AddSeparator(ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
See Also

Adding commands to the application menu sample

You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddSeparator Method


CommandControls.AddSplitButton Method

CommandControls.AddSplitButton Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new split button CommandControl object. An example of this type of control is the 'New File' split button drop down available in the Quick Access Toolbar.

Visual Basic
Sub AddSplitButton(DisplayedControl As ButtonDefinition, ButtonDefinitions As ObjectCollection, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
DisplayedControl | Input ButtonDefinition object that specifies the default control for the control. This is the control that is always displayed to the user.
ButtonDefinitions | Input ObjectCollection containing the ButtonDefinition objects hosted by this control. This collection may include the displayed control, but doesn't have to.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
See Also

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddSplitButton Method


CommandControls.AddSplitButtonMRU Method

CommandControls.AddSplitButtonMRU Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new split button MRU (Most Recently Used) CommandControl object. An example of this type of control is the 'Circle' drop down in the Sketch tab of the ribbon.

Visual Basic
Sub AddSplitButtonMRU(ButtonDefinitions As ObjectCollection, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
ButtonDefinitions | Input ObjectCollection containing the ButtonDefinition objects hosted by this control. The first ButtonDefinition is used as the displayed control. Also, the internal and display names of the first definition are used for the control. The internal name of the control remains unchanged regardless of the currently displayed control.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
See Also

Buttons - add MRU split button sample

You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddSplitButtonMRU Method


CommandControls.AddTogglePopup Method

CommandControls.AddTogglePopup Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new toggle popup CommandControl object. An example of this type of control is the 'Object Visibility' control available in the Visibility panel of the Views tab.

Visual Basic
Sub AddTogglePopup(DisplayedControl As ButtonDefinition, ButtonDefinitions As ObjectCollection, ByRef UseLargeIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef TargetControlInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetControl As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
DisplayedControl | Input ButtonDefinition object that specifies the displayed control for the control. This ButtonDefinition is only used to extract the icons and the display name for the control.
ButtonDefinitions | Input ObjectCollection containing the ButtonDefinition objects hosted by this control. Use the ButtonDefinition.Pressed property to query whether the toggle is checked or unchecked.
UseLargeIcon | Optional input Boolean that specifies whether to use large icon or small icon for the control. If not specified, the small icon is used by default.
ShowText | Optional input Boolean that specifies whether to display text (display name) for the control. If not specified, text is displayed by default.
TargetControlInternalName | Optional input String that specifies the internal name of an existing control to position the new control next to. If specified, the InsertBeforeTargetControl argument indicates whether to place the new control before or after the target control. If not specified, the new control is positioned at the end.
InsertBeforeTargetControl | Optional input Boolean that specifies whether to position the new control before or after the target control. The argument defaults to False and is not used if the TargetControlInternalName argument is not specified.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.AddTogglePopup Method


CommandControls.Item Method

CommandControls.Item Method Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the specified CommandControl object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the CommandControl to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the CommandControl name. If an out of range index or a name of a non-existent CommandControl is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Methods > CommandControls.Item Method


CommandControls Properties

CommandControls Properties
Summary

The properties of the CommandControls class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Properties


CommandControls.Application Property

CommandControls.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Properties > CommandControls.Application Property


CommandControls.Count Property

CommandControls.Count Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Properties > CommandControls.Count Property


CommandControls.Type Property

CommandControls.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandControls Interface > CommandControls Properties > CommandControls.Type Property


CommandControlsEnumerator Interface

CommandControlsEnumerator Interface Available in Inventor Introduced in Inventor 2010
Summary

The CommandControlsEnumerator object provides access to a list of CommandControl objects.

Class Hierarchy
Inventor::CommandControlsEnumerator
Visual Basic
Public Interface CommandControlsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

UserInterfaceManager.AllReferencedControls

You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface


CommandControlsEnumerator Methods

CommandControlsEnumerator Methods
Summary

The methods of the CommandControlsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface > CommandControlsEnumerator Methods


CommandControlsEnumerator.Item Method

CommandControlsEnumerator.Item Method Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] CommandControl*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface > CommandControlsEnumerator Methods > CommandControlsEnumerator.Item Method


CommandControlsEnumerator Properties

CommandControlsEnumerator Properties
Summary

The properties of the CommandControlsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface > CommandControlsEnumerator Properties


CommandControlsEnumerator.Application Property

CommandControlsEnumerator.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface > CommandControlsEnumerator Properties > CommandControlsEnumerator.Application Property


CommandControlsEnumerator.Count Property

CommandControlsEnumerator.Count Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface > CommandControlsEnumerator Properties > CommandControlsEnumerator.Count Property


CommandControlsEnumerator.Type Property

CommandControlsEnumerator.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandControlsEnumerator Interface > CommandControlsEnumerator Properties > CommandControlsEnumerator.Type Property


CommandManager Interface

CommandManager Interface Available in Inventor Introduced in Inventor 4
Summary

The CommandManager object provides functionality that interacts with the various user interaction events. See here for an overview.

Class Hierarchy
Inventor::CommandManager
Visual Basic
Public Interface CommandManager
Inherits IDispatch
Remarks

Note 1. When using SaveAs to export a SAT file, the only way to control the exported SAT version is to change the value of the registry key "SaveACISVersion" located in: HKEY_CURRENT_USERSoftwareAutodeskInventorRegistryVersion12.0TranslatorsSatTranslator The value defaults to 7.

Note 2. The CommandManager.StartCommand (commandID) method to launch in Inventor command has been depreciated. Please use the ControlDefinition.Execute method instead.

Note 3. Since Autodesk Inventor now has a "repeat last command" context menu feature, care should be exercised when adding custom commands that should execute only in very specific circumstances. The preferred behavior is for your command to disable itself when the execution context is not appropriate. If this is not done, an alternative is to assign your command to the "Context Menu" category. Commands which are in the Context Menu category will not participate in command repeat or customization.

Notes

Members through which this object may be accessed include:

Application.CommandManager

CommandCategory.Parent

ControlDefinition.Parent

InteractionEventsObject.Parent

UserInputEventsObject.Parent

See Also

Single selection - simple sample

Copy sketch contents sample

Creation of an override environment for a document sample

Adding commands to the application menu sample

Create a ribbon panel n an existing tab sample

Window Selection sample

OnDrag Event - dragging a WorkPoint sample

Cancel a double click sample

Control Definitions (Inventor Command Names) sample

Copy a sketch sample

Replace content center part sample

Macro Button - create on toolbar sample

Add a button to the context menu sample

UI customization - create combo box control sample

UI customization - create combo box control sample

Example

"Translate - Export to SAT "

This sample demonstrates saving the active part or assembly document to the SAT format.

Public Sub ExportToSat()
  ' Set reference to active document.
  Dim oDoc As Inventor.Document
  Set oDoc = ThisApplication.ActiveDocument

  ' Check the Document type is an assembly or part
  If (oDoc.DocumentType kAssemblyDocumentObject And _
    oDoc.DocumentType kPartDocumentObject) Then
    MsgBox "Error:Document type is not assembly/part"
    Set oDoc = Nothing
    Exit Sub
  End If

  ' Get document's full file name
  Dim sFname As String
  sFname = oDoc.FullFileName

  ' The file format will depend on the extension
  ' Set file name extension to ".SAT"
  sFname = Left$(sFname, Len(sFname) - 3) & "sat"

  ' Do a 'Save Copy As' to SAT format
  Call oDoc.SaveAs(sFname, True)

  Set oDoc = Nothing
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface


CommandManager Methods

CommandManager Methods
Summary

The methods of the CommandManager class are listed here.

Methods
Methods
Name | Description
ClearPrivateEvents | Clears the contents of Autodesk Inventor's internal clipboard.
CreateDragContext | Method that creates a new DragContext object.
CreateInteractionEvents | Method that creates and returns a new InteractionEvents object. The InteractionEvents object is created for document that is currently active.
CreateMiniToolbar | Method that creates a MiniToolbar object associated with the parent InteractionEvents.
DoPreSelect | Method that causes Autodesk Inventor to go through the pre-selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the pre-select notification just like a native pre-selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.
DoSelect | Method that causes Autodesk Inventor to go through the selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the select notification just like a native selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.
DoStopPreSelect | Method that causes Autodesk Inventor to go through the stop pre-selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the stop pre-select notification just like a native stop pre-selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.... more
DoUnSelect | Method that causes Autodesk Inventor to go through the de-selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the de-select notification just like a native de-selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.
PeekPrivateEvent | Method that queries data contained by Autodesk Inventor's internal clipboard.
Pick | Method that allows the user to pick a single entity.
PostPrivateEvent | Method that posts data onto Autodesk Inventor's internal clipboard. Certain commands that usually obtain information using a dialog, i.e. Open, Save, etc., look first to see if data is on the clipboard before displaying the dialog. If valid information is on the clipboard the command will use it instead of displaying the dialog and asking the user to specify the filename.
PromptMessage | This method allows the developer to put up prompt messages (unless the user has suppressed this prompt) much like the Visual Basic MsgBox functionality.
StartCommand | Method that causes the specified command to start. This is the equivalent of the user starting the command using the user-interface.
StartExecutable | Method that causes the specified executable to be run. Using the Parameters argument you can also pass arguments to the executable.
StopActiveCommand | Method that causes the currently running command to be terminated.
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods


CommandManager.ClearPrivateEvents Method

CommandManager.ClearPrivateEvents Method Available in Inventor Introduced in Inventor 10
Summary

Clears the contents of Autodesk Inventor's internal clipboard.

Visual Basic
Sub ClearPrivateEvents()
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.ClearPrivateEvents Method


CommandManager.CreateDragContext Method

CommandManager.CreateDragContext Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new DragContext object.

Visual Basic
Sub CreateDragContext(Result As [out, retval] DragContext*)
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.CreateDragContext Method


CommandManager.CreateInteractionEvents Method

CommandManager.CreateInteractionEvents Method Available in Inventor Introduced in Inventor 5
Summary

Method that creates and returns a new InteractionEvents object. The InteractionEvents object is created for document that is currently active.

Visual Basic
Sub CreateInteractionEvents(Result As [out, retval] InteractionEvents*)
Remarks

If there is no active document this method will fail. Each invocation of this method creates a new object. When a new InteractionEvents object is created, it is not immediately activated. Using the methods and property on it, you can configure the behavior you need and then activate it by using its Start method.

See Also

Window Selection sample

OnDrag Event - dragging a WorkPoint sample

Using measure events sample

InteractionGraphics sample

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.CreateInteractionEvents Method


CommandManager.CreateMiniToolbar Method

CommandManager.CreateMiniToolbar Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a MiniToolbar object associated with the parent InteractionEvents.

Visual Basic
Sub CreateMiniToolbar(Result As [out, retval] MiniToolbar*)
Remarks

The toolbar is associated with the currently active view and is not displayed until the Visible property on it is set to true. When the InteractionEvents is terminated, this MiniToolbar is automatically deleted.

You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.CreateMiniToolbar Method


CommandManager.DoPreSelect Method

CommandManager.DoPreSelect Method Available in Inventor Introduced in Inventor 5
Summary

Method that causes Autodesk Inventor to go through the pre-selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the pre-select notification just like a native pre-selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.

Visual Basic
Sub DoPreSelect(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input Autodesk Inventor object, including custom graphics object, that needs to be understood as a candidate for selection by the active selection process in progress. This entity may have been picked by a means not known to native Autodesk Inventor (say a foreign browser).
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.DoPreSelect Method


CommandManager.DoSelect Method

CommandManager.DoSelect Method Available in Inventor Introduced in Inventor 5
Summary

Method that causes Autodesk Inventor to go through the selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the select notification just like a native selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.

Visual Basic
Sub DoSelect(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input Autodesk Inventor object, including custom graphics object, that needs to be understood as a selection by the active selection process in progress. This entity may have been picked by a means not known to native Autodesk Inventor (say a foreign browser).
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.DoSelect Method


CommandManager.DoStopPreSelect Method

CommandManager.DoStopPreSelect Method Available in Inventor Introduced in Inventor 5
Summary

Method that causes Autodesk Inventor to go through the stop pre-selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the stop pre-select notification just like a native stop pre-selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.

Visual Basic
Sub DoStopPreSelect(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input Autodesk Inventor object, including custom graphics object, that needs to be understood as a candidate for selection by the active selection process in progress. This entity may have been picked by a means not known to native Autodesk Inventor (say a foreign browser).
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.DoStopPreSelect Method


CommandManager.DoUnSelect Method

CommandManager.DoUnSelect Method Available in Inventor Introduced in Inventor 5
Summary

Method that causes Autodesk Inventor to go through the de-selection protocol, including firing of corresponding event out the active InteractionEvents object if one is active. If a native Autodesk Inventor command is active and is in a selection mode, it gets the de-select notification just like a native de-selection happened. This method is useful when you want to perform picking outside of the graphic window. For example if you have a browser that has icons that represent selectable objects you can cause the selection behavior to happen as the user navigates through your browser and selects objects.

Visual Basic
Sub DoUnSelect(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input Autodesk Inventor object, including custom graphics object, that needs to be understood as being de-selected by the active selection process in progress. This entity may have been picked by a means not known to native Autodesk Inventor (say a foreign browser).
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.DoUnSelect Method


CommandManager.PeekPrivateEvent Method

CommandManager.PeekPrivateEvent Method Available in Inventor Introduced in Inventor 10
Summary

Method that queries data contained by Autodesk Inventor's internal clipboard.

Visual Basic
Sub PeekPrivateEvent(ByRef DataType As PrivateEventTypeEnum, ByRef Data As VARIANT)
Parameters
Parameters | Description
DataType | Indicates the type of value contained by the clipboard.
Data | The actual data contained by the clipboard.
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.PeekPrivateEvent Method


CommandManager.Pick Method

CommandManager.Pick Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that allows the user to pick a single entity.

Visual Basic
Sub Pick(Filter As SelectionFilterEnum, PromptText As String, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
Filter | SelectionFilterEnum Entity filter
PromptText | Text to display as prompt.
See Also

Copy sketch contents sample

Replace content center part sample

Example

Single selection - simple example.

The following sample demonstrates getting a single selection from the user.

Public Sub GetSingleSelection()

    ' Get a feature selection from the user
    Dim oObject As Object
    Set oObject = ThisApplication.CommandManager.Pick(kPartFeatureFilter, "Pick a feature")

    MsgBox "Picked: " & oObject.Name

End Sub
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.Pick Method


CommandManager.PostPrivateEvent Method

CommandManager.PostPrivateEvent Method Available in Inventor Introduced in Inventor 4
Summary

Method that posts data onto Autodesk Inventor's internal clipboard. Certain commands that usually obtain information using a dialog, i.e. Open, Save, etc., look first to see if data is on the clipboard before displaying the dialog. If valid information is on the clipboard the command will use it instead of displaying the dialog and asking the user to specify the filename.

Visual Basic
Sub PostPrivateEvent(DataType As PrivateEventTypeEnum, Data As VARIANT)
Parameters
Parameters | Description
DataType | Input constant that specifies the type of value being pushed onto Autodesk Inventor's clipboard. Most often this will be kFileNameEvent.
Data | Input Variant that contains the actual data to push onto Autodesk Inventor's clipboard.
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.PostPrivateEvent Method


CommandManager.PromptMessage Method

CommandManager.PromptMessage Method Available in Inventor Introduced in Inventor 10
Summary

This method allows the developer to put up prompt messages (unless the user has suppressed this prompt) much like the Visual Basic MsgBox functionality.

Visual Basic
Sub PromptMessage(Prompt As String, Buttons As long, ByRef Title As [optional] VARIANT, ByRef DefaultAnswer As [optional] VARIANT, ByRef Restrictions As [optional] VARIANT, ByRef PromptStrings As [optional] VARIANT, Result As [out, retval] long)
Parameters
Parameters
Description
Prompt
The string that will appear in the dialog.
Buttons
Describes which buttons will be used, and which is the default answer. For example "vbOKCancel + vbDefaultButton1", or "vbYesNo".
Title
Each time you call the function, you can give it a new dialog title/caption. If not supplied, the title will default to "Inventor x", where x is the release number.
DefaultAnswer
The default response for the dialog. (vbOK, vbYes, etc.)
Restrictions
The client can specify which of the "don't ask me" options to allow (these options are grayed on the dialog). Also, in Inventor there is an option for which window should get focus when you exit the dialog (default is the mainframe window of Inventor). Zero or more of the following, in combination (can be added together with +): General options

  • kNoRestrictions (Allow all of the radio button options in the dialog "Don't ask ever again", "Don't ask again this session", for all buttons)
  • kDontAllowNeverAgain (Disable the "Don't ever as again" option)
  • kDontAllowNoMoreThisSession (Disable the "Don't ask again this session" option)

Button 1 options (i.e. what is allowed/not allowed if button 1 is picked)

  • kDontAllowButton1NeverAgain (Disable the "Don't ever ask again" option if button 1 is selected)
  • kDontAllowButton1NoMoreThisSession (Disable the "No more this session") Button 2 options (i.e. what is allowed/not allowed if button 2 is picked)
  • kDontAllowButton2NeverAgain (Disable the "Don't ever ask again" option if button 1 is selected)
  • kDontAllowButton2NoMoreThisSession

Button 3 options (i.e. what is allowed/not allowed if button 3 is picked)

  • kDontAllowButton3NeverAgain (Disable the "Don't ever ask again" option if button 1 is selected)
  • kDontAllowButton3NoMoreThisSession

Remarks

If you pick one of the radio buttons in the "Prompts" section of the dialog, the prompt and your choice will be saved to the registry, and your selection will work for future uses of the prompt (i.e. when the client calls the prompt, if the user has selected one of the "don't ask me" options, the dialog is suppressed, and the answer specified earlier by the user is returned).

You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.PromptMessage Method


CommandManager.StartCommand Method

CommandManager.StartCommand Method Available in Inventor
Summary

Method that causes the specified command to start. This is the equivalent of the user starting the command using the user-interface.

Visual Basic
Sub StartCommand(BuiltInCommandId As CommandIDEnum)
Parameters
Parameters | Description
BuiltInCommandId | Input enum value that specifies the built-in command.
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.StartCommand Method


CommandManager.StartExecutable Method

CommandManager.StartExecutable Method Available in Inventor Introduced in Inventor 4
Summary

Method that causes the specified executable to be run. Using the Parameters argument you can also pass arguments to the executable.

Visual Basic
Sub StartExecutable(ExecutableName As String, Parameters As String)
Parameters
Parameters | Description
ExecutableName | Input String that contains the full path of the executable.
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.StartExecutable Method


CommandManager.StopActiveCommand Method

CommandManager.StopActiveCommand Method Available in Inventor Introduced in Inventor 4
Summary

Method that causes the currently running command to be terminated.

Visual Basic
Sub StopActiveCommand()
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Methods > CommandManager.StopActiveCommand Method


CommandManager Properties

CommandManager Properties
Summary

The properties of the CommandManager class are listed here.

Properties
Name | Description
ActiveCommand | Gets the active command (one that is currently running).
CommandCategories | Property that returns the collection.
ControlDefinitions | Property that returns the ControlDefinitions collection.
Parent | Property that returns the parent document of the object.
SelectionActive | Property that informs the client if Autodesk Inventor is currently in selection mode or not. This may be used, for example, by clients to test if calling the DoSelect (and related) methods will have any effect or not.
Type | Property returning an enum indicating this object's type.
UserInputEvents | Property that returns the object that fires events on all user input (commands, keyboard, mouse, etc.).
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties


CommandManager.ActiveCommand Property

CommandManager.ActiveCommand Property Available in Inventor Introduced in Inventor 4
Summary

Gets the active command (one that is currently running).

Visual Basic
Property ActiveCommand() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.ActiveCommand Property


CommandManager.CommandCategories Property

CommandManager.CommandCategories Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the collection.

Visual Basic
Property CommandCategories() As CommandCategories**
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.CommandCategories Property


CommandManager.ControlDefinitions Property

CommandManager.ControlDefinitions Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the ControlDefinitions collection.

Visual Basic
Property ControlDefinitions() As ControlDefinitions**
See Also

Creation of an override environment for a document sample

Adding commands to the application menu sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

Cancel a double click sample

Break alignment of a section view sample

Control Definitions (Inventor Command Names) sample

Copy a sketch sample

Macro Button - create on toolbar sample

Add a button to the context menu sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.ControlDefinitions Property


CommandManager.Parent Property

CommandManager.Parent Property Available in Inventor Introduced in Inventor 4
Summary

Property that returns the parent document of the object.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.Parent Property


CommandManager.SelectionActive Property

CommandManager.SelectionActive Property Available in Inventor Introduced in Inventor 5
Summary

Property that informs the client if Autodesk Inventor is currently in selection mode or not. This may be used, for example, by clients to test if calling the DoSelect (and related) methods will have any effect or not.

Visual Basic
Property SelectionActive() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.SelectionActive Property


CommandManager.Type Property

CommandManager.Type Property Available in Inventor Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.Type Property


CommandManager.UserInputEvents Property

CommandManager.UserInputEvents Property Available in Inventor Introduced in Inventor 6
Summary

Property that returns the object that fires events on all user input (commands, keyboard, mouse, etc.).

Visual Basic
Property UserInputEvents() As UserInputEvents**
See Also

OnDrag Event - dragging a WorkPoint sample

Cancel a double click sample

Add a button to the context menu sample

You are here: Symbol Reference > Inventor Library > Objects > CommandManager Interface > CommandManager Properties > CommandManager.UserInputEvents Property


ComponentDefinition Interface

ComponentDefinition Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ComponentDefinition object is the base class for the PartComponentDefinition, AssemblyComponentDefinition and the FlatPattern objects.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::AssemblyComponentDefinition
    Inventor::FlatPattern
    Inventor::PartComponentDefinition
    Inventor::VirtualComponentDefinition
    Inventor::WeldsComponentDefinition
Visual Basic
Public Interface ComponentDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AnalysisManager.Parent

ApprenticeServerDocument.ComponentDefinition

BOMQuantity.Parent

ComponentDefinitionReference.ReferencedDefinition

ComponentDefinitions.Item

ComponentDefinitionsEnumerator.Item

ComponentOccurrence.ContextDefinition

ComponentOccurrence.Definition

DerivedAliasComponents.Parent

DerivedAssemblyComponents.Parent

DerivedPartComponents.Parent

EndOfFeatures.Parent

iFeatureComponents.Parent

iFeatureTemplateDescriptor.Parent

PartFeature.Parent

ReferenceComponent.Parent

SurfaceBody.ComponentDefinition

UserCoordinateSystem.Parent

WorkAxes.Parent

WorkAxis.Parent

WorkPlane.Parent

WorkPlanes.Parent

WorkPoint.Parent

WorkPoints.Parent

WorkSurface.Parent

WorkSurfaces.Parent

See Also

Translate - Sheet Metal to DXF sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Count Ocurrences sample

Assembly Count Ocurrences sample

Client Graphics - Draw Range Box sample

Using the BOM APIs sample

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface


ComponentDefinition Methods

ComponentDefinition Methods
Summary

The methods of the ComponentDefinition class are listed here.

Methods
Methods
Name | Description
FindUsingPoint | Method that finds all the entities of the specified type at the specified location.
FindUsingVector | Method that finds all the entities of the specified type along the specified vector using either a cylinder or cone that to define the tolerance within the defined vector.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Methods


ComponentDefinition.FindUsingPoint Method

ComponentDefinition.FindUsingPoint Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that finds all the entities of the specified type at the specified location.

Visual Basic
Sub FindUsingPoint(Point As Point, ObjectTypes As SAFEARRAY(SelectionFilterEnum), ByRef ProximityTolerance As [optional] VARIANT, ByRef VisibleObjectsOnly As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Point | Input Point object that specifies the model space point at which to find the entities.
ObjectTypes | Input array of SelelctionFilterEnum values that indicate the type of objects to find. The values are the enum values from the SelectionFilterEnum and can be combined to specify multiple object types.
ProximityTolerance | Input Double that specifies the tolerance value for the search. This value defines the radius of a sphere at the input point. All objects that intersect this sphere will be returned. If not specified, the default internal tolerance is used.
VisibleObjectsOnly | Optional input Boolean that indicates whether or not invisible objects should be included in the search. Defaults to True indicating that invisible objects will be ignored.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Methods > ComponentDefinition.FindUsingPoint Method


ComponentDefinition.FindUsingVector Method

ComponentDefinition.FindUsingVector Method
Summary

Method that finds all the entities of the specified type along the specified vector using either a cylinder or cone that to define the tolerance within the defined vector.

Visual Basic
Sub FindUsingVector(OriginPoint As Point, Direction As UnitVector, ObjectTypes As SAFEARRAY(SelectionFilterEnum), ByRef UseCylinder As [defaultvalue(-1)] VARIANT_BOOL, ByRef ProximityTolerance As [optional] VARIANT, ByRef VisibleObjectsOnly As [defaultvalue(-1)] VARIANT_BOOL, ByRef LocationPoints As [optional] VARIANT, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
OriginPoint | Input Point that defines the model space location to position the vector.
Direction | Input UnitVector that defines direction to find all entities that the vector penetrates. The vector is treated as infinite in both directions from the origin point so all entities that lie in the path of the vector on either side of the origin point will be returned.
ObjectTypes | Input array of SelelctionFilterEnum values that indicate the type of objects to find. The values are the enum values from the SelectionFilterEnum and can be combined to specify multiple object types.
UseCylinder | Input argument that specifies if the vector defines a cylinder or cone when checking to see if an entity is hit by the ray.
ProximityTolerance | Optional input Double that specifies the tolerance value for the search. This value defines the radius of a cylinder if UseCylinderForProximity is True or the angle of the cone if False. If not specified, the default internal tolerance is used.
VisibleObjectsOnly | Optional input Boolean that indicates whether or not invisible objects should be included in the search. Defaults to True indicating that invisible objects will be ignored.
LocationPoints | Optional output that returns a set of Point objects. One Point object is returned for each entity in the FoundEntities list. The point defines the coordinate of the intersection between the vector and the corresponding entity.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Methods > ComponentDefinition.FindUsingVector Method


ComponentDefinition Properties

ComponentDefinition Properties
Summary

The properties of the ComponentDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BOMQuantity | Property that returns the BOMQuantity object.
BOMStructure | Gets and sets how the component is used/viewed in a BOM.
ClientGraphicsCollection | Property that returns the ClientGraphicsCollection object.
DataIO | Gets the object that directly deals with I/O to and from a storage-medium, including Streams(IStream).
Document | Property that returns the containing Document object.
ModelGeometryVersion | Property that returns a string that can be used to determine if the assembly has been modified. This version string is changed every time the assembly is modified. By saving a previous version string, you can compare the current version string to see if the assembly has been modified.
Occurrences | Property that returns the collection object.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
SurfaceBodies | Property that returns all of the result SurfaceBody objects contained within this ComponentDefinition.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties


ComponentDefinition.Application Property

ComponentDefinition.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.Application Property


ComponentDefinition.AttributeSets Property

ComponentDefinition.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.AttributeSets Property


ComponentDefinition.BOMQuantity Property

ComponentDefinition.BOMQuantity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the BOMQuantity object.

Visual Basic
Property BOMQuantity() As BOMQuantity**
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.BOMQuantity Property


ComponentDefinition.BOMStructure Property

ComponentDefinition.BOMStructure Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets and sets how the component is used/viewed in a BOM.

Visual Basic
Property BOMStructure() As BOMStructureEnum
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.BOMStructure Property


ComponentDefinition.ClientGraphicsCollection Property

ComponentDefinition.ClientGraphicsCollection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ClientGraphicsCollection object.

Visual Basic
Property ClientGraphicsCollection() As ClientGraphicsCollection**
See Also

Client graphics - image in point graphics sample

Create client graphics based on the solid body of the active part sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Transient solid body creation sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Client Graphics - Triangle sample

Client graphics from SAT file body sample

Client Graphics - Line sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.ClientGraphicsCollection Property


ComponentDefinition.DataIO Property

ComponentDefinition.DataIO Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object that directly deals with I/O to and from a storage-medium, including Streams(IStream).

Visual Basic
Property DataIO() As DataIO**
See Also

Translate - Sheet Metal to DXF sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.DataIO Property


ComponentDefinition.Document Property

ComponentDefinition.Document Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the containing Document object.

Visual Basic
Property Document() As IDispatch**
See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.Document Property


ComponentDefinition.ModelGeometryVersion Property

ComponentDefinition.ModelGeometryVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a string that can be used to determine if the assembly has been modified. This version string is changed every time the assembly is modified. By saving a previous version string, you can compare the current version string to see if the assembly has been modified.

Visual Basic
Property ModelGeometryVersion() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.ModelGeometryVersion Property


ComponentDefinition.Occurrences Property

ComponentDefinition.Occurrences Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection object.

Visual Basic
Property Occurrences() As ComponentOccurrences**
See Also

Place content center part sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

Assembly Count Ocurrences sample

Assembly Mate Constraint of Work Planes sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.Occurrences Property


ComponentDefinition.RangeBox Property

ComponentDefinition.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.RangeBox Property


ComponentDefinition.SurfaceBodies Property

ComponentDefinition.SurfaceBodies Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns all of the result SurfaceBody objects contained within this ComponentDefinition.

Visual Basic
Property SurfaceBodies() As SurfaceBodies**
Remarks

This property does not return bodies of surface features. Bodies are classified into two categories: result and work. Work bodies are intermediate bodies used for constructing the model and do not directly contribute to the part"s result body (or bodies). In Inventor graphics, result bodies are displayed in grey, whereas work bodies are displayed in yellow. The SurfaceBodies property is designed to return only result bodies. However, note that result bodies can be solid or surface. So, if you start with a solid result body, and delete one of its faces, the body remains as a result body (grey color) but is now a surface body. This property will still return such bodies.

To get a collection object that encapsulates all of the work surfaces defined in a PartComponentDefinition, use the PartComponentDefinition.WorkSurfaces property.

See Also

Associative body copy sample

Create client graphics based on the solid body of the active part sample

Client graphics texture-based color mapping sample

Sketch Edit Orientation sample

Sketch Add Oriented sample

Sketch Add sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.SurfaceBodies Property


ComponentDefinition.Type Property

ComponentDefinition.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinition Interface > ComponentDefinition Properties > ComponentDefinition.Type Property


ComponentDefinitions Interface

ComponentDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that holds a collection of objects.

Class Hierarchy
Inventor::ComponentDefinitions
Visual Basic
Public Interface ComponentDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.ComponentDefinitions

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitions Interface


ComponentDefinitions Methods

ComponentDefinitions Methods
Summary

The methods of the ComponentDefinitions class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitions Interface > ComponentDefinitions Methods


ComponentDefinitions.Item Method

ComponentDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] ComponentDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
See Also

Using the BOM APIs sample

Mate constraint with limits sample

Assembly Mate Constraint of Work Planes sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitions Interface > ComponentDefinitions Methods > ComponentDefinitions.Item Method


ComponentDefinitions Properties

ComponentDefinitions Properties
Summary

The properties of the ComponentDefinitions class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitions Interface > ComponentDefinitions Properties


ComponentDefinitions.Count Property

ComponentDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitions Interface > ComponentDefinitions Properties > ComponentDefinitions.Count Property


ComponentDefinitions.Type Property

ComponentDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitions Interface > ComponentDefinitions Properties > ComponentDefinitions.Type Property


ComponentDefinitionsEnumerator Interface

ComponentDefinitionsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

Provides access to a list of objects.

Class Hierarchy
Inventor::ComponentDefinitionsEnumerator
Visual Basic
Public Interface ComponentDefinitionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BOMRow.ComponentDefinitions

See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitionsEnumerator Interface


ComponentDefinitionsEnumerator Methods

ComponentDefinitionsEnumerator Methods
Summary

The methods of the ComponentDefinitionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitionsEnumerator Interface > ComponentDefinitionsEnumerator Methods


ComponentDefinitionsEnumerator.Item Method

ComponentDefinitionsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] ComponentDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitionsEnumerator Interface > ComponentDefinitionsEnumerator Methods > ComponentDefinitionsEnumerator.Item Method


ComponentDefinitionsEnumerator Properties

ComponentDefinitionsEnumerator Properties
Summary

The properties of the ComponentDefinitionsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitionsEnumerator Interface > ComponentDefinitionsEnumerator Properties


ComponentDefinitionsEnumerator.Count Property

ComponentDefinitionsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitionsEnumerator Interface > ComponentDefinitionsEnumerator Properties > ComponentDefinitionsEnumerator.Count Property


ComponentDefinitionsEnumerator.Type Property

ComponentDefinitionsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ComponentDefinitionsEnumerator Interface > ComponentDefinitionsEnumerator Properties > ComponentDefinitionsEnumerator.Type Property


ComponentGraphics Interface

ComponentGraphics Interface Available in Inventor Introduced in Inventor 2012
Summary

The ComponentGraphics object defines a graphics object created using a ComponentDefinition.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::ComponentGraphics
Visual Basic
Public Interface ComponentGraphics
Inherits GraphicsPrimitive
Remarks

The properties and methods of this object are in addition to those supported by the GraphicsPrimitive object.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface


ComponentGraphics Methods

ComponentGraphics Methods
Summary

The methods of the ComponentGraphics class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use.
GetTransformBehavior | Method that gets the current transform behavior of the graphic object.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file.
SetTransformBehavior | Method that sets the transform behavior of the graphic object.
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Methods


ComponentGraphics.GetCustomLineType Method

ComponentGraphics.GetCustomLineType Method Available in Inventor Introduced in Inventor 2012
Summary

Method that returns information regarding the custom line type in use.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
Remarks

The method returns a failure if the return value of the LineType property is not kCustomLineType.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Methods > ComponentGraphics.GetCustomLineType Method


ComponentGraphics.GetTransformBehavior Method

ComponentGraphics.GetTransformBehavior Method Available in Inventor Introduced in Inventor 2012
Summary

Method that gets the current transform behavior of the graphic object.

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point object that returns the anchor point of the graphic object in model space. The coordinates of this point are always defined in model space. The value of this argument is irrelevant when the behavior type to kNoTransformBehaviors.
BehaviorType | Output value from DisplayTransformBehaviorEnum that returns the type of transform behavior the text has. Valid values are kFrontFacing, kFrontFacingAndPixelScaling, kNoTransformBehaviors, and kPixelScaling. TextGraphics objects are always front facing regardless of the defined behavior type.
PixelScale | Output Double that returns the scale factor to apply to all coordinates associated with this graphics object. The scale factor is only relevant when the object has pixel scaling behavior.
Remarks

Graphic objects have two special transform behaviors: front facing and pixel scaling. A front facing object does not rotate as the view is rotated but maintains the same orientation on the screen. It is positioned at a specified location within model and its position on the screen will change as the view is zoomed in and out and scrolled, but its orientation will not change.

A graphic object that has pixel scaling behavior maintains the same size relative to the screen. As the user zooms in and out the graphic objects visible size on the screen will remain the same.

By default an object has no transform behavior, which means its size, position, and orientation are relative to model space. Text always has front facing behavior regardless of the behavior type returned through this method.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Methods > ComponentGraphics.GetTransformBehavior Method


ComponentGraphics.SetCustomLineType Method

ComponentGraphics.SetCustomLineType Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets a custom line type to the curve from the specified .lin file.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
Remarks

The method automatically changes the value of LineType property to kCustomLineType.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Methods > ComponentGraphics.SetCustomLineType Method


ComponentGraphics.SetTransformBehavior Method

ComponentGraphics.SetTransformBehavior Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the transform behavior of the graphic object.

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input Point object that specifies the anchor point of the graphic object in model space. The coordinates of this point are always defined in model space. The value of this argument is ignored when setting the behavior type to kNoTransformBehaviors.
BehaviorType | Input value from DisplayTransformBehaviorEnum that specifies the type of transform behavior the text has. Valid values are kFrontFacing, kFrontFacingAndPixelScaling, kNoTransformBehaviors, and kPixelScaling. TextGraphics objects are always front facing regardless of the defined behavior type.
PixelScale | Input Double that defines the scale factor to apply to all coordinates associated with this graphics object. This scale factor is only used when the behavior type is kFrontFacingAndPixelScaling or kPixelScaling.
Remarks

Graphic objects have two special transform behaviors: front facing and pixel scaling. A front facing object does not rotate as the view is rotated but maintains the same orientation on the screen. It is positioned at a specified location within model and its position on the screen will change as the view is zoomed in and out and scrolled, but its orientation will not change.

A graphic object that has pixel scaling behavior maintains the same size relative to the screen. As the user zooms in and out the graphic objects visible size on the screen will remain the same.

Any graphic object can have no transform behavior which means it’s size, position, and orientation are relative to model space, front facing behavior, pixel scaling behavior, or front facing and pixel scaling behavior. By default an object has not transform behavior, with the exception of text. Text always has front facing behavior regardless of the behavior type set through this method.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Methods > ComponentGraphics.SetTransformBehavior Method


ComponentGraphics Properties

ComponentGraphics Properties
Summary

The properties of the ComponentGraphics class are listed here.

Properties
Name | Description
Body | Property that returns the SurfaceBody object associated with the SurfaceGraphics.
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
Color | Property that gets and sets the color associated with the primitive.
DepthPriority | Property that allows you to specify a display priority to the graphics.
DisplayedEdges | This is DisplayedEdges, a member of class ComponentGraphics.
DisplayedFaces | This is DisplayedFaces, a member of class ComponentGraphics.
DisplaySilhouettes | Property that specifies whether or not to display the silhouette edges of bodies.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type associated with the primitive.
LineWeight | Property that gets and sets the thickness of this primitive.
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties


ComponentGraphics.Body Property

ComponentGraphics.Body Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the SurfaceBody object associated with the SurfaceGraphics.

Visual Basic
Property Body() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.Body Property


ComponentGraphics.BurnThrough Property

ComponentGraphics.BurnThrough Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.BurnThrough Property


ComponentGraphics.Color Property

ComponentGraphics.Color Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the color associated with the primitive.

Visual Basic
Property Color() As Color*
Remarks

If no color set is defined, the render style color defined for the GraphicsNode will be used. This property can be set to Nothing to remove the reference to a color and return to using the colors defined by the display style of the GraphicsNode.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.Color Property


ComponentGraphics.DepthPriority Property

ComponentGraphics.DepthPriority Property Available in Inventor Introduced in Inventor 2012
Summary

Property that allows you to specify a display priority to the graphics.

Visual Basic
Property DepthPriority() As long
Remarks

This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.DepthPriority Property


ComponentGraphics.DisplayedEdges Property

ComponentGraphics.DisplayedEdges Property
Summary

This is DisplayedEdges, a member of class ComponentGraphics.

Visual Basic
Property DisplayedEdges() As SurfaceGraphicsEdgeList**
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.DisplayedEdges Property


ComponentGraphics.DisplayedFaces Property

ComponentGraphics.DisplayedFaces Property
Summary

This is DisplayedFaces, a member of class ComponentGraphics.

Visual Basic
Property DisplayedFaces() As SurfaceGraphicsFaceList**
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.DisplayedFaces Property


ComponentGraphics.DisplaySilhouettes Property

ComponentGraphics.DisplaySilhouettes Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies whether or not to display the silhouette edges of bodies.

Visual Basic
Property DisplaySilhouettes() As VARIANT_BOOL
Remarks

The property defaults to True when the ComponentGraphics object is created.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.DisplaySilhouettes Property


ComponentGraphics.LineDefinitionSpace Property

ComponentGraphics.LineDefinitionSpace Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the line definition space for this primitive.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
Remarks

This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.LineDefinitionSpace Property


ComponentGraphics.LineScale Property

ComponentGraphics.LineScale Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.LineScale Property


ComponentGraphics.LineType Property

ComponentGraphics.LineType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the line type associated with the primitive.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.LineType Property


ComponentGraphics.LineWeight Property

ComponentGraphics.LineWeight Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the thickness of this primitive.

Visual Basic
Property LineWeight() As double
Remarks

If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

You are here: Symbol Reference > Inventor Library > Objects > ComponentGraphics Interface > ComponentGraphics Properties > ComponentGraphics.LineWeight Property


ComponentOccurrence Interface

ComponentOccurrence Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This object represents an individual occurrence within an assembly. An occurrence can be either a part or subassembly. Information obtained from the occurrence is returned in the context of the component definition that served as the starting point to access the occurrence.

Class Hierarchy
Inventor::ComponentOccurrence
    Inventor::ComponentOccurrenceProxy
Visual Basic
Public Interface ComponentOccurrence
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AngleConstraintProxy.ContainingOccurrence

AngleiMateDefinitionProxy.ContainingOccurrence

AssemblyComponentDefinition.ActiveOccurrence

AssemblyConstraint.AffectedOccurrenceOne

AssemblyConstraint.AffectedOccurrenceTwo

AssemblyConstraint.OccurrenceOne

AssemblyConstraint.OccurrenceTwo

BendConstraintProxy.ContainingOccurrence

BendPartFeatureProxy.ContainingOccurrence

BossFeatureProxy.ContainingOccurrence

BoundaryPatchFeatureProxy.ContainingOccurrence

ChamferFeatureProxy.ContainingOccurrence

CircularOccurrencePatternProxy.ContainingOccurrence

CircularPatternFeatureProxy.ContainingOccurrence

ClientFeatureElementProxy.ContainingOccurrence

ClientFeatureProxy.ContainingOccurrence

CoilFeatureProxy.ContainingOccurrence

CoincidentConstraint3DProxy.ContainingOccurrence

CoincidentConstraintProxy.ContainingOccurrence

CollinearConstraint3DProxy.ContainingOccurrence

CollinearConstraintProxy.ContainingOccurrence

CombineFeatureProxy.ContainingOccurrence

ComponentOccurrence.ParentOccurrence

ComponentOccurrenceProxy.ContainingOccurrence

ComponentOccurrenceProxy.NativeObject

ComponentOccurrences.Add

ComponentOccurrences.AddByComponentDefinition

ComponentOccurrences.AddCustomiPartMember

ComponentOccurrences.AddiAssemblyMember

ComponentOccurrences.AddiPartMember

ComponentOccurrences.AddVirtual

ComponentOccurrences.AddWithOptions

ComponentOccurrences.ItemByName

ComponentOccurrencesEnumerator.Item

CompositeiMateDefinitionProxy.ContainingOccurrence

ConcentricConstraint3DProxy.ContainingOccurrence

ConcentricConstraintProxy.ContainingOccurrence

CustomConstraint3DProxy.ContainingOccurrence

CustomConstraintProxy.ContainingOccurrence

DecalFeatureProxy.ContainingOccurrence

DeleteFaceFeatureProxy.ContainingOccurrence

DerivedAliasComponentProxy.ContainingOccurrence

DerivedAssemblyComponentProxy.ContainingOccurrence

DerivedAssemblyOccurrence.ReferencedOccurrence

DerivedPartComponentProxy.ContainingOccurrence

DiameterDimConstraintProxy.ContainingOccurrence

EdgeLoopProxy.ContainingOccurrence

EdgeProxy.ContainingOccurrence

EdgeUseProxy.ContainingOccurrence

EllipseRadiusDimConstraintProxy.ContainingOccurrence

EmbossFeatureProxy.ContainingOccurrence

EqualLengthConstraintProxy.ContainingOccurrence

EqualRadiusConstraintProxy.ContainingOccurrence

ExtendFeatureProxy.ContainingOccurrence

ExtrudeFeatureProxy.ContainingOccurrence

FaceDraftFeatureProxy.ContainingOccurrence

FaceProxy.ContainingOccurrence

FaceShellProxy.ContainingOccurrence

FeatureBasedOccurrencePatternProxy.ContainingOccurrence

FeatureDimensionProxy.ContainingOccurrence

FeaturePatternElementProxy.ContainingOccurrence

FilletFeatureProxy.ContainingOccurrence

FlushConstraintProxy.ContainingOccurrence

FlushiMateDefinitionProxy.ContainingOccurrence

GraphicsNodeProxy.ContainingOccurrence

GrillFeatureProxy.ContainingOccurrence

GroundConstraint3DProxy.ContainingOccurrence

GroundConstraintProxy.ContainingOccurrence

HelicalConstraint3DProxy.ContainingOccurrence

HoleFeatureProxy.ContainingOccurrence

HorizontalAlignConstraintProxy.ContainingOccurrence

HorizontalConstraintProxy.ContainingOccurrence

iFeatureProxy.ContainingOccurrence

iMateResultProxy.ContainingOccurrence

InsertConstraintProxy.ContainingOccurrence

InsertiMateDefinitionProxy.ContainingOccurrence

InterferenceResult.OccurrenceOne

InterferenceResult.OccurrenceTwo

KnitFeatureProxy.ContainingOccurrence

LayoutConstraintProxy.ContainingOccurrence

LevelOfDetailRepresentation.SubstituteOccurrence

LineLengthDimConstraint3DProxy.ContainingOccurrence

LipFeatureProxy.ContainingOccurrence

LoftFeatureProxy.ContainingOccurrence

MateConstraintProxy.ContainingOccurrence

MateiMateDefinitionProxy.ContainingOccurrence

MidpointConstraint3DProxy.ContainingOccurrence

MidpointConstraintProxy.ContainingOccurrence

MirrorFeatureProxy.ContainingOccurrence

MoveFaceFeatureProxy.ContainingOccurrence

MoveFeatureProxy.ContainingOccurrence

NonParametricBaseFeatureDefinition.TargetOccurrence

NonParametricBaseFeatureProxy.ContainingOccurrence

OccurrencePatternElementProxy.ContainingOccurrence

OffsetConstraintProxy.ContainingOccurrence

OffsetDimConstraintProxy.ContainingOccurrence

OffsetSplineDimConstraintProxy.ContainingOccurrence

ParallelConstraint3DProxy.ContainingOccurrence

ParallelConstraintProxy.ContainingOccurrence

PathEntityProxy.ContainingOccurrence

PathProxy.ContainingOccurrence

PatternConstraintProxy.ContainingOccurrence

PerpendicularConstraint3DProxy.ContainingOccurrence

PerpendicularConstraintProxy.ContainingOccurrence

PlanarSketchProxy.ContainingOccurrence

PointAndPlaneDistanceDimConstraint3DProxy.ContainingOccurrence

Profile3DProxy.ContainingOccurrence

ProfileEntity3DProxy.ContainingOccurrence

ProfileEntityProxy.ContainingOccurrence

ProfilePath3DProxy.ContainingOccurrence

ProfilePathProxy.ContainingOccurrence

ProfileProxy.ContainingOccurrence

ProjectedCutProxy.ContainingOccurrence

RadiusDimConstraint3DProxy.ContainingOccurrence

RadiusDimConstraintProxy.ContainingOccurrence

RectangularOccurrencePatternProxy.ContainingOccurrence

RectangularPatternFeatureProxy.ContainingOccurrence

ReferenceFeatureProxy.ContainingOccurrence

ReplaceFaceFeatureProxy.ContainingOccurrence

RestFeatureProxy.ContainingOccurrence

RevolveFeatureProxy.ContainingOccurrence

RibFeatureProxy.ContainingOccurrence

RotateRotateConstraintProxy.ContainingOccurrence

RotateRotateiMateDefinitionProxy.ContainingOccurrence

RotateTranslateConstraintProxy.ContainingOccurrence

RotateTranslateiMateDefinitionProxy.ContainingOccurrence

RuleFilletFeatureProxy.ContainingOccurrence

SculptFeatureProxy.ContainingOccurrence

ShellFeatureProxy.ContainingOccurrence

Sketch3DProxy.ContainingOccurrence

SketchArc3DProxy.ContainingOccurrence

SketchArcProxy.ContainingOccurrence

SketchBlockDefinitionProxy.ContainingOccurrence

SketchBlockProxy.ContainingOccurrence

SketchCircle3DProxy.ContainingOccurrence

SketchCircleProxy.ContainingOccurrence

SketchEllipse3DProxy.ContainingOccurrence

SketchEllipseProxy.ContainingOccurrence

SketchEllipticalArc3DProxy.ContainingOccurrence

SketchEllipticalArcProxy.ContainingOccurrence

SketchFixedSpline3DProxy.ContainingOccurrence

SketchFixedSplineProxy.ContainingOccurrence

SketchImageProxy.ContainingOccurrence

SketchLine3DProxy.ContainingOccurrence

SketchLineProxy.ContainingOccurrence

SketchOffsetSplineProxy.ContainingOccurrence

SketchPoint3DProxy.ContainingOccurrence

SketchPointProxy.ContainingOccurrence

SketchSpline3DProxy.ContainingOccurrence

SketchSplineHandle3DProxy.ContainingOccurrence

SketchSplineHandleProxy.ContainingOccurrence

SketchSplineProxy.ContainingOccurrence

SmoothConstraint3DProxy.ContainingOccurrence

SmoothConstraintProxy.ContainingOccurrence

SnapFitFeatureProxy.ContainingOccurrence

SplineFitPointConstraintProxy.ContainingOccurrence

SplineFitPointsConstraint3DProxy.ContainingOccurrence

SplitFeatureProxy.ContainingOccurrence

SurfaceBodyProxy.ContainingOccurrence

SweepFeatureProxy.ContainingOccurrence

SymmetryConstraintProxy.ContainingOccurrence

TangentConstraint3DProxy.ContainingOccurrence

TangentConstraintProxy.ContainingOccurrence

TangentDistanceDimConstraintProxy.ContainingOccurrence

TangentiMateDefinitionProxy.ContainingOccurrence

TangentSketchConstraintProxy.ContainingOccurrence

TextBoxConstraintProxy.ContainingOccurrence

TextBoxProxy.ContainingOccurrence

ThickenFeatureProxy.ContainingOccurrence

ThreadFeatureProxy.ContainingOccurrence

ThreePointAngleDimConstraintProxy.ContainingOccurrence

TransitionalConstraintProxy.ContainingOccurrence

TranslateTranslateConstraintProxy.ContainingOccurrence

TrimFeatureProxy.ContainingOccurrence

TwoLineAngleDimConstraint3DProxy.ContainingOccurrence

TwoLineAngleDimConstraintProxy.ContainingOccurrence

TwoPointDistanceDimConstraint3DProxy.ContainingOccurrence

TwoPointDistanceDimConstraintProxy.ContainingOccurrence

UserCoordinateSystemProxy.ContainingOccurrence

VertexProxy.ContainingOccurrence

VerticalAlignConstraintProxy.ContainingOccurrence

VerticalConstraintProxy.ContainingOccurrence

WorkAxisProxy.ContainingOccurrence

WorkPlaneProxy.ContainingOccurrence

WorkPointProxy.ContainingOccurrence

WorkSurfaceProxy.ContainingOccurrence

See Also

Assembly Move Occurrence sample

Assembly Ground Occurrences sample

Projection - project across parts sample

Derived Parts and Assemblies sample

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

Assembly Count Ocurrences sample

Replace content center part sample

Assembly Mate Constraint of Work Planes sample

Interference Analysis sample

Example

See ComponentOccurrences::Add for example "Add new component occurrence"

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface


ComponentOccurrence Methods

ComponentOccurrence Methods
Summary

The methods of the ComponentOccurrence class are listed here.

Methods
Methods
Name | Description
ChangeRowOfiAssemblyMember | Method that changes the row in the iAssemblyFactory this occurrence references. This method can be used only if the IsiAssemblyMember property returns True.
ChangeRowOfiPartMember | Method that changes the row in the iPartTable this iPartMember represents. This method can be used only if the iPartMember property is True.
CreateGeometryProxy | Method that creates a proxy object for input object. A proxy object represents another object within the assembly space. Queries made on the proxy object are returned with respect to the assembly space, not the space the real geometry exists in.
Delete | Method that deletes the occurrence. This is the equivalent of the user deleting the occurrence interactively.
Edit | Activates this component occurrence for editing by the end user via the user interface.
ExitEdit | Method that causes the component occurrence to return from the edit mode and into the environment specified by the input argument. If the ComponentOccurrence is not currently active (i.e. this is not the same occurrence as returned by AssemblyComponentDefinition.ActiveOccurrence), then this method does nothing.
GetDegreesOfFreedom | Method that returns the available degrees of freedom for the occurrence.
GetDisplayMode | Gets the display mode type - default or override.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetRenderStyle | Gets the render style of this occurrence.
Replace | Method that replaces the occurrence or all instances of an occurrence with another file.
SetDesignViewRepresentation | Method that sets a design view representation for an assembly occurrence. Supported occurrences of parts and assemblies.
SetDisplayMode | Sets the display mode and type - default or override.
SetLevelOfDetailRepresentation | Method that sets a level of detail representation for an assembly occurrence.
SetRenderStyle | Sets the render style of this occurrence.
SetTransformWithoutConstraints | Method that sets the position and orientation of the occurrence, ignoring any constraints on the occurrence. When the assembly is recomputed the occurrence will reposition to honor the constraints.
Suppress | Suppresses this occurrence.
Unsuppress | Method that unsuppresses the occurrence.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods


ComponentOccurrence.ChangeRowOfiAssemblyMember Method

ComponentOccurrence.ChangeRowOfiAssemblyMember Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that changes the row in the iAssemblyFactory this occurrence references. This method can be used only if the IsiAssemblyMember property returns True.

Visual Basic
Sub ChangeRowOfiAssemblyMember(NewRow As VARIANT, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
NewRow | Specifies the new row from the factory. The row index is specified either by a Long (row index), a String (MemberName of a member or DocumentName of a member), or an iAssemblyTableRow object.
Options | Optional input NameValueMap object that specifies additional options for modifying the occurrence. This argument is currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.ChangeRowOfiAssemblyMember Method


ComponentOccurrence.ChangeRowOfiPartMember Method

ComponentOccurrence.ChangeRowOfiPartMember Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that changes the row in the iPartTable this iPartMember represents. This method can be used only if the iPartMember property is True.

Visual Basic
Sub ChangeRowOfiPartMember(NewRow As VARIANT, ByRef CustomInput As [optional] VARIANT)
Parameters
Parameters | Description
NewRow | Specifies the new row from the factory. The row index is specified either by a Long (row index), a String (MemberName of a member or DocumentName of a member), or an iPartTableRow object.
CustomInput | Optional input array of Strings that specifies the input to use for the custom input. If the factory is a custom factory and this is not supplied the default values for custom values are used. The custom input strings are supplied in a column order. If the factory is not a custom factory this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.ChangeRowOfiPartMember Method


ComponentOccurrence.CreateGeometryProxy Method

ComponentOccurrence.CreateGeometryProxy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a proxy object for input object. A proxy object represents another object within the assembly space. Queries made on the proxy object are returned with respect to the assembly space, not the space the real geometry exists in.

Visual Basic
Sub CreateGeometryProxy(Geometry As IDispatch, ByRef Result As IDispatch*)
Parameters
Parameters | Description
Geometry | Input entity to create a proxy for. This entity must exist under the tree of this occurrence.
Returns

Output proxy object created.

See Also

Associative body copy sample

Projection - project across parts sample

Assembly Mate Constraint of Work Planes sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.CreateGeometryProxy Method


ComponentOccurrence.Delete Method

ComponentOccurrence.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the occurrence. This is the equivalent of the user deleting the occurrence interactively.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.Delete Method


ComponentOccurrence.Edit Method

ComponentOccurrence.Edit Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Activates this component occurrence for editing by the end user via the user interface.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.Edit Method


ComponentOccurrence.ExitEdit Method

ComponentOccurrence.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that causes the component occurrence to return from the edit mode and into the environment specified by the input argument. If the ComponentOccurrence is not currently active (i.e. this is not the same occurrence as returned by AssemblyComponentDefinition.ActiveOccurrence), then this method does nothing.

Visual Basic
Sub ExitEdit(ExitTo As ExitTypeEnum)
Parameters
Parameters | Description
ExitTo | Input ExitTypeEnum that specifies the environment to exit to. Possible values are kExitToPrevious, kExitToParent and kExitToTop.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.ExitEdit Method


ComponentOccurrence.GetDegreesOfFreedom Method

ComponentOccurrence.GetDegreesOfFreedom Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the available degrees of freedom for the occurrence.

Visual Basic
Sub GetDegreesOfFreedom(ByRef TranslationDegreesCount As long, ByRef TranslationDegreesVectors As ObjectsEnumerator*, ByRef RotationDegreesCount As long, ByRef RotationDegreesVectors As ObjectsEnumerator*, ByRef DOFCenter As Point*)
Parameters
Parameters | Description
TranslationDegreesCount | Output Long that returns the number of available translational degrees of freedom. The value can be from 0 to 3.
TranslationDegreesVectors | Output ObjectsEnumerator that returns Vector objects corresponding to the available translational degrees of freedom.
RotationDegreesCount | Output Long that returns the number of available rotational degrees of freedom. The value can be from 0 to 3.
RotationDegreesVectors | Output ObjectsEnumerator that returns Vector objects corresponding to the available rotational degrees of freedom.
DOFCenter | Output Point object that returns the DOF center as displayed by Inventor.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.GetDegreesOfFreedom Method


ComponentOccurrence.GetDisplayMode Method

ComponentOccurrence.GetDisplayMode Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the display mode type - default or override.

Visual Basic
Sub GetDisplayMode(ByRef DisplayModeSourceType As DisplayModeSourceTypeEnum, Result As [out, retval] DisplayModeEnum)
Parameters
Parameters | Description
DisplayModeSourceType | Enum indicating the display mode.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.GetDisplayMode Method


ComponentOccurrence.GetReferenceKey Method

ComponentOccurrence.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.GetReferenceKey Method


ComponentOccurrence.GetRenderStyle Method

ComponentOccurrence.GetRenderStyle Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the render style of this occurrence.

Visual Basic
Sub GetRenderStyle(ByRef StyleSourceType As StyleSourceTypeEnum, Result As [out, retval] RenderStyle*)
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.GetRenderStyle Method


ComponentOccurrence.Replace Method

ComponentOccurrence.Replace Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that replaces the occurrence or all instances of an occurrence with another file.

Visual Basic
Sub Replace(FileName As String, ReplaceAll As VARIANT_BOOL)
Parameters
Parameters | Description
FileName | Input filename of the new file to be used to replace the existing occurrence.
ReplaceAll | Input Boolean that indicates whether the current occurrence should be replace or all instances of this occurrence.
Remarks

If a replace fails, it may be due to the ownership control available since R12. For example, the hidden DocumentDescriptor.OwnershipType property using the kExclusiveOwnership enum will block replacement of the instance. Autodesk may find it necessary to mark parts or assemblies as exclusively owned. Exclusive ownership is specifically for an application to indicate that the components are not usable in other assemblies and have application controlled semantics in this assembly (in other words, the relationship between this parent and this child is very strong and application controlled).

Example

Replace content center part example.

This sample demonstrates how to replace the content part referenced by an assembly occurrence. Open an assembly that contains an occurrence of a content part and run the macro.

Sub ReplaceContentCenterPart()

    ' Set a reference to the active assembly document.
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Prompt user to pick an occurrence
    Dim oOcc As ComponentOccurrence
    Set oOcc = ThisApplication.CommandManager.Pick(kAssemblyOccurrenceFilter, "Pick occurrence to replace")

    If oOcc.DefinitionDocumentType <> kPartDocumentObject Then
        MsgBox "Occurrence does not reference a content part."
        Exit Sub
    End If

    Dim oOccDef As PartComponentDefinition
    Set oOccDef = oOcc.Definition

    If Not oOccDef.IsContentMember Then
        MsgBox "The occurrence does not reference a content part."
        Exit Sub
    End If

    ' Set a reference to the ContentCenter object.
    Dim oContentCenter As ContentCenter
    Set oContentCenter = ThisApplication.ContentCenter

    ' Get the content node (category) "Fasteners:Bolts:Hex Head"
    Dim oContentNode As ContentTreeViewNode
    Set oContentNode = oContentCenter.TreeViewTopNode.ChildNodes.Item("Fasteners").ChildNodes.Item("Bolts").ChildNodes.Item("Hex Head")

    ' Get the "ISO 4015" Family object.
    Dim oFamily As ContentFamily
    For Each oFamily In oContentNode.Families
        If oFamily.DisplayName = "ISO 4015" Then
            Exit For
        End If
    Next

    ' Create a member based on the second row of the family.
    Dim error As MemberManagerErrorsEnum
    Dim strContentPartFileName As String
    Dim strErrorMessage As String
    strContentPartFileName = oFamily.CreateMember(2, error, strErrorMessage)

    Call oOcc.Replace(strContentPartFileName, False)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.Replace Method


ComponentOccurrence.SetDesignViewRepresentation Method

ComponentOccurrence.SetDesignViewRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets a design view representation for an assembly occurrence. Supported occurrences of parts and assemblies.

Visual Basic
Sub SetDesignViewRepresentation(Representation As String, ByRef Reserved As [defaultvalue("")] BSTR, ByRef Associative As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Representation | String that specifies the Design View Representation to set on the occurrence. The method returns a failure if a representation with this name is not found in the referenced assembly or in the private representation file (if specified).
Reserved | Optional input string reserved for future use. Currently ignored.
Associative | Optional input Boolean that indicates whether to associatively apply the design view. If set to True, any changes to the design view in the referenced assembly will show in this occurrence. If not specified, a value of False is used.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.SetDesignViewRepresentation Method


ComponentOccurrence.SetDisplayMode Method

ComponentOccurrence.SetDisplayMode Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Sets the display mode and type - default or override.

Visual Basic
Sub SetDisplayMode(DisplayModeSourceType As DisplayModeSourceTypeEnum, ByRef DisplayMode As [optional] VARIANT)
Parameters
Parameters | Description
DisplayModeSourceType | Enum indicating the display mode type.
DisplayMode | The display mode.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.SetDisplayMode Method


ComponentOccurrence.SetLevelOfDetailRepresentation Method

ComponentOccurrence.SetLevelOfDetailRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets a level of detail representation for an assembly occurrence.

Visual Basic
Sub SetLevelOfDetailRepresentation(Representation As String, ByRef SkipDocumentSave As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Representation | String that specifies the Level of Detail Representation to set on the occurrence. The method returns a failure if a representation with this name is not found in the referenced assembly.
SkipDocumentSave | Optional input Boolean that indicates whether to suppress the save dialogs that appear for dirty documents that are about to be closed as a result of this action. If set to True, any edits performed on the documents needing to be closed are lost. Also, any document never saved to disk and needing to be closed is lost. The default value is False indicating that the user will be prompted to save documents about to be closed.
Remarks

Calling this method may result in the closing of certain documents that become unreferenced as a result of this action. However, these unreferenced documents will not be closed if this method is called within a ChangeProcessor or a Transaction. These unreferenced documents will be closed by Inventor at the next available opportunity. But if they need to be closed sooner, the Documents.CloseAll method (with a value of True for the input argument) can be used for this purpose.

Notes

If the SilentOperation property on the Application is set to True and this argument is specified to be False, the defaults in the resulting dialogs are accepted and the dialogs are suppressed. This will result in dirty documents being saved. However, if the dirty documents include any documents that have never been saved to disk, the method will return a failure in this situation.

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.SetLevelOfDetailRepresentation Method


ComponentOccurrence.SetRenderStyle Method

ComponentOccurrence.SetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets the render style of this occurrence.

Visual Basic
Sub SetRenderStyle(StyleSourceType As StyleSourceTypeEnum, ByRef RenderStyle As [optional] VARIANT)
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.SetRenderStyle Method


ComponentOccurrence.SetTransformWithoutConstraints Method

ComponentOccurrence.SetTransformWithoutConstraints Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the position and orientation of the occurrence, ignoring any constraints on the occurrence. When the assembly is recomputed the occurrence will reposition to honor the constraints.

Visual Basic
Sub SetTransformWithoutConstraints(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input object that specifies the position and orientation of the occurrence.
See Also

Assembly Move Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.SetTransformWithoutConstraints Method


ComponentOccurrence.Suppress Method

ComponentOccurrence.Suppress Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Suppresses this occurrence.

Visual Basic
Sub Suppress(ByRef SkipDocumentSave As [defaultvalue(0)] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.Suppress Method


ComponentOccurrence.Unsuppress Method

ComponentOccurrence.Unsuppress Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that unsuppresses the occurrence.

Visual Basic
Sub Unsuppress()
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Methods > ComponentOccurrence.Unsuppress Method


ComponentOccurrence Properties

ComponentOccurrence Properties
Summary

The properties of the ComponentOccurrence class are listed here.

Properties
Name | Description
ActiveDesignViewRepresentation | Property that returns the name of the active Design View Representation for an assembly occurrence. This property returns a null string in the case where a design view representation was set for the occurrence non-associatively (i.e. with the 'Associative' flag turned off). Supported occurrences of parts and assemblies.
ActiveLevelOfDetailRepresentation | Property that returns the name of the active Level of Detail Representation for an assembly occurrence.
ActivePositionalRepresentation | Gets and sets the active Positional Representation for this occurrence.
Adaptive | Property that gets and sets whether the occurrence is adaptive or not. A value of True signifies the occurrence is adaptive. Setting this property is not supported in Apprentice.
Application | This is Application, a member of class ComponentOccurrence.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BOMStructure | Gets and sets the BOM structure override.
Constraints | Property returns the collection of constraints that are acting on the occurrence.
ContactSet | Gets and sets whether the component belongs in the contact set.
ContextDefinition | Property that returns the object this occurrence is in the context of. For example, all coordinate data returned by the definition is in the space of this ComponentDefinition.
Definition | Property that returns the object this occurrence references.
DefinitionDocumentType | Gets the type of the Document whose occurrence this is.
DisabledActionTypes | Gets and sets the action types (ActionTypeEnum) valid for this component occurrence.
Enabled | Property gets and set whether the occurrence is enabled or not.
Excluded | Property that gets and sets whether the occurrence is excluded in the active row of the iAssembly factory. This property returns False and cannot be set to True if the parent document is not an iAssembly.
Flexible | Property that gets and sets whether the occurrence is flexible or not. A value of True signifies the occurrence is flexible. The property fails for occurrences of part.
Grounded | Property returns whether the occurrence is grounded or not. Returns True if the occurrence is grounded. Setting this property is not supported in Apprentice.
HasBodyOverride | Property that returns a Boolean specifying whether the occurrence path contains body-modifying assembly features.
iMateDefinitions | Property that returns the iMateDefinitions that are available from this occurrence. The iMateDefinition objects returned are actually proxies for the various iMateDefinition objects. These can be used as input to the Add and ValidResult methods of the iMateResults object.
IsiAssemblyMember | Property that returns whether the ComponentOccurrence is an iAssemblyMember. The property returns True if the ComponentOccurrence is an iAssemblyMember. This property always returns False for occurrences of part documents.
IsiPartMember | Property that specifies if the ComponentOccurence is an iPartMember. The property is True if the ComponentOccurence is an iPartMember.
IsPatternElement | Property that indicates whether this occurrence represents a pattern element. In the case where this occurrence represents a pattern element, this property returns True. The PatternElement property can be used to get that pattern element.
IsSubstituteOccurrence | Property that returns whether this occurrence references a substitute part in the context of a substitute level of detail representation.
MassProperties | Property that returns the MassProperties object. This supports performing mass properties calculations for this particular occurrence.
Name | Property that allows you to get and set the name of the occurrence. The display name is the name displayed in the assembly browser for the occurrence.
OccurrencePath | Gets the path of immediate (directly instanced) occurrences that make up this occurrence.
OverrideOpacity | Gets and sets the opacity of an occurrence.
Parent | This is Parent, a member of class ComponentOccurrence.
ParentOccurrence | Property that returns the parent of this occurrence. This property is only valid for the occurrences in a multi-level assembly that are not in the top level. The parent occurrence is the occurrence representing the subassembly this occurrence is contained within.
PatternElement | Property that returns the pattern element this occurrence represents. In the case where this occurrence is not part of a pattern this property returns Nothing. The IsPatternElement property can be used to check if this occurrence is part of a pattern.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
ReferencedDocumentDescriptor | Property that returns an enumeration of descriptors that represent the native document references held by this document.
ShowDegreesOfFreedom | Property that gets and sets whether to display the degrees of freedom for the occurrence. This value is not persisted with the document.
SubOccurrences | Property that returns the collection of occurrences for an occurrence. This property applies to occurrences that represent a subassembly. The collection returned provides access to the occurrences contained within the subassembly. If this collection is obtained from an occurrence that represents a part, it will not contain any occurrences.
Suppressed | Property that returns whether this occurrence is suppressed or not.
SurfaceBodies | Property that returns the SurfaceBodies collection for the occurrence. This property applies to occurrences that represent a part and provides access to the B-Rep of that part. The B-Rep queries will return coordinate data in the context of the component definition that served as the starting point to access the occurrence, which can also be accessed through the ContextDefinition property.
Transformation | Property that returns and sets the transformation for the occurrence. The transformation matrix defines the position and orientation of the component within the assembly. When setting the transform of an occurrence the actual change in position and orientation of the occurrence is limited by the constraints on the occurrence.
Type | Property returning an enum indicating this object's type.
Visible | Property gets and set whether the occurrence is visible or not.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties


ComponentOccurrence.ActiveDesignViewRepresentation Property

ComponentOccurrence.ActiveDesignViewRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the name of the active Design View Representation for an assembly occurrence. This property returns a null string in the case where a design view representation was set for the occurrence non-associatively (i.e. with the 'Associative' flag turned off). Supported occurrences of parts and assemblies.

Visual Basic
Property ActiveDesignViewRepresentation() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ActiveDesignViewRepresentation Property


ComponentOccurrence.ActiveLevelOfDetailRepresentation Property

ComponentOccurrence.ActiveLevelOfDetailRepresentation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the name of the active Level of Detail Representation for an assembly occurrence.

Visual Basic
Property ActiveLevelOfDetailRepresentation() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ActiveLevelOfDetailRepresentation Property


ComponentOccurrence.ActivePositionalRepresentation Property

ComponentOccurrence.ActivePositionalRepresentation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets the active Positional Representation for this occurrence.

Visual Basic
Property ActivePositionalRepresentation() As String
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ActivePositionalRepresentation Property


ComponentOccurrence.Adaptive Property

ComponentOccurrence.Adaptive Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets whether the occurrence is adaptive or not. A value of True signifies the occurrence is adaptive. Setting this property is not supported in Apprentice.

Visual Basic
Property Adaptive() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Adaptive Property


ComponentOccurrence.Application Property

ComponentOccurrence.Application Property
Summary

This is Application, a member of class ComponentOccurrence.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Application Property


ComponentOccurrence.AttributeSets Property

ComponentOccurrence.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.AttributeSets Property


ComponentOccurrence.BOMStructure Property

ComponentOccurrence.BOMStructure Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets and sets the BOM structure override.

Visual Basic
Property BOMStructure() As BOMStructureEnum
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.BOMStructure Property


ComponentOccurrence.Constraints Property

ComponentOccurrence.Constraints Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returns the collection of constraints that are acting on the occurrence.

Visual Basic
Property Constraints() As AssemblyConstraintsEnumerator**
Remarks

When working with ComponentOccurrenceProxy objects, suboccurrences should return constraints in the context of the root.

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Constraints Property


ComponentOccurrence.ContactSet Property

ComponentOccurrence.ContactSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets and sets whether the component belongs in the contact set.

Visual Basic
Property ContactSet() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ContactSet Property


ComponentOccurrence.ContextDefinition Property

ComponentOccurrence.ContextDefinition Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the object this occurrence is in the context of. For example, all coordinate data returned by the definition is in the space of this ComponentDefinition.

Visual Basic
Property ContextDefinition() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ContextDefinition Property


ComponentOccurrence.Definition Property

ComponentOccurrence.Definition Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the object this occurrence references.

Visual Basic
Property Definition() As ComponentDefinition**
See Also

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Definition Property


ComponentOccurrence.DefinitionDocumentType Property

ComponentOccurrence.DefinitionDocumentType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets the type of the Document whose occurrence this is.

Visual Basic
Property DefinitionDocumentType() As DocumentTypeEnum*
See Also

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.DefinitionDocumentType Property


ComponentOccurrence.DisabledActionTypes Property

ComponentOccurrence.DisabledActionTypes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the action types (ActionTypeEnum) valid for this component occurrence.

Visual Basic
Property DisabledActionTypes() As ActionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.DisabledActionTypes Property


ComponentOccurrence.Enabled Property

ComponentOccurrence.Enabled Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property gets and set whether the occurrence is enabled or not.

Visual Basic
Property Enabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Enabled Property


ComponentOccurrence.Excluded Property

ComponentOccurrence.Excluded Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the occurrence is excluded in the active row of the iAssembly factory. This property returns False and cannot be set to True if the parent document is not an iAssembly.

Visual Basic
Property Excluded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Excluded Property


ComponentOccurrence.Flexible Property

ComponentOccurrence.Flexible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the occurrence is flexible or not. A value of True signifies the occurrence is flexible. The property fails for occurrences of part.

Visual Basic
Property Flexible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Flexible Property


ComponentOccurrence.Grounded Property

ComponentOccurrence.Grounded Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returns whether the occurrence is grounded or not. Returns True if the occurrence is grounded. Setting this property is not supported in Apprentice.

Visual Basic
Property Grounded() As VARIANT_BOOL
Example

"Assembly Ground Occurrences Example "

"This sample demonstrates grounding an assembly occurrence. Before running the sample, you need to open an assembly and create a part file called C:\TempPart1.ipt, or edit the sample code to point to another part file if desired."

Public Sub FixAllOccurrences()
' Set a reference to the assembly component definintion.
' This assumes an assembly document is open.
Dim oAsmCompDef As AssemblyComponentDefinition
Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

' Ask whether to delete or suppress the existing constraints.
Dim bDelete As Boolean
If MsgBox("Do you want to delete all existing constraints?", vbYesNo + vbQuestion) = vbYes Then
  bDelete = True
Else
  bDelete = False
End If

' Iterate through all of the constraints and perform the specified operation.
Dim oConstraint As AssemblyConstraint
For Each oConstraint In oAsmCompDef.Constraints
  If bDelete Then
    oConstraint.Delete
  Else
    oConstraint.Suppressed = True
  End If
Next

' Iterate through all of the occurrences and ground them.
Dim oOccurrence As ComponentOccurrence
For Each oOccurrence In oAsmCompDef.Occurrences
  oOccurrence.Grounded = True
Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Grounded Property


ComponentOccurrence.HasBodyOverride Property

ComponentOccurrence.HasBodyOverride Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Boolean specifying whether the occurrence path contains body-modifying assembly features.

Visual Basic
Property HasBodyOverride() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.HasBodyOverride Property


ComponentOccurrence.iMateDefinitions Property

ComponentOccurrence.iMateDefinitions Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iMateDefinitions that are available from this occurrence. The iMateDefinition objects returned are actually proxies for the various iMateDefinition objects. These can be used as input to the Add and ValidResult methods of the iMateResults object.

Visual Basic
Property iMateDefinitions() As iMateDefinitionsEnumerator**
See Also

iMate Result Creation sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.iMateDefinitions Property


ComponentOccurrence.IsiAssemblyMember Property

ComponentOccurrence.IsiAssemblyMember Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the ComponentOccurrence is an iAssemblyMember. The property returns True if the ComponentOccurrence is an iAssemblyMember. This property always returns False for occurrences of part documents.

Visual Basic
Property IsiAssemblyMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.IsiAssemblyMember Property


ComponentOccurrence.IsiPartMember Property

ComponentOccurrence.IsiPartMember Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that specifies if the ComponentOccurence is an iPartMember. The property is True if the ComponentOccurence is an iPartMember.

Visual Basic
Property IsiPartMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.IsiPartMember Property


ComponentOccurrence.IsPatternElement Property

ComponentOccurrence.IsPatternElement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates whether this occurrence represents a pattern element. In the case where this occurrence represents a pattern element, this property returns True. The PatternElement property can be used to get that pattern element.

Visual Basic
Property IsPatternElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.IsPatternElement Property


ComponentOccurrence.IsSubstituteOccurrence Property

ComponentOccurrence.IsSubstituteOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether this occurrence references a substitute part in the context of a substitute level of detail representation.

Visual Basic
Property IsSubstituteOccurrence() As VARIANT_BOOL*
Remarks

If this property returns True, the occurrence will be in an un-suppressed state only when the corresponding level of detail representation is active.

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.IsSubstituteOccurrence Property


ComponentOccurrence.MassProperties Property

ComponentOccurrence.MassProperties Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the MassProperties object. This supports performing mass properties calculations for this particular occurrence.

Visual Basic
Property MassProperties() As MassProperties**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.MassProperties Property


ComponentOccurrence.Name Property

ComponentOccurrence.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the name of the occurrence. The display name is the name displayed in the assembly browser for the occurrence.

Visual Basic
Property Name() As String
See Also

Assembly Count Ocurrences sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Name Property


ComponentOccurrence.OccurrencePath Property

ComponentOccurrence.OccurrencePath Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets the path of immediate (directly instanced) occurrences that make up this occurrence.

Visual Basic
Property OccurrencePath() As ComponentOccurrencesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.OccurrencePath Property


ComponentOccurrence.OverrideOpacity Property

ComponentOccurrence.OverrideOpacity Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets the opacity of an occurrence.

Visual Basic
Property OverrideOpacity() As double
Remarks

A return value of -1 indicates that no override is currently applied, and the value can be set to -1 to clear any overrides.

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.OverrideOpacity Property


ComponentOccurrence.Parent Property

ComponentOccurrence.Parent Property
Summary

This is Parent, a member of class ComponentOccurrence.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Parent Property


ComponentOccurrence.ParentOccurrence Property

ComponentOccurrence.ParentOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent of this occurrence. This property is only valid for the occurrences in a multi-level assembly that are not in the top level. The parent occurrence is the occurrence representing the subassembly this occurrence is contained within.

Visual Basic
Property ParentOccurrence() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ParentOccurrence Property


ComponentOccurrence.PatternElement Property

ComponentOccurrence.PatternElement Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the pattern element this occurrence represents. In the case where this occurrence is not part of a pattern this property returns Nothing. The IsPatternElement property can be used to check if this occurrence is part of a pattern.

Visual Basic
Property PatternElement() As OccurrencePatternElement**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.PatternElement Property


ComponentOccurrence.RangeBox Property

ComponentOccurrence.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.RangeBox Property


ComponentOccurrence.ReferencedDocumentDescriptor Property

ComponentOccurrence.ReferencedDocumentDescriptor Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enumeration of descriptors that represent the native document references held by this document.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ReferencedDocumentDescriptor Property


ComponentOccurrence.ShowDegreesOfFreedom Property

ComponentOccurrence.ShowDegreesOfFreedom Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether to display the degrees of freedom for the occurrence. This value is not persisted with the document.

Visual Basic
Property ShowDegreesOfFreedom() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.ShowDegreesOfFreedom Property


ComponentOccurrence.SubOccurrences Property

ComponentOccurrence.SubOccurrences Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of occurrences for an occurrence. This property applies to occurrences that represent a subassembly. The collection returned provides access to the occurrences contained within the subassembly. If this collection is obtained from an occurrence that represents a part, it will not contain any occurrences.

Visual Basic
Property SubOccurrences() As ComponentOccurrencesEnumerator**
See Also

Promote occurence sample

Example

"Assembly Count Ocurrences Example "

"This sample shows how to recursively traverse an assembly and get the count of leaf node components and subassemblies. "

Public Sub AssemblyCount()
    ' Set reference to active document.
    ' This assumes the active document is an assembly
    Dim oDoc As Inventor.AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Get assembly component definition
    Dim oCompDef As Inventor.ComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    Dim sMsg As String
    Dim iLeafNodes As Long
    Dim iSubAssemblies As Long

    ' Get all occurrences from component definition for Assembly document
    Dim oCompOcc As ComponentOccurrence
    For Each oCompOcc In oCompDef.Occurrences
        ' Check if it's child occurrence (leaf node)
        If oCompOcc.SubOccurrences.Count = 0 Then
            Debug.Print oCompOcc.Name
            iLeafNodes = iLeafNodes + 1
        Else
            Debug.Print oCompOcc.Name
            iSubAssemblies = iSubAssemblies + 1
            Call processAllSubOcc(oCompOcc, _
                                sMsg, _
                                iLeafNodes, _
                                iSubAssemblies) ' subassembly
        End If
    Next

    Debug.Print "No of leaf nodes    : " + CStr(iLeafNodes)
    Debug.Print "No of sub assemblies: " + CStr(iSubAssemblies)
End Sub

' This function is called for processing sub assembly.  It is called recursively
' to iterate through the entire assembly tree.
Private Sub processAllSubOcc(ByVal oCompOcc As ComponentOccurrence, _
                             ByRef sMsg As String, _
                             ByRef iLeafNodes As Long, _
                             ByRef iSubAssemblies As Long)

    Dim oSubCompOcc As ComponentOccurrence
    For Each oSubCompOcc In oCompOcc.SubOccurrences
        ' Check if it's child occurrence (leaf node)
        If oSubCompOcc.SubOccurrences.Count = 0 Then
            Debug.Print oSubCompOcc.Name
            iLeafNodes = iLeafNodes + 1
        Else
            sMsg = sMsg + oSubCompOcc.Name + vbCr
            iSubAssemblies = iSubAssemblies + 1

            Call processAllSubOcc(oSubCompOcc, _
                                  sMsg, _
                                  iLeafNodes, _
                                  iSubAssemblies)
        End If
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.SubOccurrences Property


ComponentOccurrence.Suppressed Property

ComponentOccurrence.Suppressed Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether this occurrence is suppressed or not.

Visual Basic
Property Suppressed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Suppressed Property


ComponentOccurrence.SurfaceBodies Property

ComponentOccurrence.SurfaceBodies Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the SurfaceBodies collection for the occurrence. This property applies to occurrences that represent a part and provides access to the B-Rep of that part. The B-Rep queries will return coordinate data in the context of the component definition that served as the starting point to access the occurrence, which can also be accessed through the ContextDefinition property.

Visual Basic
Property SurfaceBodies() As SurfaceBodies**
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.SurfaceBodies Property


ComponentOccurrence.Transformation Property

ComponentOccurrence.Transformation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns and sets the transformation for the occurrence. The transformation matrix defines the position and orientation of the component within the assembly. When setting the transform of an occurrence the actual change in position and orientation of the occurrence is limited by the constraints on the occurrence.

Visual Basic
Property Transformation() As Matrix*
See Also

SurfaceBody Copy sample

Example

"Assembly Move Occurrence Example "

"This sample demonstrates moving a component occurrence. This sample performs a translate, but a rotate can also be performed since the transform is defined using a matrix.

Before running the sample you need to open an assembly and select the occurrence to move. The sample code first moves the occurrence honoring any existing constraints and then moves it ignoring any constraints."

Public Sub MoveOccurrence()
' Set a reference to the assembly component definintion.
Dim oAsmCompDef As AssemblyComponentDefinition
Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

' Get an occurrence from the select set.
On Error Resume Next
Dim oOccurrence As ComponentOccurrence
Set oOccurrence = ThisApplication.ActiveDocument.SelectSet.Item(1)
If Err Then
  MsgBox "An occurrence must be selected."
  Exit Sub
End If
On Error GoTo 0

' Get the current transformation matrix from the occurrence.
Dim oTransform As Matrix
Set oTransform = oOccurrence.Transformation

' Move the occurrence honoring any existing constraints.
oTransform.SetTranslation ThisApplication.TransientGeometry.CreateVector(2, 2, 3)
oOccurrence.Transformation = oTransform

' Move the occurrence ignoring any constraints.
' Anything that causes the assembly to recompute will cause the
' occurrence to reposition itself to honor the constraints.
oTransform.SetTranslation ThisApplication.TransientGeometry.CreateVector(3, 4, 5)
Call oOccurrence.SetTransformWithoutConstraints(oTransform)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Transformation Property


ComponentOccurrence.Type Property

ComponentOccurrence.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Type Property


ComponentOccurrence.Visible Property

ComponentOccurrence.Visible Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property gets and set whether the occurrence is visible or not.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrence Interface > ComponentOccurrence Properties > ComponentOccurrence.Visible Property


ComponentOccurrenceProxy Interface

ComponentOccurrenceProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ComponentOccurrence object.

Class Hierarchy
Inventor::ComponentOccurrence
    Inventor::ComponentOccurrenceProxy
Visual Basic
Public Interface ComponentOccurrenceProxy
Inherits ComponentOccurrence
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

See Also

Promote occurence sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrenceProxy Interface


ComponentOccurrenceProxy Properties

ComponentOccurrenceProxy Properties
Summary

The properties of the ComponentOccurrenceProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrenceProxy Interface > ComponentOccurrenceProxy Properties


ComponentOccurrenceProxy.ContainingOccurrence Property

ComponentOccurrenceProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrenceProxy Interface > ComponentOccurrenceProxy Properties > ComponentOccurrenceProxy.ContainingOccurrence Property


ComponentOccurrenceProxy.NativeObject Property

ComponentOccurrenceProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrenceProxy Interface > ComponentOccurrenceProxy Properties > ComponentOccurrenceProxy.NativeObject Property


ComponentOccurrences Interface

ComponentOccurrences Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the objects within an assembly and supports methods to create new occurrences.

Class Hierarchy
Inventor::ComponentOccurrencesEnumerator
    Inventor::ComponentOccurrences
Visual Basic
Public Interface ComponentOccurrences
Inherits ComponentOccurrencesEnumerator
Notes

Members through which this object may be accessed include:

ComponentDefinition.Occurrences

See Also

SurfaceBody Copy sample

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iPart occurrence (C#) sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

Example 1

See ComponentOccurrence::SubOccurrences for example "SubOccurrences Property"

Example 2

See ComponentOccurrences::AddiAssemblyMember for example "Adding iAssembly occurrences"

Example 3

See ComponentOccurrences::AddWithOptions for example "Create assembly occurrence specifying representations"

Example 4

See ComponentOccurrences::Add for example "Add an Occurrence"

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface


ComponentOccurrences Methods

ComponentOccurrences Methods
Summary

The methods of the ComponentOccurrences class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new for an existing part or subassembly. This method is the equivalent of the 'Place Component' command.
AddByComponentDefinition | Method that creates a new for a new part or subassembly. This method is the equivalent of the 'Create Component' command.
AddCustomiPartMember | Method that creates an of an iPartMember in this AssemblyComponentDefinition. The iPartMember is specified by a custom factory and a row in the factory.
AddiAssemblyMember | Method that creates an occurrence of an iAssemblyMember in an assembly. The iAssemblyMember is specified by a factory and a row in the factory.
AddiPartMember | Method that creates an of an iPartMember in this AssemblyComponentDefinition. The iPartMember is specified by a factory and a row in the factory.
AddUsingiMates | Method that adds a new occurrence into the assembly. This method is the equivalent of using the Place Component command with the "Use iMate" check box checked. The method returns a failure if no matches are found.
AddVirtual | Method that creates a virtual component definition and adds an occurrence based on that definition.
AddWithOptions | Method that creates a new occurrence for an existing part or subassembly. This method is the equivalent of the "Place Component" command.
AllLeafOccurrences | Return all unique leaf occurrences (optionally filtered to the specified definition) relative to this context.
AllReferencedOccurrences | Property that returns all occurrences that reference the input object.
ItemByName | Allows string-indexed access to items in the collection. (Usually found when this ability has been added to a pre-existing collection).
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods


ComponentOccurrences.Add Method

ComponentOccurrences.Add Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new for an existing part or subassembly. This method is the equivalent of the 'Place Component' command.

Visual Basic
Sub Add(FullDocumentName As String, Position As Matrix, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
FullDocumentName | Input string that specifies the full document name of the part or the sub-assembly. If only the FullFileName is specified, the master document within the file is used.
Position | Input object that defines the location and orientation to position the occurrence.
See Also

Place content center part sample

iMate Result Creation sample

Example 1

"Assembly Add Occurrence Example"

"This sample demonstrates placing an assembly occurrence. Before running the sample, you need to open an assembly and create a part file called C:\Temp\Part1.ipt, or edit the sample code to point to another part file if desired. "

Public Sub AddOccurrence()
    ' Set a reference to the assembly component definintion.
    ' This assumes an assembly document is open.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create a matrix.  A new matrix is initialized with an identity matrix.
    Dim oMatrix As Matrix
    Set oMatrix = oTG.CreateMatrix

    ' Set the rotation of the matrix for a 45 degree rotation about the Z axis.
    Call oMatrix.SetToRotation(3.14159265358979 / 4, _
                            oTG.CreateVector(0, 0, 1), oTG.CreatePoint(0, 0, 0))

    ' Set the translation portion of the matrix so the part will be positioned
    ' at (3,2,1).
    Call oMatrix.SetTranslation(oTG.CreateVector(3, 2, 1))

    ' Add the occurrence.
    Dim oOcc As ComponentOccurrence
    Set oOcc = oAsmCompDef.Occurrences.Add("C:\Temp\Part1.ipt", oMatrix)
End Sub
Example 2

Assembly Add Occurrence example (C#).

This sample demonstrates placing an assembly occurrence. Before running the sample, you need to open an assembly and

create a part file called C:/Temp/Part1.ipt, or edit the sample code to point to another part file if desired.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void AddOccurrence()
{
    Application oApp = ThisApplication;

    // Set a reference to the active assembly document.
    // This assumes an assembly document is open.
    AssemblyDocument oDoc = (AssemblyDocument)oApp.ActiveDocument;

    // Set a reference to the assembly component definition.
    AssemblyComponentDefinition oAsmCompDef = oDoc.ComponentDefinition;

    // Set a reference to the transient geometry object.
    TransientGeometry oTG = oApp.TransientGeometry;

    // Create a matrix.  A new matrix is initialized with an identity matrix.
    Matrix oMatrix = oTG.CreateMatrix();

    // Set the rotation of the matrix for a 45 degree rotation about the Z axis.
    oMatrix.SetToRotation(3.14159265358979 / 4,
        oTG.CreateVector(0, 0, 1), oTG.CreatePoint(0, 0, 0));

    // Set the translation portion of the matrix so the part will be positioned
    // at (3,2,1).
    oMatrix.SetTranslation(oTG.CreateVector(3, 2, 1), true);

    // Add the occurrence.
    ComponentOccurrence oOcc = oAsmCompDef.Occurrences.Add("C:/Temp/Part1.ipt", oMatrix);

}
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.Add Method


ComponentOccurrences.AddByComponentDefinition Method

ComponentOccurrences.AddByComponentDefinition Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new for a new part or subassembly. This method is the equivalent of the 'Create Component' command.

Visual Basic
Sub AddByComponentDefinition(CompDef As ComponentDefinition, Position As Matrix, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
CompDef | Input object that will be referenced when creating the new occurrence.
Position | Input object that defines the location and orientation to position the occurrence.
See Also

Demote occurence sample

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddByComponentDefinition Method


ComponentOccurrences.AddCustomiPartMember Method

ComponentOccurrences.AddCustomiPartMember Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates an of an iPartMember in this AssemblyComponentDefinition. The iPartMember is specified by a custom factory and a row in the factory.

Visual Basic
Sub AddCustomiPartMember(FactoryFileName As String, Position As Matrix, FullFileName As String, ByRef Row As [optional] VARIANT, ByRef CustomInput As [optional] VARIANT, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
FactoryFileName | Input String that specifies the full filename of the iPart factory.
Position | Input object that defines the position and orientation of the iPart placement within the assembly.
FullFileName | Input String that defines the filename of the resulting member. If the filename is not specified the default filename for the row will be used. In the case of a custom factory the filename must be specified and is not optional.
Row | Optional input Variant that specifies the row for the member within the factory. The row index is specified either by a Long (row index), a String (part identifier, i.e. ''[Height=1.000 in][Length=2.000 in][Radius=0.250 in]''), or an iPartTableRow object.
CustomInput | Optional input array of Strings that specifies the input to use for the custom input. If the factory is a custom factory and this is not supplied the default values for custom values are used. The custom input strings are supplied in a column order. If the factory is not a custom factory this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddCustomiPartMember Method


ComponentOccurrences.AddiAssemblyMember Method

ComponentOccurrences.AddiAssemblyMember Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates an occurrence of an iAssemblyMember in an assembly. The iAssemblyMember is specified by a factory and a row in the factory.

Visual Basic
Sub AddiAssemblyMember(FactoryDocumentName As String, Position As Matrix, ByRef Row As [optional] VARIANT, ByRef Options As [optional] VARIANT, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
FactoryDocumentName | String that specifies the full document name of the iAssembly factory.
Position | Matrix that defines the position and orientation of the iAssembly member placement within the assembly.
Row | Optional input Variant that specifies the row for the member within the factory. The row index is specified either by a Long (row index), a String (MemberName of a member), or an iAssemblyTableRow object. If not specified, the default row within the factory is used.
Options | Optional input NameValueMap object that specifies additional options for creating the occurrence. The valid options are: Name Value Type PrivateRepresentationFileName String DesignViewRepresentation String PositionalRepresentation String LevelOfDetailRepresentation String UseiMate Boolean PrivateRepresentationFileName As String If a PrivateRepresentationFileName (an idv file name) is specified, the DesignViewRepresentation name should be one of the private design views within that idv file else an error will occur. LevelOfDetailRepresentation As String Typically, the LevelOfDetailRepresentation to use should be provided in the form of a FullDocumentName (first argument). But if this is provided separately, you should make sure that it does not conflict with the FullDocumentName argument by providing FullFileName as the first argument rather than a FullDocumentName.
Example 1

Adding iAssembly occurrences

"This sample demonstrates adding iAssembly occurrences to an assembly. Before running the sample, make sure that C:\temp\iAssemblyFactory.iam exists and that it is an iAssembly factory. "

Public Sub AddiAssemblyOccurrence()

    ' Open the factory document invisible.
    Dim oFactoryDoc As AssemblyDocument
    Set oFactoryDoc = ThisApplication.Documents.Open("C:\temp\iAssemblyFactory.iam", False)

    ' Set a reference to the component definition.
    Dim oCompDef As AssemblyComponentDefinition
    Set oCompDef = oFactoryDoc.ComponentDefinition

    ' Make sure we have an iAssembly factory.
    If oCompDef.IsiAssemblyFactory = False Then
        MsgBox "Chosen document is not a factory.", vbExclamation
        Exit Sub
    End If

    ' Set a reference to the factory.
    Dim oiAssyFactory As iAssemblyFactory
    Set oiAssyFactory = oCompDef.iAssemblyFactory

    ' Get the number of rows in the factory.
    Dim iNumRows As Integer
    iNumRows = oiAssyFactory.TableRows.Count

    ' Create a new assembly document
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.Documents.Add(kAssemblyDocumentObject, , True)

    Dim oOccs As ComponentOccurrences
    Set oOccs = oDoc.ComponentDefinition.Occurrences

    Dim oPos As Matrix
    Set oPos = ThisApplication.TransientGeometry.CreateMatrix

    Dim oStep As Double
    oStep = 0#
    Dim iRow As Long

    ' Add an occurrence for each member in the factory.
    For iRow = 1 To iNumRows

        oStep = oStep + 10

        ' Add a translation along X axis
        oPos.SetTranslation ThisApplication.TransientGeometry.CreateVector(oStep, oStep, 0)

        Dim oOcc As ComponentOccurrence
        Set oOcc = oOccs.AddiAssemblyMember("C:\temp\iAssemblyFactory.iam ", oPos, iRow)
    Next
End Sub
Example 2

Add iAssembly Occurrence example (C#).

This sample demonstrates adding iAssembly occurrences to an assembly.

Before running the sample, make sure that C:/temp/iAssemblyFactory.iam exists and that it is an iAssembly factory.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void AddiAssemblyOccurrence()
{
    Application oApp = ThisApplication;

    // Open the factory document invisible.
    AssemblyDocument oFactoryDoc = (AssemblyDocument)oApp.Documents.Open("C:/temp/iAssemblyFactory.iam", false);

    // Set a reference to the component definition.
    AssemblyComponentDefinition oCompDef = oFactoryDoc.ComponentDefinition;

    // Make sure we have an iAssembly factory.
    if(!oCompDef.IsiAssemblyFactory)
    {
        System.Windows.Forms.MessageBox.Show("Chosen document is not a factory.", "Invalid document");
        return;
    }

    // Set a reference to the factory.
    iAssemblyFactory oiAssyFactory = oCompDef.iAssemblyFactory;

    // Get the number of rows in the factory.
    int iNumRows = oiAssyFactory.TableRows.Count;

    // Create a new assembly document
    AssemblyDocument oDoc = (AssemblyDocument)oApp.Documents.Add(DocumentTypeEnum.kAssemblyDocumentObject, "" , true);

    ComponentOccurrences oOccs = oDoc.ComponentDefinition.Occurrences;

    Matrix oPos = oApp.TransientGeometry.CreateMatrix();

    int oStep = 0;
    int iRow;

    // Add an occurrence for each member in the factory.
    for (iRow = 1; iRow <= iNumRows; iRow++)
    {
        oStep = oStep + 10;

        // Add a translation along X axis
        oPos.SetTranslation(oApp.TransientGeometry.CreateVector(oStep, oStep, 0), false);

        ComponentOccurrence oOcc = oOccs.AddiAssemblyMember("C:/temp/iAssemblyFactory.iam ", oPos, iRow, null);
    }

    // Release reference of the invisibly open document
    oFactoryDoc.ReleaseReference();

}
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddiAssemblyMember Method


ComponentOccurrences.AddiPartMember Method

ComponentOccurrences.AddiPartMember Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates an of an iPartMember in this AssemblyComponentDefinition. The iPartMember is specified by a factory and a row in the factory.

Visual Basic
Sub AddiPartMember(FactoryFileName As String, Position As Matrix, ByRef Row As [optional] VARIANT, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
FactoryFileName | Input String that specifies the full filename of the iPart factory.
Position | Input Matrix that defines the position and orientation of the iPart placement within the assembly.
Row | Optional input Variant that specifies the row for the member within the factory. The row index is specified either by a Long (row index), a String (part identifier, i.e. ''[Height=1.000 in][Length=2.000 in][Radius=0.250 in]''), or an iPartTableRow object.
Example 1

"Adding iPart occurrences to an assembly"

This sample demonstrates adding iPart occurrences to an assembly. Before running the sample, make sure that C:\temp\iPartFactory.ipt exists and that it is an iPart factory.

Public Sub AddiPartOccurrence()

    ' Open the factory document invisible.
    Dim oFactoryDoc As PartDocument
    Set oFactoryDoc = ThisApplication.Documents.Open("C:\temp\iPartFactory.ipt", False)

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oFactoryDoc.ComponentDefinition

    ' Make sure we have an iPart factory.
    If oCompDef.IsiPartFactory = False Then
        MsgBox "Chosen document is not a factory.", vbExclamation
        Exit Sub
    End If

    ' Set a reference to the factory.
    Dim oiPartFactory As iPartFactory
    Set oiPartFactory = oCompDef.iPartFactory

    ' Get the number of rows in the factory.
    Dim iNumRows As Integer
    iNumRows = oiPartFactory.TableRows.Count

    ' Create a new assembly document
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.Documents.Add(kAssemblyDocumentObject, , True)

    Dim oOccs As ComponentOccurrences
    Set oOccs = oDoc.ComponentDefinition.Occurrences

    Dim oPos As Matrix
    Set oPos = ThisApplication.TransientGeometry.CreateMatrix

    Dim oStep As Double
    oStep = 0#
    Dim iRow As Long

    ' Add an occurrence for each member in the factory.
    For iRow = 1 To iNumRows

        oStep = oStep + 10

        ' Add a translation along X axis
        oPos.SetTranslation ThisApplication.TransientGeometry.CreateVector(oStep, oStep, 0)

        Dim oOcc As ComponentOccurrence
        Set oOcc = oOccs.AddiPartMember("C:\temp\iPartFactory.ipt ", oPos, iRow)
    Next
End Sub
Example 2

Add iPart occurrence example (C#).

This sample demonstrates adding iPart occurrences to an assembly. Before running the sample, make sure that C:/temp/iPartFactory.ipt exists and that it is an iPart factory.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void AddiPartOccurrence()
{
    Application oApp = ThisApplication;

    // Open the factory document invisible.
    PartDocument oFactoryDoc = (PartDocument)oApp.Documents.Open("C:/temp/iPartFactory.ipt", false);

    // Set a reference to the component definition.
    PartComponentDefinition oCompDef = oFactoryDoc.ComponentDefinition;

    // Make sure we have an iPart factory.
    if(!oCompDef.IsiPartFactory)
    {
        System.Windows.Forms.MessageBox.Show("Chosen document is not a factory.", "Invalid document");
        return;
    }

    // Set a reference to the factory.
    iPartFactory oiPartFactory = oCompDef.iPartFactory;

    // Get the number of rows in the factory.
    int iNumRows = oiPartFactory.TableRows.Count;

    // Create a new assembly document
    AssemblyDocument oDoc = (AssemblyDocument)oApp.Documents.Add(DocumentTypeEnum.kAssemblyDocumentObject, "" , true);

    ComponentOccurrences oOccs = oDoc.ComponentDefinition.Occurrences;

    Matrix oPos = oApp.TransientGeometry.CreateMatrix();

    int oStep = 0;
    int iRow;

    // Add an occurrence for each member in the factory.
    for (iRow = 1; iRow <= iNumRows; iRow++)
    {
        oStep = oStep + 10;

        // Add a translation along X axis
        oPos.SetTranslation(oApp.TransientGeometry.CreateVector(oStep, oStep, 0), false);

        ComponentOccurrence oOcc = oOccs.AddiPartMember("C:/temp/iPartFactory.ipt ", oPos, iRow);
    }

    // Release reference of the invisibly open document
    oFactoryDoc.ReleaseReference();

}
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddiPartMember Method


ComponentOccurrences.AddUsingiMates Method

ComponentOccurrences.AddUsingiMates Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that adds a new occurrence into the assembly. This method is the equivalent of using the Place Component command with the "Use iMate" check box checked. The method returns a failure if no matches are found.

Visual Basic
Sub AddUsingiMates(FullDocumentName As String, ByRef PlaceAllMatching As [defaultvalue(0)] VARIANT_BOOL, ByRef Options As [optional] VARIANT, Result As [out, retval] ComponentOccurrencesEnumerator*)
Parameters
Parameters | Description
FullDocumentName | Input string that specifies the full document name of the part or the sub-assembly. If only the FullFileName is specified, the master document within the file is used.
PlaceAllMatching | Optional input Boolean that indicates whether to place multiple components corresponding to all iMate definition matches in the assembly. If specified to be True, multiple ComponentOccurrences could be returned. If specified to be False, a single ComponentOccurrence corresponding to the first match is returned.
Options | Input NameValueMap object that specifies additional options for creating the occurrence. (An empty NameValueMap object can be provided). See Remarks for valid options.
Remarks

The valid values for the Options parameter are:

Name | Value Type | Valid Document Type
PrivateRepresentationFileName | String | Assembly
DesignViewRepresentation | String | Assembly
DesignViewAssociative | Boolean | Assembly
PositionalRepresentation | String | Assembly
LevelOfDetailRepresentation | String | Assembly
Example

"iMate Creation During Occurrence Placement Example"

"This sample demonstrates creating multiple iMate results when adding an occurrence into an assembly. This uses the AddUsingiMate method which is the equivalent of using the Place Component command and checking the Use iMate check box on the dialog. To use this sample create a new part by extruding a rectangle to create a cube. Create a mate iMate on one of the faces. Next, create a flush iMate on any of the faces connecting to the first face. Save this part to C:\TempiMatePart.ipt. Finally, have an assembly open and run the sample code. "

Public Sub iMateDuringOccurrencePlacementSample()
    ' Get the component definition of the currently open assembly.
    ' This will fail if an assembly document is not open.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Create a new matrix object. It will be initialized to an identity matrix.
    Dim oMatrix As Matrix
    Set oMatrix = ThisApplication.TransientGeometry.CreateMatrix

    ' Place the first occurrence.
    Dim oOcc1 As ComponentOccurrence
    Set oOcc1 = oAsmCompDef.Occurrences.Add("C:\TempiMatePart.ipt", oMatrix)

    ' Place the second occurrence, but use iMates for its placement. This is
    ' equivalent to "Use iMate" check box on the "Place Component" dialog.
    Dim oOccEnumerator As ComponentOccurrencesEnumerator
    Set oOccEnumerator = oAsmCompDef.Occurrences.AddUsingiMates("C:\TempiMatePart.ipt", False)

    ' Since the 'PlaceAllMatching' flag was specified as False, we can be
    ' sure that just one ComponentOccurrence was returned in the enumerator.
    Dim oOcc1 As ComponentOccurrence
    Set oOcc1 = oOccEnumerator.Item(1)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddUsingiMates Method


ComponentOccurrences.AddVirtual Method

ComponentOccurrences.AddVirtual Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a virtual component definition and adds an occurrence based on that definition.

Visual Basic
Sub AddVirtual(Name As String, Position As Matrix, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
Name | Input string that specifies the name of the virtual component.
Position | Input Matrix object that defines the location and orientation to position the occurrence.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddVirtual Method


ComponentOccurrences.AddWithOptions Method

ComponentOccurrences.AddWithOptions Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new occurrence for an existing part or subassembly. This method is the equivalent of the "Place Component" command.

Visual Basic
Sub AddWithOptions(FullDocumentName As String, Position As Matrix, Options As NameValueMap, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters
Description
FullDocumentName
Input string that specifies the full document name of the part or the sub-assembly. If only the FullFileName is specified, the master document within the file is used.
Position
Input Matrix object that defines the location and orientation to position the occurrence.
Options
Input NameValueMap object that specifies additional options for creating the occurrence. (An empty NameValueMap object can be provided). The valid options are:
Name Value Type Valid Document Type
DesignViewRepresentation String Part, Assembly
DesignViewAssociative Boolean Part, Assembly
PositionalRepresentation String Assembly
LevelOfDetailRepresentation * String Assembly

  • Notes:

PrivateRepresentationFileName If a PrivateRepresentationFileName (an idv file name) is specified, the DesignViewRepresentation name should be one of the private design views within that idv file else an error will occur. LevelOfDetailRepresentation Typically, the LevelOfDetailRepresentation to use should be provided in the form of a FullDocumentName (first argument). But if this is provided separately, you should make sure that it does not conflict with the FullDocumentName argument by providing FullFileName as the first argument rather than a FullDocumentName.

Example

"Create assembly occurrence with representations"

"This sample demonstrates how to create an assembly occurrence by specifying various representations. Before running this sample, make sure that the file C:\Temp\Reps.iam exists (or change the path in the sample). The file must contain a level of detail representation named MyLODRep, a positional representation named MyPositionalRep and a design view representation named MyDesignViewRep."

Public Sub AddOccurrenceWithRepresentations()

    ' Set a reference to the assembly component definintion.
    ' This assumes an assembly document is open.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create a matrix. A new matrix is initialized with an identity matrix.
    Dim oMatrix As Matrix
    Set oMatrix = oTG.CreateMatrix

    ' Create a new NameValueMap object
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Set the representations to use when creating the occurrence.
    Call oOptions.Add("LevelOfDetailRepresentation", "MyLODRep")
    Call oOptions.Add("PositionalRepresentation", "MyPositionalRep")
    Call oOptions.Add("DesignViewRepresentation", "MyDesignViewRep")
    Call oOptions.Add("DesignViewAssociative", True)

    ' Add the occurrence.
    Dim oOcc As ComponentOccurrence
    Set oOcc = oAsmCompDef.Occurrences.AddWithOptions("C:\Temp\Reps.iam", oMatrix, oOptions)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AddWithOptions Method


ComponentOccurrences.AllLeafOccurrences Method

ComponentOccurrences.AllLeafOccurrences Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Return all unique leaf occurrences (optionally filtered to the specified definition) relative to this context.

Visual Basic
Sub AllLeafOccurrences(ByRef LeafDefinition As [optional] VARIANT, Result As [out, retval] ComponentOccurrencesEnumerator*)
Parameters
Parameters | Description
LeafDefinition | Occurence to be used as the basis for filtering the leaf space for a given leaf occurence.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AllLeafOccurrences Method


ComponentOccurrences.AllReferencedOccurrences Method

ComponentOccurrences.AllReferencedOccurrences Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns all occurrences that reference the input object.

Visual Basic
Sub AllReferencedOccurrences(Object As IDispatch, Result As [out, retval] ComponentOccurrencesEnumerator*)
Parameters
Parameters | Description
Object | Input DocumentDescriptor, ComponentDefinition or a Document object. All occurrences that reference the given object are returned.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.AllReferencedOccurrences Method


ComponentOccurrences.ItemByName Method

ComponentOccurrences.ItemByName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Allows string-indexed access to items in the collection. (Usually found when this ability has been added to a pre-existing collection).

Visual Basic
Sub ItemByName(Name As String, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
Name | Input String that specifies the name of required item in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrences Interface > ComponentOccurrences Methods > ComponentOccurrences.ItemByName Method


ComponentOccurrencesEnumerator Interface

ComponentOccurrencesEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to a list of objects.

Class Hierarchy
Inventor::ComponentOccurrencesEnumerator
    Inventor::ComponentOccurrences
Visual Basic
Public Interface ComponentOccurrencesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ComponentDefinitionReference.ImmediateOccurrences

ComponentOccurrence.OccurrencePath

ComponentOccurrence.SubOccurrences

ComponentOccurrences.AddUsingiMates

ComponentOccurrences.AllLeafOccurrences

ComponentOccurrences.AllReferencedOccurrences

OccurrencePatternElement.Occurrences

PartFeature.Participants

RigidBodyGroup.Occurrences

See Also

Promote occurence sample

iMate Creation During Occurrence Placement sample

Assembly Count Ocurrences sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrencesEnumerator Interface


ComponentOccurrencesEnumerator Methods

ComponentOccurrencesEnumerator Methods
Summary

The methods of the ComponentOccurrencesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrencesEnumerator Interface > ComponentOccurrencesEnumerator Methods


ComponentOccurrencesEnumerator.Item Method

ComponentOccurrencesEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] ComponentOccurrence*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
See Also

Promote occurence sample

iMate Creation During Occurrence Placement sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrencesEnumerator Interface > ComponentOccurrencesEnumerator Methods > ComponentOccurrencesEnumerator.Item Method


ComponentOccurrencesEnumerator Properties

ComponentOccurrencesEnumerator Properties
Summary

The properties of the ComponentOccurrencesEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrencesEnumerator Interface > ComponentOccurrencesEnumerator Properties


ComponentOccurrencesEnumerator.Count Property

ComponentOccurrencesEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Assembly Count Ocurrences sample

You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrencesEnumerator Interface > ComponentOccurrencesEnumerator Properties > ComponentOccurrencesEnumerator.Count Property


ComponentOccurrencesEnumerator.Type Property

ComponentOccurrencesEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ComponentOccurrencesEnumerator Interface > ComponentOccurrencesEnumerator Properties > ComponentOccurrencesEnumerator.Type Property


CompositeiMateDefinition Interface

CompositeiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The CompositeiMateDefinition object represents a composite iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::CompositeiMateDefinition
        Inventor::CompositeiMateDefinitionProxy
Visual Basic
Public Interface CompositeiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddCompositeiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinition Interface


CompositeiMateDefinition Methods

CompositeiMateDefinition Methods
Summary

The methods of the CompositeiMateDefinition class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified iMateDefinition object.
RemoveItems | Removes an object of the CompositeiMateDefinition collection.
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinition Interface > CompositeiMateDefinition Methods


CompositeiMateDefinition.Item Method

CompositeiMateDefinition.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified iMateDefinition object.

Visual Basic
Sub Item(index As long, Result As [out, retval] iMateDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinition Interface > CompositeiMateDefinition Methods > CompositeiMateDefinition.Item Method


CompositeiMateDefinition.RemoveItems Method

CompositeiMateDefinition.RemoveItems Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Removes an object of the CompositeiMateDefinition collection.

Visual Basic
Sub RemoveItems(iMates As ObjectCollection)
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinition Interface > CompositeiMateDefinition Methods > CompositeiMateDefinition.RemoveItems Method


CompositeiMateDefinition Properties

CompositeiMateDefinition Properties
Summary

The properties of the CompositeiMateDefinition class are listed here.

Properties
Name | Description
Count | Property that returns the number of iMateDefinitions in this composite iMate.
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinition Interface > CompositeiMateDefinition Properties


CompositeiMateDefinition.Count Property

CompositeiMateDefinition.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of iMateDefinitions in this composite iMate.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinition Interface > CompositeiMateDefinition Properties > CompositeiMateDefinition.Count Property


CompositeiMateDefinitionProxy Interface

CompositeiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CompositeiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::CompositeiMateDefinition
        Inventor::CompositeiMateDefinitionProxy
Visual Basic
Public Interface CompositeiMateDefinitionProxy
Inherits CompositeiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinitionProxy Interface


CompositeiMateDefinitionProxy Properties

CompositeiMateDefinitionProxy Properties
Summary

The properties of the CompositeiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinitionProxy Interface > CompositeiMateDefinitionProxy Properties


CompositeiMateDefinitionProxy.ContainingOccurrence Property

CompositeiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinitionProxy Interface > CompositeiMateDefinitionProxy Properties > CompositeiMateDefinitionProxy.ContainingOccurrence Property


CompositeiMateDefinitionProxy.IsConsumed Property

CompositeiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinitionProxy Interface > CompositeiMateDefinitionProxy Properties > CompositeiMateDefinitionProxy.IsConsumed Property


CompositeiMateDefinitionProxy.NativeObject Property

CompositeiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CompositeiMateDefinitionProxy Interface > CompositeiMateDefinitionProxy Properties > CompositeiMateDefinitionProxy.NativeObject Property


ConcentricConstraint Interface

ConcentricConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Sketch ConcentricConstraint object represents a concentric constraint within a sketch. Makes a circle, arc, ellipse, or elliptical arc concentric to another circle, arc, ellipse, or elliptical arc.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::ConcentricConstraint
        Inventor::ConcentricConstraintProxy
Visual Basic
Public Interface ConcentricConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

ConcentricConstraintProxy.NativeObject

GeometricConstraints.AddConcentric

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint Interface


ConcentricConstraint Properties

ConcentricConstraint Properties
Summary

The properties of the ConcentricConstraint class are listed here.

Properties
Name | Description
CenterPointConstraint | Gets a Boolean indicating if the constraint is between the arc and its centerpoint or not.
EntityOne | Gets the sketch entity being constrained.
EntityTwo | Gets the sketch entity being constrained.
You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint Interface > ConcentricConstraint Properties


ConcentricConstraint.CenterPointConstraint Property

ConcentricConstraint.CenterPointConstraint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets a Boolean indicating if the constraint is between the arc and its centerpoint or not.

Visual Basic
Property CenterPointConstraint() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint Interface > ConcentricConstraint Properties > ConcentricConstraint.CenterPointConstraint Property


ConcentricConstraint.EntityOne Property

ConcentricConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the sketch entity being constrained.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint Interface > ConcentricConstraint Properties > ConcentricConstraint.EntityOne Property


ConcentricConstraint.EntityTwo Property

ConcentricConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the sketch entity being constrained.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint Interface > ConcentricConstraint Properties > ConcentricConstraint.EntityTwo Property


ConcentricConstraint3D Interface

ConcentricConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The Sketch ConcentricConstraint3D object represents a concentric constraint within a sketch3D.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::ConcentricConstraint3D
Visual Basic
Public Interface ConcentricConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

ConcentricConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint3D Interface


ConcentricConstraint3DProxy Interface

ConcentricConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ConcentricConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::ConcentricConstraint3DProxy
Visual Basic
Public Interface ConcentricConstraint3DProxy
Inherits GeometricConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint3DProxy Interface


ConcentricConstraint3DProxy Properties

ConcentricConstraint3DProxy Properties
Summary

The properties of the ConcentricConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint3DProxy Interface > ConcentricConstraint3DProxy Properties


ConcentricConstraint3DProxy.ContainingOccurrence Property

ConcentricConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint3DProxy Interface > ConcentricConstraint3DProxy Properties > ConcentricConstraint3DProxy.ContainingOccurrence Property


ConcentricConstraint3DProxy.NativeObject Property

ConcentricConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ConcentricConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraint3DProxy Interface > ConcentricConstraint3DProxy Properties > ConcentricConstraint3DProxy.NativeObject Property


ConcentricConstraintProxy Interface

ConcentricConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ConcentricConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::ConcentricConstraint
        Inventor::ConcentricConstraintProxy
Visual Basic
Public Interface ConcentricConstraintProxy
Inherits ConcentricConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraintProxy Interface


ConcentricConstraintProxy Properties

ConcentricConstraintProxy Properties
Summary

The properties of the ConcentricConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraintProxy Interface > ConcentricConstraintProxy Properties


ConcentricConstraintProxy.ContainingOccurrence Property

ConcentricConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraintProxy Interface > ConcentricConstraintProxy Properties > ConcentricConstraintProxy.ContainingOccurrence Property


ConcentricConstraintProxy.NativeObject Property

ConcentricConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ConcentricConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ConcentricConstraintProxy Interface > ConcentricConstraintProxy Properties > ConcentricConstraintProxy.NativeObject Property


ConcentricHolePlacementDefinition Interface

ConcentricHolePlacementDefinition Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The ConcentricHolePlacementDefinition object defines the placement of a hole feature with a circular edge or a cylindrical face.

Class Hierarchy
Inventor::HolePlacementDefinition
    Inventor::ConcentricHolePlacementDefinition
Visual Basic
Public Interface ConcentricHolePlacementDefinition
Inherits HolePlacementDefinition
Notes

Members through which this object may be accessed include:

HoleFeatures.CreateConcentricPlacementDefinition

You are here: Symbol Reference > Inventor Library > Objects > ConcentricHolePlacementDefinition Interface


ConcentricHolePlacementDefinition Properties

ConcentricHolePlacementDefinition Properties
Summary

The properties of the ConcentricHolePlacementDefinition class are listed here.

Properties
Name | Description
ConcentricReference | Property that indicates the circular Edge or the cylindrical Face which forms the reference for the hole placement.
Plane | Property that indicates the Face or WorkPlane on which the hole feature is placed.
You are here: Symbol Reference > Inventor Library > Objects > ConcentricHolePlacementDefinition Interface > ConcentricHolePlacementDefinition Properties


ConcentricHolePlacementDefinition.ConcentricReference Property

ConcentricHolePlacementDefinition.ConcentricReference Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the circular Edge or the cylindrical Face which forms the reference for the hole placement.

Visual Basic
Property ConcentricReference() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ConcentricHolePlacementDefinition Interface > ConcentricHolePlacementDefinition Properties > ConcentricHolePlacementDefinition.ConcentricReference Property


ConcentricHolePlacementDefinition.Plane Property

ConcentricHolePlacementDefinition.Plane Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the Face or WorkPlane on which the hole feature is placed.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ConcentricHolePlacementDefinition Interface > ConcentricHolePlacementDefinition Properties > ConcentricHolePlacementDefinition.Plane Property


Cone Interface

Cone Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Cone object. The object is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::Cone
Visual Basic
Public Interface Cone
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateCone

Face.Geometry

FaceDefinition.SurfaceGeometry

You are here: Symbol Reference > Inventor Library > Objects > Cone Interface


Cone Methods

Cone Methods
Summary

The methods of the Cone class are listed here.

Methods
Methods
Name | Description
GetConeData | Get the data defining this cone.
PutConeData | Method that sets the data defining this cone.
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Methods


Cone.GetConeData Method

Cone.GetConeData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this cone.

Visual Basic
Sub GetConeData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef Radius As double, ByRef HalfAngle As double, ByRef IsExpanding As VARIANT_BOOL)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies the base point of the cone.
AxisVector | Input/output Double that specifies axis vector.
Radius | Output Double that specifies the radius of the cone.
HalfAngle | Output Double that specifies the half-angle value for the cone.
IsExpanding | Output Boolean that specifies whether the radius of the cone is expanding or not, in the direction of the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Methods > Cone.GetConeData Method


Cone.PutConeData Method

Cone.PutConeData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this cone.

Visual Basic
Sub PutConeData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), Radius As double, HalfAngle As double, IsExpanding As VARIANT_BOOL)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies the base point of the cone.
AxisVector | Input/output Double that specifies axis vector.
Radius | Input Double that specifies the radius of the cone.
HalfAngle | Input Double that specifies the half-angle value for the cone.
IsExpanding | Input Boolean that specifies whether the radius of the cone is expanding or not, in the direction of the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Methods > Cone.PutConeData Method


Cone Properties

Cone Properties
Summary

The properties of the Cone class are listed here.

Properties
Name | Description
AxisVector | Specifies the direction of the axis of the cone.
BasePoint | Specifies the base of the cone.
Evaluator | Gets the surface evaluator for this cone.
HalfAngle | Specifies the taper angle of the cone. This is the angle measured from the axis to the side of the cone.
IsExpanding | Indicates whether the taper of the cone is expanding outwards or inwards in the direction of the axis vector. If True and the HalfAngle is positive, then the cone is expanding outward along the axis vector.
Radius | Specifies the radius of the cone at the base point.
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties


Cone.AxisVector Property

Cone.AxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the axis of the cone.

Visual Basic
Property AxisVector() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties > Cone.AxisVector Property


Cone.BasePoint Property

Cone.BasePoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the base of the cone.

Visual Basic
Property BasePoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties > Cone.BasePoint Property


Cone.Evaluator Property

Cone.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this cone.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties > Cone.Evaluator Property


Cone.HalfAngle Property

Cone.HalfAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the taper angle of the cone. This is the angle measured from the axis to the side of the cone.

Visual Basic
Property HalfAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties > Cone.HalfAngle Property


Cone.IsExpanding Property

Cone.IsExpanding Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates whether the taper of the cone is expanding outwards or inwards in the direction of the axis vector. If True and the HalfAngle is positive, then the cone is expanding outward along the axis vector.

Visual Basic
Property IsExpanding() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties > Cone.IsExpanding Property


Cone.Radius Property

Cone.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the radius of the cone at the base point.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Cone Interface > Cone Properties > Cone.Radius Property


ConstraintLimits Interface

ConstraintLimits Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The ConstraintLimits object provides access to various limits related settings for assembly constraints and iMate definitions.

Class Hierarchy
Inventor::ConstraintLimits
Visual Basic
Public Interface ConstraintLimits
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AngleConstraint.ConstraintLimits

FlushConstraint.ConstraintLimits

FlushiMateDefinition.ConstraintLimits

InsertConstraint.ConstraintLimits

InsertiMateDefinition.ConstraintLimits

MateConstraint.ConstraintLimits

MateiMateDefinition.ConstraintLimits

TangentConstraint.ConstraintLimits

TangentiMateDefinition.ConstraintLimits

You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface


ConstraintLimits Properties

ConstraintLimits Properties
Summary

The properties of the ConstraintLimits class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Maximum | Property that returns the Parameter object that controls the maximum limit value. This property returns Nothing if the maximum limit has never been enabled for this constraint or the parameter associated with the maximum value was deleted. Set the MaximumEnabled property to True to make this parameter available.
MaximumEnabled | Property that gets and sets whether the maximum limit value should be enabled. Once enabled, the parameter returned in the Maximum property can be used to control the value of this limit.
Minimum | Property that returns the Parameter object that controls the minimum limit value. This property returns Nothing if the minimum limit has never been enabled for this constraint or the parameter associated with the minimum value was deleted. Set the MinimumEnabled property to True to make this parameter available.
MinimumEnabled | Property that gets and sets whether the minimum limit value should be enabled. Once enabled, the parameter returned in the Minimum property can be used to control the value of this limit.
Parent | Property that returns the parent object. This can be one of the strongly typed assembly constraint objects (such as MateConstraint) or one of the strongly typed iMate definition objects (such as MateiMateDefinition).
RestingPositionEnabled | Property that gets and sets whether the resting position value should be enabled. If enabled, the constraint snaps back to the nominal value after a drag or a solve.
Type | Property returning kConstraintLimitsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties


ConstraintLimits.Application Property

ConstraintLimits.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.Application Property


ConstraintLimits.Maximum Property

ConstraintLimits.Maximum Property Introduced in Inventor 2011
Summary

Property that returns the Parameter object that controls the maximum limit value. This property returns Nothing if the maximum limit has never been enabled for this constraint or the parameter associated with the maximum value was deleted. Set the MaximumEnabled property to True to make this parameter available.

Visual Basic
Property Maximum() As Parameter**
See Also

Mate constraint with limits sample

You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.Maximum Property


ConstraintLimits.MaximumEnabled Property

ConstraintLimits.MaximumEnabled Property Introduced in Inventor 2011
Summary

Property that gets and sets whether the maximum limit value should be enabled. Once enabled, the parameter returned in the Maximum property can be used to control the value of this limit.

Visual Basic
Property MaximumEnabled() As VARIANT_BOOL
See Also

Mate constraint with limits sample

You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.MaximumEnabled Property


ConstraintLimits.Minimum Property

ConstraintLimits.Minimum Property Introduced in Inventor 2011
Summary

Property that returns the Parameter object that controls the minimum limit value. This property returns Nothing if the minimum limit has never been enabled for this constraint or the parameter associated with the minimum value was deleted. Set the MinimumEnabled property to True to make this parameter available.

Visual Basic
Property Minimum() As Parameter**
See Also

Mate constraint with limits sample

You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.Minimum Property


ConstraintLimits.MinimumEnabled Property

ConstraintLimits.MinimumEnabled Property Introduced in Inventor 2011
Summary

Property that gets and sets whether the minimum limit value should be enabled. Once enabled, the parameter returned in the Minimum property can be used to control the value of this limit.

Visual Basic
Property MinimumEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.MinimumEnabled Property


ConstraintLimits.Parent Property

ConstraintLimits.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent object. This can be one of the strongly typed assembly constraint objects (such as MateConstraint) or one of the strongly typed iMate definition objects (such as MateiMateDefinition).

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.Parent Property


ConstraintLimits.RestingPositionEnabled Property

ConstraintLimits.RestingPositionEnabled Property Introduced in Inventor 2011
Summary

Property that gets and sets whether the resting position value should be enabled. If enabled, the constraint snaps back to the nominal value after a drag or a solve.

Visual Basic
Property RestingPositionEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.RestingPositionEnabled Property


ConstraintLimits.Type Property

ConstraintLimits.Type Property Introduced in Inventor 2011
Summary

Property returning kConstraintLimitsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ConstraintLimits Interface > ConstraintLimits Properties > ConstraintLimits.Type Property


ContentCenter Interface

ContentCenter Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentCenter object provides the API interface to the Content Center functionality.

Class Hierarchy
Inventor::ContentCenter
Visual Basic
Public Interface ContentCenter
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentCenterEventsObject.Parent

ContentQueryObject.Parent

Application.ContentCenter

See Also

Place content center part sample

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface


ContentCenter Methods

ContentCenter Methods
Summary

The methods of the ContentCenter class are listed here.

Methods
Methods
Name | Description
GetContentObject | Property that returns the specified content center object specified by the content identifier. If the object cannot be found then Nothing is returned. This can return a ContentFamily or ContentRow depending on what the identifier represents.
You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface > ContentCenter Methods


ContentCenter.GetContentObject Method

ContentCenter.GetContentObject Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the specified content center object specified by the content identifier. If the object cannot be found then Nothing is returned. This can return a ContentFamily or ContentRow depending on what the identifier represents.

Visual Basic
Sub GetContentObject(ContentIdentifier As String, ByRef LibraryId As [defaultvalue("")] BSTR, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
ContentIdentifier | Input String that was previously obtained using the ContentIdentifier property of a content center object.
LibraryId | Not currently supported.
You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface > ContentCenter Methods > ContentCenter.GetContentObject Method


ContentCenter Properties

ContentCenter Properties
Summary

The properties of the ContentCenter class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
TreeViewTopNode | Property that returns the top-most node in the Content Center tree. The entire tree can be accessed by traversing the tree beginning at this node.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface > ContentCenter Properties


ContentCenter.Application Property

ContentCenter.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface > ContentCenter Properties > ContentCenter.Application Property


ContentCenter.TreeViewTopNode Property

ContentCenter.TreeViewTopNode Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the top-most node in the Content Center tree. The entire tree can be accessed by traversing the tree beginning at this node.

Visual Basic
Property TreeViewTopNode() As ContentTreeViewNode**
See Also

Place content center part sample

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface > ContentCenter Properties > ContentCenter.TreeViewTopNode Property


ContentCenter.Type Property

ContentCenter.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentCenter Interface > ContentCenter Properties > ContentCenter.Type Property


ContentCenterOptions Interface

ContentCenterOptions Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentCenterOptions object provides access to properties that provide read and write access of the content center related application options.

Class Hierarchy
Inventor::ContentCenterOptions
Visual Basic
Public Interface ContentCenterOptions
Inherits IDispatch
Remarks

This is somewhat equivalent to the Content Center tab of the Application Options dialog.

Notes

Members through which this object may be accessed include:

Application.ContentCenterOptions

You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface


ContentCenterOptions Methods

ContentCenterOptions Methods
Summary

The methods of the ContentCenterOptions class are listed here.

Methods
Methods
Name | Description
GetAccessOption | Method that gets the access option for content center (Inventor Desktop or Vault/Productstream).
SetAccessOption | Method that sets the access option for content center (Inventor Desktop or Vault/Productstream).
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Methods


ContentCenterOptions.GetAccessOption Method

ContentCenterOptions.GetAccessOption Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets the access option for content center (Inventor Desktop or Vault/Productstream).

Visual Basic
Sub GetAccessOption(ByRef AccessOption As ContentCenterAccessOptionEnum, ByRef LibrariesLocation As String)
Parameters
Parameters | Description
AccessOption | Output ContentCenterAccessOptionEnum value that returns the access option for content center. This can either be kInventorDesktopAccess or kVaultOrProductstreamServerAccess. If kInventorDesktopAccess is returned, the LibrariesLocation argument returns the location of the libraries.
LibrariesLocation | Output String that returns the location of the libraries if the access option is kInventorDesktopAccess. The argument returns a null string if the access option is kVaultOrProductstreamServerAccess.
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Methods > ContentCenterOptions.GetAccessOption Method


ContentCenterOptions.SetAccessOption Method

ContentCenterOptions.SetAccessOption Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the access option for content center (Inventor Desktop or Vault/Productstream).

Visual Basic
Sub SetAccessOption(AccessOption As ContentCenterAccessOptionEnum, ByRef LibrariesLocation As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
AccessOption | Input ContentCenterAccessOptionEnum value that specifies the access option for content center. This can either be kInventorDesktopAccess or kVaultOrProductstreamServerAccess. If kInventorDesktopAccess is input, the LibrariesLocation argument must be specified.
LibrariesLocation | Optional input String that specifies the location of the libraries if the access option is kInventorDesktopAccess. The argument must be specified for kInventorDesktopAccess, and can be ignored for kVaultOrProductstreamServerAccess.
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Methods > ContentCenterOptions.SetAccessOption Method


ContentCenterOptions Properties

ContentCenterOptions Properties
Summary

The properties of the ContentCenterOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CustomFamilyAsStandard | Gets/sets whether to place Family with custom's columns As Standard or As Custom.
RefreshOutOfDateStandardParts | Property that gets and sets whether to automatically refresh out of date standard parts during placement. If set to False, the existing (out-of-date) parts are re-used and the user is notified about the out-of-date status.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Properties


ContentCenterOptions.Application Property

ContentCenterOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Properties > ContentCenterOptions.Application Property


ContentCenterOptions.CustomFamilyAsStandard Property

ContentCenterOptions.CustomFamilyAsStandard Property
Summary

Gets/sets whether to place Family with custom's columns As Standard or As Custom.

Visual Basic
Property CustomFamilyAsStandard() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Properties > ContentCenterOptions.CustomFamilyAsStandard Property


ContentCenterOptions.RefreshOutOfDateStandardParts Property

ContentCenterOptions.RefreshOutOfDateStandardParts Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to automatically refresh out of date standard parts during placement. If set to False, the existing (out-of-date) parts are re-used and the user is notified about the out-of-date status.

Visual Basic
Property RefreshOutOfDateStandardParts() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Properties > ContentCenterOptions.RefreshOutOfDateStandardParts Property


ContentCenterOptions.Type Property

ContentCenterOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentCenterOptions Interface > ContentCenterOptions Properties > ContentCenterOptions.Type Property


ContentFamiliesEnumerator Interface

ContentFamiliesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Object allowing enumeration of ContentFamily objects.

Class Hierarchy
Inventor::ContentFamiliesEnumerator
Visual Basic
Public Interface ContentFamiliesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentTreeViewNode.Families

You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface


ContentFamiliesEnumerator Methods

ContentFamiliesEnumerator Methods
Summary

The methods of the ContentFamiliesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface > ContentFamiliesEnumerator Methods


ContentFamiliesEnumerator.Item Method

ContentFamiliesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ContentFamily*)
You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface > ContentFamiliesEnumerator Methods > ContentFamiliesEnumerator.Item Method


ContentFamiliesEnumerator Properties

ContentFamiliesEnumerator Properties
Summary

The properties of the ContentFamiliesEnumerator class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of ContentFamily objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface > ContentFamiliesEnumerator Properties


ContentFamiliesEnumerator.Application Property

ContentFamiliesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface > ContentFamiliesEnumerator Properties > ContentFamiliesEnumerator.Application Property


ContentFamiliesEnumerator.Count Property

ContentFamiliesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of ContentFamily objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface > ContentFamiliesEnumerator Properties > ContentFamiliesEnumerator.Count Property


ContentFamiliesEnumerator.Type Property

ContentFamiliesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamiliesEnumerator Interface > ContentFamiliesEnumerator Properties > ContentFamiliesEnumerator.Type Property


ContentFamily Interface

ContentFamily Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentFamily object represents a content center family and provides access to the information associated with a family.

Class Hierarchy
Inventor::ContentFamily
Visual Basic
Public Interface ContentFamily
Inherits IDispatch
Remarks

Available information includes the various family properties, the thumbnail, parameter mapping, and the table.

Notes

Members through which this object may be accessed include:

ContentFamiliesEnumerator.Item

ContentTableCell.Parent

ContentTableColumn.Parent

ContentTableRow.Parent

See Also

Place content center part sample

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface


ContentFamily Methods

ContentFamily Methods
Summary

The methods of the ContentFamily class are listed here.

Methods
Methods
Name | Description
CreateMember | Method that creates a member part for the specified table row. The full filename of the created member is returned. If the creation fails the FailureReason argument indicates the reason for failure.
GetCustomData | Method that gets the specified custom data from the family. The custom data is returned if it exists or this method will fail if the specified custom data does not exist. You can use the HasCustomData property to determine if custom data exists.
HasCustomData | Property indicates if the family has the specified custom data. Returns True if the data exists.
Save | Method that saves the changes that have been made to this family. This method fails if the family is not modifiable
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Methods


ContentFamily.CreateMember Method

ContentFamily.CreateMember Method
Summary

Method that creates a member part for the specified table row. The full filename of the created member is returned. If the creation fails the FailureReason argument indicates the reason for failure.

Visual Basic
Sub CreateMember(Row As VARIANT, ByRef FailureReason As MemberManagerErrorsEnum, ByRef FailureMessage As String, ByRef Refresh As [defaultvalue(kUseDefaultRefreshSetting)] ContentMemberRefreshEnum, ByRef Custom As [defaultvalue(0)] VARIANT_BOOL, ByRef FileName As [defaultvalue("")] BSTR, ByRef CustomInput As [optional] VARIANT, ByRef Options As [optional] VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Row | Input Variant that specifies which row to use to create the member. The row index can be specified by a Long (row index), a ContentTableRow object, or the internal name of a ContentTableRow object.
FailureReason | Output MemberManagerErrorsEnum that indicates the reason for failure, if the creation of the member did fail.
FailureMessage | Output String that contains a message describing the reason for failure, if the creation of the member did fail. If it didn"t fail this will return an empty String.
Refresh | Optional Input ContentMemberRefreshEnum that specifies the behavior to use if the member already exists locally. kUseDefaultRefreshSetting indicates that the method should use whatever the default setting is as set by the user using the "Content Center" tab of the Application options dialog. kRefreshOutOfDateParts indicates that if the part already exists in the local cache and is out of date if it should be replaced with an up to date version of the part. kDoNotRefreshOutOfDateParts indicates that the existing part will be used and not overridden.
Custom | Optional Input Boolean that indicates if this part should be created as a custom or standard part. A value of True indicates it will be a custom member.
FileName | Optional Input String that defines the filename of the resulting member. This argument is only used in the case of a custom family (ContentFamily.IsCustom is true) and is ignored for a standard family. In the case of a custom factory the filename must be specified and is not optional.
CustomInput | Optional input NameValueMap that specifies the input to use for the custom input. If the family is custom and this is not supplied, the default values for custom values are used. For each input value you use the NameValueMap to specify the Column ID as the name and the custom value as the new value . If the factory is not a custom factory this argument is ignored.
Options | Optional Input NameValueMap that specifies additional options for this method. This is not currently being used.
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Methods > ContentFamily.CreateMember Method


ContentFamily.GetCustomData Method

ContentFamily.GetCustomData Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that gets the specified custom data from the family. The custom data is returned if it exists or this method will fail if the specified custom data does not exist. You can use the HasCustomData property to determine if custom data exists.

Visual Basic
Sub GetCustomData(ClientId As String, InternalName As String, ByRef CustomData As SAFEARRAY(BYTE))
Parameters
Parameters | Description
ClientId | Input String that uniquely identifies the application that created the custom data. This is commonly the CLSID of the Add-In in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", but it can be any string.
InternalName | Input String value that specifies the unique name of the custom data to retrieve.
CustomData | Output array of bytes containing the custom data.
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Methods > ContentFamily.GetCustomData Method


ContentFamily.HasCustomData Method

ContentFamily.HasCustomData Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property indicates if the family has the specified custom data. Returns True if the data exists.

Visual Basic
Sub HasCustomData(ClientId As String, InternalName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
ClientId | Input String that uniquely identifies the application that created the custom data. This is commonly the CLSID of the Add-In in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", but can be any string.
InternalName | Input String value that specifies the unique name of the custom data.
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Methods > ContentFamily.HasCustomData Method


ContentFamily.Save Method

ContentFamily.Save Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that saves the changes that have been made to this family. This method fails if the family is not modifiable

Visual Basic
Sub Save()
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Methods > ContentFamily.Save Method


ContentFamily Properties

ContentFamily Properties
Summary

The properties of the ContentFamily class are listed here.

Properties
Name | Description
ActiveCell | Property that returns a floating cell object that caller can use for iterating the table using indices. Set the Row and Column properties on the returned object to iterate through the table.
Application | Property that returns the root Application object.
ContentIdentifier | Property that returns the identifier for this object. This can be used with the GetContentObject method of the ContentCenter object to obtain this object at a later time.
Description | Property that gets and sets the description of this family. Setting the value of this property will fail if the family is not modifiable.
DesignationColumn | Property that returns the column representing family designation values.
DisplayName | Property that gets and sets the name of this family as seen by the end-user. Setting the value of this property will fail if the family is not modifiable.
FamilyType | Property that returns the constant that indicates what type of family this family is; kContentPartFamily or kContentFeatureFamily.
FileNameColumn | Property that returns the column representing family file name values.
InternalName | Property that returns the internal name of the ContentFamily. The internal name uniquely identifies this family with respect to other families in the library and it cannot be changed so it will remain consistent.
IsCustom | Property that indicates if this family is a custom or standard family. A custom family has at least one custom column and requires the additional input of the values for the custom columns and a filename when creating a member of the family.
IsModifiable | Property that indicates if this library is writable or not. Returns True in the case where the library is modifiable.
LibraryInternalName | Property that returns the internal name of the library this family is defined within.
LibraryName | Property that returns the display name of the library this family is defined within.
Manufacturer | Property that gets and sets the manufacturer of the parts within this family. Setting the value of this property will fail if the family is not modifiable.
MemberDirectory | Property that gets and sets the name of the directory where family members are saved.
RevisionId | Property that returns the family revision Id, which is a GUID in string format.
Standard | Property that gets and sets the standard this family is based on. For example, this can return 'ASNI B18.6.3'. Setting the value of this property will fail if the family is not modifiable.
StandardOrganization | Property that gets and sets the standard organization this family is part of.
StandardRevision | Property that gets the standard revision this family is based on.
TableColumns | Property that returns the collection of columns for the table associated with this family.
TableRows | Property that returns the collection of rows for the table associated with this family.
Thumbnail | Property that gets and sets the image used for the thumbnail of this family.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties


ContentFamily.ActiveCell Property

ContentFamily.ActiveCell Property
Summary

Property that returns a floating cell object that caller can use for iterating the table using indices. Set the Row and Column properties on the returned object to iterate through the table.

Visual Basic
Property ActiveCell() As ContentTableCell**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.ActiveCell Property


ContentFamily.Application Property

ContentFamily.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.Application Property


ContentFamily.ContentIdentifier Property

ContentFamily.ContentIdentifier Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the identifier for this object. This can be used with the GetContentObject method of the ContentCenter object to obtain this object at a later time.

Visual Basic
Property ContentIdentifier() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.ContentIdentifier Property


ContentFamily.Description Property

ContentFamily.Description Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the description of this family. Setting the value of this property will fail if the family is not modifiable.

Visual Basic
Property Description() As String
Remarks

Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.Description Property


ContentFamily.DesignationColumn Property

ContentFamily.DesignationColumn Property
Summary

Property that returns the column representing family designation values.

Visual Basic
Property DesignationColumn() As ContentTableColumn**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.DesignationColumn Property


ContentFamily.DisplayName Property

ContentFamily.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the name of this family as seen by the end-user. Setting the value of this property will fail if the family is not modifiable.

Visual Basic
Property DisplayName() As String
Remarks

Any changes to the table are not actually applied until the ContentFamily.Save method is called.

See Also

Place content center part sample

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.DisplayName Property


ContentFamily.FamilyType Property

ContentFamily.FamilyType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the constant that indicates what type of family this family is; kContentPartFamily or kContentFeatureFamily.

Visual Basic
Property FamilyType() As ContentFamilyTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.FamilyType Property


ContentFamily.FileNameColumn Property

ContentFamily.FileNameColumn Property
Summary

Property that returns the column representing family file name values.

Visual Basic
Property FileNameColumn() As ContentTableColumn**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.FileNameColumn Property


ContentFamily.InternalName Property

ContentFamily.InternalName Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the internal name of the ContentFamily. The internal name uniquely identifies this family with respect to other families in the library and it cannot be changed so it will remain consistent.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.InternalName Property


ContentFamily.IsCustom Property

ContentFamily.IsCustom Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that indicates if this family is a custom or standard family. A custom family has at least one custom column and requires the additional input of the values for the custom columns and a filename when creating a member of the family.

Visual Basic
Property IsCustom() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.IsCustom Property


ContentFamily.IsModifiable Property

ContentFamily.IsModifiable Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if this library is writable or not. Returns True in the case where the library is modifiable.

Visual Basic
Property IsModifiable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.IsModifiable Property


ContentFamily.LibraryInternalName Property

ContentFamily.LibraryInternalName Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the internal name of the library this family is defined within.

Visual Basic
Property LibraryInternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.LibraryInternalName Property


ContentFamily.LibraryName Property

ContentFamily.LibraryName Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the display name of the library this family is defined within.

Visual Basic
Property LibraryName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.LibraryName Property


ContentFamily.Manufacturer Property

ContentFamily.Manufacturer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the manufacturer of the parts within this family. Setting the value of this property will fail if the family is not modifiable.

Visual Basic
Property Manufacturer() As String
Remarks

Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.Manufacturer Property


ContentFamily.MemberDirectory Property

ContentFamily.MemberDirectory Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the name of the directory where family members are saved.

Visual Basic
Property MemberDirectory() As String
Remarks

Setting the value of this property will fail if the family is not modifiable. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.MemberDirectory Property


ContentFamily.RevisionId Property

ContentFamily.RevisionId Property
Summary

Property that returns the family revision Id, which is a GUID in string format.

Visual Basic
Property RevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.RevisionId Property


ContentFamily.Standard Property

ContentFamily.Standard Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the standard this family is based on. For example, this can return 'ASNI B18.6.3'. Setting the value of this property will fail if the family is not modifiable.

Visual Basic
Property Standard() As String
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.Standard Property


ContentFamily.StandardOrganization Property

ContentFamily.StandardOrganization Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the standard organization this family is part of.

Visual Basic
Property StandardOrganization() As String
Remarks

For example, the String 'ANSI' is a possible value. Setting the value of this property will fail if the family is not modifiable. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.StandardOrganization Property


ContentFamily.StandardRevision Property

ContentFamily.StandardRevision Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the standard revision this family is based on.

Visual Basic
Property StandardRevision() As String
Remarks

For example the value '2003' is a possible value. Setting the value of this property will fail if the family is not modifiable. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.StandardRevision Property


ContentFamily.TableColumns Property

ContentFamily.TableColumns Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of columns for the table associated with this family.

Visual Basic
Property TableColumns() As ContentTableColumns**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.TableColumns Property


ContentFamily.TableRows Property

ContentFamily.TableRows Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of rows for the table associated with this family.

Visual Basic
Property TableRows() As ContentTableRows**
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.TableRows Property


ContentFamily.Thumbnail Property

ContentFamily.Thumbnail Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the image used for the thumbnail of this family.

Visual Basic
Property Thumbnail() As IPictureDisp*
Remarks

Setting the value of this property will fail if the family is not modifiable. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.Thumbnail Property


ContentFamily.Type Property

ContentFamily.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentFamily Interface > ContentFamily Properties > ContentFamily.Type Property


ContentTableCell Interface

ContentTableCell Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentTableCell object represents a specific cell with a content center family table.

Class Hierarchy
Inventor::ContentTableCell
Visual Basic
Public Interface ContentTableCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentFamily.ActiveCell

ContentTableRow.Item

You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface


ContentTableCell Properties

ContentTableCell Properties
Summary

The properties of the ContentTableCell class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Column | Property that returns the column index of this cell within the parent ContentFamily.
IsOverridden | Property that indicates if the value of this sell has been overwritten from its original value.
Parent | Property that returns the parent ContentFamily object.
Row | Property that returns the row index of this cell within the parent ContentFamily.
Type | Property that returns the constant that indicates the type of this object.
Value | Property that gets and sets the value of the cell.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties


ContentTableCell.Application Property

ContentTableCell.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.Application Property


ContentTableCell.Column Property

ContentTableCell.Column Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the column index of this cell within the parent ContentFamily.

Visual Basic
Property Column() As long
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.Column Property


ContentTableCell.IsOverridden Property

ContentTableCell.IsOverridden Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that indicates if the value of this sell has been overwritten from its original value.

Visual Basic
Property IsOverridden() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.IsOverridden Property


ContentTableCell.Parent Property

ContentTableCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent ContentFamily object.

Visual Basic
Property Parent() As ContentFamily**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.Parent Property


ContentTableCell.Row Property

ContentTableCell.Row Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the row index of this cell within the parent ContentFamily.

Visual Basic
Property Row() As long
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.Row Property


ContentTableCell.Type Property

ContentTableCell.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.Type Property


ContentTableCell.Value Property

ContentTableCell.Value Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the value of the cell.

Visual Basic
Property Value() As String
You are here: Symbol Reference > Inventor Library > Objects > ContentTableCell Interface > ContentTableCell Properties > ContentTableCell.Value Property


ContentTableColumn Interface

ContentTableColumn Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentTableColumn object represents the column of the table associated with a particular content center family.

Class Hierarchy
Inventor::ContentTableColumn
Visual Basic
Public Interface ContentTableColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentFamily.DesignationColumn

ContentFamily.FileNameColumn

ContentTableColumns.Add

ContentTableColumns.Item

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface


ContentTableColumn Methods

ContentTableColumn Methods
Summary

The methods of the ContentTableColumn class are listed here.

Methods
Methods
Name | Description
ClearPropertyMap | Method that removes any property mapping for this column.
GetPropertyMap | Method that gets the information associated with a custom expression. This method is only valid when the HasPropertyMap property returns True.
SetPropertyMap | Method that sets the information associated with a custom expression.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Methods


ContentTableColumn.ClearPropertyMap Method

ContentTableColumn.ClearPropertyMap Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that removes any property mapping for this column.

Visual Basic
Sub ClearPropertyMap()
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Methods > ContentTableColumn.ClearPropertyMap Method


ContentTableColumn.GetPropertyMap Method

ContentTableColumn.GetPropertyMap Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets the information associated with a custom expression. This method is only valid when the HasPropertyMap property returns True.

Visual Basic
Sub GetPropertyMap(ByRef PropertySetId As String, ByRef PropertyIdentifier As String)
Parameters
Parameters | Description
PropertySetId | Output String that specifies the name of the property set that contains the property. This is the name associated with the property set.
PropertyIdentifier | Output String that identifies a property. This name of the property.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Methods > ContentTableColumn.GetPropertyMap Method


ContentTableColumn.SetPropertyMap Method

ContentTableColumn.SetPropertyMap Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the information associated with a custom expression.

Visual Basic
Sub SetPropertyMap(PropertySetId As String, PropertyIdentifier As VARIANT)
Parameters
Parameters | Description
PropertySetId | Input String that specifies the name of the property set that contains the property. This is the InternalName or Name associated with the property set.
PropertyIdentifier | Input Variant that identifies a property. This can be a Long value that specifies the PropId of a property within the specified property set or the name of a property.
Remarks

This method is only valid when the HasCustomExpression property returns True. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Methods > ContentTableColumn.SetPropertyMap Method


ContentTableColumn Properties

ContentTableColumn Properties
Summary

The properties of the ContentTableColumn class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
DataType | Property that indicates the type of value defined for this column. Values this property can return are kIntegerType, kDoubleType, kStringType, and kBooleanType.
DisplayHeading | Property that gets and sets the display name of this column.
Expression | Property that gets and sets the expression to use to automatically populate the rows of this column.
HasPropertyMap | Property that indicates if this column is mapped to an iProperty.
InternalName | Property that gets and sets the name of this column.
KeyColumnOrder | Property that specifies if this column is a key column and what order this column should be in the key column list. The key columns are displayed on the Select tab when placing a content part. The Filename and Designation columns do not support key ordering and this property will fail if you attempt to set their order.
Parent | Property that returns the ContentFamily object this column is associated with.
Type | Property that returns the constant that indicates the type of this object.
Units | Property that allows you to get and set the units of the column.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties


ContentTableColumn.Application Property

ContentTableColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.Application Property


ContentTableColumn.DataType Property

ContentTableColumn.DataType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates the type of value defined for this column. Values this property can return are kIntegerType, kDoubleType, kStringType, and kBooleanType.

Visual Basic
Property DataType() As ValueTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.DataType Property


ContentTableColumn.DisplayHeading Property

ContentTableColumn.DisplayHeading Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the display name of this column.

Visual Basic
Property DisplayHeading() As String
Remarks

This is the name of the column that the end-user sees within the user interface. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.DisplayHeading Property


ContentTableColumn.Expression Property

ContentTableColumn.Expression Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the expression to use to automatically populate the rows of this column.

Visual Basic
Property Expression() As VARIANT
Remarks

This property can return or take as input a String, an ExpressionLimits object, or Nothing in the case where not expression is defined.

String expressions can contain expressions like you would use to define the value of a parameter and they can also contain the values of other columns. To use the values of other columns enclose the internal name within braces. Here are some examples of valid expression strings.

20 in

{SIZE}

{TOTAL_LENGTH} ' {HEAD_HEIGHT}

{DIA} / 2

An ExpressionLimits object is used to define the valid range of values when the user enters a value for this column during the creation of a member.

Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.Expression Property


ContentTableColumn.HasPropertyMap Property

ContentTableColumn.HasPropertyMap Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if this column is mapped to an iProperty.

Visual Basic
Property HasPropertyMap() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.HasPropertyMap Property


ContentTableColumn.InternalName Property

ContentTableColumn.InternalName Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the name of this column.

Visual Basic
Property InternalName() As BSTR*
Remarks

This is the internal name of the column that remains consistent not matter what language is currently being used. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.InternalName Property


ContentTableColumn.KeyColumnOrder Property

ContentTableColumn.KeyColumnOrder Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that specifies if this column is a key column and what order this column should be in the key column list. The key columns are displayed on the Select tab when placing a content part. The Filename and Designation columns do not support key ordering and this property will fail if you attempt to set their order.

Visual Basic
Property KeyColumnOrder() As long
Remarks

A value of 0 indicates this is not a key column. A value of 1 to 9 indicates it is a key column and it's position relative to the other columns in the list. There is a limit of 9 key columns. Assigning a key column value that is already used by another column will assign the value to the specified column and shift the other columns up. For example if there are already columns 1, 2, 3, 4 and you assign another column to be 3, the existing column 3 will become column 4 and column 4 will become column 5. In this case, if you assign a column to be column 9 it will be assigned column 6 since that is the highest column in the list. If there are 9 columns defined as key columns and you assign another column to be a key column the current column 9 will be no longer be a key column.

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.KeyColumnOrder Property


ContentTableColumn.Parent Property

ContentTableColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ContentFamily object this column is associated with.

Visual Basic
Property Parent() As ContentFamily**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.Parent Property


ContentTableColumn.Type Property

ContentTableColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.Type Property


ContentTableColumn.Units Property

ContentTableColumn.Units Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that allows you to get and set the units of the column.

Visual Basic
Property Units() As VARIANT
Remarks

This property is only valid in the case where the DataType property returns kIntegerType or kDoubleType. In other cases this property will return an empty String and will fail if set.

The units will always be returned as a string. When setting the units you can use either a string defining a valid unit or an item from the UnitTypeConstants enum.

Any changes to the table are not actually applied until the ContentFamily.Save method is called.

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumn Interface > ContentTableColumn Properties > ContentTableColumn.Units Property


ContentTableColumns Interface

ContentTableColumns Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentTableColumns object is a collection that provides access to the columns of the table associated with a particular content center family.

Class Hierarchy
Inventor::ContentTableColumns
Visual Basic
Public Interface ContentTableColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentFamily.TableColumns

See Also

Create a Configuration Table sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface


ContentTableColumns Methods

ContentTableColumns Methods
Summary

The methods of the ContentTableColumns class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new column. Any changes to the table are not actually applied until the Save method of the parent ContentFamily object is called.
CreateExpressionLimits | Method that creates an ExpressionLimits object. This object can be used to define the limits of a custom expression associated with a table column.
Item | Property that returns the specified ContentTableColumn object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Methods


ContentTableColumns.Add Method

ContentTableColumns.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new column. Any changes to the table are not actually applied until the Save method of the parent ContentFamily object is called.

Visual Basic
Sub Add(InternalName As String, DisplayHeading As String, DataType As ValueTypeEnum, ByRef Units As [optional] VARIANT, ByRef Expression As [optional] VARIANT, ByRef PropertySetId As [optional] VARIANT, ByRef PropertyIdentifier As [optional] VARIANT, Result As [out, retval] ContentTableColumn*)
Parameters
Parameters
Description
InternalName
Input String that specifies the internal name of this column.
DisplayHeading
Input String that specifies the display name of this column. This is the name of the column that the end-user sees within the user interface.
DataType
Input value from ValueTypeEnum that specifies the type of data within this column. Valid values are: kIntegerType, kDoubleType, kStringType, and kBooleanType.
Units
Input value that specifies the type of unit the values in the column are. The unit type needs to be specified if the DataType argument is kIntegerType or kDoubleType. For kStringType and kBooleanType this argument is ignored.
You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in".
Expression
Optional input Variant that specifies the expression to use to automatically populate the rows of this column. Not supplying this argument or providing an empty String will result in the default value of '1' being used.
There are two things that can be defined for the expression, a standard expression and limits for a custom expression. These are defined below.
Standard Expression ' This allows you to define an expression and will evaluate it to populate the rows of the table. Expressions can contain expression like you would use to define the value of a parameter and they can also contain the values of other columns. To use the values of other columns enclose the internal name within braces. Here are some examples of valid expression strings.
20 in
{SIZE}
{TOTAL_LENGTH} ' {HEAD_HEIGHT}
{DIA} / 2
Custom Expression Limits' A custom expression allows the end-user to specify the value when placing the member into an assembly. You can choose to define the limits for this value, i.e. minimum, maximum, increment and default values. These rules are defined using an ExpressionLimits object. You can create this object using the ContentTableColumn.CreateExpressionLimits method.
PropertySetId
Optional input String that specifies the name of the property set that contains the property. This is the InternalName or Name associated with the property set. If this argument is set you must also set the PropertyIdentifier argument to fully define the property to use.
PropertyIdentifier
Optional input Variant that identifies a property. This can be a Long value that specifies the PropId or the name of a property. If this argument is set you must also set the PropertySetId argument to fully define the property to use.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Methods > ContentTableColumns.Add Method


ContentTableColumns.CreateExpressionLimits Method

ContentTableColumns.CreateExpressionLimits Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates an ExpressionLimits object. This object can be used to define the limits of a custom expression associated with a table column.

Visual Basic
Sub CreateExpressionLimits(Result As [out, retval] ExpressionLimits*)
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Methods > ContentTableColumns.CreateExpressionLimits Method


ContentTableColumns.Item Method

ContentTableColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified ContentTableColumn object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ContentTableColumn*)
Parameters
Parameters | Description
Index | Input value that specifies the ContentTableColumn object within the collection to return. Valid input is a Long to specify the index of the item within the collection where the first column has an index of 1. A String containing the name of the column can also be used; either the Name or DisplayHeading value can be used.
See Also

Create a Configuration Table sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Methods > ContentTableColumns.Item Method


ContentTableColumns Properties

ContentTableColumns Properties
Summary

The properties of the ContentTableColumns class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of ContentTableColumn objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Properties


ContentTableColumns.Application Property

ContentTableColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Properties > ContentTableColumns.Application Property


ContentTableColumns.Count Property

ContentTableColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of ContentTableColumn objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Properties > ContentTableColumns.Count Property


ContentTableColumns.Type Property

ContentTableColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableColumns Interface > ContentTableColumns Properties > ContentTableColumns.Type Property


ContentTableRow Interface

ContentTableRow Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentTableRow object represents the row of the table associated with a particular content center family.

Class Hierarchy
Inventor::ContentTableRow
Visual Basic
Public Interface ContentTableRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentTableRows.Add

ContentTableRows.Item

You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface


ContentTableRow Methods

ContentTableRow Methods
Summary

The methods of the ContentTableRow class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this row from the table. Any changes to the table are not actually applied until the ContentFamily.Save method is called.
GetCellValue | This method returns value of cell specified by given index. Caller can specify particular custom parameters which will be used for expression evaluation.
Item | Returns the specified ContentTableCell object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Methods


ContentTableRow.Delete Method

ContentTableRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes this row from the table. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Methods > ContentTableRow.Delete Method


ContentTableRow.GetCellValue Method

ContentTableRow.GetCellValue Method
Summary

This method returns value of cell specified by given index. Caller can specify particular custom parameters which will be used for expression evaluation.

Visual Basic
Sub GetCellValue(CellIndex As VARIANT, ByRef CustomInput As [optional] VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
CellIndex | Input Variant value that specifies the ContentTableCell object within the collection to return. Valid index values are 1 to the value of Count, ContentTableColumn object or column internal name.
CustomInput | Optional input NameValueMap that specifies the input to use for the custom input. If the family is custom and this is not supplied, the default values for custom values are used. For each input value you use the NameValueMap to specify the Column ID as the name and the custom value as the new value . If the factory is not a custom factory this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Methods > ContentTableRow.GetCellValue Method


ContentTableRow.Item Method

ContentTableRow.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns the specified ContentTableCell object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ContentTableCell*)
Parameters
Parameters | Description
Index | Value that specifies the ContentTableCell object within the collection to return. Valid index values are 1 to the value of Count or a ContentTableColumn object.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Methods > ContentTableRow.Item Method


ContentTableRow Properties

ContentTableRow Properties
Summary

The properties of the ContentTableRow class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ContentIdentifier | Property that returns the identifier for this object. This can be used with the GetContentObject method of the ContentCenter object to obtain this object at a later time.
Count | Property that returns the number of ContentTableCell objects in the collection.
Index | Property that returns the index of this row within the table.
InternalName | Property that returns the internal name of the ContentTableRow. The internal name uniquely identifies this row with respect to other rows in the family and it cannot be changed so it will remain consistent.
IsSuppressed | Property that gets and sets the suppressed state of this row.
Parent | Property that returns the parent ContentFamily object.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties


ContentTableRow.Application Property

ContentTableRow.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.Application Property


ContentTableRow.ContentIdentifier Property

ContentTableRow.ContentIdentifier Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the identifier for this object. This can be used with the GetContentObject method of the ContentCenter object to obtain this object at a later time.

Visual Basic
Property ContentIdentifier() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.ContentIdentifier Property


ContentTableRow.Count Property

ContentTableRow.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of ContentTableCell objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.Count Property


ContentTableRow.Index Property

ContentTableRow.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this row within the table.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.Index Property


ContentTableRow.InternalName Property

ContentTableRow.InternalName Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the internal name of the ContentTableRow. The internal name uniquely identifies this row with respect to other rows in the family and it cannot be changed so it will remain consistent.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.InternalName Property


ContentTableRow.IsSuppressed Property

ContentTableRow.IsSuppressed Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the suppressed state of this row.

Visual Basic
Property IsSuppressed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.IsSuppressed Property


ContentTableRow.Parent Property

ContentTableRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent ContentFamily object.

Visual Basic
Property Parent() As ContentFamily**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.Parent Property


ContentTableRow.Type Property

ContentTableRow.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRow Interface > ContentTableRow Properties > ContentTableRow.Type Property


ContentTableRows Interface

ContentTableRows Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentTableRows object is a collection that provides access to the rows of the table associated with a particular content center family.

Class Hierarchy
Inventor::ContentTableRows
Visual Basic
Public Interface ContentTableRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentFamily.TableRows

See Also

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface


ContentTableRows Methods

ContentTableRows Methods
Summary

The methods of the ContentTableRows class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new row. Any changes to the table are not actually applied until the ContentFamily.Save method is called.
Item | Property that returns the specified ContentTableRow object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Methods


ContentTableRows.Add Method

ContentTableRows.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new row. Any changes to the table are not actually applied until the ContentFamily.Save method is called.

Visual Basic
Sub Add(ByRef RowData As SAFEARRAY(BSTR), ByRef Position As [defaultvalue(-1)] long, Result As [out, retval] ContentTableRow*)
Parameters
Parameters | Description
RowData | Input String array that contains the new values for the row. The array should be the same size as the number of columns and the values are defined in the same order as the column order.
Position | Optional input Long that defines the position within the table where the new row should be created. If this argument is not supplied or is out of range the row will be created at the end of the table.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Methods > ContentTableRows.Add Method


ContentTableRows.Item Method

ContentTableRows.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified ContentTableRow object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ContentTableRow*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the ContentTableRow object within the collection to return. Valid index values are a Long indicating the index of the row where index 1 is the first row or a String where the value is the internal name of the ContentTableRow.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Methods > ContentTableRows.Item Method


ContentTableRows Properties

ContentTableRows Properties
Summary

The properties of the ContentTableRows class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of ContentTableRow objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Properties


ContentTableRows.Application Property

ContentTableRows.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Properties > ContentTableRows.Application Property


ContentTableRows.Count Property

ContentTableRows.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of ContentTableRow objects in the collection.

Visual Basic
Property Count() As long*
See Also

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Properties > ContentTableRows.Count Property


ContentTableRows.Type Property

ContentTableRows.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTableRows Interface > ContentTableRows Properties > ContentTableRows.Type Property


ContentTreeViewNode Interface

ContentTreeViewNode Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentTreeViewNode object represents nodes within the Content Center tree structure.

Class Hierarchy
Inventor::ContentTreeViewNode
Visual Basic
Public Interface ContentTreeViewNode
Inherits IDispatch
Remarks

The nodes provide structure for the various content categories and provide access to their associated families. This is illustrated in the picture below. The nodes in the tree shown in the category view are accessible as ContentTreeViewNode objects. Each node can have child nodes and/or families associated with it.

Notes

Members through which this object may be accessed include:

ContentCenter.TreeViewTopNode

ContentTreeViewNode.ParentNode

ContentTreeViewNodesEnumerator.Item

See Also

Place content center part sample

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface


ContentTreeViewNode Properties

ContentTreeViewNode Properties
Summary

The properties of the ContentTreeViewNode class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ChildNodes | Property that returns a collection containing the child ContentTreeViewNode objects of this node.
DisplayName | Property that returns the display name of this node. This is the name that the end-user sees and is localized for different languages.
Families | Property that returns the set of families associated with this node. The collection returned may have a count of zero indicating there aren't any families associated with this node.
FullTreeViewPath | Property that provides the full path in the tree view for this node. For example, this can return 'Fasteners:Bolts:Countersunk:Oval Countersunk Head Metric Machine Screws' where a colon is used as the delimiter.
Icon | Property that returns the icon used for this node.
InternalName | Property that returns the internal name of this node. This will be consistent regardless of the language version of Inventor.
ParentNode | Property that returns the parent ContentTreeViewNode object. This property will return Nothing for the top node.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties


ContentTreeViewNode.Application Property

ContentTreeViewNode.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.Application Property


ContentTreeViewNode.ChildNodes Property

ContentTreeViewNode.ChildNodes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a collection containing the child ContentTreeViewNode objects of this node.

Visual Basic
Property ChildNodes() As ContentTreeViewNodesEnumerator**
See Also

Place content center part sample

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.ChildNodes Property


ContentTreeViewNode.DisplayName Property

ContentTreeViewNode.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the display name of this node. This is the name that the end-user sees and is localized for different languages.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.DisplayName Property


ContentTreeViewNode.Families Property

ContentTreeViewNode.Families Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the set of families associated with this node. The collection returned may have a count of zero indicating there aren't any families associated with this node.

Visual Basic
Property Families() As ContentFamiliesEnumerator**
See Also

Replace content center part sample

Example

Place content center part example.

This sample demonstrates how to place an instance of a Content Center part into an assembly.

Sub PlaceContentCenterPart()

    ' Set a reference to the active assembly document.
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the ContentCenter object.
    Dim oContentCenter As ContentCenter
    Set oContentCenter = ThisApplication.ContentCenter

    ' Get the content node (category) "Fasteners:Bolts:Hex Head"
    Dim oContentNode As ContentTreeViewNode
    Set oContentNode = oContentCenter.TreeViewTopNode.ChildNodes.Item("Fasteners").ChildNodes.Item("Bolts").ChildNodes.Item("Hex Head")

    ' Get the "ISO 4015" Family object.
    Dim oFamily As ContentFamily
    For Each oFamily In oContentNode.Families
        If oFamily.DisplayName = "ISO 4015" Then
            Exit For
        End If
    Next

    ' Create a member based on the first row of the family.
    Dim error As MemberManagerErrorsEnum
    Dim strContentPartFileName As String
    Dim strErrorMessage As String
    strContentPartFileName = oFamily.CreateMember(1, error, strErrorMessage)

    Dim oMat As Matrix
    Set oMat = ThisApplication.TransientGeometry.CreateMatrix

    ' Insert an instance of the content center member in the assembly.
    Call oDoc.ComponentDefinition.Occurrences.Add(strContentPartFileName, oMat)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.Families Property


ContentTreeViewNode.FullTreeViewPath Property

ContentTreeViewNode.FullTreeViewPath Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that provides the full path in the tree view for this node. For example, this can return 'Fasteners:Bolts:Countersunk:Oval Countersunk Head Metric Machine Screws' where a colon is used as the delimiter.

Visual Basic
Property FullTreeViewPath() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.FullTreeViewPath Property


ContentTreeViewNode.Icon Property

ContentTreeViewNode.Icon Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the icon used for this node.

Visual Basic
Property Icon() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.Icon Property


ContentTreeViewNode.InternalName Property

ContentTreeViewNode.InternalName Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the internal name of this node. This will be consistent regardless of the language version of Inventor.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.InternalName Property


ContentTreeViewNode.ParentNode Property

ContentTreeViewNode.ParentNode Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent ContentTreeViewNode object. This property will return Nothing for the top node.

Visual Basic
Property ParentNode() As ContentTreeViewNode**
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.ParentNode Property


ContentTreeViewNode.Type Property

ContentTreeViewNode.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNode Interface > ContentTreeViewNode Properties > ContentTreeViewNode.Type Property


ContentTreeViewNodesEnumerator Interface

ContentTreeViewNodesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContentFamiliesEnumerator is a collection object that provides access to a group of ContentFamily objects.

Class Hierarchy
Inventor::ContentTreeViewNodesEnumerator
Visual Basic
Public Interface ContentTreeViewNodesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentTreeViewNode.ChildNodes

You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface


ContentTreeViewNodesEnumerator Methods

ContentTreeViewNodesEnumerator Methods
Summary

The methods of the ContentTreeViewNodesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified ContentTreeViewNode object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface > ContentTreeViewNodesEnumerator Methods


ContentTreeViewNodesEnumerator.Item Method

ContentTreeViewNodesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified ContentTreeViewNode object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ContentTreeViewNode*)
Parameters
Parameters | Description
Index | Input Long or String that that specifies the ContentTreeViewNode object within the collection to return. A Long indicates the index of the item within the collection to return. A String indicates the name of the node to return. You can use either the display or internal name. In the case where there are two nodes with the same name the first node will be returned.
See Also

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface > ContentTreeViewNodesEnumerator Methods > ContentTreeViewNodesEnumerator.Item Method


ContentTreeViewNodesEnumerator Properties

ContentTreeViewNodesEnumerator Properties
Summary

The properties of the ContentTreeViewNodesEnumerator class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of ContentTreeViewNode objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface > ContentTreeViewNodesEnumerator Properties


ContentTreeViewNodesEnumerator.Application Property

ContentTreeViewNodesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface > ContentTreeViewNodesEnumerator Properties > ContentTreeViewNodesEnumerator.Application Property


ContentTreeViewNodesEnumerator.Count Property

ContentTreeViewNodesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of ContentTreeViewNode objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface > ContentTreeViewNodesEnumerator Properties > ContentTreeViewNodesEnumerator.Count Property


ContentTreeViewNodesEnumerator.Type Property

ContentTreeViewNodesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContentTreeViewNodesEnumerator Interface > ContentTreeViewNodesEnumerator Properties > ContentTreeViewNodesEnumerator.Type Property


ContourFlangeDefinition Interface

ContourFlangeDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The ContourFlangeDefinition object represents all of the information that defines a contour flange feature.

Class Hierarchy
Inventor::ContourFlangeDefinition
Visual Basic
Public Interface ContourFlangeDefinition
Inherits IDispatch
Remarks

The ContourFlangeDefinition object is used in two ways. First it is used as input when creating contour flange feature. Second it is used to query and edit existing contour flange features. When creating a new contour flange feature you use the ContourFlangeFeatures.CreateContourFlangeDefinition method to create a new ContourFlangeDefinition object. Using the properties of this object you can define the various options of the contour flange feature. Typically a new ContourFlangeDefinition object is created and then modified to get the desired contour flange feature and then used as input to the ContourFlangeFeatures.Add method. An existing ContourFlangeFeature object is edited by modifying its associated ContourFlangeDefinition object.

Notes

Members through which this object may be accessed include:

ContourFlangeDefinition.Copy

ContourFlangeFeature.Definition

ContourFlangeFeatures.CreateContourFlangeDefinition

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface


ContourFlangeDefinition Methods

ContourFlangeDefinition Methods
Summary

The methods of the ContourFlangeDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this ContourFlangeDefinition object.
GetWidthExtent | Property that returns the PartFeatureExtent object that defines how the width extent of the specified physical contour flange is defined.
GetWidthExtentType | Property that returns the method used to define the width extent. The valid values for this property are kWidthEdgeExtent, kWidthWidthExtent, kWidthOffsetExtent, and kWidthFromToExtent.
SetCenteredDefaultWidthExtent | Method that sets the default width extent to define a contour flange that"s centered along the edge and has a defined width.
SetCenteredWidthExtent | Method that changes the ContourFlangeDefinition object to define a contour flange that's centered along the edge and has a defined width.
SetDistanceExtent | Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined by a distance from the input Profile.
SetEdgeDefaultWidthExtent | Method that sets the default width extent to define a contour flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the contour flanges.
SetEdgeWidthExtent | Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the contour flanges.
SetFromToDefaultWidthExtent | Method that sets the default width extent to define a contour flange whose width is defined as being between two entities.
SetFromToWidthExtent | Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined as being between two entities.
SetOffsetDefaultWidthExtent | Method that sets the default width extent to define a contor flange whose width is defined with respect to two entities.
SetOffsetWidthExtent | Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined with respect to two entities.
SetWidthOffsetDefaultWidthExtent | Method that sets the default width extent for the contor flange feature to define a contour flange whose width is defined relative to another entity.
SetWidthOffsetWidthExtent | Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined relative to another entity.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods


ContourFlangeDefinition.Copy Method

ContourFlangeDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a copy of this ContourFlangeDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] ContourFlangeDefinition*)
Remarks

The new ContourFlangeDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new contour flange feature.

Any of the properties of the ContourFlangeDefinition that can reference a Parameter object will behave differently depending on if the ContourFlangeDefinition is independent or associated with a feature. When it is associated with a feature these properties behave as read-only and will return the related Parameter object. When it is not associated with a feature these properties behave as read-write and will accept and return doubles and strings to define the value.

One typical use of this method is when you need to make several changes to an existing contour flange feature. If you edit the ContourFlangeDefinition object associated with the contour flange feature, the feature will recompute after each edit. It's more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The ContourFlangeFeatures.CreateContourFlangeDefinition method can also be used to create an independent ContourFlangeDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateContourFlangeDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.Copy Method


ContourFlangeDefinition.GetWidthExtent Method

ContourFlangeDefinition.GetWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the PartFeatureExtent object that defines how the width extent of the specified physical contour flange is defined.

Visual Basic
Sub GetWidthExtent(Edge As Edge, Result As [out, retval] PartFeatureExtent*)
Parameters
Parameters | Description
Edge | The Edge object that identifies the physical contour flange to return the width extent for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to return the width extent for.
Remarks

The type of extent object that this property will return can be determined by using the WidthExtentType property. Types that can be returned are EdgeWidthExtent, WidthWidthExtent, OffsetWidthExtent, and FromToWidthExtent. The extent can be defined by default width extent of the feature or an override for this particular physical contour flange. You can determine if it is an override or not by using the GetWidthExtentType property.

When the ContourFlangeDefinition object is transient, (created using the ContourFlangeFeatures.CreateContourFlangeDefinition method or the Copy method of an existing ContourFlangeDefinition object), this property will return Nothing. The ContourFlangeDefinition still defines the width extent but its details are not accessible through this property. You can determine the type of width extent by using the WidthExtentType property and can set the width type using one of the various Set methods.

If the contour flange already exists you must roll back the model to the point just before the contour flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.GetWidthExtent Method


ContourFlangeDefinition.GetWidthExtentType Method

ContourFlangeDefinition.GetWidthExtentType Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the method used to define the width extent. The valid values for this property are kWidthEdgeExtent, kWidthWidthExtent, kWidthOffsetExtent, and kWidthFromToExtent.

Visual Basic
Sub GetWidthExtentType(Edge As Edge, ByRef HasOverride As VARIANT_BOOL, Result As [out, retval] PartFeatureExtentEnum)
Parameters
Parameters | Description
Edge | The Edge object that identifies the physical contour flange to return the width extent type for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to return the width extent type for.
HasOverride | Output value that indicates if the width extent is an override extent or not. A value of True indicates that an override exists. A value of False indicates that the default width extent of the Flange feature is being used for this physical flange.
Remarks

If the contour flange already exists you must roll back the model to the point just before the contour flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.GetWidthExtentType Method


ContourFlangeDefinition.SetCenteredDefaultWidthExtent Method

ContourFlangeDefinition.SetCenteredDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a contour flange that"s centered along the edge and has a defined width.

Visual Basic
Sub SetCenteredDefaultWidthExtent(Width As VARIANT)
Parameters
Parameters | Description
Width | Input Variant that defines the distance used for the width extent of the contour flange. This value is used to define that distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetCenteredDefaultWidthExtent Method


ContourFlangeDefinition.SetCenteredWidthExtent Method

ContourFlangeDefinition.SetCenteredWidthExtent Method
Summary

Method that changes the ContourFlangeDefinition object to define a contour flange that's centered along the edge and has a defined width.

Visual Basic
Sub SetCenteredWidthExtent(Edge As Edge, Width As VARIANT)
Parameters
Parameters | Description
Edge | The Edge that identifies which physical contour flange to set the width extent for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to set the width extent for.
Width | Input Variant that defines the distance used for the width extent of the contour flange. This value is used to define that distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

If the contour flange already exists you must roll back the model to the point just before the contour flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetCenteredWidthExtent Method


ContourFlangeDefinition.SetDistanceExtent Method

ContourFlangeDefinition.SetDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined by a distance from the input Profile.

Visual Basic
Sub SetDistanceExtent(Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Distance | Defines the length of the extrusion. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Constant that indicates which side of the sketch plane to exend the flange to. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetDistanceExtent Method


ContourFlangeDefinition.SetEdgeDefaultWidthExtent Method

ContourFlangeDefinition.SetEdgeDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a contour flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the contour flanges.

Visual Basic
Sub SetEdgeDefaultWidthExtent()
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetEdgeDefaultWidthExtent Method


ContourFlangeDefinition.SetEdgeWidthExtent Method

ContourFlangeDefinition.SetEdgeWidthExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the contour flanges.

Visual Basic
Sub SetEdgeWidthExtent(Edge As Edge)
Parameters
Parameters | Description
Edge | he Edge that identifies which physical contour flange to set the width extent for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to set the width extent for.
Remarks

If the contour flange already exists you must roll back the model to the point just before the contour flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetEdgeWidthExtent Method


ContourFlangeDefinition.SetFromToDefaultWidthExtent Method

ContourFlangeDefinition.SetFromToDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a contour flange whose width is defined as being between two entities.

Visual Basic
Sub SetFromToDefaultWidthExtent(FromEntity As IDispatch, ToEntity As IDispatch)
Parameters
Parameters | Description
FromEntity | Input Object that defines the "from" extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
ToEntity | Input Object that defines the "to" extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetFromToDefaultWidthExtent Method


ContourFlangeDefinition.SetFromToWidthExtent Method

ContourFlangeDefinition.SetFromToWidthExtent Method
Summary

Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined as being between two entities.

Visual Basic
Sub SetFromToWidthExtent(Edge As Edge, FromEntity As IDispatch, ToEntity As IDispatch)
Parameters
Parameters | Description
Edge | The Edge that identifies which physical contour flange to set the width extent for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to set the width extent for.
FromEntity | Input Object that defines the 'from' extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
ToEntity | Input Object that defines the 'to' extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
Remarks

If the contour flange already exists you must roll back the model to the point just before the contour flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetFromToWidthExtent Method


ContourFlangeDefinition.SetOffsetDefaultWidthExtent Method

ContourFlangeDefinition.SetOffsetDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a contor flange whose width is defined with respect to two entities.

Visual Basic
Sub SetOffsetDefaultWidthExtent(OffsetEntityOne As IDispatch, OffsetDistanceOne As VARIANT, OffsetEntityTwo As IDispatch, OffsetDistanceTwo As VARIANT)
Parameters
Parameters | Description
OffsetEntityOne | Input Object that defines the first entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceOne | Input Variant that defines the distance of the contour flange from offset entity one. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntityTwo | Input Object that defines the second entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceTwo | Input Variant that defines the distance of the contour flange from offset entity two. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetOffsetDefaultWidthExtent Method


ContourFlangeDefinition.SetOffsetWidthExtent Method

ContourFlangeDefinition.SetOffsetWidthExtent Method
Summary

Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined with respect to two entities.

Visual Basic
Sub SetOffsetWidthExtent(Edge As Edge, OffsetEntityOne As IDispatch, OffsetDistanceOne As VARIANT, OffsetEntityTwo As IDispatch, OffsetDistanceTwo As VARIANT)
Parameters
Parameters | Description
Edge | The Edge that identifies which physical contour flange to set the width extent for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to set the width extent for.
OffsetEntityOne | Input Object that defines the first entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceOne | Input Variant that defines the distance of the contour flange from offset entity one. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntityTwo | Input Object that defines the second entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceTwo | Input Variant that defines the distance of the contour flange from offset entity two. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetOffsetWidthExtent Method


ContourFlangeDefinition.SetWidthOffsetDefaultWidthExtent Method

ContourFlangeDefinition.SetWidthOffsetDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent for the contor flange feature to define a contour flange whose width is defined relative to another entity.

Visual Basic
Sub SetWidthOffsetDefaultWidthExtent(Width As VARIANT, OffsetDistance As VARIANT, OffsetEntity As IDispatch, PositiveDirection As VARIANT_BOOL)
Parameters
Parameters | Description
Width | Input Variant that defines the distance to use for the width extent of the contour flange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetDistance | Input Variant that defines the distance of the contour flange from the offset entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntity | Input Object that defines the entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
PositiveDirection | Input Boolean that specifies the side of the offset entity the contour flange is on.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetWidthOffsetDefaultWidthExtent Method


ContourFlangeDefinition.SetWidthOffsetWidthExtent Method

ContourFlangeDefinition.SetWidthOffsetWidthExtent Method
Summary

Method that changes the ContourFlangeDefinition object to define a contour flange whose width is defined relative to another entity.

Visual Basic
Sub SetWidthOffsetWidthExtent(Edge As Edge, Width As VARIANT, OffsetDistance As VARIANT, OffsetEntity As IDispatch, PositiveDirection As VARIANT_BOOL)
Parameters
Parameters | Description
Edge | The Edge that identifies which physical contour flange to set the width extent for. The creation of a single contour flange feature can result in many physical contour flanges being added to the part. Each edge specified for the contour flange feature wll result in a physical contour flange. The edge specified as input to this argument must be one of the edges that was specified as input to the contour flange feature and defines which physical contour flange to set the width extent for.
Width | Input Variant that defines the distance to use for the width extent of the contour flange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetDistance | Input Variant that defines the distance of the contour flange from the offset entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntity | Input Object that defines the entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
PositiveDirection | Input Boolean that specifies the side of the offset entity the contour flange is on.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Methods > ContourFlangeDefinition.SetWidthOffsetWidthExtent Method


ContourFlangeDefinition Properties

ContourFlangeDefinition Properties
Summary

The properties of the ContourFlangeDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ApplyAutoMitering | Property that defines if auto mitering should be performed.
BendOptions | Property that gets and sets the bend options associated with this contour flange feature.
BendRadius | Property that provides access to the bend radius of a contour flange feature.
CornerOptions | Property that gets and sets the CornerOptions object that defines how the corners of the contour flange are modeled.
DefaultWidthExtent | Property that returns the PartFeatureExtent object that defines how the width extent of the contour flange feature is defined.
DefaultWidthExtentType | Property that returns the method used to define the width extent.
Edges | Property that gets and set the EdgeCollection object that contains the edges that are used to define the contour flange feature. When querying an existing contour flange the originally selected edges are not available because they were consumed when the contour flange feature was created. To access these edges the end-of-part marker must be placed above the contour flange feature.
ExtendFaces | Property that specifies if the existing faces will be extended to the bend or if a perpendicular section should be created to connect to the bend.
ExtentDirection | Gets the extent direction which indicates which side of the sketch the projection of the flange is in.
IsUnfoldMethodOverridden | Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.
MiterGap | Property that provides access to the miter gap size of the contour flange feature.
Parent | Property that returns the parent ContourFlangeFeature of this ContourFlangeDefinition object.
Path | Property that gets and sets the Path object that defines the shape of the contour flange. The path can be changed in two ways. The first is to modify the geometry of the path. This will cause the profile to automatically update. The second is to create an entirely new path and use it to replace the existing path.
Type | Returns an ObjectTypeEnum indicating this object's type.
UnfoldMethod | Property that gets and set the UnfoldMethod object that defines how the bends associated with this contour flange feature are unfolded.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties


ContourFlangeDefinition.Application Property

ContourFlangeDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.Application Property


ContourFlangeDefinition.ApplyAutoMitering Property

ContourFlangeDefinition.ApplyAutoMitering Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that defines if auto mitering should be performed.

Visual Basic
Property ApplyAutoMitering() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.ApplyAutoMitering Property


ContourFlangeDefinition.BendOptions Property

ContourFlangeDefinition.BendOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the bend options associated with this contour flange feature.

Visual Basic
Property BendOptions() As BendOptions*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.BendOptions Property


ContourFlangeDefinition.BendRadius Property

ContourFlangeDefinition.BendRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend radius of a contour flange feature.

Visual Basic
Property BendRadius() As VARIANT
Remarks

This property is writable when the ContourFlangeDefinition object has been created using the ContourFlangeFeatures.CreateContourFlangeDefinition or ContourFlangeDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendRadius * 2' is valid, assuming there is a parameter named MyBendRadius.

When the ContourFlangeDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend radius. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.BendRadius Property


ContourFlangeDefinition.CornerOptions Property

ContourFlangeDefinition.CornerOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the CornerOptions object that defines how the corners of the contour flange are modeled.

Visual Basic
Property CornerOptions() As CornerOptions*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.CornerOptions Property


ContourFlangeDefinition.DefaultWidthExtent Property

ContourFlangeDefinition.DefaultWidthExtent Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the PartFeatureExtent object that defines how the width extent of the contour flange feature is defined.

Visual Basic
Property DefaultWidthExtent() As PartFeatureExtent**
Remarks

The type of extent object that this property will return can be determined by using the WidthExtentType property. Types that can be returned are CenteredWidthExtent, EdgeWidthExtent, FromToWidthExtent, OffsetWidthExtent, and WidthOffsetWidthExtent.

When the ContourFlangeDefinition object is transient, (created using the ContourFlangeFeatures.CreateContourFlangeDefinition method or the Copy method of an existing ContourFlangeDefinition object), this property will return Nothing. The ContourFlangeDefinition still defines the width extent but its details are not accessible through this property. You can determine the type of width extent by using the WidthExtentType property and can set the width type using one of the various Set methods.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.DefaultWidthExtent Property


ContourFlangeDefinition.DefaultWidthExtentType Property

ContourFlangeDefinition.DefaultWidthExtentType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the method used to define the width extent.

Visual Basic
Property DefaultWidthExtentType() As PartFeatureExtentEnum*
Remarks

The default width extent is applied to all physical contour flanges in this contour flange feature that do not have a width extent override. The valid values for this property are kWidthEdgeExtent, kWidthWidthExtent, kWidthOffsetExtent, and kWidthFromToExtent.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.DefaultWidthExtentType Property


ContourFlangeDefinition.Edges Property

ContourFlangeDefinition.Edges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the EdgeCollection object that contains the edges that are used to define the contour flange feature. When querying an existing contour flange the originally selected edges are not available because they were consumed when the contour flange feature was created. To access these edges the end-of-part marker must be placed above the contour flange feature.

Visual Basic
Property Edges() As EdgeCollection*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.Edges Property


ContourFlangeDefinition.ExtendFaces Property

ContourFlangeDefinition.ExtendFaces Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies if the existing faces will be extended to the bend or if a perpendicular section should be created to connect to the bend.

Visual Basic
Property ExtendFaces() As VARIANT_BOOL
Remarks

A value of True indicates the existing faces will be extended. When a new ContourFlangeDefinition object is created this property is initialized to False.

The pictures below illustrate the two results obtained with this option. The picture on the left illustrates the result when ExtendFaces is False. The original faces are left intact and the bend is extended to meet the face. In the picture on the right, the face is extended to meet the face.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.ExtendFaces Property


ContourFlangeDefinition.ExtentDirection Property

ContourFlangeDefinition.ExtentDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the extent direction which indicates which side of the sketch the projection of the flange is in.

Visual Basic
Property ExtentDirection() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.ExtentDirection Property


ContourFlangeDefinition.IsUnfoldMethodOverridden Property

ContourFlangeDefinition.IsUnfoldMethodOverridden Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.

Visual Basic
Property IsUnfoldMethodOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.IsUnfoldMethodOverridden Property


ContourFlangeDefinition.MiterGap Property

ContourFlangeDefinition.MiterGap Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the miter gap size of the contour flange feature.

Visual Basic
Property MiterGap() As VARIANT
Remarks

This property is writable when the ContourFlangeDefinition object has been created using the CreateContourFlangeDefinition or ContourFlangeDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyMiterGap * 2' is valid, assuming there is a parameter named MyMiterGap.

When the ContourFlangeDefinition object has been obtained from an existing contour flange feature this property is read-only and returns the Parameter object that defines the miter gap size. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.MiterGap Property


ContourFlangeDefinition.Parent Property

ContourFlangeDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent ContourFlangeFeature of this ContourFlangeDefinition object.

Visual Basic
Property Parent() As ContourFlangeFeature**
Remarks

In the case where this is a newly created ContourFlangeDefinition object or it has been copied from an existing ContourFlangeDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.Parent Property


ContourFlangeDefinition.Path Property

ContourFlangeDefinition.Path Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the Path object that defines the shape of the contour flange. The path can be changed in two ways. The first is to modify the geometry of the path. This will cause the profile to automatically update. The second is to create an entirely new path and use it to replace the existing path.

Visual Basic
Property Path() As Path*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.Path Property


ContourFlangeDefinition.Type Property

ContourFlangeDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.Type Property


ContourFlangeDefinition.UnfoldMethod Property

ContourFlangeDefinition.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the UnfoldMethod object that defines how the bends associated with this contour flange feature are unfolded.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeDefinition Interface > ContourFlangeDefinition Properties > ContourFlangeDefinition.UnfoldMethod Property


ContourFlangeFeature Interface

ContourFlangeFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ContourFlangeFeature object represents a sheet metal contour flange feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::ContourFlangeFeature
        Inventor::ContourFlangeFeatureProxy
Visual Basic
Public Interface ContourFlangeFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ContourFlangeDefinition.Parent

ContourFlangeFeatures.Add

ContourFlangeFeatures.Item

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeature Interface


ContourFlangeFeature Properties

ContourFlangeFeature Properties
Summary

The properties of the ContourFlangeFeature class are listed here.

Properties
Name | Description
BendFeature | Property that returns the associated bend feature, if there is one.
Definition | Property that gets the ContourFlangeDefinition object associated with this fold feature.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeature Interface > ContourFlangeFeature Properties


ContourFlangeFeature.BendFeature Property

ContourFlangeFeature.BendFeature Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the associated bend feature, if there is one.

Visual Basic
Property BendFeature() As BendFeature**
Remarks

If there is not an associated bend feature, this property returns Nothing.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeature Interface > ContourFlangeFeature Properties > ContourFlangeFeature.BendFeature Property


ContourFlangeFeature.Definition Property

ContourFlangeFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the ContourFlangeDefinition object associated with this fold feature.

Visual Basic
Property Definition() As ContourFlangeDefinition**
Remarks

Modifying the ContourFlangeDefinition object will edit the associated ContourFlangeFeature.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeature Interface > ContourFlangeFeature Properties > ContourFlangeFeature.Definition Property


ContourFlangeFeatureProxy Interface

ContourFlangeFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ContourFlangeFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ContourFlangeFeature
        Inventor::ContourFlangeFeatureProxy
Visual Basic
Public Interface ContourFlangeFeatureProxy
Inherits ContourFlangeFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatureProxy Interface


ContourFlangeFeatures Interface

ContourFlangeFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ContourFlangeFeatures collection object provides access to the ContourFlangeFeature objects. It"s also through the ContourFlangeFeatures object that you create new ContourFlangeFeature objects.

Class Hierarchy
Inventor::ContourFlangeFeatures
Visual Basic
Public Interface ContourFlangeFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.ContourFlangeFeatures

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface


ContourFlangeFeatures Methods

ContourFlangeFeatures Methods
Summary

The methods of the ContourFlangeFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new contour flange feature. The newly created ContourFlangeFeature object is returned.
CreateContourFlangeDefinition | Method that creates a new ContourFlangeDefinition object.
Item | Property that returns the specified ContourFlangeFeature object from the collection. This is the default property of the ContourFlangeFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Methods


ContourFlangeFeatures.Add Method

ContourFlangeFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new contour flange feature. The newly created ContourFlangeFeature object is returned.

Visual Basic
Sub Add(ContourFlangeDefinition As ContourFlangeDefinition, Result As [out, retval] ContourFlangeFeature*)
Parameters
Parameters | Description
ContourFlangeDefinition | Input ContourFlangeDefinition object that defines the contour flange feature you want to create. A ContourFlangeDefinition object can be created using the ContourFlangeFeatures.CreateContourFlangeDefinition method. It can also be obtained from an existing ContourFlangeFeature object.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Methods > ContourFlangeFeatures.Add Method


ContourFlangeFeatures.CreateContourFlangeDefinition Method

ContourFlangeFeatures.CreateContourFlangeDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new ContourFlangeDefinition object.

Visual Basic
Sub CreateContourFlangeDefinition(Path As Path, ByRef Edges As [optional] VARIANT, Result As [out, retval] ContourFlangeDefinition*)
Parameters
Parameters | Description
Path | Input Path object that specifies the shape of the contour flange.
Edges | Optional input Object that specifies the edge(s) to create a contour flange feature on. This can be either an Edge object or an EdgeCollection containing at least one Edge object. If all of the edges of a Face are desired, it is up to you to obtain them from the Face and add them to the collection. Edges are not needed when a contour flange is created using a distance extent and this argument can be omitted in that case. You will need to call the SetDistanceExtent method to set the distance.
Remarks

The object created does not represent a contour flange feature but instead is a representation of the information that defines a contour flange feature. You can use this object as input to the CoutnourFlangeFeatures.Add method to create the actual contour flange feature.

The ContourFlangeDefinition object returned is fully defined and can be used to create a contour flange feature. However, defaults are used for most of the contour flange options so you may want to change some of the property values of the ContourFlangeDefinition object before using it to create a contour flange feature.

You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Methods > ContourFlangeFeatures.CreateContourFlangeDefinition Method


ContourFlangeFeatures.Item Method

ContourFlangeFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified ContourFlangeFeature object from the collection. This is the default property of the ContourFlangeFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ContourFlangeFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Methods > ContourFlangeFeatures.Item Method


ContourFlangeFeatures Properties

ContourFlangeFeatures Properties
Summary

The properties of the ContourFlangeFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Properties


ContourFlangeFeatures.Application Property

ContourFlangeFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Properties > ContourFlangeFeatures.Application Property


ContourFlangeFeatures.Count Property

ContourFlangeFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Properties > ContourFlangeFeatures.Count Property


ContourFlangeFeatures.Type Property

ContourFlangeFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContourFlangeFeatures Interface > ContourFlangeFeatures Properties > ContourFlangeFeatures.Type Property


ContourRollFeature Interface

ContourRollFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContourRollFeature object represents a contour roll sheet metal feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::ContourRollFeature
        Inventor::ContourRollFeatureProxy
Visual Basic
Public Interface ContourRollFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ContourRollFeatures.Item

Most functionality reserved for future implementation.

You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeature Interface


ContourRollFeatureProxy Interface

ContourRollFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ContourRollFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ContourRollFeature
        Inventor::ContourRollFeatureProxy
Visual Basic
Public Interface ContourRollFeatureProxy
Inherits ContourRollFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatureProxy Interface


ContourRollFeatures Interface

ContourRollFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ContourRollFeatures collection object provides access to the ContourRollFeature objects.

Class Hierarchy
Inventor::ContourRollFeatures
Visual Basic
Public Interface ContourRollFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.ContourRollFeatures

You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface


ContourRollFeatures Methods

ContourRollFeatures Methods
Summary

The methods of the ContourRollFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified ContourRollFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface > ContourRollFeatures Methods


ContourRollFeatures.Item Method

ContourRollFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified ContourRollFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ContourRollFeature*)
Parameters
Parameters | Description
Index | Input Long or String that specifies the ContourRollFeature object within the collection to return. Inputting a Long indicates the index of the ContourRollFeature within the collection to return. A String can also be used to specify the name of the feature. The property will fail is the index is out of range or the name does not exist.
You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface > ContourRollFeatures Methods > ContourRollFeatures.Item Method


ContourRollFeatures Properties

ContourRollFeatures Properties
Summary

The properties of the ContourRollFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of ContourRollFeature objects in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface > ContourRollFeatures Properties


ContourRollFeatures.Application Property

ContourRollFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface > ContourRollFeatures Properties > ContourRollFeatures.Application Property


ContourRollFeatures.Count Property

ContourRollFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of ContourRollFeature objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface > ContourRollFeatures Properties > ContourRollFeatures.Count Property


ContourRollFeatures.Type Property

ContourRollFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ContourRollFeatures Interface > ContourRollFeatures Properties > ContourRollFeatures.Type Property


ControlDefinition Interface

ControlDefinition Interface Available in Inventor Introduced in Inventor 6
Summary

The ControlDefinition object is the base class for all other command definition types. This includes the following objects: ButtonDefinition, ComboBoxDefinition, and MacroControlDefinition.

Class Hierarchy
Inventor::ControlDefinition
    Inventor::ButtonDefinitionObject
    Inventor::ComboBoxDefinitionObject
    Inventor::MacroControlDefinition
Visual Basic
Public Interface ControlDefinition
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ButtonDefinitionHandlerObject.ControlDefinition

CommandBarControl.ControlDefinition

CommandBarControl.DisplayedControl

CommandControl.ControlDefinition

CommandControl.DisplayedControl

ControlDefinitionEventsObject.Parent

ControlDefinitions.Item

DisabledCommandList.Item

DockableWindow.VisibilityControl

ProgressiveToolTip.Parent

CommandCategory.Item

See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Break alignment of a section view sample

Control Definitions (Inventor Command Names) sample

Copy a sketch sample

Copy a sketch sample

Add a button to the context menu sample

Example

See ControlDefinitions for example "ControlDefinitions Object"

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface


ControlDefinition Methods

ControlDefinition Methods
Summary

The methods of the ControlDefinition class are listed here.

Methods
Methods
Name | Description
AutoAddToGUI | Method that automatically adds a control based on this definition to the General panel of the Add-Ins tab in the ribbon interface.
Delete | Method that deletes the control definition. This method fails for built-in definitions.
Execute | Method that runs the built-in command or sends the Click event to the Add-In. The end result of calling the Execute method is the same as if the user had clicked/pressed the relevant control - for example, by clicking on a button that references a ButtonDefinition object.
Execute2 | Method that executes the control definition synchronously or asynchronously.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Methods


ControlDefinition.AutoAddToGUI Method

ControlDefinition.AutoAddToGUI Method Available in Inventor Introduced in Inventor 6
Summary

Method that automatically adds a control based on this definition to the General panel of the Add-Ins tab in the ribbon interface.

Visual Basic
Sub AutoAddToGUI()
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Methods > ControlDefinition.AutoAddToGUI Method


ControlDefinition.Delete Method

ControlDefinition.Delete Method Available in Inventor Introduced in Inventor 9
Summary

Method that deletes the control definition. This method fails for built-in definitions.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Methods > ControlDefinition.Delete Method


ControlDefinition.Execute Method

ControlDefinition.Execute Method Available in Inventor Introduced in Inventor 8
Summary

Method that runs the built-in command or sends the Click event to the Add-In. The end result of calling the Execute method is the same as if the user had clicked/pressed the relevant control - for example, by clicking on a button that references a ButtonDefinition object.

Visual Basic
Sub Execute()
Remarks

This method is now the preferred method to start a command. CommandManager.StartCommand is obsolete since Autodesk Inventor 10. Here's an example using the Execute method:

Dim oControlDef as ControlDefinition Set oControlDef = ThisApplication.CommandManager.ControlDefinitions.Item("PartExtrudeCmd") oControlDef.Execute

Example

"Copy a sketch."

"This sample demonstrates copying the contents of a sketch into another sketch via the API. Before running the sample, have a part document open that contains a sketch with some sketch entities in it."

Public Sub CopySketch()

    ' Set a reference to the active document.
    ' This assumes a part document is active.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the component definition.
    Dim oDef As PartComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    ' Set a reference to the first sketch in the part.
    Dim oSketchToCopy As PlanarSketch
    Set oSketchToCopy = oDef.Sketches.Item(1)

    ' Select the sketch to copy.
    Call oDoc.SelectSet.Clear
    Call oDoc.SelectSet.Select(oSketchToCopy)

    ' Execute the copy command.
    Dim oCopyControlDef As ControlDefinition
    Set oCopyControlDef = ThisApplication.CommandManager.ControlDefinitions.Item("AppCopyCmd")
    oCopyControlDef.Execute

    ' Create a new sketch on the XY plane.
    Dim oNewSketch As PlanarSketch
    Set oNewSketch = oDef.Sketches.Add(oDef.WorkPlanes.Item(3))

    ' Put the sketch in edit mode.
    oNewSketch.Edit

    ' Execute the paste command.
    Dim oPasteControlDef As ControlDefinition
    Set oPasteControlDef = ThisApplication.CommandManager.ControlDefinitions.Item("AppPasteCmd")
    oPasteControlDef.Execute

    Dim oSketchEnts As ObjectCollection
    Set oSketchEnts = ThisApplication.TransientObjects.CreateObjectCollection

    Dim oSketchEnt As SketchEntity
    For Each oSketchEnt In oNewSketch.SketchEntities
        Call oSketchEnts.Add(oSketchEnt)
    Next

    ' Translate all sketch entities in the new sketch.
    Call oNewSketch.MoveSketchObjects(oSketchEnts, ThisApplication.TransientGeometry.CreateVector2d(1, 0))
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Methods > ControlDefinition.Execute Method


ControlDefinition.Execute2 Method

ControlDefinition.Execute2 Method Available in Inventor Introduced in Inventor 2008
Summary

Method that executes the control definition synchronously or asynchronously.

Visual Basic
Sub Execute2(Synchronous As VARIANT_BOOL)
Parameters
Parameters | Description
Synchronous | Input Boolean that specifies whether to execute the control definition synchronously ('Send Message') or asynchronously ('Post Message').
See Also

Cancel a double click sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Methods > ControlDefinition.Execute2 Method


ControlDefinition Properties

ControlDefinition Properties
Summary

The properties of the ControlDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that specifies if the control or definition is a standard Autodesk Inventor control or definition. Built-in ones have restrictions in the edits that can be performed.
Classification | Property that returns the command classification of the ControlDefinition. These classifications are bits and can be combined to designate that a command falls within more than one classification. Because they are bits, care needs to be taken when interpreting the returned values.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
DefaultShortcut | Property that gets and sets the shortcut for the control definition.
DefaultShortcutType | Property that returns the type of shortcut assigned to this command.
DefinitionType | Property that returns the control definition type. The possible return values are kButtonDefinition, kComboBoxDefinition, and kMacroControlDefinition.
DescriptionText | Property that gets and sets the description text for this control definition. This text is displayed in the status bar when the mouse is moved over a control associated with the definition. This property is read-only for built-in definitions.
DisplayName | Property that returns the display name of the ControlDefinition.
Enabled | Property that specifies if this control definition is enabled or not.
InternalName | Property that returns the internal name. This name is the internal unique identifier for the ControlDefinition.
IsShortcutOverridden | Property that returns whether the default (internal) shortcut has been overridden by the user or through the API.
LargeIcon | Property that gets and sets the currently used large icon for the definition.
OverrideShortcut | Property that gets and sets the override shortcut for the control definition.
OverrideShortcutType | Property that returns the type of override shortcut assigned to this command.
Parent | Property that returns the parent object from whom this object can logically be reached.
ProgressiveToolTip | Property that returns a ProgressiveToolTip object providing access to enhanced tooltip display for controls in the ribbon interface.
StandardIcon | Property that gets and sets the currently used standard icon for the definition.
ToolTipText | Property that gets and sets the associated tool tip. This property is read-only for built-in definitions.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties


ControlDefinition.Application Property

ControlDefinition.Application Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.Application Property


ControlDefinition.BuiltIn Property

ControlDefinition.BuiltIn Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies if the control or definition is a standard Autodesk Inventor control or definition. Built-in ones have restrictions in the edits that can be performed.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.BuiltIn Property


ControlDefinition.Classification Property

ControlDefinition.Classification Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the command classification of the ControlDefinition. These classifications are bits and can be combined to designate that a command falls within more than one classification. Because they are bits, care needs to be taken when interpreting the returned values.

Visual Basic
Property Classification() As CommandTypesEnum*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.Classification Property


ControlDefinition.ClientId Property

ControlDefinition.ClientId Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.ClientId Property


ControlDefinition.DefaultShortcut Property

ControlDefinition.DefaultShortcut Property Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets the shortcut for the control definition.

Visual Basic
Property DefaultShortcut() As String
Remarks

The string can either specify a shortcut (an accelerator) or a command alias. This is interpreted automatically based on the input string. Setting this property will fail if it attempts to set a duplicate accelerator shortcut. Duplicate alias shortcuts are allowed.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.DefaultShortcut Property


ControlDefinition.DefaultShortcutType Property

ControlDefinition.DefaultShortcutType Property Available in Inventor Introduced in Inventor 2008
Summary

Property that returns the type of shortcut assigned to this command.

Visual Basic
Property DefaultShortcutType() As ShortcutTypeEnum*
Remarks

Possible return values are kNoShortcut (indicating that a shortcut has not been assigned), kAcceleratorShortcut (indicating a shortcut that directly launches the command), or kAliasShortcut (indicating a command alias).

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.DefaultShortcutType Property


ControlDefinition.DefinitionType Property

ControlDefinition.DefinitionType Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the control definition type. The possible return values are kButtonDefinition, kComboBoxDefinition, and kMacroControlDefinition.

Visual Basic
Property DefinitionType() As ControlDefinitionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.DefinitionType Property


ControlDefinition.DescriptionText Property

ControlDefinition.DescriptionText Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets the description text for this control definition. This text is displayed in the status bar when the mouse is moved over a control associated with the definition. This property is read-only for built-in definitions.

Visual Basic
Property DescriptionText() As String
See Also

Control Definitions (Inventor Command Names) sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.DescriptionText Property


ControlDefinition.DisplayName Property

ControlDefinition.DisplayName Property Available in Inventor Introduced in Inventor 7
Summary

Property that returns the display name of the ControlDefinition.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.DisplayName Property


ControlDefinition.Enabled Property

ControlDefinition.Enabled Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies if this control definition is enabled or not.

Visual Basic
Property Enabled() As VARIANT_BOOL
See Also

Macro Button - create on toolbar sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.Enabled Property


ControlDefinition.InternalName Property

ControlDefinition.InternalName Property Available in Inventor Introduced in Inventor 7
Summary

Property that returns the internal name. This name is the internal unique identifier for the ControlDefinition.

Visual Basic
Property InternalName() As BSTR*
See Also

Control Definitions (Inventor Command Names) sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.InternalName Property


ControlDefinition.IsShortcutOverridden Property

ControlDefinition.IsShortcutOverridden Property Available in Inventor Introduced in Inventor 2008
Summary

Property that returns whether the default (internal) shortcut has been overridden by the user or through the API.

Visual Basic
Property IsShortcutOverridden() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.IsShortcutOverridden Property


ControlDefinition.LargeIcon Property

ControlDefinition.LargeIcon Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the currently used large icon for the definition.

Visual Basic
Property LargeIcon() As IPictureDisp*
Remarks

Setting this property updates all the controls that currently reference this definition. A large size icon is 32 pixels wide and 32 pixels high for the ribbon interface and 24 pixels wide and 24 pixels high for the classic interface.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.LargeIcon Property


ControlDefinition.OverrideShortcut Property

ControlDefinition.OverrideShortcut Property Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets the override shortcut for the control definition.

Visual Basic
Property OverrideShortcut() As String
Remarks

The string can either specify a shortcut (an accelerator) or a command alias. This is interpreted automatically based on the input string. Setting this property will fail if it attempts to set a duplicate accelerator shortcut. Duplicate alias shortcuts are allowed.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.OverrideShortcut Property


ControlDefinition.OverrideShortcutType Property

ControlDefinition.OverrideShortcutType Property Available in Inventor Introduced in Inventor 2008
Summary

Property that returns the type of override shortcut assigned to this command.

Visual Basic
Property OverrideShortcutType() As ShortcutTypeEnum*
Remarks

Possible return values are kNoShortcut (indicating that a shortcut has not been assigned), kAcceleratorShortcut (indicating a shortcut that directly launches the command), or kAliasShortcut (indicating a command alias).

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.OverrideShortcutType Property


ControlDefinition.Parent Property

ControlDefinition.Parent Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As CommandManager**
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.Parent Property


ControlDefinition.ProgressiveToolTip Property

ControlDefinition.ProgressiveToolTip Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns a ProgressiveToolTip object providing access to enhanced tooltip display for controls in the ribbon interface.

Visual Basic
Property ProgressiveToolTip() As ProgressiveToolTip**
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.ProgressiveToolTip Property


ControlDefinition.StandardIcon Property

ControlDefinition.StandardIcon Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the currently used standard icon for the definition.

Visual Basic
Property StandardIcon() As IPictureDisp*
Remarks

Setting this property updates all the controls that currently reference this definition. A standard size icon is 16 pixels wide and 16 pixels high.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.StandardIcon Property


ControlDefinition.ToolTipText Property

ControlDefinition.ToolTipText Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets the associated tool tip. This property is read-only for built-in definitions.

Visual Basic
Property ToolTipText() As String
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.ToolTipText Property


ControlDefinition.Type Property

ControlDefinition.Type Property Available in Inventor Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinition Interface > ControlDefinition Properties > ControlDefinition.Type Property


ControlDefinitionEvents CoClass

ControlDefinitionEvents CoClass
Summary

The ControlDefinitionEvents object supports a set of properties and events used to work with command inputs.

Class Hierarchy
Inventor::ControlDefinitionEvents
Visual Basic
Public Class ControlDefinitionEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEvents CoClass


ControlDefinitionEventsObject Interface

ControlDefinitionEventsObject Interface
Summary

The ControlDefinitionEvents object supports a set of properties and events used to work with command inputs.

Class Hierarchy
Inventor::ControlDefinitionEventsObject
Visual Basic
Public Interface ControlDefinitionEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface


ControlDefinitionEventsObject Methods

ControlDefinitionEventsObject Methods
Summary

The methods of the ControlDefinitionEventsObject class are listed here.

Methods
Methods
Name | Description
FireOnCommandInputs | Method that fires the OnCommmandInput event.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface > ControlDefinitionEventsObject Methods


ControlDefinitionEventsObject.FireOnCommandInputs Method

ControlDefinitionEventsObject.FireOnCommandInputs Method
Summary

Method that fires the OnCommmandInput event.

Visual Basic
Sub FireOnCommandInputs(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef Inputs As NameValueMap*, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
Inputs | User Input.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface > ControlDefinitionEventsObject Methods > ControlDefinitionEventsObject.FireOnCommandInputs Method


ControlDefinitionEventsObject Properties

ControlDefinitionEventsObject Properties
Summary

The properties of the ControlDefinitionEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface > ControlDefinitionEventsObject Properties


ControlDefinitionEventsObject.Application Property

ControlDefinitionEventsObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface > ControlDefinitionEventsObject Properties > ControlDefinitionEventsObject.Application Property


ControlDefinitionEventsObject.Parent Property

ControlDefinitionEventsObject.Parent Property
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As ControlDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface > ControlDefinitionEventsObject Properties > ControlDefinitionEventsObject.Parent Property


ControlDefinitionEventsObject.Type Property

ControlDefinitionEventsObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsObject Interface > ControlDefinitionEventsObject Properties > ControlDefinitionEventsObject.Type Property


ControlDefinitionEventsSink Interface

ControlDefinitionEventsSink Interface
Summary

The ControlDefinitionEvents object supports a set of properties and events used to work with command inputs.

Class Hierarchy
Inventor::ControlDefinitionEventsSink
Visual Basic
Public Interface ControlDefinitionEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsSink Interface


ControlDefinitionEventsSink Methods

ControlDefinitionEventsSink Methods
Summary

The methods of the ControlDefinitionEventsSink class are listed here.

Methods
Methods
Name | Description
OnCommandInputs | Event that is fired whenever the command requests an input from the user.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsSink Interface > ControlDefinitionEventsSink Methods


ControlDefinitionEventsSink.OnCommandInputs Method

ControlDefinitionEventsSink.OnCommandInputs Method
Summary

Event that is fired whenever the command requests an input from the user.

Visual Basic
Sub OnCommandInputs(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef Inputs As NameValueMap*, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
Inputs | User Input
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitionEventsSink Interface > ControlDefinitionEventsSink Methods > ControlDefinitionEventsSink.OnCommandInputs Method


ControlDefinitions Interface

ControlDefinitions Interface Available in Inventor Introduced in Inventor 6
Summary

The ControlDefinitions collection object provides access to existing objects.

Class Hierarchy
Inventor::ControlDefinitions
Visual Basic
Public Interface ControlDefinitions
Inherits IDispatch
Remarks

ControlDefinition objects represent all commands available within Autodesk Inventor. This includes Autodesk Inventor native commands and commands that have been added by Add-Ins. ControlDefinitions define the behavior of any control that references them. They do not represent the actual control on a command bar. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

CommandManager.ControlDefinitions

See Also

Adding commands to the application menu sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

Break alignment of a section view sample

Macro Button - create on toolbar sample

UI customization - create combo box control sample

UI customization - create combo box control sample

Example

"Control Definitions (Inventor Command Names) Example "

This sample prints the internal names and descriptions of all commands (aka ControlDefinitions) in Inventor.

The sample prints the names and descriptions to a text file (CommandNames.txt) created in C:\Temp directory. You should either have the C:\Temp directory or change the path in the sample.

Sub PrintCommandNames()

    Dim oControlDefs As ControlDefinitions
    Set oControlDefs = ThisApplication.CommandManager.ControlDefinitions

    Dim oControlDef As ControlDefinition

    Open "C:\temp\CommandNames.txt" For Output As #1

    Print #1, Tab(10); "Command Name"; Tab(75); "Description"; vbNewLine

    For Each oControlDef In oControlDefs

        Print #1, oControlDef.InternalName; Tab(55); oControlDef.DescriptionText

    Next
    Close #1
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface


ControlDefinitions Methods

ControlDefinitions Methods
Summary

The methods of the ControlDefinitions class are listed here.

Methods
Methods
Name | Description
AddButtonDefinition | Method that adds a newButtonDefinition object.
AddComboBoxDefinition | Method that creates a new ComboBoxDefinition object.
AddMacroControlDefinition | Method that creates a new MacroControlDefinition object. The MacroControlDefinition object is used to define the information associated with a button that can be used to execute an Inventor VBA macro, insert an iPart, insert an iFeature or execute an EXE.
Item | Property that returns the specified ControlDefinitionobject from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Methods


ControlDefinitions.AddButtonDefinition Method

ControlDefinitions.AddButtonDefinition Method Available in Inventor Introduced in Inventor 9
Summary

Method that adds a newButtonDefinition object.

Visual Basic
Sub AddButtonDefinition(DisplayName As String, InternalName As String, Classification As CommandTypesEnum, ByRef ClientId As [optional] VARIANT, ByRef DescriptionText As [defaultvalue("")] BSTR, ByRef TooltipText As [defaultvalue("")] BSTR, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, ByRef ButtonDisplay As [defaultvalue(kDisplayTextInLearningMode)] ButtonDisplayEnum, Result As [out, retval] ButtonDefinition*)
Parameters
Parameters | Description
DisplayName | Input String that specifies the display name associated with this definition. The display name is the text that is displayed to the user. Because this string is displayed to the user, you should consider localizing it for different languages.
InternalName | Input String value that defines the unique name of the definition. This name is never displayed to the user. The name must be unique with respect to all other control definitions and command bars in Inventor. Because of the uniqueness requirement, it is recommended that you add your application name to the name to help eliminate naming conflicts. For example instead of the name "Analyze" it might be "ACMEAnalyze".
Classification | Input that sets the classification for this ControlDefinition. These classifications are bits and can be combined to designate that a command falls within more than one classification.
ClientId | Optional input string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
DescriptionText | Optional input String that specifies the description text for this definition. The description text is displayed in the status bar when the mouse is moved over a control associated with the definition. If not supplied the display name will be used for the description text.
StandardIcon | Optional input Picture (IPictureDisp) object that specifies the standard size icon to use for the controls using this definition. A standard size icon is 16 pixels wide and 16 pixels high. If not supplied the button will be created as a text only button and the LargeIcon argument is ignored.
LargeIcon | Optional input Picture (IPictureDisp) object that specifies the large size icon to use for the controls using this definition. A large size icon is 24 pixels wide and 24 pixels high (classic interface) or 32 wide by 32 high (ribbon interface). If not supplied and a standard size icon is supplied a large icon will be automatically created by scaling the standard size icon. Because scaling a bitmap does not necessarily create a good image, it is recommended that you create and supply a large bitmap.
ButtonDisplay | constant indicating whether to display text and icons on a button. The default value is kDisplayTextInLearningMode.
ToolTipText | Optional input String that specifies the tool tip text for this definition. If not supplied the display name will be used for the tool tip text.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Methods > ControlDefinitions.AddButtonDefinition Method


ControlDefinitions.AddComboBoxDefinition Method

ControlDefinitions.AddComboBoxDefinition Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new ComboBoxDefinition object.

Visual Basic
Sub AddComboBoxDefinition(DisplayName As String, InternalName As String, Classification As CommandTypesEnum, DropDownWidth As long, ByRef ClientId As [optional] VARIANT, ByRef DescriptionText As [defaultvalue("")] BSTR, ByRef TooltipText As [defaultvalue("")] BSTR, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, ByRef ButtonDisplay As [defaultvalue(kDisplayTextInLearningMode)] ButtonDisplayEnum, Result As [out, retval] ComboBoxDefinition*)
Parameters
Parameters | Description
DisplayName | Input String that specifies the display name associated with this definition. The display name is the text that is displayed to the user. Because this string is displayed to the user, you should consider localizing it for different languages.
InternalName | Input String value that defines the unique name of the definition. This name is never displayed to the user. The name must be unique with respect to all other control definitions and command bars in Inventor. Because of the uniqueness requirement, it is recommended that you add your application name to the name to help eliminate naming conflicts. For example instead of the name 'Analyze' it might be 'ACMEAnalyze'.
Classification | Input that sets the classification for this ControlDefinition. These classifications are bits and can be combined to designate that a command falls within more than one classification.
DropDownWidth | Input Long that specifies the width (in pixels) of the drop-down portion of a combo box.
ClientId | Optional input string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
DescriptionText | Optional input String that specifies the description text for this definition. The description text is displayed in the status bar when the mouse is moved over a control associated with the definition. If not supplied the display name will be used for the description text.
StandardIcon | Optional input Picture (IPictureDisp) object that specifies the standard size icon to use for the controls using this definition. A standard size icon is 16 pixels wide and 16 pixels high. All icons use 16 colors. If not supplied the button will be created as a text only button and the LargeIcon argument is ignored.
LargeIcon | Optional input Picture (IPictureDisp) object that specifies the large size icon to use for the controls using this definition. A large size icon is 24 pixels wide and 24 pixels high. All icons use 16 colors. If not supplied and a standard size icon is supplied a large icon will be automatically created by scaling the standard size icon. Because scaling a bitmap does not necessarily create a good image, it is recommended that you create and supply a large bitmap.
ButtonDisplay | constant indicating whether to display text and icons on a button.
ToolTipText | Optional input String that specifies the tool tip text for this definition. If not supplied the display name will be used for the tool tip text.
See Also

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Methods > ControlDefinitions.AddComboBoxDefinition Method


ControlDefinitions.AddMacroControlDefinition Method

ControlDefinitions.AddMacroControlDefinition Method Available in Inventor Introduced in Inventor 9
Summary

Method that creates a new MacroControlDefinition object. The MacroControlDefinition object is used to define the information associated with a button that can be used to execute an Inventor VBA macro, insert an iPart, insert an iFeature or execute an EXE.

Visual Basic
Sub AddMacroControlDefinition(MacroOrProgram As String, Result As [out, retval] MacroControlDefinition*)
Parameters
Parameters | Description
MacroOrProgram | Input String that defines the VBA macro to run, the external file to insert or EXE program to run. A VBA macro must be a Public Sub defined in a standard code module of the Application VBA project. The Sub cannot have any input arguments. The Sub is specified using 'Module.SubName' format. For example the Sub MovePart in a module named AsmTools would be specified by 'AsmTools.MovePart'. If a filename with a .ipt extension is supplied it is assumed to be an iPart. The filename must be a full filename. If an external EXE is specified, this argument must be the full path to the EXE.
See Also

Macro Button - create on toolbar sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Methods > ControlDefinitions.AddMacroControlDefinition Method


ControlDefinitions.Item Method

ControlDefinitions.Item Method Available in Inventor Introduced in Inventor 7
Summary

Property that returns the specified ControlDefinitionobject from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ControlDefinition*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
See Also

Creation of an override environment for a document sample

Adding commands to the application menu sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

Break alignment of a section view sample

Copy a sketch sample

Macro Button - create on toolbar sample

Add a button to the context menu sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Methods > ControlDefinitions.Item Method


ControlDefinitions Properties

ControlDefinitions Properties
Summary

The properties of the ControlDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
UseDefaultMultiCharAliases | Gets/Sets whether the multi-character Command Aliases delivered with Inventor should be used. The equivalent UI option is found under the 'Keyboard' tab of the Customize dialog.
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Properties


ControlDefinitions.Application Property

ControlDefinitions.Application Property Available in Inventor Introduced in Inventor 7
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Properties > ControlDefinitions.Application Property


ControlDefinitions.Count Property

ControlDefinitions.Count Property Available in Inventor Introduced in Inventor 7
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Properties > ControlDefinitions.Count Property


ControlDefinitions.Type Property

ControlDefinitions.Type Property Available in Inventor Introduced in Inventor 7
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Properties > ControlDefinitions.Type Property


ControlDefinitions.UseDefaultMultiCharAliases Property

ControlDefinitions.UseDefaultMultiCharAliases Property Available in Inventor Introduced in Inventor 2008
Summary

Gets/Sets whether the multi-character Command Aliases delivered with Inventor should be used. The equivalent UI option is found under the 'Keyboard' tab of the Customize dialog.

Visual Basic
Property UseDefaultMultiCharAliases() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ControlDefinitions Interface > ControlDefinitions Properties > ControlDefinitions.UseDefaultMultiCharAliases Property


CoreCavityDefinition Interface

CoreCavityDefinition Interface Introduced in Inventor 2011
Summary

The CoreCavityDefinition object represents all of the information that defines a core-cavity feature. The CoreCavityDefinition object is used in two ways. First it is used as input when creating a core-cavity feature. Second it is used to query and edit existing core-cavity features.

Class Hierarchy
Inventor::CoreCavityDefinition
Visual Basic
Public Interface CoreCavityDefinition
Inherits IDispatch
Remarks

When creating a new core-cavity feature you use the CoreCavityFeatures.CreateCoreCavityDefinition method to create a new CoreCavityDefinition object. Using the properties of this object you can define the various options of the core-cavity feature. Typically a new CreateCoreCavityDefinition object is created and then modified to get the desired core-cavity feature and then used as input to the CoreCavityFeatures.Add method. An existing CoreCavityFeature object is edited by modifying its associated CreateCoreCavityDefinition object.

Notes

Members through which this object may be accessed include:

CoreCavityDefinition.Copy

CoreCavityFeature.Definition

CoreCavityFeatures.CreateDefinition

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface


CoreCavityDefinition Methods

CoreCavityDefinition Methods
Summary

The methods of the CoreCavityDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this CoreCavityDefinition object. The new CoreCavityDefinition object is independent of any feature. It can be edited and used as input to edit an existing feature or to create a new core-cavity feature.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Methods


CoreCavityDefinition.Copy Method

CoreCavityDefinition.Copy Method Introduced in Inventor 2011
Summary

Method that creates a copy of this CoreCavityDefinition object. The new CoreCavityDefinition object is independent of any feature. It can be edited and used as input to edit an existing feature or to create a new core-cavity feature.

Visual Basic
Sub Copy(Result As [out, retval] CoreCavityDefinition*)
Remarks

Any of the properties of the CoreCavityDefinition that can reference a Parameter object will behave differently depending on whether the CoreCavityDefinition is independent or is associated with a feature. When it is associated with a feature these properties behave as read-only and will return the related Parameter object. When it is not associated with a feature these properties behave as read-write and will accept and return doubles and strings to define the value or expression.

One typical use of this method is when you need to make several changes to an existing core-cavity feature. If you edit the CoreCavityDefinition object associated with the core-cavity feature, the feature will recompute after each edit. It's more efficient to make a copy, edit the copy, and then assign the copy back to the feature. This will result in a single recompute.

The CoreCavityFeatures.CreateCoreCavityDefinition method can also be used to create an independent CoreCavityDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateHemDefinition method will be initialized using the input arguments and predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Methods > CoreCavityDefinition.Copy Method


CoreCavityDefinition Properties

CoreCavityDefinition Properties
Summary

The properties of the CoreCavityDefinition class are listed here.

Properties
Name | Description
Application | Property that returns the current top-level Application or InventorServer object.
HolePatches | Property that allows you to get and set the surfaces that define any hole patches the core-cavity feature. The ObjectCollection must contain only SurfaceBody objects or it can be empty if there aren't any hole patches. The input SurfaceBody objects must be open surfaces, (SurfaceBody.IsSolid is False).
Inserts | Property that allows you to get and set the solids that define any inserts that are part of the core-cavity feature. The input SurfaceBody objects must be solids, (SurfaceBody.IsSolid is True), or the collection can be empty if there aren't any inserts.
Parent | Property that returns the parent CoreCavityDefintion object of this CoreCavityDefintion object.
PartBody | Property that gets and sets the solid, (SurfaceBody.IsSolid is True), SurfaceBody object used to define the geometry of the part. This body represents the part that is being molded.
PullDirection | Property that gets and sets the pull direction of the CoreCavityFeature object. The portion generated on the positive direction side is the cavity, the other is the core.
RunoffSurfaces | Property that allows you to get and set the surfaces that define the run-off for the core-cavity feature. The ObjectCollection must consist of SurfaceBody objects and must contain at least one surface body. The input SurfaceBody objects must be open surfaces, (SurfaceBody.IsSolid is False).
Tolerance | Property that defines the tolerance used when attempting to fix certain failure cases such as when small gaps are detected between individual runoff surfaces or between the runoff surface and the base. The default value is 0.00005 (cm). The units are centimeters.
Type | Property that specifies an enum indicating the type of object.
WorkpieceBody | Property that gets and sets the solid, (SurfaceBody.IsSolid is True), SurfaceBody object used to define the work piece used for a CoreCavityFeature object. The work piece is a solid that represents the shape of the mold base and will be split into the core and cavity pieces.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties


CoreCavityDefinition.Application Property

CoreCavityDefinition.Application Property Introduced in Inventor 2011
Summary

Property that returns the current top-level Application or InventorServer object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.Application Property


CoreCavityDefinition.HolePatches Property

CoreCavityDefinition.HolePatches Property Introduced in Inventor 2011
Summary

Property that allows you to get and set the surfaces that define any hole patches the core-cavity feature. The ObjectCollection must contain only SurfaceBody objects or it can be empty if there aren't any hole patches. The input SurfaceBody objects must be open surfaces, (SurfaceBody.IsSolid is False).

Visual Basic
Property HolePatches() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.HolePatches Property


CoreCavityDefinition.Inserts Property

CoreCavityDefinition.Inserts Property Introduced in Inventor 2011
Summary

Property that allows you to get and set the solids that define any inserts that are part of the core-cavity feature. The input SurfaceBody objects must be solids, (SurfaceBody.IsSolid is True), or the collection can be empty if there aren't any inserts.

Visual Basic
Property Inserts() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.Inserts Property


CoreCavityDefinition.Parent Property

CoreCavityDefinition.Parent Property
Summary

Property that returns the parent CoreCavityDefintion object of this CoreCavityDefintion object.

Visual Basic
Property Parent() As CoreCavityFeature**
Remarks

In the case where this is a newly created CoreCavityDefintion object or it has been copied from an existing CoreCavityDefintion object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.Parent Property


CoreCavityDefinition.PartBody Property

CoreCavityDefinition.PartBody Property Introduced in Inventor 2011
Summary

Property that gets and sets the solid, (SurfaceBody.IsSolid is True), SurfaceBody object used to define the geometry of the part. This body represents the part that is being molded.

Visual Basic
Property PartBody() As SurfaceBody*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.PartBody Property


CoreCavityDefinition.PullDirection Property

CoreCavityDefinition.PullDirection Property Introduced in Inventor 2011
Summary

Property that gets and sets the pull direction of the CoreCavityFeature object. The portion generated on the positive direction side is the cavity, the other is the core.

Visual Basic
Property PullDirection() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.PullDirection Property


CoreCavityDefinition.RunoffSurfaces Property

CoreCavityDefinition.RunoffSurfaces Property Introduced in Inventor 2011
Summary

Property that allows you to get and set the surfaces that define the run-off for the core-cavity feature. The ObjectCollection must consist of SurfaceBody objects and must contain at least one surface body. The input SurfaceBody objects must be open surfaces, (SurfaceBody.IsSolid is False).

Visual Basic
Property RunoffSurfaces() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.RunoffSurfaces Property


CoreCavityDefinition.Tolerance Property

CoreCavityDefinition.Tolerance Property Introduced in Inventor 2011
Summary

Property that defines the tolerance used when attempting to fix certain failure cases such as when small gaps are detected between individual runoff surfaces or between the runoff surface and the base. The default value is 0.00005 (cm). The units are centimeters.

Visual Basic
Property Tolerance() As double
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.Tolerance Property


CoreCavityDefinition.Type Property

CoreCavityDefinition.Type Property Introduced in Inventor 2011
Summary

Property that specifies an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.Type Property


CoreCavityDefinition.WorkpieceBody Property

CoreCavityDefinition.WorkpieceBody Property Introduced in Inventor 2011
Summary

Property that gets and sets the solid, (SurfaceBody.IsSolid is True), SurfaceBody object used to define the work piece used for a CoreCavityFeature object. The work piece is a solid that represents the shape of the mold base and will be split into the core and cavity pieces.

Visual Basic
Property WorkpieceBody() As SurfaceBody*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityDefinition Interface > CoreCavityDefinition Properties > CoreCavityDefinition.WorkpieceBody Property


CoreCavityFeature Interface

CoreCavityFeature Interface
Summary

The CoreCavityFeature object represents a modeling feature for generating core/cavity surface bodies.

Class Hierarchy
Inventor::PartFeature
    Inventor::CoreCavityFeature
        Inventor::CoreCavityFeatureProxy
Visual Basic
Public Interface CoreCavityFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CoreCavityDefinition.Parent

CoreCavityFeatures.Add

CoreCavityFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeature Interface


CoreCavityFeature Properties

CoreCavityFeature Properties
Summary

The properties of the CoreCavityFeature class are listed here.

Properties
Name | Description
Cavity | Property that returns the SurfaceBody object that represents the cavity portion of the mold.
Core | Property that returns the SurfaceBody object that represents the core portion of the mold.
Definition | Property that gets and set the CoreCavityDefinition object associated with this core-cavity feature.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeature Interface > CoreCavityFeature Properties


CoreCavityFeature.Cavity Property

CoreCavityFeature.Cavity Property
Summary

Property that returns the SurfaceBody object that represents the cavity portion of the mold.

Visual Basic
Property Cavity() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeature Interface > CoreCavityFeature Properties > CoreCavityFeature.Cavity Property


CoreCavityFeature.Core Property

CoreCavityFeature.Core Property
Summary

Property that returns the SurfaceBody object that represents the core portion of the mold.

Visual Basic
Property Core() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeature Interface > CoreCavityFeature Properties > CoreCavityFeature.Core Property


CoreCavityFeature.Definition Property

CoreCavityFeature.Definition Property
Summary

Property that gets and set the CoreCavityDefinition object associated with this core-cavity feature.

Visual Basic
Property Definition() As CoreCavityDefinition*
Remarks

The CoreCavityDefinition object returned remains associated with the feature is was obtained from and any changes made to the CoreCavityDefinition object will cause the feature to change. You can use the Copy method of the CoreCavityDefinition object to create an independent CoreCavityDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeature Interface > CoreCavityFeature Properties > CoreCavityFeature.Definition Property


CoreCavityFeatureProxy Interface

CoreCavityFeatureProxy Interface
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CoreCavityFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CoreCavityFeature
        Inventor::CoreCavityFeatureProxy
Visual Basic
Public Interface CoreCavityFeatureProxy
Inherits CoreCavityFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatureProxy Interface


CoreCavityFeatures Interface

CoreCavityFeatures Interface Introduced in Inventor 2011
Summary

This CoreCavityFeatures collection provides access to existing CoreCavityFeature objects. It's also through the CoreCavityFeatures object that you create new CoreCavityFeature objects.

Class Hierarchy
Inventor::CoreCavityFeatures
Visual Basic
Public Interface CoreCavityFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.CoreCavityFeatures

You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface


CoreCavityFeatures Methods

CoreCavityFeatures Methods
Summary

The methods of the CoreCavityFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new CoreCavityFeature object. The newly created CoreCavityFeature object is returned.
CreateDefinition | Method that creates a new CoreCavityDefinition object. This object is not a core-cavity feature but contains the information that defines a core-cavity feature and can be used to create a new core-cavity feature. Properties on the returned CoreCavityDefinition object can be used to define additional inputs for the core-cavity feature.
Item | Property that returns specified CoreCavityFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Methods


CoreCavityFeatures.Add Method

CoreCavityFeatures.Add Method Introduced in Inventor 2011
Summary

Method that creates a new CoreCavityFeature object. The newly created CoreCavityFeature object is returned.

Visual Basic
Sub Add(Definition As CoreCavityDefinition, Result As [out, retval] CoreCavityFeature*)
Parameters
Parameters | Description
Definition | Input CoreCavityDefinition object that defines the core-cavity feature you want to create. A CoreCavityDefinition object can be created using the CreateCoreCavityDefinition method on the CoreCavityFeatures object.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Methods > CoreCavityFeatures.Add Method


CoreCavityFeatures.CreateDefinition Method

CoreCavityFeatures.CreateDefinition Method Introduced in Inventor 2011
Summary

Method that creates a new CoreCavityDefinition object. This object is not a core-cavity feature but contains the information that defines a core-cavity feature and can be used to create a new core-cavity feature. Properties on the returned CoreCavityDefinition object can be used to define additional inputs for the core-cavity feature.

Visual Basic
Sub CreateDefinition(PartBody As SurfaceBody, WorkpieceBody As SurfaceBody, RunoffSurfaces As ObjectCollection, PullDirection As UnitVector, Result As [out, retval] CoreCavityDefinition*)
Parameters
Parameters | Description
PartBody | solid SurfaceBody object used to define the geometry of the part. This body represents the part that is being molded.
WorkpieceBody | Input solid SurfaceBody object used to define the work piece used for a CoreCavityFeature object. The work piece is a solid that represents the shape of the mold base and will be split into the core and cavity pieces.
RunoffSurfaces | Input ObjectCollection of SurfaceBody objects that define the run off surfaces. The ObjectCollection must contain at least one surface body.
PullDirection | Input UnitVector that defines the pull direction. The portion generated on the positive direction side is the cavity, the other is the core.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Methods > CoreCavityFeatures.CreateDefinition Method


CoreCavityFeatures.Item Method

CoreCavityFeatures.Item Method Introduced in Inventor 2011
Summary

Property that returns specified CoreCavityFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CoreCavityFeature*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Methods > CoreCavityFeatures.Item Method


CoreCavityFeatures Properties

CoreCavityFeatures Properties
Summary

The properties of the CoreCavityFeatures class are listed here.

Properties
Name | Description
Application | Property that returns the current top-level Application or InventorServer object.
Count | Property that specifies the number of items in the collection.
Type | Property that specifies an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Properties


CoreCavityFeatures.Application Property

CoreCavityFeatures.Application Property Introduced in Inventor 2011
Summary

Property that returns the current top-level Application or InventorServer object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Properties > CoreCavityFeatures.Application Property


CoreCavityFeatures.Count Property

CoreCavityFeatures.Count Property Introduced in Inventor 2011
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Properties > CoreCavityFeatures.Count Property


CoreCavityFeatures.Type Property

CoreCavityFeatures.Type Property Introduced in Inventor 2011
Summary

Property that specifies an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CoreCavityFeatures Interface > CoreCavityFeatures Properties > CoreCavityFeatures.Type Property


CornerChamferDefinition Interface

CornerChamferDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CornerChamferDefinition object is a utility object used for creating, querying, and editing sheet metal corner chamfer features.

Class Hierarchy
Inventor::CornerChamferDefinition
Visual Basic
Public Interface CornerChamferDefinition
Inherits IDispatch
Remarks

A CornerChamferDefinition object can be created using the CornerChamferFeatures.CreateCornerChamferDefinition method. They can also be obtained from existing corner round features which enables querying and editing these features.

Notes

Members through which this object may be accessed include:

CornerChamferDefinition.Copy

CornerChamferFeature.Definition

CornerChamferFeatures.CreateCornerChamferDefinition

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface


CornerChamferDefinition Methods

CornerChamferDefinition Methods
Summary

The methods of the CornerChamferDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Function that creates a copy of this CornerChamferDefinition object. The copy is independent of any other object and can be edited without affecting anything else. It can then be used as input to either modify an existing corner round or create a new corner round feature.
SetDistance | Method that changes the way this corner chamfer is defined so that it is defined using an equal distance from the corner.
SetDistanceAndAngle | Method that changes the CornerChamferDefinition object to define a chamfer that is measured by an offset from the corner along one face and then ang chamfer feature where the chamfer is defined by a distance from an edge and an angle from a face.
SetTwoDistances | Method that changes the CornerChamferDefinition object to define a chamfer that is measured by two offset distances.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Methods


CornerChamferDefinition.Copy Method

CornerChamferDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Function that creates a copy of this CornerChamferDefinition object. The copy is independent of any other object and can be edited without affecting anything else. It can then be used as input to either modify an existing corner round or create a new corner round feature.

Visual Basic
Sub Copy(Result As [out, retval] CornerChamferDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Methods > CornerChamferDefinition.Copy Method


CornerChamferDefinition.SetDistance Method

CornerChamferDefinition.SetDistance Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the way this corner chamfer is defined so that it is defined using an equal distance from the corner.

Visual Basic
Sub SetDistance(CornerEdges As EdgeCollection, Distance As VARIANT)
Parameters
Parameters | Description
CornerEdges | Input EdgeCollection object that contains all of the corners to apply a fillet on. These must be corner edges.
Distance | Input Variant that defines the distance from the edge. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Methods > CornerChamferDefinition.SetDistance Method


CornerChamferDefinition.SetDistanceAndAngle Method

CornerChamferDefinition.SetDistanceAndAngle Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the CornerChamferDefinition object to define a chamfer that is measured by an offset from the corner along one face and then ang chamfer feature where the chamfer is defined by a distance from an edge and an angle from a face.

Visual Basic
Sub SetDistanceAndAngle(CornerEdges As EdgeCollection, Face As Face, Distance As VARIANT, Angle As VARIANT)
Parameters
Parameters | Description
CornerEdges | Input EdgeCollection object that contains all of the corners to apply a fillet on. These must be corner edges and must also be edges of the face specified through the Face argument.
Face | Input Face object that the chamfer angle is measured from.
Distance | Input Variant that defines the distance for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Angle | Input Variant that defines the angle for the chamfer. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Methods > CornerChamferDefinition.SetDistanceAndAngle Method


CornerChamferDefinition.SetTwoDistances Method

CornerChamferDefinition.SetTwoDistances Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the CornerChamferDefinition object to define a chamfer that is measured by two offset distances.

Visual Basic
Sub SetTwoDistances(CornerEdge As Edge, Face As Face, DistanceOne As VARIANT, DistanceTwo As VARIANT)
Parameters
Parameters | Description
CornerEdge | Input Edge object that defines the corner to place the chamfer on..
Face | Input Face object that specifies which face the first distance applies to. The corner edges specified must lie on this face.
DistanceOne | Input Variant that defines the first distance for the chamfer.. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
DistanceTwo | Input Variant that defines the second distance for the chamfer.. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Methods > CornerChamferDefinition.SetTwoDistances Method


CornerChamferDefinition Properties

CornerChamferDefinition Properties
Summary

The properties of the CornerChamferDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ChamferDefinition | Property that returns the ChamferDefinition object that defines how the chamfer is defined.
ChamferDefinitionType | Property that returns an enum indicating how the chamfer is defined.
CornerEdges | Property that gets and sets the edges used for this corner chamfer. When a corner chamfer feature is created is consumes the original input edges, so to be able to access the actual edges that were used as input to or the chamfer you must set the end of part marker to before the corner chamfer feature.
Parent | Property that returns the parent CornerChamferFeature object of this CornerChamferDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties


CornerChamferDefinition.Application Property

CornerChamferDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties > CornerChamferDefinition.Application Property


CornerChamferDefinition.ChamferDefinition Property

CornerChamferDefinition.ChamferDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the ChamferDefinition object that defines how the chamfer is defined.

Visual Basic
Property ChamferDefinition() As ChamferDefinition**
Remarks

The type of definition object that will be returned can be determined by using the DefinitionType property. This property will return nothing in the case where the CornerChamferDefinition object is not associated with an existing corner chamfer feature.

When the ChamferDefinition object is transient, (created using the CornerChamferFeatures. CreateCornerChamferDefinition method or the Copy method of an existing CornerChamferDefinition object), this property will return Nothing. The CornerChamferDefinition still defines a chamfer but its details are not accessible through this property. You can determine the chamfer type by using the ChamferDefinitionType property and can set the type using one of the various Set methods.

When the ChamferDefinition object is transient, (created using the CornerChamferFeatures. CreateCornerChamferDefinition method or the Copy method of an existing CornerChamferDefinition object), this property will return Nothing. The CornerChamferDefinition still defines the chamfer type but its details are not accessible through this property. You can determine the type by using the ChamferDefinitionType property and can set the type using one of the various Set methods.

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties > CornerChamferDefinition.ChamferDefinition Property


CornerChamferDefinition.ChamferDefinitionType Property

CornerChamferDefinition.ChamferDefinitionType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns an enum indicating how the chamfer is defined.

Visual Basic
Property ChamferDefinitionType() As ChamferDefinitionTypeEnum*
Remarks

This indicates the type of object returned by the ChamferDefinition property. The valid return values are kDistance, kDistanceAndAngle and kTwoDistances.

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties > CornerChamferDefinition.ChamferDefinitionType Property


CornerChamferDefinition.CornerEdges Property

CornerChamferDefinition.CornerEdges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the edges used for this corner chamfer. When a corner chamfer feature is created is consumes the original input edges, so to be able to access the actual edges that were used as input to or the chamfer you must set the end of part marker to before the corner chamfer feature.

Visual Basic
Property CornerEdges() As EdgeCollection*
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties > CornerChamferDefinition.CornerEdges Property


CornerChamferDefinition.Parent Property

CornerChamferDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent CornerChamferFeature object of this CornerChamferDefinition object.

Visual Basic
Property Parent() As CornerChamferFeature**
Remarks

In the case where this is a newly created CornerChamferDefinition object or it has been copied from an existing CornerChamferDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties > CornerChamferDefinition.Parent Property


CornerChamferDefinition.Type Property

CornerChamferDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferDefinition Interface > CornerChamferDefinition Properties > CornerChamferDefinition.Type Property


CornerChamferFeature Interface

CornerChamferFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CornerChamferFeature object represents a sheet metal corner chamfer feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::CornerChamferFeature
        Inventor::CornerChamferFeatureProxy
Visual Basic
Public Interface CornerChamferFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CornerChamferDefinition.Parent

CornerChamferFeatures.Add

CornerChamferFeatures.Item

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeature Interface


CornerChamferFeature Properties

CornerChamferFeature Properties
Summary

The properties of the CornerChamferFeature class are listed here.

Properties
Name | Description
Definition | Property that gets the CornerChamferDefinition object associated with this fold feature.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeature Interface > CornerChamferFeature Properties


CornerChamferFeature.Definition Property

CornerChamferFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the CornerChamferDefinition object associated with this fold feature.

Visual Basic
Property Definition() As CornerChamferDefinition**
Remarks

Modifying the CornerChamferDefinition object will edit the associated CornerChamferFeature.

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeature Interface > CornerChamferFeature Properties > CornerChamferFeature.Definition Property


CornerChamferFeatureProxy Interface

CornerChamferFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CornerChamferFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CornerChamferFeature
        Inventor::CornerChamferFeatureProxy
Visual Basic
Public Interface CornerChamferFeatureProxy
Inherits CornerChamferFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatureProxy Interface


CornerChamferFeatures Interface

CornerChamferFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CornerChamferFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::CornerChamferFeatures
Visual Basic
Public Interface CornerChamferFeatures
Inherits IDispatch
Remarks

It's also through the CornerChamferFeatures object that you create new CornerChamferFeature objects.

Notes

Members through which this object may be accessed include:

FlatPatternFeatures.CornerChamferFeatures

SheetMetalFeatures.CornerChamferFeatures

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface


CornerChamferFeatures Methods

CornerChamferFeatures Methods
Summary

The methods of the CornerChamferFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new corner chamfer feature. The newly created CornerChamferFeature object is returned.
CreateCornerChamferDefinition | Method that creates a new CornerChamferDefinition object.
Item | Property that returns the specified CornerChamferFeature object from the collection. This is the default property of the CornerChamferFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Methods


CornerChamferFeatures.Add Method

CornerChamferFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new corner chamfer feature. The newly created CornerChamferFeature object is returned.

Visual Basic
Sub Add(CornerChamferDefinition As CornerChamferDefinition, Result As [out, retval] CornerChamferFeature*)
Parameters
Parameters | Description
CornerChamferDefinition | Input CornerChamferFeature object that defines the corner chamfer feature you want to create. A CornerChamferDefinition object can be created using the CornerChamferFeatures.CreateCornerChamferDefinition method. It can also be obtained from an existing CornerChamferFeature object.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Methods > CornerChamferFeatures.Add Method


CornerChamferFeatures.CreateCornerChamferDefinition Method

CornerChamferFeatures.CreateCornerChamferDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new CornerChamferDefinition object.

Visual Basic
Sub CreateCornerChamferDefinition(CornerEdges As IDispatch, Distance As VARIANT, Result As [out, retval] CornerChamferDefinition*)
Parameters
Parameters | Description
CornerEdges | Input object that defines the corner(s) to apply a corner chamfer on. This can be a single Edge object or an EdgeCollection that contains the Edge objects to chamfer. Any non-corner edges will be ignored.
Distance | Input Variant that defines the distance from the edge. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

This object is not a corner chamfer feature but contains the information that defines a corner chamfer feature and can be used to create a new corner chamfer feature or edit an existing one. The returned CornerChamferDefinition can be used as input to the CornerChamferFeatures.Add method to create a new corner chamfer feature. You can edit the properties of the CornerChamferDefinition object before creating the corner chamfer feature to get the desired corner chamfer feature.

The CornerChamferDefinition object returned by this method will create a chamfer feature where the offset distance is the same on both faces. You can change the chamfer type by editing the CornerChamferDefinition object before using it to create a corner chamfer feature.

You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Methods > CornerChamferFeatures.CreateCornerChamferDefinition Method


CornerChamferFeatures.Item Method

CornerChamferFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified CornerChamferFeature object from the collection. This is the default property of the CornerChamferFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CornerChamferFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Methods > CornerChamferFeatures.Item Method


CornerChamferFeatures Properties

CornerChamferFeatures Properties
Summary

The properties of the CornerChamferFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Properties


CornerChamferFeatures.Application Property

CornerChamferFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Properties > CornerChamferFeatures.Application Property


CornerChamferFeatures.Count Property

CornerChamferFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Properties > CornerChamferFeatures.Count Property


CornerChamferFeatures.Type Property

CornerChamferFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerChamferFeatures Interface > CornerChamferFeatures Properties > CornerChamferFeatures.Type Property


CornerDefinition Interface

CornerDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CornerDefinition object represents all of the information that defines a corner feature.

Class Hierarchy
Inventor::CornerDefinition
Visual Basic
Public Interface CornerDefinition
Inherits IDispatch
Remarks

The CornerDefinition object is used in two ways. First it is used as input when creating a corner feature. Second it is used to query and edit existing corner features. When creating a new corner feature you use the CornerFeatures.CreateCornerDefinition method to create a new CornerDefinition object. Using the properties of this object you can define the various options of the corner feature. Typically a new CornerDefinition object is created and modified to get the desired corner feature and then used as input to the CornerFeatures.Add method. An existing CornerFeature object is edited by modifying its associated CornerDefinition object.

Notes

Members through which this object may be accessed include:

CornerDefinition.Copy

CornerFeature.Definition

CornerFeatures.CreateCornerDefinition

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface


CornerDefinition Methods

CornerDefinition Methods
Summary

The methods of the CornerDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Function that creates a copy of this CornerDefinition object.
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Methods


CornerDefinition.Copy Method

CornerDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Function that creates a copy of this CornerDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] CornerDefinition*)
Remarks

The copy is independent of any corner feature and can be edited without affecting anything else. It can then be used as input to edit an existing corner feature or create a new corner feature.

Any of the properties of the CornerDefinition that can reference a Parameter object will behave differently depending on if the CornerDefinition is independent or associated with a CornerFeature object. When it is associated these properties behave as read-only and will return the associated Parameter object. When it is independent these properties behave as read-write and will accept and return Doubles and Strings to define the value.

One use of this is when you need to make several edits to an existing corner feature. If you edit the CornerDefinition object associated with the corner feature, the feature will recompute after each edit. Instead you can make a copy, edit the copy, and then set the corner feature to use the copy. This will result in a single recompute.

The CornerFeatures.CreateCornerDefinition method can also be used to create an independent CornerDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateFoldDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Methods > CornerDefinition.Copy Method


CornerDefinition Properties

CornerDefinition Properties
Summary

The properties of the CornerDefinition class are listed here.

Properties
Name | Description
AlignedCornerExtension | Property that gets and sets how the corner is extened. If True the first face is projected so that it aligns with the second face. If False the first face is projected perpendicular to the second face.
Application | Returns the Application object.
BendOptions | Property that return the BendOptions object that defines the bend options associated with this corner feature.
CornerDefinitionType | Property that specifies the geometry that is used to measure the corner seam or miter gap. Valid values are kCornerMaxDistance and kCornerFaceEdgeDistance.
CornerOptions | Property that gets/sets the CornerOptions object that defines how the corners are modeled.
CornerType | Property that specifies how the gap of the corner seam or miter is measured.
Edges | Property that provides access to an EdgeCollection object that specifies either the two edges that represent the two faces to create the seam between or the set of the create a ripped edge seam on.
GapWidth | Property that provides access to the width of the gap of a sheet metal corner feature.
IsRippedCorner | Property that specifies if this corner is a seam or ripped corner. If True then it is a ripped corner, otherwise it is a seam.
Parent | Property that returns the parent CornerFeature object of this CornerDefinition object.
PercentOverlap | Property that specifies the overlap as a percentage of the flange thickness using a Double value ranging from 0 to 1. This property is only valid when the overlap type is kCornerSeamOverlap or kCornerSeamReverseOverlap.
Type | Returns an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties


CornerDefinition.AlignedCornerExtension Property

CornerDefinition.AlignedCornerExtension Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets how the corner is extened. If True the first face is projected so that it aligns with the second face. If False the first face is projected perpendicular to the second face.

Visual Basic
Property AlignedCornerExtension() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.AlignedCornerExtension Property


CornerDefinition.Application Property

CornerDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.Application Property


CornerDefinition.BendOptions Property

CornerDefinition.BendOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that return the BendOptions object that defines the bend options associated with this corner feature.

Visual Basic
Property BendOptions() As BendOptions*
Remarks

When the CornerDefinition is initially created this is initialized to the values defined by the active sheet metal style.

The BendOptions object returned remains associated with the CornerDefinition object it is obtained from. This means that edits made to the BendOptions object will affect the BendDefinition and the BendFeature, if one exists.

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.BendOptions Property


CornerDefinition.CornerDefinitionType Property

CornerDefinition.CornerDefinitionType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the geometry that is used to measure the corner seam or miter gap. Valid values are kCornerMaxDistance and kCornerFaceEdgeDistance.

Visual Basic
Property CornerDefinitionType() As CornerDefinitionTypeEnum
Remarks

This property is the equivalent of the option in the dialg shown below.

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.CornerDefinitionType Property


CornerDefinition.CornerOptions Property

CornerDefinition.CornerOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets/sets the CornerOptions object that defines how the corners are modeled.

Visual Basic
Property CornerOptions() As CornerOptions*
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.CornerOptions Property


CornerDefinition.CornerType Property

CornerDefinition.CornerType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies how the gap of the corner seam or miter is measured.

Visual Basic
Property CornerType() As CornerTypeEnum
Remarks

Valid values are kCornerNoOverlap, kCornerOverlap, and kCornerReverseOverlap.

These three values are the equivalent of the three buttons on the Corner Seam dialog, as shown below. kCornerNoOverlap is the equivalent of having the first button pressed. kCornerOverlap is the same as the second button, and kCornerReverseOverlap represents the third button.

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.CornerType Property


CornerDefinition.Edges Property

CornerDefinition.Edges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to an EdgeCollection object that specifies either the two edges that represent the two faces to create the seam between or the set of the create a ripped edge seam on.

Visual Basic
Property Edges() As EdgeCollection*
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.Edges Property


CornerDefinition.GapWidth Property

CornerDefinition.GapWidth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the width of the gap of a sheet metal corner feature.

Visual Basic
Property GapWidth() As VARIANT
Remarks

This property is writable when the CornerDefinition object has been created using the CornerFeatures.CreateCornerDefinition or the CornerDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyGap * 2' is valid, assuming there is a parameter named MyGap.

When the CornerDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the gap width. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.GapWidth Property


CornerDefinition.IsRippedCorner Property

CornerDefinition.IsRippedCorner Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if this corner is a seam or ripped corner. If True then it is a ripped corner, otherwise it is a seam.

Visual Basic
Property IsRippedCorner() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.IsRippedCorner Property


CornerDefinition.Parent Property

CornerDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent CornerFeature object of this CornerDefinition object.

Visual Basic
Property Parent() As CornerFeature**
Remarks

In the case where this is a newly created CornerDefinition object or it has been copied from an existing CornerDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.Parent Property


CornerDefinition.PercentOverlap Property

CornerDefinition.PercentOverlap Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the overlap as a percentage of the flange thickness using a Double value ranging from 0 to 1. This property is only valid when the overlap type is kCornerSeamOverlap or kCornerSeamReverseOverlap.

Visual Basic
Property PercentOverlap() As double
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.PercentOverlap Property


CornerDefinition.Type Property

CornerDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerDefinition Interface > CornerDefinition Properties > CornerDefinition.Type Property


CornerFeature Interface

CornerFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CornerSeamFeature object represents a sheet metal corner seam feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::CornerFeature
        Inventor::CornerFeatureProxy
Visual Basic
Public Interface CornerFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ContourFlangeFeature.CornerFeature

CornerDefinition.Parent

CornerFeatures.Add

CornerFeatures.Item

FlangeFeature.CornerFeature

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > CornerFeature Interface


CornerFeature Properties

CornerFeature Properties
Summary

The properties of the CornerFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the CornerDefinition object associated with this corner feature.
You are here: Symbol Reference > Inventor Library > Objects > CornerFeature Interface > CornerFeature Properties


CornerFeature.Definition Property

CornerFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the CornerDefinition object associated with this corner feature.

Visual Basic
Property Definition() As CornerDefinition**
Remarks

Modifying the CornerDefinition object will edit the associated CornerFeature.

You are here: Symbol Reference > Inventor Library > Objects > CornerFeature Interface > CornerFeature Properties > CornerFeature.Definition Property


CornerFeatureProxy Interface

CornerFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CornerFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CornerFeature
        Inventor::CornerFeatureProxy
Visual Basic
Public Interface CornerFeatureProxy
Inherits CornerFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CornerFeatureProxy Interface


CornerFeatures Interface

CornerFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CornerFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::CornerFeatures
Visual Basic
Public Interface CornerFeatures
Inherits IDispatch
Remarks

It's also through the CornerFeatures object that you create new corner features.

Notes

Members through which this object may be accessed include:

SheetMetalFeatures.CornerFeatures

You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface


CornerFeatures Methods

CornerFeatures Methods
Summary

The methods of the CornerFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sheet metal corner feature.
CreateCornerDefinition | Method that creates a new sheet metal corner feature.
Item | Property that returns the specified CornerFeature object from the collection. This is the default property of the CornerFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Methods


CornerFeatures.Add Method

CornerFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new sheet metal corner feature.

Visual Basic
Sub Add(CornerDefinition As CornerDefinition, Result As [out, retval] CornerFeature*)
Parameters
Parameters | Description
CornerDefinition | Input CornerDefinition object that defines the corner feature you want to create. A CornerDefinition object can be created using the CornerFeature.CreateCornerDefinition method. It can also be obtained from an existing CornerFeature object.
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Methods > CornerFeatures.Add Method


CornerFeatures.CreateCornerDefinition Method

CornerFeatures.CreateCornerDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new sheet metal corner feature.

Visual Basic
Sub CreateCornerDefinition(Edges As EdgeCollection, RippedCorner As VARIANT_BOOL, Result As [out, retval] CornerDefinition*)
Parameters
Parameters | Description
Edges | Input EdgeCollection object that contains the two edges that define the two sheet metal faces to create the corner between or the edges to create a ripped corner on.
RippedCorner | Input Boolean that specifies if the corner is a ripped corner or a seam corner. A value of True indicates a ripped corner.
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Methods > CornerFeatures.CreateCornerDefinition Method


CornerFeatures.Item Method

CornerFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified CornerFeature object from the collection. This is the default property of the CornerFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CornerFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Methods > CornerFeatures.Item Method


CornerFeatures Properties

CornerFeatures Properties
Summary

The properties of the CornerFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Properties


CornerFeatures.Application Property

CornerFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Properties > CornerFeatures.Application Property


CornerFeatures.Count Property

CornerFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Properties > CornerFeatures.Count Property


CornerFeatures.Type Property

CornerFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerFeatures Interface > CornerFeatures Properties > CornerFeatures.Type Property


CornerOptions Interface

CornerOptions Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CornerOptions object defines the settings that influence the creation of a corner in a sheet metal part.

Class Hierarchy
Inventor::CornerOptions
Visual Basic
Public Interface CornerOptions
Inherits IDispatch
Remarks

This object can be obtained from existing sheet metal features and the properties on the object modified to edit the feature. It can also be created using the SheetMetalFeatures.CreateCornerOptions method so that you can define the corner options when creating a new sheet metal feature.

Notes

Members through which this object may be accessed include:

ContourFlangeDefinition.CornerOptions

CornerDefinition.CornerOptions

CornerOptions.Copy

FlangeDefinition.CornerOptions

You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface


CornerOptions Methods

CornerOptions Methods
Summary

The methods of the CornerOptions class are listed here.

Methods
Methods
Name | Description
Copy | Function that creates a copy of this CornerOptions object.
You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Methods


CornerOptions.Copy Method

CornerOptions.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Function that creates a copy of this CornerOptions object.

Visual Basic
Sub Copy(Result As [out, retval] CornerOptions*)
Remarks

The copy is independent of any other object and can be edited without affecting anything else. This is referred to as a transient CornerOptions object. It can then be used as input to edit an existing object that uses corner options.

Any of the properties of the CornerOptions that can reference a Parameter object will behave differently depending on if the CornerOptions object is transient or associated with a feature. When it is associated these properties behave as read-only and will return the associated Parameter object. When it is transient these properties behave as read-write and will accept and return Doubles and Strings to define the value.

One use of this is when you need to edit several of the corner options of an existing feature. If you edit the CornerOptions object associated with the feature, the feature will recompute after each edit. Instead you can make a copy, edit the copy, and then set the feature to use the copy. This will result in a single recompute.

You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Methods > CornerOptions.Copy Method


CornerOptions Properties

CornerOptions Properties
Summary

The properties of the CornerOptions class are listed here.

Properties
Name | Description
CornerReliefShape | Property that defines the type of relief shape to use for when two bends intersect at the corner of the associated sheet metal feature.
CornerReliefSize | Property that provides access to the corner relief size of a sheet metal feature where two bends intersect at a corner.
IsTwoBend | Property that indicates if the corner this CornerOptions object is associated with is a two or three bend corner.
Parent | Property that returns the parent object of this CornerOptions object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Properties


CornerOptions.CornerReliefShape Property

CornerOptions.CornerReliefShape Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that defines the type of relief shape to use for when two bends intersect at the corner of the associated sheet metal feature.

Visual Basic
Property CornerReliefShape() As CornerReliefShapeEnum
Remarks

Value values for this are: kDefaultCornerReliefShape, kRoundCornerReliefShape, kSquareCornerReliefShape, kTearCornerReliefShape, kTrimToBendCornerReliefShape, kLinearWeldCornerReliefShape, and kArcWeldCornerReliefShape.

You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Properties > CornerOptions.CornerReliefShape Property


CornerOptions.CornerReliefSize Property

CornerOptions.CornerReliefSize Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the corner relief size of a sheet metal feature where two bends intersect at a corner.

Visual Basic
Property CornerReliefSize() As VARIANT
Remarks

This property is writable when the CornerOptions object is transient (not associated with an existing feature). The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyReliefSize * 2' is valid, assuming there is a parameter named MyReliefSize.

When the CornerOptions object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the relief size. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Properties > CornerOptions.CornerReliefSize Property


CornerOptions.IsTwoBend Property

CornerOptions.IsTwoBend Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates if the corner this CornerOptions object is associated with is a two or three bend corner.

Visual Basic
Property IsTwoBend() As VARIANT_BOOL*
Remarks

Returns True in the case of a two bend corner.

You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Properties > CornerOptions.IsTwoBend Property


CornerOptions.Parent Property

CornerOptions.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent object of this CornerOptions object.

Visual Basic
Property Parent() As IDispatch**
Remarks

In the case where this is a newly created CornerOptions object or it has been copied from an existing CornerOptions object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Properties > CornerOptions.Parent Property


CornerOptions.Type Property

CornerOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerOptions Interface > CornerOptions Properties > CornerOptions.Type Property


CornerRoundDefinition Interface

CornerRoundDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CornerRoundDefinition object is a utility object used for creating, querying, and editing sheet metal corner round features.

Class Hierarchy
Inventor::CornerRoundDefinition
Visual Basic
Public Interface CornerRoundDefinition
Inherits IDispatch
Remarks

They can be created using the CornerRoundFeatures.CreateCornerRoundDefinition method. When created this way they are used as input to the CornerRoundFeatures.Add method to create new corner round features. They can also be obtained from existing corner round features which enables querying and editing these features.

Notes

Members through which this object may be accessed include:

CornerRoundDefinition.Copy

CornerRoundEdgeSet.Parent

CornerRoundFeature.Definition

CornerRoundFeatures.CreateCornerRoundDefinition

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface


CornerRoundDefinition Methods

CornerRoundDefinition Methods
Summary

The methods of the CornerRoundDefinition class are listed here.

Methods
Methods
Name | Description
AddEdgeSet | Method that creates a new edge set within the corner round definition.
Copy | Function that creates a copy of this CornerRoundDefinition object. The copy is independent of any other object and can be edited without affecting anything else. It can then be used as input to either modify an existing corner round or create a new corner round feature.
EdgeSetItem | Method that returns the specified CornerRoundEdgeSet object from this CornerRoundDefinition object.
RemoveEdgeSet | Method that removes the specified CornerRoundEdgeSet object from this CornerRoundDefinition object. This results in all the corner round being removed from the edges in this edge set.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Methods


CornerRoundDefinition.AddEdgeSet Method

CornerRoundDefinition.AddEdgeSet Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new edge set within the corner round definition.

Visual Basic
Sub AddEdgeSet(CornerEdges As EdgeCollection, Radius As VARIANT, Result As [out, retval] CornerRoundEdgeSet*)
Parameters
Parameters | Description
CornerEdges | Input EdgesCollection object that contains all of the corners to apply a corner round on. Any non-corner edges will be ignored.
Radius | Input Variant that defines the corner radius. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Methods > CornerRoundDefinition.AddEdgeSet Method


CornerRoundDefinition.Copy Method

CornerRoundDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Function that creates a copy of this CornerRoundDefinition object. The copy is independent of any other object and can be edited without affecting anything else. It can then be used as input to either modify an existing corner round or create a new corner round feature.

Visual Basic
Sub Copy(Result As [out, retval] CornerRoundDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Methods > CornerRoundDefinition.Copy Method


CornerRoundDefinition.EdgeSetItem Method

CornerRoundDefinition.EdgeSetItem Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified CornerRoundEdgeSet object from this CornerRoundDefinition object.

Visual Basic
Sub EdgeSetItem(Index As long, Result As [out, retval] CornerRoundEdgeSet*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the CornerRoundEdgeSet to return. If an out of range index is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Methods > CornerRoundDefinition.EdgeSetItem Method


CornerRoundDefinition.RemoveEdgeSet Method

CornerRoundDefinition.RemoveEdgeSet Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that removes the specified CornerRoundEdgeSet object from this CornerRoundDefinition object. This results in all the corner round being removed from the edges in this edge set.

Visual Basic
Sub RemoveEdgeSet(Index As long)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the CornerRoundEdgeSet to return. If an out of range index is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Methods > CornerRoundDefinition.RemoveEdgeSet Method


CornerRoundDefinition Properties

CornerRoundDefinition Properties
Summary

The properties of the CornerRoundDefinition class are listed here.

Properties
Name | Description
Application | Returns the Application object.
EdgeSetCount | Property that returns the number of edge sets defined within this CornerRoundDefinition object.
Parent | Property that returns the parent CornerRoundFeature of this CornerRoundDefinition object.
Type | Returns an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Properties


CornerRoundDefinition.Application Property

CornerRoundDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Properties > CornerRoundDefinition.Application Property


CornerRoundDefinition.EdgeSetCount Property

CornerRoundDefinition.EdgeSetCount Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of edge sets defined within this CornerRoundDefinition object.

Visual Basic
Property EdgeSetCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Properties > CornerRoundDefinition.EdgeSetCount Property


CornerRoundDefinition.Parent Property

CornerRoundDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent CornerRoundFeature of this CornerRoundDefinition object.

Visual Basic
Property Parent() As CornerRoundFeature**
Remarks

In the case where this is a newly created CornerRoundDefinition object or it has been copied from an existing CornerRoundDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Properties > CornerRoundDefinition.Parent Property


CornerRoundDefinition.Type Property

CornerRoundDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundDefinition Interface > CornerRoundDefinition Properties > CornerRoundDefinition.Type Property


CornerRoundEdgeSet Interface

CornerRoundEdgeSet Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CornerRoundEdgeSet object represents a set of edges and an associated fillet radius.

Class Hierarchy
Inventor::CornerRoundEdgeSet
Visual Basic
Public Interface CornerRoundEdgeSet
Inherits IDispatch
Remarks

This is used in association with the CornerRoundDefinition object to provide the input for sheet metal corner round features.

Notes

Members through which this object may be accessed include:

CornerRoundDefinition.AddEdgeSet

CornerRoundDefinition.EdgeSetItem

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundEdgeSet Interface


CornerRoundEdgeSet Properties

CornerRoundEdgeSet Properties
Summary

The properties of the CornerRoundEdgeSet class are listed here.

Properties
Name | Description
Edges | Property that gets and sets the edges in this edge set. When a corner round feature is created is consumes the original input edges, so to be able to access the actual edges that were used as input to the edge set you must set the end of part marker to before the corner round feature.
Parent | Property that returns the parent CornerRoundDefinition of this CornerRoundEdgeSet object.
Radius | Property that provides access to the radius of a sheet metal corner round feature
Type | Returns an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundEdgeSet Interface > CornerRoundEdgeSet Properties


CornerRoundEdgeSet.Edges Property

CornerRoundEdgeSet.Edges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the edges in this edge set. When a corner round feature is created is consumes the original input edges, so to be able to access the actual edges that were used as input to the edge set you must set the end of part marker to before the corner round feature.

Visual Basic
Property Edges() As EdgeCollection*
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundEdgeSet Interface > CornerRoundEdgeSet Properties > CornerRoundEdgeSet.Edges Property


CornerRoundEdgeSet.Parent Property

CornerRoundEdgeSet.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent CornerRoundDefinition of this CornerRoundEdgeSet object.

Visual Basic
Property Parent() As CornerRoundDefinition**
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundEdgeSet Interface > CornerRoundEdgeSet Properties > CornerRoundEdgeSet.Parent Property


CornerRoundEdgeSet.Radius Property

CornerRoundEdgeSet.Radius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the radius of a sheet metal corner round feature

Visual Basic
Property Radius() As VARIANT
Remarks

This property is writable when the CornerRoundEdgeSet object has been created using the CreateFoldDefinition.AddEdgeSet method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyRadius * 2' is valid, assuming there is a parameter named MyRadius.

When the CornerRoundDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the corner radius. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundEdgeSet Interface > CornerRoundEdgeSet Properties > CornerRoundEdgeSet.Radius Property


CornerRoundEdgeSet.Type Property

CornerRoundEdgeSet.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundEdgeSet Interface > CornerRoundEdgeSet Properties > CornerRoundEdgeSet.Type Property


CornerRoundFeature Interface

CornerRoundFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CornerRoundFeature object represents a sheet metal corner round feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::CornerRoundFeature
        Inventor::CornerRoundFeatureProxy
Visual Basic
Public Interface CornerRoundFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CornerRoundDefinition.Parent

CornerRoundFeatures.Add

CornerRoundFeatures.Item

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeature Interface


CornerRoundFeature Properties

CornerRoundFeature Properties
Summary

The properties of the CornerRoundFeature class are listed here.

Properties
Name | Description
Definition | Property that gets/sets the CornerRoundDefinition object associated with this fold feature.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeature Interface > CornerRoundFeature Properties


CornerRoundFeature.Definition Property

CornerRoundFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets/sets the CornerRoundDefinition object associated with this fold feature.

Visual Basic
Property Definition() As CornerRoundDefinition**
Remarks

Modifying the CornerRoundDefinition object will edit the associated CornerRoundFeature.

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeature Interface > CornerRoundFeature Properties > CornerRoundFeature.Definition Property


CornerRoundFeatureProxy Interface

CornerRoundFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CornerRoundFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CornerRoundFeature
        Inventor::CornerRoundFeatureProxy
Visual Basic
Public Interface CornerRoundFeatureProxy
Inherits CornerRoundFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatureProxy Interface


CornerRoundFeatures Interface

CornerRoundFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CornerRoundFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::CornerRoundFeatures
Visual Basic
Public Interface CornerRoundFeatures
Inherits IDispatch
Remarks

It's also through the CornerRoundFeatures object that you create new CornerRoundFeature objects.

Notes

Members through which this object may be accessed include:

FlatPatternFeatures.CornerRoundFeatures

SheetMetalFeatures.CornerRoundFeatures

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface


CornerRoundFeatures Methods

CornerRoundFeatures Methods
Summary

The methods of the CornerRoundFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sheet metal corner round feature.
CreateCornerRoundDefinition | Method that creates a new CornerRoundDefinition object.
Item | Property that returns the specified CornerRoundFeature object from the collection. This is the default property of the CornerRoundFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Methods


CornerRoundFeatures.Add Method

CornerRoundFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new sheet metal corner round feature.

Visual Basic
Sub Add(CornerRoundDefinition As CornerRoundDefinition, Result As [out, retval] CornerRoundFeature*)
Parameters
Parameters | Description
CornerRoundDefinition | Input CornerRoundDefinition object that defines the various edges and radii.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Methods > CornerRoundFeatures.Add Method


CornerRoundFeatures.CreateCornerRoundDefinition Method

CornerRoundFeatures.CreateCornerRoundDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new CornerRoundDefinition object.

Visual Basic
Sub CreateCornerRoundDefinition(CornerEdges As EdgeCollection, Radius As VARIANT, Result As [out, retval] CornerRoundDefinition*)
Parameters
Parameters | Description
CornerEdges | Input EdgesCollection object that contains all of the corners to apply a corner round on. Any non-corner edges will be ignored.
Radius | Input Variant that defines the corner radius. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

This object is not a corner round feature but contains the information that defines a corner round feature and can be used to create a new corner round feature or edit an existing one. The returned CornerRoundDefinition can be used as input to the CornerRoundFeatures.Add method to create a new corner round feature. You can edit the properties of the CornerRoundDefinition object before creating the corner round feature to get the desired corner round feature.

You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Methods > CornerRoundFeatures.CreateCornerRoundDefinition Method


CornerRoundFeatures.Item Method

CornerRoundFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified CornerRoundFeature object from the collection. This is the default property of the CornerRoundFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CornerRoundFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Methods > CornerRoundFeatures.Item Method


CornerRoundFeatures Properties

CornerRoundFeatures Properties
Summary

The properties of the CornerRoundFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Properties


CornerRoundFeatures.Application Property

CornerRoundFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Properties > CornerRoundFeatures.Application Property


CornerRoundFeatures.Count Property

CornerRoundFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Properties > CornerRoundFeatures.Count Property


CornerRoundFeatures.Type Property

CornerRoundFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CornerRoundFeatures Interface > CornerRoundFeatures Properties > CornerRoundFeatures.Type Property


CosmeticBendFeature Interface

CosmeticBendFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CosmeticBendFeature object represents a cosmetic bend within a flat pattern.

Class Hierarchy
Inventor::PartFeature
    Inventor::CosmeticBendFeature
        Inventor::CosmeticBendFeatureProxy
Visual Basic
Public Interface CosmeticBendFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CosmeticBendFeatures.Item

Most functionality reserved for future implementation.

You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeature Interface


CosmeticBendFeatureProxy Interface

CosmeticBendFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CosmeticBendFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CosmeticBendFeature
        Inventor::CosmeticBendFeatureProxy
Visual Basic
Public Interface CosmeticBendFeatureProxy
Inherits CosmeticBendFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatureProxy Interface


CosmeticBendFeatures Interface

CosmeticBendFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CosmeticBendFeatures collection object provides access to the CosmeticBendFeature objects that have been created within a flat pattern.

Class Hierarchy
Inventor::CosmeticBendFeatures
Visual Basic
Public Interface CosmeticBendFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPatternFeatures.CosmeticBendFeatures

You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface


CosmeticBendFeatures Methods

CosmeticBendFeatures Methods
Summary

The methods of the CosmeticBendFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified CosmeticBendFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface > CosmeticBendFeatures Methods


CosmeticBendFeatures.Item Method

CosmeticBendFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified CosmeticBendFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CosmeticBendFeature*)
Parameters
Parameters | Description
Index | Input Long or String that specifies the CosmeticBendFeature object within the collection to return. Inputting a Long indicates the index of the CosmeticBendFeature within the collection to return. A String can also be used to specify the name of the feature. The property will fail is the index is out of range or the name does not exist.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface > CosmeticBendFeatures Methods > CosmeticBendFeatures.Item Method


CosmeticBendFeatures Properties

CosmeticBendFeatures Properties
Summary

The properties of the CosmeticBendFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of LoftedFlangeFeature objects in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface > CosmeticBendFeatures Properties


CosmeticBendFeatures.Application Property

CosmeticBendFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface > CosmeticBendFeatures Properties > CosmeticBendFeatures.Application Property


CosmeticBendFeatures.Count Property

CosmeticBendFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of LoftedFlangeFeature objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface > CosmeticBendFeatures Properties > CosmeticBendFeatures.Count Property


CosmeticBendFeatures.Type Property

CosmeticBendFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CosmeticBendFeatures Interface > CosmeticBendFeatures Properties > CosmeticBendFeatures.Type Property


CosmeticWeld Interface

CosmeticWeld Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The CosmeticWeld object represents a cosmetic weld within an assembly. The CosmeticWeld object is derived from the Weld object.

Class Hierarchy
Inventor::Weld
    Inventor::CosmeticWeld
Visual Basic
Public Interface CosmeticWeld
Inherits Weld
Notes

Members through which this object may be accessed include:

CosmeticWelds.Item

You are here: Symbol Reference > Inventor Library > Objects > CosmeticWeld Interface


CosmeticWeld Properties

CosmeticWeld Properties
Summary

The properties of the CosmeticWeld class are listed here.

Properties
Name | Description
Edges | Property that returns the set of edges the cosmetic weld is on.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWeld Interface > CosmeticWeld Properties


CosmeticWeld.Edges Property

CosmeticWeld.Edges Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the set of edges the cosmetic weld is on.

Visual Basic
Property Edges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWeld Interface > CosmeticWeld Properties > CosmeticWeld.Edges Property


CosmeticWelds Interface

CosmeticWelds Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The CosmeticWelds object provides access to all the existing objects within a weldment.

Class Hierarchy
Inventor::CosmeticWelds
Visual Basic
Public Interface CosmeticWelds
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Welds.CosmeticWelds

You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface


CosmeticWelds Methods

CosmeticWelds Methods
Summary

The methods of the CosmeticWelds class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified CosmeticWeld object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface > CosmeticWelds Methods


CosmeticWelds.Item Method

CosmeticWelds.Item Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the specified CosmeticWeld object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CosmeticWeld*)
Parameters
Parameters | Description
index | Input Variant value that specifies the CosmeticWeld to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the CosmeticWeld name. If an out of range index or a name of a non-existent CosmeticWeld is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface > CosmeticWelds Methods > CosmeticWelds.Item Method


CosmeticWelds Properties

CosmeticWelds Properties
Summary

The properties of the CosmeticWelds class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface > CosmeticWelds Properties


CosmeticWelds.Application Property

CosmeticWelds.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface > CosmeticWelds Properties > CosmeticWelds.Application Property


CosmeticWelds.Count Property

CosmeticWelds.Count Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the number of items in the collection

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface > CosmeticWelds Properties > CosmeticWelds.Count Property


CosmeticWelds.Type Property

CosmeticWelds.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CosmeticWelds Interface > CosmeticWelds Properties > CosmeticWelds.Type Property


Curve2dEvaluator Interface

Curve2dEvaluator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Curve2dEvaluator object. See the article in the overviews section.

Class Hierarchy
Inventor::Curve2dEvaluator
Visual Basic
Public Interface Curve2dEvaluator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Arc2d.Evaluator

BSplineCurve2d.Evaluator

Circle2d.Evaluator

DrawingCurve.Evaluator2D

EdgeUse.Evaluator

EllipseFull2d.Evaluator

EllipticalArc2d.Evaluator

Line2d.Evaluator

LineSegment2d.Evaluator

Polyline2d.Evaluator

You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface


Curve2dEvaluator Methods

Curve2dEvaluator Methods
Summary

The methods of the Curve2dEvaluator class are listed here.

Methods
Methods
Name | Description
GetCurvature | Calculates the curvature direction and magnitude of the curve at the given parameter values.
GetEndPoints | Gets the end points of the curve if the curve is bounded.
GetFirstDerivatives | Calculates the first order derivatives at the given parameter values on the curve.
GetLengthAtParam | Calculate the length of the curve as measured between the specified parameter values.
GetParamAnomaly | Gets general information about the parameterization of the curve, such as whether or not it is periodic, singular, or unbounded in the parameter domain.
GetParamAtLength | Calculates the parameter value at the point measured from the specified starting parameter along the curve.
GetParamAtPoint | Calculates the parameter value on the curve that is equal to the specified point. The point must lie on the curve.
GetParamExtents | Gets the valid parameter range of the curve if the curve is bounded.
GetPointAtParam | Calculates the coordinate points at the given parameter values on the curve.
GetSecondDerivatives | Calculates the second order derivatives at the given parameter values on the curve.
GetTangent | Calculates the tangency directions at the given parameter values on the curve.
GetThirdDerivatives | Calculates the third order derivatives at the given parameter values on the curve.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods


Curve2dEvaluator.GetCurvature Method

Curve2dEvaluator.GetCurvature Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the curvature direction and magnitude of the curve at the given parameter values.

Visual Basic
Sub GetCurvature(ByRef Params As SAFEARRAY(double), ByRef Directions As SAFEARRAY(double), ByRef Curvatures As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Directions | Input/output Double that specifies the directions of the curvatures.
Curvatures | Input/output Double that specifies the curvature.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetCurvature Method


Curve2dEvaluator.GetEndPoints Method

Curve2dEvaluator.GetEndPoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the end points of the curve if the curve is bounded.

Visual Basic
Sub GetEndPoints(ByRef StartPoint As SAFEARRAY(double), ByRef EndPoint As SAFEARRAY(double))
Parameters
Parameters | Description
StartPoint | Input/output Double that specifies the start point.
EndPoint | Input/output Double that specifies the end point.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetEndPoints Method


Curve2dEvaluator.GetFirstDerivatives Method

Curve2dEvaluator.GetFirstDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the first order derivatives at the given parameter values on the curve.

Visual Basic
Sub GetFirstDerivatives(ByRef Params As SAFEARRAY(double), ByRef FirstDerivs As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
FirstDerivs | Input/output Double array of the resulting first derivatives.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetFirstDerivatives Method


Curve2dEvaluator.GetLengthAtParam Method

Curve2dEvaluator.GetLengthAtParam Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculate the length of the curve as measured between the specified parameter values.

Visual Basic
Sub GetLengthAtParam(FromParam As double, ToParam As double, ByRef Length As double)
Parameters
Parameters | Description
FromParam | Input Double that specifies the parameter value to measure the length from.
ToParam | Input Double that specifies the parameter value to measure the length to.
Length | Output Double that returns the distance measured along the curve.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetLengthAtParam Method


Curve2dEvaluator.GetParamAnomaly Method

Curve2dEvaluator.GetParamAnomaly Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets general information about the parameterization of the curve, such as whether or not it is periodic, singular, or unbounded in the parameter domain.

Visual Basic
Sub GetParamAnomaly(ByRef Periodicity As SAFEARRAY(double), ByRef IsSingular As VARIANT_BOOL, ByRef UnboundedParam As VARIANT_BOOL)
Parameters
Parameters | Description
Periodicity | Output two element Double array that returns whether the curve is periodic. If the curve is periodic, the first array element is the period of the curve and the second element is the starting parameter of the principle period. If the curve is not periodic, the first element is zero, and the second element is unused.
IsSingular | Output Boolean that returns whether the curve is degenerate to a singularity.
UnboundedParam | Output Boolean that returns whether the curve has an unbounded parameter range.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetParamAnomaly Method


Curve2dEvaluator.GetParamAtLength Method

Curve2dEvaluator.GetParamAtLength Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the parameter value at the point measured from the specified starting parameter along the curve.

Visual Basic
Sub GetParamAtLength(FromParam As double, Length As double, ByRef Param As double)
Parameters
Parameters | Description
FromParam | Input Double that specifies the parameter value to measure the length from.
Length | Input Double that specifies the distance measured along the curve.
Param | Output Double that returns the parameter value at the specified Length from FromParam.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetParamAtLength Method


Curve2dEvaluator.GetParamAtPoint Method

Curve2dEvaluator.GetParamAtPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the parameter value on the curve that is equal to the specified point. The point must lie on the curve.

Visual Basic
Sub GetParamAtPoint(ByRef Points As SAFEARRAY(double), ByRef GuessParams As SAFEARRAY(double), ByRef MaxDeviations As SAFEARRAY(double), ByRef Params As SAFEARRAY(double), ByRef SolTypes As SAFEARRAY(SolutionNatureEnum))
Parameters
Parameters | Description
Points | Input/output double that specifies the points.
GuessParams | Input array of parameter values that are an initial guess to optimize the calculation.
MaxDeviations | Output array of Doubles that returns the maximum deviation achieved from the input points.
Params | Input/output array of Doubles that specifies the parameters.
SolTypes | Output that returns the nature of the solution found.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetParamAtPoint Method


Curve2dEvaluator.GetParamExtents Method

Curve2dEvaluator.GetParamExtents Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the valid parameter range of the curve if the curve is bounded.

Visual Basic
Sub GetParamExtents(ByRef MinParam As double, ByRef MaxParam As double)
Parameters
Parameters | Description
MinParam | Output Double that returns the minimum valid parameter value.
MaxParam | Output Double that returns the maximum valid parameter value.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetParamExtents Method


Curve2dEvaluator.GetPointAtParam Method

Curve2dEvaluator.GetPointAtParam Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the coordinate points at the given parameter values on the curve.

Visual Basic
Sub GetPointAtParam(ByRef Params As SAFEARRAY(double), ByRef Points As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Points | Input/output double that specifies the points.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetPointAtParam Method


Curve2dEvaluator.GetSecondDerivatives Method

Curve2dEvaluator.GetSecondDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the second order derivatives at the given parameter values on the curve.

Visual Basic
Sub GetSecondDerivatives(ByRef Params As SAFEARRAY(double), ByRef SecondDerivs As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
SecondDerivs | Input/output Double array of the resulting second derivatives.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetSecondDerivatives Method


Curve2dEvaluator.GetTangent Method

Curve2dEvaluator.GetTangent Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the tangency directions at the given parameter values on the curve.

Visual Basic
Sub GetTangent(ByRef Params As SAFEARRAY(double), ByRef Tangents As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Tangents | Output Double array that returns the tangent vectors at the specified parameter values.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetTangent Method


Curve2dEvaluator.GetThirdDerivatives Method

Curve2dEvaluator.GetThirdDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the third order derivatives at the given parameter values on the curve.

Visual Basic
Sub GetThirdDerivatives(ByRef Params As SAFEARRAY(double), ByRef ThirdDerivs As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
ThirdDerivs | Output Double array of the resulting third derivatives.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Methods > Curve2dEvaluator.GetThirdDerivatives Method


Curve2dEvaluator Properties

Curve2dEvaluator Properties
Summary

The properties of the Curve2dEvaluator class are listed here.

Properties
Name | Description
Continuity | Gets the level of continuity of the curve. The continuity is the largest order of continuity maintained for the entire curve.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Properties


Curve2dEvaluator.Continuity Property

Curve2dEvaluator.Continuity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the level of continuity of the curve. The continuity is the largest order of continuity maintained for the entire curve.

Visual Basic
Property Continuity() As long*
You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Properties > Curve2dEvaluator.Continuity Property


Curve2dEvaluator.RangeBox Property

Curve2dEvaluator.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > Curve2dEvaluator Interface > Curve2dEvaluator Properties > Curve2dEvaluator.RangeBox Property


CurveAndEntityWorkPointDef Interface

CurveAndEntityWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The CurveAndEntityWorkPointDefinition object that allows you to get and set the information that specifies a work point defined by a curve and another entity.

Class Hierarchy
Inventor::CurveAndEntityWorkPointDef
Visual Basic
Public Interface CurveAndEntityWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface


CurveAndEntityWorkPointDef Methods

CurveAndEntityWorkPointDef Methods
Summary

The methods of the CurveAndEntityWorkPointDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that returns all of the data defining a work point defined by the intersection of a curve and an entity.
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Methods


CurveAndEntityWorkPointDef.GetData Method

CurveAndEntityWorkPointDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns all of the data defining a work point defined by the intersection of a curve and an entity.

Visual Basic
Sub GetData(ByRef CurveEntity As IDispatch*, ByRef Entity As IDispatch*)
Parameters
Parameters | Description
CurveEntity | Output object that returns the curve used in defining a work point at the intersection of a curve and entity. This object can be an or any 2d or 3d sketch object.
Entity | Output object that returns the or WorkPlane object used in defining a work at the intersection of a curve and entity.
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Methods > CurveAndEntityWorkPointDef.GetData Method


CurveAndEntityWorkPointDef Properties

CurveAndEntityWorkPointDef Properties
Summary

The properties of the CurveAndEntityWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CurveEntity | Property that returns the curve of a curve and entity defined work point. . This object can be an Edge or any 2d or 3d sketch object.
Entity | Property that returns the Face or WorkPlane object used in defining a work at the intersection of a curve and entity.
Parent | Property that returns the parent WorkPoint object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Properties


CurveAndEntityWorkPointDef.Application Property

CurveAndEntityWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Properties > CurveAndEntityWorkPointDef.Application Property


CurveAndEntityWorkPointDef.CurveEntity Property

CurveAndEntityWorkPointDef.CurveEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the curve of a curve and entity defined work point. . This object can be an Edge or any 2d or 3d sketch object.

Visual Basic
Property CurveEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Properties > CurveAndEntityWorkPointDef.CurveEntity Property


CurveAndEntityWorkPointDef.Entity Property

CurveAndEntityWorkPointDef.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Face or WorkPlane object used in defining a work at the intersection of a curve and entity.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Properties > CurveAndEntityWorkPointDef.Entity Property


CurveAndEntityWorkPointDef.Parent Property

CurveAndEntityWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Properties > CurveAndEntityWorkPointDef.Parent Property


CurveAndEntityWorkPointDef.Type Property

CurveAndEntityWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CurveAndEntityWorkPointDef Interface > CurveAndEntityWorkPointDef Properties > CurveAndEntityWorkPointDef.Type Property


CurveEvaluator Interface

CurveEvaluator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The CurveEvaluator object. See the article in the overviews section.

Class Hierarchy
Inventor::CurveEvaluator
Visual Basic
Public Interface CurveEvaluator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Arc3d.Evaluator

BSplineCurve.Evaluator

Circle.Evaluator

DrawingCurve.Evaluator3D

Edge.Evaluator

EllipseFull.Evaluator

EllipticalArc.Evaluator

Line.Evaluator

LineSegment.Evaluator

Polyline3d.Evaluator

See Also

True length of sweep feature sample

You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface


CurveEvaluator Methods

CurveEvaluator Methods
Summary

The methods of the CurveEvaluator class are listed here.

Methods
Methods
Name | Description
GetCurvature | Calculates the curvature direction and magnitude of the curve at the given parameter values.
GetEndPoints | Gets the end points of the curve if the curve is bounded.
GetFirstDerivatives | Calculates the first order derivatives at the given parameter values on the curve.
GetLengthAtParam | Calculate the length of the curve as measured between the specified parameter values.
GetParamAnomaly | Gets general information about the parameterization of the curve, such as whether or not it is periodic, singular, or unbounded in the parameter domain.
GetParamAtLength | Calculates the parameter value at the point measured from the specified starting parameter along the curve.
GetParamAtPoint | Calculates the parameter value on the curve that is equal to the specified point. The point must lie on the curve.
GetParamExtents | Gets the valid parameter range of the curve if the curve is bounded.
GetPointAtParam | Calculates the coordinate points at the given parameter values on the curve.
GetSecondDerivatives | Calculates the second order derivatives at the given parameter values on the curve.
GetTangent | Calculates the tangency directions at the given parameter values on the curve.
GetThirdDerivatives | Calculates the third order derivatives at the given parameter values on the curve.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods


CurveEvaluator.GetCurvature Method

CurveEvaluator.GetCurvature Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the curvature direction and magnitude of the curve at the given parameter values.

Visual Basic
Sub GetCurvature(ByRef Params As SAFEARRAY(double), ByRef Directions As SAFEARRAY(double), ByRef Curvatures As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Directions | Input/output Double that specifies the directions of the curvatures.
Curvatures | Input/output Double that specifies the curvature.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetCurvature Method


CurveEvaluator.GetEndPoints Method

CurveEvaluator.GetEndPoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the end points of the curve if the curve is bounded.

Visual Basic
Sub GetEndPoints(ByRef StartPoint As SAFEARRAY(double), ByRef EndPoint As SAFEARRAY(double))
Parameters
Parameters | Description
StartPoint | Input/output Double that specifies the start point.
EndPoint | Input/output Double that specifies the end point.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetEndPoints Method


CurveEvaluator.GetFirstDerivatives Method

CurveEvaluator.GetFirstDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the first order derivatives at the given parameter values on the curve.

Visual Basic
Sub GetFirstDerivatives(ByRef Params As SAFEARRAY(double), ByRef FirstDerivs As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
FirstDerivs | Input/output Double array of the resulting first derivatives.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetFirstDerivatives Method


CurveEvaluator.GetLengthAtParam Method

CurveEvaluator.GetLengthAtParam Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculate the length of the curve as measured between the specified parameter values.

Visual Basic
Sub GetLengthAtParam(FromParam As double, ToParam As double, ByRef Length As double)
Parameters
Parameters | Description
FromParam | Input Double that specifies the parameter value to measure the length from.
ToParam | Input Double that specifies the parameter value to measure the length to.
Length | Output Double that returns the distance measured along the curve.
See Also

True length of sweep feature sample

You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetLengthAtParam Method


CurveEvaluator.GetParamAnomaly Method

CurveEvaluator.GetParamAnomaly Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets general information about the parameterization of the curve, such as whether or not it is periodic, singular, or unbounded in the parameter domain.

Visual Basic
Sub GetParamAnomaly(ByRef Periodicity As SAFEARRAY(double), ByRef IsSingular As VARIANT_BOOL, ByRef UnboundedParam As VARIANT_BOOL)
Parameters
Parameters | Description
Periodicity | Output two element Double array that returns whether the curve is periodic. If the curve is periodic, the first array element is the period of the curve and the second element is the starting parameter of the principle period. If the curve is not periodic, the first element is zero, and the second element is unused.
IsSingular | Output Boolean that returns whether the curve is degenerate to a singularity.
UnboundedParam | Output Boolean that returns whether the curve has an unbounded parameter range.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetParamAnomaly Method


CurveEvaluator.GetParamAtLength Method

CurveEvaluator.GetParamAtLength Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the parameter value at the point measured from the specified starting parameter along the curve.

Visual Basic
Sub GetParamAtLength(FromParam As double, Length As double, ByRef Param As double)
Parameters
Parameters | Description
FromParam | Input Double that specifies the parameter value to measure the length from.
Length | Input Double that specifies the distance measured along the curve.
Param | Output Double that returns the parameter value at the specified Length from FromParam.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetParamAtLength Method


CurveEvaluator.GetParamAtPoint Method

CurveEvaluator.GetParamAtPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the parameter value on the curve that is equal to the specified point. The point must lie on the curve.

Visual Basic
Sub GetParamAtPoint(ByRef Points As SAFEARRAY(double), ByRef GuessParams As SAFEARRAY(double), ByRef MaxDeviations As SAFEARRAY(double), ByRef Params As SAFEARRAY(double), ByRef SolTypes As SAFEARRAY(SolutionNatureEnum))
Parameters
Parameters | Description
Points | Input/output double that specifies the points.
GuessParams | Input array of parameter values that are an initial guess to optimize the calculation.
MaxDeviations | Output array of Doubles that returns the maximum deviation achieved from the input points.
Params | Input/output array of Doubles that specifies the parameters.
SolTypes | Output that returns the nature of the solution found.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetParamAtPoint Method


CurveEvaluator.GetParamExtents Method

CurveEvaluator.GetParamExtents Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the valid parameter range of the curve if the curve is bounded.

Visual Basic
Sub GetParamExtents(ByRef MinParam As double, ByRef MaxParam As double)
Parameters
Parameters | Description
MinParam | Output Double that returns the minimum valid parameter value.
MaxParam | Output Double that returns the maximum valid parameter value.
See Also

True length of sweep feature sample

You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetParamExtents Method


CurveEvaluator.GetPointAtParam Method

CurveEvaluator.GetPointAtParam Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the coordinate points at the given parameter values on the curve.

Visual Basic
Sub GetPointAtParam(ByRef Params As SAFEARRAY(double), ByRef Points As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Points | Input/output double that specifies the points.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetPointAtParam Method


CurveEvaluator.GetSecondDerivatives Method

CurveEvaluator.GetSecondDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the second order derivatives at the given parameter values on the curve.

Visual Basic
Sub GetSecondDerivatives(ByRef Params As SAFEARRAY(double), ByRef SecondDerivs As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
SecondDerivs | Input/output Double array of the resulting second derivatives.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetSecondDerivatives Method


CurveEvaluator.GetTangent Method

CurveEvaluator.GetTangent Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the tangency directions at the given parameter values on the curve.

Visual Basic
Sub GetTangent(ByRef Params As SAFEARRAY(double), ByRef Tangents As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Tangents | Output Double array that returns the tangent vectors at the specified parameter values.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetTangent Method


CurveEvaluator.GetThirdDerivatives Method

CurveEvaluator.GetThirdDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the third order derivatives at the given parameter values on the curve.

Visual Basic
Sub GetThirdDerivatives(ByRef Params As SAFEARRAY(double), ByRef ThirdDerivs As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
ThirdDerivs | Output Double array of the resulting third derivatives.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Methods > CurveEvaluator.GetThirdDerivatives Method


CurveEvaluator Properties

CurveEvaluator Properties
Summary

The properties of the CurveEvaluator class are listed here.

Properties
Name | Description
Continuity | Gets the level of continuity of the curve. The continuity is the largest order of continuity maintained for the entire curve.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Properties


CurveEvaluator.Continuity Property

CurveEvaluator.Continuity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the level of continuity of the curve. The continuity is the largest order of continuity maintained for the entire curve.

Visual Basic
Property Continuity() As long*
You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Properties > CurveEvaluator.Continuity Property


CurveEvaluator.RangeBox Property

CurveEvaluator.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > CurveEvaluator Interface > CurveEvaluator Properties > CurveEvaluator.RangeBox Property


CurveGraphics Interface

CurveGraphics Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The CurveGraphics object defines a graphics object created using a transient curve.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::CurveGraphics
Visual Basic
Public Interface CurveGraphics
Inherits GraphicsPrimitive
Notes

Members through which this object may be accessed include:

GraphicsNode.AddCurveGraphics

See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface


CurveGraphics Methods

CurveGraphics Methods
Summary

The methods of the CurveGraphics class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
GetTransformBehavior | Method that gets the current transform behavior of the graphic object.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
SetTransformBehavior | Method that sets the transform behavior of the graphic object.
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Methods


CurveGraphics.GetCustomLineType Method

CurveGraphics.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Methods > CurveGraphics.GetCustomLineType Method


CurveGraphics.GetTransformBehavior Method

CurveGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that gets the current transform behavior of the graphic object.

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point object that returns the anchor point of the graphic object in model space. The coordinates of this point are always defined in model space. The value of this argument is irrelevant when the behavior type to kNoTransformBehaviors.
BehaviorType | Output value from DisplayTransformBehaviorEnum that returns the type of transform behavior the text has. Valid values are kFrontFacing, kFrontFacingAndPixelScaling, kNoTransformBehaviors, and kPixelScaling. TextGraphics objects are always front facing regardless of the defined behavior type.
PixelScale | Output Double that returns the scale factor to apply to all coordinates associated with this graphics object. The scale factor is only relevant when the object has pixel scaling behavior.
Remarks

Graphic objects have two special transform behaviors: front facing and pixel scaling. A front facing object does not rotate as the view is rotated but maintains the same orientation on the screen. It is positioned at a specified location within model and its position on the screen will change as the view is zoomed in and out and scrolled, but its orientation will not change. A graphic object that has pixel scaling behavior maintains the same size relative to the screen. As the user zooms in and out the graphic objects visible size on the screen will remain the same. By default an object has no transform behavior, which means its size, position, and orientation are relative to model space. Text always has front facing behavior regardless of the behavior type returned through this method.

You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Methods > CurveGraphics.GetTransformBehavior Method


CurveGraphics.SetCustomLineType Method

CurveGraphics.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Methods > CurveGraphics.SetCustomLineType Method


CurveGraphics.SetTransformBehavior Method

CurveGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the transform behavior of the graphic object.

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input Point object that specifies the anchor point of the graphic object in model space. The coordinates of this point are always defined in model space. The value of this argument is ignored when setting the behavior type to kNoTransformBehaviors.
BehaviorType | Input value from DisplayTransformBehaviorEnum that specifies the type of transform behavior the text has. Valid values are kFrontFacing, kFrontFacingAndPixelScaling, kNoTransformBehaviors, and kPixelScaling. TextGraphics objects are always front facing regardless of the defined behavior type.
PixelScale | Input Double that defines the scale factor to apply to all coordinates associated with this graphics object. This scale factor is only used when the behavior type is kFrontFacingAndPixelScaling or kPixelScaling.
Remarks

Graphic objects have two special transform behaviors: front facing and pixel scaling. A front facing object does not rotate as the view is rotated but maintains the same orientation on the screen. It is positioned at a specified location within model and its position on the screen will change as the view is zoomed in and out and scrolled, but its orientation will not change. A graphic object that has pixel scaling behavior maintains the same size relative to the screen. As the user zooms in and out the graphic objects visible size on the screen will remain the same. Any graphic object can have no transform behavior which means it's size, position, and orientation are relative to model space, front facing behavior, pixel scaling behavior, or front facing and pixel scaling behavior. By default an object has not transform behavior, with the exception of text. Text always has front facing behavior regardless of the behavior type set through this method.

You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Methods > CurveGraphics.SetTransformBehavior Method


CurveGraphics Properties

CurveGraphics Properties
Summary

The properties of the CurveGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
Color | Property that gets and sets the color associated with the primitive. If no color set is defined, the render style color defined for the GraphicsNode will be used. This property can be set to Nothing to remove the reference to a color and return to using the colors defined by the display style of the GraphicsNode.
Curve | Property that gets and sets the curve associated with this primitive. This can be one of the following: LineSegment, Circle, Arc3d, EllipseFull, EllipticalArc, BSplineCurve and Polyline3d.
CurveType | Property that returns the type of the underlying curve geometry that defines this curve.
DepthPriority | Property that allows you to specify a display priority to the line graphics. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type associated with the primitive.
LineWeight | Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties


CurveGraphics.BurnThrough Property

CurveGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.BurnThrough Property


CurveGraphics.Color Property

CurveGraphics.Color Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the color associated with the primitive. If no color set is defined, the render style color defined for the GraphicsNode will be used. This property can be set to Nothing to remove the reference to a color and return to using the colors defined by the display style of the GraphicsNode.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.Color Property


CurveGraphics.Curve Property

CurveGraphics.Curve Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the curve associated with this primitive. This can be one of the following: LineSegment, Circle, Arc3d, EllipseFull, EllipticalArc, BSplineCurve and Polyline3d.

Visual Basic
Property Curve() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.Curve Property


CurveGraphics.CurveType Property

CurveGraphics.CurveType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the type of the underlying curve geometry that defines this curve.

Visual Basic
Property CurveType() As CurveTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.CurveType Property


CurveGraphics.DepthPriority Property

CurveGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that allows you to specify a display priority to the line graphics. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.DepthPriority Property


CurveGraphics.LineDefinitionSpace Property

CurveGraphics.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.LineDefinitionSpace Property


CurveGraphics.LineScale Property

CurveGraphics.LineScale Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.LineScale Property


CurveGraphics.LineType Property

CurveGraphics.LineType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line type associated with the primitive.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.LineType Property


CurveGraphics.LineWeight Property

CurveGraphics.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > CurveGraphics Interface > CurveGraphics Properties > CurveGraphics.LineWeight Property


CustomConstraint Interface

CustomConstraint Interface
Summary

The CustomConstraint object represents a custom constraint for a sketch entity.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::CustomConstraint
        Inventor::CustomConstraintProxy
Visual Basic
Public Interface CustomConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToCustomConstraint

AssemblyConstraints.AddCustomConstraint

CustomConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint Interface


CustomConstraint Properties

CustomConstraint Properties
Summary

The properties of the CustomConstraint class are listed here.

Properties
Name | Description
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint Interface > CustomConstraint Properties


CustomConstraint.ClientId Property

CustomConstraint.ClientId Property
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint Interface > CustomConstraint Properties > CustomConstraint.ClientId Property


CustomConstraint3D Interface

CustomConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The CustomConstraint3D object represents a custom constraint for a 3D sketch entity.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::CustomConstraint3D
        Inventor::CustomConstraint3DProxy
Visual Basic
Public Interface CustomConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

CustomConstraint3DProxy.NativeObject

GeometricConstraints3D.AddCustom

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3D Interface


CustomConstraint3D Properties

CustomConstraint3D Properties
Summary

The properties of the CustomConstraint3D class are listed here.

Properties
Name | Description
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
Entity | Property that returns the entity to which this custom constraint has been applied.
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3D Interface > CustomConstraint3D Properties


CustomConstraint3D.ClientId Property

CustomConstraint3D.ClientId Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3D Interface > CustomConstraint3D Properties > CustomConstraint3D.ClientId Property


CustomConstraint3D.Entity Property

CustomConstraint3D.Entity Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the entity to which this custom constraint has been applied.

Visual Basic
Property Entity() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3D Interface > CustomConstraint3D Properties > CustomConstraint3D.Entity Property


CustomConstraint3DProxy Interface

CustomConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CustomConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::CustomConstraint3D
        Inventor::CustomConstraint3DProxy
Visual Basic
Public Interface CustomConstraint3DProxy
Inherits CustomConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3DProxy Interface


CustomConstraint3DProxy Properties

CustomConstraint3DProxy Properties
Summary

The properties of the CustomConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3DProxy Interface > CustomConstraint3DProxy Properties


CustomConstraint3DProxy.ContainingOccurrence Property

CustomConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3DProxy Interface > CustomConstraint3DProxy Properties > CustomConstraint3DProxy.ContainingOccurrence Property


CustomConstraint3DProxy.NativeObject Property

CustomConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CustomConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraint3DProxy Interface > CustomConstraint3DProxy Properties > CustomConstraint3DProxy.NativeObject Property


CustomConstraintProxy Interface

CustomConstraintProxy Interface
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CustomConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::CustomConstraint
        Inventor::CustomConstraintProxy
Visual Basic
Public Interface CustomConstraintProxy
Inherits CustomConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraintProxy Interface


CustomConstraintProxy Properties

CustomConstraintProxy Properties
Summary

The properties of the CustomConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > CustomConstraintProxy Interface > CustomConstraintProxy Properties


CustomConstraintProxy.ContainingOccurrence Property

CustomConstraintProxy.ContainingOccurrence Property
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraintProxy Interface > CustomConstraintProxy Properties > CustomConstraintProxy.ContainingOccurrence Property


CustomConstraintProxy.NativeObject Property

CustomConstraintProxy.NativeObject Property
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As CustomConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > CustomConstraintProxy Interface > CustomConstraintProxy Properties > CustomConstraintProxy.NativeObject Property


CustomParameterGroup Interface

CustomParameterGroup Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The CustomParameterGroup object represents a grouping of certain parameters in the parameters dialog. These groups serve as a logical grouping of parameters to allow the user to more easily find a specific parameter.

Class Hierarchy
Inventor::CustomParameterGroup
Visual Basic
Public Interface CustomParameterGroup
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CustomParameterGroups.Add

CustomParameterGroups.Item

See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface


CustomParameterGroup Methods

CustomParameterGroup Methods
Summary

The methods of the CustomParameterGroup class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a parameter to the group. Adding a parameter to a group does not remove it from group(s) that it currently resides in.
Delete | Method that deletes the group and optionally deletes the parameters that it contains.
Item | Property that returns the specified Parameter object.
Remove | Method that removes a parameter from the group. This does not delete the parameter.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Methods


CustomParameterGroup.Add Method

CustomParameterGroup.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that adds a parameter to the group. Adding a parameter to a group does not remove it from group(s) that it currently resides in.

Visual Basic
Sub Add(Parameter As Parameter)
Parameters
Parameters | Description
Parameter | Input Parameter object that represents the parameter to be added to this group.
Example

"Creating a new parameter group."

"This sample demonstrates the creation of model, reference and user parameters and copying these parameters to a newly created group."

Public Sub CreateParametersAndGroup()

    ' Create a new Part document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the compdef.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a model parameter
    Dim oModelParam As ModelParameter
    Set oModelParam = oCompDef.Parameters.ModelParameters.AddByValue(2, kCentimeterLengthUnits)

    ' Create a reference parameter
    Dim oReferenceParam As ReferenceParameter
    Set oReferenceParam = oCompDef.Parameters.ReferenceParameters.AddByValue(4, kCentimeterLengthUnits)

    ' Create a user parameter
    Dim oUserParam As UserParameter
    Set oUserParam = oCompDef.Parameters.UserParameters.AddByValue("length", 6, kCentimeterLengthUnits)

    ' Create a new custom parameter group
    Dim oCustomParamGroup As CustomParameterGroup
    Set oCustomParamGroup = oCompDef.Parameters.CustomParameterGroups.Add("Custom Group", "CustomGroup1")

    ' Add the created parameters to this group
    ' Note that adding the parameters to the custom group
    ' does not remove it from the original group.
    Call oCustomParamGroup.Add(oModelParam)
    Call oCustomParamGroup.Add(oReferenceParam)
    Call oCustomParamGroup.Add(oUserParam)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Methods > CustomParameterGroup.Add Method


CustomParameterGroup.Delete Method

CustomParameterGroup.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the group and optionally deletes the parameters that it contains.

Visual Basic
Sub Delete(ByRef DeleteParameters As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
DeleteParameters | Optional input Boolean value that indicates whether or not to additionally delete the parameters contained in the group. A value of True specifies that the parameters should be deleted. If not specified, a default of False is used indicating that the parameters in the group will not be deleted.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Methods > CustomParameterGroup.Delete Method


CustomParameterGroup.Item Method

CustomParameterGroup.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Parameter object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Parameter*)
Parameters
Parameters | Description
index | Input Long value that indicates the index of the Parameter to return. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Methods > CustomParameterGroup.Item Method


CustomParameterGroup.Remove Method

CustomParameterGroup.Remove Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that removes a parameter from the group. This does not delete the parameter.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Input Long that specifies the index of the item within the list to be removed from this group.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Methods > CustomParameterGroup.Remove Method


CustomParameterGroup Properties

CustomParameterGroup Properties
Summary

The properties of the CustomParameterGroup class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
Count | Property that returns the number of parameters in this group.
DisabledActionTypes | Property that gets and sets the disabling of certain user actions on this object. Currently, only kDeleteAction is supported.
DisplayName | Property that gets and sets the display name of the custom group. This is the name displayed to the user and can vary between locales.
InternalName | Property that returns the name of the custom group. The name is the internal English name of the group. This name will remain constant and is not affected by locale. The name is never displayed to the user. The display name is what's shown to the user.
Type | Property returning kCustomParameterGroupObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties


CustomParameterGroup.Application Property

CustomParameterGroup.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.Application Property


CustomParameterGroup.ClientId Property

CustomParameterGroup.ClientId Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.ClientId Property


CustomParameterGroup.Count Property

CustomParameterGroup.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of parameters in this group.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.Count Property


CustomParameterGroup.DisabledActionTypes Property

CustomParameterGroup.DisabledActionTypes Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the disabling of certain user actions on this object. Currently, only kDeleteAction is supported.

Visual Basic
Property DisabledActionTypes() As ActionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.DisabledActionTypes Property


CustomParameterGroup.DisplayName Property

CustomParameterGroup.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the display name of the custom group. This is the name displayed to the user and can vary between locales.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.DisplayName Property


CustomParameterGroup.InternalName Property

CustomParameterGroup.InternalName Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the name of the custom group. The name is the internal English name of the group. This name will remain constant and is not affected by locale. The name is never displayed to the user. The display name is what's shown to the user.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.InternalName Property


CustomParameterGroup.Type Property

CustomParameterGroup.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kCustomParameterGroupObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroup Interface > CustomParameterGroup Properties > CustomParameterGroup.Type Property


CustomParameterGroups Interface

CustomParameterGroups Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The CustomParameterGroups collection object provides access to all existing custom parameter groups and provides methods to create additional groups

Class Hierarchy
Inventor::CustomParameterGroups
Visual Basic
Public Interface CustomParameterGroups
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameters.CustomParameterGroups

See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface


CustomParameterGroups Methods

CustomParameterGroups Methods
Summary

The methods of the CustomParameterGroups class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a custom parameter group.
Item | Property that returns the specified CustomParameterGroup object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Methods


CustomParameterGroups.Add Method

CustomParameterGroups.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that adds a custom parameter group.

Visual Basic
Sub Add(DisplayName As String, InternalName As String, ByRef ClientId As [defaultvalue("")] BSTR, Result As [out, retval] CustomParameterGroup*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the custom group. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the name of the custom group. This is the internal name and is not displayed to the user. The name must be unique with respect to all other groups. The name should remain constant in all locales to it can be used to find a specific group.
ClientId | Optional input string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Methods > CustomParameterGroups.Add Method


CustomParameterGroups.Item Method

CustomParameterGroups.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified CustomParameterGroup object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CustomParameterGroup*)
Parameters
Parameters | Description
index | Input Variant that specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection or a String indicating the name of the CustomParameterGroup. If the specified name does not exist, a failure occurs.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Methods > CustomParameterGroups.Item Method


CustomParameterGroups Properties

CustomParameterGroups Properties
Summary

The properties of the CustomParameterGroups class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kCustomParameterGroupsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Properties


CustomParameterGroups.Application Property

CustomParameterGroups.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Properties > CustomParameterGroups.Application Property


CustomParameterGroups.Count Property

CustomParameterGroups.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Properties > CustomParameterGroups.Count Property


CustomParameterGroups.Type Property

CustomParameterGroups.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kCustomParameterGroupsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CustomParameterGroups Interface > CustomParameterGroups Properties > CustomParameterGroups.Type Property


CustomPropertyFormat Interface

CustomPropertyFormat Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The CustomPropertyFormat provides control over how the parameter value is formatted when it is exposed as a custom iProperty.

Class Hierarchy
Inventor::CustomPropertyFormat
Visual Basic
Public Interface CustomPropertyFormat
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameter.CustomPropertyFormat

You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface


CustomPropertyFormat Properties

CustomPropertyFormat Properties
Summary

The properties of the CustomPropertyFormat class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent Parameter object.
Precision | Property that specifies the precision to use when formatting the parameter value to be displayed as an iProperty. The precision value chosen must be compatible with the current unit type or setting this property will fail.
PropertyType | Property that allows you to get and set whether the custom iProperty created for this parameter is a text (String) or number (Double) parameter.
ShowLeadingZeros | Property that specifies if leading zeros should be shown in the formatted iProperty value. This property is only valid when the PropertyType property is set to kTextPropertyType and a decimal type of precision has been specified, otherwise setting this property will fail.
ShowTrailingZeros | Property that specifies if leading zeros should be shown in the formatted iProperty value. This property is only valid when the PropertyType property is set to kTextPropertyType and a decimal type of precision has been specified, otherwise setting this property will fail.
ShowUnitsString | Property that specifies if the unit string should be shown in the formatted iProperty value. This property is only valid when the PropertyType property is set to kTextPropertyType, otherwise setting this property will fail.
Type | Returns an ObjectTypeEnum indicating this object's type.
Units | Property that specifies the units to use when formatting the parameter value to be displayed as an iProperty.
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties


CustomPropertyFormat.Application Property

CustomPropertyFormat.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.Application Property


CustomPropertyFormat.Parent Property

CustomPropertyFormat.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent Parameter object.

Visual Basic
Property Parent() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.Parent Property


CustomPropertyFormat.Precision Property

CustomPropertyFormat.Precision Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the precision to use when formatting the parameter value to be displayed as an iProperty. The precision value chosen must be compatible with the current unit type or setting this property will fail.

Visual Basic
Property Precision() As CustomPropertyPrecisionEnum
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.Precision Property


CustomPropertyFormat.PropertyType Property

CustomPropertyFormat.PropertyType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that allows you to get and set whether the custom iProperty created for this parameter is a text (String) or number (Double) parameter.

Visual Basic
Property PropertyType() As CustomPropertyTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.PropertyType Property


CustomPropertyFormat.ShowLeadingZeros Property

CustomPropertyFormat.ShowLeadingZeros Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies if leading zeros should be shown in the formatted iProperty value. This property is only valid when the PropertyType property is set to kTextPropertyType and a decimal type of precision has been specified, otherwise setting this property will fail.

Visual Basic
Property ShowLeadingZeros() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.ShowLeadingZeros Property


CustomPropertyFormat.ShowTrailingZeros Property

CustomPropertyFormat.ShowTrailingZeros Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies if leading zeros should be shown in the formatted iProperty value. This property is only valid when the PropertyType property is set to kTextPropertyType and a decimal type of precision has been specified, otherwise setting this property will fail.

Visual Basic
Property ShowTrailingZeros() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.ShowTrailingZeros Property


CustomPropertyFormat.ShowUnitsString Property

CustomPropertyFormat.ShowUnitsString Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies if the unit string should be shown in the formatted iProperty value. This property is only valid when the PropertyType property is set to kTextPropertyType, otherwise setting this property will fail.

Visual Basic
Property ShowUnitsString() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.ShowUnitsString Property


CustomPropertyFormat.Type Property

CustomPropertyFormat.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.Type Property


CustomPropertyFormat.Units Property

CustomPropertyFormat.Units Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the units to use when formatting the parameter value to be displayed as an iProperty.

Visual Basic
Property Units() As VARIANT
Remarks

When reading this property the result is always a String. When setting this property you can use either a String that defines the unit or a value from UnitsTypeEnum. The specified units must be compatible with the units of the associated parameter or setting this property will fail. For example, if the parameter is a length then any of the length units known to Inventor can be used, (i.e. millimeter, centimeter, meter, inch, foot, mile, etc.).

You are here: Symbol Reference > Inventor Library > Objects > CustomPropertyFormat Interface > CustomPropertyFormat Properties > CustomPropertyFormat.Units Property


CustomTable Interface

CustomTable Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The CustomTable object allows the creation of user-defined tables with the specified number of rows and columns, headings, content, and so on. See the Custom Tables overview for more information.

Class Hierarchy
Inventor::CustomTable
Visual Basic
Public Interface CustomTable
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Cell.Parent

Column.Parent

CustomTable.CopyTo

CustomTables.Add

CustomTables.AddBendTable

CustomTables.AddConfigurationTable

CustomTables.AddCSVTable

CustomTables.AddExcelTable

CustomTables.Item

Row.Parent

See Also

Create a drawing Excel Table sample

Create a Configuration Table sample

Create a Bend Table sample

Custom Table - create sample

Example

See CustomTables for example "Adding a new custom table"

You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface


CustomTable Methods

CustomTable Methods
Summary

The methods of the CustomTable class are listed here.

Methods
Methods
Name | Description
AddLink | Method that adds a link to the specified document. If a link to a foreign file type already exists, the link is replaced if the input is also a foreign file.
CopyTo | Method that copies the table to another sheet, either within the same document or in another document.
Delete | Method that deletes the CustomTable.
Export | Method that saves the custom table to an external file.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Renumber | Method that renumbers all rows in the table. This method applies only to bend tables and returns an error for all other tables.
Sort | Method that sorts the table.
Update | Method that updates the custom table if it is out of date with respect to its linked files. The method returns a success and returns trivially if no update is required.
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods


CustomTable.AddLink Method

CustomTable.AddLink Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that adds a link to the specified document. If a link to a foreign file type already exists, the link is replaced if the input is also a foreign file.

Visual Basic
Sub AddLink(FullFileName As String)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of the file to add a link to.
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.AddLink Method


CustomTable.CopyTo Method

CustomTable.CopyTo Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that copies the table to another sheet, either within the same document or in another document.

Visual Basic
Sub CopyTo(TargetSheet As Sheet, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
TargetSheet | Input Sheet object that specifies the sheet to copy the custom table to.
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.CopyTo Method


CustomTable.Delete Method

CustomTable.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes the CustomTable.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.Delete Method


CustomTable.Export Method

CustomTable.Export Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that saves the custom table to an external file.

Visual Basic
Sub Export(FileName As String, FileFormat As FileFormatEnum, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
FileName | Input string that specifies the file name to export the table to.
Options | Optional input NameValueMap object that specifies additional options for export. See Remarks for valid options:
Remarks

Valid values for the Options parameter:

Name | Value Type | Valid for export formats
TableName | String | kMicrosoftExcel, kMicrosoftAccess
ExportedColumns | String containing semicolon separated column titles | All
IncludeTitle | Boolean | kMicrosoftExcel, kTextFileCommaDelimited, kTextFileTabDelimited, kUnicodeTextFileCommaDelimited, kUnicodeTextFileTabDelimited
StartingCell | String | kMicrosoftExcel
Template | String | kMicrosoftExcel
AutoFitColumnWidth | Boolean | kMicrosoftExcel
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.Export Method


CustomTable.GetReferenceKey Method

CustomTable.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.GetReferenceKey Method


CustomTable.Renumber Method

CustomTable.Renumber Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that renumbers all rows in the table. This method applies only to bend tables and returns an error for all other tables.

Visual Basic
Sub Renumber()
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.Renumber Method


CustomTable.Sort Method

CustomTable.Sort Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sorts the table.

Visual Basic
Sub Sort(PrimaryColumnTitle As String, ByRef PrimaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef SecondaryColumnTitle As [defaultvalue("")] BSTR, ByRef SecondaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef TertiaryColumnTitle As [defaultvalue("")] BSTR, ByRef TertiaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
PrimaryColumnTitle | Input string that specifies the primary column to use for the sorting. If the name of a non-existing column is provided, an error occurs.
PrimaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
SecondaryColumnTitle | Optional input string that specifies the secondary column to use for the sorting. If the name of a non-existing column or the primary column is provided, an error occurs.
SecondaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
TertiaryColumnTitle | Optional input string that specifies the tertiary column to use for the sorting. If the name of a non-existing column, the primary column or the secondary column is provided, an error occurs.
TertiaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.Sort Method


CustomTable.Update Method

CustomTable.Update Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that updates the custom table if it is out of date with respect to its linked files. The method returns a success and returns trivially if no update is required.

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Methods > CustomTable.Update Method


CustomTable Properties

CustomTable Properties
Summary

The properties of the CustomTable class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BendDirectionReversed | Property that gets and sets whether the bend direction is reversed. If set to True, any DOWN direction is flipped to UP and any UP direction is flipped to DOWN. Applies to bend tables only (i.e. applies only if TableSource returns kBendTableSource). The property returns False and setting the property fails for all other table types.
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
Columns | Property that returns the Columns collection object.
DataTextStyle | Property that gets and sets the text style used for the contents of the table.
HeadingPlacement | Property that gets and sets the location of the heading. Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
Layer | Property that gets and sets the layer associated with this object.
MaximumRows | Property that gets and sets the maximum number of rows per section. Setting this property automatically toggles the WrapAutomatically property to True.
NumberOfSections | Property that gets and sets the number of columns to wrap. Setting this property automatically toggles the WrapAutomatically property to True.
OverrideFormat | Property that gets and sets the TableFormat object that specifies format overrides for the table. A TableFormat object can be created using the CreateTableFormat method on the Tables object. At least one of the properties on the TableFormat object must be set for this call to succeed. If this property is set to Nothing, all the values are set to a style default.
Parent | Property that returns the parent object from whom this object can logically be reached.
Position | Property that gets and sets the position of the table on the Sheet.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
ReferencedDocumentDescriptor | Property that returns either a DocumentDescriptor object (for Inventor references) or a FileDescriptor object (for foreign file references). The property returns Nothing if no links have been specified for the table.
Rotation | Property that gets and sets the absolute rotation angle of the table in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, 'pi/2, 'pi, and '1.5pi.
RowGap | Property that returns the row gap.
RowLineSpacing | Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.
Rows | Property that returns the Rows collection object.
ShowTitle | Property that specifies the whether to show the title of the table.
Style | Property that gets and sets the style associated with this object.
TableDirection | Property that gets and sets the direction of the table. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.
TableSource | Property that returns the source type for this table.
Title | Property that gets and sets the title of the CustomTable.
TitleTextStyle | Property that gets and sets the text style used for the title of the table.
Type | Property returning an enum indicating this object's type.
WrapAutomatically | Property that gets and sets whether to split the table equally. If set to True, the table is split equally.
WrapLeft | Property that gets and sets whether the sections of the table are moved to the left or right when the number of rows increase. A value of True indicates that sections are moved to the left.
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties


CustomTable.Application Property

CustomTable.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Application Property


CustomTable.AttributeSets Property

CustomTable.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.AttributeSets Property


CustomTable.BendDirectionReversed Property

CustomTable.BendDirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the bend direction is reversed. If set to True, any DOWN direction is flipped to UP and any UP direction is flipped to DOWN. Applies to bend tables only (i.e. applies only if TableSource returns kBendTableSource). The property returns False and setting the property fails for all other table types.

Visual Basic
Property BendDirectionReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.BendDirectionReversed Property


CustomTable.ColumnHeaderTextStyle Property

CustomTable.ColumnHeaderTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.ColumnHeaderTextStyle Property


CustomTable.Columns Property

CustomTable.Columns Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the Columns collection object.

Visual Basic
Property Columns() As Columns**
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Columns Property


CustomTable.DataTextStyle Property

CustomTable.DataTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.DataTextStyle Property


CustomTable.HeadingPlacement Property

CustomTable.HeadingPlacement Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location of the heading. Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.HeadingPlacement Property


CustomTable.Layer Property

CustomTable.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Layer Property


CustomTable.MaximumRows Property

CustomTable.MaximumRows Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the maximum number of rows per section. Setting this property automatically toggles the WrapAutomatically property to True.

Visual Basic
Property MaximumRows() As long
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.MaximumRows Property


CustomTable.NumberOfSections Property

CustomTable.NumberOfSections Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the number of columns to wrap. Setting this property automatically toggles the WrapAutomatically property to True.

Visual Basic
Property NumberOfSections() As long
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.NumberOfSections Property


CustomTable.OverrideFormat Property

CustomTable.OverrideFormat Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the TableFormat object that specifies format overrides for the table. A TableFormat object can be created using the CreateTableFormat method on the Tables object. At least one of the properties on the TableFormat object must be set for this call to succeed. If this property is set to Nothing, all the values are set to a style default.

Visual Basic
Property OverrideFormat() As TableFormat*
See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.OverrideFormat Property


CustomTable.Parent Property

CustomTable.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Parent Property


CustomTable.Position Property

CustomTable.Position Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the position of the table on the Sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Position Property


CustomTable.RangeBox Property

CustomTable.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.RangeBox Property


CustomTable.ReferencedDocumentDescriptor Property

CustomTable.ReferencedDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns either a DocumentDescriptor object (for Inventor references) or a FileDescriptor object (for foreign file references). The property returns Nothing if no links have been specified for the table.

Visual Basic
Property ReferencedDocumentDescriptor() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.ReferencedDocumentDescriptor Property


CustomTable.Rotation Property

CustomTable.Rotation Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the absolute rotation angle of the table in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, 'pi/2, 'pi, and '1.5pi.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Rotation Property


CustomTable.RowGap Property

CustomTable.RowGap Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the row gap.

Visual Basic
Property RowGap() As double*
Remarks

This value is obtained from the table style.

You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.RowGap Property


CustomTable.RowLineSpacing Property

CustomTable.RowLineSpacing Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.

Visual Basic
Property RowLineSpacing() As LineSpacingEnum
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.RowLineSpacing Property


CustomTable.Rows Property

CustomTable.Rows Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the Rows collection object.

Visual Basic
Property Rows() As Rows**
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Rows Property


CustomTable.ShowTitle Property

CustomTable.ShowTitle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the whether to show the title of the table.

Visual Basic
Property ShowTitle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.ShowTitle Property


CustomTable.Style Property

CustomTable.Style Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the style associated with this object.

Visual Basic
Property Style() As TableStyle*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Style Property


CustomTable.TableDirection Property

CustomTable.TableDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the direction of the table. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.

Visual Basic
Property TableDirection() As TableDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.TableDirection Property


CustomTable.TableSource Property

CustomTable.TableSource Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the source type for this table.

Visual Basic
Property TableSource() As TableSourceTypeEnum*
Remarks

Possible return values are kNoTableSource, kBendTableSource, kConfigurationTableSource, kExcelTableSource and kCSVTableSource.

You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.TableSource Property


CustomTable.Title Property

CustomTable.Title Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the title of the CustomTable.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Title Property


CustomTable.TitleTextStyle Property

CustomTable.TitleTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the title of the table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.TitleTextStyle Property


CustomTable.Type Property

CustomTable.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.Type Property


CustomTable.WrapAutomatically Property

CustomTable.WrapAutomatically Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to split the table equally. If set to True, the table is split equally.

Visual Basic
Property WrapAutomatically() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.WrapAutomatically Property


CustomTable.WrapLeft Property

CustomTable.WrapLeft Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the sections of the table are moved to the left or right when the number of rows increase. A value of True indicates that sections are moved to the left.

Visual Basic
Property WrapLeft() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > CustomTable Interface > CustomTable Properties > CustomTable.WrapLeft Property


CustomTables Interface

CustomTables Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The CustomTables object contains the collection of objects for a given Sheet. See the Custom Tables overview for more information.

Class Hierarchy
Inventor::CustomTables
Visual Basic
Public Interface CustomTables
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.CustomTables

See Also

Create a drawing Excel Table sample

Create a Configuration Table sample

Create a Bend Table sample

Example

"Custom Table - create Example "

This sample demonstrates how to create a custom table.

Public Sub CreateCustomTable()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Set the column titles
    Dim oTitles(1 To 3) As String
    oTitles(1) = "Part Number"
    oTitles(2) = "Quantity"
    oTitles(3) = "Material"

    ' Set the contents of the custom table (contents are set row-wise)
    Dim oContents(1 To 9) As String
    oContents(1) = "1"
    oContents(2) = "1"
    oContents(3) = "Brass"
    oContents(4) = "2"
    oContents(5) = "2"
    oContents(6) = "Aluminium"
    oContents(7) = "3"
    oContents(8) = "1"
    oContents(9) = "Steel"

    ' Set the column widths (defaults to the column title width if not specified)
    Dim oColumnWidths(1 To 3) As Double
    oColumnWidths(1) = 2.5
    oColumnWidths(2) = 2.5
    oColumnWidths(3) = 4

    ' Create the custom table
    Dim oCustomTable As CustomTable
    Set oCustomTable = oSheet.CustomTables.Add("My Table", ThisApplication.TransientGeometry.CreatePoint2d(15, 15), _
                                        3, 3, oTitles, oContents, oColumnWidths)

    ' Change the 3rd column to be left justified.
    oCustomTable.Columns.Item(3).ValueHorizontalJustification = kAlignTextLeft

    ' Create a table format object
    Dim oFormat As TableFormat
    Set oFormat = oSheet.CustomTables.CreateTableFormat

    ' Set inside line color to red.
    oFormat.InsideLineColor = ThisApplication.TransientObjects.CreateColor(255, 0, 0)

    ' Set outside line weight.
    oFormat.OutsideLineWeight = 0.1

    ' Modify the table formats
    oCustomTable.OverrideFormat = oFormat
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface


CustomTables Methods

CustomTables Methods
Summary

The methods of the CustomTables class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new CustomTable. The new created CustomTable is returned.
AddBendTable | Method that creates a new bend table. The newly created CustomTable is returned.
AddConfigurationTable | Method that creates a new configuration (iPart/iAssembly) table. The newly created CustomTable is returned.
AddCSVTable | Method that creates a new custom table based on a CSV (comma delimited) file. The newly created CustomTable is returned.
AddExcelTable | Method that creates a new custom table based on an excel file. The newly created CustomTable is returned.
CreateTableFormat | Method that creates a TableFormat object.
Item | Property that returns the specified object in the collection.
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods


CustomTables.Add Method

CustomTables.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new CustomTable. The new created CustomTable is returned.

Visual Basic
Sub Add(Title As String, PlacementPoint As Point2d, NumberOfColumns As long, NumberOfRows As long, ByRef ColumnTitles As SAFEARRAY(BSTR), ByRef Contents As [optional] VARIANT, ByRef ColumnWidths As [optional] VARIANT, ByRef RowHeights As [optional] VARIANT, ByRef MoreInfo As [optional] VARIANT, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
Title | String that specifies the title (or the header) of the table.
PlacementPoint | Input Point2d object that defines the placement point of the table.
NumberOfColumns | Input Long that specifies the number of columns in the table.
NumberOfRows | Input Long that specifies the number of rows in the table.
ColumnTitles | Array of Strings that specifies the titles of the columns. The number of strings should be equal to the number of columns, else an error will occur.
Contents | Optional input String array that specifies the contents of the table. The number of Strings must match the number of cells in the table, else an error will occur. This array of String is used to sequentially populate each row of the table.
ColumnWidths | Optional input array of Doubles that specifies the width of the columns. The number of doubles specified must be equal to the number of columns, else an error will occur. If not specified, a default value is used.
RowHeights | Optional input array of Doubles that specifies the height of the rows. The number of doubles specified must be equal to the number of rows, else an error will occur. If not specified, a default value is used.
MoreInfo | Optional input NameValueMap that specifies additional information for the table creation. This argument is currently ignored.
See Also

Custom Table - create sample

Example

See CustomTables for example "Adding a new custom table"

You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.Add Method


CustomTables.AddBendTable Method

CustomTables.AddBendTable Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new bend table. The newly created CustomTable is returned.

Visual Basic
Sub AddBendTable(SheetMetalFileName As String, PlacementPoint As Point2d, ByRef Title As [defaultvalue("")] BSTR, ByRef Columns As [optional] VARIANT, ByRef BendIDNumericFormat As [defaultvalue(-1)] VARIANT_BOOL, ByRef BendIDPrefix As [defaultvalue("")] BSTR, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
SheetMetalFileName | Input String that specifies the full file name of the sheet metal file to create the bend table from. The input file name must be that of a sheet metal file with a flat pattern created in it, else an error will occur.
PlacementPoint | Input Point2d object that defines the placement point of the table on the sheet.
Title | Optional input String that specifies the title (or the header) of the table.
Columns | Optional input array of Strings that specifies the columns of the bend table. The strings can be any or all of the following in any order: 'BEND ID', 'BEND DIRECTION', 'BEND ANGLE', 'BEND RADIUS' and 'BEND KFACTOR'. If not specified, all the five columns are created.
BendIDNumericFormat | Optional input Boolean that specifies whether the format of the Bend ID is alphabetic or numeric. If not specified, a value of True is used indicating that numeric format will be used.
BendIDPrefix | Optional input String that specifies a prefix for the Bend IDs.
Example

"Create a Bend Table"

This sample demonstrates the creation of a bend table in a drawing from a sheet metal part. Change the location of the source part in the code below before running the sample.

Public Sub CreateBendTable()

    ' Set a reference to the active drawing document
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Create the placement point for the table
    Dim oPoint As Point2d
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint2d(25, 25)

    ' Specify the columns - this can be specified in any combination/order
    Dim strColumns(1 To 5) As String
    strColumns(1) = "BEND ID"
    strColumns(2) = "BEND RADIUS"
    strColumns(3) = "BEND ANGLE"
    strColumns(4) = "BEND KFACTOR"
    strColumns(5) = "BEND DIRECTION"

    ' Create the bend table by specifying the source sheet metal file
    Dim oBendTable As CustomTable
    Set oBendTable = oActiveSheet.CustomTables.AddBendTable("C:\Temp\SheetMetal.ipt", oPoint, "Bend Table", strColumns)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.AddBendTable Method


CustomTables.AddConfigurationTable Method

CustomTables.AddConfigurationTable Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new configuration (iPart/iAssembly) table. The newly created CustomTable is returned.

Visual Basic
Sub AddConfigurationTable(ConfigurationFileName As String, PlacementPoint As Point2d, ByRef Title As [defaultvalue("")] BSTR, ByRef Columns As [optional] VARIANT, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
ConfigurationFileName | Input String that specifies the full file name of the configuration file to create the configuration table from. The file can be an iPart, an iAssembly, or a Presentation file which contains views of an iPart or an iAssembly.
PlacementPoint | Input Point2d object that defines the placement point of the table on the sheet.
Title | Optional input String that specifies the title (or the header) of the table.
Columns | Optional input array of Strings that specifies the columns of the configuration table. The strings specified must be the headings of the columns from the iPart or the iAssembly (obtained using iPartTableColumn.Heading or iAssemblyTableColumn.Heading properties). If not specified, only the 'Member' column is used to create the table.
Example

"Create a Configuration Table"

This sample demonstrates the creation of a configuration (iPart/iAssembly) table in a drawing from a factory document. Change the location of the source part in the code below before running the sample.

Public Sub CreateConfigurationTable()

    ' Set a reference to the active drawing document
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Create the placement point for the table
    Dim oPoint As Point2d
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint2d(25, 25)

    ' Open the factory document invisible
    Dim oiPartDoc As PartDocument
    Set oiPartDoc = ThisApplication.Documents.Open("C:\Temp\iPartFactory.ipt", False)

    Dim oiPartFactory As iPartFactory
    Set oiPartFactory = oiPartDoc.ComponentDefinition.iPartFactory

    ' Specify the columns - this sample includes all columns from the factory table
    Dim strColumns() As String
    Redim strColumns(oiPartFactory.TableColumns.Count - 1)

    Dim i As Long
    For i = 1 To oiPartFactory.TableColumns.Count
        strColumns(i - 1) = oiPartFactory.TableColumns.Item(i).Heading
    Next

    ' Release reference on factory document since we opened it invisible
    oiPartDoc.ReleaseReference

    ' Create the configuration table by specifying the source iPart/iAssembly file
    Dim oConfigTable As CustomTable
    Set oConfigTable = oActiveSheet.CustomTables.AddConfigurationTable("C:\Temp\iPartFactory.ipt", oPoint, "Configuration Table", strColumns)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.AddConfigurationTable Method


CustomTables.AddCSVTable Method

CustomTables.AddCSVTable Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new custom table based on a CSV (comma delimited) file. The newly created CustomTable is returned.

Visual Basic
Sub AddCSVTable(CSVFileName As String, PlacementPoint As Point2d, ByRef Title As [defaultvalue("")] BSTR, ByRef UseFirstRowForHeaders As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
CSVFileName | Input String that specifies the full file name of the CSV (comma delimited) file.
PlacementPoint | Input Point2d object that defines the placement point of the table on the sheet.
Title | Optional input String that specifies the title (or the header) of the table.
UseFirstRowForHeaders | Optional input Boolean that specifies whether to use the first row for column headers. If not specified, this argument defaults to True.
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.AddCSVTable Method


CustomTables.AddExcelTable Method

CustomTables.AddExcelTable Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new custom table based on an excel file. The newly created CustomTable is returned.

Visual Basic
Sub AddExcelTable(ExcelFileName As String, PlacementPoint As Point2d, ByRef Title As [defaultvalue("")] BSTR, ByRef StartCell As [defaultvalue("A2")] BSTR, ByRef ColumnHeaderRow As [defaultvalue(1)] long, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
ExcelFileName | Input String that specifies the full file name of the excel file.
PlacementPoint | Input Point2d object that defines the placement point of the table on the sheet.
Title | Optional input String that specifies the title (or the header) of the table.
StartCell | Optional input String that specifies the start cell of the data in the excel file. If not specified, the cell 'A2' is used as the start cell.
ColumnHeaderRow | Optional input Long that specifies the header row in the excel file. If not specified, the first row in the excel file is assumed to be the header row.
Example

"Create a drawing Excel Table"

This sample demonstrates the creation of a table based on an Excel file in a drawing. Change the location of the source Excel file in the code below before running the sample.

Public Sub CreateDrawingExcelTable()

    ' Set a reference to the active drawing document
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Create the placement point for the table
    Dim oPoint As Point2d
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint2d(25, 25)

    ' Create the table by specifying the source Excel file
    ' This assumes that the first row in the Excel sheet specifies the column headers
    ' You can specify a different row using the last argument of the AddExcelTable method
    Dim oExcelTable As CustomTable
    Set oExcelTable = oActiveSheet.CustomTables.AddExcelTable("C:\Temp\test.xls", oPoint, "Excel Table")
End Sub
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.AddExcelTable Method


CustomTables.CreateTableFormat Method

CustomTables.CreateTableFormat Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a TableFormat object.

Visual Basic
Sub CreateTableFormat(Result As [out, retval] TableFormat*)
See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.CreateTableFormat Method


CustomTables.Item Method

CustomTables.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] CustomTable*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Methods > CustomTables.Item Method


CustomTables Properties

CustomTables Properties
Summary

The properties of the CustomTables class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Properties


CustomTables.Application Property

CustomTables.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Properties > CustomTables.Application Property


CustomTables.Count Property

CustomTables.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Properties > CustomTables.Count Property


CustomTables.Type Property

CustomTables.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CustomTables Interface > CustomTables Properties > CustomTables.Type Property


CutAcrossBendsExtent Interface

CutAcrossBendsExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CutAcrossBendsExtent object represents the extent definition for a sheet metal cut feature that cuts across the bends of the part.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::CutAcrossBendsExtent
Visual Basic
Public Interface CutAcrossBendsExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > CutAcrossBendsExtent Interface


CutAcrossBendsExtent Properties

CutAcrossBendsExtent Properties
Summary

The properties of the CutAcrossBendsExtent class are listed here.

Properties
Name | Description
Distance | Property that returns the parameter controlling the depth of the cut.
You are here: Symbol Reference > Inventor Library > Objects > CutAcrossBendsExtent Interface > CutAcrossBendsExtent Properties


CutAcrossBendsExtent.Distance Property

CutAcrossBendsExtent.Distance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the depth of the cut.

Visual Basic
Property Distance() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > CutAcrossBendsExtent Interface > CutAcrossBendsExtent Properties > CutAcrossBendsExtent.Distance Property


CutDefinition Interface

CutDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The CutDefinition object represents all of the information that defines a cut feature.

Class Hierarchy
Inventor::CutDefinition
Visual Basic
Public Interface CutDefinition
Inherits IDispatch
Remarks

The CutDefinition object is used in two ways. First it is used as input when creating a cut feature. Second it is used to query and edit existing cut features. When creating a new cut feature you use the CutFeatures.CreateCutDefinition method to create a new CutDefinition object. Using the properties of this object you can define the various options of the cut feature. Typically a new CutDefinition object is created and modified to get the desired face feature and then used as input to the CutFeatures.Add method. An existing CutFeature object is edited by modifying its associated CutDefinition object.

Notes

Members through which this object may be accessed include:

CutFeature.Definition

CutFeatures.CreateCutDefinition

See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface


CutDefinition Methods

CutDefinition Methods
Summary

The methods of the CutDefinition class are listed here.

Methods
Methods
Name | Description
SetCutAcrossBendsExtent | Method that changes the cut to cut across bends.
SetDistanceExtent | Method that changes the extent to be a distance extent.
SetFromToExtent | Method that changes the extent to be a 'from to' extent.
SetThroughAllExtent | Method that changes the extent to be a 'to next' extent.
SetToExtent | Method that changes the extent to be a 'to' extent.
SetToNextExtent | Method that changes the extent to be a 'to next' extent.
You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods


CutDefinition.SetCutAcrossBendsExtent Method

CutDefinition.SetCutAcrossBendsExtent Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that changes the cut to cut across bends.

Visual Basic
Sub SetCutAcrossBendsExtent(Distance As VARIANT)
Parameters
Parameters | Description
Distance | Input Variant that defines the depth of the cut. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

Calling this method for a CutDefinition object that was obtained from an existing cut feature will cause the cut feature to update with the change.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods > CutDefinition.SetCutAcrossBendsExtent Method


CutDefinition.SetDistanceExtent Method

CutDefinition.SetDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that changes the extent to be a distance extent.

Visual Basic
Sub SetDistanceExtent(Distance As VARIANT, Direction As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Distance | Input Variant that defines the depth of the cut. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Direction | Input PartFeatureExtentDirectionEnum value to indicate which side of the sketch the cut should be. The value kPositiveExtentDirection defines the cut direction to be in the same direction as the normal of the sketch plane.
Remarks

Calling this method for a CutDefinition object that was obtained from an existing cut feature will cause the cut feature to update with the change.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods > CutDefinition.SetDistanceExtent Method


CutDefinition.SetFromToExtent Method

CutDefinition.SetFromToExtent Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that changes the extent to be a 'from to' extent.

Visual Basic
Sub SetFromToExtent(FromFace As IDispatch, ExtendFromFace As VARIANT_BOOL, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL)
Parameters
Parameters | Description
FromFace | Input Object that defines the 'from face'. This can be either a face or work plane. The same limitations for the 'from' face that exist when creating a cut feature interactively through the command exist when using the API to create a cut feature.
ExtendFromFace | Input Boolean that defines whether the 'from face' should be extended to contain the extents of the profile.
ToFace | Input Object that defines the 'to face'. This can be either a face or work plane. The same limitations for the 'to' plane that exist when creating a cut feature interactively through the command exist when using the API to create a cut feature.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
Remarks

Calling this method for a CutDefinition object that was obtained from an existing cut feature will cause the cut feature to update with the change.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods > CutDefinition.SetFromToExtent Method


CutDefinition.SetThroughAllExtent Method

CutDefinition.SetThroughAllExtent Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that changes the extent to be a 'to next' extent.

Visual Basic
Sub SetThroughAllExtent(Direction As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Direction | Input PartFeatureExtentDirectionEnum value to indicate which side of the sketch the cut should be. The value kPositiveExtentDirection defines the cut direction to be in the same direction as the normal of the sketch plane.
Remarks

Calling this method for a CutDefinition object that was obtained from an existing cut feature will cause the cut feature to update with the change.

See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods > CutDefinition.SetThroughAllExtent Method


CutDefinition.SetToExtent Method

CutDefinition.SetToExtent Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that changes the extent to be a 'to' extent.

Visual Basic
Sub SetToExtent(ToFace As IDispatch, ExtendToFace As VARIANT_BOOL)
Parameters
Parameters | Description
ToFace | Input Object that defines the 'to face'. This can be either a face or work plane. The same limitations for the 'to' face that exist when creating a cut feature interactively through the command exist when using the API to create a cut feature.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
Remarks

Calling this method for a CutDefinition object that was obtained from an existing cut feature will cause the cut feature to update with the change.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods > CutDefinition.SetToExtent Method


CutDefinition.SetToNextExtent Method

CutDefinition.SetToNextExtent Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that changes the extent to be a 'to next' extent.

Visual Basic
Sub SetToNextExtent(Direction As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Direction | Input PartFeatureExtentDirectionEnum value to indicate which side of the sketch the cut should be. kPositiveExtentDirection and kNegativeExtentDirection are valid values. The value kPositiveExtentDirection defines the cut direction to be in the same direction as the normal of the sketch plane.
Remarks

Calling this method for a CutDefinition object that was obtained from an existing cut feature will cause the cut feature to update with the change.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Methods > CutDefinition.SetToNextExtent Method


CutDefinition Properties

CutDefinition Properties
Summary

The properties of the CutDefinition class are listed here.

Properties
Name | Description
Application | Returns the Application object.
CutAcrossBends | Property that returns whether this cut feature goes across bends or not.
Extent | Property that returns the PartFeatureExtent object that defines how the extent of the feature is defined.
ExtentType | Property that returns an enum value indicating how the extent of the feature is defined.
Parent | Property that returns the parent CutFeature object of this CutDefinition object.
Profile | Property that gets and sets the Profile object that defines the shape of the cut.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties


CutDefinition.Application Property

CutDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.Application Property


CutDefinition.CutAcrossBends Property

CutDefinition.CutAcrossBends Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether this cut feature goes across bends or not.

Visual Basic
Property CutAcrossBends() As VARIANT_BOOL*
Remarks

To set a feature to cut across bends use the SetCutAcrossBendsExtent method.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.CutAcrossBends Property


CutDefinition.Extent Property

CutDefinition.Extent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the PartFeatureExtent object that defines how the extent of the feature is defined.

Visual Basic
Property Extent() As PartFeatureExtent**
Remarks

The type of extent object that this property will return can be determined by using the ExtentType property. When a new CutDefinition object is created using the CutFeatures.CreateCutDefinition method the extent is not accessible but will default to a distance extent where the distance is the sheet metal thickness as and the direction is kNegativeExtentDirection. If you need a different extent type or different inputs for the distance extent you can use the various Set methods to define a new extent.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.Extent Property


CutDefinition.ExtentType Property

CutDefinition.ExtentType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns an enum value indicating how the extent of the feature is defined.

Visual Basic
Property ExtentType() As PartFeatureExtentEnum*
Remarks

This indicates the type of object returned by the Extent property. When a new CutDefinition object is created using the CutFeatures.CreateCutDefinition method, this property is initialized to kDistanceExtent, where the distance is the sheet metal thickness defined by the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.ExtentType Property


CutDefinition.Parent Property

CutDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent CutFeature object of this CutDefinition object.

Visual Basic
Property Parent() As CutFeature**
Remarks

In the case where this is a newly created CutDefinition object or it has been copied from an existing CutDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.Parent Property


CutDefinition.Profile Property

CutDefinition.Profile Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the Profile object that defines the shape of the cut.

Visual Basic
Property Profile() As Profile*
Remarks

The profile can be changed in two ways. The first is to obtain the parent sketch of the profile and make changes to the sketch. This will cause the profile to automatically update. The second is to create an entirely new profile and use it to replace the existing profile. The new profile must be a child of the sketch that was used for the initial creation of the cut.

You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.Profile Property


CutDefinition.Type Property

CutDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CutDefinition Interface > CutDefinition Properties > CutDefinition.Type Property


CutFeature Interface

CutFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CutFeature object represents a sheet metal cut feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::CutFeature
        Inventor::CutFeatureProxy
Visual Basic
Public Interface CutFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

CutDefinition.Parent

CutFeatures.Add

CutFeatures.Item

See Also

Create sheet metal face and cut features sample

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > CutFeature Interface


CutFeature Properties

CutFeature Properties
Summary

The properties of the CutFeature class are listed here.

Properties
Name | Description
Definition | Property that gets/sets the CutDefinition object associated with this cut feature.
You are here: Symbol Reference > Inventor Library > Objects > CutFeature Interface > CutFeature Properties


CutFeature.Definition Property

CutFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets/sets the CutDefinition object associated with this cut feature.

Visual Basic
Property Definition() As CutDefinition**
Remarks

Modifying the CutDefinition object will edit the associated CutFeature.

You are here: Symbol Reference > Inventor Library > Objects > CutFeature Interface > CutFeature Properties > CutFeature.Definition Property


CutFeatureProxy Interface

CutFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the CutFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::CutFeature
        Inventor::CutFeatureProxy
Visual Basic
Public Interface CutFeatureProxy
Inherits CutFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > CutFeatureProxy Interface


CutFeatures Interface

CutFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The CutFeatures collection object provides access to the CutFeature objects. It"s also through the CutFeatures object that you create new CutFeature objects.

Class Hierarchy
Inventor::CutFeatures
Visual Basic
Public Interface CutFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPatternFeatures.CutFeatures

SheetMetalFeatures.CutFeatures

See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface


CutFeatures Methods

CutFeatures Methods
Summary

The methods of the CutFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new cut feature.
CreateCutDefinition | Method that creates a new CutDefinition object.
Item | Property that returns the specified CutFeature object from the collection. This is the default property of the CutFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Methods


CutFeatures.Add Method

CutFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new cut feature.

Visual Basic
Sub Add(CutDefinition As CutDefinition, Result As [out, retval] CutFeature*)
Parameters
Parameters | Description
CutDefinition | Input CutDefinition object that defines the face feature you want to create. A CutDefinition object can be created using the CutFeatures.CreateCutDefinition method. It can also be obtained from an existing CutFeature object.
Remarks

The newly created CutFeature object is returned.

See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Methods > CutFeatures.Add Method


CutFeatures.CreateCutDefinition Method

CutFeatures.CreateCutDefinition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new CutDefinition object.

Visual Basic
Sub CreateCutDefinition(Profile As Profile, Result As [out, retval] CutDefinition*)
Parameters
Parameters | Description
Profile | Input Profile object that defines the shape of the cut feature. The input profile must consist of one or more closed paths.
Remarks

This object is not a cut feature but contains the information that defines a cut feature and can be used to create a new cut feature or edit an existing one. The returned CutDefinition can be used as input to the CutFeatures.Add method to create a new cut feature. You can edit the properties of the CutDefinition object before creating the cut feature to get the desired cut feature.

See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Methods > CutFeatures.CreateCutDefinition Method


CutFeatures.Item Method

CutFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified CutFeature object from the collection. This is the default property of the CutFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] CutFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Methods > CutFeatures.Item Method


CutFeatures Properties

CutFeatures Properties
Summary

The properties of the CutFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Properties


CutFeatures.Application Property

CutFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Properties > CutFeatures.Application Property


CutFeatures.Count Property

CutFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Properties > CutFeatures.Count Property


CutFeatures.Type Property

CutFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > CutFeatures Interface > CutFeatures Properties > CutFeatures.Type Property


Cylinder Interface

Cylinder Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Cylinder object. The object created is a transient mathematical object and is not displayed graphically

Class Hierarchy
Inventor::Cylinder
Visual Basic
Public Interface Cylinder
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateCylinder

Face.Geometry

FaceDefinition.SurfaceGeometry

See Also

Is cylindrical face interior or exterior? sample

Example

See Line::IsColinearTo for example "Is cylindrical face interior or exterior?"

You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface


Cylinder Methods

Cylinder Methods
Summary

The methods of the Cylinder class are listed here.

Methods
Methods
Name | Description
GetCylinderData | Get the data defining this cylinder.
PutCylinderData | Method that sets the data defining this cylinder.
You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Methods


Cylinder.GetCylinderData Method

Cylinder.GetCylinderData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this cylinder.

Visual Basic
Sub GetCylinderData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef Radius As double)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies the base point of the cylinder.
AxisVector | Input/output Double that specifies axis vector.
Radius | Output Double that specifies the radius of the cylinder.
You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Methods > Cylinder.GetCylinderData Method


Cylinder.PutCylinderData Method

Cylinder.PutCylinderData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this cylinder.

Visual Basic
Sub PutCylinderData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), Radius As double)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies the base point of the cylinder.
AxisVector | Input/output Double that specifies axis vector.
Radius | Input Double that specifies the radius of the cylinder.
You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Methods > Cylinder.PutCylinderData Method


Cylinder Properties

Cylinder Properties
Summary

The properties of the Cylinder class are listed here.

Properties
Name | Description
AxisVector | Specifies the direction of the axis of the cylinder.
BasePoint | Specifies the base of the cylinder.
Evaluator | Gets the surface evaluator for this cylinder.
Radius | Specifies the radius of the cylinder.
You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Properties


Cylinder.AxisVector Property

Cylinder.AxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the axis of the cylinder.

Visual Basic
Property AxisVector() As UnitVector*
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Properties > Cylinder.AxisVector Property


Cylinder.BasePoint Property

Cylinder.BasePoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the base of the cylinder.

Visual Basic
Property BasePoint() As Point*
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Properties > Cylinder.BasePoint Property


Cylinder.Evaluator Property

Cylinder.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this cylinder.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Properties > Cylinder.Evaluator Property


Cylinder.Radius Property

Cylinder.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the radius of the cylinder.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Cylinder Interface > Cylinder Properties > Cylinder.Radius Property


DataIO Interface

DataIO Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Generic object that handles input and output of formatted data. IDataObject-style functionality that's IDispatch-compatible and simplified.

Class Hierarchy
Inventor::DataIO
Visual Basic
Public Interface DataIO
Inherits IDispatch
Remarks

See the article in the overviews section.

Notes

Members through which this object may be accessed include:

AttributeSet.DataIO

AttributeSets.DataIO

ComponentDefinition.DataIO

DrawingView.DataIO

Sheet.DataIO

Sketch.DataIO

SurfaceBody.DataIO

Example

"Translate - Sheet Metal to DXF Example "

The sample code below writes a sheet metal file out as DXF. DWG is also supported. Use either the FLAT PATTERN DWG or FLAT PATTERN DXF formats.There are several optional arguments that can be specified as part of the format string. E.g. 'FLAT PATTERN DXF?TangentLayer=Tangents&SimplifySplines=True'). Below are the names of these arguments and relevant default values. The output will use these values unless you override them as part of the input string.

Argument | Type | Default Value | Note
TangentLayer | String | IV_TANGENT | "
OuterProfileLayer | String | IV_OUTER_PROFILE | "
ArcCentersLayer | String | IV_ARC_CENTERS | "
InteriorProfilesLayer | String | IV_INTERIOR_PROFILES | "
BendLayer | String | IV_BEND | BendUpLayer + BendDownLayer (legacy support)
BendUpLayer | String | IV_BEND | "
BendDownLayer | String | IV_BEND_DOWN | "
ToolCenterLayer | String | IV_TOOL_CENTER | ToolCenterUpLayer + ToolCenterDownLayer (legacy support)
ToolCenterUpLayer | String | IV_TOOL_CENTER | "
ToolCenterDownLayer | String | IV_TOOL_CENTER_DOWN | "
FeatureProfilesLayer | String | IV_FEATURE_PROFILES | FeatureProfilesUpLayer + FeatureProfilesDownLayer (legacy support)
FeatureProfilesUpLayer | String | IV_FEATURE_PROFILES | "
FeatureProfilesDownLayer | String | IV_FEATURE_PROFILES_DOWN | "
AltRepFrontLayer | String | IV_ALTREP_FRONT | "
AltRepBackLayer | String | IV_ALTREP_BACK | "
UnconsumedSketchesLayer | String | IV_UNCONSUMED_SKETCHES | "
TangentRollLinesLayer | String | IV_ROLL_TANGENT | "
RollLinesLayer | String | IV_ROLL | "
***Color | String | " | *** indicates name of layer from the argument column. RGB values separated by ;. Example: TangentLayerColor=255;0;0
***LineType | Long | " | *** indicates name of layer from the argument column. Long value from LineTypeEnum. Example: TangentLayerLineType=37644
***LineWeight | Double | " | *** indicates name of layer from the argument column. Value in centimeters. Example: TangentLayerLineWeight=.1016
ExportUnconsumedSketchProperties | Boolean | True | Specifies whether individual sketch entity properties should be exported. If set to False, the properties specified by the UnconsumedSketchesLayer are used.
CustomizeFilename | String | " | "
AcadVersion | String | " | 2010, 2007, 2004, 2000, or R12 (for DXF only)
SimplifySplines | Boolean | True | Enable spline replacement by linear segments
SplineTolerance | Double | 0.01 | Chord tolerance for spline replacement
AdvancedLegacyExport | Boolean | True | "
MergeProfilesIntoPolyline | Boolean | False | Build a polyline of the exterior profiles
RebaseGeometry | Boolean | False | Move geometry to 1st quadrant
InvisibleLayers | String | " | List of layer names to make invisible, separated by ;

The following sample demonstrates creating an R12 DXF file that will have a layer called Outer where the curves for the outer shape will be created.

Public Sub WriteSheetMetalDXF()

    ' Get the active document.  This assumes it is a part document.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Get the DataIO object.
    Dim oDataIO As DataIO
    Set oDataIO = oDoc.ComponentDefinition.DataIO

    ' Build the string that defines the format of the DXF file.
    Dim sOut As String
    sOut = "FLAT PATTERN DXF?AcadVersion=R12&OuterProfileLayer=Outer"

    ' Create the DXF file.
    oDataIO.WriteDataToFile sOut, "C:\temp\flat2.dxf"
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface


DataIO Methods

DataIO Methods
Summary

The methods of the DataIO class are listed here.

Methods
Methods
Name | Description
GetInputFormats | Obtains all the formats that can be accepted, paired with the storage-mediums on which they can possibly be received.
GetOutputFormats | Obtains all the formats that can be output, paired with the storage-mediums into which they can possibly be presented.
ReadDataFromFile | Reads in the specifically formatted contents of a file into the supporting object.
ReadDataFromStream | Reads in the specifically formatted contents of a Stream (IStream) into the supporting object.
WriteDataToFile | Writes out the contents of the supporting object in the specified format onto a file.
WriteDataToStream | Writes out the contents of the supporting object in the specified format onto a Stream (IStream). If once-dereferenced Stream pointer is NULL, then a Stream is allocated and must be 'Release-d()' by caller.
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods


DataIO.GetInputFormats Method

DataIO.GetInputFormats Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains all the formats that can be accepted, paired with the storage-mediums on which they can possibly be received.

Visual Basic
Sub GetInputFormats(ByRef Formats As SAFEARRAY(BSTR), ByRef StorageTypes As SAFEARRAY(StorageTypeEnum))
Parameters
Parameters | Description
Formats | Input/output String that specifies all of the formats accepted by the method.
StorageTypes | Input/output that specifies storage-media on which specific formats can be saved.
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods > DataIO.GetInputFormats Method


DataIO.GetOutputFormats Method

DataIO.GetOutputFormats Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains all the formats that can be output, paired with the storage-mediums into which they can possibly be presented.

Visual Basic
Sub GetOutputFormats(ByRef Formats As SAFEARRAY(BSTR), ByRef StorageTypes As SAFEARRAY(StorageTypeEnum))
Parameters
Parameters | Description
Formats | Input/output String that specifies all of the formats accepted by the method.
StorageTypes | Input/output that specifies storage-media on which specific formats can be saved.
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods > DataIO.GetOutputFormats Method


DataIO.ReadDataFromFile Method

DataIO.ReadDataFromFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Reads in the specifically formatted contents of a file into the supporting object.

Visual Basic
Sub ReadDataFromFile(Format As String, FileName As String)
Parameters
Parameters | Description
Format | Input String that specifies the format of the data to be read from the file.
FileName | Input String that specifies the name of the file to read the data from.
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods > DataIO.ReadDataFromFile Method


DataIO.ReadDataFromStream Method

DataIO.ReadDataFromStream Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Reads in the specifically formatted contents of a Stream (IStream) into the supporting object.

Visual Basic
Sub ReadDataFromStream(Format As String, Stream As IUnknown)
Parameters
Parameters | Description
Format | Input String that specifies the format of the data to be read from the stream.
Stream | Input/output object from which to read the formatted data.
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods > DataIO.ReadDataFromStream Method


DataIO.WriteDataToFile Method

DataIO.WriteDataToFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Writes out the contents of the supporting object in the specified format onto a file.

Visual Basic
Sub WriteDataToFile(Format As String, FileName As String)
Parameters
Parameters | Description
Format | Input String that specifies the format of the data to be written to the file.
FileName | Input String that specifies the name of the file to write the data to.
See Also

Translate - Sheet Metal to DXF sample

Example

See DataIO for example "DataIO Object code sample"

You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods > DataIO.WriteDataToFile Method


DataIO.WriteDataToStream Method

DataIO.WriteDataToStream Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Writes out the contents of the supporting object in the specified format onto a Stream (IStream). If once-dereferenced Stream pointer is NULL, then a Stream is allocated and must be 'Release-d()' by caller.

Visual Basic
Sub WriteDataToStream(Format As String, ByRef Stream As [unique] IUnknown *)
Parameters
Parameters | Description
Format | Input String that specifies the format of the data to be written to the stream.
Stream | Input/output object from which to read the formatted data.
You are here: Symbol Reference > Inventor Library > Objects > DataIO Interface > DataIO Methods > DataIO.WriteDataToStream Method


DataMedium Interface

DataMedium Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DataMedium object is used when exporting/importing to various formats using the TranslatorAddIn APIs. See the 'export' samples under TranslatorAddin for examples of its use.

Class Hierarchy
Inventor::DataMedium
Visual Basic
Public Interface DataMedium
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientObjects.CreateDataMedium

See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface


DataMedium Properties

DataMedium Properties
Summary

The properties of the DataMedium class are listed here.

Properties
Name | Description
FileName | Specifies the name of a data file.
IDataObject | Specifies a IDataObject containing the data.
MediumType | Specifies the type of the data.
Stream | Specifies an IStream containing the data.
String | Specifies a String containing the data.
You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface > DataMedium Properties


DataMedium.FileName Property

DataMedium.FileName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the name of a data file.

Visual Basic
Property FileName() As String
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface > DataMedium Properties > DataMedium.FileName Property


DataMedium.IDataObject Property

DataMedium.IDataObject Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Specifies a IDataObject containing the data.

Visual Basic
Property IDataObject() As IUnknown*
You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface > DataMedium Properties > DataMedium.IDataObject Property


DataMedium.MediumType Property

DataMedium.MediumType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies the type of the data.

Visual Basic
Property MediumType() As MediumTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface > DataMedium Properties > DataMedium.MediumType Property


DataMedium.Stream Property

DataMedium.Stream Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies an IStream containing the data.

Visual Basic
Property Stream() As IUnknown*
You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface > DataMedium Properties > DataMedium.Stream Property


DataMedium.String Property

DataMedium.String Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies a String containing the data.

Visual Basic
Property String() As String
You are here: Symbol Reference > Inventor Library > Objects > DataMedium Interface > DataMedium Properties > DataMedium.String Property


DecalFeature Interface

DecalFeature Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DecalFeature object represents a decal feature on a part.

Class Hierarchy
Inventor::PartFeature
    Inventor::DecalFeature
        Inventor::DecalFeatureProxy
Visual Basic
Public Interface DecalFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

DecalFeatureProxy.NativeObject

DecalFeatures.Add

DecalFeatures.Item

See Also

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > DecalFeature Interface


DecalFeature Properties

DecalFeature Properties
Summary

The properties of the DecalFeature class are listed here.

Properties
Name | Description
ChainFaces | Property that specifies if the decal is also applied on any faces that are adjacent to the primary face on which the decal is applied.
Face | Property that gets and sets the primary face on which the decal is applied. If a new face is specified, then the decal will be applied on the newly specified face. But, in order to set a new face using this property, the end of part marker needs to be moved above the feature before setting this property.
Image | Property that gets and sets the sketch image used to apply the decal.
WrapFace | Property that specifies if the decal is wrapped on the face on which it is applied.
You are here: Symbol Reference > Inventor Library > Objects > DecalFeature Interface > DecalFeature Properties


DecalFeature.ChainFaces Property

DecalFeature.ChainFaces Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies if the decal is also applied on any faces that are adjacent to the primary face on which the decal is applied.

Visual Basic
Property ChainFaces() As VARIANT_BOOL
Remarks

If a value of True is specified, then the decal will also be applied on any adjacent faces in addition to the primary face specified by the Face property. If there are no adjacent faces, then the decal will be applied only on the primary face.

If a value of False is specified, then the decal will be applied only on the primary face specified by the Face property.

You are here: Symbol Reference > Inventor Library > Objects > DecalFeature Interface > DecalFeature Properties > DecalFeature.ChainFaces Property


DecalFeature.Face Property

DecalFeature.Face Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the primary face on which the decal is applied. If a new face is specified, then the decal will be applied on the newly specified face. But, in order to set a new face using this property, the end of part marker needs to be moved above the feature before setting this property.

Visual Basic
Property Face() As Face*
You are here: Symbol Reference > Inventor Library > Objects > DecalFeature Interface > DecalFeature Properties > DecalFeature.Face Property


DecalFeature.Image Property

DecalFeature.Image Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the sketch image used to apply the decal.

Visual Basic
Property Image() As SketchImage*
You are here: Symbol Reference > Inventor Library > Objects > DecalFeature Interface > DecalFeature Properties > DecalFeature.Image Property


DecalFeature.WrapFace Property

DecalFeature.WrapFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies if the decal is wrapped on the face on which it is applied.

Visual Basic
Property WrapFace() As VARIANT_BOOL
Remarks

If a value of True is specified, then the image will be wrapped on the face on which the decal is applied. But, the image will be wrapped on the face only if the face is tangential to the plane of the image. If the face is not tangential to the plane of the image, then specifying a value of True for this property will fail. The effects of wrapping the decal are pronounced if the face is a curved face.

If a value of False is specified, then it implies that the decal feature should not be wrapped around any face, but created as a result of straight projection onto the face.

You are here: Symbol Reference > Inventor Library > Objects > DecalFeature Interface > DecalFeature Properties > DecalFeature.WrapFace Property


DecalFeatureProxy Interface

DecalFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DecalFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::DecalFeature
        Inventor::DecalFeatureProxy
Visual Basic
Public Interface DecalFeatureProxy
Inherits DecalFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DecalFeatureProxy Interface


DecalFeatureProxy Properties

DecalFeatureProxy Properties
Summary

The properties of the DecalFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatureProxy Interface > DecalFeatureProxy Properties


DecalFeatureProxy.ContainingOccurrence Property

DecalFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DecalFeatureProxy Interface > DecalFeatureProxy Properties > DecalFeatureProxy.ContainingOccurrence Property


DecalFeatureProxy.NativeObject Property

DecalFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As DecalFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DecalFeatureProxy Interface > DecalFeatureProxy Properties > DecalFeatureProxy.NativeObject Property


DecalFeatures Interface

DecalFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DecalFeatures collection object provides access to all of the DecalFeature objects.

Class Hierarchy
Inventor::DecalFeatures
Visual Basic
Public Interface DecalFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.DecalFeatures

See Also

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface


DecalFeatures Methods

DecalFeatures Methods
Summary

The methods of the DecalFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new decal feature by applying an image on one or more faces in the model.
Item | Property that returns the specified DecalFeature object from the collection. This is the default property of the Decals collection object.
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Methods


DecalFeatures.Add Method

DecalFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new decal feature by applying an image on one or more faces in the model.

Visual Basic
Sub Add(Image As SketchImage, Face As Face, ByRef WrapFace As [defaultvalue(0)] VARIANT_BOOL, ByRef ChainFaces As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] DecalFeature*)
Parameters
Parameters | Description
Image | Input SketchImage object used to define the sketch image used to apply the decal.
Face | Input Face object that defines the primary face on which the decal should be applied. The orientation of the face must be such that the image can be projected onto the face, otherwise the creation of the decal will fail. If the face is planar, then the angle between the normal vector of the face and the normal vector of the sketch plane that contains the image should be less than 90 degrees. If this angle is equal to 90 degrees (which means that the plane of the face is perpendicular to the plane of the image) or if this angle is greater than 90 degrees, then the creation of the decal will fail. For example, if the face is planar and the plane of the face is perpendicular to the plane of the image, then the creation of the decal will fail.
WrapFace | Optional Input Boolean that specifies if the image should be wrapped on the face on which the decal needs to be applied. If a value of True is specified, then the image will be wrapped on the face on which the decal is applied. But, the image will be wrapped on the face only if the face is tangential to the plane of the image. If the face is not tangential to the plane of the image and a value of True is specified for this argument, then the creation of the decal will fail. The effects of wrapping the decal are pronounced if the face is a curved face. If a value of False is specified, then it implies that the decal feature should not be wrapped around the face, but created as a result of straight projection onto the face. A default value of False will be assumed if no value is explicitly specified for this argument.
ChainFaces | Optional Input Boolean that specifies whether the decal should also be applied on any faces that are adjacent to the primary face on which the decal needs to be applied. If a value of True is specified, then the decal will also be applied on adjacent faces in addition to the primary face specified by the Face argument. If there are no adjacent faces, then the decal will be applied only on the primary face. If a value of False is specified, then the decal will be applied only on the primary face specified by the Face argument. A default value of True will be assumed if no value is explicitly specified for this argument.
Remarks

If the decal feature is created successfully, a DecalFeature object corresponding to the newly created decal feature is returned from this method.

Example

"Add a decal feature"

This sample demonstrates the creation of a decal feature. Make sure that the path to the bmp file is valid before running the sample.

Public Sub DecalFeature()

    ' ***Change path to point to the desired bmp file.
    Dim strImagePath As String
    strImagePath = "C:\Program Files\Autodesk\Inventor 2010\Texturessky.bmp"

    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry
    Dim oCenter As Point2d
    Set oCenter = oTransGeom.CreatePoint2d(0, 0)

    ' Create a sketch circle
    Dim oCircle As SketchCircle
    Set oCircle = oSketch.SketchCircles.AddByCenterRadius(oCenter, 1)

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a base extrusion 4 cm thick.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent(oProfile, 4, _
                    kPositiveExtentDirection, kJoinOperation)

    ' Create a new sketch on the Y-Z work plane.
    Dim oDecalSketch As PlanarSketch
    Set oDecalSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(1))

    ' Create the placement point for the image.
    Dim oPoint As Point2d
    Set oPoint = oTransGeom.CreatePoint2d(0, 4)

    ' Add a sketch image
    Dim oSketchImage As SketchImage
    Set oSketchImage = oDecalSketch.SketchImages.Add(strImagePath, oPoint)

    ' Get the cylindrical face of the extrude
    Dim oFace As Face
    Set oFace = oExtrude.SideFaces.Item(1)

    ' Create a decal feature that wraps onto the cylindrical face.
    Dim oDecal As DecalFeature
    Set oDecal = oCompDef.Features.DecalFeatures.Add(oSketchImage, oFace, True)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Methods > DecalFeatures.Add Method


DecalFeatures.Item Method

DecalFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified DecalFeature object from the collection. This is the default property of the Decals collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DecalFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DecalFeature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the decal's name. The name expected is the display name of the decal. This is the name that is displayed to the user in the assembly browser. If an out-of-range index or a name of a non-existent constraint name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Methods > DecalFeatures.Item Method


DecalFeatures Properties

DecalFeatures Properties
Summary

The properties of the DecalFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Properties


DecalFeatures.Application Property

DecalFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Properties > DecalFeatures.Application Property


DecalFeatures.Count Property

DecalFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Properties > DecalFeatures.Count Property


DecalFeatures.Type Property

DecalFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DecalFeatures Interface > DecalFeatures Properties > DecalFeatures.Type Property


DefaultBorder Interface

DefaultBorder Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DefaultBorder object represents an instance of the default border.

Class Hierarchy
Inventor::Border
    Inventor::DefaultBorder
Visual Basic
Public Interface DefaultBorder
Inherits Border
Notes

Members through which this object may be accessed include:

Sheet.AddDefaultBorder

See Also

Border Insert Default sample

Border Insert sample

You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface


DefaultBorder Properties

DefaultBorder Properties
Summary

The properties of the DefaultBorder class are listed here.

Properties
Name | Description
BottomMargin | Property that returns the space between the bottom edge of the sheet and the border line. The distance is specified in centimeters.
Centermarks | Property that returns if center marks are displayed on the border. A value of True indicates center marks are displayed.
DelimitZonesByLines | Property that returns if delimit zones are indicated by lines or arrowheads. A value of True indicates lines are used and False specifies arrowheads.
HorizontalZoneCount | Property that returns the number of horizontal zones to be created for the border.
HorizontalZoneLabelMode | Property that returns the label style for the horizontal labels. Valid values are kBorderLabelModeAlphabetical, kBorderLabelModeNumeric, and kBorderLabelModeNone.
LabelFromBottomRight | Property that returns whether the zone numbers begin at the bottom-right or top-left corner. A value of True indicates the bottom-right corner and False specifies the top-left.
LeftMargin | Property that returns the space between the left edge of the sheet and the border line. The distance is specified in centimeters.
RightMargin | Property that returns the space between the right edge of the sheet and the border line. The distance is specified in centimeters.
TopMargin | Property that returns the space between the top edge of the sheet and the border line. The distance is specified in centimeters.
VerticalZoneCount | Property that returns the number of vertical zones to be created for the border.
VerticalZoneLabelMode | Property that returns the label style for the vertical labels. Valid values are kBorderLabelModeAlphabetical, kBorderLabelModeNumeric, and kBorderLabelModeNone.
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties


DefaultBorder.BottomMargin Property

DefaultBorder.BottomMargin Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the space between the bottom edge of the sheet and the border line. The distance is specified in centimeters.

Visual Basic
Property BottomMargin() As double*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.BottomMargin Property


DefaultBorder.Centermarks Property

DefaultBorder.Centermarks Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns if center marks are displayed on the border. A value of True indicates center marks are displayed.

Visual Basic
Property Centermarks() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.Centermarks Property


DefaultBorder.DelimitZonesByLines Property

DefaultBorder.DelimitZonesByLines Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns if delimit zones are indicated by lines or arrowheads. A value of True indicates lines are used and False specifies arrowheads.

Visual Basic
Property DelimitZonesByLines() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.DelimitZonesByLines Property


DefaultBorder.HorizontalZoneCount Property

DefaultBorder.HorizontalZoneCount Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of horizontal zones to be created for the border.

Visual Basic
Property HorizontalZoneCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.HorizontalZoneCount Property


DefaultBorder.HorizontalZoneLabelMode Property

DefaultBorder.HorizontalZoneLabelMode Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the label style for the horizontal labels. Valid values are kBorderLabelModeAlphabetical, kBorderLabelModeNumeric, and kBorderLabelModeNone.

Visual Basic
Property HorizontalZoneLabelMode() As BorderLabelModeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.HorizontalZoneLabelMode Property


DefaultBorder.LabelFromBottomRight Property

DefaultBorder.LabelFromBottomRight Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns whether the zone numbers begin at the bottom-right or top-left corner. A value of True indicates the bottom-right corner and False specifies the top-left.

Visual Basic
Property LabelFromBottomRight() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.LabelFromBottomRight Property


DefaultBorder.LeftMargin Property

DefaultBorder.LeftMargin Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the space between the left edge of the sheet and the border line. The distance is specified in centimeters.

Visual Basic
Property LeftMargin() As double*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.LeftMargin Property


DefaultBorder.RightMargin Property

DefaultBorder.RightMargin Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the space between the right edge of the sheet and the border line. The distance is specified in centimeters.

Visual Basic
Property RightMargin() As double*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.RightMargin Property


DefaultBorder.TopMargin Property

DefaultBorder.TopMargin Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the space between the top edge of the sheet and the border line. The distance is specified in centimeters.

Visual Basic
Property TopMargin() As double*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.TopMargin Property


DefaultBorder.VerticalZoneCount Property

DefaultBorder.VerticalZoneCount Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of vertical zones to be created for the border.

Visual Basic
Property VerticalZoneCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.VerticalZoneCount Property


DefaultBorder.VerticalZoneLabelMode Property

DefaultBorder.VerticalZoneLabelMode Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the label style for the vertical labels. Valid values are kBorderLabelModeAlphabetical, kBorderLabelModeNumeric, and kBorderLabelModeNone.

Visual Basic
Property VerticalZoneLabelMode() As BorderLabelModeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DefaultBorder Interface > DefaultBorder Properties > DefaultBorder.VerticalZoneLabelMode Property


DeleteFaceFeature Interface

DeleteFaceFeature Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DeleteFaceFeature object represents a delete face feature on a part. A delete face feature is created interactively by using the Delete Face tool on the Feature toolbar--see Autodesk Inventor user interface help for further information about delete face features.

Class Hierarchy
Inventor::PartFeature
    Inventor::DeleteFaceFeature
        Inventor::DeleteFaceFeatureProxy
Visual Basic
Public Interface DeleteFaceFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

DeleteFaceFeatureProxy.NativeObject

DeleteFaceFeatures.Add

DeleteFaceFeatures.Item

See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeature Interface


DeleteFaceFeature Properties

DeleteFaceFeature Properties
Summary

The properties of the DeleteFaceFeature class are listed here.

Properties
Name | Description
InputFaces | Property that specifies the faces that were specified to create the feature. This property will return the faces only when the end of part marker is moved above this feature, else this property will return Nothing. This can either be a FaceCollection or a FaceShell object.
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeature Interface > DeleteFaceFeature Properties


DeleteFaceFeature.InputFaces Property

DeleteFaceFeature.InputFaces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the faces that were specified to create the feature. This property will return the faces only when the end of part marker is moved above this feature, else this property will return Nothing. This can either be a FaceCollection or a FaceShell object.

Visual Basic
Property InputFaces() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeature Interface > DeleteFaceFeature Properties > DeleteFaceFeature.InputFaces Property


DeleteFaceFeatureProxy Interface

DeleteFaceFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DeleteFaceFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::DeleteFaceFeature
        Inventor::DeleteFaceFeatureProxy
Visual Basic
Public Interface DeleteFaceFeatureProxy
Inherits DeleteFaceFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatureProxy Interface


DeleteFaceFeatureProxy Properties

DeleteFaceFeatureProxy Properties
Summary

The properties of the DeleteFaceFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatureProxy Interface > DeleteFaceFeatureProxy Properties


DeleteFaceFeatureProxy.ContainingOccurrence Property

DeleteFaceFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatureProxy Interface > DeleteFaceFeatureProxy Properties > DeleteFaceFeatureProxy.ContainingOccurrence Property


DeleteFaceFeatureProxy.NativeObject Property

DeleteFaceFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As DeleteFaceFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatureProxy Interface > DeleteFaceFeatureProxy Properties > DeleteFaceFeatureProxy.NativeObject Property


DeleteFaceFeatures Interface

DeleteFaceFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DeleteFaceFeatures object represents a collection of objects on a part.

Class Hierarchy
Inventor::DeleteFaceFeatures
Visual Basic
Public Interface DeleteFaceFeatures
Inherits IDispatch
Remarks

A delete face feature is created interactively by using the Delete Face tool on the Feature toolbar--see Autodesk Inventor user interface help for further information about delete face features.

Notes

Members through which this object may be accessed include:

PartFeatures.DeleteFaceFeatures

You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface


DeleteFaceFeatures Methods

DeleteFaceFeatures Methods
Summary

The methods of the DeleteFaceFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DeleteFaceFeature. The new created DeleteFaceFeature is returned.
Item | Property that returns the specified DeleteFaceFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Methods


DeleteFaceFeatures.Add Method

DeleteFaceFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new DeleteFaceFeature. The new created DeleteFaceFeature is returned.

Visual Basic
Sub Add(FacesToDelete As IDispatch, ByRef Heal As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] DeleteFaceFeature*)
Parameters
Parameters | Description
FacesToDelete | Input object that defines the faces to be deleted. This can either be a FaceCollection or a FaceShell object. If a FaceShell is specified, and it defines a void, this method deletes the void and restores mass to the model. If the FaceShell does not define a void, it results in the deletion of all the faces of the lump that this FaceShell belongs to.
Heal | Optional input Boolean that specifies whether or not to attempt to heal gaps by extending adjacent faces until they intersect. If specified, this input is used only if a collection of faces is provided in the Faces argument. The default value is False indicating that the faces will not be healed.
See Also

Delete Face, Boundary Patch and Stitch features. sample

Example

See BoundaryPatchFeatures.Add for sample code.

You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Methods > DeleteFaceFeatures.Add Method


DeleteFaceFeatures.Item Method

DeleteFaceFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified DeleteFaceFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DeleteFaceFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the constraint name. The name expected is the display name of the constraint. This is the name that is displayed to the user in the assembly browser. If an out-of-range index or a name of a non-existent constraint name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Methods > DeleteFaceFeatures.Item Method


DeleteFaceFeatures Properties

DeleteFaceFeatures Properties
Summary

The properties of the DeleteFaceFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Properties


DeleteFaceFeatures.Application Property

DeleteFaceFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Properties > DeleteFaceFeatures.Application Property


DeleteFaceFeatures.Count Property

DeleteFaceFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Properties > DeleteFaceFeatures.Count Property


DeleteFaceFeatures.Type Property

DeleteFaceFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DeleteFaceFeatures Interface > DeleteFaceFeatures Properties > DeleteFaceFeatures.Type Property


DerivedAliasComponent Interface

DerivedAliasComponent Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The DerivedAliasComponent object represents a specific derived Alias instance.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedAliasComponent
        Inventor::DerivedAliasComponentProxy
Visual Basic
Public Interface DerivedAliasComponent
Inherits ReferenceComponent
Notes

Members through which this object may be accessed include:

DerivedAliasComponentProxy.NativeObject

DerivedAliasComponents.Item

You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponent Interface


DerivedAliasComponent Properties

DerivedAliasComponent Properties
Summary

The properties of the DerivedAliasComponent class are listed here.

Properties
Name | Description
ResultFeatures | Property that returns the list of NonParametricBaseFeature objects that were created as a result of deriving this Alias file.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponent Interface > DerivedAliasComponent Properties


DerivedAliasComponent.ResultFeatures Property

DerivedAliasComponent.ResultFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the list of NonParametricBaseFeature objects that were created as a result of deriving this Alias file.

Visual Basic
Property ResultFeatures() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponent Interface > DerivedAliasComponent Properties > DerivedAliasComponent.ResultFeatures Property


DerivedAliasComponentProxy Interface

DerivedAliasComponentProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DerivedAliasComponent object.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedAliasComponent
        Inventor::DerivedAliasComponentProxy
Visual Basic
Public Interface DerivedAliasComponentProxy
Inherits DerivedAliasComponent
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponentProxy Interface


DerivedAliasComponentProxy Properties

DerivedAliasComponentProxy Properties
Summary

The properties of the DerivedAliasComponentProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponentProxy Interface > DerivedAliasComponentProxy Properties


DerivedAliasComponentProxy.ContainingOccurrence Property

DerivedAliasComponentProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponentProxy Interface > DerivedAliasComponentProxy Properties > DerivedAliasComponentProxy.ContainingOccurrence Property


DerivedAliasComponentProxy.NativeObject Property

DerivedAliasComponentProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As DerivedAliasComponent**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponentProxy Interface > DerivedAliasComponentProxy Properties > DerivedAliasComponentProxy.NativeObject Property


DerivedAliasComponents Interface

DerivedAliasComponents Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The DerivedAliasComponents collection object provides access to all of the existing DerivedAliasComponent objects in a part and provides methods to create additional derived components.

Class Hierarchy
Inventor::DerivedAliasComponents
Visual Basic
Public Interface DerivedAliasComponents
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ReferenceComponents.DerivedAliasComponents

You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface


DerivedAliasComponents Methods

DerivedAliasComponents Methods
Summary

The methods of the DerivedAliasComponents class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified DerivedAliasComponent object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Methods


DerivedAliasComponents.Item Method

DerivedAliasComponents.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified DerivedAliasComponent object from the collection.

Visual Basic
Sub Item(Value As VARIANT, Result As [out, retval] DerivedAliasComponent*)
Parameters
Parameters | Description
Value | Input Variant value that specifies the DeriveAliasStudioComponent to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived component's name. If an out of range index or a name of a non-existent DerivedAssemblyComponent is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Methods > DerivedAliasComponents.Item Method


DerivedAliasComponents Properties

DerivedAliasComponents Properties
Summary

The properties of the DerivedAliasComponents class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the ComponentDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Properties


DerivedAliasComponents.Application Property

DerivedAliasComponents.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Properties > DerivedAliasComponents.Application Property


DerivedAliasComponents.Count Property

DerivedAliasComponents.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Properties > DerivedAliasComponents.Count Property


DerivedAliasComponents.Parent Property

DerivedAliasComponents.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Properties > DerivedAliasComponents.Parent Property


DerivedAliasComponents.Type Property

DerivedAliasComponents.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAliasComponents Interface > DerivedAliasComponents Properties > DerivedAliasComponents.Type Property


DerivedAssemblyComponent Interface

DerivedAssemblyComponent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedAssemblyComponent object represents a specific derived assembly instance.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedAssemblyComponent
        Inventor::DerivedAssemblyComponentProxy
Visual Basic
Public Interface DerivedAssemblyComponent
Inherits ReferenceComponent
Notes

Members through which this object may be accessed include:

DerivedAssemblyComponentProxy.NativeObject

DerivedAssemblyComponents.Add

DerivedAssemblyComponents.Item

ClientFeatureElement.Element

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponent Interface


DerivedAssemblyComponent Properties

DerivedAssemblyComponent Properties
Summary

The properties of the DerivedAssemblyComponent class are listed here.

Properties
Name | Description
Definition | Property that returns the derived assembly definition that defines the current state of the derived assembly.
ReferenceFeatures | Property that returns the collection containing the ReferenceFeatures that was created as a result of the derived component.
SuppressAll | Property that gets and sets the suppress state for all of the Reference features created by this derived assembly component.
SuppressLinkToFile | Property that suppresses or unsuppresses the link to the base assembly.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponent Interface > DerivedAssemblyComponent Properties


DerivedAssemblyComponent.Definition Property

DerivedAssemblyComponent.Definition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the derived assembly definition that defines the current state of the derived assembly.

Visual Basic
Property Definition() As DerivedAssemblyDefinition*
Remarks

The state of the derived assembly can be changed by modifying the values of the returned descriptor and assigning it back to the derived assembly using the DerivedAssemblyComponentDefinition property. The part will be updated as a result of the assignment.

Note: Definition property will return Nothing if the link to the base assembly is broken or if the link to the base assembly could not be resolved.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponent Interface > DerivedAssemblyComponent Properties > DerivedAssemblyComponent.Definition Property


DerivedAssemblyComponent.ReferenceFeatures Property

DerivedAssemblyComponent.ReferenceFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the collection containing the ReferenceFeatures that was created as a result of the derived component.

Visual Basic
Property ReferenceFeatures() As ReferenceFeaturesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponent Interface > DerivedAssemblyComponent Properties > DerivedAssemblyComponent.ReferenceFeatures Property


DerivedAssemblyComponent.SuppressAll Property

DerivedAssemblyComponent.SuppressAll Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the suppress state for all of the Reference features created by this derived assembly component.

Visual Basic
Property SuppressAll() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponent Interface > DerivedAssemblyComponent Properties > DerivedAssemblyComponent.SuppressAll Property


DerivedAssemblyComponent.SuppressLinkToFile Property

DerivedAssemblyComponent.SuppressLinkToFile Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that suppresses or unsuppresses the link to the base assembly.

Visual Basic
Property SuppressLinkToFile() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponent Interface > DerivedAssemblyComponent Properties > DerivedAssemblyComponent.SuppressLinkToFile Property


DerivedAssemblyComponentProxy Interface

DerivedAssemblyComponentProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DerivedAssemblyComponent object.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedAssemblyComponent
        Inventor::DerivedAssemblyComponentProxy
Visual Basic
Public Interface DerivedAssemblyComponentProxy
Inherits DerivedAssemblyComponent
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponentProxy Interface


DerivedAssemblyComponentProxy Properties

DerivedAssemblyComponentProxy Properties
Summary

The properties of the DerivedAssemblyComponentProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponentProxy Interface > DerivedAssemblyComponentProxy Properties


DerivedAssemblyComponentProxy.ContainingOccurrence Property

DerivedAssemblyComponentProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponentProxy Interface > DerivedAssemblyComponentProxy Properties > DerivedAssemblyComponentProxy.ContainingOccurrence Property


DerivedAssemblyComponentProxy.NativeObject Property

DerivedAssemblyComponentProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As DerivedAssemblyComponent**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponentProxy Interface > DerivedAssemblyComponentProxy Properties > DerivedAssemblyComponentProxy.NativeObject Property


DerivedAssemblyComponents Interface

DerivedAssemblyComponents Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedAssemblyComponents collection object provides access to all of the existing objects in a part and provides methods to create additional derived assembly components.

Class Hierarchy
Inventor::DerivedAssemblyComponents
Visual Basic
Public Interface DerivedAssemblyComponents
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ReferenceComponents.DerivedAssemblyComponents

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface


DerivedAssemblyComponents Methods

DerivedAssemblyComponents Methods
Summary

The methods of the DerivedAssemblyComponents class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new using the information supplied by the input DerivedAssemblyDefinition object. If successful, the new DerivedAssemblyComponent is returned.
CreateDefinition | Method that creates a new Definition. The returned definition provides access to all of the items in the document that can be derived.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Methods


DerivedAssemblyComponents.Add Method

DerivedAssemblyComponents.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new using the information supplied by the input DerivedAssemblyDefinition object. If successful, the new DerivedAssemblyComponent is returned.

Visual Basic
Sub Add(Definition As DerivedAssemblyDefinition, Result As [out, retval] DerivedAssemblyComponent*)
Parameters
Parameters | Description
Definition | Input object that defines the derived component.
See Also

Shrink wrap substitute in assembly sample

Example

"Derived Parts and Assemblies Example"

This sample demonstrates the use of the API to create derived parts and assemblies. The example used is a simple case of a part subtracted from a mold. To simplify setup, the program creates the parts representing the part and the mold. It then uses derived parts and assemblies to scale the part and subtract it from the mold. To run the sample set the sFilePath variable to the location where you want the files to be created. C:\Temp is the default path.

Public Sub MoldBaseSample()
    ' Initialize the string that defines the directory where the
    ' files will be created.
    Dim sFilePath As String
    sFilePath = "C:\Temp\"

    ' Call the functions to create the parts that represent the
    ' molded part and the mold base.
    Call CreateMoldPart(sFilePath & "MoldPart.ipt")
    Call CreateMoldBase(sFilePath & "MoldBase.ipt")

    ' Create a new part file to derive the mold part in.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Create a derived definition for the molded part.
    Dim oDerivedPartDef As DerivedPartUniformScaleDef
    Set oDerivedPartDef = oPartDoc.ComponentDefinition.ReferenceComponents.DerivedPartComponents.CreateUniformScaleDef(sFilePath & "MoldPart.ipt")

    ' Set the scale to use.
    oDerivedPartDef.ScaleFactor = 1.1

    ' We could set other options for the derived part using the derived part definition.
    ' In this case the defaults are good except for the scale which we changed.

    ' Create the derived part.
    Call oPartDoc.ComponentDefinition.ReferenceComponents.DerivedPartComponents.Add(oDerivedPartDef)

    ' Save and close the part.
    Call oPartDoc.SaveAs(sFilePath & "ScaledMoldPart.ipt", False)
    oPartDoc.Close

    ' Create a new assembly file to put the mold base and scaled part together.
    Dim oAsmDoc As AssemblyDocument
    Set oAsmDoc = ThisApplication.Documents.Add(kAssemblyDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kAssemblyDocumentObject))

    ' Create the matrix used to define the position of the occurrences.  When a new
    ' matrix is created it is initialized to an identity matrix.  This will cause
    ' parts to be placed into the assembly in the same location that are in part space.
    Dim oMatrix As Matrix
    Set oMatrix = ThisApplication.TransientGeometry.CreateMatrix

    ' Place the mold base.
    Dim oOcc As ComponentOccurrence
    Set oOcc = oAsmDoc.ComponentDefinition.Occurrences.Add(sFilePath & "MoldBase.ipt", oMatrix)

    ' Rename the occurrence.  This sample uses the name to identify the occurrence later.
    ' This isn't the only method that could be used, but is one of the simplest.
    oOcc.Name = "Mold Base"

    ' Place the scaled part.
    Set oOcc = oAsmDoc.ComponentDefinition.Occurrences.Add(sFilePath & "ScaledMoldPart.ipt", oMatrix)
    oOcc.Name = "Mold Part"

    ' Save and close the assembly.
    Call oAsmDoc.SaveAs(sFilePath & "MoldSample.iam", False)
    oAsmDoc.Close

    ' Create a new part to derive the assembly into, subtracting the part from the mold base.
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Create a derived definition for the molded assembly.
    Dim oDerivedAsmDef As DerivedAssemblyDefinition
    Set oDerivedAsmDef = oPartDoc.ComponentDefinition.ReferenceComponents.DerivedAssemblyComponents.CreateDefinition(sFilePath & "MoldSample.iam")

    ' Set the part to be subtracted.
    oDerivedAsmDef.Occurrences.Item("Mold Part").InclusionOption = kDerivedSubtractAll

    ' Create the derived assembly.
    Call oPartDoc.ComponentDefinition.ReferenceComponents.DerivedAssemblyComponents.Add(oDerivedAsmDef)
End Sub

' Sub to create the part representing the molded part.
Private Sub CreateMoldPart(Filename As String)
    ' Create a new part document using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Create a new sketch on the XY base workplane.
    Dim oSketch As PlanarSketch
    Set oSketch = oPartDoc.ComponentDefinition.Sketches.Add(oPartDoc.ComponentDefinition.WorkPlanes(3))

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Draw the geometry defining the shape of the part.
    Dim oPoints As ObjectCollection
    Set oPoints = ThisApplication.TransientObjects.CreateObjectCollection
    oPoints.Add oTG.CreatePoint2d(-5, 0)
    oPoints.Add oTG.CreatePoint2d(-4, 3)
    oPoints.Add oTG.CreatePoint2d(-2, 4)
    oPoints.Add oTG.CreatePoint2d(0, 3)
    oPoints.Add oTG.CreatePoint2d(3, 4)
    oPoints.Add oTG.CreatePoint2d(4, 2)
    oPoints.Add oTG.CreatePoint2d(5, 0)

    Dim oSpline As SketchSpline
    Set oSpline = oSketch.SketchSplines.Add(oPoints)
    oSpline.FitMethod = kSweetSplineFit

    Dim oLine As SketchLine
    Set oLine = oSketch.SketchLines.AddByTwoPoints(oSpline.FitPoint(1), oSpline.FitPoint(oSpline.FitPointCount))

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a revolved feature.
    Call oPartDoc.ComponentDefinition.Features.RevolveFeatures.AddFull(oProfile, oLine, kJoinOperation)

    ' Save and close the document.
    Call oPartDoc.SaveAs(Filename, False)
    oPartDoc.Close
End Sub

' Sub to create the part representing the mold base.
Private Sub CreateMoldBase(Filename As String)
    ' Create a new part document using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Create a new sketch on the XY base workplane.
    Dim oSketch As PlanarSketch
    Set oSketch = oPartDoc.ComponentDefinition.Sketches.Add(oPartDoc.ComponentDefinition.WorkPlanes(3))

    ' Draw the geometry defining the shape of the part.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry
    Call oSketch.SketchLines.AddAsTwoPointRectangle(oTG.CreatePoint2d(-6, -5), oTG.CreatePoint2d(6, 5))

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extruded feature.
    Call oPartDoc.ComponentDefinition.Features.ExtrudeFeatures.AddByDistanceExtent(oProfile, 5, kNegativeExtentDirection, kJoinOperation)

    ' Save and close the document.
    Call oPartDoc.SaveAs(Filename, False)
    oPartDoc.Close
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Methods > DerivedAssemblyComponents.Add Method


DerivedAssemblyComponents.CreateDefinition Method

DerivedAssemblyComponents.CreateDefinition Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new Definition. The returned definition provides access to all of the items in the document that can be derived.

Visual Basic
Sub CreateDefinition(FullDocumentName As String, Result As [out, retval] DerivedAssemblyDefinition*)
Parameters
Parameters | Description
FullDocumentName | String that specifies the full document name of the assembly document to create the definition for. If only the FullFileName is specified, the master document within the assembly file is opened.
Remarks

Using this object you define which of these items will be derived when the derived component is created. When a DerivedAssemblyDefinition is initially created it is set so all available entities will be included in the derived component.

See Also

Shrink wrap substitute in assembly sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Methods > DerivedAssemblyComponents.CreateDefinition Method


DerivedAssemblyComponents.Item Method

DerivedAssemblyComponents.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DerivedAssemblyComponent*)
Parameters
Parameters | Description
index | Input Long value that specifies the to return.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Methods > DerivedAssemblyComponents.Item Method


DerivedAssemblyComponents Properties

DerivedAssemblyComponents Properties
Summary

The properties of the DerivedAssemblyComponents class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Parent | Property that returns the parent ComponentDefinition object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Properties


DerivedAssemblyComponents.Application Property

DerivedAssemblyComponents.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Properties > DerivedAssemblyComponents.Application Property


DerivedAssemblyComponents.Count Property

DerivedAssemblyComponents.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Properties > DerivedAssemblyComponents.Count Property


DerivedAssemblyComponents.Parent Property

DerivedAssemblyComponents.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Properties > DerivedAssemblyComponents.Parent Property


DerivedAssemblyComponents.Type Property

DerivedAssemblyComponents.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyComponents Interface > DerivedAssemblyComponents Properties > DerivedAssemblyComponents.Type Property


DerivedAssemblyDefinition Interface

DerivedAssemblyDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedAssemblyDefinition object is used to describe which parts in an assembly will be used during the creation of the DerivedAssemblyComponent. It is also used when querying and editing an existing derived assembly.

Class Hierarchy
Inventor::DerivedAssemblyDefinition
Visual Basic
Public Interface DerivedAssemblyDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedAssemblyComponent.Definition

DerivedAssemblyComponents.CreateDefinition

See Also

Shrink wrap substitute in assembly sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface


DerivedAssemblyDefinition Methods

DerivedAssemblyDefinition Methods
Summary

The methods of the DerivedAssemblyDefinition class are listed here.

Methods
Methods
Name | Description
GetHolePatchingOptions | Method that returns the hole patching options for the derived assembly.
GetRemoveBySizeOptions | Method that returns the simplification options specifying geometry to remove based on size.
GetRemoveByVisibilityOptions | Method that returns the simplification options specifying geometry to remove based on visibility.
IncludeAllSketches | Method that includes all sketches from the source assembly. This includes top level sketches in the source assembly as well as sketches in sub-assemblies and parts.
IncludeAllWorkFeatures | Method that includes all work features from the source assembly. This includes top level work features in the source assembly as well as work features in sub-assemblies and parts.
SetHolePatchingOptions | Method that sets the hole patching options for the derived assembly.
SetRemoveBySizeOptions | Method that sets the simplification options specifying geometry to remove based on size.
SetRemoveByVisibilityOptions | Method that sets the simplification options specifying geometry to remove based on visibility.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods


DerivedAssemblyDefinition.GetHolePatchingOptions Method

DerivedAssemblyDefinition.GetHolePatchingOptions Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns the hole patching options for the derived assembly.

Visual Basic
Sub GetHolePatchingOptions(ByRef HolePatchType As DerivedHolePatchEnum, ByRef MinimumPerimeter As double, ByRef MaximumPerimeter As double, ByRef Reserved As EdgeCollection*)
Parameters
Parameters | Description
HolePatchType | Output DerivedHolePatchEnum that specifies the holes to patch. Valid values are kDerivedPatchNone, kDerivedPatchAll and kDerivedPatchRange. If kDerivedPatchRange is returned, the MinimumPerimeter and MaximumPerimeter values define the range.
MinimumPerimeter | Output Double that specifies the minimum perimeter value if the HolePatchType is specified to be kDerivedPatchRange.
MaximumPerimeter | Output Double that specifies the maximum perimeter value if the HolePatchType is specified to be kDerivedPatchRange.
Reserved | For future use.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.GetHolePatchingOptions Method


DerivedAssemblyDefinition.GetRemoveBySizeOptions Method

DerivedAssemblyDefinition.GetRemoveBySizeOptions Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns the simplification options specifying geometry to remove based on size.

Visual Basic
Sub GetRemoveBySizeOptions(ByRef Enable As VARIANT_BOOL, ByRef SizeRatioPercentage As long)
Parameters
Parameters | Description
Enable | Output Boolean that specifies whether to enable or disable the 'remove by size' simplification option.
SizeRatioPercentage | Output Long that specifies the size ratio percentage value of parts/faces to be removed. Valid range is 0 to 100. The ratio indicates the difference between the part bounding box and the assembly bounding box. This value returns 1 and should be ignored if the Enable argument is returns False.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.GetRemoveBySizeOptions Method


DerivedAssemblyDefinition.GetRemoveByVisibilityOptions Method

DerivedAssemblyDefinition.GetRemoveByVisibilityOptions Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns the simplification options specifying geometry to remove based on visibility.

Visual Basic
Sub GetRemoveByVisibilityOptions(ByRef GeometryToRemove As DerivedGeometryRemovalEnum, ByRef VisibilityPercentage As long, ByRef IgnoreSurfaceFeatures As VARIANT_BOOL)
Parameters
Parameters | Description
GeometryToRemove | Output that specifies what geometry to remove. Valid values are kDerivedRemoveNone, kDerivedRemovePartsOnly and kDerivedRemovePartsAndFaces.
VisibilityPercentage | Output Long that specifies the visibility percentage value of parts/faces to be removed. For instance, a value of 0 indicates that parts/faces not visible in any view are to be removed. Valid range is 0 to 100. This value returns 0 and should be ignored if GeometryToRemove returns kDerivedRemoveNone.
IgnoreSurfaceFeatures | Output Boolean that specifies whether to ignore surfaces in visibility detection and removal. This value returns True and should be ignored if GeometryToRemove returns kDerivedRemoveNone.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.GetRemoveByVisibilityOptions Method


DerivedAssemblyDefinition.IncludeAllSketches Method

DerivedAssemblyDefinition.IncludeAllSketches Method
Summary

Method that includes all sketches from the source assembly. This includes top level sketches in the source assembly as well as sketches in sub-assemblies and parts.

Visual Basic
Sub IncludeAllSketches()
Remarks

Calling this method automatically sets the IncludeAllTopLevelSketches property to kDerivedIncludeAll. But note that it may not be possible to include all sketches. For instance, sketches that are invisible in the source assemblies and parts are not included. This method returns an error in the edit scenario and can only be used in the forward create scenario.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.IncludeAllSketches Method


DerivedAssemblyDefinition.IncludeAllWorkFeatures Method

DerivedAssemblyDefinition.IncludeAllWorkFeatures Method
Summary

Method that includes all work features from the source assembly. This includes top level work features in the source assembly as well as work features in sub-assemblies and parts.

Visual Basic
Sub IncludeAllWorkFeatures()
Remarks

Calling this method automatically sets the IncludeAllTopLevelWorkFeatures property to kDerivedIncludeAll. But note that it may not be possible to include all work features. For instance, work features that are invisible in the source assemblies and parts are not included. This method returns an error in the edit scenario and can only be used in the forward create scenario.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.IncludeAllWorkFeatures Method


DerivedAssemblyDefinition.SetHolePatchingOptions Method

DerivedAssemblyDefinition.SetHolePatchingOptions Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the hole patching options for the derived assembly.

Visual Basic
Sub SetHolePatchingOptions(HolePatchType As DerivedHolePatchEnum, ByRef MinimumPerimeter As [defaultvalue(0)] double, ByRef MaximumPerimeter As [defaultvalue(0)] double, ByRef Reserved As [optional] VARIANT)
Parameters
Parameters | Description
HolePatchType | Input DerivedHolePatchEnum that specifies the holes to patch. Valid values are kDerivedPatchNone, kDerivedPatchAll and kDerivedPatchRange. If kDerivedPatchRange is provided, the MinimumPerimeter and MaximumPerimeter values define the range.
MinimumPerimeter | Optional input Double that specifies the minimum perimeter value if the HolePatchType is specified to be kDerivedPatchRange. If not provided, an internal default value is assumed.
MaximumPerimeter | Optional input Double that specifies the maximum perimeter value if the HolePatchType is specified to be kDerivedPatchRange. If not provided, an internal default value is assumed.
Reserved | Optional input Variant reserved for future use. Currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.SetHolePatchingOptions Method


DerivedAssemblyDefinition.SetRemoveBySizeOptions Method

DerivedAssemblyDefinition.SetRemoveBySizeOptions Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the simplification options specifying geometry to remove based on size.

Visual Basic
Sub SetRemoveBySizeOptions(Enable As VARIANT_BOOL, ByRef SizeRatioPercentage As [defaultvalue(1)] long)
Parameters
Parameters | Description
Enable | Input Boolean that specifies whether to enable or disable the 'remove by size' simplification option.
SizeRatioPercentage | Optional input Long that specifies the size ratio percentage value of parts/faces to be removed. Valid range is 0 to 100. The ratio indicates the difference between the part bounding box and the assembly bounding box. This input is required if the Enable argument is specified to be True.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.SetRemoveBySizeOptions Method


DerivedAssemblyDefinition.SetRemoveByVisibilityOptions Method

DerivedAssemblyDefinition.SetRemoveByVisibilityOptions Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the simplification options specifying geometry to remove based on visibility.

Visual Basic
Sub SetRemoveByVisibilityOptions(GeometryToRemove As DerivedGeometryRemovalEnum, ByRef VisibilityPercentage As [defaultvalue(0)] long, ByRef IgnoreSurfaceFeatures As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
GeometryToRemove | Input that specifies what geometry to remove. Valid values are kDerivedRemoveNone, kDerivedRemovePartsOnly and kDerivedRemovePartsAndFaces.
VisibilityPercentage | Optional input Long that specifies the visibility percentage value of parts/faces to be removed. For instance, a value of 0 indicates that parts/faces not visible in any view are to be removed. Valid range is 0 to 100. This input is required if GeometryToRemove is specified to be kDerivedRemovePartsOnly or kDerivedRemovePartsAndFaces.
IgnoreSurfaceFeatures | Optional input Boolean that specifies whether to ignore surfaces in visibility detection and removal. If not specified, a default of True is assumed indicating that surfaces will be ignored.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Methods > DerivedAssemblyDefinition.SetRemoveByVisibilityOptions Method


DerivedAssemblyDefinition Properties

DerivedAssemblyDefinition Properties
Summary

The properties of the DerivedAssemblyDefinition class are listed here.

Properties
Name | Description
ActiveDesignViewRepresentation | Property that gets and sets the name of the active Design View Representation for the derived assembly.
ActiveLevelOfDetailRepresentation | Property that returns the name of the active Level of Detail Representation for the derived assembly.
ActivePositionalRepresentation | Property that gets and sets the name of the active Positional Representation for the derived assembly.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DeriveStyle | Property that gets and sets how bodies are derived. Valid options are kDeriveAsSingleBodyWithSeams, kDeriveAsSingleBodyNoSeams and kDeriveAsMultipleBodies. kDeriveAsWorkSurface is not a valid option for derived assemblies.
IncludeAllTopLeveliMateDefinitions | Property that defines whether all top level iMates in the source assembly are included in the derived assembly.
IncludeAllTopLevelParameters | Property that defines whether all top level parameters in the source assembly are included in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllTopLevelSketches | Property that defines whether all top level sketches in the source assembly are included in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllTopLevelWorkFeatures | Property that defines whether all top level work features in the source assembly are included in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
InclusionOption | Property that defines the inclusion status for all of the occurrences in the assembly. Valid options are kDerivedIncludeAll, kDerivedSubtractAll, kDerivedExcludeAll, kDerivedBoundingBox, kDerivedIntersect and kDerivedIndividualDefined.
IndependentSolidsOnFailedBoolean | This is IndependentSolidsOnFailedBoolean, a member of class DerivedAssemblyDefinition.
MirrorPlane | Property that gets and sets the plane about which the base assembly will be mirrored to create the derived assembly. This property is initialized to kDerivedPartNoMirrorPlane when the DerivedAssemblyDefinition object is created.
Occurrences | Property that gets the available in the selected assembly. This returns the top-level occurrences in the assembly. You can use the SubOccurrences of the DerivedAssemblyOccurrence object to traverse through the entire occurrence tree.
ReducedMemoryMode | Gets and sets reduced memory mode for the derived Assembly.
ScaleFactor | Property that gets and sets the scale factor for the Derived Assembly. The base assembly will be scaled by this factor to create the Derived Assembly. This property is initialized to 1.0 when the DerivedAssemblyDefinition object is created.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties


DerivedAssemblyDefinition.ActiveDesignViewRepresentation Property

DerivedAssemblyDefinition.ActiveDesignViewRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the name of the active Design View Representation for the derived assembly.

Visual Basic
Property ActiveDesignViewRepresentation() As String
Remarks

Setting the property to a null string or a return value of null string implies that a design view is applied un-associatively. If a design view name is returned, it implies that it was applied associatively.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.ActiveDesignViewRepresentation Property


DerivedAssemblyDefinition.ActiveLevelOfDetailRepresentation Property

DerivedAssemblyDefinition.ActiveLevelOfDetailRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the name of the active Level of Detail Representation for the derived assembly.

Visual Basic
Property ActiveLevelOfDetailRepresentation() As String
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.ActiveLevelOfDetailRepresentation Property


DerivedAssemblyDefinition.ActivePositionalRepresentation Property

DerivedAssemblyDefinition.ActivePositionalRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the name of the active Positional Representation for the derived assembly.

Visual Basic
Property ActivePositionalRepresentation() As String
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.ActivePositionalRepresentation Property


DerivedAssemblyDefinition.Application Property

DerivedAssemblyDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.Application Property


DerivedAssemblyDefinition.DeriveStyle Property

DerivedAssemblyDefinition.DeriveStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets how bodies are derived. Valid options are kDeriveAsSingleBodyWithSeams, kDeriveAsSingleBodyNoSeams and kDeriveAsMultipleBodies. kDeriveAsWorkSurface is not a valid option for derived assemblies.

Visual Basic
Property DeriveStyle() As DerivedComponentStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.DeriveStyle Property


DerivedAssemblyDefinition.IncludeAllTopLeveliMateDefinitions Property

DerivedAssemblyDefinition.IncludeAllTopLeveliMateDefinitions Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that defines whether all top level iMates in the source assembly are included in the derived assembly.

Visual Basic
Property IncludeAllTopLeveliMateDefinitions() As DerivedComponentOptionEnum
Remarks

Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined. If set to kDerivedIncludeAll, all top level iMate definitions will be included. If set to kDerivedExcludeAll, no iMate definitions will be included. If set to kDerivedIndividualDefined, then the inclusion state of each iMate definition is defined by the definition itself.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.IncludeAllTopLeveliMateDefinitions Property


DerivedAssemblyDefinition.IncludeAllTopLevelParameters Property

DerivedAssemblyDefinition.IncludeAllTopLevelParameters Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that defines whether all top level parameters in the source assembly are included in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllTopLevelParameters() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all top level parameters will be included. If set to kDerivedExcludeAll, no parameters will be included. If set to kDerivedIndividualDefined, then the inclusion state of each parameter is defined by the parameter itself.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.IncludeAllTopLevelParameters Property


DerivedAssemblyDefinition.IncludeAllTopLevelSketches Property

DerivedAssemblyDefinition.IncludeAllTopLevelSketches Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that defines whether all top level sketches in the source assembly are included in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllTopLevelSketches() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all top level sketches will be included. If set to kDerivedExcludeAll, no sketches will be derived. If set to kDerivedIndividualDefined, then the inclusion state of each sketch is defined by the sketch itself.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.IncludeAllTopLevelSketches Property


DerivedAssemblyDefinition.IncludeAllTopLevelWorkFeatures Property

DerivedAssemblyDefinition.IncludeAllTopLevelWorkFeatures Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that defines whether all top level work features in the source assembly are included in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllTopLevelWorkFeatures() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all top level work features will be included. If set to kDerivedExcludeAll, no work features will be derived. If set to kDerivedIndividualDefined, then the inclusion state of each work feature is defined by the work feature itself.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.IncludeAllTopLevelWorkFeatures Property


DerivedAssemblyDefinition.InclusionOption Property

DerivedAssemblyDefinition.InclusionOption Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that defines the inclusion status for all of the occurrences in the assembly. Valid options are kDerivedIncludeAll, kDerivedSubtractAll, kDerivedExcludeAll, kDerivedBoundingBox, kDerivedIntersect and kDerivedIndividualDefined.

Visual Basic
Property InclusionOption() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all occurrences in the assembly will be used and will add material to the solid body. If set to kDerivedSubtractAll, all occurrences will be used and will remove material from the solid body. If set to kDerivedExcludeAll, all occurrences will be ignored. If set to kDerivedBoundingBox, the bounding box of the component will be used for the derivation. If set to kDerivedIndividualDefined, the suboccurrences define their behavior.

An important distinction between 'All' and 'IndividualDefined' switches is that as occurrences are added to the assembly they will automatically be included if any of the 'All' switches are used. If the 'InidividualDefined' switch is used, new components added to the assembly will be set to kDerivedExludeAll.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.InclusionOption Property


DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean Property

DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean Property
Summary

This is IndependentSolidsOnFailedBoolean, a member of class DerivedAssemblyDefinition.

Visual Basic
Property IndependentSolidsOnFailedBoolean() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean Property


DerivedAssemblyDefinition.MirrorPlane Property

DerivedAssemblyDefinition.MirrorPlane Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the plane about which the base assembly will be mirrored to create the derived assembly. This property is initialized to kDerivedPartNoMirrorPlane when the DerivedAssemblyDefinition object is created.

Visual Basic
Property MirrorPlane() As DerivedPartMirrorPlaneEnum
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.MirrorPlane Property


DerivedAssemblyDefinition.Occurrences Property

DerivedAssemblyDefinition.Occurrences Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the available in the selected assembly. This returns the top-level occurrences in the assembly. You can use the SubOccurrences of the DerivedAssemblyOccurrence object to traverse through the entire occurrence tree.

Visual Basic
Property Occurrences() As DerivedAssemblyOccurrences**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.Occurrences Property


DerivedAssemblyDefinition.ReducedMemoryMode Property

DerivedAssemblyDefinition.ReducedMemoryMode Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets and sets reduced memory mode for the derived Assembly.

Visual Basic
Property ReducedMemoryMode() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.ReducedMemoryMode Property


DerivedAssemblyDefinition.ScaleFactor Property

DerivedAssemblyDefinition.ScaleFactor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the scale factor for the Derived Assembly. The base assembly will be scaled by this factor to create the Derived Assembly. This property is initialized to 1.0 when the DerivedAssemblyDefinition object is created.

Visual Basic
Property ScaleFactor() As double
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.ScaleFactor Property


DerivedAssemblyDefinition.Type Property

DerivedAssemblyDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyDefinition Interface > DerivedAssemblyDefinition Properties > DerivedAssemblyDefinition.Type Property


DerivedAssemblyOccurrence Interface

DerivedAssemblyOccurrence Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedAssemblyOccurrence object defines the behavior of an occurrence within a derived assembly.

Class Hierarchy
Inventor::DerivedAssemblyOccurrence
Visual Basic
Public Interface DerivedAssemblyOccurrence
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedAssemblyOccurrences.Item

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface


DerivedAssemblyOccurrence Properties

DerivedAssemblyOccurrence Properties
Summary

The properties of the DerivedAssemblyOccurrence class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
FailedBooleanOperation | This is FailedBooleanOperation, a member of class DerivedAssemblyOccurrence.
InclusionOption | Property that defines if this occurrence is included and if it is how it is used in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedSubtractAll, kDerivedExcludeAll, kDerivedBoundingBox, kDerivedIntersect and kDerivedIndividualDefined.
IsAssembly | Property that specifies whether this DerivedAssemblyOccurrence object represents a subassembly or a leaf part. This property is True in the case where it represents a subassembly. When it is a subassembly, the SubOccurrences property can be used to access the occurrences within this subassembly.
Name | Property that returns the name of the derived occurrence.
ReferencedOccurrence | Property that returns the in the assembly document. This can be used to perform additional queries to help to determine whether to include this occurrence or not.
SubOccurrences | Property that returns the in the top-level of the assembly this DerivedAssemblyOccurrence object represents. This property is only valid in the case where the IsAssembly property is True.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties


DerivedAssemblyOccurrence.Application Property

DerivedAssemblyOccurrence.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.Application Property


DerivedAssemblyOccurrence.FailedBooleanOperation Property

DerivedAssemblyOccurrence.FailedBooleanOperation Property
Summary

This is FailedBooleanOperation, a member of class DerivedAssemblyOccurrence.

Visual Basic
Property FailedBooleanOperation() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.FailedBooleanOperation Property


DerivedAssemblyOccurrence.InclusionOption Property

DerivedAssemblyOccurrence.InclusionOption Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that defines if this occurrence is included and if it is how it is used in the derived assembly. Valid values for this property are kDerivedIncludeAll, kDerivedSubtractAll, kDerivedExcludeAll, kDerivedBoundingBox, kDerivedIntersect and kDerivedIndividualDefined.

Visual Basic
Property InclusionOption() As DerivedComponentOptionEnum
Remarks

If this occurrence represents a subassembly, setting to kDerivedIncludeAll will cause all sub occurrences to add material to the solid body. Setting to kDerivedSubtractAll will cause all sub occurrences to remove material from the solid body. Setting to kDerivedExcludeAll will cause all sub occurrences will be ignored. If set to kDerivedBoundingBox, the bounding box of the component will be used for the derivation. If setting to kDerivedIndividualDefined, the sub occurrence's define their behavior. An important distinction between 'All' and 'IndividualDefined' switches is that as occurrences are added to the subassembly they will automatically be included if any of the 'All' switches are used. If the 'InidividualDefined' switch is used, new components added to the assembly will be set to kDerivedExludeAll.

If this occurrence represents a leaf part, then valid options are kDerivedIncludeAll, kDerivedSubtractAll, or kDerivedExcludeAll.

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.InclusionOption Property


DerivedAssemblyOccurrence.IsAssembly Property

DerivedAssemblyOccurrence.IsAssembly Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies whether this DerivedAssemblyOccurrence object represents a subassembly or a leaf part. This property is True in the case where it represents a subassembly. When it is a subassembly, the SubOccurrences property can be used to access the occurrences within this subassembly.

Visual Basic
Property IsAssembly() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.IsAssembly Property


DerivedAssemblyOccurrence.Name Property

DerivedAssemblyOccurrence.Name Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the name of the derived occurrence.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.Name Property


DerivedAssemblyOccurrence.ReferencedOccurrence Property

DerivedAssemblyOccurrence.ReferencedOccurrence Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the in the assembly document. This can be used to perform additional queries to help to determine whether to include this occurrence or not.

Visual Basic
Property ReferencedOccurrence() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.ReferencedOccurrence Property


DerivedAssemblyOccurrence.SubOccurrences Property

DerivedAssemblyOccurrence.SubOccurrences Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the in the top-level of the assembly this DerivedAssemblyOccurrence object represents. This property is only valid in the case where the IsAssembly property is True.

Visual Basic
Property SubOccurrences() As DerivedAssemblyOccurrences**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.SubOccurrences Property


DerivedAssemblyOccurrence.Type Property

DerivedAssemblyOccurrence.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrence Interface > DerivedAssemblyOccurrence Properties > DerivedAssemblyOccurrence.Type Property


DerivedAssemblyOccurrences Interface

DerivedAssemblyOccurrences Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedAssemblyOccurrences collection object provides access to the objects associated with a specific DerivedAssemblyDefinition object. The DerivedAssemblyOccurrence objects contained within the collection represent the top-level occurrences within the assembly you obtained the collection from.

Class Hierarchy
Inventor::DerivedAssemblyOccurrences
Visual Basic
Public Interface DerivedAssemblyOccurrences
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedAssemblyDefinition.Occurrences

DerivedAssemblyOccurrence.SubOccurrences

You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface


DerivedAssemblyOccurrences Methods

DerivedAssemblyOccurrences Methods
Summary

The methods of the DerivedAssemblyOccurrences class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface > DerivedAssemblyOccurrences Methods


DerivedAssemblyOccurrences.Item Method

DerivedAssemblyOccurrences.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DerivedAssemblyOccurrence*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the derived occurrence's name. If an out of range index or a name of a non-existent occurrence is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface > DerivedAssemblyOccurrences Methods > DerivedAssemblyOccurrences.Item Method


DerivedAssemblyOccurrences Properties

DerivedAssemblyOccurrences Properties
Summary

The properties of the DerivedAssemblyOccurrences class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface > DerivedAssemblyOccurrences Properties


DerivedAssemblyOccurrences.Application Property

DerivedAssemblyOccurrences.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface > DerivedAssemblyOccurrences Properties > DerivedAssemblyOccurrences.Application Property


DerivedAssemblyOccurrences.Count Property

DerivedAssemblyOccurrences.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface > DerivedAssemblyOccurrences Properties > DerivedAssemblyOccurrences.Count Property


DerivedAssemblyOccurrences.Type Property

DerivedAssemblyOccurrences.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedAssemblyOccurrences Interface > DerivedAssemblyOccurrences Properties > DerivedAssemblyOccurrences.Type Property


DerivedParameter Interface

DerivedParameter Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Object that represents a parameter that was created automatically by Inventor as the result of deriving a component or due to the creation of a DerivedParameterTable by linking to an Inventor document.

Class Hierarchy
Inventor::Parameter
    Inventor::DerivedParameter
Visual Basic
Public Interface DerivedParameter
Inherits Parameter
Notes

Members through which this object may be accessed include:

DerivedParameters.Item

For information on this object, please refer to Parameter, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameter Interface


DerivedParameter Properties

DerivedParameter Properties
Summary

The properties of the DerivedParameter class are listed here.

Properties
Name | Description
ReferencedEntity | Property that returns the Parameter that this parameter is dependent on.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameter Interface > DerivedParameter Properties


DerivedParameter.ReferencedEntity Property

DerivedParameter.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Parameter that this parameter is dependent on.

Visual Basic
Property ReferencedEntity() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameter Interface > DerivedParameter Properties > DerivedParameter.ReferencedEntity Property


DerivedParameters Interface

DerivedParameters Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Provides access to the derived parameters associated with the DerivedParameterTable object the collection was obtained from.

Class Hierarchy
Inventor::DerivedParameters
Visual Basic
Public Interface DerivedParameters
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedParameterTable.DerivedParameters

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameters Interface


DerivedParameters Methods

DerivedParameters Methods
Summary

The methods of the DerivedParameters class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified DerivedParameter object from the collection. This is the default method of the DerivedParameters collection object.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameters Interface > DerivedParameters Methods


DerivedParameters.Item Method

DerivedParameters.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified DerivedParameter object from the collection. This is the default method of the DerivedParameters collection object.

Visual Basic
Sub Item(Value As VARIANT, Result As [out, retval] DerivedParameter*)
Parameters
Parameters | Description
Value | Value that specifies the DerivedParameter to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the parameter name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameters Interface > DerivedParameters Methods > DerivedParameters.Item Method


DerivedParameters Properties

DerivedParameters Properties
Summary

The properties of the DerivedParameters class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameters Interface > DerivedParameters Properties


DerivedParameters.Count Property

DerivedParameters.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameters Interface > DerivedParameters Properties > DerivedParameters.Count Property


DerivedParameters.Type Property

DerivedParameters.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameters Interface > DerivedParameters Properties > DerivedParameters.Type Property


DerivedParameterTable Interface

DerivedParameterTable Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DerivedParameterTable object represents the connection to an Inventor document.

Class Hierarchy
Inventor::DerivedParameterTable
Visual Basic
Public Interface DerivedParameterTable
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedParameterTables.Add

DerivedParameterTables.Add2

DerivedParameterTables.Item

See Also

Selectively link parameters sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface


DerivedParameterTable Methods

DerivedParameterTable Methods
Summary

The methods of the DerivedParameterTable class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the DerivedParameterTable object. This method will fail if the HasReferenceComponent property returns true.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Methods


DerivedParameterTable.Delete Method

DerivedParameterTable.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the DerivedParameterTable object. This method will fail if the HasReferenceComponent property returns true.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Methods > DerivedParameterTable.Delete Method


DerivedParameterTable.GetReferenceKey Method

DerivedParameterTable.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Methods > DerivedParameterTable.GetReferenceKey Method


DerivedParameterTable Properties

DerivedParameterTable Properties
Summary

The properties of the DerivedParameterTable class are listed here.

Properties
Name | Description
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DerivedParameters | Property that returns the DerivedParameters collection object.
HasReferenceComponent | Property that indicates whether this table has a reference component and hence was created as a result of deriving a component. If this property returns false, it indicates that this table was created by the user by linking to a part or assembly document.
LinkedParameters | Property that gets and sets the collection of parameters that have been linked from the referenced document.
Parent | Property that returns the parent object of this DerivedParameterTable. This property will return different types of objects depending on the document type the DerivedParameterTable is contained in. If the DerivedParameterTable is in a part document then the parent is a PartComponentDefinition object. If the DerivedParameterTable is in an assembly document then the parent is an AssemblyComponentDefinition.
ReferenceComponent | Property that returns the reference component. This property returns Nothing if HasReferenceComponent returns false.
ReferencedDocumentDescriptor | Property that returns the referenced Inventor document.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties


DerivedParameterTable.AttributeSets Property

DerivedParameterTable.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.AttributeSets Property


DerivedParameterTable.DerivedParameters Property

DerivedParameterTable.DerivedParameters Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the DerivedParameters collection object.

Visual Basic
Property DerivedParameters() As DerivedParameters**
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.DerivedParameters Property


DerivedParameterTable.HasReferenceComponent Property

DerivedParameterTable.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates whether this table has a reference component and hence was created as a result of deriving a component. If this property returns false, it indicates that this table was created by the user by linking to a part or assembly document.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.HasReferenceComponent Property


DerivedParameterTable.LinkedParameters Property

DerivedParameterTable.LinkedParameters Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the collection of parameters that have been linked from the referenced document.

Visual Basic
Property LinkedParameters() As ObjectCollection *
See Also

Selectively link paramaters sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.LinkedParameters Property


DerivedParameterTable.Parent Property

DerivedParameterTable.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object of this DerivedParameterTable. This property will return different types of objects depending on the document type the DerivedParameterTable is contained in. If the DerivedParameterTable is in a part document then the parent is a PartComponentDefinition object. If the DerivedParameterTable is in an assembly document then the parent is an AssemblyComponentDefinition.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.Parent Property


DerivedParameterTable.ReferenceComponent Property

DerivedParameterTable.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the reference component. This property returns Nothing if HasReferenceComponent returns false.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.ReferenceComponent Property


DerivedParameterTable.ReferencedDocumentDescriptor Property

DerivedParameterTable.ReferencedDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the referenced Inventor document.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.ReferencedDocumentDescriptor Property


DerivedParameterTable.Type Property

DerivedParameterTable.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTable Interface > DerivedParameterTable Properties > DerivedParameterTable.Type Property


DerivedParameterTables Interface

DerivedParameterTables Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Creates and provides access to the parameters that reference parameters in another Inventor document.

Class Hierarchy
Inventor::DerivedParameterTables
Visual Basic
Public Interface DerivedParameterTables
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameters.DerivedParameterTables

See Also

Selectively link parameters sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface


DerivedParameterTables Methods

DerivedParameterTables Methods
Summary

The methods of the DerivedParameterTables class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DerivedParameterTable object, given an existing Inventor part or assembly document as input. Returns the resulting DerivedParameterTable object. The creation fails if the input document does not have any exported parameters.
Add2 | Method that creates a new DerivedParameterTable object, given an existing Inventor part or assembly document as input. Returns the resulting DerivedParameterTable object. This method fails if the input document has already been linked.
Item | Method that returns the specified DerivedParameterTable object from the collection. This is the default method of the DerivedParameterTables collection object.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Methods


DerivedParameterTables.Add Method

DerivedParameterTables.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new DerivedParameterTable object, given an existing Inventor part or assembly document as input. Returns the resulting DerivedParameterTable object. The creation fails if the input document does not have any exported parameters.

Visual Basic
Sub Add(FullFilename As String, Result As [out, retval] DerivedParameterTable*)
Parameters
Parameters | Description
FullFileName | String value that contains the full path to the part or assembly document.
See Also

Selectively link paramaters sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Methods > DerivedParameterTables.Add Method


DerivedParameterTables.Add2 Method

DerivedParameterTables.Add2 Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new DerivedParameterTable object, given an existing Inventor part or assembly document as input. Returns the resulting DerivedParameterTable object. This method fails if the input document has already been linked.

Visual Basic
Sub Add2(FullFilename As String, ByRef ParametersToLink As [optional] VARIANT, Result As [out, retval] DerivedParameterTable*)
Parameters
Parameters | Description
ParametersToLink | Optional input ObjectCollection that specifies the parameters in the input file to link. If this argument is not specified, all the exported parameters in the input file are linked. If there are no exported parameters, the method will fail. If specified, all parameters in the input file that are not already exported are automatically exported.
FullFileName | Input String value that contains the full path to the part or assembly document.
Example

"Selectively link paramaters"

This sample demonstrates the selective linking of parameters from another Inventor file. Before running this sample, make sure that the file C:\temp\block.ipt exists (or change the path in the sample). The sample assumes that the file contains parameters named d0, d1 and d2.

Sub SelectivelyLinkParams()

    ' Open the source document invisible.
    Dim oSourceDoc As PartDocument
    Set oSourceDoc = ThisApplication.Documents.Open("C:\temp\block.ipt", False)

    ' Set a reference to the component definition.
    Dim oSourceCompDef As PartComponentDefinition
    Set oSourceCompDef = oSourceDoc.ComponentDefinition

    Dim oParamsToLink As ObjectCollection
    Set oParamsToLink = ThisApplication.TransientObjects.CreateObjectCollection

    ' Add parameters named "d0" and "d1".
    ' This assumes that the source document contains
    ' parameters with these names.
    oParamsToLink.Add oSourceCompDef.Parameters.Item("d0")
    oParamsToLink.Add oSourceCompDef.Parameters.Item("d1")

    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject)

    ' Create a derived parameter table that links only to "d0"
    ' and "d1" in the source part.
    ' Note: If parameters "d0" and "d1" in the source part
    ' are not already exported, they will be automatically
    ' exported and hence will result in changing the source part.
    Dim oDerivedParamTable As DerivedParameterTable
    Set oDerivedParamTable = oPartDoc.ComponentDefinition.Parameters. _
        DerivedParameterTables.Add2("C:\temp\block.ipt", oParamsToLink)

    ' Add parameter named "d2"
    ' This assumes that the source document
    ' contains a parameters named "d2".
    oParamsToLink.Add oSourceCompDef.Parameters.Item("d2")

    ' Change derived parameter table so it also links to "d2".
    oDerivedParamTable.LinkedParameters = oParamsToLink
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Methods > DerivedParameterTables.Add2 Method


DerivedParameterTables.Item Method

DerivedParameterTables.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified DerivedParameterTable object from the collection. This is the default method of the DerivedParameterTables collection object.

Visual Basic
Sub Item(Value As long, Result As [out, retval] DerivedParameterTable*)
Parameters
Parameters | Description
Value | Value that specifies the object to return.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Methods > DerivedParameterTables.Item Method


DerivedParameterTables Properties

DerivedParameterTables Properties
Summary

The properties of the DerivedParameterTables class are listed here.

Properties
Name | Description
Count | Property that specifies the number of items in the collection.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Properties


DerivedParameterTables.Count Property

DerivedParameterTables.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Properties > DerivedParameterTables.Count Property


DerivedParameterTables.Type Property

DerivedParameterTables.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedParameterTables Interface > DerivedParameterTables Properties > DerivedParameterTables.Type Property


DerivedPartComponent Interface

DerivedPartComponent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedPartComponent object represents a specific derived part instance.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedPartComponent
        Inventor::DerivedPartComponentProxy
Visual Basic
Public Interface DerivedPartComponent
Inherits ReferenceComponent
Notes

Members through which this object may be accessed include:

DerivedPartComponentProxy.NativeObject

DerivedPartComponents.Add

DerivedPartComponents.Item

ClientFeatureElement.Element

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface


DerivedPartComponent Properties

DerivedPartComponent Properties
Summary

The properties of the DerivedPartComponent class are listed here.

Properties
Name | Description
Definition | Property that returns the derived part definition that defines the current state of the derived part.
iMateDefinitions | Property that returns the iMateDefinition objects that were created as a result of this derived part.
Parameters | Property that returns the Parameter objects that were created as a result of this derived part. This property will return Nothing in the case where the link to the part has been broken.
SketchBlockDefinitions | Property that returns the SketchBlockDefinition objects that were created as a result of this derived part.
SketchBlocks | Property that returns the SketchBlock objects that were created as a result of this derived part.
Sketches | Property that returns the PlanarSketch objects that were created as a result of this derived part.
Sketches3D | Property that returns the Sketch3D objects that were created as a result of this derived part.
SolidBodies | Property that returns the ReferenceFeature objects that represent the solids that were created as a result of this derived part.
SuppressLinkToFile | Property that suppresses or unsuppresses the link to the base part.
SurfaceBodies | Property that returns the SurfaceBody objects that represent work surfaces that were created as a result of this derived part.
WorkFeatures | Property that returns the WorkPlane, WorkAxis, and WorkPoint objects that were created as a result of this derived part.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties


DerivedPartComponent.Definition Property

DerivedPartComponent.Definition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the derived part definition that defines the current state of the derived part.

Visual Basic
Property Definition() As DerivedPartDefinition*
Remarks

The state of the derived part can be changed by modifying the values of the returned descriptor and assigning it back to the derived part using the DerivedPartDefinition property. The part will be updated as a result of the assignment.

Note: Definition property will return Nothing if the link to the base part is broken or if the link to the base part could not be resolved.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.Definition Property


DerivedPartComponent.iMateDefinitions Property

DerivedPartComponent.iMateDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the iMateDefinition objects that were created as a result of this derived part.

Visual Basic
Property iMateDefinitions() As iMateDefinitionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.iMateDefinitions Property


DerivedPartComponent.Parameters Property

DerivedPartComponent.Parameters Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the Parameter objects that were created as a result of this derived part. This property will return Nothing in the case where the link to the part has been broken.

Visual Basic
Property Parameters() As ParametersEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.Parameters Property


DerivedPartComponent.SketchBlockDefinitions Property

DerivedPartComponent.SketchBlockDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the SketchBlockDefinition objects that were created as a result of this derived part.

Visual Basic
Property SketchBlockDefinitions() As SketchBlockDefinitionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.SketchBlockDefinitions Property


DerivedPartComponent.SketchBlocks Property

DerivedPartComponent.SketchBlocks Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the SketchBlock objects that were created as a result of this derived part.

Visual Basic
Property SketchBlocks() As SketchBlocksEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.SketchBlocks Property


DerivedPartComponent.Sketches Property

DerivedPartComponent.Sketches Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the PlanarSketch objects that were created as a result of this derived part.

Visual Basic
Property Sketches() As SketchesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.Sketches Property


DerivedPartComponent.Sketches3D Property

DerivedPartComponent.Sketches3D Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the Sketch3D objects that were created as a result of this derived part.

Visual Basic
Property Sketches3D() As Sketches3DEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.Sketches3D Property


DerivedPartComponent.SolidBodies Property

DerivedPartComponent.SolidBodies Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ReferenceFeature objects that represent the solids that were created as a result of this derived part.

Visual Basic
Property SolidBodies() As ReferenceFeaturesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.SolidBodies Property


DerivedPartComponent.SuppressLinkToFile Property

DerivedPartComponent.SuppressLinkToFile Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that suppresses or unsuppresses the link to the base part.

Visual Basic
Property SuppressLinkToFile() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.SuppressLinkToFile Property


DerivedPartComponent.SurfaceBodies Property

DerivedPartComponent.SurfaceBodies Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SurfaceBody objects that represent work surfaces that were created as a result of this derived part.

Visual Basic
Property SurfaceBodies() As ReferenceFeaturesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.SurfaceBodies Property


DerivedPartComponent.WorkFeatures Property

DerivedPartComponent.WorkFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the WorkPlane, WorkAxis, and WorkPoint objects that were created as a result of this derived part.

Visual Basic
Property WorkFeatures() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponent Interface > DerivedPartComponent Properties > DerivedPartComponent.WorkFeatures Property


DerivedPartComponentProxy Interface

DerivedPartComponentProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DerivedPartComponent object.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedPartComponent
        Inventor::DerivedPartComponentProxy
Visual Basic
Public Interface DerivedPartComponentProxy
Inherits DerivedPartComponent
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponentProxy Interface


DerivedPartComponentProxy Properties

DerivedPartComponentProxy Properties
Summary

The properties of the DerivedPartComponentProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponentProxy Interface > DerivedPartComponentProxy Properties


DerivedPartComponentProxy.ContainingOccurrence Property

DerivedPartComponentProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponentProxy Interface > DerivedPartComponentProxy Properties > DerivedPartComponentProxy.ContainingOccurrence Property


DerivedPartComponentProxy.NativeObject Property

DerivedPartComponentProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As DerivedPartComponent**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponentProxy Interface > DerivedPartComponentProxy Properties > DerivedPartComponentProxy.NativeObject Property


DerivedPartComponents Interface

DerivedPartComponents Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedPartComponents collection object provides access to all of the existing objects in a part and provides methods to create additional derived components.

Class Hierarchy
Inventor::DerivedPartComponents
Visual Basic
Public Interface DerivedPartComponents
Inherits IDispatch
Remarks

The various derived component creation methods only include the exported objects by default. However, similar to the user interface dialog, you can include additional objects before creating the derived part (using DerivedPartComponents.Add)

Notes

Members through which this object may be accessed include:

ReferenceComponents.DerivedPartComponents

See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface


DerivedPartComponents Methods

DerivedPartComponents Methods
Summary

The methods of the DerivedPartComponents class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DerivedPartDefinition using the information supplied by the input DerivedPartDefinition object. If successful, the new DerivedPartComponent is returned.
CreateCoordinateSystemDef | Method that creates a new DerivedPartCoordinateSystemDef object.
CreateDefinition | Method that creates a new DerivedAssemblyDefinition. The returned definition provides access to all of the items in the document that can be derived. Using this object you define which of these items will be derived when the derived component is created. When a DerivedAssemblyDefinition is initially created it is set so all available entities will be included in the derived component.
CreateTransformDef | Method that creates a new DerivedPartTransformDef object.
CreateUniformScaleDef | Method that creates a new DerivedPartUniformScaleDef object.
Item | Property that returns the specified DerivedPartComponent object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods


DerivedPartComponents.Add Method

DerivedPartComponents.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new DerivedPartDefinition using the information supplied by the input DerivedPartDefinition object. If successful, the new DerivedPartComponent is returned.

Visual Basic
Sub Add(Definition As DerivedPartDefinition, Result As [out, retval] DerivedPartComponent*)
Parameters
Parameters | Description
Definition | Input object that defines the derived component.
See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods > DerivedPartComponents.Add Method


DerivedPartComponents.CreateCoordinateSystemDef Method

DerivedPartComponents.CreateCoordinateSystemDef Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new DerivedPartCoordinateSystemDef object.

Visual Basic
Sub CreateCoordinateSystemDef(FullFileName As String, Result As [out, retval] DerivedPartCoordinateSystemDef*)
Parameters
Parameters | Description
FullFileName | Input string that specifies the name of the file to create the definition for.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods > DerivedPartComponents.CreateCoordinateSystemDef Method


DerivedPartComponents.CreateDefinition Method

DerivedPartComponents.CreateDefinition Method Available in Inventor Available in Server
Summary

Method that creates a new DerivedAssemblyDefinition. The returned definition provides access to all of the items in the document that can be derived. Using this object you define which of these items will be derived when the derived component is created. When a DerivedAssemblyDefinition is initially created it is set so all available entities will be included in the derived component.

Visual Basic
Sub CreateDefinition(FullDocumentName As String, Result As [out, retval] DerivedPartUniformScaleDef*)
Parameters
Parameters | Description
FullDocumentName | Input string that specifies the full document name of the assembly. If only the FullFileName is specified, the master document within the file is used.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods > DerivedPartComponents.CreateDefinition Method


DerivedPartComponents.CreateTransformDef Method

DerivedPartComponents.CreateTransformDef Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new DerivedPartTransformDef object.

Visual Basic
Sub CreateTransformDef(FullFileName As String, Result As [out, retval] DerivedPartTransformDef*)
Parameters
Parameters | Description
FullFileName | Input string that specifies the name of the file to create the definition for.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods > DerivedPartComponents.CreateTransformDef Method


DerivedPartComponents.CreateUniformScaleDef Method

DerivedPartComponents.CreateUniformScaleDef Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new DerivedPartUniformScaleDef object.

Visual Basic
Sub CreateUniformScaleDef(FullFileName As String, Result As [out, retval] DerivedPartUniformScaleDef*)
Parameters
Parameters | Description
FullFileName | Input string that specifies the name of the file to create the definition for.
See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods > DerivedPartComponents.CreateUniformScaleDef Method


DerivedPartComponents.Item Method

DerivedPartComponents.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified DerivedPartComponent object from the collection.

Visual Basic
Sub Item(Value As long, Result As [out, retval] DerivedPartComponent*)
Parameters
Parameters | Description
Value | Input Long value that specifies the to return.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Methods > DerivedPartComponents.Item Method


DerivedPartComponents Properties

DerivedPartComponents Properties
Summary

The properties of the DerivedPartComponents class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Parent | Property that returns the parent ComponentDefinition object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Properties


DerivedPartComponents.Application Property

DerivedPartComponents.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Properties > DerivedPartComponents.Application Property


DerivedPartComponents.Count Property

DerivedPartComponents.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Properties > DerivedPartComponents.Count Property


DerivedPartComponents.Parent Property

DerivedPartComponents.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Properties > DerivedPartComponents.Parent Property


DerivedPartComponents.Type Property

DerivedPartComponents.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartComponents Interface > DerivedPartComponents Properties > DerivedPartComponents.Type Property


DerivedPartCoordinateSystemDef Interface

DerivedPartCoordinateSystemDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DerivedPartCoordinateSystemDef object allows you to query and define the coordinate system for a derived part, as well as to include and exclude elements and characteristics from the base part to the part to be derived.

Class Hierarchy
Inventor::DerivedPartDefinition
    Inventor::DerivedPartCoordinateSystemDef
Visual Basic
Public Interface DerivedPartCoordinateSystemDef
Inherits DerivedPartDefinition
Notes

Members through which this object may be accessed include:

DerivedPartComponents.CreateCoordinateSystemDef

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface


DerivedPartCoordinateSystemDef Methods

DerivedPartCoordinateSystemDef Methods
Summary

The methods of the DerivedPartCoordinateSystemDef class are listed here.

Methods
Methods
Name | Description
GetCoordinateSystem | Method that returns the coordinate system.
GetScale | Method that returns the scale factors along the x, y and z directions.
SetCoordinateSystem | Method that sets the coordinate system.
SetScale | Method that sets the scale factors along the x, y and z directions.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Methods


DerivedPartCoordinateSystemDef.GetCoordinateSystem Method

DerivedPartCoordinateSystemDef.GetCoordinateSystem Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the coordinate system.

Visual Basic
Sub GetCoordinateSystem(ByRef Origin As Point*, ByRef XAxis As Vector*, ByRef YAxis As Vector*, ByRef ZAxis As Vector*)
Parameters
Parameters | Description
Origin | Output that specifies the origin of the coordinate system.
XAxis | Output that specifies the x-axis of the coordinate system.
YAxis | Output that specifies the y-axis of the coordinate system.
ZAxis | Output that specifies the z-axis of the coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Methods > DerivedPartCoordinateSystemDef.GetCoordinateSystem Method


DerivedPartCoordinateSystemDef.GetScale Method

DerivedPartCoordinateSystemDef.GetScale Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the scale factors along the x, y and z directions.

Visual Basic
Sub GetScale(ByRef XScale As double, ByRef YScale As double, ByRef ZScale As double)
Parameters
Parameters | Description
XScale | Output Double that specifies the x scale.
YScale | Output Double that specifies the y scale.
ZScale | Output Double that specifies the z scale.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Methods > DerivedPartCoordinateSystemDef.GetScale Method


DerivedPartCoordinateSystemDef.SetCoordinateSystem Method

DerivedPartCoordinateSystemDef.SetCoordinateSystem Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the coordinate system.

Visual Basic
Sub SetCoordinateSystem(Origin As Point, XAxis As Vector, YAxis As Vector)
Parameters
Parameters | Description
Origin | Input that specifies the origin of the coordinate system.
XAxis | Input that specifies the x-axis of the coordinate system.
YAxis | Input that specifies the y-axis of the coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Methods > DerivedPartCoordinateSystemDef.SetCoordinateSystem Method


DerivedPartCoordinateSystemDef.SetScale Method

DerivedPartCoordinateSystemDef.SetScale Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the scale factors along the x, y and z directions.

Visual Basic
Sub SetScale(XScale As double, YScale As double, ZScale As double)
Parameters
Parameters | Description
XScale | Input Double that specifies the x scale.
YScale | Input Double that specifies the y scale.
ZScale | Input Double that specifies the z scale.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Methods > DerivedPartCoordinateSystemDef.SetScale Method


DerivedPartCoordinateSystemDef Properties

DerivedPartCoordinateSystemDef Properties
Summary

The properties of the DerivedPartCoordinateSystemDef class are listed here.

Properties
Name | Description
MirrorPlane | Sets the plane about which the base part will be mirrored to create the derived part.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Properties


DerivedPartCoordinateSystemDef.MirrorPlane Property

DerivedPartCoordinateSystemDef.MirrorPlane Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Sets the plane about which the base part will be mirrored to create the derived part.

Visual Basic
Property MirrorPlane() As DerivedPartMirrorPlaneEnum
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartCoordinateSystemDef Interface > DerivedPartCoordinateSystemDef Properties > DerivedPartCoordinateSystemDef.MirrorPlane Property


DerivedPartDefinition Interface

DerivedPartDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedPartDefinition object is used to describe which entities within a part will be used during the creation of the DerivedPartComponent. It is also used when querying and editing an existing derived part.

Class Hierarchy
Inventor::DerivedPartDefinition
    Inventor::DerivedPartCoordinateSystemDef
    Inventor::DerivedPartTransformDef
    Inventor::DerivedPartUniformScaleDef
Visual Basic
Public Interface DerivedPartDefinition
Inherits IDispatch
Remarks

When a DerivedPartDefinition is initially created it is set so all available entities will be included in the derived part.

Notes

Members through which this object may be accessed include:

DerivedPartComponent.Definition

the DerivedPartDefinition object will become invalid after it has been set in the DerivedPartComponent object. In other words, all the properties will return failure.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface


DerivedPartDefinition Methods

DerivedPartDefinition Methods
Summary

The methods of the DerivedPartDefinition class are listed here.

Methods
Methods
Name | Description
ExcludeAll | Method that causes all entities within the derived part component to be set to kDerivedExcludeAll.
IncludeAll | Method that causes all entities within the derived part component to be set to kDerivedIncludeAll.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Methods


DerivedPartDefinition.ExcludeAll Method

DerivedPartDefinition.ExcludeAll Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that causes all entities within the derived part component to be set to kDerivedExcludeAll.

Visual Basic
Sub ExcludeAll()
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Methods > DerivedPartDefinition.ExcludeAll Method


DerivedPartDefinition.IncludeAll Method

DerivedPartDefinition.IncludeAll Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that causes all entities within the derived part component to be set to kDerivedIncludeAll.

Visual Basic
Sub IncludeAll()
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Methods > DerivedPartDefinition.IncludeAll Method


DerivedPartDefinition Properties

DerivedPartDefinition Properties
Summary

The properties of the DerivedPartDefinition class are listed here.

Properties
Name | Description
ActiveDesignViewRepresentation | Property that gets and sets the name of the active Design View Representation for the derived part. Setting the property to a null string or a return value of null string implies that a design view is applied un-associatively. If a design view name is returned, it implies that it was applied associatively.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DeriveStyle | Property that gets and sets how bodies are derived. Valid options are kDeriveAsSingleBodyWithSeams, kDeriveAsSingleBodyNoSeams, kDeriveAsMultipleBodies and kDeriveAsWorkSurface.
iMateDefinitions | Property that gets the collection of iMates available in the selected part along with the inclusion option for each iMate.
IncludeAlliMateDefinitions | Property that defines whether all iMates are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllParameters | Property that defines whether exported parameters are included in the derived part. This property is initialized to True when the DerivedPartDefinition object is created.
IncludeAllSolids | Property that defines whether all solids are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllSurfaces | Property that defines whether all surfaces are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
Parameters | Property that gets the collection of parameters available in the selected part along with the inclusion option for each parameter.
ReducedMemoryMode | This is ReducedMemoryMode, a member of class DerivedPartDefinition.
Solids | Property that gets the collection of solids available in the selected part along with the inclusion option for each solid.
Surfaces | Property that gets the collection of surfaces available in the selected part along with the inclusion option for each surface.
Type | Property returning an enum indicating this object's type.
UseColorOverridesFromSource | This is UseColorOverridesFromSource, a member of class DerivedPartDefinition.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties


DerivedPartDefinition.ActiveDesignViewRepresentation Property

DerivedPartDefinition.ActiveDesignViewRepresentation Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the name of the active Design View Representation for the derived part. Setting the property to a null string or a return value of null string implies that a design view is applied un-associatively. If a design view name is returned, it implies that it was applied associatively.

Visual Basic
Property ActiveDesignViewRepresentation() As String
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.ActiveDesignViewRepresentation Property


DerivedPartDefinition.Application Property

DerivedPartDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.Application Property


DerivedPartDefinition.DeriveStyle Property

DerivedPartDefinition.DeriveStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets how bodies are derived. Valid options are kDeriveAsSingleBodyWithSeams, kDeriveAsSingleBodyNoSeams, kDeriveAsMultipleBodies and kDeriveAsWorkSurface.

Visual Basic
Property DeriveStyle() As DerivedComponentStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.DeriveStyle Property


DerivedPartDefinition.iMateDefinitions Property

DerivedPartDefinition.iMateDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the collection of iMates available in the selected part along with the inclusion option for each iMate.

Visual Basic
Property iMateDefinitions() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.iMateDefinitions Property


DerivedPartDefinition.IncludeAlliMateDefinitions Property

DerivedPartDefinition.IncludeAlliMateDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that defines whether all iMates are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAlliMateDefinitions() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all iMate definitions will be included. This also includes any iMate definitions that are added to the part at a later time. If set to kDerivedExcludeAll, no iMate definitions will be included. If set to kDerivedIndividualDefined, then the inclusion state of each iMate definition is defined by the definition itself. The available iMateDefinitions are accessed using the iMateDefinitions property of the DerivedPartDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.IncludeAlliMateDefinitions Property


DerivedPartDefinition.IncludeAllParameters Property

DerivedPartDefinition.IncludeAllParameters Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that defines whether exported parameters are included in the derived part. This property is initialized to True when the DerivedPartDefinition object is created.

Visual Basic
Property IncludeAllParameters() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.IncludeAllParameters Property


DerivedPartDefinition.IncludeAllSolids Property

DerivedPartDefinition.IncludeAllSolids Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that defines whether all solids are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllSolids() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all solids will be included. This also includes any solids that are added to the part at a later time. If set to kDerivedExcludeAll, no solids will be included. If set to kDerivedIndividualDefined, then the inclusion state of each solid is defined by the solid itself. The available solids are accessed using the Solids property of the DerivedPartDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.IncludeAllSolids Property


DerivedPartDefinition.IncludeAllSurfaces Property

DerivedPartDefinition.IncludeAllSurfaces Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that defines whether all surfaces are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllSurfaces() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all surfaces will be included. This also includes any surfaces that are added to the part at a later time. If set to kDerivedExcludeAll, no surfaces will be imported. If set to kDerivedIndividualDefined, then the inclusion state of each surface is defined by the surface itself. The available surfaces are accessed using the Surfaces property of the DerivedPartDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.IncludeAllSurfaces Property


DerivedPartDefinition.Parameters Property

DerivedPartDefinition.Parameters Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the collection of parameters available in the selected part along with the inclusion option for each parameter.

Visual Basic
Property Parameters() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.Parameters Property


DerivedPartDefinition.ReducedMemoryMode Property

DerivedPartDefinition.ReducedMemoryMode Property
Summary

This is ReducedMemoryMode, a member of class DerivedPartDefinition.

Visual Basic
Property ReducedMemoryMode() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.ReducedMemoryMode Property


DerivedPartDefinition.Solids Property

DerivedPartDefinition.Solids Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the collection of solids available in the selected part along with the inclusion option for each solid.

Visual Basic
Property Solids() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.Solids Property


DerivedPartDefinition.Surfaces Property

DerivedPartDefinition.Surfaces Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the collection of surfaces available in the selected part along with the inclusion option for each surface.

Visual Basic
Property Surfaces() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.Surfaces Property


DerivedPartDefinition.Type Property

DerivedPartDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.Type Property


DerivedPartDefinition.UseColorOverridesFromSource Property

DerivedPartDefinition.UseColorOverridesFromSource Property
Summary

This is UseColorOverridesFromSource, a member of class DerivedPartDefinition.

Visual Basic
Property UseColorOverridesFromSource() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartDefinition Interface > DerivedPartDefinition Properties > DerivedPartDefinition.UseColorOverridesFromSource Property


DerivedPartEntities Interface

DerivedPartEntities Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedPartEntities collection object provides access to all of the objects associated with a specific DerivedPartDefinition object.

Class Hierarchy
Inventor::DerivedPartEntities
Visual Basic
Public Interface DerivedPartEntities
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartDefinition.iMateDefinitions

DerivedPartDefinition.Parameters

DerivedPartDefinition.Solids

DerivedPartDefinition.Surfaces

DerivedPartUniformScaleDef.SketchBlockDefinitions

DerivedPartUniformScaleDef.SketchBlocks

DerivedPartUniformScaleDef.Sketches

DerivedPartUniformScaleDef.Sketches3D

DerivedPartUniformScaleDef.WorkFeatures

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface


DerivedPartEntities Methods

DerivedPartEntities Methods
Summary

The methods of the DerivedPartEntities class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified DerivedPartEntity object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface > DerivedPartEntities Methods


DerivedPartEntities.Item Method

DerivedPartEntities.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns the specified DerivedPartEntity object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DerivedPartEntity*)
Parameters
Parameters | Description
index | Value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface > DerivedPartEntities Methods > DerivedPartEntities.Item Method


DerivedPartEntities Properties

DerivedPartEntities Properties
Summary

The properties of the DerivedPartEntities class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface > DerivedPartEntities Properties


DerivedPartEntities.Application Property

DerivedPartEntities.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface > DerivedPartEntities Properties > DerivedPartEntities.Application Property


DerivedPartEntities.Count Property

DerivedPartEntities.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface > DerivedPartEntities Properties > DerivedPartEntities.Count Property


DerivedPartEntities.Type Property

DerivedPartEntities.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntities Interface > DerivedPartEntities Properties > DerivedPartEntities.Type Property


DerivedPartEntity Interface

DerivedPartEntity Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DerivedPartEntity object contains the information associated with an entity being derived.

Class Hierarchy
Inventor::DerivedPartEntity
Visual Basic
Public Interface DerivedPartEntity
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartEntities.Item

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntity Interface


DerivedPartEntity Properties

DerivedPartEntity Properties
Summary

The properties of the DerivedPartEntity class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
IncludeEntity | Property that defines whether this entity is included in the derived part. This property is initialized to True when the DerivedPartDefinition object is created.
ReferencedEntity | Property that returns the entity in the part document. This can be used to perform additional queries to help to determine whether to include this entity or not.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntity Interface > DerivedPartEntity Properties


DerivedPartEntity.Application Property

DerivedPartEntity.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntity Interface > DerivedPartEntity Properties > DerivedPartEntity.Application Property


DerivedPartEntity.IncludeEntity Property

DerivedPartEntity.IncludeEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that defines whether this entity is included in the derived part. This property is initialized to True when the DerivedPartDefinition object is created.

Visual Basic
Property IncludeEntity() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntity Interface > DerivedPartEntity Properties > DerivedPartEntity.IncludeEntity Property


DerivedPartEntity.ReferencedEntity Property

DerivedPartEntity.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the entity in the part document. This can be used to perform additional queries to help to determine whether to include this entity or not.

Visual Basic
Property ReferencedEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntity Interface > DerivedPartEntity Properties > DerivedPartEntity.ReferencedEntity Property


DerivedPartEntity.Type Property

DerivedPartEntity.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartEntity Interface > DerivedPartEntity Properties > DerivedPartEntity.Type Property


DerivedPartTransformDef Interface

DerivedPartTransformDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DerivedPartCoordinateSystemDef object allows you to define the transformation for a derived part, as well as to include and exclude elements from the base part to the part to be derived.

Class Hierarchy
Inventor::DerivedPartDefinition
    Inventor::DerivedPartTransformDef
Visual Basic
Public Interface DerivedPartTransformDef
Inherits DerivedPartDefinition
Notes

Members through which this object may be accessed include:

DerivedPartComponents.CreateTransformDef

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartTransformDef Interface


DerivedPartTransformDef Methods

DerivedPartTransformDef Methods
Summary

The methods of the DerivedPartTransformDef class are listed here.

Methods
Methods
Name | Description
GetTransformation | Method that gets the matrix describing the transform that should be applied to the entities being derived.
SetTransformation | Method that sets the matrix describing the transform that should be applied to the entities being derived. Operations allowed in the transform are: translation, rotation, non-uniform scale and mirror.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartTransformDef Interface > DerivedPartTransformDef Methods


DerivedPartTransformDef.GetTransformation Method

DerivedPartTransformDef.GetTransformation Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that gets the matrix describing the transform that should be applied to the entities being derived.

Visual Basic
Sub GetTransformation(ByRef Transform As Matrix*, ByRef Mirror As VARIANT_BOOL)
Parameters
Parameters | Description
Transform | Output that describes the transform to apply to the entities derived.
Mirror | Output Boolean that specifies whether the derived part is mirrored.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartTransformDef Interface > DerivedPartTransformDef Methods > DerivedPartTransformDef.GetTransformation Method


DerivedPartTransformDef.SetTransformation Method

DerivedPartTransformDef.SetTransformation Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the matrix describing the transform that should be applied to the entities being derived. Operations allowed in the transform are: translation, rotation, non-uniform scale and mirror.

Visual Basic
Sub SetTransformation(Transform As Matrix, ByRef Mirror As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Transform | Input object that specifies the transform for the derived part.
Mirror | Optional input Boolean that specifies whether the derived part should be mirrored.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartTransformDef Interface > DerivedPartTransformDef Methods > DerivedPartTransformDef.SetTransformation Method


DerivedPartUniformScaleDef Interface

DerivedPartUniformScaleDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The DerivedPartUniformScaleDef object allows you to query and define the uniform scale for a derived part, as well as to include and exclude elements and characteristics from the base part to the part to be derived.

Class Hierarchy
Inventor::DerivedPartDefinition
    Inventor::DerivedPartUniformScaleDef
Visual Basic
Public Interface DerivedPartUniformScaleDef
Inherits DerivedPartDefinition
Notes

Members through which this object may be accessed include:

DerivedPartComponents.CreateDefinition

DerivedPartComponents.CreateUniformScaleDef

See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface


DerivedPartUniformScaleDef Properties

DerivedPartUniformScaleDef Properties
Summary

The properties of the DerivedPartUniformScaleDef class are listed here.

Properties
Name | Description
IncludeAllSketchBlockDefinitions | Property that defines whether all sketch block definitions are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllSketches | Property that defines whether all sketches are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllSketches3D | Property that defines whether all 3D sketches are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
IncludeAllWorkFeatures | Property that defines whether all work features are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.
MirrorPlane | Property that gets and sets the plane about which the base part will be mirrored to create the derived part. This property is initialized to kDerivedPartNoMirrorPlane when the DerivedPartDefinition object is created.
ScaleFactor | Property that gets and sets the scale factor for the Derived Part. The base part will be scaled by this factor to create the Derived Part. This property is initialized to 1.0 when the DerivedPartDefinition object is created.
SketchBlockDefinitions | Property that gets the collection of sketch block definitions available in the selected part along with the inclusion option for each sketch block definition.
SketchBlocks | Property that gets the collection of sketch blocks available in the selected part along with the inclusion option for each sketch block.
Sketches | Property that returns the collection of sketches available in the selected part along with the inclusion option for each sketch.
Sketches3D | Property that gets the collection of 3D sketches available in the selected part along with the inclusion option for each sketch.
WorkFeatures | Property that returns the collection of work features available in the selected part along with the inclusion option for each work feature.
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties


DerivedPartUniformScaleDef.IncludeAllSketchBlockDefinitions Property

DerivedPartUniformScaleDef.IncludeAllSketchBlockDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that defines whether all sketch block definitions are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllSketchBlockDefinitions() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all definitions will be included. This also includes any definitions that are added to the part at a later time. If set to kDerivedExcludeAll, no definitions will be imported. If set to kDerivedIndividualDefined, then the inclusion state of each sketch block definition is defined by the definition itself. The available definitions are accessed using the SketchBlockDefinitions property of the DerivedPartDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.IncludeAllSketchBlockDefinitions Property


DerivedPartUniformScaleDef.IncludeAllSketches Property

DerivedPartUniformScaleDef.IncludeAllSketches Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that defines whether all sketches are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllSketches() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all sketches will be included. This also includes any sketches that are added to the part at a later time. If set to kDerivedExcludeAll, no sketches will be imported. If set to kDerivedIndividualDefined, then the inclusion state of each sketch is defined by the sketch itself. The available sketches are accessed using the Sketches property of the DerivedPartDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.IncludeAllSketches Property


DerivedPartUniformScaleDef.IncludeAllSketches3D Property

DerivedPartUniformScaleDef.IncludeAllSketches3D Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that defines whether all 3D sketches are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllSketches3D() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all sketches will be included. This also includes any sketches that are added to the part at a later time. If set to kDerivedExcludeAll, no sketches will be imported. If set to kDerivedIndividualDefined, then the inclusion state of each sketch is defined by the sketch itself. The available sketches are accessed using the Sketches3D property of the DerivedPartDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.IncludeAllSketches3D Property


DerivedPartUniformScaleDef.IncludeAllWorkFeatures Property

DerivedPartUniformScaleDef.IncludeAllWorkFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that defines whether all work features are included in the derived part. Valid input for this property is kDerivedIncludeAll, kDerivedExcludeAll, and kDerivedIndividualDefined.

Visual Basic
Property IncludeAllWorkFeatures() As DerivedComponentOptionEnum
Remarks

If set to kDerivedIncludeAll, all work features will be included. This also includes any work features that are added to the part at a later time. If set to kDerivedExcludeAll, no work features will be imported. If set to kDerivedIndividualDefined, then the inclusion state of each work feature is defined by the surface itself. The available work features are accessed using the WorkFeatures property.

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.IncludeAllWorkFeatures Property


DerivedPartUniformScaleDef.MirrorPlane Property

DerivedPartUniformScaleDef.MirrorPlane Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the plane about which the base part will be mirrored to create the derived part. This property is initialized to kDerivedPartNoMirrorPlane when the DerivedPartDefinition object is created.

Visual Basic
Property MirrorPlane() As DerivedPartMirrorPlaneEnum
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.MirrorPlane Property


DerivedPartUniformScaleDef.ScaleFactor Property

DerivedPartUniformScaleDef.ScaleFactor Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the scale factor for the Derived Part. The base part will be scaled by this factor to create the Derived Part. This property is initialized to 1.0 when the DerivedPartDefinition object is created.

Visual Basic
Property ScaleFactor() As double
See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.ScaleFactor Property


DerivedPartUniformScaleDef.SketchBlockDefinitions Property

DerivedPartUniformScaleDef.SketchBlockDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the collection of sketch block definitions available in the selected part along with the inclusion option for each sketch block definition.

Visual Basic
Property SketchBlockDefinitions() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.SketchBlockDefinitions Property


DerivedPartUniformScaleDef.SketchBlocks Property

DerivedPartUniformScaleDef.SketchBlocks Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the collection of sketch blocks available in the selected part along with the inclusion option for each sketch block.

Visual Basic
Property SketchBlocks() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.SketchBlocks Property


DerivedPartUniformScaleDef.Sketches Property

DerivedPartUniformScaleDef.Sketches Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection of sketches available in the selected part along with the inclusion option for each sketch.

Visual Basic
Property Sketches() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.Sketches Property


DerivedPartUniformScaleDef.Sketches3D Property

DerivedPartUniformScaleDef.Sketches3D Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets the collection of 3D sketches available in the selected part along with the inclusion option for each sketch.

Visual Basic
Property Sketches3D() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.Sketches3D Property


DerivedPartUniformScaleDef.WorkFeatures Property

DerivedPartUniformScaleDef.WorkFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection of work features available in the selected part along with the inclusion option for each work feature.

Visual Basic
Property WorkFeatures() As DerivedPartEntities**
You are here: Symbol Reference > Inventor Library > Objects > DerivedPartUniformScaleDef Interface > DerivedPartUniformScaleDef Properties > DerivedPartUniformScaleDef.WorkFeatures Property


DesignProject Interface

DesignProject Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 7
Summary

The DesignProject object represents an Inventor project file (.ipj).

Class Hierarchy
Inventor::DesignProject
Visual Basic
Public Interface DesignProject
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContentCenterConfiguration.Parent

DesignProjectManager.ActiveDesignProject

DesignProjects.Add

DesignProjects.AddExisting

DesignProjects.Item

DesignProjects.ItemByName

IntentConfiguration.Parent

ProjectPath.Parent

See Also

Set active project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface


DesignProject Methods

DesignProject Methods
Summary

The methods of the DesignProject class are listed here.

Methods
Methods
Name | Description
_Activate | This is _Activate, a member of class DesignProject.
Activate | Method that activates the DesignProject. This requires all the documents to be closed in Inventor.
GetCustomSection | Method that returns a custom section (in the form of an XML string) from the project file.
GetIncludedCustomSection | Method that returns a custom section (in the form of an XML string) from the included project file.
Remove | Method that removes the DesignProject from the list of available project files. This does not delete the .ipj file on disk. This method fails if the project is currently active.
SetCustomSection | Method that adds or modifies a custom section (in the form of an XML string) in the project file. If a section with the given name is found, the section is replaced, else the section is added.
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods


DesignProject._Activate Method

DesignProject._Activate Method
Summary

This is _Activate, a member of class DesignProject.

Visual Basic
Sub _Activate()
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods > DesignProject._Activate Method


DesignProject.Activate Method

DesignProject.Activate Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that activates the DesignProject. This requires all the documents to be closed in Inventor.

Visual Basic
Sub Activate(ByRef SetAsDefaultProject As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
SetAsDefaultProject | Optional input Boolean that specifies whether this project should be set as the default project for the next session of Inventor and Apprentice. If not specified, a value of True is used indicating the this project will be set as the default.
See Also

Set active project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods > DesignProject.Activate Method


DesignProject.GetCustomSection Method

DesignProject.GetCustomSection Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns a custom section (in the form of an XML string) from the project file.

Visual Basic
Sub GetCustomSection(Name As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Name | Input String that specifies name of the custom section in the project file. If the section with the specified name is not found, a null string is returned. The following strings can be used to retrieve some of the built-in sections: 'ContentCenterConfig', 'VaultOptions', and 'AutodeskIntent.'
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods > DesignProject.GetCustomSection Method


DesignProject.GetIncludedCustomSection Method

DesignProject.GetIncludedCustomSection Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns a custom section (in the form of an XML string) from the included project file.

Visual Basic
Sub GetIncludedCustomSection(Name As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Name | Input String that specifies name of the custom section in the included project file. If the section with the specified name is not found or there is no included project, a null string is returned. The following strings can be used to retrieve some of the built-in sections: 'ContentCenterConfig', 'VaultOptions', and 'AutodeskIntent'.
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods > DesignProject.GetIncludedCustomSection Method


DesignProject.Remove Method

DesignProject.Remove Method Available in Apprentice
Summary

Method that removes the DesignProject from the list of available project files. This does not delete the .ipj file on disk. This method fails if the project is currently active.

Visual Basic
Sub Remove()
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods > DesignProject.Remove Method


DesignProject.SetCustomSection Method

DesignProject.SetCustomSection Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that adds or modifies a custom section (in the form of an XML string) in the project file. If a section with the given name is found, the section is replaced, else the section is added.

Visual Basic
Sub SetCustomSection(Name As String, CustomSection As String)
Parameters
Parameters | Description
Name | Input String that specifies name of the custom section in the project file. The name should be as unique and human-readable as possible. If a section with this name is found, the existing section is replaced with the input CustomSection string. If not found, a new section is created.
CustomSection | Input String containing an XML string with custom data to be stored in the project file. The name of the section should be included in this XML string, for example 'ApplicationXYZProjectOptions'.
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Methods > DesignProject.SetCustomSection Method


DesignProject Properties

DesignProject Properties
Summary

The properties of the DesignProject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ContentCenterPath | Property that gets and sets the directory in which to look for the Content Center components. If set, this value overrides the corresponding application option. The ContentCenterPathOverridden property returns whether the path is overridden and provides the ability to clear the override.
ContentCenterPathOverridden | Property that gets and sets whether the content center path is overridden by this project. Setting the property to False clears the override and path in the application option is used.
CreationTime | Property that gets and sets the creation time of the project file.
DesignDataPath | Property that gets and sets the directory in which to look for the Design Data such as styles. If set, this value overrides the corresponding application option. The DesignDataPathOverridden property returns whether the path is overridden and provides the ability to clear the override.
DesignDataPathOverridden | Property that gets and sets whether the design data path is overridden by this project. Setting the property to False clears the override and path in the application option is used.
FrequentlyUsedPaths | Property that returns a ProjectPaths object that contains the list of frequently used paths and provides ability to add/remove paths.
FullFileName | Property that returns the fully qualified file name for this design project.
ImportedComponentsFolderName | Property that gets and sets folder name for imported components. If you select to save imported component files to your Workspace, this folder is created and the component files are saved to it.
ImportedTopLevelAssembliesFolderName | Property that gets and sets folder name for imported top level assemblies. If you select to save imported assembly files to your Workspace, separate from your parts, this folder is created and the assembly files are saved to it.
IncludedProject | Property that gets and sets the full file name of another project to include in this project. The search paths in the included file are included in the project. The project type of the included file overrides the setting in the project. The property can be set to a null string to indicate that there are no included projects.
LibraryPaths | Property that returns a ProjectPaths object that contains the list of library paths and provides ability to add/remove paths.
Name | Property that gets and sets the name for this design project.
OldVersionsToKeep | Property that gets and sets the number of versions to store in the OldVersions folder for each file saved. The first time a file is saved in a project, an OldVersions folder for that file is created. When the file is saved, the prior version is moved automatically to its OldVersions folder. After the number of old versions reaches the maximum, the oldest version is deleted when a newer version is moved into the folder. A value of -1 indicates that all versions should be saved.
Owner | Property that gets and sets the string identifying the owner of the project.
Parent | Property that returns the parent DesignProjectManager object.
ProjectType | Property that gets and sets the project type. Setting the type to shared or semi-isolated requires workgroup(s) to be specified. Setting the type to a Vault project requires a workspace to be specified but no workgroups or included project should be specified.
ReleaseId | Property that gets and sets version of the project.
Shortcuts | Property that gets and sets an array of strings specifying the shortcuts for the project. If there are no shortcuts, an empty array is returned. The property can be set to an empty array or Nothing to delete all shortcuts. Shortcuts are stored in the projects folder.
StylesLibraryAccess | Gets/Sets the status of the styles library access for the Design Project.
TemplatesPath | Property that gets and sets the directory in which to look for the template files. If set, this value overrides the corresponding application option. The TemplatesPathOverridden property returns whether the path is overridden and provides the ability to clear the override.
TemplatesPathOverridden | Property that gets and sets whether the templates path is overridden by this project. Setting the property to False clears the override and path in the application option is used.
Type | Returns an ObjectTypeEnum indicating this object's type.
UsingUniqueFileNames | Property that gets and sets whether duplicate file names are used in the project.
VaultName | Property that gets and sets the vault name. Applicable only if the ProjectType is set to kVaultMode.
VaultPublishPath | Property that gets and sets the publish folder for Vault. Applicable only if the ProjectType is set to kVaultMode.
VaultServer | Property that gets and sets the vault server. Applicable only if the ProjectType is set to kVaultMode.
VaultVirtualPath | Property that gets and sets the virtual folder for Vault. Applicable only if the ProjectType is set to kVaultMode.
WorkgroupPaths | Property that returns a ProjectPaths object that contains the list of workgroup paths and provides ability to add/remove paths.
WorkspacePath | Property that gets and sets the workspace folder for the project.
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties


DesignProject.Application Property

DesignProject.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.Application Property


DesignProject.ContentCenterPath Property

DesignProject.ContentCenterPath Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the directory in which to look for the Content Center components. If set, this value overrides the corresponding application option. The ContentCenterPathOverridden property returns whether the path is overridden and provides the ability to clear the override.

Visual Basic
Property ContentCenterPath() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.ContentCenterPath Property


DesignProject.ContentCenterPathOverridden Property

DesignProject.ContentCenterPathOverridden Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the content center path is overridden by this project. Setting the property to False clears the override and path in the application option is used.

Visual Basic
Property ContentCenterPathOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.ContentCenterPathOverridden Property


DesignProject.CreationTime Property

DesignProject.CreationTime Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the creation time of the project file.

Visual Basic
Property CreationTime() As DATE
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.CreationTime Property


DesignProject.DesignDataPath Property

DesignProject.DesignDataPath Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the directory in which to look for the Design Data such as styles. If set, this value overrides the corresponding application option. The DesignDataPathOverridden property returns whether the path is overridden and provides the ability to clear the override.

Visual Basic
Property DesignDataPath() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.DesignDataPath Property


DesignProject.DesignDataPathOverridden Property

DesignProject.DesignDataPathOverridden Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the design data path is overridden by this project. Setting the property to False clears the override and path in the application option is used.

Visual Basic
Property DesignDataPathOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.DesignDataPathOverridden Property


DesignProject.FrequentlyUsedPaths Property

DesignProject.FrequentlyUsedPaths Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns a ProjectPaths object that contains the list of frequently used paths and provides ability to add/remove paths.

Visual Basic
Property FrequentlyUsedPaths() As ProjectPaths**
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.FrequentlyUsedPaths Property


DesignProject.FullFileName Property

DesignProject.FullFileName Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the fully qualified file name for this design project.

Visual Basic
Property FullFileName() As BSTR*
See Also

Set active project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.FullFileName Property


DesignProject.ImportedComponentsFolderName Property

DesignProject.ImportedComponentsFolderName Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets folder name for imported components. If you select to save imported component files to your Workspace, this folder is created and the component files are saved to it.

Visual Basic
Property ImportedComponentsFolderName() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.ImportedComponentsFolderName Property


DesignProject.ImportedTopLevelAssembliesFolderName Property

DesignProject.ImportedTopLevelAssembliesFolderName Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets folder name for imported top level assemblies. If you select to save imported assembly files to your Workspace, separate from your parts, this folder is created and the assembly files are saved to it.

Visual Basic
Property ImportedTopLevelAssembliesFolderName() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.ImportedTopLevelAssembliesFolderName Property


DesignProject.IncludedProject Property

DesignProject.IncludedProject Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the full file name of another project to include in this project. The search paths in the included file are included in the project. The project type of the included file overrides the setting in the project. The property can be set to a null string to indicate that there are no included projects.

Visual Basic
Property IncludedProject() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.IncludedProject Property


DesignProject.LibraryPaths Property

DesignProject.LibraryPaths Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns a ProjectPaths object that contains the list of library paths and provides ability to add/remove paths.

Visual Basic
Property LibraryPaths() As ProjectPaths**
See Also

Query and create library paths sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.LibraryPaths Property


DesignProject.Name Property

DesignProject.Name Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the name for this design project.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.Name Property


DesignProject.OldVersionsToKeep Property

DesignProject.OldVersionsToKeep Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the number of versions to store in the OldVersions folder for each file saved. The first time a file is saved in a project, an OldVersions folder for that file is created. When the file is saved, the prior version is moved automatically to its OldVersions folder. After the number of old versions reaches the maximum, the oldest version is deleted when a newer version is moved into the folder. A value of -1 indicates that all versions should be saved.

Visual Basic
Property OldVersionsToKeep() As long
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.OldVersionsToKeep Property


DesignProject.Owner Property

DesignProject.Owner Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the string identifying the owner of the project.

Visual Basic
Property Owner() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.Owner Property


DesignProject.Parent Property

DesignProject.Parent Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the parent DesignProjectManager object.

Visual Basic
Property Parent() As DesignProjectManager**
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.Parent Property


DesignProject.ProjectType Property

DesignProject.ProjectType Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the project type. Setting the type to shared or semi-isolated requires workgroup(s) to be specified. Setting the type to a Vault project requires a workspace to be specified but no workgroups or included project should be specified.

Visual Basic
Property ProjectType() As MultiUserModeEnum
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.ProjectType Property


DesignProject.ReleaseId Property

DesignProject.ReleaseId Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets version of the project.

Visual Basic
Property ReleaseId() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.ReleaseId Property


DesignProject.Shortcuts Property

DesignProject.Shortcuts Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets an array of strings specifying the shortcuts for the project. If there are no shortcuts, an empty array is returned. The property can be set to an empty array or Nothing to delete all shortcuts. Shortcuts are stored in the projects folder.

Visual Basic
Property Shortcuts() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.Shortcuts Property


DesignProject.StylesLibraryAccess Property

DesignProject.StylesLibraryAccess Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets/Sets the status of the styles library access for the Design Project.

Visual Basic
Property StylesLibraryAccess() As StylesLibraryAccessEnum
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.StylesLibraryAccess Property


DesignProject.TemplatesPath Property

DesignProject.TemplatesPath Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the directory in which to look for the template files. If set, this value overrides the corresponding application option. The TemplatesPathOverridden property returns whether the path is overridden and provides the ability to clear the override.

Visual Basic
Property TemplatesPath() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.TemplatesPath Property


DesignProject.TemplatesPathOverridden Property

DesignProject.TemplatesPathOverridden Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the templates path is overridden by this project. Setting the property to False clears the override and path in the application option is used.

Visual Basic
Property TemplatesPathOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.TemplatesPathOverridden Property


DesignProject.Type Property

DesignProject.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 7
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.Type Property


DesignProject.UsingUniqueFileNames Property

DesignProject.UsingUniqueFileNames Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether duplicate file names are used in the project.

Visual Basic
Property UsingUniqueFileNames() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.UsingUniqueFileNames Property


DesignProject.VaultName Property

DesignProject.VaultName Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the vault name. Applicable only if the ProjectType is set to kVaultMode.

Visual Basic
Property VaultName() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.VaultName Property


DesignProject.VaultPublishPath Property

DesignProject.VaultPublishPath Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the publish folder for Vault. Applicable only if the ProjectType is set to kVaultMode.

Visual Basic
Property VaultPublishPath() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.VaultPublishPath Property


DesignProject.VaultServer Property

DesignProject.VaultServer Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the vault server. Applicable only if the ProjectType is set to kVaultMode.

Visual Basic
Property VaultServer() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.VaultServer Property


DesignProject.VaultVirtualPath Property

DesignProject.VaultVirtualPath Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the virtual folder for Vault. Applicable only if the ProjectType is set to kVaultMode.

Visual Basic
Property VaultVirtualPath() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.VaultVirtualPath Property


DesignProject.WorkgroupPaths Property

DesignProject.WorkgroupPaths Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns a ProjectPaths object that contains the list of workgroup paths and provides ability to add/remove paths.

Visual Basic
Property WorkgroupPaths() As ProjectPaths**
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.WorkgroupPaths Property


DesignProject.WorkspacePath Property

DesignProject.WorkspacePath Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the workspace folder for the project.

Visual Basic
Property WorkspacePath() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignProject Interface > DesignProject Properties > DesignProject.WorkspacePath Property


DesignProjectManager Interface

DesignProjectManager Interface Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The DesignProjectManager object provides access to project files related functionality in Inventor.

Class Hierarchy
Inventor::DesignProjectManager
Visual Basic
Public Interface DesignProjectManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.DesignProjectManager

DesignProject.Parent

Application.DesignProjectManager

See Also

Query and create library paths sample

Set active project sample

Create project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface


DesignProjectManager Methods

DesignProjectManager Methods
Summary

The methods of the DesignProjectManager class are listed here.

Methods
Methods
Name | Description
AddOptionsButton | This is AddOptionsButton, a member of class DesignProjectManager.
IsFileInActiveProject | Method that returns whether the given file is located within the active project using the resolution rules of the project, and additionally returns the path type (library, workspace, workgroup) and its name.
ResolveFile | Method that runs the file resolver from the source path and attempts to find the destination file name, in the active project. The full file name of the resolved file is returned. A null string is returned if no file was resolved to.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Methods


DesignProjectManager.AddOptionsButton Method

DesignProjectManager.AddOptionsButton Method
Summary

This is AddOptionsButton, a member of class DesignProjectManager.

Visual Basic
Sub AddOptionsButton(ClientId As String, DisplayName As String, TooltipText As String, ByRef StandardIcon As [optional] VARIANT, Result As [out, retval] ProjectOptionsButton*)
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Methods > DesignProjectManager.AddOptionsButton Method


DesignProjectManager.IsFileInActiveProject Method

DesignProjectManager.IsFileInActiveProject Method Available in Apprentice Introduced in Inventor 2011
Summary

Method that returns whether the given file is located within the active project using the resolution rules of the project, and additionally returns the path type (library, workspace, workgroup) and its name.

Visual Basic
Sub IsFileInActiveProject(FileName As String, ByRef ProjectPathType As LocationTypeEnum, ByRef ProjectPathName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
ProjectPathType | Output LocationTypeEnum that returns where the input file was found. Possible returns values are: kLibraryLocation, kWorkspaceLocation, kWorkgroupLocation, kUnknownLocation (if none of the above or if the file is not found within the project).
ProjectPathName | Output String that returns the name of the library, workspace or workgroup that the file was found in. Returns a null string if none of the above.
FullFileName | Input String that specifies the name of a file. This can either be a full file name (recommended), a relative file name or a file name with no path.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Methods > DesignProjectManager.IsFileInActiveProject Method


DesignProjectManager.ResolveFile Method

DesignProjectManager.ResolveFile Method Available in Apprentice Introduced in Inventor 2011
Summary

Method that runs the file resolver from the source path and attempts to find the destination file name, in the active project. The full file name of the resolved file is returned. A null string is returned if no file was resolved to.

Visual Basic
Sub ResolveFile(SourcePath As String, DestinationFileName As String, Options As [optional] VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
SourcePath | Input String that specifies the source path to start the file resolution from.
DestinationFileName | Input String that specifies the destination file name to resolve to. This can either be a relative file name or a full file name.
Options | Optional input Variant reserved for future use. Currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Methods > DesignProjectManager.ResolveFile Method


DesignProjectManager Properties

DesignProjectManager Properties
Summary

The properties of the DesignProjectManager class are listed here.

Properties
Name | Description
ActiveDesignProject | Property that returns the currently active design project. Use DesignProject.Activate method to activate a project.
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
DesignProjects | Property that returns the DesignProjects collection object containing all the projects.
Parent | Property that returns the parent Application or ApprenticeServerComponent object.
Type | Property returning kDesignProjectManagerObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Properties


DesignProjectManager.ActiveDesignProject Property

DesignProjectManager.ActiveDesignProject Property Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the currently active design project. Use DesignProject.Activate method to activate a project.

Visual Basic
Property ActiveDesignProject() As DesignProject**
See Also

Query and create library paths sample

Set active project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Properties > DesignProjectManager.ActiveDesignProject Property


DesignProjectManager.Application Property

DesignProjectManager.Application Property Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Properties > DesignProjectManager.Application Property


DesignProjectManager.DesignProjects Property

DesignProjectManager.DesignProjects Property Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the DesignProjects collection object containing all the projects.

Visual Basic
Property DesignProjects() As DesignProjects**
See Also

Set active project sample

Create project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Properties > DesignProjectManager.DesignProjects Property


DesignProjectManager.Parent Property

DesignProjectManager.Parent Property Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the parent Application or ApprenticeServerComponent object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Properties > DesignProjectManager.Parent Property


DesignProjectManager.Type Property

DesignProjectManager.Type Property Available in Apprentice Introduced in Inventor 2011
Summary

Property returning kDesignProjectManagerObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DesignProjectManager Interface > DesignProjectManager Properties > DesignProjectManager.Type Property


DesignProjects Interface

DesignProjects Interface Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The DesignProjects collection object provides access to all the existing projects and provides methods to create additional projects.

Class Hierarchy
Inventor::DesignProjects
Visual Basic
Public Interface DesignProjects
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DesignProjectManager.DesignProjects

You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface


DesignProjects Methods

DesignProjects Methods
Summary

The methods of the DesignProjects class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DesignProject. The newly created DesignProject is returned.
AddExisting | Method that adds an existing project file to the list of project files. This is equivalent of browsing to a specific ipj file on disk and choosing it in the Projects editor dialog. If the design project is already in the collection, the corresponding DesignProject object is returned.
Item | Property that returns the specified DesignProject object from the collection.
ItemByName | Property that returns the specified DesignProject object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Methods


DesignProjects.Add Method

DesignProjects.Add Method Available in Apprentice Introduced in Inventor 2011
Summary

Method that creates a new DesignProject. The newly created DesignProject is returned.

Visual Basic
Sub Add(ProjectType As MultiUserModeEnum, Name As String, ProjectPath As String, Result As [out, retval] DesignProject*)
Parameters
Parameters | Description
ProjectType | Input MultiUserModeEnum that specifies the type of project to create.
Name | Input String that specifies a name for the project.
ProjectPath | Input String that specifies the project (workspace or workgroup) folder for the project.
See Also

Create project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Methods > DesignProjects.Add Method


DesignProjects.AddExisting Method

DesignProjects.AddExisting Method Available in Apprentice Introduced in Inventor 2011
Summary

Method that adds an existing project file to the list of project files. This is equivalent of browsing to a specific ipj file on disk and choosing it in the Projects editor dialog. If the design project is already in the collection, the corresponding DesignProject object is returned.

Visual Basic
Sub AddExisting(FullFileName As String, Result As [out, retval] DesignProject*)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of an Inventor project file with an .ipj extension.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Methods > DesignProjects.AddExisting Method


DesignProjects.Item Method

DesignProjects.Item Method Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the specified DesignProject object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DesignProject*)
Parameters
Parameters | Description
Index | Input Long that specifies the item to return.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Methods > DesignProjects.Item Method


DesignProjects.ItemByName Method

DesignProjects.ItemByName Method Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the specified DesignProject object from the collection.

Visual Basic
Sub ItemByName(NameOrFileName As String, Result As [out, retval] DesignProject*)
Parameters
Parameters | Description
NameOrFileName | Input String that specifies either the FullFileName or the Name of the design project to return.
See Also

Set active project sample

You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Methods > DesignProjects.ItemByName Method


DesignProjects Properties

DesignProjects Properties
Summary

The properties of the DesignProjects class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDesignProjectsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Properties


DesignProjects.Application Property

DesignProjects.Application Property Available in Apprentice Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Properties > DesignProjects.Application Property


DesignProjects.Count Property

DesignProjects.Count Property Available in Apprentice Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Properties > DesignProjects.Count Property


DesignProjects.Type Property

DesignProjects.Type Property Available in Apprentice Introduced in Inventor 2011
Summary

Property returning kDesignProjectsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DesignProjects Interface > DesignProjects Properties > DesignProjects.Type Property


DesignViewRepresentation Interface

DesignViewRepresentation Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DesignViewRepresentation object represents a design view representation in parts and assemblies.

Class Hierarchy
Inventor::DesignViewRepresentation
Visual Basic
Public Interface DesignViewRepresentation
Inherits IDispatch
Remarks

A design view representation captures the following display characteristics:

  • Component visibility (visible or not visible)
  • Sketch and work feature visibility (visible or not visible)
  • Component selection status (enabled or not enabled)
  • Color and style characteristics applied in the assembly
  • Zoom magnification
  • Viewing angle
Notes

Members through which this object may be accessed include:

DesignViewRepresentation.Copy

DesignViewRepresentations.Add

DesignViewRepresentations.Item

RepresentationsManager.ActiveDesignViewRepresentation

You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface


DesignViewRepresentation Methods

DesignViewRepresentation Methods
Summary

The methods of the DesignViewRepresentation class are listed here.

Methods
Methods
Name | Description
Activate | Method that activates the design view representation.
Copy | Method that creates a copy of the DesignViewRepresentation. The new created DesignViewRepresentation is returned.
Delete | Method that deletes the DesignViewRepresentation. The method returns an error if the DesignViewType is kMasterDesignViewType.
GetReferenceKey | Method that generates and returns the reference key for this entity.
HideAll | Method that makes all components invisible in this representation.
RemoveColorOverrides | Method that returns all components to their default colors.
ShowAll | Method that makes all components visible in this representation.
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods


DesignViewRepresentation.Activate Method

DesignViewRepresentation.Activate Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that activates the design view representation.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.Activate Method


DesignViewRepresentation.Copy Method

DesignViewRepresentation.Copy Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a copy of the DesignViewRepresentation. The new created DesignViewRepresentation is returned.

Visual Basic
Sub Copy(ByRef NewName As [defaultvalue("")] BSTR, Result As [out, retval] DesignViewRepresentation*)
Parameters
Parameters | Description
NewName | Optional input string that specifies the name of the design view representation to create. If not specified, Inventor assigns a name to the representation.
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.Copy Method


DesignViewRepresentation.Delete Method

DesignViewRepresentation.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the DesignViewRepresentation. The method returns an error if the DesignViewType is kMasterDesignViewType.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.Delete Method


DesignViewRepresentation.GetReferenceKey Method

DesignViewRepresentation.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.GetReferenceKey Method


DesignViewRepresentation.HideAll Method

DesignViewRepresentation.HideAll Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that makes all components invisible in this representation.

Visual Basic
Sub HideAll()
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.HideAll Method


DesignViewRepresentation.RemoveColorOverrides Method

DesignViewRepresentation.RemoveColorOverrides Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns all components to their default colors.

Visual Basic
Sub RemoveColorOverrides()
Notes

Setting this method fails for design view representation in parts.

You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.RemoveColorOverrides Method


DesignViewRepresentation.ShowAll Method

DesignViewRepresentation.ShowAll Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that makes all components visible in this representation.

Visual Basic
Sub ShowAll()
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Methods > DesignViewRepresentation.ShowAll Method


DesignViewRepresentation Properties

DesignViewRepresentation Properties
Summary

The properties of the DesignViewRepresentation class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DesignViewInfo | Property that returns the design view representation information as a String containing XML formatted data.
DesignViewType | Property that returns the design view representation type. This can return kMasterDesignViewType, kPublicDesignViewType and kTransientDesignViewType.
Locked | Property that gets and sets whether this design view representation is locked. If a representation is locked, changes made to it will not be saved to the document. Setting this property will fail if the DesignViewType is kMasterDesignViewType.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent RepresentationsManager object.
Type | Property returning kDesignViewRepresentationObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties


DesignViewRepresentation.Application Property

DesignViewRepresentation.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.Application Property


DesignViewRepresentation.AttributeSets Property

DesignViewRepresentation.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.AttributeSets Property


DesignViewRepresentation.DesignViewInfo Property

DesignViewRepresentation.DesignViewInfo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the design view representation information as a String containing XML formatted data.

Visual Basic
Property DesignViewInfo() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.DesignViewInfo Property


DesignViewRepresentation.DesignViewType Property

DesignViewRepresentation.DesignViewType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the design view representation type. This can return kMasterDesignViewType, kPublicDesignViewType and kTransientDesignViewType.

Visual Basic
Property DesignViewType() As DesignViewTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.DesignViewType Property


DesignViewRepresentation.Locked Property

DesignViewRepresentation.Locked Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether this design view representation is locked. If a representation is locked, changes made to it will not be saved to the document. Setting this property will fail if the DesignViewType is kMasterDesignViewType.

Visual Basic
Property Locked() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.Locked Property


DesignViewRepresentation.Name Property

DesignViewRepresentation.Name Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.Name Property


DesignViewRepresentation.Parent Property

DesignViewRepresentation.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent RepresentationsManager object.

Visual Basic
Property Parent() As RepresentationsManager**
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.Parent Property


DesignViewRepresentation.Type Property

DesignViewRepresentation.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDesignViewRepresentationObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentation Interface > DesignViewRepresentation Properties > DesignViewRepresentation.Type Property


DesignViewRepresentations Interface

DesignViewRepresentations Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DesignViewRepresentations collection object provides access to all the design view representations in parts and assemblies and provides methods to create new ones.

Class Hierarchy
Inventor::DesignViewRepresentations
Visual Basic
Public Interface DesignViewRepresentations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RepresentationsManager.DesignViewRepresentations

You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface


DesignViewRepresentations Methods

DesignViewRepresentations Methods
Summary

The methods of the DesignViewRepresentations class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DesignViewRepresentation. The new created DesignViewRepresentation is returned.
Item | Property that returns the specified DesignViewRepresentation object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Methods


DesignViewRepresentations.Add Method

DesignViewRepresentations.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new DesignViewRepresentation. The new created DesignViewRepresentation is returned.

Visual Basic
Sub Add(ByRef Name As [defaultvalue("")] BSTR, ByRef Reserved As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] DesignViewRepresentation*)
Parameters
Parameters | Description
Name | Optional input string that specifies the name of the design view representation to create. If not specified, Inventor assigns a name to the representation.
Reserved | Optional input Boolean reserved for future use. Currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Methods > DesignViewRepresentations.Add Method


DesignViewRepresentations.Item Method

DesignViewRepresentations.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified DesignViewRepresentation object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] DesignViewRepresentation*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DesignViewRepresentation to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the DesignViewRepresentation name. If an out of range index or a name of a non-existent DesignViewRepresentation is provided, an error will occur .
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Methods > DesignViewRepresentations.Item Method


DesignViewRepresentations Properties

DesignViewRepresentations Properties
Summary

The properties of the DesignViewRepresentations class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDesignViewRepresentationsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Properties


DesignViewRepresentations.Application Property

DesignViewRepresentations.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Properties > DesignViewRepresentations.Application Property


DesignViewRepresentations.Count Property

DesignViewRepresentations.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Properties > DesignViewRepresentations.Count Property


DesignViewRepresentations.Type Property

DesignViewRepresentations.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDesignViewRepresentationsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DesignViewRepresentations Interface > DesignViewRepresentations Properties > DesignViewRepresentations.Type Property


DetailDrawingView Interface

DetailDrawingView Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

For information on this object, please refer to DrawingView, which provides identical or very similar functionality.

Class Hierarchy
Inventor::DrawingView
    Inventor::DetailDrawingView
Visual Basic
Public Interface DetailDrawingView
Inherits DrawingView
Notes

Members through which this object may be accessed include:

DrawingViews.AddDetailView

You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface


DetailDrawingView Properties

DetailDrawingView Properties
Summary

The properties of the DetailDrawingView class are listed here.

Properties
Name | Description
AttachPoint | Property that gets and sets geometry to attach the view to. Use Sheet.CreateGeometryIntent method to create a new GeometryIntent object. This property can be set to Nothing to un-attach the view from a geometry.
BoundaryLayer | Property that gets and sets the layer associated with the boundary geometry.
CircularFence | Property that returns whether the detail view uses a circular fence or a rectangular fence. Circular fence if True; rectangular fence if False.
DisplayConnectionLine | Property that gets and sets whether to display the line between the detail view fence and the full boundary. This property can be set to True only if the IsBreakLineSmooth and DisplayFullBoundary properties are set to True.
DisplayFullBoundary | Property that gets and sets whether to display full boundary of the detail view. This property can be set to True only if the IsBreakLineSmooth property is set to True.
FenceCenter | Property that gets and sets the center of the fence. Applies to both circular and rectangular fence types. Setting this property will fail if the view is attached to geometry (i.e. the AttachPoint property returns an object).
FenceCornerOne | Property that gets and sets the first corner of the rectangular fence. This property returns Nothing and cannot be set if the fence type is circular.
FenceCornerTwo | Property that gets and sets the second corner of the rectangular fence. This property returns Nothing and cannot be set if the fence type is circular.
FenceRadius | Property that gets and sets the radius of the circular fence. This property fails if the fence type is rectangular.
IsBreakLineSmooth | Property that gets and sets whether the cut shape of the fence is smooth or jogged.
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties


DetailDrawingView.AttachPoint Property

DetailDrawingView.AttachPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets geometry to attach the view to. Use Sheet.CreateGeometryIntent method to create a new GeometryIntent object. This property can be set to Nothing to un-attach the view from a geometry.

Visual Basic
Property AttachPoint() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.AttachPoint Property


DetailDrawingView.BoundaryLayer Property

DetailDrawingView.BoundaryLayer Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the layer associated with the boundary geometry.

Visual Basic
Property BoundaryLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.BoundaryLayer Property


DetailDrawingView.CircularFence Property

DetailDrawingView.CircularFence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the detail view uses a circular fence or a rectangular fence. Circular fence if True; rectangular fence if False.

Visual Basic
Property CircularFence() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.CircularFence Property


DetailDrawingView.DisplayConnectionLine Property

DetailDrawingView.DisplayConnectionLine Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether to display the line between the detail view fence and the full boundary. This property can be set to True only if the IsBreakLineSmooth and DisplayFullBoundary properties are set to True.

Visual Basic
Property DisplayConnectionLine() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.DisplayConnectionLine Property


DetailDrawingView.DisplayFullBoundary Property

DetailDrawingView.DisplayFullBoundary Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether to display full boundary of the detail view. This property can be set to True only if the IsBreakLineSmooth property is set to True.

Visual Basic
Property DisplayFullBoundary() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.DisplayFullBoundary Property


DetailDrawingView.FenceCenter Property

DetailDrawingView.FenceCenter Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the center of the fence. Applies to both circular and rectangular fence types. Setting this property will fail if the view is attached to geometry (i.e. the AttachPoint property returns an object).

Visual Basic
Property FenceCenter() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.FenceCenter Property


DetailDrawingView.FenceCornerOne Property

DetailDrawingView.FenceCornerOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the first corner of the rectangular fence. This property returns Nothing and cannot be set if the fence type is circular.

Visual Basic
Property FenceCornerOne() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.FenceCornerOne Property


DetailDrawingView.FenceCornerTwo Property

DetailDrawingView.FenceCornerTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the second corner of the rectangular fence. This property returns Nothing and cannot be set if the fence type is circular.

Visual Basic
Property FenceCornerTwo() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.FenceCornerTwo Property


DetailDrawingView.FenceRadius Property

DetailDrawingView.FenceRadius Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the radius of the circular fence. This property fails if the fence type is rectangular.

Visual Basic
Property FenceRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.FenceRadius Property


DetailDrawingView.IsBreakLineSmooth Property

DetailDrawingView.IsBreakLineSmooth Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the cut shape of the fence is smooth or jogged.

Visual Basic
Property IsBreakLineSmooth() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DetailDrawingView Interface > DetailDrawingView Properties > DetailDrawingView.IsBreakLineSmooth Property


DiameterDimConstraint Interface

DiameterDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The DiameterDimConstraint object represents a constraint that controls the diameter of a circle or arc.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::DiameterDimConstraint
        Inventor::DiameterDimConstraintProxy
Visual Basic
Public Interface DiameterDimConstraint
Inherits DimensionConstraint
Remarks

The picture below illustrates the use of this constraint.

Notes

Members through which this object may be accessed include:

DiameterDimConstraintProxy.NativeObject

DimensionConstraints.AddDiameter

You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraint Interface


DiameterDimConstraint Properties

DiameterDimConstraint Properties
Summary

The properties of the DiameterDimConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns the circle or arc being constrained.
You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraint Interface > DiameterDimConstraint Properties


DiameterDimConstraint.Entity Property

DiameterDimConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the circle or arc being constrained.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraint Interface > DiameterDimConstraint Properties > DiameterDimConstraint.Entity Property


DiameterDimConstraintProxy Interface

DiameterDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the DiameterDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::DiameterDimConstraint
        Inventor::DiameterDimConstraintProxy
Visual Basic
Public Interface DiameterDimConstraintProxy
Inherits DiameterDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraintProxy Interface


DiameterDimConstraintProxy Properties

DiameterDimConstraintProxy Properties
Summary

The properties of the DiameterDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraintProxy Interface > DiameterDimConstraintProxy Properties


DiameterDimConstraintProxy.ContainingOccurrence Property

DiameterDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraintProxy Interface > DiameterDimConstraintProxy Properties > DiameterDimConstraintProxy.ContainingOccurrence Property


DiameterDimConstraintProxy.NativeObject Property

DiameterDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As DiameterDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > DiameterDimConstraintProxy Interface > DiameterDimConstraintProxy Properties > DiameterDimConstraintProxy.NativeObject Property


DiameterGeneralDimension Interface

DiameterGeneralDimension Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DiameterGeneralDimension object represents a diameter dimension placed on a sheet.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
        Inventor::DiameterGeneralDimension
            Inventor::HoleThreadNote
Visual Basic
Public Interface DiameterGeneralDimension
Inherits GeneralDimension
Notes

Members through which this object may be accessed include:

GeneralDimensions.AddDiameter

You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface


DiameterGeneralDimension Properties

DiameterGeneralDimension Properties
Summary

The properties of the DiameterGeneralDimension class are listed here.

Properties
Name | Description
ExtensionLineOne | Property that returns the first extension line of the dimension.
ExtensionLineTwo | Property that returns the second extension line of the dimension.
Intent | Property that returns the geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
LeaderFromCenter | Property that gets and sets whether the leader starts from the center of the arc or the circle.
SingleDimensionLine | Property that gets and sets whether to use a single dimension line.
You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface > DiameterGeneralDimension Properties


DiameterGeneralDimension.ExtensionLineOne Property

DiameterGeneralDimension.ExtensionLineOne Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the first extension line of the dimension.

Visual Basic
Property ExtensionLineOne() As IDispatch**
Remarks

This property may return Nothing in cases where there are no extension lines. The object returned by this property is a LineSegment2d in sheet space for projected dimensions and LineSegment in model space for true (iso) dimensions.

You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface > DiameterGeneralDimension Properties > DiameterGeneralDimension.ExtensionLineOne Property


DiameterGeneralDimension.ExtensionLineTwo Property

DiameterGeneralDimension.ExtensionLineTwo Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the second extension line of the dimension.

Visual Basic
Property ExtensionLineTwo() As IDispatch**
Remarks

This property may return Nothing in cases where there are no extension lines. The object returned by this property is a LineSegment2d in sheet space for projected dimensions and LineSegment in model space for true (iso) dimensions.

You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface > DiameterGeneralDimension Properties > DiameterGeneralDimension.ExtensionLineTwo Property


DiameterGeneralDimension.Intent Property

DiameterGeneralDimension.Intent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property Intent() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface > DiameterGeneralDimension Properties > DiameterGeneralDimension.Intent Property


DiameterGeneralDimension.LeaderFromCenter Property

DiameterGeneralDimension.LeaderFromCenter Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the leader starts from the center of the arc or the circle.

Visual Basic
Property LeaderFromCenter() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface > DiameterGeneralDimension Properties > DiameterGeneralDimension.LeaderFromCenter Property


DiameterGeneralDimension.SingleDimensionLine Property

DiameterGeneralDimension.SingleDimensionLine Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to use a single dimension line.

Visual Basic
Property SingleDimensionLine() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DiameterGeneralDimension Interface > DiameterGeneralDimension Properties > DiameterGeneralDimension.SingleDimensionLine Property


DimensionConstraint Interface

DimensionConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The DimensionConstraint object represents the base class of all dimension constraints.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::DiameterDimConstraint
    Inventor::EllipseRadiusDimConstraint
    Inventor::OffsetDimConstraint
    Inventor::OffsetSplineDimConstraint
    Inventor::RadiusDimConstraint
    Inventor::TangentDistanceDimConstraint
    Inventor::ThreePointAngleDimConstraint
    Inventor::TwoLineAngleDimConstraint
    Inventor::TwoPointDistanceDimConstraint
Visual Basic
Public Interface DimensionConstraint
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionConstraints.Item

GeneralDimension.PromoteToSketch

SketchConstraintsEnumerator.Item

GeneralDimension.RetrievedFrom

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface


DimensionConstraint Methods

DimensionConstraint Methods
Summary

The methods of the DimensionConstraint class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the constraint.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Methods


DimensionConstraint.Delete Method

DimensionConstraint.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the constraint.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Methods > DimensionConstraint.Delete Method


DimensionConstraint.GetReferenceKey Method

DimensionConstraint.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Methods > DimensionConstraint.GetReferenceKey Method


DimensionConstraint Properties

DimensionConstraint Properties
Summary

The properties of the DimensionConstraint class are listed here.

Properties
Name | Description
AnchorPoints | This is AnchorPoints, a member of class DimensionConstraint.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DimensionCenterPoint | Gets the center of the dimension line.
Driven | Property that gets and sets whether this dimension constraint is driving the geometry or the geometry is defining the value associated with the constraint. If True, the geometry is defining the value of constraint.
Parameter | Property that returns the parameter associated with this dimension constraint. If the Driven property of the constraint is True, this will return a ReferenceParameter object. Otherwise it will return a ModelParameter object.
Parent | Property that returns the parent sketch of the object.
TextPoint | Property that gets and sets the position of the dimension text.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties


DimensionConstraint.AnchorPoints Property

DimensionConstraint.AnchorPoints Property
Summary

This is AnchorPoints, a member of class DimensionConstraint.

Visual Basic
Property AnchorPoints() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.AnchorPoints Property


DimensionConstraint.Application Property

DimensionConstraint.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.Application Property


DimensionConstraint.AttributeSets Property

DimensionConstraint.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.AttributeSets Property


DimensionConstraint.DimensionCenterPoint Property

DimensionConstraint.DimensionCenterPoint Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the center of the dimension line.

Visual Basic
Property DimensionCenterPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.DimensionCenterPoint Property


DimensionConstraint.Driven Property

DimensionConstraint.Driven Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether this dimension constraint is driving the geometry or the geometry is defining the value associated with the constraint. If True, the geometry is defining the value of constraint.

Visual Basic
Property Driven() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.Driven Property


DimensionConstraint.Parameter Property

DimensionConstraint.Parameter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter associated with this dimension constraint. If the Driven property of the constraint is True, this will return a ReferenceParameter object. Otherwise it will return a ModelParameter object.

Visual Basic
Property Parameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.Parameter Property


DimensionConstraint.Parent Property

DimensionConstraint.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent sketch of the object.

Visual Basic
Property Parent() As Sketch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.Parent Property


DimensionConstraint.TextPoint Property

DimensionConstraint.TextPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the position of the dimension text.

Visual Basic
Property TextPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.TextPoint Property


DimensionConstraint.Type Property

DimensionConstraint.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint Interface > DimensionConstraint Properties > DimensionConstraint.Type Property


DimensionConstraint3D Interface

DimensionConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DimensionConstraint3D object represents the base class of all 3D sketch dimension constraints.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::LineLengthDimConstraint3D
    Inventor::PointAndPlaneDistanceDimConstraint3D
    Inventor::RadiusDimConstraint3D
    Inventor::TwoLineAngleDimConstraint3D
    Inventor::TwoPointDistanceDimConstraint3D
Visual Basic
Public Interface DimensionConstraint3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionConstraints3D.Item

SketchConstraints3DEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface


DimensionConstraint3D Methods

DimensionConstraint3D Methods
Summary

The methods of the DimensionConstraint3D class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the constraint.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Methods


DimensionConstraint3D.Delete Method

DimensionConstraint3D.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the constraint.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Methods > DimensionConstraint3D.Delete Method


DimensionConstraint3D.GetReferenceKey Method

DimensionConstraint3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Methods > DimensionConstraint3D.GetReferenceKey Method


DimensionConstraint3D Properties

DimensionConstraint3D Properties
Summary

The properties of the DimensionConstraint3D class are listed here.

Properties
Name | Description
AnchorPoints | This is AnchorPoints, a member of class DimensionConstraint3D.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DimensionPlane | Property that returns the transient dimension plane used to place and position the dimension text for this dimension constraint.
Driven | Property that gets and sets whether this dimension constraint is driving the geometry or the geometry is defining the value associated with the constraint. If True, the geometry is defining the value of constraint.
Parameter | Property that returns the parameter associated with this dimension constraint. If the Driven property of the constraint is True, this will return a ReferenceParameter object. Otherwise it will return a ModelParameter object.
Parent | Property that returns the parent sketch of the object.
TextPoint | Property that gets and sets the position of the dimension text.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties


DimensionConstraint3D.AnchorPoints Property

DimensionConstraint3D.AnchorPoints Property
Summary

This is AnchorPoints, a member of class DimensionConstraint3D.

Visual Basic
Property AnchorPoints() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.AnchorPoints Property


DimensionConstraint3D.Application Property

DimensionConstraint3D.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.Application Property


DimensionConstraint3D.AttributeSets Property

DimensionConstraint3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.AttributeSets Property


DimensionConstraint3D.DimensionPlane Property

DimensionConstraint3D.DimensionPlane Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the transient dimension plane used to place and position the dimension text for this dimension constraint.

Visual Basic
Property DimensionPlane() As Plane**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.DimensionPlane Property


DimensionConstraint3D.Driven Property

DimensionConstraint3D.Driven Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether this dimension constraint is driving the geometry or the geometry is defining the value associated with the constraint. If True, the geometry is defining the value of constraint.

Visual Basic
Property Driven() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.Driven Property


DimensionConstraint3D.Parameter Property

DimensionConstraint3D.Parameter Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parameter associated with this dimension constraint. If the Driven property of the constraint is True, this will return a ReferenceParameter object. Otherwise it will return a ModelParameter object.

Visual Basic
Property Parameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.Parameter Property


DimensionConstraint3D.Parent Property

DimensionConstraint3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent sketch of the object.

Visual Basic
Property Parent() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.Parent Property


DimensionConstraint3D.TextPoint Property

DimensionConstraint3D.TextPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the position of the dimension text.

Visual Basic
Property TextPoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.TextPoint Property


DimensionConstraint3D.Type Property

DimensionConstraint3D.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraint3D Interface > DimensionConstraint3D Properties > DimensionConstraint3D.Type Property


DimensionConstraints Interface

DimensionConstraints Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The DimensionConstraints object provides access to all the dimension sketch constraints ( objects) in a sketch and provides methods to create additional dimension sketch constraints.

Class Hierarchy
Inventor::DimensionConstraints
Visual Basic
Public Interface DimensionConstraints
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.DimensionConstraints

See Also

Create sketch elliptical arc sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface


DimensionConstraints Methods

DimensionConstraints Methods
Summary

The methods of the DimensionConstraints class are listed here.

Methods
Methods
Name | Description
AddDiameter | Method that creates a new diameter dimension constraint on the input circle or arc.
AddEllipseRadius | Method that creates a new dimension constraint defining the major or minor radius of the ellipse. This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch.
AddOffset | Method that creates a new offset dimension constraint between two entities.
AddOffsetSpline | Creates a new offsetSpline dimension constraint between offset spline and the original spline.
AddRadius | Method that creates a new radius dimension constraint on the input circle or arc.
AddTangentDistance | Method that creates a new tangent distance dimension constraint between the two input entities. The input entities can consist of two circles or a line and a circle. Arcs can also be used in place of the circles.
AddThreePointAngle | Method that creates a new angular dimension constraint between three points.
AddTwoLineAngle | Method that creates a new angular dimension constraint between two lines.
AddTwoPointDistance | Method that creates a new linear dimension constraint between two points.
Item | Property that returns the specified sketch dimension constraint object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods


DimensionConstraints.AddDiameter Method

DimensionConstraints.AddDiameter Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new diameter dimension constraint on the input circle or arc.

Visual Basic
Sub AddDiameter(Entity As SketchEntity, TextPoint As Point2d, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] DiameterDimConstraint*)
Parameters
Parameters | Description
Entity | Input or SketchArc object.
TextPoint | Input object that defines the position of the dimension text.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch. The picture below illustrates the result of adding a diameter dimension constraint.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddDiameter Method


DimensionConstraints.AddEllipseRadius Method

DimensionConstraints.AddEllipseRadius Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new dimension constraint defining the major or minor radius of the ellipse. This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch.

Visual Basic
Sub AddEllipseRadius(Entity As SketchEntity, MajorRadius As VARIANT_BOOL, TextPoint As Point2d, ByRef PositiveSide As [optional] VARIANT, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] EllipseRadiusDimConstraint*)
Parameters
Parameters | Description
Entity | Input SketchEllipse or SketchEllipticalArc object.
MajorRadius | Boolean that defines if the dimension is for the major or minor radius of the ellipse.
TextPoint | Input Point2d object that defines the position of the dimension text. This also defines which side of the ellipse the dimension is placed on if the PositiveSide argument is not specified.
PositiveSide | Optional input Boolean that specifies whether to dimension the positive or the negative side of the major/minor axis. If not specified, the position of the TextPoint defines which side the dimension is placed on.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
See Also

Create sketch elliptical arc sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddEllipseRadius Method


DimensionConstraints.AddOffset Method

DimensionConstraints.AddOffset Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new offset dimension constraint between two entities.

Visual Basic
Sub AddOffset(Line As SketchLine, Entity As SketchEntity, TextPoint As Point2d, LinearDiameter As VARIANT_BOOL, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] OffsetDimConstraint*)
Parameters
Parameters | Description
Line | Input SketchLine object.
Entity | Input sketch entity. This must be either a or SketchPoint object. If creating a linear diameter dimension and Entity is a SketchLine, then Entity is used as the centerline. If Entity is a SketchPoint, then Line is used as the centerline.
TextPoint | Input object that defines the position of the dimension text.
LinearDiameter | Input Boolean that specifies whether the dimension should be a standard distance dimension or be displayed as a linear diameter dimension.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default is False, which will create a driving dimension.
Remarks

One of the input entities must be a sketch line. The other entity can be either a line or a point. When two lines are input this constraint has the effect of forcing parallelism between the lines. The dimension axis is perpendicular to the sketch line input for the Line argument. The picture below illustrates two cases of the offset dimension constraint. In the dimension with the 0.614 value, the two red vertical lines are constrained. In the second case the line representing the center line and the horizontal red line are constrained. In the second case the LinearDiameter flag was set to True to result in the linear diameter type of dimension.

In the picture below, two offset dimension constraints are placed. This illustrates that the input line controls the axis of the dimension. The dimension line is perpendicular to the sketch line. The distance between the line and the other object is controlled by the constraint. The two dimensions below are both between a line and a point. The 0.684 dia. was placed with the LinearDiameter flag set to true.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddOffset Method


DimensionConstraints.AddOffsetSpline Method

DimensionConstraints.AddOffsetSpline Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Creates a new offsetSpline dimension constraint between offset spline and the original spline.

Visual Basic
Sub AddOffsetSpline(Line As SketchOffsetSpline, TextPoint As Point2d, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] OffsetSplineDimConstraint*)
Parameters
Parameters | Description
Line | Input object.
TextPoint | Input object that defines the position of the dimension text.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default is False, which will create a driving dimension.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddOffsetSpline Method


DimensionConstraints.AddRadius Method

DimensionConstraints.AddRadius Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new radius dimension constraint on the input circle or arc.

Visual Basic
Sub AddRadius(Entity As SketchEntity, TextPoint As Point2d, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] RadiusDimConstraint*)
Parameters
Parameters | Description
Entity | Input or SketchArc object.
TextPoint | Input object that defines the position of the dimension text.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The picture below illustrates the result of adding an arc dimension constraint.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddRadius Method


DimensionConstraints.AddTangentDistance Method

DimensionConstraints.AddTangentDistance Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new tangent distance dimension constraint between the two input entities. The input entities can consist of two circles or a line and a circle. Arcs can also be used in place of the circles.

Visual Basic
Sub AddTangentDistance(EntityOne As SketchEntity, EntityTwo As SketchEntity, ProximityPointOne As Point2d, ProximityPointTwo As Point2d, TextPoint As Point2d, LinearDiameter As VARIANT_BOOL, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] TangentDistanceDimConstraint*)
Parameters
Parameters | Description
EntityOne | Input , SketchArc, or SketchLine object. Both EntityOne and EntityTwo cannot be sketch lines, at least one must be an arc or circle.
EntityTwo | Input , SketchArc, or SketchLine object. Both EntityOne and EntityTwo cannot be sketch lines, at least one must be an arc or circle.
ProximityPointOne | The supplied by this argument is used when EntityOne is a circle or arc. This point specifies which of the possible two tangent cases is used when creating the constraint. The closest tangent to the input point is used. If EntityOne is a line, this argument is ignored.
ProximityPointTwo | The supplied by this argument is used when EntityTwo is a circle or arc. This point specifies which of the possible two tangent cases is used when creating the constraint. The closest tangent to the input point is used. If EntityTwo is a line, this argument is ignored.
TextPoint | Input object that defines the position of the dimension text.
LinearDiameter | In the case when either EntityOne or EntityTwo is a line, it is valid to specify that this constraint be placed as a linear diameter type of dimension. If neither EntityOne nor EntityTwo is a line, this argument is ignored.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The proximity point arguments are required whenever a circle or arc is input. This point specifies which of the two possible solutions is used when creating the constraint. The figure below illustrates two tangent distance constraints placed using the same input arguments except the proximity point for the smaller circle indicated the position closer to the large circle in one case and further away in the other.

The General Dimension command allows you to dimension the difference in radius between two concentric circles. During interactive placement there is special behavior that makes the placement behave similar to that when placing a radius or diameter dimension. However, the command actually creates a TangentDistanceDimConstraint. By providing the appropriate input you can duplicate the result using the AddTangentDistance method. The result is shown below.

The picture below illustrates creating a tangent dimension constraint between a line and an arc. The 1.293 dia. dimension was placed by inputting the red line representing the center line and the red arc. It is defined to be a linear diameter style of dimension.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddTangentDistance Method


DimensionConstraints.AddThreePointAngle Method

DimensionConstraints.AddThreePointAngle Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new angular dimension constraint between three points.

Visual Basic
Sub AddThreePointAngle(PointOne As SketchPoint, PointTwo As SketchPoint, PointThree As SketchPoint, TextPoint As Point2d, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ThreePointAngleDimConstraint*)
Parameters
Parameters | Description
PointOne | Input sketch point.
PointTwo | Input sketch point. This point defines the vertex point of the angle.
PointThree | Input sketch point.
TextPoint | Input object that defines the position of the dimension text and which of the four possible quadrants to place the dimension within.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The position of the text point defines which of the four quadrants the constraint is placed within. The picture below illustrates the result of adding a three-point angle dimension constraint.

The General Dimension command allows you to place a dimension controlling the sweep angle of an arc by selecting the arc and the center point. This results in a three point angle dimension constraint being placed between the two sketch points at the end of the arc and the sketch point at the center. This results in a dimension like that shown below.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddThreePointAngle Method


DimensionConstraints.AddTwoLineAngle Method

DimensionConstraints.AddTwoLineAngle Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new angular dimension constraint between two lines.

Visual Basic
Sub AddTwoLineAngle(LineOne As SketchLine, LineTwo As SketchLine, TextPoint As Point2d, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] TwoLineAngleDimConstraint*)
Parameters
Parameters | Description
LineOne | Input sketch line.
LineTwo | Input sketch line.
TextPoint | Input object that defines the position of the dimension text and which of the four possible quadrants to place the dimension within.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The position of the text point defines which of the four quadrants the constraint is placed within. The picture below illustrates the result of adding a two-line angle dimension constraint.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddTwoLineAngle Method


DimensionConstraints.AddTwoPointDistance Method

DimensionConstraints.AddTwoPointDistance Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new linear dimension constraint between two points.

Visual Basic
Sub AddTwoPointDistance(PointOne As SketchPoint, PointTwo As SketchPoint, Orientation As DimensionOrientationEnum, TextPoint As Point2d, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] TwoPointDistanceDimConstraint*)
Parameters
Parameters | Description
PointOne | Input sketch point.
PointTwo | Input sketch point.
Orientation | Input constant that specifies if the dimension is horizontal, vertical, or aligned.
TextPoint | Input object that defines the position of the dimension text.
Driven | Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The result can be either a vertical, horizontal, or aligned dimension depending on the orientation specified. The picture below illustrates the three possible cases when placing this constraint between two points.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.AddTwoPointDistance Method


DimensionConstraints.Item Method

DimensionConstraints.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified sketch dimension constraint object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DimensionConstraint*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Methods > DimensionConstraints.Item Method


DimensionConstraints Properties

DimensionConstraints Properties
Summary

The properties of the DimensionConstraints class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Properties


DimensionConstraints.Application Property

DimensionConstraints.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Properties > DimensionConstraints.Application Property


DimensionConstraints.Count Property

DimensionConstraints.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Properties > DimensionConstraints.Count Property


DimensionConstraints.Type Property

DimensionConstraints.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints Interface > DimensionConstraints Properties > DimensionConstraints.Type Property


DimensionConstraints3D Interface

DimensionConstraints3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DimensionConstraints3D object provides access to all the dimension sketch constraints in a 3D sketch and provides methods to create additional dimension sketch constraints.

Class Hierarchy
Inventor::DimensionConstraints3D
Visual Basic
Public Interface DimensionConstraints3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.DimensionConstraints3D

Example

See DimensionConstraints3D::AddTwoPointDistance for example "Create dimension"

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface


DimensionConstraints3D Methods

DimensionConstraints3D Methods
Summary

The methods of the DimensionConstraints3D class are listed here.

Methods
Methods
Name | Description
AddLineLength | Method that creates a new linear dimension constraint that defines the length of a 3D sketch line. This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch.
AddPointAndPlaneDistance | Method that creates a new linear dimension constraint between a 3D sketch point and a planar face or workplane. This method will fail if the input 3D sketch point lies on the input plane specified by the face or workplane. This method will also fail in the case where a driving dimension is specified and it will overconstrain the sketch.
AddRadius | Method that creates a new radius dimension constraint on the input circle or arc.
AddTwoLineAngle | Method that creates a new angular dimension constraint between two 3D sketch lines. This method will fail if the two input 3D sketch lines that need to be constrained are not co-planar. This method will also fail in the case where a driving dimension is specified and it will overconstrain the sketch.
AddTwoPointDistance | Method that creates a new linear dimension constraint between a 3D sketch point and another 3D sketch point, vertex or workpoint. This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch.
GetDimensionPlane | Method that gets the transient dimension plane used to place and position the dimension text when a dimension constraint is applied to the specified input entities.
Item | Returns the specified 3D sketch dimension constraint object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods


DimensionConstraints3D.AddLineLength Method

DimensionConstraints3D.AddLineLength Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new linear dimension constraint that defines the length of a 3D sketch line. This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch.

Visual Basic
Sub AddLineLength(Line As SketchLine3D, ByRef TextPoint As [optional] VARIANT, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] LineLengthDimConstraint3D*)
Parameters
Parameters
Description
Line
Object that defines the 3D sketch line being constrained.
TextPoint
Object that defines the position of the dimension text. The dimension text will always be placed on a particular dimension plane the orientation of which will be automatically determined using the input line that is being dimensioned. The dimension plane is a transient geometric plane which is only used to define the placement plane for the dimension text and does not have a graphical representation. If no input is specified for the position of the dimension text, a default position on the dimension plane will be calculated and used to place the dimension text. If a valid point for the dimension text is specified, then either of the following conditions will apply:

  • If the specified point already lies on the dimension plane, then this

point will be directly used to place the dimension text.

  • If the specified point does not lie on the dimension plane, it will be

projected onto the dimension plane. Therefore, the resultant placement position for the dimension text will be different from the specified one.
The GetDimensionPlane method of the DimensionConstraints3D object can be used to get the dimension plane object which provides access to the dimension plane geometry.

Driven
Specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.AddLineLength Method


DimensionConstraints3D.AddPointAndPlaneDistance Method

DimensionConstraints3D.AddPointAndPlaneDistance Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new linear dimension constraint between a 3D sketch point and a planar face or workplane. This method will fail if the input 3D sketch point lies on the input plane specified by the face or workplane. This method will also fail in the case where a driving dimension is specified and it will overconstrain the sketch.

Visual Basic
Sub AddPointAndPlaneDistance(Point As SketchPoint3D, Plane As IDispatch, ByRef TextPoint As [optional] VARIANT, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] PointAndPlaneDistanceDimConstraint3D*)
Parameters
Parameters
Description
Point
Object that defines the 3D sketch point being constrained.
Plane
Planar Face or WorkPlane object that defines the distance to the 3D sketch point being constrained.
TextPoint
Point object that defines the position of the dimension text. The dimension text will always be placed on a particular dimension plane the orientation of which will be automatically determined based on the input plane and sketch point to which the dimension is being applied. The dimension plane is a transient geometric plane which is only used to define the placement plane for the dimension text and does not have a graphical representation. If no input is specified for the position of the dimension text, a default position on the dimension plane will be calculated and used to place the dimension text. If a valid point for the dimension text is specified, then either of the following conditions will apply:

  • If the specified point already lies on the dimension plane, then this

point will be directly used to place the dimension text.

  • If the specified point does not lie on the dimension plane, it will be

projected onto the dimension plane. Therefore, the resultant placement position for the dimension text will be different from the specified one.
The GetDimensionPlane method of the DimensionConstraints3D object can be used to get the dimension plane object which provides access to the dimension plane geometry.

Driven
Specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.AddPointAndPlaneDistance Method


DimensionConstraints3D.AddRadius Method

DimensionConstraints3D.AddRadius Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new radius dimension constraint on the input circle or arc.

Visual Basic
Sub AddRadius(Entity As SketchEntity3D, ByRef TextPoint As [optional] VARIANT, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] RadiusDimConstraint3D*)
Parameters
Parameters
Description
Entity
Input SketchCircle3D or SketchArc3D object.
TextPoint
The dimension text can only be placed on the plane that contains the two input sketch lines to which the dimension is being applied. The orientation of this dimension plane will be automatically determined using the input sketch lines. The dimension plane is a transient geometric plane which is only used to define the placement plane for the dimension text and does not have a graphical representation. The position of the text point defines which of the four quadrants on the dimension plane the constraint is placed within.
If no input is specified for the position of the dimension text, a default position on the dimension plane will be calculated and used to place the dimension text.
If a valid point for the dimension text is specified, then either of the following conditions will apply:

  • If the specified point already lies on the dimension plane, then this point will be directly used to place the dimension text.
  • If the specified point does not lie on the dimension plane, it will be projected onto the dimension plane. Therefore, the resultant placement position for the dimension text will be different from the specified one.

The GetDimensionPlane method of the DimensionConstraints3D object can be used to get the dimension plane object which provides access to the dimension plane geometry.

Driven
Optional input Boolean that specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The picture below illustrates the result of adding an arc dimension constraint.

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.AddRadius Method


DimensionConstraints3D.AddTwoLineAngle Method

DimensionConstraints3D.AddTwoLineAngle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new angular dimension constraint between two 3D sketch lines. This method will fail if the two input 3D sketch lines that need to be constrained are not co-planar. This method will also fail in the case where a driving dimension is specified and it will overconstrain the sketch.

Visual Basic
Sub AddTwoLineAngle(LineOne As SketchLine3D, LineTwo As SketchLine3D, ByRef TextPoint As [optional] VARIANT, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] TwoLineAngleDimConstraint3D*)
Parameters
Parameters
Description
LineOne
Object that defines the first 3D sketch line being constrained.
LineTwo
Object that defines the second 3D sketch line being constrained.
TextPoint
Point object that defines the position of the dimension text. The dimension text will always be placed on a particular dimension plane the orientation of which will be automatically determined based on the input plane and sketch point to which the dimension is being applied. The dimension plane is a transient geometric plane which is only used to define the placement plane for the dimension text and does not have a graphical representation. If no input is specified for the position of the dimension text, a default position on the dimension plane will be calculated and used to place the dimension text. If a valid point for the dimension text is specified, then either of the following conditions will apply:

  • If the specified point already lies on the dimension plane, then this

point will be directly used to place the dimension text.

  • If the specified point does not lie on the dimension plane, it will be

projected onto the dimension plane. Therefore, the resultant placement position for the dimension text will be different from the specified one.
The GetDimensionPlane method of the DimensionConstraints3D object can be used to get the dimension plane object which provides access to the dimension plane geometry.

Driven
Specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.AddTwoLineAngle Method


DimensionConstraints3D.AddTwoPointDistance Method

DimensionConstraints3D.AddTwoPointDistance Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new linear dimension constraint between a 3D sketch point and another 3D sketch point, vertex or workpoint. This method will fail in the case where a driving dimension is specified and it will overconstrain the sketch.

Visual Basic
Sub AddTwoPointDistance(PointOne As IDispatch, PointTwo As IDispatch, ByRef TextPoint As [optional] VARIANT, ByRef Driven As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] TwoPointDistanceDimConstraint3D*)
Parameters
Parameters
Description
PointOne
SketchPoint3D, Vertex or WorkPoint object that defines the first point being constrained.
PointTwo
SketchPoint3D, Vertex or WorkPoint object that defines the second point being constrained. At least one of the input points (PointOne or PointTwo) for the dimension constraint must be a SketchPoint3D object. If a 3D sketch point is specified for either PointOne or PointTwo and a vertex or workpoint is specified for the other point, then a 3D sketch point will be created at the specified vertex or workpoint and then the constraint will be applied between the two 3D sketch points.
TextPoint
Point object that defines the position of the dimension text. The dimension text will always be placed on a particular dimension plane the orientation of which will be automatically determined based on the input plane and sketch point to which the dimension is being applied. The dimension plane is a transient geometric plane which is only used to define the placement plane for the dimension text and does not have a graphical representation. If no input is specified for the position of the dimension text, a default position on the dimension plane will be calculated and used to place the dimension text. If a valid point for the dimension text is specified, then either of the following conditions will apply:

  • If the specified point already lies on the dimension plane, then this point will be directly used to place the dimension text.
  • If the specified point does not lie on the dimension plane, it will be projected onto the dimension plane. Therefore, the resultant placement position for the dimension text will be different from the specified one.

The GetDimensionPlane method of the DimensionConstraints3D object can be used to get the dimension plane object which provides access to the dimension plane geometry.

Driven
Specifies whether the dimension should be a driven or driving dimension. The default value is False, which causes a driving dimension constraint to be created.
Remarks

The constraint can currently be applied between:

  • two 3D sketch points
  • a 3D sketch point and a vertex
  • a 3D sketch point and a workpoint
Example

"Create a 3D sketch dimension"

This sample demonstrates the creation of a 3d sketch line and a dimension between the start and the end points of the line. To run this sample you must have a 3D sketch active.

Public Sub Create3DSketchDimension()

    ' Check to make sure a 3d sketch is open.
    If Not Typeof ThisApplication.ActiveEditObject Is Sketch3D Then
        MsgBox "A 3d sketch must be active."
        Exit Sub
    End If

    ' Set a reference to the active sketch.
    Dim oSketch As Sketch3D
    Set oSketch = ThisApplication.ActiveEditObject

    ' Set a reference to the transient geometry collection.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create a sketch line
    Dim oSketchLine As SketchLine3D
    Set oSketchLine = oSketch.SketchLines3D.AddByTwoPoints(oTransGeom.CreatePoint(5, 5, 0), oTransGeom.CreatePoint(10, 10, 20))

    ' Create an object collection and add the end points.
    Dim oColl As ObjectCollection
    Set oColl = ThisApplication.TransientObjects.CreateObjectCollection

    oColl.Add oSketchLine.StartSketchPoint
    oColl.Add oSketchLine.EndSketchPoint

    ' The text point for the dimension needs to be on a plane
    ' that Inventor internally computes based on the sketch
    ' entities being dimensioned. Get this plane.
    Dim oDimPlane As Plane
    Set oDimPlane = oSketch.DimensionConstraints3D.GetDimensionPlane(oColl)

    ' Get the normal of the plane
    Dim oPlaneNormal As UnitVector
    Set oPlaneNormal = oDimPlane.Normal

    ' Get the sketch line direction
    Dim oLineDir As UnitVector
    Set oLineDir = oSketchLine.Geometry.Direction

    ' Get the direction in which to offset the text point.
    ' (This should be perpendicular to the plane normal
    ' and the line direction).
    Dim oOffsetDir As UnitVector
    Set oOffsetDir = oPlaneNormal.CrossProduct(oLineDir)

    ' Get the midpoint of the sketch line
    Dim oMidPoint As Point
    Set oMidPoint = oSketchLine.Geometry.MidPoint

    ' Offset the midpoint from the line by a distance.
    Dim oOffsetPoint As Point
    Set oOffsetPoint = oMidPoint
    Call oOffsetPoint.TranslateBy(oOffsetDir.AsVector)

    ' Create the dimension.
    Dim oTwoPointDim As TwoPointDistanceDimConstraint3D
    Set oTwoPointDim = oSketch.DimensionConstraints3D.AddTwoPointDistance(oSketchLine.StartSketchPoint, oSketchLine.EndSketchPoint, oOffsetPoint)

    ' Make sure that the dimension text was placed at the specified point.
    If oOffsetPoint.IsEqualTo(oTwoPointDim.TextPoint) Then
        MsgBox "Dimension text placed at specified point."
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.AddTwoPointDistance Method


DimensionConstraints3D.GetDimensionPlane Method

DimensionConstraints3D.GetDimensionPlane Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that gets the transient dimension plane used to place and position the dimension text when a dimension constraint is applied to the specified input entities.

Visual Basic
Sub GetDimensionPlane(Entities As ObjectCollection, Result As [out, retval] Plane*)
Parameters
Parameters | Description
Entities | ObjectCollection that contains the entity objects that represents the entities for which the dimension plane has to be determined. The objects in this collection should normally contain the same objects that would be supplied as inputs to create a dimension constraint.
Remarks

The dimension plane is a transient geometric plane which is only used to define the placement plane for the dimension text and does not have a graphical representation. The orientation of the dimension plane will be automatically determined using the sketch entities when they are dimensioned. The dimension text will always be placed on this dimension plane. This method can be used to determine this dimension plane prior to actually creating the dimension constraint.

The geometric information about the dimension plane could be used to calculate a 3D point that lies on the plane. This point can then be supplied as input for the position for the dimension text when creating the dimension constraint in which case the resultant position of the dimension text will be the same as the specified input placement point. On the other hand, if a placement point that does not lie on the dimension plane is specified as the position for the dimension text, it will be projected onto the dimension plane and the dimension text will be placed at this projected point.

The following table shows the combination of the types of input objects that can be used to determine the dimension plane for the various dimension constraints. This combination matches the input types that will be supplied to actually create the corresponding dimension constraint.

Dimension Constraint | Objects in collection
LineLengthDimConstraint3D | SketchLine3D
PointAndPlaneDistanceDimConstraint3D | SketchPoint3D and Face (planar) or SketchPoint3D and WorkPlane
TwoLineAngleDimConstraint3D | SketchLine3D and SketchLine3D
TwoPointDistanceDimConstraint3D | SketchPoint3D and SketchPoint3D or SketchPoint3D and Vertex or SketchPoint3D and WorkPoint

The collection must contain one of the combination of objects specified in the above table, otherwise the dimension plane cannot be determined.

See Also

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.GetDimensionPlane Method


DimensionConstraints3D.Item Method

DimensionConstraints3D.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the specified 3D sketch dimension constraint object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DimensionConstraint3D*)
Parameters
Parameters | Description
index | Specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Methods > DimensionConstraints3D.Item Method


DimensionConstraints3D Properties

DimensionConstraints3D Properties
Summary

The properties of the DimensionConstraints3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Properties


DimensionConstraints3D.Application Property

DimensionConstraints3D.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Properties > DimensionConstraints3D.Application Property


DimensionConstraints3D.Count Property

DimensionConstraints3D.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Properties > DimensionConstraints3D.Count Property


DimensionConstraints3D.Type Property

DimensionConstraints3D.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DimensionConstraints3D Interface > DimensionConstraints3D Properties > DimensionConstraints3D.Type Property


DimensionStyle Interface

DimensionStyle Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DimensionStyle object represents a dimension style in a drawing.

Class Hierarchy
Inventor::Style
    Inventor::DimensionStyle
Visual Basic
Public Interface DimensionStyle
Inherits Style
Notes

Members through which this object may be accessed include:

BaselineDimensionSet.Style

ChainDimensionSet.Style

DimensionStylesEnumerator.Item

GeneralDimension.Style

HoleTag.DimensionStyle

LeaderNote.DimensionStyle

ObjectDefaultsStyle.AngularDimensionStyle

ObjectDefaultsStyle.BaselineDimensionStyle

ObjectDefaultsStyle.BendNoteStyle

ObjectDefaultsStyle.BendTagStyle

ObjectDefaultsStyle.ChainDimensionStyle

ObjectDefaultsStyle.ChamferNoteStyle

ObjectDefaultsStyle.DiameterDimensionStyle

ObjectDefaultsStyle.HoleNoteStyle

ObjectDefaultsStyle.HoleTagStyle

ObjectDefaultsStyle.LeaderTextStyle

ObjectDefaultsStyle.LinearDimensionStyle

ObjectDefaultsStyle.OrdinateDimensionStyle

ObjectDefaultsStyle.OrdinateSetDimensionStyle

ObjectDefaultsStyle.PunchNoteStyle

ObjectDefaultsStyle.RadialDimensionStyle

ObjectDefaultsStyle.ThreadNoteStyle

OrdinateDimension.Style

OrdinateDimensionSet.Style

See Also

Dimensions - editing sample

Example

See DrawingDimension for example "Editing dimensions and dimension styles"

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface


DimensionStyle Methods

DimensionStyle Methods
Summary

The methods of the DimensionStyle class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
SetCustomLineType | Method that sets a custom line type to the style from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Methods


DimensionStyle.GetCustomLineType Method

DimensionStyle.GetCustomLineType Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Methods > DimensionStyle.GetCustomLineType Method


DimensionStyle.SetCustomLineType Method

DimensionStyle.SetCustomLineType Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets a custom line type to the style from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Methods > DimensionStyle.SetCustomLineType Method


DimensionStyle Properties

DimensionStyle Properties
Summary

The properties of the DimensionStyle class are listed here.

Properties
Name | Description
AlternateDecimalMarkerType | Property that gets and sets the character to use as a decimal marker for alternate dimensions. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateDisplayFormat | Property that gets and sets the alternate units display format for all non-angular dimensions. Valid values are kFractionalNotStackedFormat, kFractionalHorizontalStackedFormat, kFractionalDiagonalStackedFormat and kDecimalFormat.
AlternateDisplayUnitType | Property that gets and sets whether to display units for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateFractionalTextScale | Property that gets and sets the size of the stacked text relative to the default text size when using alternate units. The valid range of values is 0.25 to 1.25. Setting this property fails if the AlternateDisplayFormat property value is not kFractionalHorizontalStackedFormat or kFractionalDiagonalStackedFormat.
AlternateIncludedZeroDisplay | Property that gets and sets whether to display the included zeroes for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateLeadingZeroDisplay | Property that gets and sets whether to display the leading zeroes for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateLinearPrecision | Property that gets and sets the precision for linear alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateLinearUnits | Property that gets and sets the units of length measure used for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateStyleFormat | Property that gets and sets the arrangement of the alternate dimension display with respect to the primary dimension. The primary dimension always precedes the alternate dimension.. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateTrailingZeroDisplay | Property that gets and sets whether to display the trailing zeroes for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.
AngularPrecision | Property that gets and sets the precision for angular dimensions in the drawing.
ArrowheadHeight | Property that gets and sets the height of the arrowhead relative to the associated line, in centimeters.
ArrowheadSize | Property that gets and sets the size of the arrowhead (i.e. the terminator), in centimeters. The value is that of width of the arrow if the terminator is an arrowhead or for diameter if the terminator is a circle.
ArrowheadType | Property that gets and sets the arrowhead style to use.
ArrowheadTypeForChainDimensions | Property that gets and sets the internal arrowhead styles to use for chain dimensions. The two outermost arrowheads will be as specified in the ArrowheadType property.
Color | Property that gets and sets the line color for the dimension style. Setting the property to Nothing restores the style to the color defined by the layer.
DecimalMarkerType | Property that gets and sets the character to use as a decimal marker for dimensions. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker
DisplayFormat | Property that gets and sets the display format for all non-angular dimensions. Valid values are kFractionalNotStackedFormat, kFractionalHorizontalStackedFormat, kFractionalDiagonalStackedFormat and kDecimalFormat.
DisplayUnitType | Property that gets and sets whether to display units for dimensions in the drawing.
Extension | Property that gets and sets the distance the extension line is drawn past the dimension line, in centimeters.
FractionalTextScale | Property that gets and sets the size of the stacked text relative to the default text size. The valid range of values is 0.25 to 1.25. Setting this property fails if the DisplayFormat property value is not kFractionalHorizontalStackedFormat or kFractionalDiagonalStackedFormat.
Gap | Property that gets and sets the distance between the dimension text and the dimension lines, in centimeters.
IncludedZeroDisplay | Property that gets and sets whether to display the included zeroes for dimensions in the drawing.
LeaderStyle | Property that gets and sets the leader style used for the dimension style.
LeadingZeroDisplay | Property that gets and sets whether to display the leading zeroes for dimensions in the drawing.
LinearPrecision | Property that gets and sets the precision value for linear dimensions in the drawing.
LinearUnits | Property that gets and sets the units of length measure used for dimensions in the drawing.
LineType | Property that gets and sets the line type override for the style.
OrdinateDimensionOriginArrowheadType | This is OrdinateDimensionOriginArrowheadType, a member of class DimensionStyle.
LineWeight | Property that gets and sets the line weight override for the style. The property returns 0 if the line weight is defined by the associated layer. Setting the property to 0 restores the style to the line weight defined by the layer.
OriginOffset | Property that gets and sets the distance from an edge or point to the endpoint of the extension line, in centimeters.
PartOffset | Property that gets and sets the distance from the referenced part edge to a parallel dimension line, in centimeters.
Prefix | Property that gets and sets the dimension prefix. A prefix can include numeric characters, letters or symbols.
PrefixAndSuffixOrder | Property that gets and sets the location of prefix and suffix. Valid values are kBeforeAndAfter indicating the location to be before and after the dimension text or kAboveAndBelow indicating the location to be above and below the dimension text.
ShowBreakSymbol | Property that gets and sets whether to display break symbols for dimensions on a broken view.
ShowDimensionLine | Property that gets and sets whether to display the dimension line when arrowheads are outside the dimension extension lines.
Spacing | Property that gets and sets the distance between the parallel dimension lines, in centimeters.
Suffix | Property that gets and sets the dimension suffix. A suffix can include numeric characters, letters or symbols.
TextStyle | Property that gets and sets the text style used for the dimension style. If a text style is set, the font attributes, justification, and color are controlled by the text style.
Tolerance | Property that returns the Tolerance object. The Tolerance object contains methods and properties to query and modify tolerance types and values.
ToleranceAlternateIncludedZeroDisplay | Property that gets and sets whether to display the included zeroes for tolerances in alternate units.
ToleranceAlternateLeadingZeroDisplay | Property that gets and sets whether to display the leading zeroes for tolerances in alternate units.
ToleranceAlternateTrailingZeroDisplay | Property that gets and sets whether to display the trailing zeroes for tolerances in alternate units.
ToleranceAlternateUnitPrecision | Property that gets and sets the number of decimal places visible to the right of the decimal marker in tolerance text for alternate dimensions. This property is used only when the AlternateUnitsDisplay property is set to true.
ToleranceAngularPrecision | Property that gets and sets the number of decimal places visible to the right of the decimal marker in tolerance text for angular dimensions.
ToleranceFontSize | Property that gets and sets the size of the font used for tolerances. The size is specified in centimeters.
ToleranceIncludedZeroDisplay | Property that gets and sets whether to display the included zeroes for tolerances.
ToleranceLeadingZeroDisplay | Property that gets and sets whether to display the leading zeroes for tolerances.
ToleranceLinearPrecision | Property that gets and sets the number of decimal places visible to the right of the decimal marker in tolerance text for linear dimensions.
ToleranceTextStyle | Property that gets and sets the text style used for tolerances.
ToleranceTrailingZeroDisplay | Property that gets and sets whether to display the trailing zeroes for tolerances.
TrailingZeroDisplay | Property that gets and sets whether to display the trailing zeroes for dimensions in the drawing.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties


DimensionStyle.AlternateDecimalMarkerType Property

DimensionStyle.AlternateDecimalMarkerType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the character to use as a decimal marker for alternate dimensions. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateDecimalMarkerType() As DecimalMarkerTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateDecimalMarkerType Property


DimensionStyle.AlternateDisplayFormat Property

DimensionStyle.AlternateDisplayFormat Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the alternate units display format for all non-angular dimensions. Valid values are kFractionalNotStackedFormat, kFractionalHorizontalStackedFormat, kFractionalDiagonalStackedFormat and kDecimalFormat.

Visual Basic
Property AlternateDisplayFormat() As DisplayFormatEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateDisplayFormat Property


DimensionStyle.AlternateDisplayUnitType Property

DimensionStyle.AlternateDisplayUnitType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display units for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateDisplayUnitType() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateDisplayUnitType Property


DimensionStyle.AlternateFractionalTextScale Property

DimensionStyle.AlternateFractionalTextScale Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the size of the stacked text relative to the default text size when using alternate units. The valid range of values is 0.25 to 1.25. Setting this property fails if the AlternateDisplayFormat property value is not kFractionalHorizontalStackedFormat or kFractionalDiagonalStackedFormat.

Visual Basic
Property AlternateFractionalTextScale() As double
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateFractionalTextScale Property


DimensionStyle.AlternateIncludedZeroDisplay Property

DimensionStyle.AlternateIncludedZeroDisplay Property
Summary

Property that gets and sets whether to display the included zeroes for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateIncludedZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateIncludedZeroDisplay Property


DimensionStyle.AlternateLeadingZeroDisplay Property

DimensionStyle.AlternateLeadingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the leading zeroes for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateLeadingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateLeadingZeroDisplay Property


DimensionStyle.AlternateLinearPrecision Property

DimensionStyle.AlternateLinearPrecision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the precision for linear alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateLinearPrecision() As LinearPrecisionEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateLinearPrecision Property


DimensionStyle.AlternateLinearUnits Property

DimensionStyle.AlternateLinearUnits Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the units of length measure used for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateLinearUnits() As UnitsTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateLinearUnits Property


DimensionStyle.AlternateStyleFormat Property

DimensionStyle.AlternateStyleFormat Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the arrangement of the alternate dimension display with respect to the primary dimension. The primary dimension always precedes the alternate dimension.. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateStyleFormat() As DimensionStyleFormatEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateStyleFormat Property


DimensionStyle.AlternateTrailingZeroDisplay Property

DimensionStyle.AlternateTrailingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the trailing zeroes for alternate dimensions in the drawing. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateTrailingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AlternateTrailingZeroDisplay Property


DimensionStyle.AngularPrecision Property

DimensionStyle.AngularPrecision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the precision for angular dimensions in the drawing.

Visual Basic
Property AngularPrecision() As AngularPrecisionEnum
See Also

Dimensions - editing sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.AngularPrecision Property


DimensionStyle.ArrowheadHeight Property

DimensionStyle.ArrowheadHeight Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the height of the arrowhead relative to the associated line, in centimeters.

Visual Basic
Property ArrowheadHeight() As double
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ArrowheadHeight Property


DimensionStyle.ArrowheadSize Property

DimensionStyle.ArrowheadSize Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the size of the arrowhead (i.e. the terminator), in centimeters. The value is that of width of the arrow if the terminator is an arrowhead or for diameter if the terminator is a circle.

Visual Basic
Property ArrowheadSize() As double
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ArrowheadSize Property


DimensionStyle.ArrowheadType Property

DimensionStyle.ArrowheadType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the arrowhead style to use.

Visual Basic
Property ArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ArrowheadType Property


DimensionStyle.ArrowheadTypeForChainDimensions Property

DimensionStyle.ArrowheadTypeForChainDimensions Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the internal arrowhead styles to use for chain dimensions. The two outermost arrowheads will be as specified in the ArrowheadType property.

Visual Basic
Property ArrowheadTypeForChainDimensions() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ArrowheadTypeForChainDimensions Property


DimensionStyle.Color Property

DimensionStyle.Color Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the line color for the dimension style. Setting the property to Nothing restores the style to the color defined by the layer.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Color Property


DimensionStyle.DecimalMarkerType Property

DimensionStyle.DecimalMarkerType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the character to use as a decimal marker for dimensions. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker

Visual Basic
Property DecimalMarkerType() As DecimalMarkerTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.DecimalMarkerType Property


DimensionStyle.DisplayFormat Property

DimensionStyle.DisplayFormat Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the display format for all non-angular dimensions. Valid values are kFractionalNotStackedFormat, kFractionalHorizontalStackedFormat, kFractionalDiagonalStackedFormat and kDecimalFormat.

Visual Basic
Property DisplayFormat() As DisplayFormatEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.DisplayFormat Property


DimensionStyle.DisplayUnitType Property

DimensionStyle.DisplayUnitType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display units for dimensions in the drawing.

Visual Basic
Property DisplayUnitType() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.DisplayUnitType Property


DimensionStyle.Extension Property

DimensionStyle.Extension Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the distance the extension line is drawn past the dimension line, in centimeters.

Visual Basic
Property Extension() As double
Remarks

Denoted by 'A' in the following picture.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Extension Property


DimensionStyle.FractionalTextScale Property

DimensionStyle.FractionalTextScale Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the size of the stacked text relative to the default text size. The valid range of values is 0.25 to 1.25. Setting this property fails if the DisplayFormat property value is not kFractionalHorizontalStackedFormat or kFractionalDiagonalStackedFormat.

Visual Basic
Property FractionalTextScale() As double
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.FractionalTextScale Property


DimensionStyle.Gap Property

DimensionStyle.Gap Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the distance between the dimension text and the dimension lines, in centimeters.

Visual Basic
Property Gap() As double
Remarks

Denoted by 'C' in the following picture.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Gap Property


DimensionStyle.IncludedZeroDisplay Property

DimensionStyle.IncludedZeroDisplay Property
Summary

Property that gets and sets whether to display the included zeroes for dimensions in the drawing.

Visual Basic
Property IncludedZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.IncludedZeroDisplay Property


DimensionStyle.LeaderStyle Property

DimensionStyle.LeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the leader style used for the dimension style.

Visual Basic
Property LeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.LeaderStyle Property


DimensionStyle.LeadingZeroDisplay Property

DimensionStyle.LeadingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the leading zeroes for dimensions in the drawing.

Visual Basic
Property LeadingZeroDisplay() As VARIANT_BOOL
See Also

Dimensions - editing sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.LeadingZeroDisplay Property


DimensionStyle.LinearPrecision Property

DimensionStyle.LinearPrecision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the precision value for linear dimensions in the drawing.

Visual Basic
Property LinearPrecision() As LinearPrecisionEnum
See Also

Dimensions - editing sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.LinearPrecision Property


DimensionStyle.LinearUnits Property

DimensionStyle.LinearUnits Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the units of length measure used for dimensions in the drawing.

Visual Basic
Property LinearUnits() As UnitsTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.LinearUnits Property


DimensionStyle.LineType Property

DimensionStyle.LineType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the line type override for the style.

Visual Basic
Property LineType() As LineTypeEnum
Remarks

Setting the property to kDefaultLineType restores the style to the line type defined by the associated layer. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.LineType Property


DimensionStyle.OrdinateDimensionOriginArrowheadType Property

DimensionStyle.OrdinateDimensionOriginArrowheadType Property
Summary

This is OrdinateDimensionOriginArrowheadType, a member of class DimensionStyle.

Visual Basic
Property OrdinateDimensionOriginArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.OrdinateDimensionOriginArrowheadType Property


DimensionStyle.LineWeight Property

DimensionStyle.LineWeight Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the line weight override for the style. The property returns 0 if the line weight is defined by the associated layer. Setting the property to 0 restores the style to the line weight defined by the layer.

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.LineWeight Property


DimensionStyle.OriginOffset Property

DimensionStyle.OriginOffset Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the distance from an edge or point to the endpoint of the extension line, in centimeters.

Visual Basic
Property OriginOffset() As double
Remarks

Denoted by 'B' in the following picture.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.OriginOffset Property


DimensionStyle.PartOffset Property

DimensionStyle.PartOffset Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the distance from the referenced part edge to a parallel dimension line, in centimeters.

Visual Basic
Property PartOffset() As double
Remarks

Denoted by 'E' in the following picture. This value is only used when edges are parallel to the dimension lines.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.PartOffset Property


DimensionStyle.Prefix Property

DimensionStyle.Prefix Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the dimension prefix. A prefix can include numeric characters, letters or symbols.

Visual Basic
Property Prefix() As String
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Prefix Property


DimensionStyle.PrefixAndSuffixOrder Property

DimensionStyle.PrefixAndSuffixOrder Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location of prefix and suffix. Valid values are kBeforeAndAfter indicating the location to be before and after the dimension text or kAboveAndBelow indicating the location to be above and below the dimension text.

Visual Basic
Property PrefixAndSuffixOrder() As PrefixAndSuffixOrderEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.PrefixAndSuffixOrder Property


DimensionStyle.ShowBreakSymbol Property

DimensionStyle.ShowBreakSymbol Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether to display break symbols for dimensions on a broken view.

Visual Basic
Property ShowBreakSymbol() As VARIANT_BOOL
Remarks

A value of True results in the first picture and a value of False results in the second.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ShowBreakSymbol Property


DimensionStyle.ShowDimensionLine Property

DimensionStyle.ShowDimensionLine Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether to display the dimension line when arrowheads are outside the dimension extension lines.

Visual Basic
Property ShowDimensionLine() As VARIANT_BOOL
Remarks

A value of False results in the first picture and a value of True results in the second.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ShowDimensionLine Property


DimensionStyle.Spacing Property

DimensionStyle.Spacing Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the distance between the parallel dimension lines, in centimeters.

Visual Basic
Property Spacing() As double
Remarks

Denoted by 'D' in the following picture.

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Spacing Property


DimensionStyle.Suffix Property

DimensionStyle.Suffix Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the dimension suffix. A suffix can include numeric characters, letters or symbols.

Visual Basic
Property Suffix() As String
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Suffix Property


DimensionStyle.TextStyle Property

DimensionStyle.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the text style used for the dimension style. If a text style is set, the font attributes, justification, and color are controlled by the text style.

Visual Basic
Property TextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.TextStyle Property


DimensionStyle.Tolerance Property

DimensionStyle.Tolerance Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the Tolerance object. The Tolerance object contains methods and properties to query and modify tolerance types and values.

Visual Basic
Property Tolerance() As Tolerance**
See Also

Dimensions - editing sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.Tolerance Property


DimensionStyle.ToleranceAlternateIncludedZeroDisplay Property

DimensionStyle.ToleranceAlternateIncludedZeroDisplay Property
Summary

Property that gets and sets whether to display the included zeroes for tolerances in alternate units.

Visual Basic
Property ToleranceAlternateIncludedZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceAlternateIncludedZeroDisplay Property


DimensionStyle.ToleranceAlternateLeadingZeroDisplay Property

DimensionStyle.ToleranceAlternateLeadingZeroDisplay Property
Summary

Property that gets and sets whether to display the leading zeroes for tolerances in alternate units.

Visual Basic
Property ToleranceAlternateLeadingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceAlternateLeadingZeroDisplay Property


DimensionStyle.ToleranceAlternateTrailingZeroDisplay Property

DimensionStyle.ToleranceAlternateTrailingZeroDisplay Property
Summary

Property that gets and sets whether to display the trailing zeroes for tolerances in alternate units.

Visual Basic
Property ToleranceAlternateTrailingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceAlternateTrailingZeroDisplay Property


DimensionStyle.ToleranceAlternateUnitPrecision Property

DimensionStyle.ToleranceAlternateUnitPrecision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the number of decimal places visible to the right of the decimal marker in tolerance text for alternate dimensions. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property ToleranceAlternateUnitPrecision() As long
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceAlternateUnitPrecision Property


DimensionStyle.ToleranceAngularPrecision Property

DimensionStyle.ToleranceAngularPrecision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the number of decimal places visible to the right of the decimal marker in tolerance text for angular dimensions.

Visual Basic
Property ToleranceAngularPrecision() As AngularPrecisionEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceAngularPrecision Property


DimensionStyle.ToleranceFontSize Property

DimensionStyle.ToleranceFontSize Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the size of the font used for tolerances. The size is specified in centimeters.

Visual Basic
Property ToleranceFontSize() As double
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceFontSize Property


DimensionStyle.ToleranceIncludedZeroDisplay Property

DimensionStyle.ToleranceIncludedZeroDisplay Property
Summary

Property that gets and sets whether to display the included zeroes for tolerances.

Visual Basic
Property ToleranceIncludedZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceIncludedZeroDisplay Property


DimensionStyle.ToleranceLeadingZeroDisplay Property

DimensionStyle.ToleranceLeadingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the leading zeroes for tolerances.

Visual Basic
Property ToleranceLeadingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceLeadingZeroDisplay Property


DimensionStyle.ToleranceLinearPrecision Property

DimensionStyle.ToleranceLinearPrecision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the number of decimal places visible to the right of the decimal marker in tolerance text for linear dimensions.

Visual Basic
Property ToleranceLinearPrecision() As long
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceLinearPrecision Property


DimensionStyle.ToleranceTextStyle Property

DimensionStyle.ToleranceTextStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the text style used for tolerances.

Visual Basic
Property ToleranceTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceTextStyle Property


DimensionStyle.ToleranceTrailingZeroDisplay Property

DimensionStyle.ToleranceTrailingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the trailing zeroes for tolerances.

Visual Basic
Property ToleranceTrailingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.ToleranceTrailingZeroDisplay Property


DimensionStyle.TrailingZeroDisplay Property

DimensionStyle.TrailingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the trailing zeroes for dimensions in the drawing.

Visual Basic
Property TrailingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DimensionStyle Interface > DimensionStyle Properties > DimensionStyle.TrailingZeroDisplay Property


DimensionStylesEnumerator Interface

DimensionStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DimensionStylesEnumerator collection object provides access to the existing objects.

Class Hierarchy
Inventor::DimensionStylesEnumerator
Visual Basic
Public Interface DimensionStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.DimensionStyles

You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface


DimensionStylesEnumerator Methods

DimensionStylesEnumerator Methods
Summary

The methods of the DimensionStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface > DimensionStylesEnumerator Methods


DimensionStylesEnumerator.Item Method

DimensionStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DimensionStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DimensionStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the DimensionStyle name. If an out of range index or a name of a non-existent DimensionStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface > DimensionStylesEnumerator Methods > DimensionStylesEnumerator.Item Method


DimensionStylesEnumerator Properties

DimensionStylesEnumerator Properties
Summary

The properties of the DimensionStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface > DimensionStylesEnumerator Properties


DimensionStylesEnumerator.Application Property

DimensionStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface > DimensionStylesEnumerator Properties > DimensionStylesEnumerator.Application Property


DimensionStylesEnumerator.Count Property

DimensionStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface > DimensionStylesEnumerator Properties > DimensionStylesEnumerator.Count Property


DimensionStylesEnumerator.Type Property

DimensionStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DimensionStylesEnumerator Interface > DimensionStylesEnumerator Properties > DimensionStylesEnumerator.Type Property


DimensionText Interface

DimensionText Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DimensionText object represents text in a dimension placed on a sheet.

Class Hierarchy
Inventor::DimensionText
Visual Basic
Public Interface DimensionText
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDimension.Text

See Also

Aligning drawing dimensions sample

Example

See DrawingDimension for example "Editing dimensions and dimension styles"

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface


DimensionText Properties

DimensionText Properties
Summary

The properties of the DimensionText class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Color | Property that gets and set the color of the dimension text.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
HorizontalJustification | Property that gets and sets the horizontal justification override of the dimension text.
LineSpacing | Property that gets and sets the line spacing of the dimension text.
LineSpacingType | Property that gets and sets the method used to define the line spacing.
Origin | Property that gets and sets the position of the origin of the dimension text.
Parent | Property that returns the parent of the object.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Text | Property that indicates the string that defines the dimension text. When getting this property, the returned string has all formatting removed and contains the actual text characters displayed in the text. If this property is used to set the text, all format overrides will be removed and the text will revert to the associated text style. Also, the dimension value will always be placed at the beginning of the text. If you want to control the location of the dimension value, use the FormattedText property. The dimension value can be hidden using the HideValue property.
Type | Returns an ObjectTypeEnum indicating this object's type.
VerticalJustification | Property that gets and sets the vertical justification override of the dimension text.
WidthScale | Property that gets and sets the width scale factor for the dimension text.
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties


DimensionText.Application Property

DimensionText.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.Application Property


DimensionText.Color Property

DimensionText.Color Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and set the color of the dimension text.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.Color Property


DimensionText.FormattedText Property

DimensionText.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.FormattedText Property


DimensionText.HorizontalJustification Property

DimensionText.HorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the horizontal justification override of the dimension text.

Visual Basic
Property HorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.HorizontalJustification Property


DimensionText.LineSpacing Property

DimensionText.LineSpacing Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line spacing of the dimension text.

Visual Basic
Property LineSpacing() As double
Remarks

The value of this property is treated in one of two ways depending on the value of the LineSpacingType property. When the value of the LineSpacingType property is set to kExactLineSpacing, the value of the LineSpacing property defines the exact distance (in centimeters) from the bottom of one line to bottom of the next line.

When the value of the LineSpacingType property is set to kMultipleLineSpacing, the value defines a spacing factor relative to standard single line spacing. For example, a value of 1.0 will result in standard single line spacing, and a value of 1.5 will result in one and a half line spacing.

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.LineSpacing Property


DimensionText.LineSpacingType Property

DimensionText.LineSpacingType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the method used to define the line spacing.

Visual Basic
Property LineSpacingType() As TextLineSpacingTypeEnum
Remarks

The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.LineSpacingType Property


DimensionText.Origin Property

DimensionText.Origin Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the position of the origin of the dimension text.

Visual Basic
Property Origin() As Point2d *
Remarks

The text origin is controlled by the horizontal and vertical justification of the text box. If the text's horizontal justification is kAlignTextLeft and the vertical justification is kAlignTextUpper then the origin will be the upper-left corner of the text. Setting the justifications to kAlignTextCenter and kAlignTextMiddle will result in the text moving to position the origin at the center of the text. As the text changes, the position of the origin remains fixed.

See Also

Aligning drawing dimensions sample

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.Origin Property


DimensionText.Parent Property

DimensionText.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As DrawingDimension**
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.Parent Property


DimensionText.RangeBox Property

DimensionText.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.RangeBox Property


DimensionText.Text Property

DimensionText.Text Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the string that defines the dimension text. When getting this property, the returned string has all formatting removed and contains the actual text characters displayed in the text. If this property is used to set the text, all format overrides will be removed and the text will revert to the associated text style. Also, the dimension value will always be placed at the beginning of the text. If you want to control the location of the dimension value, use the FormattedText property. The dimension value can be hidden using the HideValue property.

Visual Basic
Property Text() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.Text Property


DimensionText.Type Property

DimensionText.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.Type Property


DimensionText.VerticalJustification Property

DimensionText.VerticalJustification Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the vertical justification override of the dimension text.

Visual Basic
Property VerticalJustification() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.VerticalJustification Property


DimensionText.WidthScale Property

DimensionText.WidthScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the width scale factor for the dimension text.

Visual Basic
Property WidthScale() As double
Remarks

This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.

You are here: Symbol Reference > Inventor Library > Objects > DimensionText Interface > DimensionText Properties > DimensionText.WidthScale Property


DirectionAndDistanceMoveDefinition Interface

DirectionAndDistanceMoveDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The DirectionAndDistanceMoveDefinition object defines all of the inputs that are unique to a move face feature defined using a direction vector and a distance.

Class Hierarchy
Inventor::DirectionAndDistanceMoveDefinition
Visual Basic
Public Interface DirectionAndDistanceMoveDefinition
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface


DirectionAndDistanceMoveDefinition Properties

DirectionAndDistanceMoveDefinition Properties
Summary

The properties of the DirectionAndDistanceMoveDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Direction | Property that gets and sets the entity defining the direction for the move. This can either be a WorkAxis, a linear Edge, or a planar Face object.
DirectionReversed | Property that gets and sets whether the direction defined by the entity in the Direction property should be reversed. This property defaults to False when the MoveFaceDefinition is initially created.
Distance | Property that returns the distance Parameter object associated with the move.
Parent | Property that returns the parent MoveFaceDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties


DirectionAndDistanceMoveDefinition.Application Property

DirectionAndDistanceMoveDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties > DirectionAndDistanceMoveDefinition.Application Property


DirectionAndDistanceMoveDefinition.Direction Property

DirectionAndDistanceMoveDefinition.Direction Property
Summary

Property that gets and sets the entity defining the direction for the move. This can either be a WorkAxis, a linear Edge, or a planar Face object.

Visual Basic
Property Direction() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties > DirectionAndDistanceMoveDefinition.Direction Property


DirectionAndDistanceMoveDefinition.DirectionReversed Property

DirectionAndDistanceMoveDefinition.DirectionReversed Property
Summary

Property that gets and sets whether the direction defined by the entity in the Direction property should be reversed. This property defaults to False when the MoveFaceDefinition is initially created.

Visual Basic
Property DirectionReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties > DirectionAndDistanceMoveDefinition.DirectionReversed Property


DirectionAndDistanceMoveDefinition.Distance Property

DirectionAndDistanceMoveDefinition.Distance Property
Summary

Property that returns the distance Parameter object associated with the move.

Visual Basic
Property Distance() As Parameter**
Remarks

When creating a new move face feature and the MoveFaceDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetDirectionAndDistanceMoveType method of the MoveFaceDefinition to set this value in that case.

When this object is obtained from an existing feature you can edit the move face feature by modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties > DirectionAndDistanceMoveDefinition.Distance Property


DirectionAndDistanceMoveDefinition.Parent Property

DirectionAndDistanceMoveDefinition.Parent Property
Summary

Property that returns the parent MoveFaceDefinition object.

Visual Basic
Property Parent() As MoveFaceDefinition**
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties > DirectionAndDistanceMoveDefinition.Parent Property


DirectionAndDistanceMoveDefinition.Type Property

DirectionAndDistanceMoveDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DirectionAndDistanceMoveDefinition Interface > DirectionAndDistanceMoveDefinition Properties > DirectionAndDistanceMoveDefinition.Type Property


DisabledCommandList Interface

DisabledCommandList Interface Available in Inventor Introduced in Inventor 10
Summary

This object represents a list of commands that are disabled in the given context. For example, a DisabledCommandList collection in the document context lists all commands disabled at the document level, while a DisabledCommandList collection at the environment level list commands disabled in a given environment. This collection object compliments the Enabled property of the ControlDefinition object.

Class Hierarchy
Inventor::DisabledCommandList
Visual Basic
Public Interface DisabledCommandList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.DisabledCommandList

DrawingDocument.DisabledCommandList

Environment.DisabledCommandList

PartDocument.DisabledCommandList

PresentationDocument.DisabledCommandList

You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface


DisabledCommandList Methods

DisabledCommandList Methods
Summary

The methods of the DisabledCommandList class are listed here.

Methods
Methods
Name | Description
Add | Method that adds the specified command to the list.
Item | Property that returns the specified ControlDefinition from the list.
Remove | Method that removes the specified command from the list.
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Methods


DisabledCommandList.Add Method

DisabledCommandList.Add Method Available in Inventor Introduced in Inventor 10
Summary

Method that adds the specified command to the list.

Visual Basic
Sub Add(Command As ControlDefinition)
Parameters
Parameters | Description
Command | Input ControlDefinition object that is to be added to the disabled command list.
See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Methods > DisabledCommandList.Add Method


DisabledCommandList.Item Method

DisabledCommandList.Item Method Available in Inventor Introduced in Inventor 10
Summary

Property that returns the specified ControlDefinition from the list.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ControlDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the ControlDefinition to return. The first item in the list has an index of one.
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Methods > DisabledCommandList.Item Method


DisabledCommandList.Remove Method

DisabledCommandList.Remove Method Available in Inventor Introduced in Inventor 10
Summary

Method that removes the specified command from the list.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the ControlDefinition object to remove from the list. The first item in the list has an index of one.
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Methods > DisabledCommandList.Remove Method


DisabledCommandList Properties

DisabledCommandList Properties
Summary

The properties of the DisabledCommandList class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Read only property that returns the number of commands in the list.
Type | Read only property returning kDisabledCommandListObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Properties


DisabledCommandList.Application Property

DisabledCommandList.Application Property Available in Inventor Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Properties > DisabledCommandList.Application Property


DisabledCommandList.Count Property

DisabledCommandList.Count Property Available in Inventor Introduced in Inventor 10
Summary

Read only property that returns the number of commands in the list.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Properties > DisabledCommandList.Count Property


DisabledCommandList.Type Property

DisabledCommandList.Type Property Available in Inventor Introduced in Inventor 10
Summary

Read only property returning kDisabledCommandListObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DisabledCommandList Interface > DisabledCommandList Properties > DisabledCommandList.Type Property


DisplayOptions Interface

DisplayOptions Interface Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

The DisplayOptions object provides access to properties that provide read and write access of the display related application options. This is somewhat equivalent to the Display tab of the Application Options dialog.

Class Hierarchy
Inventor::DisplayOptions
Visual Basic
Public Interface DisplayOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.DisplayOptions

ApprenticeServer.DisplayOptions

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface


DisplayOptions Methods

DisplayOptions Methods
Summary

The methods of the DisplayOptions class are listed here.

Methods
Methods
Name | Description
ShadedDisplayOptions | Property that returns the ShadedDisplayOptions object. The ShadedDisplayOptions object provides access to various shaded display related application level options. This is equivalent to the Shaded Display Mode section of the Display tab on the Application Options dialog.
WireframeDisplayOptions | Property that returns the WireframeDisplayOptions object. The WireframeDisplayOptions object provides access to various shaded display related application level options. This is equivalent to the Wireframe Display Mode section of the Display tab on the Application Options dialog.
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Methods


DisplayOptions.ShadedDisplayOptions Method

DisplayOptions.ShadedDisplayOptions Method Available in Inventor Introduced in Inventor 11
Summary

Property that returns the ShadedDisplayOptions object. The ShadedDisplayOptions object provides access to various shaded display related application level options. This is equivalent to the Shaded Display Mode section of the Display tab on the Application Options dialog.

Visual Basic
Sub ShadedDisplayOptions(Result As [out, retval] ShadedDisplayOptions*)
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Methods > DisplayOptions.ShadedDisplayOptions Method


DisplayOptions.WireframeDisplayOptions Method

DisplayOptions.WireframeDisplayOptions Method Available in Inventor Introduced in Inventor 11
Summary

Property that returns the WireframeDisplayOptions object. The WireframeDisplayOptions object provides access to various shaded display related application level options. This is equivalent to the Wireframe Display Mode section of the Display tab on the Application Options dialog.

Visual Basic
Sub WireframeDisplayOptions(Result As [out, retval] WireframeDisplayOptions*)
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Methods > DisplayOptions.WireframeDisplayOptions Method


DisplayOptions Properties

DisplayOptions Properties
Summary

The properties of the DisplayOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DefaultOrbitType | Property that specifies the default behavior for the Orbit command. Valid values are kFreeOrbit and kConstrainedOrbit.
DepthDimming | Property that enables or disables the depth dimming effect that displays entities that are nearer with a brighter light to better convey the depth of the model. Setting this property to True enables the depth dimming effect.
DisplayQuality | Property that specifies the resolution quality to apply to the display of the model. The valid options are kSmootherDisplayQuality, kSmoothDisplayQuality, kMediumDisplayQuality and kRoughDisplayQuality.
DisplaySilhouettes | Property that specifies whether to display silhouette edges for active components.
EdgeColor | Property that gets and sets the color for the edge display (including silhouettes) for active components. This property will return Nothing if no color has been specified. Additionally, this property can also be set to Nothing to indicate that the edges should be displayed using part color.
HiddenLineDimmingPercent | Property that gets and sets the dimming factor (expressed as a percentage) applied to the display of hidden lines in the model. The valid values for this property are in the range of 0 to 100, setting a value outside this range will cause an error.
InactiveComponentsEdgeColor | Property that gets and sets the color for the edge display (including silhouettes) for inactive components. This property will return Nothing if no color has been specified. Additionally, this property can also be set to Nothing to indicate that the edges should be displayed using default color.
InactiveComponentsEdgeDisplay | Property that specifies whether edges should be displayed for inactive components.
InactiveComponentsShaded | Property that enables or disables contrasting shading for the display of inactive components.
InactiveComponentsShadeOpacity | Property that gets and sets the opacity level (expressed as a percentage) for the shading of inactive components. Note that the InactiveComponentsShaded property has to be True in order for the components to be displayed using the opacity level specified by this property.
MinimumFrameRate | Property that gets and sets the number of frames to display for the model during interactive viewing operations like Rotate, Pan and Zoom. The valid values for this property are in the range of 0.0 to 10.0, setting a value outside this range will cause an error.
NewWindowDisplayMode | Property that gets and sets the default display mode for new windows.
NewWindowProjectionType | Property that gets and sets the default projection type for new windows. Valid values are kOrthographicProjection and kPerspectiveProjection.
NewWindowShowAmbientShadows | Property that gets and sets whether to display ambient shadows (occlusions) for new windows.
NewWindowShowGroundPlane | Property that gets and sets whether to display ground planes for new windows.
NewWindowShowGroundReflections | Property that gets and sets whether to display ground plane reflections for new windows.
NewWindowShowGroundShadows | Property that gets and sets whether to display ground shadows for new windows.
NewWindowShowObjectShadows | Property that gets and sets whether to display object shadows for new windows.
RayTracingQuality | Property that gets and sets the quality used when ray tracing is enabled.
ReverseZoomDirection | Property that gets and sets the zoom direction with respect to the movement of the mouse cursor or mouse wheel.
Show3DIndicator | Property that gets and sets if the 3D indicator (triad) is displayed or not. A value of True indicates the triad is visible and a value of False indicates it is hidden.
ShowXYZAxisLabels | Property that gets and sets whether to show axis labels for the 3D indicator (triad).
SolidLinesForHiddenEdges | Property that gets and sets whether the hidden model edges should be displayed as solid lines.
Type | Returns an ObjectTypeEnum indicating this object's type.
UseDocumentDisplaySettings | Property that gets and sets whether to use the display appearance settings defined in the document. If set to False, the application level display settings are used.
UseRayTracingForRealisticDisplay | Property that gets and sets whether to enable ray tracing in realistic visual styles for new windows.
ViewTransitionTime | Property that gets and sets the time taken to transition between views of a model.
ZoomToCursor | Property that gets and sets whether the cursor position is the focus point for the zoom operation.
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties


DisplayOptions.Application Property

DisplayOptions.Application Property Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.Application Property


DisplayOptions.DefaultOrbitType Property

DisplayOptions.DefaultOrbitType Property Available in Apprentice Available in Inventor Introduced in Inventor 2010
Summary

Property that specifies the default behavior for the Orbit command. Valid values are kFreeOrbit and kConstrainedOrbit.

Visual Basic
Property DefaultOrbitType() As OrbitTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.DefaultOrbitType Property


DisplayOptions.DepthDimming Property

DisplayOptions.DepthDimming Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that enables or disables the depth dimming effect that displays entities that are nearer with a brighter light to better convey the depth of the model. Setting this property to True enables the depth dimming effect.

Visual Basic
Property DepthDimming() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.DepthDimming Property


DisplayOptions.DisplayQuality Property

DisplayOptions.DisplayQuality Property Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

Property that specifies the resolution quality to apply to the display of the model. The valid options are kSmootherDisplayQuality, kSmoothDisplayQuality, kMediumDisplayQuality and kRoughDisplayQuality.

Visual Basic
Property DisplayQuality() As DisplayQualityEnum
Remarks

Setting this property to kSmoothDisplayQuality provides the best display quality in terms of resolution but, might result in reduced performance when displaying complex models.

Setting this property to kMediumDisplayQuality provides an intermediate display quality and provides a reasonably good resolution quality without unduly compromising the performance.

Setting this property to kRoughDisplayQuality provides a rough resolution quality by simplifying the details on complex models but, provides better performance than what would be obtained with the smooth or medium display quality setting.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.DisplayQuality Property


DisplayOptions.DisplaySilhouettes Property

DisplayOptions.DisplaySilhouettes Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that specifies whether to display silhouette edges for active components.

Visual Basic
Property DisplaySilhouettes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.DisplaySilhouettes Property


DisplayOptions.EdgeColor Property

DisplayOptions.EdgeColor Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the color for the edge display (including silhouettes) for active components. This property will return Nothing if no color has been specified. Additionally, this property can also be set to Nothing to indicate that the edges should be displayed using part color.

Visual Basic
Property EdgeColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.EdgeColor Property


DisplayOptions.HiddenLineDimmingPercent Property

DisplayOptions.HiddenLineDimmingPercent Property Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets the dimming factor (expressed as a percentage) applied to the display of hidden lines in the model. The valid values for this property are in the range of 0 to 100, setting a value outside this range will cause an error.

Visual Basic
Property HiddenLineDimmingPercent() As long
Remarks

This property is only applicable when the model is being currently displayed in wireframe mode and the display of hidden edges has been enabled for either or both active and enabled components using the DimmedHiddenEdgesForActiveComponents and DimmedHiddenEdgesForEnabledComponents properties respectively of the WireframeDisplayOptions object.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.HiddenLineDimmingPercent Property


DisplayOptions.InactiveComponentsEdgeColor Property

DisplayOptions.InactiveComponentsEdgeColor Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the color for the edge display (including silhouettes) for inactive components. This property will return Nothing if no color has been specified. Additionally, this property can also be set to Nothing to indicate that the edges should be displayed using default color.

Visual Basic
Property InactiveComponentsEdgeColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.InactiveComponentsEdgeColor Property


DisplayOptions.InactiveComponentsEdgeDisplay Property

DisplayOptions.InactiveComponentsEdgeDisplay Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that specifies whether edges should be displayed for inactive components.

Visual Basic
Property InactiveComponentsEdgeDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.InactiveComponentsEdgeDisplay Property


DisplayOptions.InactiveComponentsShaded Property

DisplayOptions.InactiveComponentsShaded Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that enables or disables contrasting shading for the display of inactive components.

Visual Basic
Property InactiveComponentsShaded() As VARIANT_BOOL
Remarks

Setting this property to True enables contrasting shading for enabled components. Setting this property to False automatically sets the InactiveComponentsEdgeDisplay property to True.

The opacity for the shading can be specified using the ShadeOpacityForEnabledComponents property.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.InactiveComponentsShaded Property


DisplayOptions.InactiveComponentsShadeOpacity Property

DisplayOptions.InactiveComponentsShadeOpacity Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the opacity level (expressed as a percentage) for the shading of inactive components. Note that the InactiveComponentsShaded property has to be True in order for the components to be displayed using the opacity level specified by this property.

Visual Basic
Property InactiveComponentsShadeOpacity() As long
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.InactiveComponentsShadeOpacity Property


DisplayOptions.MinimumFrameRate Property

DisplayOptions.MinimumFrameRate Property Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets the number of frames to display for the model during interactive viewing operations like Rotate, Pan and Zoom. The valid values for this property are in the range of 0.0 to 10.0, setting a value outside this range will cause an error.

Visual Basic
Property MinimumFrameRate() As double
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.MinimumFrameRate Property


DisplayOptions.NewWindowDisplayMode Property

DisplayOptions.NewWindowDisplayMode Property Available in Apprentice Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the default display mode for new windows.

Visual Basic
Property NewWindowDisplayMode() As DisplayModeEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowDisplayMode Property


DisplayOptions.NewWindowProjectionType Property

DisplayOptions.NewWindowProjectionType Property Available in Apprentice Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the default projection type for new windows. Valid values are kOrthographicProjection and kPerspectiveProjection.

Visual Basic
Property NewWindowProjectionType() As ProjectionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowProjectionType Property


DisplayOptions.NewWindowShowAmbientShadows Property

DisplayOptions.NewWindowShowAmbientShadows Property Available in Apprentice
Summary

Property that gets and sets whether to display ambient shadows (occlusions) for new windows.

Visual Basic
Property NewWindowShowAmbientShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowShowAmbientShadows Property


DisplayOptions.NewWindowShowGroundPlane Property

DisplayOptions.NewWindowShowGroundPlane Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether to display ground planes for new windows.

Visual Basic
Property NewWindowShowGroundPlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowShowGroundPlane Property


DisplayOptions.NewWindowShowGroundReflections Property

DisplayOptions.NewWindowShowGroundReflections Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether to display ground plane reflections for new windows.

Visual Basic
Property NewWindowShowGroundReflections() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowShowGroundReflections Property


DisplayOptions.NewWindowShowGroundShadows Property

DisplayOptions.NewWindowShowGroundShadows Property Available in Apprentice
Summary

Property that gets and sets whether to display ground shadows for new windows.

Visual Basic
Property NewWindowShowGroundShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowShowGroundShadows Property


DisplayOptions.NewWindowShowObjectShadows Property

DisplayOptions.NewWindowShowObjectShadows Property Available in Apprentice
Summary

Property that gets and sets whether to display object shadows for new windows.

Visual Basic
Property NewWindowShowObjectShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.NewWindowShowObjectShadows Property


DisplayOptions.RayTracingQuality Property

DisplayOptions.RayTracingQuality Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the quality used when ray tracing is enabled.

Visual Basic
Property RayTracingQuality() As RayTracingQualityEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.RayTracingQuality Property


DisplayOptions.ReverseZoomDirection Property

DisplayOptions.ReverseZoomDirection Property Available in Apprentice Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets the zoom direction with respect to the movement of the mouse cursor or mouse wheel.

Visual Basic
Property ReverseZoomDirection() As VARIANT_BOOL
Remarks

A value of True specifies that the mouse cursor moving up in the display window or rolling the mouse wheel up will zoom in towards the model. A value of False specifies that the mouse cursor moving up in the display window or rolling the mouse wheel up will zoom out and away from the model.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.ReverseZoomDirection Property


DisplayOptions.Show3DIndicator Property

DisplayOptions.Show3DIndicator Property Available in Apprentice
Summary

Property that gets and sets if the 3D indicator (triad) is displayed or not. A value of True indicates the triad is visible and a value of False indicates it is hidden.

Visual Basic
Property Show3DIndicator() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.Show3DIndicator Property


DisplayOptions.ShowXYZAxisLabels Property

DisplayOptions.ShowXYZAxisLabels Property Available in Apprentice
Summary

Property that gets and sets whether to show axis labels for the 3D indicator (triad).

Visual Basic
Property ShowXYZAxisLabels() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.ShowXYZAxisLabels Property


DisplayOptions.SolidLinesForHiddenEdges Property

DisplayOptions.SolidLinesForHiddenEdges Property Available in Apprentice Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets whether the hidden model edges should be displayed as solid lines.

Visual Basic
Property SolidLinesForHiddenEdges() As VARIANT_BOOL
Remarks

A value of True specifies that the hidden model edges should be displayed as solid lines. A value of False specifies that the hidden model edges should be displayed as dashed lines.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.SolidLinesForHiddenEdges Property


DisplayOptions.Type Property

DisplayOptions.Type Property Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.Type Property


DisplayOptions.UseDocumentDisplaySettings Property

DisplayOptions.UseDocumentDisplaySettings Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether to use the display appearance settings defined in the document. If set to False, the application level display settings are used.

Visual Basic
Property UseDocumentDisplaySettings() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.UseDocumentDisplaySettings Property


DisplayOptions.UseRayTracingForRealisticDisplay Property

DisplayOptions.UseRayTracingForRealisticDisplay Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to enable ray tracing in realistic visual styles for new windows.

Visual Basic
Property UseRayTracingForRealisticDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.UseRayTracingForRealisticDisplay Property


DisplayOptions.ViewTransitionTime Property

DisplayOptions.ViewTransitionTime Property Available in Apprentice Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets the time taken to transition between views of a model.

Visual Basic
Property ViewTransitionTime() As double
Remarks

The transition time is the time taken to change the display of the model from the current view (the starting point for the view transition) to the desired resultant view in a continuous manner. The valid values for this property are in the range of 0.0 to 3.0, setting a value outside this range will cause an error.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.ViewTransitionTime Property


DisplayOptions.ZoomToCursor Property

DisplayOptions.ZoomToCursor Property Available in Apprentice Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets whether the cursor position is the focus point for the zoom operation.

Visual Basic
Property ZoomToCursor() As VARIANT_BOOL
Remarks

A value of True specifies that the cursor position is the focus point for the zoom operation. A value of False specifies that the center of the display window is the focus point for the zoom operation.

You are here: Symbol Reference > Inventor Library > Objects > DisplayOptions Interface > DisplayOptions Properties > DisplayOptions.ZoomToCursor Property


DisplaySettings Interface

DisplaySettings Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The DisplaySettings object provides access to properties that provide read and write access of the display appearance related document settings. This is somewhat equivalent to the Display Appearance tab of the Document Settings dialog.

Class Hierarchy
Inventor::DisplaySettings
Visual Basic
Public Interface DisplaySettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.DisplaySettings

PartDocument.DisplaySettings

PresentationDocument.DisplaySettings

You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface


DisplaySettings Properties

DisplaySettings Properties
Summary

The properties of the DisplaySettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DepthDimming | Property that enables or disables the depth dimming effect that displays entities that are nearer with a brighter light to better convey the depth of the model. Setting this property to True enables the depth dimming effect.
DisplaySilhouettes | Property that specifies whether to display silhouette edges for active components.
EdgeColor | Property that gets and sets the color for the edge display (including silhouettes) for active components.
GroundPlaneSettings | Property that returns the GroundPlaneSettings object. The GroundPlaneSettings object provides access to various settings that define the ground plane.
HiddenLineDimmingPercent | Property that gets and sets the dimming factor (expressed as a percentage) applied to the display of hidden lines in the model. The valid values for this property are in the range of 0 to 100, setting a value outside this range will cause an error.
NewWindowDisplayMode | Property that gets and sets the default display mode for new windows.
NewWindowProjectionType | Property that gets and sets the default projection type for new windows. Valid values are kOrthographicProjection and kPerspectiveProjection.
NewWindowShowAmbientShadows | Property that gets and sets whether to display ambient shadows (occlusions) for new windows.
NewWindowShowGroundPlane | Property that gets and sets whether to display ground planes for new windows.
NewWindowShowGroundReflections | Property that gets and sets whether to display ground plane reflections for new windows.
NewWindowShowGroundShadows | Property that gets and sets whether to display ground shadows for new windows.
NewWindowShowObjectShadows | Property that gets and sets whether to display object shadows for new windows.
Parent | Property that returns the parent Document object.
RayTracingQuality | Property that gets and sets the quality used when ray tracing is enabled.
SolidLinesForHiddenEdges | Property that gets and sets whether the hidden model edges should be displayed as solid lines. This is the equivalent of the UI option "Display hidden edges as dashed".
Type | Returns an ObjectTypeEnum indicating this object's type.
UseRayTracingForRealisticDisplay | Property that gets and sets whether to enable ray tracing in realistic visual styles for new windows.
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties


DisplaySettings.Application Property

DisplaySettings.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.Application Property


DisplaySettings.DepthDimming Property

DisplaySettings.DepthDimming Property
Summary

Property that enables or disables the depth dimming effect that displays entities that are nearer with a brighter light to better convey the depth of the model. Setting this property to True enables the depth dimming effect.

Visual Basic
Property DepthDimming() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.DepthDimming Property


DisplaySettings.DisplaySilhouettes Property

DisplaySettings.DisplaySilhouettes Property
Summary

Property that specifies whether to display silhouette edges for active components.

Visual Basic
Property DisplaySilhouettes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.DisplaySilhouettes Property


DisplaySettings.EdgeColor Property

DisplaySettings.EdgeColor Property
Summary

Property that gets and sets the color for the edge display (including silhouettes) for active components.

Visual Basic
Property EdgeColor() As Color*
Remarks

This property will return Nothing if no color has been specified. Additionally, this property can also be set to Nothing to indicate that the edges should be displayed using part color.

You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.EdgeColor Property


DisplaySettings.GroundPlaneSettings Property

DisplaySettings.GroundPlaneSettings Property
Summary

Property that returns the GroundPlaneSettings object. The GroundPlaneSettings object provides access to various settings that define the ground plane.

Visual Basic
Property GroundPlaneSettings() As GroundPlaneSettings**
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.GroundPlaneSettings Property


DisplaySettings.HiddenLineDimmingPercent Property

DisplaySettings.HiddenLineDimmingPercent Property
Summary

Property that gets and sets the dimming factor (expressed as a percentage) applied to the display of hidden lines in the model. The valid values for this property are in the range of 0 to 100, setting a value outside this range will cause an error.

Visual Basic
Property HiddenLineDimmingPercent() As long
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.HiddenLineDimmingPercent Property


DisplaySettings.NewWindowDisplayMode Property

DisplaySettings.NewWindowDisplayMode Property
Summary

Property that gets and sets the default display mode for new windows.

Visual Basic
Property NewWindowDisplayMode() As DisplayModeEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowDisplayMode Property


DisplaySettings.NewWindowProjectionType Property

DisplaySettings.NewWindowProjectionType Property
Summary

Property that gets and sets the default projection type for new windows. Valid values are kOrthographicProjection and kPerspectiveProjection.

Visual Basic
Property NewWindowProjectionType() As ProjectionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowProjectionType Property


DisplaySettings.NewWindowShowAmbientShadows Property

DisplaySettings.NewWindowShowAmbientShadows Property
Summary

Property that gets and sets whether to display ambient shadows (occlusions) for new windows.

Visual Basic
Property NewWindowShowAmbientShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowShowAmbientShadows Property


DisplaySettings.NewWindowShowGroundPlane Property

DisplaySettings.NewWindowShowGroundPlane Property
Summary

Property that gets and sets whether to display ground planes for new windows.

Visual Basic
Property NewWindowShowGroundPlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowShowGroundPlane Property


DisplaySettings.NewWindowShowGroundReflections Property

DisplaySettings.NewWindowShowGroundReflections Property
Summary

Property that gets and sets whether to display ground plane reflections for new windows.

Visual Basic
Property NewWindowShowGroundReflections() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowShowGroundReflections Property


DisplaySettings.NewWindowShowGroundShadows Property

DisplaySettings.NewWindowShowGroundShadows Property
Summary

Property that gets and sets whether to display ground shadows for new windows.

Visual Basic
Property NewWindowShowGroundShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowShowGroundShadows Property


DisplaySettings.NewWindowShowObjectShadows Property

DisplaySettings.NewWindowShowObjectShadows Property
Summary

Property that gets and sets whether to display object shadows for new windows.

Visual Basic
Property NewWindowShowObjectShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.NewWindowShowObjectShadows Property


DisplaySettings.Parent Property

DisplaySettings.Parent Property
Summary

Property that returns the parent Document object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.Parent Property


DisplaySettings.RayTracingQuality Property

DisplaySettings.RayTracingQuality Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the quality used when ray tracing is enabled.

Visual Basic
Property RayTracingQuality() As RayTracingQualityEnum
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.RayTracingQuality Property


DisplaySettings.SolidLinesForHiddenEdges Property

DisplaySettings.SolidLinesForHiddenEdges Property
Summary

Property that gets and sets whether the hidden model edges should be displayed as solid lines. This is the equivalent of the UI option "Display hidden edges as dashed".

Visual Basic
Property SolidLinesForHiddenEdges() As VARIANT_BOOL
Remarks

A value of True specifies that the hidden model edges should be displayed as solid lines. A value of False specifies that the hidden model edges should be displayed as dashed lines.

You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.SolidLinesForHiddenEdges Property


DisplaySettings.Type Property

DisplaySettings.Type Property Available in Inventor
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.Type Property


DisplaySettings.UseRayTracingForRealisticDisplay Property

DisplaySettings.UseRayTracingForRealisticDisplay Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to enable ray tracing in realistic visual styles for new windows.

Visual Basic
Property UseRayTracingForRealisticDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DisplaySettings Interface > DisplaySettings Properties > DisplaySettings.UseRayTracingForRealisticDisplay Property


DistanceAndAngleChamferDef Interface

DistanceAndAngleChamferDef Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DistanceAndAngleChamferDef object provides access to the information that defines the variables for a chamfer feature created using a distance and an angle.

Class Hierarchy
Inventor::ChamferDefinition
    Inventor::DistanceAndAngleChamferDef
Visual Basic
Public Interface DistanceAndAngleChamferDef
Inherits ChamferDefinition
You are here: Symbol Reference > Inventor Library > Objects > DistanceAndAngleChamferDef Interface


DistanceAndAngleChamferDef Properties

DistanceAndAngleChamferDef Properties
Summary

The properties of the DistanceAndAngleChamferDef class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter that controls the angle used for the chamfer feature.
Distance | Property that returns the parameter that controls the distance used for the chamfer feature.
Face | Property that returns the used for the chamfer feature.
You are here: Symbol Reference > Inventor Library > Objects > DistanceAndAngleChamferDef Interface > DistanceAndAngleChamferDef Properties


DistanceAndAngleChamferDef.Angle Property

DistanceAndAngleChamferDef.Angle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the angle used for the chamfer feature.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DistanceAndAngleChamferDef Interface > DistanceAndAngleChamferDef Properties > DistanceAndAngleChamferDef.Angle Property


DistanceAndAngleChamferDef.Distance Property

DistanceAndAngleChamferDef.Distance Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the distance used for the chamfer feature.

Visual Basic
Property Distance() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DistanceAndAngleChamferDef Interface > DistanceAndAngleChamferDef Properties > DistanceAndAngleChamferDef.Distance Property


DistanceAndAngleChamferDef.Face Property

DistanceAndAngleChamferDef.Face Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the used for the chamfer feature.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > DistanceAndAngleChamferDef Interface > DistanceAndAngleChamferDef Properties > DistanceAndAngleChamferDef.Face Property


DistanceChamferDef Interface

DistanceChamferDef Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DistanceChamferDef object provides access to the information that defines the variables for a chamfer feature created using a distance.

Class Hierarchy
Inventor::ChamferDefinition
    Inventor::DistanceChamferDef
Visual Basic
Public Interface DistanceChamferDef
Inherits ChamferDefinition
You are here: Symbol Reference > Inventor Library > Objects > DistanceChamferDef Interface


DistanceChamferDef Properties

DistanceChamferDef Properties
Summary

The properties of the DistanceChamferDef class are listed here.

Properties
Name | Description
CornerSetback | Property that returns whether a setback is to be applied to the chamfer feature.
Distance | Property that returns the parameter that controls the distance used for the chamfer feature.
You are here: Symbol Reference > Inventor Library > Objects > DistanceChamferDef Interface > DistanceChamferDef Properties


DistanceChamferDef.CornerSetback Property

DistanceChamferDef.CornerSetback Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns whether a setback is to be applied to the chamfer feature.

Visual Basic
Property CornerSetback() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DistanceChamferDef Interface > DistanceChamferDef Properties > DistanceChamferDef.CornerSetback Property


DistanceChamferDef.Distance Property

DistanceChamferDef.Distance Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the distance used for the chamfer feature.

Visual Basic
Property Distance() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DistanceChamferDef Interface > DistanceChamferDef Properties > DistanceChamferDef.Distance Property


DistanceExtent Interface

DistanceExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The DistanceExtent object defines an extent given by a specified distance value.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::DistanceExtent
Visual Basic
Public Interface DistanceExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > DistanceExtent Interface


DistanceExtent Properties

DistanceExtent Properties
Summary

The properties of the DistanceExtent class are listed here.

Properties
Name | Description
Direction | Property that gets and sets the distance direction of the feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
Distance | Property that returns the parameter controlling the distance extent of the feature.
You are here: Symbol Reference > Inventor Library > Objects > DistanceExtent Interface > DistanceExtent Properties


DistanceExtent.Direction Property

DistanceExtent.Direction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the distance direction of the feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > DistanceExtent Interface > DistanceExtent Properties > DistanceExtent.Direction Property


DistanceExtent.Distance Property

DistanceExtent.Distance Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter controlling the distance extent of the feature.

Visual Basic
Property Distance() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > DistanceExtent Interface > DistanceExtent Properties > DistanceExtent.Distance Property


DistanceHeightExtent Interface

DistanceHeightExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DistanceHeightExtent is used by the FlangeFeature object when the height extent type is defined as a distance extent.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::DistanceHeightExtent
Visual Basic
Public Interface DistanceHeightExtent
Inherits PartFeatureExtent
Remarks

This object is obtained from an existing FlangeFeature object whose height is defined by a distance extent. The various properties of this object can be used to query and edit an existing flange feature.

You are here: Symbol Reference > Inventor Library > Objects > DistanceHeightExtent Interface


DistanceHeightExtent Properties

DistanceHeightExtent Properties
Summary

The properties of the DistanceHeightExtent class are listed here.

Properties
Name | Description
Distance | Property that returns the parameter controlling the extent distance of the flange.
FlangeDirection | Property that gets and sets the direction of the flange.
HeightDatumType | Property that gets and set the how the height of the flange is defined when the height extent is a distance extent.
You are here: Symbol Reference > Inventor Library > Objects > DistanceHeightExtent Interface > DistanceHeightExtent Properties


DistanceHeightExtent.Distance Property

DistanceHeightExtent.Distance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the extent distance of the flange.

Visual Basic
Property Distance() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > DistanceHeightExtent Interface > DistanceHeightExtent Properties > DistanceHeightExtent.Distance Property


DistanceHeightExtent.FlangeDirection Property

DistanceHeightExtent.FlangeDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the direction of the flange.

Visual Basic
Property FlangeDirection() As PartFeatureExtentDirectionEnum*
Remarks

kPositiveExtentDirection indicates that the direction of the flange on the side of the selected edge. kNegativeExtentDirection indicates the flange is on the opposite side of the select edge. kSymmetricExtentDirection is not valid for a flange direction.

You are here: Symbol Reference > Inventor Library > Objects > DistanceHeightExtent Interface > DistanceHeightExtent Properties > DistanceHeightExtent.FlangeDirection Property


DistanceHeightExtent.HeightDatumType Property

DistanceHeightExtent.HeightDatumType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the how the height of the flange is defined when the height extent is a distance extent.

Visual Basic
Property HeightDatumType() As HeightDatumTypeEnum*
Remarks

The value of this property is only valid when the HeightExtentType is kDistanceExtent. There are five options to define the height. Three of these are measured along the flange and two are measured in an orthogonal direction. These are illustrated in the figures below, along with the corresponding option as shown in the Flange dialog. In all cases the flange distance is specified as 1.00, the angle is 135.0 and the position of the bend is outside of the base face extents.

kHeightDatumOuter

kHeightDatumInner

kHeightDatumTangent

kHeightDatumOuterOrtho

kHeightDatumInnerOrtho

You are here: Symbol Reference > Inventor Library > Objects > DistanceHeightExtent Interface > DistanceHeightExtent Properties > DistanceHeightExtent.HeightDatumType Property


DockableWindow Interface

DockableWindow Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

A DockableWindow object represents a window that can be docked on to the Inventor application window by the user.

Class Hierarchy
Inventor::DockableWindow
Visual Basic
Public Interface DockableWindow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DockableWindows.Add

DockableWindows.Item

See Also

Dockable window sample

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface


DockableWindow Methods

DockableWindow Methods
Summary

The methods of the DockableWindow class are listed here.

Methods
Methods
Name | Description
AddChild | Method that adds a dialog or a control to the dockable window. Currently, you can only add a single child to a dockable window. So this method returns a failure if the dockable window already has a child. It is the responsibility of the client to destroy the dialog/control as and when appropriate.
Clear | Method that empties the contents of the dockable window (i.e. removes any children of the window). This does not destroy the child dialog/controls; it is the responsibility of the client to destroy them.
Delete | Method that deletes the DockableWindow. This does not destroy the child dialog/controls; it is the responsibility of the client to destroy them.
Move | Method that repositions and resizes the window. If the window is docked, calling this method automatically undocks the window and honors the input values.
SetMinimumSize | Method that sets the minimum size that the user can resize the window to.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Methods


DockableWindow.AddChild Method

DockableWindow.AddChild Method Introduced in Inventor 2011
Summary

Method that adds a dialog or a control to the dockable window. Currently, you can only add a single child to a dockable window. So this method returns a failure if the dockable window already has a child. It is the responsibility of the client to destroy the dialog/control as and when appropriate.

Visual Basic
Sub AddChild(Identifier As VARIANT)
Parameters
Parameters | Description
Identifier | Input Variant that specifies the dialog or control. This can either be the HWND of a dialog/window, or the ProgID of a control or the GUID of the control as a string (including the braces "{ }"). The ProgID/GUID can be that of an ActiveX or a .NET user control.
Notes

When adding a dialog (by passing in an HWND as input), it must be created as a modeless dialog. Also, it is recommended that the dialog be created with the DockableWindow.HWND as the parent before calling this method. However, if created with any other parent, this method re-parents the child dialog to the dockable window.

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Methods > DockableWindow.AddChild Method


DockableWindow.Clear Method

DockableWindow.Clear Method
Summary

Method that empties the contents of the dockable window (i.e. removes any children of the window). This does not destroy the child dialog/controls; it is the responsibility of the client to destroy them.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Methods > DockableWindow.Clear Method


DockableWindow.Delete Method

DockableWindow.Delete Method
Summary

Method that deletes the DockableWindow. This does not destroy the child dialog/controls; it is the responsibility of the client to destroy them.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Methods > DockableWindow.Delete Method


DockableWindow.Move Method

DockableWindow.Move Method Introduced in Inventor 2011
Summary

Method that repositions and resizes the window. If the window is docked, calling this method automatically undocks the window and honors the input values.

Visual Basic
Sub Move(Top As long, Left As long, Height As long, Width As long)
Parameters
Parameters | Description
Top | Input Long that specifies the distance between the top of the screen and top of the window.
Left | Input Long that specifies the distance between the left edge of the screen and left edge of the window.
Height | Input Long that specifies the height of the window.
Width | Input Long that specifies the width of the window.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Methods > DockableWindow.Move Method


DockableWindow.SetMinimumSize Method

DockableWindow.SetMinimumSize Method Introduced in Inventor 2011
Summary

Method that sets the minimum size that the user can resize the window to.

Visual Basic
Sub SetMinimumSize(Height As long, Width As long)
Parameters
Parameters | Description
Height | Input Long that specifies the minimum height for the window.
Width | Input Long that specifies the minimum width for the window.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Methods > DockableWindow.SetMinimumSize Method


DockableWindow Properties

DockableWindow Properties
Summary

The properties of the DockableWindow class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Caption | Property that gets and sets the caption of the window.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. '{C9A6C580-3817-11D0-BE4E-080036E87B02}'.
Control | Property that returns the control associated with the pane. This property returns Nothing if the pane contains a dialog and not a control.
DisabledDockingStates | Property that gets and sets the bit-mask that specifies the docking positions to disallow.
DockingState | Property that gets and sets the current docking state of the window. Possible values are kDockBottom, kDockLeft, kDockRight, kDockTop, kDockLastKnown and kFloat.
Height | Property that gets and sets the current height of the window. Setting the height may fail in certain situations such as when the window is docked to the left or right and spans the entire height of the Inventor frame.
HWND | Property that returns the handle of the dockable window.
InternalName | Property that returns the unique internal name of the window.
IsCustomized | Property that returns whether size, position and docking states of this window have previously been customized and remembered by Inventor. If this property returns True, the size, position and docking states should not be initialized by the creating application so that the last known values are re-applied.
Left | Property that returns the distance between the left edge of the screen and left edge of the window.
Parent | Property that returns the parent UserInterfaceManager object.
ShowTitleBar | Property that gets and sets whether to display a title bar within the dockable window.
Title | Property that gets and sets the title of the window. The title is displayed to the user only when the window is floating (i.e. undocked).
Top | Property that returns the distance between the top of the screen and top of the window.
Type | Property returning kDockableWindowObject indicating this object's type.
VisibilityControl | Property that returns the button control automatically created by Inventor to control the visibility of the dockable window.
Visible | Property that gets and sets whether the window is currently visible.
Width | Property that gets and sets the current width of the window. Setting the width may fail in certain situations such as when the window is docked to the top or bottom and spans the entire width of the Inventor frame.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties


DockableWindow.Application Property

DockableWindow.Application Property Introduced in Inventor 2011
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Application Property


DockableWindow.Caption Property

DockableWindow.Caption Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the caption of the window.

Visual Basic
Property Caption() As String
Remarks

The caption is displayed to the user only when the window is floating (i.e. undocked). This value is initialized to the Title string when the dockable window is created, but can be set independent of the title thereafter.

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Caption Property


DockableWindow.ClientId Property

DockableWindow.ClientId Property Introduced in Inventor 2011
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. '{C9A6C580-3817-11D0-BE4E-080036E87B02}'.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.ClientId Property


DockableWindow.Control Property

DockableWindow.Control Property Introduced in Inventor 2011
Summary

Property that returns the control associated with the pane. This property returns Nothing if the pane contains a dialog and not a control.

Visual Basic
Property Control() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Control Property


DockableWindow.DisabledDockingStates Property

DockableWindow.DisabledDockingStates Property Introduced in Inventor 2011
Summary

Property that gets and sets the bit-mask that specifies the docking positions to disallow.

Visual Basic
Property DisabledDockingStates() As DockingStateEnum
Remarks

The following values and their combinations can be used: kDockBottom, kDockLeft, kDockRight and kDockTop. It is not possible to disallow undocking of a window, so kFloat is not a valid value. By default, all positions are allowed and hence this propery returns 0.

See Also

Dockable window sample

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.DisabledDockingStates Property


DockableWindow.DockingState Property

DockableWindow.DockingState Property Introduced in Inventor 2011
Summary

Property that gets and sets the current docking state of the window. Possible values are kDockBottom, kDockLeft, kDockRight, kDockTop, kDockLastKnown and kFloat.

Visual Basic
Property DockingState() As DockingStateEnum
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.DockingState Property


DockableWindow.Height Property

DockableWindow.Height Property Introduced in Inventor 2011
Summary

Property that gets and sets the current height of the window. Setting the height may fail in certain situations such as when the window is docked to the left or right and spans the entire height of the Inventor frame.

Visual Basic
Property Height() As long
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Height Property


DockableWindow.HWND Property

DockableWindow.HWND Property Introduced in Inventor 2011
Summary

Property that returns the handle of the dockable window.

Visual Basic
Property HWND() As long*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.HWND Property


DockableWindow.InternalName Property

DockableWindow.InternalName Property Introduced in Inventor 2011
Summary

Property that returns the unique internal name of the window.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.InternalName Property


DockableWindow.IsCustomized Property

DockableWindow.IsCustomized Property Introduced in Inventor 2011
Summary

Property that returns whether size, position and docking states of this window have previously been customized and remembered by Inventor. If this property returns True, the size, position and docking states should not be initialized by the creating application so that the last known values are re-applied.

Visual Basic
Property IsCustomized() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.IsCustomized Property


DockableWindow.Left Property

DockableWindow.Left Property Introduced in Inventor 2011
Summary

Property that returns the distance between the left edge of the screen and left edge of the window.

Visual Basic
Property Left() As long*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Left Property


DockableWindow.ShowTitleBar Property

DockableWindow.ShowTitleBar Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to display a title bar within the dockable window.

Visual Basic
Property ShowTitleBar() As VARIANT_BOOL
Remarks

The title bar contains the title (as specified in the Title property) and a help button. Clicking the help button invokes the DockableWindows.Events.OnHelp event. This property defaults to False when the dockable window is created.

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.ShowTitleBar Property


DockableWindow.Title Property

DockableWindow.Title Property Introduced in Inventor 2011
Summary

Property that gets and sets the title of the window. The title is displayed to the user only when the window is floating (i.e. undocked).

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Title Property


DockableWindow.Top Property

DockableWindow.Top Property Introduced in Inventor 2011
Summary

Property that returns the distance between the top of the screen and top of the window.

Visual Basic
Property Top() As long*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Top Property


DockableWindow.Type Property

DockableWindow.Type Property Introduced in Inventor 2011
Summary

Property returning kDockableWindowObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Type Property


DockableWindow.VisibilityControl Property

DockableWindow.VisibilityControl Property
Summary

Property that returns the button control automatically created by Inventor to control the visibility of the dockable window.

Visual Basic
Property VisibilityControl() As ControlDefinition**
Remarks

Inventor automatically adds this control to the "User Interface" dropdown in the View tab | Windows panel. The icons of this control can be changed and the control can be added elsewhere in the user interface by the creator of the window.

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.VisibilityControl Property


DockableWindow.Visible Property

DockableWindow.Visible Property Introduced in Inventor 2011
Summary

Property that gets and sets whether the window is currently visible.

Visual Basic
Property Visible() As VARIANT_BOOL
See Also

Dockable window sample

You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Visible Property


DockableWindow.Width Property

DockableWindow.Width Property Introduced in Inventor 2011
Summary

Property that gets and sets the current width of the window. Setting the width may fail in certain situations such as when the window is docked to the top or bottom and spans the entire width of the Inventor frame.

Visual Basic
Property Width() As long
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Width Property


DockableWindows Interface

DockableWindows Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The DockableWindows collection object provides access to all existing dockable windows and provides methods to create additional ones.

Class Hierarchy
Inventor::DockableWindows
Visual Basic
Public Interface DockableWindows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

UserInterfaceManager.DockableWindows

See Also

Dockable window sample

You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface


DockableWindows Methods

DockableWindows Methods
Summary

The methods of the DockableWindows class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DockableWindow. The newly created DockableWindow is returned. The window is created invisible and is undocked. The window remains invisible until explicitly made visible by the creator of the window.
Item | Property that returns the specified DockableWindow object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Methods


DockableWindows.Add Method

DockableWindows.Add Method
Summary

Method that creates a new DockableWindow. The newly created DockableWindow is returned. The window is created invisible and is undocked. The window remains invisible until explicitly made visible by the creator of the window.

Visual Basic
Sub Add(ClientId As String, InternalName As String, Title As String, Result As [out, retval] DockableWindow*)
Parameters
Parameters | Description
ClientId | Input String that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}". If supplied, this string is used at Inventor start up time to determine whether the AddIn that created this ribbon tab has since been uninstalled. If so, settings (such as window position, docking state, etc.) associated with the window are deleted. The string is also used to find all the windows to delete when the associated Add-in is unloaded. A 'dummy' string or a null string can be specified, but is not recommended.
InternalName | Input String that specifies a unique internal name for the window. This name is never displayed to the user and is only used (in combination with ClientId) to uniquely identify the window.
Remarks

A visibility toggle control for the window is automatically added by Inventor to the 'User Interface' dropdown in the View tab | Windows panel. The VisibilityControl property returns this control.

Example

Dockable window example.

This sample demonstrates creating a dockable window and adding a dialog into it. You need to create the (modeless) dialog and set the hwnd of the dialog in the code below.

Sub DockableWindow()

    Dim oUserInterfaceMgr As UserInterfaceManager
    Set oUserInterfaceMgr = ThisApplication.UserInterfaceManager

    ' Create a new dockable window
    Dim oWindow As DockableWindow
    Set oWindow = oUserInterfaceMgr.DockableWindows.Add("SampleClientId", "TestWindowInternalName", "Test Window")

    ' Get the hwnd of the dialog to be added as a child
    ' CHANGE THIS VALUE!
    Dim hwnd As Long
    hwnd = 4851096

    ' Add the dialog as a child to the dockable window
    Call oWindow.AddChild(hwnd)

    ' Don't allow docking to top and bottom
    oWindow.DisabledDockingStates = kDockTop + kDockBottom

    ' Make the window visible
    oWindow.Visible = True

End Sub
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Methods > DockableWindows.Add Method


DockableWindows.Item Method

DockableWindows.Item Method Introduced in Inventor 2011
Summary

Property that returns the specified DockableWindow object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DockableWindow*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the DockableWindow to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the InternalName of the window. If an out of range index or an InternalName of a non-existent DockableWindow is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Methods > DockableWindows.Item Method


DockableWindows Properties

DockableWindows Properties
Summary

The properties of the DockableWindows class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Events | Property that returns the the DockableWindowsEvents object that hosts events related to dockable windows.
Type | Property returning kDockableWindowsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Properties


DockableWindows.Application Property

DockableWindows.Application Property Introduced in Inventor 2011
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Properties > DockableWindows.Application Property


DockableWindows.Count Property

DockableWindows.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Properties > DockableWindows.Count Property


DockableWindows.Events Property

DockableWindows.Events Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the the DockableWindowsEvents object that hosts events related to dockable windows.

Visual Basic
Property Events() As DockableWindowsEvents**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Properties > DockableWindows.Events Property


DockableWindows.Type Property

DockableWindows.Type Property Introduced in Inventor 2011
Summary

Property returning kDockableWindowsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindows Interface > DockableWindows Properties > DockableWindows.Type Property


DockableWindowsEventsObject Interface

DockableWindowsEventsObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The DockableWindowsEvents object contains events related to dockable windows.

Class Hierarchy
Inventor::DockableWindowsEventsObject
Visual Basic
Public Interface DockableWindowsEventsObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsObject Interface


DockableWindowsEventsObject Properties

DockableWindowsEventsObject Properties
Summary

The properties of the DockableWindowsEventsObject class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Parent | Property that returns the parent DockableWindows object.
Type | Property returning kDockableWindowsEventsObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsObject Interface > DockableWindowsEventsObject Properties


DockableWindowsEventsObject.Application Property

DockableWindowsEventsObject.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsObject Interface > DockableWindowsEventsObject Properties > DockableWindowsEventsObject.Application Property


DockableWindowsEventsObject.Parent Property

DockableWindowsEventsObject.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent DockableWindows object.

Visual Basic
Property Parent() As DockableWindows**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsObject Interface > DockableWindowsEventsObject Properties > DockableWindowsEventsObject.Parent Property


DockableWindowsEventsObject.Type Property

DockableWindowsEventsObject.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kDockableWindowsEventsObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsObject Interface > DockableWindowsEventsObject Properties > DockableWindowsEventsObject.Type Property


DockableWindowsEventsSink Interface

DockableWindowsEventsSink Interface
Summary

This is class Inventor::DockableWindowsEventsSink.

Class Hierarchy
Inventor::DockableWindowsEventsSink
Visual Basic
Public Interface DockableWindowsEventsSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsSink Interface


DockableWindowsEventsSink Methods

DockableWindowsEventsSink Methods
Summary

The methods of the DockableWindowsEventsSink class are listed here.

Methods
Methods
Name | Description
OnHelp | Event that is fired whenever the user clicks the help button in a dockable window.
OnHide | Event that is fired whenever a dockable window is hidden (i.e. closed).
OnShow | Event that is fired whenever a dockable window is shown.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsSink Interface > DockableWindowsEventsSink Methods


DockableWindowsEventsSink.OnHelp Method

DockableWindowsEventsSink.OnHelp Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired whenever the user clicks the help button in a dockable window.

Visual Basic
Sub OnHelp(DockableWindow As DockableWindow, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DockableWindow | Input DockableWindow object that specifies the window on which the help button was pressed.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. Setting the value of the HandlingCode argument specifies how Inventor is to handle displaying help. If you set this argument to kEventNotHandled or kEventCanceled, Inventor will display some general help. Setting the value of this argument to kEventHandled will allow you to handle displaying help to the end-user and Inventor will not display anything. To display help to the end-user you can choose to use whatever help system you want. Inventor's API does not provide support for the actual display of the clients help.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsSink Interface > DockableWindowsEventsSink Methods > DockableWindowsEventsSink.OnHelp Method


DockableWindowsEventsSink.OnHide Method

DockableWindowsEventsSink.OnHide Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired whenever a dockable window is hidden (i.e. closed).

Visual Basic
Sub OnHide(DockableWindow As DockableWindow, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DockableWindow | Input DockableWindow object that specifies the window being hidden.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the window is hidden.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsSink Interface > DockableWindowsEventsSink Methods > DockableWindowsEventsSink.OnHide Method


DockableWindowsEventsSink.OnShow Method

DockableWindowsEventsSink.OnShow Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired whenever a dockable window is shown.

Visual Basic
Sub OnShow(DockableWindow As DockableWindow, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DockableWindow | Input DockableWindow object that specifies the window being shown.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the window is shown.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > DockableWindowsEventsSink Interface > DockableWindowsEventsSink Methods > DockableWindowsEventsSink.OnShow Method


Document Interface

Document Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Document object represents an in-memory Inventor document.

Class Hierarchy
Inventor::Document
    Inventor::AssemblyDocument
    Inventor::DrawingDocument
    Inventor::PartDocument
    Inventor::PresentationDocument
Visual Basic
Public Interface Document
Inherits IDispatch
Remarks

Do not close any document inside a transaction, even the active one. The exception to this rule is that it is legal to close a document in a transaction when the document was opened in that exact same transaction.

Notes

Members through which this object may be accessed include:

Application.ActiveDocument

Application.ActiveEditDocument

BrowserNodeDefinition.Parent

BrowserPaneObject.Parent

ClientNodeResource.Parent

Document.InventorDocument

Documents.Add

Documents.ItemByName

Documents.Open

Documents.OpenWithOptions

DocumentsEnumerator.Item

EnvironmentManager.Parent

FileMetadata.Document

InteractionEventsObject.TargetDocument

MemberManager.GetNewInstance

ModelingSettings.Parent

ObjectVisibility.Parent

Sketch3DSettings.Parent

SketchSettings.Parent

Transaction.Document

View.Document

View.Parent

Document.ActivatedObject

Application.ActiveEditObject

ClientView.Document

DocumentDescriptor.ReferencedDocument

See Also

Translate - Export to SAT sample

Client Graphics - Draw Range Box sample

Remove client feature elements sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface


Document Methods

Document Methods
Summary

The methods of the Document class are listed here.

Methods
Methods
Name | Description
Activate | Makes this document the active one (receives user-focus).
Close | Closes this document.
CreateHighlightSet | Method that creates a new highlight set.
FindWhereUsed | Method that obtains the set of documents that reference the given file within this document.
GetLocationFoundIn | Obtains the name of the location this file was found in.
GetMissingAddInBehavior | Method that gets the commands disabled when a particular AddIn is absent.
GetPrivateStorage | Obtains a private sub-storage within this document with the given name. Can create one, if one does not exist.
GetPrivateStream | Obtains a private stream within this document with the given name. Can create one, if one does not exist.
HasPrivateStorage | Obtains a Boolean flag indicating if the specified sub-storage exists within this document.
HasPrivateStream | Obtains a Boolean flag indicating if the specified stream exists within this document.
PutInternalNameAndRevisionId |
Rebuild | Performs compute operations on all of the entities within this document's scope as if all of the driving entities had been 'dirtied.'
Rebuild2 | Method that performs compute operations on all of the entities within this Document's scope as if all of the driving entities had been 'dirtied'.
ReleaseReference | Method that releases the reference that gets added if a document is opened invisibly through the API. Releasing the reference on a hidden document makes it a candidate for closure the next time Inventor closes all unreferenced documents.
RevertReservedForWriteByMe | Method that reverts the file checked out by the caller.
Save | Saves this document to disk.
Save2 | Method that saves the document and the specified dependent documents.
SaveAs | Saves this document into a file of the specified name. None of the dependent documents get saved.
SetMissingAddInBehavior | Method that sets the commands to be disabled when a particular AddIn is absent.
SetThumbnailSaveOption | Method that sets the thumbnail (preview picture) save option.
Update | Performs compute operations on all of the entities within this Document's scope that may be out of date with respect to their driving entities.
Update2 | Method that performs compute operations on all of the entities within this Document's scope that may be out of date with respect to their driving entities.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods


Document.Activate Method

Document.Activate Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Makes this document the active one (receives user-focus).

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Activate Method


Document.Close Method

Document.Close Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Closes this document.

Visual Basic
Sub Close(ByRef SkipSave As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
SkipSave | Optional input Boolean that specifies whether to skip the save. If SkipSave is set to True, it indicates that the changes to the document should not be saved and that the document should be closed silently. If SkipSave is set to False, it indicates that the normal save process should be followed (including prompting a dialog to the user). In addition, if Application.SilentOperation is set to True, the default choice on the dialog should be accepted. The Close method will fail if the combination of SkipSave = False & SilentOperation = True is used for a previously unsaved document.
See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Close Method


Document.CreateHighlightSet Method

Document.CreateHighlightSet Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new highlight set.

Visual Basic
Sub CreateHighlightSet(Result As [out, retval] HighlightSet*)
Remarks

The returned object is transient in nature and is destroyed when all references to it are lost.

See Also

Highlight Feature Faces sample

Example

"Example of creating a HighlightSet"

Sub Main()
  ' Check to make sure the active document is a part.
  If ThisApplication.ActiveDocumentType  kPartDocumentObject Then
     MsgBox "A part document must be open."
     End
  End If

  ' Set a reference to the active part document.
  Dim oDoc As PartDocument
  Set oDoc = ThisApplication.ActiveDocument

  ' Arbitrarily get two faces.  (Assumes a model exists that has
  ' at least 3 faces.
  Dim oFace1 As Face
  Dim oFace2 As Face
  Set oFace1 = oDoc.ComponentDefinitions(1).SurfaceBodies(1).Faces(1)
  Set oFace2 = oDoc.ComponentDefinitions(1).SurfaceBodies(1).Faces(3)

  ' Create a highlight set.
  Dim oSet1 As HighlightSet
  Set oSet1 = oDoc.CreateHighlightSet

  ' Add the first face to the highlight set.
   Call oSet1.AddItem(oFace1)

  ' Create another highlight set.
  Dim oSet2 As HighlightSet
  Set oSet2 = oDoc.CreateHighlightSet

  ' Change the color of the highlight set to green.
  oSet2.Color = ThisApplication.TransientObjects.CreateColor(0, 255, 0)

  ' Add the second face to the highlight set.
  Call oSet2.AddItem(oFace2)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.CreateHighlightSet Method


Document.FindWhereUsed Method

Document.FindWhereUsed Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that obtains the set of documents that reference the given file within this document.

Visual Basic
Sub FindWhereUsed(FullFileName As String, Result As [out, retval] DocumentsEnumerator*)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of the file to search for references to.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.FindWhereUsed Method


Document.GetLocationFoundIn Method

Document.GetLocationFoundIn Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains the name of the location this file was found in.

Visual Basic
Sub GetLocationFoundIn(ByRef LocationName As String, ByRef LocationType As LocationTypeEnum)
Parameters
Parameters | Description
LocationName | Output String that specifies the name of the location.
LocationType | Output String that specifies the type of the location.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.GetLocationFoundIn Method


Document.GetMissingAddInBehavior Method

Document.GetMissingAddInBehavior Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that gets the commands disabled when a particular AddIn is absent.

Visual Basic
Sub GetMissingAddInBehavior(ByRef ClientId As String, ByRef DisabledCommandTypesEnum As CommandTypesEnum, ByRef DisabledCommands As ObjectCollection*)
Parameters
Parameters | Description
ClientId | Specifies the ClassId of the AddIn. When the AddIn corresponding to this ClientId is absent (unloaded or uninstalled), the commands specified are disabled.
DisabledCommandTypesEnum | CommandTypesEnum that specifies the classifications of the commands disabled.
DisabledCommands | ObjectCollection that specifies the commands disabled.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.GetMissingAddInBehavior Method


Document.GetPrivateStorage Method

Document.GetPrivateStorage Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains a private sub-storage within this document with the given name. Can create one, if one does not exist.

Visual Basic
Sub GetPrivateStorage(StorageName As String, CreateIfNecessary As VARIANT_BOOL, Result As [out, retval] IUnknown*)
Parameters
Parameters | Description
StorageName | Input String that specifies the name of the private sub-storage.
CreateIfNecessary | Input Boolean that specifies whether to create a private sub-storage if one does not already exist.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.GetPrivateStorage Method


Document.GetPrivateStream Method

Document.GetPrivateStream Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains a private stream within this document with the given name. Can create one, if one does not exist.

Visual Basic
Sub GetPrivateStream(StreamName As String, CreateIfNecessary As VARIANT_BOOL, Result As [out, retval] IUnknown*)
Parameters
Parameters | Description
StreamName | Input String value that specifies the name of the stream to get (31 chars max).
CreateIfNecessary | Input Boolean that specifies whether to create a private stream if one does not already exist.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.GetPrivateStream Method


Document.HasPrivateStorage Method

Document.HasPrivateStorage Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains a Boolean flag indicating if the specified sub-storage exists within this document.

Visual Basic
Sub HasPrivateStorage(StorageName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
StorageName | Input String that specifies the name of the sub-storage.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.HasPrivateStorage Method


Document.HasPrivateStream Method

Document.HasPrivateStream Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains a Boolean flag indicating if the specified stream exists within this document.

Visual Basic
Sub HasPrivateStream(StreamName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
StreamName | Input String value that specifies the name of the stream.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.HasPrivateStream Method


Document.PutInternalNameAndRevisionId Method

Document.PutInternalNameAndRevisionId Method Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Sub PutInternalNameAndRevisionId(InternalNameToken As String, RevisionIdToken As String, ByRef InternalName As String, ByRef RevisionId As String)
Notes

For information on this item, please refer to PartDocument::PutInternalNameAndRevisionId, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.PutInternalNameAndRevisionId Method


Document.Rebuild Method

Document.Rebuild Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Performs compute operations on all of the entities within this document's scope as if all of the driving entities had been 'dirtied.'

Visual Basic
Sub Rebuild()
Remarks

Please Note: The rebuild and Rebuild2 methods are not applicable on DrawingDocument and PresentationDocument objects, which do not support rebuilding.

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Rebuild Method


Document.Rebuild2 Method

Document.Rebuild2 Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that performs compute operations on all of the entities within this Document's scope as if all of the driving entities had been 'dirtied'.

Visual Basic
Sub Rebuild2(ByRef AcceptErrorsAndContinue As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
IgnoreErrors | If the IgnoreErrors argument is set to True, errors are skipped and the rebuild process continues. If IgnoreErrors is set to False, the method returns as soon as the first error is encountered.
Remarks

The method returns False if any errors are encountered during the rebuild.

Please Note: The rebuild and Rebuild2 methods are not applicable on DrawingDocument and PresentationDocument objects, which do not support rebuilding.

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Rebuild2 Method


Document.ReleaseReference Method

Document.ReleaseReference Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that releases the reference that gets added if a document is opened invisibly through the API. Releasing the reference on a hidden document makes it a candidate for closure the next time Inventor closes all unreferenced documents.

Visual Basic
Sub ReleaseReference()
Remarks

This is not a COM reference release. Note that this method is only applicable for documents opened invisibly through the API. This is useful in situations where the client has opened a document invisibly but would prefer the close to be delayed (until the time that Inventor collects up all unreferenced documents and closes them). Closing a document clears the undo stack, and this is typically an undesired side-effect. If the API reference is not released, Inventor will not close this document and it would be up to the client to call the Close method on it.

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.ReleaseReference Method


Document.RevertReservedForWriteByMe Method

Document.RevertReservedForWriteByMe Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that reverts the file checked out by the caller.

Visual Basic
Sub RevertReservedForWriteByMe()
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.RevertReservedForWriteByMe Method


Document.Save Method

Document.Save Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Saves this document to disk.

Visual Basic
Sub Save()
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Save Method


Document.Save2 Method

Document.Save2 Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that saves the document and the specified dependent documents.

Visual Basic
Sub Save2(ByRef SaveDependents As [defaultvalue(-1)] VARIANT_BOOL, ByRef DocumentsToSave As [optional] VARIANT)
Parameters
Parameters | Description
SaveDependents | Optional input Boolean that specifies whether or not to save dependent documents that have been dirtied. Defaults to True indicating that the dependents will be saved. If the DependentsToSave argument is not specified, all dirty dependents are saved. If the argument is specified as False, only this document will be saved. The argument is ignored if the document doesn't have any dependents needing save.
DocumentsToSave | Optional input ObjectCollection that contains the Document objects to save. Use the Document.AllReferencedDocuments property to iterate over all dependent documents and find the ones that need to be saved (i.e. Dirty property returns True). If the SaveDependents argument is True and this argument is not specified, all dirty documents are saved. The argument is ignored if the document doesn't have any dependents needing save.
Remarks

If the document has never been saved, calling this method prompts the user for a file name just like the Save method. Calling Document.Save2 without specifying any arguments results in the dirty dependents getting saved. The "Save Dependents" dialog is not displayed (the Save method does display the dialog).

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Save2 Method


Document.SaveAs Method

Document.SaveAs Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Saves this document into a file of the specified name. None of the dependent documents get saved.

Visual Basic
Sub SaveAs(FileName As String, SaveCopyAs As VARIANT_BOOL)
Parameters
Parameters | Description
FileName | Input String that specifies the name of the file to save the document into.
SaveCopyAs | Input Boolean that indicates whether the file to be saved is new or is a copy of a previously existing file.
See Also

Derived Parts and Assemblies sample

Translate - Export to SAT sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.SaveAs Method


Document.SetMissingAddInBehavior Method

Document.SetMissingAddInBehavior Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets the commands to be disabled when a particular AddIn is absent.

Visual Basic
Sub SetMissingAddInBehavior(ClientId As String, DisabledCommandTypesEnum As CommandTypesEnum, ByRef DisabledCommands As [optional] VARIANT)
Parameters
Parameters | Description
ClientId | Specifies the ClassId of the AddIn. When the AddIn corresponding to this ClientId is absent (unloaded or uninstalled), the commands specified are disabled.
DisabledCommandTypesEnum | CommandTypesEnum that specifies the classifications of the commands to be disabled.
DisabledCommands | Optional input ObjectCollection that specifies the commands to be disabled. The ObjectCollection must contain only ControlDefinition objects.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.SetMissingAddInBehavior Method


Document.SetThumbnailSaveOption Method

Document.SetThumbnailSaveOption Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the thumbnail (preview picture) save option.

Visual Basic
Sub SetThumbnailSaveOption(SaveOption As ThumbnailSaveOptionEnum, ByRef ImageFullFileName As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
SaveOption | ThumbnailSaveOptionEnum indicating what gets saved as a thumbnail, if anything. Options include kNoThumbnail, kActiveComponentIsoViewOnSave, kActiveWindowOnSave, kActiveWindow, and kImportFromFile.
ImageFullFileName | Indicates what image file to use if SaveOption is set to kImportFromFile.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.SetThumbnailSaveOption Method


Document.Update Method

Document.Update Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Performs compute operations on all of the entities within this Document's scope that may be out of date with respect to their driving entities.

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Update Method


Document.Update2 Method

Document.Update2 Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that performs compute operations on all of the entities within this Document's scope that may be out of date with respect to their driving entities.

Visual Basic
Sub Update2(ByRef AcceptErrorsAndContinue As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
IgnoreErrors | If the IgnoreErrors argument is set to True, errors are skipped and the update process continues. If IgnoreErrors is set to False, the method returns as soon as the first error is encountered.
Remarks

The method should return False if any error is encountered during the update process (regardless of the IgnoreErrors argument). The IgnoreErrors argument just specifies whether to stop and return as soon as the first error is encountered or to continue on and finish the update by accepting the errors.

A failed re-compute must be handled in a similar manner as through the UI, because typically such failures require some intuitive interpretation. This means examining the model. In API terms, this involves iterating through the parts and features, checking their HealthStatus values. A useful technique is to use SetEndOfPart to help confirm whether an error disappears when part of the model is excluded.

Notes

For information on this item, please refer to AssemblyDocument::Update2, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Methods > Document.Update2 Method


Document Properties

Document Properties
Summary

The properties of the Document class are listed here.

Properties
Name | Description
ActivatedObject | Gets the object that has been in-place activated for edit within the context of this document.
AllReferencedDocuments | Property that returns all the document references of this Document along with all of the recursively nested references.
AttributeManager | Returns the AttributeManager object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BrowserPanes | Property that returns the BrowserPanes collection object.
Compacted | Gets the Boolean that states whether this file has been processed for compaction since the last save.
DatabaseRevisionId | Gets the GUID that represents the last saved revision of database contained in this document. This revision id tracks modifications to the database (such as reference changes, geometry changes, etc.) but does not track file property changes.
DefaultCommand | Gets the default command for this document.
Dirty | Property that indicates a Boolean flag indicating if the document has been written into since it was opened.
DisabledCommandTypes | Property that indicates a bit mask indicating the disabled command types.
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
DisplayNameOverridden | Property that gets and sets whether the display name of the document has been overridden.
DocumentEvents | This object supports a set of events that are specific to the document.
DocumentInterests | Property that returns the DocumentInterests collection object.
DocumentSubType | Property that returns the subtype of the document.
DocumentType | Gets the constant that indicates the type of this document.
File | Property that returns the file (storage) on disk that contains this document.
FileSaveCounter | Gets the number that indicates the number of times the file has been saved.
FullDocumentName | Property that returns the fully qualified name of the document. The string is the full file name concatenated with the document name and is a unique identifier for the document. The document name is returned by the Name property on the Document object.
FullFileName | Gets/sets the fully qualified file-name of this document.
GraphicsDataSetsCollection | Property that returns the object for the document.
InternalName | Gets the Internal Name (a GUID) for this document.
IsModifiable | Property that returns whether this document can be currently modified. One of the reasons a document may be non-modifiable is if any other document belonging to the file containing this document is currently being edited.
NeedsMigrating | Property that returns whether the document needs to be migrated to the current release.
Open | Property that returns whether this document is currently open. If False, the document has only been initialized and calling methods or properties on the document could cause it to open.
Parent | Property that returns the parent object from whom this object can logically be reached.
PrintManager | Property that returns the PrintManager, or when called from a DrawingDocument it returns a DrawingPrintManager object.
PropertySets | Gets the Property Sets object that controls the file's published-format properties.
RecentChanges | Gets a bit-encoded value where the bits indicate the kind of changes made to the document since it became dirty.
ReferencedDocumentDescriptors | Property that returns an enumeration of descriptors that represent the native document references held by this document.
ReferencedDocuments | Property that returns all the documents directly referenced by this document.
ReferencedOLEFileDescriptors | Property that returns the collection of linked and embedded files in the document.
ReferenceKeyManager | Gets this document's ReferenceKeyManager.
ReferencingDocuments | Property that returns all the documents in memory that reference this document. A referencing document may or may not be fully open (i.e. may just be initialized).
RenderStyles | Property that returns the RenderStyles collection object.
RequiresUpdate | Gets the Boolean indicating if any of the entities within this document's scope is out of date with respect to their driving entities.
ReservedForWrite | Gets the Boolean flag indicating whether this file has been reserved for write by someone.
ReservedForWriteByMe | Gets/sets the Boolean flag indicating whether this file has been reserved for write by the caller.
ReservedForWriteLogin | Gets the login of the person who currently holds the reservation to write.
ReservedForWriteName | Gets the name of the person who currently holds the reservation to write.
ReservedForWriteTime | Gets the time at which the reservation was made.
ReservedForWriteVersion | Gets the version within this file that has been reserved for write.
RevisionId | Gets the GUID that represents the last saved revision of this file. Works as a stamp of the contents of this file.
SelectionPriority | Property that gets and sets the current selection priority for the document.
SelectSet | Property that returns the SelectSet object.
SoftwareVersionCreated | Gets the object that encapsulates the version of the software with which this document was first created.
SoftwareVersionSaved | Gets the object that encapsulates the version of the software with which this document was last saved.
SubType | Gets/sets the sub-Type (a published GUID--see DocCLSIDs.h) of this document. Setting a new sub-Type will invoke a validation sequence and may fail if the operation is invalid.
Thumbnail | Property that returns a bitmap picture of the document.
ThumbnailSaveOption | Property that returns the current thumbnail (preview picture) save option.
Type | Property returning an enum indicating this object's type.
UnitsOfMeasure | Property that returns the UnitsOfMeasure object.
VBAProject | Property that returns the Autodesk Inventor VBA project for this document.
Views | Gets all the open views of this document in a collection.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties


Document.ActivatedObject Property

Document.ActivatedObject Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object that has been in-place activated for edit within the context of this document.

Visual Basic
Property ActivatedObject() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ActivatedObject Property


Document.AllReferencedDocuments Property

Document.AllReferencedDocuments Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the document references of this Document along with all of the recursively nested references.

Visual Basic
Property AllReferencedDocuments() As DocumentsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.AllReferencedDocuments Property


Document.AttributeManager Property

Document.AttributeManager Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the AttributeManager object.

Visual Basic
Property AttributeManager() As AttributeManager**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.AttributeManager Property


Document.AttributeSets Property

Document.AttributeSets Property
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.AttributeSets Property


Document.BrowserPanes Property

Document.BrowserPanes Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the BrowserPanes collection object.

Visual Basic
Property BrowserPanes() As BrowserPanes**
See Also

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.BrowserPanes Property


Document.Compacted Property

Document.Compacted Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the Boolean that states whether this file has been processed for compaction since the last save.

Visual Basic
Property Compacted() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Compacted Property


Document.DatabaseRevisionId Property

Document.DatabaseRevisionId Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the GUID that represents the last saved revision of database contained in this document. This revision id tracks modifications to the database (such as reference changes, geometry changes, etc.) but does not track file property changes.

Visual Basic
Property DatabaseRevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DatabaseRevisionId Property


Document.DefaultCommand Property

Document.DefaultCommand Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the default command for this document.

Visual Basic
Property DefaultCommand() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DefaultCommand Property


Document.Dirty Property

Document.Dirty Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates a Boolean flag indicating if the document has been written into since it was opened.

Visual Basic
Property Dirty() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Dirty Property


Document.DisabledCommandTypes Property

Document.DisabledCommandTypes Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates a bit mask indicating the disabled command types.

Visual Basic
Property DisabledCommandTypes() As CommandTypesEnum
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DisabledCommandTypes Property


Document.DisplayName Property

Document.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DisplayName Property


Document.DisplayNameOverridden Property

Document.DisplayNameOverridden Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the display name of the document has been overridden.

Visual Basic
Property DisplayNameOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DisplayNameOverridden Property


Document.DocumentEvents Property

Document.DocumentEvents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

This object supports a set of events that are specific to the document.

Visual Basic
Property DocumentEvents() As DocumentEvents**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DocumentEvents Property


Document.DocumentInterests Property

Document.DocumentInterests Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the DocumentInterests collection object.

Visual Basic
Property DocumentInterests() As DocumentInterests**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DocumentInterests Property


Document.DocumentSubType Property

Document.DocumentSubType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the subtype of the document.

Visual Basic
Property DocumentSubType() As DocumentSubType**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DocumentSubType Property


Document.DocumentType Property

Document.DocumentType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the constant that indicates the type of this document.

Visual Basic
Property DocumentType() As DocumentTypeEnum*
See Also

Translate - Export to SAT sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.DocumentType Property


Document.File Property

Document.File Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the file (storage) on disk that contains this document.

Visual Basic
Property File() As File**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.File Property


Document.FileSaveCounter Property

Document.FileSaveCounter Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the number that indicates the number of times the file has been saved.

Visual Basic
Property FileSaveCounter() As long*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.FileSaveCounter Property


Document.FullDocumentName Property

Document.FullDocumentName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the fully qualified name of the document. The string is the full file name concatenated with the document name and is a unique identifier for the document. The document name is returned by the Name property on the Document object.

Visual Basic
Property FullDocumentName() As BSTR*
See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.FullDocumentName Property


Document.FullFileName Property

Document.FullFileName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the fully qualified file-name of this document.

Visual Basic
Property FullFileName() As String
See Also

SurfaceBody Copy sample

Translate - Export to SAT sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.FullFileName Property


Document.GraphicsDataSetsCollection Property

Document.GraphicsDataSetsCollection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object for the document.

Visual Basic
Property GraphicsDataSetsCollection() As GraphicsDataSetsCollection**
See Also

Client graphics - image in point graphics sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Line sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.GraphicsDataSetsCollection Property


Document.InternalName Property

Document.InternalName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Internal Name (a GUID) for this document.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.InternalName Property


Document.IsModifiable Property

Document.IsModifiable Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns whether this document can be currently modified. One of the reasons a document may be non-modifiable is if any other document belonging to the file containing this document is currently being edited.

Visual Basic
Property IsModifiable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.IsModifiable Property


Document.NeedsMigrating Property

Document.NeedsMigrating Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the document needs to be migrated to the current release.

Visual Basic
Property NeedsMigrating() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.NeedsMigrating Property


Document.Open Property

Document.Open Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether this document is currently open. If False, the document has only been initialized and calling methods or properties on the document could cause it to open.

Visual Basic
Property Open() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Open Property


Document.Parent Property

Document.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Parent Property


Document.PrintManager Property

Document.PrintManager Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the PrintManager, or when called from a DrawingDocument it returns a DrawingPrintManager object.

Visual Basic
Property PrintManager() As PrintManager**
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.PrintManager Property


Document.PropertySets Property

Document.PropertySets Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Property Sets object that controls the file's published-format properties.

Visual Basic
Property PropertySets() As PropertySets**
See Also

Change the thumbnail of a document sample

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.PropertySets Property


Document.RecentChanges Property

Document.RecentChanges Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets a bit-encoded value where the bits indicate the kind of changes made to the document since it became dirty.

Visual Basic
Property RecentChanges() As CommandTypesEnum*
Remarks

The following enums can be used to test for these conditions.

  • kShapeEditCmdType - Commands that can affect the geometry of the model.

  • kQueryOnlyCmdType - Commands that purely query data. These do not 'dirty'

the document.

  • kNonShapeEditCmdType - Commands that edit data (other than File

Properties) that is not directly related to the geometry of the model (e.g. color, style).

  • kFilePropertyEditCmdType - Commands that edit File Properties (a.k.a

Document Properties).

  • kReferencesChangeCmdType - Commands that cause this document to change

which files it references.

  • kUpdateWithReferencesCmdType - Commands that cause this document to

recalculate its contents with respect to changes that may have occurred in files it is referencing.

  • kSchemaChangeCmd - Set if the document undergoes migration upon opening.
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.RecentChanges Property


Document.ReferencedDocumentDescriptors Property

Document.ReferencedDocumentDescriptors Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enumeration of descriptors that represent the native document references held by this document.

Visual Basic
Property ReferencedDocumentDescriptors() As DocumentDescriptorsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReferencedDocumentDescriptors Property


Document.ReferencedDocuments Property

Document.ReferencedDocuments Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the documents directly referenced by this document.

Visual Basic
Property ReferencedDocuments() As DocumentsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReferencedDocuments Property


Document.ReferencedOLEFileDescriptors Property

Document.ReferencedOLEFileDescriptors Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of linked and embedded files in the document.

Visual Basic
Property ReferencedOLEFileDescriptors() As ReferencedOLEFileDescriptors**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReferencedOLEFileDescriptors Property


Document.ReferenceKeyManager Property

Document.ReferenceKeyManager Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets this document's ReferenceKeyManager.

Visual Basic
Property ReferenceKeyManager() As ReferenceKeyManager**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReferenceKeyManager Property


Document.ReferencingDocuments Property

Document.ReferencingDocuments Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the documents in memory that reference this document. A referencing document may or may not be fully open (i.e. may just be initialized).

Visual Basic
Property ReferencingDocuments() As DocumentsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReferencingDocuments Property


Document.RenderStyles Property

Document.RenderStyles Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the RenderStyles collection object.

Visual Basic
Property RenderStyles() As RenderStyles**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.RenderStyles Property


Document.RequiresUpdate Property

Document.RequiresUpdate Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Boolean indicating if any of the entities within this document's scope is out of date with respect to their driving entities.

Visual Basic
Property RequiresUpdate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.RequiresUpdate Property


Document.ReservedForWrite Property

Document.ReservedForWrite Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Boolean flag indicating whether this file has been reserved for write by someone.

Visual Basic
Property ReservedForWrite() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReservedForWrite Property


Document.ReservedForWriteByMe Property

Document.ReservedForWriteByMe Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the Boolean flag indicating whether this file has been reserved for write by the caller.

Visual Basic
Property ReservedForWriteByMe() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReservedForWriteByMe Property


Document.ReservedForWriteLogin Property

Document.ReservedForWriteLogin Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the login of the person who currently holds the reservation to write.

Visual Basic
Property ReservedForWriteLogin() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReservedForWriteLogin Property


Document.ReservedForWriteName Property

Document.ReservedForWriteName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the name of the person who currently holds the reservation to write.

Visual Basic
Property ReservedForWriteName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReservedForWriteName Property


Document.ReservedForWriteTime Property

Document.ReservedForWriteTime Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the time at which the reservation was made.

Visual Basic
Property ReservedForWriteTime() As DATE*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReservedForWriteTime Property


Document.ReservedForWriteVersion Property

Document.ReservedForWriteVersion Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the version within this file that has been reserved for write.

Visual Basic
Property ReservedForWriteVersion() As long*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ReservedForWriteVersion Property


Document.RevisionId Property

Document.RevisionId Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets the GUID that represents the last saved revision of this file. Works as a stamp of the contents of this file.

Visual Basic
Property RevisionId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.RevisionId Property


Document.SelectionPriority Property

Document.SelectionPriority Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the current selection priority for the document.

Visual Basic
Property SelectionPriority() As SelectionPriorityEnum
Remarks

This setting is only for the current state of the document. For instance, if this property is set when an assembly is in-place activated, returning from in-place activation changes the priority back to the value it was set to before the in-place activation.

Environment | Valid options
Assembly/Weldment | kComponentSelectionPriority kPartSelectionPriority kFeatureSelectionPriority kEdgeAndFaceSelectionPriority kSketchSelectionPriority
Drawing | kEdgeSelectionPriority kFeatureSelectionPriority kPartSelectionPriority
Part/Sheet Metal | kFeatureSelectionPriority kEdgeAndFaceSelectionPriority kSketchSelectionPriority
Solid edit | kEdgeAndFaceSelectionPriority
Construction | kFeatureSelectionPriority kEdgeAndFaceSelectionPriority kGroupSelectionPriority kWireSelectionPriority
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.SelectionPriority Property


Document.SelectSet Property

Document.SelectSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the SelectSet object.

Visual Basic
Property SelectSet() As SelectSet**
See Also

OnDrag Event - dragging a WorkPoint sample

Highlight Feature Faces sample

Find component referenced by balloon sample

Mate constraint with limits sample

Assembly Mate Constraint of Work Planes sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.SelectSet Property


Document.SoftwareVersionCreated Property

Document.SoftwareVersionCreated Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object that encapsulates the version of the software with which this document was first created.

Visual Basic
Property SoftwareVersionCreated() As SoftwareVersion**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.SoftwareVersionCreated Property


Document.SoftwareVersionSaved Property

Document.SoftwareVersionSaved Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object that encapsulates the version of the software with which this document was last saved.

Visual Basic
Property SoftwareVersionSaved() As SoftwareVersion**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.SoftwareVersionSaved Property


Document.SubType Property

Document.SubType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/sets the sub-Type (a published GUID--see DocCLSIDs.h) of this document. Setting a new sub-Type will invoke a validation sequence and may fail if the operation is invalid.

Visual Basic
Property SubType() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.SubType Property


Document.Thumbnail Property

Document.Thumbnail Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a bitmap picture of the document.

Visual Basic
Property Thumbnail() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Thumbnail Property


Document.ThumbnailSaveOption Property

Document.ThumbnailSaveOption Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the current thumbnail (preview picture) save option.

Visual Basic
Property ThumbnailSaveOption() As ThumbnailSaveOptionEnum*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.ThumbnailSaveOption Property


Document.Type Property

Document.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Type Property


Document.UnitsOfMeasure Property

Document.UnitsOfMeasure Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the UnitsOfMeasure object.

Visual Basic
Property UnitsOfMeasure() As UnitsOfMeasure**
See Also

Units of Measure Conversion sample

Get and Set Units of Measure sample

Using measure events sample

You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.UnitsOfMeasure Property


Document.VBAProject Property

Document.VBAProject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Autodesk Inventor VBA project for this document.

Visual Basic
Property VBAProject() As InventorVBAProject**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.VBAProject Property


Document.Views Property

Document.Views Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets all the open views of this document in a collection.

Visual Basic
Property Views() As Views**
You are here: Symbol Reference > Inventor Library > Objects > Document Interface > Document Properties > Document.Views Property


DocumentDescriptor Interface

DocumentDescriptor Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DocumentDescriptor object represents a native document reference.

Class Hierarchy
Inventor::DocumentDescriptor
Visual Basic
Public Interface DocumentDescriptor
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ComponentOccurrence.ReferencedDocumentDescriptor

DerivedParameterTable.ReferencedDocumentDescriptor

DocumentDescriptorsEnumerator.Item

DrawingBOM.ReferencedDocumentDescriptor

DrawingView.ReferencedDocumentDescriptor

iAssemblyMember.ReferencedDocumentDescriptor

LevelOfDetailRepresentation.SubstituteDocumentDescriptor

PartsList.ReferencedDocumentDescriptor

ReferenceComponent.ReferencedDocumentDescriptor

ReferencedFileDescriptor.DocumentDescriptor

CustomTable.ReferencedDocumentDescriptor

You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface


DocumentDescriptor Properties

DocumentDescriptor Properties
Summary

The properties of the DocumentDescriptor class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DisplayName | Property that returns the display name of the referenced document as currently found (or the last known display name, if the reference is not found).
FullDocumentName | Property that returns the full path name of the referenced document as currently found (or the last known full document name, if the reference is not found).
Parent | Property that returns the parent of this object.
ReferencedDocument | Property that returns the Document object being referenced.
ReferencedDocumentType | Property that returns type of the referenced document.
ReferencedFileDescriptor | Property that returns the descriptor object for the file object that contains the referenced document.
ReferenceDisabled | Gets whether the link to this file is disabled.
ReferencedLevelOfDetail | Property that returns the LevelOfDetail type of the referenced document. This can be kMasterLevelOfDetail, kSubstituteLevelOfDetail, kAllComponentsSuppressedLevelOfDetail, kAllPartsSuppressedLevelOfDetail, kAllContentSuppressedLevelOfDetail, kSandboxLevelOfDetail, kTransientLevelOfDetail or kCustomLevelOfDetail.
ReferenceInternalNameDifferent | Gets whether the internal name of the referenced file is different from the last time the parent (referencing) file was saved. A value of True indicates that the currently referenced file has a different internal name than the originally referenced file.
ReferenceLocationDifferent | Gets whether the file path or the file name of the referenced document is different from the last time the parent (referencing) document was saved. A value of True indicates that the currently referenced document has a different file path or file name.
ReferenceMissing | Property that returns whether the referenced document is missing (unresolved or suppressed).
ReferenceSuppressed | Property that returns whether the reference is currently suppressed.
Type | Property returning kDocumentDescriptorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties


DocumentDescriptor.Application Property

DocumentDescriptor.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.Application Property


DocumentDescriptor.DisplayName Property

DocumentDescriptor.DisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the display name of the referenced document as currently found (or the last known display name, if the reference is not found).

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.DisplayName Property


DocumentDescriptor.FullDocumentName Property

DocumentDescriptor.FullDocumentName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the full path name of the referenced document as currently found (or the last known full document name, if the reference is not found).

Visual Basic
Property FullDocumentName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.FullDocumentName Property


DocumentDescriptor.Parent Property

DocumentDescriptor.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent of this object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.Parent Property


DocumentDescriptor.ReferencedDocument Property

DocumentDescriptor.ReferencedDocument Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Document object being referenced.

Visual Basic
Property ReferencedDocument() As IDispatch**
See Also

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferencedDocument Property


DocumentDescriptor.ReferencedDocumentType Property

DocumentDescriptor.ReferencedDocumentType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns type of the referenced document.

Visual Basic
Property ReferencedDocumentType() As DocumentTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferencedDocumentType Property


DocumentDescriptor.ReferencedFileDescriptor Property

DocumentDescriptor.ReferencedFileDescriptor Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the descriptor object for the file object that contains the referenced document.

Visual Basic
Property ReferencedFileDescriptor() As FileDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferencedFileDescriptor Property


DocumentDescriptor.ReferenceDisabled Property

DocumentDescriptor.ReferenceDisabled Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the link to this file is disabled.

Visual Basic
Property ReferenceDisabled() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferenceDisabled Property


DocumentDescriptor.ReferencedLevelOfDetail Property

DocumentDescriptor.ReferencedLevelOfDetail Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the LevelOfDetail type of the referenced document. This can be kMasterLevelOfDetail, kSubstituteLevelOfDetail, kAllComponentsSuppressedLevelOfDetail, kAllPartsSuppressedLevelOfDetail, kAllContentSuppressedLevelOfDetail, kSandboxLevelOfDetail, kTransientLevelOfDetail or kCustomLevelOfDetail.

Visual Basic
Property ReferencedLevelOfDetail() As LevelOfDetailEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferencedLevelOfDetail Property


DocumentDescriptor.ReferenceInternalNameDifferent Property

DocumentDescriptor.ReferenceInternalNameDifferent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the internal name of the referenced file is different from the last time the parent (referencing) file was saved. A value of True indicates that the currently referenced file has a different internal name than the originally referenced file.

Visual Basic
Property ReferenceInternalNameDifferent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferenceInternalNameDifferent Property


DocumentDescriptor.ReferenceLocationDifferent Property

DocumentDescriptor.ReferenceLocationDifferent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the file path or the file name of the referenced document is different from the last time the parent (referencing) document was saved. A value of True indicates that the currently referenced document has a different file path or file name.

Visual Basic
Property ReferenceLocationDifferent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferenceLocationDifferent Property


DocumentDescriptor.ReferenceMissing Property

DocumentDescriptor.ReferenceMissing Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the referenced document is missing (unresolved or suppressed).

Visual Basic
Property ReferenceMissing() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferenceMissing Property


DocumentDescriptor.ReferenceSuppressed Property

DocumentDescriptor.ReferenceSuppressed Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the reference is currently suppressed.

Visual Basic
Property ReferenceSuppressed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.ReferenceSuppressed Property


DocumentDescriptor.Type Property

DocumentDescriptor.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDocumentDescriptorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptor Interface > DocumentDescriptor Properties > DocumentDescriptor.Type Property


DocumentDescriptorsEnumerator Interface

DocumentDescriptorsEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DocumentDescriptorsEnumerator object provides information about native document references held.

Class Hierarchy
Inventor::DocumentDescriptorsEnumerator
Visual Basic
Public Interface DocumentDescriptorsEnumerator
Inherits IDispatch
Remarks

There will be a document descriptor for every unique document reference. For example, if you have two instances of the same subassembly in an assembly, there will be one document descriptor for that reference. If you edit one of those instances to reference a different Level Of Detail (but still the same file), you will get two document descriptors (one for each unique LOD). Since a "Document" identifies a specific LOD representation, which LOD is meaningful for a suppressed instance? Inventor uses a 'suppressed' descriptor for all suppressed references to a particular file. Essentially, 'suppressed' references are treated as just another LOD. So if you have four instances of the same file, two in master and two suppressed, you should expect two document descriptors, one for master, and one for suppressed. DocumentDescriptor.ReferenceSuppressed can be used to identify suppressed reference descriptors.

Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.ReferencedDocumentDescriptors

Document.ReferencedDocumentDescriptors

You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface


DocumentDescriptorsEnumerator Methods

DocumentDescriptorsEnumerator Methods
Summary

The methods of the DocumentDescriptorsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified DocumentDescriptor object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface > DocumentDescriptorsEnumerator Methods


DocumentDescriptorsEnumerator.Item Method

DocumentDescriptorsEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified DocumentDescriptor object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DocumentDescriptor*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DocumentDescriptor to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the full document name. If an out of range index or a name of a non-existent DocumentDescriptor is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface > DocumentDescriptorsEnumerator Methods > DocumentDescriptorsEnumerator.Item Method


DocumentDescriptorsEnumerator Properties

DocumentDescriptorsEnumerator Properties
Summary

The properties of the DocumentDescriptorsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDocumentDescriptorsEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface > DocumentDescriptorsEnumerator Properties


DocumentDescriptorsEnumerator.Application Property

DocumentDescriptorsEnumerator.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface > DocumentDescriptorsEnumerator Properties > DocumentDescriptorsEnumerator.Application Property


DocumentDescriptorsEnumerator.Count Property

DocumentDescriptorsEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface > DocumentDescriptorsEnumerator Properties > DocumentDescriptorsEnumerator.Count Property


DocumentDescriptorsEnumerator.Type Property

DocumentDescriptorsEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDocumentDescriptorsEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentDescriptorsEnumerator Interface > DocumentDescriptorsEnumerator Properties > DocumentDescriptorsEnumerator.Type Property


DocumentEvents CoClass

DocumentEvents CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DocumentEvents object provides notification of events that take place at the document level, such as activating, closing and saving particular documents.

Class Hierarchy
Inventor::DocumentEvents
Visual Basic
Public Class DocumentEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Document.DocumentEvents

You are here: Symbol Reference > Inventor Library > Objects > DocumentEvents CoClass


DocumentEventsObject Interface

DocumentEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DocumentEvents object provides notification of events that take place at the document level, such as activating, closing and saving particular documents.

Class Hierarchy
Inventor::DocumentEventsObject
Visual Basic
Public Interface DocumentEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsObject Interface


DocumentEventsObject Properties

DocumentEventsObject Properties
Summary

The properties of the DocumentEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsObject Interface > DocumentEventsObject Properties


DocumentEventsObject.Application Property

DocumentEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsObject Interface > DocumentEventsObject Properties > DocumentEventsObject.Application Property


DocumentEventsObject.Parent Property

DocumentEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsObject Interface > DocumentEventsObject Properties > DocumentEventsObject.Parent Property


DocumentEventsObject.Type Property

DocumentEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsObject Interface > DocumentEventsObject Properties > DocumentEventsObject.Type Property


DocumentEventsSink Interface

DocumentEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DocumentEvents object provides notification of events that take place at the document level, such as activating, closing and saving particular documents.

Class Hierarchy
Inventor::DocumentEventsSink
Visual Basic
Public Interface DocumentEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface


DocumentEventsSink Methods

DocumentEventsSink Methods
Summary

The methods of the DocumentEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivate | The OnActivate event notifies a client when the document is activated.
OnChange | Fires when this document changes, supplying the reasons for change and the context in which this action is being taken.
OnChangeSelectSet | The OnChangeSelectSet event notifies a client when the contents of the select set have changed.
OnClose | The Onclose event notifies a client when the document is closed.
OnDeactivate | The OnDeactivate event notifies a client when the document is being deactivated.
OnDelete | The OnDelete event notifies a client when an entity is deleted.
OnSave | The OnSave event notifies a client whenever the document is saved.
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods


DocumentEventsSink.OnActivate Method

DocumentEventsSink.OnActivate Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnActivate event notifies a client when the document is activated.

Visual Basic
Sub OnActivate(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter). Notification is sent before and after the document is activated. BeforeOrAfter is kAbort if the native processing was ABORTED.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
Remarks

When a document is activated it is the top-level document currently available for edit in the user-interface. In-place activating a document within the context of an assembly does not cause it to be the active document. In this case the document being in-place activated becomes the active edit object, but not the active document. The top-level assembly that the edit is taking place within remains the active document.

You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnActivate Method


DocumentEventsSink.OnChange Method

DocumentEventsSink.OnChange Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Fires when this document changes, supplying the reasons for change and the context in which this action is being taken.

Visual Basic
Sub OnChange(ReasonsForChange As CommandTypesEnum, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
ReasonsForChange
This argument indicates the type of change that occurred. The value is from the CommandTypesEnum list, which represents the different categories of changes that can be made. Typically this will be a single value from the list but it can represent multiple values that have been combined together so you need to use bitwise operations to check for a specific change.
BeforeOrAfter
This argument specifies if the notification is being sent before a change is made (kBefore), after a change is made (kAfter), or when a change has been aborted (kAbort).
Context
Input NameValueMap object that can be used to determine the context of why the event fired. This argument provides additional information as described below:
Name = "DisplayName", Value = The display name of the command that caused the change. This name will change based on the language currently being used for Inventor.
Name = "InternalName", Value = The internal name of the command that caused the change. This name will be consistent regardless of the current language.
Name = "InternalNamesList", Value = as follows. When the internal name is "CompositeChange" this value is returned. Some commands result in making several changes but combine or composite them into a single command. The individual changes that were composited into the single command are provided through this value. It is an array of strings that consist of the internal names of the individual changes made. For example, if you drag a sketch point that connects two lines, the display name is "Drag Sketch Inference", the internal name is "CompositeChange" and the internal names list is an array of the following three strings; "Modify Point", "Modify Line", and "Modify Line".
Name = "ConsideredDirty", Value = "". If this name appears in the context list then the change made is one that causes the document to be dirty.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event. This event supports the ability to cancel the change. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the change. When the change is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.
Remarks

The notification is not sent for commands that do not change the document, i.e. measure and view commands.

Care needs to be taken when using this event because changes to the document are made so frequently that depending on what you do in response to the event it can degrade the performance of Inventor. You should perform simple checks first to see if the change is one that you're interested in before you perform more expensive operations. Whenever possible you should use more specific events instead of this general change event. For example, if you're interested in knowing when a parameter value changes you can listen to the ModelingEvents.OnParameterChange event instead. This is both simpler for you and more efficient, but not all actions that can occur within Inventor have corresponding events so in many cases using the OnChange event is the only solution.

There is also a corresponding OnDocumentChange event on the ApplicationEvents object. The OnDocumentChange event notifies clients for changes in all documents. Whereas the OnChange event only sends notification for changes made to the document the event object was obtained from.

You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnChange Method


DocumentEventsSink.OnChangeSelectSet Method

DocumentEventsSink.OnChangeSelectSet Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

The OnChangeSelectSet event notifies a client when the contents of the select set have changed.

Visual Basic
Sub OnChangeSelectSet(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input that indicates when the event is fired. This notification is only provided after the contents of the select set have changed so the value of this argument will always be kAfter.
Context | Input that specifies additional context information regarding the event. No context information is provided for this event.
HandlingCode | Output that specifies how Autodesk Inventor is to handle the event. This argument is ignored for this event.
Remarks

This notification is sent when items are added or removed from the select set and when the select set is cleared. The current contents of the select set can be obtained through the document's SelectSet object. Note. You can get what appears to be double notifications of this event when an object is already selected and the end-user selects another object. In this case the first notification is because the current object(s) in the select set are being removed and the second notification is for the new entity being added.

You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnChangeSelectSet Method


DocumentEventsSink.OnClose Method

DocumentEventsSink.OnClose Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Onclose event notifies a client when the document is closed.

Visual Basic
Sub OnClose(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input indicating when the event is being fired. Notification is sent before and after the document is closed.
Context | Input object that can be used to determine the context of why the event fired. This event provides additional information through the Context argument as described below: Name = "HealthStatusEnum", Value = The health status of the document. If this value is anything other than kUpToDateHealth you know the Document object returned is not in a state where you can use most of its methods or properties.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnClose Method


DocumentEventsSink.OnDeactivate Method

DocumentEventsSink.OnDeactivate Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnDeactivate event notifies a client when the document is being deactivated.

Visual Basic
Sub OnDeactivate(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input indicating when the event is fired. Notification is only sent before the document is deactivated.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnDeactivate Method


DocumentEventsSink.OnDelete Method

DocumentEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

The OnDelete event notifies a client when an entity is deleted.

Visual Basic
Sub OnDelete(Entity As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
Entity
The Entity that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the object provided is the object before it is deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example: Private m_oDeletedEntity As Object Private Sub oDocEvents_OnDelete(ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...) If BeforeOrAfter = kBefore Then ' Check to see if the Entity being deleted is an interesting one. ' For example, it could have an attribute attached to it. If Interesting(Entity) Then ' Save a reference to the object. Set m_oDeletedEntity = Entity End If Else ' Now we're either after the delete or it's been aborted. ' Check to see if the object is the interesting one. If Entity is m_oDeletedEntity Then If BeforeOrAfter = kAfter then ' The object was deleted. Else If BeforeOrAfter = kAbort Then ' The delete was aborted. End If End If End Sub
BeforeOrAfter
Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the entity is deleted.
Context
Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode
Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

This notification is sent for each entity that is deleted. If the end-user selects multiple objects and then presses the delete key, an OnDelete notification is sent for each entity that's deleted.

You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnDelete Method


DocumentEventsSink.OnSave Method

DocumentEventsSink.OnSave Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnSave event notifies a client whenever the document is saved.

Visual Basic
Sub OnSave(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input indicating when the event is being fired. Specifies if the notification is being sent before the document is saved (kBefore) or after the save (kAfter).
Context | Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the save. Name = "SaveFileName", Value = The full filename that document is being saved to.
HandlingCode | Output that indicates how you are handling the event. This event supports the ability to cancel the change. Setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the save. If the event is aborted, it is not fired again with either kAfter or kAbort.
Remarks

The notification is made when the standard Save and the Save Copy As commands are invoked.

Example

"Using OnSave"

"Example of using OnSave event"

'Firstly you need a class that sinks the events, for example:

Option Explicit

Private WithEvents oApplicationEvents As ApplicationEvents

Private Sub Class_Initialize()
  Set oApplicationEvents = ThisApplication.ApplicationEvents
End Sub

Private Sub Class_Terminate()
  Set oApplicationEvents = Nothing
End Sub

Private Sub oApplicationEvents_OnSaveDocument(ByVal DocumentObject As Document, ByVal BeforeOrAfter As EventTimingEnum, ByVal Context As NameValueMap, HandlingCode As HandlingCodeEnum)
  If (BeforeOrAfter = kBefore) Then
    MsgBox ("about to save " & DocumentObject.FullFileName)
  Else

  MsgBox (DocumentObject.FullFileName & " has been saved")
  End If
End Sub

'Then you need to create an instance of this class so that
'the event is reacted to e.g.

Option Explicit

Dim oEventHandler As MyEventHandler

Sub listenToEvents()
  Set oEventHandler = New MyEventHandler
End Sub

Sub stopListening()
  Set oEventHandler = Nothing
End Sub

'In this case I called the class "MyEventHandler".
You are here: Symbol Reference > Inventor Library > Objects > DocumentEventsSink Interface > DocumentEventsSink Methods > DocumentEventsSink.OnSave Method


DocumentInterest Interface

DocumentInterest Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Provides a means for an application to register an interest in a document. In order words, to flag the document as containing application-specific data, and to set the data version (for example, so Inventor can determine whether data migration is required and so fire the appropriate event).

Class Hierarchy
Inventor::DocumentInterest
Visual Basic
Public Interface DocumentInterest
Inherits IDispatch
Remarks

Document Interests are the recommended means of marking schema versions for application custom data in a document, and in fact is now the preferred method for an Add-in to implement a document sub-type. However, it is not recommended that applications rely on DocumentInterests when querying a document type. An application should not draw any meaning from DocumentInterests that it did not add. In other words, application A should not infer anything from application B's DocumentInterests. Please refer to the Zero Impact Migration overview for more details.

Notes

Members through which this object may be accessed include:

DocumentInterests.Add

DocumentInterests.Item

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface


DocumentInterest Methods

DocumentInterest Methods
Summary

The methods of the DocumentInterest class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the DocumentInterest object.
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Methods


DocumentInterest.Delete Method

DocumentInterest.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes the DocumentInterest object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Methods > DocumentInterest.Delete Method


DocumentInterest Properties

DocumentInterest Properties
Summary

The properties of the DocumentInterest class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
ClientData | Contains some additional data that the client would like to store with the interest. This string is not interpreted by Inventor. Clients are expected to use the string with extreme economy.
ClientId | Property that returns the ClientId associated with the DocumentInterest indicating the owner of this object.
DataVersion | Specifies the current data version of the document. If not specified, this is assumed to be a 'non-migrating' type of interest. When a document is opened, if this DataVersion value is less than the current DataVersion value of the AddIn (ApplicationAddIn.DataVersion), the 'Migrate' command is enabled. When the user invokes the Migrate command, the OnMigrateDocument event is fired and gives the client an opportunity to migrate their data.
InterestType | Specifies the type of interest that the client has in this document. Valid inputs are kInterested and kNotInterested.
Name | Property that returns the non-localized name associated with this interest.
Parent | Property that returns the parent document object.
Type | Property returning kDocumentInterestObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties


DocumentInterest.Application Property

DocumentInterest.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.Application Property


DocumentInterest.ClientData Property

DocumentInterest.ClientData Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Contains some additional data that the client would like to store with the interest. This string is not interpreted by Inventor. Clients are expected to use the string with extreme economy.

Visual Basic
Property ClientData() As String
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.ClientData Property


DocumentInterest.ClientId Property

DocumentInterest.ClientId Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ClientId associated with the DocumentInterest indicating the owner of this object.

Visual Basic
Property ClientId() As BSTR*
Remarks

This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.ClientId Property


DocumentInterest.DataVersion Property

DocumentInterest.DataVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Specifies the current data version of the document. If not specified, this is assumed to be a 'non-migrating' type of interest. When a document is opened, if this DataVersion value is less than the current DataVersion value of the AddIn (ApplicationAddIn.DataVersion), the 'Migrate' command is enabled. When the user invokes the Migrate command, the OnMigrateDocument event is fired and gives the client an opportunity to migrate their data.

Visual Basic
Property DataVersion() As long
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.DataVersion Property


DocumentInterest.InterestType Property

DocumentInterest.InterestType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Specifies the type of interest that the client has in this document. Valid inputs are kInterested and kNotInterested.

Visual Basic
Property InterestType() As DocumentInterestTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.InterestType Property


DocumentInterest.Name Property

DocumentInterest.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the non-localized name associated with this interest.

Visual Basic
Property Name() As BSTR*
Remarks

This is typically a string specifying the document 'sub-type'.

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.Name Property


DocumentInterest.Parent Property

DocumentInterest.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent document object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.Parent Property


DocumentInterest.Type Property

DocumentInterest.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kDocumentInterestObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterest Interface > DocumentInterest Properties > DocumentInterest.Type Property


DocumentInterests Interface

DocumentInterests Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Description of the collection object. Below are some common methods and properties.

Class Hierarchy
Inventor::DocumentInterests
Visual Basic
Public Interface DocumentInterests
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.DocumentInterests

Document.DocumentInterests

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface


DocumentInterests Methods

DocumentInterests Methods
Summary

The methods of the DocumentInterests class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new DocumentInterest.
HasInterest | Method that returns whether an AddIn with the input ClientId/Name has expressed interest in this document.
Item | Property that returns the specified DocumentInterest object from the collection
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Methods


DocumentInterests.Add Method

DocumentInterests.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new DocumentInterest.

Visual Basic
Sub Add(ClientId As String, Name As String, InterestType As DocumentInterestTypeEnum, ByRef DataVersion As [defaultvalue(-1)] long, ByRef ClientData As [optional] VARIANT, Result As [out, retval] DocumentInterest*)
Parameters
Parameters | Description
ClientId | Input String that uniquely identifies a client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
Name | Input String that specifies the name associated with this interest. This is typically a string specifying the document 'sub-type'.
InterestType | Input DocumentInterestTypeEnum that specifies the type of interest that the client has in this document. Valid inputs are kInterested and kNotInterested.
DataVersion | Optional input Long that specifies the current data version of the document. If not specified, this is assumed to be a 'non-migrating' type of interest. When a document is opened, if this DataVersion value is less than the current DataVersion value of the AddIn (ApplicationAddIn.DataVersion), the 'Migrate' command is enabled. When the user invokes the Migrate command, the OnMigrateDocument event is fired and gives the client an opportunity to migrate their data.
ClientData | Optional input String that contains some additional data that the client would like to store with the interest. This string is not interpreted by Inventor. Clients are expected to use the string with extreme economy.
Remarks

The new created DocumentInterest is returned. The method fails if a DocumentInterest with the same ClientId already exists.

Notes

Clients are strongly warned to store as little data as practicably possible, partly to avoid capacity issues, but mainly because this will affect Inventor's ability to open documents quickly in a 'lightweight' background mode.

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Methods > DocumentInterests.Add Method


DocumentInterests.HasInterest Method

DocumentInterests.HasInterest Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether an AddIn with the input ClientId/Name has expressed interest in this document.

Visual Basic
Sub HasInterest(ClientIdOrName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
ClientIdOrName | Input String that uniquely identifies a client. This could be the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}", or the Name of the interest.
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Methods > DocumentInterests.HasInterest Method


DocumentInterests.Item Method

DocumentInterests.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified DocumentInterest object from the collection

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DocumentInterest*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DocumentInterest to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ClientId associated with the DocumentInterest, or it can be the a string indicating the Name of the DocumentInterest. If an out of range index or a ClientId/Name of a non-existent DocumentInterest is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Methods > DocumentInterests.Item Method


DocumentInterests Properties

DocumentInterests Properties
Summary

The properties of the DocumentInterests class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDocumentInterestsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Properties


DocumentInterests.Application Property

DocumentInterests.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Properties > DocumentInterests.Application Property


DocumentInterests.Count Property

DocumentInterests.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Properties > DocumentInterests.Count Property


DocumentInterests.Type Property

DocumentInterests.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kDocumentInterestsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentInterests Interface > DocumentInterests Properties > DocumentInterests.Type Property


Documents Interface

Documents Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Document collection object contains all in-memory Inventor documents.

Class Hierarchy
Inventor::DocumentsEnumerator
    Inventor::Documents
Visual Basic
Public Interface Documents
Inherits DocumentsEnumerator
Notes

Members through which this object may be accessed include:

Application.Documents

See Also

Create a Configuration Table sample

Creating a new parameter group sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Example

See Documents::OpenWithOptions for example "Open assembly document with Representations"

You are here: Symbol Reference > Inventor Library > Objects > Documents Interface


Documents Methods

Documents Methods
Summary

The methods of the Documents class are listed here.

Methods
Methods
Name | Description
Add | Creates a new of the specified type. Optionally, a template file can be specified instead.
CloseAll | Method that closes all the documents in the current Inventor session. Changes are not saved to any of the documents. In other words, if there are dirty documents in the collection, changes made to them will be lost.
ItemByName | Property that returns the specified Document object from the collection.
Open | Method that opens the specified Inventor document.
OpenWithOptions | Method that opens the specified Inventor document.
You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Methods


Documents.Add Method

Documents.Add Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Creates a new of the specified type. Optionally, a template file can be specified instead.

Visual Basic
Sub Add(DocumentType As DocumentTypeEnum, ByRef TemplateFileName As [defaultvalue("")] BSTR, ByRef CreateVisible As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Document*)
Parameters
Parameters | Description
DocumentType | Input that specifies the type of document to add. If the DocumentType argument is specified to be kDrawingDocumentObject, the method will honor the application option to decide whether to use an idw template or an Inventor DWG template.
TemplateFileName | Input String that specifies the name of the template file.
CreateVisible | Optional input Boolean that specifies whether the created document or template is visible.
See Also

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Derived Parts and Assemblies sample

Derived Parts and Assemblies sample

Add a decal feature sample

Creating a new parameter group sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Navigation between browser and data sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Methods > Documents.Add Method


Documents.CloseAll Method

Documents.CloseAll Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that closes all the documents in the current Inventor session. Changes are not saved to any of the documents. In other words, if there are dirty documents in the collection, changes made to them will be lost.

Visual Basic
Sub CloseAll(ByRef UnreferencedOnly As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters
Description
UnreferencedOnly
Optional input Boolean that indicates whether to close only the unreferenced documents. If not specified, a value of False is assumed and all documents are closed. Examples of unreferenced documents:

  • Create a new assembly, place an instance of a part "block.ipt", (provided block.ipt is not open in it's own window) and then delete the instance in the assembly. At this point, block.ipt is an unreferenced document.
  • Set the Suppressed property of a ComponentOccurrence to True within an API Transaction (or a ChangeProcessor). Assuming that the document that this occurrence was referencing is not referenced elsewhere, it becomes an "unreferenced" document.

You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Methods > Documents.CloseAll Method


Documents.ItemByName Method

Documents.ItemByName Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Document object from the collection.

Visual Basic
Sub ItemByName(FullDocumentName As String, Result As [out, retval] Document*)
Parameters
Parameters | Description
FullDocumentName | Input String that specifies the Document to return. If only the FullFileName is specified for part and assembly documents, the master document within the file is returned (if it exists in the collection).
You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Methods > Documents.ItemByName Method


Documents.Open Method

Documents.Open Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that opens the specified Inventor document.

Visual Basic
Sub Open(FullDocumentName As String, ByRef OpenVisible As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Document*)
Parameters
Parameters | Description
FullDocumentName | Input String that specifies the full document name of the document to open. If only the FullFileName is specified for part and assembly documents, the master document within the file is opened.
OpenVisible | Optional input Boolean that specifies whether to open the document as visible.
Remarks

Programmatic changes to the "Defer Updates" setting made through the kDrawingDeferUpdateDesignTrackingProperties iProperty of a drawing document opened in Autodesk Inventor will not affect the open drawing document and will be overwritten upon save of that document. However, changes to the "Defer Updates" setting made through the DrawingSettings.DeferUpdates property of the API, or through the Autodesk Inventor Document Settings dialog, will be honored for the open drawing document. When opening non-Inventor DWG files, this method honors the application option to decide between open and import.

See Also

Copying a title block definition sample

Create sheet with multiple views sample

Open assembly in last LOD sample

Create base view with representations (C#) sample

Create flat pattern drawing view sample

Adding Representation views sample

Create a Configuration Table sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Methods > Documents.Open Method


Documents.OpenWithOptions Method

Documents.OpenWithOptions Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that opens the specified Inventor document.

Visual Basic
Sub OpenWithOptions(FullDocumentName As String, Options As NameValueMap, ByRef OpenVisible As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Document*)
Parameters
Parameters | Description
FullDocumentName | Input String that specifies the full document name of the document to open. If only the FullFileName is specified for an assembly, the master document within the file is opened.
Options | Input NameValueMap object that specifies additional options for open. (An empty NameValueMap object can be provided). See Remarks section for the valid options.
OpenVisible | Optional input Boolean that specifies whether to open the document as visible. If not specified, the document is opened visible.
Remarks

When opening non-Inventor DWG files, this method honors the application option to decide between open and import, unless an override is specified in the Options argument.

Valid Options arguements are:

Name Value | Type | Valid document | Notes
DesignViewRepresentation | String | Part, Assembly |
PositionalRepresentation | String | Assembly |
LevelOfDetailRepresentation | String | Assembly | Typically, the LevelOfDetailRepresentation to use should be provided in the form of a FulDocumentName (first argument). But if this is provided separately, you should make sure that it does not conflict with the FullDocumentName argument by providing FullFileName as the first argument rather than a FullDocumentName.
DeferUpdates | Boolean | Drawing |
FileVersionOption | FileVersionEnum | All | Valid values for FileVersionEnum are kOpenOldVersion, kOpenCurrentVersion and kRestoreOldVersionToCurrent. If set to kOpenOldVersion, save will not be allowed on the opened document. kRestoreOldVersionToCurrent is valid only if no other versions are open and the current version is not checked out.
ImportNonInventorDWG | Boolean | Imports the DWG file to an IDW if True, Opens it into Inventor DWG if False | When opening non-Inventor DWG files, this method honors the application option to decide between open and import, unless an override is specified in the Options argument.
Password | String | All |
SkipAllUnresolvedFiles | Boolean | All |
Example 1

Open assembly document with Representations

This sample demonstrates how to open an assembly document by specifying which representations to open the document in. Before running this sample, make sure that the file C:\Temp\Reps.iam exists (or change the path in the sample). The file must contain a level of detail representation named MyLODRep, a positional representation named MyPositionalRep and a design view representation named MyDesignViewRep.

Public Sub OpenDocumentWithRepresentations()

    ' Create a new NameValueMap object
    Dim oDocOpenOptions As NameValueMap
    Set oDocOpenOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Set the representations to use when opening the document.
    Call oDocOpenOptions.Add("LevelOfDetailRepresentation", "MyLODRep")
    Call oDocOpenOptions.Add("PositionalRepresentation", "MyPositionalRep")
    Call oDocOpenOptions.Add("DesignViewRepresentation", "MyDesignViewRep")

    ' Open the document.
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.Documents.OpenWithOptions("C:\Temp\Reps.iam", oDocOpenOptions, True)

End Sub
Example 2

See ComponentOccurrences::AddWithOptions for example "Create assembly occurrence with representations"

Example 3

Open assembly document with Representations (C#).

This sample demonstrates how to open an assembly document by specifying which representations to open the document in. Before running this sample, make sure that the file C:/Temp/Reps.iam exists (or change the path in the sample). The file must contain a level of detail representation named MyLODRep, a positional representation named MyPositionalRep and a design view representation named MyDesignViewRep.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void OpenDocumentWithRepresentations()
{
    Application oApp = ThisApplication;

    // Create a new NameValueMap object
    NameValueMap oDocOpenOptions = oApp.TransientObjects.CreateNameValueMap();

    // Set the representations to use when opening the document.
    oDocOpenOptions.Add("LevelOfDetailRepresentation", "MyLODRep");
    oDocOpenOptions.Add("PositionalRepresentation", "MyPositionalRep");
    oDocOpenOptions.Add("DesignViewRepresentation", "MyDesignViewRep");

    // Open the document.
    AssemblyDocument oDoc = (AssemblyDocument)oApp.Documents.OpenWithOptions("C:/Temp/Reps.iam", oDocOpenOptions, true);

}
You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Methods > Documents.OpenWithOptions Method


Documents Properties

Documents Properties
Summary

The properties of the Documents class are listed here.

Properties
Name | Description
VisibleDocuments | Gets the collection of visible documents.
You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Properties


Documents.VisibleDocuments Property

Documents.VisibleDocuments Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the collection of visible documents.

Visual Basic
Property VisibleDocuments() As DocumentsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Documents Interface > Documents Properties > Documents.VisibleDocuments Property


DocumentsEnumerator Interface

DocumentsEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to a list of objects.

Class Hierarchy
Inventor::DocumentsEnumerator
    Inventor::Documents
Visual Basic
Public Interface DocumentsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Document.AllReferencedDocuments

Document.ReferencedDocuments

Document.ReferencingDocuments

Document.FindWhereUsed

Document.ReferencedFiles

Documents.VisibleDocuments

File.AvailableDocuments

You are here: Symbol Reference > Inventor Library > Objects > DocumentsEnumerator Interface


DocumentsEnumerator Methods

DocumentsEnumerator Methods
Summary

The methods of the DocumentsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection. This is the default property of the DocumentsEnumerator object.
You are here: Symbol Reference > Inventor Library > Objects > DocumentsEnumerator Interface > DocumentsEnumerator Methods


DocumentsEnumerator.Item Method

DocumentsEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified object from the collection. This is the default property of the DocumentsEnumerator object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Document*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > DocumentsEnumerator Interface > DocumentsEnumerator Methods > DocumentsEnumerator.Item Method


DocumentsEnumerator Properties

DocumentsEnumerator Properties
Summary

The properties of the DocumentsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DocumentsEnumerator Interface > DocumentsEnumerator Properties


DocumentsEnumerator.Count Property

DocumentsEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DocumentsEnumerator Interface > DocumentsEnumerator Properties > DocumentsEnumerator.Count Property


DocumentsEnumerator.Type Property

DocumentsEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DocumentsEnumerator Interface > DocumentsEnumerator Properties > DocumentsEnumerator.Type Property


DoubleHemDefinition Interface

DoubleHemDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DoubleHemDefinition defines all of the inputs that are unique to a double style of hem feature.

Class Hierarchy
Inventor::DoubleHemDefinition
Visual Basic
Public Interface DoubleHemDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HemDefinition.HemTypeDefinition

You are here: Symbol Reference > Inventor Library > Objects > DoubleHemDefinition Interface


DoubleHemDefinition Properties

DoubleHemDefinition Properties
Summary

The properties of the DoubleHemDefinition class are listed here.

Properties
Name | Description
Gap | Property that returns the parameter controlling the gap of a hem feature defined by a double bend style of bend.
Length | Property that returns the parameter controlling the length of a hem feature defined by a double bend style of bend.
Parent | Property that returns the parent hem definition feature.
You are here: Symbol Reference > Inventor Library > Objects > DoubleHemDefinition Interface > DoubleHemDefinition Properties


DoubleHemDefinition.Gap Property

DoubleHemDefinition.Gap Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the gap of a hem feature defined by a double bend style of bend.

Visual Basic
Property Gap() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > DoubleHemDefinition Interface > DoubleHemDefinition Properties > DoubleHemDefinition.Gap Property


DoubleHemDefinition.Length Property

DoubleHemDefinition.Length Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the length of a hem feature defined by a double bend style of bend.

Visual Basic
Property Length() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > DoubleHemDefinition Interface > DoubleHemDefinition Properties > DoubleHemDefinition.Length Property


DoubleHemDefinition.Parent Property

DoubleHemDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent hem definition feature.

Visual Basic
Property Parent() As HemDefinition**
You are here: Symbol Reference > Inventor Library > Objects > DoubleHemDefinition Interface > DoubleHemDefinition Properties > DoubleHemDefinition.Parent Property


DraftAnalyses Interface

DraftAnalyses Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DraftAnalyses collection object provides access to existing draft analyses and supports the ability to create new draft analysis.

Class Hierarchy
Inventor::DraftAnalyses
Visual Basic
Public Interface DraftAnalyses
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AnalysisManager.DraftAnalyses

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface


DraftAnalyses Methods

DraftAnalyses Methods
Summary

The methods of the DraftAnalyses class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new draft analysis. If the draft analysis is created successfully, a DraftAnalysis object corresponding to the newly created draft analysis is returned from this method.
Item | Method that returns the specified DraftAnalysis object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Methods


DraftAnalyses.Add Method

DraftAnalyses.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new draft analysis. If the draft analysis is created successfully, a DraftAnalysis object corresponding to the newly created draft analysis is returned from this method.

Visual Basic
Sub Add(StartAngle As double, EndAngle As double, PullDirection As IDispatch, ByRef Reversed As [defaultvalue(0)] VARIANT_BOOL, ByRef Faces As [optional] VARIANT, ByRef GradientDisplay As [defaultvalue(0)] VARIANT_BOOL, ByRef DisplayQuality As [defaultvalue(0)] long, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] DraftAnalysis*)
Parameters
Parameters
Description
StartAngle
Input Double that defines the start angle for the draft analysis. The units for the input value will be assumed to be radians. If a value in another units (e.g. degrees) or a string expression needs to be used, the methods of the UnitsOfMeasure object can be used to first convert that value to the corresponding double value in radians units. The converted double value in radians units can then be specified as the input value for this argument.
EndAngle
Input Double that defines the end angle for the draft analysis. The units for the input value will be assumed to be radians. If a value in another units (e.g. degrees) or a string expression needs to be used, the methods of the UnitsOfMeasure object can be used to first convert that value to the corresponding double value in radians units. The converted double value in radians units can then be specified as the input value for this argument.
PullDirection
Input Object that defines the direction in which the draft is applied. This can be any one of the following:

  • Face - planar, cylindrical, conical or torus

For a planar face, the normal direction of the face will be used as the pull direction. For a cylindrical, conical or torus face, the axis direction of the face will be used as the pull direction.

  • Edge
  • WorkPlane
  • WorkAxis

Face and edges that belong to surfaces can also be used to specify the pull direction for the draft analysis. The same limitations that apply for the pull direction when creating a draft analysis interactively through the command also apply when creating a draft analysis using the API.

Faces
Optional input Variant that specifies an ObjectCollection containing the faces for the draft analysis. If no value is specified for this argument, then all faces in the part will be used for the draft analysis. If only a specific set of faces need to be used for the draft analysis, then they have to be specified as an ObjectCollection. The input collection can contain a combination of Face and WorkSurface objects. If WorkSurface objects are specified, then all faces of the WorkSurface will be used for the draft analysis.
GradientDisplay
Optional input Boolean that specifies whether the draft analysis results should be displayed as a color gradient. If a value of True is specified, then the draft analysis results will be displayed as a color gradient. If a value of False is specified, then the draft analysis results will be displayed as discrete color bands. If no value is explicitly specified, then a default value of False will be assumed to indicate that the draft analysis results should be displayed as discrete color bands.
DisplayQuality
Optional input Long that specifies the resolution or surface quality for the color gradient or color bands that represent the draft analysis results. The value indicates a scale, the valid values are in the range of 0 and 10. The specified value will then be interpreted in terms of the percentage value which is the type of value that is specified interactively through the command. For example, if a value of 1 is specified for this argument, this will be indicate a value of 10 percentage.
Name
Optional input String that specifies the name of the draft analysis. If not specified, Inventor assigns a name to the draft analysis.
reversed
Optional input Boolean that specifies whether the pull direction of the draft should be reversed. If no value is explicitly specified, then a default value of False will be assumed to indicate that the pull direction will not be reversed.
Example

"Create a Draft Analysis"

This sample demonstrates the creation of a draft analysis in a part. Open a part document and run the following sample.

Public Sub CreateDraftAnalysis()

    ' Set a reference to the active part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the component definition
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    ' Set a reference to the analysis manager
    Dim oAnalysisMgr As AnalysisManager
    Set oAnalysisMgr = oCompDef.AnalysisManager

    ' Get the y-axis, to be used as the pull direction for the draft analysis
    Dim oYAxis As WorkAxis
    Set oYAxis = oCompDef.WorkAxes.Item(2)

    ' Create the draft analysis with the following input values
    '   Start Angle = -3 degrees
    '   End Angle =   3 degrees
    '   Pull direction = Negative Y Axis
    '   Display Quality = 50%

    Dim oDraftAnalysis As DraftAnalysis
    Set oDraftAnalysis = oAnalysisMgr.DraftAnalyses.Add(-0.05236, 0.05236, oYAxis, True, , , 5)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Methods > DraftAnalyses.Add Method


DraftAnalyses.Item Method

DraftAnalyses.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified DraftAnalysis object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DraftAnalysis*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the DraftAnalysis name. If an out of range index or a name of a non-existent draft analysis is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Methods > DraftAnalyses.Item Method


DraftAnalyses Properties

DraftAnalyses Properties
Summary

The properties of the DraftAnalyses class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning kDraftAnalysesObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Properties


DraftAnalyses.Application Property

DraftAnalyses.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Properties > DraftAnalyses.Application Property


DraftAnalyses.Count Property

DraftAnalyses.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Properties > DraftAnalyses.Count Property


DraftAnalyses.Type Property

DraftAnalyses.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDraftAnalysesObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalyses Interface > DraftAnalyses Properties > DraftAnalyses.Type Property


DraftAnalysis Interface

DraftAnalysis Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DraftAnalysis object represents an existing draft analysis feature in a part document.

Class Hierarchy
Inventor::DraftAnalysis
Visual Basic
Public Interface DraftAnalysis
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DraftAnalyses.Add

DraftAnalyses.Item

DraftAnalysis.Copy

See Also

Create a Draft Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface


DraftAnalysis Methods

DraftAnalysis Methods
Summary

The methods of the DraftAnalysis class are listed here.

Methods
Methods
Name | Description
Activate | Method that activates the draft analysis.
Copy | Method that creates a copy of the draft analysis.
Delete | Method that deletes the draft analysis.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Methods


DraftAnalysis.Activate Method

DraftAnalysis.Activate Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that activates the draft analysis.

Visual Basic
Sub Activate()
Remarks

This method will activate the draft analysis irrespective of whether the analysis visibility is turned on or off. Activating an analysis does not necessarily make it visible. The analysis will be visible only if the analysis visibility is turned on. The IsAnalysisVisible property of the AnalysisManager object can be used to turn on the visibility for the currently active analysis.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Methods > DraftAnalysis.Activate Method


DraftAnalysis.Copy Method

DraftAnalysis.Copy Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a copy of the draft analysis.

Visual Basic
Sub Copy(Result As [out, retval] DraftAnalysis*)
Remarks

If the draft analysis is copied successfully, this method will return a DraftAnalysis object that represents the new copy. The copy will have the same initial values as the source DraftAnalysis that has been copied, except for the name. Inventor assigns a default unique name to the draft analysis copy. The values of the draft analysis copy (including the name) can be changed by using the properties of the DraftAnalysis object that is returned by this method.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Methods > DraftAnalysis.Copy Method


DraftAnalysis.Delete Method

DraftAnalysis.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes the draft analysis.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Methods > DraftAnalysis.Delete Method


DraftAnalysis.GetReferenceKey Method

DraftAnalysis.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Methods > DraftAnalysis.GetReferenceKey Method


DraftAnalysis Properties

DraftAnalysis Properties
Summary

The properties of the DraftAnalysis class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DisplayQuality | Property that gets and sets the resolution or surface quality for the color gradient or color bands that represent the draft analysis results.
EndAngle | Property that gets and sets the end angle for the draft analysis. When getting the value of the end angle, this property will return a double value in radians units.
Faces | Property that gets and sets the faces for the draft analysis.
GradientDisplay | Property that gets and sets whether the draft analysis results should be displayed as a color gradient. A value of True indicates that the draft analysis results should be displayed as a color gradient. A value of indicates that the draft analysis results should be displayed as discrete color bands.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent AnalysisManager object.
PullDirection | Property that gets and sets the object that specifies the direction in which the draft is applied.
PullDirectionReversed | Property that gets and sets whether the pull direction of the draft should be reversed. A value of True specifies that the pull direction should be reversed.
StartAngle | Property that gets and sets the start angle for the draft analysis.
Type | Property returning kDraftAnalysisObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties


DraftAnalysis.Application Property

DraftAnalysis.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.Application Property


DraftAnalysis.AttributeSets Property

DraftAnalysis.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.AttributeSets Property


DraftAnalysis.DisplayQuality Property

DraftAnalysis.DisplayQuality Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the resolution or surface quality for the color gradient or color bands that represent the draft analysis results.

Visual Basic
Property DisplayQuality() As long
Remarks

The value indicates a scale, the valid values are in the range of 0 and 10. This value actually represents the percentage value which is the type of value that is specified interactively through the command. For example, a value of 1 for this property indicates a value of 10 percent for the display quality.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.DisplayQuality Property


DraftAnalysis.EndAngle Property

DraftAnalysis.EndAngle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the end angle for the draft analysis. When getting the value of the end angle, this property will return a double value in radians units.

Visual Basic
Property EndAngle() As double
Remarks

When setting a value, the units of the specified value will be assumed to be radians. If a value in another units (e.g. degrees) or a string expression needs to be used, the methods of the UnitsOfMeasure object can be used to convert that value to the corresponding value in radians units.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.EndAngle Property


DraftAnalysis.Faces Property

DraftAnalysis.Faces Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the faces for the draft analysis.

Visual Basic
Property Faces() As ObjectCollection*
Remarks

The collection can contain a combination of Face and WorkSurface objects. In the case of WorkSurface objects, all the faces of the WorkSurface are used for the draft analysis.

The ObjectCollection returned by this property represents a copy of the faces used for the draft analysis and does not affect the draft analysis if its contents are modified. To change which faces are used for the draft analysis, you need to set this property to an ObjectCollection that contains the desired set of faces.

If all the faces of the part are used for the draft analysis, then this property will return Nothing. On the other hand, if a specific set of faces are used, then this property will return those faces.

When setting this property, if Nothing is specified, then all the faces of the part will be used for the draft analysis. On the other hand, if a specific set of faces need to be used, this property can be set to an ObjectCollection that contains those desired set of faces.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.Faces Property


DraftAnalysis.GradientDisplay Property

DraftAnalysis.GradientDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the draft analysis results should be displayed as a color gradient. A value of True indicates that the draft analysis results should be displayed as a color gradient. A value of indicates that the draft analysis results should be displayed as discrete color bands.

Visual Basic
Property GradientDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.GradientDisplay Property


DraftAnalysis.Name Property

DraftAnalysis.Name Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.Name Property


DraftAnalysis.Parent Property

DraftAnalysis.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent AnalysisManager object.

Visual Basic
Property Parent() As AnalysisManager**
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.Parent Property


DraftAnalysis.PullDirection Property

DraftAnalysis.PullDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the object that specifies the direction in which the draft is applied.

Visual Basic
Property PullDirection() As IDispatch*
Remarks

This can be any one of the following:

' Face ' planar, cylindrical, conical or torus

For a planar face, the normal direction of the face will be used as the pull direction. For a cylindrical, conical or torus face, the axis direction of the face will be used as the pull direction.

' Edge

' WorkPlane

' WorkAxis

Face and edges that belong to surfaces can also be used to specify the pull direction for the draft analysis.

The same limitations that apply for the pull direction when editing a draft analysis interactively through the command also apply when editing a draft analysis using the API.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.PullDirection Property


DraftAnalysis.PullDirectionReversed Property

DraftAnalysis.PullDirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the pull direction of the draft should be reversed. A value of True specifies that the pull direction should be reversed.

Visual Basic
Property PullDirectionReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.PullDirectionReversed Property


DraftAnalysis.StartAngle Property

DraftAnalysis.StartAngle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the start angle for the draft analysis.

Visual Basic
Property StartAngle() As double
Remarks

When getting the value of the start angle, this property will return a double value in radians units.

Also, when setting a value, the units of the specified value will be assumed to be radians. If a value in another units (e.g. degrees) or a string expression needs to be used, the methods of the UnitsOfMeasure object can be used to convert that value to the corresponding value in radians units.

You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.StartAngle Property


DraftAnalysis.Type Property

DraftAnalysis.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDraftAnalysisObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DraftAnalysis Interface > DraftAnalysis Properties > DraftAnalysis.Type Property


DraftingStandard Interface

DraftingStandard Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DraftingStandard object represent the currently applied drafting standard, and indicates whether the standard has been customized.

Class Hierarchy
Inventor::DraftingStandard
Visual Basic
Public Interface DraftingStandard
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDrawingDocument.ActiveStandard

You are here: Symbol Reference > Inventor Library > Objects > DraftingStandard Interface


DraftingStandard Properties

DraftingStandard Properties
Summary

The properties of the DraftingStandard class are listed here.

Properties
Name | Description
BaseStandard | Gets the base drafting standard associated with this particular object.
BuiltIn | Gets the Boolean indicating if this object represents a built-in drafting standard. If FALSE, then this object represents a standard that has been customized.
Name | Property that indicates the displayable name of this standard. No 'Set' allowed in Apprentice.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DraftingStandard Interface > DraftingStandard Properties


DraftingStandard.BaseStandard Property

DraftingStandard.BaseStandard Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the base drafting standard associated with this particular object.

Visual Basic
Property BaseStandard() As DraftingStandardEnum*
You are here: Symbol Reference > Inventor Library > Objects > DraftingStandard Interface > DraftingStandard Properties > DraftingStandard.BaseStandard Property


DraftingStandard.BuiltIn Property

DraftingStandard.BuiltIn Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Boolean indicating if this object represents a built-in drafting standard. If FALSE, then this object represents a standard that has been customized.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DraftingStandard Interface > DraftingStandard Properties > DraftingStandard.BuiltIn Property


DraftingStandard.Name Property

DraftingStandard.Name Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the displayable name of this standard. No 'Set' allowed in Apprentice.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DraftingStandard Interface > DraftingStandard Properties > DraftingStandard.Name Property


DraftingStandard.Type Property

DraftingStandard.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DraftingStandard Interface > DraftingStandard Properties > DraftingStandard.Type Property


DragContext Interface

DragContext Interface Available in Inventor Introduced in Inventor 2012
Summary

The DragContext object provides methods that allow a user to move an object similar to the standard Inventor Assembly Drag.

Class Hierarchy
Inventor::DragContext
Visual Basic
Public Interface DragContext
Inherits IDispatch
Remarks

The DragContext object returned is valid until either EndDrag or CancelDrag is called.

You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface


DragContext Methods

DragContext Methods
Summary

The methods of the DragContext class are listed here.

Methods
Methods
Name | Description
CancelDrag | Method called when the user wants to cancel the drag operation.
Drag | Method called to drag a part to the given position.
EndDrag | Method called when the drag is finished.
StartDrag | Method called at the beginning of the drag to initialize drag environment.
TryMove | Method that tries to position the object at the exact location given.
You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface > DragContext Methods


DragContext.CancelDrag Method

DragContext.CancelDrag Method Available in Inventor Introduced in Inventor 2012
Summary

Method called when the user wants to cancel the drag operation.

Visual Basic
Sub CancelDrag()
Remarks

After calling CancelDrag, all methods of DragContext are no longer available to call. You should match each CreateDragContext with either and EndDrag or CancelDrag call.

You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface > DragContext Methods > DragContext.CancelDrag Method


DragContext.Drag Method

DragContext.Drag Method Available in Inventor Introduced in Inventor 2012
Summary

Method called to drag a part to the given position.

Visual Basic
Sub Drag(ModelPosition As Point)
Parameters
Parameters | Description
ModelPosition | The Point parameter is the new position, usually defined by the mouse in model space, to drag the object.
Remarks

The Point parameter is the current position of the mouse in model space. This is the same as ModelPosition in OnDrag.

You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface > DragContext Methods > DragContext.Drag Method


DragContext.EndDrag Method

DragContext.EndDrag Method Available in Inventor Introduced in Inventor 2012
Summary

Method called when the drag is finished.

Visual Basic
Sub EndDrag()
Remarks

Use this call to commit the drag changes. After calling EndDrag, all methods of DragContext are no longer available to call. You should match each CreateDragContext with either and EndDrag or CancelDrag call.

You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface > DragContext Methods > DragContext.EndDrag Method


DragContext.StartDrag Method

DragContext.StartDrag Method Available in Inventor Introduced in Inventor 2012
Summary

Method called at the beginning of the drag to initialize drag environment.

Visual Basic
Sub StartDrag(ModelPosition As Point)
Parameters
Parameters | Description
ModelPosition | The Point parameter is the current position of the mouse in model space. This is usually the same as ModelPosition in OnDrag.
Remarks

This method must be called before any Drag or TryMove call.

You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface > DragContext Methods > DragContext.StartDrag Method


DragContext.TryMove Method

DragContext.TryMove Method Available in Inventor Introduced in Inventor 2012
Summary

Method that tries to position the object at the exact location given.

Visual Basic
Sub TryMove(NewPosition As Matrix, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
NewPosition | The new absolute transform to apply to the object.
Remarks

Returns false if object could not be placed at the exact transform given.

You are here: Symbol Reference > Inventor Library > Objects > DragContext Interface > DragContext Methods > DragContext.TryMove Method


DrawingBOM Interface

DrawingBOM Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOM object represents a locally stored BOM. This is the equivalent of the table displayed when the 'Attach Balloon From List' command in the context menu of a balloon is invoked.

Class Hierarchy
Inventor::DrawingBOM
Visual Basic
Public Interface DrawingBOM
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingBOMCell.Parent

DrawingBOMColumn.Parent

DrawingBOMRow.Parent

DrawingBOMs.Item

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface


DrawingBOM Properties

DrawingBOM Properties
Summary

The properties of the DrawingBOM class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
DrawingBOMColumns | Property that gets the DrawingBOMColumns collection object.
DrawingBOMRows | Property that gets the DrawingBOMRows collection object.
Level | Property that returns the type of numbering for the BOM.
Parent | Property that returns the parent DrawingDocument object.
ReferencedDocumentDescriptor | Property that gets the model document referenced by this DrawingBOM.
Type | Property returning kDrawingBOMObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties


DrawingBOM.Application Property

DrawingBOM.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.Application Property


DrawingBOM.DrawingBOMColumns Property

DrawingBOM.DrawingBOMColumns Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the DrawingBOMColumns collection object.

Visual Basic
Property DrawingBOMColumns() As DrawingBOMColumns**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.DrawingBOMColumns Property


DrawingBOM.DrawingBOMRows Property

DrawingBOM.DrawingBOMRows Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the DrawingBOMRows collection object.

Visual Basic
Property DrawingBOMRows() As DrawingBOMRows**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.DrawingBOMRows Property


DrawingBOM.Level Property

DrawingBOM.Level Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the type of numbering for the BOM.

Visual Basic
Property Level() As PartsListLevelEnum*
Remarks

Possible values are kStructured, kStructuredAllLevels and kPartsOnly.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.Level Property


DrawingBOM.Parent Property

DrawingBOM.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent DrawingDocument object.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.Parent Property


DrawingBOM.ReferencedDocumentDescriptor Property

DrawingBOM.ReferencedDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the model document referenced by this DrawingBOM.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.ReferencedDocumentDescriptor Property


DrawingBOM.Type Property

DrawingBOM.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOM Interface > DrawingBOM Properties > DrawingBOM.Type Property


DrawingBOMCell Interface

DrawingBOMCell Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOMCell object represents a cell within the drawing BOM.

Class Hierarchy
Inventor::DrawingBOMCell
Visual Basic
Public Interface DrawingBOMCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingBOMRow.Item

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface


DrawingBOMCell Properties

DrawingBOMCell Properties
Summary

The properties of the DrawingBOMCell class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Parent | Property that returns the parent DrawingBOM object.
Static | Property that returns whether or not the contents of this cell are static.
Type | Property returning kDrawingBOMCellObject indicating this object's type.
Value | Property that returns the value of the cell.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface > DrawingBOMCell Properties


DrawingBOMCell.Application Property

DrawingBOMCell.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface > DrawingBOMCell Properties > DrawingBOMCell.Application Property


DrawingBOMCell.Parent Property

DrawingBOMCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent DrawingBOM object.

Visual Basic
Property Parent() As DrawingBOM**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface > DrawingBOMCell Properties > DrawingBOMCell.Parent Property


DrawingBOMCell.Static Property

DrawingBOMCell.Static Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether or not the contents of this cell are static.

Visual Basic
Property Static() As VARIANT_BOOL*
Remarks

The contents of a static cell are never automatically updated. Also, when the value of a cell is overridden, the cell is marked as static.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface > DrawingBOMCell Properties > DrawingBOMCell.Static Property


DrawingBOMCell.Type Property

DrawingBOMCell.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMCellObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface > DrawingBOMCell Properties > DrawingBOMCell.Type Property


DrawingBOMCell.Value Property

DrawingBOMCell.Value Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the value of the cell.

Visual Basic
Property Value() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMCell Interface > DrawingBOMCell Properties > DrawingBOMCell.Value Property


DrawingBOMColumn Interface

DrawingBOMColumn Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOMColumn object represents a column within the drawing BOM.

Class Hierarchy
Inventor::DrawingBOMColumn
Visual Basic
Public Interface DrawingBOMColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingBOMColumns.Item

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface


DrawingBOMColumn Methods

DrawingBOMColumn Methods
Summary

The methods of the DrawingBOMColumn class are listed here.

Methods
Methods
Name | Description
GetFilePropertyId | Method that returns the id of the property associated with the column. This method will return an error if the PropertyType property does not return a value of kFilePropertyType.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Methods


DrawingBOMColumn.GetFilePropertyId Method

DrawingBOMColumn.GetFilePropertyId Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the id of the property associated with the column. This method will return an error if the PropertyType property does not return a value of kFilePropertyType.

Visual Basic
Sub GetFilePropertyId(ByRef PropSetId As String, ByRef PropId As long)
Parameters
Parameters | Description
PropSetId | Returned String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set.
PropId | Returned Long that specifies the property id. This value is unique within the specified property set.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Methods > DrawingBOMColumn.GetFilePropertyId Method


DrawingBOMColumn Properties

DrawingBOMColumn Properties
Summary

The properties of the DrawingBOMColumn class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
CustomPropertyName | Property that returns the name of the custom property associated with this column.
Parent | Property that returns the parent DrawingBOM object.
PropertyType | Property that returns the property type associated with this column.
Title | Property that returns the title of the column.
Type | Property returning kDrawingBOMColumnObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties


DrawingBOMColumn.Application Property

DrawingBOMColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties > DrawingBOMColumn.Application Property


DrawingBOMColumn.CustomPropertyName Property

DrawingBOMColumn.CustomPropertyName Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the name of the custom property associated with this column.

Visual Basic
Property CustomPropertyName() As BSTR*
Remarks

This property will return a null string if the PropertyType property does not return a value of kCustomPropertyType.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties > DrawingBOMColumn.CustomPropertyName Property


DrawingBOMColumn.Parent Property

DrawingBOMColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent DrawingBOM object.

Visual Basic
Property Parent() As DrawingBOM**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties > DrawingBOMColumn.Parent Property


DrawingBOMColumn.PropertyType Property

DrawingBOMColumn.PropertyType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the property type associated with this column.

Visual Basic
Property PropertyType() As PropertyTypeEnum*
Remarks

If this property returns kFilePropertyType, the GetFilePropertyId method returns the identity of the file property. If this property returns kCustomPropertyType, use the CustomPropertyName property to get the name of the custom property.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties > DrawingBOMColumn.PropertyType Property


DrawingBOMColumn.Title Property

DrawingBOMColumn.Title Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the title of the column.

Visual Basic
Property Title() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties > DrawingBOMColumn.Title Property


DrawingBOMColumn.Type Property

DrawingBOMColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMColumnObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumn Interface > DrawingBOMColumn Properties > DrawingBOMColumn.Type Property


DrawingBOMColumns Interface

DrawingBOMColumns Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOMColumns collection object represents the collection of all columns of a drawing BOM.

Class Hierarchy
Inventor::DrawingBOMColumns
Visual Basic
Public Interface DrawingBOMColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingBOM.DrawingBOMColumns

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface


DrawingBOMColumns Methods

DrawingBOMColumns Methods
Summary

The methods of the DrawingBOMColumns class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified DrawingBOMColumn object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface > DrawingBOMColumns Methods


DrawingBOMColumns.Item Method

DrawingBOMColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified DrawingBOMColumn object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DrawingBOMColumn*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DrawingBOMColumn to return. This can be either a Long value indicating the index of the item in the collection or a String that corresponds to the title of a column. If an out of range index or a non-existent column title is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface > DrawingBOMColumns Methods > DrawingBOMColumns.Item Method


DrawingBOMColumns Properties

DrawingBOMColumns Properties
Summary

The properties of the DrawingBOMColumns class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDrawingBOMColumnsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface > DrawingBOMColumns Properties


DrawingBOMColumns.Application Property

DrawingBOMColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface > DrawingBOMColumns Properties > DrawingBOMColumns.Application Property


DrawingBOMColumns.Count Property

DrawingBOMColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface > DrawingBOMColumns Properties > DrawingBOMColumns.Count Property


DrawingBOMColumns.Type Property

DrawingBOMColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMColumnsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMColumns Interface > DrawingBOMColumns Properties > DrawingBOMColumns.Type Property


DrawingBOMRow Interface

DrawingBOMRow Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOMRow object represents a row within the drawing BOM.

Class Hierarchy
Inventor::DrawingBOMRow
Visual Basic
Public Interface DrawingBOMRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BalloonValueSet.ReferencedRow

DrawingBOMRows.Item

See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface


DrawingBOMRow Methods

DrawingBOMRow Methods
Summary

The methods of the DrawingBOMRow class are listed here.

Methods
Methods
Name | Description
Item |
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Methods


DrawingBOMRow.Item Method

DrawingBOMRow.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DrawingBOMCell*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DrawingBOMCell to return. This can be either a numeric value indicating the index of the item in the collection, a string indicating the title of a column, or a DrawingBOMColumn object. If an out of range index, a non-existent column title, or an invalid DrawingBOMColumn object is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Methods > DrawingBOMRow.Item Method


DrawingBOMRow Properties

DrawingBOMRow Properties
Summary

The properties of the DrawingBOMRow class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Ballooned | Property that returns whether the item represented by this row in the drawing BOM has been ballooned in the drawing.
BOMRow | Property that returns the corresponding BOMRow from the model.
Count | Property that specifies the number of items in the collection.
Custom | Property that returns whether this row is a custom row.
Parent | Property that returns the parent DrawingBOM object.
Type | Property returning kDrawingBOMRowObject indicating this object's type.
Virtual | Property that returns whether this row references a virtual component in the assembly.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties


DrawingBOMRow.Application Property

DrawingBOMRow.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Application Property


DrawingBOMRow.Ballooned Property

DrawingBOMRow.Ballooned Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether the item represented by this row in the drawing BOM has been ballooned in the drawing.

Visual Basic
Property Ballooned() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Ballooned Property


DrawingBOMRow.BOMRow Property

DrawingBOMRow.BOMRow Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the corresponding BOMRow from the model.

Visual Basic
Property BOMRow() As BOMRow**
Remarks

This property returns Nothing if this is a custom row (i.e. the Custom property returns True).

See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.BOMRow Property


DrawingBOMRow.Count Property

DrawingBOMRow.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Count Property


DrawingBOMRow.Custom Property

DrawingBOMRow.Custom Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether this row is a custom row.

Visual Basic
Property Custom() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Custom Property


DrawingBOMRow.Parent Property

DrawingBOMRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent DrawingBOM object.

Visual Basic
Property Parent() As DrawingBOM**
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Parent Property


DrawingBOMRow.Type Property

DrawingBOMRow.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMRowObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Type Property


DrawingBOMRow.Virtual Property

DrawingBOMRow.Virtual Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether this row references a virtual component in the assembly.

Visual Basic
Property Virtual() As VARIANT_BOOL*
See Also

Find component referenced by balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRow Interface > DrawingBOMRow Properties > DrawingBOMRow.Virtual Property


DrawingBOMRows Interface

DrawingBOMRows Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOMRows collection object represents the collection of all rows of a drawing BOM.

Class Hierarchy
Inventor::DrawingBOMRows
Visual Basic
Public Interface DrawingBOMRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingBOM.DrawingBOMRows

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface


DrawingBOMRows Methods

DrawingBOMRows Methods
Summary

The methods of the DrawingBOMRows class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified DrawingBOMRow object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface > DrawingBOMRows Methods


DrawingBOMRows.Item Method

DrawingBOMRows.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified DrawingBOMRow object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DrawingBOMRow*)
Parameters
Parameters | Description
index | Input Long value that specifies the DrawingBOMRow to return. This is a numeric value indicating the index of the item in the collection. If an out of range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface > DrawingBOMRows Methods > DrawingBOMRows.Item Method


DrawingBOMRows Properties

DrawingBOMRows Properties
Summary

The properties of the DrawingBOMRows class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDrawingBOMRowsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface > DrawingBOMRows Properties


DrawingBOMRows.Application Property

DrawingBOMRows.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface > DrawingBOMRows Properties > DrawingBOMRows.Application Property


DrawingBOMRows.Count Property

DrawingBOMRows.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface > DrawingBOMRows Properties > DrawingBOMRows.Count Property


DrawingBOMRows.Type Property

DrawingBOMRows.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMRowsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMRows Interface > DrawingBOMRows Properties > DrawingBOMRows.Type Property


DrawingBOMs Interface

DrawingBOMs Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingBOMs collection object returns the collection of all locally stored BOMs in the drawing document.

Class Hierarchy
Inventor::DrawingBOMs
Visual Basic
Public Interface DrawingBOMs
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.DrawingBOMs

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface


DrawingBOMs Methods

DrawingBOMs Methods
Summary

The methods of the DrawingBOMs class are listed here.

Methods
Methods
Name | Description
IsDrawingBOMDefined | Method that returns whether BOM properties have been defined in the drawing for the input model.
Item | Property that returns the specified DrawingBOM object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Methods


DrawingBOMs.IsDrawingBOMDefined Method

DrawingBOMs.IsDrawingBOMDefined Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns whether BOM properties have been defined in the drawing for the input model.

Visual Basic
Sub IsDrawingBOMDefined(FullFileName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies a model document.
Remarks

If the method returns False, it indicates that no balloons or parts lists have been created in the drawing document based on the input model. If the method returns True, balloons and/or parts list have been created based on the model and the various BOM properties & numbering schemes should not be specified when creating additional balloons or parts lists.

See Also

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Methods > DrawingBOMs.IsDrawingBOMDefined Method


DrawingBOMs.Item Method

DrawingBOMs.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified DrawingBOM object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DrawingBOM*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DrawingBOM to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the FullFileName of the model document referenced by the DrawingBOM. If the input is an out of range index or the file name of a model for which a DrawingBOM has not yet been created, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Methods > DrawingBOMs.Item Method


DrawingBOMs Properties

DrawingBOMs Properties
Summary

The properties of the DrawingBOMs class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDrawingBOMsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Properties


DrawingBOMs.Application Property

DrawingBOMs.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Properties > DrawingBOMs.Application Property


DrawingBOMs.Count Property

DrawingBOMs.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Properties > DrawingBOMs.Count Property


DrawingBOMs.Type Property

DrawingBOMs.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDrawingBOMsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingBOMs Interface > DrawingBOMs Properties > DrawingBOMs.Type Property


DrawingCurve Interface

DrawingCurve Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DrawingCurve object represents a curve within a drawing view that resulted from a model (including sketch entities).

Class Hierarchy
Inventor::DrawingCurve
Visual Basic
Public Interface DrawingCurve
Inherits IDispatch
Remarks

DrawingCurve and DrawingCurveSegment objects may become invalid (and will need to be reaquired) after a drawing view update or other recompute.

Notes

Members through which this object may be accessed include:

BendNote.BendEdge

DrawingCurveSegment.Parent

DrawingCurvesEnumerator.Item

DrawingView.AuxiliaryOrientationEdge

ChamferNote.ChamferEdgeOne

ChamferNote.ChamferEdgeTwo

HoleThreadNote.Edge

HoleTableRow.ReferencedHole

See Also

Chain dimensions sets sample

Create thread note sample

create punch note sample

Create bend note sample

Baseline dimension sets sample

Create sketched symbol and leader sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface


DrawingCurve Methods

DrawingCurve Methods
Summary

The methods of the DrawingCurve class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Methods


DrawingCurve.GetCustomLineType Method

DrawingCurve.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Methods > DrawingCurve.GetCustomLineType Method


DrawingCurve.SetCustomLineType Method

DrawingCurve.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Methods > DrawingCurve.SetCustomLineType Method


DrawingCurve Properties

DrawingCurve Properties
Summary

The properties of the DrawingCurve class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CenterPoint | Property that returns the center point of the curve in sheet space. This property returns the center for arcs and circles and Nothing if the curve does not have a center.
Color | Property that gets and sets the color for the curve. Setting the property to Nothing restores the curve to the color defined by the layer on which this curve resides.
CurveType | Property that returns the type of the underlying curve geometry that this curve is defined by.
EdgeType | Property that returns the edge type of this curve. Possible return values are kThreadEdge, kBendUpEdge, kBendDownEdge, kBendExtentEdge, kPunchDownEdge, kPunchUpEdge, kTangentEdge, kContourRollEdge, and kUnknownEdge.
EndPoint | Property that returns the end point of the curve in sheet space. This property returns Nothing for circular curves.
Evaluator2D | Property that returns the Curve2dEvaluator object for this curve in sheet space.
Evaluator3D | Property that returns the CurveEvaluator object for this curve in 3d model view space.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
MidPoint | Property that returns the mid point of the curve in sheet space. This property returns the mid point for linear curves and arcs.
ModelGeometry | Property that returns the corresponding geometry from the model. This property returns Nothing in the case the model is not available.
Parent | Property that returns the parent drawing view of the curve.
ProjectedCurveType | Property that returns the curve type of the drawing curve projected onto the sheet. For instance, if a circular drawing curve shows up as a linear curve on the sheet, this property returns kLineSegmentCurve2d.
Segments | Property that returns the collection of the selectable segments representing this curve.
StartPoint | Property that returns the start point of the curve in sheet space. This property returns Nothing for circular curves.
Type | Property returning kDrawingCurveObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties


DrawingCurve.Application Property

DrawingCurve.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Application Property


DrawingCurve.CenterPoint Property

DrawingCurve.CenterPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the center point of the curve in sheet space. This property returns the center for arcs and circles and Nothing if the curve does not have a center.

Visual Basic
Property CenterPoint() As Point2d**
See Also

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.CenterPoint Property


DrawingCurve.Color Property

DrawingCurve.Color Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color for the curve. Setting the property to Nothing restores the curve to the color defined by the layer on which this curve resides.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Color Property


DrawingCurve.CurveType Property

DrawingCurve.CurveType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the type of the underlying curve geometry that this curve is defined by.

Visual Basic
Property CurveType() As CurveTypeEnum*
See Also

Create ordinate dimension sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.CurveType Property


DrawingCurve.EdgeType Property

DrawingCurve.EdgeType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the edge type of this curve. Possible return values are kThreadEdge, kBendUpEdge, kBendDownEdge, kBendExtentEdge, kPunchDownEdge, kPunchUpEdge, kTangentEdge, kContourRollEdge, and kUnknownEdge.

Visual Basic
Property EdgeType() As DrawingEdgeTypeEnum*
See Also

Create thread note sample

create punch note sample

Create bend note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.EdgeType Property


DrawingCurve.EndPoint Property

DrawingCurve.EndPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the end point of the curve in sheet space. This property returns Nothing for circular curves.

Visual Basic
Property EndPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.EndPoint Property


DrawingCurve.Evaluator2D Property

DrawingCurve.Evaluator2D Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Curve2dEvaluator object for this curve in sheet space.

Visual Basic
Property Evaluator2D() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Evaluator2D Property


DrawingCurve.Evaluator3D Property

DrawingCurve.Evaluator3D Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the CurveEvaluator object for this curve in 3d model view space.

Visual Basic
Property Evaluator3D() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Evaluator3D Property


DrawingCurve.LineType Property

DrawingCurve.LineType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.LineType Property


DrawingCurve.LineWeight Property

DrawingCurve.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.LineWeight Property


DrawingCurve.MidPoint Property

DrawingCurve.MidPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the mid point of the curve in sheet space. This property returns the mid point for linear curves and arcs.

Visual Basic
Property MidPoint() As Point2d**
See Also

Create sketched symbol and leader sample

Create a feature control frame symbol sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.MidPoint Property


DrawingCurve.ModelGeometry Property

DrawingCurve.ModelGeometry Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the corresponding geometry from the model. This property returns Nothing in the case the model is not available.

Visual Basic
Property ModelGeometry() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.ModelGeometry Property


DrawingCurve.Parent Property

DrawingCurve.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent drawing view of the curve.

Visual Basic
Property Parent() As DrawingView**
See Also

Chain dimensions sets sample

Baseline dimension sets sample

Create sketched symbol and leader sample

Create ordinate dimension sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Parent Property


DrawingCurve.ProjectedCurveType Property

DrawingCurve.ProjectedCurveType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the curve type of the drawing curve projected onto the sheet. For instance, if a circular drawing curve shows up as a linear curve on the sheet, this property returns kLineSegmentCurve2d.

Visual Basic
Property ProjectedCurveType() As Curve2dTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.ProjectedCurveType Property


DrawingCurve.Segments Property

DrawingCurve.Segments Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the collection of the selectable segments representing this curve.

Visual Basic
Property Segments() As DrawingCurveSegments**
Remarks

Segments are exclusively owned by their curve (they are actually a subpart of the curve), and are never shared between sources. Drawing curves are exclusive to a source. Logically, you could think of overlapping curves as being shared, but really when multiple curves overlap, Inventor occludes or removes redundant overlapping curves, leaving the topmost curve. Turning on hidden curve display enables the first layer of occluded curves.

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Segments Property


DrawingCurve.StartPoint Property

DrawingCurve.StartPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the start point of the curve in sheet space. This property returns Nothing for circular curves.

Visual Basic
Property StartPoint() As Point2d**
See Also

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.StartPoint Property


DrawingCurve.Type Property

DrawingCurve.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDrawingCurveObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurve Interface > DrawingCurve Properties > DrawingCurve.Type Property


DrawingCurveSegment Interface

DrawingCurveSegment Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DrawingCurveSegment object represents a single segment of a drawing curve.

Class Hierarchy
Inventor::DrawingCurveSegment
Visual Basic
Public Interface DrawingCurveSegment
Inherits IDispatch
Remarks

DrawingCurve and DrawingCurveSegment objects may become invalid (and will need to be reaquired) after a drawing view update or other recompute.

Notes

Members through which this object may be accessed include:

DrawingCurveSegments.Item

See Also

Chain dimensions sets sample

Create thread note sample

create punch note sample

Create bend note sample

Baseline dimension sets sample

Create sketched symbol and leader sample

Create sketched symbol and leader sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface


DrawingCurveSegment Properties

DrawingCurveSegment Properties
Summary

The properties of the DrawingCurveSegment class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EndPoint | Property that returns the end point of the curve segment in sheet space.
HiddenLine | Property that returns whether this segment represents the hidden portion of a line. This is only applicable for drawing views with hidden lines and always returns False otherwise.
Layer | Property that gets and sets the layer associated with this object.
Parent | Property that returns the parent drawing curve.
StartPoint | Property that returns the start point of the curve segment in sheet space.
Type | Property returning kDrawingCurveSegmentObject indicating this objects type.
Visible | Property that gets and sets whether the curve segment is visible.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties


DrawingCurveSegment.Application Property

DrawingCurveSegment.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.Application Property


DrawingCurveSegment.EndPoint Property

DrawingCurveSegment.EndPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the end point of the curve segment in sheet space.

Visual Basic
Property EndPoint() As Point2d**
Remarks

This property returns Nothing for circular segments.

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.EndPoint Property


DrawingCurveSegment.HiddenLine Property

DrawingCurveSegment.HiddenLine Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether this segment represents the hidden portion of a line. This is only applicable for drawing views with hidden lines and always returns False otherwise.

Visual Basic
Property HiddenLine() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.HiddenLine Property


DrawingCurveSegment.Layer Property

DrawingCurveSegment.Layer Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.Layer Property


DrawingCurveSegment.Parent Property

DrawingCurveSegment.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent drawing curve.

Visual Basic
Property Parent() As DrawingCurve**
See Also

Chain dimensions sets sample

Baseline dimension sets sample

Create sketched symbol and leader sample

Create a feature control frame symbol sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.Parent Property


DrawingCurveSegment.StartPoint Property

DrawingCurveSegment.StartPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the start point of the curve segment in sheet space.

Visual Basic
Property StartPoint() As Point2d**
Remarks

This property returns Nothing for circular segments.

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.StartPoint Property


DrawingCurveSegment.Type Property

DrawingCurveSegment.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDrawingCurveSegmentObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.Type Property


DrawingCurveSegment.Visible Property

DrawingCurveSegment.Visible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the curve segment is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegment Interface > DrawingCurveSegment Properties > DrawingCurveSegment.Visible Property


DrawingCurveSegments Interface

DrawingCurveSegments Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DrawingCurveSegments object provides access to the segments of a drawing curve.

Class Hierarchy
Inventor::DrawingCurveSegments
Visual Basic
Public Interface DrawingCurveSegments
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingCurve.Segments

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface


DrawingCurveSegments Methods

DrawingCurveSegments Methods
Summary

The methods of the DrawingCurveSegments class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified DrawingCurveSegment object from the collection. This is the default property of the DrawingCurveSegments collection object.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface > DrawingCurveSegments Methods


DrawingCurveSegments.Item Method

DrawingCurveSegments.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified DrawingCurveSegment object from the collection. This is the default property of the DrawingCurveSegments collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DrawingCurveSegment*)
Parameters
Parameters | Description
index | Value that specifies the object to return.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface > DrawingCurveSegments Methods > DrawingCurveSegments.Item Method


DrawingCurveSegments Properties

DrawingCurveSegments Properties
Summary

The properties of the DrawingCurveSegments class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDrawingCurveSegmentsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface > DrawingCurveSegments Properties


DrawingCurveSegments.Application Property

DrawingCurveSegments.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface > DrawingCurveSegments Properties > DrawingCurveSegments.Application Property


DrawingCurveSegments.Count Property

DrawingCurveSegments.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface > DrawingCurveSegments Properties > DrawingCurveSegments.Count Property


DrawingCurveSegments.Type Property

DrawingCurveSegments.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDrawingCurveSegmentsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurveSegments Interface > DrawingCurveSegments Properties > DrawingCurveSegments.Type Property


DrawingCurvesEnumerator Interface

DrawingCurvesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The DrawingCurvesEnumerator object provides access to drawing view curves.

Class Hierarchy
Inventor::DrawingCurvesEnumerator
Visual Basic
Public Interface DrawingCurvesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingView.DrawingCurves

You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface


DrawingCurvesEnumerator Methods

DrawingCurvesEnumerator Methods
Summary

The methods of the DrawingCurvesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified DrawingCurve object from the collection. This is the default property of the DrawingCurves collection object.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface > DrawingCurvesEnumerator Methods


DrawingCurvesEnumerator.Item Method

DrawingCurvesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified DrawingCurve object from the collection. This is the default property of the DrawingCurves collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DrawingCurve*)
Parameters
Parameters | Description
index | Value that specifies the object to return.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface > DrawingCurvesEnumerator Methods > DrawingCurvesEnumerator.Item Method


DrawingCurvesEnumerator Properties

DrawingCurvesEnumerator Properties
Summary

The properties of the DrawingCurvesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kDrawingCurvesEnumeratorObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface > DrawingCurvesEnumerator Properties


DrawingCurvesEnumerator.Application Property

DrawingCurvesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface > DrawingCurvesEnumerator Properties > DrawingCurvesEnumerator.Application Property


DrawingCurvesEnumerator.Count Property

DrawingCurvesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface > DrawingCurvesEnumerator Properties > DrawingCurvesEnumerator.Count Property


DrawingCurvesEnumerator.Type Property

DrawingCurvesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kDrawingCurvesEnumeratorObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingCurvesEnumerator Interface > DrawingCurvesEnumerator Properties > DrawingCurvesEnumerator.Type Property


DrawingDimension Interface

DrawingDimension Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingDimension object is the base class for all dimensions placed on a sheet.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
    Inventor::OrdinateDimension
Visual Basic
Public Interface DrawingDimension
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionText.Parent

DrawingDimensions.Item

See Also

Aligning drawing dimensions sample

Center Dimension Text sample

Example

"Dimensions - editing Example "

This sample demonstrates the editing of sheet dimensions and the associated dimension style.

To run this sample, open a drawing document that has one or more drawing views on the active sheet and add various sheet dimensions to it.

Public Sub EditDrawingDimensions()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    Dim counter As Long
    counter = 1

    Dim oDrawingDim As DrawingDimension
    For Each oDrawingDim In oSheet.DrawingDimensions

        ' Add some formatted text to all dimensions on the sheet.
        oDrawingDim.Text.FormattedText = " (Metric)"
        counter = counter + 1

    Next

    ' Set a reference to the first general dimension in the collection.
    Dim oGeneralDim As GeneralDimension
    Set oGeneralDim = oSheet.DrawingDimensions.GeneralDimensions.Item(1)

    ' Set a reference to the dimension style of that dimension.
    Dim oDimStyle As DimensionStyle
    Set oDimStyle = oGeneralDim.Style

    ' Modify some properties of the dimension style.
    ' This will modify all dimensions that use this style.
    oDimStyle.LinearPrecision = kFourDecimalPlacesLinearPrecision
    oDimStyle.AngularPrecision = kFourDecimalPlacesAngularPrecision
    oDimStyle.LeadingZeroDisplay = False
    oDimStyle.Tolerance.SetToSymmetric (0.02)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface


DrawingDimension Methods

DrawingDimension Methods
Summary

The methods of the DrawingDimension class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the DrawingDimension.
GetInspectionDimensionData | Method that returns the data associated with an inspection dimension. This method returns an error if the IsInspectionDimension property returns False.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetInspectionDimensionData | Method that sets the data associated with an inspection dimension. This method automatically sets the IsInspectionDimension property to True, if it isn't already.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Methods


DrawingDimension.Delete Method

DrawingDimension.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes the DrawingDimension.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Methods > DrawingDimension.Delete Method


DrawingDimension.GetInspectionDimensionData Method

DrawingDimension.GetInspectionDimensionData Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the data associated with an inspection dimension. This method returns an error if the IsInspectionDimension property returns False.

Visual Basic
Sub GetInspectionDimensionData(ByRef Shape As InspectionDimensionShapeEnum, ByRef Label As String, ByRef Rate As String)
Parameters
Parameters | Description
Shape | Output InspectionDimensionShapeEnum that indicates the border shape surrounding the inspection dimension text. Valid return values are kNoInspectionBorder, kAngularEndsInspectionBorder and kRoundedEndsInspectionBorder.
Label | Output string that returns the text placed left of the dimension value. The string can contain symbols specified using the StyleOverride tag.
Rate | Output string that returns the text (typically a percentage value) placed to the right of the dimension value. The string can contain symbols specified using the StyleOverride tag.
Remarks

An example of a StyleOverride tag in this context.

'<StyleOverride Font='AIGDT'>m</StyleOverride>'

will result in the symbol

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Methods > DrawingDimension.GetInspectionDimensionData Method


DrawingDimension.GetReferenceKey Method

DrawingDimension.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Methods > DrawingDimension.GetReferenceKey Method


DrawingDimension.SetInspectionDimensionData Method

DrawingDimension.SetInspectionDimensionData Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the data associated with an inspection dimension. This method automatically sets the IsInspectionDimension property to True, if it isn't already.

Visual Basic
Sub SetInspectionDimensionData(ByRef Shape As [defaultvalue(kNoInspectionBorder)] InspectionDimensionShapeEnum, ByRef Label As [defaultvalue("")] BSTR, ByRef Rate As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
Shape | Optional input InspectionDimensionShapeEnum that specifies the border shape surrounding the inspection dimension text. Valid values are kNoInspectionBorder, kAngularEndsInspectionBorder and kRoundedEndsInspectionBorder. If not specified, kNoInspectionBorder is used.
Label | Optional input string that specifies the text placed left of the dimension value. The string can contain symbols specified using the StyleOverride tag.
Rate | Optional input string that specifies the text (typically a percentage value) placed to the right of the dimension value. The string can contain symbols specified using the StyleOverride tag.
Remarks

An example of a StyleOverride tag in this context.

'<StyleOverride Font='AIGDT'>m</StyleOverride>'

will result in the symbol

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Methods > DrawingDimension.SetInspectionDimensionData Method


DrawingDimension Properties

DrawingDimension Properties
Summary

The properties of the DrawingDimension class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Attached | Indicates whether this dimension is attached to anything. If not, it is considered orphaned and can be removed.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DimensionLine | Property that returns the dimension line geometry of the dimension.
HideValue | Property that gets and sets whether to display the dimension value.
IsInspectionDimension | Property that gets and sets whether this is an inspection dimension.
Layer | Property that gets and sets the layer associated with this object.
ModelValue | Property that gets the dimension value as defined in the model or as measured in the drawing.
ModelValueOverridden | Property that gets and sets whether the model value is overridden for the dimension. Setting the OverrideModelValue property automatically toggles this property to True.
OverrideModelValue | Property that gets and sets the display value for the dimension. Changing the override model value does not change the dimension value in the model.
Parent | Property that returns the parent sheet of the object.
Precision | Property that gets and sets the number of decimal places displayed for this dimension.
Text | Property that indicates the text of the dimension.
Tolerance | Property that returns the Tolerance object associated with this dimension.
TolerancePrecision | Property that gets and sets the number of decimal places displayed for this tolerance.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties


DrawingDimension.Application Property

DrawingDimension.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Application Property


DrawingDimension.Attached Property

DrawingDimension.Attached Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Indicates whether this dimension is attached to anything. If not, it is considered orphaned and can be removed.

Visual Basic
Property Attached() As VARIANT_BOOL*
Example

"Find and remove unattached dimensions."

This sample finds and deletes all unattached drawing dimensions on the active sheet in a drawing. Before you run the sample, have a drawing document open that contains several drawing dimensions including unattached (sick) ones.

Public Sub DeleteUnattachedDimensions()

    ' Set a reference to the active drawing document
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet
    Dim oSheet As Sheet
    Set oSheet = oDoc.ActiveSheet

    Dim oDrawingDim As DrawingDimension

    ' Iterate over all dimensions in the drawing
    ' and delete unattached (sick) dimensions.

    For Each oDrawingDim In oSheet.DrawingDimensions
        If oDrawingDim.Attached = False Then
            Call oDrawingDim.Delete
        End If
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Attached Property


DrawingDimension.AttributeSets Property

DrawingDimension.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.AttributeSets Property


DrawingDimension.DimensionLine Property

DrawingDimension.DimensionLine Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the dimension line geometry of the dimension.

Visual Basic
Property DimensionLine() As IDispatch**
Remarks

Following are the possible return values based on the dimension type:

Dimension Type | Object(s) returned by the property
Projected linear, diameter and radius general dimensions | LineSegment2d in sheet space
True linear, diameter and radius general dimensions (in iso-views) | LineSegment in model space
Projected angular general dimension | Arc2d in sheet space
True angular general dimension (in iso-views) | Arc3d in model space
Ordinate dimension | Polyline2d in sheet space
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.DimensionLine Property


DrawingDimension.HideValue Property

DrawingDimension.HideValue Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether to display the dimension value.

Visual Basic
Property HideValue() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.HideValue Property


DrawingDimension.IsInspectionDimension Property

DrawingDimension.IsInspectionDimension Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether this is an inspection dimension.

Visual Basic
Property IsInspectionDimension() As VARIANT_BOOL
Remarks

Inspection dimensions are used during the quality control process. They are formatted specifically to indicate which dimensions must be checked before accepting a part. The dimension includes a label and an inspection rate, which can be obtained and set using the GetInspectionDimensionData and SetInspectionDimensionData methods respectively.

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.IsInspectionDimension Property


DrawingDimension.Layer Property

DrawingDimension.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Layer Property


DrawingDimension.ModelValue Property

DrawingDimension.ModelValue Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the dimension value as defined in the model or as measured in the drawing.

Visual Basic
Property ModelValue() As double*
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.ModelValue Property


DrawingDimension.ModelValueOverridden Property

DrawingDimension.ModelValueOverridden Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the model value is overridden for the dimension. Setting the OverrideModelValue property automatically toggles this property to True.

Visual Basic
Property ModelValueOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.ModelValueOverridden Property


DrawingDimension.OverrideModelValue Property

DrawingDimension.OverrideModelValue Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the display value for the dimension. Changing the override model value does not change the dimension value in the model.

Visual Basic
Property OverrideModelValue() As double
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.OverrideModelValue Property


DrawingDimension.Parent Property

DrawingDimension.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent sheet of the object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Parent Property


DrawingDimension.Precision Property

DrawingDimension.Precision Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the number of decimal places displayed for this dimension.

Visual Basic
Property Precision() As long
Remarks

Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Precision Property


DrawingDimension.Text Property

DrawingDimension.Text Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the text of the dimension.

Visual Basic
Property Text() As DimensionText*
Example

"Aligning drawing dimensions"

This sample demonstrates aligning the selected drawing dimensions along a horizontal or vertical axis. The first dimension selected defines the origin of the axis. A drawing document must be open and at least two dimensions selected.

Public Sub DimensionAlign()
Dim oDrawDoc As DrawingDocument
Set oDrawDoc = ThisApplication.ActiveDocument

' Determine if there are any dimensions in the select set.
Dim oSelectSet As SelectSet
Set oSelectSet = oDrawDoc.SelectSet
Dim colDimensions As New Collection
Dim i As Long
For i = 1 To oSelectSet.Count
  If Typeof oSelectSet.Item(i) Is DrawingDimension Then
    ' Add any dimensions to the collection. We need to save them
    ' in something besides the selection set because once we start
    ' manipulating them the select set will be cleared.
    colDimensions.Add oSelectSet.Item(i)
  End If
Next

If colDimensions.Count < 2 Then
  MsgBox "You must select at least 2 dimensions for this operation."
  Exit Sub
End If

' Ask the user if he/she wants vertical or horizontal alignment.
Dim bHorizontal As Boolean
  If MsgBox("Do you want horizontal alignment? (Selecting ""No"" results in vertical alignment)", vbQuestion + vbYesNo, "Align Dimensions") = vbYes Then
    bHorizontal = True
  Else
    bHorizontal = False
  End If

For i = 1 To colDimensions.Count
  Dim oDimension As DrawingDimension
  Set oDimension = colDimensions.Item(i)

  If i = 1 Then
    ' Get the position of the first dimension text. This is
    ' the position the other dimensions will be aligned to.
    Dim dPosition As Double
    If bHorizontal Then
      dPosition = oDimension.Text.Origin.Y
    Else
      dPosition = oDimension.Text.Origin.X
    End If
  Else
    ' Change the position of the dimension.
    Dim oPosition As Point2d
    Set oPosition = oDimension.Text.Origin
    If bHorizontal Then
      oPosition.Y = dPosition
    Else
      oPosition.X = dPosition
    End If
    oDimension.Text.Origin = oPosition
  End If
Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Text Property


DrawingDimension.Tolerance Property

DrawingDimension.Tolerance Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the Tolerance object associated with this dimension.

Visual Basic
Property Tolerance() As Tolerance**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Tolerance Property


DrawingDimension.TolerancePrecision Property

DrawingDimension.TolerancePrecision Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the number of decimal places displayed for this tolerance.

Visual Basic
Property TolerancePrecision() As long
Remarks

Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.TolerancePrecision Property


DrawingDimension.Type Property

DrawingDimension.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimension Interface > DrawingDimension Properties > DrawingDimension.Type Property


DrawingDimensions Interface

DrawingDimensions Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingDimensions object provides access to all of the dimensions ( objects) on the sheet.

Class Hierarchy
Inventor::DrawingDimensions
Visual Basic
Public Interface DrawingDimensions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.DrawingDimensions

See Also

Baseline dimension sets sample

Dimensions - editing sample

Example

See DrawingDimension for example "Editing dimensions and dimension styles"

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface


DrawingDimensions Methods

DrawingDimensions Methods
Summary

The methods of the DrawingDimensions class are listed here.

Methods
Methods
Name | Description
Arrange | Method that automatically arranges the input drawing dimensions.
Item | Method that returns the specified dimension object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Methods


DrawingDimensions.Arrange Method

DrawingDimensions.Arrange Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that automatically arranges the input drawing dimensions.

Visual Basic
Sub Arrange(DrawingDimensions As ObjectCollection, ByRef ContourEntity As [optional] VARIANT)
Parameters
Parameters | Description
DrawingDimensions | Input ObjectCollection that contains the drawing dimensions to arrange. The collection can contains dimensions from different drawing views. The collection can contain DrawingDimension and ChainDimensionSet objects. The input DrawingDimension objects should not be a member of an ordinate dimension set, a baseline dimension set or a chain dimension set.
ContourEntity | Optional input object that specifies a contour entity to use for dimension arrangement. This can either be a GeometryIntent object (which specifies a geometry) or a Point2d object (which specifies a 2d point in sheet space). This argument is applicable only when all the input dimension objects are along an axis (i.e. they are parallel).
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Methods > DrawingDimensions.Arrange Method


DrawingDimensions.Item Method

DrawingDimensions.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified dimension object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DrawingDimension*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Methods > DrawingDimensions.Item Method


DrawingDimensions Properties

DrawingDimensions Properties
Summary

The properties of the DrawingDimensions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BaselineDimensionSets | Property that returns the BaselineDimensionSets collection object.
ChainDimensionSets | Property that returns the ChainDimensionSets collection object. This object provides access to all of the chain dimension sets on the sheet and provides functionality to create new chain dimension sets.
Count | Property that returns the number of items in the collection.
GeneralDimensions | Property that returns the GeneralDimensions collection object. This object provides access to all of the general dimensions on the sheet and provides functionality to create new general dimensions.
OrdinateDimensions | Property that returns the OrdinateDimensions collection object.
OrdinateDimensionSets | Property that returns the OrdinateDimensionSets collection object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties


DrawingDimensions.Application Property

DrawingDimensions.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.Application Property


DrawingDimensions.BaselineDimensionSets Property

DrawingDimensions.BaselineDimensionSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the BaselineDimensionSets collection object.

Visual Basic
Property BaselineDimensionSets() As BaselineDimensionSets**
Remarks

This object provides access to all of the baseline dimension sets on the sheet and provides functionality to create new baseline dimension sets.

See Also

Baseline dimension sets sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.BaselineDimensionSets Property


DrawingDimensions.ChainDimensionSets Property

DrawingDimensions.ChainDimensionSets Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ChainDimensionSets collection object. This object provides access to all of the chain dimension sets on the sheet and provides functionality to create new chain dimension sets.

Visual Basic
Property ChainDimensionSets() As ChainDimensionSets**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.ChainDimensionSets Property


DrawingDimensions.Count Property

DrawingDimensions.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.Count Property


DrawingDimensions.GeneralDimensions Property

DrawingDimensions.GeneralDimensions Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the GeneralDimensions collection object. This object provides access to all of the general dimensions on the sheet and provides functionality to create new general dimensions.

Visual Basic
Property GeneralDimensions() As GeneralDimensions**
See Also

Dimensions - editing sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.GeneralDimensions Property


DrawingDimensions.OrdinateDimensions Property

DrawingDimensions.OrdinateDimensions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the OrdinateDimensions collection object.

Visual Basic
Property OrdinateDimensions() As OrdinateDimensions**
Remarks

This object provides access to all of the ordinate dimensions on the sheet and provides functionality to create new ordinate dimensions.

See Also

Create ordinate dimension sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.OrdinateDimensions Property


DrawingDimensions.OrdinateDimensionSets Property

DrawingDimensions.OrdinateDimensionSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the OrdinateDimensionSets collection object.

Visual Basic
Property OrdinateDimensionSets() As OrdinateDimensionSets**
Remarks

This object provides access to all of the ordinate dimension sets on the sheet and provides functionality to create new ordinate dimension sets.

You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.OrdinateDimensionSets Property


DrawingDimensions.Type Property

DrawingDimensions.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingDimensions Interface > DrawingDimensions Properties > DrawingDimensions.Type Property


DrawingDocument Interface

DrawingDocument Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DrawingDocument object provides methods and properties to create, activate, save, and query many properties of individual drawing documents.

Class Hierarchy
Inventor::Document
    Inventor::DrawingDocument
Visual Basic
Public Interface DrawingDocument
Inherits Document
Remarks

The Rebuild and Rebuild2 methods are non-functional in the context of Drawing and Presentation documents.

Notes

Members through which this object may be accessed include:

AutoCADBlockDefinition.Parent

BorderDefinition.Parent

DrawingBOM.Parent

DrawingEventsObject.Parent

DrawingSettings.Parent

DrawingStylesManager.Parent

SheetFormat.Parent

SheetSettings.Parent

SketchedSymbolDefinition.Parent

TitleBlockDefinition.Parent

See Also

Copying a title block definition sample

Title Block Definition Create and Insert sample

Custom Table - create sample

Find component referenced by balloon sample

Creation a balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface


DrawingDocument Methods

DrawingDocument Methods
Summary

The methods of the DrawingDocument class are listed here.

Methods
Methods
Name | Description
ProcessViewSelection | Process object selection according to the context of the document referenced by the containing view.
SaveAsInventorDWG | Method that saves the document as an Inventor DWG with the specified name.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Methods


DrawingDocument.ProcessViewSelection Method

DrawingDocument.ProcessViewSelection Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Process object selection according to the context of the document referenced by the containing view.

Visual Basic
Sub ProcessViewSelection(Selection As GenericObject, ByRef ContainingView As DrawingView*, ByRef SelectedObject As IDispatch*)
Parameters
Parameters | Description
Selection | Input GenericObject obtained from the SelectSet.Item property.
ContainingView | Output DrawingView object that returns the drawing view in the context of which the selection was made.
SelectedObject | Output GenericObject that returns the object in the context of the document referenced by the containing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Methods > DrawingDocument.ProcessViewSelection Method


DrawingDocument.SaveAsInventorDWG Method

DrawingDocument.SaveAsInventorDWG Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that saves the document as an Inventor DWG with the specified name.

Visual Basic
Sub SaveAsInventorDWG(FullFileName As String, SaveCopyAs As VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Methods > DrawingDocument.SaveAsInventorDWG Method


DrawingDocument Properties

DrawingDocument Properties
Summary

The properties of the DrawingDocument class are listed here.

Properties
Name | Description
ActiveSheet | Property that returns the currently active sheet.
AutoCADBlockDefinitions | Property that returns the AutoCADBlockDefinitions collection object.
BorderDefinitions | Property that returns the BorderDefinitions collection object. This object provides access to all of the border definitions in the document and provides functionality to create new border definitions.
ContainingDWGDocument | Gets the reference to the containing DWG document when this document is stored in a DWG.
DisabledCommandList | Property that returns the DisabledCommandList object. This object allows the document to disable specific commands. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.
DrawingBOMs | Property that returns the collection of locally stored BOMs in this drawing document.
DrawingEvents | Property that gets the DrawingEvents object. This provides drawing event notification such as onRetrieveDimensions.
DrawingSettings | The DrawingSettings object provides access to various drawing related document settings. This is somewhat equivalent to the Drawing tab of the Document Settings dialog.
EnvironmentManager | Property that returns the EnvironmentManager object.
IsInventorDWG | Property that returns whether this is an Inventor DWG document.
Parameters | Property that returns the set of parameters stored in this drawing document.
SheetFormats | Property that returns the SheetFormats collection object.
Sheets | Property that returns the Sheets collection object. This object provides access to all of the sheets in the document.
SheetSettings | Property that returns the SheetSettings object. The SheetSettings object provides access to various sheet related document options. This is somewhat equivalent to the Sheet tab of the Document Settings dialog.
SketchedSymbolDefinitions | Property that returns the SketchedSymbolDefinitions collection object. This object provides access to all of the sketched symbol definitions available for placement in the document and provides functionality to create new sketched symbol definitions.
SketchSettings | Property that returns the SketchSettings object. The SketchSettings object provides access to various sketch related document options. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.
StylesManager | Property that returns the DrawingStylesManager object.
TitleBlockDefinitions | Property that returns the TitleBlockDefinitions collection object. This object provides access to all of the title block definition in the document and provides functionality to create new title block definitions.
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties


DrawingDocument.ActiveSheet Property

DrawingDocument.ActiveSheet Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the currently active sheet.

Visual Basic
Property ActiveSheet() As Sheet**
See Also

Dimensions - editing sample

Create a drawing Excel Table sample

Create a Configuration Table sample

Create a Bend Table sample

Custom Table - create sample

Creation a balloon sample

Balloons - edit sample

Center Dimension Text sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.ActiveSheet Property


DrawingDocument.AutoCADBlockDefinitions Property

DrawingDocument.AutoCADBlockDefinitions Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the AutoCADBlockDefinitions collection object.

Visual Basic
Property AutoCADBlockDefinitions() As AutoCADBlockDefinitions**
Remarks

This object provides access to all of the AutoCAD block definitions available for placement in the document and provides functionality to import definitions from other documents. This property returns Nothing for Inventor IDW documents.

See Also

AutoCAD block insertion sample

AutoCAD block definitions import sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.AutoCADBlockDefinitions Property


DrawingDocument.BorderDefinitions Property

DrawingDocument.BorderDefinitions Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the BorderDefinitions collection object. This object provides access to all of the border definitions in the document and provides functionality to create new border definitions.

Visual Basic
Property BorderDefinitions() As BorderDefinitions**
Example

"Border Create & Insert Example"

This sample illustrates creating a new border definition object and using it for a sheet. This sample consists of two sub procedures. The first creates the border definition. The second inserts it into the active sheet. To run the sample have a drawing document open and run the CreateBorderDefinition sub first. After that you can run the InsertBorderOnSheet sub.

Public Sub CreateBorderDefinition()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Create the new borderdefinition.
    Dim oBorderDef As BorderDefinition
    Set oBorderDef = oDrawDoc.BorderDefinitions.Add("Sample Border")

    ' Open the border definition's sketch for edit.  This is done by calling the Edit
    ' method of the BorderDefinition to obtain a DrawingSketch.  This actually creates
    ' a copy of the border definition's and opens it for edit.
    Dim oSketch As DrawingSketch
    Call oBorderDef.Edit(oSketch)

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Use the functionality of the sketch to add geometry.
    Call oSketch.SketchLines.AddAsTwoPointRectangle(oTG.CreatePoint2d(2, 2), oTG.CreatePoint2d(25.94, 19.59))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 10.795), oTG.CreatePoint2d(2, 10.795))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(13.97, 0), oTG.CreatePoint2d(13.97, 2))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(25.94, 10.795), oTG.CreatePoint2d(27.94, 10.795))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(13.97, 19.59), oTG.CreatePoint2d(13.97, 21.59))

    ' Add some text to the border.
    Dim oTextBox As TextBox
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(2, 1), "Here is a sample string")
    oTextBox.VerticalJustification = kAlignTextMiddle

    ' Add some prompted text to the border.
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(2, 20.59), "Enter designers name:")
    oTextBox.VerticalJustification = kAlignTextMiddle

    Call oBorderDef.ExitEdit(True)
End Sub

Public Sub InsertCustomBorderOnSheet()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Obtain a reference to the desired border definition.
    Dim oBorderDef As BorderDefinition
    Set oBorderDef = oDrawDoc.BorderDefinitions.Item("Sample Border")

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Check to see if the sheet already has a border and delete it if it does.
    If Not oSheet.Border Is Nothing Then
        oSheet.Border.Delete
    End If

    ' This border definition contains one prompted string input.  An array
    ' must be input that contains the strings for the prompted strings.
    Dim sPromptStrings(1 To 1) As String
    sPromptStrings(1) = "This is the input for the prompted text."

    ' Add an instance of the border definition to the sheet.
    Dim oBorder As Border
    Set oBorder = oSheet.AddBorder(oBorderDef, sPromptStrings)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.BorderDefinitions Property


DrawingDocument.ContainingDWGDocument Property

DrawingDocument.ContainingDWGDocument Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the reference to the containing DWG document when this document is stored in a DWG.

Visual Basic
Property ContainingDWGDocument() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.ContainingDWGDocument Property


DrawingDocument.DisabledCommandList Property

DrawingDocument.DisabledCommandList Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the DisabledCommandList object. This object allows the document to disable specific commands. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.

Visual Basic
Property DisabledCommandList() As DisabledCommandList**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.DisabledCommandList Property


DrawingDocument.DrawingBOMs Property

DrawingDocument.DrawingBOMs Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the collection of locally stored BOMs in this drawing document.

Visual Basic
Property DrawingBOMs() As DrawingBOMs**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.DrawingBOMs Property


DrawingDocument.DrawingEvents Property

DrawingDocument.DrawingEvents Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the DrawingEvents object. This provides drawing event notification such as onRetrieveDimensions.

Visual Basic
Property DrawingEvents() As DrawingEvents**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.DrawingEvents Property


DrawingDocument.DrawingSettings Property

DrawingDocument.DrawingSettings Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

The DrawingSettings object provides access to various drawing related document settings. This is somewhat equivalent to the Drawing tab of the Document Settings dialog.

Visual Basic
Property DrawingSettings() As DrawingSettings**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.DrawingSettings Property


DrawingDocument.EnvironmentManager Property

DrawingDocument.EnvironmentManager Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the EnvironmentManager object.

Visual Basic
Property EnvironmentManager() As EnvironmentManager**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.EnvironmentManager Property


DrawingDocument.IsInventorDWG Property

DrawingDocument.IsInventorDWG Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether this is an Inventor DWG document.

Visual Basic
Property IsInventorDWG() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.IsInventorDWG Property


DrawingDocument.Parameters Property

DrawingDocument.Parameters Property
Summary

Property that returns the set of parameters stored in this drawing document.

Visual Basic
Property Parameters() As Parameters**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.Parameters Property


DrawingDocument.SheetFormats Property

DrawingDocument.SheetFormats Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the SheetFormats collection object.

Visual Basic
Property SheetFormats() As SheetFormats**
Remarks

This object provides access to all of the sheet formats in the document and provides functionality to create new sheet formats.

See Also

Create sheet with multiple views sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.SheetFormats Property


DrawingDocument.Sheets Property

DrawingDocument.Sheets Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the Sheets collection object. This object provides access to all of the sheets in the document.

Visual Basic
Property Sheets() As Sheets**
See Also

Copying a title block definition sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.Sheets Property


DrawingDocument.SheetSettings Property

DrawingDocument.SheetSettings Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the SheetSettings object. The SheetSettings object provides access to various sheet related document options. This is somewhat equivalent to the Sheet tab of the Document Settings dialog.

Visual Basic
Property SheetSettings() As SheetSettings**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.SheetSettings Property


DrawingDocument.SketchedSymbolDefinitions Property

DrawingDocument.SketchedSymbolDefinitions Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchedSymbolDefinitions collection object. This object provides access to all of the sketched symbol definitions available for placement in the document and provides functionality to create new sketched symbol definitions.

Visual Basic
Property SketchedSymbolDefinitions() As SketchedSymbolDefinitions**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.SketchedSymbolDefinitions Property


DrawingDocument.SketchSettings Property

DrawingDocument.SketchSettings Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the SketchSettings object. The SketchSettings object provides access to various sketch related document options. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.

Visual Basic
Property SketchSettings() As SketchSettings**
You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.SketchSettings Property


DrawingDocument.StylesManager Property

DrawingDocument.StylesManager Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the DrawingStylesManager object.

Visual Basic
Property StylesManager() As DrawingStylesManager**
See Also

Moving sketch entities to a new layer sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.StylesManager Property


DrawingDocument.TitleBlockDefinitions Property

DrawingDocument.TitleBlockDefinitions Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the TitleBlockDefinitions collection object. This object provides access to all of the title block definition in the document and provides functionality to create new title block definitions.

Visual Basic
Property TitleBlockDefinitions() As TitleBlockDefinitions**
See Also

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingDocument Interface > DrawingDocument Properties > DrawingDocument.TitleBlockDefinitions Property


DrawingEvents CoClass

DrawingEvents CoClass Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingEvents object provides drawing event notification, such as onRetrieveDimensions.

Class Hierarchy
Inventor::DrawingEvents
Visual Basic
Public Class DrawingEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

DrawingDocument.DrawingEvents

You are here: Symbol Reference > Inventor Library > Objects > DrawingEvents CoClass


DrawingEventsObject Interface

DrawingEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingEvents object provides drawing event notification, such as onRetrieveDimensions.

Class Hierarchy
Inventor::DrawingEventsObject
Visual Basic
Public Interface DrawingEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsObject Interface


DrawingEventsObject Properties

DrawingEventsObject Properties
Summary

The properties of the DrawingEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent DrawingDocument object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsObject Interface > DrawingEventsObject Properties


DrawingEventsObject.Application Property

DrawingEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsObject Interface > DrawingEventsObject Properties > DrawingEventsObject.Application Property


DrawingEventsObject.Parent Property

DrawingEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent DrawingDocument object.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsObject Interface > DrawingEventsObject Properties > DrawingEventsObject.Parent Property


DrawingEventsObject.Type Property

DrawingEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsObject Interface > DrawingEventsObject Properties > DrawingEventsObject.Type Property


DrawingEventsSink Interface

DrawingEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingEvents object provides drawing event notification, such as onRetrieveDimensions.

Class Hierarchy
Inventor::DrawingEventsSink
Visual Basic
Public Interface DrawingEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsSink Interface


DrawingEventsSink Methods

DrawingEventsSink Methods
Summary

The methods of the DrawingEventsSink class are listed here.

Methods
Methods
Name | Description
OnRetrieveDimensions | The OnRetrieveDimensions event notifies a client whenever dimensions are retrieved into a drawing using the Retrieve Dimensions command.
You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsSink Interface > DrawingEventsSink Methods


DrawingEventsSink.OnRetrieveDimensions Method

DrawingEventsSink.OnRetrieveDimensions Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

The OnRetrieveDimensions event notifies a client whenever dimensions are retrieved into a drawing using the Retrieve Dimensions command.

Visual Basic
Sub OnRetrieveDimensions(SketchDimensions As ObjectsEnumerator, DrawingDimensions As GeneralDimensionsEnumerator, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SketchDimensions | A collection containing the original dimensions that were retrieved into the drawing. These will be various dimension constraints or feature dimensions that were created in the part or drawing sketch. Feature dimensions are the dimensions created automatically when a feature is created. For example, when you create an extrude feature with a distance extent two feature dimensions are created. One to control the distance and another to control the taper angle.
DrawingDimensions | A collection containing the drawing dimensions that were created as a result of the retrieve. The items in this collection will match up 1 for 1 with the dimensions provided by the SketchDimensions argument.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. This notification is only provided after the dimensions have been retrieved so the value of this argument will always be kAfter.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > DrawingEventsSink Interface > DrawingEventsSink Methods > DrawingEventsSink.OnRetrieveDimensions Method


DrawingNote Interface

DrawingNote Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The DrawingNote object is the base class for all the drawing notes on a sheet.

Class Hierarchy
Inventor::DrawingNote
    Inventor::GeneralNote
    Inventor::LeaderNote
Visual Basic
Public Interface DrawingNote
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.Item

You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface


DrawingNote Methods

DrawingNote Methods
Summary

The methods of the DrawingNote class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the DrawingNote.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Methods


DrawingNote.Delete Method

DrawingNote.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the DrawingNote.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Methods > DrawingNote.Delete Method


DrawingNote.GetReferenceKey Method

DrawingNote.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Methods > DrawingNote.GetReferenceKey Method


DrawingNote Properties

DrawingNote Properties
Summary

The properties of the DrawingNote class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Color | Property that gets and set the color of the text.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
HorizontalJustification | Property that gets and sets the horizontal justification override of the drawing note.
Layer | Property that gets and sets the layer associated with this note.
LineSpacing | Property that gets and sets the line spacing of the drawing note
LineSpacingType | Property that gets and sets the method used to define the line spacing.
Parent | Property that returns the parent sheet of the object.
Position | Property that gets and sets the position of the note on the sheet.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
StackedTextPosition | Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.
Text | Property that indicates the string that defines the contents of the note. When getting this property, the returned string has all formatting removed and contains the actual text characters displayed in the note. If this property is used to set the text in the drawing note, all format overrides will be removed and the note will revert to the associated text style.
Type | Property returning kDrawingNoteObject indicating this objects type.
VerticalJustification | Property that gets and sets the vertical justification override of the note.
WidthScale | Property that gets and sets the width scale factor for the drawing note. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties


DrawingNote.Application Property

DrawingNote.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Application Property


DrawingNote.AttributeSets Property

DrawingNote.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.AttributeSets Property


DrawingNote.Color Property

DrawingNote.Color Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and set the color of the text.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Color Property


DrawingNote.FormattedText Property

DrawingNote.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.FormattedText Property


DrawingNote.HorizontalJustification Property

DrawingNote.HorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the horizontal justification override of the drawing note.

Visual Basic
Property HorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.HorizontalJustification Property


DrawingNote.Layer Property

DrawingNote.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this note.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Layer Property


DrawingNote.LineSpacing Property

DrawingNote.LineSpacing Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the line spacing of the drawing note

Visual Basic
Property LineSpacing() As double
Remarks

The value of this property is treated in one of two ways depending on the value of the LineSpacingType property. When the value of the LineSpacingType property is set to kExactLineSpacing, the value of the LineSpacing property defines the exact distance (in centimeters) from the bottom of one line to bottom of the next line.

When the value of the LineSpacingType property is set to kMultipleLineSpacing, the value defines a spacing factor relative to standard single line spacing. For example, a value of 1.0 will result in standard single line spacing, and a value of 1.5 will result in one and a half line spacing.

You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.LineSpacing Property


DrawingNote.LineSpacingType Property

DrawingNote.LineSpacingType Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the method used to define the line spacing.

Visual Basic
Property LineSpacingType() As TextLineSpacingTypeEnum
Remarks

The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.

You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.LineSpacingType Property


DrawingNote.Parent Property

DrawingNote.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent sheet of the object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Parent Property


DrawingNote.Position Property

DrawingNote.Position Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the position of the note on the sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Position Property


DrawingNote.RangeBox Property

DrawingNote.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.RangeBox Property


DrawingNote.StackedTextPosition Property

DrawingNote.StackedTextPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.

Visual Basic
Property StackedTextPosition() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.StackedTextPosition Property


DrawingNote.Text Property

DrawingNote.Text Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the string that defines the contents of the note. When getting this property, the returned string has all formatting removed and contains the actual text characters displayed in the note. If this property is used to set the text in the drawing note, all format overrides will be removed and the note will revert to the associated text style.

Visual Basic
Property Text() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Text Property


DrawingNote.Type Property

DrawingNote.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kDrawingNoteObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.Type Property


DrawingNote.VerticalJustification Property

DrawingNote.VerticalJustification Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the vertical justification override of the note.

Visual Basic
Property VerticalJustification() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.VerticalJustification Property


DrawingNote.WidthScale Property

DrawingNote.WidthScale Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the width scale factor for the drawing note. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.

Visual Basic
Property WidthScale() As double
You are here: Symbol Reference > Inventor Library > Objects > DrawingNote Interface > DrawingNote Properties > DrawingNote.WidthScale Property


DrawingNotes Interface

DrawingNotes Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The DrawingNotes collection object provides access to all of the drawing notes on the sheet.

Class Hierarchy
Inventor::DrawingNotes
Visual Basic
Public Interface DrawingNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.DrawingNotes

See Also

Create thread note sample

create punch note sample

Create bend note sample

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface


DrawingNotes Methods

DrawingNotes Methods
Summary

The methods of the DrawingNotes class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified DrawingNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Methods


DrawingNotes.Item Method

DrawingNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified DrawingNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] DrawingNote*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
Remarks

This property returns all of the ChamferNote, BendNote, and PunchNote objects on the sheet. However, HoleThreadNote objects are not returned by this property and must be obtained explicitly by using the HoleThreadNotes collection object.

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Methods > DrawingNotes.Item Method


DrawingNotes Properties

DrawingNotes Properties
Summary

The properties of the DrawingNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BendNotes | Property that returns the collection of bend notes on the sheet.
ChamferNotes | Property that returns the collection of chamfer notes on the sheet.
Count | Property that returns the number of items in the collection.
GeneralNotes | Property that returns the collection of general notes on the sheet.
HoleThreadNotes | Property that returns the collection of hole and thread notes on the sheet.
LeaderNotes | Property that returns the collection of leader notes on the sheet.
PunchNotes | Property that returns the collection of punch notes on the sheet.
Type | Property returning kDrawingNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties


DrawingNotes.Application Property

DrawingNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.Application Property


DrawingNotes.BendNotes Property

DrawingNotes.BendNotes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of bend notes on the sheet.

Visual Basic
Property BendNotes() As BendNotes**
See Also

Create bend note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.BendNotes Property


DrawingNotes.ChamferNotes Property

DrawingNotes.ChamferNotes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of chamfer notes on the sheet.

Visual Basic
Property ChamferNotes() As ChamferNotes**
You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.ChamferNotes Property


DrawingNotes.Count Property

DrawingNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.Count Property


DrawingNotes.GeneralNotes Property

DrawingNotes.GeneralNotes Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the collection of general notes on the sheet.

Visual Basic
Property GeneralNotes() As GeneralNotes**
See Also

Creating Stacked Text sample

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.GeneralNotes Property


DrawingNotes.HoleThreadNotes Property

DrawingNotes.HoleThreadNotes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of hole and thread notes on the sheet.

Visual Basic
Property HoleThreadNotes() As HoleThreadNotes**
See Also

Create thread note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.HoleThreadNotes Property


DrawingNotes.LeaderNotes Property

DrawingNotes.LeaderNotes Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the collection of leader notes on the sheet.

Visual Basic
Property LeaderNotes() As LeaderNotes**
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.LeaderNotes Property


DrawingNotes.PunchNotes Property

DrawingNotes.PunchNotes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of punch notes on the sheet.

Visual Basic
Property PunchNotes() As PunchNotes**
See Also

create punch note sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.PunchNotes Property


DrawingNotes.Type Property

DrawingNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kDrawingNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingNotes Interface > DrawingNotes Properties > DrawingNotes.Type Property


DrawingOptions Interface

DrawingOptions Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The DrawingOptions object provides access to properties that provide read and write access of the drawing related application options. This is somewhat equivalent to the Drawing tab of the Application Options dialog.

Class Hierarchy
Inventor::DrawingOptions
Visual Basic
Public Interface DrawingOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.DrawingOptions

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface


DrawingOptions Properties

DrawingOptions Properties
Summary

The properties of the DrawingOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ArcDimensionType | Property that specifies the type of dimensioning to use while placing arc dimensions on drawing sheets.
CenterDimensionText | Property that specifies if the dimension text is to be centered when adding dimensions to drawing views.
CircleDimensionType | Property that specifies the type of dimensioning to use while placing circle dimensions on drawing sheets.
DefaultDrawingFileType | Property that specifies the default file type (.idw or .dwg) to use when creating new drawings. The valid options are kDWGDefaultDrawingFileType and kIDWDefaultDrawingFileType.
DefaultLayerStyle | Property that specifies the default style to use for drawing layers. The valid options are kStandardDefaultLayerStyle and kLastUsedDefaultLayerStyle.
DefaultNonInventorDWGFileOpenBehavior | Property that specifies the default file open behavior for non-Inventor DWG files. The valid options are kRegularOpenNonInventorDWGFile and kImportNonInventorDWGFile.
DefaultObjectStyle | Property that specifies the default style to use for drawing objects. The valid options are kStandardDefaultObjectStyle and kLastUsedDefaultObjectStyle.
DisplayLineWeights | Property that enables or disables the display of unique line weights in drawings. If True, visible lines in drawings are displayed with the line weights defined in the active drafting standard. If False, all visible lines are displayed with the same weight. Note: This setting does not affect line weights when printing drawings.
EditDimensionWhenCreated | Property that gets and sets whether the edit dimension dialog should be shown when a dimension is created using the 'General Dimension' command.
EnableBackgroundUpdates | Property that gets and sets whether drawing views are computed as a background process or not.
EnableOrdinateDimGeomSelection | Property that enables or disables the selection of drawing geometry when creating ordinate dimensions. If True, drawing geometry can be selected when creating ordinate dimensions.
GetModelDimensions | Property that gets and sets the default for the Dimensions option in the Create View dialog boxes.
InventorDWGFileVersion | Property that specifies the AutoCAD DWG version for Inventor DWG files. The valid options are kAutoCAD2000, kAutoCAD2004, kAutoCAD2007 and kAutoCAD2010.
LinearDimensionType | Property that specifies the type of dimensioning to use while placing linear dimensions on drawing sheets.
LineWeightType | Property that specifies the type of line weight to apply when displaying lines in the drawing. The valid options are kTrueLineWeight and kRangeLineWeight.
MemorySavingMode | Property that specifies whether the memory saving mode should be enabled for drawing view computations. If True, the memory saving mode will be enabled for drawing view computations.
ShowUncutSectionViewPreview | Property that specifies whether the section view previews should be displayed in uncut mode. If True, section view previews will be displayed in uncut mode.
StandardPartsSectionBehavior | Property that specifies the sectioning behavior for standard parts when section views that contain standard parts are created in the drawing
TitleBlockAlignment | Property that specifies the default title block location. The valid options are kUpperLeftTitleBlockAlignment, kLowerLeftTitleBlockAlignment, kUpperRightTitleBlockAlignment and kLowerRightTitleBlockAlignment.
Type | Returns an ObjectTypeEnum indicating this object's type.
UpperLimitForFirstRangeOfLineWeights | Property that specifies the upper limit of the drawing line thickness value for which the first range of line weight applies.
UpperLimitForSecondRangeOfLineWeights | Property that specifies the upper limit of the drawing line thickness value for which the second range of line weight applies.
UpperLimitForThirdRangeOfLineWeights | Property that specifies the upper limit of the drawing line thickness value for which the third range of line weight applies.
ViewBlockInsertionPoint | Property that specifies default insertion point for a view block. Valid values are kViewCenterInsertion and kModelOriginInsertion.
ViewJustification | Property that specifies the default drawing view justification. The valid options are kCenteredViewJustification and kFixedViewJustification.
ViewPreview | Property that specifies the preview type for drawing views. The valid options are kAllComponentsViewPreview, kPartialViewPreview and kBoundingBoxViewPreview.
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties


DrawingOptions.Application Property

DrawingOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.Application Property


DrawingOptions.ArcDimensionType Property

DrawingOptions.ArcDimensionType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of dimensioning to use while placing arc dimensions on drawing sheets.

Visual Basic
Property ArcDimensionType() As ArcDimensionTypeEnum
Remarks

The valid options are kRadialArcDimension, kDiametricArcDimension, kAngleArcDimension, kArcLengthArcDimension and kChordLengthArcDimension. These options correspond to the Radial Dimension, Diametric Dimension, Angle, Arc Length and Chord Length options under the Arc Dimension Type Preferences category on the Drawing tab of the Application Options dialog.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.ArcDimensionType Property


DrawingOptions.CenterDimensionText Property

DrawingOptions.CenterDimensionText Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies if the dimension text is to be centered when adding dimensions to drawing views.

Visual Basic
Property CenterDimensionText() As VARIANT_BOOL
Remarks

If True, the dimension text is placed centrally on the dimension when a linear or angular dimension is created. If False, the dimension text follows the mouse movement while creating the dimension and is finally placed at the position where the mouse is clicked.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.CenterDimensionText Property


DrawingOptions.CircleDimensionType Property

DrawingOptions.CircleDimensionType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of dimensioning to use while placing circle dimensions on drawing sheets.

Visual Basic
Property CircleDimensionType() As CircleDimensionTypeEnum
Remarks

The valid options are kDiametricCircleDimension and kRadialCircleDimension. These options correspond to the Diametric Dimension and Radial Dimension options under the Circle Dimension Type Preferences category on the Drawing tab of the Application Options dialog.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.CircleDimensionType Property


DrawingOptions.DefaultDrawingFileType Property

DrawingOptions.DefaultDrawingFileType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the default file type (.idw or .dwg) to use when creating new drawings. The valid options are kDWGDefaultDrawingFileType and kIDWDefaultDrawingFileType.

Visual Basic
Property DefaultDrawingFileType() As DefaultDrawingFileTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.DefaultDrawingFileType Property


DrawingOptions.DefaultLayerStyle Property

DrawingOptions.DefaultLayerStyle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the default style to use for drawing layers. The valid options are kStandardDefaultLayerStyle and kLastUsedDefaultLayerStyle.

Visual Basic
Property DefaultLayerStyle() As DefaultLayerStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.DefaultLayerStyle Property


DrawingOptions.DefaultNonInventorDWGFileOpenBehavior Property

DrawingOptions.DefaultNonInventorDWGFileOpenBehavior Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the default file open behavior for non-Inventor DWG files. The valid options are kRegularOpenNonInventorDWGFile and kImportNonInventorDWGFile.

Visual Basic
Property DefaultNonInventorDWGFileOpenBehavior() As DefaultNonInventorDWGFileOpenBehaviorEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.DefaultNonInventorDWGFileOpenBehavior Property


DrawingOptions.DefaultObjectStyle Property

DrawingOptions.DefaultObjectStyle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the default style to use for drawing objects. The valid options are kStandardDefaultObjectStyle and kLastUsedDefaultObjectStyle.

Visual Basic
Property DefaultObjectStyle() As DefaultObjectStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.DefaultObjectStyle Property


DrawingOptions.DisplayLineWeights Property

DrawingOptions.DisplayLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that enables or disables the display of unique line weights in drawings. If True, visible lines in drawings are displayed with the line weights defined in the active drafting standard. If False, all visible lines are displayed with the same weight.

Note: This setting does not affect line weights when printing drawings.

Visual Basic
Property DisplayLineWeights() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.DisplayLineWeights Property


DrawingOptions.EditDimensionWhenCreated Property

DrawingOptions.EditDimensionWhenCreated Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the edit dimension dialog should be shown when a dimension is created using the 'General Dimension' command.

Visual Basic
Property EditDimensionWhenCreated() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.EditDimensionWhenCreated Property


DrawingOptions.EnableBackgroundUpdates Property

DrawingOptions.EnableBackgroundUpdates Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether drawing views are computed as a background process or not.

Visual Basic
Property EnableBackgroundUpdates() As VARIANT_BOOL
Remarks

A value of True indicates that views will be computed in the background.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.EnableBackgroundUpdates Property


DrawingOptions.EnableOrdinateDimGeomSelection Property

DrawingOptions.EnableOrdinateDimGeomSelection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that enables or disables the selection of drawing geometry when creating ordinate dimensions. If True, drawing geometry can be selected when creating ordinate dimensions.

Visual Basic
Property EnableOrdinateDimGeomSelection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.EnableOrdinateDimGeomSelection Property


DrawingOptions.GetModelDimensions Property

DrawingOptions.GetModelDimensions Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the default for the Dimensions option in the Create View dialog boxes.

Visual Basic
Property GetModelDimensions() As VARIANT_BOOL
Remarks

If True, the Dimensions option in Create View is automatically selected so that applicable model dimensions are added to drawing views when they are placed. If False, the Dimensions option in the Create View dialog boxes must be manually selected to add the model dimensions when placing drawing views.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.GetModelDimensions Property


DrawingOptions.InventorDWGFileVersion Property

DrawingOptions.InventorDWGFileVersion Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the AutoCAD DWG version for Inventor DWG files. The valid options are kAutoCAD2000, kAutoCAD2004, kAutoCAD2007 and kAutoCAD2010.

Visual Basic
Property InventorDWGFileVersion() As DWGFileVersionEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.InventorDWGFileVersion Property


DrawingOptions.LinearDimensionType Property

DrawingOptions.LinearDimensionType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of dimensioning to use while placing linear dimensions on drawing sheets.

Visual Basic
Property LinearDimensionType() As LinearDimensionTypeEnum
Remarks

The valid options are kRegularLinearDimension, kDiametricLinearDimension and kSymmetricLinearDimension. These options correspond to the Linear Dimension, Linear Diametric and Linear Symmetric options under the Linear Dimension Type Preferences category on the Drawing tab of the Application Options dialog.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.LinearDimensionType Property


DrawingOptions.LineWeightType Property

DrawingOptions.LineWeightType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of line weight to apply when displaying lines in the drawing. The valid options are kTrueLineWeight and kRangeLineWeight.

Visual Basic
Property LineWeightType() As LineWeightTypeEnum
Remarks

Setting this property to kTrueLineWeight specifies that the line weights should correspond to the actual line dimensions. The line weights will be displayed on screen with the same dimensions as they would appear on paper, regardless of zoom magnification.

Setting this property to kRangeLineWeight specifies that lines will be displayed with a particular line weight depending on which one of the defined range of line thickness values the actual line thickness falls into. All lines whose thickness lies within a particular range will be displayed with the same line weight. The ranges for the line thicknesses are defined by the UpperLimitForFirstRangeOfLineWeights, UpperLimitForSecondRangeOfLineWeights and UpperLimitForThirdRangeOfLineWeights properties.

Note: This property can be set only if the DisplayLineWeights property has already been set to True. Setting this property will fail if the DisplayLineWeights property has been set to False.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.LineWeightType Property


DrawingOptions.MemorySavingMode Property

DrawingOptions.MemorySavingMode Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether the memory saving mode should be enabled for drawing view computations. If True, the memory saving mode will be enabled for drawing view computations.

Visual Basic
Property MemorySavingMode() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.MemorySavingMode Property


DrawingOptions.ShowUncutSectionViewPreview Property

DrawingOptions.ShowUncutSectionViewPreview Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether the section view previews should be displayed in uncut mode. If True, section view previews will be displayed in uncut mode.

Visual Basic
Property ShowUncutSectionViewPreview() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.ShowUncutSectionViewPreview Property


DrawingOptions.StandardPartsSectionBehavior Property

DrawingOptions.StandardPartsSectionBehavior Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the sectioning behavior for standard parts when section views that contain standard parts are created in the drawing

Visual Basic
Property StandardPartsSectionBehavior() As StandardPartsSectionBehaviorEnum
Remarks

The valid options are kAlwaysSectionStandardParts, kNeverSectionStandardParts and kObeyBrowserSettingsSectionStandardParts.

Setting this property to kAlwaysSectionStandardParts specifies in a overriding manner that standard parts should always be sectioned irrespective of the settings in the Model browser pane of the drawing.

Setting this property to kNeverSectionStandardParts specifies in a overriding manner that standard parts should never be sectioned irrespective of the settings in the Model browser pane of the drawing.

Setting this property to kObeyBrowserSettingsSectionStandardParts specifies that the drawing browser settings should be obeyed when sectioning standard parts. The default browser setting specifies that standard parts should not be sectioned.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.StandardPartsSectionBehavior Property


DrawingOptions.TitleBlockAlignment Property

DrawingOptions.TitleBlockAlignment Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the default title block location. The valid options are kUpperLeftTitleBlockAlignment, kLowerLeftTitleBlockAlignment, kUpperRightTitleBlockAlignment and kLowerRightTitleBlockAlignment.

Visual Basic
Property TitleBlockAlignment() As TitleBlockAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.TitleBlockAlignment Property


DrawingOptions.Type Property

DrawingOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.Type Property


DrawingOptions.UpperLimitForFirstRangeOfLineWeights Property

DrawingOptions.UpperLimitForFirstRangeOfLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the upper limit of the drawing line thickness value for which the first range of line weight applies.

Visual Basic
Property UpperLimitForFirstRangeOfLineWeights() As double
Remarks

This property can be set only if the DisplayLineWeights property has already been set to True and the LineWeightType property has been set to kRangeLineWeight. Setting this property will fail if the DisplayLineWeights property has been set to False or the LineWeightType property has been set to kTrueLineWeight.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.UpperLimitForFirstRangeOfLineWeights Property


DrawingOptions.UpperLimitForSecondRangeOfLineWeights Property

DrawingOptions.UpperLimitForSecondRangeOfLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the upper limit of the drawing line thickness value for which the second range of line weight applies.

Visual Basic
Property UpperLimitForSecondRangeOfLineWeights() As double
Remarks

This property can be set only if the DisplayLineWeights property has already been set to True and the LineWeightType property has been set to kRangeLineWeight. Setting this property will fail if the DisplayLineWeights property has been set to False or the LineWeightType property has been set to kTrueLineWeight.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.UpperLimitForSecondRangeOfLineWeights Property


DrawingOptions.UpperLimitForThirdRangeOfLineWeights Property

DrawingOptions.UpperLimitForThirdRangeOfLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the upper limit of the drawing line thickness value for which the third range of line weight applies.

Visual Basic
Property UpperLimitForThirdRangeOfLineWeights() As double
Remarks

This property can be set only if the DisplayLineWeights property has already been set to True and the LineWeightType property has been set to kRangeLineWeight. Setting this property will fail if the DisplayLineWeights property has been set to False or the LineWeightType property has been set to kTrueLineWeight.

You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.UpperLimitForThirdRangeOfLineWeights Property


DrawingOptions.ViewBlockInsertionPoint Property

DrawingOptions.ViewBlockInsertionPoint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies default insertion point for a view block. Valid values are kViewCenterInsertion and kModelOriginInsertion.

Visual Basic
Property ViewBlockInsertionPoint() As ViewBlockInsertionPointEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.ViewBlockInsertionPoint Property


DrawingOptions.ViewJustification Property

DrawingOptions.ViewJustification Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the default drawing view justification. The valid options are kCenteredViewJustification and kFixedViewJustification.

Visual Basic
Property ViewJustification() As ViewJustificationEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.ViewJustification Property


DrawingOptions.ViewPreview Property

DrawingOptions.ViewPreview Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the preview type for drawing views. The valid options are kAllComponentsViewPreview, kPartialViewPreview and kBoundingBoxViewPreview.

Visual Basic
Property ViewPreview() As ViewPreviewTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingOptions Interface > DrawingOptions Properties > DrawingOptions.ViewPreview Property


DrawingPrintManager Interface

DrawingPrintManager Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The DrawingPrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print.

Class Hierarchy
Inventor::PrintManager
    Inventor::DrawingPrintManager
Visual Basic
Public Interface DrawingPrintManager
Inherits PrintManager
Remarks

This object is only available through the PrintManager property of the DrawingDocument object.

See Also

Printing - Drawing Print sample

Example

"Printing - All Sheets in Drawing Example "

This sample demonstrates how to print all sheets in a drawing document and set some of the DrawingPrintManager properties.

Public Sub PlotAllSheetsInDrawing()
    'Print all sheets in drawing document
    'Get the active document and check whether it's drawing document
    If ThisApplication.ActiveDocument.DocumentType = kDrawingDocumentObject Then

        Dim oDrgDoc As DrawingDocument
        Set oDrgDoc = ThisApplication.ActiveDocument

        ' Set reference to drawing print manager
        ' DrawingPrintManager has more options than PrintManager
        ' as it's specific to drawing document
        Dim oDrgPrintMgr As DrawingPrintManager
        Set oDrgPrintMgr = oDrgDoc.PrintManager
        ' Set the printer name
        ' comment this line to use default printer or assign another one
        oDrgPrintMgr.Printer = "HP LaserJet 4000 Series PCL 6"

        'Set the paper size , scale and orientation
        oDrgPrintMgr.ScaleMode = kPrintBestFitScale
        oDrgPrintMgr.PaperSize = kPaperSizeA4
        oDrgPrintMgr.PrintRange = kPrintAllSheets
        oDrgPrintMgr.Orientation = kLandscapeOrientation
        oDrgPrintMgr.SubmitPrint
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface


DrawingPrintManager Methods

DrawingPrintManager Methods
Summary

The methods of the DrawingPrintManager class are listed here.

Methods
Methods
Name | Description
GetSheetRange | Method that gets the sheet range to print. The sheet range is only used when the PrintRange property is set to kPrintSheetRange.
SetSheetRange | Method that sets the sheet range to print. The range set is only used when the PrintRange property is set to kPrintSheetRange.
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Methods


DrawingPrintManager.GetSheetRange Method

DrawingPrintManager.GetSheetRange Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets the sheet range to print. The sheet range is only used when the PrintRange property is set to kPrintSheetRange.

Visual Basic
Sub GetSheetRange(ByRef FromSheet As long, ByRef ToSheet As long)
Parameters
Parameters | Description
FromSheet | Output Long value that specifies the first sheet of the range to print.
ToSheet | Output Long value that specifies the last sheet of the range to print.
See Also

Printing - Drawing Print sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Methods > DrawingPrintManager.GetSheetRange Method


DrawingPrintManager.SetSheetRange Method

DrawingPrintManager.SetSheetRange Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the sheet range to print. The range set is only used when the PrintRange property is set to kPrintSheetRange.

Visual Basic
Sub SetSheetRange(FromSheet As long, ToSheet As long)
Parameters
Parameters | Description
FromSheet | Input Long value that specifies the first sheet of the range to print.
ToSheet | Input Long value that specifies the last sheet of the range to print.
Example

"Printing - Drawing Print Example"

This sample demonstrates how to print a drawing, setting specifics such as sheet range.

Public Sub PrintDrawing()
    ' Set a reference to the print manager object of the active document.
    ' This will fail if a drawing document is not active.
    Dim oPrintMgr As DrawingPrintManager
    Set oPrintMgr = ThisApplication.ActiveDocument.PrintManager

    ' Get the name of the printer that will be used.
    If MsgBox("Using printer """ & oPrintMgr.Printer & """  Do you want to continue?", vbYesNo + vbQuestion) = vbNo Then
        ' Change to another printer.
        Dim sPrinterName As String
        sPrinterName = InputBox("Enter name of new printer:", "New Printer")
        If sPrinterName = "" Then
            Exit Sub
        Else
            oPrintMgr.Printer = sPrinterName
        End If
    End If

    ' Set to print in color.
    oPrintMgr.ColorMode = kPrintColorPalette

    ' Set to print two copies.
    oPrintMgr.NumberOfCopies = 2

    ' Set to print using portrait orientation.
    oPrintMgr.Orientation = kPortraitOrientation

    ' Set the paper size.
    oPrintMgr.PaperSize = kPaperSize11x17

    ' Set to print all sheets.
    oPrintMgr.PrintRange = kPrintAllSheets

    ' Set to print full scale.
    oPrintMgr.ScaleMode = kPrintFullScale

    ' Submit the print.
    oPrintMgr.SubmitPrint

    ' Change the number of copies to 1.
    oPrintMgr.NumberOfCopies = 1

    ' Change the paper size to a custom size.  The units are in centimeters.
    oPrintMgr.PaperSize = kPaperSizeCustom
    oPrintMgr.PaperHeight = 15
    oPrintMgr.PaperWidth = 10

    ' Get and set the current sheet range.
    Dim iFromSheet As Long
    Dim iToSheet As Long
    Call oPrintMgr.GetSheetRange(iFromSheet, iToSheet)

    MsgBox "Current sheet range is " & iFromSheet & " to " & iToSheet & Chr(13) & _
            "Setting to print sheets 1-2."

    ' Change the print range to print sheets 1 through 2.
    oPrintMgr.PrintRange = kPrintSheetRange
    Call oPrintMgr.SetSheetRange(1, 2)

    ' Submit the print.
    oPrintMgr.SubmitPrint
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Methods > DrawingPrintManager.SetSheetRange Method


DrawingPrintManager Properties

DrawingPrintManager Properties
Summary

The properties of the DrawingPrintManager class are listed here.

Properties
Name | Description
AllColorsAsBlack | Property that gets and sets whether all the Drawing colors should be printed in black only. This property only applies to drawing documents. It is initialized to False.
PrintExcludedSheets | Property that gets and sets whether exluded sheets should be printed. This property applies only in drawing documents and when the PrintRange property is set to either kPrintAllSheets or kPrintSheetRange.
PrintRange | Property that gets and sets which sheets to print.
RemoveLineWeights | Gets/Sets the Boolean flag indicating whether the Drawing line weights should be removed in the print.
Rotate90Degrees | Property that gets and sets whether the drawing should be rotated 90 degrees when printed. This property only applies to drawing documents. It is initialized to False.
Scale | Property that gets and sets the scale of the plot. This property is only valid when the Scalemode property is set to kCustomScale.
ScaleMode | Property that gets and sets how the scale of the print is defined. The options below can be used in drawing documents. All other documents always print using the best fit option. This property is initialized to kPrintBestFitScale.
TilingEnabled | Property that gets and sets whether tiling is enabled during print.
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties


DrawingPrintManager.AllColorsAsBlack Property

DrawingPrintManager.AllColorsAsBlack Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether all the Drawing colors should be printed in black only. This property only applies to drawing documents. It is initialized to False.

Visual Basic
Property AllColorsAsBlack() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.AllColorsAsBlack Property


DrawingPrintManager.PrintExcludedSheets Property

DrawingPrintManager.PrintExcludedSheets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether exluded sheets should be printed. This property applies only in drawing documents and when the PrintRange property is set to either kPrintAllSheets or kPrintSheetRange.

Visual Basic
Property PrintExcludedSheets() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.PrintExcludedSheets Property


DrawingPrintManager.PrintRange Property

DrawingPrintManager.PrintRange Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets which sheets to print.

Visual Basic
Property PrintRange() As PrintRangeEnum
Remarks

If this property is set to kPrintCurrentSheet then the active sheet will be printed.

If this property is set to kPrintAllSheets then all sheets will be printed. Depending on the value of the PrintExcludedSheets property, the excluded sheets may not print.

If this property is set to kPrintSheetRange then the sheets defined using SetSheetRange will be printed.

See Also

Printing - Drawing Print sample

Printing - All Sheets in Drawing sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.PrintRange Property


DrawingPrintManager.RemoveLineWeights Property

DrawingPrintManager.RemoveLineWeights Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets/Sets the Boolean flag indicating whether the Drawing line weights should be removed in the print.

Visual Basic
Property RemoveLineWeights() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.RemoveLineWeights Property


DrawingPrintManager.Rotate90Degrees Property

DrawingPrintManager.Rotate90Degrees Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the drawing should be rotated 90 degrees when printed. This property only applies to drawing documents. It is initialized to False.

Visual Basic
Property Rotate90Degrees() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.Rotate90Degrees Property


DrawingPrintManager.Scale Property

DrawingPrintManager.Scale Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the scale of the plot. This property is only valid when the Scalemode property is set to kCustomScale.

Visual Basic
Property Scale() As double
Remarks

The scale is specified in a decimal form. For example if you need to plot as drawing as 1/4 scale, this property should be set to 0.25. If you need to plot at twice the scale this property should be set to 2. If the paper is smaller than the specified sheet size, a portion of the sheet will not print.

You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.Scale Property


DrawingPrintManager.ScaleMode Property

DrawingPrintManager.ScaleMode Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the scale of the print is defined. The options below can be used in drawing documents. All other documents always print using the best fit option. This property is initialized to kPrintBestFitScale.

Visual Basic
Property ScaleMode() As PrintScaleModeEnum
Remarks

If this property is set to kPrintFullScale then the plot is printed at full scale. If the paper is smaller than the specified sheet size, a portion of the sheet will not print.

If this property is set to kPrintBestFitScale the sheet will be scaled to fit on the current paper size. This is the only valid option when printing from anything but a drawing document.

If this property is set to kCustomScale, you can use the Scale property to specify a precise scale. If the paper is smaller than the specified sheet size, a portion of the sheet will not print.

If this property is set to kPrintCurrentWindow the contents displayed within the currently active window are printed using a best-fit scale. Any graphics outside the window are not printed.

See Also

Printing - Drawing Print sample

Printing - All Sheets in Drawing sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.ScaleMode Property


DrawingPrintManager.TilingEnabled Property

DrawingPrintManager.TilingEnabled Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether tiling is enabled during print.

Visual Basic
Property TilingEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingPrintManager Interface > DrawingPrintManager Properties > DrawingPrintManager.TilingEnabled Property


DrawingSettings Interface

DrawingSettings Interface Available in Inventor Available in Server Introduced in Inventor 7
Summary

The DrawingSettings object provides access to properties that provide read and write access of the various drawing document specific settings. This is somewhat equivalent to the Drawing tab of the Document Settings dialog.

Class Hierarchy
Inventor::DrawingSettings
Visual Basic
Public Interface DrawingSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.DrawingSettings

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface


DrawingSettings Properties

DrawingSettings Properties
Summary

The properties of the DrawingSettings class are listed here.

Properties
Name | Description
AlwaysUseBitmapsForShadedViews | Property that indicates whether bitmaps should always be used when displaying shaded drawing views.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutomatedCenterlineSettings | Property that returns an object that provides properties to set all of the various settings that are used as the default settings for this document when creating automatic centerlines.
CrossHatchClipping | Gets and sets whether cross hatches should be clipped about drawing annotations.
CustomPropertySourceFile | Property that gets and sets the full file name of the model file that contains custom properties to copy to the active drawing or template. The property can return or can be set to a null string to indicate no source file.
DeferUpdates | Property that indicates the state of the defer updates setting of the drawing. A value of True indicates that automatic updates are suppressed. A value of False indicates that the drawing will automatically update when the model changes. Note: If defer updates is set in a template, you will not be able to place views in the drawings created from it.
DimensionTextAlignment | Property that indicates the new text position for existing angular and linear dimensions when the geometry they are associated with is updated which in turn causes the dimensions to resize.
HighlightInvalidAnnotations | Property that indicates the state of the "invalid annotation highlighting" setting of the drawing. A value of True will cause invalid annotations to be highlighted. A value of False will suppress the highlighting.
InvalidFeatureBasedAnnotationsColor | Property that indicates the color for invalid feature-based annotations.
MemorySavingMode | Property that indicates the memory saving mode during drawing view computations.
OfflineImageFidelity | Property that indicates the printing quality for a shaded drawing view when Defer Updates is active. The options are: kLowerImageFidelity - which is 50 dpi kStandardImageFidelity - which is 100 dpi kBetterImageFidelity - which is 150 dpi kBestImageFidelity - which is 200 dpi
Parent | Property that returns the parent DrawingDocument object.
PreserveOrphanedAnnotations | Property that indicates whether orphaned annotations should be preserved and continued to be displayed.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties


DrawingSettings.AlwaysUseBitmapsForShadedViews Property

DrawingSettings.AlwaysUseBitmapsForShadedViews Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether bitmaps should always be used when displaying shaded drawing views.

Visual Basic
Property AlwaysUseBitmapsForShadedViews() As VARIANT_BOOL
Remarks

A drawing document that contains shaded views has the ability to store bitmaps that represent the shaded views when the drawing document is saved. When the drawing document is opened again, the shaded views can be displayed faster using the saved bitmaps instead of generating the full graphics corresponding to the shaded views. This property specifies whether shaded views should always be displayed using these saved bitmaps or only in offline situations, i.e. when the referenced model document that the view represents can no longer be located.

A value of True for this property specifies that shaded views should always be displayed using the stored bitmaps as long as the bitmaps accurately represent the current model views. For example, if a shaded view of a model is placed on a drawing sheet and then the model is modified so that the bitmap that represents the shaded view of the model is no longer accurate, then the shaded view will be recomputed and the bitmap will be replaced by the full graphics corresponding to the shaded view.

A value of False for this property specifies that shaded views should be displayed using the stored bitmaps only in offline situations, i.e. a given shaded view should be displayed using its stored bitmap only when the actual graphics for the view cannot be obtained because the referenced model document that the view represents can no longer be located. If the referenced model document can be located, the shaded view will be displayed using full graphics information obtained from the model.

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.AlwaysUseBitmapsForShadedViews Property


DrawingSettings.Application Property

DrawingSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.Application Property


DrawingSettings.AutomatedCenterlineSettings Property

DrawingSettings.AutomatedCenterlineSettings Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns an object that provides properties to set all of the various settings that are used as the default settings for this document when creating automatic centerlines.

Visual Basic
Property AutomatedCenterlineSettings() As AutomatedCenterlineSettings**
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.AutomatedCenterlineSettings Property


DrawingSettings.CrossHatchClipping Property

DrawingSettings.CrossHatchClipping Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets and sets whether cross hatches should be clipped about drawing annotations.

Visual Basic
Property CrossHatchClipping() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.CrossHatchClipping Property


DrawingSettings.CustomPropertySourceFile Property

DrawingSettings.CustomPropertySourceFile Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the full file name of the model file that contains custom properties to copy to the active drawing or template. The property can return or can be set to a null string to indicate no source file.

Visual Basic
Property CustomPropertySourceFile() As String
Remarks

The properties will be copied from the model into the active drawing or template when the first drawing view is placed. If this property is set after the first drawing view has already been placed, the properties will not be copied. The copy sets the starting properties for the drawing. Once copied, the properties do not update automatically when they are changed in the model.

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.CustomPropertySourceFile Property


DrawingSettings.DeferUpdates Property

DrawingSettings.DeferUpdates Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that indicates the state of the defer updates setting of the drawing. A value of True indicates that automatic updates are suppressed. A value of False indicates that the drawing will automatically update when the model changes. Note: If defer updates is set in a template, you will not be able to place views in the drawings created from it.

Visual Basic
Property DeferUpdates() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.DeferUpdates Property


DrawingSettings.DimensionTextAlignment Property

DrawingSettings.DimensionTextAlignment Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the new text position for existing angular and linear dimensions when the geometry they are associated with is updated which in turn causes the dimensions to resize.

Visual Basic
Property DimensionTextAlignment() As DimensionTextAlignmentEnum
Remarks

The valid options are kMaintainViewPositionAlignment, kMaintainCenteredTextAlignment and kMaintainAllTextAlignment.

Setting this property to kMaintainViewPositionAlignment maintains the current text position of all dimensions on the sheet.

Setting this property to kMaintainCenteredTextAlignment retains centered dimension placement while all other dimensions maintain their text positions on the sheet.

Setting this property to kMaintainAllTextAlignment attempts to maintain all dimension text positions relative to the dimension line.

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.DimensionTextAlignment Property


DrawingSettings.HighlightInvalidAnnotations Property

DrawingSettings.HighlightInvalidAnnotations Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that indicates the state of the "invalid annotation highlighting" setting of the drawing. A value of True will cause invalid annotations to be highlighted. A value of False will suppress the highlighting.

Visual Basic
Property HighlightInvalidAnnotations() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.HighlightInvalidAnnotations Property


DrawingSettings.InvalidFeatureBasedAnnotationsColor Property

DrawingSettings.InvalidFeatureBasedAnnotationsColor Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the color for invalid feature-based annotations.

Visual Basic
Property InvalidFeatureBasedAnnotationsColor() As Color*
Remarks

This property can be used to specify a color only if the PreserveOrphanedAnnotations property has been set to True to indicate that orphaned annotations that have become detached from their corresponding geometry should continue to be displayed in the drawing. If the PreserveOrphanedAnnotations property is False, then the orphaned annotations will be deleted, hence this property does not apply and will fail.

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.InvalidFeatureBasedAnnotationsColor Property


DrawingSettings.MemorySavingMode Property

DrawingSettings.MemorySavingMode Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the memory saving mode during drawing view computations.

Visual Basic
Property MemorySavingMode() As MemorySavingModeEnum
Remarks

The valid options are kUseApplicationOptionsMemoryMode, kAlwaysSaveMemoryMode and kNeverSaveMemoryMode.

Setting this property to kUseApplicationOptionsMemoryMode specifies that the default setting on the Drawing tab of the Application Options dialog box should be used for the memory saving mode.

Setting this property to kAlwaysSaveMemoryMode specifies that memory conservation should be done for all drawing view computations.

Setting this property to kNeverSaveMemoryMode specifies that memory conservation should not be done for any drawing view computation.

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.MemorySavingMode Property


DrawingSettings.OfflineImageFidelity Property

DrawingSettings.OfflineImageFidelity Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that indicates the printing quality for a shaded drawing view when Defer Updates is active. The options are: kLowerImageFidelity - which is 50 dpi kStandardImageFidelity - which is 100 dpi kBetterImageFidelity - which is 150 dpi kBestImageFidelity - which is 200 dpi

Visual Basic
Property OfflineImageFidelity() As OfflineImageFidelityEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.OfflineImageFidelity Property


DrawingSettings.Parent Property

DrawingSettings.Parent Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the parent DrawingDocument object.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.Parent Property


DrawingSettings.PreserveOrphanedAnnotations Property

DrawingSettings.PreserveOrphanedAnnotations Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether orphaned annotations should be preserved and continued to be displayed.

Visual Basic
Property PreserveOrphanedAnnotations() As VARIANT_BOOL
Remarks

A value of True indicates that orphaned annotations should be preserved and continued to be displayed. A value of False will cause all orphaned annotations to be deleted.

You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.PreserveOrphanedAnnotations Property


DrawingSettings.Type Property

DrawingSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingSettings Interface > DrawingSettings Properties > DrawingSettings.Type Property


DrawingSketch Interface

DrawingSketch Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DrawingSketch object represents a sketch within a drawing.

Class Hierarchy
Inventor::Sketch
    Inventor::DrawingSketch
Visual Basic
Public Interface DrawingSketch
Inherits Sketch
Remarks

This object represents sketches for sheets, views, title block definitions, border definitions, and sketched symbols. For operations that deal with sketch contents, such as adding SketchEntities and TextBoxes inside a Sketch to a SelectSet, ensure the Sketch is in Edit mode. Call the Edit method, then ExitEdit afterwards to exit edit mode.

Notes

Members through which this object may be accessed include:

BorderDefinition.Sketch

DrawingSketches.Add

DrawingSketches.Item

SectionDrawingView.SectionLineSketch

SketchedSymbolDefinition.Sketch

TitleBlockDefinition.Sketch

See Also

Title Block Definition Create and Insert sample

Create SketchedSymbol Definition sample

Sketch fill region sample

Example

"Drawing Sketches - editing line type and color Example "

This sample demonstrates the modification of sketch entity line type and color in drawings.

Open a drawing document and run the following sample.

Public Sub ModifyDrawingSketchEntityProperties()
    ' Set a reference to the active document.  This assumes it
    ' is a drawing document.
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the drawing view on the active sheet.
    Dim oDrawView As DrawingView
    Set oDrawView = oDoc.ActiveSheet.DrawingViews.AddDraftView

    ' Set a reference to the sketch of the draft view.
    Dim oSketch As DrawingSketch
    Set oSketch = oDrawView.Sketches.Item(1)

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Draw two lines in the sketch.
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(10, 10), oTG.CreatePoint2d(30, 30))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(10, 30), oTG.CreatePoint2d(30, 10))

    ' Create a transient color object.
    Dim oColor As Color
    Set oColor = ThisApplication.TransientObjects.CreateColor(255, 0, 0) 'Red

    ' Override the color of the first line.
    oSketch.SketchLines(1).OverrideColor = oColor

    ' Override the line type of the second line.
    oSketch.SketchLines(2).LineType = kDashedLineType

    ' Override the line weight of the second line.
    oSketch.SketchLines(2).LineWeight = 0.11

    ' Override the line scale of the second line.
    oSketch.SketchLines(2).LineScale = 0.5

    ' Exit from editing the sketch.
    oSketch.ExitEdit
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface


DrawingSketch Methods

DrawingSketch Methods
Summary

The methods of the DrawingSketch class are listed here.

Methods
Methods
Name | Description
GetAutomatedCenterlineSettings | Method that returns the settings that define how automatic center lines and center marks are to be calculated for this sketch.
SetAutomatedCenterlineSettings | Method that sets the automatic centerline and center mark settings for this sketch and creates the centerlines and center marks defined by the settings. The centerlines and center marks that were created are returned.
SheetToSketchSpace | Method that takes a coordinate in sheet space returns a Point2d object containing the resulting coordinate point in sketch space.
SketchToSheetSpace | Method that takes a coordinate in sketch space, and returns a Point2d object containing the coordinates of the point in sheet space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Methods


DrawingSketch.GetAutomatedCenterlineSettings Method

DrawingSketch.GetAutomatedCenterlineSettings Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the settings that define how automatic center lines and center marks are to be calculated for this sketch.

Visual Basic
Sub GetAutomatedCenterlineSettings(ByRef AutomatedCenterlineSettings As AutomatedCenterlineSettings*)
Parameters
Parameters | Description
AutomatedCenterlineSettings | Output AutomatedCenterlineSettings object that defines the automatic center line and center mark creation settings for this drawing sketch.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Methods > DrawingSketch.GetAutomatedCenterlineSettings Method


DrawingSketch.SetAutomatedCenterlineSettings Method

DrawingSketch.SetAutomatedCenterlineSettings Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the automatic centerline and center mark settings for this sketch and creates the centerlines and center marks defined by the settings. The centerlines and center marks that were created are returned.

Visual Basic
Sub SetAutomatedCenterlineSettings(ByRef AutomatedCenterlineSettings As [optional] VARIANT, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
AutomatedCenterlineSettings | Optional input AutomatedCenterlineSettings object that defines the automatic center line and center mark creation settings for this sketch. If this argument is omitted the following rules apply. If automated centerlines and center marks have not been created for this sketch then this argument will default to the settings defined by the drawing settings. If this sketch has had automatic centerlines and center marks created, then the values used for the previous created are used.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Methods > DrawingSketch.SetAutomatedCenterlineSettings Method


DrawingSketch.SheetToSketchSpace Method

DrawingSketch.SheetToSketchSpace Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that takes a coordinate in sheet space returns a Point2d object containing the resulting coordinate point in sketch space.

Visual Basic
Sub SheetToSketchSpace(SheetCoordinate As Point2d, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
SheetCoordinate | Input object of a point within sheet space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Methods > DrawingSketch.SheetToSketchSpace Method


DrawingSketch.SketchToSheetSpace Method

DrawingSketch.SketchToSheetSpace Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that takes a coordinate in sketch space, and returns a Point2d object containing the coordinates of the point in sheet space.

Visual Basic
Sub SketchToSheetSpace(SketchCoordinate As Point2d, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
SketchCoordinate | Input object of a point within sketch space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Methods > DrawingSketch.SketchToSheetSpace Method


DrawingSketch Properties

DrawingSketch Properties
Summary

The properties of the DrawingSketch class are listed here.

Properties
Name | Description
Profiles | Gets the profiles collection associated with this drawing sketch.
SketchFillRegions |
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Properties


DrawingSketch.Profiles Property

DrawingSketch.Profiles Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the profiles collection associated with this drawing sketch.

Visual Basic
Property Profiles() As Profiles**
See Also

Sketch fill region sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Properties > DrawingSketch.Profiles Property


DrawingSketch.SketchFillRegions Property

DrawingSketch.SketchFillRegions Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property SketchFillRegions() As SketchFillRegions**
Example

"Sketch fill region."

This sample demonstrates the sketch fill functionality in drawing sketches. Have a drawing document open and run the sample.

Public Sub DrawingSketchFill()
    ' Set a reference to the active document. This assumes it
    ' is a drawing document.
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Create a sketch on the active sheet
    Dim oSketch As DrawingSketch
    Set oSketch = oDoc.ActiveSheet.Sketches.Add

    ' Put the sketch in edit mode
    oSketch.Edit

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Draw a circle in the sketch.
    Dim oCircle1 As SketchCircle
    Set oCircle1 = oSketch.SketchCircles.AddByCenterRadius(oTG.CreatePoint2d(10, 30), 2)

    ' Create a collection and add the circle.
    Dim oCollection1 As ObjectCollection
    Set oCollection1 = ThisApplication.TransientObjects.CreateObjectCollection
    oCollection1.Add oCircle1

    ' Create a profile from the first circle
    Dim oProfile1 As Profile
    Set oProfile1 = oSketch.Profiles.AddForSolid(False, oCollection1)

    ' Create a fill region based on the layer color.
    Call oSketch.SketchFillRegions.Add(oProfile1)

    ' Draw another circle in the sketch.
    Dim oCircle2 As SketchCircle
    Set oCircle2 = oSketch.SketchCircles.AddByCenterRadius(oTG.CreatePoint2d(30, 30), 2)

    ' Create a collection and add the circle.
    Dim oCollection2 As ObjectCollection
    Set oCollection2 = ThisApplication.TransientObjects.CreateObjectCollection
    oCollection2.Add oCircle2

    ' Create a profile from the second circle
    Dim oProfile2 As Profile
    Set oProfile2 = oSketch.Profiles.AddForSolid(False, oCollection2)

    ' Create a transient color object.
    Dim oColor As Color
    Set oColor = ThisApplication.TransientObjects.CreateColor(255, 0, 0) 'Red

    ' Create a fill region with an override color.
    Call oSketch.SketchFillRegions.Add(oProfile2, oColor)

    ' Exit from editing the sketch.
    oSketch.ExitEdit
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketch Interface > DrawingSketch Properties > DrawingSketch.SketchFillRegions Property


DrawingSketches Interface

DrawingSketches Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The DrawingSketches collection object provides access to the objects associated with the object the collection was obtained from.

Class Hierarchy
Inventor::DrawingSketches
Visual Basic
Public Interface DrawingSketches
Inherits IDispatch
Remarks

The DrawingSketches object also provides functionality to create new sketches.

Notes

Members through which this object may be accessed include:

DrawingView.Sketches

Sheet.Sketches

You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface


DrawingSketches Methods

DrawingSketches Methods
Summary

The methods of the DrawingSketches class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new drawing sketch.
Item | Property that returns the specified DrawingSketch object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Methods


DrawingSketches.Add Method

DrawingSketches.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new drawing sketch.

Visual Basic
Sub Add(Result As [out, retval] DrawingSketch*)
See Also

Sketch within a drawing view sample

Sketch fill region sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Methods > DrawingSketches.Add Method


DrawingSketches.Item Method

DrawingSketches.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified DrawingSketch object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DrawingSketch*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the sketch name. If an out of range index or a name of a non-existent sketch is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Methods > DrawingSketches.Item Method


DrawingSketches Properties

DrawingSketches Properties
Summary

The properties of the DrawingSketches class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Properties


DrawingSketches.Application Property

DrawingSketches.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Properties > DrawingSketches.Application Property


DrawingSketches.Count Property

DrawingSketches.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Properties > DrawingSketches.Count Property


DrawingSketches.Type Property

DrawingSketches.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingSketches Interface > DrawingSketches Properties > DrawingSketches.Type Property


DrawingStandardStyle Interface

DrawingStandardStyle Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingStandardStyle object represents a drawing standard.

Class Hierarchy
Inventor::Style
    Inventor::DrawingStandardStyle
Visual Basic
Public Interface DrawingStandardStyle
Inherits Style
Notes

Members through which this object may be accessed include:

DrawingStandardStylesEnumerator.Item

DrawingStylesManager.ActiveStandardStyle

You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface


DrawingStandardStyle Methods

DrawingStandardStyle Methods
Summary

The methods of the DrawingStandardStyle class are listed here.

Methods
Methods
Name | Description
GetViewLabelDefaults | Method that returns the drawing view label defaults for the specified view type.
SetViewLabelDefaults | Method that sets the drawing view label defaults for the specified view type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Methods


DrawingStandardStyle.GetViewLabelDefaults Method

DrawingStandardStyle.GetViewLabelDefaults Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the drawing view label defaults for the specified view type.

Visual Basic
Sub GetViewLabelDefaults(ViewType As DrawingViewTypeEnum, ByRef Prefix As String, ByRef Visible As VARIANT_BOOL, ByRef FormattedText As String, ByRef ConstrainToBorder As VARIANT_BOOL, ByRef PlaceBelowView As VARIANT_BOOL)
Parameters
Parameters | Description
ViewType | Input DrawingViewTypeEnum value that specifies the drawing view type for which to return the label defaults.
Prefix | Output String that returns the default view label prefix.
Visible | Output Boolean that returns whether the label should be displayed by default.
FormattedText | Output String that returns the content of the view label. See the documentation of the DrawingViewLabel.FormattedText property for details, or see the list of XML text formatting tags under Reference Topics in the Overviews section.
ConstrainToBorder | Output Boolean that returns whether the view label is constrained to the view. If a value of True is returned, the view label maintains its relative position to the view boundary as the boundary changes in size or position due to a modeling change, changing a view's assembly representation, or changing the view scale.
PlaceBelowView | Output Boolean that returns whether to place the label below or above the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Methods > DrawingStandardStyle.GetViewLabelDefaults Method


DrawingStandardStyle.SetViewLabelDefaults Method

DrawingStandardStyle.SetViewLabelDefaults Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the drawing view label defaults for the specified view type.

Visual Basic
Sub SetViewLabelDefaults(ViewType As DrawingViewTypeEnum, Prefix As String, Visible As VARIANT_BOOL, FormattedText As String, ConstrainToBorder As VARIANT_BOOL, PlaceBelowView As VARIANT_BOOL)
Parameters
Parameters | Description
ViewType | Input DrawingViewTypeEnum value that specifies the drawing view type for which to set the label defaults.
Prefix | Input String that specifies the default view label prefix.
Visible | Input Boolean that specifies whether the label should be displayed by default.
FormattedText | Input String that sets the content of the view label. See the documentation of the DrawingViewLabel.FormattedText property for details, or see the list of XML text formatting tags under Reference Topics in the Overviews section.
ConstrainToBorder | Input Boolean that specifies whether the view label is constrained to the view. If set to True, the view label maintains its relative position to the view boundary as the boundary changes in size or position due to a modeling change, changing a view's assembly representation, or changing the view scale.
PlaceBelowView | Input Boolean that specifies whether to place the label below or above the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Methods > DrawingStandardStyle.SetViewLabelDefaults Method


DrawingStandardStyle Properties

DrawingStandardStyle Properties
Summary

The properties of the DrawingStandardStyle class are listed here.

Properties
Name | Description
ActiveObjectDefaults | Returns the active ObjectDefaultsStyle object.
ApplyExcludeCharactersToBendTables | Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from bend tables and its associated tags.
ApplyExcludeCharactersToHoleTables | Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from hole tables and its associated tags.
ApplyExcludeCharactersToRevisionTables | Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from revision tables and its associated tags.
ApplyExcludeCharactersToViewNames | Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from view names.
DecimalMarkerType | Property that gets and sets the character to use as a decimal marker. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker.
ExcludeCharacters | Property that gets and sets comma separated list of characters to be excluded from automatic alphabetical indexing. The setting applies to indexing of newly created drawing views or table rows. Existing objects in the drawing are not affected.
FirstAngleProjection | Property that gets and sets whether the projection type is first angle or third angle projection. Third angle if the property is set to False.
FrontViewPlane | Property that gets and sets the viewing plane to use as front view when creating a drawing view.
GlobalLineScale | Property that gets and sets the line scale for all line styles in the drawing.
InternationalStandardReference | Property that returns the International Standard on which this standard style is based.
LinearUnits | Property that gets and sets the units of length measure.
PartialCircularThreadEdge | Property that gets and sets thread edge display type for top views.
PartialSectionThreadEnd | Property that gets and sets thread edge display type for sectional views.
PresetLineWeights | Property that gets and sets an array of Doubles that specify the set of default values for line weights.
PresetScales | Property that gets and sets an array of Strings that specify the set of default values for drawing view scales.
PresetSectionHatchAngles | Property that gets and sets an array of Doubles that specify the set of default values for section hatch angles.
PresetTextHeights | Property that gets and sets an array of Doubles that specify the set of default values for text heights.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties


DrawingStandardStyle.ActiveObjectDefaults Property

DrawingStandardStyle.ActiveObjectDefaults Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns the active ObjectDefaultsStyle object.

Visual Basic
Property ActiveObjectDefaults() As ObjectDefaultsStyle *
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.ActiveObjectDefaults Property


DrawingStandardStyle.ApplyExcludeCharactersToBendTables Property

DrawingStandardStyle.ApplyExcludeCharactersToBendTables Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from bend tables and its associated tags.

Visual Basic
Property ApplyExcludeCharactersToBendTables() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.ApplyExcludeCharactersToBendTables Property


DrawingStandardStyle.ApplyExcludeCharactersToHoleTables Property

DrawingStandardStyle.ApplyExcludeCharactersToHoleTables Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from hole tables and its associated tags.

Visual Basic
Property ApplyExcludeCharactersToHoleTables() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.ApplyExcludeCharactersToHoleTables Property


DrawingStandardStyle.ApplyExcludeCharactersToRevisionTables Property

DrawingStandardStyle.ApplyExcludeCharactersToRevisionTables Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from revision tables and its associated tags.

Visual Basic
Property ApplyExcludeCharactersToRevisionTables() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.ApplyExcludeCharactersToRevisionTables Property


DrawingStandardStyle.ApplyExcludeCharactersToViewNames Property

DrawingStandardStyle.ApplyExcludeCharactersToViewNames Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to exclude characters specified in the ExcludeCharacters property from view names.

Visual Basic
Property ApplyExcludeCharactersToViewNames() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.ApplyExcludeCharactersToViewNames Property


DrawingStandardStyle.DecimalMarkerType Property

DrawingStandardStyle.DecimalMarkerType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the character to use as a decimal marker. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker.

Visual Basic
Property DecimalMarkerType() As DecimalMarkerTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.DecimalMarkerType Property


DrawingStandardStyle.ExcludeCharacters Property

DrawingStandardStyle.ExcludeCharacters Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets comma separated list of characters to be excluded from automatic alphabetical indexing. The setting applies to indexing of newly created drawing views or table rows. Existing objects in the drawing are not affected.

Visual Basic
Property ExcludeCharacters() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.ExcludeCharacters Property


DrawingStandardStyle.FirstAngleProjection Property

DrawingStandardStyle.FirstAngleProjection Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the projection type is first angle or third angle projection. Third angle if the property is set to False.

Visual Basic
Property FirstAngleProjection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.FirstAngleProjection Property


DrawingStandardStyle.FrontViewPlane Property

DrawingStandardStyle.FrontViewPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the viewing plane to use as front view when creating a drawing view.

Visual Basic
Property FrontViewPlane() As FrontViewPlaneEnum
Remarks

Valid values are kFrontViewXYPlane, kFrontViewYZPlane, kFrontViewXZPlane and kFrontViewFromModel. Setting this property affects the orientation of all subsequent drawing views, but has no effect on existing views. If set to kFrontViewFromModel, front view orientation settings from the model document are used to calculate view orientations in drawings.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.FrontViewPlane Property


DrawingStandardStyle.GlobalLineScale Property

DrawingStandardStyle.GlobalLineScale Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the line scale for all line styles in the drawing.

Visual Basic
Property GlobalLineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.GlobalLineScale Property


DrawingStandardStyle.InternationalStandardReference Property

DrawingStandardStyle.InternationalStandardReference Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the International Standard on which this standard style is based.

Visual Basic
Property InternationalStandardReference() As DraftingStandardEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.InternationalStandardReference Property


DrawingStandardStyle.LinearUnits Property

DrawingStandardStyle.LinearUnits Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the units of length measure.

Visual Basic
Property LinearUnits() As UnitsTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.LinearUnits Property


DrawingStandardStyle.PartialCircularThreadEdge Property

DrawingStandardStyle.PartialCircularThreadEdge Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets thread edge display type for top views.

Visual Basic
Property PartialCircularThreadEdge() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.PartialCircularThreadEdge Property


DrawingStandardStyle.PartialSectionThreadEnd Property

DrawingStandardStyle.PartialSectionThreadEnd Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets thread edge display type for sectional views.

Visual Basic
Property PartialSectionThreadEnd() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.PartialSectionThreadEnd Property


DrawingStandardStyle.PresetLineWeights Property

DrawingStandardStyle.PresetLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets an array of Doubles that specify the set of default values for line weights.

Visual Basic
Property PresetLineWeights() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.PresetLineWeights Property


DrawingStandardStyle.PresetScales Property

DrawingStandardStyle.PresetScales Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets an array of Strings that specify the set of default values for drawing view scales.

Visual Basic
Property PresetScales() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.PresetScales Property


DrawingStandardStyle.PresetSectionHatchAngles Property

DrawingStandardStyle.PresetSectionHatchAngles Property
Summary

Property that gets and sets an array of Doubles that specify the set of default values for section hatch angles.

Visual Basic
Property PresetSectionHatchAngles() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.PresetSectionHatchAngles Property


DrawingStandardStyle.PresetTextHeights Property

DrawingStandardStyle.PresetTextHeights Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets an array of Doubles that specify the set of default values for text heights.

Visual Basic
Property PresetTextHeights() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStyle Interface > DrawingStandardStyle Properties > DrawingStandardStyle.PresetTextHeights Property


DrawingStandardStylesEnumerator Interface

DrawingStandardStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingStandardStylesEnumerator object provides access to the existing objects.

Class Hierarchy
Inventor::DrawingStandardStylesEnumerator
Visual Basic
Public Interface DrawingStandardStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.StandardStyles

You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface


DrawingStandardStylesEnumerator Methods

DrawingStandardStylesEnumerator Methods
Summary

The methods of the DrawingStandardStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object in the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface > DrawingStandardStylesEnumerator Methods


DrawingStandardStylesEnumerator.Item Method

DrawingStandardStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] DrawingStandardStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the DrawingStandardStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the internal name of a DrawingStandardStyle. If an out of range index or a name of a non-existent DrawingStandardStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface > DrawingStandardStylesEnumerator Methods > DrawingStandardStylesEnumerator.Item Method


DrawingStandardStylesEnumerator Properties

DrawingStandardStylesEnumerator Properties
Summary

The properties of the DrawingStandardStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface > DrawingStandardStylesEnumerator Properties


DrawingStandardStylesEnumerator.Application Property

DrawingStandardStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface > DrawingStandardStylesEnumerator Properties > DrawingStandardStylesEnumerator.Application Property


DrawingStandardStylesEnumerator.Count Property

DrawingStandardStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface > DrawingStandardStylesEnumerator Properties > DrawingStandardStylesEnumerator.Count Property


DrawingStandardStylesEnumerator.Type Property

DrawingStandardStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingStandardStylesEnumerator Interface > DrawingStandardStylesEnumerator Properties > DrawingStandardStylesEnumerator.Type Property


DrawingStylesManager Interface

DrawingStylesManager Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The DrawingStylesManager object provides utilities to manage the various styles in a drawing document.

Class Hierarchy
Inventor::DrawingStylesManager
Visual Basic
Public Interface DrawingStylesManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.StylesManager

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface


DrawingStylesManager Properties

DrawingStylesManager Properties
Summary

The properties of the DrawingStylesManager class are listed here.

Properties
Name | Description
ActiveStandardStyle | Gets and sets the active standard style.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BalloonStyles | Property that returns the BalloonStylesEnumerator object.
CentermarkStyles | Property that returns the CentermarkStylesEnumerator object. This object provides access to all the center mark styles.
DimensionStyles | Property that returns the DimensionStylesEnumerator object. This object provides access to all the dimension styles.
FeatureControlFrameStyles | Property that returns the FeatureControlFrameStylesEnumerator object.
HoleTableStyles | Property that returns the HoleTableStylesEnumerator object.
Layers | Property that returns the LayersEnumerator object. This object provides access to all the layers.
LeaderStyles | Property that returns the LeaderStylesEnumerator object.
ObjectDefaultsStyles | Property that gets the ObjectDefaultsStylesEnumerator collection object.
Parent | Property that returns the parent object from whom this object can logically be reached.
PartsListStyles | Property that returns the PartsListStylesEnumerator object. This object provides access to all the parts list styles.
RevisionTableStyles | Property that returns the RevisionTableStylesEnumerator object. This object provides access to all the revision table styles.
StandardStyles | Property that returns the DrawingStandardStylesEnumerator object. This object provides access to all the standard styles.
Styles | Read-only property that returns the Styles object.
SurfaceTextureStyles | Property that returns the SurfaceTextureStylesEnumerator object.
TableStyles | Property that returns the TableStylesEnumerator object. This object provides access to all the general table styles.
TextStyles | Property that gets the TextStyles collection object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties


DrawingStylesManager.ActiveStandardStyle Property

DrawingStylesManager.ActiveStandardStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the active standard style.

Visual Basic
Property ActiveStandardStyle() As DrawingStandardStyle*
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.ActiveStandardStyle Property


DrawingStylesManager.Application Property

DrawingStylesManager.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.Application Property


DrawingStylesManager.BalloonStyles Property

DrawingStylesManager.BalloonStyles Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the BalloonStylesEnumerator object.

Visual Basic
Property BalloonStyles() As BalloonStylesEnumerator**
Remarks

This object provides access to all the balloon styles.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.BalloonStyles Property


DrawingStylesManager.CentermarkStyles Property

DrawingStylesManager.CentermarkStyles Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CentermarkStylesEnumerator object. This object provides access to all the center mark styles.

Visual Basic
Property CentermarkStyles() As CentermarkStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.CentermarkStyles Property


DrawingStylesManager.DimensionStyles Property

DrawingStylesManager.DimensionStyles Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the DimensionStylesEnumerator object. This object provides access to all the dimension styles.

Visual Basic
Property DimensionStyles() As DimensionStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.DimensionStyles Property


DrawingStylesManager.FeatureControlFrameStyles Property

DrawingStylesManager.FeatureControlFrameStyles Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the FeatureControlFrameStylesEnumerator object.

Visual Basic
Property FeatureControlFrameStyles() As FeatureControlFrameStylesEnumerator**
Remarks

This object provides access to all the feature control frame styles.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.FeatureControlFrameStyles Property


DrawingStylesManager.HoleTableStyles Property

DrawingStylesManager.HoleTableStyles Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the HoleTableStylesEnumerator object.

Visual Basic
Property HoleTableStyles() As HoleTableStylesEnumerator**
Remarks

This object provides access to all the hole table styles.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.HoleTableStyles Property


DrawingStylesManager.Layers Property

DrawingStylesManager.Layers Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the LayersEnumerator object. This object provides access to all the layers.

Visual Basic
Property Layers() As LayersEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.Layers Property


DrawingStylesManager.LeaderStyles Property

DrawingStylesManager.LeaderStyles Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the LeaderStylesEnumerator object.

Visual Basic
Property LeaderStyles() As LeaderStylesEnumerator**
Remarks

This object provides access to all the leader styles.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.LeaderStyles Property


DrawingStylesManager.ObjectDefaultsStyles Property

DrawingStylesManager.ObjectDefaultsStyles Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the ObjectDefaultsStylesEnumerator collection object.

Visual Basic
Property ObjectDefaultsStyles() As ObjectDefaultsStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.ObjectDefaultsStyles Property


DrawingStylesManager.Parent Property

DrawingStylesManager.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.Parent Property


DrawingStylesManager.PartsListStyles Property

DrawingStylesManager.PartsListStyles Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the PartsListStylesEnumerator object. This object provides access to all the parts list styles.

Visual Basic
Property PartsListStyles() As PartsListStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.PartsListStyles Property


DrawingStylesManager.RevisionTableStyles Property

DrawingStylesManager.RevisionTableStyles Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the RevisionTableStylesEnumerator object. This object provides access to all the revision table styles.

Visual Basic
Property RevisionTableStyles() As RevisionTableStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.RevisionTableStyles Property


DrawingStylesManager.StandardStyles Property

DrawingStylesManager.StandardStyles Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the DrawingStandardStylesEnumerator object. This object provides access to all the standard styles.

Visual Basic
Property StandardStyles() As DrawingStandardStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.StandardStyles Property


DrawingStylesManager.Styles Property

DrawingStylesManager.Styles Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Read-only property that returns the Styles object.

Visual Basic
Property Styles() As Styles**
Remarks

This object provides access to all the available styles.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.Styles Property


DrawingStylesManager.SurfaceTextureStyles Property

DrawingStylesManager.SurfaceTextureStyles Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the SurfaceTextureStylesEnumerator object.

Visual Basic
Property SurfaceTextureStyles() As SurfaceTextureStylesEnumerator**
Remarks

This object provides access to all the surface texture styles.

You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.SurfaceTextureStyles Property


DrawingStylesManager.TableStyles Property

DrawingStylesManager.TableStyles Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the TableStylesEnumerator object. This object provides access to all the general table styles.

Visual Basic
Property TableStyles() As TableStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.TableStyles Property


DrawingStylesManager.TextStyles Property

DrawingStylesManager.TextStyles Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the TextStyles collection object.

Visual Basic
Property TextStyles() As TextStylesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.TextStyles Property


DrawingStylesManager.Type Property

DrawingStylesManager.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingStylesManager Interface > DrawingStylesManager Properties > DrawingStylesManager.Type Property


DrawingView Interface

DrawingView Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DrawingView object represents a drawing view on a sheet. It allows access to information about drawing views. See the article in the overviews section.

Class Hierarchy
Inventor::DrawingView
    Inventor::DetailDrawingView
    Inventor::SectionDrawingView
Visual Basic
Public Interface DrawingView
Inherits IDispatch
Remarks

A drawing view is a 3D graphical representation of the model in the requested orientation, with all the superimposed portions of the geometries completely removed. The end user perceives a drawing view as being 2D.

A DrawingCurve has multiple segments if portions of it are obscured. Any segments are accessed using DrawingCurve.Segments property. Selections always deal with segments, not whole DrawingCurves. Similarly, visibility and layer control are at the segment level.

Model edges, model sketch entities, and view sketch entities are represented by the DrawingCurve object, accessed through DrawingView.DrawingCurves. Sheet sketch entities are represented by the SketchEntity object, and are accessed through Sketch.SketchEntities. The CenterLine and Centermark objects are accessed via Sheet.Centerlines and Sheet.Centermarks respectively.

It's important to remember that there are no corresponding drawing entities for model entities, so drawing entities obtained using FindUsingPoint may not be the intended ones, resulting in association to incorrect geometry. Also, the drawing view curves are recreated any time the drawing updates (for example, if the model recomputes). When initiating many changes to the sketch, consider using the DeferUpdates property to improve performance.

Please also refer to the GeometryIntent object for information about specifying points for dimensions.

Notes

Members through which this object may be accessed include:

Balloon.ParentView

BreakOperation.Parent

BreakOutOperation.Parent

DrawingCurve.Parent

DrawingView.ParentView

DrawingView.CopyTo

DrawingView.MoveTo

DrawingViewEventsObject.Parent

DrawingViewLabel.Parent

DrawingViews.AddAssociativeDraftView

DrawingViews.AddAuxiliaryView

DrawingViews.AddBaseView

DrawingViews.AddDraftView

DrawingViews.AddOverlayView

DrawingViews.AddProjectedView

DrawingViews.Item

HoleTable.ParentView

PartsList.ParentView

See Also

Chain dimensions sets sample

Creation of a break operation in a drawing view sample

Baseline dimension sets sample

Creating a parts list sample

Creating hole tables sample

Creation a balloon sample

Example

See DrawingViews::AddDraftView for example "Adding a draft view"

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface


DrawingView Methods

DrawingView Methods
Summary

The methods of the DrawingView class are listed here.

Methods
Methods
Name | Description
Align | Method that aligns this view with the input drawing view. The method returns a failure if the view is already aligned. Use the Aligned property to check for this condition and to break existing alignment.
AlignAuxiliary | Method that re-aligns an auxiliary view. The method fails if the view is not an auxiliary view.
CopyTo | Method that copies this drawing view into the specified sheet. The new object is returned.
CreateOriginIndicator | Method that creates the origin indicator for ordinate dimensions and hole tables. The specified input GeometryIntent object must be associated with this drawing view, otherwise this method will fail.
Delete | Method that deletes the DrawingView.
DrawingCurves | Property that returns all the drawing curves within the drawing view optionally filtered to the input model object. This property returns Nothing for draft views.iew object represents a drawing view on a sheet.
DrawingViewToModelSpace | Method that takes a 2d coordinate in drawing view space, and returns a Line in model space. Since this method transforms from 2D space to 3D space, there is insufficient information to obtain a 3D model point. Hence, this method returns a Line in the view direction on which the point lies. You may then use the FindUsingRay method to find the point(s) of interest.
DrawingViewToSheetSpace | Method that takes a 2d coordinate in drawing view space, and returns a Point2d containing the coordinates of the point in sheet space.
GetAutomatedCenterlineSettings | Method that returns the settings that define how automatic center lines and center marks are to be calculated for this view.
GetIncludeStatus | Method that gets the include status of the input object in the drawing view.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetVisibility | Method that gets the visibility of the input object in the drawing view.
GetWeldmentState | Method that gets the weldment option for the drawing view. The method returns a failure if the referenced model does not contain weldments.
InsertInModelSpace | This is InsertInModelSpace, a member of class DrawingView.
ModelToDrawingViewSpace | Method that takes a 3d coordinate in model space, and returns a Point2d object containing the coordinate point in drawing view space.
ModelToSheetSpace | Method that takes a 3d coordinate in model space, and returns a Point2d object containing the coordinate point in sheet space.
MoveTo | Method that moves this drawing view into the specified sheet. The moved object is returned.
ReferencedFile | Property returning a ReferencedFileDescriptor object that describes the model file referenced by the view.
RotateByAngle | Method that rotates the drawing view by the specified angle.
SetAutomatedCenterlineSettings | Method that sets the automatic centerline and center mark settings for this view and creates the centerlines and center marks defined by the settings. The centerlines and center marks that were created are returned.
SetDesignViewRepresentation | Method that sets a design view representation for a drawing view of a part or an assembly. This method fails for drawing views of presentations and in the case where the model (part or assembly) is unresolved.
SetIncludeStatus | Method that sets the include status of the input object in the drawing view. This method automatically makes the object visible as well. After an object has been included, its visibility can be controlled using the GetVisibility and SetVisibility methods.
SetVisibility | Method that sets the visibility of the input object in the drawing view.
SetWeldmentState | Method that sets the weldment option for the drawing view. The method returns a failure if the referenced model does not contain weldments.
SheetToDrawingViewSpace | Method that takes a 2d coordinate in sheet space, and returns a Point2d object containing the coordinate point in drawing view space.
SheetToModelSpace | Method that takes a 2d coordinate in sheet space, and returns a Line in model space. Since this method transforms from 2D space to 3D space, there is insufficient information to obtain a 3D model point. Hence, this method returns a Line in the view direction on which the point lies. You may then use the FindUsingRay method to find the point(s) of interest.
ShowHiddenAnnotations | Method that displays all the annotations hidden by the user.
ShowHiddenCurves | Method that displays all the curves explicitly hidden by the user.
ShowName | Property that indicates whether to show the label (name) of the drawing view on the sheet.
ShowName | Property that indicates whether to show the label (name) of the drawing view on the sheet.
ShowScale | Property that indicates whether to show the scale of the drawing view on the sheet.
ShowScale | Property that indicates whether to show the scale of the drawing view on the sheet.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods


DrawingView.Align Method

DrawingView.Align Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that aligns this view with the input drawing view. The method returns a failure if the view is already aligned. Use the Aligned property to check for this condition and to break existing alignment.

Visual Basic
Sub Align(DrawingView As DrawingView, AlignmentType As DrawingViewAlignmentEnum)
Parameters
Parameters | Description
DrawingView | Input DrawingView object that specifies the view with which to align this view.
AlignmentType | Input DrawingViewAlignmentEnum that specifies the alignment type. Valid values are kHorizontalViewAlignment, kVerticalViewAlignment and kInPositionViewAlignment.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.Align Method


DrawingView.AlignAuxiliary Method

DrawingView.AlignAuxiliary Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that re-aligns an auxiliary view. The method fails if the view is not an auxiliary view.

Visual Basic
Sub AlignAuxiliary(DrawingCurve As DrawingCurve, Position As Point2d)
Parameters
Parameters | Description
DrawingCurve | Input DrawingCurve object that specifies the orientation edge for the auxiliary view. This must be from the parent view, else the method returns an error.
Position | Input Point2d object that specifies the new placement point for the auxiliary view on the sheet.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.AlignAuxiliary Method


DrawingView.CopyTo Method

DrawingView.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that copies this drawing view into the specified sheet. The new object is returned.

Visual Basic
Sub CopyTo(TargetSheet As Sheet, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
TargetSheet | Input Sheet object that specifies the sheet that this drawing view is to be copied into. An error occurs if the input sheet is the parent sheet object.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.CopyTo Method


DrawingView.CreateOriginIndicator Method

DrawingView.CreateOriginIndicator Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates the origin indicator for ordinate dimensions and hole tables. The specified input GeometryIntent object must be associated with this drawing view, otherwise this method will fail.

Visual Basic
Sub CreateOriginIndicator(Intent As GeometryIntent)
Parameters
Parameters | Description
Intent | Input GeometryIntent object that specifies the origin point with which the origin indicator is associated. The GeometryIntent object can be created using the Sheet.CreateGeometryIntent method. Valid intent values are points. If an invalid intent value is specified, this method will fail.
Remarks

This method will create the origin indicator on the view if one does not already exist as indicated by the HasOriginIndicator property returning a value of False. If an origin indicator has already been created for the view as indicated by the HasOriginIndicator property returning a value of True, this method will fail. The OriginIndicator property will return this already existing origin indicator. If the origin point with which this origin indicator is associated needs to be changed, it can be done using the OriginIndicator.Intent property.

See Also

Create ordinate dimension sample

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.CreateOriginIndicator Method


DrawingView.Delete Method

DrawingView.Delete Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that deletes the DrawingView.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.Delete Method


DrawingView.DrawingCurves Method

DrawingView.DrawingCurves Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the drawing curves within the drawing view optionally filtered to the input model object. This property returns Nothing for draft views.iew object represents a drawing view on a sheet.

Visual Basic
Sub DrawingCurves(ByRef ModelObject As [optional] VARIANT, Result As [out, retval] DrawingCurvesEnumerator*)
Parameters
Parameters | Description
ModelObject | Optional input object that specifies the object from the model for which the corresponding drawing view curves need to be retrieved. This could be an Edge, Face, PartFeature, Sketch, SketchEntity, Sketch3D, SketchEntity3D, ComponentOccurrence, or the proxies to any of these. If not specified, all the edges from the drawing view are returned.
See Also

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.DrawingCurves Method


DrawingView.DrawingViewToModelSpace Method

DrawingView.DrawingViewToModelSpace Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that takes a 2d coordinate in drawing view space, and returns a Line in model space. Since this method transforms from 2D space to 3D space, there is insufficient information to obtain a 3D model point. Hence, this method returns a Line in the view direction on which the point lies. You may then use the FindUsingRay method to find the point(s) of interest.

Visual Basic
Sub DrawingViewToModelSpace(ViewCoordinate As Point2d, Result As [out, retval] Line*)
Parameters
Parameters | Description
ViewCoordinate | Input Point2d object of a point within drawing view space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.DrawingViewToModelSpace Method


DrawingView.DrawingViewToSheetSpace Method

DrawingView.DrawingViewToSheetSpace Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that takes a 2d coordinate in drawing view space, and returns a Point2d containing the coordinates of the point in sheet space.

Visual Basic
Sub DrawingViewToSheetSpace(ViewCoordinate As Point2d, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
ViewCoordinate | Input Point2d object of a point within drawing view space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.DrawingViewToSheetSpace Method


DrawingView.GetAutomatedCenterlineSettings Method

DrawingView.GetAutomatedCenterlineSettings Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the settings that define how automatic center lines and center marks are to be calculated for this view.

Visual Basic
Sub GetAutomatedCenterlineSettings(ByRef AutomatedCenterlineSettings As AutomatedCenterlineSettings*)
Parameters
Parameters | Description
AutomatedCenterlineSettings | Output AutomatedCenterlineSettings object that defines the automatic center line and center mark creation settings for this drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.GetAutomatedCenterlineSettings Method


DrawingView.GetIncludeStatus Method

DrawingView.GetIncludeStatus Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that gets the include status of the input object in the drawing view.

Visual Basic
Sub GetIncludeStatus(Object As IDispatch, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | Input object to get the include status of. Valid objects are 2d and 3d sketches, work features, surface features, and proxies for all of these. The object needs to be supplied in the context of the document referenced by the drawing view. For instance, to set the include status of a 3D sketch within a part instanced in an assembly (and the drawing view is of the assembly), the input should be a Sketch3DProxy object created in context of the assembly. An error will occur if no corresponding object exists in the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.GetIncludeStatus Method


DrawingView.GetReferenceKey Method

DrawingView.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.GetReferenceKey Method


DrawingView.GetVisibility Method

DrawingView.GetVisibility Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that gets the visibility of the input object in the drawing view.

Visual Basic
Sub GetVisibility(Object As IDispatch, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | Input object to get the visibility state of. Valid objects are 2d and 3d sketches, work features, surface features, occurrences and proxies for all of these. The object needs to be supplied in the context of the document referenced by the drawing view. For instance, to set the visibility state of a 3D sketch within a part instanced in an assembly (and the drawing view is of the assembly), the input should be a Sketch3DProxy object created in context of the assembly. An error will occur if no corresponding object exists in the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.GetVisibility Method


DrawingView.GetWeldmentState Method

DrawingView.GetWeldmentState Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets the weldment option for the drawing view. The method returns a failure if the referenced model does not contain weldments.

Visual Basic
Sub GetWeldmentState(ByRef WeldmentState As WeldmentStateEnum, ByRef Component As IDispatch*)
Parameters
Parameters | Description
WeldmentState | Output WeldmentStateEnum that returns the weldment state of the drawing view. Valid return values are kAssemblyWeldmentState, kMachiningWeldmentState, kWeldsWeldmentState and kPreparationsWeldmentState. If kPreparationsWeldmentState is returned, the Component argument returns the corresponding preparations component.
Component | Output object that returns the component used for the Preparations weldment state. Valid return objects include an AssemblyDocument that represents the top level weldment document or a ComponentOccurrence that represents a first level occurrence in the weldment document.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.GetWeldmentState Method


DrawingView.InsertInModelSpace Method

DrawingView.InsertInModelSpace Method
Summary

This is InsertInModelSpace, a member of class DrawingView.

Visual Basic
Sub InsertInModelSpace()
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.InsertInModelSpace Method


DrawingView.ModelToDrawingViewSpace Method

DrawingView.ModelToDrawingViewSpace Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that takes a 3d coordinate in model space, and returns a Point2d object containing the coordinate point in drawing view space.

Visual Basic
Sub ModelToDrawingViewSpace(ModelCoordinate As Point, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
ModelCoordinate | Input Point object of a point within model space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ModelToDrawingViewSpace Method


DrawingView.ModelToSheetSpace Method

DrawingView.ModelToSheetSpace Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that takes a 3d coordinate in model space, and returns a Point2d object containing the coordinate point in sheet space.

Visual Basic
Sub ModelToSheetSpace(ModelCoordinate As Point, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
ModelCoordinate | Point object of a point within model space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ModelToSheetSpace Method


DrawingView.MoveTo Method

DrawingView.MoveTo Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that moves this drawing view into the specified sheet. The moved object is returned.

Visual Basic
Sub MoveTo(TargetSheet As Sheet, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
TargetSheet | Input Sheet object that specifies the sheet that this drawing view is to be moved into. An error occurs if the input sheet is the parent sheet object.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.MoveTo Method


DrawingView.ReferencedFile Method

DrawingView.ReferencedFile Method Available in Inventor Available in Server
Summary

Property returning a ReferencedFileDescriptor object that describes the model file referenced by the view.

Visual Basic
Sub ReferencedFile(Result As [out, retval] ReferencedFileDescriptor*)
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ReferencedFile Method


DrawingView.RotateByAngle Method

DrawingView.RotateByAngle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that rotates the drawing view by the specified angle.

Visual Basic
Sub RotateByAngle(Angle As double, ByRef Clockwise As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
Angle | Input double that specifies the angle by which to rotate the view.
Clockwise | Optional input Boolean that specifies whether to rotate the view clockwise or counter-clockwise. The default value is True indicating that the view will be rotated clockwise.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.RotateByAngle Method


DrawingView.SetAutomatedCenterlineSettings Method

DrawingView.SetAutomatedCenterlineSettings Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the automatic centerline and center mark settings for this view and creates the centerlines and center marks defined by the settings. The centerlines and center marks that were created are returned.

Visual Basic
Sub SetAutomatedCenterlineSettings(ByRef AutomatedCenterlineSettings As [optional] VARIANT, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
AutomatedCenterlineSettings | Optional input AutomatedCenterlineSettings object that defines the automatic center line and center mark creation settings for this drawing view. If this argument is omitted the following rules apply. If automated centerlines and center marks have not been created for this view then this argument will default to the settings defined by the drawing settings. If this view has had automatic centerlines and center marks created, then the values used for the previous created are used.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SetAutomatedCenterlineSettings Method


DrawingView.SetDesignViewRepresentation Method

DrawingView.SetDesignViewRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets a design view representation for a drawing view of a part or an assembly. This method fails for drawing views of presentations and in the case where the model (part or assembly) is unresolved.

Visual Basic
Sub SetDesignViewRepresentation(Representation As String, ByRef Associative As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Representation | String that specifies the Design View Representation to set on the drawing view. The method returns a failure if a representation with this name is not found in the referenced model.
Associative | Optional input Boolean that indicates whether to associatively apply the design view. If set to True, any changes to the design view in the referenced model will show in this view. If not specified, a value of False is used.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SetDesignViewRepresentation Method


DrawingView.SetIncludeStatus Method

DrawingView.SetIncludeStatus Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the include status of the input object in the drawing view. This method automatically makes the object visible as well. After an object has been included, its visibility can be controlled using the GetVisibility and SetVisibility methods.

Visual Basic
Sub SetIncludeStatus(Object As IDispatch, Include As VARIANT_BOOL)
Parameters
Parameters | Description
Object | Input object to set the include status of. Valid objects are 2d& 3d sketches, work features, surface features, and proxies for all of these. The object needs to be supplied in the context of the document referenced by the drawing view. For instance, to set the include status of a 3D sketch within a part instanced in an assembly (and the drawing view is of the assembly), the input should be a Sketch3DProxy object created in context of the assembly. An error will occur if no corresponding object exists in the drawing view.
Include | Input Boolean that specifies whether the input object is included in the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SetIncludeStatus Method


DrawingView.SetVisibility Method

DrawingView.SetVisibility Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that sets the visibility of the input object in the drawing view.

Visual Basic
Sub SetVisibility(Object As IDispatch, Visible As VARIANT_BOOL)
Parameters
Parameters | Description
Object | Input object to set the visibility state of. Valid objects are 2d& 3d sketches, work features, surface features, occurrences and proxies for all of these. The object needs to be supplied in the context of the document referenced by the drawing view. For instance, to set the visibility state of a 3D sketch within a part instanced in an assembly (and the drawing view is of the assembly), the input should be a Sketch3DProxy object created in context of the assembly. An error will occur if no corresponding object exists in the drawing view.
Visible | Input Boolean that specifies whether the input object is visible in the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SetVisibility Method


DrawingView.SetWeldmentState Method

DrawingView.SetWeldmentState Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the weldment option for the drawing view. The method returns a failure if the referenced model does not contain weldments.

Visual Basic
Sub SetWeldmentState(WeldmentState As WeldmentStateEnum, ByRef Component As [optional] VARIANT)
Parameters
Parameters | Description
WeldmentState | Input WeldmentStateEnum that specifies the weldment state of the drawing view. Valid options are kAssemblyWeldmentState, kMachiningWeldmentState, kWeldsWeldmentState and kPreparationsWeldmentState. If kPreparationsWeldmentState is specified, the Component argument must also be specified, else the top level weldment document is assumed as the component.
Component | Optional input object that specifies the component to use for the Preparations weldment state. Valid input objects include an AssemblyDocument that represents the top level weldment document or a ComponentOccurrence that represents a first level occurrence in the weldment document.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SetWeldmentState Method


DrawingView.SheetToDrawingViewSpace Method

DrawingView.SheetToDrawingViewSpace Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that takes a 2d coordinate in sheet space, and returns a Point2d object containing the coordinate point in drawing view space.

Visual Basic
Sub SheetToDrawingViewSpace(SheetCoordinate As Point2d, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
SheetCoordinate | Input Point2d object of a point within sheet space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SheetToDrawingViewSpace Method


DrawingView.SheetToModelSpace Method

DrawingView.SheetToModelSpace Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that takes a 2d coordinate in sheet space, and returns a Line in model space. Since this method transforms from 2D space to 3D space, there is insufficient information to obtain a 3D model point. Hence, this method returns a Line in the view direction on which the point lies. You may then use the FindUsingRay method to find the point(s) of interest.

Visual Basic
Sub SheetToModelSpace(SheetCoordinate As Point2d, Result As [out, retval] Line*)
Parameters
Parameters | Description
SheetCoordinate | Input Point2d object of a point within sheet space.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.SheetToModelSpace Method


DrawingView.ShowHiddenAnnotations Method

DrawingView.ShowHiddenAnnotations Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that displays all the annotations hidden by the user.

Visual Basic
Sub ShowHiddenAnnotations()
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ShowHiddenAnnotations Method


DrawingView.ShowHiddenCurves Method

DrawingView.ShowHiddenCurves Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that displays all the curves explicitly hidden by the user.

Visual Basic
Sub ShowHiddenCurves()
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ShowHiddenCurves Method


DrawingView.ShowName Method ([in] VARIANT_BOOL)

DrawingView.ShowName Method ([in] VARIANT_BOOL) Available in Inventor Available in Server
Summary

Property that indicates whether to show the label (name) of the drawing view on the sheet.

Visual Basic
Sub ShowName(Value As VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ShowName Method ([in] VARIANT_BOOL)


DrawingView.ShowName Method ([out, retval] VARIANT_BOOL*)

DrawingView.ShowName Method ([out, retval] VARIANT_BOOL*) Available in Inventor Available in Server
Summary

Property that indicates whether to show the label (name) of the drawing view on the sheet.

Visual Basic
Sub ShowName(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ShowName Method ([out, retval] VARIANT_BOOL*)


DrawingView.ShowScale Method ([in] VARIANT_BOOL)

DrawingView.ShowScale Method ([in] VARIANT_BOOL) Available in Inventor Available in Server
Summary

Property that indicates whether to show the scale of the drawing view on the sheet.

Visual Basic
Sub ShowScale(Value As VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ShowScale Method ([in] VARIANT_BOOL)


DrawingView.ShowScale Method ([out, retval] VARIANT_BOOL*)

DrawingView.ShowScale Method ([out, retval] VARIANT_BOOL*) Available in Inventor Available in Server
Summary

Property that indicates whether to show the scale of the drawing view on the sheet.

Visual Basic
Sub ShowScale(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Methods > DrawingView.ShowScale Method ([out, retval] VARIANT_BOOL*)


DrawingView Properties

DrawingView Properties
Summary

The properties of the DrawingView class are listed here.

Properties
Name | Description
ActiveDesignViewRepresentation | Property that returns the name of the active Design View Representation for a drawing view of a part or an assembly. This property returns a null string for drawing views of presentations and in the case where the model (part or assembly) is unresolved.
ActiveLevelOfDetailRepresentation | Property that returns the name of the active Level of Detail Representation for a drawing view of an assembly. This property returns a null string for drawing views of parts & presentations and in the case where the model (assembly) is unresolved.
ActiveMemberName | Property that gets and sets the name of the active member for a drawing view of an iPart or an iAssembly.
ActivePositionalRepresentation | Property that gets and sets the name of the active Positional Representation for a drawing view of an assembly. This property returns a null string and cannot be set for drawing views of parts & presentations and in the case where the model (assembly) is unresolved.
ActivePresentationView | Property that returns the name of the active Presentation (Exploded) View for a drawing view of a presentation.
Aligned | Property that gets and sets whether the view is aligned with another view. This property can only be set to False in order to break the alignment. To align the view, use the Align method.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
AuxiliaryOrientationEdge | Property that returns drawing curve that the auxiliary view is aligned to. This property returns Nothing if this is not an auxiliary view or if the orientation edge (drawing curve) has been removed from the parent view during a subsequent update.
BitmapAvailable | Property that returns if this view's graphics are also available as a bitmap as well. If a bitmap exists it can be retrieved using the DataIO object. This is only applicable within Apprentice.
BreakOperations | Property that returns the BreakOperations object containing information about all the break operations applied to this view as well as methods to add breaks. Both local as well as inherited break operations are returned in the collection.
BreakOutOperations | Property that returns the BreakOutOperations object containing information about all the break out operations applied to this view as well as methods to add break outs. Only local break out operations are returned.
Camera | Property that returns the Camera object describing the orientation of the view in greater detail.
Center | Gets and sets the display center point of the drawing view on the owning sheet.
ClientGraphicsCollection | Property that returns the ClientGraphicsCollection object.
DataIO | Property that returns the associated DataIO object. This can be used in Apprentice to obtain an associated bitmap, if it exists.
DisplayBendExtents | Property that gets and sets whether to display sheet metal bend extents on the drawing view.
DisplayDefinitionInBase | Property that gets and sets whether to display detail circles, section lines and the associated text in the base view. The property returns False and cannot be set where not applicable.
DisplayForeshortenedTangentEdges | Property that gets and sets whether to display shortened tangent edges in order to distinguish them from visible edges. Setting this property to True automatically toggles the DisplayTangentEdges property to True.
DisplayHatching | Property that gets and sets whether to display hatches for section and slice views.
DisplayInterferenceEdges | Property that gets and sets whether to display both hidden edges that are excluded due to an interference condition (press, or interference fit conditions, threaded fasteners in tapped holes where the hole feature is modeled with the minor diameter).
DisplayTangentEdges | Property that gets and sets whether to display the tangent edges on the drawing view. Setting this property to False automatically toggles the DisplayForeshortenedTangentEdges property to False.
DisplayThreadFeatures | Property that gets and sets whether to display thread features on the drawing view.
DisplayTrails | Property that gets and sets whether to display trails. The property returns False and setting it fails if the drawing view does not reference a presentation document.
DrawingViewEvents | Property that returns the object, which provides event notifcation. For example, view updates.
DrawingViewToModelTransform | Property that returns the transformation from drawing view coordinate space to the model space.
DrawingViewToSheetTransform | Property that returns the transformation from drawing view coordinate space to the sheet space.
GeneralDimensionType | Property that indicates the type of dimension.
GraphicsDataSetsCollection | Property that returns the object for the drawing view.
HasOriginIndicator | Property that specifies whether the origin indicator for ordinate dimensions and hole tables has been created.
Height | Property that specifies the height of the drawing view. The view height cannot be set but is defined by the contents of the view
InheritBreak | Property that gets and sets whether the view should inherit the corresponding break from the parent view. Setting this property is only possible for certain views. Orthographic projected views inherit breaks by default, which can be turned off.
InheritBreakOut | Property that gets and sets whether the view should inherit the corresponding break out from the parent view. Setting this property is only possible for certain views. Isometric projected views created for views with a break out inherit the break out by default. Orthographic projected and auxiliary views do not support inheritance of break out operations.
InheritSection | Property that gets and sets whether the view should inherit the corresponding section cut from the parent view. Setting this property is only possible for certain views. Isometric projected views created for section views inherit the section cut by default. Orthographic projected and auxiliary views support the inheritance of the section, but it is switched off by default.
InheritSlice | Property that gets and sets whether the view should inherit the corresponding slice cut from the parent view. Setting this property is only possible for certain views.
IsFlatPatternView | Gets whether the drawing view is of a sheet metal flat pattern.
IsUpdateComplete | Property that indicates if the view has finished updating.
Label | Property that returns the DrawingViewLabel object.
Left | Property that returns the position of the left edge of the drawing view.
ModelToDrawingViewTransform | Property that returns the transformation from model space to the drawing view coordinate space.
ModelToSheetTransform | Property that returns the transformation from model space to the sheet coordinate space.
Name | Property that gets and sets the name of the DrawingView. This is the editable portion of the name that is displayed within the browser. Inventor appends some additional information to the displayed name. When setting the name, the name must be unique with respect to all other DrawingView objects in the sheet, or an error will occur.
OriginIndicator | Property that gets the origin indicator for ordinate dimensions and hole tables.
Parent | Property returning the parent Sheet object.
ParentView | Property that returns the parent . This property returns Nothing in the case where no parent view exists.
Position | Gets and sets the point used to position the drawing view on the sheet.
PresentationViewAssociative | Property that gets and sets whether to associate the drawing view to the referenced presentation view. The property always returns False for drawing views of parts and assemblies and setting the property returns an error in this case. Use the ActivePresentationView property to get the referenced presentation view.
ReferencedDocumentDescriptor | Property that returns the model document referenced by this view.
Rotation | Property that gets and sets the absolute rotation angle of the drawing view in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation).
Scale | Property that gets and sets the model to paper space scale of the view. Setting this property will fail if the ScaleFromBase property returns True.
ScaleFromBase | Property that gets and sets whether the scale of the view derives from the parent view or not. This property fails for base drawing views.
ScaleString | Property that gets and sets the scale in string format. For instance, '2', '5:1' and '1 / 2' are valid values. The Scale property returns the value of this scale as a double value. Setting this property will fail if the ScaleFromBase property returns True.
SheetToDrawingViewTransform | Property that returns the transformation from sheet space to the drawing view coordinate space.
SheetToModelTransform | Property that returns the transformation from sheet coordinate space to the model space.
ShowLabel | Property that gets and sets whether to show the label of the drawing view on the sheet.
Sketches | Property that returns the DrawingSketches collection object for the sheet. This object provides access to all of the sketches that have been created on the sheet and provides functionality to create new sketches.
StandardPartsSectionBehavior | Property that gets and sets the sectioning behavior for standard parts in drawing views of assemblies.
Suppressed | Property that gets and sets whether the drawing view is suppressed (invisible).
Top | Property that specifies the position of the top edge of the drawing view.
Type | Property returning an enum indicating this object's type.
UpToDate | Property that returns whether the drawing view is up to date with respect to the model.
ViewJustification | Property that gets and sets the view justification. Valid values are kCenteredViewJustification and kFixedViewJustification.
ViewOrientationFromBase | Property that gets and sets whether the view should inherit the orientation from the base view.
ViewStyle | Property that gets and sets the drawing view style. Valid values are kHiddenLineDrawingViewStyle, kHiddenLineRemovedDrawingViewStyle, kShadedDrawingViewStyle, kShadedHiddenLineDrawingViewStyle and kFromBaseDrawingViewStyle.
ViewType | Property returning an DrawingViewTypeEnum constant indicating the type of view.
Width | Property that specifies the width of the drawing view. The view width cannot be set but is defined by the contents of the view.
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties


DrawingView.ActiveDesignViewRepresentation Property

DrawingView.ActiveDesignViewRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the name of the active Design View Representation for a drawing view of a part or an assembly. This property returns a null string for drawing views of presentations and in the case where the model (part or assembly) is unresolved.

Visual Basic
Property ActiveDesignViewRepresentation() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ActiveDesignViewRepresentation Property


DrawingView.ActiveLevelOfDetailRepresentation Property

DrawingView.ActiveLevelOfDetailRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the name of the active Level of Detail Representation for a drawing view of an assembly. This property returns a null string for drawing views of parts & presentations and in the case where the model (assembly) is unresolved.

Visual Basic
Property ActiveLevelOfDetailRepresentation() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ActiveLevelOfDetailRepresentation Property


DrawingView.ActiveMemberName Property

DrawingView.ActiveMemberName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the name of the active member for a drawing view of an iPart or an iAssembly.

Visual Basic
Property ActiveMemberName() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ActiveMemberName Property


DrawingView.ActivePositionalRepresentation Property

DrawingView.ActivePositionalRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the name of the active Positional Representation for a drawing view of an assembly. This property returns a null string and cannot be set for drawing views of parts & presentations and in the case where the model (assembly) is unresolved.

Visual Basic
Property ActivePositionalRepresentation() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ActivePositionalRepresentation Property


DrawingView.ActivePresentationView Property

DrawingView.ActivePresentationView Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the name of the active Presentation (Exploded) View for a drawing view of a presentation.

Visual Basic
Property ActivePresentationView() As BSTR*
Remarks

This property returns a null string for drawing views of parts & assemblies and in the case where the model (presentation) is unresolved. The property also returns a null string if the presentation view has been applied non-associatively. Use the PresentationViewAssociative property to toggle the association.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ActivePresentationView Property


DrawingView.Aligned Property

DrawingView.Aligned Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the view is aligned with another view. This property can only be set to False in order to break the alignment. To align the view, use the Align method.

Visual Basic
Property Aligned() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Aligned Property


DrawingView.AttributeSets Property

DrawingView.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.AttributeSets Property


DrawingView.AuxiliaryOrientationEdge Property

DrawingView.AuxiliaryOrientationEdge Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns drawing curve that the auxiliary view is aligned to. This property returns Nothing if this is not an auxiliary view or if the orientation edge (drawing curve) has been removed from the parent view during a subsequent update.

Visual Basic
Property AuxiliaryOrientationEdge() As DrawingCurve**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.AuxiliaryOrientationEdge Property


DrawingView.BitmapAvailable Property

DrawingView.BitmapAvailable Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns if this view's graphics are also available as a bitmap as well. If a bitmap exists it can be retrieved using the DataIO object. This is only applicable within Apprentice.

Visual Basic
Property BitmapAvailable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.BitmapAvailable Property


DrawingView.BreakOperations Property

DrawingView.BreakOperations Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the BreakOperations object containing information about all the break operations applied to this view as well as methods to add breaks. Both local as well as inherited break operations are returned in the collection.

Visual Basic
Property BreakOperations() As BreakOperations**
See Also

Creation of a break operation in a drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.BreakOperations Property


DrawingView.BreakOutOperations Property

DrawingView.BreakOutOperations Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the BreakOutOperations object containing information about all the break out operations applied to this view as well as methods to add break outs. Only local break out operations are returned.

Visual Basic
Property BreakOutOperations() As BreakOutOperations**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.BreakOutOperations Property


DrawingView.Camera Property

DrawingView.Camera Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Camera object describing the orientation of the view in greater detail.

Visual Basic
Property Camera() As Camera**
Remarks

The Camera can be modified to change the (custom) orientation of the view.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Camera Property


DrawingView.Center Property

DrawingView.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets and sets the display center point of the drawing view on the owning sheet.

Visual Basic
Property Center() As Point2d*
See Also

Creation of a break operation in a drawing view sample

Add detail drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Center Property


DrawingView.ClientGraphicsCollection Property

DrawingView.ClientGraphicsCollection Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ClientGraphicsCollection object.

Visual Basic
Property ClientGraphicsCollection() As ClientGraphicsCollection**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ClientGraphicsCollection Property


DrawingView.DataIO Property

DrawingView.DataIO Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the associated DataIO object. This can be used in Apprentice to obtain an associated bitmap, if it exists.

Visual Basic
Property DataIO() As DataIO**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DataIO Property


DrawingView.DisplayBendExtents Property

DrawingView.DisplayBendExtents Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display sheet metal bend extents on the drawing view.

Visual Basic
Property DisplayBendExtents() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayBendExtents Property


DrawingView.DisplayDefinitionInBase Property

DrawingView.DisplayDefinitionInBase Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display detail circles, section lines and the associated text in the base view. The property returns False and cannot be set where not applicable.

Visual Basic
Property DisplayDefinitionInBase() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayDefinitionInBase Property


DrawingView.DisplayForeshortenedTangentEdges Property

DrawingView.DisplayForeshortenedTangentEdges Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display shortened tangent edges in order to distinguish them from visible edges. Setting this property to True automatically toggles the DisplayTangentEdges property to True.

Visual Basic
Property DisplayForeshortenedTangentEdges() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayForeshortenedTangentEdges Property


DrawingView.DisplayHatching Property

DrawingView.DisplayHatching Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display hatches for section and slice views.

Visual Basic
Property DisplayHatching() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayHatching Property


DrawingView.DisplayInterferenceEdges Property

DrawingView.DisplayInterferenceEdges Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display both hidden edges that are excluded due to an interference condition (press, or interference fit conditions, threaded fasteners in tapped holes where the hole feature is modeled with the minor diameter).

Visual Basic
Property DisplayInterferenceEdges() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayInterferenceEdges Property


DrawingView.DisplayTangentEdges Property

DrawingView.DisplayTangentEdges Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether to display the tangent edges on the drawing view. Setting this property to False automatically toggles the DisplayForeshortenedTangentEdges property to False.

Visual Basic
Property DisplayTangentEdges() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayTangentEdges Property


DrawingView.DisplayThreadFeatures Property

DrawingView.DisplayThreadFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display thread features on the drawing view.

Visual Basic
Property DisplayThreadFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayThreadFeatures Property


DrawingView.DisplayTrails Property

DrawingView.DisplayTrails Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display trails. The property returns False and setting it fails if the drawing view does not reference a presentation document.

Visual Basic
Property DisplayTrails() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DisplayTrails Property


DrawingView.DrawingViewEvents Property

DrawingView.DrawingViewEvents Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the object, which provides event notifcation. For example, view updates.

Visual Basic
Property DrawingViewEvents() As DrawingViewEvents**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DrawingViewEvents Property


DrawingView.DrawingViewToModelTransform Property

DrawingView.DrawingViewToModelTransform Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the transformation from drawing view coordinate space to the model space.

Visual Basic
Property DrawingViewToModelTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DrawingViewToModelTransform Property


DrawingView.DrawingViewToSheetTransform Property

DrawingView.DrawingViewToSheetTransform Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the transformation from drawing view coordinate space to the sheet space.

Visual Basic
Property DrawingViewToSheetTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.DrawingViewToSheetTransform Property


DrawingView.GeneralDimensionType Property

DrawingView.GeneralDimensionType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the type of dimension.

Visual Basic
Property GeneralDimensionType() As GeneralDimensionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.GeneralDimensionType Property


DrawingView.GraphicsDataSetsCollection Property

DrawingView.GraphicsDataSetsCollection Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the object for the drawing view.

Visual Basic
Property GraphicsDataSetsCollection() As GraphicsDataSetsCollection**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.GraphicsDataSetsCollection Property


DrawingView.HasOriginIndicator Property

DrawingView.HasOriginIndicator Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies whether the origin indicator for ordinate dimensions and hole tables has been created.

Visual Basic
Property HasOriginIndicator() As VARIANT_BOOL*
Remarks

A value of True specifies that the origin indicator has been created. The OriginIndicator property will return an OriginIndicator object that provides access to this origin indicator. A value of False specifies that the origin indicator has not been created. The CreateOriginIndicator method can be used to create the origin indicator.

See Also

Create ordinate dimension sample

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.HasOriginIndicator Property


DrawingView.Height Property

DrawingView.Height Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the height of the drawing view. The view height cannot be set but is defined by the contents of the view

Visual Basic
Property Height() As double*
See Also

Add detail drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Height Property


DrawingView.InheritBreak Property

DrawingView.InheritBreak Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the view should inherit the corresponding break from the parent view. Setting this property is only possible for certain views. Orthographic projected views inherit breaks by default, which can be turned off.

Visual Basic
Property InheritBreak() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.InheritBreak Property


DrawingView.InheritBreakOut Property

DrawingView.InheritBreakOut Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the view should inherit the corresponding break out from the parent view. Setting this property is only possible for certain views. Isometric projected views created for views with a break out inherit the break out by default. Orthographic projected and auxiliary views do not support inheritance of break out operations.

Visual Basic
Property InheritBreakOut() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.InheritBreakOut Property


DrawingView.InheritSection Property

DrawingView.InheritSection Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the view should inherit the corresponding section cut from the parent view. Setting this property is only possible for certain views. Isometric projected views created for section views inherit the section cut by default. Orthographic projected and auxiliary views support the inheritance of the section, but it is switched off by default.

Visual Basic
Property InheritSection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.InheritSection Property


DrawingView.InheritSlice Property

DrawingView.InheritSlice Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the view should inherit the corresponding slice cut from the parent view. Setting this property is only possible for certain views.

Visual Basic
Property InheritSlice() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.InheritSlice Property


DrawingView.IsFlatPatternView Property

DrawingView.IsFlatPatternView Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets whether the drawing view is of a sheet metal flat pattern.

Visual Basic
Property IsFlatPatternView() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.IsFlatPatternView Property


DrawingView.IsUpdateComplete Property

DrawingView.IsUpdateComplete Property Available in Inventor Introduced in Inventor 2012
Summary

Property that indicates if the view has finished updating.

Visual Basic
Property IsUpdateComplete() As VARIANT_BOOL*
Remarks

This will return False where the view is still processing the precise geometry in the background and can be used to determine when the precise processing is complete. This will always return True for draft views since there isn’t any processing required by Inventor for a draft view.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.IsUpdateComplete Property


DrawingView.Label Property

DrawingView.Label Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the DrawingViewLabel object.

Visual Basic
Property Label() As DrawingViewLabel**
Remarks

This object can be used to format the contents of the drawing view label.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Label Property


DrawingView.Left Property

DrawingView.Left Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the position of the left edge of the drawing view.

Visual Basic
Property Left() As double*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Left Property


DrawingView.ModelToDrawingViewTransform Property

DrawingView.ModelToDrawingViewTransform Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the transformation from model space to the drawing view coordinate space.

Visual Basic
Property ModelToDrawingViewTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ModelToDrawingViewTransform Property


DrawingView.ModelToSheetTransform Property

DrawingView.ModelToSheetTransform Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the transformation from model space to the sheet coordinate space.

Visual Basic
Property ModelToSheetTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ModelToSheetTransform Property


DrawingView.Name Property

DrawingView.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the name of the DrawingView. This is the editable portion of the name that is displayed within the browser. Inventor appends some additional information to the displayed name. When setting the name, the name must be unique with respect to all other DrawingView objects in the sheet, or an error will occur.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Name Property


DrawingView.OriginIndicator Property

DrawingView.OriginIndicator Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the origin indicator for ordinate dimensions and hole tables.

Visual Basic
Property OriginIndicator() As OriginIndicator**
Remarks

If the origin indicator has not been created for the view as indicated by the HasOriginIndicator property returning a value of False, this property will return Nothing. The CreateOriginIndicator method can be used to create the origin indicator.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.OriginIndicator Property


DrawingView.Parent Property

DrawingView.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent Sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Parent Property


DrawingView.ParentView Property

DrawingView.ParentView Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent . This property returns Nothing in the case where no parent view exists.

Visual Basic
Property ParentView() As DrawingView**
Remarks

It is valid for this property to return Nothing for the following view types: Base View, DraftView, AssociativeDraftView, and Isometric Projected View.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ParentView Property


DrawingView.Position Property

DrawingView.Position Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets and sets the point used to position the drawing view on the sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Position Property


DrawingView.PresentationViewAssociative Property

DrawingView.PresentationViewAssociative Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to associate the drawing view to the referenced presentation view. The property always returns False for drawing views of parts and assemblies and setting the property returns an error in this case. Use the ActivePresentationView property to get the referenced presentation view.

Visual Basic
Property PresentationViewAssociative() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.PresentationViewAssociative Property


DrawingView.ReferencedDocumentDescriptor Property

DrawingView.ReferencedDocumentDescriptor Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the model document referenced by this view.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
See Also

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ReferencedDocumentDescriptor Property


DrawingView.Rotation Property

DrawingView.Rotation Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the absolute rotation angle of the drawing view in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation).

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Rotation Property


DrawingView.Scale Property

DrawingView.Scale Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the model to paper space scale of the view. Setting this property will fail if the ScaleFromBase property returns True.

Visual Basic
Property Scale() As double
Remarks

When calling this property from VB/A, enclose it in square brackets (for example, DrawingView.[Scale] ). Otherwise, VB/A can confuse it with its own Scale reserved word.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Scale Property


DrawingView.ScaleFromBase Property

DrawingView.ScaleFromBase Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the scale of the view derives from the parent view or not. This property fails for base drawing views.

Visual Basic
Property ScaleFromBase() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ScaleFromBase Property


DrawingView.ScaleString Property

DrawingView.ScaleString Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the scale in string format. For instance, '2', '5:1' and '1 / 2' are valid values. The Scale property returns the value of this scale as a double value. Setting this property will fail if the ScaleFromBase property returns True.

Visual Basic
Property ScaleString() As String
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ScaleString Property


DrawingView.SheetToDrawingViewTransform Property

DrawingView.SheetToDrawingViewTransform Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the transformation from sheet space to the drawing view coordinate space.

Visual Basic
Property SheetToDrawingViewTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.SheetToDrawingViewTransform Property


DrawingView.SheetToModelTransform Property

DrawingView.SheetToModelTransform Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the transformation from sheet coordinate space to the model space.

Visual Basic
Property SheetToModelTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.SheetToModelTransform Property


DrawingView.ShowLabel Property

DrawingView.ShowLabel Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to show the label of the drawing view on the sheet.

Visual Basic
Property ShowLabel() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ShowLabel Property


DrawingView.Sketches Property

DrawingView.Sketches Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the DrawingSketches collection object for the sheet. This object provides access to all of the sketches that have been created on the sheet and provides functionality to create new sketches.

Visual Basic
Property Sketches() As DrawingSketches**
See Also

Moving sketch entities to a new layer sample

Draft Views - create sample

Drawing Sketches - editing line type and color sample

Example

"Sketch within a drawing view Example"

This sample demonstrates creating a sketch within an existing drawing view.

To run this sample have a drawing open where the active sheet contains at least one drawing view.

Private Sub CreateDrawingSketchInView()
    ' Set a reference to the active document.  This assumes it
    ' is a drawing document.
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the first drawing view on the active sheet.  This
    ' assumes the active sheet contains at least one drawing view.
    Dim oDrawView As DrawingView
    Set oDrawView = oDoc.ActiveSheet.DrawingViews.Item(1)

    ' Create the new drawing sketch.
    Dim oSketch As DrawingSketch
    Set oSketch = oDrawView.Sketches.Add

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Open the sketch for edit.
    oSketch.Edit

    ' Draw two lines in the sketch.
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 0), oTG.CreatePoint2d(3, 3))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 3), oTG.CreatePoint2d(3, 0))

    ' Exit from editing the sketch.
    oSketch.ExitEdit
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Sketches Property


DrawingView.StandardPartsSectionBehavior Property

DrawingView.StandardPartsSectionBehavior Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the sectioning behavior for standard parts in drawing views of assemblies.

Visual Basic
Property StandardPartsSectionBehavior() As StandardPartsSectionBehaviorEnum
Remarks

The valid options are kAlwaysSectionStandardParts, kNeverSectionStandardParts and kObeyBrowserSettingsSectionStandardParts.

Setting this property to kAlwaysSectionStandardParts specifies that standard parts should always be sectioned irrespective of the settings in the browser pane of the drawing.

Setting this property to kNeverSectionStandardParts specifies that standard parts should never be sectioned irrespective of the settings in the browser pane of the drawing.

Setting this property to kObeyBrowserSettingsSectionStandardParts specifies that the browser pane settings should be obeyed when sectioning standard parts. The default browser setting specifies that standard parts should not be sectioned.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.StandardPartsSectionBehavior Property


DrawingView.Suppressed Property

DrawingView.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the drawing view is suppressed (invisible).

Visual Basic
Property Suppressed() As VARIANT_BOOL
Remarks

Suppressing a view hides all model-generated geometry (visible and hidden edges, thread edges and tweak trails) and annotations attached to the view (view sketch, dimensions, symbols and centerlines). Setting this property fails for overlay views since the visibility of an overlay view is controlled by its parent view.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Suppressed Property


DrawingView.Top Property

DrawingView.Top Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the position of the top edge of the drawing view.

Visual Basic
Property Top() As double*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Top Property


DrawingView.Type Property

DrawingView.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Type Property


DrawingView.UpToDate Property

DrawingView.UpToDate Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the drawing view is up to date with respect to the model.

Visual Basic
Property UpToDate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.UpToDate Property


DrawingView.ViewJustification Property

DrawingView.ViewJustification Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the view justification. Valid values are kCenteredViewJustification and kFixedViewJustification.

Visual Basic
Property ViewJustification() As ViewJustificationEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ViewJustification Property


DrawingView.ViewOrientationFromBase Property

DrawingView.ViewOrientationFromBase Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the view should inherit the orientation from the base view.

Visual Basic
Property ViewOrientationFromBase() As VARIANT_BOOL
Remarks

This property returns False and cannot be set for base views.

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ViewOrientationFromBase Property


DrawingView.ViewStyle Property

DrawingView.ViewStyle Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the drawing view style. Valid values are kHiddenLineDrawingViewStyle, kHiddenLineRemovedDrawingViewStyle, kShadedDrawingViewStyle, kShadedHiddenLineDrawingViewStyle and kFromBaseDrawingViewStyle.

Visual Basic
Property ViewStyle() As DrawingViewStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ViewStyle Property


DrawingView.ViewType Property

DrawingView.ViewType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an DrawingViewTypeEnum constant indicating the type of view.

Visual Basic
Property ViewType() As DrawingViewTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.ViewType Property


DrawingView.Width Property

DrawingView.Width Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the width of the drawing view. The view width cannot be set but is defined by the contents of the view.

Visual Basic
Property Width() As double*
See Also

Add detail drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > DrawingView Interface > DrawingView Properties > DrawingView.Width Property


DrawingViewEvents CoClass

DrawingViewEvents CoClass Available in Inventor Available in Server Introduced in Inventor 9
Summary

Call-back or 'outgoing' sink interface through which Inventor fires the DrawingView Events. See the article in the overviews section.

Class Hierarchy
Inventor::DrawingViewEvents
Visual Basic
Public Class DrawingViewEvents
Notes

Members through which this object may be accessed include:

DrawingView.DrawingViewEvents

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEvents CoClass


DrawingViewEventsObject Interface

DrawingViewEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

Call-back or 'outgoing' sink interface through which Inventor fires the DrawingView Events. See the article in the overviews section.

Class Hierarchy
Inventor::DrawingViewEventsObject
Visual Basic
Public Interface DrawingViewEventsObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsObject Interface


DrawingViewEventsObject Properties

DrawingViewEventsObject Properties
Summary

The properties of the DrawingViewEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent DrawingView object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsObject Interface > DrawingViewEventsObject Properties


DrawingViewEventsObject.Application Property

DrawingViewEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsObject Interface > DrawingViewEventsObject Properties > DrawingViewEventsObject.Application Property


DrawingViewEventsObject.Parent Property

DrawingViewEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent DrawingView object.

Visual Basic
Property Parent() As DrawingView**
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsObject Interface > DrawingViewEventsObject Properties > DrawingViewEventsObject.Parent Property


DrawingViewEventsObject.Type Property

DrawingViewEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsObject Interface > DrawingViewEventsObject Properties > DrawingViewEventsObject.Type Property


DrawingViewEventsSink Interface

DrawingViewEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

Call-back or 'outgoing' sink interface through which Inventor fires the DrawingView Events. See the article in the overviews section.

Class Hierarchy
Inventor::DrawingViewEventsSink
Visual Basic
Public Interface DrawingViewEventsSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsSink Interface


DrawingViewEventsSink Methods

DrawingViewEventsSink Methods
Summary

The methods of the DrawingViewEventsSink class are listed here.

Methods
Methods
Name | Description
OnViewUpdate | The OnViewUpdate event notifies a client when the document associated with the drawing view has been modified and causes the drawing view to update.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsSink Interface > DrawingViewEventsSink Methods


DrawingViewEventsSink.OnViewUpdate Method

DrawingViewEventsSink.OnViewUpdate Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

The OnViewUpdate event notifies a client when the document associated with the drawing view has been modified and causes the drawing view to update.

Visual Basic
Sub OnViewUpdate(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ReasonsForChange As CommandTypesEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Indicates if the notification is being sent before or after the drawing view has been updated.
Context | Additional information is provided through this argument to help in understanding the context of the update, as indicated by the value of ReasonsForChange, which is a value from the CommandTypesEnum list, which represents the different categories of changes that can be made.
ReasonsForChange | A value from the CommandTypesEnum list, which represents the different categories of changes that can be made. Typically this will be a single value from the list but it can represent multiple values that have been combined together so you need to use bitwise operations to check for a specific change.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

This event in useful in the case where you have created additional sketch geometry or labels referencing that view that may need to be updated to reflect changes in the attached model. Note. Modifying actions should only be performed in the kAfter state. The use of kBefore should be avoided except for query operations.

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewEventsSink Interface > DrawingViewEventsSink Methods > DrawingViewEventsSink.OnViewUpdate Method


DrawingViewLabel Interface

DrawingViewLabel Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The DrawingViewLabel object represents the text in a drawing view label.

Class Hierarchy
Inventor::DrawingViewLabel
Visual Basic
Public Interface DrawingViewLabel
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingView.Label

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface


DrawingViewLabel Properties

DrawingViewLabel Properties
Summary

The properties of the DrawingViewLabel class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Color | Property that gets and set the color of the text.
ConstrainToBorder | Property that gets and sets whether to constrain the view label to the view. If set to True, the view label maintains its relative position to the view boundary as the boundary changes in size or position due to a modeling change, changing a view's assembly representation, or changing the view scale.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
HorizontalJustification | Property that gets and sets the horizontal justification override of the drawing view label.
Layer | Property that gets and sets the layer associated with the view label.
LineSpacing | Property that gets and sets the line spacing of the drawing view label.
LineSpacingType | Property that gets and sets the method used to define the line spacing. The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.
Parent | Property that returns the parent of the object.
Position | Property that gets and sets the position of the label.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
StackedTextPosition | Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.
Text | Property that gets the string that defines the drawing view label.
TextStyle | Property that gets and sets the text style associated with the view label.
Type | Property returning kDimensionTextObject indicating the objects type.
VerticalJustification | Property that gets and sets the vertical justification override of the drawing view label.
WidthScale | Property that gets and sets the width scale factor for the drawing view label. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties


DrawingViewLabel.Application Property

DrawingViewLabel.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Application Property


DrawingViewLabel.Color Property

DrawingViewLabel.Color Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the color of the text.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Color Property


DrawingViewLabel.ConstrainToBorder Property

DrawingViewLabel.ConstrainToBorder Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to constrain the view label to the view. If set to True, the view label maintains its relative position to the view boundary as the boundary changes in size or position due to a modeling change, changing a view's assembly representation, or changing the view scale.

Visual Basic
Property ConstrainToBorder() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.ConstrainToBorder Property


DrawingViewLabel.FormattedText Property

DrawingViewLabel.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.FormattedText Property


DrawingViewLabel.HorizontalJustification Property

DrawingViewLabel.HorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the horizontal justification override of the drawing view label.

Visual Basic
Property HorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.HorizontalJustification Property


DrawingViewLabel.Layer Property

DrawingViewLabel.Layer Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the layer associated with the view label.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Layer Property


DrawingViewLabel.LineSpacing Property

DrawingViewLabel.LineSpacing Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line spacing of the drawing view label.

Visual Basic
Property LineSpacing() As double
Remarks

The value of this property is treated in one of two ways depending on the value of the LineSpacingType property. When the value of the LineSpacingType property is set to kExactLineSpacing, the value of the LineSpacing property defines the exact distance (in centimeters) from the bottom of one line to bottom of the next line.

When the value of the LineSpacingType property is set to kMultipleLineSpacing, the value defines a spacing factor relative to standard single line spacing. For example, a value of 1.0 will result in standard single line spacing, and a value of 1.5 will result in one and a half line spacing.

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.LineSpacing Property


DrawingViewLabel.LineSpacingType Property

DrawingViewLabel.LineSpacingType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the method used to define the line spacing. The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.

Visual Basic
Property LineSpacingType() As TextLineSpacingTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.LineSpacingType Property


DrawingViewLabel.Parent Property

DrawingViewLabel.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As DrawingView**
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Parent Property


DrawingViewLabel.Position Property

DrawingViewLabel.Position Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the label.

Visual Basic
Property Position() As Point2d*
Remarks

The position is controlled by the horizontal and vertical justification of the text. If the text's horizontal justification is kAlignTextLeft and the vertical justification is kAlignTextUpper then the position will be the upper-left corner of the text. Setting the justifications to kAlignTextCenter and kAlignTextMiddle will result in the text moving to position at the center of the text. As the text changes, the position remains fixed.

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Position Property


DrawingViewLabel.RangeBox Property

DrawingViewLabel.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.RangeBox Property


DrawingViewLabel.StackedTextPosition Property

DrawingViewLabel.StackedTextPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.

Visual Basic
Property StackedTextPosition() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.StackedTextPosition Property


DrawingViewLabel.Text Property

DrawingViewLabel.Text Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the string that defines the drawing view label.

Visual Basic
Property Text() As BSTR*
Remarks

When getting this property, the returned string has all formatting removed and contains the actual text characters displayed in the text.

You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Text Property


DrawingViewLabel.TextStyle Property

DrawingViewLabel.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style associated with the view label.

Visual Basic
Property TextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.TextStyle Property


DrawingViewLabel.Type Property

DrawingViewLabel.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kDimensionTextObject indicating the objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.Type Property


DrawingViewLabel.VerticalJustification Property

DrawingViewLabel.VerticalJustification Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the vertical justification override of the drawing view label.

Visual Basic
Property VerticalJustification() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.VerticalJustification Property


DrawingViewLabel.WidthScale Property

DrawingViewLabel.WidthScale Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the width scale factor for the drawing view label. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.

Visual Basic
Property WidthScale() As double
You are here: Symbol Reference > Inventor Library > Objects > DrawingViewLabel Interface > DrawingViewLabel Properties > DrawingViewLabel.WidthScale Property


DrawingViews Interface

DrawingViews Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The DrawingViews collection object provides access to the objects associated with the sheet the collection was obtained from. It also provides method to create new drawing views.

Class Hierarchy
Inventor::DrawingViews
Visual Basic
Public Interface DrawingViews
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.DrawingViews

Example 1

See DrawingViews::AddDraftView for example "Adding a draft view"

Example 2

See DrawingViews::AddBaseView for example "Adding a base view"

Example 3

See DrawingViews::AddDetailView for example "Adding a detail view"

You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface


DrawingViews Methods

DrawingViews Methods
Summary

The methods of the DrawingViews class are listed here.

Methods
Methods
Name | Description
AddAssociativeDraftView | Method that creates a new associative draft . An empty draft view is created and associated with the input document. The newly created DrawingView is returned.
AddAuxiliaryView | Method that creates an auxiliary drawing view.
AddBaseView | Method that creates a new base . The newly created DrawingView is returned.
AddDetailView | Method that creates a detail drawing view. This method fails if the parent sheet is not active.
AddDraftView | Method that creates a new draft . The newly created DrawingView is returned.
AddOverlayView | Method that creates an overlay drawing view.
AddProjectedView | Method that creates a projected .
AddSectionView | Method that creates a section drawing view.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods


DrawingViews.AddAssociativeDraftView Method

DrawingViews.AddAssociativeDraftView Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new associative draft . An empty draft view is created and associated with the input document. The newly created DrawingView is returned.

Visual Basic
Sub AddAssociativeDraftView(Model As Document, Position As Point2d, ByRef Scale As [defaultvalue(1.0)] double, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
Model | Input Document that specifies the document to associate with this view. Valid document types include part file, assembly files, and presentation files.
Scale | Optional input Double that specifies the drawing view scale factor. If not specified, a default value of 1.0 is used.
Name | Optional input String that defines the editable portion of the name that is displayed within the browser.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddAssociativeDraftView Method


DrawingViews.AddAuxiliaryView Method

DrawingViews.AddAuxiliaryView Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates an auxiliary drawing view.

Visual Basic
Sub AddAuxiliaryView(ParentView As DrawingView, OrientationEdge As DrawingCurve, Position As Point2d, ViewStyle As DrawingViewStyleEnum, ByRef Scale As [optional] VARIANT, ByRef ShowLabel As [defaultvalue(-1)] VARIANT_BOOL, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
ParentView | Input DrawingView object that specifies the parent view of the auxiliary view.
OrientationEdge | Input DrawingCurve object that specifies the orientation of the auxiliary view. This must be a linear DrawingCurve from the parent view, else the method returns an error.
Position | Input Point2d that specifies the placement point of the view on the sheet.
ViewStyle | Input DrawingViewStyleEnum the specifies the display style of the geometry within the view. Valid values are kHiddenLineDrawingViewStyle, kHiddenLineRemovedDrawingViewStyle, kShadedDrawingViewStyle, kShadedHiddenLineDrawingViewStyle and kFromBaseDrawingViewStyle.
Scale | Optional input that specifies the drawing view scale factor. This can be either specified as a Double or a String. Examples: 2.0, '5:1', '1 / 2', etc. If this argument is not specified, the scale is derived from the ParentView.
ShowLabel | Optional input Boolean that specifies whether to display or hide the view label. The default is True indicating that the label will be displayed.
Name | Optional input String that defines the editable portion of the drawing view name that is displayed within the browser.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddAuxiliaryView Method


DrawingViews.AddBaseView Method

DrawingViews.AddBaseView Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new base . The newly created DrawingView is returned.

Visual Basic
Sub AddBaseView(Model As Document, Position As Point2d, Scale As double, ViewOrientation As ViewOrientationTypeEnum, ViewStyle As DrawingViewStyleEnum, ByRef ModelViewName As [defaultvalue("")] BSTR, ByRef ArbitraryCamera As [optional] VARIANT, ByRef AdditionalOptions As [optional] VARIANT, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
Model | Input Document that specifies the document to create the view of. Valid document types include part file, assembly files, and presentation files. This method uses a Document object as input rather than a filename to allow the insertion of a document into a drawing and avoid the requirement of that document first being saved to a file. If a document already exists as a file on disk you can use the Documents.Open method to open the file and obtain a Documents object. Typically, you'll want to set the OpenVisible argument of the Open method to False so the open is invisible to the user.
Position | Input Point2d that specifies the placement point of the view on the sheet.
Scale | Input Double that specifies the drawing view scale factor.
ViewOrientation | Input ViewOrientationTypeEnum that specifies the orientation of the model within the view. If this value is kArbitraryViewOrientation the orientation is derived from the Camera specified by the ArbitraryCamera argument.
ViewStyle | Input DrawingViewStyleEnum the specifies the display style of the geometry within the view. Valid values are kHiddenLineDrawingViewStyle, kHiddenLineRemovedDrawingViewStyle, kShadedDrawingViewStyle, and kShadedHiddenLineDrawingViewStyle. If kFromBaseDrawingViewStyle is specified, an error is returned.
ModelViewName | Optional input String that defines the design view name for assembly files, or the presentation view name for presentation files. This argument is ignored if the document type specified by the Model argument is a part file (.ipt).
ArbitraryCamera | Optional input Camera object that specifies the model orientation within the view. This argument is ignored if the ViewOrientation argument is not kArbitraryViewOrientation.
AdditionalOptions | Optional input NameValueMap object that specifies additional or advanced options. See Remarks. You should make sure that this input does not conflict with the ModelViewName argument that can also be used to specify a design view name. The string 'Last Active' can also be specified.
Remarks

AdditionalOptions currently supported include:

Name | Value Type | Valid Document Type
WeldmentFeatureGroup | WeldmentFeatureGroupEnum | Weldment
SheetMetalFoldedModel | Boolean | Sheet Metal
DesignViewRepresentation | String | Part, Assembly
DesignViewAssociative | Boolean | Part, Assembly
PositionalRepresentation | String | Assembly
MemberName | String | Part, Assembly
PresentationView | String | Presentation
PresentationViewAssociative | Boolean | Presentation
Example 1

Adding Representation views

This sample demonstrates how to create a base view by specifying various representations. Before running this sample, make sure that the file C:\TempReps.iam exists (or change the path in the sample). The file must contain a level of detail representation named MyLODRep, a positional representation named MyPositionalRep and a design view representation named MyDesignViewRep.

Public Sub AddBaseViewWithRepresentations()

  ' Set a reference to the drawing document.
  ' This assumes a drawing document is active.
  Dim oDrawDoc As DrawingDocument
  Set oDrawDoc = ThisApplication.ActiveDocument

  'Set a reference to the active sheet.
  Dim oSheet As Sheet
  Set oSheet = oDrawDoc.ActiveSheet

  ' Create a new NameValueMap object
  Dim oBaseViewOptions As NameValueMap
  Set oBaseViewOptions = ThisApplication.TransientObjects.CreateNameValueMap

  ' Set the representations to use when creating the base view.
  Call oBaseViewOptions.Add("PositionalRepresentation", "MyPositionalRep")
  Call oBaseViewOptions.Add("DesignViewRepresentation", "MyDesignViewRep")
  Call oBaseViewOptions.Add("DesignViewAssociative", True)

  ' Open the model document (corresponding to the "MyLODRep" representation).
  Dim strFullDocumentName As String
  strFullDocumentName = ThisApplication.FileManager.GetFullDocumentName("C:\tempreps.iam", "MyLODRep")

  Dim oModel As Document
  Set oModel = ThisApplication.Documents.Open(strFullDocumentName, False)

  ' Create the placement point object.
  Dim oPoint As Point2d
  Set oPoint = ThisApplication.TransientGeometry.CreatePoint2d(25, 25)

  ' Create a base view.
  Dim oBaseView As DrawingView
  Set oBaseView = oSheet.DrawingViews.AddBaseView(oModel, oPoint, 2, _
  kIsoTopLeftViewOrientation, kHiddenLineRemovedDrawingViewStyle, _
      , , oBaseViewOptions)
End Sub
Example 2

Create flat pattern drawing view example.

This sample demonstrates the creation of a flat pattern base view in a drawing. Open a drawing document and run the sample.

Public Sub AddFlatPatternDrawingView()

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Create a new NameValueMap object
    Dim oBaseViewOptions As NameValueMap
    Set oBaseViewOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Set the options to use when creating the base view.
    Call oBaseViewOptions.Add("SheetMetalFoldedModel", False)

    ' Open the sheet metal document invisibly
    Dim oModel As Document
    Set oModel = ThisApplication.Documents.Open("C:\temp\SheetMetal.ipt", False)

    ' Create the placement point object.
    Dim oPoint As Point2d
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint2d(25, 25)

    ' Create a base view.
    Dim oBaseView As DrawingView
    Set oBaseView = oSheet.DrawingViews.AddBaseView(oModel, oPoint, 1, _
    kDefaultViewOrientation, kHiddenLineRemovedDrawingViewStyle, _
    , , oBaseViewOptions)

End Sub
Example 3

Create base view with representations example (C#).

This sample demonstrates how to create a base view by specifying various representations. Before running this sample, make sure that the file C:\\temp\\Reps.iam exists (or change the path in the sample). The file must contain a level of detail representation named MyLODRep, a positional representation named MyPositionalRep and a design view representation named MyDesignViewRep.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void AddBaseViewWithRepresentations()
{
    Application oApp = ThisApplication;

    // Set a reference to the drawing document.
    // This assumes a drawing document is active.
    DrawingDocument oDrawDoc = (DrawingDocument)oApp.ActiveDocument;

    //Set a reference to the active sheet.
    Sheet oSheet = oDrawDoc.ActiveSheet;

    // Create a new NameValueMap object
    NameValueMap oBaseViewOptions = oApp.TransientObjects.CreateNameValueMap();

    // Set the representations to use when creating the base view.
    oBaseViewOptions.Add("PositionalRepresentation", "MyPositionalRep");
    oBaseViewOptions.Add("DesignViewRepresentation", "MyDesignViewRep");
    oBaseViewOptions.Add("DesignViewAssociative", true);

    // Open the model document (corresponding to the "MyLODRep" representation).
    String strFullDocumentName = oApp.FileManager.GetFullDocumentName("C:\\temp\\Reps.iam", "MyLODRep");
    Document oModel = oApp.Documents.Open(strFullDocumentName, false);

    // Create the placement point object.
    Point2d oPoint = oApp.TransientGeometry.CreatePoint2d(25, 25);

    // Create a base view.
    DrawingView oBaseView = oSheet.DrawingViews.AddBaseView((_Document)oModel, oPoint, 2,
                                        ViewOrientationTypeEnum.kIsoTopLeftViewOrientation,
                                        DrawingViewStyleEnum.kHiddenLineRemovedDrawingViewStyle,
                                        "", null, oBaseViewOptions);

    // Release reference of the invisibly open model
    oModel.ReleaseReference();

}
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddBaseView Method


DrawingViews.AddDetailView Method

DrawingViews.AddDetailView Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a detail drawing view. This method fails if the parent sheet is not active.

Visual Basic
Sub AddDetailView(ParentView As DrawingView, Position As Point2d, ViewStyle As DrawingViewStyleEnum, CircularFence As VARIANT_BOOL, FenceCenterOrCornerOne As Point2d, FenceRadiusOrCornerTwo As VARIANT, ByRef AttachPoint As [optional] VARIANT, ByRef Scale As [optional] VARIANT, ByRef ShowLabel As [defaultvalue(-1)] VARIANT_BOOL, ByRef Name As [defaultvalue("")] BSTR, ByRef Reserved As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] DetailDrawingView*)
Parameters
Parameters | Description
ParentView | DrawingView object that specifies the base parent view of the projected view.
ViewStyle | DrawingViewStyleEnum the specifies the display style of the geometry within the view.
CircularFence | Boolean that specifies whether to use a circular fence or a rectangular fence. Specify True for circular and False for rectangular.
FenceCenterOrCornerOne | Point2d object that specifies the center point for a circular fence or the first corner for a rectangular fence.
FenceRadiusOrCornerTwo | Specifies the radius of a circular fence or input Point2d object that specifies the second corner for a rectangular fence.
AttachPoint | Optional input GeometryIntent object that specifies the geometry to attach the detail view to. If not specified, the detail view is unattached and can be moved around.
Scale | Optional input Double that specifies the drawing view scale factor. If this argument is not specified, the scale is derived from the ParentView.
ShowLabel | Optional input Boolean that specifies whether to display or hide the view label. The default is True indicating that the label will be displayed.
Name | Optional input String that defines the editable portion of the drawing view name that is displayed within the browser.
reserved | Optional input Boolean reserved for future use.
Example

"Add detail drawing view"

This sample demonstrates the creation of a detail drawing view with an attach point. Before running this sample, select a drawing view in the active drawing.

Public Sub CreateDetailView()

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Check to make sure a drawing view is selected.
    If Not Typeof oDrawDoc.SelectSet.Item(1) Is DrawingView Then
        MsgBox "A drawing view must be selected."
        Exit Sub
    End If

    ' Set a reference to the selected drawing. This assumes
    ' that the selected view is not a draft view.
    Dim oDrawingView As DrawingView
    Set oDrawingView = oDrawDoc.SelectSet.Item(1)

    ' Set a reference to the center of the base view.
    Dim oPoint As Point2d
    Set oPoint = oDrawingView.Center

    ' Translate point by a distance = 2 * width of the view
    ' This will be the placement point of the detail view.
    oPoint.X = oPoint.X + 2 * oDrawingView.Width

    ' Set corner one of rectangular fence as
    ' the left-bottom corner of the base view.
    Dim oCornerOne As Point2d
    Set oCornerOne = oDrawingView.Center

    oCornerOne.X = oCornerOne.X - oDrawingView.Width / 2
    oCornerOne.Y = oCornerOne.Y - oDrawingView.height / 2

    ' Set corner two of rectangular fence as
    ' the center of the base view.
    Dim oCornerTwo As Point2d
    Set oCornerTwo = oDrawingView.Center

    ' Get any linear curve from the base view
    Dim oCurve As DrawingViewCurve
    For Each oCurve In oDrawingView.DrawingViewCurves
        If oCurve.CurveType = kLineCurve Then
            Exit For
        End If
    Next

    ' Create an intent object
    Dim oAttachPoint As GeometryIntent
    Set oAttachPoint = oSheet.CreateGeometryIntent(oCurve, kStartPointIntent)

    ' Create the detail view
    Dim oDetailView As DetailDrawingView
    Set oDetailView = oSheet.DrawingViews.AddDetailView(oDrawingView, oPoint, _
    kFromBaseDrawingViewStyle, False, oCornerOne, oCornerTwo, oAttachPoint, 2)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddDetailView Method


DrawingViews.AddDraftView Method

DrawingViews.AddDraftView Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new draft . The newly created DrawingView is returned.

Visual Basic
Sub AddDraftView(ByRef Scale As [defaultvalue(1.0)] double, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
Scale | Optional input Double that specifies the drawing view scale factor. If not specified, a default value of 1.0 is used.
Name | Optional input String that defines the editable portion of the drawing view name that is displayed within the browser.
See Also

Moving sketch entities to a new layer sample

Drawing Sketches - editing line type and color sample

Example

"Draft Views - create Example "

This sample demonstrates the creation of a draft view in a drawing.

Open a drawing document and run the following sample.

Public Sub CreateDraftView()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    'A draft view can only be created on an active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    'Set a reference to the drawing view.
    Dim oDraftView As DrawingView
    Set oDraftView = oSheet.DrawingViews.AddDraftView(1#, "My Draft View")

    ' Set a reference to the sketch of the created draft view.
    Dim oSketch As DrawingSketch
    Set oSketch = oDraftView.Sketches.Item(1)

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Draw two lines in the sketch.
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(10, 10), oTG.CreatePoint2d(30, 30))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(10, 30), oTG.CreatePoint2d(30, 10))

    ' Exit from editing the sketch.
    oSketch.ExitEdit

End Sub
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddDraftView Method


DrawingViews.AddOverlayView Method

DrawingViews.AddOverlayView Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates an overlay drawing view.

Visual Basic
Sub AddOverlayView(ParentView As DrawingView, PositionalRepresentation As String, DesignViewRepresentation As String, DesignViewAssociative As VARIANT_BOOL, ViewStyle As DrawingViewStyleEnum, ByRef ShowLabel As [defaultvalue(-1)] VARIANT_BOOL, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
ParentView | Input DrawingView object that specifies the parent view of the overlay view. The parent view must be a base view, projected view or an auxiliary view of an assembly, else the method returns an error.
PositionalRepresentation | Input String that specifies the positional representation to use for the overlay view. The input string must the name of an existing position representation in the assembly referenced by the parent view. The method returns a failure if a representation with this name is not found in the referenced assembly.
DesignViewRepresentation | Input String that specifies the design view representation to use for the overlay view. The input string must the name of an existing design view representation in the assembly referenced by the parent view. In addition, 'Nothing Visible' and 'All Visible' can also be provided. The method returns a failure if a representation with this name is not found in the referenced assembly.
DesignViewAssociative | Input Boolean that indicates whether to associatively apply the design view representation. If set to True, any changes to the design view in the referenced assembly will show in this view.
ViewStyle | Input DrawingViewStyleEnum the specifies the display style of the geometry within the view. Valid values are kHiddenLineDrawingViewStyle, kHiddenLineRemovedDrawingViewStyle, kShadedDrawingViewStyle, kShadedHiddenLineDrawingViewStyle and kFromBaseDrawingViewStyle.
ShowLabel | Optional input Boolean that specifies whether to display or hide the view label. The default is True indicating that the label will be displayed.
Name | Optional input String that defines the editable portion of the drawing view name that is displayed within the browser. If not specified, the name of the input positional representation is used.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddOverlayView Method


DrawingViews.AddProjectedView Method

DrawingViews.AddProjectedView Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a projected .

Visual Basic
Sub AddProjectedView(ParentView As DrawingView, Position As Point2d, ViewStyle As DrawingViewStyleEnum, ByRef Scale As [optional] VARIANT, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
ParentView | Input object that specifies the base parent view of the projected view.
ViewStyle | Input DrawingViewStyleEnum the specifies the display style of the geometry within the view.
Scale | Optional input Variant that specifies the drawing view scale factor. If this argument is not specified, the scale is derived from the ParentView.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddProjectedView Method


DrawingViews.AddSectionView Method

DrawingViews.AddSectionView Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a section drawing view.

Visual Basic
Sub AddSectionView(ParentView As DrawingView, SectionLineSketch As DrawingSketch, Position As Point2d, ViewStyle As DrawingViewStyleEnum, ByRef Scale As [optional] VARIANT, ByRef ShowLabel As [defaultvalue(-1)] VARIANT_BOOL, ByRef Name As [defaultvalue("")] BSTR, ByRef Reserved As [defaultvalue(-1)] VARIANT_BOOL, ByRef FullDepth As [defaultvalue(-1)] VARIANT_BOOL, ByRef SectionDepth As [optional] VARIANT, Result As [out, retval] SectionDrawingView*)
Parameters
Parameters | Description
ParentView | Input DrawingView object that specifies the base parent view of the projected view.
SectionLineSketch | Input DrawingSketch object that contains the profile that will be used to define the section line of the view. The choice between the projected and aligned methods is made automatically based on the following rules. The method can be changed after creation using SectionDrawingView.UseAlignedMethod property. 1) One line - Full Section View - Projected method 2) Two perpendicular lines - Half Section View - Projected method 3) Two non-perpendicular lines - Aligned Section View 4) Three or more lines - Offset Section View - Projected method
ViewStyle | Input DrawingViewStyleEnum the specifies the display style of the geometry within the view.
Scale | Optional input Double that specifies the drawing view scale factor. If this argument is not specified, the scale is derived from the ParentView.
ShowLabel | Optional input Boolean that specifies whether to display or hide the view label. The default is True indicating that the label will be displayed.
Name | Optional input String that defines the editable portion of the drawing view name that is displayed within the browser.
FullDepth | Optional input Boolean that specifies whether to use full section depth. A value of True indicates full section depth. If False, the SectionDepth argument needs to be supplied.
SectionDepth | Input Variant that defines the section depth. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
reserved | Optional input Boolean reserved for future use.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.AddSectionView Method


DrawingViews.Item Method

DrawingViews.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] DrawingView*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Methods > DrawingViews.Item Method


DrawingViews Properties

DrawingViews Properties
Summary

The properties of the DrawingViews class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Properties


DrawingViews.Count Property

DrawingViews.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Properties > DrawingViews.Count Property


DrawingViews.Type Property

DrawingViews.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DrawingViews Interface > DrawingViews Properties > DrawingViews.Type Property


DriveConstraintSettingsObject Interface

DriveConstraintSettingsObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The DriveConstraintSettings object provides access to various drive constraint related settings for assembly constraints.

Class Hierarchy
Inventor::DriveConstraintSettingsObject
Visual Basic
Public Interface DriveConstraintSettingsObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface


DriveConstraintSettingsObject Methods

DriveConstraintSettingsObject Methods
Summary

The methods of the DriveConstraintSettingsObject class are listed here.

Methods
Methods
Name | Description
GetIncrement | Method that returns how the increment was specified and the value.
GoToEnd | Method that advances the constraint to the end value.
GoToStart | Method that returns the constraint to the start value.
PlayForward | Method that drives the constraint forward. The returns a failure if start and end values are not set.
PlayReverse | Method that drives the constraint in reverse. The returns a failure if start and end values are not set.
SetIncrement | Method that sets the increment type and the value.
StartAVIRecording | Method that starts recording the drive constraint animation for saving to an avi file. Use the StopRecording method to stop recording and generate the animation file.
StartWMVRecording | Method that starts recording the drive constraint animation for saving to a wmv file. Use the StopRecording method to stop recording and generate the animation file.
StepForward | Method that advances the constraint by one step.
StepReverse | Method that reverses the constraint by one step.
StopRecording | Method that stops recording the drive constraint animation and generates the animation file.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods


DriveConstraintSettingsObject.GetIncrement Method

DriveConstraintSettingsObject.GetIncrement Method Available in Inventor Introduced in Inventor 2012
Summary

Method that returns how the increment was specified and the value.

Visual Basic
Sub GetIncrement(ByRef IncrementType As ConstraintIncrementTypeEnum, ByRef Increment As String)
Parameters
Parameters | Description
IncrementType | Output enum that returns the increment type. The possible return values are kIncrementAsAmountOfValue and kIncrementAsNumberOfSteps.
Increment | Output String that returns the increment value. The value returned is based on the increment type - amount of value if the type is kIncrementAsAmountOfValue and total number of steps if the type is kIncrementAsNumberOfSteps.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.GetIncrement Method


DriveConstraintSettingsObject.GoToEnd Method

DriveConstraintSettingsObject.GoToEnd Method Available in Inventor Introduced in Inventor 2012
Summary

Method that advances the constraint to the end value.

Visual Basic
Sub GoToEnd()
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.GoToEnd Method


DriveConstraintSettingsObject.GoToStart Method

DriveConstraintSettingsObject.GoToStart Method Available in Inventor Introduced in Inventor 2012
Summary

Method that returns the constraint to the start value.

Visual Basic
Sub GoToStart()
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.GoToStart Method


DriveConstraintSettingsObject.PlayForward Method

DriveConstraintSettingsObject.PlayForward Method Available in Inventor Introduced in Inventor 2012
Summary

Method that drives the constraint forward. The returns a failure if start and end values are not set.

Visual Basic
Sub PlayForward()
Parameters
Parameters | Description
Synchronous | Optional input Boolean that specifies whether the method is synchronous (control returns after completion of the drive constraint) or asynchronous (control returns immediately). If run asynchronously, the Stop method can be used to stop the animation.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.PlayForward Method


DriveConstraintSettingsObject.PlayReverse Method

DriveConstraintSettingsObject.PlayReverse Method Available in Inventor Introduced in Inventor 2012
Summary

Method that drives the constraint in reverse. The returns a failure if start and end values are not set.

Visual Basic
Sub PlayReverse()
Parameters
Parameters | Description
Synchronous | Optional input Boolean that specifies whether the method is synchronous (control returns after completion of the drive constraint) or asynchronous (control returns immediately). If run asynchronously, the Stop method can be used to stop the animation.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.PlayReverse Method


DriveConstraintSettingsObject.SetIncrement Method

DriveConstraintSettingsObject.SetIncrement Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the increment type and the value.

Visual Basic
Sub SetIncrement(IncrementType As ConstraintIncrementTypeEnum, Increment As String)
Parameters
Parameters | Description
IncrementType | Input enum that specifies the increment type. Valid values are kIncrementAsAmountOfValue and kIncrementAsNumberOfSteps.
Increment | Input String that specifies the increment value. The value is interpreted based on the increment type - amount of value if the type is kIncrementAsAmountOfValue and total number of steps if the type is kIncrementAsNumberOfSteps.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.SetIncrement Method


DriveConstraintSettingsObject.StartAVIRecording Method

DriveConstraintSettingsObject.StartAVIRecording Method Available in Inventor Introduced in Inventor 2012
Summary

Method that starts recording the drive constraint animation for saving to an avi file. Use the StopRecording method to stop recording and generate the animation file.

Visual Basic
Sub StartAVIRecording(FullFileName As String, ByRef Compressor As [defaultvalue("")] BSTR, ByRef CompressionQuality As [defaultvalue(75)] long, ByRef MoreOptions As [optional] VARIANT)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of the avi file to save the recording to.
Compressor | Optional input String that specifies the name of the compressor to use. The string should be a FourCC code (see here for details). If not specified, the default is used.
CompressionQuality | Optional input Long that specifies the compression quality. The valid range of values is 0 to 100. If not specified, a default value of 75 is used.
MoreOptions | Optional input that specifies additional options. Currently unused.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.StartAVIRecording Method


DriveConstraintSettingsObject.StartWMVRecording Method

DriveConstraintSettingsObject.StartWMVRecording Method Available in Inventor Introduced in Inventor 2012
Summary

Method that starts recording the drive constraint animation for saving to a wmv file. Use the StopRecording method to stop recording and generate the animation file.

Visual Basic
Sub StartWMVRecording(FullFileName As String, ByRef NetworkBandwidth As [defaultvalue(250)] long, ByRef ImageWidth As [defaultvalue(176)] long, ByRef ImageHeight As [defaultvalue(144)] long, ByRef AddMarkers As [defaultvalue(0)] VARIANT_BOOL, ByRef MoreOptions As [optional] VARIANT)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of the wmv file to save the recording to.
NetworkBandwidth | Optional input Long that specifies the bandwidth of your network connection in kbps. This value determines the size of the output file and the quality of recording. If not specified, this defaults to the BroadBand connection speed (250 Kbps).
ImageWidth | Optional input Long that specifies the width of the recorded window. Defaults to 176 if not specified.
ImageHeight | Optional input Long that specifies the height of the recorded window. Defaults to 144 if not specified.
AddMarkers | Optional input Boolean that specifies whether or not to add markers to the recording. Defaults to False.
MoreOptions | Optional input that specifies additional options. Currently unused.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.StartWMVRecording Method


DriveConstraintSettingsObject.StepForward Method

DriveConstraintSettingsObject.StepForward Method Available in Inventor Introduced in Inventor 2012
Summary

Method that advances the constraint by one step.

Visual Basic
Sub StepForward()
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.StepForward Method


DriveConstraintSettingsObject.StepReverse Method

DriveConstraintSettingsObject.StepReverse Method Available in Inventor Introduced in Inventor 2012
Summary

Method that reverses the constraint by one step.

Visual Basic
Sub StepReverse()
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.StepReverse Method


DriveConstraintSettingsObject.StopRecording Method

DriveConstraintSettingsObject.StopRecording Method Available in Inventor Introduced in Inventor 2012
Summary

Method that stops recording the drive constraint animation and generates the animation file.

Visual Basic
Sub StopRecording()
Remarks

Use the StartWMVRecording or StartAVIRecording method to start recording the animation.

You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Methods > DriveConstraintSettingsObject.StopRecording Method


DriveConstraintSettingsObject Properties

DriveConstraintSettingsObject Properties
Summary

The properties of the DriveConstraintSettingsObject class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
CollisionDetection | Property that gets and sets whether to drive the constrained assembly until a collision is detected.
DriveAdaptivity | Property that gets and sets whether to adapt components while maintaining constraint relationships.
EndValue | Property that gets and sets the expression for the end value.
FrameRate | Property that gets and sets the increments at which a "snapshot" is taken for inclusion as a frame in a recorded animation.
IsInitialized | Property that returns whether the drive constraint parameters have been set for this constraint.
Parent | Property that returns the parent constraint object.
PauseDelay | Property that gets and sets the delay between steps in seconds.
RepetitionCount | Property that gets and sets the number of repetitions for the Start/End sequence and the number of cycles for the Start/End/Start sequence. Each movement is considered one cycle.
RepetitionStartEndStart | Property that gets and sets whether to drive the constraint from the start value to the end value and then in reverse to the start value. If set to True, the constraint is driven in reverse to the start value, else it is reset back to the start value.
StartValue | Property that gets and sets the expression for the start value. If units are not specified, it defaults to the current length units of the document.
Type | Property returning kDriveConstraintSettingsObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties


DriveConstraintSettingsObject.Application Property

DriveConstraintSettingsObject.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.Application Property


DriveConstraintSettingsObject.CollisionDetection Property

DriveConstraintSettingsObject.CollisionDetection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to drive the constrained assembly until a collision is detected.

Visual Basic
Property CollisionDetection() As VARIANT_BOOL
Remarks

When an interference is detected, it is displayed and its constraint value shown. Setting this property to True will return an error if the DriveAdaptivity property is set to True.

You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.CollisionDetection Property


DriveConstraintSettingsObject.DriveAdaptivity Property

DriveConstraintSettingsObject.DriveAdaptivity Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to adapt components while maintaining constraint relationships.

Visual Basic
Property DriveAdaptivity() As VARIANT_BOOL
Remarks

Setting this property to True will return an error if the CollisionDetection property is set to True.

You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.DriveAdaptivity Property


DriveConstraintSettingsObject.EndValue Property

DriveConstraintSettingsObject.EndValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the expression for the end value.

Visual Basic
Property EndValue() As String
Remarks

If units are not specified, it defaults to the current length units of the document.

You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.EndValue Property


DriveConstraintSettingsObject.FrameRate Property

DriveConstraintSettingsObject.FrameRate Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the increments at which a "snapshot" is taken for inclusion as a frame in a recorded animation.

Visual Basic
Property FrameRate() As long
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.FrameRate Property


DriveConstraintSettingsObject.IsInitialized Property

DriveConstraintSettingsObject.IsInitialized Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns whether the drive constraint parameters have been set for this constraint.

Visual Basic
Property IsInitialized() As VARIANT_BOOL*
Remarks

If this property returns False, the properties on this object will return hard-coded default values and the methods will fail. Calling properties and methods to set drive constraint parameters will automatically toggle this property to True.

You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.IsInitialized Property


DriveConstraintSettingsObject.Parent Property

DriveConstraintSettingsObject.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent constraint object.

Visual Basic
Property Parent() As AssemblyConstraint**
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.Parent Property


DriveConstraintSettingsObject.PauseDelay Property

DriveConstraintSettingsObject.PauseDelay Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the delay between steps in seconds.

Visual Basic
Property PauseDelay() As double
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.PauseDelay Property


DriveConstraintSettingsObject.RepetitionCount Property

DriveConstraintSettingsObject.RepetitionCount Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the number of repetitions for the Start/End sequence and the number of cycles for the Start/End/Start sequence. Each movement is considered one cycle.

Visual Basic
Property RepetitionCount() As long
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.RepetitionCount Property


DriveConstraintSettingsObject.RepetitionStartEndStart Property

DriveConstraintSettingsObject.RepetitionStartEndStart Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to drive the constraint from the start value to the end value and then in reverse to the start value. If set to True, the constraint is driven in reverse to the start value, else it is reset back to the start value.

Visual Basic
Property RepetitionStartEndStart() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.RepetitionStartEndStart Property


DriveConstraintSettingsObject.StartValue Property

DriveConstraintSettingsObject.StartValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the expression for the start value. If units are not specified, it defaults to the current length units of the document.

Visual Basic
Property StartValue() As String
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.StartValue Property


DriveConstraintSettingsObject.Type Property

DriveConstraintSettingsObject.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kDriveConstraintSettingsObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsObject Interface > DriveConstraintSettingsObject Properties > DriveConstraintSettingsObject.Type Property


DriveConstraintSettingsSink Interface

DriveConstraintSettingsSink Interface
Summary

This is class Inventor::DriveConstraintSettingsSink.

Class Hierarchy
Inventor::DriveConstraintSettingsSink
Visual Basic
Public Interface DriveConstraintSettingsSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsSink Interface


DriveConstraintSettingsSink Methods

DriveConstraintSettingsSink Methods
Summary

The methods of the DriveConstraintSettingsSink class are listed here.

Methods
Methods
Name | Description
OnCollision | Event that is fired whenever a collision occurs during the animation/play of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsSink Interface > DriveConstraintSettingsSink Methods


DriveConstraintSettingsSink.OnCollision Method

DriveConstraintSettingsSink.OnCollision Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired whenever a collision occurs during the animation/play of the constraint.

Visual Basic
Sub OnCollision()
Remarks

The event fires only if the CollisionDetection property is set to True.

You are here: Symbol Reference > Inventor Library > Objects > DriveConstraintSettingsSink Interface > DriveConstraintSettingsSink Methods > DriveConstraintSettingsSink.OnCollision Method


Edge Interface

Edge Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Edge object. See the Boundary Representation article in the overviews section.

Class Hierarchy
Inventor::Edge
    Inventor::EdgeProxy
Visual Basic
Public Interface Edge
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AnalyticEdgeWorkAxisDef.Edge

CenteredWidthExtent.Edge

Edge.GetSourceEdge

EdgeProxy.NativeObject

Edges.Item

EdgeUse.Edge

EdgeWidthExtent.Edge

FilletIntermediateRadius.Edge

FilletSetback.Edge

FlatBendResult.Edge

FromToWidthExtent.Edge

MidPointWorkPointDef.Edge

NonLinearEdgeWorkPointDef.Edge

OffsetWidthExtent.Edge

SurfaceGraphicsEdge.Edge

WidthOffsetWidthExtent.Edge

PlanarSketch.AxisEntity

CircularPatternFeature.AxisEntity

ConcentricHolePlacementDefinition.ConcentricReference

PointHolePlacementDefinition.Direction

CentroidWorkPointDef.Entities

AngleiMateDefinition.Entity

InsertiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

LineAndPlaneWorkAxisDef.Line

LineAndPointWorkAxisDef.Line

LineAndTangentWorkPlaneDef.Line

LinePlaneAndAngleWorkPlaneDef.Line

LineWorkAxisDef.Line

TwoLinesWorkPlaneDef.Line1

TwoLinesWorkPointDef.Line1

TwoLinesWorkPlaneDef.Line2

TwoLinesWorkPointDef.Line2

iFeatureSketchPlaneInput.PlaneInput

iFeatureWorkPlaneInput.PlaneInput

FaceDraftFeature.PullDirection

DraftAnalysis.PullDirection

LinearHolePlacementDefinition.ReferenceEntityOne

LinearHolePlacementDefinition.ReferenceEntityTwo

ToExtent.ToEntity

RectangularPatternFeature.XDirectionEntity

RectangularPatternFeature.YDirectionEntity

See Also

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Window Selection sample

Sketch Edit Orientation sample

Thread Feature Create sample

Create sheet metal face and flange features sample

Sketch Add Oriented sample

Delete Face, Boundary Patch and Stitch features. sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface


Edge Methods

Edge Methods
Summary

The methods of the Edge class are listed here.

Methods
Methods
Name | Description
CalculateStrokes | Method that calculates the set of strokes that approximate all of the edges of the SurfaceBody, Face or Edge from which the method was called. The Tolerance argument defines the accuracy of the strokes. The output from this method represents a series of line segments, not connected polylines.
GetClosestPointTo | Method that returns a point on the edge that is closest to the input point. A single point is returned even if multiple equidistant points are found. To get the u parameter of the returned point on the edge, use Edge.Evaluator.GetParamAtPoint method.
GetExistingStrokes | Method that returns the specified set of strokes from the SurfaceBody, Face or Edge the method was called from. Existing strokes are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateStrokes method, which will calculate new strokes to a given tolerance at double-precision accuracy. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load... more
GetExistingStrokeTolerances | Method that gets the tolerances that were used to calculate the existing sets of display strokes. These can be used to determine if any existing strokes have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing strokes to retrieve when using the GetExistingStrokes method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetSourceEdge | Method that gets the source edge that has been overridden by this edge. The method returns Nothing if this edge is not an override. An error is returned if this method is called on an edge in a part.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods


Edge.CalculateStrokes Method

Edge.CalculateStrokes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that calculates the set of strokes that approximate all of the edges of the SurfaceBody, Face or Edge from which the method was called. The Tolerance argument defines the accuracy of the strokes. The output from this method represents a series of line segments, not connected polylines.

Visual Basic
Sub CalculateStrokes(Tolerance As double, ByRef VertexCount As long, ByRef SegmentCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
Parameters
Parameters | Description
Tolerance | Input Double that defines the accuracy of the strokes. This is a "chord height" tolerance. This is the maximum distance the stroke can be from the actual curve.
VertexCount | Output Long that returns the number of vertices that were generated for the strokes. This is the number of vertices that will be returned by the VertexCoordinates argument.
SegmentCount | Output Long that returns the number of line segments represented by the strokes.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
VertexIndices | Output array of Longs that are used to index into the vertex coordinates array. These indices provide the information that defines how the vertices are connected to create the strokes.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods > Edge.CalculateStrokes Method


Edge.GetClosestPointTo Method

Edge.GetClosestPointTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns a point on the edge that is closest to the input point. A single point is returned even if multiple equidistant points are found. To get the u parameter of the returned point on the edge, use Edge.Evaluator.GetParamAtPoint method.

Visual Basic
Sub GetClosestPointTo(InputPoint As Point, Result As [out, retval] Point*)
Parameters
Parameters | Description
InputPoint | Point object that specifies the point for which the closest point on the edge is to be located. If the input point lies on the Edge, the coordinates of the input point are returned.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods > Edge.GetClosestPointTo Method


Edge.GetExistingStrokes Method

Edge.GetExistingStrokes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified set of strokes from the SurfaceBody, Face or Edge the method was called from. Existing strokes are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateStrokes method, which will calculate new strokes to a given tolerance at double-precision accuracy. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingStrokes(ToleranceIndex As double, ByRef VertexCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef PolylineCount As long, ByRef PolylineLengths As SAFEARRAY(long))
Parameters
Parameters | Description
ToleranceIndex | Input Double that serves as an index into which set of existing strokes you want to retrieve. If the input tolerance does not match an existing set an error will occur. The tolerances for existing strokes can be obtained using the GetExistingStrokeTolerances method.
VertexCount | Output Long that returns the number of vertices that were generated for the strokes. This is the number of vertices will be returned by the VertexCoordinates argument.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
PolylineCount | Output Long that specifies the number of polylines that are represented by the strokes.
PolylineLengths | Output array of Longs that specifies the number of vertices that are used for each polyline.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods > Edge.GetExistingStrokes Method


Edge.GetExistingStrokeTolerances Method

Edge.GetExistingStrokeTolerances Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that gets the tolerances that were used to calculate the existing sets of display strokes. These can be used to determine if any existing strokes have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing strokes to retrieve when using the GetExistingStrokes method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingStrokeTolerances(ByRef ToleranceCount As long, ByRef ExistingTolerances As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceCount | Output Long that specifies the number of existing stroke sets.
ExistingTolerances | Output array of Doubles that contains the tolerances that were used to compute the existing sets of display strokes.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods > Edge.GetExistingStrokeTolerances Method


Edge.GetReferenceKey Method

Edge.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods > Edge.GetReferenceKey Method


Edge.GetSourceEdge Method

Edge.GetSourceEdge Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that gets the source edge that has been overridden by this edge. The method returns Nothing if this edge is not an override. An error is returned if this method is called on an edge in a part.

Visual Basic
Sub GetSourceEdge(ByRef GetLeafSource As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Edge*)
Parameters
Parameters | Description
GetLeafSource | Optional input Boolean that specifies whether to get the 'leaf' source edge in the case where there are multiple levels of override. If specified to be False, the method returns the next level override edge. If not specified, the argument defaults to True indicating that the leaf source will be returned.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Methods > Edge.GetSourceEdge Method


Edge Properties

Edge Properties
Summary

The properties of the Edge class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
EdgeUses | Gets the that reference this Edge.
Evaluator | Gets the CurveEvaluator for this Edge.
Faces | Property that returns the that this Edge is referenced from.
Geometry | Property that returns the underlying geometry of the edge (e.g. Arc2D, Circle, Cone etc.)
GeometryForm | Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.
GeometryType | Get the curve type of the curve that will be returned from the Geometry property.
IsParamReversed | Gets whether the parameterization of the geometry obtained from the Geometry property is aligned or opposed to the topological sense of this Edge.
IsTolerant | Indicates if this Edge is using tolerant modeling to allow a non-exact model.
Parent | Property that returns the parent object from whom this object can logically be reached.
PointOnEdge | Property that returns a characteristic somewhere in the middle of the Edge.
StartVertex | Gets the Vertex referenced at the start of this Edge.
StopVertex | Gets the Vertex referenced at the end of this Edge.
TangentiallyConnectedEdges | Property that returns an that contains the input edge and all tangentially connected edges. The CollectionType of the output EdgeCollection is set to kTangentiallyConnected.
Tolerance | Returns the tolerance being used for modeling calculations and this Edge.
TransientKey | Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.
Type | Property returning an enum indicating this object's type.
Wire | Get the Wire containing this Edge. Returns Nothing if this Edge does not belong to a Wire.
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties


Edge.Application Property

Edge.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Application Property


Edge.AttributeSets Property

Edge.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.AttributeSets Property


Edge.EdgeUses Property

Edge.EdgeUses Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the that reference this Edge.

Visual Basic
Property EdgeUses() As EdgeUses**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.EdgeUses Property


Edge.Evaluator Property

Edge.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the CurveEvaluator for this Edge.

Visual Basic
Property Evaluator() As CurveEvaluator**
Remarks

What is the difference between Edge.Evaluator and Edge.Geometry.Evaluator? Do not assume that these evaluators are based on the same parameterization. Edge.Evaluator returns an evaluator on the edge's curve, adjusted for the sense of the edge in relation to the curve (see IsParamReversed), as well as being limited to the extents of the Edge. Edge.Geometry returns the geometric curve that this Edge is based on. The difference between Curve and Geometry is that Curve returns the actual unbounded geometry that the Edge is really based on, where Geometry trims it to the same extents. So, Edge.Geometry.Evaluator returns the evaluator for the Edge's underlying curve. When should I use each type? If all you want to do is to evaluate points along an edge, use the Edge.Evaluator. Sometimes though, it is necessary to get specific geometry type information from the edge's curve (such as arc center point, elliptical arc major axis, etc...) and in those cases you need to access the Edge.Geometry. Also, if you also want to evaluate points or intervals across this same curve instead of the edge, we provide the evaluator on there as well, though you will have to adjust it for the IsParamReversed sense relative to the Edge if you care about aligning it with the Edge sense. Sometimes, such as in the case of transient geometry or transient geometry curves obtained from objects like sketch curve entities, you only have the curve evaluator on the geometry itself.

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Evaluator Property


Edge.Faces Property

Edge.Faces Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the that this Edge is referenced from.

Visual Basic
Property Faces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Faces Property


Edge.Geometry Property

Edge.Geometry Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the underlying geometry of the edge (e.g. Arc2D, Circle, Cone etc.)

Visual Basic
Property Geometry() As IDispatch**
See Also

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Geometry Property


Edge.GeometryForm Property

Edge.GeometryForm Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.

Visual Basic
Property GeometryForm() As long*
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.GeometryForm Property


Edge.GeometryType Property

Edge.GeometryType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Get the curve type of the curve that will be returned from the Geometry property.

Visual Basic
Property GeometryType() As CurveTypeEnum*
See Also

Window Selection sample

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.GeometryType Property


Edge.IsParamReversed Property

Edge.IsParamReversed Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the parameterization of the geometry obtained from the Geometry property is aligned or opposed to the topological sense of this Edge.

Visual Basic
Property IsParamReversed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.IsParamReversed Property


Edge.IsTolerant Property

Edge.IsTolerant Property Available in Apprentice
Summary

Indicates if this Edge is using tolerant modeling to allow a non-exact model.

Visual Basic
Property IsTolerant() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.IsTolerant Property


Edge.Parent Property

Edge.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Parent Property


Edge.PointOnEdge Property

Edge.PointOnEdge Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a characteristic somewhere in the middle of the Edge.

Visual Basic
Property PointOnEdge() As Point**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.PointOnEdge Property


Edge.StartVertex Property

Edge.StartVertex Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Vertex referenced at the start of this Edge.

Visual Basic
Property StartVertex() As Vertex**
See Also

Creating flange features sample

Edit width extent of an existing flange feature sample

Sketch Add Oriented sample

Finding Bend Extent (Tangent) Edges sample

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.StartVertex Property


Edge.StopVertex Property

Edge.StopVertex Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Vertex referenced at the end of this Edge.

Visual Basic
Property StopVertex() As Vertex**
See Also

Creating flange features sample

Edit width extent of an existing flange feature sample

Finding Bend Extent (Tangent) Edges sample

You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.StopVertex Property


Edge.TangentiallyConnectedEdges Property

Edge.TangentiallyConnectedEdges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns an that contains the input edge and all tangentially connected edges. The CollectionType of the output EdgeCollection is set to kTangentiallyConnected.

Visual Basic
Property TangentiallyConnectedEdges() As EdgeCollection**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.TangentiallyConnectedEdges Property


Edge.Tolerance Property

Edge.Tolerance Property Available in Apprentice
Summary

Returns the tolerance being used for modeling calculations and this Edge.

Visual Basic
Property Tolerance() As double*
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Tolerance Property


Edge.TransientKey Property

Edge.TransientKey Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.

Visual Basic
Property TransientKey() As long*
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.TransientKey Property


Edge.Type Property

Edge.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Type Property


Edge.Wire Property

Edge.Wire Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Get the Wire containing this Edge. Returns Nothing if this Edge does not belong to a Wire.

Visual Basic
Property Wire() As Wire**
You are here: Symbol Reference > Inventor Library > Objects > Edge Interface > Edge Properties > Edge.Wire Property


EdgeCollection Interface

EdgeCollection Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The EdgeCollection object provides access to all of the and EdgeCollection objects in a collection and provides methods to add Edge and EdgeCollection objects to the collection.

Class Hierarchy
Inventor::ObjectsEnumerator
    Inventor::ObjectCollection
        Inventor::EdgeCollection
Visual Basic
Public Interface EdgeCollection
Inherits ObjectCollection
Remarks

An example of when you would use an EdgeCollection within another EdgeCollection is when creating a fillet feature. For example, say you have a case of two sets of tangentially connected edges and two other edges to fillet. Using the TangentiallyConnectedEdges property of the Edge object you can create two EdgeCollection objects that each contain a set of tangent edges. You can then create a new EdgeCollection object using the CreateEdgeCollection method of the TransientObjects object and use its Add method to add the two previously created EdgeCollection objects and any additional edges you want to fillet. The EdgeCollection object containing all of the edges can then be used as input to create the fillet feature. See here for an overview.

Notes

Members through which this object may be accessed include:

BendDefinition.Edges

ChamferFeature.ChamferedEdges

ContourFlangeDefinition.Edges

CornerChamferDefinition.CornerEdges

CornerDefinition.Edges

CornerRoundEdgeSet.Edges

Edge.TangentiallyConnectedEdges

FaceDraftFeature.FixedEdges

FilletRadiusEdgeSet.Edges

FlangeDefinition.Edges

HemDefinition.Edges

SurfaceBody.ConcaveEdges

SurfaceBody.ConvexEdges

TransientObjects.CreateEdgeCollection

BoundaryPatchLoop.BoundaryPath

LoftDefinition.Centerline

CentroidWorkPointDef.Entities

See Also

Create sheet metal rip feature sample

Create sheet metal face and flange features sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > EdgeCollection Interface


EdgeCollection Properties

EdgeCollection Properties
Summary

The properties of the EdgeCollection class are listed here.

Properties
Name | Description
CollectionType | Property that returns how the edge collection was constructed. Valid returns are kAllConcave, kAllConvex, kTangentiallyConnected, and kUndefined. This property is set when the EdgeCollection object is originally created. When the ConcaveEdges property of the SurfaceBody object is used, it is set to kAllConcave. When the ConvexEdges property of the SurfaceBody object is used, it is set to kAllConvex. When the TangentiallyConnectedEdges property of the Edge object is used, it is set to kTangentiallyConnected. When it is created using the CreateEdgeCollection method of the TransientObjects it is set to kUndefined. If an EdgeCollection has a collection type other than kUndefined and... more
You are here: Symbol Reference > Inventor Library > Objects > EdgeCollection Interface > EdgeCollection Properties


EdgeCollection.CollectionType Property

EdgeCollection.CollectionType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns how the edge collection was constructed. Valid returns are kAllConcave, kAllConvex, kTangentiallyConnected, and kUndefined. This property is set when the EdgeCollection object is originally created. When the ConcaveEdges property of the SurfaceBody object is used, it is set to kAllConcave. When the ConvexEdges property of the SurfaceBody object is used, it is set to kAllConvex. When the TangentiallyConnectedEdges property of the Edge object is used, it is set to kTangentiallyConnected. When it is created using the CreateEdgeCollection method of the TransientObjects it is set to kUndefined. If an EdgeCollection has a collection type other than kUndefined and the contents are changed by adding or removing items from the collection, the CollectionType will be reset to kUndefined.

Visual Basic
Property CollectionType() As EdgeCollectionEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeCollection Interface > EdgeCollection Properties > EdgeCollection.CollectionType Property


EdgeDefinition Interface

EdgeDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The EdgeDefinition represents a transient definition of an Edge object.

Class Hierarchy
Inventor::EdgeDefinition
Visual Basic
Public Interface EdgeDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeDefinitions.Add

EdgeDefinitions.Item

EdgeUseDefinition.EdgeDefinition

See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface


EdgeDefinition Properties

EdgeDefinition Properties
Summary

The properties of the EdgeDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AssociativeID | Property that gets and sets the associate ID of this edge. This ID will be transferred to the corresponding edge when this SurfaceBodyDefinition is used to create a SurfaceBody. It is used by Inventor as the identifier for the edge and is used for tracking this geometry for associativity. A value of -1 for the associative ID indicates that it has not been set.
EndVertex | Property that gets and sets the end vertex of the edge. This can be Nothing where no end vertex is specifically defined.
FaceOne | Property that gets and sets the associated FaceDefinition object
FaceTwo | Property that gets and sets the associated FaceDefinition object.
IsParamReversed | Property that defines if the orientation of this EdgeUse is in the same direction or not relative to the associated EdgeDefinition object.
ModelSpaceCurve | Property that gets and sets the definition of the edge in model space. This can be Nothing in the case where no model space geometry is specified for this edge.
ParameterSpaceCurveOne | Property that gets and sets the definition of the edge in parameter space. If this is provided then the FaceOne property must also be set to define the parameter space this curve is defined within. This can be Nothing in the case where no parameter space curve is defined for this edge.
ParameterSpaceCurveTwo | Property that gets and sets the definition of the edge in parameter space. If this is provided then the FaceTwo property must also be set to define the parameter space this curve is defined within. This can be Nothing in the case where no parameter space curve is defined for this edge.
StartVertex | Property that gets and sets the starting vertex of the edge. This can be Nothing where no start vertex is specifically defined.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties


EdgeDefinition.Application Property

EdgeDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.Application Property


EdgeDefinition.AssociativeID Property

EdgeDefinition.AssociativeID Property
Summary

Property that gets and sets the associate ID of this edge. This ID will be transferred to the corresponding edge when this SurfaceBodyDefinition is used to create a SurfaceBody. It is used by Inventor as the identifier for the edge and is used for tracking this geometry for associativity. A value of -1 for the associative ID indicates that it has not been set.

Visual Basic
Property AssociativeID() As long
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.AssociativeID Property


EdgeDefinition.EndVertex Property

EdgeDefinition.EndVertex Property
Summary

Property that gets and sets the end vertex of the edge. This can be Nothing where no end vertex is specifically defined.

Visual Basic
Property EndVertex() As VertexDefinition*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.EndVertex Property


EdgeDefinition.FaceOne Property

EdgeDefinition.FaceOne Property
Summary

Property that gets and sets the associated FaceDefinition object

Visual Basic
Property FaceOne() As FaceDefinition*
Remarks

This is used in two cases. The first case is where the edge is being defined by a parameter space curve and this face defines the parameter space of the curve provided through the ParameterSpaceCurveOne property. The second case is where the edge is defined by the intersection of two faces, in which case FaceTwo also needs to be defined. This can be Nothing in the case where a face is not being used to define the edge.

You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.FaceOne Property


EdgeDefinition.FaceTwo Property

EdgeDefinition.FaceTwo Property
Summary

Property that gets and sets the associated FaceDefinition object.

Visual Basic
Property FaceTwo() As FaceDefinition*
Remarks

This is used in two cases. The first case is where the edge is being defined by a parameter space curve and this face defines the parameter space of the curve provided through the ParameterSpaceCurveTwo property. The second case is where the edge is defined by the intersection of two faces, in which case FaceOne also needs to be defined. This can be Nothing in the case where a face is not being used to define the edge.

You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.FaceTwo Property


EdgeDefinition.IsParamReversed Property

EdgeDefinition.IsParamReversed Property Introduced in Inventor 2011
Summary

Property that defines if the orientation of this EdgeUse is in the same direction or not relative to the associated EdgeDefinition object.

Visual Basic
Property IsParamReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.IsParamReversed Property


EdgeDefinition.ModelSpaceCurve Property

EdgeDefinition.ModelSpaceCurve Property
Summary

Property that gets and sets the definition of the edge in model space. This can be Nothing in the case where no model space geometry is specified for this edge.

Visual Basic
Property ModelSpaceCurve() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.ModelSpaceCurve Property


EdgeDefinition.ParameterSpaceCurveOne Property

EdgeDefinition.ParameterSpaceCurveOne Property
Summary

Property that gets and sets the definition of the edge in parameter space. If this is provided then the FaceOne property must also be set to define the parameter space this curve is defined within. This can be Nothing in the case where no parameter space curve is defined for this edge.

Visual Basic
Property ParameterSpaceCurveOne() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.ParameterSpaceCurveOne Property


EdgeDefinition.ParameterSpaceCurveTwo Property

EdgeDefinition.ParameterSpaceCurveTwo Property
Summary

Property that gets and sets the definition of the edge in parameter space. If this is provided then the FaceTwo property must also be set to define the parameter space this curve is defined within. This can be Nothing in the case where no parameter space curve is defined for this edge.

Visual Basic
Property ParameterSpaceCurveTwo() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.ParameterSpaceCurveTwo Property


EdgeDefinition.StartVertex Property

EdgeDefinition.StartVertex Property
Summary

Property that gets and sets the starting vertex of the edge. This can be Nothing where no start vertex is specifically defined.

Visual Basic
Property StartVertex() As VertexDefinition*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.StartVertex Property


EdgeDefinition.Type Property

EdgeDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinition Interface > EdgeDefinition Properties > EdgeDefinition.Type Property


EdgeDefinitions Interface

EdgeDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The EdgeDefinitions collection provides access to existing EdgeDefinition objects and allows creation of new EdgeDefinition objects.

Class Hierarchy
Inventor::EdgeDefinitions
Visual Basic
Public Interface EdgeDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceBodyDefinition.EdgeDefinitions

You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface


EdgeDefinitions Methods

EdgeDefinitions Methods
Summary

The methods of the EdgeDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new EdgeDefinition within the associated SurfaceBodyDefinition.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Methods


EdgeDefinitions.Add Method

EdgeDefinitions.Add Method
Summary

Method that creates a new EdgeDefinition within the associated SurfaceBodyDefinition.

Visual Basic
Sub Add(StartVertex As VertexDefinition, EndVertex As VertexDefinition, ByRef ModelSpaceCurve As [optional] VARIANT, ByRef ParameterSpaceCurveOne As [optional] VARIANT, ByRef FaceOne As [optional] VARIANT, ByRef ParameterSpaceCurveTwo As [optional] VARIANT, ByRef FaceTwo As [optional] VARIANT, Result As [out, retval] EdgeDefinition*)
Parameters
Parameters | Description
StartVertex | Optional input VertexDefinition object that defines the start of the edge.
EndVertex | Optional input VertexDefinition object that defines the end of the edge.
ModelSpaceCurve | Optional input transient geometry curve object that defines the shape of this edge using 3d geometry in model space. Valid input is Arc3d, BsplineCurve, Circle, EllipseFull, EllipticalArc, LineSegment and Polyline3D.
ParameterSpaceCurveOne | Optional input transient geometry curve object that defines the shape of this edge using 2d geometry in the parametric space of the surface defined by the FaceOne argument. Valid input is Arc2d, BsplineCurve2d, Circle2d, EllipseFull2d, EllipticalArc2d, LineSegment2d and Polyline2D.
FaceOne | Optional input FaceDefinition object that either defines the parametric space that the curve provided in ParameterSpaceCurveOne argument is defined within or it defines the first of two faces to be intersected to calculate the edge.
ParameterSpaceCurveTwo | Optional input transient geometry curve object that defines the shape of this edge using 2d geometry in the parametric space of the surface defined by the FaceOne argument. Valid input is Arc2d, BsplineCurve2d, Circle2d, EllipseFull2d, EllipticalArc2d, LineSegment2d and Polyline2D.
FaceTwo | Optional input FaceDefinition object that either defines the parametric space that the curve provided in ParameterSpaceCurveTwo argument is defined within or it defines the second of two faces to be intersected to calculate the edge.
Remarks

Various combinations of the input arguments can be used to define the edge in different ways. The various valid combinations are described below:

  • If you know the geometry of the edge as a 3d curve in model space then just the ModelSpaceCurve argument can be supplied.
  • If you know the geometry of the edge in parametric space of one of the faces then you can supply the ParameterSpaceCurveOne that defines the 2d parameter space curve and the FaceOne argument that defines the parameter space that curve is defined within. Optionally you can also supply the ParameterSpaceCurveTwo and FaceTwo arguments to define the edge in parametric space of the second face too.
  • You can also define the edge as the intersection of two faces by supplying only the FaceOne and FaceTwo arguments.
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Methods > EdgeDefinitions.Add Method


EdgeDefinitions.Item Method

EdgeDefinitions.Item Method
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] EdgeDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Methods > EdgeDefinitions.Item Method


EdgeDefinitions Properties

EdgeDefinitions Properties
Summary

The properties of the EdgeDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Properties


EdgeDefinitions.Application Property

EdgeDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Properties > EdgeDefinitions.Application Property


EdgeDefinitions.Count Property

EdgeDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Properties > EdgeDefinitions.Count Property


EdgeDefinitions.Type Property

EdgeDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeDefinitions Interface > EdgeDefinitions Properties > EdgeDefinitions.Type Property


EdgeLoop Interface

EdgeLoop Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EdgeLoop object. See the article in the overviews section.

Class Hierarchy
Inventor::EdgeLoop
    Inventor::EdgeLoopProxy
Visual Basic
Public Interface EdgeLoop
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeLoopProxy.NativeObject

EdgeLoops.Item

EdgeUse.EdgeLoop

BoundaryPatchLoop.BoundaryPath

LoftDefinition.Centerline

CentroidWorkPointDef.Entities

LoftRail.Rail

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface


EdgeLoop Methods

EdgeLoop Methods
Summary

The methods of the EdgeLoop class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Methods


EdgeLoop.GetReferenceKey Method

EdgeLoop.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Methods > EdgeLoop.GetReferenceKey Method


EdgeLoop Properties

EdgeLoop Properties
Summary

The properties of the EdgeLoop class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Edges | Gets the referenced by this EdgeLoop.
EdgeUses | Gets the referenced by this EdgeLoop.
Face | Gets the containing this EdgeLoop.
IsOuterEdgeLoop | Gets whether this EdgeLoop is an external loop, or a loop that encloses material as opposed to a void.
Parent | Property that returns the parent object from whom this object can logically be reached.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
TransientKey | Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties


EdgeLoop.Application Property

EdgeLoop.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.Application Property


EdgeLoop.AttributeSets Property

EdgeLoop.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.AttributeSets Property


EdgeLoop.Edges Property

EdgeLoop.Edges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the referenced by this EdgeLoop.

Visual Basic
Property Edges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.Edges Property


EdgeLoop.EdgeUses Property

EdgeLoop.EdgeUses Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the referenced by this EdgeLoop.

Visual Basic
Property EdgeUses() As EdgeUses**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.EdgeUses Property


EdgeLoop.Face Property

EdgeLoop.Face Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the containing this EdgeLoop.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.Face Property


EdgeLoop.IsOuterEdgeLoop Property

EdgeLoop.IsOuterEdgeLoop Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether this EdgeLoop is an external loop, or a loop that encloses material as opposed to a void.

Visual Basic
Property IsOuterEdgeLoop() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.IsOuterEdgeLoop Property


EdgeLoop.Parent Property

EdgeLoop.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.Parent Property


EdgeLoop.RangeBox Property

EdgeLoop.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.RangeBox Property


EdgeLoop.TransientKey Property

EdgeLoop.TransientKey Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.

Visual Basic
Property TransientKey() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.TransientKey Property


EdgeLoop.Type Property

EdgeLoop.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoop Interface > EdgeLoop Properties > EdgeLoop.Type Property


EdgeLoopDefinition Interface

EdgeLoopDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FaceDefinition represents a transient definition of a Face object.

Class Hierarchy
Inventor::EdgeLoopDefinition
Visual Basic
Public Interface EdgeLoopDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeLoopDefinitions.Add

EdgeLoopDefinitions.Item

See Also

Transient surface body creation sample

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinition Interface


EdgeLoopDefinition Properties

EdgeLoopDefinition Properties
Summary

The properties of the EdgeLoopDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EdgeUseDefinitions | Property that returns the collection of EdgeUseDefinition objects associated with this EdgeLoopDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinition Interface > EdgeLoopDefinition Properties


EdgeLoopDefinition.Application Property

EdgeLoopDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinition Interface > EdgeLoopDefinition Properties > EdgeLoopDefinition.Application Property


EdgeLoopDefinition.EdgeUseDefinitions Property

EdgeLoopDefinition.EdgeUseDefinitions Property
Summary

Property that returns the collection of EdgeUseDefinition objects associated with this EdgeLoopDefinition object.

Visual Basic
Property EdgeUseDefinitions() As EdgeUseDefinitions**
See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinition Interface > EdgeLoopDefinition Properties > EdgeLoopDefinition.EdgeUseDefinitions Property


EdgeLoopDefinition.Type Property

EdgeLoopDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinition Interface > EdgeLoopDefinition Properties > EdgeLoopDefinition.Type Property


EdgeLoopDefinitions Interface

EdgeLoopDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The EdgeLoopsDefinitions collection provides access to existing EdgeLoopDefinition objects and allows creation of new EdgeLoopDefinition objects.

Class Hierarchy
Inventor::EdgeLoopDefinitions
Visual Basic
Public Interface EdgeLoopDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FaceDefinition.EdgeLoopDefinitions

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface


EdgeLoopDefinitions Methods

EdgeLoopDefinitions Methods
Summary

The methods of the EdgeLoopDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new EdgeLoopDefinition within the associated SurfaceBodyDefinition.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Methods


EdgeLoopDefinitions.Add Method

EdgeLoopDefinitions.Add Method
Summary

Method that creates a new EdgeLoopDefinition within the associated SurfaceBodyDefinition.

Visual Basic
Sub Add(Result As [out, retval] EdgeLoopDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Methods > EdgeLoopDefinitions.Add Method


EdgeLoopDefinitions.Item Method

EdgeLoopDefinitions.Item Method
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] EdgeLoopDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Methods > EdgeLoopDefinitions.Item Method


EdgeLoopDefinitions Properties

EdgeLoopDefinitions Properties
Summary

The properties of the EdgeLoopDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Properties


EdgeLoopDefinitions.Application Property

EdgeLoopDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Properties > EdgeLoopDefinitions.Application Property


EdgeLoopDefinitions.Count Property

EdgeLoopDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Properties > EdgeLoopDefinitions.Count Property


EdgeLoopDefinitions.Type Property

EdgeLoopDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopDefinitions Interface > EdgeLoopDefinitions Properties > EdgeLoopDefinitions.Type Property


EdgeLoopProxy Interface

EdgeLoopProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EdgeLoop object.

Class Hierarchy
Inventor::EdgeLoop
    Inventor::EdgeLoopProxy
Visual Basic
Public Interface EdgeLoopProxy
Inherits EdgeLoop
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopProxy Interface


EdgeLoopProxy Properties

EdgeLoopProxy Properties
Summary

The properties of the EdgeLoopProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopProxy Interface > EdgeLoopProxy Properties


EdgeLoopProxy.ContainingOccurrence Property

EdgeLoopProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopProxy Interface > EdgeLoopProxy Properties > EdgeLoopProxy.ContainingOccurrence Property


EdgeLoopProxy.NativeObject Property

EdgeLoopProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As EdgeLoop**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoopProxy Interface > EdgeLoopProxy Properties > EdgeLoopProxy.NativeObject Property


EdgeLoops Interface

EdgeLoops Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EdgeLoops object is a collection of objects. See the article in the overviews section.

Class Hierarchy
Inventor::EdgeLoops
Visual Basic
Public Interface EdgeLoops
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Face.EdgeLoops

You are here: Symbol Reference > Inventor Library > Objects > EdgeLoops Interface


EdgeLoops Methods

EdgeLoops Methods
Summary

The methods of the EdgeLoops class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoops Interface > EdgeLoops Methods


EdgeLoops.Item Method

EdgeLoops.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] EdgeLoop*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoops Interface > EdgeLoops Methods > EdgeLoops.Item Method


EdgeLoops Properties

EdgeLoops Properties
Summary

The properties of the EdgeLoops class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoops Interface > EdgeLoops Properties


EdgeLoops.Count Property

EdgeLoops.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoops Interface > EdgeLoops Properties > EdgeLoops.Count Property


EdgeLoops.Type Property

EdgeLoops.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeLoops Interface > EdgeLoops Properties > EdgeLoops.Type Property


EdgeProxy Interface

EdgeProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Edge object.

Class Hierarchy
Inventor::Edge
    Inventor::EdgeProxy
Visual Basic
Public Interface EdgeProxy
Inherits Edge
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

Notes

Members through which this object may be accessed include:

CircularOccurrencePattern.AxisEntity

RectangularOccurrencePattern.RowEntity

You are here: Symbol Reference > Inventor Library > Objects > EdgeProxy Interface


EdgeProxy Properties

EdgeProxy Properties
Summary

The properties of the EdgeProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EdgeProxy Interface > EdgeProxy Properties


EdgeProxy.ContainingOccurrence Property

EdgeProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EdgeProxy Interface > EdgeProxy Properties > EdgeProxy.ContainingOccurrence Property


EdgeProxy.NativeObject Property

EdgeProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As Edge**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EdgeProxy Interface > EdgeProxy Properties > EdgeProxy.NativeObject Property


Edges Interface

Edges Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Edges object is a collection of objects. See the article in the overviews section.

Class Hierarchy
Inventor::Edges
Visual Basic
Public Interface Edges
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeLoop.Edges

Face.Edges

FaceShell.Edges

FlatPattern.GetEdgesOfType

FlatPunchResult.SketchRepresentationEdges

SurfaceBody.Edges

ThreadFeature.StartEdge

Vertex.Edges

Wire.Edges

See Also

Window Selection sample

Sketch Edit Orientation sample

Thread Feature Create sample

You are here: Symbol Reference > Inventor Library > Objects > Edges Interface


Edges Methods

Edges Methods
Summary

The methods of the Edges class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > Edges Interface > Edges Methods


Edges.Item Method

Edges.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] Edge*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
See Also

Thread Feature Create sample

Sketch Add Oriented sample

You are here: Symbol Reference > Inventor Library > Objects > Edges Interface > Edges Methods > Edges.Item Method


Edges Properties

Edges Properties
Summary

The properties of the Edges class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Edges Interface > Edges Properties


Edges.Count Property

Edges.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Edges Interface > Edges Properties > Edges.Count Property


Edges.Type Property

Edges.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Edges Interface > Edges Properties > Edges.Type Property


EdgeUse Interface

EdgeUse Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EdgeUse object. See the article in the overviews section.

Class Hierarchy
Inventor::EdgeUse
    Inventor::EdgeUseProxy
Visual Basic
Public Interface EdgeUse
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeUse.Next

EdgeUse.Partner

EdgeUse.Previous

EdgeUseProxy.NativeObject

EdgeUses.Item

You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface


EdgeUse Methods

EdgeUse Methods
Summary

The methods of the EdgeUse class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Methods


EdgeUse.GetReferenceKey Method

EdgeUse.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Methods > EdgeUse.GetReferenceKey Method


EdgeUse Properties

EdgeUse Properties
Summary

The properties of the EdgeUse class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CurveType | Gets the type of the underlying curve geometry that this EdgeUse is defined by.
Edge | Gets the that this EdgeUse references.
EdgeLoop | Gets the that contains this EdgeUse.
Evaluator | Gets the Curve2dEvaluator for this edge use.
Geometry | Property that returns the underlying geometry of the edge use.
GeometryForm | Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.
IsOpposedToEdge | Gets whether this EdgeUse is opposed to or aligned with the orientation of the referenced Edge.
IsParamReversed | Gets whether the parameterization of the geometry obtained from the Curve property is aligned or opposed to the topological sense of this EdgeUse.
Next | Gets the next in the connected list of EdgeUses in the EdgeLoop.
Parent | Property that returns the parent object from whom this object can logically be reached.
Partner | In a solid, Face objects are connected to other Face objects by virtue of sharing at least one Edge. The shared Edge is the same object. objects, however ,are unique to a particular face. The Partner property returns the corresponding EdgeUse that belongs to the connected face.
Previous | Gets the previous .
TransientKey | Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.
Type | Property returning an enum indicating this object's type.
Wire | Get the Wire containing this EdgeUse. Returns Nothing if this EdgeUse does not belong to a Wire.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties


EdgeUse.Application Property

EdgeUse.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Application Property


EdgeUse.CurveType Property

EdgeUse.CurveType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the type of the underlying curve geometry that this EdgeUse is defined by.

Visual Basic
Property CurveType() As Curve2dTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.CurveType Property


EdgeUse.Edge Property

EdgeUse.Edge Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the that this EdgeUse references.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Edge Property


EdgeUse.EdgeLoop Property

EdgeUse.EdgeLoop Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the that contains this EdgeUse.

Visual Basic
Property EdgeLoop() As EdgeLoop**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.EdgeLoop Property


EdgeUse.Evaluator Property

EdgeUse.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Curve2dEvaluator for this edge use.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Evaluator Property


EdgeUse.Geometry Property

EdgeUse.Geometry Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the underlying geometry of the edge use.

Visual Basic
Property Geometry() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Geometry Property


EdgeUse.GeometryForm Property

EdgeUse.GeometryForm Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.

Visual Basic
Property GeometryForm() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.GeometryForm Property


EdgeUse.IsOpposedToEdge Property

EdgeUse.IsOpposedToEdge Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether this EdgeUse is opposed to or aligned with the orientation of the referenced Edge.

Visual Basic
Property IsOpposedToEdge() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.IsOpposedToEdge Property


EdgeUse.IsParamReversed Property

EdgeUse.IsParamReversed Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the parameterization of the geometry obtained from the Curve property is aligned or opposed to the topological sense of this EdgeUse.

Visual Basic
Property IsParamReversed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.IsParamReversed Property


EdgeUse.Next Property

EdgeUse.Next Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the next in the connected list of EdgeUses in the EdgeLoop.

Visual Basic
Property Next() As EdgeUse**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Next Property


EdgeUse.Parent Property

EdgeUse.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Parent Property


EdgeUse.Partner Property

EdgeUse.Partner Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

In a solid, Face objects are connected to other Face objects by virtue of sharing at least one Edge. The shared Edge is the same object. objects, however ,are unique to a particular face. The Partner property returns the corresponding EdgeUse that belongs to the connected face.

Visual Basic
Property Partner() As EdgeUse**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Partner Property


EdgeUse.Previous Property

EdgeUse.Previous Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the previous .

Visual Basic
Property Previous() As EdgeUse**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Previous Property


EdgeUse.TransientKey Property

EdgeUse.TransientKey Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.

Visual Basic
Property TransientKey() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.TransientKey Property


EdgeUse.Type Property

EdgeUse.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Type Property


EdgeUse.Wire Property

EdgeUse.Wire Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Get the Wire containing this EdgeUse. Returns Nothing if this EdgeUse does not belong to a Wire.

Visual Basic
Property Wire() As Wire**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUse Interface > EdgeUse Properties > EdgeUse.Wire Property


EdgeUseDefinition Interface

EdgeUseDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FaceDefinition represents a transient definition of a Face object.

Class Hierarchy
Inventor::EdgeUseDefinition
Visual Basic
Public Interface EdgeUseDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeUseDefinitions.Add

EdgeUseDefinitions.Item

See Also

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinition Interface


EdgeUseDefinition Properties

EdgeUseDefinition Properties
Summary

The properties of the EdgeUseDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EdgeDefinition | Property that gets and set the associated EdgeDefinition object.
IsOpposedToEdge | Property that defines if the orientation of this EdgeUse is in the same direction or not relative to the associated EdgeDefinition object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinition Interface > EdgeUseDefinition Properties


EdgeUseDefinition.Application Property

EdgeUseDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinition Interface > EdgeUseDefinition Properties > EdgeUseDefinition.Application Property


EdgeUseDefinition.EdgeDefinition Property

EdgeUseDefinition.EdgeDefinition Property
Summary

Property that gets and set the associated EdgeDefinition object.

Visual Basic
Property EdgeDefinition() As EdgeDefinition*
See Also

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinition Interface > EdgeUseDefinition Properties > EdgeUseDefinition.EdgeDefinition Property


EdgeUseDefinition.IsOpposedToEdge Property

EdgeUseDefinition.IsOpposedToEdge Property
Summary

Property that defines if the orientation of this EdgeUse is in the same direction or not relative to the associated EdgeDefinition object.

Visual Basic
Property IsOpposedToEdge() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinition Interface > EdgeUseDefinition Properties > EdgeUseDefinition.IsOpposedToEdge Property


EdgeUseDefinition.Type Property

EdgeUseDefinition.Type Property
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinition Interface > EdgeUseDefinition Properties > EdgeUseDefinition.Type Property


EdgeUseDefinitions Interface

EdgeUseDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The EdgeUseDefinitions collection object provides access to existing EdgeUseDefinition objects, and allows creation of new EdgeUseDefinition objects.

Class Hierarchy
Inventor::EdgeUseDefinitions
Visual Basic
Public Interface EdgeUseDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeLoopDefinition.EdgeUseDefinitions

You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface


EdgeUseDefinitions Methods

EdgeUseDefinitions Methods
Summary

The methods of the EdgeUseDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new EdgeUseDefinition within the associated EdgeLoopDefinition.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Methods


EdgeUseDefinitions.Add Method

EdgeUseDefinitions.Add Method
Summary

Method that creates a new EdgeUseDefinition within the associated EdgeLoopDefinition.

Visual Basic
Sub Add(EdgeDefinition As EdgeDefinition, IsOpposedToEdge As VARIANT_BOOL, Result As [out, retval] EdgeUseDefinition*)
Parameters
Parameters | Description
EdgeDefinition | Input EdgeDefinition that defines the geometry for this EdgeUseDefinition.
IsOpposedToEdge | Input Boolean that indicates if the parameterization of this EdgeUseDefinition is reversed with respect to the associated EdgeDefinition object.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Methods > EdgeUseDefinitions.Add Method


EdgeUseDefinitions.Item Method

EdgeUseDefinitions.Item Method
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] EdgeUseDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Methods > EdgeUseDefinitions.Item Method


EdgeUseDefinitions Properties

EdgeUseDefinitions Properties
Summary

The properties of the EdgeUseDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Properties


EdgeUseDefinitions.Application Property

EdgeUseDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Properties > EdgeUseDefinitions.Application Property


EdgeUseDefinitions.Count Property

EdgeUseDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Properties > EdgeUseDefinitions.Count Property


EdgeUseDefinitions.Type Property

EdgeUseDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseDefinitions Interface > EdgeUseDefinitions Properties > EdgeUseDefinitions.Type Property


EdgeUseProxy Interface

EdgeUseProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EdgeUse object.

Class Hierarchy
Inventor::EdgeUse
    Inventor::EdgeUseProxy
Visual Basic
Public Interface EdgeUseProxy
Inherits EdgeUse
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > EdgeUseProxy Interface


EdgeUseProxy Properties

EdgeUseProxy Properties
Summary

The properties of the EdgeUseProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUseProxy Interface > EdgeUseProxy Properties


EdgeUseProxy.ContainingOccurrence Property

EdgeUseProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EdgeUseProxy Interface > EdgeUseProxy Properties > EdgeUseProxy.ContainingOccurrence Property


EdgeUseProxy.NativeObject Property

EdgeUseProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As EdgeUse**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EdgeUseProxy Interface > EdgeUseProxy Properties > EdgeUseProxy.NativeObject Property


EdgeUses Interface

EdgeUses Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EdgeUses object is a collection of objects. See the article in the overviews section.

Class Hierarchy
Inventor::EdgeUses
Visual Basic
Public Interface EdgeUses
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Edge.EdgeUses

EdgeLoop.EdgeUses

Wire.EdgeUses

You are here: Symbol Reference > Inventor Library > Objects > EdgeUses Interface


EdgeUses Methods

EdgeUses Methods
Summary

The methods of the EdgeUses class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUses Interface > EdgeUses Methods


EdgeUses.Item Method

EdgeUses.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] EdgeUse*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUses Interface > EdgeUses Methods > EdgeUses.Item Method


EdgeUses Properties

EdgeUses Properties
Summary

The properties of the EdgeUses class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EdgeUses Interface > EdgeUses Properties


EdgeUses.Count Property

EdgeUses.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUses Interface > EdgeUses Properties > EdgeUses.Count Property


EdgeUses.Type Property

EdgeUses.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EdgeUses Interface > EdgeUses Properties > EdgeUses.Type Property


EdgeWidthExtent Interface

EdgeWidthExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The EdgeWidthExtent is used by sheet metal features when the width of the feature is defined by an edge.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::EdgeWidthExtent
Visual Basic
Public Interface EdgeWidthExtent
Inherits PartFeatureExtent
Remarks

The EdgeWidthExtent object is obtained from an existing sheet metal feature object whose width is defined as an 'Edge' extent. This object doesn't perform any function since the edge(s) that define the width are available from the feature and there are no other inputs needed for this extent type.

You are here: Symbol Reference > Inventor Library > Objects > EdgeWidthExtent Interface


EdgeWidthExtent Properties

EdgeWidthExtent Properties
Summary

The properties of the EdgeWidthExtent class are listed here.

Properties
Name | Description
Edge | Property that gets the Edge object that the width is defined relative to.
You are here: Symbol Reference > Inventor Library > Objects > EdgeWidthExtent Interface > EdgeWidthExtent Properties


EdgeWidthExtent.Edge Property

EdgeWidthExtent.Edge Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the Edge object that the width is defined relative to.

Visual Basic
Property Edge() As Edge**
Remarks

This is the same edge that was selected to create the feature. When querying an existing feature this edge is not available because it was consumed when the sheet metal feature was created. This property returns Nothing in the case where the edge no longer exists in the model. Because of this, the end-of-part marker must be placed above the feature to allow access this edge.

You are here: Symbol Reference > Inventor Library > Objects > EdgeWidthExtent Interface > EdgeWidthExtent Properties > EdgeWidthExtent.Edge Property


EllipseFull Interface

EllipseFull Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EllipseFull object. The object created is a transient mathematical object and is not displayed graphically

Class Hierarchy
Inventor::EllipseFull
Visual Basic
Public Interface EllipseFull
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchEllipse3D.Geometry

TransientGeometry.CreateEllipseFull

CurveGraphics.Curve

Edge.Geometry

You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface


EllipseFull Methods

EllipseFull Methods
Summary

The methods of the EllipseFull class are listed here.

Methods
Methods
Name | Description
GetEllipseFullData | Get the data defining this ellipse.
PutEllipseFullData | Method that sets the data defining this ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Methods


EllipseFull.GetEllipseFullData Method

EllipseFull.GetEllipseFullData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this ellipse.

Visual Basic
Sub GetEllipseFullData(ByRef Center As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MinorMajorRatio As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the entity's center.
AxisVector | Input/output Double that specifies axis vector.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Output Double that specifies the ratio of the minor and major axes of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Methods > EllipseFull.GetEllipseFullData Method


EllipseFull.PutEllipseFullData Method

EllipseFull.PutEllipseFullData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this ellipse.

Visual Basic
Sub PutEllipseFullData(ByRef Center As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), MinorMajorRatio As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the entity's center.
AxisVector | Input/output Double that specifies axis vector.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Methods > EllipseFull.PutEllipseFullData Method


EllipseFull Properties

EllipseFull Properties
Summary

The properties of the EllipseFull class are listed here.

Properties
Name | Description
Center | Specifies the center of the ellipse.
Evaluator | Gets the CurveEvaluator for this ellipse.
MajorAxisVector | Specifies the direction of the major axis of the ellipse.
MinorMajorRatio | Specifies the ratio of the minor and major axes of the ellipse.
Normal | Specifies the axis of the ellipse. The axis extends out of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Properties


EllipseFull.Center Property

EllipseFull.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the center of the ellipse.

Visual Basic
Property Center() As Point*
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Properties > EllipseFull.Center Property


EllipseFull.Evaluator Property

EllipseFull.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the CurveEvaluator for this ellipse.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Properties > EllipseFull.Evaluator Property


EllipseFull.MajorAxisVector Property

EllipseFull.MajorAxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the major axis of the ellipse.

Visual Basic
Property MajorAxisVector() As Vector*
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Properties > EllipseFull.MajorAxisVector Property


EllipseFull.MinorMajorRatio Property

EllipseFull.MinorMajorRatio Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the ratio of the minor and major axes of the ellipse.

Visual Basic
Property MinorMajorRatio() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Properties > EllipseFull.MinorMajorRatio Property


EllipseFull.Normal Property

EllipseFull.Normal Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the axis of the ellipse. The axis extends out of the ellipse.

Visual Basic
Property Normal() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull Interface > EllipseFull Properties > EllipseFull.Normal Property


EllipseFull2d Interface

EllipseFull2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EllipseFull2d object. The object is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::EllipseFull2d
Visual Basic
Public Interface EllipseFull2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchEllipse.Geometry

TransientGeometry.CreateEllipseFull2d

ProfileEntity.Curve

You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface


EllipseFull2d Methods

EllipseFull2d Methods
Summary

The methods of the EllipseFull2d class are listed here.

Methods
Methods
Name | Description
GetEllipseFullData | Get the data defining this ellipse.
PutEllipseFullData | Method that sets the data defining this ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Methods


EllipseFull2d.GetEllipseFullData Method

EllipseFull2d.GetEllipseFullData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this ellipse.

Visual Basic
Sub GetEllipseFullData(ByRef Center As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MinorMajorRatio As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the entity's center.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Output Double that specifies the ratio of the minor and major axes of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Methods > EllipseFull2d.GetEllipseFullData Method


EllipseFull2d.PutEllipseFullData Method

EllipseFull2d.PutEllipseFullData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this ellipse.

Visual Basic
Sub PutEllipseFullData(ByRef Center As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), MinorMajorRatio As double)
Parameters
Parameters | Description
Center | Input/output Double that specifies the Ellipse's center.
MajorAxis | Input/output Double that specifies the Ellipse's major axis.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the Ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Methods > EllipseFull2d.PutEllipseFullData Method


EllipseFull2d Properties

EllipseFull2d Properties
Summary

The properties of the EllipseFull2d class are listed here.

Properties
Name | Description
Center | Specifies the center of the ellipse.
Evaluator | Gets the Curve2dEvaluator for this ellipse.
MajorAxisVector | Specifies the direction of the major axis of the ellipse.
MinorMajorRatio | Specifies the ratio of the minor and major axes of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Properties


EllipseFull2d.Center Property

EllipseFull2d.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the center of the ellipse.

Visual Basic
Property Center() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Properties > EllipseFull2d.Center Property


EllipseFull2d.Evaluator Property

EllipseFull2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Curve2dEvaluator for this ellipse.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Properties > EllipseFull2d.Evaluator Property


EllipseFull2d.MajorAxisVector Property

EllipseFull2d.MajorAxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the major axis of the ellipse.

Visual Basic
Property MajorAxisVector() As Vector2d*
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Properties > EllipseFull2d.MajorAxisVector Property


EllipseFull2d.MinorMajorRatio Property

EllipseFull2d.MinorMajorRatio Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the ratio of the minor and major axes of the ellipse.

Visual Basic
Property MinorMajorRatio() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipseFull2d Interface > EllipseFull2d Properties > EllipseFull2d.MinorMajorRatio Property


EllipseRadiusDimConstraint Interface

EllipseRadiusDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The EllipseRadiusDimConstraint object represents a constraint that controls either the major or minor radius of an ellipse.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::EllipseRadiusDimConstraint
        Inventor::EllipseRadiusDimConstraintProxy
Visual Basic
Public Interface EllipseRadiusDimConstraint
Inherits DimensionConstraint
Remarks

The constraint that controls either the major or minor radius of an ellipse.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddEllipseRadius

EllipseRadiusDimConstraintProxy.NativeObject

See Also

Create sketch elliptical arc sample

You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraint Interface


EllipseRadiusDimConstraint Properties

EllipseRadiusDimConstraint Properties
Summary

The properties of the EllipseRadiusDimConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns the ellipse or elliptical arc being constrained.
MajorRadius | Property that returns whether the proxy constraint is controlling the major or minor radius of the ellipse. Returns true if it is the major radius.
You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraint Interface > EllipseRadiusDimConstraint Properties


EllipseRadiusDimConstraint.Entity Property

EllipseRadiusDimConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ellipse or elliptical arc being constrained.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraint Interface > EllipseRadiusDimConstraint Properties > EllipseRadiusDimConstraint.Entity Property


EllipseRadiusDimConstraint.MajorRadius Property

EllipseRadiusDimConstraint.MajorRadius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns whether the proxy constraint is controlling the major or minor radius of the ellipse. Returns true if it is the major radius.

Visual Basic
Property MajorRadius() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraint Interface > EllipseRadiusDimConstraint Properties > EllipseRadiusDimConstraint.MajorRadius Property


EllipseRadiusDimConstraintProxy Interface

EllipseRadiusDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EllipseRadiusDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::EllipseRadiusDimConstraint
        Inventor::EllipseRadiusDimConstraintProxy
Visual Basic
Public Interface EllipseRadiusDimConstraintProxy
Inherits EllipseRadiusDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraintProxy Interface


EllipseRadiusDimConstraintProxy Properties

EllipseRadiusDimConstraintProxy Properties
Summary

The properties of the EllipseRadiusDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraintProxy Interface > EllipseRadiusDimConstraintProxy Properties


EllipseRadiusDimConstraintProxy.ContainingOccurrence Property

EllipseRadiusDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraintProxy Interface > EllipseRadiusDimConstraintProxy Properties > EllipseRadiusDimConstraintProxy.ContainingOccurrence Property


EllipseRadiusDimConstraintProxy.NativeObject Property

EllipseRadiusDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As EllipseRadiusDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EllipseRadiusDimConstraintProxy Interface > EllipseRadiusDimConstraintProxy Properties > EllipseRadiusDimConstraintProxy.NativeObject Property


EllipticalArc Interface

EllipticalArc Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

The EllipticalArc object. The object created is a transient mathematical object and is not displayed graphically

Class Hierarchy
Inventor::EllipticalArc
Visual Basic
Public Interface EllipticalArc
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchEllipticalArc3D.Geometry

TransientGeometry.CreateEllipticalArc

CurveGraphics.Curve

Edge.Geometry

You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface


EllipticalArc Methods

EllipticalArc Methods
Summary

The methods of the EllipticalArc class are listed here.

Methods
Methods
Name | Description
GetEllipticalArcData | Get the data defining this elliptical arc.
PutEllipticalArcData | Method that sets the data defining this elliptical arc.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Methods


EllipticalArc.GetEllipticalArcData Method

EllipticalArc.GetEllipticalArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Get the data defining this elliptical arc.

Visual Basic
Sub GetEllipticalArcData(ByRef Center As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MinorAxis As SAFEARRAY(double), ByRef MajorRadius As double, ByRef MinorRadius As double, ByRef StartAngle As double, ByRef SweepAngle As double)
Parameters
Parameters
Description
Center
Input/output Double that specifies the elliptical arc's center.
MajorAxis
Input/output Double that specifies major axis.
MinorAxis
Input/output Double that specifies minor axis.
MajorRadius
Output Double that specifies major radius.
MinorRadius
Output Double that specifies the minor radius.
StartAngle
Output Double that specifies the elliptical arc's start angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
SweepAngle
Output Double that specifies the elliptical arc's sweep angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Methods > EllipticalArc.GetEllipticalArcData Method


EllipticalArc.PutEllipticalArcData Method

EllipticalArc.PutEllipticalArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the data defining this elliptical arc.

Visual Basic
Sub PutEllipticalArcData(ByRef Center As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MinorAxis As SAFEARRAY(double), MajorRadius As double, MinorRadius As double, StartAngle As double, SweepAngle As double)
Parameters
Parameters
Description
Center
Input/output Double that specifies the elliptical arc's center.
MajorAxis
Input/output Double that specifies major axis.
MinorAxis
Input/output Double that specifies minor axis.
MajorRadius
Input Double that specifies major radius.
MinorRadius
Input Double that specifies the minor radius.
StartAngle
Input Double that specifies the elliptical arc's start angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
SweepAngle
Input Double that specifies the elliptical arc's sweep angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Methods > EllipticalArc.PutEllipticalArcData Method


EllipticalArc Properties

EllipticalArc Properties
Summary

The properties of the EllipticalArc class are listed here.

Properties
Name | Description
Center | Specifies the center of the elliptical arc.
EndPoint | Gets the end point for the arc.
Evaluator | Gets the CurveEvaluator for the arc.
MajorAxis | Specifies the direction of the major axis of the elliptical arc.
MajorRadius | Specifies the major radius of the elliptical arc.
MinorAxis | Specifies the direction of the minor axis of the elliptical arc.
MinorRadius | Specifies the minor radius of the elliptical arc.
StartAngle | Specifies start angle of the elliptical arc. The start angle is measured from the major axis vector using the right-hand rule about the axis vector.
StartPoint | Gets the start point for the arc.
SweepAngle | Specifies the sweep angle from the start angle in a direction defined using the right-hand rule about the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties


EllipticalArc.Center Property

EllipticalArc.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the center of the elliptical arc.

Visual Basic
Property Center() As Point*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.Center Property


EllipticalArc.EndPoint Property

EllipticalArc.EndPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the end point for the arc.

Visual Basic
Property EndPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.EndPoint Property


EllipticalArc.Evaluator Property

EllipticalArc.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the CurveEvaluator for the arc.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.Evaluator Property


EllipticalArc.MajorAxis Property

EllipticalArc.MajorAxis Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the direction of the major axis of the elliptical arc.

Visual Basic
Property MajorAxis() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.MajorAxis Property


EllipticalArc.MajorRadius Property

EllipticalArc.MajorRadius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the major radius of the elliptical arc.

Visual Basic
Property MajorRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.MajorRadius Property


EllipticalArc.MinorAxis Property

EllipticalArc.MinorAxis Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the direction of the minor axis of the elliptical arc.

Visual Basic
Property MinorAxis() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.MinorAxis Property


EllipticalArc.MinorRadius Property

EllipticalArc.MinorRadius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the minor radius of the elliptical arc.

Visual Basic
Property MinorRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.MinorRadius Property


EllipticalArc.StartAngle Property

EllipticalArc.StartAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies start angle of the elliptical arc. The start angle is measured from the major axis vector using the right-hand rule about the axis vector.

Visual Basic
Property StartAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.StartAngle Property


EllipticalArc.StartPoint Property

EllipticalArc.StartPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the start point for the arc.

Visual Basic
Property StartPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.StartPoint Property


EllipticalArc.SweepAngle Property

EllipticalArc.SweepAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the sweep angle from the start angle in a direction defined using the right-hand rule about the axis vector.

Visual Basic
Property SweepAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc Interface > EllipticalArc Properties > EllipticalArc.SweepAngle Property


EllipticalArc2d Interface

EllipticalArc2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The EllipticalArc2d object. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::EllipticalArc2d
Visual Basic
Public Interface EllipticalArc2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchEllipticalArc.Geometry

TransientGeometry.CreateEllipticalArc2d

You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface


EllipticalArc2d Methods

EllipticalArc2d Methods
Summary

The methods of the EllipticalArc2d class are listed here.

Methods
Methods
Name | Description
GetEllipticalArcData | Get the data defining this elliptical arc.
PutEllipticalArcData | Method that sets the data defining this elliptical arc.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Methods


EllipticalArc2d.GetEllipticalArcData Method

EllipticalArc2d.GetEllipticalArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Get the data defining this elliptical arc.

Visual Basic
Sub GetEllipticalArcData(ByRef Center As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MajorRadius As double, ByRef MinorRadius As double, ByRef StartAngle As double, ByRef SweepAngle As double)
Parameters
Parameters
Description
Center
Input/output Double that specifies the elliptical arc's center.
MajorAxis
Input/output Double that specifies major axis.
MajorRadius
Output Double that specifies major radius.
MinorRadius
Output Double that specifies the minor radius.
StartAngle
Output Double that specifies the elliptical arc's start angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
SweepAngle
Output Double that specifies the elliptical arc's sweep angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Methods > EllipticalArc2d.GetEllipticalArcData Method


EllipticalArc2d.PutEllipticalArcData Method

EllipticalArc2d.PutEllipticalArcData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the data defining this elliptical arc.

Visual Basic
Sub PutEllipticalArcData(ByRef Center As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), MajorRadius As double, MinorRadius As double, StartAngle As double, SweepAngle As double)
Parameters
Parameters
Description
Center
Input/output Double that specifies the elliptical arc's center.
MajorAxis
Input/output Double that specifies major axis.
MajorRadius
Input Double that specifies major radius.
MinorRadius
Input Double that specifies the minor radius.
StartAngle
Input Double that specifies the elliptical arc's start angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
SweepAngle
Input Double that specifies the elliptical arc's sweep angle. This angle is an elliptical angle, not a circular angle, unlike the user interface which uses circular angles in all cases.
To convert from an elliptical angle to a circular angle CircAngle = atn( tan(EllipAngle) * MinorRadius / MajorRadius )
To convert from a circular angle to an elliptical angle EllipAngle = atn( tan(CircAngle) * MajorRadius / MinorRadius )
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Methods > EllipticalArc2d.PutEllipticalArcData Method


EllipticalArc2d Properties

EllipticalArc2d Properties
Summary

The properties of the EllipticalArc2d class are listed here.

Properties
Name | Description
Center | Specifies the center of the elliptical arc.
EndPoint | Gets the end point for the arc.
Evaluator | Gets the Curve2DEvaluator for the arc.
MajorAxis | Specifies the direction of the major axis of the elliptical arc.
MajorRadius | Specifies the major radius of the elliptical arc.
MinorRadius | Specifies the minor radius of the elliptical arc.
StartAngle | Specifies start angle of the elliptical arc. The start angle is measured from the major axis vector.
StartPoint | Gets the start point for the arc.
SweepAngle | Specifies the sweep angle from the start angle in a counterclockwise direction.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties


EllipticalArc2d.Center Property

EllipticalArc2d.Center Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the center of the elliptical arc.

Visual Basic
Property Center() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.Center Property


EllipticalArc2d.EndPoint Property

EllipticalArc2d.EndPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the end point for the arc.

Visual Basic
Property EndPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.EndPoint Property


EllipticalArc2d.Evaluator Property

EllipticalArc2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the Curve2DEvaluator for the arc.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.Evaluator Property


EllipticalArc2d.MajorAxis Property

EllipticalArc2d.MajorAxis Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the direction of the major axis of the elliptical arc.

Visual Basic
Property MajorAxis() As UnitVector2d*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.MajorAxis Property


EllipticalArc2d.MajorRadius Property

EllipticalArc2d.MajorRadius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the major radius of the elliptical arc.

Visual Basic
Property MajorRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.MajorRadius Property


EllipticalArc2d.MinorRadius Property

EllipticalArc2d.MinorRadius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the minor radius of the elliptical arc.

Visual Basic
Property MinorRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.MinorRadius Property


EllipticalArc2d.StartAngle Property

EllipticalArc2d.StartAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies start angle of the elliptical arc. The start angle is measured from the major axis vector.

Visual Basic
Property StartAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.StartAngle Property


EllipticalArc2d.StartPoint Property

EllipticalArc2d.StartPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the start point for the arc.

Visual Basic
Property StartPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.StartPoint Property


EllipticalArc2d.SweepAngle Property

EllipticalArc2d.SweepAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the sweep angle from the start angle in a counterclockwise direction.

Visual Basic
Property SweepAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalArc2d Interface > EllipticalArc2d Properties > EllipticalArc2d.SweepAngle Property


EllipticalCone Interface

EllipticalCone Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EllipticalCone object. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::EllipticalCone
Visual Basic
Public Interface EllipticalCone
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateEllipticalCone

Face.Geometry

FaceDefinition.SurfaceGeometry

You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface


EllipticalCone Methods

EllipticalCone Methods
Summary

The methods of the EllipticalCone class are listed here.

Methods
Methods
Name | Description
GetEllipticalConeData | Get the data defining this elliptical cone.
PutEllipticalConeData | Method that sets the data defining this elliptical cone.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Methods


EllipticalCone.GetEllipticalConeData Method

EllipticalCone.GetEllipticalConeData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this elliptical cone.

Visual Basic
Sub GetEllipticalConeData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MinorMajorRatio As double, ByRef HalfAngle As double, ByRef IsExpanding As VARIANT_BOOL)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies base point.
AxisVector | Input/output Double that specifies axis vector.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Output Double that specifies the ratio of the minor and major axes of the elliptical cone.
HalfAngle | Output Double that specifies the half-angle value for the elliptical cone.
IsExpanding | Output Boolean that specifies whether the radius of the cone is expanding or not, in the direction of the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Methods > EllipticalCone.GetEllipticalConeData Method


EllipticalCone.PutEllipticalConeData Method

EllipticalCone.PutEllipticalConeData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this elliptical cone.

Visual Basic
Sub PutEllipticalConeData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), MinorMajorRatio As double, HalfAngle As double, IsExpanding As VARIANT_BOOL)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies base point.
AxisVector | Input/output Double that specifies axis vector.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the elliptical cone.
HalfAngle | Input Double that specifies the half-angle value for the elliptical cone.
IsExpanding | Input Boolean that specifies whether the radius of the cone is expanding or not, in the direction of the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Methods > EllipticalCone.PutEllipticalConeData Method


EllipticalCone Properties

EllipticalCone Properties
Summary

The properties of the EllipticalCone class are listed here.

Properties
Name | Description
AxisVector | Specifies the direction of the axis of the elliptical cone.
BasePoint | Specifies the base of the elliptical cone.
Evaluator | Gets the surface evaluator for this elliptical cone.
HalfAngle | Specifies the taper angle of the elliptical cone. This is the angle measured from the axis to the side of the elliptical cone.
IsExpanding | Specifies whether the taper of the elliptical cone is expanding outwards or inwards in the direction of the axis vector. If True and the HalfAngle is positive, then the elliptical cone is expanding outward along the axis vector.
MajorAxisVector | Specifies the direction of the major axis of the elliptical cone.
MinorMajorRatio | Specifies the ratio of the minor and major axes of the elliptical cone.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties


EllipticalCone.AxisVector Property

EllipticalCone.AxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the axis of the elliptical cone.

Visual Basic
Property AxisVector() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.AxisVector Property


EllipticalCone.BasePoint Property

EllipticalCone.BasePoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the base of the elliptical cone.

Visual Basic
Property BasePoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.BasePoint Property


EllipticalCone.Evaluator Property

EllipticalCone.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this elliptical cone.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.Evaluator Property


EllipticalCone.HalfAngle Property

EllipticalCone.HalfAngle Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the taper angle of the elliptical cone. This is the angle measured from the axis to the side of the elliptical cone.

Visual Basic
Property HalfAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.HalfAngle Property


EllipticalCone.IsExpanding Property

EllipticalCone.IsExpanding Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies whether the taper of the elliptical cone is expanding outwards or inwards in the direction of the axis vector. If True and the HalfAngle is positive, then the elliptical cone is expanding outward along the axis vector.

Visual Basic
Property IsExpanding() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.IsExpanding Property


EllipticalCone.MajorAxisVector Property

EllipticalCone.MajorAxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the major axis of the elliptical cone.

Visual Basic
Property MajorAxisVector() As Vector*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.MajorAxisVector Property


EllipticalCone.MinorMajorRatio Property

EllipticalCone.MinorMajorRatio Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the ratio of the minor and major axes of the elliptical cone.

Visual Basic
Property MinorMajorRatio() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCone Interface > EllipticalCone Properties > EllipticalCone.MinorMajorRatio Property


EllipticalCylinder Interface

EllipticalCylinder Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The EllipticalCylinder object. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::EllipticalCylinder
Visual Basic
Public Interface EllipticalCylinder
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateEllipticalCylinder

Face.Geometry

FaceDefinition.SurfaceGeometry

You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface


EllipticalCylinder Methods

EllipticalCylinder Methods
Summary

The methods of the EllipticalCylinder class are listed here.

Methods
Methods
Name | Description
GetEllipticalCylinderData | Get the data defining this elliptical cylinder.
PutEllipticalCylinderData | Method that sets the data defining this elliptical cylinder.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Methods


EllipticalCylinder.GetEllipticalCylinderData Method

EllipticalCylinder.GetEllipticalCylinderData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this elliptical cylinder.

Visual Basic
Sub GetEllipticalCylinderData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), ByRef MinorMajorRatio As double)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies base point.
AxisVector | Input/output Double that specifies axis vector.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Output Double that specifies the ratio of the minor and major axes of the elliptical cylinder.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Methods > EllipticalCylinder.GetEllipticalCylinderData Method


EllipticalCylinder.PutEllipticalCylinderData Method

EllipticalCylinder.PutEllipticalCylinderData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this elliptical cylinder.

Visual Basic
Sub PutEllipticalCylinderData(ByRef BasePoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorAxis As SAFEARRAY(double), MinorMajorRatio As double)
Parameters
Parameters | Description
BasePoint | Input/output Double that specifies base point.
AxisVector | Input/output Double that specifies axis vector.
MajorAxis | Input/output Double that specifies major axis.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the elliptical cylinder.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Methods > EllipticalCylinder.PutEllipticalCylinderData Method


EllipticalCylinder Properties

EllipticalCylinder Properties
Summary

The properties of the EllipticalCylinder class are listed here.

Properties
Name | Description
AxisVector | Specifies the direction of the axis of the elliptical cylinder.
BasePoint | Specifies the base of the elliptical cylinder.
Evaluator | Gets the surface evaluator for this elliptical cylinder.
MajorAxisVector | Specifies the direction of the major axis of the elliptical cylinder.
MinorMajorRatio | Specifies the ratio of the minor and major axes of the elliptical cylinder.
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Properties


EllipticalCylinder.AxisVector Property

EllipticalCylinder.AxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the axis of the elliptical cylinder.

Visual Basic
Property AxisVector() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Properties > EllipticalCylinder.AxisVector Property


EllipticalCylinder.BasePoint Property

EllipticalCylinder.BasePoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the base of the elliptical cylinder.

Visual Basic
Property BasePoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Properties > EllipticalCylinder.BasePoint Property


EllipticalCylinder.Evaluator Property

EllipticalCylinder.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this elliptical cylinder.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Properties > EllipticalCylinder.Evaluator Property


EllipticalCylinder.MajorAxisVector Property

EllipticalCylinder.MajorAxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the major axis of the elliptical cylinder.

Visual Basic
Property MajorAxisVector() As Vector*
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Properties > EllipticalCylinder.MajorAxisVector Property


EllipticalCylinder.MinorMajorRatio Property

EllipticalCylinder.MinorMajorRatio Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the ratio of the minor and major axes of the elliptical cylinder.

Visual Basic
Property MinorMajorRatio() As double
You are here: Symbol Reference > Inventor Library > Objects > EllipticalCylinder Interface > EllipticalCylinder Properties > EllipticalCylinder.MinorMajorRatio Property


EmbossFeature Interface

EmbossFeature Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The EmbossFeature object represents an emboss feature on a part.

Class Hierarchy
Inventor::PartFeature
    Inventor::EmbossFeature
        Inventor::EmbossFeatureProxy
Visual Basic
Public Interface EmbossFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

EmbossFeatureProxy.NativeObject

EmbossFeatures.AddEmbossEngraveFromPlane

EmbossFeatures.AddEmbossFromFace

EmbossFeatures.AddEngraveFromFace

EmbossFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface


EmbossFeature Methods

EmbossFeature Methods
Summary

The methods of the EmbossFeature class are listed here.

Methods
Methods
Name | Description
SetEmbossEngraveFromPlane | Method that redefines the emboss feature by embossing and/or engraving a profile on one or more faces in the model.
SetEmbossFromFace | Method that redefines the emboss feature by embossing a profile on one or more faces in the model.
SetEngraveFromFace | Method that redefines the emboss feature by engraving a profile on one or more faces in the model.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Methods


EmbossFeature.SetEmbossEngraveFromPlane Method

EmbossFeature.SetEmbossEngraveFromPlane Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the emboss feature by embossing and/or engraving a profile on one or more faces in the model.

Visual Basic
Sub SetEmbossEngraveFromPlane(Taper As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Taper | Input Variant that defines the taper angle of the emboss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates on which side of the sketch plane the emboss feature should be placed. Valid input is one of the constants in PartFeatureExtentDirectionEnum: kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection. The value kPositiveExtentDirection defines the emboss direction to be in the same direction as the normal of the sketch plane that contains the profile to be embossed.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Methods > EmbossFeature.SetEmbossEngraveFromPlane Method


EmbossFeature.SetEmbossFromFace Method

EmbossFeature.SetEmbossFromFace Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the emboss feature by embossing a profile on one or more faces in the model.

Visual Basic
Sub SetEmbossFromFace(Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef WrapFace As [optional] VARIANT)
Parameters
Parameters | Description
Distance | Input Variant that defines the depth of the emboss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates on which side of the sketch plane the emboss feature should be placed. Valid input is either kPositiveExtentDirection or kNegativeExtentDirection constant value in PartFeatureExtentDirectionEnum. The value kPositiveExtentDirection defines the projection direction of the profile to be in the same direction as the normal of the sketch plane that contains the profile to be embossed. If kSymmetricExtentDirection is specified, then the emboss feature will fail to be redefined.
WrapFace | Optional Input Variant that specifies the face around which the emboss feature should be wrapped. The valid input is a Face object. This argument can be used to specify a curved face around which the emboss feature should be wrapped. The face can only be planar or conical, not a spline. If the emboss profile is large relative to the amount of curvature, the embossed or engraved area distorts slightly as it projects to the curved face. The wrap stops when a perpendicular face is encountered. If this argument is not specified, then it implies that the emboss feature should not be wrapped around any face, but created as a result of straight projection onto the face.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Methods > EmbossFeature.SetEmbossFromFace Method


EmbossFeature.SetEngraveFromFace Method

EmbossFeature.SetEngraveFromFace Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the emboss feature by engraving a profile on one or more faces in the model.

Visual Basic
Sub SetEngraveFromFace(Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef WrapFace As [optional] VARIANT)
Parameters
Parameters | Description
Distance | Input Variant that defines the depth of the emboss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates on which side of the sketch plane the emboss feature should be placed. Valid input is either kPositiveExtentDirection or kNegativeExtentDirection constant value in PartFeatureExtentDirectionEnum. The value kPositiveExtentDirection defines the projection direction of the profile to be in the same direction as the normal of the sketch plane that contains the profile to be embossed. If kSymmetricExtentDirection is specified, then the emboss feature will fail to be redefined.
WrapFace | Optional Input Variant that specifies the face around which the emboss feature should be wrapped. The valid input is a Face object. This argument can be used to specify a curved face around which the emboss feature should be wrapped. The face can only be planar or conical, not a spline. If the emboss profile is large relative to the amount of curvature, the embossed or engraved area distorts slightly as it projects to the curved face. The wrap stops when a perpendicular face is encountered. If this argument is not specified, then it implies that the emboss feature should not be wrapped around any face, but created as a result of straight projection onto the face.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Methods > EmbossFeature.SetEngraveFromFace Method


EmbossFeature Properties

EmbossFeature Properties
Summary

The properties of the EmbossFeature class are listed here.

Properties
Name | Description
Depth | Property returns the parameter controlling the depth of the emboss feature.
Direction | Property gets and sets the direction of the emboss feature relative to the sketch plane that contains the emboss profile. This direction indicates on which side of the profile plane the emboss feature lies.
EmbossType | Property that returns the type of emboss feature.
Profile | Property that gets and sets the Profile object that defines the shape of the emboss.
Taper | Property that returns the parameter controlling the taper angle of the emboss feature.
TopFaceColor | Property that gets and sets the render style for the top face of the emboss feature.
WrapFace | Property that gets and sets the face around which the emboss feature is wrapped.
WrapToFace | Property that returns a Boolean indicating if the emboss feature is wrapped around a face.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties


EmbossFeature.Depth Property

EmbossFeature.Depth Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returns the parameter controlling the depth of the emboss feature.

Visual Basic
Property Depth() As Parameter**
Remarks

This property is only applicable if the type of emboss feature is an emboss or engrave from face which will be indicated by the EmbossType property returning either kEmbossFromFace or kEngraveFromFace. In this case, the value of the parameter returned by this property will correspond to the depth of the emboss feature. The value of this parameter can also be edited to specify a new depth for the emboss. This property is not applicable if the type of emboss feature is an emboss and/or engrave from plane which will be indicated by the EmbossType property returning kEmbossEngraveFromPlane. In this case, this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.Depth Property


EmbossFeature.Direction Property

EmbossFeature.Direction Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property gets and sets the direction of the emboss feature relative to the sketch plane that contains the emboss profile. This direction indicates on which side of the profile plane the emboss feature lies.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
Remarks

This property can also be set to specify a new direction for the emboss feature.

If the type of emboss feature is an emboss or engrave from face which will be indicated by the EmbossType property returning either kEmbossFromFace or kEngraveFromFace, then the valid input is either kPositiveExtentDirection or kNegativeExtentDirection constant value in PartFeatureExtentDirectionEnum. The value kPositiveExtentDirection defines the projection direction of the profile to be in the same direction as the normal of the sketch plane that contains the profile to be embossed. If kSymmetricExtentDirection is specified, then the creation of the emboss feature will fail.

If the type of emboss feature is an emboss and/or engrave from plane which will be indicated by the EmbossType property returning kEmbossEngraveFromPlane, then the valid input is any one of the constants in PartFeatureExtentDirectionEnum: kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.Direction Property


EmbossFeature.EmbossType Property

EmbossFeature.EmbossType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the type of emboss feature.

Visual Basic
Property EmbossType() As EmbossTypeEnum*
Remarks

The valid return values are one of the constants in EmbossTypeEnum: kEmbossFromFace, kEngraveFromFace and kEmbossEngraveFromPlane.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.EmbossType Property


EmbossFeature.Profile Property

EmbossFeature.Profile Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the Profile object that defines the shape of the emboss.

Visual Basic
Property Profile() As Profile*
Remarks

This property can be set to use a new profile with the restriction that the new profile must belong to the same sketch as the currently defined profile. If the specified profile does not belong to the same sketch as the currently defined profile, then setting this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.Profile Property


EmbossFeature.Taper Property

EmbossFeature.Taper Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parameter controlling the taper angle of the emboss feature.

Visual Basic
Property Taper() As Parameter**
Remarks

This property is only applicable if the type of emboss feature is an emboss and/or engrave from plane which will be indicated by the EmbossType property returning kEmbossEngraveFromPlane. In this case, the value of the parameter returned by this property will correspond to the taper angle of the emboss feature. The value of this parameter can also be edited to specify a new taper angle for the emboss. This property is not applicable if the type of emboss feature is an emboss or engrave from face which will be indicated by the EmbossType property returning either kEmbossFromFace or kEngraveFromFace. In this case, this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.Taper Property


EmbossFeature.TopFaceColor Property

EmbossFeature.TopFaceColor Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the render style for the top face of the emboss feature.

Visual Basic
Property TopFaceColor() As RenderStyle*
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.TopFaceColor Property


EmbossFeature.WrapFace Property

EmbossFeature.WrapFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the face around which the emboss feature is wrapped.

Visual Basic
Property WrapFace() As Face*
Remarks

This property is only applicable if the type of emboss feature is an emboss or engrave from face which will be indicated by the EmbossType property returning either kEmbossFromFace or kEngraveFromFace. In this case, if the emboss feature is wrapped around a face as indicated by the WrapToFace property returning True, then this property will return that face. If the emboss feature is not wrapped around any face but created as a result of straight projection onto the face as indicated by the WrapToFace property returning False, then this property will return Nothing.

This property can also be set to a new curved face around which the emboss feature should be wrapped. The face can only be planar or conical, not a spline. If the emboss profile is large relative to the amount of curvature, the embossed or engraved area distorts slightly as it projects to the curved face. The wrap stops when a perpendicular face is encountered.

This property is not applicable if the type of emboss feature is an emboss and/or engrave from plane which will be indicated by the EmbossType property returning kEmbossEngraveFromPlane. In this case, this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.WrapFace Property


EmbossFeature.WrapToFace Property

EmbossFeature.WrapToFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns a Boolean indicating if the emboss feature is wrapped around a face.

Visual Basic
Property WrapToFace() As VARIANT_BOOL*
Remarks

A value of True indicates that the emboss feature is wrapped around a face which also implies that the type of emboss feature is an emboss or engrave from face as indicated by the EmbossType property returning either kEmbossFromFace or kEngraveFromFace. A value of False indicates one of two possible cases:

  • The type of emboss feature is an emboss and/or engrave from plane which will be indicated by the EmbossType property returning kEmbossEngraveFromPlane in which case the emboss feature cannot be wrapped around any face.
  • The type of emboss feature is an emboss or engrave from face as indicated by the EmbossType property returning either kEmbossFromFace or kEngraveFromFace but, the emboss feature is not specified to be wrapped around a face but created as a result of straight projection onto the face.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeature Interface > EmbossFeature Properties > EmbossFeature.WrapToFace Property


EmbossFeatureProxy Interface

EmbossFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EmbossFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::EmbossFeature
        Inventor::EmbossFeatureProxy
Visual Basic
Public Interface EmbossFeatureProxy
Inherits EmbossFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatureProxy Interface


EmbossFeatureProxy Properties

EmbossFeatureProxy Properties
Summary

The properties of the EmbossFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatureProxy Interface > EmbossFeatureProxy Properties


EmbossFeatureProxy.ContainingOccurrence Property

EmbossFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatureProxy Interface > EmbossFeatureProxy Properties > EmbossFeatureProxy.ContainingOccurrence Property


EmbossFeatureProxy.NativeObject Property

EmbossFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As EmbossFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatureProxy Interface > EmbossFeatureProxy Properties > EmbossFeatureProxy.NativeObject Property


EmbossFeatures Interface

EmbossFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The EmbossFeatures object represents a collection of objects on a part.

Class Hierarchy
Inventor::EmbossFeatures
Visual Basic
Public Interface EmbossFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPatternFeatures.EmbossFeatures

PartFeatures.EmbossFeatures

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface


EmbossFeatures Methods

EmbossFeatures Methods
Summary

The methods of the EmbossFeatures class are listed here.

Methods
Methods
Name | Description
AddEmbossEngraveFromPlane | Method that creates a new emboss feature by embossing and/or engraving a profile on one or more faces in the model.
AddEmbossFromFace | Method that creates a new emboss feature by embossing a profile on one or more faces in the model.
AddEngraveFromFace | Method that creates a new emboss feature by engraving a profile on one or more faces in the model.
Item | Property that returns the specified EmbossFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Methods


EmbossFeatures.AddEmbossEngraveFromPlane Method

EmbossFeatures.AddEmbossEngraveFromPlane Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new emboss feature by embossing and/or engraving a profile on one or more faces in the model.

Visual Basic
Sub AddEmbossEngraveFromPlane(Profile As Profile, Taper As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef TopFaceColor As [optional] VARIANT, Result As [out, retval] EmbossFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the emboss. The specified profile must be closed, otherwise (i.e. if the profile is open), the creation of the emboss feature will fail. The closed profiles can constitute both sketch entities as well as text.
Taper | Input Variant that defines the taper angle of the emboss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates on which side of the sketch plane the emboss feature should be created. The profile will be extended to create the emboss feature starting from the sketch plane until any existing face in the model is intersected. Valid input is any one of the constants in PartFeatureExtentDirectionEnum: kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection. The value kPositiveExtentDirection defines the emboss direction to be in the same direction as the normal of the sketch plane that contains the profile to be embossed.
TopFaceColor | Optional Input Variant that defines the render style to use for the top face of the emboss feature. The valid input is a RenderStyle object. If no input is specified, then the default render style will be applied.
Remarks

If the emboss feature is created successfully, an EmbossFeature object corresponding to the newly created emboss feature is returned from this method.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Methods > EmbossFeatures.AddEmbossEngraveFromPlane Method


EmbossFeatures.AddEmbossFromFace Method

EmbossFeatures.AddEmbossFromFace Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new emboss feature by embossing a profile on one or more faces in the model.

Visual Basic
Sub AddEmbossFromFace(Profile As Profile, Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef TopFaceColor As [optional] VARIANT, ByRef WrapFace As [optional] VARIANT, Result As [out, retval] EmbossFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the emboss. The specified profile must be closed, otherwise (i.e. if the profile is open), the creation of the emboss feature will fail. The closed profiles can constitute both sketch entities as well as text.
Distance | Input Variant that defines the depth of the emboss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates on which side of the sketch plane the emboss feature should be created. First, the profile will be projected along the specified direction onto all faces that are in that direction. Then, the emboss feature will be generated by embossing the projected profile on these faces. Valid input is either kPositiveExtentDirection or kNegativeExtentDirection constant value in PartFeatureExtentDirectionEnum. The value kPositiveExtentDirection defines the projection direction of the profile to be in the same direction as the normal of the sketch plane that contains the profile to be embossed. If kSymmetricExtentDirection is specified, then the creation of the emboss feature will fail.
TopFaceColor | Optional Input Variant that defines the render style to use for the top face of the emboss feature. The valid input is a RenderStyle object. If no input is specified, then the default render style will be applied.
WrapFace | Optional Input Variant that specifies the face around which the emboss feature should be wrapped. The valid input is a Face object. This argument can be used to specify a curved face around which the emboss feature should be wrapped. The face can only be planar or conical, not a spline. If the emboss profile is large relative to the amount of curvature, the embossed or engraved area distorts slightly as it projects to the curved face. The wrap stops when a perpendicular face is encountered. If this argument is not specified, then it implies that the emboss feature should not be wrapped around any face, but created as a result of straight projection onto the face.
Remarks

If the emboss feature is created successfully, an EmbossFeature object corresponding to the newly created emboss feature is returned from this method.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Methods > EmbossFeatures.AddEmbossFromFace Method


EmbossFeatures.AddEngraveFromFace Method

EmbossFeatures.AddEngraveFromFace Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new emboss feature by engraving a profile on one or more faces in the model.

Visual Basic
Sub AddEngraveFromFace(Profile As Profile, Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef TopFaceColor As [optional] VARIANT, ByRef WrapFace As [optional] VARIANT, Result As [out, retval] EmbossFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the emboss. The specified profile must be closed, otherwise (i.e. if the profile is open), the creation of the emboss feature will fail. The closed profiles can constitute both sketch entities as well as text.
Distance | Input Variant that defines the depth of the emboss. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates on which side of the sketch plane the emboss feature should be created. First, the profile will be projected along the specified direction onto all faces that are in that direction. Then, the emboss feature will be generated by engraving the projected profile on these faces. Valid input is either kPositiveExtentDirection or kNegativeExtentDirection constant value in PartFeatureExtentDirectionEnum. The value kPositiveExtentDirection defines the projection direction of the profile to be in the same direction as the normal of the sketch plane that contains the profile to be embossed. If kSymmetricExtentDirection is specified, then the creation of the emboss feature will fail.
TopFaceColor | Optional Input Variant that defines the render style to use for the top face of the emboss feature. The valid input is a RenderStyle object. If no input is specified, then the default render style will be applied.
WrapFace | Optional Input Variant that specifies the face around which the emboss feature should be wrapped. The valid input is a Face object. This argument can be used to specify a curved face around which the emboss feature should be wrapped. The face can only be planar or conical, not a spline. If the emboss profile is large relative to the amount of curvature, the embossed or engraved area distorts slightly as it projects to the curved face. The wrap stops when a perpendicular face is encountered. If this argument is not specified, then it implies that the emboss feature should not be wrapped around any face, but created as a result of straight projection onto the face.
Remarks

If the emboss feature is created successfully, an EmbossFeature object corresponding to the newly created emboss feature is returned from this method.

You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Methods > EmbossFeatures.AddEngraveFromFace Method


EmbossFeatures.Item Method

EmbossFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified EmbossFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] EmbossFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Methods > EmbossFeatures.Item Method


EmbossFeatures Properties

EmbossFeatures Properties
Summary

The properties of the EmbossFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Properties


EmbossFeatures.Application Property

EmbossFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Properties > EmbossFeatures.Application Property


EmbossFeatures.Count Property

EmbossFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Properties > EmbossFeatures.Count Property


EmbossFeatures.Type Property

EmbossFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EmbossFeatures Interface > EmbossFeatures Properties > EmbossFeatures.Type Property


EndOfFeatures Interface

EndOfFeatures Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This object represents the End of Part marker in the browser. When traversing through the browser hierarchy, this is one of the nodes that is encountered, indicating the position of the marker in the browser.

Class Hierarchy
Inventor::EndOfFeatures
Visual Basic
Public Interface EndOfFeatures
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > EndOfFeatures Interface


EndOfFeatures Properties

EndOfFeatures Properties
Summary

The properties of the EndOfFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > EndOfFeatures Interface > EndOfFeatures Properties


EndOfFeatures.Application Property

EndOfFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > EndOfFeatures Interface > EndOfFeatures Properties > EndOfFeatures.Application Property


EndOfFeatures.Parent Property

EndOfFeatures.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > EndOfFeatures Interface > EndOfFeatures Properties > EndOfFeatures.Parent Property


EndOfFeatures.Type Property

EndOfFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EndOfFeatures Interface > EndOfFeatures Properties > EndOfFeatures.Type Property


EnumType Interface

EnumType Interface
Summary

Enum Type Wrapper Object.

Class Hierarchy
Inventor::EnumType
Visual Basic
Public Interface EnumType
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TestManager.GetEnumType

You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface


EnumType Methods

EnumType Methods
Summary

The methods of the EnumType class are listed here.

Methods
Methods
Name | Description
MoveNext | Move to next enum value in the available list of values.
Reset | Reset enum type to one before the first enum value.
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Methods


EnumType.MoveNext Method

EnumType.MoveNext Method
Summary

Move to next enum value in the available list of values.

Visual Basic
Sub MoveNext()
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Methods > EnumType.MoveNext Method


EnumType.Reset Method

EnumType.Reset Method
Summary

Reset enum type to one before the first enum value.

Visual Basic
Sub Reset()
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Methods > EnumType.Reset Method


EnumType Properties

EnumType Properties
Summary

The properties of the EnumType class are listed here.

Properties
Name | Description
Count | Gets the number of available enum values.
CurrentIndex | Gets/sets the current index indicating which enum value is stored from the available list of values (1 To Count).
Name | Gets the name of the enum type wrapped by this object.
Value | Gets/sets a the enum value.
ValueName | Gets the string representation of the enum value.
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Properties


EnumType.Count Property

EnumType.Count Property
Summary

Gets the number of available enum values.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Properties > EnumType.Count Property


EnumType.CurrentIndex Property

EnumType.CurrentIndex Property
Summary

Gets/sets the current index indicating which enum value is stored from the available list of values (1 To Count).

Visual Basic
Property CurrentIndex() As long
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Properties > EnumType.CurrentIndex Property


EnumType.Name Property

EnumType.Name Property
Summary

Gets the name of the enum type wrapped by this object.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Properties > EnumType.Name Property


EnumType.Value Property

EnumType.Value Property
Summary

Gets/sets a the enum value.

Visual Basic
Property Value() As long
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Properties > EnumType.Value Property


EnumType.ValueName Property

EnumType.ValueName Property
Summary

Gets the string representation of the enum value.

Visual Basic
Property ValueName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > EnumType Interface > EnumType Properties > EnumType.ValueName Property


Environment Interface

Environment Interface Available in Inventor Introduced in Inventor 5
Summary

The Environment object represents any Autodesk Inventor environment. Example environments are Part, Assembly, Sketch, etc. The Environment represents the current state of an environment. See the UI customization and Environments overviews for more information.

Class Hierarchy
Inventor::Environment
Visual Basic
Public Interface Environment
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.ActiveEnvironment

EnvironmentList.Item

EnvironmentManager.BaseEnvironment

EnvironmentManager.EditObjectEnvironment

EnvironmentManager.OverrideEnvironment

Environments.Add

Environments.Item

PanelBarObject.Parent

UserInterfaceManager.ActiveEnvironment

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Render the active document in Inventor Studio. sample

Example 1

See Environment::PanelBar for example "Change the current panel bar"

Example 2

See Environment::InternalName for example "Print Environment Names"

You are here: Symbol Reference > Inventor Library > Objects > Environment Interface


Environment Methods

Environment Methods
Summary

The methods of the Environment class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the environment. This method will fail for built-in environments.
GetRadialMarkingMenu | Method that returns the RadialMarkingMenu object that can be used to query and set the commands available in the radial menu for the input object type.
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Methods


Environment.Delete Method

Environment.Delete Method Available in Inventor Introduced in Inventor 9
Summary

Method that deletes the environment. This method will fail for built-in environments.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Methods > Environment.Delete Method


Environment.GetRadialMarkingMenu Method

Environment.GetRadialMarkingMenu Method Available in Inventor Introduced in Inventor 2012
Summary

Method that returns the RadialMarkingMenu object that can be used to query and set the commands available in the radial menu for the input object type.

Visual Basic
Sub GetRadialMarkingMenu(ByRef ObjectType As [optional] VARIANT, Result As [out, retval] RadialMarkingMenu*)
Parameters
Parameters | Description
ObjectType | Optional input ObjectTypeEnum that specifies the object type to retrieve the marking menu for. If not provided, the marking menu for the default environment state (no selections) is returned.
Remarks

If object type is not provided, the radial menu returned is for the default environment state with no object selected.

There are a set of pre-defined (built-in) marking menus provided by Inventor. If you provide the object type associated with a built-in marking menu, the built-in marking menu is returned allowing you to query and edit its contents. The built-in marking menus are those that are editable in the “Marking Menu” tab of the Customize dialog.

If you provide an object that does not have an associated marking menu, a new custom marking menu is created. It is created empty and you can populate it with the desired commands. Custom marking menus are not persisted from session to session so it is the responsibility of your add-in to create any its custom marking menus each time it is activated.

You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Methods > Environment.GetRadialMarkingMenu Method


Environment Properties

Environment Properties
Summary

The properties of the Environment class are listed here.

Properties
Name | Description
AdditionalVisibleRibbonTabs | Property that gets and sets an array of strings containing the internal names of ribbon tabs that should be displayed in this environment.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BuiltIn | Property that specifies if the Environment a standard Autodesk Inventor Environment or if it has been added by a client. Built-in environments have restrictions in the edits that can be performed. For example, build-in environments cannot be deleted. For more information, see the Environments overview.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
ContextMenuList | Property that returns the that defines the command bars that are shown in the context menu when the user right-clicks on any tool bar. Using this context menu the user can turn the display of toolbars on and off.
DefaultMenuBar | Property that specifies which command bar should be displayed within the menu bar when the environment is initially activated.
DefaultRibbonTab | Property that gets and sets the internal name of the ribbon tab that should be displayed when this environment is activated.
DefaultToolBar | Property that specifies which command bar should be displayed within the standard tool bar when the environment is initially activated.
DisabledCommandList | Property that returns the DisabledCommandList object. This object allows the environment to disable commands when this environment is active. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.
DisabledCommandTypes | Property that gets and sets the classes of commands to be disabled when this environment is active. The enum values are bits and can be combined to indicate that more than one classification of commands is to be disabled.
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
InheritAllRibbonTabs | Property that gets and sets whether this environment should inherit all ribbon tabs from the 'base' environment.
InternalName | Property that indicates the name of the environment.
LargeIcon | Property that returns the large icon associated with this environment.
PanelBar | Property that returns the PanelBar object.
Parent | Property that returns the parent of the environment.
Ribbon | Property that returns the Ribbon object associated with this environment. This property returns Nothing when the environment is initially created and not yet applied as an override or a parallel environment.
StandardIcon | Property that returns the standard icon associated with this environment.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties


Environment.AdditionalVisibleRibbonTabs Property

Environment.AdditionalVisibleRibbonTabs Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets an array of strings containing the internal names of ribbon tabs that should be displayed in this environment.

Visual Basic
Property AdditionalVisibleRibbonTabs() As VARIANT
Remarks

These are in addition to the tabs displayed as a result of setting the InheritAllRibbonTabs property to True.

See Also

Creation of an override environment for a document sample

Example 1

The following sample demonstrates the use of parallel environments and contextual ribbon tabs. Run the following macro. Open an assembly document. Go to the "Environments" tab and click on the "Some Analysis" button.

Sub AddParallelEnvironment()

    ' Get the Environments collection
    Dim oEnvironments As Environments
    Set oEnvironments = ThisApplication.UserInterfaceManager.Environments

    ' Create a new environment
    Dim oNewEnv As Environment
    Set oNewEnv = oEnvironments.Add("Some Analysis", "SomeAnalysis")

    ' Get the ribbon associated with the assembly environment
    Dim oAssemblyRibbon As Ribbon
    Set oAssemblyRibbon = ThisApplication.UserInterfaceManager.Ribbons.Item("Assembly")

    ' Create contextual tabs and panels within them
    Dim oContextualTabOne As RibbonTab
    Set oContextualTabOne = oAssemblyRibbon.RibbonTabs.Add("Some Analysis", "SomeAnalysis", "ClientId123", , , True)

    Dim oPanelOne As RibbonPanel
    Set oPanelOne = oContextualTabOne.RibbonPanels.Add("Panel One", "PanelOne", "ClientId123")

    Dim oDef1 As ButtonDefinition
    Set oDef1 = ThisApplication.CommandManager.ControlDefinitions.Item("PartExtrudeCmd")

    Call oPanelOne.CommandControls.AddButton(oDef1, True)

    Dim oPanelTwo As RibbonPanel
    Set oPanelTwo = oContextualTabOne.RibbonPanels.Add("Panel Two", "PanelTwo", "ClientId123")

    Dim oDef2 As ButtonDefinition
    Set oDef2 = ThisApplication.CommandManager.ControlDefinitions.Item("AssemblyPlaceComponentCmd")

    Call oPanelTwo.CommandControls.AddButton(oDef2, True)

    Dim oContextualTabTwo As RibbonTab
    Set oContextualTabTwo = oAssemblyRibbon.RibbonTabs.Add("Some Analysis Extras", "SomeAnalysisExtras", "ClientId123", , , True)

    Dim oPanelThree As RibbonPanel
    Set oPanelThree = oContextualTabTwo.RibbonPanels.Add("Panel Three", "PanelThree", "ClientId123")
    Call oPanelThree.CommandControls.AddButton(oDef1, True)

    ' Associate the contextual tabs with the newly created environment
    ' The contextual tabs will only be displayed when this environment is active
    Dim strTabs(1) As String
    strTabs(0) = "SomeAnalysis"
    strTabs(1) = "SomeAnalysisExtras"

    oNewEnv.AdditionalVisibleRibbonTabs = strTabs

    ' Make the "SomeAnalysis" tab default for the environment
    oNewEnv.DefaultRibbonTab = "SomeAnalysis"

    ' Get the collection of parallel environments and add the new environment
    Dim oParEnvs As EnvironmentList
    Set oParEnvs = ThisApplication.UserInterfaceManager.ParallelEnvironments

    Call oParEnvs.Add(oNewEnv)

    ' Make the new parallel environment available only within the assembly environment
    ' A ControlDefinition is automatically created when an environment is added to the
    ' parallel environments list. The internal name of the definition is the same as
    ' the internal name of the environment.
    Dim oParallelEnvButton As ControlDefinition
    Set oParallelEnvButton = ThisApplication.CommandManager.ControlDefinitions.Item("SomeAnalysis")

    Dim oEnv As Environment
    For Each oEnv In oEnvironments
        If Not oEnv.InternalName = "AMxAssemblyEnvironment" Then
            On Error Resume Next
            Call oEnv.DisabledCommandList.Add(oParallelEnvButton)
        End If
    Next

End Sub
Example 2

See the following pages for samples.

RibbonPanels.Add

CommandControls.AddButton

EnvironmentManager.OverrideEnvironment

Ribbons

Example 3

Add parallel environment with contextual tabs example (C#).

The following sample demonstrates the use of parallel environments and contextual ribbon tabs. Run the following macro. Open an assembly document. Go to the "Environments" tab and click on the "Some Analysis" button.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void AddParallelEnvironment()
{
    Application oApp = ThisApplication;

    // Get the Environments collection
    Environments oEnvironments = oApp.UserInterfaceManager.Environments;

    // Create a new environment
    Inventor.Environment oNewEnv = oEnvironments.Add("Some Analysis", "SomeAnalysis", null, null, null);

    // Get the ribbon associated with the assembly environment
    Ribbon oAssemblyRibbon = oApp.UserInterfaceManager.Ribbons["Assembly"];

    // Create contextual tabs and panels within them
    RibbonTab oContextualTabOne = oAssemblyRibbon.RibbonTabs.Add("Some Analysis", "SomeAnalysis", "ClientId123","" ,false , true);

    RibbonPanel oPanelOne = oContextualTabOne.RibbonPanels.Add("Panel One", "PanelOne", "ClientId123","", false);
    ButtonDefinition oDef1 = (ButtonDefinition)oApp.CommandManager.ControlDefinitions["PartExtrudeCmd"];
    oPanelOne.CommandControls.AddButton(oDef1, true, true, "", false);

    RibbonPanel oPanelTwo = oContextualTabOne.RibbonPanels.Add("Panel Two", "PanelTwo", "ClientId123", "", false);
    ButtonDefinition oDef2 = (ButtonDefinition)oApp.CommandManager.ControlDefinitions["AssemblyPlaceComponentCmd"];
    oPanelTwo.CommandControls.AddButton(oDef2, true, true, "", false);

    RibbonTab oContextualTabTwo = oAssemblyRibbon.RibbonTabs.Add("Some Analysis Extras", "SomeAnalysisExtras", "ClientId123","" ,false , true);

    RibbonPanel oPanelThree = oContextualTabTwo.RibbonPanels.Add("Panel Three", "PanelThree", "ClientId123", "", false);
    oPanelThree.CommandControls.AddButton(oDef1, true, true, "", false);

    // Associate the contextual tabs with the newly created environment
    // The contextual tabs will only be displayed when this environment is active
    String[] strTabs = new String[2];
    strTabs[0] = "SomeAnalysis";
    strTabs[1] = "SomeAnalysisExtras";

    oNewEnv.AdditionalVisibleRibbonTabs = strTabs;

    // Make the "SomeAnalysis" tab default for the environment
    oNewEnv.DefaultRibbonTab = "SomeAnalysis";

    // Get the collection of parallel environments and add the new environment
    EnvironmentList oParEnvs = oApp.UserInterfaceManager.ParallelEnvironments;

    oParEnvs.Add(oNewEnv);

    // Make the new parallel environment available only within the assembly environment
    // A ControlDefinition is automatically created when an environment is added to the
    // parallel environments list. The internal name of the definition is the same as
    // the internal name of the environment.
    ControlDefinition oParallelEnvButton = oApp.CommandManager.ControlDefinitions["SomeAnalysis"];

    int iEnvCount = oEnvironments.Count;
    Inventor.Environment oEnv;
    int i;
    for (i = 1; i <= iEnvCount; i++)
    {
        oEnv = oEnvironments[i];
        if (oEnv.InternalName != "AMxAssemblyEnvironment")
        {
            oEnv.DisabledCommandList.Add(oParallelEnvButton);
        }
    }

}
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.AdditionalVisibleRibbonTabs Property


Environment.Application Property

Environment.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.Application Property


Environment.BuiltIn Property

Environment.BuiltIn Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies if the Environment a standard Autodesk Inventor Environment or if it has been added by a client. Built-in environments have restrictions in the edits that can be performed. For example, build-in environments cannot be deleted. For more information, see the Environments overview.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.BuiltIn Property


Environment.ClientId Property

Environment.ClientId Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.ClientId Property


Environment.ContextMenuList Property

Environment.ContextMenuList Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the that defines the command bars that are shown in the context menu when the user right-clicks on any tool bar. Using this context menu the user can turn the display of toolbars on and off.

Visual Basic
Property ContextMenuList() As CommandBarList**
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.ContextMenuList Property


Environment.DefaultMenuBar Property

Environment.DefaultMenuBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies which command bar should be displayed within the menu bar when the environment is initially activated.

Visual Basic
Property DefaultMenuBar() As CommandBar*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.DefaultMenuBar Property


Environment.DefaultRibbonTab Property

Environment.DefaultRibbonTab Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the internal name of the ribbon tab that should be displayed when this environment is activated.

Visual Basic
Property DefaultRibbonTab() As String
See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.DefaultRibbonTab Property


Environment.DefaultToolBar Property

Environment.DefaultToolBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that specifies which command bar should be displayed within the standard tool bar when the environment is initially activated.

Visual Basic
Property DefaultToolBar() As CommandBar*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.DefaultToolBar Property


Environment.DisabledCommandList Property

Environment.DisabledCommandList Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the DisabledCommandList object. This object allows the environment to disable commands when this environment is active. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.

Visual Basic
Property DisabledCommandList() As DisabledCommandList**
See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.DisabledCommandList Property


Environment.DisabledCommandTypes Property

Environment.DisabledCommandTypes Property Available in Inventor Introduced in Inventor 10
Summary

Property that gets and sets the classes of commands to be disabled when this environment is active. The enum values are bits and can be combined to indicate that more than one classification of commands is to be disabled.

Visual Basic
Property DisabledCommandTypes() As CommandTypesEnum
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.DisabledCommandTypes Property


Environment.DisplayName Property

Environment.DisplayName Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.DisplayName Property


Environment.InheritAllRibbonTabs Property

Environment.InheritAllRibbonTabs Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether this environment should inherit all ribbon tabs from the 'base' environment.

Visual Basic
Property InheritAllRibbonTabs() As VARIANT_BOOL
Remarks

This property applies only to custom environments and defaults to True when an environment is initially created. If set to True, all visible tabs in the base environment are automatically displayed in this environment. Tab visibility can be further controlled using RibbonTab.Visible and Environment.AdditionalVisibleRibbonTabs properties.

See Also

Creation of an override environment for a document sample

You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.InheritAllRibbonTabs Property


Environment.InternalName Property

Environment.InternalName Property Available in Inventor Introduced in Inventor 5
Summary

Property that indicates the name of the environment.

Visual Basic
Property InternalName() As BSTR*
Remarks

When setting the name it must be unique with respect to all other environments. This should not be a localized name, but should be consistent regardless of the current locale (typically it is English). This is used primarily for looking up the environment and is not displayed to the user. The display name is the name shown to the user. This property is read-only for built-in environments.

See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Example

"Print Environment Names"

This sample prints the internal names and descriptions of all environments in Inventor. The sample prints the names and descriptions to a text file (EnvironmentNames.txt) created in C:\Temp directory. Change the path if required.

Sub PrintEnvironmentNames()
    Dim oEnvironments As Environments
    Set oEnvironments = ThisApplication.UserInterfaceManager.Environments
    Dim oEnvironment As Environment

    Open "C:\temp\EnvironmentNames.txt" For Output As #1
    Print #1, Tab(10); "Environment Name"; Tab(60); "Description"; vbNewLine

    For Each oEnvironment In oEnvironments
        Print #1, oEnvironment.InternalName; Tab(55); oEnvironment.DisplayName
    Next

    Close #1
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.InternalName Property


Environment.LargeIcon Property

Environment.LargeIcon Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the large icon associated with this environment.

Visual Basic
Property LargeIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.LargeIcon Property


Environment.PanelBar Property

Environment.PanelBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the PanelBar object.

Visual Basic
Property PanelBar() As PanelBar**
Example

"Change the current panel bar"

This sample demonstrates the changing of the current panel bar. The sample changes the current panel bar to the part features panel bar. Make sure that the part features panel bar is not already active.

Public Sub ChangeCurrentPanelBar()

    ' Set a reference to the Part Features toolbar.
    Dim oFeaturesCmdBar As CommandBar
    Set oFeaturesCmdBar = ThisApplication.UserInterfaceManager.CommandBars.Item("PMxPartFeatureCmdBar")

    ' Set a reference to the active environment
    Dim oActiveEnv As Environment
    Set oActiveEnv = ThisApplication.UserInterfaceManager.ActiveEnvironment

    ' Set a reference to the PanelBar object
    Dim oPanelBar As PanelBar
    Set oPanelBar = oActiveEnv.PanelBar

    ' Change the current panel bar to part features
    ' This call also adds the assigned command bar to
    ' the list of command bars in the panel, if it
    ' doesn't already exist in the list.
    oPanelBar.CurrentCommandBar = oFeaturesCmdBar
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.PanelBar Property


Environment.Parent Property

Environment.Parent Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the parent of the environment.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.Parent Property


Environment.Ribbon Property

Environment.Ribbon Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the Ribbon object associated with this environment. This property returns Nothing when the environment is initially created and not yet applied as an override or a parallel environment.

Visual Basic
Property Ribbon() As Ribbon**
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.Ribbon Property


Environment.StandardIcon Property

Environment.StandardIcon Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the standard icon associated with this environment.

Visual Basic
Property StandardIcon() As IPictureDisp*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.StandardIcon Property


Environment.Type Property

Environment.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Environment Interface > Environment Properties > Environment.Type Property


EnvironmentList Interface

EnvironmentList Interface Available in Inventor Introduced in Inventor 10
Summary

The EnvironmentList object defines a list of environments that are displayed to the user in various contexts. For more information, refer to the Environments overview.

Class Hierarchy
Inventor::EnvironmentList
Visual Basic
Public Interface EnvironmentList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

UserInterfaceManager.ParallelEnvironments

See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface


EnvironmentList Methods

EnvironmentList Methods
Summary

The methods of the EnvironmentList class are listed here.

Methods
Methods
Name | Description
Add | Method that adds an Environment object to the list. The method returns an error if a built-in Environment is supplied.
Item | Property that returns the specified Environment object from the list.
Remove | Method that removes the specified Environment from the list.
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Methods


EnvironmentList.Add Method

EnvironmentList.Add Method Available in Inventor Introduced in Inventor 10
Summary

Method that adds an Environment object to the list. The method returns an error if a built-in Environment is supplied.

Visual Basic
Sub Add(Environment As Environment)
Parameters
Parameters | Description
Environment | Input Environment object to add to the list.
See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Methods > EnvironmentList.Add Method


EnvironmentList.Item Method

EnvironmentList.Item Method Available in Inventor Introduced in Inventor 10
Summary

Property that returns the specified Environment object from the list.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Environment*)
Parameters
Parameters | Description
index | Input Long that specifies the object within the list to return.
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Methods > EnvironmentList.Item Method


EnvironmentList.Remove Method

EnvironmentList.Remove Method Available in Inventor Introduced in Inventor 10
Summary

Method that removes the specified Environment from the list.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Long that specifies the index of the Environment to remove from the list.
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Methods > EnvironmentList.Remove Method


EnvironmentList Properties

EnvironmentList Properties
Summary

The properties of the EnvironmentList class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of environments currently in the list.
Type | Property returning kEnvironmentListObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Properties


EnvironmentList.Application Property

EnvironmentList.Application Property Available in Inventor Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Properties > EnvironmentList.Application Property


EnvironmentList.Count Property

EnvironmentList.Count Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the number of environments currently in the list.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Properties > EnvironmentList.Count Property


EnvironmentList.Type Property

EnvironmentList.Type Property Available in Inventor Introduced in Inventor 10
Summary

Property returning kEnvironmentListObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentList Interface > EnvironmentList Properties > EnvironmentList.Type Property


EnvironmentManager Interface

EnvironmentManager Interface Available in Inventor Introduced in Inventor 10
Summary

This object provides methods and properties to get and set the base and override environments for this document. For more information, refer to the Environments overview.

Class Hierarchy
Inventor::EnvironmentManager
Visual Basic
Public Interface EnvironmentManager
Inherits IDispatch
Remarks

The Edit Target Environment is an environment corresponding to an edit context. An edit context is the term used to describe the edit state of an Inventor entity. Sketch, assembly component, part feature and drawing sheet are all examples of native edit target entities. In Autodesk Inventor Professional, a Tube and Pipe component and a Harness component are examples of custom edit target entities. When the user creates or edits an edit target, this entity's edit environment is activated. An edit target entity typically has a command in the parent environment.

This command will be used for forward work flow. Once created, the edit target entity can be found in the browser. Subsequent edits will take place by double click activation or menu activation of the browser node. The current edit target environment can be found by looking at the top item in the "Application" menu. This menu item corresponds to FWxParallelEvnCmd1. Since Autodesk Inventor 10, an edit target environment can have several parallel environments. Analysis or similar embellishment tools are the typical users of a parallel environment. FEA, Inventor Studio, Motion Analysis are examples of a parallel environment. Activation of a parallel environment is done via the Application menu. User can switch between a parallel environment and its parent edit target environment or between a parallel environment and a sibling parallel environment via the Application menu. Autodesk Inventor does not remember the activation trail for parallel environments.

Navigation from one parallel to another implies that the previous parallel will be terminated before the next one is activated. Inventor does however remember the activation trail for edit target environments. The Return button can be used to retrace this trail. Activation of an edit target environment inside another edit target environment activates the Return button. The assembly environment is an example for this. The user can start with an assembly, then in-place-edit a sub-assembly, in-place-edit a part in the sub-assembly, edit a feature in the part, and so on. In this example, first Return button click will take the user back from feature edit to part, from part to sub-assembly and from sub-assembly to top assembly. When specified, the override environment indicates that after a custom environment is applied as an override environment to a document and the document is closed after a save, this document will open in the override environment. This functionality used to specify a custom default environment for a document.

Notes

Members through which this object may be accessed include:

AssemblyDocument.EnvironmentManager

DrawingDocument.EnvironmentManager

PartDocument.EnvironmentManager

PresentationDocument.EnvironmentManager

See Also

Creation of an override environment for a document sample

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface


EnvironmentManager Methods

EnvironmentManager Methods
Summary

The methods of the EnvironmentManager class are listed here.

Methods
Methods
Name | Description
GetCurrentEnvironment | Method that gets the current Environment for this document. This is the environment that the document is currently displayed in.
SetCurrentEnvironment | Method that sets the current Environment for this document. This is the environment that the document is currently displayed in. The change is not persisted with the document; i.e. the next time the document is opened, it will show up in its base environment or the override environment if specified.
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Methods


EnvironmentManager.GetCurrentEnvironment Method

EnvironmentManager.GetCurrentEnvironment Method Available in Inventor Introduced in Inventor 10
Summary

Method that gets the current Environment for this document. This is the environment that the document is currently displayed in.

Visual Basic
Sub GetCurrentEnvironment(ByRef Environment As Environment*, ByRef EditTargetId As String)
Parameters
Parameters | Description
Environment | Output Environment that the document is currently displayed in.
EditTargetId | Output string (if available) that contains the edit target identifier if specified by the client. The string indicates the edit target associated with this instance of the environment.
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Methods > EnvironmentManager.GetCurrentEnvironment Method


EnvironmentManager.SetCurrentEnvironment Method

EnvironmentManager.SetCurrentEnvironment Method Available in Inventor Introduced in Inventor 10
Summary

Method that sets the current Environment for this document. This is the environment that the document is currently displayed in. The change is not persisted with the document; i.e. the next time the document is opened, it will show up in its base environment or the override environment if specified.

Visual Basic
Sub SetCurrentEnvironment(Environment As Environment, ByRef EditObjectId As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
Environment | Environment that the document should be displayed in.
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Methods > EnvironmentManager.SetCurrentEnvironment Method


EnvironmentManager Properties

EnvironmentManager Properties
Summary

The properties of the EnvironmentManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BaseEnvironment | Property that returns the Environment that is defined as the default for this document. This is the environment displayed when the document is opened unless an override environment has been specified for this document.
EditObjectEnvironment | This method returns the environment associated with the currently active edit object. This is the environment which is the topmost entry in the Application menu. Since Autodesk Inventor 10, the active environment and EditObjectEnvironment are not necessarily the same. Using parallel environments, one can switch to a parallel environment for the same edit object.
OverrideEnvironment | Property that indicates the override environment for the document. This specifies the environment that the document should open with and overrides the base environment. This property returns Nothing if no override has been specified and can be set to Nothing to clear the override.
Parent | Property that returns the parent of the EnvironmentManager.
Type | Property returning kEnvironmentManagerObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties


EnvironmentManager.Application Property

EnvironmentManager.Application Property Available in Inventor Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties > EnvironmentManager.Application Property


EnvironmentManager.BaseEnvironment Property

EnvironmentManager.BaseEnvironment Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the Environment that is defined as the default for this document. This is the environment displayed when the document is opened unless an override environment has been specified for this document.

Visual Basic
Property BaseEnvironment() As Environment**
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties > EnvironmentManager.BaseEnvironment Property


EnvironmentManager.EditObjectEnvironment Property

EnvironmentManager.EditObjectEnvironment Property Available in Inventor Introduced in Inventor 10
Summary

This method returns the environment associated with the currently active edit object. This is the environment which is the topmost entry in the Application menu. Since Autodesk Inventor 10, the active environment and EditObjectEnvironment are not necessarily the same. Using parallel environments, one can switch to a parallel environment for the same edit object.

Visual Basic
Property EditObjectEnvironment() As Environment**
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties > EnvironmentManager.EditObjectEnvironment Property


EnvironmentManager.OverrideEnvironment Property

EnvironmentManager.OverrideEnvironment Property Available in Inventor Introduced in Inventor 10
Summary

Property that indicates the override environment for the document. This specifies the environment that the document should open with and overrides the base environment. This property returns Nothing if no override has been specified and can be set to Nothing to clear the override.

Visual Basic
Property OverrideEnvironment() As Environment*
Example 1

The following sample demonstrates the creation of an override environment for a document. A new ribbon tab is created and associated with the override environment. Open a part document and run the sample.

Sub AddOverrideEnvironment()

    ' Make sure a part document is active
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oEnvironments As Environments
    Set oEnvironments = ThisApplication.UserInterfaceManager.Environments

    ' Create a new environment
    Dim oOverrideEnv As Environment
    Set oOverrideEnv = oEnvironments.Add("Override", "OverrideEnvironment")

    ' Get the part ribbon
    Dim oPartRibbon As Ribbon
    Set oPartRibbon = ThisApplication.UserInterfaceManager.Ribbons.Item("Part")

    ' Create a contextual tab to be used as the default for the override environment
    Dim oTabOne As RibbonTab
    Set oTabOne = oPartRibbon.RibbonTabs.Add("Tab One", "TabOne", "ClientId123", "id_TabSheetMetal", True, False)

    ' Create panels with the tab
    Dim oPanelOne As RibbonPanel
    Set oPanelOne = oTabOne.RibbonPanels.Add("Panel One", "PanelOne", "ClientId123")

    Dim oDef1 As ButtonDefinition
    Set oDef1 = ThisApplication.CommandManager.ControlDefinitions.Item("PartExtrudeCmd")

    Call oPanelOne.CommandControls.AddButton(oDef1, True)

    Dim oPanelTwo As RibbonPanel
    Set oPanelTwo = oTabOne.RibbonPanels.Add("Panel Two", "PanelTwo", "ClientId123")

    Dim oDef2 As ButtonDefinition
    Set oDef2 = ThisApplication.CommandManager.ControlDefinitions.Item("PartRevolveCmd")

    Call oPanelTwo.CommandControls.AddButton(oDef2, True)

    Dim strTabs(0) As String
    strTabs(0) = "TabOne"

    oOverrideEnv.InheritAllRibbonTabs = False
    oOverrideEnv.AdditionalVisibleRibbonTabs = strTabs
    oOverrideEnv.DefaultRibbonTab = "TabOne"

    ' Set the override environment on the active part
    oPartDoc.EnvironmentManager.OverrideEnvironment = oOverrideEnv

End Sub
Example 2

See the following pages for samples.

RibbonPanels.Add

Environment.AdditionalVisibleRibbonTabs

CommandControls.AddButton

Ribbons

You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties > EnvironmentManager.OverrideEnvironment Property


EnvironmentManager.Parent Property

EnvironmentManager.Parent Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the parent of the EnvironmentManager.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties > EnvironmentManager.Parent Property


EnvironmentManager.Type Property

EnvironmentManager.Type Property Available in Inventor Introduced in Inventor 10
Summary

Property returning kEnvironmentManagerObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > EnvironmentManager Interface > EnvironmentManager Properties > EnvironmentManager.Type Property


Environments Interface

Environments Interface Available in Inventor Introduced in Inventor 5
Summary

The Environments collection object provides access to all of the existing objects, and allows creation of new ones. See the UI customization overview and the Environments overview for more information.

Class Hierarchy
Inventor::Environments
Visual Basic
Public Interface Environments
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.Environments

UserInterfaceManager.Environments

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > Environments Interface


Environments Methods

Environments Methods
Summary

The methods of the Environments class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Environment object.
Item | Property that returns the specified Environment object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Methods


Environments.Add Method

Environments.Add Method Available in Inventor Introduced in Inventor 10
Summary

Method that creates a new Environment object.

Visual Basic
Sub Add(DisplayName As String, InternalName As String, ByRef ClientId As [optional] VARIANT, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, Result As [out, retval] Environment*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the environment. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the name of the environment. This is the internal name and is not displayed to the user. The name must be unique with respect to all other environments and is typically a GUID. The name should remain constant in all locales to it can be used to find a specific environment.
ClientId | Optional input string that uniquely identifies the client. Ignored for VBA clients, but Addins should supply the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}". If supplied, this string is used at Inventor start up time to determine whether the AddIn that created this environment has since been uninstalled. If so, the environment is deleted. If a ClientId is supplied, it must be the CLSID of an Add-in, else the method returns a failure.
StandardIcon | Optional input Picture object that specifies the standard size icon to use for the environment. A standard size icon is 16 pixels wide and 16 pixels high. All icons use 16 colors. If not supplied the icon from the source environment will be used.
LargeIcon | Optional input Picture object that specifies the large size icon to use for the environment. A large size icon is 24 pixels wide and 24 pixels high. All icons use 16 colors. If not supplied and a standard size icon is supplied a large icon will be automatically created by scaling the standard size icon. Because scaling a bitmap does not necessarily create a good image, it is recommended that you create and supply a large bitmap.
See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Methods > Environments.Add Method


Environments.Item Method

Environments.Item Method Available in Inventor Introduced in Inventor 5
Summary

Property that returns the specified Environment object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Environment*)
Parameters
Parameters | Description
index | Input Variant that specifies the environment within the collection to return. This can be either a Long to indicate the index of the item within the collection or a String indicating the name of the environment. If the specified name does not exist for a control, a failure occurs.
You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Methods > Environments.Item Method


Environments Properties

Environments Properties
Summary

The properties of the Environments class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of Environments in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Properties


Environments.Application Property

Environments.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Properties > Environments.Application Property


Environments.Count Property

Environments.Count Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the number of Environments in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Properties > Environments.Count Property


Environments.Type Property

Environments.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Environments Interface > Environments Properties > Environments.Type Property


EqualLengthConstraint Interface

EqualLengthConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The EqualLengthConstraint object represents a constraint that makes two lines equal in length.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::EqualLengthConstraint
        Inventor::EqualLengthConstraintProxy
Visual Basic
Public Interface EqualLengthConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

EqualLengthConstraintProxy.NativeObject

GeometricConstraints.AddEqualLength

You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraint Interface


EqualLengthConstraint Properties

EqualLengthConstraint Properties
Summary

The properties of the EqualLengthConstraint class are listed here.

Properties
Name | Description
LineOne | Property that returns the sketch line being constrained.
LineTwo | Property that returns the sketch line being constrained.
You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraint Interface > EqualLengthConstraint Properties


EqualLengthConstraint.LineOne Property

EqualLengthConstraint.LineOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch line being constrained.

Visual Basic
Property LineOne() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraint Interface > EqualLengthConstraint Properties > EqualLengthConstraint.LineOne Property


EqualLengthConstraint.LineTwo Property

EqualLengthConstraint.LineTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch line being constrained.

Visual Basic
Property LineTwo() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraint Interface > EqualLengthConstraint Properties > EqualLengthConstraint.LineTwo Property


EqualLengthConstraintProxy Interface

EqualLengthConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EqualLengthConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::EqualLengthConstraint
        Inventor::EqualLengthConstraintProxy
Visual Basic
Public Interface EqualLengthConstraintProxy
Inherits EqualLengthConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraintProxy Interface


EqualLengthConstraintProxy Properties

EqualLengthConstraintProxy Properties
Summary

The properties of the EqualLengthConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraintProxy Interface > EqualLengthConstraintProxy Properties


EqualLengthConstraintProxy.ContainingOccurrence Property

EqualLengthConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraintProxy Interface > EqualLengthConstraintProxy Properties > EqualLengthConstraintProxy.ContainingOccurrence Property


EqualLengthConstraintProxy.NativeObject Property

EqualLengthConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As EqualLengthConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EqualLengthConstraintProxy Interface > EqualLengthConstraintProxy Properties > EqualLengthConstraintProxy.NativeObject Property


EqualRadiusConstraint Interface

EqualRadiusConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The EqualRadiusConstraint object represents a constraint that makes the radius of two circular entities equal.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::EqualRadiusConstraint
        Inventor::EqualRadiusConstraintProxy
Visual Basic
Public Interface EqualRadiusConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

EqualRadiusConstraintProxy.NativeObject

GeometricConstraints.AddEqualRadius

You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraint Interface


EqualRadiusConstraint Properties

EqualRadiusConstraint Properties
Summary

The properties of the EqualRadiusConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch circle or arc being constrained.
EntityTwo | Property that returns the sketch circle or arc being constrained.
You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraint Interface > EqualRadiusConstraint Properties


EqualRadiusConstraint.EntityOne Property

EqualRadiusConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch circle or arc being constrained.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraint Interface > EqualRadiusConstraint Properties > EqualRadiusConstraint.EntityOne Property


EqualRadiusConstraint.EntityTwo Property

EqualRadiusConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch circle or arc being constrained.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraint Interface > EqualRadiusConstraint Properties > EqualRadiusConstraint.EntityTwo Property


EqualRadiusConstraintProxy Interface

EqualRadiusConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the EqualRadiusConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::EqualRadiusConstraint
        Inventor::EqualRadiusConstraintProxy
Visual Basic
Public Interface EqualRadiusConstraintProxy
Inherits EqualRadiusConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraintProxy Interface


EqualRadiusConstraintProxy Properties

EqualRadiusConstraintProxy Properties
Summary

The properties of the EqualRadiusConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraintProxy Interface > EqualRadiusConstraintProxy Properties


EqualRadiusConstraintProxy.ContainingOccurrence Property

EqualRadiusConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraintProxy Interface > EqualRadiusConstraintProxy Properties > EqualRadiusConstraintProxy.ContainingOccurrence Property


EqualRadiusConstraintProxy.NativeObject Property

EqualRadiusConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As EqualRadiusConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > EqualRadiusConstraintProxy Interface > EqualRadiusConstraintProxy Properties > EqualRadiusConstraintProxy.NativeObject Property


ErrorManager Interface

ErrorManager Interface Available in Inventor Introduced in Inventor 2010
Summary

The ErrorManager object contains methods and properties to get errors and warnings that occurred during an API call, add to Inventor's errors or to display them.

Class Hierarchy
Inventor::ErrorManager
Visual Basic
Public Interface ErrorManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.ErrorManager

MessageSection.Parent

See Also

Display custom error messages sample

Example

The following sample demonstrates how you can use Inventor's error dialog to present errors to the user.

Public Sub ErrorDialog()
    ' Create a new part document
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject)

    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Dim oRectangleLines As SketchEntitiesEnumerator
    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a base extrusion 1cm thick.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfile, 1, kNegativeExtentDirection, kJoinOperation)

    Dim oErrorMgr As ErrorManager
    Set oErrorMgr = ThisApplication.ErrorManager

    Dim oMessageSection As MessageSection
    Set oMessageSection = oErrorMgr.StartMessageSection

    On Error Resume Next

    Dim oTransaction As Transaction
    Set oTransaction = ThisApplication.TransactionManager.StartTransaction(oPartDoc, "Edit Feature")

    ' Delete all sketch lines making the sketch profile invalid.
    Dim oSketchLine As SketchLine
    For Each oSketchLine In oRectangleLines
        oSketchLine.Delete
    Next

    oPartDoc.Update

    If oMessageSection.HasErrors Or oMessageSection.HasWarnings Then
        ' End section by adopting all messages in section
        Call oMessageSection.AdoptMessages("Feature edit failed", True)

        ' Display the messages
        Dim kButtonType As ButtonTypeEnum
        kButtonType = oErrorMgr.Show("Feature Edit Error", True, False)

        If kButtonType = kAcceptButtonType Then
            ' Go through with the invalid edit if user accepts
            oTransaction.End
        Else
            oTransaction.Abort
        End If
    Else
        ' End section by clearing all messages in section
        oMessageSection.ClearMessages
        oTransaction.End
    End If

End Sub
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface


ErrorManager Methods

ErrorManager Methods
Summary

The methods of the ErrorManager class are listed here.

Methods
Methods
Name | Description
AddMessage | Method that adds a new message at the current level in the message tree.
Clear | Method that clears all errors and warnings. This method returns a failure if there are any active message sections (indicated by the IsMessageSectionActive property).
Show | Method that displays the current error/warning or the stack of errors/warnings to the user.
StartMessageSection | Method that starts a message section and returns a MessageSection object which can be used to clear, adopt or retain error/warning messages created during the section.
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Methods


ErrorManager.AddMessage Method

ErrorManager.AddMessage Method Available in Inventor Introduced in Inventor 2010
Summary

Method that adds a new message at the current level in the message tree.

Visual Basic
Sub AddMessage(Message As String, Error As VARIANT_BOOL, ByRef Reserved As [optional] VARIANT)
Parameters
Parameters | Description
Message | Input String that specifies the error or warning message.
Error | Input Boolean that specifies whether this is an error or a warning. True indicates error.
Reserved | Optional input Variant reserved for future use. Currently unused.
Example

The following sample demonstrates the use of Inventor's error dialog to display custom error messages.

Sub DisplayErrorsInInventorDialog()

    ' Set a reference to the ErrorManager object
    Dim oErrorMgr As ErrorManager
    Set oErrorMgr = ThisApplication.ErrorManager

    ' Start a message section
    Dim oMsgSection1 As MessageSection
    Set oMsgSection1 = oErrorMgr.StartMessageSection

    ' Start another (nested) message section
    Dim oMsgSection2 As MessageSection
    Set oMsgSection2 = oErrorMgr.StartMessageSection

    ' Add a message
    Call oErrorMgr.AddMessage("My third level error", True)

    ' Adopt the above message under a new message
    Call oMsgSection2.AdoptMessages("My second level error", True)

    ' Adopt the above messages under the top level message
    Call oMsgSection1.AdoptMessages("My first level error", True)

    ' Show the error dialog
    Call oErrorMgr.Show("My errors", False, False)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Methods > ErrorManager.AddMessage Method


ErrorManager.Clear Method

ErrorManager.Clear Method Available in Inventor Introduced in Inventor 2010
Summary

Method that clears all errors and warnings. This method returns a failure if there are any active message sections (indicated by the IsMessageSectionActive property).

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Methods > ErrorManager.Clear Method


ErrorManager.Show Method

ErrorManager.Show Method Available in Inventor Introduced in Inventor 2010
Summary

Method that displays the current error/warning or the stack of errors/warnings to the user.

Visual Basic
Sub Show(Title As String, AllowAccept As VARIANT_BOOL, AllowEdit As VARIANT_BOOL, Result As [out, retval] ButtonTypeEnum)
Parameters
Parameters | Description
Title | Input string that specifies the title of the message dialog. The display name of the product (e.g. 'Autodesk Inventor 2010 ' ') is prefixed to the string automatically.
AllowAccept | Input Boolean that indicates whether the 'Accept' button should be available. This user choice implies that the user would like to continue despite any errors/warnings.
AllowEdit | Input Boolean that indicates whether the 'Edit' button should be available. This user choice implies that implies that the user would like to go back into the command to correct the situation.
Remarks

The method returns an error if there are no errors or warnings. If there were errors or warnings, the method returns a ButtonTypeEnum value indicating the user's choice. The return value can be one of the three values listed below and should be handled as described:

  • kCancelButtonType - Implies that the user does not want to continue. Any partial success during the execution is to be aborted. The command would have thus behaved like a no-op.
  • kAcceptButtonType - Implies that the user would like to continue despite the errors/warnings. The entire operation should return success, with the partially successful results committed to the document(s).
  • kEditButtonType - Implies that the user would like to go back into the command to correct the situation. The entire operation should be aborted, including any partial success and control should be returned back to the command.
See Also

Display custom error messages sample

Using Inventor's error dialog sample

You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Methods > ErrorManager.Show Method


ErrorManager.StartMessageSection Method

ErrorManager.StartMessageSection Method Available in Inventor Introduced in Inventor 2010
Summary

Method that starts a message section and returns a MessageSection object which can be used to clear, adopt or retain error/warning messages created during the section.

Visual Basic
Sub StartMessageSection(Result As [out, retval] MessageSection*)
Remarks

If started, the section must be terminated using one of the three methods ' ClearMessages, AdoptMessages or End on the MessageSection object. If the intent is to replace the messages within the section, use the ClearMessages method to clear all messages and create your own using the ErrorManager.AddMessage method.

See Also

Display custom error messages sample

Using Inventor's error dialog sample

You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Methods > ErrorManager.StartMessageSection Method


ErrorManager Properties

ErrorManager Properties
Summary

The properties of the ErrorManager class are listed here.

Properties
Name | Description
AllMessages | Property that returns an XML string containing all messages (errors and warnings).
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
HasErrors | Property that returns whether there are any recorded errors.
HasWarnings | Property that returns whether there are any recorded warnings.
IsMessageSectionActive | Property that returns whether there is any message section active.
LastMessage | Property that returns the last recorded error/warning message. If there is a tree of errors/warnings, this property returns the most recent leaf error/warning.
Parent | Property that returns the parent Application object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties


ErrorManager.AllMessages Property

ErrorManager.AllMessages Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns an XML string containing all messages (errors and warnings).

Visual Basic
Property AllMessages() As BSTR*
Remarks

An example string:

<ErrorsAndWarnings>
  <Warning Message= "Part4: Errors occurred during update">
    <Error Message= "Extrusion2: Could not build this Extrusion">
      <Error Message= 'A profile loop could not be repaired after sketch geometry was edited or deleted. Use Edit Feature to reselect the profile.'/>
    </Error>
  </Warning>
</ErrorsAndWarnings>
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.AllMessages Property


ErrorManager.Application Property

ErrorManager.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.Application Property


ErrorManager.HasErrors Property

ErrorManager.HasErrors Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether there are any recorded errors.

Visual Basic
Property HasErrors() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.HasErrors Property


ErrorManager.HasWarnings Property

ErrorManager.HasWarnings Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether there are any recorded warnings.

Visual Basic
Property HasWarnings() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.HasWarnings Property


ErrorManager.IsMessageSectionActive Property

ErrorManager.IsMessageSectionActive Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether there is any message section active.

Visual Basic
Property IsMessageSectionActive() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.IsMessageSectionActive Property


ErrorManager.LastMessage Property

ErrorManager.LastMessage Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the last recorded error/warning message. If there is a tree of errors/warnings, this property returns the most recent leaf error/warning.

Visual Basic
Property LastMessage() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.LastMessage Property


ErrorManager.Parent Property

ErrorManager.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent Application object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.Parent Property


ErrorManager.Type Property

ErrorManager.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ErrorManager Interface > ErrorManager Properties > ErrorManager.Type Property


ExpressionLimits Interface

ExpressionLimits Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ExpressionLimits object provides access to the various range values that can be specified when defining a custom expression for a column.

Class Hierarchy
Inventor::ExpressionLimits
Visual Basic
Public Interface ExpressionLimits
Inherits IDispatch
Remarks

The range values are equivalent to the UI dialog shown below.

Notes

Members through which this object may be accessed include:

ContentTableColumns.CreateExpressionLimits

You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface


ExpressionLimits Properties

ExpressionLimits Properties
Summary

The properties of the ExpressionLimits class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
DefaultValue | Property that gets and set the default value for this expression.
IncrementValue | Property that gets and set the increment value for this expression.
MaximumValue | Property that gets and set the maximum value for this expression.
MaximumValueComparisonType | Property that gets and set the type of comparison to perform against the maximum value. Valid input is kLessThanComparisonType or kLessThanOrEqualToComparisonType.
MinimumValue | Property that gets and set the minimum value for this expression.
MinimumValueComparisonType | Property that gets and set the type of comparison to perform against the minimum value. Value input is kGreaterThanComparisonType or kGreaterThanOrEqualToComparisonType.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties


ExpressionLimits.Application Property

ExpressionLimits.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.Application Property


ExpressionLimits.DefaultValue Property

ExpressionLimits.DefaultValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the default value for this expression.

Visual Basic
Property DefaultValue() As String
Remarks

The string must be a valid expression and is evaluated using the current document units for the unit type of the column. To specify specific units you should define them as part of the string, i.e. '4.5 in'.

You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.DefaultValue Property


ExpressionLimits.IncrementValue Property

ExpressionLimits.IncrementValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the increment value for this expression.

Visual Basic
Property IncrementValue() As String
Remarks

The string must be a valid expression and is evaluated using the current document units for the unit type of the column. To specify specific units you should define them as part of the string, i.e. '0.25 in'. An empty string indicates there is no increment value.

You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.IncrementValue Property


ExpressionLimits.MaximumValue Property

ExpressionLimits.MaximumValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the maximum value for this expression.

Visual Basic
Property MaximumValue() As String
Remarks

The string must be a valid expression and is evaluated using the current document units for the unit type of the column. To specify specific units you should define them as part of the string, i.e. '10.0 in'. An empty string indicates there is no maximum value.

You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.MaximumValue Property


ExpressionLimits.MaximumValueComparisonType Property

ExpressionLimits.MaximumValueComparisonType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the type of comparison to perform against the maximum value. Valid input is kLessThanComparisonType or kLessThanOrEqualToComparisonType.

Visual Basic
Property MaximumValueComparisonType() As ComparisonTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.MaximumValueComparisonType Property


ExpressionLimits.MinimumValue Property

ExpressionLimits.MinimumValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the minimum value for this expression.

Visual Basic
Property MinimumValue() As String
Remarks

The string must be a valid expression and is evaluated using the current document units for the unit type of the column. To specify specific units you should define them as part of the string, i.e. '0.25 in'. An empty string indicates there is no minimum value.

You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.MinimumValue Property


ExpressionLimits.MinimumValueComparisonType Property

ExpressionLimits.MinimumValueComparisonType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the type of comparison to perform against the minimum value. Value input is kGreaterThanComparisonType or kGreaterThanOrEqualToComparisonType.

Visual Basic
Property MinimumValueComparisonType() As ComparisonTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.MinimumValueComparisonType Property


ExpressionLimits.Type Property

ExpressionLimits.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ExpressionLimits Interface > ExpressionLimits Properties > ExpressionLimits.Type Property


ExpressionList Interface

ExpressionList Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The ExpressionList provides access to a list of possible expressions that can be used for the associated parameter.

Class Hierarchy
Inventor::ExpressionList
Visual Basic
Public Interface ExpressionList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameter.ExpressionList

You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface


ExpressionList Methods

ExpressionList Methods
Summary

The methods of the ExpressionList class are listed here.

Methods
Methods
Name | Description
ClearAll | Method that removes all items from the list.
GetExpressionList | Rreturns an array of Strings that represents the list of expressions used in the list.
SetExpressionList | Method that sets the list of expressions for the parameter this expression list is associated with. The current value of the associated parameter will be modifed to match one of the values in the list. The CurrentValueIndex argument allows you control over which value from the list is used.
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Methods


ExpressionList.ClearAll Method

ExpressionList.ClearAll Method
Summary

Method that removes all items from the list.

Visual Basic
Sub ClearAll()
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Methods > ExpressionList.ClearAll Method


ExpressionList.GetExpressionList Method

ExpressionList.GetExpressionList Method
Summary

Rreturns an array of Strings that represents the list of expressions used in the list.

Visual Basic
Sub GetExpressionList(Result As [out, retval] SAFEARRAY(BSTR))
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Methods > ExpressionList.GetExpressionList Method


ExpressionList.SetExpressionList Method

ExpressionList.SetExpressionList Method
Summary

Method that sets the list of expressions for the parameter this expression list is associated with. The current value of the associated parameter will be modifed to match one of the values in the list. The CurrentValueIndex argument allows you control over which value from the list is used.

Visual Basic
Sub SetExpressionList(ExpressionList As SAFEARRAY(BSTR), ByRef ChangeCurrentValue As [defaultvalue(0)] VARIANT_BOOL, ByRef CurrentValueIndex As [defaultvalue(-1)] long)
Parameters
Parameters | Description
ExpressionList | Input array of Strings that defines a list of valid expressions that the user will be able to select from when setting the value of the associated parameter.
CurrentValueIndex | Input Long value that specifies which value within the expression list should be used as the current value of the parameter." The first value in the expression list is index 0. For a numerical parameter, the default value of -1 will result in the expression that is closest to the current value of the parameter being used." Otherwise the index value specified will be used. For a String parameter, the default value of -1 will result in using the value from the list if there's one that matches the current value of the parameter. If -1 is specified and the current parameter value doesn't match one of the values in the list the first value in the list is used. This method is not valid for Boolean type parameters since they are already limited to True or False.
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Methods > ExpressionList.SetExpressionList Method


ExpressionList Properties

ExpressionList Properties
Summary

The properties of the ExpressionList class are listed here.

Methods
Methods
Name | Description
Item | Property that gets the specified expression in the list.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class ExpressionList.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of expressions in the list.
Parent | Property that returns the parent Parameter object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties


ExpressionList._NewEnum Property

ExpressionList._NewEnum Property
Summary

This is _NewEnum, a member of class ExpressionList.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties > ExpressionList._NewEnum Property


ExpressionList.Application Property

ExpressionList.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties > ExpressionList.Application Property


ExpressionList.Count Property

ExpressionList.Count Property Introduced in Inventor 2011
Summary

Property that specifies the number of expressions in the list.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties > ExpressionList.Count Property


ExpressionList.Item Method

ExpressionList.Item Method Introduced in Inventor 2011
Summary

Property that gets the specified expression in the list.

Visual Basic
Sub Item(Index As long, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Index | Input Long value that specifies the expression to return.
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties > ExpressionList.Item Method


ExpressionList.Parent Property

ExpressionList.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent Parameter object.

Visual Basic
Property Parent() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties > ExpressionList.Parent Property


ExpressionList.Type Property

ExpressionList.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ExpressionList Interface > ExpressionList Properties > ExpressionList.Type Property


ExtendFeature Interface

ExtendFeature Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

For information on this object, please refer to PartFeature, which provides identical or very similar functionality.

Class Hierarchy
Inventor::PartFeature
    Inventor::ExtendFeature
        Inventor::ExtendFeatureProxy
Visual Basic
Public Interface ExtendFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ExtendFeatureProxy.NativeObject

ExtendFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > ExtendFeature Interface


ExtendFeatureProxy Interface

ExtendFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ExtendFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ExtendFeature
        Inventor::ExtendFeatureProxy
Visual Basic
Public Interface ExtendFeatureProxy
Inherits ExtendFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatureProxy Interface


ExtendFeatureProxy Properties

ExtendFeatureProxy Properties
Summary

The properties of the ExtendFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatureProxy Interface > ExtendFeatureProxy Properties


ExtendFeatureProxy.ContainingOccurrence Property

ExtendFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatureProxy Interface > ExtendFeatureProxy Properties > ExtendFeatureProxy.ContainingOccurrence Property


ExtendFeatureProxy.NativeObject Property

ExtendFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ExtendFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatureProxy Interface > ExtendFeatureProxy Properties > ExtendFeatureProxy.NativeObject Property


ExtendFeatures Interface

ExtendFeatures Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

For information on this object, please refer to PartFeatures, which provides identical or very similar functionality.

Class Hierarchy
Inventor::ExtendFeatures
Visual Basic
Public Interface ExtendFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.ExtendFeatures

You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface


ExtendFeatures Methods

ExtendFeatures Methods
Summary

The methods of the ExtendFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface > ExtendFeatures Methods


ExtendFeatures.Item Method

ExtendFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ExtendFeature*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface > ExtendFeatures Methods > ExtendFeatures.Item Method


ExtendFeatures Properties

ExtendFeatures Properties
Summary

The properties of the ExtendFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface > ExtendFeatures Properties


ExtendFeatures.Application Property

ExtendFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface > ExtendFeatures Properties > ExtendFeatures.Application Property


ExtendFeatures.Count Property

ExtendFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface > ExtendFeatures Properties > ExtendFeatures.Count Property


ExtendFeatures.Type Property

ExtendFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ExtendFeatures Interface > ExtendFeatures Properties > ExtendFeatures.Type Property


ExtrudeDefinition Interface

ExtrudeDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

The ExtrudeDefinition object represents all of the information that defines an Extrude feature.

Class Hierarchy
Inventor::ExtrudeDefinition
Visual Basic
Public Interface ExtrudeDefinition
Inherits IDispatch
Remarks

The ExtrudeDefinition object is used in two ways. First it is used as input when creating an Extrude feature. Second it is used to query and edit existing Extrude features.

When creating a new Extrude feature you use the ExtrudeFeatures.CreateExtrudeDefinition method to create a new ExtrudeDefinition object. Using the properties of this object you can define the various options of the Extrude feature. Typically a new ExtrudeDefinition object is created and then modified to get the desired Extrude feature and then used as input to the ExtrudeFeatures.Add method. An existing ExtrudeFeature object is edited by modifying its associated ExtrudeDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface


ExtrudeDefinition Methods

ExtrudeDefinition Methods
Summary

The methods of the ExtrudeDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this ExtrudeDefinition object.
SetDistanceExtent | Method that changes the extents to be “distance” extents.
SetDistanceExtentTwo | Method that sets the second direction extent to be “distance” extents.
SetFromToExtent | Method that changes the extents to be “from and to face” extents.
SetThroughAllExtent | Method that changes the extents to be “through all” extents.
SetToExtent | Method that changes the extents to be “to entity” extents.
SetToNextExtent | Method that changes the extents to be “to next face” extents.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods


ExtrudeDefinition.Copy Method

ExtrudeDefinition.Copy Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a copy of this ExtrudeDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] ExtrudeDefinition*)
Remarks

The new ExtrudeDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new Extrude feature.

One typical use of this method is when you need to make several changes to an existing Extrude feature. If you edit the ExtrudeDefinition object associated with the Extrude feature, the feature will recompute after each edit. It’s more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The ExtrudeFeatures.CreateExtrudeDefinition method can also be used to create an independent ExtrudeDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that’s created with the CreateExtrudeDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.Copy Method


ExtrudeDefinition.SetDistanceExtent Method

ExtrudeDefinition.SetDistanceExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that changes the extents to be “distance” extents.

Visual Basic
Sub SetDistanceExtent(Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Distance | Input Variant that defines the length of the extrusion. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
Remarks

If this method is called on an asymmetric extrude, the second direction extent is removed. To change extent values, use the properties on the object returned by the Extent property.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.SetDistanceExtent Method


ExtrudeDefinition.SetDistanceExtentTwo Method

ExtrudeDefinition.SetDistanceExtentTwo Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the second direction extent to be “distance” extents.

Visual Basic
Sub SetDistanceExtentTwo(Distance As VARIANT)
Parameters
Parameters | Description
Distance | Input Variant that defines the length of the extrusion in the other direction for an asymmetric extrude. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

This method returns an error if the first extent type is not distance extent.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.SetDistanceExtentTwo Method


ExtrudeDefinition.SetFromToExtent Method

ExtrudeDefinition.SetFromToExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that changes the extents to be “from and to face” extents.

Visual Basic
Sub SetFromToExtent(FromFace As IDispatch, ExtendFromFace As VARIANT_BOOL, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL)
Parameters
Parameters | Description
FromFace | Input Object that defines the “from face”. This can be either a Face or WorkPlane object.
ExtendFromFace | Input Boolean that defines whether the “from face” should be extended to contain the extents of the profile.
ToFace | Input Object that defines the “to face”. This can be either a Face or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the “to face” should be extended to contain the extents of the profile.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.SetFromToExtent Method


ExtrudeDefinition.SetThroughAllExtent Method

ExtrudeDefinition.SetThroughAllExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that changes the extents to be “through all” extents.

Visual Basic
Sub SetThroughAllExtent(ExtentDirection As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.SetThroughAllExtent Method


ExtrudeDefinition.SetToExtent Method

ExtrudeDefinition.SetToExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that changes the extents to be “to entity” extents.

Visual Basic
Sub SetToExtent(ToEntity As IDispatch, ByRef ExtendToFace As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
ToEntity | Input Object that defines the “to entity”. This can be one of the following types: • Planar entity: Face or WorkPlane object. • Point entity: Vertex, SketchPoint, SketchPoint3D, WorkPoint or Edge object. If an Edge object is specified, only its mid-point will be used as input. If other points (e.g. start point or end point) of the edge need to be used as input, they have to be specified using the corresponding Vertex object.
ExtendToFace | Optional Input Boolean that defines whether the plane defined by the “to entity” should be extended to contain the extents of the profile. This argument is applicable only if the ToEntity argument is a Face. If no value is explicitly specified, a default value of False will be assumed. If the ToEntity argument is not a Face, this argument will be ignored.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.SetToExtent Method


ExtrudeDefinition.SetToNextExtent Method

ExtrudeDefinition.SetToNextExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that changes the extents to be “to next face” extents.

Visual Basic
Sub SetToNextExtent(ExtentDirection As PartFeatureExtentDirectionEnum, Terminator As SurfaceBody)
Parameters
Parameters | Description
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
Terminator | Input SurfaceBody object that specifies the solid or the surface on which to terminate the extrude.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Methods > ExtrudeDefinition.SetToNextExtent Method


ExtrudeDefinition Properties

ExtrudeDefinition Properties
Summary

The properties of the ExtrudeDefinition class are listed here.

Properties
Name | Description
AffectedBodies | Property that gets and sets the collection of bodies affected by this feature.
AffectedOccurrences | Property that gets and sets the collection of occurrences that should participate in this feature.
Application | Property that returns the root Application object.
Extent | Property that returns the PartFeatureExtent object that defines how the extent of the feature is defined.
ExtentTwo | Property that returns the PartFeatureExtent object that defines how the second direction extent of the feature is defined.
ExtentTwoType | Property that returns an enum indicating how the second direction extent of the feature is defined.
ExtentType | Property that returns an enum indicating how the extent of the feature is defined.
InferiMates | Property that gets and sets whether to automatically place iMates on full circular edges.
IsTwoDirectional | Property that returns whether extents have been defined in two directions for the extrude.
MatchShape | Property that gets and sets how open profiles are handled.
Operation | Property that gets and sets the type of operation used to add the feature to the model.
Parent | Property that returns the parent ExtrudeFeature of this ExtrudeDefinition object.
Profile | Property gets and sets the sketch profile used for the extrude feature.
TaperAngle | Property that provides access to the taper angle of an extrude feature.
TaperAngleTwo | Property that provides access to the second direction taper angle of an asymmetric extrude feature.
Type | Property returning kExtrudeDefinitionObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties


ExtrudeDefinition.AffectedBodies Property

ExtrudeDefinition.AffectedBodies Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the collection of bodies affected by this feature.

Visual Basic
Property AffectedBodies() As ObjectCollection*
Remarks

If this property is not set for multi-body parts, the default solid body is used as the affected body. This property applies only to features in a part.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.AffectedBodies Property


ExtrudeDefinition.AffectedOccurrences Property

ExtrudeDefinition.AffectedOccurrences Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the collection of occurrences that should participate in this feature.

Visual Basic
Property AffectedOccurrences() As ObjectCollection*
Remarks

If this property is not set, all possible occurrences will participate. This property applies only to features in an assembly.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.AffectedOccurrences Property


ExtrudeDefinition.Application Property

ExtrudeDefinition.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.Application Property


ExtrudeDefinition.Extent Property

ExtrudeDefinition.Extent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the PartFeatureExtent object that defines how the extent of the feature is defined.

Visual Basic
Property Extent() As PartFeatureExtent**
Remarks

The type of extent object returned can be determined by using the ExtentType property. When the ExtrudeDefinition object is created using ExtrudeFeatures.CreateExtrudeDefinition, this extent defaults to the distance extent type with the distance value initialized to “1.0 in.”

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.Extent Property


ExtrudeDefinition.ExtentTwo Property

ExtrudeDefinition.ExtentTwo Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the PartFeatureExtent object that defines how the second direction extent of the feature is defined.

Visual Basic
Property ExtentTwo() As PartFeatureExtent**
Remarks

The type of extent object returned can be determined by using the ExtentTwoType property. This property returns an error if the IsTwoDirectional property returns False.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.ExtentTwo Property


ExtrudeDefinition.ExtentTwoType Property

ExtrudeDefinition.ExtentTwoType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns an enum indicating how the second direction extent of the feature is defined.

Visual Basic
Property ExtentTwoType() As PartFeatureExtentEnum*
Remarks

This indicates the type of object returned by the Extent property. This property returns an error if the IsTwoDirectional property returns False.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.ExtentTwoType Property


ExtrudeDefinition.ExtentType Property

ExtrudeDefinition.ExtentType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns an enum indicating how the extent of the feature is defined.

Visual Basic
Property ExtentType() As PartFeatureExtentEnum*
Remarks

This indicates the type of object returned by the Extent property. When the ExtrudeDefinition object is created using ExtrudeFeatures.CreateExtrudeDefinition, this extent type defaults to the distance extent type.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.ExtentType Property


ExtrudeDefinition.InferiMates Property

ExtrudeDefinition.InferiMates Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to automatically place iMates on full circular edges.

Visual Basic
Property InferiMates() As VARIANT_BOOL
Remarks

If set to True, Inventor places the iMates on closed loops most likely to be useful. This property defaults to False and is only applicable when creating the feature.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.InferiMates Property


ExtrudeDefinition.IsTwoDirectional Property

ExtrudeDefinition.IsTwoDirectional Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns whether extents have been defined in two directions for the extrude.

Visual Basic
Property IsTwoDirectional() As VARIANT_BOOL*
Remarks

If this property returns True, the ExtentTwoType and ExtentTwo properties can be used to query details about the second direction extent. When the ExtrudeDefinition object is created using ExtrudeFeatures.CreateExtrudeDefinition, this property defaults to False.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.IsTwoDirectional Property


ExtrudeDefinition.MatchShape Property

ExtrudeDefinition.MatchShape Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets how open profiles are handled.

Visual Basic
Property MatchShape() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.MatchShape Property


ExtrudeDefinition.Operation Property

ExtrudeDefinition.Operation Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the type of operation used to add the feature to the model.

Visual Basic
Property Operation() As PartFeatureOperationEnum
Remarks

Valid inputs are kNewBodyOperation, kJoinOperation, kCutOperation, kIntersectOperation and kSurfaceOperation.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.Operation Property


ExtrudeDefinition.Parent Property

ExtrudeDefinition.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent ExtrudeFeature of this ExtrudeDefinition object.

Visual Basic
Property Parent() As ExtrudeFeature**
Remarks

In the case where this is a newly created ExtrudeDefinition object or it has been copied from an existing ExtrudeDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.Parent Property


ExtrudeDefinition.Profile Property

ExtrudeDefinition.Profile Property Available in Inventor Introduced in Inventor 2012
Summary

Property gets and sets the sketch profile used for the extrude feature.

Visual Basic
Property Profile() As Profile*
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.Profile Property


ExtrudeDefinition.TaperAngle Property

ExtrudeDefinition.TaperAngle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the taper angle of an extrude feature.

Visual Basic
Property TaperAngle() As VARIANT
Remarks

If not supplied, the feature will be created with a taper angle of zero. This property is writable when the ExtrudeDefinition object has been created using the ExtrudeFeatures.CreateExtrudeDefinition or ExtrudeDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyTaperAngle * 2” is valid, assuming there is a parameter named MyTaperAngle.

When the ExtrudeDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the taper angle. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.TaperAngle Property


ExtrudeDefinition.TaperAngleTwo Property

ExtrudeDefinition.TaperAngleTwo Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the second direction taper angle of an asymmetric extrude feature.

Visual Basic
Property TaperAngleTwo() As VARIANT
Remarks

This property is not applicable and returns an error if the IsTwoDirectional property is False. If not supplied, the feature will be created with a taper angle of zero. This property is writable when the ExtrudeDefinition object has been created using the ExtrudeFeatures.CreateExtrudeDefinition or ExtrudeDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyTaperAngle * 2” is valid, assuming there is a parameter named MyTaperAngle.

When the ExtrudeDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the taper angle. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.TaperAngleTwo Property


ExtrudeDefinition.Type Property

ExtrudeDefinition.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kExtrudeDefinitionObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeDefinition Interface > ExtrudeDefinition Properties > ExtrudeDefinition.Type Property


ExtrudeFeature Interface

ExtrudeFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ExtrudeFeature object represents extruded modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::ExtrudeFeature
        Inventor::ExtrudeFeatureProxy
Visual Basic
Public Interface ExtrudeFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ExtrudeFeatureProxy.NativeObject

ExtrudeFeatures.AddByDistanceExtent

ExtrudeFeatures.AddByFromToExtent

ExtrudeFeatures.AddByThroughAllExtent

ExtrudeFeatures.AddByToExtent

ExtrudeFeatures.AddByToFaceExtent

ExtrudeFeatures.AddByToNextExtent

ExtrudeFeatures.Item

See Also

Create sheet metal rip feature sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Share sample

Edit profile of an extrude feature sample

Thread Feature Create sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Add a decal feature sample

Delete Face, Boundary Patch and Stitch features. sample

Example

"Extrude Feature - Create Block with Pocket Example"

This sample demonstrates creating a simple solid consisting a block with a pocket. It shows how to create a sketch plane at a specified orientation to existing geometry.

Public Sub DrawBlockWithPocket()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.  Since it's being created on
    ' one of the base workplanes we know the orientation it will be created in
    ' and don't need to worry about controlling it.  Because of this we also
    ' know the origin of the sketch plane will be at (0,0,0) in model space.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Dim oRectangleLines As SketchEntitiesEnumerator
    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a base extrusion 1cm thick.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfile, 1, kNegativeExtentDirection, kJoinOperation)

    ' Get the top face of the extrusion to use for creating the new sketch.
    Dim oFrontFace As Face
    Set oFrontFace = oExtrude.StartFaces.Item(1)

    ' Create a new sketch on this face, but use the method that allows you to
    ' control the orientation and orgin of the new sketch.
    Set oSketch = oCompDef.Sketches.AddWithOrientation(oFrontFace, _
                    oCompDef.WorkAxes.Item(1), True, True, oCompDef.WorkPoints(1))

    ' Determine where in sketch space the point (0.5,0.5,0) is.
    Dim oCorner As Point2d
    Set oCorner = oSketch.ModelToSketchSpace(oTransGeom.CreatePoint(0.5, 0.5, 0))

    ' Create the interior 3cm x 2cm rectangle for the pocket.
    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
                oCorner, oTransGeom.CreatePoint2d(oCorner.X + 3, oCorner.Y + 2))

    ' Create a profile.
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a pocket .25 cm deep.
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfile, 0.25, kNegativeExtentDirection, kCutOperation)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface


ExtrudeFeature Methods

ExtrudeFeature Methods
Summary

The methods of the ExtrudeFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Method that adds the specified participant to the assembly feature. This method fails for features in a part.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Methods


ExtrudeFeature.AddParticipant Method

ExtrudeFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that adds the specified participant to the assembly feature. This method fails for features in a part.

Visual Basic
Sub AddParticipant(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the participant to be added. An error occurs if the input ComponentOccurrence is not a leaf occurrence.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Methods > ExtrudeFeature.AddParticipant Method


ExtrudeFeature Properties

ExtrudeFeature Properties
Summary

The properties of the ExtrudeFeature class are listed here.

Properties
Name | Description
Definition | This is Definition, a member of class ExtrudeFeature.
EndFaces | Property that returns the set of that cap one end of the extrusion.
SideFaces | Property that returns a object that provides access to all of the faces created around the perimeter of the feature.
StartFaces | Property that returns the set of that cap one end of the extrusion and are coincident with the sketch plane. In the case of a symmetric extrusion these faces are the ones on the positive normal side of the sketch plane. In the case where there aren't any start faces this property will return Nothing.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Properties


ExtrudeFeature.Definition Property

ExtrudeFeature.Definition Property
Summary

This is Definition, a member of class ExtrudeFeature.

Visual Basic
Property Definition() As ExtrudeDefinition*
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Properties > ExtrudeFeature.Definition Property


ExtrudeFeature.EndFaces Property

ExtrudeFeature.EndFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of that cap one end of the extrusion.

Visual Basic
Property EndFaces() As Faces**
Remarks

The end faces are the face not coincident with the sketch plane of the feature's profile. In the case of a symmetric extrusion these faces are the ones on the negative normal side of the sketch plane. In the cases where there aren't any end faces this property will return Nothing.

See Also

Thread Feature Create sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Highlight Feature Faces sample

Fillet Feature (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Properties > ExtrudeFeature.EndFaces Property


ExtrudeFeature.SideFaces Property

ExtrudeFeature.SideFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a object that provides access to all of the faces created around the perimeter of the feature.

Visual Basic
Property SideFaces() As Faces**
See Also

Create sheet metal rip feature sample

Thread Feature Create sample

Sketch from face silhouette sample

Highlight Feature Faces sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Properties > ExtrudeFeature.SideFaces Property


ExtrudeFeature.StartFaces Property

ExtrudeFeature.StartFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of that cap one end of the extrusion and are coincident with the sketch plane. In the case of a symmetric extrusion these faces are the ones on the positive normal side of the sketch plane. In the case where there aren't any start faces this property will return Nothing.

Visual Basic
Property StartFaces() As Faces**
See Also

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Highlight Feature Faces sample

Fillet Feature (Simple) sample

Fillet Feature (Complex) sample

Extrude Feature - Create Block with Pocket sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeature Interface > ExtrudeFeature Properties > ExtrudeFeature.StartFaces Property


ExtrudeFeatureProxy Interface

ExtrudeFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ExtrudeFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ExtrudeFeature
        Inventor::ExtrudeFeatureProxy
Visual Basic
Public Interface ExtrudeFeatureProxy
Inherits ExtrudeFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatureProxy Interface


ExtrudeFeatureProxy Properties

ExtrudeFeatureProxy Properties
Summary

The properties of the ExtrudeFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatureProxy Interface > ExtrudeFeatureProxy Properties


ExtrudeFeatureProxy.ContainingOccurrence Property

ExtrudeFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatureProxy Interface > ExtrudeFeatureProxy Properties > ExtrudeFeatureProxy.ContainingOccurrence Property


ExtrudeFeatureProxy.NativeObject Property

ExtrudeFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ExtrudeFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatureProxy Interface > ExtrudeFeatureProxy Properties > ExtrudeFeatureProxy.NativeObject Property


ExtrudeFeatures Interface

ExtrudeFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ExtrudeFeatures collection object provides access to all of the ExtrudeFeature object in a part component definition and provides methods to create additional ExtrudeFeatures.

Class Hierarchy
Inventor::ExtrudeFeatures
Visual Basic
Public Interface ExtrudeFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.ExtrudeFeatures

FlatPatternFeatures.ExtrudeFeatures

PartFeatures.ExtrudeFeatures

See Also

Create sheet metal rip feature sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Share sample

Edit profile of an extrude feature sample

Thread Feature Create sample

SurfaceBody Copy sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Add a decal feature sample

Example 1

See ExtrudeFeature for example "Simple extrude feature"

Example 2

See ExtrudeFeatures::AddByDistanceExtent for example "Extrude text"

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface


ExtrudeFeatures Methods

ExtrudeFeatures Methods
Summary

The methods of the ExtrudeFeatures class are listed here.

Methods
Methods
Name | Description
Add | This is Add, a member of class ExtrudeFeatures.
AddByToFaceExtent | Method that creates a new using 'to face' extents. The new ExtrudeFeature is returned.
CreateExtrudeDefinition | This is CreateExtrudeDefinition, a member of class ExtrudeFeatures.
Item | Returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Methods


ExtrudeFeatures.Add Method

ExtrudeFeatures.Add Method
Summary

This is Add, a member of class ExtrudeFeatures.

Visual Basic
Sub Add(Definition As ExtrudeDefinition, Result As [out, retval] ExtrudeFeature*)
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Methods > ExtrudeFeatures.Add Method


ExtrudeFeatures.AddByToFaceExtent Method

ExtrudeFeatures.AddByToFaceExtent Method Available in Inventor Available in Server
Summary

Method that creates a new using 'to face' extents. The new ExtrudeFeature is returned.

Visual Basic
Sub AddByToFaceExtent(Profile As Profile, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, Operation As PartFeatureOperationEnum, ByRef TaperAngle As [optional] VARIANT, Result As [out, retval] ExtrudeFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the extrusion. If the Operation argument is anything except kSurfaceOperation, then the input profile must have closed paths. Open paths are valid when creating surfaces.
ToFace | Input Object that defines the 'to face.' This can be either a faces collection or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
TaperAngle | Optional Input Variant that defines the angle of the taper. If not supplied, the feature will be created with a taper angle of zero. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
Example

See ExtrudeFeatures::AddByDistanceExtent for example "AddByDistanceExtent Method"

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Methods > ExtrudeFeatures.AddByToFaceExtent Method


ExtrudeFeatures.CreateExtrudeDefinition Method

ExtrudeFeatures.CreateExtrudeDefinition Method
Summary

This is CreateExtrudeDefinition, a member of class ExtrudeFeatures.

Visual Basic
Sub CreateExtrudeDefinition(Profile As Profile, Operation As PartFeatureOperationEnum, Result As [out, retval] ExtrudeDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Methods > ExtrudeFeatures.CreateExtrudeDefinition Method


ExtrudeFeatures.Item Method

ExtrudeFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ExtrudeFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
See Also

Sketch Share sample

You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Methods > ExtrudeFeatures.Item Method


ExtrudeFeatures Properties

ExtrudeFeatures Properties
Summary

The properties of the ExtrudeFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Properties


ExtrudeFeatures.Application Property

ExtrudeFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Properties > ExtrudeFeatures.Application Property


ExtrudeFeatures.Count Property

ExtrudeFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Properties > ExtrudeFeatures.Count Property


ExtrudeFeatures.Type Property

ExtrudeFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ExtrudeFeatures Interface > ExtrudeFeatures Properties > ExtrudeFeatures.Type Property


Face Interface

Face Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Face object. See the article in the overviews section.

Class Hierarchy
Inventor::Face
    Inventor::FaceProxy
Visual Basic
Public Interface Face
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DecalFeature.Face

DistanceAndAngleChamferDef.Face

EdgeLoop.Face

EmbossFeature.WrapFace

Face.GetSourceFace

FaceProxy.NativeObject

Faces.Item

FlatPattern.BaseFace

FlatPattern.BottomFace

FlatPattern.TopFace

LineAndFaceWorkPointDef.Face

LineAndTangentWorkPlaneDef.Face

LoftFeature.EndFace

LoftFeature.StartFace

PlaneAndTangentWorkPlaneDef.Face

PointAndTangentWorkPlaneDef.Face

RefoldFeature.StationaryFace

RevolvedFaceWorkAxisDef.Face

RipDefinition.RipFace

SurfaceGraphicsFace.Face

TorusCenterPointWorkPointDef.Face

TorusMidPlaneWorkPlaneDef.Face

TwoDistancesChamferDef.Face

UnfoldFeature.StationaryFace

CircularPatternFeature.AxisEntity

ConcentricHolePlacementDefinition.ConcentricReference

PointHolePlacementDefinition.Direction

AngleiMateDefinition.Entity

CurveAndEntityWorkPointDef.Entity

FlushiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

LoftDefinition.FirstSectionTangentPlane

FromToWidthExtent.FromEntity

FromToExtent.FromFace

LoftDefinition.LastSectionTangentPlane

MirrorFeature.MirrorPlaneEntity

OffsetWidthExtent.OffsetEntityOne

OffsetWidthExtent.OffsetEntityTwo

PlanarSketch.PlanarEntity

ConcentricHolePlacementDefinition.Plane

LineAndPlaneWorkAxisDef.Plane

LinearHolePlacementDefinition.Plane

LinePlaneAndAngleWorkPlaneDef.Plane

PlaneAndOffsetWorkPlaneDef.Plane

PlaneAndPointWorkPlaneDef.Plane

PlaneAndTangentWorkPlaneDef.Plane

PointAndPlaneDistanceDimConstraint3D.Plane

PointAndPlaneWorkAxisDef.Plane

ThreePlanesWorkPointDef.Plane1

TwoPlanesWorkAxisDef.Plane1

TwoPlanesWorkPlaneDef.Plane1

ThreePlanesWorkPointDef.Plane2

TwoPlanesWorkAxisDef.Plane2

TwoPlanesWorkPlaneDef.Plane2

ThreePlanesWorkPointDef.Plane3

FaceDraftFeature.PullDirection

DraftAnalysis.PullDirection

NormalToSurfaceWorkAxisDef.SurfaceEntity

FromToWidthExtent.ToEntity

ToExtent.ToEntity

ToExtent.ToFace

FromToExtent.ToFace

RectangularPatternFeature.XDirectionEntity

RectangularPatternFeature.YDirectionEntity

See Also

Create sheet metal rip feature sample

Sketch Edit Orientation sample

Thread Feature Create sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Reference keys sample

Add a punch tool feature sample

Sketch Add Oriented sample

Sketch Add sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Add a decal feature sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > Face Interface


Face Methods

Face Methods
Summary

The methods of the Face class are listed here.

Methods
Methods
Name | Description
CalculateFacets | Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.
CalculateFacetsAndTextureMap | Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.
CalculateStrokes | Obtain the stroked or polygonal representation for the given chord-height tolerance. Client to deallocate pointers with CoTaskMemFree.
GetClosestPointTo | Method that returns a point on the face that is closest to the input point. A single point is returned even if multiple equidistant points are found. To get the u-v parameters of the returned point on the face, use Face.Evaluator.GetParamAtPoint method.
GetExistingFacets | Obtain the facetted representation for the given chord-height tolerance as. Fails if the tolerance supplied is not pre-existing.
GetExistingFacetsAndTextureMap | Method that returns the specified set of existing display facets. Existing display facets are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateFacets method which will calculate new facets to a given tolerance at double-precision accuracy.
GetExistingFacetTolerances | Method that gets the tolerances that were used to calculate the existing sets of display facets. These can be used to determine if any existing facets have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing facets to retrieve when using the GetExistingFacets method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to facets. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.
GetExistingStrokes | Method that returns the specified set of strokes from the SurfaceBody, Face or Edge the method was called from. Existing strokes are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateStrokes method, which will calculate new strokes to a given tolerance at double-precision accuracy. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load... more
GetExistingStrokeTolerances | Method that gets the tolerances that were used to calculate the existing sets of display strokes. These can be used to determine if any existing strokes have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing strokes to retrieve when using the GetExistingStrokes method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetRenderStyle | This method returns the render style currently used for this object. The used for an object can be specified in two ways. First, the object can inherit the RenderStyle defined for the part. Second, a RenderStyle can be explicitly assigned to the object (feature, face..).
GetSourceFace | Method that gets the source face that has been overridden by this face. The method returns Nothing if this face is not an override. An error is returned if this method is called on a face in a part.
GetTextureScale | This is GetTextureScale, a member of class Face.
SetRenderStyle | This method sets the render style to use for this object (feature, face, etc.). The used for an object can be specified in two ways. The object can inherit the RenderStyle defined for the part, or a RenderStyle can be explicitly assigned to the object.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods


Face.CalculateFacets Method

Face.CalculateFacets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.

Visual Basic
Sub CalculateFacets(Tolerance As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.CalculateFacets Method


Face.CalculateFacetsAndTextureMap Method

Face.CalculateFacetsAndTextureMap Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.

Visual Basic
Sub CalculateFacetsAndTextureMap(Tolerance As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long), ByRef TextureCoordinates As SAFEARRAY(double))
Parameters
Parameters | Description
Tolerance | Input Double that specifies the tolerance.
VertexCount | Output Long that returns the number of vertices that were generated. This is the number of vertices that will be returned by the VertexCoordinates argument.
FacetCount | Output Long that returns the number of facets that were generated.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
NormalVectors | Output array of Doubles that contains the components of the vertex normals. A normal is returned for each vertex. The normal is the normal of the actual surface at the position of the vertex.
VertexIndices | Output array of Longs that are used to index into the vertex coordinates array. These indices provide the information that defines how the vertices are connected to create the triangular facets.
TextureCoordinates | Output array of Doubles that contains the coordinates of the texture map.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.CalculateFacetsAndTextureMap Method


Face.CalculateStrokes Method

Face.CalculateStrokes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Obtain the stroked or polygonal representation for the given chord-height tolerance. Client to deallocate pointers with CoTaskMemFree.

Visual Basic
Sub CalculateStrokes(Tolerance As double, ByRef VertexCount As long, ByRef SegmentCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.CalculateStrokes Method


Face.GetClosestPointTo Method

Face.GetClosestPointTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns a point on the face that is closest to the input point. A single point is returned even if multiple equidistant points are found. To get the u-v parameters of the returned point on the face, use Face.Evaluator.GetParamAtPoint method.

Visual Basic
Sub GetClosestPointTo(InputPoint As Point, Result As [out, retval] Point*)
Parameters
Parameters | Description
InputPoint | Point object that specifies the point for which the closest point on the face is to be located. If the input point lies on the Face, the coordinates of the input point are returned.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetClosestPointTo Method


Face.GetExistingFacets Method

Face.GetExistingFacets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Obtain the facetted representation for the given chord-height tolerance as. Fails if the tolerance supplied is not pre-existing.

Visual Basic
Sub GetExistingFacets(ToleranceIndex As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetExistingFacets Method


Face.GetExistingFacetsAndTextureMap Method

Face.GetExistingFacetsAndTextureMap Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified set of existing display facets. Existing display facets are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateFacets method which will calculate new facets to a given tolerance at double-precision accuracy.

Visual Basic
Sub GetExistingFacetsAndTextureMap(ToleranceIndex As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long), ByRef TextureCoordinates As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceIndex | Input Double that serves as an index as to which set of existing facets you want to retrieve. If the input tolerance does not match an existing set an error will occur. The tolerances for existing facets can be obtained using the GetExistingFacetTolerances method.
VertexCount | Output Long that returns the number of vertices that were generated for the facets. This is the number of vertices that will be returned by the VertexCoordinates argument.
FacetCount | Output Long that returns the number of facets that were generated.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
NormalVectors | Output array of Doubles that contains the components of the vertex normals. A normal is returned for each vertex. The normal is the normal of the actual surface at the position of the vertex.
VertexIndices | Output array of Doubles that are used to index into the vertex coordinates array. These indices provide the information that defines how the vertices are connected to create the triangular facets.
TextureCoordinates | Output array of Doubles that contains the coordinates of the texture map.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetExistingFacetsAndTextureMap Method


Face.GetExistingFacetTolerances Method

Face.GetExistingFacetTolerances Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that gets the tolerances that were used to calculate the existing sets of display facets. These can be used to determine if any existing facets have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing facets to retrieve when using the GetExistingFacets method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to facets. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingFacetTolerances(ByRef ToleranceCount As long, ByRef ExistingTolerances As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceCount | Output Long that specifies the number of existing facet sets.
ExistingTolerances | Output array of Doubles that contains the tolerances that were used to compute the existing sets of display facets.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetExistingFacetTolerances Method


Face.GetExistingStrokes Method

Face.GetExistingStrokes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified set of strokes from the SurfaceBody, Face or Edge the method was called from. Existing strokes are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateStrokes method, which will calculate new strokes to a given tolerance at double-precision accuracy. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingStrokes(ToleranceIndex As double, ByRef VertexCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef PolylineCount As long, ByRef PolylineLengths As SAFEARRAY(long))
Parameters
Parameters | Description
ToleranceIndex | Input Double that serves as an index into which set of existing strokes you want to retrieve. If the input tolerance does not match an existing set an error will occur. The tolerances for existing strokes can be obtained using the GetExistingStrokeTolerances method.
VertexCount | Output Long that returns the number of vertices that were generated for the facets. This is the number of vertices that will be returned by the VertexCoordinates argument.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
PolylineCount | Output Long that specifies the number of polylines that are represented by the strokes.
PolylineLengths | Output array of Longs that specifies the number of vertices that are used for each polyline.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetExistingStrokes Method


Face.GetExistingStrokeTolerances Method

Face.GetExistingStrokeTolerances Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that gets the tolerances that were used to calculate the existing sets of display strokes. These can be used to determine if any existing strokes have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing strokes to retrieve when using the GetExistingStrokes method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingStrokeTolerances(ByRef ToleranceCount As long, ByRef ExistingTolerances As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceCount | Output Long that specifies the number of existing stroke sets.
ExistingTolerances | Output array of Doubles that contains the tolerances that were used to compute the existing sets of display strokes.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetExistingStrokeTolerances Method


Face.GetReferenceKey Method

Face.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetReferenceKey Method


Face.GetRenderStyle Method

Face.GetRenderStyle Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 7
Summary

This method returns the render style currently used for this object. The used for an object can be specified in two ways. First, the object can inherit the RenderStyle defined for the part. Second, a RenderStyle can be explicitly assigned to the object (feature, face..).

Visual Basic
Sub GetRenderStyle(ByRef StyleSourceType As StyleSourceTypeEnum, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
StyleSourceType | Output that specifies how the render style that is used for the face was obtained. This can be kPartRenderStyle in the case where the face will use the render style assigned to the part, kFeatureRenderStyle in the case where the face will use the render style assigned to its creating feature, or kOverrideRenderStyle where a render style has been explicitly assigned to the face.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetRenderStyle Method


Face.GetSourceFace Method

Face.GetSourceFace Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that gets the source face that has been overridden by this face. The method returns Nothing if this face is not an override. An error is returned if this method is called on a face in a part.

Visual Basic
Sub GetSourceFace(ByRef GetLeafSource As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Face*)
Parameters
Parameters | Description
GetLeafSource | Optional input Boolean that specifies whether to get the 'leaf' source face in the case where there are multiple levels of override. If specified to be False, the method returns the next level override face. If not specified, the argument defaults to True indicating that the leaf source will be returned.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetSourceFace Method


Face.GetTextureScale Method

Face.GetTextureScale Method
Summary

This is GetTextureScale, a member of class Face.

Visual Basic
Sub GetTextureScale(ByRef UScale As double, ByRef VScale As double)
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.GetTextureScale Method


Face.SetRenderStyle Method

Face.SetRenderStyle Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 7
Summary

This method sets the render style to use for this object (feature, face, etc.). The used for an object can be specified in two ways. The object can inherit the RenderStyle defined for the part, or a RenderStyle can be explicitly assigned to the object.

Visual Basic
Sub SetRenderStyle(StyleSourceType As StyleSourceTypeEnum, ByRef RenderStyle As [optional] VARIANT)
Parameters
Parameters | Description
StyleSourceType | Input that specifies how the render style for the feature will be defined. This can be either kPartRenderStyle in the case where the feature will use the render style assigned to the part, and kOverrideRenderStyle where a render style will be explicitly assigned to the feature.
RenderStyle | Optional input object that is the render style to use for this face. This argument only used in the case where the StyleSourceType is kOverrideRenderStyle. For other style source types, this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Methods > Face.SetRenderStyle Method


Face Properties

Face Properties
Summary

The properties of the Face class are listed here.

Methods
Methods
Name | Description
AlternateBody | Property that returns the alternate SurfaceBody.
Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
CreatedByFeature | Property that returns the feature that resulted in the creation of this face. This property is not currently supported for FaceProxy objects and will return Nothing in those cases. It is also not currently supported for Assembly Features and will fail in that case.
EdgeLoops | Gets the collection referenced by this Face.
Edges | Gets the referenced by this Face.
Evaluator | Gets the surface evaluator for this face.
FaceShell | Property that returns the FaceShell object.
Geometry | Property that returns the underlying geometry of the face.
GeometryForm | Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.
HasReferenceComponent | Property that specifies if the object was created as the result of a derived part.
InternalName | Property that returns a unique string identifying this face. This identifier is valid only so long as there are no further modifications to the face.
IsParamReversed | Gets whether the parameterization of the geometry obtained from the Geometry property is aligned or opposed to the topological sense of this Face.
Parent | Property that returns the parent object from whom this object can logically be reached.
PointOnFace | Property that returns a characteristic somewhere on the interior of the Face.
ReferenceComponent | Property that returns the ReferenceComponent that resulted in the creation of this feature.
ReferencedEntity | Property that returns the referenced face(s) from the source part. This could be a proxy object in case of a derived assembly. The property returns Nothing if there isn't a referenced entity.
SurfaceBody | Property that returns the associated with this object or feature.
SurfaceType | Property that returns a SurfaceTypeEnum that specifies the surface type for this Face.
TangentiallyConnectedFaces | Property that returns a FaceCollection that contains the input face and all tangentially connected faces. The CollectionType of the output FaceCollection is set to kFaceTangentiallyConnected.
TextureMaps | Gets the texture maps associated with this face.
ThreadInfos | Property that returns a ThreadInfo object for each thread affecting this face.
TransientKey | Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.
Type | Property returning an enum indicating this object's type.
Vertices | Gets the vertices for this Face.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties


Face.AlternateBody Method

Face.AlternateBody Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the alternate SurfaceBody.

Visual Basic
Sub AlternateBody(AlternateForm As long, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
AlternateForm | Input Long that specifies the requested alternate form as a combination of values.
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.AlternateBody Method


Face.Application Property

Face.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Application Property


Face.AttributeSets Property

Face.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.AttributeSets Property


Face.CreatedByFeature Property

Face.CreatedByFeature Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the feature that resulted in the creation of this face. This property is not currently supported for FaceProxy objects and will return Nothing in those cases. It is also not currently supported for Assembly Features and will fail in that case.

Visual Basic
Property CreatedByFeature() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.CreatedByFeature Property


Face.EdgeLoops Property

Face.EdgeLoops Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the collection referenced by this Face.

Visual Basic
Property EdgeLoops() As EdgeLoops**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.EdgeLoops Property


Face.Edges Property

Face.Edges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the referenced by this Face.

Visual Basic
Property Edges() As Edges**
See Also

Create sheet metal face and fold features sample

Sketch Add Oriented sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Edges Property


Face.Evaluator Property

Face.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this face.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
See Also

Is cylindrical face interior or exterior? sample

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Evaluator Property


Face.FaceShell Property

Face.FaceShell Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the FaceShell object.

Visual Basic
Property FaceShell() As FaceShell**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.FaceShell Property


Face.Geometry Property

Face.Geometry Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the underlying geometry of the face.

Visual Basic
Property Geometry() As IDispatch**
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Geometry Property


Face.GeometryForm Property

Face.GeometryForm Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.

Visual Basic
Property GeometryForm() As long*
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.GeometryForm Property


Face.HasReferenceComponent Property

Face.HasReferenceComponent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if the object was created as the result of a derived part.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
Remarks

This property returns True in the case where the object is from a derived part (so it belongs to a ReferenceComponent). In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case. If the HasReferenceComponent property is False, the ReferenceComponent property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.HasReferenceComponent Property


Face.InternalName Property

Face.InternalName Property Available in Apprentice
Summary

Property that returns a unique string identifying this face. This identifier is valid only so long as there are no further modifications to the face.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.InternalName Property


Face.IsParamReversed Property

Face.IsParamReversed Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the parameterization of the geometry obtained from the Geometry property is aligned or opposed to the topological sense of this Face.

Visual Basic
Property IsParamReversed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.IsParamReversed Property


Face.Parent Property

Face.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Parent Property


Face.PointOnFace Property

Face.PointOnFace Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a characteristic somewhere on the interior of the Face.

Visual Basic
Property PointOnFace() As Point**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.PointOnFace Property


Face.ReferenceComponent Property

Face.ReferenceComponent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the ReferenceComponent that resulted in the creation of this feature.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
Remarks

If the object belongs to a derived part, a DerivedPartComponent will be returned. If the object belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.ReferenceComponent Property


Face.ReferencedEntity Property

Face.ReferencedEntity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the referenced face(s) from the source part. This could be a proxy object in case of a derived assembly. The property returns Nothing if there isn't a referenced entity.

Visual Basic
Property ReferencedEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.ReferencedEntity Property


Face.SurfaceBody Property

Face.SurfaceBody Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the associated with this object or feature.

Visual Basic
Property SurfaceBody() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.SurfaceBody Property


Face.SurfaceType Property

Face.SurfaceType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a SurfaceTypeEnum that specifies the surface type for this Face.

Visual Basic
Property SurfaceType() As SurfaceTypeEnum*
See Also

Add a punch tool feature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.SurfaceType Property


Face.TangentiallyConnectedFaces Property

Face.TangentiallyConnectedFaces Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a FaceCollection that contains the input face and all tangentially connected faces. The CollectionType of the output FaceCollection is set to kFaceTangentiallyConnected.

Visual Basic
Property TangentiallyConnectedFaces() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.TangentiallyConnectedFaces Property


Face.TextureMaps Property

Face.TextureMaps Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the texture maps associated with this face.

Visual Basic
Property TextureMaps() As TextureMaps**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.TextureMaps Property


Face.ThreadInfos Property

Face.ThreadInfos Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a ThreadInfo object for each thread affecting this face.

Visual Basic
Property ThreadInfos() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.ThreadInfos Property


Face.TransientKey Property

Face.TransientKey Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.

Visual Basic
Property TransientKey() As long*
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.TransientKey Property


Face.Type Property

Face.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Type Property


Face.Vertices Property

Face.Vertices Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the vertices for this Face.

Visual Basic
Property Vertices() As Vertices**
You are here: Symbol Reference > Inventor Library > Objects > Face Interface > Face Properties > Face.Vertices Property


FaceCollection Interface

FaceCollection Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

The FaceCollection object is a transient object created by the CreateFaceCollection method of the TransientObjects object. Typically used when creating a ShellFeature, FaceDraftFeature, etc.

Class Hierarchy
Inventor::ObjectsEnumerator
    Inventor::ObjectCollection
        Inventor::FaceCollection
Visual Basic
Public Interface FaceCollection
Inherits ObjectCollection
Notes

Members through which this object may be accessed include:

Face.TangentiallyConnectedFaces

FaceDraftFeature.InputFaces

FilletConstantRadiusFaceSet.FacesOne

FilletConstantRadiusFaceSet.FacesTwo

FilletFullRoundSet.CenterFaces

FilletFullRoundSet.SideFacesOne

FilletFullRoundSet.SideFacesTwo

MoveFaceDefinition.Faces

ShellDefinition.InputFaces

ShellThicknessFaceSet.Faces

TransientObjects.CreateFaceCollection

DeleteFaceFeature.InputFaces

ThickenFeature.InputFaces

See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > FaceCollection Interface


FaceCollection Properties

FaceCollection Properties
Summary

The properties of the FaceCollection class are listed here.

Properties
Name | Description
CollectionType | Property returning a constant indicating the Face Collection type.
You are here: Symbol Reference > Inventor Library > Objects > FaceCollection Interface > FaceCollection Properties


FaceCollection.CollectionType Property

FaceCollection.CollectionType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning a constant indicating the Face Collection type.

Visual Basic
Property CollectionType() As FaceCollectionEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceCollection Interface > FaceCollection Properties > FaceCollection.CollectionType Property


FaceDefinition Interface

FaceDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FaceDefinition represents a transient definition of a Face object.

Class Hierarchy
Inventor::FaceDefinition
Visual Basic
Public Interface FaceDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeDefinition.FaceOne

EdgeDefinition.FaceTwo

FaceDefinitions.Add

FaceDefinitions.Item

See Also

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface


FaceDefinition Properties

FaceDefinition Properties
Summary

The properties of the FaceDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AssociativeID | Property that gets and sets the associate ID of this face. This ID will be transferred to the corresponding face when this SurfaceBodyDefinition is used to create a SurfaceBody. It is used by Inventor as the identifier for the face and is used for tracking this geometry for associativity. A value of -1 for the associative ID indicates that it has not been set.
EdgeLoopDefinitions | Property that returns the collection of EdgeLoopDefinition objects associated with this FaceDefinition object.
IsParamReversed | Property that indicates if the normal of this face is reversed with respect to the geometry associated with this face definition..
SurfaceGeometry | Property that gets and set the geometry associated with this FaceDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties


FaceDefinition.Application Property

FaceDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties > FaceDefinition.Application Property


FaceDefinition.AssociativeID Property

FaceDefinition.AssociativeID Property
Summary

Property that gets and sets the associate ID of this face. This ID will be transferred to the corresponding face when this SurfaceBodyDefinition is used to create a SurfaceBody. It is used by Inventor as the identifier for the face and is used for tracking this geometry for associativity. A value of -1 for the associative ID indicates that it has not been set.

Visual Basic
Property AssociativeID() As long
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties > FaceDefinition.AssociativeID Property


FaceDefinition.EdgeLoopDefinitions Property

FaceDefinition.EdgeLoopDefinitions Property
Summary

Property that returns the collection of EdgeLoopDefinition objects associated with this FaceDefinition object.

Visual Basic
Property EdgeLoopDefinitions() As EdgeLoopDefinitions**
See Also

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties > FaceDefinition.EdgeLoopDefinitions Property


FaceDefinition.IsParamReversed Property

FaceDefinition.IsParamReversed Property Introduced in Inventor 2011
Summary

Property that indicates if the normal of this face is reversed with respect to the geometry associated with this face definition..

Visual Basic
Property IsParamReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties > FaceDefinition.IsParamReversed Property


FaceDefinition.SurfaceGeometry Property

FaceDefinition.SurfaceGeometry Property
Summary

Property that gets and set the geometry associated with this FaceDefinition object.

Visual Basic
Property SurfaceGeometry() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties > FaceDefinition.SurfaceGeometry Property


FaceDefinition.Type Property

FaceDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinition Interface > FaceDefinition Properties > FaceDefinition.Type Property


FaceDefinitions Interface

FaceDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FaceDefinitions collection provides access to exisitng FaceDefinition objects and allows creation of new FaceDefinition objects.

Class Hierarchy
Inventor::FaceDefinitions
Visual Basic
Public Interface FaceDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FaceShellDefinition.FaceDefinitions

See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface


FaceDefinitions Methods

FaceDefinitions Methods
Summary

The methods of the FaceDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new FaceDefinition within the associated SurfaceBodyDefinition.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Methods


FaceDefinitions.Add Method

FaceDefinitions.Add Method
Summary

Method that creates a new FaceDefinition within the associated SurfaceBodyDefinition.

Visual Basic
Sub Add(SurfaceGeometry As IDispatch, IsParamReversed As VARIANT_BOOL, Result As [out, retval] FaceDefinition*)
Parameters
Parameters | Description
SurfaceGeometry | Input transient geometry object that defines the surface geometry of the face. Valid objects for input are BSplineSurface, Cone, Cylinder, EllipticalCone, EllipticalCylinder, Plane, Sphere, and Torus.
IsParamReversed | Input Boolean that indicates if the normal of this face is reversed with respect to the geometry.
See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Methods > FaceDefinitions.Add Method


FaceDefinitions.Item Method

FaceDefinitions.Item Method
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] FaceDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Methods > FaceDefinitions.Item Method


FaceDefinitions Properties

FaceDefinitions Properties
Summary

The properties of the FaceDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Properties


FaceDefinitions.Application Property

FaceDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Properties > FaceDefinitions.Application Property


FaceDefinitions.Count Property

FaceDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Properties > FaceDefinitions.Count Property


FaceDefinitions.Type Property

FaceDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceDefinitions Interface > FaceDefinitions Properties > FaceDefinitions.Type Property


FaceDraftFeature Interface

FaceDraftFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The FaceDraftFeature object represents a face draft on a part..

Class Hierarchy
Inventor::PartFeature
    Inventor::FaceDraftFeature
        Inventor::FaceDraftFeatureProxy
Visual Basic
Public Interface FaceDraftFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

FaceDraftFeatureProxy.NativeObject

FaceDraftFeatures.AddFixedEdge

FaceDraftFeatures.AddFixedPlane

FaceDraftFeatures.AddTaperShadow

FaceDraftFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface


FaceDraftFeature Properties

FaceDraftFeature Properties
Summary

The properties of the FaceDraftFeature class are listed here.

Properties
Name | Description
DirectionReversed | Property that gets whether to reverse the pull direction of the draft.
DraftAngle | Property that returns the parameter that controls the angle of the draft.
FixedEdges | Property that specifies the fixed edges ( ) on the input faces. This property returns Nothing for a fixed plane FaceDraft feature.
InputFaces | Property that specifies the faces used to create the feature.
PullDirection | Property that specifies the object used to determine the pull direction. For a fixed edge face draft this could be a planar Face, an Edge, a WorkPlane or a WorkAxis. For a fixed plane face draft this could either be a planar Face or a WorkPlane.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface > FaceDraftFeature Properties


FaceDraftFeature.DirectionReversed Property

FaceDraftFeature.DirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether to reverse the pull direction of the draft.

Visual Basic
Property DirectionReversed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface > FaceDraftFeature Properties > FaceDraftFeature.DirectionReversed Property


FaceDraftFeature.DraftAngle Property

FaceDraftFeature.DraftAngle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parameter that controls the angle of the draft.

Visual Basic
Property DraftAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface > FaceDraftFeature Properties > FaceDraftFeature.DraftAngle Property


FaceDraftFeature.FixedEdges Property

FaceDraftFeature.FixedEdges Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the fixed edges ( ) on the input faces. This property returns Nothing for a fixed plane FaceDraft feature.

Visual Basic
Property FixedEdges() As EdgeCollection**
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface > FaceDraftFeature Properties > FaceDraftFeature.FixedEdges Property


FaceDraftFeature.InputFaces Property

FaceDraftFeature.InputFaces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the faces used to create the feature.

Visual Basic
Property InputFaces() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface > FaceDraftFeature Properties > FaceDraftFeature.InputFaces Property


FaceDraftFeature.PullDirection Property

FaceDraftFeature.PullDirection Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the object used to determine the pull direction. For a fixed edge face draft this could be a planar Face, an Edge, a WorkPlane or a WorkAxis. For a fixed plane face draft this could either be a planar Face or a WorkPlane.

Visual Basic
Property PullDirection() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeature Interface > FaceDraftFeature Properties > FaceDraftFeature.PullDirection Property


FaceDraftFeatureProxy Interface

FaceDraftFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FaceDraftFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::FaceDraftFeature
        Inventor::FaceDraftFeatureProxy
Visual Basic
Public Interface FaceDraftFeatureProxy
Inherits FaceDraftFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatureProxy Interface


FaceDraftFeatureProxy Properties

FaceDraftFeatureProxy Properties
Summary

The properties of the FaceDraftFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatureProxy Interface > FaceDraftFeatureProxy Properties


FaceDraftFeatureProxy.ContainingOccurrence Property

FaceDraftFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatureProxy Interface > FaceDraftFeatureProxy Properties > FaceDraftFeatureProxy.ContainingOccurrence Property


FaceDraftFeatureProxy.NativeObject Property

FaceDraftFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FaceDraftFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatureProxy Interface > FaceDraftFeatureProxy Properties > FaceDraftFeatureProxy.NativeObject Property


FaceDraftFeatures Interface

FaceDraftFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The FaceDraftFeatures object represents a collection of face draft features ( objects) on a part.

Class Hierarchy
Inventor::FaceDraftFeatures
Visual Basic
Public Interface FaceDraftFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.FaceDraftFeatures

You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface


FaceDraftFeatures Methods

FaceDraftFeatures Methods
Summary

The methods of the FaceDraftFeatures class are listed here.

Methods
Methods
Name | Description
AddFixedEdge | Method that creates a new FaceDraftFeature. The new created FaceDraftFeature is returned.
AddFixedPlane | Method that creates a new FaceDraftFeature. The new created FaceDraftFeature is returned.
AddTaperShadow | Method that creates a new FaceDraftFeature. The new created FaceDraftFeature is returned.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Methods


FaceDraftFeatures.AddFixedEdge Method

FaceDraftFeatures.AddFixedEdge Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new FaceDraftFeature. The new created FaceDraftFeature is returned.

Visual Basic
Sub AddFixedEdge(Faces As FaceCollection, FixedEdges As EdgeCollection, DraftAngle As VARIANT, PullDirection As IDispatch, ByRef DirectionReversed As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] FaceDraftFeature*)
Parameters
Parameters | Description
Faces | Input FaceCollection that contains the faces to which draft will be applied. The method will fail if this collection contains faces with face normals the same direction as the pull direction. The method will also fail if there are conical/cylindrical faces in the collection whose axis direction is perpendicular to the pull direction -- you must use the AddTaperShadow method in this case.
FixedEdges | Input EdgeCollection that contains the edges on the input Faces that are to remain fixed. These edges must lie on the input Faces, else an error will occur. All the tangentially connected edges on a face may be obtained using the TangentiallyConnectedEdges property on the Edge object.
DraftAngle | Input Variant that defines the angle of the draft. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
PullDirection | Input object that defines the direction in which the draft is applied. This can be a planar Face, an Edge, a WorkPlane or a WorkAxis.
DirectionReversed | Optional input Boolean that specifies whether to reverse the pull direction. The default value is False indicating that the direction will not be reversed.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Methods > FaceDraftFeatures.AddFixedEdge Method


FaceDraftFeatures.AddFixedPlane Method

FaceDraftFeatures.AddFixedPlane Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new FaceDraftFeature. The new created FaceDraftFeature is returned.

Visual Basic
Sub AddFixedPlane(Faces As FaceCollection, DraftAngle As VARIANT, FixedPlane As IDispatch, ByRef DirectionReversed As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] FaceDraftFeature*)
Parameters
Parameters | Description
Faces | FaceCollection that contains the faces to which draft will be applied.
DraftAngle | Input Variant that defines the angle of the draft. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FixedPlane | Input object that defines the direction in which the draft is applied. This can be a planar Face, or a WorkPlane.
DirectionReversed | Optional input Boolean that specifies whether to reverse the pull direction. The default value is False indicating that the direction will not be reversed.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Methods > FaceDraftFeatures.AddFixedPlane Method


FaceDraftFeatures.AddTaperShadow Method

FaceDraftFeatures.AddTaperShadow Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new FaceDraftFeature. The new created FaceDraftFeature is returned.

Visual Basic
Sub AddTaperShadow(Faces As FaceCollection, DraftAngle As VARIANT, PullDirection As IDispatch, ByRef DirectionReversed As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] FaceDraftFeature*)
Parameters
Parameters | Description
Faces | Input FaceCollection that contains the faces to which draft will be applied. The method will fail if this collection does not contain at least one conical or cylindrical face whose axis direction is perpendicular to the pull direction.
DraftAngle | Input Variant that defines the angle of the draft. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
PullDirection | Input object that defines the direction in which the draft is applied. This can be a planar Face, an Edge, a WorkPlane or a WorkAxis.
DirectionReversed | Optional input Boolean that specifies whether to reverse the pull direction. The default value is False indicating that the direction will not be reversed.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Methods > FaceDraftFeatures.AddTaperShadow Method


FaceDraftFeatures.Item Method

FaceDraftFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FaceDraftFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Methods > FaceDraftFeatures.Item Method


FaceDraftFeatures Properties

FaceDraftFeatures Properties
Summary

The properties of the FaceDraftFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Properties


FaceDraftFeatures.Application Property

FaceDraftFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Properties > FaceDraftFeatures.Application Property


FaceDraftFeatures.Count Property

FaceDraftFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Properties > FaceDraftFeatures.Count Property


FaceDraftFeatures.Type Property

FaceDraftFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceDraftFeatures Interface > FaceDraftFeatures Properties > FaceDraftFeatures.Type Property


FaceFeature Interface

FaceFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FaceFeature object represents a sheet metal face feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::FaceFeature
        Inventor::FaceFeatureProxy
Visual Basic
Public Interface FaceFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

FaceFeatureDefinition.Parent

FaceFeatures.Add

FaceFeatures.Item

See Also

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > FaceFeature Interface


FaceFeature Properties

FaceFeature Properties
Summary

The properties of the FaceFeature class are listed here.

Properties
Name | Description
BendFeature | Property that returns the associated bend feature, if one exists. If there isn't an associated bend feature this property returns Nothing.
Definition | Property that gets the FaceFeatureDefinition object associated with this face feature.
You are here: Symbol Reference > Inventor Library > Objects > FaceFeature Interface > FaceFeature Properties


FaceFeature.BendFeature Property

FaceFeature.BendFeature Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the associated bend feature, if one exists. If there isn't an associated bend feature this property returns Nothing.

Visual Basic
Property BendFeature() As BendFeature**
You are here: Symbol Reference > Inventor Library > Objects > FaceFeature Interface > FaceFeature Properties > FaceFeature.BendFeature Property


FaceFeature.Definition Property

FaceFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the FaceFeatureDefinition object associated with this face feature.

Visual Basic
Property Definition() As FaceFeatureDefinition**
Remarks

Modifying the FaceFeatureDefinition object will edit the associated FaceFeature.

You are here: Symbol Reference > Inventor Library > Objects > FaceFeature Interface > FaceFeature Properties > FaceFeature.Definition Property


FaceFeatureDefinition Interface

FaceFeatureDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FaceFeatureDefinition object represents all of the information that defines a face feature.

Class Hierarchy
Inventor::FaceFeatureDefinition
Visual Basic
Public Interface FaceFeatureDefinition
Inherits IDispatch
Remarks

The FaceFeatureDefinition object is used in two ways. First it is used as input when creating a faces feature. Second it is used to query and edit existing face features. When creating a new face feature you use the FaceFeatures.CreateFaceFeatureDefinition method to create a new FaceFeatureDefinition object. Using the properties of this object you can define the various options of the face feature. Typically a new FaceFeatureDefinition object is created and modified to get the desired face feature and then used as input to the FaceFeatures.Add method. An existing FaceFeature object is edited by modifying its associated FaceFeatureDefinition object.

Notes

Members through which this object may be accessed include:

FaceFeature.Definition

FaceFeatures.CreateFaceFeatureDefinition

See Also

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface


FaceFeatureDefinition Properties

FaceFeatureDefinition Properties
Summary

The properties of the FaceFeatureDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BendDefinition | Property that get and sets the BendDefinition object that defines the bend information for this face feature.
Direction | Property that gets and sets the extent direction which indicates which side of the sketch the projection of the face is in. When a new FaceDefinition is created this value defaults to kPositiveExtentDirection. Valid values are kNegativeExtentDirection and kPositiveExtentDirection.
Parent | Property that returns the parent FaceFeature object of this FaceFeatureDefinition object.
Profile | Property that gets and sets the Profile object that defines the shape of the face feature. The profile can be changed in two ways. The first is to obtain the parent sketch of the profile and make changes to the sketch. The second is to create an entirely new profile and use it to replace the existing profile.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties


FaceFeatureDefinition.Application Property

FaceFeatureDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties > FaceFeatureDefinition.Application Property


FaceFeatureDefinition.BendDefinition Property

FaceFeatureDefinition.BendDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that get and sets the BendDefinition object that defines the bend information for this face feature.

Visual Basic
Property BendDefinition() As BendDefinition*
Remarks

Editing the returned BendDefinition object will modify the bend.

This property will return Nothing in the case where there isn't a bend for the Face feature. When the FaceFeatureDefinition is initially created this is initialized to Nothing. Setting this property with a valid BendDefinition object will add a bend. Setting this property to Nothing will delete the bend.

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties > FaceFeatureDefinition.BendDefinition Property


FaceFeatureDefinition.Direction Property

FaceFeatureDefinition.Direction Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the extent direction which indicates which side of the sketch the projection of the face is in. When a new FaceDefinition is created this value defaults to kPositiveExtentDirection. Valid values are kNegativeExtentDirection and kPositiveExtentDirection.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties > FaceFeatureDefinition.Direction Property


FaceFeatureDefinition.Parent Property

FaceFeatureDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent FaceFeature object of this FaceFeatureDefinition object.

Visual Basic
Property Parent() As FaceFeature**
Remarks

In the case where this is a newly created FaceFeatureDefinition object or it has been copied from an existing FaceFeatureDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties > FaceFeatureDefinition.Parent Property


FaceFeatureDefinition.Profile Property

FaceFeatureDefinition.Profile Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the Profile object that defines the shape of the face feature. The profile can be changed in two ways. The first is to obtain the parent sketch of the profile and make changes to the sketch. The second is to create an entirely new profile and use it to replace the existing profile.

Visual Basic
Property Profile() As Profile*
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties > FaceFeatureDefinition.Profile Property


FaceFeatureDefinition.Type Property

FaceFeatureDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureDefinition Interface > FaceFeatureDefinition Properties > FaceFeatureDefinition.Type Property


FaceFeatureProxy Interface

FaceFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FaceFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::FaceFeature
        Inventor::FaceFeatureProxy
Visual Basic
Public Interface FaceFeatureProxy
Inherits FaceFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatureProxy Interface


FaceFeatures Interface

FaceFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FaceFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::FaceFeatures
Visual Basic
Public Interface FaceFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.FaceFeatures

See Also

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface


FaceFeatures Methods

FaceFeatures Methods
Summary

The methods of the FaceFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new face feature. The newly created FaceFeature object is returned.
CreateFaceFeatureDefinition | Method that creates a new FaceFeatureDefinition object.
Item | Property that returns the specified FaceFeature object from the collection. This is the default property of the FaceFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Methods


FaceFeatures.Add Method

FaceFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new face feature. The newly created FaceFeature object is returned.

Visual Basic
Sub Add(FaceFeatureDefinition As FaceFeatureDefinition, Result As [out, retval] FaceFeature*)
Parameters
Parameters | Description
FaceFeatureDefinition | Input FaceFeatureDefinition object that defines the face feature you want to create. A FaceFeatureDefinition object can be created using the FaceFeatures.CreateFaceFeatureDefinition method. It can also be obtained from an existing FaceFeature object.
See Also

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Methods > FaceFeatures.Add Method


FaceFeatures.CreateFaceFeatureDefinition Method

FaceFeatures.CreateFaceFeatureDefinition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new FaceFeatureDefinition object.

Visual Basic
Sub CreateFaceFeatureDefinition(Profile As Profile, Result As [out, retval] FaceFeatureDefinition*)
Parameters
Parameters | Description
Profile | Input Profile object that defines the shape of the face. The input profile must consist of one or more closed paths.
Remarks

This object is not a face feature but contains the information that defines a face feature and can be used to create a new face feature or edit an existing one. The returned FaceFeatureDefinition can be used as input to the FaceFeatures.Add method to create a new face feature. You can edit the properties of the FaceFeatureDefinition object before creating the face feature to get the desired face feature.

See Also

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Methods > FaceFeatures.CreateFaceFeatureDefinition Method


FaceFeatures.Item Method

FaceFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified FaceFeature object from the collection. This is the default property of the FaceFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FaceFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Methods > FaceFeatures.Item Method


FaceFeatures Properties

FaceFeatures Properties
Summary

The properties of the FaceFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Properties


FaceFeatures.Application Property

FaceFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Properties > FaceFeatures.Application Property


FaceFeatures.Count Property

FaceFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Properties > FaceFeatures.Count Property


FaceFeatures.Type Property

FaceFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceFeatures Interface > FaceFeatures Properties > FaceFeatures.Type Property


FaceProxy Interface

FaceProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Face object.

Class Hierarchy
Inventor::Face
    Inventor::FaceProxy
Visual Basic
Public Interface FaceProxy
Inherits Face
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FaceProxy Interface


FaceProxy Properties

FaceProxy Properties
Summary

The properties of the FaceProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FaceProxy Interface > FaceProxy Properties


FaceProxy.ContainingOccurrence Property

FaceProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FaceProxy Interface > FaceProxy Properties > FaceProxy.ContainingOccurrence Property


FaceProxy.NativeObject Property

FaceProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As Face**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FaceProxy Interface > FaceProxy Properties > FaceProxy.NativeObject Property


Faces Interface

Faces Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Faces object represents a collection of objects. See the article in the overviews section.

Class Hierarchy
Inventor::Faces
Visual Basic
Public Interface Faces
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Bend.BackFaces

Bend.FrontFaces

Edge.Faces

ExtrudeFeature.EndFaces

ExtrudeFeature.SideFaces

ExtrudeFeature.StartFaces

FaceShell.Faces

FeaturePatternElement.Faces

FlatPunchResult.Faces

HoleFeature.EndFaces

HoleFeature.SideFaces

LoftFeature.SideFaces

MoldSplitResult.Faces

PartFeature.Faces

RevolveFeature.EndFaces

RevolveFeature.SideFaces

RevolveFeature.StartFaces

SurfaceBody.Faces

SweepFeature.EndFaces

SweepFeature.SideFaces

SweepFeature.StartFaces

ThreadFeature.ThreadedFace

Vertex.Faces

WeldBead.BeadFaces

WeldBead.EndFaces

WeldBead.SideFaces

See Also

Sketch Edit Orientation sample

Thread Feature Create sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Reference keys sample

Sketch Add Oriented sample

Sketch from face silhouette sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > Faces Interface


Faces Methods

Faces Methods
Summary

The methods of the Faces class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > Faces Interface > Faces Methods


Faces.Item Method

Faces.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] Face*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
See Also

Thread Feature Create sample

Create sheet metal face and cut features sample

Sketch Add Oriented sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > Faces Interface > Faces Methods > Faces.Item Method


Faces Properties

Faces Properties
Summary

The properties of the Faces class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Faces Interface > Faces Properties


Faces.Count Property

Faces.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Faces Interface > Faces Properties > Faces.Count Property


Faces.Type Property

Faces.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Faces Interface > Faces Properties > Faces.Type Property


FaceShell Interface

FaceShell Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The FaceShell object. See the article in the overviews section.

Class Hierarchy
Inventor::FaceShell
    Inventor::FaceShellProxy
Visual Basic
Public Interface FaceShell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Face.FaceShell

FaceShellProxy.NativeObject

FaceShells.Item

DeleteFaceFeature.InputFaces

ThickenFeature.InputFaces

You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface


FaceShell Methods

FaceShell Methods
Summary

The methods of the FaceShell class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
IsPointInside | Property that returns a constant indicating whether the specified point is inside, on or outside the body.
Volume | Property that returns the volume of the component in database units.
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Methods


FaceShell.GetReferenceKey Method

FaceShell.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Methods > FaceShell.GetReferenceKey Method


FaceShell.IsPointInside Method

FaceShell.IsPointInside Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a constant indicating whether the specified point is inside, on or outside the body.

Visual Basic
Sub IsPointInside(ByRef Point As SAFEARRAY(double), ByRef UseBox As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] ContainmentEnum)
Parameters
Parameters | Description
Point | Point whose location to determine.
UseBox | Optional input Boolean that specifies whether to use a box to determine if the point is inside, on or outside of the body. Sometimes one wants to avoid the creation of bounding boxes during intermediate steps of a construction because the creation of bounding boxes can be costly. If you're applying multiple operations to a body then the bounding box of some of the shells would be invalid after each operation. You wouldn't want to use the bounding box during these intermediate stages because you might spend more time computing the bounding box than you'd save by using it for trivial rejection. On the other hand, if you have a stable body and a high likelihood that the bounding box is up-to-date, then it might save some time to set the use_box parameter to true.
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Methods > FaceShell.IsPointInside Method


FaceShell.Volume Method

FaceShell.Volume Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the volume of the component in database units.

Visual Basic
Sub Volume(PrecisionPercent As double, Result As [out, retval] double)
Parameters
Parameters | Description
PrecisionPercent | Input Double that specifies the requested relative accuracy of the result as a percentage. For example, a value of 0.01 requests a maximum error of one percent.
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Methods > FaceShell.Volume Method


FaceShell Properties

FaceShell Properties
Summary

The properties of the FaceShell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Edges | Gets the referenced by this FaceShell.
Faces | Property that returns a collection object generated as a result of the feature.
IsClosed | Indicates whether the FaceShell is closed.
IsVoid | Indicates whether the FaceShell is a void.
Parent | Property that returns the parent object from whom this object can logically be reached.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
SurfaceBody | Property that returns the surface body for this face shell.
TransientKey | Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties


FaceShell.Application Property

FaceShell.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.Application Property


FaceShell.AttributeSets Property

FaceShell.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.AttributeSets Property


FaceShell.Edges Property

FaceShell.Edges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the referenced by this FaceShell.

Visual Basic
Property Edges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.Edges Property


FaceShell.Faces Property

FaceShell.Faces Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a collection object generated as a result of the feature.

Visual Basic
Property Faces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.Faces Property


FaceShell.IsClosed Property

FaceShell.IsClosed Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates whether the FaceShell is closed.

Visual Basic
Property IsClosed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.IsClosed Property


FaceShell.IsVoid Property

FaceShell.IsVoid Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Indicates whether the FaceShell is a void.

Visual Basic
Property IsVoid() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.IsVoid Property


FaceShell.Parent Property

FaceShell.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.Parent Property


FaceShell.RangeBox Property

FaceShell.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.RangeBox Property


FaceShell.SurfaceBody Property

FaceShell.SurfaceBody Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the surface body for this face shell.

Visual Basic
Property SurfaceBody() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.SurfaceBody Property


FaceShell.TransientKey Property

FaceShell.TransientKey Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the ReferenceKeys overview.

Visual Basic
Property TransientKey() As long*
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.TransientKey Property


FaceShell.Type Property

FaceShell.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceShell Interface > FaceShell Properties > FaceShell.Type Property


FaceShellDefinition Interface

FaceShellDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FaceShellDefinition represents a transient definition of a FaceShell object.

Class Hierarchy
Inventor::FaceShellDefinition
Visual Basic
Public Interface FaceShellDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FaceShellDefinitions.Add

FaceShellDefinitions.Item

See Also

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinition Interface


FaceShellDefinition Properties

FaceShellDefinition Properties
Summary

The properties of the FaceShellDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
FaceDefinitions | Property that returns the collection of FaceDefinition objects associated with this FaceShellDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinition Interface > FaceShellDefinition Properties


FaceShellDefinition.Application Property

FaceShellDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinition Interface > FaceShellDefinition Properties > FaceShellDefinition.Application Property


FaceShellDefinition.FaceDefinitions Property

FaceShellDefinition.FaceDefinitions Property
Summary

Property that returns the collection of FaceDefinition objects associated with this FaceShellDefinition object.

Visual Basic
Property FaceDefinitions() As FaceDefinitions**
See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinition Interface > FaceShellDefinition Properties > FaceShellDefinition.FaceDefinitions Property


FaceShellDefinition.Type Property

FaceShellDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinition Interface > FaceShellDefinition Properties > FaceShellDefinition.Type Property


FaceShellDefinitions Interface

FaceShellDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FaceShellDefinitions object represents a collection of FaceShellDefinition objects.

Class Hierarchy
Inventor::FaceShellDefinitions
Visual Basic
Public Interface FaceShellDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LumpDefinition.FaceShellDefinitions

See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface


FaceShellDefinitions Methods

FaceShellDefinitions Methods
Summary

The methods of the FaceShellDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new FaceShellDefinition within the associated SurfaceBodyDefinition.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Methods


FaceShellDefinitions.Add Method

FaceShellDefinitions.Add Method
Summary

Method that creates a new FaceShellDefinition within the associated SurfaceBodyDefinition.

Visual Basic
Sub Add(Result As [out, retval] FaceShellDefinition*)
See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Methods > FaceShellDefinitions.Add Method


FaceShellDefinitions.Item Method

FaceShellDefinitions.Item Method
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] FaceShellDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Methods > FaceShellDefinitions.Item Method


FaceShellDefinitions Properties

FaceShellDefinitions Properties
Summary

The properties of the FaceShellDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Properties


FaceShellDefinitions.Application Property

FaceShellDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Properties > FaceShellDefinitions.Application Property


FaceShellDefinitions.Count Property

FaceShellDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Properties > FaceShellDefinitions.Count Property


FaceShellDefinitions.Type Property

FaceShellDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceShellDefinitions Interface > FaceShellDefinitions Properties > FaceShellDefinitions.Type Property


FaceShellProxy Interface

FaceShellProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FaceShell object.

Class Hierarchy
Inventor::FaceShell
    Inventor::FaceShellProxy
Visual Basic
Public Interface FaceShellProxy
Inherits FaceShell
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FaceShellProxy Interface


FaceShellProxy Properties

FaceShellProxy Properties
Summary

The properties of the FaceShellProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FaceShellProxy Interface > FaceShellProxy Properties


FaceShellProxy.ContainingOccurrence Property

FaceShellProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FaceShellProxy Interface > FaceShellProxy Properties > FaceShellProxy.ContainingOccurrence Property


FaceShellProxy.NativeObject Property

FaceShellProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FaceShell**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FaceShellProxy Interface > FaceShellProxy Properties > FaceShellProxy.NativeObject Property


FaceShells Interface

FaceShells Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The FaceShells object represents a collection of objects. See the article in the overviews section.

Class Hierarchy
Inventor::FaceShells
Visual Basic
Public Interface FaceShells
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceBody.FaceShells

You are here: Symbol Reference > Inventor Library > Objects > FaceShells Interface


FaceShells Methods

FaceShells Methods
Summary

The methods of the FaceShells class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to objects in the collection.
You are here: Symbol Reference > Inventor Library > Objects > FaceShells Interface > FaceShells Methods


FaceShells.Item Method

FaceShells.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to objects in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] FaceShell*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > FaceShells Interface > FaceShells Methods > FaceShells.Item Method


FaceShells Properties

FaceShells Properties
Summary

The properties of the FaceShells class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FaceShells Interface > FaceShells Properties


FaceShells.Count Property

FaceShells.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FaceShells Interface > FaceShells Properties > FaceShells.Count Property


FaceShells.Type Property

FaceShells.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FaceShells Interface > FaceShells Properties > FaceShells.Type Property


FactoryOptions Interface

FactoryOptions Interface Available in Inventor Available in Server Introduced in Inventor 2010
Class Hierarchy
Inventor::FactoryOptions
Visual Basic
Public Interface FactoryOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iAssemblyFactory.FactoryOptions

iPartFactory.FactoryOptions

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface


FactoryOptions Methods

FactoryOptions Methods
Summary

The methods of the FactoryOptions class are listed here.

Methods
Methods
Name | Description
ApplyToAllMembers | Method that applies the factory options to all members of the factory including existing ones. By default, any factory options specified using the FactoryOptions object will only apply to newly created members. If the options need to be applied to existing members also, this method needs to be called.
You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Methods


FactoryOptions.ApplyToAllMembers Method

FactoryOptions.ApplyToAllMembers Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that applies the factory options to all members of the factory including existing ones. By default, any factory options specified using the FactoryOptions object will only apply to newly created members. If the options need to be applied to existing members also, this method needs to be called.

Visual Basic
Sub ApplyToAllMembers()
You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Methods > FactoryOptions.ApplyToAllMembers Method


FactoryOptions Properties

FactoryOptions Properties
Summary

The properties of the FactoryOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
IsPartNumberIndexed | Property that gets and sets whether the part number displayed in the iPart factory table is indexed.
MemberNameIndexDigits | Property that gets and sets the number of digits to use for the member name index.
MemberNameIndexInitialValue | Property that gets and sets the starting value of the member name index.
MemberNameIndexSeparator | Property that gets and sets the separator for the member name index.
MemberNameIndexStepValue | Property that gets and sets the step value for the member name index.
MemberNameType | Property that specifies the type of value to use for the member name. The valid options are kPartNumberMemberNameType, kFileNameMemberNameType and kValueMemberNameType.
MemberNameValue | Property that gets and sets the custom text value for the member name.
PartNumberIndexDigits | Property that gets and sets the number of digits to use for the part number index.
PartNumberIndexInitialValue | Property that gets and sets the starting value of the part number index.
PartNumberIndexSeparator | Property that gets and sets the separator for the part number index.
PartNumberIndexStepValue | Property that gets and sets the step value for the part number index.
PartNumberType | Property that specifies the type of value to use for the part number. The valid options are kNonePartNumberType and kValuePartNumberType.
PartNumberValue | Property that gets and sets the custom text value for the part number.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties


FactoryOptions.Application Property

FactoryOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.Application Property


FactoryOptions.IsPartNumberIndexed Property

FactoryOptions.IsPartNumberIndexed Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the part number displayed in the iPart factory table is indexed.

Visual Basic
Property IsPartNumberIndexed() As VARIANT_BOOL
Remarks

If this property is True, an index will be used for the part number.

Setting this property to False specifies that an index should not be used for the part number. Additionally, if the MemberNameType property is currently kPartNumberMemberNameType, then it will be automatically reverted to kFileNameMemberNameType because the member name is always indexed.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.IsPartNumberIndexed Property


FactoryOptions.MemberNameIndexDigits Property

FactoryOptions.MemberNameIndexDigits Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the number of digits to use for the member name index.

Visual Basic
Property MemberNameIndexDigits() As long
Remarks

This property is only applicable if the member name has been specified to be factory file name or custom text value as indicated by the MemberNameType property returning kFileNameMemberNameType or kValueMemberNameType, respectively.

If the member name has been specified to use the part number, i.e. the MemberNameType property value is kPartNumberMemberNameType, the digits for the part number index will be used and this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.MemberNameIndexDigits Property


FactoryOptions.MemberNameIndexInitialValue Property

FactoryOptions.MemberNameIndexInitialValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the starting value of the member name index.

Visual Basic
Property MemberNameIndexInitialValue() As long
Remarks

This property is only applicable if the member name has been specified to be factory file name or custom text value as indicated by the MemberNameType property returning kFileNameMemberNameType or kValueMemberNameType, respectively.

If the member name has been specified to use the part number, i.e. the MemberNameType property value is kPartNumberMemberNameType, the digits for the part number index will be used and this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.MemberNameIndexInitialValue Property


FactoryOptions.MemberNameIndexSeparator Property

FactoryOptions.MemberNameIndexSeparator Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the separator for the member name index.

Visual Basic
Property MemberNameIndexSeparator() As String
Remarks

This property is only applicable if the member name has been specified to be factory file name or custom text value as indicated by the MemberNameType property returning kFileNameMemberNameType or kValueMemberNameType, respectively.

If the member name has been specified to use the part number, i.e. the MemberNameType property value is kPartNumberMemberNameType, the digits for the part number index will be used and this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.MemberNameIndexSeparator Property


FactoryOptions.MemberNameIndexStepValue Property

FactoryOptions.MemberNameIndexStepValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the step value for the member name index.

Visual Basic
Property MemberNameIndexStepValue() As long
Remarks

For every item added to the iPart factory table, the member name index will be incremented by the step value specified by this property.

This property is only applicable if the member name has been specified to be factory file name or custom text value as indicated by the MemberNameType property returning kFileNameMemberNameType or kValueMemberNameType, respectively.

If the member name has been specified to use the part number, i.e. the MemberNameType property value is kPartNumberMemberNameType, the digits for the part number index will be used and this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.MemberNameIndexStepValue Property


FactoryOptions.MemberNameType Property

FactoryOptions.MemberNameType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the type of value to use for the member name. The valid options are kPartNumberMemberNameType, kFileNameMemberNameType and kValueMemberNameType.

Visual Basic
Property MemberNameType() As FactoryOptionsMemberNameTypeEnum
Remarks

Setting this property to kPartNumberMemberNameType specifies that the part number index should be used for the member name. This value is only applicable if the part number has been specified as indicated by the PartNumberType property returning a value of kValuePartNumberType. If the part number has not been specified to be displayed, i.e. the PartNumberType property value is kNonePartNumberType, setting this property to kPartNumberMemberNameType will fail. Also, since the member name is always indexed, the IsPartNumberIndexed property should be True. If the IsPartNumberIndexed property is False, setting this property to kPartNumberMemberNameType will fail.

Setting this property to kFileNameMemberNameType specifies that the factory file name should be used for the member name.

Setting this property to kValueMemberNameType specifies that a custom text value should be displayed for the part number. This text value can be specified using the MemberNameValue property.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.MemberNameType Property


FactoryOptions.MemberNameValue Property

FactoryOptions.MemberNameValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the custom text value for the member name.

Visual Basic
Property MemberNameValue() As String
Remarks

This property is only applicable if member name has been specified to be a custom text value as indicated by the MemberNameType property returning a value of kValueMemberNameType. If the member name has been specified to be any other value, this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.MemberNameValue Property


FactoryOptions.PartNumberIndexDigits Property

FactoryOptions.PartNumberIndexDigits Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the number of digits to use for the part number index.

Visual Basic
Property PartNumberIndexDigits() As long
Remarks

This property is only applicable if the part number has been specified to be a custom text value as indicated by the PartNumberType property returning a value of kValuePartNumberType. If the part number has not been specified, i.e. the PartNumberType property value is kNonePartNumberType, this property value will be ignored.

Also, this property is applicable only if the part number has been specified to use an index, as indicated by the IsPartNumberIndexed property returning a value of True. If IsPartNumberIndexed property is False, this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.PartNumberIndexDigits Property


FactoryOptions.PartNumberIndexInitialValue Property

FactoryOptions.PartNumberIndexInitialValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the starting value of the part number index.

Visual Basic
Property PartNumberIndexInitialValue() As long
Remarks

This property is only applicable if the part number has been specified to be a custom text value as indicated by the PartNumberType property returning a value of kValuePartNumberType. If the part number has not been specified, i.e. the PartNumberType property value is kNonePartNumberType, this property value will be ignored.

Also,this property is applicable only if the part number has been specified to use an index, as indicated by the IsPartNumberIndexed property returning a value of True. If IsPartNumberIndexed property is False, this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.PartNumberIndexInitialValue Property


FactoryOptions.PartNumberIndexSeparator Property

FactoryOptions.PartNumberIndexSeparator Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the separator for the part number index.

Visual Basic
Property PartNumberIndexSeparator() As String
Remarks

This property is only applicable if the part number has been specified to be a custom text value as indicated by the PartNumberType property returning a value of kValuePartNumberType. If the part number has not been specified, i.e. the PartNumberType property value is kNonePartNumberType, this property value will be ignored.

Also, this property is applicable only if the part number has been specified to use an index, as indicated by the IsPartNumberIndexed property returning a value of True. If IsPartNumberIndexed property is False, this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.PartNumberIndexSeparator Property


FactoryOptions.PartNumberIndexStepValue Property

FactoryOptions.PartNumberIndexStepValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the step value for the part number index.

Visual Basic
Property PartNumberIndexStepValue() As long
Remarks

For every item added to the iPart factory table, the part number index will be incremented by the step value specified by this property.

This property is only applicable if the part number has been specified to be a custom text value as indicated by the PartNumberType property returning a value of kValuePartNumberType. If the part number has not been specified, i.e. the PartNumberType property value is kNonePartNumberType, this property value will be ignored.

Also, this property is applicable only if the part number has been specified to use an index, as indicated by the IsPartNumberIndexed property returning a value of True. If IsPartNumberIndexed property is False, this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.PartNumberIndexStepValue Property


FactoryOptions.PartNumberType Property

FactoryOptions.PartNumberType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the type of value to use for the part number. The valid options are kNonePartNumberType and kValuePartNumberType.

Visual Basic
Property PartNumberType() As FactoryOptionsPartNumberTypeEnum
Remarks

Setting this property to kNonePartNumberType specifies that the part number should not be displayed.

Setting this property to kValuePartNumberType specifies that a custom text value should be displayed for the part number. This text value can be specified using the PartNumberValue property.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.PartNumberType Property


FactoryOptions.PartNumberValue Property

FactoryOptions.PartNumberValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the custom text value for the part number.

Visual Basic
Property PartNumberValue() As String
Remarks

This property is only applicable if the part number has been specified to be a custom text value as indicated by the PartNumberType property returning a value of kValuePartNumberType. If the part number has not been specified, i.e. the PartNumberType property value is kNonePartNumberType, this property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.PartNumberValue Property


FactoryOptions.Type Property

FactoryOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FactoryOptions Interface > FactoryOptions Properties > FactoryOptions.Type Property


FeatureBasedOccurrencePattern Interface

FeatureBasedOccurrencePattern Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The FeatureBasedOccurrencePattern object represents a feature-based occurrence pattern.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::FeatureBasedOccurrencePattern
        Inventor::FeatureBasedOccurrencePatternProxy
Visual Basic
Public Interface FeatureBasedOccurrencePattern
Inherits OccurrencePattern
Notes

Members through which this object may be accessed include:

FeatureBasedOccurrencePatternProxy.NativeObject

OccurrencePatterns.AddFeatureBasedPattern

You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePattern Interface


FeatureBasedOccurrencePattern Properties

FeatureBasedOccurrencePattern Properties
Summary

The properties of the FeatureBasedOccurrencePattern class are listed here.

Properties
Name | Description
FeaturePattern | Property that gets and sets the feature pattern used as input for this occurrence pattern.
You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePattern Interface > FeatureBasedOccurrencePattern Properties


FeatureBasedOccurrencePattern.FeaturePattern Property

FeatureBasedOccurrencePattern.FeaturePattern Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the feature pattern used as input for this occurrence pattern.

Visual Basic
Property FeaturePattern() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePattern Interface > FeatureBasedOccurrencePattern Properties > FeatureBasedOccurrencePattern.FeaturePattern Property


FeatureBasedOccurrencePatternProxy Interface

FeatureBasedOccurrencePatternProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FeatureBasedOccurrencePattern object.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::FeatureBasedOccurrencePattern
        Inventor::FeatureBasedOccurrencePatternProxy
Visual Basic
Public Interface FeatureBasedOccurrencePatternProxy
Inherits FeatureBasedOccurrencePattern
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePatternProxy Interface


FeatureBasedOccurrencePatternProxy Properties

FeatureBasedOccurrencePatternProxy Properties
Summary

The properties of the FeatureBasedOccurrencePatternProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePatternProxy Interface > FeatureBasedOccurrencePatternProxy Properties


FeatureBasedOccurrencePatternProxy.ContainingOccurrence Property

FeatureBasedOccurrencePatternProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePatternProxy Interface > FeatureBasedOccurrencePatternProxy Properties > FeatureBasedOccurrencePatternProxy.ContainingOccurrence Property


FeatureBasedOccurrencePatternProxy.NativeObject Property

FeatureBasedOccurrencePatternProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FeatureBasedOccurrencePattern**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FeatureBasedOccurrencePatternProxy Interface > FeatureBasedOccurrencePatternProxy Properties > FeatureBasedOccurrencePatternProxy.NativeObject Property


FeatureControlFrame Interface

FeatureControlFrame Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FeatureControlFrame object represents a feature control frame symbol on a sheet.

Class Hierarchy
Inventor::FeatureControlFrame
Visual Basic
Public Interface FeatureControlFrame
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FeatureControlFrameRow.Parent

FeatureControlFrames.Add

FeatureControlFrames.Item

See Also

Adding and editing a feature control frame sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface


FeatureControlFrame Methods

FeatureControlFrame Methods
Summary

The methods of the FeatureControlFrame class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the FeatureControlFrame.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Methods


FeatureControlFrame.Delete Method

FeatureControlFrame.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes the FeatureControlFrame.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Methods > FeatureControlFrame.Delete Method


FeatureControlFrame.GetReferenceKey Method

FeatureControlFrame.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Methods > FeatureControlFrame.GetReferenceKey Method


FeatureControlFrame Properties

FeatureControlFrame Properties
Summary

The properties of the FeatureControlFrame class are listed here.

Properties
Name | Description
AllAroundSymbol | Property that gets and sets whether to add the all-around indicator to the symbol. The diameter is specified in the associated leader style.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DatumIdentifier | Property that gets and sets a datum identifier for the feature control frame.
FeatureControlFrameRows | Property that gets and sets the FeatureControlFrameRows object.
Layer | Property that gets and sets the layer associated with this object.
Leader | Property that returns the leader associated with the feature control frame symbol.
Notes | Property that gets and sets notes for the feature control frame.
Parent | Property that returns the parent Sheet object.
Position | Property that gets and sets the position of the symbol on the sheet. Changing the position of the symbol does not affect the position of the root node of its leader. It only repositions the symbol along the landing line.
Rotation | Property that gets and sets the absolute rotation angle of the symbol in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, 'pi/2, 'pi, and '1.5pi.
Style | Gets and sets the associated FeatureControlFrameStyle object.
Type | Property returning kFeatureControlFrameObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties


FeatureControlFrame.AllAroundSymbol Property

FeatureControlFrame.AllAroundSymbol Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to add the all-around indicator to the symbol. The diameter is specified in the associated leader style.

Visual Basic
Property AllAroundSymbol() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.AllAroundSymbol Property


FeatureControlFrame.Application Property

FeatureControlFrame.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Application Property


FeatureControlFrame.AttributeSets Property

FeatureControlFrame.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.AttributeSets Property


FeatureControlFrame.DatumIdentifier Property

FeatureControlFrame.DatumIdentifier Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets a datum identifier for the feature control frame.

Visual Basic
Property DatumIdentifier() As String
Remarks

Setting this property fails if the associated style does not allow the specification of a datum identifier. This can be checked using the FeatureControlFrameStyle.AllowDatumIdentifier property. The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify an 'M' with a circle around it:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.DatumIdentifier Property


FeatureControlFrame.FeatureControlFrameRows Property

FeatureControlFrame.FeatureControlFrameRows Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the FeatureControlFrameRows object.

Visual Basic
Property FeatureControlFrameRows() As FeatureControlFrameRows*
Remarks

This object can be used to query and edit the rows of the feature control frame. Any edits to the rows of the object obtained from this property has the affect of immediately updating the symbol. If a batch update of the rows is to be performed, it is better to create a new FeatureControlFrameRows using the CreateFeatureControlFrameRows method on the FeatureControlFrames collection object and assigning the new object to this property.

Example

"Adding and editing a feature control frame"

These samples demonstrate editing an existing feature control frame symbol. The first sample adds a row to an existing symbol. The second sample replaces all rows of an existing symbol.

Public Sub EditFeatureControlFrame()
' Set a reference to the drawing document.
' This assumes a drawing document is active.
Dim oDrawDoc As DrawingDocument
Set oDrawDoc = ThisApplication.ActiveDocument

' Get the feature control frame selection
Dim oFCF As FeatureControlFrame
Set oFCF = oDrawDoc.SelectSet.Item(1)

' Add a new row to the FCF symbol
Dim oNewRow As FeatureControlFrameRow
Set oNewRow = oFCF.FeatureControlFrameRows.Add(kParallelism, "0.40", , "C")

End Sub

Public Sub BatchUpdateFeatureControlFrameRows()
' Set a reference to the drawing document.
' This assumes a drawing document is active.
Dim oDrawDoc As DrawingDocument
Set oDrawDoc = ThisApplication.ActiveDocument

' Set a reference to the active sheet.
Dim oActiveSheet As Sheet
Set oActiveSheet = oDrawDoc.ActiveSheet

' Get the feature control frame selection
Dim oFCF As FeatureControlFrame
Set oFCF = oDrawDoc.SelectSet.Item(1)

' Create a FeatureControlFrameRows object to define the symbol's rows
Dim oRows As FeatureControlFrameRows
Set oRows = oActiveSheet.FeatureControlFrames.CreateFeatureControlFrameRows

' Add two rows
Call oRows.Add(kProfileOfAnySurface, "0.20", , "A", "B")
Call oRows.Add(kParallelism, "0.40", , "C")

oFCF.FeatureControlFrameRows = oRows
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.FeatureControlFrameRows Property


FeatureControlFrame.Layer Property

FeatureControlFrame.Layer Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Layer Property


FeatureControlFrame.Leader Property

FeatureControlFrame.Leader Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the leader associated with the feature control frame symbol.

Visual Basic
Property Leader() As Leader**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Leader Property


FeatureControlFrame.Notes Property

FeatureControlFrame.Notes Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets notes for the feature control frame.

Visual Basic
Property Notes() As String
Remarks

The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify an 'M' with a circle around it:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Notes Property


FeatureControlFrame.Parent Property

FeatureControlFrame.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent Sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Parent Property


FeatureControlFrame.Position Property

FeatureControlFrame.Position Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the symbol on the sheet. Changing the position of the symbol does not affect the position of the root node of its leader. It only repositions the symbol along the landing line.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Position Property


FeatureControlFrame.Rotation Property

FeatureControlFrame.Rotation Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the absolute rotation angle of the symbol in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, 'pi/2, 'pi, and '1.5pi.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Rotation Property


FeatureControlFrame.Style Property

FeatureControlFrame.Style Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets and sets the associated FeatureControlFrameStyle object.

Visual Basic
Property Style() As FeatureControlFrameStyle*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Style Property


FeatureControlFrame.Type Property

FeatureControlFrame.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kFeatureControlFrameObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrame Interface > FeatureControlFrame Properties > FeatureControlFrame.Type Property


FeatureControlFrameRow Interface

FeatureControlFrameRow Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FeatureControlFrameRow object represents a row within a feature control frame symbol.

Class Hierarchy
Inventor::FeatureControlFrameRow
Visual Basic
Public Interface FeatureControlFrameRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FeatureControlFrameRows.Add

FeatureControlFrameRows.Item

See Also

Adding and editing a feature control frame sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface


FeatureControlFrameRow Methods

FeatureControlFrameRow Methods
Summary

The methods of the FeatureControlFrameRow class are listed here.

Methods
Methods
Name | Description
Delete | The row of the feature control frame.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Methods


FeatureControlFrameRow.Delete Method

FeatureControlFrameRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The row of the feature control frame.

Visual Basic
Sub Delete()
Remarks

If this is not the last row of the feature control frame, all the rows below this row are also deleted. The first row of the symbol cannot be deleted, so this method will return an error.

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Methods > FeatureControlFrameRow.Delete Method


FeatureControlFrameRow Properties

FeatureControlFrameRow Properties
Summary

The properties of the FeatureControlFrameRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DatumOne | property that gets and sets the first datum that affects the tolerance.
DatumThree | Property that gets and sets the third datum that affects the tolerance.
DatumTwo | Property that gets and sets the second datum that affects the tolerance.
GeometricCharacteristic | Property that gets and sets the geometric characteristic symbol for the row.
LowerTolerance | Property that gets and sets the lower tolerance associated with this geometric characteristic. Applies to ANSI standard only.
Parent | Property that returns the parent FeatureControlFrame object.
Tolerance | Property that gets and sets the tolerance associated with this geometric characteristic.
Type | Property returning kFeatureControlFrameRowObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties


FeatureControlFrameRow.Application Property

FeatureControlFrameRow.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.Application Property


FeatureControlFrameRow.DatumOne Property

FeatureControlFrameRow.DatumOne Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

property that gets and sets the first datum that affects the tolerance.

Visual Basic
Property DatumOne() As String
Remarks

The property returns a null string if the datum is not specified. The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.DatumOne Property


FeatureControlFrameRow.DatumThree Property

FeatureControlFrameRow.DatumThree Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the third datum that affects the tolerance.

Visual Basic
Property DatumThree() As String
Remarks

The property returns a null string if the datum is not specified. The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.DatumThree Property


FeatureControlFrameRow.DatumTwo Property

FeatureControlFrameRow.DatumTwo Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the second datum that affects the tolerance.

Visual Basic
Property DatumTwo() As String
Remarks

The property returns a null string if the datum is not specified. The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.DatumTwo Property


FeatureControlFrameRow.GeometricCharacteristic Property

FeatureControlFrameRow.GeometricCharacteristic Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the geometric characteristic symbol for the row.

Visual Basic
Property GeometricCharacteristic() As GeometricCharacteristicEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.GeometricCharacteristic Property


FeatureControlFrameRow.LowerTolerance Property

FeatureControlFrameRow.LowerTolerance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the lower tolerance associated with this geometric characteristic. Applies to ANSI standard only.

Visual Basic
Property LowerTolerance() As String
Remarks

The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.LowerTolerance Property


FeatureControlFrameRow.Parent Property

FeatureControlFrameRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent FeatureControlFrame object.

Visual Basic
Property Parent() As FeatureControlFrame**
Remarks

This property returns Nothing if the FeatureControlFrameRows object was not obtained from a symbol but was created using the CreateFeatureControlFrameRows method.

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.Parent Property


FeatureControlFrameRow.Tolerance Property

FeatureControlFrameRow.Tolerance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the tolerance associated with this geometric characteristic.

Visual Basic
Property Tolerance() As String
Remarks

The string can contain symbols specified using the StyleOverride tag. For instance, use '<StyleOverride Font='AIGDT'>m</StyleOverride>' to specify:

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.Tolerance Property


FeatureControlFrameRow.Type Property

FeatureControlFrameRow.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kFeatureControlFrameRowObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRow Interface > FeatureControlFrameRow Properties > FeatureControlFrameRow.Type Property


FeatureControlFrameRows Interface

FeatureControlFrameRows Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FeatureControlFrameRows object provides access to all rows of a feature control frame.

Class Hierarchy
Inventor::FeatureControlFrameRows
Visual Basic
Public Interface FeatureControlFrameRows
Inherits IDispatch
Remarks

This object is also used to define the rows during feature control frame creation.

Notes

Members through which this object may be accessed include:

FeatureControlFrame.FeatureControlFrameRows

FeatureControlFrames.CreateFeatureControlFrameRows

See Also

Adding and editing a feature control frame sample

Create a feature control frame symbol sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface


FeatureControlFrameRows Methods

FeatureControlFrameRows Methods
Summary

The methods of the FeatureControlFrameRows class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a row to the feature control frame.
Item | Method that returns the specified FeatureControlFrameRow object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Methods


FeatureControlFrameRows.Add Method

FeatureControlFrameRows.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that adds a row to the feature control frame.

Visual Basic
Sub Add(GeometricCharacteristic As GeometricCharacteristicEnum, Tolerance As String, ByRef LowerTolerance As [defaultvalue("")] BSTR, ByRef DatumOne As [defaultvalue("")] BSTR, ByRef DatumTwo As [defaultvalue("")] BSTR, ByRef DatumThree As [defaultvalue("")] BSTR, Result As [out, retval] FeatureControlFrameRow*)
Parameters
Parameters | Description
GeometricCharacteristic | Input GeometricCharacteristicEnum that specifies the geometric characteristic symbol for the row.
Tolerance | Input String that specifies the tolerance associated with this geometric characteristic. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
LowerTolerance | Optional input String that specifies the lower tolerance associated with this geometric characteristic. Applies to ANSI standard only. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
DatumOne | Optional input String that specifies the first datum that affects the tolerance. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
DatumTwo | Optional input String that specifies the second datum that affects the tolerance. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
DatumThree | Optional input String that specifies the third datum that affects the tolerance. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
See Also

Adding and editing a feature control frame sample

Create a feature control frame symbol sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Methods > FeatureControlFrameRows.Add Method


FeatureControlFrameRows.Item Method

FeatureControlFrameRows.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified FeatureControlFrameRow object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] FeatureControlFrameRow*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Methods > FeatureControlFrameRows.Item Method


FeatureControlFrameRows Properties

FeatureControlFrameRows Properties
Summary

The properties of the FeatureControlFrameRows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kFeatureControlFrameRowsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Properties


FeatureControlFrameRows.Application Property

FeatureControlFrameRows.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Properties > FeatureControlFrameRows.Application Property


FeatureControlFrameRows.Count Property

FeatureControlFrameRows.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Properties > FeatureControlFrameRows.Count Property


FeatureControlFrameRows.Type Property

FeatureControlFrameRows.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kFeatureControlFrameRowsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameRows Interface > FeatureControlFrameRows Properties > FeatureControlFrameRows.Type Property


FeatureControlFrames Interface

FeatureControlFrames Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FeatureControlFrames collection object provides access to all the feature control frame symbols on a sheet and provides methods to create additional ones.

Class Hierarchy
Inventor::FeatureControlFrames
Visual Basic
Public Interface FeatureControlFrames
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.FeatureControlFrames

See Also

Adding and editing a feature control frame sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface


FeatureControlFrames Methods

FeatureControlFrames Methods
Summary

The methods of the FeatureControlFrames class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a feature control frame symbol.
CreateFeatureControlFrameRows | Method that creates a new FeatureControlFrameRows object.
Item | Method that returns the specified FeatureControlFrame object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Methods


FeatureControlFrames.Add Method

FeatureControlFrames.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a feature control frame symbol.

Visual Basic
Sub Add(LeaderPoints As ObjectCollection, FeatureControlFrameRows As FeatureControlFrameRows, ByRef AllAroundSymbol As [defaultvalue(0)] VARIANT_BOOL, ByRef DatumIdentifier As [defaultvalue("")] BSTR, ByRef Notes As [defaultvalue("")] BSTR, ByRef FeatureControlFrameStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] FeatureControlFrame*)
Parameters
Parameters | Description
LeaderPoints | Input ObjectCollection containing a series of Point2d objects representing the leader originating at the symbol. The last item in the collection (even if it is the only item) can be a GeometryIntent object indicating a geometry to attach the leader to. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method. The ObjectCollection must contain at least one item, else the method will fail.
FeatureControlFrameRows | Input FeatureControlFrameRows object containing the definition of the rows of the feature control frame. The FeatureControlFrameRows object is created using the CreateFeatureControlFrameRows method on the FeatureControlFrames collection object.
AllAroundSymbol | Optional input Boolean that specifies whether to add the all-around indicator to the symbol. The diameter is specified in the leader style. Defaults to False.
DatumIdentifier | Optional input String that specifies a datum identifier for the feature control frame. This argument is ignored if the associated style does not allow the specification of a datum identifier. This can be checked using the FeatureControlFrameStyle.AllowDatumIdentifier property. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
Notes | Optional input String that specifies notes for the feature control frame symbol. The string can contain symbols specified using the StyleOverride tag. For instance, use 'm' to specify m.
FeatureControlFrameStyle | Optional input FeatureControlFrameStyle object which specifies the feature control frame style to use for the symbol. If not specified, the style defined by the active standard is used.
Layer | Optional input Layer object that specifies the layer to use for the symbol. If not specified, the layer defined by the active standard is used.
Example

"Create a feature control frame symbol"

This sample demonstrates the creation of a feature control frame symbol. Select a linear drawing curve and run the sample.

Public Sub AddFeatureControlFrame()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the drawing curve segment.
    ' This assumes that a drwaing curve is selected.
    Dim oDrawingCurveSegment As DrawingCurveSegment
    Set oDrawingCurveSegment = oDrawDoc.SelectSet.Item(1)

    ' Set a reference to the drawing curve.
    Dim oDrawingCurve As DrawingCurve
    Set oDrawingCurve = oDrawingCurveSegment.Parent

    ' Get the mid point of the selected curve
    ' assuming that the selection curve is linear
    Dim oMidPoint As Point2d
    Set oMidPoint = oDrawingCurve.MidPoint

    ' Set a reference to the TransientGeometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oLeaderPoints As ObjectCollection
    Set oLeaderPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Create a few leader points.
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 10))
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 5))

    ' Create an intent and add to the leader points collection.
    ' This is the geometry that the symbol will attach to.
    Dim oGeometryIntent As GeometryIntent
    Set oGeometryIntent = oActiveSheet.CreateGeometryIntent(oDrawingCurve)
    Call oLeaderPoints.Add(oGeometryIntent)

    ' Create a FeatureControlFrameRows object to define the symbol's rows
    Dim oRows As FeatureControlFrameRows
    Set oRows = oActiveSheet.FeatureControlFrames.CreateFeatureControlFrameRows

    ' Add a row
    Dim oRow As FeatureControlFrameRow
    Set oRow = oRows.Add(kProfileOfAnySurface, "0.20", , "A", "B")

    ' Create the feature control frame symbol with a leader
    Dim oSymbol As FeatureControlFrame
    Set oSymbol = oActiveSheet.FeatureControlFrames.Add(oLeaderPoints, oRows)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Methods > FeatureControlFrames.Add Method


FeatureControlFrames.CreateFeatureControlFrameRows Method

FeatureControlFrames.CreateFeatureControlFrameRows Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new FeatureControlFrameRows object.

Visual Basic
Sub CreateFeatureControlFrameRows(Result As [out, retval] FeatureControlFrameRows*)
Remarks

This object defines the rows of the feature control frame and is used as input in the Add method to create feature control frames. The object is initially created with no rows. Use the FeatureControlFrameRows.Add method to add rows before using this as input in the Add method.

See Also

Adding and editing a feature control frame sample

Create a feature control frame symbol sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Methods > FeatureControlFrames.CreateFeatureControlFrameRows Method


FeatureControlFrames.Item Method

FeatureControlFrames.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified FeatureControlFrame object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] FeatureControlFrame*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Methods > FeatureControlFrames.Item Method


FeatureControlFrames Properties

FeatureControlFrames Properties
Summary

The properties of the FeatureControlFrames class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kFeatureControlFramesObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Properties


FeatureControlFrames.Application Property

FeatureControlFrames.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Properties > FeatureControlFrames.Application Property


FeatureControlFrames.Count Property

FeatureControlFrames.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Properties > FeatureControlFrames.Count Property


FeatureControlFrames.Type Property

FeatureControlFrames.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kFeatureControlFramesObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrames Interface > FeatureControlFrames Properties > FeatureControlFrames.Type Property


FeatureControlFrameStyle Interface

FeatureControlFrameStyle Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FeatureControlFrameStyle object represents a feature control frame style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::FeatureControlFrameStyle
Visual Basic
Public Interface FeatureControlFrameStyle
Inherits Style
Notes

Members through which this object may be accessed include:

FeatureControlFrame.Style

FeatureControlFrameStylesEnumerator.Item

ObjectDefaultsStyle.FeatureControlFrameStyle

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface


FeatureControlFrameStyle Properties

FeatureControlFrameStyle Properties
Summary

The properties of the FeatureControlFrameStyle class are listed here.

Properties
Name | Description
AlignCellsVertically | Property that gets and sets whether to add spaces to short cells so that pairs of cells align vertically.
AllowTolerance2 | Property that gets and sets whether to provide the ability to add a second tolerance in the feature control frame dialog.
AlternateDecimalMarkerType | Property that gets and sets the character to use as a decimal marker for alternate units. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateDisplayUnitType | Property that gets and sets the arrangement of the alternate units display with respect to the primary units. The primary unit always precedes the alternate unit. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateLeadingZeroDisplay | Property that gets and sets whether to display the leading zeroes for alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateLinearPrecision | Property that gets and sets the precision for linear alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateLinearUnits | Property that gets and sets the units of length measure used for alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateTrailingZeroDisplay | Property that gets and sets whether to display the trailing zeroes for alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.
AlternateUnitsDisplay | Property that gets and sets whether to display alternate units.
AlternateUnitsDisplayType | Property that gets and sets the arrangement of the alternate units display with respect to the primary units. The primary unit always precedes the alternate unit. This property is used only when the AlternateUnitsDisplay property is set to true.
AttachLeaderToCorner | Property that gets and sets whether the leader terminates on the corner of the frame or at the midpoint of a vertical leg of the frame.
AvailableGeometricCharacteristics | Property that gets and sets the geometric characteristics to be made available in the feature control frame creation and edit dialog. A combination of enum values can be provided.
AvailableModifiers | Property that gets and sets the material removal modifiers to be made available in the feature control frame creation and edit dialog. A combination of enum values can be provided.
DecimalMarkerType | Property that gets and sets the character to use as a decimal marker for primary units. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker.
DisplayUnitType | Property that gets and sets whether to display units string for primary units.
LeaderStyle | Property that gets and sets the leader style used for a feature control frame symbol.
LeadingZeroDisplay | Property that gets and sets whether to display the leading zeroes for primary units.
LinearUnits | Property that gets and sets the units of length measure.
MergeDatum | Property that gets and sets whether to merge datum cells when the data is the same.
MergeSymbol | Property that gets and sets whether to merge symbol cells when the data is the same.
MergeTolerance | Property that gets and sets whether to merge tolerance cells when the data is the same.
ScaleToTextHeight | Property that gets and sets whether to define the symbol size by text height.
Size | Property that gets and sets the size of the feature control frame in linear units. This value is used only if the ScaleToTextHeight property is set to False.
TextStyle | Property that gets and sets the text style used to format the text in a feature control frame symbol.
TrailingZeroDisplay | Property that gets and sets whether to display the trailing zeroes for primary units.
WhiteSpace | Property that gets and sets the space before and after text in the tolerance and datum cells.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties


FeatureControlFrameStyle.AlignCellsVertically Property

FeatureControlFrameStyle.AlignCellsVertically Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to add spaces to short cells so that pairs of cells align vertically.

Visual Basic
Property AlignCellsVertically() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlignCellsVertically Property


FeatureControlFrameStyle.AllowTolerance2 Property

FeatureControlFrameStyle.AllowTolerance2 Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to provide the ability to add a second tolerance in the feature control frame dialog.

Visual Basic
Property AllowTolerance2() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AllowTolerance2 Property


FeatureControlFrameStyle.AlternateDecimalMarkerType Property

FeatureControlFrameStyle.AlternateDecimalMarkerType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the character to use as a decimal marker for alternate units. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateDecimalMarkerType() As DecimalMarkerTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateDecimalMarkerType Property


FeatureControlFrameStyle.AlternateDisplayUnitType Property

FeatureControlFrameStyle.AlternateDisplayUnitType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the arrangement of the alternate units display with respect to the primary units. The primary unit always precedes the alternate unit. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateDisplayUnitType() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateDisplayUnitType Property


FeatureControlFrameStyle.AlternateLeadingZeroDisplay Property

FeatureControlFrameStyle.AlternateLeadingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to display the leading zeroes for alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateLeadingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateLeadingZeroDisplay Property


FeatureControlFrameStyle.AlternateLinearPrecision Property

FeatureControlFrameStyle.AlternateLinearPrecision Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the precision for linear alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateLinearPrecision() As LinearPrecisionEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateLinearPrecision Property


FeatureControlFrameStyle.AlternateLinearUnits Property

FeatureControlFrameStyle.AlternateLinearUnits Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the units of length measure used for alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateLinearUnits() As UnitsTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateLinearUnits Property


FeatureControlFrameStyle.AlternateTrailingZeroDisplay Property

FeatureControlFrameStyle.AlternateTrailingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to display the trailing zeroes for alternate units. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateTrailingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateTrailingZeroDisplay Property


FeatureControlFrameStyle.AlternateUnitsDisplay Property

FeatureControlFrameStyle.AlternateUnitsDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to display alternate units.

Visual Basic
Property AlternateUnitsDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateUnitsDisplay Property


FeatureControlFrameStyle.AlternateUnitsDisplayType Property

FeatureControlFrameStyle.AlternateUnitsDisplayType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the arrangement of the alternate units display with respect to the primary units. The primary unit always precedes the alternate unit. This property is used only when the AlternateUnitsDisplay property is set to true.

Visual Basic
Property AlternateUnitsDisplayType() As AlternateUnitsDisplayTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AlternateUnitsDisplayType Property


FeatureControlFrameStyle.AttachLeaderToCorner Property

FeatureControlFrameStyle.AttachLeaderToCorner Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the leader terminates on the corner of the frame or at the midpoint of a vertical leg of the frame.

Visual Basic
Property AttachLeaderToCorner() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AttachLeaderToCorner Property


FeatureControlFrameStyle.AvailableGeometricCharacteristics Property

FeatureControlFrameStyle.AvailableGeometricCharacteristics Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the geometric characteristics to be made available in the feature control frame creation and edit dialog. A combination of enum values can be provided.

Visual Basic
Property AvailableGeometricCharacteristics() As GeometricCharacteristicEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AvailableGeometricCharacteristics Property


FeatureControlFrameStyle.AvailableModifiers Property

FeatureControlFrameStyle.AvailableModifiers Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the material removal modifiers to be made available in the feature control frame creation and edit dialog. A combination of enum values can be provided.

Visual Basic
Property AvailableModifiers() As MaterialRemovalModifierEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.AvailableModifiers Property


FeatureControlFrameStyle.DecimalMarkerType Property

FeatureControlFrameStyle.DecimalMarkerType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the character to use as a decimal marker for primary units. Valid values are kPeriodDecimalMarker and kCommaDecimalMarker.

Visual Basic
Property DecimalMarkerType() As DecimalMarkerTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.DecimalMarkerType Property


FeatureControlFrameStyle.DisplayUnitType Property

FeatureControlFrameStyle.DisplayUnitType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to display units string for primary units.

Visual Basic
Property DisplayUnitType() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.DisplayUnitType Property


FeatureControlFrameStyle.LeaderStyle Property

FeatureControlFrameStyle.LeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the leader style used for a feature control frame symbol.

Visual Basic
Property LeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.LeaderStyle Property


FeatureControlFrameStyle.LeadingZeroDisplay Property

FeatureControlFrameStyle.LeadingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to display the leading zeroes for primary units.

Visual Basic
Property LeadingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.LeadingZeroDisplay Property


FeatureControlFrameStyle.LinearUnits Property

FeatureControlFrameStyle.LinearUnits Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the units of length measure.

Visual Basic
Property LinearUnits() As UnitsTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.LinearUnits Property


FeatureControlFrameStyle.MergeDatum Property

FeatureControlFrameStyle.MergeDatum Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to merge datum cells when the data is the same.

Visual Basic
Property MergeDatum() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.MergeDatum Property


FeatureControlFrameStyle.MergeSymbol Property

FeatureControlFrameStyle.MergeSymbol Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to merge symbol cells when the data is the same.

Visual Basic
Property MergeSymbol() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.MergeSymbol Property


FeatureControlFrameStyle.MergeTolerance Property

FeatureControlFrameStyle.MergeTolerance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to merge tolerance cells when the data is the same.

Visual Basic
Property MergeTolerance() As VARIANT_BOOL
Remarks

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.MergeTolerance Property


FeatureControlFrameStyle.ScaleToTextHeight Property

FeatureControlFrameStyle.ScaleToTextHeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to define the symbol size by text height.

Visual Basic
Property ScaleToTextHeight() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.ScaleToTextHeight Property


FeatureControlFrameStyle.Size Property

FeatureControlFrameStyle.Size Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the size of the feature control frame in linear units. This value is used only if the ScaleToTextHeight property is set to False.

Visual Basic
Property Size() As double
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.Size Property


FeatureControlFrameStyle.TextStyle Property

FeatureControlFrameStyle.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used to format the text in a feature control frame symbol.

Visual Basic
Property TextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.TextStyle Property


FeatureControlFrameStyle.TrailingZeroDisplay Property

FeatureControlFrameStyle.TrailingZeroDisplay Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to display the trailing zeroes for primary units.

Visual Basic
Property TrailingZeroDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.TrailingZeroDisplay Property


FeatureControlFrameStyle.WhiteSpace Property

FeatureControlFrameStyle.WhiteSpace Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the space before and after text in the tolerance and datum cells.

Visual Basic
Property WhiteSpace() As double
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStyle Interface > FeatureControlFrameStyle Properties > FeatureControlFrameStyle.WhiteSpace Property


FeatureControlFrameStylesEnumerator Interface

FeatureControlFrameStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FeatureControlFrameStylesEnumerator object provides access to the existing FeatureControlFrameStyle objects.

Class Hierarchy
Inventor::FeatureControlFrameStylesEnumerator
Visual Basic
Public Interface FeatureControlFrameStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.FeatureControlFrameStyles

You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface


FeatureControlFrameStylesEnumerator Methods

FeatureControlFrameStylesEnumerator Methods
Summary

The methods of the FeatureControlFrameStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified FeatureControlFrameStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface > FeatureControlFrameStylesEnumerator Methods


FeatureControlFrameStylesEnumerator.Item Method

FeatureControlFrameStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified FeatureControlFrameStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FeatureControlFrameStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the FeatureControlFrameStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the FeatureControlFrameStyle name. If an out of range index or a name of a non-existent FeatureControlFrameStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface > FeatureControlFrameStylesEnumerator Methods > FeatureControlFrameStylesEnumerator.Item Method


FeatureControlFrameStylesEnumerator Properties

FeatureControlFrameStylesEnumerator Properties
Summary

The properties of the FeatureControlFrameStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kFeatureControlFrameStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface > FeatureControlFrameStylesEnumerator Properties


FeatureControlFrameStylesEnumerator.Application Property

FeatureControlFrameStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface > FeatureControlFrameStylesEnumerator Properties > FeatureControlFrameStylesEnumerator.Application Property


FeatureControlFrameStylesEnumerator.Count Property

FeatureControlFrameStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface > FeatureControlFrameStylesEnumerator Properties > FeatureControlFrameStylesEnumerator.Count Property


FeatureControlFrameStylesEnumerator.Type Property

FeatureControlFrameStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kFeatureControlFrameStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureControlFrameStylesEnumerator Interface > FeatureControlFrameStylesEnumerator Properties > FeatureControlFrameStylesEnumerator.Type Property


FeatureDimension Interface

FeatureDimension Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

A FeatureDimension object represents a dimension associated with a feature.

Class Hierarchy
Inventor::FeatureDimension
    Inventor::FeatureDimensionProxy
Visual Basic
Public Interface FeatureDimension
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FeatureDimensionProxy.NativeObject

FeatureDimensions.Item

GeneralDimension.RetrievedFrom

See Also

Query feature dimensions sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface


FeatureDimension Methods

FeatureDimension Methods
Summary

The methods of the FeatureDimension class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | This is GetReferenceKey, a member of class FeatureDimension.
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Methods


FeatureDimension.GetReferenceKey Method

FeatureDimension.GetReferenceKey Method
Summary

This is GetReferenceKey, a member of class FeatureDimension.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Methods > FeatureDimension.GetReferenceKey Method


FeatureDimension Properties

FeatureDimension Properties
Summary

The properties of the FeatureDimension class are listed here.

Properties
Name | Description
AnchorPoints | This is AnchorPoints, a member of class FeatureDimension.
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
AttributeSets | This is AttributeSets, a member of class FeatureDimension.
DimensionType | This is DimensionType, a member of class FeatureDimension.
Parameter | Property that returns the parameter associated with the dimension.
Parent | Property that returns the parent PartFeature object.
TextPoint | Property that returns the position of the dimension text.
Type | Property returning kFeatureDimensionObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties


FeatureDimension.AnchorPoints Property

FeatureDimension.AnchorPoints Property
Summary

This is AnchorPoints, a member of class FeatureDimension.

Visual Basic
Property AnchorPoints() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.AnchorPoints Property


FeatureDimension.Application Property

FeatureDimension.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.Application Property


FeatureDimension.AttributeSets Property

FeatureDimension.AttributeSets Property
Summary

This is AttributeSets, a member of class FeatureDimension.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.AttributeSets Property


FeatureDimension.DimensionType Property

FeatureDimension.DimensionType Property
Summary

This is DimensionType, a member of class FeatureDimension.

Visual Basic
Property DimensionType() As FeatureDimensionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.DimensionType Property


FeatureDimension.Parameter Property

FeatureDimension.Parameter Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parameter associated with the dimension.

Visual Basic
Property Parameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.Parameter Property


FeatureDimension.Parent Property

FeatureDimension.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent PartFeature object.

Visual Basic
Property Parent() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.Parent Property


FeatureDimension.TextPoint Property

FeatureDimension.TextPoint Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the position of the dimension text.

Visual Basic
Property TextPoint() As Point**
See Also

Query feature dimensions sample

You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.TextPoint Property


FeatureDimension.Type Property

FeatureDimension.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kFeatureDimensionObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimension Interface > FeatureDimension Properties > FeatureDimension.Type Property


FeatureDimensionProxy Interface

FeatureDimensionProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FeatureDimension object.

Class Hierarchy
Inventor::FeatureDimension
    Inventor::FeatureDimensionProxy
Visual Basic
Public Interface FeatureDimensionProxy
Inherits FeatureDimension
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensionProxy Interface


FeatureDimensionProxy Properties

FeatureDimensionProxy Properties
Summary

The properties of the FeatureDimensionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensionProxy Interface > FeatureDimensionProxy Properties


FeatureDimensionProxy.ContainingOccurrence Property

FeatureDimensionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensionProxy Interface > FeatureDimensionProxy Properties > FeatureDimensionProxy.ContainingOccurrence Property


FeatureDimensionProxy.NativeObject Property

FeatureDimensionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FeatureDimension**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensionProxy Interface > FeatureDimensionProxy Properties > FeatureDimensionProxy.NativeObject Property


FeatureDimensions Interface

FeatureDimensions Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The FeatureDimensions collection object contains all the dimensions that are associated with a feature. These do not include the dimensions within sketches used by the feature.

Class Hierarchy
Inventor::FeatureDimensions
Visual Basic
Public Interface FeatureDimensions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeature.FeatureDimensions

Example

"Query feature dimensions"

This sample demonstrates querying the dimensions of a feature in a part or an assembly document. The sample also demonstrates how to show the dimensions of a feature.

Sub QueryAndShowFeatureDimensions()

    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Check to make sure a feature is selected.
    If Not Typeof oDoc.SelectSet.Item(1) Is PartFeature Then
        MsgBox "A feature must be selected."
        Exit Sub
    End If

    ' Set a reference to the selected feature.
    Dim oFeature As PartFeature
    Set oFeature = oDoc.SelectSet.Item(1)

    Dim oFeatureDim As FeatureDimension
    Dim i As Long
    i = 0
    ' Iterate over all dimensions of the feature.
    For Each oFeatureDim In oFeature.FeatureDimensions
        i = i + 1
        ' Format and print the name and position.
        Debug.Print i & ". Name: " & oFeatureDim.Parameter.Name _
                 & "  Position: (" & oFeatureDim.TextPoint.X & _
                              ", " & oFeatureDim.TextPoint.Y & _
                              ", " & oFeatureDim.TextPoint.Z & ")"
    Next

    ' Show all the feature dimensions
    oFeature.FeatureDimensions.Show
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface


FeatureDimensions Methods

FeatureDimensions Methods
Summary

The methods of the FeatureDimensions class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified FeatureDimension object from the collection.
Show | Method that displays all the dimensions for the feature. This is the equivalent of the 'Show Dimensions' command in the user interface.
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Methods


FeatureDimensions.Item Method

FeatureDimensions.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified FeatureDimension object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FeatureDimension*)
Parameters
Parameters | Description
index | Input Variant value that specifies the FeatureDimension to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the name of the parameter associated with the dimension. If an out of range index or a name of a non-existent FeatureDimension is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Methods > FeatureDimensions.Item Method


FeatureDimensions.Show Method

FeatureDimensions.Show Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that displays all the dimensions for the feature. This is the equivalent of the 'Show Dimensions' command in the user interface.

Visual Basic
Sub Show()
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Methods > FeatureDimensions.Show Method


FeatureDimensions Properties

FeatureDimensions Properties
Summary

The properties of the FeatureDimensions class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that returns the number of items in the collection.
Type | Property returning kFeatureDimensionsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Properties


FeatureDimensions.Application Property

FeatureDimensions.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Properties > FeatureDimensions.Application Property


FeatureDimensions.Count Property

FeatureDimensions.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Properties > FeatureDimensions.Count Property


FeatureDimensions.Type Property

FeatureDimensions.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kFeatureDimensionsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeatureDimensions Interface > FeatureDimensions Properties > FeatureDimensions.Type Property


FeaturePatternElement Interface

FeaturePatternElement Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

Represents a single instance within a feature pattern.

Class Hierarchy
Inventor::FeaturePatternElement
    Inventor::FeaturePatternElementProxy
Visual Basic
Public Interface FeaturePatternElement
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FeaturePatternElementProxy.NativeObject

FeaturePatternElements.Item

You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface


FeaturePatternElement Methods

FeaturePatternElement Methods
Summary

The methods of the FeaturePatternElement class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Methods


FeaturePatternElement.GetReferenceKey Method

FeaturePatternElement.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Methods > FeaturePatternElement.GetReferenceKey Method


FeaturePatternElement Properties

FeaturePatternElement Properties
Summary

The properties of the FeaturePatternElement class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Faces | Property that returns a collection object generated as a result of the feature.
Index | Property that returns the index of this element within the pattern.
Parent | Property that returns the feature pattern this element is a member of.
ResultFeatures | Property that returns the features that were created for this pattern element. These can be work planes, work axes, work points and work surfaces.
Suppressed | Property that gets and sets whether the element is suppressed or not. A value of True indicates it is suppressed.
Transform | Property that returns the transform that describes this occurrences relative position to the parent feature(s). The transform returned for the first element in a pattern (the parent feature(s)) will be an identity matrix.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties


FeaturePatternElement.Application Property

FeaturePatternElement.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Application Property


FeaturePatternElement.AttributeSets Property

FeaturePatternElement.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.AttributeSets Property


FeaturePatternElement.Faces Property

FeaturePatternElement.Faces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a collection object generated as a result of the feature.

Visual Basic
Property Faces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Faces Property


FeaturePatternElement.Index Property

FeaturePatternElement.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this element within the pattern.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Index Property


FeaturePatternElement.Parent Property

FeaturePatternElement.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the feature pattern this element is a member of.

Visual Basic
Property Parent() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Parent Property


FeaturePatternElement.ResultFeatures Property

FeaturePatternElement.ResultFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the features that were created for this pattern element. These can be work planes, work axes, work points and work surfaces.

Visual Basic
Property ResultFeatures() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.ResultFeatures Property


FeaturePatternElement.Suppressed Property

FeaturePatternElement.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the element is suppressed or not. A value of True indicates it is suppressed.

Visual Basic
Property Suppressed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Suppressed Property


FeaturePatternElement.Transform Property

FeaturePatternElement.Transform Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the transform that describes this occurrences relative position to the parent feature(s). The transform returned for the first element in a pattern (the parent feature(s)) will be an identity matrix.

Visual Basic
Property Transform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Transform Property


FeaturePatternElement.Type Property

FeaturePatternElement.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElement Interface > FeaturePatternElement Properties > FeaturePatternElement.Type Property


FeaturePatternElementProxy Interface

FeaturePatternElementProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FeaturePatternElement object.

Class Hierarchy
Inventor::FeaturePatternElement
    Inventor::FeaturePatternElementProxy
Visual Basic
Public Interface FeaturePatternElementProxy
Inherits FeaturePatternElement
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElementProxy Interface


FeaturePatternElementProxy Properties

FeaturePatternElementProxy Properties
Summary

The properties of the FeaturePatternElementProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElementProxy Interface > FeaturePatternElementProxy Properties


FeaturePatternElementProxy.ContainingOccurrence Property

FeaturePatternElementProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElementProxy Interface > FeaturePatternElementProxy Properties > FeaturePatternElementProxy.ContainingOccurrence Property


FeaturePatternElementProxy.NativeObject Property

FeaturePatternElementProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FeaturePatternElement**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElementProxy Interface > FeaturePatternElementProxy Properties > FeaturePatternElementProxy.NativeObject Property


FeaturePatternElements Interface

FeaturePatternElements Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

Provides access to the instances ( objects) that result from the creation of a feature pattern.

Class Hierarchy
Inventor::FeaturePatternElements
Visual Basic
Public Interface FeaturePatternElements
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CircularPatternFeature.PatternElements

MirrorFeature.PatternElements

RectangularPatternFeature.PatternElements

You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface


FeaturePatternElements Methods

FeaturePatternElements Methods
Summary

The methods of the FeaturePatternElements class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection. This is the default property of the FeaturePatternElements collection object.
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface > FeaturePatternElements Methods


FeaturePatternElements.Item Method

FeaturePatternElements.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection. This is the default property of the FeaturePatternElements collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] FeaturePatternElement*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface > FeaturePatternElements Methods > FeaturePatternElements.Item Method


FeaturePatternElements Properties

FeaturePatternElements Properties
Summary

The properties of the FeaturePatternElements class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface > FeaturePatternElements Properties


FeaturePatternElements.Application Property

FeaturePatternElements.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface > FeaturePatternElements Properties > FeaturePatternElements.Application Property


FeaturePatternElements.Count Property

FeaturePatternElements.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface > FeaturePatternElements Properties > FeaturePatternElements.Count Property


FeaturePatternElements.Type Property

FeaturePatternElements.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FeaturePatternElements Interface > FeaturePatternElements Properties > FeaturePatternElements.Type Property


Features Interface

Features Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

Represents the collection of features in the assembly context. The API does not yet support addition of assembly features.

Class Hierarchy
Inventor::Features
Visual Basic
Public Interface Features
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.Features

See Also

Create sheet metal lofted flange feature sample

Sketch Share sample

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > Features Interface


Features Methods

Features Methods
Summary

The methods of the Features class are listed here.

Methods
Methods
Name | Description
CreatePath | Method that creates a path used to define the shape of several part features such as Sweep, RectangularPattern, Split, etc. All other 2D and 3D curves that are connected to the input curve are obtained and used to create a Path object. The new Path is returned.
CreateSpecifiedPath | Method that creates a path used to define the shape of several part features such as Sweep, RectangularPattern, Split, etc. The new Path is returned. This method will fail if the input curves are not connected end to end.
Item |
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Methods


Features.CreatePath Method

Features.CreatePath Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a path used to define the shape of several part features such as Sweep, RectangularPattern, Split, etc. All other 2D and 3D curves that are connected to the input curve are obtained and used to create a Path object. The new Path is returned.

Visual Basic
Sub CreatePath(SketchCurve As IDispatch, Result As [out, retval] Path*)
Parameters
Parameters | Description
SketchCurve | Input sketch (planar or 3D) entity. This can be any entity that is part of the desired path. All curves that are end point connected will be found and used to create the path.
See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Methods > Features.CreatePath Method


Features.CreateSpecifiedPath Method

Features.CreateSpecifiedPath Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a path used to define the shape of several part features such as Sweep, RectangularPattern, Split, etc. The new Path is returned. This method will fail if the input curves are not connected end to end.

Visual Basic
Sub CreateSpecifiedPath(SketchCurves As ObjectCollection, Result As [out, retval] Path*)
Parameters
Parameters | Description
SketchCurves | Input (planar or 3D) sketch entities. These are entities that are part of the desired path. The input curves must form a contiguous set.
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Methods > Features.CreateSpecifiedPath Method


Features.Item Method

Features.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartFeature*)
Notes

For information on this item, please refer to PartFeatures::Item, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Methods > Features.Item Method


Features Properties

Features Properties
Summary

The properties of the Features class are listed here.

Properties
Name | Description
Application |
ChamferFeatures | Property that returns the ChamferFeatures collection object. This collection provides access to existing ChamferFeature objects.
CircularPatternFeatures | Property that returns the CircularPatternFeatures collection object. This collection provides access to existing CircularPatternFeature objects.
ClientFeatures | Gets the Client Features collection object.
Count |
ExtrudeFeatures | Property that returns the collection object. This collection provides access to existing ExtrudeFeature objects.
FilletFeatures | Property that returns the FilletFeatures collection object. This collection provides access to existing FilletFeature objects.
HoleFeatures | Property that returns the HoleFeatures collection object. This collection provides access to existing HoleFeature objects.
MirrorFeatures | Property that returns the MirrorFeatures collection object. This collection provides access to existing MirrorFeature objects.
MoveFaceFeatures | Property that returns the MoveFaceFeatures collection object. This collection provides access to existing MoveFaceFeatures objects.
RectangularPatternFeatures | Property that returns the RectangularPatternFeatures collection object. This collection provides access to existing RectangularPatternFeature objects.
RevolveFeatures | Property that returns the RevolveFeatures collection object. This collection provides access to existing RevolveFeature objects.
SweepFeatures | Property that returns the SweepFeatures collection object. This collection provides access to existing SweepFeature objects.
Type |
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties


Features.Application Property

Features.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property Application() As IDispatch**
Notes

For information on this item, please refer to PartFeatures::Application, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.Application Property


Features.ChamferFeatures Property

Features.ChamferFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the ChamferFeatures collection object. This collection provides access to existing ChamferFeature objects.

Visual Basic
Property ChamferFeatures() As ChamferFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.ChamferFeatures Property


Features.CircularPatternFeatures Property

Features.CircularPatternFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the CircularPatternFeatures collection object. This collection provides access to existing CircularPatternFeature objects.

Visual Basic
Property CircularPatternFeatures() As CircularPatternFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.CircularPatternFeatures Property


Features.ClientFeatures Property

Features.ClientFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the Client Features collection object.

Visual Basic
Property ClientFeatures() As ClientFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.ClientFeatures Property


Features.Count Property

Features.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property Count() As long*
Notes

For information on this item, please refer to PartFeatures::Count, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.Count Property


Features.ExtrudeFeatures Property

Features.ExtrudeFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the collection object. This collection provides access to existing ExtrudeFeature objects.

Visual Basic
Property ExtrudeFeatures() As ExtrudeFeatures**
See Also

Using Inventor's error dialog sample

Sketch Share sample

SurfaceBody Copy sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.ExtrudeFeatures Property


Features.FilletFeatures Property

Features.FilletFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the FilletFeatures collection object. This collection provides access to existing FilletFeature objects.

Visual Basic
Property FilletFeatures() As FilletFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.FilletFeatures Property


Features.HoleFeatures Property

Features.HoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the HoleFeatures collection object. This collection provides access to existing HoleFeature objects.

Visual Basic
Property HoleFeatures() As HoleFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.HoleFeatures Property


Features.MirrorFeatures Property

Features.MirrorFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the MirrorFeatures collection object. This collection provides access to existing MirrorFeature objects.

Visual Basic
Property MirrorFeatures() As MirrorFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.MirrorFeatures Property


Features.MoveFaceFeatures Property

Features.MoveFaceFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the MoveFaceFeatures collection object. This collection provides access to existing MoveFaceFeatures objects.

Visual Basic
Property MoveFaceFeatures() As MoveFaceFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.MoveFaceFeatures Property


Features.RectangularPatternFeatures Property

Features.RectangularPatternFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the RectangularPatternFeatures collection object. This collection provides access to existing RectangularPatternFeature objects.

Visual Basic
Property RectangularPatternFeatures() As RectangularPatternFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.RectangularPatternFeatures Property


Features.RevolveFeatures Property

Features.RevolveFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the RevolveFeatures collection object. This collection provides access to existing RevolveFeature objects.

Visual Basic
Property RevolveFeatures() As RevolveFeatures**
You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.RevolveFeatures Property


Features.SweepFeatures Property

Features.SweepFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the SweepFeatures collection object. This collection provides access to existing SweepFeature objects.

Visual Basic
Property SweepFeatures() As SweepFeatures**
See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.SweepFeatures Property


Features.Type Property

Features.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property Type() As ObjectTypeEnum*
Notes

For information on this item, please refer to PartFeatures::Type, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Features Interface > Features Properties > Features.Type Property


File Interface

File Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The File object represents an Inventor file on disk.

Class Hierarchy
Inventor::File
Visual Basic
Public Interface File
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.File

Document.File

FileDescriptor.Parent

FileDescriptor.ReferencedFile

FilesEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > File Interface


File Properties

File Properties
Summary

The properties of the File class are listed here.

Properties
Name | Description
AllReferencedFiles | Property that returns all the file references of this File along with all of the recursively nested references.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AvailableDocuments | Property that returns an enumeration of all the documents within this file that are currently available (i.e. have been initialized). The returned documents may or may not be open. The property returns a DocumentsEnumerator object in Inventor and a ApprenticeServerDocuments in Apprentice.
FileSaveCounter | Returns the number that is indicative of the number of times the file has been saved.
FullFileName | Property that indicates the fully qualified name of this file. This property can only be set if this file has never been saved.
InternalName | Property that gets the Internal Name (a GUID) for this File.
ReferencedFileDescriptors | Property that returns an enumeration of descriptors that represent the direct file references held by this file.
ReferencedFiles | Property that returns all the files directly referenced by this file.
ReferencingFiles | Property that returns all the files in memory that reference this file.
Type | Property returning kFileObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties


File.AllReferencedFiles Property

File.AllReferencedFiles Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the file references of this File along with all of the recursively nested references.

Visual Basic
Property AllReferencedFiles() As FilesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.AllReferencedFiles Property


File.Application Property

File.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.Application Property


File.AvailableDocuments Property

File.AvailableDocuments Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enumeration of all the documents within this file that are currently available (i.e. have been initialized). The returned documents may or may not be open. The property returns a DocumentsEnumerator object in Inventor and a ApprenticeServerDocuments in Apprentice.

Visual Basic
Property AvailableDocuments() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.AvailableDocuments Property


File.FileSaveCounter Property

File.FileSaveCounter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the number that is indicative of the number of times the file has been saved.

Visual Basic
Property FileSaveCounter() As long*
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.FileSaveCounter Property


File.FullFileName Property

File.FullFileName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the fully qualified name of this file. This property can only be set if this file has never been saved.

Visual Basic
Property FullFileName() As String
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.FullFileName Property


File.InternalName Property

File.InternalName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets the Internal Name (a GUID) for this File.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.InternalName Property


File.ReferencedFileDescriptors Property

File.ReferencedFileDescriptors Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enumeration of descriptors that represent the direct file references held by this file.

Visual Basic
Property ReferencedFileDescriptors() As FileDescriptorsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.ReferencedFileDescriptors Property


File.ReferencedFiles Property

File.ReferencedFiles Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the files directly referenced by this file.

Visual Basic
Property ReferencedFiles() As FilesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.ReferencedFiles Property


File.ReferencingFiles Property

File.ReferencingFiles Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the files in memory that reference this file.

Visual Basic
Property ReferencingFiles() As FilesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.ReferencingFiles Property


File.Type Property

File.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kFileObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > File Interface > File Properties > File.Type Property


FileAccessEvents CoClass

FileAccessEvents CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

The FileAccessEvents object supports a set of properties and events used to get access to files.

Class Hierarchy
Inventor::FileAccessEvents
Visual Basic
Public Class FileAccessEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

ApprenticeServer.FileAccessEvents

Application.FileAccessEvents

You are here: Symbol Reference > Inventor Library > Objects > FileAccessEvents CoClass


FileAccessEventsObject Interface

FileAccessEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The FileAccessEvents object supports a set of properties and events used to get access to files.

Class Hierarchy
Inventor::FileAccessEventsObject
Visual Basic
Public Interface FileAccessEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface


FileAccessEventsObject Methods

FileAccessEventsObject Methods
Summary

The methods of the FileAccessEventsObject class are listed here.

Methods
Methods
Name | Description
FireOnFileResolution | Method that fires the OnFileResolution event.
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface > FileAccessEventsObject Methods


FileAccessEventsObject.FireOnFileResolution Method

FileAccessEventsObject.FireOnFileResolution Method
Summary

Method that fires the OnFileResolution event.

Visual Basic
Sub FireOnFileResolution(RelativeFileName As String, LibraryName As String, ByRef CustomLogicalName As SAFEARRAY(unsigned char), BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef FullFileName As String, ByRef HandlingCode As HandlingCodeEnum)
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface > FileAccessEventsObject Methods > FileAccessEventsObject.FireOnFileResolution Method


FileAccessEventsObject Properties

FileAccessEventsObject Properties
Summary

The properties of the FileAccessEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface > FileAccessEventsObject Properties


FileAccessEventsObject.Application Property

FileAccessEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface > FileAccessEventsObject Properties > FileAccessEventsObject.Application Property


FileAccessEventsObject.Parent Property

FileAccessEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface > FileAccessEventsObject Properties > FileAccessEventsObject.Parent Property


FileAccessEventsObject.Type Property

FileAccessEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsObject Interface > FileAccessEventsObject Properties > FileAccessEventsObject.Type Property


FileAccessEventsSink Interface

FileAccessEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The FileAccessEvents object supports a set of properties and events used to get access to files.

Class Hierarchy
Inventor::FileAccessEventsSink
Visual Basic
Public Interface FileAccessEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsSink Interface


FileAccessEventsSink Methods

FileAccessEventsSink Methods
Summary

The methods of the FileAccessEventsSink class are listed here.

Methods
Methods
Name | Description
OnFileDirty | The OnFileDirty event notifies a client when a document is about to become to dirty.
OnFileResolution | The OnFileResolution event notifies a client whenever Inventor is trying to find the location of a file on disk.
You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsSink Interface > FileAccessEventsSink Methods


FileAccessEventsSink.OnFileDirty Method

FileAccessEventsSink.OnFileDirty Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnFileDirty event notifies a client when a document is about to become to dirty.

Visual Basic
Sub OnFileDirty(RelativeFileName As String, LibraryName As String, ByRef CustomLogicalName As SAFEARRAY(unsigned char), FullFileName As String, DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
RelativeFileName
The relative filename of the document. This is typically just the filename but may also include relative path information.
LibraryName
If the document is a library part, this argument provides the name of the library as defined in the active project. If it is not a library part this will be an empty string.
CustomLogicalName
An array of Bytes that is used by data management systems as a way to associated additional information with a file reference. In the case where a custom logical name was assigned to a reference and the associated document, this argument will return that value.
FullFileName
The full filename of the document.
DocumentObject
Input object being dirtied.
BeforeOrAfter
Input indicating when the event is being fired. This notification is currently only provided before the document is dirtied so this is always kBefore.
Context
Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the notification. Name = "AffectedFiles". Value = An array of Strings that contains a list of full filenames of the files being dirtied. Typically this will contain a single filename, but in the case of referenced files, changing one document can also cause others to become dirty. For example, editing a part in the context of the assembly can cause other parts to reposition within other assemblies and in the case of adaptivity can cause parts to update. Each of these documents becomes dirty as a result of editing the single part. This list returns the filenames of the files affected. An OnFileDirty event notification is also made for each document as it is dirtied. Name = "ReasonsForChange". Value = A value from the CommandTypesEnum list, which represents the different categories of changes that can be made. Typically this will be a single value from the list but it can represent multiple values that have been combined together so you need to use bitwise operations to check for a specific change.
HandlingCode
Output that indicates how you are handling the event. This event supports the ability to cancel the dirty by aborting the actions that caused the change. By setting this argument to kEventCanceled Inventor will abort the change.
Remarks

A document becomes dirty when a change is made to a clean document. A clean document is defined as a document that has not changed since it was last saved. Examples of clean documents are documents that have just been opened and documents that have just been saved. In both cases, a save operation is not needed because the file on disk is the same as the open document. Any change to the open document causes it to be different than the version on disk. When the document changes state of going from clean to dirty this notification is sent. Any subsequent changes to the document do not result in the OnFileDirty notification being sent because the document is already dirty. If the document is saved it will become clean, (the in-memory version of the document matches the version on disk), and the next change will again cause the OnFileDirty event notification to be made. Some of the actions that cause a document to become dirty can be controlled through the Save tab of the Application Options dialog and will impact when this notification is sent.

You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsSink Interface > FileAccessEventsSink Methods > FileAccessEventsSink.OnFileDirty Method


FileAccessEventsSink.OnFileResolution Method

FileAccessEventsSink.OnFileResolution Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnFileResolution event notifies a client whenever Inventor is trying to find the location of a file on disk.

Visual Basic
Sub OnFileResolution(RelativeFileName As String, LibraryName As String, ByRef CustomLogicalName As SAFEARRAY(unsigned char), BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef FullFileName As String, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
RelativeFileName
The relative filename of the document. This is typically just the filename but may also include relative path information. Inventor uses this in combination with the paths defined by the active project to resolve the location of the file.
LibraryName
If the document is a library part, this argument provides the name of the library as defined in the active project. If it is not a library part this will be an empty string.
CustomLogicalName
An array of Bytes that is used by data management systems as a way to associate additional information with a file reference. In the case where a custom logical name was assigned to a reference and the associated document, this argument will return that value. The data management application that originally defined the custom logical name can use this information to help look up the file within the data management system.
BeforeOrAfter
Input indicating when the event is being fired. This notification is currently only provided before the document is resolved.
Context
Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the notification. Name = "DatabaseRevisionId". Value = This value should be ignored. Name = "InternalName". Value = The internal name of the document that was last resolved for this reference. This is the same value returned by the InternalName property of the document that was last used for this reference. Name = "DirectReferencingFileName". Value = This value and the value for TopLevelFilename are related. Looking at a simple example helps to explain the information they provide: In this example there is Part.ipt that's referenced by subassembly Sub.iam, which is referenced by the assembly Top.iam. When you open Top.iam, the other files also need to be resolved and loaded. When Top.iam is opened, an OnFileResolution notification is sent for Sub.iam. For Sub.iam, DirectReferencingFileName will be the full filename of Top.iam because Sub.iam is being loaded because of the direct reference from Top.iam. TopLevelFilename will also be the full filename of Top.iam since that is the top level document that was opened. An OnFileResolution notification is also sent for Part.ipt. In this case, DirectReferencingFileName will be the full filename of Sub.iam since Part.ipt is being loaded because of the direct reference from Sub.iam. TopLevelFilename will be the full filename of Top.iam, since is it the top-level document that caused the loading. Name = "TopLevelFilename". Value = See the description for DirectReferencingFileName.
FullFileName
: If you are handling this event you use this argument to pass back the full filename of the document you want Inventor to load.
HandlingCode
Output that indicates how you are handling the event. To handle this event and you need to set this argument to kEventHandled. This will cause Inventor to skip its standard resolution and load the file you spescified in the FullFileName argument. Setting the value of this argument to kEventNotHandled (the default) will cause Inventor to use its standard file resolution. Canceling this event is not supported and setting this argument to kEventCanceled has the same effect as kEventNotHandled.
Remarks

Whenever a document is opened in Inventor that contains references to other documents, the paths to the referenced documents must be determined. This process referred to as "file resolution". For example, if there is an assembly Top.iam that contains Part.ipt, when Top.iam is opened Inventor needs to find Part.ipt on the disk in order to open it too. It does this using a combination of information stored in Top.iam and the paths defined by the active project. This event allows you to override Inventors standard file resolution and perform the resolution yourself. The OnFileResolution event notification is sent at the time Inventor recognizes that a file needs to be resolved but before it begins the resolution process. Through the arguments of this event, Inventor provides you all of the information it has about this reference. You can use this information to perform your own file resolution using whatever logic you choose and then supply Inventor with the full filename to use. If you supply a valid filename Inventor skips its resolution and loads the file you specify. The intent of this event is to allow you to control how Inventor resolves files. It is not intended as a mechanism to replace parts in an assembly. The filename you provide should be the full path of the original file that was referenced.

You are here: Symbol Reference > Inventor Library > Objects > FileAccessEventsSink Interface > FileAccessEventsSink Methods > FileAccessEventsSink.OnFileResolution Method


FileDescriptor Interface

FileDescriptor Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The FileDescriptor object represents a reference to an Autodesk Inventor file or a foreign file.

Class Hierarchy
Inventor::FileDescriptor
Visual Basic
Public Interface FileDescriptor
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BOMRow.ReferencedFileDescriptor

DocumentDescriptor.ReferencedFileDescriptor

FileDescriptorsEnumerator.Item

ReferencedOLEFileDescriptor.FileDescriptor

CustomTable.ReferencedDocumentDescriptor

You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface


FileDescriptor Methods

FileDescriptor Methods
Summary

The methods of the FileDescriptor class are listed here.

Methods
Methods
Name | Description
GetCustomLogicalFileName | Similar in nature to the Logical Filename, except that the application interprets and perhaps controls the location and access to the file being referenced.
PutCustomLogicalFileName | This method does the posting of the Custom Logical Filename referred to in GetCustomLogicalFileName.
ReplaceReference | Method that replaces the referenced file.
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Methods


FileDescriptor.GetCustomLogicalFileName Method

FileDescriptor.GetCustomLogicalFileName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Similar in nature to the Logical Filename, except that the application interprets and perhaps controls the location and access to the file being referenced.

Visual Basic
Sub GetCustomLogicalFileName(Result As [out, retval] SAFEARRAY(unsigned char))
Remarks

When the container Document (document that holds this reference) is being opened, the application is contacted via the FileResolution event found off the Document. The CustomLogicalFileName is supplied to it and the fully qualified filename expected in return. This way, the Custom Logical Filename is never interpreted by Inventor, but entirely by the application whose internal reference name to the file this is.

Typically, the Custom Logical Filename is used at the time of the creation of the reference. It is then seen/used by the application while listening to the File Resolution event.

Not supported when this description is of an OLE attachment.

You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Methods > FileDescriptor.GetCustomLogicalFileName Method


FileDescriptor.PutCustomLogicalFileName Method

FileDescriptor.PutCustomLogicalFileName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

This method does the posting of the Custom Logical Filename referred to in GetCustomLogicalFileName.

Visual Basic
Sub PutCustomLogicalFileName(ByRef Value As [ref] SAFEARRAY(unsigned char))
Remarks

Typically, this method is rarely used, since the initialization takes place during the insert of a file into container documents such as an assembly or drawing.

Not supported when this description is of an OLE attachment.

You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Methods > FileDescriptor.PutCustomLogicalFileName Method


FileDescriptor.ReplaceReference Method

FileDescriptor.ReplaceReference Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that replaces the referenced file.

Visual Basic
Sub ReplaceReference(FullFileName As String)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name to which the reference should be switched.
Remarks

The file being replaced and the replacement file must share ancestry (i.e. they must have the same InternalName). Documents have the same internal name if they are copied using 'Save Copy As' or a file explorer copy.

You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Methods > FileDescriptor.ReplaceReference Method


FileDescriptor Properties

FileDescriptor Properties
Summary

The properties of the FileDescriptor class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
FileSaveCounter | Property that returns the save counter associated with the file.
FullFileName | Property that returns the full path name of the file as currently found (or the last known full file name, if the reference is not found).
LibraryName | Gets the name of the library this reference was resolved in. This property is only valid when ReferenceMissing is false.
LocationType | Gets the type of location this reference was resolved in. This property is only valid when ReferenceMissing is false.
Parent | Property that returns the parent File object of this descriptor.
ReferencedFile | Property that returns the File object being referenced. The property returns Nothing for foreign file references.
ReferencedFileType | Property that returns type of the referenced file.
ReferenceDisabled | Gets whether the link to this file is disabled.
ReferenceInternalNameDifferent | Gets whether the internal name of the referenced file is different from the last time the parent (referencing) file was saved. A value of True indicates that the currently referenced file has a different internal name than the originally referenced file.
ReferenceLocationDifferent | Gets whether the file path or the file name of the referenced file is different from the last time the parent (referencing) file was saved. A value of True indicates that the currently referenced file has a different file path or file name.
ReferenceMissing | Property that returns whether the referenced file is missing (unresolved or suppressed).
RelativeFileName | Gets the relative file name from the resolved location of this reference. This property is only valid when ReferenceMissing is false.
Type | Property returning kFileDescriptorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties


FileDescriptor.Application Property

FileDescriptor.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.Application Property


FileDescriptor.FileSaveCounter Property

FileDescriptor.FileSaveCounter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the save counter associated with the file.

Visual Basic
Property FileSaveCounter() As long*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.FileSaveCounter Property


FileDescriptor.FullFileName Property

FileDescriptor.FullFileName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the full path name of the file as currently found (or the last known full file name, if the reference is not found).

Visual Basic
Property FullFileName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.FullFileName Property


FileDescriptor.LibraryName Property

FileDescriptor.LibraryName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the name of the library this reference was resolved in. This property is only valid when ReferenceMissing is false.

Visual Basic
Property LibraryName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.LibraryName Property


FileDescriptor.LocationType Property

FileDescriptor.LocationType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the type of location this reference was resolved in. This property is only valid when ReferenceMissing is false.

Visual Basic
Property LocationType() As LocationTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.LocationType Property


FileDescriptor.Parent Property

FileDescriptor.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent File object of this descriptor.

Visual Basic
Property Parent() As File**
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.Parent Property


FileDescriptor.ReferencedFile Property

FileDescriptor.ReferencedFile Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the File object being referenced. The property returns Nothing for foreign file references.

Visual Basic
Property ReferencedFile() As File**
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.ReferencedFile Property


FileDescriptor.ReferencedFileType Property

FileDescriptor.ReferencedFileType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns type of the referenced file.

Visual Basic
Property ReferencedFileType() As FileTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.ReferencedFileType Property


FileDescriptor.ReferenceDisabled Property

FileDescriptor.ReferenceDisabled Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the link to this file is disabled.

Visual Basic
Property ReferenceDisabled() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.ReferenceDisabled Property


FileDescriptor.ReferenceInternalNameDifferent Property

FileDescriptor.ReferenceInternalNameDifferent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the internal name of the referenced file is different from the last time the parent (referencing) file was saved. A value of True indicates that the currently referenced file has a different internal name than the originally referenced file.

Visual Basic
Property ReferenceInternalNameDifferent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.ReferenceInternalNameDifferent Property


FileDescriptor.ReferenceLocationDifferent Property

FileDescriptor.ReferenceLocationDifferent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the file path or the file name of the referenced file is different from the last time the parent (referencing) file was saved. A value of True indicates that the currently referenced file has a different file path or file name.

Visual Basic
Property ReferenceLocationDifferent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.ReferenceLocationDifferent Property


FileDescriptor.ReferenceMissing Property

FileDescriptor.ReferenceMissing Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the referenced file is missing (unresolved or suppressed).

Visual Basic
Property ReferenceMissing() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.ReferenceMissing Property


FileDescriptor.RelativeFileName Property

FileDescriptor.RelativeFileName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the relative file name from the resolved location of this reference. This property is only valid when ReferenceMissing is false.

Visual Basic
Property RelativeFileName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.RelativeFileName Property


FileDescriptor.Type Property

FileDescriptor.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kFileDescriptorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptor Interface > FileDescriptor Properties > FileDescriptor.Type Property


FileDescriptorsEnumerator Interface

FileDescriptorsEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The FileDescriptorsEnumerator object provides information about file references held, both native and foreign.

Class Hierarchy
Inventor::FileDescriptorsEnumerator
Visual Basic
Public Interface FileDescriptorsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

File.ReferencedFileDescriptors

You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface


FileDescriptorsEnumerator Methods

FileDescriptorsEnumerator Methods
Summary

The methods of the FileDescriptorsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified FileDescriptor object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface > FileDescriptorsEnumerator Methods


FileDescriptorsEnumerator.Item Method

FileDescriptorsEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the specified FileDescriptor object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FileDescriptor*)
Parameters
Parameters | Description
index | Input Variant value that specifies the FileDescriptor to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the full file name. If an out of range index or a name of a non-existent FileDescriptor is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface > FileDescriptorsEnumerator Methods > FileDescriptorsEnumerator.Item Method


FileDescriptorsEnumerator Properties

FileDescriptorsEnumerator Properties
Summary

The properties of the FileDescriptorsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kFileDescriptorsEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface > FileDescriptorsEnumerator Properties


FileDescriptorsEnumerator.Application Property

FileDescriptorsEnumerator.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface > FileDescriptorsEnumerator Properties > FileDescriptorsEnumerator.Application Property


FileDescriptorsEnumerator.Count Property

FileDescriptorsEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface > FileDescriptorsEnumerator Properties > FileDescriptorsEnumerator.Count Property


FileDescriptorsEnumerator.Type Property

FileDescriptorsEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kFileDescriptorsEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileDescriptorsEnumerator Interface > FileDescriptorsEnumerator Properties > FileDescriptorsEnumerator.Type Property


FileDialog Interface

FileDialog Interface Available in Inventor Introduced in Inventor 6
Summary

The FileDialog object represents the Inventor dialogs that are displayed when the user invokes the Place Component or Save As command. In the API, the FileDialog object provides the ability to use these same dialogs when a filename is needed from the user. It is very similar in concept to the Microsoft common file control.

Class Hierarchy
Inventor::FileDialog
Visual Basic
Public Interface FileDialog
Inherits IDispatch
Remarks

In the API, the FileDialog object provides the ability to use these same dialogs when a filename is needed from the user. It is very similar in concept to the Microsoft common file control. For further information, please see the File Dialog section of the API Overview.

Notes

Members through which this object may be accessed include:

FileDialogEventsObject.Parent

Example 1

"File Dialog Example "

This sample demonstrates the use of the FileDialog object. The only requirement to run this sample is to have Inventor open.

Public Sub TestFileDialog()
    ' Create a new FileDialog object.
    Dim oFileDlg As FileDialog
    Call ThisApplication.CreateFileDialog(oFileDlg)

    ' Define the filter to select part and assembly files or any file.
    oFileDlg.Filter = "Inventor Files (*.iam;*.ipt)|*.iam;*.ipt|All Files (*.*)|*.*"

    ' Define the part and assembly files filter to be the default filter.
    oFileDlg.FilterIndex = 1

    ' Set the title for the dialog.
    oFileDlg.DialogTitle = "Open File Test"

    ' Set the initial directory that will be displayed in the dialog.
    oFileDlg.InitialDirectory = "C:\Temp"

    ' Set the flag so an error will be raised if the user clicks the Cancel button.
    oFileDlg.CancelError = True

    ' Show the open dialog.  The same procedure is also used for the Save dialog.
    ' The commented code can be used for the Save dialog.
    On Error Resume Next
    oFileDlg.ShowOpen
'    oFileDlg.ShowSave

    ' If an error was raised, the user clicked cancel, otherwise display the filename.
    If Err Then
        MsgBox "User cancelled out of dialog"
    ElseIf oFileDlg.FileName  "" Then
        MsgBox "File " & oFileDlg.FileName & " was selected."
    End If
End Sub
Example 2

File dialog example (C#).

This sample demonstrates the use of the FileDialog object. The only requirement to run this sample is to have Inventor open.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void TestFileDialog()
{
    Application oApp = ThisApplication;

    // Create a new FileDialog object.
    FileDialog oFileDlg;
    oApp.CreateFileDialog(out(oFileDlg));

    // Define the filter to select part and assembly files or any file.
    oFileDlg.Filter = "Inventor Files (*.iam;*.ipt)|*.iam;*.ipt|All Files (*.*)|*.*";

    // Define the part and assembly files filter to be the default filter.
    oFileDlg.FilterIndex = 1;

    // Set the title for the dialog.
    oFileDlg.DialogTitle = "Open File Test";

    // Set the initial directory that will be displayed in the dialog.
    oFileDlg.InitialDirectory = "C:/Temp";

    // Set the flag so an error will not be raised if the user clicks the Cancel button.
    oFileDlg.CancelError = false;

    // Show the open dialog.  The same procedure is also used for the Save dialog.
    // The commented code can be used for the Save dialog.
    oFileDlg.ShowOpen();
    // oFileDlg.ShowSave();

    System.Windows.Forms.MessageBox.Show("File " + oFileDlg.FileName + " was selected.", "Selected file");

}
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface


FileDialog Methods

FileDialog Methods
Summary

The methods of the FileDialog class are listed here.

Methods
Methods
Name | Description
SetHelpContext | Method that sets the HTML Help Context to display when the help button is pressed in the FileDialog.
SetHelpTopic | Method that sets the HTML Help Topic to display when the help button is pressed in the FileDialog.
ShowOpen | Method that displays the open dialog. The existence of the specified file is checked for by the dialog, so only valid filenames will be returned. This does not actually open the file but only returns the filename the user has specified through the dialog.
ShowSave | Method that displays the Save As dialog. If the user selects an existing file a warning message is displayed notifying them that the file already exists and the file will be overwritten if they continue. The use of this method does not actually perform a save but only returns the filename the user has specified through the dialog.
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Methods


FileDialog.SetHelpContext Method

FileDialog.SetHelpContext Method Available in Inventor Introduced in Inventor 11
Summary

Method that sets the HTML Help Context to display when the help button is pressed in the FileDialog.

Visual Basic
Sub SetHelpContext(FileName As String, Context As long)
Parameters
Parameters | Description
FileName | Input string that specifies the name of the HTML file.
Context | Input Long that specifies the HTML help context.
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Methods > FileDialog.SetHelpContext Method


FileDialog.SetHelpTopic Method

FileDialog.SetHelpTopic Method Available in Inventor Introduced in Inventor 11
Summary

Method that sets the HTML Help Topic to display when the help button is pressed in the FileDialog.

Visual Basic
Sub SetHelpTopic(FileName As String, TopicName As String)
Parameters
Parameters | Description
FileName | Input string that specifies the name of the HTML file.
TopicName | Input string that specifies the HTML topic to display.
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Methods > FileDialog.SetHelpTopic Method


FileDialog.ShowOpen Method

FileDialog.ShowOpen Method Available in Inventor Introduced in Inventor 6
Summary

Method that displays the open dialog. The existence of the specified file is checked for by the dialog, so only valid filenames will be returned. This does not actually open the file but only returns the filename the user has specified through the dialog.

Visual Basic
Sub ShowOpen()
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Methods > FileDialog.ShowOpen Method


FileDialog.ShowSave Method

FileDialog.ShowSave Method Available in Inventor Introduced in Inventor 6
Summary

Method that displays the Save As dialog. If the user selects an existing file a warning message is displayed notifying them that the file already exists and the file will be overwritten if they continue. The use of this method does not actually perform a save but only returns the filename the user has specified through the dialog.

Visual Basic
Sub ShowSave()
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Methods > FileDialog.ShowSave Method


FileDialog Properties

FileDialog Properties
Summary

The properties of the FileDialog class are listed here.

Properties
Name | Description
CancelError | Property indicates whether an error is generated when the user chooses the Cancel button. A value of True indicates an error is generated, and False, (which is the default), does not generate an error.
DialogTitle | Property that gets and sets the string displayed in the title bar dialog.
FileDialogEvents | Property that returns the FileDialogEvents object.
FileName | Property that gets and sets the full filename of the selected file.
Filter | Property that gets and sets filters that are displayed in the 'Files of type' list box in the dialog.
FilterIndex | Property that gets and sets the default filter used when you use the Filter property to specify filters. The index for the first defined filter is 1.
InitialDirectory | Property that gets and sets the directory that will be used when the dialog is initially displayed.
InsertMode | Property that gets and sets whether the FileDialog is being used for inserting a file (as opposed to opening one). An example of inserting a file in Inventor is the 'Place Component' command in an assembly. This property dictates whether the ShowOpen method fires the OnFileOpenDialog event or the OnFileInsertDialog event. The value of this property defaults to True when the FileDialog is initially created. If set to True, the OnFileInsertDialog event is fired.
MultiSelectEnabled | Property that gets and sets whether the 'Open' dialog (invoked using the ShowOpen method) should allow the selection of multiple files. If multiple files are selected by the user, the FileName property returns a string containing all selected file names delimited by a vertical bar (a.k.a. pipe, '|').
OptionsEnabled | Property that gets and sets whether the 'Options' button on the dialog is enabled. If the button is enabled and the user clicks it, the OnOptions event is fired. This property defaults to False.
SuppressResolutionWarnings | Property that gets and sets whether or not to warn that a file is being saved outside of a project resolvable location.
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties


FileDialog.CancelError Property

FileDialog.CancelError Property Available in Inventor Introduced in Inventor 6
Summary

Property indicates whether an error is generated when the user chooses the Cancel button. A value of True indicates an error is generated, and False, (which is the default), does not generate an error.

Visual Basic
Property CancelError() As VARIANT_BOOL
See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.CancelError Property


FileDialog.DialogTitle Property

FileDialog.DialogTitle Property Available in Inventor Introduced in Inventor 6
Summary

Property that gets and sets the string displayed in the title bar dialog.

Visual Basic
Property DialogTitle() As String
See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.DialogTitle Property


FileDialog.FileDialogEvents Property

FileDialog.FileDialogEvents Property Available in Inventor Introduced in Inventor 2008
Summary

Property that returns the FileDialogEvents object.

Visual Basic
Property FileDialogEvents() As FileDialogEvents**
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.FileDialogEvents Property


FileDialog.FileName Property

FileDialog.FileName Property Available in Inventor Introduced in Inventor 6
Summary

Property that gets and sets the full filename of the selected file.

Visual Basic
Property FileName() As String
Remarks

When you first obtain the FileDialog object, the FileName property is set to a zero-length string (""), meaning no file is currently selected.

You can set the FileName property before opening a dialog box to set an initial filename.

Reading this property returns the currently selected filename from the list. The full filename is returned.

If the MultiSelectEnabled property is set to True and multiple files are selected by the user, this property returns a string containing all selected file names delimited by a vertical bar (a.k.a. pipe, '|').

See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.FileName Property


FileDialog.Filter Property

FileDialog.Filter Property Available in Inventor Introduced in Inventor 6
Summary

Property that gets and sets filters that are displayed in the 'Files of type' list box in the dialog.

Visual Basic
Property Filter() As String
Remarks

A filter specifies the type of files that are displayed in the dialog box's file list box. For example, selecting the filter *.txt displays all text files.

Use this property to provide the user with a list of filters that can be selected when the dialog box is displayed.

Use the pipe ( | ) symbol (ASCII 124) to separate the description and filter values. Don't include spaces before or after the pipe symbol, because these spaces will be displayed with the description and filter values.

The following code shows an example of a string that defines two filters. The first allows them to select part and assembly files, and the second allows them to select any file.

Inventor Parts and Assemblies (*.iam;*.ipt)|*.iam;*.ipt|All Files (*.*)|*.*

When you specify more than one filter for a dialog box, use the FilterIndex property to determine which filter is displayed as the default.

See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.Filter Property


FileDialog.FilterIndex Property

FileDialog.FilterIndex Property Available in Inventor Introduced in Inventor 6
Summary

Property that gets and sets the default filter used when you use the Filter property to specify filters. The index for the first defined filter is 1.

Visual Basic
Property FilterIndex() As long
See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.FilterIndex Property


FileDialog.InitialDirectory Property

FileDialog.InitialDirectory Property Available in Inventor Introduced in Inventor 6
Summary

Property that gets and sets the directory that will be used when the dialog is initially displayed.

Visual Basic
Property InitialDirectory() As String
See Also

File dialog (C#) sample

File Dialog sample

You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.InitialDirectory Property


FileDialog.InsertMode Property

FileDialog.InsertMode Property Available in Inventor Introduced in Inventor 2009
Summary

Property that gets and sets whether the FileDialog is being used for inserting a file (as opposed to opening one). An example of inserting a file in Inventor is the 'Place Component' command in an assembly. This property dictates whether the ShowOpen method fires the OnFileOpenDialog event or the OnFileInsertDialog event. The value of this property defaults to True when the FileDialog is initially created. If set to True, the OnFileInsertDialog event is fired.

Visual Basic
Property InsertMode() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.InsertMode Property


FileDialog.MultiSelectEnabled Property

FileDialog.MultiSelectEnabled Property Available in Inventor Introduced in Inventor 2009
Summary

Property that gets and sets whether the 'Open' dialog (invoked using the ShowOpen method) should allow the selection of multiple files. If multiple files are selected by the user, the FileName property returns a string containing all selected file names delimited by a vertical bar (a.k.a. pipe, '|').

Visual Basic
Property MultiSelectEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.MultiSelectEnabled Property


FileDialog.OptionsEnabled Property

FileDialog.OptionsEnabled Property Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets whether the 'Options' button on the dialog is enabled. If the button is enabled and the user clicks it, the OnOptions event is fired. This property defaults to False.

Visual Basic
Property OptionsEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.OptionsEnabled Property


FileDialog.SuppressResolutionWarnings Property

FileDialog.SuppressResolutionWarnings Property Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets whether or not to warn that a file is being saved outside of a project resolvable location.

Visual Basic
Property SuppressResolutionWarnings() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileDialog Interface > FileDialog Properties > FileDialog.SuppressResolutionWarnings Property


FileDialogEvents CoClass

FileDialogEvents CoClass Available in Inventor Introduced in Inventor 2008
Summary

The FileDialogEvents object hosts events related to the FileDialog.

Class Hierarchy
Inventor::FileDialogEvents
Visual Basic
Public Class FileDialogEvents
Remarks

The File Dialogs portion of the API provides the functionality for developers to reuse the standard Inventor Open and Save As dialogs as shown below. Using the API, the developer can define some of the behavior of the dialog and then displays the dialog to the user. The user interacts with the dialog to specify a file name to open or save. The developer is provided the selected file. The use of this API does not actually perform the Open or Save but only obtains a file name from the user. The developer can then use this file name in any way. This functionality is very similar to the Microsoft common file control. Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

FileDialog.FileDialogEvents

You are here: Symbol Reference > Inventor Library > Objects > FileDialogEvents CoClass


FileDialogEventsObject Interface

FileDialogEventsObject Interface Available in Inventor Introduced in Inventor 2008
Summary

The FileDialogEvents object hosts events related to the FileDialog.

Class Hierarchy
Inventor::FileDialogEventsObject
Visual Basic
Public Interface FileDialogEventsObject
Inherits IDispatch
Remarks

The File Dialogs portion of the API provides the functionality for developers to reuse the standard Inventor Open and Save As dialogs as shown below. Using the API, the developer can define some of the behavior of the dialog and then displays the dialog to the user. The user interacts with the dialog to specify a file name to open or save. The developer is provided the selected file. The use of this API does not actually perform the Open or Save but only obtains a file name from the user. The developer can then use this file name in any way. This functionality is very similar to the Microsoft common file control. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsObject Interface


FileDialogEventsObject Properties

FileDialogEventsObject Properties
Summary

The properties of the FileDialogEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent FileDialog object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsObject Interface > FileDialogEventsObject Properties


FileDialogEventsObject.Application Property

FileDialogEventsObject.Application Property Available in Inventor Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsObject Interface > FileDialogEventsObject Properties > FileDialogEventsObject.Application Property


FileDialogEventsObject.Parent Property

FileDialogEventsObject.Parent Property Available in Inventor Introduced in Inventor 2008
Summary

Property that returns the parent FileDialog object.

Visual Basic
Property Parent() As FileDialog**
You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsObject Interface > FileDialogEventsObject Properties > FileDialogEventsObject.Parent Property


FileDialogEventsObject.Type Property

FileDialogEventsObject.Type Property Available in Inventor Introduced in Inventor 2008
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsObject Interface > FileDialogEventsObject Properties > FileDialogEventsObject.Type Property


FileDialogEventsSink Interface

FileDialogEventsSink Interface Available in Inventor Introduced in Inventor 2008
Summary

The FileDialogEvents object hosts events related to the FileDialog.

Class Hierarchy
Inventor::FileDialogEventsSink
Visual Basic
Public Interface FileDialogEventsSink
Inherits IDispatch
Remarks

The File Dialogs portion of the API provides the functionality for developers to reuse the standard Inventor Open and Save As dialogs as shown below. Using the API, the developer can define some of the behavior of the dialog and then displays the dialog to the user. The user interacts with the dialog to specify a file name to open or save. The developer is provided the selected file. The use of this API does not actually perform the Open or Save but only obtains a file name from the user. The developer can then use this file name in any way. This functionality is very similar to the Microsoft common file control. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsSink Interface


FileDialogEventsSink Methods

FileDialogEventsSink Methods
Summary

The methods of the FileDialogEventsSink class are listed here.

Methods
Methods
Name | Description
OnOptions | Event that fires when the user clicks the Options button on the file dialog. This event can be used to put up customized option pages.
You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsSink Interface > FileDialogEventsSink Methods


FileDialogEventsSink.OnOptions Method

FileDialogEventsSink.OnOptions Method Available in Inventor Introduced in Inventor 2008
Summary

Event that fires when the user clicks the Options button on the file dialog. This event can be used to put up customized option pages.

Visual Basic
Sub OnOptions(Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Context | Output NameValueMap object that can be used to determine the context of why the event fired. This argument is currently empty.
HandlingCode | Output that indicates how you are handling the event.
You are here: Symbol Reference > Inventor Library > Objects > FileDialogEventsSink Interface > FileDialogEventsSink Methods > FileDialogEventsSink.OnOptions Method


FileLocations Interface

FileLocations Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary
Please Note
While this object is still accessible, it is now hidden by default. Please use the Design Project APIs instead (see sample code below).

Object that provides access to the current, active Project being used by Autodesk Inventor. A Project is an organization of 'file locations.'

Class Hierarchy
Inventor::FileLocations
Visual Basic
Public Interface FileLocations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.FileLocations

Application.FileLocations

Example 1

Create project example.

The following sample demonstrates the creation of an Inventor project.

Public Sub CreateProject()

    ' Set a reference to the DesignProjectManager object.
    Dim oDesignProjectMgr As DesignProjectManager
    Set oDesignProjectMgr = ThisApplication.DesignProjectManager

    ' Create a new singler user project
    Dim oProject As DesignProject
    Set oProject = oDesignProjectMgr.DesignProjects.Add(kSingleUserMode, "MyProject", "C:\temp\")

End Sub
Example 2

Set active project example.

The following sample demonstrates the activation of an Inventor project.

Public Sub SetActiveProject()
    ' Check to make sure a document isn't open.
    If ThisApplication.Documents.Count > 0 Then
        MsgBox "All documents must be closed before changing the project."
        Exit Sub
    End If

    ' Set a reference to the DesignProjectManager object.
    Dim oDesignProjectMgr As DesignProjectManager
    Set oDesignProjectMgr = ThisApplication.DesignProjectManager

    ' Show the current project.
    Debug.Print "Old active project: " & oDesignProjectMgr.ActiveDesignProject.FullFileName

    ' Get the project to activate
    ' This assumes that "C:\Temp\MyProject.ipj" exists.
    Dim oProject As DesignProject
    Set oProject = oDesignProjectMgr.DesignProjects.ItemByName("C:\temp\MyProject.ipj")

    ' Activate the project
    oProject.Activate

    ' Show the current project after making the project change.
    Debug.Print "New active project: " & oDesignProjectMgr.ActiveDesignProject.FullFileName
End Sub
Example 3

Query and create library paths example.

The following sample demonstrates querying existing library paths associated with a project and adding a new library path.

Sub QueryAndCreateLibraryPaths()

    Dim oProjectMgr As DesignProjectManager
    Set oProjectMgr = ThisApplication.DesignProjectManager

    ' Get the active project
    Dim oProject As DesignProject
    Set oProject = oProjectMgr.ActiveDesignProject

    Dim oLibraryPaths As ProjectPaths
    Set oLibraryPaths = oProject.LibraryPaths

    ' Add a new library path to the end of the list
    Call oLibraryPaths.Add("MyLibraryPath", "C:\temp\MyLibrary")

    ' Print all library names and paths
    Dim oLibraryPath As ProjectPath
    For Each oLibraryPath In oLibraryPaths
        Debug.Print "Name: " & oLibraryPath.Name & " Path: " & oLibraryPath.Path
    Next

End Sub
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface


FileLocations Methods

FileLocations Methods
Summary

The methods of the FileLocations class are listed here.

Methods
Methods
Name | Description
AddLibrary | Adds a given library path with its name at a specific position in the list.
AddWorkgroup | Adds a given Workgroup path with its name at a specific position in the list.
FindInLocations | Finds the file location in which a given fully qualified filename will be found using the current resolution rules.
FindLogicalInLocations | Finds the file location in which a given logical filename will be found using the current resolution rules.
Libraries | Obtains the list of all Library paths along with their logical names.
ProjectFiles | Method that obtains the list of all the project files available to Autodesk Inventor.
RemoveLibrary | Method that removes a given Library path, given its name.
RemoveWorkgroup | Method that removes a given Workgroup path, given its name.
Workgroups | Obtains the list of all workgroup paths along with their logical names.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods


FileLocations.AddLibrary Method

FileLocations.AddLibrary Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Adds a given library path with its name at a specific position in the list.

Visual Basic
Sub AddLibrary(Name As String, Path As String)
Parameters
Parameters | Description
Name | Input String that specifies the name of the library.
Path | Input String that specifies the library path to add.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.AddLibrary Method


FileLocations.AddWorkgroup Method

FileLocations.AddWorkgroup Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Adds a given Workgroup path with its name at a specific position in the list.

Visual Basic
Sub AddWorkgroup(Name As String, Path As String, Index As long)
Parameters
Parameters | Description
Name | Input String that specifies the work group path name.
Path | Input String that specifies the work group path to add.
index | Input Long value that specifies the position in which to add the work group path name.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.AddWorkgroup Method


FileLocations.FindInLocations Method

FileLocations.FindInLocations Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Finds the file location in which a given fully qualified filename will be found using the current resolution rules.

Visual Basic
Sub FindInLocations(FullFileName As String, ByRef RepositoryName As String, ByRef Type As LocationTypeEnum)
Parameters
Parameters | Description
FullFileName | Input String value that specifies the full filename of the file to locate.
RepositoryName | Output String that indicates the name of the repository in which the specified filename is located.
Type | Output that defines the type of location.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.FindInLocations Method


FileLocations.FindLogicalInLocations Method

FileLocations.FindLogicalInLocations Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Finds the file location in which a given logical filename will be found using the current resolution rules.

Visual Basic
Sub FindLogicalInLocations(RelativeFileName As String, LibraryName As String, ByRef RepositoryName As String, ByRef Type As LocationTypeEnum)
Parameters
Parameters | Description
RelativeFileName | Input String value that specifies the relative path and filename of the reference.
LibraryName | Input String value that specifies the name of the library.
RepositoryName | Output String that indicates the name of the repository in which the specified filename is located.
Type | Output that defines the type of location.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.FindLogicalInLocations Method


FileLocations.Libraries Method

FileLocations.Libraries Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains the list of all Library paths along with their logical names.

Visual Basic
Sub Libraries(ByRef NumLibraries As long, ByRef Names As SAFEARRAY(BSTR), ByRef Paths As SAFEARRAY(BSTR))
Parameters
Parameters | Description
NumLibraries | Output Long that specifies the number of libraries.
Names | Input/output String value that specifies the names of the libraries.
Paths | Input/output String that specifies the library paths to add.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.Libraries Method


FileLocations.ProjectFiles Method

FileLocations.ProjectFiles Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that obtains the list of all the project files available to Autodesk Inventor.

Visual Basic
Sub ProjectFiles(ByRef NumProjectFiles As long, ByRef ProjectFileNamePaths As SAFEARRAY(BSTR))
Parameters
Parameters | Description
NumProjectFiles | Output Long that specifies the number of project files available.
ProjectFileNamePaths | String containing the filenames of the project files available.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.ProjectFiles Method


FileLocations.RemoveLibrary Method

FileLocations.RemoveLibrary Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that removes a given Library path, given its name.

Visual Basic
Sub RemoveLibrary(Name As String)
Parameters
Parameters | Description
Name | Input String that specifies the name of the library.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.RemoveLibrary Method


FileLocations.RemoveWorkgroup Method

FileLocations.RemoveWorkgroup Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that removes a given Workgroup path, given its name.

Visual Basic
Sub RemoveWorkgroup(Name As String)
Parameters
Parameters | Description
Name | Input String that specifies the Workgroup's name.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.RemoveWorkgroup Method


FileLocations.Workgroups Method

FileLocations.Workgroups Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Obtains the list of all workgroup paths along with their logical names.

Visual Basic
Sub Workgroups(ByRef NumWorkGroups As long, ByRef Names As SAFEARRAY(BSTR), ByRef Paths As SAFEARRAY(BSTR))
Parameters
Parameters | Description
NumWorkGroups | Output Long that specifies the number of workgroups.
Names | Input/output String value that specifies the names of the workgroup paths.
Paths | Input/output String that specifies the workgroups to add.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Methods > FileLocations.Workgroups Method


FileLocations Properties

FileLocations Properties
Summary

The properties of the FileLocations class are listed here.

Properties
Name | Description
FileLocationsFile | Gets/Sets the currently active Project File.
FileLocationsFilesDir | Gets/Sets the directory in which to look for the Project Files that can be used in Inventor sessions.
Workspace | Gets/Sets the Workspace directory for the Project.
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Properties


FileLocations.FileLocationsFile Property

FileLocations.FileLocationsFile Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/Sets the currently active Project File.

Visual Basic
Property FileLocationsFile() As String
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Properties > FileLocations.FileLocationsFile Property


FileLocations.FileLocationsFilesDir Property

FileLocations.FileLocationsFilesDir Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/Sets the directory in which to look for the Project Files that can be used in Inventor sessions.

Visual Basic
Property FileLocationsFilesDir() As String
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Properties > FileLocations.FileLocationsFilesDir Property


FileLocations.Workspace Property

FileLocations.Workspace Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets/Sets the Workspace directory for the Project.

Visual Basic
Property Workspace() As String
You are here: Symbol Reference > Inventor Library > Objects > FileLocations Interface > FileLocations Properties > FileLocations.Workspace Property


FileManager Interface

FileManager Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

The FileManager object provides access to file-related utility functions.

Class Hierarchy
Inventor::FileManager
Visual Basic
Public Interface FileManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.FileManager

Application.FileManager

See Also

Create sheet metal lofted flange feature sample

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Sketch profile control sample

Edit profile of an extrude feature sample

SurfaceBody Copy sample

Create sheet metal face and flange features sample

Sheet Metal Feature Display sample

Sketch from face silhouette sample

Open assembly in last LOD sample

Derived Parts and Assemblies sample

Add a decal feature sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface


FileManager Methods

FileManager Methods
Summary

The methods of the FileManager class are listed here.

Methods
Methods
Name | Description
CopyFile | Method that copies the specified Autodesk Inventor file (.ipt, .idw, .ipt etc.) from one location to another.
DeleteFile | Method that deletes the specified file.
GetAutoCADBlockDefinitions | Method that returns the names of all the AutoCAD block definitions contained within the input DWG file. The input file can be an AutoCAD DWG or an Inventor DWG.
GetDesignViewRepresentations | Method that returns the names of all the design view representations contained within the input file (either *.ipt or *.iam).
GetDWGDocumentReferences | Gets the set of direct file references from a DWG file.
GetFileNameFromIdentifier | Property that returns the fully qualified name of a file using its unique identifier. The identifier must have been obtained from the GetIdentifierFromFileName method.
GetFullDocumentName | Returns the full document name which is a unique identifier for an open Document. The returned string is the full file name concatenated with the level of detail name for an assembly document.
GetFullFileName | Returns the full file name given its full document name.
GetIdentifierFromFileName | Creates and returns a unique, persistent identifier for the specified file.
GetLastActiveDesignViewRepresentation | Method that returns the name of the design view representation that was active when the file was last saved.
GetLastActiveLevelOfDetailRepresentation |
GetLevelOfDetailName | Returns the name of the level of detail given its full document name.
GetLevelOfDetailRepresentations | Method that returns the names of all the level of detail representations contained within the input file.
GetPositionalRepresentations | Method that returns the names of all the positional representations contained within the input assembly file.
GetTemplateFile | Method that specifies the template to use when creating a file.
IsFileNameValid | Validate the input filename and replace illegal filename characters with something more appropriate.
IsInventorDWG | Method that returns whether the input file is an Inventor DWG file.
MoveFile | Method that moves the specified file from one location to another.
RefreshAllDocuments | Refreshes all documents in memory to the latest version on disk.
SoftwareVersionSaved | Returns the object that encapsulates the version of the software with which this file was last saved.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods


FileManager.CopyFile Method

FileManager.CopyFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that copies the specified Autodesk Inventor file (.ipt, .idw, .ipt etc.) from one location to another.

Visual Basic
Sub CopyFile(SourceFullFileName As String, DestinationFullFileName As String, ByRef FileManagementOption As [defaultvalue(kNoForceFile)] FileManagementEnum)
Parameters
Parameters | Description
SourceFullFileName | Input String that specifies the full path and filename of the file to copy.
DestinationFullFileName | Input String that specifies the full path and filename in which to place the results of the copy procedure.
FileManagementOption | Input constant that specifies how to handle the results of the file operation.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.CopyFile Method


FileManager.DeleteFile Method

FileManager.DeleteFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that deletes the specified file.

Visual Basic
Sub DeleteFile(FullFileName As String, ByRef FileManagementOption As [defaultvalue(kNoForceFile)] FileManagementEnum)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full path and filename of the file to delete.
FileManagementOption | Input constant that specifies how to handle the results of the file operation.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.DeleteFile Method


FileManager.GetAutoCADBlockDefinitions Method

FileManager.GetAutoCADBlockDefinitions Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns the names of all the AutoCAD block definitions contained within the input DWG file. The input file can be an AutoCAD DWG or an Inventor DWG.

Visual Basic
Sub GetAutoCADBlockDefinitions(FullFileName As String, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name of the AutoCAD or Inventor DWG file from which to return the block definition names.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetAutoCADBlockDefinitions Method


FileManager.GetDesignViewRepresentations Method

FileManager.GetDesignViewRepresentations Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the names of all the design view representations contained within the input file (either *.ipt or *.iam).

Visual Basic
Sub GetDesignViewRepresentations(FullFileName As String, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
FullFileName | Input String that specifies the file (*.ipt or *.iam) to retrieve the design view names from. A FullDocumentName can also be specified. For sheet metal documents, the design views within the flat pattern are not returned in this array.
Remarks

Returned in the following order:

1. Last Active

2. Master

3. All Visible

4. Nothing Visible

5. Default

6. Other

You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetDesignViewRepresentations Method


FileManager.GetDWGDocumentReferences Method

FileManager.GetDWGDocumentReferences Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the set of direct file references from a DWG file.

Visual Basic
Sub GetDWGDocumentReferences(DocumentOrFileName As VARIANT, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
DocumentOrFileName | Input String that specifies the full document or file name.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetDWGDocumentReferences Method


FileManager.GetFileNameFromIdentifier Method

FileManager.GetFileNameFromIdentifier Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the fully qualified name of a file using its unique identifier. The identifier must have been obtained from the GetIdentifierFromFileName method.

Visual Basic
Sub GetFileNameFromIdentifier(ByRef Identifier As SAFEARRAY(unsigned char), ByRef FullFileName As String, ByRef AbsolutePath As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
Identifier | The identifier obtained from the GetIdentifierFromFileName method.
FullFileName | Output String value that specifies the full filename of the file.
AbsolutePath | String specifying the absolute path to the file.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetFileNameFromIdentifier Method


FileManager.GetFullDocumentName Method

FileManager.GetFullDocumentName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the full document name which is a unique identifier for an open Document. The returned string is the full file name concatenated with the level of detail name for an assembly document.

Visual Basic
Sub GetFullDocumentName(FullFileName As String, ByRef LevelOfDetailName As [defaultvalue("")] BSTR, Result As [out, retval] BSTR)
Parameters
Parameters | Description
FullFileName | Input String that specifies the Inventor file on disk.
LevelOfDetailName | Optional input String that specifies the name of the level of detail within the file. This argument is ignored for part, presentation and drawing documents. If an assembly document has multiple level of detail representations and this argument is not specified, the full document name of the master document is returned.
See Also

Create base view with representations (C#) sample

Create flat pattern drawing view sample

Adding Representation views sample

You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetFullDocumentName Method


FileManager.GetFullFileName Method

FileManager.GetFullFileName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the full file name given its full document name.

Visual Basic
Sub GetFullFileName(FullDocumentName As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
FullDocumentName | Input String that specifies the full document name.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetFullFileName Method


FileManager.GetIdentifierFromFileName Method

FileManager.GetIdentifierFromFileName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Creates and returns a unique, persistent identifier for the specified file.

Visual Basic
Sub GetIdentifierFromFileName(FullFileName As String, ByRef Identifier As SAFEARRAY(unsigned char), ByRef AbsolutePath As [defaultvalue("")] BSTR)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full path and filename of the file.
Identifier | The Identifier for the file.
AbsolutePath | String specifying the absolute path to the file.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetIdentifierFromFileName Method


FileManager.GetLastActiveDesignViewRepresentation Method

FileManager.GetLastActiveDesignViewRepresentation Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the name of the design view representation that was active when the file was last saved.

Visual Basic
Sub GetLastActiveDesignViewRepresentation(FullFileName As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full file name (supported for part and assembly documents).
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetLastActiveDesignViewRepresentation Method


FileManager.GetLastActiveLevelOfDetailRepresentation Method

FileManager.GetLastActiveLevelOfDetailRepresentation Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetLastActiveLevelOfDetailRepresentation(FullFileName As String, Result As [out, retval] BSTR)
Example

"Open assembly in last LOD"

This sample demonstrates how to open an assembly document in its last active Level of Detail Representation.

Public Sub OpenDocumentInLastActiveLOD()

    Dim strFullFileName As String
    strFullFileName = "C:\temp\Assembly1.iam"

    ' Set a reference to the FileManager object.
    Dim oFileManager As FileManager
    Set oFileManager = ThisApplication.FileManager

    ' Get the name of the last active Level of Detail (LOD) Representation.
    Dim strLastActiveLOD As String
    strLastActiveLOD = oFileManager.GetLastActiveLevelOfDetailRepresentation(strFullFileName)

    ' Use the full file name and LOD name to get the full document name.
    Dim strFullDocumentName As String
    strFullDocumentName = oFileManager.GetFullDocumentName(strFullFileName, strLastActiveLOD)

    ' Open the document in the last active LOD.
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.Documents.Open(strFullDocumentName)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetLastActiveLevelOfDetailRepresentation Method


FileManager.GetLevelOfDetailName Method

FileManager.GetLevelOfDetailName Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the name of the level of detail given its full document name.

Visual Basic
Sub GetLevelOfDetailName(FullDocumentName As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
FullDocumentName | Input String that specifies the full document name (currently only supported for assembly documents).
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetLevelOfDetailName Method


FileManager.GetLevelOfDetailRepresentations Method

FileManager.GetLevelOfDetailRepresentations Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the names of all the level of detail representations contained within the input file.

Visual Basic
Sub GetLevelOfDetailRepresentations(FullFileName As String, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
FullFileName | Input String that specifies the file to retrieve the level of detail names from.
Remarks

Returned in the following order:

1. Master

2. All Parts Suppressed

3. All Components Suppressed

4. All Content Suppressed

5. Other

You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetLevelOfDetailRepresentations Method


FileManager.GetPositionalRepresentations Method

FileManager.GetPositionalRepresentations Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the names of all the positional representations contained within the input assembly file.

Visual Basic
Sub GetPositionalRepresentations(FullFileName As String, Result As [out, retval] SAFEARRAY(BSTR))
Remarks

Returned in the following order:

1. Master

2. Other

You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetPositionalRepresentations Method


FileManager.GetTemplateFile Method

FileManager.GetTemplateFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that specifies the template to use when creating a file.

Visual Basic
Sub GetTemplateFile(DocumentType As DocumentTypeEnum, ByRef SystemOfMeasure As [defaultvalue(kDefaultSystemOfMeasure)] SystemOfMeasureEnum, ByRef DraftingStandard As [defaultvalue(kDefault_DraftingStandard)] DraftingStandardEnum, ByRef DocumentSubType As [optional] VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
DocumentType | Input constant that specifies the type of to create.
SystemOfMeasure | Input constant that specifies the system of measure to use in the drawing being created.
DraftingStandard | Input constant that specifies the drafting standard to use in the drawing being created.
DocumentSubType | Input constant (GUID) that specifies the subtype of the document to be created (sheet metal or weldment).
See Also

Create sheet metal lofted flange feature sample

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Sketch profile control sample

Edit profile of an extrude feature sample

SurfaceBody Copy sample

Create sheet metal face and flange features sample

Sheet Metal Feature Display sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Derived Parts and Assemblies sample

Derived Parts and Assemblies sample

Add a decal feature sample

Creating a new parameter group sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.GetTemplateFile Method


FileManager.IsFileNameValid Method

FileManager.IsFileNameValid Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Validate the input filename and replace illegal filename characters with something more appropriate.

Visual Basic
Sub IsFileNameValid(FileName As String, ByRef ValidFileName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
FileName | Filename to validate.
ValidFileName | Validated filename.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.IsFileNameValid Method


FileManager.IsInventorDWG Method

FileManager.IsInventorDWG Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether the input file is an Inventor DWG file.

Visual Basic
Sub IsInventorDWG(FullFileName As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of a DWG file.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.IsInventorDWG Method


FileManager.MoveFile Method

FileManager.MoveFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that moves the specified file from one location to another.

Visual Basic
Sub MoveFile(SourceFullFileName As String, DestinationFullFileName As String, ByRef FileManagementOption As [defaultvalue(kNoForceFile)] FileManagementEnum)
Parameters
Parameters | Description
SourceFullFileName | Input String that specifies the full path and filename of the file to move.
DestinationFullFileName | Input String that specifies the full path and filename in which to place the results of the move procedure.
FileManagementOption | Input constant that specifies how to handle the results of the file operation.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.MoveFile Method


FileManager.RefreshAllDocuments Method

FileManager.RefreshAllDocuments Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Refreshes all documents in memory to the latest version on disk.

Visual Basic
Sub RefreshAllDocuments()
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.RefreshAllDocuments Method


FileManager.SoftwareVersionSaved Method

FileManager.SoftwareVersionSaved Method Available in Apprentice
Summary

Returns the object that encapsulates the version of the software with which this file was last saved.

Visual Basic
Sub SoftwareVersionSaved(FullFileName As String, Result As [out, retval] SoftwareVersion*)
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Methods > FileManager.SoftwareVersionSaved Method


FileManager Properties

FileManager Properties
Summary

The properties of the FileManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
FileManagerEvents | Property that gets the object that fires the File Manager related events.
Files | Property that returns the FilesEnumerator object
FileSystemObject | Gets the Scripting.FileSystemObject in Inventor process.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Properties


FileManager.Application Property

FileManager.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Properties > FileManager.Application Property


FileManager.FileManagerEvents Property

FileManager.FileManagerEvents Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the object that fires the File Manager related events.

Visual Basic
Property FileManagerEvents() As FileManagerEvents**
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Properties > FileManager.FileManagerEvents Property


FileManager.Files Property

FileManager.Files Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the FilesEnumerator object

Visual Basic
Property Files() As FilesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Properties > FileManager.Files Property


FileManager.FileSystemObject Property

FileManager.FileSystemObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the Scripting.FileSystemObject in Inventor process.

Visual Basic
Property FileSystemObject() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Properties > FileManager.FileSystemObject Property


FileManager.Type Property

FileManager.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileManager Interface > FileManager Properties > FileManager.Type Property


FileManagerEvents CoClass

FileManagerEvents CoClass Available in Inventor Available in Server Introduced in Inventor 9
Summary

The FileManagerEvents object provides access to file events, such as file deletion.

Class Hierarchy
Inventor::FileManagerEvents
Visual Basic
Public Class FileManagerEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

FileManager.FileManagerEvents

You are here: Symbol Reference > Inventor Library > Objects > FileManagerEvents CoClass


FileManagerEventsObject Interface

FileManagerEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The FileManagerEvents object provides access to file events, such as file deletion.

Class Hierarchy
Inventor::FileManagerEventsObject
Visual Basic
Public Interface FileManagerEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsObject Interface


FileManagerEventsObject Properties

FileManagerEventsObject Properties
Summary

The properties of the FileManagerEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsObject Interface > FileManagerEventsObject Properties


FileManagerEventsObject.Application Property

FileManagerEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsObject Interface > FileManagerEventsObject Properties > FileManagerEventsObject.Application Property


FileManagerEventsObject.Parent Property

FileManagerEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsObject Interface > FileManagerEventsObject Properties > FileManagerEventsObject.Parent Property


FileManagerEventsObject.Type Property

FileManagerEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsObject Interface > FileManagerEventsObject Properties > FileManagerEventsObject.Type Property


FileManagerEventsSink Interface

FileManagerEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The FileManagerEvents object provides access to file events, such as file deletion.

Class Hierarchy
Inventor::FileManagerEventsSink
Visual Basic
Public Interface FileManagerEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsSink Interface


FileManagerEventsSink Methods

FileManagerEventsSink Methods
Summary

The methods of the FileManagerEventsSink class are listed here.

Methods
Methods
Name | Description
OnFileCopy | Event that fires whenever a file is moved or copied using the MoveFile or CopyFile methods of the FileManager object.
OnFileDelete | The OnFileDelete event notifies a client whenever a file is deleted using the DeleteFile method of the FileManager object.
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsSink Interface > FileManagerEventsSink Methods


FileManagerEventsSink.OnFileCopy Method

FileManagerEventsSink.OnFileCopy Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Event that fires whenever a file is moved or copied using the MoveFile or CopyFile methods of the FileManager object.

Visual Basic
Sub OnFileCopy(SourceFullFileName As String, DestinationFullFileName As String, Copy As VARIANT_BOOL, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SourceFullFileName | The full file name of the file to copy/move.
DestinationFullFileName | The full file name of the destination to copy/move to.
Copy | Indicates whether this is a 'copy' (True) or a 'move' (False).
Context | Input object that can be used to determine the context of why the event fired.
HandlingCode | This event supports a veto (HandlingCode = kEventCanceled)
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsSink Interface > FileManagerEventsSink Methods > FileManagerEventsSink.OnFileCopy Method


FileManagerEventsSink.OnFileDelete Method

FileManagerEventsSink.OnFileDelete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

The OnFileDelete event notifies a client whenever a file is deleted using the DeleteFile method of the FileManager object.

Visual Basic
Sub OnFileDelete(FullFileName As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
FullFileName | The full filename of the file being deleted.
Context | Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the notification. Name = "FileManagementOption". Value = A value from the FileManagementEnum list. This can represent multiple values that have been combined together so you need to use bitwise operations to check for a specific option.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > FileManagerEventsSink Interface > FileManagerEventsSink Methods > FileManagerEventsSink.OnFileDelete Method


FileMetadata Interface

FileMetadata Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

A container object for defining the name and file properties for an Inventor file.

Class Hierarchy
Inventor::FileMetadata
Visual Basic
Public Interface FileMetadata
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientObjects.CreateFileMetadata

You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface


FileMetadata Properties

FileMetadata Properties
Summary

The properties of the FileMetadata class are listed here.

Properties
Name | Description
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
DisplayNameOverridden | Property that gets and sets whether the display name of the document has been overridden.
Document | Property that gets and sets the document object for which the file name and properties are being requested. This can be set to Nothing if the document hasn't yet been created.
FileName | Property that gets and sets just the file name portion (no extension and no path) of the FullFileName string.
FileNameOverridden | Property that gets and sets whether the filename provided should be editable by the end-user or not. If set to True, the supplied filename should be used as given and not allow the end-user to change it. If set to False, the provided filename should be used as the default filename in any dialogs but should allow the end-user to change it to another name. This property defaults to False.
FileProperties | Property that gets and sets an XML string containing the values for file properties.
FullFileName | Property that gets and sets the full file name (with the extension and the path).
Type | Property returning kFileMetadataObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties


FileMetadata.DisplayName Property

FileMetadata.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.DisplayName Property


FileMetadata.DisplayNameOverridden Property

FileMetadata.DisplayNameOverridden Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the display name of the document has been overridden.

Visual Basic
Property DisplayNameOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.DisplayNameOverridden Property


FileMetadata.Document Property

FileMetadata.Document Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the document object for which the file name and properties are being requested. This can be set to Nothing if the document hasn't yet been created.

Visual Basic
Property Document() As Document*
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.Document Property


FileMetadata.FileName Property

FileMetadata.FileName Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets just the file name portion (no extension and no path) of the FullFileName string.

Visual Basic
Property FileName() As String
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.FileName Property


FileMetadata.FileNameOverridden Property

FileMetadata.FileNameOverridden Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the filename provided should be editable by the end-user or not. If set to True, the supplied filename should be used as given and not allow the end-user to change it. If set to False, the provided filename should be used as the default filename in any dialogs but should allow the end-user to change it to another name. This property defaults to False.

Visual Basic
Property FileNameOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.FileNameOverridden Property


FileMetadata.FileProperties Property

FileMetadata.FileProperties Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets an XML string containing the values for file properties.

Visual Basic
Property FileProperties() As String
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.FileProperties Property


FileMetadata.FullFileName Property

FileMetadata.FullFileName Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the full file name (with the extension and the path).

Visual Basic
Property FullFileName() As String
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.FullFileName Property


FileMetadata.Type Property

FileMetadata.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kFileMetadataObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileMetadata Interface > FileMetadata Properties > FileMetadata.Type Property


FileOpenOptions Interface

FileOpenOptions Interface Available in Apprentice
Summary

The FileOpenOptions object provides access to options affecting the opening of files.

Class Hierarchy
Inventor::FileOpenOptions
Visual Basic
Public Interface FileOpenOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FileOptions.FileOpenOptions

You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface


FileOpenOptions Properties

FileOpenOptions Properties
Summary

The properties of the FileOpenOptions class are listed here.

Properties
Name | Description
DefaultDesignView | Property that gets and sets the default design view representation to use when opening assembly documents.
DefaultDesignViewIsAssociative | Property that gets and sets whether the default design view representation is associative.
DefaultLevelOfDetail | Property that gets and sets the default level of detail representation to use when opening assembly documents.
SkipAllUnresolvedFilesInAssembly | Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening assembly files.
SkipAllUnresolvedFilesInDrawing | Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening drawing files.
SkipAllUnresolvedFilesInPart | Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening part files.
You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties


FileOpenOptions.DefaultDesignView Property

FileOpenOptions.DefaultDesignView Property Available in Apprentice
Summary

Property that gets and sets the default design view representation to use when opening assembly documents.

Visual Basic
Property DefaultDesignView() As DesignViewTypeEnum
Remarks

The valid options are kAllVisibleDesignViewType, kLastActiveDesignViewType, kMasterDesignViewType and kNothingVisibleDesignViewType.

The other values kPrivateDesignViewType, kPublicDesignViewType and kTransientDesignViewType are only used to indicate the type of design view representation. They are not valid values to specify the default design view representation and therefore they are not valid values for this property.

You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties > FileOpenOptions.DefaultDesignView Property


FileOpenOptions.DefaultDesignViewIsAssociative Property

FileOpenOptions.DefaultDesignViewIsAssociative Property Available in Apprentice
Summary

Property that gets and sets whether the default design view representation is associative.

Visual Basic
Property DefaultDesignViewIsAssociative() As VARIANT_BOOL
Remarks

This property is only applicable if the default design view is 'Last Active' as indicated by the DefaultDesignView property returning kLastActiveDesignViewType. If the default design view is any other value, then this property is not applicable and setting it will fail.

You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties > FileOpenOptions.DefaultDesignViewIsAssociative Property


FileOpenOptions.DefaultLevelOfDetail Property

FileOpenOptions.DefaultLevelOfDetail Property Available in Apprentice
Summary

Property that gets and sets the default level of detail representation to use when opening assembly documents.

Visual Basic
Property DefaultLevelOfDetail() As LevelOfDetailEnum
Remarks

The valid options are kMasterLevelOfDetail, kAllComponentsSuppressedLevelOfDetail, kAllPartsSuppressedLevelOfDetail and kLastActiveLevelOfDetail.

The other values kSubstituteLevelOfDetail, kAllContentSuppressedLevelOfDetail, kSandboxLevelOfDetail, kTransientLevelOfDetail and kCustomLevelOfDetail are only used to indicate the type of level of detail representation. They are not valid values to specify the default level of representation and therefore they are not valid values for this property.

You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties > FileOpenOptions.DefaultLevelOfDetail Property


FileOpenOptions.SkipAllUnresolvedFilesInAssembly Property

FileOpenOptions.SkipAllUnresolvedFilesInAssembly Property Available in Apprentice
Summary

Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening assembly files.

Visual Basic
Property SkipAllUnresolvedFilesInAssembly() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties > FileOpenOptions.SkipAllUnresolvedFilesInAssembly Property


FileOpenOptions.SkipAllUnresolvedFilesInDrawing Property

FileOpenOptions.SkipAllUnresolvedFilesInDrawing Property Available in Apprentice
Summary

Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening drawing files.

Visual Basic
Property SkipAllUnresolvedFilesInDrawing() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties > FileOpenOptions.SkipAllUnresolvedFilesInDrawing Property


FileOpenOptions.SkipAllUnresolvedFilesInPart Property

FileOpenOptions.SkipAllUnresolvedFilesInPart Property Available in Apprentice
Summary

Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening part files.

Visual Basic
Property SkipAllUnresolvedFilesInPart() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileOpenOptions Interface > FileOpenOptions Properties > FileOpenOptions.SkipAllUnresolvedFilesInPart Property


FileOptions Interface

FileOptions Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

The FileOptions object provides access to properties that provide read and write access of the file related application options.

Class Hierarchy
Inventor::FileOptions
Visual Basic
Public Interface FileOptions
Inherits IDispatch
Remarks

This is somewhat equivalent to the File tab of the Application Options dialog.

Notes

Members through which this object may be accessed include:

ApprenticeServer.FileOptions

Application.FileOptions

You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface


FileOptions Properties

FileOptions Properties
Summary

The properties of the FileOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ContentCenterPath | Property that gets and sets the default location of content center files used by Autodesk Inventor.
DefaultVBAProjectFileFullFilename | Property that gets and sets the full filename of the .ivb file that is being used as the application VBA project. When setting this property you must specify an existing .ivb file.
DesignDataPath | Property that gets and sets the location of external files, such as thread tables, used by Autodesk Inventor.
FileOpenOptions | Property that gets the FileOpenOptions object.
ProjectsPath | Property that gets and sets the location that contains shortcuts to project files. When a new project file is created a shortcut is added to this folder.
QuickFileOpenCachedAssembly | This is QuickFileOpenCachedAssembly, a member of class FileOptions.
QuickFileOpenCacheLastAssembly | This is QuickFileOpenCacheLastAssembly, a member of class FileOptions.
QuickFileOpenEnabled | This is QuickFileOpenEnabled, a member of class FileOptions.
TeamWebFullFilename | Property that gets and sets the full filename of the html file that is displayed when the 'Team Web' command in the Web menu is run.
TemplatesPath | Property that gets and sets the location of template files that Autodesk Inventor uses when creating new files.
Type | Returns an ObjectTypeEnum indicating this object's type.
UndoPath | Property that gets and sets the location of the temporary file that tracks changes to a model or drawing so that actions can be undone.
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties


FileOptions.Application Property

FileOptions.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.Application Property


FileOptions.ContentCenterPath Property

FileOptions.ContentCenterPath Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the default location of content center files used by Autodesk Inventor.

Visual Basic
Property ContentCenterPath() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.ContentCenterPath Property


FileOptions.DefaultVBAProjectFileFullFilename Property

FileOptions.DefaultVBAProjectFileFullFilename Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the full filename of the .ivb file that is being used as the application VBA project. When setting this property you must specify an existing .ivb file.

Visual Basic
Property DefaultVBAProjectFileFullFilename() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.DefaultVBAProjectFileFullFilename Property


FileOptions.DesignDataPath Property

FileOptions.DesignDataPath Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location of external files, such as thread tables, used by Autodesk Inventor.

Visual Basic
Property DesignDataPath() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.DesignDataPath Property


FileOptions.FileOpenOptions Property

FileOptions.FileOpenOptions Property
Summary

Property that gets the FileOpenOptions object.

Visual Basic
Property FileOpenOptions() As FileOpenOptions**
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.FileOpenOptions Property


FileOptions.ProjectsPath Property

FileOptions.ProjectsPath Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location that contains shortcuts to project files. When a new project file is created a shortcut is added to this folder.

Visual Basic
Property ProjectsPath() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.ProjectsPath Property


FileOptions.QuickFileOpenCachedAssembly Property

FileOptions.QuickFileOpenCachedAssembly Property
Summary

This is QuickFileOpenCachedAssembly, a member of class FileOptions.

Visual Basic
Property QuickFileOpenCachedAssembly() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.QuickFileOpenCachedAssembly Property


FileOptions.QuickFileOpenCacheLastAssembly Property

FileOptions.QuickFileOpenCacheLastAssembly Property
Summary

This is QuickFileOpenCacheLastAssembly, a member of class FileOptions.

Visual Basic
Property QuickFileOpenCacheLastAssembly() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.QuickFileOpenCacheLastAssembly Property


FileOptions.QuickFileOpenEnabled Property

FileOptions.QuickFileOpenEnabled Property
Summary

This is QuickFileOpenEnabled, a member of class FileOptions.

Visual Basic
Property QuickFileOpenEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.QuickFileOpenEnabled Property


FileOptions.TeamWebFullFilename Property

FileOptions.TeamWebFullFilename Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the full filename of the html file that is displayed when the 'Team Web' command in the Web menu is run.

Visual Basic
Property TeamWebFullFilename() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.TeamWebFullFilename Property


FileOptions.TemplatesPath Property

FileOptions.TemplatesPath Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location of template files that Autodesk Inventor uses when creating new files.

Visual Basic
Property TemplatesPath() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.TemplatesPath Property


FileOptions.Type Property

FileOptions.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.Type Property


FileOptions.UndoPath Property

FileOptions.UndoPath Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location of the temporary file that tracks changes to a model or drawing so that actions can be undone.

Visual Basic
Property UndoPath() As String
You are here: Symbol Reference > Inventor Library > Objects > FileOptions Interface > FileOptions Properties > FileOptions.UndoPath Property


FileSaveAs Interface

FileSaveAs Interface Available in Apprentice Introduced in Inventor 4
Summary

Custom interface to access management information about a particular file version.

Class Hierarchy
Inventor::FileSaveAs
Visual Basic
Public Interface FileSaveAs
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.FileSaveAs

You are here: Symbol Reference > Inventor Library > Objects > FileSaveAs Interface


FileSaveAs Methods

FileSaveAs Methods
Summary

The methods of the FileSaveAs class are listed here.

Methods
Methods
Name | Description
AddFileToSave | Adds a document, taken from within this tree, to the set of documents to be saved. Please note: Saving of files in Apprentice is not allowed on files that require migration (any file that has not already been migrated to the same version of the Apprentice server). The current document's NeedsMigrating property must return False before the FileSaveAs object can successfully be returned.
ExecuteSave | Executes the Save operation on each of the documents specified via the AddFileToSave method.
ExecuteSaveAs | Executes the Save As operation on each of the documents specified via the AddFileToSave method.
ExecuteSaveCopyAs | Executes the Save Copy As operation on each of the documents specified via the AddFileToSave method.
You are here: Symbol Reference > Inventor Library > Objects > FileSaveAs Interface > FileSaveAs Methods


FileSaveAs.AddFileToSave Method

FileSaveAs.AddFileToSave Method Available in Apprentice Introduced in Inventor 4
Summary

Adds a document, taken from within this tree, to the set of documents to be saved. Please note: Saving of files in Apprentice is not allowed on files that require migration (any file that has not already been migrated to the same version of the Apprentice server). The current document's NeedsMigrating property must return False before the FileSaveAs object can successfully be returned.

Visual Basic
Sub AddFileToSave(Document As IUnknown, TargetFileName As String)
Parameters
Parameters | Description
Document | Input object that specifies the to be saved.
TargetFileName | Input String that specifies the name of the file to be saved.
You are here: Symbol Reference > Inventor Library > Objects > FileSaveAs Interface > FileSaveAs Methods > FileSaveAs.AddFileToSave Method


FileSaveAs.ExecuteSave Method

FileSaveAs.ExecuteSave Method Available in Apprentice Introduced in Inventor 4
Summary

Executes the Save operation on each of the documents specified via the AddFileToSave method.

Visual Basic
Sub ExecuteSave()
You are here: Symbol Reference > Inventor Library > Objects > FileSaveAs Interface > FileSaveAs Methods > FileSaveAs.ExecuteSave Method


FileSaveAs.ExecuteSaveAs Method

FileSaveAs.ExecuteSaveAs Method Available in Apprentice Introduced in Inventor 4
Summary

Executes the Save As operation on each of the documents specified via the AddFileToSave method.

Visual Basic
Sub ExecuteSaveAs()
You are here: Symbol Reference > Inventor Library > Objects > FileSaveAs Interface > FileSaveAs Methods > FileSaveAs.ExecuteSaveAs Method


FileSaveAs.ExecuteSaveCopyAs Method

FileSaveAs.ExecuteSaveCopyAs Method Available in Apprentice Introduced in Inventor 4
Summary

Executes the Save Copy As operation on each of the documents specified via the AddFileToSave method.

Visual Basic
Sub ExecuteSaveCopyAs()
You are here: Symbol Reference > Inventor Library > Objects > FileSaveAs Interface > FileSaveAs Methods > FileSaveAs.ExecuteSaveCopyAs Method


FilesEnumerator Interface

FilesEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The FilesEnumerator object provides access to all Inventor files.

Class Hierarchy
Inventor::FilesEnumerator
Visual Basic
Public Interface FilesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

File.AllReferencedFiles

File.ReferencedFiles

File.ReferencingFiles

FileManager.Files

You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface


FilesEnumerator Methods

FilesEnumerator Methods
Summary

The methods of the FilesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified File object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface > FilesEnumerator Methods


FilesEnumerator.Item Method

FilesEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the specified File object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] File*)
Parameters
Parameters | Description
index | Input Variant value that specifies the File to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the full file name. If an out of range index or a name of a non-existent File is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface > FilesEnumerator Methods > FilesEnumerator.Item Method


FilesEnumerator Properties

FilesEnumerator Properties
Summary

The properties of the FilesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Returns kFilesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface > FilesEnumerator Properties


FilesEnumerator.Application Property

FilesEnumerator.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface > FilesEnumerator Properties > FilesEnumerator.Application Property


FilesEnumerator.Count Property

FilesEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface > FilesEnumerator Properties > FilesEnumerator.Count Property


FilesEnumerator.Type Property

FilesEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns kFilesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilesEnumerator Interface > FilesEnumerator Properties > FilesEnumerator.Type Property


FileUIEvents CoClass

FileUIEvents CoClass Available in Inventor Introduced in Inventor 4
Summary

The FileUIEvents object supports a set of events that are fired when the user is creating, inserting, opening and saving files.

Class Hierarchy
Inventor::FileUIEvents
Visual Basic
Public Class FileUIEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.FileUIEvents

You are here: Symbol Reference > Inventor Library > Objects > FileUIEvents CoClass


FileUIEventsObject Interface

FileUIEventsObject Interface Available in Inventor Introduced in Inventor 4
Summary

The FileUIEvents object supports a set of events that are fired when the user is creating, inserting, opening and saving files.

Class Hierarchy
Inventor::FileUIEventsObject
Visual Basic
Public Interface FileUIEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface


FileUIEventsObject Methods

FileUIEventsObject Methods
Summary

The methods of the FileUIEventsObject class are listed here.

Methods
Methods
Name | Description
PopulateFileMetadata | Method that fires the OnPopulateFileMetadata event with the input arguments and returns the values specified in the event.
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface > FileUIEventsObject Methods


FileUIEventsObject.PopulateFileMetadata Method

FileUIEventsObject.PopulateFileMetadata Method Available in Inventor Introduced in Inventor 2009
Summary

Method that fires the OnPopulateFileMetadata event with the input arguments and returns the values specified in the event.

Visual Basic
Sub PopulateFileMetadata(FileMetadataObjects As ObjectCollection, Formulae As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
FileMetadataObjects | Input/output ObjectCollection that contains FileMetadata objects with the proposed file names and properties. The input collection should contain one FileMetadata object for every file being generated. The output collection will contain the same number, but the proposed names and properties may have been modified by interested clients.
Formulae | Input String that specifies XML-based formulae for generating file name, display name and file properties. Null strings are valid. Sample formula XML (suggested): <'Some way to get the index'>
Returns

'Route D112B9C8-78F8-4e3c-BB1E-2740D6C5557A 5 AAA' Context : Input/output NameValueMap object that can be used to specify the context.

HandlingCode : Output HandlingCodeEnum that returns one of the following values:

  • kEventNotHandled: No interception took place and the command should continue with its standard behavior and display the file naming dialog to the user.
  • kEventHandled: Indicates that the client has specified one or more file names and/or properties for the files. The command should use these to display in its file naming dialog.
  • kEventCanceled: A problem was encountered in the event handling by the client. The command can choose to message the user and proceed with its own default filenames or cancel out of the command at the user's discretion.
Remarks

This method should be called just before showing the file naming dialog to the user. The method returns the values specified in the corresponding event.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface > FileUIEventsObject Methods > FileUIEventsObject.PopulateFileMetadata Method


FileUIEventsObject Properties

FileUIEventsObject Properties
Summary

The properties of the FileUIEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface > FileUIEventsObject Properties


FileUIEventsObject.Application Property

FileUIEventsObject.Application Property Available in Inventor Introduced in Inventor 7
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface > FileUIEventsObject Properties > FileUIEventsObject.Application Property


FileUIEventsObject.Parent Property

FileUIEventsObject.Parent Property Available in Inventor Introduced in Inventor 7
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface > FileUIEventsObject Properties > FileUIEventsObject.Parent Property


FileUIEventsObject.Type Property

FileUIEventsObject.Type Property Available in Inventor Introduced in Inventor 7
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsObject Interface > FileUIEventsObject Properties > FileUIEventsObject.Type Property


FileUIEventsSink Interface

FileUIEventsSink Interface Available in Inventor Introduced in Inventor 4
Summary

The FileUIEvents object supports a set of events that are fired when the user is creating, inserting, opening and saving files.

Class Hierarchy
Inventor::FileUIEventsSink
Visual Basic
Public Interface FileUIEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface


FileUIEventsSink Methods

FileUIEventsSink Methods
Summary

The methods of the FileUIEventsSink class are listed here.

Methods
Methods
Name | Description
OnFileInsertDialog | The OnFileInsertDialog event notifies a client whenever the end-user has executed a command that provides for the selection and insertion of a document into another document.
OnFileInsertNewDialog | The OnFileInsertNewDialog event notifies the client whenever the end-user executes the Create Component command within an assembly.
OnFileNew | Fires before a File New from standard template is executed.
OnFileNewDialog | The OnFileNewDialog event notifies the client when the end-user executes the New command to create a new file.
OnFileOpenDialog | The OnFileOpenDialog event notifies the client when the end-user executes the Open command to open an existing file.
OnFileOpenFromMRU | Fires when a file is selected from the MRU list to open.
OnFileSaveAsDialog | The OnFileSaveAsDialog event notifies the client when the end-user executes the Save As or Save Copy As command to create a new file.
OnPopulateFileMetadata | Event that fires when file names and properties are being generated by a command.
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods


FileUIEventsSink.OnFileInsertDialog Method

FileUIEventsSink.OnFileInsertDialog Method Available in Inventor Introduced in Inventor 4
Summary

The OnFileInsertDialog event notifies a client whenever the end-user has executed a command that provides for the selection and insertion of a document into another document.

Visual Basic
Sub OnFileInsertDialog(FileTypes As SAFEARRAY(BSTR), DocumentObject As Document, ParentHWND As long, ByRef FileName As String, ByRef RelativeFileName As String, ByRef LibraryName As String, ByRef CustomLogicalName As SAFEARRAY(unsigned char), Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
FileTypes
A list of the file types displayed in the 'Files of Type' combo box on the Open dialog. For example, when the Derived Component command is executed the array contains the following three strings: "Component Files (*.ipt, *.iam)|*.ipt; *.iam" "Part Files (*.ipt)|*.ipt" "Assembly Files (*.iam)|*.iam"
DocumentObject
The object the file will be inserted into. For example, if the Place Component command is invoked, this will be the assembly the component will be inserted into.
ParentHWND
The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
FileName
The full filename that the client returns to Inventor if they choose to override Inventor's standard behavior and obtain the filename themselves. In order for this filename to be used the client must also return kEventHandled as the handling code.
RelativeFileName
Not used.
LibraryName
Not used.
CustomLogicalName
An array of Bytes that can be used by data management systems as a way to associate additional information with a file reference. During file resolution, the data management system can use this information to help look up the file within the data management system. Supplying an array of bytes for this event will associate this custom logical name with the reference created to the document being inserted. If a reference already exists for this document, the existing custom logical name will be replaced by this one.
Context
Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the notification. See the Remarks section for valid NameValueMap values.
HandlingCode
Output that indicates how you are handling the event. Can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the Open dialog to allow the end-user to select a file.
  • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also sets the FileName argument with the full filename of the file Inventor should use.
  • kEventCanceled: Cancels the operation.

Remarks

Three common commands are the Place Component command in assembly, the Derived Component command in part, and the Base View command in drawing. When these commands are run, the end-user needs to select a file. By default Inventor displays the standard Open dialog to allow them to specify the file. Using this event a client can override the standard behavior of Inventor and provide the filename using whatever procedure they choose; typically replacing the Open dialog with their own dialog. This notification is sent to the client at the point the Open dialog would usually be displayed. If the client wants to handle getting the filename then they get a filename any way they choose and then respond to this event by setting the FileName argument with the filename they have and set the HandlingCode argument to kEventHandled. If the client responds to this event with a filename and the kEventHandled, then Inventor uses the supplied filename and does not display its standard Open dialog. If the client responds with kEventNotHandled, Inventor uses its standard behavior and will display the Open dialog. If the client responds with kEventCanceled, the command is cancelled.

Valid NameValueMap values for the Context argument:

Name | Value | Valid when inserting
Embed | Boolean | .xls, .xlsx, all image files
StartCell | String | .xls, .xlsx
DesignViewRepresentation | String | .iam
DesignViewAssociative | Boolean | .iam
PrivateRepresentationFileName | String | .iam
PositionalRepresentation | Boolean | .iam
LevelOfDetailRepresentation | String | .iam
InteractiveiMates | Boolean | .ipt, .iam
AutomaticiMates | Boolean | .ipt, .iam
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileInsertDialog Method


FileUIEventsSink.OnFileInsertNewDialog Method

FileUIEventsSink.OnFileInsertNewDialog Method Available in Inventor Introduced in Inventor 4
Summary

The OnFileInsertNewDialog event notifies the client whenever the end-user executes the Create Component command within an assembly.

Visual Basic
Sub OnFileInsertNewDialog(TemplateDir As String, FileTypes As SAFEARRAY(BSTR), DocumentObject As Document, ParentHWND As long, ByRef TemplateFileName As String, ByRef FileName As String, ByRef RelativeFileName As String, ByRef LibraryName As String, ByRef CustomLogicalName As SAFEARRAY(unsigned char), Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
TemplateDir
The default template directory as defined in the File tab of the Application Options dialog. This information can be used by the client in their dialog to allow the end-user to select one of the standard templates.
FileTypes
A list of the file types displayed in the "Files of Type" combo box on the Open dialog. For example, when the Derived Component command is executed the array contains the following strings: "Part Files (*.ipt)|*.ipt" "Assembly Files (*.iam)|*.iam"
DocumentObject
The AssemblyDocument object the new component will be created within.
ParentHWND
The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
TemplateFileName
The full filename of the file to use as the template when creating the new component. This can be any existing file and is not restricted to the files within the default template path. If this argument is not set, then the default part or assembly template will be used for the component. The type of document is determined based on the extension of the filename supplied in the Filename argument. This argument is ignored unless the HandlingCode argument is set to kEventHandled.
FileName
The full filename of the file to be created. When creating a component in-place, the component is created in memory and is not written to disk until the end-user performs a save of the file. Because the filename is specified during the creation of the component the end-user will not be prompted for a filename during the save operation. This argument is required if the HandlingCode is set to kEventHandled.
RelativeFileName
Not used.
LibraryName
Not used.
CustomLogicalName
An array of Bytes that could have been defined by an application as an additional identifier for this document.
Context
Input object that can be used to determine the context of why the event fired. No context information is provided for this event. See Remarks for valid NameValueMap values.
HandlingCode
Output that indicates how you are handling the event. This can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the "Create In-Place Component" dialog to allow the end-user to specify the component information.
  • kEventHandled: Indicates that the client is handling getting the component information. Requires that the client also set, at least, the FileName argument with the full filename of the component to be created.
  • kEventCanceled: Cancels the operation.

Remarks

By responding to this event the client can replace the 'Create In-Place Component' dialog with their own. This notification is sent to the client immediately after the command is executed but before the standard dialog is displayed to the end-user. By supplying at least the Filename argument and setting the HandlingCode to kEventHandled, Inventor will bypass displaying the standard dialog and use the information provided to create a new in-place component within the assembly. The rest of the command behavior remains the same. That is, if this isn't the first component being placed in the assembly, the end-user must select a location in the assembly to position the new component.

Valid NameValueMap values for the Context parameter:

Name | Value | Comments
BOMStructure | BOMStructureEnum |
VirtualComponent | Boolean | The FileName argument is the virtual component name.
ConstrainSketchPlane | Boolean | Does not apply for the first component in assembly.
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileInsertNewDialog Method


FileUIEventsSink.OnFileNew Method

FileUIEventsSink.OnFileNew Method Available in Inventor Introduced in Inventor 2009
Summary

Fires before a File New from standard template is executed.

Visual Basic
Sub OnFileNew(DocumentType As DocumentTypeEnum, ByRef TemplateFileName As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentType
DocumentTypeEnum indicating the document's type. Possible values include kUnknownDocumentObject,
kPartDocumentObject, kAssemblyDocumentObject, kDrawingDocumentObject, kPresentationDocumentObject, kDesignElementDocumentObject, kForeignModelDocumentObject, and kSATFileDocumentObject.
TemplateFileName
The full filename of the file to use as the template when creating the new file. This can be any existing file and is not restricted to the files within the default template path. This argument must be set if the HandlingCode is set to kEventHandled.
Context
Input object that, if populated, can be used to determine the context of why the event fired.
HandlingCode
Output that indicates how you are handling the event. Can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the "Open" dialog to allow the end-user to select a template.
  • kEventHandled: Indicates that the client is handling getting the template. Requires that the client also set the TemplateFileName argument.
  • kEventCanceled: Cancels the operation.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileNew Method


FileUIEventsSink.OnFileNewDialog Method

FileUIEventsSink.OnFileNewDialog Method Available in Inventor Introduced in Inventor 4
Summary

The OnFileNewDialog event notifies the client when the end-user executes the New command to create a new file.

Visual Basic
Sub OnFileNewDialog(TemplateDir As String, ParentHWND As long, ByRef TemplateFileName As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
TemplateDir
The default template directory as defined in the File tab of the Application Options dialog. This information can be used by the client in their dialog to allow the end-user to select one of the standard templates.
ParentHWND
The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
TemplateFileName
The full filename of the file to use as the template when creating the new file. This can be any existing file and is not restricted to the files within the default template path. This argument must be set if the HandlingCode is set to kEventHandled.
Context
Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode
Output that indicates how you are handling the event. Can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the "Open" dialog to allow the end-user to select a template.
  • kEventHandled: Indicates that the client is handling getting the template. Requires that the client also set the TemplateFileName argument.
  • kEventCanceled: Cancels the operation.

Remarks

By responding to this event the client can override Inventor's standard behavior of displaying the Open dialog and provide their own interface to determine the template to use in creating the new file. This notification is only made in cases where the Open dialog is displayed to allow the end-user to select a template. If the end-user uses the pop-up command list next to the New command to select an assembly, part, presentation, or drawing document, the Open dialog is bypassed and this notification is not sent in this case.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileNewDialog Method


FileUIEventsSink.OnFileOpenDialog Method

FileUIEventsSink.OnFileOpenDialog Method Available in Inventor Introduced in Inventor 4
Summary

The OnFileOpenDialog event notifies the client when the end-user executes the Open command to open an existing file.

Visual Basic
Sub OnFileOpenDialog(FileTypes As SAFEARRAY(BSTR), ParentHWND As long, ByRef FileName As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
FileTypes
A list of the file types displayed in the "Files of Type" combo box on the Open dialog. Examples of some strings that could be provided by this arguments are: "Inventor Files (*.iam;*.idw;*.ipt;*.ipn;*.ide)|*.iam;*.idw;*.ipt;*.ipn;*.ide" "Assembly Files (*.iam)|*.iam" "Drawing Files (*.idw)|*.idw" "Part Files (*.ipt)|*.ipt" "STEP Files (*.stp;*.ste;*.step)|*.stp;*.ste;*.step" "All Files (*.*)|*.*"
ParentHWND
The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
FileName
The full filename of the file to open. This must be an existing valid file and the HandlingCode must be set to kEventHandled in order to override the standard open behavior.
Context
Input object that can be used to determine the context of why the event fired. No context information is provided for this event. See Remarks for valid NameValueMap values.
HandlingCode
Output that indicates how you are handling the event. Can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the "Open" dialog to allow the end-user to select a file.
  • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also set the FileName argument.
  • kEventCanceled: Cancels the operation.

Remarks

By responding to this event the client can override Inventor's standard behavior of displaying the Open dialog and provide their own interface to determine the file to open. This notification is only made in cases where the Open dialog is displayed to allow the end-user to select a file. If the end-user uses the most recently used list in the File menu to open a file, the Open dialog is bypassed and the file is opened directly. In this case, because the Open dialog is not used this notification is not sent.

Valid NameValueMap values for the Context parameter:

Name | Value | Valid when inserting
DesignViewRepresentation | String | .iam
DesignViewAssociative | Boolean | .iam
PrivateRepresentationFileName | String | .iam
PositionalRepresentation | Boolean | .iam
LevelOfDetailRepresentation | String | .iam
DeferUpdates | Boolean | .idw, .dwg (Inventor dwg)
ImportNonInventorDWG | Boolean | .dwg (non-Inventor dwg)
FileVersionOption | FileVersionEnum | All
Password | String | Protected .dwg
You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileOpenDialog Method


FileUIEventsSink.OnFileOpenFromMRU Method

FileUIEventsSink.OnFileOpenFromMRU Method Available in Inventor Introduced in Inventor 2009
Summary

Fires when a file is selected from the MRU list to open.

Visual Basic
Sub OnFileOpenFromMRU(ByRef FullFileName As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
FullFileName
The full filename of the file to open. This must be an existing valid file and the HandlingCode must be set to kEventHandled in order to override the standard open behavior.
Context
Input object that can be used to determine the context of why the event fired. No context information is provided for this event. See Remarks for valid NameValueMap values.
HandlingCode
Output that indicates how you are handling the event. Can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the "Open" dialog to allow the end-user to select a file.
  • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also set the FileName argument.
  • kEventCanceled: Cancels the operation.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileOpenFromMRU Method


FileUIEventsSink.OnFileSaveAsDialog Method

FileUIEventsSink.OnFileSaveAsDialog Method Available in Inventor Introduced in Inventor 4
Summary

The OnFileSaveAsDialog event notifies the client when the end-user executes the Save As or Save Copy As command to create a new file.

Visual Basic
Sub OnFileSaveAsDialog(FileTypes As SAFEARRAY(BSTR), SaveCopyAs As VARIANT_BOOL, ParentHWND As long, ByRef FileName As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
FileTypes
A list of the file types displayed in the 'Files of Type' combo box on the Save As dialog. When saving a copy of part an example of the list is: "Part Files (*.ipt)|*.ipt" "DWF Files (*.dwf)|*.dwf" "BMP (*.bmp)|*.bmp" "IGES Files (*.igs;*.ige;*.iges)|*.igs;*.ige;*.iges" "SAT Files (*.sat)|*.sat"
SaveCopyAs
Indicates if the end-user is performing a Save As or Save Copy As operation. Returns True if it is a Save Copy As and False for Save As.
ParentHWND
The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
FileName
The full filename to use when saving the file. The handling code must be set to kEventHandled in order to override the standard Save dialog and save the file using this filename.
Context
Input object that can be used to determine the context of why the event fired. The following information is provided through the Context argument: Name = "TopLevelDocument". Value = The Document object being saved.
HandlingCode
Output that indicates how you are handling the event. Can supply any of the following three values:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the "Save As" dialog to allow the end-user to specify the filename.
  • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also set the FileName argument.
  • kEventCanceled: Cancels the operation.

Remarks

This notification is also sent when the Save command is executed the first time for a file that has not been previously saved. By responding to this event the client can override Inventor's standard behavior of displaying the Save As dialog and provide their own interface to determine the new filename.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnFileSaveAsDialog Method


FileUIEventsSink.OnPopulateFileMetadata Method

FileUIEventsSink.OnPopulateFileMetadata Method Available in Inventor Introduced in Inventor 2009
Summary

Event that fires when file names and properties are being generated by a command.

Visual Basic
Sub OnPopulateFileMetadata(FileMetadataObjects As ObjectsEnumerator, Formulae As String, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
FileMetadataObjects
Input ObjectsEnumerator that contains FileMetadata objects with the proposed file names and properties. The input enumerator contains one FileMetadata object for every file being generated. The properties of the FileMetadata objects can be set to the desired values.
Formulae
Input String that specifies XML-based formulae for generating file name, display name and file properties. This can be a null string.
Context
Input/output NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event:

  • kEventNotHandled: Inventor continues with its standard behavior and displays the file-naming dialog to the end-user.
  • kEventHandled: Indicates that the client has specified file names and/or properties for the files and Inventor should use these to display in its dialog to the user.
  • kEventCanceled: This code is return as a signal that an unexpected failure has occurred

Remarks

By responding to this event, clients can override the file names and properties of Inventor files being generated by the command.

You are here: Symbol Reference > Inventor Library > Objects > FileUIEventsSink Interface > FileUIEventsSink Methods > FileUIEventsSink.OnPopulateFileMetadata Method


FilletConstantRadiusEdgeSet Interface

FilletConstantRadiusEdgeSet Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ConstantRadiusEdgeSet object provides access the edges and their associated radii for a constant radius fillet.

Class Hierarchy
Inventor::FilletRadiusEdgeSet
    Inventor::FilletConstantRadiusEdgeSet
Visual Basic
Public Interface FilletConstantRadiusEdgeSet
Inherits FilletRadiusEdgeSet
Notes

Members through which this object may be accessed include:

FilletDefinition.AddConstantRadiusEdgeSet

You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusEdgeSet Interface


FilletConstantRadiusEdgeSet Properties

FilletConstantRadiusEdgeSet Properties
Summary

The properties of the FilletConstantRadiusEdgeSet class are listed here.

Properties
Name | Description
AllFillets | Property that returns if the edge set defines all concave edges.
AllRounds | Property that returns if the edge set defines all convex edges.
ContinuityType | Property that gets and sets the continuity type for the edge set. Valid values are kTangentContinuity and kCurvatureContinuity. This property can currently only be set in the forward create scenario (it fails if the FilletDefinition is obtained from an existing feature).
Radius | Property that returns the parameter that controls the radius of the fillet. This property will return Nothing if the fillet feature has not been created yet.
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusEdgeSet Interface > FilletConstantRadiusEdgeSet Properties


FilletConstantRadiusEdgeSet.AllFillets Property

FilletConstantRadiusEdgeSet.AllFillets Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns if the edge set defines all concave edges.

Visual Basic
Property AllFillets() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusEdgeSet Interface > FilletConstantRadiusEdgeSet Properties > FilletConstantRadiusEdgeSet.AllFillets Property


FilletConstantRadiusEdgeSet.AllRounds Property

FilletConstantRadiusEdgeSet.AllRounds Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns if the edge set defines all convex edges.

Visual Basic
Property AllRounds() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusEdgeSet Interface > FilletConstantRadiusEdgeSet Properties > FilletConstantRadiusEdgeSet.AllRounds Property


FilletConstantRadiusEdgeSet.ContinuityType Property

FilletConstantRadiusEdgeSet.ContinuityType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the continuity type for the edge set. Valid values are kTangentContinuity and kCurvatureContinuity. This property can currently only be set in the forward create scenario (it fails if the FilletDefinition is obtained from an existing feature).

Visual Basic
Property ContinuityType() As ContinuityTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusEdgeSet Interface > FilletConstantRadiusEdgeSet Properties > FilletConstantRadiusEdgeSet.ContinuityType Property


FilletConstantRadiusEdgeSet.Radius Property

FilletConstantRadiusEdgeSet.Radius Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the radius of the fillet. This property will return Nothing if the fillet feature has not been created yet.

Visual Basic
Property Radius() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusEdgeSet Interface > FilletConstantRadiusEdgeSet Properties > FilletConstantRadiusEdgeSet.Radius Property


FilletConstantRadiusFaceSet Interface

FilletConstantRadiusFaceSet Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The ConstantRadiusFaceSet object provides access to the faces for a constant radius fillet.

Class Hierarchy
Inventor::FilletConstantRadiusFaceSet
Visual Basic
Public Interface FilletConstantRadiusFaceSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletDefinition.FaceSet

FilletDefinition.AddFaceSet

You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface


FilletConstantRadiusFaceSet Properties

FilletConstantRadiusFaceSet Properties
Summary

The properties of the FilletConstantRadiusFaceSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BiasPoint | Optional input Point object that specifies a bias point to help choose between solutions if there are multiple possibilities.
FacesOne | FaceCollection object that contains the first set of faces for the face fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
FacesOneReverseDirection | Boolean that indicates whether the side of the surface on which the fillet will be created is flipped. This only applies to faces of a surface and is ignored for faces of a solid.
FacesTwo | FaceCollection object that contains the second set of faces for the face fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
FacesTwoReverseDirection | Boolean that indicates whether the side of the surface on which the fillet was created is flipped. This only applies to faces of a surface and is ignored for faces of a solid.
IncludeTangentFaces | Boolean that indicates whether faces were tangential to the faces input in the FacesOne and FacesTwo arguments for the fillet creation.
Radius | Property that returns the parameter that controls the radius of the fillet. This property will return Nothing if the fillet feature has not been created yet.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties


FilletConstantRadiusFaceSet.Application Property

FilletConstantRadiusFaceSet.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.Application Property


FilletConstantRadiusFaceSet.BiasPoint Property

FilletConstantRadiusFaceSet.BiasPoint Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Optional input Point object that specifies a bias point to help choose between solutions if there are multiple possibilities.

Visual Basic
Property BiasPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.BiasPoint Property


FilletConstantRadiusFaceSet.FacesOne Property

FilletConstantRadiusFaceSet.FacesOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

FaceCollection object that contains the first set of faces for the face fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.

Visual Basic
Property FacesOne() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.FacesOne Property


FilletConstantRadiusFaceSet.FacesOneReverseDirection Property

FilletConstantRadiusFaceSet.FacesOneReverseDirection Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Boolean that indicates whether the side of the surface on which the fillet will be created is flipped. This only applies to faces of a surface and is ignored for faces of a solid.

Visual Basic
Property FacesOneReverseDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.FacesOneReverseDirection Property


FilletConstantRadiusFaceSet.FacesTwo Property

FilletConstantRadiusFaceSet.FacesTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

FaceCollection object that contains the second set of faces for the face fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.

Visual Basic
Property FacesTwo() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.FacesTwo Property


FilletConstantRadiusFaceSet.FacesTwoReverseDirection Property

FilletConstantRadiusFaceSet.FacesTwoReverseDirection Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Boolean that indicates whether the side of the surface on which the fillet was created is flipped. This only applies to faces of a surface and is ignored for faces of a solid.

Visual Basic
Property FacesTwoReverseDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.FacesTwoReverseDirection Property


FilletConstantRadiusFaceSet.IncludeTangentFaces Property

FilletConstantRadiusFaceSet.IncludeTangentFaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Boolean that indicates whether faces were tangential to the faces input in the FacesOne and FacesTwo arguments for the fillet creation.

Visual Basic
Property IncludeTangentFaces() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.IncludeTangentFaces Property


FilletConstantRadiusFaceSet.Radius Property

FilletConstantRadiusFaceSet.Radius Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parameter that controls the radius of the fillet. This property will return Nothing if the fillet feature has not been created yet.

Visual Basic
Property Radius() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.Radius Property


FilletConstantRadiusFaceSet.Type Property

FilletConstantRadiusFaceSet.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletConstantRadiusFaceSet Interface > FilletConstantRadiusFaceSet Properties > FilletConstantRadiusFaceSet.Type Property


FilletDefinition Interface

FilletDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FilletDefinition object is used to define all of the input required for fillet features. It is also used to query and edit existing fillet features.

Class Hierarchy
Inventor::FilletDefinition
Visual Basic
Public Interface FilletDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletFeature.FilletDefinition

FilletFeatures.CreateFilletDefinition

See Also

Fillet Feature (Complex) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface


FilletDefinition Methods

FilletDefinition Methods
Summary

The methods of the FilletDefinition class are listed here.

Methods
Methods
Name | Description
AddConstantRadiusEdgeSet | Method that creates a new constant radius edge set. The new FilletDefinition is returned.
AddFaceSet | Method that creates a new constant radius face set used to create a face fillet. The new FilletFaceSet is returned. If a FilletFaceSet already exists in the definition, it is replaced with this new one.
AddFullRoundSet | Method that creates a new full round set used to create a full round fillet. The new FilletFullRoundSet is returned. If a FilletFullRoundSet already exists in the definition, it is replaced with this new one.
AddVariableRadiusEdgeSet | Method that creates a new variable radius edge set. Intermediate radii can be defined using the AddIntermediatePoint method of the FilletVariableRadiusEdgeSet object returned by this method.
EdgeSetItem | Method that returns the specified FilletRadiusEdgeSet object from the collection. This will return either a FilletConstantRadiusEdgeSet or FilletVariableRadiusEdgeSet object.
SetbackVertexItem | Property that returns the specified FilletSetbackVertex object from the definition.
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods


FilletDefinition.AddConstantRadiusEdgeSet Method

FilletDefinition.AddConstantRadiusEdgeSet Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new constant radius edge set. The new FilletDefinition is returned.

Visual Basic
Sub AddConstantRadiusEdgeSet(Edges As EdgeCollection, ConstantRadius As VARIANT, Result As [out, retval] FilletConstantRadiusEdgeSet*)
Parameters
Parameters | Description
Edges | Input object that contains edges for the fillet feature.
ConstantRadius | Input Variant that defines the radius of the fillet. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
See Also

Fillet Feature (Complex) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods > FilletDefinition.AddConstantRadiusEdgeSet Method


FilletDefinition.AddFaceSet Method

FilletDefinition.AddFaceSet Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new constant radius face set used to create a face fillet. The new FilletFaceSet is returned. If a FilletFaceSet already exists in the definition, it is replaced with this new one.

Visual Basic
Sub AddFaceSet(FacesOne As FaceCollection, FacesTwo As FaceCollection, Radius As VARIANT, ByRef IncludeTangentFaces As [defaultvalue(-1)] VARIANT_BOOL, ByRef BiasPoint As [optional] VARIANT, ByRef FacesOneReverseDirection As [defaultvalue(0)] VARIANT_BOOL, ByRef FacesTwoReverseDirection As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] FilletConstantRadiusFaceSet*)
Parameters
Parameters | Description
FacesOne | FaceCollection object that contains the first set of faces for the face fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
FacesTwo | FaceCollection object that contains the second set of faces for the face fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
Radius | Defines the radius of the face fillet. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
IncludeTangentFaces | Boolean that specifies whether to include faces that are tangential to the faces input in the FacesOne and FacesTwo arguments for the fillet creation. If not specified, a default of True is used, indicating that the tangential faces will be used in feature creation.
BiasPoint | Optional input Point object that specifies a bias point to help choose between solutions if there are multiple possibilities.
FacesOneReverseDirection | Optional input Boolean that specifies whether to flip the side of the surface on which the fillet will be created. This argument only applies to faces of a surface and is ignored for faces of a solid. Default value is False.
FacesTwoReverseDirection | Optional input Boolean that specifies whether to flip the side of the surface on which the fillet will be created. This argument only applies to faces of a surface and is ignored for faces of a solid. Default value is False.
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods > FilletDefinition.AddFaceSet Method


FilletDefinition.AddFullRoundSet Method

FilletDefinition.AddFullRoundSet Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new full round set used to create a full round fillet. The new FilletFullRoundSet is returned. If a FilletFullRoundSet already exists in the definition, it is replaced with this new one.

Visual Basic
Sub AddFullRoundSet(SideFacesOne As FaceCollection, CenterFaces As FaceCollection, SideFacesTwo As FaceCollection, ByRef IncludeTangentFaces As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] FilletFullRoundSet*)
Parameters
Parameters | Description
SideFacesOne | FaceCollection object that contains the first set of side faces for the full round fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
CenterFaces | FaceCollection object that contains the center faces for the full round fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
SideFacesTwo | FaceCollection object that contains the second set of side faces for the full round fillet feature. This can contain more than one face only if the faces are tangentially connected. The Face.TangentiallyConnectedFaces property can be used to get a collection of faces that are tangent to a given face.
IncludeTangentFaces | Optional input Boolean that specifies whether to include faces that are tangential to the faces input in the SideFacesOne, CenterFaces and SideFacesTwo arguments for the fillet creation. If not specified, a default of True is used, indicating that the tangential faces will be used in feature creation.
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods > FilletDefinition.AddFullRoundSet Method


FilletDefinition.AddVariableRadiusEdgeSet Method

FilletDefinition.AddVariableRadiusEdgeSet Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new variable radius edge set. Intermediate radii can be defined using the AddIntermediatePoint method of the FilletVariableRadiusEdgeSet object returned by this method.

Visual Basic
Sub AddVariableRadiusEdgeSet(Edges As EdgeCollection, StartRadius As VARIANT, EndRadius As VARIANT, Result As [out, retval] FilletVariableRadiusEdgeSet*)
Parameters
Parameters | Description
Edges | Input object that contains edges for the fillet feature. For variable radius fillets, this can contain more than one edge only if the edges are tangentially connected.
StartRadius | Input Variant that defines the start radius of the variable radius fillet. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
EndRadius | Input Variant that defines the end radius of the variable radius fillet. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
See Also

Fillet Feature (Complex) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods > FilletDefinition.AddVariableRadiusEdgeSet Method


FilletDefinition.EdgeSetItem Method

FilletDefinition.EdgeSetItem Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified FilletRadiusEdgeSet object from the collection. This will return either a FilletConstantRadiusEdgeSet or FilletVariableRadiusEdgeSet object.

Visual Basic
Sub EdgeSetItem(Index As long, Result As [out, retval] FilletRadiusEdgeSet*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return from the definition. If an out of range index is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods > FilletDefinition.EdgeSetItem Method


FilletDefinition.SetbackVertexItem Method

FilletDefinition.SetbackVertexItem Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified FilletSetbackVertex object from the definition.

Visual Basic
Sub SetbackVertexItem(Index As long, Result As [out, retval] FilletSetbackVertex*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return. If an out of range index is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Methods > FilletDefinition.SetbackVertexItem Method


FilletDefinition Properties

FilletDefinition Properties
Summary

The properties of the FilletDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EdgeSetCount | Property that specifies the number of edge sets currently defined in the definition. This property always returns 0 if the FilletType is not kEdgeFillet.
FaceSet | Property that returns the FilletConstantRadiusFaceSet object that defines the inputs used to create a face fillet. This property returns Nothing if the FilletType is not kFaceFillet.
FilletType | Property that returns the type of the fillet. Possible return values are kEdgeFillet, kFaceFillet and kFullRoundFillet.
FullRoundSet | property that returns the FilletFullRoundSet object that defines the inputs used to create a full round fillet. This property returns Nothing if the FilletType is not kFullRoundFillet.
Parent | Property that returns the parent FilletFeature of the definition.
SetbackVertexCount | Property that specifies the number of possible vertex setbacks available for the current set of edges in the definition. This property always returns 0 if the FilletType is not kEdgeFillet.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties


FilletDefinition.Application Property

FilletDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.Application Property


FilletDefinition.EdgeSetCount Property

FilletDefinition.EdgeSetCount Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies the number of edge sets currently defined in the definition. This property always returns 0 if the FilletType is not kEdgeFillet.

Visual Basic
Property EdgeSetCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.EdgeSetCount Property


FilletDefinition.FaceSet Property

FilletDefinition.FaceSet Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the FilletConstantRadiusFaceSet object that defines the inputs used to create a face fillet. This property returns Nothing if the FilletType is not kFaceFillet.

Visual Basic
Property FaceSet() As FilletConstantRadiusFaceSet**
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.FaceSet Property


FilletDefinition.FilletType Property

FilletDefinition.FilletType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the type of the fillet. Possible return values are kEdgeFillet, kFaceFillet and kFullRoundFillet.

Visual Basic
Property FilletType() As FilletTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.FilletType Property


FilletDefinition.FullRoundSet Property

FilletDefinition.FullRoundSet Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

property that returns the FilletFullRoundSet object that defines the inputs used to create a full round fillet. This property returns Nothing if the FilletType is not kFullRoundFillet.

Visual Basic
Property FullRoundSet() As FilletFullRoundSet**
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.FullRoundSet Property


FilletDefinition.Parent Property

FilletDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parent FilletFeature of the definition.

Visual Basic
Property Parent() As FilletFeature**
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.Parent Property


FilletDefinition.SetbackVertexCount Property

FilletDefinition.SetbackVertexCount Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies the number of possible vertex setbacks available for the current set of edges in the definition. This property always returns 0 if the FilletType is not kEdgeFillet.

Visual Basic
Property SetbackVertexCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.SetbackVertexCount Property


FilletDefinition.Type Property

FilletDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletDefinition Interface > FilletDefinition Properties > FilletDefinition.Type Property


FilletFeature Interface

FilletFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The FilletFeature object represents the fillet modeling feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::FilletFeature
        Inventor::FilletFeatureProxy
Visual Basic
Public Interface FilletFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

FilletDefinition.Parent

FilletFeatureProxy.NativeObject

FilletFeatures.Add

FilletFeatures.AddSimple

FilletFeatures.Item

Example 1

"Fillet Feature (All Rounds) Example"

This sample demonstrates rounding all of the edges of a part.

Public Sub CreateAllRoundsFillet()
    ' Create a new Part document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the compdef.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a sketch on the xy work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Draw a rectangle.
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                            ThisApplication.TransientGeometry.CreatePoint2d(-6, -4), _
                            ThisApplication.TransientGeometry.CreatePoint2d(6, 4))

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extrusion.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                            oProfile, 5, kSymmetricExtentDirection, kJoinOperation)

    ' Declare an EdgeCollection object to pass in since it is a required argument,
    ' but since we're going to specify all rounds, we don't need to actually create
    ' the EdgeCollection or add any edges to it.
    Dim oEdges As EdgeCollection

    ' Create the fillet feature specifying to do all rounds.
    Dim oFillet As FilletFeature
    Set oFillet = oCompDef.Features.FilletFeatures.AddSimple(oEdges, 1, , True)
End Sub
Example 2

"Fillet Feature (Complex) Example"

This sample demonstrates creating a complex fillet. The result in this case has several different constant radii fillets and two edges that use variable radius, with one of these having a different radius defined along the edge.

Public Sub CreateFilletComplex()
    ' Create a new Part document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the compdef.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a sketch on the xy work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Draw a rectangle.
    Dim oEnts As SketchEntitiesEnumerator
    Set oEnts = oSketch.SketchLines.AddAsTwoPointRectangle( _
                            ThisApplication.TransientGeometry.CreatePoint2d(-6, -4), _
                            ThisApplication.TransientGeometry.CreatePoint2d(6, 4))

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extrusion.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                            oProfile, 8, kSymmetricExtentDirection, kJoinOperation)

    ' Create an EdgeCollection object to use for inputting the edges for fillets.
    Dim oEdgeCollection As EdgeCollection
    Set oEdgeCollection = ThisApplication.TransientObjects.CreateEdgeCollection

    ' Add all of the edges of the start face to the edge collection.
    Dim oEdge As Edge
    For Each oEdge In oExtrude.StartFaces.Item(1).Edges
        oEdgeCollection.Add oEdge
    Next

    ' Obtain a FilletDefinition object to use in defining the various inputs to create the fillet.
    Dim oFilletDef As FilletDefinition
    Set oFilletDef = oCompDef.Features.FilletFeatures.CreateFilletDefinition

    ' Create the first edge set.
    Call oFilletDef.AddConstantRadiusEdgeSet(oEdgeCollection, 1.5)

    ' Reinitialize the edge collection.
    Set oEdgeCollection = ThisApplication.TransientObjects.CreateEdgeCollection

    ' Add all of the edges of the end face to the edge collection.
    For Each oEdge In oExtrude.EndFaces.Item(1).Edges
        oEdgeCollection.Add oEdge
    Next

    ' Create the first edge set.
    Call oFilletDef.AddConstantRadiusEdgeSet(oEdgeCollection, 1)

    ' Find the edges that go between the start and end faces by checking to
    ' see if they're parallel to the Z axis.
    Dim oZVector As UnitVector
    Set oZVector = ThisApplication.TransientGeometry.CreateUnitVector(0, 0, 1)
    Dim oSideEdges(1 To 4) As Edge
    Dim EdgeCount As Long
    EdgeCount = 0
    For Each oEdge In oCompDef.SurfaceBodies.Item(1).Edges
        ' In this case we know all the edges are linear.
        Dim oLine As LineSegment
        Set oLine = oEdge.Geometry

        If oLine.Direction.IsParallelTo(oZVector) Then
            EdgeCount = EdgeCount + 1
            Set oSideEdges(EdgeCount) = oEdge
        End If
    Next

    ' Add the first two edges to a constant radius edge set.
    Set oEdgeCollection = ThisApplication.TransientObjects.CreateEdgeCollection
    oEdgeCollection.Add oSideEdges(1)
    oEdgeCollection.Add oSideEdges(2)
    Call oFilletDef.AddConstantRadiusEdgeSet(oEdgeCollection, 0.5)

    ' Create a variable radius edge set for the third edge.
    Set oEdgeCollection = ThisApplication.TransientObjects.CreateEdgeCollection
    oEdgeCollection.Add oSideEdges(3)
    Call oFilletDef.AddVariableRadiusEdgeSet(oEdgeCollection, 1, 2)

    ' Create a variable radius edge with a different internal radius for the fourth edge.
    Set oEdgeCollection = ThisApplication.TransientObjects.CreateEdgeCollection
    oEdgeCollection.Add oSideEdges(4)
    Dim oVarRadiusEdgeSet As FilletVariableRadiusEdgeSet
    Set oVarRadiusEdgeSet = oFilletDef.AddVariableRadiusEdgeSet(oEdgeCollection, 0.5, 1.5)
    Call oVarRadiusEdgeSet.AddIntermediateRadius(oSideEdges(4), 3, 0.5)

    Dim oFillet As FilletFeature
    Set oFillet = oCompDef.Features.FilletFeatures.Add(oFilletDef, False)
End Sub
Example 3

"Fillet Feature (Simple) Example "

This sample demonstrates using the AddSimple method of the FilletFeatures collection to create a constant radius fillet.

Public Sub CreateSimpleFillet()
    ' Create a new Part document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the compdef.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a sketch on the xy work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Draw a rectangle.
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                            ThisApplication.TransientGeometry.CreatePoint2d(-6, -4), _
                            ThisApplication.TransientGeometry.CreatePoint2d(6, 4))

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extrusion.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                            oProfile, 5, kSymmetricExtentDirection, kJoinOperation)

    ' Define the set of edges that are for the start and end faces of the solid.
    Dim oEdges As EdgeCollection
    Set oEdges = ThisApplication.TransientObjects.CreateEdgeCollection

    Dim oEdge As Edge
    For Each oEdge In oExtrude.StartFaces.Item(1).Edges
        oEdges.Add oEdge
    Next

    For Each oEdge In oExtrude.EndFaces.Item(1).Edges
        oEdges.Add oEdge
    Next

    ' Create the fillet feature.
    Dim oFillet As FilletFeature
    Set oFillet = oCompDef.Features.FilletFeatures.AddSimple(oEdges, 1)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface


FilletFeature Properties

FilletFeature Properties
Summary

The properties of the FilletFeature class are listed here.

Properties
Name | Description
AutomaticEdgeChain | Property that returns whether or not to use all tangentially connected edges. A value of True indicates that automatic edge chaining of tangentially connected edges should be performed.
FilletDefinition | Property that returns the object which defines the various input that was used to create the fillet feature.
PreserveAllFeatures | Property that specifies whether all other features that intersect with the feature are checked and their intersections calculated during this feature operation. If False, only the objects that are part of this feature operation are calculated.
RollAlongSharpEdges | Property that specifies the solution method for fillets when the specified radius would cause adjacent faces to be extended. When True, the radius will be varied when necessary to preserve the edges of adjacent faces. When False, a constant radius will be maintained and adjacent faces extended as needed.
RollingBallWherePossible | Property that specifies the corner style for the fillet. When True, the fillet will be defined as if a ball had been rolled along the edge and around the corners. When False, a continuous tangent transition between fillets in sharp corners is created.
SmoothRadiusTransition | Property that applies only to variable radius fillets and specifies whether the transition between different radii is to be smooth. For a smooth transition there is a gradual blending transition between the defined radius points and the transitions are tangent. Without a smooth transition, a linear transition is used between radius points.
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties


FilletFeature.AutomaticEdgeChain Property

FilletFeature.AutomaticEdgeChain Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns whether or not to use all tangentially connected edges. A value of True indicates that automatic edge chaining of tangentially connected edges should be performed.

Visual Basic
Property AutomaticEdgeChain() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties > FilletFeature.AutomaticEdgeChain Property


FilletFeature.FilletDefinition Property

FilletFeature.FilletDefinition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the object which defines the various input that was used to create the fillet feature.

Visual Basic
Property FilletDefinition() As FilletDefinition**
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties > FilletFeature.FilletDefinition Property


FilletFeature.PreserveAllFeatures Property

FilletFeature.PreserveAllFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies whether all other features that intersect with the feature are checked and their intersections calculated during this feature operation. If False, only the objects that are part of this feature operation are calculated.

Visual Basic
Property PreserveAllFeatures() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties > FilletFeature.PreserveAllFeatures Property


FilletFeature.RollAlongSharpEdges Property

FilletFeature.RollAlongSharpEdges Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies the solution method for fillets when the specified radius would cause adjacent faces to be extended. When True, the radius will be varied when necessary to preserve the edges of adjacent faces. When False, a constant radius will be maintained and adjacent faces extended as needed.

Visual Basic
Property RollAlongSharpEdges() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties > FilletFeature.RollAlongSharpEdges Property


FilletFeature.RollingBallWherePossible Property

FilletFeature.RollingBallWherePossible Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies the corner style for the fillet. When True, the fillet will be defined as if a ball had been rolled along the edge and around the corners. When False, a continuous tangent transition between fillets in sharp corners is created.

Visual Basic
Property RollingBallWherePossible() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties > FilletFeature.RollingBallWherePossible Property


FilletFeature.SmoothRadiusTransition Property

FilletFeature.SmoothRadiusTransition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that applies only to variable radius fillets and specifies whether the transition between different radii is to be smooth. For a smooth transition there is a gradual blending transition between the defined radius points and the transitions are tangent. Without a smooth transition, a linear transition is used between radius points.

Visual Basic
Property SmoothRadiusTransition() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeature Interface > FilletFeature Properties > FilletFeature.SmoothRadiusTransition Property


FilletFeatureProxy Interface

FilletFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FilletFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::FilletFeature
        Inventor::FilletFeatureProxy
Visual Basic
Public Interface FilletFeatureProxy
Inherits FilletFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatureProxy Interface


FilletFeatureProxy Properties

FilletFeatureProxy Properties
Summary

The properties of the FilletFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatureProxy Interface > FilletFeatureProxy Properties


FilletFeatureProxy.ContainingOccurrence Property

FilletFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatureProxy Interface > FilletFeatureProxy Properties > FilletFeatureProxy.ContainingOccurrence Property


FilletFeatureProxy.NativeObject Property

FilletFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FilletFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatureProxy Interface > FilletFeatureProxy Properties > FilletFeatureProxy.NativeObject Property


FilletFeatures Interface

FilletFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The FilletFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional FilletFeature objects.

Class Hierarchy
Inventor::FilletFeatures
Visual Basic
Public Interface FilletFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.FilletFeatures

FlatPatternFeatures.FilletFeatures

PartFeatures.FilletFeatures

See Also

Fillet Feature (Complex) sample

Example

See FilletFeature for example "Creating simple, complex and all-round fillet features"

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface


FilletFeatures Methods

FilletFeatures Methods
Summary

The methods of the FilletFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new FilletFeature. This method may be used to create fillet features of constant radius, variable radius or a combination of constant and variable radius. Setbacks may also be specified. The new FilletFeature is returned.
AddSimple | Method that creates a new constant radius fillet where all fillets have the same radius. For more complex fillet features, the Add method of the FilletFeatures collection can be used.
CreateFilletDefinition | Method that creates a new FilletDefinition object. The object returned by this method is used to define the inputs for a fillet feature and is provided as the argument to the Add method of the FilletFeatures collection.
Item | Property that returns the specified FilletFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Methods


FilletFeatures.Add Method

FilletFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new FilletFeature. This method may be used to create fillet features of constant radius, variable radius or a combination of constant and variable radius. Setbacks may also be specified. The new FilletFeature is returned.

Visual Basic
Sub Add(FilletDefinition As FilletDefinition, ByRef AutomaticEdgeChain As [defaultvalue(-1)] VARIANT_BOOL, ByRef SmoothRadiusTransition As [defaultvalue(-1)] VARIANT_BOOL, ByRef RollAlongSharpEdges As [defaultvalue(0)] VARIANT_BOOL, ByRef RollingBallWherePossible As [defaultvalue(-1)] VARIANT_BOOL, ByRef PreserveAllFeatures As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] FilletFeature*)
Parameters
Parameters | Description
FilletDefinition | Input object that defines the input definition for the fillet feature. The object defines the edges, radii, and setbacks.
AutomaticEdgeChain | Optional input Boolean that defines if automatic edge chaining along tangentially connected edges should be performed. The default is True.
SmoothRadiusTransition | Optional input Boolean that applies only to variable radius fillets and defines whether the transition between different radii is to be smooth. For a smooth transition there is a gradual blending transition between the defined radius points and the transitions are tangent. Without a smooth transition, a linear transition is used between radius points. The default is True for a smooth transition.
RollAlongSharpEdges | Optional input Boolean that sets the solution method for fillets when the specified radius would cause adjacent faces to be extended. When True, the radius will be varied when necessary to preserve the edges of adjacent faces. When False, a constant radius will be maintained and adjacent faces extended as needed. The default is False.
RollingBallWherePossible | Optional input Boolean that sets the corner style for the fillet. When True, the fillet will be defined as if a ball had been rolled along the edge and around the corners. When False, a continuous tangent transition between fillets in sharp corners is created. The default is True.
PreserveAllFeatures | Optional input Boolean that specifies if all features that intersect with the fillet are checked and their intersections calculated during the fillet operation. If False, only the edges that are part of the fillet operation are calculated during the operation. The default is False.
See Also

Fillet Feature (Complex) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Methods > FilletFeatures.Add Method


FilletFeatures.AddSimple Method

FilletFeatures.AddSimple Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new constant radius fillet where all fillets have the same radius. For more complex fillet features, the Add method of the FilletFeatures collection can be used.

Visual Basic
Sub AddSimple(Edges As EdgeCollection, Radius As VARIANT, ByRef AllFillets As [defaultvalue(0)] VARIANT_BOOL, ByRef AllRounds As [defaultvalue(0)] VARIANT_BOOL, ByRef AutomaticEdgeChain As [defaultvalue(-1)] VARIANT_BOOL, ByRef RollAlongSharpEdges As [defaultvalue(0)] VARIANT_BOOL, ByRef RollingBallWherePossible As [defaultvalue(-1)] VARIANT_BOOL, ByRef PreserveAllFeatures As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] FilletFeature*)
Parameters
Parameters | Description
Edges | Input object that contains the edges to be filleted.
Radius | Input Variant that defines the radius of the fillet. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
AllFillets | Optional input Boolean that specifies if all concave edges of the body are to be considered part of this edge set. True indicates all concave edges will be filleted. The default is False.
AllRounds | Optional input Boolean that specifies if all convex edges of the body are to be considered part of this edge set. True indicates all convex edges will be filleted. The default is False.
AutomaticEdgeChain | Optional input Boolean that defines if automatic edge chaining along tangentially connected edges should be performed. The default is True.
RollAlongSharpEdges | Optional input Boolean that sets the solution method for fillets when the specified radius would cause adjacent faces to be extended. When True, the radius will be varied when necessary to preserve the edges of adjacent faces. When False, a constant radius will be maintained and adjacent faces extended as needed. The default is False.
RollingBallWherePossible | Optional input Boolean that sets the corner style for the fillet. When True, the fillet will be defined as if a ball had been rolled along the edge and around the corners. When False, a continuous tangent transition between fillets in sharp corners is created. The default is True.
PreserveAllFeatures | Optional input Boolean that specifies if all features that intersect with the fillet are checked and their intersections calculated during the fillet operation. If False, only the edges that are part of the fillet operation are calculated during the operation. The default is False.
See Also

Fillet Feature (All Rounds) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Methods > FilletFeatures.AddSimple Method


FilletFeatures.CreateFilletDefinition Method

FilletFeatures.CreateFilletDefinition Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new FilletDefinition object. The object returned by this method is used to define the inputs for a fillet feature and is provided as the argument to the Add method of the FilletFeatures collection.

Visual Basic
Sub CreateFilletDefinition(Result As [out, retval] FilletDefinition*)
See Also

Fillet Feature (Complex) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Methods > FilletFeatures.CreateFilletDefinition Method


FilletFeatures.Item Method

FilletFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified FilletFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FilletFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Methods > FilletFeatures.Item Method


FilletFeatures Properties

FilletFeatures Properties
Summary

The properties of the FilletFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Properties


FilletFeatures.Application Property

FilletFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Properties > FilletFeatures.Application Property


FilletFeatures.Count Property

FilletFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Properties > FilletFeatures.Count Property


FilletFeatures.Type Property

FilletFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletFeatures Interface > FilletFeatures Properties > FilletFeatures.Type Property


FilletFullRoundSet Interface

FilletFullRoundSet Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The FilletFullRoundSet object provides access to the inputs used to create a full round fillet feature.

Class Hierarchy
Inventor::FilletFullRoundSet
Visual Basic
Public Interface FilletFullRoundSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletDefinition.FullRoundSet

FilletDefinition.AddFullRoundSet

You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface


FilletFullRoundSet Properties

FilletFullRoundSet Properties
Summary

The properties of the FilletFullRoundSet class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. Where the property is weakly-typed, it can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServer' when running with the Apprentice Server.
CenterFaces | Property that returns the center faces for the full round fillet feature.
IncludeTangentFaces | Property that returns whether to include faces that are tangential to the faces specified in the SideFacesOne, CenterFaces and SideFacesTwo properties for the fillet creation.
SideFacesOne | Property that returns the first set of side faces for the full round fillet feature.
SideFacesTwo | Property that returns the second set of side faces for the full round fillet feature.
Type | Property returning kFilletFullRoundSetObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties


FilletFullRoundSet.Application Property

FilletFullRoundSet.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. Where the property is weakly-typed, it can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServer' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties > FilletFullRoundSet.Application Property


FilletFullRoundSet.CenterFaces Property

FilletFullRoundSet.CenterFaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the center faces for the full round fillet feature.

Visual Basic
Property CenterFaces() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties > FilletFullRoundSet.CenterFaces Property


FilletFullRoundSet.IncludeTangentFaces Property

FilletFullRoundSet.IncludeTangentFaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether to include faces that are tangential to the faces specified in the SideFacesOne, CenterFaces and SideFacesTwo properties for the fillet creation.

Visual Basic
Property IncludeTangentFaces() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties > FilletFullRoundSet.IncludeTangentFaces Property


FilletFullRoundSet.SideFacesOne Property

FilletFullRoundSet.SideFacesOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the first set of side faces for the full round fillet feature.

Visual Basic
Property SideFacesOne() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties > FilletFullRoundSet.SideFacesOne Property


FilletFullRoundSet.SideFacesTwo Property

FilletFullRoundSet.SideFacesTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the second set of side faces for the full round fillet feature.

Visual Basic
Property SideFacesTwo() As FaceCollection**
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties > FilletFullRoundSet.SideFacesTwo Property


FilletFullRoundSet.Type Property

FilletFullRoundSet.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kFilletFullRoundSetObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletFullRoundSet Interface > FilletFullRoundSet Properties > FilletFullRoundSet.Type Property


FilletIntermediateRadius Interface

FilletIntermediateRadius Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FilletIntermediateRadius object represents the information needed to define the radius at a point along an edge for a variable radius fillet.

Class Hierarchy
Inventor::FilletIntermediateRadius
Visual Basic
Public Interface FilletIntermediateRadius
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletVariableRadiusEdgeSet.AddIntermediateRadius

FilletVariableRadiusEdgeSet.IntermediateRadiusItem

Example

See FilletFeature for example "Creating simple, complex and all-round fillet features"

You are here: Symbol Reference > Inventor Library > Objects > FilletIntermediateRadius Interface


FilletIntermediateRadius Properties

FilletIntermediateRadius Properties
Summary

The properties of the FilletIntermediateRadius class are listed here.

Properties
Name | Description
Edge | Property that returns the associated with the PercentLength value. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.
PercentLength | Property that returns the parameter that controls the position of the point along the edge. The value defines it's position as a percentage of the entire length. This property will return Nothing if the fillet feature has not been created yet.
Radius | Property that returns the parameter that controls the radius of the fillet at the defined point. This property will return Nothing if the fillet feature has not been created yet.
You are here: Symbol Reference > Inventor Library > Objects > FilletIntermediateRadius Interface > FilletIntermediateRadius Properties


FilletIntermediateRadius.Edge Property

FilletIntermediateRadius.Edge Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the associated with the PercentLength value. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > FilletIntermediateRadius Interface > FilletIntermediateRadius Properties > FilletIntermediateRadius.Edge Property


FilletIntermediateRadius.PercentLength Property

FilletIntermediateRadius.PercentLength Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the position of the point along the edge. The value defines it's position as a percentage of the entire length. This property will return Nothing if the fillet feature has not been created yet.

Visual Basic
Property PercentLength() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FilletIntermediateRadius Interface > FilletIntermediateRadius Properties > FilletIntermediateRadius.PercentLength Property


FilletIntermediateRadius.Radius Property

FilletIntermediateRadius.Radius Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the radius of the fillet at the defined point. This property will return Nothing if the fillet feature has not been created yet.

Visual Basic
Property Radius() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FilletIntermediateRadius Interface > FilletIntermediateRadius Properties > FilletIntermediateRadius.Radius Property


FilletRadiusEdgeSet Interface

FilletRadiusEdgeSet Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FilletRadiusEdgeSet object is the base class for FilletConstantRadiusEdgeSet and FilletVariableRadiusEdgeSet objects.

Class Hierarchy
Inventor::FilletRadiusEdgeSet
    Inventor::FilletConstantRadiusEdgeSet
    Inventor::FilletVariableRadiusEdgeSet
Visual Basic
Public Interface FilletRadiusEdgeSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletDefinition.EdgeSetItem

Example

See FilletFeature for example "Creating simple, complex and all-round fillet features"

You are here: Symbol Reference > Inventor Library > Objects > FilletRadiusEdgeSet Interface


FilletRadiusEdgeSet Properties

FilletRadiusEdgeSet Properties
Summary

The properties of the FilletRadiusEdgeSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Edges | Property that provides access to the in the edge set. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FilletRadiusEdgeSet Interface > FilletRadiusEdgeSet Properties


FilletRadiusEdgeSet.Application Property

FilletRadiusEdgeSet.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FilletRadiusEdgeSet Interface > FilletRadiusEdgeSet Properties > FilletRadiusEdgeSet.Application Property


FilletRadiusEdgeSet.Edges Property

FilletRadiusEdgeSet.Edges Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that provides access to the in the edge set. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.

Visual Basic
Property Edges() As EdgeCollection**
You are here: Symbol Reference > Inventor Library > Objects > FilletRadiusEdgeSet Interface > FilletRadiusEdgeSet Properties > FilletRadiusEdgeSet.Edges Property


FilletRadiusEdgeSet.Type Property

FilletRadiusEdgeSet.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletRadiusEdgeSet Interface > FilletRadiusEdgeSet Properties > FilletRadiusEdgeSet.Type Property


FilletSetback Interface

FilletSetback Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FilletSetback object provides access to an edge and its setback value.

Class Hierarchy
Inventor::FilletSetback
Visual Basic
Public Interface FilletSetback
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletSetbackVertex.SetbackItem

Example

See FilletFeature for example "Creating simple, complex and all-round fillet features"

You are here: Symbol Reference > Inventor Library > Objects > FilletSetback Interface


FilletSetback Properties

FilletSetback Properties
Summary

The properties of the FilletSetback class are listed here.

Properties
Name | Description
Edge | Property that returns the associated with this setback. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.
Setback | Property that gets and sets the setback associated with the edge. This property behaves differently in different circumstances.
You are here: Symbol Reference > Inventor Library > Objects > FilletSetback Interface > FilletSetback Properties


FilletSetback.Edge Property

FilletSetback.Edge Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the associated with this setback. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > FilletSetback Interface > FilletSetback Properties > FilletSetback.Edge Property


FilletSetback.Setback Property

FilletSetback.Setback Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the setback associated with the edge. This property behaves differently in different circumstances.

Visual Basic
Property Setback() As VARIANT
Remarks

In the case where the FilletSetback object is being used to define a FilletDefinition object to create a new fillet, it behaves as a read-write property. It can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.

Also, in the case where the FilletSetback object is being used to define a FilletDefinition object, if the MinimalSetback property of the parent FilletSetbackVertex object is True, then the setback value will not be used during creation of the fillet feature. The specified setback value will be used only if the MinimalSetback property is False.

In the case where the FilletSetback object is obtained from an existing FilletFeature object, this property is read-only and returns the Parameter object that controls the setback. Edits to the setback value can be made by editing the value of the associated Parameter object.

Also, in the case where the FilletSetback object is obtained from an existing FilletFeature object, if the MinimalSetback property of the parent FilletSetbackVertex object is True, then it implies that the setback value is not currently used and the associated Parameter object will return a value of 0. But, if a setback value is explicitly set using this property, then it will be used and the MinimalSetback property will be automatically set to False.

You are here: Symbol Reference > Inventor Library > Objects > FilletSetback Interface > FilletSetback Properties > FilletSetback.Setback Property


FilletSetbackVertex Interface

FilletSetbackVertex Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FilletSetbackVertex object provides access to a vertex that is valid to define fillet setbacks for. It also provides access to the edges connected to the vertex and each edge's associated setback value.

Class Hierarchy
Inventor::FilletSetbackVertex
Visual Basic
Public Interface FilletSetbackVertex
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FilletDefinition.SetbackVertexItem

Example

See FilletFeature for example "Creating simple, complex and all-round fillet features"

You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface


FilletSetbackVertex Methods

FilletSetbackVertex Methods
Summary

The methods of the FilletSetbackVertex class are listed here.

Methods
Methods
Name | Description
SetbackItem | Method that returns the specified FilletSetback object from this vertex.
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Methods


FilletSetbackVertex.SetbackItem Method

FilletSetbackVertex.SetbackItem Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified FilletSetback object from this vertex.

Visual Basic
Sub SetbackItem(Index As long, Result As [out, retval] FilletSetback*)
Parameters
Parameters | Description
index | Input Long value that specifies index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Methods > FilletSetbackVertex.SetbackItem Method


FilletSetbackVertex Properties

FilletSetbackVertex Properties
Summary

The properties of the FilletSetbackVertex class are listed here.

Properties
Name | Description
MinimalSetback | Property that gets and sets whether the minimum allowable setback should be used for this vertex. By default, this value is False, which indicates that the minimal setback should not be used. The values specified by the FilletSetback objects will be used for the setbacks. If it is set to True, then minimal setback will be used. The setback values specified by the FilletSetback objects will be ignored.
SetbackCount | Property that returns the number of edges connected to the vertex. Each edge is represented by a FilletSetback object which can be obtained using the Setback property.
Type | Property returning an enum indicating this object's type.
UseSetbacks | Property that gets and sets whether the setback values are to be used for this vertex. By default, this value is False, which indicates setback values should not be used. It is automatically set to True if any of the setback values of the FilletSetback object are modified or if the MinimalSetback property is set to True.
Vertex | Property that gets the vertex shared by the edges. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Properties


FilletSetbackVertex.MinimalSetback Property

FilletSetbackVertex.MinimalSetback Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the minimum allowable setback should be used for this vertex. By default, this value is False, which indicates that the minimal setback should not be used. The values specified by the FilletSetback objects will be used for the setbacks. If it is set to True, then minimal setback will be used. The setback values specified by the FilletSetback objects will be ignored.

Visual Basic
Property MinimalSetback() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Properties > FilletSetbackVertex.MinimalSetback Property


FilletSetbackVertex.SetbackCount Property

FilletSetbackVertex.SetbackCount Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of edges connected to the vertex. Each edge is represented by a FilletSetback object which can be obtained using the Setback property.

Visual Basic
Property SetbackCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Properties > FilletSetbackVertex.SetbackCount Property


FilletSetbackVertex.Type Property

FilletSetbackVertex.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Properties > FilletSetbackVertex.Type Property


FilletSetbackVertex.UseSetbacks Property

FilletSetbackVertex.UseSetbacks Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the setback values are to be used for this vertex. By default, this value is False, which indicates setback values should not be used. It is automatically set to True if any of the setback values of the FilletSetback object are modified or if the MinimalSetback property is set to True.

Visual Basic
Property UseSetbacks() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Properties > FilletSetbackVertex.UseSetbacks Property


FilletSetbackVertex.Vertex Property

FilletSetbackVertex.Vertex Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the vertex shared by the edges. This property is only available when a FilletDefinition object is being defined to use as input for creating a fillet. When the parent FilletDefinition object is obtained from an existing Fillet, the end-of-part marker should be placed above this fillet feature to allow access this property.

Visual Basic
Property Vertex() As Vertex**
You are here: Symbol Reference > Inventor Library > Objects > FilletSetbackVertex Interface > FilletSetbackVertex Properties > FilletSetbackVertex.Vertex Property


FilletVariableRadiusEdgeSet Interface

FilletVariableRadiusEdgeSet Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FilletVariableRadiusEdgeSet object provides methods to specify the radius for variable radius fillet features.

Class Hierarchy
Inventor::FilletRadiusEdgeSet
    Inventor::FilletVariableRadiusEdgeSet
Visual Basic
Public Interface FilletVariableRadiusEdgeSet
Inherits FilletRadiusEdgeSet
Notes

Members through which this object may be accessed include:

FilletDefinition.AddVariableRadiusEdgeSet

See Also

Fillet Feature (Complex) sample

Example

See FilletFeature for example "Creating simple, complex and all-round fillet features"

You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface


FilletVariableRadiusEdgeSet Methods

FilletVariableRadiusEdgeSet Methods
Summary

The methods of the FilletVariableRadiusEdgeSet class are listed here.

Methods
Methods
Name | Description
AddIntermediateRadius | Method that creates a new FilletIntermediateRadius. The new FilletIntermediateRadius is returned. This method is used to define radii at intermediate points along an edge.
IntermediateRadiusItem | Property that returns the specified FilletIntermediateRadius object.
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Methods


FilletVariableRadiusEdgeSet.AddIntermediateRadius Method

FilletVariableRadiusEdgeSet.AddIntermediateRadius Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new FilletIntermediateRadius. The new FilletIntermediateRadius is returned. This method is used to define radii at intermediate points along an edge.

Visual Basic
Sub AddIntermediateRadius(Edge As Edge, Radius As VARIANT, PercentLength As VARIANT, Result As [out, retval] FilletIntermediateRadius*)
Parameters
Parameters | Description
Edge | Input object that the intermediate radius lies on.
Radius | Input Variant that defines the radius at the specified point. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
PercentLength | Input Variant that defines the position of the point along the edge as a percentage of the length of the edge. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. The units for input value need to be unitless and the value should be between 0 and 1.
See Also

Fillet Feature (Complex) sample

You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Methods > FilletVariableRadiusEdgeSet.AddIntermediateRadius Method


FilletVariableRadiusEdgeSet.IntermediateRadiusItem Method

FilletVariableRadiusEdgeSet.IntermediateRadiusItem Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified FilletIntermediateRadius object.

Visual Basic
Sub IntermediateRadiusItem(Index As long, Result As [out, retval] FilletIntermediateRadius*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Methods > FilletVariableRadiusEdgeSet.IntermediateRadiusItem Method


FilletVariableRadiusEdgeSet Properties

FilletVariableRadiusEdgeSet Properties
Summary

The properties of the FilletVariableRadiusEdgeSet class are listed here.

Properties
Name | Description
ContinuityType | This is ContinuityType, a member of class FilletVariableRadiusEdgeSet.
EndRadius | Property that returns the parameter that controls the end radius of the fillet.
IntermediateRadiusCount | Property that returns the number of intermediate points defined in the edge set.
StartRadius | Property that returns the parameter that controls the start radius of the fillet.
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Properties


FilletVariableRadiusEdgeSet.ContinuityType Property

FilletVariableRadiusEdgeSet.ContinuityType Property
Summary

This is ContinuityType, a member of class FilletVariableRadiusEdgeSet.

Visual Basic
Property ContinuityType() As ContinuityTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Properties > FilletVariableRadiusEdgeSet.ContinuityType Property


FilletVariableRadiusEdgeSet.EndRadius Property

FilletVariableRadiusEdgeSet.EndRadius Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the end radius of the fillet.

Visual Basic
Property EndRadius() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Properties > FilletVariableRadiusEdgeSet.EndRadius Property


FilletVariableRadiusEdgeSet.IntermediateRadiusCount Property

FilletVariableRadiusEdgeSet.IntermediateRadiusCount Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of intermediate points defined in the edge set.

Visual Basic
Property IntermediateRadiusCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Properties > FilletVariableRadiusEdgeSet.IntermediateRadiusCount Property


FilletVariableRadiusEdgeSet.StartRadius Property

FilletVariableRadiusEdgeSet.StartRadius Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the start radius of the fillet.

Visual Basic
Property StartRadius() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FilletVariableRadiusEdgeSet Interface > FilletVariableRadiusEdgeSet Properties > FilletVariableRadiusEdgeSet.StartRadius Property


FixedWorkAxisDef Interface

FixedWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a fixed work axis.

Class Hierarchy
Inventor::FixedWorkAxisDef
Visual Basic
Public Interface FixedWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface


FixedWorkAxisDef Methods

FixedWorkAxisDef Methods
Summary

The methods of the FixedWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a fixed work axis.
PutData | Method that sets the data defining a fixed work axis.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Methods


FixedWorkAxisDef.GetData Method

FixedWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a fixed work axis.

Visual Basic
Sub GetData(ByRef OriginPoint As Point*, ByRef Axis As UnitVector*)
Parameters
Parameters | Description
OriginPoint | Output object that defines the origin of the work axis.
Axis | Output object that defines the X-axis vector of the work axis.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Methods > FixedWorkAxisDef.GetData Method


FixedWorkAxisDef.PutData Method

FixedWorkAxisDef.PutData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining a fixed work axis.

Visual Basic
Sub PutData(OriginPoint As Point, Axis As UnitVector)
Parameters
Parameters | Description
OriginPoint | Input object that defines the origin of the work axis.
Axis | Input object that defines the X-axis vector of the work axis.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Methods > FixedWorkAxisDef.PutData Method


FixedWorkAxisDef Properties

FixedWorkAxisDef Properties
Summary

The properties of the FixedWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Axis | Property that returns the X-axis vector of the work plane.
OriginPoint | Property that indicates the origin point of the work axis.
Parent | Property returning the parent WorkAxis object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Properties


FixedWorkAxisDef.Application Property

FixedWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Properties > FixedWorkAxisDef.Application Property


FixedWorkAxisDef.Axis Property

FixedWorkAxisDef.Axis Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the X-axis vector of the work plane.

Visual Basic
Property Axis() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Properties > FixedWorkAxisDef.Axis Property


FixedWorkAxisDef.OriginPoint Property

FixedWorkAxisDef.OriginPoint Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the origin point of the work axis.

Visual Basic
Property OriginPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Properties > FixedWorkAxisDef.OriginPoint Property


FixedWorkAxisDef.Parent Property

FixedWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Properties > FixedWorkAxisDef.Parent Property


FixedWorkAxisDef.Type Property

FixedWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkAxisDef Interface > FixedWorkAxisDef Properties > FixedWorkAxisDef.Type Property


FixedWorkPlaneDef Interface

FixedWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a fixed work plane.

Class Hierarchy
Inventor::FixedWorkPlaneDef
Visual Basic
Public Interface FixedWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface


FixedWorkPlaneDef Methods

FixedWorkPlaneDef Methods
Summary

The methods of the FixedWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a fixed work plane.
PutData | Method that redefines the origin point, x, and y axes of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Methods


FixedWorkPlaneDef.GetData Method

FixedWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a fixed work plane.

Visual Basic
Sub GetData(ByRef OriginPoint As Point*, ByRef XAxis As UnitVector*, ByRef YAxis As UnitVector*)
Parameters
Parameters | Description
OriginPoint | Output object that defines the origin of the work plane.
XAxis | Output object that defines the X-axis vector of the work plane.
YAxis | Output object that defines the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Methods > FixedWorkPlaneDef.GetData Method


FixedWorkPlaneDef.PutData Method

FixedWorkPlaneDef.PutData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the origin point, x, and y axes of the work plane.

Visual Basic
Sub PutData(OriginPoint As Point, XAxis As UnitVector, YAxis As UnitVector)
Parameters
Parameters | Description
OriginPoint | Input object that defines the origin of the work plane.
XAxis | Input object that defines the X-axis vector of the work plane.
YAxis | Input object that defines the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Methods > FixedWorkPlaneDef.PutData Method


FixedWorkPlaneDef Properties

FixedWorkPlaneDef Properties
Summary

The properties of the FixedWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
OriginPoint | Property that returns the origin point of the work plane.
Parent | Property that returns the parent WorkPlane object.
Type | Property returning an enum indicating this object's type.
XAxis | Property that returns the X-axis vector of the work plane.
YAxis | Property that returns the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties


FixedWorkPlaneDef.Application Property

FixedWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties > FixedWorkPlaneDef.Application Property


FixedWorkPlaneDef.OriginPoint Property

FixedWorkPlaneDef.OriginPoint Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the origin point of the work plane.

Visual Basic
Property OriginPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties > FixedWorkPlaneDef.OriginPoint Property


FixedWorkPlaneDef.Parent Property

FixedWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties > FixedWorkPlaneDef.Parent Property


FixedWorkPlaneDef.Type Property

FixedWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties > FixedWorkPlaneDef.Type Property


FixedWorkPlaneDef.XAxis Property

FixedWorkPlaneDef.XAxis Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the X-axis vector of the work plane.

Visual Basic
Property XAxis() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties > FixedWorkPlaneDef.XAxis Property


FixedWorkPlaneDef.YAxis Property

FixedWorkPlaneDef.YAxis Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Y-axis vector of the work plane.

Visual Basic
Property YAxis() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPlaneDef Interface > FixedWorkPlaneDef Properties > FixedWorkPlaneDef.YAxis Property


FixedWorkPointDef Interface

FixedWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a fixed work point.

Class Hierarchy
Inventor::FixedWorkPointDef
Visual Basic
Public Interface FixedWorkPointDef
Inherits IDispatch
See Also

OnDrag Event - dragging a WorkPoint sample

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPointDef Interface


FixedWorkPointDef Properties

FixedWorkPointDef Properties
Summary

The properties of the FixedWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property returning the parent WorkPoint object.
Point | Property that gets and set the origin point of the work point.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPointDef Interface > FixedWorkPointDef Properties


FixedWorkPointDef.Application Property

FixedWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPointDef Interface > FixedWorkPointDef Properties > FixedWorkPointDef.Application Property


FixedWorkPointDef.Parent Property

FixedWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPointDef Interface > FixedWorkPointDef Properties > FixedWorkPointDef.Parent Property


FixedWorkPointDef.Point Property

FixedWorkPointDef.Point Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and set the origin point of the work point.

Visual Basic
Property Point() As Point*
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPointDef Interface > FixedWorkPointDef Properties > FixedWorkPointDef.Point Property


FixedWorkPointDef.Type Property

FixedWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FixedWorkPointDef Interface > FixedWorkPointDef Properties > FixedWorkPointDef.Type Property


FlangeDefinition Interface

FlangeDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FlangeDefinition object represents the information that defines a flange feature, not a flange feature.

Class Hierarchy
Inventor::FlangeDefinition
Visual Basic
Public Interface FlangeDefinition
Inherits IDispatch
Remarks

This object used when creating new flange features and also for querying and editing existing flange features.

Notes

Members through which this object may be accessed include:

FlangeDefinition.Copy

FlangeFeature.Definition

FlangeFeatures.CreateFlangeDefinition

See Also

Create sheet metal face and flange features sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface


FlangeDefinition Methods

FlangeDefinition Methods
Summary

The methods of the FlangeDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this FlangeDefinition object. The new FlangeDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new flange feature.
GetWidthExtent | Property that returns the PartFeatureExtent object that defines how the width extent of the flange feature is defined.
GetWidthExtentType | Property that returns the method used to define the width extent.
RemoveOverrideWidthExtent | Method that removes the override width extent for the specified physical flange.
SetCenteredDefaultWidthExtent | Method that sets the default width extent to define a flange that"s centered along the edge and has a defined width.
SetCenteredWidthExtent | Method that overrides the width extent of the specified physical flange to define a flange that"s centered along the edge and has a defined width.
SetDistanceHeightExtent | Method that changes the FlangeDefinition object to define a flange whose height is measured by a distance.
SetEdgeDefaultWidthExtent | Method that sets the default width extent to define a flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the flanges.
SetEdgeWidthExtent | Method that changes the FlangeDefinition object to define a flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the flanges.
SetFromToDefaultWidthExtent | Method that sets the default width extent to define a flange whose width is defined as being between two entities.
SetFromToWidthExtent | Method that overrides the width extent of the specified physical flange to define a flange whose width is defined as being between two entities.
SetLegacyDistanceHeightExtent | Method that changes the FlangeDefinition object to define a flange whose height is measured by a distance. The way the distance is computed for this type of height extent was used in earlier versions of Inventor and is supported in the current versions to support backward compatibility with older models.
SetOffsetDefaultWidthExtent | Method that sets the default width extent to define a flange whose width is defined with respect to two entities.
SetOffsetWidthExtent | Method that overrides the width extent of the specified physical flange to define a flange whose width is defined with respect to two entities.
SetToHeightExtent | Method that changes the FlangeDefinition object to define a flange whose height is defined by extending to the specified entity.
SetWidthOffsetDefaultWidthExtent | Method that sets the default width extent for the flange feature to define a flange whose width is defined relative to another entity.
SetWidthOffsetWidthExtent | Method that overrides the width extent of the specified physical flange to define a flange whose width is defined relative to another entity.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods


FlangeDefinition.Copy Method

FlangeDefinition.Copy Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a copy of this FlangeDefinition object. The new FlangeDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new flange feature.

Visual Basic
Sub Copy(Result As [out, retval] FlangeDefinition*)
Remarks

Any of the properties of the FlangeDefinition that can reference a Parameter object will behave differently depending on if the FlangeDefinition is independent or associated with a feature. When it is associated with a feature these properties behave as read-only and will return the related Parameter object. When it is not associated with a feature these properties behave as read-write and will accept and return doubles and strings to define the value.

One typical use of this method is when you need to make several changes to an existing flange feature. If you edit the FlangeDefinition object associated with the flange feature, the feature will recompute after each edit. It's more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The FlangeFeatures.CreateFlangeDefinition method can also be used to create an independent FlangeDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateFlangeDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.Copy Method


FlangeDefinition.GetWidthExtent Method

FlangeDefinition.GetWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the PartFeatureExtent object that defines how the width extent of the flange feature is defined.

Visual Basic
Sub GetWidthExtent(Edge As Edge, Result As [out, retval] PartFeatureExtent*)
Parameters
Parameters | Description
Edge | The Edge object that identifies the physical flange to return the width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to return the width extent for.
Remarks

The type of extent object that this property will return can be determined by using the WidthExtentType property. Types that can be returned are EdgeWidthExtent, WidthWidthExtent, OffsetWidthExtent, and FromToWidthExtent. The extent can be defined by default width extent of the feature or an override for this particular physical flange. You can determine if it is an override or not by using the GetWidthExtentType property.

When the FlangeDefinition object is transient, (created using the FlangeFeatures. CreateFlangeDefinition method or the Copy method of an existing FlangeDefinition object), this property will return Nothing. The FlangeDefinition still defines the width extent but its details are not accessible through this property. You can determine the type of width extent by using the WidthExtentType property and can set the width type using one of the various Set methods.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.GetWidthExtent Method


FlangeDefinition.GetWidthExtentType Method

FlangeDefinition.GetWidthExtentType Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the method used to define the width extent.

Visual Basic
Sub GetWidthExtentType(Edge As Edge, ByRef HasOverride As VARIANT_BOOL, Result As [out, retval] PartFeatureExtentEnum)
Parameters
Parameters | Description
Edge | The Edge object that identifies the physical flange to return the width extent type for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to return the width extent type for.
HasOverride | Output value that indicates if the width extent is an override extent or not. A value of True indicates that an override exists. A value of False indicates that the default width extent of the Flange feature is being used for this physical flange.
Remarks

The valid values for this property are kWidthEdgeExtent, kWidthWidthExtent, kWidthOffsetExtent, and kWidthFromToExtent.

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.GetWidthExtentType Method


FlangeDefinition.RemoveOverrideWidthExtent Method

FlangeDefinition.RemoveOverrideWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that removes the override width extent for the specified physical flange.

Visual Basic
Sub RemoveOverrideWidthExtent(Edge As Edge)
Parameters
Parameters | Description
Edge | The Edge object that identifies the physical flange to remove the override width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to return the width extent type for.
Remarks

This method will be successful regardless of whether the specified physical flange has an override width extent or not. If the physical flange doesn"t have an override then this will result in no change. You can use the GetWidthExtentType to determine if a physical flange has an override or not.

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.RemoveOverrideWidthExtent Method


FlangeDefinition.SetCenteredDefaultWidthExtent Method

FlangeDefinition.SetCenteredDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a flange that"s centered along the edge and has a defined width.

Visual Basic
Sub SetCenteredDefaultWidthExtent(Width As VARIANT)
Parameters
Parameters | Description
Width | Input Variant that defines the distance used for the width extent of the flange. This value is used to define that distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetCenteredDefaultWidthExtent Method


FlangeDefinition.SetCenteredWidthExtent Method

FlangeDefinition.SetCenteredWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that overrides the width extent of the specified physical flange to define a flange that"s centered along the edge and has a defined width.

Visual Basic
Sub SetCenteredWidthExtent(Edge As Edge, Width As VARIANT)
Parameters
Parameters | Description
Edge | The Edge that identifies which flange to set the width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to set the width extent for. If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.
Width | Input Variant that defines the distance used for the width extent of the flange. This value is used to define that distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

See Also

Creating flange features sample

Edit width extent of an existing flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetCenteredWidthExtent Method


FlangeDefinition.SetDistanceHeightExtent Method

FlangeDefinition.SetDistanceHeightExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that changes the FlangeDefinition object to define a flange whose height is measured by a distance.

Visual Basic
Sub SetDistanceHeightExtent(Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, HeightDatumType As HeightDatumTypeEnum)
Parameters
Parameters | Description
Distance | Input Variant that defines the distance used for the height extent of the flange. When the FlangeDefinition object is created it defaults to a distance height extent. This value is used to define that distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input value from PartFeatureExtentDirectionEnum that defines the direction of the flange. kPositiveExtentDirection indicates that the direction of the flange is on the side of the selected edge. kNegativeExtentDirection indicates the flange is on the opposite side of the select edge. kSymmetricExtentDirection is not valid for a flange direction.
HeightDatumType | Input value from HeightDatumTypeEnum that defines how the height of the flange is defined. There are five options to define the height. Three of these are measured along the flange and two are measured in an orthogonal direction. These are illustrated in the figures below, along with the corresponding option as shown in the Flange dialog. In the examples below the flange distance is 1.00, the angle is 135.0 and the position of the bend is outside of the base face extents.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetDistanceHeightExtent Method


FlangeDefinition.SetEdgeDefaultWidthExtent Method

FlangeDefinition.SetEdgeDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the flanges.

Visual Basic
Sub SetEdgeDefaultWidthExtent()
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetEdgeDefaultWidthExtent Method


FlangeDefinition.SetEdgeWidthExtent Method

FlangeDefinition.SetEdgeWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that changes the FlangeDefinition object to define a flange whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the flanges.

Visual Basic
Sub SetEdgeWidthExtent(Edge As Edge)
Parameters
Parameters | Description
Edge | The Edge that identifies which flange to set the width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to set the width extent for.
Remarks

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

Example

Edit width extent of an existing flange feature

This sample demonstrates editing the width extent of an existing flange feature. This expects an existing sheet metal document that contains a flange feature that contains for physical flanges. It changes the type of width extent for each of the physical flanges. The result from the FlangeWidthsCreation sample can be used as the document to run this macro in.

Public Sub EditFlangeWidths()
    ' Create the active sheet metal document.
    Dim sheetMetalDoc As PartDocument
    Set sheetMetalDoc = ThisApplication.ActiveDocument

    ' Get the sheet metal component definition.
    Dim smCompDef As SheetMetalComponentDefinition
    Set smCompDef = sheetMetalDoc.ComponentDefinition

    Dim smFeatures As SheetMetalFeatures
    Set smFeatures = smCompDef.Features

    ' Get the flange feature.
    Dim flange As FlangeFeature
    Set flange = smFeatures.FlangeFeatures.Item(1)

    ' Position the end of part marker to just before this feature so the
    ' edges are in their original state.
    Call flange.SetEndOfPart(True)

    Dim flangeDef As FlangeDefinition
    Set flangeDef = flange.Definition

    ' Iterate over the four edges and edit the width extent for each one.
    Dim i As Integer
    For i = 1 To 4
        Dim currentEdge As Edge
        Set currentEdge = flangeDef.Edges.Item(i)
        Select Case i
            Case 1
                ' Edit the width extent to be offset as measured from the vertices of the edge.
                Call flangeDef.SetOffsetWidthExtent(currentEdge, currentEdge.StartVertex, 2, currentEdge.StopVertex, 5)
            Case 2
                Call flangeDef.SetEdgeWidthExtent(currentEdge)
            Case 3
                ' Edit the width extent to be an offset width extent.
                Call flangeDef.SetWidthOffsetWidthExtent(currentEdge, 6, 2, currentEdge.StartVertex, True)
            Case 4
                ' Edit the width extent to be centered.
                Call flangeDef.SetCenteredWidthExtent(currentEdge, 10)
        End Select
    Next

    ' Set the stop node back to the bottom of the browser.
    Call smCompDef.SetEndOfPartToTopOrBottom(False)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetEdgeWidthExtent Method


FlangeDefinition.SetFromToDefaultWidthExtent Method

FlangeDefinition.SetFromToDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a flange whose width is defined as being between two entities.

Visual Basic
Sub SetFromToDefaultWidthExtent(FromEntity As IDispatch, ToEntity As IDispatch)
Parameters
Parameters | Description
FromEntity | Input Object that defines the "from" extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
ToEntity | Input Object that defines the "to" extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetFromToDefaultWidthExtent Method


FlangeDefinition.SetFromToWidthExtent Method

FlangeDefinition.SetFromToWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that overrides the width extent of the specified physical flange to define a flange whose width is defined as being between two entities.

Visual Basic
Sub SetFromToWidthExtent(Edge As Edge, FromEntity As IDispatch, ToEntity As IDispatch)
Parameters
Parameters | Description
Edge | The Edge that identifies which flange to set the width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to set the width extent for.
FromEntity | Input Object that defines the 'from' extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
ToEntity | Input Object that defines the 'to' extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
Remarks

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetFromToWidthExtent Method


FlangeDefinition.SetLegacyDistanceHeightExtent Method

FlangeDefinition.SetLegacyDistanceHeightExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that changes the FlangeDefinition object to define a flange whose height is measured by a distance. The way the distance is computed for this type of height extent was used in earlier versions of Inventor and is supported in the current versions to support backward compatibility with older models.

Visual Basic
Sub SetLegacyDistanceHeightExtent(Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, HeightDatumType As HeightDatumTypeEnum)
Parameters
Parameters | Description
Distance | Input Variant that defines the distance used for the height extent of the flange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input value from PartFeatureExtentDirectionEnum that defines the direction of the flange. kPositiveExtentDirection indicates that the direction of the flange is on the side of the selected edge. kNegativeExtentDirection indicates the flange is on the opposite side of the select edge. kSymmetricExtentDirection is not valid for a flange direction.
HeightDatumType | HeightDatumTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetLegacyDistanceHeightExtent Method


FlangeDefinition.SetOffsetDefaultWidthExtent Method

FlangeDefinition.SetOffsetDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent to define a flange whose width is defined with respect to two entities.

Visual Basic
Sub SetOffsetDefaultWidthExtent(OffsetEntityOne As IDispatch, OffsetDistanceOne As VARIANT, OffsetEntityTwo As IDispatch, OffsetDistanceTwo As VARIANT)
Parameters
Parameters | Description
OffsetEntityOne | Input Object that defines the first entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceOne | Input Variant that defines the distance of the flange from offset entity one. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntityTwo | Input Object that defines the second entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceTwo | Input Variant that defines the distance of the flange from offset entity two. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetOffsetDefaultWidthExtent Method


FlangeDefinition.SetOffsetWidthExtent Method

FlangeDefinition.SetOffsetWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that overrides the width extent of the specified physical flange to define a flange whose width is defined with respect to two entities.

Visual Basic
Sub SetOffsetWidthExtent(Edge As Edge, OffsetEntityOne As IDispatch, OffsetDistanceOne As VARIANT, OffsetEntityTwo As IDispatch, OffsetDistanceTwo As VARIANT)
Parameters
Parameters | Description
Edge | The Edge that identifies which flange to set the width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to set the width extent for.
OffsetEntityOne | Input Object that defines the first entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceOne | Input Variant that defines the distance of the flange from offset entity one. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntityTwo | Input Object that defines the second entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceTwo | Input Variant that defines the distance of the flange from offset entity two. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

See Also

Edit width extent of an existing flange feature sample

Example

Creating flange features

Demonstrates creating flange features of various width extents. This creates a new document, creates a face feature and adds a flange feature on four edges.

Public Sub FlangeWidthsCreation()
    ' Create a new sheet metal document.
    Dim sheetMetalDoc As PartDocument
    Set sheetMetalDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                        ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject, , , "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}"))

    ' Get the sheet metal component definition.
    Dim smCompDef As SheetMetalComponentDefinition
    Set smCompDef = sheetMetalDoc.ComponentDefinition

    ' Create a sketch on the x-y plane.
    Dim sketch As PlanarSketch
    Set sketch = smCompDef.Sketches.Add(smCompDef.WorkPlanes.Item(3))

    Dim tg As TransientGeometry
    Set tg = ThisApplication.TransientGeometry

    ' Draw a rectangle.
    Call sketch.SketchLines.AddAsTwoPointRectangle(tg.CreatePoint2d(0, 0), tg.CreatePoint2d(25, 15))

    ' Create a profile.
    Dim profile As profile
    Set profile = sketch.Profiles.AddForSolid

    Dim smFeatures As SheetMetalFeatures
    Set smFeatures = smCompDef.Features

    ' Build up a face feature definition.
    Dim faceDef As FaceFeatureDefinition
    Set faceDef = smFeatures.FaceFeatures.CreateFaceFeatureDefinition(profile)

    ' Create a face feature.
    Dim faceFeature As faceFeature
    Set faceFeature = smFeatures.FaceFeatures.Add(faceDef)

    ' Get the "top" face.
    Dim topFace As face
    Set topFace = smCompDef.SurfaceBodies.Item(1).LocateUsingPoint(kFaceObject, tg.CreatePoint(5, 5, smCompDef.Thickness.Value))

    ' Create a collection containing the four edges.
    Dim edgeSet As EdgeCollection
    Set edgeSet = ThisApplication.TransientObjects.CreateEdgeCollection
    Dim i As Integer
    For i = 1 To 4
        Call edgeSet.Add(topFace.Edges.Item(i))
    Next

    ' Create the flange definition.
    Dim flangeDef As FlangeDefinition
    Set flangeDef = smFeatures.FlangeFeatures.CreateFlangeDefinition(edgeSet, "90", 6)

    ' Edit the definition to define a different width extent for each edge.
    For i = 1 To 4
        Dim faceEdge As Edge
        Set faceEdge = edgeSet.Item(i)
        Select Case i
            Case 1
                ' Do nothing and let it default to the edge extent.
            Case 2
                ' Edit the width extent to be centered.
                Call flangeDef.SetCenteredWidthExtent(faceEdge, 10)
            Case 3
                ' Edit the width extent to be offset as measured from the vertices of the edge.
                Call flangeDef.SetOffsetWidthExtent(faceEdge, faceEdge.StartVertex, 2, faceEdge.StopVertex, 5)
            Case 4
                ' Edit the width extent to be an offset width extent.
                Call flangeDef.SetWidthOffsetWidthExtent(faceEdge, 6, 2, faceEdge.StartVertex, True)
        End Select
    Next

    ' Create the flange.
    Call smFeatures.FlangeFeatures.Add(flangeDef)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetOffsetWidthExtent Method


FlangeDefinition.SetToHeightExtent Method

FlangeDefinition.SetToHeightExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that changes the FlangeDefinition object to define a flange whose height is defined by extending to the specified entity.

Visual Basic
Sub SetToHeightExtent(ToEntity As IDispatch, ByRef Offset As [optional] VARIANT)
Parameters
Parameters | Description
ToEntity | Input Object that defines the 'To' point. A WorkPoint or Vertex object is valid for input.
Offset | Optional Input Variant that defines the offset distance from the 'To' point. The default value is zero. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetToHeightExtent Method


FlangeDefinition.SetWidthOffsetDefaultWidthExtent Method

FlangeDefinition.SetWidthOffsetDefaultWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the default width extent for the flange feature to define a flange whose width is defined relative to another entity.

Visual Basic
Sub SetWidthOffsetDefaultWidthExtent(Width As VARIANT, OffsetDistance As VARIANT, OffsetEntity As IDispatch, PositiveDirection As VARIANT_BOOL)
Parameters
Parameters | Description
Width | Input Variant that defines the distance to use for the width extent of the flange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetDistance | Input Variant that defines the distance of the flange from the offset entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntity | Input Object that defines the entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
PositiveDirection | Input Boolean that specifies the side of the offset entity the flange is on.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetWidthOffsetDefaultWidthExtent Method


FlangeDefinition.SetWidthOffsetWidthExtent Method

FlangeDefinition.SetWidthOffsetWidthExtent Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that overrides the width extent of the specified physical flange to define a flange whose width is defined relative to another entity.

Visual Basic
Sub SetWidthOffsetWidthExtent(Edge As Edge, Width As VARIANT, OffsetDistance As VARIANT, OffsetEntity As IDispatch, PositiveDirection As VARIANT_BOOL)
Parameters
Parameters | Description
Edge | The Edge that identifies which flange to set the width extent for. The creation of a single flange feature can result in many physical flanges being added to the part. Each edge specified for the flange feature wll result in a physical flange. The edge specified as input to this argument must be one of the edges that was specified as input to the flange feature and defines which physical flange to set the width extent for.
Width | Input Variant that defines the distance to use for the width extent of the flange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetDistance | Input Variant that defines the distance of the flange from the offset entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntity | Input Object that defines the entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
PositiveDirection | Input Boolean that specifies the side of the offset entity the flange is on.
Remarks

If the flange already exists you must roll back the model to the point just before the flange feature was created so that the edge exists in the model and can be used as input to this method.

See Also

Creating flange features sample

Edit width extent of an existing flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Methods > FlangeDefinition.SetWidthOffsetWidthExtent Method


FlangeDefinition Properties

FlangeDefinition Properties
Summary

The properties of the FlangeDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ApplyAutoMitering | Property that defines if auto mitering should be performed.
BendOptions | Property that gets the bend options associated with this bend feature.
BendPosition | Property that gets and sets how the position of the bend is calculated.
BendRadius | Property that provides access to the bend radius of a sheet metal flange feature.
CornerOptions | Property that gets the CornerOptions object that defines how the corners of the bend are modeled.
DefaultWidthExtent | Property that returns the PartFeatureExtent object that defines how the default width extent of the flange feature is defined.
DefaultWidthExtentType | Property that returns the method used to define the default width extent.
Edges | Property that gets and set the EdgeCollection object that contains the edges that are used to define the flange feature.
FlangeAngle | Property that provides access to the bend angle of a sheet metal flange feature.
HeightExtent | Property that returns the PartFeatureExtent object that defines how the height extent of the flange feature is defined.
HeightExtentType | Property that returns the method used to define the height extent.
IsUnfoldMethodOverridden | Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.
MiterGap | Property that provides access to the miter gap size of the flange feature.
Parent | Property that returns the parent FlangeFeature of this FlangeDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
UnfoldMethod | Property that gets and set the UnfoldMethod object that defines how the bends associated with this flange feature are unfolded.
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties


FlangeDefinition.Application Property

FlangeDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.Application Property


FlangeDefinition.ApplyAutoMitering Property

FlangeDefinition.ApplyAutoMitering Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that defines if auto mitering should be performed.

Visual Basic
Property ApplyAutoMitering() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.ApplyAutoMitering Property


FlangeDefinition.BendOptions Property

FlangeDefinition.BendOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the bend options associated with this bend feature.

Visual Basic
Property BendOptions() As BendOptions*
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.BendOptions Property


FlangeDefinition.BendPosition Property

FlangeDefinition.BendPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets how the position of the bend is calculated.

Visual Basic
Property BendPosition() As BendPositionEnum
Remarks

The position is defined as the location of the bend along the sheet metal plate relative to the selected edge. There are six different bend position types, as illustrated below. Some bend positions are only valid for certain height extent types. These are also listed below.

kBendPositionOutsideBaseFace This bend position type is valid when the flange height extent is either a FlangeHeightDistanceExtent or FlangeHeightToExtent.

kBendPositionAdjacentFace This bend position type is valid when the flange height extent is either a FlangeHeightDistanceExtent or FlangeHeightToExtent.

kBendPositionInsideBendFace This bend position type is valid when the flange height extent is either a FlangeHeightDistanceExtent or FlangeHeightToExtent.

kBendPositionTangentToSideFace This bend position type is valid when the flange height extent is either a FlangeHeightDistanceExtent, FlangeHeightToExtent, or FlangeHeightLegacyDistanceExtent.

kBendPositionInnerEdgeOffset This bend position type is valid when the flange height extent is FlangeHeightLegacyDistanceExtent.

kBendPositionOuterEdgeOffset This bend position type is valid when the flange height extent is FlangeHeightLegacyDistanceExtent.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.BendPosition Property


FlangeDefinition.BendRadius Property

FlangeDefinition.BendRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend radius of a sheet metal flange feature.

Visual Basic
Property BendRadius() As VARIANT
Remarks

This property is writable when the FlangeDefinition object has been created using the FlangeFeatures.CreateFlangeDefinition or FlangeDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendRadius * 2' is valid, assuming there is a parameter named MyBendRadius. When the FlangeDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend radius. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.BendRadius Property


FlangeDefinition.CornerOptions Property

FlangeDefinition.CornerOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the CornerOptions object that defines how the corners of the bend are modeled.

Visual Basic
Property CornerOptions() As CornerOptions*
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.CornerOptions Property


FlangeDefinition.DefaultWidthExtent Property

FlangeDefinition.DefaultWidthExtent Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the PartFeatureExtent object that defines how the default width extent of the flange feature is defined.

Visual Basic
Property DefaultWidthExtent() As PartFeatureExtent**
Remarks

The default width extent is applied to all physical flanges in this flange feature that do not have a width extent override. The type of extent object that this property will return can be determined by using the WidthExtentType property. Types that can be returned are EdgeWidthExtent, WidthWidthExtent, OffsetWidthExtent, and FromToWidthExtent.

When the FlangeDefinition object is transient, (created using the FlangeFeatures. CreateFlangeDefinition method or the Copy method of an existing FlangeDefinition object), this property will return Nothing. The FlangeDefinition still defines the width extent but its details are not accessible through this property. You can determine the type of width extent by using the WidthExtentType property and can set the width type using one of the various Set methods.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.DefaultWidthExtent Property


FlangeDefinition.DefaultWidthExtentType Property

FlangeDefinition.DefaultWidthExtentType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the method used to define the default width extent.

Visual Basic
Property DefaultWidthExtentType() As PartFeatureExtentEnum*
Remarks

The default width extent is applied to all physical flanges in this flange feature that do not have a width extent override. The valid values for this property are kEdgeWidthExtent, kWidthOffsetWidthExtent, kOffsetWidthExtent and kFromToWidthExtent.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.DefaultWidthExtentType Property


FlangeDefinition.Edges Property

FlangeDefinition.Edges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the EdgeCollection object that contains the edges that are used to define the flange feature.

Visual Basic
Property Edges() As EdgeCollection*
Remarks

When querying an existing flange the originally selected edges are not available because they were consumed when the flange feature was created. To access these edges the end-of-part marker must be placed above the flange feature.

See Also

Edit width extent of an existing flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.Edges Property


FlangeDefinition.FlangeAngle Property

FlangeDefinition.FlangeAngle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend angle of a sheet metal flange feature.

Visual Basic
Property FlangeAngle() As VARIANT
Remarks

This property is writable when the FlangeDefinition object has been created using the FlangeFeatures.CreateFlangeDefinition or FlangeDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyFlangeAngle * 2' is valid, assuming there is a parameter named MyFlangeAngle. When the FlangeDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend angle. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.FlangeAngle Property


FlangeDefinition.HeightExtent Property

FlangeDefinition.HeightExtent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the PartFeatureExtent object that defines how the height extent of the flange feature is defined.

Visual Basic
Property HeightExtent() As PartFeatureExtent**
Remarks

The type of extent object that this property will return can be determined by using the HeightExtentType property. Types that can be returned are FlangeDistanceExtent, FlangeToExtent, and FlangeLegacyDistanceExtent. When a new FlangeDefinition object is created using the FlangeFeatures.CreateFlangeDefinition method the extent is not accessible but will default to a distance extent with a default extent distance. To use a different extent type or provide different inputs for the distance extent you can use the various Set methods of the FlangeDefinition to define a new height extent.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.HeightExtent Property


FlangeDefinition.HeightExtentType Property

FlangeDefinition.HeightExtentType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the method used to define the height extent.

Visual Basic
Property HeightExtentType() As PartFeatureExtentEnum*
Remarks

The three valid values for this property are kFlangeDistanceExtent, kFlangeToExtent, and kFlangeLegacyDistanceExtent.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.HeightExtentType Property


FlangeDefinition.IsUnfoldMethodOverridden Property

FlangeDefinition.IsUnfoldMethodOverridden Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.

Visual Basic
Property IsUnfoldMethodOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.IsUnfoldMethodOverridden Property


FlangeDefinition.MiterGap Property

FlangeDefinition.MiterGap Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the miter gap size of the flange feature.

Visual Basic
Property MiterGap() As VARIANT
Remarks

This property is writable when the FlangeDefinition object has been created using the CreateFlangeDefinition or FlangeDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyMiterGap * 2' is valid, assuming there is a parameter named MyMiterGap. When the FlangeDefinition object has been obtained from an existing flange feature this property is read-only and returns the Parameter object that defines the miter gap size. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.MiterGap Property


FlangeDefinition.Parent Property

FlangeDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent FlangeFeature of this FlangeDefinition object.

Visual Basic
Property Parent() As FlangeFeature**
Remarks

In the case where this is a newly created FlangeDefinition object or it has been copied from an existing FlangeDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.Parent Property


FlangeDefinition.Type Property

FlangeDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.Type Property


FlangeDefinition.UnfoldMethod Property

FlangeDefinition.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the UnfoldMethod object that defines how the bends associated with this flange feature are unfolded.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
You are here: Symbol Reference > Inventor Library > Objects > FlangeDefinition Interface > FlangeDefinition Properties > FlangeDefinition.UnfoldMethod Property


FlangeFeature Interface

FlangeFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FlangeFeature object represents a sheet metal flange feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::FlangeFeature
        Inventor::FlangeFeatureProxy
Visual Basic
Public Interface FlangeFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

FlangeDefinition.Parent

FlangeFeatures.Add

FlangeFeatures.Item

See Also

Create sheet metal face and flange features sample

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeature Interface


FlangeFeature Properties

FlangeFeature Properties
Summary

The properties of the FlangeFeature class are listed here.

Properties
Name | Description
BendFeature | Property that returns the associated bend feature, if there is one.
Definition | Property that gets the FlangeDefinition object associated with this fold feature.
You are here: Symbol Reference > Inventor Library > Objects > FlangeFeature Interface > FlangeFeature Properties


FlangeFeature.BendFeature Property

FlangeFeature.BendFeature Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the associated bend feature, if there is one.

Visual Basic
Property BendFeature() As BendFeature**
Remarks

If there is not an associated bend feature, this property returns Nothing.

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeature Interface > FlangeFeature Properties > FlangeFeature.BendFeature Property


FlangeFeature.Definition Property

FlangeFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the FlangeDefinition object associated with this fold feature.

Visual Basic
Property Definition() As FlangeDefinition*
Remarks

Modifying the FlangeDefinition object will edit the associated FlangeFeature.

See Also

Edit width extent of an existing flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeature Interface > FlangeFeature Properties > FlangeFeature.Definition Property


FlangeFeatureProxy Interface

FlangeFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FlangeFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::FlangeFeature
        Inventor::FlangeFeatureProxy
Visual Basic
Public Interface FlangeFeatureProxy
Inherits FlangeFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatureProxy Interface


FlangeFeatures Interface

FlangeFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FlangeFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::FlangeFeatures
Visual Basic
Public Interface FlangeFeatures
Inherits IDispatch
Remarks

It's also through the FlangeFeatures object that you create new FlangeFeature objects.

Notes

Members through which this object may be accessed include:

SheetMetalFeatures.FlangeFeatures

See Also

Create sheet metal face and flange features sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface


FlangeFeatures Methods

FlangeFeatures Methods
Summary

The methods of the FlangeFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new flange feature. The newly created FlangeFeature object is returned.
CreateFlangeDefinition | Method that creates a new FlangeDefinition object. The object created does not represent a flange feature but instead is a representation of the information that defines a flange feature. You can use this object as input to the FlangeFeatures.Add method to create the actual flange feature.
Item | Property that returns the specified FlangeFeature object from the collection. This is the default property of the FlangeFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Methods


FlangeFeatures.Add Method

FlangeFeatures.Add Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new flange feature. The newly created FlangeFeature object is returned.

Visual Basic
Sub Add(FlangeDefinition As FlangeDefinition, Result As [out, retval] FlangeFeature*)
Parameters
Parameters | Description
FlangeDefinition | Input FlangeDefinition object that defines the flange feature you want to create. A FlangeDefinition object can be created using the FlangeFeatures.CreateFlangeDefinition method. It can also be obtained from an existing FlangeFeature object.
See Also

Creating flange features sample

Create sheet metal face and flange features sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Methods > FlangeFeatures.Add Method


FlangeFeatures.CreateFlangeDefinition Method

FlangeFeatures.CreateFlangeDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new FlangeDefinition object. The object created does not represent a flange feature but instead is a representation of the information that defines a flange feature. You can use this object as input to the FlangeFeatures.Add method to create the actual flange feature.

Visual Basic
Sub CreateFlangeDefinition(Edges As EdgeCollection, FlangeAngle As VARIANT, Distance As VARIANT, Result As [out, retval] FlangeDefinition*)
Parameters
Parameters | Description
Edges | Input EdgeCollection that specifies the edges to create a flange feature on. If the all of the edges of a Face are desired, it is up to you to obtain them from the Face and and add them to the collection.
FlangeAngle | Input Variant that defines the angle of the flange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
Distance | Input Variant that defines the distance used for the height extent of the flange. When the FlangeDefinition object is created it defaults to a distance height extent. This value is used to define that distance. If you want to define the height using a 'to' extent instead you can edit the definition and change it, but to initially create the definition you must still supply an value for the distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

The FlangeDefinition object returned is fully defined and can be used to create a flange feature. However, defaults are used for most of the flange options so you may want to change some of the property values of the FlangeDefinition object before using it to create a flange feature.

See Also

Creating flange features sample

Create sheet metal face and flange features sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Methods > FlangeFeatures.CreateFlangeDefinition Method


FlangeFeatures.Item Method

FlangeFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified FlangeFeature object from the collection. This is the default property of the FlangeFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FlangeFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return.
See Also

Edit width extent of an existing flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Methods > FlangeFeatures.Item Method


FlangeFeatures Properties

FlangeFeatures Properties
Summary

The properties of the FlangeFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Properties


FlangeFeatures.Application Property

FlangeFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Properties > FlangeFeatures.Application Property


FlangeFeatures.Count Property

FlangeFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Properties > FlangeFeatures.Count Property


FlangeFeatures.Type Property

FlangeFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlangeFeatures Interface > FlangeFeatures Properties > FlangeFeatures.Type Property


FlatBendResult Interface

FlatBendResult Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The FlatBendResult object represents a single bend instance in the flat. A bend instance can result from a feature placed either in the folded model or in the flat pattern. A bend feature may define multiple bends, and every one of the resulting bend instances is represented by a FlatBendResult object.

Class Hierarchy
Inventor::FlatBendResult
Visual Basic
Public Interface FlatBendResult
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatBendResults.Item

You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface


FlatBendResult Methods

FlatBendResult Methods
Summary

The methods of the FlatBendResult class are listed here.

Methods
Methods
Name | Description
GetBendOrder | Method that gets the bend order for this bend result.
SetBendOrder | Method that sets the bend order for this bend result. This will define a bend order override for this bend result.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Methods


FlatBendResult.GetBendOrder Method

FlatBendResult.GetBendOrder Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets the bend order for this bend result.

Visual Basic
Sub GetBendOrder(ByRef BenderOrder As long, ByRef BendOrderSourceType As BendOrderSourceTypeEnum)
Parameters
Parameters | Description
BenderOrder | Output Long that defines the order of this bend.
BendOrderSourceType | Output BendOrderSourceTypeEnum value that defines how the bend order value has been defined. Valid values and their meaning is described below. kDefaultBendOrder The original bend order as determined by Inventor. kOverrideBendOrder The bend order has been assigned by the end-user and has overridden the default value. kDuplicateOverrideBendOrder The bend order has been assigned by the end-user and has overridden the default value. It is also has a duplicate value as another bend.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Methods > FlatBendResult.GetBendOrder Method


FlatBendResult.SetBendOrder Method

FlatBendResult.SetBendOrder Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the bend order for this bend result. This will define a bend order override for this bend result.

Visual Basic
Sub SetBendOrder(BenderOrder As long, AllowDuplicate As VARIANT_BOOL)
Parameters
Parameters | Description
BenderOrder | Input Long that defines the order of this bend.
AllowDuplicate | Input Boolean that indicates if duplicate bend order values are allowed. If True and the specified bend order value already exists on another bend result, the same bend order will be assigned to this bend result and both bend results will be defined to have an duplicate override bend order. If False and the value specified already exists then the bend values on the other bend results will modified to make room for this value.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Methods > FlatBendResult.SetBendOrder Method


FlatBendResult Properties

FlatBendResult Properties
Summary

The properties of the FlatBendResult class are listed here.

Properties
Name | Description
Angle | Property that returns the angle of the bend.
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Edge | Property that returns the edge in the flat pattern that belongs to the bend result.
InnerRadius | Property that returns the inner radius of the bend.
InternalName | Property that returns a string that uniquely identifies a bend instance within the flat pattern.
IsDirectionUp | Property that returns whether the direction of the bend is up or down.
IsOnBottomFace | Property that returns whether this bend result is on the bottom face of the flat pattern. Every bend has two coresponding bend results on the flat pattern one on the top face and one on the bottom face.
KFactor | Property that returns the K-Factor value associated with this bend.
Parent | Property that returns the parent FlatPattern object.
Type | Property returning kFlatBendResultObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties


FlatBendResult.Angle Property

FlatBendResult.Angle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the angle of the bend.

Visual Basic
Property Angle() As double*
Remarks

This property always returns the outer bend angle regardless of the FlatPattern.UseOuterBendAngle flag.

You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.Angle Property


FlatBendResult.Application Property

FlatBendResult.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.Application Property


FlatBendResult.Edge Property

FlatBendResult.Edge Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the edge in the flat pattern that belongs to the bend result.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.Edge Property


FlatBendResult.InnerRadius Property

FlatBendResult.InnerRadius Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the inner radius of the bend.

Visual Basic
Property InnerRadius() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.InnerRadius Property


FlatBendResult.InternalName Property

FlatBendResult.InternalName Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns a string that uniquely identifies a bend instance within the flat pattern.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.InternalName Property


FlatBendResult.IsDirectionUp Property

FlatBendResult.IsDirectionUp Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the direction of the bend is up or down.

Visual Basic
Property IsDirectionUp() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.IsDirectionUp Property


FlatBendResult.IsOnBottomFace Property

FlatBendResult.IsOnBottomFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether this bend result is on the bottom face of the flat pattern. Every bend has two coresponding bend results on the flat pattern one on the top face and one on the bottom face.

Visual Basic
Property IsOnBottomFace() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.IsOnBottomFace Property


FlatBendResult.KFactor Property

FlatBendResult.KFactor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the K-Factor value associated with this bend.

Visual Basic
Property KFactor() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.KFactor Property


FlatBendResult.Parent Property

FlatBendResult.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent FlatPattern object.

Visual Basic
Property Parent() As FlatPattern**
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.Parent Property


FlatBendResult.Type Property

FlatBendResult.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kFlatBendResultObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResult Interface > FlatBendResult Properties > FlatBendResult.Type Property


FlatBendResults Interface

FlatBendResults Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The FlatBendResults collection object contains information about all the resulting bends in the flat pattern.

Class Hierarchy
Inventor::FlatBendResults
Visual Basic
Public Interface FlatBendResults
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPattern.FlatBendResults

You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface


FlatBendResults Methods

FlatBendResults Methods
Summary

The methods of the FlatBendResults class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified FlatBendResultobject from the collection.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface > FlatBendResults Methods


FlatBendResults.Item Method

FlatBendResults.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified FlatBendResultobject from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FlatBendResult*)
Parameters
Parameters | Description
index | Input Variant value that specifies the FlatBendResult to return. This can be a numeric value indicating the index of the item in the collection, an Edge object that belongs to the resulting bend or it can be a string indicating the InternalName of the bend. If an out of range index is provided or the InternalName of a non-existing bend is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface > FlatBendResults Methods > FlatBendResults.Item Method


FlatBendResults Properties

FlatBendResults Properties
Summary

The properties of the FlatBendResults class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface > FlatBendResults Properties


FlatBendResults.Application Property

FlatBendResults.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface > FlatBendResults Properties > FlatBendResults.Application Property


FlatBendResults.Count Property

FlatBendResults.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface > FlatBendResults Properties > FlatBendResults.Count Property


FlatBendResults.Type Property

FlatBendResults.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlatBendResults Interface > FlatBendResults Properties > FlatBendResults.Type Property


FlatPattern Interface

FlatPattern Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The FlatPattern object represents the unfolded model in a sheet metal document.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::FlatPattern
Visual Basic
Public Interface FlatPattern
Inherits ComponentDefinition
Notes

Members through which this object may be accessed include:

FlatBendResult.Parent

FlatPunchResult.Parent

SheetMetalComponentDefinition.FlatPattern

Document.ActivatedObject

Application.ActiveEditObject

See Also

Finding Bend Extent (Tangent) Edges sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface


FlatPattern Methods

FlatPattern Methods
Summary

The methods of the FlatPattern class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the FlatPattern.
DeleteObjects | Method that deletes a collection of objects that belong to the flat pattern.
Edit | Method that puts the FlatPattern in edit mode.
ExitEdit | Method that causes the FlatPattern editing environment to be closed and the user interface to return to sheet metal editing environment.
FindUsingRay |
FlipBaseFace | Method that flips the flat pattern by swapping the top and bottom faces.
GetAlignment | Method that returns the alignment data for the flat pattern
GetEdgesOfType | Method that returns edges of the specified type from the flat pattern body.
GetEndOfPartPosition | Method that returns the current end of part position in the browser in parts and assemblies.
GetFlatPatternEntity | Method that returns the corresponding BRep entity (face, edge, etc.) in the flat pattern body given a BRep entity in the sheet metal body.
SetAlignment | Method that sets the alignment for the flat pattern.
SetEndOfPartToTopOrBottom | Method that positions the end-of-part marker at the top or bottom of the browser.
SuppressFeatures | Method that suppresses the specified features.
UnsuppressFeatures | Method that unsuppresses the specified features.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods


FlatPattern.Delete Method

FlatPattern.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes the FlatPattern.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.Delete Method


FlatPattern.DeleteObjects Method

FlatPattern.DeleteObjects Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes a collection of objects that belong to the flat pattern.

Visual Basic
Sub DeleteObjects(Objects As ObjectCollection, ByRef RetainConsumedSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDepFeatsAndSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDepWorkFeats As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Objects | Collection of objects to delete from the part. Valid objects are part features, work features, sketches and 3d sketches.
RetainConsumedSketches | Optional input Boolean indicating if consumed sketches within the feature should be deleted. If the feature being deleted is not a sketch based feature this argument is ignored.
RetainDepFeatsAndSketches | Optional input Boolean that specifies if dependent features and sketches should be deleted. If there are no such dependents this argument is ignored.
RetainDepWorkFeats | Optional input Boolean that specifies if dependent work features should be deleted. If there are no dependent work features this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.DeleteObjects Method


FlatPattern.Edit Method

FlatPattern.Edit Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that puts the FlatPattern in edit mode.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.Edit Method


FlatPattern.ExitEdit Method

FlatPattern.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that causes the FlatPattern editing environment to be closed and the user interface to return to sheet metal editing environment.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.ExitEdit Method


FlatPattern.FindUsingRay Method

FlatPattern.FindUsingRay Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary
Visual Basic
Sub FindUsingRay(RayStartPoint As Point, RayDirection As UnitVector, Radius As double, ByRef FoundEntities As ObjectsEnumerator*, ByRef LocationPoints As ObjectsEnumerator*, ByRef FindFirstOnly As [defaultvalue(0)] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.FindUsingRay Method


FlatPattern.FlipBaseFace Method

FlatPattern.FlipBaseFace Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that flips the flat pattern by swapping the top and bottom faces.

Visual Basic
Sub FlipBaseFace()
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.FlipBaseFace Method


FlatPattern.GetAlignment Method

FlatPattern.GetAlignment Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the alignment data for the flat pattern

Visual Basic
Sub GetAlignment(ByRef AlignmentType As AlignmentTypeEnum, ByRef AlignedTo As IDispatch*, ByRef AlignmentDirectionReversed As VARIANT_BOOL)
Parameters
Parameters | Description
AlignmentType | Output AlignmentTypeEnum that indicates the alignment type. Possible return values are kHorizontalAlignment and kVerticalAlignment.
AlignedTo | Output object that indicates the entity that the flat pattern is aligned to. Possible return values are Edge object or an ObjectCollection containing two Vertex objects. This argument returns Nothing if the flat pattern has never been explicitly aligned to any entity.
AlignmentDirectionReversed | Output Boolean that indicates whether the alignment direction is the opposite of the natural direction of the entity that the flat pattern is aligned to.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.GetAlignment Method


FlatPattern.GetEdgesOfType Method

FlatPattern.GetEdgesOfType Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns edges of the specified type from the flat pattern body.

Visual Basic
Sub GetEdgesOfType(EdgeType As FlatPatternEdgeTypeEnum, ByRef TopFaceEdges As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Edges*)
Parameters
Parameters | Description
EdgeType | Input FlatPatternEdgeTypeEnum that specifies the type of edges to return from the flat pattern body.
TopFaceEdges | Optional input Boolean that specifies whether to return the edges from the top face or the bottom face of the unfolded model. If not specified, edges from the top face are returned.
Example

"Finding Bend Extent (Tangent) Edges"

This sample demonstrates how to retrieve the bend extent edges (a.k.a. tangent edges) associated with the selected bend edge on a flat pattern. Before running the sample, activate a flat pattern and select a bend edge.

Sub BendExtentEdges()
    ' Check to make sure a flat pattern is open.
    If Not TypeOf ThisApplication.ActiveEditObject Is FlatPattern Then
        MsgBox "A flat pattern must be active."
        Exit Sub
    End If

    ' Set a reference to the active document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active flat pattern.
    Dim oFlatPattern As FlatPattern
    Set oFlatPattern = ThisApplication.ActiveEditObject

    ' Check to make sure a bend edge is selected.
    If Not TypeOf oPartDoc.SelectSet(1) Is Edge Then
        MsgBox "A bend edge must be selected."
        Exit Sub
    End If

    Dim oBendEdge As Edge
    Set oBendEdge = oPartDoc.SelectSet(1)

    If Not IsBendEdge(oBendEdge, oFlatPattern) Then
        MsgBox "A bend edge must be selected."
        Exit Sub
    End If

    Dim oAllTangentEdges As Edges
    Set oAllTangentEdges = oFlatPattern.GetEdgesOfType(kTangentFlatPatternEdge)

    Dim MinimumDist As Double
    MinimumDist = 0

    ' Collect up tangent edges that are parallel and closest to the bend edge
    Dim oBendTangentEdges As ObjectCollection
    Set oBendTangentEdges = ThisApplication.TransientObjects.CreateObjectCollection

    Dim oEdge As Edge
    For Each oEdge In oAllTangentEdges
        ' Only interested in edges that are parallel to the bend edge
        If oBendEdge.Geometry.Direction.IsParallelTo(oEdge.Geometry.Direction, 0.0001) Then
            ' Eliminate any bend edges whose midpoint when projected onto
            ' the bend line is not within the length of the bend line.
            If IsWithinBendEdge(oBendEdge, oEdge) Then
                Dim dist As Double
                dist = ThisApplication.MeasureTools.GetMinimumDistance(oBendEdge, oEdge)
                If MinimumDist = 0 Then
                    oBendTangentEdges.Add oEdge
                    MinimumDist = dist
                ElseIf Abs(dist - MinimumDist) < 0.00001 Then
                    oBendTangentEdges.Add oEdge
                    MinimumDist = dist
                ElseIf dist < MinimumDist Then
                    ' Clear the collection
                    Dim oObject As Object
                    For Each oObject In oBendTangentEdges
                        oBendTangentEdges.RemoveByObject oObject
                    Next

                    oBendTangentEdges.Add oEdge
                    MinimumDist = dist
                End If
            End If
        End If
    Next

    ' Highlight tangent edges in blue.
    Dim oTangentHS As HighlightSet
    Set oTangentHS = oPartDoc.CreateHighlightSet
    oTangentHS.Color = ThisApplication.TransientObjects.CreateColor(255, 255, 0)

    Dim oBendTangentEdge As Edge
    For Each oBendTangentEdge In oBendTangentEdges
        oTangentHS.AddItem oBendTangentEdge
    Next

    MsgBox "Bend extent edges highlighted in yellow."
End Sub

Private Function IsWithinBendEdge(oBendEdge As Edge, TangentEdge As Edge) As Boolean
    Dim dPi As Double
    dPi = 4 * Atn(1)

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Determine the lengths of the sides of the triangle defined by the end points
    ' of the bend edge and the center point of the tangent edge.
    Dim oStartPoint As Point2d
    Set oStartPoint = oTG.CreatePoint2d(oBendEdge.StartVertex.Point.x, oBendEdge.StartVertex.Point.y)
    Dim oEndPoint As Point2d
    Set oEndPoint = oTG.CreatePoint2d(oBendEdge.StopVertex.Point.x, oBendEdge.StopVertex.Point.y)
    Dim oTangentPoint As Point2d
    Set oTangentPoint = oTG.CreatePoint2d((TangentEdge.StartVertex.Point.x + TangentEdge.StopVertex.Point.x) / 2, (TangentEdge.StartVertex.Point.y + TangentEdge.StopVertex.Point.y) / 2)
    Dim dBendLength As Double
    dBendLength = oStartPoint.DistanceTo(oEndPoint)
    Dim dStartLength As Double
    dStartLength = oStartPoint.DistanceTo(oTangentPoint)
    Dim dEndLength As Double
    dEndLength = oEndPoint.DistanceTo(oTangentPoint)

    ' Compute the angle from the start point to the tangent midpoint.
    Dim dStartAngle As Double
    dStartAngle = ArcCos((dStartLength ^ 2 + dBendLength ^ 2 - dEndLength ^ 2) / (2 * dStartLength * dBendLength))

    ' Check that it is less than 90 deg.
    If dStartAngle > dPi / 2 Then
        IsWithinBendEdge = False
        Exit Function
    End If

    ' Compute the angle from the end point to the tangent midpoint.
    Dim dEndAngle As Double
    dEndAngle = ArcCos((dEndLength ^ 2 + dBendLength ^ 2 - dStartLength ^ 2) / (2 * dEndLength * dBendLength))

    ' Check that it is less than 90 deg.
    If dEndAngle > dPi / 2 Then
        IsWithinBendEdge = False
        Exit Function
    End If

    IsWithinBendEdge = True
End Function

Private Function ArcCos(x As Double) As Double
    If x = 1 Then
        ArcCos = 0
    ElseIf Abs((Abs(x) - 1)) < 0.000001 Then
        ArcCos = 4 * Atn(1) 'Pi
    Else
        ArcCos = Atn(-x / Sqr(-x * x + 1)) + 2 * (Pi / 4)
    End If
End Function

Private Function IsBendEdge(oEdge As Edge, oFlatPattern As FlatPattern) As Boolean
    ' Return False if the input edge is not a wire edge.
    Dim oWire As Wire
    Set oWire = oEdge.Wire

    If oWire Is Nothing Then
        IsBendEdge = False
        Exit Function
    End If

    Dim oAllBendEdges As EdgeCollection
    Set oAllBendEdges = ThisApplication.TransientObjects.CreateEdgeCollection

    Dim oTempEdge As Edge

    ' Get all Bend UP edges on top face
    Dim oTopFaceBendUpEdges As Edges
    Set oTopFaceBendUpEdges = oFlatPattern.GetEdgesOfType(kBendUpFlatPatternEdge, True)
    For Each oTempEdge In oTopFaceBendUpEdges
        oAllBendEdges.Add oTempEdge
    Next

    ' Get all Bend DOWN edges on top face
    Dim oTopFaceBendDownEdges As Edges
    Set oTopFaceBendDownEdges = oFlatPattern.GetEdgesOfType(kBendDownFlatPatternEdge, True)
    For Each oTempEdge In oTopFaceBendDownEdges
        oAllBendEdges.Add oTempEdge
    Next

    ' Get all Bend UP edges on bottom face
    Dim oBottomFaceBendUpEdges As Edges
    Set oBottomFaceBendUpEdges = oFlatPattern.GetEdgesOfType(kBendUpFlatPatternEdge, False)
    For Each oTempEdge In oBottomFaceBendUpEdges
        oAllBendEdges.Add oTempEdge
    Next

    ' Get all Bend DOWN edges on bottom face
    Dim oBottomFaceBendDownEdges As Edges
    Set oBottomFaceBendDownEdges = oFlatPattern.GetEdgesOfType(kBendDownFlatPatternEdge, False)
    For Each oTempEdge In oBottomFaceBendDownEdges
        oAllBendEdges.Add oTempEdge
    Next

     ' Check if the input edge is a bend edge
    For Each oTempEdge In oAllBendEdges
        If oTempEdge Is oEdge Then
            IsBendEdge = True
            Exit Function
        End If
    Next

    IsBendEdge = False
End Function
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.GetEdgesOfType Method


FlatPattern.GetEndOfPartPosition Method

FlatPattern.GetEndOfPartPosition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the current end of part position in the browser in parts and assemblies.

Visual Basic
Sub GetEndOfPartPosition(ByRef After As IDispatch*, ByRef Before As IDispatch*)
Parameters
Parameters | Description
After | Output object that returns the object after which the end of part is currently positioned. This could return Nothing if there are no features before the end of part in the browser. Valid return objects in part are features, 2d & 3d sketches, all work features and derived part/assembly components. Valid return objects in assembly are features and 2d sketches.
Before | Output object that returns the object before which the end of part is currently positioned. This could return Nothing if there are no features after the end of part in the browser. Valid return objects in part are features, 2d & 3d sketches, all work features and derived part/assembly components. Valid return objects in assembly are features and 2d sketches.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.GetEndOfPartPosition Method


FlatPattern.GetFlatPatternEntity Method

FlatPattern.GetFlatPatternEntity Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the corresponding BRep entity (face, edge, etc.) in the flat pattern body given a BRep entity in the sheet metal body.

Visual Basic
Sub GetFlatPatternEntity(SheetMetalEntity As IDispatch, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
SheetMetalEntity | Input BRep entity from the sheet metal body.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.GetFlatPatternEntity Method


FlatPattern.SetAlignment Method

FlatPattern.SetAlignment Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the alignment for the flat pattern.

Visual Basic
Sub SetAlignment(AlignmentType As AlignmentTypeEnum, AlignedTo As IDispatch, ByRef AlignmentDirectionReversed As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
AlignmentType | Input AlignmentTypeEnum that indicates the alignment type. Valid values are kHorizontalAlignment and kVerticalAlignment.
AlignedTo | Input object that indicates the entity that the flat pattern should be aligned to. Valid inputs are Edge object and an ObjectCollection containing two Vertex objects.
AlignmentDirectionReversed | Optional input Boolean that indicates whether the alignment direction is the opposite of the natural direction of the entity that the flat pattern is being aligned to. If not specified, a default value of False is assumed.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.SetAlignment Method


FlatPattern.SetEndOfPartToTopOrBottom Method

FlatPattern.SetEndOfPartToTopOrBottom Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that positions the end-of-part marker at the top or bottom of the browser.

Visual Basic
Sub SetEndOfPartToTopOrBottom(SetToTop As VARIANT_BOOL)
Parameters
Parameters | Description
SetToTop | Input Boolean that specifies whether the end-of-part marker is to be moved to the top or the bottom of the browser. If True, the marker is moved to the top of the browser, just below the Origin folder. If False, it is moved to the bottom of the browser, just below the last item in the browser.
See Also

Edit width extent of an existing flange feature sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.SetEndOfPartToTopOrBottom Method


FlatPattern.SuppressFeatures Method

FlatPattern.SuppressFeatures Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that suppresses the specified features.

Visual Basic
Sub SuppressFeatures(Features As ObjectCollection)
Parameters
Parameters | Description
Features | Collection of features to suppress.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.SuppressFeatures Method


FlatPattern.UnsuppressFeatures Method

FlatPattern.UnsuppressFeatures Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that unsuppresses the specified features.

Visual Basic
Sub UnsuppressFeatures(Features As ObjectCollection)
Parameters
Parameters | Description
Features | Collection of features to unsuppress.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Methods > FlatPattern.UnsuppressFeatures Method


FlatPattern Properties

FlatPattern Properties
Summary

The properties of the FlatPattern class are listed here.

Properties
Name | Description
BaseFace | Property that returns the base face from the folded model that was used to create the flat pattern.
BendAngleReportType | Property that gets and sets which angle is reported in the flat pattern. Valid values are kBendingAngleReportType, kOpenAngleReportType, or kDefaultAngleReportType.
Body | Property that returns the corresponding SurfaceBody.
BottomFace | Property that returns the bottom face of the flat pattern.
Features | Property that returns the collection object that provides access to the features associated with the flat pattern.
FlatBendResults | Property that returns the FlatBendResults collection object that contains information about all the bends in the flat pattern.
FlatPunchResults | Property that returns the FlatPunchResults collection object that contains information about all the punches in the flat pattern.
GraphicsDataSetsCollection |
Length | Property that returns the length of the flat pattern.
MassProperties | Property that returns the MassProperties object for the flat pattern.
Parameters | Property that returns the set of parameters for the flat pattern.
Parent | Property that returns the parent SheetMetalComponentDefinition object.
PartEvents | Property that returns the PartEvents object associated with the flat pattern. This object will fire events for changes that occur to the flat pattern.
PunchRepresentationType | Property that indicates the punch representation to use for the flat pattern.
RepresentationsManager | Property that returns the RepresentationsManager object.
RolledBackForEdit | Property that gets whether the flat pattern model is currently rolled back to a previous point in the feature history.
SketchBlockDefinitions | Property that returns the SketchBlockDefinitions collection object.
Sketches | Gets the PlanarSketches collection object that encapsulates all of the planar sketches defined in this ComponentDefinition.
Sketches3D |
TopFace | Property that returns top face of the flat pattern.
UserCoordinateSystems | Property that returns the UserCoordinateSystems collection object.
Width | Property that returns the width of the flat pattern.
WorkAxes | Property that returns that collection object that provides access to all of the existing work axis objects in the flat pattern and provides the functionality to create new work axis objects.
WorkPlanes | Property that returns that collection object that provides access to all of the existing work plane objects in the flat pattern and provides the functionality to create new work plane objects.
WorkPoints | Property that returns that collection object that provides access to all of the existing work point objects in the flat pattern and provides the functionality to create new work point objects.
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties


FlatPattern.BaseFace Property

FlatPattern.BaseFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the base face from the folded model that was used to create the flat pattern.

Visual Basic
Property BaseFace() As Face**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.BaseFace Property


FlatPattern.BendAngleReportType Property

FlatPattern.BendAngleReportType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets which angle is reported in the flat pattern. Valid values are kBendingAngleReportType, kOpenAngleReportType, or kDefaultAngleReportType.

Visual Basic
Property BendAngleReportType() As BendAngleTypeEnum
Remarks

kDefaultAngleReportType will result in using the type specified by the active sheet metal style. Either one of the other two settings will override the value defined by the style.

This value controls which angle is used to report the bends, i.e. bend tables, exporting DWG/DXF files, etc. The bend angles reported by the API (in the FlatBendResult.Angle property) are always the bending angle regardless of this setting.

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.BendAngleReportType Property


FlatPattern.Body Property

FlatPattern.Body Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the corresponding SurfaceBody.

Visual Basic
Property Body() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Body Property


FlatPattern.BottomFace Property

FlatPattern.BottomFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the bottom face of the flat pattern.

Visual Basic
Property BottomFace() As Face**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.BottomFace Property


FlatPattern.Features Property

FlatPattern.Features Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection object that provides access to the features associated with the flat pattern.

Visual Basic
Property Features() As FlatPatternFeatures**
Remarks

Due to an internal architecture issue, there may be problems in creating/editing flat pattern features if the flat pattern is not active. To workaround this limitation, activate the flat pattern (use FlatPattern.Edit) before creating/editing features.

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Features Property


FlatPattern.FlatBendResults Property

FlatPattern.FlatBendResults Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the FlatBendResults collection object that contains information about all the bends in the flat pattern.

Visual Basic
Property FlatBendResults() As FlatBendResults**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.FlatBendResults Property


FlatPattern.FlatPunchResults Property

FlatPattern.FlatPunchResults Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the FlatPunchResults collection object that contains information about all the punches in the flat pattern.

Visual Basic
Property FlatPunchResults() As FlatPunchResults**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.FlatPunchResults Property


FlatPattern.GraphicsDataSetsCollection Property

FlatPattern.GraphicsDataSetsCollection Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property GraphicsDataSetsCollection() As GraphicsDataSetsCollection**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.GraphicsDataSetsCollection Property


FlatPattern.Length Property

FlatPattern.Length Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the length of the flat pattern.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Length Property


FlatPattern.MassProperties Property

FlatPattern.MassProperties Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the MassProperties object for the flat pattern.

Visual Basic
Property MassProperties() As MassProperties**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.MassProperties Property


FlatPattern.Parameters Property

FlatPattern.Parameters Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the set of parameters for the flat pattern.

Visual Basic
Property Parameters() As Parameters**
Remarks

These are a different set of properties than those accessed through the Paramaters collection obtained from the SheetMetalComponentDefinition object and are exclusive to the flat pattern. The sheet metal specific parameters, (Thickness, BendRadius, etc.) are available in this collection as reference parameters.

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Parameters Property


FlatPattern.Parent Property

FlatPattern.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent SheetMetalComponentDefinition object.

Visual Basic
Property Parent() As SheetMetalComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Parent Property


FlatPattern.PartEvents Property

FlatPattern.PartEvents Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the PartEvents object associated with the flat pattern. This object will fire events for changes that occur to the flat pattern.

Visual Basic
Property PartEvents() As PartEvents**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.PartEvents Property


FlatPattern.PunchRepresentationType Property

FlatPattern.PunchRepresentationType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the punch representation to use for the flat pattern.

Visual Basic
Property PunchRepresentationType() As PunchRepresentationTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.PunchRepresentationType Property


FlatPattern.RepresentationsManager Property

FlatPattern.RepresentationsManager Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the RepresentationsManager object.

Visual Basic
Property RepresentationsManager() As RepresentationsManager**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.RepresentationsManager Property


FlatPattern.RolledBackForEdit Property

FlatPattern.RolledBackForEdit Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets whether the flat pattern model is currently rolled back to a previous point in the feature history.

Visual Basic
Property RolledBackForEdit() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.RolledBackForEdit Property


FlatPattern.SketchBlockDefinitions Property

FlatPattern.SketchBlockDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the SketchBlockDefinitions collection object.

Visual Basic
Property SketchBlockDefinitions() As SketchBlockDefinitions**
See Also

Create and insert a sketch block definition into a part sketch sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.SketchBlockDefinitions Property


FlatPattern.Sketches Property

FlatPattern.Sketches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the PlanarSketches collection object that encapsulates all of the planar sketches defined in this ComponentDefinition.

Visual Basic
Property Sketches() As PlanarSketches**
See Also

Set Sketch Visibility sample

Create sheet metal face and cut features sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Add a decal feature sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Sketches Property


FlatPattern.Sketches3D Property

FlatPattern.Sketches3D Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary
Visual Basic
Property Sketches3D() As Sketches3D**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Sketches3D Property


FlatPattern.TopFace Property

FlatPattern.TopFace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns top face of the flat pattern.

Visual Basic
Property TopFace() As Face**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.TopFace Property


FlatPattern.UserCoordinateSystems Property

FlatPattern.UserCoordinateSystems Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the UserCoordinateSystems collection object.

Visual Basic
Property UserCoordinateSystems() As UserCoordinateSystems**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.UserCoordinateSystems Property


FlatPattern.Width Property

FlatPattern.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the width of the flat pattern.

Visual Basic
Property Width() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.Width Property


FlatPattern.WorkAxes Property

FlatPattern.WorkAxes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns that collection object that provides access to all of the existing work axis objects in the flat pattern and provides the functionality to create new work axis objects.

Visual Basic
Property WorkAxes() As WorkAxes**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.WorkAxes Property


FlatPattern.WorkPlanes Property

FlatPattern.WorkPlanes Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns that collection object that provides access to all of the existing work plane objects in the flat pattern and provides the functionality to create new work plane objects.

Visual Basic
Property WorkPlanes() As WorkPlanes**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.WorkPlanes Property


FlatPattern.WorkPoints Property

FlatPattern.WorkPoints Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns that collection object that provides access to all of the existing work point objects in the flat pattern and provides the functionality to create new work point objects.

Visual Basic
Property WorkPoints() As WorkPoints**
You are here: Symbol Reference > Inventor Library > Objects > FlatPattern Interface > FlatPattern Properties > FlatPattern.WorkPoints Property


FlatPatternFeatures Interface

FlatPatternFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The FlatPatternFeatures object represents a collection of FlatPatternFeature objects.

Class Hierarchy
Inventor::FlatPatternFeatures
Visual Basic
Public Interface FlatPatternFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPattern.Features

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface


FlatPatternFeatures Methods

FlatPatternFeatures Methods
Summary

The methods of the FlatPatternFeatures class are listed here.

Methods
Methods
Name | Description
CreatePath |
Item | Property that returns the specified PartFeature object from the collection. This is limited to the features within the flat pattern.
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Methods


FlatPatternFeatures.CreatePath Method

FlatPatternFeatures.CreatePath Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary
Visual Basic
Sub CreatePath(SketchCurve As IDispatch, Result As [out, retval] Path*)
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Methods > FlatPatternFeatures.CreatePath Method


FlatPatternFeatures.Item Method

FlatPatternFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified PartFeature object from the collection. This is limited to the features within the flat pattern.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartFeature*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the PartFeature to return. This can be a numeric value indicating the index of the item in the collection or it can be a string indicating the Name of the feature. If an out of range index is provided or the name does not match an existing feature an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Methods > FlatPatternFeatures.Item Method


FlatPatternFeatures Properties

FlatPatternFeatures Properties
Summary

The properties of the FlatPatternFeatures class are listed here.

Properties
Name | Description
Application |
ChamferFeatures | Property that returns the ChamferFeatures collection object. This collection provides access to existing ChamferFeature objects and provides functionality to create new ChamferFeature objects.
CircularPatternFeatures | Property that returns the CornerChamferFeatures collection object.
CornerChamferFeatures | Property that returns the CornerChamferFeatures collection object.
CornerRoundFeatures | Property that returns the CornerRoundFeatures collection object.
CosmeticBendFeatures | Returns the CosmeticBendFeatures collection object.
Count | Property that returns the number of features in the flat pattern.
CutFeatures | Property that returns the CutFeatures object.
EmbossFeatures |
ExtrudeFeatures | Property that returns the collection object. This collection provides access to existing ExtrudeFeature objects and provides functionality to create new ExtrudeFeature objects.
FilletFeatures | Property that returns the FilletFeatures collection object. This collection provides access to existing FilletFeature objects and provides functionality to create new FilletFeature objects.
HoleFeatures | Property that returns the HoleFeatures collection object. This collection provides access to existing HoleFeature objects and provides functionality to create new HoleFeature objects.
iFeatures | Property that returns the iFeatures collection object.
MirrorFeatures | Property that returns the MirrorFeatures collection object. This collection provides access to existing MirrorFeature objects and provides functionality to create new MirrorFeature objects.
PunchToolFeatures | Property that returns the PunchToolFeatures collection object.
RectangularPatternFeatures | Property that returns the RectangularPatternFeatures collection object. This collection provides access to existing RectangularPatternFeature objects and provides functionality to create new RectangularPatternFeature objects.
RevolveFeatures | Property that returns the RevolveFeatures collection object. This collection provides access to existing RevolveFeature objects and provides functionality to create new RevolveFeature objects.
SweepFeatures | Property that returns the SweepFeatures collection object. This collection provides access to existing SweepFeature objects and provides functionality to create new SweepFeature objects.
Type | Property returning kFlatPatternFeatuersObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties


FlatPatternFeatures.Application Property

FlatPatternFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary
Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.Application Property


FlatPatternFeatures.ChamferFeatures Property

FlatPatternFeatures.ChamferFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ChamferFeatures collection object. This collection provides access to existing ChamferFeature objects and provides functionality to create new ChamferFeature objects.

Visual Basic
Property ChamferFeatures() As ChamferFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.ChamferFeatures Property


FlatPatternFeatures.CircularPatternFeatures Property

FlatPatternFeatures.CircularPatternFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CornerChamferFeatures collection object.

Visual Basic
Property CircularPatternFeatures() As CircularPatternFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.CircularPatternFeatures Property


FlatPatternFeatures.CornerChamferFeatures Property

FlatPatternFeatures.CornerChamferFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CornerChamferFeatures collection object.

Visual Basic
Property CornerChamferFeatures() As CornerChamferFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.CornerChamferFeatures Property


FlatPatternFeatures.CornerRoundFeatures Property

FlatPatternFeatures.CornerRoundFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CornerRoundFeatures collection object.

Visual Basic
Property CornerRoundFeatures() As CornerRoundFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.CornerRoundFeatures Property


FlatPatternFeatures.CosmeticBendFeatures Property

FlatPatternFeatures.CosmeticBendFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns the CosmeticBendFeatures collection object.

Visual Basic
Property CosmeticBendFeatures() As CosmeticBendFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.CosmeticBendFeatures Property


FlatPatternFeatures.Count Property

FlatPatternFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of features in the flat pattern.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.Count Property


FlatPatternFeatures.CutFeatures Property

FlatPatternFeatures.CutFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CutFeatures object.

Visual Basic
Property CutFeatures() As CutFeatures**
See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.CutFeatures Property


FlatPatternFeatures.EmbossFeatures Property

FlatPatternFeatures.EmbossFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary
Visual Basic
Property EmbossFeatures() As EmbossFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.EmbossFeatures Property


FlatPatternFeatures.ExtrudeFeatures Property

FlatPatternFeatures.ExtrudeFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection object. This collection provides access to existing ExtrudeFeature objects and provides functionality to create new ExtrudeFeature objects.

Visual Basic
Property ExtrudeFeatures() As ExtrudeFeatures**
See Also

Thread Feature Create sample

Extrude Feature - Create Block with Pocket sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.ExtrudeFeatures Property


FlatPatternFeatures.FilletFeatures Property

FlatPatternFeatures.FilletFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the FilletFeatures collection object. This collection provides access to existing FilletFeature objects and provides functionality to create new FilletFeature objects.

Visual Basic
Property FilletFeatures() As FilletFeatures**
See Also

Fillet Feature (Complex) sample

Fillet Feature (All Rounds) sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.FilletFeatures Property


FlatPatternFeatures.HoleFeatures Property

FlatPatternFeatures.HoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the HoleFeatures collection object. This collection provides access to existing HoleFeature objects and provides functionality to create new HoleFeature objects.

Visual Basic
Property HoleFeatures() As HoleFeatures**
See Also

Hole feature linear placement sample

Hole Feature - Through holes (RegularAndTapped) sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.HoleFeatures Property


FlatPatternFeatures.iFeatures Property

FlatPatternFeatures.iFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the iFeatures collection object.

Visual Basic
Property iFeatures() As iFeatures**
See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.iFeatures Property


FlatPatternFeatures.MirrorFeatures Property

FlatPatternFeatures.MirrorFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the MirrorFeatures collection object. This collection provides access to existing MirrorFeature objects and provides functionality to create new MirrorFeature objects.

Visual Basic
Property MirrorFeatures() As MirrorFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.MirrorFeatures Property


FlatPatternFeatures.PunchToolFeatures Property

FlatPatternFeatures.PunchToolFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the PunchToolFeatures collection object.

Visual Basic
Property PunchToolFeatures() As PunchToolFeatures**
See Also

Add a punch tool feature sample

Report on punch feature ID's sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.PunchToolFeatures Property


FlatPatternFeatures.RectangularPatternFeatures Property

FlatPatternFeatures.RectangularPatternFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the RectangularPatternFeatures collection object. This collection provides access to existing RectangularPatternFeature objects and provides functionality to create new RectangularPatternFeature objects.

Visual Basic
Property RectangularPatternFeatures() As RectangularPatternFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.RectangularPatternFeatures Property


FlatPatternFeatures.RevolveFeatures Property

FlatPatternFeatures.RevolveFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the RevolveFeatures collection object. This collection provides access to existing RevolveFeature objects and provides functionality to create new RevolveFeature objects.

Visual Basic
Property RevolveFeatures() As RevolveFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.RevolveFeatures Property


FlatPatternFeatures.SweepFeatures Property

FlatPatternFeatures.SweepFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the SweepFeatures collection object. This collection provides access to existing SweepFeature objects and provides functionality to create new SweepFeature objects.

Visual Basic
Property SweepFeatures() As SweepFeatures**
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.SweepFeatures Property


FlatPatternFeatures.Type Property

FlatPatternFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kFlatPatternFeatuersObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlatPatternFeatures Interface > FlatPatternFeatures Properties > FlatPatternFeatures.Type Property


FlatPunchResult Interface

FlatPunchResult Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The FlatPunchResult object represents a single punch instance in the flat. A punch instance can result from a punch tool feature placed either in the folded model or in the flat pattern. A punch tool feature may define multiple punches, and every one of the resulting punch instances is represented by a FlatPunchResult object.

Class Hierarchy
Inventor::FlatPunchResult
Visual Basic
Public Interface FlatPunchResult
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPunchResults.Item

You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface


FlatPunchResult Properties

FlatPunchResult Properties
Summary

The properties of the FlatPunchResult class are listed here.

Properties
Name | Description
Angle | Property that returns an angle value indicating the punch orientation. This property may return an error if this information is not available.
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Depth | Property that returns the depth of the punch.
Faces | Property that returns the faces in the flat pattern that belong to the punch result. This property returns Nothing if punch representation is not formed feature representation.
FoldedAngle | Property that returns an angle value indicating the punch orientation in the folded model.
FoldedPosition | Property that returns a Point indicating the position of the punch instance in the folded model.
HasDepth | Gets whether there is a depth value associated with this punch result.
InternalName | Property that returns a string that uniquely identifies a punch instance within the flat pattern.
IsDirectionUp | Property that whether the direction of the punch is up or down.
IsPunchAfterStopNode | Property that returns whether the punch feature that resulted in this punch result is currently after the stop node.
IsPunchSuppressed | Property that returns whether the punch feature that resulted in this punch result is currently suppressed.
Parent | Property that returns the parent FlatPattern object.
Position | Property that returns a Point indicating the position of the punch instance in the flat pattern. This property may return Nothing if this information is not available.
PunchId | Property that returns the Id associated with the punch result. This is the Id assigned during creation of the punch feature and is the same for all instances of a punch feature.
SketchRepresentationEdges | Property that returns the edges in the flat pattern that belong to the punch result. The property will return Nothing if the punch tool feature that resulted in this punch result does not have a sketch-based alternate representation defined for it.
Type | Property returning kFlatPunchResultObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties


FlatPunchResult.Angle Property

FlatPunchResult.Angle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns an angle value indicating the punch orientation. This property may return an error if this information is not available.

Visual Basic
Property Angle() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Angle Property


FlatPunchResult.Application Property

FlatPunchResult.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Application Property


FlatPunchResult.Depth Property

FlatPunchResult.Depth Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the depth of the punch.

Visual Basic
Property Depth() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Depth Property


FlatPunchResult.Faces Property

FlatPunchResult.Faces Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the faces in the flat pattern that belong to the punch result. This property returns Nothing if punch representation is not formed feature representation.

Visual Basic
Property Faces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Faces Property


FlatPunchResult.FoldedAngle Property

FlatPunchResult.FoldedAngle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns an angle value indicating the punch orientation in the folded model.

Visual Basic
Property FoldedAngle() As double*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.FoldedAngle Property


FlatPunchResult.FoldedPosition Property

FlatPunchResult.FoldedPosition Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns a Point indicating the position of the punch instance in the folded model.

Visual Basic
Property FoldedPosition() As Point**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.FoldedPosition Property


FlatPunchResult.HasDepth Property

FlatPunchResult.HasDepth Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets whether there is a depth value associated with this punch result.

Visual Basic
Property HasDepth() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.HasDepth Property


FlatPunchResult.InternalName Property

FlatPunchResult.InternalName Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns a string that uniquely identifies a punch instance within the flat pattern.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.InternalName Property


FlatPunchResult.IsDirectionUp Property

FlatPunchResult.IsDirectionUp Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that whether the direction of the punch is up or down.

Visual Basic
Property IsDirectionUp() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.IsDirectionUp Property


FlatPunchResult.IsPunchAfterStopNode Property

FlatPunchResult.IsPunchAfterStopNode Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the punch feature that resulted in this punch result is currently after the stop node.

Visual Basic
Property IsPunchAfterStopNode() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.IsPunchAfterStopNode Property


FlatPunchResult.IsPunchSuppressed Property

FlatPunchResult.IsPunchSuppressed Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the punch feature that resulted in this punch result is currently suppressed.

Visual Basic
Property IsPunchSuppressed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.IsPunchSuppressed Property


FlatPunchResult.Parent Property

FlatPunchResult.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent FlatPattern object.

Visual Basic
Property Parent() As FlatPattern**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Parent Property


FlatPunchResult.Position Property

FlatPunchResult.Position Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns a Point indicating the position of the punch instance in the flat pattern. This property may return Nothing if this information is not available.

Visual Basic
Property Position() As Point**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Position Property


FlatPunchResult.PunchId Property

FlatPunchResult.PunchId Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the Id associated with the punch result. This is the Id assigned during creation of the punch feature and is the same for all instances of a punch feature.

Visual Basic
Property PunchId() As BSTR*
See Also

Report on punch feature ID's sample

You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.PunchId Property


FlatPunchResult.SketchRepresentationEdges Property

FlatPunchResult.SketchRepresentationEdges Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the edges in the flat pattern that belong to the punch result. The property will return Nothing if the punch tool feature that resulted in this punch result does not have a sketch-based alternate representation defined for it.

Visual Basic
Property SketchRepresentationEdges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.SketchRepresentationEdges Property


FlatPunchResult.Type Property

FlatPunchResult.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kFlatPunchResultObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResult Interface > FlatPunchResult Properties > FlatPunchResult.Type Property


FlatPunchResults Interface

FlatPunchResults Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The FlatPunchResults collection object contains information about all the resulting punches in the flat pattern.

Class Hierarchy
Inventor::FlatPunchResults
Visual Basic
Public Interface FlatPunchResults
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPattern.FlatPunchResults

You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface


FlatPunchResults Methods

FlatPunchResults Methods
Summary

The methods of the FlatPunchResults class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified FlatPunchResult object from the collection
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface > FlatPunchResults Methods


FlatPunchResults.Item Method

FlatPunchResults.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified FlatPunchResult object from the collection

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FlatPunchResult*)
Parameters
Parameters | Description
index | Input Variant value that specifies the FlatPunchResult to return. This can be a numeric value indicating the index of the item in the collection, an Edge or a Face object that belongs to the resulting punch or it can be a string indicating the InternalName of the punch. If an out of range index is provided or the InternalName of a non-existing punch is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface > FlatPunchResults Methods > FlatPunchResults.Item Method


FlatPunchResults Properties

FlatPunchResults Properties
Summary

The properties of the FlatPunchResults class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that returns the number of items in the collection.
Type | Property returning kFlatPunchResultsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface > FlatPunchResults Properties


FlatPunchResults.Application Property

FlatPunchResults.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface > FlatPunchResults Properties > FlatPunchResults.Application Property


FlatPunchResults.Count Property

FlatPunchResults.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface > FlatPunchResults Properties > FlatPunchResults.Count Property


FlatPunchResults.Type Property

FlatPunchResults.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning kFlatPunchResultsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FlatPunchResults Interface > FlatPunchResults Properties > FlatPunchResults.Type Property


FlushConstraint Interface

FlushConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a flush assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::FlushConstraint
        Inventor::FlushConstraintProxy
Visual Basic
Public Interface FlushConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToFlushConstraint

AssemblyConstraints.AddFlushConstraint

FlushConstraintProxy.NativeObject

LayoutConstraint.XYFlushConstraint

LayoutConstraint.XZFlushConstraint

LayoutConstraint.YZFlushConstraint

You are here: Symbol Reference > Inventor Library > Objects > FlushConstraint Interface


FlushConstraint Properties

FlushConstraint Properties
Summary

The properties of the FlushConstraint class are listed here.

Properties
Name | Description
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.
Offset | Property that returns the Parameter object that controls the offset distance of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > FlushConstraint Interface > FlushConstraint Properties


FlushConstraint.ConstraintLimits Property

FlushConstraint.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > FlushConstraint Interface > FlushConstraint Properties > FlushConstraint.ConstraintLimits Property


FlushConstraint.Offset Property

FlushConstraint.Offset Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Parameter object that controls the offset distance of the constraint.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FlushConstraint Interface > FlushConstraint Properties > FlushConstraint.Offset Property


FlushConstraintProxy Interface

FlushConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FlushConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::FlushConstraint
        Inventor::FlushConstraintProxy
Visual Basic
Public Interface FlushConstraintProxy
Inherits FlushConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FlushConstraintProxy Interface


FlushConstraintProxy Properties

FlushConstraintProxy Properties
Summary

The properties of the FlushConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FlushConstraintProxy Interface > FlushConstraintProxy Properties


FlushConstraintProxy.ContainingOccurrence Property

FlushConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FlushConstraintProxy Interface > FlushConstraintProxy Properties > FlushConstraintProxy.ContainingOccurrence Property


FlushConstraintProxy.NativeObject Property

FlushConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As FlushConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FlushConstraintProxy Interface > FlushConstraintProxy Properties > FlushConstraintProxy.NativeObject Property


FlushiMateDefinition Interface

FlushiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The FlushiMateDefinition object represents a flush iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::FlushiMateDefinition
        Inventor::FlushiMateDefinitionProxy
Visual Basic
Public Interface FlushiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddFlushiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinition Interface


FlushiMateDefinition Properties

FlushiMateDefinition Properties
Summary

The properties of the FlushiMateDefinition class are listed here.

Properties
Name | Description
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.
Entity | Property that returns the entity used for the iMate definition.
Offset | Property that returns the Parameter object that controls the offset of the flush iMate definition.
You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinition Interface > FlushiMateDefinition Properties


FlushiMateDefinition.ConstraintLimits Property

FlushiMateDefinition.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinition Interface > FlushiMateDefinition Properties > FlushiMateDefinition.ConstraintLimits Property


FlushiMateDefinition.Entity Property

FlushiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinition Interface > FlushiMateDefinition Properties > FlushiMateDefinition.Entity Property


FlushiMateDefinition.Offset Property

FlushiMateDefinition.Offset Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the offset of the flush iMate definition.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinition Interface > FlushiMateDefinition Properties > FlushiMateDefinition.Offset Property


FlushiMateDefinitionProxy Interface

FlushiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FlushiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::FlushiMateDefinition
        Inventor::FlushiMateDefinitionProxy
Visual Basic
Public Interface FlushiMateDefinitionProxy
Inherits FlushiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinitionProxy Interface


FlushiMateDefinitionProxy Properties

FlushiMateDefinitionProxy Properties
Summary

The properties of the FlushiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinitionProxy Interface > FlushiMateDefinitionProxy Properties


FlushiMateDefinitionProxy.ContainingOccurrence Property

FlushiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinitionProxy Interface > FlushiMateDefinitionProxy Properties > FlushiMateDefinitionProxy.ContainingOccurrence Property


FlushiMateDefinitionProxy.IsConsumed Property

FlushiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinitionProxy Interface > FlushiMateDefinitionProxy Properties > FlushiMateDefinitionProxy.IsConsumed Property


FlushiMateDefinitionProxy.NativeObject Property

FlushiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > FlushiMateDefinitionProxy Interface > FlushiMateDefinitionProxy Properties > FlushiMateDefinitionProxy.NativeObject Property


FoldDefinition Interface

FoldDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FoldDefinition object represents all of the information that defines a fold feature.

Class Hierarchy
Inventor::FoldDefinition
Visual Basic
Public Interface FoldDefinition
Inherits IDispatch
Remarks

The FoldDefinition object is used in two ways. First it is used as input when creating a fold feature. Second it is used to query and edit existing fold features. When creating a new fold feature you use the FoldFeatures.CreateFoldDefinition method to create a new FoldDefinition object. Using the properties of this object you can define the various options of the fold feature. Typically a new FoldDefinition object is created and modified to get the desired fold feature and then used as input to the FoldFeatures.Add method. An existing FoldFeature object is edited by modifying its associated FoldDefinition object.

Notes

Members through which this object may be accessed include:

FoldDefinition.Copy

FoldFeature.Definition

FoldFeatures.CreateFoldDefinition

See Also

Create sheet metal face and fold features sample

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface


FoldDefinition Methods

FoldDefinition Methods
Summary

The methods of the FoldDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Function that creates a copy of this FoldDefinition object. The copy is independent of any fold feature and can be edited without affecting anything else. It can then be used as input to edit an existing fold feature or create a new fold feature.
You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Methods


FoldDefinition.Copy Method

FoldDefinition.Copy Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Function that creates a copy of this FoldDefinition object. The copy is independent of any fold feature and can be edited without affecting anything else. It can then be used as input to edit an existing fold feature or create a new fold feature.

Visual Basic
Sub Copy(Result As [out, retval] FoldDefinition*)
Remarks

Any of the properties of the FoldDefinition that can reference a Parameter object will behave differently depending on if the FoldDefinition is independent or associated with a FoldFeature object. When it is associated these properties behave as read-only and will return the associated Parameter object. When it is independent these properties behave as read-write and will accept and return Doubles and Strings to define the value.

One use of this is when you need to make several edits to an existing fold feature. If you edit the FoldDefinition object associated with the fold feature, the feature will recompute after each edit. Instead you can make a copy, edit the copy, and then set the fold feature to use the copy. This will result in a single recompute.

The FoldFeatures.CreateFoldDefinition method can also be used to create an independent FoldDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateFoldDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Methods > FoldDefinition.Copy Method


FoldDefinition Properties

FoldDefinition Properties
Summary

The properties of the FoldDefinition class are listed here.

Properties
Name | Description
Application | Returns the Application object.
BendAngle | Property that provides access to the bend angle of a sheet metal fold feature.
BendLine | Property that gets and sets the SketchLine object that defines the location of the bend line.
BendLocation | Property that gets and sets the position of the bend with respect to the bend line.
BendOptions | Property that gets the BendOptions object that defines the bend options for this bend feature.
BendRadius | Property that provides access to the bend radius of a sheet metal fold feature.
IsPositiveBendDirection | Property that gets and sets whether the direction of the fold is in the positive or negative direction.
IsPositiveBendSide | Property that gets and sets whether the flip direction is positive or negative.
IsUnfoldMethodOverridden | Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.
Parent | Property that returns the parent FoldFeature object of this FoldDefinition object.
Type | Property returning enum indicating this object's type.
UnfoldMethod | Property that gets and set the UnfoldMethod object that defines how this bend is unfolded.
You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties


FoldDefinition.Application Property

FoldDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.Application Property


FoldDefinition.BendAngle Property

FoldDefinition.BendAngle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend angle of a sheet metal fold feature.

Visual Basic
Property BendAngle() As VARIANT
Remarks

This property is writable when the FoldDefinition object has been created using the CreateFoldDefinition or FoldDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendAngle * 2' is valid, assuming there is a parameter named MyBendAngle. When the FoldDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend angle. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.BendAngle Property


FoldDefinition.BendLine Property

FoldDefinition.BendLine Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the SketchLine object that defines the location of the bend line.

Visual Basic
Property BendLine() As SketchLine*
Remarks

The bend line must be on the face being folded, and must terminate at the edges of the face.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.BendLine Property


FoldDefinition.BendLocation Property

FoldDefinition.BendLocation Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the bend with respect to the bend line.

Visual Basic
Property BendLocation() As BendLocationEnum
Remarks

Valid values are kCenterlineOfBend, kStartOfBend, and kEndOfBend. When a new FoldDefinition object is created using the FoldFeatures.CreateFoldDefinition method this value is initialized to kCenterlineOfBend.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.BendLocation Property


FoldDefinition.BendOptions Property

FoldDefinition.BendOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the BendOptions object that defines the bend options for this bend feature.

Visual Basic
Property BendOptions() As BendOptions*
Remarks

Modifying this BendOptions object will cause the fold feature to update.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.BendOptions Property


FoldDefinition.BendRadius Property

FoldDefinition.BendRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that provides access to the bend radius of a sheet metal fold feature.

Visual Basic
Property BendRadius() As VARIANT
Remarks

This property is writable when the FoldDefinition object has been created using the CreateFoldDefinition or FoldDefinition.Copy method. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendRadius * 2' is valid, assuming there is a parameter named MyBendRadius. When the FoldDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend radius. In this case, you can use the properties of the parameter object to change the value. When a new FoldDefinition object is created using the FoldFeatures.CreateFoldDefinition method this value is initialized to the bend radius defined by the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.BendRadius Property


FoldDefinition.IsPositiveBendDirection Property

FoldDefinition.IsPositiveBendDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the direction of the fold is in the positive or negative direction.

Visual Basic
Property IsPositiveBendDirection() As VARIANT_BOOL
Remarks

A value of True indicates a positive bend direction which is in the direction of the normal of the face that the bend line lies on. When a new FoldDefinition object is created using the FoldFeatures.CreateFoldDefinition method this value is initialized to True.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.IsPositiveBendDirection Property


FoldDefinition.IsPositiveBendSide Property

FoldDefinition.IsPositiveBendSide Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the flip direction is positive or negative.

Visual Basic
Property IsPositiveBendSide() As VARIANT_BOOL
Remarks

A value of True indicates a positive flip direction which means the portion of the model to the right of the bend line will maintain its position while the portion of the model to the left of the bend line will bend up or down. Left or right of the bend line is determined by walking down the sketch line from the start to the end point. When a new FoldDefinition object is created using the FoldFeatures.CreateFoldDefinition method this value is initialized to True.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.IsPositiveBendSide Property


FoldDefinition.IsUnfoldMethodOverridden Property

FoldDefinition.IsUnfoldMethodOverridden Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.

Visual Basic
Property IsUnfoldMethodOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.IsUnfoldMethodOverridden Property


FoldDefinition.Parent Property

FoldDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent FoldFeature object of this FoldDefinition object.

Visual Basic
Property Parent() As FoldFeature**
Remarks

In the case where this is a newly created FoldDefinition object or it has been copied from an existing FoldDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.Parent Property


FoldDefinition.Type Property

FoldDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.Type Property


FoldDefinition.UnfoldMethod Property

FoldDefinition.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the UnfoldMethod object that defines how this bend is unfolded.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
You are here: Symbol Reference > Inventor Library > Objects > FoldDefinition Interface > FoldDefinition Properties > FoldDefinition.UnfoldMethod Property


FoldFeature Interface

FoldFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FoldFeature object represents a sheet metal fold feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::FoldFeature
        Inventor::FoldFeatureProxy
Visual Basic
Public Interface FoldFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

FoldDefinition.Parent

FoldFeatures.Add

FoldFeatures.Item

See Also

Create sheet metal face and fold features sample

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > FoldFeature Interface


FoldFeature Properties

FoldFeature Properties
Summary

The properties of the FoldFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the FoldDefinition object associated with this fold feature.
You are here: Symbol Reference > Inventor Library > Objects > FoldFeature Interface > FoldFeature Properties


FoldFeature.Definition Property

FoldFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the FoldDefinition object associated with this fold feature.

Visual Basic
Property Definition() As FoldDefinition*
Remarks

Modifying the FoldDefinition object will edit the associated FoldFeature. You can also modify the fold feature by assigning a new FoldDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > FoldFeature Interface > FoldFeature Properties > FoldFeature.Definition Property


FoldFeatureProxy Interface

FoldFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the FoldFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::FoldFeature
        Inventor::FoldFeatureProxy
Visual Basic
Public Interface FoldFeatureProxy
Inherits FoldFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > FoldFeatureProxy Interface


FoldFeatures Interface

FoldFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The FoldFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::FoldFeatures
Visual Basic
Public Interface FoldFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.FoldFeatures

See Also

Create sheet metal face and fold features sample

You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface


FoldFeatures Methods

FoldFeatures Methods
Summary

The methods of the FoldFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new fold feature. The newly created CutFeature object is returned.
CreateFoldDefinition | Method that creates a new FoldDefinition object.
Item | Property that returns the specified FoldFeature object from the collection. This is the default property of the FoldFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Methods


FoldFeatures.Add Method

FoldFeatures.Add Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new fold feature. The newly created CutFeature object is returned.

Visual Basic
Sub Add(FoldDefinition As FoldDefinition, Result As [out, retval] FoldFeature*)
Parameters
Parameters | Description
FoldDefinition | Input FoldDefinition object that defines the fold feature you want to create. A FoldDefinition object can be created using the FoldFeatures.CreateFoldDefinition method. It can also be obtained from an existing FoldFeature object.
Example

Create sheet metal face and fold features example.

This sample demonstrates the creation of sheet metal face and fold features.

Public Sub FaceAndFoldFeatureCreation()
    ' Create a new sheet metal document, using the default sheet metal template.
    Dim oSheetMetalDoc As PartDocument
    Set oSheetMetalDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject, , , "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}"))

    ' Set a reference to the component definition.
    Dim oCompDef As SheetMetalComponentDefinition
    Set oCompDef = oSheetMetalDoc.ComponentDefinition

    ' Set a reference to the sheet metal features collection.
    Dim oSheetMetalFeatures As SheetMetalFeatures
    Set oSheetMetalFeatures = oCompDef.Features

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    Dim oFaceFeatureDefinition As FaceFeatureDefinition
    Set oFaceFeatureDefinition = oSheetMetalFeatures.FaceFeatures.CreateFaceFeatureDefinition(oProfile)

    ' Create a face feature.
    Dim oFaceFeature As FaceFeature
    Set oFaceFeature = oSheetMetalFeatures.FaceFeatures.Add(oFaceFeatureDefinition)

    ' Get the top face for creating the new sketch.
    ' We'll assume that the 6th face is the top face.
    Dim oFrontFace As Face
    Set oFrontFace = oFaceFeature.Faces.Item(6)

    ' Create a new sketch on the top face.
    Dim oFoldLineSketch As PlanarSketch
    Set oFoldLineSketch = oCompDef.Sketches.Add(oFrontFace)

    ' The end points of the sketch line must lie on an edge

    Dim oEdge1MidPoint As Point
    Set oEdge1MidPoint = oFrontFace.Edges(1).Geometry.MidPoint

    Dim oSketchPoint1 As Point2d
    Set oSketchPoint1 = oFoldLineSketch.ModelToSketchSpace(oEdge1MidPoint)

    Dim oEdge2MidPoint As Point
    Set oEdge2MidPoint = oFrontFace.Edges(3).Geometry.MidPoint

    Dim oSketchPoint2 As Point2d
    Set oSketchPoint2 = oFoldLineSketch.ModelToSketchSpace(oEdge2MidPoint)

    ' Create the fold line between the midpoint of two opposite edges on the face
    Dim oFoldLine As SketchLine
    Set oFoldLine = oFoldLineSketch.SketchLines.AddByTwoPoints(oSketchPoint1, oSketchPoint2)

    Dim oFoldDefinition As FoldDefinition
    Set oFoldDefinition = oSheetMetalFeatures.FoldFeatures.CreateFoldDefinition(oFoldLine, "60 deg")

    ' Create a fold feature
    Dim oFoldFeature As FoldFeature
    Set oFoldFeature = oSheetMetalFeatures.FoldFeatures.Add(oFoldDefinition)

    ThisApplication.ActiveView.GoHome

End Sub
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Methods > FoldFeatures.Add Method


FoldFeatures.CreateFoldDefinition Method

FoldFeatures.CreateFoldDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new FoldDefinition object.

Visual Basic
Sub CreateFoldDefinition(BendLine As SketchLine, BendAngle As VARIANT, Result As [out, retval] FoldDefinition*)
Parameters
Parameters | Description
BendLine | Input SketchLine object that defines the location of the bend line. The bend line must be on the face you are folding, and must terminate at the edges of the face.
BendAngle | Input Variant that defines the bend angle. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
Remarks

This object is not a fold feature but contains the information that defines a fold feature and can be used to create a new fold feature or edit an existing one. The returned FoldDefinition can be used as input to the FoldFeatures.Add method to create a new fold feature. You can edit the properties of the FoldDefinition object before creating the fold feature to get the desired fold feature.

See Also

Create sheet metal face and fold features sample

You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Methods > FoldFeatures.CreateFoldDefinition Method


FoldFeatures.Item Method

FoldFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified FoldFeature object from the collection. This is the default property of the FoldFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] FoldFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Methods > FoldFeatures.Item Method


FoldFeatures Properties

FoldFeatures Properties
Summary

The properties of the FoldFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Properties


FoldFeatures.Application Property

FoldFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Properties > FoldFeatures.Application Property


FoldFeatures.Count Property

FoldFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Properties > FoldFeatures.Count Property


FoldFeatures.Type Property

FoldFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FoldFeatures Interface > FoldFeatures Properties > FoldFeatures.Type Property


FreeMoveDefinition Interface

FreeMoveDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The FreeMoveDefinition object defines all of the inputs that are unique to a move face feature defined using a transform.

Class Hierarchy
Inventor::FreeMoveDefinition
Visual Basic
Public Interface FreeMoveDefinition
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > FreeMoveDefinition Interface


FreeMoveDefinition Properties

FreeMoveDefinition Properties
Summary

The properties of the FreeMoveDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent MoveFaceDefinition object.
Transformation | Property that gets and sets the Matrix defining the free move transform of the faces. This property is initialized to an identity matrix when the MoveFaceDefinition is initially created.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > FreeMoveDefinition Interface > FreeMoveDefinition Properties


FreeMoveDefinition.Application Property

FreeMoveDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > FreeMoveDefinition Interface > FreeMoveDefinition Properties > FreeMoveDefinition.Application Property


FreeMoveDefinition.Parent Property

FreeMoveDefinition.Parent Property
Summary

Property that returns the parent MoveFaceDefinition object.

Visual Basic
Property Parent() As MoveFaceDefinition**
You are here: Symbol Reference > Inventor Library > Objects > FreeMoveDefinition Interface > FreeMoveDefinition Properties > FreeMoveDefinition.Parent Property


FreeMoveDefinition.Transformation Property

FreeMoveDefinition.Transformation Property
Summary

Property that gets and sets the Matrix defining the free move transform of the faces. This property is initialized to an identity matrix when the MoveFaceDefinition is initially created.

Visual Basic
Property Transformation() As Matrix*
You are here: Symbol Reference > Inventor Library > Objects > FreeMoveDefinition Interface > FreeMoveDefinition Properties > FreeMoveDefinition.Transformation Property


FreeMoveDefinition.Type Property

FreeMoveDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > FreeMoveDefinition Interface > FreeMoveDefinition Properties > FreeMoveDefinition.Type Property


FromToExtent Interface

FromToExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The FromToExtent object provides access to the information that defines the extent for a feature using 'from' and 'to' faces to define the extent.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::FromToExtent
Visual Basic
Public Interface FromToExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface


FromToExtent Properties

FromToExtent Properties
Summary

The properties of the FromToExtent class are listed here.

Properties
Name | Description
Direction | Property that gets and sets the direction of the feature. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
ExtendFromFace | Property that gets and sets whether the 'from face' should be extended to contain the extents of the feature. This property is not valid for every surface type.
ExtendToFace | Property that gets and sets whether the 'to face' should be extended to contain the extents of the feature. This property is not valid for every surface type.
FromFace | Property that gets and sets the face that defines the 'from' extents of the feature.
MinimumSolution | Property that gets and sets whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.
ToFace | Property that gets and sets the face that defines the 'to' extents of the feature.
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties


FromToExtent.Direction Property

FromToExtent.Direction Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the direction of the feature. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties > FromToExtent.Direction Property


FromToExtent.ExtendFromFace Property

FromToExtent.ExtendFromFace Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the 'from face' should be extended to contain the extents of the feature. This property is not valid for every surface type.

Visual Basic
Property ExtendFromFace() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties > FromToExtent.ExtendFromFace Property


FromToExtent.ExtendToFace Property

FromToExtent.ExtendToFace Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the 'to face' should be extended to contain the extents of the feature. This property is not valid for every surface type.

Visual Basic
Property ExtendToFace() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties > FromToExtent.ExtendToFace Property


FromToExtent.FromFace Property

FromToExtent.FromFace Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the face that defines the 'from' extents of the feature.

Visual Basic
Property FromFace() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties > FromToExtent.FromFace Property


FromToExtent.MinimumSolution Property

FromToExtent.MinimumSolution Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.

Visual Basic
Property MinimumSolution() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties > FromToExtent.MinimumSolution Property


FromToExtent.ToFace Property

FromToExtent.ToFace Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the face that defines the 'to' extents of the feature.

Visual Basic
Property ToFace() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > FromToExtent Interface > FromToExtent Properties > FromToExtent.ToFace Property


FromToWidthExtent Interface

FromToWidthExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The FromToWidthExtent is used by sheet metal features when the width of the feature is defined from one entity to another entity.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::FromToWidthExtent
Visual Basic
Public Interface FromToWidthExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > FromToWidthExtent Interface


FromToWidthExtent Properties

FromToWidthExtent Properties
Summary

The properties of the FromToWidthExtent class are listed here.

Properties
Name | Description
Edge | Property that gets the Edge object that the width is defined relative to.
FromEntity | Property that gets and set the entity that defines the 'from' extents of the feature.
ToEntity | Property that gets and set the entity that defines the 'to' extents of the feature.
You are here: Symbol Reference > Inventor Library > Objects > FromToWidthExtent Interface > FromToWidthExtent Properties


FromToWidthExtent.Edge Property

FromToWidthExtent.Edge Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the Edge object that the width is defined relative to.

Visual Basic
Property Edge() As Edge**
Remarks

This is the same edge that was selected to create the feature. When querying an existing feature this edge is not available because it was consumed when the sheet metal feature was created. This property returns Nothing in the case where the edge no longer exists in the model. Because of this, the end-of-part marker must be placed above the feature to allow access this edge.

You are here: Symbol Reference > Inventor Library > Objects > FromToWidthExtent Interface > FromToWidthExtent Properties > FromToWidthExtent.Edge Property


FromToWidthExtent.FromEntity Property

FromToWidthExtent.FromEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the entity that defines the 'from' extents of the feature.

Visual Basic
Property FromEntity() As IDispatch**
Remarks

This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.

You are here: Symbol Reference > Inventor Library > Objects > FromToWidthExtent Interface > FromToWidthExtent Properties > FromToWidthExtent.FromEntity Property


FromToWidthExtent.ToEntity Property

FromToWidthExtent.ToEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the entity that defines the 'to' extents of the feature.

Visual Basic
Property ToEntity() As IDispatch**
Remarks

This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.

You are here: Symbol Reference > Inventor Library > Objects > FromToWidthExtent Interface > FromToWidthExtent Properties > FromToWidthExtent.ToEntity Property


FullSweepExtent Interface

FullSweepExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The FullSweepExtent object suggests that a full, 360-degree sweep about an axis, is the definition of the extents on this feature.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::FullSweepExtent
Visual Basic
Public Interface FullSweepExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > FullSweepExtent Interface


GeneralDimension Interface

GeneralDimension Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The GeneralDimension object represents a general dimension placed on a sheet.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
        Inventor::AngularGeneralDimension
        Inventor::DiameterGeneralDimension
        Inventor::LinearGeneralDimension
        Inventor::RadiusGeneralDimension
Visual Basic
Public Interface GeneralDimension
Inherits DrawingDimension
Notes

Members through which this object may be accessed include:

GeneralDimensions.Item

GeneralDimensionsEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface


GeneralDimension Methods

GeneralDimension Methods
Summary

The methods of the GeneralDimension class are listed here.

Methods
Methods
Name | Description
PromoteToSketch | Method that copies the dimension to the underlying sketch. This method only works for dimensions associated with a draft view.
ShowAllExtensionLines | Method that un-hides all the extension lines associated with this dimension. If there are no hidden extension lines associated with this dimension, this method does nothing and returns a success.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Methods


GeneralDimension.PromoteToSketch Method

GeneralDimension.PromoteToSketch Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that copies the dimension to the underlying sketch. This method only works for dimensions associated with a draft view.

Visual Basic
Sub PromoteToSketch(Result As [out, retval] DimensionConstraint*)
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Methods > GeneralDimension.PromoteToSketch Method


GeneralDimension.ShowAllExtensionLines Method

GeneralDimension.ShowAllExtensionLines Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that un-hides all the extension lines associated with this dimension. If there are no hidden extension lines associated with this dimension, this method does nothing and returns a success.

Visual Basic
Sub ShowAllExtensionLines()
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Methods > GeneralDimension.ShowAllExtensionLines Method


GeneralDimension Properties

GeneralDimension Properties
Summary

The properties of the GeneralDimension class are listed here.

Properties
Name | Description
ArrowheadsInside | Property that gets and sets whether the arrowheads are inside or outside. This is a style override.
FirstArrowheadInside | Property that gets and sets whether the first arrowhead is inside or outside. This is a style override.
FirstArrowheadType | Property that gets and sets the type of the first arrowhead. This is a style override. This property cannot be set for the members of a baseline dimension set.
GeneralDimensionType | Returns an enum indicating the type of general dimension.
Retrieved | Property that indicates whether the dimension was created as a result of retrieving it either from the model or a drawing view sketch. If True, the RetrievedFrom property returns the object that the dimension was retrieved from.
RetrievedFrom | Property that returns the object that this dimension was retrieved from. Possible return objects include all sketch constraint objects that derive from DimensionConstraint and their proxies, FeatureDimension and FeatureDimensionProxy. The property returns Nothing if the Retrieved property returns False.
SecondArrowheadInside | Property that gets and sets whether the second arrowhead is inside or outside. This is a style override.
SecondArrowheadType | Property that gets and sets the type of the second arrowhead. This is a style override. This property returns an error and cannot be set for the following dimension types: members of a baseline dimension set, radius dimensions, diameter dimensions with the SingleDimensionLine property set to True, and linear diametric dimensions with the FullDimensionLine property is set to False.
Style | Property that gets and sets the dimension style used for this dimension. Setting a new style resets all the style-overriding properties on this object.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties


GeneralDimension.ArrowheadsInside Property

GeneralDimension.ArrowheadsInside Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether the arrowheads are inside or outside. This is a style override.

Visual Basic
Property ArrowheadsInside() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.ArrowheadsInside Property


GeneralDimension.FirstArrowheadInside Property

GeneralDimension.FirstArrowheadInside Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the first arrowhead is inside or outside. This is a style override.

Visual Basic
Property FirstArrowheadInside() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.FirstArrowheadInside Property


GeneralDimension.FirstArrowheadType Property

GeneralDimension.FirstArrowheadType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the type of the first arrowhead. This is a style override. This property cannot be set for the members of a baseline dimension set.

Visual Basic
Property FirstArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.FirstArrowheadType Property


GeneralDimension.GeneralDimensionType Property

GeneralDimension.GeneralDimensionType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns an enum indicating the type of general dimension.

Visual Basic
Property GeneralDimensionType() As GeneralDimensionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.GeneralDimensionType Property


GeneralDimension.Retrieved Property

GeneralDimension.Retrieved Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether the dimension was created as a result of retrieving it either from the model or a drawing view sketch. If True, the RetrievedFrom property returns the object that the dimension was retrieved from.

Visual Basic
Property Retrieved() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.Retrieved Property


GeneralDimension.RetrievedFrom Property

GeneralDimension.RetrievedFrom Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the object that this dimension was retrieved from. Possible return objects include all sketch constraint objects that derive from DimensionConstraint and their proxies, FeatureDimension and FeatureDimensionProxy. The property returns Nothing if the Retrieved property returns False.

Visual Basic
Property RetrievedFrom() As IDispatch**
Remarks

When circular geometry is projected onto a drawing such that the arc is perpendicular to the sheet, dimensions that would have been retrieved as type DiameterGeneralDimension prior to Inventor 2010 will now be of type LinearGeneralDimension, and will show a diameter symbol. Their Dimension.Type property will return kLinearGeneralDimensionObject, while their RetrievedFrom property will return kDiameterDimConstraintObject. Similarly, in the user interface, the Retrieve Dimensions command and the General Dimensions command will now both produce a linear dimension with diameter symbol, in situations where the arc diameter cannot be represented correctly.

You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.RetrievedFrom Property


GeneralDimension.SecondArrowheadInside Property

GeneralDimension.SecondArrowheadInside Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the second arrowhead is inside or outside. This is a style override.

Visual Basic
Property SecondArrowheadInside() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.SecondArrowheadInside Property


GeneralDimension.SecondArrowheadType Property

GeneralDimension.SecondArrowheadType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the type of the second arrowhead. This is a style override. This property returns an error and cannot be set for the following dimension types: members of a baseline dimension set, radius dimensions, diameter dimensions with the SingleDimensionLine property set to True, and linear diametric dimensions with the FullDimensionLine property is set to False.

Visual Basic
Property SecondArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.SecondArrowheadType Property


GeneralDimension.Style Property

GeneralDimension.Style Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the dimension style used for this dimension. Setting a new style resets all the style-overriding properties on this object.

Visual Basic
Property Style() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimension Interface > GeneralDimension Properties > GeneralDimension.Style Property


GeneralDimensions Interface

GeneralDimensions Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The GeneralDimensions collection object provides access to all of the general dimensions ( objects) on the sheet.

Class Hierarchy
Inventor::GeneralDimensions
Visual Basic
Public Interface GeneralDimensions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDimensions.GeneralDimensions

You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface


GeneralDimensions Methods

GeneralDimensions Methods
Summary

The methods of the GeneralDimensions class are listed here.

Methods
Methods
Name | Description
AddAngular | Method that creates an angular dimension. Valid intent combinations are Three points, Two non-parallel linear curves, One arc curve.
AddDiameter | Method that creates a diameter dimension.
AddLinear | Method that creates a linear dimension. Valid intent combinations are: Two points, Two curves, Point and a curve, One linear curve, One arc curve (with DimensionType set to kAlignedDimensionType for chord length and kArcLengthDimensionType for arc length).
AddRadius | Method that creates a radius dimension.
GetRetrievableDimensions | Method that returns a collection of objects that represent the valid set of model dimensions that can be retrieved into the input drawing view.
Item | Method that returns the specified dimension object from the collection.
Retrieve | Method that retrieves sketch and/or model dimensions into the drawing.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods


GeneralDimensions.AddAngular Method

GeneralDimensions.AddAngular Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates an angular dimension. Valid intent combinations are Three points, Two non-parallel linear curves, One arc curve.

Visual Basic
Sub AddAngular(TextOrigin As Point2d, IntentOne As GeometryIntent, ByRef IntentTwo As [optional] VARIANT, ByRef IntentThree As [optional] VARIANT, ByRef ArrowheadsInside As [defaultvalue(-1)] VARIANT_BOOL, ByRef UseQuadrant As [defaultvalue(-1)] VARIANT_BOOL, ByRef OppositeAngle As [defaultvalue(0)] VARIANT_BOOL, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] AngularGeneralDimension*)
Parameters
Parameters | Description
TextOrigin | Object that specifies the position of the dimension text on sheet.
IntentOne | Object that specifies the first geometry to dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IntentTwo | Object that specifies the second geometry to dimension. If three point intents are provided, this input indicates the apex point of the angle. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IntentThree | Object that specifies the third geometry to dimension. This argument must be specified if the first and second geometry intents are points. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
ArrowheadsInside | Indicates whether to place the dimension line arrows inside or outside. If not specified, this argument defaults to True indicating that arrowheads will be place inside (if possible).
UseQuadrant | Optional input Boolean that indicates whether to use the quadrant in which the input text point lies to decide which angle to dimension. If not specified, the argument defaults to True. If a single (arc) intent is provided as input, this argument is ignored and assumed to be False.
OppositeAngle | Indicates whether to dimension the opposite angle. If not specified, the argument defaults to False.
DimensionStyle | Object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.AddAngular Method


GeneralDimensions.AddDiameter Method

GeneralDimensions.AddDiameter Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a diameter dimension.

Visual Basic
Sub AddDiameter(TextOrigin As Point2d, Intent As GeometryIntent, ByRef ArrowheadsInside As [defaultvalue(0)] VARIANT_BOOL, ByRef LeaderFromCenter As [defaultvalue(0)] VARIANT_BOOL, ByRef SingleDimensionLine As [defaultvalue(-1)] VARIANT_BOOL, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] DiameterGeneralDimension*)
Parameters
Parameters | Description
TextOrigin | Specifies the position of the dimension text on sheet.
Intent | Specifies the arc or circle to dimension. A parameter along the curve should be specified in the intent. If not, a default is assumed. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
ArrowheadsInside | Indicates whether to place the dimension line arrows inside or outside. If not specified, this argument defaults to False indicating that arrowheads will be place outside.
LeaderFromCenter | Indicates whether the leader starts from the center of the arc or the circle. If not specified, the argument defaults to False indicating that the leader will not start from the center.
SingleDimensionLine | Indicates whether to use a single dimension line. If not specified, the argument defaults to True indicating a single dimension line will be used.
DimensionStyle | Specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.AddDiameter Method


GeneralDimensions.AddLinear Method

GeneralDimensions.AddLinear Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a linear dimension. Valid intent combinations are: Two points, Two curves, Point and a curve, One linear curve, One arc curve (with DimensionType set to kAlignedDimensionType for chord length and kArcLengthDimensionType for arc length).

Visual Basic
Sub AddLinear(TextOrigin As Point2d, IntentOne As GeometryIntent, ByRef IntentTwo As [optional] VARIANT, ByRef DimensionType As [defaultvalue(kAlignedDimensionType)] DimensionTypeEnum, ByRef ArrowheadsInside As [defaultvalue(-1)] VARIANT_BOOL, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] LinearGeneralDimension*)
Parameters
Parameters | Description
TextOrigin | Object that specifies the position of the dimension text on sheet.
IntentOne | Object that specifies the first geometry to dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IntentTwo | Object that specifies the second geometry to dimension. This argument must be specified if the first geometry intent is a point. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
DimensionType | Specifies the linear dimension type. Valid values (based on the input intents) are kAlignedDimensionType, kHorizontalDimensionType, kVerticalDimensionType, kArcLengthDimensionType, kSymmetricDimensionType and kDiametricDimensionType. If not specified, the argument defaults to kAlignedDimensionType. An error will occur if the specified type is invalid for the input intents. For instance, kHorizontalDimensionType is invalid for a vertical dimension and kSymmetricDimensionType & kDiametricDimensionType are invalid if only the first intent (an edge) is specified. kArcLengthDimensionType is only valid if two intents are supplied and they represent end points of an arc or a single intent is supplied and it represents an arc.
ArrowheadsInside | Indicates whether to place the dimension line arrows inside or outside. If not specified, this argument defaults to True indicating that arrowheads will be place inside (if possible).
DimensionStyle | Object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.AddLinear Method


GeneralDimensions.AddRadius Method

GeneralDimensions.AddRadius Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a radius dimension.

Visual Basic
Sub AddRadius(TextOrigin As Point2d, Intent As GeometryIntent, ByRef ArrowheadsInside As [defaultvalue(0)] VARIANT_BOOL, ByRef LeaderFromCenter As [defaultvalue(0)] VARIANT_BOOL, ByRef Jogged As [defaultvalue(0)] VARIANT_BOOL, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] RadiusGeneralDimension*)
Parameters
Parameters | Description
TextOrigin | Specifies the position of the dimension text on sheet.
Intent | Specifies the arc or circle to dimension. A parameter along the curve should be specified in the intent. If not, a default is assumed. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
ArrowheadsInside | Indicates whether to place the dimension line arrows inside or outside. If not specified, this argument defaults to False indicating that arrowheads will be place outside.
LeaderFromCenter | Indicates whether the leader starts from the center of the arc or the circle. If not specified, the argument defaults to False indicating that the leader will not start from the center. This argument is ignored and defaulted to True if the ArrowheadsInside argument is specified to be True.
Jogged | Indicates whether the dimension is jogged. If not specified, the argument defaults to False.
DimensionStyle | Specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.AddRadius Method


GeneralDimensions.GetRetrievableDimensions Method

GeneralDimensions.GetRetrievableDimensions Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns a collection of objects that represent the valid set of model dimensions that can be retrieved into the input drawing view.

Visual Basic
Sub GetRetrievableDimensions(View As DrawingView, ByRef ModelObject As [optional] VARIANT, Result As [out, retval] ObjectCollection*)
Parameters
Parameters | Description
View | Input DrawingView object that is to be queried for retrievable dimensions.
ModelObject | Optional input object from the model referenced by the drawing view that specifies a filter for this method. If specified, only the dimensions related to this object will be returned. Valid inputs include PlanarSketch, any of the objects that derive from PartFeature, ComponentOccurrence and the proxies to all these objects. If not specified, all the valid dimensions for the input view are returned.
Remarks

Based on the drawing view orientation, not all dimensions from the model can be retrieved into the view. The returned collection can contain sketch constraint objects or their proxies that derive from DimensionConstraint, FeatureDimension objects or FeatureDimensionProxy objects.

You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.GetRetrievableDimensions Method


GeneralDimensions.Item Method

GeneralDimensions.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified dimension object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GeneralDimension*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
See Also

Dimensions - editing sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.Item Method


GeneralDimensions.Retrieve Method

GeneralDimensions.Retrieve Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that retrieves sketch and/or model dimensions into the drawing.

Visual Basic
Sub Retrieve(ViewOrSketch As IDispatch, ByRef DimensionsToRetrieve As [optional] VARIANT, Result As [out, retval] GeneralDimensionsEnumerator*)
Parameters
Parameters | Description
ViewOrSketch | Input object that specifies the DrawingView or the DrawingSketch object to retrieve dimensions from. If a DrawingSketch object is specified, it must be owned by a Sheet. A DrawingSketch owned by a drawing view is invalid input.
DimensionsToRetrieve | Optional input ObjectCollection that specifies the dimensions to retrieve. If not specified, all dimensions from the specified view or sketch are retrieved. If specified, the collection can contain sketch constraint objects or their proxies that derive from DimensionConstraint, FeatureDimension objects or FeatureDimensionProxy objects. The objects must belong to the view or sketch specified in the first argument, else an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Methods > GeneralDimensions.Retrieve Method


GeneralDimensions Properties

GeneralDimensions Properties
Summary

The properties of the GeneralDimensions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Properties


GeneralDimensions.Application Property

GeneralDimensions.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Properties > GeneralDimensions.Application Property


GeneralDimensions.Count Property

GeneralDimensions.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Properties > GeneralDimensions.Count Property


GeneralDimensions.Type Property

GeneralDimensions.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensions Interface > GeneralDimensions Properties > GeneralDimensions.Type Property


GeneralDimensionsEnumerator Interface

GeneralDimensionsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The GeneralDimensionsEnumerator object provides access to the existing objects.

Class Hierarchy
Inventor::GeneralDimensionsEnumerator
Visual Basic
Public Interface GeneralDimensionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BaselineDimensionSet.Members

ChainDimensionSet.Members

ChainDimensionSet.AddMembers

GeneralDimensions.Retrieve

You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensionsEnumerator Interface


GeneralDimensionsEnumerator Methods

GeneralDimensionsEnumerator Methods
Summary

The methods of the GeneralDimensionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified DrawingStandardStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensionsEnumerator Interface > GeneralDimensionsEnumerator Methods


GeneralDimensionsEnumerator.Item Method

GeneralDimensionsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns the specified DrawingStandardStyle object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GeneralDimension*)
Parameters
Parameters | Description
index | Value that specifies the GeneralDimension to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the GeneralDimension name. If an out of range index or a name of a non-existent GeneralDimension is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensionsEnumerator Interface > GeneralDimensionsEnumerator Methods > GeneralDimensionsEnumerator.Item Method


GeneralDimensionsEnumerator Properties

GeneralDimensionsEnumerator Properties
Summary

The properties of the GeneralDimensionsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensionsEnumerator Interface > GeneralDimensionsEnumerator Properties


GeneralDimensionsEnumerator.Count Property

GeneralDimensionsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensionsEnumerator Interface > GeneralDimensionsEnumerator Properties > GeneralDimensionsEnumerator.Count Property


GeneralDimensionsEnumerator.Type Property

GeneralDimensionsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeneralDimensionsEnumerator Interface > GeneralDimensionsEnumerator Properties > GeneralDimensionsEnumerator.Type Property


GeneralNote Interface

GeneralNote Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The GeneralNote object represents a general note on a sheet and derives from the DrawingNote object.

Class Hierarchy
Inventor::DrawingNote
    Inventor::GeneralNote
Visual Basic
Public Interface GeneralNote
Inherits DrawingNote
Notes

Members through which this object may be accessed include:

GeneralNotes.AddByRectangle

GeneralNotes.AddFitted

GeneralNotes.Item

Example

"Add a general note."

This sample illustrates creating text (general note) in a sheet. Before running this sample, open a drawing document.

Public Sub SheetTextAdd()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the GeneralNotes object
    Dim oGeneralNotes As GeneralNotes
    Set oGeneralNotes = oActiveSheet.DrawingNotes.GeneralNotes

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create text with simple string as input. Since this doesn't use
    ' any text overrides, it will default to the active text style.
    Dim sText As String
    sText = "Drawing Notes"

    Dim oGeneralNote As GeneralNote
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, 18), sText)

    ' Create text using various overrides.
    sText = "Notice: All holes larger than 0.500 n are to be lubricated."
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, 16), sText)

    ' Create a set of notes that are numbered and aligned along the left.
    Dim dYCoord As Double
    dYCoord = 14
    Dim dYOffset As Double
    Dim oStyle As TextStyle
    Set oStyle = oGeneralNotes.Item(1).TextStyle
    dYOffset = oStyle.FontSize * 1.5

    ' Simple single line text.
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "1.")
    sText = "This is note 1."
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Two line text. The two lines are defined using the  tag within the text string.
    dYCoord = dYCoord - (oGeneralNote.FittedTextHeight + 0.5)
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "2.")
    sText = "This is note 2,  which contains two lines."
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Single line of text.
    dYCoord = dYCoord - (oGeneralNote.FittedTextHeight + 0.5)
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "3.")
    sText = "This is note 3."
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Three lines of text.
    dYCoord = dYCoord - (oGeneralNote.FittedTextHeight + 0.5)
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "4.")
    sText = "This is note 4,  which contains  several lines."
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    dYCoord = dYCoord - (oGeneralNote.FittedTextHeight + 0.5)
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "5.")

    sText = "Here is the last and final line of text."
    Set oGeneralNote = oGeneralNotes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface


GeneralNote Properties

GeneralNote Properties
Summary

The properties of the GeneralNote class are listed here.

Properties
Name | Description
Fitted | Property that returns whether the note remains tightly fitted to the text within the box.
FittedTextHeight | Property that returns the actual height of the text within the note. This does not necessarily represent the current height of the note, but only the text within the note. If the Fitted property is True then this value is the same as the height of the note.
FittedTextWidth | Property that returns the actual width of the text within the note. This does not necessarily represent the current width of the note, but only the text within the note. If the Fitted property is True then this value is the same as the width of the note.
Height | Property that gets and sets the height of the note. The height is defined in centimeters. Setting this value for a fitted note will convert the note to be non-fitted.
Rotation | Property that gets and sets the rotation of the general note. The units used to define the rotation angle are radians.
TextStyle | Property that gets and sets the text style associated with this general note.
Width | Property that gets and sets the width of the note. The width is defined in centimeters. Setting this value for a fitted note will convert the note to be non-fitted.
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties


GeneralNote.Fitted Property

GeneralNote.Fitted Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns whether the note remains tightly fitted to the text within the box.

Visual Basic
Property Fitted() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.Fitted Property


GeneralNote.FittedTextHeight Property

GeneralNote.FittedTextHeight Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the actual height of the text within the note. This does not necessarily represent the current height of the note, but only the text within the note. If the Fitted property is True then this value is the same as the height of the note.

Visual Basic
Property FittedTextHeight() As double*
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.FittedTextHeight Property


GeneralNote.FittedTextWidth Property

GeneralNote.FittedTextWidth Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the actual width of the text within the note. This does not necessarily represent the current width of the note, but only the text within the note. If the Fitted property is True then this value is the same as the width of the note.

Visual Basic
Property FittedTextWidth() As double*
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.FittedTextWidth Property


GeneralNote.Height Property

GeneralNote.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the height of the note. The height is defined in centimeters. Setting this value for a fitted note will convert the note to be non-fitted.

Visual Basic
Property Height() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.Height Property


GeneralNote.Rotation Property

GeneralNote.Rotation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the rotation of the general note. The units used to define the rotation angle are radians.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.Rotation Property


GeneralNote.TextStyle Property

GeneralNote.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the text style associated with this general note.

Visual Basic
Property TextStyle() As TextStyle *
See Also

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.TextStyle Property


GeneralNote.Width Property

GeneralNote.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the width of the note. The width is defined in centimeters. Setting this value for a fitted note will convert the note to be non-fitted.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralNote Interface > GeneralNote Properties > GeneralNote.Width Property


GeneralNotes Interface

GeneralNotes Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

GeneralNotes collection object provides access to all of the general notes on the sheet.

Class Hierarchy
Inventor::GeneralNotes
Visual Basic
Public Interface GeneralNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.GeneralNotes

See Also

Add a general note sample

Example

"Creating Stacked Text"

This sample demonstrates the creation of stacked text and text with superscript & subscript.

Public Sub StackedText()

    ' Set a reference to the active drawing document
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Create the placement point for the text
    Dim oPoint As Point2d
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint2d(25, 25)

    ' Define horizontally stacked text
    Dim strHorizontalStack As String
    strHorizontalStack = "11/2"

    ' Define diagonally stacked text
    Dim strDiagonalStack As String
    strDiagonalStack = "11#2"

    ' Define text with subscript
    Dim strSubscript As String
    strSubscript = "H^2SO^4"

    ' Define text with superscript
    Dim strSuperscript As String
    strSuperscript = "x2^ + y2^ = z2^"

    Dim strText As String
    strText = strHorizontalStack & "" & strDiagonalStack & "" & strSubscript & "" & strSuperscript

    Dim oGeneralNote As GeneralNote
    Set oGeneralNote = oActiveSheet.DrawingNotes.GeneralNotes.AddFitted(oPoint, strText)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface


GeneralNotes Methods

GeneralNotes Methods
Summary

The methods of the GeneralNotes class are listed here.

Methods
Methods
Name | Description
AddByRectangle | Method that creates a general note whose size is defined by the input points that define opposing diagonals of the note.
AddFitted | Method that creates a fitted general note positioned at the specified point on the sheet.
Item | Property that returns the specified GeneralNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Methods


GeneralNotes.AddByRectangle Method

GeneralNotes.AddByRectangle Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a general note whose size is defined by the input points that define opposing diagonals of the note.

Visual Basic
Sub AddByRectangle(CornerOne As Point2d, CornerTwo As Point2d, FormattedText As String, ByRef TextStyle As [optional] VARIANT, Result As [out, retval] GeneralNote*)
Parameters
Parameters | Description
CornerOne | Input Point2d that specifies the first corner of the rectangle.
CornerTwo | Input Point2d that specifies the second corner of the rectangle.
FormattedText | Input String that specifies the text of the general note. This string can contain tags that define internal formatting changes, which override the text style associated with the general note. The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the text style assigned to the note. You can use the XML tags to override the default style and apply style overrides for all or portions of the text. The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override. See the list of XML text formatting tags under Reference Topics in the Overviews section.
TextStyle | Optional input Variant that specifies which text style to use for the general note. The text style can be specified by providing the name of an existing style or by supplying a TextStyle object.
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Methods > GeneralNotes.AddByRectangle Method


GeneralNotes.AddFitted Method

GeneralNotes.AddFitted Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a fitted general note positioned at the specified point on the sheet.

Visual Basic
Sub AddFitted(PlacementPoint As Point2d, FormattedText As String, ByRef TextStyle As [optional] VARIANT, Result As [out, retval] GeneralNote*)
Parameters
Parameters | Description
PlacementPoint | Input Point2d that specifies the position of the general note on the sheet. The position of this point in relation to the resulting text string is dependent on the vertical and horizontal justification of the note. For example if the vertical justification is the top and horizontal is the left, then the position point defines the upper-left corner of the note. If the vertical justification is the center and the horizontal justification is the center, the position point defines the center of the note.
FormattedText | Input String that specifies the text of the general note. This string can contain tags that define internal formatting changes, which override the text style associated with the general note. The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the text style assigned to the note. You can use the XML tags to override the default style and apply style overrides for all or portions of the text. The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override. See the list of XML text formatting tags under Reference Topics in the Overviews section.
TextStyle | Optional input Variant that specifies which text style to use for the general note. The text style can be specified by providing the name of an existing style or by supplying a TextStyle object.
See Also

Creating Stacked Text sample

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Methods > GeneralNotes.AddFitted Method


GeneralNotes.Item Method

GeneralNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified GeneralNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GeneralNote*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
See Also

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Methods > GeneralNotes.Item Method


GeneralNotes Properties

GeneralNotes Properties
Summary

The properties of the GeneralNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kGeneralNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Properties


GeneralNotes.Application Property

GeneralNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Properties > GeneralNotes.Application Property


GeneralNotes.Count Property

GeneralNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Properties > GeneralNotes.Count Property


GeneralNotes.Type Property

GeneralNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kGeneralNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeneralNotes Interface > GeneralNotes Properties > GeneralNotes.Type Property


GeneralOptions Interface

GeneralOptions Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The GeneralOptions object provides access to properties that provide read and write access of the general application options. This is somewhat equivalent to the General tab of the Application Options dialog.

Class Hierarchy
Inventor::GeneralOptions
Visual Basic
Public Interface GeneralOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.GeneralOptions

See Also

Window Selection sample

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface


GeneralOptions Methods

GeneralOptions Methods
Summary

The methods of the GeneralOptions class are listed here.

Methods
Methods
Name | Description
StartupHelpFocusTopic | Property that gets and sets the focus topic of the help dialog box that is displayed on startup of Autodesk Inventor.
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Methods


GeneralOptions.StartupHelpFocusTopic Method

GeneralOptions.StartupHelpFocusTopic Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the focus topic of the help dialog box that is displayed on startup of Autodesk Inventor.

Visual Basic
Sub StartupHelpFocusTopic(Result As [out, retval] StartupHelpFocusTopicEnum)
Remarks

The valid options are kInventorClassicStartupHelpTopic and kInventorForAutocadStartupHelpTopic.

The ShowHelpDialogOnStartup property specifies whether the help dialog should be displayed each time Autodesk Inventor is opened. Therefore, the help dialog will focus on the topic specified by this property only if the value of the ShowHelpDialogOnStartup property is set to True.

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Methods > GeneralOptions.StartupHelpFocusTopic Method


GeneralOptions Properties

GeneralOptions Properties
Summary

The properties of the GeneralOptions class are listed here.

Properties
Name | Description
AnnotationScale | Property that gets and sets the size of non-model elements in the graphics window such as dimension text, arrowheads on dimensions, degree of freedom symbols, and so on. The valid values for this property are in the range of 0.2 to 5.0, setting a value outside this range will cause an error.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EnableLegacyProjectCreation | Property that enables or disables the creation of shared and semi-isolated legacy projects. A value of True enables the creation of legacy projects.
EnableOptimizedSelection | Property that enables or disables optimized selection. A value of True specifies that optimized selection should be enabled.
GripSnapOptions | Property that returns the GripSnapOptions object. The GripSnapOptions object provides access to various grip snap related application level options.
iMateVisibility | Gets and sets the visibility of the iMate glyph.
LoadVBAOnStartup | This is LoadVBAOnStartup, a member of class GeneralOptions.
SecondLevelTooltipDelay | Property that gets and sets the length of the delay time (in seconds), while the cursor is hovering over a command in the ribbon, before the second tooltip is displayed.
SelectOtherDelay | Property that gets and sets the length of the delay time (in seconds), while the cursor is hovering over geometry in the graphics window, before the Select Other tool is displayed. A value of zero or less indicates that the Select Other tool is turned off.
ShowAutocompleteForCommandAlias | Property that gets and sets whether the autocomplete dropdown box should be displayed for command aliases. A value of True indicates that the autocomplete dropdown box should be displayed for command aliases. A value of False will not display the autocomplete dropdown box for command aliases.
ShowCommandAliasInputDialog | Property that gets and sets whether the input dialog should be displayed for command aliases. A value of True indicates that the input dialog should be displayed for command aliases.
ShowCommandPromptTooltips | Property that gets and sets whether tooltips should be displayed to prompt for command inputs. A value of True indicates that tooltips should be displayed to prompt for command inputs. A value of False indicates that the display of tooltip prompts for command inputs should be suppressed.
ShowDocumentTabTooltips | Property that gets and sets whether to show tooltips when hovering over document tabs.
ShowSecondLevelTooltips | Property that gets and sets whether to show second level tooltips when hovering over a command in the ribbon.
ShowTooltips | Property that gets and sets whether to show tooltips when hovering over a command in the ribbon.
ShowVideoToolClips | This is ShowVideoToolClips, a member of class GeneralOptions.
StartupActionType | Property that gets and sets the type of startup action to perform each time Autodesk Inventor is opened.
StartupNewFileTemplateName | Property that gets and sets the name of the template for the new file that will be automatically created each time Autodesk Inventor is opened.
StartupProjectFileName | Property that gets and sets the name of the project file that will be used each time Autodesk Inventor is opened.
TextAppearance | Property that gets and sets the text font used for dialog boxes, browsers, and title bars. The string is the name of the font. Setting this value to a non-existent font will cause an error.
TextSize | Property that gets and sets the text size used for dialog boxes, browsers, and title bars. The valid values for the text size are 8 or 9, setting any other value will cause an error.
ThreadTableQuery | Property that returns the ThreadTableQuery object. This object has methods to query the thread table data contained in the Thread.xls spreadsheet.
ToleranceValue | Property that gets and sets the distance (in pixels) where a selection of an object can occur. The valid values for this property are in the range of 1 to 10, setting a value outside this range will cause an error.
TooltipDelay | Property that gets and sets the length of the delay time (in seconds), while the cursor is hovering over a command in the ribbon, before the tooltip is displayed.
Type | Returns an ObjectTypeEnum indicating this object's type.
UndoFileSize | Property that gets and sets the size of the temporary file that tracks changes to a model or drawing so that actions can be undone. The size is specified in megabytes and the valid values are in the range of 1 to 1000, setting a value outside this range will cause an error.
UpdatePropertiesOnSaveForFileType | Property that gets and sets whether properties should be updated when part or assembly files are saved.
UseNegativeIntegralForInertialProperties | Property that gets and sets whether the inertial properties should be calculated using the negative integral. A value of True specifies that inertial properties should be calculated using the negative integral and a value of False specifies that inertial properties should be calculated using the positive integral.
UserName | Property that gets and sets the username associated with this document.
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties


GeneralOptions.AnnotationScale Property

GeneralOptions.AnnotationScale Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the size of non-model elements in the graphics window such as dimension text, arrowheads on dimensions, degree of freedom symbols, and so on. The valid values for this property are in the range of 0.2 to 5.0, setting a value outside this range will cause an error.

Visual Basic
Property AnnotationScale() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.AnnotationScale Property


GeneralOptions.Application Property

GeneralOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.Application Property


GeneralOptions.EnableLegacyProjectCreation Property

GeneralOptions.EnableLegacyProjectCreation Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that enables or disables the creation of shared and semi-isolated legacy projects. A value of True enables the creation of legacy projects.

Visual Basic
Property EnableLegacyProjectCreation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.EnableLegacyProjectCreation Property


GeneralOptions.EnableOptimizedSelection Property

GeneralOptions.EnableOptimizedSelection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that enables or disables optimized selection. A value of True specifies that optimized selection should be enabled.

Visual Basic
Property EnableOptimizedSelection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.EnableOptimizedSelection Property


GeneralOptions.GripSnapOptions Property

GeneralOptions.GripSnapOptions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the GripSnapOptions object. The GripSnapOptions object provides access to various grip snap related application level options.

Visual Basic
Property GripSnapOptions() As GripSnapOptions**
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.GripSnapOptions Property


GeneralOptions.iMateVisibility Property

GeneralOptions.iMateVisibility Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets the visibility of the iMate glyph.

Visual Basic
Property iMateVisibility() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.iMateVisibility Property


GeneralOptions.LoadVBAOnStartup Property

GeneralOptions.LoadVBAOnStartup Property
Summary

This is LoadVBAOnStartup, a member of class GeneralOptions.

Visual Basic
Property LoadVBAOnStartup() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.LoadVBAOnStartup Property


GeneralOptions.SecondLevelTooltipDelay Property

GeneralOptions.SecondLevelTooltipDelay Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the length of the delay time (in seconds), while the cursor is hovering over a command in the ribbon, before the second tooltip is displayed.

Visual Basic
Property SecondLevelTooltipDelay() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.SecondLevelTooltipDelay Property


GeneralOptions.SelectOtherDelay Property

GeneralOptions.SelectOtherDelay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the length of the delay time (in seconds), while the cursor is hovering over geometry in the graphics window, before the Select Other tool is displayed. A value of zero or less indicates that the Select Other tool is turned off.

Visual Basic
Property SelectOtherDelay() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.SelectOtherDelay Property


GeneralOptions.ShowAutocompleteForCommandAlias Property

GeneralOptions.ShowAutocompleteForCommandAlias Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the autocomplete dropdown box should be displayed for command aliases. A value of True indicates that the autocomplete dropdown box should be displayed for command aliases. A value of False will not display the autocomplete dropdown box for command aliases.

Visual Basic
Property ShowAutocompleteForCommandAlias() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowAutocompleteForCommandAlias Property


GeneralOptions.ShowCommandAliasInputDialog Property

GeneralOptions.ShowCommandAliasInputDialog Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the input dialog should be displayed for command aliases. A value of True indicates that the input dialog should be displayed for command aliases.

Visual Basic
Property ShowCommandAliasInputDialog() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowCommandAliasInputDialog Property


GeneralOptions.ShowCommandPromptTooltips Property

GeneralOptions.ShowCommandPromptTooltips Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether tooltips should be displayed to prompt for command inputs. A value of True indicates that tooltips should be displayed to prompt for command inputs. A value of False indicates that the display of tooltip prompts for command inputs should be suppressed.

Visual Basic
Property ShowCommandPromptTooltips() As VARIANT_BOOL
See Also

Window Selection sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowCommandPromptTooltips Property


GeneralOptions.ShowDocumentTabTooltips Property

GeneralOptions.ShowDocumentTabTooltips Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to show tooltips when hovering over document tabs.

Visual Basic
Property ShowDocumentTabTooltips() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowDocumentTabTooltips Property


GeneralOptions.ShowSecondLevelTooltips Property

GeneralOptions.ShowSecondLevelTooltips Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to show second level tooltips when hovering over a command in the ribbon.

Visual Basic
Property ShowSecondLevelTooltips() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowSecondLevelTooltips Property


GeneralOptions.ShowTooltips Property

GeneralOptions.ShowTooltips Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to show tooltips when hovering over a command in the ribbon.

Visual Basic
Property ShowTooltips() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowTooltips Property


GeneralOptions.ShowVideoToolClips Property

GeneralOptions.ShowVideoToolClips Property
Summary

This is ShowVideoToolClips, a member of class GeneralOptions.

Visual Basic
Property ShowVideoToolClips() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ShowVideoToolClips Property


GeneralOptions.StartupActionType Property

GeneralOptions.StartupActionType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the type of startup action to perform each time Autodesk Inventor is opened.

Visual Basic
Property StartupActionType() As StartupActionTypeEnum
Remarks

The valid options are kNoStartupAction, kFileNewDialogStartupAction, kFileOpenDialogStartupAction and kNewFileFromTemplateStartupAction.

Setting this property to kNoStartupAction will cause no startup action to be performed.

Setting this property to kFileNewDialogStartupAction will cause the File New dialog box to be displayed each time Autodesk Inventor is opened.

Setting this property to kFileOpenDialogStartupAction will cause the File Open dialog box to be displayed each time Autodesk Inventor is opened.

Setting this property to kNewFileFromTemplateStartupAction will cause a new file to be automatically created each time Autodesk Inventor is opened. The name of the template for the new file can be specified using the StartupNewFileTemplateName property. The name of the project file can be specified using the StartupProjectFileName property.

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.StartupActionType Property


GeneralOptions.StartupNewFileTemplateName Property

GeneralOptions.StartupNewFileTemplateName Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the name of the template for the new file that will be automatically created each time Autodesk Inventor is opened.

Visual Basic
Property StartupNewFileTemplateName() As String
Remarks

This property is only applicable if the StartupActionType property is specified to be kNewFileFromTemplateStartupAction. If the StartupActionType property is set to a value other than kNewFileFromTemplateStartupAction, then setting a value for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.StartupNewFileTemplateName Property


GeneralOptions.StartupProjectFileName Property

GeneralOptions.StartupProjectFileName Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the name of the project file that will be used each time Autodesk Inventor is opened.

Visual Basic
Property StartupProjectFileName() As String
Remarks

This property is only applicable if the StartupActionType property is specified to be kNewFileFromTemplateStartupAction. If the StartupActionType property is set to a value other than kNewFileFromTemplateStartupAction, then setting a value for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.StartupProjectFileName Property


GeneralOptions.TextAppearance Property

GeneralOptions.TextAppearance Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the text font used for dialog boxes, browsers, and title bars. The string is the name of the font. Setting this value to a non-existent font will cause an error.

Visual Basic
Property TextAppearance() As String
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.TextAppearance Property


GeneralOptions.TextSize Property

GeneralOptions.TextSize Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the text size used for dialog boxes, browsers, and title bars. The valid values for the text size are 8 or 9, setting any other value will cause an error.

Visual Basic
Property TextSize() As long
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.TextSize Property


GeneralOptions.ThreadTableQuery Property

GeneralOptions.ThreadTableQuery Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ThreadTableQuery object. This object has methods to query the thread table data contained in the Thread.xls spreadsheet.

Visual Basic
Property ThreadTableQuery() As ThreadTableQuery**
See Also

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ThreadTableQuery Property


GeneralOptions.ToleranceValue Property

GeneralOptions.ToleranceValue Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the distance (in pixels) where a selection of an object can occur. The valid values for this property are in the range of 1 to 10, setting a value outside this range will cause an error.

Visual Basic
Property ToleranceValue() As long
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.ToleranceValue Property


GeneralOptions.TooltipDelay Property

GeneralOptions.TooltipDelay Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the length of the delay time (in seconds), while the cursor is hovering over a command in the ribbon, before the tooltip is displayed.

Visual Basic
Property TooltipDelay() As double
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.TooltipDelay Property


GeneralOptions.Type Property

GeneralOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.Type Property


GeneralOptions.UndoFileSize Property

GeneralOptions.UndoFileSize Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the size of the temporary file that tracks changes to a model or drawing so that actions can be undone. The size is specified in megabytes and the valid values are in the range of 1 to 1000, setting a value outside this range will cause an error.

Visual Basic
Property UndoFileSize() As long
Remarks

For best results, increase or decrease the file size in 4 megabyte increments.

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.UndoFileSize Property


GeneralOptions.UpdatePropertiesOnSaveForFileType Property

GeneralOptions.UpdatePropertiesOnSaveForFileType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether properties should be updated when part or assembly files are saved.

Visual Basic
Property UpdatePropertiesOnSaveForFileType() As UpdatePropertiesOnSaveForFileTypeEnum
Remarks

The valid options are kDontUpdateProperties, kUpdatePropertiesForPartsOnly, and kUpdatePropertiesForPartsAndAssemblies.

Setting this property to kDontUpdateProperties specifies that properties of neither part nor assembly files should be updated when they are saved.

Setting this property to kUpdatePropertiesForPartsOnly specifies that only properties of part files should be updated when they are saved.

Setting this property to kUpdatePropertiesForPartsAndAssemblies specifies that properties of both part and assembly files should be updated when they are saved.

You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.UpdatePropertiesOnSaveForFileType Property


GeneralOptions.UseNegativeIntegralForInertialProperties Property

GeneralOptions.UseNegativeIntegralForInertialProperties Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the inertial properties should be calculated using the negative integral. A value of True specifies that inertial properties should be calculated using the negative integral and a value of False specifies that inertial properties should be calculated using the positive integral.

Visual Basic
Property UseNegativeIntegralForInertialProperties() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.UseNegativeIntegralForInertialProperties Property


GeneralOptions.UserName Property

GeneralOptions.UserName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the username associated with this document.

Visual Basic
Property UserName() As String
You are here: Symbol Reference > Inventor Library > Objects > GeneralOptions Interface > GeneralOptions Properties > GeneralOptions.UserName Property


GeneralPreferences Interface

GeneralPreferences Interface
Summary

The GeneralPreferences object provides the ability to store information about users' preferences, such as what template directory to use when creating new files, whether the Multi-User facility is on or off, etc.

Class Hierarchy
Inventor::GeneralPreferences
Visual Basic
Public Interface GeneralPreferences
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > GeneralPreferences Interface


GeneralPreferences Properties

GeneralPreferences Properties
Summary

The properties of the GeneralPreferences class are listed here.

Properties
Name | Description
DeferUpdate | Property that indicates the Boolean flag indicating whether to defer update or not.
MultiUserExternallyManaged | Property that indicates the Boolean flag indicating whether Multi-User facility is managed by Autodesk Inventor or not.
MultiUserMode | Property that indicates a constant indicating the Multi-User mode.
TemplateDir | Property that indicates the directory from which Autodesk Inventor will present the templates for use in its File New command.
You are here: Symbol Reference > Inventor Library > Objects > GeneralPreferences Interface > GeneralPreferences Properties


GeneralPreferences.DeferUpdate Property

GeneralPreferences.DeferUpdate Property
Summary

Property that indicates the Boolean flag indicating whether to defer update or not.

Visual Basic
Property DeferUpdate() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralPreferences Interface > GeneralPreferences Properties > GeneralPreferences.DeferUpdate Property


GeneralPreferences.MultiUserExternallyManaged Property

GeneralPreferences.MultiUserExternallyManaged Property
Summary

Property that indicates the Boolean flag indicating whether Multi-User facility is managed by Autodesk Inventor or not.

Visual Basic
Property MultiUserExternallyManaged() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GeneralPreferences Interface > GeneralPreferences Properties > GeneralPreferences.MultiUserExternallyManaged Property


GeneralPreferences.MultiUserMode Property

GeneralPreferences.MultiUserMode Property
Summary

Property that indicates a constant indicating the Multi-User mode.

Visual Basic
Property MultiUserMode() As MultiUserModeEnum
You are here: Symbol Reference > Inventor Library > Objects > GeneralPreferences Interface > GeneralPreferences Properties > GeneralPreferences.MultiUserMode Property


GeneralPreferences.TemplateDir Property

GeneralPreferences.TemplateDir Property
Summary

Property that indicates the directory from which Autodesk Inventor will present the templates for use in its File New command.

Visual Basic
Property TemplateDir() As String
You are here: Symbol Reference > Inventor Library > Objects > GeneralPreferences Interface > GeneralPreferences Properties > GeneralPreferences.TemplateDir Property


GenericObject Interface

GenericObject Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Generic object. Weakly-typed (IDispatch).

Class Hierarchy
Inventor::GenericObject
Visual Basic
Public Interface GenericObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > GenericObject Interface


GenericObject Properties

GenericObject Properties
Summary

The properties of the GenericObject class are listed here.

Properties
Name | Description
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GenericObject Interface > GenericObject Properties


GenericObject.Type Property

GenericObject.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GenericObject Interface > GenericObject Properties > GenericObject.Type Property


GeometricConstraint Interface

GeometricConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GeomtricConstraint object represents the base class of all geometric constraints.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::CoincidentConstraint
    Inventor::CollinearConstraint
    Inventor::ConcentricConstraint
    Inventor::EqualLengthConstraint
    Inventor::EqualRadiusConstraint
    Inventor::GroundConstraint
    Inventor::HorizontalAlignConstraint
    Inventor::HorizontalConstraint
    Inventor::MidpointConstraint
    Inventor::OffsetConstraint
    Inventor::ParallelConstraint
    Inventor::PatternConstraint
    Inventor::PerpendicularConstraint
    Inventor::SmoothConstraint
    Inventor::SplineFitPointConstraint
    Inventor::SymmetryConstraint
    Inventor::TangentSketchConstraint
    Inventor::TextBoxConstraint
    Inventor::VerticalAlignConstraint
    Inventor::VerticalConstraint
Visual Basic
Public Interface GeometricConstraint
Inherits IDispatch
Notes

Members through which this object may be accessed include:

GeometricConstraints.Item

SketchConstraintsEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface


GeometricConstraint Methods

GeometricConstraint Methods
Summary

The methods of the GeometricConstraint class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the constraint.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Methods


GeometricConstraint.Delete Method

GeometricConstraint.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the constraint.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Methods > GeometricConstraint.Delete Method


GeometricConstraint.GetReferenceKey Method

GeometricConstraint.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Methods > GeometricConstraint.GetReferenceKey Method


GeometricConstraint Properties

GeometricConstraint Properties
Summary

The properties of the GeometricConstraint class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Deletable | Indicates whether this object is deletable.
Parent | Property that returns the parent sketch of the object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Properties


GeometricConstraint.Application Property

GeometricConstraint.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Properties > GeometricConstraint.Application Property


GeometricConstraint.AttributeSets Property

GeometricConstraint.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Properties > GeometricConstraint.AttributeSets Property


GeometricConstraint.Deletable Property

GeometricConstraint.Deletable Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Indicates whether this object is deletable.

Visual Basic
Property Deletable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Properties > GeometricConstraint.Deletable Property


GeometricConstraint.Parent Property

GeometricConstraint.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent sketch of the object.

Visual Basic
Property Parent() As Sketch**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Properties > GeometricConstraint.Parent Property


GeometricConstraint.Type Property

GeometricConstraint.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint Interface > GeometricConstraint Properties > GeometricConstraint.Type Property


GeometricConstraint3D Interface

GeometricConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The GeometricConstraint3D object represents the base class of all 3D geometric constraints.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::BendConstraint
    Inventor::CoincidentConstraint3D
    Inventor::CollinearConstraint3D
    Inventor::ConcentricConstraint3D
    Inventor::ConcentricConstraint3DProxy
    Inventor::CustomConstraint3D
    Inventor::GroundConstraint3D
    Inventor::HelicalConstraint3D
    Inventor::HelicalConstraint3DProxy
    Inventor::MidpointConstraint3D
    Inventor::ParallelConstraint3D
    Inventor::PerpendicularConstraint3D
    Inventor::SmoothConstraint3D
    Inventor::SplineFitPointsConstraint3D
    Inventor::TangentConstraint3D
Visual Basic
Public Interface GeometricConstraint3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.Item

SketchConstraints3DEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface


GeometricConstraint3D Methods

GeometricConstraint3D Methods
Summary

The methods of the GeometricConstraint3D class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the constraint. In the case of coincident constraint, all the connected lines are disconnected and the constraint is deleted.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Methods


GeometricConstraint3D.Delete Method

GeometricConstraint3D.Delete Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that deletes the constraint. In the case of coincident constraint, all the connected lines are disconnected and the constraint is deleted.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Methods > GeometricConstraint3D.Delete Method


GeometricConstraint3D.GetReferenceKey Method

GeometricConstraint3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Methods > GeometricConstraint3D.GetReferenceKey Method


GeometricConstraint3D Properties

GeometricConstraint3D Properties
Summary

The properties of the GeometricConstraint3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Deletable | Indicates whether this object can be deleted.
Parent | Property that returns the parent sketch of the object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Properties


GeometricConstraint3D.Application Property

GeometricConstraint3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Properties > GeometricConstraint3D.Application Property


GeometricConstraint3D.AttributeSets Property

GeometricConstraint3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Properties > GeometricConstraint3D.AttributeSets Property


GeometricConstraint3D.Deletable Property

GeometricConstraint3D.Deletable Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Indicates whether this object can be deleted.

Visual Basic
Property Deletable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Properties > GeometricConstraint3D.Deletable Property


GeometricConstraint3D.Parent Property

GeometricConstraint3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent sketch of the object.

Visual Basic
Property Parent() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Properties > GeometricConstraint3D.Parent Property


GeometricConstraint3D.Type Property

GeometricConstraint3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraint3D Interface > GeometricConstraint3D Properties > GeometricConstraint3D.Type Property


GeometricConstraints Interface

GeometricConstraints Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GeometricConstraints object provides access to all the geometric sketch constraints ( objects) in a sketch and provides methods to create additional geometric sketch constraints.

Class Hierarchy
Inventor::GeometricConstraints
Visual Basic
Public Interface GeometricConstraints
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.GeometricConstraints

See Also

Sketch Spline sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface


GeometricConstraints Methods

GeometricConstraints Methods
Summary

The methods of the GeometricConstraints class are listed here.

Methods
Methods
Name | Description
AddCoincident | Method that creates a new coincident constraint between two entities. One of the input entities must be a sketch point. The other entity can be a point or any other type of sketch entity.
AddCollinear | Method that creates a new collinear constraint between the two input sketch entities. Valid objects for input include lines, ellipses, and elliptical arcs. Either the major or minor axis of an ellipse is used, depending on the value of the EllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become collinear to the other entity. This method will fail if the constraint overconstrains the sketch.
AddConcentric | Method that creates a new concentric constraint between the two input sketch entities. The two entities must be circles, arcs, ellipses, or elliptical arcs. This method will fail if the constraint overconstrains the sketch.
AddEqualLength | Method that creates a new equal length constraint between the two input sketch lines. This method will fail if the constraint overconstrains the sketch.
AddEqualRadius | Method that creates a new equal radius constraint between the two input sketch entities. Valid input entities are circles and arcs. This method will fail if the constraint overconstrains the sketch.
AddGround | Method that creates a new ground constraint on the input sketch entity. This method will fail if the constraint overconstrains the sketch.
AddHorizontal | Method that creates a new horizontal constraint on the input sketch entity. Valid input objects are lines, ellipses, and elliptical arcs. Either the major or minor axis of an ellipse is used depending on the value of the EllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become horizontal. This method will fail if the constraint overconstrains the sketch.
AddHorizontalAlign | Method that creates a new horizontal alignment constraint between two sketch points. This causes the two points to align along the same horizontal axis. This method will fail if the constraint overconstrains the sketch.
AddMidpoint | Method that creates a new midpoint constraint between the point and line. This causes the input sketch point to be positioned at the midpoint of the input line. This method will fail if the constraint overconstrains the sketch.
AddParallel | Method that creates a new parallel constraint between the two input sketch entities. Valid objects for input include lines and ellipses. Either the major or minor axis of an ellipse is used depending on the values of UseEllipseMajorAxis input arguments. When an ellipse is used, the specified axis of the ellipse will become parallel to the other entity. This method will fail if the constraint overconstrains the sketch.
AddPerpendicular | Method that creates a new perpendicular constraint between the two input sketch entities. Valid objects for input include lines and ellipses. Either the major or minor axis of an ellipse is used depending on the value of EllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become perpendicular to the other entity. This method will fail if the constraint overconstrains the sketch.
AddSmooth | Method that creates a new smooth (G2-continuous) constraint. This method will fail if the constraint overconstrains the sketch.
AddSymmetry | Method that creates a new symmetry constraint between the two input entities about the specified line. The two input entities must be of the same type. This method will fail if the constraint overconstrains the sketch.
AddTangent | Method that creates a new tangent constraint. This method will fail if the constraint overconstrains the sketch.
AddVertical | Method that creates a new vertical constraint on the input sketch entity. Valid input objects are lines and ellipses. Either the major or minor axis of an ellipse is used depending on the value of the UseEllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become vertical. This method will fail if the constraint overconstrains the sketch.
AddVerticalAlign | Method that creates a new vertical alignment constraint between two sketch points. This causes the two points to align along the same vertical axis. This method will fail if the constraint overconstrains the sketch.
Item | Property that returns the specified geometric sketch constraint object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods


GeometricConstraints.AddCoincident Method

GeometricConstraints.AddCoincident Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new coincident constraint between two entities. One of the input entities must be a sketch point. The other entity can be a point or any other type of sketch entity.

Visual Basic
Sub AddCoincident(EntityOne As SketchEntity, EntityTwo As SketchEntity, Result As [out, retval] CoincidentConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity.
EntityTwo | Input sketch entity.
Remarks

Placing a coincident constraint between two points will not cause them to merge into a single point. Use the Merge method on the SketchPoint object to merge two points. This method will fail if the constraint overconstrains the sketch.

See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddCoincident Method


GeometricConstraints.AddCollinear Method

GeometricConstraints.AddCollinear Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new collinear constraint between the two input sketch entities. Valid objects for input include lines, ellipses, and elliptical arcs. Either the major or minor axis of an ellipse is used, depending on the value of the EllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become collinear to the other entity. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddCollinear(EntityOne As SketchEntity, EntityTwo As SketchEntity, ByRef UseEllipseOneMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, ByRef UseEllipseTwoMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] CollinearConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity. Must be a line, ellipse, or elliptical arc.
EntityTwo | Input sketch entity. Must be a line, ellipse, or elliptical arc.
UseEllipseOneMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse supplied in the EntityOne argument. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied as the EntityOne argument.
UseEllipseTwoMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse supplied in the EntityTwo argument. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied as the EntityTwo argument.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddCollinear Method


GeometricConstraints.AddConcentric Method

GeometricConstraints.AddConcentric Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new concentric constraint between the two input sketch entities. The two entities must be circles, arcs, ellipses, or elliptical arcs. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddConcentric(EntityOne As SketchEntity, EntityTwo As SketchEntity, Result As [out, retval] ConcentricConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity. Must be a circle, arc, ellipse, or elliptical arc.
EntityTwo | Input sketch entity. Must be a circle, arc, ellipse, or elliptical arc.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddConcentric Method


GeometricConstraints.AddEqualLength Method

GeometricConstraints.AddEqualLength Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new equal length constraint between the two input sketch lines. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddEqualLength(LineOne As SketchLine, LineTwo As SketchLine, Result As [out, retval] EqualLengthConstraint*)
Parameters
Parameters | Description
LineOne | Input SketchLine object.
LineTwo | Input SketchLine object.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddEqualLength Method


GeometricConstraints.AddEqualRadius Method

GeometricConstraints.AddEqualRadius Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new equal radius constraint between the two input sketch entities. Valid input entities are circles and arcs. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddEqualRadius(EntityOne As SketchEntity, EntityTwo As SketchEntity, Result As [out, retval] EqualRadiusConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity. Must be a circle or arc.
EntityTwo | Input sketch entity. Must be a circle or arc.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddEqualRadius Method


GeometricConstraints.AddGround Method

GeometricConstraints.AddGround Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new ground constraint on the input sketch entity. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddGround(Entity As SketchEntity, Result As [out, retval] GroundConstraint*)
Parameters
Parameters | Description
Entity | Input sketch entity.
See Also

Sketch Spline sample

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddGround Method


GeometricConstraints.AddHorizontal Method

GeometricConstraints.AddHorizontal Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new horizontal constraint on the input sketch entity. Valid input objects are lines, ellipses, and elliptical arcs. Either the major or minor axis of an ellipse is used depending on the value of the EllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become horizontal. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddHorizontal(Entity As SketchEntity, ByRef UseEllipseMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] HorizontalConstraint*)
Parameters
Parameters | Description
Entity | Input sketch entity. Must be a line, ellipse, or elliptical arc.
UseEllipseMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied for the entity.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddHorizontal Method


GeometricConstraints.AddHorizontalAlign Method

GeometricConstraints.AddHorizontalAlign Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new horizontal alignment constraint between two sketch points. This causes the two points to align along the same horizontal axis. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddHorizontalAlign(PointOne As SketchPoint, PointTwo As SketchPoint, Result As [out, retval] HorizontalAlignConstraint*)
Parameters
Parameters | Description
PointOne | Input SketchPoint entity.
PointTwo | Input SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddHorizontalAlign Method


GeometricConstraints.AddMidpoint Method

GeometricConstraints.AddMidpoint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new midpoint constraint between the point and line. This causes the input sketch point to be positioned at the midpoint of the input line. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddMidpoint(Point As SketchPoint, Line As SketchLine, Result As [out, retval] MidpointConstraint*)
Parameters
Parameters | Description
Point | Input SketchPoint entity.
Line | Input SketchLine object.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddMidpoint Method


GeometricConstraints.AddParallel Method

GeometricConstraints.AddParallel Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new parallel constraint between the two input sketch entities. Valid objects for input include lines and ellipses. Either the major or minor axis of an ellipse is used depending on the values of UseEllipseMajorAxis input arguments. When an ellipse is used, the specified axis of the ellipse will become parallel to the other entity. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddParallel(EntityOne As SketchEntity, EntityTwo As SketchEntity, ByRef UseEllipseOneMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, ByRef UseEllipseTwoMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] ParallelConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity. Must be a line, ellipse, or elliptical arc.
EntityTwo | Input sketch entity. Must be a line, ellipse, or elliptical arc.
UseEllipseOneMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse supplied in the EntityOne argument. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied as the EntityOne argument.
UseEllipseTwoMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse supplied in the EntityTwo argument. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied as the EntityTwo argument.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddParallel Method


GeometricConstraints.AddPerpendicular Method

GeometricConstraints.AddPerpendicular Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new perpendicular constraint between the two input sketch entities. Valid objects for input include lines and ellipses. Either the major or minor axis of an ellipse is used depending on the value of EllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become perpendicular to the other entity. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddPerpendicular(EntityOne As SketchEntity, EntityTwo As SketchEntity, ByRef UseEllipseOneMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, ByRef UseEllipseTwoMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] PerpendicularConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity. Must be a line, ellipse, or elliptical arc.
EntityTwo | Input sketch entity. Must be a line, ellipse, or elliptical arc.
UseEllipseOneMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse supplied in the EntityOne argument. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied as the EntityOne argument.
UseEllipseTwoMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse supplied in the EntityTwo argument. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied as the EntityTwo argument.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddPerpendicular Method


GeometricConstraints.AddSmooth Method

GeometricConstraints.AddSmooth Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new smooth (G2-continuous) constraint. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddSmooth(EntityOne As SketchEntity, EntityTwo As SketchEntity, ByRef ProximityPoint As [optional] VARIANT, Result As [out, retval] SmoothConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch entity.
EntityTwo | Input sketch entity.
ProximityPoint | Optional input Point2d object that specifies which ends of the curves to make smooth in case there are multiple connections.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddSmooth Method


GeometricConstraints.AddSymmetry Method

GeometricConstraints.AddSymmetry Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new symmetry constraint between the two input entities about the specified line. The two input entities must be of the same type. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddSymmetry(EntityOne As SketchEntity, EntityTwo As SketchEntity, SymmetryAxis As SketchLine, Result As [out, retval] SymmetryConstraint*)
Parameters
Parameters | Description
EntityOne | Input entity that is to be symmetric. Must be the same type as EntityTwo.
EntityTwo | Input entity that is to be symmetric. Must be the same type as EntityOne.
SymmetryAxis | Input object that defines the axis of symmetry.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddSymmetry Method


GeometricConstraints.AddTangent Method

GeometricConstraints.AddTangent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new tangent constraint. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddTangent(EntityOne As SketchEntity, EntityTwo As SketchEntity, ByRef ProximityPoint As [optional] VARIANT, Result As [out, retval] TangentSketchConstraint*)
Parameters
Parameters | Description
EntityOne | Input sketch object.
EntityTwo | Input sketch object.
ProximityPoint | Optional input Point object that specifies where the tangency should be applied in the case where the input entities share two sketch points.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddTangent Method


GeometricConstraints.AddVertical Method

GeometricConstraints.AddVertical Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new vertical constraint on the input sketch entity. Valid input objects are lines and ellipses. Either the major or minor axis of an ellipse is used depending on the value of the UseEllipseMajorAxis input argument. When an ellipse is used, the specified axis of the ellipse will become vertical. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddVertical(Entity As SketchEntity, ByRef UseEllipseMajorAxis As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] VerticalConstraint*)
Parameters
Parameters | Description
Entity | Input sketch entity. Must be a line, ellipse, or elliptical arc.
UseEllipseMajorAxis | Optional Boolean that specifies whether to use the major or minor axis for the ellipse. This argument only applies when the input entity is an ellipse or elliptical arc. Inputting True results in the constraint being applied to the major axis. This value is ignored when a line is supplied for the entity.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddVertical Method


GeometricConstraints.AddVerticalAlign Method

GeometricConstraints.AddVerticalAlign Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new vertical alignment constraint between two sketch points. This causes the two points to align along the same vertical axis. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddVerticalAlign(PointOne As SketchPoint, PointTwo As SketchPoint, Result As [out, retval] VerticalAlignConstraint*)
Parameters
Parameters | Description
PointOne | Input SketchPoint entity.
PointTwo | Input SketchLine object.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.AddVerticalAlign Method


GeometricConstraints.Item Method

GeometricConstraints.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified geometric sketch constraint object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GeometricConstraint*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Methods > GeometricConstraints.Item Method


GeometricConstraints Properties

GeometricConstraints Properties
Summary

The properties of the GeometricConstraints class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Properties


GeometricConstraints.Application Property

GeometricConstraints.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Properties > GeometricConstraints.Application Property


GeometricConstraints.Count Property

GeometricConstraints.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Properties > GeometricConstraints.Count Property


GeometricConstraints.Type Property

GeometricConstraints.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints Interface > GeometricConstraints Properties > GeometricConstraints.Type Property


GeometricConstraints3D Interface

GeometricConstraints3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The GeometricConstraints3D object provides access to all the geometric sketch constraints ( objects) in a 3D sketch and provides methods to create additional geometric sketch constraints.

Class Hierarchy
Inventor::GeometricConstraints3D
Visual Basic
Public Interface GeometricConstraints3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.GeometricConstraints3D

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface


GeometricConstraints3D Methods

GeometricConstraints3D Methods
Summary

The methods of the GeometricConstraints3D class are listed here.

Methods
Methods
Name | Description
AddCoincident | Method that creates a new coincident constraint between two entities. One of the input entities must be a sketch point. The other entity can be any other type of sketch entity (but not a sketch point). Placing a coincident constraint between two points will fail. Use the ConnectTo method on the SketchPoint3D object to merge two points. This method will fail if the constraint overconstrains the sketch.
AddCollinear | Method that creates a new collinear constraint between the two input objects. This method will fail if the constraint overconstrains the sketch.
AddCustom | Method that creates a new custom constraint on the input sketch entity.
AddGround | Method that creates a new ground constraint on the input sketch entity. This method will fail if the constraint overconstrains the sketch.
AddMidpoint | Method that creates a new midpoint constraint between the input point and the midpoint of the line. This causes the input sketch point to be positioned at the midpoint of the input line. This method will fail if the constraint overconstrains the sketch.
AddParallel | Method that creates a new parallel constraint between the two input entities. This method will fail if the constraint overconstrains the sketch.
AddPerpendicular | Method that creates a new perpendicular constraint between the two input entities. This method will fail if the constraint overconstrains the sketch.
AddSmooth | Method that creates a new smooth (G2-continuous) constraint. This method will fail if the constraint overconstrains the sketch.
AddTangent | Method that creates a new tangent constraint. This method will fail if the constraint overconstrains the sketch or if the two input entities do not share at least one common sketch point. In creating the constraint, the method attempts to match the existing orientation between the two curves. If the dot product of the direction vectors for the curves at the tangent point is greater than 0.0 the options for the tangent constraint is set to be outward. That means that if you look at the curves and ignore the parameterization, the curves will be going in opposite directions.
Item | Property that returns the specified geometric sketch constraint object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods


GeometricConstraints3D.AddCoincident Method

GeometricConstraints3D.AddCoincident Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new coincident constraint between two entities. One of the input entities must be a sketch point. The other entity can be any other type of sketch entity (but not a sketch point). Placing a coincident constraint between two points will fail. Use the ConnectTo method on the SketchPoint3D object to merge two points. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddCoincident(EntityOne As SketchEntity3D, EntityTwo As SketchEntity3D, Result As [out, retval] CoincidentConstraint3D*)
Parameters
Parameters | Description
EntityOne | Input sketch entity.
EntityTwo | Input sketch entity.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddCoincident Method


GeometricConstraints3D.AddCollinear Method

GeometricConstraints3D.AddCollinear Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new collinear constraint between the two input objects. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddCollinear(EntityOne As IDispatch, EntityTwo As IDispatch, ByRef Reserved1 As [defaultvalue(-1)] VARIANT_BOOL, ByRef Reserved2 As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] CollinearConstraint3D*)
Parameters
Parameters | Description
EntityOne | Object that specifies the first entity to be constrained.
EntityTwo | Object that specifies the second entity to be constrained.
Reserved1 | This argument is reserved for future use and is currently ignored.
Reserved2 | This argument is reserved for future use and is currently ignored.
Remarks

The constraint can currently be applied between two 3D sketch lines, or between a 3D sketch line and a work axis.

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddCollinear Method


GeometricConstraints3D.AddCustom Method

GeometricConstraints3D.AddCustom Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new custom constraint on the input sketch entity.

Visual Basic
Sub AddCustom(Entity As SketchEntity3D, ClientId As String, Result As [out, retval] CustomConstraint3D*)
Parameters
Parameters | Description
Entity | SketchEntity3D object that specifies the entity to which the custom constraint needs to be applied.
ClientId | String that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddCustom Method


GeometricConstraints3D.AddGround Method

GeometricConstraints3D.AddGround Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new ground constraint on the input sketch entity. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddGround(Entity As SketchEntity3D, Result As [out, retval] GroundConstraint3D*)
Parameters
Parameters | Description
Entity | SketchEntity3D object that specifies the entity to ground.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddGround Method


GeometricConstraints3D.AddMidpoint Method

GeometricConstraints3D.AddMidpoint Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new midpoint constraint between the input point and the midpoint of the line. This causes the input sketch point to be positioned at the midpoint of the input line. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddMidpoint(Point As SketchPoint3D, Line As SketchLine3D, Result As [out, retval] MidpointConstraint3D*)
Parameters
Parameters | Description
Point | Input SketchPoint3D object.
Line | Input SketchLine3D object.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddMidpoint Method


GeometricConstraints3D.AddParallel Method

GeometricConstraints3D.AddParallel Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new parallel constraint between the two input entities. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddParallel(EntityOne As IDispatch, EntityTwo As IDispatch, ByRef Reserved1 As [defaultvalue(-1)] VARIANT_BOOL, ByRef Reserved2 As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] ParallelConstraint3D*)
Parameters
Parameters | Description
EntityOne | Object that specifies the first entity to be constrained.
EntityTwo | Object that specifies the second entity to be constrained.
Reserved1 | This argument is reserved for future use and is currently ignored.
Reserved2 | This argument is reserved for future use and is currently ignored.
Remarks

The constraint can currently be applied between:

  • a 3D sketch line and another 3D sketch line, a work axis, linear edge, or axis of a cylindrical face.
  • a 3D sketch line and a planar face or work plane.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddParallel Method


GeometricConstraints3D.AddPerpendicular Method

GeometricConstraints3D.AddPerpendicular Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new perpendicular constraint between the two input entities. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddPerpendicular(EntityOne As IDispatch, EntityTwo As IDispatch, ByRef Reserved1 As [defaultvalue(-1)] VARIANT_BOOL, ByRef Reserved2 As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] PerpendicularConstraint3D*)
Parameters
Parameters | Description
EntityOne | Object that specifies the first entity to be constrained.
EntityTwo | Object that specifies the second entity to be constrained.
Reserved1 | This argument is reserved for future use and is currently ignored.
Reserved2 | This argument is reserved for future use and is currently ignored.
Remarks

The constraint can currently be applied between a 3D sketch line and another 3D sketch line, a work axis, linear edge, work plane or a surface (face).

You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddPerpendicular Method


GeometricConstraints3D.AddSmooth Method

GeometricConstraints3D.AddSmooth Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new smooth (G2-continuous) constraint. This method will fail if the constraint overconstrains the sketch.

Visual Basic
Sub AddSmooth(EntityOne As SketchEntity3D, EntityTwo As SketchEntity3D, ByRef ProximityPoint As [optional] VARIANT, Result As [out, retval] SmoothConstraint3D*)
Parameters
Parameters | Description
EntityOne | Input sketch entity.
EntityTwo | Input sketch entity.
ProximityPoint | Optional input Point object that specifies which ends of the curves to make smooth in case there are multiple connections.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddSmooth Method


GeometricConstraints3D.AddTangent Method

GeometricConstraints3D.AddTangent Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that creates a new tangent constraint. This method will fail if the constraint overconstrains the sketch or if the two input entities do not share at least one common sketch point. In creating the constraint, the method attempts to match the existing orientation between the two curves. If the dot product of the direction vectors for the curves at the tangent point is greater than 0.0 the options for the tangent constraint is set to be outward. That means that if you look at the curves and ignore the parameterization, the curves will be going in opposite directions.

Visual Basic
Sub AddTangent(EntityOne As SketchEntity3D, EntityTwo As IDispatch, ByRef ProximityPoint As [optional] VARIANT, Result As [out, retval] TangentConstraint3D*)
Parameters
Parameters | Description
EntityOne | Input sketch object.
EntityTwo | Input sketch or edge object.
ProximityPoint | Optional input object that specifies where the tangency should be applied in the case where the input entities share two sketch points.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.AddTangent Method


GeometricConstraints3D.Item Method

GeometricConstraints3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified geometric sketch constraint object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GeometricConstraint3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Methods > GeometricConstraints3D.Item Method


GeometricConstraints3D Properties

GeometricConstraints3D Properties
Summary

The properties of the GeometricConstraints3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Properties


GeometricConstraints3D.Application Property

GeometricConstraints3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Properties > GeometricConstraints3D.Application Property


GeometricConstraints3D.Count Property

GeometricConstraints3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Properties > GeometricConstraints3D.Count Property


GeometricConstraints3D.Type Property

GeometricConstraints3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeometricConstraints3D Interface > GeometricConstraints3D Properties > GeometricConstraints3D.Type Property


GeometryIntent Interface

GeometryIntent Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The GeometryIntent object represents a geometry intent for use in various annotation and view creations.

Class Hierarchy
Inventor::GeometryIntent
Visual Basic
Public Interface GeometryIntent
Inherits IDispatch
Remarks

To better understand GeometryIntent objects, imagine a sheet with a leader line and arrow pointing to a user-selected point on a drawing line. Leader line associativity to the selected spot on the drawing line needs to be maintained, but there is no point geometry midway on the drawing line to reference. In this example, a GeometryIntent object encapsulates the intent to reference a location on the drawing line, a certain distance from a particular end.

Similarly, dimensions require GeometryIntent objects because, unlike the Autodesk Inventor modeling environment, the drawing environment contains only 2D lines, arcs and circles - no points. So, a GeometryIntent object for a dimension might reference a particular end of a line or arc, or the center of a circle or arc. For more information, refer to the Drawing Dimensions overview.

When creating dimensions on a drawing sheet, the preferred technique is to use the Retrieve method of the dimension, which retrieves sketch and/or model dimensions into the drawing. If this doesn't achieve the desired result, create the dimensions using appropriate GeometryIntent objects. Another way is to create dimensions on the view sketch and the retrieve the dimensions, but this will not result in associative dimensions.

Notes

Members through which this object may be accessed include:

AngularGeneralDimension.IntentOne

AngularGeneralDimension.IntentThree

AngularGeneralDimension.IntentTwo

BaselineDimensionSet.Origin

Centerline.PatternCenter

DetailDrawingView.AttachPoint

DiameterGeneralDimension.Intent

LeaderNode.AttachedEntity

LinearGeneralDimension.IntentOne

LinearGeneralDimension.IntentTwo

OrdinateDimension.Intent

OriginIndicator.Intent

PunchNote.PunchEdge

RadiusGeneralDimension.Intent

Sheet.CreateGeometryIntent

HoleThreadNote.Edge

See Also

Chain dimensions sets sample

create punch note sample

Baseline dimension sets sample

Add surface texture symbol to dimension sample

Create sketched symbol and leader sample

Creating hole tables sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface


GeometryIntent Properties

GeometryIntent Properties
Summary

The properties of the GeometryIntent class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Geometry | Property that returns the geometry associated with the intent.
Intent | Property that returns the intent point on the input geometry. This can be a value from PointIntentEnum, a geometry if the intent is the intersection of two geometries, a Point2d object that specifies a sheet point on the geometry or a double value (0 to 1) indicating the parameter on the input curve geometry.
IntentType | Property that returns intent type indicating the type of value that the Intent property will return. Possible return values are kPointEnumIntent (a PointIntentEnum will be returned), kPoint2dIntent (a Point2d object will be returned), kParameterIntent (a double value will be returned), kGeometryIntent (a DrawingCurve or a SketchEntity will be returned) or kNoPointIntent (the GeometryIntent is not a point and the Intent property will not return a meaningful value).
Parent | Property that returns the parent of this object.
PointOnSheet | Property that returns the point on sheet represented by a point intent. This property returns Nothing if this is not a point intent.
Type | Property returning kGeometryIntentObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties


GeometryIntent.Application Property

GeometryIntent.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.Application Property


GeometryIntent.Geometry Property

GeometryIntent.Geometry Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the geometry associated with the intent.

Visual Basic
Property Geometry() As IDispatch**
Remarks

The following objects can be returned: DrawingCurve, sketch entities on a sheet sketch, DrawingDimension, Centerline and Centermark

You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.Geometry Property


GeometryIntent.Intent Property

GeometryIntent.Intent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the intent point on the input geometry. This can be a value from PointIntentEnum, a geometry if the intent is the intersection of two geometries, a Point2d object that specifies a sheet point on the geometry or a double value (0 to 1) indicating the parameter on the input curve geometry.

Visual Basic
Property Intent() As VARIANT*
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.Intent Property


GeometryIntent.IntentType Property

GeometryIntent.IntentType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns intent type indicating the type of value that the Intent property will return. Possible return values are kPointEnumIntent (a PointIntentEnum will be returned), kPoint2dIntent (a Point2d object will be returned), kParameterIntent (a double value will be returned), kGeometryIntent (a DrawingCurve or a SketchEntity will be returned) or kNoPointIntent (the GeometryIntent is not a point and the Intent property will not return a meaningful value).

Visual Basic
Property IntentType() As IntentTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.IntentType Property


GeometryIntent.Parent Property

GeometryIntent.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent of this object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.Parent Property


GeometryIntent.PointOnSheet Property

GeometryIntent.PointOnSheet Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the point on sheet represented by a point intent. This property returns Nothing if this is not a point intent.

Visual Basic
Property PointOnSheet() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.PointOnSheet Property


GeometryIntent.Type Property

GeometryIntent.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kGeometryIntentObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GeometryIntent Interface > GeometryIntent Properties > GeometryIntent.Type Property


GraphicsColorMapper Interface

GraphicsColorMapper Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The GraphicsColorMapper object maps scalar values to colors. Use methods provided on the object to define the scalar values and colors. The same object can be used to define the mapping for multiple graphics primitives using the ColorMapper property on the primitives.

Class Hierarchy
Inventor::GraphicsColorMapper
Visual Basic
Public Interface GraphicsColorMapper
Inherits IDispatch
Remarks

If the count of the colors (returned by the ColorCount property) equals the count of the values (returned by the ValueCount property), then the mapping results in continuously interpolated colors.

If the count of the colors (returned by the ColorCount property) is exactly one more than the count of the values (returned by the ValueCount property), then the mapping results in a color band (i.e. the map is discrete).

In both these cases, the first color applies to all values lesser than the first value and the last color applies to all values greater than the last value. Typically, the values should be specified in ascending order.

If the count of the colors is not equal to or one more than the count of the values, the mapper is not used.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateColorMapper

TriangleFanGraphics.ColorMapper

TriangleGraphics.ColorMapper

TriangleStripGraphics.ColorMapper

Example

Test of client graphics texture-based color mapping.

This test applies texture coordinates expressing distance from the origin to 'the triangle mesh of whatever Part you have open. It then creates either a discrete-band or continuous color mapper and allows you to adjust the values of the mapper to change the range of values that map to various colors.

To operate:

  1. Open a part
  2. Run Demo - it should show discrete bands moving across the model
  3. Click on any of the other "convenience functions" and hit F5 to exercise them

Dim lastOffset As Double
Dim mapperType As Integer

'convenience "links"
Sub Demo()
    ThisApplication.ActiveView.DisplayMode = kWireframeRendering
    Call OffsetSurfaceBy(0#)
    Call UpdateValues(1 / 1.01, 0, 30)
    Call UpdateValues(1, -0.01, 20)
    Call UpdateValues(1, 0.01, 20)
    Call UpdateValues(1 / 1.01, 0, 50)
    Call UpdateValues(1, -0.01, 20)
    Call UpdateValues(1, 0.01, 20)
    Call UpdateValues(1 * 1.01, 0, 50)
End Sub

Sub narrowBands()
    Call UpdateValues(1 / 1.01, 0, 1)
End Sub

Sub widenBands()
    Call UpdateValues(1 * 1.01, 0, 1)
End Sub

Sub slideBandsUp()
    Call UpdateValues(1, 0.01, 1)
End Sub

Sub slideBandsDown()
    Call UpdateValues(1, -0.01, 1)
End Sub

Sub setContinuousMode()
    mapperType = 1
    Call OffsetSurfaceBy(0#)
End Sub

Sub setDiscreteMode()
    mapperType = 0
    Call OffsetSurfaceBy(0#)
End Sub

'internal functions

'randomly change colors in ColorMapper

Sub UpdateColors()

Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

Dim oDataSets As GraphicsDataSets
Set oDataSets = oDoc.GraphicsDataSetsCollection.Item("CG_Test")

Dim oCompDef As ComponentDefinition
Set oCompDef = oDoc.ComponentDefinition

Dim oClientGraphics As ClientGraphics
Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("CG_Test")

Dim oGraphicsNode As GraphicsNode
Set oGraphicsNode = oClientGraphics.ItemById(100)

Dim oTriangleSet As TriangleGraphics
Set oTriangleSet = oGraphicsNode.Item(1)
Dim oColorMapper As GraphicsColorMapper
Set oColorMapper = oTriangleSet.ColorMapper

For i = 1 To 100
    Dim cmColors() As Byte
    Call oColorMapper.GetColors(cmColors)
    For j = 0 To oColorMapper.ColorCount * 3 - 1
        cmColors(j) = 255 * Rnd() * i / 100#
    Next
    Call oColorMapper.PutColors(cmColors)
    ThisApplication.ActiveView.Update
Next

End Sub

'change values in ColorMapper

Sub UpdateValues(factor As Double, offset As Double, count As Integer)

Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

Dim oDataSets As GraphicsDataSets
Set oDataSets = oDoc.GraphicsDataSetsCollection.Item("CG_Test")

Dim oCompDef As ComponentDefinition
Set oCompDef = oDoc.ComponentDefinition

Dim oClientGraphics As ClientGraphics
Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("CG_Test")

Dim oGraphicsNode As GraphicsNode
Set oGraphicsNode = oClientGraphics.ItemById(100)

Dim oTriangleSet As TriangleGraphics
Set oTriangleSet = oGraphicsNode.Item(1)
Dim oColorMapper As GraphicsColorMapper
Set oColorMapper = oTriangleSet.ColorMapper

For i = 1 To count
    Dim v() As Double
    Call oColorMapper.GetValues(v)
    Dim vMid As Double
    vMid = v(oColorMapper.ValueCount / 2)
    For j = 0 To oColorMapper.ValueCount - 1
        v(j) = (v(j) - vMid) * factor + vMid + offset * (v(oColorMapper.ValueCount - 1) - v(0))
    Next
    Call oColorMapper.PutValues(v)
    ThisApplication.ActiveView.Update
Next

End Sub

Function min(a, b)
    min = a
    If (b < a) Then
        min = b
    End If
End Function

Function max(a, b)
    max = a
    If (b > a) Then
        max = b
    End If
End Function

'display part thickness by adding display of surfaces offset by given distance --
'wherever they stick through the part, it's thinner than that distance at that point

Public Sub OffsetSurfaceBy(offset As Double)
    ' Get the surface body from the active document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    Dim oSurfBody As SurfaceBody
    Set oSurfBody = oPartDoc.ComponentDefinition.SurfaceBodies.Item(1)
    Set oSurfBody = oPartDoc.ComponentDefinitions.Item(1).SurfaceBodies.Item(1)

    ' Delete the graphics data set and client graphics, if they exist.
    Dim oDataSets As GraphicsDataSets
    On Error Resume Next
    Set oDataSets = oPartDoc.GraphicsDataSetsCollection.Item("CG_Test")
    If Err.Number = 0 Then
        oDataSets.Delete
        oPartDoc.ComponentDefinition.ClientGraphicsCollection.Item("CG_Test").Delete
        oSurfBody.Visible = True
        ThisApplication.ActiveView.Update
    End If
    On Error GoTo 0

'    If offset = 0 Then
'        Exit Sub
'    End If

    ' Determine the highest tolerance of the existing facet sets.
    Dim ToleranceCount As Long
    Dim ExistingTolerances() As Double
    Call oSurfBody.GetExistingFacetTolerances(ToleranceCount, ExistingTolerances)

    Dim i As Long
    Dim BestTolerance As Double
    For i = 0 To ToleranceCount - 1
        If i = 0 Then
            BestTolerance = ExistingTolerances(i)
        ElseIf ExistingTolerances(i) < BestTolerance Then
            BestTolerance = ExistingTolerances(i)
        End If
    Next

    ' Get a set of existing facets.
    Dim iVertexCount As Long
    Dim iFacetCount As Long
    Dim adVertexCoords() As Double
    Dim adNormalVectors() As Double
    Dim aiVertexIndices() As Long
    Call oSurfBody.GetExistingFacets(BestTolerance, iVertexCount, iFacetCount, _
                                    adVertexCoords, adNormalVectors, aiVertexIndices)

    ' >>>> offset vertices by given distance along anti-normals
    For i = 0 To (iVertexCount * 3 - 1)
        adVertexCoords(i) = adVertexCoords(i) - adNormalVectors(i) * offset
    Next

    ' Start a transaction.
    Dim oTrans As Transaction
    Set oTrans = ThisApplication.TransactionManager.StartTransaction(oPartDoc, "Z Height Colors")

    ' Create the graphics data sets collection.
    Set oDataSets = oPartDoc.GraphicsDataSetsCollection.Add("CG_Test")

    ' Create the coordinate set and set it using the coordinates from the facets.
    Dim oGraphicsCoordSet As GraphicsCoordinateSet
    Set oGraphicsCoordSet = oDataSets.CreateCoordinateSet(1)
    Call oGraphicsCoordSet.PutCoordinates(adVertexCoords)

    ' Create the index set and set it using the indices from the facets.
    Dim oGraphicsIndexSet As GraphicsIndexSet
    Set oGraphicsIndexSet = oDataSets.CreateIndexSet(2)
    Call oGraphicsIndexSet.PutIndices(aiVertexIndices)

    ' Create the normal set and set it using the normals from the facets.
    Dim oGraphicsNormalSet As GraphicsNormalSet
    Set oGraphicsNormalSet = oDataSets.CreateNormalSet(3)
    Call oGraphicsNormalSet.PutNormals(adNormalVectors)

    ' Allocate the array that will contain the color information.
    ' This array contains RGB values for each vertex.
    Dim abtColors() As Byte
    ReDim abtColors(0 To iVertexCount * 3 - 1) As Byte

    ' Load the array with color information for each vertex.
    For i = 0 To iVertexCount - 1
        ' Set the color information for the current vertex.
        ' currently, all vertices are a constant color, but ...
        abtColors(i * 3) = 200
        abtColors(i * 3 + 1) = 0
        abtColors(i * 3 + 2) = 0
    Next

    ' Create the color set and set it using the array of rgb values just created.
    Dim oGraphicsColorSet As GraphicsColorSet
    Set oGraphicsColorSet = oDataSets.CreateColorSet(4)
    Call oGraphicsColorSet.PutColors(abtColors)

    ' Create a scalar data texture coordinate set representing distance from origin
    Dim oTCSet As GraphicsTextureCoordinateSet
    Set oTCSet = oDataSets.CreateTextureCoordinateSet(5)
    Dim tc() As Double
    ReDim tc(1 To iVertexCount) As Double
    Dim tcMax As Double
    tcMax = 0
    Dim tcMin As Double
    tcMin = 1000000#
    For i = 1 To iVertexCount
        tc(i) = Sqr(adVertexCoords(3 * (i - 1)) * adVertexCoords(3 * (i - 1)) + adVertexCoords(3 * (i - 1) + 1) * adVertexCoords(3 * (i - 1) + 1) + adVertexCoords(3 * (i - 1) + 2) * adVertexCoords(3 * (i - 1) + 2))
        tcMin = min(tcMin, tc(i))
        tcMax = max(tcMax, tc(i))
    Next
    Call oTCSet.PutCoordinates(tc)

    ' Create the client graphics collection.
    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oPartDoc.ComponentDefinition.ClientGraphicsCollection.Add("CG_Test")

    ' Create a graphics node.
    Dim oGraphicNode As GraphicsNode
    Set oGraphicNode = oClientGraphics.AddNode(100)

    ' Create the triangle graphics.
    Dim oTriangles As TriangleGraphics
    Set oTriangles = oGraphicNode.AddTriangleGraphics

    '============================================

    Dim oColorMapper As GraphicsColorMapper
    Set oColorMapper = oDataSets.CreateColorMapper

    '============================================

    'construct ColorMapper:
    '  black - red - orange - yellow - green - cyan - blue - magenta - black
    '      minV                          ...                        maxV
    Dim nColors As Integer
    nColors = 9

    Dim cmColors() As Byte
    ReDim cmColors(1 To nColors * 3) As Byte
    For i = 1 To nColors * 3
        cmColors(i) = 0
    Next
    'black
    cmColors(4) = 255       'red
    cmColors(7) = 255       'orange
    cmColors(7 + 1) = 125
    cmColors(10) = 255      'yellow
    cmColors(10 + 1) = 255
    cmColors(13 + 1) = 255  'green
    cmColors(16 + 1) = 255  'cyan
    cmColors(16 + 2) = 255
    cmColors(19 + 2) = 255  'blue
    cmColors(22) = 255      'magenta
    cmColors(22 + 2) = 255
    'black

    Dim nValues As Integer
    If (mapperType = 0) Then
        nValues = nColors - 1   'discrete value boundaries
    Else
        nValues = nColors       'continuous value points
    End If

    Dim cmValues() As Double
    ReDim cmValues(1 To nValues) As Double
    For i = 1 To nValues
        cmValues(i) = tcMin + (tcMax - tcMin) * (i - 1#) / (nValues - 1#)
    Next

    '============================================

    Call oColorMapper.PutColors(cmColors)
    Call oColorMapper.PutValues(cmValues)

    ' Set various properties of the triangle graphics.
    oTriangles.CoordinateSet = oGraphicsCoordSet
    oTriangles.CoordinateIndexSet = oGraphicsIndexSet
    oTriangles.NormalSet = oGraphicsNormalSet
    oTriangles.NormalBinding = kPerVertexNormals
    oTriangles.NormalIndexSet = oGraphicsIndexSet
'    oTriangles.ColorSet = oGraphicsColorSet
'    oTriangles.ColorBinding = kPerVertexColors
'    oTriangles.ColorIndexSet = oGraphicsIndexSet
    oTriangles.TextureCoordinateSet = oTCSet
    oTriangles.TextureCoordinateIndexSet = oGraphicsIndexSet
    oTriangles.ColorMapper = oColorMapper

    ' End the transaction.
    oTrans.End

    ' Update the view.
    ThisApplication.ActiveView.Update
End Sub

Public Sub increaseOffset()
    lastOffset = lastOffset * 1.1
    Dim offset As Double
    offset = lastOffset
    Call OffsetSurfaceBy(offset)
End Sub

Public Sub DecreaseOffset()
    lastOffset = lastOffset * 0.9
    Dim offset As Double
    offset = lastOffset
    Call OffsetSurfaceBy(offset)
End Sub

Public Sub OffsetSurface()
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim lenunits As UnitsTypeEnum
    lenunits = oPartDoc.UnitsOfMeasure.LengthUnits
    Dim unitscale As Double
    Dim unitname As String
    If lenunits = kInchLengthUnits Then
        unitscale = 2.54
        unitname = "inches"
    Else
    If lenunits = kMillimeterLengthUnits Then
        unitscale = 0.1
        unitname = "millimeters"
    Else
    If lenunits = kCentimeterLengthUnits Then
        unitscale = 1#
        unitname = "centimeters"
    End If
    End If
    End If

    Dim offset As Double
    offset = 0
    On Error Resume Next
    offset = InputBox("Enter offset (in " + unitname + "):", "Offset", lastOffset / unitscale)
    On Error GoTo 0

    lastOffset = offset * unitscale

    Call OffsetSurfaceBy(lastOffset)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface


GraphicsColorMapper Methods

GraphicsColorMapper Methods
Summary

The methods of the GraphicsColorMapper class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the GraphicsColorMapper object.
GetColors | Method that gets all of the colors in the map.
GetValues | Method that gets all of the values in the map.
MappedColor | Property that returns the color at a given value in the map. This property is informational only and need not be used when assigning a color map to a primitive.
PutColors | Method that sets all of the colors in the map. This will replace all existing colors currently defined for the map.
PutValues | Method that sets all of the values in the map. This will replace all existing values currently defined for the map.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods


GraphicsColorMapper.Delete Method

GraphicsColorMapper.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the GraphicsColorMapper object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods > GraphicsColorMapper.Delete Method


GraphicsColorMapper.GetColors Method

GraphicsColorMapper.GetColors Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets all of the colors in the map.

Visual Basic
Sub GetColors(ByRef Colors As SAFEARRAY(unsigned char))
Parameters
Parameters | Description
Colors | Output array of bytes that contains the values of the colors. The array is a single dimension array containing sequential red, green, and blue values. If the array has been declared undimensioned, this method will redimension its size to be able to contain the complete set of colors. If the array has been dimensioned, it must be large enough to contain the entire set of colors or an error will occur.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods > GraphicsColorMapper.GetColors Method


GraphicsColorMapper.GetValues Method

GraphicsColorMapper.GetValues Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets all of the values in the map.

Visual Basic
Sub GetValues(ByRef Values As SAFEARRAY(double))
Parameters
Parameters | Description
Values | Output array of Doubles that contains the values in the map. The array is a single dimension array containing the scalar values. If the array has been declared undimensioned, this method will redimension its size to be able to contain the complete set of values. If the array has been dimensioned, it must be large enough to contain the entire set of values or an error will occur.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods > GraphicsColorMapper.GetValues Method


GraphicsColorMapper.MappedColor Method

GraphicsColorMapper.MappedColor Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the color at a given value in the map. This property is informational only and need not be used when assigning a color map to a primitive.

Visual Basic
Sub MappedColor(Value As double, Result As [out, retval] Color*)
Parameters
Parameters | Description
Value | Double value to retrieve the color for.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods > GraphicsColorMapper.MappedColor Method


GraphicsColorMapper.PutColors Method

GraphicsColorMapper.PutColors Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets all of the colors in the map. This will replace all existing colors currently defined for the map.

Visual Basic
Sub PutColors(Colors As SAFEARRAY(unsigned char))
Parameters
Parameters | Description
Colors | Input array of Bytes that contains the values of the colors. The array is a single dimension array containing sequential red, green, and blue values.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods > GraphicsColorMapper.PutColors Method


GraphicsColorMapper.PutValues Method

GraphicsColorMapper.PutValues Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets all of the values in the map. This will replace all existing values currently defined for the map.

Visual Basic
Sub PutValues(Values As SAFEARRAY(double))
Parameters
Parameters | Description
Values | Input array of Doubles that contains the values.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Methods > GraphicsColorMapper.PutValues Method


GraphicsColorMapper Properties

GraphicsColorMapper Properties
Summary

The properties of the GraphicsColorMapper class are listed here.

Methods
Methods
Name | Description
Color | Property that gets and sets the color at a given index in the set.
Value | Property that gets and sets the value at a given index in the set.
Properties
Name | Description
ColorCount | Property that returns the number of colors defined within the set.
Type | Returns an ObjectTypeEnum indicating this object's type.
ValueCount | Property that returns the number of values defined within the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Properties


GraphicsColorMapper.Color Method

GraphicsColorMapper.Color Method
Summary

Property that gets and sets the color at a given index in the set.

Visual Basic
Sub Color(Index As long, Result As [out, retval] Color*)
Parameters
Parameters | Description
Index | Index into the list of colors.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Properties > GraphicsColorMapper.Color Method


GraphicsColorMapper.ColorCount Property

GraphicsColorMapper.ColorCount Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of colors defined within the set.

Visual Basic
Property ColorCount() As long*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Properties > GraphicsColorMapper.ColorCount Property


GraphicsColorMapper.Type Property

GraphicsColorMapper.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Properties > GraphicsColorMapper.Type Property


GraphicsColorMapper.ValueCount Property

GraphicsColorMapper.ValueCount Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of values defined within the set.

Visual Basic
Property ValueCount() As long*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Properties > GraphicsColorMapper.ValueCount Property


GraphicsColorMapper.Value Method

GraphicsColorMapper.Value Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the value at a given index in the set.

Visual Basic
Sub Value(Index As long, Result As [out, retval] double)
Parameters
Parameters | Description
Index | Input array of Doubles that contains the values.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorMapper Interface > GraphicsColorMapper Properties > GraphicsColorMapper.Value Method


GraphicsColorSet Interface

GraphicsColorSet Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsColorSet object contains a list of colors. This object can be referenced by any number of graphic primitives to use in defining triangle or vertex specific colors to use when rendering.

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsColorSet
Visual Basic
Public Interface GraphicsColorSet
Inherits GraphicsDataSet
Remarks

The GraphicsColorSet has no direct relationship to a specific coordinate set. The relation is made when defining the graphic primitive. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateColorSet

LineGraphics.ColorSet

LineStripGraphics.ColorSet

TriangleFanGraphics.ColorSet

TriangleGraphics.ColorSet

TriangleStripGraphics.ColorSet

See Also

Client graphics texture-based color mapping sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorSet Interface


GraphicsColorSet Methods

GraphicsColorSet Methods
Summary

The methods of the GraphicsColorSet class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new color to the set.
Color | Property that gets and sets the color at a given index in the set.
GetColors | Method that gets all of the colors of the set.
PutColors | Method that sets all of the colors of the set. This will replace all existing colors currently defined for the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorSet Interface > GraphicsColorSet Methods


GraphicsColorSet.Add Method

GraphicsColorSet.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that adds a new color to the set.

Visual Basic
Sub Add(Index As long, Red As unsigned char, Green As unsigned char, Blue As unsigned char)
Parameters
Parameters | Description
Red | Input value that specifies the red component of the color. This must be a value between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | The blue component of the color. A Byte value between 0 and 255.
index | Input Long value that specifies the index of the object to return.
See Also

InteractionGraphics sample

Client Graphics - Line sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorSet Interface > GraphicsColorSet Methods > GraphicsColorSet.Add Method


GraphicsColorSet.Color Method

GraphicsColorSet.Color Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the color at a given index in the set.

Visual Basic
Sub Color(Index As long, Result As [out, retval] Color*)
Parameters
Parameters | Description
Index | Index into the list of colors.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorSet Interface > GraphicsColorSet Methods > GraphicsColorSet.Color Method


GraphicsColorSet.GetColors Method

GraphicsColorSet.GetColors Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets all of the colors of the set.

Visual Basic
Sub GetColors(ByRef Colors As SAFEARRAY(unsigned char))
Parameters
Parameters | Description
Colors | Output array of bytes that contains the values of the colors. The array is a single dimension array containing sequential red, green, and blue values. If the array has been declared undimensioned, this method will redimension its size to be able to contain the complete set of colors. If the array has been dimensioned, it must be large enough to contain the entire set of colors or an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorSet Interface > GraphicsColorSet Methods > GraphicsColorSet.GetColors Method


GraphicsColorSet.PutColors Method

GraphicsColorSet.PutColors Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets all of the colors of the set. This will replace all existing colors currently defined for the set.

Visual Basic
Sub PutColors(ByRef Colors As SAFEARRAY(unsigned char))
Parameters
Parameters | Description
Colors | Input array of bytes that contains the values of the colors. The array is a single dimension array containing sequential red, green, and blue values.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsColorSet Interface > GraphicsColorSet Methods > GraphicsColorSet.PutColors Method


GraphicsCoordinateSet Interface

GraphicsCoordinateSet Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsCoordinateSet object contains a list of coordinate values. This object can be referenced by any number of graphic primitives to use in defining their coordinates.

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsCoordinateSet
Visual Basic
Public Interface GraphicsCoordinateSet
Inherits GraphicsDataSet
Remarks

The list of coordinates is used in different ways depending on the object that is referencing it. See the various graphic primitives for information about what their requirements are for the coordinate set. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateCoordinateSet

LineGraphics.CoordinateSet

LineStripGraphics.CoordinateSet

PointGraphics.CoordinateSet

TriangleFanGraphics.CoordinateSet

TriangleGraphics.CoordinateSet

TriangleStripGraphics.CoordinateSet

See Also

Client graphics - image in point graphics sample

Client graphics texture-based color mapping sample

OnDrag Event - dragging a WorkPoint sample

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsCoordinateSet Interface


GraphicsCoordinateSet Methods

GraphicsCoordinateSet Methods
Summary

The methods of the GraphicsCoordinateSet class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a single coordinate to the set.
Coordinate | Property that gets and set the value of a specific coordinate within the set.
GetCoordinates | Method that gets all of the coordinates of the set.
PutCoordinates | Method that sets all of the coordinates of the set. This will replace all existing coordinates currently defined for the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsCoordinateSet Interface > GraphicsCoordinateSet Methods


GraphicsCoordinateSet.Add Method

GraphicsCoordinateSet.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that adds a single coordinate to the set.

Visual Basic
Sub Add(Index As long, Coordinate As Point)
Parameters
Parameters | Description
Coordinate | Input object that specifies the coordinate to add.
index | Specifies the index you want this coordinate to be within the set. All coordinates above the Index will be shifted up to make room for this index. Specifying any number greater than the current count of the set will cause the coordinate to become the last in the set. The coordinate set indices are one-based.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsCoordinateSet Interface > GraphicsCoordinateSet Methods > GraphicsCoordinateSet.Add Method


GraphicsCoordinateSet.Coordinate Method

GraphicsCoordinateSet.Coordinate Method
Summary

Property that gets and set the value of a specific coordinate within the set.

Visual Basic
Sub Coordinate(Index As long, Result As [out, retval] Point*)
Parameters
Parameters | Description
index | Index into the list of coordinates. The coordinate set indices are one-based, meaning the first coordinate in the list is index one.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsCoordinateSet Interface > GraphicsCoordinateSet Methods > GraphicsCoordinateSet.Coordinate Method


GraphicsCoordinateSet.GetCoordinates Method

GraphicsCoordinateSet.GetCoordinates Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets all of the coordinates of the set.

Visual Basic
Sub GetCoordinates(ByRef Coordinates As SAFEARRAY(double))
Parameters
Parameters | Description
Coordinates | Input/output array of Doubles that contains the x-y-z value of the coordinates. The array is a single dimension array containing sequential x, y, and z values. If the array has been declared undimensioned, this method will redimension its size to be able to contain the complete set of coordinates. If the array has been dimensioned, it must be large enough to contain the entire set of coordinates or an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsCoordinateSet Interface > GraphicsCoordinateSet Methods > GraphicsCoordinateSet.GetCoordinates Method


GraphicsCoordinateSet.PutCoordinates Method

GraphicsCoordinateSet.PutCoordinates Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets all of the coordinates of the set. This will replace all existing coordinates currently defined for the set.

Visual Basic
Sub PutCoordinates(ByRef Coordinates As SAFEARRAY(double))
Parameters
Parameters | Description
Coordinates | Input/output array of Doubles that contains the x-y-z value of the coordinates. The array is a single dimension array containing sequential x, y, z values.
See Also

Client graphics - image in point graphics sample

Client graphics texture-based color mapping sample

OnDrag Event - dragging a WorkPoint sample

InteractionGraphics sample

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsCoordinateSet Interface > GraphicsCoordinateSet Methods > GraphicsCoordinateSet.PutCoordinates Method


GraphicsDataSet Interface

GraphicsDataSet Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsDataSet object is the base class for the various utility objects used for creating custom graphics.

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsColorSet
    Inventor::GraphicsCoordinateSet
    Inventor::GraphicsImageSet
    Inventor::GraphicsIndexSet
    Inventor::GraphicsNormalSet
    Inventor::GraphicsTextureCoordinateSet
Visual Basic
Public Interface GraphicsDataSet
Inherits IDispatch
Remarks

These objects don't represent actual graphics themselves, but contain the raw data that can be used in defining graphics objects and how they display. The objects that derive from this object are GraphicsCoordinateSet, GraphicsIndexSet, GraphicsNormalSet, and GraphicsColorSet. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.Item

GraphicsDataSets.ItemById

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface


GraphicsDataSet Methods

GraphicsDataSet Methods
Summary

The methods of the GraphicsDataSet class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the GraphicsDataSet.
Remove | Method that removes a coordinate from the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Methods


GraphicsDataSet.Delete Method

GraphicsDataSet.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the GraphicsDataSet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Methods > GraphicsDataSet.Delete Method


GraphicsDataSet.Remove Method

GraphicsDataSet.Remove Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that removes a coordinate from the set.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Specifies the index you want to remove from the set. All coordinates above the Index will be shifted down. The coordinate set indices are one-based.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Methods > GraphicsDataSet.Remove Method


GraphicsDataSet Properties

GraphicsDataSet Properties
Summary

The properties of the GraphicsDataSet class are listed here.

Properties
Name | Description
Count | Property that returns the number of objects in this collection.
Id | Property returning the unique id of this GraphicsDataSet.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Properties


GraphicsDataSet.Count Property

GraphicsDataSet.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of objects in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Properties > GraphicsDataSet.Count Property


GraphicsDataSet.Id Property

GraphicsDataSet.Id Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning the unique id of this GraphicsDataSet.

Visual Basic
Property Id() As long*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Properties > GraphicsDataSet.Id Property


GraphicsDataSet.Type Property

GraphicsDataSet.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSet Interface > GraphicsDataSet Properties > GraphicsDataSet.Type Property


GraphicsDataSets Interface

GraphicsDataSets Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GrahicsDataSets object supports methods to create the various graphics-related data objects.

Class Hierarchy
Inventor::GraphicsDataSets
Visual Basic
Public Interface GraphicsDataSets
Inherits IDispatch
Remarks

The objects created by this utility don't represent actual graphics themselves, but contain the raw data that can be used in defining graphics objects and how they display. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

GraphicsDataSetsCollection.Add

GraphicsDataSetsCollection.Add2

GraphicsDataSetsCollection.Item

InteractionGraphics.GraphicsDataSets

See Also

Client graphics - image in point graphics sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

OnDrag Event - dragging a WorkPoint sample

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface


GraphicsDataSets Methods

GraphicsDataSets Methods
Summary

The methods of the GraphicsDataSets class are listed here.

Methods
Methods
Name | Description
CreateColorMapper | Method that creates a new GraphicsColorMapper object.
CreateColorSet | Method that creates a new GraphicsColorSet object. You use methods provided by the ColorSet object to define the colors.
CreateCoordinateSet | Method that creates a new GraphicsCoordinateSet object. You use methods provided by the CoordinateSet object to define the coordinates.
CreateImageSet | Method that creates a new GraphicsImageSet object. You use methods provided by the GraphicsImageSet object to define the images.
CreateIndexSet | Method that creates a new GraphicsIndexSet object. You use methods provided by the GraphicsIndexSet object to define the indices.
CreateNormalSet | Method that creates a new GraphicsNormalSet object. You use methods provided by the NormalSet object to define the normal vectors.
CreateTextureCoordinateSet | Method that creates a new GraphicsTextureCoordinateSet object. You use methods provided by the GraphicsTextureCoordinateSet object to define the coordinates.
Delete | Method that deletes the GraphicsDataSets object.
Item | Property that returns the specified object from the collection.
ItemById | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods


GraphicsDataSets.CreateColorMapper Method

GraphicsDataSets.CreateColorMapper Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new GraphicsColorMapper object.

Visual Basic
Sub CreateColorMapper(Result As [out, retval] GraphicsColorMapper*)
Remarks

Note that this object does not derive from the GraphicsDataSet object. This is a transient object that maps scalar values to colors. Use methods provided by the GraphicsColorMapper object to define the scalar values and colors. The same object can be used to define the mapping for multiple graphics primitives using the ColorMapper property on the primitives.

Example

See GraphicsColorMapper for sample code.

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateColorMapper Method


GraphicsDataSets.CreateColorSet Method

GraphicsDataSets.CreateColorSet Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new GraphicsColorSet object. You use methods provided by the ColorSet object to define the colors.

Visual Basic
Sub CreateColorSet(DataSetId As long, Result As [out, retval] GraphicsColorSet*)
Parameters
Parameters | Description
DataSetId | Input Long that specifies the unique identifier for the GraphicsDataSet object. This must be unique with respect to all other GraphicsDataSet objects within this GraphicsDataSets object.
See Also

Client graphics texture-based color mapping sample

InteractionGraphics sample

Client Graphics - Line sample

Example

"Client Graphics - Vertex Color by Z Height Example"

This sample demonstrates using client graphics and some other functions that help to support display control. It uses the currently active part and replaces the part display with a display where the part's color varies from blue to red where blue is assigned to the lowest Z portion of the part and red is assigned to the highest Z portion of the part. Areas in between are represented by a smooth blend of color from blue to red.

Public Sub ZHeightColors()
    ' Get the surface body from the active document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    Dim oSurfBody As SurfaceBody
    Set oSurfBody = oPartDoc.ComponentDefinition.SurfaceBodies.Item(1)
    Set oSurfBody = oPartDoc.ComponentDefinitions.Item(1).SurfaceBodies.Item(1)

    ' Delete the graphics data set and client graphics, if they exist.
    Dim oDataSets As GraphicsDataSets
    On Error Resume Next
    Set oDataSets = oPartDoc.GraphicsDataSetsCollection.Item("MyTest")
    If Err.Number = 0 Then
        oDataSets.Delete
        oPartDoc.ComponentDefinition.ClientGraphicsCollection.Item("MyTest").Delete
        oSurfBody.Visible = True
        ThisApplication.ActiveView.Update
        Exit Sub
    End If
    On Error GoTo 0

    ' Determine the highest tolerance of the existing facet sets.
    Dim ToleranceCount As Long
    Dim ExistingTolerances() As Double
    Call oSurfBody.GetExistingFacetTolerances(ToleranceCount, ExistingTolerances)

    Dim i As Long
    Dim BestTolerance As Double
    For i = 0 To ToleranceCount - 1
        If i = 0 Then
            BestTolerance = ExistingTolerances(i)
        ElseIf ExistingTolerances(i) < BestTolerance Then
            BestTolerance = ExistingTolerances(i)
        End If
    Next

    ' Get a set of existing facets.
    Dim iVertexCount As Long
    Dim iFacetCount As Long
    Dim adVertexCoords() As Double
    Dim adNormalVectors() As Double
    Dim aiVertexIndices() As Long
    Call oSurfBody.GetExistingFacets(BestTolerance, iVertexCount, iFacetCount, _
                                    adVertexCoords, adNormalVectors, aiVertexIndices)

    ' Start a transaction.
    Dim oTrans As Transaction
    Set oTrans = ThisApplication.TransactionManager.StartTransaction(oPartDoc, "Z Height Colors")

    ' Create the graphics data sets collection.
    Set oDataSets = oPartDoc.GraphicsDataSetsCollection.Add("MyTest")

    ' Create the coordinate set and set it using the coordinates from the facets.
    Dim oGraphicsCoordSet As GraphicsCoordinateSet
    Set oGraphicsCoordSet = oDataSets.CreateCoordinateSet(1)
    Call oGraphicsCoordSet.PutCoordinates(adVertexCoords)

    ' Create the index set and set it using the indices from the facets.
    Dim oGraphicsIndexSet As GraphicsIndexSet
    Set oGraphicsIndexSet = oDataSets.CreateIndexSet(2)
    Call oGraphicsIndexSet.PutIndices(aiVertexIndices)

    ' Create the normal set and set it using the normals from the facets.
    Dim oGraphicsNormalSet As GraphicsNormalSet
    Set oGraphicsNormalSet = oDataSets.CreateNormalSet(3)
    Call oGraphicsNormalSet.PutNormals(adNormalVectors)

    ' Determine the min-max range of the body in Z.
    Dim dMinZ As Double
    dMinZ = oSurfBody.RangeBox.MinPoint.Z
    Dim dMaxZ As Double
    dMaxZ = oSurfBody.RangeBox.MaxPoint.Z
    Dim dHeightDifference As Double
    dHeightDifference = dMaxZ - dMinZ

    ' Allocate the array that will contain the color information.
    ' This array contains RGB values for each vertex.
    Dim abtColors() As Byte
    ReDim abtColors(0 To iVertexCount * 3 - 1) As Byte

    ' Load the array with color information for each vertex.
    For i = 0 To iVertexCount - 1
        ' Get the Z height of the current vertex.
        Dim dZValue As Double
        dZValue = adVertexCoords(i * 3 + 2)

        ' Set the color information for the current vertex.  It's computed by
        ' determining the percentage of the total Z range of the body this vertex
        ' is within.  A color between red and blue is computed based on this percentage.
        ' Blue is at the minimum Z and Red is at the maximum Z with blending between.
        abtColors(i * 3) = ((dZValue - dMinZ) / dHeightDifference) * 255
        abtColors(i * 3 + 1) = 0
        abtColors(i * 3 + 2) = ((dMaxZ - dZValue) / dHeightDifference) * 255
    Next

    ' Create the color set and set it using the array of rgb values just created.
    Dim oGraphicsColorSet As GraphicsColorSet
    Set oGraphicsColorSet = oDataSets.CreateColorSet(4)
    Call oGraphicsColorSet.PutColors(abtColors)

    ' Create the client graphics collection.
    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oPartDoc.ComponentDefinition.ClientGraphicsCollection.Add("MyTest")

    ' Create a graphics node.
    Dim oGraphicNode As GraphicsNode
    Set oGraphicNode = oClientGraphics.AddNode(1)

    ' Create the triangle graphics.
    Dim oTriangles As TriangleGraphics
    Set oTriangles = oGraphicNode.AddTriangleGraphics

    ' Set various prroperties of the triangle graphics.
    oTriangles.CoordinateSet = oGraphicsCoordSet
    oTriangles.CoordinateIndexSet = oGraphicsIndexSet
    oTriangles.NormalSet = oGraphicsNormalSet
    oTriangles.NormalBinding = kPerVertexNormals
    oTriangles.NormalIndexSet = oGraphicsIndexSet
    oTriangles.ColorSet = oGraphicsColorSet
    oTriangles.ColorBinding = kPerVertexColors
    oTriangles.ColorIndexSet = oGraphicsIndexSet

    ' Turn off the display of the body.
    oSurfBody.Visible = False

    ' End the transaction.
    oTrans.End

    ' Update the view.
    ThisApplication.ActiveView.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateColorSet Method


GraphicsDataSets.CreateCoordinateSet Method

GraphicsDataSets.CreateCoordinateSet Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new GraphicsCoordinateSet object. You use methods provided by the CoordinateSet object to define the coordinates.

Visual Basic
Sub CreateCoordinateSet(DataSetId As long, Result As [out, retval] GraphicsCoordinateSet*)
Parameters
Parameters | Description
DataSetId | Input Long that specifies the unique identifier for the GraphicsDataSet object. This must be unique with respect to all other GraphicsDataSet objects within this GraphicsDataSets object.
See Also

Client graphics - image in point graphics sample

Client graphics texture-based color mapping sample

OnDrag Event - dragging a WorkPoint sample

InteractionGraphics sample

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateCoordinateSet Method


GraphicsDataSets.CreateImageSet Method

GraphicsDataSets.CreateImageSet Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new GraphicsImageSet object. You use methods provided by the GraphicsImageSet object to define the images.

Visual Basic
Sub CreateImageSet(DataSetId As long, Result As [out, retval] GraphicsImageSet*)
Parameters
Parameters | Description
DataSetId | Specifies the unique identifier for the GraphicsImageSet object. This must be unique with respect to all other GraphicsDataSet objects within this GraphicDataSets collection object.
Remarks

This method will fail in the case where the GraphicDataSets object can be saved with the document. This occurs when the GraphicDataSets object was created using the Add2 method and the SaveWithDocument argument was True.

See Also

Client graphics - image in point graphics sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateImageSet Method


GraphicsDataSets.CreateIndexSet Method

GraphicsDataSets.CreateIndexSet Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new GraphicsIndexSet object. You use methods provided by the GraphicsIndexSet object to define the indices.

Visual Basic
Sub CreateIndexSet(DataSetId As long, Result As [out, retval] GraphicsIndexSet*)
Parameters
Parameters | Description
DataSetId | Input Long that specifies the unique identifier for the GraphicsDataSet object. This must be unique with respect to all other GraphicsDataSet objects within this GraphicsDataSets object.
See Also

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateIndexSet Method


GraphicsDataSets.CreateNormalSet Method

GraphicsDataSets.CreateNormalSet Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new GraphicsNormalSet object. You use methods provided by the NormalSet object to define the normal vectors.

Visual Basic
Sub CreateNormalSet(DataSetId As long, Result As [out, retval] GraphicsNormalSet*)
Parameters
Parameters | Description
DataSetId | Input Long that specifies the unique identifier for the GraphicsDataSet object. This must be unique with respect to all other GraphicsDataSet objects within this GraphicsDataSets object.
See Also

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateNormalSet Method


GraphicsDataSets.CreateTextureCoordinateSet Method

GraphicsDataSets.CreateTextureCoordinateSet Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new GraphicsTextureCoordinateSet object. You use methods provided by the GraphicsTextureCoordinateSet object to define the coordinates.

Visual Basic
Sub CreateTextureCoordinateSet(DataSetId As long, Result As [out, retval] GraphicsTextureCoordinateSet*)
Parameters
Parameters | Description
DataSetId | Specifies the unique identifier for the GraphicsTextureCoordinateSet object. This must be unique with respect to all other GraphicsDataSet objects within this GraphicDataSets collection object.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.CreateTextureCoordinateSet Method


GraphicsDataSets.Delete Method

GraphicsDataSets.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the GraphicsDataSets object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.Delete Method


GraphicsDataSets.Item Method

GraphicsDataSets.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GraphicsDataSet*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.Item Method


GraphicsDataSets.ItemById Method

GraphicsDataSets.ItemById Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub ItemById(DataSetId As long, Result As [out, retval] GraphicsDataSet*)
Parameters
Parameters | Description
DataSetId | Input Long that specifies the ID of the object within the collection.
See Also

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Methods > GraphicsDataSets.ItemById Method


GraphicsDataSets Properties

GraphicsDataSets Properties
Summary

The properties of the GraphicsDataSets class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property that returns the unique identifier for the GraphicsDataSets object. The ClientId is assigned during the creation of the GraphicsDataSets object. Typically, it is a GUID in string form, but any string is valid.
Count | Property that returns the number of GraphicDataSet objects in this collection.
NonTransacting | Property that returns whether the creation of this GraphicsDataSets object and all its associated data is non-transacting.
Parent | Property returns the parent of this object.
SaveWithDocument | Property that returns whether to save the GraphicsDataSets with the document.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties


GraphicsDataSets.Application Property

GraphicsDataSets.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.Application Property


GraphicsDataSets.ClientId Property

GraphicsDataSets.ClientId Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the unique identifier for the GraphicsDataSets object. The ClientId is assigned during the creation of the GraphicsDataSets object. Typically, it is a GUID in string form, but any string is valid.

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.ClientId Property


GraphicsDataSets.Count Property

GraphicsDataSets.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of GraphicDataSet objects in this collection.

Visual Basic
Property Count() As long*
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.Count Property


GraphicsDataSets.NonTransacting Property

GraphicsDataSets.NonTransacting Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns whether the creation of this GraphicsDataSets object and all its associated data is non-transacting.

Visual Basic
Property NonTransacting() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.NonTransacting Property


GraphicsDataSets.Parent Property

GraphicsDataSets.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returns the parent of this object.

Visual Basic
Property Parent() As GraphicsDataSetsCollection**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.Parent Property


GraphicsDataSets.SaveWithDocument Property

GraphicsDataSets.SaveWithDocument Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether to save the GraphicsDataSets with the document.

Visual Basic
Property SaveWithDocument() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.SaveWithDocument Property


GraphicsDataSets.Type Property

GraphicsDataSets.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSets Interface > GraphicsDataSets Properties > GraphicsDataSets.Type Property


GraphicsDataSetsCollection Interface

GraphicsDataSetsCollection Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ClientGraphicsCollection object allows you to create new objects and supports access to existing GraphicsDataSets objects. See the article in the overview section for more information.

Class Hierarchy
Inventor::GraphicsDataSetsCollection
Visual Basic
Public Interface GraphicsDataSetsCollection
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Document.GraphicsDataSetsCollection

DrawingView.GraphicsDataSetsCollection

FlatPattern.GraphicsDataSetsCollection

GraphicsDataSets.Parent

Sheet.GraphicsDataSetsCollection

See Also

Client graphics - image in point graphics sample

Client Graphics - Triangle sample

Client Graphics - Line sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface


GraphicsDataSetsCollection Methods

GraphicsDataSetsCollection Methods
Summary

The methods of the GraphicsDataSetsCollection class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new GraphicsDataSets object.
Add2 | Creates a new GraphicsDataSets object with an option to save the object with the document.
AddNonTransacting | Method that creates a new GraphicsDataSets object.
Item | Property that returns an existing GraphicsDataSets object.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Methods


GraphicsDataSetsCollection.Add Method

GraphicsDataSetsCollection.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new GraphicsDataSets object.

Visual Basic
Sub Add(ClientId As String, Result As [out, retval] GraphicsDataSets*)
Parameters
Parameters | Description
ClientId | Specifies the unique identifier for the GraphicsDataSets object. This must be unique with respect to all other GraphicsDataSets objects. Typically, this is a GUID in string form, but any string is valid.
See Also

Client graphics - image in point graphics sample

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Methods > GraphicsDataSetsCollection.Add Method


GraphicsDataSetsCollection.Add2 Method

GraphicsDataSetsCollection.Add2 Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Creates a new GraphicsDataSets object with an option to save the object with the document.

Visual Basic
Sub Add2(ClientId As String, ByRef SaveWithDocument As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] GraphicsDataSets*)
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Methods > GraphicsDataSetsCollection.Add2 Method


GraphicsDataSetsCollection.AddNonTransacting Method

GraphicsDataSetsCollection.AddNonTransacting Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new GraphicsDataSets object.

Visual Basic
Sub AddNonTransacting(ClientId As String, Result As [out, retval] GraphicsDataSets*)
Parameters
Parameters | Description
ClientId | Specifies the unique identifier for the GraphicsDataSets object. This must be unique with respect to all other GraphicsDataSets objects. Typically, this is a GUID in string form, but any string is valid.
Remarks

The creation of this object and all subsequent data within this object are non-transacted and cannot be undone by the user. The creation does not dirty the document.

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Methods > GraphicsDataSetsCollection.AddNonTransacting Method


GraphicsDataSetsCollection.Item Method

GraphicsDataSetsCollection.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an existing GraphicsDataSets object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] GraphicsDataSets*)
Parameters
Parameters | Description
index | Specifies which object to return. This can be a Long, which specifies the index in the collection, or it can be the client id (which is a string). The property will fail in the case where an Index is provided that does not identify an existing GraphicsDataSets object.
See Also

Client Graphics - Triangle sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Methods > GraphicsDataSetsCollection.Item Method


GraphicsDataSetsCollection Properties

GraphicsDataSetsCollection Properties
Summary

The properties of the GraphicsDataSetsCollection class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of coordinates defined within the set.
Parent | Property returns the parent document of this object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Properties


GraphicsDataSetsCollection.Application Property

GraphicsDataSetsCollection.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Properties > GraphicsDataSetsCollection.Application Property


GraphicsDataSetsCollection.Count Property

GraphicsDataSetsCollection.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of coordinates defined within the set.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Properties > GraphicsDataSetsCollection.Count Property


GraphicsDataSetsCollection.Parent Property

GraphicsDataSetsCollection.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returns the parent document of this object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Properties > GraphicsDataSetsCollection.Parent Property


GraphicsDataSetsCollection.Type Property

GraphicsDataSetsCollection.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsDataSetsCollection Interface > GraphicsDataSetsCollection Properties > GraphicsDataSetsCollection.Type Property


GraphicsImageSet Interface

GraphicsImageSet Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The GraphicsImageSet defines images that can be used when displaying client graphics objects that support images. Currently this is limited to the GraphicsPoint object.

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsImageSet
Visual Basic
Public Interface GraphicsImageSet
Inherits GraphicsDataSet
Remarks

This object derives from GraphicsDataSet.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateImageSet

See Also

Client graphics - image in point graphics sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsImageSet Interface


GraphicsImageSet Methods

GraphicsImageSet Methods
Summary

The methods of the GraphicsImageSet class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new custom point to the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsImageSet Interface > GraphicsImageSet Methods


GraphicsImageSet.Add Method

GraphicsImageSet.Add Method Introduced in Inventor 2011
Summary

Method that adds a new custom point to the set.

Visual Basic
Sub Add(Index As long, Image As IPictureDisp, ByRef TransparentColor As [optional] VARIANT, ByRef HotPointX As [defaultvalue(-1)] long, ByRef HotPointY As [defaultvalue(-1)] long)
Parameters
Parameters | Description
Index | Input Long that specifies the position you want this image to have within the set. All images above the specified index will be shifted up to make room for this image. Specifying any number greater than the current count of the set will cause the new image to become the last in the set.
Image | Input picture to use for the image. This should be the size that you want the point to appear on the screen.
TransparentColor | Optional input Color object that defines the transparent color within the image. If this argument is not supplied and the image provided doesn't define a transparent color, then there won't be any transparency.
HotPointX | Optional input Integer that defines the x coordinate of the hot spot as defined in pixels of the image where 0,0 is the top-left corner of the image. The default value of -1 will result in the center of the image being used.
HotPointY | Optional input Integer that defines the x coordinate of the hot spot as defined in pixels of the image where 0,0 is the top-left corner of the image. The default value of -1 will result in the center of the image being used.
See Also

Client graphics - image in point graphics sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsImageSet Interface > GraphicsImageSet Methods > GraphicsImageSet.Add Method


GraphicsIndexSet Interface

GraphicsIndexSet Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsIndexSet object contains a list of indices. This object can be referenced by any number of graphic primitives to use in defining the list of indices that index into a coordinate set.

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsIndexSet
Visual Basic
Public Interface GraphicsIndexSet
Inherits GraphicsDataSet
Remarks

The GraphicsIndexSet has no direct relationship to a specific coordinate set. The relation is made when the within the graphic primitive definition. The list of indices is used in different ways depending on the object that is referencing it. See the various graphic primitives for information about what their requirements are for the index set. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateIndexSet

LineGraphics.ColorIndexSet

LineGraphics.CoordinateIndexSet

LineStripGraphics.ColorIndexSet

LineStripGraphics.CoordinateIndexSet

PointGraphics.CoordinateIndexSet

TriangleFanGraphics.ColorIndexSet

TriangleFanGraphics.CoordinateIndexSet

TriangleFanGraphics.NormalIndexSet

TriangleFanGraphics.TextureCoordinateIndexSet

TriangleGraphics.ColorIndexSet

TriangleGraphics.CoordinateIndexSet

TriangleGraphics.NormalIndexSet

TriangleGraphics.TextureCoordinateIndexSet

TriangleStripGraphics.ColorIndexSet

TriangleStripGraphics.CoordinateIndexSet

TriangleStripGraphics.NormalIndexSet

TriangleStripGraphics.TextureCoordinateIndexSet

See Also

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsIndexSet Interface


GraphicsIndexSet Methods

GraphicsIndexSet Methods
Summary

The methods of the GraphicsIndexSet class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new index to the set.
GetIndices | Method that gets all of the indices of the set.
IndexValue | Property that gets and set the value of a specific index within the set.
PutIndices | Method that sets all of the indices of the set. This will replace any existing indices currently defined for the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsIndexSet Interface > GraphicsIndexSet Methods


GraphicsIndexSet.Add Method

GraphicsIndexSet.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that adds a new index to the set.

Visual Basic
Sub Add(Index As long, IndexValue As long)
Parameters
Parameters | Description
IndexValue | Input Long that specifies the index value.
index | Input Long that specifies the position you want this index to be within the set. All indices above the position will be shifted up to make room for this index. Specifying any number greater than the current count of the set will cause the index to become the last in the set. The index set indices are one-based.
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsIndexSet Interface > GraphicsIndexSet Methods > GraphicsIndexSet.Add Method


GraphicsIndexSet.GetIndices Method

GraphicsIndexSet.GetIndices Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets all of the indices of the set.

Visual Basic
Sub GetIndices(ByRef IndexValues As SAFEARRAY(long))
Parameters
Parameters | Description
IndexValues | Output array of longs that contains the indices of the set. The array is a single dimension array. If the array has been declared undimensioned, this method will redimension its size to be able to contain the complete set of indices. If the array has been dimensioned, it must be large enough to contain the entire set of indices or an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsIndexSet Interface > GraphicsIndexSet Methods > GraphicsIndexSet.GetIndices Method


GraphicsIndexSet.IndexValue Method

GraphicsIndexSet.IndexValue Method
Summary

Property that gets and set the value of a specific index within the set.

Visual Basic
Sub IndexValue(Index As long, Result As [out, retval] long)
Parameters
Parameters | Description
index | Index into the list of indices.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsIndexSet Interface > GraphicsIndexSet Methods > GraphicsIndexSet.IndexValue Method


GraphicsIndexSet.PutIndices Method

GraphicsIndexSet.PutIndices Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets all of the indices of the set. This will replace any existing indices currently defined for the set.

Visual Basic
Sub PutIndices(ByRef IndexValues As SAFEARRAY(long))
Parameters
Parameters | Description
IndexValues | Input array of longs that contains the indices into a an index set. The array is a single dimension array.
See Also

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsIndexSet Interface > GraphicsIndexSet Methods > GraphicsIndexSet.PutIndices Method


GraphicsNode Interface

GraphicsNode Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsNode object provides a logical grouping of Client graphics. It is the lowest level of detail the user will see when selecting objects.

Class Hierarchy
Inventor::GraphicsNode
    Inventor::GraphicsNodeProxy
Visual Basic
Public Interface GraphicsNode
Inherits IDispatch
Remarks

This object is used as input to Autodesk Inventor functions that require object input. For example, the GraphicsNode object can be highlighted and it can be added to the select set. The GraphicsNode can contain any number of graphic primitives, but they will display and transform as a group. See the article in the overviews section.

Notes

Members through which this object may be accessed include:

ClientGraphics.AddNode

ClientGraphics.Item

ClientGraphics.ItemById

GraphicsNode.Copy

GraphicsNodeProxy.NativeObject

GraphicsPrimitive.Parent

See Also

Client graphics - image in point graphics sample

Create client graphics based on the solid body of the active part sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Transient solid body creation sample

OnDrag Event - dragging a WorkPoint sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Client graphics creation of 3D primitives sample

Client Graphics - Triangle sample

Client graphics from SAT file body sample

Client Graphics - Line sample

Client Graphics - Vertex Color by Z Height sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface


GraphicsNode Methods

GraphicsNode Methods
Summary

The methods of the GraphicsNode class are listed here.

Methods
Methods
Name | Description
AddComponentGraphics | Method that creates a new ComponentGraphics object based on the input ComponentDefinition.
AddCurveGraphics | Method that creates a new CurveGraphics graphic primitive.
AddLineGraphics | Method that creates a new LineGraphics graphic primitive.
AddLineStripGraphics | Method that creates a new LineStripGraphics graphic primitive.
AddPointGraphics | Method that creates a new PointGraphics graphic primitive.
AddScalableTextGraphics | Method that creates a new (scalable) TextGraphics graphic primitive.
AddSurfaceGraphics | Method that creates a new SurfaceGraphics object based on the input surface(s).
AddTextGraphics | Method that creates a new TextGraphics graphic primitive.
AddTriangleFanGraphics | Method that creates a new TriangleFanGraphics graphic primitive.
AddTriangleGraphics | Method that creates a new TriangleGraphics graphic primitive.
AddTriangleStripGraphics | Method that creates a new TriangleStripGraphics graphic primitive.
ClearSlice | Method that clears all the slicing applied to the graphics node.
Copy | Method that creates a copy of this . The copy has the same property values as the original, a duplicate of all of the graphics primitives, and the CustomRenderStyle has the same values. A new ID is generated for the copy.
Delete | Method that deletes the GraphicsNode. This also deletes all associated graphic primitives.
Item | Property that returns the specified graphic entity from the collection.
SliceGraphics | Method that slices the graphics based on the input planes and optionally caps the sliced end.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods


GraphicsNode.AddComponentGraphics Method

GraphicsNode.AddComponentGraphics Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new ComponentGraphics object based on the input ComponentDefinition.

Visual Basic
Sub AddComponentGraphics(ComponentDefinition As ComponentDefinition, Result As [out, retval] ComponentGraphics*)
Parameters
Parameters | Description
ComponentDefinition | Input ComponentDefinition object (either from a part or an assembly) to create the graphics from.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddComponentGraphics Method


GraphicsNode.AddCurveGraphics Method

GraphicsNode.AddCurveGraphics Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new CurveGraphics graphic primitive.

Visual Basic
Sub AddCurveGraphics(Curve As IDispatch, Result As [out, retval] CurveGraphics*)
Parameters
Parameters | Description
Curve | Input object that defines the curve. This can be one of the following: LineSegment, Circle, Arc3d, EllipseFull, EllipticalArc, BSplineCurve and Polyline3d.
See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddCurveGraphics Method


GraphicsNode.AddLineGraphics Method

GraphicsNode.AddLineGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new LineGraphics graphic primitive.

Visual Basic
Sub AddLineGraphics(Result As [out, retval] LineGraphics*)
See Also

InteractionGraphics sample

Client Graphics - Draw Range Box sample

Example

"Client Graphics - Line Example "

This sample demonstrates the creation of custom graphics using LineGraphics and LineStripGraphics. The same set of coordinate data is used for both types of graphics. Line graphics use two coordinates to define a line, and then the next two coordinates to define the next line, and so on through the defined coordinates. For the data provided, this results in gaps in the drawn curve. Line strips use the first two coordinates to define the first line and then the last point of the first line becomes the first point of the second line and the next coordinate is used as the end point of the second line. This results in the set of points being connected by a continuous set of lines, drawing a continuous curve. This sample also demonstrates two methods of defining the color for client graphics. In one case it uses an existing rendering style, and in the other, it explicitly defines a color and assigns it. To use the sample you need to have an assembly or part document open. The program has two behaviors: the first time it is run it will draw the graphics. The second time it is run it deletes the previously drawn graphics.

Public Sub DrawCustomLines()
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active document.
    ' This assumes that a part or assembly document is active.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Check to see if the test graphics data object already exists.
    ' If it does clean up by removing all associated of the client graphics
    ' from the document.  If it doesn't create it.
    On Error Resume Next
    Dim oGraphicsData As GraphicsDataSets
    Set oGraphicsData = oDoc.GraphicsDataSetsCollection.Item("SampleGraphicsID")
    If Err.Number = 0 Then
        On Error GoTo 0
        ' An existing client graphics object was successfully obtained so clean up.
        oGraphicsData.Delete
        oCompDef.ClientGraphicsCollection.Item("SampleGraphicsID").Delete

        ' update the display to see the results.
        ThisApplication.ActiveView.Update
    Else
        Err.Clear
        On Error GoTo 0

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create a graphics data set object.  This object contains all of the
        ' information used to define the graphics.
        Dim oDataSets As GraphicsDataSets
        Set oDataSets = oDoc.GraphicsDataSetsCollection.Add("SampleGraphicsID")

        ' Create a coordinate set.
        Dim oCoordSet As GraphicsCoordinateSet
        Set oCoordSet = oDataSets.CreateCoordinateSet(1)

        ' Create an array that contains coordinates that define a set
        ' of outwardly spiraling points.
        Dim oPointCoords(1 To 90) As Double
        Dim i As Long
        Dim dRadius As Double
        dRadius = 1
        Dim dAngle As Double
        For i = 0 To 29
            ' Define the X, Y, and Z components of the point.
            oPointCoords(i * 3 + 1) = dRadius * Cos(dAngle)
            oPointCoords(i * 3 + 2) = dRadius * Sin(dAngle)
            oPointCoords(i * 3 + 3) = i / 2

            ' Increment the angle and radius to create the spiral.
            dRadius = dRadius + 0.25
            dAngle = dAngle + (3.14159265358979 / 6)
        Next

        ' Assign the points into the coordinate set.
        Call oCoordSet.PutCoordinates(oPointCoords)

        ' Create the ClientGraphics object.
        Dim oClientGraphics As ClientGraphics
        Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("SampleGraphicsID")

        ' Create a new graphics node within the client graphics objects.
        Dim oLineNode As GraphicsNode
        Set oLineNode = oClientGraphics.AddNode(1)

        ' Create a LineGraphics object within the node.
        Dim oLineSet As LineGraphics
        Set oLineSet = oLineNode.AddLineGraphics

        ' Assign the coordinate set to the line graphics.
        oLineSet.CoordinateSet = oCoordSet

        ' Assign a color to the node using an existing rendering style.  This
        ' assumes the rendering style "Purple" exists.
        oLineNode.RenderStyle = oDoc.RenderStyles.Item("Purple")

        ' Update the view to see the resulting spiral.
        ThisApplication.ActiveView.Update

        ' Create another graphics node for a line strip.
        Dim oLineStripNode As GraphicsNode
        Set oLineStripNode = oClientGraphics.AddNode(2)

        ' Create a LineStripGraphics object within the new node.
        Dim oLineStrip As LineStripGraphics
        Set oLineStrip = oLineStripNode.AddLineStripGraphics

        ' Assign the same coordinate set to the line strip.
        oLineStrip.CoordinateSet = oCoordSet

        ' Create a color set to use in defining a explicit color to the line strip.
        Dim oColorSet As GraphicsColorSet
        Set oColorSet = oDataSets.CreateColorSet(1)

        ' Add a single color to the set that is red.
        Call oColorSet.Add(1, 255, 0, 0)

        ' Assign the color set to the line strip.
        oLineStrip.ColorSet = oColorSet

        ' The two spirals are currently on top of each other so translate the
        ' new one in the x direction so they're side by side.
        Dim oMatrix As Matrix
        Set oMatrix = oLineStripNode.Transformation
        Call oMatrix.SetTranslation(oTransGeom.CreateVector(15, 0, 0))
        oLineStripNode.Transformation = oMatrix

        ' Update the view to see the resulting spiral.
        ThisApplication.ActiveView.Update
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddLineGraphics Method


GraphicsNode.AddLineStripGraphics Method

GraphicsNode.AddLineStripGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new LineStripGraphics graphic primitive.

Visual Basic
Sub AddLineStripGraphics(Result As [out, retval] LineStripGraphics*)
See Also

InteractionGraphics sample

Client Graphics - Line sample

Example

See GraphicsNode::AddLineGraphics for example "Adding line and linestrip graphics"

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddLineStripGraphics Method


GraphicsNode.AddPointGraphics Method

GraphicsNode.AddPointGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new PointGraphics graphic primitive.

Visual Basic
Sub AddPointGraphics(Result As [out, retval] PointGraphics*)
See Also

Client graphics - image in point graphics sample

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddPointGraphics Method


GraphicsNode.AddScalableTextGraphics Method

GraphicsNode.AddScalableTextGraphics Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new (scalable) TextGraphics graphic primitive.

Visual Basic
Sub AddScalableTextGraphics(Result As [out, retval] TextGraphics*)
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddScalableTextGraphics Method


GraphicsNode.AddSurfaceGraphics Method

GraphicsNode.AddSurfaceGraphics Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new SurfaceGraphics object based on the input surface(s).

Visual Basic
Sub AddSurfaceGraphics(Surfaces As IDispatch, Result As [out, retval] SurfaceGraphics*)
Parameters
Parameters | Description
Surfaces | Input object that defines the surfaces. This can be one of the following: SurfaceBody, Face, Faces or a FaceCollection object. If a FaceCollection is provided, all the Face objects in the collection must belong to the same SurfaceBody, else an error will occur. Use the various body primitive creation methods on the TransientBRep object to create bodies for input to this method.
Notes

The input body (or the body associated with the input faces) is copied and the copied body is displayed. The client graphics does not remain associative to the original input body and the copied body cannot be edited in any manner.

See Also

Create client graphics based on the solid body of the active part sample

Transient solid body creation sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Example

Client graphics from SAT file body example.

The following sample demonstrates how to display client graphics based on bodies read in from a SAT file. Make sure you have "C:\temp\block.sat" or change the path in the code below.

Public Sub ClientGraphicsFromSATFileBody()

    ' Set a reference to the TransientBRep object
    Dim oTransientBRep As TransientBRep
    Set oTransientBRep = ThisApplication.TransientBRep

    ' Get the first body from the specified sat file
    Dim oBody As SurfaceBody
    Set oBody = oTransientBRep.ReadFromFile("C:\temp\block.sat").Item(1)

    ' Create a new Part document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject)

    ' Set a reference to the compdef.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create the ClientGraphics object.
    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("Sample3DGraphicsID")

    ' Create a new graphics node within the client graphics objects.
    Dim oSurfacesNode As GraphicsNode
    Set oSurfacesNode = oClientGraphics.AddNode(1)

    ' Create client graphics based on the transient body
    Dim oSurfaceGraphics As SurfaceGraphics
    Set oSurfaceGraphics = oSurfacesNode.AddSurfaceGraphics(oBody)

    ' Update the view to see the resulting curves.
    ThisApplication.ActiveView.Update

End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddSurfaceGraphics Method


GraphicsNode.AddTextGraphics Method

GraphicsNode.AddTextGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new TextGraphics graphic primitive.

Visual Basic
Sub AddTextGraphics(Result As [out, retval] TextGraphics*)
See Also

Anchored Client Grahics sample

Example 1

"Text Using Client Graphics (Simple) Example "

This sample demonstrates creating text using client graphics. It illustrates the simple case where the text is one font and is one line.

To run the sample have a part or assembly document open.

Public Sub ClientGraphicsText()
    ' Set a reference to the document.  This will work with
    ' either a part or assembly document.
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the component definition.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    ' Attempt to get the existing client graphics object.  If it exists
    ' delete it so the rest of the code can continue as if it never existed.
    Dim oClientGraphics As ClientGraphics
    On Error Resume Next
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("Text Test")
    If Err.Number = 0 Then
        oClientGraphics.Delete
    End If
    On Error GoTo 0
    ThisApplication.ActiveView.Update

    ' Create a new ClientGraphics object.
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("Text Test")

    ' Create a graphics node.
    Dim oNode As GraphicsNode
    Set oNode = oClientGraphics.AddNode(1)

    ' Create text graphics.
    Dim oTextGraphics As TextGraphics
    Set oTextGraphics = oNode.AddTextGraphics

    ' Set the properties of the text.
    oTextGraphics.Text = "This is the sample text."
    oTextGraphics.Anchor = ThisApplication.TransientGeometry.CreatePoint(0, 0, 0)
    oTextGraphics.Bold = True
    oTextGraphics.Font = "Arial"
    oTextGraphics.FontSize = 40
    oTextGraphics.HorizontalAlignment = kAlignTextLeft
    oTextGraphics.Italic = True
    Call oTextGraphics.PutTextColor(0, 255, 0)
    oTextGraphics.VerticalAlignment = kAlignTextMiddle

    ' Update the view to see the text.
    ThisApplication.ActiveView.Update
End Sub
Example 2

"Text Using Client Graphics (Multiple fonts and lines) Example "

This sample demonstrates creating text using client graphics. It illustrates the more complex case of changes in font and more than one line.

To run the sample have a part or assembly document open.

Public Sub ClientGraphicsTextMultipleFonts()
    ' Set a reference to the document.  This will work with
    ' either a part or assembly document.
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to the component definition.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    ' Attempt to get the existing client graphics object.  If it exists
    ' delete it so the rest of the code can continue as if it never existed.
    Dim oClientGraphics As ClientGraphics
    On Error Resume Next
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("Text Test")
    If Err.Number = 0 Then
        oClientGraphics.Delete
    End If
    On Error GoTo 0
    ThisApplication.ActiveView.Update

    ' Create a new ClientGraphics object.
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("Text Test")

    ' Create a graphics node.
    Dim oNode As GraphicsNode
    Set oNode = oClientGraphics.AddNode(1)

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oModelAnchorPoint As Point
    Set oModelAnchorPoint = oTG.CreatePoint(50, 0, 0)

    ' Create several text graphics objects, one for each font change.  The anchor of the
    ' TextGraphics object defines the position of each text element relative to each other.
    ' Because they're all drawn with pixel scaling behavior these coordinates are in
    ' pixel space.  They all use the same point as input for the SetTransformBehavior call.
    ' This point is in model space and defines their anchor within the model.

    ' Draw the first character which is the diameter symbol.
    Dim oTextGraphics(1 To 4) As TextGraphics
    Set oTextGraphics(1) = oNode.AddTextGraphics
    oTextGraphics(1).Text = "n "

    ' Because this text will have pixel scaling behavior these coordinates are in pixel space.
    oTextGraphics(1).Anchor = oTG.CreatePoint(0, 0, 0)

    oTextGraphics(1).Font = "AIGDT"
    oTextGraphics(1).FontSize = 25
    oTextGraphics(1).HorizontalAlignment = kAlignTextLeft
    Call oTextGraphics(1).PutTextColor(0, 255, 255)
    oTextGraphics(1).VerticalAlignment = kAlignTextMiddle
    Call oTextGraphics(1).SetTransformBehavior(oModelAnchorPoint, kFrontFacingAndPixelScaling)
    Dim oBox As Box
    Set oBox = oTextGraphics(1).RangeBox

    ' Draw the next section of the string relative to the first section.
    Set oTextGraphics(2) = oNode.AddTextGraphics
    oTextGraphics(2).Text = "9.4 - 9.8"

    ' The range of the previous character is used to determine where to position
    ' the next string.  The range is returned in pixels.
    oTextGraphics(2).Anchor = oTG.CreatePoint(oModelAnchorPoint.X + oBox.MaxPoint.X, 0, 0)

    oTextGraphics(2).Font = "Arial"
    oTextGraphics(2).FontSize = 25
    oTextGraphics(2).HorizontalAlignment = kAlignTextLeft
    Call oTextGraphics(2).PutTextColor(0, 255, 255)
    oTextGraphics(2).VerticalAlignment = kAlignTextMiddle
    Call oTextGraphics(2).SetTransformBehavior(oModelAnchorPoint, kFrontFacingAndPixelScaling)

    ' Draw a depth symbol on the next line.
    Set oTextGraphics(3) = oNode.AddTextGraphics
    oTextGraphics(3).Text = "x "

    ' Using the range of the first text graphics determine the position for a string that
    ' is immediately below.  This defines the next line of text.
    oTextGraphics(3).Anchor = oTG.CreatePoint(oModelAnchorPoint.X + oBox.MinPoint.X, oBox.MinPoint.Y - ((oBox.MaxPoint.Y - oBox.MinPoint.Y) * 1.5), 0)
    oTextGraphics(3).Font = "AIGDT"
    oTextGraphics(3).FontSize = 25
    oTextGraphics(3).HorizontalAlignment = kAlignTextLeft
    Call oTextGraphics(3).PutTextColor(0, 255, 255)
    oTextGraphics(3).VerticalAlignment = kAlignTextMiddle
    Call oTextGraphics(3).SetTransformBehavior(oModelAnchorPoint, kFrontFacingAndPixelScaling)
    Set oBox = oTextGraphics(3).RangeBox

     ' Draw the last set of text.s
    Set oTextGraphics(4) = oNode.AddTextGraphics
    oTextGraphics(4).Text = "20"
    oTextGraphics(4).Anchor = oTG.CreatePoint(oModelAnchorPoint.X + oBox.MaxPoint.X, oTextGraphics(3).Anchor.Y, 0)
    oTextGraphics(4).Font = "Arial"
    oTextGraphics(4).FontSize = 25
    oTextGraphics(4).HorizontalAlignment = kAlignTextLeft
    Call oTextGraphics(4).PutTextColor(0, 255, 255)
    oTextGraphics(4).VerticalAlignment = kAlignTextMiddle
    Call oTextGraphics(4).SetTransformBehavior(oModelAnchorPoint, kFrontFacingAndPixelScaling)

    ' Update the view to see the text.
    ThisApplication.ActiveView.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddTextGraphics Method


GraphicsNode.AddTriangleFanGraphics Method

GraphicsNode.AddTriangleFanGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new TriangleFanGraphics graphic primitive.

Visual Basic
Sub AddTriangleFanGraphics(Result As [out, retval] TriangleFanGraphics*)
Example

"Client Graphics - Triangle Example "

This sample demonstrates the creation of client graphics triangles using triange fans and strips. It does this by drawing a cylinder. The end caps are triangle fans and the cylinder is made from a triangle strip.

To run this sample you need to have an assembly or part document open. The sample code will prompt for the number of sides of the cylinder. This is the number of facets the cylinder will be approximated by.

Public Sub DrawCustomTriangles()
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active document.
    ' This assumes that a part or assembly document is active.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Check to see if the test graphics data object already exists.
    ' If it does clean up by removing all associated of the client graphics
    ' from the document.  If it doesn't create it and draw a line.
    On Error Resume Next
    Dim oGraphicsData As GraphicsDataSets
    Set oGraphicsData = oDoc.GraphicsDataSetsCollection.Item("SampleGraphicsID")
    If Err.Number = 0 Then
        On Error GoTo 0
        ' An existing client graphics object was successfully obtained so clean up.
        oGraphicsData.Delete
        oCompDef.ClientGraphicsCollection.Item("SampleGraphicsID").Delete

        ' update the display to see the results.
        ThisApplication.ActiveView.Update
    Else
        Err.Clear
        On Error GoTo 0

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create a graphics data set object.  This object contains all of the
        ' information used to define the graphics.
        Dim oDataSets As GraphicsDataSets
        Set oDataSets = oDoc.GraphicsDataSetsCollection.Add("SampleGraphicsID")

        ' Create a coordinate set.
        Dim oCoordSet As GraphicsCoordinateSet
        Set oCoordSet = oDataSets.CreateCoordinateSet(1)

        ' Get the number of sides for the cylinder.
        Dim iSideCount As Long
        iSideCount = InputBox("Enter number of sides for the cylinder.  (Must be greater than 2.)", "Cylinder Tolerance", 25)

        Dim dRadius As Double
        Dim dHeight As Double
        dRadius = 3
        dHeight = 7

        ' Create an array containing points to used in drawing the cylinder.
        ' The points could also be directly defined in a coordinate set, but
        ' defining them in array and then setting the coordinates using the
        ' array is more efficient for a large set of points.
        Dim adPointCoords() As Double
        ReDim adPointCoords(1 To ((iSideCount + 1) * 2) * 3) As Double
        Dim i As Long
        Dim dAngle As Double

        ' Define the points for the outline of the first end of the cylinder.
        dAngle = 0
        For i = 0 To iSideCount - 1
            adPointCoords(i * 3 + 1) = dRadius * Cos(dAngle)
            adPointCoords(i * 3 + 2) = dRadius * Sin(dAngle)
            adPointCoords(i * 3 + 3) = 0

            ' Increment the angle for the next point
            dAngle = dAngle + ((2 * 3.14159265358979) / iSideCount)
        Next

        ' Define the points for the outline of the other end of the cylinder.
        dAngle = 0
        For i = iSideCount To (iSideCount * 2) - 1
            adPointCoords(i * 3 + 1) = dRadius * Cos(dAngle)
            adPointCoords(i * 3 + 2) = dRadius * Sin(dAngle)
            adPointCoords(i * 3 + 3) = dHeight

            ' Increment the angle for the next point
            dAngle = dAngle + ((2 * 3.14159265358979) / iSideCount)
        Next

        ' Define coordinate at the center of the first end of the cylinder.
        adPointCoords((iSideCount * 2) * 3 + 1) = 0
        adPointCoords((iSideCount * 2) * 3 + 2) = 0
        adPointCoords((iSideCount * 2) * 3 + 3) = 0

        ' Define coordinate at the center of the other end of the cylinder.
        adPointCoords((iSideCount * 2) * 3 + 4) = 0
        adPointCoords((iSideCount * 2) * 3 + 5) = 0
        adPointCoords((iSideCount * 2) * 3 + 6) = dHeight

        ' Assign the points to the coordinate set.
        Call oCoordSet.PutCoordinates(adPointCoords)

        ' Create an index set to use for the triangle fan for
        ' cap of the first end of the cylinder.  This will
        ' serve as in index look-up into the coordinate set.
        Dim oCap1Index As GraphicsIndexSet
        Set oCap1Index = oDataSets.CreateIndexSet(1)

        ' Set the index values.  This could also be done by setting the
        ' value in an array and then using the array to set the values
        ' of the index set.  Using an array is more efficient, but this
        ' is used to here to demonstrate the IndexSet object's Add method.
        Call oCap1Index.Add(1, iSideCount * 2 + 1)
        Call oCap1Index.Add(2, 1)
        Call oCap1Index.Add(3, 2)
        For i = 4 To iSideCount + 1
            Call oCap1Index.Add(i, i - 1)
        Next
        Call oCap1Index.Add(iSideCount + 2, 1)

        ' Create an index set to use for the triangle fan of the other cylinder cap.
        Dim oCap2Index As GraphicsIndexSet
        Set oCap2Index = oDataSets.CreateIndexSet(2)

        ' Set the index values.
        Call oCap2Index.Add(1, iSideCount * 2 + 2)
        Call oCap2Index.Add(2, iSideCount + 1)
        Call oCap2Index.Add(3, iSideCount + 2)
        For i = 4 To iSideCount + 1
            Call oCap2Index.Add(i, i + iSideCount - 1)
        Next
        Call oCap2Index.Add(iSideCount + 2, iSideCount + 1)

        ' Create an index set to use for the triangle strip that will
        ' define the sides of the cylinder.
        Dim oCylinderIndex As GraphicsIndexSet
        Set oCylinderIndex = oDataSets.CreateIndexSet(3)

        ' Define the index values in an array.
        Dim iIndexValues() As Long
        ReDim iIndexValues(1 To (iSideCount + 1) * 2) As Long
        For i = 0 To iSideCount - 1
            iIndexValues(i * 2 + 1) = i + 1
            iIndexValues(i * 2 + 2) = i + iSideCount + 1
        Next
        iIndexValues(((iSideCount + 1) * 2) - 1) = 1
        iIndexValues((iSideCount + 1) * 2) = iSideCount + 1

        ' Define the index values in the index set using the array.
        Call oCylinderIndex.PutIndices(iIndexValues)

        ' Create the ClientGraphics object.
        Dim oClientGraphics As ClientGraphics
        Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("SampleGraphicsID")

        ' Create a new graphics node within the client graphics objects.
        Dim oCylinderNode As GraphicsNode
        Set oCylinderNode = oClientGraphics.AddNode(1)

        ' Create a triangle fan for cap 1 of the cylinder.
        Dim oCap1TriangleFan As TriangleFanGraphics
        Set oCap1TriangleFan = oCylinderNode.AddTriangleFanGraphics

        ' Set the coordinates and index set for the cap.
        oCap1TriangleFan.CoordinateSet = oCoordSet
        oCap1TriangleFan.CoordinateIndexSet = oCap1Index

        ' Create a triangle fan for cap 2 of the cylinder.
        Dim oCap2TriangleFan As TriangleFanGraphics
        Set oCap2TriangleFan = oCylinderNode.AddTriangleFanGraphics

        ' Set the coordinates and index set for the cap.
        oCap2TriangleFan.CoordinateSet = oCoordSet
        oCap2TriangleFan.CoordinateIndexSet = oCap2Index

        ' Create a triangle string for the sides of the cylinder.
        Dim oCylinderStrip As TriangleStripGraphics
        Set oCylinderStrip = oCylinderNode.AddTriangleStripGraphics

        ' Set the coordinates and index set for the cap.
        oCylinderStrip.CoordinateSet = oCoordSet
        oCylinderStrip.CoordinateIndexSet = oCylinderIndex

        oCylinderNode.RenderStyle = oDoc.RenderStyles.Item("Purple")

        ' update the display to see the results.
        ThisApplication.ActiveView.Update

        ' Define a normal for cap 1.
        Dim oCap1Normals As GraphicsNormalSet
        Set oCap1Normals = oDataSets.CreateNormalSet(1)
        Call oCap1Normals.Add(1, oTransGeom.CreateUnitVector(0, 0, -1))

        ' Assign the normals to the cap.
        oCap1TriangleFan.NormalSet = oCap1Normals

        ' Define a normal for cap 2.
        Dim oCap2Normals As GraphicsNormalSet
        Set oCap2Normals = oDataSets.CreateNormalSet(2)
        Call oCap2Normals.Add(1, oTransGeom.CreateUnitVector(0, 0, 1))

        ' Assign the normals to the cap.
        oCap2TriangleFan.NormalSet = oCap2Normals

        ' Create an array that contains the normals for each vertex of the cylinder.
        Dim adNormals() As Double
        ReDim adNormals(1 To ((iSideCount + 1) * 2) * 3) As Double
        dAngle = 0
        For i = 0 To iSideCount
            Dim dX As Double
            Dim dY As Double
            dX = Cos(dAngle)
            dY = Sin(dAngle)
            adNormals(i * 6 + 1) = dX
            adNormals(i * 6 + 2) = dY
            adNormals(i * 6 + 3) = 0
            adNormals(i * 6 + 4) = dX
            adNormals(i * 6 + 5) = dY
            adNormals(i * 6 + 6) = 0

            ' Increment the angle for the next normal.
            dAngle = dAngle + ((2 * 3.14159265358979) / iSideCount)
        Next

        ' Create and set the normal set for the cylinder.
        Dim oCylinderNormals As GraphicsNormalSet
        Set oCylinderNormals = oDataSets.CreateNormalSet(3)
        Call oCylinderNormals.PutNormals(adNormals)

        ' Assign the normals to the cylinder.
        oCylinderStrip.NormalSet = oCylinderNormals

        ' update the display to see the results.
        ThisApplication.ActiveView.Update
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddTriangleFanGraphics Method


GraphicsNode.AddTriangleGraphics Method

GraphicsNode.AddTriangleGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new TriangleGraphics graphic primitive.

Visual Basic
Sub AddTriangleGraphics(Result As [out, retval] TriangleGraphics*)
See Also

Client graphics texture-based color mapping sample

Client Graphics - Vertex Color by Z Height sample

Example

See GraphicsNode::AddTriangleGraphics for example "Adding triangular graphics"

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddTriangleGraphics Method


GraphicsNode.AddTriangleStripGraphics Method

GraphicsNode.AddTriangleStripGraphics Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new TriangleStripGraphics graphic primitive.

Visual Basic
Sub AddTriangleStripGraphics(Result As [out, retval] TriangleStripGraphics*)
See Also

Client Graphics - Triangle sample

Example

See GraphicsNode::AddTriangleFanGraphics for example "Adding triangular graphics"

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.AddTriangleStripGraphics Method


GraphicsNode.ClearSlice Method

GraphicsNode.ClearSlice Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that clears all the slicing applied to the graphics node.

Visual Basic
Sub ClearSlice()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.ClearSlice Method


GraphicsNode.Copy Method

GraphicsNode.Copy Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a copy of this . The copy has the same property values as the original, a duplicate of all of the graphics primitives, and the CustomRenderStyle has the same values. A new ID is generated for the copy.

Visual Basic
Sub Copy(Transformation As Matrix, NodeId As long, Result As [out, retval] GraphicsNode*)
Parameters
Parameters | Description
Transformation | Input that defines the transform for the copy.
NodeId | Input Long that specifies the identifier for the newly created node. This id needs to be unique with respect to all other object in this ClientGraphics object.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.Copy Method


GraphicsNode.Delete Method

GraphicsNode.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the GraphicsNode. This also deletes all associated graphic primitives.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.Delete Method


GraphicsNode.Item Method

GraphicsNode.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified graphic entity from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] GraphicsPrimitive*)
Parameters
Parameters | Description
index | Specifies which object to return. This is an index into the collection.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.Item Method


GraphicsNode.SliceGraphics Method

GraphicsNode.SliceGraphics Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that slices the graphics based on the input planes and optionally caps the sliced end.

Visual Basic
Sub SliceGraphics(ApplyCapping As VARIANT_BOOL, SlicingPlanes As ObjectCollection, ByRef ThreeQuarterSection As [defaultvalue(0)] VARIANT_BOOL, ByRef RenderStyle As [optional] VARIANT)
Parameters
Parameters | Description
ApplyCapping | Input Boolean that specifies whether or not to cap the sliced end.
SlicingPlanes | Input ObjectCollection that can contain up to six Plane objects if ApplyCapping is False and either one or two Plane objects if ApplyCapping is True.
ThreeQuarterSection | Optional input Boolean that indicates whether to produce a ' section or a ' section. Applicable only when two slicing planes are input, ignored otherwise.
RenderStyle | Optional input RenderStyle object that specifies the render style to apply for the capping. The texture image in the input RenderStyle is used for the cap. Applicable only if the ApplyCapping argument is set to True.
Remarks

The portions of all the slices on the side of all the slicing planes in the direction of the plane normals are preserved.

Example

This sample demonstrates the creation of client graphics based on the solid body of the active part. The sample also demonstrates the use of the slicing functionality available for client graphics. Open a part that has a solid body and run the following code.

Public Sub SliceClientGraphics()

    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active part.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    Dim bApplyCap As Boolean
    If MsgBox("Do you want an end cap?", vbQuestion + vbYesNo, "SliceGraphics") = vbYes Then
        bApplyCap = True
    Else
        bApplyCap = False
    End If

    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("SliceGraphicsID")

    ' Create a new graphics node within the client graphics objects.
    Dim oSurfacesNode As GraphicsNode
    Set oSurfacesNode = oClientGraphics.AddNode(1)

    Dim oTransientBRep As TransientBRep
    Set oTransientBRep = ThisApplication.TransientBRep

    ' Create a copy of the solid body in the part
    Dim oBody As SurfaceBody
    Set oBody = oTransientBRep.Copy(oCompDef.SurfaceBodies.Item(1))

    ' Create client graphics based on the transient body
    Dim oSurfaceGraphics As SurfaceGraphics
    Set oSurfaceGraphics = oSurfacesNode.AddSurfaceGraphics(oBody)

    ' Color it red
    oSurfacesNode.RenderStyle = oDoc.RenderStyles.Item("Red")

    ' Make the body in the part invisible
    oCompDef.SurfaceBodies.Item(1).Visible = False

    Dim oLineSegment As LineSegment
    Set oLineSegment = ThisApplication.TransientGeometry.CreateLineSegment(oSurfacesNode.RangeBox.MaxPoint, oSurfacesNode.RangeBox.MinPoint)

    Dim oRootPoint As Point
    Set oRootPoint = oLineSegment.MidPoint

    ' Get the negative Z-axis vector
    Dim oNormal As Vector
    Set oNormal = ThisApplication.TransientGeometry.CreateVector(0, 0, -1)

    ' Create a plane normal to Z axis with the root point at the center of the part
    Dim oPlane As Plane
    Set oPlane = ThisApplication.TransientGeometry.CreatePlane(oRootPoint, oNormal)

    Dim oSlicingPlanes As ObjectCollection
    Set oSlicingPlanes = ThisApplication.TransientObjects.CreateObjectCollection
    Call oSlicingPlanes.Add(oPlane)

    ' Slice the client graphics
    Call oSurfacesNode.SliceGraphics(bApplyCap, oSlicingPlanes)

    ' Update the view to see the result
    ThisApplication.ActiveView.Update

End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Methods > GraphicsNode.SliceGraphics Method


GraphicsNode Properties

GraphicsNode Properties
Summary

The properties of the GraphicsNode class are listed here.

Properties
Name | Description
AllowSlicing | Property that gets and sets whether the primitives within this node should participate in the section view commands in assembly and slice graphics command in sketch.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of graphic primitive objects associated with this GraphicsNode object.
DisplayName | Property that gets and sets the display name of this graphics node.
ExcludedFromViewAll | Specifies that the node is not considered when doing a view all.
Id | Property that returns the Id of the GraphicsNode.
Parent | Property that returns the object this graphics node belongs to.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
RenderStyle | Property that gets and sets the render style associated with the GraphicsNode. If any color sets are used on a graphic entity, those color sets will override the render style applied to the GraphicsNode.
Selectable | Property that specifies whether the GraphicsNode object can be selected when the Select command is running in Inventor.
Transformation | Property that gets and sets the transformation of the GraphicsNode.
Type | Property returning an enum indicating this object's type.
Visible | Property that gets and sets whether the GraphicsNode is visible or not.
VisibleInActiveEditObject | Property that gets and sets whether this graphics node is visible when the containing object is not the active edit object. A value of True indicates that this node is visible only when the containing object is activated. The value of this property is ignored if the Visible property on GraphicsNode is False.
VisibleInViews | Property that returns a object containing the Views that this graphics node is visible in. If there are no views in the list, the node is visible in all views. Views may be added or removed from the list. This property is ignored if the Visible property on GraphicsNode is False.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties


GraphicsNode.AllowSlicing Property

GraphicsNode.AllowSlicing Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the primitives within this node should participate in the section view commands in assembly and slice graphics command in sketch.

Visual Basic
Property AllowSlicing() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.AllowSlicing Property


GraphicsNode.Application Property

GraphicsNode.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Application Property


GraphicsNode.Count Property

GraphicsNode.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of graphic primitive objects associated with this GraphicsNode object.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Count Property


GraphicsNode.DisplayName Property

GraphicsNode.DisplayName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the display name of this graphics node.

Visual Basic
Property DisplayName() As String
Remarks

The display name of a graphics node is used for the Select Other combo box when the user is selecting entities in the graphics window. If no name is specified it will default to a generic name for custom graphics.

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.DisplayName Property


GraphicsNode.ExcludedFromViewAll Property

GraphicsNode.ExcludedFromViewAll Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies that the node is not considered when doing a view all.

Visual Basic
Property ExcludedFromViewAll() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.ExcludedFromViewAll Property


GraphicsNode.Id Property

GraphicsNode.Id Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Id of the GraphicsNode.

Visual Basic
Property Id() As long
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Id Property


GraphicsNode.Parent Property

GraphicsNode.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object this graphics node belongs to.

Visual Basic
Property Parent() As ClientGraphics**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Parent Property


GraphicsNode.RangeBox Property

GraphicsNode.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.RangeBox Property


GraphicsNode.RenderStyle Property

GraphicsNode.RenderStyle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the render style associated with the GraphicsNode. If any color sets are used on a graphic entity, those color sets will override the render style applied to the GraphicsNode.

Visual Basic
Property RenderStyle() As RenderStyle*
See Also

Create client graphics based on the solid body of the active part sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.RenderStyle Property


GraphicsNode.Selectable Property

GraphicsNode.Selectable Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether the GraphicsNode object can be selected when the Select command is running in Inventor.

Visual Basic
Property Selectable() As VARIANT_BOOL
See Also

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Selectable Property


GraphicsNode.Transformation Property

GraphicsNode.Transformation Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the transformation of the GraphicsNode.

Visual Basic
Property Transformation() As Matrix*
See Also

InteractionGraphics sample

Client Graphics - Line sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Transformation Property


GraphicsNode.Type Property

GraphicsNode.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Type Property


GraphicsNode.Visible Property

GraphicsNode.Visible Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the GraphicsNode is visible or not.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.Visible Property


GraphicsNode.VisibleInActiveEditObject Property

GraphicsNode.VisibleInActiveEditObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether this graphics node is visible when the containing object is not the active edit object. A value of True indicates that this node is visible only when the containing object is activated. The value of this property is ignored if the Visible property on GraphicsNode is False.

Visual Basic
Property VisibleInActiveEditObject() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.VisibleInActiveEditObject Property


GraphicsNode.VisibleInViews Property

GraphicsNode.VisibleInViews Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a object containing the Views that this graphics node is visible in. If there are no views in the list, the node is visible in all views. Views may be added or removed from the list. This property is ignored if the Visible property on GraphicsNode is False.

Visual Basic
Property VisibleInViews() As ViewList**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNode Interface > GraphicsNode Properties > GraphicsNode.VisibleInViews Property


GraphicsNodeProxy Interface

GraphicsNodeProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GraphicsNode object.

Class Hierarchy
Inventor::GraphicsNode
    Inventor::GraphicsNodeProxy
Visual Basic
Public Interface GraphicsNodeProxy
Inherits GraphicsNode
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNodeProxy Interface


GraphicsNodeProxy Properties

GraphicsNodeProxy Properties
Summary

The properties of the GraphicsNodeProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNodeProxy Interface > GraphicsNodeProxy Properties


GraphicsNodeProxy.ContainingOccurrence Property

GraphicsNodeProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNodeProxy Interface > GraphicsNodeProxy Properties > GraphicsNodeProxy.ContainingOccurrence Property


GraphicsNodeProxy.NativeObject Property

GraphicsNodeProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As GraphicsNode**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNodeProxy Interface > GraphicsNodeProxy Properties > GraphicsNodeProxy.NativeObject Property


GraphicsNormalSet Interface

GraphicsNormalSet Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsNormalSet object contains a list of normals. This object can be referenced by any number of graphic primitives to help define the normals to be used when rendering.

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsNormalSet
Visual Basic
Public Interface GraphicsNormalSet
Inherits GraphicsDataSet
Remarks

The GraphicsNormalSet has no direct relationship to a specific coordinate set. The relation is made when the graphic primitive is created. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateNormalSet

TriangleFanGraphics.NormalSet

TriangleGraphics.NormalSet

TriangleStripGraphics.NormalSet

See Also

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNormalSet Interface


GraphicsNormalSet Methods

GraphicsNormalSet Methods
Summary

The methods of the GraphicsNormalSet class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new normal to the set.
GetNormals | Method that gets all of the normals of the set.
Normal | Property that indicates the vector for a specific normal in the set.
PutNormals | Method that sets all of the normals of the set. This will replace any existing normals currently defined for the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNormalSet Interface > GraphicsNormalSet Methods


GraphicsNormalSet.Add Method

GraphicsNormalSet.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that adds a new normal to the set.

Visual Basic
Sub Add(Index As long, Normal As UnitVector)
Parameters
Parameters | Description
Normal | Input object that specifies the normal to add to the set.
index | Specifies the position you want this normal to have within the set. All normals above the position will be shifted up to make room for this normal. Specifying any number greater than the current count of the set will cause the normal to become the last in the set. The normal set indices are one-based, meaning the first normal in the set has an index of one.
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNormalSet Interface > GraphicsNormalSet Methods > GraphicsNormalSet.Add Method


GraphicsNormalSet.GetNormals Method

GraphicsNormalSet.GetNormals Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets all of the normals of the set.

Visual Basic
Sub GetNormals(ByRef Normals As SAFEARRAY(double))
Parameters
Parameters | Description
Normals | Input/output array of Doubles that contains the x-y-z values of the normals. The array is a single dimension array containing sequential x, y, and z values. If the array has been declared undimensioned, this method will redimension its size to be able to contain the complete set of normals. If the array has been dimensioned, it must be large enough to contain the entire set of normals or an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNormalSet Interface > GraphicsNormalSet Methods > GraphicsNormalSet.GetNormals Method


GraphicsNormalSet.Normal Method

GraphicsNormalSet.Normal Method
Summary

Property that indicates the vector for a specific normal in the set.

Visual Basic
Sub Normal(Index As long, Result As [out, retval] UnitVector*)
Parameters
Parameters | Description
index | Index into the list of normals.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsNormalSet Interface > GraphicsNormalSet Methods > GraphicsNormalSet.Normal Method


GraphicsNormalSet.PutNormals Method

GraphicsNormalSet.PutNormals Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets all of the normals of the set. This will replace any existing normals currently defined for the set.

Visual Basic
Sub PutNormals(ByRef Normals As SAFEARRAY(double))
Parameters
Parameters | Description
Normals | Input/output array of Doubles that contains the x-y-z values of the normals. The array is a single dimension array containing sequential x, y, and z values.
See Also

Client graphics texture-based color mapping sample

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsNormalSet Interface > GraphicsNormalSet Methods > GraphicsNormalSet.PutNormals Method


GraphicsPreferences Interface

GraphicsPreferences Interface
Summary

The GraphicsPreferences object represents preference options for the graphical environment.

Class Hierarchy
Inventor::GraphicsPreferences
Visual Basic
Public Interface GraphicsPreferences
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPreferences Interface


GraphicsPrimitive Interface

GraphicsPrimitive Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GraphicsPrimitive object is the base class for all the various primitive types of client graphics.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::ComponentGraphics
    Inventor::CurveGraphics
    Inventor::LineGraphics
    Inventor::LineStripGraphics
    Inventor::PointGraphics
    Inventor::SurfaceGraphics
    Inventor::TextGraphics
    Inventor::TriangleFanGraphics
    Inventor::TriangleGraphics
    Inventor::TriangleStripGraphics
Visual Basic
Public Interface GraphicsPrimitive
Inherits IDispatch
Notes

Members through which this object may be accessed include:

GraphicsNode.Item

You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface


GraphicsPrimitive Methods

GraphicsPrimitive Methods
Summary

The methods of the GraphicsPrimitive class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the graphics primitive.
GetViewSpaceAnchor | Method that gets the anchor information of the graphics object. This method returns an error if the 'Anchored' property returns False.
Parent | Property that returns the parent object from whom this object can logically be reached.
RemoveViewSpaceAnchor | The RemoveViewSpaceAnchor method removes the view space anchor from the object, and sets the Anchored property to false.
SetViewSpaceAnchor | Method that anchors the graphics object at the specified point in view space. The Anchored property is set to True.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Methods


GraphicsPrimitive.Delete Method

GraphicsPrimitive.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the graphics primitive.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Methods > GraphicsPrimitive.Delete Method


GraphicsPrimitive.GetViewSpaceAnchor Method

GraphicsPrimitive.GetViewSpaceAnchor Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that gets the anchor information of the graphics object. This method returns an error if the 'Anchored' property returns False.

Visual Basic
Sub GetViewSpaceAnchor(ByRef Origin As Point*, ByRef Anchor As Point2d*, ByRef AnchorRelativeTo As ViewLayoutEnum)
Parameters
Parameters | Description
Origin | Output that specifies the origin of the coordinate system.
Anchor | Output that indicates which point is unaffected by the transform behavior.
AnchorRelativeTo | Output constant indicating which corner of the view the anchor is relative to.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Methods > GraphicsPrimitive.GetViewSpaceAnchor Method


GraphicsPrimitive.Parent Method

GraphicsPrimitive.Parent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Sub Parent(Result As [out, retval] GraphicsNode*)
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Methods > GraphicsPrimitive.Parent Method


GraphicsPrimitive.RemoveViewSpaceAnchor Method

GraphicsPrimitive.RemoveViewSpaceAnchor Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

The RemoveViewSpaceAnchor method removes the view space anchor from the object, and sets the Anchored property to false.

Visual Basic
Sub RemoveViewSpaceAnchor()
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Methods > GraphicsPrimitive.RemoveViewSpaceAnchor Method


GraphicsPrimitive.SetViewSpaceAnchor Method

GraphicsPrimitive.SetViewSpaceAnchor Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that anchors the graphics object at the specified point in view space. The Anchored property is set to True.

Visual Basic
Sub SetViewSpaceAnchor(Origin As Point, Anchor As Point2d, AnchorRelativeTo As ViewLayoutEnum)
Parameters
Parameters | Description
Origin | Input that specifies the origin of the coordinate system.
Anchor | Input that indicates which point is unaffected by the transform behavior.
AnchorRelativeTo | Input constant indicating which corner of the view the anchor is relative to.
Example

"Anchored Client Grahics Example "

This sample demonstrates the creation of client graphics that is fully anchored in a view. This sample anchors some text graphics relative to the top-left corner of the view.

Open a part or an assembly document and run the following sample.

Public Sub AnchoredClientGraphics()
  ' Set a reference to the document.
  Dim oDoc As Document
  Set oDoc = ThisApplication.ActiveDocument

  ' Set a reference to the component definition.
  ' This assumes that the active document is a part or an assembly.
  Dim oCompDef As ComponentDefinition
  Set oCompDef = oDoc.ComponentDefinition

  ' Attempt to get the existing client graphics object. If it exists
  ' delete it so the rest of the code can continue as if it never existed.
  Dim oClientGraphics As ClientGraphics
  On Error Resume Next
  Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("Anchored Text")
  If Err.Number = 0 Then
    oClientGraphics.Delete
  End If
  On Error GoTo 0
  ThisApplication.ActiveView.Update

  ' Create a new ClientGraphics object.
  Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("Anchored Text")

  ' Create a graphics node.
  Dim oNode As GraphicsNode
  Set oNode = oClientGraphics.AddNode(1)

  ' Create text graphics.
  Dim oTextGraphics As TextGraphics
  Set oTextGraphics = oNode.AddTextGraphics

  ' Set the properties of the text.
  oTextGraphics.Text = "Anchored text."
  oTextGraphics.Bold = True
  oTextGraphics.FontSize = 30
  Call oTextGraphics.PutTextColor(0, 255, 0)

  Dim oAnchorPoint As Point
  Set oAnchorPoint = ThisApplication.TransientGeometry.CreatePoint(1, 1, 1)

  ' Set the text's anchor in model space.
  oTextGraphics.Anchor = oAnchorPoint

  ' Anchor the text graphics in the view.
  Call oTextGraphics.SetViewSpaceAnchor( _
      oAnchorPoint, ThisApplication.TransientGeometry.CreatePoint2d(30, 30), _
      kTopLeftViewCorner)

  ' Update the view to see the text.
  ThisApplication.ActiveView.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Methods > GraphicsPrimitive.SetViewSpaceAnchor Method


GraphicsPrimitive Properties

GraphicsPrimitive Properties
Summary

The properties of the GraphicsPrimitive class are listed here.

Properties
Name | Description
Anchored | Property that indicates whether this graphics primitive is anchored in view space. This property can only be set to False. The Anchored property is automatically set to True by the SetViewSpaceAnchor method.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Properties


GraphicsPrimitive.Anchored Property

GraphicsPrimitive.Anchored Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates whether this graphics primitive is anchored in view space. This property can only be set to False. The Anchored property is automatically set to True by the SetViewSpaceAnchor method.

Visual Basic
Property Anchored() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Properties > GraphicsPrimitive.Anchored Property


GraphicsPrimitive.Application Property

GraphicsPrimitive.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Properties > GraphicsPrimitive.Application Property


GraphicsPrimitive.RangeBox Property

GraphicsPrimitive.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Properties > GraphicsPrimitive.RangeBox Property


GraphicsPrimitive.Type Property

GraphicsPrimitive.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GraphicsPrimitive Interface > GraphicsPrimitive Properties > GraphicsPrimitive.Type Property


GraphicsTextureCoordinateSet Interface

GraphicsTextureCoordinateSet Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The GraphicsTextureCoordinateSet object contains a list of coordinate values

Class Hierarchy
Inventor::GraphicsDataSet
    Inventor::GraphicsTextureCoordinateSet
Visual Basic
Public Interface GraphicsTextureCoordinateSet
Inherits GraphicsDataSet
Remarks

This object can be referenced by any number of graphic primitives to use in defining their texture coordinates. The list of coordinates is used in different ways depending on the object that is referencing it. See the various graphic primitives for information about what their requirements are for the texture coordinate set.

Notes

Members through which this object may be accessed include:

GraphicsDataSets.CreateTextureCoordinateSet

TriangleFanGraphics.TextureCoordinateSet

TriangleGraphics.TextureCoordinateSet

TriangleStripGraphics.TextureCoordinateSet

See Also

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface


GraphicsTextureCoordinateSet Methods

GraphicsTextureCoordinateSet Methods
Summary

The methods of the GraphicsTextureCoordinateSet class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a single coordinate to the set.
Coordinate | Property that gets and set the value of a specific coordinate within the set. The return type can be a Double or Point2d object.
GetCoordinates | Method that gets all of the coordinates of the set.
PutCoordinates | Method that sets all of the coordinates of the set. This will replace all existing coordinates currently defined for the set.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Methods


GraphicsTextureCoordinateSet.Add Method

GraphicsTextureCoordinateSet.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds a single coordinate to the set.

Visual Basic
Sub Add(Index As long, Coordinate As VARIANT)
Parameters
Parameters | Description
Index | Specifies the index you want this coordinate to be within the set. All coordinates above the Index will be shifted up to make room for this index. Specifying any number greater than the current count of the set will cause the coordinate to become the last in the set. The coordinate set indices are one-based.
Coordinate | Input Double or Point2d object that specifies the value of the coordinate to add. The input is currently limited to double values. It must be consistent with the rest of the data. For example, if Double’s have already been used to define single dimension coordinates, attempting to add a Point2D object will fail.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Methods > GraphicsTextureCoordinateSet.Add Method


GraphicsTextureCoordinateSet.Coordinate Method

GraphicsTextureCoordinateSet.Coordinate Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and set the value of a specific coordinate within the set. The return type can be a Double or Point2d object.

Visual Basic
Sub Coordinate(Index As long, Value As VARIANT)
Parameters
Parameters | Description
Index | Index into the list of coordinates. The coordinate set indices are one-based, meaning the first coordinate in the list is index one.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Methods > GraphicsTextureCoordinateSet.Coordinate Method


GraphicsTextureCoordinateSet.GetCoordinates Method

GraphicsTextureCoordinateSet.GetCoordinates Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets all of the coordinates of the set.

Visual Basic
Sub GetCoordinates(ByRef Coordinates As SAFEARRAY(double))
Parameters
Parameters | Description
Coordinates | Output array of doubles that contains the scalar texture coordinates. The array is a single dimension array containing texture coordinates. If the array has been declared undimensioned, this method will redimension its size to contain the complete set of coordinates. If the array has been dimensioned, it must be large enough to contain the entire set of coordinates or an error will occur. The returned array can represent either a list of 1D or 2D texture coordinates. You can use the TextureDimension property to determine which one it is.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Methods > GraphicsTextureCoordinateSet.GetCoordinates Method


GraphicsTextureCoordinateSet.PutCoordinates Method

GraphicsTextureCoordinateSet.PutCoordinates Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets all of the coordinates of the set. This will replace all existing coordinates currently defined for the set.

Visual Basic
Sub PutCoordinates(Coordinates As SAFEARRAY(double))
Parameters
Parameters | Description
Coordinates | Input array of doubles that contains value of the texture coordinates.
Remarks

Coordinates can be a single dimension or 2-dimensional. Before using this method you should set the value of the TextureDimension property so that it is correct for the type of texture coordinates you’re using. If you are defining 2D texture coordinates, the array must have an even number of entries where each pair represents the u-v values of the texture coordinate.

See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Methods > GraphicsTextureCoordinateSet.PutCoordinates Method


GraphicsTextureCoordinateSet Properties

GraphicsTextureCoordinateSet Properties
Summary

The properties of the GraphicsTextureCoordinateSet class are listed here.

Properties
Name | Description
TextureDimension | Property that defines the dimension of the texture coordinate array.
You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Properties


GraphicsTextureCoordinateSet.TextureDimension Property

GraphicsTextureCoordinateSet.TextureDimension Property Available in Inventor Introduced in Inventor 2012
Summary

Property that defines the dimension of the texture coordinate array.

Visual Basic
Property TextureDimension() As TextureDimensionEnum
Remarks

1D and 2D coordinates are currently supported. Initialized to k1DTexture for a new GraphicsTextureCoordinateSet.

You are here: Symbol Reference > Inventor Library > Objects > GraphicsTextureCoordinateSet Interface > GraphicsTextureCoordinateSet Properties > GraphicsTextureCoordinateSet.TextureDimension Property


GrillFeature Interface

GrillFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The GrillFeature object represents a grill feature within the model.

Class Hierarchy
Inventor::PartFeature
    Inventor::GrillFeature
        Inventor::GrillFeatureProxy
Visual Basic
Public Interface GrillFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

GrillFeatureProxy.NativeObject

GrillFeatures.Item

Most functionality reserved for future implementation.

You are here: Symbol Reference > Inventor Library > Objects > GrillFeature Interface


GrillFeatureProxy Interface

GrillFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GrillFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::GrillFeature
        Inventor::GrillFeatureProxy
Visual Basic
Public Interface GrillFeatureProxy
Inherits GrillFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > GrillFeatureProxy Interface


GrillFeatureProxy Properties

GrillFeatureProxy Properties
Summary

The properties of the GrillFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatureProxy Interface > GrillFeatureProxy Properties


GrillFeatureProxy.ContainingOccurrence Property

GrillFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > GrillFeatureProxy Interface > GrillFeatureProxy Properties > GrillFeatureProxy.ContainingOccurrence Property


GrillFeatureProxy.NativeObject Property

GrillFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As GrillFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > GrillFeatureProxy Interface > GrillFeatureProxy Properties > GrillFeatureProxy.NativeObject Property


GrillFeatures Interface

GrillFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The GrillFeatures collection object provides access to existing grill features.

Class Hierarchy
Inventor::GrillFeatures
Visual Basic
Public Interface GrillFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.GrillFeatures

You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface


GrillFeatures Methods

GrillFeatures Methods
Summary

The methods of the GrillFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface > GrillFeatures Methods


GrillFeatures.Item Method

GrillFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] GrillFeature*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface > GrillFeatures Methods > GrillFeatures.Item Method


GrillFeatures Properties

GrillFeatures Properties
Summary

The properties of the GrillFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface > GrillFeatures Properties


GrillFeatures.Application Property

GrillFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface > GrillFeatures Properties > GrillFeatures.Application Property


GrillFeatures.Count Property

GrillFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface > GrillFeatures Properties > GrillFeatures.Count Property


GrillFeatures.Type Property

GrillFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GrillFeatures Interface > GrillFeatures Properties > GrillFeatures.Type Property


GripSnapOptions Interface

GripSnapOptions Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The GripSnapOptions object provides access to various grip snap related application level options. This object is obtained from the GeneralOptions.GripSnapOptions property.

Class Hierarchy
Inventor::GripSnapOptions
Visual Basic
Public Interface GripSnapOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

GeneralOptions.GripSnapOptions

You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface


GripSnapOptions Properties

GripSnapOptions Properties
Summary

The properties of the GripSnapOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DisplayObjectInOriginalLocation | Property that gets and sets whether or not to maintain a static reference image of the selection set while transient graphics represent the translation or rotation in drag and snap and reference geometry workflows.
SelectGroundedComponentsAndWorkGeometry | Property that gets and sets whether grounded components and work geometries can be included for move/rotate.
ShowDegreesOfFreedom | Property that gets and sets whether or not to add boxes to the end of the heads-up display (HUD) for translational and rotational degrees of freedom related to the active component or assembly selection.
Type | Returns an ObjectTypeEnum indicating this object's type.
UseFreeDrag | Property that gets and sets whether or not to use the free drag option for each geometry type, skipping the step to select Free Drag from the Grip Snap move options. When selected, the move options are not displayed, and you can select and place a component or assembly directly.
UseTemporaryConstraints | Property that gets and sets whether or not to use transient constraints during multiple manipulations of the same selection set.
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties


GripSnapOptions.Application Property

GripSnapOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.Application Property


GripSnapOptions.DisplayObjectInOriginalLocation Property

GripSnapOptions.DisplayObjectInOriginalLocation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to maintain a static reference image of the selection set while transient graphics represent the translation or rotation in drag and snap and reference geometry workflows.

Visual Basic
Property DisplayObjectInOriginalLocation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.DisplayObjectInOriginalLocation Property


GripSnapOptions.SelectGroundedComponentsAndWorkGeometry Property

GripSnapOptions.SelectGroundedComponentsAndWorkGeometry Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether grounded components and work geometries can be included for move/rotate.

Visual Basic
Property SelectGroundedComponentsAndWorkGeometry() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.SelectGroundedComponentsAndWorkGeometry Property


GripSnapOptions.ShowDegreesOfFreedom Property

GripSnapOptions.ShowDegreesOfFreedom Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to add boxes to the end of the heads-up display (HUD) for translational and rotational degrees of freedom related to the active component or assembly selection.

Visual Basic
Property ShowDegreesOfFreedom() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.ShowDegreesOfFreedom Property


GripSnapOptions.Type Property

GripSnapOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.Type Property


GripSnapOptions.UseFreeDrag Property

GripSnapOptions.UseFreeDrag Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to use the free drag option for each geometry type, skipping the step to select Free Drag from the Grip Snap move options. When selected, the move options are not displayed, and you can select and place a component or assembly directly.

Visual Basic
Property UseFreeDrag() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.UseFreeDrag Property


GripSnapOptions.UseTemporaryConstraints Property

GripSnapOptions.UseTemporaryConstraints Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to use transient constraints during multiple manipulations of the same selection set.

Visual Basic
Property UseTemporaryConstraints() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GripSnapOptions Interface > GripSnapOptions Properties > GripSnapOptions.UseTemporaryConstraints Property


GroundConstraint Interface

GroundConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The GroundConstraint object represents a constraint that grounds an entity.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::GroundConstraint
        Inventor::GroundConstraintProxy
Visual Basic
Public Interface GroundConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddGround

GroundConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint Interface


GroundConstraint Properties

GroundConstraint Properties
Summary

The properties of the GroundConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns entity being grounded.
You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint Interface > GroundConstraint Properties


GroundConstraint.Entity Property

GroundConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns entity being grounded.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint Interface > GroundConstraint Properties > GroundConstraint.Entity Property


GroundConstraint3D Interface

GroundConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The GroundConstraint3D object represents a constraint that grounds an entity.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::GroundConstraint3D
        Inventor::GroundConstraint3DProxy
Visual Basic
Public Interface GroundConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.AddGround

GroundConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3D Interface


GroundConstraint3D Properties

GroundConstraint3D Properties
Summary

The properties of the GroundConstraint3D class are listed here.

Properties
Name | Description
Entity | Property that returns the entity being grounded.
You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3D Interface > GroundConstraint3D Properties


GroundConstraint3D.Entity Property

GroundConstraint3D.Entity Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the entity being grounded.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3D Interface > GroundConstraint3D Properties > GroundConstraint3D.Entity Property


GroundConstraint3DProxy Interface

GroundConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GroundConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::GroundConstraint3D
        Inventor::GroundConstraint3DProxy
Visual Basic
Public Interface GroundConstraint3DProxy
Inherits GroundConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3DProxy Interface


GroundConstraint3DProxy Properties

GroundConstraint3DProxy Properties
Summary

The properties of the GroundConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3DProxy Interface > GroundConstraint3DProxy Properties


GroundConstraint3DProxy.ContainingOccurrence Property

GroundConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3DProxy Interface > GroundConstraint3DProxy Properties > GroundConstraint3DProxy.ContainingOccurrence Property


GroundConstraint3DProxy.NativeObject Property

GroundConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As GroundConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraint3DProxy Interface > GroundConstraint3DProxy Properties > GroundConstraint3DProxy.NativeObject Property


GroundConstraintProxy Interface

GroundConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the GroundConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::GroundConstraint
        Inventor::GroundConstraintProxy
Visual Basic
Public Interface GroundConstraintProxy
Inherits GroundConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraintProxy Interface


GroundConstraintProxy Properties

GroundConstraintProxy Properties
Summary

The properties of the GroundConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > GroundConstraintProxy Interface > GroundConstraintProxy Properties


GroundConstraintProxy.ContainingOccurrence Property

GroundConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraintProxy Interface > GroundConstraintProxy Properties > GroundConstraintProxy.ContainingOccurrence Property


GroundConstraintProxy.NativeObject Property

GroundConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As GroundConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > GroundConstraintProxy Interface > GroundConstraintProxy Properties > GroundConstraintProxy.NativeObject Property


GroundPlaneSettings Interface

GroundPlaneSettings Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::GroundPlaneSettings
Visual Basic
Public Interface GroundPlaneSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DisplaySettings.GroundPlaneSettings

The GroundPlaneSettings object provides access to properties that provide read and write access of the ground plane related document settings. This object is obtained from the DisplaySettings.GroundPlaneSettings property.

You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface


GroundPlaneSettings Methods

GroundPlaneSettings Methods
Summary

The methods of the GroundPlaneSettings class are listed here.

Methods
Methods
Name | Description
GetSize | Method that gets the current size of the displayed graphics for the ground plane. The plane is functionally infinite but has a plane that is displayed to allow the user to visualize it.
SetSize | Method that sets the current size of the displayed graphics for the ground plane. The plane is functionally infinite but has a plane that is displayed to allow the user to visualize it. This method will fail if the AutoResize property is set to True.
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Methods


GroundPlaneSettings.GetSize Method

GroundPlaneSettings.GetSize Method
Summary

Method that gets the current size of the displayed graphics for the ground plane. The plane is functionally infinite but has a plane that is displayed to allow the user to visualize it.

Visual Basic
Sub GetSize(ByRef PointOne As Point*, ByRef PointTwo As Point*)
Parameters
Parameters | Description
PointOne | Point object that returns the first corner of the ground plane in model space.
PointTwo | Point object that returns the diagonally opposite corner of the ground plane in model space.
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Methods > GroundPlaneSettings.GetSize Method


GroundPlaneSettings.SetSize Method

GroundPlaneSettings.SetSize Method
Summary

Method that sets the current size of the displayed graphics for the ground plane. The plane is functionally infinite but has a plane that is displayed to allow the user to visualize it. This method will fail if the AutoResize property is set to True.

Visual Basic
Sub SetSize(PointOne As Point, PointTwo As Point)
Parameters
Parameters | Description
PointOne | Point object that defines the first corner of the ground plane in model space. If the input point does not lie on the ground plane, the point is projected to the plane.
PointTwo | Point object that defines the diagonally opposite corner of the ground plane in model space. If the input point does not lie on the ground plane, the point is projected to the plane.
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Methods > GroundPlaneSettings.SetSize Method


GroundPlaneSettings Properties

GroundPlaneSettings Properties
Summary

The properties of the GroundPlaneSettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutoResize | Property that gets or sets whether the ground plane should be resized automatically based on the component size. This property should be set to False in order to resize the plane using the SetSize method.
Color | Property that gets and sets the color for the ground plane for the area inside the margin. This property can be set to Nothing to indicate no color is to be used.
DisplayGridLines | Property that specifies whether to display grid lines.
FrontDirection | Property that returns the front direction of the ground plane.
HeightOffset | Property that gets and sets the offset of the ground plane from the specified position. Negative and positive values can be provided. The value is defined in centimeters.
MinorGridLineSpacing | Property that gets and sets the spacing between minor grid lines in centimeters.
MinorLinesPerMajorGridLine | Property that gets and sets the number of minor lines to appear between major lines. Major lines appear heavier in the grid display. Valid range of values is 1 to 512.
Opacity | Property that gets and sets the opacity of the ground plane. The opacity is defined using a value between 0 and 1. A value of 0 results in a completely translucent plane while a value of 1 results in a completely opaque plane.
Plane | Property that returns the geometry of the ground plane. The returned Plane object provides information about the position and normal of the work plane.
Position | Property that gets and sets the position of the ground plane. Following are the valid objects: transient Point, WorkPoint and Vertex. In assemblies, WorkPointProxy and VertexProxy can be provided/returned.
ReflectionBlur | Property that gets and sets the reflection"s blurriness, specifying the amount of blur the ground plane surface will produce. The blur is defined using a value between 0 and 1. A value of 0 results in no blur while a value of 1 results in maximum blurring.
ReflectionBlurFalloff | Property that gets and sets where the model reflection seems to fade away. The blur fall-off is defined using a value between 0 and 1.
Reflectivity | Property that gets and sets the reflectivity of the ground plane. The reflectivity is defined using a value between 0 and 1. A value of 0 results in a non-reflective plane while a value of 1 results in a fully reflective plane.
Type | Returns an ObjectTypeEnum indicating this object's type.
UpDirection | Property that returns the up direction of the ground plane.
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties


GroundPlaneSettings.Application Property

GroundPlaneSettings.Application Property Available in Inventor
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Application Property


GroundPlaneSettings.AutoResize Property

GroundPlaneSettings.AutoResize Property
Summary

Property that gets or sets whether the ground plane should be resized automatically based on the component size. This property should be set to False in order to resize the plane using the SetSize method.

Visual Basic
Property AutoResize() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.AutoResize Property


GroundPlaneSettings.Color Property

GroundPlaneSettings.Color Property
Summary

Property that gets and sets the color for the ground plane for the area inside the margin. This property can be set to Nothing to indicate no color is to be used.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Color Property


GroundPlaneSettings.DisplayGridLines Property

GroundPlaneSettings.DisplayGridLines Property
Summary

Property that specifies whether to display grid lines.

Visual Basic
Property DisplayGridLines() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.DisplayGridLines Property


GroundPlaneSettings.FrontDirection Property

GroundPlaneSettings.FrontDirection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the front direction of the ground plane.

Visual Basic
Property FrontDirection() As UnitVector**
Remarks

This is the direction that the view curve refers to as “Front”. The front direction is set as a result of using either the SetCurrentAsFront or SetCurrentAsTop methods on the View object.

You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.FrontDirection Property


GroundPlaneSettings.HeightOffset Property

GroundPlaneSettings.HeightOffset Property
Summary

Property that gets and sets the offset of the ground plane from the specified position. Negative and positive values can be provided. The value is defined in centimeters.

Visual Basic
Property HeightOffset() As double
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.HeightOffset Property


GroundPlaneSettings.MinorGridLineSpacing Property

GroundPlaneSettings.MinorGridLineSpacing Property
Summary

Property that gets and sets the spacing between minor grid lines in centimeters.

Visual Basic
Property MinorGridLineSpacing() As double
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.MinorGridLineSpacing Property


GroundPlaneSettings.MinorLinesPerMajorGridLine Property

GroundPlaneSettings.MinorLinesPerMajorGridLine Property
Summary

Property that gets and sets the number of minor lines to appear between major lines. Major lines appear heavier in the grid display. Valid range of values is 1 to 512.

Visual Basic
Property MinorLinesPerMajorGridLine() As long
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.MinorLinesPerMajorGridLine Property


GroundPlaneSettings.Opacity Property

GroundPlaneSettings.Opacity Property
Summary

Property that gets and sets the opacity of the ground plane. The opacity is defined using a value between 0 and 1. A value of 0 results in a completely translucent plane while a value of 1 results in a completely opaque plane.

Visual Basic
Property Opacity() As double
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Opacity Property


GroundPlaneSettings.Plane Property

GroundPlaneSettings.Plane Property
Summary

Property that returns the geometry of the ground plane. The returned Plane object provides information about the position and normal of the work plane.

Visual Basic
Property Plane() As Plane**
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Plane Property


GroundPlaneSettings.Position Property

GroundPlaneSettings.Position Property
Summary

Property that gets and sets the position of the ground plane. Following are the valid objects: transient Point, WorkPoint and Vertex. In assemblies, WorkPointProxy and VertexProxy can be provided/returned.

Visual Basic
Property Position() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Position Property


GroundPlaneSettings.ReflectionBlur Property

GroundPlaneSettings.ReflectionBlur Property
Summary

Property that gets and sets the reflection"s blurriness, specifying the amount of blur the ground plane surface will produce. The blur is defined using a value between 0 and 1. A value of 0 results in no blur while a value of 1 results in maximum blurring.

Visual Basic
Property ReflectionBlur() As double
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.ReflectionBlur Property


GroundPlaneSettings.ReflectionBlurFalloff Property

GroundPlaneSettings.ReflectionBlurFalloff Property
Summary

Property that gets and sets where the model reflection seems to fade away. The blur fall-off is defined using a value between 0 and 1.

Visual Basic
Property ReflectionBlurFalloff() As double
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.ReflectionBlurFalloff Property


GroundPlaneSettings.Reflectivity Property

GroundPlaneSettings.Reflectivity Property
Summary

Property that gets and sets the reflectivity of the ground plane. The reflectivity is defined using a value between 0 and 1. A value of 0 results in a non-reflective plane while a value of 1 results in a fully reflective plane.

Visual Basic
Property Reflectivity() As double
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Reflectivity Property


GroundPlaneSettings.Type Property

GroundPlaneSettings.Type Property Available in Inventor
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.Type Property


GroundPlaneSettings.UpDirection Property

GroundPlaneSettings.UpDirection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the up direction of the ground plane.

Visual Basic
Property UpDirection() As UnitVector**
Remarks

The up direction is set as a result of using either the SetCurrentAsFront or SetCurrentAsTop methods on the View object.

You are here: Symbol Reference > Inventor Library > Objects > GroundPlaneSettings Interface > GroundPlaneSettings Properties > GroundPlaneSettings.UpDirection Property


HardwareOptions Interface

HardwareOptions Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

The HardwareOptions object provides access to properties that provide read and write access of the hardware related application options. This is somewhat equivalent to the Hardware tab of the Application Options dialog.

Class Hierarchy
Inventor::HardwareOptions
Visual Basic
Public Interface HardwareOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.HardwareOptions

ApprenticeServer.HardwareOptions

You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface


HardwareOptions Properties

HardwareOptions Properties
Summary

The properties of the HardwareOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Diagnostics | Property that returns a string with results of diagnostic testing.
GraphicsSettingType | Property that specifies the type of the graphics hardware setting to use.
Type | Returns an ObjectTypeEnum indicating this object's type.
UseSoftwareGraphics | Property that specifies whether to use software graphics. This should be used only for systems with unrecognized graphics hardware or when graphics hardware does not support desired functionality.
You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface > HardwareOptions Properties


HardwareOptions.Application Property

HardwareOptions.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface > HardwareOptions Properties > HardwareOptions.Application Property


HardwareOptions.Diagnostics Property

HardwareOptions.Diagnostics Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a string with results of diagnostic testing.

Visual Basic
Property Diagnostics() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface > HardwareOptions Properties > HardwareOptions.Diagnostics Property


HardwareOptions.GraphicsSettingType Property

HardwareOptions.GraphicsSettingType Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that specifies the type of the graphics hardware setting to use.

Visual Basic
Property GraphicsSettingType() As GraphicsSettingTypeEnum
Remarks

The valid options are kQualityGraphicsSetting, kPerformanceGraphicsSetting and kCompatibilityGraphicsSetting.

kQualityGraphicsSetting " Use this setting for the highest quality realistic visualization.

kPerformanceGraphicsSetting " Use this setting when performance is desired over realistic visualization such as in modeling where realistic visual quality may conflict with work or performance.

kCompatibilityGraphicsSetting " Use this setting for graphics compatible with previous Inventor releases.

Note: Changing the optimization setting does not take full effect until all windows in Autodesk Inventor have been closed and re-opened.

You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface > HardwareOptions Properties > HardwareOptions.GraphicsSettingType Property


HardwareOptions.Type Property

HardwareOptions.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface > HardwareOptions Properties > HardwareOptions.Type Property


HardwareOptions.UseSoftwareGraphics Property

HardwareOptions.UseSoftwareGraphics Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that specifies whether to use software graphics. This should be used only for systems with unrecognized graphics hardware or when graphics hardware does not support desired functionality.

Visual Basic
Property UseSoftwareGraphics() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HardwareOptions Interface > HardwareOptions Properties > HardwareOptions.UseSoftwareGraphics Property


HeadsUpDisplayOptions Interface

HeadsUpDisplayOptions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::HeadsUpDisplayOptions
Visual Basic
Public Interface HeadsUpDisplayOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchOptions.HeadsUpDisplayOptions

The HeadsUpDisplayOptions object provides access to various heads-up display related application level options for sketches. This object is obtained from the SketchOptions.HeadsUpDisplayOptions property.

You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface


HeadsUpDisplayOptions Properties

HeadsUpDisplayOptions Properties
Summary

The properties of the HeadsUpDisplayOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CreateDimensionsOnValueInput | Property that gets and sets whether to create dimensions when the user inputs values into the heads-up display fields.
DimensionInputEnabled | Property that gets and sets whether to enable dimension input where possible.
DimensionInputInCartesianCoordinates | Property that gets and sets whether dimension input is in Cartesian or Polar coordinates. If set to False, input is in Polar coordinates.
Enabled | Property that gets and sets whether heads-up display is enabled for sketches.
Parent | Property that returns the parent SketchOptions object.
PointerInputEnabled | Property that gets and sets whether pointer input is enabled for sketches.
PointerInputInCartesianCoordinates | Property that gets and sets whether pointer input is in Cartesian or Polar coordinates. If set to False, input is in Polar coordinates.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties


HeadsUpDisplayOptions.Application Property

HeadsUpDisplayOptions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.Application Property


HeadsUpDisplayOptions.CreateDimensionsOnValueInput Property

HeadsUpDisplayOptions.CreateDimensionsOnValueInput Property
Summary

Property that gets and sets whether to create dimensions when the user inputs values into the heads-up display fields.

Visual Basic
Property CreateDimensionsOnValueInput() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.CreateDimensionsOnValueInput Property


HeadsUpDisplayOptions.DimensionInputEnabled Property

HeadsUpDisplayOptions.DimensionInputEnabled Property
Summary

Property that gets and sets whether to enable dimension input where possible.

Visual Basic
Property DimensionInputEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.DimensionInputEnabled Property


HeadsUpDisplayOptions.DimensionInputInCartesianCoordinates Property

HeadsUpDisplayOptions.DimensionInputInCartesianCoordinates Property
Summary

Property that gets and sets whether dimension input is in Cartesian or Polar coordinates. If set to False, input is in Polar coordinates.

Visual Basic
Property DimensionInputInCartesianCoordinates() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.DimensionInputInCartesianCoordinates Property


HeadsUpDisplayOptions.Enabled Property

HeadsUpDisplayOptions.Enabled Property
Summary

Property that gets and sets whether heads-up display is enabled for sketches.

Visual Basic
Property Enabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.Enabled Property


HeadsUpDisplayOptions.Parent Property

HeadsUpDisplayOptions.Parent Property
Summary

Property that returns the parent SketchOptions object.

Visual Basic
Property Parent() As SketchOptions**
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.Parent Property


HeadsUpDisplayOptions.PointerInputEnabled Property

HeadsUpDisplayOptions.PointerInputEnabled Property
Summary

Property that gets and sets whether pointer input is enabled for sketches.

Visual Basic
Property PointerInputEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.PointerInputEnabled Property


HeadsUpDisplayOptions.PointerInputInCartesianCoordinates Property

HeadsUpDisplayOptions.PointerInputInCartesianCoordinates Property
Summary

Property that gets and sets whether pointer input is in Cartesian or Polar coordinates. If set to False, input is in Polar coordinates.

Visual Basic
Property PointerInputInCartesianCoordinates() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.PointerInputInCartesianCoordinates Property


HeadsUpDisplayOptions.Type Property

HeadsUpDisplayOptions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HeadsUpDisplayOptions Interface > HeadsUpDisplayOptions Properties > HeadsUpDisplayOptions.Type Property


HelicalConstraint3D Interface

HelicalConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This object represents a helix-based constraint.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::HelicalConstraint3D
Visual Basic
Public Interface HelicalConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

HelicalConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > HelicalConstraint3D Interface


HelicalConstraint3DProxy Interface

HelicalConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HelicalConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::HelicalConstraint3DProxy
Visual Basic
Public Interface HelicalConstraint3DProxy
Inherits GeometricConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HelicalConstraint3DProxy Interface


HelicalConstraint3DProxy Properties

HelicalConstraint3DProxy Properties
Summary

The properties of the HelicalConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > HelicalConstraint3DProxy Interface > HelicalConstraint3DProxy Properties


HelicalConstraint3DProxy.ContainingOccurrence Property

HelicalConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HelicalConstraint3DProxy Interface > HelicalConstraint3DProxy Properties > HelicalConstraint3DProxy.ContainingOccurrence Property


HelicalConstraint3DProxy.NativeObject Property

HelicalConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As HelicalConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HelicalConstraint3DProxy Interface > HelicalConstraint3DProxy Properties > HelicalConstraint3DProxy.NativeObject Property


HelpEventsObject Interface

HelpEventsObject Interface Available in Inventor Introduced in Inventor 2012
Summary

This object provides access to Help related events.

Class Hierarchy
Inventor::HelpEventsObject
Visual Basic
Public Interface HelpEventsObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > HelpEventsObject Interface


HelpEventsObject Properties

HelpEventsObject Properties
Summary

The properties of the HelpEventsObject class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Type | Property that returns the constant that indicates the type of the object.
You are here: Symbol Reference > Inventor Library > Objects > HelpEventsObject Interface > HelpEventsObject Properties


HelpEventsObject.Application Property

HelpEventsObject.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

Where the property is weakly-typed, it can be set to (QueryInterface for) "Application" when running with Inventor, whereas it can be set to "ApprenticeServer" when running with Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > HelpEventsObject Interface > HelpEventsObject Properties > HelpEventsObject.Application Property


HelpEventsObject.Type Property

HelpEventsObject.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the constant that indicates the type of the object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HelpEventsObject Interface > HelpEventsObject Properties > HelpEventsObject.Type Property


HelpEventsSink Interface

HelpEventsSink Interface
Summary

This is class Inventor::HelpEventsSink.

Class Hierarchy
Inventor::HelpEventsSink
Visual Basic
Public Interface HelpEventsSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > HelpEventsSink Interface


HelpEventsSink Methods

HelpEventsSink Methods
Summary

The methods of the HelpEventsSink class are listed here.

Methods
Methods
Name | Description
OnApplicationHelp | Event that fires before Application Help is displayed.
You are here: Symbol Reference > Inventor Library > Objects > HelpEventsSink Interface > HelpEventsSink Methods


HelpEventsSink.OnApplicationHelp Method

HelpEventsSink.OnApplicationHelp Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires before Application Help is displayed.

Visual Basic
Sub OnApplicationHelp(Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
You are here: Symbol Reference > Inventor Library > Objects > HelpEventsSink Interface > HelpEventsSink Methods > HelpEventsSink.OnApplicationHelp Method


HelpManager Interface

HelpManager Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The HelpManager object encapsulates all of the help functionality.

Class Hierarchy
Inventor::HelpManager
Visual Basic
Public Interface HelpManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.HelpManager

You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface


HelpManager Methods

HelpManager Methods
Summary

The methods of the HelpManager class are listed here.

Methods
Methods
Name | Description
DisplayHelpContext | Displays an HTML Help Context ID.
DisplayHelpTopic | Displays an HTML Help topic.
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Methods


HelpManager.DisplayHelpContext Method

HelpManager.DisplayHelpContext Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Displays an HTML Help Context ID.

Visual Basic
Sub DisplayHelpContext(FileName As String, Context As long)
Parameters
Parameters | Description
FileName | Input String that specifies the name of the Help file that contains the context ID.
Context | Input Long that specifies the HTML Help context ID.
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Methods > HelpManager.DisplayHelpContext Method


HelpManager.DisplayHelpTopic Method

HelpManager.DisplayHelpTopic Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Displays an HTML Help topic.

Visual Basic
Sub DisplayHelpTopic(FileName As String, TopicName As String)
Parameters
Parameters | Description
FileName | Input String that specifies the name of the helpfile that contains the topic.
TopicName | Input String that specifies the name of the help topic to display.
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Methods > HelpManager.DisplayHelpTopic Method


HelpManager Properties

HelpManager Properties
Summary

The properties of the HelpManager class are listed here.

Properties
Name | Description
HelpEvents | Property that returns the object that fires Help related events.
HelpPath | Gets the full path location of the help directory.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Properties


HelpManager.HelpEvents Property

HelpManager.HelpEvents Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the object that fires Help related events.

Visual Basic
Property HelpEvents() As HelpEvents**
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Properties > HelpManager.HelpEvents Property


HelpManager.HelpPath Property

HelpManager.HelpPath Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the full path location of the help directory.

Visual Basic
Property HelpPath() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Properties > HelpManager.HelpPath Property


HelpManager.Parent Property

HelpManager.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Properties > HelpManager.Parent Property


HelpManager.Type Property

HelpManager.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HelpManager Interface > HelpManager Properties > HelpManager.Type Property


HemDefinition Interface

HemDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The HemDefinition object represents all of the information that defines a hem feature.

Class Hierarchy
Inventor::HemDefinition
Visual Basic
Public Interface HemDefinition
Inherits IDispatch
Remarks

The HemDefinition object is used in two ways. First it is used as input when creating a hem feature. Second it is used to query and edit existing hem features. When creating a new hem feature you use the HemFeatures.CreateHemDefinition method to create a new HemDefinition object. Using the properties of this object you can define the various options of the hem feature. Typically a new HemDefinition object is created and then modified to get the desired hem feature and then used as input to the HemFeatures.Add method. An existing HemFeature object is edited by modifying its associated HemDefinition object.

Notes

Members through which this object may be accessed include:

DoubleHemDefinition.Parent

HemDefinition.Copy

HemFeature.Definition

HemFeatures.CreateHemDefinition

RolledHemDefinition.Parent

SingleHemDefinition.Parent

TeardropHemDefinition.Parent

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface


HemDefinition Methods

HemDefinition Methods
Summary

The methods of the HemDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this HemDefinition object.
SetCenteredWidthExtent | Method that changes the HemDefinition object to define a hem that's centered along the edge and has a defined width.
SetDoubleHemType | Method that changes the HemDefinition object to define a hem whose shape has a double bend.
SetEdgeWidthExtent | Method that changes the ContourFlangeDefinition object to define a hem whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the hems.
SetFromToWidthExtent | Method that changes the FlangeDefinition object to define a hem whose width is defined as being between two entities.
SetOffsetWidthExtent | Method that changes the HemDefinition object to define a hem whose width is defined with respect to two entities.
SetRolledHemType | Method that changes the HemDefinition object to define a hem whose shape has a rolled bend.
SetSingleHemType | Method that changes the HemDefinition object to define a hem whose shape has a single bend.
SetTeardropHemType | Method that changes the HemDefinition object to define a hem whose shape has a teardrop bend.
SetWidthOffsetWidthExtent | Method that changes the ContourFlangeDefinition object to define a hem whose width is defined relative to another entity.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods


HemDefinition.Copy Method

HemDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a copy of this HemDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] HemDefinition*)
Remarks

The new HemDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new hem feature.

Any of the properties of the HemDefinition that can reference a Parameter object will behave differently depending on if the HemDefinition is independent or associated with a feature. When it is associated with a feature these properties behave as read-only and will return the related Parameter object. When it is not associated with a feature these properties behave as read-write and will accept and return doubles and strings to define the value.

One typical use of this method is when you need to make several changes to an existing hem feature. If you edit the HemDefinition object associated with the hem feature, the feature will recompute after each edit. It's more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The HemFeatures.CreateHemDefinition method can also be used to create an independent HemDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateHemDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.Copy Method


HemDefinition.SetCenteredWidthExtent Method

HemDefinition.SetCenteredWidthExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the HemDefinition object to define a hem that's centered along the edge and has a defined width.

Visual Basic
Sub SetCenteredWidthExtent(Width As VARIANT)
Parameters
Parameters | Description
Width | Input Variant that defines the distance used for the width extent of the hem. This value is used to define that distance. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetCenteredWidthExtent Method


HemDefinition.SetDoubleHemType Method

HemDefinition.SetDoubleHemType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the HemDefinition object to define a hem whose shape has a double bend.

Visual Basic
Sub SetDoubleHemType(Gap As VARIANT, Length As VARIANT)
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetDoubleHemType Method


HemDefinition.SetEdgeWidthExtent Method

HemDefinition.SetEdgeWidthExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the ContourFlangeDefinition object to define a hem whose width is defined by the length of the input edge(s). These are the same edges that were specified to define the location of the hems.

Visual Basic
Sub SetEdgeWidthExtent()
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetEdgeWidthExtent Method


HemDefinition.SetFromToWidthExtent Method

HemDefinition.SetFromToWidthExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the FlangeDefinition object to define a hem whose width is defined as being between two entities.

Visual Basic
Sub SetFromToWidthExtent(FromEntity As IDispatch, ToEntity As IDispatch)
Parameters
Parameters | Description
FromEntity | Input Object that defines the 'from' extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
ToEntity | Input Object that defines the 'to' extents. This can be a planar Face, WorkPlane, Vertex, or WorkPoint object that intersects the selected edge.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetFromToWidthExtent Method


HemDefinition.SetOffsetWidthExtent Method

HemDefinition.SetOffsetWidthExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the HemDefinition object to define a hem whose width is defined with respect to two entities.

Visual Basic
Sub SetOffsetWidthExtent(OffsetEntityOne As IDispatch, OffsetDistanceOne As VARIANT, OffsetEntityTwo As IDispatch, OffsetDistanceTwo As VARIANT)
Parameters
Parameters | Description
OffsetEntityOne | Input Object that defines the first entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceOne | Input Variant that defines the distance of the hem from offset entity one. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntityTwo | Input Object that defines the second entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
OffsetDistanceTwo | Input Variant that defines the distance of the hem from offset entity two. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetOffsetWidthExtent Method


HemDefinition.SetRolledHemType Method

HemDefinition.SetRolledHemType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the HemDefinition object to define a hem whose shape has a rolled bend.

Visual Basic
Sub SetRolledHemType(Radius As VARIANT, Angle As VARIANT)
Parameters
Parameters | Description
Radius | Input Variant that defines the radius of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Angle | Input Variant that defines the angle of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetRolledHemType Method


HemDefinition.SetSingleHemType Method

HemDefinition.SetSingleHemType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the HemDefinition object to define a hem whose shape has a single bend.

Visual Basic
Sub SetSingleHemType(Gap As VARIANT, Length As VARIANT)
Parameters
Parameters | Description
Gap | Input Variant that defines the gap of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Length | Input Variant that defines the length of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetSingleHemType Method


HemDefinition.SetTeardropHemType Method

HemDefinition.SetTeardropHemType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the HemDefinition object to define a hem whose shape has a teardrop bend.

Visual Basic
Sub SetTeardropHemType(Radius As VARIANT, Angle As VARIANT)
Parameters
Parameters | Description
Radius | Input Variant that defines the radius of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Angle | Input Variant that defines the angle of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetTeardropHemType Method


HemDefinition.SetWidthOffsetWidthExtent Method

HemDefinition.SetWidthOffsetWidthExtent Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the ContourFlangeDefinition object to define a hem whose width is defined relative to another entity.

Visual Basic
Sub SetWidthOffsetWidthExtent(Width As VARIANT, OffsetDistance As VARIANT, OffsetEntity As IDispatch, PositiveDirection As VARIANT_BOOL)
Parameters
Parameters | Description
Width | Input Variant that defines the distance to use for the width extent of the hem. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetDistance | Input Variant that defines the distance of the hem from the offset entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
OffsetEntity | Input Object that defines the entity the distance is measured relative to. This can be a point (WorkPoint or a Vertex object) or a plane (Face or WorkPlane object that is perpendicular to the selected edge).
PositiveDirection | Input Boolean that specifies the side of the offset entity the hem is on.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Methods > HemDefinition.SetWidthOffsetWidthExtent Method


HemDefinition Properties

HemDefinition Properties
Summary

The properties of the HemDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BendOptions | Property that gets and sets the bend options associated with this contour flange feature.
Edges | Property that gets and set the EdgeCollection object that contains the edges that are used to define the hem feature. Hem features are currently limited to a single edge. When querying an existing hem faeture the originally selected edges are not available because they were consumed when the hem feature was created. To access these edges the end-of-part marker must be placed above the hem feature.
HemType | Property that returns the method used to define the type of hem.
HemTypeDefinition | Property that returns the HemTypeDefinition object that defines the type of hem.
IsOnEdgeSide | Property that returns the side of the part the hem is on. If True the hem is on the side of the input edge, if False, it is on the opposite side.Parent As HemFeature.
IsUnfoldMethodOverridden | Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.
Parent | Property that returns the parent HemFeature of this HemDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
UnfoldMethod | Property that gets and set the UnfoldMethod object that defines how the bends associated with this contour flange feature are unfolded.
WidthExtent | Property that returns the PartFeatureExtent object that defines how the width extent of the hem feature is defined.
WidthExtentType | Property that returns the method used to define the width extent.
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties


HemDefinition.Application Property

HemDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.Application Property


HemDefinition.BendOptions Property

HemDefinition.BendOptions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the bend options associated with this contour flange feature.

Visual Basic
Property BendOptions() As BendOptions*
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.BendOptions Property


HemDefinition.Edges Property

HemDefinition.Edges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the EdgeCollection object that contains the edges that are used to define the hem feature. Hem features are currently limited to a single edge. When querying an existing hem faeture the originally selected edges are not available because they were consumed when the hem feature was created. To access these edges the end-of-part marker must be placed above the hem feature.

Visual Basic
Property Edges() As EdgeCollection*
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.Edges Property


HemDefinition.HemType Property

HemDefinition.HemType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the method used to define the type of hem.

Visual Basic
Property HemType() As HemTypeEnum*
Remarks

The valid values for this property are kSingleHemType, kTeardropHemType, kRolledHemType, and kDoubleHemType.

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.HemType Property


HemDefinition.HemTypeDefinition Property

HemDefinition.HemTypeDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the HemTypeDefinition object that defines the type of hem.

Visual Basic
Property HemTypeDefinition() As IDispatch**
Remarks

The type of hem object that this property will return can be determined by using the HemType property. Types that can be returned are SingleHemDefinition, TeardropHemDefinition, RolledHemDefinition, and DoubleHemDefinition.

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.HemTypeDefinition Property


HemDefinition.IsOnEdgeSide Property

HemDefinition.IsOnEdgeSide Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the side of the part the hem is on. If True the hem is on the side of the input edge, if False, it is on the opposite side.Parent As HemFeature.

Visual Basic
Property IsOnEdgeSide() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.IsOnEdgeSide Property


HemDefinition.IsUnfoldMethodOverridden Property

HemDefinition.IsUnfoldMethodOverridden Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.

Visual Basic
Property IsUnfoldMethodOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.IsUnfoldMethodOverridden Property


HemDefinition.Parent Property

HemDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent HemFeature of this HemDefinition object.

Visual Basic
Property Parent() As HemFeature**
Remarks

In the case where this is a newly created HemDefinition object or it has been copied from an existing HemDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.Parent Property


HemDefinition.Type Property

HemDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.Type Property


HemDefinition.UnfoldMethod Property

HemDefinition.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the UnfoldMethod object that defines how the bends associated with this contour flange feature are unfolded.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.UnfoldMethod Property


HemDefinition.WidthExtent Property

HemDefinition.WidthExtent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the PartFeatureExtent object that defines how the width extent of the hem feature is defined.

Visual Basic
Property WidthExtent() As PartFeatureExtent**
Remarks

The type of extent object that this property will return can be determined by using the WidthExtentType property. Types that can be returned are CenteredWidthExtent, EdgeWidthExtent, FromToWidthExtent, OffsetWidthExtent, and WidthOffsetWidthExtent. When a new HemDefinition object is created using the HemFeatures.CreateHemDefinition method the extent is not accessible and this property will return Nothing. The extent type will default to a edge width extent. To use a different extent type you can use the various Set methods of the HemDefinition to define a new width extent.

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.WidthExtent Property


HemDefinition.WidthExtentType Property

HemDefinition.WidthExtentType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the method used to define the width extent.

Visual Basic
Property WidthExtentType() As PartFeatureExtentEnum*
Remarks

The valid values for this property are kCenteredWidthExtent, kEdgeWidthExtent, kFromToWidthExtent, kOffsetWidthExtent, and kWidthOffsetWidthExtent.

You are here: Symbol Reference > Inventor Library > Objects > HemDefinition Interface > HemDefinition Properties > HemDefinition.WidthExtentType Property


HemFeature Interface

HemFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The HemFeature object represents a sheet metal hem feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::HemFeature
        Inventor::HemFeatureProxy
Visual Basic
Public Interface HemFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

HemDefinition.Parent

HemFeatures.Add

HemFeatures.Item

See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > HemFeature Interface


HemFeature Properties

HemFeature Properties
Summary

The properties of the HemFeature class are listed here.

Properties
Name | Description
Definition | Property that gets the HemDefinition object associated with this fold feature.
You are here: Symbol Reference > Inventor Library > Objects > HemFeature Interface > HemFeature Properties


HemFeature.Definition Property

HemFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the HemDefinition object associated with this fold feature.

Visual Basic
Property Definition() As HemDefinition**
Remarks

Modifying the HemDefinition object will edit the associated HemFeature.

You are here: Symbol Reference > Inventor Library > Objects > HemFeature Interface > HemFeature Properties > HemFeature.Definition Property


HemFeatureProxy Interface

HemFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HemFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::HemFeature
        Inventor::HemFeatureProxy
Visual Basic
Public Interface HemFeatureProxy
Inherits HemFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HemFeatureProxy Interface


HemFeatures Interface

HemFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The HemFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::HemFeatures
Visual Basic
Public Interface HemFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.HemFeatures

You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface


HemFeatures Methods

HemFeatures Methods
Summary

The methods of the HemFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new hem feature. The newly created HemFeature object is returned.
CreateHemDefinition | Method that creates a new HemDefinition object.
Item | Property that returns the specified HemFeature object from the collection. This is the default property of the HemFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Methods


HemFeatures.Add Method

HemFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new hem feature. The newly created HemFeature object is returned.

Visual Basic
Sub Add(HemDefinition As HemDefinition, Result As [out, retval] HemFeature*)
Parameters
Parameters | Description
HemDefinition | Input HemDefinition object that defines the hem feature you want to create. A HemDefinition object can be created using the HemFeatures.CreateHemDefinition method. It can also be obtained from an existing HemFeature object.
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Methods > HemFeatures.Add Method


HemFeatures.CreateHemDefinition Method

HemFeatures.CreateHemDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new HemDefinition object.

Visual Basic
Sub CreateHemDefinition(Edges As EdgeCollection, Result As [out, retval] HemDefinition*)
Parameters
Parameters | Description
Edges | Input EdgeCollection object that specifies the edges to create a hem feature on.
Remarks

The object created does not represent a hem feature but instead is a representation of the information that defines a hem feature. You can use this object as input to the HemFeatures.Add method to create the actual hem feature.

The HemDefinition object returned is fully defined and can be used to create a hem feature. However, defaults are used for most of the hem options so you may want to change some of the property values of the HemDefinition object before using it to create a hem feature.

You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Methods > HemFeatures.CreateHemDefinition Method


HemFeatures.Item Method

HemFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified HemFeature object from the collection. This is the default property of the HemFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] HemFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Methods > HemFeatures.Item Method


HemFeatures Properties

HemFeatures Properties
Summary

The properties of the HemFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Properties


HemFeatures.Application Property

HemFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Properties > HemFeatures.Application Property


HemFeatures.Count Property

HemFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Properties > HemFeatures.Count Property


HemFeatures.Type Property

HemFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HemFeatures Interface > HemFeatures Properties > HemFeatures.Type Property


HighlightSet Interface

HighlightSet Interface Available in Inventor Introduced in Inventor 5
Summary

The HighlightSet object defines a set of objects and an associated color to display them with.

Class Hierarchy
Inventor::HighlightSet
Visual Basic
Public Interface HighlightSet
Inherits IDispatch
Remarks

When highlighting an object in the assembly context, for example during in-place editing using ActiveEdit, remember that you are in fact dealing with proxy objects, not native objects.

Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.CreateHighlightSet

Document.CreateHighlightSet

HighlightSets.Add

HighlightSets.Item

See Also

Creating a HighlightSet sample

Interference Analysis sample

Example

"Highlight Feature Faces Example"

This sample highlights the faces of an extrusion, revolution, or hole feature. It differentiates the faces on the start cap, end cap, and side faces by highlighting them in different colors.

The HighlightFeatureFaces sub highlights the feature faces. Since the highlight set objects are declared outside of this sub, the highlighting remains after the sub has finished executing. Use the ClearHighlight sub to clear the highlighting that does so by releasing the HighlightSet objects.

Private oStartHLSet As HighlightSet
Private oEndHLSet As HighlightSet
Private oSideHLSet As HighlightSet

Public Sub HighlightFeatureFaces()
    ' Get the first item in the select set. This assumes it is a feature.
    If ThisApplication.ActiveDocument.SelectSet.Count > 0 Then
        Dim oFeature As PartFeature
        Set oFeature = ThisApplication.ActiveDocument.SelectSet.Item(1)
    Else
        MsgBox "You must select a feature."
        Exit Sub
    End If

    ' Check to see that it's an extrusion, revolution or hole feature.
    If oFeature.Type  kExtrudeFeatureObject And _
       oFeature.Type  kRevolveFeatureObject And _
       oFeature.Type  kHoleFeatureObject Then
        MsgBox "You must select an extrusion, revolution, or hole."
        Exit Sub
    End If

    ' Create a new highlight set for the start face(s).
    Set oStartHLSet = ThisApplication.ActiveDocument.CreateHighlightSet

    ' Change the highlight color for the set to red.
    Dim oRed As Color
    Set oRed = ThisApplication.TransientObjects.CreateColor(255, 0, 0)

    ' Set the opacity
    oRed.Opacity = 0.8

    oStartHLSet.Color = oRed

    ' Add all start faces to the highlightset. Skip holes because
    ' they don't support the StartFaces property.
    If oFeature.Type  kHoleFeatureObject Then
        Dim oFace As Face
        For Each oFace In oFeature.StartFaces
            oStartHLSet.AddItem oFace
        Next
    End If

    ' Create a new highlight set for the end face(s).
    Set oEndHLSet = ThisApplication.ActiveDocument.CreateHighlightSet

    ' Change the highlight color for the set to green.
    Dim oGreen As Color
    Set oGreen = ThisApplication.TransientObjects.CreateColor(0, 255, 0)

    oEndHLSet.Color = oGreen

    ' Add all end faces to the highlightset.
    For Each oFace In oFeature.EndFaces
        oEndHLSet.AddItem oFace
    Next

    ' Create a new highlight set for the side face(s).
    Set oSideHLSet = ThisApplication.ActiveDocument.CreateHighlightSet

    ' Change the highlight color for the set to blue.
    Dim oBlue As Color
    Set oBlue = ThisApplication.TransientObjects.CreateColor(0, 0, 255)

    oSideHLSet.Color = oBlue

    ' Add all end faces to the highlightset.
    For Each oFace In oFeature.SideFaces
        oSideHLSet.AddItem oFace
    Next

    MsgBox "Start faces are displayed in red." & Chr(13) & _
            "End faces are displayed in green." & Chr(13) & _
            "Side faces are displayed in blue.", vbOKOnly + vbInformation
End Sub

Public Sub ClearHighlight()

    ' Release the highlight set objects to clear highlighting.
    ' Alternatively, HighlightSet.Delete or HighlightSet.Clear
    ' can also be used to clear the highlighting.

    Set oStartHLSet = Nothing
    Set oEndHLSet = Nothing
    Set oSideHLSet = Nothing
End Sub
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface


HighlightSet Methods

HighlightSet Methods
Summary

The methods of the HighlightSet class are listed here.

Methods
Methods
Name | Description
AddItem | Method that adds an entity to the highlight set.
Clear | Method that removes all objects from the highlight set.
Delete | Method that deletes the HighlightSet object.
GetColor | Method that gets the color of the highlight set. The highlight set color is initialized to the highlight color defined by the current color scheme.
Item | Property that returns the specified object from the highlight set.
Remove | Method that removes the specified object from the highlight set.
SetColor | Method that sets the color of the highlight set.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods


HighlightSet.AddItem Method

HighlightSet.AddItem Method Available in Inventor Introduced in Inventor 5
Summary

Method that adds an entity to the highlight set.

Visual Basic
Sub AddItem(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input Autodesk Inventor object that is valid to be highlighted.
See Also

Creating a HighlightSet sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.AddItem Method


HighlightSet.Clear Method

HighlightSet.Clear Method Available in Inventor Introduced in Inventor 5
Summary

Method that removes all objects from the highlight set.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.Clear Method


HighlightSet.Delete Method

HighlightSet.Delete Method Available in Inventor Introduced in Inventor 5
Summary

Method that deletes the HighlightSet object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.Delete Method


HighlightSet.GetColor Method

HighlightSet.GetColor Method Available in Inventor
Summary

Method that gets the color of the highlight set. The highlight set color is initialized to the highlight color defined by the current color scheme.

Visual Basic
Sub GetColor(ByRef Red As long, ByRef Green As long, ByRef Blue As long)
Parameters
Parameters | Description
Red | Output value that specifies the red component of the color. This will be a value between 0 and 255.
Green | Output value that specifies the green component of the color. This will be a value between 0 and 255.
Blue | Output value that specifies the blue component of the color. This will be a value between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.GetColor Method


HighlightSet.Item Method

HighlightSet.Item Method Available in Inventor Introduced in Inventor 5
Summary

Property that returns the specified object from the highlight set.

Visual Basic
Sub Item(index As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Input Long that specifies the index of the item within the collection to return.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.Item Method


HighlightSet.Remove Method

HighlightSet.Remove Method Available in Inventor Introduced in Inventor 5
Summary

Method that removes the specified object from the highlight set.

Visual Basic
Sub Remove(Index As VARIANT)
Parameters
Parameters | Description
index | Input value that specifies the object to remove. This can be a Long, which specifies the index within the collection of the item to remove, or it can be the object you wish to remove. This method only removes the object from the highlight set. It does not delete it from the document.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.Remove Method


HighlightSet.SetColor Method

HighlightSet.SetColor Method Available in Inventor
Summary

Method that sets the color of the highlight set.

Visual Basic
Sub SetColor(Red As long, Green As long, Blue As long)
Parameters
Parameters | Description
Red | Input value that specifies the red component of the color. This must be a value between 0 and 255.
Green | Input value that specifies the green component of the color. This must be a value between 0 and 255.
Blue | Input value that specifies the blue component of the color. This must be a value between 0 and 255.
See Also

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Methods > HighlightSet.SetColor Method


HighlightSet Properties

HighlightSet Properties
Summary

The properties of the HighlightSet class are listed here.

Properties
Name | Description
Color | Property that gets and sets the color to use for the highlight set. The highlight set color is initialized to the highlight color defined by the current color scheme. A Color object can be created using the TransientObjects.CreateColor method.
Count | Property that returns the number of objects in the highlight set.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Properties


HighlightSet.Color Property

HighlightSet.Color Property Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets the color to use for the highlight set. The highlight set color is initialized to the highlight color defined by the current color scheme. A Color object can be created using the TransientObjects.CreateColor method.

Visual Basic
Property Color() As Color*
See Also

Highlight Feature Faces sample

Creating a HighlightSet sample

You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Properties > HighlightSet.Color Property


HighlightSet.Count Property

HighlightSet.Count Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the number of objects in the highlight set.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Properties > HighlightSet.Count Property


HighlightSet.Type Property

HighlightSet.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HighlightSet Interface > HighlightSet Properties > HighlightSet.Type Property


HighlightSets Interface

HighlightSets Interface
Class Hierarchy
Inventor::HighlightSets
Visual Basic
Public Interface HighlightSets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.HighlightSets

Document.HighlightSets

The HighlightSets collection object allows for the creation of objects and provides access to existing HighlightSet objects.

Example

See HighlightSet for example "HighlightSet Object"

You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface


HighlightSets Methods

HighlightSets Methods
Summary

The methods of the HighlightSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new HighlightSet object. A new HighlightSet will be empty and the color will be the current highlight color as defined by the color scheme.
Item | Property that returns the specified HighlightSet from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface > HighlightSets Methods


HighlightSets.Add Method

HighlightSets.Add Method
Summary

Method that creates a new HighlightSet object. A new HighlightSet will be empty and the color will be the current highlight color as defined by the color scheme.

Visual Basic
Sub Add(Result As [out, retval] HighlightSet*)
Example

See HighlightSet for example "HighlightSet Object"

You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface > HighlightSets Methods > HighlightSets.Add Method


HighlightSets.Item Method

HighlightSets.Item Method
Summary

Property that returns the specified HighlightSet from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] HighlightSet*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface > HighlightSets Methods > HighlightSets.Item Method


HighlightSets Properties

HighlightSets Properties
Summary

The properties of the HighlightSets class are listed here.

Properties
Name | Description
Count | Property that returns the number of HighlightSet objects in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface > HighlightSets Properties


HighlightSets.Count Property

HighlightSets.Count Property
Summary

Property that returns the number of HighlightSet objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface > HighlightSets Properties > HighlightSets.Count Property


HighlightSets.Type Property

HighlightSets.Type Property
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HighlightSets Interface > HighlightSets Properties > HighlightSets.Type Property


HoleFeature Interface

HoleFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The HoleFeature object represents hole modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::HoleFeature
        Inventor::HoleFeatureProxy
Visual Basic
Public Interface HoleFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

HoleFeatureProxy.NativeObject

HoleFeatures.AddCBoreByDistanceExtent

HoleFeatures.AddCBoreByThroughAllExtent

HoleFeatures.AddCBoreByToFaceExtent

HoleFeatures.AddCSinkByDistanceExtent

HoleFeatures.AddCSinkByThroughAllExtent

HoleFeatures.AddCSinkByToFaceExtent

HoleFeatures.AddDrilledByDistanceExtent

HoleFeatures.AddDrilledByThroughAllExtent

HoleFeatures.AddDrilledByToFaceExtent

HoleFeatures.AddSpotFaceByDistanceExtent

HoleFeatures.AddSpotFaceByThroughAllExtent

HoleFeatures.AddSpotFaceByToFaceExtent

HoleFeatures.Item

HolePlacementDefinition.Parent

Example

"Hole Feature - Through holes (RegularAndTapped) Example "

This sample demonstrates the creation of through holes, both regular and tapped.

Public Sub HoleSample()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create a rectangle on the sketch.
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                        oTransGeom.CreatePoint2d(0, 0), _
                                        oTransGeom.CreatePoint2d(6, 4))

    ' Create the profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extrusion.
    Call oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent(oProfile, _
                                    "2 cm", kNegativeExtentDirection, kJoinOperation)

    ' Create a new sketch to contain the points that define the hole centers.
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Create an object collection for the hole center points.
    Dim oHoleCenters As ObjectCollection
    Set oHoleCenters = ThisApplication.TransientObjects.CreateObjectCollection

    ' Add two points as hole centers.
    oHoleCenters.Add oSketch.SketchPoints.Add(oTransGeom.CreatePoint2d(1, 1))
    oHoleCenters.Add oSketch.SketchPoints.Add(oTransGeom.CreatePoint2d(5, 1))

    ' Create the hole feature.
    Call oCompDef.Features.HoleFeatures.AddDrilledByThroughAllExtent( _
                            oHoleCenters, "1 cm", kPositiveExtentDirection)

    ' Define tap information.

    Dim oHoleTapInfo As HoleTapInfo
    Set oHoleTapInfo = oCompDef.Features.HoleFeatures.CreateTapInfo( _
                            True, "ANSI Unified Screw Threads", _
                            "7/16-14 UNC", "1B", False, "1 cm")

    ' Create a new sketch for the tapped hole centers.
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Create a new object collection for the hole center points.
    Set oHoleCenters = ThisApplication.TransientObjects.CreateObjectCollection

    ' Add two points as hole centers.
    oHoleCenters.Add oSketch.SketchPoints.Add(oTransGeom.CreatePoint2d(1, 3))
    oHoleCenters.Add oSketch.SketchPoints.Add(oTransGeom.CreatePoint2d(5, 3))

    ' Create the hole feature.
    Call oCompDef.Features.HoleFeatures.AddDrilledByThroughAllExtent( _
                            oHoleCenters, oHoleTapInfo, kPositiveExtentDirection)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface


HoleFeature Methods

HoleFeature Methods
Summary

The methods of the HoleFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Method that adds the specified participant to the assembly feature. This method fails for features in a part.
SetCBore | Method that changes the hole to be a counterbore hole type. If the hole is already a counterbore type you can access and modify the counterbore parameters using the CBoreDiameter and CBoreDepth properties of the HoleFeature object.
SetCSink | Method that changes the hole to be a countersink hole type. If the hole is already a countersink type you can access and modify the counterbore parameters using the CSinkDiameter and CSinkAngle properties of the HoleFeature object.
SetDistanceExtent | Method that specifies the termination type for the hole feature. Hole features can be specified to terminate at a particular distance or object, or can be specified as "through all," which means it extends through all faces of the feature. This method defines the hole's termination at a particular distance.
SetDrilled | Method that changes the hole to be a drilled hole type.
SetSpotFace | Method that changes the hole to be a spotface hole type. If the hole is already a spotface type you can access and modify the spotface parameters using the SpotFaceDiameter and SpotFaceDepth properties of the HoleFeature object. This method will fail of the hole contains a tapered thread.
SetThroughAllExtent | Method that specifies the termination type for the hole feature. Hole features can be specified to terminate at a particular distance or object, or can be specified as "through all," which means it extends through all faces of the feature. This method defines a through-all termination type.
SetToFaceExtent | Method that specifies the termination type for the hole feature. Hole features can be specified to terminate at a particular distance or object, or can be specified as "through all," which means it extends through all faces of the feature. This method defines the hole's termination at a particular face.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods


HoleFeature.AddParticipant Method

HoleFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that adds the specified participant to the assembly feature. This method fails for features in a part.

Visual Basic
Sub AddParticipant(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the participant to be added. An error occurs if the input ComponentOccurrence is not a leaf occurrence.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.AddParticipant Method


HoleFeature.SetCBore Method

HoleFeature.SetCBore Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that changes the hole to be a counterbore hole type. If the hole is already a counterbore type you can access and modify the counterbore parameters using the CBoreDiameter and CBoreDepth properties of the HoleFeature object.

Visual Basic
Sub SetCBore(CBoreDiameter As VARIANT, CBoreDepth As VARIANT)
Parameters
Parameters | Description
CBoreDiameter | Input Variant that defines the diameter of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units.
CBoreDepth | Input Variant that defines the depth of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetCBore Method


HoleFeature.SetCSink Method

HoleFeature.SetCSink Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that changes the hole to be a countersink hole type. If the hole is already a countersink type you can access and modify the counterbore parameters using the CSinkDiameter and CSinkAngle properties of the HoleFeature object.

Visual Basic
Sub SetCSink(CSinkDiameter As VARIANT, CSinkAngle As VARIANT)
Parameters
Parameters | Description
CSinkDiameter | Input Variant that defines the diameter of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or it will default to the current length units of the document.
CSinkAngle | Input Variant that defines the angle of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetCSink Method


HoleFeature.SetDistanceExtent Method

HoleFeature.SetDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that specifies the termination type for the hole feature. Hole features can be specified to terminate at a particular distance or object, or can be specified as "through all," which means it extends through all faces of the feature. This method defines the hole's termination at a particular distance.

Visual Basic
Sub SetDistanceExtent(Depth As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef FlatBottom As [defaultvalue(0xff)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT)
Parameters
Parameters | Description
Depth | Input Variant that specifies the depth to which to extend the hole feature.
ExtentDirection | Input constant that specifies the direction in which to extend the hole feature.
FlatBottom | Optional input Boolean that determines whether the hole feature has a flat bottom.
BottomTipAngle | Optional input Variant that specifies the angle of the hole feature's bottom tip (if FlatBottom is False.)
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetDistanceExtent Method


HoleFeature.SetDrilled Method

HoleFeature.SetDrilled Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that changes the hole to be a drilled hole type.

Visual Basic
Sub SetDrilled()
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetDrilled Method


HoleFeature.SetSpotFace Method

HoleFeature.SetSpotFace Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that changes the hole to be a spotface hole type. If the hole is already a spotface type you can access and modify the spotface parameters using the SpotFaceDiameter and SpotFaceDepth properties of the HoleFeature object. This method will fail of the hole contains a tapered thread.

Visual Basic
Sub SetSpotFace(SpotFaceDiameter As VARIANT, SpotFaceDepth As VARIANT)
Parameters
Parameters | Description
SpotFaceDiameter | Input Variant that defines the diameter of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
SpotFaceDepth | Input Variant that defines the depth of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetSpotFace Method


HoleFeature.SetThroughAllExtent Method

HoleFeature.SetThroughAllExtent Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that specifies the termination type for the hole feature. Hole features can be specified to terminate at a particular distance or object, or can be specified as "through all," which means it extends through all faces of the feature. This method defines a through-all termination type.

Visual Basic
Sub SetThroughAllExtent(ExtentDirection As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
ExtentDirection | Input argument identifying the direction in which to extend the hole feature.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetThroughAllExtent Method


HoleFeature.SetToFaceExtent Method

HoleFeature.SetToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that specifies the termination type for the hole feature. Hole features can be specified to terminate at a particular distance or object, or can be specified as "through all," which means it extends through all faces of the feature. This method defines the hole's termination at a particular face.

Visual Basic
Sub SetToFaceExtent(ToFace As IDispatch, ExtendToFace As VARIANT_BOOL)
Parameters
Parameters | Description
ToFace | Input Object that defines the 'to face.' This can be either a or WorkPlane object.
ExtendToFace | Input Boolean that specifies whether to extend to the face.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Methods > HoleFeature.SetToFaceExtent Method


HoleFeature Properties

HoleFeature Properties
Summary

The properties of the HoleFeature class are listed here.

Properties
Name | Description
BottomTipAngle | Property that returns the Parameter that defines the included angle of the tip of a blind hole, one that has been specified by a distance extent or 'to face' extent . If this is a Flat Bottomed hole then the property will return Nothing.
CBoreDepth | Property that returns the parameter controlling the CBore depth. This property will return Nothing in the case where the HoleType is not kCounterBoreHole.
CBoreDiameter | Property that returns the parameter controlling the CBore diameter. This property will return Nothing in the case where the HoleType is not kCounterBoreHole.
CSinkAngle | Property that returns the parameter controlling the CSink angle. This property will return Nothing in the case where the HoleType is not kCounterSinkHole.
CSinkDiameter | Property that returns the parameter controlling the CSink diameter. This property will return Nothing in the case where the HoleType is not kCounterSinkHole.
EndFaces | Property that returns the set of that cap the end of the hole. In the cases where there aren't any such end faces this property will return Nothing.
Extent | Property that returns the object that defines how the extent of the feature is defined. The type of extent object that this property will return can be determined by using the ExtentType property.
ExtentType | Property that returns an enum indicating how the extent of the feature is defined. This indicates the type of object returned by the Extent property.
FlatBottom | Property that is meaningful only if the hole's extent has been defined by distance (blind depth). In that case this property returns a True if a non-zero bottom tip angle has been specified.
HoleCenterPoints | Property that returns the set of points that define the centers of the holes of this feature.
HoleDiameter | Property that returns the parameter controlling the diameter of the hole. This property will return Nothing if the diameter is being read off a value from the HoleTapInfo, when this hole is tapped.
HoleType | Property that returns the type of hole. Can be kDrilledHole, kCounterBoreHole, kCounterSinkHole, or kSpotFaceHole. The hole type can be set by using the SetToCBore, SetToCSink, SetDrilled, and SetToSpotFace methods.
PlacementDefinition | Property that gets and sets the placement type for the hole feature
PlacementType | Property that returns a constant indicating the type of hole placement.
SideFaces | Property that returns a object that provides access to all of the faces created around the perimeter of the feature.
Sketch | Property that returns the Sketch object that contains the points the hole is based on.
SpotFaceDepth | Property that returns the parameter controlling the SpotFace depth. This property will return Nothing in the case where the HoleType is not kSpotFaceHole.
SpotFaceDiameter | Property that returns the parameter controlling the SpotFace diameter. This property will return Nothing in the case where the HoleType is not kSpotFaceHole.
TapInfo | Property that gets and sets the HoleTapInfo or TaperedThreadInfo object associated with the hole.
Tapped | Property that returns the Boolean flag indicating whether the hole is tapped or not.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties


HoleFeature.BottomTipAngle Property

HoleFeature.BottomTipAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Parameter that defines the included angle of the tip of a blind hole, one that has been specified by a distance extent or 'to face' extent . If this is a Flat Bottomed hole then the property will return Nothing.

Visual Basic
Property BottomTipAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.BottomTipAngle Property


HoleFeature.CBoreDepth Property

HoleFeature.CBoreDepth Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter controlling the CBore depth. This property will return Nothing in the case where the HoleType is not kCounterBoreHole.

Visual Basic
Property CBoreDepth() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.CBoreDepth Property


HoleFeature.CBoreDiameter Property

HoleFeature.CBoreDiameter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter controlling the CBore diameter. This property will return Nothing in the case where the HoleType is not kCounterBoreHole.

Visual Basic
Property CBoreDiameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.CBoreDiameter Property


HoleFeature.CSinkAngle Property

HoleFeature.CSinkAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter controlling the CSink angle. This property will return Nothing in the case where the HoleType is not kCounterSinkHole.

Visual Basic
Property CSinkAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.CSinkAngle Property


HoleFeature.CSinkDiameter Property

HoleFeature.CSinkDiameter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter controlling the CSink diameter. This property will return Nothing in the case where the HoleType is not kCounterSinkHole.

Visual Basic
Property CSinkDiameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.CSinkDiameter Property


HoleFeature.EndFaces Property

HoleFeature.EndFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of that cap the end of the hole. In the cases where there aren't any such end faces this property will return Nothing.

Visual Basic
Property EndFaces() As Faces**
See Also

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.EndFaces Property


HoleFeature.Extent Property

HoleFeature.Extent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object that defines how the extent of the feature is defined. The type of extent object that this property will return can be determined by using the ExtentType property.

Visual Basic
Property Extent() As PartFeatureExtent**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.Extent Property


HoleFeature.ExtentType Property

HoleFeature.ExtentType Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an enum indicating how the extent of the feature is defined. This indicates the type of object returned by the Extent property.

Visual Basic
Property ExtentType() As PartFeatureExtentEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.ExtentType Property


HoleFeature.FlatBottom Property

HoleFeature.FlatBottom Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that is meaningful only if the hole's extent has been defined by distance (blind depth). In that case this property returns a True if a non-zero bottom tip angle has been specified.

Visual Basic
Property FlatBottom() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.FlatBottom Property


HoleFeature.HoleCenterPoints Property

HoleFeature.HoleCenterPoints Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of points that define the centers of the holes of this feature.

Visual Basic
Property HoleCenterPoints() As ObjectCollection*
Remarks

This property can also be set with an ObjectCollection of SketchPoints that lie within the Sketch.

You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.HoleCenterPoints Property


HoleFeature.HoleDiameter Property

HoleFeature.HoleDiameter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter controlling the diameter of the hole. This property will return Nothing if the diameter is being read off a value from the HoleTapInfo, when this hole is tapped.

Visual Basic
Property HoleDiameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.HoleDiameter Property


HoleFeature.HoleType Property

HoleFeature.HoleType Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the type of hole. Can be kDrilledHole, kCounterBoreHole, kCounterSinkHole, or kSpotFaceHole. The hole type can be set by using the SetToCBore, SetToCSink, SetDrilled, and SetToSpotFace methods.

Visual Basic
Property HoleType() As HoleTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.HoleType Property


HoleFeature.PlacementDefinition Property

HoleFeature.PlacementDefinition Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the placement type for the hole feature

Visual Basic
Property PlacementDefinition() As HolePlacementDefinition*
Remarks

This can be one of the following objects: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition or PointHolePlacementDefinition. The PlacementType property indicates the type of object that will be returned by this property.

You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.PlacementDefinition Property


HoleFeature.PlacementType Property

HoleFeature.PlacementType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a constant indicating the type of hole placement.

Visual Basic
Property PlacementType() As HolePlacementTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.PlacementType Property


HoleFeature.SideFaces Property

HoleFeature.SideFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a object that provides access to all of the faces created around the perimeter of the feature.

Visual Basic
Property SideFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.SideFaces Property


HoleFeature.Sketch Property

HoleFeature.Sketch Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Sketch object that contains the points the hole is based on.

Visual Basic
Property Sketch() As PlanarSketch**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.Sketch Property


HoleFeature.SpotFaceDepth Property

HoleFeature.SpotFaceDepth Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parameter controlling the SpotFace depth. This property will return Nothing in the case where the HoleType is not kSpotFaceHole.

Visual Basic
Property SpotFaceDepth() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.SpotFaceDepth Property


HoleFeature.SpotFaceDiameter Property

HoleFeature.SpotFaceDiameter Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parameter controlling the SpotFace diameter. This property will return Nothing in the case where the HoleType is not kSpotFaceHole.

Visual Basic
Property SpotFaceDiameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.SpotFaceDiameter Property


HoleFeature.TapInfo Property

HoleFeature.TapInfo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the HoleTapInfo or TaperedThreadInfo object associated with the hole.

Visual Basic
Property TapInfo() As IDispatch*
Remarks

If there is no thread information associated with this hole then the value returned is Nothing.

Setting this property with a valid HoleTapInfo or TaperedThreadInfo automatically changes the Tapped property to True; setting it to Nothing sets the Tapped property to false.

You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.TapInfo Property


HoleFeature.Tapped Property

HoleFeature.Tapped Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Boolean flag indicating whether the hole is tapped or not.

Visual Basic
Property Tapped() As VARIANT_BOOL
Remarks

If True then the hole is tapped and the tap information can be accessed through the TapInfo property, including the hole diameter. If False, the HoleDiameter property controls the diameter of the hole.

You are here: Symbol Reference > Inventor Library > Objects > HoleFeature Interface > HoleFeature Properties > HoleFeature.Tapped Property


HoleFeatureProxy Interface

HoleFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HoleFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::HoleFeature
        Inventor::HoleFeatureProxy
Visual Basic
Public Interface HoleFeatureProxy
Inherits HoleFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatureProxy Interface


HoleFeatureProxy Properties

HoleFeatureProxy Properties
Summary

The properties of the HoleFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatureProxy Interface > HoleFeatureProxy Properties


HoleFeatureProxy.ContainingOccurrence Property

HoleFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatureProxy Interface > HoleFeatureProxy Properties > HoleFeatureProxy.ContainingOccurrence Property


HoleFeatureProxy.NativeObject Property

HoleFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As HoleFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatureProxy Interface > HoleFeatureProxy Properties > HoleFeatureProxy.NativeObject Property


HoleFeatures Interface

HoleFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The HoleFeatures object provides access to all of the objects in a component definition and provides methods to create additional HoleFeature objects.

Class Hierarchy
Inventor::HoleFeatures
Visual Basic
Public Interface HoleFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.HoleFeatures

FlatPatternFeatures.HoleFeatures

PartFeatures.HoleFeatures

Example 1

See HoleFeature for example "Creating through holes - regular and tapped"

Example 2

See HoleFeatures::CreateLinearPlacementDefinition for example "Hole feature linear placement"

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface


HoleFeatures Methods

HoleFeatures Methods
Summary

The methods of the HoleFeatures class are listed here.

Methods
Methods
Name | Description
AddCBoreByDistanceExtent | Method that creates a new counterbore HoleFeature using distance extents. The new HoleFeature is returned.
AddCBoreByThroughAllExtent | Method that creates a new counterbore HoleFeature using 'through all' extents. The new HoleFeature is returned.
AddCBoreByToFaceExtent | Method that creates a new counterbore HoleFeature using 'to face' extents. The new HoleFeature is returned.
AddCSinkByDistanceExtent | Method that creates a new countersink HoleFeature using distance extents. The new HoleFeature is returned.
AddCSinkByThroughAllExtent | Method that creates a new counter sink HoleFeature using 'through all' extents. The new HoleFeature is returned.
AddCSinkByToFaceExtent | Method that creates a new countersink HoleFeature using 'to face' extents. The new HoleFeature is returned.
AddDrilledByDistanceExtent | Method that creates a new drilled HoleFeature using distance extents. The new HoleFeature is returned.
AddDrilledByThroughAllExtent | Method that creates a new drilled HoleFeature using 'through all' extents. The new HoleFeature is returned.
AddDrilledByToFaceExtent | Method that creates a new drilled HoleFeature using 'to face' extents. The new HoleFeature is returned.
AddSpotFaceByDistanceExtent | Method that creates a new spotface HoleFeature using distance extents. The new HoleFeature is returned.
AddSpotFaceByThroughAllExtent | Method that creates a new spotface HoleFeature using 'through all' extents. The new HoleFeature is returned.
AddSpotFaceByToFaceExtent | Method that creates a new spotface HoleFeature using 'to face' extents. The new HoleFeature is returned.
CreateConcentricPlacementDefinition | Method that creates a new ConcentricHolePlacementDefinition object that can be used for defining the placement of Hole features concentric with a circular edge or a cylindrical face.
CreateLinearPlacementDefinition | Method that creates a new LinearHolePlacementDefinition object that can be used for defining the placement of Hole features with respect to two linear edges.
CreatePointPlacementDefinition | Method that creates a new PointHolePlacementDefinition object that can be used for defining the placement of Hole features coincident with a work point and positioned with respect to an axis, edge or work plane.
CreateSketchPlacementDefinition | Method that creates a new SketchHolePlacementDefinition object that can be used for defining the placement of Hole features using sketch points.
CreateTaperedTapInfo | Method that creates a new TaperedThreadInfo object that can be used in creating HoleFeature objects. See the Thread.xls file that is delivered with Inventor for examples of valid input for these arguments. The spreadsheet columns match one for one with these arguments.
CreateTapInfo | Method that creates a new HoleTapInfo object that can be used in creating threads for Hole features. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments.
Item | Property that returns the specified HoleFeature object from the collection. This is the default property of the HoleFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods


HoleFeatures.AddCBoreByDistanceExtent Method

HoleFeatures.AddCBoreByDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new counterbore HoleFeature using distance extents. The new HoleFeature is returned.

Visual Basic
Sub AddCBoreByDistanceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, Depth As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, CBoreDiameter As VARIANT, CBoreDepth As VARIANT, ByRef FlatBottom As [defaultvalue(0xff)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.
Depth | Input Variant that defines the depth of the hole. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
CBoreDiameter | Input Variant that defines the diameter of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
CBoreDepth | Input Variant that defines the depth of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddCBoreByDistanceExtent Method


HoleFeatures.AddCBoreByThroughAllExtent Method

HoleFeatures.AddCBoreByThroughAllExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new counterbore HoleFeature using 'through all' extents. The new HoleFeature is returned.

Visual Basic
Sub AddCBoreByThroughAllExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, CBoreDiameter As VARIANT, CBoreDepth As VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
CBoreDiameter | Input Variant that defines the diameter of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
CBoreDepth | Input Variant that defines the depth of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddCBoreByThroughAllExtent Method


HoleFeatures.AddCBoreByToFaceExtent Method

HoleFeatures.AddCBoreByToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new counterbore HoleFeature using 'to face' extents. The new HoleFeature is returned.

Visual Basic
Sub AddCBoreByToFaceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, CBoreDiameter As VARIANT, CBoreDepth As VARIANT, ByRef FlatBottom As [defaultvalue(-1)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ToFace | Input Object that defines the 'to face.' This can be either a or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the hole.
CBoreDiameter | Input Variant that defines the diameter of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
CBoreDepth | Input Variant that defines the depth of the counterbore. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddCBoreByToFaceExtent Method


HoleFeatures.AddCSinkByDistanceExtent Method

HoleFeatures.AddCSinkByDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new countersink HoleFeature using distance extents. The new HoleFeature is returned.

Visual Basic
Sub AddCSinkByDistanceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, Depth As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, CSinkDiameter As VARIANT, CSinkAngle As VARIANT, ByRef FlatBottom As [defaultvalue(0xff)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Depth | Input Variant that defines the depth of the hole. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
CSinkDiameter | Input Variant that defines the diameter of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or it will default to the current length units of the document.
CSinkAngle | Input Variant that defines the angle of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddCSinkByDistanceExtent Method


HoleFeatures.AddCSinkByThroughAllExtent Method

HoleFeatures.AddCSinkByThroughAllExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new counter sink HoleFeature using 'through all' extents. The new HoleFeature is returned.

Visual Basic
Sub AddCSinkByThroughAllExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, CSinkDiameter As VARIANT, CSinkAngle As VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
CSinkDiameter | Input Variant that defines the diameter of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
CSinkAngle | Input Variant that defines the angle of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddCSinkByThroughAllExtent Method


HoleFeatures.AddCSinkByToFaceExtent Method

HoleFeatures.AddCSinkByToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new countersink HoleFeature using 'to face' extents. The new HoleFeature is returned.

Visual Basic
Sub AddCSinkByToFaceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, CSinkDiameter As VARIANT, CSinkAngle As VARIANT, ByRef FlatBottom As [defaultvalue(-1)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ToFace | Input Object that defines the 'to face.' This can be either a or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the hole.
CSinkDiameter | Input Variant that defines the diameter of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
CSinkAngle | Input Variant that defines the angle of the countersink. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddCSinkByToFaceExtent Method


HoleFeatures.AddDrilledByDistanceExtent Method

HoleFeatures.AddDrilledByDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new drilled HoleFeature using distance extents. The new HoleFeature is returned.

Visual Basic
Sub AddDrilledByDistanceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, Depth As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, ByRef FlatBottom As [defaultvalue(0xff)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Depth | Input Variant that defines the depth of the hole. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddDrilledByDistanceExtent Method


HoleFeatures.AddDrilledByThroughAllExtent Method

HoleFeatures.AddDrilledByThroughAllExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new drilled HoleFeature using 'through all' extents. The new HoleFeature is returned.

Visual Basic
Sub AddDrilledByThroughAllExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
See Also

Hole Feature - Through holes (RegularAndTapped) sample

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddDrilledByThroughAllExtent Method


HoleFeatures.AddDrilledByToFaceExtent Method

HoleFeatures.AddDrilledByToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new drilled HoleFeature using 'to face' extents. The new HoleFeature is returned.

Visual Basic
Sub AddDrilledByToFaceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, ByRef FlatBottom As [defaultvalue(-1)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ToFace | Input Object that defines the 'to face.' This can be either a or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the entire hole diameter.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddDrilledByToFaceExtent Method


HoleFeatures.AddSpotFaceByDistanceExtent Method

HoleFeatures.AddSpotFaceByDistanceExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new spotface HoleFeature using distance extents. The new HoleFeature is returned.

Visual Basic
Sub AddSpotFaceByDistanceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, Depth As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, SpotFaceDiameter As VARIANT, SpotFaceDepth As VARIANT, ByRef FlatBottom As [defaultvalue(0xff)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Input Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Input Variant that defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter.
Depth | Input Variant that defines the depth of the hole. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
SpotFaceDiameter | Input Variant that defines the diameter of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
SpotFaceDepth | Input Variant that defines the depth of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddSpotFaceByDistanceExtent Method


HoleFeatures.AddSpotFaceByThroughAllExtent Method

HoleFeatures.AddSpotFaceByThroughAllExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new spotface HoleFeature using 'through all' extents. The new HoleFeature is returned.

Visual Basic
Sub AddSpotFaceByThroughAllExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, SpotFaceDiameter As VARIANT, SpotFaceDepth As VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Input Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Input Variant that defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositive or kNegative. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
SpotFaceDiameter | Input Variant that defines the diameter of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
SpotFaceDepth | Input Variant that defines the depth of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddSpotFaceByThroughAllExtent Method


HoleFeatures.AddSpotFaceByToFaceExtent Method

HoleFeatures.AddSpotFaceByToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new spotface HoleFeature using 'to face' extents. The new HoleFeature is returned.

Visual Basic
Sub AddSpotFaceByToFaceExtent(PlacementDefinition As IDispatch, DiameterOrTapInfo As VARIANT, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, SpotFaceDiameter As VARIANT, SpotFaceDepth As VARIANT, ByRef FlatBottom As [defaultvalue(-1)] VARIANT_BOOL, ByRef BottomTipAngle As [optional] VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
PlacementDefinition | Input Object that defines the centerpoint(s) of the hole feature. This object can be one of the following four objects that derive from the HolePlacementDefinition object: SketchHolePlacementDefinition, LinearHolePlacementDefinition, ConcentricHolePlacementDefinition, PointHolePlacementDefinition. These objects can be created using methods provided on this HoleFeatures object. This argument also supports an ObjectCollection of SketchPoints for compatibility with the older version of this method.
DiameterOrTapInfo | Input Variant that defines either the diameter of the hole or the tap information (using a HoleTapInfo or a TaperedThreadInfo object). In the case of a tapped hole, the tap information defines the diameter of the hole. When the diameter is supplied, this can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or it will default to the current length units of the document.
ToFace | Input Object that defines the 'to face'. This can be either a Face or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the hole.
SpotFaceDiameter | Input Variant that defines the diameter of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
SpotFaceDepth | Input Variant that defines the depth of the spotface. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
FlatBottom | Optional input Boolean that indicates that the bottom of the hole should be flat or pointed. True indicates a flat hole. If False then the BottomTipAngle argument needs to be provided to specify the angle. The default value is True.
BottomTipAngle | Optional input Variant that defines the angle of the tip at the bottom of a hole. This argument is only used when the FlatBottom argument is False. If FlatBottom is false and this argument is not supplied a default value of 118 degrees is assigned. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.AddSpotFaceByToFaceExtent Method


HoleFeatures.CreateConcentricPlacementDefinition Method

HoleFeatures.CreateConcentricPlacementDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new ConcentricHolePlacementDefinition object that can be used for defining the placement of Hole features concentric with a circular edge or a cylindrical face.

Visual Basic
Sub CreateConcentricPlacementDefinition(Plane As IDispatch, ConcentricReference As IDispatch, Result As [out, retval] ConcentricHolePlacementDefinition*)
Parameters
Parameters | Description
Plane | Object that indicates the plane on which to place the hole feature. This can be either a Face or a WorkPlane object. An error will occur if the input Face object is non-planar.
ConcentricReference | Object that specifies the reference for the placement of the hole center. This can either be a circular Edge or a cylindrical Face. If a circular edge is specified, it must lie on a plane parallel to the plane of the input Plane object. If a cylindrical face is specified, its axis must be perpendicular to the plane of the input Plane object.
Example

See HoleFeatures::CreateLinearPlacementDefinition for example "CreateLinearPlacementDefinition Method"

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.CreateConcentricPlacementDefinition Method


HoleFeatures.CreateLinearPlacementDefinition Method

HoleFeatures.CreateLinearPlacementDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new LinearHolePlacementDefinition object that can be used for defining the placement of Hole features with respect to two linear edges.

Visual Basic
Sub CreateLinearPlacementDefinition(Plane As IDispatch, ReferenceEntityOne As IDispatch, DistanceOne As VARIANT, ReferenceEntityTwo As IDispatch, DistanceTwo As VARIANT, BiasPoint As Point, Result As [out, retval] LinearHolePlacementDefinition*)
Parameters
Parameters | Description
Plane | Object that indicates the plane on which to place the hole feature. Valid inputs are Face and WorkPlane objects. The input Face object needs to be planar else an error will occur.
ReferenceEntityOne | Object that specifies the first entity referenced for dimensioning the placement of the hole. The only valid input is an Edge object and it needs to be linear. An error will occur if the entity is perpendicular to the plane of the input face.
DistanceOne | Specifies the distance of the hole center from the first reference entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ReferenceEntityTwo | Object that specifies the second entity referenced for dimensioning the placement of the hole. The only valid input is an Edge object and it needs to be linear. An error will occur if the entity is perpendicular to the plane of the input face. An error will also occur if the entity is parallel to the first reference entity.
DistanceTwo | Specifies the distance of the hole center from the second reference entity. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
BiasPoint | Object that specifies a point to be used as a bias point. This can simply be the location where the hole needs to be placed and is equivalent to the pick point when creating a hole feature with the linear placement option through the user interface. The true location is decided by the DistanceOne and DistanceTwo arguments. The point must lie on the infinite plane defined by the Plane argument input, else an error will occur.
Example

"Hole feature linear placement"

This sample demonstrates the creation of a hole feature using the linear placement type.

Public Sub HoleFeatureLinearPlacement()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create a square on the sketch.
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                        oTransGeom.CreatePoint2d(0, 0), _
                                        oTransGeom.CreatePoint2d(6, 6))

    ' Create the profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extrusion.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent(oProfile, _
                        "2 cm", kNegativeExtentDirection, kJoinOperation)

    ' Get the start face of the extrude.
    Dim oFace As Face
    Set oFace = oExtrude.StartFaces(1)

    ' Get two adjacent edges on the start face.
    Dim oEdge1, oEdge2 As Edge
    Set oEdge1 = oFace.Edges(1)
    Set oEdge2 = oFace.Edges(2)

    ' Create a bias point for hole placement to place it at
    ' the expected location. This is the model point
    ' corresponding to the center of the square in the sketch.
    Dim oBiasPoint As Point
    Set oBiasPoint = oSketch.SketchToModelSpace(oTransGeom.CreatePoint2d(1.5, 1.5))

    ' Create the hole feature placement definition.
    Dim oLinearPlacementDef As LinearHolePlacementDefinition
    Set oLinearPlacementDef = oCompDef.Features.HoleFeatures.CreateLinearPlacementDefinition _
    (oFace, oEdge1, "2 cm", oEdge2, "2 cm", oBiasPoint)

    ' Create the hole feature.
    Call oCompDef.Features.HoleFeatures.AddDrilledByThroughAllExtent( _
                            oLinearPlacementDef, "1 cm", kPositiveExtentDirection)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.CreateLinearPlacementDefinition Method


HoleFeatures.CreatePointPlacementDefinition Method

HoleFeatures.CreatePointPlacementDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new PointHolePlacementDefinition object that can be used for defining the placement of Hole features coincident with a work point and positioned with respect to an axis, edge or work plane.

Visual Basic
Sub CreatePointPlacementDefinition(Point As IDispatch, Direction As IDispatch, Result As [out, retval] PointHolePlacementDefinition*)
Parameters
Parameters | Description
Point | Object that specifies the point to set as the hole center. The only valid input is a WorkPoint.
Direction | Object that specifies the direction of the hole axis. This can be a planar Face object or a WorkPlane object with which the axis of the hole is perpendicular, or an Edge or WorkAxis object with which the axis of the hole is parallel.
Example

See HoleFeatures::CreateLinearPlacementDefinition for example "CreateLinearPlacementDefinition Method"

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.CreatePointPlacementDefinition Method


HoleFeatures.CreateSketchPlacementDefinition Method

HoleFeatures.CreateSketchPlacementDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new SketchHolePlacementDefinition object that can be used for defining the placement of Hole features using sketch points.

Visual Basic
Sub CreateSketchPlacementDefinition(HoleCenterPoints As ObjectCollection, Result As [out, retval] SketchHolePlacementDefinition*)
Parameters
Parameters | Description
HoleCenterPoints | ObjectCollection object that contains the SketchPoint objects that will be used to define the centers of the holes. All of the SketchPoint objects used as input must be within the same sketch.
Example

See HoleFeatures::CreateLinearPlacementDefinition for example "CreateLinearPlacementDefinition Method"

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.CreateSketchPlacementDefinition Method


HoleFeatures.CreateTaperedTapInfo Method

HoleFeatures.CreateTaperedTapInfo Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new TaperedThreadInfo object that can be used in creating HoleFeature objects. See the Thread.xls file that is delivered with Inventor for examples of valid input for these arguments. The spreadsheet columns match one for one with these arguments.

Visual Basic
Sub CreateTaperedTapInfo(RightHanded As VARIANT_BOOL, ThreadType As String, ThreadDesignation As String, Result As [out, retval] TaperedThreadInfo*)
Parameters
Parameters | Description
RightHanded | Input Boolean that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.
ThreadType | Input String that specifies the thread type. The thread type is the name of the sheet in the Thread.xls file that is used by the Thread command to define valid thread definitions.
ThreadDesignation | Input String that contains the thread designation. This is input as the full thread designation that will be used in a drawing for the thread callout. The nominal size information is extracted from the designation.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.CreateTaperedTapInfo Method


HoleFeatures.CreateTapInfo Method

HoleFeatures.CreateTapInfo Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new HoleTapInfo object that can be used in creating threads for Hole features. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments.

Visual Basic
Sub CreateTapInfo(RightHanded As VARIANT_BOOL, ThreadType As String, ThreadDesignation As String, Class As String, FullTapDepth As VARIANT_BOOL, ByRef ThreadDepth As [optional] VARIANT, Result As [out, retval] HoleTapInfo*)
Parameters
Parameters | Description
RightHanded | Input Boolean that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.
ThreadType | Input String that specifies the sheet in the Thread.xls that this thread information should be validated within. Each sheet within the Excel document is typically used for different thread types. The string is the name of the sheet. For example "ANSI Unified Screw Threads" or "ANSI Metric M Profile" are valid for English versions of Autodesk Inventor.
ThreadDesignation | Input String that contains the thread designation. This is input as the full thread designation that will be used in a drawing for the thread callout. The nominal size and pitch information are extracted from the designation. For example valid inch thread designations are '10-24 UNC' and '7/16-20 UNF'. Examples of valid metric designations are 'M16x1.5' and 'M55x1.5'.
Class | Input String that defines the thread class. For example a valid class for an inch internal thread is 2B. A valid class for a metric external thread is 6g.
FullTapDepth | Input Boolean that indicates if the thread extends the full length of the hole or not. A value of True indicates the thread goes the full extent of the hole.
ThreadDepth | Optional input Variant that defines the thread depth. This is only applicable when the FullDepth argument is False, otherwise this argument is ignored. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
See Also

Hole Feature - Through holes (RegularAndTapped) sample

You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.CreateTapInfo Method


HoleFeatures.Item Method

HoleFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified HoleFeature object from the collection. This is the default property of the HoleFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] HoleFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Methods > HoleFeatures.Item Method


HoleFeatures Properties

HoleFeatures Properties
Summary

The properties of the HoleFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Properties


HoleFeatures.Application Property

HoleFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Properties > HoleFeatures.Application Property


HoleFeatures.Count Property

HoleFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Properties > HoleFeatures.Count Property


HoleFeatures.Type Property

HoleFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleFeatures Interface > HoleFeatures Properties > HoleFeatures.Type Property


HolePlacementDefinition Interface

HolePlacementDefinition Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HolePlacementDefinition object is the base class that defines the placement method for hole features.

Class Hierarchy
Inventor::HolePlacementDefinition
    Inventor::ConcentricHolePlacementDefinition
    Inventor::LinearHolePlacementDefinition
    Inventor::PointHolePlacementDefinition
    Inventor::SketchHolePlacementDefinition
Visual Basic
Public Interface HolePlacementDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleFeature.PlacementDefinition

You are here: Symbol Reference > Inventor Library > Objects > HolePlacementDefinition Interface


HolePlacementDefinition Properties

HolePlacementDefinition Properties
Summary

The properties of the HolePlacementDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent PartFeature of the definition. This property returns Nothing in the case where the definition object is created using one of the Create methods on the HoleFeatures object.
Type | Property that returns kHolePlacementDefinitionObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HolePlacementDefinition Interface > HolePlacementDefinition Properties


HolePlacementDefinition.Application Property

HolePlacementDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HolePlacementDefinition Interface > HolePlacementDefinition Properties > HolePlacementDefinition.Application Property


HolePlacementDefinition.Parent Property

HolePlacementDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent PartFeature of the definition. This property returns Nothing in the case where the definition object is created using one of the Create methods on the HoleFeatures object.

Visual Basic
Property Parent() As HoleFeature**
You are here: Symbol Reference > Inventor Library > Objects > HolePlacementDefinition Interface > HolePlacementDefinition Properties > HolePlacementDefinition.Parent Property


HolePlacementDefinition.Type Property

HolePlacementDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns kHolePlacementDefinitionObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HolePlacementDefinition Interface > HolePlacementDefinition Properties > HolePlacementDefinition.Type Property


HoleTable Interface

HoleTable Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

A hole table contains information for some or all holes in a drawing view. A hole tag is associated with each hole and a corresponding row in the table. If an existing hole is changed, the hole table is updated when the drawing updates.

Class Hierarchy
Inventor::HoleTable
Visual Basic
Public Interface HoleTable
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTableCell.Parent

HoleTableColumn.Parent

HoleTableRow.Parent

HoleTables.Add

HoleTables.AddByFeatureType

HoleTables.AddSelected

HoleTables.Item

You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface


HoleTable Methods

HoleTable Methods
Summary

The methods of the HoleTable class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the HoleTable.
Export | Method that saves the custom table to an external file.
GetReferenceKey | Method that generates and returns the reference key for this entity.
MatchCustomHoles | Method that specifies two or more custom holes (designated with center marks) to be the same.
ShowTags | Property that indicates whether to show or hide all the hole tags associated with this table.
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Methods


HoleTable.Delete Method

HoleTable.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the HoleTable.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Methods > HoleTable.Delete Method


HoleTable.Export Method

HoleTable.Export Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that saves the custom table to an external file.

Visual Basic
Sub Export(FileName As String, FileFormat As FileFormatEnum, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
FileName | Input string that specifies the file name to export the table to.
Options | Optional input NameValueMap object that specifies additional options for export. See Remarks for valid inputs:
Remarks

Valid inputs for Options parameter:

Name | Value type | Valid for Export formats
TableName | String | kMicrosoftExcel, kMicrosoftAccess
ExportedColumns | String containing semicolon separated column titles | All
IncludeTitle | Boolean | kMicrosoftExcel, kTextFileCommaDelimited, kTextFileTabDelimited, kUnicodeTextFileCommaDelimited, kUnicodeTextFileTabDelimited
StartingCell | String | kMicrosoftExcel
Template | String | kMicrosoftExcel
AutoFitColumnWidth | Boolean | kMicrosoftExcel
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Methods > HoleTable.Export Method


HoleTable.GetReferenceKey Method

HoleTable.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Methods > HoleTable.GetReferenceKey Method


HoleTable.MatchCustomHoles Method

HoleTable.MatchCustomHoles Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that specifies two or more custom holes (designated with center marks) to be the same.

Visual Basic
Sub MatchCustomHoles(HoleTags As ObjectCollection)
Parameters
Parameters | Description
HoleTags | Input ObjectCollection containing HoleTag objects that represent center marks. All the hole tags are matched to the first hole tag in the collection. The method returns an error if any of the input hole tags do not represent a center mark.
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Methods > HoleTable.MatchCustomHoles Method


HoleTable.ShowTags Method

HoleTable.ShowTags Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates whether to show or hide all the hole tags associated with this table.

Visual Basic
Sub ShowTags(Value As VARIANT_BOOL)
Parameters
Parameters | Description
Value | When set to True, show all the hole tags associated with this table.
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Methods > HoleTable.ShowTags Method


HoleTable Properties

HoleTable Properties
Summary

The properties of the HoleTable class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ArrangeByPosition | Property that gets and sets whether to tags holes relative to their position on the selected view or by their relative size.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
DataTextStyle | Property that gets and sets the text style used for the contents of the table.
DeleteTagsOnRollup | Property that gets and sets whether to delete tags except for the first in a series of hole tags when the row merge type is kRollupRowMerge.
GroupHoleTypes | Property that gets and sets whether to group and tag holes by type.
HeadingPlacement | Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
HoleTableColumns | Property that returns the HoleTableColumns collection object.
HoleTableRows | Property that returns the HoleTableRows collection object.
HoleTableType | Property that returns the type of the hole table.
IncludeCentermarks | Property that gets and sets whether to include center marks. Center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeCircularCuts | Property that gets and sets whether to include extruded cuts. Circular cuts are recognized only as drilled thru or drilled blind holes, and do not include mid-plane extrusions. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeCounterBoreHoleFeatures | Property that gets and sets whether to include counterbored hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeCounterSinkHoleFeatures | Property that gets and sets whether to include countersunk hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeDrilledHoleFeatures | Property that gets and sets whether to include drilled hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeHoleFeatures | Property that gets and sets whether to include hole features. Applies only to view based hole tables.
IncludeRecoveredPunchCenters | Property that gets and sets whether to include recovered punch center marks. Punch center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeThreadedHoleFeatures | Property that gets and sets whether to include threaded hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
Layer | Property that gets and sets the layer associated with this object.
Parent | Property that returns the parent object of this HoleTable.
ParentView | Property that returns the drawing view that this table is associated with.
Position | Property that gets and sets the position of the top left corner of the hole table on the sheet.
PreserveTagging | Property that gets and sets whether to preserve the hole tags assigned when the table is created. Tagging is preserved only with respect to changes to the model, such as when you add, delete, suppress or unsuppress hole features. Manual changes to the hole table, such as when you resort, change tag order, and filter hole types, are not affected.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
ReformatOnCustomHoleMatch | Property that gets and sets whether to re-index the hole tags and resort contents when a 'Match Custom Hole' operation is done. Setting this property returns an error if the RowMergeType is kRollupRowMerge.
RowMergeType | Property that gets and sets the row merge option for the hole table. Valid values are kNoRowMerge, kRollupRowMerge and kCombineNotesRowMerge.
SecondaryTagModifierOnRollup | Property that gets and sets whether to include a secondary numeric tag when the row merge type is kRollupRowMerge.
SequentialNumbering | Property that gets and sets whether to replace the alphanumeric hole tags with sequential numbering of the holes in the hole table. Setting this property returns an error if the RowMergeType is kRollupRowMerge.
Style | Gets/Sets the associated HoleTableStyle object.
Title | Property that gets and sets the title of the HoleTable.
TitleTextStyle | Property that gets and sets the text style used for the title of the table.
Type | Property returning kHoleTableObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties


HoleTable.Application Property

HoleTable.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Application Property


HoleTable.ArrangeByPosition Property

HoleTable.ArrangeByPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to tags holes relative to their position on the selected view or by their relative size.

Visual Basic
Property ArrangeByPosition() As VARIANT_BOOL
Remarks

Position is arranged with YDIM as the primary key and XDIM as secondary key. If YDIM and XDIM are equal, hole size is the tertiary sorting key, smallest to largest. If this property is set to False, holes are arranged by size in order by size (smallest to largest). Size refers to the drill diameter parameter for drilled, counterbored, and countersunk holes. The tap drill diameter is used for threaded holes. If holes are of equal size, holes are sorted by position.

You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.ArrangeByPosition Property


HoleTable.AttributeSets Property

HoleTable.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.AttributeSets Property


HoleTable.ColumnHeaderTextStyle Property

HoleTable.ColumnHeaderTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.ColumnHeaderTextStyle Property


HoleTable.DataTextStyle Property

HoleTable.DataTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.DataTextStyle Property


HoleTable.DeleteTagsOnRollup Property

HoleTable.DeleteTagsOnRollup Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to delete tags except for the first in a series of hole tags when the row merge type is kRollupRowMerge.

Visual Basic
Property DeleteTagsOnRollup() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.DeleteTagsOnRollup Property


HoleTable.GroupHoleTypes Property

HoleTable.GroupHoleTypes Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to group and tag holes by type.

Visual Basic
Property GroupHoleTypes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.GroupHoleTypes Property


HoleTable.HeadingPlacement Property

HoleTable.HeadingPlacement Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.HeadingPlacement Property


HoleTable.HoleTableColumns Property

HoleTable.HoleTableColumns Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the HoleTableColumns collection object.

Visual Basic
Property HoleTableColumns() As HoleTableColumns**
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.HoleTableColumns Property


HoleTable.HoleTableRows Property

HoleTable.HoleTableRows Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the HoleTableRows collection object.

Visual Basic
Property HoleTableRows() As HoleTableRows**
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.HoleTableRows Property


HoleTable.HoleTableType Property

HoleTable.HoleTableType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the type of the hole table.

Visual Basic
Property HoleTableType() As HoleTableTypeEnum*
Remarks

Possible return values are kViewTypeHoleTable, kSelectionTypeHoleTable and kFeatureTypeHoleTable.

You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.HoleTableType Property


HoleTable.IncludeCentermarks Property

HoleTable.IncludeCentermarks Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include center marks. Center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCentermarks() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeCentermarks Property


HoleTable.IncludeCircularCuts Property

HoleTable.IncludeCircularCuts Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include extruded cuts. Circular cuts are recognized only as drilled thru or drilled blind holes, and do not include mid-plane extrusions. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCircularCuts() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeCircularCuts Property


HoleTable.IncludeCounterBoreHoleFeatures Property

HoleTable.IncludeCounterBoreHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include counterbored hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCounterBoreHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeCounterBoreHoleFeatures Property


HoleTable.IncludeCounterSinkHoleFeatures Property

HoleTable.IncludeCounterSinkHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include countersunk hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCounterSinkHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeCounterSinkHoleFeatures Property


HoleTable.IncludeDrilledHoleFeatures Property

HoleTable.IncludeDrilledHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include drilled hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeDrilledHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeDrilledHoleFeatures Property


HoleTable.IncludeHoleFeatures Property

HoleTable.IncludeHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include hole features. Applies only to view based hole tables.

Visual Basic
Property IncludeHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeHoleFeatures Property


HoleTable.IncludeRecoveredPunchCenters Property

HoleTable.IncludeRecoveredPunchCenters Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include recovered punch center marks. Punch center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeRecoveredPunchCenters() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeRecoveredPunchCenters Property


HoleTable.IncludeThreadedHoleFeatures Property

HoleTable.IncludeThreadedHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include threaded hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeThreadedHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.IncludeThreadedHoleFeatures Property


HoleTable.Layer Property

HoleTable.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Layer Property


HoleTable.Parent Property

HoleTable.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent object of this HoleTable.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Parent Property


HoleTable.ParentView Property

HoleTable.ParentView Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the drawing view that this table is associated with.

Visual Basic
Property ParentView() As DrawingView**
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.ParentView Property


HoleTable.Position Property

HoleTable.Position Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the position of the top left corner of the hole table on the sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Position Property


HoleTable.PreserveTagging Property

HoleTable.PreserveTagging Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to preserve the hole tags assigned when the table is created. Tagging is preserved only with respect to changes to the model, such as when you add, delete, suppress or unsuppress hole features. Manual changes to the hole table, such as when you resort, change tag order, and filter hole types, are not affected.

Visual Basic
Property PreserveTagging() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.PreserveTagging Property


HoleTable.RangeBox Property

HoleTable.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d **
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.RangeBox Property


HoleTable.ReformatOnCustomHoleMatch Property

HoleTable.ReformatOnCustomHoleMatch Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to re-index the hole tags and resort contents when a 'Match Custom Hole' operation is done. Setting this property returns an error if the RowMergeType is kRollupRowMerge.

Visual Basic
Property ReformatOnCustomHoleMatch() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.ReformatOnCustomHoleMatch Property


HoleTable.RowMergeType Property

HoleTable.RowMergeType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the row merge option for the hole table. Valid values are kNoRowMerge, kRollupRowMerge and kCombineNotesRowMerge.

Visual Basic
Property RowMergeType() As RowMergeTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.RowMergeType Property


HoleTable.SecondaryTagModifierOnRollup Property

HoleTable.SecondaryTagModifierOnRollup Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include a secondary numeric tag when the row merge type is kRollupRowMerge.

Visual Basic
Property SecondaryTagModifierOnRollup() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.SecondaryTagModifierOnRollup Property


HoleTable.SequentialNumbering Property

HoleTable.SequentialNumbering Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to replace the alphanumeric hole tags with sequential numbering of the holes in the hole table. Setting this property returns an error if the RowMergeType is kRollupRowMerge.

Visual Basic
Property SequentialNumbering() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.SequentialNumbering Property


HoleTable.Style Property

HoleTable.Style Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets/Sets the associated HoleTableStyle object.

Visual Basic
Property Style() As HoleTableStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Style Property


HoleTable.Title Property

HoleTable.Title Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the title of the HoleTable.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Title Property


HoleTable.TitleTextStyle Property

HoleTable.TitleTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the title of the table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.TitleTextStyle Property


HoleTable.Type Property

HoleTable.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTableObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTable Interface > HoleTable Properties > HoleTable.Type Property


HoleTableCell Interface

HoleTableCell Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTableCell object represents an individual cell in the hole table.

Class Hierarchy
Inventor::HoleTableCell
Visual Basic
Public Interface HoleTableCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTableRow.Item

You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface


HoleTableCell Properties

HoleTableCell Properties
Summary

The properties of the HoleTableCell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
Parent | Property that returns the parent HoleTable object.
StackedTextPosition | Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.
Text | Property that gets and sets the text of the cell.
Type | Property returning kHoleTableCellObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties


HoleTableCell.Application Property

HoleTableCell.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties > HoleTableCell.Application Property


HoleTableCell.FormattedText Property

HoleTableCell.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties > HoleTableCell.FormattedText Property


HoleTableCell.Parent Property

HoleTableCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent HoleTable object.

Visual Basic
Property Parent() As HoleTable**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties > HoleTableCell.Parent Property


HoleTableCell.StackedTextPosition Property

HoleTableCell.StackedTextPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.

Visual Basic
Property StackedTextPosition() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties > HoleTableCell.StackedTextPosition Property


HoleTableCell.Text Property

HoleTableCell.Text Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the text of the cell.

Visual Basic
Property Text() As String
You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties > HoleTableCell.Text Property


HoleTableCell.Type Property

HoleTableCell.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTableCellObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableCell Interface > HoleTableCell Properties > HoleTableCell.Type Property


HoleTableColumn Interface

HoleTableColumn Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTableColumn object defines a column within the hole table, including the column width.

Class Hierarchy
Inventor::HoleTableColumn
Visual Basic
Public Interface HoleTableColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTableColumns.Add

HoleTableColumns.Item

You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface


HoleTableColumn Methods

HoleTableColumn Methods
Summary

The methods of the HoleTableColumn class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the column from the table.
Reposition | Method that repositions the column within the table.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Methods


HoleTableColumn.Delete Method

HoleTableColumn.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes the column from the table.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Methods > HoleTableColumn.Delete Method


HoleTableColumn.Reposition Method

HoleTableColumn.Reposition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that repositions the column within the table.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing column next to which the column will be inserted. The valid range of values is 0 to the number of existing columns in the table. The position remains unchanged if the index of the column being moved is specified. A value of 0 will put the column at the end. If not specified, a default value of 0 is used, indicating that the column will be moved to the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used indicating that the column will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Methods > HoleTableColumn.Reposition Method


HoleTableColumn Properties

HoleTableColumn Properties
Summary

The properties of the HoleTableColumn class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CustomPropertyName | Property that returns the name of the custom property associated with this column.
Parent | Property that returns the parent HoleTable.
PropertyType | Property that returns the property type associated with this column.
Title | Property that gets and sets the title of the column.
Type | Property returning kHoleTableColumnObject indicating this objects type.
Width | Property that gets and sets the width of the column.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties


HoleTableColumn.Application Property

HoleTableColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.Application Property


HoleTableColumn.CustomPropertyName Property

HoleTableColumn.CustomPropertyName Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the name of the custom property associated with this column.

Visual Basic
Property CustomPropertyName() As BSTR*
Remarks

This property returns a null string if the PropertyType property does not return a value of kCustomHoleProperty.

You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.CustomPropertyName Property


HoleTableColumn.Parent Property

HoleTableColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent HoleTable.

Visual Basic
Property Parent() As HoleTable**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.Parent Property


HoleTableColumn.PropertyType Property

HoleTableColumn.PropertyType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the property type associated with this column.

Visual Basic
Property PropertyType() As HolePropertyEnum*
Remarks

If this property returns kCustomTableProperty, use the CustomPropertyName property to get the name of the custom property.

You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.PropertyType Property


HoleTableColumn.Title Property

HoleTableColumn.Title Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the title of the column.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.Title Property


HoleTableColumn.Type Property

HoleTableColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTableColumnObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.Type Property


HoleTableColumn.Width Property

HoleTableColumn.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the width of the column.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumn Interface > HoleTableColumn Properties > HoleTableColumn.Width Property


HoleTableColumns Interface

HoleTableColumns Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTableColumns collection object provides access to the existing collection of HoleTableColumn objects.

Class Hierarchy
Inventor::HoleTableColumns
Visual Basic
Public Interface HoleTableColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTable.HoleTableColumns

You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface


HoleTableColumns Methods

HoleTableColumns Methods
Summary

The methods of the HoleTableColumns class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new HoleTableColumn based on a property. The newly created HoleTableColumn is returned.
Item | Property that returns the specified Column object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Methods


HoleTableColumns.Add Method

HoleTableColumns.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new HoleTableColumn based on a property. The newly created HoleTableColumn is returned.

Visual Basic
Sub Add(PropertyType As HolePropertyEnum, ByRef CustomPropertyName As [defaultvalue("")] BSTR, ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] HoleTableColumn*)
Parameters
Parameters | Description
PropertyType | Input HolePropertyEnum that specifies the property type to associate with the column. If kCustomHoleProperty is specified, the CustomPropertyName argument is required.
CustomPropertyName | Optional input String that specifies the name of the custom property to associate with the column. This argument must be specified if the PropertyType is specified to be kCustomHoleProperty, else the method returns an error.
TargetIndex | Optional input Long that specifies the existing column next to which the new column will be inserted. The valid range of values is 0 to the number of existing columns in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the column will be added at the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Methods > HoleTableColumns.Add Method


HoleTableColumns.Item Method

HoleTableColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Column object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] HoleTableColumn*)
Parameters
Parameters | Description
index | Input Variant value that specifies the HoleTableColumn to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string that corresponds to the title of a column header. If an out of range index or a name of a non-existent HoleTableColumn is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Methods > HoleTableColumns.Item Method


HoleTableColumns Properties

HoleTableColumns Properties
Summary

The properties of the HoleTableColumns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kHoleTableColumnsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Properties


HoleTableColumns.Application Property

HoleTableColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Properties > HoleTableColumns.Application Property


HoleTableColumns.Count Property

HoleTableColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Properties > HoleTableColumns.Count Property


HoleTableColumns.Type Property

HoleTableColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTableColumnsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableColumns Interface > HoleTableColumns Properties > HoleTableColumns.Type Property


HoleTableRow Interface

HoleTableRow Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTableRow object defines a row within the hole table, including the row height.

Class Hierarchy
Inventor::HoleTableRow
Visual Basic
Public Interface HoleTableRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTableRows.Add

HoleTableRows.Item

HoleTag.Parent

You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface


HoleTableRow Methods

HoleTableRow Methods
Summary

The methods of the HoleTableRow class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the HoleTableRow and the associated hole tag.
Item | Property that returns the specified Cell object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Methods


HoleTableRow.Delete Method

HoleTableRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the HoleTableRow and the associated hole tag.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Methods > HoleTableRow.Delete Method


HoleTableRow.Item Method

HoleTableRow.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Cell object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] HoleTableCell*)
Parameters
Parameters | Description
index | Input Variant value that specifies the HoleTableCell to return. This can be either a numeric value indicating the index of the item in the collection, a string indicating the title of a column header, or a HoleTableColumn object. If an out of range index, a non-existent column header title, or an invalid HoleTableColumn object is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Methods > HoleTableRow.Item Method


HoleTableRow Properties

HoleTableRow Properties
Summary

The properties of the HoleTableRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Height | Property that gets and sets the height of the row.
HoleTag | Property that returns the hole tag associated with this hole in the table.
Parent | Property that returns the parent HoleTable.
ReferencedHole | Property that returns the hole associated with this row.
Type | Property returning kHoleTableRowObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties


HoleTableRow.Application Property

HoleTableRow.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.Application Property


HoleTableRow.Count Property

HoleTableRow.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.Count Property


HoleTableRow.Height Property

HoleTableRow.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the height of the row.

Visual Basic
Property Height() As double
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.Height Property


HoleTableRow.HoleTag Property

HoleTableRow.HoleTag Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the hole tag associated with this hole in the table.

Visual Basic
Property HoleTag() As HoleTag**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.HoleTag Property


HoleTableRow.Parent Property

HoleTableRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent HoleTable.

Visual Basic
Property Parent() As HoleTable**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.Parent Property


HoleTableRow.ReferencedHole Property

HoleTableRow.ReferencedHole Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the hole associated with this row.

Visual Basic
Property ReferencedHole() As IDispatch**
Remarks

This property can either return a DrawingCurve object (i.e. the geometric entity of the hole being referenced) or a Centermark object.

You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.ReferencedHole Property


HoleTableRow.Type Property

HoleTableRow.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTableRowObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRow Interface > HoleTableRow Properties > HoleTableRow.Type Property


HoleTableRows Interface

HoleTableRows Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTableRows collection object provides access to the existing collection of HoleTableRow objects.

Class Hierarchy
Inventor::HoleTableRows
Visual Basic
Public Interface HoleTableRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTable.HoleTableRows

You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface


HoleTableRows Methods

HoleTableRows Methods
Summary

The methods of the HoleTableRows class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a row to the table.
Item | Property that returns the specified row object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Methods


HoleTableRows.Add Method

HoleTableRows.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that adds a row to the table.

Visual Basic
Sub Add(Hole As IDispatch, Result As [out, retval] HoleTableRow*)
Parameters
Parameters | Description
Hole | Input object that specifies the hole to be added to the table. This can either be a DrawingCurve object (which represents the geometry of the hole to be added) or a Centermark object. The method returns an error if the input DrawingCurve does not represent a hole. For view based and feature type based hole tables, the method returns an error if the input hole feature type is not included in the hole table.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Methods > HoleTableRows.Add Method


HoleTableRows.Item Method

HoleTableRows.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified row object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] HoleTableRow*)
Parameters
Parameters | Description
index | Input Long value that specifies the HoleTableRow to return. This is a numeric value indicating the index of the item in the collection. If an out of range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Methods > HoleTableRows.Item Method


HoleTableRows Properties

HoleTableRows Properties
Summary

The properties of the HoleTableRows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kHoleTableRowsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Properties


HoleTableRows.Application Property

HoleTableRows.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Properties > HoleTableRows.Application Property


HoleTableRows.Count Property

HoleTableRows.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Properties > HoleTableRows.Count Property


HoleTableRows.Type Property

HoleTableRows.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTableRowsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableRows Interface > HoleTableRows Properties > HoleTableRows.Type Property


HoleTables Interface

HoleTables Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTables collection object represents all the hole tables on a sheet.

Class Hierarchy
Inventor::HoleTables
Visual Basic
Public Interface HoleTables
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.HoleTables

You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface


HoleTables Methods

HoleTables Methods
Summary

The methods of the HoleTables class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new hole table by including all holes in the input drawing view. Only those feature types specified in the input (or the default) hole table style will be included. The newly created HoleTable is returned.
AddByFeatureType | Method that creates a new hole table by including only the holes that are of the specified type in the input drawing view. The newly created HoleTable is returned.
AddSelected | Method that creates a new hole table by including only the specified holes. The newly created HoleTable is returned.
Item | Property that returns the specified HoleTable object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Methods


HoleTables.Add Method

HoleTables.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new hole table by including all holes in the input drawing view. Only those feature types specified in the input (or the default) hole table style will be included. The newly created HoleTable is returned.

Visual Basic
Sub Add(DrawingView As DrawingView, PlacementPoint As Point2d, ByRef HoleTableStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] HoleTable*)
Parameters
Parameters | Description
DrawingView | Input DrawingView object that specifies the drawing view for which the hole table is to be created.
PlacementPoint | Input Point2d object that specifies the position of the top left corner of the table on the sheet.
HoleTableStyle | Optional input HoleTableStyle object that specifies the hole table style to use for the table. If not specified, the default style specified by the standard is used.
Layer | Optional input Layer object that specifies the layer to use for the table. If not specified, the default layer specified by the standard is used.
Remarks

This method returns an error if the origin indicator is not set for the drawing view. Use the DrawingView.HasOriginIndicator property to query if an origin has already been set and if not, use DrawingView.CreateOriginIndicator method to set the origin of the drawing view. Note that the origin of the drawing view may have already been defined for creating ordinate dimensions or other hole tables based on this view.

Example

"Creating hole tables"

This sample demonstrates the creation of hole tables in a drawing. Select a drawing view that contains holes and run the following sample.

Sub CreateHoleTables()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the drawing view.
    ' This assumes that a drawing view is selected.
    Dim oDrawingView As DrawingView
    Set oDrawingView = oDrawDoc.SelectSet.Item(1)

    ' Create origin indicator if it has not been already created.
    If Not oDrawingView.HasOriginIndicator Then
        ' Create point intent to anchor the origin to.
        Dim oDimIntent As GeometryIntent
        Dim oPointIntent As Point2d

        ' Get the first curve on the view
        Dim oCurve As DrawingCurve
        Set oCurve = oDrawingView.DrawingCurves.Item(1)

        ' Check if it has a strt point
        Set oPointIntent = oCurve.StartPoint

        If oPointIntent Is Nothing Then
            ' Else use the center point
            Set oPointIntent = oCurve.CenterPoint
        End If

        Set oDimIntent = oActiveSheet.CreateGeometryIntent(oCurve, oPointIntent)

        oDrawingView.CreateOriginIndicator oDimIntent
    End If

    Dim oPlacementPoint As Point2d

    ' Set a reference to th sheet's border
    Dim oBorder As Border
    Set oBorder = oActiveSheet.Border

    If Not oBorder Is Nothing Then
        ' A border exists. The placement point
        ' is the top-left corner of the border.
        Set oPlacementPoint = ThisApplication.TransientGeometry.CreatePoint2d(oBorder.RangeBox.MinPoint.X, oBorder.RangeBox.MaxPoint.Y)
    Else
        ' There is no border. The placement point
        ' is the top-left corner of the sheet.
        Set oPlacementPoint = ThisApplication.TransientGeometry.CreatePoint2d(0, oActiveSheet.height)
    End If

    ' Create a 'view' hole table
    ' This hole table includes all holes as specified by the active hole table style
    Dim oViewHoleTable As HoleTable
    Set oViewHoleTable = oActiveSheet.HoleTables.Add(oDrawingView, oPlacementPoint)

    oPlacementPoint.X = oActiveSheet.width / 2

    ' Create a 'feature type' hole table
    ' This hole table includes specified hole types only
    Dim oFeatureHoleTable As HoleTable
    Set oFeatureHoleTable = oActiveSheet.HoleTables.AddByFeatureType(oDrawingView, oPlacementPoint, _
            True, True, True, True, False, False, False)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Methods > HoleTables.Add Method


HoleTables.AddByFeatureType Method

HoleTables.AddByFeatureType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new hole table by including only the holes that are of the specified type in the input drawing view. The newly created HoleTable is returned.

Visual Basic
Sub AddByFeatureType(DrawingView As DrawingView, PlacementPoint As Point2d, IncludeDrilledHoleFeatures As VARIANT_BOOL, IncludeCounterBoreHoleFeatures As VARIANT_BOOL, IncludeCounterSinkHoleFeatures As VARIANT_BOOL, IncludeThreadedHoleFeatures As VARIANT_BOOL, IncludeCircularCuts As VARIANT_BOOL, IncludeCentermarks As VARIANT_BOOL, IncludeRecoveredPunchCenters As VARIANT_BOOL, ByRef HoleTableStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] HoleTable*)
Parameters
Parameters | Description
DrawingView | Input DrawingView object that specifies the drawing view for which the hole table is to be created.
PlacementPoint | Input Point2d object that specifies the position of the top left corner of the table on the sheet.
IncludeDrilledHoleFeatures | Input Boolean that specifies whether to include drilled hole features.
IncludeCounterBoreHoleFeatures | Input Boolean that specifies whether to include counterbored hole features.
IncludeCounterSinkHoleFeatures | Input Boolean that specifies whether to include countersunk hole features.
IncludeThreadedHoleFeatures | Input Boolean that specifies whether to include threaded hole features.
IncludeCircularCuts | Input Boolean that specifies whether to include circular extruded cuts. Circular cuts are recognized only as drilled thru or drilled blind holes, and do not include mid-plane extrusions.
IncludeCentermarks | Input Boolean that specifies whether to include center marks. Center marks with visibility turned off are not included in the hole table.
IncludeRecoveredPunchCenters | Input Boolean that specifies whether to include recovered punch center marks. Punch center marks with visibility turned off are not included in the hole table.
HoleTableStyle | Optional input HoleTableStyle object that specifies the hole table style to use for the table. If not specified, the default style specified by the standard is used.
Layer | Optional input Layer object that specifies the layer to use for the table. If not specified, the default layer specified by the standard is used.
Remarks

This method returns an error if the origin indicator is not set for the drawing view. Use the DrawingView.HasOriginIndicator property to query if an origin has already been set and if not, use DrawingView.CreateOriginIndicator method to set the origin of the drawing view. Note that the origin of the drawing view may have already been defined for creating ordinate dimensions or other hole tables based on this view.

See Also

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Methods > HoleTables.AddByFeatureType Method


HoleTables.AddSelected Method

HoleTables.AddSelected Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new hole table by including only the specified holes. The newly created HoleTable is returned.

Visual Basic
Sub AddSelected(Holes As ObjectCollection, PlacementPoint As Point2d, ByRef HoleTableStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] HoleTable*)
Parameters
Parameters | Description
Holes | Input ObjectCollection which specifies the holes to create the table with. The collection may contain DrawingCurve objects that represent hole features or circular extrude cuts, or Centermark objects (which include recovered punch centers). All the holes must belong to the same drawing view, else an error will occur.
PlacementPoint | Input Point2d object that specifies the position of the top left corner of the table on the sheet.
HoleTableStyle | Optional input HoleTableStyle object that specifies the hole table style to use for the table. If not specified, the default style specified by the standard is used.
Layer | Optional input Layer object that specifies the layer to use for the table. If not specified, the default layer specified by the standard is used.
Remarks

This method returns an error if the origin indicator is not set for the drawing view. Use the DrawingView.HasOriginIndicator property to query if an origin has already been set and if not, use DrawingView.CreateOriginIndicator method to set the origin of the drawing view. Note that the origin of the drawing view may have already been defined for creating ordinate dimensions or other hole tables based on this view.

You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Methods > HoleTables.AddSelected Method


HoleTables.Item Method

HoleTables.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified HoleTable object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] HoleTable*)
Parameters
Parameters | Description
index | Input Variant value that specifies the HoleTable to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the HoleTable name. If an out of range index or a name of a non-existent HoleTable is provided, an error will occur .
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Methods > HoleTables.Item Method


HoleTables Properties

HoleTables Properties
Summary

The properties of the HoleTables class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kHoleTablesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Properties


HoleTables.Application Property

HoleTables.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Properties > HoleTables.Application Property


HoleTables.Count Property

HoleTables.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Properties > HoleTables.Count Property


HoleTables.Type Property

HoleTables.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTablesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTables Interface > HoleTables Properties > HoleTables.Type Property


HoleTableStyle Interface

HoleTableStyle Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The HoleTableStyle object represents a hole table style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::HoleTableStyle
Visual Basic
Public Interface HoleTableStyle
Inherits Style
Notes

Members through which this object may be accessed include:

HoleTable.Style

HoleTableStylesEnumerator.Item

ObjectDefaultsStyle.HoleTableStyle

You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface


HoleTableStyle Methods

HoleTableStyle Methods
Summary

The methods of the HoleTableStyle class are listed here.

Methods
Methods
Name | Description
AddColumn | Method that adds a column to the list of default columns in the style.
RemoveAllColumns | Method that removes all columns from the style.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Methods


HoleTableStyle.AddColumn Method

HoleTableStyle.AddColumn Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that adds a column to the list of default columns in the style.

Visual Basic
Sub AddColumn(PropertyType As HolePropertyEnum, ByRef CustomPropertyName As [defaultvalue("")] BSTR, ByRef Title As [defaultvalue("")] BSTR, ByRef Width As [defaultvalue(0)] double, ByRef TitleHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum, ByRef ValueHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum)
Parameters
Parameters | Description
PropertyType | Input HolePropertyEnum that specifies the property type to associate with the column. If kCustomHoleProperty is specified, the CustomPropertyName argument is required.
CustomPropertyName | Optional input String that specifies the name of the custom property to associate with the column. This argument must be specified if the PropertyType is specified to be kCustomHoleProperty, else the method returns an error.
Title | Optional input String that specifies the column title. If not specified, the property name is used.
Width | Optional input Double that specifies the width of the column. If not specified, the default width value is used. A value of 0 indicates the default width value.
TitleHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column title.
ValueHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column values.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Methods > HoleTableStyle.AddColumn Method


HoleTableStyle.RemoveAllColumns Method

HoleTableStyle.RemoveAllColumns Method
Summary

Method that removes all columns from the style.

Visual Basic
Sub RemoveAllColumns()
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Methods > HoleTableStyle.RemoveAllColumns Method


HoleTableStyle Properties

HoleTableStyle Properties
Summary

The properties of the HoleTableStyle class are listed here.

Properties
Name | Description
ArrangeByPosition | Property that gets and sets whether to tags holes relative to their position on the selected view or by their relative size.
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
DataTextStyle | Property that gets and sets the text style used for the contents of the table.
DeleteTagsOnRollup | Property that gets and sets whether to delete tags except for the first in a series of hole tags when the row merge type is kRollupRowMerge.
GroupHoleTypes | Property that gets and sets whether to group and tag holes by type.
HeadingPlacement | Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
IncludeCentermarks | Property that gets and sets whether to include center marks. Center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeCircularCuts | Property that gets and sets whether to include extruded cuts. Circular cuts are recognized only as drilled thru or drilled blind holes, and do not include mid-plane extrusions. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeCounterBoreHoleFeatures | Property that gets and sets whether to include counterbored hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeCounterSinkHoleFeatures | Property that gets and sets whether to include countersunk hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeDrilledHoleFeatures | Property that gets and sets whether to include drilled hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeHoleFeatures | Property that gets and sets whether to include hole features. Applies only to view based hole tables.
IncludeRecoveredPunchCenters | Property that gets and sets whether to include recovered punch center marks. Punch center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
IncludeThreadedHoleFeatures | Property that gets and sets whether to include threaded hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.
InsideLineColor | Property that gets and sets the color of the inner lines of the table.
InsideLineWeight | Property that gets and sets the line weight of the inner lines of the table.
OutsideLineColor | Property that gets and sets the color of the outer lines of the table.
OutsideLineWeight | Property that gets and sets the line weight of the outer lines of the table.
PreserveTagging | Property that gets and sets whether to preserve the hole tags assigned when the table is created.Tagging is preserved only with respect to changes to the model, such as when you add, delete, suppress or unsuppress hole features. Manual changes to the hole table, such as when you resort, change tag order, and filter hole types, are not affected.
ReformatOnCustomHoleMatch | Property that gets and sets whether to re-index the hole tags and resort contents when a 'Match Custom Hole' operation is done. Setting this property returns an error if the RowMergeType is kRollupRowMerge.
RowMergeType | Property that gets and sets the row merge option for the hole table. Valid values are kNoRowMerge, kRollupRowMerge and kCombineNotesRowMerge.
SecondaryTagModifierOnRollup | Property that gets and sets whether to include a secondary numeric tag when the row merge type is kRollupRowMerge.
SequentialNumbering | Property that gets and sets whether to replace the alphanumeric hole tags with sequential numbering of the holes in the hole table. Setting this property returns an error if the RowMergeType is kRollupRowMerge.
Title | Property that gets and sets the title of the HoleTable.
TitleTextStyle | Property that gets and sets the text style used for the title of the table.
UseLeaderForTags | Property that gets and sets whether to generate a leader for any hole tag dragged away from the hole with which it is associated.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties


HoleTableStyle.ArrangeByPosition Property

HoleTableStyle.ArrangeByPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to tags holes relative to their position on the selected view or by their relative size.

Visual Basic
Property ArrangeByPosition() As VARIANT_BOOL
Remarks

Position is arranged with YDIM as the primary key and XDIM as secondary key. If YDIM and XDIM are equal, hole size is the tertiary sorting key, smallest to largest. If this property is set to False, holes are arranged by size in order by size (smallest to largest). Size refers to the drill diameter parameter for drilled, counterbored, and countersunk holes. The tap drill diameter is used for threaded holes. If holes are of equal size, holes are sorted by position.

You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.ArrangeByPosition Property


HoleTableStyle.ColumnHeaderTextStyle Property

HoleTableStyle.ColumnHeaderTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.ColumnHeaderTextStyle Property


HoleTableStyle.DataTextStyle Property

HoleTableStyle.DataTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.DataTextStyle Property


HoleTableStyle.DeleteTagsOnRollup Property

HoleTableStyle.DeleteTagsOnRollup Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to delete tags except for the first in a series of hole tags when the row merge type is kRollupRowMerge.

Visual Basic
Property DeleteTagsOnRollup() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.DeleteTagsOnRollup Property


HoleTableStyle.GroupHoleTypes Property

HoleTableStyle.GroupHoleTypes Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to group and tag holes by type.

Visual Basic
Property GroupHoleTypes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.GroupHoleTypes Property


HoleTableStyle.HeadingPlacement Property

HoleTableStyle.HeadingPlacement Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.HeadingPlacement Property


HoleTableStyle.IncludeCentermarks Property

HoleTableStyle.IncludeCentermarks Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include center marks. Center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCentermarks() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeCentermarks Property


HoleTableStyle.IncludeCircularCuts Property

HoleTableStyle.IncludeCircularCuts Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include extruded cuts. Circular cuts are recognized only as drilled thru or drilled blind holes, and do not include mid-plane extrusions. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCircularCuts() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeCircularCuts Property


HoleTableStyle.IncludeCounterBoreHoleFeatures Property

HoleTableStyle.IncludeCounterBoreHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include counterbored hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCounterBoreHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeCounterBoreHoleFeatures Property


HoleTableStyle.IncludeCounterSinkHoleFeatures Property

HoleTableStyle.IncludeCounterSinkHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include countersunk hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeCounterSinkHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeCounterSinkHoleFeatures Property


HoleTableStyle.IncludeDrilledHoleFeatures Property

HoleTableStyle.IncludeDrilledHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include drilled hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeDrilledHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeDrilledHoleFeatures Property


HoleTableStyle.IncludeHoleFeatures Property

HoleTableStyle.IncludeHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include hole features. Applies only to view based hole tables.

Visual Basic
Property IncludeHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeHoleFeatures Property


HoleTableStyle.IncludeRecoveredPunchCenters Property

HoleTableStyle.IncludeRecoveredPunchCenters Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include recovered punch center marks. Punch center marks with visibility turned off are not included in hole tables. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeRecoveredPunchCenters() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeRecoveredPunchCenters Property


HoleTableStyle.IncludeThreadedHoleFeatures Property

HoleTableStyle.IncludeThreadedHoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include threaded hole features. Setting this property to True automatically sets the IncludeHoleFeatures property to True. This property is read-write for view based tables, read-only for feature type based tables and does not apply for selection based tables.

Visual Basic
Property IncludeThreadedHoleFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.IncludeThreadedHoleFeatures Property


HoleTableStyle.InsideLineColor Property

HoleTableStyle.InsideLineColor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the color of the inner lines of the table.

Visual Basic
Property InsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.InsideLineColor Property


HoleTableStyle.InsideLineWeight Property

HoleTableStyle.InsideLineWeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line weight of the inner lines of the table.

Visual Basic
Property InsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.InsideLineWeight Property


HoleTableStyle.OutsideLineColor Property

HoleTableStyle.OutsideLineColor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the color of the outer lines of the table.

Visual Basic
Property OutsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.OutsideLineColor Property


HoleTableStyle.OutsideLineWeight Property

HoleTableStyle.OutsideLineWeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line weight of the outer lines of the table.

Visual Basic
Property OutsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.OutsideLineWeight Property


HoleTableStyle.PreserveTagging Property

HoleTableStyle.PreserveTagging Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to preserve the hole tags assigned when the table is created.Tagging is preserved only with respect to changes to the model, such as when you add, delete, suppress or unsuppress hole features. Manual changes to the hole table, such as when you resort, change tag order, and filter hole types, are not affected.

Visual Basic
Property PreserveTagging() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.PreserveTagging Property


HoleTableStyle.ReformatOnCustomHoleMatch Property

HoleTableStyle.ReformatOnCustomHoleMatch Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to re-index the hole tags and resort contents when a 'Match Custom Hole' operation is done. Setting this property returns an error if the RowMergeType is kRollupRowMerge.

Visual Basic
Property ReformatOnCustomHoleMatch() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.ReformatOnCustomHoleMatch Property


HoleTableStyle.RowMergeType Property

HoleTableStyle.RowMergeType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the row merge option for the hole table. Valid values are kNoRowMerge, kRollupRowMerge and kCombineNotesRowMerge.

Visual Basic
Property RowMergeType() As RowMergeTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.RowMergeType Property


HoleTableStyle.SecondaryTagModifierOnRollup Property

HoleTableStyle.SecondaryTagModifierOnRollup Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to include a secondary numeric tag when the row merge type is kRollupRowMerge.

Visual Basic
Property SecondaryTagModifierOnRollup() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.SecondaryTagModifierOnRollup Property


HoleTableStyle.SequentialNumbering Property

HoleTableStyle.SequentialNumbering Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to replace the alphanumeric hole tags with sequential numbering of the holes in the hole table. Setting this property returns an error if the RowMergeType is kRollupRowMerge.

Visual Basic
Property SequentialNumbering() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.SequentialNumbering Property


HoleTableStyle.Title Property

HoleTableStyle.Title Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the title of the HoleTable.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.Title Property


HoleTableStyle.TitleTextStyle Property

HoleTableStyle.TitleTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the title of the table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.TitleTextStyle Property


HoleTableStyle.UseLeaderForTags Property

HoleTableStyle.UseLeaderForTags Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to generate a leader for any hole tag dragged away from the hole with which it is associated.

Visual Basic
Property UseLeaderForTags() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStyle Interface > HoleTableStyle Properties > HoleTableStyle.UseLeaderForTags Property


HoleTableStylesEnumerator Interface

HoleTableStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The HoleTableStylesEnumerator object provides access to the existing HoleTableStyle objects.

Class Hierarchy
Inventor::HoleTableStylesEnumerator
Visual Basic
Public Interface HoleTableStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.HoleTableStyles

You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface


HoleTableStylesEnumerator Methods

HoleTableStylesEnumerator Methods
Summary

The methods of the HoleTableStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified HoleTableStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface > HoleTableStylesEnumerator Methods


HoleTableStylesEnumerator.Item Method

HoleTableStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified HoleTableStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] HoleTableStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the HoleTableStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the HoleTableStyle name. If an out of range index or a name of a non-existent HoleTableStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface > HoleTableStylesEnumerator Methods > HoleTableStylesEnumerator.Item Method


HoleTableStylesEnumerator Properties

HoleTableStylesEnumerator Properties
Summary

The properties of the HoleTableStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kHoleTableStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface > HoleTableStylesEnumerator Properties


HoleTableStylesEnumerator.Application Property

HoleTableStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface > HoleTableStylesEnumerator Properties > HoleTableStylesEnumerator.Application Property


HoleTableStylesEnumerator.Count Property

HoleTableStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface > HoleTableStylesEnumerator Properties > HoleTableStylesEnumerator.Count Property


HoleTableStylesEnumerator.Type Property

HoleTableStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kHoleTableStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTableStylesEnumerator Interface > HoleTableStylesEnumerator Properties > HoleTableStylesEnumerator.Type Property


HoleTag Interface

HoleTag Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The HoleTag object represents a hole tag associated with a hole table row.

Class Hierarchy
Inventor::HoleTag
Visual Basic
Public Interface HoleTag
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HoleTableRow.HoleTag

You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface


HoleTag Properties

HoleTag Properties
Summary

The properties of the HoleTag class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DimensionStyle | Property that gets and sets the associated DimensionStyle object.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
Layer | Property that gets and sets the layer on which the hole tag resides.
Leader | Property that returns the Leader object associated with the hole tag.
Parent | Property that returns the parent HoleTableRow object.
Position | Property that gets and sets the position of the hole tag on the Sheet. If the new position is less than a distance of 0.25 cm from the current position, the position will not be modified.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
ShowLeader | Property that gets and sets whether to display the leader line.
StackedTextPosition | Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.
Text | Property that gets and sets the text of the cell.
Type | Property returning kHoleTagObject indicating this objects type.
Visible | Property that gets and sets whether the tag is visible.
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties


HoleTag.Application Property

HoleTag.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Application Property


HoleTag.DimensionStyle Property

HoleTag.DimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the associated DimensionStyle object.

Visual Basic
Property DimensionStyle() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.DimensionStyle Property


HoleTag.FormattedText Property

HoleTag.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.FormattedText Property


HoleTag.Layer Property

HoleTag.Layer Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the layer on which the hole tag resides.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Layer Property


HoleTag.Leader Property

HoleTag.Leader Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the Leader object associated with the hole tag.

Visual Basic
Property Leader() As Leader**
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Leader Property


HoleTag.Parent Property

HoleTag.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent HoleTableRow object.

Visual Basic
Property Parent() As HoleTableRow**
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Parent Property


HoleTag.Position Property

HoleTag.Position Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the position of the hole tag on the Sheet. If the new position is less than a distance of 0.25 cm from the current position, the position will not be modified.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Position Property


HoleTag.RangeBox Property

HoleTag.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.RangeBox Property


HoleTag.ShowLeader Property

HoleTag.ShowLeader Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether to display the leader line.

Visual Basic
Property ShowLeader() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.ShowLeader Property


HoleTag.StackedTextPosition Property

HoleTag.StackedTextPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.

Visual Basic
Property StackedTextPosition() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.StackedTextPosition Property


HoleTag.Text Property

HoleTag.Text Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the text of the cell.

Visual Basic
Property Text() As String
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Text Property


HoleTag.Type Property

HoleTag.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kHoleTagObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Type Property


HoleTag.Visible Property

HoleTag.Visible Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether the tag is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleTag Interface > HoleTag Properties > HoleTag.Visible Property


HoleTapInfo Interface

HoleTapInfo Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

This object is really a StandardThreadInfo object with the addition of the property specifying which of the various diameter dimensions to use to model the cylindrical surface of the hole.

Class Hierarchy
Inventor::ThreadInfo
    Inventor::StandardThreadInfo
        Inventor::HoleTapInfo
Visual Basic
Public Interface HoleTapInfo
Inherits StandardThreadInfo
Remarks

This additional information is not needed when the thread information is applied onto an existing cylindrical (or conical) surface.

Notes

Members through which this object may be accessed include:

HoleFeatures.CreateTapInfo

HoleFeature.TapInfo

See Also

Hole Feature - Through holes (RegularAndTapped) sample

Example

See HoleFeature for example "Creating through holes - regular and tapped"

You are here: Symbol Reference > Inventor Library > Objects > HoleTapInfo Interface


HoleTapInfo Properties

HoleTapInfo Properties
Summary

The properties of the HoleTapInfo class are listed here.

Properties
Name | Description
ThreadDepth | Property that returns the parameter that controls the depth of the thread. Even though the parameter for the thread depth is always created and accessible through this property, it is only used in the case where the FullDepth property is False.
You are here: Symbol Reference > Inventor Library > Objects > HoleTapInfo Interface > HoleTapInfo Properties


HoleTapInfo.ThreadDepth Property

HoleTapInfo.ThreadDepth Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that controls the depth of the thread. Even though the parameter for the thread depth is always created and accessible through this property, it is only used in the case where the FullDepth property is False.

Visual Basic
Property ThreadDepth() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > HoleTapInfo Interface > HoleTapInfo Properties > HoleTapInfo.ThreadDepth Property


HoleThreadNote Interface

HoleThreadNote Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The HoleThreadNote object represents either a hole note or a thread note on a sheet and derives from the DiameterGeneralDimension object.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
        Inventor::DiameterGeneralDimension
            Inventor::HoleThreadNote
Visual Basic
Public Interface HoleThreadNote
Inherits DiameterGeneralDimension
Notes

Members through which this object may be accessed include:

HoleThreadNotes.Add

HoleThreadNotes.Item

These objects do not appear in the DrawingNotes collection since these do not derive from DrawingNote.

See Also

Create thread note sample

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface


HoleThreadNote Properties

HoleThreadNote Properties
Summary

The properties of the HoleThreadNote class are listed here.

Properties
Name | Description
Edge | Property that gets and sets the hole/thread edge associated with the note. This may be either a DrawingCurve or a GeometryIntent depending on the type of note.
FormattedHoleThreadNote | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
FormattedQuantityNote | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
IsHoleNote | Property that indicates if this note is for a hole or thread feature. Returns True if it is for a hole note. This is true even in the case where the hole is tapped and has threads. Returns False in the case where the note is for a thread feature. There is some difference in behavior between the two and this property provides a convenient way to determine the expected behavior.
QuantityDefinition | Property that gets and sets how the quantity value is set for the note.
TapDrill | Property that gets and sets whether to set the hole note as tap drill type. This property only applies to tapped hole features.
UseCustomThreadDesignation | Property that gets and sets whether to use the custom thread designation, as defined in the Thread.xls spreadsheet for thread notes.
UseDefaultFormat | Property that gets and sets whether to use the default format for hole notes.
UsePartUnits | Property that gets and sets whether to use model units or the units specified by dimension style.
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties


HoleThreadNote.Edge Property

HoleThreadNote.Edge Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the hole/thread edge associated with the note. This may be either a DrawingCurve or a GeometryIntent depending on the type of note.

Visual Basic
Property Edge() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.Edge Property


HoleThreadNote.FormattedHoleThreadNote Property

HoleThreadNote.FormattedHoleThreadNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedHoleThreadNote() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.FormattedHoleThreadNote Property


HoleThreadNote.FormattedQuantityNote Property

HoleThreadNote.FormattedQuantityNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedQuantityNote() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.FormattedQuantityNote Property


HoleThreadNote.IsHoleNote Property

HoleThreadNote.IsHoleNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if this note is for a hole or thread feature. Returns True if it is for a hole note. This is true even in the case where the hole is tapped and has threads. Returns False in the case where the note is for a thread feature. There is some difference in behavior between the two and this property provides a convenient way to determine the expected behavior.

Visual Basic
Property IsHoleNote() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.IsHoleNote Property


HoleThreadNote.QuantityDefinition Property

HoleThreadNote.QuantityDefinition Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets how the quantity value is set for the note.

Visual Basic
Property QuantityDefinition() As HoleNoteQuantityEnum
Remarks

The valid values are kNumberOfHolesInFeature and kNumberOfLikeHolesNormalToView. This is only valid for notes to hole features and not notes to thread features. This can easily be determined by checking the value of IsHoleNote property. In other cases the value of this property should be ignored and setting it will fail.

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.QuantityDefinition Property


HoleThreadNote.TapDrill Property

HoleThreadNote.TapDrill Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to set the hole note as tap drill type. This property only applies to tapped hole features.

Visual Basic
Property TapDrill() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.TapDrill Property


HoleThreadNote.UseCustomThreadDesignation Property

HoleThreadNote.UseCustomThreadDesignation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use the custom thread designation, as defined in the Thread.xls spreadsheet for thread notes.

Visual Basic
Property UseCustomThreadDesignation() As VARIANT_BOOL
Remarks

This is only valid for notes to thread features and not notes to hole features. This can easily be determined by checking the value of IsHoleNote property. In other cases the value of this property should be ignored and setting it will fail.

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.UseCustomThreadDesignation Property


HoleThreadNote.UseDefaultFormat Property

HoleThreadNote.UseDefaultFormat Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use the default format for hole notes.

Visual Basic
Property UseDefaultFormat() As VARIANT_BOOL
Remarks

This property is automatically set to False if the FormattedHoleThreadNote property is set.

This is only valid for notes to hole features and not notes to thread features. This can easily be determined by checking the value of IsHoleNote property. In other cases the value of this property should be ignored and setting it will fail.

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.UseDefaultFormat Property


HoleThreadNote.UsePartUnits Property

HoleThreadNote.UsePartUnits Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use model units or the units specified by dimension style.

Visual Basic
Property UsePartUnits() As VARIANT_BOOL
Remarks

Model units are used if the property is set to True. This is only valid for notes to hole features and not notes to thread features. This can easily be determined by checking the value of IsHoleNote property. In other cases the value of this property should be ignored and setting it will fail.

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNote Interface > HoleThreadNote Properties > HoleThreadNote.UsePartUnits Property


HoleThreadNotes Interface

HoleThreadNotes Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The HoleThreadNotes collection object provides access to all of the hole and thread notes on the sheet.

Class Hierarchy
Inventor::HoleThreadNotes
Visual Basic
Public Interface HoleThreadNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.HoleThreadNotes

See Also

Create thread note sample

You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface


HoleThreadNotes Methods

HoleThreadNotes Methods
Summary

The methods of the HoleThreadNotes class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a hole or thread note on the sheet. Different results are possible depending on the input provided, as discussed below.
Item | Property that returns the specified HoleThreadNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Methods


HoleThreadNotes.Add Method

HoleThreadNotes.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a hole or thread note on the sheet. Different results are possible depending on the input provided, as discussed below.

Visual Basic
Sub Add(Position As Point2d, HoleOrThreadEdge As IDispatch, ByRef LinearDiameterType As [defaultvalue(0)] VARIANT_BOOL, ByRef DimensionStyle As [optional] VARIANT, Result As [out, retval] HoleThreadNote*)
Parameters
Parameters | Description
Position | Input Point2d that specifies the position of the hole/thread note on the sheet.
HoleOrThreadEdge | Optional Input DrawingCurve or GeometryIntent object that specifies the edge to create the note for and the location along the edge the note points to. If the drawing curve or geometry intent does not represent a hole or thread edge, the method returns an error. See the discussion above for more information about how to get different results by providing different inputs for this argument.
LinearDiameterType | Optional Input Boolean that specifies whether to create a leader type of note or a linear diameter type of note. There are two examples of linear diameter types in the figure above. These are the uncircled notes in the right view. The three circled notes illustrate a leader type of note.
DimensionStyle | Optional input Variant that specifies which dimension style to use for the note. The dimension style can be specified by providing the name of an existing style or by supplying a DimensionStyle object.
Remarks

In the example below there are three holes created using various modeling techniques. The top one was created using an extrude feature and a subsequent thread feature was added to it. The middle feature is a counter bore hole feature that is also tapped. The bottom feature is a standard hole.

To get any of the four notes shown on the left-hand view the only required input is the Position to define the text position and a DrawingCurve defining which curve the note should point to. The text position is enough to determine where the note points to the circle. Notice that in the case of the thread feature you get a thread note if the input drawing curve is for the thread and you get a hole note if the drawing curve is for the hole.

The right view demonstrates some other possibilities. The three circled notes can be created by defining the text position point, the geometry to point to and a point along that geometry. The geometry and point on the geometry are defined by providing a GeometryIntent object as input to the HoleOrThreadEdge argument.

The other two notes in the right view require the input of the text position and one of the lines that represents the diameter of the thread. In addition, the LinearDiameterType argument must be set to True.

Example

This sample demonstrates the creation of a thread note on a drawing view. Select a thread edge on a drawing view and run the sample.

Sub AddThreadNote()

    ' Assumes that a drawing document is active
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Check to make sure a thread edge is selected.
    If oDoc.SelectSet.Count <> 1 Then
        MsgBox "A single thread edge must be selected."
        Exit Sub
    End If

    If Not TypeOf oDoc.SelectSet(1) Is DrawingCurveSegment Then
        MsgBox "A thread edge must be selected."
        Exit Sub
    End If

    Dim oThreadEdge As DrawingCurve
    Set oThreadEdge = oDoc.SelectSet(1).Parent

    If Not (oThreadEdge.EdgeType = kThreadEdge) Then
        MsgBox "A thread edge must be selected."
        Exit Sub
    End If

    Dim oPosition As Point2d
    Set oPosition = ThisApplication.TransientGeometry.CreatePoint2d(5, 25)

    ' Create the thread note
    Dim oThreadNote As HoleThreadNote
    Set oThreadNote = oDoc.ActiveSheet.DrawingNotes.HoleThreadNotes.Add(oPosition, oThreadEdge)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Methods > HoleThreadNotes.Add Method


HoleThreadNotes.Item Method

HoleThreadNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified HoleThreadNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] HoleThreadNote*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Methods > HoleThreadNotes.Item Method


HoleThreadNotes Properties

HoleThreadNotes Properties
Summary

The properties of the HoleThreadNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kHoleThreadNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Properties


HoleThreadNotes.Application Property

HoleThreadNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Properties > HoleThreadNotes.Application Property


HoleThreadNotes.Count Property

HoleThreadNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Properties > HoleThreadNotes.Count Property


HoleThreadNotes.Type Property

HoleThreadNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kHoleThreadNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > HoleThreadNotes Interface > HoleThreadNotes Properties > HoleThreadNotes.Type Property


HorizontalAlignConstraint Interface

HorizontalAlignConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The HorizontalAlignConstraint object represents a constraint that makes two sketch points align horizontally.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::HorizontalAlignConstraint
        Inventor::HorizontalAlignConstraintProxy
Visual Basic
Public Interface HorizontalAlignConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddHorizontalAlign

HorizontalAlignConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraint Interface


HorizontalAlignConstraint Properties

HorizontalAlignConstraint Properties
Summary

The properties of the HorizontalAlignConstraint class are listed here.

Properties
Name | Description
PointOne | Property that returns the first sketch point being constrained.
PointTwo | Property that returns the second sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraint Interface > HorizontalAlignConstraint Properties


HorizontalAlignConstraint.PointOne Property

HorizontalAlignConstraint.PointOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first sketch point being constrained.

Visual Basic
Property PointOne() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraint Interface > HorizontalAlignConstraint Properties > HorizontalAlignConstraint.PointOne Property


HorizontalAlignConstraint.PointTwo Property

HorizontalAlignConstraint.PointTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second sketch point being constrained.

Visual Basic
Property PointTwo() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraint Interface > HorizontalAlignConstraint Properties > HorizontalAlignConstraint.PointTwo Property


HorizontalAlignConstraintProxy Interface

HorizontalAlignConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HorizontalAlignConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::HorizontalAlignConstraint
        Inventor::HorizontalAlignConstraintProxy
Visual Basic
Public Interface HorizontalAlignConstraintProxy
Inherits HorizontalAlignConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraintProxy Interface


HorizontalAlignConstraintProxy Properties

HorizontalAlignConstraintProxy Properties
Summary

The properties of the HorizontalAlignConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraintProxy Interface > HorizontalAlignConstraintProxy Properties


HorizontalAlignConstraintProxy.ContainingOccurrence Property

HorizontalAlignConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraintProxy Interface > HorizontalAlignConstraintProxy Properties > HorizontalAlignConstraintProxy.ContainingOccurrence Property


HorizontalAlignConstraintProxy.NativeObject Property

HorizontalAlignConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As HorizontalAlignConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HorizontalAlignConstraintProxy Interface > HorizontalAlignConstraintProxy Properties > HorizontalAlignConstraintProxy.NativeObject Property


HorizontalConstraint Interface

HorizontalConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The HorizontalConstraint object represents a horizontal constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::HorizontalConstraint
        Inventor::HorizontalConstraintProxy
Visual Basic
Public Interface HorizontalConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddHorizontal

HorizontalConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraint Interface


HorizontalConstraint Properties

HorizontalConstraint Properties
Summary

The properties of the HorizontalConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns the sketch entity being constrained. This can be a sketch line, ellipse, or elliptical arc.
UseEllipseMajorAxis | Property used in the case where the entity returned by the Entity property is an ellipse. This property specifies if the major or minor axis of the ellipse is horizontal. True if it is the major axis.
You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraint Interface > HorizontalConstraint Properties


HorizontalConstraint.Entity Property

HorizontalConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained. This can be a sketch line, ellipse, or elliptical arc.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraint Interface > HorizontalConstraint Properties > HorizontalConstraint.Entity Property


HorizontalConstraint.UseEllipseMajorAxis Property

HorizontalConstraint.UseEllipseMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the Entity property is an ellipse. This property specifies if the major or minor axis of the ellipse is horizontal. True if it is the major axis.

Visual Basic
Property UseEllipseMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraint Interface > HorizontalConstraint Properties > HorizontalConstraint.UseEllipseMajorAxis Property


HorizontalConstraintProxy Interface

HorizontalConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the HorizontalConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::HorizontalConstraint
        Inventor::HorizontalConstraintProxy
Visual Basic
Public Interface HorizontalConstraintProxy
Inherits HorizontalConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraintProxy Interface


HorizontalConstraintProxy Properties

HorizontalConstraintProxy Properties
Summary

The properties of the HorizontalConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraintProxy Interface > HorizontalConstraintProxy Properties


HorizontalConstraintProxy.ContainingOccurrence Property

HorizontalConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraintProxy Interface > HorizontalConstraintProxy Properties > HorizontalConstraintProxy.ContainingOccurrence Property


HorizontalConstraintProxy.NativeObject Property

HorizontalConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As HorizontalConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > HorizontalConstraintProxy Interface > HorizontalConstraintProxy Properties > HorizontalConstraintProxy.NativeObject Property


iAssemblyFactory Interface

iAssemblyFactory Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyFactory object provides access to the iAssembly table and provides methods to create iAssembly members.

Class Hierarchy
Inventor::iAssemblyFactory
Visual Basic
Public Interface iAssemblyFactory
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.iAssemblyFactory

AssemblyComponentDefinition.CreateFactory

iAssemblyMember.ParentFactory

iAssemblyTableCell.Parent

iAssemblyTableColumn.Parent

iAssemblyTableRow.Parent

See Also

Add iAssembly Occurrence (C#) sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface


iAssemblyFactory Methods

iAssemblyFactory Methods
Summary

The methods of the iAssemblyFactory class are listed here.

Methods
Methods
Name | Description
CreateMember | Method that creates an iAssembly member using the parameter values in a row. The created iAssemblyMember is returned. If the member already exists, the member is updated and the iAssemblyMember object is returned.
Delete | Method that converts the iAssembly factory to a regular assembly. When an iAssembly factory is converted to a regular assembly, all of the iAssembly members created from the factory become sick.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Methods


iAssemblyFactory.CreateMember Method

iAssemblyFactory.CreateMember Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates an iAssembly member using the parameter values in a row. The created iAssemblyMember is returned. If the member already exists, the member is updated and the iAssemblyMember object is returned.

Visual Basic
Sub CreateMember(ByRef Row As [optional] VARIANT)
Parameters
Parameters | Description
Row | Optional input Variant that specifies the row number within an iAssembly table. The row index is specified either by a Long (row index), a String (MemberName), or an iAssemblyTableRow object. If the argument is not specified, the default row of the factory will be used to create the iAssembly member.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Methods > iAssemblyFactory.CreateMember Method


iAssemblyFactory.Delete Method

iAssemblyFactory.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that converts the iAssembly factory to a regular assembly. When an iAssembly factory is converted to a regular assembly, all of the iAssembly members created from the factory become sick.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Methods > iAssemblyFactory.Delete Method


iAssemblyFactory Properties

iAssemblyFactory Properties
Summary

The properties of the iAssemblyFactory class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DefaultRow | Property that gets and sets the default row for this iAssemblyFactory. The assembly shown in the iAssembly factory is computed with the values in the default row. Also, in the absence of a row input to the CreateiAssemblyMember method, the values in this row will be used to create a new iAssemblyMember object.
ExcelWorkSheet | Property that returns the excel spreadsheet that represents the iAssembly table.
FactoryOptions | Property that gets the options for the factory.
FileNameColumn | Property that gets and sets the column to use as the file name column. If a column is set as the file name column, the value of the corresponding cell is used as the browser name when a member is placed into an assembly. This property returns Nothing if no column is set as the file name column and the property can be set to Nothing to indicate that no column is to be set as the file name column.
MemberCacheDir | Property that returns the directory location for the newly created iAssembly members.
MemberEditScope | Property that gets and sets whether the edits to a member should affect just the active member or all members within the factory. Valid values are kEditActiveMember and kEditAllMembers. This value is not persisted.
Parent | Property that returns the parent AssemblyComponentDefinition of the factory.
TableColumns | Property that returns the iAssemblyTableColumns collection object.
TableRows | Property that returns the iAssemblyTableRows collection object.
Type | Property returning kiAssemblyFactoryObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties


iAssemblyFactory.Application Property

iAssemblyFactory.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.Application Property


iAssemblyFactory.DefaultRow Property

iAssemblyFactory.DefaultRow Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the default row for this iAssemblyFactory. The assembly shown in the iAssembly factory is computed with the values in the default row. Also, in the absence of a row input to the CreateiAssemblyMember method, the values in this row will be used to create a new iAssemblyMember object.

Visual Basic
Property DefaultRow() As iAssemblyTableRow*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.DefaultRow Property


iAssemblyFactory.ExcelWorkSheet Property

iAssemblyFactory.ExcelWorkSheet Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the excel spreadsheet that represents the iAssembly table.

Visual Basic
Property ExcelWorkSheet() As IDispatch**
Remarks

This object can be assigned to an Excel WorkSheet object. The WorkSheet object can then be used to query and to set data in the spreadsheet using Excel APIs. If any edits are made to the Excel worksheet obtained from this property, the parent WorkBook of the WorkSheet must be saved and closed for the changes to take effect in Inventor.

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.ExcelWorkSheet Property


iAssemblyFactory.FactoryOptions Property

iAssemblyFactory.FactoryOptions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the options for the factory.

Visual Basic
Property FactoryOptions() As FactoryOptions**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.FactoryOptions Property


iAssemblyFactory.FileNameColumn Property

iAssemblyFactory.FileNameColumn Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the column to use as the file name column. If a column is set as the file name column, the value of the corresponding cell is used as the browser name when a member is placed into an assembly. This property returns Nothing if no column is set as the file name column and the property can be set to Nothing to indicate that no column is to be set as the file name column.

Visual Basic
Property FileNameColumn() As iAssemblyTableColumn*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.FileNameColumn Property


iAssemblyFactory.MemberCacheDir Property

iAssemblyFactory.MemberCacheDir Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the directory location for the newly created iAssembly members.

Visual Basic
Property MemberCacheDir() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.MemberCacheDir Property


iAssemblyFactory.MemberEditScope Property

iAssemblyFactory.MemberEditScope Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the edits to a member should affect just the active member or all members within the factory. Valid values are kEditActiveMember and kEditAllMembers. This value is not persisted.

Visual Basic
Property MemberEditScope() As MemberEditScopeEnum
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.MemberEditScope Property


iAssemblyFactory.Parent Property

iAssemblyFactory.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent AssemblyComponentDefinition of the factory.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.Parent Property


iAssemblyFactory.TableColumns Property

iAssemblyFactory.TableColumns Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the iAssemblyTableColumns collection object.

Visual Basic
Property TableColumns() As iAssemblyTableColumns**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.TableColumns Property


iAssemblyFactory.TableRows Property

iAssemblyFactory.TableRows Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the iAssemblyTableRows collection object.

Visual Basic
Property TableRows() As iAssemblyTableRows**
See Also

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.TableRows Property


iAssemblyFactory.Type Property

iAssemblyFactory.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyFactoryObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyFactory Interface > iAssemblyFactory Properties > iAssemblyFactory.Type Property


iAssemblyMember Interface

iAssemblyMember Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyMember object provides access to a member of an iAssembly.

Class Hierarchy
Inventor::iAssemblyMember
Visual Basic
Public Interface iAssemblyMember
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.iAssemblyMember

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface


iAssemblyMember Methods

iAssemblyMember Methods
Summary

The methods of the iAssemblyMember class are listed here.

Methods
Methods
Name | Description
BreakLinkToFactory | Method that breaks the link to the parent factory and converts the iAssembly member to a regular assembly.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Methods


iAssemblyMember.BreakLinkToFactory Method

iAssemblyMember.BreakLinkToFactory Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that breaks the link to the parent factory and converts the iAssembly member to a regular assembly.

Visual Basic
Sub BreakLinkToFactory()
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Methods > iAssemblyMember.BreakLinkToFactory Method


iAssemblyMember Properties

iAssemblyMember Properties
Summary

The properties of the iAssemblyMember class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
HealthStatus | Property that returns an enum indicating the current state of the object.
Parent | Property that returns the parent AssemblyComponentDefinition of the member.
ParentFactory | Property that returns the iAssembly factory that created this iAssemblyMember.
ReferencedDocumentDescriptor | Property that returns the descriptor of the iAssembly factory document.
Row | Property that returns the row in the iAssembly table that this iAssemblyMember represents.
Type | Property returning kiAssemblyMemberObject indicating this object's type
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties


iAssemblyMember.Application Property

iAssemblyMember.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.Application Property


iAssemblyMember.HealthStatus Property

iAssemblyMember.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.HealthStatus Property


iAssemblyMember.Parent Property

iAssemblyMember.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent AssemblyComponentDefinition of the member.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.Parent Property


iAssemblyMember.ParentFactory Property

iAssemblyMember.ParentFactory Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the iAssembly factory that created this iAssemblyMember.

Visual Basic
Property ParentFactory() As iAssemblyFactory**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.ParentFactory Property


iAssemblyMember.ReferencedDocumentDescriptor Property

iAssemblyMember.ReferencedDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the descriptor of the iAssembly factory document.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.ReferencedDocumentDescriptor Property


iAssemblyMember.Row Property

iAssemblyMember.Row Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the row in the iAssembly table that this iAssemblyMember represents.

Visual Basic
Property Row() As iAssemblyTableRow**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.Row Property


iAssemblyMember.Type Property

iAssemblyMember.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyMemberObject indicating this object's type

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyMember Interface > iAssemblyMember Properties > iAssemblyMember.Type Property


iAssemblyTableCell Interface

iAssemblyTableCell Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyTableCell object represents an individual cell in the iAssembly factory table.

Class Hierarchy
Inventor::iAssemblyTableCell
Visual Basic
Public Interface iAssemblyTableCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iAssemblyTableColumn.Item

iAssemblyTableRow.Item

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface


iAssemblyTableCell Properties

iAssemblyTableCell Properties
Summary

The properties of the iAssemblyTableCell class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Column | Property that returns the index of this cell within the parent iAssemblyTableColumn.
HasFormula | Property that returns whether a formula (equation) was input into this cell via Excel. Such cells show with a red background in the user interface and are not editable.
IsValid | Property that returns whether the contents of this cell are valid. Invalid cells show with a yellow background in the user interface.
Parent | Property that returns the parent iAssemblyFactory object.
Row | Property that returns the index of this cell within the parent iAssemblyTableRow.
Type | Property returning kiAssemblyTableCellObject indicating this object's type.
Value | Property that gets and sets the value of the cell. Setting this property returns an error if the HasFormula property returns True.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties


iAssemblyTableCell.Application Property

iAssemblyTableCell.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.Application Property


iAssemblyTableCell.Column Property

iAssemblyTableCell.Column Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the index of this cell within the parent iAssemblyTableColumn.

Visual Basic
Property Column() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.Column Property


iAssemblyTableCell.HasFormula Property

iAssemblyTableCell.HasFormula Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether a formula (equation) was input into this cell via Excel. Such cells show with a red background in the user interface and are not editable.

Visual Basic
Property HasFormula() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.HasFormula Property


iAssemblyTableCell.IsValid Property

iAssemblyTableCell.IsValid Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the contents of this cell are valid. Invalid cells show with a yellow background in the user interface.

Visual Basic
Property IsValid() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.IsValid Property


iAssemblyTableCell.Parent Property

iAssemblyTableCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent iAssemblyFactory object.

Visual Basic
Property Parent() As iAssemblyFactory**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.Parent Property


iAssemblyTableCell.Row Property

iAssemblyTableCell.Row Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the index of this cell within the parent iAssemblyTableRow.

Visual Basic
Property Row() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.Row Property


iAssemblyTableCell.Type Property

iAssemblyTableCell.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyTableCellObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.Type Property


iAssemblyTableCell.Value Property

iAssemblyTableCell.Value Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the value of the cell. Setting this property returns an error if the HasFormula property returns True.

Visual Basic
Property Value() As String
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableCell Interface > iAssemblyTableCell Properties > iAssemblyTableCell.Value Property


iAssemblyTableColumn Interface

iAssemblyTableColumn Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyTableColumn object represents a column in the iAssembly factory table.

Class Hierarchy
Inventor::iAssemblyTableColumn
Visual Basic
Public Interface iAssemblyTableColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iAssemblyFactory.FileNameColumn

iAssemblyTableColumns.Item

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface


iAssemblyTableColumn Methods

iAssemblyTableColumn Methods
Summary

The methods of the iAssemblyTableColumn class are listed here.

Methods
Methods
Name | Description
Delete | Deletes this column in the factory.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Methods


iAssemblyTableColumn.Delete Method

iAssemblyTableColumn.Delete Method
Summary

Deletes this column in the factory.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Methods > iAssemblyTableColumn.Delete Method


iAssemblyTableColumn Properties

iAssemblyTableColumn Properties
Summary

The properties of the iAssemblyTableColumn class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified iAssemblyTableCell object from the collection.
Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that specifies the number of items in the collection.
DisplayHeading | Property that returns the localized heading of the column.
FormattedHeading | Property that returns the heading of the column in XML format.
Heading | Property that returns the non-localized heading of the column.
Index | Property that returns the index of this column within the iAssembly factory table.
Key | Property that gets and sets the key order for the column. A value of 0 indicates that this is not a key column. The key sets the nesting order in the browser. For example, if you select an iAssembly by its length, and then its width, set Length as Key = 1 and Width as Key = 2.
Parent | Property that returns the parent iAssemblyFactory object.
ReferencedDataType | Property that returns the data type contained in the column.
ReferencedObject | Property that returns the object referenced by the column. For instance, if the column references a fillet feature suppression, the corresponding FilletFeature object is returned. Similarly, if a file property is referenced, the corresponding Property object is returned. The property returns Nothing if there is no corresponding object (e.g. when the ReferencedDataType returns kMemberNameColumn).
Type | Property returning kiAssemblyTableColumnObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties


iAssemblyTableColumn.Application Property

iAssemblyTableColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Application Property


iAssemblyTableColumn.Count Property

iAssemblyTableColumn.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Count Property


iAssemblyTableColumn.DisplayHeading Property

iAssemblyTableColumn.DisplayHeading Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the localized heading of the column.

Visual Basic
Property DisplayHeading() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.DisplayHeading Property


iAssemblyTableColumn.FormattedHeading Property

iAssemblyTableColumn.FormattedHeading Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the heading of the column in XML format.

Visual Basic
Property FormattedHeading() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.FormattedHeading Property


iAssemblyTableColumn.Heading Property

iAssemblyTableColumn.Heading Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the non-localized heading of the column.

Visual Basic
Property Heading() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Heading Property


iAssemblyTableColumn.Index Property

iAssemblyTableColumn.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this column within the iAssembly factory table.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Index Property


iAssemblyTableColumn.Item Method

iAssemblyTableColumn.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified iAssemblyTableCell object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iAssemblyTableCell*)
Parameters
Parameters | Description
index | Value that specifies the iAssemblyTableCell to return. This can be either a numeric value indicating the index of a row where the first row has an index of 1 or it can be a string indicating the member name of a particular row. The member name is obtained using the MemberName property on an iAssemblyTableRow object. If an out of range index or a name of a non-existent member is provided, an error will occur
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Item Method


iAssemblyTableColumn.Key Property

iAssemblyTableColumn.Key Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the key order for the column. A value of 0 indicates that this is not a key column. The key sets the nesting order in the browser. For example, if you select an iAssembly by its length, and then its width, set Length as Key = 1 and Width as Key = 2.

Visual Basic
Property Key() As long
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Key Property


iAssemblyTableColumn.Parent Property

iAssemblyTableColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent iAssemblyFactory object.

Visual Basic
Property Parent() As iAssemblyFactory**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Parent Property


iAssemblyTableColumn.ReferencedDataType Property

iAssemblyTableColumn.ReferencedDataType Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the data type contained in the column.

Visual Basic
Property ReferencedDataType() As iComponentColumnTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.ReferencedDataType Property


iAssemblyTableColumn.ReferencedObject Property

iAssemblyTableColumn.ReferencedObject Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the object referenced by the column. For instance, if the column references a fillet feature suppression, the corresponding FilletFeature object is returned. Similarly, if a file property is referenced, the corresponding Property object is returned. The property returns Nothing if there is no corresponding object (e.g. when the ReferencedDataType returns kMemberNameColumn).

Visual Basic
Property ReferencedObject() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.ReferencedObject Property


iAssemblyTableColumn.Type Property

iAssemblyTableColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyTableColumnObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumn Interface > iAssemblyTableColumn Properties > iAssemblyTableColumn.Type Property


iAssemblyTableColumns Interface

iAssemblyTableColumns Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyTableColumns collection object provides access to all existing iAssemblyTableColumn objects in the iAssembly factory table.

Class Hierarchy
Inventor::iAssemblyTableColumns
Visual Basic
Public Interface iAssemblyTableColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iAssemblyFactory.TableColumns

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface


iAssemblyTableColumns Methods

iAssemblyTableColumns Methods
Summary

The methods of the iAssemblyTableColumns class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified iAssemblyTableColumn object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface > iAssemblyTableColumns Methods


iAssemblyTableColumns.Item Method

iAssemblyTableColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified iAssemblyTableColumn object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iAssemblyTableColumn*)
Parameters
Parameters | Description
index | Value that specifies the iAssemblyTableColumn to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the column heading. If an out of range index or a name of a non-existent iAssemblyTableColumn is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface > iAssemblyTableColumns Methods > iAssemblyTableColumns.Item Method


iAssemblyTableColumns Properties

iAssemblyTableColumns Properties
Summary

The properties of the iAssemblyTableColumns class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that specifies the number of items in the collection.
Type | Property returning kiAssemblyTableColumnsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface > iAssemblyTableColumns Properties


iAssemblyTableColumns.Application Property

iAssemblyTableColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface > iAssemblyTableColumns Properties > iAssemblyTableColumns.Application Property


iAssemblyTableColumns.Count Property

iAssemblyTableColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface > iAssemblyTableColumns Properties > iAssemblyTableColumns.Count Property


iAssemblyTableColumns.Type Property

iAssemblyTableColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyTableColumnsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableColumns Interface > iAssemblyTableColumns Properties > iAssemblyTableColumns.Type Property


iAssemblyTableRow Interface

iAssemblyTableRow Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyTableRow object represents a row in the iAssembly factory table.

Class Hierarchy
Inventor::iAssemblyTableRow
Visual Basic
Public Interface iAssemblyTableRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iAssemblyFactory.DefaultRow

iAssemblyMember.Row

iAssemblyTableRow.Copy

iAssemblyTableRows.Item

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface


iAssemblyTableRow Methods

iAssemblyTableRow Methods
Summary

The methods of the iAssemblyTableRow class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a new row with all values equal to the original row.
Delete | Method that deletes this row in the factory.
GetReferenceKey | Method that generates and returns the reference key for this entity.
IsExcluded | Method that returns whether the input object is excluded in this member.
Item | Property that returns the specified iAssemblyTableCell object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Methods


iAssemblyTableRow.Copy Method

iAssemblyTableRow.Copy Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new row with all values equal to the original row.

Visual Basic
Sub Copy(ByRef NewMemberName As [defaultvalue("")] BSTR, Result As [out, retval] iAssemblyTableRow*)
Parameters
Parameters | Description
NewMemberName | Name of new row member.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Methods > iAssemblyTableRow.Copy Method


iAssemblyTableRow.Delete Method

iAssemblyTableRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes this row in the factory.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Methods > iAssemblyTableRow.Delete Method


iAssemblyTableRow.GetReferenceKey Method

iAssemblyTableRow.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Methods > iAssemblyTableRow.GetReferenceKey Method


iAssemblyTableRow.IsExcluded Method

iAssemblyTableRow.IsExcluded Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the input object is excluded in this member.

Visual Basic
Sub IsExcluded(Object As IDispatch, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | Object to check for exclusion.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Methods > iAssemblyTableRow.IsExcluded Method


iAssemblyTableRow.Item Method

iAssemblyTableRow.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified iAssemblyTableCell object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iAssemblyTableCell*)
Parameters
Parameters | Description
index | Value that specifies the iAssemblyTableCell to return. This can be either a numeric value indicating the index of a column where the first column has an index of 1 or it can be a string indicating the heading of a particular column. The heading is obtained using the Heading property on an iAssemblyTableColumn object. If an out of range index or a heading of a non-existent column is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Methods > iAssemblyTableRow.Item Method


iAssemblyTableRow Properties

iAssemblyTableRow Properties
Summary

The properties of the iAssemblyTableRow class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Count | Property that specifies the number of items in the collection.
DocumentName | Property that gets and sets the document name corresponding to this row in the iAssembly table. In the absence of a DocumentName input to the CreateiAssemblyMember method, the DocumentName for this row will be used to create a new iAssembly member. Setting this property will fail if the DocumentNameModifiable property returns False. Setting this property will fail if the corresponding cell in Excel contains a formula.
DocumentNameModifiable | Property that returns whether the name of the document corresponding to this member can be modified.
Index | Property that returns the index of this row within the iAssembly factory table.
IsDocumentNameBasedOnMemberName | Gets whether the member's filename is based on the member name or an explicitly set filename.
MemberName | Property that returns the member name corresponding to this row in the iAssembly table.
Parent | Property that returns the parent iAssemblyFactory object.
Type | Property returning kiAssemblyTableRowObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties


iAssemblyTableRow.Application Property

iAssemblyTableRow.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.Application Property


iAssemblyTableRow.AttributeSets Property

iAssemblyTableRow.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.AttributeSets Property


iAssemblyTableRow.Count Property

iAssemblyTableRow.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.Count Property


iAssemblyTableRow.DocumentName Property

iAssemblyTableRow.DocumentName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the document name corresponding to this row in the iAssembly table. In the absence of a DocumentName input to the CreateiAssemblyMember method, the DocumentName for this row will be used to create a new iAssembly member. Setting this property will fail if the DocumentNameModifiable property returns False. Setting this property will fail if the corresponding cell in Excel contains a formula.

Visual Basic
Property DocumentName() As String
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.DocumentName Property


iAssemblyTableRow.DocumentNameModifiable Property

iAssemblyTableRow.DocumentNameModifiable Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the name of the document corresponding to this member can be modified.

Visual Basic
Property DocumentNameModifiable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.DocumentNameModifiable Property


iAssemblyTableRow.Index Property

iAssemblyTableRow.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this row within the iAssembly factory table.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.Index Property


iAssemblyTableRow.IsDocumentNameBasedOnMemberName Property

iAssemblyTableRow.IsDocumentNameBasedOnMemberName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets whether the member's filename is based on the member name or an explicitly set filename.

Visual Basic
Property IsDocumentNameBasedOnMemberName() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.IsDocumentNameBasedOnMemberName Property


iAssemblyTableRow.MemberName Property

iAssemblyTableRow.MemberName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the member name corresponding to this row in the iAssembly table.

Visual Basic
Property MemberName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.MemberName Property


iAssemblyTableRow.Parent Property

iAssemblyTableRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent iAssemblyFactory object.

Visual Basic
Property Parent() As iAssemblyFactory**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.Parent Property


iAssemblyTableRow.Type Property

iAssemblyTableRow.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyTableRowObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRow Interface > iAssemblyTableRow Properties > iAssemblyTableRow.Type Property


iAssemblyTableRows Interface

iAssemblyTableRows Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iAssemblyTableRows collection object provides access to all existing iAssemblyTableRow objects in the iAssembly factory table.

Class Hierarchy
Inventor::iAssemblyTableRows
Visual Basic
Public Interface iAssemblyTableRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iAssemblyFactory.TableRows

You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface


iAssemblyTableRows Methods

iAssemblyTableRows Methods
Summary

The methods of the iAssemblyTableRows class are listed here.

Methods
Methods
Name | Description
Item | Returns an item from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface > iAssemblyTableRows Methods


iAssemblyTableRows.Item Method

iAssemblyTableRows.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an item from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iAssemblyTableRow*)
Parameters
Parameters | Description
index | Value that specifies the iAssemblyTableRow to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the member name. If an out of range index or a name of a non-existent iAssemblyTableRow is provided, an error will occur. This index value is not the same as the index value indicated in the user interface dialog. Rows in the dialog may be re-ordered.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface > iAssemblyTableRows Methods > iAssemblyTableRows.Item Method


iAssemblyTableRows Properties

iAssemblyTableRows Properties
Summary

The properties of the iAssemblyTableRows class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that specifies the number of items in the collection.
Type | Property returning kiAssemblyTableRowsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface > iAssemblyTableRows Properties


iAssemblyTableRows.Application Property

iAssemblyTableRows.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface > iAssemblyTableRows Properties > iAssemblyTableRows.Application Property


iAssemblyTableRows.Count Property

iAssemblyTableRows.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface > iAssemblyTableRows Properties > iAssemblyTableRows.Count Property


iAssemblyTableRows.Type Property

iAssemblyTableRows.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kiAssemblyTableRowsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iAssemblyTableRows Interface > iAssemblyTableRows Properties > iAssemblyTableRows.Type Property


iFeature Interface

iFeature Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeature object represents the instance of a placed iFeature.

Class Hierarchy
Inventor::PartFeature
    Inventor::ReferenceFeature
        Inventor::iFeature
            Inventor::iFeatureProxy
Visual Basic
Public Interface iFeature
Inherits ReferenceFeature
Remarks

Prior to Inventor 2009 an iFeature instance was represented in the API by a combination of the ReferenceFeature and iFeatureComponent objects. The iFeature object is derived from the ReferenceFeature class (which is derived from PartFeature) in order to provide backward compatibility.

Notes

Members through which this object may be accessed include:

iFeatureProxy.NativeObject

iFeatures.Add

iFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > iFeature Interface


iFeature Properties

iFeature Properties
Summary

The properties of the iFeature class are listed here.

Properties
Name | Description
iFeatureDefinition | Property that returns the associated iFeatureDefinition.
iFeatureTemplateDescriptor | Property that returns the iFeatureTemplateDescriptor object associated with this iFeature.
Sketches | Property that returns the sketches that were created when the iFeature was placed. In most case there will be a single sketch.
You are here: Symbol Reference > Inventor Library > Objects > iFeature Interface > iFeature Properties


iFeature.iFeatureDefinition Property

iFeature.iFeatureDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the associated iFeatureDefinition.

Visual Basic
Property iFeatureDefinition() As iFeatureDefinition**
Remarks

An existing iFeature can be edited by accessing the information associated with the iFeatureDefinition object.

See Also

Changing row of table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeature Interface > iFeature Properties > iFeature.iFeatureDefinition Property


iFeature.iFeatureTemplateDescriptor Property

iFeature.iFeatureTemplateDescriptor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the iFeatureTemplateDescriptor object associated with this iFeature.

Visual Basic
Property iFeatureTemplateDescriptor() As iFeatureTemplateDescriptor**
Remarks

The iFeatureTemplateDescriptor object describes the iFeature file that was used to create the iFeature.

You are here: Symbol Reference > Inventor Library > Objects > iFeature Interface > iFeature Properties > iFeature.iFeatureTemplateDescriptor Property


iFeature.Sketches Property

iFeature.Sketches Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the sketches that were created when the iFeature was placed. In most case there will be a single sketch.

Visual Basic
Property Sketches() As SketchesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > iFeature Interface > iFeature Properties > iFeature.Sketches Property


iFeatureDefinition Interface

iFeatureDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureDefinition object represents the positional and parameter information of an iFeature.

Class Hierarchy
Inventor::iFeatureDefinition
Visual Basic
Public Interface iFeatureDefinition
Inherits IDispatch
Remarks

The iFeatureDefinition object is used to describe and specify the parameters and geometry necessary for the placement of an iFeature. It is also used to describe the current parameters and geometry an existing iFeature is dependent on. Editing the iFeatureDefinition object obtained from an existing iFeature instance will result in an edit to the iFeature instance. An update of the model is required after any changes.

Notes

Members through which this object may be accessed include:

iFeature.iFeatureDefinition

iFeatureComponent.Definition

iFeatureComponents.CreateDefinition

iFeatures.CreateiFeatureDefinition

PunchToolFeature.iFeatureDefinition

PunchToolFeatures.CreateiFeatureDefinition

See Also

Add a punch tool feature sample

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface


iFeatureDefinition Properties

iFeatureDefinition Properties
Summary

The properties of the iFeatureDefinition class are listed here.

Properties
Name | Description
ActiveTableRow | Property that specifies the row from the table that should be used to specify the sizes for the iFeature instances.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
iFeatureInputs | Property that indicates the input information of the iFeature.
iFeatureTable | Property that returns the table information associated with this iFeature.
IsPunchTool | Property that specifies if this iFeature has been defined to be used as a punch tool.
IsTableDriven | Property that specifies if this iFeature is driven by a table.
PunchId | Property that returns the PunchID associated with this iFeature.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties


iFeatureDefinition.ActiveTableRow Property

iFeatureDefinition.ActiveTableRow Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the row from the table that should be used to specify the sizes for the iFeature instances.

Visual Basic
Property ActiveTableRow() As iFeatureTableRow*
Remarks

This property is only valid when the iFeature is table driven, (the IsTableDriven property returns True). If the iFeature is not table driven this property returns Nothing.

When The iFeatureDefinition object is created using the CreateiFeatureDefinition this method this is initialized with the default row as defined in the .ide file.

See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.ActiveTableRow Property


iFeatureDefinition.Application Property

iFeatureDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.Application Property


iFeatureDefinition.iFeatureInputs Property

iFeatureDefinition.iFeatureInputs Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the input information of the iFeature.

Visual Basic
Property iFeatureInputs() As iFeatureInputs**
See Also

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.iFeatureInputs Property


iFeatureDefinition.iFeatureTable Property

iFeatureDefinition.iFeatureTable Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the table information associated with this iFeature.

Visual Basic
Property iFeatureTable() As iFeatureTable**
Remarks

If this iFeature is not table driven this property will return Nothing.

See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.iFeatureTable Property


iFeatureDefinition.IsPunchTool Property

iFeatureDefinition.IsPunchTool Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if this iFeature has been defined to be used as a punch tool.

Visual Basic
Property IsPunchTool() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.IsPunchTool Property


iFeatureDefinition.IsTableDriven Property

iFeatureDefinition.IsTableDriven Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if this iFeature is driven by a table.

Visual Basic
Property IsTableDriven() As VARIANT_BOOL*
See Also

Changing row of table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.IsTableDriven Property


iFeatureDefinition.PunchId Property

iFeatureDefinition.PunchId Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the PunchID associated with this iFeature.

Visual Basic
Property PunchId() As BSTR*
Remarks

This property is only valid in the case where the IsPunchTool property returns True. Even in the case where IsPunchTool is True this can still return an empty string when no punch ID has been defined.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.PunchId Property


iFeatureDefinition.Type Property

iFeatureDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureDefinition Interface > iFeatureDefinition Properties > iFeatureDefinition.Type Property


iFeatureEntityInput Interface

iFeatureEntityInput Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureEntityInput object represents the positional information of an iFeature. The iFeatureEntityInput object is used both to describe and specify the geometry necessary for the placement of an iFeature.

Class Hierarchy
Inventor::iFeatureInput
    Inventor::iFeatureEntityInput
Visual Basic
Public Interface iFeatureEntityInput
Inherits iFeatureInput
You are here: Symbol Reference > Inventor Library > Objects > iFeatureEntityInput Interface


iFeatureEntityInput Properties

iFeatureEntityInput Properties
Summary

The properties of the iFeatureEntityInput class are listed here.

Properties
Name | Description
Entity | Property that gets and sets the position geometry matching the EntityType.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureEntityInput Interface > iFeatureEntityInput Properties


iFeatureEntityInput.Entity Property

iFeatureEntityInput.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the position geometry matching the EntityType.

Visual Basic
Property Entity() As IDispatch*
Remarks

This property will fail in the case where the iFeatureEntityInput object is was obtained from an existing iFeature.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureEntityInput Interface > iFeatureEntityInput Properties > iFeatureEntityInput.Entity Property


iFeatureInput Interface

iFeatureInput Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureInput object is the base class for iFeatureParameterInput, iFeatureEntityInput, iFeatureSketchPlaneInput, iFeatureWorkPlaneInput and iFeatureVectorInput.

Class Hierarchy
Inventor::iFeatureInput
    Inventor::iFeatureEntityInput
    Inventor::iFeatureParameterInput
    Inventor::iFeatureSketchPlaneInput
    Inventor::iFeatureVectorInput
    Inventor::iFeatureWorkPlaneInput
Visual Basic
Public Interface iFeatureInput
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureInputs.Item

See Also

Add a punch tool feature sample

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface


iFeatureInput Properties

iFeatureInput Properties
Summary

The properties of the iFeatureInput class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EntityType | Property that returns the type of geometry that are valid. The value returned is the sum of values specifying the valid entity types.
Name | Property that gets the name associated with this input. When placing an iFeature using the API you can use the name to identify each input when assigning the desired values and entities.
Prompt | Property that gets the prompt that is used for this input during the placement of the iFeature.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface > iFeatureInput Properties


iFeatureInput.Application Property

iFeatureInput.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface > iFeatureInput Properties > iFeatureInput.Application Property


iFeatureInput.EntityType Property

iFeatureInput.EntityType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the type of geometry that are valid. The value returned is the sum of values specifying the valid entity types.

Visual Basic
Property EntityType() As iFeatureEntityInputTypeEnum*
Remarks

You can use bitwise operations to check for specific types as shown below.

If (oFeature.EntityType And kiFeatureEntityInputTypeCylindricalSurface) = kiFeatureEntityInputTypeCylindricalSurface Then
  MsgBox "Uses Cylinder"
End If
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface > iFeatureInput Properties > iFeatureInput.EntityType Property


iFeatureInput.Name Property

iFeatureInput.Name Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the name associated with this input. When placing an iFeature using the API you can use the name to identify each input when assigning the desired values and entities.

Visual Basic
Property Name() As BSTR*
See Also

Add a punch tool feature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface > iFeatureInput Properties > iFeatureInput.Name Property


iFeatureInput.Prompt Property

iFeatureInput.Prompt Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the prompt that is used for this input during the placement of the iFeature.

Visual Basic
Property Prompt() As BSTR*
Remarks

When placing an iFeature using the API you can use the prompt string to identify each input when assigning the desired values and entities.

Not all of the types of iFeature input objects have a prompt so this can return an empty string.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface > iFeatureInput Properties > iFeatureInput.Prompt Property


iFeatureInput.Type Property

iFeatureInput.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInput Interface > iFeatureInput Properties > iFeatureInput.Type Property


iFeatureInputs Interface

iFeatureInputs Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureInputs collection object provides access to all of the / iFeatureParameterInput objects associated with a specific iFeatureDefinition object.

Class Hierarchy
Inventor::iFeatureInputs
Visual Basic
Public Interface iFeatureInputs
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureDefinition.iFeatureInputs

You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface


iFeatureInputs Methods

iFeatureInputs Methods
Summary

The methods of the iFeatureInputs class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object in the collection.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface > iFeatureInputs Methods


iFeatureInputs.Item Method

iFeatureInputs.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] iFeatureInput*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface > iFeatureInputs Methods > iFeatureInputs.Item Method


iFeatureInputs Properties

iFeatureInputs Properties
Summary

The properties of the iFeatureInputs class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface > iFeatureInputs Properties


iFeatureInputs.Application Property

iFeatureInputs.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface > iFeatureInputs Properties > iFeatureInputs.Application Property


iFeatureInputs.Count Property

iFeatureInputs.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface > iFeatureInputs Properties > iFeatureInputs.Count Property


iFeatureInputs.Type Property

iFeatureInputs.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureInputs Interface > iFeatureInputs Properties > iFeatureInputs.Type Property


iFeatureOptions Interface

iFeatureOptions Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The iFeatureOptions object provides access to properties that provide read and write access of the iFeature related application options. This is somewhat equivalent to the iFeature tab of the Application Options dialog.

Class Hierarchy
Inventor::iFeatureOptions
Visual Basic
Public Interface iFeatureOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.iFeatureOptions

You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface


iFeatureOptions Properties

iFeatureOptions Properties
Summary

The properties of the iFeatureOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
RootPath | Property that gets and sets the location of iFeature files used by the View Catalog dialog box. The location can be on your local computer or on a network drive accessed by other users.
SheetMetalPunchesRootPath | Property that gets and sets the location of iFeature files used by the sheet metal Punch Tool dialog box. The location can be on your local computer or on a network drive accessed by other users.
Type | Returns an ObjectTypeEnum indicating this object's type.
UseKey1AsBrowserNameColumn | Property that gets and sets whether to use the Key 1 column of a table-driven iFeature as the Browser Name column. If set to True, the name and value of Key 1 is suffixed to the name of the iFeature in the browser for easier identification.
UserRootPath | Property that gets and sets the location of iFeature files used by both the Create iFeature and Insert iFeature dialog boxes. The location can be on your local computer or on a network drive accessed by other users.
Viewer | Property that gets and sets the viewer application used to manage the iFeature files. The value of this property is the name of the executable file for the viewer application. The default is 'explorer' for Windows Explorer.
ViewerArguments | Property that gets and sets the viewer command line arguments for run-time options. The default is /n. Windows Explorer opens with the folder specified in the iFeature Root box.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties


iFeatureOptions.Application Property

iFeatureOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.Application Property


iFeatureOptions.RootPath Property

iFeatureOptions.RootPath Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the location of iFeature files used by the View Catalog dialog box. The location can be on your local computer or on a network drive accessed by other users.

Visual Basic
Property RootPath() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.RootPath Property


iFeatureOptions.SheetMetalPunchesRootPath Property

iFeatureOptions.SheetMetalPunchesRootPath Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the location of iFeature files used by the sheet metal Punch Tool dialog box. The location can be on your local computer or on a network drive accessed by other users.

Visual Basic
Property SheetMetalPunchesRootPath() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.SheetMetalPunchesRootPath Property


iFeatureOptions.Type Property

iFeatureOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.Type Property


iFeatureOptions.UseKey1AsBrowserNameColumn Property

iFeatureOptions.UseKey1AsBrowserNameColumn Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use the Key 1 column of a table-driven iFeature as the Browser Name column. If set to True, the name and value of Key 1 is suffixed to the name of the iFeature in the browser for easier identification.

Visual Basic
Property UseKey1AsBrowserNameColumn() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.UseKey1AsBrowserNameColumn Property


iFeatureOptions.UserRootPath Property

iFeatureOptions.UserRootPath Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the location of iFeature files used by both the Create iFeature and Insert iFeature dialog boxes. The location can be on your local computer or on a network drive accessed by other users.

Visual Basic
Property UserRootPath() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.UserRootPath Property


iFeatureOptions.Viewer Property

iFeatureOptions.Viewer Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the viewer application used to manage the iFeature files. The value of this property is the name of the executable file for the viewer application. The default is 'explorer' for Windows Explorer.

Visual Basic
Property Viewer() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.Viewer Property


iFeatureOptions.ViewerArguments Property

iFeatureOptions.ViewerArguments Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the viewer command line arguments for run-time options. The default is /n. Windows Explorer opens with the folder specified in the iFeature Root box.

Visual Basic
Property ViewerArguments() As String
Remarks

To find out if your viewer application supports command line arguments, refer to the Help for your viewer.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureOptions Interface > iFeatureOptions Properties > iFeatureOptions.ViewerArguments Property


iFeatureParameterInput Interface

iFeatureParameterInput Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureParameterInput object contains the information associated with a parameter of an iFeature.

Class Hierarchy
Inventor::iFeatureInput
    Inventor::iFeatureParameterInput
Visual Basic
Public Interface iFeatureParameterInput
Inherits iFeatureInput
See Also

Add a punch tool feature sample

Add a punch tool feature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface


iFeatureParameterInput Methods

iFeatureParameterInput Methods
Summary

The methods of the iFeatureParameterInput class are listed here.

Methods
Methods
Name | Description
LimitListExpressions | Method that gets the expressions of the LimitType kParamLimitList. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.
LimitRangeExpressions | Method that gets the expressions of the LimitType kParamLimitRange. If the LeftLimitValue and LeftRangeSpec strings are NULL, there is no lower limit for the values that the user can enter. Similarly if the RightLimitValue and RightRangeSpec strings are NULL, there is no upper limit for the values that the user can enter. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Methods


iFeatureParameterInput.LimitListExpressions Method

iFeatureParameterInput.LimitListExpressions Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that gets the expressions of the LimitType kParamLimitList. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.

Visual Basic
Sub LimitListExpressions(Index As long, Result As [out, retval] BSTR)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the expression to return.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Methods > iFeatureParameterInput.LimitListExpressions Method


iFeatureParameterInput.LimitRangeExpressions Method

iFeatureParameterInput.LimitRangeExpressions Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that gets the expressions of the LimitType kParamLimitRange. If the LeftLimitValue and LeftRangeSpec strings are NULL, there is no lower limit for the values that the user can enter. Similarly if the RightLimitValue and RightRangeSpec strings are NULL, there is no upper limit for the values that the user can enter. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.

Visual Basic
Sub LimitRangeExpressions(ByRef LeftLimitValue As String, ByRef LeftRangeSpec As String, ByRef RightRangeSpec As String, ByRef RightLimitValue As String)
Parameters
Parameters | Description
LeftLimitValue | Output String that contains the expression of the lower limit value. If an empty string is returned then there is no lower limit.
LeftRangeSpec | Output String that contains the comparison operator used for the lower range. If an empty string is returned then there is no lower limit.
RightRangeSpec | Output String that contains the expression of the upper limit value. If an empty string is returned then there is no upper limit.
RightLimitValue | Output String that contains the comparison operator used for the upper range. If an empty string is returned then there is no upper limit.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Methods > iFeatureParameterInput.LimitRangeExpressions Method


iFeatureParameterInput Properties

iFeatureParameterInput Properties
Summary

The properties of the iFeatureParameterInput class are listed here.

Properties
Name | Description
DefaultExpression | Property that gets the expression which specifies the default value and unit. This is the default value of the Expression property. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.
Expression | Property that gets and sets the expression of the parameter. When an iFeature is created, the expression is initialized to the DefaultExpression. This property will fail in the case where the iFeatureParameterDefinition object is associated with an iFeature instance.
IsPunchToolDepth | Property specifies if this parameter input is used to define the custom depth of a punch tool.
LimitListCount | Property that returns the number of limit values if the LimitType is kParamLimitList. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.
LimitType | Property that returns the limit type of the parameter. If this returns kParamLimitRange, the LimitExpression property will return the upper and lower limits will be two limit values: the value of the lower and upper bounds. If the LimitType property is kParamLimitList there will be n values. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.
Parameter | Property that returns the parameter in the model this iFeature parameter is dependent on. This property will return Nothing in the case where the iFeatureDefinition object is not associated with an iFeature instance.
Value | Property that allows you to get and set the value of the parameter. This value is always represented in database units. When setting the value, the expression will be replaced.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties


iFeatureParameterInput.DefaultExpression Property

iFeatureParameterInput.DefaultExpression Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the expression which specifies the default value and unit. This is the default value of the Expression property. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.

Visual Basic
Property DefaultExpression() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.DefaultExpression Property


iFeatureParameterInput.Expression Property

iFeatureParameterInput.Expression Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the expression of the parameter. When an iFeature is created, the expression is initialized to the DefaultExpression. This property will fail in the case where the iFeatureParameterDefinition object is associated with an iFeature instance.

Visual Basic
Property Expression() As String
See Also

Add a punch tool feature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.Expression Property


iFeatureParameterInput.IsPunchToolDepth Property

iFeatureParameterInput.IsPunchToolDepth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property specifies if this parameter input is used to define the custom depth of a punch tool.

Visual Basic
Property IsPunchToolDepth() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.IsPunchToolDepth Property


iFeatureParameterInput.LimitListCount Property

iFeatureParameterInput.LimitListCount Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of limit values if the LimitType is kParamLimitList. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.

Visual Basic
Property LimitListCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.LimitListCount Property


iFeatureParameterInput.LimitType Property

iFeatureParameterInput.LimitType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the limit type of the parameter. If this returns kParamLimitRange, the LimitExpression property will return the upper and lower limits will be two limit values: the value of the lower and upper bounds. If the LimitType property is kParamLimitList there will be n values. This property will fail in the case where the iFeatureDefinition object is associated with an iFeature instance.

Visual Basic
Property LimitType() As iFeatureParamLimitTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.LimitType Property


iFeatureParameterInput.Parameter Property

iFeatureParameterInput.Parameter Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parameter in the model this iFeature parameter is dependent on. This property will return Nothing in the case where the iFeatureDefinition object is not associated with an iFeature instance.

Visual Basic
Property Parameter() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.Parameter Property


iFeatureParameterInput.Value Property

iFeatureParameterInput.Value Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that allows you to get and set the value of the parameter. This value is always represented in database units. When setting the value, the expression will be replaced.

Visual Basic
Property Value() As double
You are here: Symbol Reference > Inventor Library > Objects > iFeatureParameterInput Interface > iFeatureParameterInput Properties > iFeatureParameterInput.Value Property


iFeatureProxy Interface

iFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the iFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ReferenceFeature
        Inventor::iFeature
            Inventor::iFeatureProxy
Visual Basic
Public Interface iFeatureProxy
Inherits iFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureProxy Interface


iFeatureProxy Properties

iFeatureProxy Properties
Summary

The properties of the iFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureProxy Interface > iFeatureProxy Properties


iFeatureProxy.ContainingOccurrence Property

iFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > iFeatureProxy Interface > iFeatureProxy Properties > iFeatureProxy.ContainingOccurrence Property


iFeatureProxy.NativeObject Property

iFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > iFeatureProxy Interface > iFeatureProxy Properties > iFeatureProxy.NativeObject Property


iFeatures Interface

iFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatures collection object provides access to all of the iFeature objects in a part component definition and provides methods to create additional iFeatures..

Class Hierarchy
Inventor::iFeatures
Visual Basic
Public Interface iFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPatternFeatures.iFeatures

PartFeatures.iFeatures

Example

"Placementof a standard iFeature"

This program demonstrates the placement of a standard iFeature in a part. A part must be open and a planar face within that part selected. The iFeature used is delivered as a sample with Inventor.

Public Sub PlaceiFeature()
    ' Get the part document and component definition of the active document.
    On Error Resume Next
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    If Err Then
        MsgBox "A part must be active."
        Exit Sub
    End If

    Dim oPartDef As PartComponentDefinition
    Set oPartDef = oPartDoc.ComponentDefinition

    ' Get the selected face to use as input for the iFeature.
    Dim oFace As Face
    Set oFace = oPartDoc.SelectSet.Item(1)
    If Err Then
        MsgBox "A planar face must be selected."
        Exit Sub
    End If
    On Error GoTo 0

    If oFace.SurfaceType  kPlaneSurface Then
        MsgBox "A planar face must be selected."
        Exit Sub
    End If

    Dim oFeatures As PartFeatures
    Set oFeatures = oPartDef.Features

    ' Create an iFeatureDefinition object.
    Dim oiFeatureDef As iFeatureDefinition
    Set oiFeatureDef = oFeatures.iFeatures.CreateiFeatureDefinition( _
"C:\Program Files\Autodesk\Inventor 2010\Catalog\Slots\End_mill_curved.ide")

    ' Set the input.
    Dim oInput As iFeatureInput
    For Each oInput In oiFeatureDef.iFeatureInputs
        Dim oParamInput As iFeatureParameterInput
        Select Case oInput.Name
            Case "Sketch Plane"
                Dim oPlaneInput As iFeatureSketchPlaneInput
                Set oPlaneInput = oInput
                oPlaneInput.PlaneInput = oFace
            Case "Diameter"
                Set oParamInput = oInput
                oParamInput.Expression = "1 in"
            Case "Depth"
                Set oParamInput = oInput
                oParamInput.Expression = "0.5 in"
        End Select
    Next

    ' Create the iFeature.
    Dim oiFeature As iFeature
    Set oiFeature = oFeatures.iFeatures.Add(oiFeatureDef)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface


iFeatures Methods

iFeatures Methods
Summary

The methods of the iFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new iFeature using the input placement information. If successfully created the new iFeature is returned.
CreateiFeatureDefinition | Method that creates a new iFeatrureDefinition. The returned definition provides access to all of the inputs that are necessary for placing an iFeature. Using this object you provide the parameter and the geometry inputs necessary for placing the iFeature.
Item | Property that returns the specified iFeature object from the collection..
You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Methods


iFeatures.Add Method

iFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new iFeature using the input placement information. If successfully created the new iFeature is returned.

Visual Basic
Sub Add(Definition As iFeatureDefinition, Result As [out, retval] iFeature*)
Parameters
Parameters | Description
Definition | Input iFeatureDefinition object used to define the various input required for the placement of an iFeature. Appropriate input must be defined in the iFeatureDefinition object in order to place the iFeature.
See Also

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Methods > iFeatures.Add Method


iFeatures.CreateiFeatureDefinition Method

iFeatures.CreateiFeatureDefinition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new iFeatrureDefinition. The returned definition provides access to all of the inputs that are necessary for placing an iFeature. Using this object you provide the parameter and the geometry inputs necessary for placing the iFeature.

Visual Basic
Sub CreateiFeatureDefinition(FullFileName As String, Result As [out, retval] iFeatureDefinition*)
Parameters
Parameters | Description
FullFileName | Input string that specifies the name of the iFeature file (.ide) to create the definition for. The file must be an existing iFeature file. If an invalid file is specified an error will occur.
See Also

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Methods > iFeatures.CreateiFeatureDefinition Method


iFeatures.Item Method

iFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified iFeature object from the collection..

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iFeature*)
Parameters
Parameters | Description
index | Input Long or String value that specifies the iFeature to return. If a Long is input then it is the index of the item to return. If a String is input then it must match the name of an existing iFeature. If the index is out of range or the name does not exist a failure will occur.
See Also

Changing row of table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Methods > iFeatures.Item Method


iFeatures Properties

iFeatures Properties
Summary

The properties of the iFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Properties


iFeatures.Application Property

iFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Properties > iFeatures.Application Property


iFeatures.Count Property

iFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Properties > iFeatures.Count Property


iFeatures.Type Property

iFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatures Interface > iFeatures Properties > iFeatures.Type Property


iFeatureSketchPlaneInput Interface

iFeatureSketchPlaneInput Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureSketchPlaneInput object represents the sketch plane input information of an iFeature. The iFeatureSketchPlaneInput object is used specify the geometry's and other data necessary for the sketch plane input of an iFeature.

Class Hierarchy
Inventor::iFeatureInput
    Inventor::iFeatureSketchPlaneInput
Visual Basic
Public Interface iFeatureSketchPlaneInput
Inherits iFeatureInput
See Also

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureSketchPlaneInput Interface


iFeatureSketchPlaneInput Methods

iFeatureSketchPlaneInput Methods
Summary

The methods of the iFeatureSketchPlaneInput class are listed here.

Methods
Methods
Name | Description
SetPosition | Method that sets the position of the iFeature on the plane provided.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureSketchPlaneInput Interface > iFeatureSketchPlaneInput Methods


iFeatureSketchPlaneInput.SetPosition Method

iFeatureSketchPlaneInput.SetPosition Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the position of the iFeature on the plane provided.

Visual Basic
Sub SetPosition(Point As Point, Axis As Vector, RotationAngle As double)
Parameters
Parameters | Description
Point | Input object that specifies the 3D location of the iFeature on the plane.
Axis | Specifies the vector along which the X-axis of iFeature will be aligned.
RotationAngle | Specifies the angle in radians by which the axis will be rotated about a vector perpendicular to the plane used for placing the iFeature.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureSketchPlaneInput Interface > iFeatureSketchPlaneInput Methods > iFeatureSketchPlaneInput.SetPosition Method


iFeatureSketchPlaneInput Properties

iFeatureSketchPlaneInput Properties
Summary

The properties of the iFeatureSketchPlaneInput class are listed here.

Properties
Name | Description
FlipOption | Property that gets and gets the Boolean indicating whether direction of the selection needs to be flipped.
PlaneInput | Property that sets and gets the entity matching the kSketchObject. Valid entity types are kSketchObject, kWorkPlaneObject and kEdgeObject. This property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureSketchPlaneInput Interface > iFeatureSketchPlaneInput Properties


iFeatureSketchPlaneInput.FlipOption Property

iFeatureSketchPlaneInput.FlipOption Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and gets the Boolean indicating whether direction of the selection needs to be flipped.

Visual Basic
Property FlipOption() As VARIANT_BOOL
Remarks

Setting this property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance. Setting this property will also fail if the direction of the sketch plane input cannot be flipped. For instance, the direction cannot be flipped if the input plane is a face, but it can be if the input plane is a work plane.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureSketchPlaneInput Interface > iFeatureSketchPlaneInput Properties > iFeatureSketchPlaneInput.FlipOption Property


iFeatureSketchPlaneInput.PlaneInput Property

iFeatureSketchPlaneInput.PlaneInput Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that sets and gets the entity matching the kSketchObject. Valid entity types are kSketchObject, kWorkPlaneObject and kEdgeObject. This property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance.

Visual Basic
Property PlaneInput() As IDispatch*
See Also

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureSketchPlaneInput Interface > iFeatureSketchPlaneInput Properties > iFeatureSketchPlaneInput.PlaneInput Property


iFeatureTable Interface

iFeatureTable Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatureTable object represents the table associated with a table driven iFeature. This object provides access to the contents of the table and provides information about the default and active rows.

Class Hierarchy
Inventor::iFeatureTable
Visual Basic
Public Interface iFeatureTable
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureDefinition.iFeatureTable

iFeatureTableCell.Parent

iFeatureTableColumn.Parent

iFeatureTableRow.Parent

Example

Place table driven iFeature

This program demonstrates the placement of a table driven iFeature in a part. A part must be open and a planar face on that part selected. There aren't any table driven .ide files delivered with Inventor so one must be constructed to be used as input. The primary assumption this sample makes about the Test.ide file is that a custom row has been created named 'Size' and one of the rows in this column has the value '4.5.'

Public Sub PlaceTableDriveniFeature()
    ' Get the part document and component definition of the active document.
    On Error Resume Next
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    If Err Then
        MsgBox "A part must be active."
        Exit Sub
    End If

    Dim oPartDef As PartComponentDefinition
    Set oPartDef = oPartDoc.ComponentDefinition

    ' Get the selected face to use as input for the iFeature.
    Dim oFace As Face
    Set oFace = oPartDoc.SelectSet.Item(1)
    If Err Then
        MsgBox "A planar face must be selected."
        Exit Sub
    End If
    On Error GoTo 0

    If oFace.SurfaceType <> kPlaneSurface Then
        MsgBox "A planar face must be selected."
        Exit Sub
    End If

    Dim oFeatures As PartFeatures
    Set oFeatures = oPartDef.Features

    ' Create an iFeatureDefinition object based on a previously-created table-driven IDE file.
    ' This code assumes the IDE file has a custom row named 'Size' and one of the columns
    ' in this row has the value '4.5'.
    Dim oiFeatureDef As iFeatureDefinition
    Set oiFeatureDef = oFeatures.iFeatures.CreateiFeatureDefinition("C:\MyTestSample\Test.ide")

    ' Set the input, which in this case is only the sketch plane
    ' since the other input comes from the table.  The parameter input
    ' should not be available at this point since it can't be changed
    ' and is controlled by the table.
    '
    ' When an existing table driven iFeature is accessed then this should
    ' include the parameters so the programmer has access to the corresponding
    ' reference parameter that's created.
    Dim bFoundPlaneInput As Boolean
    bFoundPlaneInput = False
    Dim oInput As iFeatureInput
    For Each oInput In oiFeatureDef.iFeatureInputs
        Dim oParamInput As iFeatureParameterInput
        Select Case oInput.Name
            Case "Profile Plane1"
                Dim oPlaneInput As iFeatureSketchPlaneInput
                Set oPlaneInput = oInput
                oPlaneInput.PlaneInput = oFace
                bFoundPlaneInput = True
        End Select
    Next

    If Not bFoundPlaneInput Then
        MsgBox "The ide file does not contain an iFeature input named ""Profile Plane1""."
        Exit Sub
    End If

    '** Look through the table to find the row where "Size" is "4.5".
    Dim oTable As iFeatureTable
    Set oTable = oiFeatureDef.iFeatureTable

    ' Find the "Size" column.
    Dim oColumn As iFeatureTableColumn
    Dim bFoundSize As Boolean
    bFoundSize = False
    For Each oColumn In oTable.iFeatureTableColumns
        If oColumn.DisplayHeading = "Size" Then
            bFoundSize = True
            Exit For
        End If
    Next

    If Not bFoundSize Then
        MsgBox "The column ""Size"" was not found."
        Exit Sub
    End If

    ' Find the row in the "Size" column with the value of "4.5"
    Dim oCell As iFeatureTableCell
    bFoundSize = False
    For Each oCell In oColumn
        If oCell.Value = "4.5" Then
            bFoundSize = True
            Exit For
        End If
    Next

    If Not bFoundSize Then
        MsgBox "The cell with value ""4.5"" was not found."
        Exit Sub
    End If

    ' Set this row as the active row.
    oiFeatureDef.ActiveTableRow = oCell.Row

    ' Create the iFeature.
    Dim oiFeature As iFeature
    Set oiFeature = oFeatures.iFeatures.Add(oiFeatureDef)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface


iFeatureTable Methods

iFeatureTable Methods
Summary

The methods of the iFeatureTable class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the iFeatureTable. This converts a table driven iFeature into a standard iFeature.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Methods


iFeatureTable.Delete Method

iFeatureTable.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the iFeatureTable. This converts a table driven iFeature into a standard iFeature.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Methods > iFeatureTable.Delete Method


iFeatureTable Properties

iFeatureTable Properties
Summary

The properties of the iFeatureTable class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DefaultRow | Property that gets and sets the default row.
ExcelWorkSheet | Property that returns the Excel WorkSheet object representing the iFeature table. After making changes to the Excel sheet, save and close the parent WorkBook object of the sheet in order for Inventor to absorb the changes.
iFeatureTableColumns | Property returning the collection of columns in the table.
iFeatureTableRows | Property returning the collection of rows in the table.
Parent | Property returning the parent object.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties


iFeatureTable.Application Property

iFeatureTable.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.Application Property


iFeatureTable.DefaultRow Property

iFeatureTable.DefaultRow Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the default row.

Visual Basic
Property DefaultRow() As iFeatureTableRow*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.DefaultRow Property


iFeatureTable.ExcelWorkSheet Property

iFeatureTable.ExcelWorkSheet Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the Excel WorkSheet object representing the iFeature table. After making changes to the Excel sheet, save and close the parent WorkBook object of the sheet in order for Inventor to absorb the changes.

Visual Basic
Property ExcelWorkSheet() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.ExcelWorkSheet Property


iFeatureTable.iFeatureTableColumns Property

iFeatureTable.iFeatureTableColumns Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the collection of columns in the table.

Visual Basic
Property iFeatureTableColumns() As iFeatureTableColumns**
See Also

Place table driven iFeature sample

Example

"Changing row of table driven iFeature"

This program demonstrates the edit of a table driven iFeature to change which row of the table is being used to drive the iFeature.

Public Sub EditTableDriveniFeature()
    ' Get the part document and component definition of the active document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    If Err Then
        MsgBox "A part must be active."
        Exit Sub
    End If

    Dim oFeatures As PartFeatures
    Set oFeatures = oPartDoc.ComponentDefinition.Features

    ' Get the first iFeature assuming that it is table-driven.
    Dim oiFeature As iFeature
    Set oiFeature = oFeatures.iFeatures.Item(1)

    ' Check to see if the first iFeature is table-driven.
    If Not oiFeature.iFeatureDefinition.IsTableDriven Then
        MsgBox "The first iFeature in the part is not table-driven."
        Exit Sub
    End If

    '** Look through the table to find the row where "Size" is "3".
    Dim oTable As iFeatureTable
    Set oTable = oiFeature.iFeatureDefinition.iFeatureTable

    ' Find the "Size" column.
    Dim oColumn As iFeatureTableColumn
    Dim bFoundSize As Boolean
    bFoundSize = False
    For Each oColumn In oTable.iFeatureTableColumns
        If oColumn.DisplayHeading = "Size" Then
            bFoundSize = True
            Exit For
        End If
    Next

    If Not bFoundSize Then
        MsgBox "The column ""Size"" was not found."
        Exit Sub
    End If

    ' Find the row in the "Size" column with the value of "3"
    Dim oCell As iFeatureTableCell
    bFoundSize = False
    For Each oCell In oColumn
        If oCell.Value = "3" Then
            bFoundSize = True
            Exit For
        End If
    Next

    If Not bFoundSize Then
        MsgBox "The cell with value ""3"" was not found."
        Exit Sub
    End If

    oiFeature.iFeatureDefinition.ActiveTableRow = oCell.Row
End Sub
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.iFeatureTableColumns Property


iFeatureTable.iFeatureTableRows Property

iFeatureTable.iFeatureTableRows Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the collection of rows in the table.

Visual Basic
Property iFeatureTableRows() As iFeatureTableRows**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.iFeatureTableRows Property


iFeatureTable.Parent Property

iFeatureTable.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the parent object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.Parent Property


iFeatureTable.Type Property

iFeatureTable.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTable Interface > iFeatureTable Properties > iFeatureTable.Type Property


iFeatureTableCell Interface

iFeatureTableCell Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatureTableCell object represents a single cell within a table associated with a table driven iFeature.

Class Hierarchy
Inventor::iFeatureTableCell
Visual Basic
Public Interface iFeatureTableCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureTableColumn.Item

iFeatureTableRow.Item

See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface


iFeatureTableCell Properties

iFeatureTableCell Properties
Summary

The properties of the iFeatureTableCell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Column | Property that returns the column this cell is within.
CustomCell | Property that gets and sets whether this is a custom parameter cell. Setting this property to True will fail if this cell is within a 'Key' column (i.e. the Key property of the column does not return 0).
CustomIncrement | Property that gets and sets the increment value for custom parameter cell. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).
CustomRangeMaximum | Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).
CustomRangeMinimum | Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).
HasFormula | Gets whether a formula (equation) was input into this cell via Excel.
IsValid | Gets whether the contents of this cell are valid.
Parent | Property that returns the parent iFeatureTable.
Row | Property that returns the row this cell is within.
Type | Property returning an enum indicating the type of object.
Value | Property that gets and sets the value of the cell.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties


iFeatureTableCell.Application Property

iFeatureTableCell.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.Application Property


iFeatureTableCell.Column Property

iFeatureTableCell.Column Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the column this cell is within.

Visual Basic
Property Column() As iFeatureTableColumn**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.Column Property


iFeatureTableCell.CustomCell Property

iFeatureTableCell.CustomCell Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether this is a custom parameter cell. Setting this property to True will fail if this cell is within a 'Key' column (i.e. the Key property of the column does not return 0).

Visual Basic
Property CustomCell() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.CustomCell Property


iFeatureTableCell.CustomIncrement Property

iFeatureTableCell.CustomIncrement Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the increment value for custom parameter cell. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).

Visual Basic
Property CustomIncrement() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.CustomIncrement Property


iFeatureTableCell.CustomRangeMaximum Property

iFeatureTableCell.CustomRangeMaximum Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).

Visual Basic
Property CustomRangeMaximum() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.CustomRangeMaximum Property


iFeatureTableCell.CustomRangeMinimum Property

iFeatureTableCell.CustomRangeMinimum Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).

Visual Basic
Property CustomRangeMinimum() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.CustomRangeMinimum Property


iFeatureTableCell.HasFormula Property

iFeatureTableCell.HasFormula Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether a formula (equation) was input into this cell via Excel.

Visual Basic
Property HasFormula() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.HasFormula Property


iFeatureTableCell.IsValid Property

iFeatureTableCell.IsValid Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether the contents of this cell are valid.

Visual Basic
Property IsValid() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.IsValid Property


iFeatureTableCell.Parent Property

iFeatureTableCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent iFeatureTable.

Visual Basic
Property Parent() As iFeatureTable**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.Parent Property


iFeatureTableCell.Row Property

iFeatureTableCell.Row Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the row this cell is within.

Visual Basic
Property Row() As iFeatureTableRow**
See Also

Changing row of table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.Row Property


iFeatureTableCell.Type Property

iFeatureTableCell.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.Type Property


iFeatureTableCell.Value Property

iFeatureTableCell.Value Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the value of the cell.

Visual Basic
Property Value() As String
See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableCell Interface > iFeatureTableCell Properties > iFeatureTableCell.Value Property


iFeatureTableColumn Interface

iFeatureTableColumn Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatureTableColumn object represents a single column of a table associated with a table driven iFeature.

Class Hierarchy
Inventor::iFeatureTableColumn
Visual Basic
Public Interface iFeatureTableColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureTableCell.Column

iFeatureTableColumns.Item

See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface


iFeatureTableColumn Methods

iFeatureTableColumn Methods
Summary

The methods of the iFeatureTableColumn class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the column from the table.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Methods


iFeatureTableColumn.Delete Method

iFeatureTableColumn.Delete Method
Summary

Method that deletes the column from the table.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Methods > iFeatureTableColumn.Delete Method


iFeatureTableColumn Properties

iFeatureTableColumn Properties
Summary

The properties of the iFeatureTableColumn class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified iFeatureTableCell object from the row.
Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of rows in the column.
CustomColumn | Property that gets and sets whether this is a custom parameter column. Setting this property to True will fail if this is a 'Key' column (i.e. the Key property does not return 0).
CustomIncrement | Property that gets and sets the increment value for custom parameter columns. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).
CustomRangeMaximum | Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).
CustomRangeMinimum | Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).
DisplayHeading | Property that returns the heading of the column as seen in the iFeature author command.
FormattedHeading | Property that returns the heading of the column in XML format.
Heading | Property that returns the heading of the column in XML format.
Index | Property that returns the index of this column within the iFeatureTableColumns collection where the first column has an index of 1.
Key | Property that gets and sets the key order for the column. A value of 0 indicates that this is not a key column. Setting this property to a key value will fail if this is a custom column or if any of the cells within this column is a custom cell.
Parent | Property that returns the parent iFeatureTable.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties


iFeatureTableColumn.Application Property

iFeatureTableColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Application Property


iFeatureTableColumn.Count Property

iFeatureTableColumn.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of rows in the column.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Count Property


iFeatureTableColumn.CustomColumn Property

iFeatureTableColumn.CustomColumn Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether this is a custom parameter column. Setting this property to True will fail if this is a 'Key' column (i.e. the Key property does not return 0).

Visual Basic
Property CustomColumn() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.CustomColumn Property


iFeatureTableColumn.CustomIncrement Property

iFeatureTableColumn.CustomIncrement Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the increment value for custom parameter columns. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).

Visual Basic
Property CustomIncrement() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.CustomIncrement Property


iFeatureTableColumn.CustomRangeMaximum Property

iFeatureTableColumn.CustomRangeMaximum Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).

Visual Basic
Property CustomRangeMaximum() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.CustomRangeMaximum Property


iFeatureTableColumn.CustomRangeMinimum Property

iFeatureTableColumn.CustomRangeMinimum Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).

Visual Basic
Property CustomRangeMinimum() As String
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.CustomRangeMinimum Property


iFeatureTableColumn.DisplayHeading Property

iFeatureTableColumn.DisplayHeading Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the heading of the column as seen in the iFeature author command.

Visual Basic
Property DisplayHeading() As BSTR*
See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.DisplayHeading Property


iFeatureTableColumn.FormattedHeading Property

iFeatureTableColumn.FormattedHeading Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the heading of the column in XML format.

Visual Basic
Property FormattedHeading() As BSTR*
Remarks

The XML data describes additional information associated with this column and can be seen when editing the table as an Excel spreadsheet.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.FormattedHeading Property


iFeatureTableColumn.Heading Property

iFeatureTableColumn.Heading Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the heading of the column in XML format.

Visual Basic
Property Heading() As BSTR*
Remarks

The XML data describes additional information associated with this column and can be seen when editing the table as an Excel spreadsheet. For example, for the material iProperty the value of this property is 'Material [Physical]'.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Heading Property


iFeatureTableColumn.Index Property

iFeatureTableColumn.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this column within the iFeatureTableColumns collection where the first column has an index of 1.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Index Property


iFeatureTableColumn.Item Method

iFeatureTableColumn.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified iFeatureTableCell object from the row.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iFeatureTableCell*)
Parameters
Parameters | Description
index | Value that specifies the index of the iFeatureTableCell to return. The first row in the column has an index of 1.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Item Method


iFeatureTableColumn.Key Property

iFeatureTableColumn.Key Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the key order for the column. A value of 0 indicates that this is not a key column. Setting this property to a key value will fail if this is a custom column or if any of the cells within this column is a custom cell.

Visual Basic
Property Key() As long
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Key Property


iFeatureTableColumn.Parent Property

iFeatureTableColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent iFeatureTable.

Visual Basic
Property Parent() As iFeatureTable**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Parent Property


iFeatureTableColumn.Type Property

iFeatureTableColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumn Interface > iFeatureTableColumn Properties > iFeatureTableColumn.Type Property


iFeatureTableColumns Interface

iFeatureTableColumns Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatureTableColumns collection object provides access to the columns of an iFeature table.

Class Hierarchy
Inventor::iFeatureTableColumns
Visual Basic
Public Interface iFeatureTableColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureTable.iFeatureTableColumns

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface


iFeatureTableColumns Methods

iFeatureTableColumns Methods
Summary

The methods of the iFeatureTableColumns class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified iFeatureTableColumn object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface > iFeatureTableColumns Methods


iFeatureTableColumns.Item Method

iFeatureTableColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns the specified iFeatureTableColumn object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iFeatureTableColumn*)
Parameters
Parameters | Description
index | Value that specifies the index of the iFeatureTableColumn to return.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface > iFeatureTableColumns Methods > iFeatureTableColumns.Item Method


iFeatureTableColumns Properties

iFeatureTableColumns Properties
Summary

The properties of the iFeatureTableColumns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface > iFeatureTableColumns Properties


iFeatureTableColumns.Application Property

iFeatureTableColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface > iFeatureTableColumns Properties > iFeatureTableColumns.Application Property


iFeatureTableColumns.Count Property

iFeatureTableColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface > iFeatureTableColumns Properties > iFeatureTableColumns.Count Property


iFeatureTableColumns.Type Property

iFeatureTableColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableColumns Interface > iFeatureTableColumns Properties > iFeatureTableColumns.Type Property


iFeatureTableRow Interface

iFeatureTableRow Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatureTableRow object represents a single row of a table associated with a table driven iFeature.

Class Hierarchy
Inventor::iFeatureTableRow
Visual Basic
Public Interface iFeatureTableRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureDefinition.ActiveTableRow

iFeatureTable.DefaultRow

iFeatureTableCell.Row

iFeatureTableRow.Copy

iFeatureTableRows.Item

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface


iFeatureTableRow Methods

iFeatureTableRow Methods
Summary

The methods of the iFeatureTableRow class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a new row with all cell values equal to the original row with the exception of columns whose values must be unique for each row. These are automatically modified to be unique using the same behavior that you see when inserting a new row in the user-interface.
Delete | Method that deletes the row from the table.
Item | Method that returns the specified iFeatureTableCell object from the row.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Methods


iFeatureTableRow.Copy Method

iFeatureTableRow.Copy Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new row with all cell values equal to the original row with the exception of columns whose values must be unique for each row. These are automatically modified to be unique using the same behavior that you see when inserting a new row in the user-interface.

Visual Basic
Sub Copy(Result As [out, retval] iFeatureTableRow*)
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Methods > iFeatureTableRow.Copy Method


iFeatureTableRow.Delete Method

iFeatureTableRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the row from the table.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Methods > iFeatureTableRow.Delete Method


iFeatureTableRow.Item Method

iFeatureTableRow.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified iFeatureTableCell object from the row.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iFeatureTableCell*)
Parameters
Parameters | Description
index | Specifies the index of the iFeatureTableCell to return. The first column in the row has an index of 1. This can be either a numeric value indicating the index of the item in the collection, a string indicating the title of a column header, or a iFeatureTableColumn object. If an out of range index, a non-existent column header title, or an invalid iFeatureTableColumn object is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Methods > iFeatureTableRow.Item Method


iFeatureTableRow Properties

iFeatureTableRow Properties
Summary

The properties of the iFeatureTableRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of columns in the row.
Index | Property that returns the index of this row within the iFeatureTableRows collection where the first row has an index of 1.
MemberName | Property that returns the name that identifies this row.
Parent | Property that returns the parent iFeatureTable.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties


iFeatureTableRow.Application Property

iFeatureTableRow.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties > iFeatureTableRow.Application Property


iFeatureTableRow.Count Property

iFeatureTableRow.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of columns in the row.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties > iFeatureTableRow.Count Property


iFeatureTableRow.Index Property

iFeatureTableRow.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this row within the iFeatureTableRows collection where the first row has an index of 1.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties > iFeatureTableRow.Index Property


iFeatureTableRow.MemberName Property

iFeatureTableRow.MemberName Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the name that identifies this row.

Visual Basic
Property MemberName() As BSTR*
Remarks

This name is created based on the column headings of the key columns.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties > iFeatureTableRow.MemberName Property


iFeatureTableRow.Parent Property

iFeatureTableRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent iFeatureTable.

Visual Basic
Property Parent() As iFeatureTable**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties > iFeatureTableRow.Parent Property


iFeatureTableRow.Type Property

iFeatureTableRow.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRow Interface > iFeatureTableRow Properties > iFeatureTableRow.Type Property


iFeatureTableRows Interface

iFeatureTableRows Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The iFeatureTableRows collection object provides access to the rows of an iFeature table.

Class Hierarchy
Inventor::iFeatureTableRows
Visual Basic
Public Interface iFeatureTableRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeatureTable.iFeatureTableRows

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface


iFeatureTableRows Methods

iFeatureTableRows Methods
Summary

The methods of the iFeatureTableRows class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified iFeatureTableRow object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface > iFeatureTableRows Methods


iFeatureTableRows.Item Method

iFeatureTableRows.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified iFeatureTableRow object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iFeatureTableRow*)
Parameters
Parameters | Description
index | Input Long or String value that specifies the iFeatureTableRow to return. If a Long is input then it is the index of the item to return. If a String is input then it must match the member name of one of the rows. If the index is out of range or the name does not exist a failure will occur.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface > iFeatureTableRows Methods > iFeatureTableRows.Item Method


iFeatureTableRows Properties

iFeatureTableRows Properties
Summary

The properties of the iFeatureTableRows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface > iFeatureTableRows Properties


iFeatureTableRows.Application Property

iFeatureTableRows.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface > iFeatureTableRows Properties > iFeatureTableRows.Application Property


iFeatureTableRows.Count Property

iFeatureTableRows.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface > iFeatureTableRows Properties > iFeatureTableRows.Count Property


iFeatureTableRows.Type Property

iFeatureTableRows.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTableRows Interface > iFeatureTableRows Properties > iFeatureTableRows.Type Property


iFeatureTemplateDescriptor Interface

iFeatureTemplateDescriptor Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The iFeatureTemplateDescriptor object describes the iFeature file that was used to create the iFeature.

Class Hierarchy
Inventor::iFeatureTemplateDescriptor
Visual Basic
Public Interface iFeatureTemplateDescriptor
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iFeature.iFeatureTemplateDescriptor

iFeatureComponent.iFeatureTemplateDescriptor

iFeatureTemplateDescriptors.Item

PunchToolFeature.iFeatureTemplateDescriptor

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface


iFeatureTemplateDescriptor Methods

iFeatureTemplateDescriptor Methods
Summary

The methods of the iFeatureTemplateDescriptor class are listed here.

Methods
Methods
Name | Description
DelayReplaceAll | Method that flags the ReferenceComponent corresponding to the iFeature as being out of date. The next time this part is opened a message will be displayed to the user notifying them that the iFeature is out of date and allowing them to update it using the file specified.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Methods


iFeatureTemplateDescriptor.DelayReplaceAll Method

iFeatureTemplateDescriptor.DelayReplaceAll Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that flags the ReferenceComponent corresponding to the iFeature as being out of date. The next time this part is opened a message will be displayed to the user notifying them that the iFeature is out of date and allowing them to update it using the file specified.

Visual Basic
Sub DelayReplaceAll(NewSourceFilename As String)
Parameters
Parameters | Description
NewSourceFilename | Input String value that specifies the name of the file to use during the replacement of the iFeatureTemplateDescriptor.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Methods > iFeatureTemplateDescriptor.DelayReplaceAll Method


iFeatureTemplateDescriptor Properties

iFeatureTemplateDescriptor Properties
Summary

The properties of the iFeatureTemplateDescriptor class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
InternalName | Gets the Internal Name (a GUID) for this document.
LastKnownSourceFileName | Property that returns the name of the iFeature file (.ide) used to create this iFeatureTemplateDescriptor.
Parent | Property that returns the parent ComponentDefinition object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Properties


iFeatureTemplateDescriptor.Application Property

iFeatureTemplateDescriptor.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Properties > iFeatureTemplateDescriptor.Application Property


iFeatureTemplateDescriptor.InternalName Property

iFeatureTemplateDescriptor.InternalName Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets the Internal Name (a GUID) for this document.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Properties > iFeatureTemplateDescriptor.InternalName Property


iFeatureTemplateDescriptor.LastKnownSourceFileName Property

iFeatureTemplateDescriptor.LastKnownSourceFileName Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the name of the iFeature file (.ide) used to create this iFeatureTemplateDescriptor.

Visual Basic
Property LastKnownSourceFileName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Properties > iFeatureTemplateDescriptor.LastKnownSourceFileName Property


iFeatureTemplateDescriptor.Parent Property

iFeatureTemplateDescriptor.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Properties > iFeatureTemplateDescriptor.Parent Property


iFeatureTemplateDescriptor.Type Property

iFeatureTemplateDescriptor.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptor Interface > iFeatureTemplateDescriptor Properties > iFeatureTemplateDescriptor.Type Property


iFeatureTemplateDescriptors Interface

iFeatureTemplateDescriptors Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The iFeatureTemplateDescriptors collection object provides access to all of the objects in a document.

Class Hierarchy
Inventor::iFeatureTemplateDescriptors
Visual Basic
Public Interface iFeatureTemplateDescriptors
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ReferenceComponents.iFeatureTemplateDescriptors

You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface


iFeatureTemplateDescriptors Methods

iFeatureTemplateDescriptors Methods
Summary

The methods of the iFeatureTemplateDescriptors class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified iFeatureTemplateDescriptor object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface > iFeatureTemplateDescriptors Methods


iFeatureTemplateDescriptors.Item Method

iFeatureTemplateDescriptors.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified iFeatureTemplateDescriptor object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] iFeatureTemplateDescriptor*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface > iFeatureTemplateDescriptors Methods > iFeatureTemplateDescriptors.Item Method


iFeatureTemplateDescriptors Properties

iFeatureTemplateDescriptors Properties
Summary

The properties of the iFeatureTemplateDescriptors class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface > iFeatureTemplateDescriptors Properties


iFeatureTemplateDescriptors.Application Property

iFeatureTemplateDescriptors.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface > iFeatureTemplateDescriptors Properties > iFeatureTemplateDescriptors.Application Property


iFeatureTemplateDescriptors.Count Property

iFeatureTemplateDescriptors.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface > iFeatureTemplateDescriptors Properties > iFeatureTemplateDescriptors.Count Property


iFeatureTemplateDescriptors.Type Property

iFeatureTemplateDescriptors.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureTemplateDescriptors Interface > iFeatureTemplateDescriptors Properties > iFeatureTemplateDescriptors.Type Property


iFeatureVectorInput Interface

iFeatureVectorInput Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureVectorInput object represents the vector input information of an iFeature.

Class Hierarchy
Inventor::iFeatureInput
    Inventor::iFeatureVectorInput
Visual Basic
Public Interface iFeatureVectorInput
Inherits iFeatureInput
Remarks

The iFeatureVectorInput object is used specify the geometry's and other data necessary for the vector input of an iFeature.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureVectorInput Interface


iFeatureVectorInput Properties

iFeatureVectorInput Properties
Summary

The properties of the iFeatureVectorInput class are listed here.

Properties
Name | Description
FlipOption | Property that gets and gets the Boolean indicating whether direction of the selection needs to be flipped. This property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance.
LineInput | Property that sets and gets the entity matching the line input. Valid entity types are kSketchLineObject, kWorkLineObject and kEdgeObject. This property will fail in the case where the iFeatureVectorInput object is associated with an iFeature instance.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureVectorInput Interface > iFeatureVectorInput Properties


iFeatureVectorInput.FlipOption Property

iFeatureVectorInput.FlipOption Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and gets the Boolean indicating whether direction of the selection needs to be flipped. This property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance.

Visual Basic
Property FlipOption() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iFeatureVectorInput Interface > iFeatureVectorInput Properties > iFeatureVectorInput.FlipOption Property


iFeatureVectorInput.LineInput Property

iFeatureVectorInput.LineInput Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that sets and gets the entity matching the line input. Valid entity types are kSketchLineObject, kWorkLineObject and kEdgeObject. This property will fail in the case where the iFeatureVectorInput object is associated with an iFeature instance.

Visual Basic
Property LineInput() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureVectorInput Interface > iFeatureVectorInput Properties > iFeatureVectorInput.LineInput Property


iFeatureWorkPlaneInput Interface

iFeatureWorkPlaneInput Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iFeatureWorkPlaneInput object represents the work plane input information of an iFeature.

Class Hierarchy
Inventor::iFeatureInput
    Inventor::iFeatureWorkPlaneInput
Visual Basic
Public Interface iFeatureWorkPlaneInput
Inherits iFeatureInput
Remarks

The iFeatureWorkPlaneInput object is used specify the geometry's and other data necessary for the work plane input of an iFeature.

You are here: Symbol Reference > Inventor Library > Objects > iFeatureWorkPlaneInput Interface


iFeatureWorkPlaneInput Properties

iFeatureWorkPlaneInput Properties
Summary

The properties of the iFeatureWorkPlaneInput class are listed here.

Properties
Name | Description
FlipOption | Property that gets and gets the Boolean indicating whether direction of the selection needs to be flipped. This property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance.
PlaneInput | Property that sets and gets the entity matching the plane input. Valid entity types are kSketchObject, kWorkPlaneObject and kFaceObject. This property will fail in the case where the iFeatureWorkPlaneInput object is associated with an iFeature instance.
You are here: Symbol Reference > Inventor Library > Objects > iFeatureWorkPlaneInput Interface > iFeatureWorkPlaneInput Properties


iFeatureWorkPlaneInput.FlipOption Property

iFeatureWorkPlaneInput.FlipOption Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and gets the Boolean indicating whether direction of the selection needs to be flipped. This property will fail in the case where the iFeatureSketchPlaneInput object is associated with an iFeature instance.

Visual Basic
Property FlipOption() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iFeatureWorkPlaneInput Interface > iFeatureWorkPlaneInput Properties > iFeatureWorkPlaneInput.FlipOption Property


iFeatureWorkPlaneInput.PlaneInput Property

iFeatureWorkPlaneInput.PlaneInput Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that sets and gets the entity matching the plane input. Valid entity types are kSketchObject, kWorkPlaneObject and kFaceObject. This property will fail in the case where the iFeatureWorkPlaneInput object is associated with an iFeature instance.

Visual Basic
Property PlaneInput() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > iFeatureWorkPlaneInput Interface > iFeatureWorkPlaneInput Properties > iFeatureWorkPlaneInput.PlaneInput Property


iMateDefinition Interface

iMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iMateDefinition object is the base class for all iMate definition objects.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::AngleiMateDefinition
    Inventor::CompositeiMateDefinition
    Inventor::FlushiMateDefinition
    Inventor::InsertiMateDefinition
    Inventor::MateiMateDefinition
    Inventor::RotateRotateiMateDefinition
    Inventor::RotateTranslateiMateDefinition
    Inventor::TangentiMateDefinition
Visual Basic
Public Interface iMateDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AngleiMateDefinitionProxy.NativeObject

CompositeiMateDefinition.Item

CompositeiMateDefinitionProxy.NativeObject

FlushiMateDefinitionProxy.NativeObject

iMateDefinition.ReferencedEntity

iMateDefinitions.Item

iMateDefinitionsEnumerator.Item

InsertiMateDefinitionProxy.NativeObject

MateiMateDefinitionProxy.NativeObject

RotateRotateiMateDefinitionProxy.NativeObject

RotateTranslateiMateDefinitionProxy.NativeObject

TangentiMateDefinitionProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface


iMateDefinition Methods

iMateDefinition Methods
Summary

The methods of the iMateDefinition class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the iMateDefinition.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Methods


iMateDefinition.Delete Method

iMateDefinition.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the iMateDefinition.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Methods > iMateDefinition.Delete Method


iMateDefinition.GetReferenceKey Method

iMateDefinition.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Methods > iMateDefinition.GetReferenceKey Method


iMateDefinition Properties

iMateDefinition Properties
Summary

The properties of the iMateDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
HasReferenceComponent | Property that specifies if the object was created as the result of a derived part.
Identifier | Property that returns the internal unique identifier for this iMateDefinition.
MatchList | Property that gets and sets an array of strings that specifies the priority order for iMate definition matches.
Name | Property that indicates the name of this object or instance.
ReferenceComponent | Property that returns the ReferenceComponent that resulted in the creation of this feature.
ReferencedEntity | Gets the object this entity is dependent on.
SequenceIndex | Property that gets and sets the index of this iMate definition.
Suppressed | Property that gets and sets whether the iMate definition is suppressed or not.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties


iMateDefinition.Application Property

iMateDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.Application Property


iMateDefinition.AttributeSets Property

iMateDefinition.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.AttributeSets Property


iMateDefinition.Exported Property

iMateDefinition.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.Exported Property


iMateDefinition.HasReferenceComponent Property

iMateDefinition.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if the object was created as the result of a derived part.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
Remarks

This property returns True in the case where the object is from a derived part (so it belongs to a ReferenceComponent). In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case. If the HasReferenceComponent property is False, the ReferenceComponent property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.HasReferenceComponent Property


iMateDefinition.Identifier Property

iMateDefinition.Identifier Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the internal unique identifier for this iMateDefinition.

Visual Basic
Property Identifier() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.Identifier Property


iMateDefinition.MatchList Property

iMateDefinition.MatchList Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets an array of strings that specifies the priority order for iMate definition matches.

Visual Basic
Property MatchList() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.MatchList Property


iMateDefinition.Name Property

iMateDefinition.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.Name Property


iMateDefinition.ReferenceComponent Property

iMateDefinition.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the ReferenceComponent that resulted in the creation of this feature.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
Remarks

If the object belongs to a derived part, a DerivedPartComponent will be returned. If the object belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.ReferenceComponent Property


iMateDefinition.ReferencedEntity Property

iMateDefinition.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the object this entity is dependent on.

Visual Basic
Property ReferencedEntity() As iMateDefinition**
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.ReferencedEntity Property


iMateDefinition.SequenceIndex Property

iMateDefinition.SequenceIndex Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the index of this iMate definition.

Visual Basic
Property SequenceIndex() As long
Remarks

This defines the order of the iMateDefinition in the browser and defines the order used by Inventor when looking for matching iMates. The iMate with a SequenceIndex value of 1 is the first one in the list. Setting this value will insert this iMateDefinition into the value defined and shift all following iMateDefinitions back one. Setting this to a value equal than or greater than the number of iMateDefinitions will resequence it to the end of the list.

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.SequenceIndex Property


iMateDefinition.Suppressed Property

iMateDefinition.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether the iMate definition is suppressed or not.

Visual Basic
Property Suppressed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.Suppressed Property


iMateDefinition.Type Property

iMateDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinition Interface > iMateDefinition Properties > iMateDefinition.Type Property


iMateDefinitions Interface

iMateDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iMateDefinitions collection provides access to all of the objects in a part or assembly.

Class Hierarchy
Inventor::iMateDefinitions
Visual Basic
Public Interface iMateDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.iMateDefinitions

PartComponentDefinition.iMateDefinitions

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface


iMateDefinitions Methods

iMateDefinitions Methods
Summary

The methods of the iMateDefinitions class are listed here.

Methods
Methods
Name | Description
AddAngleiMateDefinition | Method that creates a new angle iMate definition. The newly created AngleiMateDefinition object is returned.
AddCompositeiMateDefinition | Method that creates a new composite iMate definition. The newly created CompositeiMateDefinition object is returned. When iMate definition objects are used as input for a composite iMate, the iMateDefinition objects are no longer directly accessible through the iMateDefinitions collection. They are only accessible through the CompositeiMateDefinition object.
AddFlushiMateDefinition | Method that creates a new flush iMate definition. The newly created FlushiMateDefinition object is returned.
AddInsertiMateDefinition | Method that creates a new insert iMate definition. The newly created InsertiMateDefinition object is returned.
AddMateiMateDefinition | Method that creates a new mate iMate definition.
AddRotateRotateiMateDefinition | Method that creates a new rotation motion iMate definition.
AddRotateTranslateiMateDefinition | Method that creates a new rotate-translate motion iMate definition.
AddTangentiMateDefinition | Method that creates a new tangent iMate definition.
Item | Property that returns the specified iMateDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods


iMateDefinitions.AddAngleiMateDefinition Method

iMateDefinitions.AddAngleiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new angle iMate definition. The newly created AngleiMateDefinition object is returned.

Visual Basic
Sub AddAngleiMateDefinition(Entity As IDispatch, DirectionReversed As VARIANT_BOOL, Angle As VARIANT, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] AngleiMateDefinition*)
Parameters
Parameters | Description
Entity | Object that defines the entity. This object can be a planar face, work plane, linear edge, work axis, or a face that defines an axis.
DirectionReversed | Boolean that specifies whether to reverse the direction of the entity.
Angle | Defines the angle value. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input the units can be specified as part of the string or will default to the current angle units of the document.
BiasPoint | Point object that is used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | String that specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddAngleiMateDefinition Method


iMateDefinitions.AddCompositeiMateDefinition Method

iMateDefinitions.AddCompositeiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new composite iMate definition. The newly created CompositeiMateDefinition object is returned. When iMate definition objects are used as input for a composite iMate, the iMateDefinition objects are no longer directly accessible through the iMateDefinitions collection. They are only accessible through the CompositeiMateDefinition object.

Visual Basic
Sub AddCompositeiMateDefinition(iMates As ObjectCollection, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] CompositeiMateDefinition*)
Parameters
Parameters | Description
iMates | Contains the iMates that are used as input for the composite iMate. The collection must contain only iMateDefinition objects. It will fail if any other object types are input or if any of the objects are a CompositeiMateDefinition object.
Name | Specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddCompositeiMateDefinition Method


iMateDefinitions.AddFlushiMateDefinition Method

iMateDefinitions.AddFlushiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new flush iMate definition. The newly created FlushiMateDefinition object is returned.

Visual Basic
Sub AddFlushiMateDefinition(Entity As IDispatch, Offset As VARIANT, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] FlushiMateDefinition*)
Parameters
Parameters | Description
Entity | Object that defines the entity. The input object must be either a planar Face object or WorkPlane object.
Offset | Defines the offset value. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPoint | Point object that is used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | String that specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddFlushiMateDefinition Method


iMateDefinitions.AddInsertiMateDefinition Method

iMateDefinitions.AddInsertiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new insert iMate definition. The newly created InsertiMateDefinition object is returned.

Visual Basic
Sub AddInsertiMateDefinition(Entity As IDispatch, AxesOpposed As VARIANT_BOOL, Distance As VARIANT, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] InsertiMateDefinition*)
Parameters
Parameters | Description
Entity | Object that defines the entity. This object must be a circular edge.
AxesOpposed | Specifies whether the direction of the axis of the input entities are in the same direction or opposed. A value of True indicates they are opposed.
Distance | Defines the offset value. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPoint | Used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | Specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
See Also

Add iMate Definition sample

Example

See iMateDefinitions::AddMateiMateDefinition for example "Add iMate definition"

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddInsertiMateDefinition Method


iMateDefinitions.AddMateiMateDefinition Method

iMateDefinitions.AddMateiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new mate iMate definition.

Visual Basic
Sub AddMateiMateDefinition(Entity As IDispatch, Offset As VARIANT, ByRef EntityInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] MateiMateDefinition*)
Parameters
Parameters | Description
Entity | Defines the entity to mate.
Offset | Defines the offset value. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
EntityInferredType | Enum that specifies how the geometry of the entity is to be interpreted. Depending on the geometry of the entity, different options are possible. If the entity is a cylinder this can be either kNoInferrence or kInferredLine. For kNoInferrence to be valid for a cylinder, the matching iMate must also be on a cylinder and they must be the same radius. If the entity is a sphere this can be either kNoInferrence or kInferredPoint. For kNoInferrence to be valid for a sphere, the matching iMate must also be on a sphere and they must be the same radius. If the entity is a cone this can be either kNoInferrence or kInferredLine. For kNoInferrence to be valid for a cone, the matching iMate must also be on a cone and they must have the same taper angle. If the entity is a torus this can be either kInferredLine or kInferredPoint. For a plane, only kNoInferrence is valid.
BiasPoint | Point object that is used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | Specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
Example

"Add iMate Definition"

Add iMate definitions using AddMateiMateDefinition and AddInsertiMateDefinition.

Public Sub CreateiMateDefinitionSample()

    ' Create a new part document, using the default part template.

    Dim oPartDoc As PartDocument

    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _

                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.

    Dim oCompDef As PartComponentDefinition

    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.

    Dim oSketch As PlanarSketch

    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the transient geometry object.

    Dim oTransGeom As TransientGeometry

    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)

    Dim oRectangleLines As SketchEntitiesEnumerator

    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _

                                oTransGeom.CreatePoint2d(0, 0), _

                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.

    Dim oProfile As Profile

    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a base extrusion 1cm thick.

    Dim oExtrude1 As ExtrudeFeature

    Set oExtrude1 = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _

                        oProfile, 1, kNegativeExtentDirection, kJoinOperation)

    ' Get the top face of the extrusion to use for creating the new sketch.

    Dim oFrontFace As Face

    Set oFrontFace = oExtrude1.StartFaces.Item(1)

    ' Create a new sketch on this face, but use the method that allows you to

    ' control the orientation and orgin of the new sketch.

    Set oSketch = oCompDef.Sketches.AddWithOrientation(oFrontFace, _

                    oCompDef.WorkAxes.Item(1), True, True, oCompDef.WorkPoints(1))

    ' Create a sketch circle with the center at (2, 1.5).

    Dim oCircle As SketchCircle

    Set oCircle = oSketch.SketchCircles.AddByCenterRadius(oTransGeom.CreatePoint2d(2, 1.5), 0.5)

    ' Create a profile.

    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create the second extrude (a hole).

    Dim oExtrude2 As ExtrudeFeature

    Set oExtrude2 = oCompDef.Features.ExtrudeFeatures.AddByThroughAllExtent( _

                        oProfile, kNegativeExtentDirection, kCutOperation)

    ' Create a mate iMateDefinition on a side face of the first extrude.

    Dim oMateiMateDefinition As MateiMateDefinition

    Set oMateiMateDefinition = oCompDef.iMateDefinitions.AddMateiMateDefinition( _

                        oExtrude1.SideFaces.Item(1), 0, , , "MateA")

    ' Create a match list of names to use for the next iMateDefinition.

    Dim strMatchList(2) As String

    strMatchList(0) = "InsertA"

    strMatchList(1) = "InsertB"

    strMatchList(2) = "InsertC"

    ' Create an insert iMateDefinition on the cylindrical face of the second extrude.

    Dim oInsertiMateDefinition As InsertiMateDefinition

    Set oInsertiMateDefinition = oCompDef.iMateDefinitions.AddInsertiMateDefinition( _

                        oExtrude2.SideFaces.Item(1), False, 0, , "InsertA", strMatchList)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddMateiMateDefinition Method


iMateDefinitions.AddRotateRotateiMateDefinition Method

iMateDefinitions.AddRotateRotateiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new rotation motion iMate definition.

Visual Basic
Sub AddRotateRotateiMateDefinition(Entity As IDispatch, Ratio As VARIANT, ForwardDirection As VARIANT_BOOL, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] RotateRotateiMateDefinition*)
Parameters
Parameters | Description
Entity | Defines the entity and it rotation axis. The input object must be a planar Face, a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the rotation axis is normal to the input face.
Ratio | Defines the rotation ratio value. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. The input value is unitless.
ForwardDirection | Defines the direction of rotation of the objects with respect to the axis direction. If the input value is True then both objects will rotate the same direction around their axes. If False, then they will rotate in opposite directions.
BiasPoint | Point object that is used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | Specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddRotateRotateiMateDefinition Method


iMateDefinitions.AddRotateTranslateiMateDefinition Method

iMateDefinitions.AddRotateTranslateiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new rotate-translate motion iMate definition.

Visual Basic
Sub AddRotateTranslateiMateDefinition(Entity As IDispatch, Ratio As VARIANT, ForwardDirection As VARIANT_BOOL, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] RotateTranslateiMateDefinition*)
Parameters
Parameters | Description
Entity | Defines the entity and its rotation axis. The input object must be a planar Face, a revolved Face, a linear Edge, a WorkPlane, or a WorkAxis object. For planar objects the rotation axis is normal to the input face.
Ratio | Input Variant that defines the distance of translation for every revolution of the rotated occurrence. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
ForwardDirection | Defines the direction of translation with respect to the rotation direction relative to the axes directions. If the input value is True then when the rotation object is rotated in a positive direction about its axis, the translation object will move in the positive direction of its vector, If False, it will move in the negative direction.
BiasPoint | Point object that is used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | Specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddRotateTranslateiMateDefinition Method


iMateDefinitions.AddTangentiMateDefinition Method

iMateDefinitions.AddTangentiMateDefinition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new tangent iMate definition.

Visual Basic
Sub AddTangentiMateDefinition(Entity As IDispatch, InsideTangency As VARIANT_BOOL, Offset As VARIANT, ByRef BiasPoint As [optional] VARIANT, ByRef Name As [defaultvalue("")] BSTR, ByRef MatchList As [optional] VARIANT, Result As [out, retval] TangentiMateDefinition*)
Parameters
Parameters | Description
Entity | Defines the entity to use for the tangency.
InsideTangency | Specifies the orientation of the surfaces at the tangent contact point of the surfaces.
Offset | Defines the offset value. This can be either a numeric value or a string. A parameter for this value is created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input the units can be specified as part of the string or will default to the current length units of the document.
BiasPoint | Point object that is used to help determine the initial position when this iMate definition is used. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias points you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
Name | Specifies the name of the iMate definition. If not specified, a name is automatically generated.
MatchList | Array of Strings that specifies the priority order of the iMate definitions to match.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.AddTangentiMateDefinition Method


iMateDefinitions.Item Method

iMateDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified iMateDefinition object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] iMateDefinition*)
Parameters
Parameters | Description
index | Specifies the index of the to return.
See Also

iMate Result Creation sample

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Methods > iMateDefinitions.Item Method


iMateDefinitions Properties

iMateDefinitions Properties
Summary

The properties of the iMateDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Properties


iMateDefinitions.Application Property

iMateDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Properties > iMateDefinitions.Application Property


iMateDefinitions.Count Property

iMateDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Properties > iMateDefinitions.Count Property


iMateDefinitions.Type Property

iMateDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitions Interface > iMateDefinitions Properties > iMateDefinitions.Type Property


iMateDefinitionsEnumerator Interface

iMateDefinitionsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Object that represents an iMateDefinitionsEnumerator. Presents a snapshot of the set of objects.

Class Hierarchy
Inventor::iMateDefinitionsEnumerator
Visual Basic
Public Interface iMateDefinitionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ComponentOccurrence.iMateDefinitions

DerivedPartComponent.iMateDefinitions

You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitionsEnumerator Interface


iMateDefinitionsEnumerator Methods

iMateDefinitionsEnumerator Methods
Summary

The methods of the iMateDefinitionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitionsEnumerator Interface > iMateDefinitionsEnumerator Methods


iMateDefinitionsEnumerator.Item Method

iMateDefinitionsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] iMateDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitionsEnumerator Interface > iMateDefinitionsEnumerator Methods > iMateDefinitionsEnumerator.Item Method


iMateDefinitionsEnumerator Properties

iMateDefinitionsEnumerator Properties
Summary

The properties of the iMateDefinitionsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitionsEnumerator Interface > iMateDefinitionsEnumerator Properties


iMateDefinitionsEnumerator.Count Property

iMateDefinitionsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitionsEnumerator Interface > iMateDefinitionsEnumerator Properties > iMateDefinitionsEnumerator.Count Property


iMateDefinitionsEnumerator.Type Property

iMateDefinitionsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iMateDefinitionsEnumerator Interface > iMateDefinitionsEnumerator Properties > iMateDefinitionsEnumerator.Type Property


iMateResult Interface

iMateResult Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iMateResult object represents the result of using an iMate in an assembly.

Class Hierarchy
Inventor::iMateResult
    Inventor::iMateResultProxy
Visual Basic
Public Interface iMateResult
Inherits IDispatch
Remarks

An iMateResult object represents both composite iMate results and individual iMate results. This can be checked using the IsComposite property.

Notes

Members through which this object may be accessed include:

AssemblyConstraint.iMateResult

iMateResult.ParentComposite

iMateResultProxy.NativeObject

iMateResults.AddByiMateAndEntity

iMateResults.AddByTwoiMates

iMateResults.Item

iMateResultsEnumerator.Item

Example

"iMate Result Creation Example"

This sample demonstrates creating an iMate result using two existin iMate definitions.

To use this sample create a new part by extruding a rectangle to create a cube. Create a mate iMate on one of the faces. This sample assumes the iMate is named the default name used in the English version of Inventor, which is iMate:1. If the iMate definition is created with another name you can either edit the name of the iMate definition in the part file, or edit the sample code below to use the different name.

Save the part to C:\Temp\iMatePart.ipt. Finally, have an assembly open and run the sample code.

Public Sub iMateResultCreationSample()

    ' Get the component definition of the currently open assembly.

    ' This will fail if an assembly document is not open.

    Dim oAsmCompDef As AssemblyComponentDefinition

    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Create a new matrix object.  It will be initialized to an identity matrix.

    Dim oMatrix As Matrix

    Set oMatrix = ThisApplication.TransientGeometry.CreateMatrix

    ' Place the first occurrence.

    Dim oOcc1 As ComponentOccurrence

    Set oOcc1 = oAsmCompDef.Occurrences.Add("C:\Temp\iMatePart.ipt", oMatrix)

    ' Place the second occurrence, but adjust the matrix slightly so they're

    ' not right on top of each other.

    oMatrix.Cell(1, 4) = 10

    Dim oOcc2 As ComponentOccurrence

    Set oOcc2 = oAsmCompDef.Occurrences.Add("C:\Temp\iMatePart.ipt", oMatrix)

    ' Look through the iMateDefinitions defined for the first occurrence

    ' and find the one named "iMate:1".  This loop demonstrates using the

    ' Count and Item properties of the iMateDefinitions object.

    Dim i As Long

    Dim oiMateDef1 As iMateDefinition

    For i = 1 To oOcc1.iMateDefinitions.Count

        If oOcc1.iMateDefinitions.Item(i).Name = "iMate:1" Then

            Set oiMateDef1 = oOcc1.iMateDefinitions.Item(i)

            Exit For

        End If

    Next

    If oiMateDef1 Is Nothing Then

        MsgBox "An iMate definition named ""iMate:1"" does not exist in " & oOcc1.Name

        Exit Sub

    End If

    ' Look through the iMateDefinitions defined for the second occurrence

    ' and find the one named "iMate:1".  This loop demonstrates using the

    ' For Each method of iterating through a collection.

    Dim oiMateDef2 As iMateDefinition

    Dim bFoundDefinition As Boolean

    For Each oiMateDef2 In oOcc2.iMateDefinitions

        If oiMateDef2.Name = "iMate:1" Then

            bFoundDefinition = True

            Exit For

        End If

    Next

    If Not bFoundDefinition Then

        MsgBox "An iMate definition named ""iMate:1"" does not exist in " & oOcc2.Name

        Exit Sub

    End If

    ' Create an iMate result using the two definitions.

    Dim oiMateResult As iMateResult

    Set oiMateResult = oAsmCompDef.iMateResults.AddByTwoiMates(oiMateDef1, oiMateDef2)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface


iMateResult Methods

iMateResult Methods
Summary

The methods of the iMateResult class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the iMateResult. This method will fail if the iMateResult is a part of a composite iMateResult.
GetInputs | Method that returns the input entities that were used to create this iMateResult object.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetInputs | Method that edits the inputs of an iMate result.
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Methods


iMateResult.Delete Method

iMateResult.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the iMateResult. This method will fail if the iMateResult is a part of a composite iMateResult.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Methods > iMateResult.Delete Method


iMateResult.GetInputs Method

iMateResult.GetInputs Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the input entities that were used to create this iMateResult object.

Visual Basic
Sub GetInputs(ByRef iMateDefinition As iMateDefinition*, ByRef Entity As IDispatch*)
Parameters
Parameters | Description
iMateDefinition | Output object that defines the output iMate.
Entity | Output object that defines the second entity. This object can be either an object or a geometric entity.
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Methods > iMateResult.GetInputs Method


iMateResult.GetReferenceKey Method

iMateResult.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Methods > iMateResult.GetReferenceKey Method


iMateResult.SetInputs Method

iMateResult.SetInputs Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that edits the inputs of an iMate result.

Visual Basic
Sub SetInputs(iMateDefinition As iMateDefinition, Entity As IDispatch, ByRef EntityBiasPoint As [optional] VARIANT, ByRef SolutionType As [defaultvalue(kDirectedSolution)] AngleConstraintSolutionTypeEnum)
Parameters
Parameters | Description
iMateDefinition | Input iMateDefinitionProxy object that defines the input iMate.
Entity | Input object that defines the second entity. This object can be either a iMateDefinition proxy object or a geometric entity.
EntityBiasPoint | Optional input Point object that is used to help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the bias point coincident with the iMate. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias point you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
SolutionType | Optional input AngleConstraintSolutionTypeEnum that specifies the solution type when creating an angle constraint. If specified to be kDirectedSolution, the solution always applies the right hand rule. If specified to be kUndirectedSolution, the solution allows either orientation, thus resolving situations where component orientation flips during a constraint drive or drag. The default value is kDirectedSolution.
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Methods > iMateResult.SetInputs Method


iMateResult Properties

iMateResult Properties
Summary

The properties of the iMateResult class are listed here.

Properties
Name | Description
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Constraints | Property that returns an AssemblyConstraintstEnumerator containing the constraints associated with this iMate. If the iMate is not a composite iMate this collection will contain one constraint. If it is a composite it can contain any number of constraints.
IsComposite | Property that indicates if this iMateResult represents a composite iMate result.
Name | Property that indicates the name of this object or instance.
ParentComposite | Property that returns the parent iMateResult object. This property is only valid in the case when the iMateResult object it is being called from is not a composite. This can be checked for by using the IsComposite property of the iMateResult object.
Results | Property that returns an iMateResultsEnumerator object that provides access to the iMate results object that are part of a composite iMate. This property is only valid in the case when the iMateResult object it is being called from is a composite. This can be checked for by using the IsComposite property of the iMateResult object.
Suppressed | Property that gets and sets whether the iMateResult is suppressed or not. Setting this property will fail if the iMateResult is a part of a composite iMateResult.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties


iMateResult.AttributeSets Property

iMateResult.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.AttributeSets Property


iMateResult.Constraints Property

iMateResult.Constraints Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns an AssemblyConstraintstEnumerator containing the constraints associated with this iMate. If the iMate is not a composite iMate this collection will contain one constraint. If it is a composite it can contain any number of constraints.

Visual Basic
Property Constraints() As AssemblyConstraintsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.Constraints Property


iMateResult.IsComposite Property

iMateResult.IsComposite Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates if this iMateResult represents a composite iMate result.

Visual Basic
Property IsComposite() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.IsComposite Property


iMateResult.Name Property

iMateResult.Name Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.Name Property


iMateResult.ParentComposite Property

iMateResult.ParentComposite Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent iMateResult object. This property is only valid in the case when the iMateResult object it is being called from is not a composite. This can be checked for by using the IsComposite property of the iMateResult object.

Visual Basic
Property ParentComposite() As iMateResult**
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.ParentComposite Property


iMateResult.Results Property

iMateResult.Results Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns an iMateResultsEnumerator object that provides access to the iMate results object that are part of a composite iMate. This property is only valid in the case when the iMateResult object it is being called from is a composite. This can be checked for by using the IsComposite property of the iMateResult object.

Visual Basic
Property Results() As iMateResultsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.Results Property


iMateResult.Suppressed Property

iMateResult.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the iMateResult is suppressed or not. Setting this property will fail if the iMateResult is a part of a composite iMateResult.

Visual Basic
Property Suppressed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.Suppressed Property


iMateResult.Type Property

iMateResult.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iMateResult Interface > iMateResult Properties > iMateResult.Type Property


iMateResultProxy Interface

iMateResultProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the iMateResult object.

Class Hierarchy
Inventor::iMateResult
    Inventor::iMateResultProxy
Visual Basic
Public Interface iMateResultProxy
Inherits iMateResult
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > iMateResultProxy Interface


iMateResultProxy Properties

iMateResultProxy Properties
Summary

The properties of the iMateResultProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > iMateResultProxy Interface > iMateResultProxy Properties


iMateResultProxy.ContainingOccurrence Property

iMateResultProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > iMateResultProxy Interface > iMateResultProxy Properties > iMateResultProxy.ContainingOccurrence Property


iMateResultProxy.NativeObject Property

iMateResultProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateResult**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > iMateResultProxy Interface > iMateResultProxy Properties > iMateResultProxy.NativeObject Property


iMateResults Interface

iMateResults Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iMateResults collection provides access to all of the objects in an assembly. It also supports the methods that allow the creation of iMateResult objects.

Class Hierarchy
Inventor::iMateResults
Visual Basic
Public Interface iMateResults
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.iMateResults

You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface


iMateResults Methods

iMateResults Methods
Summary

The methods of the iMateResults class are listed here.

Methods
Methods
Name | Description
AddByiMateAndEntity | Method that creates a new iMate result. The newly created iMateResult object is returned. If the two inputs do not define a valid iMateResult the method will fail.
AddByTwoiMates | Method that creates a new iMate result. The newly created iMateResult object is returned.
Item | Property that returns the specified iMateResult object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Methods


iMateResults.AddByiMateAndEntity Method

iMateResults.AddByiMateAndEntity Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new iMate result. The newly created iMateResult object is returned. If the two inputs do not define a valid iMateResult the method will fail.

Visual Basic
Sub AddByiMateAndEntity(iMateDefinition As iMateDefinition, Entity As IDispatch, ByRef EntityBiasPoint As [optional] VARIANT, ByRef AngleEntityReversed As [optional] VARIANT, Result As [out, retval] iMateResult*)
Parameters
Parameters | Description
iMateDefinition | Input object that defines the input iMate.
Entity | Input object that defines the second entity. This object must be a valid geometric entity in the assembly, such as a , WorkAxis, SketchLine, etc.
EntityBiasPoint | Optional input object that is used to help in determining the initial position of the occurrence. The occurrences are repositioned in an attempt to make the bias point coincident with the iMate. This provides some general control over the position of the occurrence when it isn't being controlled by another constraint. An example of when the bias points are useful is the case when the first constraint on a part is a mate constraint. In the case where the mate is between two planes, the parts can be positioned anywhere along the infinite plane that defines their mating contact. Using the bias point you can define the position of the two occurrences, relative to each other. If a bias point is not given, one is calculated that is at the center of the parameter range of the input entity.
AngleEntityReversed | Optional input Boolean that is only used when creating an angle constraint. This argument specifies if the direction of the entity should be reversed or not. A value of True indicates it should be reversed. If this argument is not provided for an angle constraint it defaults to False. This argument is ignored for all other constraint types.
Example

"iMate Using Entities Example"

This sample demonstrates creating iMate results between an iMate definition on one occurrence and an entity from another occurrence. It places a cube and for each planar face on the cube places an additional cube and uses an iMate to constrain the new cube to the face of the initial cube.

To use this sample create a new part by extruding a rectangle to create a cube. Create a mate iMate on one of the faces. This sample assumes the iMate is named the default name used in the English version of Inventor, which is iMate:1. If the iMate definition is created with another name you can either edit the name of the iMate definition in the part file, or edit the sample code below to use the different name.

Save the part to C:\Temp\iMatePart.ipt. Finally, have an assembly open and run the sample code.

Public Sub iMateResultCreationUsingEntitiesSample()

    ' Get the component definition of the currently open assembly.

    ' This will fail if an assembly document is not open.

    Dim oAsmCompDef As AssemblyComponentDefinition

    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Create a new matrix object.  It will be initialized to an identity matrix.

    Dim oMatrix As Matrix

    Set oMatrix = ThisApplication.TransientGeometry.CreateMatrix

    ' Place the first occurrence.

    Dim oOcc1 As ComponentOccurrence

    Set oOcc1 = oAsmCompDef.Occurrences.Add("C:\Temp\iMatePart.ipt", oMatrix)

    ' Iterate through all of the faces of the occurrence and constrain

    ' a second part to each planar face.  The face of the inserted part is

    ' identified using an iMate.

    Dim oFace As Face

    For Each oFace In oOcc1.SurfaceBodies.Item(1).Faces

        ' Check to see if the face is planar.

        If oFace.SurfaceType = kPlaneSurface Then

            ' Place a new occurrence with a slightly adjusted matrix it's

            ' right on top of the previous occurrence.

            oMatrix.Cell(1, 4) = 10

            Dim oOcc2 As ComponentOccurrence

            Set oOcc2 = oAsmCompDef.Occurrences.Add("C:\Temp\iMatePart.ipt", oMatrix)

            ' Look through the iMateDefinitions and find the one named "iMate:1".

            Dim oiMateDef As iMateDefinition

            Dim bFoundDefinition As Boolean

            For Each oiMateDef In oOcc2.iMateDefinitions

                If oiMateDef.Name = "iMate:1" Then

                    bFoundDefinition = True

                    Exit For

                End If

            Next

            ' Exit sub if an iMate wasn't found.

            If Not bFoundDefinition Then

                MsgBox "The occurrence does not contain an iMate named ""iMate:1"""

                Exit Sub

            End If

            ' Create an iMate result between the iMate and the face.

            Dim oiMateResult As iMateResult

            Set oiMateResult = oAsmCompDef.iMateResults.AddByiMateAndEntity(oiMateDef, oFace)

        End If

    Next

End Sub
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Methods > iMateResults.AddByiMateAndEntity Method


iMateResults.AddByTwoiMates Method

iMateResults.AddByTwoiMates Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new iMate result. The newly created iMateResult object is returned.

Visual Basic
Sub AddByTwoiMates(iMateDefinitionOne As iMateDefinition, iMateDefinitionTwo As iMateDefinition, Result As [out, retval] iMateResult*)
Parameters
Parameters | Description
iMateDefinitionOne | Input object that defines the first input iMate.
iMateDefinitionTwo | Input object that defines the second input iMate.
Remarks

If the two inputs do not define a valid iMateResult the method will fail. The result of adding an iMate will create a single iMateResult and one or more assembly constraints. If a CompositeiMateDefinition is input, multiple constraints will result.

See Also

iMate Result Creation sample

You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Methods > iMateResults.AddByTwoiMates Method


iMateResults.Item Method

iMateResults.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified iMateResult object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] iMateResult*)
Parameters
Parameters | Description
index | Input Variant value that specifies the to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the name of the iMateResult object. If an out-of-range index or a name of a non-existent iMateResult is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Methods > iMateResults.Item Method


iMateResults Properties

iMateResults Properties
Summary

The properties of the iMateResults class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Properties


iMateResults.Application Property

iMateResults.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Properties > iMateResults.Application Property


iMateResults.Count Property

iMateResults.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Properties > iMateResults.Count Property


iMateResults.Type Property

iMateResults.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iMateResults Interface > iMateResults Properties > iMateResults.Type Property


iMateResultsEnumerator Interface

iMateResultsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Object that represents an iMateResultsEnumerator. Presents a snapshot of the set of objects.

Class Hierarchy
Inventor::iMateResultsEnumerator
Visual Basic
Public Interface iMateResultsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iMateResult.Results

You are here: Symbol Reference > Inventor Library > Objects > iMateResultsEnumerator Interface


iMateResultsEnumerator Methods

iMateResultsEnumerator Methods
Summary

The methods of the iMateResultsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > iMateResultsEnumerator Interface > iMateResultsEnumerator Methods


iMateResultsEnumerator.Item Method

iMateResultsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] iMateResult*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the to return.
You are here: Symbol Reference > Inventor Library > Objects > iMateResultsEnumerator Interface > iMateResultsEnumerator Methods > iMateResultsEnumerator.Item Method


iMateResultsEnumerator Properties

iMateResultsEnumerator Properties
Summary

The properties of the iMateResultsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iMateResultsEnumerator Interface > iMateResultsEnumerator Properties


iMateResultsEnumerator.Count Property

iMateResultsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iMateResultsEnumerator Interface > iMateResultsEnumerator Properties > iMateResultsEnumerator.Count Property


iMateResultsEnumerator.Type Property

iMateResultsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iMateResultsEnumerator Interface > iMateResultsEnumerator Properties > iMateResultsEnumerator.Type Property


InsertConstraint Interface

InsertConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents an insert assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::InsertConstraint
        Inventor::InsertConstraintProxy
Visual Basic
Public Interface InsertConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToInsertConstraint

AssemblyConstraints.AddInsertConstraint

InsertConstraintProxy.NativeObject

See Also

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > InsertConstraint Interface


InsertConstraint Properties

InsertConstraint Properties
Summary

The properties of the InsertConstraint class are listed here.

Properties
Name | Description
AxesOpposed | Property that gets whether the direction of the two axes is opposed.
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.
Distance | Property that returns the Parameter object that controls the offset distance of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > InsertConstraint Interface > InsertConstraint Properties


InsertConstraint.AxesOpposed Property

InsertConstraint.AxesOpposed Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets whether the direction of the two axes is opposed.

Visual Basic
Property AxesOpposed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > InsertConstraint Interface > InsertConstraint Properties > InsertConstraint.AxesOpposed Property


InsertConstraint.ConstraintLimits Property

InsertConstraint.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > InsertConstraint Interface > InsertConstraint Properties > InsertConstraint.ConstraintLimits Property


InsertConstraint.Distance Property

InsertConstraint.Distance Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Parameter object that controls the offset distance of the constraint.

Visual Basic
Property Distance() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > InsertConstraint Interface > InsertConstraint Properties > InsertConstraint.Distance Property


InsertConstraintProxy Interface

InsertConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the InsertConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::InsertConstraint
        Inventor::InsertConstraintProxy
Visual Basic
Public Interface InsertConstraintProxy
Inherits InsertConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > InsertConstraintProxy Interface


InsertConstraintProxy Properties

InsertConstraintProxy Properties
Summary

The properties of the InsertConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > InsertConstraintProxy Interface > InsertConstraintProxy Properties


InsertConstraintProxy.ContainingOccurrence Property

InsertConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > InsertConstraintProxy Interface > InsertConstraintProxy Properties > InsertConstraintProxy.ContainingOccurrence Property


InsertConstraintProxy.NativeObject Property

InsertConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As InsertConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > InsertConstraintProxy Interface > InsertConstraintProxy Properties > InsertConstraintProxy.NativeObject Property


InsertiMateDefinition Interface

InsertiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The InsertiMateDefinition object represents an insert iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::InsertiMateDefinition
        Inventor::InsertiMateDefinitionProxy
Visual Basic
Public Interface InsertiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddInsertiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinition Interface


InsertiMateDefinition Properties

InsertiMateDefinition Properties
Summary

The properties of the InsertiMateDefinition class are listed here.

Properties
Name | Description
AxesOpposed | Property that gets whether the direction of the two axes is opposed.
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.
Distance | Property that returns the Parameter object that controls the distance of the insert iMate definition.
Entity | Property that returns the entity used for the iMate definition.
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinition Interface > InsertiMateDefinition Properties


InsertiMateDefinition.AxesOpposed Property

InsertiMateDefinition.AxesOpposed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets whether the direction of the two axes is opposed.

Visual Basic
Property AxesOpposed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinition Interface > InsertiMateDefinition Properties > InsertiMateDefinition.AxesOpposed Property


InsertiMateDefinition.ConstraintLimits Property

InsertiMateDefinition.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinition Interface > InsertiMateDefinition Properties > InsertiMateDefinition.ConstraintLimits Property


InsertiMateDefinition.Distance Property

InsertiMateDefinition.Distance Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the distance of the insert iMate definition.

Visual Basic
Property Distance() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinition Interface > InsertiMateDefinition Properties > InsertiMateDefinition.Distance Property


InsertiMateDefinition.Entity Property

InsertiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinition Interface > InsertiMateDefinition Properties > InsertiMateDefinition.Entity Property


InsertiMateDefinitionProxy Interface

InsertiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the InsertiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::InsertiMateDefinition
        Inventor::InsertiMateDefinitionProxy
Visual Basic
Public Interface InsertiMateDefinitionProxy
Inherits InsertiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinitionProxy Interface


InsertiMateDefinitionProxy Properties

InsertiMateDefinitionProxy Properties
Summary

The properties of the InsertiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinitionProxy Interface > InsertiMateDefinitionProxy Properties


InsertiMateDefinitionProxy.ContainingOccurrence Property

InsertiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinitionProxy Interface > InsertiMateDefinitionProxy Properties > InsertiMateDefinitionProxy.ContainingOccurrence Property


InsertiMateDefinitionProxy.IsConsumed Property

InsertiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinitionProxy Interface > InsertiMateDefinitionProxy Properties > InsertiMateDefinitionProxy.IsConsumed Property


InsertiMateDefinitionProxy.NativeObject Property

InsertiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > InsertiMateDefinitionProxy Interface > InsertiMateDefinitionProxy Properties > InsertiMateDefinitionProxy.NativeObject Property


InteractionEvents CoClass

InteractionEvents CoClass Available in Inventor Introduced in Inventor 5
Summary

The InteractionEvents object provides the ability to obtain input from the user. This includes selecting objects, various mouse inputs, and using the keyboard.

Class Hierarchy
Inventor::InteractionEvents
Visual Basic
Public Class InteractionEvents
Remarks

The InteractionEvents object has the ability to behave like an Autodesk Inventor command. When started, the currently running command is terminated and it becomes the active command. All input from the user is now directed to the InteractionEvents object. Depending on which events you choose to subscribe to you can listen and respond the user's input. The InteractionEvents object supports some events that are used to allow the InteractionEvents object to behave correctly. For example, if the user starts another command, the OnTerminate event is fired to let you know to abort whatever you are doing and clean up. The InteractionEvents object also provides access to three other event sets: SelectEvents, MouseEvents and KeyboardEvents. The SelectEvents and MouseEvents are mutually exclusive, meaning you can receive events only through one or the other at any given time. Which one of the events sets is firing depends on the value of the SelectionActive property of the InteractionEvents object. The KeyboardEvents can always be listened to and is not restricted by the other events. See here for an overview. Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

CommandManager.CreateInteractionEvents

KeyboardEventsObject.Parent

MeasureEventsObject.Parent

MouseEventsObject.Parent

SelectEventsObject.Parent

TriadEventsObject.Parent

See Also

Window Selection sample

OnDrag Event - dragging a WorkPoint sample

Using measure events sample

Selection Simple sample

Example

See InteractionEventsSink for the "Selection Simple Example "

You are here: Symbol Reference > Inventor Library > Objects > InteractionEvents CoClass


InteractionEventsObject Interface

InteractionEventsObject Interface Available in Inventor Introduced in Inventor 5
Summary

The InteractionEvents object provides the ability to obtain input from the user. This includes selecting objects, various mouse inputs, and using the keyboard.

Class Hierarchy
Inventor::InteractionEventsObject
Visual Basic
Public Interface InteractionEventsObject
Inherits IDispatch
Remarks

The InteractionEvents object has the ability to behave like an Autodesk Inventor command. When started, the currently running command is terminated and it becomes the active command. All input from the user is now directed to the InteractionEvents object. Depending on which events you choose to subscribe to you can listen and respond the user's input. The InteractionEvents object supports some events that are used to allow the InteractionEvents object to behave correctly. For example, if the user starts another command, the OnTerminate event is fired to let you know to abort whatever you are doing and clean up. The InteractionEvents object also provides access to three other event sets: SelectEvents, MouseEvents and KeyboardEvents. The SelectEvents and MouseEvents are mutually exclusive, meaning you can receive events only through one or the other at any given time. Which one of the events sets is firing depends on the value of the SelectionActive property of the InteractionEvents object. The KeyboardEvents can always be listened to and is not restricted by the other events. See here for an overview. Also, see the EventWatcher sample provided in the SDK.

See Also

Window Selection sample

OnDrag Event - dragging a WorkPoint sample

Example

See InteractionEventsSink for the "Selection Simple Example ".

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface


InteractionEventsObject Methods

InteractionEventsObject Methods
Summary

The methods of the InteractionEventsObject class are listed here.

Methods
Methods
Name | Description
CreateMiniToolbar | Method that creates a MiniToolbar object associated with the parent InteractionEvents.
GetCursor | Method that gets the cursor for the command in which this interaction takes place.
SetCursor | Method that sets the cursor for the command in which this interaction takes place.
Start | Method that starts this object working within Autodesk Inventor. The events on the InteractionEvents, MouseEvents, SelectEvents, and KeyboardEvents objects start firing after this method has been invoked. You are expected to have connected up to at least the events the InteractionEvents object. Invocation of this method will cause the OnActivate method of the InteractionEvents object to fire.
Stop | Method that terminates this command, if it's already been started and is running. Invocation of this method will cause the OnTerminate method of the InteractionEvents object to fire.
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Methods


InteractionEventsObject.CreateMiniToolbar Method

InteractionEventsObject.CreateMiniToolbar Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a MiniToolbar object associated with the parent InteractionEvents.

Visual Basic
Sub CreateMiniToolbar(Result As [out, retval] MiniToolbar*)
Remarks

The toolbar is associated with the currently active view and is not displayed until the Visible property on it is set to true. When the InteractionEvents is terminated, this MiniToolbar is automatically deleted.

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Methods > InteractionEventsObject.CreateMiniToolbar Method


InteractionEventsObject.GetCursor Method

InteractionEventsObject.GetCursor Method Available in Inventor Introduced in Inventor 9
Summary

Method that gets the cursor for the command in which this interaction takes place.

Visual Basic
Sub GetCursor(ByRef CursorType As CursorTypeEnum, ByRef Cursor As VARIANT, ByRef CursorHotSpot As CursorHotSpotEnum)
Parameters
Parameters | Description
CursorType | indicating the cursor type.
Cursor | The cursor
CursorHotSpot | indicating the hotspot location relative to the cursor.
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Methods > InteractionEventsObject.GetCursor Method


InteractionEventsObject.SetCursor Method

InteractionEventsObject.SetCursor Method Available in Inventor Introduced in Inventor 9
Summary

Method that sets the cursor for the command in which this interaction takes place.

Visual Basic
Sub SetCursor(CursorType As CursorTypeEnum, ByRef Cursor As [optional] VARIANT, ByRef CursorHotSpot As [optional] VARIANT)
Parameters
Parameters | Description
CursorType | indicating the cursor type.
Cursor | The cursor - IPictureDisp (a bitmap, an icon, or a cursor).
CursorHotSpot | Indicates the location of the cursor hotspot relative to the cursor.
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Methods > InteractionEventsObject.SetCursor Method


InteractionEventsObject.Start Method

InteractionEventsObject.Start Method Available in Inventor Introduced in Inventor 5
Summary

Method that starts this object working within Autodesk Inventor. The events on the InteractionEvents, MouseEvents, SelectEvents, and KeyboardEvents objects start firing after this method has been invoked. You are expected to have connected up to at least the events the InteractionEvents object. Invocation of this method will cause the OnActivate method of the InteractionEvents object to fire.

Visual Basic
Sub Start()
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Methods > InteractionEventsObject.Start Method


InteractionEventsObject.Stop Method

InteractionEventsObject.Stop Method Available in Inventor Introduced in Inventor 5
Summary

Method that terminates this command, if it's already been started and is running. Invocation of this method will cause the OnTerminate method of the InteractionEvents object to fire.

Visual Basic
Sub Stop()
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Methods > InteractionEventsObject.Stop Method


InteractionEventsObject Properties

InteractionEventsObject Properties
Summary

The properties of the InteractionEventsObject class are listed here.

Properties
Name | Description
AllowCommandAliases | Property that gets and sets whether command aliases are allowed while the interaction command is active. Defaults to False.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
InteractionDisabled | Property that gets and sets whether any of the events on the SelectEvents, MouseEvents or KeyboardEvents will be fired.
InteractionGraphics | Gets the InteractionGraphics object. Inventor now supports the creation of preview and overlay graphics. These graphics are similar to ClientGraphics in the way they are created, but their scope is limited to a running InteractionEvents object.
KeyboardEvents | Property that returns the KeyboardEvents object.
MeasureEvents | Property that returns the MeasureEvents object.
MouseEvents | Property that returns the MouseEvents object.
Name | Property that gets and sets the name of the InteractionEvents instance. Ideally, this should be set to the InternalName of the ControlDefinition whose execution resulted in the creation of this InteractionEvents.
Parent | Property that returns the parent command manager of the object.
SelectEvents | Property that returns the SelectEvents object.
StatusBarText | Gets/Sets the status bar message for the command in which this interaction takes place.
TargetDocument | Property that returns the object that the interaction is sought on. All of the data to and fro this and its constituent objects/eventsets relate to this particular document.
TriadEvents | Property that returns the TriadEvents object - for manipulation of the 3D move/rotate tool.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties


InteractionEventsObject.AllowCommandAliases Property

InteractionEventsObject.AllowCommandAliases Property Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets whether command aliases are allowed while the interaction command is active. Defaults to False.

Visual Basic
Property AllowCommandAliases() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.AllowCommandAliases Property


InteractionEventsObject.Application Property

InteractionEventsObject.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.Application Property


InteractionEventsObject.InteractionDisabled Property

InteractionEventsObject.InteractionDisabled Property Available in Inventor Introduced in Inventor 5
Summary

Property that gets and sets whether any of the events on the SelectEvents, MouseEvents or KeyboardEvents will be fired.

Visual Basic
Property InteractionDisabled() As VARIANT_BOOL
Remarks

False indicates that none of them will be fired. It has no effect on the events of the InteractionEvents object, (ie. OnSuspend OnTerminate, OnResume, are always fired regardless of the value of this property).

When the InteractionEvents object is initially created this property is initialized to False.

See Also

Window Selection sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.InteractionDisabled Property


InteractionEventsObject.InteractionGraphics Property

InteractionEventsObject.InteractionGraphics Property Available in Inventor Introduced in Inventor 8
Summary

Gets the InteractionGraphics object. Inventor now supports the creation of preview and overlay graphics. These graphics are similar to ClientGraphics in the way they are created, but their scope is limited to a running InteractionEvents object.

Visual Basic
Property InteractionGraphics() As InteractionGraphics**
Remarks

The advantage of these graphics is that they are very fast for dynamic graphics that are typically used to provide feedback to the end-user during a command. Preview and overlay graphics are not transacted. This is done to gain performance and avoid side effects, like clearing of the selection set. This also means that transacting operations cannot be mixed with preview graphics. The intent here is that the operation is previewed with either preview or overlay graphics. Then, if the user accepts this preview, the operation is committed with "real" operations - which could be modeling operations or regular client graphics, etc. These graphics objects are automatically deleted when the interaction event is stopped or some other command executes (e.g. user does a place component or fillets an edge). They can be deleted but it is not necessary to do so. The only difference between overlay and preview graphics is that overlay graphics can be drawn independently, in a single view (window), and then merged with the last full redraw of the scene by drawing the graphics in a special "overlay" plane. It doesn't mean that the graphics are always drawn on top. You can position them anywhere you want and you can turn on or off "burn through" on them. In short, anything you can do with preview graphics you can do with overlay graphics.

Notes

Less powerful graphics cards may not have the ability to render overlay graphics in this manner so you may not always get this performance boost, but most professional level cards work well.

See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.InteractionGraphics Property


InteractionEventsObject.KeyboardEvents Property

InteractionEventsObject.KeyboardEvents Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the KeyboardEvents object.

Visual Basic
Property KeyboardEvents() As KeyboardEvents**
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.KeyboardEvents Property


InteractionEventsObject.MeasureEvents Property

InteractionEventsObject.MeasureEvents Property Available in Inventor Introduced in Inventor 2009
Summary

Property that returns the MeasureEvents object.

Visual Basic
Property MeasureEvents() As MeasureEvents**
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.MeasureEvents Property


InteractionEventsObject.MouseEvents Property

InteractionEventsObject.MouseEvents Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the MouseEvents object.

Visual Basic
Property MouseEvents() As MouseEvents**
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.MouseEvents Property


InteractionEventsObject.Name Property

InteractionEventsObject.Name Property Available in Inventor Introduced in Inventor 10
Summary

Property that gets and sets the name of the InteractionEvents instance. Ideally, this should be set to the InternalName of the ControlDefinition whose execution resulted in the creation of this InteractionEvents.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.Name Property


InteractionEventsObject.Parent Property

InteractionEventsObject.Parent Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the parent command manager of the object.

Visual Basic
Property Parent() As CommandManager**
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.Parent Property


InteractionEventsObject.SelectEvents Property

InteractionEventsObject.SelectEvents Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the SelectEvents object.

Visual Basic
Property SelectEvents() As SelectEvents**
See Also

Window Selection sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.SelectEvents Property


InteractionEventsObject.StatusBarText Property

InteractionEventsObject.StatusBarText Property Available in Inventor Introduced in Inventor 6
Summary

Gets/Sets the status bar message for the command in which this interaction takes place.

Visual Basic
Property StatusBarText() As String
See Also

Window Selection sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.StatusBarText Property


InteractionEventsObject.TargetDocument Property

InteractionEventsObject.TargetDocument Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the object that the interaction is sought on. All of the data to and fro this and its constituent objects/eventsets relate to this particular document.

Visual Basic
Property TargetDocument() As Document**
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.TargetDocument Property


InteractionEventsObject.TriadEvents Property

InteractionEventsObject.TriadEvents Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the TriadEvents object - for manipulation of the 3D move/rotate tool.

Visual Basic
Property TriadEvents() As TriadEvents**
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.TriadEvents Property


InteractionEventsObject.Type Property

InteractionEventsObject.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsObject Interface > InteractionEventsObject Properties > InteractionEventsObject.Type Property


InteractionEventsSink Interface

InteractionEventsSink Interface Available in Inventor Introduced in Inventor 5
Summary

The InteractionEvents object provides the ability to obtain input from the user. This includes selecting objects, various mouse inputs, and using the keyboard.

Class Hierarchy
Inventor::InteractionEventsSink
Visual Basic
Public Interface InteractionEventsSink
Inherits IDispatch
Remarks

The InteractionEvents object has the ability to behave like an Autodesk Inventor command. When started, the currently running command is terminated and it becomes the active command. All input from the user is now directed to the InteractionEvents object. Depending on which events you choose to subscribe to you can listen and respond the user's input. The InteractionEvents object supports some events that are used to allow the InteractionEvents object to behave correctly. For example, if the user starts another command, the OnTerminate event is fired to let you know to abort whatever you are doing and clean up. The InteractionEvents object also provides access to three other event sets: SelectEvents, MouseEvents and KeyboardEvents. The SelectEvents and MouseEvents are mutually exclusive, meaning you can receive events only through one or the other at any given time. Which one of the events sets is firing depends on the value of the SelectionActive property of the InteractionEvents object. The KeyboardEvents can always be listened to and is not restricted by the other events. See here for an overview. Also, see the EventWatcher sample provided in the SDK.

Example

"Selection Simple Example "

This sample demonstrates using the selection events to select a face. Selection is dependent on events and VB only supports events within a class module.

To use the sample copy the TestSelection sub into a code module. Create a new class module called clsSelect and copy all of the rest of the code into it. To run the sample, have a part document open that contains some geometry and run the TestSelection sub. Select a face and it will display its area.

Public Sub TestSelection()
    ' Create a new clsSelect object.
    Dim oSelect As New clsSelect

    ' Call the pick method of the clsSelect object and set
    ' the filter to pick any face.
    Dim oFace As Face
    Set oFace = oSelect.Pick(kPartFaceFilter)

    ' Check to make sure an object was selected.
    If Not oFace Is Nothing Then
        ' Display the area of the selected face.
        MsgBox "Face area: " & oFace.Evaluator.Area & " cm^2"
    End If
End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsSelect". The name can be
' changed but you'll need to change the declaration in the
' calling function "TestSelection" to use the new name.

' Declare the event objects
Private WithEvents oInteractEvents As InteractionEvents
Private WithEvents oSelectEvents As SelectEvents

' Declare a flag that's used to determine when selection stops.
Private bStillSelecting As Boolean

Public Function Pick(filter As SelectionFilterEnum) As Object
    ' Initialize flag.
    bStillSelecting = True

    ' Create an InteractionEvents object.
    Set oInteractEvents = ThisApplication.CommandManager.CreateInteractionEvents

    ' Ensure interaction is enabled.
    oInteractEvents.InteractionDisabled = False

    ' Set a reference to the select events.
    Set oSelectEvents = oInteractEvents.SelectEvents

    ' Set the filter using the value passed in.
    oSelectEvents.AddSelectionFilter filter

    ' Start the InteractionEvents object.
    oInteractEvents.Start

    ' Loop until a selection is made.
    Do While bStillSelecting
        ThisApplication.UserInterfaceManager.DoEvents
    Loop

    ' Get the selected item. If more than one thing was selected,
    ' just get the first item and ignore the rest.
    Dim oSelectedEnts As ObjectsEnumerator
    Set oSelectedEnts = oSelectEvents.SelectedEntities
    If oSelectedEnts.Count > 0 Then
        Set Pick = oSelectedEnts.Item(1)
    Else
        Set Pick = Nothing
    End If

    ' Stop the InteractionEvents object.
    oInteractEvents.Stop

    ' Clean up.
    Set oSelectEvents = Nothing
    Set oInteractEvents = Nothing
End Function

Private Sub oInteractEvents_OnTerminate()
    ' Set the flag to indicate we're done.
    bStillSelecting = False
End Sub

Private Sub oSelectEvents_OnSelect(ByVal JustSelectedEntities As ObjectsEnumerator, ByVal SelectionDevice As SelectionDeviceEnum, ByVal ModelPosition As Point, ByVal ViewPosition As Point2d, ByVal View As View)
    ' Set the flag to indicate we're done.
    bStillSelecting = False
End Sub
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface


InteractionEventsSink Methods

InteractionEventsSink Methods
Summary

The methods of the InteractionEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivate | Event that notifies the command that control has been passed to it. This event is fired when the command initially starts, (when the Start method has been called).
OnHelp | Event that fires to signal the client to present help for the associated activity.
OnResume | Event that notifies the command to resume execution after being suspended.
OnSuspend | Event that notifies the InteractionEvents object to temporarily suspend itself. This happens when the user selects a command that stacks on the current command. Invocation of any of the view commands will cause the stacking behavior.
OnTerminate | Event that notifies the command has been terminated. This can happen when the user selects another command or presses escape. It can be forced by calling the Stop method on the InteractionEvents object as well.
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface > InteractionEventsSink Methods


InteractionEventsSink.OnActivate Method

InteractionEventsSink.OnActivate Method Available in Inventor Introduced in Inventor 5
Summary

Event that notifies the command that control has been passed to it. This event is fired when the command initially starts, (when the Start method has been called).

Visual Basic
Sub OnActivate()
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface > InteractionEventsSink Methods > InteractionEventsSink.OnActivate Method


InteractionEventsSink.OnHelp Method

InteractionEventsSink.OnHelp Method Available in Inventor Introduced in Inventor 7
Summary

Event that fires to signal the client to present help for the associated activity.

Visual Basic
Sub OnHelp(BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
BeforeOrAfter | Input indicating if the event is being fired before (kBefore) or after (kAfter) the assembly structure is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. In this case it specifies whether the user pressed the F1 key or selected "How to..." from the context menu. A value of "Help" maps to the F1 key, and "HowTo" to the context menu.
HandlingCode | Output that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface > InteractionEventsSink Methods > InteractionEventsSink.OnHelp Method


InteractionEventsSink.OnResume Method

InteractionEventsSink.OnResume Method Available in Inventor Introduced in Inventor 5
Summary

Event that notifies the command to resume execution after being suspended.

Visual Basic
Sub OnResume()
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface > InteractionEventsSink Methods > InteractionEventsSink.OnResume Method


InteractionEventsSink.OnSuspend Method

InteractionEventsSink.OnSuspend Method Available in Inventor Introduced in Inventor 5
Summary

Event that notifies the InteractionEvents object to temporarily suspend itself. This happens when the user selects a command that stacks on the current command. Invocation of any of the view commands will cause the stacking behavior.

Visual Basic
Sub OnSuspend()
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface > InteractionEventsSink Methods > InteractionEventsSink.OnSuspend Method


InteractionEventsSink.OnTerminate Method

InteractionEventsSink.OnTerminate Method Available in Inventor Introduced in Inventor 5
Summary

Event that notifies the command has been terminated. This can happen when the user selects another command or presses escape. It can be forced by calling the Stop method on the InteractionEvents object as well.

Visual Basic
Sub OnTerminate()
You are here: Symbol Reference > Inventor Library > Objects > InteractionEventsSink Interface > InteractionEventsSink Methods > InteractionEventsSink.OnTerminate Method


InteractionGraphics Interface

InteractionGraphics Interface Available in Inventor Introduced in Inventor 8
Summary

Inventor supports the creation of preview and overlay graphics.

Class Hierarchy
Inventor::InteractionGraphics
Visual Basic
Public Interface InteractionGraphics
Inherits IDispatch
Remarks

These graphics objects are similar to in the way they are created, but are transient in nature. Their creation is not transacted. The advantage of these graphics is that they are very fast for dynamic graphics that are typically used to provide feedback to the end-user during a command. Preview and overlay graphics are not transacted. This is done to gain performance and avoid side effects, like clearing of the selection set. This also means that transacting operations cannot be mixed with preview graphics. The intent here is that the operation is previewed with either preview or overlay graphics. Then, if the user accepts this preview, the operation is committed with "real" operations - which could be modeling operations or regular client graphics, etc. These graphics objects are automatically deleted when the interaction event is stopped or some other command executes (e.g. user does a place component or fillets an edge). They can be deleted but it isnG't necessary to do so. The only difference between overlay and preview graphics is that overlay graphics can be drawn independently, in a single view (window), and then merged with the last full redraw of the scene by drawing the graphics in a special "overlay" plane. It doesnG't mean that the graphics are always drawn on top. You can position them anywhere you want and you can turn on or off "burn through" on them. In short, anything you can do with preview graphics you can do with overlay graphics.

Notes

Members through which this object may be accessed include:

InteractionEventsObject.InteractionGraphics

Less powerful graphics cards may not have the ability to render overlay graphics in this manner so you may not always get this performance boost, but most professional level cards work well.

See Also

OnDrag Event - dragging a WorkPoint sample

Example

"InteractionGraphics"

The sample creates overlay graphics. Follow these steps: 1. Have a drawing document open. 2. Cut and paste in a VBA module. 3. Run the sample. Overlay graphics is created. 4. Hit the escape key to end interaction events and bring down the graphics.

Dim oIE As InteractionEvents

Public Sub DrawOverlayGraphics()

    Dim oDoc As Document

    Set oDoc = ThisApplication.ActiveDocument

    Set oIE = ThisApplication.CommandManager.CreateInteractionEvents

    oIE.Start

    Dim oIG As InteractionGraphics

    Set oIG = oIE.InteractionGraphics

    On Error Resume Next

    Dim oDataSets As GraphicsDataSets

    Set oDataSets = oIG.GraphicsDataSets

    ' Set a reference to the transient geometry object for use later.

    Dim oTransGeom As TransientGeometry

    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create a coordinate set.

    Dim oCoordSet As GraphicsCoordinateSet

    Set oCoordSet = oDataSets.CreateCoordinateSet(1)

    ' Create an array that contains coordinates that define a set

    ' of outwardly spiraling points.

    Dim oPointCoords(1 To 90) As Double

    Dim i As Long

    Dim dRadius As Double

    dRadius = 1

    Dim dAngle As Double

    For i = 0 To 29

        ' Define the X, Y, and Z components of the point.

        oPointCoords(i * 3 + 1) = dRadius * Cos(dAngle)

        oPointCoords(i * 3 + 2) = dRadius * Sin(dAngle)

        oPointCoords(i * 3 + 3) = i / 2

        ' Increment the angle and radius to create the spiral.

        dRadius = dRadius + 0.25

        dAngle = dAngle + (3.14159265358979 / 6)

    Next

    ' Assign the points into the coordinate set.

    Call oCoordSet.PutCoordinates(oPointCoords)

    ' Create the ClientGraphics object.

    Dim oClientGraphics As ClientGraphics

    Set oClientGraphics = oIG.OverlayClientGraphics

    ' Create a new graphics node within the client graphics objects.

    Dim oLineNode As GraphicsNode

    Set oLineNode = oClientGraphics.AddNode(1)

    ' Create a LineGraphics object within the node.

    Dim oLineSet As LineGraphics

    Set oLineSet = oLineNode.AddLineGraphics

    ' Assign the coordinate set to the line graphics.

    oLineSet.CoordinateSet = oCoordSet

    ' Update the view to see the resulting spiral.

    oIG.UpdateOverlayGraphics ThisApplication.ActiveView

    ' Create another graphics node for a line strip.

    Dim oLineStripNode As GraphicsNode

    Set oLineStripNode = oClientGraphics.AddNode(2)

    ' Create a LineStripGraphics object within the new node.

    Dim oLineStrip As LineStripGraphics

    Set oLineStrip = oLineStripNode.AddLineStripGraphics

    ' Assign the same coordinate set to the line strip.

    oLineStrip.CoordinateSet = oCoordSet

    ' Create a color set to use in defining a explicit color to the line strip.

    Dim oColorSet As GraphicsColorSet

    Set oColorSet = oDataSets.CreateColorSet(1)

    ' Add a single color to the set that is red.

    Call oColorSet.Add(1, 255, 0, 0)

    ' Assign the color set to the line strip.

    oLineStrip.ColorSet = oColorSet

    ' The two spirals are currently on top of each other so translate the

    ' new one in the x direction so they're side by side.

    Dim oMatrix As Matrix

    Set oMatrix = oLineStripNode.Transformation

    Call oMatrix.SetTranslation(oTransGeom.CreateVector(15, 0, 0))

    oLineStripNode.Transformation = oMatrix

    ' Update the view to see the resulting spiral.

    oIG.UpdateOverlayGraphics ThisApplication.ActiveView

    'oIE.Stop

End Sub
You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface


InteractionGraphics Methods

InteractionGraphics Methods
Summary

The methods of the InteractionGraphics class are listed here.

Methods
Methods
Name | Description
UpdateOverlayGraphics | Redraw just the overlay graphics only in a specified view.
You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Methods


InteractionGraphics.UpdateOverlayGraphics Method

InteractionGraphics.UpdateOverlayGraphics Method Available in Inventor Introduced in Inventor 8
Summary

Redraw just the overlay graphics only in a specified view.

Visual Basic
Sub UpdateOverlayGraphics(TheView As View)
Parameters
Parameters | Description
TheView | View object representing the view to redraw.
See Also

InteractionGraphics sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Methods > InteractionGraphics.UpdateOverlayGraphics Method


InteractionGraphics Properties

InteractionGraphics Properties
Summary

The properties of the InteractionGraphics class are listed here.

Properties
Name | Description
GraphicsDataSets | The object that can be used with the preview and overlay graphics properties.
OverlayClientGraphics | The top level object for graphics that are rendered independently from the main scene.
PreviewClientGraphics | The top level object for graphics that are rendered with the main scene.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Properties


InteractionGraphics.GraphicsDataSets Property

InteractionGraphics.GraphicsDataSets Property Available in Inventor Introduced in Inventor 8
Summary

The object that can be used with the preview and overlay graphics properties.

Visual Basic
Property GraphicsDataSets() As GraphicsDataSets**
See Also

OnDrag Event - dragging a WorkPoint sample

InteractionGraphics sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Properties > InteractionGraphics.GraphicsDataSets Property


InteractionGraphics.OverlayClientGraphics Property

InteractionGraphics.OverlayClientGraphics Property Available in Inventor Introduced in Inventor 8
Summary

The top level object for graphics that are rendered independently from the main scene.

Visual Basic
Property OverlayClientGraphics() As ClientGraphics**
You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Properties > InteractionGraphics.OverlayClientGraphics Property


InteractionGraphics.PreviewClientGraphics Property

InteractionGraphics.PreviewClientGraphics Property Available in Inventor Introduced in Inventor 8
Summary

The top level object for graphics that are rendered with the main scene.

Visual Basic
Property PreviewClientGraphics() As ClientGraphics**
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Properties > InteractionGraphics.PreviewClientGraphics Property


InteractionGraphics.Type Property

InteractionGraphics.Type Property Available in Inventor Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InteractionGraphics Interface > InteractionGraphics Properties > InteractionGraphics.Type Property


InterferenceResult Interface

InterferenceResult Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

In an assembly, two or more components cannot occupy the same space at the same time. To detect such errors, you can analyze assemblies for interference.

Class Hierarchy
Inventor::InterferenceResult
Visual Basic
Public Interface InterferenceResult
Inherits IDispatch
Remarks

Where components overlap, there is said to be an interference between them. The interference API detects the volume of interference between the components that overlap. This object contains information about the results of the interference analysis.

Notes

Members through which this object may be accessed include:

InterferenceResults.Item

You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface


InterferenceResult Properties

InterferenceResult Properties
Summary

The properties of the InterferenceResult class are listed here.

Properties
Name | Description
Centroid | Property that returns the centroid of the volume of interference.
InterferenceBody | This is InterferenceBody, a member of class InterferenceResult.
OccurrenceOne | Property that returns the first interfering .
OccurrenceTwo | Property that returns the second interfering .
Type | Property returning an enum indicating this object's type.
Volume | Property that returns the volume of interference in cubic centimeters.
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties


InterferenceResult.Centroid Property

InterferenceResult.Centroid Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the centroid of the volume of interference.

Visual Basic
Property Centroid() As Point**
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties > InterferenceResult.Centroid Property


InterferenceResult.InterferenceBody Property

InterferenceResult.InterferenceBody Property
Summary

This is InterferenceBody, a member of class InterferenceResult.

Visual Basic
Property InterferenceBody() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties > InterferenceResult.InterferenceBody Property


InterferenceResult.OccurrenceOne Property

InterferenceResult.OccurrenceOne Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the first interfering .

Visual Basic
Property OccurrenceOne() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties > InterferenceResult.OccurrenceOne Property


InterferenceResult.OccurrenceTwo Property

InterferenceResult.OccurrenceTwo Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the second interfering .

Visual Basic
Property OccurrenceTwo() As ComponentOccurrence**
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties > InterferenceResult.OccurrenceTwo Property


InterferenceResult.Type Property

InterferenceResult.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties > InterferenceResult.Type Property


InterferenceResult.Volume Property

InterferenceResult.Volume Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the volume of interference in cubic centimeters.

Visual Basic
Property Volume() As double*
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResult Interface > InterferenceResult Properties > InterferenceResult.Volume Property


InterferenceResults Interface

InterferenceResults Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

In an assembly, two or more components cannot occupy the same space at the same time. To detect such errors, you can analyze assemblies for interference.

Class Hierarchy
Inventor::InterferenceResults
Visual Basic
Public Interface InterferenceResults
Inherits IDispatch
Remarks

Where components overlap, there is said to be an interference between them. The interference API detects the volume of interference between the components that overlap. This object represents a collection of InterferenceResult objects.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.AnalyzeInterference

See Also

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > InterferenceResults Interface


InterferenceResults Methods

InterferenceResults Methods
Summary

The methods of the InterferenceResults class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified InterferenceResult object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResults Interface > InterferenceResults Methods


InterferenceResults.Item Method

InterferenceResults.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified InterferenceResult object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] InterferenceResult*)
Parameters
Parameters | Description
index | Input value that specifies the InterferenceResult object to return. If an out-of-range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResults Interface > InterferenceResults Methods > InterferenceResults.Item Method


InterferenceResults Properties

InterferenceResults Properties
Summary

The properties of the InterferenceResults class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResults Interface > InterferenceResults Properties


InterferenceResults.Count Property

InterferenceResults.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResults Interface > InterferenceResults Properties > InterferenceResults.Count Property


InterferenceResults.Type Property

InterferenceResults.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InterferenceResults Interface > InterferenceResults Properties > InterferenceResults.Type Property


InventorServer CoClass

InventorServer CoClass
Summary

The top-level object in the server environment, equivalent to the Application object in previous versions of Inventor.

Class Hierarchy
Inventor::InventorServer
Visual Basic
Public Class InventorServer
You are here: Symbol Reference > Inventor Library > Objects > InventorServer CoClass


InventorVBAArgument Interface

InventorVBAArgument Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Represents a VBAArgument object.

Class Hierarchy
Inventor::InventorVBAArgument
Visual Basic
Public Interface InventorVBAArgument
Inherits IDispatch
Notes

Members through which this object may be accessed include:

InventorVBAArguments.Item

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface


InventorVBAArgument Properties

InventorVBAArgument Properties
Summary

The properties of the InventorVBAArgument class are listed here.

Properties
Name | Description
ArgumentType | Property that returns the argument's type.
Name | Property that returns the argument's name.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
Value | Get/Sets the argument's value.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface > InventorVBAArgument Properties


InventorVBAArgument.ArgumentType Property

InventorVBAArgument.ArgumentType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the argument's type.

Visual Basic
Property ArgumentType() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface > InventorVBAArgument Properties > InventorVBAArgument.ArgumentType Property


InventorVBAArgument.Name Property

InventorVBAArgument.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the argument's name.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface > InventorVBAArgument Properties > InventorVBAArgument.Name Property


InventorVBAArgument.Parent Property

InventorVBAArgument.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InventorVBAMember**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface > InventorVBAArgument Properties > InventorVBAArgument.Parent Property


InventorVBAArgument.Type Property

InventorVBAArgument.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface > InventorVBAArgument Properties > InventorVBAArgument.Type Property


InventorVBAArgument.Value Property

InventorVBAArgument.Value Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Get/Sets the argument's value.

Visual Basic
Property Value() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArgument Interface > InventorVBAArgument Properties > InventorVBAArgument.Value Property


InventorVBAArguments Interface

InventorVBAArguments Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Represents a collection of objects in an InventorVBAMember.

Class Hierarchy
Inventor::InventorVBAArguments
Visual Basic
Public Interface InventorVBAArguments
Inherits IDispatch
Notes

Members through which this object may be accessed include:

InventorVBAMember.Arguments

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface


InventorVBAArguments Methods

InventorVBAArguments Methods
Summary

The methods of the InventorVBAArguments class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified InventorVBAArgument object from the collection. This is the default property of the InventorVBAArguments collection object.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface > InventorVBAArguments Methods


InventorVBAArguments.Item Method

InventorVBAArguments.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified InventorVBAArgument object from the collection. This is the default property of the InventorVBAArguments collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] InventorVBAArgument*)
Parameters
Parameters | Description
index | Input Variant value that specifies the OccurrencePattern to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the pattern name. This is the name that is displayed to the user in the assembly browser. If an out of range index or a name of a non-existent occurrence name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface > InventorVBAArguments Methods > InventorVBAArguments.Item Method


InventorVBAArguments Properties

InventorVBAArguments Properties
Summary

The properties of the InventorVBAArguments class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface > InventorVBAArguments Properties


InventorVBAArguments.Count Property

InventorVBAArguments.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface > InventorVBAArguments Properties > InventorVBAArguments.Count Property


InventorVBAArguments.Parent Property

InventorVBAArguments.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InventorVBAMember**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface > InventorVBAArguments Properties > InventorVBAArguments.Parent Property


InventorVBAArguments.Type Property

InventorVBAArguments.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAArguments Interface > InventorVBAArguments Properties > InventorVBAArguments.Type Property


InventorVBAComponent Interface

InventorVBAComponent Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The InventorVBAComponent object represents a code, class or form module.

Class Hierarchy
Inventor::InventorVBAComponent
Visual Basic
Public Interface InventorVBAComponent
Inherits IDispatch
Notes

Members through which this object may be accessed include:

InventorVBAComponents.Add

InventorVBAComponents.Item

InventorVBAMember.Parent

InventorVBAMembers.Parent

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface


InventorVBAComponent Properties

InventorVBAComponent Properties
Summary

The properties of the InventorVBAComponent class are listed here.

Properties
Name | Description
InventorVBAMembers | Property that returns the InventorVBAMembers collection.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
VBComponent | Property that returns the VBComponent object corresponding to this InventorVBAComponent.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface > InventorVBAComponent Properties


InventorVBAComponent.InventorVBAMembers Property

InventorVBAComponent.InventorVBAMembers Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the InventorVBAMembers collection.

Visual Basic
Property InventorVBAMembers() As InventorVBAMembers**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface > InventorVBAComponent Properties > InventorVBAComponent.InventorVBAMembers Property


InventorVBAComponent.Name Property

InventorVBAComponent.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface > InventorVBAComponent Properties > InventorVBAComponent.Name Property


InventorVBAComponent.Parent Property

InventorVBAComponent.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InventorVBAProject**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface > InventorVBAComponent Properties > InventorVBAComponent.Parent Property


InventorVBAComponent.Type Property

InventorVBAComponent.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface > InventorVBAComponent Properties > InventorVBAComponent.Type Property


InventorVBAComponent.VBComponent Property

InventorVBAComponent.VBComponent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the VBComponent object corresponding to this InventorVBAComponent.

Visual Basic
Property VBComponent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponent Interface > InventorVBAComponent Properties > InventorVBAComponent.VBComponent Property


InventorVBAComponents Interface

InventorVBAComponents Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The InventorVBAComponents collection object represents a collection of objects in an InventorVBAProject, and provides methods to create new InventorVBAComponent objects.

Class Hierarchy
Inventor::InventorVBAComponents
Visual Basic
Public Interface InventorVBAComponents
Inherits IDispatch
Notes

Members through which this object may be accessed include:

InventorVBAProject.InventorVBAComponents

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface


InventorVBAComponents Methods

InventorVBAComponents Methods
Summary

The methods of the InventorVBAComponents class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a component to the collection.
Item | Property that returns the specified InventorVBAComponent object from the collection. This is the default property of the InventorVBAComponents collection object.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Methods


InventorVBAComponents.Add Method

InventorVBAComponents.Add Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that adds a component to the collection.

Visual Basic
Sub Add(Name As String, Result As [out, retval] InventorVBAComponent*)
Parameters
Parameters | Description
Name | Input String that specifies the name of the new component to add to the collection.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Methods > InventorVBAComponents.Add Method


InventorVBAComponents.Item Method

InventorVBAComponents.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified InventorVBAComponent object from the collection. This is the default property of the InventorVBAComponents collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] InventorVBAComponent*)
Parameters
Parameters | Description
index | Input Variant value that specifies the InventorVBAComponent to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the component's name. If an out-of-range index or a name of a non-existent component name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Methods > InventorVBAComponents.Item Method


InventorVBAComponents Properties

InventorVBAComponents Properties
Summary

The properties of the InventorVBAComponents class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Properties


InventorVBAComponents.Count Property

InventorVBAComponents.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Properties > InventorVBAComponents.Count Property


InventorVBAComponents.Parent Property

InventorVBAComponents.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InventorVBAProject**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Properties > InventorVBAComponents.Parent Property


InventorVBAComponents.Type Property

InventorVBAComponents.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAComponents Interface > InventorVBAComponents Properties > InventorVBAComponents.Type Property


InventorVBAMember Interface

InventorVBAMember Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Represents a member within a InventorVBAComponent.

Class Hierarchy
Inventor::InventorVBAMember
Visual Basic
Public Interface InventorVBAMember
Inherits IDispatch
Notes

Members through which this object may be accessed include:

InventorVBAArgument.Parent

InventorVBAArguments.Parent

InventorVBAMembers.Item

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface


InventorVBAMember Methods

InventorVBAMember Methods
Summary

The methods of the InventorVBAMember class are listed here.

Methods
Methods
Name | Description
Execute | Method that is used to execute this member.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Methods


InventorVBAMember.Execute Method

InventorVBAMember.Execute Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that is used to execute this member.

Visual Basic
Sub Execute(ByRef FunctionReturnValue As [optional] VARIANT)
Parameters
Parameters | Description
FunctionReturnValue | Optional input Variant that specifies the function's return value.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Methods > InventorVBAMember.Execute Method


InventorVBAMember Properties

InventorVBAMember Properties
Summary

The properties of the InventorVBAMember class are listed here.

Properties
Name | Description
Arguments | Property that returns the collection containing the member's arguments.
MemberType | Property that returns a constant that specifies the member type.
Name | Property that indicates the member's display name.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
VBMember | Property that returns the member object that corresponds to this InventorVBAMember object.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties


InventorVBAMember.Arguments Property

InventorVBAMember.Arguments Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection containing the member's arguments.

Visual Basic
Property Arguments() As InventorVBAArguments**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties > InventorVBAMember.Arguments Property


InventorVBAMember.MemberType Property

InventorVBAMember.MemberType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a constant that specifies the member type.

Visual Basic
Property MemberType() As MemberTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties > InventorVBAMember.MemberType Property


InventorVBAMember.Name Property

InventorVBAMember.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the member's display name.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties > InventorVBAMember.Name Property


InventorVBAMember.Parent Property

InventorVBAMember.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InventorVBAComponent**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties > InventorVBAMember.Parent Property


InventorVBAMember.Type Property

InventorVBAMember.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties > InventorVBAMember.Type Property


InventorVBAMember.VBMember Property

InventorVBAMember.VBMember Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the member object that corresponds to this InventorVBAMember object.

Visual Basic
Property VBMember() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMember Interface > InventorVBAMember Properties > InventorVBAMember.VBMember Property


InventorVBAMembers Interface

InventorVBAMembers Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Represents a collection of objects in an InventorVBAComponent object.

Class Hierarchy
Inventor::InventorVBAMembers
Visual Basic
Public Interface InventorVBAMembers
Inherits IDispatch
Notes

Members through which this object may be accessed include:

InventorVBAComponent.InventorVBAMembers

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface


InventorVBAMembers Methods

InventorVBAMembers Methods
Summary

The methods of the InventorVBAMembers class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified InventorVBAMember object from the collection. This is the default property of the InventorVBAMemberscollection object.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface > InventorVBAMembers Methods


InventorVBAMembers.Item Method

InventorVBAMembers.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified InventorVBAMember object from the collection. This is the default property of the InventorVBAMemberscollection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] InventorVBAMember*)
Parameters
Parameters | Description
index | Input Variant value that specifies the InventorVBAMember to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the member name. If an out of range index or a name of a non-existent name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface > InventorVBAMembers Methods > InventorVBAMembers.Item Method


InventorVBAMembers Properties

InventorVBAMembers Properties
Summary

The properties of the InventorVBAMembers class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface > InventorVBAMembers Properties


InventorVBAMembers.Count Property

InventorVBAMembers.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface > InventorVBAMembers Properties > InventorVBAMembers.Count Property


InventorVBAMembers.Parent Property

InventorVBAMembers.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InventorVBAComponent**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface > InventorVBAMembers Properties > InventorVBAMembers.Parent Property


InventorVBAMembers.Type Property

InventorVBAMembers.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAMembers Interface > InventorVBAMembers Properties > InventorVBAMembers.Type Property


InventorVBAProject Interface

InventorVBAProject Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Represents Autodesk Inventor's VBA project.

Class Hierarchy
Inventor::InventorVBAProject
Visual Basic
Public Interface InventorVBAProject
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Document.VBAProject

InventorVBAComponent.Parent

InventorVBAComponents.Parent

InventorVBAProjects.Add

InventorVBAProjects.Item

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface


InventorVBAProject Methods

InventorVBAProject Methods
Summary

The methods of the InventorVBAProject class are listed here.

Methods
Methods
Name | Description
Close | Method that closes this project. Please note that this method works only for user-defined VBA projects. It will not work with Application or Document VBA projects, which are built in.
Save | Method that saves the VBA project.
SaveAs | Method that saves the project to a specified location. Please note that this method works only for user-defined VBA projects. It will not work with Application or Document VBA projects, which are built in.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Methods


InventorVBAProject.Close Method

InventorVBAProject.Close Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that closes this project. Please note that this method works only for user-defined VBA projects. It will not work with Application or Document VBA projects, which are built in.

Visual Basic
Sub Close()
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Methods > InventorVBAProject.Close Method


InventorVBAProject.Save Method

InventorVBAProject.Save Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that saves the VBA project.

Visual Basic
Sub Save()
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Methods > InventorVBAProject.Save Method


InventorVBAProject.SaveAs Method

InventorVBAProject.SaveAs Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that saves the project to a specified location. Please note that this method works only for user-defined VBA projects. It will not work with Application or Document VBA projects, which are built in.

Visual Basic
Sub SaveAs(FullFileName As String)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full path of the project file to save.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Methods > InventorVBAProject.SaveAs Method


InventorVBAProject Properties

InventorVBAProject Properties
Summary

The properties of the InventorVBAProject class are listed here.

Properties
Name | Description
InventorVBAComponents | Gets the InventorVBAComponents contained in this project.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent object from whom this object can logically be reached.
ProjectType | Property that returns a constant specifying the type of VBA project this project is.
Saved | Property that indicates if this project has been saved or not.
Type | Property returning an enum indicating this object's type.
VBProject | Property that returns the VBA project that corresponds to this InventorVBAProject.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties


InventorVBAProject.InventorVBAComponents Property

InventorVBAProject.InventorVBAComponents Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the InventorVBAComponents contained in this project.

Visual Basic
Property InventorVBAComponents() As InventorVBAComponents**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.InventorVBAComponents Property


InventorVBAProject.Name Property

InventorVBAProject.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.Name Property


InventorVBAProject.Parent Property

InventorVBAProject.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.Parent Property


InventorVBAProject.ProjectType Property

InventorVBAProject.ProjectType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a constant specifying the type of VBA project this project is.

Visual Basic
Property ProjectType() As VBAProjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.ProjectType Property


InventorVBAProject.Saved Property

InventorVBAProject.Saved Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates if this project has been saved or not.

Visual Basic
Property Saved() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.Saved Property


InventorVBAProject.Type Property

InventorVBAProject.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.Type Property


InventorVBAProject.VBProject Property

InventorVBAProject.VBProject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the VBA project that corresponds to this InventorVBAProject.

Visual Basic
Property VBProject() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProject Interface > InventorVBAProject Properties > InventorVBAProject.VBProject Property


InventorVBAProjects Interface

InventorVBAProjects Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

A collection of Autodesk Inventor's VBA projects ( objects).

Class Hierarchy
Inventor::InventorVBAProjects
Visual Basic
Public Interface InventorVBAProjects
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.VBAProjects

You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface


InventorVBAProjects Methods

InventorVBAProjects Methods
Summary

The methods of the InventorVBAProjects class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Autodesk Inventor VBA project. Please note that this method works only for user-defined VBA projects.
Item | Property that returns the specified InventorVBAProject object from the collection.
Open | Method that opens the specified VBA project.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Methods


InventorVBAProjects.Add Method

InventorVBAProjects.Add Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new Autodesk Inventor VBA project. Please note that this method works only for user-defined VBA projects.

Visual Basic
Sub Add(Result As [out, retval] InventorVBAProject*)
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Methods > InventorVBAProjects.Add Method


InventorVBAProjects.Item Method

InventorVBAProjects.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified InventorVBAProject object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] InventorVBAProject*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Methods > InventorVBAProjects.Item Method


InventorVBAProjects.Open Method

InventorVBAProjects.Open Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that opens the specified VBA project.

Visual Basic
Sub Open(FullFileName As String)
Parameters
Parameters | Description
FullFileName | Input String that specifies the name of the project file to open.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Methods > InventorVBAProjects.Open Method


InventorVBAProjects Properties

InventorVBAProjects Properties
Summary

The properties of the InventorVBAProjects class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in the collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Properties


InventorVBAProjects.Count Property

InventorVBAProjects.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Properties > InventorVBAProjects.Count Property


InventorVBAProjects.Parent Property

InventorVBAProjects.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Properties > InventorVBAProjects.Parent Property


InventorVBAProjects.Type Property

InventorVBAProjects.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > InventorVBAProjects Interface > InventorVBAProjects Properties > InventorVBAProjects.Type Property


iPartFactory Interface

iPartFactory Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iPartFactory object provides access to the iPart table and provides methods to create additional iPart members ( objects).

Class Hierarchy
Inventor::iPartFactory
Visual Basic
Public Interface iPartFactory
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iPartMember.ParentFactory

iPartTableCell.Parent

iPartTableColumn.Parent

iPartTableRow.Parent

PartComponentDefinition.iPartFactory

PartComponentDefinition.CreateFactory

See Also

Create a Configuration Table sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface


iPartFactory Methods

iPartFactory Methods
Summary

The methods of the iPartFactory class are listed here.

Methods
Methods
Name | Description
CreateCustomMember | Method that creates an iPart member for a custom factory using the parameter values in a row. The created iPartMember is returned.
CreateMember | Method that creates an iPart member using the parameter values in a row. The created iPartMember is returned.
Delete | Method that converts an iPart factory to a regular part. When an iPart factory is converted to a regular part, all of the iPart members created from the factory become sick.
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Methods


iPartFactory.CreateCustomMember Method

iPartFactory.CreateCustomMember Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates an iPart member for a custom factory using the parameter values in a row. The created iPartMember is returned.

Visual Basic
Sub CreateCustomMember(FullFileName As String, ByRef Row As [optional] VARIANT, ByRef CustomInput As [optional] VARIANT, Result As [out, retval] iPartMember*)
Parameters
Parameters | Description
FullFileName | Input String that specifies the full filename of the iPart member.
Row | Optional input Variant that specifies the row number within an iPart table. The row index is specified either by a Long (row index), a String (PartIdentifier), or an iPartTableRow object. If a RowIndex is not specified, default row will be used to create the iPart member.
CustomInput | Optional input safearray of Strings that specifies the input to use for the custom input. If the factory is a custom factory and this is not supplied the default values for custom values are used. The custom input strings are supplied in a column order. If the factory is not a custom factory this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Methods > iPartFactory.CreateCustomMember Method


iPartFactory.CreateMember Method

iPartFactory.CreateMember Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates an iPart member using the parameter values in a row. The created iPartMember is returned.

Visual Basic
Sub CreateMember(ByRef Row As [optional] VARIANT, Result As [out, retval] iPartMember*)
Parameters
Parameters | Description
Row | Optional input Variant that specifies the row number within an iPart table. The row index is specified either by a Long (row index), a String (PartIdentifier), or an iPartTableRow object. If a RowIndex is not specified, the default row will be used to create the iPart member.
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Methods > iPartFactory.CreateMember Method


iPartFactory.Delete Method

iPartFactory.Delete Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that converts an iPart factory to a regular part. When an iPart factory is converted to a regular part, all of the iPart members created from the factory become sick.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Methods > iPartFactory.Delete Method


iPartFactory Properties

iPartFactory Properties
Summary

The properties of the iPartFactory class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CustomFactory | Property that specifies whether this iPartFactory object represents a custom factory or a standard factory. This property is True in the case where it represents a custom factory.
DefaultRow | Property that returns the default row for this iPartFactory. The part shown in the iPart factory is computed with the values in the default row. Also, in the absence of a row input to the CreateMember method, the values in this row will be used to create a new iPart member object.
DisplayStyleColumn | Property that gets and sets the column to use as the display (render) style column.
ExcelWorkSheet | Property that returns the Excel spreadsheet that represents the iPart table.
FactoryOptions | Property that gets the options for the factory.
FileNameColumn | Property that gets and sets the column to use as the file name column.
MaterialColumn | Property that gets and sets the column to use as the material column.
MemberCacheDir | Property that returns the directory location for the newly created iPart members.
MemberEditScope | Property that gets and sets whether the edits to a member should affect just the active member or all members within the factory. Valid values are kEditActiveMember and kEditAllMembers. This value is not persisted.
Parent | Property that returns the parent PartDocument of the factory.
TableColumns | Property that returns the iPartTableColumns collection object.
TableRows | Property that returns the iPartTableRows collection object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties


iPartFactory.Application Property

iPartFactory.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.Application Property


iPartFactory.CustomFactory Property

iPartFactory.CustomFactory Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that specifies whether this iPartFactory object represents a custom factory or a standard factory. This property is True in the case where it represents a custom factory.

Visual Basic
Property CustomFactory() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.CustomFactory Property


iPartFactory.DefaultRow Property

iPartFactory.DefaultRow Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the default row for this iPartFactory. The part shown in the iPart factory is computed with the values in the default row. Also, in the absence of a row input to the CreateMember method, the values in this row will be used to create a new iPart member object.

Visual Basic
Property DefaultRow() As iPartTableRow*
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.DefaultRow Property


iPartFactory.DisplayStyleColumn Property

iPartFactory.DisplayStyleColumn Property
Summary

Property that gets and sets the column to use as the display (render) style column.

Visual Basic
Property DisplayStyleColumn() As iPartTableColumn*
Remarks

If a column is set as the display style column, the value of the corresponding cell is used as the render style for the member. This property returns Nothing if no column is set as the display style column and the property can be set to Nothing to indicate that no column is to be set as the display style column.

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.DisplayStyleColumn Property


iPartFactory.ExcelWorkSheet Property

iPartFactory.ExcelWorkSheet Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Excel spreadsheet that represents the iPart table.

Visual Basic
Property ExcelWorkSheet() As IDispatch**
Remarks

This object can be assigned to an Excel WorkSheet object. The Excel object can then be used to query and to set data in the spreadsheet. If any edits are made to the Excel worksheet obtained from this property, the parent WorkBook of the WorkSheet must be saved and closed for the changes to take effect in Inventor.

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.ExcelWorkSheet Property


iPartFactory.FactoryOptions Property

iPartFactory.FactoryOptions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the options for the factory.

Visual Basic
Property FactoryOptions() As FactoryOptions**
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.FactoryOptions Property


iPartFactory.FileNameColumn Property

iPartFactory.FileNameColumn Property
Summary

Property that gets and sets the column to use as the file name column.

Visual Basic
Property FileNameColumn() As iPartTableColumn*
Remarks

If a column is set as the file name column, the value of the corresponding cell is used as the browser name when a member is placed into an assembly. This property returns Nothing if no column is set as the file name column and the property can be set to Nothing to indicate that no column is to be set as the file name column.

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.FileNameColumn Property


iPartFactory.MaterialColumn Property

iPartFactory.MaterialColumn Property
Summary

Property that gets and sets the column to use as the material column.

Visual Basic
Property MaterialColumn() As iPartTableColumn*
Remarks

If a column is set as the material column, the value of the corresponding cell is used as the material for the member. This property returns Nothing if no column is set as the material column and the property can be set to Nothing to indicate that no column is to be set as the material column.

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.MaterialColumn Property


iPartFactory.MemberCacheDir Property

iPartFactory.MemberCacheDir Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the directory location for the newly created iPart members.

Visual Basic
Property MemberCacheDir() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.MemberCacheDir Property


iPartFactory.MemberEditScope Property

iPartFactory.MemberEditScope Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the edits to a member should affect just the active member or all members within the factory. Valid values are kEditActiveMember and kEditAllMembers. This value is not persisted.

Visual Basic
Property MemberEditScope() As MemberEditScopeEnum
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.MemberEditScope Property


iPartFactory.Parent Property

iPartFactory.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent PartDocument of the factory.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.Parent Property


iPartFactory.TableColumns Property

iPartFactory.TableColumns Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iPartTableColumns collection object.

Visual Basic
Property TableColumns() As iPartTableColumns**
See Also

Create a Configuration Table sample

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.TableColumns Property


iPartFactory.TableRows Property

iPartFactory.TableRows Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iPartTableRows collection object.

Visual Basic
Property TableRows() As iPartTableRows**
See Also

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.TableRows Property


iPartFactory.Type Property

iPartFactory.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartFactory Interface > iPartFactory Properties > iPartFactory.Type Property


iPartMember Interface

iPartMember Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iPartMember object provides access to the iPart.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::iPartMember
Visual Basic
Public Interface iPartMember
Inherits ReferenceComponent
Notes

Members through which this object may be accessed include:

iPartFactory.CreateCustomMember

iPartFactory.CreateMember

PartComponentDefinition.iPartMember

You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface


iPartMember Methods

iPartMember Methods
Summary

The methods of the iPartMember class are listed here.

Methods
Methods
Name | Description
BreakLinkToFactory | Method that breaks the link to the parent factory and converts the iPart member to a derived part.
ChangeRow | Method that changes the row in the iPartTable that this custom iPartMember represents. This method is only valid for custom members. This can be determined using the CustomMember property.
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Methods


iPartMember.BreakLinkToFactory Method

iPartMember.BreakLinkToFactory Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that breaks the link to the parent factory and converts the iPart member to a derived part.

Visual Basic
Sub BreakLinkToFactory()
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Methods > iPartMember.BreakLinkToFactory Method


iPartMember.ChangeRow Method

iPartMember.ChangeRow Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that changes the row in the iPartTable that this custom iPartMember represents. This method is only valid for custom members. This can be determined using the CustomMember property.

Visual Basic
Sub ChangeRow(NewRow As VARIANT, ByRef CustomInput As [optional] VARIANT)
Parameters
Parameters | Description
NewRow | Input Variant that specifies the new row. The row index is specified either by a Long (row index), a String (part identifier, i.e. ''[Height=1.000 in][Length=2.000 in][Radius=0.250 in]''), or an iPartTableRow object. If a RowIndex is not specified, default row will be used to create the iPart member.
CustomInput | Optional input safearray of Strings that specifies the input to use for the custom input. If the factory is a custom factory and this is not supplied the default values for custom values are used. The custom input strings are supplied in a column order. If the factory is not a custom factory this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Methods > iPartMember.ChangeRow Method


iPartMember Properties

iPartMember Properties
Summary

The properties of the iPartMember class are listed here.

Properties
Name | Description
CustomMember | Property that specifies whether this iPartMember represents a custom member or a standard member. This property is True if the iPartMember is a CustomMember.
ParentFactory | Property that returns the iPart factory that created this iPartMember.
PrimaryBody | Property that returns the primary body as a solid body. The solid body corresponds to the resultant body obtained from the iPartFactory.
Row | Property that returns the row in the iPart table that this iPartMember represents.
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Properties


iPartMember.CustomMember Property

iPartMember.CustomMember Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that specifies whether this iPartMember represents a custom member or a standard member. This property is True if the iPartMember is a CustomMember.

Visual Basic
Property CustomMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Properties > iPartMember.CustomMember Property


iPartMember.ParentFactory Property

iPartMember.ParentFactory Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iPart factory that created this iPartMember.

Visual Basic
Property ParentFactory() As iPartFactory**
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Properties > iPartMember.ParentFactory Property


iPartMember.PrimaryBody Property

iPartMember.PrimaryBody Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the primary body as a solid body. The solid body corresponds to the resultant body obtained from the iPartFactory.

Visual Basic
Property PrimaryBody() As ReferenceFeature**
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Properties > iPartMember.PrimaryBody Property


iPartMember.Row Property

iPartMember.Row Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the row in the iPart table that this iPartMember represents.

Visual Basic
Property Row() As iPartTableRow**
You are here: Symbol Reference > Inventor Library > Objects > iPartMember Interface > iPartMember Properties > iPartMember.Row Property


iPartTableCell Interface

iPartTableCell Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iPartTableCell object represents an individual cell in the iPart factory table.

Class Hierarchy
Inventor::iPartTableCell
Visual Basic
Public Interface iPartTableCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iPartTableColumn.Item

iPartTableRow.Item

You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface


iPartTableCell Properties

iPartTableCell Properties
Summary

The properties of the iPartTableCell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Column | Property that returns the index of this cell within the parent iPartTableColumn.
CustomCell | Property that gets and sets whether this is a custom parameter cell. Setting this property to True will fail if this cell is within a "Key" column (i.e. the Key property of the column does not return 0).
CustomIncrement | Property that gets and sets the increment value for custom parameter cell. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).
CustomRangeMaximum | Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).
CustomRangeMinimum | Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).
HasFormula | Property that returns whether a formula (equation) was input into this cell via Excel. Such cells show with a red background in the user interface and are not editable.
IsValid | Property that returns whether the contents of this cell are valid. Invalid cells show with a yellow background in the user interface.
Parent | Property that returns the parent iPartTableRow object.
Row | Property that returns the index of this cell within the parent iPartTableRow.
Type | Property returning an enum indicating this object's type.
Value | Property that gets and sets the value of the cell. Setting this property returns an error if the HasFormula property returns True.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties


iPartTableCell.Application Property

iPartTableCell.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.Application Property


iPartTableCell.Column Property

iPartTableCell.Column Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the index of this cell within the parent iPartTableColumn.

Visual Basic
Property Column() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.Column Property


iPartTableCell.CustomCell Property

iPartTableCell.CustomCell Property
Summary

Property that gets and sets whether this is a custom parameter cell. Setting this property to True will fail if this cell is within a "Key" column (i.e. the Key property of the column does not return 0).

Visual Basic
Property CustomCell() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.CustomCell Property


iPartTableCell.CustomIncrement Property

iPartTableCell.CustomIncrement Property
Summary

Property that gets and sets the increment value for custom parameter cell. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).

Visual Basic
Property CustomIncrement() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.CustomIncrement Property


iPartTableCell.CustomRangeMaximum Property

iPartTableCell.CustomRangeMaximum Property
Summary

Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).

Visual Basic
Property CustomRangeMaximum() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.CustomRangeMaximum Property


iPartTableCell.CustomRangeMinimum Property

iPartTableCell.CustomRangeMinimum Property
Summary

Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomCell property returns True and the cell contains numerical values (double or integer).

Visual Basic
Property CustomRangeMinimum() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.CustomRangeMinimum Property


iPartTableCell.HasFormula Property

iPartTableCell.HasFormula Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether a formula (equation) was input into this cell via Excel. Such cells show with a red background in the user interface and are not editable.

Visual Basic
Property HasFormula() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.HasFormula Property


iPartTableCell.IsValid Property

iPartTableCell.IsValid Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the contents of this cell are valid. Invalid cells show with a yellow background in the user interface.

Visual Basic
Property IsValid() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.IsValid Property


iPartTableCell.Parent Property

iPartTableCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent iPartTableRow object.

Visual Basic
Property Parent() As iPartFactory**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.Parent Property


iPartTableCell.Row Property

iPartTableCell.Row Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the index of this cell within the parent iPartTableRow.

Visual Basic
Property Row() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.Row Property


iPartTableCell.Type Property

iPartTableCell.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.Type Property


iPartTableCell.Value Property

iPartTableCell.Value Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the value of the cell. Setting this property returns an error if the HasFormula property returns True.

Visual Basic
Property Value() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableCell Interface > iPartTableCell Properties > iPartTableCell.Value Property


iPartTableColumn Interface

iPartTableColumn Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iPartTableColumn object represents a column in the iPart factory table.

Class Hierarchy
Inventor::iPartTableColumn
Visual Basic
Public Interface iPartTableColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iPartFactory.DisplayStyleColumn

iPartFactory.FileNameColumn

iPartFactory.MaterialColumn

iPartTableColumns.Item

You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface


iPartTableColumn Methods

iPartTableColumn Methods
Summary

The methods of the iPartTableColumn class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this column in the factory. The "Member" and "Part Number" columns cannot be deleted.
Item | Returns the specified iPartTableCell object from the collection. This is the default property of the iPartTableColumn object.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Methods


iPartTableColumn.Delete Method

iPartTableColumn.Delete Method
Summary

Method that deletes this column in the factory. The "Member" and "Part Number" columns cannot be deleted.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Methods > iPartTableColumn.Delete Method


iPartTableColumn.Item Method

iPartTableColumn.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns the specified iPartTableCell object from the collection. This is the default property of the iPartTableColumn object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iPartTableCell*)
Parameters
Parameters | Description
index | Value that specifies the iPartTableCell to return. The first cell in the column has in index of 1. If an out-of-range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Methods > iPartTableColumn.Item Method


iPartTableColumn Properties

iPartTableColumn Properties
Summary

The properties of the iPartTableColumn class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
CustomColumn | Property that gets and sets whether this is a custom parameter column. Setting this property to True will fail if this is a "Key" column (i.e. the Key property does not return 0).
CustomIncrement | Property that gets and sets the increment value for custom parameter columns. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).
CustomRangeMaximum | Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).
CustomRangeMinimum | Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).
DisplayHeading | Property that returns the localized heading of the column.
FormattedHeading | Property that returns the heading of the column in XML format.
Heading | Property that returns the heading of the column.
Index | Property that returns the index of this column within the iPart factory table.
Key | Property that gets and sets the key order for the column.
Parent | Property that returns the parent iPartFactory object.
ReferencedDataType | Property that returns the data type contained in the column.
ReferencedObject | Property that returns the object referenced by the column. For instance, if the column references a fillet feature suppression, the corresponding FilletFeature object is returned. Similarly, if a file property is referenced, the corresponding Property object is returned.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties


iPartTableColumn.Application Property

iPartTableColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Application Property


iPartTableColumn.Count Property

iPartTableColumn.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Count Property


iPartTableColumn.CustomColumn Property

iPartTableColumn.CustomColumn Property
Summary

Property that gets and sets whether this is a custom parameter column. Setting this property to True will fail if this is a "Key" column (i.e. the Key property does not return 0).

Visual Basic
Property CustomColumn() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.CustomColumn Property


iPartTableColumn.CustomIncrement Property

iPartTableColumn.CustomIncrement Property
Summary

Property that gets and sets the increment value for custom parameter columns. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).

Visual Basic
Property CustomIncrement() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.CustomIncrement Property


iPartTableColumn.CustomRangeMaximum Property

iPartTableColumn.CustomRangeMaximum Property
Summary

Property that gets and sets the maximum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).

Visual Basic
Property CustomRangeMaximum() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.CustomRangeMaximum Property


iPartTableColumn.CustomRangeMinimum Property

iPartTableColumn.CustomRangeMinimum Property
Summary

Property that gets and sets the minimum value for a custom parameter. This value is applicable only if the CustomColumn property returns True and the column contains numerical values (double or integer).

Visual Basic
Property CustomRangeMinimum() As String
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.CustomRangeMinimum Property


iPartTableColumn.DisplayHeading Property

iPartTableColumn.DisplayHeading Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the localized heading of the column.

Visual Basic
Property DisplayHeading() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.DisplayHeading Property


iPartTableColumn.FormattedHeading Property

iPartTableColumn.FormattedHeading Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the heading of the column in XML format.

Visual Basic
Property FormattedHeading() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.FormattedHeading Property


iPartTableColumn.Heading Property

iPartTableColumn.Heading Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the heading of the column.

Visual Basic
Property Heading() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Heading Property


iPartTableColumn.Index Property

iPartTableColumn.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this column within the iPart factory table.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Index Property


iPartTableColumn.Key Property

iPartTableColumn.Key Property
Summary

Property that gets and sets the key order for the column.

Visual Basic
Property Key() As long
Remarks

A value of 0 indicates that this is not a key column. The key sets the nesting order in the browser. For example, if you select an iPart by its length, and then its width, set Length as Key = 1 and Width as Key = 2. Setting this property to a key value will fail if this is a custom column or if any of the cells within this column is a custom cell.

You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Key Property


iPartTableColumn.Parent Property

iPartTableColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent iPartFactory object.

Visual Basic
Property Parent() As iPartFactory**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Parent Property


iPartTableColumn.ReferencedDataType Property

iPartTableColumn.ReferencedDataType Property
Summary

Property that returns the data type contained in the column.

Visual Basic
Property ReferencedDataType() As iComponentColumnTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.ReferencedDataType Property


iPartTableColumn.ReferencedObject Property

iPartTableColumn.ReferencedObject Property
Summary

Property that returns the object referenced by the column. For instance, if the column references a fillet feature suppression, the corresponding FilletFeature object is returned. Similarly, if a file property is referenced, the corresponding Property object is returned.

Visual Basic
Property ReferencedObject() As IDispatch**
Remarks

The property returns Nothing if there is no corresponding object (e.g. when the ReferencedDataType returns kMemberNameColumn).

You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.ReferencedObject Property


iPartTableColumn.Type Property

iPartTableColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumn Interface > iPartTableColumn Properties > iPartTableColumn.Type Property


iPartTableColumns Interface

iPartTableColumns Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iPartTableColumns collection object provides access to all existing objects in the iPart factory table.

Class Hierarchy
Inventor::iPartTableColumns
Visual Basic
Public Interface iPartTableColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iPartFactory.TableColumns

You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface


iPartTableColumns Methods

iPartTableColumns Methods
Summary

The methods of the iPartTableColumns class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified iPartTableColumn object from the collection. This is the default property of the iPartTableColumns collection object.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface > iPartTableColumns Methods


iPartTableColumns.Item Method

iPartTableColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns the specified iPartTableColumn object from the collection. This is the default property of the iPartTableColumns collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] iPartTableColumn*)
Parameters
Parameters | Description
index | Value that specifies the index of the iPartTableColumn to return. The first column has in index of 1. If an out-of-range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface > iPartTableColumns Methods > iPartTableColumns.Item Method


iPartTableColumns Properties

iPartTableColumns Properties
Summary

The properties of the iPartTableColumns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface > iPartTableColumns Properties


iPartTableColumns.Application Property

iPartTableColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface > iPartTableColumns Properties > iPartTableColumns.Application Property


iPartTableColumns.Count Property

iPartTableColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface > iPartTableColumns Properties > iPartTableColumns.Count Property


iPartTableColumns.Type Property

iPartTableColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableColumns Interface > iPartTableColumns Properties > iPartTableColumns.Type Property


iPartTableRow Interface

iPartTableRow Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The iPartTableRow object represents a row in the iPart factory table.

Class Hierarchy
Inventor::iPartTableRow
Visual Basic
Public Interface iPartTableRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iPartFactory.DefaultRow

iPartMember.Row

iPartTableRow.Copy

iPartTableRows.Item

You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface


iPartTableRow Methods

iPartTableRow Methods
Summary

The methods of the iPartTableRow class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a new row with all values equal to the original row.
Delete | Method that deletes this row in the factory.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Returns the specified iPartTableCell object from the collection. This is the default property of the iPartTableRow object.
PartIdentifier | Property that returns the part identifier corresponding to this row in the iPart table. The part identifier string is constructed by concatenating the information in the heading row and the cell values in the specified row, i.e.''[Height=1.000 in][Length=2.000 in][Radius=0.250 in]''.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Methods


iPartTableRow.Copy Method

iPartTableRow.Copy Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new row with all values equal to the original row.

Visual Basic
Sub Copy(ByRef NewMemberName As [defaultvalue("")] BSTR, Result As [out, retval] iPartTableRow*)
Parameters
Parameters | Description
NewMemberName | Optional input string that specifies the member name for the new row. If not specified, a member name is automatically generated.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Methods > iPartTableRow.Copy Method


iPartTableRow.Delete Method

iPartTableRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes this row in the factory.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Methods > iPartTableRow.Delete Method


iPartTableRow.GetReferenceKey Method

iPartTableRow.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Methods > iPartTableRow.GetReferenceKey Method


iPartTableRow.Item Method

iPartTableRow.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns the specified iPartTableCell object from the collection. This is the default property of the iPartTableRow object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] iPartTableCell*)
Parameters
Parameters | Description
index | Value that specifies the iPartTableCell to return. The first cell in the row has in index of 1. If an out of range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Methods > iPartTableRow.Item Method


iPartTableRow.PartIdentifier Method

iPartTableRow.PartIdentifier Method Available in Inventor Available in Server
Summary

Property that returns the part identifier corresponding to this row in the iPart table. The part identifier string is constructed by concatenating the information in the heading row and the cell values in the specified row, i.e.''[Height=1.000 in][Length=2.000 in][Radius=0.250 in]''.

Visual Basic
Sub PartIdentifier(Result As [out, retval] BSTR)
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Methods > iPartTableRow.PartIdentifier Method


iPartTableRow Properties

iPartTableRow Properties
Summary

The properties of the iPartTableRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Count | Property that returns the number of items in the collection.
Index | Property that returns the index of this row within the iPart factory table.
IsPartNameBasedOnMemberName | Gets whether the member's filename is based on the member name or an explicitly set filename.
MemberName | Property that returns the member name corresponding to this row in the iPart table.
Parent | Property that returns the parent iPartFactory object.
PartName | Property that gets and sets the document name corresponding to this row in the iPart table. In the absence of a filename input to the CreateMember method, the filename for this row will be used to create a new iPart member.
PartNameModifiable | Property that returns whether the name of the document corresponding to this member can be modified. This property also returns False if the corresponding cell in Excel contains a formula.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties


iPartTableRow.Application Property

iPartTableRow.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.Application Property


iPartTableRow.AttributeSets Property

iPartTableRow.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.AttributeSets Property


iPartTableRow.Count Property

iPartTableRow.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.Count Property


iPartTableRow.Index Property

iPartTableRow.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this row within the iPart factory table.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.Index Property


iPartTableRow.IsPartNameBasedOnMemberName Property

iPartTableRow.IsPartNameBasedOnMemberName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets whether the member's filename is based on the member name or an explicitly set filename.

Visual Basic
Property IsPartNameBasedOnMemberName() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.IsPartNameBasedOnMemberName Property


iPartTableRow.MemberName Property

iPartTableRow.MemberName Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the member name corresponding to this row in the iPart table.

Visual Basic
Property MemberName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.MemberName Property


iPartTableRow.Parent Property

iPartTableRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent iPartFactory object.

Visual Basic
Property Parent() As iPartFactory**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.Parent Property


iPartTableRow.PartName Property

iPartTableRow.PartName Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the document name corresponding to this row in the iPart table. In the absence of a filename input to the CreateMember method, the filename for this row will be used to create a new iPart member.

Visual Basic
Property PartName() As String
Remarks

This property returns the string in the filename property of the iPart table. Setting this property will fail if the PartNameModifiable property returns False. Setting this property will fail if the corresponding cell in Excel contains a formula.

You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.PartName Property


iPartTableRow.PartNameModifiable Property

iPartTableRow.PartNameModifiable Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the name of the document corresponding to this member can be modified. This property also returns False if the corresponding cell in Excel contains a formula.

Visual Basic
Property PartNameModifiable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.PartNameModifiable Property


iPartTableRow.Type Property

iPartTableRow.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRow Interface > iPartTableRow Properties > iPartTableRow.Type Property


iPartTableRows Interface

iPartTableRows Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

TheiPartTableRows collection object provides access to all existing objects in the iPart factory table.

Class Hierarchy
Inventor::iPartTableRows
Visual Basic
Public Interface iPartTableRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

iPartFactory.TableRows

You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface


iPartTableRows Methods

iPartTableRows Methods
Summary

The methods of the iPartTableRows class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified iPartTableRow object from the collection. This is the default property of the iPartTableRows collection object.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface > iPartTableRows Methods


iPartTableRows.Item Method

iPartTableRows.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified iPartTableRow object from the collection. This is the default property of the iPartTableRows collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] iPartTableRow*)
Parameters
Parameters | Description
index | Input Variant value that specifies the iPartTableRow to return. The input can be either an Integer value or a string. In the case of an Integer, the value specifies the row where the first row has in index of 1. If a string is input it should be in a part identifier format (i.e. ''[Height=1.000 in][Length=2.000 in][Radius=0.250 in]''). If the part specified does not exist an error occurs. This index value is not the same as the index value indicated in the user interface dialog. Rows in the dialog may be re-ordered.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface > iPartTableRows Methods > iPartTableRows.Item Method


iPartTableRows Properties

iPartTableRows Properties
Summary

The properties of the iPartTableRows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface > iPartTableRows Properties


iPartTableRows.Application Property

iPartTableRows.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface > iPartTableRows Properties > iPartTableRows.Application Property


iPartTableRows.Count Property

iPartTableRows.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
See Also

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface > iPartTableRows Properties > iPartTableRows.Count Property


iPartTableRows.Type Property

iPartTableRows.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > iPartTableRows Interface > iPartTableRows Properties > iPartTableRows.Type Property


KeyboardEvents CoClass

KeyboardEvents CoClass Available in Inventor Introduced in Inventor 5
Summary

The KeyboardEvents object supports a set of events that can be received by the client when a key on the keyboard is pressed while the InteractionEvents object has been started AND the InteractionDisabled flag is set to False.

Class Hierarchy
Inventor::KeyboardEvents
Visual Basic
Public Class KeyboardEvents
Remarks

See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

InteractionEventsObject.KeyboardEvents

You are here: Symbol Reference > Inventor Library > Objects > KeyboardEvents CoClass


KeyboardEventsObject Interface

KeyboardEventsObject Interface Available in Inventor Introduced in Inventor 5
Summary

The KeyboardEvents object supports a set of events that can be received by the client when a key on the keyboard is pressed while the InteractionEvents object has been started AND the InteractionDisabled flag is set to False.

Class Hierarchy
Inventor::KeyboardEventsObject
Visual Basic
Public Interface KeyboardEventsObject
Inherits IDispatch
Remarks

See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsObject Interface


KeyboardEventsObject Properties

KeyboardEventsObject Properties
Summary

The properties of the KeyboardEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent document of the object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsObject Interface > KeyboardEventsObject Properties


KeyboardEventsObject.Application Property

KeyboardEventsObject.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsObject Interface > KeyboardEventsObject Properties > KeyboardEventsObject.Application Property


KeyboardEventsObject.Parent Property

KeyboardEventsObject.Parent Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the parent document of the object.

Visual Basic
Property Parent() As InteractionEvents**
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsObject Interface > KeyboardEventsObject Properties > KeyboardEventsObject.Parent Property


KeyboardEventsObject.Type Property

KeyboardEventsObject.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsObject Interface > KeyboardEventsObject Properties > KeyboardEventsObject.Type Property


KeyboardEventsSink Interface

KeyboardEventsSink Interface Available in Inventor Introduced in Inventor 5
Summary

The KeyboardEvents object supports a set of events that can be received by the client when a key on the keyboard is pressed while the InteractionEvents object has been started AND the InteractionDisabled flag is set to False.

Class Hierarchy
Inventor::KeyboardEventsSink
Visual Basic
Public Interface KeyboardEventsSink
Inherits IDispatch
Remarks

See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsSink Interface


KeyboardEventsSink Methods

KeyboardEventsSink Methods
Summary

The methods of the KeyboardEventsSink class are listed here.

Methods
Methods
Name | Description
OnKeyDown | Event that occurs when the user presses a button on the keyboard. Only the keys specified in the enumerator are handled through this event. The input signifies the hardware key that was actually depressed.
OnKeyPress | Event that occurs when the user presses and releases an ANSI key on the keyboard. The ANSI value of the key pressed is returned.
OnKeyUp | Event that occurs when the user releases a button on the keyboard . Only the keys specified in the enumerator are handled through this event. The input signifies the hardware key that was actually depressed.
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsSink Interface > KeyboardEventsSink Methods


KeyboardEventsSink.OnKeyDown Method

KeyboardEventsSink.OnKeyDown Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user presses a button on the keyboard. Only the keys specified in the enumerator are handled through this event. The input signifies the hardware key that was actually depressed.

Visual Basic
Sub OnKeyDown(Key As long, ShiftKeys As ShiftStateEnum)
Parameters
Parameters | Description
Key | Returns a key code, such as kKeyF1 (the F1 key) or kKeyHome (the HOME key). The key codes are defined in the constant list KeyCodeEnum.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsSink Interface > KeyboardEventsSink Methods > KeyboardEventsSink.OnKeyDown Method


KeyboardEventsSink.OnKeyPress Method

KeyboardEventsSink.OnKeyPress Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user presses and releases an ANSI key on the keyboard. The ANSI value of the key pressed is returned.

Visual Basic
Sub OnKeyPress(KeyASCII As long)
Parameters
Parameters | Description
KeyASCII | Returns a Long that is a standard numeric ANSI keycode. KeyASCII is passed by value. Changing KeyASCII to 0 cancels the keystroke so the object receives no character.
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsSink Interface > KeyboardEventsSink Methods > KeyboardEventsSink.OnKeyPress Method


KeyboardEventsSink.OnKeyUp Method

KeyboardEventsSink.OnKeyUp Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user releases a button on the keyboard . Only the keys specified in the enumerator are handled through this event. The input signifies the hardware key that was actually depressed.

Visual Basic
Sub OnKeyUp(Key As long, ShiftKeys As ShiftStateEnum)
Parameters
Parameters | Description
Key | Returns a key code, such as kKeyF1 (the F1 key) or kKeyHome (the HOME key). The key codes are defined in the constant list KeyCodeEnum.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
You are here: Symbol Reference > Inventor Library > Objects > KeyboardEventsSink Interface > KeyboardEventsSink Methods > KeyboardEventsSink.OnKeyUp Method


KnitFeature Interface

KnitFeature Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The KnitFeature object represents a knit feature on a part. Knit features connect edge-matched surfaces together to create a quilt.

Class Hierarchy
Inventor::PartFeature
    Inventor::KnitFeature
        Inventor::KnitFeatureProxy
Visual Basic
Public Interface KnitFeature
Inherits PartFeature
Remarks

Unlike the Stitch tool in the construction environment, this operation is parametric. That is, changes to the parent surfaces update the quilted surface.

Notes

Members through which this object may be accessed include:

KnitFeatureProxy.NativeObject

KnitFeatures.Add

KnitFeatures.Item

See Also

Delete Face, Boundary Patch and Stitch features. sample

Example

"Adding a new stitch (knit) feature"

This sample demonstrates the creation of a stitch feature (known as the Knit feature in the API). The sample creates two work surfaces using surface extrusions and stitches them together.

Sub StitchFeatureCreate()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane. Dim oSketch As PlanarSketch
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw two sketch lines that will be used as the
    ' open profiles for creating work surfaces.
    Dim oLineOne As SketchLine
    Set oLineOne = oSketch.SketchLines.AddByTwoPoints( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(2, -2))

    Dim oLineTwo As SketchLine
    Set oLineTwo = oSketch.SketchLines.AddByTwoPoints( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(-2, -2))

    ' Create a profile for the first extrude.
    Dim oProfileOne As Profile
    Set oProfileOne = oSketch.Profiles.AddForSurface(oLineOne)

    ' Create an extrusion 2 cm thick.
    Dim oExtrudeOne As ExtrudeFeature
    Set oExtrudeOne = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfileOne, 2, kNegativeExtentDirection, kSurfaceOperation)

    ' Create a profile for the second extrude.
    Dim oProfileTwo As Profile
    Set oProfileTwo = oSketch.Profiles.AddForSurface(oLineTwo)

    ' Create an extrusion 2 cm thick.
    Dim oExtrudeTwo As ExtrudeFeature
    Set oExtrudeTwo = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfileTwo, 2, kNegativeExtentDirection, kSurfaceOperation)

    Dim oSurfaces As ObjectCollection
    Set oSurfaces = ThisApplication.TransientObjects.CreateObjectCollection

    ' Since we know that the only work surfaces in the document
    ' are those created by the above extrusions, use those.
    oSurfaces.Add oCompDef.WorkSurfaces.Item(1)
    oSurfaces.Add oCompDef.WorkSurfaces.Item(2)

    ' Create a stitch (knit) feature by stitching
    ' together the two work surfaces created above.
    Dim oKnitFeature As KnitFeature
    Set oKnitFeature = oCompDef.Features.KnitFeatures.Add(oSurfaces)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > KnitFeature Interface


KnitFeature Properties

KnitFeature Properties
Summary

The properties of the KnitFeature class are listed here.

Properties
Name | Description
MaintainAsSurface | Property that gets and sets whether to maintain the resulting body as a surface in the case where the resulting body of the stitch operation could potentially be a solid.
MaximumTolerance | Property that gets and sets the maximum distance between the edges of two faces before being knit together.
Surfaces | Property that gets and sets the set of surfaces used to create the knit feature.
You are here: Symbol Reference > Inventor Library > Objects > KnitFeature Interface > KnitFeature Properties


KnitFeature.MaintainAsSurface Property

KnitFeature.MaintainAsSurface Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to maintain the resulting body as a surface in the case where the resulting body of the stitch operation could potentially be a solid.

Visual Basic
Property MaintainAsSurface() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > KnitFeature Interface > KnitFeature Properties > KnitFeature.MaintainAsSurface Property


KnitFeature.MaximumTolerance Property

KnitFeature.MaximumTolerance Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the maximum distance between the edges of two faces before being knit together.

Visual Basic
Property MaximumTolerance() As double
You are here: Symbol Reference > Inventor Library > Objects > KnitFeature Interface > KnitFeature Properties > KnitFeature.MaximumTolerance Property


KnitFeature.Surfaces Property

KnitFeature.Surfaces Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the set of surfaces used to create the knit feature.

Visual Basic
Property Surfaces() As ObjectCollection*
Remarks

The collection is meant to contain a set of WorkSurface objects which represent the surfaces used for a knit feature. The collection may also contain the solid body of the part.

The collection will contain a copy of the surfaces used by the knit feature which implies that the knit feature will not be affected if the contents of the collection are modified. To change which surfaces are used by the knit feature, you need to set this property to an ObjectCollection that contains the desired set of WorkSurface objects that represent the new set of surfaces to be knitted.

You are here: Symbol Reference > Inventor Library > Objects > KnitFeature Interface > KnitFeature Properties > KnitFeature.Surfaces Property


KnitFeatureProxy Interface

KnitFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the KnitFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::KnitFeature
        Inventor::KnitFeatureProxy
Visual Basic
Public Interface KnitFeatureProxy
Inherits KnitFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > KnitFeatureProxy Interface


KnitFeatureProxy Properties

KnitFeatureProxy Properties
Summary

The properties of the KnitFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatureProxy Interface > KnitFeatureProxy Properties


KnitFeatureProxy.ContainingOccurrence Property

KnitFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > KnitFeatureProxy Interface > KnitFeatureProxy Properties > KnitFeatureProxy.ContainingOccurrence Property


KnitFeatureProxy.NativeObject Property

KnitFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As KnitFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > KnitFeatureProxy Interface > KnitFeatureProxy Properties > KnitFeatureProxy.NativeObject Property


KnitFeatures Interface

KnitFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The KnitFeatures object represents a collection of knit features ( objects) on a part. Knit features connect edge-matched surfaces together to create a quilt.

Class Hierarchy
Inventor::KnitFeatures
Visual Basic
Public Interface KnitFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.KnitFeatures

Example

See KnitFeature for example "KnitFeature Object"

You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface


KnitFeatures Methods

KnitFeatures Methods
Summary

The methods of the KnitFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new knit feature.
Item | Returns the specified KnitFeature object from the collection. This is the default property of the KnitFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Methods


KnitFeatures.Add Method

KnitFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new knit feature.

Visual Basic
Sub Add(Surfaces As ObjectCollection, ByRef MaximumTolerance As [defaultvalue(0.0254)] double, ByRef MaintainAsSurface As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] KnitFeature*)
Parameters
Parameters | Description
Surfaces | Input ObjectCollection that defines the input surfaces for the knit feature. Valid objects for the surfaces are WorkSurface objects and the result solid body obtained from PartComponentDefinition.SurfaceBodies.Item(1).
See Also

Adding a new stitch (knit) feature sample

Delete Face, Boundary Patch and Stitch features. sample

Example

See BoundaryPatchFeatures.Add for sample code.

You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Methods > KnitFeatures.Add Method


KnitFeatures.Item Method

KnitFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns the specified KnitFeature object from the collection. This is the default property of the KnitFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] KnitFeature*)
Parameters
Parameters | Description
index | Value that specifies the index of the KnitFeature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the attribute set name. If an out-of-range index or a name of a nonexistent attribute set is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Methods > KnitFeatures.Item Method


KnitFeatures Properties

KnitFeatures Properties
Summary

The properties of the KnitFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Properties


KnitFeatures.Application Property

KnitFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Properties > KnitFeatures.Application Property


KnitFeatures.Count Property

KnitFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Properties > KnitFeatures.Count Property


KnitFeatures.Type Property

KnitFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > KnitFeatures Interface > KnitFeatures Properties > KnitFeatures.Type Property


LanguageTools Interface

LanguageTools Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The LanguageTools object provides a means of determining the logical boolean value of iPart/iComponent table strings.

Class Hierarchy
Inventor::LanguageTools
Visual Basic
Public Interface LanguageTools
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.LanguageTools

You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface


LanguageTools Methods

LanguageTools Methods
Summary

The methods of the LanguageTools class are listed here.

Methods
Methods
Name | Description
GetiComponentStringValue | Method that returns the logical value of the input iComponent string. For instance, if the input string is 'Include', a value of True is returned. The input string can be in any of the supported localized languages.
You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface > LanguageTools Methods


LanguageTools.GetiComponentStringValue Method

LanguageTools.GetiComponentStringValue Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the logical value of the input iComponent string. For instance, if the input string is 'Include', a value of True is returned. The input string can be in any of the supported localized languages.

Visual Basic
Sub GetiComponentStringValue(iComponentString As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
iComponentString | Return the logical value of this string.
Remarks

This method will only deal with strings that have a Boolean value associated with them. For instance, if any of the following strings is input, the return value from the method will be True:

  • Include (English)
  • Einschlieen (German)
  • Inclure (French)
  • Incluir (Spanish)
  • Yes (Synonym)
  • yes (Synonym)
  • YES (Synonym)
  • 1 (Synonym)

This method will not work with strings that don't have a clear Boolean value, for example:

  • Family
  • Designation
  • Class
You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface > LanguageTools Methods > LanguageTools.GetiComponentStringValue Method


LanguageTools Properties

LanguageTools Properties
Summary

The properties of the LanguageTools class are listed here.

Properties
Name | Description
Application | Property that returns the LanguageTools object.
Parent | Property that returns the parent Application object.
Type | Property that returns kLanguageToolsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface > LanguageTools Properties


LanguageTools.Application Property

LanguageTools.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the LanguageTools object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface > LanguageTools Properties > LanguageTools.Application Property


LanguageTools.Parent Property

LanguageTools.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent Application object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface > LanguageTools Properties > LanguageTools.Parent Property


LanguageTools.Type Property

LanguageTools.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kLanguageToolsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LanguageTools Interface > LanguageTools Properties > LanguageTools.Type Property


Layer Interface

Layer Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The Layer object represents a layer in a drawing document.

Class Hierarchy
Inventor::Style
    Inventor::Layer
Visual Basic
Public Interface Layer
Inherits Style
Notes

Members through which this object may be accessed include:

AutoCADBlock.Layer

Balloon.Layer

BaselineDimensionSet.Layer

BreakOperation.Layer

Centerline.Layer

Centermark.Layer

ChainDimensionSet.Layer

CustomTable.Layer

DetailDrawingView.BoundaryLayer

DrawingCurveSegment.Layer

DrawingDimension.Layer

DrawingNote.Layer

DrawingViewLabel.Layer

FeatureControlFrame.Layer

HoleTable.Layer

HoleTag.Layer

LayersEnumerator.Item

ObjectDefaultsStyle.AngularDimensionLayer

ObjectDefaultsStyle.BalloonLayer

ObjectDefaultsStyle.BaselineDimensionLayer

ObjectDefaultsStyle.BendNoteLayer

ObjectDefaultsStyle.BendTableLayer

ObjectDefaultsStyle.BendTagLayer

ObjectDefaultsStyle.BorderGeometryLayer

ObjectDefaultsStyle.BorderTextLayer

ObjectDefaultsStyle.CenterlineLayer

ObjectDefaultsStyle.CentermarkLayer

ObjectDefaultsStyle.CenterOfGravityLayer

ObjectDefaultsStyle.ChainDimensionLayer

ObjectDefaultsStyle.ChamferNoteLayer

ObjectDefaultsStyle.ConfigurationTableLayer

ObjectDefaultsStyle.DiameterDimensionLayer

ObjectDefaultsStyle.FeatureControlFrameLayer

ObjectDefaultsStyle.GeneralNoteLayer

ObjectDefaultsStyle.HoleNoteLayer

ObjectDefaultsStyle.HoleTableLayer

ObjectDefaultsStyle.HoleTagLayer

ObjectDefaultsStyle.LeaderTextLayer

ObjectDefaultsStyle.LinearDimensionLayer

ObjectDefaultsStyle.OrdinateDimensionLayer

ObjectDefaultsStyle.OrdinateDimensionSetLayer

ObjectDefaultsStyle.OriginIndicatorLayer

ObjectDefaultsStyle.PartsListLayer

ObjectDefaultsStyle.PunchNoteLayer

ObjectDefaultsStyle.RadialDimensionLayer

ObjectDefaultsStyle.RevisionTableLayer

ObjectDefaultsStyle.RevisionTagLayer

ObjectDefaultsStyle.SheetMetalPunchLayer

ObjectDefaultsStyle.Sketch3DGeometryLayer

ObjectDefaultsStyle.SketchedSymbolGeometryLayer

ObjectDefaultsStyle.SketchedSymbolLeaderLayer

ObjectDefaultsStyle.SketchedSymbolTextLayer

ObjectDefaultsStyle.SketchGeometryLayer

ObjectDefaultsStyle.SketchTextLayer

ObjectDefaultsStyle.SurfaceTextureLayer

ObjectDefaultsStyle.TableLayer

ObjectDefaultsStyle.ThreadNoteLayer

ObjectDefaultsStyle.TitleBlockGeometryLayer

ObjectDefaultsStyle.TitleBlockTextLayer

ObjectDefaultsStyle.ViewLabelLayer

ObjectDefaultsStyle.WorkAxisLayer

ObjectDefaultsStyle.WorkPlaneLayer

ObjectDefaultsStyle.WorkPointLayer

OrdinateDimensionSet.Layer

OriginIndicator.Layer

PartsList.Layer

RevisionTable.Layer

SketchedSymbol.Layer

SketchEntity.Layer

SurfaceTextureSymbol.Layer

TextBox.Layer

Example

"Moving sketch entities to a new layer."

This sample demonstrates the creation of a new layer and moving sketch entities onto this newly created layer. To run the sample, have a drawing document open. After running the sample, select the 'Edit Layers' command in the toolbar and turn on the layer named Custom Sketch Circles.

Public Sub Layer()

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the drawing view.
    Dim oDraftView As DrawingView
    Set oDraftView = oDrawDoc.ActiveSheet.DrawingViews.AddDraftView(1#, "My Draft View")

    ' Set a reference to the sketch of the created draft view.
    Dim oSketch As DrawingSketch
    Set oSketch = oDraftView.Sketches.Item(1)

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw four sketch lines that form a rectangle
    Call oSketch.SketchLines.AddAsTwoPointRectangle(oTransGeom.CreatePoint2d(10, 10), _
                                                oTransGeom.CreatePoint2d(30, 30))

    ' Draw four sketch circles
    Dim oSketchCircles(1 To 4) As SketchCircle
    Set oSketchCircles(1) = oSketch.SketchCircles.AddByCenterRadius(oTransGeom.CreatePoint2d(12, 12), 1.5)
    Set oSketchCircles(2) = oSketch.SketchCircles.AddByCenterRadius(oTransGeom.CreatePoint2d(28, 12), 1.5)
    Set oSketchCircles(3) = oSketch.SketchCircles.AddByCenterRadius(oTransGeom.CreatePoint2d(12, 28), 1.5)
    Set oSketchCircles(4) = oSketch.SketchCircles.AddByCenterRadius(oTransGeom.CreatePoint2d(28, 28), 1.5)

    ' Create a new layer (as a copy of the 'Sketch Geometry' layer)
    ' to put the sketch circles in.
    Dim oNewLayer As Layer
    Set oNewLayer = oDrawDoc.StylesManager.Layers.Item("Sketch Geometry (ANSI)").Copy("Custom Sketch Circles")

    ' Set the LineType on the new layer to 'dashed'.
    oNewLayer.LineType = kDashedLineType

    'Put all the sketch circles on this layer
    oSketchCircles(1).Layer = oNewLayer
    oSketchCircles(2).Layer = oNewLayer
    oSketchCircles(3).Layer = oNewLayer
    oSketchCircles(4).Layer = oNewLayer

    ' Turn off the new layer
    oNewLayer.Visible = False

    ' Exit from editing the sketch.
    oSketch.ExitEdit
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface


Layer Methods

Layer Methods
Summary

The methods of the Layer class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use, or a failure if it is not a kCustomLineType.
SetCustomLineType | Method that sets a custom line type to the entity from the specified .lin file. The method automatically changes the value of the LineType property to kCustomLineType.
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Methods


Layer.GetCustomLineType Method

Layer.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns information regarding the custom line type in use, or a failure if it is not a kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | The name of the custom line type in use.
LineTypeDescription | The description of the line type in use.
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Methods > Layer.GetCustomLineType Method


Layer.SetCustomLineType Method

Layer.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets a custom line type to the entity from the specified .lin file. The method automatically changes the value of the LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | The full path and file name of the .lin file.
LineTypeName | The linetype name specified in the .lin file.
ReplaceExisting | Indicates whether to override an existing line type of the same name.
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Methods > Layer.SetCustomLineType Method


Layer Properties

Layer Properties
Summary

The properties of the Layer class are listed here.

Properties
Name | Description
AutomaticColor | Property that gets and sets whether to use the default color for the layer. This property can only be set to True. Setting the Color property automatically sets this property to False.
Color | Property that gets and sets the color used for the layer.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
Plot | Property that gets and sets whether this layer is plotted. If set to False, the layer continues to display in the drawing but will neither get printed nor published.
ScaleByLineWeight | Property that gets and sets whether to scale the line type based on the line weight value.
Visible | Property that gets and sets whether the layer is turned on or off.
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties


Layer.AutomaticColor Property

Layer.AutomaticColor Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether to use the default color for the layer. This property can only be set to True. Setting the Color property automatically sets this property to False.

Visual Basic
Property AutomaticColor() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.AutomaticColor Property


Layer.Color Property

Layer.Color Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the color used for the layer.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.Color Property


Layer.LineType Property

Layer.LineType Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.LineType Property


Layer.LineWeight Property

Layer.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.LineWeight Property


Layer.Plot Property

Layer.Plot Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether this layer is plotted. If set to False, the layer continues to display in the drawing but will neither get printed nor published.

Visual Basic
Property Plot() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.Plot Property


Layer.ScaleByLineWeight Property

Layer.ScaleByLineWeight Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether to scale the line type based on the line weight value.

Visual Basic
Property ScaleByLineWeight() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.ScaleByLineWeight Property


Layer.Visible Property

Layer.Visible Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether the layer is turned on or off.

Visual Basic
Property Visible() As VARIANT_BOOL
See Also

Moving sketch entities to a new layer sample

You are here: Symbol Reference > Inventor Library > Objects > Layer Interface > Layer Properties > Layer.Visible Property


LayersEnumerator Interface

LayersEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The LayersEnumerator object provides access to the existing Layer objects.

Class Hierarchy
Inventor::LayersEnumerator
Visual Basic
Public Interface LayersEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.Layers

You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface


LayersEnumerator Methods

LayersEnumerator Methods
Summary

The methods of the LayersEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified Layer object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface > LayersEnumerator Methods


LayersEnumerator.Item Method

LayersEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Layer object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Layer*)
Parameters
Parameters | Description
index | Input Variant value that specifies the Layer to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the internal name of a Layer. If an out of range index or a name of a non-existent Layer is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface > LayersEnumerator Methods > LayersEnumerator.Item Method


LayersEnumerator Properties

LayersEnumerator Properties
Summary

The properties of the LayersEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kLayersEnumeratorObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface > LayersEnumerator Properties


LayersEnumerator.Application Property

LayersEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface > LayersEnumerator Properties > LayersEnumerator.Application Property


LayersEnumerator.Count Property

LayersEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface > LayersEnumerator Properties > LayersEnumerator.Count Property


LayersEnumerator.Type Property

LayersEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kLayersEnumeratorObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LayersEnumerator Interface > LayersEnumerator Properties > LayersEnumerator.Type Property


LayoutConstraint Interface

LayoutConstraint Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The LayoutConstraint object represents a layout constraint within an assembly.

Class Hierarchy
Inventor::LayoutConstraint
    Inventor::LayoutConstraintProxy
Visual Basic
Public Interface LayoutConstraint
Inherits IDispatch
Remarks

A LayoutConstraint provides a wrapper for standard assembly constraints. The fact that the constraints are a member of a layout constraint affects their behavior. For example, a constraint that is a member of a layout constraint cannot be deleted. Only the layout constraint can be deleted, which will cause it's associated constraints to be deleted.

Layout constraints are never explicitly created but are produced as a results of component creation. They're only accessible through an occurrence that is being constrained by the layout constraint.

Notes

Members through which this object may be accessed include:

AssemblyConstraint.LayoutConstraint

LayoutConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface


LayoutConstraint Methods

LayoutConstraint Methods
Summary

The methods of the LayoutConstraint class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the constraint.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Methods


LayoutConstraint.Delete Method

LayoutConstraint.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the constraint.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Methods > LayoutConstraint.Delete Method


LayoutConstraint.GetReferenceKey Method

LayoutConstraint.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Methods > LayoutConstraint.GetReferenceKey Method


LayoutConstraint Properties

LayoutConstraint Properties
Summary

The properties of the LayoutConstraint class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
HealthStatus | Property that returns an enum indicating the current state of the object.
Name | Property that allows you to get and set the name of the constraint. This is the name that is displayed in the browser.
Parent | Property that returns the parent of the object.
Type | Returns an ObjectTypeEnum indicating this object's type.
XYFlushConstraint | Property that returns the flush constraint that defines the XY plane of the layout constraint.
XZFlushConstraint | Property that returns the flush constraint that defines the XZ plane of the layout constraint.
YZFlushConstraint | Property that returns the flush constraint that defines the YZ plane of the layout constraint.
ZAngleConstraint | Property that returns the angle constraint that defines the rotation about the Z axis of the layout constraint.
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties


LayoutConstraint.Application Property

LayoutConstraint.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.Application Property


LayoutConstraint.AttributeSets Property

LayoutConstraint.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.AttributeSets Property


LayoutConstraint.HealthStatus Property

LayoutConstraint.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.HealthStatus Property


LayoutConstraint.Name Property

LayoutConstraint.Name Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that allows you to get and set the name of the constraint. This is the name that is displayed in the browser.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.Name Property


LayoutConstraint.Parent Property

LayoutConstraint.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.Parent Property


LayoutConstraint.Type Property

LayoutConstraint.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.Type Property


LayoutConstraint.XYFlushConstraint Property

LayoutConstraint.XYFlushConstraint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the flush constraint that defines the XY plane of the layout constraint.

Visual Basic
Property XYFlushConstraint() As FlushConstraint**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.XYFlushConstraint Property


LayoutConstraint.XZFlushConstraint Property

LayoutConstraint.XZFlushConstraint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the flush constraint that defines the XZ plane of the layout constraint.

Visual Basic
Property XZFlushConstraint() As FlushConstraint**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.XZFlushConstraint Property


LayoutConstraint.YZFlushConstraint Property

LayoutConstraint.YZFlushConstraint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the flush constraint that defines the YZ plane of the layout constraint.

Visual Basic
Property YZFlushConstraint() As FlushConstraint**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.YZFlushConstraint Property


LayoutConstraint.ZAngleConstraint Property

LayoutConstraint.ZAngleConstraint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the angle constraint that defines the rotation about the Z axis of the layout constraint.

Visual Basic
Property ZAngleConstraint() As AngleConstraint**
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraint Interface > LayoutConstraint Properties > LayoutConstraint.ZAngleConstraint Property


LayoutConstraintProxy Interface

LayoutConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LayoutConstraint object.

Class Hierarchy
Inventor::LayoutConstraint
    Inventor::LayoutConstraintProxy
Visual Basic
Public Interface LayoutConstraintProxy
Inherits LayoutConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraintProxy Interface


LayoutConstraintProxy Properties

LayoutConstraintProxy Properties
Summary

The properties of the LayoutConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraintProxy Interface > LayoutConstraintProxy Properties


LayoutConstraintProxy.ContainingOccurrence Property

LayoutConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraintProxy Interface > LayoutConstraintProxy Properties > LayoutConstraintProxy.ContainingOccurrence Property


LayoutConstraintProxy.NativeObject Property

LayoutConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As LayoutConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LayoutConstraintProxy Interface > LayoutConstraintProxy Properties > LayoutConstraintProxy.NativeObject Property


Leader Interface

Leader Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The Leader object represents a leader associated with a drawing annotation.

Class Hierarchy
Inventor::Leader
Visual Basic
Public Interface Leader
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Balloon.Leader

FeatureControlFrame.Leader

HoleTag.Leader

LeaderNote.Leader

SketchedSymbol.Leader

SurfaceTextureSymbol.Leader

You are here: Symbol Reference > Inventor Library > Objects > Leader Interface


Leader Methods

Leader Methods
Summary

The methods of the Leader class are listed here.

Methods
Methods
Name | Description
AddLeader | Method that adds a leader branch with the input points. This is the equivalent of the 'Add Leader' command in the user interface. This method will succeed only if the HasRootNode property returns False (i.e. there are no existing leader segments). If there are existing leader segments, this method will fail you should use the LeaderNode.AddLeader method instead.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Methods


Leader.AddLeader Method

Leader.AddLeader Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that adds a leader branch with the input points. This is the equivalent of the 'Add Leader' command in the user interface. This method will succeed only if the HasRootNode property returns False (i.e. there are no existing leader segments). If there are existing leader segments, this method will fail you should use the LeaderNode.AddLeader method instead.

Visual Basic
Sub AddLeader(Points As ObjectCollection)
Parameters
Parameters | Description
Points | ObjectCollection containing a series of Point2d objects representing a leader branch originating at the drawing annotation or symbol. The first point indicates the position of the root node. The last item in the collection can be a GeometryIntent object indicating a geometry to attach the leader branch to. The ObjectCollection must contain at least two items, else the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Methods > Leader.AddLeader Method


Leader.GetReferenceKey Method

Leader.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Methods > Leader.GetReferenceKey Method


Leader Properties

Leader Properties
Summary

The properties of the Leader class are listed here.

Properties
Name | Description
AllLeafNodes | Property that returns a flat collection of all the leaf nodes in the leader tree. This property will return Nothing if the HasRootNode property returns False.
AllNodes | Property that returns a flat collection of all the nodes in the leader tree. This property will return Nothing if the HasRootNode property returns False.
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
ArrowheadType | Gets and sets the arrowhead type of the leader.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
HasRootNode | Property that returns if a root node exists for this leader. If False, there are no leader segments associated with this leader and the RootNode property will return Nothing.
Parent | Property that returns the parent of this leader object.
RootNode | Property that returns the root node of this leader. This property will return Nothing if the HasRootNode property returns False.
Type | Property returning kLeaderObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties


Leader.AllLeafNodes Property

Leader.AllLeafNodes Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a flat collection of all the leaf nodes in the leader tree. This property will return Nothing if the HasRootNode property returns False.

Visual Basic
Property AllLeafNodes() As LeaderNodesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.AllLeafNodes Property


Leader.AllNodes Property

Leader.AllNodes Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a flat collection of all the nodes in the leader tree. This property will return Nothing if the HasRootNode property returns False.

Visual Basic
Property AllNodes() As LeaderNodesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.AllNodes Property


Leader.Application Property

Leader.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.Application Property


Leader.ArrowheadType Property

Leader.ArrowheadType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets and sets the arrowhead type of the leader.

Visual Basic
Property ArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.ArrowheadType Property


Leader.AttributeSets Property

Leader.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.AttributeSets Property


Leader.HasRootNode Property

Leader.HasRootNode Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns if a root node exists for this leader. If False, there are no leader segments associated with this leader and the RootNode property will return Nothing.

Visual Basic
Property HasRootNode() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.HasRootNode Property


Leader.Parent Property

Leader.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent of this leader object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.Parent Property


Leader.RootNode Property

Leader.RootNode Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root node of this leader. This property will return Nothing if the HasRootNode property returns False.

Visual Basic
Property RootNode() As LeaderNode**
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.RootNode Property


Leader.Type Property

Leader.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kLeaderObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Leader Interface > Leader Properties > Leader.Type Property


LeaderNode Interface

LeaderNode Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LeaderNode object represents a node in a leader.

Class Hierarchy
Inventor::LeaderNode
Visual Basic
Public Interface LeaderNode
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Leader.RootNode

LeaderNode.InsertNode

LeaderNodesEnumerator.Item

Example

"Add new leader note."

This sample illustrates creating leader text on a sheet. Before running this sample, open a drawing document and select a linear drawing edge.

Public Sub AddLeaderNote()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the drawing curve segment.
    ' This assumes that a drawing curve is selected.
    Dim oDrawingCurveSegment As DrawingCurveSegment
    Set oDrawingCurveSegment = oDrawDoc.SelectSet.Item(1)

    ' Set a reference to the drawing curve.
    Dim oDrawingCurve As DrawingCurve
    Set oDrawingCurve = oDrawingCurveSegment.Parent

    ' Get the mid point of the selected curve
    ' assuming that the selected curve is linear
    Dim oMidPoint As Point2d
    Set oMidPoint = oDrawingCurve.MidPoint

    ' Set a reference to the TransientGeometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oLeaderPoints As ObjectCollection
    Set oLeaderPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Create a few leader points.
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 10))
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 5))

    ' Create an intent and add to the leader points collection.
    ' This is the geometry that the leader text will attach to.
    Dim oGeometryIntent As GeometryIntent
    Set oGeometryIntent = oActiveSheet.CreateGeometryIntent(oDrawingCurve)

    Call oLeaderPoints.Add(oGeometryIntent)

    ' Create text with simple string as input. Since this doesn't use
    ' any text overrides, it will default to the active text style.
    Dim sText As String
    sText = "API Leader Note"

    Dim oLeaderNote As LeaderNote
    Set oLeaderNote = oActiveSheet.DrawingNotes.LeaderNotes.Add(oLeaderPoints, sText)

    ' Insert a node.
    Dim oFirstNode As LeaderNode
    Set oFirstNode = oLeaderNote.Leader.RootNode.ChildNodes.Item(1)

    Dim oSecondNode As LeaderNode
    Set oSecondNode = oFirstNode.ChildNodes.Item(1)

    Call oFirstNode.InsertNode(oSecondNode, oTG.CreatePoint2d(oMidPoint.X + 5, oMidPoint.Y + 5))
End Sub
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface


LeaderNode Methods

LeaderNode Methods
Summary

The methods of the LeaderNode class are listed here.

Methods
Methods
Name | Description
AddLeader | Method that adds a leader branch with the input points. This is the equivalent of the 'Add Leader' command in the user interface.
Delete | Method that deletes this leader node.
GetReferenceKey | Method that generates and returns the reference key for this entity.
InsertNode | Method that adds a LeaderNode at the specified position between two existing leader nodes. This is the equivalent of the 'Add Vertex' command in the user interface. This method does not apply for leaf nodes.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Methods


LeaderNode.AddLeader Method

LeaderNode.AddLeader Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that adds a leader branch with the input points. This is the equivalent of the 'Add Leader' command in the user interface.

Visual Basic
Sub AddLeader(Points As ObjectCollection)
Parameters
Parameters | Description
Points | ObjectCollection containing a series of points representing a leader branch, that originates at the node that the branch is being attached to and terminates at the leaf of the branch. If the first point specified has the same position as the node that the branch is being attached to, then the first point is ignored. The last item in the collection can be a GeometryIntent object indicating a geometry to attach the leader branch to. The ObjectCollection must contain at least one item, else the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Methods > LeaderNode.AddLeader Method


LeaderNode.Delete Method

LeaderNode.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes this leader node.

Visual Basic
Sub Delete(ByRef RetainDependentNodes As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainDependentNodes | Optional input Boolean that indicates whether to delete all the dependent nodes as well. If specified to be True, dependent nodes are not deleted. Instead, their ownership is transferred to the parent of this node. If not specified, the argument defaults to False, indicating that all dependent nodes will be deleted.
Remarks
  • If a root node has more than one child node and RetainDependentNodes is

true, an error will be returned.

  • If a root node has one child node and RetainDependentNodes is

true, the root node will be moved to the child node.

  • If a root node and RetainDependentNodes is false, all nodes are deleted.

  • RetainDependentNodes is ignored for all leaf nodes.
  • For leaf nodes where the parent is the root, the leader branch is

deleted.

  • If leaf node, then new leaf node will be the parent node and the

attachment is lost.

You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Methods > LeaderNode.Delete Method


LeaderNode.GetReferenceKey Method

LeaderNode.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Methods > LeaderNode.GetReferenceKey Method


LeaderNode.InsertNode Method

LeaderNode.InsertNode Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that adds a LeaderNode at the specified position between two existing leader nodes. This is the equivalent of the 'Add Vertex' command in the user interface. This method does not apply for leaf nodes.

Visual Basic
Sub InsertNode(ChildNode As LeaderNode, Position As Point2d, Result As [out, retval] LeaderNode*)
Parameters
Parameters | Description
ChildNode | LeaderNode object that specifies a child node of this node. The new node will be inserted between these two nodes. If the input node is not an immediate child, an error will occur.
Position | Point2d object that specifies the position of the node to add. The method fails if the input position is not on the leader segment connecting the two leader nodes.
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Methods > LeaderNode.InsertNode Method


LeaderNode Properties

LeaderNode Properties
Summary

The properties of the LeaderNode class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
AttachedEntity | Property that gets and sets the geometry intent (attachment) for the node.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ChildNodes | Property that returns the children nodes under this node. The count will return 0 if the node is a leaf node.
Parent | Property that returns the parent of this leader node object. This could either be another LeaderNode object or the Leader object in case of a root node.
Position | Property that gets and sets the position of the node on the sheet. Setting this property on a node with an attachment (returned by the AttachedEntity property) will result in removal of the attachment. Setting the position of a node (other than leaf nodes) to the position of it's parent or children nodes may have the effect of merging the two nodes.
Type | Property returning kLeaderNodeObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties


LeaderNode.Application Property

LeaderNode.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.Application Property


LeaderNode.AttachedEntity Property

LeaderNode.AttachedEntity Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the geometry intent (attachment) for the node.

Visual Basic
Property AttachedEntity() As GeometryIntent*
Remarks

A geometry attachment only applies for leaf nodes, so for all other nodes this property will return Nothing and will fail if set. If set to Nothing, the attachment is removed. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method.

You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.AttachedEntity Property


LeaderNode.AttributeSets Property

LeaderNode.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.AttributeSets Property


LeaderNode.ChildNodes Property

LeaderNode.ChildNodes Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the children nodes under this node. The count will return 0 if the node is a leaf node.

Visual Basic
Property ChildNodes() As LeaderNodesEnumerator**
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.ChildNodes Property


LeaderNode.Parent Property

LeaderNode.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent of this leader node object. This could either be another LeaderNode object or the Leader object in case of a root node.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.Parent Property


LeaderNode.Position Property

LeaderNode.Position Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the position of the node on the sheet. Setting this property on a node with an attachment (returned by the AttachedEntity property) will result in removal of the attachment. Setting the position of a node (other than leaf nodes) to the position of it's parent or children nodes may have the effect of merging the two nodes.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.Position Property


LeaderNode.Type Property

LeaderNode.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kLeaderNodeObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNode Interface > LeaderNode Properties > LeaderNode.Type Property


LeaderNodesEnumerator Interface

LeaderNodesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LeaderNodesEnumerator object provides an enumeration of LeaderNode objects.

Class Hierarchy
Inventor::LeaderNodesEnumerator
Visual Basic
Public Interface LeaderNodesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Leader.AllLeafNodes

Leader.AllNodes

LeaderNode.ChildNodes

You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface


LeaderNodesEnumerator Methods

LeaderNodesEnumerator Methods
Summary

The methods of the LeaderNodesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified LeaderNode object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface > LeaderNodesEnumerator Methods


LeaderNodesEnumerator.Item Method

LeaderNodesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified LeaderNode object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] LeaderNode*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface > LeaderNodesEnumerator Methods > LeaderNodesEnumerator.Item Method


LeaderNodesEnumerator Properties

LeaderNodesEnumerator Properties
Summary

The properties of the LeaderNodesEnumerator class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that returns the number of items in the collection.
Type | Property returning kLeaderNodesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface > LeaderNodesEnumerator Properties


LeaderNodesEnumerator.Application Property

LeaderNodesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface > LeaderNodesEnumerator Properties > LeaderNodesEnumerator.Application Property


LeaderNodesEnumerator.Count Property

LeaderNodesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface > LeaderNodesEnumerator Properties > LeaderNodesEnumerator.Count Property


LeaderNodesEnumerator.Type Property

LeaderNodesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kLeaderNodesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNodesEnumerator Interface > LeaderNodesEnumerator Properties > LeaderNodesEnumerator.Type Property


LeaderNote Interface

LeaderNote Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The LeaderNote object represents a note with an attached leader on a sheet and derives from the DrawingNote object. The properties and methods listed below are in addition to those supported by the DrawingNote object.

Class Hierarchy
Inventor::DrawingNote
    Inventor::LeaderNote
        Inventor::BendNote
        Inventor::ChamferNote
        Inventor::PunchNote
Visual Basic
Public Interface LeaderNote
Inherits DrawingNote
Notes

Members through which this object may be accessed include:

LeaderNotes.Add

LeaderNotes.Item

See Also

Add new leader note sample

Example

See LeaderNode for example "LeaderNode Object"

You are here: Symbol Reference > Inventor Library > Objects > LeaderNote Interface


LeaderNote Properties

LeaderNote Properties
Summary

The properties of the LeaderNote class are listed here.

Properties
Name | Description
DimensionStyle | Property that gets and sets the dimension style associated with this leader note.
Leader | Property that returns the Leader object.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNote Interface > LeaderNote Properties


LeaderNote.DimensionStyle Property

LeaderNote.DimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the dimension style associated with this leader note.

Visual Basic
Property DimensionStyle() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNote Interface > LeaderNote Properties > LeaderNote.DimensionStyle Property


LeaderNote.Leader Property

LeaderNote.Leader Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Leader object.

Visual Basic
Property Leader() As Leader**
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > LeaderNote Interface > LeaderNote Properties > LeaderNote.Leader Property


LeaderNotes Interface

LeaderNotes Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The LeaderNotes collection object provides access to all of the leader notes on the sheet.

Class Hierarchy
Inventor::LeaderNotes
Visual Basic
Public Interface LeaderNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.LeaderNotes

You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface


LeaderNotes Methods

LeaderNotes Methods
Summary

The methods of the LeaderNotes class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a leader note.
Item | Property that returns the specified LeaderNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Methods


LeaderNotes.Add Method

LeaderNotes.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a leader note.

Visual Basic
Sub Add(LeaderPoints As ObjectCollection, FormattedText As String, ByRef DimensionStyle As [optional] VARIANT, Result As [out, retval] LeaderNote*)
Parameters
Parameters | Description
LeaderPoints | ObjectCollection containing a series of Point2d objects representing the leader originating at the note. The last item in the collection (even if it is the only item) can be a GeometryIntent object indicating a geometry to attach the leader to. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method. The ObjectCollection must contain at least one item, else the method will fail.
FormattedText | Input String that specifies the text of the general note. This string can contain tags that define internal formatting changes, which override the text style associated with the general note. The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the text style assigned to the note. You can use the XML tags to override the default style and apply style overrides for all or portions of the text. The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override. See the list of XML text formatting tags under Reference Topics in the Overviews section.
DimensionStyle | Specifies which dimension style to use for the leader note. The dimension style can be specified by providing the name of an existing style or by supplying a DimensionStyle object.
See Also

Add new leader note sample

You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Methods > LeaderNotes.Add Method


LeaderNotes.Item Method

LeaderNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified LeaderNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] LeaderNote*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Methods > LeaderNotes.Item Method


LeaderNotes Properties

LeaderNotes Properties
Summary

The properties of the LeaderNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kLeaderNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Properties


LeaderNotes.Application Property

LeaderNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Properties > LeaderNotes.Application Property


LeaderNotes.Count Property

LeaderNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Properties > LeaderNotes.Count Property


LeaderNotes.Type Property

LeaderNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kLeaderNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LeaderNotes Interface > LeaderNotes Properties > LeaderNotes.Type Property


LeaderStyle Interface

LeaderStyle Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The LeaderStyle object represents a leader style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::LeaderStyle
Visual Basic
Public Interface LeaderStyle
Inherits Style
Notes

Members through which this object may be accessed include:

BalloonStyle.AlternateLeaderStyle

BalloonStyle.LeaderStyle

DimensionStyle.LeaderStyle

FeatureControlFrameStyle.LeaderStyle

LeaderStylesEnumerator.Item

ObjectDefaultsStyle.OriginIndicatorStyle

ObjectDefaultsStyle.SketchedSymbolLeaderStyle

OriginIndicator.LeaderStyle

RevisionTableStyle.RevisionTagLeaderStyle

SketchedSymbol.LeaderStyle

SurfaceTextureStyle.LeaderStyle

You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface


LeaderStyle Methods

LeaderStyle Methods
Summary

The methods of the LeaderStyle class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
SetCustomLineType | Method that sets a custom line type to the style from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Methods


LeaderStyle.GetCustomLineType Method

LeaderStyle.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Methods > LeaderStyle.GetCustomLineType Method


LeaderStyle.SetCustomLineType Method

LeaderStyle.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets a custom line type to the style from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Methods > LeaderStyle.SetCustomLineType Method


LeaderStyle Properties

LeaderStyle Properties
Summary

The properties of the LeaderStyle class are listed here.

Properties
Name | Description
AllAroundSymbolDiameter | Property that gets and sets the size of the all-around symbol for Feature Control Frames, Surface symbols, and Weld symbols (circular only). This value is used only if the ScaleToTextHeight property is set to False.
ArrowheadHeight | Property that gets and sets the height of the arrowhead relative to the associated line.
ArrowheadSize | Property that gets and sets the size of the arrowhead (i.e. the terminator). The value is that of width of the arrow if the terminator is an arrowhead or for diameter if the terminator is a circle.
ArrowheadType | Property that gets and sets the arrowhead style to use.
Color | Property that gets and sets the color for the style. Setting the property to Nothing restores the style to the color defined by the layer.
ExtensionLineOffset | Property that gets and sets the space from the end of the edge to which the leader attaches to the beginning of the leader extension line.
ExtensionLineOvershoot | Property that gets and sets the length of the leader extension line past the end of the terminator.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
ScaleToTextHeight | Property that gets and sets whether to define the all-around symbol size by the height of text from the symbol's text style. This specifies the size of the all-around symbol for Feature Control Frames, Surface symbols, and Weld symbols (circular only).
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties


LeaderStyle.AllAroundSymbolDiameter Property

LeaderStyle.AllAroundSymbolDiameter Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the size of the all-around symbol for Feature Control Frames, Surface symbols, and Weld symbols (circular only). This value is used only if the ScaleToTextHeight property is set to False.

Visual Basic
Property AllAroundSymbolDiameter() As double
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.AllAroundSymbolDiameter Property


LeaderStyle.ArrowheadHeight Property

LeaderStyle.ArrowheadHeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the height of the arrowhead relative to the associated line.

Visual Basic
Property ArrowheadHeight() As double
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.ArrowheadHeight Property


LeaderStyle.ArrowheadSize Property

LeaderStyle.ArrowheadSize Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the size of the arrowhead (i.e. the terminator). The value is that of width of the arrow if the terminator is an arrowhead or for diameter if the terminator is a circle.

Visual Basic
Property ArrowheadSize() As double
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.ArrowheadSize Property


LeaderStyle.ArrowheadType Property

LeaderStyle.ArrowheadType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the arrowhead style to use.

Visual Basic
Property ArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.ArrowheadType Property


LeaderStyle.Color Property

LeaderStyle.Color Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color for the style. Setting the property to Nothing restores the style to the color defined by the layer.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.Color Property


LeaderStyle.ExtensionLineOffset Property

LeaderStyle.ExtensionLineOffset Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the space from the end of the edge to which the leader attaches to the beginning of the leader extension line.

Visual Basic
Property ExtensionLineOffset() As double
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.ExtensionLineOffset Property


LeaderStyle.ExtensionLineOvershoot Property

LeaderStyle.ExtensionLineOvershoot Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the length of the leader extension line past the end of the terminator.

Visual Basic
Property ExtensionLineOvershoot() As double
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.ExtensionLineOvershoot Property


LeaderStyle.LineType Property

LeaderStyle.LineType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.LineType Property


LeaderStyle.LineWeight Property

LeaderStyle.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.LineWeight Property


LeaderStyle.ScaleToTextHeight Property

LeaderStyle.ScaleToTextHeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to define the all-around symbol size by the height of text from the symbol's text style. This specifies the size of the all-around symbol for Feature Control Frames, Surface symbols, and Weld symbols (circular only).

Visual Basic
Property ScaleToTextHeight() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LeaderStyle Interface > LeaderStyle Properties > LeaderStyle.ScaleToTextHeight Property


LeaderStylesEnumerator Interface

LeaderStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The LeaderStylesEnumerator object provides access to the existing LeaderStyle objects.

Class Hierarchy
Inventor::LeaderStylesEnumerator
Visual Basic
Public Interface LeaderStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.LeaderStyles

You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface


LeaderStylesEnumerator Methods

LeaderStylesEnumerator Methods
Summary

The methods of the LeaderStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified LeaderStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface > LeaderStylesEnumerator Methods


LeaderStylesEnumerator.Item Method

LeaderStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified LeaderStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] LeaderStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the LeaderStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the LeaderStyle name. If an out of range index or a name of a non-existent LeaderStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface > LeaderStylesEnumerator Methods > LeaderStylesEnumerator.Item Method


LeaderStylesEnumerator Properties

LeaderStylesEnumerator Properties
Summary

The properties of the LeaderStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kLeaderStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface > LeaderStylesEnumerator Properties


LeaderStylesEnumerator.Application Property

LeaderStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface > LeaderStylesEnumerator Properties > LeaderStylesEnumerator.Application Property


LeaderStylesEnumerator.Count Property

LeaderStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface > LeaderStylesEnumerator Properties > LeaderStylesEnumerator.Count Property


LeaderStylesEnumerator.Type Property

LeaderStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kLeaderStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LeaderStylesEnumerator Interface > LeaderStylesEnumerator Properties > LeaderStylesEnumerator.Type Property


LegacyDistanceHeightExtent Interface

LegacyDistanceHeightExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The LegacyDistanceHeightExtent is used by the FlangeFeature object when the 'Old Method' is specified in the Flange feature dialog.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::LegacyDistanceHeightExtent
Visual Basic
Public Interface LegacyDistanceHeightExtent
Inherits PartFeatureExtent
Remarks

This uses the methodology from Inventor 11 and previous for defining the height and bend position of the flange. This object is obtained from an existing FlangeFeature object whose height is defined by a legacy distance extent. The various properties of this object can be used to query and edit an existing flange feature.

You are here: Symbol Reference > Inventor Library > Objects > LegacyDistanceHeightExtent Interface


LegacyDistanceHeightExtent Properties

LegacyDistanceHeightExtent Properties
Summary

The properties of the LegacyDistanceHeightExtent class are listed here.

Properties
Name | Description
Distance | Property that returns the parameter controlling the extent distance of the flange.
FlangeDirection | Property that gets and sets the direction of the flange.
You are here: Symbol Reference > Inventor Library > Objects > LegacyDistanceHeightExtent Interface > LegacyDistanceHeightExtent Properties


LegacyDistanceHeightExtent.Distance Property

LegacyDistanceHeightExtent.Distance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the extent distance of the flange.

Visual Basic
Property Distance() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > LegacyDistanceHeightExtent Interface > LegacyDistanceHeightExtent Properties > LegacyDistanceHeightExtent.Distance Property


LegacyDistanceHeightExtent.FlangeDirection Property

LegacyDistanceHeightExtent.FlangeDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the direction of the flange.

Visual Basic
Property FlangeDirection() As PartFeatureExtentDirectionEnum*
Remarks

kPositiveExtentDirection indicates that the direction of the flange on the side of the selected edge. kNegativeExtentDirection indicates the flange is on the opposite side of the select edge. kSymmetricExtentDirection is not valid for a flange direction. This property is ignored in the case where the flange bend position is defined as tangent to the side face (BendPosition = kBendPositionTangentToSideFace).

You are here: Symbol Reference > Inventor Library > Objects > LegacyDistanceHeightExtent Interface > LegacyDistanceHeightExtent Properties > LegacyDistanceHeightExtent.FlangeDirection Property


LevelOfDetailRepresentation Interface

LevelOfDetailRepresentation Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LevelOfDetailRepresentation object represents a positional representation in the assembly.

Class Hierarchy
Inventor::LevelOfDetailRepresentation
Visual Basic
Public Interface LevelOfDetailRepresentation
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LevelOfDetailRepresentation.Copy

LevelOfDetailRepresentations.Add

LevelOfDetailRepresentations.AddSubstitute

LevelOfDetailRepresentations.Item

RepresentationsManager.ActiveLevelOfDetailRepresentation

Example

See LevelOfDetailRepresentations::Add for example "Create a level of detail representation"

You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface


LevelOfDetailRepresentation Methods

LevelOfDetailRepresentation Methods
Summary

The methods of the LevelOfDetailRepresentation class are listed here.

Methods
Methods
Name | Description
Activate | Method that activates the level of detail representation.
Copy | Method that creates a copy of the LevelOfDetailRepresentation. The new created LevelOfDetailRepresentation is returned.
Delete | Method that deletes the LevelOfDetailRepresentation. The method returns an error if this is a built-in LOD representation.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Methods


LevelOfDetailRepresentation.Activate Method

LevelOfDetailRepresentation.Activate Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that activates the level of detail representation.

Visual Basic
Sub Activate(ByRef SkipDocumentSave As [defaultvalue(0)] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Methods > LevelOfDetailRepresentation.Activate Method


LevelOfDetailRepresentation.Copy Method

LevelOfDetailRepresentation.Copy Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a copy of the LevelOfDetailRepresentation. The new created LevelOfDetailRepresentation is returned.

Visual Basic
Sub Copy(ByRef NewName As [defaultvalue("")] BSTR, Result As [out, retval] LevelOfDetailRepresentation*)
Parameters
Parameters | Description
NewName | Optional input string that specifies the name of the level of detail representation to create. If not specified, Inventor assigns a name to the representation.
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Methods > LevelOfDetailRepresentation.Copy Method


LevelOfDetailRepresentation.Delete Method

LevelOfDetailRepresentation.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the LevelOfDetailRepresentation. The method returns an error if this is a built-in LOD representation.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Methods > LevelOfDetailRepresentation.Delete Method


LevelOfDetailRepresentation.GetReferenceKey Method

LevelOfDetailRepresentation.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Methods > LevelOfDetailRepresentation.GetReferenceKey Method


LevelOfDetailRepresentation Properties

LevelOfDetailRepresentation Properties
Summary

The properties of the LevelOfDetailRepresentation class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
LevelOfDetail | Property that returns the enum indicating the LOD type.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent RepresentationsManager object.
SubstituteDocumentDescriptor | Property that returns the DocumentDescriptor of the document associated with the substitute occurrence.
SubstituteOccurrence | Property that returns the ComponentOccurrence object associated with this level of detail representation.
Type | Property returning kLevelOfDetailRepresentationObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties


LevelOfDetailRepresentation.Application Property

LevelOfDetailRepresentation.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.Application Property


LevelOfDetailRepresentation.AttributeSets Property

LevelOfDetailRepresentation.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.AttributeSets Property


LevelOfDetailRepresentation.LevelOfDetail Property

LevelOfDetailRepresentation.LevelOfDetail Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the enum indicating the LOD type.

Visual Basic
Property LevelOfDetail() As LevelOfDetailEnum*
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.LevelOfDetail Property


LevelOfDetailRepresentation.Name Property

LevelOfDetailRepresentation.Name Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.Name Property


LevelOfDetailRepresentation.Parent Property

LevelOfDetailRepresentation.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent RepresentationsManager object.

Visual Basic
Property Parent() As RepresentationsManager**
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.Parent Property


LevelOfDetailRepresentation.SubstituteDocumentDescriptor Property

LevelOfDetailRepresentation.SubstituteDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the DocumentDescriptor of the document associated with the substitute occurrence.

Visual Basic
Property SubstituteDocumentDescriptor() As DocumentDescriptor**
Remarks

This property returns Nothing if the LevelOfDetail property returns anything but kSubstituteLevelOfDetail.

You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.SubstituteDocumentDescriptor Property


LevelOfDetailRepresentation.SubstituteOccurrence Property

LevelOfDetailRepresentation.SubstituteOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the ComponentOccurrence object associated with this level of detail representation.

Visual Basic
Property SubstituteOccurrence() As ComponentOccurrence**
Remarks

This property returns Nothing if the LevelOfDetail property returns anything but kSubstituteLevelOfDetail.

You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.SubstituteOccurrence Property


LevelOfDetailRepresentation.Type Property

LevelOfDetailRepresentation.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kLevelOfDetailRepresentationObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentation Interface > LevelOfDetailRepresentation Properties > LevelOfDetailRepresentation.Type Property


LevelOfDetailRepresentations Interface

LevelOfDetailRepresentations Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LevelOfDetailRepresentations collection object provides access to all the LOD (Level Of Detail) representations in the assembly and provides methods to create new ones.

Class Hierarchy
Inventor::LevelOfDetailRepresentations
Visual Basic
Public Interface LevelOfDetailRepresentations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RepresentationsManager.LevelOfDetailRepresentations

You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface


LevelOfDetailRepresentations Methods

LevelOfDetailRepresentations Methods
Summary

The methods of the LevelOfDetailRepresentations class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new LevelOfDetailRepresentation. The newly created LevelOfDetailRepresentation is returned.
AddSubstitute | Method that creates a new substitute LevelOfDetailRepresentation based on the input file. The newly created LevelOfDetailRepresentation is returned.
Item | Property that returns the specified LevelOfDetailRepresentation object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Methods


LevelOfDetailRepresentations.Add Method

LevelOfDetailRepresentations.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new LevelOfDetailRepresentation. The newly created LevelOfDetailRepresentation is returned.

Visual Basic
Sub Add(ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] LevelOfDetailRepresentation*)
Parameters
Parameters | Description
Name | Optional input string that specifies the name of the LOD representation to create. If not specified, Inventor assigns a name to the representation.
Example

"Create a level of detail representation"

This sample demonstrates creation of a level of detail representation in an assembly. Before running the sample, you need to open an assembly and create two part files called C:\Temp\Part1.ipt and C:\Temp\Part2.ipt, or edit the sample code to point to different part files if desired.

Public Sub CreateLevelOfDetail()
    ' Set a reference to the assembly component definintion.
    ' This assumes an assembly document is open.
    Dim oAsmCompDef As AssemblyComponentDefinition
    Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create a matrix. A new matrix is initialized with an identity matrix.
    Dim oMatrix As Matrix
    Set oMatrix = oTG.CreateMatrix

    ' Add the first occurrence.
    Dim oOcc1 As ComponentOccurrence
    Set oOcc1 = oAsmCompDef.Occurrences.Add("C:\Temp\Part1.ipt", oMatrix)

    ' Set the translation portion of the matrix so the
    ' second part will be positioned at (3,2,1).
    Call oMatrix.SetTranslation(oTG.CreateVector(3, 2, 1))

    ' Add the second occurrence.
    Dim oOcc2 As ComponentOccurrence
    Set oOcc2 = oAsmCompDef.Occurrences.Add("C:\Temp\Part2.ipt", oMatrix)

    ' Create a new level of detail representation.
    ' The new representation is automatically activated.
    Dim oLODRep As LevelOfDetailRepresentation
    Set oLODRep = oAsmCompDef.RepresentationsManager.LevelOfDetailRepresentations.Add("Part2Suppressed")

    ' Suppress the second component in the new LOD representation.
    ' If the document "C:\Temp\Part2.ipt" is not currently referenced
    ' elsewhere, it will be closed.
    oOcc2.Suppress
End Sub
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Methods > LevelOfDetailRepresentations.Add Method


LevelOfDetailRepresentations.AddSubstitute Method

LevelOfDetailRepresentations.AddSubstitute Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new substitute LevelOfDetailRepresentation based on the input file. The newly created LevelOfDetailRepresentation is returned.

Visual Basic
Sub AddSubstitute(FullFileName As String, ByRef Name As [defaultvalue("")] BSTR, ByRef SkipDocumentSave As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] LevelOfDetailRepresentation*)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full name of the file to create the substitute LOD with.
Name | Optional input string that specifies the name of the LOD representation to create. If not specified, Inventor assigns a name to the representation.
SkipDocumentSave | Optional input Boolean that indicates whether to suppress the save dialogs that appear for dirty documents that are about to be closed as a result of this action. If set to True, any edits performed on the documents needing to be closed are lost. Also, any document never saved to disk and needing to be closed is lost. The default value is False indicating that the user will be prompted to save documents about to be closed.
Remarks

Calling this method may result in the closing of certain documents that become unreferenced as a result of this action. However, these unreferenced documents will not be closed if this method is called within a ChangeProcessor or a Transaction. These unreferenced documents will be closed by Inventor at the next available opportunity. But if they need to be closed sooner, the Documents.CloseAll method (with a value of True for the input argument) can be used for this purpose.

Notes

If the SilentOperation property on the Application is set to True and this argument is specified to be False, the defaults in the resulting dialogs are accepted and the dialogs are suppressed. This will result in dirty documents being saved. However, if the dirty documents include any documents that have never been saved to disk, the method will return a failure in this situation.

Example

Shrink wrap substitute in assembly example.

The following sample demonstrates the creation of a shrinkwrap substitute within an assembly. Open any assembly document and run the sample. A shrinkwrap part is created at the same location as the assembly.

Sub CreateShrinkwrapSubstitute()

    ' Set a reference to the active assembly document
    Dim oDoc As AssemblyDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oDef As AssemblyComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    ' Create a new part document that will be the shrinkwrap substitute
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, , False)

    Dim oPartDef As PartComponentDefinition
    Set oPartDef = oPartDoc.ComponentDefinition

    Dim oDerivedAssemblyDef As DerivedAssemblyDefinition
    Set oDerivedAssemblyDef = oPartDef.ReferenceComponents.DerivedAssemblyComponents.CreateDefinition(oDoc.FullDocumentName)

    ' Set various shrinkwrap related options
    oDerivedAssemblyDef.DeriveStyle = kDeriveAsSingleBodyNoSeams
    oDerivedAssemblyDef.IncludeAllTopLevelWorkFeatures = kDerivedIncludeAll
    oDerivedAssemblyDef.IncludeAllTopLevelSketches = kDerivedIncludeAll
    oDerivedAssemblyDef.IncludeAllTopLeveliMateDefinitions = kDerivedExcludeAll
    oDerivedAssemblyDef.IncludeAllTopLevelParameters = kDerivedExcludeAll
    oDerivedAssemblyDef.ReducedMemoryMode = True

    Call oDerivedAssemblyDef.SetHolePatchingOptions(kDerivedPatchAll)
    Call oDerivedAssemblyDef.SetRemoveByVisibilityOptions(kDerivedRemovePartsAndFaces, 25)

    ' Create the shrinkwrap component
    Dim oDerivedAssembly As DerivedAssemblyComponent
    Set oDerivedAssembly = oPartDef.ReferenceComponents.DerivedAssemblyComponents.Add(oDerivedAssemblyDef)

    ' Save the part
    Dim strSubstituteFileName As String
    strSubstituteFileName = Left$(oDoc.FullFileName, Len(oDoc.FullFileName) - 4)
    strSubstituteFileName = strSubstituteFileName & "_ShrinkwrapSubstitute.ipt"

    ThisApplication.SilentOperation = True
    Call oPartDoc.SaveAs(strSubstituteFileName, False)
    ThisApplication.SilentOperation = False

    ' Create a substitute level of detail using the shrinkwrap part.
    Dim oSubstituteLOD As LevelOfDetailRepresentation
    Set oSubstituteLOD = oDef.RepresentationsManager.LevelOfDetailRepresentations.AddSubstitute(strSubstituteFileName)

    ' Release reference of the invisibly opened part document.
    oPartDoc.ReleaseReference
End Sub
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Methods > LevelOfDetailRepresentations.AddSubstitute Method


LevelOfDetailRepresentations.Item Method

LevelOfDetailRepresentations.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified LevelOfDetailRepresentation object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] LevelOfDetailRepresentation*)
Parameters
Parameters | Description
index | Input Variant value that specifies the LevelOfDetailRepresentation to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the LevelOfDetailRepresentation name. If an out of range index or a name of a non-existent LevelOfDetailRepresentation is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Methods > LevelOfDetailRepresentations.Item Method


LevelOfDetailRepresentations Properties

LevelOfDetailRepresentations Properties
Summary

The properties of the LevelOfDetailRepresentations class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Properties


LevelOfDetailRepresentations.Application Property

LevelOfDetailRepresentations.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Properties > LevelOfDetailRepresentations.Application Property


LevelOfDetailRepresentations.Count Property

LevelOfDetailRepresentations.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Properties > LevelOfDetailRepresentations.Count Property


LevelOfDetailRepresentations.Type Property

LevelOfDetailRepresentations.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LevelOfDetailRepresentations Interface > LevelOfDetailRepresentations Properties > LevelOfDetailRepresentations.Type Property


Light Interface

Light Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The Light object provides access to all of the properties that define a specific light source.

Class Hierarchy
Inventor::Light
Visual Basic
Public Interface Light
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Lights.Add

Lights.Item

You are here: Symbol Reference > Inventor Library > Objects > Light Interface


Light Properties

Light Properties
Summary

The properties of the Light class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Color | Property that gets and sets the color of the light source.
ConstantAttenuation | Property that gets and sets the ConstantAttenuation value.
Direction | Property that gets and sets the direction of the light.
Intensity | Property that gets and sets the intensity value.
LightDefinitionType | Property returning the light definition type. This can either be kSpotLight, kDirectionalLight or kPointLight.
LightType | Property returning the light type. This can either be kModelSpaceLight or kViewSpaceLight.
LinearAttenuation | Property that gets and sets the LinearAttenuation value.
On | Property that gets and sets whether this light is switched on.
Parent | Property returning the parent of the object.
Position | Property that gets and sets the position of the light in model space.
QuadraticAttenuation | Property that gets and sets the QuadraticAttenuation value.
SpotLightCutoffAngle | Property that gets and sets the SpotLightCutoffAngle value.
SpotLightFalloff | Property that gets and sets the SpotLightFalloff value.
SpotLightInnerAngle | Property that gets and sets the SpotLightInnerAngle value.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties


Light.Application Property

Light.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Application Property


Light.Color Property

Light.Color Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the color of the light source.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Color Property


Light.ConstantAttenuation Property

Light.ConstantAttenuation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the ConstantAttenuation value.

Visual Basic
Property ConstantAttenuation() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.ConstantAttenuation Property


Light.Direction Property

Light.Direction Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the direction of the light.

Visual Basic
Property Direction() As Vector*
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Direction Property


Light.Intensity Property

Light.Intensity Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the intensity value.

Visual Basic
Property Intensity() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Intensity Property


Light.LightDefinitionType Property

Light.LightDefinitionType Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning the light definition type. This can either be kSpotLight, kDirectionalLight or kPointLight.

Visual Basic
Property LightDefinitionType() As LightDefinitionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.LightDefinitionType Property


Light.LightType Property

Light.LightType Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning the light type. This can either be kModelSpaceLight or kViewSpaceLight.

Visual Basic
Property LightType() As LightTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.LightType Property


Light.LinearAttenuation Property

Light.LinearAttenuation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the LinearAttenuation value.

Visual Basic
Property LinearAttenuation() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.LinearAttenuation Property


Light.On Property

Light.On Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether this light is switched on.

Visual Basic
Property On() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.On Property


Light.Parent Property

Light.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning the parent of the object.

Visual Basic
Property Parent() As LightingStyle**
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Parent Property


Light.Position Property

Light.Position Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the position of the light in model space.

Visual Basic
Property Position() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Position Property


Light.QuadraticAttenuation Property

Light.QuadraticAttenuation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the QuadraticAttenuation value.

Visual Basic
Property QuadraticAttenuation() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.QuadraticAttenuation Property


Light.SpotLightCutoffAngle Property

Light.SpotLightCutoffAngle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the SpotLightCutoffAngle value.

Visual Basic
Property SpotLightCutoffAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.SpotLightCutoffAngle Property


Light.SpotLightFalloff Property

Light.SpotLightFalloff Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the SpotLightFalloff value.

Visual Basic
Property SpotLightFalloff() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.SpotLightFalloff Property


Light.SpotLightInnerAngle Property

Light.SpotLightInnerAngle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the SpotLightInnerAngle value.

Visual Basic
Property SpotLightInnerAngle() As double
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.SpotLightInnerAngle Property


Light.Type Property

Light.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Light Interface > Light Properties > Light.Type Property


LightingStyle Interface

LightingStyle Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The LightingStyle object provides access to all of the properties that define a specific lighting style.

Class Hierarchy
Inventor::LightingStyle
Visual Basic
Public Interface LightingStyle
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.ActiveLightingStyle

Light.Parent

LightingStyle.ConvertToLocal

LightingStyle.Copy

LightingStyles.Add

LightingStyles.Item

PartDocument.ActiveLightingStyle

PresentationDocument.ActiveLightingStyle

You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface


LightingStyle Methods

LightingStyle Methods
Summary

The methods of the LightingStyle class are listed here.

Methods
Methods
Name | Description
ConvertToLocal | Method that creates a local cached copy of a global style and returns the local style. This method fails if this style is already local. Use the StyleLocation property to determine whether the style is local.
Copy | Method that copies the rendering style and assigns the specified name to the copy. The new style is returned by the method.
Delete | Method that deletes the LightingStyle.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SaveToGlobal | Method that saves this style to the global repository. If a style with the same name is found in the repository, that style is updated.
UpdateFromGlobal | Method that updates this style from the global repository.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods


LightingStyle.ConvertToLocal Method

LightingStyle.ConvertToLocal Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a local cached copy of a global style and returns the local style. This method fails if this style is already local. Use the StyleLocation property to determine whether the style is local.

Visual Basic
Sub ConvertToLocal(Result As [out, retval] LightingStyle*)
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods > LightingStyle.ConvertToLocal Method


LightingStyle.Copy Method

LightingStyle.Copy Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that copies the rendering style and assigns the specified name to the copy. The new style is returned by the method.

Visual Basic
Sub Copy(NewName As String, Result As [out, retval] LightingStyle*)
Parameters
Parameters | Description
NewName | Input String that specifies the name for the new lighting style. This name must be unique with respect to all other lighting styles in the document. If it is not unique the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods > LightingStyle.Copy Method


LightingStyle.Delete Method

LightingStyle.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the LightingStyle.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods > LightingStyle.Delete Method


LightingStyle.GetReferenceKey Method

LightingStyle.GetReferenceKey Method
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods > LightingStyle.GetReferenceKey Method


LightingStyle.SaveToGlobal Method

LightingStyle.SaveToGlobal Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that saves this style to the global repository. If a style with the same name is found in the repository, that style is updated.

Visual Basic
Sub SaveToGlobal()
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods > LightingStyle.SaveToGlobal Method


LightingStyle.UpdateFromGlobal Method

LightingStyle.UpdateFromGlobal Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that updates this style from the global repository.

Visual Basic
Sub UpdateFromGlobal()
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Methods > LightingStyle.UpdateFromGlobal Method


LightingStyle Properties

LightingStyle Properties
Summary

The properties of the LightingStyle class are listed here.

Properties
Name | Description
Ambience | Property that gets and sets the ambience of the lighting style. The ambience is defined using a value between 0 and 100.
AmbientShadowIntensity | Property that gets and sets the intensity of the ambient shadow (occlusion). The intensity is defined using a value between 0 and 100.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Brightness | Property that gets and sets the brightness of the lighting style. The brightness is defined using a value between 0 and 100.
ImageBasedLightingBrightness | Property that gets and sets the brightness of the lighting style. The brightness is defined using a value between 0 and 100.
ImageBasedLightingRotation | Property that gets and sets the rotation to be applied to the image. The angle is defined in radians. The range of valid values is -180 degrees to 180 degrees.
ImageBasedLightingScale | Property that gets and sets the scale to be applied to the image. Valid range of values is 0.1 to 10.
ImageBasedLightingShowImage | Property that gets and sets whether to display the image in the graphics scene.
ImageBasedLightingSourceInternalName | Property that gets and sets the internal name of the source for image based lighting. This property returns a null string if image based lighting is not enabled. Also, the property can be set to a null string to disable image based lighting.
ImageBasedLightingSourceName | Property that gets and sets the display name of the source for image based lighting. This property returns a null string if image based lighting is not enabled. Also, the property can be set to a null string to disable image based lighting.
InternalName | property that returns the unique name of the style. The name is the internal English name of the style. This name will remain constant and is not affected by locale. This name is never displayed to the user.
InUse | Property that indicates if this style is in use.
Lights | Property that returns the Lights collection object.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent of the object.
ShadowDensity | Property that gets and sets the direction of the light source that controls the shadow. The density is defined using a value between 0 and 100. A value of 0 displays a faint shadow. A value of 100 displays the darkest portion of the shadow black (RGB 0,0,0).
ShadowDirection | Property that gets and sets the direction of the light source that controls the shadow.
ShadowSoftness | Property that gets and sets the blending between shadowed and non-shadowed areas. The softness is defined using a value between 0 and 100. A value of 0 displays a sharp shadow edge. A value of 100 displays the softest shadows.
StyleLocation | Property that returns the location of this lighting style, i.e. local to the document, cached locally in the document, exists in the library. Lighting styles that exist in the library cannot be edited.
Type | Property returning kLightingStyleObject indicating the type of object.
UpToDate | Property that gets the up-to-date status of the style against the global repository.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties


LightingStyle.Ambience Property

LightingStyle.Ambience Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the ambience of the lighting style. The ambience is defined using a value between 0 and 100.

Visual Basic
Property Ambience() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Ambience Property


LightingStyle.AmbientShadowIntensity Property

LightingStyle.AmbientShadowIntensity Property
Summary

Property that gets and sets the intensity of the ambient shadow (occlusion). The intensity is defined using a value between 0 and 100.

Visual Basic
Property AmbientShadowIntensity() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.AmbientShadowIntensity Property


LightingStyle.Application Property

LightingStyle.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Application Property


LightingStyle.AttributeSets Property

LightingStyle.AttributeSets Property
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.AttributeSets Property


LightingStyle.Brightness Property

LightingStyle.Brightness Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the brightness of the lighting style. The brightness is defined using a value between 0 and 100.

Visual Basic
Property Brightness() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Brightness Property


LightingStyle.ImageBasedLightingBrightness Property

LightingStyle.ImageBasedLightingBrightness Property
Summary

Property that gets and sets the brightness of the lighting style. The brightness is defined using a value between 0 and 100.

Visual Basic
Property ImageBasedLightingBrightness() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ImageBasedLightingBrightness Property


LightingStyle.ImageBasedLightingRotation Property

LightingStyle.ImageBasedLightingRotation Property
Summary

Property that gets and sets the rotation to be applied to the image. The angle is defined in radians. The range of valid values is -180 degrees to 180 degrees.

Visual Basic
Property ImageBasedLightingRotation() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ImageBasedLightingRotation Property


LightingStyle.ImageBasedLightingScale Property

LightingStyle.ImageBasedLightingScale Property
Summary

Property that gets and sets the scale to be applied to the image. Valid range of values is 0.1 to 10.

Visual Basic
Property ImageBasedLightingScale() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ImageBasedLightingScale Property


LightingStyle.ImageBasedLightingShowImage Property

LightingStyle.ImageBasedLightingShowImage Property
Summary

Property that gets and sets whether to display the image in the graphics scene.

Visual Basic
Property ImageBasedLightingShowImage() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ImageBasedLightingShowImage Property


LightingStyle.ImageBasedLightingSourceInternalName Property

LightingStyle.ImageBasedLightingSourceInternalName Property
Summary

Property that gets and sets the internal name of the source for image based lighting. This property returns a null string if image based lighting is not enabled. Also, the property can be set to a null string to disable image based lighting.

Visual Basic
Property ImageBasedLightingSourceInternalName() As String
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ImageBasedLightingSourceInternalName Property


LightingStyle.ImageBasedLightingSourceName Property

LightingStyle.ImageBasedLightingSourceName Property
Summary

Property that gets and sets the display name of the source for image based lighting. This property returns a null string if image based lighting is not enabled. Also, the property can be set to a null string to disable image based lighting.

Visual Basic
Property ImageBasedLightingSourceName() As String
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ImageBasedLightingSourceName Property


LightingStyle.InternalName Property

LightingStyle.InternalName Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

property that returns the unique name of the style. The name is the internal English name of the style. This name will remain constant and is not affected by locale. This name is never displayed to the user.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.InternalName Property


LightingStyle.InUse Property

LightingStyle.InUse Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates if this style is in use.

Visual Basic
Property InUse() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.InUse Property


LightingStyle.Lights Property

LightingStyle.Lights Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the Lights collection object.

Visual Basic
Property Lights() As Lights**
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Lights Property


LightingStyle.Name Property

LightingStyle.Name Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Name Property


LightingStyle.Parent Property

LightingStyle.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning the parent of the object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Parent Property


LightingStyle.ShadowDensity Property

LightingStyle.ShadowDensity Property
Summary

Property that gets and sets the direction of the light source that controls the shadow. The density is defined using a value between 0 and 100. A value of 0 displays a faint shadow. A value of 100 displays the darkest portion of the shadow black (RGB 0,0,0).

Visual Basic
Property ShadowDensity() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ShadowDensity Property


LightingStyle.ShadowDirection Property

LightingStyle.ShadowDirection Property
Summary

Property that gets and sets the direction of the light source that controls the shadow.

Visual Basic
Property ShadowDirection() As ShadowDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ShadowDirection Property


LightingStyle.ShadowSoftness Property

LightingStyle.ShadowSoftness Property
Summary

Property that gets and sets the blending between shadowed and non-shadowed areas. The softness is defined using a value between 0 and 100. A value of 0 displays a sharp shadow edge. A value of 100 displays the softest shadows.

Visual Basic
Property ShadowSoftness() As double
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.ShadowSoftness Property


LightingStyle.StyleLocation Property

LightingStyle.StyleLocation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the location of this lighting style, i.e. local to the document, cached locally in the document, exists in the library. Lighting styles that exist in the library cannot be edited.

Visual Basic
Property StyleLocation() As StyleLocationEnum*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.StyleLocation Property


LightingStyle.Type Property

LightingStyle.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kLightingStyleObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.Type Property


LightingStyle.UpToDate Property

LightingStyle.UpToDate Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the up-to-date status of the style against the global repository.

Visual Basic
Property UpToDate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyle Interface > LightingStyle Properties > LightingStyle.UpToDate Property


LightingStyles Interface

LightingStyles Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The LightingStyles collection object allows for the creation of new LightingStyle objects and provides access to existing LightingStyle objects.

Class Hierarchy
Inventor::LightingStyles
Visual Basic
Public Interface LightingStyles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.LightingStyles

PartDocument.LightingStyles

PresentationDocument.LightingStyles

You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface


LightingStyles Methods

LightingStyles Methods
Summary

The methods of the LightingStyles class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new LightingStyle object. The name of the new style is specified, while the rendering attributes are initialized with the same values as the Default style.
Item | Returns the specified from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Methods


LightingStyles.Add Method

LightingStyles.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new LightingStyle object. The name of the new style is specified, while the rendering attributes are initialized with the same values as the Default style.

Visual Basic
Sub Add(Name As String, Result As [out, retval] LightingStyle*)
Parameters
Parameters | Description
Name | Input String that specifies the name of the new rendering style. This name must be unique with respect to all other rendering styles defined in the document. The method will fail if the name is not unique.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Methods > LightingStyles.Add Method


LightingStyles.Item Method

LightingStyles.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Returns the specified from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] LightingStyle*)
Parameters
Parameters | Description
index | Value that specifies the index number of the LightingStyle to return. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Methods > LightingStyles.Item Method


LightingStyles Properties

LightingStyles Properties
Summary

The properties of the LightingStyles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of objects in the collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Properties


LightingStyles.Application Property

LightingStyles.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Properties > LightingStyles.Application Property


LightingStyles.Count Property

LightingStyles.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Properties > LightingStyles.Count Property


LightingStyles.Parent Property

LightingStyles.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Properties > LightingStyles.Parent Property


LightingStyles.Type Property

LightingStyles.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LightingStyles Interface > LightingStyles Properties > LightingStyles.Type Property


Lights Interface

Lights Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The Lights collection object allows for the creation of new Light objects and provides access to existing model space and view space lights.

Class Hierarchy
Inventor::Lights
Visual Basic
Public Interface Lights
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LightingStyle.Lights

You are here: Symbol Reference > Inventor Library > Objects > Lights Interface


Lights Methods

Lights Methods
Summary

The methods of the Lights class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Light object.
Item | Returns the specified Light from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Methods


Lights.Add Method

Lights.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new Light object.

Visual Basic
Sub Add(LightType As LightTypeEnum, Result As [out, retval] Light*)
Parameters
Parameters | Description
LightType | Specifies the light type - model space or view space.
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Methods > Lights.Add Method


Lights.Item Method

Lights.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Returns the specified Light from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Light*)
Parameters
Parameters | Description
index | Value that specifies the index number of the Light to return. If an out of range index is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Methods > Lights.Item Method


Lights Properties

Lights Properties
Summary

The properties of the Lights class are listed here.

Properties
Name | Description
Application | Property returning the Application object.
Count | Property that returns the number of Light objects in the collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning kLightsObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Properties


Lights.Application Property

Lights.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Properties > Lights.Application Property


Lights.Count Property

Lights.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of Light objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Properties > Lights.Count Property


Lights.Parent Property

Lights.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Properties > Lights.Parent Property


Lights.Type Property

Lights.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kLightsObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Lights Interface > Lights Properties > Lights.Type Property


Line Interface

Line Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Line object. The object created is a transient mathematical object and is not displayed graphically.

For more information, see the Transient Geometry article in the overview section.

Class Hierarchy
Inventor::Line
Visual Basic
Public Interface Line
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingView.DrawingViewToModelSpace

DrawingView.SheetToModelSpace

PlanarSketch.AxisEntityGeometry

Plane.IntersectWithPlane

TransientGeometry.CreateLine

WorkAxis.Line

See Also

Create sheet metal rip feature sample

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > Line Interface


Line Methods

Line Methods
Summary

The methods of the Line class are listed here.

Methods
Methods
Name | Description
DistanceTo | Method that returns the distance to the specified point.
GetLineData | Get the data defining this line.
IntersectWithCurve | Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input curve. Returns Nothing if the curves overlap or are parallel.
IntersectWithSurface | Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input surface. Returns Nothing if the Line/LineSegment lies on the surface or it is parallel to the surface.
IsColinearTo | Property that gets whether this line is colinear to the specified line, within the specified tolerance.
PutLineData | Method that sets the data defining this line.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods


Line.DistanceTo Method

Line.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the distance to the specified point.

Visual Basic
Sub DistanceTo(Point As Point, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Point object that specifies the point to which the distance is to be returned.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods > Line.DistanceTo Method


Line.GetLineData Method

Line.GetLineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this line.

Visual Basic
Sub GetLineData(ByRef RootPoint As SAFEARRAY(double), ByRef Direction As SAFEARRAY(double))
Parameters
Parameters | Description
RootPoint | Input/output Double that specifies the root point of the line.
Direction | Input/output Double that specifies the direction of the line.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods > Line.GetLineData Method


Line.IntersectWithCurve Method

Line.IntersectWithCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input curve. Returns Nothing if the curves overlap or are parallel.

Visual Basic
Sub IntersectWithCurve(Curve As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Curve | Input object. This can be a Line, LineSegment, Arc3d, EllipticalArc, Circle, EllipseFull, or a BSplineCurve.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods > Line.IntersectWithCurve Method


Line.IntersectWithSurface Method

Line.IntersectWithSurface Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input surface. Returns Nothing if the Line/LineSegment lies on the surface or it is parallel to the surface.

Visual Basic
Sub IntersectWithSurface(Surface As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Surface | Input object. This can be a Plane, Cone, Cylinder, EllipticalCone, EllipticalCylinder, Sphere, Torus or a BSplineSurface.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods > Line.IntersectWithSurface Method


Line.IsColinearTo Method

Line.IsColinearTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether this line is colinear to the specified line, within the specified tolerance.

Visual Basic
Sub IsColinearTo(Line As IDispatch, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Tolerance | Input Double that specifies the tolerance.
Example

"Is cylindrical face interior or exterior?"

This sample shows how to determine whether the selected cylindircal face is an exterior face or an interior (hollow) face. Before running the sample, select a cylindrical face.

Public Sub IsCylindricalFaceInterior()

    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    If Not Typeof oDoc.SelectSet(1) Is Face Then
        MsgBox "A face must be selected."
        Exit Sub
    End If

    Dim oFace As Face
    Set oFace = oDoc.SelectSet(1)

    If Not oFace.SurfaceType = kCylinderSurface Then
        MsgBox "A cylindrical face must be selected."
        Exit Sub
    End If

    Dim oCylinder As Cylinder
    Set oCylinder = oFace.Geometry

    Dim params(1) As Double
    params(0) = 0.5
    params(1) = 0.5

    ' Get point on surface at param .5,.5
    Dim points(2) As Double
    Call oFace.Evaluator.GetPointAtParam(params, points)

    ' Create point object
    Dim oPoint As point
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint(points(0), points(1), points(2))

    ' Get normal at this point
    Dim normals(2) As Double
    Call oFace.Evaluator.GetNormal(params, normals)

    ' Create normal vector object
    Dim oNormal As Vector
    Set oNormal = ThisApplication.TransientGeometry.CreateVector(normals(0), normals(1), normals(2))

    ' Scale vector by radius of the cylinder
    oNormal.ScaleBy oCylinder.Radius

    ' Find the sampler point on the normal by adding the
    ' scaled normal vector to the point at .5,.5 param.
    Dim oSamplePoint As point
    Set oSamplePoint = oPoint

    oSamplePoint.TranslateBy oNormal

    ' Check if the sample point lies on the cylinder axis.
    ' If it does, we have a hollow face.

    ' Create a line describing the cylinder axis
    Dim oAxisLine As Line
    Set oAxisLine = ThisApplication.TransientGeometry.CreateLine _
        (oCylinder.BasePoint, oCylinder.AxisVector.AsVector)

    'Create a line parallel to the axis passing thru the sample point.
    Dim oSampleLine As Line
    Set oSampleLine = ThisApplication.TransientGeometry.CreateLine _
        (oSamplePoint, oCylinder.AxisVector.AsVector)

    If oSampleLine.IsColinearTo(oAxisLine) Then
        MsgBox "Interior face."
    Else
        MsgBox "Exterior face."
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods > Line.IsColinearTo Method


Line.PutLineData Method

Line.PutLineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this line.

Visual Basic
Sub PutLineData(ByRef RootPoint As SAFEARRAY(double), ByRef Direction As SAFEARRAY(double))
Parameters
Parameters | Description
RootPoint | Input/output Double that specifies the root point of the line.
Direction | Input/output Double that specifies the direction of the line.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Methods > Line.PutLineData Method


Line Properties

Line Properties
Summary

The properties of the Line class are listed here.

Properties
Name | Description
Direction | Specifies the direction of the line.
Evaluator | Gets the CurveEvaluator for the line.
RootPoint | Specifies the root point of the line.
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Properties


Line.Direction Property

Line.Direction Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the line.

Visual Basic
Property Direction() As UnitVector*
See Also

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Properties > Line.Direction Property


Line.Evaluator Property

Line.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the CurveEvaluator for the line.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Properties > Line.Evaluator Property


Line.RootPoint Property

Line.RootPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the root point of the line.

Visual Basic
Property RootPoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Line Interface > Line Properties > Line.RootPoint Property


Line2d Interface

Line2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Line2d object. A Line2d object is infinite. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::Line2d
Visual Basic
Public Interface Line2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateLine2d

You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface


Line2d Methods

Line2d Methods
Summary

The methods of the Line2d class are listed here.

Methods
Methods
Name | Description
DistanceTo | Method that returns the distance to the specified point.
GetLineData | Get the data defining this line.
IntersectWithCurve | Method that returns Point2d objects that represent the points at the intersection of the Line2d/LineSegment2d and the input curve. Returns Nothing if the curves overlap or are parallel.
PutLineData | Method that sets the data defining this line.
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Methods


Line2d.DistanceTo Method

Line2d.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the distance to the specified point.

Visual Basic
Sub DistanceTo(Point As Point2d, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Point2d object that specifies the point to which the distance is to be returned.
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Methods > Line2d.DistanceTo Method


Line2d.GetLineData Method

Line2d.GetLineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this line.

Visual Basic
Sub GetLineData(ByRef RootPoint As SAFEARRAY(double), ByRef Direction As SAFEARRAY(double))
Parameters
Parameters | Description
RootPoint | Input/output Double that specifies the root point of the line.
Direction | Input/output Double that specifies the direction of the line.
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Methods > Line2d.GetLineData Method


Line2d.IntersectWithCurve Method

Line2d.IntersectWithCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns Point2d objects that represent the points at the intersection of the Line2d/LineSegment2d and the input curve. Returns Nothing if the curves overlap or are parallel.

Visual Basic
Sub IntersectWithCurve(Curve As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Curve | Input object. This can be a Line2d, LineSegment2d, Arc2d, EllipticalArc2d, Circle2d, EllipseFull2d, or a BSplineCurve2d.
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Methods > Line2d.IntersectWithCurve Method


Line2d.PutLineData Method

Line2d.PutLineData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this line.

Visual Basic
Sub PutLineData(ByRef RootPoint As SAFEARRAY(double), ByRef Direction As SAFEARRAY(double))
Parameters
Parameters | Description
RootPoint | Input/output Double that specifies the root point of the line.
Direction | Input/output Double that specifies the direction of the line.
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Methods > Line2d.PutLineData Method


Line2d Properties

Line2d Properties
Summary

The properties of the Line2d class are listed here.

Properties
Name | Description
Direction | Specifies the direction of the line.
Evaluator | Gets the Curve2DEvaluator for the line.
RootPoint | Specifies the root point of the line.
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Properties


Line2d.Direction Property

Line2d.Direction Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the line.

Visual Basic
Property Direction() As UnitVector2d*
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Properties > Line2d.Direction Property


Line2d.Evaluator Property

Line2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Curve2DEvaluator for the line.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Properties > Line2d.Evaluator Property


Line2d.RootPoint Property

Line2d.RootPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the root point of the line.

Visual Basic
Property RootPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > Line2d Interface > Line2d Properties > Line2d.RootPoint Property


LineAndPlaneWorkAxisDef Interface

LineAndPlaneWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work axis that is along a line defined by projecting a line onto a plane along the plane normal.

Class Hierarchy
Inventor::LineAndPlaneWorkAxisDef
Visual Basic
Public Interface LineAndPlaneWorkAxisDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface


LineAndPlaneWorkAxisDef Methods

LineAndPlaneWorkAxisDef Methods
Summary

The methods of the LineAndPlaneWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work axis that is along a line defined by projecting a line onto a plane along the plane normal.
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Methods


LineAndPlaneWorkAxisDef.GetData Method

LineAndPlaneWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work axis that is along a line defined by projecting a line onto a plane along the plane normal.

Visual Basic
Sub GetData(ByRef Line As IDispatch*, ByRef Plane As IDispatch*)
Parameters
Parameters | Description
Line | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Plane | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Methods > LineAndPlaneWorkAxisDef.GetData Method


LineAndPlaneWorkAxisDef Properties

LineAndPlaneWorkAxisDef Properties
Summary

The properties of the LineAndPlaneWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Line | Property that returns the point of a work axis that is along a line defined by projecting a line onto a plane along the plane normal. This object can be a linear Edge, WorkAxis, or SketchLine object.
Parent | Property returning the parent WorkAxis object.
Plane | Property that indicates the plane of a work axis that is along a line defined by projecting a line onto a plane along the plane normal. This object can be a planar Face, WorkPlane, or Sketch object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Properties


LineAndPlaneWorkAxisDef.Application Property

LineAndPlaneWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Properties > LineAndPlaneWorkAxisDef.Application Property


LineAndPlaneWorkAxisDef.Line Property

LineAndPlaneWorkAxisDef.Line Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the point of a work axis that is along a line defined by projecting a line onto a plane along the plane normal. This object can be a linear Edge, WorkAxis, or SketchLine object.

Visual Basic
Property Line() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Properties > LineAndPlaneWorkAxisDef.Line Property


LineAndPlaneWorkAxisDef.Parent Property

LineAndPlaneWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Properties > LineAndPlaneWorkAxisDef.Parent Property


LineAndPlaneWorkAxisDef.Plane Property

LineAndPlaneWorkAxisDef.Plane Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the plane of a work axis that is along a line defined by projecting a line onto a plane along the plane normal. This object can be a planar Face, WorkPlane, or Sketch object.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Properties > LineAndPlaneWorkAxisDef.Plane Property


LineAndPlaneWorkAxisDef.Type Property

LineAndPlaneWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LineAndPlaneWorkAxisDef Interface > LineAndPlaneWorkAxisDef Properties > LineAndPlaneWorkAxisDef.Type Property


LineAndPointWorkAxisDef Interface

LineAndPointWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Object that allows you to get and set the information that specifies a work axis that is along a line and passes through a point.

Class Hierarchy
Inventor::LineAndPointWorkAxisDef
Visual Basic
Public Interface LineAndPointWorkAxisDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface


LineAndPointWorkAxisDef Methods

LineAndPointWorkAxisDef Methods
Summary

The methods of the LineAndPointWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work axis that is along a line and passes through a point.
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Methods


LineAndPointWorkAxisDef.GetData Method

LineAndPointWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that gets all of the data defining a work axis that is along a line and passes through a point.

Visual Basic
Sub GetData(ByRef Line As IDispatch*, ByRef Point As IDispatch*)
Parameters
Parameters | Description
Line | Object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Point | Output object that represents a point. This object can be a vertex, WorkPoint, SketchPoint, or SketchPoint3D object.
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Methods > LineAndPointWorkAxisDef.GetData Method


LineAndPointWorkAxisDef Properties

LineAndPointWorkAxisDef Properties
Summary

The properties of the LineAndPointWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Line | Property that returns the line used to define a work axis that is along a line and passes through a point. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Parent | Property that returns the parent WorkAxis object.
Point | Property that returns the point used to define a work axis that is along a line and passes through a point.. This object can be a vertex, WorkPoint, SketchPoint, or SketchPoint3D object.
Type | Property that returns kLineAndPointWorkAxisDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Properties


LineAndPointWorkAxisDef.Application Property

LineAndPointWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Properties > LineAndPointWorkAxisDef.Application Property


LineAndPointWorkAxisDef.Line Property

LineAndPointWorkAxisDef.Line Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the line used to define a work axis that is along a line and passes through a point. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.

Visual Basic
Property Line() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Properties > LineAndPointWorkAxisDef.Line Property


LineAndPointWorkAxisDef.Parent Property

LineAndPointWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Properties > LineAndPointWorkAxisDef.Parent Property


LineAndPointWorkAxisDef.Point Property

LineAndPointWorkAxisDef.Point Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the point used to define a work axis that is along a line and passes through a point.. This object can be a vertex, WorkPoint, SketchPoint, or SketchPoint3D object.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Properties > LineAndPointWorkAxisDef.Point Property


LineAndPointWorkAxisDef.Type Property

LineAndPointWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns kLineAndPointWorkAxisDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LineAndPointWorkAxisDef Interface > LineAndPointWorkAxisDef Properties > LineAndPointWorkAxisDef.Type Property


LineAndTangentWorkPlaneDef Interface

LineAndTangentWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane that passes through a line and is tangent to a surface.

Class Hierarchy
Inventor::LineAndTangentWorkPlaneDef
Visual Basic
Public Interface LineAndTangentWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface


LineAndTangentWorkPlaneDef Methods

LineAndTangentWorkPlaneDef Methods
Summary

The methods of the LineAndTangentWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work that passes through the line and is tangent to the input face.
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Methods


LineAndTangentWorkPlaneDef.GetData Method

LineAndTangentWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work that passes through the line and is tangent to the input face.

Visual Basic
Sub GetData(ByRef Line As IDispatch*, ByRef Face As Face*, ByRef ProximityPoint As Point*)
Parameters
Parameters | Description
Line | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object. The work plane passes through this line.
Face | Output Face object that indicates the tangent surface. This face will be a cylinder, cone, or sphere.
ProximityPoint | Output object that indicates which of the possible two solutions was used when calculating the tangent plane. The proximity point itself is not stored. The point returned is calculated as an arbitrary point along the tangent between the face and plane.
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Methods > LineAndTangentWorkPlaneDef.GetData Method


LineAndTangentWorkPlaneDef Properties

LineAndTangentWorkPlaneDef Properties
Summary

The properties of the LineAndTangentWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Face | Property that returns the tangent of the work plane. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.
Line | Property that returns the line of a work plane that passes through a line and is tangent to a surface. This object can be a linear Edge, WorkAxis, or SketchLine object.
Parent | Property returning the parent WorkPlane object.
ProximityPoint | Property that returns the proximity point. The proximity point defines which of the two possible solutions is chosen when computing the tangent plane. This point is used for the initial computation and the specific point is not stored. During a recompute of the model the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point. The point returned by this property is as an arbitrary point along the tangent between the face and plane.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties


LineAndTangentWorkPlaneDef.Application Property

LineAndTangentWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties > LineAndTangentWorkPlaneDef.Application Property


LineAndTangentWorkPlaneDef.Face Property

LineAndTangentWorkPlaneDef.Face Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the tangent of the work plane. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties > LineAndTangentWorkPlaneDef.Face Property


LineAndTangentWorkPlaneDef.Line Property

LineAndTangentWorkPlaneDef.Line Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the line of a work plane that passes through a line and is tangent to a surface. This object can be a linear Edge, WorkAxis, or SketchLine object.

Visual Basic
Property Line() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties > LineAndTangentWorkPlaneDef.Line Property


LineAndTangentWorkPlaneDef.Parent Property

LineAndTangentWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties > LineAndTangentWorkPlaneDef.Parent Property


LineAndTangentWorkPlaneDef.ProximityPoint Property

LineAndTangentWorkPlaneDef.ProximityPoint Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the proximity point. The proximity point defines which of the two possible solutions is chosen when computing the tangent plane. This point is used for the initial computation and the specific point is not stored. During a recompute of the model the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point. The point returned by this property is as an arbitrary point along the tangent between the face and plane.

Visual Basic
Property ProximityPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties > LineAndTangentWorkPlaneDef.ProximityPoint Property


LineAndTangentWorkPlaneDef.Type Property

LineAndTangentWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LineAndTangentWorkPlaneDef Interface > LineAndTangentWorkPlaneDef Properties > LineAndTangentWorkPlaneDef.Type Property


LinearGeneralDimension Interface

LinearGeneralDimension Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LinearGeneralDimension object represents a linear general dimension placed on a sheet.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
        Inventor::LinearGeneralDimension
Visual Basic
Public Interface LinearGeneralDimension
Inherits GeneralDimension
Notes

Members through which this object may be accessed include:

BaselineDimensionSet.AddMember

GeneralDimensions.AddLinear

See Also

Add surface texture symbol to dimension sample

Center Dimension Text sample

You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface


LinearGeneralDimension Methods

LinearGeneralDimension Methods
Summary

The methods of the LinearGeneralDimension class are listed here.

Methods
Methods
Name | Description
CenterText | Method that centers the dimension text on the dimension line.
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Methods


LinearGeneralDimension.CenterText Method

LinearGeneralDimension.CenterText Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that centers the dimension text on the dimension line.

Visual Basic
Sub CenterText()
Example

See AngularGeneralDimension::CenterText for example "CenterText Method"

You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Methods > LinearGeneralDimension.CenterText Method


LinearGeneralDimension Properties

LinearGeneralDimension Properties
Summary

The properties of the LinearGeneralDimension class are listed here.

Properties
Name | Description
BaselineDimensionSet | Property that returns the BaselineDimensionSet that owns this dimension.
ChainDimensionSet | Property that returns the ChainDimensionSet that owns this dimension. This property returns nothing if this dimension is not a chain dimension set member. This can be checked using the IsChainSetMember property.
DimensionType | Property that returns the dimension type. Possible values are kAlignedDimensionType, kHorizontalDimensionType, kVerticalDimensionType, kArcLengthDimensionType, kSymmetricDimensionType and kDiametricDimensionType.
ExtensionLineOne | Property that returns the first extension line of the dimension.
ExtensionLineOneVisible | Property that gets and sets whether the first extension line is visible.
ExtensionLineTwo | Property that returns the second extension line of the dimension.
ExtensionLineTwoVisible | Property that gets and sets whether the second extension line is visible. This property returns False and cannot be set to True for linear symmetric dimensions. For linear diametric dimensions, this property returns False and cannot be set to True if the FullDimensionLine property is False.
FullDimensionLine | Property that gets and sets whether the full dimension line should be displayed for linear diametric dimensions. This property can only be set if the DimensionType property returns kDiametricDimensionType. For all other cases, the property returns True and setting to False returns an error.
IntentOne | Property that returns the first geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IntentTwo | Property that returns the second geometry associated with the dimension. This may return Nothing in some cases where a single geometry was used for the dimension creation. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
IsBaselineSetMember | Property that returns whether this dimension is a member of a baseline dimension set. If this property returns True, the BaselineDimensionSet object is returned by the BaselineDimensionSet property.
IsChainSetMember | Property that returns whether this dimension is a member of a chain dimension set. If this property returns True, the ChainDimensionSet object is returned by the ChainDimensionSet property.
ShowLeader | Property that gets and sets whether to display a leader line for the dimension text.
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties


LinearGeneralDimension.BaselineDimensionSet Property

LinearGeneralDimension.BaselineDimensionSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the BaselineDimensionSet that owns this dimension.

Visual Basic
Property BaselineDimensionSet() As BaselineDimensionSet**
Remarks

This property returns nothing if this dimension is not a baseline dimension set member. This can be checked using the IsBaselineSetMember property.

You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.BaselineDimensionSet Property


LinearGeneralDimension.ChainDimensionSet Property

LinearGeneralDimension.ChainDimensionSet Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ChainDimensionSet that owns this dimension. This property returns nothing if this dimension is not a chain dimension set member. This can be checked using the IsChainSetMember property.

Visual Basic
Property ChainDimensionSet() As ChainDimensionSet**
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.ChainDimensionSet Property


LinearGeneralDimension.DimensionType Property

LinearGeneralDimension.DimensionType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the dimension type. Possible values are kAlignedDimensionType, kHorizontalDimensionType, kVerticalDimensionType, kArcLengthDimensionType, kSymmetricDimensionType and kDiametricDimensionType.

Visual Basic
Property DimensionType() As DimensionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.DimensionType Property


LinearGeneralDimension.ExtensionLineOne Property

LinearGeneralDimension.ExtensionLineOne Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the first extension line of the dimension.

Visual Basic
Property ExtensionLineOne() As IDispatch**
Remarks

This property may return Nothing in cases where there are no extension lines. The object returned by this property is a LineSegment2d in sheet space for projected dimensions and LineSegment in model space for true (iso) dimensions.

See Also

Add surface texture symbol to dimension sample

You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.ExtensionLineOne Property


LinearGeneralDimension.ExtensionLineOneVisible Property

LinearGeneralDimension.ExtensionLineOneVisible Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the first extension line is visible.

Visual Basic
Property ExtensionLineOneVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.ExtensionLineOneVisible Property


LinearGeneralDimension.ExtensionLineTwo Property

LinearGeneralDimension.ExtensionLineTwo Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the second extension line of the dimension.

Visual Basic
Property ExtensionLineTwo() As IDispatch**
Remarks

This property may return Nothing in cases where there are no extension lines. The object returned by this property is a LineSegment2d in sheet space for projected dimensions and LineSegment in model space for true (iso) dimensions.

You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.ExtensionLineTwo Property


LinearGeneralDimension.ExtensionLineTwoVisible Property

LinearGeneralDimension.ExtensionLineTwoVisible Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the second extension line is visible. This property returns False and cannot be set to True for linear symmetric dimensions. For linear diametric dimensions, this property returns False and cannot be set to True if the FullDimensionLine property is False.

Visual Basic
Property ExtensionLineTwoVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.ExtensionLineTwoVisible Property


LinearGeneralDimension.FullDimensionLine Property

LinearGeneralDimension.FullDimensionLine Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the full dimension line should be displayed for linear diametric dimensions. This property can only be set if the DimensionType property returns kDiametricDimensionType. For all other cases, the property returns True and setting to False returns an error.

Visual Basic
Property FullDimensionLine() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.FullDimensionLine Property


LinearGeneralDimension.IntentOne Property

LinearGeneralDimension.IntentOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the first geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property IntentOne() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.IntentOne Property


LinearGeneralDimension.IntentTwo Property

LinearGeneralDimension.IntentTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the second geometry associated with the dimension. This may return Nothing in some cases where a single geometry was used for the dimension creation. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property IntentTwo() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.IntentTwo Property


LinearGeneralDimension.IsBaselineSetMember Property

LinearGeneralDimension.IsBaselineSetMember Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether this dimension is a member of a baseline dimension set. If this property returns True, the BaselineDimensionSet object is returned by the BaselineDimensionSet property.

Visual Basic
Property IsBaselineSetMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.IsBaselineSetMember Property


LinearGeneralDimension.IsChainSetMember Property

LinearGeneralDimension.IsChainSetMember Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns whether this dimension is a member of a chain dimension set. If this property returns True, the ChainDimensionSet object is returned by the ChainDimensionSet property.

Visual Basic
Property IsChainSetMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.IsChainSetMember Property


LinearGeneralDimension.ShowLeader Property

LinearGeneralDimension.ShowLeader Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to display a leader line for the dimension text.

Visual Basic
Property ShowLeader() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LinearGeneralDimension Interface > LinearGeneralDimension Properties > LinearGeneralDimension.ShowLeader Property


LinearHolePlacementDefinition Interface

LinearHolePlacementDefinition Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The LinearHolePlacementDefinition object defines the placement of a hole feature with respect to two linear entities.

Class Hierarchy
Inventor::HolePlacementDefinition
    Inventor::LinearHolePlacementDefinition
Visual Basic
Public Interface LinearHolePlacementDefinition
Inherits HolePlacementDefinition
Notes

Members through which this object may be accessed include:

HoleFeatures.CreateLinearPlacementDefinition

See Also

Hole feature linear placement sample

You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface


LinearHolePlacementDefinition Properties

LinearHolePlacementDefinition Properties
Summary

The properties of the LinearHolePlacementDefinition class are listed here.

Properties
Name | Description
DirectionOneReversed | Property that gets and sets whether to reverse the direction of the hole placement with respect to the first reference entity.
DirectionTwoReversed | Property that gets and sets whether to reverse the direction of the hole placement with respect to the second reference entity.
DistanceOne | Property that returns the parameter controlling the distance of the hole center from the first reference entity.
DistanceTwo | Property that returns the parameter controlling the distance of the hole center from the second reference entity.
Plane | Property that indicates the plane on which the hole feature is placed. This can be a planar Face object or a WorkPlane object.
ReferenceEntityOne | Property that indicates the first entity referenced for dimensioning the placement of the hole. This can only be a linear Edge.
ReferenceEntityTwo | Property that indicates the second entity referenced for dimensioning the placement of the hole. This can only be a linear Edge.
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties


LinearHolePlacementDefinition.DirectionOneReversed Property

LinearHolePlacementDefinition.DirectionOneReversed Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether to reverse the direction of the hole placement with respect to the first reference entity.

Visual Basic
Property DirectionOneReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.DirectionOneReversed Property


LinearHolePlacementDefinition.DirectionTwoReversed Property

LinearHolePlacementDefinition.DirectionTwoReversed Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether to reverse the direction of the hole placement with respect to the second reference entity.

Visual Basic
Property DirectionTwoReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.DirectionTwoReversed Property


LinearHolePlacementDefinition.DistanceOne Property

LinearHolePlacementDefinition.DistanceOne Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parameter controlling the distance of the hole center from the first reference entity.

Visual Basic
Property DistanceOne() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.DistanceOne Property


LinearHolePlacementDefinition.DistanceTwo Property

LinearHolePlacementDefinition.DistanceTwo Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parameter controlling the distance of the hole center from the second reference entity.

Visual Basic
Property DistanceTwo() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.DistanceTwo Property


LinearHolePlacementDefinition.Plane Property

LinearHolePlacementDefinition.Plane Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the plane on which the hole feature is placed. This can be a planar Face object or a WorkPlane object.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.Plane Property


LinearHolePlacementDefinition.ReferenceEntityOne Property

LinearHolePlacementDefinition.ReferenceEntityOne Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the first entity referenced for dimensioning the placement of the hole. This can only be a linear Edge.

Visual Basic
Property ReferenceEntityOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.ReferenceEntityOne Property


LinearHolePlacementDefinition.ReferenceEntityTwo Property

LinearHolePlacementDefinition.ReferenceEntityTwo Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the second entity referenced for dimensioning the placement of the hole. This can only be a linear Edge.

Visual Basic
Property ReferenceEntityTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LinearHolePlacementDefinition Interface > LinearHolePlacementDefinition Properties > LinearHolePlacementDefinition.ReferenceEntityTwo Property


LineGraphics Interface

LineGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The LineGraphics object defines one or more disconnected lines.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::LineGraphics
Visual Basic
Public Interface LineGraphics
Inherits GraphicsPrimitive
Remarks

The first coordinate defines the start of the first line, the second coordinate defines the end of the first line, the third coordinate defines the start of the second line, and so on. The description below shows two methods of defining the lines to draw the box with an X as shown in the figure. The unique vertices are numbered. One uses only a coordinate set and the other also uses an index set to make more efficient use of the coordinates.

Coordinate set 1

(0,0,0),(1,0,0), (1,0,0),(1,1,0), (1,1,0),(0,1,0), (0,1,0),(0,0,0), (0,0,0),(1,1,0), (1,0,0),(0,1,0)

The coordinates listed in the set above define a square with diagonal lines going from one corner to the other. Each pair of coordinates defines a separate line. In this case it takes 12 coordinates to draw the 6 lines. (This can also be done more efficiently using a LineStripGraphics.)

Coordinate set 2

(0,0,0), (1,0,0), (1,1,0), (0,1,0)

Index set

1, 2, 2, 3, 3, 4, 4, 1, 1, 3, 2, 4

This case uses an index set to define the points for the lines. When an index set is used it is used to look up the coordinates in the coordinate set. The use of an index allows the reuse of a coordinates by using a portion of the complete set and/or using the coordinates in any order. In this example, the four unique points are defined in the coordinate set. Each pair of indices in the index set defines a point by referencing a coordinate from the coordinate set.

In many cases, use of an index set is much more efficient, particularly when you consider that other graphic primitives can share coordinate sets. For example, you may have a list of coordinates that defines all of the vertices of a triangle mesh. It is much more efficient to define each of these vertices once and then reference them using an index set to build the triangles. The same set of coordinates can also be used to draw line sets or linestrip sets along the boundaries.

Notes

Members through which this object may be accessed include:

GraphicsNode.AddLineGraphics

See Also

Client Graphics - Line sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface


LineGraphics Methods

LineGraphics Methods
Summary

The methods of the LineGraphics class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
GetTransformBehavior | Returns the current view transformation settings (e.g. pixel scaling and front facing).
SetCustomLineType |
SetTransformBehavior | Sets the view transformation settings (e.g. pixel scaling and front facing).
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Methods


LineGraphics.GetCustomLineType Method

LineGraphics.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Methods > LineGraphics.GetCustomLineType Method


LineGraphics.GetTransformBehavior Method

LineGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the current view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point that returns the point that is unaffected by the transform behavior.
BehaviorType | Output DisplayTransformBehaviorEnum that returns the transform behaviors currently being used.
PixelScale | Output Double that returns the number of pixels that are used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Methods > LineGraphics.GetTransformBehavior Method


LineGraphics.SetCustomLineType Method

LineGraphics.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Methods > LineGraphics.SetCustomLineType Method


LineGraphics.SetTransformBehavior Method

LineGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Sets the view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input that indicates which point is unaffected by the transform behavior.
BehaviorType | Input DisplayTransformBehaviorEnum that specifies which transform behaviors are to be used.
PixelScale | Input Double that indicates how many pixels should be used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Methods > LineGraphics.SetTransformBehavior Method


LineGraphics Properties

LineGraphics Properties
Summary

The properties of the LineGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
ColorBinding | Property that gets and sets how colors are defined for the line.
ColorIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to a index set.
ColorSet | Property that gets and sets the GraphicsColorSet associated with the set.
CoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the coordinate set to use for the lines of the set.
CoordinateSet | Property that gets and sets the GraphicsCoordinateSet associated with the set.
DepthPriority | Property that allows you to specify a display priority to the line graphics. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type associated with the primitive.
LineWeight | Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties


LineGraphics.BurnThrough Property

LineGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.BurnThrough Property


LineGraphics.ColorBinding Property

LineGraphics.ColorBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how colors are defined for the line.

Visual Basic
Property ColorBinding() As ColorBindingEnum
Remarks

If an index set is defined, then the order of colors is defined by the index set. If an index set is not defined, then the order of the colors in the color set is used. The options are:

  • kOverallColor ' The first color in the set is used for the entire line set.
  • kPerItemColors ' The first color in the set is used for the first line, the second color for the second line, and so on. If there are more lines than colors, the last color in the list is used for the remaining lines. If there are more colors than lines, the additional colors are ignored.
  • kPerStripColor ' Not applicable to line sets. Will be interpreted to be the same as kPerItemColor.
  • kPerVertexColors ' The first color in the set is used for the first vertex (start of the first line), the second color is used for the second vertex (end of the first line), the third color is used for the third vertex (start of the second line) and so on. Since a different color can be defined for each vertex the color blends along the line from one color to the other. If there are more vertices than colors, the last color in the set is used for the remaining vertices. If there are more colors than vertices, the additional colors are ignored.
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.ColorBinding Property


LineGraphics.ColorIndexSet Property

LineGraphics.ColorIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to a index set.

Visual Basic
Property ColorIndexSet() As GraphicsIndexSet*
Remarks

An index set for colors serves as a color lookup mechanism into the color set. When colors are assigned to the object the order defined by the index set is used instead of the ordering within the color set.

You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.ColorIndexSet Property


LineGraphics.ColorSet Property

LineGraphics.ColorSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsColorSet associated with the set.

Visual Basic
Property ColorSet() As GraphicsColorSet*
Remarks

If no color set is set for the line set, the render style color defined for the GraphicsNode will be used. If a color set is defined, it overrides the diffuse and ambient colors defined in the render style of the GraphicsNode. This property can be set to Nothing to remove the reference to a color set and return to using the colors defined by the display style of the GraphicsNode.

You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.ColorSet Property


LineGraphics.CoordinateIndexSet Property

LineGraphics.CoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the coordinate set to use for the lines of the set.

Visual Basic
Property CoordinateIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.CoordinateIndexSet Property


LineGraphics.CoordinateSet Property

LineGraphics.CoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsCoordinateSet associated with the set.

Visual Basic
Property CoordinateSet() As GraphicsCoordinateSet*
See Also

InteractionGraphics sample

Client Graphics - Line sample

Client Graphics - Draw Range Box sample

You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.CoordinateSet Property


LineGraphics.DepthPriority Property

LineGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a display priority to the line graphics. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.DepthPriority Property


LineGraphics.LineDefinitionSpace Property

LineGraphics.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.LineDefinitionSpace Property


LineGraphics.LineScale Property

LineGraphics.LineScale Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.LineScale Property


LineGraphics.LineType Property

LineGraphics.LineType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line type associated with the primitive.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.LineType Property


LineGraphics.LineWeight Property

LineGraphics.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > LineGraphics Interface > LineGraphics Properties > LineGraphics.LineWeight Property


LineLengthDimConstraint3D Interface

LineLengthDimConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LineLengthDimConstraint3D object represents a constraint that controls the length of a 3D sketch line.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::LineLengthDimConstraint3D
        Inventor::LineLengthDimConstraint3DProxy
Visual Basic
Public Interface LineLengthDimConstraint3D
Inherits DimensionConstraint3D
Notes

Members through which this object may be accessed include:

DimensionConstraints3D.AddLineLength

LineLengthDimConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3D Interface


LineLengthDimConstraint3D Properties

LineLengthDimConstraint3D Properties
Summary

The properties of the LineLengthDimConstraint3D class are listed here.

Properties
Name | Description
Line | Property that returns the 3D sketch line being constrained.
You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3D Interface > LineLengthDimConstraint3D Properties


LineLengthDimConstraint3D.Line Property

LineLengthDimConstraint3D.Line Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the 3D sketch line being constrained.

Visual Basic
Property Line() As SketchLine3D**
You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3D Interface > LineLengthDimConstraint3D Properties > LineLengthDimConstraint3D.Line Property


LineLengthDimConstraint3DProxy Interface

LineLengthDimConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LineLengthDimConstraint3D object.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::LineLengthDimConstraint3D
        Inventor::LineLengthDimConstraint3DProxy
Visual Basic
Public Interface LineLengthDimConstraint3DProxy
Inherits LineLengthDimConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3DProxy Interface


LineLengthDimConstraint3DProxy Properties

LineLengthDimConstraint3DProxy Properties
Summary

The properties of the LineLengthDimConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3DProxy Interface > LineLengthDimConstraint3DProxy Properties


LineLengthDimConstraint3DProxy.ContainingOccurrence Property

LineLengthDimConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3DProxy Interface > LineLengthDimConstraint3DProxy Properties > LineLengthDimConstraint3DProxy.ContainingOccurrence Property


LineLengthDimConstraint3DProxy.NativeObject Property

LineLengthDimConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As LineLengthDimConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LineLengthDimConstraint3DProxy Interface > LineLengthDimConstraint3DProxy Properties > LineLengthDimConstraint3DProxy.NativeObject Property


LinePlaneAndAngleWorkPlaneDef Interface

LinePlaneAndAngleWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane that passes through a line and is a specified angle to a plane.

Class Hierarchy
Inventor::LinePlaneAndAngleWorkPlaneDef
Visual Basic
Public Interface LinePlaneAndAngleWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface


LinePlaneAndAngleWorkPlaneDef Methods

LinePlaneAndAngleWorkPlaneDef Methods
Summary

The methods of the LinePlaneAndAngleWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work planed defined by a line, plane and an angle. The work plane passes through the line and is a specified angle to the plane.
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Methods


LinePlaneAndAngleWorkPlaneDef.GetData Method

LinePlaneAndAngleWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work planed defined by a line, plane and an angle. The work plane passes through the line and is a specified angle to the plane.

Visual Basic
Sub GetData(ByRef Line As IDispatch*, ByRef Plane As IDispatch*, ByRef Angle As Parameter*)
Parameters
Parameters | Description
Line | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object. The work plane passes through this line.
Plane | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object. The angle of the work plane is measured with respect to this plane.
Angle | Output Parameter that defines the angle of the work plane to the plane. The positive angle direction is computed by crossing the axis vector with the plane normal vector.
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Methods > LinePlaneAndAngleWorkPlaneDef.GetData Method


LinePlaneAndAngleWorkPlaneDef Properties

LinePlaneAndAngleWorkPlaneDef Properties
Summary

The properties of the LinePlaneAndAngleWorkPlaneDef class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter controlling the angle of a line, plane and angle defined work plane. The angle of the plane can be read and modified by accessing the returned Parameter object. The positive angle direction is computed by crossing the axis vector with the plane normal vector. Changes made will not be visible until the model is recomputed.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Line | Property that returns the line of a line, plane and angle defined work plane. This object can be a linear Edge, WorkAxis, or SketchLine object. The work plane passes through the line.
Parent | Property returning the parent WorkPlane object.
Plane | Property that indicates the plane of a line, plane and angle defined work plane. This object can be a planar Face, WorkPlane, or Sketch object. The angle of the plane is measured with respect to this plane.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties


LinePlaneAndAngleWorkPlaneDef.Angle Property

LinePlaneAndAngleWorkPlaneDef.Angle Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parameter controlling the angle of a line, plane and angle defined work plane. The angle of the plane can be read and modified by accessing the returned Parameter object. The positive angle direction is computed by crossing the axis vector with the plane normal vector. Changes made will not be visible until the model is recomputed.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties > LinePlaneAndAngleWorkPlaneDef.Angle Property


LinePlaneAndAngleWorkPlaneDef.Application Property

LinePlaneAndAngleWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties > LinePlaneAndAngleWorkPlaneDef.Application Property


LinePlaneAndAngleWorkPlaneDef.Line Property

LinePlaneAndAngleWorkPlaneDef.Line Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the line of a line, plane and angle defined work plane. This object can be a linear Edge, WorkAxis, or SketchLine object. The work plane passes through the line.

Visual Basic
Property Line() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties > LinePlaneAndAngleWorkPlaneDef.Line Property


LinePlaneAndAngleWorkPlaneDef.Parent Property

LinePlaneAndAngleWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties > LinePlaneAndAngleWorkPlaneDef.Parent Property


LinePlaneAndAngleWorkPlaneDef.Plane Property

LinePlaneAndAngleWorkPlaneDef.Plane Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the plane of a line, plane and angle defined work plane. This object can be a planar Face, WorkPlane, or Sketch object. The angle of the plane is measured with respect to this plane.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties > LinePlaneAndAngleWorkPlaneDef.Plane Property


LinePlaneAndAngleWorkPlaneDef.Type Property

LinePlaneAndAngleWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LinePlaneAndAngleWorkPlaneDef Interface > LinePlaneAndAngleWorkPlaneDef Properties > LinePlaneAndAngleWorkPlaneDef.Type Property


LineSegment Interface

LineSegment Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

The LineSegment object represents a line segment. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::LineSegment
Visual Basic
Public Interface LineSegment
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchLine3D.Geometry

TransientGeometry.CreateLineSegment

CurveGraphics.Curve

DrawingDimension.DimensionLine

AngularGeneralDimension.ExtensionLineOne

DiameterGeneralDimension.ExtensionLineOne

LinearGeneralDimension.ExtensionLineOne

AngularGeneralDimension.ExtensionLineTwo

DiameterGeneralDimension.ExtensionLineTwo

LinearGeneralDimension.ExtensionLineTwo

Edge.Geometry

See Also

Create sheet metal rip feature sample

Create client graphics based on the solid body of the active part sample

Transient surface body creation sample

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface


LineSegment Methods

LineSegment Methods
Summary

The methods of the LineSegment class are listed here.

Methods
Methods
Name | Description
DistanceTo | Method that returns the distance to the specified point.
GetLineSegmentData | Method that returns the data defining this line segment.
IntersectWithCurve | Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input curve. Returns Nothing if the curves overlap or are parallel.
IntersectWithSurface | Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input surface. Returns Nothing if the Line/LineSegment lies on the surface or it is parallel to the surface.
PutLineSegmentData | Method that sets the data defining this line segment.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Methods


LineSegment.DistanceTo Method

LineSegment.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the distance to the specified point.

Visual Basic
Sub DistanceTo(Point As Point, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Point object that specifies the point to which the distance is to be returned.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Methods > LineSegment.DistanceTo Method


LineSegment.GetLineSegmentData Method

LineSegment.GetLineSegmentData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the data defining this line segment.

Visual Basic
Sub GetLineSegmentData(ByRef StartPoint As SAFEARRAY(double), ByRef EndPoint As SAFEARRAY(double))
Parameters
Parameters | Description
StartPoint | Input/output Double that specifies the start point.
EndPoint | Input/output Double that specifies the end point.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Methods > LineSegment.GetLineSegmentData Method


LineSegment.IntersectWithCurve Method

LineSegment.IntersectWithCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input curve. Returns Nothing if the curves overlap or are parallel.

Visual Basic
Sub IntersectWithCurve(Curve As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Curve | Input object. This can be a Line, LineSegment, Arc3d, EllipticalArc, Circle, EllipseFull, or a BSplineCurve.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Methods > LineSegment.IntersectWithCurve Method


LineSegment.IntersectWithSurface Method

LineSegment.IntersectWithSurface Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns Point objects that represent the points at the intersection of the Line/LineSegment and the input surface. Returns Nothing if the Line/LineSegment lies on the surface or it is parallel to the surface.

Visual Basic
Sub IntersectWithSurface(Surface As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Surface | Input object. This can be a Plane, Cone, Cylinder, EllipticalCone, EllipticalCylinder, Sphere, Torus or a BSplineSurface.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Methods > LineSegment.IntersectWithSurface Method


LineSegment.PutLineSegmentData Method

LineSegment.PutLineSegmentData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the data defining this line segment.

Visual Basic
Sub PutLineSegmentData(ByRef StartPoint As SAFEARRAY(double), ByRef EndPoint As SAFEARRAY(double))
Parameters
Parameters | Description
StartPoint | Input/output Double that specifies the start point.
EndPoint | Input/output Double that defines the end point.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Methods > LineSegment.PutLineSegmentData Method


LineSegment Properties

LineSegment Properties
Summary

The properties of the LineSegment class are listed here.

Properties
Name | Description
Direction | Property that returns the direction of the line segment.
EndPoint | Specifies the end point of the line.
Evaluator | Property that returns the CurveEvaluator for this line segment.
MidPoint | Property that returns the midpoint of the line segment.
StartPoint | Specifies the end point of the line.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Properties


LineSegment.Direction Property

LineSegment.Direction Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the direction of the line segment.

Visual Basic
Property Direction() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Properties > LineSegment.Direction Property


LineSegment.EndPoint Property

LineSegment.EndPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the end point of the line.

Visual Basic
Property EndPoint() As Point*
See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Properties > LineSegment.EndPoint Property


LineSegment.Evaluator Property

LineSegment.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the CurveEvaluator for this line segment.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Properties > LineSegment.Evaluator Property


LineSegment.MidPoint Property

LineSegment.MidPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the midpoint of the line segment.

Visual Basic
Property MidPoint() As Point**
See Also

Add surface texture symbol to dimension sample

You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Properties > LineSegment.MidPoint Property


LineSegment.StartPoint Property

LineSegment.StartPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the end point of the line.

Visual Basic
Property StartPoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > LineSegment Interface > LineSegment Properties > LineSegment.StartPoint Property


LineSegment2d Interface

LineSegment2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The LineSegment2d object. The object is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::LineSegment2d
Visual Basic
Public Interface LineSegment2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchLine.Geometry

TransientGeometry.CreateLineSegment2d

ProfileEntity.Curve

DrawingDimension.DimensionLine

AngularGeneralDimension.ExtensionLineOne

DiameterGeneralDimension.ExtensionLineOne

LinearGeneralDimension.ExtensionLineOne

AngularGeneralDimension.ExtensionLineTwo

DiameterGeneralDimension.ExtensionLineTwo

LinearGeneralDimension.ExtensionLineTwo

Centerline.Geometry

You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface


LineSegment2d Methods

LineSegment2d Methods
Summary

The methods of the LineSegment2d class are listed here.

Methods
Methods
Name | Description
DistanceTo | Method that returns the distance to the specified point.
GetLineSegmentData | Get the data defining this line segment.
IntersectWithCurve | Method that returns Point2d objects that represent the points at the intersection of the Line2d/LineSegment2d and the input curve. Returns Nothing if the curves overlap or are parallel.
PutLineSegmentData | Method that sets the data defining this line segment.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Methods


LineSegment2d.DistanceTo Method

LineSegment2d.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the distance to the specified point.

Visual Basic
Sub DistanceTo(Point As Point2d, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Point2d object that specifies the point to which the distance is to be returned.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Methods > LineSegment2d.DistanceTo Method


LineSegment2d.GetLineSegmentData Method

LineSegment2d.GetLineSegmentData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Get the data defining this line segment.

Visual Basic
Sub GetLineSegmentData(ByRef StartPoint As SAFEARRAY(double), ByRef EndPoint As SAFEARRAY(double))
Parameters
Parameters | Description
StartPoint | Input/output Double that specifies the start point.
EndPoint | Input/output Double that defines the end point.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Methods > LineSegment2d.GetLineSegmentData Method


LineSegment2d.IntersectWithCurve Method

LineSegment2d.IntersectWithCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns Point2d objects that represent the points at the intersection of the Line2d/LineSegment2d and the input curve. Returns Nothing if the curves overlap or are parallel.

Visual Basic
Sub IntersectWithCurve(Curve As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Curve | Input object. This can be a Line2d, LineSegment2d, Arc2d, EllipticalArc2d, Circle2d, EllipseFull2d, or a BSplineCurve2d.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Methods > LineSegment2d.IntersectWithCurve Method


LineSegment2d.PutLineSegmentData Method

LineSegment2d.PutLineSegmentData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the data defining this line segment.

Visual Basic
Sub PutLineSegmentData(ByRef StartPoint As SAFEARRAY(double), ByRef EndPoint As SAFEARRAY(double))
Parameters
Parameters | Description
StartPoint | Input/output Double that specifies the start point.
EndPoint | Input/output Double that defines the end point.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Methods > LineSegment2d.PutLineSegmentData Method


LineSegment2d Properties

LineSegment2d Properties
Summary

The properties of the LineSegment2d class are listed here.

Properties
Name | Description
Direction | Gets the direction of the line segment.
EndPoint | Specifies the end point of the line.
Evaluator | Gets the Curve2dEvaluator for this line segment.
MidPoint | Gets the mid point of the line segment.
StartPoint | Specifies the start point of the line.
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Properties


LineSegment2d.Direction Property

LineSegment2d.Direction Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the direction of the line segment.

Visual Basic
Property Direction() As UnitVector2d**
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Properties > LineSegment2d.Direction Property


LineSegment2d.EndPoint Property

LineSegment2d.EndPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the end point of the line.

Visual Basic
Property EndPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Properties > LineSegment2d.EndPoint Property


LineSegment2d.Evaluator Property

LineSegment2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the Curve2dEvaluator for this line segment.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Properties > LineSegment2d.Evaluator Property


LineSegment2d.MidPoint Property

LineSegment2d.MidPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the mid point of the line segment.

Visual Basic
Property MidPoint() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Properties > LineSegment2d.MidPoint Property


LineSegment2d.StartPoint Property

LineSegment2d.StartPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Specifies the start point of the line.

Visual Basic
Property StartPoint() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > LineSegment2d Interface > LineSegment2d Properties > LineSegment2d.StartPoint Property


LineStripGraphics Interface

LineStripGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The LineStripGraphics Object. The LineStripGraphics object defines a set of connected lines.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::LineStripGraphics
Visual Basic
Public Interface LineStripGraphics
Inherits GraphicsPrimitive
Remarks

The first coordinate defines the start of the first line; the second coordinate defines the end of the first line and the start of the second, and so on. The description below shows two methods of defining line strips to draw the box with an X as shown in the figure. The unique vertices are numbered. One uses only a coordinate set and the other also uses an index set to make more efficient use of the coordinates.

Coordinate set

(0,0,0), (1,0,0), (1,1,0), (0,1,0), (0,0,0), (0,0,0), (1,1,0), (1,0,0), (0,1,0)

The coordinates listed in the set above define three line strips. The first five coordinates define the outer square. The next two define one diagonal line and the last two define the other diagonal line. The length of each strip is defined by setting the strip lengths using the array below, which indicates how many coordinates are used for each strip.

Strip Lengths

5, 2, 2

The coordinate set shown below can also be used to define the same set of line strips, but in this case an index set is used in conjunction with the coordinates.

Coordinate set

(0,0,0), (1,0,0), (1,1,0), (0,1,0)

Index set

1 1, 2, 3, 4, 1, 1, 3, 2, 4

Strip Lengths

5, 2, 2

This case uses an index set to define the points for the line strips. When an index set is used it is used to look up the coordinates in the coordinate set. With an index set, the coordinates can be reused. In this example, the four unique points are defined in the coordinate set. The indices in the index set define the vertices of the line strip by referencing a coordinate from the coordinate set.

In many cases, use of an index set is much more efficient, particularly when you consider that other graphic primitives can share coordinate sets. For example, you may have a list of coordinates that defines all of the vertices of a triangle mesh. It is much more efficient to define each of these vertices once and then reference them using an index set to build the triangles. The same set of coordinates can also be used to draw line sets or linestrip sets along the boundaries.

Notes

Members through which this object may be accessed include:

GraphicsNode.AddLineStripGraphics

See Also

Client Graphics - Line sample

You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface


LineStripGraphics Methods

LineStripGraphics Methods
Summary

The methods of the LineStripGraphics class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
GetStripLengths | Method that returns the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.
GetTransformBehavior | Returns the current view transformation settings (e.g. pixel scaling and front facing).
PutStripLengths | Method that sets the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.
SetCustomLineType |
SetTransformBehavior | Sets the view transformation settings (e.g. pixel scaling and front facing).
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods


LineStripGraphics.GetCustomLineType Method

LineStripGraphics.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods > LineStripGraphics.GetCustomLineType Method


LineStripGraphics.GetStripLengths Method

LineStripGraphics.GetStripLengths Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.

Visual Basic
Sub GetStripLengths(ByRef StripLengths As SAFEARRAY(long))
Parameters
Parameters | Description
StripLengths | Array of Longs that defines the strip lengths. The length of a strip is defined by specifying the number of coordinates used for each strip.
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods > LineStripGraphics.GetStripLengths Method


LineStripGraphics.GetTransformBehavior Method

LineStripGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the current view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point that returns the point that is unaffected by the transform behavior.
BehaviorType | Output DisplayTransformBehaviorEnum that returns the transform behaviors currently being used.
PixelScale | Output Double that returns the number of pixels that are used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods > LineStripGraphics.GetTransformBehavior Method


LineStripGraphics.PutStripLengths Method

LineStripGraphics.PutStripLengths Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.

Visual Basic
Sub PutStripLengths(ByRef StripLengths As SAFEARRAY(long))
Parameters
Parameters | Description
StripLengths | Array of Longs that defines the strip lengths. The length of a strip is defined by specifying the number of coordinates used for each strip.
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods > LineStripGraphics.PutStripLengths Method


LineStripGraphics.SetCustomLineType Method

LineStripGraphics.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods > LineStripGraphics.SetCustomLineType Method


LineStripGraphics.SetTransformBehavior Method

LineStripGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Sets the view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input that indicates which point is unaffected by the transform behavior.
BehaviorType | Input DisplayTransformBehaviorEnum that specifies which transform behaviors are to be used.
PixelScale | Input Double that indicates how many pixels should be used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Methods > LineStripGraphics.SetTransformBehavior Method


LineStripGraphics Properties

LineStripGraphics Properties
Summary

The properties of the LineStripGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
ColorBinding | Property that gets and sets how the colors are defined for the line.
ColorIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to an index set.
ColorSet | Property that gets and sets the GraphicsColorSet associated with the set.
CoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the lines of the set.
CoordinateSet | Property that gets and sets the GraphicsCoordinateSet associated with the set.
DepthPriority | Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type associated with the primitive.
LineWeight | Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties


LineStripGraphics.BurnThrough Property

LineStripGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.BurnThrough Property


LineStripGraphics.ColorBinding Property

LineStripGraphics.ColorBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the colors are defined for the line.

Visual Basic
Property ColorBinding() As ColorBindingEnum
Remarks

If an index set is defined, then the order of colors is defined by the index set. If an index is not defined, then the order of the colors in the color set is used. The options are:

  • kOverallColor:The first color in the set is used for the entire line set.
  • kPerItemColors :The first color in the set is used for the first line, the second color for the second line, and so on. If there are more lines than colors, the last color in the set is used for the remaining lines. If there are more colors than lines, the additional colors are ignored.
  • kPerStripColors:The first color in the set is used for the first strip, the second color for the second strip, and so on. If there are more strips than colors, the last color in the set is used for the remaining strips. If there are more colors than strips, the additional colors are ignored.
  • kPerVertexColors: The first color in the set is used for the first vertex (start of the first line), the second color is used for the second vertex (end of the first line), the third color is used for the third vertex (start of the second line) and so on. Since a different color can be defined for each vertex the color blends along the line from one color to the other. If there are more vertices than colors, the last color in the set is used for the remaining vertices. If there are more colors than vertices, the additional colors are ignored.
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.ColorBinding Property


LineStripGraphics.ColorIndexSet Property

LineStripGraphics.ColorIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property ColorIndexSet() As GraphicsIndexSet*
Remarks

An index set for colors serves as a color lookup mechanism into the color set. When colors are assigned to the object the order defined by the index set is used instead of the ordering within the color set.

You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.ColorIndexSet Property


LineStripGraphics.ColorSet Property

LineStripGraphics.ColorSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsColorSet associated with the set.

Visual Basic
Property ColorSet() As GraphicsColorSet*
Remarks

If no color set is set for the line set, the render style color defined for the GraphicsNode will be used. If a color set is defined, it overrides the diffuse and ambient colors defined in the render style of the GraphicsNode. This property can be set to Nothing to remove the reference to a color set and return to using the colors defined by the display style of the GraphicsNode.

See Also

InteractionGraphics sample

Client Graphics - Line sample

You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.ColorSet Property


LineStripGraphics.CoordinateIndexSet Property

LineStripGraphics.CoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the lines of the set.

Visual Basic
Property CoordinateIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.CoordinateIndexSet Property


LineStripGraphics.CoordinateSet Property

LineStripGraphics.CoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsCoordinateSet associated with the set.

Visual Basic
Property CoordinateSet() As GraphicsCoordinateSet*
See Also

InteractionGraphics sample

You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.CoordinateSet Property


LineStripGraphics.DepthPriority Property

LineStripGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.DepthPriority Property


LineStripGraphics.LineDefinitionSpace Property

LineStripGraphics.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.LineDefinitionSpace Property


LineStripGraphics.LineScale Property

LineStripGraphics.LineScale Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.LineScale Property


LineStripGraphics.LineType Property

LineStripGraphics.LineType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the line type associated with the primitive.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.LineType Property


LineStripGraphics.LineWeight Property

LineStripGraphics.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > LineStripGraphics Interface > LineStripGraphics Properties > LineStripGraphics.LineWeight Property


LineWorkAxisDef Interface

LineWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work axis along a line.

Class Hierarchy
Inventor::LineWorkAxisDef
Visual Basic
Public Interface LineWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > LineWorkAxisDef Interface


LineWorkAxisDef Properties

LineWorkAxisDef Properties
Summary

The properties of the LineWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Line | Property that returns the line of a line defined work axis. This object can be a linear Edge, WorkAxis, or SketchLine object.
Parent | Property returning the parent WorkAxis object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LineWorkAxisDef Interface > LineWorkAxisDef Properties


LineWorkAxisDef.Application Property

LineWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineWorkAxisDef Interface > LineWorkAxisDef Properties > LineWorkAxisDef.Application Property


LineWorkAxisDef.Line Property

LineWorkAxisDef.Line Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the line of a line defined work axis. This object can be a linear Edge, WorkAxis, or SketchLine object.

Visual Basic
Property Line() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LineWorkAxisDef Interface > LineWorkAxisDef Properties > LineWorkAxisDef.Line Property


LineWorkAxisDef.Parent Property

LineWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > LineWorkAxisDef Interface > LineWorkAxisDef Properties > LineWorkAxisDef.Parent Property


LineWorkAxisDef.Type Property

LineWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LineWorkAxisDef Interface > LineWorkAxisDef Properties > LineWorkAxisDef.Type Property


LipFeature Interface

LipFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The LipFeature object represents a lip feature within the model.

Class Hierarchy
Inventor::PartFeature
    Inventor::LipFeature
        Inventor::LipFeatureProxy
Visual Basic
Public Interface LipFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

LipFeatureProxy.NativeObject

LipFeatures.Item

Most functionality reserved for future implementation.

You are here: Symbol Reference > Inventor Library > Objects > LipFeature Interface


LipFeatureProxy Interface

LipFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LipFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::LipFeature
        Inventor::LipFeatureProxy
Visual Basic
Public Interface LipFeatureProxy
Inherits LipFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > LipFeatureProxy Interface


LipFeatureProxy Properties

LipFeatureProxy Properties
Summary

The properties of the LipFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > LipFeatureProxy Interface > LipFeatureProxy Properties


LipFeatureProxy.ContainingOccurrence Property

LipFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LipFeatureProxy Interface > LipFeatureProxy Properties > LipFeatureProxy.ContainingOccurrence Property


LipFeatureProxy.NativeObject Property

LipFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As LipFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LipFeatureProxy Interface > LipFeatureProxy Properties > LipFeatureProxy.NativeObject Property


LipFeatures Interface

LipFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The LipFeatures collection object provides access to existing Lip features.

Class Hierarchy
Inventor::LipFeatures
Visual Basic
Public Interface LipFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.LipFeatures

You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface


LipFeatures Methods

LipFeatures Methods
Summary

The methods of the LipFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface > LipFeatures Methods


LipFeatures.Item Method

LipFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] LipFeature*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface > LipFeatures Methods > LipFeatures.Item Method


LipFeatures Properties

LipFeatures Properties
Summary

The properties of the LipFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface > LipFeatures Properties


LipFeatures.Application Property

LipFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface > LipFeatures Properties > LipFeatures.Application Property


LipFeatures.Count Property

LipFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface > LipFeatures Properties > LipFeatures.Count Property


LipFeatures.Type Property

LipFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LipFeatures Interface > LipFeatures Properties > LipFeatures.Type Property


LoftDefinition Interface

LoftDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The LoftDefinition object is used to define additional input required for creating loft features.

Class Hierarchy
Inventor::LoftDefinition
Visual Basic
Public Interface LoftDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LoftDefinition.Copy

LoftFeature.Definition

LoftFeatures.CreateLoftDefinition

See Also

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface


LoftDefinition Methods

LoftDefinition Methods
Summary

The methods of the LoftDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates and returns a copy of this loft definition.
You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Methods


LoftDefinition.Copy Method

LoftDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates and returns a copy of this loft definition.

Visual Basic
Sub Copy(Result As [out, retval] LoftDefinition*)
Remarks

If this loft definition is being currently used by a loft feature, then this method will return a copy of the LoftDefinition object used by that loft feature. The loft feature will not be affected if the definition returned by this property is modified. To update the loft feature to use the modified definition, you need to set the Definition property of the LoftFeature object to the LoftDefinition object that corresponds to this modified definition.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Methods > LoftDefinition.Copy Method


LoftDefinition Properties

LoftDefinition Properties
Summary

The properties of the LoftDefinition class are listed here.

Properties
Name | Description
Centerline | Property that specifies the centerline for the loft. Valid objects for the centerline are Profile, Profile3D, EdgeLoop and EdgeCollection objects.
Closed | Property that specifies whether the loft needs to be closed or not. A value of True indicates the loft is to be closed. The default value for this property is False.
FirstSectionAngle | Property that specifies the angle of the loft in relation to the sketch plane of the starting section.
FirstSectionCondition | Property that specifies the condition of the loft at the starting section. Valid values are kFreeLoftCondition, kTangentLoftCondition, kDirectionLoftCondition, kSmoothLoftCondition, kSharpPointLoftCondition or kTangentToPlaneLoftCondition. The default value for this property is kFreeLoftCondition.
FirstSectionDirectionReversed | Property that specifies whether the takeoff direction for the starting section should be reversed from its default direction. A value of True indicates that the takeoff direction should be reversed. The default value for this property is False.
FirstSectionImpact | Property that specifies the impact the starting section's condition has on the shape of the entire loft.
FirstSectionTangentPlane | Property that specifies the tangent plane for the starting section in the case that the section is a point. Valid objects for the tangent plane are WorkPlane and planar Face objects.
LastSectionAngle | Property that specifies the angle of the loft in relation to the sketch plane of the ending section.
LastSectionCondition | Property that specifies the condition of the loft at the ending section. Valid values are kFreeLoftCondition, kTangentLoftCondition, kDirectionLoftCondition, kSmoothLoftCondition, kSharpPointLoftCondition or kTangentToPlaneLoftCondition. The default value for this property is kFreeLoftCondition.
LastSectionDirectionReversed | Property that specifies whether the takeoff direction for the ending section should be reversed from its default direction. A value of True indicates that the takeoff direction should be reversed. The default value for this property is False.
LastSectionImpact | Property that specifies the impact the ending section's condition has on the shape of the entire loft.
LastSectionTangentPlane | Property that specifies the tangent plane for the ending section in the case that the section is a point. Valid objects for the tangent plane are WorkPlane and planar Face objects.
LoftRails | Property that specifies the rails for the loft.
LoftSectionDimensions | Property that specifies the placed section dimensions for an area-graph type loft.
LoftType | Property that gets the type of loft feature.
MapPointCurves | Property that specifies the mapping to use between sections.
MergeTangentFaces | Property that specifies if the tangent faces of the loft should be merged or not. A value of True indicates that the tangent faces should be merged. The default value for this property is False.
Operation | Property that specifies the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
Sections | Property that specifies the sections used for a loft. Valid objects for sections are Profile, Profile3D, EdgeLoop, EdgeCollection, SketchPoint, SketchPoint3D, WorkPoint and Vertex objects.
You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties


LoftDefinition.Centerline Property

LoftDefinition.Centerline Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the centerline for the loft. Valid objects for the centerline are Profile, Profile3D, EdgeLoop and EdgeCollection objects.

Visual Basic
Property Centerline() As IDispatch*
Remarks

Specifying a centerline using this property is valid only in the following cases:

  • Rails have not been currently specified using the Rails property (since a loft can be defined using either rails or a centerline but not both). If rails have been specified using the Rails property, then setting a centerline using this property will fail. A centerline can be specified only after all the rails returned by the Rails property are deleted. Similarly, if a centerline has been currently specified using this property, then rails cannot be specified using the Rails property. The rails can be specified only after this property is set to Nothing.
  • Placed section dimensions have not been currently specified using the LoftSectionDimensions property (since the placed section dimensions are dependent on the centerline). If placed section dimensions have been specified using the LoftSectionDimensions property, then setting a centerline using this property will fail. A centerline can be specified only after all the placed section dimensions returned by the LoftSectionDimensions property are deleted. Similarly, the placed section dimensions can be specified using the LoftSectionDimensions property only after this property is set to a valid centerline.

If a centerline is successfully specified using this property, the LoftType property will be automatically set to kLoftWithCenterline.

Also, if this property is queried from a loft definition object of an existing loft feature, it will return a valid centerline object only if the loft is currently specified to use a centerline as indicated by the LoftType property returning kLoftWithCenterline or kLoftWithAreaGraphSections. In this case, this property can be set to Nothing to specify the loft to be a regular loft as a result of which, the LoftType property will be automatically set to kRegularLoft. If the loft is not specified to use a centerline as indicated by the LoftType property returning kRegularLoft or kLoftWithRails, then this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.Centerline Property


LoftDefinition.Closed Property

LoftDefinition.Closed Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether the loft needs to be closed or not. A value of True indicates the loft is to be closed. The default value for this property is False.

Visual Basic
Property Closed() As VARIANT_BOOL
Remarks

This property is only valid in the case where no rails are specified using the Rails property. If rails are specified, then the rails define if the loft is closed or not, hence specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature. If rails are not specified and a value for this property has not been explicitly specified, then the default value of False will be used.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.Closed Property


LoftDefinition.FirstSectionAngle Property

LoftDefinition.FirstSectionAngle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the angle of the loft in relation to the sketch plane of the starting section.

Visual Basic
Property FirstSectionAngle() As VARIANT
Remarks

When the loft definition corresponds to a transient definition object, i.e. it has been newly created using the CreateLoftDefinition method of the LoftFeatures object or has been copied using the Copy method of the LoftDefinition object, then the value that can be specified for this property can be either a numeric value or a string. If a value is specified, the units are radians. If a string is specified, the units can be specified as part of the string or it will default to the current angle units of the document. If no value is specified, then a default value of ?/2 (90 degrees) will be assumed. After the loft feature is successfully created, a parameter for this value will be created and the supplied string or value will be assigned to the parameter.

When the loft definition is obtained from an existing loft feature, then this property will return a read-only Parameter object. The properties of the Parameter object can then be used to specify a new value, if needed.

This property is valid if the starting section is a 2D profile and the FirstSectionCondition property is specified to be kDirectionLoftCondition. If this condition is not satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.FirstSectionAngle Property


LoftDefinition.FirstSectionCondition Property

LoftDefinition.FirstSectionCondition Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the condition of the loft at the starting section. Valid values are kFreeLoftCondition, kTangentLoftCondition, kDirectionLoftCondition, kSmoothLoftCondition, kSharpPointLoftCondition or kTangentToPlaneLoftCondition. The default value for this property is kFreeLoftCondition.

Visual Basic
Property FirstSectionCondition() As LoftConditionEnum
Remarks

The valid values that can be specified for this property vary depending on the type of entity used for the starting section.

If the section is a Profile, then the valid values for this property are kFreeLoftCondition, kDirectionLoftCondition and additionally, if the Profile is adjacent to a lateral surface or body then the values kTangentLoftCondition or kSmoothLoftCondition are also applicable.

If the section is a Profile3D, then the valid value for this property is kFreeLoftCondition.

If the section is an EdgeLoop or EdgeCollection, then the valid values for this property are kFreeLoftCondition, kTangentLoftCondition or kSmoothLoftCondition.

If the section is a SketchPoint, SketchPoint3D, WorkPoint or Vertex, then the valid values for this property are kSharpPointLoftCondition, kTangentLoftCondition or kTangentToPlaneLoftCondition.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.FirstSectionCondition Property


LoftDefinition.FirstSectionDirectionReversed Property

LoftDefinition.FirstSectionDirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether the takeoff direction for the starting section should be reversed from its default direction. A value of True indicates that the takeoff direction should be reversed. The default value for this property is False.

Visual Basic
Property FirstSectionDirectionReversed() As VARIANT_BOOL
Remarks

This property is only valid in the following cases:

  • The starting section is a Profile that is adjacent to a lateral surface or body and the FirstSectionCondition property is specified to be either kTangentLoftCondition or kSmoothLoftCondition or
  • The starting section is an EdgeLoop or EdgeCollection and the FirstSectionCondition property is specified to be either kTangentLoftCondition or kSmoothLoftCondition.

If none of the above conditions are satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature. If any one of the above conditions is satisfied and a value for this property has not been explicitly specified, then the default value of False will be used.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.FirstSectionDirectionReversed Property


LoftDefinition.FirstSectionImpact Property

LoftDefinition.FirstSectionImpact Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the impact the starting section's condition has on the shape of the entire loft.

Visual Basic
Property FirstSectionImpact() As VARIANT
Remarks

When the loft definition corresponds to a transient definition object, i.e. it has been newly created using the CreateLoftDefinition method of the LoftFeatures object or has been copied using the Copy method of the LoftDefinition object, then the value that can be specified for this property can be either a numeric value or a string. If a value is specified, it is assumed to be unitless. If a string is specified, it must resolve to a unitless value. If no value is specified, then a default value of 0 will be assumed. After the loft feature is successfully created, a parameter for this value will be created and the supplied string or value will be assigned to the parameter.

When the loft definition is obtained from an existing loft feature, then this property will return a read-only Parameter object. The properties of the Parameter object can then be used to specify a new value, if needed.

This property is only valid in the following cases:

  • The starting section is a 2D profile and the FirstSectionCondition property is specified to be kDirectionLoftCondition or
  • The starting section is one of the following: 2D profile, point, edge or a collection of edges that are end-to-end connected and the FirstSectionCondition property is specified to be kTangentLoftCondition or
  • The starting section is a point and the FirstSectionCondition property is specified to be kTangentToPlaneLoftCondition or
  • The starting section is one of the following: 2D profile, edge or a collection of edges that are end-to-end connected and the FirstSectionCondition property is specified to be kSmoothLoftCondition.

If none of the above conditions are satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.FirstSectionImpact Property


LoftDefinition.FirstSectionTangentPlane Property

LoftDefinition.FirstSectionTangentPlane Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the tangent plane for the starting section in the case that the section is a point. Valid objects for the tangent plane are WorkPlane and planar Face objects.

Visual Basic
Property FirstSectionTangentPlane() As IDispatch*
Remarks

This property is valid only if this condition is satisfied: the starting section is a point and the FirstSectionCondition property can be specified to be kTangentToPlaneLoftCondition. If this condition is satisfied and a valid value is specified for this property, then the FirstSectionCondition will be automatically set to kTangentToPlaneLoftCondition. If this condition is not satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.FirstSectionTangentPlane Property


LoftDefinition.LastSectionAngle Property

LoftDefinition.LastSectionAngle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the angle of the loft in relation to the sketch plane of the ending section.

Visual Basic
Property LastSectionAngle() As VARIANT
Remarks

When the loft definition corresponds to a transient definition object, i.e. it has been newly created using the CreateLoftDefinition method of the LoftFeatures object or has been copied using the Copy method of the LoftDefinition object, then the value that can be specified for this property can be either a numeric value or a string. If a value is specified, the units are radians. If a string is specified, the units can be specified as part of the string or it will default to the current angle units of the document. If no value is specified, then a default value of ?/2 (90 degrees) will be assumed. After the loft feature is successfully created, a parameter for this value will be created and the supplied string or value will be assigned to the parameter.

When the loft definition is obtained from an existing loft feature, then this property will return a read-only Parameter object. The properties of the Parameter object can then be used to specify a new value, if needed.

This property is valid if the ending section is a 2D profile and the LastSectionCondition property is specified to be kDirectionLoftCondition. If this condition is not satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LastSectionAngle Property


LoftDefinition.LastSectionCondition Property

LoftDefinition.LastSectionCondition Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the condition of the loft at the ending section. Valid values are kFreeLoftCondition, kTangentLoftCondition, kDirectionLoftCondition, kSmoothLoftCondition, kSharpPointLoftCondition or kTangentToPlaneLoftCondition. The default value for this property is kFreeLoftCondition.

Visual Basic
Property LastSectionCondition() As LoftConditionEnum
Remarks

The valid values that can be specified for this property vary depending on the type of entity used for the ending section.

If the section is a Profile, then the valid values for this property are kFreeLoftCondition, kDirectionLoftCondition and additionally, if the Profile is adjacent to a lateral surface or body then the values kTangentLoftCondition or kSmoothLoftCondition are also applicable.

If the section is a Profile3D, then the valid value for this property is kFreeLoftCondition.

If the section is an EdgeLoop or EdgeCollection, then the valid values for this property are kFreeLoftCondition, kTangentLoftCondition or kSmoothLoftCondition.

If the section is a SketchPoint, SketchPoint3D, WorkPoint or Vertex, then the valid values for this property are kSharpPointLoftCondition, kTangentLoftCondition or kTangentToPlaneLoftCondition.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LastSectionCondition Property


LoftDefinition.LastSectionDirectionReversed Property

LoftDefinition.LastSectionDirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether the takeoff direction for the ending section should be reversed from its default direction. A value of True indicates that the takeoff direction should be reversed. The default value for this property is False.

Visual Basic
Property LastSectionDirectionReversed() As VARIANT_BOOL
Remarks

This property is only valid in the following cases:

  • The ending section is a Profile that is adjacent to a lateral surface or body and the LastSectionCondition property is specified to be either kTangentLoftCondition or kSmoothLoftCondition or
  • The ending section is an EdgeLoop or EdgeCollection and the LastSectionCondition property is specified to be either kTangentLoftCondition or kSmoothLoftCondition.

If none of the above conditions are satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature. If any one of the above conditions is satisfied and a value for this property has not been explicitly specified, then the default value of False will be used.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LastSectionDirectionReversed Property


LoftDefinition.LastSectionImpact Property

LoftDefinition.LastSectionImpact Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the impact the ending section's condition has on the shape of the entire loft.

Visual Basic
Property LastSectionImpact() As VARIANT
Remarks

When the loft definition corresponds to a transient definition object, i.e. it has been newly created using the CreateLoftDefinition method of the LoftFeatures object or has been copied using the Copy method of the LoftDefinition object, then the value that can be specified for this property can be either a numeric value or a string. If a value is specified, it is assumed to be unitless. If a string is specified, it must resolve to a unitless value. If no value is specified, then a default value of 0 will be assumed. After the loft feature is successfully created, a parameter for this value will be created and the supplied string or value will be assigned to the parameter.

When the loft definition is obtained from an existing loft feature, then this property will return a read-only Parameter object. The properties of the Parameter object can then be used to specify a new value, if needed.

This property is only valid in the following cases:

  • The ending section is a 2D profile and the LastSectionCondition property is specified to be kDirectionLoftCondition or
  • The ending section is one of the following: 2D profile, point, edge or a collection of edges that are end-to-end connected and the LastSectionCondition property is specified to be kTangentLoftCondition or
  • The ending section is a point and the LastSectionCondition property is specified to be kTangentToPlaneLoftCondition or
  • The ending section is one of the following: 2D profile, edge or a collection of edges that are end-to-end connected and the LastSectionCondition property is specified to be kSmoothLoftCondition.

If none of the above conditions are satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LastSectionImpact Property


LoftDefinition.LastSectionTangentPlane Property

LoftDefinition.LastSectionTangentPlane Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the tangent plane for the ending section in the case that the section is a point. Valid objects for the tangent plane are WorkPlane and planar Face objects.

Visual Basic
Property LastSectionTangentPlane() As IDispatch*
Remarks

This property is valid only if this condition is satisfied: the ending section is a point and the LastSectionCondition property can be specified to be kTangentToPlaneLoftCondition. If this condition is satisfied and a valid value is specified for this property, then the LastSectionCondition will be automatically set to kTangentToPlaneLoftCondition. If this condition is not satisfied, then specifying a value for this property will result in a failure and also this property will be ignored during the creation of the loft feature.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LastSectionTangentPlane Property


LoftDefinition.LoftRails Property

LoftDefinition.LoftRails Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the rails for the loft.

Visual Basic
Property LoftRails() As LoftRails**
Remarks

This property returns a LoftRails collection object that specifies the rails for the loft. The collection will be initially empty, but the Add method can be used to add rails for the loft. The order of the rails within the collection defines the fit order of the loft through the rails. The rails must all intersect the sections specified for the loft. The rails must be either all open or all closed, you cannot mix open and closed rails. Specifying rails using this property is valid only in the following case:

  • A centerline has not been currently specified using the Centerline property (since a loft can be defined using either rails or a centerline but not both). If a centerline has been specified using the Centerline property, then specifying rails using this property will fail. The rails can be specified only after the Centerline property is set to Nothing. Similarly, if rails have been currently specified using this property, then a centerline cannot be specified using the Centerline property. The centerline can be specified only after all the rails returned by this property are deleted.

If rails are successfully specified using this property, the LoftType property will be automatically set to kLoftWithRails.

Also, if this property is queried from a loft definition object of an existing loft feature, it will return the rails used by the loft only if the loft is currently specified to use rails as indicated by the LoftType property returning kLoftWithRails. In this case, all the rails returned by this property can be deleted to specify the loft to be a regular loft as a result of which, the LoftType property will be automatically set to kRegularLoft. If the loft is not specified to use rails as indicated by the LoftType property returning kRegularLoft or kLoftWithCenterline or kLoftWithAreaGraphSections, then this property will return an empty collection.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LoftRails Property


LoftDefinition.LoftSectionDimensions Property

LoftDefinition.LoftSectionDimensions Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the placed section dimensions for an area-graph type loft.

Visual Basic
Property LoftSectionDimensions() As LoftSectionDimensions**
Remarks

This property returns a LoftSectionDimensions collection object that specifies the placed section dimensions for an area-graph type loft. Specifying placed section dimensions using this property is valid only in the following case:

  • A centerline has been currently specified using the Centerline property (since the placed section dimensions are dependent on the centerline). If a centerline has not been specified using the Centerline property, then specifying placed section dimensions using this property will fail. Similarly, if placed section dimensions have been currently specified using this property, then a centerline cannot be specified using the Centerline property. The centerline can be specified only after all the placed section dimensions returned by this property are deleted.

If placed section dimensions are successfully specified using this property, the LoftType property will be automatically set to kLoftWithAreaGraphSections.

If this property is queried from a loft definition object of an existing loft feature, it will return the section dimensions used by the area-graph type loft only if the loft is currently specified to use section dimensions as indicated by the LoftType property returning kLoftWithAreaGraphSections. If the loft is not specified to use section dimensions as indicated by the LoftType property returning kRegularLoft or kLoftWithCenterline or kLoftWithRails, then this property will return an empty collection.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LoftSectionDimensions Property


LoftDefinition.LoftType Property

LoftDefinition.LoftType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets the type of loft feature.

Visual Basic
Property LoftType() As LoftTypeEnum*
Remarks

Valid values are kRegularLoft, kLoftWithRails, kLoftWithCenterline and kLoftWithAreaGraphSections. If kRegularLoft is returned, then the loft is defined using neither rails, centerline nor area-graph sections. If kLoftWithRails is returned, then the loft is defined using rails. If kLoftWithCenterline is returned, then the loft is defined using only a centerline. If kLoftWithAreaGraphSections is returned, then the loft is defined using a centerline and area-graph sections.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.LoftType Property


LoftDefinition.MapPointCurves Property

LoftDefinition.MapPointCurves Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the mapping to use between sections.

Visual Basic
Property MapPointCurves() As MapPointCurves*
Remarks

This property returns a MapPointCurves collection object that specifies the mapping points for the loft. The collection will be initially empty, but the AddMapCurve method can be used to add mapping points for the loft.

If no mapping points are specified in the collection, i.e. if the collection is empty, then Inventor will perform automatic mapping to best minimize twisting. If mapping points are specified in the collection, then all the points corresponding to each map curve must be specified.

If the MapPointCurves object is currently being used by a loft feature, i.e. if the parent LoftDefinition object is queried from a loft feature, then this property will return a copy of the MapPointCurves object used by that loft feature. The loft feature will not be affected if the mapping points contained in the MapPointCurves object returned by this property are modified. To update the loft feature to use the modified mapping points, you need to set this property to the MapPointCurves object that contains the modified mapping points.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.MapPointCurves Property


LoftDefinition.MergeTangentFaces Property

LoftDefinition.MergeTangentFaces Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies if the tangent faces of the loft should be merged or not. A value of True indicates that the tangent faces should be merged. The default value for this property is False.

Visual Basic
Property MergeTangentFaces() As VARIANT_BOOL
Remarks

If a centerline has been currently specified using the Centerline property, then this property should be True. If a centerline has been currently specified, then specifying False for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.MergeTangentFaces Property


LoftDefinition.Operation Property

LoftDefinition.Operation Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.Operation Property


LoftDefinition.Sections Property

LoftDefinition.Sections Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the sections used for a loft. Valid objects for sections are Profile, Profile3D, EdgeLoop, EdgeCollection, SketchPoint, SketchPoint3D, WorkPoint and Vertex objects.

Visual Basic
Property Sections() As ObjectCollection*
Remarks

If a point (SketchPoint, SketchPoint3D, WorkPoint or Vertex object) is used, it must be either the first section or the last section and there must be at least one other intermediate section which is not a point. If an EdgeCollection object is used it may contain either a single edge or a set of tangentially connected edges. The order of the sections within the ObjectCollection defines the fit order of the loft through the sections. The sections must be either all open or all closed; you cannot mix open and closed sections.

You are here: Symbol Reference > Inventor Library > Objects > LoftDefinition Interface > LoftDefinition Properties > LoftDefinition.Sections Property


LoftedFlangeDefinition Interface

LoftedFlangeDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The LoftedFlangeDefinition object represents all of the information that defines a lofted flange feature. The LoftedFlangeDefinition object is used in two ways. First it is used as input when creating a lofted flange feature. Second it is used to query and edit existing lofted flange features.

Class Hierarchy
Inventor::LoftedFlangeDefinition
Visual Basic
Public Interface LoftedFlangeDefinition
Inherits IDispatch
Remarks

When creating a new lofted flange feature you use the LoftedFlangeFeatures.CreateLoftedFlangeDefinition method to create a new LoftedFlangeDefinition object. Using the properties of this object you can define the various options of the lofted flange feature. An existing LoftedFlangeFeature object is edited by modifying the LoftedFlangeDefinition object associated with it.

Notes

Members through which this object may be accessed include:

LoftedFlangeDefinition.Copy

LoftedFlangeFeature.Definition

LoftedFlangeFeatures.CreateLoftedFlangeDefinition

See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface


LoftedFlangeDefinition Methods

LoftedFlangeDefinition Methods
Summary

The methods of the LoftedFlangeDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this LoftedFlangeDefinition object. The new LoftedFlangeDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new lofted flange feature.
SetOutputType | Method that sets the technique that will be used to calculate the lofted flange.
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Methods


LoftedFlangeDefinition.Copy Method

LoftedFlangeDefinition.Copy Method Introduced in Inventor 2011
Summary

Method that creates a copy of this LoftedFlangeDefinition object. The new LoftedFlangeDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new lofted flange feature.

Visual Basic
Sub Copy(Result As [out, retval] LoftedFlangeDefinition*)
Remarks

Any of the properties of the LoftedFlangeDefinition that can reference a Parameter object will behave differently depending on if the LoftedFlangeDefinition is independent or associated with a feature. When it is associated with a feature these properties behave as read-only and will return the related Parameter object. When it is not associated with a feature these properties behave as read-write and will accept and return doubles and strings to define the value.

One typical use of this method is when you need to make several changes to an existing lofted flange feature. If you edit the LoftedFlangeDefinition object associated with the lofted flange feature, the feature will recompute after each edit. It's more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The LoftedFlangeFeatures.CreateLoftedFlangeDefinition method can also be used to create an independent LoftedFlangeDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateLoftedFlangeDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Methods > LoftedFlangeDefinition.Copy Method


LoftedFlangeDefinition.SetOutputType Method

LoftedFlangeDefinition.SetOutputType Method Introduced in Inventor 2011
Summary

Method that sets the technique that will be used to calculate the lofted flange.

Visual Basic
Sub SetOutputType(OutputType As LoftedFlangeOutputTypeEnum, ByRef FacetTolerance As [optional] VARIANT)
Parameters
Parameters | Description
OutputType | Constant that defines the how the lofted flange will be calculated. Valid values are kDieFormedLoftedFlange, kPressBrakeChordToleranceLoftedFlange, kPressBrakeFacetAngleLoftedFlange, and kPressBrakeFacetDistanceLoftedFlange.
FacetTolerance | Optional Variant that defines the tolerance value used when calculating the lofted flange. This only applies to the press brake methods and is ignored if the OutputType argument is kDieFormedLoftedFlange. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input and the output type is kPressBrakeChordToleranceLoftedFlange or kPressBrakeFacetDistanceLoftedFlange, the units are centimeters. If the output type is kPressBrakeFacetAngleLoftedFlange, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current length or angle units of the document.
See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Methods > LoftedFlangeDefinition.SetOutputType Method


LoftedFlangeDefinition Properties

LoftedFlangeDefinition Properties
Summary

The properties of the LoftedFlangeDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BendRadius | Property that provides access to the bend radius of a lofted flange feature. This property is writable when the LoftedFlangeDefinition object has been created using the LoftedFlangeFeatures.CreateLoftedFlangeDefinition or LoftedFlangeDefinition.Copy method.
Converge | Property that defines whether the corner of the lofted flange should converge. This property should be ignored when the OutputType property returns kDieFormedLoftedFlange.
ExtentDirection | Property that gets and set the which side of the sketch entities is the direction for the material to be added. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection.
FacetTolerance | Property that returns the parameter controlling the tolerance used to calculate the lofted flange. This will return Nothing in the case where the OutputType property returns kDieFormedLoftedFlange and where the LoftedFlangeDefinition object is not associated with an existing lofted flange.
IsUnfoldMethodOverridden | Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.
OutputType | Property that returns the technique being used to calculate the shape of the lofted flange. To set the output type use the SetOutputType method.
Parent | Property that returns the parent LoftedFlangeFeature object.
ProfileOne | Property that gets and sets the first of two profiles defining the lofted flange.
ProfileTwo | Property that gets and sets the second of two profiles defining the lofted flange.
Type | Returns an ObjectTypeEnum indicating this object's type.
UnfoldMethod | Property that gets and set the UnfoldMethod object that defines how the bends associated with this lofted flange feature are unfolded.
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties


LoftedFlangeDefinition.Application Property

LoftedFlangeDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.Application Property


LoftedFlangeDefinition.BendRadius Property

LoftedFlangeDefinition.BendRadius Property Introduced in Inventor 2011
Summary

Property that provides access to the bend radius of a lofted flange feature. This property is writable when the LoftedFlangeDefinition object has been created using the LoftedFlangeFeatures.CreateLoftedFlangeDefinition or LoftedFlangeDefinition.Copy method.

Visual Basic
Property BendRadius() As VARIANT
Remarks

The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string 'MyBendRadius * 2' is valid, assuming there is a parameter named MyBendRadius.

When the LoftedFlangeDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the bend radius. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.BendRadius Property


LoftedFlangeDefinition.Converge Property

LoftedFlangeDefinition.Converge Property Introduced in Inventor 2011
Summary

Property that defines whether the corner of the lofted flange should converge. This property should be ignored when the OutputType property returns kDieFormedLoftedFlange.

Visual Basic
Property Converge() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.Converge Property


LoftedFlangeDefinition.ExtentDirection Property

LoftedFlangeDefinition.ExtentDirection Property Introduced in Inventor 2011
Summary

Property that gets and set the which side of the sketch entities is the direction for the material to be added. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection.

Visual Basic
Property ExtentDirection() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.ExtentDirection Property


LoftedFlangeDefinition.FacetTolerance Property

LoftedFlangeDefinition.FacetTolerance Property Introduced in Inventor 2011
Summary

Property that returns the parameter controlling the tolerance used to calculate the lofted flange. This will return Nothing in the case where the OutputType property returns kDieFormedLoftedFlange and where the LoftedFlangeDefinition object is not associated with an existing lofted flange.

Visual Basic
Property FacetTolerance() As Parameter**
Remarks

When the LoftedFlangeDefinition object is obtained from an existing lofted flange feature you can edit the facet tolerance feature by modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.FacetTolerance Property


LoftedFlangeDefinition.IsUnfoldMethodOverridden Property

LoftedFlangeDefinition.IsUnfoldMethodOverridden Property
Summary

Property that gets and set whether the unfold method has been overridden for this feature. Setting this property to False clears the override. Setting the property to True returns a failure.

Visual Basic
Property IsUnfoldMethodOverridden() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.IsUnfoldMethodOverridden Property


LoftedFlangeDefinition.OutputType Property

LoftedFlangeDefinition.OutputType Property Introduced in Inventor 2011
Summary

Property that returns the technique being used to calculate the shape of the lofted flange. To set the output type use the SetOutputType method.

Visual Basic
Property OutputType() As LoftedFlangeOutputTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.OutputType Property


LoftedFlangeDefinition.Parent Property

LoftedFlangeDefinition.Parent Property
Summary

Property that returns the parent LoftedFlangeFeature object.

Visual Basic
Property Parent() As LoftedFlangeFeature**
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.Parent Property


LoftedFlangeDefinition.ProfileOne Property

LoftedFlangeDefinition.ProfileOne Property Introduced in Inventor 2011
Summary

Property that gets and sets the first of two profiles defining the lofted flange.

Visual Basic
Property ProfileOne() As Path*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.ProfileOne Property


LoftedFlangeDefinition.ProfileTwo Property

LoftedFlangeDefinition.ProfileTwo Property Introduced in Inventor 2011
Summary

Property that gets and sets the second of two profiles defining the lofted flange.

Visual Basic
Property ProfileTwo() As Path*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.ProfileTwo Property


LoftedFlangeDefinition.Type Property

LoftedFlangeDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.Type Property


LoftedFlangeDefinition.UnfoldMethod Property

LoftedFlangeDefinition.UnfoldMethod Property Introduced in Inventor 2011
Summary

Property that gets and set the UnfoldMethod object that defines how the bends associated with this lofted flange feature are unfolded.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeDefinition Interface > LoftedFlangeDefinition Properties > LoftedFlangeDefinition.UnfoldMethod Property


LoftedFlangeFeature Interface

LoftedFlangeFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The LoftedFlangeFeature object represents a lofted flange sheet metal feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::LoftedFlangeFeature
        Inventor::LoftedFlangeFeatureProxy
Visual Basic
Public Interface LoftedFlangeFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

LoftedFlangeDefinition.Parent

LoftedFlangeFeatures.Add

LoftedFlangeFeatures.Item

See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeature Interface


LoftedFlangeFeature Properties

LoftedFlangeFeature Properties
Summary

The properties of the LoftedFlangeFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the LoftedFlangeDefinition object associated with this lofted flange feature. Modifying the LoftedFlangeDefinition object will edit the associated HemFeature.
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeature Interface > LoftedFlangeFeature Properties


LoftedFlangeFeature.Definition Property

LoftedFlangeFeature.Definition Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the LoftedFlangeDefinition object associated with this lofted flange feature. Modifying the LoftedFlangeDefinition object will edit the associated HemFeature.

Visual Basic
Property Definition() As LoftedFlangeDefinition*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeature Interface > LoftedFlangeFeature Properties > LoftedFlangeFeature.Definition Property


LoftedFlangeFeatureProxy Interface

LoftedFlangeFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LoftedFlangeFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::LoftedFlangeFeature
        Inventor::LoftedFlangeFeatureProxy
Visual Basic
Public Interface LoftedFlangeFeatureProxy
Inherits LoftedFlangeFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatureProxy Interface


LoftedFlangeFeatures Interface

LoftedFlangeFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The LoftedFlangeFeatures collection object provides access to the LoftedFlangeFeature objects.

Class Hierarchy
Inventor::LoftedFlangeFeatures
Visual Basic
Public Interface LoftedFlangeFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.LoftedFlangeFeatures

See Also

Create sheet metal lofted flange feature sample

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface


LoftedFlangeFeatures Methods

LoftedFlangeFeatures Methods
Summary

The methods of the LoftedFlangeFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new lofted flange feature. The newly created LoftedFlangeFeature object is returned.
CreateLoftedFlangeDefinition | Method that creates a new LoftedFlangeDefinition object.
Item | Property that returns the specified LoftedFlangeFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Methods


LoftedFlangeFeatures.Add Method

LoftedFlangeFeatures.Add Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new lofted flange feature. The newly created LoftedFlangeFeature object is returned.

Visual Basic
Sub Add(LoftedFlangeDefinition As LoftedFlangeDefinition, Result As [out, retval] LoftedFlangeFeature*)
Parameters
Parameters | Description
LoftedFlangeDefinition | Object that defines the lofted flange feature you want to create. A LoftedFlangeDefinition object can be created using the CreateLoftedFlangeDefinition method on the LoftedFlangeFeatures object.
Example

Create sheet metal lofted flange feature example.

The following sample demonstrates the creation of a sheet metal lofted flange feature.

Public Sub LoftedFeatureCreation()
    ' Create a new sheet metal document, using the default sheet metal template.
    Dim oSheetMetalDoc As PartDocument
    Set oSheetMetalDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject, , , "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}"))

    ' Set a reference to the component definition.
    Dim oCompDef As SheetMetalComponentDefinition
    Set oCompDef = oSheetMetalDoc.ComponentDefinition

    ' Set a reference to the sheet metal features collection.
    Dim oSheetMetalFeatures As SheetMetalFeatures
    Set oSheetMetalFeatures = oCompDef.Features

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create the first sketch on the X-Y work plane.
    Dim oSketch1 As PlanarSketch
    Set oSketch1 = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Dim oSketchLines As SketchEntitiesEnumerator
    Set oSketchLines = oSketch1.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(-2, -2), _
                                oTransGeom.CreatePoint2d(2, 2))

    ' Create a path.
    Dim oPath1 As Path
    Set oPath1 = oCompDef.Features.CreatePath(oSketchLines.Item(1))

    ' Create a workplane offset from the X-Y plane by 2 inches.
    Dim oWorkPlane As WorkPlane
    Set oWorkPlane = oCompDef.WorkPlanes.AddByPlaneAndOffset(oCompDef.WorkPlanes.Item(3), "2 in")
    oWorkPlane.Visible = False

    ' Create the second sketch on the new work plane.
    Dim oSketch2 As PlanarSketch
    Set oSketch2 = oCompDef.Sketches.Add(oWorkPlane)

    ' Draw a circle with center at (0,0) and radius 5.
    Dim oSketchCircle As SketchCircle
    Set oSketchCircle = oSketch2.SketchCircles.AddByCenterRadius(oTransGeom.CreatePoint2d(0, 0), 5)

    ' Create a path.
    Dim oPath2 As Path
    Set oPath2 = oCompDef.Features.CreatePath(oSketchCircle)

    Dim oLoftedFlangeDefinition As LoftedFlangeDefinition
    Set oLoftedFlangeDefinition = oSheetMetalFeatures.LoftedFlangeFeatures.CreateLoftedFlangeDefinition(oPath1, oPath2)

    ' Set the output type to press brake with a chord tolerance of .1
    Call oLoftedFlangeDefinition.SetOutputType(kPressBrakeChordToleranceLoftedFlange, "0.1 in")

    ' Create a lofted flange feature.
    Dim oLoftedFlangeFeature As LoftedFlangeFeature
    Set oLoftedFlangeFeature = oSheetMetalFeatures.LoftedFlangeFeatures.Add(oLoftedFlangeDefinition)

    ThisApplication.ActiveView.GoHome
End Sub
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Methods > LoftedFlangeFeatures.Add Method


LoftedFlangeFeatures.CreateLoftedFlangeDefinition Method

LoftedFlangeFeatures.CreateLoftedFlangeDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new LoftedFlangeDefinition object.

Visual Basic
Sub CreateLoftedFlangeDefinition(ProfileOne As Path, ProfileTwo As Path, Result As [out, retval] LoftedFlangeDefinition*)
Parameters
Parameters | Description
ProfileOne | The first of two profiles that defines the shape of the lofted flange. Use PartFeatures.CreatePath method to create this path.
ProfileTwo | The second of two profiles that defines the shape of the lofted flange. Use PartFeatures.CreatePath method to create this path.
Remarks

This object is not a lofted flange feature but contains the information that defines a lofted flange and can be used to create a new lofted flange. The definition created defines a die formed lofted flange. To create press brake types of lofted flanges you can edit the definition before using it to create the lofted flange feature.

See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Methods > LoftedFlangeFeatures.CreateLoftedFlangeDefinition Method


LoftedFlangeFeatures.Item Method

LoftedFlangeFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified LoftedFlangeFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] LoftedFlangeFeature*)
Parameters
Parameters | Description
Index | Input Long or String that specifies the LoftedFlangeFeature object within the collection to return. Inputting a Long indicates the index of the LoftedFlangeFeature within the collection to return. A String can also be used to specify the name of the feature. The property will fail is the index is out of range or the name does not exist.
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Methods > LoftedFlangeFeatures.Item Method


LoftedFlangeFeatures Properties

LoftedFlangeFeatures Properties
Summary

The properties of the LoftedFlangeFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Properties


LoftedFlangeFeatures.Application Property

LoftedFlangeFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Properties > LoftedFlangeFeatures.Application Property


LoftedFlangeFeatures.Count Property

LoftedFlangeFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Properties > LoftedFlangeFeatures.Count Property


LoftedFlangeFeatures.Type Property

LoftedFlangeFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftedFlangeFeatures Interface > LoftedFlangeFeatures Properties > LoftedFlangeFeatures.Type Property


LoftFeature Interface

LoftFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The LoftFeature object represents an existing loft in an Autodesk Inventor part document. The LoftFeature is derived from the PartFeature object and inherits all of its methods and properties.

Class Hierarchy
Inventor::PartFeature
    Inventor::LoftFeature
        Inventor::LoftFeatureProxy
Visual Basic
Public Interface LoftFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

LoftFeatureProxy.NativeObject

LoftFeatures.Add

LoftFeatures.Item

Example

"Loft Feature With Non-Planar Section Example "

This sample demonstrates the creation of a loft feature. It uses two sections for the loft, one is from a 2d sketch and the other is a non-planar section from a 3d sketch. Because one of the sketches isn't planar, a surface is created instead of a solid.

Public Sub CreateNonPlanarSectionLoft()
    ' Set a reference to the active document.
    ' This assumes the active document is a part document.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create a 2d sketch to use as one section.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))
    Call oSketch.SketchCircles.AddByCenterRadius(oTG.CreatePoint2d(0, 0), 5)

    ' Create the profile to use as the section.
    Dim oProfile1 As Profile
    Set oProfile1 = oSketch.Profiles.AddForSolid

    ' Create a 3d sketch to use as the second section.
    Dim oSketch3d As Sketch3D
    Set oSketch3d = oCompDef.Sketches3D.Add

    Dim oWPs(1 To 6) As WorkPoint
    Set oWPs(1) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(-8, 6, 10))
    Set oWPs(2) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(-8, -6, 10))
    Set oWPs(3) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(0, -4, 8))
    Set oWPs(4) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(8, -6, 10))
    Set oWPs(5) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(8, 6, 10))
    Set oWPs(6) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(0, 4, 8))
    Dim oStartLine3d As SketchLine3D
    Set oStartLine3d = oSketch3d.SketchLines3D.AddByTwoPoints(oWPs(1), oWPs(2), True, 2)
    Dim oLine3d As SketchLine3D
    Set oLine3d = oSketch3d.SketchLines3D.AddByTwoPoints(oStartLine3d.EndPoint, oWPs(3), True, 2)
    Set oLine3d = oSketch3d.SketchLines3D.AddByTwoPoints(oLine3d.EndPoint, oWPs(4), True, 2)
    Set oLine3d = oSketch3d.SketchLines3D.AddByTwoPoints(oLine3d.EndPoint, oWPs(5), True, 2)
    Set oLine3d = oSketch3d.SketchLines3D.AddByTwoPoints(oLine3d.EndPoint, oWPs(6), True, 2)
    Set oLine3d = oSketch3d.SketchLines3D.AddByTwoPoints(oLine3d.EndPoint, oStartLine3d.StartPoint, True, 2)

    ' Create a 3d profile to use as the section. Even though this section
    ' is closed the AddOpen method must be used because it is non-planar.
    Dim oProfile2 As Profile3D
    Set oProfile2 = oSketch3d.Profiles3D.AddOpen

    ' Create an object collection for the sections.
    Dim oSections As ObjectCollection
    Set oSections = ThisApplication.TransientObjects.CreateObjectCollection
    Call oSections.Add(oProfile1)
    Call oSections.Add(oProfile2)

    ' Create the loft definition. Because one of the ends isn't planar,
    ' a surface must be created instead of a solid.
    Dim oLoftDefinition As LoftDefinition
    Set oLoftDefinition = oCompDef.Features.LoftFeatures.CreateLoftDefinition(oSections, kSurfaceOperation)

    ' Create the loft feature.
    Call oCompDef.Features.LoftFeatures.Add(oLoftDefinition)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > LoftFeature Interface


LoftFeature Properties

LoftFeature Properties
Summary

The properties of the LoftFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the definition for the loft feature.
EndFace | Property that returns the that acts as the cap of the last section of the loft. This property will return nothing in the cases where the loft does not have a ending face. These cases are when the loft sections are not closed or when the loft operation does not result in a solid.
SideFaces | Property that returns a object that provides access to all of the faces created around the perimeter of the feature.
StartFace | Property that returns the that acts as the cap of the first section of the loft. This property will return nothing in the cases where the loft does not have a starting face. These cases are when the loft sections are not closed or when the loft operation does not result in a solid.
You are here: Symbol Reference > Inventor Library > Objects > LoftFeature Interface > LoftFeature Properties


LoftFeature.Definition Property

LoftFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the definition for the loft feature.

Visual Basic
Property Definition() As LoftDefinition*
Remarks

The LoftDefinition object returned by this property can be directly used to modify the loft feature, i.e. if any of the properties of the returned LoftDefinition object are modified, the loft feature will also be immediately modified.

If the loft definition needs to be modified by updating a set of properties (e.g. batch edit scenario), then the Copy method of the LoftDefinition object can be used to obtain a copy of the LoftDefinition object used by the loft feature. Since the copy of the LoftDefinition object is not directly used by the loft feature, its properties can be updated without affecting the loft feature. After modifying the properties of the copy of the LoftDefinition, the loft feature can then be updated to use that modified definition by setting this property back to that modified LoftDefinition object.

The loft feature can also be specified to use a new definition by using the CreateLoftDefinition method of the LoftFeatures object to create the new LoftDefinition object, then setting the desired properties on that loft definition and then finally setting this property to that new LoftDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > LoftFeature Interface > LoftFeature Properties > LoftFeature.Definition Property


LoftFeature.EndFace Property

LoftFeature.EndFace Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that acts as the cap of the last section of the loft. This property will return nothing in the cases where the loft does not have a ending face. These cases are when the loft sections are not closed or when the loft operation does not result in a solid.

Visual Basic
Property EndFace() As Face**
You are here: Symbol Reference > Inventor Library > Objects > LoftFeature Interface > LoftFeature Properties > LoftFeature.EndFace Property


LoftFeature.SideFaces Property

LoftFeature.SideFaces Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a object that provides access to all of the faces created around the perimeter of the feature.

Visual Basic
Property SideFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > LoftFeature Interface > LoftFeature Properties > LoftFeature.SideFaces Property


LoftFeature.StartFace Property

LoftFeature.StartFace Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that acts as the cap of the first section of the loft. This property will return nothing in the cases where the loft does not have a starting face. These cases are when the loft sections are not closed or when the loft operation does not result in a solid.

Visual Basic
Property StartFace() As Face**
You are here: Symbol Reference > Inventor Library > Objects > LoftFeature Interface > LoftFeature Properties > LoftFeature.StartFace Property


LoftFeatureProxy Interface

LoftFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the LoftFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::LoftFeature
        Inventor::LoftFeatureProxy
Visual Basic
Public Interface LoftFeatureProxy
Inherits LoftFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > LoftFeatureProxy Interface


LoftFeatureProxy Properties

LoftFeatureProxy Properties
Summary

The properties of the LoftFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatureProxy Interface > LoftFeatureProxy Properties


LoftFeatureProxy.ContainingOccurrence Property

LoftFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LoftFeatureProxy Interface > LoftFeatureProxy Properties > LoftFeatureProxy.ContainingOccurrence Property


LoftFeatureProxy.NativeObject Property

LoftFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As LoftFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > LoftFeatureProxy Interface > LoftFeatureProxy Properties > LoftFeatureProxy.NativeObject Property


LoftFeatures Interface

LoftFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The LoftFeatures collection object provides access to existing loft features and supports the ability to create new loft features.

Class Hierarchy
Inventor::LoftFeatures
Visual Basic
Public Interface LoftFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.LoftFeatures

See Also

Loft Feature With Non-Planar Section sample

Example

See LoftFeature for example "Create a loft feature"

You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface


LoftFeatures Methods

LoftFeatures Methods
Summary

The methods of the LoftFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new loft.
CreateLoftDefinition | Method that creates a LoftDefinition object that defines the input definition for a loft feature.
CreateMapCurves | Method that creates a new MapPointCurves object. You then use functionality provided by the resulting MapPointCurves object to define the specific point mapping.
Item | Property that returns the specified LoftFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Methods


LoftFeatures.Add Method

LoftFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new loft.

Visual Basic
Sub Add(Definition As LoftDefinition, Result As [out, retval] LoftFeature*)
Parameters
Parameters | Description
Definition | Input LoftDefinition object that defines the input definition for the loft. The LoftDefinition object can be created using the CreateLoftDefinition method of the LoftFeatures object. The LoftDefinition object defines the following input data for creating the loft feature: the loft sections, the boundary conditions for the starting and ending sections, a centerline or rails with any applicable boundary conditions, the mapping between the sections, an option to indicate whether the loft should be closed or not and an option to indicate whether tangent faces should be merged or not.
See Also

Loft Feature With Non-Planar Section sample

Example

See LoftFeature for example "Create a loft feature"

You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Methods > LoftFeatures.Add Method


LoftFeatures.CreateLoftDefinition Method

LoftFeatures.CreateLoftDefinition Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a LoftDefinition object that defines the input definition for a loft feature.

Visual Basic
Sub CreateLoftDefinition(Sections As ObjectCollection, Operation As PartFeatureOperationEnum, Result As [out, retval] LoftDefinition*)
Parameters
Parameters | Description
Sections | Input ObjectCollection that contains the sections for the loft. Valid objects for sections are Profile, Profile3D, EdgeLoop, EdgeCollection, SketchPoint, SketchPoint3D, WorkPoint and Vertex objects. If a point (SketchPoint, SketchPoint3D, WorkPoint or Vertex object) is used, it must be either the first section or the last section and there must be at least one other intermediate section which is not a point. If an EdgeCollection object is used it may contain either a single edge or a set of tangentially connected edges. The order of the sections within the ObjectCollection defines the fit order of the loft through the sections. The sections must be either all open or all closed; you cannot mix open and closed sections.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation or kSurfaceOperation.
Remarks

The functionality provided by the resulting LoftDefinition object can also be used to define additional input data for creating the loft feature which includes the following: the boundary conditions for the starting and ending sections, a centerline or rails with any applicable boundary conditions, the mapping between the sections, an option to indicate whether the loft should be closed or not and an option to indicate whether tangent faces should be merged or not.

See Also

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Methods > LoftFeatures.CreateLoftDefinition Method


LoftFeatures.CreateMapCurves Method

LoftFeatures.CreateMapCurves Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new MapPointCurves object. You then use functionality provided by the resulting MapPointCurves object to define the specific point mapping.

Visual Basic
Sub CreateMapCurves(Sections As ObjectCollection, Result As [out, retval] MapPointCurves*)
Parameters
Parameters | Description
Sections | Input ObjectCollection that contains the sections for the loft. The sections provided for input must be the same sections that will be used as input for the LoftFeatures.Add method.
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Methods > LoftFeatures.CreateMapCurves Method


LoftFeatures.Item Method

LoftFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified LoftFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] LoftFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Methods > LoftFeatures.Item Method


LoftFeatures Properties

LoftFeatures Properties
Summary

The properties of the LoftFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Properties


LoftFeatures.Application Property

LoftFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Properties > LoftFeatures.Application Property


LoftFeatures.Count Property

LoftFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Properties > LoftFeatures.Count Property


LoftFeatures.Type Property

LoftFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftFeatures Interface > LoftFeatures Properties > LoftFeatures.Type Property


LoftRail Interface

LoftRail Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LoftRail object is used to define a rail in a loft feature.

Class Hierarchy
Inventor::LoftRail
Visual Basic
Public Interface LoftRail
Inherits IDispatch
Remarks

If the rail has conditions associated with it, then this object will also return the condition data.

Notes

Members through which this object may be accessed include:

LoftRails.Add

LoftRails.Item

You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface


LoftRail Methods

LoftRail Methods
Summary

The methods of the LoftRail class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this loft rail.
You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Methods


LoftRail.Delete Method

LoftRail.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes this loft rail.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Methods > LoftRail.Delete Method


LoftRail Properties

LoftRail Properties
Summary

The properties of the LoftRail class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Condition | Property that gets and sets the enum indicating the condition of the loft at the rail, if the rail has conditions associated with it. The return values can be kFreeLoftCondition, kTangentLoftCondition or kSmoothLoftCondition.
HasConditions | Property that specifies whether the rail has conditions associated with it.
Impact | Property that returns the Parameter object that controls the amount of influence the rail has on the shape of the entire loft.
Rail | Property that gets the rail for the loft feature.
Type | Property that returns kLoftRailObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties


LoftRail.Application Property

LoftRail.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties > LoftRail.Application Property


LoftRail.Condition Property

LoftRail.Condition Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the enum indicating the condition of the loft at the rail, if the rail has conditions associated with it. The return values can be kFreeLoftCondition, kTangentLoftCondition or kSmoothLoftCondition.

Visual Basic
Property Condition() As LoftConditionEnum
Remarks

Since the condition is only applicable for a rail to which conditions can be applied, if the loft rail represents a rail that has conditions associated with it as indicated by the HasConditions property returning True, then this property will return the condition value. If the rail does not have conditions associated with it as indicated by the HasConditions property returning False, then this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties > LoftRail.Condition Property


LoftRail.HasConditions Property

LoftRail.HasConditions Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether the rail has conditions associated with it.

Visual Basic
Property HasConditions() As VARIANT_BOOL*
Remarks

If the rail has conditions, then this property will return True, otherwise this property will return False.

You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties > LoftRail.HasConditions Property


LoftRail.Impact Property

LoftRail.Impact Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Parameter object that controls the amount of influence the rail has on the shape of the entire loft.

Visual Basic
Property Impact() As Parameter**
Remarks

A value of 0 for this parameter indicates no impact on the loft shape. Higher values increase the amount of impact. The impact is only applicable for a rail to which the tangent or smooth condition has been applied. Therefore, this property is only applicable if both of the following conditions are satisfied:

  • The loft rail has conditions associated with it as indicated by the HasConditions property returning True and
  • The tangent or smooth condition has been applied as indicated by the Condition property returning kTangentLoftCondition or kSmoothLoftCondition

If any one or both of the above conditions are not satisfied, then this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties > LoftRail.Impact Property


LoftRail.Rail Property

LoftRail.Rail Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets the rail for the loft feature.

Visual Basic
Property Rail() As IDispatch**
Remarks

Valid objects for the rail are Profile, Profile3D, EdgeLoop, and EdgeCollection objects.

You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties > LoftRail.Rail Property


LoftRail.Type Property

LoftRail.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns kLoftRailObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftRail Interface > LoftRail Properties > LoftRail.Type Property


LoftRails Interface

LoftRails Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The LoftRails object is used to define the rails and their conditions in a loft feature.

Class Hierarchy
Inventor::LoftRails
Visual Basic
Public Interface LoftRails
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LoftDefinition.LoftRails

LoftFeature.LoftRails

You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface


LoftRails Methods

LoftRails Methods
Summary

The methods of the LoftRails class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new LoftRail that represents a rail for a loft feature.
Item | Method that returns the specified LoftRail object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Methods


LoftRails.Add Method

LoftRails.Add Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new LoftRail that represents a rail for a loft feature.

Visual Basic
Sub Add(Value As IDispatch, ByRef Condition As [optional] VARIANT, ByRef Impact As [optional] VARIANT, Result As [out, retval] LoftRail*)
Parameters
Parameters
Description
Value
Input Object that defines a rail for a loft feature. Valid input objects for rails are Profile, Profile3D, EdgeLoop and EdgeCollection objects. The EdgeCollection object may contain either a single edge or a set of tangentially connected edges. Since all the rails for a loft must be either open or all closed, if the existing rails in the collection are open, then the rail specified using this argument must be open. Similarly, if the existing rails in the collection are closed, then the rail specified using this argument must be closed.
Condition
Optional input constant that defines the condition of the loft at the rail. Valid input is one of the following constants in LoftConditionEnum: kFreeLoftCondition, kTangentLoftCondition or kSmoothLoftCondition. If any other constant in LoftConditionEnum is specified, then the creation of the loft rail will fail. Since the condition is only applicable for a rail to which boundary conditions can be applied, the rail condition must not be specified using this argument if boundary conditions cannot be applied to the rail specified by the Rail argument, otherwise the creation of the loft rail will fail. If the rail is a rail to which boundary conditions can be applied and if no value is explicitly specified for this argument, then the default value of kFreeLoftCondition will be assumed.
Impact
Optional input Variant that defines the impact the rail's condition has on the shape of the entire loft. The value can be specified either as a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, it is unitless. If a string is input it must resolve to a unitless value. Since the impact is only applicable for a rail to which the tangent or smooth condition can been applied, the impact value should be specified only if both of the following conditions are satisfied:

  • The loft rail is a rail to which boundary conditions can be applied and
  • The Condition argument is specified to be kTangentLoftCondition or kSmoothLoftCondition to indicate tangent or smooth condition

If any one or both of the above conditions are not satisfied and an impact value is specified, then this method will fail to create the loft rail. If both the conditions are satisfied and if no value is explicitly specified for this argument, then the default value of 0 will be assumed.

Remarks

The Condition and Impact arguments can be used to specify the boundary conditions for a rail only if these conditions can be applied to the rail. Therefore, these arguments are valid only if boundary conditions are applicable to the rail specified using the Rail argument. If boundary conditions cannot be applied to the rail and either one of or both the Condition and Impact arguments are specified, then this method will fail.

You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Methods > LoftRails.Add Method


LoftRails.Item Method

LoftRails.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified LoftRail object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] LoftRail*)
Parameters
Parameters | Description
index | Value that specifies the LoftRail to return.
You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Methods > LoftRails.Item Method


LoftRails Properties

LoftRails Properties
Summary

The properties of the LoftRails class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of LoftRail objects in the collection.
Type | Property that returns kLoftRailsObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Properties


LoftRails.Application Property

LoftRails.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Properties > LoftRails.Application Property


LoftRails.Count Property

LoftRails.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of LoftRail objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Properties > LoftRails.Count Property


LoftRails.Type Property

LoftRails.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns kLoftRailsObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftRails Interface > LoftRails Properties > LoftRails.Type Property


LoftSectionDimension Interface

LoftSectionDimension Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The LoftSectionDimension object is used to define the position and area for a placed section of an area-graph type loft.

Class Hierarchy
Inventor::LoftSectionDimension
Visual Basic
Public Interface LoftSectionDimension
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LoftSectionDimensions.AddDrivenSection

LoftSectionDimensions.AddDrivingSection

LoftSectionDimensions.Item

You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface


LoftSectionDimension Methods

LoftSectionDimension Methods
Summary

The methods of the LoftSectionDimension class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this placed section of an area-graph type loft.
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Methods


LoftSectionDimension.Delete Method

LoftSectionDimension.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes this placed section of an area-graph type loft.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Methods > LoftSectionDimension.Delete Method


LoftSectionDimension Properties

LoftSectionDimension Properties
Summary

The properties of the LoftSectionDimension class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
IsDrivingSection | Property that specifies whether the placed section for an area-graph type loft is driving or driven. A value of True specifies that the placed section is driving.
Position | Property that gets and sets the positional distance (from the starting section) of the placed section for an area-graph type loft.
PositionAsAbsoluteDistance | Property that gets and sets the whether the positional distance of the placed section for an area-graph type loft is specified as an absolute distance value.
Size | Property that gets and sets the size of the placed section for an area-graph type loft.
SizeAsScaleFactor | Property that gets and sets whether the size of the placed section for an area-graph type loft is specified as a scale factor with respect to its default size.
Type | Property that returns kLoftSectionDimensionObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties


LoftSectionDimension.Application Property

LoftSectionDimension.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.Application Property


LoftSectionDimension.IsDrivingSection Property

LoftSectionDimension.IsDrivingSection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether the placed section for an area-graph type loft is driving or driven. A value of True specifies that the placed section is driving.

Visual Basic
Property IsDrivingSection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.IsDrivingSection Property


LoftSectionDimension.Position Property

LoftSectionDimension.Position Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the positional distance (from the starting section) of the placed section for an area-graph type loft.

Visual Basic
Property Position() As double
Remarks

If the PositionAsAbsoluteDistance property returns True, then this property will specify the absolute distance value (measured along the centerline of the loft of the placed section from the starting section) ) and any Double value that represents this absolute distance can be specified when setting a value for this property.

If the PositionAsAbsoluteDistance property returns False, then this property will specify the proportional distance value (relative to the starting section). The valid range of values for the proportional distance is 0.0 to 1.0 (including 0.0 and 1.0). This proportional distance is defined as the absolute distance of the placed section from the starting section divided by the absolute distance of the ending section from the starting section where both the distances are measured along the centerline of the loft. For example, for a placed section that coincides with the starting section the value of the proportional distance will be 0.0 and for a placed section that coincides with the ending section the value of the proportional distance will be 1.0. For intermediate placed sections, the value of the proportional distance will be between 0.0 and 1.0.

You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.Position Property


LoftSectionDimension.PositionAsAbsoluteDistance Property

LoftSectionDimension.PositionAsAbsoluteDistance Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the whether the positional distance of the placed section for an area-graph type loft is specified as an absolute distance value.

Visual Basic
Property PositionAsAbsoluteDistance() As VARIANT_BOOL
Remarks

A value of True indicates that the positional distance of the placed section is specified as an absolute distance value (measured along the centerline of the loft from the starting section). The Position property can be used to get this absolute distance value.

A value of False indicates that the positional distance of the placed section is specified as a proportional distance value (relative to the starting section). This proportional distance is defined as the absolute distance of the placed section from the starting section divided by the absolute distance of the ending section from the starting section where both the distances are measured along the centerline of the loft. For example, for a placed section that coincides with the starting section the value of the proportional distance will be 0.0 and for a placed section that coincides with the ending section the value of the proportional distance will be 1.0. For intermediate placed sections, the value of the proportional distance will be between 0.0 and 1.0. The Position property can be used to get this proportional distance value.

You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.PositionAsAbsoluteDistance Property


LoftSectionDimension.Size Property

LoftSectionDimension.Size Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the size of the placed section for an area-graph type loft.

Visual Basic
Property Size() As double
Remarks

If the SizeAsScaleFactor property returns True, then this property will specify the value of the scale factor that specifies the actual size of the placed section with respect to its default size. For example, for a placed section whose area is the same as its default size, the value of the scale factor will be 1.0 and for a placed section whose area is half the default size, the value of the scale factor will be 0.5.

If the SizeAsScaleFactor property returns False, then this property will specify the absolute area value of the placed section.

This property is only applicable if the placed section is a driving section as indicated by the IsDrivingSection property returning a value of True. If the placed section is a driven section as indicated by the IsDrivingSection property returning a value of False, then getting or setting a value using this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.Size Property


LoftSectionDimension.SizeAsScaleFactor Property

LoftSectionDimension.SizeAsScaleFactor Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the size of the placed section for an area-graph type loft is specified as a scale factor with respect to its default size.

Visual Basic
Property SizeAsScaleFactor() As VARIANT_BOOL
Remarks

A value of True indicates that the size of the placed section is specified in terms of a scale factor with respect to its default size. For example, for a placed section whose area needs to be the same as its default size, the value of the scale factor will be 1.0 and for a placed section whose area needs to be half the default size, the value of the scale factor will be 0.5. The Size property can be used to get the value of this scale factor.

A value of False indicates that the size of the placed section is specified as an absolute area value. The Size property can be used to get this absolute area value.

This property is only applicable if the placed section is a driving section as indicated by the IsDrivingSection property returning a value of True. If the placed section is a driven section as indicated by the IsDrivingSection property returning a value of False, then getting or setting a value using this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.SizeAsScaleFactor Property


LoftSectionDimension.Type Property

LoftSectionDimension.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kLoftSectionDimensionObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimension Interface > LoftSectionDimension Properties > LoftSectionDimension.Type Property


LoftSectionDimensions Interface

LoftSectionDimensions Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The LoftSectionDimensions object is used to define the placed section dimensions for an area-graph type loft.

Class Hierarchy
Inventor::LoftSectionDimensions
Visual Basic
Public Interface LoftSectionDimensions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LoftDefinition.LoftSectionDimensions

You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface


LoftSectionDimensions Methods

LoftSectionDimensions Methods
Summary

The methods of the LoftSectionDimensions class are listed here.

Methods
Methods
Name | Description
AddDrivenSection | Method that creates a new LoftSectionDimension that represents a driven placed section for an area-graph type loft feature.
AddDrivingSection | Method that creates a new LoftSectionDimension that represents a driving placed section for an area-graph type loft feature.
Item | Returns the specified LoftSectionDimension object from the collection
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Methods


LoftSectionDimensions.AddDrivenSection Method

LoftSectionDimensions.AddDrivenSection Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new LoftSectionDimension that represents a driven placed section for an area-graph type loft feature.

Visual Basic
Sub AddDrivenSection(Position As double, ByRef PositionAsAbsoluteDistance As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] LoftSectionDimension*)
Parameters
Parameters
Description
Position
Specifies the positional distance (from the starting section) of the placed section for an area-graph type loft feature. The valid range of values for this argument depends on the value of the PositionAsAbsoluteDistance argument. If the PositionAsAbsoluteDistance argument is True, then the value specified by this argument represents an absolute distance value (measured along the centerline of the loft from the starting section) and any Double value that represents this absolute distance can be specified. If the PositionAsAbsoluteDistance argument is False, then the value specified by this argument represents a proportional distance value (relative to the starting section). The valid range of values for the proportional distance is 0.0 to 1.0 (including 0.0 and 1.0). This proportional distance is defined as the absolute distance of the placed section from the starting section divided by the absolute distance of the ending section from the starting section where both the distances are measured along the centerline of the loft. For example, for a placed section that coincides with the starting section the value of the proportional distance will be 0.0 and for a placed section that coincides with the ending section the value of the proportional distance will be 1.0. For intermediate placed sections, the value of the proportional distance will be between 0.0 and 1.0.
PositionAsAbsoluteDistance
Indicates whether the positional distance of the placed section for an area-graph type loft feature is specified as an absolute distance value. A value of True indicates that the positional distance (specified by the Position argument) of the placed section is specified as an absolute distance value (measured along the centerline of the loft from the starting section). A value of False indicates that the positional distance (specified by the Position argument) of the placed section is specified as a proportional distance value (relative to the starting section). This proportional distance is defined as the absolute distance of the placed section from the starting section divided by the absolute distance of the ending section from the starting section where both the distances are measured along the centerline of the loft. For example, for a placed section that coincides with the starting section the value of the proportional distance will be 0.0 and for a placed section that coincides with the ending section the value of the proportional distance will be 1.0. For intermediate placed sections, the value of the proportional distance will be between 0.0 and 1.0. If no value is explicitly specified, a default value of False will be assumed to indicate that positional distance is specified as a proportional distance value.
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Methods > LoftSectionDimensions.AddDrivenSection Method


LoftSectionDimensions.AddDrivingSection Method

LoftSectionDimensions.AddDrivingSection Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new LoftSectionDimension that represents a driving placed section for an area-graph type loft feature.

Visual Basic
Sub AddDrivingSection(Position As double, Size As double, ByRef PositionAsAbsoluteDistance As [defaultvalue(0)] VARIANT_BOOL, ByRef SizeAsScaleFactor As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] LoftSectionDimension*)
Parameters
Parameters
Description
Position
Specifies the positional distance (from the starting section) of the placed section for an area-graph type loft feature. The valid range of values for this argument depends on the value of the PositionAsAbsoluteDistance argument. If the PositionAsAbsoluteDistance argument is True, then the value specified by this argument represents an absolute distance value (measured along the centerline of the loft from the starting section) and any Double value that represents this absolute distance can be specified. If the PositionAsAbsoluteDistance argument is False, then the value specified by this argument represents a proportional distance value (relative to the starting section). The valid range of values for the proportional distance is 0.0 to 1.0 (including 0.0 and 1.0). This proportional distance is defined as the absolute distance of the placed section from the starting section divided by the absolute distance of the ending section from the starting section where both the distances are measured along the centerline of the loft. For example, for a placed section that coincides with the starting section the value of the proportional distance will be 0.0 and for a placed section that coincides with the ending section the value of the proportional distance will be 1.0. For intermediate placed sections, the value of the proportional distance will be between 0.0 and 1.0.
Size
Specifies the size of the placed section for an area-graph type loft feature. The specified value will either represent an absolute area value or a scale factor value depending on the value of the SizeAsScaleFactor argument. If the SizeAsScaleFactor argument is True, then the value specified by this argument represents a scale factor for the size of the placed section (i.e. by what scale factor should the placed section be re-sized from its default size). For example, for a placed section whose area needs to be the same as its default size, the value of the scale factor will be 1.0 and for a placed section whose area needs to be half the default size, the value of the scale factor will be 0.5. If the SizeAsScaleFactor argument is False, then the value specified by this argument represents the absolute area of the placed section.
PositionAsAbsoluteDistance
Indicates whether the positional distance of the placed section for an area-graph type loft feature is specified as an absolute distance value. A value of True indicates that the positional distance (specified by the Position argument) of the placed section is specified as an absolute distance value (measured along the centerline of the loft from the starting section). A value of False indicates that the positional distance (specified by the Position argument) of the placed section is specified as a proportional distance value (relative to the starting section). This proportional distance is defined as the absolute distance of the placed section from the starting section divided by the absolute distance of the ending section from the starting section where both the distances are measured along the centerline of the loft. For example, for a placed section that coincides with the starting section the value of the proportional distance will be 0.0 and for a placed section that coincides with the ending section the value of the proportional distance will be 1.0. For intermediate placed sections, the value of the proportional distance will be between 0.0 and 1.0. If no value is explicitly specified, a default value of False will be assumed to indicate that positional distance is specified as a proportional distance value.
SizeAsScaleFactor
Indicates whether the size of the placed section for an area-graph type loft feature is specified as a scale factor with respect to its default size. A value of True indicates that the size (specified by the Size argument) of the placed section is specified in terms of a scale factor with respect to its default size. For example, for a placed section whose area needs to be the same as its default size, the value of the scale factor will be 1.0 and for a placed section whose area needs to be half the default size, the value of the scale factor will be 0.5. A value of False indicates that the size (specified by the Size argument) of the placed section is specified as an absolute area value. If no value is explicitly specified, a default value of False will be assumed to indicate that that the size of the placed section is specified as an absolute area value.
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Methods > LoftSectionDimensions.AddDrivingSection Method


LoftSectionDimensions.Item Method

LoftSectionDimensions.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns the specified LoftSectionDimension object from the collection

Visual Basic
Sub Item(Index As long, Result As [out, retval] LoftSectionDimension*)
Parameters
Parameters | Description
index | Specifies the LoftSectionDimension to return.
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Methods > LoftSectionDimensions.Item Method


LoftSectionDimensions Properties

LoftSectionDimensions Properties
Summary

The properties of the LoftSectionDimensions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of LoftSectionDimension objects in the collection.
Type | Property that returns kLoftSectionDimensionsObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Properties


LoftSectionDimensions.Application Property

LoftSectionDimensions.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Properties > LoftSectionDimensions.Application Property


LoftSectionDimensions.Count Property

LoftSectionDimensions.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the number of LoftSectionDimension objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Properties > LoftSectionDimensions.Count Property


LoftSectionDimensions.Type Property

LoftSectionDimensions.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kLoftSectionDimensionsObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LoftSectionDimensions Interface > LoftSectionDimensions Properties > LoftSectionDimensions.Type Property


LumpDefinition Interface

LumpDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The LumpDefinition represents a transient definition of a lump. A lump represents a bounded area of space. It can consist of one or more FaceShell objects.

Class Hierarchy
Inventor::LumpDefinition
Visual Basic
Public Interface LumpDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LumpDefinitions.Add

LumpDefinitions.Item

See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > LumpDefinition Interface


LumpDefinition Properties

LumpDefinition Properties
Summary

The properties of the LumpDefinition class are listed here.

Properties
Name | Description
Application | Property returning the root Application object.
FaceShellDefinitions | Property that returns the collection of FaceShellDefinitionobjects associated with this LumpDefinition object.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinition Interface > LumpDefinition Properties


LumpDefinition.Application Property

LumpDefinition.Application Property Introduced in Inventor 2011
Summary

Property returning the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinition Interface > LumpDefinition Properties > LumpDefinition.Application Property


LumpDefinition.FaceShellDefinitions Property

LumpDefinition.FaceShellDefinitions Property Introduced in Inventor 2011
Summary

Property that returns the collection of FaceShellDefinitionobjects associated with this LumpDefinition object.

Visual Basic
Property FaceShellDefinitions() As FaceShellDefinitions**
See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > LumpDefinition Interface > LumpDefinition Properties > LumpDefinition.FaceShellDefinitions Property


LumpDefinition.Type Property

LumpDefinition.Type Property Introduced in Inventor 2011
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinition Interface > LumpDefinition Properties > LumpDefinition.Type Property


LumpDefinitions Interface

LumpDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::LumpDefinitions
Visual Basic
Public Interface LumpDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceBodyDefinition.LumpDefinitions

The LumpDefinitions collection provides access to existing LumpDefinition objects and allows creation of new LumpDefinition objects.

You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface


LumpDefinitions Methods

LumpDefinitions Methods
Summary

The methods of the LumpDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new LumpDefinition within the associated SurfaceBodyDefinition.
Item | Property that returns the specified LumpDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Methods


LumpDefinitions.Add Method

LumpDefinitions.Add Method Introduced in Inventor 2011
Summary

Method that creates a new LumpDefinition within the associated SurfaceBodyDefinition.

Visual Basic
Sub Add(Result As [out, retval] LumpDefinition*)
See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Methods > LumpDefinitions.Add Method


LumpDefinitions.Item Method

LumpDefinitions.Item Method Introduced in Inventor 2011
Summary

Property that returns the specified LumpDefinition object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] LumpDefinition*)
Parameters
Parameters | Description
Index | Input Long value that specifies the LumpDefinition object within the collection to return.
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Methods > LumpDefinitions.Item Method


LumpDefinitions Properties

LumpDefinitions Properties
Summary

The properties of the LumpDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of LumpDefinition objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Properties


LumpDefinitions.Application Property

LumpDefinitions.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Properties > LumpDefinitions.Application Property


LumpDefinitions.Count Property

LumpDefinitions.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of LumpDefinition objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Properties > LumpDefinitions.Count Property


LumpDefinitions.Type Property

LumpDefinitions.Type Property Introduced in Inventor 2011
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > LumpDefinitions Interface > LumpDefinitions Properties > LumpDefinitions.Type Property


Machining Interface

Machining Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Allows editing for environment-specific features.

Class Hierarchy
Inventor::Machining
Visual Basic
Public Interface Machining
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WeldmentComponentDefinition.Machining

Document.ActivatedObject

Application.ActiveEditObject

You are here: Symbol Reference > Inventor Library > Objects > Machining Interface


Machining Methods

Machining Methods
Summary

The methods of the Machining class are listed here.

Methods
Methods
Name | Description
Edit | Method that activates this object for editing by the user.
ExitEdit | Method that causes the current editing environment to be closed and the user interface to return to weldment editing environment.
You are here: Symbol Reference > Inventor Library > Objects > Machining Interface > Machining Methods


Machining.Edit Method

Machining.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that activates this object for editing by the user.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > Machining Interface > Machining Methods > Machining.Edit Method


Machining.ExitEdit Method

Machining.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that causes the current editing environment to be closed and the user interface to return to weldment editing environment.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > Machining Interface > Machining Methods > Machining.ExitEdit Method


Machining Properties

Machining Properties
Summary

The properties of the Machining class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Machining Interface > Machining Properties


Machining.Application Property

Machining.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Machining Interface > Machining Properties > Machining.Application Property


Machining.Type Property

Machining.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Machining Interface > Machining Properties > Machining.Type Property


MacroControlDefinition Interface

MacroControlDefinition Interface Available in Inventor Introduced in Inventor 9
Summary

The MacroControlDefinition object represents a command that causes a macro to run.

Class Hierarchy
Inventor::ControlDefinition
    Inventor::MacroControlDefinition
Visual Basic
Public Interface MacroControlDefinition
Inherits ControlDefinition
Remarks

The MacroControlDefinition object does not represent the button in the user interface, but instead represents the command that causes the resulting behavior. The button itself is represented by a CommandBarControl. One or more controls can reference a single MacroControlDefinition.The MacroControlDefinition object is derived from the ControlDefinition object.

Notes

Members through which this object may be accessed include:

ControlDefinitions.AddMacroControlDefinition

See Also

Macro Button - create on toolbar sample

You are here: Symbol Reference > Inventor Library > Objects > MacroControlDefinition Interface


MacroControlDefinition Properties

MacroControlDefinition Properties
Summary

The properties of the MacroControlDefinition class are listed here.

Properties
Name | Description
MacroOrFileName | Property that indicates the macro or filename associated with this MacroControlDefinition. A VBA macro must be a Public Sub defined in a standard code module of the Application VBA project. The Sub cannot have any input arguments. The Sub is specified using 'Module.SubName' format. For example, the Sub MovePart in a module named AsmTools would be specified by 'AsmTools.MovePart'. If a filename with an .ide extension is supplied it is assumed to be an iFeature. When the user clicks the button it will begin placement of the iFeature. The filename must be a full filename. If an... more
You are here: Symbol Reference > Inventor Library > Objects > MacroControlDefinition Interface > MacroControlDefinition Properties


MacroControlDefinition.MacroOrFileName Property

MacroControlDefinition.MacroOrFileName Property Available in Inventor Introduced in Inventor 9
Summary

Property that indicates the macro or filename associated with this MacroControlDefinition. A VBA macro must be a Public Sub defined in a standard code module of the Application VBA project. The Sub cannot have any input arguments. The Sub is specified using 'Module.SubName' format. For example, the Sub MovePart in a module named AsmTools would be specified by 'AsmTools.MovePart'. If a filename with an .ide extension is supplied it is assumed to be an iFeature. When the user clicks the button it will begin placement of the iFeature. The filename must be a full filename. If an external EXE is specified, this must be the full path to the EXE.

Visual Basic
Property MacroOrFileName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > MacroControlDefinition Interface > MacroControlDefinition Properties > MacroControlDefinition.MacroOrFileName Property


MapPointCurve Interface

MapPointCurve Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The MapPointCurve object is used to define a set of mapping points between sections in a loft feature.

Class Hierarchy
Inventor::MapPointCurve
Visual Basic
Public Interface MapPointCurve
Inherits IDispatch
Notes

Members through which this object may be accessed include:

MapPointCurves.AddMapCurve

MapPointCurves.Item

You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface


MapPointCurve Methods

MapPointCurve Methods
Summary

The methods of the MapPointCurve class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this set of mapping points for a loft.
GetPosition | Method that gets the position of the specified map point along the input entity.
GetPositionPoint | Method that returns the position of the specified map point in 3D space.
SetPosition | Method that sets the position of the map point. The entity implicitly defines which section the point is for. The position of the map points is defined using a 3D coordinate point. If a map point already exists for the section the input entity is a member of, the current map point will be replaced.
SetPositionUsingPoint | Method that sets the position of the map point using a 3D coordinate. The index corresponds with the section of the same index. If a map point already exists for the section the input entity is a member of, the current map point will be replaced.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Methods


MapPointCurve.Delete Method

MapPointCurve.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes this set of mapping points for a loft.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Methods > MapPointCurve.Delete Method


MapPointCurve.GetPosition Method

MapPointCurve.GetPosition Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that gets the position of the specified map point along the input entity.

Visual Basic
Sub GetPosition(Index As long, ByRef Entity As IDispatch*, ByRef Result As double)
Parameters
Parameters | Description
Index | Input Long that defines which map point to get the position for. The first map point has an index of 1.
Entity | Output entity that is the component of the section that was used to define the position of the map point. This argument can be a SketchEntity, SketchEntity3D, Edge, WorkPoint or Vertex.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Methods > MapPointCurve.GetPosition Method


MapPointCurve.GetPositionPoint Method

MapPointCurve.GetPositionPoint Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the position of the specified map point in 3D space.

Visual Basic
Sub GetPositionPoint(Index As long, Result As [out, retval] Point*)
Parameters
Parameters | Description
index | Input Long that defines which map point to get the position for. The first map point has an index of 1 and corresponds with the section of the same index.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Methods > MapPointCurve.GetPositionPoint Method


MapPointCurve.SetPosition Method

MapPointCurve.SetPosition Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the position of the map point. The entity implicitly defines which section the point is for. The position of the map points is defined using a 3D coordinate point. If a map point already exists for the section the input entity is a member of, the current map point will be replaced.

Visual Basic
Sub SetPosition(Entity As IDispatch, Value As double)
Parameters
Parameters | Description
Entity | Input entity that is a component of a section. Valid input is a SketchEntity, SketchEntity3D, Edge, WorkPoint or Vertex.
Value | Input Double that defines the position of the map point along the input entity as a percentage of the length of the entity. The input value should be between 0 and 1.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Methods > MapPointCurve.SetPosition Method


MapPointCurve.SetPositionUsingPoint Method

MapPointCurve.SetPositionUsingPoint Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the position of the map point using a 3D coordinate. The index corresponds with the section of the same index. If a map point already exists for the section the input entity is a member of, the current map point will be replaced.

Visual Basic
Sub SetPositionUsingPoint(SectionIndex As long, Position As Point)
Parameters
Parameters | Description
SectionIndex | Input Long that identifies which section the map point is being defined for. The index corresponds with the section of the same index.
Position | Input that defines the coordinate position of the map point. The input point will be projected to the nearest point along the specified section.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Methods > MapPointCurve.SetPositionUsingPoint Method


MapPointCurve Properties

MapPointCurve Properties
Summary

The properties of the MapPointCurve class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
PointCount | Property that specifies the number of MapPoints in the set.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Properties


MapPointCurve.Application Property

MapPointCurve.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Properties > MapPointCurve.Application Property


MapPointCurve.PointCount Property

MapPointCurve.PointCount Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that specifies the number of MapPoints in the set.

Visual Basic
Property PointCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Properties > MapPointCurve.PointCount Property


MapPointCurve.Type Property

MapPointCurve.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurve Interface > MapPointCurve Properties > MapPointCurve.Type Property


MapPointCurves Interface

MapPointCurves Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The MapPointCurves object represents a collection of objects, used to define mapping points between sections in a loft feature.

Class Hierarchy
Inventor::MapPointCurves
Visual Basic
Public Interface MapPointCurves
Inherits IDispatch
Notes

Members through which this object may be accessed include:

LoftDefinition.MapPointCurves

LoftFeature.MapPointCurves

LoftFeatures.CreateMapCurves

You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface


MapPointCurves Methods

MapPointCurves Methods
Summary

The methods of the MapPointCurves class are listed here.

Methods
Methods
Name | Description
AddMapCurve | Method that creates a new MapPointCurve. This method is only valid for MapPointCurves objects that were created using the LoftFeatures.CreateMapCurves. A error will occur if you use this method for a MapPointCurves object obtained from an existing LoftFeature object.
Item | Method that returns the specified MapPointCurve object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Methods


MapPointCurves.AddMapCurve Method

MapPointCurves.AddMapCurve Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new MapPointCurve. This method is only valid for MapPointCurves objects that were created using the LoftFeatures.CreateMapCurves. A error will occur if you use this method for a MapPointCurves object obtained from an existing LoftFeature object.

Visual Basic
Sub AddMapCurve(Result As [out, retval] MapPointCurve*)
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Methods > MapPointCurves.AddMapCurve Method


MapPointCurves.Item Method

MapPointCurves.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified MapPointCurve object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] MapPointCurve*)
Parameters
Parameters | Description
index | Input Long value that specifies the MapPointCurve to return.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Methods > MapPointCurves.Item Method


MapPointCurves Properties

MapPointCurves Properties
Summary

The properties of the MapPointCurves class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of MapPointCurve objects in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Properties


MapPointCurves.Application Property

MapPointCurves.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Properties > MapPointCurves.Application Property


MapPointCurves.Count Property

MapPointCurves.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of MapPointCurve objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Properties > MapPointCurves.Count Property


MapPointCurves.Type Property

MapPointCurves.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MapPointCurves Interface > MapPointCurves Properties > MapPointCurves.Type Property


MassProperties Interface

MassProperties Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The MassProperties object provides access to properties that provide read and write access to various mass property information.

Class Hierarchy
Inventor::MassProperties
Visual Basic
Public Interface MassProperties
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.MassProperties

ComponentOccurrence.MassProperties

FlatPattern.MassProperties

PartComponentDefinition.MassProperties

See Also

Computing mass properties without dirtying document sample

Example

"Mass Properties from Part Example"

This sample demonstrates getting mass properties from a part. This sample is specific to a part document, but the MassProperties object can also be obtained from an Assembly document and from component occurrences. To run the sample you must have a part document open that contains a solid.

Public Sub GetPartMassProps()
    ' Set a reference to the part document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Set a reference to the mass properties object.
    Dim oMassProps As MassProperties
    Set oMassProps = oPartDoc.ComponentDefinition.MassProperties

    ' Set the accuracy to medium.
    oMassProps.Accuracy = k_Medium

    ' Display the mass properties of the part.
    Debug.Print "Area: " & oMassProps.Area

    Debug.Print "Center of Mass: " & _
                    oMassProps.CenterOfMass.X & ", " & _
                    oMassProps.CenterOfMass.Y & ", " & _
                    oMassProps.CenterOfMass.Z

    Debug.Print "Mass: " & oMassProps.Mass
    Dim adPrincipalMoments(1 To 3) As Double
    Call oMassProps.PrincipalMomentsOfInertia(adPrincipalMoments(1), _
                                                    adPrincipalMoments(2), _
                                                    adPrincipalMoments(3))
    Debug.Print "Principal Moments of Inertia: " & _
                    adPrincipalMoments(1) & ", " & _
                    adPrincipalMoments(2) & ", " & _
                    adPrincipalMoments(3)

    Dim adRadiusOfGyration(1 To 3) As Double
    Call oMassProps.RadiusOfGyration(adRadiusOfGyration(1), _
                                            adRadiusOfGyration(2), _
                                            adRadiusOfGyration(3))
    Debug.Print "Radius of Gyration: " & _
                    adRadiusOfGyration(1) & ", " & _
                    adRadiusOfGyration(2) & ", " & _
                    adRadiusOfGyration(3)

    Debug.Print "Volume: " & oMassProps.Volume

    Dim Ixx As Double
    Dim Iyy As Double
    Dim Izz As Double
    Dim Ixy As Double
    Dim Iyz As Double
    Dim Ixz As Double
    Call oMassProps.XYZMomentsOfInertia(Ixx, Iyy, Izz, Ixy, Iyz, Ixz)
    Debug.Print "Moments: "
    Debug.Print "   Ixx: " & Ixx
    Debug.Print "   Iyy: " & Iyy
    Debug.Print "   Izz: " & Izz
    Debug.Print "   Ixy: " & Ixy
    Debug.Print "   Iyz: " & Iyz
    Debug.Print "   Ixz: " & Ixz
End Sub
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface


MassProperties Methods

MassProperties Methods
Summary

The methods of the MassProperties class are listed here.

Methods
Methods
Name | Description
AchievedAccuracy | Property that gets the actual accuracy achieved while computing the mass property calculations.
PrincipalMomentsOfInertia | Property that gets the moments of inertia about the principal axis.
RadiusOfGyration | Property that gets the radius of gyration about the principal axis.
RotationToPrincipal | This is RotationToPrincipal, a member of class MassProperties.
XYZMomentsOfInertia | Property that gets the moment of inertia about reference axis.
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Methods


MassProperties.AchievedAccuracy Method

MassProperties.AchievedAccuracy Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the actual accuracy achieved while computing the mass property calculations.

Visual Basic
Sub AchievedAccuracy(ByRef AchievedAccuracyArea As double, ByRef AchievedAccuracyVolume As double)
Parameters
Parameters | Description
AchievedAccuracyArea | Gets the actual accuracy achieved while computing the mass property calculations for the area.
AchievedAccuracyVolume | Gets the actual accuracy achieved while computing the mass property calculations for the vol/com/centroid.
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Methods > MassProperties.AchievedAccuracy Method


MassProperties.PrincipalMomentsOfInertia Method

MassProperties.PrincipalMomentsOfInertia Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the moments of inertia about the principal axis.

Visual Basic
Sub PrincipalMomentsOfInertia(ByRef I1 As double, ByRef I2 As double, ByRef I3 As double)
Parameters
Parameters | Description
I1 | Output Double that specifies the first moment of inertia.
I2 | Output Double that specifies the second moment of inertia.
I3 | Output Double that specifies the third moment of inertia.
See Also

Computing mass properties without dirtying document sample

Mass Properties from Part sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Methods > MassProperties.PrincipalMomentsOfInertia Method


MassProperties.RadiusOfGyration Method

MassProperties.RadiusOfGyration Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the radius of gyration about the principal axis.

Visual Basic
Sub RadiusOfGyration(ByRef Kx As double, ByRef Ky As double, ByRef Kz As double)
Parameters
Parameters | Description
Kx | Output Double that returns the X partial radius of gyration.
Ky | Output Double that returns the Y partial radius of gyration.
Kz | Output Double that returns the Z partial radius of gyration.
See Also

Computing mass properties without dirtying document sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Methods > MassProperties.RadiusOfGyration Method


MassProperties.RotationToPrincipal Method

MassProperties.RotationToPrincipal Method
Summary

This is RotationToPrincipal, a member of class MassProperties.

Visual Basic
Sub RotationToPrincipal(ByRef Rx As double, ByRef Ry As double, ByRef Rz As double)
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Methods > MassProperties.RotationToPrincipal Method


MassProperties.XYZMomentsOfInertia Method

MassProperties.XYZMomentsOfInertia Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the moment of inertia about reference axis.

Visual Basic
Sub XYZMomentsOfInertia(ByRef Ixx As double, ByRef Iyy As double, ByRef Izz As double, ByRef Ixy As double, ByRef Iyz As double, ByRef Ixz As double)
Parameters
Parameters | Description
Ixx | Output Double that returns the XX partial moment.
Iyy | Output Double that returns the YY partial moment.
Izz | Output Double that returns the ZZ partial moment.
Ixy | Output Double that returns the XY partial moment.
Iyz | Output Double that returns the YZ partial moment.
Ixz | Output Double that returns the XZ partial moment.
See Also

Computing mass properties without dirtying document sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Methods > MassProperties.XYZMomentsOfInertia Method


MassProperties Properties

MassProperties Properties
Summary

The properties of the MassProperties class are listed here.

Properties
Name | Description
Accuracy | Property that gets and sets the desired level of computational accuracy of the mass property calculations. The valid values are one of the constants in MassPropertiesAccuracyEnum: k_High, k_Low, k_Medium, k_None, k_VeryHigh.
Area | Property that returns the area of the entity.
AvailableAccuracy | Indicates the computational accuracy of mass properties calculations.
CacheResultsOnCompute | If this property is set to True, the results of the mass properties computation are cached in the document.
CenterOfMass | Property that gets the center of mass.
IncludeCosmeticWelds | Property that gets and sets whether cosmetic welds should be included for mass property calculations.
IncludeQuantityOverrides | Property that gets and sets whether BOM quantity overrides should be used for assembly components to perform mass property calculations.
Mass | Property that gets and sets the mass of the model in database units.
MassOverridden | Property that gets and sets whether the mass value is overridden.
Type | Property returning an enum indicating this object's type.
Volume | Property that gets and sets the volume of the model in database units.
VolumeOverridden | Property that gets and sets whether the volume value is overridden.
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties


MassProperties.Accuracy Property

MassProperties.Accuracy Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the desired level of computational accuracy of the mass property calculations. The valid values are one of the constants in MassPropertiesAccuracyEnum: k_High, k_Low, k_Medium, k_None, k_VeryHigh.

Visual Basic
Property Accuracy() As MassPropertiesAccuracyEnum
See Also

Computing mass properties without dirtying document sample

Mass Properties from Part sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.Accuracy Property


MassProperties.Area Property

MassProperties.Area Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the area of the entity.

Visual Basic
Property Area() As double*
See Also

Mass Properties from Part sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.Area Property


MassProperties.AvailableAccuracy Property

MassProperties.AvailableAccuracy Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Indicates the computational accuracy of mass properties calculations.

Visual Basic
Property AvailableAccuracy() As MassPropertiesAccuracyEnum*
See Also

Computing mass properties without dirtying document sample

Example

See MassProperties::CacheResultsOnCompute for example "CacheResultsOnCompute Property"

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.AvailableAccuracy Property


MassProperties.CacheResultsOnCompute Property

MassProperties.CacheResultsOnCompute Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

If this property is set to True, the results of the mass properties computation are cached in the document.

Visual Basic
Property CacheResultsOnCompute() As VARIANT_BOOL
Example

"Computing mass properties without dirtying document."

This sample demonstrates getting mass properties from a part without dirtying the document (i.e. without caching the computed results in the document). This sample is specific to a part document, but the MassProperties object can also be obtained from an Assembly document and from component occurrences. To run the sample you must have a part document open that contains a solid.

Public Sub GetPartMassPropsWithoutDirtying()
' Set a reference to the part document.
' This assumes a part document is active.
Dim oPartDoc As PartDocument
Set oPartDoc = ThisApplication.ActiveDocument

' Set a reference to the mass properties object.
Dim oMassProps As MassProperties
Set oMassProps = oPartDoc.ComponentDefinition.MassProperties

'Check if mass property results are already available
'at a high accuracy level or better. If so, simply
'print out the results, else, set a flag to not cache
'the results in the document.
If oMassProps.AvailableAccuracy k_High And _
  oMassProps.AvailableAccuracy k_VeryHigh Then
  ' Set the accuracy to high.
  oMassProps.Accuracy = k_High

  'Set CacheResultsOnCompute property to False
  'so that results are not saved with the document
  'and hence the document is not 'dirtied'.
  oMassProps.CacheResultsOnCompute = False
End If

' Display the mass properties of the part.
Debug.Print "Area: " & oMassProps.Area

Debug.Print "Center of Mass: " & _
oMassProps.CenterOfMass.X & ", " & _
oMassProps.CenterOfMass.Y & ", " & _
oMassProps.CenterOfMass.Z

Debug.Print "Mass: " & oMassProps.Mass
Dim adPrincipalMoments(1 To 3) As Double
Call oMassProps.PrincipalMomentsOfInertia(adPrincipalMoments(1), _
adPrincipalMoments(2), _
adPrincipalMoments(3))
Debug.Print "Principal Moments of Inertia: " & _
adPrincipalMoments(1) & ", " & _
adPrincipalMoments(2) & ", " & _
adPrincipalMoments(3)

Dim adRadiusOfGyration(1 To 3) As Double
Call oMassProps.RadiusOfGyration(adRadiusOfGyration(1), _
adRadiusOfGyration(2), _
adRadiusOfGyration(3))
Debug.Print "Radius of Gyration: " & _
adRadiusOfGyration(1) & ", " & _
adRadiusOfGyration(2) & ", " & _
adRadiusOfGyration(3)

Debug.Print "Volume: " & oMassProps.Volume

Dim Ixx As Double
Dim Iyy As Double
Dim Izz As Double
Dim Ixy As Double
Dim Iyz As Double
Dim Ixz As Double
Call oMassProps.XYZMomentsOfInertia(Ixx, Iyy, Izz, Ixy, Iyz, Ixz)
Debug.Print "Moments: "
Debug.Print " Ixx: " & Ixx
Debug.Print " Iyy: " & Iyy
Debug.Print " Izz: " & Izz
Debug.Print " Ixy: " & Ixy
Debug.Print " Iyz: " & Iyz
Debug.Print " Ixz: " & Ixz
End Sub
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.CacheResultsOnCompute Property


MassProperties.CenterOfMass Property

MassProperties.CenterOfMass Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the center of mass.

Visual Basic
Property CenterOfMass() As Point**
See Also

Computing mass properties without dirtying document sample

Mass Properties from Part sample

Example 1

Work point at mass center example (C#).

This sample demonstrates creating a fixed work point and edit its position. It does this by computing the center of mass of the part and creating a work point at that position. Subsequent runs of the sample reposition the work point at the new center of mass.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void WorkPointAtMassCenter()
{
    Application oApp = ThisApplication;

    // Check to make sure a part document is active.
    if (oApp.ActiveDocumentType != DocumentTypeEnum.kPartDocumentObject)
    {
        System.Windows.Forms.MessageBox.Show("A part document must be active.", "Part not active");
        return;
    }

    // Set a reference to the active document.
    PartDocument oDoc = (PartDocument)oApp.ActiveDocument;

    // Get the Center of Mass.
    Point oCenterOfMass = oDoc.ComponentDefinition.MassProperties.CenterOfMass;

    // Check to see if a work point for center of mass already exists.
    // This uses the name of the work feature to identify it.

    WorkPoint oWorkPoint = null;
    try
    {
        oWorkPoint = oDoc.ComponentDefinition.WorkPoints["Center Of Mass"];

        FixedWorkPointDef oFixedDef = (FixedWorkPointDef)oWorkPoint.Definition;
        oFixedDef.Point = oCenterOfMass;
        oDoc.Update();
    }
    catch
    {
        // Create a new workpoint at the location of the center of mass.
        oWorkPoint = oDoc.ComponentDefinition.WorkPoints.AddFixed(oCenterOfMass, false);

        // Rename the work point.
        oWorkPoint.Name = "Center Of Mass";
    }

}
Example 2

Work Point at Mass Center Example

This sample demonstrates creating a fixed work point and edit its position. I does this by computing the center of mass of the part or assembly and creating a work point at that position. Subsequent runs of the sample reposition the work point at the new center of mass.

Public Sub WorkPointAtMassCenter()
    ' Check to make sure a part document is active.
    If ThisApplication.ActiveDocumentType <> kPartDocumentObject Then
        MsgBox "A part document must be active."
        Exit Sub
    End If

    ' Set a reference to the active document.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Get the Center of Mass.
    Dim oCenterOfMass As Point
    Set oCenterOfMass = oDoc.ComponentDefinition.MassProperties.CenterOfMass

    ' Check to see if a work point for center of mass already exists.
    ' This uses the name of the work feature to identify it.
    On Error Resume Next
    Dim oWorkPoint As WorkPoint
    Set oWorkPoint = oDoc.ComponentDefinition.WorkPoints.Item("Center Of Mass")
    If Err.Number = 0 Then
        Dim oFixedDef As FixedWorkPointDef
        Set oFixedDef = oWorkPoint.Definition

        oFixedDef.Point = oCenterOfMass
        oDoc.Update
    Else
        ' Create a new workpoint at the location of the center of mass.
        Set oWorkPoint = oDoc.ComponentDefinition.WorkPoints.AddFixed(oCenterOfMass)

        ' Rename the work point.
        oWorkPoint.Name = "Center Of Mass"
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.CenterOfMass Property


MassProperties.IncludeCosmeticWelds Property

MassProperties.IncludeCosmeticWelds Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether cosmetic welds should be included for mass property calculations.

Visual Basic
Property IncludeCosmeticWelds() As VARIANT_BOOL
Remarks

A value of True indicates that cosmetic welds should be included for calculating the mass property values, e.g. mass, volume etc. Since exact values for these properties cannot be determined for cosmetic welds, only approximate values will be included.

Cosmetic welds will be included in property calculations only for those properties that have not been overridden. For example, if the mass has been overridden as indicated by the MassOverridden property returning True, then including cosmetic welds in the mass property calculations will not change the custom mass value of the model.

On the other hand, if the mass value is the calculated value for the model, then an approximate mass value for the cosmetic welds will be added to the current calculated mass of the model. The Mass property will be automatically updated to reflect this.

Similarly, other overridden mass properties (e.g. Volume) will not be affected if a value of True is specified for this property. But, if those properties are not overridden, then the calculated value for these properties will be updated to include cosmetic welds.

Also, if this property is True, the value of any overridable mass properties cannot be changed. For example, if the Mass property is the calculated value and it needs to be overridden by specifying a custom value, it will fail. Similarly, if the Mass property has been overridden to a custom value and it needs to be reverted to the calculated value by setting the MassOverridden property to False, it will fail. These property changes will succeed only if the value of this property is False.

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.IncludeCosmeticWelds Property


MassProperties.IncludeQuantityOverrides Property

MassProperties.IncludeQuantityOverrides Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether BOM quantity overrides should be used for assembly components to perform mass property calculations.

Visual Basic
Property IncludeQuantityOverrides() As VARIANT_BOOL
Remarks

This property is only applicable for mass property calculations in assemblies. If this property is used for parts, then it will fail.

A value of True indicates that BOM quantity overrides should be used for assembly components to perform mass property calculations.

BOM quantity overrides will be included in property calculations only for those properties that have not been overridden. For example, if the mass has been overridden as indicated by the MassOverridden property returning True, then including BOM quantity overrides in the mass property calculations will not change the custom mass value of the model.

On the other hand, if the mass value is the calculated value for the model, then BOM quantity overrides will be used to calculate the new mass of the model. The Mass property will be automatically updated to reflect this.

Similarly, other overridden mass properties (e.g. Volume) will not be affected if a value of True is specified for this property. But, if those properties are not overridden, then the calculated value for these properties will be updated to include BOM quantity overrides.

Also, if this property is True, the value of any overridable mass properties cannot be changed. For example, if the Mass property is the calculated value and it needs to be overridden by specifying a custom value, it will fail. Similarly, if the Mass property has been overridden to a custom value and it needs to be reverted to the calculated value by setting the MassOverridden property to False, it will fail. These property changes will succeed only if the value of this property is False.

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.IncludeQuantityOverrides Property


MassProperties.Mass Property

MassProperties.Mass Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the mass of the model in database units.

Visual Basic
Property Mass() As double
Remarks

This property can be set to a desired custom value in which case the default calculated value will be overridden. The MassOverridden property will return a value of True to indicate that the mass value has been overridden.

On the other hand, if the mass value is not overridden which will be indicated by the MassOverridden property returning a value of False, this property will return the calculated mass value of the model. Also, the MassOverridden can be set to False if the mass value needs to be reverted from the custom value to the calculated value.

A custom value for the mass can be specified using this property only if the IncludeCosmeticWelds and IncludeQuantityOverrides (for assemblies) properties are both False. If either the IncludeCosmeticWelds property or IncludeQuantityOverrides is True, setting a custom mass value using this property will fail.

See Also

Mass Properties from Part sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.Mass Property


MassProperties.MassOverridden Property

MassProperties.MassOverridden Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the mass value is overridden.

Visual Basic
Property MassOverridden() As VARIANT_BOOL
Remarks

A value of True indicates that the mass value has been overridden to a custom value. A value of False indicates the mass value corresponds to the calculated value for the model. In either case, the Mass property will return the appropriate mass value.

This property cannot be directly set to True. If a value of True is specified, then this property will fail. If the mass value needs to be overridden, then the Mass property should be set to the desired custom mass value which will automatically toggle this property to True.

This property can be set to False in which case the Mass property will be automatically set to the calculated mass value for the model. But, this property can be set only if the IncludeCosmeticWelds and IncludeQuantityOverrides (for assemblies) properties are both False. If either the IncludeCosmeticWelds property or IncludeQuantityOverrides is True, setting a value of False for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.MassOverridden Property


MassProperties.Type Property

MassProperties.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.Type Property


MassProperties.Volume Property

MassProperties.Volume Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the volume of the model in database units.

Visual Basic
Property Volume() As double
Remarks

This property can be set to a desired custom value in which case the default calculated value will be overridden. The VolumeOverridden property will return a value of True to indicate that the volume value has been overridden.

On the other hand, if the volume value is not overridden which will be indicated by the VolumeOverridden property returning a value of False, this property will return the calculated volume value of the model. Also, the VolumeOverridden can be set to False if the volume value needs to be reverted from the custom value to the calculated value.

A custom value for the volume can be specified using this property only if the IncludeCosmeticWelds and IncludeQuantityOverrides (for assemblies) properties are both False. If either the IncludeCosmeticWelds property or IncludeQuantityOverrides is True, setting a custom volume value using this property will fail.

See Also

Computing mass properties without dirtying document sample

Mass Properties from Part sample

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.Volume Property


MassProperties.VolumeOverridden Property

MassProperties.VolumeOverridden Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether the volume value is overridden.

Visual Basic
Property VolumeOverridden() As VARIANT_BOOL
Remarks

A value of True indicates that the volume value has been overridden to a custom value. A value of False indicates the volume value corresponds to the calculated value for the model. In either case, the Volume property will return the appropriate volume value.

This property cannot be directly set to True. If a value of True is specified, then this property will fail. If the volume value needs to be overridden, then the Volume property should be set to the desired custom volume value which will automatically toggle this property to True.

This property can be set to False in which case the Volume property will be automatically set to the calculated volume value for the model. But, this property can be set only if the IncludeCosmeticWelds and IncludeQuantityOverrides (for assemblies) properties are both False. If either the IncludeCosmeticWelds property or IncludeQuantityOverrides is True, setting a value of False for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > MassProperties Interface > MassProperties Properties > MassProperties.VolumeOverridden Property


MateConstraint Interface

MateConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a mate assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::MateConstraint
        Inventor::MateConstraintProxy
Visual Basic
Public Interface MateConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToMateConstraint

AssemblyConstraints.AddMateConstraint

MateConstraintProxy.NativeObject

See Also

Mate constraint with limits sample

Assembly Mate Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > MateConstraint Interface


MateConstraint Properties

MateConstraint Properties
Summary

The properties of the MateConstraint class are listed here.

Properties
Name | Description
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.
EntityOneInferredType | Property that returns an enum indicating how the geometry of entity one is interpreted.
EntityTwoInferredType | Property that returns an enum indicating how the geometry of entity two is interpreted.
Offset | Property that returns the Parameter object that controls the offset distance of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > MateConstraint Interface > MateConstraint Properties


MateConstraint.ConstraintLimits Property

MateConstraint.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > MateConstraint Interface > MateConstraint Properties > MateConstraint.ConstraintLimits Property


MateConstraint.EntityOneInferredType Property

MateConstraint.EntityOneInferredType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns an enum indicating how the geometry of entity one is interpreted.

Visual Basic
Property EntityOneInferredType() As InferredTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MateConstraint Interface > MateConstraint Properties > MateConstraint.EntityOneInferredType Property


MateConstraint.EntityTwoInferredType Property

MateConstraint.EntityTwoInferredType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns an enum indicating how the geometry of entity two is interpreted.

Visual Basic
Property EntityTwoInferredType() As InferredTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MateConstraint Interface > MateConstraint Properties > MateConstraint.EntityTwoInferredType Property


MateConstraint.Offset Property

MateConstraint.Offset Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Parameter object that controls the offset distance of the constraint.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > MateConstraint Interface > MateConstraint Properties > MateConstraint.Offset Property


MateConstraintProxy Interface

MateConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MateConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::MateConstraint
        Inventor::MateConstraintProxy
Visual Basic
Public Interface MateConstraintProxy
Inherits MateConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MateConstraintProxy Interface


MateConstraintProxy Properties

MateConstraintProxy Properties
Summary

The properties of the MateConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MateConstraintProxy Interface > MateConstraintProxy Properties


MateConstraintProxy.ContainingOccurrence Property

MateConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MateConstraintProxy Interface > MateConstraintProxy Properties > MateConstraintProxy.ContainingOccurrence Property


MateConstraintProxy.NativeObject Property

MateConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As MateConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MateConstraintProxy Interface > MateConstraintProxy Properties > MateConstraintProxy.NativeObject Property


MateiMateDefinition Interface

MateiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The MateiMateDefinition object represents a mate iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::MateiMateDefinition
        Inventor::MateiMateDefinitionProxy
Visual Basic
Public Interface MateiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddMateiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinition Interface


MateiMateDefinition Properties

MateiMateDefinition Properties
Summary

The properties of the MateiMateDefinition class are listed here.

Properties
Name | Description
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.
Entity | Property that returns the entity used for the iMate definition.
EntityInferredType | Property that returns an enum indicating how the geometry of the entity is interpreted.
Offset | Property that returns the Parameter object that controls the offset of the mate iMate definition.
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinition Interface > MateiMateDefinition Properties


MateiMateDefinition.ConstraintLimits Property

MateiMateDefinition.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinition Interface > MateiMateDefinition Properties > MateiMateDefinition.ConstraintLimits Property


MateiMateDefinition.Entity Property

MateiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinition Interface > MateiMateDefinition Properties > MateiMateDefinition.Entity Property


MateiMateDefinition.EntityInferredType Property

MateiMateDefinition.EntityInferredType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns an enum indicating how the geometry of the entity is interpreted.

Visual Basic
Property EntityInferredType() As InferredTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinition Interface > MateiMateDefinition Properties > MateiMateDefinition.EntityInferredType Property


MateiMateDefinition.Offset Property

MateiMateDefinition.Offset Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the offset of the mate iMate definition.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinition Interface > MateiMateDefinition Properties > MateiMateDefinition.Offset Property


MateiMateDefinitionProxy Interface

MateiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MateiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::MateiMateDefinition
        Inventor::MateiMateDefinitionProxy
Visual Basic
Public Interface MateiMateDefinitionProxy
Inherits MateiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinitionProxy Interface


MateiMateDefinitionProxy Properties

MateiMateDefinitionProxy Properties
Summary

The properties of the MateiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinitionProxy Interface > MateiMateDefinitionProxy Properties


MateiMateDefinitionProxy.ContainingOccurrence Property

MateiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinitionProxy Interface > MateiMateDefinitionProxy Properties > MateiMateDefinitionProxy.ContainingOccurrence Property


MateiMateDefinitionProxy.IsConsumed Property

MateiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinitionProxy Interface > MateiMateDefinitionProxy Properties > MateiMateDefinitionProxy.IsConsumed Property


MateiMateDefinitionProxy.NativeObject Property

MateiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MateiMateDefinitionProxy Interface > MateiMateDefinitionProxy Properties > MateiMateDefinitionProxy.NativeObject Property


Material Interface

Material Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Material object provides access to all of the properties that define a specific material.

Class Hierarchy
Inventor::Material
Visual Basic
Public Interface Material
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.DefaultMaterial

Material.ConvertToLocal

Material.Copy

Materials.Add

Materials.Item

MaterialsEnumerator.Item

PartComponentDefinition.Material

SheetMetalStyle.Material

VirtualComponentDefinition.Material

WeldmentComponentDefinition.Material

See Also

Material Read sample

UI customization - create combo box control sample

UI customization - create combo box control sample

Example

"Material Create Example "

This sample demonstrates how to create a new material in a part document. Before running the sample you must have a part document open.

Public Sub CreateMaterial()
    ' Set a reference to the part document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Create a new material.
    Dim oNewMaterial As Material
    Set oNewMaterial = oPartDoc.Materials.Add("My Material", 11.37)

    ' Define the other properties of the material
    oNewMaterial.LinearExpansion = 5.73
    oNewMaterial.PoissonsRatio = 0.38
    ' Arbitrarily assigns the first render style in the render styles collection.
    oNewMaterial.RenderStyle = oPartDoc.RenderStyles.Item(1)
    oNewMaterial.SpecificHeat = 124.3
    oNewMaterial.ThermalConductivity = 310.2
    oNewMaterial.UltimateTensileStrength = 210.45
    oNewMaterial.YieldStrength = 185.5
    oNewMaterial.YoungsModulus = 76.37
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Material Interface


Material Methods

Material Methods
Summary

The methods of the Material class are listed here.

Methods
Methods
Name | Description
ConvertToLocal | Method that creates a local cached copy of a global style and returns the local style. This method fails if this style is already local. Use the Local property to determine whether the style is local.
Copy | Method that copies the material and assigns the specified name to the new material. The new material is returned by the method.
Delete | Method that deletes the Material.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SaveToGlobal | Method that saves this material to the global repository.
UpdateFromGlobal | Method that updates this material from the global repository.
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods


Material.ConvertToLocal Method

Material.ConvertToLocal Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a local cached copy of a global style and returns the local style. This method fails if this style is already local. Use the Local property to determine whether the style is local.

Visual Basic
Sub ConvertToLocal(Result As [out, retval] Material*)
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods > Material.ConvertToLocal Method


Material.Copy Method

Material.Copy Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that copies the material and assigns the specified name to the new material. The new material is returned by the method.

Visual Basic
Sub Copy(NewName As String, Result As [out, retval] Material*)
Parameters
Parameters | Description
NewName | Input String that specifies the name for the new material. This name must be unique with respect to all other materials in the document. If it is not unique the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods > Material.Copy Method


Material.Delete Method

Material.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the Material.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods > Material.Delete Method


Material.GetReferenceKey Method

Material.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods > Material.GetReferenceKey Method


Material.SaveToGlobal Method

Material.SaveToGlobal Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that saves this material to the global repository.

Visual Basic
Sub SaveToGlobal()
Remarks

If a material with the same name is found in the repository, that material is updated.

You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods > Material.SaveToGlobal Method


Material.UpdateFromGlobal Method

Material.UpdateFromGlobal Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that updates this material from the global repository.

Visual Basic
Sub UpdateFromGlobal()
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Methods > Material.UpdateFromGlobal Method


Material Properties

Material Properties
Summary

The properties of the Material class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Density | Property that gets and sets the density of the material. The density is mass per unit volume. The units density is defined in are g/cm3 (grams/cubic centimeter).
ExternalMaterialId | This is ExternalMaterialId, a member of class Material.
InternalName | Property that returns the unique name of the material.
InUse | Property that indicates if this material style is in use in the document.
LinearExpansion | Property that gets and sets the linear expansion of the material. The linear expansion is the measure of how much a material expands as it is heated. The units linear expansion is defined in are 10^5m/m/C (' change in length / original length ? ' Celsius).
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent object from whom this object can logically be reached.
PoissonsRatio | Property that gets and sets Poisson's Ratio for the material. Poisson's Ratio is a measure of how much a material will laterally contract or expand as a sample of it is stretched or compressed, respectively.
RenderStyle | Property that gets and sets the render style associated with the material.
SpecificHeat | Property that gets and sets the specific heat of the material. The specific heat is a measure of how much heat energy a material can store (absorb) per unit of mass per unit of temperature. The units specific heat is defined in are J / [kg*K] (Joules / kilogram - K).
StyleLocation | Property that indicates the location status ( ) of this material style.
ThermalConductivity | Property that gets and sets thermal conductivity of the material. The thermal conductivity is the amount of heat energy transferred through a material per unit length and per one degree of temperature. The units thermal conductivity is defined in are W/[m*K] (Watts / meter ? ? Kelvin).
Type | Property returning an enum indicating this object's type.
UltimateTensileStrength | Property that gets and sets the ultimate tensile strength of the material. The ultimate tensile strength is the stress at which the material fails. The units tensile strength is defined in are megaPascals (Mpa).
UpToDate | If a property of both a Local and Global style is changed, its UpToDate property returns False until UpdateFromGlobal is called. UpdateFromGlobal undoes any changes made locally on this style, so then the UpToDate property will return True.
YieldStrength | Property that gets and sets the yield strength of the material. The yield strength is the stress at which the material begins to permanently deform. The units yield strength is defined in are megaPascals (Mpa).
YoungsModulus | Property that gets and sets Young's modulus or the modulus of elasticity for the material. Young's modulus the ratio of stress: ? (force/area) to strain, ? (? change in length / original length ); ? = E?. The units Young's modulus is defined in are the same as for pressure (force/area), gigaPascals (GPa).
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties


Material.Application Property

Material.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.Application Property


Material.AttributeSets Property

Material.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.AttributeSets Property


Material.Density Property

Material.Density Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the density of the material. The density is mass per unit volume. The units density is defined in are g/cm3 (grams/cubic centimeter).

Visual Basic
Property Density() As double
See Also

Material Read sample

You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.Density Property


Material.ExternalMaterialId Property

Material.ExternalMaterialId Property
Summary

This is ExternalMaterialId, a member of class Material.

Visual Basic
Property ExternalMaterialId() As String
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.ExternalMaterialId Property


Material.InternalName Property

Material.InternalName Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the unique name of the material.

Visual Basic
Property InternalName() As BSTR*
Remarks

The name is the internal English name of the material. This name will remain constant and is not affected by locale. This name is never displayed to the user.

You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.InternalName Property


Material.InUse Property

Material.InUse Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates if this material style is in use in the document.

Visual Basic
Property InUse() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.InUse Property


Material.LinearExpansion Property

Material.LinearExpansion Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the linear expansion of the material. The linear expansion is the measure of how much a material expands as it is heated. The units linear expansion is defined in are 10^5m/m/C (' change in length / original length ? ' Celsius).

Visual Basic
Property LinearExpansion() As double
See Also

Material Read sample

Material Create sample

You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.LinearExpansion Property


Material.Name Property

Material.Name Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.Name Property


Material.Parent Property

Material.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.Parent Property


Material.PoissonsRatio Property

Material.PoissonsRatio Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets Poisson's Ratio for the material. Poisson's Ratio is a measure of how much a material will laterally contract or expand as a sample of it is stretched or compressed, respectively.

Visual Basic
Property PoissonsRatio() As double
See Also

Material Read sample

Material Create sample

You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.PoissonsRatio Property


Material.RenderStyle Property

Material.RenderStyle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the render style associated with the material.

Visual Basic
Property RenderStyle() As RenderStyle*
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.RenderStyle Property


Material.SpecificHeat Property

Material.SpecificHeat Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the specific heat of the material. The specific heat is a measure of how much heat energy a material can store (absorb) per unit of mass per unit of temperature. The units specific heat is defined in are J / [kg*K] (Joules / kilogram - K).

Visual Basic
Property SpecificHeat() As double
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.SpecificHeat Property


Material.StyleLocation Property

Material.StyleLocation Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the location status ( ) of this material style.

Visual Basic
Property StyleLocation() As StyleLocationEnum*
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.StyleLocation Property


Material.ThermalConductivity Property

Material.ThermalConductivity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets thermal conductivity of the material. The thermal conductivity is the amount of heat energy transferred through a material per unit length and per one degree of temperature. The units thermal conductivity is defined in are W/[m*K] (Watts / meter ? ? Kelvin).

Visual Basic
Property ThermalConductivity() As double
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.ThermalConductivity Property


Material.Type Property

Material.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.Type Property


Material.UltimateTensileStrength Property

Material.UltimateTensileStrength Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the ultimate tensile strength of the material. The ultimate tensile strength is the stress at which the material fails. The units tensile strength is defined in are megaPascals (Mpa).

Visual Basic
Property UltimateTensileStrength() As double
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.UltimateTensileStrength Property


Material.UpToDate Property

Material.UpToDate Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

If a property of both a Local and Global style is changed, its UpToDate property returns False until UpdateFromGlobal is called. UpdateFromGlobal undoes any changes made locally on this style, so then the UpToDate property will return True.

Visual Basic
Property UpToDate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.UpToDate Property


Material.YieldStrength Property

Material.YieldStrength Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the yield strength of the material. The yield strength is the stress at which the material begins to permanently deform. The units yield strength is defined in are megaPascals (Mpa).

Visual Basic
Property YieldStrength() As double
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.YieldStrength Property


Material.YoungsModulus Property

Material.YoungsModulus Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets Young's modulus or the modulus of elasticity for the material. Young's modulus the ratio of stress: ? (force/area) to strain, ? (? change in length / original length ); ? = E?. The units Young's modulus is defined in are the same as for pressure (force/area), gigaPascals (GPa).

Visual Basic
Property YoungsModulus() As double
You are here: Symbol Reference > Inventor Library > Objects > Material Interface > Material Properties > Material.YoungsModulus Property


Materials Interface

Materials Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Materials collection object allows for the creation of new objects and provides access to existing Material objects.

Class Hierarchy
Inventor::Materials
Visual Basic
Public Interface Materials
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.Materials

PartDocument.Materials

See Also

UI customization - create combo box control sample

UI customization - create combo box control sample

Example 1

"Material Read Example "

This sample demonstrates accessing all of the materials defined within a part document.

Public Sub ShowMaterials()
    ' Set a reference to the part document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oMaterial As Material
    For Each oMaterial In oPartDoc.Materials
        Debug.Print "Name: " & oMaterial.Name
        Debug.Print "   Density: " & oMaterial.Density
        Debug.Print "   Linear Expansion: " & oMaterial.LinearExpansion
        Debug.Print "   Poissons Ratio: " & oMaterial.PoissonsRatio
        Debug.Print "   Render Style: " & oMaterial.RenderStyle.Name
        Debug.Print "   Specific Heat: " & oMaterial.SpecificHeat
        Debug.Print "   Thermal Conductivity: " & oMaterial.ThermalConductivity
        Debug.Print "   Ultimate Tensile Strength: " & oMaterial.UltimateTensileStrength
        Debug.Print "   Yeild Strength: " & oMaterial.YieldStrength
        Debug.Print "   Youngs Modulus: " & oMaterial.YoungsModulus
    Next
End Sub
Example 2

See Material for example "Material Object"

You are here: Symbol Reference > Inventor Library > Objects > Materials Interface


Materials Methods

Materials Methods
Summary

The methods of the Materials class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Material object. The density is specified during creation and all other material attributes default to zero. To specify any of the other material attributes you can use the properties supported by the Material object.
Item | Property that returns the specified Material object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Methods


Materials.Add Method

Materials.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new Material object. The density is specified during creation and all other material attributes default to zero. To specify any of the other material attributes you can use the properties supported by the Material object.

Visual Basic
Sub Add(Name As String, Density As double, Result As [out, retval] Material*)
Parameters
Parameters | Description
Name | Input String that specifies the name of the material. The name must be unique with respect to the other materials in the collection. If the name is not unique an error will occur.
Density | Input Double that specifies the density of the material. The density is mass per unit volume. The units used to define density are g/cm3 (grams/cubic centimeter).
See Also

Material Create sample

You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Methods > Materials.Add Method


Materials.Item Method

Materials.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified Material object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Material*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be a numeric value indicating the index of the item in the collection or it can be a string indicating the Material name. If an out of range index or a name of a non-existent Material is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Methods > Materials.Item Method


Materials Properties

Materials Properties
Summary

The properties of the Materials class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of Material objects in the collection.
Parent | Property returning the parent Document object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Properties


Materials.Application Property

Materials.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Properties > Materials.Application Property


Materials.Count Property

Materials.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of Material objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Properties > Materials.Count Property


Materials.Parent Property

Materials.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning the parent Document object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Properties > Materials.Parent Property


Materials.Type Property

Materials.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Materials Interface > Materials Properties > Materials.Type Property


MaterialsEnumerator Interface

MaterialsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Enumerates through the available Materials.

Class Hierarchy
Inventor::MaterialsEnumerator
Visual Basic
Public Interface MaterialsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

StylesManager.Materials

You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface


MaterialsEnumerator Methods

MaterialsEnumerator Methods
Summary

The methods of the MaterialsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface > MaterialsEnumerator Methods


MaterialsEnumerator.Item Method

MaterialsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Material*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface > MaterialsEnumerator Methods > MaterialsEnumerator.Item Method


MaterialsEnumerator Properties

MaterialsEnumerator Properties
Summary

The properties of the MaterialsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface > MaterialsEnumerator Properties


MaterialsEnumerator.Application Property

MaterialsEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface > MaterialsEnumerator Properties > MaterialsEnumerator.Application Property


MaterialsEnumerator.Count Property

MaterialsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface > MaterialsEnumerator Properties > MaterialsEnumerator.Count Property


MaterialsEnumerator.Type Property

MaterialsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MaterialsEnumerator Interface > MaterialsEnumerator Properties > MaterialsEnumerator.Type Property


Matrix Interface

Matrix Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

A 4x4 Matrix object. For more information, see the Transient Geometry article in the overviews section.

Class Hierarchy
Inventor::Matrix
Visual Basic
Public Interface Matrix
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Camera.ViewToWorld

Camera.WorldToView

ComponentOccurrence.Transformation

DrawingView.DrawingViewToModelTransform

DrawingView.DrawingViewToSheetTransform

DrawingView.ModelToDrawingViewTransform

DrawingView.ModelToSheetTransform

DrawingView.SheetToDrawingViewTransform

DrawingView.SheetToModelTransform

FeaturePatternElement.Transform

FreeMoveDefinition.Transformation

GraphicsNode.Transformation

MoveFeature.Transformation

PlanarSketch.ModelToSketchTransform

PlanarSketch.SketchToModelTransform

PresentationExplodedView.GetTransform

TextureMap.Transformation

TransientGeometry.CreateMatrix

TriadEventsObject.GlobalTransform

UserCoordinateSystem.Transformation

UserCoordinateSystemDefinition.Transformation

See Also

UCS by transformation matrix sample

Demote occurence sample

Assembly Move Occurrence sample

SurfaceBody Copy sample

Client Graphics - Line sample

Derived Parts and Assemblies sample

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface


Matrix Methods

Matrix Methods
Summary

The methods of the Matrix class are listed here.

Methods
Methods
Name | Description
GetCoordinateSystem | Get the coordinate system that this matrix maps to from the standard coordinate system.
GetMatrixData | Get the data defining this matrix.
Invert | Invert this matrix.
IsEqualTo | Compares this matrix for equality with the specified matrix.
PostMultiplyBy | Method that post-multiplies this matrix by the specified matrix, setting this matrix to the result.
PreMultiplyBy | Method that post-multiplies this matrix by the specified matrix, setting this matrix to the result.
PutMatrixData | Method that sets the data defining this matrix.
SetCoordinateSystem | Sets this matrix to be the matrix that maps from the standard coordinate system to the specified coordinate system.
SetToAlignCoordinateSystems | Sets this matrix to be the matrix that maps from the 'from' coordinate system to the 'to' coordinate system.
SetToIdentity | Sets this matrix to the identity matrix.
SetToRotateTo | Sets to the matrix of rotation that would align the 'from' vector with the 'to' vector. The optional Axis argument may be used when the two vectors are perpendicular and in opposite directions to specify a specific solution, but is otherwise ignored.
SetToRotation | Sets this matrix to the matrix of rotation by the specified angle, through the specified origin, around the specified axis.
SetTranslation | Sets the translation portion of the matrix. If the optional ResetRotation flag is True, the rotation portion of the matrix is reset to identity.
TransformBy | Method that sets this matrix to the result of this transformation followed by the specified transformation (a pre-multiplication of this matrix by the specified matrix).
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods


Matrix.GetCoordinateSystem Method

Matrix.GetCoordinateSystem Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the coordinate system that this matrix maps to from the standard coordinate system.

Visual Basic
Sub GetCoordinateSystem(ByRef Origin As Point*, ByRef XAxis As Vector*, ByRef YAxis As Vector*, ByRef ZAxis As Vector*)
Parameters
Parameters | Description
Origin | Output Point object that defines the origin of the coordinate system.
XAxis | Output Vector object that defines the X-axis vector of the coordinate system.
YAxis | Output Vector object that defines the Y-axis vector of the coordinate system.
ZAxis | Output Vector object that defines the Z-axis vector of the coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.GetCoordinateSystem Method


Matrix.GetMatrixData Method

Matrix.GetMatrixData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this matrix.

Visual Basic
Sub GetMatrixData(ByRef Cells As SAFEARRAY(double))
Parameters
Parameters | Description
Cells | Input/output Double that defines the matrix's cells.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.GetMatrixData Method


Matrix.Invert Method

Matrix.Invert Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Invert this matrix.

Visual Basic
Sub Invert()
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.Invert Method


Matrix.IsEqualTo Method

Matrix.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Compares this matrix for equality with the specified matrix.

Visual Basic
Sub IsEqualTo(Matrix As Matrix, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies matrix to compare.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the matrices are equal.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.IsEqualTo Method


Matrix.PostMultiplyBy Method

Matrix.PostMultiplyBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that post-multiplies this matrix by the specified matrix, setting this matrix to the result.

Visual Basic
Sub PostMultiplyBy(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies the matrix to post-multiply by.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.PostMultiplyBy Method


Matrix.PreMultiplyBy Method

Matrix.PreMultiplyBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that post-multiplies this matrix by the specified matrix, setting this matrix to the result.

Visual Basic
Sub PreMultiplyBy(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies the matrix to pre-multiply by.
See Also

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.PreMultiplyBy Method


Matrix.PutMatrixData Method

Matrix.PutMatrixData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this matrix.

Visual Basic
Sub PutMatrixData(ByRef Cells As SAFEARRAY(double))
Parameters
Parameters | Description
Cells | Input/output Double that defines the matrix's cells.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.PutMatrixData Method


Matrix.SetCoordinateSystem Method

Matrix.SetCoordinateSystem Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets this matrix to be the matrix that maps from the standard coordinate system to the specified coordinate system.

Visual Basic
Sub SetCoordinateSystem(Origin As Point, XAxis As Vector, YAxis As Vector, ZAxis As Vector)
Parameters
Parameters | Description
Origin | Input Point object that defines the origin of the coordinate system.
XAxis | Input Vector object that defines the X-axis vector of the coordinate system.
YAxis | Input Vector object that defines the Y-axis vector of the coordinate system.
ZAxis | Input Vector object that defines the Z-axis vector of the coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.SetCoordinateSystem Method


Matrix.SetToAlignCoordinateSystems Method

Matrix.SetToAlignCoordinateSystems Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets this matrix to be the matrix that maps from the 'from' coordinate system to the 'to' coordinate system.

Visual Basic
Sub SetToAlignCoordinateSystems(FromOrigin As Point, FromXAxis As Vector, FromYAxis As Vector, FromZAxis As Vector, ToOrigin As Point, ToXAxis As Vector, ToYAxis As Vector, ToZAxis As Vector)
Parameters
Parameters | Description
FromOrigin | Input Point object that defines the origin to map the coordinate system from.
FromXAxis | Input Vector object that defines the X-axis to map the coordinate system from.
FromYAxis | Input Vector object that defines the Y-axis to map the coordinate system from.
FromZAxis | Input Vector object that defines the Z-axis to map the coordinate system from.
ToOrigin | Input Point object that defines the origin to map the coordinate system to.
ToXAxis | Input Vector object that defines the X-axis to map the coordinate system to.
ToYAxis | Input Vector object that defines the Y-axis to map the coordinate system to.
ToZAxis | Input Vector object that defines the Z-axis to map the coordinate system to.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.SetToAlignCoordinateSystems Method


Matrix.SetToIdentity Method

Matrix.SetToIdentity Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets this matrix to the identity matrix.

Visual Basic
Sub SetToIdentity()
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.SetToIdentity Method


Matrix.SetToRotateTo Method

Matrix.SetToRotateTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets to the matrix of rotation that would align the 'from' vector with the 'to' vector. The optional Axis argument may be used when the two vectors are perpendicular and in opposite directions to specify a specific solution, but is otherwise ignored.

Visual Basic
Sub SetToRotateTo(From As Vector, To As Vector, ByRef Axis As [defaultvalue(0)] Vector)
Parameters
Parameters | Description
From | Input Vector object to align from.
To | Input Vector object to align to.
Axis | Input Vector object.
Remarks

Although the last argument is optional, a NULL (Nothing for VB users) must be passed in if the user wishes to ignore the argument.

You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.SetToRotateTo Method


Matrix.SetToRotation Method

Matrix.SetToRotation Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets this matrix to the matrix of rotation by the specified angle, through the specified origin, around the specified axis.

Visual Basic
Sub SetToRotation(Angle As double, Axis As Vector, Center As Point)
Parameters
Parameters | Description
Angle | Input Double that specifies the angle of rotation.
Axis | Input Vector object.
Center | Input Point object that specifies the origin.
See Also

UCS by transformation matrix sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.SetToRotation Method


Matrix.SetTranslation Method

Matrix.SetTranslation Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets the translation portion of the matrix. If the optional ResetRotation flag is True, the rotation portion of the matrix is reset to identity.

Visual Basic
Sub SetTranslation(Translation As Vector, ByRef ResetRotation As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Translation | Input Vector that specifies the new translation portion of the matrix.
ResetRotation | Optional input Boolean that indicates whether to reset to rotation portion of the matrix to identity.
See Also

UCS by transformation matrix sample

Assembly Move Occurrence sample

InteractionGraphics sample

Client Graphics - Line sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.SetTranslation Method


Matrix.TransformBy Method

Matrix.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets this matrix to the result of this transformation followed by the specified transformation (a pre-multiplication of this matrix by the specified matrix).

Visual Basic
Sub TransformBy(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies the matrix to transform by.
See Also

UCS by transformation matrix sample

You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Methods > Matrix.TransformBy Method


Matrix Properties

Matrix Properties
Summary

The properties of the Matrix class are listed here.

Methods
Methods
Name | Description
Cell | Property that returns the cell defined by row/col.
Properties
Name | Description
Determinant | Get the determinant of this matrix.
Translation | Get the translation portion of the matrix.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Properties


Matrix.Cell Method

Matrix.Cell Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the cell defined by row/col.

Visual Basic
Sub Cell(Row As long, Col As long, Cell As double)
Parameters
Parameters | Description
Row | Input Long that specifies a row.
Col | Input Long that specifies a column.
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Properties > Matrix.Cell Method


Matrix.Determinant Property

Matrix.Determinant Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the determinant of this matrix.

Visual Basic
Property Determinant() As double*
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Properties > Matrix.Determinant Property


Matrix.Translation Property

Matrix.Translation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the translation portion of the matrix.

Visual Basic
Property Translation() As Vector**
You are here: Symbol Reference > Inventor Library > Objects > Matrix Interface > Matrix Properties > Matrix.Translation Property


Matrix2d Interface

Matrix2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

A 3x3 Matrix2d object. For more information, see the Transient Geometry article on the overviews section.

Class Hierarchy
Inventor::Matrix2d
Visual Basic
Public Interface Matrix2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AutoCADBlock.Transformation

SketchBlock.Transformation

SketchedSymbol.Transformation

TitleBlock.Transformation

TransientGeometry.CreateMatrix2d

You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface


Matrix2d Methods

Matrix2d Methods
Summary

The methods of the Matrix2d class are listed here.

Methods
Methods
Name | Description
GetCoordinateSystem | Get the coordinate system that this matrix2d maps to from the standard coordinate system.
GetMatrixData | Get the data defining this matrix.
Invert | Method to Invert this matrix2d.
IsEqualTo | Compares this matrix2d for equality with the specified matrix2d
PostMultiplyBy | Post multiply this matrix2d by the specified matrix2d, setting this matrix2d to the result.
PreMultiplyBy | Pre multiply this matrix2d by the specified matrix2d, setting this matrix2d to the result.
PutMatrixData | Method that sets the data defining this matrix.
SetCoordinateSystem | Sets this matrix2d to be the matrix2d that maps from the standard coordinate system to the specified coordinate system.
SetToAlignCoordinateSystems | Sets this matrix2d to be the matrix2d that maps from the 'from' coordinate system to the 'to' coordinate system.
SetToIdentity | Sets this matrix2d to the identity matrix2d.
SetToRotateTo | Sets to the matrix2d of rotation that would align the 'from' vector2d with the 'to' vector2d.
SetToRotation | Sets this matrix2d to the matrix2d of rotation by the specified angle, through the specified origin.
SetTranslation | Sets the translation portion of the matrix2d.
TransformBy | Set this matrix2d to the result of this transformation followed by the specified transformation (a pre multiplication of this matrix2d by the specified matrix2d).
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods


Matrix2d.GetCoordinateSystem Method

Matrix2d.GetCoordinateSystem Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Get the coordinate system that this matrix2d maps to from the standard coordinate system.

Visual Basic
Sub GetCoordinateSystem(ByRef Origin As Point2d*, ByRef XAxis As Vector2d*, ByRef YAxis As Vector2d*)
Parameters
Parameters | Description
Origin | Specifies the origin point.
XAxis | Vextor for the X axis of the coordinate system.
YAxis | Vextor for the Y axis of the coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.GetCoordinateSystem Method


Matrix2d.GetMatrixData Method

Matrix2d.GetMatrixData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this matrix.

Visual Basic
Sub GetMatrixData(ByRef Cells As SAFEARRAY(double))
Parameters
Parameters | Description
Cells | Input/output Double that defines the matrix's cells.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.GetMatrixData Method


Matrix2d.Invert Method

Matrix2d.Invert Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method to Invert this matrix2d.

Visual Basic
Sub Invert()
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.Invert Method


Matrix2d.IsEqualTo Method

Matrix2d.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Compares this matrix2d for equality with the specified matrix2d

Visual Basic
Sub IsEqualTo(Matrix2d As Matrix2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Matrix2d | Matrix2s to compare to.
Tolerance | Tolerance value for comparison.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.IsEqualTo Method


Matrix2d.PostMultiplyBy Method

Matrix2d.PostMultiplyBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Post multiply this matrix2d by the specified matrix2d, setting this matrix2d to the result.

Visual Basic
Sub PostMultiplyBy(Matrix2d As Matrix2d)
Parameters
Parameters | Description
Matrix2d | Matrix2d to multiply by.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.PostMultiplyBy Method


Matrix2d.PreMultiplyBy Method

Matrix2d.PreMultiplyBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Pre multiply this matrix2d by the specified matrix2d, setting this matrix2d to the result.

Visual Basic
Sub PreMultiplyBy(Matrix2d As Matrix2d)
Parameters
Parameters | Description
Matrix2d | Matrix2d to multiply by.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.PreMultiplyBy Method


Matrix2d.PutMatrixData Method

Matrix2d.PutMatrixData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this matrix.

Visual Basic
Sub PutMatrixData(ByRef Cells As SAFEARRAY(double))
Parameters
Parameters | Description
Cells | Input/output Double that defines the matrix's cells.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.PutMatrixData Method


Matrix2d.SetCoordinateSystem Method

Matrix2d.SetCoordinateSystem Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets this matrix2d to be the matrix2d that maps from the standard coordinate system to the specified coordinate system.

Visual Basic
Sub SetCoordinateSystem(Origin As Point2d, XAxis As Vector2d, YAxis As Vector2d)
Parameters
Parameters | Description
Origin | Origin point.
XAxis | Vector for X axis of coordinate system.
YAxis | Vector for Y axis of coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.SetCoordinateSystem Method


Matrix2d.SetToAlignCoordinateSystems Method

Matrix2d.SetToAlignCoordinateSystems Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets this matrix2d to be the matrix2d that maps from the 'from' coordinate system to the 'to' coordinate system.

Visual Basic
Sub SetToAlignCoordinateSystems(FromOrigin As Point2d, FromXAxis As Vector2d, FromYAxis As Vector2d, ToOrigin As Point2d, ToXAxis As Vector2d, ToYAxis As Vector2d)
Parameters
Parameters | Description
FromOrigin | Origin point of 'from' coordinate system.
FromXAxis | Vector of X axis of 'from' coordinate system.
FromYAxis | Vector of Y axis of 'from' coordinate system.
ToOrigin | Origin point of "to" coordinate system.
ToXAxis | Vector of X axis of 'to' coordinate system.
ToYAxis | Vector of Y axis of 'to' coordinate system.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.SetToAlignCoordinateSystems Method


Matrix2d.SetToIdentity Method

Matrix2d.SetToIdentity Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets this matrix2d to the identity matrix2d.

Visual Basic
Sub SetToIdentity()
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.SetToIdentity Method


Matrix2d.SetToRotateTo Method

Matrix2d.SetToRotateTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets to the matrix2d of rotation that would align the 'from' vector2d with the 'to' vector2d.

Visual Basic
Sub SetToRotateTo(From As Vector2d, To As Vector2d)
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.SetToRotateTo Method


Matrix2d.SetToRotation Method

Matrix2d.SetToRotation Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets this matrix2d to the matrix2d of rotation by the specified angle, through the specified origin.

Visual Basic
Sub SetToRotation(Angle As double, Center As Point2d)
Parameters
Parameters | Description
Angle | Angle of rotation for new matrix2d.
Center | Origin (center) of rotation.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.SetToRotation Method


Matrix2d.SetTranslation Method

Matrix2d.SetTranslation Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets the translation portion of the matrix2d.

Visual Basic
Sub SetTranslation(Translation As Vector2d, ByRef ResetRotation As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Translation | Vector of translation
ResetRotation | Optional. If True, the rotation portion of the matrix2d is reset to identity.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.SetTranslation Method


Matrix2d.TransformBy Method

Matrix2d.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Set this matrix2d to the result of this transformation followed by the specified transformation (a pre multiplication of this matrix2d by the specified matrix2d).

Visual Basic
Sub TransformBy(Matrix2d As Matrix2d)
Parameters
Parameters | Description
Matrix2d | Matrix to use for pre-multiplication.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Methods > Matrix2d.TransformBy Method


Matrix2d Properties

Matrix2d Properties
Summary

The properties of the Matrix2d class are listed here.

Methods
Methods
Name | Description
Cell | Property that returns the cell defined by row/col.
Properties
Name | Description
Determinant | Get the determinant of this matrix2d.
Translation | Get the translation portion of the matrix2d.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Properties


Matrix2d.Cell Method

Matrix2d.Cell Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the cell defined by row/col.

Visual Basic
Sub Cell(Row As long, Col As long, Cell As double)
Parameters
Parameters | Description
Row | Input Long that specifies a row.
Col | Input Long that specifies a column.
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Properties > Matrix2d.Cell Method


Matrix2d.Determinant Property

Matrix2d.Determinant Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Get the determinant of this matrix2d.

Visual Basic
Property Determinant() As double*
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Properties > Matrix2d.Determinant Property


Matrix2d.Translation Property

Matrix2d.Translation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Get the translation portion of the matrix2d.

Visual Basic
Property Translation() As Vector2d**
You are here: Symbol Reference > Inventor Library > Objects > Matrix2d Interface > Matrix2d Properties > Matrix2d.Translation Property


MeasureEvents CoClass

MeasureEvents CoClass Available in Inventor Introduced in Inventor 2009
Summary

The MeasureEvents object provides the ability to invoke the measure and show dimension commands during InteractionEvents.

Class Hierarchy
Inventor::MeasureEvents
Visual Basic
Public Class MeasureEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

InteractionEventsObject.MeasureEvents

See Also

Using measure events sample

You are here: Symbol Reference > Inventor Library > Objects > MeasureEvents CoClass


MeasureEventsObject Interface

MeasureEventsObject Interface Available in Inventor Introduced in Inventor 2009
Summary

The MeasureEvents object provides the ability to invoke the measure and show dimension commands during InteractionEvents.

Class Hierarchy
Inventor::MeasureEventsObject
Visual Basic
Public Interface MeasureEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface


MeasureEventsObject Methods

MeasureEventsObject Methods
Summary

The methods of the MeasureEventsObject class are listed here.

Methods
Methods
Name | Description
ListParameters | Method that displays a list of parameters that a user can choose from. When the user selects a parameter from the list, the OnSelectParameter event fires.
Measure | Method that invokes the 'Measure' command and prompts the user to select entities for measure. The OnMeasure event fires as a result of the user action.
ShowDimensions | Method that invokes the 'show dimensions' command, prompting the user to select a feature to show the dimensions for.
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Methods


MeasureEventsObject.ListParameters Method

MeasureEventsObject.ListParameters Method Available in Inventor Introduced in Inventor 2009
Summary

Method that displays a list of parameters that a user can choose from. When the user selects a parameter from the list, the OnSelectParameter event fires.

Visual Basic
Sub ListParameters(ByRef ScreenPosition As [optional] VARIANT, ByRef Component As [optional] VARIANT, ByRef DisplayAllParameters As [defaultvalue(0)] VARIANT_BOOL, ByRef hWnd As [defaultvalue(0)] long)
Parameters
Parameters | Description
ScreenPosition | Optional input Point2d object that specifies the location for the parameter list dialog on the screen. This should typically be adjacent to the edit control where the user chose the 'List Parameters' option. If not supplied, the dialog is displayed at the center of the screen.
Component | Optional input object that specifies the component from which to populate the parameters list from. This can either be a ComponentDefinition object or a FlatPattern object. If not specified, the parameters from the currently active component are displayed.
DisplayAllParameters | Optional input Boolean that specifies whether to display all the parameters from the component or only the renamed and user parameters. The default behavior (which is also the predominant behavior in Inventor) is to display only the renamed and user parameters.
HWND | Optional input Long that specifies the hwnd of the parent dialog that is launching the ListParameters dialog. If not specified, the active Inventor application's hwnd is used.
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Methods > MeasureEventsObject.ListParameters Method


MeasureEventsObject.Measure Method

MeasureEventsObject.Measure Method Available in Inventor Introduced in Inventor 2009
Summary

Method that invokes the 'Measure' command and prompts the user to select entities for measure. The OnMeasure event fires as a result of the user action.

Visual Basic
Sub Measure(MeasureType As MeasureTypeEnum, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
MeasureType | Input MeasureTypeEnum that indicates the type of measure action to invoke. Valid values are kDistanceMeasure and kAngleMeasure.
Options | Optional input specifying additional options for measure. Currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Methods > MeasureEventsObject.Measure Method


MeasureEventsObject.ShowDimensions Method

MeasureEventsObject.ShowDimensions Method Available in Inventor Introduced in Inventor 2009
Summary

Method that invokes the 'show dimensions' command, prompting the user to select a feature to show the dimensions for.

Visual Basic
Sub ShowDimensions()
Remarks

The method returns an error if the Enabled property is set to False. When the user selects a dimension, the OnSelectParameter event fires.

You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Methods > MeasureEventsObject.ShowDimensions Method


MeasureEventsObject Properties

MeasureEventsObject Properties
Summary

The properties of the MeasureEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Enabled | Property that gets and sets whether MeasureEvents is enabled. Defaults to False. This property should be set to True when the relevant field in the command's dialog gets focus and should be set to False when it loses focus.
Parent | Property that returns the parent InteractionEvents object.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Properties


MeasureEventsObject.Application Property

MeasureEventsObject.Application Property Available in Inventor Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Properties > MeasureEventsObject.Application Property


MeasureEventsObject.Enabled Property

MeasureEventsObject.Enabled Property Available in Inventor Introduced in Inventor 2009
Summary

Property that gets and sets whether MeasureEvents is enabled. Defaults to False. This property should be set to True when the relevant field in the command's dialog gets focus and should be set to False when it loses focus.

Visual Basic
Property Enabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Properties > MeasureEventsObject.Enabled Property


MeasureEventsObject.Parent Property

MeasureEventsObject.Parent Property Available in Inventor Introduced in Inventor 2009
Summary

Property that returns the parent InteractionEvents object.

Visual Basic
Property Parent() As InteractionEvents**
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Properties > MeasureEventsObject.Parent Property


MeasureEventsObject.Type Property

MeasureEventsObject.Type Property Available in Inventor Introduced in Inventor 2009
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsObject Interface > MeasureEventsObject Properties > MeasureEventsObject.Type Property


MeasureEventsSink Interface

MeasureEventsSink Interface Available in Inventor Introduced in Inventor 2009
Summary

The MeasureEvents object provides the ability to invoke the measure and show dimension commands during InteractionEvents.

Class Hierarchy
Inventor::MeasureEventsSink
Visual Basic
Public Interface MeasureEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsSink Interface


MeasureEventsSink Methods

MeasureEventsSink Methods
Summary

The methods of the MeasureEventsSink class are listed here.

Methods
Methods
Name | Description
OnMeasure | Event that fires when the user selects entities for measure..
OnSelectParameter | Event that fires when the user selects a parameter. The selected object can be a feature dimension, a 2d sketch dimension, a 3d sketch dimension or a parameter from the parameters list box.
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsSink Interface > MeasureEventsSink Methods


MeasureEventsSink.OnMeasure Method

MeasureEventsSink.OnMeasure Method Available in Inventor Introduced in Inventor 2009
Summary

Event that fires when the user selects entities for measure..

Visual Basic
Sub OnMeasure(MeasureType As MeasureTypeEnum, MeasuredValue As double, Context As NameValueMap)
Parameters
Parameters | Description
MeasureType | Input MeasureTypeEnum that indicates the type of measure action. Possible values are kDistanceMeasure and kAngleMeasure.
MeasuredValue | Input measured value returned in centimeters for kDistanceMeasure and in radians for kAngleMeasure.
Context | Currently empty.
Example

"Using measure events"

This sample demonstrates using the measure events to measure distance and angle. Interactive measure is dependent on events and VB only supports events within a class module. To use the sample copy the InteractiveMeasureDistance and InteractiveMeasureAngle subs into a code module. Create a new class module called clsMeasure and copy all of the rest of the code into it. To run the sample, have a document open that contains some geometry and run the InteractiveMeasureDistance and InteractiveMeasureAngle subs.

Public Sub InteractiveMeasureDistance()

    ' Create a new clsMeasure object.
    Dim oMeasure As New clsMeasure

    ' Call the Measure method of the clsMeasure object
    Call oMeasure.Measure(kDistanceMeasure)

End Sub

Public Sub InteractiveMeasureAngle()

    ' Create a new clsMeasure object.
    Dim oMeasure As New clsMeasure

    ' Call the Measure method of the clsMeasure object
    Call oMeasure.Measure(kAngleMeasure)
End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsMeasure". The name can be
' changed but you'll need to change the declaration in the
' calling function "InteractiveMeasureDistance" and
' "InteractiveMeasureAngle" to use the new name.

' Declare the event objects
Private WithEvents oInteractEvents As InteractionEvents
Private WithEvents oMeasureEvents As MeasureEvents

' Declare a flag that's used to determine when measuring stops.
Private bStillMeasuring As Boolean
Private eMeasureType As MeasureTypeEnum

Public Sub Measure(MeasureType As MeasureTypeEnum)

    eMeasureType = MeasureType

    ' Initialize flag.
    bStillMeasuring = True

    ' Create an InteractionEvents object.
    Set oInteractEvents = ThisApplication.CommandManager.CreateInteractionEvents

    ' Set a reference to the measure events.
    Set oMeasureEvents = oInteractEvents.MeasureEvents
    oMeasureEvents.Enabled = True

    ' Start the InteractionEvents object.
    oInteractEvents.Start

    ' Start measure tool
    If eMeasureType = kDistanceMeasure Then
        oMeasureEvents.Measure kDistanceMeasure
    Else
        oMeasureEvents.Measure kAngleMeasure
    End If

    ' Loop until a selection is made.
    Do While bStillMeasuring
        DoEvents
    Loop

    ' Stop the InteractionEvents object.
    oInteractEvents.Stop

    ' Clean up.
    Set oMeasureEvents = Nothing
    Set oInteractEvents = Nothing
End Sub

Private Sub oInteractEvents_OnTerminate()
    ' Set the flag to indicate we're done.
    bStillMeasuring = False
End Sub

Private Sub oMeasureEvents_OnMeasure(ByVal MeasureType As MeasureTypeEnum, ByVal MeasuredValue As Double, ByVal Context As NameValueMap)

    Dim strMeasuredValue As String

    If eMeasureType = kDistanceMeasure Then
        strMeasureValue = ThisApplication.ActiveDocument.UnitsOfMeasure.GetStringFromValue(MeasuredValue, kDefaultDisplayLengthUnits)
        MsgBox "Distance = " & strMeasureValue, vbOKOnly, "Measure Distance"
    Else
        strMeasureValue = ThisApplication.ActiveDocument.UnitsOfMeasure.GetStringFromValue(MeasuredValue, kDefaultDisplayAngleUnits)
        MsgBox "Angle = " & strMeasureValue, vbOKOnly, "Measure Angle"
    End If

    ' Set the flag to indicate we're done.
    bStillMeasuring = False

End Sub
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsSink Interface > MeasureEventsSink Methods > MeasureEventsSink.OnMeasure Method


MeasureEventsSink.OnSelectParameter Method

MeasureEventsSink.OnSelectParameter Method Available in Inventor Introduced in Inventor 2009
Summary

Event that fires when the user selects a parameter. The selected object can be a feature dimension, a 2d sketch dimension, a 3d sketch dimension or a parameter from the parameters list box.

Visual Basic
Sub OnSelectParameter(Parameter As Parameter, Context As NameValueMap)
Parameters
Parameters | Description
Parameter | Input Parameter object selected by the user. This parameter can either be associated with a dimension or could be a parameter created by the user or via the API.
Context | Currently empty.
You are here: Symbol Reference > Inventor Library > Objects > MeasureEventsSink Interface > MeasureEventsSink Methods > MeasureEventsSink.OnSelectParameter Method


MeasureTools Interface

MeasureTools Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The MeasureTools object provides methods for various measurement related utilities.

Class Hierarchy
Inventor::MeasureTools
Visual Basic
Public Interface MeasureTools
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.MeasureTools

You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface


MeasureTools Methods

MeasureTools Methods
Summary

The methods of the MeasureTools class are listed here.

Methods
Methods
Name | Description
GetAngle | Method that returns the angle between the input entities. The input entities must all belong to the same document, unless they are transient objects.
GetLoopLength | Method that returns the total length of a loop.
GetMinimumDistance | Method that returns the minimum distance between the two input entities and also returns the closest points associated with both entities (not necessarily on the entity).
You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Methods


MeasureTools.GetAngle Method

MeasureTools.GetAngle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the angle between the input entities. The input entities must all belong to the same document, unless they are transient objects.

Visual Basic
Sub GetAngle(EntityOne As IDispatch, EntityTwo As IDispatch, ByRef EntityThree As [optional] VARIANT, Result As [out, retval] double)
Parameters
Parameters | Description
EntityOne | Object that specifies the first entity. Valid inputs include Face, Edge, Vertex, transient objects (Point, Plane, Cylinder, etc.), work features, 2d & 3d sketch entities, DrawingViewCurve and GeometryIntent objects. Proxy object inputs are supported for assembly documents. For spherical and circular entity inputs, the center is assumed. For cylindrical and conical inputs, the axis is assumed. For toroidal inputs, the axis is assumed, unless the third argument of the method is also supplied in which case the center is assumed. For position inputs (such as Vertex, WorkPoint, Point, etc.) to be valid, all three inputs to the method should be supplied and they must all be position inputs (this implies a 3-point angle measurement).
EntityTwo | Input object that specifies the second entity. Valid inputs include Face, Edge, Vertex, transient objects (Point, Plane, Cylinder, etc.), work features, 2d & 3d sketch entities, DrawingViewCurve and GeometryIntent objects. Proxy object inputs are supported for assembly documents. For spherical and circular entity inputs, the center is assumed. For cylindrical and conical inputs, the axis is assumed. For toroidal inputs, the axis is assumed, unless the third argument of the method is also supplied in which case the center is assumed. For position inputs (such as Vertex, WorkPoint, Point, etc.) to be valid, all three inputs to the method should be supplied and they must all be position inputs (this implies a 3-point angle measurement).
EntityThree | Optional input object that specifies the third entity for a 3-point angle measurement. Valid inputs include spherical & toroidal Face, Vertex, transient objects defining a position (Point, Sphere, etc.), work points, 2d & 3d sketch points, and GeometryIntent objects. Proxy object inputs are supported for assembly documents.
You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Methods > MeasureTools.GetAngle Method


MeasureTools.GetLoopLength Method

MeasureTools.GetLoopLength Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the total length of a loop.

Visual Basic
Sub GetLoopLength(Curves As IDispatch, Result As [out, retval] double)
Parameters
Parameters
Description
Curves
Object that specifies the loop. Valid inputs are:

  • An Edge object
  • A 2d/3d sketch curve (SketchLine, SketchArc, etc.)

(For the above inputs, the method returns the length of the loop that the input entity is a part of (whether open or closed). Based on the input, the method looks for a unique closed loop or a unique open loop (in that order). If one is found, the length is returned else the method returns an error.)

  • An ObjectCollection containing Edge objects or 2d/3d sketch curve objects.

(The collection can contain all the elements of a loop or must contain enough number of elements to uniquely identify a loop. Else the method returns an error. Also, the input curves must be end to end connected and in order.)

  • An EdgeLoop object
  • A ProfilePath object
  • A ProfilePath3D object

You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Methods > MeasureTools.GetLoopLength Method


MeasureTools.GetMinimumDistance Method

MeasureTools.GetMinimumDistance Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the minimum distance between the two input entities and also returns the closest points associated with both entities (not necessarily on the entity).

Visual Basic
Sub GetMinimumDistance(EntityOne As IDispatch, EntityTwo As IDispatch, ByRef EntityOneInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef EntityTwoInferredType As [defaultvalue(kNoInference)] InferredTypeEnum, ByRef Context As [optional] VARIANT, Result As [out, retval] double)
Parameters
Parameters
Description
EntityOne
Object that specifies the first entity.
EntityTwo
Object that specifies the second entity.
EntityOneInferredType
Optional input InferredTypeEnum that specifies how the geometry of entity one is to be interpreted. Depending on the geometry of the entity one, different options are possible.

  • If entity one is a cylinder this can be either kNoInference (cylindrical

surface) or kInferredLine (axis).

  • If entity one is a sphere this can be either kNoInference (spherical

surface) or kInferredPoint (center).

  • If entity one is a cone this can be either kNoInference (conical surface)

or kInferredLine (axis).

  • If entity one is a torus this can be either kInferredLine (axis) or

kInferredPoint (center).

  • If entity one is a circular or elliptical curve this can be either

kNoInference (the curve) or kInferredPoint (center).

  • For all other inputs, only kNoInference is valid.

EntityTwoInferredType
Optional input InferredTypeEnum that specifies how the geometry of entity two is to be interpreted. Depending on the geometry of the entity two, different options are possible.

  • If entity two is a cylinder this can be either kNoInference (cylindrical

surface) or kInferredLine (axis).

  • If entity two is a sphere this can be either kNoInference (spherical

surface) or kInferredPoint (center).

  • If entity two is a cone this can be either kNoInference (conical surface)

or kInferredLine (axis).

  • If entity two is a torus this can be either kInferredLine (axis) or

kInferredPoint (center).

  • If entity two is a circular or elliptical curve this can be either

kNoInference (the curve) or kInferredPoint (center).

  • For all other inputs, only kNoInference is valid.

Context
Optional output NameValueMap object that returns additional information regarding the measurement. Following are the possible return values (descriptions are below the table):
Name Value Type
ClosestPointOne Point object that returns a transient point closest to entity one in the minimum distance measure. This point may or may not lie on entity one (but will lie on the plane or axis of entity one). If entity one is a position input (Point, Vertex, WorkPoint, etc.), the position of the input entity is returned
ClosestPointTwo Point object that returns a transient point closest to entity two in the minimum distance measure. This point may or may not lie on entity two (but will lie on the plane or axis of entity two). If entity two is a position input (Point, Vertex, WorkPoint, etc.), the position of the input entity is returned
ClosestEntityOne Object type that returns the entity on which the returned ClosestPointOne lies. This is applicable only in the case where the input EntityOne is a ComponentOccurrence (or itG's proxy)
ClosestEntityTwo Object type that returns the entity on which the returned ClosestPointTwo lies. This is applicable only in the case where the input EntityTwo is a ComponentOccurrence (or itG's proxy)
IntersectionFound Boolean that indicates whether an intersection was found between entities one and two. If True, the method returns a value of 0
Remarks

The two input entities must belong to the same document, unless they are transient objects. A value of 0 is returned if an intersection is found. The following are the valid entities for minimum distance measure based on the document type:

Document type | Valid entities
All (and with no documents open) | Transient objects ( Point, Line, Plane, Cylinder, BSplineSurface, etc.)
Part | Face, Edge, Vertex, work features, 2d and 3d sketch entities
Assembly | FaceProxy, EdgeProxy, VertexProxy, work features & their proxies, 2d & 3d sketch entities & their proxies, ComponentOccurrences and their proxies
Drawing | DrawingViewCurve, GeometryIntent, 2d sketch entities
See Also

Finding Bend Extent (Tangent) Edges sample

You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Methods > MeasureTools.GetMinimumDistance Method


MeasureTools Properties

MeasureTools Properties
Summary

The properties of the MeasureTools class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Parent | Property that returns the parent object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Type | Property returning kMeasureToolsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Properties


MeasureTools.Application Property

MeasureTools.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Properties > MeasureTools.Application Property


MeasureTools.Parent Property

MeasureTools.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Properties > MeasureTools.Parent Property


MeasureTools.Type Property

MeasureTools.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kMeasureToolsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MeasureTools Interface > MeasureTools Properties > MeasureTools.Type Property


MessageSection Interface

MessageSection Interface Available in Inventor Introduced in Inventor 2010
Summary

A MessageSection object can be used to clear, adopt or retain error/warning messages created during the section.

Class Hierarchy
Inventor::MessageSection
Visual Basic
Public Interface MessageSection
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ErrorManager.StartMessageSection

See Also

Display custom error messages sample

Using Inventor's error dialog sample

You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface


MessageSection Methods

MessageSection Methods
Summary

The methods of the MessageSection class are listed here.

Methods
Methods
Name | Description
AdoptMessages | Method that adopts all messages within this section under the specified message and terminates the section.
ClearMessages | Method that clears all messages within this section and terminates the section.
End | Method that retains all the messages within this section as is and terminates the section. Calling this method is not required if either the ClearMessages or the AdoptMessages method has been called.
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Methods


MessageSection.AdoptMessages Method

MessageSection.AdoptMessages Method Available in Inventor Introduced in Inventor 2010
Summary

Method that adopts all messages within this section under the specified message and terminates the section.

Visual Basic
Sub AdoptMessages(Message As String, Error As VARIANT_BOOL, ByRef Reserved As [optional] VARIANT)
Parameters
Parameters | Description
Message | Input String that specifies the error or warning message to be used as the parent of existing messages.
Error | Input Boolean that specifies whether this is an error or a warning. True indicates error.
Reserved | Optional input Variant reserved for future use. Currently unused.
See Also

Display custom error messages sample

Using Inventor's error dialog sample

You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Methods > MessageSection.AdoptMessages Method


MessageSection.ClearMessages Method

MessageSection.ClearMessages Method Available in Inventor Introduced in Inventor 2010
Summary

Method that clears all messages within this section and terminates the section.

Visual Basic
Sub ClearMessages()
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Methods > MessageSection.ClearMessages Method


MessageSection.End Method

MessageSection.End Method Available in Inventor Introduced in Inventor 2010
Summary

Method that retains all the messages within this section as is and terminates the section. Calling this method is not required if either the ClearMessages or the AdoptMessages method has been called.

Visual Basic
Sub End()
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Methods > MessageSection.End Method


MessageSection Properties

MessageSection Properties
Summary

The properties of the MessageSection class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
HasErrors | Property that returns whether this message section has any errors reported in it.
HasWarnings | Property that returns whether this message section has any warnings reported in it.
Parent | Property that returns the parent ErrorManager object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Properties


MessageSection.Application Property

MessageSection.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Properties > MessageSection.Application Property


MessageSection.HasErrors Property

MessageSection.HasErrors Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether this message section has any errors reported in it.

Visual Basic
Property HasErrors() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Properties > MessageSection.HasErrors Property


MessageSection.HasWarnings Property

MessageSection.HasWarnings Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether this message section has any warnings reported in it.

Visual Basic
Property HasWarnings() As VARIANT_BOOL*
See Also

Using Inventor's error dialog sample

You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Properties > MessageSection.HasWarnings Property


MessageSection.Parent Property

MessageSection.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent ErrorManager object.

Visual Basic
Property Parent() As ErrorManager**
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Properties > MessageSection.Parent Property


MessageSection.Type Property

MessageSection.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MessageSection Interface > MessageSection Properties > MessageSection.Type Property


MidpointConstraint Interface

MidpointConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The MidpointConstraint object represents a constraint that connects a sketch point to the midpoint of a sketch line.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::MidpointConstraint
        Inventor::MidpointConstraintProxy
Visual Basic
Public Interface MidpointConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddMidpoint

MidpointConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint Interface


MidpointConstraint Properties

MidpointConstraint Properties
Summary

The properties of the MidpointConstraint class are listed here.

Properties
Name | Description
Line | Property that returns the sketch line being constrained.
Point | Property that returns the sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint Interface > MidpointConstraint Properties


MidpointConstraint.Line Property

MidpointConstraint.Line Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch line being constrained.

Visual Basic
Property Line() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint Interface > MidpointConstraint Properties > MidpointConstraint.Line Property


MidpointConstraint.Point Property

MidpointConstraint.Point Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch point being constrained.

Visual Basic
Property Point() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint Interface > MidpointConstraint Properties > MidpointConstraint.Point Property


MidpointConstraint3D Interface

MidpointConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The MidpointConstraint3D object represents a constraint that connects a sketch point to the midpoint of a sketch line.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::MidpointConstraint3D
        Inventor::MidpointConstraint3DProxy
Visual Basic
Public Interface MidpointConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.AddMidpoint

MidpointConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3D Interface


MidpointConstraint3D Properties

MidpointConstraint3D Properties
Summary

The properties of the MidpointConstraint3D class are listed here.

Properties
Name | Description
Line | Property that returns the sketch line being constrained.
Point | Property that returns the sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3D Interface > MidpointConstraint3D Properties


MidpointConstraint3D.Line Property

MidpointConstraint3D.Line Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the sketch line being constrained.

Visual Basic
Property Line() As SketchLine3D**
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3D Interface > MidpointConstraint3D Properties > MidpointConstraint3D.Line Property


MidpointConstraint3D.Point Property

MidpointConstraint3D.Point Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the sketch point being constrained.

Visual Basic
Property Point() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3D Interface > MidpointConstraint3D Properties > MidpointConstraint3D.Point Property


MidpointConstraint3DProxy Interface

MidpointConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MidpointConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::MidpointConstraint3D
        Inventor::MidpointConstraint3DProxy
Visual Basic
Public Interface MidpointConstraint3DProxy
Inherits MidpointConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3DProxy Interface


MidpointConstraint3DProxy Properties

MidpointConstraint3DProxy Properties
Summary

The properties of the MidpointConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3DProxy Interface > MidpointConstraint3DProxy Properties


MidpointConstraint3DProxy.ContainingOccurrence Property

MidpointConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3DProxy Interface > MidpointConstraint3DProxy Properties > MidpointConstraint3DProxy.ContainingOccurrence Property


MidpointConstraint3DProxy.NativeObject Property

MidpointConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As MidpointConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraint3DProxy Interface > MidpointConstraint3DProxy Properties > MidpointConstraint3DProxy.NativeObject Property


MidpointConstraintProxy Interface

MidpointConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MidpointConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::MidpointConstraint
        Inventor::MidpointConstraintProxy
Visual Basic
Public Interface MidpointConstraintProxy
Inherits MidpointConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraintProxy Interface


MidpointConstraintProxy Properties

MidpointConstraintProxy Properties
Summary

The properties of the MidpointConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraintProxy Interface > MidpointConstraintProxy Properties


MidpointConstraintProxy.ContainingOccurrence Property

MidpointConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraintProxy Interface > MidpointConstraintProxy Properties > MidpointConstraintProxy.ContainingOccurrence Property


MidpointConstraintProxy.NativeObject Property

MidpointConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As MidpointConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MidpointConstraintProxy Interface > MidpointConstraintProxy Properties > MidpointConstraintProxy.NativeObject Property


MidPointWorkPointDef Interface

MidPointWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work point defined to be at the midpoint of an edge.

Class Hierarchy
Inventor::MidPointWorkPointDef
Visual Basic
Public Interface MidPointWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MidPointWorkPointDef Interface


MidPointWorkPointDef Properties

MidPointWorkPointDef Properties
Summary

The properties of the MidPointWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Edge | Property that returns the object of a work point that is defined to be at the center of the edge. Any open edge is valid as input. Inputting a closed edge, (i.e. circle), will cause and error to occur.
Parent | Property returning the parent WorkPoint object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MidPointWorkPointDef Interface > MidPointWorkPointDef Properties


MidPointWorkPointDef.Application Property

MidPointWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MidPointWorkPointDef Interface > MidPointWorkPointDef Properties > MidPointWorkPointDef.Application Property


MidPointWorkPointDef.Edge Property

MidPointWorkPointDef.Edge Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the object of a work point that is defined to be at the center of the edge. Any open edge is valid as input. Inputting a closed edge, (i.e. circle), will cause and error to occur.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > MidPointWorkPointDef Interface > MidPointWorkPointDef Properties > MidPointWorkPointDef.Edge Property


MidPointWorkPointDef.Parent Property

MidPointWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > MidPointWorkPointDef Interface > MidPointWorkPointDef Properties > MidPointWorkPointDef.Parent Property


MidPointWorkPointDef.Type Property

MidPointWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MidPointWorkPointDef Interface > MidPointWorkPointDef Properties > MidPointWorkPointDef.Type Property


MiniToolbarButtonObject Interface

MiniToolbarButtonObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarButton object represents a button control within a MiniToolbar.

Class Hierarchy
Inventor::MiniToolbarControl
    Inventor::MiniToolbarButtonObject
Visual Basic
Public Interface MiniToolbarButtonObject
Inherits MiniToolbarControl
Remarks

MiniToolbarButton object is derived from the MiniToolbarControl object. The properties and methods below are in addition to those supported by the MiniToolbarControl object.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarButtonObject Interface


MiniToolbarButtonObject Properties

MiniToolbarButtonObject Properties
Summary

The properties of the MiniToolbarButtonObject class are listed here.

Properties
Name | Description
Pressed | Property that gets and sets whether the button is currently pressed (active).
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarButtonObject Interface > MiniToolbarButtonObject Properties


MiniToolbarButtonObject.Pressed Property

MiniToolbarButtonObject.Pressed Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the button is currently pressed (active).

Visual Basic
Property Pressed() As VARIANT_BOOL
Remarks

This state is entirely maintained by the application that created the button.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarButtonObject Interface > MiniToolbarButtonObject Properties > MiniToolbarButtonObject.Pressed Property


MiniToolbarButtonSink Interface

MiniToolbarButtonSink Interface
Summary

This is class Inventor::MiniToolbarButtonSink.

Class Hierarchy
Inventor::MiniToolbarButtonSink
Visual Basic
Public Interface MiniToolbarButtonSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarButtonSink Interface


MiniToolbarButtonSink Methods

MiniToolbarButtonSink Methods
Summary

The methods of the MiniToolbarButtonSink class are listed here.

Methods
Methods
Name | Description
OnClick | Event that is fired when the button is clicked by the user.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarButtonSink Interface > MiniToolbarButtonSink Methods


MiniToolbarButtonSink.OnClick Method

MiniToolbarButtonSink.OnClick Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the button is clicked by the user.

Visual Basic
Sub OnClick()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarButtonSink Interface > MiniToolbarButtonSink Methods > MiniToolbarButtonSink.OnClick Method


MiniToolbarCheckBoxObject Interface

MiniToolbarCheckBoxObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarCheckBox object represents a check box control within a MiniToolbar.

Class Hierarchy
Inventor::MiniToolbarControl
    Inventor::MiniToolbarCheckBoxObject
Visual Basic
Public Interface MiniToolbarCheckBoxObject
Inherits MiniToolbarControl
Remarks

The MiniToolbarCheckBox object is derived from the MiniToolbarControl object. The properties and methods below are in addition to those supported by the MiniToolbarControl object.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarCheckBoxObject Interface


MiniToolbarCheckBoxObject Properties

MiniToolbarCheckBoxObject Properties
Summary

The properties of the MiniToolbarCheckBoxObject class are listed here.

Properties
Name | Description
Checked | Property that gets and sets whether the check box is currently checked.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarCheckBoxObject Interface > MiniToolbarCheckBoxObject Properties


MiniToolbarCheckBoxObject.Checked Property

MiniToolbarCheckBoxObject.Checked Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the check box is currently checked.

Visual Basic
Property Checked() As VARIANT_BOOL
Remarks

Either the user or the application can toggle this state. The OnClick event is fired when the user toggles the state.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarCheckBoxObject Interface > MiniToolbarCheckBoxObject Properties > MiniToolbarCheckBoxObject.Checked Property


MiniToolbarCheckBoxSink Interface

MiniToolbarCheckBoxSink Interface
Summary

This is class Inventor::MiniToolbarCheckBoxSink.

Class Hierarchy
Inventor::MiniToolbarCheckBoxSink
Visual Basic
Public Interface MiniToolbarCheckBoxSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarCheckBoxSink Interface


MiniToolbarCheckBoxSink Methods

MiniToolbarCheckBoxSink Methods
Summary

The methods of the MiniToolbarCheckBoxSink class are listed here.

Methods
Methods
Name | Description
OnClick | Event that is fired when the check box is toggled by the user.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarCheckBoxSink Interface > MiniToolbarCheckBoxSink Methods


MiniToolbarCheckBoxSink.OnClick Method

MiniToolbarCheckBoxSink.OnClick Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the check box is toggled by the user.

Visual Basic
Sub OnClick()
Remarks

The Checked property can be used to find the current state of the check box.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarCheckBoxSink Interface > MiniToolbarCheckBoxSink Methods > MiniToolbarCheckBoxSink.OnClick Method


MiniToolbarComboBoxObject Interface

MiniToolbarComboBoxObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarComboBox object represents a combobox control within a MiniToolbar.

Class Hierarchy
Inventor::MiniToolbarControl
    Inventor::MiniToolbarComboBoxObject
Visual Basic
Public Interface MiniToolbarComboBoxObject
Inherits MiniToolbarControl
Remarks

The MiniToolbarComboBox object is derived from the MiniToolbarControl object. The properties and methods below are in addition to those supported by the MiniToolbarControl object.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface


MiniToolbarComboBoxObject Methods

MiniToolbarComboBoxObject Methods
Summary

The methods of the MiniToolbarComboBoxObject class are listed here.

Methods
Methods
Name | Description
AddItem | Method that adds an item to the controls list.
Clear | Method that removes all the items from the control, including any separators.
RemoveItem | Method that removes the specified item or the separator from the control.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Methods


MiniToolbarComboBoxObject.AddItem Method

MiniToolbarComboBoxObject.AddItem Method Available in Inventor Introduced in Inventor 2012
Summary

Method that adds an item to the controls list.

Visual Basic
Sub AddItem(Text As String, ToolTipText As String, ByRef InternalName As [defaultvalue("")] BSTR, ByRef AllowDelete As [defaultvalue(0)] VARIANT_BOOL, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, ByRef Index As [defaultvalue(0)] LONG, Result As [out, retval] MiniToolbarListItem*)
Parameters
Parameters | Description
Text | Input String that specifies the text for the item.
ToolTipText | Input String that specifies the tooltip text for the item. This is used as the tooltip for the control when this item is selected.
InternalName | Input String that specifies an internal name for the control. You can provide this for convenience in identifying the item at a later time. If provided, it must be unique with respect to all other items in this combo box.
AllowDelete | Optional input Boolean that specifies whether the user can delete this item from the combobox.
StandardIcon | Optional input IPictureDisp that specifies the icon to use for the item. A standard size icon is 16 pixels wide and 16 pixels high.
LargeIcon | Optional input IPictureDisp that specifies the large icon to use for the item. A large size icon is 24 pixels wide and 24 pixels high.
Index | Optional input Long value that specifies the 1-based index at which to add the item. If not specified, the item is added at the end.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Methods > MiniToolbarComboBoxObject.AddItem Method


MiniToolbarComboBoxObject.Clear Method

MiniToolbarComboBoxObject.Clear Method Available in Inventor Introduced in Inventor 2012
Summary

Method that removes all the items from the control, including any separators.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Methods > MiniToolbarComboBoxObject.Clear Method


MiniToolbarComboBoxObject.RemoveItem Method

MiniToolbarComboBoxObject.RemoveItem Method Available in Inventor Introduced in Inventor 2012
Summary

Method that removes the specified item or the separator from the control.

Visual Basic
Sub RemoveItem(Index As VARIANT)
Parameters
Parameters | Description
Index | Input Variant value that specifies the item to remove. This can be a numeric value indicating the index of the item in the list or it can be the ListItem object to be removed. If an out of range index is provided or an invalid ListItem object is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Methods > MiniToolbarComboBoxObject.RemoveItem Method


MiniToolbarComboBoxObject Properties

MiniToolbarComboBoxObject Properties
Summary

The properties of the MiniToolbarComboBoxObject class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified item from the list.
Properties
Name | Description
Count | Property that returns the number of items in the combobox, including separators.
SelectedIndex | Property that gets and set the index of the item currently selected.
SelectedItem | Property that returns the item currently selected.
ShowIcon | Property that gets and sets whether the icon associated with the currently selected item should be displayed on the face of the control.
ShowText | Property that gets and sets whether the display name associated with the currently selected item should be displayed on the face of the control.
Width | Property that gets and sets the width of the combobox in pixels.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties


MiniToolbarComboBoxObject.Count Property

MiniToolbarComboBoxObject.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the number of items in the combobox, including separators.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.Count Property


MiniToolbarComboBoxObject.Item Method

MiniToolbarComboBoxObject.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the specified item from the list.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] MiniToolbarListItem*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the item to return. This can be a numeric value indicating the index of the item in the combobox or it can be a string that is the internal name of the item. If an out of range index is provided or a name that doesn’t exist, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.Item Method


MiniToolbarComboBoxObject.SelectedIndex Property

MiniToolbarComboBoxObject.SelectedIndex Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and set the index of the item currently selected.

Visual Basic
Property SelectedIndex() As long
Remarks

The first item in the list has an index of 1. Setting this to a value greater than Count will fail. Setting this property to zero will remove all selections.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.SelectedIndex Property


MiniToolbarComboBoxObject.SelectedItem Property

MiniToolbarComboBoxObject.SelectedItem Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the item currently selected.

Visual Basic
Property SelectedItem() As MiniToolbarListItem**
Remarks

This can return Nothing in the case were no item is selected.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.SelectedItem Property


MiniToolbarComboBoxObject.ShowIcon Property

MiniToolbarComboBoxObject.ShowIcon Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the icon associated with the currently selected item should be displayed on the face of the control.

Visual Basic
Property ShowIcon() As VARIANT_BOOL
Remarks

This property defaults to False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.ShowIcon Property


MiniToolbarComboBoxObject.ShowText Property

MiniToolbarComboBoxObject.ShowText Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the display name associated with the currently selected item should be displayed on the face of the control.

Visual Basic
Property ShowText() As VARIANT_BOOL
Remarks

This property defaults to True.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.ShowText Property


MiniToolbarComboBoxObject.Width Property

MiniToolbarComboBoxObject.Width Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the width of the combobox in pixels.

Visual Basic
Property Width() As long
Remarks

This is the width of the control as displayed in the MiniToolbar.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxObject Interface > MiniToolbarComboBoxObject Properties > MiniToolbarComboBoxObject.Width Property


MiniToolbarComboBoxSink Interface

MiniToolbarComboBoxSink Interface
Summary

This is class Inventor::MiniToolbarComboBoxSink.

Class Hierarchy
Inventor::MiniToolbarComboBoxSink
Visual Basic
Public Interface MiniToolbarComboBoxSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface


MiniToolbarComboBoxSink Methods

MiniToolbarComboBoxSink Methods
Summary

The methods of the MiniToolbarComboBoxSink class are listed here.

Methods
Methods
Name | Description
OnItemHoverEnd | Event that is fired when the user stops hovering over an item in the combo box in the expanded state.
OnItemHoverStart | Event that is fired when the user starts to hover over an item in the combo box in the expanded state.
OnItemRemove | Event that is fired when the user removes an item from the combobox.
OnPreMenuDisplay | Event that is fired when the user clicks the combobox.
OnSelect | Event that is fired after the user selects an item from the drop down list.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface > MiniToolbarComboBoxSink Methods


MiniToolbarComboBoxSink.OnItemHoverEnd Method

MiniToolbarComboBoxSink.OnItemHoverEnd Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user stops hovering over an item in the combo box in the expanded state.

Visual Basic
Sub OnItemHoverEnd(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input ListItem that indicates the item the user has stopped hovering over.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface > MiniToolbarComboBoxSink Methods > MiniToolbarComboBoxSink.OnItemHoverEnd Method


MiniToolbarComboBoxSink.OnItemHoverStart Method

MiniToolbarComboBoxSink.OnItemHoverStart Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user starts to hover over an item in the combo box in the expanded state.

Visual Basic
Sub OnItemHoverStart(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input ListItem that indicates the item the user has started hovering over.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface > MiniToolbarComboBoxSink Methods > MiniToolbarComboBoxSink.OnItemHoverStart Method


MiniToolbarComboBoxSink.OnItemRemove Method

MiniToolbarComboBoxSink.OnItemRemove Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user removes an item from the combobox.

Visual Basic
Sub OnItemRemove(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input ListItem that indicates the item being deleted.
Remarks

This event is fired just before the item is deleted so any queries on the contents of the combo box will include this item.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface > MiniToolbarComboBoxSink Methods > MiniToolbarComboBoxSink.OnItemRemove Method


MiniToolbarComboBoxSink.OnPreMenuDisplay Method

MiniToolbarComboBoxSink.OnPreMenuDisplay Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user clicks the combobox.

Visual Basic
Sub OnPreMenuDisplay()
Remarks

The event is fired just before the contents of the combo box are shown to the user, so you can dynamically modify the contents of the list.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface > MiniToolbarComboBoxSink Methods > MiniToolbarComboBoxSink.OnPreMenuDisplay Method


MiniToolbarComboBoxSink.OnSelect Method

MiniToolbarComboBoxSink.OnSelect Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired after the user selects an item from the drop down list.

Visual Basic
Sub OnSelect(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input ListItem that indicates the item just selected.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarComboBoxSink Interface > MiniToolbarComboBoxSink Methods > MiniToolbarComboBoxSink.OnSelect Method


MiniToolbarControl Interface

MiniToolbarControl Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarControl object is the base class for all controls within a MiniToolbar.

Class Hierarchy
Inventor::MiniToolbarControl
    Inventor::MiniToolbarButtonObject
    Inventor::MiniToolbarCheckBoxObject
    Inventor::MiniToolbarComboBoxObject
    Inventor::MiniToolbarDropdownObject
    Inventor::MiniToolbarValueEditorObject
Visual Basic
Public Interface MiniToolbarControl
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface


MiniToolbarControl Methods

MiniToolbarControl Methods
Summary

The methods of the MiniToolbarControl class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the control.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Methods


MiniToolbarControl.Delete Method

MiniToolbarControl.Delete Method Available in Inventor Introduced in Inventor 2012
Summary

Method that deletes the control.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Methods > MiniToolbarControl.Delete Method


MiniToolbarControl Properties

MiniToolbarControl Properties
Summary

The properties of the MiniToolbarControl class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
AutoHide | Property that gets and sets whether the control should be automatically hidden when the user moves the cursor away from the MiniToolbar.
ControlType | Property that returns the control type.
DisplayName | Property that gets and sets the display name for the control.
Enabled | Property that gets and sets whether the control is enabled.
Index | Property that returns the index this control is currently positioned at within the mini toolbar.
InternalName | Property that returns a string uniquely identifying this control within the toolbar.
LargeIcon | Property that gets and sets the large icon for the control.
Parent | Property that returns the parent MiniToolbar object.
StandardIcon | Property that gets and sets the standard (small) icon for the control.
ToolTipText | Property that gets and sets the tooltip text for the control.
Type | Property returning kMiniToolbarControlObject indicating this object’s type.
Visible | Property that gets and sets whether the control is visible.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties


MiniToolbarControl.Application Property

MiniToolbarControl.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.Application Property


MiniToolbarControl.AutoHide Property

MiniToolbarControl.AutoHide Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the control should be automatically hidden when the user moves the cursor away from the MiniToolbar.

Visual Basic
Property AutoHide() As VARIANT_BOOL
Remarks

This property defaults to False when the control is created.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.AutoHide Property


MiniToolbarControl.ControlType Property

MiniToolbarControl.ControlType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the control type.

Visual Basic
Property ControlType() As MiniToolbarControlTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.ControlType Property


MiniToolbarControl.DisplayName Property

MiniToolbarControl.DisplayName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the display name for the control.

Visual Basic
Property DisplayName() As String
Remarks

This property returns a null string if the control does not have a display name.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.DisplayName Property


MiniToolbarControl.Enabled Property

MiniToolbarControl.Enabled Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the control is enabled.

Visual Basic
Property Enabled() As VARIANT_BOOL
Remarks

This property defaults to True when the control is created.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.Enabled Property


MiniToolbarControl.Index Property

MiniToolbarControl.Index Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the index this control is currently positioned at within the mini toolbar.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.Index Property


MiniToolbarControl.InternalName Property

MiniToolbarControl.InternalName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns a string uniquely identifying this control within the toolbar.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.InternalName Property


MiniToolbarControl.LargeIcon Property

MiniToolbarControl.LargeIcon Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the large icon for the control.

Visual Basic
Property LargeIcon() As IPictureDisp*
Remarks

A large size icon is 24 pixels wide and 24 pixels high. This property returns nothing if the control does not have an associated large icon. Setting this property to Nothing will remove the icon.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.LargeIcon Property


MiniToolbarControl.Parent Property

MiniToolbarControl.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent MiniToolbar object.

Visual Basic
Property Parent() As MiniToolbar**
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.Parent Property


MiniToolbarControl.StandardIcon Property

MiniToolbarControl.StandardIcon Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the standard (small) icon for the control.

Visual Basic
Property StandardIcon() As IPictureDisp*
Remarks

A standard size icon is 16 pixels wide and 16 pixels high. This property returns nothing if the control does not have an associated standard icon. Setting this property to Nothing will remove the icon.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.StandardIcon Property


MiniToolbarControl.ToolTipText Property

MiniToolbarControl.ToolTipText Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the tooltip text for the control.

Visual Basic
Property ToolTipText() As String
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.ToolTipText Property


MiniToolbarControl.Type Property

MiniToolbarControl.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kMiniToolbarControlObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.Type Property


MiniToolbarControl.Visible Property

MiniToolbarControl.Visible Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the control is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

This property defaults to True when the control is created.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControl Interface > MiniToolbarControl Properties > MiniToolbarControl.Visible Property


MiniToolbarControls Interface

MiniToolbarControls Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarControls object contains the controls within a minitoolbar and methods to create new controls.

Class Hierarchy
Inventor::MiniToolbarControls
Visual Basic
Public Interface MiniToolbarControls
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface


MiniToolbarControls Methods

MiniToolbarControls Methods
Summary

The methods of the MiniToolbarControls class are listed here.

Methods
Methods
Name | Description
AddButton | Method that creates a new button control within the MiniToolbar.
AddCheckBox | Method that creates a new check box control within the MiniToolbar.
AddComboBox | Method that creates a new combobox control within the MiniToolbar.
AddDropdown | Method that creates a new dropdown control within the MiniToolbar.
AddLabel | Method that creates a new label control within the MiniToolbar.
AddNewLine | Method that creates a new line within the MiniToolbar.
AddSeparator | Method that creates a new separator within the MiniToolbar.
AddValueEditor | Method that creates a new value edit control within the MiniToolbar.
Item | Property that returns the specified MiniToolbarControl object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods


MiniToolbarControls.AddButton Method

MiniToolbarControls.AddButton Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new button control within the MiniToolbar.

Visual Basic
Sub AddButton(InternalName As String, DisplayName As String, ToolTipText As String, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, Result As [out, retval] MiniToolbarButton*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control.
DisplayName | Input String that specifies a display name for the control. If this is specified to be a null string, the control does not display any text.
ToolTipText | Input String that specifies the tooltip text for the control.
StandardIcon | Optional input IPictureDisp that specifies the icon to use for the control. A standard size icon is 16 pixels wide and 16 pixels high.
LargeIcon | Optional input IPictureDisp that specifies the large icon to use for the control. A large size icon is 24 pixels wide and 24 pixels high.
Remarks

The newly created MiniToolbarButton is returned.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddButton Method


MiniToolbarControls.AddCheckBox Method

MiniToolbarControls.AddCheckBox Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new check box control within the MiniToolbar.

Visual Basic
Sub AddCheckBox(InternalName As String, DisplayName As String, ToolTipText As String, Checked As VARIANT_BOOL, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, Result As [out, retval] MiniToolbarCheckBox*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control.
DisplayName | Input String that specifies a display name for the control. If this is specified to be a null string, the control does not display any text.
ToolTipText | Input String that specifies the tooltip text for the control.
Checked | Input Boolean that specifies whether to initially display the control as checked.
StandardIcon | Optional input IPictureDisp that specifies the icon to use for the control. A standard size icon is 16 pixels wide and 16 pixels high.
LargeIcon | Optional input IPictureDisp that specifies the large icon to use for the control. A large size icon is 24 pixels wide and 24 pixels high.
Remarks

The newly created MiniToolbarCheckBox is returned.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddCheckBox Method


MiniToolbarControls.AddComboBox Method

MiniToolbarControls.AddComboBox Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new combobox control within the MiniToolbar.

Visual Basic
Sub AddComboBox(InternalName As String, ByRef ShowIcon As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(-1)] VARIANT_BOOL, ByRef Width As [defaultvalue(0)] long, Result As [out, retval] MiniToolbarComboBox*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control.
ShowIcon | Optional input Boolean that specifies whether the icon associated with the currently selected item should be displayed on the face of the control.
ShowText | Optional input Boolean that specifies whether the text associated with the currently selected item should be displayed on the face of the control.
Width | Optional input Long that specifies the width of the control in pixels. If not specified, the default internal value is used. Note: The width and height of the dropdown area of the control are automatically calculated based on the contents.
Remarks

The newly created MiniToolbarComboBox is returned. Use the AddItem method on the returned control to populate the control with items. The icon, display name, and the tooltip for this control are extracted from the currently selected item in the combobox.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddComboBox Method


MiniToolbarControls.AddDropdown Method

MiniToolbarControls.AddDropdown Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new dropdown control within the MiniToolbar.

Visual Basic
Sub AddDropdown(InternalName As String, ByRef ShowIcon As [defaultvalue(-1)] VARIANT_BOOL, ByRef ShowText As [defaultvalue(0)] VARIANT_BOOL, ByRef HasMRUBehavior As [defaultvalue(-1)] VARIANT_BOOL, ByRef IsSplitButton As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] MiniToolbarDropdown*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control.
ShowIcon | Optional input Boolean that specifies whether the icon associated with the currently selected item should be displayed on the face of the control.
ShowText | Optional input Boolean that specifies whether the display name associated with the currently selected item should be displayed on the face of the control.
HasMRUBehavior | Specifies if this button displays the most recently selected item from the list. When True, the item displayed on the button is the item last selected from the list. If False, the text of the button is independent of the list.
IsSplitButton | Optional input Boolean that specifies whether this is a split button dropdown control. If set to True, a separator is added between the currently selected item and the dropdown arrow within the control, and the currently selected item is clickable by the user.
Remarks

The newly created MiniToolbarDropdown is returned. Use the AddItem method on the returned control to populate the control with items. The icon, display name and the tooltip for this control are extracted from the currently selected item in the dropdown.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddDropdown Method


MiniToolbarControls.AddLabel Method

MiniToolbarControls.AddLabel Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new label control within the MiniToolbar.

Visual Basic
Sub AddLabel(InternalName As String, Text As String, ToolTipText As String, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, Result As [out, retval] MiniToolbarControl*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control.
Text | Input String that specifies a display name for the control. If this is specified to be a null string, the control does not display any text.
ToolTipText | Input String that specifies the tooltip text for the control.
StandardIcon | Optional input IPictureDisp that specifies the icon to use for the control. A standard size icon is 16 pixels wide and 16 pixels high.
LargeIcon | Optional input IPictureDisp that specifies the large icon to use for the control. A large size icon is 24 pixels wide and 24 pixels high.
Remarks

The newly created MiniToolbarControl is returned.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddLabel Method


MiniToolbarControls.AddNewLine Method

MiniToolbarControls.AddNewLine Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new line within the MiniToolbar.

Visual Basic
Sub AddNewLine(Result As [out, retval] MiniToolbarControl*)
Remarks

Adding a new line results in any subsequent controls to be added to a new line in the MiniToolbar. The newly created MiniToolbarControl is returned.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddNewLine Method


MiniToolbarControls.AddSeparator Method

MiniToolbarControls.AddSeparator Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new separator within the MiniToolbar.

Visual Basic
Sub AddSeparator(Result As [out, retval] MiniToolbarControl*)
Remarks

Adding a separator results in the creation of a new group for any subsequently added controls. The newly created MiniToolbarControl is returned.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddSeparator Method


MiniToolbarControls.AddValueEditor Method

MiniToolbarControls.AddValueEditor Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new value edit control within the MiniToolbar.

Visual Basic
Sub AddValueEditor(InternalName As String, ToolTipText As String, UnitsType As ValueUnitsTypeEnum, Expression As String, ByRef DisplayName As String, ByRef Width As [defaultvalue(0)] long, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, Result As [out, retval] MiniToolbarValueEditor*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control.
ToolTipText | Input String that specifies the tooltip text for the control.
UnitsType | Input enum that specifies the units type for the value editor.
Expression | Input String that specifies the initial value to display in the value editor.
DisplayName | Input String that specifies the label text to display next to the value field.
Width | Optional input Long that specifies the width of the value editor in pixels. If not specified (or specified to be 0), an internal default width value is used.
StandardIcon | Optional input IPictureDisp that specifies the icon to use for the control. A standard size icon is 16 pixels wide and 16 pixels high.
LargeIcon | Optional input IPictureDisp that specifies the large icon to use for the control. A large size icon is 24 pixels wide and 24 pixels high.
Remarks

The newly created MiniToolbarValueEditor is returned.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.AddValueEditor Method


MiniToolbarControls.Item Method

MiniToolbarControls.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the specified MiniToolbarControl object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] MiniToolbarControl*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the MiniToolbarControl to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the InternalName of the MiniToolbarControl. If an out of range index or a name of a non-existent MiniToolbarControl is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Methods > MiniToolbarControls.Item Method


MiniToolbarControls Properties

MiniToolbarControls Properties
Summary

The properties of the MiniToolbarControls class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kMiniToolbarControlsObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Properties


MiniToolbarControls.Application Property

MiniToolbarControls.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Properties > MiniToolbarControls.Application Property


MiniToolbarControls.Count Property

MiniToolbarControls.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Properties > MiniToolbarControls.Count Property


MiniToolbarControls.Type Property

MiniToolbarControls.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kMiniToolbarControlsObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarControls Interface > MiniToolbarControls Properties > MiniToolbarControls.Type Property


MiniToolbarDropdownObject Interface

MiniToolbarDropdownObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarDropdown object represents a dropdown control within a MiniToolbar.

Class Hierarchy
Inventor::MiniToolbarControl
    Inventor::MiniToolbarDropdownObject
Visual Basic
Public Interface MiniToolbarDropdownObject
Inherits MiniToolbarControl
Remarks

The MiniToolbarDropdown object is derived from the MiniToolbarControl object. The properties and methods below are in addition to those supported by the MiniToolbarControl object.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface


MiniToolbarDropdownObject Methods

MiniToolbarDropdownObject Methods
Summary

The methods of the MiniToolbarDropdownObject class are listed here.

Methods
Methods
Name | Description
AddItem | Method that adds an item to the control.
AddSeparator | Method that add a separator to this control.
Clear | Method that removes all the items from the control.
RemoveItem | Method that removes the specified item from the control.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Methods


MiniToolbarDropdownObject.AddItem Method

MiniToolbarDropdownObject.AddItem Method Available in Inventor Introduced in Inventor 2012
Summary

Method that adds an item to the control.

Visual Basic
Sub AddItem(Text As String, ToolTipText As String, ByRef InternalName As [defaultvalue("")] BSTR, ByRef AllowDelete As [defaultvalue(0)] VARIANT_BOOL, ByRef ShowCheckBox As [defaultvalue(0)] VARIANT_BOOL, ByRef StandardIcon As [optional] VARIANT, ByRef LargeIcon As [optional] VARIANT, ByRef Index As [defaultvalue(0)] long, Result As [out, retval] MiniToolbarListItem*)
Parameters
Parameters | Description
Text | Input String that specifies the text for the item.
ToolTipText | Input String that specifies the tooltip text for the item. This is used as the tooltip for the control when this item is selected.
InternalName | Input String that specifies an internal name for the control. You can provide this for convenience in identifying the item at a later time. If provided, it must be unique with respect to all other items in this drop down.
AllowDelete | Optional input Boolean that specifies whether the user can delete this item from the drop down.
ShowCheckBox | Optional input Boolean that specifies if a check box should be displayed by this item. It will be initialized to be unchecked. To check it, use the IsChecked property on the returned MiniToolbarListItem.
StandardIcon | Optional input IPictureDisp that specifies the icon to use for the item. A standard size icon is 16 pixels wide and 16 pixels high.
LargeIcon | Optional input IPictureDisp that specifies the large icon to use for the item. A large size icon is 24 pixels wide and 24 pixels high.
Index | Optional input Long value that specifies the 1-based index at which to add the item. If not specified, the item is added at the end.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Methods > MiniToolbarDropdownObject.AddItem Method


MiniToolbarDropdownObject.AddSeparator Method

MiniToolbarDropdownObject.AddSeparator Method Available in Inventor Introduced in Inventor 2012
Summary

Method that add a separator to this control.

Visual Basic
Sub AddSeparator(ByRef InternalName As [defaultvalue("")] BSTR, ByRef Index As [defaultvalue(0)] long, Result As [out, retval] MiniToolbarListItem*)
Parameters
Parameters | Description
InternalName | Input String that specifies an internal name for the control. You can provide this for convenience in identifying the item at a later time. If provided, it must be unique with respect to all other items in this drop down.
Index | Optional input Long value that specifies the 1-based index at which to add the separator. If not specified, the separator is added at the end.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Methods > MiniToolbarDropdownObject.AddSeparator Method


MiniToolbarDropdownObject.Clear Method

MiniToolbarDropdownObject.Clear Method Available in Inventor Introduced in Inventor 2012
Summary

Method that removes all the items from the control.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Methods > MiniToolbarDropdownObject.Clear Method


MiniToolbarDropdownObject.RemoveItem Method

MiniToolbarDropdownObject.RemoveItem Method Available in Inventor Introduced in Inventor 2012
Summary

Method that removes the specified item from the control.

Visual Basic
Sub RemoveItem(Index As VARIANT)
Parameters
Parameters | Description
Index | Input Variant value that specifies the item to remove. This can be a numeric value indicating the index of the item in the list or it can be a string that is the internal name of the item. If an out of range index is provided or a name that doesn’t exist, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Methods > MiniToolbarDropdownObject.RemoveItem Method


MiniToolbarDropdownObject Properties

MiniToolbarDropdownObject Properties
Summary

The properties of the MiniToolbarDropdownObject class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the MiniToolbarListItem of the specified item from the drop down.
Properties
Name | Description
Count | Property that returns the number of items in the dropdown.
HasMRUBehavior | Property that specifies if this button displays the most recently selected item from the list.
IsSplitButton | Property that specifies if this is a split button dropdown control.
Pressed | Property that gets and sets whether the button for this control appears pressed.
SelectedIndex | Property that gets and sets the index of the item currently selected.
SelectedItem | Property that returns the item currently selected.
ShowIcon | Property that gets and sets whether the icon associated with the currently selected item should be displayed on the face of the control.
ShowText | Property that gets and sets whether the display name associated with the currently selected item should be displayed on the face of the control.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties


MiniToolbarDropdownObject.Count Property

MiniToolbarDropdownObject.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the number of items in the dropdown.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.Count Property


MiniToolbarDropdownObject.HasMRUBehavior Property

MiniToolbarDropdownObject.HasMRUBehavior Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies if this button displays the most recently selected item from the list.

Visual Basic
Property HasMRUBehavior() As VARIANT_BOOL
Remarks

When True, the item displayed on the button is the item last selected from the list. If False, the text of the button is independent of the list.

The picture below on the left illustrates the result when this property is False. The MiniToolbarDropDown control has its own text, defined by the DisplayName property, and is not affected when an item from the list is select. The picture on the right shows the result when it is True. Selecting an item from the list changes the icon and text of the drop down button and the DisplayName is ignored.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.HasMRUBehavior Property


MiniToolbarDropdownObject.IsSplitButton Property

MiniToolbarDropdownObject.IsSplitButton Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies if this is a split button dropdown control.

Visual Basic
Property IsSplitButton() As VARIANT_BOOL*
Remarks

If True, clicking the button will result in an OnClick event. If this property if False, clicking the button will cause the pop-up to be displayed where the user can click on an item in the list.

The images below illustrate the difference between the two. The example on the left has a split button. Clicking the button results in the OnClick event being fired. To display the list, the user must click the arrow. The image on right is not a split button. Clicking anywhere on the button results in the list being displayed, forcing the user to select an item.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.IsSplitButton Property


MiniToolbarDropdownObject.Item Method

MiniToolbarDropdownObject.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the MiniToolbarListItem of the specified item from the drop down.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] MiniToolbarListItem*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the item to remove. This can be a numeric value indicating the index of the item in the list or it can be a string that is the internal name of the item. If an out of range index is provided or a name that doesn’t exist, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.Item Method


MiniToolbarDropdownObject.Pressed Property

MiniToolbarDropdownObject.Pressed Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the button for this control appears pressed.

Visual Basic
Property Pressed() As VARIANT_BOOL
Remarks

This state is managed by the client application that created the control and should typically be set in the OnClick event. This is applicable only for split button controls. If IsSplitButton property returns False, this property always returns False and cannot be set to True.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.Pressed Property


MiniToolbarDropdownObject.SelectedIndex Property

MiniToolbarDropdownObject.SelectedIndex Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the index of the item currently selected.

Visual Basic
Property SelectedIndex() As long
Remarks

If the HasMRUBehavior property is False, this property will always return 0 since no item is selected, and setting this property will have not effect.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.SelectedIndex Property


MiniToolbarDropdownObject.SelectedItem Property

MiniToolbarDropdownObject.SelectedItem Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the item currently selected.

Visual Basic
Property SelectedItem() As MiniToolbarListItem**
Remarks

This can return Nothing in the case where nothing is selected and will always return Nothing in the case where HasMRUBehavior is False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.SelectedItem Property


MiniToolbarDropdownObject.ShowIcon Property

MiniToolbarDropdownObject.ShowIcon Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the icon associated with the currently selected item should be displayed on the face of the control.

Visual Basic
Property ShowIcon() As VARIANT_BOOL
Remarks

This property defaults to True.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.ShowIcon Property


MiniToolbarDropdownObject.ShowText Property

MiniToolbarDropdownObject.ShowText Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the display name associated with the currently selected item should be displayed on the face of the control.

Visual Basic
Property ShowText() As VARIANT_BOOL
Remarks

This property defaults to False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownObject Interface > MiniToolbarDropdownObject Properties > MiniToolbarDropdownObject.ShowText Property


MiniToolbarDropdownSink Interface

MiniToolbarDropdownSink Interface
Summary

This is class Inventor::MiniToolbarDropdownSink.

Class Hierarchy
Inventor::MiniToolbarDropdownSink
Visual Basic
Public Interface MiniToolbarDropdownSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface


MiniToolbarDropdownSink Methods

MiniToolbarDropdownSink Methods
Summary

The methods of the MiniToolbarDropdownSink class are listed here.

Methods
Methods
Name | Description
OnItemHoverEnd | Event that is fired when the user stops hovering over an item in the drop down in the expanded state.
OnItemHoverStart | Event that is fired when the user starts to hover over an item in the drop down in the expanded state.
OnItemRemove | Event that is fired when the user removes an item from the drop down.
OnPreMenuDisplay | Event that is fired when the user clicks the dropdown in a way where the drop down menu will be displayed.
OnSelect | Event that is fired after the user selects an item from the drop down list.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface > MiniToolbarDropdownSink Methods


MiniToolbarDropdownSink.OnItemHoverEnd Method

MiniToolbarDropdownSink.OnItemHoverEnd Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user stops hovering over an item in the drop down in the expanded state.

Visual Basic
Sub OnItemHoverEnd(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input ListItem that indicates the item being deleted.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface > MiniToolbarDropdownSink Methods > MiniToolbarDropdownSink.OnItemHoverEnd Method


MiniToolbarDropdownSink.OnItemHoverStart Method

MiniToolbarDropdownSink.OnItemHoverStart Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user starts to hover over an item in the drop down in the expanded state.

Visual Basic
Sub OnItemHoverStart(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input Long that is the index of the item the user is starting to hover over.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface > MiniToolbarDropdownSink Methods > MiniToolbarDropdownSink.OnItemHoverStart Method


MiniToolbarDropdownSink.OnItemRemove Method

MiniToolbarDropdownSink.OnItemRemove Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user removes an item from the drop down.

Visual Basic
Sub OnItemRemove(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input MiniToolbarListItem that is being deleted.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface > MiniToolbarDropdownSink Methods > MiniToolbarDropdownSink.OnItemRemove Method


MiniToolbarDropdownSink.OnPreMenuDisplay Method

MiniToolbarDropdownSink.OnPreMenuDisplay Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the user clicks the dropdown in a way where the drop down menu will be displayed.

Visual Basic
Sub OnPreMenuDisplay()
Remarks

The event is fired just before the contents of the drop down list are shown to the user, so you can dynamically modify the contents of the list. If the IsSplitButton property is True, then clicking on the arrow to the right of the button will cause this event to be fired and display the drop-down list. Clicking the button itself is result in the OnSelect event to be fired. If the IsSplitbutton property is False, clicking the button will cause this event to be fired and display the drop-down list.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface > MiniToolbarDropdownSink Methods > MiniToolbarDropdownSink.OnPreMenuDisplay Method


MiniToolbarDropdownSink.OnSelect Method

MiniToolbarDropdownSink.OnSelect Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired after the user selects an item from the drop down list.

Visual Basic
Sub OnSelect(ListItem As MiniToolbarListItem)
Parameters
Parameters | Description
ListItem | Input MiniToolbarListItem that is the item just selected.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarDropdownSink Interface > MiniToolbarDropdownSink Methods > MiniToolbarDropdownSink.OnSelect Method


MiniToolbarListItem Interface

MiniToolbarListItem Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarListItem object represents an item in either a MiniToolBarComboBox or a MiniToolBarDropdown object.

Class Hierarchy
Inventor::MiniToolbarListItem
Visual Basic
Public Interface MiniToolbarListItem
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface


MiniToolbarListItem Properties

MiniToolbarListItem Properties
Summary

The properties of the MiniToolbarListItem class are listed here.

Properties
Name | Description
AllowDelete | Property that specifies if this item can be deleted. This will always be false for a separator.
Index | Property that specifies the position of this item within the list. A value of 1 indicates it is the first item in the list.
InternalName | Property that gets the internal name of this item.
IsChecked | Property that specifies if the check box beside this item is checked or not.
IsSeperator | Property that indicates if this control is a separator or not.
LargeIcon | Property that gets and sets the standard size icon for this item.
ShowCheckBox | Property that gets and sets whether the a check box is displayed beside this item.
StandardIcon | Property that gets and sets the standard size icon for this item.
Text | Property that gets and sets the visible text for this item.
ToolTipText | Property that gets and sets the tool tip text for this item.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties


MiniToolbarListItem.AllowDelete Property

MiniToolbarListItem.AllowDelete Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies if this item can be deleted. This will always be false for a separator.

Visual Basic
Property AllowDelete() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.AllowDelete Property


MiniToolbarListItem.Index Property

MiniToolbarListItem.Index Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the position of this item within the list. A value of 1 indicates it is the first item in the list.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.Index Property


MiniToolbarListItem.InternalName Property

MiniToolbarListItem.InternalName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets the internal name of this item.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.InternalName Property


MiniToolbarListItem.IsChecked Property

MiniToolbarListItem.IsChecked Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies if the check box beside this item is checked or not.

Visual Basic
Property IsChecked() As VARIANT_BOOL
Remarks

The ShowCheckBox property must be True for the check box to be displayed.

This property is only valid for a MiniToolBarDropdown object. For a combo box or seperator, it will always be False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.IsChecked Property


MiniToolbarListItem.IsSeperator Property

MiniToolbarListItem.IsSeperator Property Available in Inventor Introduced in Inventor 2012
Summary

Property that indicates if this control is a separator or not.

Visual Basic
Property IsSeperator() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.IsSeperator Property


MiniToolbarListItem.LargeIcon Property

MiniToolbarListItem.LargeIcon Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the standard size icon for this item.

Visual Basic
Property LargeIcon() As IPictureDisp*
Remarks

A standard size icon is 24x24 pixels. If the control is a separator, this will return Nothing and setting its value will be ignored. Setting this property to Nothing will remove the icon.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.LargeIcon Property


MiniToolbarListItem.ShowCheckBox Property

MiniToolbarListItem.ShowCheckBox Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the a check box is displayed beside this item.

Visual Basic
Property ShowCheckBox() As VARIANT_BOOL
Remarks

If this is set to True, any associated icon will be hidden. Displaying both a check box and an icon is not supported and the display of a check box will override the display of an icon.

This property is only valid for a MiniToolBarDropdown object. For a combo box or seperator, it will always be False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.ShowCheckBox Property


MiniToolbarListItem.StandardIcon Property

MiniToolbarListItem.StandardIcon Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the standard size icon for this item.

Visual Basic
Property StandardIcon() As IPictureDisp*
Remarks

A standard size icon is 16x16 pixels. If the control is a separator, this will return Nothing and setting its value will be ignored. Setting this property to Nothing will remove the icon.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.StandardIcon Property


MiniToolbarListItem.Text Property

MiniToolbarListItem.Text Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the visible text for this item.

Visual Basic
Property Text() As String
Remarks

If the control is a separator, this will return an empty string and setting its value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.Text Property


MiniToolbarListItem.ToolTipText Property

MiniToolbarListItem.ToolTipText Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the tool tip text for this item.

Visual Basic
Property ToolTipText() As String
Remarks

If the control is a separator, this will return an empty string and setting its value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarListItem Interface > MiniToolbarListItem Properties > MiniToolbarListItem.ToolTipText Property


MiniToolbarObject Interface

MiniToolbarObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbar object provides the ability to create and display in-canvas controls for user interaction.

Class Hierarchy
Inventor::MiniToolbarObject
Visual Basic
Public Interface MiniToolbarObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface


MiniToolbarObject Methods

MiniToolbarObject Methods
Summary

The methods of the MiniToolbarObject class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the MiniToolbar object.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Methods


MiniToolbarObject.Delete Method

MiniToolbarObject.Delete Method Available in Inventor Introduced in Inventor 2012
Summary

Method that deletes the MiniToolbar object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Methods > MiniToolbarObject.Delete Method


MiniToolbarObject Properties

MiniToolbarObject Properties
Summary

The properties of the MiniToolbarObject class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Controls | Property that returns the MiniToolbarControls collection object.
EnableApply | Property that specifies whether the ‘Apply’ button is enabled.
EnableOK | Property that specifies whether the ‘OK’ button is enabled.
Parent | Property that returns the parent object.
Position | Property that gets and sets the view space point specifying the current position of the toolbar within the graphical window.
ShowApply | Property that gets and sets whether the toolbar should display the ‘Apply’ button (represented by a green plus symbol).
ShowCancel | Property that gets and sets whether the toolbar should display the ‘Cancel’ button (represented by a red ‘x’).
ShowOK | Property that gets and sets whether the toolbar should display the OK button (represented by a green check mark).
ShowOptionBox | Property that gets and sets whether the toolbar should display the option box.
Type | Property returning kMiniToolbarObject indicating this object’s type.
Visible | Property that gets and sets whether the toolbar is visible.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties


MiniToolbarObject.Application Property

MiniToolbarObject.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.Application Property


MiniToolbarObject.Controls Property

MiniToolbarObject.Controls Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the MiniToolbarControls collection object.

Visual Basic
Property Controls() As MiniToolbarControls**
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.Controls Property


MiniToolbarObject.EnableApply Property

MiniToolbarObject.EnableApply Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies whether the ‘Apply’ button is enabled.

Visual Basic
Property EnableApply() As VARIANT_BOOL
Remarks

Applies only if the ‘Apply’ button is displayed. This value defaults to True.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.EnableApply Property


MiniToolbarObject.EnableOK Property

MiniToolbarObject.EnableOK Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies whether the ‘OK’ button is enabled.

Visual Basic
Property EnableOK() As VARIANT_BOOL
Remarks

Applies only if the ‘OK’ button is displayed. This value defaults to True.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.EnableOK Property


MiniToolbarObject.Parent Property

MiniToolbarObject.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent object.

Visual Basic
Property Parent() As IDispatch**
Remarks

This can either be a CommandManager object or an InteractionEvents object.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.Parent Property


MiniToolbarObject.Position Property

MiniToolbarObject.Position Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the view space point specifying the current position of the toolbar within the graphical window.

Visual Basic
Property Position() As Point2d*
Remarks

This point specifies the top left corner of the toolbar in the view. This property defaults to the center of the graphical window when the toolbar is created.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.Position Property


MiniToolbarObject.ShowApply Property

MiniToolbarObject.ShowApply Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the toolbar should display the ‘Apply’ button (represented by a green plus symbol).

Visual Basic
Property ShowApply() As VARIANT_BOOL
Remarks

This property defaults to True when the toolbar is initially created. When the ‘Apply’ button is clicked, the OnApply event is fired. The toolbar continues to display.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.ShowApply Property


MiniToolbarObject.ShowCancel Property

MiniToolbarObject.ShowCancel Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the toolbar should display the ‘Cancel’ button (represented by a red ‘x’).

Visual Basic
Property ShowCancel() As VARIANT_BOOL
Remarks

This property defaults to True when the toolbar is initially created. When the ‘Cancel’ button is clicked, the OnCancel event is fired.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.ShowCancel Property


MiniToolbarObject.ShowOK Property

MiniToolbarObject.ShowOK Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the toolbar should display the OK button (represented by a green check mark).

Visual Basic
Property ShowOK() As VARIANT_BOOL
Remarks

This property defaults to True when the toolbar is initially created. When the ‘OK’ button is clicked, the OnOK event is fired.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.ShowOK Property


MiniToolbarObject.ShowOptionBox Property

MiniToolbarObject.ShowOptionBox Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the toolbar should display the option box.

Visual Basic
Property ShowOptionBox() As VARIANT_BOOL
Remarks

This is the box that is displayed at the end of the toolbar that has the auto fade and pin options. This property defaults to True when the toolbar is initially created.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.ShowOptionBox Property


MiniToolbarObject.Type Property

MiniToolbarObject.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kMiniToolbarObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.Type Property


MiniToolbarObject.Visible Property

MiniToolbarObject.Visible Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the toolbar is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

This property defaults to False when the toolbar is created.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarObject Interface > MiniToolbarObject Properties > MiniToolbarObject.Visible Property


MiniToolbarSink Interface

MiniToolbarSink Interface
Summary

This is class Inventor::MiniToolbarSink.

Class Hierarchy
Inventor::MiniToolbarSink
Visual Basic
Public Interface MiniToolbarSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarSink Interface


MiniToolbarSink Methods

MiniToolbarSink Methods
Summary

The methods of the MiniToolbarSink class are listed here.

Methods
Methods
Name | Description
OnApply | Event that fires when the ‘Apply’ button is clicked. The toolbar continues to display.
OnCancel | Event that fires when the ‘Cancel’ button is clicked.
OnOK | Event that fires when the ‘OK’ button is clicked.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarSink Interface > MiniToolbarSink Methods


MiniToolbarSink.OnApply Method

MiniToolbarSink.OnApply Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires when the ‘Apply’ button is clicked. The toolbar continues to display.

Visual Basic
Sub OnApply()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarSink Interface > MiniToolbarSink Methods > MiniToolbarSink.OnApply Method


MiniToolbarSink.OnCancel Method

MiniToolbarSink.OnCancel Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires when the ‘Cancel’ button is clicked.

Visual Basic
Sub OnCancel()
Remarks

For toolbars created within InteractionEvents, this event also fires if the InteractionEvents is canceled in any other way. If the MiniToolbar is created off of an InteractionEvents object, the InteractionEvents is terminated and the toolbar is deleted automatically.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarSink Interface > MiniToolbarSink Methods > MiniToolbarSink.OnCancel Method


MiniToolbarSink.OnOK Method

MiniToolbarSink.OnOK Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires when the ‘OK’ button is clicked.

Visual Basic
Sub OnOK()
Remarks

If the MiniToolbar is created off of an InteractionEvents object, the InteractionEvents is terminated and the toolbar is deleted automatically.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarSink Interface > MiniToolbarSink Methods > MiniToolbarSink.OnOK Method


MiniToolbarValueEditorObject Interface

MiniToolbarValueEditorObject Interface Available in Inventor Introduced in Inventor 2012
Summary

The MiniToolbarValueEditor object represents a value edit control within a MiniToolbar.

Class Hierarchy
Inventor::MiniToolbarControl
    Inventor::MiniToolbarValueEditorObject
Visual Basic
Public Interface MiniToolbarValueEditorObject
Inherits MiniToolbarControl
Remarks

The MiniToolbarValueEditor object is derived from the MiniToolbarControl object. The properties and methods of this object are in addition to those supported by the MiniToolbarControl object.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface


MiniToolbarValueEditorObject Methods

MiniToolbarValueEditorObject Methods
Summary

The methods of the MiniToolbarValueEditorObject class are listed here.

Methods
Methods
Name | Description
SetFocus | Method that sets the focus on this control and highlights the current content of the value editor.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Methods


MiniToolbarValueEditorObject.SetFocus Method

MiniToolbarValueEditorObject.SetFocus Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the focus on this control and highlights the current content of the value editor.

Visual Basic
Sub SetFocus()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Methods > MiniToolbarValueEditorObject.SetFocus Method


MiniToolbarValueEditorObject Properties

MiniToolbarValueEditorObject Properties
Summary

The properties of the MiniToolbarValueEditorObject class are listed here.

Properties
Name | Description
AllowToleranceEdit | Property that gets and sets whether to provide the ‘Tolerance…’ command in the fly-out and right click context menus of the value editor.
Expression | Property that gets and sets the current, unevaluated content of the value editor.
IsExpressionValid | Property that returns whether the current content of the value editor evaluates to a valid value based on the specified units, and that the evaluated value is within the range of values, if specified.
MaximumValue | Property that gets and sets the maximum valid value for this control in database units (i.e. cm for length, radians for angle, etc.).
MinimumValue | Property that gets and sets the minimum valid value for this control in database units (i.e. cm for length, radians for angle, etc.).
ModelValueType | Property that gets and sets the model value type.
MostRecentValues | Property that gets and sets an array of strings representing the most recent values associated with this control.
Precision | Property that gets and sets number of decimal places to be used when displaying the parameter associated with this control.
Tolerance | Property that returns a Tolerance object containing tolerance values for the parameter associated with this control.
UnitsType | Property that returns the units type assigned to the control during creation.
Value | Property that gets and sets the evaluated value of the current expression in database units (i.e. cm for length, radians for angle, etc.).
Width | Property that gets and sets the width of the control (in pixels).
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties


MiniToolbarValueEditorObject.AllowToleranceEdit Property

MiniToolbarValueEditorObject.AllowToleranceEdit Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to provide the ‘Tolerance…’ command in the fly-out and right click context menus of the value editor.

Visual Basic
Property AllowToleranceEdit() As VARIANT_BOOL
Remarks

If set to True, use the ModelValueType, Precision and Tolerance properties to set the default values and query the values set by the user. These values should then be applied by the application to the parameter associated with this control.

Note that the control always displays the ‘Measure’ and ‘Show Dimensions’ menus. The ‘List Parameters’ menu is shown only if the document contains any renamed parameters. And the presence of the ‘Tolerance…’ menu is based on the value of this property.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.AllowToleranceEdit Property


MiniToolbarValueEditorObject.Expression Property

MiniToolbarValueEditorObject.Expression Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the current, unevaluated content of the value editor.

Visual Basic
Property Expression() As String
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.Expression Property


MiniToolbarValueEditorObject.IsExpressionValid Property

MiniToolbarValueEditorObject.IsExpressionValid Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns whether the current content of the value editor evaluates to a valid value based on the specified units, and that the evaluated value is within the range of values, if specified.

Visual Basic
Property IsExpressionValid() As VARIANT_BOOL*
Remarks

The range of values can be specified using MaximumValue and MinimumValue properties. If the current content is invalid, the text in the control is displayed in red.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.IsExpressionValid Property


MiniToolbarValueEditorObject.MaximumValue Property

MiniToolbarValueEditorObject.MaximumValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the maximum valid value for this control in database units (i.e. cm for length, radians for angle, etc.).

Visual Basic
Property MaximumValue() As double
Remarks

If the user specifies a value greater than this, the text in the control is displayed in red and the IsExpressionValid property returns False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.MaximumValue Property


MiniToolbarValueEditorObject.MinimumValue Property

MiniToolbarValueEditorObject.MinimumValue Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the minimum valid value for this control in database units (i.e. cm for length, radians for angle, etc.).

Visual Basic
Property MinimumValue() As double
Remarks

If the user specifies a value lesser than this, the text in the control is displayed in red and the IsExpressionValid property returns False.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.MinimumValue Property


MiniToolbarValueEditorObject.ModelValueType Property

MiniToolbarValueEditorObject.ModelValueType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the model value type.

Visual Basic
Property ModelValueType() As ModelValueTypeEnum
Remarks

This property is applicable only if the AllowToleranceEdit property is set to True. Use this property to set the default value for the tolerance dialog and to query the value set by the user.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.ModelValueType Property


MiniToolbarValueEditorObject.MostRecentValues Property

MiniToolbarValueEditorObject.MostRecentValues Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets an array of strings representing the most recent values associated with this control.

Visual Basic
Property MostRecentValues() As VARIANT
Remarks

If not specified, no values are displayed.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.MostRecentValues Property


MiniToolbarValueEditorObject.Precision Property

MiniToolbarValueEditorObject.Precision Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets number of decimal places to be used when displaying the parameter associated with this control.

Visual Basic
Property Precision() As long
Remarks

This property is applicable only if the AllowToleranceEdit property is set to True. Use this property to set the default value for the tolerance dialog and to query the value set by the user.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.Precision Property


MiniToolbarValueEditorObject.Tolerance Property

MiniToolbarValueEditorObject.Tolerance Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns a Tolerance object containing tolerance values for the parameter associated with this control.

Visual Basic
Property Tolerance() As Tolerance**
Remarks

This property is applicable only if the AllowToleranceEdit property is set to True. Use this property to set the default values for the tolerance dialog and to query the values set by the user.

You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.Tolerance Property


MiniToolbarValueEditorObject.UnitsType Property

MiniToolbarValueEditorObject.UnitsType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the units type assigned to the control during creation.

Visual Basic
Property UnitsType() As ValueUnitsTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.UnitsType Property


MiniToolbarValueEditorObject.Value Property

MiniToolbarValueEditorObject.Value Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the evaluated value of the current expression in database units (i.e. cm for length, radians for angle, etc.).

Visual Basic
Property Value() As double
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.Value Property


MiniToolbarValueEditorObject.Width Property

MiniToolbarValueEditorObject.Width Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the width of the control (in pixels).

Visual Basic
Property Width() As long
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorObject Interface > MiniToolbarValueEditorObject Properties > MiniToolbarValueEditorObject.Width Property


MiniToolbarValueEditorSink Interface

MiniToolbarValueEditorSink Interface
Summary

This is class Inventor::MiniToolbarValueEditorSink.

Class Hierarchy
Inventor::MiniToolbarValueEditorSink
Visual Basic
Public Interface MiniToolbarValueEditorSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorSink Interface


MiniToolbarValueEditorSink Methods

MiniToolbarValueEditorSink Methods
Summary

The methods of the MiniToolbarValueEditorSink class are listed here.

Methods
Methods
Name | Description
OnChange | Event that is fired when the content of the value editor is changed by the user.
OnEnter | Event that is fired just before the control gets focus.
OnExit | Event that is fired just before the control loses focus.
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorSink Interface > MiniToolbarValueEditorSink Methods


MiniToolbarValueEditorSink.OnChange Method

MiniToolbarValueEditorSink.OnChange Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired when the content of the value editor is changed by the user.

Visual Basic
Sub OnChange()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorSink Interface > MiniToolbarValueEditorSink Methods > MiniToolbarValueEditorSink.OnChange Method


MiniToolbarValueEditorSink.OnEnter Method

MiniToolbarValueEditorSink.OnEnter Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired just before the control gets focus.

Visual Basic
Sub OnEnter()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorSink Interface > MiniToolbarValueEditorSink Methods > MiniToolbarValueEditorSink.OnEnter Method


MiniToolbarValueEditorSink.OnExit Method

MiniToolbarValueEditorSink.OnExit Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired just before the control loses focus.

Visual Basic
Sub OnExit()
You are here: Symbol Reference > Inventor Library > Objects > MiniToolbarValueEditorSink Interface > MiniToolbarValueEditorSink Methods > MiniToolbarValueEditorSink.OnExit Method


MirrorFeature Interface

MirrorFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The MirrorFeature object represents mirror pattern feature objects.

Class Hierarchy
Inventor::PartFeature
    Inventor::MirrorFeature
        Inventor::MirrorFeatureProxy
Visual Basic
Public Interface MirrorFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

MirrorFeatureProxy.NativeObject

MirrorFeatures.Add

MirrorFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface


MirrorFeature Methods

MirrorFeature Methods
Summary

The methods of the MirrorFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Add the specified occurrence from the list of participants for this feature. This method only applies to assembly features.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Methods


MirrorFeature.AddParticipant Method

MirrorFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Add the specified occurrence from the list of participants for this feature. This method only applies to assembly features.

Visual Basic
Sub AddParticipant(Occurrenc As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence to add.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Methods > MirrorFeature.AddParticipant Method


MirrorFeature Properties

MirrorFeature Properties
Summary

The properties of the MirrorFeature class are listed here.

Properties
Name | Description
ComputeType | Property that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation.
MirrorOfBody | Property that gets whether this mirror feature resulted from mirroring the Surface Body.
MirrorPlaneEntity | Property that gets and sets the mirror plane. This can be either a planar face or work plane.
NewBodyOperation | Property that gets and sets whether the feature creates new bodies, rather than modifying the existing body. Applies only when a body is patterned (i.e. when MirrorOfBody returns True).
ParentFeatures | Property that gets and sets the parent features of the pattern. The ObjectCollection returned by this property is a 'tear off' and does not affect the pattern if its contents are modified. To change the which features are the parents of the pattern you need to use this property to set the parent features by providing an ObjectCollection that contains the desired set of parent features.
PatternElements | Gets the FeaturePatternElements collection that contains the elements created by this pattern.
ResultFeatures | Property that returns the features that were created for this mirror. These can be work planes, work axes, work points and work surfaces.
SurfacesOpaque | Property that gets and sets whether all the resulting surfaces are opaque or transparent. False by default.
SurfacesVisible | Property that gets and sets whether all the resulting surfaces are visible or not. True by default.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties


MirrorFeature.ComputeType Property

MirrorFeature.ComputeType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation.

Visual Basic
Property ComputeType() As PatternComputeTypeEnum
Remarks

If kIdenticalCompute is specified, all occurrences in the pattern use an identical termination, regardless of where they intersect another feature. Use this method to efficiently pattern large numbers of features when the feature being duplicated has a distance termination or terminates on a work plane.

If kAdjustToModelCompute is specified, the termination of each occurrence is calculated individually. Computation time can be lengthy for patterns with a large number of occurrences. You must use this method if the parent feature terminates on a model face.

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.ComputeType Property


MirrorFeature.MirrorOfBody Property

MirrorFeature.MirrorOfBody Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether this mirror feature resulted from mirroring the Surface Body.

Visual Basic
Property MirrorOfBody() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.MirrorOfBody Property


MirrorFeature.MirrorPlaneEntity Property

MirrorFeature.MirrorPlaneEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the mirror plane. This can be either a planar face or work plane.

Visual Basic
Property MirrorPlaneEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.MirrorPlaneEntity Property


MirrorFeature.NewBodyOperation Property

MirrorFeature.NewBodyOperation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the feature creates new bodies, rather than modifying the existing body. Applies only when a body is patterned (i.e. when MirrorOfBody returns True).

Visual Basic
Property NewBodyOperation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.NewBodyOperation Property


MirrorFeature.ParentFeatures Property

MirrorFeature.ParentFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the parent features of the pattern. The ObjectCollection returned by this property is a 'tear off' and does not affect the pattern if its contents are modified. To change the which features are the parents of the pattern you need to use this property to set the parent features by providing an ObjectCollection that contains the desired set of parent features.

Visual Basic
Property ParentFeatures() As ObjectCollection*
Remarks

If a MirrorFeature is created by mirroring the entire solid, its ParentFeature is nothing. When a body is patterned, there are no parent 'features' to return. In this case, the body of the part was used as input and the MirrorFeature.MirrorOfBody Boolean property indicates this. The MirrorFeature.SurfaceBody property returns the body, but note that the returned body is in the new state (includes the mirror operation). You have to roll the "end of part" marker above the mirror feature to get the true input body.

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.ParentFeatures Property


MirrorFeature.PatternElements Property

MirrorFeature.PatternElements Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the FeaturePatternElements collection that contains the elements created by this pattern.

Visual Basic
Property PatternElements() As FeaturePatternElements**
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.PatternElements Property


MirrorFeature.ResultFeatures Property

MirrorFeature.ResultFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the features that were created for this mirror. These can be work planes, work axes, work points and work surfaces.

Visual Basic
Property ResultFeatures() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.ResultFeatures Property


MirrorFeature.SurfacesOpaque Property

MirrorFeature.SurfacesOpaque Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether all the resulting surfaces are opaque or transparent. False by default.

Visual Basic
Property SurfacesOpaque() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.SurfacesOpaque Property


MirrorFeature.SurfacesVisible Property

MirrorFeature.SurfacesVisible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether all the resulting surfaces are visible or not. True by default.

Visual Basic
Property SurfacesVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeature Interface > MirrorFeature Properties > MirrorFeature.SurfacesVisible Property


MirrorFeatureProxy Interface

MirrorFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MirrorFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::MirrorFeature
        Inventor::MirrorFeatureProxy
Visual Basic
Public Interface MirrorFeatureProxy
Inherits MirrorFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatureProxy Interface


MirrorFeatureProxy Properties

MirrorFeatureProxy Properties
Summary

The properties of the MirrorFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatureProxy Interface > MirrorFeatureProxy Properties


MirrorFeatureProxy.ContainingOccurrence Property

MirrorFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatureProxy Interface > MirrorFeatureProxy Properties > MirrorFeatureProxy.ContainingOccurrence Property


MirrorFeatureProxy.NativeObject Property

MirrorFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As MirrorFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatureProxy Interface > MirrorFeatureProxy Properties > MirrorFeatureProxy.NativeObject Property


MirrorFeatures Interface

MirrorFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The MirrorFeatures object provides access to all of the objects in a component definition and provides methods to create additional MirrorFeature objects.

Class Hierarchy
Inventor::MirrorFeatures
Visual Basic
Public Interface MirrorFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.MirrorFeatures

FlatPatternFeatures.MirrorFeatures

PartFeatures.MirrorFeatures

You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface


MirrorFeatures Methods

MirrorFeatures Methods
Summary

The methods of the MirrorFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new mirror feature. The new MirrorFeature object is returned. Defining instances in the Y direction is optional. If any of the Y direction information is missing, only the X instances will be created.
Item | Property that returns the specified MirrorFeature objects from the collection. This is the default property of the MirrorFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Methods


MirrorFeatures.Add Method

MirrorFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new mirror feature. The new MirrorFeature object is returned. Defining instances in the Y direction is optional. If any of the Y direction information is missing, only the X instances will be created.

Visual Basic
Sub Add(ParentFeatures As ObjectCollection, MirrorPlaneEntity As IDispatch, ByRef RemoveOriginal As [defaultvalue(0)] VARIANT_BOOL, ByRef ComputeType As [defaultvalue(kOptimizedCompute)] PatternComputeTypeEnum, Result As [out, retval] MirrorFeature*)
Parameters
Parameters | Description
ParentFeatures | ObjectCollection object that contains the features to be patterned. The collection could contain the various part features, sheet metal features, work planes, work axes, work points, or a SurfaceBody. Only the primary (result) surface body, obtained from ComponentDefinition.SurfaceBodies.Item(1) is a valid input. If a SurfaceBody is supplied, the only other objects that can be in the collection are work features and surface part features.
MirrorPlaneEntity | Input planar entity that defines the mirror plane. This can be either a planar face or a work plane.
RemoveOriginal | Optional input Boolean that specifies whether to remove the original portion after the mirror operation. This argument only applies if a SurfaceBody is specified in the collection of items to be mirrored. The default is false, indicating that the original portion will not be removed.
ComputeType | Property that that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation. If kIdenticalCompute is specified, all occurrences in the pattern use an identical termination, regardless of where they intersect another feature. Use this method to efficiently pattern large numbers of features when the feature being duplicated has a distance termination or terminates on a work plane. If kAdjustToModelCompute is specified, the termination of each occurrence is calculated individually. Computation time can be lengthy for patterns with a large number of occurrences. You must use this method if the parent feature terminates on a model face.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Methods > MirrorFeatures.Add Method


MirrorFeatures.Item Method

MirrorFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified MirrorFeature objects from the collection. This is the default property of the MirrorFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] MirrorFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Methods > MirrorFeatures.Item Method


MirrorFeatures Properties

MirrorFeatures Properties
Summary

The properties of the MirrorFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Properties


MirrorFeatures.Application Property

MirrorFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Properties > MirrorFeatures.Application Property


MirrorFeatures.Count Property

MirrorFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Properties > MirrorFeatures.Count Property


MirrorFeatures.Type Property

MirrorFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MirrorFeatures Interface > MirrorFeatures Properties > MirrorFeatures.Type Property


ModelingEvents CoClass

ModelingEvents CoClass Available in Inventor Available in Server Introduced in Inventor 11
Summary

The ModelingEvents object provides notification of modeling events including new feature, feature delete, changed feature, client feature or new/changed parameters.

Class Hierarchy
Inventor::ModelingEvents
Visual Basic
Public Class ModelingEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.ModelingEvents

You are here: Symbol Reference > Inventor Library > Objects > ModelingEvents CoClass


ModelingEventsObject Interface

ModelingEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The ModelingEvents object provides notification of modeling events including new feature, feature delete, changed feature, client feature or new/changed parameters.

Class Hierarchy
Inventor::ModelingEventsObject
Visual Basic
Public Interface ModelingEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.ModelingEvents

You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsObject Interface


ModelingEventsObject Properties

ModelingEventsObject Properties
Summary

The properties of the ModelingEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning kModelingEventsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsObject Interface > ModelingEventsObject Properties


ModelingEventsObject.Application Property

ModelingEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsObject Interface > ModelingEventsObject Properties > ModelingEventsObject.Application Property


ModelingEventsObject.Parent Property

ModelingEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsObject Interface > ModelingEventsObject Properties > ModelingEventsObject.Parent Property


ModelingEventsObject.Type Property

ModelingEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kModelingEventsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsObject Interface > ModelingEventsObject Properties > ModelingEventsObject.Type Property


ModelingEventsSink Interface

ModelingEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The ModelingEvents object provides notification of modeling events including new feature, feature delete, changed feature, client feature or new/changed parameters.

Class Hierarchy
Inventor::ModelingEventsSink
Visual Basic
Public Interface ModelingEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.ModelingEvents

You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface


ModelingEventsSink Methods

ModelingEventsSink Methods
Summary

The methods of the ModelingEventsSink class are listed here.

Methods
Methods
Name | Description
OnClientFeatureDoubleClick | Event that fires when the user double-clicks a client feature.
OnDelete | The OnDelete event notifies the client when a modeling entity is deleted.
OnFeatureChange | Event that is fired whenever a feature changes.
OnGenerateMember | Event that fires before and after an iPart or an iAssembly member is being generated or regenerated.
OnNewFeature | Event that is fired whenever a feature is created.
OnNewParameter | The OnNewParameter event notifies the client when a new parameter is created.
OnParameterChange | The OnParameterChange event notifies the client when a parameter is changed. The event reports if the name, unit type, or value of a parameter is changed.
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods


ModelingEventsSink.OnClientFeatureDoubleClick Method

ModelingEventsSink.OnClientFeatureDoubleClick Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Event that fires when the user double-clicks a client feature.

Visual Basic
Sub OnClientFeatureDoubleClick(DocumentObject As Document, Feature As ClientFeature, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Feature | Input ClientFeature object that indicates the client feature that was double-clicked.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. This argument is currently ignored for the event.
Remarks

Applications should typically invoke the edit of the client feature when this event is fired.

You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnClientFeatureDoubleClick Method


ModelingEventsSink.OnDelete Method

ModelingEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnDelete event notifies the client when a modeling entity is deleted.

Visual Basic
Sub OnDelete(DocumentObject As Document, Entity As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
The Document object that contains the entity being deleted.
Entity
The Entity that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the object provided is the object before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example: Private m_oDeletedEntity As Object Private Sub oModelingEvents_OnDelete(ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...) If BeforeOrAfter = kBefore Then ' Somehow Check to see if the Entity being deleted is an interesting one. ' For example, it could have an attribute attached to it to identify it. If Interesting(Entity) Then ' Save a reference to the object. Set m_oDeletedEntity = Entity End If Else ' Now we're either after the delete or it's been aborted. ' Check to see if the object is the interesting one. If Entity is m_oDeletedEntity Then If BeforeOrAfter = kAfter then ' The object was deleted. ElseIf BeforeOrAfter = kAbort Then ' The delete was aborted. End If End If End Sub
BeforeOrAfter
Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the entity is deleted. You should only perform query operations when the value of this argument is kBefore. Inventor is not in a state to correctly handle edit operations after that point.
Context
Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Currently the notification is limited to features and parameters. Notification for parameters is only sent when a parameter is explicitly deleted, not when it is deleted as a result of its owner being deleted. For example if you delete a fillet feature, the notification will be sent for the fillet feature, but not for the parameter that controls the fillet radius, even though the parameter is deleted as a result of the feature delete. The type of entities supported for this event may be expanded in the future so you should be careful to write code that is not dependent on the current behavior and filters correctly for the entity type you need.

You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnDelete Method


ModelingEventsSink.OnFeatureChange Method

ModelingEventsSink.OnFeatureChange Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Event that is fired whenever a feature changes.

Visual Basic
Sub OnFeatureChange(DocumentObject As Document, Feature As PartFeature, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Feature | Input PartFeature object that indicates the feature that changed.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the feature is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

This is provided for features in parts and also for assembly features. A change is defined as the modification of a feature's definition. This can occur when the end-user uses the edit command for that particular feature and when a feature is modified using the API. A feature recomputing as the result of other changes in the model is not considered a feature change. For example, if a fillet recomputes because the underlying geometry has changed, this is not considered a feature change because only the resulting geometry changed, not the definition of the fillet. Also, editing any of the various objects the feature is dependent on (sketch, parameters) is also not considered a feature change.

You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnFeatureChange Method


ModelingEventsSink.OnGenerateMember Method

ModelingEventsSink.OnGenerateMember Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Event that fires before and after an iPart or an iAssembly member is being generated or regenerated.

Visual Basic
Sub OnGenerateMember(FactoryDocumentObject As Document, MemberName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
FactoryDocumentObject | Name of the factory document.
MemberName | Name of iPart or iAssembly member.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the feature is changed.
Context | Input NameValueMap object that, if populated, can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event.
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnGenerateMember Method


ModelingEventsSink.OnNewFeature Method

ModelingEventsSink.OnNewFeature Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Event that is fired whenever a feature is created.

Visual Basic
Sub OnNewFeature(DocumentObject As Document, Feature As PartFeature, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Feature | Input PartFeature object that was just created. Nothing in the kBefore case.
BeforeOrAfter | Notification is sent before and after the feature has been created. You should only perform query operations when the valueof this argument is kBefore. Inventor is not in a state to correctly handle edit operations at that point.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnNewFeature Method


ModelingEventsSink.OnNewParameter Method

ModelingEventsSink.OnNewParameter Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnNewParameter event notifies the client when a new parameter is created.

Visual Basic
Sub OnNewParameter(DocumentObject As Document, Parameter As Parameter, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the parameter is contained within.
Parameter | The Parameter object that has just been created. When the BeforeOrAfter argument is kBefore, the value of this argument is Nothing since the Parameter does not yet exist.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the parameter has been created. Generally, you should only perform query operations in Inventor when the value of this argument is kBefore. Inventor is not in a state to correctly handle edit operations after that point.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

New parameters can be created explicitly by the end-user using the Add button on the Parameters dialog and they are also created implicitly as the result of placing dimension constraints and constructing features. This event provides notification is both cases.

You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnNewParameter Method


ModelingEventsSink.OnParameterChange Method

ModelingEventsSink.OnParameterChange Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnParameterChange event notifies the client when a parameter is changed. The event reports if the name, unit type, or value of a parameter is changed.

Visual Basic
Sub OnParameterChange(DocumentObject As Document, Parameter As Parameter, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the parameter is contained within.
Parameter | The Parameter object that is being changed.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the value of the parameter is changed. Using the kBefore timing you can examine the parameter to determine its state before the change is applied and then compare it to the state when the timing is kAfter.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. When BeforeOrAfter is kBefore one of the following values is provided depending on what information associated with the parameter is changing: Name = "Value". Value = A String containing the new value of the parameter. This is provided if the value of the parameter is changed. This is the equivalent of the Value property of the parameter converted to a String, so it is in internal units. Name = "Unit". Value = The String "TBD". This indicates that the unit of the parameter has been changed. The value for this name can be ignored. Name = "Name". Value = A String containing the new name of the parameter. This is provided if the name of the parameter is changed.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

A parameter's value can be changed in many ways. This notification is sent for any change, regardless of what caused it. For example some ways that a parameter value can change are:

  • An explicit edit by the end-user by editing the value in the Parameters dialog or editing the value of the associated dimension.
  • Being driven through an adaptive assembly. For example, if the length of a part changes as other parts in an assembly are modified, a notification is sent when the parameter controlling the length is changed as a result of the adaptivity.
  • Being changed as the result of an equation. For example, if there is a parameter A whose equation is "1.0" and parameter B whose equation is "A * 2", any change to A will also cause B to change. In this case a notification will be sent for A and also for B since both of them will have changed.
You are here: Symbol Reference > Inventor Library > Objects > ModelingEventsSink Interface > ModelingEventsSink Methods > ModelingEventsSink.OnParameterChange Method


ModelingSettings Interface

ModelingSettings Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The ModelingSettings object provides access to properties that provide read and write access of the various modeling related document specific settings. This is somewhat equivalent to the Modeling tab of the Document Settings dialog.

Class Hierarchy
Inventor::ModelingSettings
Visual Basic
Public Interface ModelingSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.ModelingSettings

PartDocument.ModelingSettings

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface


ModelingSettings Properties

ModelingSettings Properties
Summary

The properties of the ModelingSettings class are listed here.

Properties
Name | Description
AdaptivelyUsedInAssembly | Property that gets and sets the indicator that a part is user adaptively in an assembly.
AdvancedFeatureValidation | Gets and sets the advanced feature validation setting, which sets the algorithm for computing part features.
AllowSectioningThruPart | Property that gets and sets whether the part should participate in assembly and drawing sections. A value of True indicates that the part should participate in assembly and drawing sections.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CompactModelHistory | Property that gets and sets the whether the rollback history should be purges when the document is saved. A value of True will cause the rollback history to be purged. A value of False will save the rollback history in the document which allows for better performance when rolling back in the feature tree.
InitialDrawingViewHeight | Property that gets and sets the initial view height (in centimeters) to use when creating a drawing view from this model.
InitialDrawingViewWidth | Property that gets and sets the initial view width (in centimeters) to use when creating a drawing view from this model.
InteractiveContactAnalysis | Property that specifies whether interactive contact analysis should be performed and if so, the type of components to use for interactive contact analysis.
InteractiveContactSurfaces | Property that specifies the type of surfaces to be included for interactive contact analysis.
MaintainEnhancedGraphicsDetail | Property that gets and sets the whether to save enhanced graphics mesh data with the document.
Parent | Property that returns the parent Document object.
Snap3DAngle | Property that gets and sets the snap angle value used in 3D.
Snap3DDistance | Property that gets and sets the snap distance value used in 3D.
SolidBodyNamePrefix | Property that gets and sets the naming prefix for solid bodies.
SurfaceBodyNamePrefix | Property that gets and sets the naming prefix for surface bodies.
TappedHoleDiameter | Sets the size of tapped holes according to the Major, Minor, Pitch, or Tap Drill diameter of the specified thread. It is recommended to use the default value for this option.
Type | Property returning an enum indicating this object's type.
UpdateLegacyHoles | When True, all tapped hole features in the document assume the Tapped Hole Diameter setting. This is the case only if any legacy tapped holes exist in the drawing.
UserCoordinateSystemSettings | Property that returns the UserCoordinateSystemSettings object. The UserCoordinateSystemSettings object provides access to various UCS related document level settings.
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties


ModelingSettings.AdaptivelyUsedInAssembly Property

ModelingSettings.AdaptivelyUsedInAssembly Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the indicator that a part is user adaptively in an assembly.

Visual Basic
Property AdaptivelyUsedInAssembly() As VARIANT_BOOL
Remarks

A value of True indicates that the part is being used adaptively in an assembly. A value of False, removes this indicator and will cause the part to behave as a rigid body, if it is still being used adaptively in an assembly.

When setting this property, it can only be set to False to remove the indicator. Setting to True will cause an error. To make a part behave adaptively, you must use the Adaptive property of the ComponentOccurrence object within an assembly. This will cause this indicator to be set.

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.AdaptivelyUsedInAssembly Property


ModelingSettings.AdvancedFeatureValidation Property

ModelingSettings.AdvancedFeatureValidation Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the advanced feature validation setting, which sets the algorithm for computing part features.

Visual Basic
Property AdvancedFeatureValidation() As VARIANT_BOOL
Remarks

If True, a comprehensive compute algorithm is used. It's slower but can produce more accurate feature results in rare cases. If False, use an optimized feature compute algorithm is used which significantly improves the performance of Shell, Draft, Thicken and Offset features. To avoid unexpected topological changes, Autodesk Inventor does not allow a mixture of the two algorithms in one part. The Advanced Feature Validation option is not available for legacy parts computed by the comprehensive algorithm.

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.AdvancedFeatureValidation Property


ModelingSettings.AllowSectioningThruPart Property

ModelingSettings.AllowSectioningThruPart Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether the part should participate in assembly and drawing sections. A value of True indicates that the part should participate in assembly and drawing sections.

Visual Basic
Property AllowSectioningThruPart() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.AllowSectioningThruPart Property


ModelingSettings.Application Property

ModelingSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.Application Property


ModelingSettings.CompactModelHistory Property

ModelingSettings.CompactModelHistory Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the whether the rollback history should be purges when the document is saved. A value of True will cause the rollback history to be purged. A value of False will save the rollback history in the document which allows for better performance when rolling back in the feature tree.

Visual Basic
Property CompactModelHistory() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.CompactModelHistory Property


ModelingSettings.InitialDrawingViewHeight Property

ModelingSettings.InitialDrawingViewHeight Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the initial view height (in centimeters) to use when creating a drawing view from this model.

Visual Basic
Property InitialDrawingViewHeight() As double
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.InitialDrawingViewHeight Property


ModelingSettings.InitialDrawingViewWidth Property

ModelingSettings.InitialDrawingViewWidth Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the initial view width (in centimeters) to use when creating a drawing view from this model.

Visual Basic
Property InitialDrawingViewWidth() As double
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.InitialDrawingViewWidth Property


ModelingSettings.InteractiveContactAnalysis Property

ModelingSettings.InteractiveContactAnalysis Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies whether interactive contact analysis should be performed and if so, the type of components to use for interactive contact analysis.

Visual Basic
Property InteractiveContactAnalysis() As InteractiveContactAnalysisEnum
Remarks

The valid options are kContactSetOnlyInteractiveContact, kAllComponentsInteractiveContact and kSolverOffInteractiveContact.

The value kContactSetOnlyInteractiveContact corresponds to the 'Contact Set Only' option on the Modeling tab of the Document Settings dialog for assembly documents. If this value is specified, the interactive contact analysis will be performed and the analysis will be limited to only those components that have been included in the contact set.

The value kAllComponentsInteractiveContact corresponds to the 'All Components' option on the Modeling tab of the Document Settings dialog for an assembly document. If this value is specified, the interactive contact analysis will be performed and all components in the assembly will be used as input for the contact analysis.

The value kSolverOffInteractiveContact corresponds to the 'Contact Solver Off' option on the Modeling tab of the Document Settings dialog for an assembly document. If this value is specified, interactive contact analysis will not be performed for any of the components.

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.InteractiveContactAnalysis Property


ModelingSettings.InteractiveContactSurfaces Property

ModelingSettings.InteractiveContactSurfaces Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of surfaces to be included for interactive contact analysis.

Visual Basic
Property InteractiveContactSurfaces() As InteractiveContactSurfacesEnum
Remarks

This property corresponds to the 'Surface Complexity' options in the 'Interactive Contact' groupbox on the Modeling tab of the Document Settings dialog for assembly documents.

The complexity of the surfaces affects the performance of the contact solver and the accuracy of the contact analysis. If all surfaces including the complex ones are used in the contact analysis, it will be more accurate but, the performance of the contact solver will be lower. This property can be used to specify that complex surfaces that are within close proximity to each other be ignored during the contact analysis and thus provides a trade-off between better performance and the accuracy of the contact detection.

The valid options are kAllSurfacesInteractiveContact, kGeneralSurfacesInteractiveContact and kSimpleSurfacesInteractiveContact.

Setting this property to kAllSurfacesInteractiveContact takes all surfaces into consideration when performing the contact analysis. While this option is the most accurate, it might be slow for some models.

Setting this property to kGeneralSurfacesInteractiveContact takes into account most surfaces, but some fillets (blends) are ignored. This eliminates a few of the most problematic cases to provide better performance and provides a reasonable compromise between performance and accuracy.

Setting this property to kSimpleSurfacesInteractiveContact ignores non-analytic surfaces. This option yields the best performance, but any contact between nurbs surfaces is missed.

Note: This property can be set only if the InteractiveContactAnalysis property is specified to be either kContactSetOnlyInteractiveContact or kAllComponentsInteractiveContact. Setting this property will fail if the InteractiveContactAnalysis property is specified to be kSolverOffInteractiveContact.

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.InteractiveContactSurfaces Property


ModelingSettings.MaintainEnhancedGraphicsDetail Property

ModelingSettings.MaintainEnhancedGraphicsDetail Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the whether to save enhanced graphics mesh data with the document.

Visual Basic
Property MaintainEnhancedGraphicsDetail() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.MaintainEnhancedGraphicsDetail Property


ModelingSettings.Parent Property

ModelingSettings.Parent Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the parent Document object.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.Parent Property


ModelingSettings.Snap3DAngle Property

ModelingSettings.Snap3DAngle Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the snap angle value used in 3D.

Visual Basic
Property Snap3DAngle() As String
Remarks

The string is an expression that can be evaluated as an angle. When setting this property, you must provide a string that can be evaluated as an angle or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.

This value is used by various commands that allow the user to dynamically specify an angle. For example, the '3D Move or Rotate' functionality that is used in conjunction with the 'Grounded Work Point' command snaps in even increments of the snap angle when rotating the triad tool.

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.Snap3DAngle Property


ModelingSettings.Snap3DDistance Property

ModelingSettings.Snap3DDistance Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the snap distance value used in 3D.

Visual Basic
Property Snap3DDistance() As String
Remarks

The string is an expression that can be evaluated as an distance. When setting this property, you must provide a string that can be evaluated as an distance or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.

This value is used by various commands that allow the user to dynamically specify an distance. For example, the Extrude command snaps in even increments of the snap distance when dynamically dragging to define the distance of the extrude.

You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.Snap3DDistance Property


ModelingSettings.SolidBodyNamePrefix Property

ModelingSettings.SolidBodyNamePrefix Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the naming prefix for solid bodies.

Visual Basic
Property SolidBodyNamePrefix() As String
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.SolidBodyNamePrefix Property


ModelingSettings.SurfaceBodyNamePrefix Property

ModelingSettings.SurfaceBodyNamePrefix Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the naming prefix for surface bodies.

Visual Basic
Property SurfaceBodyNamePrefix() As String
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.SurfaceBodyNamePrefix Property


ModelingSettings.TappedHoleDiameter Property

ModelingSettings.TappedHoleDiameter Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Sets the size of tapped holes according to the Major, Minor, Pitch, or Tap Drill diameter of the specified thread. It is recommended to use the default value for this option.

Visual Basic
Property TappedHoleDiameter() As ModelDiameterFromThreadEnum
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.TappedHoleDiameter Property


ModelingSettings.Type Property

ModelingSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.Type Property


ModelingSettings.UpdateLegacyHoles Property

ModelingSettings.UpdateLegacyHoles Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

When True, all tapped hole features in the document assume the Tapped Hole Diameter setting. This is the case only if any legacy tapped holes exist in the drawing.

Visual Basic
Property UpdateLegacyHoles() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.UpdateLegacyHoles Property


ModelingSettings.UserCoordinateSystemSettings Property

ModelingSettings.UserCoordinateSystemSettings Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the UserCoordinateSystemSettings object. The UserCoordinateSystemSettings object provides access to various UCS related document level settings.

Visual Basic
Property UserCoordinateSystemSettings() As UserCoordinateSystemSettings**
You are here: Symbol Reference > Inventor Library > Objects > ModelingSettings Interface > ModelingSettings Properties > ModelingSettings.UserCoordinateSystemSettings Property


ModelParameter Interface

ModelParameter Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a parameter that was created automatically by Autodesk Inventor as the result of creating an object that is dependent on a parameter. For example, when a placing a driving dimension constraint a ModelParameter is automatically created to control the dimension.

Class Hierarchy
Inventor::Parameter
    Inventor::ModelParameter
Visual Basic
Public Interface ModelParameter
Inherits Parameter
Notes

Members through which this object may be accessed include:

ModelParameters.AddByExpression

ModelParameters.AddByValue

ModelParameters.Item

ReferenceParameter.ConvertToModelParameter

UserParameter.ConvertToModelParameter

See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface


ModelParameter Methods

ModelParameter Methods
Summary

The methods of the ModelParameter class are listed here.

Methods
Methods
Name | Description
ConvertToReferenceParameter | Method that causes the parameter to be converted to a reference parameter. The new ReferenceParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).
ConvertToUserParameter | Method that causes the parameter to be converted to a user parameter. The new UserParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).
You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface > ModelParameter Methods


ModelParameter.ConvertToReferenceParameter Method

ModelParameter.ConvertToReferenceParameter Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that causes the parameter to be converted to a reference parameter. The new ReferenceParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).

Visual Basic
Sub ConvertToReferenceParameter(Result As [out, retval] ReferenceParameter*)
You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface > ModelParameter Methods > ModelParameter.ConvertToReferenceParameter Method


ModelParameter.ConvertToUserParameter Method

ModelParameter.ConvertToUserParameter Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that causes the parameter to be converted to a user parameter. The new UserParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).

Visual Basic
Sub ConvertToUserParameter(Result As [out, retval] UserParameter*)
You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface > ModelParameter Methods > ModelParameter.ConvertToUserParameter Method


ModelParameter Properties

ModelParameter Properties
Summary

The properties of the ModelParameter class are listed here.

Properties
Name | Description
BuiltIn | Property that returns whether this is an Inventor-generated parameter or an API-created one. Returns True if it is Inventor-generated.
Renamed | Gets whether the ModelParameter has been renamed by the user.
You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface > ModelParameter Properties


ModelParameter.BuiltIn Property

ModelParameter.BuiltIn Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns whether this is an Inventor-generated parameter or an API-created one. Returns True if it is Inventor-generated.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface > ModelParameter Properties > ModelParameter.BuiltIn Property


ModelParameter.Renamed Property

ModelParameter.Renamed Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets whether the ModelParameter has been renamed by the user.

Visual Basic
Property Renamed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ModelParameter Interface > ModelParameter Properties > ModelParameter.Renamed Property


ModelParameters Interface

ModelParameters Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the model parameters ( objects) associated with the object the collection was obtained from.

Class Hierarchy
Inventor::ModelParameters
Visual Basic
Public Interface ModelParameters
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameters.ModelParameters

See Also

Model Parameters sample

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface


ModelParameters Methods

ModelParameters Methods
Summary

The methods of the ModelParameters class are listed here.

Methods
Methods
Name | Description
_AddByValue | This is _AddByValue, a member of class ModelParameters.
AddByExpression | Method that creates a new model parameter given an expression.
AddByValue | Method that creates a new model parameter given a name and equation.
Item | Property that returns the specified ModelParameter object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Methods


ModelParameters._AddByValue Method

ModelParameters._AddByValue Method
Summary

This is _AddByValue, a member of class ModelParameters.

Visual Basic
Sub _AddByValue(Value As double, UnitsSpecifier As VARIANT, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] ModelParameter*)
You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Methods > ModelParameters._AddByValue Method


ModelParameters.AddByExpression Method

ModelParameters.AddByExpression Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new model parameter given an expression.

Visual Basic
Sub AddByExpression(Expression As String, UnitsSpecifier As VARIANT, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] ModelParameter*)
Parameters
Parameters | Description
Expression | Input String value that specifies the equation for the parameter. This string is evaluated the same way as strings entered in any of the Inventor dialogs are evaluated. For example 'x + 3 in / 2 cm' is a valid string for input.
UnitsSpecifier | Input value that specifies the type of unit the parameter is. The units can be specified using either a string defining a valid unit or an item from the UnitsTypeEnum. If the equation references existing parameters, this unit type must be consistent with the unit type defined by the equation, otherwise an error will occur.
Name | Optional input String value that specifies the name for the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur. If not specified, a unique name generated by Inventor is assigned to the parameter.
You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Methods > ModelParameters.AddByExpression Method


ModelParameters.AddByValue Method

ModelParameters.AddByValue Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new model parameter given a name and equation.

Visual Basic
Sub AddByValue(Value As VARIANT, UnitsSpecifier As VARIANT, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] ModelParameter*)
Parameters
Parameters | Description
Value | Specifies the value for the parameter. This value is given in database units for the unit type defined by the UnitsSpecifier argument.
UnitsSpecifier | Input value that specifies the type of unit the parameter is. The units can be specified using either a string defining a valid unit or an item from the UnitsTypeEnum. If the equation references existing parameters, this unit type must be consistent with the unit type defined by the equation, otherwise an error will occur.
Name | Optional input String value that specifies the name for the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur. If not specified, a unique name generated by Inventor is assigned to the parameter.
See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Methods > ModelParameters.AddByValue Method


ModelParameters.Item Method

ModelParameters.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified ModelParameter object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] ModelParameter*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ModelParameter to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the parameter name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
See Also

Model Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Methods > ModelParameters.Item Method


ModelParameters Properties

ModelParameters Properties
Summary

The properties of the ModelParameters class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Properties


ModelParameters.Count Property

ModelParameters.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Model Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Properties > ModelParameters.Count Property


ModelParameters.Type Property

ModelParameters.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ModelParameters Interface > ModelParameters Properties > ModelParameters.Type Property


MouseEvents CoClass

MouseEvents CoClass Available in Inventor Introduced in Inventor 5
Summary

The MouseEvents object supports a set of events that can be received by clients who are interested in mouse input from the end-user.

Class Hierarchy
Inventor::MouseEvents
Visual Basic
Public Class MouseEvents
Remarks

The InteractionEvents object should have been Start-ed AND the InteractionDisabled switch must be off to start receiving these events. See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

InteractionEventsObject.MouseEvents

See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > MouseEvents CoClass


MouseEventsObject Interface

MouseEventsObject Interface Available in Inventor Introduced in Inventor 5
Summary

The MouseEvents object supports a set of events that can be received by clients who are interested in mouse input from the end-user.

Class Hierarchy
Inventor::MouseEventsObject
Visual Basic
Public Interface MouseEventsObject
Inherits IDispatch
Remarks

The InteractionEvents object should have been Start-ed AND the InteractionDisabled switch must be off to start receiving these events. See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface


MouseEventsObject Properties

MouseEventsObject Properties
Summary

The properties of the MouseEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
MouseMoveEnabled | Property that gets and sets whether the OnMouseMove event is fired or not. If you don't need move events you can use this property to disable them and increase performance.
Parent | Property that returns the parent document of the object.
PointInferenceEnabled | Property that gets and sets whether any inference of points is done.
PointInferences | Returns a PointInferenceEnumerator object, which contains information about how the mouse position was defined by inference to other objects or points. Applies only when a sketch or a drawing document is active.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties


MouseEventsObject.Application Property

MouseEventsObject.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties > MouseEventsObject.Application Property


MouseEventsObject.MouseMoveEnabled Property

MouseEventsObject.MouseMoveEnabled Property Available in Inventor Introduced in Inventor 5
Summary

Property that gets and sets whether the OnMouseMove event is fired or not. If you don't need move events you can use this property to disable them and increase performance.

Visual Basic
Property MouseMoveEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties > MouseEventsObject.MouseMoveEnabled Property


MouseEventsObject.Parent Property

MouseEventsObject.Parent Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the parent document of the object.

Visual Basic
Property Parent() As InteractionEvents**
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties > MouseEventsObject.Parent Property


MouseEventsObject.PointInferenceEnabled Property

MouseEventsObject.PointInferenceEnabled Property Available in Inventor Introduced in Inventor 5
Summary

Property that gets and sets whether any inference of points is done.

Visual Basic
Property PointInferenceEnabled() As VARIANT_BOOL
Remarks

Inference is when Inventor automatically infers specific point positions based on the graphics and how the mouse is moved relative to the graphics. For example, if you move the mouse near the end of a line, a glyph is shown to indicate you're near the end and the mouse snaps to exact end. The same is true for other types of snap points. In addition, you can pass the mouse over the end of an entity and then receive feedback indicating you're still vertically or horizontally aligned to the point. You can also find the intersection of two elements through inference.

This property is valid only when a sketch is active or when a drawing document is active. You cannot infer points while you are selecting objects. The selected point inference can be found using the PointInferences property during the OnMouseClick event.

Default value is False.

You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties > MouseEventsObject.PointInferenceEnabled Property


MouseEventsObject.PointInferences Property

MouseEventsObject.PointInferences Property Available in Inventor Introduced in Inventor 5
Summary

Returns a PointInferenceEnumerator object, which contains information about how the mouse position was defined by inference to other objects or points. Applies only when a sketch or a drawing document is active.

Visual Basic
Property PointInferences() As PointInferenceEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties > MouseEventsObject.PointInferences Property


MouseEventsObject.Type Property

MouseEventsObject.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsObject Interface > MouseEventsObject Properties > MouseEventsObject.Type Property


MouseEventsSink Interface

MouseEventsSink Interface Available in Inventor Introduced in Inventor 5
Summary

The MouseEvents object supports a set of events that can be received by clients who are interested in mouse input from the end-user.

Class Hierarchy
Inventor::MouseEventsSink
Visual Basic
Public Interface MouseEventsSink
Inherits IDispatch
Remarks

The InteractionEvents object should have been Start-ed AND the InteractionDisabled switch must be off to start receiving these events. See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface


MouseEventsSink Methods

MouseEventsSink Methods
Summary

The methods of the MouseEventsSink class are listed here.

Methods
Methods
Name | Description
OnMouseClick | Event that occurs when the user presses and then releases a mouse button.
OnMouseDoubleClick | Event that occurs when the user presses and releases a mouse button and then presses and releases it again in quick succession.
OnMouseDown | Event that occurs then the user presses a mouse button and begins to hold it down for a perceptible time.
OnMouseLeave | Event that occurs when the user moves the mouse out of a view.
OnMouseMove | Event that occurs when the user moves the mouse. The position moved to is described by the arguments of this event.
OnMouseUp | Event that occurs when the user transitions out of a MouseDown position, releasing the mouse button.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods


MouseEventsSink.OnMouseClick Method

MouseEventsSink.OnMouseClick Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user presses and then releases a mouse button.

Visual Basic
Sub OnMouseClick(Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, view As View)
Parameters
Parameters | Description
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
ModelPosition | Returns the coordinates that specify the current location of the mouse pointer in model space and are returned in centimeters.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels.
View | Returns the View object where the mouse was pressed.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods > MouseEventsSink.OnMouseClick Method


MouseEventsSink.OnMouseDoubleClick Method

MouseEventsSink.OnMouseDoubleClick Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user presses and releases a mouse button and then presses and releases it again in quick succession.

Visual Basic
Sub OnMouseDoubleClick(Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, view As View)
Parameters
Parameters | Description
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
ModelPosition | Returns the coordinates that specify the current location of the mouse pointer in model space and are returned in centimeters.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels.
View | Returns the View object where the mouse was pressed.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods > MouseEventsSink.OnMouseDoubleClick Method


MouseEventsSink.OnMouseDown Method

MouseEventsSink.OnMouseDown Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs then the user presses a mouse button and begins to hold it down for a perceptible time.

Visual Basic
Sub OnMouseDown(Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, view As View)
Parameters
Parameters | Description
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
ModelPosition | Returns the coordinates that specify the current location of the mouse pointer in model space and are returned in centimeters.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels.
View | Returns the View object where the mouse was pressed.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods > MouseEventsSink.OnMouseDown Method


MouseEventsSink.OnMouseLeave Method

MouseEventsSink.OnMouseLeave Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user moves the mouse out of a view.

Visual Basic
Sub OnMouseLeave(Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, view As View)
Parameters
Parameters | Description
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
View | Returns the View object the mouse was moved out of.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods > MouseEventsSink.OnMouseLeave Method


MouseEventsSink.OnMouseMove Method

MouseEventsSink.OnMouseMove Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user moves the mouse. The position moved to is described by the arguments of this event.

Visual Basic
Sub OnMouseMove(Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, view As View)
Parameters
Parameters | Description
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
ModelPosition | Returns the coordinates that specify the current location of the mouse pointer in model space and are returned in centimeters.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels.
View | Returns the View object where the mouse was pressed.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods > MouseEventsSink.OnMouseMove Method


MouseEventsSink.OnMouseUp Method

MouseEventsSink.OnMouseUp Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user transitions out of a MouseDown position, releasing the mouse button.

Visual Basic
Sub OnMouseUp(Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, view As View)
Parameters
Parameters | Description
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
ModelPosition | Returns the coordinates that specify the current location of the mouse pointer in model space and are returned in centimeters.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels.
View | Returns the View object where the mouse was pressed.
You are here: Symbol Reference > Inventor Library > Objects > MouseEventsSink Interface > MouseEventsSink Methods > MouseEventsSink.OnMouseUp Method


MoveFaceDefinition Interface

MoveFaceDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::MoveFaceDefinition
Visual Basic
Public Interface MoveFaceDefinition
Inherits IDispatch
Remarks

The MoveFaceDefinition object is used in two ways. First it is used as input when creating a Move Face feature. Second it is used to query and edit existing Move Face features.

When creating a new Move Face feature you use the MoveFaceFeatures.CreateDefinition method to create a new MoveFaceDefinition object. Using the properties of this object you can define the various options of the Move Face feature. Typically a new MoveFaceDefinition object is created and then modified to get the desired Move Face feature and then used as input to the MoveFaceFeatures.Add method. An existing MoveFaceFeature object is edited by modifying its associated MoveFaceDefinition object.

Notes

Members through which this object may be accessed include:

DirectionAndDistanceMoveDefinition.Parent

FreeMoveDefinition.Parent

MoveFaceDefinition.Copy

MoveFaceFeature.Definition

MoveFaceFeatures.CreateDefinition

PlanarMoveDefinition.Parent

The MoveFaceDefinition object represents all of the information that defines a Move Face feature.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface


MoveFaceDefinition Methods

MoveFaceDefinition Methods
Summary

The methods of the MoveFaceDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this MoveFaceDefinition object. The new MoveFaceDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new Move Face feature.
SetDirectionAndDistanceMoveType | Method that sets the move face type to kDirectionAndDistanceMoveType. The move is defined using a direction and a distance along the direction.
SetFreeMoveType | Method that sets the move face type to kFreeMoveType. The move is defined using a matrix that defines the transform to be applies to the face(s).
SetPlanarMoveType | Method that sets the move face type to kPlanarMoveType. The move is defined using two points, and optionally, a plane for the move.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Methods


MoveFaceDefinition.Copy Method

MoveFaceDefinition.Copy Method
Summary

Method that creates a copy of this MoveFaceDefinition object. The new MoveFaceDefinition object is independent of any feature. It can edited and used as input to edit an existing feature or to create a new Move Face feature.

Visual Basic
Sub Copy(Result As [out, retval] MoveFaceDefinition*)
Remarks

One typical use of this method is when you need to make several changes to an existing Move Face feature. If you edit the MoveFaceDefinition object associated with the Move Face feature, the feature will recompute after each edit. It"s more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The MoveFaceFeatures.CreateDefinition method can also be used to create an independent MoveFaceDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that"s created with the CreateDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Methods > MoveFaceDefinition.Copy Method


MoveFaceDefinition.SetDirectionAndDistanceMoveType Method

MoveFaceDefinition.SetDirectionAndDistanceMoveType Method
Summary

Method that sets the move face type to kDirectionAndDistanceMoveType. The move is defined using a direction and a distance along the direction.

Visual Basic
Sub SetDirectionAndDistanceMoveType(Distance As VARIANT, Direction As IDispatch, ByRef DirectionReversed As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Distance | Defines the distance to move along the specified direction. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Direction | Specifies the entity defining the direction for the move. This can either be a WorkAxis, a linear Edge, or a planar Face object.
DirectionReversed | Specifies whether the direction defined by the entity in the Direction argument should be reversed. Defaults to False indicating that the direction is not reversed.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Methods > MoveFaceDefinition.SetDirectionAndDistanceMoveType Method


MoveFaceDefinition.SetFreeMoveType Method

MoveFaceDefinition.SetFreeMoveType Method
Summary

Method that sets the move face type to kFreeMoveType. The move is defined using a matrix that defines the transform to be applies to the face(s).

Visual Basic
Sub SetFreeMoveType(Transformation As Matrix)
Parameters
Parameters | Description
Transformation | Matrix that defines the free move transform of the faces.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Methods > MoveFaceDefinition.SetFreeMoveType Method


MoveFaceDefinition.SetPlanarMoveType Method

MoveFaceDefinition.SetPlanarMoveType Method
Summary

Method that sets the move face type to kPlanarMoveType. The move is defined using two points, and optionally, a plane for the move.

Visual Basic
Sub SetPlanarMoveType(PointOne As IDispatch, PointTwo As IDispatch, ByRef Plane As [optional] VARIANT)
Parameters
Parameters | Description
PointOne | Specifies the first point for the planar move. This can either be a WorkPoint or a Vertex object.
PointTwo | Specifies the second point for the planar move. This can either be a WorkPoint or a Vertex object.
Plane | Specifies the plane for the planar move. This can either be a WorkPlane or a planar Face object. If not specified, the move is based on the input points.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Methods > MoveFaceDefinition.SetPlanarMoveType Method


MoveFaceDefinition Properties

MoveFaceDefinition Properties
Summary

The properties of the MoveFaceDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutomaticBlending | Property that gets and sets whether the move operation should propagate to adjacent tangent faces.
Faces | Property that gets and set the FaceCollection object that contains the faces that are used to define the Move Face feature. When querying an existing feature, the originally selected faces may not be available if they were consumed downstream. To access these faces, the end-of-part marker must be placed above the move face feature.
MoveFaceType | Property that returns the method used to define the type of the move face operation. The valid values for this property are kDirectionAndDistanceMoveType, kPlanarMoveType, and kFreeMoveType. This property is initialized to kFreeMoveType when the definition is created. Use the MoveFaceTypeDefinition property to get the corresponding definition object.
MoveFaceTypeDefinition | Property that returns the definition object that defines the type of move.
Parent | Property that returns the parent MoveFaceFeature of this MoveFaceDefinition object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties


MoveFaceDefinition.Application Property

MoveFaceDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.Application Property


MoveFaceDefinition.AutomaticBlending Property

MoveFaceDefinition.AutomaticBlending Property
Summary

Property that gets and sets whether the move operation should propagate to adjacent tangent faces.

Visual Basic
Property AutomaticBlending() As VARIANT_BOOL
Remarks

This property is initialized to True when the definition object is initially created. Setting this property returns an error when the definition object is obtained from an existing feature, since this value can only be set when creating features.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.AutomaticBlending Property


MoveFaceDefinition.Faces Property

MoveFaceDefinition.Faces Property
Summary

Property that gets and set the FaceCollection object that contains the faces that are used to define the Move Face feature. When querying an existing feature, the originally selected faces may not be available if they were consumed downstream. To access these faces, the end-of-part marker must be placed above the move face feature.

Visual Basic
Property Faces() As FaceCollection*
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.Faces Property


MoveFaceDefinition.MoveFaceType Property

MoveFaceDefinition.MoveFaceType Property
Summary

Property that returns the method used to define the type of the move face operation. The valid values for this property are kDirectionAndDistanceMoveType, kPlanarMoveType, and kFreeMoveType. This property is initialized to kFreeMoveType when the definition is created. Use the MoveFaceTypeDefinition property to get the corresponding definition object.

Visual Basic
Property MoveFaceType() As MoveFaceTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.MoveFaceType Property


MoveFaceDefinition.MoveFaceTypeDefinition Property

MoveFaceDefinition.MoveFaceTypeDefinition Property
Summary

Property that returns the definition object that defines the type of move.

Visual Basic
Property MoveFaceTypeDefinition() As IDispatch**
Remarks

The type of object that this property will return can be determined by using the MoveFaceType property. Types that can be returned are DirectionAndDistanceMoveDefinition, PlanarMoveDefinition, and FreeMoveDefinition. The property returns a FreeMoveDefinition object (to correspond with the kFreeMoveType returned by the MoveFaceType property) when the MoveFaceDefinition is initially created.

When the MoveFaceDefinition object is transient, (created using the MoveFaceFeatures.CreateDefinition method or the Copy method of an existing MoveFaceDefinition object), this property will return Nothing. The MoveFaceDefinition still defines the move face type but its details are not accessible through this property. You can determine the type of move by using the MoveFaceType property and can set the type using one of the various Set methods.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.MoveFaceTypeDefinition Property


MoveFaceDefinition.Parent Property

MoveFaceDefinition.Parent Property
Summary

Property that returns the parent MoveFaceFeature of this MoveFaceDefinition object.

Visual Basic
Property Parent() As MoveFaceFeature**
Remarks

In the case where this is a newly created MoveFaceDefinition object or it has been copied from an existing MoveFaceDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.Parent Property


MoveFaceDefinition.Type Property

MoveFaceDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceDefinition Interface > MoveFaceDefinition Properties > MoveFaceDefinition.Type Property


MoveFaceFeature Interface

MoveFaceFeature Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The MoveFaceFeature provides the ability to move any face of a part along it's normal.

Class Hierarchy
Inventor::PartFeature
    Inventor::MoveFaceFeature
        Inventor::MoveFaceFeatureProxy
Visual Basic
Public Interface MoveFaceFeature
Inherits PartFeature
Remarks

Prior to Autodesk Inventor 10, no feature existed to change the location of a face along it's normal, except to change the dimension of an extrusion feature.

Notes

Members through which this object may be accessed include:

MoveFaceDefinition.Parent

MoveFaceFeatureProxy.NativeObject

MoveFaceFeatures.Add

MoveFaceFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeature Interface


MoveFaceFeature Properties

MoveFaceFeature Properties
Summary

The properties of the MoveFaceFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the MoveFaceDefinition object associated with this feature.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeature Interface > MoveFaceFeature Properties


MoveFaceFeature.Definition Property

MoveFaceFeature.Definition Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the MoveFaceDefinition object associated with this feature.

Visual Basic
Property Definition() As MoveFaceDefinition*
Remarks

Modifying the MoveFaceDefinition object will edit the associated MoveFaceFeature. If you want to batch up the edits to the feature, you can set a new definition object to this property. A new definition object can be created either using MoveFaceFeatures.CreateDefinition or MoveFaceDefinition.Copy methods.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeature Interface > MoveFaceFeature Properties > MoveFaceFeature.Definition Property


MoveFaceFeatureProxy Interface

MoveFaceFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MoveFaceFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::MoveFaceFeature
        Inventor::MoveFaceFeatureProxy
Visual Basic
Public Interface MoveFaceFeatureProxy
Inherits MoveFaceFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatureProxy Interface


MoveFaceFeatureProxy Properties

MoveFaceFeatureProxy Properties
Summary

The properties of the MoveFaceFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatureProxy Interface > MoveFaceFeatureProxy Properties


MoveFaceFeatureProxy.ContainingOccurrence Property

MoveFaceFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatureProxy Interface > MoveFaceFeatureProxy Properties > MoveFaceFeatureProxy.ContainingOccurrence Property


MoveFaceFeatureProxy.NativeObject Property

MoveFaceFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As MoveFaceFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatureProxy Interface > MoveFaceFeatureProxy Properties > MoveFaceFeatureProxy.NativeObject Property


MoveFaceFeatures Interface

MoveFaceFeatures Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The MoveFaceFeatures object provides access to all of the objects in a component definition and provides methods to create additional MoveFaceFeature objects.

Class Hierarchy
Inventor::MoveFaceFeatures
Visual Basic
Public Interface MoveFaceFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.MoveFaceFeatures

PartFeatures.MoveFaceFeatures

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface


MoveFaceFeatures Methods

MoveFaceFeatures Methods
Summary

The methods of the MoveFaceFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Move Face feature. The newly created MoveFaceFeature object is returned.
CreateDefinition | Method that creates a new MoveFaceDefinition object
Item | Property that returns the specified feature object from the collection. This is the default property of this collection object.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Methods


MoveFaceFeatures.Add Method

MoveFaceFeatures.Add Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new Move Face feature. The newly created MoveFaceFeature object is returned.

Visual Basic
Sub Add(Definition As MoveFaceDefinition, Result As [out, retval] MoveFaceFeature*)
Parameters
Parameters | Description
Definition | MoveFaceDefinition object that defines the move face feature you want to create. A MoveFaceDefinition object can be created using the MoveFaceFeatures.CreateDefinition method. It can also be obtained from an existing MoveFaceFeature object.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Methods > MoveFaceFeatures.Add Method


MoveFaceFeatures.CreateDefinition Method

MoveFaceFeatures.CreateDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new MoveFaceDefinition object

Visual Basic
Sub CreateDefinition(Faces As FaceCollection, Result As [out, retval] MoveFaceDefinition*)
Parameters
Parameters | Description
Faces | FaceCollection object that specifies the faces to move.
Remarks

The object created does not represent a move face feature but instead is a representation of the information that defines a move face feature. You can use this object as input to the MoveFaceFeatures.Add method to create the actual feature.

The MoveFaceDefinition object returned is fully defined and can be used to create a move face feature. However, defaults are used for move face options, so you may want to change some of the property values of the MoveFaceDefinition object before using it to create a feature.

You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Methods > MoveFaceFeatures.CreateDefinition Method


MoveFaceFeatures.Item Method

MoveFaceFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified feature object from the collection. This is the default property of this collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] MoveFaceFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Methods > MoveFaceFeatures.Item Method


MoveFaceFeatures Properties

MoveFaceFeatures Properties
Summary

The properties of the MoveFaceFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Properties


MoveFaceFeatures.Application Property

MoveFaceFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Properties > MoveFaceFeatures.Application Property


MoveFaceFeatures.Count Property

MoveFaceFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Properties > MoveFaceFeatures.Count Property


MoveFaceFeatures.Type Property

MoveFaceFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MoveFaceFeatures Interface > MoveFaceFeatures Properties > MoveFaceFeatures.Type Property


MoveFeature Interface

MoveFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Use a MoveFeature object to drag an extrude, revolve, or sweep feature to a new location by supplying a transformation matrix.

Class Hierarchy
Inventor::PartFeature
    Inventor::MoveFeature
        Inventor::MoveFeatureProxy
Visual Basic
Public Interface MoveFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

MoveFeatureProxy.NativeObject

MoveFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > MoveFeature Interface


MoveFeature Properties

MoveFeature Properties
Summary

The properties of the MoveFeature class are listed here.

Properties
Name | Description
Transformation | A transformation matrix that moves an extrude, revolve, or sweep feature to a new location.
You are here: Symbol Reference > Inventor Library > Objects > MoveFeature Interface > MoveFeature Properties


MoveFeature.Transformation Property

MoveFeature.Transformation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

A transformation matrix that moves an extrude, revolve, or sweep feature to a new location.

Visual Basic
Property Transformation() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > MoveFeature Interface > MoveFeature Properties > MoveFeature.Transformation Property


MoveFeatureProxy Interface

MoveFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the MoveFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::MoveFeature
        Inventor::MoveFeatureProxy
Visual Basic
Public Interface MoveFeatureProxy
Inherits MoveFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > MoveFeatureProxy Interface


MoveFeatureProxy Properties

MoveFeatureProxy Properties
Summary

The properties of the MoveFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatureProxy Interface > MoveFeatureProxy Properties


MoveFeatureProxy.ContainingOccurrence Property

MoveFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MoveFeatureProxy Interface > MoveFeatureProxy Properties > MoveFeatureProxy.ContainingOccurrence Property


MoveFeatureProxy.NativeObject Property

MoveFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As MoveFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > MoveFeatureProxy Interface > MoveFeatureProxy Properties > MoveFeatureProxy.NativeObject Property


MoveFeatures Interface

MoveFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The MoveFeatures object provides access to all of the MoveFeature objects in a part.

Class Hierarchy
Inventor::MoveFeatures
Visual Basic
Public Interface MoveFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.MoveFeatures

You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface


MoveFeatures Methods

MoveFeatures Methods
Summary

The methods of the MoveFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface > MoveFeatures Methods


MoveFeatures.Item Method

MoveFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] MoveFeature*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface > MoveFeatures Methods > MoveFeatures.Item Method


MoveFeatures Properties

MoveFeatures Properties
Summary

The properties of the MoveFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface > MoveFeatures Properties


MoveFeatures.Application Property

MoveFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface > MoveFeatures Properties > MoveFeatures.Application Property


MoveFeatures.Count Property

MoveFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface > MoveFeatures Properties > MoveFeatures.Count Property


MoveFeatures.Type Property

MoveFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > MoveFeatures Interface > MoveFeatures Properties > MoveFeatures.Type Property


NameValueMap Interface

NameValueMap Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The NameValueMap object. This object provides context-specific information, usually the context in which an event occurred. For more information, see the Event Context Information article in the overview section.

Class Hierarchy
Inventor::NameValueMap
Visual Basic
Public Interface NameValueMap
Inherits IDispatch
Notes

Members through which this object may be accessed include:

MemberManager.GetUserParametersFromInstance

SurfaceBody.GetASMAttributes

TransientObjects.CreateNameValueMap

See Also

Transient surface body creation sample

Transient solid body creation sample

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

Create assembly occurrence with representations sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface


NameValueMap Methods

NameValueMap Methods
Summary

The methods of the NameValueMap class are listed here.

Methods
Methods
Name | Description
Add | Add a value associated to the specified key name.
Clear | Removes all objects from the map.
Insert | Method that insert a name value pair into the name value map with specified location.
Remove | Removes the specified object from the map.
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Methods


NameValueMap.Add Method

NameValueMap.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Add a value associated to the specified key name.

Visual Basic
Sub Add(Name As String, Value As VARIANT)
Parameters
Parameters | Description
Name | Input String that specifies the name of the key.
Value | Input Variant value that specifies the value of the attribute.
See Also

Export to DWF sample

Create base view with representations (C#) sample

Create flat pattern drawing view sample

Adding Representation views sample

Open assembly document with Representations (C#) sample

Open assembly document with Representations sample

Create assembly occurrence with representations sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Methods > NameValueMap.Add Method


NameValueMap.Clear Method

NameValueMap.Clear Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Removes all objects from the map.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Methods > NameValueMap.Clear Method


NameValueMap.Insert Method

NameValueMap.Insert Method Available in Inventor Introduced in Inventor 2012
Summary

Method that insert a name value pair into the name value map with specified location.

Visual Basic
Sub Insert(Name As String, Value As VARIANT, ByRef TargetIndex As [optional] VARIANT, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
Name | Input String that specifies the name of the key.
Value | Input Variant value that specifies the value of the attribute.
TargetIndex | Optional input an index that specifies the existing name value pair next to which the new name value pair will be inserted. This can either be a numeric value indicating the index of an existing name value pair, or it can be a string indicating the name of an existing name value pair in the NameValueMap. If this is not specified, the new name value pair will be added at the end.
InsertBefore | Optional input Boolean indicating if the name value pair should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is not specified.
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Methods > NameValueMap.Insert Method


NameValueMap.Remove Method

NameValueMap.Remove Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Removes the specified object from the map.

Visual Basic
Sub Remove(Index As VARIANT)
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Methods > NameValueMap.Remove Method


NameValueMap Properties

NameValueMap Properties
Summary

The properties of the NameValueMap class are listed here.

Methods
Methods
Name | Description
Item | Gets the value at the specified index number or key name.
Name | Property that returns the name associated with the specified integer index.
Value | Specifies the value associated with the specified key name.
Properties
Name | Description
Count | Property that returns the count of name - value pairs in the map.
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Properties


NameValueMap.Count Property

NameValueMap.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the count of name - value pairs in the map.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Properties > NameValueMap.Count Property


NameValueMap.Item Method

NameValueMap.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the value at the specified index number or key name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] VARIANT)
Parameters
Parameters | Description
index | Input Variant that specifies the index of the value to return.
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Properties > NameValueMap.Item Method


NameValueMap.Name Method

NameValueMap.Name Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the name associated with the specified integer index.

Visual Basic
Sub Name(Index As long, Result As [out, retval] BSTR)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Properties > NameValueMap.Name Method


NameValueMap.Value Method

NameValueMap.Value Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the value associated with the specified key name.

Visual Basic
Sub Value(Name As String, Value As VARIANT)
Parameters
Parameters | Description
Name | Input String that specifies the name of the key.
You are here: Symbol Reference > Inventor Library > Objects > NameValueMap Interface > NameValueMap Properties > NameValueMap.Value Method


NativeBrowserNodeDefinition CoClass

NativeBrowserNodeDefinition CoClass Available in Inventor Introduced in Inventor 8
Summary

The BrowserNodeDefinition object contains the definition of a node in the browser.

Class Hierarchy
Inventor::NativeBrowserNodeDefinition
Visual Basic
Public Class NativeBrowserNodeDefinition
Notes

Members through which this object may be accessed include:

BrowserPanes.GetNativeBrowserNodeDefinition

See Also

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinition CoClass


NativeBrowserNodeDefinitionObject Interface

NativeBrowserNodeDefinitionObject Interface
Summary

The NativeBrowserNodeDefinition object derives from the BrowserNodeDefinition and contains the definition for a native-created node in the browser. The properties, methods and events listed below are in addition to those supported by the BrowserNodeDefinition object.

Class Hierarchy
Inventor::BrowserNodeDefinition
    Inventor::NativeBrowserNodeDefinitionObject
Visual Basic
Public Interface NativeBrowserNodeDefinitionObject
Inherits BrowserNodeDefinition
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface


NativeBrowserNodeDefinitionObject Properties

NativeBrowserNodeDefinitionObject Properties
Summary

The properties of the NativeBrowserNodeDefinitionObject class are listed here.

Properties
Name | Description
ExpandedIcon | Property returning an IPictureDisp of a 16X16 pixel image. This is the icon that is used when the corresponding BrowserNode is in an expanded state. This may return Nothing. In this case, the expanded state of the BrowserNode uses the Icon.
Icon | Property returning an IPictureDisp of a 16X16 pixel image. This is the icon that is used when the corresponding BrowserNode is in a non-expanded state or collapsed state.
NativeObject | Property that returns the Inventor object represented by this node.
OverrideExpandedIcon | Property that gets and sets any override on the expanded icon of an existing definition object. If this returns Nothing, no override is present. Setting this to Nothing removes any override.
OverrideIcon | Property that gets and sets any override on the icon of an existing definition object. If this returns Nothing, no override is present. Setting this to Nothing removes any override.
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface > NativeBrowserNodeDefinitionObject Properties


NativeBrowserNodeDefinitionObject.ExpandedIcon Property

NativeBrowserNodeDefinitionObject.ExpandedIcon Property
Summary

Property returning an IPictureDisp of a 16X16 pixel image. This is the icon that is used when the corresponding BrowserNode is in an expanded state. This may return Nothing. In this case, the expanded state of the BrowserNode uses the Icon.

Visual Basic
Property ExpandedIcon() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface > NativeBrowserNodeDefinitionObject Properties > NativeBrowserNodeDefinitionObject.ExpandedIcon Property


NativeBrowserNodeDefinitionObject.Icon Property

NativeBrowserNodeDefinitionObject.Icon Property
Summary

Property returning an IPictureDisp of a 16X16 pixel image. This is the icon that is used when the corresponding BrowserNode is in a non-expanded state or collapsed state.

Visual Basic
Property Icon() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface > NativeBrowserNodeDefinitionObject Properties > NativeBrowserNodeDefinitionObject.Icon Property


NativeBrowserNodeDefinitionObject.NativeObject Property

NativeBrowserNodeDefinitionObject.NativeObject Property
Summary

Property that returns the Inventor object represented by this node.

Visual Basic
Property NativeObject() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface > NativeBrowserNodeDefinitionObject Properties > NativeBrowserNodeDefinitionObject.NativeObject Property


NativeBrowserNodeDefinitionObject.OverrideExpandedIcon Property

NativeBrowserNodeDefinitionObject.OverrideExpandedIcon Property
Summary

Property that gets and sets any override on the expanded icon of an existing definition object. If this returns Nothing, no override is present. Setting this to Nothing removes any override.

Visual Basic
Property OverrideExpandedIcon() As ClientNodeResource *
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface > NativeBrowserNodeDefinitionObject Properties > NativeBrowserNodeDefinitionObject.OverrideExpandedIcon Property


NativeBrowserNodeDefinitionObject.OverrideIcon Property

NativeBrowserNodeDefinitionObject.OverrideIcon Property
Summary

Property that gets and sets any override on the icon of an existing definition object. If this returns Nothing, no override is present. Setting this to Nothing removes any override.

Visual Basic
Property OverrideIcon() As ClientNodeResource *
You are here: Symbol Reference > Inventor Library > Objects > NativeBrowserNodeDefinitionObject Interface > NativeBrowserNodeDefinitionObject Properties > NativeBrowserNodeDefinitionObject.OverrideIcon Property


NonLinearEdgeWorkPointDef Interface

NonLinearEdgeWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Object that allows you to get and set the information that specifies a work point using a non-linear edge.

Class Hierarchy
Inventor::NonLinearEdgeWorkPointDef
Visual Basic
Public Interface NonLinearEdgeWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > NonLinearEdgeWorkPointDef Interface


NonLinearEdgeWorkPointDef Properties

NonLinearEdgeWorkPointDef Properties
Summary

The properties of the NonLinearEdgeWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Edge | Property that returns a non-linear Edge object.
Parent | Property that returns the parent WorkPoint object.
Type | Property that returns kNonLinearEdgeWorkPointDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > NonLinearEdgeWorkPointDef Interface > NonLinearEdgeWorkPointDef Properties


NonLinearEdgeWorkPointDef.Application Property

NonLinearEdgeWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NonLinearEdgeWorkPointDef Interface > NonLinearEdgeWorkPointDef Properties > NonLinearEdgeWorkPointDef.Application Property


NonLinearEdgeWorkPointDef.Edge Property

NonLinearEdgeWorkPointDef.Edge Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a non-linear Edge object.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > NonLinearEdgeWorkPointDef Interface > NonLinearEdgeWorkPointDef Properties > NonLinearEdgeWorkPointDef.Edge Property


NonLinearEdgeWorkPointDef.Parent Property

NonLinearEdgeWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > NonLinearEdgeWorkPointDef Interface > NonLinearEdgeWorkPointDef Properties > NonLinearEdgeWorkPointDef.Parent Property


NonLinearEdgeWorkPointDef.Type Property

NonLinearEdgeWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns kNonLinearEdgeWorkPointDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > NonLinearEdgeWorkPointDef Interface > NonLinearEdgeWorkPointDef Properties > NonLinearEdgeWorkPointDef.Type Property


NonParametricBaseFeature Interface

NonParametricBaseFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The NonParametricBaseFeature object represents the feature that is created when a foreign file is translated into an Autodesk Inventor part file. If the foreign file defines a solid, it is read in and used to define the base feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::NonParametricBaseFeature
        Inventor::NonParametricBaseFeatureProxy
Visual Basic
Public Interface NonParametricBaseFeature
Inherits PartFeature
Remarks

There isn't an explicit command to create a base feature. It is created as a result of translating a foreign file using the Open command or API calls to translate foreign files. The base feature must be the first feature created in a file and only one base feature can exist in a part. This used to be called the BaseFeature object. The NonParametricBaseFeature object currently doesn't support any methods or properties in addition to those on the PartFeature base class object.

Notes

Members through which this object may be accessed include:

NonParametricBaseFeatureProxy.NativeObject

NonParametricBaseFeatures.Add

NonParametricBaseFeatures.AddByDefinition

NonParametricBaseFeatures.Item

PartFeatures.NonParametricBaseFeature

See Also

Transient surface body creation sample

Create primitive BRep sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface


NonParametricBaseFeature Methods

NonParametricBaseFeature Methods
Summary

The methods of the NonParametricBaseFeature class are listed here.

Methods
Methods
Name | Description
DeleteFaces |
Edit | Edits the base feature.
ExitEdit | Exits the edit context of the base feature.
Redefine | Method that redefines the geometric contents of a non-parametric base feature.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Methods


NonParametricBaseFeature.DeleteFaces Method

NonParametricBaseFeature.DeleteFaces Method Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Sub DeleteFaces(Faces As ObjectCollection)
Notes

For information on this item, please refer to TransientBRep::DeleteFaces, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Methods > NonParametricBaseFeature.DeleteFaces Method


NonParametricBaseFeature.Edit Method

NonParametricBaseFeature.Edit Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Edits the base feature.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Methods > NonParametricBaseFeature.Edit Method


NonParametricBaseFeature.ExitEdit Method

NonParametricBaseFeature.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Exits the edit context of the base feature.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Methods > NonParametricBaseFeature.ExitEdit Method


NonParametricBaseFeature.Redefine Method

NonParametricBaseFeature.Redefine Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that redefines the geometric contents of a non-parametric base feature.

Visual Basic
Sub Redefine(BRepEntities As IDispatch)
Parameters
Parameters | Description
BRepEntities | Input Object that defines the entity(s) that will replace the existing entity(s). The input for this argument must currently be a SurfaceBody object.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Methods > NonParametricBaseFeature.Redefine Method


NonParametricBaseFeature Properties

NonParametricBaseFeature Properties
Summary

The properties of the NonParametricBaseFeature class are listed here.

Properties
Name | Description
InputSurfaceBodies | Property that returns the underlying SurfaceBody object associated with this feature.
IsAssociative | Property that indicates whether this contents of this base feature are associatively copied from bodies and faces in the assembly.
IsComposite | Property that indicates if the non-parametric base feature is a composite of multiple solids and/or surfaces or is a single solid or surface.
IsSolid | Indicates whether this base feature is a solid or surface.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Properties


NonParametricBaseFeature.InputSurfaceBodies Property

NonParametricBaseFeature.InputSurfaceBodies Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the underlying SurfaceBody object associated with this feature.

Visual Basic
Property InputSurfaceBodies() As SurfaceBodies**
Remarks

Inventor stores the original SurfaceBody used to create this non-parametric base feature and then uses this stored SurfaceBody whenever the feature needs to be recomputed. This SurfaceBody is not the same SurfaceBody that is displayed in Inventor and may be quite different geometrically depending on what has been done to model with subsequent features.

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Properties > NonParametricBaseFeature.InputSurfaceBodies Property


NonParametricBaseFeature.IsAssociative Property

NonParametricBaseFeature.IsAssociative Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that indicates whether this contents of this base feature are associatively copied from bodies and faces in the assembly.

Visual Basic
Property IsAssociative() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Properties > NonParametricBaseFeature.IsAssociative Property


NonParametricBaseFeature.IsComposite Property

NonParametricBaseFeature.IsComposite Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates if the non-parametric base feature is a composite of multiple solids and/or surfaces or is a single solid or surface.

Visual Basic
Property IsComposite() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Properties > NonParametricBaseFeature.IsComposite Property


NonParametricBaseFeature.IsSolid Property

NonParametricBaseFeature.IsSolid Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Indicates whether this base feature is a solid or surface.

Visual Basic
Property IsSolid() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeature Interface > NonParametricBaseFeature Properties > NonParametricBaseFeature.IsSolid Property


NonParametricBaseFeatureDefinition Interface

NonParametricBaseFeatureDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The NonParametricBaseFeatureDefinition is a utility object used for creating, querying, and editing non-parametric base features. A NonParametricBaseFeatureDefinition object can be created using the CreateDefinition method of the NonParametricBaseFeatures collection object. They can also be obtained from existing NonParametricBaseFeature objects.

Class Hierarchy
Inventor::NonParametricBaseFeatureDefinition
Visual Basic
Public Interface NonParametricBaseFeatureDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

NonParametricBaseFeatures.CreateDefinition

See Also

Associative body copy sample

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface


NonParametricBaseFeatureDefinition Properties

NonParametricBaseFeatureDefinition Properties
Summary

The properties of the NonParametricBaseFeatureDefinition class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor, 'ApprenticeServerComponent' when running with the Apprentice Server or 'ServerApplication' when running with Inventor Server.
BRepEntities | Property that defines the geometry to be used for creating the non-parametric base feature. The input is an ObjectCollection which can contain one or more Face or SurfaceBody objects.
DeleteOriginal | Property that defines if the original geometry in the construction environment is deleted. This has no affect when the original geometry exists in the parametric environment or is a transient B-Rep entity. Defaults to True when the NonParametricBaseFeatureDefinition is created.
IsAssociative | Property that defines if the copied geometry should be associative to the original geometry.
OutputType | Property that specifies the desired result type.
TargetOccurrence | Property that sets the target occurrence when copying the surface body from one occurrence into another. When using the Copy Object command, the target occurrence is determined by the occurrence in-place activated occurrence.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties


NonParametricBaseFeatureDefinition.Application Property

NonParametricBaseFeatureDefinition.Application Property Introduced in Inventor 2011
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor, 'ApprenticeServerComponent' when running with the Apprentice Server or 'ServerApplication' when running with Inventor Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties > NonParametricBaseFeatureDefinition.Application Property


NonParametricBaseFeatureDefinition.BRepEntities Property

NonParametricBaseFeatureDefinition.BRepEntities Property Introduced in Inventor 2011
Summary

Property that defines the geometry to be used for creating the non-parametric base feature. The input is an ObjectCollection which can contain one or more Face or SurfaceBody objects.

Visual Basic
Property BRepEntities() As ObjectCollection*
Remarks

The collection must consist of only Face or only SurfaceBody objects and cannot be a mixture of the two. SurfaceBody's can be either solid or not. Any wire information associated with the SurfaceBody is ignored. If this is being used to copy geometry from one file to another in the context of an assembly, the B-Rep entities provided need to be proxy objects in the context of the top-level assembly.

See Also

Associative body copy sample

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties > NonParametricBaseFeatureDefinition.BRepEntities Property


NonParametricBaseFeatureDefinition.DeleteOriginal Property

NonParametricBaseFeatureDefinition.DeleteOriginal Property Introduced in Inventor 2011
Summary

Property that defines if the original geometry in the construction environment is deleted. This has no affect when the original geometry exists in the parametric environment or is a transient B-Rep entity. Defaults to True when the NonParametricBaseFeatureDefinition is created.

Visual Basic
Property DeleteOriginal() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties > NonParametricBaseFeatureDefinition.DeleteOriginal Property


NonParametricBaseFeatureDefinition.IsAssociative Property

NonParametricBaseFeatureDefinition.IsAssociative Property Introduced in Inventor 2011
Summary

Property that defines if the copied geometry should be associative to the original geometry.

Visual Basic
Property IsAssociative() As VARIANT_BOOL
Remarks

Before this property can be set to True the TargetOccurence property must be set with a valid occurrence. This is also only valid when used in the context of an assembly and where the BRepEntities argument consists of a SurfaceBody or Face objects from other parts and are represented by SurfaceBodyProxy or FaceProxy objects in the context of the top-level assembly. The output type must be kSurfaceResultType or kCompositeResultType for this to be valid. If any of these conditions are not met the result will be created as a non-associative copy.

See Also

Associative body copy sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties > NonParametricBaseFeatureDefinition.IsAssociative Property


NonParametricBaseFeatureDefinition.OutputType Property

NonParametricBaseFeatureDefinition.OutputType Property Introduced in Inventor 2011
Summary

Property that specifies the desired result type.

Visual Basic
Property OutputType() As BaseFeatureOutputTypeEnum
Remarks

The types are kSurfaceResultType, kSolidResultType, and kCompositeResultType and are described in detail below. Defaults to kCompositeResultType when the NonParametricBaseFeatureDefinition is created.

kSurfaceOutputType: Specifies that the result is to be a work surface. Valid input includes a single SurfaceBody object (can be a solid or not) or a single Face object.

kSolidOutputType: Specifies that the result is to be a solid. This can only be specified when the SurfaceBody(s) provided as input for the BRepEntities argument represent solid bodies. If an ObjectCollection of solid SurfaceBody objects is provided the result will be a single NonParametricBaseFeature that contains a single SurfaceBody with a FaceShell for each of the original input SurfaceBody objects.

kMultipleSolidsOutputType: Specifies that the result is to be multiple solids. This can only be specified when the SurfaceBody(s) provided as input for the BRepData argument represent solid bodies. If an ObjectCollection of solid SurfaceBody objects is provided the result will be a NonParameterBaseFeature object and an associated SurfaceBody for each input SurfaceBody object.

kCompositeOutputType: Specifies that a composite non-parametric base feature is to be created that contains multiple bodies. This can be used in all cases and can result in surfaces and solids being created. The result in this case is a single NonParametricBaseBody with a SurfaceBody for each SurfaceBody or connected set of faces that was input.

See Also

Associative body copy sample

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties > NonParametricBaseFeatureDefinition.OutputType Property


NonParametricBaseFeatureDefinition.TargetOccurrence Property

NonParametricBaseFeatureDefinition.TargetOccurrence Property Introduced in Inventor 2011
Summary

Property that sets the target occurrence when copying the surface body from one occurrence into another. When using the Copy Object command, the target occurrence is determined by the occurrence in-place activated occurrence.

Visual Basic
Property TargetOccurrence() As ComponentOccurrence*
Remarks

When using the API you need to explicitly define the target. The target occurrence provided must be in the context of the top-level assembly where the source and target exists. It will be a ComponentOccurrence if it's a top-level occurrence or a ComponentOccurrenceProxy if it's in a lower level. Setting the IsAssociative property to True will cause the copy to be associative, otherwise a non-associate copy will be made.

See Also

Associative body copy sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureDefinition Interface > NonParametricBaseFeatureDefinition Properties > NonParametricBaseFeatureDefinition.TargetOccurrence Property


NonParametricBaseFeatureProxy Interface

NonParametricBaseFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the NonParametricBaseFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::NonParametricBaseFeature
        Inventor::NonParametricBaseFeatureProxy
Visual Basic
Public Interface NonParametricBaseFeatureProxy
Inherits NonParametricBaseFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureProxy Interface


NonParametricBaseFeatureProxy Properties

NonParametricBaseFeatureProxy Properties
Summary

The properties of the NonParametricBaseFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureProxy Interface > NonParametricBaseFeatureProxy Properties


NonParametricBaseFeatureProxy.ContainingOccurrence Property

NonParametricBaseFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureProxy Interface > NonParametricBaseFeatureProxy Properties > NonParametricBaseFeatureProxy.ContainingOccurrence Property


NonParametricBaseFeatureProxy.NativeObject Property

NonParametricBaseFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As NonParametricBaseFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatureProxy Interface > NonParametricBaseFeatureProxy Properties > NonParametricBaseFeatureProxy.NativeObject Property


NonParametricBaseFeatures Interface

NonParametricBaseFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The object represented the base solid that was created when a file was imported into Autodesk Inventor.

Class Hierarchy
Inventor::NonParametricBaseFeatures
Visual Basic
Public Interface NonParametricBaseFeatures
Inherits IDispatch
Remarks

Prior to Autodesk Inventor 6 there could only be one of these at a time in a part, so the API supported the NonParametricBaseFeature property on the PartFeatures collection object to obtain this single object. Autodesk Inventor now supports multiple features of this type in a single document. This new NonParametricBaseFeatures collection object has been implemented on the PartFeatures collection object to allow you to iterate through all of them. The previous property still exists but has been hidden in the type library. If there are multiple NonParametricBaseFeatures in a part it will arbitrarily return one of them. Because this is a new capability existing binaries and source should continue to work correctly; however it's recommended to change code to use the new collection and add logic to handle the case of multiple features of this type.

Notes

Members through which this object may be accessed include:

PartFeatures.NonParametricBaseFeatures

See Also

Associative body copy sample

Transient surface body creation sample

Create primitive BRep sample

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface


NonParametricBaseFeatures Methods

NonParametricBaseFeatures Methods
Summary

The methods of the NonParametricBaseFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a NonParametricBaseFeature to the collection.
AddByDefinition | Method that creates a new NonParametricBaseFeature object.
CreateDefinition | Method that creates and returns a NonParametricBaseFeatureDefinition object. This object is not a non-parametric base feature but contains the information that defines one and be used to create a new non-parametric base feature.
Item | Property that returns the specified NonParametricBaseFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Methods


NonParametricBaseFeatures.Add Method

NonParametricBaseFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that adds a NonParametricBaseFeature to the collection.

Visual Basic
Sub Add(SurfaceBody As SurfaceBody, ByRef Transform As [optional] VARIANT, Result As [out, retval] NonParametricBaseFeature*)
Parameters
Parameters | Description
SurfaceBody | Input SurfaceBody to create the new NonParametricBaseFeature in the collection.
Transform | Optional input Variant that specifies the transformation for the new NonParametricBaseFeature in the collection.
See Also

Create primitive BRep sample

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Methods > NonParametricBaseFeatures.Add Method


NonParametricBaseFeatures.AddByDefinition Method

NonParametricBaseFeatures.AddByDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new NonParametricBaseFeature object.

Visual Basic
Sub AddByDefinition(Definition As NonParametricBaseFeatureDefinition, Result As [out, retval] NonParametricBaseFeature*)
Parameters
Parameters | Description
Definition | Input NonParametricBaseFeatureDefinition object that defines all of the input required to create a non-parametric base feature. A NonParametricBaseFeatureDefinition object is created using the CreateDefinition method of the NonParametricBaseFeatures collection object.
Remarks

This method is very similar to the Copy Object command. A difference is that the use of this method will only ever result in the creation of a single NonParametricBaseFeature object whereas in some case the Copy Object command will create multiple base features. If you need to reproduce these cases using the API you'll need to call this method multiple times, once for each required base feature.

See Also

Transient surface body creation sample

Example

Associative body copy example.

The following sample demonstrates copying bodies (associatively and non-associatively) across parts in an assembly. Before running the sample, create an assembly with two parts in it. The sample copies the body from the first part into the second part.

Sub AssociativeBodyCopy()

    ' Set a reference to the active assembly document.
    Dim oAssemblyDoc As AssemblyDocument
    Set oAssemblyDoc = ThisApplication.ActiveDocument

    Dim oAssemblyDef As AssemblyComponentDefinition
    Set oAssemblyDef = oAssemblyDoc.ComponentDefinition

    Dim oOccurrence1 As ComponentOccurrence
    Set oOccurrence1 = oAssemblyDef.Occurrences.Item(1)

    Dim oPartDef1 As PartComponentDefinition
    Set oPartDef1 = oOccurrence1.Definition

    Dim oOccurrence2 As ComponentOccurrence
    Set oOccurrence2 = oAssemblyDef.Occurrences.Item(2)

    Dim oPartDef2 As PartComponentDefinition
    Set oPartDef2 = oOccurrence2.Definition

    ' Get the source solid body from the first part.
    Dim oSourceBody As SurfaceBody
    Set oSourceBody = oPartDef1.SurfaceBodies.Item(1)

    Dim oSourceBodyProxy As SurfaceBodyProxy
    Call oOccurrence1.CreateGeometryProxy(oSourceBody, oSourceBodyProxy)

    ' Create an associative surface base feature in the second part.
    Dim oFeatureDef1 As NonParametricBaseFeatureDefinition
    Set oFeatureDef1 = oPartDef2.Features.NonParametricBaseFeatures.CreateDefinition

    Dim oCollection As ObjectCollection
    Set oCollection = ThisApplication.TransientObjects.CreateObjectCollection

    oCollection.Add oSourceBodyProxy

    oFeatureDef1.BRepEntities = oCollection
    oFeatureDef1.OutputType = kSurfaceOutputType
    oFeatureDef1.TargetOccurrence = oOccurrence2
    oFeatureDef1.IsAssociative = True

    Dim oBaseFeature1 As NonParametricBaseFeature
    Set oBaseFeature1 = oPartDef2.Features.NonParametricBaseFeatures.AddByDefinition(oFeatureDef1)

    ' Create a non-associative solid base feature in the second part.
    Dim oFeatureDef2 As NonParametricBaseFeatureDefinition
    Set oFeatureDef2 = oPartDef2.Features.NonParametricBaseFeatures.CreateDefinition

    oFeatureDef2.BRepEntities = oCollection
    oFeatureDef2.OutputType = kSolidOutputType
    oFeatureDef2.TargetOccurrence = oOccurrence2

    Dim oBaseFeature2 As NonParametricBaseFeature
    Set oBaseFeature2 = oPartDef2.Features.NonParametricBaseFeatures.AddByDefinition(oFeatureDef2)

    oAssemblyDoc.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Methods > NonParametricBaseFeatures.AddByDefinition Method


NonParametricBaseFeatures.CreateDefinition Method

NonParametricBaseFeatures.CreateDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates and returns a NonParametricBaseFeatureDefinition object. This object is not a non-parametric base feature but contains the information that defines one and be used to create a new non-parametric base feature.

Visual Basic
Sub CreateDefinition(Result As [out, retval] NonParametricBaseFeatureDefinition*)
See Also

Associative body copy sample

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Methods > NonParametricBaseFeatures.CreateDefinition Method


NonParametricBaseFeatures.Item Method

NonParametricBaseFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified NonParametricBaseFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] NonParametricBaseFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the NonParametricBaseFeature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the border definition's name. If an out-of-range index or a name of a non-existent border definition is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Methods > NonParametricBaseFeatures.Item Method


NonParametricBaseFeatures Properties

NonParametricBaseFeatures Properties
Summary

The properties of the NonParametricBaseFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Properties


NonParametricBaseFeatures.Application Property

NonParametricBaseFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Properties > NonParametricBaseFeatures.Application Property


NonParametricBaseFeatures.Count Property

NonParametricBaseFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Properties > NonParametricBaseFeatures.Count Property


NonParametricBaseFeatures.Type Property

NonParametricBaseFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > NonParametricBaseFeatures Interface > NonParametricBaseFeatures Properties > NonParametricBaseFeatures.Type Property


NormalToCurveWorkPlaneDef Interface

NormalToCurveWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The NormalToCurveWorkPlaneDef object that allows you to get and set the information that specifies a work plane defined as normal to a curve and through a point.

Class Hierarchy
Inventor::NormalToCurveWorkPlaneDef
Visual Basic
Public Interface NormalToCurveWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface


NormalToCurveWorkPlaneDef Methods

NormalToCurveWorkPlaneDef Methods
Summary

The methods of the NormalToCurveWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that returns all of the data defining a work plane defined by a curve and a point.
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Methods


NormalToCurveWorkPlaneDef.GetData Method

NormalToCurveWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns all of the data defining a work plane defined by a curve and a point.

Visual Basic
Sub GetData(ByRef CurveEntity As IDispatch*, ByRef Point As IDispatch*)
Parameters
Parameters | Description
CurveEntity | Output argument that returns the curve object used to define the NormalToCurveWorkPlaneDef. This object can be an Edge, 3D Sketch entity, or 2D Sketch entity.
Point | Output argument that returns the point object used to define the NormalToCurveWorkPlaneDef. This object can be a WorkPoint, Vertex, SketchPoint3D, or SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Methods > NormalToCurveWorkPlaneDef.GetData Method


NormalToCurveWorkPlaneDef Properties

NormalToCurveWorkPlaneDef Properties
Summary

The properties of the NormalToCurveWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CurveEntity | Property that returns the curve entity of a normal to curve defined work plane. This object can be an Edge, 3D Sketch entity, or 2D Sketch entity.
Parent | Property that returns the parent object from whom this object can logically be reached.
Point | Property that returns the point of a normal to curve defined work plane. The point can be a WorkPoint, Vertex, SketchPoint3D or SketchPoint object. The work plane passes through the point.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Properties


NormalToCurveWorkPlaneDef.Application Property

NormalToCurveWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Properties > NormalToCurveWorkPlaneDef.Application Property


NormalToCurveWorkPlaneDef.CurveEntity Property

NormalToCurveWorkPlaneDef.CurveEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the curve entity of a normal to curve defined work plane. This object can be an Edge, 3D Sketch entity, or 2D Sketch entity.

Visual Basic
Property CurveEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Properties > NormalToCurveWorkPlaneDef.CurveEntity Property


NormalToCurveWorkPlaneDef.Parent Property

NormalToCurveWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Properties > NormalToCurveWorkPlaneDef.Parent Property


NormalToCurveWorkPlaneDef.Point Property

NormalToCurveWorkPlaneDef.Point Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the point of a normal to curve defined work plane. The point can be a WorkPoint, Vertex, SketchPoint3D or SketchPoint object. The work plane passes through the point.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Properties > NormalToCurveWorkPlaneDef.Point Property


NormalToCurveWorkPlaneDef.Type Property

NormalToCurveWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > NormalToCurveWorkPlaneDef Interface > NormalToCurveWorkPlaneDef Properties > NormalToCurveWorkPlaneDef.Type Property


NormalToSurfaceWorkAxisDef Interface

NormalToSurfaceWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

Object that allows you to get and set the information that specifies a work axis defined normal to a surface and through a point.

Class Hierarchy
Inventor::NormalToSurfaceWorkAxisDef
Visual Basic
Public Interface NormalToSurfaceWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface


NormalToSurfaceWorkAxisDef Methods

NormalToSurfaceWorkAxisDef Methods
Summary

The methods of the NormalToSurfaceWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work axis defined normal to a surface at a point.
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Methods


NormalToSurfaceWorkAxisDef.GetData Method

NormalToSurfaceWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that gets all of the data defining a work axis defined normal to a surface at a point.

Visual Basic
Sub GetData(ByRef Point As IDispatch*, ByRef SurfaceEntity As IDispatch*)
Parameters
Parameters | Description
Point | Output object that represents a Point. This object can be a WorkPoint, Vertex, SketchPoint3D, or SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Methods > NormalToSurfaceWorkAxisDef.GetData Method


NormalToSurfaceWorkAxisDef Properties

NormalToSurfaceWorkAxisDef Properties
Summary

The properties of the NormalToSurfaceWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent WorkAxis object.
Point | Property that returns the point of a normal to surface defined work axis. The point can be a WorkPoint, Vertex, SketchPoint3D or SketchPoint object. The work axis passes through the point.
SurfaceEntity | Property that returns the surface entity of a normal to surface defined work axis. This object can be a Face, WorkPlane, or PlanarSketch.
Type | Property that returns kNormalToSurfaceWorkAxisDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Properties


NormalToSurfaceWorkAxisDef.Application Property

NormalToSurfaceWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Properties > NormalToSurfaceWorkAxisDef.Application Property


NormalToSurfaceWorkAxisDef.Parent Property

NormalToSurfaceWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Properties > NormalToSurfaceWorkAxisDef.Parent Property


NormalToSurfaceWorkAxisDef.Point Property

NormalToSurfaceWorkAxisDef.Point Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the point of a normal to surface defined work axis. The point can be a WorkPoint, Vertex, SketchPoint3D or SketchPoint object. The work axis passes through the point.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Properties > NormalToSurfaceWorkAxisDef.Point Property


NormalToSurfaceWorkAxisDef.SurfaceEntity Property

NormalToSurfaceWorkAxisDef.SurfaceEntity Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the surface entity of a normal to surface defined work axis. This object can be a Face, WorkPlane, or PlanarSketch.

Visual Basic
Property SurfaceEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Properties > NormalToSurfaceWorkAxisDef.SurfaceEntity Property


NormalToSurfaceWorkAxisDef.Type Property

NormalToSurfaceWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns kNormalToSurfaceWorkAxisDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > NormalToSurfaceWorkAxisDef Interface > NormalToSurfaceWorkAxisDef Properties > NormalToSurfaceWorkAxisDef.Type Property


NotebookOptions Interface

NotebookOptions Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The NotebookOptions object provides access to properties that provide read and write access of the notebook related application options. This is somewhat equivalent to the Notebook tab of the Application Options dialog.

Class Hierarchy
Inventor::NotebookOptions
Visual Basic
Public Interface NotebookOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.NotebookOptions

You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface


NotebookOptions Properties

NotebookOptions Properties
Summary

The properties of the NotebookOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ArrowColor | Property that gets and sets the color for arrows in design notes.
DisplayNoteIcons | Property that enables or disables displaying icons for design notes in the graphics window. A value of True enables icon display. Note: If multiple notes are attached to a single item, a symbol is displayed only for the first note.
DisplayNoteText | Property that enables or disables displaying text for design notes when the cursor pauses over a note symbol in the graphics window. The text is displayed in a pop-up window. A value of True enables text display.
KeepNotesOnDeletedObjects | Property that specifies whether design notes associated with model geometry should be retained after the geometry has been deleted. A value of True specifies that notes attached to deleted geometry should be retained.
NoteHighlightColor | Property that gets and sets the color for the highlighted component in note views.
TextBackgroundColor | Property that gets and sets the background color for the comment boxes in design notes.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties


NotebookOptions.Application Property

NotebookOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.Application Property


NotebookOptions.ArrowColor Property

NotebookOptions.ArrowColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the color for arrows in design notes.

Visual Basic
Property ArrowColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.ArrowColor Property


NotebookOptions.DisplayNoteIcons Property

NotebookOptions.DisplayNoteIcons Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables displaying icons for design notes in the graphics window. A value of True enables icon display.

Note: If multiple notes are attached to a single item, a symbol is displayed only for the first note.

Visual Basic
Property DisplayNoteIcons() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.DisplayNoteIcons Property


NotebookOptions.DisplayNoteText Property

NotebookOptions.DisplayNoteText Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables displaying text for design notes when the cursor pauses over a note symbol in the graphics window. The text is displayed in a pop-up window. A value of True enables text display.

Visual Basic
Property DisplayNoteText() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.DisplayNoteText Property


NotebookOptions.KeepNotesOnDeletedObjects Property

NotebookOptions.KeepNotesOnDeletedObjects Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether design notes associated with model geometry should be retained after the geometry has been deleted. A value of True specifies that notes attached to deleted geometry should be retained.

Visual Basic
Property KeepNotesOnDeletedObjects() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.KeepNotesOnDeletedObjects Property


NotebookOptions.NoteHighlightColor Property

NotebookOptions.NoteHighlightColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the color for the highlighted component in note views.

Visual Basic
Property NoteHighlightColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.NoteHighlightColor Property


NotebookOptions.TextBackgroundColor Property

NotebookOptions.TextBackgroundColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the background color for the comment boxes in design notes.

Visual Basic
Property TextBackgroundColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.TextBackgroundColor Property


NotebookOptions.Type Property

NotebookOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > NotebookOptions Interface > NotebookOptions Properties > NotebookOptions.Type Property


ObjectCollection Interface

ObjectCollection Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Generic collection of weakly-typed objects (IDispatch).

Class Hierarchy
Inventor::ObjectsEnumerator
    Inventor::ObjectCollection
        Inventor::EdgeCollection
        Inventor::FaceCollection
Visual Basic
Public Interface ObjectCollection
Inherits ObjectsEnumerator
Notes

Members through which this object may be accessed include:

AttributeManager.FindObjects

AttributeManager.FindObjectsByPattern

CircularPatternFeature.ParentFeatures

ClientFeature.HiddenParameters

ClientFeatureDefinition.FeatureInputs

CoreCavityDefinition.HolePatches

CoreCavityDefinition.Inserts

CoreCavityDefinition.RunoffSurfaces

DerivedParameterTable.LinkedParameters

DraftAnalysis.Faces

Face.ThreadInfos

GeneralDimensions.GetRetrievableDimensions

HoleFeature.HoleCenterPoints

KnitFeature.Surfaces

LoftDefinition.Sections

LoftFeature.Rails

LoftFeature.Sections

MirrorFeature.ParentFeatures

MoldDefinition.HolePatches

MoldDefinition.InsertBodies

MoldDefinition.RunoffSurfaces

NonParametricBaseFeatureDefinition.BRepEntities

OccurrencePattern.ParentComponents

Parameter.Dependents

Parameter.DrivenBy

PunchToolFeature.PunchCenterPoints

RectangularPatternFeature.ParentFeatures

SculptFeature.Surfaces

SketchHolePlacementDefinition.HoleCenterPoints

SplineFitPointsConstraint3D.Points

TransientObjects.CreateObjectCollection

WorkAxis.Dependents

WorkAxis.DrivenBy

WorkPlane.Dependents

WorkPlane.DrivenBy

WorkPoint.Dependents

WorkPoint.DrivenBy

BoundaryPatchLoop.BoundaryPath

See Also

Transient surface body creation sample

Add assembly occurrences to a new folder sample

Baseline dimension sets sample

Edit profile of an extrude feature sample

Add surface texture symbol to dimension sample

Sketch Spline sample

Spline - create NURBS sample

Create sketched symbol and leader sample

Create sketched symbol and leader sample

Offset a 2D sketch sample

Move sketch entities sample

Add a punch tool feature sample

Selectively link paramaters sample

Copy a sketch sample

Delete Face, Boundary Patch and Stitch features. sample

Creation a balloon sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > ObjectCollection Interface


ObjectCollection Methods

ObjectCollection Methods
Summary

The methods of the ObjectCollection class are listed here.

Methods
Methods
Name | Description
Add | Adds an object to the generic collection.
Clear | Removes all objects from the generic collection.
Remove | Method that removes the specified object from the generic collection.
RemoveByObject | Method that removes the specified object from the generic object collection.
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollection Interface > ObjectCollection Methods


ObjectCollection.Add Method

ObjectCollection.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Adds an object to the generic collection.

Visual Basic
Sub Add(Object As IDispatch)
Parameters
Parameters | Description
Object | Input Object to add to the collection.
See Also

Transient surface body creation sample

Add assembly occurrences to a new folder sample

Baseline dimension sets sample

Add surface texture symbol to dimension sample

Sketch Spline sample

Create sketched symbol and leader sample

Offset a 2D sketch sample

Move sketch entities sample

Finding Bend Extent (Tangent) Edges sample

Selectively link paramaters sample

Delete Face, Boundary Patch and Stitch features. sample

Creation a balloon sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > ObjectCollection Interface > ObjectCollection Methods > ObjectCollection.Add Method


ObjectCollection.Clear Method

ObjectCollection.Clear Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Removes all objects from the generic collection.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollection Interface > ObjectCollection Methods > ObjectCollection.Clear Method


ObjectCollection.Remove Method

ObjectCollection.Remove Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that removes the specified object from the generic collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to remove.
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollection Interface > ObjectCollection Methods > ObjectCollection.Remove Method


ObjectCollection.RemoveByObject Method

ObjectCollection.RemoveByObject Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that removes the specified object from the generic object collection.

Visual Basic
Sub RemoveByObject(Object As IDispatch)
Parameters
Parameters | Description
Object | Input Object to remove.
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollection Interface > ObjectCollection Methods > ObjectCollection.RemoveByObject Method


ObjectCollectionByVariant Interface

ObjectCollectionByVariant Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Generic collection of weakly-typed objects (IDispatch).

Class Hierarchy
Inventor::ObjectsEnumeratorByVariant
    Inventor::ObjectCollectionByVariant
Visual Basic
Public Interface ObjectCollectionByVariant
Inherits ObjectsEnumeratorByVariant
Notes

Members through which this object may be accessed include:

TransientObjects.CreateObjectCollectionByVariant

You are here: Symbol Reference > Inventor Library > Objects > ObjectCollectionByVariant Interface


ObjectCollectionByVariant Methods

ObjectCollectionByVariant Methods
Summary

The methods of the ObjectCollectionByVariant class are listed here.

Methods
Methods
Name | Description
Add | Adds an object to the generic collection.
Remove | Method that removes the specified object from the generic collection.
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollectionByVariant Interface > ObjectCollectionByVariant Methods


ObjectCollectionByVariant.Add Method

ObjectCollectionByVariant.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Adds an object to the generic collection.

Visual Basic
Sub Add(StringIndex As String, Object As IDispatch)
Parameters
Parameters | Description
StringIndex | Input String that specifies the index key for the item.
Object | Input Object to add to the collection.
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollectionByVariant Interface > ObjectCollectionByVariant Methods > ObjectCollectionByVariant.Add Method


ObjectCollectionByVariant.Remove Method

ObjectCollectionByVariant.Remove Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that removes the specified object from the generic collection.

Visual Basic
Sub Remove(Index As VARIANT)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the object to remove.
You are here: Symbol Reference > Inventor Library > Objects > ObjectCollectionByVariant Interface > ObjectCollectionByVariant Methods > ObjectCollectionByVariant.Remove Method


ObjectDefaultsStyle Interface

ObjectDefaultsStyle Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Object Defaults style is a sub-style of the active standard style. In a drawing document, after a standard is selected, the active Object Default style specifies which layer and object style provides the format definition for a particular object.

Class Hierarchy
Inventor::Style
    Inventor::ObjectDefaultsStyle
Visual Basic
Public Interface ObjectDefaultsStyle
Inherits Style
Remarks

Unlike other style types, only one Object Default style is available for each standard. When you select a standard, you set the active Object Default style.

Notes

Members through which this object may be accessed include:

DrawingStandardStyle.ActiveObjectDefaults

ObjectDefaultsStylesEnumerator.Item

Some objects do not have associative object styles, such as visible and hidden edges.

You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface


ObjectDefaultsStyle Properties

ObjectDefaultsStyle Properties
Summary

The properties of the ObjectDefaultsStyle class are listed here.

Properties
Name | Description
AngularDimensionLayer | Property that specifies which layer/object style provides the format definition for this object.
AngularDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
BalloonLayer | Property that specifies which layer/object style provides the format definition for this object.
BalloonStyle | Property that specifies which layer/object style provides the format definition for this object.
BaselineDimensionLayer | Property that specifies which layer/object style provides the format definition for this object.
BaselineDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
BendNoteLayer | Property that specifies which layer/object style provides the format definition for this object.
BendNoteStyle | Property that specifies which layer/object style provides the format definition for this object.
BendTableLayer | Property that gets and sets the default layer for bend tables.
BendTableStyle | Property that gets and sets the default style for bend tables.
BendTagLayer | Property that gets and sets the default layer for bend tags.
BendTagStyle | Property that gets and sets the default style for bend tags.
BorderGeometryLayer | Property that specifies which layer/object style provides the format definition for this object.
BorderTextLayer | Property that specifies which layer/object style provides the format definition for this object.
BorderTextStyle | Property that specifies which layer/object style provides the format definition for this object.
CenterlineLayer | Property that gets and sets the default layer for centerlines.
CenterlineStyle | Property that gets and sets the default style for centerlines.
CentermarkLayer | Property that gets and sets the default layer for center marks.
CentermarkStyle | Property that gets and sets the default style for center marks.
CenterOfGravityLayer | Property that gets and sets the default layer for center mark identifying the center of gravity.
CenterOfGravityStyle | Property that gets and sets the default style for center mark identifying the center of gravity.
ChainDimensionLayer | Property that gets and sets the default layer for chain dimension sets.
ChainDimensionStyle | Property that gets and sets the default style for chain dimension sets.
ChamferNoteLayer | Property that specifies which layer/object style provides the format definition for this object.
ChamferNoteStyle | Property that specifies which layer/object style provides the format definition for this object.
ConfigurationTableLayer | Property that gets and sets the default layer for configuration tables.
ConfigurationTableStyle | Property that gets and sets the default style for configuration tables.
DiameterDimensionLayer | Property that specifies which layer/object style provides the format definition for this object.
DiameterDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
FeatureControlFrameLayer | Property that specifies which layer/object style provides the format definition for this object.
FeatureControlFrameStyle | Property that specifies which layer/object style provides the format definition for this object.
GeneralNoteLayer | Property that specifies which layer/object style provides the format definition for this object.
GeneralNoteStyle | Property that specifies which layer/object style provides the format definition for this object.
HoleNoteLayer | Property that specifies which layer/object style provides the format definition for this object.
HoleNoteStyle | Property that specifies which layer/object style provides the format definition for this object.
HoleTableLayer | Property that specifies which layer/object style provides the format definition for this object.
HoleTableStyle | Property that specifies which layer/object style provides the format definition for this object.
HoleTagLayer | Property that specifies which layer/object style provides the format definition for this object.
HoleTagStyle | Property that specifies which layer/object style provides the format definition for this object.
LeaderTextLayer | Property that specifies which layer/object style provides the format definition for this object.
LeaderTextStyle | Property that specifies which layer/object style provides the format definition for this object.
LinearDimensionLayer | Property that specifies which layer/object style provides the format definition for this object.
LinearDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
OrdinateDimensionLayer | Property that specifies which layer/object style provides the format definition for this object.
OrdinateDimensionSetLayer | Property that specifies which layer/object style provides the format definition for this object.
OrdinateDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
OrdinateSetDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
OriginIndicatorLayer | Property that specifies which layer/object style provides the format definition for this object.
OriginIndicatorStyle | Property that specifies which layer/object style provides the format definition for this object.
PartsListLayer | Property that specifies which layer/object style provides the format definition for this object.
PartsListStyle | Property that gets and sets the default style for parts lists.
PunchNoteLayer | Property that specifies which layer/object style provides the format definition for this object.
PunchNoteStyle | Property that specifies which layer/object style provides the format definition for this object.
RadialDimensionLayer | Property that specifies which layer/object style provides the format definition for this object.
RadialDimensionStyle | Property that specifies which layer/object style provides the format definition for this object.
RevisionTableLayer | Property that gets and sets the default layer for revision tables.
RevisionTableStyle | Property that gets and sets the default style for revision tables.
RevisionTagLayer | Property that gets and sets the default layer for revision tags.
RevisionTagStyle | Property that gets and sets the default style for revision tags.
SheetMetalPunchLayer | Property that gets and sets the default layer for a center mark identifying a sheet metal punch origin.
SheetMetalPunchStyle | Property that gets and sets the default style for a center mark identifying a sheet metal punch origin.
Sketch3DGeometryLayer | Property that specifies which layer/object style provides the format definition for this object.
SketchedSymbolGeometryLayer | Property that specifies which layer/object style provides the format definition for this object.
SketchedSymbolLeaderLayer | Property that specifies which layer/object style provides the format definition for this object.
SketchedSymbolLeaderStyle | Property that specifies which layer/object style provides the format definition for this object.
SketchedSymbolTextLayer | Property that specifies which layer/object style provides the format definition for this object.
SketchedSymbolTextStyle | Property that specifies which layer/object style provides the format definition for this object.
SketchGeometryLayer | Property that specifies which layer/object style provides the format definition for this object.
SketchTextLayer | Property that specifies which layer/object style provides the format definition for this object.
SketchTextStyle | Property that specifies which layer/object style provides the format definition for this object.
SurfaceTextureLayer | Property that specifies which layer/object style provides the format definition for this object.
SurfaceTextureStyle | Property that specifies which layer/object style provides the format definition for this object.
TableLayer | Property that gets and sets the default layer for general (custom) tables.
TableStyle | Property that gets and sets the default style for general (custom) tables.
ThreadNoteLayer | Property that specifies which layer/object style provides the format definition for this object.
ThreadNoteStyle | Property that specifies which layer/object style provides the format definition for this object.
TitleBlockGeometryLayer | Property that specifies which layer/object style provides the format definition for this object.
TitleBlockTextLayer | Property that specifies which layer/object style provides the format definition for this object.
TitleBlockTextStyle | Property that specifies which layer/object style provides the format definition for this object.
ViewLabelLayer | Property that specifies which layer/object style provides the format definition for this object.
ViewLabelStyle | Property that specifies which layer/object style provides the format definition for this object.
WorkAxisLayer | Property that gets and sets the default layer for a centerline or center mark identifying a work axis.
WorkAxisStyle | Property that gets and sets the default layer for a centerline or center mark identifying a work axis.
WorkPlaneLayer | Property that gets and sets the default layer for a centerline identifying a work plane.
WorkPlaneStyle | Property that gets and sets the default style for a centerline identifying a work plane.
WorkPointLayer | Property that gets and sets the default layer for a center mark identifying a work point.
WorkPointStyle | Property that gets and sets the default style for a center mark identifying a work point.
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties


ObjectDefaultsStyle.AngularDimensionLayer Property

ObjectDefaultsStyle.AngularDimensionLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property AngularDimensionLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.AngularDimensionLayer Property


ObjectDefaultsStyle.AngularDimensionStyle Property

ObjectDefaultsStyle.AngularDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property AngularDimensionStyle() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.AngularDimensionStyle Property


ObjectDefaultsStyle.BalloonLayer Property

ObjectDefaultsStyle.BalloonLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BalloonLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BalloonLayer Property


ObjectDefaultsStyle.BalloonStyle Property

ObjectDefaultsStyle.BalloonStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BalloonStyle() As BalloonStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BalloonStyle Property


ObjectDefaultsStyle.BaselineDimensionLayer Property

ObjectDefaultsStyle.BaselineDimensionLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BaselineDimensionLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BaselineDimensionLayer Property


ObjectDefaultsStyle.BaselineDimensionStyle Property

ObjectDefaultsStyle.BaselineDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BaselineDimensionStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BaselineDimensionStyle Property


ObjectDefaultsStyle.BendNoteLayer Property

ObjectDefaultsStyle.BendNoteLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BendNoteLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BendNoteLayer Property


ObjectDefaultsStyle.BendNoteStyle Property

ObjectDefaultsStyle.BendNoteStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BendNoteStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BendNoteStyle Property


ObjectDefaultsStyle.BendTableLayer Property

ObjectDefaultsStyle.BendTableLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for bend tables.

Visual Basic
Property BendTableLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BendTableLayer Property


ObjectDefaultsStyle.BendTableStyle Property

ObjectDefaultsStyle.BendTableStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for bend tables.

Visual Basic
Property BendTableStyle() As TableStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BendTableStyle Property


ObjectDefaultsStyle.BendTagLayer Property

ObjectDefaultsStyle.BendTagLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for bend tags.

Visual Basic
Property BendTagLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BendTagLayer Property


ObjectDefaultsStyle.BendTagStyle Property

ObjectDefaultsStyle.BendTagStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for bend tags.

Visual Basic
Property BendTagStyle() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BendTagStyle Property


ObjectDefaultsStyle.BorderGeometryLayer Property

ObjectDefaultsStyle.BorderGeometryLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BorderGeometryLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BorderGeometryLayer Property


ObjectDefaultsStyle.BorderTextLayer Property

ObjectDefaultsStyle.BorderTextLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BorderTextLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BorderTextLayer Property


ObjectDefaultsStyle.BorderTextStyle Property

ObjectDefaultsStyle.BorderTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property BorderTextStyle() As TextStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.BorderTextStyle Property


ObjectDefaultsStyle.CenterlineLayer Property

ObjectDefaultsStyle.CenterlineLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for centerlines.

Visual Basic
Property CenterlineLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.CenterlineLayer Property


ObjectDefaultsStyle.CenterlineStyle Property

ObjectDefaultsStyle.CenterlineStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default style for centerlines.

Visual Basic
Property CenterlineStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.CenterlineStyle Property


ObjectDefaultsStyle.CentermarkLayer Property

ObjectDefaultsStyle.CentermarkLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for center marks.

Visual Basic
Property CentermarkLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.CentermarkLayer Property


ObjectDefaultsStyle.CentermarkStyle Property

ObjectDefaultsStyle.CentermarkStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default style for center marks.

Visual Basic
Property CentermarkStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.CentermarkStyle Property


ObjectDefaultsStyle.CenterOfGravityLayer Property

ObjectDefaultsStyle.CenterOfGravityLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for center mark identifying the center of gravity.

Visual Basic
Property CenterOfGravityLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.CenterOfGravityLayer Property


ObjectDefaultsStyle.CenterOfGravityStyle Property

ObjectDefaultsStyle.CenterOfGravityStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default style for center mark identifying the center of gravity.

Visual Basic
Property CenterOfGravityStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.CenterOfGravityStyle Property


ObjectDefaultsStyle.ChainDimensionLayer Property

ObjectDefaultsStyle.ChainDimensionLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for chain dimension sets.

Visual Basic
Property ChainDimensionLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ChainDimensionLayer Property


ObjectDefaultsStyle.ChainDimensionStyle Property

ObjectDefaultsStyle.ChainDimensionStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for chain dimension sets.

Visual Basic
Property ChainDimensionStyle() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ChainDimensionStyle Property


ObjectDefaultsStyle.ChamferNoteLayer Property

ObjectDefaultsStyle.ChamferNoteLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property ChamferNoteLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ChamferNoteLayer Property


ObjectDefaultsStyle.ChamferNoteStyle Property

ObjectDefaultsStyle.ChamferNoteStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property ChamferNoteStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ChamferNoteStyle Property


ObjectDefaultsStyle.ConfigurationTableLayer Property

ObjectDefaultsStyle.ConfigurationTableLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for configuration tables.

Visual Basic
Property ConfigurationTableLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ConfigurationTableLayer Property


ObjectDefaultsStyle.ConfigurationTableStyle Property

ObjectDefaultsStyle.ConfigurationTableStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for configuration tables.

Visual Basic
Property ConfigurationTableStyle() As TableStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ConfigurationTableStyle Property


ObjectDefaultsStyle.DiameterDimensionLayer Property

ObjectDefaultsStyle.DiameterDimensionLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property DiameterDimensionLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.DiameterDimensionLayer Property


ObjectDefaultsStyle.DiameterDimensionStyle Property

ObjectDefaultsStyle.DiameterDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property DiameterDimensionStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.DiameterDimensionStyle Property


ObjectDefaultsStyle.FeatureControlFrameLayer Property

ObjectDefaultsStyle.FeatureControlFrameLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property FeatureControlFrameLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.FeatureControlFrameLayer Property


ObjectDefaultsStyle.FeatureControlFrameStyle Property

ObjectDefaultsStyle.FeatureControlFrameStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property FeatureControlFrameStyle() As FeatureControlFrameStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.FeatureControlFrameStyle Property


ObjectDefaultsStyle.GeneralNoteLayer Property

ObjectDefaultsStyle.GeneralNoteLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property GeneralNoteLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.GeneralNoteLayer Property


ObjectDefaultsStyle.GeneralNoteStyle Property

ObjectDefaultsStyle.GeneralNoteStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property GeneralNoteStyle() As TextStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.GeneralNoteStyle Property


ObjectDefaultsStyle.HoleNoteLayer Property

ObjectDefaultsStyle.HoleNoteLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property HoleNoteLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.HoleNoteLayer Property


ObjectDefaultsStyle.HoleNoteStyle Property

ObjectDefaultsStyle.HoleNoteStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property HoleNoteStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.HoleNoteStyle Property


ObjectDefaultsStyle.HoleTableLayer Property

ObjectDefaultsStyle.HoleTableLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property HoleTableLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.HoleTableLayer Property


ObjectDefaultsStyle.HoleTableStyle Property

ObjectDefaultsStyle.HoleTableStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property HoleTableStyle() As HoleTableStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.HoleTableStyle Property


ObjectDefaultsStyle.HoleTagLayer Property

ObjectDefaultsStyle.HoleTagLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property HoleTagLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.HoleTagLayer Property


ObjectDefaultsStyle.HoleTagStyle Property

ObjectDefaultsStyle.HoleTagStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property HoleTagStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.HoleTagStyle Property


ObjectDefaultsStyle.LeaderTextLayer Property

ObjectDefaultsStyle.LeaderTextLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property LeaderTextLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.LeaderTextLayer Property


ObjectDefaultsStyle.LeaderTextStyle Property

ObjectDefaultsStyle.LeaderTextStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property LeaderTextStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.LeaderTextStyle Property


ObjectDefaultsStyle.LinearDimensionLayer Property

ObjectDefaultsStyle.LinearDimensionLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property LinearDimensionLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.LinearDimensionLayer Property


ObjectDefaultsStyle.LinearDimensionStyle Property

ObjectDefaultsStyle.LinearDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property LinearDimensionStyle() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.LinearDimensionStyle Property


ObjectDefaultsStyle.OrdinateDimensionLayer Property

ObjectDefaultsStyle.OrdinateDimensionLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property OrdinateDimensionLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.OrdinateDimensionLayer Property


ObjectDefaultsStyle.OrdinateDimensionSetLayer Property

ObjectDefaultsStyle.OrdinateDimensionSetLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property OrdinateDimensionSetLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.OrdinateDimensionSetLayer Property


ObjectDefaultsStyle.OrdinateDimensionStyle Property

ObjectDefaultsStyle.OrdinateDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property OrdinateDimensionStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.OrdinateDimensionStyle Property


ObjectDefaultsStyle.OrdinateSetDimensionStyle Property

ObjectDefaultsStyle.OrdinateSetDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property OrdinateSetDimensionStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.OrdinateSetDimensionStyle Property


ObjectDefaultsStyle.OriginIndicatorLayer Property

ObjectDefaultsStyle.OriginIndicatorLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property OriginIndicatorLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.OriginIndicatorLayer Property


ObjectDefaultsStyle.OriginIndicatorStyle Property

ObjectDefaultsStyle.OriginIndicatorStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property OriginIndicatorStyle() As LeaderStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.OriginIndicatorStyle Property


ObjectDefaultsStyle.PartsListLayer Property

ObjectDefaultsStyle.PartsListLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property PartsListLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.PartsListLayer Property


ObjectDefaultsStyle.PartsListStyle Property

ObjectDefaultsStyle.PartsListStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for parts lists.

Visual Basic
Property PartsListStyle() As PartsListStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.PartsListStyle Property


ObjectDefaultsStyle.PunchNoteLayer Property

ObjectDefaultsStyle.PunchNoteLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property PunchNoteLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.PunchNoteLayer Property


ObjectDefaultsStyle.PunchNoteStyle Property

ObjectDefaultsStyle.PunchNoteStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property PunchNoteStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.PunchNoteStyle Property


ObjectDefaultsStyle.RadialDimensionLayer Property

ObjectDefaultsStyle.RadialDimensionLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property RadialDimensionLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.RadialDimensionLayer Property


ObjectDefaultsStyle.RadialDimensionStyle Property

ObjectDefaultsStyle.RadialDimensionStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property RadialDimensionStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.RadialDimensionStyle Property


ObjectDefaultsStyle.RevisionTableLayer Property

ObjectDefaultsStyle.RevisionTableLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for revision tables.

Visual Basic
Property RevisionTableLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.RevisionTableLayer Property


ObjectDefaultsStyle.RevisionTableStyle Property

ObjectDefaultsStyle.RevisionTableStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for revision tables.

Visual Basic
Property RevisionTableStyle() As RevisionTableStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.RevisionTableStyle Property


ObjectDefaultsStyle.RevisionTagLayer Property

ObjectDefaultsStyle.RevisionTagLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for revision tags.

Visual Basic
Property RevisionTagLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.RevisionTagLayer Property


ObjectDefaultsStyle.RevisionTagStyle Property

ObjectDefaultsStyle.RevisionTagStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for revision tags.

Visual Basic
Property RevisionTagStyle() As RevisionTableStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.RevisionTagStyle Property


ObjectDefaultsStyle.SheetMetalPunchLayer Property

ObjectDefaultsStyle.SheetMetalPunchLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for a center mark identifying a sheet metal punch origin.

Visual Basic
Property SheetMetalPunchLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SheetMetalPunchLayer Property


ObjectDefaultsStyle.SheetMetalPunchStyle Property

ObjectDefaultsStyle.SheetMetalPunchStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default style for a center mark identifying a sheet metal punch origin.

Visual Basic
Property SheetMetalPunchStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SheetMetalPunchStyle Property


ObjectDefaultsStyle.Sketch3DGeometryLayer Property

ObjectDefaultsStyle.Sketch3DGeometryLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property Sketch3DGeometryLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.Sketch3DGeometryLayer Property


ObjectDefaultsStyle.SketchedSymbolGeometryLayer Property

ObjectDefaultsStyle.SketchedSymbolGeometryLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchedSymbolGeometryLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchedSymbolGeometryLayer Property


ObjectDefaultsStyle.SketchedSymbolLeaderLayer Property

ObjectDefaultsStyle.SketchedSymbolLeaderLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchedSymbolLeaderLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchedSymbolLeaderLayer Property


ObjectDefaultsStyle.SketchedSymbolLeaderStyle Property

ObjectDefaultsStyle.SketchedSymbolLeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchedSymbolLeaderStyle() As LeaderStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchedSymbolLeaderStyle Property


ObjectDefaultsStyle.SketchedSymbolTextLayer Property

ObjectDefaultsStyle.SketchedSymbolTextLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchedSymbolTextLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchedSymbolTextLayer Property


ObjectDefaultsStyle.SketchedSymbolTextStyle Property

ObjectDefaultsStyle.SketchedSymbolTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchedSymbolTextStyle() As TextStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchedSymbolTextStyle Property


ObjectDefaultsStyle.SketchGeometryLayer Property

ObjectDefaultsStyle.SketchGeometryLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchGeometryLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchGeometryLayer Property


ObjectDefaultsStyle.SketchTextLayer Property

ObjectDefaultsStyle.SketchTextLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchTextLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchTextLayer Property


ObjectDefaultsStyle.SketchTextStyle Property

ObjectDefaultsStyle.SketchTextStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SketchTextStyle() As TextStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SketchTextStyle Property


ObjectDefaultsStyle.SurfaceTextureLayer Property

ObjectDefaultsStyle.SurfaceTextureLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SurfaceTextureLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SurfaceTextureLayer Property


ObjectDefaultsStyle.SurfaceTextureStyle Property

ObjectDefaultsStyle.SurfaceTextureStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property SurfaceTextureStyle() As SurfaceTextureStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.SurfaceTextureStyle Property


ObjectDefaultsStyle.TableLayer Property

ObjectDefaultsStyle.TableLayer Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default layer for general (custom) tables.

Visual Basic
Property TableLayer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.TableLayer Property


ObjectDefaultsStyle.TableStyle Property

ObjectDefaultsStyle.TableStyle Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the default style for general (custom) tables.

Visual Basic
Property TableStyle() As TableStyle*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.TableStyle Property


ObjectDefaultsStyle.ThreadNoteLayer Property

ObjectDefaultsStyle.ThreadNoteLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property ThreadNoteLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ThreadNoteLayer Property


ObjectDefaultsStyle.ThreadNoteStyle Property

ObjectDefaultsStyle.ThreadNoteStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property ThreadNoteStyle() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ThreadNoteStyle Property


ObjectDefaultsStyle.TitleBlockGeometryLayer Property

ObjectDefaultsStyle.TitleBlockGeometryLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property TitleBlockGeometryLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.TitleBlockGeometryLayer Property


ObjectDefaultsStyle.TitleBlockTextLayer Property

ObjectDefaultsStyle.TitleBlockTextLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property TitleBlockTextLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.TitleBlockTextLayer Property


ObjectDefaultsStyle.TitleBlockTextStyle Property

ObjectDefaultsStyle.TitleBlockTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property TitleBlockTextStyle() As TextStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.TitleBlockTextStyle Property


ObjectDefaultsStyle.ViewLabelLayer Property

ObjectDefaultsStyle.ViewLabelLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property ViewLabelLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ViewLabelLayer Property


ObjectDefaultsStyle.ViewLabelStyle Property

ObjectDefaultsStyle.ViewLabelStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies which layer/object style provides the format definition for this object.

Visual Basic
Property ViewLabelStyle() As TextStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.ViewLabelStyle Property


ObjectDefaultsStyle.WorkAxisLayer Property

ObjectDefaultsStyle.WorkAxisLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for a centerline or center mark identifying a work axis.

Visual Basic
Property WorkAxisLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.WorkAxisLayer Property


ObjectDefaultsStyle.WorkAxisStyle Property

ObjectDefaultsStyle.WorkAxisStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for a centerline or center mark identifying a work axis.

Visual Basic
Property WorkAxisStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.WorkAxisStyle Property


ObjectDefaultsStyle.WorkPlaneLayer Property

ObjectDefaultsStyle.WorkPlaneLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for a centerline identifying a work plane.

Visual Basic
Property WorkPlaneLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.WorkPlaneLayer Property


ObjectDefaultsStyle.WorkPlaneStyle Property

ObjectDefaultsStyle.WorkPlaneStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default style for a centerline identifying a work plane.

Visual Basic
Property WorkPlaneStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.WorkPlaneStyle Property


ObjectDefaultsStyle.WorkPointLayer Property

ObjectDefaultsStyle.WorkPointLayer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default layer for a center mark identifying a work point.

Visual Basic
Property WorkPointLayer() As Layer *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.WorkPointLayer Property


ObjectDefaultsStyle.WorkPointStyle Property

ObjectDefaultsStyle.WorkPointStyle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default style for a center mark identifying a work point.

Visual Basic
Property WorkPointStyle() As CentermarkStyle *
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStyle Interface > ObjectDefaultsStyle Properties > ObjectDefaultsStyle.WorkPointStyle Property


ObjectDefaultsStylesEnumerator Interface

ObjectDefaultsStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ObjectDefaultsStylesEnumerator object allows iteration through the collection.

Class Hierarchy
Inventor::ObjectDefaultsStylesEnumerator
Visual Basic
Public Interface ObjectDefaultsStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.ObjectDefaultsStyles

You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStylesEnumerator Interface


ObjectDefaultsStylesEnumerator Properties

ObjectDefaultsStylesEnumerator Properties
Summary

The properties of the ObjectDefaultsStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object in the collection.
Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStylesEnumerator Interface > ObjectDefaultsStylesEnumerator Properties


ObjectDefaultsStylesEnumerator.Application Property

ObjectDefaultsStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStylesEnumerator Interface > ObjectDefaultsStylesEnumerator Properties > ObjectDefaultsStylesEnumerator.Application Property


ObjectDefaultsStylesEnumerator.Count Property

ObjectDefaultsStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStylesEnumerator Interface > ObjectDefaultsStylesEnumerator Properties > ObjectDefaultsStylesEnumerator.Count Property


ObjectDefaultsStylesEnumerator.Item Method

ObjectDefaultsStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ObjectDefaultsStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ObjectDefaultsStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the internal name of a ObjectDefaultsStyle. If an out of range index or a name of a non-existent ObjectDefaultsStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStylesEnumerator Interface > ObjectDefaultsStylesEnumerator Properties > ObjectDefaultsStylesEnumerator.Item Method


ObjectDefaultsStylesEnumerator.Type Property

ObjectDefaultsStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ObjectDefaultsStylesEnumerator Interface > ObjectDefaultsStylesEnumerator Properties > ObjectDefaultsStylesEnumerator.Type Property


ObjectsEnumerator Interface

ObjectsEnumerator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Generic enumerator for a group of objects. This enumerator will also support the IEnumxxx-style interface (IEnumUnknown, unless otherwise specified).

Class Hierarchy
Inventor::ObjectsEnumerator
    Inventor::ObjectCollection
Visual Basic
Public Interface ObjectsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BreakOperation.AllAffectedViews

BreakOutOperation.AllAffectedViews

Centerline.FitPoints

Centermark.Centerlines

ComponentDefinition.FindUsingPoint

ComponentDefinition.FindUsingVector

DerivedAliasComponent.ResultFeatures

DerivedPartComponent.WorkFeatures

DrawingSketch.SetAutomatedCenterlineSettings

DrawingView.SetAutomatedCenterlineSettings

FeaturePatternElement.ResultFeatures

Line.IntersectWithCurve

Line.IntersectWithSurface

Line2d.IntersectWithCurve

LineSegment.IntersectWithCurve

LineSegment.IntersectWithSurface

LineSegment2d.IntersectWithCurve

MirrorFeature.ResultFeatures

OccurrencePatternElement.Components

PartsListRow.ReferencedRows

PlanarSketch.Dependents

Plane.IntersectWithCurve

PointInference.Entity

SelectEventsObject.SelectedEntities

Sheet.FindUsingPoint

SheetFormat.ReferencedSymbolDefinitions

Sketch.MoveSketchObjects

Sketch.RotateSketchObjects

Sketch3D.Dependents

SweepFeatures.GetProfileOrientationAtParam

ThreadInfo.ThreadBasePoints

See Also

True length of sweep feature sample

Sketch Delete sample

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumerator Interface


ObjectsEnumerator Methods

ObjectsEnumerator Methods
Summary

The methods of the ObjectsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumerator Interface > ObjectsEnumerator Methods


ObjectsEnumerator.Item Method

ObjectsEnumerator.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
See Also

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumerator Interface > ObjectsEnumerator Methods > ObjectsEnumerator.Item Method


ObjectsEnumerator Properties

ObjectsEnumerator Properties
Summary

The properties of the ObjectsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumerator Interface > ObjectsEnumerator Properties


ObjectsEnumerator.Count Property

ObjectsEnumerator.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Sketch Delete sample

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumerator Interface > ObjectsEnumerator Properties > ObjectsEnumerator.Count Property


ObjectsEnumerator.Type Property

ObjectsEnumerator.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumerator Interface > ObjectsEnumerator Properties > ObjectsEnumerator.Type Property


ObjectsEnumeratorByVariant Interface

ObjectsEnumeratorByVariant Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Generic enumerator for a group of objects. This enumerator will also support the IEnumxxx-style interface (IEnumUnknown, unless otherwise specified).

Class Hierarchy
Inventor::ObjectsEnumeratorByVariant
    Inventor::ObjectCollectionByVariant
Visual Basic
Public Interface ObjectsEnumeratorByVariant
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.Preferences

You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumeratorByVariant Interface


ObjectsEnumeratorByVariant Methods

ObjectsEnumeratorByVariant Methods
Summary

The methods of the ObjectsEnumeratorByVariant class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumeratorByVariant Interface > ObjectsEnumeratorByVariant Methods


ObjectsEnumeratorByVariant.Item Method

ObjectsEnumeratorByVariant.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumeratorByVariant Interface > ObjectsEnumeratorByVariant Methods > ObjectsEnumeratorByVariant.Item Method


ObjectsEnumeratorByVariant Properties

ObjectsEnumeratorByVariant Properties
Summary

The properties of the ObjectsEnumeratorByVariant class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumeratorByVariant Interface > ObjectsEnumeratorByVariant Properties


ObjectsEnumeratorByVariant.Count Property

ObjectsEnumeratorByVariant.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumeratorByVariant Interface > ObjectsEnumeratorByVariant Properties > ObjectsEnumeratorByVariant.Count Property


ObjectsEnumeratorByVariant.Type Property

ObjectsEnumeratorByVariant.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ObjectsEnumeratorByVariant Interface > ObjectsEnumeratorByVariant Properties > ObjectsEnumeratorByVariant.Type Property


ObjectVisibility Interface

ObjectVisibility Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::ObjectVisibility
Visual Basic
Public Interface ObjectVisibility
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.ObjectVisibility

PartDocument.ObjectVisibility

The ObjectVisibility object provides override visibility controls for objects in the document. Changes are not saved with the document.

You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface


ObjectVisibility Properties

ObjectVisibility Properties
Summary

The properties of the ObjectVisibility class are listed here.

Properties
Name | Description
AllWorkFeatures | Property that gets and sets whether all work features should be visible.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ConstructionSurfaces | Property that gets and sets whether construction work surfaces should be visible.
GroupDiagnostics | Property that gets and sets whether group diagnostics should be visible in the construction environment of parts. Returns False for assemblies.
GroupSolids | Property that gets and sets whether group solids should be visible in the construction environment of parts. Returns False for assemblies.
GroupSurfaces | Property that gets and sets whether group surfaces should be visible in the construction environment of parts. Returns False for assemblies.
GroupWires | Property that gets and sets whether group wires should be visible in the construction environment of parts. Returns False for assemblies.
OriginWorkAxes | Property that gets and sets whether origin work axes should be visible.
OriginWorkPlanes | Property that gets and sets whether origin work planes should be visible.
OriginWorkPoints | Property that gets and sets whether origin work points should be visible.
Parent | Property that returns the parent Document object.
Sketches | Property that gets and sets whether 2d sketches should be visible.
Sketches3D | Property that gets and sets whether 3d sketches should be visible.
Type | Returns an ObjectTypeEnum indicating this object's type.
UCSTriads | Property that gets and sets whether user coordinate system triads should be visible.
UCSWorkAxes | Property that gets and sets whether user coordinate system work axes should be visible.
UCSWorkPlanes | Property that gets and sets whether user coordinate system work planes should be visible.
UCSWorkPoints | Property that gets and sets whether user coordinate system work points should be visible.
UserWorkAxes | Property that gets and sets whether user work axes should be visible.
UserWorkPlanes | Property that gets and sets whether user work planes should be visible.
UserWorkPoints | Property that gets and sets whether user work points should be visible.
WeldmentSymbols | Property that gets and sets whether weldment symbols should be visible. Applies to assembly documents only. Returns False for parts.
Welds | Property that gets and sets whether welds should be visible. Applies to assembly documents only. Returns False for parts.
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties


ObjectVisibility.AllWorkFeatures Property

ObjectVisibility.AllWorkFeatures Property
Summary

Property that gets and sets whether all work features should be visible.

Visual Basic
Property AllWorkFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.AllWorkFeatures Property


ObjectVisibility.Application Property

ObjectVisibility.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.Application Property


ObjectVisibility.ConstructionSurfaces Property

ObjectVisibility.ConstructionSurfaces Property
Summary

Property that gets and sets whether construction work surfaces should be visible.

Visual Basic
Property ConstructionSurfaces() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.ConstructionSurfaces Property


ObjectVisibility.GroupDiagnostics Property

ObjectVisibility.GroupDiagnostics Property
Summary

Property that gets and sets whether group diagnostics should be visible in the construction environment of parts. Returns False for assemblies.

Visual Basic
Property GroupDiagnostics() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.GroupDiagnostics Property


ObjectVisibility.GroupSolids Property

ObjectVisibility.GroupSolids Property
Summary

Property that gets and sets whether group solids should be visible in the construction environment of parts. Returns False for assemblies.

Visual Basic
Property GroupSolids() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.GroupSolids Property


ObjectVisibility.GroupSurfaces Property

ObjectVisibility.GroupSurfaces Property
Summary

Property that gets and sets whether group surfaces should be visible in the construction environment of parts. Returns False for assemblies.

Visual Basic
Property GroupSurfaces() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.GroupSurfaces Property


ObjectVisibility.GroupWires Property

ObjectVisibility.GroupWires Property
Summary

Property that gets and sets whether group wires should be visible in the construction environment of parts. Returns False for assemblies.

Visual Basic
Property GroupWires() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.GroupWires Property


ObjectVisibility.OriginWorkAxes Property

ObjectVisibility.OriginWorkAxes Property
Summary

Property that gets and sets whether origin work axes should be visible.

Visual Basic
Property OriginWorkAxes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.OriginWorkAxes Property


ObjectVisibility.OriginWorkPlanes Property

ObjectVisibility.OriginWorkPlanes Property
Summary

Property that gets and sets whether origin work planes should be visible.

Visual Basic
Property OriginWorkPlanes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.OriginWorkPlanes Property


ObjectVisibility.OriginWorkPoints Property

ObjectVisibility.OriginWorkPoints Property
Summary

Property that gets and sets whether origin work points should be visible.

Visual Basic
Property OriginWorkPoints() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.OriginWorkPoints Property


ObjectVisibility.Parent Property

ObjectVisibility.Parent Property
Summary

Property that returns the parent Document object.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.Parent Property


ObjectVisibility.Sketches Property

ObjectVisibility.Sketches Property
Summary

Property that gets and sets whether 2d sketches should be visible.

Visual Basic
Property Sketches() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.Sketches Property


ObjectVisibility.Sketches3D Property

ObjectVisibility.Sketches3D Property
Summary

Property that gets and sets whether 3d sketches should be visible.

Visual Basic
Property Sketches3D() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.Sketches3D Property


ObjectVisibility.Type Property

ObjectVisibility.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.Type Property


ObjectVisibility.UCSTriads Property

ObjectVisibility.UCSTriads Property
Summary

Property that gets and sets whether user coordinate system triads should be visible.

Visual Basic
Property UCSTriads() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UCSTriads Property


ObjectVisibility.UCSWorkAxes Property

ObjectVisibility.UCSWorkAxes Property
Summary

Property that gets and sets whether user coordinate system work axes should be visible.

Visual Basic
Property UCSWorkAxes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UCSWorkAxes Property


ObjectVisibility.UCSWorkPlanes Property

ObjectVisibility.UCSWorkPlanes Property
Summary

Property that gets and sets whether user coordinate system work planes should be visible.

Visual Basic
Property UCSWorkPlanes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UCSWorkPlanes Property


ObjectVisibility.UCSWorkPoints Property

ObjectVisibility.UCSWorkPoints Property
Summary

Property that gets and sets whether user coordinate system work points should be visible.

Visual Basic
Property UCSWorkPoints() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UCSWorkPoints Property


ObjectVisibility.UserWorkAxes Property

ObjectVisibility.UserWorkAxes Property
Summary

Property that gets and sets whether user work axes should be visible.

Visual Basic
Property UserWorkAxes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UserWorkAxes Property


ObjectVisibility.UserWorkPlanes Property

ObjectVisibility.UserWorkPlanes Property
Summary

Property that gets and sets whether user work planes should be visible.

Visual Basic
Property UserWorkPlanes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UserWorkPlanes Property


ObjectVisibility.UserWorkPoints Property

ObjectVisibility.UserWorkPoints Property
Summary

Property that gets and sets whether user work points should be visible.

Visual Basic
Property UserWorkPoints() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.UserWorkPoints Property


ObjectVisibility.WeldmentSymbols Property

ObjectVisibility.WeldmentSymbols Property
Summary

Property that gets and sets whether weldment symbols should be visible. Applies to assembly documents only. Returns False for parts.

Visual Basic
Property WeldmentSymbols() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.WeldmentSymbols Property


ObjectVisibility.Welds Property

ObjectVisibility.Welds Property
Summary

Property that gets and sets whether welds should be visible. Applies to assembly documents only. Returns False for parts.

Visual Basic
Property Welds() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ObjectVisibility Interface > ObjectVisibility Properties > ObjectVisibility.Welds Property


OccurrencePattern Interface

OccurrencePattern Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The OccurrencePattern object is the base class for the FeatureBasedOccurrencePattern, RectangularOccurrencePattern, and CircularOccurrencePattern objects.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::CircularOccurrencePattern
    Inventor::FeatureBasedOccurrencePattern
    Inventor::RectangularOccurrencePattern
Visual Basic
Public Interface OccurrencePattern
Inherits IDispatch
Notes

Members through which this object may be accessed include:

OccurrencePatternElements.Parent

OccurrencePatterns.Item

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface


OccurrencePattern Methods

OccurrencePattern Methods
Summary

The methods of the OccurrencePattern class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the pattern.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Methods


OccurrencePattern.Delete Method

OccurrencePattern.Delete Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that deletes the pattern.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Methods > OccurrencePattern.Delete Method


OccurrencePattern.GetReferenceKey Method

OccurrencePattern.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Methods > OccurrencePattern.GetReferenceKey Method


OccurrencePattern Properties

OccurrencePattern Properties
Summary

The properties of the OccurrencePattern class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsPatternElement | Property that indicates whether this occurrence pattern is itself an element of a parent pattern. In the case where this occurrence pattern represents a pattern element, this property returns True. The PatternElement property can be used to get that pattern element.
Name | Property that indicates the name of this object or instance.
OccurrencePatternElements | Property returning an OccurrencePatternElements collection object. The first element within this collection will contain the components that were provided as input for the pattern.
Parent | Property that returns the parent of the object.
ParentComponents | Property that gets and sets the components used as input for the pattern.
PatternElement | Property that returns the pattern element this occurrence pattern represents. In the case where this occurrence pattern is not part of a parent pattern this property returns Nothing. The IsPatternElement property can be used to check if this occurrence pattern is part of a parent pattern.
Type | Property returning an enum indicating this object's type.
Visible | Gets/Sets the visibility of the pattern.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties


OccurrencePattern.Application Property

OccurrencePattern.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.Application Property


OccurrencePattern.AttributeSets Property

OccurrencePattern.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.AttributeSets Property


OccurrencePattern.HealthStatus Property

OccurrencePattern.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.HealthStatus Property


OccurrencePattern.IsPatternElement Property

OccurrencePattern.IsPatternElement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates whether this occurrence pattern is itself an element of a parent pattern. In the case where this occurrence pattern represents a pattern element, this property returns True. The PatternElement property can be used to get that pattern element.

Visual Basic
Property IsPatternElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.IsPatternElement Property


OccurrencePattern.Name Property

OccurrencePattern.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.Name Property


OccurrencePattern.OccurrencePatternElements Property

OccurrencePattern.OccurrencePatternElements Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an OccurrencePatternElements collection object. The first element within this collection will contain the components that were provided as input for the pattern.

Visual Basic
Property OccurrencePatternElements() As OccurrencePatternElements**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.OccurrencePatternElements Property


OccurrencePattern.Parent Property

OccurrencePattern.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.Parent Property


OccurrencePattern.ParentComponents Property

OccurrencePattern.ParentComponents Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the components used as input for the pattern.

Visual Basic
Property ParentComponents() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.ParentComponents Property


OccurrencePattern.PatternElement Property

OccurrencePattern.PatternElement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the pattern element this occurrence pattern represents. In the case where this occurrence pattern is not part of a parent pattern this property returns Nothing. The IsPatternElement property can be used to check if this occurrence pattern is part of a parent pattern.

Visual Basic
Property PatternElement() As OccurrencePatternElement**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.PatternElement Property


OccurrencePattern.Type Property

OccurrencePattern.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.Type Property


OccurrencePattern.Visible Property

OccurrencePattern.Visible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets/Sets the visibility of the pattern.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePattern Interface > OccurrencePattern Properties > OccurrencePattern.Visible Property


OccurrencePatternElement Interface

OccurrencePatternElement Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The OccurrencePatternElement object represents a single instance within an occurrence pattern.

Class Hierarchy
Inventor::OccurrencePatternElement
    Inventor::OccurrencePatternElementProxy
Visual Basic
Public Interface OccurrencePatternElement
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ComponentOccurrence.PatternElement

OccurrencePattern.PatternElement

OccurrencePatternElementProxy.NativeObject

OccurrencePatternElements.Item

RectangularOccurrencePattern.OccurrencePatternElement

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface


OccurrencePatternElement Properties

OccurrencePatternElement Properties
Summary

The properties of the OccurrencePatternElement class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Components | Property that returns the set of components that were created for this particular instance. There are cases where this collection can contain a count of zero. The obvious cases are when this element has been set to be independent or suppressed. There is another case when this element is the result of a feature based occurrence pattern and the instance it is associated with within the feature pattern has been suppressed.
Independent | Property that gets and sets whether the element is independent of the pattern or not. A value of True indicates this element has been made independent. The Suppressed and Independent properties are mutually exclusive. If either is set to True, attempting to set the other to True will result in an error.
Index | Property that returns the index of this element within the OccurrencePatternElements collection it is a member of.
Name | Property that returns the name of the element.
Occurrences | Property that returns the set of occurrences that were created for this particular instance.
Parent | Property that returns the parent occurrence pattern of the object.
Suppressed | Property that gets and sets whether the element is suppressed or not. A value of True indicates it is suppressed.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties


OccurrencePatternElement.Application Property

OccurrencePatternElement.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Application Property


OccurrencePatternElement.Components Property

OccurrencePatternElement.Components Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the set of components that were created for this particular instance. There are cases where this collection can contain a count of zero. The obvious cases are when this element has been set to be independent or suppressed. There is another case when this element is the result of a feature based occurrence pattern and the instance it is associated with within the feature pattern has been suppressed.

Visual Basic
Property Components() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Components Property


OccurrencePatternElement.Independent Property

OccurrencePatternElement.Independent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether the element is independent of the pattern or not. A value of True indicates this element has been made independent. The Suppressed and Independent properties are mutually exclusive. If either is set to True, attempting to set the other to True will result in an error.

Visual Basic
Property Independent() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Independent Property


OccurrencePatternElement.Index Property

OccurrencePatternElement.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of this element within the OccurrencePatternElements collection it is a member of.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Index Property


OccurrencePatternElement.Name Property

OccurrencePatternElement.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the name of the element.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Name Property


OccurrencePatternElement.Occurrences Property

OccurrencePatternElement.Occurrences Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the set of occurrences that were created for this particular instance.

Visual Basic
Property Occurrences() As ComponentOccurrencesEnumerator**
Remarks

If this pattern element consists of occurrence patterns, this property returns all the leaf occurrences within the occurrence pattern. Irrespective of how deeply nested the occurrences might be within any child patterns, this property will return all those occurrences after trimming the hierarchy path. On the other hand, if this pattern element consists of occurrences, this property will directly return those occurrences.

There are cases where this collection can contain a count of zero. The obvious cases are when this element has been set to be independent or suppressed. There is another case when this element is the result of a feature based occurrence pattern and the instance it is associated with within the feature pattern has been suppressed.

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Occurrences Property


OccurrencePatternElement.Parent Property

OccurrencePatternElement.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent occurrence pattern of the object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Parent Property


OccurrencePatternElement.Suppressed Property

OccurrencePatternElement.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether the element is suppressed or not. A value of True indicates it is suppressed.

Visual Basic
Property Suppressed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Suppressed Property


OccurrencePatternElement.Type Property

OccurrencePatternElement.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElement Interface > OccurrencePatternElement Properties > OccurrencePatternElement.Type Property


OccurrencePatternElementProxy Interface

OccurrencePatternElementProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OccurrencePatternElement object.

Class Hierarchy
Inventor::OccurrencePatternElement
    Inventor::OccurrencePatternElementProxy
Visual Basic
Public Interface OccurrencePatternElementProxy
Inherits OccurrencePatternElement
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElementProxy Interface


OccurrencePatternElementProxy Properties

OccurrencePatternElementProxy Properties
Summary

The properties of the OccurrencePatternElementProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElementProxy Interface > OccurrencePatternElementProxy Properties


OccurrencePatternElementProxy.ContainingOccurrence Property

OccurrencePatternElementProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElementProxy Interface > OccurrencePatternElementProxy Properties > OccurrencePatternElementProxy.ContainingOccurrence Property


OccurrencePatternElementProxy.NativeObject Property

OccurrencePatternElementProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As OccurrencePatternElement**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElementProxy Interface > OccurrencePatternElementProxy Properties > OccurrencePatternElementProxy.NativeObject Property


OccurrencePatternElements Interface

OccurrencePatternElements Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The OccurrencePatternElements collection object provides access to the instances ( objects) that result from the creation of a pattern.

Class Hierarchy
Inventor::OccurrencePatternElements
Visual Basic
Public Interface OccurrencePatternElements
Inherits IDispatch
Notes

Members through which this object may be accessed include:

OccurrencePattern.OccurrencePatternElements

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface


OccurrencePatternElements Methods

OccurrencePatternElements Methods
Summary

The methods of the OccurrencePatternElements class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified OccurrencePatternElement object from the collection. This is the default method of the OccurrencePatternElements collection object.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Methods


OccurrencePatternElements.Item Method

OccurrencePatternElements.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified OccurrencePatternElement object from the collection. This is the default method of the OccurrencePatternElements collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] OccurrencePatternElement*)
Parameters
Parameters | Description
index | Input Variant value that specifies the OccurrencePatternElement to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the element name. This is the name that is displayed to the user in the assembly browser. If an out-of-range index or a name of a non-existent element name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Methods > OccurrencePatternElements.Item Method


OccurrencePatternElements Properties

OccurrencePatternElements Properties
Summary

The properties of the OccurrencePatternElements class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Parent | Property that returns the parent OccurrencePattern object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Properties


OccurrencePatternElements.Application Property

OccurrencePatternElements.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Properties > OccurrencePatternElements.Application Property


OccurrencePatternElements.Count Property

OccurrencePatternElements.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Properties > OccurrencePatternElements.Count Property


OccurrencePatternElements.Parent Property

OccurrencePatternElements.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent OccurrencePattern object.

Visual Basic
Property Parent() As OccurrencePattern**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Properties > OccurrencePatternElements.Parent Property


OccurrencePatternElements.Type Property

OccurrencePatternElements.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatternElements Interface > OccurrencePatternElements Properties > OccurrencePatternElements.Type Property


OccurrencePatterns Interface

OccurrencePatterns Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The OccurrencePatterns collection object provides access to the existing assembly patterns ( objects) and supports methods to create new patterns.

Class Hierarchy
Inventor::OccurrencePatterns
Visual Basic
Public Interface OccurrencePatterns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.OccurrencePatterns

You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface


OccurrencePatterns Methods

OccurrencePatterns Methods
Summary

The methods of the OccurrencePatterns class are listed here.

Methods
Methods
Name | Description
AddCircularPattern | Method that creates a new circular occurrence pattern of input component(s).
AddFeatureBasedPattern | Method that creates a new occurrence pattern of the input component(s) using a pattern feature to define the positions of the elements within the pattern.
AddRectangularPattern | Method that creates a new rectangular occurrence pattern of input component(s).
Item | Method that returns the specified OccurrencePattern object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Methods


OccurrencePatterns.AddCircularPattern Method

OccurrencePatterns.AddCircularPattern Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new circular occurrence pattern of input component(s).

Visual Basic
Sub AddCircularPattern(ParentComponents As ObjectCollection, AxisEntity As IDispatch, AxisEntityNaturalDirection As VARIANT_BOOL, AngleOffset As VARIANT, Count As VARIANT, Result As [out, retval] CircularOccurrencePattern*)
Parameters
Parameters | Description
ParentComponents | Input ObjectCollection that contains the components to pattern. The valid objects that can be specified in the collection are ComponentOccurrence and OccurrencePattern objects.
AxisEntity | Input proxy object that defines the axis of the pattern. This can be a proxy to a linear edge or work axis in a part or subassembly, or it can be a work axis from the top-level assembly.
AxisEntityNaturalDirection | Input Boolean that specifies if the rotation direction of the pattern uses the natural direction of the axis entity. If True it uses the natural direction which defines the rotation direction using the right hand rule where the thumb is pointed in the direction of the axis. If False the direction is reversed.
AngleOffset | Input Variant that defines the angle offset between pattern instances. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
Count | Input Variant that defines the number of instances. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a string is input it must result in a unitless number.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Methods > OccurrencePatterns.AddCircularPattern Method


OccurrencePatterns.AddFeatureBasedPattern Method

OccurrencePatterns.AddFeatureBasedPattern Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new occurrence pattern of the input component(s) using a pattern feature to define the positions of the elements within the pattern.

Visual Basic
Sub AddFeatureBasedPattern(ParentComponents As ObjectCollection, FeaturePattern As PartFeature, Result As [out, retval] FeatureBasedOccurrencePattern*)
Parameters
Parameters | Description
ParentComponents | Input ObjectCollection that contains the components to pattern. The valid objects that can be specified in the collection are ComponentOccurrence and OccurrencePattern objects.
FeaturePattern | Input PatternFeatureProxy object that defines which pattern feature to use for this occurrence pattern.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Methods > OccurrencePatterns.AddFeatureBasedPattern Method


OccurrencePatterns.AddRectangularPattern Method

OccurrencePatterns.AddRectangularPattern Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new rectangular occurrence pattern of input component(s).

Visual Basic
Sub AddRectangularPattern(ParentComponents As ObjectCollection, ColumnEntity As IDispatch, ColumnEntityNaturalDirection As VARIANT_BOOL, ColumnOffset As VARIANT, ColumnCount As VARIANT, ByRef RowEntity As [optional] VARIANT, ByRef RowEntityNaturalDirection As [defaultvalue(-1)] VARIANT_BOOL, ByRef RowOffset As [optional] VARIANT, ByRef RowCount As [optional] VARIANT, Result As [out, retval] RectangularOccurrencePattern*)
Parameters
Parameters
Description
ParentComponents
Input ObjectCollection that contains the components to pattern. The valid objects that can be specified in the collection are ComponentOccurrence and OccurrencePattern objects.
ColumnEntity
Input proxy object that defines the column (x) direction of the pattern. This must be a proxy to a linear edge or a work axis.
ColumnEntityNaturalDirection
Input Boolean that specifies if the column direction is in the natural direction of the column entity or opposed. True if it is in the same direction as the natural direction of the column entity.
ColumnOffset
Input Variant that defines the distance between the columns. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ColumnCount
Input Variant that defines the number of columns. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a string is input it must result in a unitless number.
RowEntity
Optional input Variant that defines the row (y) direction of the pattern. This must be a proxy to a linear edge or a work axis. If this argument is left out then the pattern will have a single row and all subsequent arguments will be ignored.
RowEntityNaturalDirection
Optional input Boolean that specifies if the row direction is in the natural direction of the row entity or opposed. True if it is in the same direction as the natural direction of the row entity. This argument must be supplied if the RowEntity argument is provided; otherwise it is ignored.
RowOffset
Optional input Variant that defines the distance between the rows. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. This argument must be supplied if the RowEntity argument is provided; otherwise it is ignored.
RowCount
Optional input Variant that defines the number of rows. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a string is input it must result in a unitless number. This argument must be supplied if the RowEntity argument is provided; otherwise it is ignored.Sub PatternComponent()

' Set a reference to the active assembly document
Dim oDoc As AssemblyDocument
Set oDoc = ThisApplication.ActiveDocument

' Set a reference to the AssemblyComponentDefinition
Dim oDef As AssemblyComponentDefinition
Set oDef = oDoc.ComponentDefinition

' Get the x-axis of the assembly
Dim oXAxis As WorkAxis
Set oXAxis = oDef.WorkAxes.Item(1)

' Get the y-axis of the assembly
Dim oYAxis As WorkAxis
Set oYAxis = oDef.WorkAxes.Item(2)

Dim oParentOccs As ObjectCollection
Set oParentOccs = ThisApplication.TransientObjects.CreateObjectCollection

oParentOccs.Add oDef.Occurrences.Item(1)

' Create a rectangular pattern of components:
' 4 columns in the x-direction with an offset of 5 in
' 3 rows in the y-direction with an offset of 4 in
Dim oRectOccPattern As RectangularOccurrencePattern
Set oRectOccPattern = oDef.OccurrencePatterns.AddRectangularPattern( _
oParentOccs, oXAxis, True, "5 in", 4, oYAxis, True, "4 in", 3)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Methods > OccurrencePatterns.AddRectangularPattern Method


OccurrencePatterns.Item Method

OccurrencePatterns.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified OccurrencePattern object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] OccurrencePattern*)
Parameters
Parameters | Description
index | Input Variant value that specifies the OccurrencePattern to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the pattern name. This is the name that is displayed to the user in the assembly browser. If an out of range index or a name of a non-existent pattern name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Methods > OccurrencePatterns.Item Method


OccurrencePatterns Properties

OccurrencePatterns Properties
Summary

The properties of the OccurrencePatterns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Parent | Property that returns the parent of the object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Properties


OccurrencePatterns.Application Property

OccurrencePatterns.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Properties > OccurrencePatterns.Application Property


OccurrencePatterns.Count Property

OccurrencePatterns.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Properties > OccurrencePatterns.Count Property


OccurrencePatterns.Parent Property

OccurrencePatterns.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent of the object.

Visual Basic
Property Parent() As AssemblyComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Properties > OccurrencePatterns.Parent Property


OccurrencePatterns.Type Property

OccurrencePatterns.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OccurrencePatterns Interface > OccurrencePatterns Properties > OccurrencePatterns.Type Property


OffsetConstraint Interface

OffsetConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The OffsetConstraint object represents a constraint that defines an offset of two entities from two other entities.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::OffsetConstraint
        Inventor::OffsetConstraintProxy
Visual Basic
Public Interface OffsetConstraint
Inherits GeometricConstraint
Remarks

The constraint provides access to the four entities. These represent two end-point connected objects and two other end-point connected objects that represent the offset of the two initial entities. This constraint is created interactively by using the Offset command. EntityOne & EntityThree are always the originals and EntityTwo & EntityFour are always the offsets.

Notes

Members through which this object may be accessed include:

OffsetConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraint Interface


OffsetConstraint Properties

OffsetConstraint Properties
Summary

The properties of the OffsetConstraint class are listed here.

Properties
Name | Description
EntityFour | Property that returns one of the entities.
EntityOne | Property that returns one of the entities.
EntityThree | Property that returns one of the entities.
EntityTwo | Property that returns one of the entities.
You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraint Interface > OffsetConstraint Properties


OffsetConstraint.EntityFour Property

OffsetConstraint.EntityFour Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns one of the entities.

Visual Basic
Property EntityFour() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraint Interface > OffsetConstraint Properties > OffsetConstraint.EntityFour Property


OffsetConstraint.EntityOne Property

OffsetConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns one of the entities.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraint Interface > OffsetConstraint Properties > OffsetConstraint.EntityOne Property


OffsetConstraint.EntityThree Property

OffsetConstraint.EntityThree Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns one of the entities.

Visual Basic
Property EntityThree() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraint Interface > OffsetConstraint Properties > OffsetConstraint.EntityThree Property


OffsetConstraint.EntityTwo Property

OffsetConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns one of the entities.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraint Interface > OffsetConstraint Properties > OffsetConstraint.EntityTwo Property


OffsetConstraintProxy Interface

OffsetConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OffsetConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::OffsetConstraint
        Inventor::OffsetConstraintProxy
Visual Basic
Public Interface OffsetConstraintProxy
Inherits OffsetConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraintProxy Interface


OffsetConstraintProxy Properties

OffsetConstraintProxy Properties
Summary

The properties of the OffsetConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraintProxy Interface > OffsetConstraintProxy Properties


OffsetConstraintProxy.ContainingOccurrence Property

OffsetConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraintProxy Interface > OffsetConstraintProxy Properties > OffsetConstraintProxy.ContainingOccurrence Property


OffsetConstraintProxy.NativeObject Property

OffsetConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As OffsetConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OffsetConstraintProxy Interface > OffsetConstraintProxy Properties > OffsetConstraintProxy.NativeObject Property


OffsetDimConstraint Interface

OffsetDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The OffsetDimConstraint object represents a constraint that controls the distance between two parallel lines or a line and a point.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::OffsetDimConstraint
        Inventor::OffsetDimConstraintProxy
Visual Basic
Public Interface OffsetDimConstraint
Inherits DimensionConstraint
Remarks

The picture below illustrates two cases of the offset dimension constraint. In the case where dimension value is 0.614, the two red vertical lines are being constrained. In the second case, the line representing the centerline and the horizontal red line are being constrained. Also, in the second case, it is a linear diameter style of dimension.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddOffset

OffsetDimConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraint Interface


OffsetDimConstraint Properties

OffsetDimConstraint Properties
Summary

The properties of the OffsetDimConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns the circle or arc being constrained.
Line | Property that returns the proxy SketchLine being constrained.
LinearDiameter | Property that returns whether the dimension is a linear diameter style of dimension.
You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraint Interface > OffsetDimConstraint Properties


OffsetDimConstraint.Entity Property

OffsetDimConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the circle or arc being constrained.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraint Interface > OffsetDimConstraint Properties > OffsetDimConstraint.Entity Property


OffsetDimConstraint.Line Property

OffsetDimConstraint.Line Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the proxy SketchLine being constrained.

Visual Basic
Property Line() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraint Interface > OffsetDimConstraint Properties > OffsetDimConstraint.Line Property


OffsetDimConstraint.LinearDiameter Property

OffsetDimConstraint.LinearDiameter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns whether the dimension is a linear diameter style of dimension.

Visual Basic
Property LinearDiameter() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraint Interface > OffsetDimConstraint Properties > OffsetDimConstraint.LinearDiameter Property


OffsetDimConstraintProxy Interface

OffsetDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OffsetDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::OffsetDimConstraint
        Inventor::OffsetDimConstraintProxy
Visual Basic
Public Interface OffsetDimConstraintProxy
Inherits OffsetDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraintProxy Interface


OffsetDimConstraintProxy Properties

OffsetDimConstraintProxy Properties
Summary

The properties of the OffsetDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraintProxy Interface > OffsetDimConstraintProxy Properties


OffsetDimConstraintProxy.ContainingOccurrence Property

OffsetDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraintProxy Interface > OffsetDimConstraintProxy Properties > OffsetDimConstraintProxy.ContainingOccurrence Property


OffsetDimConstraintProxy.NativeObject Property

OffsetDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As OffsetDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OffsetDimConstraintProxy Interface > OffsetDimConstraintProxy Properties > OffsetDimConstraintProxy.NativeObject Property


OffsetSplineDimConstraint Interface

OffsetSplineDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OffsetSplineDimConstraint is automatically created when offset spline dimensions are created. The OffsetDimConstraint object represents a constraint that controls the distance between two parallel lines or a line and a point. This constraint cannot be explicitly deleted.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::OffsetSplineDimConstraint
        Inventor::OffsetSplineDimConstraintProxy
Visual Basic
Public Interface OffsetSplineDimConstraint
Inherits DimensionConstraint
Notes

Members through which this object may be accessed include:

DimensionConstraints.AddOffsetSpline

OffsetSplineDimConstraintProxy.NativeObject

For more information on this object, please refer to OffsetDimConstraint, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraint Interface


OffsetSplineDimConstraint Properties

OffsetSplineDimConstraint Properties
Summary

The properties of the OffsetSplineDimConstraint class are listed here.

Properties
Name | Description
OffsetSpline | Gets the SketchOffsetSpline being constrained to.
Spline | Gets the SketchSpline being constrained.
You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraint Interface > OffsetSplineDimConstraint Properties


OffsetSplineDimConstraint.OffsetSpline Property

OffsetSplineDimConstraint.OffsetSpline Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the SketchOffsetSpline being constrained to.

Visual Basic
Property OffsetSpline() As SketchOffsetSpline**
You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraint Interface > OffsetSplineDimConstraint Properties > OffsetSplineDimConstraint.OffsetSpline Property


OffsetSplineDimConstraint.Spline Property

OffsetSplineDimConstraint.Spline Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the SketchSpline being constrained.

Visual Basic
Property Spline() As SketchSpline**
You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraint Interface > OffsetSplineDimConstraint Properties > OffsetSplineDimConstraint.Spline Property


OffsetSplineDimConstraintProxy Interface

OffsetSplineDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the OffsetSplineDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::OffsetSplineDimConstraint
        Inventor::OffsetSplineDimConstraintProxy
Visual Basic
Public Interface OffsetSplineDimConstraintProxy
Inherits OffsetSplineDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraintProxy Interface


OffsetSplineDimConstraintProxy Properties

OffsetSplineDimConstraintProxy Properties
Summary

The properties of the OffsetSplineDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraintProxy Interface > OffsetSplineDimConstraintProxy Properties


OffsetSplineDimConstraintProxy.ContainingOccurrence Property

OffsetSplineDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraintProxy Interface > OffsetSplineDimConstraintProxy Properties > OffsetSplineDimConstraintProxy.ContainingOccurrence Property


OffsetSplineDimConstraintProxy.NativeObject Property

OffsetSplineDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As OffsetSplineDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > OffsetSplineDimConstraintProxy Interface > OffsetSplineDimConstraintProxy Properties > OffsetSplineDimConstraintProxy.NativeObject Property


OffsetWidthExtent Interface

OffsetWidthExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The OffsetWidthExtent is used by sheet metal features when the width of the feature is defined with respect to two entities.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::OffsetWidthExtent
Visual Basic
Public Interface OffsetWidthExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface


OffsetWidthExtent Properties

OffsetWidthExtent Properties
Summary

The properties of the OffsetWidthExtent class are listed here.

Properties
Name | Description
Edge | Property that gets the Edge object that the width is defined relative to.
OffsetDistanceOne | Property that returns the parameter controlling the distance of the feature from this offset entity.
OffsetDistanceTwo | Property that returns the parameter controlling the distance of the feature from this offset entity.
OffsetEntityOne | Property that gets and set the entity the width is measured relative to.
OffsetEntityTwo | Property that gets and set the entity the width is measured relative to.
You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface > OffsetWidthExtent Properties


OffsetWidthExtent.Edge Property

OffsetWidthExtent.Edge Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the Edge object that the width is defined relative to.

Visual Basic
Property Edge() As Edge**
Remarks

This is the same edge that was selected to create the feature. When querying an existing feature this edge is not available because it was consumed when the sheet metal feature was created. This property returns Nothing in the case where the edge no longer exists in the model. Because of this, the end-of-part marker must be placed above the feature to allow access this edge.

You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface > OffsetWidthExtent Properties > OffsetWidthExtent.Edge Property


OffsetWidthExtent.OffsetDistanceOne Property

OffsetWidthExtent.OffsetDistanceOne Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the distance of the feature from this offset entity.

Visual Basic
Property OffsetDistanceOne() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface > OffsetWidthExtent Properties > OffsetWidthExtent.OffsetDistanceOne Property


OffsetWidthExtent.OffsetDistanceTwo Property

OffsetWidthExtent.OffsetDistanceTwo Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the distance of the feature from this offset entity.

Visual Basic
Property OffsetDistanceTwo() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface > OffsetWidthExtent Properties > OffsetWidthExtent.OffsetDistanceTwo Property


OffsetWidthExtent.OffsetEntityOne Property

OffsetWidthExtent.OffsetEntityOne Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the entity the width is measured relative to.

Visual Basic
Property OffsetEntityOne() As IDispatch**
Remarks

This can be a WorkPoint or a Vertex object or a Face or WorkPlane object that intersects the selected edge.

You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface > OffsetWidthExtent Properties > OffsetWidthExtent.OffsetEntityOne Property


OffsetWidthExtent.OffsetEntityTwo Property

OffsetWidthExtent.OffsetEntityTwo Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the entity the width is measured relative to.

Visual Basic
Property OffsetEntityTwo() As IDispatch**
Remarks

This can be a WorkPoint or a Vertex object or a Face or WorkPlane object that intersects the selected edge.

You are here: Symbol Reference > Inventor Library > Objects > OffsetWidthExtent Interface > OffsetWidthExtent Properties > OffsetWidthExtent.OffsetEntityTwo Property


OrdinateDimension Interface

OrdinateDimension Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The OrdinateDimension object represents an ordinate dimension placed on a sheet. The properties and methods listed below are in addition to those supported by the DrawingDimension object.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::OrdinateDimension
Visual Basic
Public Interface OrdinateDimension
Inherits DrawingDimension
Notes

Members through which this object may be accessed include:

OrdinateDimensions.Add

OrdinateDimensions.Item

OrdinateDimensionsEnumerator.Item

OrdinateDimensionSet.OriginMember

OrdinateDimensionSet.AddMember

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface


OrdinateDimension Properties

OrdinateDimension Properties
Summary

The properties of the OrdinateDimension class are listed here.

Properties
Name | Description
DimensionType | Property that returns the dimension type.
Intent | Property that gets and sets the geometry associated with the dimension.
IsOrdinateSetMember | Property that returns whether this dimension is a member of an ordinate dimension set. If this property returns True, the OrdinateDimensionSet object is returned by the OrdinateDimensionSet property.
JogPointOne | Property that gets and sets the first jog point for the ordinate dimension.
JogPointTwo | Property that gets and sets the first jog point for the ordinate dimension.
OrdinateDimensionSet | Property that returns the OrdinateDimensionSet that owns this dimension. This property returns nothing if this dimension is not an ordinate dimension set member. This can be checked using the IsOrdinateSetMember property.
Style | Property that gets and sets the dimension style used for this dimension. Setting a new style resets all the style-overriding properties on this object.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties


OrdinateDimension.DimensionType Property

OrdinateDimension.DimensionType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the dimension type.

Visual Basic
Property DimensionType() As DimensionTypeEnum*
Remarks

Possible values are kHorizontalDimensionType, kVerticalDimensionType and kAlignedDimensionType. The value kAlignedDimensionType is applicable only if the geometry of the intent represents a line in which case the ordinate dimension is aligned along the direction of that line.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.DimensionType Property


OrdinateDimension.Intent Property

OrdinateDimension.Intent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the geometry associated with the dimension.

Visual Basic
Property Intent() As GeometryIntent *
Remarks

The GeometryIntent object can be created using the Sheet.CreateGeometryIntent method.

Valid intent values are points that specify geometry to which an ordinate dimension can be attached. If an invalid intent is specified, this method will fail.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.Intent Property


OrdinateDimension.IsOrdinateSetMember Property

OrdinateDimension.IsOrdinateSetMember Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether this dimension is a member of an ordinate dimension set. If this property returns True, the OrdinateDimensionSet object is returned by the OrdinateDimensionSet property.

Visual Basic
Property IsOrdinateSetMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.IsOrdinateSetMember Property


OrdinateDimension.JogPointOne Property

OrdinateDimension.JogPointOne Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the first jog point for the ordinate dimension.

Visual Basic
Property JogPointOne() As Point2d *
Remarks

This point corresponds to the jog point that is directly connected to the intent point of the ordinate dimension.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.JogPointOne Property


OrdinateDimension.JogPointTwo Property

OrdinateDimension.JogPointTwo Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the first jog point for the ordinate dimension.

Visual Basic
Property JogPointTwo() As Point2d *
Remarks

This point corresponds to the jog point that is directly connected to the text origin point of the ordinate dimension.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.JogPointTwo Property


OrdinateDimension.OrdinateDimensionSet Property

OrdinateDimension.OrdinateDimensionSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the OrdinateDimensionSet that owns this dimension. This property returns nothing if this dimension is not an ordinate dimension set member. This can be checked using the IsOrdinateSetMember property.

Visual Basic
Property OrdinateDimensionSet() As OrdinateDimensionSet**
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.OrdinateDimensionSet Property


OrdinateDimension.Style Property

OrdinateDimension.Style Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the dimension style used for this dimension. Setting a new style resets all the style-overriding properties on this object.

Visual Basic
Property Style() As DimensionStyle *
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimension Interface > OrdinateDimension Properties > OrdinateDimension.Style Property


OrdinateDimensions Interface

OrdinateDimensions Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The OrdinateDimensions collection object provides access to all of the ordinate dimensions on the sheet.

Class Hierarchy
Inventor::OrdinateDimensions
Visual Basic
Public Interface OrdinateDimensions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDimensions.OrdinateDimensions

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface


OrdinateDimensions Methods

OrdinateDimensions Methods
Summary

The methods of the OrdinateDimensions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates an ordinate dimension.
Item | Method that returns the specified dimension object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Methods


OrdinateDimensions.Add Method

OrdinateDimensions.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates an ordinate dimension.

Visual Basic
Sub Add(Intent As GeometryIntent, TextOrigin As Point2d, DimensionType As DimensionTypeEnum, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] OrdinateDimension*)
Parameters
Parameters
Description
Intent
Input GeometryIntent object that specifies the geometry to dimension. The GeometryIntent object can be created using the Sheet.CreateGeometryIntent method. Valid intent values are points that specify geometry to which an ordinate dimension can be attached. For example, the start, mid, end point of lines and start, end, center point of curves are valid intent values. If an invalid intent is specified, this method will fail.
TextOrigin
Input Point2d object that specifies the position of the dimension text on the sheet. The specified position of the dimension text together with the dimension alignment type (specified by the DimensionType argument) will determine the actual resulting position for the dimension text. If the specified dimension text position lies along the dimension line implied by the DimensionType argument, the dimension text will be placed exactly at the specified position. On the other hand, if the specified dimension text position does not lie along the dimension line implied by the DimensionType argument, the specified point will be projected onto the dimension line and the dimension text will be placed at this projected point. The following figures show how the specified position will be interpreted. In the first figure, the dimension type is specified to be a horizontal ordinate dimension and the specified point (P) lies on the horizontal line (L), therefore the dimension text will be placed exactly at the specified point (P).

In the second figure (shown below), the dimension type is specified to be a horizontal ordinate dimension and the specified point (P) does not lie on the horizontal line (L), therefore the point P will be first projected onto the dimension line and this projected point (P') will be used as the placement point for the dimension text.

DimensionType
Input DimensionTypeEnum that specifies the ordinate dimension type. Valid values kHorizontalDimensionType, kVerticalDimensionType and kAlignedDimensionType. The value kAlignedDimensionType can be specified only if the geometry of the specified input intent represents a line in which case an ordinate dimension that is aligned along the direction of the line will be created. An error will occur if an invalid dimension type is specified. For instance, kArcLengthDimensionType, kDiametricDimensionType and kSymmetricDimensionType are invalid for all types of intent and kAlignedDimensionType is invalid if the geometry of the specified input intent does not represent a line. The following figures show the aligned, horizontal and vertical ordinate dimensions for the same input intent (the geometry of the intent represents a line whose direction is used to place the aligned ordinate dimension).
Aligned Ordinate Dimension

Horizontal Ordinate Dimension

Vertical Ordinate Dimension

DimensionStyle
Optional input DimensionStyle object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer
Optional input Layer object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
Remarks

The ordinate dimension will be placed with respect to an origin point defined on the view. If an origin point has not been already defined on the view, this method will fail. The DrawingView.HasOriginIndicator property can be used to verify if the origin has already been created. If it has not been created, the DrawingView.CreateOriginIndicator method can be used to create it. The difference in behavior when placing ordinate dimensions using the API (when compared to placing them interactively using the user interface) is that ordinate dimensions have to be placed only one at a time using the API. To illustrate this difference, consider the drawing view shown in the figure below which shows ordinate dimensions placed on a curve.

Ordinate dimensions placed on a curve

The figure shows three ordinate dimensions placed on the start point, center point and end point of the curve. When using the user interface, all three dimensions can be placed at the same time by starting the ordinate dimension command and just selecting the curve entity (assuming that the origin for the ordinate dimensions has already been selected, otherwise this has to be selected first). After the dimensions have been placed, each one of them can be edited or deleted individually. Therefore, these dimensions are independent without any relationship or grouping between them. Similarly, if the line is selected for placing ordinate dimensions, two ordinate dimensions will be placed at the start point and end point of the line respectively. The user interface merely allows the convenience of placing multiple dimensions simultaneously, although they are independent. When placing these ordinate dimensions using the API, they can only be placed one at a time. If the three dimensions shown in the figure need to be placed using the API, this method needs to be called three times and the start point, center point and end point of the curve has to be specified as input geometry intent. Therefore, the only acceptable input geometry intent for placing an ordinate dimension is a point to which the ordinate dimension can be attached.

Example

"Create ordinate dimension"

This sample demonstrates the creation of ordinate dimensions in a drawing document. Before running this sample, select a linear drawing curve on the active drawing document.

Public Sub CreateOrdinateDimensions()

  ' Set a reference to the drawing document.
  ' This assumes a drawing document is active.
  Dim oDrawDoc As DrawingDocument
  Set oDrawDoc = ThisApplication.ActiveDocument

  ' Set a reference to the active sheet.
  Dim oActiveSheet As Sheet
  Set oActiveSheet = oDrawDoc.ActiveSheet

  ' Set a reference to the drawing curve segment.
  ' This assumes that a linear drawing curve is selected.
  Dim oDrawingCurveSegment As DrawingCurveSegment
  Set oDrawingCurveSegment = oDrawDoc.SelectSet.Item(1)

  ' Set a reference to the drawing curve.
  Dim oDrawingCurve As DrawingCurve
  Set oDrawingCurve = oDrawingCurveSegment.Parent

  If Not oDrawingCurve.CurveType = kLineSegmentCurve Then
    MsgBox "A linear curve should be selected for this sample."
    Exit Sub
  End If

  ' Create point intents to anchor the dimension to.
  Dim oDimIntent1 As GeometryIntent
  Set oDimIntent1 = oActiveSheet.CreateGeometryIntent(oDrawingCurve, kStartPointIntent)

  Dim oDimIntent2 As GeometryIntent
  Set oDimIntent2 = oActiveSheet.CreateGeometryIntent(oDrawingCurve, kEndPointIntent)

  ' Set a reference to the view to which the curve belongs.
  Dim oDrawingView As DrawingView
  Set oDrawingView = oDrawingCurve.Parent

  ' If origin indicator has not been already created, create it first.
  If Not oDrawingView.HasOriginIndicator Then
    ' The indicator will be located at the start point of the selected curve.
    oDrawingView.CreateOriginIndicator oDimIntent1
  End If

  ' Set a reference to the ordinate dimensions collection.
  Dim oOrdinateDimensions As OrdinateDimensions
  Set oOrdinateDimensions = oActiveSheet.DrawingDimensions.OrdinateDimensions

  ' Create the x-axis vector
  Dim oXAxis As Vector2d
  Set oXAxis = ThisApplication.TransientGeometry.CreateVector2d(1, 0)

  Dim oCurveVector As Vector2d
  Set oCurveVector = oDrawingCurve.StartPoint.VectorTo(oDrawingCurve.EndPoint)

  Dim oTextOrigin1 As Point2d
  Dim oTextOrigin2 As Point2d
  Dim DimType As DimensionTypeEnum

  If oCurveVector.IsParallelTo(oXAxis) Then
    ' Selected curve is horizontal
    DimType = kVerticalDimensionType

    ' Set the text points for the 2 dimensions.
    Set oTextOrigin1 = ThisApplication.TransientGeometry.CreatePoint2d(oDrawingCurve.StartPoint.X, oDrawingView.Top + 5)
    Set oTextOrigin2 = ThisApplication.TransientGeometry.CreatePoint2d(oDrawingCurve.EndPoint.X, oDrawingView.Top + 5)

  Else
    ' Selected curve is vertical or at an angle.
    DimType = kHorizontalDimensionType

    ' Set the text points for the 2 dimensions.
    Set oTextOrigin1 = ThisApplication.TransientGeometry.CreatePoint2d(oDrawingView.Left - 5, oDrawingCurve.StartPoint.Y)
    Set oTextOrigin2 = ThisApplication.TransientGeometry.CreatePoint2d(oDrawingView.Left - 5, oDrawingCurve.EndPoint.Y)

  End If

  ' Create the first ordinate dimension.
  Dim oOrdinateDimension1 As OrdinateDimension
  Set oOrdinateDimension1 = oOrdinateDimensions.Add(oDimIntent1, oTextOrigin1, DimType)

  ' Create the second ordinate dimension.
  Dim oOrdinateDimension2 As OrdinateDimension
  Set oOrdinateDimension2 = oOrdinateDimensions.Add(oDimIntent2, oTextOrigin2, DimType)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Methods > OrdinateDimensions.Add Method


OrdinateDimensions.Item Method

OrdinateDimensions.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified dimension object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] OrdinateDimension*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Methods > OrdinateDimensions.Item Method


OrdinateDimensions Properties

OrdinateDimensions Properties
Summary

The properties of the OrdinateDimensions class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kOrdinateDimensionsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Properties


OrdinateDimensions.Application Property

OrdinateDimensions.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

Where the property is weakly-typed, it can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServer' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Properties > OrdinateDimensions.Application Property


OrdinateDimensions.Count Property

OrdinateDimensions.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Properties > OrdinateDimensions.Count Property


OrdinateDimensions.Type Property

OrdinateDimensions.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kOrdinateDimensionsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensions Interface > OrdinateDimensions Properties > OrdinateDimensions.Type Property


OrdinateDimensionsEnumerator Interface

OrdinateDimensionsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Allows iteration of available OrdinateDimension objects.

Class Hierarchy
Inventor::OrdinateDimensionsEnumerator
Visual Basic
Public Interface OrdinateDimensionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

OrdinateDimensionSet.Members

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionsEnumerator Interface


OrdinateDimensionsEnumerator Methods

OrdinateDimensionsEnumerator Methods
Summary

The methods of the OrdinateDimensionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionsEnumerator Interface > OrdinateDimensionsEnumerator Methods


OrdinateDimensionsEnumerator.Item Method

OrdinateDimensionsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] OrdinateDimension*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionsEnumerator Interface > OrdinateDimensionsEnumerator Methods > OrdinateDimensionsEnumerator.Item Method


OrdinateDimensionsEnumerator Properties

OrdinateDimensionsEnumerator Properties
Summary

The properties of the OrdinateDimensionsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionsEnumerator Interface > OrdinateDimensionsEnumerator Properties


OrdinateDimensionsEnumerator.Count Property

OrdinateDimensionsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionsEnumerator Interface > OrdinateDimensionsEnumerator Properties > OrdinateDimensionsEnumerator.Count Property


OrdinateDimensionsEnumerator.Type Property

OrdinateDimensionsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionsEnumerator Interface > OrdinateDimensionsEnumerator Properties > OrdinateDimensionsEnumerator.Type Property


OrdinateDimensionSet Interface

OrdinateDimensionSet Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The OrdinateDimensionSet object represents an ordinate dimension set placed on a sheet.

Class Hierarchy
Inventor::OrdinateDimensionSet
Visual Basic
Public Interface OrdinateDimensionSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

OrdinateDimension.OrdinateDimensionSet

OrdinateDimensionSets.Add

OrdinateDimensionSets.Item

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface


OrdinateDimensionSet Methods

OrdinateDimensionSet Methods
Summary

The methods of the OrdinateDimensionSet class are listed here.

Methods
Methods
Name | Description
AddMember | Method that adds a member to the ordinate set and returns an OrdinateDimension object that represents the member.
Delete | Method that deletes the OrdinateDimensionSet.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Methods


OrdinateDimensionSet.AddMember Method

OrdinateDimensionSet.AddMember Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds a member to the ordinate set and returns an OrdinateDimension object that represents the member.

Visual Basic
Sub AddMember(GeometryIntent As GeometryIntent, Result As [out, retval] OrdinateDimension*)
Parameters
Parameters | Description
GeometryIntent | Input GeometryIntent object that specifies the member to add. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Methods > OrdinateDimensionSet.AddMember Method


OrdinateDimensionSet.Delete Method

OrdinateDimensionSet.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the OrdinateDimensionSet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Methods > OrdinateDimensionSet.Delete Method


OrdinateDimensionSet.GetReferenceKey Method

OrdinateDimensionSet.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Methods > OrdinateDimensionSet.GetReferenceKey Method


OrdinateDimensionSet Properties

OrdinateDimensionSet Properties
Summary

The properties of the OrdinateDimensionSet class are listed here.

Properties
Name | Description
AlignMembers | Property that gets and sets whether to align the text and the jog points of all the members. If set to True, changing the text or the jog point positions of a member results in relocation of all members.
AllowBrokenLeaders | Property that gets and sets whether to allow jog points (movable vertices) on the dimensions.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ContinuousRunning | Property that gets and sets whether to display continuity line between the set members.
DimensionType | Property that returns the dimension type of the ordinate set. Possible values are kAlignedDimensionType, kHorizontalDimensionType and kVerticalDimensionType.
DirectionReversed | Property that gets and sets whether to reverse the direction of positive numbers.
Layer | Property that gets and sets the layer for the dimension set.
Members | Property that returns all the member OrdinateDimension objects.
OriginArrowheadType | This is OriginArrowheadType, a member of class OrdinateDimensionSet.
OriginMember | Property that gets and sets the origin dimension for the ordinate dimension set. When setting the property, this must be a member of the set, else the property returns an error.
Parent | Property that returns the parent sheet of the object.
PositiveBothDirections | Property that gets and sets whether dimension values should be positive in both directions of the origin.
Precision | Property that gets and sets the number of decimal places displayed for all the members in this set. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.
ShowDirection | Property that gets and sets whether to place an arrow on the origin dimension pointing in the positive direction. If set to False, the arrow is not displayed.
Style | Property that gets and sets the dimension style used for this dimension set. Setting a new style resets all the style-overriding properties on the members.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties


OrdinateDimensionSet.AlignMembers Property

OrdinateDimensionSet.AlignMembers Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to align the text and the jog points of all the members. If set to True, changing the text or the jog point positions of a member results in relocation of all members.

Visual Basic
Property AlignMembers() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.AlignMembers Property


OrdinateDimensionSet.AllowBrokenLeaders Property

OrdinateDimensionSet.AllowBrokenLeaders Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to allow jog points (movable vertices) on the dimensions.

Visual Basic
Property AllowBrokenLeaders() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.AllowBrokenLeaders Property


OrdinateDimensionSet.Application Property

OrdinateDimensionSet.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Application Property


OrdinateDimensionSet.AttributeSets Property

OrdinateDimensionSet.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.AttributeSets Property


OrdinateDimensionSet.ContinuousRunning Property

OrdinateDimensionSet.ContinuousRunning Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display continuity line between the set members.

Visual Basic
Property ContinuousRunning() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.ContinuousRunning Property


OrdinateDimensionSet.DimensionType Property

OrdinateDimensionSet.DimensionType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the dimension type of the ordinate set. Possible values are kAlignedDimensionType, kHorizontalDimensionType and kVerticalDimensionType.

Visual Basic
Property DimensionType() As DimensionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.DimensionType Property


OrdinateDimensionSet.DirectionReversed Property

OrdinateDimensionSet.DirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to reverse the direction of positive numbers.

Visual Basic
Property DirectionReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.DirectionReversed Property


OrdinateDimensionSet.Layer Property

OrdinateDimensionSet.Layer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the layer for the dimension set.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Layer Property


OrdinateDimensionSet.Members Property

OrdinateDimensionSet.Members Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns all the member OrdinateDimension objects.

Visual Basic
Property Members() As OrdinateDimensionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Members Property


OrdinateDimensionSet.OriginArrowheadType Property

OrdinateDimensionSet.OriginArrowheadType Property
Summary

This is OriginArrowheadType, a member of class OrdinateDimensionSet.

Visual Basic
Property OriginArrowheadType() As ArrowheadTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.OriginArrowheadType Property


OrdinateDimensionSet.OriginMember Property

OrdinateDimensionSet.OriginMember Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the origin dimension for the ordinate dimension set. When setting the property, this must be a member of the set, else the property returns an error.

Visual Basic
Property OriginMember() As OrdinateDimension*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.OriginMember Property


OrdinateDimensionSet.Parent Property

OrdinateDimensionSet.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent sheet of the object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Parent Property


OrdinateDimensionSet.PositiveBothDirections Property

OrdinateDimensionSet.PositiveBothDirections Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether dimension values should be positive in both directions of the origin.

Visual Basic
Property PositiveBothDirections() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.PositiveBothDirections Property


OrdinateDimensionSet.Precision Property

OrdinateDimensionSet.Precision Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the number of decimal places displayed for all the members in this set. Values are truncated and rounded to the specified precision. Valid range of values is 0 to 8.

Visual Basic
Property Precision() As long
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Precision Property


OrdinateDimensionSet.ShowDirection Property

OrdinateDimensionSet.ShowDirection Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to place an arrow on the origin dimension pointing in the positive direction. If set to False, the arrow is not displayed.

Visual Basic
Property ShowDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.ShowDirection Property


OrdinateDimensionSet.Style Property

OrdinateDimensionSet.Style Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the dimension style used for this dimension set. Setting a new style resets all the style-overriding properties on the members.

Visual Basic
Property Style() As DimensionStyle*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Style Property


OrdinateDimensionSet.Type Property

OrdinateDimensionSet.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSet Interface > OrdinateDimensionSet Properties > OrdinateDimensionSet.Type Property


OutOfProcessInventorServer CoClass

OutOfProcessInventorServer CoClass
Summary

This is class Inventor::OutOfProcessInventorServer.

Class Hierarchy
Inventor::OutOfProcessInventorServer
Visual Basic
Public Class OutOfProcessInventorServer
You are here: Symbol Reference > Inventor Library > Objects > OutOfProcessInventorServer CoClass


OrdinateDimensionSets Interface

OrdinateDimensionSets Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The OrdinateDimensionSets collection object provides access to all of the ordinate dimension sets on the sheet.

Class Hierarchy
Inventor::OrdinateDimensionSets
Visual Basic
Public Interface OrdinateDimensionSets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDimensions.OrdinateDimensionSets

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface


OrdinateDimensionSets Methods

OrdinateDimensionSets Methods
Summary

The methods of the OrdinateDimensionSets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates an ordinate dimension set and returns the newly created OrdinateDimensionSet object.
Item | Method that returns the specified dimension set object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Methods


OrdinateDimensionSets.Add Method

OrdinateDimensionSets.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates an ordinate dimension set and returns the newly created OrdinateDimensionSet object.

Visual Basic
Sub Add(GeometryIntents As ObjectCollection, PlacementPoint As Point2d, DimensionType As DimensionTypeEnum, ByRef DimensionStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] OrdinateDimensionSet*)
Parameters
Parameters | Description
GeometryIntents | Input ObjectCollection containing GeometryIntent objects. The GeometryIntent objects specify the geometries to use for the dimension. The first geometry in the collection is assumed to be the origin. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method.
PlacementPoint | Input Point2d object that specifies the placement point of the dimension set on the sheet.
DimensionType | ' Input DimensionTypeEnum that specifies the dimension type. Valid values kHorizontalDimensionType, kVerticalDimensionType and kAlignedDimensionType. See Remarks.
DimensionStyle | Optional input DimensionStyle object that specifies the dimension style to use for the dimension. If not specified, the style defined by the active standard is used.
Layer | Optional input Layer object that specifies the layer to use for the dimension. If not specified, the layer defined by the active standard is used.
Remarks

The value kAlignedDimensionType of the DimensionType parameter can be specified only if the first geometry specified in the input GeometryIntents collection represents a line which is not parallel to the x or y axes of the sheet. If kAlignedDimensionType is specified, the placement point decides the orientation of the dimension set as demonstrated in the picture below.

You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Methods > OrdinateDimensionSets.Add Method


OrdinateDimensionSets.Item Method

OrdinateDimensionSets.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified dimension set object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] OrdinateDimensionSet*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Methods > OrdinateDimensionSets.Item Method


OrdinateDimensionSets Properties

OrdinateDimensionSets Properties
Summary

The properties of the OrdinateDimensionSets class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kOrdinateDimensionSetsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Properties


OrdinateDimensionSets.Application Property

OrdinateDimensionSets.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Properties > OrdinateDimensionSets.Application Property


OrdinateDimensionSets.Count Property

OrdinateDimensionSets.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Properties > OrdinateDimensionSets.Count Property


OrdinateDimensionSets.Type Property

OrdinateDimensionSets.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kOrdinateDimensionSetsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OrdinateDimensionSets Interface > OrdinateDimensionSets Properties > OrdinateDimensionSets.Type Property


OriginIndicator Interface

OriginIndicator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The OriginIndicator object represents an origin indicator for ordinate dimensions and hole tables placed on a drawing view.

Class Hierarchy
Inventor::OriginIndicator
Visual Basic
Public Interface OriginIndicator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingView.OriginIndicator

You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface


OriginIndicator Properties

OriginIndicator Properties
Summary

The properties of the OriginIndicator class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Attached | Property that specifies whether the origin indicator is attached to an origin point.
Intent | Property that gets and sets the origin point to which the origin indicator is attached.
Layer | Property that gets and sets the layer associated with the origin indicator.
LeaderStyle | Property that gets and sets the leader style associated with the origin indicator. The line format properties are the only properties of the leader style that are applicable to the origin indicator. The other properties of the leader style do not have any effect on the origin indicator.
RelativeX | Property that gets and sets the relative X coordinate of the origin indicator.
RelativeY | Property that gets and sets the relative Y coordinate of the origin indicator.
Type | Property returning kOriginIndicatorObject indicating this object's type.
Visible | Property that gets and sets whether the origin indicator should be hidden.
You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties


OriginIndicator.Application Property

OriginIndicator.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

Where the property is weakly-typed, it can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServer' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.Application Property


OriginIndicator.Attached Property

OriginIndicator.Attached Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies whether the origin indicator is attached to an origin point.

Visual Basic
Property Attached() As VARIANT_BOOL*
Remarks

If the origin indicator is no longer attached to an origin point which means that the origin indicator is sick, this property will return False and the Intent property will return Nothing. The Intent property can be used to set an origin point to which the origin indicator can be re-attached.

You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.Attached Property


OriginIndicator.Intent Property

OriginIndicator.Intent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the origin point to which the origin indicator is attached.

Visual Basic
Property Intent() As GeometryIntent*
Remarks

Valid intent values are points that specify geometry to which the origin indicator can be attached. When setting this property, if an invalid intent value is specified, setting this property will fail.

If the origin indicator is no longer attached to an origin point as indicated by the Attached property returning a value of False, this property will return Nothing. A new intent point can then be set to which the origin indicator can be re-attached.

You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.Intent Property


OriginIndicator.Layer Property

OriginIndicator.Layer Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the layer associated with the origin indicator.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.Layer Property


OriginIndicator.LeaderStyle Property

OriginIndicator.LeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the leader style associated with the origin indicator. The line format properties are the only properties of the leader style that are applicable to the origin indicator. The other properties of the leader style do not have any effect on the origin indicator.

Visual Basic
Property LeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.LeaderStyle Property


OriginIndicator.RelativeX Property

OriginIndicator.RelativeX Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the relative X coordinate of the origin indicator.

Visual Basic
Property RelativeX() As double
Remarks

This property represents a delta value from the origin point measured along the sheet x-axis. If the origin point is changed using the Intent property, the value of this property will be automatically reverted to 0.0.

When getting the value, this property will return a double value in centimeter units.

Also, when setting a value, the units of the specified value will be assumed to be centimeters. If a value in another units (e.g. inches) or a string expression needs to be used, the methods of the UnitsOfMeasure object can be used to convert that value to the corresponding value in centimeter units.

You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.RelativeX Property


OriginIndicator.RelativeY Property

OriginIndicator.RelativeY Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the relative Y coordinate of the origin indicator.

Visual Basic
Property RelativeY() As double
Remarks

This property represents a delta value from the origin point measured along the sheet y-axis. If the origin point is changed using the Intent property, the value of this property will be automatically reverted to 0.0.

When getting the value, this property will return a double value in centimeter units.

Also, when setting a value, the units of the specified value will be assumed to be centimeters. If a value in another units (e.g. inches) or a string expression needs to be used, the methods of the UnitsOfMeasure object can be used to convert that value to the corresponding value in centimeter units.

You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.RelativeY Property


OriginIndicator.Type Property

OriginIndicator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kOriginIndicatorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.Type Property


OriginIndicator.Visible Property

OriginIndicator.Visible Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the origin indicator should be hidden.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > OriginIndicator Interface > OriginIndicator Properties > OriginIndicator.Visible Property


PanelBar CoClass

PanelBar CoClass Available in Inventor Introduced in Inventor 9
Summary

The PanelBar object represents the panel window in an environment. See the article in the overviews section.

Class Hierarchy
Inventor::PanelBar
Visual Basic
Public Class PanelBar
Notes

Members through which this object may be accessed include:

Environment.PanelBar

You are here: Symbol Reference > Inventor Library > Objects > PanelBar CoClass


PanelBarEventsSink Interface

PanelBarEventsSink Interface
Summary

The PanelBar object represents the panel window in an environment.

Class Hierarchy
Inventor::PanelBarEventsSink
Visual Basic
Public Interface PanelBarEventsSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PanelBarEventsSink Interface


PanelBarEventsSink Methods

PanelBarEventsSink Methods
Summary

The methods of the PanelBarEventsSink class are listed here.

Methods
Methods
Name | Description
OnCommandBarSelection | Event that is fired when the current selection of the panel bar is changed.
You are here: Symbol Reference > Inventor Library > Objects > PanelBarEventsSink Interface > PanelBarEventsSink Methods


PanelBarEventsSink.OnCommandBarSelection Method

PanelBarEventsSink.OnCommandBarSelection Method
Summary

Event that is fired when the current selection of the panel bar is changed.

Visual Basic
Sub OnCommandBarSelection(CommandBarObject As CommandBar, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
CommandBarObject | Input CommandBar object. This CommandBar represents the contents of the command bar that will be displayed to the user.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the selection is changed.
Context | Input NameValueMap object that contains additional information about the event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > PanelBarEventsSink Interface > PanelBarEventsSink Methods > PanelBarEventsSink.OnCommandBarSelection Method


PanelBarObject Interface

PanelBarObject Interface
Summary

The PanelBar object represents the panel window in an environment.

Class Hierarchy
Inventor::PanelBarObject
Visual Basic
Public Interface PanelBarObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface


PanelBarObject Properties

PanelBarObject Properties
Summary

The properties of the PanelBarObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CommandBarList | Property that returns the CommandBarList that defines the command bars available in the panel bar.
CurrentCommandBar | Property that specifies which command bar is currently displayed within the panel bar.
DefaultCommandBar | Property that specifies which command bar should be displayed within the panel bar when the environment is initially activated.
Parent | Property that returns the parent of the PanelBar.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties


PanelBarObject.Application Property

PanelBarObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties > PanelBarObject.Application Property


PanelBarObject.CommandBarList Property

PanelBarObject.CommandBarList Property
Summary

Property that returns the CommandBarList that defines the command bars available in the panel bar.

Visual Basic
Property CommandBarList() As CommandBarList**
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties > PanelBarObject.CommandBarList Property


PanelBarObject.CurrentCommandBar Property

PanelBarObject.CurrentCommandBar Property
Summary

Property that specifies which command bar is currently displayed within the panel bar.

Visual Basic
Property CurrentCommandBar() As CommandBar*
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties > PanelBarObject.CurrentCommandBar Property


PanelBarObject.DefaultCommandBar Property

PanelBarObject.DefaultCommandBar Property
Summary

Property that specifies which command bar should be displayed within the panel bar when the environment is initially activated.

Visual Basic
Property DefaultCommandBar() As CommandBar*
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties > PanelBarObject.DefaultCommandBar Property


PanelBarObject.Parent Property

PanelBarObject.Parent Property
Summary

Property that returns the parent of the PanelBar.

Visual Basic
Property Parent() As Environment**
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties > PanelBarObject.Parent Property


PanelBarObject.Type Property

PanelBarObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PanelBarObject Interface > PanelBarObject Properties > PanelBarObject.Type Property


ParallelConstraint Interface

ParallelConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ParallelConstraint object represents a parallel constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::ParallelConstraint
        Inventor::ParallelConstraintProxy
Visual Basic
Public Interface ParallelConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddParallel

ParallelConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint Interface


ParallelConstraint Properties

ParallelConstraint Properties
Summary

The properties of the ParallelConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseOneMajorAxis property indicates if the parallel constraint is between the major or minor axis of the ellipse.
EntityTwo | Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseTwoMajorAxis property indicates if the parallel constraint is between the major or minor axis of the ellipse.
UseEllipseOneMajorAxis | Property used in the case where the entity returned by the EntityOne property is an ellipse. This property specifies if the major or minor axis of the ellipse is parallel to EntityTwo. True if it is the major axis.
UseEllipseTwoMajorAxis | Property used in the case where the entity returned by the EntityTwo property is an ellipse. This property specifies if the major or minor axis of the ellipse is parallel to EntityOne. True if it is the major axis.
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint Interface > ParallelConstraint Properties


ParallelConstraint.EntityOne Property

ParallelConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseOneMajorAxis property indicates if the parallel constraint is between the major or minor axis of the ellipse.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint Interface > ParallelConstraint Properties > ParallelConstraint.EntityOne Property


ParallelConstraint.EntityTwo Property

ParallelConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseTwoMajorAxis property indicates if the parallel constraint is between the major or minor axis of the ellipse.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint Interface > ParallelConstraint Properties > ParallelConstraint.EntityTwo Property


ParallelConstraint.UseEllipseOneMajorAxis Property

ParallelConstraint.UseEllipseOneMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the EntityOne property is an ellipse. This property specifies if the major or minor axis of the ellipse is parallel to EntityTwo. True if it is the major axis.

Visual Basic
Property UseEllipseOneMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint Interface > ParallelConstraint Properties > ParallelConstraint.UseEllipseOneMajorAxis Property


ParallelConstraint.UseEllipseTwoMajorAxis Property

ParallelConstraint.UseEllipseTwoMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the EntityTwo property is an ellipse. This property specifies if the major or minor axis of the ellipse is parallel to EntityOne. True if it is the major axis.

Visual Basic
Property UseEllipseTwoMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint Interface > ParallelConstraint Properties > ParallelConstraint.UseEllipseTwoMajorAxis Property


ParallelConstraint3D Interface

ParallelConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The ParallelConstraint3D object represents a parallel constraint within a 3D sketch.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::ParallelConstraint3D
        Inventor::ParallelConstraint3DProxy
Visual Basic
Public Interface ParallelConstraint3D
Inherits GeometricConstraint3D
Remarks

The constraint can be applied between:

  • A 3D sketch line and another 3D sketch line, a work axis, linear edge, or axis of a cylindrical face.
  • A 3D sketch line and a planar face or work plane.
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.AddParallel

ParallelConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3D Interface


ParallelConstraint3D Properties

ParallelConstraint3D Properties
Summary

The properties of the ParallelConstraint3D class are listed here.

Properties
Name | Description
EntityOne | Property that returns the first entity being constrained.
EntityTwo | Property that returns the second entity being constrained.
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3D Interface > ParallelConstraint3D Properties


ParallelConstraint3D.EntityOne Property

ParallelConstraint3D.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the first entity being constrained.

Visual Basic
Property EntityOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3D Interface > ParallelConstraint3D Properties > ParallelConstraint3D.EntityOne Property


ParallelConstraint3D.EntityTwo Property

ParallelConstraint3D.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the second entity being constrained.

Visual Basic
Property EntityTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3D Interface > ParallelConstraint3D Properties > ParallelConstraint3D.EntityTwo Property


ParallelConstraint3DProxy Interface

ParallelConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ParallelConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::ParallelConstraint3D
        Inventor::ParallelConstraint3DProxy
Visual Basic
Public Interface ParallelConstraint3DProxy
Inherits ParallelConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3DProxy Interface


ParallelConstraint3DProxy Properties

ParallelConstraint3DProxy Properties
Summary

The properties of the ParallelConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3DProxy Interface > ParallelConstraint3DProxy Properties


ParallelConstraint3DProxy.ContainingOccurrence Property

ParallelConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3DProxy Interface > ParallelConstraint3DProxy Properties > ParallelConstraint3DProxy.ContainingOccurrence Property


ParallelConstraint3DProxy.NativeObject Property

ParallelConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ParallelConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraint3DProxy Interface > ParallelConstraint3DProxy Properties > ParallelConstraint3DProxy.NativeObject Property


ParallelConstraintProxy Interface

ParallelConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ParallelConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::ParallelConstraint
        Inventor::ParallelConstraintProxy
Visual Basic
Public Interface ParallelConstraintProxy
Inherits ParallelConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraintProxy Interface


ParallelConstraintProxy Properties

ParallelConstraintProxy Properties
Summary

The properties of the ParallelConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraintProxy Interface > ParallelConstraintProxy Properties


ParallelConstraintProxy.ContainingOccurrence Property

ParallelConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraintProxy Interface > ParallelConstraintProxy Properties > ParallelConstraintProxy.ContainingOccurrence Property


ParallelConstraintProxy.NativeObject Property

ParallelConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ParallelConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ParallelConstraintProxy Interface > ParallelConstraintProxy Properties > ParallelConstraintProxy.NativeObject Property


Parameter Interface

Parameter Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

General parameter type that serves as the base class for all types of parameters. This object is returned when accessing parameters using the Item method of the Parameters collection object.

Class Hierarchy
Inventor::Parameter
    Inventor::DerivedParameter
    Inventor::ModelParameter
    Inventor::ReferenceParameter
    Inventor::TableParameter
    Inventor::UserParameter
Visual Basic
Public Interface Parameter
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AngleConstraint.Angle

AngleExtent.Angle

AngleiMateDefinition.Angle

BendConstraint.Radius

BendPartFeature.InputOne

BendPartFeature.InputTwo

CenteredWidthExtent.Width

CircularOccurrencePattern.AngleOffset

CircularOccurrencePattern.ElementCount

CircularPatternFeature.Angle

CircularPatternFeature.Count

CoilFeature.EndFlatAngle

CoilFeature.EndTransitionAngle

CoilFeature.StartFlatAngle

CoilFeature.StartTransitionAngle

ConstraintLimits.Maximum

ConstraintLimits.Minimum

CustomParameterGroup.Item

CustomPropertyFormat.Parent

CutAcrossBendsExtent.Distance

DerivedParameter.ReferencedEntity

DimensionConstraint.Parameter

DimensionConstraint3D.Parameter

DirectionAndDistanceMoveDefinition.Distance

DistanceAndAngleChamferDef.Angle

DistanceAndAngleChamferDef.Distance

DistanceChamferDef.Distance

DistanceExtent.Distance

DistanceHeightExtent.Distance

DoubleHemDefinition.Gap

DoubleHemDefinition.Length

EmbossFeature.Depth

EmbossFeature.Taper

ExpressionList.Parent

ExtrudeFeature.TaperAngle

ExtrudeFeature.TaperAngleTwo

FaceDraftFeature.DraftAngle

FeatureDimension.Parameter

FilletConstantRadiusEdgeSet.Radius

FilletConstantRadiusFaceSet.Radius

FilletIntermediateRadius.PercentLength

FilletIntermediateRadius.Radius

FilletVariableRadiusEdgeSet.EndRadius

FilletVariableRadiusEdgeSet.StartRadius

FlushConstraint.Offset

FlushiMateDefinition.Offset

HoleFeature.BottomTipAngle

HoleFeature.CBoreDepth

HoleFeature.CBoreDiameter

HoleFeature.CSinkAngle

HoleFeature.CSinkDiameter

HoleFeature.HoleDiameter

HoleFeature.SpotFaceDepth

HoleFeature.SpotFaceDiameter

HoleTapInfo.ThreadDepth

iFeatureParameterInput.Parameter

InsertConstraint.Distance

InsertiMateDefinition.Distance

LegacyDistanceHeightExtent.Distance

LinearHolePlacementDefinition.DistanceOne

LinearHolePlacementDefinition.DistanceTwo

LinePlaneAndAngleWorkPlaneDef.Angle

LoftedFlangeDefinition.FacetTolerance

LoftFeature.FirstSectionAngle

LoftFeature.FirstSectionImpact

LoftFeature.LastSectionAngle

LoftFeature.LastSectionImpact

LoftRail.Impact

MateConstraint.Offset

MateiMateDefinition.Offset

OffsetWidthExtent.OffsetDistanceOne

OffsetWidthExtent.OffsetDistanceTwo

Parameters.Item

ParametersEnumerator.Item

PathAndSectionTwistsSweepDef.TaperAngle

PathSweepDef.TaperAngle

PitchAndHeightCoilExtent.Height

PitchAndHeightCoilExtent.Pitch

PitchAndHeightCoilExtent.TaperAngle

PitchAndRevolutionCoilExtent.Pitch

PitchAndRevolutionCoilExtent.Revolution

PitchAndRevolutionCoilExtent.TaperAngle

PlaneAndOffsetWorkPlaneDef.Offset

PointToPointRipTypeDef.GapSize

PunchToolFeature.Angle

PunchToolFeature.Depth

RectangularOccurrencePattern.ColumnCount

RectangularOccurrencePattern.ColumnOffset

RectangularOccurrencePattern.RowCount

RectangularOccurrencePattern.RowOffset

RectangularPatternFeature.XCount

RectangularPatternFeature.XSpacing

RectangularPatternFeature.YCount

RectangularPatternFeature.YSpacing

RevolutionAndHeightCoilExtent.Height

RevolutionAndHeightCoilExtent.Revolution

RevolutionAndHeightCoilExtent.TaperAngle

RolledHemDefinition.Angle

RolledHemDefinition.Radius

RotateRotateConstraint.Ratio

RotateRotateiMateDefinition.Ratio

RotateTranslateConstraint.Ratio

RotateTranslateiMateDefinition.Ratio

SheetMetalComponentDefinition.BendRadius

SheetMetalComponentDefinition.BendReliefDepth

SheetMetalComponentDefinition.BendReliefWidth

SheetMetalComponentDefinition.CornerReliefSize

SheetMetalComponentDefinition.GapSize

SheetMetalComponentDefinition.JacobiRadiusSize

SheetMetalComponentDefinition.MinimumRemnant

SheetMetalComponentDefinition.Thickness

SheetMetalComponentDefinition.TransitionRadius

ShellDefinition.Thickness

ShellThicknessFaceSet.Thickness

SingleHemDefinition.Gap

SingleHemDefinition.Length

SinglePointRipTypeDef.GapSize

SketchSpline3D.EndTangentScale

SketchSpline3D.StartTangentScale

SpiralCoilExtent.Pitch

SpiralCoilExtent.Revolution

SweepFeature.TaperAngle

TangentConstraint.Offset

TangentiMateDefinition.Offset

TeardropHemDefinition.Angle

TeardropHemDefinition.Radius

ThickenFeature.Distance

ThreadFeature.ThreadDepth

ThreadFeature.ThreadOffset

ToHeightExtent.Offset

TranslateTranslateConstraint.Ratio

TwoDistancesChamferDef.DistanceOne

TwoDistancesChamferDef.DistanceTwo

UserCoordinateSystem.XAngle

UserCoordinateSystem.XOffset

UserCoordinateSystem.YAngle

UserCoordinateSystem.YOffset

UserCoordinateSystem.ZAngle

UserCoordinateSystem.ZOffset

WidthOffsetWidthExtent.OffsetDistance

WidthOffsetWidthExtent.Width

See Also

Sheet Metal Thickness Editing sample

Example

See Parameters for example "Parameters Object"

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface


Parameter Methods

Parameter Methods
Summary

The methods of the Parameter class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this Parameter.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Methods


Parameter.Delete Method

Parameter.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes this Parameter.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Methods > Parameter.Delete Method


Parameter.GetReferenceKey Method

Parameter.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Methods > Parameter.GetReferenceKey Method


Parameter Properties

Parameter Properties
Summary

The properties of the Parameter class are listed here.

Properties
Name | Description
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Comment | Property that allows you to get and set the comment string associated with the parameter. Depending on the type of parameter, this property may not be writable.
CustomPropertyFormat | Property that returns the CustomPropertyFormat object associated with this parameter. The CustomPropertyFormat provides control over how the parameter value is formatted when it is exposed as a custom iProperty.
Dependents | Property that returns the collection of objects that have a direct dependency on the parameter.
DisabledActionTypes | Property that indicates the disabling of certain user actions on this object.
DisplayFormat | Property that gets and sets the display format for the parameter. Valid values are kDecimalDisplayFormat, kFractionalDisplayFormat and kArchitecturalDisplayFormat.
DrivenBy | Method that returns the collection objects that the parameter is dependent on.
ExposedAsProperty | Property that allows you to get and set the Boolean indicating if this parameter is exposed as an iProperty of this document.
Expression | Property that allows you to get and set the equation associated with the parameter. Depending on the type of parameter, this property may not be writable.
ExpressionList | Property that returns the expression list associated with this parameter.
HealthStatus | Property that returns an enum indicating the current state of the object.
InUse | Property that returns whether whether this parameter is currently in use (by a dimension, feature or by any other parameter).
IsKey | Property that gets and sets whether this parameter is a key parameter or not. Key parameters are typically those that need to be easily accessed and are designated as key to be filtered out from the rest of the parameters.
ModelValue | Property that returns the evaluation of this parameter (in database units) that is currently used by the model. This takes into account the value computed from the expression and the tolerance. This method is only valid for numeric unit types and will fail for Text and Boolean unit types.
ModelValueType | Property that indicates a constant used to determine the method used to compute the model value. For Text and Boolean unit types of parameters this property will always return kNominalValue and attempts to set this property to another value will be ignored
Name | Property that allows you to get and set the name of the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur. Depending on the type of parameter, this property may not be writable.
ParameterType | Property that allows you to get the type of the parameter. The parameter type can be either kModelParameterType, kReferenceParameterType, kTableParameterType, or kUserParameterType.
Parent | Property that returns the parent Document of this parameter.
Precision | Property that indicates the number of decimal places displayed for this parameter. Note that the precision is used when applying a standard tolerance to the parameter. For Text and Boolean unit type parameters this property will always return 0 and setting the value will be ignored.
Tolerance | Property that returns the tolerance for this parameter. This property returns Nothing in the case where the unit type of this parameter is kTextUnits or kBooleanUnits.
Type | Property returning an enum indicating this object's type.
Units | Property that allows you to get and set the units of the parameter. The units will always be returned as a string. When setting the units you can use either a string defining a valid unit or an item from UnitsTypeEnum. Depending on the type of parameter, this property may not be writable. Most unit types will result in a value but a unit type can also define whether a property is a Text or Boolean type of parameter.
Value | Property that allows you to get and set the value of the parameter. This value is always represented in database units. When setting the value, the existing equation will be replaced. Depending on the type of parameter, this property may not be writable.
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties


Parameter.AttributeSets Property

Parameter.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.AttributeSets Property


Parameter.Comment Property

Parameter.Comment Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the comment string associated with the parameter. Depending on the type of parameter, this property may not be writable.

Visual Basic
Property Comment() As String
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Comment Property


Parameter.CustomPropertyFormat Property

Parameter.CustomPropertyFormat Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CustomPropertyFormat object associated with this parameter. The CustomPropertyFormat provides control over how the parameter value is formatted when it is exposed as a custom iProperty.

Visual Basic
Property CustomPropertyFormat() As CustomPropertyFormat**
Remarks

This property returns Nothing in case where this property is not exposed as an iProperty, ExposedAsProperty is False.

This property returns Nothing in the case where the unit type of this parameter is kTextUnits or kBooleanUnits.

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.CustomPropertyFormat Property


Parameter.Dependents Property

Parameter.Dependents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that have a direct dependency on the parameter.

Visual Basic
Property Dependents() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Dependents Property


Parameter.DisabledActionTypes Property

Parameter.DisabledActionTypes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the disabling of certain user actions on this object.

Visual Basic
Property DisabledActionTypes() As ActionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.DisabledActionTypes Property


Parameter.DisplayFormat Property

Parameter.DisplayFormat Property
Summary

Property that gets and sets the display format for the parameter. Valid values are kDecimalDisplayFormat, kFractionalDisplayFormat and kArchitecturalDisplayFormat.

Visual Basic
Property DisplayFormat() As ParameterDisplayFormatEnum
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.DisplayFormat Property


Parameter.DrivenBy Property

Parameter.DrivenBy Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that returns the collection objects that the parameter is dependent on.

Visual Basic
Property DrivenBy() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.DrivenBy Property


Parameter.ExposedAsProperty Property

Parameter.ExposedAsProperty Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that allows you to get and set the Boolean indicating if this parameter is exposed as an iProperty of this document.

Visual Basic
Property ExposedAsProperty() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.ExposedAsProperty Property


Parameter.Expression Property

Parameter.Expression Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the equation associated with the parameter. Depending on the type of parameter, this property may not be writable.

Visual Basic
Property Expression() As String
Remarks

When working with ReferenceParameter objects - in order to edit the value/expression of an API-created reference parameter (when ReferenceParameter.BuiltIn is False), you can temporarily convert it to a model parameter (using the ReferenceParameter.ConvertToModelParameter method), edit the value/expression and convert it back to a reference parameter (using the ModelParameter.ConvertToReferenceParameter method).

See Also

Sheet Metal Style Creation sample

Table Parameters sample

Mate constraint with limits sample

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Expression Property


Parameter.ExpressionList Property

Parameter.ExpressionList Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the expression list associated with this parameter.

Visual Basic
Property ExpressionList() As ExpressionList**
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.ExpressionList Property


Parameter.HealthStatus Property

Parameter.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.HealthStatus Property


Parameter.InUse Property

Parameter.InUse Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether whether this parameter is currently in use (by a dimension, feature or by any other parameter).

Visual Basic
Property InUse() As VARIANT_BOOL*
Remarks

If the property returns True, this parameter cannot be deleted.

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.InUse Property


Parameter.IsKey Property

Parameter.IsKey Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether this parameter is a key parameter or not. Key parameters are typically those that need to be easily accessed and are designated as key to be filtered out from the rest of the parameters.

Visual Basic
Property IsKey() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.IsKey Property


Parameter.ModelValue Property

Parameter.ModelValue Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the evaluation of this parameter (in database units) that is currently used by the model. This takes into account the value computed from the expression and the tolerance. This method is only valid for numeric unit types and will fail for Text and Boolean unit types.

Visual Basic
Property ModelValue() As double*
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.ModelValue Property


Parameter.ModelValueType Property

Parameter.ModelValueType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates a constant used to determine the method used to compute the model value. For Text and Boolean unit types of parameters this property will always return kNominalValue and attempts to set this property to another value will be ignored

Visual Basic
Property ModelValueType() As ModelValueTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.ModelValueType Property


Parameter.Name Property

Parameter.Name Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the name of the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur. Depending on the type of parameter, this property may not be writable.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Name Property


Parameter.ParameterType Property

Parameter.ParameterType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get the type of the parameter. The parameter type can be either kModelParameterType, kReferenceParameterType, kTableParameterType, or kUserParameterType.

Visual Basic
Property ParameterType() As ParameterTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.ParameterType Property


Parameter.Parent Property

Parameter.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent Document of this parameter.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Parent Property


Parameter.Precision Property

Parameter.Precision Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the number of decimal places displayed for this parameter. Note that the precision is used when applying a standard tolerance to the parameter. For Text and Boolean unit type parameters this property will always return 0 and setting the value will be ignored.

Visual Basic
Property Precision() As long
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Precision Property


Parameter.Tolerance Property

Parameter.Tolerance Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the tolerance for this parameter. This property returns Nothing in the case where the unit type of this parameter is kTextUnits or kBooleanUnits.

Visual Basic
Property Tolerance() As Tolerance**
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Tolerance Property


Parameter.Type Property

Parameter.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
See Also

Model Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Type Property


Parameter.Units Property

Parameter.Units Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the units of the parameter. The units will always be returned as a string. When setting the units you can use either a string defining a valid unit or an item from UnitsTypeEnum. Depending on the type of parameter, this property may not be writable. Most unit types will result in a value but a unit type can also define whether a property is a Text or Boolean type of parameter.

Visual Basic
Property Units() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Units Property


Parameter.Value Property

Parameter.Value Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the value of the parameter. This value is always represented in database units. When setting the value, the existing equation will be replaced. Depending on the type of parameter, this property may not be writable.

Visual Basic
Property Value() As VARIANT
Remarks

When working with ReferenceParameter objects - in order to edit the value/expression of an API-created reference parameter (when ReferenceParameter.BuiltIn is False), you can temporarily convert it to a model parameter (using the ReferenceParameter.ConvertToModelParameter method), edit the value/expression and convert it back to a reference parameter (using the ModelParameter.ConvertToReferenceParameter method).

See Also

Sheet Metal Thickness Editing sample

Model Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > Parameter Interface > Parameter Properties > Parameter.Value Property


Parameters Interface

Parameters Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the objects associated with the object the collection was obtained from. Using the properties supported by the collection you can access the all of the parameters as a set or by type.

Class Hierarchy
Inventor::Parameters
Visual Basic
Public Interface Parameters
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.Parameters

DrawingDocument.Parameters

FlatPattern.Parameters

PartComponentDefinition.Parameters

See Also

Table Parameters sample

Selectively link paramaters sample

Example

"Model Parameters Example"

This sample demonstrates the methods and properties supported by the Parameters object for model parameters.

To run the sample you must have an part document open that contains at least one parameter, one of which is named d0.

Public Sub ModelParameters()
    ' Obtain the active document, this assumes
    ' that a part document is active in Inventor.
    Dim oPartDoc As Inventor.PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Obtain the Parameters collection
    Dim oParams As Parameters
    Set oParams = oPartDoc.ComponentDefinition.Parameters

    ' Iterate through the Parameters collection to obtain
    ' information about the Parameters
    Dim iNumParams As Long
    Debug.Print "ALL PARAMETERS"
    For iNumParams = 1 To oParams.Count
        'Display the Name
        Debug.Print " Name: " & oParams.Item(iNumParams).Name

        'Display the Parameter Type
        Select Case oParams.Item(iNumParams).Type
            Case kModelParameterObject
                Debug.Print "  Type: " & "Model Parameter"
            Case kTableParameterObject
                Debug.Print "  Type: " & "Table Parameter"
            Case kUserParameterObject
                Debug.Print "  Type: " & "User Parameter"
        End Select

        'Display the Value
        Debug.Print "  Value: " & oParams.Item(iNumParams).Value

        'Display the Health Status
        Select Case oParams.Item(iNumParams).HealthStatus
            Case kDeletedHealth
                Debug.Print "  Health Status: " & "Deleted"
            Case kDriverLostHealth
                Debug.Print "  Health Status: " & "Driver Lost"
            Case kInErrorHealth
                Debug.Print "  Health Status: " & "In Error"
            Case kOutOfDateHealth
                Debug.Print "  Health Status: " & "Out of Date"
            Case kUnknownHealth
                Debug.Print "  Health Status: " & "Unknown"
            Case kUpToDateHealth
                Debug.Print "  Health Status: " & "Up to Date"
        End Select
    Next iNumParams

    ' Obtain the Model Parameters collection
    Dim oModelParams As ModelParameters
    Set oModelParams = oParams.ModelParameters

    ' Iterate through the Model Parameters collection
    Dim iNumModelParams As Long
    Debug.Print "MODEL PARAMETER VALUES"
    For iNumModelParams = 1 To oModelParams.Count
        ' Display the Name
        Debug.Print " Name:" & oModelParams.Item(iNumModelParams).Name

        ' Display the Value
        Debug.Print "  Value: " & oModelParams.Item(iNumModelParams).Value

        ' Display the units
        Debug.Print "  Units: " & oModelParams.Item(iNumModelParams).Units

        ' Change the Model Parameter values
        oModelParams.Item(iNumModelParams).Value = oModelParams.Item(iNumModelParams).Value * 2
    Next iNumModelParams

    ' Accessing a particular parameter if you know its name, the user and reference parameters can also be accessed in a similar way
    oModelParams.Item("d0").Name = "NewParam"

    ' Change the value of the newly named parameter "param1"
    oModelParams.Item("NewParam").Value = 25

    ' Update the model.
    oPartDoc.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface


Parameters Methods

Parameters Methods
Summary

The methods of the Parameters class are listed here.

Methods
Methods
Name | Description
_GetValueFromExpression | This is _GetValueFromExpression, a member of class Parameters.
AngularStandardTolerance | Property that indicates the standard tolerance for angular dimensions in this document.
GetValueFromExpression | Method that evaluates the input expression using the units specified and returns a value in database units.
IsExpressionValid | Returns whether the input expression is valid or not.
Item | Property that returns the specified Parameter object from the collection. This is the default property of the Parameters collection object.
LinearStandardTolerance | Property that indicates the standard tolerance for linear dimensions in this document.
LinearStandardTolerance | Property that indicates the standard tolerance for linear dimensions in this document.
SetAllToMax | Method that sets the values of all parameters to be the maximum value as defined by the parameter's tolerance.
SetAllToMedian | Sets the values of all parameters to be the median value as defined by the parameter's tolerance.
SetAllToMin | Method that sets the values of all parameters to be the minimum value as defined by the parameter's tolerance.
SetAllToNominal | Method that sets the values of all parameters to be the nominal value as defined by the parameter's tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods


Parameters._GetValueFromExpression Method

Parameters._GetValueFromExpression Method
Summary

This is _GetValueFromExpression, a member of class Parameters.

Visual Basic
Sub _GetValueFromExpression(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] double)
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters._GetValueFromExpression Method


Parameters.AngularStandardTolerance Method

Parameters.AngularStandardTolerance Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the standard tolerance for angular dimensions in this document.

Visual Basic
Sub AngularStandardTolerance(Precision As long, Value As String)
Parameters
Parameters | Description
Precision | Input Long that specifies the precision of the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.AngularStandardTolerance Method


Parameters.GetValueFromExpression Method

Parameters.GetValueFromExpression Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that evaluates the input expression using the units specified and returns a value in database units.

Visual Basic
Sub GetValueFromExpression(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] VARIANT)
Parameters
Parameters | Description
Expression | Input String value that contains the expression to evaluate. This string is evaluated the same ways a string entered in any of the Autodesk Inventor dialogs are evaluated. For example "3 in / 2 cm" is a valid string for input.
UnitsSpecifier | Input variant value that specifies the unit type the expression is to be evaluated with. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in." String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in."
Remarks

For example, the string "34 in / 2" with a length unit specifier, will return the value 43.1800. The UnitsSpecifier is used to determine the type of unit that is expected, (i.e.. area, volume, velocity, etc.) and is used for values that do not have an explicit type defined. For example the expression "4 * 5" with a units specifier of "mm mm" would be assumed to be "4 mm * 5 mm." An error occurs if the string cannot be evaluated. This method is currently not supported when the UnitsOfMeasure object was obtained using Apprentice. A common use of this method will be to evaluate an expression using the current display units of the document. For example if the expression should define a length you can use kDefaultDisplayLengthUnits as the unit specifier so the expression will be evaluated as a length in the current document units. The enum values that specify to use the document default display units are kDefaultDisplayLengthUnits, kDefaultDisplayAngleUnits, kDefaultDisplayMassUnits, kDefaultDisplayTimeUnits, and kDefaultDisplayTemperatureUnits.

The input expression is specified by a string. This string may or may not specify a unit type (for example, "1" versus "1 in"). In the case where the string expression does not specify a unit type, the additional unit-type argument is required to determine the unit type. Note: Up to and including Autodesk Inventor 10, if the string expression does specify a unit type, the UnitsSpecifier type specified will be ignored because the unit type is obtained from the string expression. However, subsequent releases of Autodesk Inventor will return an error condition if the two unit types do not match.

Notes

For information on this item, please refer to UnitsOfMeasure::GetValueFromExpression, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.GetValueFromExpression Method


Parameters.IsExpressionValid Method

Parameters.IsExpressionValid Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns whether the input expression is valid or not.

Visual Basic
Sub IsExpressionValid(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.IsExpressionValid Method


Parameters.Item Method

Parameters.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified Parameter object from the collection. This is the default property of the Parameters collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] Parameter*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the parameter name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
See Also

Model Parameters sample

Selectively link paramaters sample

You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.Item Method


Parameters.LinearStandardTolerance Method ([in] long, [in] BSTR)

Parameters.LinearStandardTolerance Method ([in] long, [in] BSTR) Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the standard tolerance for linear dimensions in this document.

Visual Basic
Sub LinearStandardTolerance(Precision As long, Value As String)
Parameters
Parameters | Description
Precision | Input Long that specifies the precision of the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.LinearStandardTolerance Method ([in] long, [in] BSTR)


Parameters.LinearStandardTolerance Method ([in] long, [out, retval] BSTR*)

Parameters.LinearStandardTolerance Method ([in] long, [out, retval] BSTR*) Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the standard tolerance for linear dimensions in this document.

Visual Basic
Sub LinearStandardTolerance(Precision As long, Result As [out, retval] BSTR)
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.LinearStandardTolerance Method ([in] long, [out, retval] BSTR*)


Parameters.SetAllToMax Method

Parameters.SetAllToMax Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the values of all parameters to be the maximum value as defined by the parameter's tolerance.

Visual Basic
Sub SetAllToMax()
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.SetAllToMax Method


Parameters.SetAllToMedian Method

Parameters.SetAllToMedian Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Sets the values of all parameters to be the median value as defined by the parameter's tolerance.

Visual Basic
Sub SetAllToMedian()
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.SetAllToMedian Method


Parameters.SetAllToMin Method

Parameters.SetAllToMin Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the values of all parameters to be the minimum value as defined by the parameter's tolerance.

Visual Basic
Sub SetAllToMin()
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.SetAllToMin Method


Parameters.SetAllToNominal Method

Parameters.SetAllToNominal Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the values of all parameters to be the nominal value as defined by the parameter's tolerance.

Visual Basic
Sub SetAllToNominal()
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Methods > Parameters.SetAllToNominal Method


Parameters Properties

Parameters Properties
Summary

The properties of the Parameters class are listed here.

Properties
Name | Description
AngularDimensionPrecision | Property that indicates the precision for angular dimensions in this document.
Count | Property that returns the number of items in this collection.
CustomParameterGroups | Property that returns the CustomParameterGroups collection object.
DerivedParameterTables | Property that returns the DerivedParameterTables collection object.
DimensionDisplayType | Property that gets and sets the dimension display type for dimensions in this document.
DisplayParameterAsExpression | Property that gets and sets whether parameters are displayed as values or expressions in edit boxes when a dimension or a feature is edited.
ExportStandardTolerances | Property that gets and sets whether to export dimensions to drawings using the standard tolerance values.
LinearDimensionPrecision | Property that indicates the precision for linear dimensions in this document.
ModelParameters | Property that returns the ModelParameters collection object.
ParameterTables | Property that returns the ParameterTables collection object.
ReferenceParameters | Property that returns the ReferenceParameters collection object.
Type | Property returning an enum indicating this object's type.
UserParameters | Property that returns the UserParameters collection object.
UseStandardTolerances | Property that gets and sets whether to use standard tolerances for dimensions in this document.
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties


Parameters.AngularDimensionPrecision Property

Parameters.AngularDimensionPrecision Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the precision for angular dimensions in this document.

Visual Basic
Property AngularDimensionPrecision() As long
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.AngularDimensionPrecision Property


Parameters.Count Property

Parameters.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.Count Property


Parameters.CustomParameterGroups Property

Parameters.CustomParameterGroups Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the CustomParameterGroups collection object.

Visual Basic
Property CustomParameterGroups() As CustomParameterGroups**
See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.CustomParameterGroups Property


Parameters.DerivedParameterTables Property

Parameters.DerivedParameterTables Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the DerivedParameterTables collection object.

Visual Basic
Property DerivedParameterTables() As DerivedParameterTables**
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.DerivedParameterTables Property


Parameters.DimensionDisplayType Property

Parameters.DimensionDisplayType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the dimension display type for dimensions in this document.

Visual Basic
Property DimensionDisplayType() As DimensionDisplayTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.DimensionDisplayType Property


Parameters.DisplayParameterAsExpression Property

Parameters.DisplayParameterAsExpression Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether parameters are displayed as values or expressions in edit boxes when a dimension or a feature is edited.

Visual Basic
Property DisplayParameterAsExpression() As VARIANT_BOOL
Example

Input expression: LENGTH = 1 mm + 2 mm

As Value: 1 mm + 2 mm

As Expression: LENGTH = 1 mm + 2 mm

You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.DisplayParameterAsExpression Property


Parameters.ExportStandardTolerances Property

Parameters.ExportStandardTolerances Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to export dimensions to drawings using the standard tolerance values.

Visual Basic
Property ExportStandardTolerances() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.ExportStandardTolerances Property


Parameters.LinearDimensionPrecision Property

Parameters.LinearDimensionPrecision Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that indicates the precision for linear dimensions in this document.

Visual Basic
Property LinearDimensionPrecision() As long
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.LinearDimensionPrecision Property


Parameters.ModelParameters Property

Parameters.ModelParameters Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ModelParameters collection object.

Visual Basic
Property ModelParameters() As ModelParameters**
See Also

Model Parameters sample

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.ModelParameters Property


Parameters.ParameterTables Property

Parameters.ParameterTables Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ParameterTables collection object.

Visual Basic
Property ParameterTables() As ParameterTables**
See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.ParameterTables Property


Parameters.ReferenceParameters Property

Parameters.ReferenceParameters Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ReferenceParameters collection object.

Visual Basic
Property ReferenceParameters() As ReferenceParameters**
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.ReferenceParameters Property


Parameters.Type Property

Parameters.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.Type Property


Parameters.UserParameters Property

Parameters.UserParameters Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the UserParameters collection object.

Visual Basic
Property UserParameters() As UserParameters**
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.UserParameters Property


Parameters.UseStandardTolerances Property

Parameters.UseStandardTolerances Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether to use standard tolerances for dimensions in this document.

Visual Basic
Property UseStandardTolerances() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Parameters Interface > Parameters Properties > Parameters.UseStandardTolerances Property


ParametersEnumerator Interface

ParametersEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ParametersEnumerator object allows enumeration through available parameters.

Class Hierarchy
Inventor::ParametersEnumerator
Visual Basic
Public Interface ParametersEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartComponent.Parameters

PartFeature.Parameters

UnitsOfMeasure.GetDrivingParameters

You are here: Symbol Reference > Inventor Library > Objects > ParametersEnumerator Interface


ParametersEnumerator Methods

ParametersEnumerator Methods
Summary

The methods of the ParametersEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified Parameter object from the collection. This is the default property of the ParametersEnumerator collection object.
You are here: Symbol Reference > Inventor Library > Objects > ParametersEnumerator Interface > ParametersEnumerator Methods


ParametersEnumerator.Item Method

ParametersEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns the specified Parameter object from the collection. This is the default property of the ParametersEnumerator collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Parameter*)
Parameters
Parameters | Description
index | Value that specifies the index of the Parameter to return.
You are here: Symbol Reference > Inventor Library > Objects > ParametersEnumerator Interface > ParametersEnumerator Methods > ParametersEnumerator.Item Method


ParametersEnumerator Properties

ParametersEnumerator Properties
Summary

The properties of the ParametersEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ParametersEnumerator Interface > ParametersEnumerator Properties


ParametersEnumerator.Count Property

ParametersEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ParametersEnumerator Interface > ParametersEnumerator Properties > ParametersEnumerator.Count Property


ParametersEnumerator.Type Property

ParametersEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ParametersEnumerator Interface > ParametersEnumerator Properties > ParametersEnumerator.Type Property


ParameterTable Interface

ParameterTable Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ParameterTable object represents the connection to a spreadsheet. From the ParameterTable object you can access the spreadsheet and the properties that define how the spreadsheet is read. In addition, the ParameterTable object provides access to the parameters that were created as a result of reading in the spreadsheet.

Class Hierarchy
Inventor::ParameterTable
Visual Basic
Public Interface ParameterTable
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ParameterTables.AddExcelTable

ParameterTables.Item

See Also

Table Parameters sample

Example

See ParameterTables for example "ParameterTables Object"

You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface


ParameterTable Methods

ParameterTable Methods
Summary

The methods of the ParameterTable class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the ParameterTable object.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Methods


ParameterTable.Delete Method

ParameterTable.Delete Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that deletes the ParameterTable object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Methods > ParameterTable.Delete Method


ParameterTable.GetReferenceKey Method

ParameterTable.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Methods > ParameterTable.GetReferenceKey Method


ParameterTable Properties

ParameterTable Properties
Summary

The properties of the ParameterTable class are listed here.

Properties
Name | Description
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
FileName | Property that specifies the spreadsheet path. If the spreadsheet is embedded this will return an empty string.
Linked | Property that specifies if the Excel document is linked or embedded to the Autodesk Inventor document.
Parent | Property that returns the parent object of this ParameterTable. This property will return different types of objects depending on the document type the ParameterTable is contained in. If the ParameterTable is in a part document then the parent is a PartComponentDefinition object. If the ParameterTable is in an assembly document then the parent is an AssemblyComponentDefinition. If the document is a drawing document then the parent is a DraftDocument.
ReferencedFileDescriptor | This is ReferencedFileDescriptor, a member of class ParameterTable.
StartCell | Property that returns the starting cell that's used when reading the spreadsheet.
TableParameters | Property that returns the TableParameters collection object.
Type | Returns an ObjectTypeEnum indicating this object's type.
WorkSheet | Property that returns the Excel WorkSheet object. Using the Excel Automation interface you can query and modify the contents of the sheet.
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties


ParameterTable.AttributeSets Property

ParameterTable.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.AttributeSets Property


ParameterTable.FileName Property

ParameterTable.FileName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the spreadsheet path. If the spreadsheet is embedded this will return an empty string.

Visual Basic
Property FileName() As String
Remarks

This property can be used to change the reference from one spreadsheet to another. Setting the filename for an embedded Excel document will fail. Setting a new filename may add new parameters, update existing ones, and may change the HealthStatus of some to kDriverLost.

See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.FileName Property


ParameterTable.Linked Property

ParameterTable.Linked Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies if the Excel document is linked or embedded to the Autodesk Inventor document.

Visual Basic
Property Linked() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.Linked Property


ParameterTable.Parent Property

ParameterTable.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object of this ParameterTable. This property will return different types of objects depending on the document type the ParameterTable is contained in. If the ParameterTable is in a part document then the parent is a PartComponentDefinition object. If the ParameterTable is in an assembly document then the parent is an AssemblyComponentDefinition. If the document is a drawing document then the parent is a DraftDocument.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.Parent Property


ParameterTable.ReferencedFileDescriptor Property

ParameterTable.ReferencedFileDescriptor Property
Summary

This is ReferencedFileDescriptor, a member of class ParameterTable.

Visual Basic
Property ReferencedFileDescriptor() As ReferencedOLEFileDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.ReferencedFileDescriptor Property


ParameterTable.StartCell Property

ParameterTable.StartCell Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the starting cell that's used when reading the spreadsheet.

Visual Basic
Property StartCell() As String
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.StartCell Property


ParameterTable.TableParameters Property

ParameterTable.TableParameters Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the TableParameters collection object.

Visual Basic
Property TableParameters() As TableParameters**
See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.TableParameters Property


ParameterTable.Type Property

ParameterTable.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.Type Property


ParameterTable.WorkSheet Property

ParameterTable.WorkSheet Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Excel WorkSheet object. Using the Excel Automation interface you can query and modify the contents of the sheet.

Visual Basic
Property WorkSheet() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ParameterTable Interface > ParameterTable Properties > ParameterTable.WorkSheet Property


ParameterTables Interface

ParameterTables Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Creates and provides access to the parameters that were created as a result of reading in a spreadsheet.

Class Hierarchy
Inventor::ParameterTables
Visual Basic
Public Interface ParameterTables
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameters.ParameterTables

Example

"Table Parameters Example"

This sample demonstrates how to access the Parameters object, and from it in turn the TableParameters collection that represents the collection of parameters that have been linked/embedded from an external spreadsheet.

To run the sample, you need to have a part document open, and the spreadsheet C:\Temp\params.xls must exist. You can also edit the sample to reference another spreadsheet if you prefer. The spreadsheet should contain valid definitions for parameters.

For the section of the code that demonstrates changing the reference you also need to create a spreadsheet C:\Temp\newparams.xls, or edit the sample to reference another spreadsheet.

Public Sub TableParameters()
    Dim oPartDoc As Inventor.PartDocument
    ' Obtain the active document, this assumes that
    ' a part document is active in Inventor
    Set oPartDoc = ThisApplication.ActiveDocument

    'Obtain the Parameters collection
    Dim oParams As Parameters
    Set oParams = oPartDoc.ComponentDefinition.Parameters

    ' Add a parameter table using an existing spreadsheet.
    oParams.ParameterTables.AddExcelTable "C:\Temp\params.xls", "A1", True

    ' Accessing a parameters in a linked/embedded file
    Dim oParamTableFiles As ParameterTables
    Set oParamTableFiles = oParams.ParameterTables

    ' Traverse through the collection of linked files
    Dim oParamTableFile As ParameterTable
    For Each oParamTableFile In oParamTableFiles
        ' Change the linked file to another file
        If LCase(oParamTableFile.FileName) = "C:\temp\params.xls" Then
            oParamTableFile.FileName = "C:\Temp\newparams.xls"
        End If

        ' Get the Parameters collection from the file
        Dim oTableParams As TableParameters
        Set oTableParams = oParamTableFile.TableParameters

        ' Traverse through the table parameters collection and display them
        Dim iNumTableParams As Long
        Debug.Print "TABLE PARAMETER VALUES"
        For iNumTableParams = 1 To oTableParams.Count
            ' Display the name
            Debug.Print " Name: " & oTableParams.Item(iNumTableParams).Name

            ' Display the expression
            Debug.Print " Expression: " & oTableParams.Item(iNumTableParams).Expression

            ' Display the value.  This will be in database units.
            Debug.Print " Value: " & oTableParams.Item(iNumTableParams).Value
        Next iNumTableParams
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface


ParameterTables Methods

ParameterTables Methods
Summary

The methods of the ParameterTables class are listed here.

Methods
Methods
Name | Description
AddExcelTable | Method that creates a new ParameterTable object, given an existing Excel document as input. Returns the resulting ParameterTable object. The first sheet in the Excel document is used.
Item | Property that returns the specified ParameterTable object from the collection. This is the default property of the ParameterTables collection object.
You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface > ParameterTables Methods


ParameterTables.AddExcelTable Method

ParameterTables.AddExcelTable Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new ParameterTable object, given an existing Excel document as input. Returns the resulting ParameterTable object. The first sheet in the Excel document is used.

Visual Basic
Sub AddExcelTable(ExcelDocument As String, StartCell As String, Link As VARIANT_BOOL, Result As [out, retval] ParameterTable*)
Parameters
Parameters | Description
ExcelDocument | Input String value that contains the full path to the Excel document.
StartCell | Input String value that specifies the beginning cell to begin importing from, for example "A1".
Link | Input Boolean value that specifies whether the Excel document is to be embedded or linked. True indicates it should be linked.
See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface > ParameterTables Methods > ParameterTables.AddExcelTable Method


ParameterTables.Item Method

ParameterTables.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified ParameterTable object from the collection. This is the default property of the ParameterTables collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] ParameterTable*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the ParameterTable object to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ParameterTable name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface > ParameterTables Methods > ParameterTables.Item Method


ParameterTables Properties

ParameterTables Properties
Summary

The properties of the ParameterTables class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface > ParameterTables Properties


ParameterTables.Count Property

ParameterTables.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface > ParameterTables Properties > ParameterTables.Count Property


ParameterTables.Type Property

ParameterTables.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ParameterTables Interface > ParameterTables Properties > ParameterTables.Type Property


PartComponentDefinition Interface

PartComponentDefinition Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartComponentDefinition object that provides access to the Part.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::PartComponentDefinition
        Inventor::SheetMetalComponentDefinition
Visual Basic
Public Interface PartComponentDefinition
Inherits ComponentDefinition
Notes

Members through which this object may be accessed include:

PartComponentDefinitions.Item

PartDocument.ComponentDefinition

See Also

Create sheet metal face and cut features sample

Sketch Add sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Selectively link paramaters sample

Derived Parts and Assemblies sample

Add a decal feature sample

Creating a new parameter group sample

Copy a sketch sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Replace content center part sample

UI customization - create combo box control sample

UI customization - create combo box control sample

Navigation between browser and data sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface


PartComponentDefinition Methods

PartComponentDefinition Methods
Summary

The methods of the PartComponentDefinition class are listed here.

Methods
Methods
Name | Description
CreateFactory | Converts a part to an iPart factory.
DeleteObjects | Method that deletes a collection of objects that belong to the part.
ExportObjects | Marks all the input objects as exported.
FindUsingRay | Method that fires a ray through the part or assembly and returns the entities intersected by the ray. The objects intersected by the ray are returned in the order in which they are intersected, with the first entities returned being those closest to the clipping plane.
GetEndOfPartPosition | Gets the current end of part position in the browser (in parts).
SetEndOfPartToTopOrBottom | Method that positions the end-of-part marker at the top or bottom of the browser.
SuppressFeatures | Method that suppresses the specified features.
UnsuppressFeatures | Method that unsuppresses the specified features.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods


PartComponentDefinition.CreateFactory Method

PartComponentDefinition.CreateFactory Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Converts a part to an iPart factory.

Visual Basic
Sub CreateFactory(Result As [out, retval] iPartFactory*)
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.CreateFactory Method


PartComponentDefinition.DeleteObjects Method

PartComponentDefinition.DeleteObjects Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes a collection of objects that belong to the part.

Visual Basic
Sub DeleteObjects(Objects As ObjectCollection, ByRef RetainConsumedSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDepFeatsAndSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDepWorkFeats As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
Objects | Collection of objects to delete from the part. Valid objects are part features, work features, sketches and 3d sketches.
RetainConsumedSketches | Optional input Boolean indicating if consumed sketches within the feature should be deleted. If the feature being deleted is not a sketch based feature this argument is ignored.
RetainDepFeatsAndSketches | Optional input Boolean that specifies if dependent features and sketches should be deleted. If there are no such dependents this argument is ignored.
RetainDepWorkFeats | Optional input Boolean that specifies if dependent work features should be deleted. If there are no dependent work features this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.DeleteObjects Method


PartComponentDefinition.ExportObjects Method

PartComponentDefinition.ExportObjects Method
Summary

Marks all the input objects as exported.

Visual Basic
Sub ExportObjects(Objects As ObjectCollection)
Parameters
Parameters | Description
Objects | Object collection to mark as exported.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.ExportObjects Method


PartComponentDefinition.FindUsingRay Method

PartComponentDefinition.FindUsingRay Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that fires a ray through the part or assembly and returns the entities intersected by the ray. The objects intersected by the ray are returned in the order in which they are intersected, with the first entities returned being those closest to the clipping plane.

Visual Basic
Sub FindUsingRay(RayStartPoint As Point, RayDirection As UnitVector, Radius As double, ByRef FoundEntities As ObjectsEnumerator*, ByRef LocationPoints As ObjectsEnumerator*, ByRef FindFirstOnly As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RayStartPoint | Input Point object that defines the start point of the ray in model space.
RayDirection | Input UnitVector object that defines the direction of the ray. The ray is infinite in the direction defined.
Radius | Input Double that defines the radius of the ray. This value is specified in centimeters. Defining a radius for a ray allows the intersection to be within a given tolerance. This radius essentially results in the definition of a cylinder whose axis lies along the axis defined by the RayStartPoint and RayDirection. The intersection result is between the cylinder and the model's entities. A value higher than zero is recommended, though not explicitly required.
FoundEntities | Output ObjectsEnumerator that returns the entities that were intersected by the ray.
LocationPoints | Output ObjectsEnumerator that returns a set of Point objects. One Point object is returned for each entity in the FoundEntities list. The point defines the coordinate of the intersection between the ray and the corresponding entity.
FindFirstOnly | Optional input Boolean that specifies whether to find just the first entity in the ray's path. If False (the default) then all entities found are returned.
Remarks

There is also a precedence in the type of entities returned. The entities returned can be Vertex, Edge, or Face objects. The precedence is in that order. If the ray intersects a vertex, then that vertex is returned and none of the edges or faces that connect to that vertex are returned. If the ray intersects an edge, then that edge is returned and none of the faces that connect to the edge are returned. If the ray intersects a face, then that face is returned. If desired, you can use the functionality provided by the B-Rep portion of the API to obtain the various associated objects from the entity returned. For example if you need a face but an edge is returned, you can use the Faces property of the Edge object to get the associated faces. The start point defines the physical starting point from which to determine intersections. Any intersections behind the start point are ignored. However, the ray is infinite from the start point, so all intersections in the direction of the ray will be returned.

Notes

As of Autodesk Inventor 5.3 Service Pack 2, the FindUsingRay method has superseded LocateUsingRay. Please update your applications accordingly.

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.FindUsingRay Method


PartComponentDefinition.GetEndOfPartPosition Method

PartComponentDefinition.GetEndOfPartPosition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the current end of part position in the browser (in parts).

Visual Basic
Sub GetEndOfPartPosition(ByRef After As IDispatch*, ByRef Before As IDispatch*)
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.GetEndOfPartPosition Method


PartComponentDefinition.SetEndOfPartToTopOrBottom Method

PartComponentDefinition.SetEndOfPartToTopOrBottom Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that positions the end-of-part marker at the top or bottom of the browser.

Visual Basic
Sub SetEndOfPartToTopOrBottom(SetToTop As VARIANT_BOOL)
Parameters
Parameters | Description
SetToTop | Input Boolean that specifies whether the end-of-part marker is to be moved to the top or the bottom of the browser. If True, the marker is moved to the top of the browser, just below the Origin folder. If False, it is moved to the bottom of the browser, just below the last item in the browser.
See Also

Edit width extent of an existing flange feature sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.SetEndOfPartToTopOrBottom Method


PartComponentDefinition.SuppressFeatures Method

PartComponentDefinition.SuppressFeatures Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that suppresses the specified features.

Visual Basic
Sub SuppressFeatures(Features As ObjectCollection)
Parameters
Parameters | Description
Features | Collection of features to suppress.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.SuppressFeatures Method


PartComponentDefinition.UnsuppressFeatures Method

PartComponentDefinition.UnsuppressFeatures Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that unsuppresses the specified features.

Visual Basic
Sub UnsuppressFeatures(Features As ObjectCollection)
Parameters
Parameters | Description
Features | Collection of features to unsuppress.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Methods > PartComponentDefinition.UnsuppressFeatures Method


PartComponentDefinition Properties

PartComponentDefinition Properties
Summary

The properties of the PartComponentDefinition class are listed here.

Properties
Name | Description
AnalysisManager | Property that returns the AnalysisManager object.
BIMComponent | Property that returns the BIMComponent object associated with this component definition.
CompactModelHistoryOnNextSave | Property that indicates the flag that determines whether the BRep's modifications through its history are saved explicitly in the next save or not (independent of CompactModelHistory setting).
Features | Property that returns the PartFeatures collection object.
HasMultipleSolidBodies | Determines whether the part contains multiple solid bodies or not.
iMateDefinitions | Property that returns the iMateDefinitions collection object associated with this part.
iPartFactory | Property that returns the iPartFactory object. This property will fail in the case where the part is not an iPart Factory. You can determine this by using the IsiPartFactory property.
iPartMember | Property that returns the iPartMember object.
IsContentMember | Property that indicates if this part is a Content Center part or not. A value of True indicates it is a Content Center part.
IsiPartFactory | Property that returns if the part is an iPart Factory or not. It returns True in the case where the part is a factory. If True, the factory can be obtained using the iPartFactory property.
IsiPartMember | Property that returns the iPartMember object. This property will fail in the case where the part is not an iPart Member. You can determine this by using the IsiPartMember property.
MassProperties | Mass properties for this ComponentDefinition.
Material | Property that indicates which material is associated with the part.
Parameters | Gets the Parameters collection object that encapsulates all of the parameters defined in this ComponentDefinition.
PartEvents | Property that returns the PartEvents source object.
ReferenceComponents | Property that returns the ReferenceComponents collection object.
RepresentationsManager | Property that returns the RepresentationsManager object.
RolledBackForEdit | Property that gets whether the model is currently rolled back to a previous point in the feature history.
SketchBlockDefinitions | Property that returns the SketchBlockDefinitions collection object.
Sketches | Gets the PlanarSketches collection object that encapsulates all of the planar sketches defined in this ComponentDefinition.
Sketches3D | Property that returns the Sketches3D collection object that encapsulates all of the 3D sketches defined in this ComponentDefinition.
UserCoordinateSystems | Property that returns the UserCoordinateSystems collection object.
WorkAxes | Property that returns the WorkAxes collection object.
WorkPlanes | Property that returns the WorkPlanes collection object.
WorkPoints | Property that returns the WorkPoints collection object.
WorkSurfaces | Property that returns the collection object that encapsulates all of the work surfaces defined in this PartComponentDefinition.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties


PartComponentDefinition.AnalysisManager Property

PartComponentDefinition.AnalysisManager Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AnalysisManager object.

Visual Basic
Property AnalysisManager() As AnalysisManager**
See Also

Create a Draft Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.AnalysisManager Property


PartComponentDefinition.BIMComponent Property

PartComponentDefinition.BIMComponent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the BIMComponent object associated with this component definition.

Visual Basic
Property BIMComponent() As BIMComponent**
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.BIMComponent Property


PartComponentDefinition.CompactModelHistoryOnNextSave Property

PartComponentDefinition.CompactModelHistoryOnNextSave Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the flag that determines whether the BRep's modifications through its history are saved explicitly in the next save or not (independent of CompactModelHistory setting).

Visual Basic
Property CompactModelHistoryOnNextSave() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.CompactModelHistoryOnNextSave Property


PartComponentDefinition.Features Property

PartComponentDefinition.Features Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the PartFeatures collection object.

Visual Basic
Property Features() As PartFeatures**
See Also

Create sheet metal lofted flange feature sample

Create sheet metal face and fold features sample

Create sheet metal face and cut features sample

Add a punch tool feature sample

Place table driven iFeature sample

Placementof a standard iFeature sample

Extrude Feature - Create Block with Pocket sample

Derived Parts and Assemblies sample

Add a decal feature sample

Remove client feature elements sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.Features Property


PartComponentDefinition.HasMultipleSolidBodies Property

PartComponentDefinition.HasMultipleSolidBodies Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Determines whether the part contains multiple solid bodies or not.

Visual Basic
Property HasMultipleSolidBodies() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.HasMultipleSolidBodies Property


PartComponentDefinition.iMateDefinitions Property

PartComponentDefinition.iMateDefinitions Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iMateDefinitions collection object associated with this part.

Visual Basic
Property iMateDefinitions() As iMateDefinitions**
See Also

Add iMate Definition sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.iMateDefinitions Property


PartComponentDefinition.iPartFactory Property

PartComponentDefinition.iPartFactory Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iPartFactory object. This property will fail in the case where the part is not an iPart Factory. You can determine this by using the IsiPartFactory property.

Visual Basic
Property iPartFactory() As iPartFactory**
See Also

Create a Configuration Table sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.iPartFactory Property


PartComponentDefinition.iPartMember Property

PartComponentDefinition.iPartMember Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iPartMember object.

Visual Basic
Property iPartMember() As iPartMember**
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.iPartMember Property


PartComponentDefinition.IsContentMember Property

PartComponentDefinition.IsContentMember Property Available in Apprentice Introduced in Inventor 2011
Summary

Property that indicates if this part is a Content Center part or not. A value of True indicates it is a Content Center part.

Visual Basic
Property IsContentMember() As VARIANT_BOOL*
See Also

Replace content center part sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.IsContentMember Property


PartComponentDefinition.IsiPartFactory Property

PartComponentDefinition.IsiPartFactory Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns if the part is an iPart Factory or not. It returns True in the case where the part is a factory. If True, the factory can be obtained using the iPartFactory property.

Visual Basic
Property IsiPartFactory() As VARIANT_BOOL*
See Also

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.IsiPartFactory Property


PartComponentDefinition.IsiPartMember Property

PartComponentDefinition.IsiPartMember Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the iPartMember object. This property will fail in the case where the part is not an iPart Member. You can determine this by using the IsiPartMember property.

Visual Basic
Property IsiPartMember() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.IsiPartMember Property


PartComponentDefinition.MassProperties Property

PartComponentDefinition.MassProperties Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Mass properties for this ComponentDefinition.

Visual Basic
Property MassProperties() As MassProperties**
See Also

Computing mass properties without dirtying document sample

Work Point at Mass Center sample

Work point at mass center (C#) sample

Mass Properties from Part sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.MassProperties Property


PartComponentDefinition.Material Property

PartComponentDefinition.Material Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates which material is associated with the part.

Visual Basic
Property Material() As Material*
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.Material Property


PartComponentDefinition.Parameters Property

PartComponentDefinition.Parameters Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Parameters collection object that encapsulates all of the parameters defined in this ComponentDefinition.

Visual Basic
Property Parameters() As Parameters**
See Also

Table Parameters sample

Model Parameters sample

Selectively link paramaters sample

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.Parameters Property


PartComponentDefinition.PartEvents Property

PartComponentDefinition.PartEvents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the PartEvents source object.

Visual Basic
Property PartEvents() As PartEvents**
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.PartEvents Property


PartComponentDefinition.ReferenceComponents Property

PartComponentDefinition.ReferenceComponents Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponents collection object.

Visual Basic
Property ReferenceComponents() As ReferenceComponents**
Remarks

This object provides access to the derived part information within a part. For legacy reasons, this will also contain some information related to iFeatures and punch features. This information should be ignored. iFeatures are now available through the iFeatures collection and punch tool features are accessed through the PunchToolFeatures collection.

See Also

Shrink wrap substitute in assembly sample

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.ReferenceComponents Property


PartComponentDefinition.RepresentationsManager Property

PartComponentDefinition.RepresentationsManager Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the RepresentationsManager object.

Visual Basic
Property RepresentationsManager() As RepresentationsManager**
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.RepresentationsManager Property


PartComponentDefinition.RolledBackForEdit Property

PartComponentDefinition.RolledBackForEdit Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets whether the model is currently rolled back to a previous point in the feature history.

Visual Basic
Property RolledBackForEdit() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.RolledBackForEdit Property


PartComponentDefinition.SketchBlockDefinitions Property

PartComponentDefinition.SketchBlockDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the SketchBlockDefinitions collection object.

Visual Basic
Property SketchBlockDefinitions() As SketchBlockDefinitions**
See Also

Create and insert a sketch block definition into a part sketch sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.SketchBlockDefinitions Property


PartComponentDefinition.Sketches Property

PartComponentDefinition.Sketches Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the PlanarSketches collection object that encapsulates all of the planar sketches defined in this ComponentDefinition.

Visual Basic
Property Sketches() As PlanarSketches**
See Also

Set Sketch Visibility sample

Create sheet metal face and cut features sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Add a decal feature sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.Sketches Property


PartComponentDefinition.Sketches3D Property

PartComponentDefinition.Sketches3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Sketches3D collection object that encapsulates all of the 3D sketches defined in this ComponentDefinition.

Visual Basic
Property Sketches3D() As Sketches3D**
See Also

Sweep Feature Add sample

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.Sketches3D Property


PartComponentDefinition.UserCoordinateSystems Property

PartComponentDefinition.UserCoordinateSystems Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the UserCoordinateSystems collection object.

Visual Basic
Property UserCoordinateSystems() As UserCoordinateSystems**
See Also

UCS by three points sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.UserCoordinateSystems Property


PartComponentDefinition.WorkAxes Property

PartComponentDefinition.WorkAxes Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the WorkAxes collection object.

Visual Basic
Property WorkAxes() As WorkAxes**
See Also

Create sheet metal face and cut features sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.WorkAxes Property


PartComponentDefinition.WorkPlanes Property

PartComponentDefinition.WorkPlanes Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the WorkPlanes collection object.

Visual Basic
Property WorkPlanes() As WorkPlanes**
See Also

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Extrude sketch text sample

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.WorkPlanes Property


PartComponentDefinition.WorkPoints Property

PartComponentDefinition.WorkPoints Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the WorkPoints collection object.

Visual Basic
Property WorkPoints() As WorkPoints**
See Also

UCS by three points sample

Create sheet metal face and cut features sample

Sketch Add Oriented sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Work Point at Mass Center sample

Work point at mass center (C#) sample

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.WorkPoints Property


PartComponentDefinition.WorkSurfaces Property

PartComponentDefinition.WorkSurfaces Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection object that encapsulates all of the work surfaces defined in this PartComponentDefinition.

Visual Basic
Property WorkSurfaces() As WorkSurfaces**
See Also

Adding a new stitch (knit) feature sample

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinition Interface > PartComponentDefinition Properties > PartComponentDefinition.WorkSurfaces Property


PartComponentDefinitions Interface

PartComponentDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Part ComponentDefinitions object represents a collection of objects.

Class Hierarchy
Inventor::PartComponentDefinitions
Visual Basic
Public Interface PartComponentDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartDocument.ComponentDefinitions

You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinitions Interface


PartComponentDefinitions Methods

PartComponentDefinitions Methods
Summary

The methods of the PartComponentDefinitions class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinitions Interface > PartComponentDefinitions Methods


PartComponentDefinitions.Item Method

PartComponentDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] PartComponentDefinition*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the PartComponentDefinition to return.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinitions Interface > PartComponentDefinitions Methods > PartComponentDefinitions.Item Method


PartComponentDefinitions Properties

PartComponentDefinitions Properties
Summary

The properties of the PartComponentDefinitions class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinitions Interface > PartComponentDefinitions Properties


PartComponentDefinitions.Count Property

PartComponentDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinitions Interface > PartComponentDefinitions Properties > PartComponentDefinitions.Count Property


PartComponentDefinitions.Type Property

PartComponentDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartComponentDefinitions Interface > PartComponentDefinitions Properties > PartComponentDefinitions.Type Property


PartDocument Interface

PartDocument Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartDocument object is derived from the Document object.

Class Hierarchy
Inventor::Document
    Inventor::PartDocument
Visual Basic
Public Interface PartDocument
Inherits Document
See Also

Buttons - add MRU split button sample

UI customization - create combo box control sample

UI customization - create combo box control sample

Remove client feature elements sample

Navigation between browser and data sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface


PartDocument Methods

PartDocument Methods
Summary

The methods of the PartDocument class are listed here.

Methods
Methods
Name | Description
GetSelectedObject | This is GetSelectedObject, a member of class PartDocument.
PutGraphicsLevelsOfDetail | Sets the graphics facet groups that must be saved with this file. Each bit indicating a level of detail. Up to 6 permitted. File size affected adversely when more. Recommend pick from GraphicsLevelsOfDetailEnum.
UpdateSubstitutePart | Method that updates the substitute part.
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Methods


PartDocument.GetSelectedObject Method

PartDocument.GetSelectedObject Method
Summary

This is GetSelectedObject, a member of class PartDocument.

Visual Basic
Sub GetSelectedObject(Selection As GenericObject, ByRef ObjectType As ObjectTypeEnum, ByRef AdditionalData As NameValueMap*, ByRef ContainingOccurrence As ComponentOccurrence*, ByRef SelectedObject As [optional] VARIANT)
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Methods > PartDocument.GetSelectedObject Method


PartDocument.PutGraphicsLevelsOfDetail Method

PartDocument.PutGraphicsLevelsOfDetail Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets the graphics facet groups that must be saved with this file. Each bit indicating a level of detail. Up to 6 permitted. File size affected adversely when more. Recommend pick from GraphicsLevelsOfDetailEnum.

Visual Basic
Sub PutGraphicsLevelsOfDetail(LevelsOfDetail As long)
Parameters
Parameters | Description
LevelsOfDetail | Input Long that specifies the level of detail.
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Methods > PartDocument.PutGraphicsLevelsOfDetail Method


PartDocument.UpdateSubstitutePart Method

PartDocument.UpdateSubstitutePart Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that updates the substitute part.

Visual Basic
Sub UpdateSubstitutePart(ByRef IgnoreErrors As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
IgnoreErrors | Optional input Boolean that indicates whether to continue the update process if an error (such as a missing link) is encountered.
Remarks

All suppressed links are temporarily unsuppressed to perform the update. The method trivially exits if this is not a substitute part. The Boolean return indicates whether an error was encountered during the update.

You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Methods > PartDocument.UpdateSubstitutePart Method


PartDocument Properties

PartDocument Properties
Summary

The properties of the PartDocument class are listed here.

Properties
Name | Description
ActiveLightingStyle | Gets the active lighting style object.
ActiveRenderStyle | Gets the active render style object.
ComponentDefinition | Gets the primary ComponentDefinition that resides in this file (housing the BRep and its geometric Feature Constraints).
DisabledCommandList | Property that returns the DisabledCommandList object. This object allows the document to disable specific commands. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.
DisplaySettings | Property that returns the DisplaySettings object. The DisplaySettings object provides access to various display appearance related document settings.
EnvironmentManager | Property that returns the EnvironmentManager object.
IsSubstitutePart | Property that gets and sets whether this part is intended to be used as a substitute part.
LightingStyles | Property that returns the LightingStyles collection object.
Materials | Property that returns the Materials collection object.
ModelingSettings | Property that returns the ModelingSettings object. The ModelingSettings object provides access to various modeling related document options. This is somewhat equivalent to the Modeling tab of the Document Settings dialog.
ObjectVisibility | Property that returns the ObjectVisibility object providing override visibility controls for objects in the document. Changes are not saved with the document.
Sketch3DSettings | Property that returns the Sketch3DSettings object. The Sketch3DSettings object provides access to various 3D sketch related document options. This is somewhat equivalent to the 3D sketch related properties on Sketch tab of the Document Settings dialog.
SketchActive | Gets a Boolean flag indicating whether sketching is currently active.
SketchSettings | Property that returns the SketchSettings object. The SketchSettings object provides access to various sketch related document options. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.
SubstitutePartStatus | Property that returns whether this substitute part is up to date with respect to external links.
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties


PartDocument.ActiveLightingStyle Property

PartDocument.ActiveLightingStyle Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the active lighting style object.

Visual Basic
Property ActiveLightingStyle() As LightingStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.ActiveLightingStyle Property


PartDocument.ActiveRenderStyle Property

PartDocument.ActiveRenderStyle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the active render style object.

Visual Basic
Property ActiveRenderStyle() As RenderStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.ActiveRenderStyle Property


PartDocument.ComponentDefinition Property

PartDocument.ComponentDefinition Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the primary ComponentDefinition that resides in this file (housing the BRep and its geometric Feature Constraints).

Visual Basic
Property ComponentDefinition() As PartComponentDefinition**
See Also

Assembly Ground Occurrences sample

Sheet Metal Feature Display sample

Add a punch tool feature sample

Table Parameters sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Selectively link paramaters sample

Derived Parts and Assemblies sample

Add a decal feature sample

Translate - Sheet Metal to DXF sample

Create a Configuration Table sample

Copy a sketch sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

UI customization - create combo box control sample

UI customization - create combo box control sample

Client Graphics - Draw Range Box sample

Remove client feature elements sample

Navigation between browser and data sample

Delete Face, Boundary Patch and Stitch features. sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.ComponentDefinition Property


PartDocument.DisabledCommandList Property

PartDocument.DisabledCommandList Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the DisabledCommandList object. This object allows the document to disable specific commands. This list contains commands that are disabled in addition to those specified by the DisabledCommandTypes property.

Visual Basic
Property DisabledCommandList() As DisabledCommandList**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.DisabledCommandList Property


PartDocument.DisplaySettings Property

PartDocument.DisplaySettings Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the DisplaySettings object. The DisplaySettings object provides access to various display appearance related document settings.

Visual Basic
Property DisplaySettings() As DisplaySettings**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.DisplaySettings Property


PartDocument.EnvironmentManager Property

PartDocument.EnvironmentManager Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the EnvironmentManager object.

Visual Basic
Property EnvironmentManager() As EnvironmentManager**
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.EnvironmentManager Property


PartDocument.IsSubstitutePart Property

PartDocument.IsSubstitutePart Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether this part is intended to be used as a substitute part.

Visual Basic
Property IsSubstitutePart() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.IsSubstitutePart Property


PartDocument.LightingStyles Property

PartDocument.LightingStyles Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the LightingStyles collection object.

Visual Basic
Property LightingStyles() As LightingStyles**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.LightingStyles Property


PartDocument.Materials Property

PartDocument.Materials Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Materials collection object.

Visual Basic
Property Materials() As Materials**
See Also

Material Read sample

Material Create sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.Materials Property


PartDocument.ModelingSettings Property

PartDocument.ModelingSettings Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the ModelingSettings object. The ModelingSettings object provides access to various modeling related document options. This is somewhat equivalent to the Modeling tab of the Document Settings dialog.

Visual Basic
Property ModelingSettings() As ModelingSettings**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.ModelingSettings Property


PartDocument.ObjectVisibility Property

PartDocument.ObjectVisibility Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ObjectVisibility object providing override visibility controls for objects in the document. Changes are not saved with the document.

Visual Basic
Property ObjectVisibility() As ObjectVisibility**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.ObjectVisibility Property


PartDocument.Sketch3DSettings Property

PartDocument.Sketch3DSettings Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the Sketch3DSettings object. The Sketch3DSettings object provides access to various 3D sketch related document options. This is somewhat equivalent to the 3D sketch related properties on Sketch tab of the Document Settings dialog.

Visual Basic
Property Sketch3DSettings() As Sketch3DSettings**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.Sketch3DSettings Property


PartDocument.SketchActive Property

PartDocument.SketchActive Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets a Boolean flag indicating whether sketching is currently active.

Visual Basic
Property SketchActive() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.SketchActive Property


PartDocument.SketchSettings Property

PartDocument.SketchSettings Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the SketchSettings object. The SketchSettings object provides access to various sketch related document options. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.

Visual Basic
Property SketchSettings() As SketchSettings**
You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.SketchSettings Property


PartDocument.SubstitutePartStatus Property

PartDocument.SubstitutePartStatus Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether this substitute part is up to date with respect to external links.

Visual Basic
Property SubstitutePartStatus() As ReferenceStatusEnum*
Remarks

This property is applicable only if the IsSubstitutePart property returns False. All the suppressed links of the substitute part are temporarily unsuppressed in order to check whether the part needs updating. Possible return values are kUpToDateReference, kOutOfDateReference and kMissingReference. The property returns kUnknownReference if the IsSubstitutePart property returns False.

You are here: Symbol Reference > Inventor Library > Objects > PartDocument Interface > PartDocument Properties > PartDocument.SubstitutePartStatus Property


PartEvents CoClass

PartEvents CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartEvents object provides notification of part events including changes to surface bodies.

Class Hierarchy
Inventor::PartEvents
Visual Basic
Public Class PartEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

FlatPattern.PartEvents

PartComponentDefinition.PartEvents

You are here: Symbol Reference > Inventor Library > Objects > PartEvents CoClass


PartEventsObject Interface

PartEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartEvents object provides notification of part events including changes to surface bodies.

Class Hierarchy
Inventor::PartEventsObject
Visual Basic
Public Interface PartEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

FlatPattern.PartEvents

PartComponentDefinition.PartEvents

You are here: Symbol Reference > Inventor Library > Objects > PartEventsObject Interface


PartEventsObject Properties

PartEventsObject Properties
Summary

The properties of the PartEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartEventsObject Interface > PartEventsObject Properties


PartEventsObject.Application Property

PartEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartEventsObject Interface > PartEventsObject Properties > PartEventsObject.Application Property


PartEventsObject.Parent Property

PartEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartEventsObject Interface > PartEventsObject Properties > PartEventsObject.Parent Property


PartEventsObject.Type Property

PartEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartEventsObject Interface > PartEventsObject Properties > PartEventsObject.Type Property


PartEventsSink Interface

PartEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartEvents object provides notification of part events including changes to surface bodies.

Class Hierarchy
Inventor::PartEventsSink
Visual Basic
Public Interface PartEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

FlatPattern.PartEvents

PartComponentDefinition.PartEvents

You are here: Symbol Reference > Inventor Library > Objects > PartEventsSink Interface


PartEventsSink Methods

PartEventsSink Methods
Summary

The methods of the PartEventsSink class are listed here.

Methods
Methods
Name | Description
OnSurfaceBodyChanged | The OnSurfaceBodyChanged event notifies the client when the surface and solid geometry of a part geometrically changes.
You are here: Symbol Reference > Inventor Library > Objects > PartEventsSink Interface > PartEventsSink Methods


PartEventsSink.OnSurfaceBodyChanged Method

PartEventsSink.OnSurfaceBodyChanged Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnSurfaceBodyChanged event notifies the client when the surface and solid geometry of a part geometrically changes.

Visual Basic
Sub OnSurfaceBodyChanged(Context As NameValueMap, BeforeOrAfter As EventTimingEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Context | Input object that can be used to determine the context of why the event fired. Additional information is provided through this argument to help in understanding the context of the notification. Name = "Undo". Value = A Boolean indicating if the change occurred as the result of an undo operation. This context value is only provided in the case where the change does occur because of an undo operation, so the value will always be True.
BeforeOrAfter | Input indicating when the event is being fired. Notification is only sent after the surface body has changed, so this value is always kAfter.
pHandlingCode | Output HandlingCodeEnum that indicates how the event was handled. This argument is ignored for this event.
Remarks

If there are multiple surface bodies within a part, (solid and/or work surfaces), this notification is sent if any of them change.

You are here: Symbol Reference > Inventor Library > Objects > PartEventsSink Interface > PartEventsSink Methods > PartEventsSink.OnSurfaceBodyChanged Method


PartFeature Interface

PartFeature Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartFeature object is the base class for all part modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::AliasFreeformFeature
    Inventor::BendFeature
    Inventor::BendPartFeature
    Inventor::BossFeature
    Inventor::BoundaryPatchFeature
    Inventor::ChamferFeature
    Inventor::CircularPatternFeature
    Inventor::ClientFeature
    Inventor::CoilFeature
    Inventor::CombineFeature
    Inventor::ContourFlangeFeature
    Inventor::ContourRollFeature
    Inventor::CoreCavityFeature
    Inventor::CornerChamferFeature
    Inventor::CornerFeature
    Inventor::CornerRoundFeature
    Inventor::CosmeticBendFeature
    Inventor::CutFeature
    Inventor::DecalFeature
    Inventor::DeleteFaceFeature
    Inventor::EmbossFeature
    Inventor::ExtendFeature
    Inventor::ExtrudeFeature
    Inventor::FaceDraftFeature
    Inventor::FaceFeature
    Inventor::FilletFeature
    Inventor::FlangeFeature
    Inventor::FoldFeature
    Inventor::GrillFeature
    Inventor::HemFeature
    Inventor::HoleFeature
    Inventor::KnitFeature
    Inventor::LipFeature
    Inventor::LoftedFlangeFeature
    Inventor::LoftFeature
    Inventor::MirrorFeature
    Inventor::MoveFaceFeature
    Inventor::MoveFeature
    Inventor::NonParametricBaseFeature
    Inventor::PunchToolFeature
    Inventor::RectangularPatternFeature
    Inventor::ReferenceFeature
    Inventor::RefoldFeature
    Inventor::ReplaceFaceFeature
    Inventor::RestFeature
    Inventor::RevolveFeature
    Inventor::RibFeature
    Inventor::RipFeature
    Inventor::RuleFilletFeature
    Inventor::SculptFeature
    Inventor::ShellFeature
    Inventor::SnapFitFeature
    Inventor::SplitFeature
    Inventor::SweepFeature
    Inventor::ThickenFeature
    Inventor::ThreadFeature
    Inventor::TrimFeature
    Inventor::UnfoldFeature
Visual Basic
Public Interface PartFeature
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ChamferDefinition.Parent

Face.CreatedByFeature

FeatureDimension.Parent

FeaturePatternElement.Parent

Features.Item

FlatPatternFeatures.Item

PartFeature.OwnedBy

PartFeatureExtent.Parent

PartFeatures.Item

PartFeaturesEnumerator.Item

PlanarSketch.OwnedBy

Sketch3D.OwnedBy

SurfaceBody.CreatedByFeature

UserCoordinateSystem.OwnedBy

WorkAxis.OwnedBy

WorkPlane.OwnedBy

WorkPoint.OwnedBy

ClientFeatureElement.Element

See Also

Create sheet metal rip feature sample

Sheet Metal Feature Display sample

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface


PartFeature Methods

PartFeature Methods
Summary

The methods of the PartFeature class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the feature. The arguments allow control over which dependent objects are also deleted.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetRenderStyle | This method returns the render style currently used for this object. The used for an object can be specified in two ways. First, the object can inherit the RenderStyle defined for the part. Second, a RenderStyle can be explicitly assigned to the object (feature, face..).
GetSuppressionCondition | Method that gets the suppression condition for the feature. The method returns False if no condition has been applied.
RemoveParticipant | Method that removes the specified participant from the assembly feature. This method fails for features in a part.
SetAffectedBodies | Method that sets a collection of SurfaceBody objects affected by this feature.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from.
SetRenderStyle | This method sets the render style to use for this object (feature, face, etc.). The used for an object can be specified in two ways. The object can inherit the RenderStyle defined for the part, or a RenderStyle can be explicitly assigned to the object.
SetSuppressionCondition | Method that sets the suppression condition for the feature.
SurfaceBody | Property that returns the associated with this object or feature.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods


PartFeature.Delete Method

PartFeature.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the feature. The arguments allow control over which dependent objects are also deleted.

Visual Basic
Sub Delete(ByRef RetainConsumedSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDependentFeaturesAndSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDependentWorkFeatures As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainConsumedSketches | Optional input Boolean indicating if consumed sketches within the feature should be deleted. If the feature being deleted is not a sketch based feature this argument is ignored.
RetainDependentFeaturesAndSketches | Optional input Boolean that specifies if dependent features should be deleted. If there are no dependent features this argument is ignored.
RetainDependentWorkFeatures | Optional input Boolean that specifies if dependent work features should be deleted. If there are no dependent work features this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.Delete Method


PartFeature.GetReferenceKey Method

PartFeature.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.GetReferenceKey Method


PartFeature.GetRenderStyle Method

PartFeature.GetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

This method returns the render style currently used for this object. The used for an object can be specified in two ways. First, the object can inherit the RenderStyle defined for the part. Second, a RenderStyle can be explicitly assigned to the object (feature, face..).

Visual Basic
Sub GetRenderStyle(ByRef StyleSourceType As StyleSourceTypeEnum, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
StyleSourceType | Output that specifies how the render style that is used for the feature was obtained. This can be kPartRenderStyle in the case where the feature will use the render style assigned to the part, or kOverrideRenderStyle where a render style has been explicitly assigned to the feature.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.GetRenderStyle Method


PartFeature.GetSuppressionCondition Method

PartFeature.GetSuppressionCondition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that gets the suppression condition for the feature. The method returns False if no condition has been applied.

Visual Basic
Sub GetSuppressionCondition(ByRef Parameter As Parameter*, ByRef ComparisonType As ComparisonTypeEnum, ByRef Expression As VARIANT, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Parameter | Parameter object that specifies the parameter whose value is to be checked for feature suppression.
ComparisonType | ComparisonTypeEnum that specifies the type of comparison. Valid return types are kEqualToComparison, kNotEqualToComparison, kLessThanComparison, kGreaterThanComparison, kLessThanOrEqualToComparison, kGreaterThanOrEqualToComparison.
Expression | Specifies the expression used for the comparison with the parameter value. This can either be a string or a parameter object.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.GetSuppressionCondition Method


PartFeature.RemoveParticipant Method

PartFeature.RemoveParticipant Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that removes the specified participant from the assembly feature. This method fails for features in a part.

Visual Basic
Sub RemoveParticipant(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the participant to be removed. An error occurs if the input ComponentOccurrence is not a participant.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.RemoveParticipant Method


PartFeature.SetAffectedBodies Method

PartFeature.SetAffectedBodies Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets a collection of SurfaceBody objects affected by this feature.

Visual Basic
Sub SetAffectedBodies(Bodies As ObjectCollection)
Parameters
Parameters | Description
Bodies | ObjectCollection of SurfaceBody objects.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.SetAffectedBodies Method


PartFeature.SetEndOfPart Method

PartFeature.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that repositions the end-of-part marker relative to the object this method is called from.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this work feature. A value of True indicates before and False indicates after.
Remarks

The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

See Also

Edit width extent of an existing flange feature sample

Example 1

Create and Edit an Extrude Feature with a pocket example.

This sample demonstrates how to edit an extrude feature.

Public Sub EditExtrudeFeature()
' Create a new part document, using the default part template.
Dim oPartDoc As PartDocument
Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

' Set a reference to the component definition.
Dim oCompDef As PartComponentDefinition
Set oCompDef = oPartDoc.ComponentDefinition

' Create a new sketch on the X-Y work plane.
Dim oSketch As PlanarSketch
Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

' Set a reference to the transient geometry object.
Dim oTransGeom As TransientGeometry
Set oTransGeom = ThisApplication.TransientGeometry

' Draw a 4cm x 3cm rectangle with the corner at (0,0)
Dim oRectangleLines As SketchEntitiesEnumerator
Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
oTransGeom.CreatePoint2d(0, 0), _
oTransGeom.CreatePoint2d(4, 3))

' Create a profile.
Dim oProfile As Profile
Set oProfile = oSketch.Profiles.AddForSolid

' Create a base extrusion 1cm thick.
Dim oExtrude1 As ExtrudeFeature
Set oExtrude1 = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
oProfile, 1, kNegativeExtentDirection, kJoinOperation)

' Get the top face of the extrusion to use for creating the new sketch.
Dim oFrontFace As Face
Set oFrontFace = oExtrude1.StartFaces.Item(1)

' Create a new sketch on this face, but use the method that allows you to
' control the orientation and orgin of the new sketch.
Set oSketch = oCompDef.Sketches.AddWithOrientation(oFrontFace, _
oCompDef.WorkAxes.Item(1), True, True, oCompDef.WorkPoints(1))

' Determine where in sketch space the point (0.5,0.5,0) is.
Dim oCorner As Point2d
Set oCorner = oSketch.ModelToSketchSpace(oTransGeom.CreatePoint(0.5, 0.5, 0))

' Create the interior 3cm x 2cm rectangle for the pocket.
Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
oCorner, oTransGeom.CreatePoint2d(oCorner.X + 3, oCorner.Y + 2))

' Create a profile.
Set oProfile = oSketch.Profiles.AddForSolid

' Create a pocket .25 cm deep (using distance extent).
Dim oExtrude2 As ExtrudeFeature
Set oExtrude2 = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
oProfile, 0.25, kNegativeExtentDirection, kCutOperation)

' Move the end of part above this extrude feature since the edit
' we are going to perform on this feature involves BREP input.
Call oExtrude2.SetEndOfPart(True)

' Get the back face of the first extrusion to use as termination plane.
Dim oBackFace As Face
Set oBackFace = oExtrude1.EndFaces.Item(1)

' Change the extent type of the feature.
Call oExtrude2.SetToFaceExtent(oBackFace, False)

' Move the end of part back to bottom of the feature tree.
oCompDef.SetEndOfPartToTopOrBottom (False)

' The following edit of the feature does not involve BREP input.
' Hence, no need to move the end of part.
Call oExtrude2.SetDistanceExtent(0.25, kNegativeExtentDirection)
End Sub
Example 2

Extrude feature - create block with pocket example (C#).

This sample demonstrates creating a simple solid consisting a block with a pocket. It shows how to create a sketch plane at a specified orientation to existing geometry.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void DrawBlockWithPocket()
{
    // Create a new part document, using the default part template.
    PartDocument oPartDoc = (PartDocument)ThisApplication.Documents.Add(DocumentTypeEnum.kPartDocumentObject, "", true);

    // Set a reference to the component definition.
    PartComponentDefinition oCompDef = oPartDoc.ComponentDefinition;

    // Create a new sketch on the X-Y work plane.  Since it's being created on
    // one of the base workplanes we know the orientation it will be created in
    // and don't need to worry about controlling it.  Because of this we also
    // know the origin of the sketch plane will be at (0,0,0) in model space.
    PlanarSketch oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes[3], false);

    // Set a reference to the transient geometry object.
    TransientGeometry oTransGeom = ThisApplication.TransientGeometry;

    // Draw a 4cm x 3cm rectangle with the corner at (0,0)
    SketchEntitiesEnumerator oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle(
                                                oTransGeom.CreatePoint2d(0, 0),
                                                oTransGeom.CreatePoint2d(4, 3));

    // Create a profile.
    Profile oProfile = oSketch.Profiles.AddForSolid(true, null, null);

    // Create a base extrusion 1cm thick.
    ExtrudeFeature oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent(
                                oProfile, 1, PartFeatureExtentDirectionEnum.kNegativeExtentDirection,
                                PartFeatureOperationEnum.kJoinOperation, null);

    // Get the top face of the extrusion to use for creating the new sketch.
    Face oFrontFace = oExtrude.StartFaces[1];

    // Create a new sketch on this face, but use the method that allows you to
    // control the orientation and orgin of the new sketch.
    oSketch = oCompDef.Sketches.AddWithOrientation(oFrontFace,
                    oCompDef.WorkAxes[1], true, true, oCompDef.WorkPoints[1], false);

    // Determine where in sketch space the point (0.5,0.5,0) is.
    Point2d oCorner;
    oCorner = oSketch.ModelToSketchSpace(oTransGeom.CreatePoint(0.5, 0.5, 0));

    // Create the interior 3cm x 2cm rectangle for the pocket.
    oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle(
                oCorner, oTransGeom.CreatePoint2d(oCorner.X + 3, oCorner.Y + 2));

    // Create a profile.
    oProfile = oSketch.Profiles.AddForSolid(true, null, null);

    // Create a pocket .25 cm deep.
    oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent(
                        oProfile, 0.25, PartFeatureExtentDirectionEnum.kNegativeExtentDirection,
                        PartFeatureOperationEnum.kCutOperation, null);

}
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.SetEndOfPart Method


PartFeature.SetRenderStyle Method

PartFeature.SetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

This method sets the render style to use for this object (feature, face, etc.). The used for an object can be specified in two ways. The object can inherit the RenderStyle defined for the part, or a RenderStyle can be explicitly assigned to the object.

Visual Basic
Sub SetRenderStyle(StyleSourceType As StyleSourceTypeEnum, ByRef RenderStyle As [optional] VARIANT)
Parameters
Parameters | Description
StyleSourceType | Input that specifies how the render style for the feature will be defined. This can be either kPartRenderStyle in the case where the feature will use the render style assigned to the part, and kOverrideRenderStyle where a render style will be explicitly assigned to the feature.
RenderStyle | Optional input object that is the render style to use for this feature. This argument only used in the case where the StyleSourceType is kOverrideRenderStyle. For other style source types, this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.SetRenderStyle Method


PartFeature.SetSuppressionCondition Method

PartFeature.SetSuppressionCondition Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets the suppression condition for the feature.

Visual Basic
Sub SetSuppressionCondition(Parameter As Parameter, ComparisonType As ComparisonTypeEnum, Expression As VARIANT)
Parameters
Parameters | Description
Parameter | Parameter object that specifies the parameter whose value is to be checked for feature suppression.
ComparisonType | ComparisonTypeEnum that specifies the type of comparison. Valid types are kEqualToComparison, kNotEqualToComparison, kLessThanComparison, kGreaterThanComparison, kLessThanOrEqualToComparison, kGreaterThanOrEqualToComparison.
Expression | Specifies the expression used for the comparison with the parameter value. This can either be a string, a value or a parameter object. If a value is input, the database units for the units defined by the parameter are used. For instance, if the parameter defines length units, the value is assumed to be in centimeters. If a string is input, the units can be specified as part of the string or it will default to the current units of the document. For instance, if the parameter defines length units, the current length units of the document are used.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.SetSuppressionCondition Method


PartFeature.SurfaceBody Method

PartFeature.SurfaceBody Method Available in Inventor Available in Server
Summary

Property that returns the associated with this object or feature.

Visual Basic
Sub SurfaceBody(Result As [out, retval] SurfaceBody*)
See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Methods > PartFeature.SurfaceBody Method


PartFeature Properties

PartFeature Properties
Summary

The properties of the PartFeature class are listed here.

Properties
Name | Description
Adaptive | Property that indicates whether the feature is adaptive or not. A value of True indicates it is adaptive.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ConsumeInputs | Gets and sets whether the inputs to this feature should be nested under this feature in the browser.
ExtendedName | This is ExtendedName, a member of class PartFeature.
Faces | Property that returns a collection that provides access to all of the faces of the feature. The Faces collection object will return the faces that still currently exist in the part. For example, if a face has been consumed by additional modeling operations it will not be returned.
FeatureDimensions | Property that returns the FeatureDimensions collection object.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsOwnedByFeature | Property that returns whether this object is owned by a feature. If True, the OwnedBy property returns the owning feature.
Name | Property that indicates the name of this object or instance.
OwnedBy | Property that returns the owning PartFeature object. This property returns Nothing if the IsOwnedByFeature property returns False.
Parameters | Property that returns all the parameters associated with the feature.
Parent | Property that returns the parent of the feature.
Participants | Property that returns the list of participants for an assembly feature. This list is empty for features in a part.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Shared | Gets and sets whether the feature is shared or not, applies only to surface features.
Suppressed | Property that indicates whether the feature is suppressed or not. A value of True indicates the feature is suppressed.
SurfaceBodies | Property that returns the bodies that this feature has created or modified.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties


PartFeature.Adaptive Property

PartFeature.Adaptive Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates whether the feature is adaptive or not. A value of True indicates it is adaptive.

Visual Basic
Property Adaptive() As VARIANT_BOOL
See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Adaptive Property


PartFeature.Application Property

PartFeature.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Application Property


PartFeature.AttributeSets Property

PartFeature.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.AttributeSets Property


PartFeature.ConsumeInputs Property

PartFeature.ConsumeInputs Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets whether the inputs to this feature should be nested under this feature in the browser.

Visual Basic
Property ConsumeInputs() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.ConsumeInputs Property


PartFeature.ExtendedName Property

PartFeature.ExtendedName Property
Summary

This is ExtendedName, a member of class PartFeature.

Visual Basic
Property ExtendedName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.ExtendedName Property


PartFeature.Faces Property

PartFeature.Faces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a collection that provides access to all of the faces of the feature. The Faces collection object will return the faces that still currently exist in the part. For example, if a face has been consumed by additional modeling operations it will not be returned.

Visual Basic
Property Faces() As Faces**
See Also

Create sheet metal face and flange features sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Faces Property


PartFeature.FeatureDimensions Property

PartFeature.FeatureDimensions Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the FeatureDimensions collection object.

Visual Basic
Property FeatureDimensions() As FeatureDimensions**
See Also

Query feature dimensions sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.FeatureDimensions Property


PartFeature.HealthStatus Property

PartFeature.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.HealthStatus Property


PartFeature.IsOwnedByFeature Property

PartFeature.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether this object is owned by a feature. If True, the OwnedBy property returns the owning feature.

Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.IsOwnedByFeature Property


PartFeature.Name Property

PartFeature.Name Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Name Property


PartFeature.OwnedBy Property

PartFeature.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the owning PartFeature object. This property returns Nothing if the IsOwnedByFeature property returns False.

Visual Basic
Property OwnedBy() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.OwnedBy Property


PartFeature.Parameters Property

PartFeature.Parameters Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns all the parameters associated with the feature.

Visual Basic
Property Parameters() As ParametersEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Parameters Property


PartFeature.Parent Property

PartFeature.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent of the feature.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Parent Property


PartFeature.Participants Property

PartFeature.Participants Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the list of participants for an assembly feature. This list is empty for features in a part.

Visual Basic
Property Participants() As ComponentOccurrencesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Participants Property


PartFeature.RangeBox Property

PartFeature.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.RangeBox Property


PartFeature.Shared Property

PartFeature.Shared Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets whether the feature is shared or not, applies only to surface features.

Visual Basic
Property Shared() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Shared Property


PartFeature.Suppressed Property

PartFeature.Suppressed Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates whether the feature is suppressed or not. A value of True indicates the feature is suppressed.

Visual Basic
Property Suppressed() As VARIANT_BOOL
See Also

Sheet Metal Feature Display sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Suppressed Property


PartFeature.SurfaceBodies Property

PartFeature.SurfaceBodies Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the bodies that this feature has created or modified.

Visual Basic
Property SurfaceBodies() As SurfaceBodies**
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.SurfaceBodies Property


PartFeature.Type Property

PartFeature.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
See Also

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeature Interface > PartFeature Properties > PartFeature.Type Property


PartFeatureExtent Interface

PartFeatureExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PartFeatureExtent object is the base class that defines the extent for certain part features--those that are profile-based.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::AngleExtent
    Inventor::CenteredWidthExtent
    Inventor::CutAcrossBendsExtent
    Inventor::DistanceExtent
    Inventor::DistanceHeightExtent
    Inventor::EdgeWidthExtent
    Inventor::FromToExtent
    Inventor::FromToWidthExtent
    Inventor::FullSweepExtent
    Inventor::LegacyDistanceHeightExtent
    Inventor::OffsetWidthExtent
    Inventor::PitchAndHeightCoilExtent
    Inventor::PitchAndRevolutionCoilExtent
    Inventor::RevolutionAndHeightCoilExtent
    Inventor::SpiralCoilExtent
    Inventor::ThroughAllExtent
    Inventor::ToExtent
    Inventor::ToHeightExtent
    Inventor::ToNextExtent
    Inventor::WidthOffsetWidthExtent
Visual Basic
Public Interface PartFeatureExtent
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CoilFeature.Extent

ContourFlangeDefinition.WidthExtent

CutDefinition.Extent

ExtrudeFeature.Extent

ExtrudeFeature.ExtentTwo

FlangeDefinition.HeightExtent

FlangeDefinition.WidthExtent

HemDefinition.WidthExtent

HoleFeature.Extent

RevolveFeature.Extent

RevolveFeature.ExtentTwo

You are here: Symbol Reference > Inventor Library > Objects > PartFeatureExtent Interface


PartFeatureExtent Properties

PartFeatureExtent Properties
Summary

The properties of the PartFeatureExtent class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent PartFeature of the definition.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartFeatureExtent Interface > PartFeatureExtent Properties


PartFeatureExtent.Application Property

PartFeatureExtent.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatureExtent Interface > PartFeatureExtent Properties > PartFeatureExtent.Application Property


PartFeatureExtent.Parent Property

PartFeatureExtent.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent PartFeature of the definition.

Visual Basic
Property Parent() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatureExtent Interface > PartFeatureExtent Properties > PartFeatureExtent.Parent Property


PartFeatureExtent.Type Property

PartFeatureExtent.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartFeatureExtent Interface > PartFeatureExtent Properties > PartFeatureExtent.Type Property


PartFeatures Interface

PartFeatures Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PartFeatures collection object. Presents the current view of objects and allows their creation.

Class Hierarchy
Inventor::PartFeatures
    Inventor::SheetMetalFeatures
Visual Basic
Public Interface PartFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartComponentDefinition.Features

See Also

Associative body copy sample

Transient surface body creation sample

Edit thread features sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface


PartFeatures Methods

PartFeatures Methods
Summary

The methods of the PartFeatures class are listed here.

Methods
Methods
Name | Description
CreatePath | Method that creates a path used to define the shape of several part features such as sweep, rectangular pattern, split, etc. All other 2D and 3D curves that are connected to the input curve are obtained and used to create a Path object. The new Path is returned.
CreateSpecifiedPath | Method that creates a path used to define the shape of several part features such as sweep, rectangular pattern, split, etc. The new path is returned. This method will fail if the input curves are not connected end-to-end.
Item | Property that returns the specified PartFeature object from the collection. It accesses all of the features regardless of their type. If you increment through the features in the collection they are returned in the same order as they appear in the feature browser.
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Methods


PartFeatures.CreatePath Method

PartFeatures.CreatePath Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that creates a path used to define the shape of several part features such as sweep, rectangular pattern, split, etc. All other 2D and 3D curves that are connected to the input curve are obtained and used to create a Path object. The new Path is returned.

Visual Basic
Sub CreatePath(SketchCurve As IDispatch, Result As [out, retval] Path*)
Parameters
Parameters | Description
SketchCurve | Input sketch (planar or 3D) entity. This can be any entity that is part of the desired path. All curves that are end point connected will be found and used to create the path.
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Methods > PartFeatures.CreatePath Method


PartFeatures.CreateSpecifiedPath Method

PartFeatures.CreateSpecifiedPath Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that creates a path used to define the shape of several part features such as sweep, rectangular pattern, split, etc. The new path is returned. This method will fail if the input curves are not connected end-to-end.

Visual Basic
Sub CreateSpecifiedPath(SketchCurves As ObjectCollection, Result As [out, retval] Path*)
Parameters
Parameters | Description
SketchCurves | Input (planar or 3D) sketch entities. These are entities that are part of the desired path. The input curves must form a contiguous set.
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Methods > PartFeatures.CreateSpecifiedPath Method


PartFeatures.Item Method

PartFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified PartFeature object from the collection. It accesses all of the features regardless of their type. If you increment through the features in the collection they are returned in the same order as they appear in the feature browser.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a String indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Methods > PartFeatures.Item Method


PartFeatures Properties

PartFeatures Properties
Summary

The properties of the PartFeatures class are listed here.

Methods
Methods
Name | Description
CoreCavityFeatures | Property that returns the CoreCavityFeatures collection object.
Properties
Name | Description
AliasFreeformFeatures | Returns the AliasFrreeformFeatures collection object.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
BendPartFeatures | Gets the collection object that besides listing out the subset of part features that are BendPartFeatures, allows the creations of BendPartFeatures.
BossFeatures | Gets the collection object that lists the subset of part features that are BossFeatures.
BoundaryPatchFeatures | Property that gets the collection object. Besides listing out the subset of part features that are BoundaryPatches, it allows the creation of new BoundaryPatches.
ChamferFeatures | Property that returns the ChamferFeatures collection object. This collection provides access to existing ChamferFeature objects and provides functionality to create new ChamferFeature objects.
CircularPatternFeatures | Property that returns the CircularPatternFeatures collection object. This collection provides access to existing CircularPatternFeature objects and provides functionality to create new CircularPatternFeature objects.
ClientFeatures | Property returning the client features collection object.
CoilFeatures | Property that returns the CoilFeatures collection object. This collection provides access to existing CoilFeature objects and provides functionality to create new CoilFeature objects.
CombineFeatures | Property that returns the CombineFeatures collection object.
Count | Property that returns the number of items in the collection.
DecalFeatures | Property that returns the DecalFeatures collection object. This collection provides access to existing DecalFeature objects.
DeleteFaceFeatures | Property that returns the DeleteFaceFeatures collection object. This collection provides access to existing DeleteFaceFeature objects.
EmbossFeatures | Property that returns the EmbossFeatures collection object. This collection provides access to existing EmbossFeature objects.
ExtendFeatures | Property that returns the ExtendFeatures collection object. This collection provides access to existing ExtendFeature objects and provides functionality to create new ExtendFeature objects.
ExtrudeFeatures | Property that returns the collection object. This collection provides access to existing ExtrudeFeature objects and provides functionality to create new ExtrudeFeature objects.
FaceDraftFeatures | Property that returns the FaceDraftFeatures collection object. This collection provides access to existing FaceDraftFeature objects.
FilletFeatures | Property that returns the FilletFeatures collection object. This collection provides access to existing FilletFeature objects and provides functionality to create new FilletFeature objects.
GrillFeatures | Gets the collection object that lists the subset of part features that are GrillFeatures.
HoleFeatures | Property that returns the HoleFeatures collection object. This collection provides access to existing HoleFeature objects and provides functionality to create new HoleFeature objects.
iFeatures | Property that returns the iFeatures collection object.
KnitFeatures | Property that returns the KnitFeatures collection object. This collection provides access to existing KnitFeature objects.
LipFeatures | Gets the collection object that lists the subset of part features that are LipFeatures.
LoftFeatures | Property that returns the LoftFeatures collection object. This collection provides access to existing LoftFeature objects and provides functionality to create new LoftFeature objects.
MirrorFeatures | Property that returns the MirrorFeatures collection object. This collection provides access to existing MirrorFeature objects and provides functionality to create new MirrorFeature objects.
MoveFaceFeatures | Property that returns the MoveFaceFeatures collection object.
MoveFeatures | Gets the collection object that besides listing out the subset of part features that are Moves, allows the creations of new Moves.
NonParametricBaseFeatures | Property that returns the NonParametericBaseFeatures collection object. This collection provides access to existing NonParametericBaseFeature objects and provides functionality to create new NonParametericBaseFeature objects.
RectangularPatternFeatures | Property that returns the RectangularPatternFeatures collection object. This collection provides access to existing RectangularPatternFeature objects and provides functionality to create new RectangularPatternFeature objects.
ReferenceFeatures | Property that returns the ReferenceFeatures collection object.
ReplaceFaceFeatures | Property that returns the ReplaceFaceFeatures collection object. This collection provides access to existing ReplaceFaceFeature objects.
RestFeatures | Gets the collection object that lists the subset of part features that are RestFeatures.
RevolveFeatures | Property that returns the RevolveFeatures collection object. This collection provides access to existing RevolveFeature objects and provides functionality to create new RevolveFeature objects.
RibFeatures | Property that returns the RibFeatures collection object. This collection provides access to existing RibFeature objects.
RuleFilletFeatures | Gets the collection object that lists the subset of part features that are RuleFilletFeatures.
SculptFeatures | Property that returns the SculptFeatures collection object. This collection provides access to existing SculptFeature objects and provides functionality to create new SculptFeature objects.
ShellFeatures | Property that returns the ShellFeatures collection object. This collection provides access to existing ShellFeature objects.
SnapFitFeatures | Gets the collection object that lists the subset of part features that are SnapFitFeatures.
SplitFeatures | Property that returns the SplitFeatures collection object. This collection provides access to existing SplitFeature objects.
SweepFeatures | Property that returns the SweepFeatures collection object. This collection provides access to existing SweepFeature objects and provides functionality to create new SweepFeature objects.
ThickenFeatures | Property that returns the ThickenFeatures collection object. This collection provides access to existing ThickenFeature objects.
ThreadFeatures | Property that returns the ThreadFeatures collection object. This collection provides access to existing ThreadFeature objects and provides functionality to create new ThreadFeature objects.
TrimFeatures | Property that returns the TrimFeatures collection object. This collection provides access to existing TrimFeature objects and provides functionality to create new TrimFeature objects.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties


PartFeatures.AliasFreeformFeatures Property

PartFeatures.AliasFreeformFeatures Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Returns the AliasFrreeformFeatures collection object.

Visual Basic
Property AliasFreeformFeatures() As AliasFreeformFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.AliasFreeformFeatures Property


PartFeatures.Application Property

PartFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.Application Property


PartFeatures.BendPartFeatures Property

PartFeatures.BendPartFeatures Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the collection object that besides listing out the subset of part features that are BendPartFeatures, allows the creations of BendPartFeatures.

Visual Basic
Property BendPartFeatures() As BendPartFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.BendPartFeatures Property


PartFeatures.BossFeatures Property

PartFeatures.BossFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that lists the subset of part features that are BossFeatures.

Visual Basic
Property BossFeatures() As BossFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.BossFeatures Property


PartFeatures.BoundaryPatchFeatures Property

PartFeatures.BoundaryPatchFeatures Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the collection object. Besides listing out the subset of part features that are BoundaryPatches, it allows the creation of new BoundaryPatches.

Visual Basic
Property BoundaryPatchFeatures() As BoundaryPatchFeatures**
See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.BoundaryPatchFeatures Property


PartFeatures.ChamferFeatures Property

PartFeatures.ChamferFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ChamferFeatures collection object. This collection provides access to existing ChamferFeature objects and provides functionality to create new ChamferFeature objects.

Visual Basic
Property ChamferFeatures() As ChamferFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ChamferFeatures Property


PartFeatures.CircularPatternFeatures Property

PartFeatures.CircularPatternFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the CircularPatternFeatures collection object. This collection provides access to existing CircularPatternFeature objects and provides functionality to create new CircularPatternFeature objects.

Visual Basic
Property CircularPatternFeatures() As CircularPatternFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.CircularPatternFeatures Property


PartFeatures.ClientFeatures Property

PartFeatures.ClientFeatures Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning the client features collection object.

Visual Basic
Property ClientFeatures() As ClientFeatures**
See Also

Remove client feature elements sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ClientFeatures Property


PartFeatures.CoilFeatures Property

PartFeatures.CoilFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the CoilFeatures collection object. This collection provides access to existing CoilFeature objects and provides functionality to create new CoilFeature objects.

Visual Basic
Property CoilFeatures() As CoilFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.CoilFeatures Property


PartFeatures.CombineFeatures Property

PartFeatures.CombineFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the CombineFeatures collection object.

Visual Basic
Property CombineFeatures() As CombineFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.CombineFeatures Property


PartFeatures.CoreCavityFeatures Method

PartFeatures.CoreCavityFeatures Method Introduced in Inventor 2011
Summary

Property that returns the CoreCavityFeatures collection object.

Visual Basic
Sub CoreCavityFeatures(Result As [out, retval] CoreCavityFeatures*)
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.CoreCavityFeatures Method


PartFeatures.Count Property

PartFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.Count Property


PartFeatures.DecalFeatures Property

PartFeatures.DecalFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the DecalFeatures collection object. This collection provides access to existing DecalFeature objects.

Visual Basic
Property DecalFeatures() As DecalFeatures**
See Also

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.DecalFeatures Property


PartFeatures.DeleteFaceFeatures Property

PartFeatures.DeleteFaceFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the DeleteFaceFeatures collection object. This collection provides access to existing DeleteFaceFeature objects.

Visual Basic
Property DeleteFaceFeatures() As DeleteFaceFeatures**
See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.DeleteFaceFeatures Property


PartFeatures.EmbossFeatures Property

PartFeatures.EmbossFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the EmbossFeatures collection object. This collection provides access to existing EmbossFeature objects.

Visual Basic
Property EmbossFeatures() As EmbossFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.EmbossFeatures Property


PartFeatures.ExtendFeatures Property

PartFeatures.ExtendFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ExtendFeatures collection object. This collection provides access to existing ExtendFeature objects and provides functionality to create new ExtendFeature objects.

Visual Basic
Property ExtendFeatures() As ExtendFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ExtendFeatures Property


PartFeatures.ExtrudeFeatures Property

PartFeatures.ExtrudeFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the collection object. This collection provides access to existing ExtrudeFeature objects and provides functionality to create new ExtrudeFeature objects.

Visual Basic
Property ExtrudeFeatures() As ExtrudeFeatures**
See Also

Thread Feature Create sample

Extrude Feature - Create Block with Pocket sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ExtrudeFeatures Property


PartFeatures.FaceDraftFeatures Property

PartFeatures.FaceDraftFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the FaceDraftFeatures collection object. This collection provides access to existing FaceDraftFeature objects.

Visual Basic
Property FaceDraftFeatures() As FaceDraftFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.FaceDraftFeatures Property


PartFeatures.FilletFeatures Property

PartFeatures.FilletFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the FilletFeatures collection object. This collection provides access to existing FilletFeature objects and provides functionality to create new FilletFeature objects.

Visual Basic
Property FilletFeatures() As FilletFeatures**
See Also

Fillet Feature (Complex) sample

Fillet Feature (All Rounds) sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.FilletFeatures Property


PartFeatures.GrillFeatures Property

PartFeatures.GrillFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that lists the subset of part features that are GrillFeatures.

Visual Basic
Property GrillFeatures() As GrillFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.GrillFeatures Property


PartFeatures.HoleFeatures Property

PartFeatures.HoleFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the HoleFeatures collection object. This collection provides access to existing HoleFeature objects and provides functionality to create new HoleFeature objects.

Visual Basic
Property HoleFeatures() As HoleFeatures**
See Also

Hole feature linear placement sample

Hole Feature - Through holes (RegularAndTapped) sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.HoleFeatures Property


PartFeatures.iFeatures Property

PartFeatures.iFeatures Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the iFeatures collection object.

Visual Basic
Property iFeatures() As iFeatures**
See Also

Changing row of table driven iFeature sample

Place table driven iFeature sample

Placementof a standard iFeature sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.iFeatures Property


PartFeatures.KnitFeatures Property

PartFeatures.KnitFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the KnitFeatures collection object. This collection provides access to existing KnitFeature objects.

Visual Basic
Property KnitFeatures() As KnitFeatures**
See Also

Adding a new stitch (knit) feature sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.KnitFeatures Property


PartFeatures.LipFeatures Property

PartFeatures.LipFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that lists the subset of part features that are LipFeatures.

Visual Basic
Property LipFeatures() As LipFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.LipFeatures Property


PartFeatures.LoftFeatures Property

PartFeatures.LoftFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the LoftFeatures collection object. This collection provides access to existing LoftFeature objects and provides functionality to create new LoftFeature objects.

Visual Basic
Property LoftFeatures() As LoftFeatures**
See Also

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.LoftFeatures Property


PartFeatures.MirrorFeatures Property

PartFeatures.MirrorFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the MirrorFeatures collection object. This collection provides access to existing MirrorFeature objects and provides functionality to create new MirrorFeature objects.

Visual Basic
Property MirrorFeatures() As MirrorFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.MirrorFeatures Property


PartFeatures.MoveFaceFeatures Property

PartFeatures.MoveFaceFeatures Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the MoveFaceFeatures collection object.

Visual Basic
Property MoveFaceFeatures() As MoveFaceFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.MoveFaceFeatures Property


PartFeatures.MoveFeatures Property

PartFeatures.MoveFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that besides listing out the subset of part features that are Moves, allows the creations of new Moves.

Visual Basic
Property MoveFeatures() As MoveFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.MoveFeatures Property


PartFeatures.NonParametricBaseFeatures Property

PartFeatures.NonParametricBaseFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the NonParametericBaseFeatures collection object. This collection provides access to existing NonParametericBaseFeature objects and provides functionality to create new NonParametericBaseFeature objects.

Visual Basic
Property NonParametricBaseFeatures() As NonParametricBaseFeatures**
See Also

Associative body copy sample

Transient surface body creation sample

Create primitive BRep sample

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.NonParametricBaseFeatures Property


PartFeatures.RectangularPatternFeatures Property

PartFeatures.RectangularPatternFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the RectangularPatternFeatures collection object. This collection provides access to existing RectangularPatternFeature objects and provides functionality to create new RectangularPatternFeature objects.

Visual Basic
Property RectangularPatternFeatures() As RectangularPatternFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.RectangularPatternFeatures Property


PartFeatures.ReferenceFeatures Property

PartFeatures.ReferenceFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceFeatures collection object.

Visual Basic
Property ReferenceFeatures() As ReferenceFeatures**
Remarks

This collection provides access to the features that are created when a part with surface and/or solid data is derived in. For legacy reasons, this will also contain some information related to iFeatures and punch features. This information should be ignored. iFeatures are now available through the iFeatures collection and punch tool features are accessed through the PunchToolFeatures collection.

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ReferenceFeatures Property


PartFeatures.ReplaceFaceFeatures Property

PartFeatures.ReplaceFaceFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ReplaceFaceFeatures collection object. This collection provides access to existing ReplaceFaceFeature objects.

Visual Basic
Property ReplaceFaceFeatures() As ReplaceFaceFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ReplaceFaceFeatures Property


PartFeatures.RestFeatures Property

PartFeatures.RestFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that lists the subset of part features that are RestFeatures.

Visual Basic
Property RestFeatures() As RestFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.RestFeatures Property


PartFeatures.RevolveFeatures Property

PartFeatures.RevolveFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the RevolveFeatures collection object. This collection provides access to existing RevolveFeature objects and provides functionality to create new RevolveFeature objects.

Visual Basic
Property RevolveFeatures() As RevolveFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.RevolveFeatures Property


PartFeatures.RibFeatures Property

PartFeatures.RibFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the RibFeatures collection object. This collection provides access to existing RibFeature objects.

Visual Basic
Property RibFeatures() As RibFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.RibFeatures Property


PartFeatures.RuleFilletFeatures Property

PartFeatures.RuleFilletFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that lists the subset of part features that are RuleFilletFeatures.

Visual Basic
Property RuleFilletFeatures() As RuleFilletFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.RuleFilletFeatures Property


PartFeatures.SculptFeatures Property

PartFeatures.SculptFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the SculptFeatures collection object. This collection provides access to existing SculptFeature objects and provides functionality to create new SculptFeature objects.

Visual Basic
Property SculptFeatures() As SculptFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.SculptFeatures Property


PartFeatures.ShellFeatures Property

PartFeatures.ShellFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ShellFeatures collection object. This collection provides access to existing ShellFeature objects.

Visual Basic
Property ShellFeatures() As ShellFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ShellFeatures Property


PartFeatures.SnapFitFeatures Property

PartFeatures.SnapFitFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection object that lists the subset of part features that are SnapFitFeatures.

Visual Basic
Property SnapFitFeatures() As SnapFitFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.SnapFitFeatures Property


PartFeatures.SplitFeatures Property

PartFeatures.SplitFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the SplitFeatures collection object. This collection provides access to existing SplitFeature objects.

Visual Basic
Property SplitFeatures() As SplitFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.SplitFeatures Property


PartFeatures.SweepFeatures Property

PartFeatures.SweepFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the SweepFeatures collection object. This collection provides access to existing SweepFeature objects and provides functionality to create new SweepFeature objects.

Visual Basic
Property SweepFeatures() As SweepFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.SweepFeatures Property


PartFeatures.ThickenFeatures Property

PartFeatures.ThickenFeatures Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ThickenFeatures collection object. This collection provides access to existing ThickenFeature objects.

Visual Basic
Property ThickenFeatures() As ThickenFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ThickenFeatures Property


PartFeatures.ThreadFeatures Property

PartFeatures.ThreadFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ThreadFeatures collection object. This collection provides access to existing ThreadFeature objects and provides functionality to create new ThreadFeature objects.

Visual Basic
Property ThreadFeatures() As ThreadFeatures**
See Also

Edit thread features sample

Thread Feature Create sample

You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.ThreadFeatures Property


PartFeatures.TrimFeatures Property

PartFeatures.TrimFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the TrimFeatures collection object. This collection provides access to existing TrimFeature objects and provides functionality to create new TrimFeature objects.

Visual Basic
Property TrimFeatures() As TrimFeatures**
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.TrimFeatures Property


PartFeatures.Type Property

PartFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartFeatures Interface > PartFeatures Properties > PartFeatures.Type Property


PartFeaturesEnumerator Interface

PartFeaturesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PartFeaturesEnumerator object. Presents a snapshot of the set of objects.

Class Hierarchy
Inventor::PartFeaturesEnumerator
Visual Basic
Public Interface PartFeaturesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceBody.AffectedByFeatures

You are here: Symbol Reference > Inventor Library > Objects > PartFeaturesEnumerator Interface


PartFeaturesEnumerator Methods

PartFeaturesEnumerator Methods
Summary

The methods of the PartFeaturesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > PartFeaturesEnumerator Interface > PartFeaturesEnumerator Methods


PartFeaturesEnumerator.Item Method

PartFeaturesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the PartFeature to return.
You are here: Symbol Reference > Inventor Library > Objects > PartFeaturesEnumerator Interface > PartFeaturesEnumerator Methods > PartFeaturesEnumerator.Item Method


PartFeaturesEnumerator Properties

PartFeaturesEnumerator Properties
Summary

The properties of the PartFeaturesEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartFeaturesEnumerator Interface > PartFeaturesEnumerator Properties


PartFeaturesEnumerator.Count Property

PartFeaturesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PartFeaturesEnumerator Interface > PartFeaturesEnumerator Properties > PartFeaturesEnumerator.Count Property


PartFeaturesEnumerator.Type Property

PartFeaturesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartFeaturesEnumerator Interface > PartFeaturesEnumerator Properties > PartFeaturesEnumerator.Type Property


PartOptions Interface

PartOptions Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PartOptions object provides access to properties that provide read and write access of the part related application options. This is somewhat equivalent to the Part tab of the Application Options dialog.

Class Hierarchy
Inventor::PartOptions
Visual Basic
Public Interface PartOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.PartOptions

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface


PartOptions Properties

PartOptions Properties
Summary

The properties of the PartOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutoConsumeWorkAndSurfaceFeatures | Property that enables or disables automatically consuming work and surface features when they are used as inputs for creating other features.
AutoHideInLineWorkFeatures | Property that enables or disables automatically hiding a work feature when it is consumed by another work feature. A value of True enables automatic hiding.
DefaultDesignView | Property that gets and sets the default design view representation to use when opening part documents.
DefaultDesignViewIsAssociative | Property that gets and sets whether the default design view representation is associative.
DimensionConstraintsRelaxation | Property that gets and sets the preference for relaxing dimension constraints during 3D grip edit.
DisplayExtendedName | This is DisplayExtendedName, a member of class PartOptions.
DisplayGripsOnSelection | Property that enables or disables display of glyphs for 3D grips when faces are selected.
EditBaseSolidsUsingFusion | Property that gets and sets whether command to edit base solids in parts launches Inventor Fusion or the legacy Solid Edit environment. This property cannot be set to True if Inventor Fusion is not installed.
Enable3DGrips | Enables/disables access to 3D grips.
GeometricConstraintsBreakage | Property that gets and sets the preference for breaking geometric constraints during 3D grip edit.
OpaqueConstructionSurfaces | Property that specifies whether construction surfaces are displayed opaque or translucent when they are initially created. The display of existing construction surfaces is not affected by the value of this property. A value of True indicates that construction surfaces will be created with an opaque display.
SketchCreationOnNewPart | Property that gets and sets the preference for creating a sketch when a new part file is created. The valid options are kNoNewSketchCreation, kXYPlaneSketchCreation, kYZPlaneSketchCreation and kXZPlaneSketchCreation.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties


PartOptions.Application Property

PartOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.Application Property


PartOptions.AutoConsumeWorkAndSurfaceFeatures Property

PartOptions.AutoConsumeWorkAndSurfaceFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables automatically consuming work and surface features when they are used as inputs for creating other features.

Visual Basic
Property AutoConsumeWorkAndSurfaceFeatures() As VARIANT_BOOL
Remarks

In the browser, the consumed work and surface features will be nested under the feature that consumes them.

A value of True enables automatic consumption of work and surface features.

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.AutoConsumeWorkAndSurfaceFeatures Property


PartOptions.AutoHideInLineWorkFeatures Property

PartOptions.AutoHideInLineWorkFeatures Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables automatically hiding a work feature when it is consumed by another work feature. A value of True enables automatic hiding.

Visual Basic
Property AutoHideInLineWorkFeatures() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.AutoHideInLineWorkFeatures Property


PartOptions.DefaultDesignView Property

PartOptions.DefaultDesignView Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the default design view representation to use when opening part documents.

Visual Basic
Property DefaultDesignView() As DesignViewTypeEnum
Remarks

The valid options are kAllVisibleDesignViewType, kLastActiveDesignViewType, kMasterDesignViewType and kNothingVisibleDesignViewType.

The other values kPublicDesignViewType and kTransientDesignViewType are only used to indicate the type of design view representation. They are not valid values to specify the default design view representation and therefore they are not valid values for this property.

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.DefaultDesignView Property


PartOptions.DefaultDesignViewIsAssociative Property

PartOptions.DefaultDesignViewIsAssociative Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the default design view representation is associative.

Visual Basic
Property DefaultDesignViewIsAssociative() As VARIANT_BOOL
Remarks

This property is only applicable if the default design view is ‘Last Active’ as indicated by the DefaultDesignView property returning kLastActiveDesignViewType. If the default design view is any other value, then this property is not applicable and setting it will fail.

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.DefaultDesignViewIsAssociative Property


PartOptions.DimensionConstraintsRelaxation Property

PartOptions.DimensionConstraintsRelaxation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the preference for relaxing dimension constraints during 3D grip edit.

Visual Basic
Property DimensionConstraintsRelaxation() As DimensionConstraintsRelaxationEnum
Remarks

The valid options are kNeverRelaxDimensionConstraints, kNoEquationRelaxDimensionConstraints, kAlwaysRelaxDimensionConstraints and kPromptRelaxDimensionConstraints.

A value can be specified for this property only if the Enable3DGrips property is True. If the Enable3DGrips property is False, then specifying a value for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.DimensionConstraintsRelaxation Property


PartOptions.DisplayExtendedName Property

PartOptions.DisplayExtendedName Property
Summary

This is DisplayExtendedName, a member of class PartOptions.

Visual Basic
Property DisplayExtendedName() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.DisplayExtendedName Property


PartOptions.DisplayGripsOnSelection Property

PartOptions.DisplayGripsOnSelection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that enables or disables display of glyphs for 3D grips when faces are selected.

Visual Basic
Property DisplayGripsOnSelection() As VARIANT_BOOL
Remarks

A value of True specifies that glyphs for 3D grips should be displayed when faces are selected. A value of False specifies that the display of glyphs for 3D grips should be suppressed.

A value can be specified for this property only if the Enable3DGrips property is True. If the Enable3DGrips property is False, then specifying a value for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.DisplayGripsOnSelection Property


PartOptions.EditBaseSolidsUsingFusion Property

PartOptions.EditBaseSolidsUsingFusion Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether command to edit base solids in parts launches Inventor Fusion or the legacy Solid Edit environment. This property cannot be set to True if Inventor Fusion is not installed.

Visual Basic
Property EditBaseSolidsUsingFusion() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.EditBaseSolidsUsingFusion Property


PartOptions.Enable3DGrips Property

PartOptions.Enable3DGrips Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Enables/disables access to 3D grips.

Visual Basic
Property Enable3DGrips() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.Enable3DGrips Property


PartOptions.GeometricConstraintsBreakage Property

PartOptions.GeometricConstraintsBreakage Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the preference for breaking geometric constraints during 3D grip edit.

Visual Basic
Property GeometricConstraintsBreakage() As GeometricConstraintsBreakageEnum
Remarks

The valid options are kNeverBreakGeometricConstraints, kAlwaysBreakGeometricConstraints and kPromptBreakGeometricConstraints.

A value can be specified for this property only if the Enable3DGrips property is True. If the Enable3DGrips property is False, then specifying a value for this property will fail.

You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.GeometricConstraintsBreakage Property


PartOptions.OpaqueConstructionSurfaces Property

PartOptions.OpaqueConstructionSurfaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether construction surfaces are displayed opaque or translucent when they are initially created. The display of existing construction surfaces is not affected by the value of this property. A value of True indicates that construction surfaces will be created with an opaque display.

Visual Basic
Property OpaqueConstructionSurfaces() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.OpaqueConstructionSurfaces Property


PartOptions.SketchCreationOnNewPart Property

PartOptions.SketchCreationOnNewPart Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the preference for creating a sketch when a new part file is created. The valid options are kNoNewSketchCreation, kXYPlaneSketchCreation, kYZPlaneSketchCreation and kXZPlaneSketchCreation.

Visual Basic
Property SketchCreationOnNewPart() As SketchCreationOnNewPartEnum
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.SketchCreationOnNewPart Property


PartOptions.Type Property

PartOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartOptions Interface > PartOptions Properties > PartOptions.Type Property


PartsList Interface

PartsList Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsList object represents a parts list in a drawing sheet.

Class Hierarchy
Inventor::PartsList
Visual Basic
Public Interface PartsList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartsList.CopyTo

PartsListCell.Parent

PartsListColumn.Parent

PartsListRow.Parent

PartsLists.Add

PartsLists.Item

See Also

Creating a parts list sample

Example 1

"Parts List Query Example "

This sample illustrates querying the contents of the parts list. To run this sample have a sheet active that contains a parts list.

Public Sub PartListQuery()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the first parts list on the active sheet.
    ' This assumes that a parts list is on the active sheet.
    Dim oPartList As PartsList
    Set oPartList = oDrawDoc.ActiveSheet.PartsLists.Item(1)

    ' Iterate through the contents of the parts list.
    Dim i As Long
    For i = 1 To oPartList.PartsListRows.Count
        ' Get the current row.
        Dim oRow As PartsListRow
        Set oRow = oPartList.PartsListRows.Item(i)

        ' Iterate through each column in the row.
        Dim j As Long
        For j = 1 To oPartList.PartsListColumns.Count
            ' Get the current cell.
            Dim oCell As PartsListCell
            Set oCell = oRow.Item(j)

            ' Display the value of the current cell.
            Debug.Print "Row: " & i & ", Column: " & oPartList.PartsListColumns.Item(j).Title & " = "; oCell.Value
        Next
    Next
End Sub
Example 2

"Parts List Edit Example "

This sample illustrates editing the contents of the parts list. To run this sample have a sheet active that contains a parts list.

Public Sub PartListEdit()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the first parts list on the active sheet.
    ' This assumes that a parts list is on the active sheet.
    Dim oPartList As PartsList
    Set oPartList = oDrawDoc.ActiveSheet.PartsLists.Item(1)

    ' Iterate through the contents of the parts list.
    Dim i As Long
    For i = 1 To oPartList.PartsListRows.Count
        ' Get the current row.
        Dim oRow As PartsListRow
        Set oRow = oPartList.PartsListRows.Item(i)

        ' Iterate through each column in the row.
        Dim j As Long
        For j = 1 To oPartList.PartsListColumns.Count
            ' Get the current cell.
            Dim oCell As PartsListCell
            Set oCell = oRow.Item(j)

            ' Check that the column isn't the quantity column.
            If oPartList.PartsListColumns.Item(j).Title  "QTY" Then
                ' Change the current value in the part list.
                oCell.Value = i & "," & j
            End If
        Next
    Next

    ' This changes a specific column by name.
    Dim ItemNumber As Long
    ItemNumber = oPartList.PartsListRows.Count
    For i = 1 To oPartList.PartsListRows.Count
        Set oCell = oPartList.PartsListRows.Item(i).Item("ITEM")
        oCell.Value = ItemNumber
        ItemNumber = ItemNumber - 1
    Next
End Sub
Example 3

See PartsLists::Add for example "Creating a parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface


PartsList Methods

PartsList Methods
Summary

The methods of the PartsList class are listed here.

Methods
Methods
Name | Description
CopyTo | Method that copies the parts list to another sheet.
Delete | Method that deletes this PartsList.
Export | Method that saves the parts list to an external file.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Renumber | Method that renumbers all rows in the parts list.
SaveItemOverridesToBOM | Saves any overrides to the item values in the balloon to the model BOM.
Sort | Method that changes the sort order of items in the parts list.
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods


PartsList.CopyTo Method

PartsList.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that copies the parts list to another sheet.

Visual Basic
Sub CopyTo(TargetSheet As Sheet, Result As [out, retval] PartsList*)
Parameters
Parameters | Description
TargetSheet | Input Sheet object that specifies the sheet to copy the parts list to.
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.CopyTo Method


PartsList.Delete Method

PartsList.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes this PartsList.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.Delete Method


PartsList.Export Method

PartsList.Export Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that saves the parts list to an external file.

Visual Basic
Sub Export(FileName As String, FileFormat As PartsListFileFormatEnum, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
FileName | Input string that specifies the file name to export the parts list to.
FileFormat | Input that specifies the file format to save to.
Options | Optional input String that specifies the 'Table Name' for kMicrosoftAccess and kMicrosoftExcel file formats. (LEGACY SUPPORT). Optional input NameValueMap object that specifies additional options for export. See Remarks for valid inputs.
Remarks

Valid inputs for Options parameter:

Name | Value Type | Valid for export formats
TableName | String | kMicrosoftExcel, kMicrosoftAccess
ExportedColumns | String containing semicolon separated column titles | All
IncludeTitle | Boolean | kMicrosoftExcel, kTextFileCommaDelimited, kTextFileTabDelimited, kUnicodeTextFileCommaDelimited, kUnicodeTextFileTabDelimited
StartingCell | String | kMicrosoftExcel
Template | String | kMicrosoftExcel
AutoFitColumnWidth | Boolean | kMicrosoftExcel
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.Export Method


PartsList.GetReferenceKey Method

PartsList.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.GetReferenceKey Method


PartsList.Renumber Method

PartsList.Renumber Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that renumbers all rows in the parts list.

Visual Basic
Sub Renumber()
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.Renumber Method


PartsList.SaveItemOverridesToBOM Method

PartsList.SaveItemOverridesToBOM Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Saves any overrides to the item values in the balloon to the model BOM.

Visual Basic
Sub SaveItemOverridesToBOM()
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.SaveItemOverridesToBOM Method


PartsList.Sort Method

PartsList.Sort Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that changes the sort order of items in the parts list.

Visual Basic
Sub Sort(PrimaryColumnTitle As String, ByRef PrimaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef SecondaryColumnTitle As [defaultvalue("")] BSTR, ByRef SecondaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef TertiaryColumnTitle As [defaultvalue("")] BSTR, ByRef TertiaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
PrimaryColumnTitle | Input string that specifies the primary column to use for the sorting. If the name of a non-existing column is provided, an error occurs.
PrimaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
SecondaryColumnTitle | Optional input string that specifies the secondary column to use for the sorting. If the name of a non-existing column or the primary column is provided, an error occurs.
SecondaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
TertiaryColumnTitle | Optional input string that specifies the tertiary column to use for the sorting. If the name of a non-existing column, the primary column or the secondary column is provided, an error occurs.
TertiaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Methods > PartsList.Sort Method


PartsList Properties

PartsList Properties
Summary

The properties of the PartsList class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
DataTextStyle | Property that gets and sets the text style used for the contents of the parts list.
HeadingPlacement | Property that gets and sets the location of the heading. Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
HideZeroQuantityRows | Property that gets and sets whether to hide rows of zero quantity. Defaults to True. This property only applies if the parts list references an iAssembly component and fails in other situations.
Layer | Property that gets and sets the layer associated with this object.
Level | Property that returns the type of numbering for the parts list. Possible values are kFirstLevelComponents and kPartsOnly.
MaximumRows | Property that gets and sets the maximum number of rows per section. Setting this property automatically toggles the WrapAutomatically property to True.
MembersToInclude | Property that gets and sets the names of the iPart/iAssembly members to include as columns in the parts list. This property only applies if the parts list references an iPart or an iAssembly component. The property cannot be set to an empty array.
NumberingScheme | Property that returns the numbering scheme used for a 'parts only' parts list. The property returns an error if this is not a 'parts only' parts list. Possible return values are kNumericNumbering, kLowercaseAlphaNumbering and kUppercaseAlphaNumbering.
NumberOfSections | Property that gets and sets the number of columns to wrap. Setting this property automatically toggles the WrapAutomatically property to True.
Parent | Property that gets the parent object from whom this object can logically be reached.
PartsListColumns | Gets the PartsListColumns collection object for this parts list table.
PartsListRows | Gets the PartsListRows collection object for this parts list table.
Position | Property that gets and sets the position of the parts list on the Sheet.
RangeBox | Property that returns the extents of the parts list in sheet space.
ReferencedDocumentDescriptor | Property that gets the document referenced by this parts list.
Rotation | Property that gets and sets the absolute rotation angle of the parts list in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, 'pi/2, 'pi, and '1.5pi.
RowGap | Property that returns the row gap. This value is obtained from the parts list style.
RowLineSpacing | Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.
ShowTitle | Property that specifies the whether to show the title of the parts list.
Style | Property that gets and sets the associated PartsListStyle object.
TableDirection | Property that gets and sets the direction of the table based on the Item numbers. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.
Title | Property that gets and sets the title of the parts list heading.
TitleTextStyle | Property that gets and sets the text style used for the title of the parts list.
Type | Property returning an enum indicating this object's type.
WrapAutomatically | Property that gets and sets whether to split the table equally. If set to True, the parts list table is split equally.
WrapLeft | Property that gets and sets whether the sections of the parts list are moved to the left or right when the number of rows increase. A value of True indicates that sections are moved to the left.
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties


PartsList.Application Property

PartsList.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Application Property


PartsList.AttributeSets Property

PartsList.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.AttributeSets Property


PartsList.ColumnHeaderTextStyle Property

PartsList.ColumnHeaderTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.ColumnHeaderTextStyle Property


PartsList.DataTextStyle Property

PartsList.DataTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the contents of the parts list.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.DataTextStyle Property


PartsList.HeadingPlacement Property

PartsList.HeadingPlacement Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the location of the heading. Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.HeadingPlacement Property


PartsList.HideZeroQuantityRows Property

PartsList.HideZeroQuantityRows Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether to hide rows of zero quantity. Defaults to True. This property only applies if the parts list references an iAssembly component and fails in other situations.

Visual Basic
Property HideZeroQuantityRows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.HideZeroQuantityRows Property


PartsList.Layer Property

PartsList.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Layer Property


PartsList.Level Property

PartsList.Level Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the type of numbering for the parts list. Possible values are kFirstLevelComponents and kPartsOnly.

Visual Basic
Property Level() As PartsListLevelEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Level Property


PartsList.MaximumRows Property

PartsList.MaximumRows Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the maximum number of rows per section. Setting this property automatically toggles the WrapAutomatically property to True.

Visual Basic
Property MaximumRows() As long
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.MaximumRows Property


PartsList.MembersToInclude Property

PartsList.MembersToInclude Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the names of the iPart/iAssembly members to include as columns in the parts list. This property only applies if the parts list references an iPart or an iAssembly component. The property cannot be set to an empty array.

Visual Basic
Property MembersToInclude() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.MembersToInclude Property


PartsList.NumberingScheme Property

PartsList.NumberingScheme Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the numbering scheme used for a 'parts only' parts list. The property returns an error if this is not a 'parts only' parts list. Possible return values are kNumericNumbering, kLowercaseAlphaNumbering and kUppercaseAlphaNumbering.

Visual Basic
Property NumberingScheme() As NumberingSchemeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.NumberingScheme Property


PartsList.NumberOfSections Property

PartsList.NumberOfSections Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the number of columns to wrap. Setting this property automatically toggles the WrapAutomatically property to True.

Visual Basic
Property NumberOfSections() As long
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.NumberOfSections Property


PartsList.Parent Property

PartsList.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Parent Property


PartsList.PartsListColumns Property

PartsList.PartsListColumns Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets the PartsListColumns collection object for this parts list table.

Visual Basic
Property PartsListColumns() As PartsListColumns**
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.PartsListColumns Property


PartsList.PartsListRows Property

PartsList.PartsListRows Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets the PartsListRows collection object for this parts list table.

Visual Basic
Property PartsListRows() As PartsListRows**
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.PartsListRows Property


PartsList.Position Property

PartsList.Position Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the position of the parts list on the Sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Position Property


PartsList.RangeBox Property

PartsList.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the extents of the parts list in sheet space.

Visual Basic
Property RangeBox() As Box2d **
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.RangeBox Property


PartsList.ReferencedDocumentDescriptor Property

PartsList.ReferencedDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets the document referenced by this parts list.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.ReferencedDocumentDescriptor Property


PartsList.Rotation Property

PartsList.Rotation Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the absolute rotation angle of the parts list in radians. The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, 'pi/2, 'pi, and '1.5pi.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Rotation Property


PartsList.RowGap Property

PartsList.RowGap Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the row gap. This value is obtained from the parts list style.

Visual Basic
Property RowGap() As double*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.RowGap Property


PartsList.RowLineSpacing Property

PartsList.RowLineSpacing Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.

Visual Basic
Property RowLineSpacing() As LineSpacingEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.RowLineSpacing Property


PartsList.ShowTitle Property

PartsList.ShowTitle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the whether to show the title of the parts list.

Visual Basic
Property ShowTitle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.ShowTitle Property


PartsList.Style Property

PartsList.Style Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the associated PartsListStyle object.

Visual Basic
Property Style() As PartsListStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Style Property


PartsList.TableDirection Property

PartsList.TableDirection Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the direction of the table based on the Item numbers. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.

Visual Basic
Property TableDirection() As TableDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.TableDirection Property


PartsList.Title Property

PartsList.Title Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the title of the parts list heading.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Title Property


PartsList.TitleTextStyle Property

PartsList.TitleTextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used for the title of the parts list.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.TitleTextStyle Property


PartsList.Type Property

PartsList.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.Type Property


PartsList.WrapAutomatically Property

PartsList.WrapAutomatically Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether to split the table equally. If set to True, the parts list table is split equally.

Visual Basic
Property WrapAutomatically() As VARIANT_BOOL
Remarks

The PartsList.WrapAutomatically property indicates whether either of the two properties, MaximumRows or NumberOfSections is set. If WrapAutomatically returns False, both properties should be ignored. If True, one of them returns a failure.

The NumberOfSections and MaximumRows properties are mutually exclusive - only one or the other has any meaning.

You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.WrapAutomatically Property


PartsList.WrapLeft Property

PartsList.WrapLeft Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether the sections of the parts list are moved to the left or right when the number of rows increase. A value of True indicates that sections are moved to the left.

Visual Basic
Property WrapLeft() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartsList Interface > PartsList Properties > PartsList.WrapLeft Property


PartsListCell Interface

PartsListCell Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsListCell object represents an individual cell in the parts list table.

Class Hierarchy
Inventor::PartsListCell
Visual Basic
Public Interface PartsListCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartsListRow.Item

See Also

Parts List Edit sample

Parts List Query sample

Example

See PartsList for example "Querying and editing the parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface


PartsListCell Methods

PartsListCell Methods
Summary

The methods of the PartsListCell class are listed here.

Methods
Methods
Name | Description
Static | Property that specifies the whether or not the contents of this cell are static. The contents of a static cell are not updated when the parts list is updated. Also, when the value of a cell is overridden, the cell is marked as static.
Update | Method that updates the parts list cell to reflect the current property values of the components.
UpToDate | Method that checks the values in the parts list cell against the current property values for the components and returns False if the values are not the same.
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Methods


PartsListCell.Static Method

PartsListCell.Static Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that specifies the whether or not the contents of this cell are static. The contents of a static cell are not updated when the parts list is updated. Also, when the value of a cell is overridden, the cell is marked as static.

Visual Basic
Sub Static(Value As VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Methods > PartsListCell.Static Method


PartsListCell.Update Method

PartsListCell.Update Method Available in Inventor Available in Server
Summary

Method that updates the parts list cell to reflect the current property values of the components.

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Methods > PartsListCell.Update Method


PartsListCell.UpToDate Method

PartsListCell.UpToDate Method Available in Inventor Available in Server
Summary

Method that checks the values in the parts list cell against the current property values for the components and returns False if the values are not the same.

Visual Basic
Sub UpToDate(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Methods > PartsListCell.UpToDate Method


PartsListCell Properties

PartsListCell Properties
Summary

The properties of the PartsListCell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that gets the parent object from whom this object can logically be reached.
Static | Property that specifies the whether or not the contents of this cell are static. The contents of a static cell are not updated when the parts list is updated. Also, when the value of a cell is overridden, the cell is marked as static.
Type | Property returning an enum indicating this object's type.
Value | Property that gets and sets the value of the cell.
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Properties


PartsListCell.Application Property

PartsListCell.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Properties > PartsListCell.Application Property


PartsListCell.Parent Property

PartsListCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As PartsList**
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Properties > PartsListCell.Parent Property


PartsListCell.Static Property

PartsListCell.Static Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that specifies the whether or not the contents of this cell are static. The contents of a static cell are not updated when the parts list is updated. Also, when the value of a cell is overridden, the cell is marked as static.

Visual Basic
Property Static() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Properties > PartsListCell.Static Property


PartsListCell.Type Property

PartsListCell.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Properties > PartsListCell.Type Property


PartsListCell.Value Property

PartsListCell.Value Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the value of the cell.

Visual Basic
Property Value() As String
You are here: Symbol Reference > Inventor Library > Objects > PartsListCell Interface > PartsListCell Properties > PartsListCell.Value Property


PartsListColumn Interface

PartsListColumn Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsListColumn object represents a column in a parts list table.

Class Hierarchy
Inventor::PartsListColumn
Visual Basic
Public Interface PartsListColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartsListColumns.Add

PartsListColumns.Item

Example

See PartsList for example "Querying and editing the parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface


PartsListColumn Methods

PartsListColumn Methods
Summary

The methods of the PartsListColumn class are listed here.

Methods
Methods
Name | Description
GetFilePropertyId | Method that returns the id of the property associated with the column. This method will return an error if the PropertyType property does not return a value of kFilePropertyType.
Remove | Method that removes this column from the parts list.
Reposition | Method that repositions the column within the parts list.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Methods


PartsListColumn.GetFilePropertyId Method

PartsListColumn.GetFilePropertyId Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the id of the property associated with the column. This method will return an error if the PropertyType property does not return a value of kFilePropertyType.

Visual Basic
Sub GetFilePropertyId(ByRef PropertySetId As String, ByRef PropId As long)
Parameters
Parameters | Description
PropertySetId | Returned String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set.
PropId | Returned Long that specifies the property id. This value is unique within the specified property set.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Methods > PartsListColumn.GetFilePropertyId Method


PartsListColumn.Remove Method

PartsListColumn.Remove Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that removes this column from the parts list.

Visual Basic
Sub Remove()
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Methods > PartsListColumn.Remove Method


PartsListColumn.Reposition Method

PartsListColumn.Reposition Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that repositions the column within the parts list.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing column next to which the column will be inserted. The valid range of values is 0 to the number of existing columns in the table. The position remains unchanged if the index of the column being moved is specified. A value of 0 will put the column at the end. If not specified, a default value of 0 is used, indicating that the column will be moved to the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used indicating that the column will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Methods > PartsListColumn.Reposition Method


PartsListColumn Properties

PartsListColumn Properties
Summary

The properties of the PartsListColumn class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CustomPropertyName | Property that returns the name of the custom property associated with this object. This method will return an error if the PropertyType property does not return a value of kCustomPropertyType.
Parent | Property that gets the parent object from whom this object can logically be reached.
PropertyType | Property that returns the property type associated with this column. If this property returns kFilePropertyType, the GetFilePropertyId method returns the identity of the file property. If this property returns kCustomPropertyType, use the CustomPropertyName property to get the name of the custom property.
Title | Property that gets and sets the title of the column header.
TitleHorizontalJustification | Property that gets and sets the justification of the column title.
Type | Property returning an enum indicating this object's type.
ValueHorizontalJustification | Property that gets and sets the justification of the values in the column.
Width | Property that gets and sets the width of the column.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties


PartsListColumn.Application Property

PartsListColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.Application Property


PartsListColumn.CustomPropertyName Property

PartsListColumn.CustomPropertyName Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the name of the custom property associated with this object. This method will return an error if the PropertyType property does not return a value of kCustomPropertyType.

Visual Basic
Property CustomPropertyName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.CustomPropertyName Property


PartsListColumn.Parent Property

PartsListColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As PartsList**
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.Parent Property


PartsListColumn.PropertyType Property

PartsListColumn.PropertyType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the property type associated with this column. If this property returns kFilePropertyType, the GetFilePropertyId method returns the identity of the file property. If this property returns kCustomPropertyType, use the CustomPropertyName property to get the name of the custom property.

Visual Basic
Property PropertyType() As PropertyTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.PropertyType Property


PartsListColumn.Title Property

PartsListColumn.Title Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the title of the column header.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.Title Property


PartsListColumn.TitleHorizontalJustification Property

PartsListColumn.TitleHorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the justification of the column title.

Visual Basic
Property TitleHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.TitleHorizontalJustification Property


PartsListColumn.Type Property

PartsListColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.Type Property


PartsListColumn.ValueHorizontalJustification Property

PartsListColumn.ValueHorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the justification of the values in the column.

Visual Basic
Property ValueHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.ValueHorizontalJustification Property


PartsListColumn.Width Property

PartsListColumn.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the width of the column.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumn Interface > PartsListColumn Properties > PartsListColumn.Width Property


PartsListColumns Interface

PartsListColumns Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsListColumns collection object provides access to all existing objects in the parts list.

Class Hierarchy
Inventor::PartsListColumns
Visual Basic
Public Interface PartsListColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartsList.PartsListColumns

Example

See PartsList for example "Querying and editing the parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface


PartsListColumns Methods

PartsListColumns Methods
Summary

The methods of the PartsListColumns class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new PartsListColumn based on a property. The newly created PartsListColumn is returned.
Item | Property that returns the specified PartsListColumn object from the collection. This is the default property of the PartsListColumns collection object.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Methods


PartsListColumns.Add Method

PartsListColumns.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new PartsListColumn based on a property. The newly created PartsListColumn is returned.

Visual Basic
Sub Add(PropertyType As PropertyTypeEnum, ByRef PropertySetId As [defaultvalue("")] BSTR, ByRef PropertyIdentifier As [optional] VARIANT, ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] PartsListColumn*)
Parameters
Parameters | Description
PropertyType | Input PropertyTypeEnum that specifies the property type to associate with the column. Valid values are kFileProperty, kCustomProperty, kFilenamePartsListProperty, kItemPartsListProperty, kMassPartsListProperty, kMaterialPartsListProperty and kQuantityPartsListProperty. If kFileProperty is specified, the PropertySetId and PropertyIdentifier arguments are required. If kCustomProperty is specified, the PropertyIdentifier argument is required.
PropertySetId | Optional input String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set. This argument is ignored if the input PropertyType is not kFileProperty.
PropertyIdentifier | Optional input Variant that identifies a property. This could either be a Long value that specifies the PropId of a property within the specified property set or the name of a property. Typically, a PropId should be specified when the input PropertyType is kFileProperty and a name should be specified when the input PropertyType is kCustomProperty.
TargetIndex | Optional input Long that specifies the existing column next to which the new column will be inserted. The valid range of values is 0 to the number of existing columns in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the column will be added at the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
Remarks

The properties that are available when adding PartsListColumns via the API are generally the same as those available through the user interface (plus the thumbnail property).

You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Methods > PartsListColumns.Add Method


PartsListColumns.Item Method

PartsListColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified PartsListColumn object from the collection. This is the default property of the PartsListColumns collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartsListColumn*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the PartsListColumn to return.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Methods > PartsListColumns.Item Method


PartsListColumns Properties

PartsListColumns Properties
Summary

The properties of the PartsListColumns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Properties


PartsListColumns.Application Property

PartsListColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Properties > PartsListColumns.Application Property


PartsListColumns.Count Property

PartsListColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Properties > PartsListColumns.Count Property


PartsListColumns.Type Property

PartsListColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListColumns Interface > PartsListColumns Properties > PartsListColumns.Type Property


PartsListRow Interface

PartsListRow Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsListRow object represents a row in a parts list table.

Class Hierarchy
Inventor::PartsListRow
Visual Basic
Public Interface PartsListRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartsListRows.Add

PartsListRows.Item

Example

See PartsList for example "Querying and editing the parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface


PartsListRow Methods

PartsListRow Methods
Summary

The methods of the PartsListRow class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified PartsListCells object from the collection. This is the default property of the PartsListCells collection object.
ReferencedFiles | Property that gets files referenced by this row. A row typically references a single file unless the row resulted from merging multiple rows.
Remove | Method that removes this row from the parts list. This method works only for custom rows.
Reposition | Method that repositions the row within the parts list.
SaveItemOverridesToBOM | Saves any overrides to the item values in the balloon to the model BOM.
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Methods


PartsListRow.Item Method

PartsListRow.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified PartsListCells object from the collection. This is the default property of the PartsListCells collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartsListCell*)
Parameters
Parameters | Description
index | Input Variant value that specifies the PartsListCell to return. This can be either a numeric value indicating the index of the item in the collection, a string indicating the title of a column header, or a PartsListColumn object. If an out of range index, a non-existent column header title, or an invalid PartsListColumn object is specified, an error occurs.
See Also

Parts List Edit sample

You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Methods > PartsListRow.Item Method


PartsListRow.ReferencedFiles Method

PartsListRow.ReferencedFiles Method Available in Inventor Available in Server
Summary

Property that gets files referenced by this row. A row typically references a single file unless the row resulted from merging multiple rows.

Visual Basic
Sub ReferencedFiles(Result As [out, retval] ReferencedFileDescriptors*)
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Methods > PartsListRow.ReferencedFiles Method


PartsListRow.Remove Method

PartsListRow.Remove Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that removes this row from the parts list. This method works only for custom rows.

Visual Basic
Sub Remove()
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Methods > PartsListRow.Remove Method


PartsListRow.Reposition Method

PartsListRow.Reposition Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that repositions the row within the parts list.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing row next to which the row will be inserted. The valid range of values is 0 to the number of existing rows in the table. The position remains unchanged if the index of the row being moved is specified. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the row will be moved to the end.
InsertBefore | Optional input Boolean indicating if the row should be inserted before or after the target index. If not specified, a default value of True is used indicating that the row will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Methods > PartsListRow.Reposition Method


PartsListRow.SaveItemOverridesToBOM Method

PartsListRow.SaveItemOverridesToBOM Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Saves any overrides to the item values in the balloon to the model BOM.

Visual Basic
Sub SaveItemOverridesToBOM()
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Methods > PartsListRow.SaveItemOverridesToBOM Method


PartsListRow Properties

PartsListRow Properties
Summary

The properties of the PartsListRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Ballooned | Property that returns whether the item represented by this row in the parts list has been ballooned.
Count | Property that returns the number of items in this collection.
Custom | Property that returns whether this row is a custom row.
Expandable | Property that returns whether this row is a nested one. (i.e. it references an assembly.)
Expanded | Property that specifies the whether this row is expanded if this row is a nested one i.e. it references an assembly.
Height | Property that gets and sets the height of the row.
Parent | Property that gets the parent object from whom this object can logically be reached.
ReferencedRows | Property that returns an enumerator of DrawingBOMRow objects.
Type | Property returning an enum indicating this object's type.
Visible | Property that gets and sets whether the row is visible.
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties


PartsListRow.Application Property

PartsListRow.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Application Property


PartsListRow.Ballooned Property

PartsListRow.Ballooned Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns whether the item represented by this row in the parts list has been ballooned.

Visual Basic
Property Ballooned() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Ballooned Property


PartsListRow.Count Property

PartsListRow.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Count Property


PartsListRow.Custom Property

PartsListRow.Custom Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns whether this row is a custom row.

Visual Basic
Property Custom() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Custom Property


PartsListRow.Expandable Property

PartsListRow.Expandable Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns whether this row is a nested one. (i.e. it references an assembly.)

Visual Basic
Property Expandable() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Expandable Property


PartsListRow.Expanded Property

PartsListRow.Expanded Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the whether this row is expanded if this row is a nested one i.e. it references an assembly.

Visual Basic
Property Expanded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Expanded Property


PartsListRow.Height Property

PartsListRow.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the height of the row.

Visual Basic
Property Height() As double
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Height Property


PartsListRow.Parent Property

PartsListRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As PartsList**
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Parent Property


PartsListRow.ReferencedRows Property

PartsListRow.ReferencedRows Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns an enumerator of DrawingBOMRow objects.

Visual Basic
Property ReferencedRows() As ObjectsEnumerator**
Remarks

The property typically returns a single DrawingBOMRow unless the parts list row resulted from grouping multiple rows in the parts list.

You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.ReferencedRows Property


PartsListRow.Type Property

PartsListRow.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Type Property


PartsListRow.Visible Property

PartsListRow.Visible Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets whether the row is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartsListRow Interface > PartsListRow Properties > PartsListRow.Visible Property


PartsListRows Interface

PartsListRows Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsListRows collection object provides access to all existing objects in the parts list.

Class Hierarchy
Inventor::PartsListRows
Visual Basic
Public Interface PartsListRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartsList.PartsListRows

See Also

Parts List Query sample

Example

See PartsList for example "Querying and editing the parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface


PartsListRows Methods

PartsListRows Methods
Summary

The methods of the PartsListRows class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a custom PartsListRow. The newly created PartsListRow is returned.
Item | Returns the specified PartsListRows object from the collection. This is the default property of the PartsListRows collection object.
You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Methods


PartsListRows.Add Method

PartsListRows.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a custom PartsListRow. The newly created PartsListRow is returned.

Visual Basic
Sub Add(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] PartsListRow*)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing row next to which the new row will be inserted. The valid range of values is 0 to the number of existing rows in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the row will be added at the end.
InsertBefore | Optional input Boolean indicating if the row should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Methods > PartsListRows.Add Method


PartsListRows.Item Method

PartsListRows.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns the specified PartsListRows object from the collection. This is the default property of the PartsListRows collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] PartsListRow*)
Parameters
Parameters | Description
index | Value that specifies the index of the PartsListRow to return.
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Methods > PartsListRows.Item Method


PartsListRows Properties

PartsListRows Properties
Summary

The properties of the PartsListRows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Properties


PartsListRows.Application Property

PartsListRows.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Properties > PartsListRows.Application Property


PartsListRows.Count Property

PartsListRows.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Properties > PartsListRows.Count Property


PartsListRows.Type Property

PartsListRows.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListRows Interface > PartsListRows Properties > PartsListRows.Type Property


PartsLists Interface

PartsLists Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PartsLists collection object provides access to all existing objects on the sheet.

Class Hierarchy
Inventor::PartsLists
Visual Basic
Public Interface PartsLists
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.PartsLists

See Also

Parts List Query sample

Example

See PartsList for example "Querying and editing the parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface


PartsLists Methods

PartsLists Methods
Summary

The methods of the PartsLists class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new PartsList. The newly created PartsList is returned. Currently, this method will fail if the sheet from which this collection was obtained is not active.
Item | Returns the specified PartsList object from the collection. This is the default property of the PartsLists collection object.
You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Methods


PartsLists.Add Method

PartsLists.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new PartsList. The newly created PartsList is returned. Currently, this method will fail if the sheet from which this collection was obtained is not active.

Visual Basic
Sub Add(ViewOrModel As IDispatch, PlacementPoint As Point2d, ByRef Level As [defaultvalue(kStructured)] PartsListLevelEnum, ByRef NumberingScheme As [optional] VARIANT, ByRef NumberOfSections As [defaultvalue(1)] long, ByRef WrapLeft As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] PartsList*)
Parameters
Parameters
Description
ViewOrModel
Input object that specifies the source for the parts list. This can either be a DrawingView object or a Document object. Valid document types include part files and assembly files. Use the Documents.Open method to open the file if not already open and obtain a Document object. Typically you'll want to set the OpenVisible argument of the Open method to False so the open is invisible to the user.
PlacementPoint
Input Point2d that specifies the placement point of the parts list on the sheet.
Level
Optional input enum that sets the type of numbering for the parts list. If supplied, this input is only used in the case where the ParentView references an assembly file. If this value was previously set on the parent drawing view as a result of creating a parts list or a balloon based on the view, this argument is ignored. Valid enums are: kFirstLevelComponents, that creates a parts list in which subassemblies are assigned nested numbering (for example, 1, 1.1, 1.1.1) and the nested number extends as many levels as needed for the assembly levels in the model and kPartsOnly, that creates a parts list that sequentially numbers all parts in the top level assembly, even if they are contained in subassemblies.
NumberingScheme
Optional input NameValueMap object that specifies the numbering scheme to use for the parts list. The NameValueMap can contain the following entries based on the input 'Level' argument:

  • For kStructured: MinimumDigits As Long
  • For kStructuredAllLevels: Delimiter As String
  • For kPartsOnly: NumberingScheme As NumberingSchemeEnum and MinimumDigits As Long

Valid values for NumberingSchemeEnum are kNumericNumbering, kLowercaseAlphaNumbering and kUppercaseAlphaNumbering. This input should be supplied only if the input argument Level is specified to be kPartsOnly. If this argument is not supplied for a 'parts only' parts list, a default value of kNumericNumbering is assumed.

NumberOfSections
Optional input long that specifies the number of sections desired in the parts list. If supplied, this input is only used in the case where the ParentView references an assembly file. The default value is 1.
WrapLeft
Optional input Boolean that specifies whether to move the sections to the left or the right when the number of rows increase. If supplied, this input is only used in the case where the ParentView references an assembly file. The default value is true, indicating that sections will be moved to the left.
Example 1

"Creating a parts list"

This sample demonstrates the creation of a parts list. The parts list is placed at the top right corner of the border if one exists, else it is placed at the top right corner of the sheet. To run this sample, have a drawing document open. The active sheet in the drawing should have at least one drawing view and the first drawing view on the sheet should not be a draft view.

Public Sub CreatePartsList()

    On Error Resume Next

    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the active sheet.
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the first drawing view on
    ' the sheet. This assumes the first drawing
    ' view on the sheet is not a draft view.
    Dim oDrawingView As DrawingView
    Set oDrawingView = oSheet.DrawingViews(1)

    ' Set a reference to th sheet's border
    Dim oBorder As Border
    Set oBorder = oSheet.Border

    Dim oPlacementPoint As Point2d

    If Not oBorder Is Nothing Then
        ' A border exists. The placement point
        ' is the top-right corner of the border.
        Set oPlacementPoint = oBorder.RangeBox.MaxPoint
    Else
        ' There is no border. The placement point
        ' is the top-right corner of the sheet.
        Set oPlacementPoint = ThisApplication.TransientGeometry.CreatePoint2d(oSheet.Width, oSheet.height)
    End If

    ' Create the parts list.
    Dim oPartsList As PartsList
    Set oPartsList = oSheet.PartsLists.Add(oDrawingView, oPlacementPoint)

End Sub
Example 2

See PartsList for example "Querying / editing a parts list"

You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Methods > PartsLists.Add Method


PartsLists.Item Method

PartsLists.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns the specified PartsList object from the collection. This is the default property of the PartsLists collection object.

Visual Basic
Sub Item(Index As long, Result As [out, retval] PartsList*)
Parameters
Parameters | Description
index | Value that specifies the index of the PartsList to return.
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Methods > PartsLists.Item Method


PartsLists Properties

PartsLists Properties
Summary

The properties of the PartsLists class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Properties


PartsLists.Application Property

PartsLists.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Properties > PartsLists.Application Property


PartsLists.Count Property

PartsLists.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Properties > PartsLists.Count Property


PartsLists.Type Property

PartsLists.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsLists Interface > PartsLists Properties > PartsLists.Type Property


PartsListStyle Interface

PartsListStyle Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The PartsListStyle object represents a parts list style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::PartsListStyle
Visual Basic
Public Interface PartsListStyle
Inherits Style
Notes

Members through which this object may be accessed include:

ObjectDefaultsStyle.PartsListStyle

PartsList.Style

PartsListStylesEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface


PartsListStyle Methods

PartsListStyle Methods
Summary

The methods of the PartsListStyle class are listed here.

Methods
Methods
Name | Description
AddColumn | Method that adds a column to the list of default columns in the style.
RemoveAllColumns | Method that removes all columns from the style.
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Methods


PartsListStyle.AddColumn Method

PartsListStyle.AddColumn Method Introduced in Inventor 2011
Summary

Method that adds a column to the list of default columns in the style.

Visual Basic
Sub AddColumn(PropertyType As PropertyTypeEnum, ByRef PropertySetId As [defaultvalue("")] BSTR, ByRef PropertyIdentifier As [optional] VARIANT, ByRef Title As [defaultvalue("")] BSTR, ByRef Width As [defaultvalue(0.0)] double, ByRef TitleHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum, ByRef ValueHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum)
Parameters
Parameters | Description
PropertyType | Input PropertyTypeEnum that specifies the property type to associate with the column. Valid values are kFileProperty, kCustomProperty, kFilenamePartsListProperty, kItemPartsListProperty, kMassPartsListProperty, kMaterialPartsListProperty, kQuantityPartsListProperty, kBaseQuantityPartsListProperty, kBaseUnitPartsListProperty, kItemQuantityPartsListProperty and kUnitQuantityPartsListProperty. If kFileProperty is specified, the PropertySetId and PropertyIdentifier arguments are required. If kCustomProperty is specified, the PropertyIdentifier argument is required.
PropertySetId | Optional input String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set. This argument is ignored if the input PropertyType is not kFileProperty.
PropertyIdentifier | Optional input Variant that identifies a property. This could either be a Long value that specifies the PropId of a property within the specified property set or the name of a property. Typically, a PropId should be specified when the input PropertyType is kFileProperty and a name should be specified when the input PropertyType is kCustomProperty.
Title | Optional input String that specifies the column title. If not specified, the property name is used.
Width | Optional input Double that specifies the width of the column. If not specified, the default width value is used. A value of 0 indicates the default width value.
TitleHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column title.
ValueHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column values.
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Methods > PartsListStyle.AddColumn Method


PartsListStyle.RemoveAllColumns Method

PartsListStyle.RemoveAllColumns Method
Summary

Method that removes all columns from the style.

Visual Basic
Sub RemoveAllColumns()
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Methods > PartsListStyle.RemoveAllColumns Method


PartsListStyle Properties

PartsListStyle Properties
Summary

The properties of the PartsListStyle class are listed here.

Properties
Name | Description
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
DataTextStyle | Property that gets and sets the text style used for the contents of the table.
HeadingGap | Property that gets and sets the heading gap in centimeters.
HeadingPlacement | Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
RowGap | Property that gets and sets the row gap in centimeters.
RowLineSpacing | Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.
ShowTitle | Property that specifies the whether to show the title of the table.
TableDirection | Property that gets and sets the direction of the table based on the Item numbers. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.
Title | Property that gets and sets the title for the table.
TitleTextStyle | Property that gets and sets the text style used for the title of the table.
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties


PartsListStyle.ColumnHeaderTextStyle Property

PartsListStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.ColumnHeaderTextStyle Property


PartsListStyle.DataTextStyle Property

PartsListStyle.DataTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.DataTextStyle Property


PartsListStyle.HeadingGap Property

PartsListStyle.HeadingGap Property Introduced in Inventor 2011
Summary

Property that gets and sets the heading gap in centimeters.

Visual Basic
Property HeadingGap() As double
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.HeadingGap Property


PartsListStyle.HeadingPlacement Property

PartsListStyle.HeadingPlacement Property Introduced in Inventor 2011
Summary

Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.HeadingPlacement Property


PartsListStyle.RowGap Property

PartsListStyle.RowGap Property Introduced in Inventor 2011
Summary

Property that gets and sets the row gap in centimeters.

Visual Basic
Property RowGap() As double
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.RowGap Property


PartsListStyle.RowLineSpacing Property

PartsListStyle.RowLineSpacing Property Introduced in Inventor 2011
Summary

Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.

Visual Basic
Property RowLineSpacing() As LineSpacingEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.RowLineSpacing Property


PartsListStyle.ShowTitle Property

PartsListStyle.ShowTitle Property Introduced in Inventor 2011
Summary

Property that specifies the whether to show the title of the table.

Visual Basic
Property ShowTitle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.ShowTitle Property


PartsListStyle.TableDirection Property

PartsListStyle.TableDirection Property Introduced in Inventor 2011
Summary

Property that gets and sets the direction of the table based on the Item numbers. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.

Visual Basic
Property TableDirection() As TableDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.TableDirection Property


PartsListStyle.Title Property

PartsListStyle.Title Property Introduced in Inventor 2011
Summary

Property that gets and sets the title for the table.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.Title Property


PartsListStyle.TitleTextStyle Property

PartsListStyle.TitleTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the title of the table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > PartsListStyle Interface > PartsListStyle Properties > PartsListStyle.TitleTextStyle Property


PartsListStylesEnumerator Interface

PartsListStylesEnumerator Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The PartsListStylesEnumerator object provides access to the existing PartsListStyle objects.

Class Hierarchy
Inventor::PartsListStylesEnumerator
Visual Basic
Public Interface PartsListStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.PartsListStyles

You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface


PartsListStylesEnumerator Methods

PartsListStylesEnumerator Methods
Summary

The methods of the PartsListStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified PartsListStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Methods


PartsListStylesEnumerator.Item Method

PartsListStylesEnumerator.Item Method Introduced in Inventor 2011
Summary

Property that returns the specified PartsListStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PartsListStyle*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the PartsListStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the PartsListStyle name. If an out of range index or a name of a non-existent PartsListStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Methods > PartsListStylesEnumerator.Item Method


PartsListStylesEnumerator Properties

PartsListStylesEnumerator Properties
Summary

The properties of the PartsListStylesEnumerator class are listed here.

Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class PartsListStylesEnumerator.
Application | Property that returns the Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kPartsListStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Properties


PartsListStylesEnumerator._NewEnum Property

PartsListStylesEnumerator._NewEnum Property
Summary

This is _NewEnum, a member of class PartsListStylesEnumerator.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Properties > PartsListStylesEnumerator._NewEnum Property


PartsListStylesEnumerator.Application Property

PartsListStylesEnumerator.Application Property Introduced in Inventor 2011
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Properties > PartsListStylesEnumerator.Application Property


PartsListStylesEnumerator.Count Property

PartsListStylesEnumerator.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Properties > PartsListStylesEnumerator.Count Property


PartsListStylesEnumerator.Type Property

PartsListStylesEnumerator.Type Property Introduced in Inventor 2011
Summary

Property returning kPartsListStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PartsListStylesEnumerator Interface > PartsListStylesEnumerator Properties > PartsListStylesEnumerator.Type Property


Path Interface

Path Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The Path object represents a single set of connected curves. The order of the objects within the collection is the same as the connection order of the entities.

Class Hierarchy
Inventor::Path
    Inventor::PathProxy
Visual Basic
Public Interface Path
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ContourFlangeDefinition.Path

Features.CreatePath

Features.CreateSpecifiedPath

FlatPatternFeatures.CreatePath

LoftedFlangeDefinition.ProfileOne

LoftedFlangeDefinition.ProfileTwo

PartFeatures.CreatePath

PartFeatures.CreateSpecifiedPath

PathAndGuideRailSweepDef.GuideRail

PathEntity.Parent

PathProxy.NativeObject

RectangularPatternFeatures.CreatePath

SplitFeatures.CreatePath

SweepFeature.Path

SweepFeatures.CreatePath

BoundaryPatchLoop.BoundaryPath

SplitFeature.SplitTool

RectangularPatternFeature.XDirectionEntity

RectangularPatternFeature.YDirectionEntity

See Also

Create sheet metal lofted flange feature sample

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > Path Interface


Path Methods

Path Methods
Summary

The methods of the Path class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Property that returns the specified PathEntity object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Methods


Path.GetReferenceKey Method

Path.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Methods > Path.GetReferenceKey Method


Path.Item Method

Path.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified PathEntity object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] PathEntity*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Methods > Path.Item Method


Path Properties

Path Properties
Summary

The properties of the Path class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Closed | Property that returns a Boolean indicating if the path is closed or not. Returns True in the case of a closed path.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
Wires | Property returning the Wires collection object associated with this Path.
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties


Path.Application Property

Path.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties > Path.Application Property


Path.AttributeSets Property

Path.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties > Path.AttributeSets Property


Path.Closed Property

Path.Closed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Boolean indicating if the path is closed or not. Returns True in the case of a closed path.

Visual Basic
Property Closed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties > Path.Closed Property


Path.Count Property

Path.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties > Path.Count Property


Path.Type Property

Path.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties > Path.Type Property


Path.Wires Property

Path.Wires Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the Wires collection object associated with this Path.

Visual Basic
Property Wires() As Wires**
Remarks

A Wire object provides a different representation of 3D curves and is sometimes required when working with the TransientBRep object.

You are here: Symbol Reference > Inventor Library > Objects > Path Interface > Path Properties > Path.Wires Property


PathAndGuideRailSweepDef Interface

PathAndGuideRailSweepDef Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PathAndGuideRailSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and a guide rail.

Class Hierarchy
Inventor::SweepDefinition
    Inventor::PathAndGuideRailSweepDef
Visual Basic
Public Interface PathAndGuideRailSweepDef
Inherits SweepDefinition
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideRailSweepDef Interface


PathAndGuideRailSweepDef Properties

PathAndGuideRailSweepDef Properties
Summary

The properties of the PathAndGuideRailSweepDef class are listed here.

Properties
Name | Description
GuideRail | Property that gets and sets the guide rail for the sweep which is the guide curve that controls the scaling and twist of the sweep profile.
ProfileScaling | Property that gets and sets the enum indicating the scaling direction specified for the sweep profile. The return values can be kXYProfileScaling, kXProfileScaling or kNoProfileScaling.
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideRailSweepDef Interface > PathAndGuideRailSweepDef Properties


PathAndGuideRailSweepDef.GuideRail Property

PathAndGuideRailSweepDef.GuideRail Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the guide rail for the sweep which is the guide curve that controls the scaling and twist of the sweep profile.

Visual Basic
Property GuideRail() As Path*
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideRailSweepDef Interface > PathAndGuideRailSweepDef Properties > PathAndGuideRailSweepDef.GuideRail Property


PathAndGuideRailSweepDef.ProfileScaling Property

PathAndGuideRailSweepDef.ProfileScaling Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the enum indicating the scaling direction specified for the sweep profile. The return values can be kXYProfileScaling, kXProfileScaling or kNoProfileScaling.

Visual Basic
Property ProfileScaling() As SweepProfileScalingEnum
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideRailSweepDef Interface > PathAndGuideRailSweepDef Properties > PathAndGuideRailSweepDef.ProfileScaling Property


PathAndGuideSurfaceSweepDef Interface

PathAndGuideSurfaceSweepDef Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PathAndGuideSurfaceSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and a guide surface.

Class Hierarchy
Inventor::SweepDefinition
    Inventor::PathAndGuideSurfaceSweepDef
Visual Basic
Public Interface PathAndGuideSurfaceSweepDef
Inherits SweepDefinition
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideSurfaceSweepDef Interface


PathAndGuideSurfaceSweepDef Properties

PathAndGuideSurfaceSweepDef Properties
Summary

The properties of the PathAndGuideSurfaceSweepDef class are listed here.

Properties
Name | Description
GuideSurface | Property that gets and sets the guide surface the normal of which controls the twist of the swept profile about the path.
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideSurfaceSweepDef Interface > PathAndGuideSurfaceSweepDef Properties


PathAndGuideSurfaceSweepDef.GuideSurface Property

PathAndGuideSurfaceSweepDef.GuideSurface Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the guide surface the normal of which controls the twist of the swept profile about the path.

Visual Basic
Property GuideSurface() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PathAndGuideSurfaceSweepDef Interface > PathAndGuideSurfaceSweepDef Properties > PathAndGuideSurfaceSweepDef.GuideSurface Property


PathAndSectionTwistsSweepDef Interface

PathAndSectionTwistsSweepDef Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The PathAndSectionTwistsSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and twist sections.

Class Hierarchy
Inventor::SweepDefinition
    Inventor::PathAndSectionTwistsSweepDef
Visual Basic
Public Interface PathAndSectionTwistsSweepDef
Inherits SweepDefinition
You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface


PathAndSectionTwistsSweepDef Methods

PathAndSectionTwistsSweepDef Methods
Summary

The methods of the PathAndSectionTwistsSweepDef class are listed here.

Methods
Methods
Name | Description
GetSectionTwists | Method that gets the twisted sweep sections and the twist conditions at these sections.
SetSectionTwists | Method that sets the twist conditions at the specified sweep sections.
You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface > PathAndSectionTwistsSweepDef Methods


PathAndSectionTwistsSweepDef.GetSectionTwists Method

PathAndSectionTwistsSweepDef.GetSectionTwists Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that gets the twisted sweep sections and the twist conditions at these sections.

Visual Basic
Sub GetSectionTwists(ByRef SectionTwistPoints As ObjectCollection*, ByRef SectionTwistVectors As ObjectCollection*)
Parameters
Parameters
Description
SectionTwistPoints
Output ObjectCollection that contains the points along the sweep path at which the sweep twists have been specified. The sweep path points define the positions of the sweep cross-sections at which the twists have been specified. Since the sweep feature is created by sweeping a profile cross-section along a sweep path, the twist of the sweep can theoretically be controlled at all points along the sweep path. But for practical purposes, the creation of a twisted sweep feature is limited to sweep features that are swept along a spline path and the twist can only be specified for cross-sections at fit points of the spline path. Since the sweep feature can only be twisted at fit points of the spline that defines the sweep path, the objects returned in the collection will correspond to those fit points at which the twists have been specified. The objects returned in the collection will be either SketchPoint objects that correspond to one of the fit points of the sweep path if it is a 2D spline or SketchPoint3D objects that correspond to one of the fit points of the sweep path if it is a 3D spline. Since this argument together with the SectionTwistVectors argument defines the twist conditions at the cross-sections of the sweep at which the twists have been specified, the order of the sweep path points in the collection returned by this argument will correspond to the order of the twist unit-vectors in the collection returned by the SectionTwistVectors argument. Therefore, if a particular item number in the collection returned by this argument corresponds to a particular sweep path point at which the sweep section has been twisted, the same item number in the collection returned by the SectionTwistVectors argument will correspond to the twist vector for that sweep section. For example, if a twist condition has been applied for the sweep cross-section at the first fit point of the sweep path and if the first item in the collection returned by this argument is the first fit point of the sweep path, then the first item in the collection returned by the SectionTwistVectors argument will be the twist vector for the cross-section at the first fit point of the sweep path. If no twist conditions have been specified for any of the sweep sections, then this argument will return Nothing.
SectionTwistVectors
Output ObjectCollection object that contains the unit-vectors that define the twists for the sweep sections. The sweep twist vectors define the twists for the sweep cross-sections returned in the SectionTwistPoints argument. The twist vectors are unit-vectors specified in the model space coordinate system. Also, each vector lies on the plane of the sweep cross-section for which it defines the twist. The objects returned in the collection will be UnitVector objects that specify the twist vector directions for the sweep sections. Since this argument together with the SectionTwistPoints argument defines the twist conditions at the cross-sections of the sweep at which the twists have been specified, the order of the twist unit-vectors in the collection returned by this argument will correspond to the order of the sweep path points in the collection returned by the SectionTwistPoints argument. Therefore, if a particular item number in the collection returned by the SectionTwistPoints argument corresponds to a particular sweep path point at which the sweep section has been twisted, the same item number in the collection returned by this argument will correspond to the twist vector for that sweep section. For example, if a twist condition has been applied for the sweep cross-section at the first fit point of the sweep path and if the first item in the collection returned by the SectionTwistPoints argument is the first fit point of the sweep path, then the first item in the collection returned by this argument will be the twist vector for the cross-section at the first fit point of the sweep path.
Remarks

This method returns the sweep path points at which section twists have been specified in the SectionTwistPoints object collection and the corresponding twists for these sweep sections in the SectionTwistVectors object collection. If no twist conditions have been specified for any of the sweep sections, then both the arguments will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface > PathAndSectionTwistsSweepDef Methods > PathAndSectionTwistsSweepDef.GetSectionTwists Method


PathAndSectionTwistsSweepDef.SetSectionTwists Method

PathAndSectionTwistsSweepDef.SetSectionTwists Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the twist conditions at the specified sweep sections.

Visual Basic
Sub SetSectionTwists(SectionTwistPoints As ObjectCollection, SectionTwistVectors As ObjectCollection)
Parameters
Parameters
Description
SectionTwistPoints
Input ObjectCollection that contains the points along the sweep path at which the sweep twists need to be specified. The sweep path points define the positions of the sweep cross-sections at which the twists need to be specified. Since the sweep feature is created by sweeping a profile cross-section along a sweep path, the twist of the sweep can theoretically be controlled at all points along the sweep path. But for practical purposes, the creation of a twisted sweep feature will be limited to sweep features that are swept along a spline path and the twist can only be specified for cross-sections at fit points of the spline path. Since the sweep feature can only be twisted at fit points of the spline that defines the sweep path, the valid input points are only the fit points of the spline that defines the sweep path. If any of the specified input points are not fit points on the sweep path specified by the Path argument, then setting the twists for the sweep sections will fail. Therefore, the valid input objects can be either SketchPoint objects that correspond to any of the fit points of the sweep path if it is a 2D spline or SketchPoint3D objects that correspond to any of the fit points of the sweep path if it is a 3D spline. Since this argument together with the SectionTwistVectors argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by this argument must be the same as the number of items in the collection specified by the SectionTwistVectors argument.

The order of the sweep path points in the collection specified by this argument must correspond to the order of the twist unit-vectors in the collection specified by the SectionTwistVectors argument. Therefore, if a particular item number in the collection specified by this argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by the SectionTwistVectors argument should correspond to the twist vector for that sweep section. For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by this argument is the first fit point of the sweep path, then the first item in the collection specified by the SectionTwistVectors argument must be the twist vector for the cross-section at the first fit point of the sweep path. Setting the twists for the sweep sections will fail for the following cases:

  • The object collections specified for this argument and the SectionTwistVectors arguments are both empty.
  • Valid object collections are specified for both this argument and the SectionTwistVectors argument, but any of the sweep path points specified by this argument are not fit points on the sweep path specified by the Path argument.

SectionTwistVectors
Input ObjectCollection object that specifies the unit-vectors that define the twists for the sweep sections. The sweep twist vectors define the twists for the sweep cross-sections specified using the SectionTwistPoints argument. The twist vectors are unit-vectors specified in the model space coordinate system. Also, each vector should lie on the plane of the sweep cross-section for which it defines the twist, otherwise, setting the twists for the sweep sections will fail. Therefore, the valid input objects are UnitVector objects that specify the twist vector directions for the sweep sections. Since this argument together with the SectionTwistPoints argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by this argument must be the same as the number of items in the collection specified by the SectionTwistPoints argument.
  • The order of the sweep path points in the collection specified by the SectionTwistPoints argument must correspond to the order of the twist unit-vectors in the collection specified by this argument. Therefore, if a particular item number in the collection specified by the SectionTwistPoints argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by this argument should correspond to the twist vector for that sweep section.

For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by the SectionTwistPoints argument is the first fit point of the sweep path, then the first item in the collection specified by this argument must be the twist vector for the cross-section at the first fit point of the sweep path. Setting the twists for the sweep sections will fail for the following cases:

  • The object collections specified for this argument and the SectionTwistPoints arguments are both empty.

Valid object collections are specified for both this argument and the SectionTwistPoints argument, but any of the twist unit-vectors specified by this argument does not lie on the respective sweep cross-section plane for which the unit-vector defines the twist.

Remarks

The SectionTwistPoints argument specifies the object collection that contains the sweep path points at which section twists need to be applied and the SectionTwistPoints argument specifies the object collection that contains the corresponding twist vectors for these sweep sections.

You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface > PathAndSectionTwistsSweepDef Methods > PathAndSectionTwistsSweepDef.SetSectionTwists Method


PathAndSectionTwistsSweepDef Properties

PathAndSectionTwistsSweepDef Properties
Summary

The properties of the PathAndSectionTwistsSweepDef class are listed here.

Properties
Name | Description
ProfileOrientation | Property that gets and sets the enum indicating the orientation of the sweep profile. The values can be kNormalToPath or kParallelToOriginalProfile.
TaperAngle | Property that returns the parameter controlling the taper angle of the feature.
You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface > PathAndSectionTwistsSweepDef Properties


PathAndSectionTwistsSweepDef.ProfileOrientation Property

PathAndSectionTwistsSweepDef.ProfileOrientation Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the enum indicating the orientation of the sweep profile. The values can be kNormalToPath or kParallelToOriginalProfile.

Visual Basic
Property ProfileOrientation() As SweepProfileOrientationEnum
Remarks

A return value of kNormalToPath indicates that the sweep profile is normal to the path along all sections of the sweep.

A return value of kParallelToOriginalProfile indicates that the sweep profile section, along all points of the sweep path, is always parallel to the original profile that defines the starting section for the sweep.

You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface > PathAndSectionTwistsSweepDef Properties > PathAndSectionTwistsSweepDef.ProfileOrientation Property


PathAndSectionTwistsSweepDef.TaperAngle Property

PathAndSectionTwistsSweepDef.TaperAngle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parameter controlling the taper angle of the feature.

Visual Basic
Property TaperAngle() As Parameter**
Remarks

If the profile orientation has been specified to be parallel to the starting section profile as indicated by the ProfileOrientation property being kParallelToOriginalProfile, then the taper angle does not apply. Therefore, the value of this parameter will be zero in most cases. This parameter can be edited to specify a non-zero value but, this will not have any effect on the sweep feature. If the profile orientation has been specified to be normal to the sweep path as indicated by the ProfileOrientation property being kNormalToPath, then the taper angle is applicable and the value of this parameter will correspond to the taper angle of the sweep. The value of this parameter can also be edited to specify a new taper angle for the sweep.

You are here: Symbol Reference > Inventor Library > Objects > PathAndSectionTwistsSweepDef Interface > PathAndSectionTwistsSweepDef Properties > PathAndSectionTwistsSweepDef.TaperAngle Property


PathEntity Interface

PathEntity Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The PathEntity object represents a curve within a path.

Class Hierarchy
Inventor::PathEntity
    Inventor::PathEntityProxy
Visual Basic
Public Interface PathEntity
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Path.Item

PathEntityProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface


PathEntity Methods

PathEntity Methods
Summary

The methods of the PathEntity class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Methods


PathEntity.GetReferenceKey Method

PathEntity.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Methods > PathEntity.GetReferenceKey Method


PathEntity Properties

PathEntity Properties
Summary

The properties of the PathEntity class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Curve | Property that returns the geometry of the entity. The geometry is returned such that the entities are connected in a head-to-tail fashion.
CurveType | Property that returns the type of the curve referenced by the path entity. This property allows you to determine what type of object will be returned by the Curve property.
OpposedToSketchEntity | Property that returns a Boolean indicating if the parametric flow of the path entity is in the same direction as the sketch entity it was derived from.
Parent | Property that returns the parent Path of the entity.
SketchEntity | Property that gets the sketch entity (2D or 3D) this entity was derived from.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties


PathEntity.Application Property

PathEntity.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.Application Property


PathEntity.Curve Property

PathEntity.Curve Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the geometry of the entity. The geometry is returned such that the entities are connected in a head-to-tail fashion.

Visual Basic
Property Curve() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.Curve Property


PathEntity.CurveType Property

PathEntity.CurveType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the type of the curve referenced by the path entity. This property allows you to determine what type of object will be returned by the Curve property.

Visual Basic
Property CurveType() As CurveTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.CurveType Property


PathEntity.OpposedToSketchEntity Property

PathEntity.OpposedToSketchEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Boolean indicating if the parametric flow of the path entity is in the same direction as the sketch entity it was derived from.

Visual Basic
Property OpposedToSketchEntity() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.OpposedToSketchEntity Property


PathEntity.Parent Property

PathEntity.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent Path of the entity.

Visual Basic
Property Parent() As Path**
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.Parent Property


PathEntity.SketchEntity Property

PathEntity.SketchEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the sketch entity (2D or 3D) this entity was derived from.

Visual Basic
Property SketchEntity() As IDispatch**
See Also

Sketch profile control sample

You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.SketchEntity Property


PathEntity.Type Property

PathEntity.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PathEntity Interface > PathEntity Properties > PathEntity.Type Property


PathEntityProxy Interface

PathEntityProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PathEntity object.

Class Hierarchy
Inventor::PathEntity
    Inventor::PathEntityProxy
Visual Basic
Public Interface PathEntityProxy
Inherits PathEntity
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PathEntityProxy Interface


PathEntityProxy Properties

PathEntityProxy Properties
Summary

The properties of the PathEntityProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PathEntityProxy Interface > PathEntityProxy Properties


PathEntityProxy.ContainingOccurrence Property

PathEntityProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PathEntityProxy Interface > PathEntityProxy Properties > PathEntityProxy.ContainingOccurrence Property


PathEntityProxy.NativeObject Property

PathEntityProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As PathEntity**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PathEntityProxy Interface > PathEntityProxy Properties > PathEntityProxy.NativeObject Property


PathProxy Interface

PathProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Path object.

Class Hierarchy
Inventor::Path
    Inventor::PathProxy
Visual Basic
Public Interface PathProxy
Inherits Path
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PathProxy Interface


PathProxy Properties

PathProxy Properties
Summary

The properties of the PathProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PathProxy Interface > PathProxy Properties


PathProxy.ContainingOccurrence Property

PathProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PathProxy Interface > PathProxy Properties > PathProxy.ContainingOccurrence Property


PathProxy.NativeObject Property

PathProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As Path**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PathProxy Interface > PathProxy Properties > PathProxy.NativeObject Property


PathSweepDef Interface

PathSweepDef Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PathSweepDef object provides access to the information that defines the variables for a sweep feature defined by a path and profile orientation constant.

Class Hierarchy
Inventor::SweepDefinition
    Inventor::PathSweepDef
Visual Basic
Public Interface PathSweepDef
Inherits SweepDefinition
You are here: Symbol Reference > Inventor Library > Objects > PathSweepDef Interface


PathSweepDef Properties

PathSweepDef Properties
Summary

The properties of the PathSweepDef class are listed here.

Properties
Name | Description
ProfileOrientation | Property that gets and sets the enum indicating the orientation of the sweep profile. The values can be kNormalToPath or kParallelToOriginalProfile.
TaperAngle | Property that returns the parameter controlling the taper angle of the feature.
You are here: Symbol Reference > Inventor Library > Objects > PathSweepDef Interface > PathSweepDef Properties


PathSweepDef.ProfileOrientation Property

PathSweepDef.ProfileOrientation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the enum indicating the orientation of the sweep profile. The values can be kNormalToPath or kParallelToOriginalProfile.

Visual Basic
Property ProfileOrientation() As SweepProfileOrientationEnum
Remarks

A return value of kNormalToPath indicates that the sweep profile is normal to the path along all sections of the sweep.

A return value of kParallelToOriginalProfile indicates that the sweep profile section, along all points of the sweep path, is always parallel to the original profile that defines the starting section for the sweep.

You are here: Symbol Reference > Inventor Library > Objects > PathSweepDef Interface > PathSweepDef Properties > PathSweepDef.ProfileOrientation Property


PathSweepDef.TaperAngle Property

PathSweepDef.TaperAngle Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parameter controlling the taper angle of the feature.

Visual Basic
Property TaperAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PathSweepDef Interface > PathSweepDef Properties > PathSweepDef.TaperAngle Property


PatternConstraint Interface

PatternConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PatternConstraint object represents a constraint placed between elements of a pattern to make these elements associative.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::PatternConstraint
        Inventor::PatternConstraintProxy
Visual Basic
Public Interface PatternConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

PatternConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > PatternConstraint Interface


PatternConstraintProxy Interface

PatternConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PatternConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::PatternConstraint
        Inventor::PatternConstraintProxy
Visual Basic
Public Interface PatternConstraintProxy
Inherits PatternConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PatternConstraintProxy Interface


PatternConstraintProxy Properties

PatternConstraintProxy Properties
Summary

The properties of the PatternConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PatternConstraintProxy Interface > PatternConstraintProxy Properties


PatternConstraintProxy.ContainingOccurrence Property

PatternConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PatternConstraintProxy Interface > PatternConstraintProxy Properties > PatternConstraintProxy.ContainingOccurrence Property


PatternConstraintProxy.NativeObject Property

PatternConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As PatternConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PatternConstraintProxy Interface > PatternConstraintProxy Properties > PatternConstraintProxy.NativeObject Property


PerpendicularConstraint Interface

PerpendicularConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PerpendicularConstraint object represents a perpendicular constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::PerpendicularConstraint
        Inventor::PerpendicularConstraintProxy
Visual Basic
Public Interface PerpendicularConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddPerpendicular

PerpendicularConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint Interface


PerpendicularConstraint Properties

PerpendicularConstraint Properties
Summary

The properties of the PerpendicularConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseOneMajorAxis property indicates if the perpendicular constraint is between the major or minor axis of the ellipse.
EntityTwo | Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseTwoMajorAxis property indicates if the perpendicular constraint is between the major or minor axis of the ellipse.
UseEllipseOneMajorAxis | Property used in the case where the entity returned by the EntityOne property is an ellipse. This property specifies if the major or minor axis of the ellipse is perpendicular to EntityTwo. True if it is the major axis.
UseEllipseTwoMajorAxis | Property used in the case where the entity returned by the EntityTwo property is an ellipse. This property specifies if the major or minor axis of the ellipse is perpendicular to EntityOne. True if it is the major axis.
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint Interface > PerpendicularConstraint Properties


PerpendicularConstraint.EntityOne Property

PerpendicularConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseOneMajorAxis property indicates if the perpendicular constraint is between the major or minor axis of the ellipse.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint Interface > PerpendicularConstraint Properties > PerpendicularConstraint.EntityOne Property


PerpendicularConstraint.EntityTwo Property

PerpendicularConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained. This will be a line, ellipse, or elliptical arc. In the case where an elliptical entity is returned, the UsesEllipseTwoMajorAxis property indicates if the perpendicular constraint is between the major or minor axis of the ellipse.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint Interface > PerpendicularConstraint Properties > PerpendicularConstraint.EntityTwo Property


PerpendicularConstraint.UseEllipseOneMajorAxis Property

PerpendicularConstraint.UseEllipseOneMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the EntityOne property is an ellipse. This property specifies if the major or minor axis of the ellipse is perpendicular to EntityTwo. True if it is the major axis.

Visual Basic
Property UseEllipseOneMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint Interface > PerpendicularConstraint Properties > PerpendicularConstraint.UseEllipseOneMajorAxis Property


PerpendicularConstraint.UseEllipseTwoMajorAxis Property

PerpendicularConstraint.UseEllipseTwoMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the EntityTwo property is an ellipse. This property specifies if the major or minor axis of the ellipse is perpendicular to EntityOne. True if it is the major axis.

Visual Basic
Property UseEllipseTwoMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint Interface > PerpendicularConstraint Properties > PerpendicularConstraint.UseEllipseTwoMajorAxis Property


PerpendicularConstraint3D Interface

PerpendicularConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The PerpendicularConstraint3D object represents a perpendicular constraint within a 3D sketch. The constraint can be applied between a 3D sketch line and another 3D sketch line, a work axis, linear edge, work plane or a surface (face).

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::PerpendicularConstraint3D
        Inventor::PerpendicularConstraint3DProxy
Visual Basic
Public Interface PerpendicularConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.AddPerpendicular

PerpendicularConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3D Interface


PerpendicularConstraint3D Properties

PerpendicularConstraint3D Properties
Summary

The properties of the PerpendicularConstraint3D class are listed here.

Properties
Name | Description
EntityOne | Property that returns the first sketch entity being constrained.
EntityTwo | Property that returns the second sketch entity being constrained.
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3D Interface > PerpendicularConstraint3D Properties


PerpendicularConstraint3D.EntityOne Property

PerpendicularConstraint3D.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the first sketch entity being constrained.

Visual Basic
Property EntityOne() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3D Interface > PerpendicularConstraint3D Properties > PerpendicularConstraint3D.EntityOne Property


PerpendicularConstraint3D.EntityTwo Property

PerpendicularConstraint3D.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the second sketch entity being constrained.

Visual Basic
Property EntityTwo() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3D Interface > PerpendicularConstraint3D Properties > PerpendicularConstraint3D.EntityTwo Property


PerpendicularConstraint3DProxy Interface

PerpendicularConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PerpendicularConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::PerpendicularConstraint3D
        Inventor::PerpendicularConstraint3DProxy
Visual Basic
Public Interface PerpendicularConstraint3DProxy
Inherits PerpendicularConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3DProxy Interface


PerpendicularConstraint3DProxy Properties

PerpendicularConstraint3DProxy Properties
Summary

The properties of the PerpendicularConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3DProxy Interface > PerpendicularConstraint3DProxy Properties


PerpendicularConstraint3DProxy.ContainingOccurrence Property

PerpendicularConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3DProxy Interface > PerpendicularConstraint3DProxy Properties > PerpendicularConstraint3DProxy.ContainingOccurrence Property


PerpendicularConstraint3DProxy.NativeObject Property

PerpendicularConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As PerpendicularConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraint3DProxy Interface > PerpendicularConstraint3DProxy Properties > PerpendicularConstraint3DProxy.NativeObject Property


PerpendicularConstraintProxy Interface

PerpendicularConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PerpendicularConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::PerpendicularConstraint
        Inventor::PerpendicularConstraintProxy
Visual Basic
Public Interface PerpendicularConstraintProxy
Inherits PerpendicularConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraintProxy Interface


PerpendicularConstraintProxy Properties

PerpendicularConstraintProxy Properties
Summary

The properties of the PerpendicularConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the that the native object is being referenced through.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraintProxy Interface > PerpendicularConstraintProxy Properties


PerpendicularConstraintProxy.ContainingOccurrence Property

PerpendicularConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the that the native object is being referenced through.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

The returned occurrence is the containing occurrence. For more detailed information about object proxies, please see More Proxy Information.

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraintProxy Interface > PerpendicularConstraintProxy Properties > PerpendicularConstraintProxy.ContainingOccurrence Property


PerpendicularConstraintProxy.NativeObject Property

PerpendicularConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As PerpendicularConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PerpendicularConstraintProxy Interface > PerpendicularConstraintProxy Properties > PerpendicularConstraintProxy.NativeObject Property


PitchAndHeightCoilExtent Interface

PitchAndHeightCoilExtent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PitchAndHeightExtent object provides access to the information that defines the variables for a coil feature created using pitch and height values.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::PitchAndHeightCoilExtent
Visual Basic
Public Interface PitchAndHeightCoilExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > PitchAndHeightCoilExtent Interface


PitchAndHeightCoilExtent Properties

PitchAndHeightCoilExtent Properties
Summary

The properties of the PitchAndHeightCoilExtent class are listed here.

Properties
Name | Description
Height | Property that gets the height of the coil feature.
Pitch | Property that indicates the pitch of the coil feature.
TaperAngle | Property that indicates the taper angle of the coil feature.
You are here: Symbol Reference > Inventor Library > Objects > PitchAndHeightCoilExtent Interface > PitchAndHeightCoilExtent Properties


PitchAndHeightCoilExtent.Height Property

PitchAndHeightCoilExtent.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the height of the coil feature.

Visual Basic
Property Height() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PitchAndHeightCoilExtent Interface > PitchAndHeightCoilExtent Properties > PitchAndHeightCoilExtent.Height Property


PitchAndHeightCoilExtent.Pitch Property

PitchAndHeightCoilExtent.Pitch Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the pitch of the coil feature.

Visual Basic
Property Pitch() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PitchAndHeightCoilExtent Interface > PitchAndHeightCoilExtent Properties > PitchAndHeightCoilExtent.Pitch Property


PitchAndHeightCoilExtent.TaperAngle Property

PitchAndHeightCoilExtent.TaperAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the taper angle of the coil feature.

Visual Basic
Property TaperAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PitchAndHeightCoilExtent Interface > PitchAndHeightCoilExtent Properties > PitchAndHeightCoilExtent.TaperAngle Property


PitchAndRevolutionCoilExtent Interface

PitchAndRevolutionCoilExtent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PitchAndRevolutionExtent object provides access to the information that defines the variables for a coil feature created using pitch and revolution values.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::PitchAndRevolutionCoilExtent
Visual Basic
Public Interface PitchAndRevolutionCoilExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > PitchAndRevolutionCoilExtent Interface


PitchAndRevolutionCoilExtent Properties

PitchAndRevolutionCoilExtent Properties
Summary

The properties of the PitchAndRevolutionCoilExtent class are listed here.

Properties
Name | Description
Pitch | Property that returns the parameter that controls the pitch of the coil feature.
Revolution | Property that returns the parameter that controls the number of revolutions of the coil feature.
TaperAngle | Property that returns the parameter that controls the taper angle of the coil feature.
You are here: Symbol Reference > Inventor Library > Objects > PitchAndRevolutionCoilExtent Interface > PitchAndRevolutionCoilExtent Properties


PitchAndRevolutionCoilExtent.Pitch Property

PitchAndRevolutionCoilExtent.Pitch Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the pitch of the coil feature.

Visual Basic
Property Pitch() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PitchAndRevolutionCoilExtent Interface > PitchAndRevolutionCoilExtent Properties > PitchAndRevolutionCoilExtent.Pitch Property


PitchAndRevolutionCoilExtent.Revolution Property

PitchAndRevolutionCoilExtent.Revolution Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the number of revolutions of the coil feature.

Visual Basic
Property Revolution() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PitchAndRevolutionCoilExtent Interface > PitchAndRevolutionCoilExtent Properties > PitchAndRevolutionCoilExtent.Revolution Property


PitchAndRevolutionCoilExtent.TaperAngle Property

PitchAndRevolutionCoilExtent.TaperAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the taper angle of the coil feature.

Visual Basic
Property TaperAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PitchAndRevolutionCoilExtent Interface > PitchAndRevolutionCoilExtent Properties > PitchAndRevolutionCoilExtent.TaperAngle Property


PlanarMoveDefinition Interface

PlanarMoveDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The PlanarMoveDefinition object defines all of the inputs that are unique to a move face feature defined using two planar points.

Class Hierarchy
Inventor::PlanarMoveDefinition
Visual Basic
Public Interface PlanarMoveDefinition
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface


PlanarMoveDefinition Properties

PlanarMoveDefinition Properties
Summary

The properties of the PlanarMoveDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent MoveFaceDefinition object.
Plane | Property that gets and sets the plane for the planar move. This can either be a WorkPlane or a planar Face object.
PointOne | Property that gets and sets the first point for the planar move. This can either be a WorkPoint or a Vertex object.
PointTwo | Property that gets and sets the second point for the planar move. This can either be a WorkPoint or a Vertex object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties


PlanarMoveDefinition.Application Property

PlanarMoveDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties > PlanarMoveDefinition.Application Property


PlanarMoveDefinition.Parent Property

PlanarMoveDefinition.Parent Property
Summary

Property that returns the parent MoveFaceDefinition object.

Visual Basic
Property Parent() As MoveFaceDefinition**
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties > PlanarMoveDefinition.Parent Property


PlanarMoveDefinition.Plane Property

PlanarMoveDefinition.Plane Property
Summary

Property that gets and sets the plane for the planar move. This can either be a WorkPlane or a planar Face object.

Visual Basic
Property Plane() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties > PlanarMoveDefinition.Plane Property


PlanarMoveDefinition.PointOne Property

PlanarMoveDefinition.PointOne Property
Summary

Property that gets and sets the first point for the planar move. This can either be a WorkPoint or a Vertex object.

Visual Basic
Property PointOne() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties > PlanarMoveDefinition.PointOne Property


PlanarMoveDefinition.PointTwo Property

PlanarMoveDefinition.PointTwo Property
Summary

Property that gets and sets the second point for the planar move. This can either be a WorkPoint or a Vertex object.

Visual Basic
Property PointTwo() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties > PlanarMoveDefinition.PointTwo Property


PlanarMoveDefinition.Type Property

PlanarMoveDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PlanarMoveDefinition Interface > PlanarMoveDefinition Properties > PlanarMoveDefinition.Type Property


PlanarSketch Interface

PlanarSketch Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PlanarSketch object, situated in 3D space. See the overview articles.

Class Hierarchy
Inventor::Sketch
    Inventor::PlanarSketch
        Inventor::PlanarSketchProxy
        Inventor::SketchBlockDefinition
Visual Basic
Public Interface PlanarSketch
Inherits Sketch
Notes

Members through which this object may be accessed include:

HoleFeature.Sketch

PlanarSketch.ReferencedEntity

PlanarSketches.Add

PlanarSketches.AddWithOrientation

PlanarSketches.Item

PlanarSketchProxy.NativeObject

ProjectedCut.Parent

NormalToSurfaceWorkAxisDef.SurfaceEntity

See Also

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Share sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Set Sketch Visibility sample

True length of sweep feature sample

Sweep Feature Add sample

SurfaceBody Copy sample

Sketch Spline sample

Spline - create NURBS sample

Create sketch elliptical arc sample

Sketch Lines sample

Offset a 2D sketch sample

Sketch Open for Edit sample

Sketch Delete sample

Projection - project across parts sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Add a punch tool feature sample

Accessing region properties from a profile sample

Sketch Add Oriented sample

Sketch Add sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Derived Parts and Assemblies sample

Add a decal feature sample

Copy a sketch sample

Delete Face, Boundary Patch and Stitch features. sample

Example

See Sketch.Visible for an example.

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface


PlanarSketch Methods

PlanarSketch Methods
Summary

The methods of the PlanarSketch class are listed here.

Methods
Methods
Name | Description
AddBySilhouette | Method that creates new reference sketch geometry as the silhouette on the input face near the input proximity point.
BreakLink | Method that breaks the link to the source sketch.
ModelToSketchSpace | Method that takes a 3D coordinate in model space, projects it onto the sketch plane along the normal of the plane and returns a Point2d object containing the resulting coordinate point in sketch space.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.
SketchToModelSpace | Method that takes a 2D coordinate in sketch space, and returns a Point3d containing the coordinates of the point in model space.
UpdateProfiles | Method that updates all the profiles within the sketch.
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods


PlanarSketch.AddBySilhouette Method

PlanarSketch.AddBySilhouette Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates new reference sketch geometry as the silhouette on the input face near the input proximity point.

Visual Basic
Sub AddBySilhouette(Face As Face, ProximityPoint As Point, Result As [out, retval] SketchEntity*)
Parameters
Parameters | Description
Face | Input Face that defines a silhouette edge that can be projected onto the sketch plane.
ProximityPoint | Input that identifies which one of possible multiple results to use. For example, if the input face is a cylinder there are two possible silhouette edges.
Example

"Sketch from Face Silhouette Example "

This sample creates a cylindrical solid, creates a new sketch plane and creates some new sketch lines from the actual edges and the apparent (silhouette) edges of the cylinder.

Public Sub SilhouetteSample()
    ' Create a new part document using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the part component definition.
    ' This assumes that a part document is active.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch1 As PlanarSketch
    Set oSketch1 = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a circle on the sketch.
    Dim oCircle As SketchCircle
    Set oCircle = oSketch1.SketchCircles.AddByCenterRadius( _
                                oTransGeom.CreatePoint2d(0, 0), 2)

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch1.Profiles.AddForSolid

    ' Create a solid extrusion.
    Dim oExtrusion As ExtrudeFeature
    Set oExtrusion = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                    oProfile, 3, kSymmetricExtentDirection, kJoinOperation)

    ' Create another sketch on the Y-Z plane.
    Dim oSketch2 As PlanarSketch
    Set oSketch2 = oCompDef.Sketches.Add(oCompDef.WorkPlanes(1))

    ' Get the cylindrical face of the solid.
    Dim oCylinder As Face
    Set oCylinder = oExtrusion.SideFaces.Item(1)

    ' Create a sketch line using the silhouette of the cylinder.  The proximity
    ' point determines which of the two silhouette edges will be used.
    Dim oSilhouetteCurve As SketchEntity
    Set oSilhouetteCurve = oSketch2.AddBySilhouette(oCylinder, _
                                    oTransGeom.CreatePoint(0, -1, 0))

    ' Create another sketch line from the silhouette on the
    ' other side of the cylinder.
    Set oSilhouetteCurve = oSketch2.AddBySilhouette(oCylinder, _
                                    oTransGeom.CreatePoint(0, 1, 0))

    ' Create sketch lines from the ends of the cylinder.  This takes
    ' advantage of the fact that a cylinder only has two edges.
    Dim oEndLine As SketchEntity
    Set oEndLine = oSketch2.AddByProjectingEntity( _
                            oExtrusion.StartFaces.Item(1).Edges.Item(1))
    Set oEndLine = oSketch2.AddByProjectingEntity( _
                            oExtrusion.EndFaces.Item(1).Edges.Item(1))
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods > PlanarSketch.AddBySilhouette Method


PlanarSketch.BreakLink Method

PlanarSketch.BreakLink Method
Summary

Method that breaks the link to the source sketch.

Visual Basic
Sub BreakLink()
Remarks

For a flat pattern sketch that has been transposed (copied) from the folded model, this method breaks the link to the referenced sheet metal folded model sketch. The CopyToFlatPattern property on the folded model sketch is automatically set to False.

For a sketch block definition that resulted from a derive operation, this method breaks the link to the sketch block definition in the source (base) part.

The method returns a failure for all other sketches.

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods > PlanarSketch.BreakLink Method


PlanarSketch.ModelToSketchSpace Method

PlanarSketch.ModelToSketchSpace Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that takes a 3D coordinate in model space, projects it onto the sketch plane along the normal of the plane and returns a Point2d object containing the resulting coordinate point in sketch space.

Visual Basic
Sub ModelToSketchSpace(ModelCoordinate As Point, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
ModelCoordinate | Input Point that specifies the point in model space to be transformed into sketch space.
See Also

Create sheet metal face and fold features sample

Sweep Feature Add sample

Create sheet metal face and cut features sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Extrude Feature - Create Block with Pocket sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods > PlanarSketch.ModelToSketchSpace Method


PlanarSketch.SetEndOfPart Method

PlanarSketch.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this work feature. A value of True indicates before and False indicates after.
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods > PlanarSketch.SetEndOfPart Method


PlanarSketch.SketchToModelSpace Method

PlanarSketch.SketchToModelSpace Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that takes a 2D coordinate in sketch space, and returns a Point3d containing the coordinates of the point in model space.

Visual Basic
Sub SketchToModelSpace(SketchCoordinate As Point2d, Result As [out, retval] Point*)
Parameters
Parameters | Description
SketchCoordinate | Input Point2d that specifies the 2d coordinate in sketch space.
See Also

True length of sweep feature sample

Sweep Feature Add sample

Hole feature linear placement sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods > PlanarSketch.SketchToModelSpace Method


PlanarSketch.UpdateProfiles Method

PlanarSketch.UpdateProfiles Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that updates all the profiles within the sketch.

Visual Basic
Sub UpdateProfiles()
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Methods > PlanarSketch.UpdateProfiles Method


PlanarSketch Properties

PlanarSketch Properties
Summary

The properties of the PlanarSketch class are listed here.

Properties
Name | Description
Adaptive | Property that gets and sets whether the sketch is adaptive or not. This is the same as selecting Adaptive on the context menu of a sketch within the browser. This property only applies to sketches within a part, not drawing related sketches.
AxisEntity | Property that gets and sets the object that defines the X or Y axis of the sketch plane. The AxisIsX property defines whether it is the X or Y axis, and the NaturalAxisDirection property defines the direction of the axis. Valid input is a linear edge, work axis, or a sketch line from another sketch.
AxisEntityGeometry | Property that gets the geometry that describes the axis entity.
AxisIsX | Property that defines if the axis entity defines the X or Y axis. True indicates the axis defines the X-axis. Setting this property will fail in the case where the sketch is active.
Consumed | Gets whether the sketch is consumed or not.
CopyToFlatPattern | Property that gets and sets whether a sheet metal folded model sketch should be copied over (transposed) to the flat pattern.
Dependents | Gets the dependent objects of the sketch.
DimensionsVisible | Gets and sets whether the dimensions on the sketch are visible.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
HasReferenceComponent | Property that specifies if the object was created as the result of a derived part. This property returns True in the case where the object is from a derived part. In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsOwnedByFeature | Property that returns whether this object is owned by a feature. This property should return True for sketches that are created as a result of an unfold or refold feature.
ModelToSketchTransform | Property that returns the transformation from model space to the 2d sketch coordinate space.
NaturalAxisDirection | Property that indicates if the sketch plane X or Y axis is in the same direction as that defined by axis entity. True indicates the axis direction is in the same direction as the axis.
OriginPoint | Gets and sets origin of the sketch.
OriginPointGeometry | Property that gets the geometry that describes the origin point.
OwnedBy | Property that returns the PartFeature object. This property should return the UnfoldFeature or RefoldFeature object that created the sketch.
PlanarEntity | Property that gets and sets the planar object that defines the plane of the sketch. Valid input includes planar faces and sketch planes. Setting this property will fail in the case where the sketch is active.
PlanarEntityGeometry | Property that returns the geometry that describes the plane the sketch is based on.
Profiles | Property that returns the Profiles collection object.
ProjectedCuts | Property that returns the ProjectedCuts collection object. This collection provides access to the existing projected cut edges in the sketch and provides functionality to create new projected cut edges.
ReferenceComponent | Property that returns the ReferenceComponent that this feature was created as the result of. If the PlanarSketch belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.
ReferencedEntity | Property that returns the referenced sketch in the cases where this sketch was created as a result of a "derive" operation or copied over to the sheet metal flat pattern from the folded model.
Shared | Property that indicates whether the profile is shared or not.
SketchBlocks | Property that returns the SketchBlocks collection object. Only the first level sketch blocks in the sketch are returned. Use SketchBlock.ChildBlocks property recursively to get sketch blocks at all levels.
SketchToModelTransform | Property that returns the transformation from the 2D sketch coordinate space to model space.
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties


PlanarSketch.Adaptive Property

PlanarSketch.Adaptive Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the sketch is adaptive or not. This is the same as selecting Adaptive on the context menu of a sketch within the browser. This property only applies to sketches within a part, not drawing related sketches.

Visual Basic
Property Adaptive() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.Adaptive Property


PlanarSketch.AxisEntity Property

PlanarSketch.AxisEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the object that defines the X or Y axis of the sketch plane. The AxisIsX property defines whether it is the X or Y axis, and the NaturalAxisDirection property defines the direction of the axis. Valid input is a linear edge, work axis, or a sketch line from another sketch.

Visual Basic
Property AxisEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.AxisEntity Property


PlanarSketch.AxisEntityGeometry Property

PlanarSketch.AxisEntityGeometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the geometry that describes the axis entity.

Visual Basic
Property AxisEntityGeometry() As Line**
See Also

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.AxisEntityGeometry Property


PlanarSketch.AxisIsX Property

PlanarSketch.AxisIsX Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that defines if the axis entity defines the X or Y axis. True indicates the axis defines the X-axis. Setting this property will fail in the case where the sketch is active.

Visual Basic
Property AxisIsX() As VARIANT_BOOL
See Also

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.AxisIsX Property


PlanarSketch.Consumed Property

PlanarSketch.Consumed Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets whether the sketch is consumed or not.

Visual Basic
Property Consumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.Consumed Property


PlanarSketch.CopyToFlatPattern Property

PlanarSketch.CopyToFlatPattern Property
Summary

Property that gets and sets whether a sheet metal folded model sketch should be copied over (transposed) to the flat pattern.

Visual Basic
Property CopyToFlatPattern() As VARIANT_BOOL
Remarks

This property only applies to sheet metal folded model sketches and returns False for all other sketches. If a sketch has been copied over to the flat pattern, setting this property to False has the effect of breaking the link between that flat pattern sketch and the folded model sketch. Setting this property to True always creates a newly copied sketch in the flat pattern.

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.CopyToFlatPattern Property


PlanarSketch.Dependents Property

PlanarSketch.Dependents Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the dependent objects of the sketch.

Visual Basic
Property Dependents() As ObjectsEnumerator**
See Also

Sketch Delete sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.Dependents Property


PlanarSketch.DimensionsVisible Property

PlanarSketch.DimensionsVisible Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets and sets whether the dimensions on the sketch are visible.

Visual Basic
Property DimensionsVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.DimensionsVisible Property


PlanarSketch.Exported Property

PlanarSketch.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.Exported Property


PlanarSketch.HasReferenceComponent Property

PlanarSketch.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies if the object was created as the result of a derived part. This property returns True in the case where the object is from a derived part. In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.HasReferenceComponent Property


PlanarSketch.HealthStatus Property

PlanarSketch.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.HealthStatus Property


PlanarSketch.IsOwnedByFeature Property

PlanarSketch.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether this object is owned by a feature. This property should return True for sketches that are created as a result of an unfold or refold feature.

Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.IsOwnedByFeature Property


PlanarSketch.ModelToSketchTransform Property

PlanarSketch.ModelToSketchTransform Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the transformation from model space to the 2d sketch coordinate space.

Visual Basic
Property ModelToSketchTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.ModelToSketchTransform Property


PlanarSketch.NaturalAxisDirection Property

PlanarSketch.NaturalAxisDirection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates if the sketch plane X or Y axis is in the same direction as that defined by axis entity. True indicates the axis direction is in the same direction as the axis.

Visual Basic
Property NaturalAxisDirection() As VARIANT_BOOL
Example

"Sketch Edit Orientation Example "

This sample demonstrates modifying the orientation of a sketch.

To use this sample, have a part document open that contains a box and run the program.

Public Sub ChangeSketchPlane()
' Set a reference to the part component definition.
' This assumes that a part document is active.
Dim oCompDef As PartComponentDefinition
Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

' Get the first face of the model. This sample assumes a simple
' model where at least the first face is a plane. (A box is a good
' test case.)
Dim oFace As Face
Set oFace = oCompDef.SurfaceBodies.Item(1).Faces.Item(1)

' Create a new sketch
Dim oSketch As PlanarSketch
Set oSketch = oCompDef.Sketches.Add(oFace, True)

' Draw a circle at the origin of the sketch plane.
Dim oCircle As SketchCircle
Set oCircle = oSketch.SketchCircles.AddByCenterRadius( _
ThisApplication.TransientGeometry.CreatePoint2d(0, 0), 1)

' Draw a line along the X axis.
Call oSketch.SketchLines.AddByTwoPoints(oCircle.CenterSketchPoint, _
ThisApplication.TransientGeometry.CreatePoint2d(1, 0))

MsgBox "The sketch will be moved to another face."

' Move the sketch to the second face of the model.
Set oFace = oCompDef.SurfaceBodies.Item(1).Faces.Item(2)
oSketch.PlanarEntity = oFace

MsgBox "Current Origin Point: " & oSketch.OriginPointGeometry.X & ", " & _
oSketch.OriginPointGeometry.Y & ", " & oSketch.OriginPointGeometry.Z & _
Chr(13) & Chr(13) & _
"The origin of the sketch will now be set to the center point."

' Set the origin point to use the center point work point.
oSketch.OriginPoint = oCompDef.WorkPoints.Item(1)

MsgBox "New Origin Point: " & oSketch.OriginPointGeometry.X & ", " & _
oSketch.OriginPointGeometry.Y & ", " & oSketch.OriginPointGeometry.Z & _
Chr(13) & Chr(13) & _
"The origin of the sketch will now be set to the center point."

MsgBox "Current X axis: " & oSketch.AxisEntityGeometry.Direction.X & ", " & _
oSketch.AxisEntityGeometry.Direction.Y & ", " & _
oSketch.AxisEntityGeometry.Direction.Z

MsgBox "The X axis of the sketch will now be redefined."

' Set the axis to be one of the edges of the face.
oSketch.AxisEntity = oFace.Edges.Item(2)

MsgBox "New X axis: " & oSketch.AxisEntityGeometry.Direction.X & ", " & _
oSketch.AxisEntityGeometry.Direction.Y & ", " & _
oSketch.AxisEntityGeometry.Direction.Z

MsgBox "The direction of the axis will now be reversed."

' Reverse the axis direction.
oSketch.NaturalAxisDirection = False

MsgBox "New X axis: " & oSketch.AxisEntityGeometry.Direction.X & ", " & _
oSketch.AxisEntityGeometry.Direction.Y & ", " & _
oSketch.AxisEntityGeometry.Direction.Z

MsgBox "The axis will be changed to define the Y instead of the X axis."

' Change the axis definition.
oSketch.AxisIsX = False
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.NaturalAxisDirection Property


PlanarSketch.OriginPoint Property

PlanarSketch.OriginPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets and sets origin of the sketch.

Visual Basic
Property OriginPoint() As IDispatch*
See Also

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.OriginPoint Property


PlanarSketch.OriginPointGeometry Property

PlanarSketch.OriginPointGeometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the geometry that describes the origin point.

Visual Basic
Property OriginPointGeometry() As Point**
See Also

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.OriginPointGeometry Property


PlanarSketch.OwnedBy Property

PlanarSketch.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the PartFeature object. This property should return the UnfoldFeature or RefoldFeature object that created the sketch.

Visual Basic
Property OwnedBy() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.OwnedBy Property


PlanarSketch.PlanarEntity Property

PlanarSketch.PlanarEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the planar object that defines the plane of the sketch. Valid input includes planar faces and sketch planes. Setting this property will fail in the case where the sketch is active.

Visual Basic
Property PlanarEntity() As IDispatch*
See Also

Sketch Edit Orientation sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.PlanarEntity Property


PlanarSketch.PlanarEntityGeometry Property

PlanarSketch.PlanarEntityGeometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the geometry that describes the plane the sketch is based on.

Visual Basic
Property PlanarEntityGeometry() As Plane**
See Also

Create sheet metal rip feature sample

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.PlanarEntityGeometry Property


PlanarSketch.Profiles Property

PlanarSketch.Profiles Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Profiles collection object.

Visual Basic
Property Profiles() As Profiles**
See Also

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Accessing region properties from a profile sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Derived Parts and Assemblies sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.Profiles Property


PlanarSketch.ProjectedCuts Property

PlanarSketch.ProjectedCuts Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ProjectedCuts collection object. This collection provides access to the existing projected cut edges in the sketch and provides functionality to create new projected cut edges.

Visual Basic
Property ProjectedCuts() As ProjectedCuts**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.ProjectedCuts Property


PlanarSketch.ReferenceComponent Property

PlanarSketch.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponent that this feature was created as the result of. If the PlanarSketch belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.ReferenceComponent Property


PlanarSketch.ReferencedEntity Property

PlanarSketch.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the referenced sketch in the cases where this sketch was created as a result of a "derive" operation or copied over to the sheet metal flat pattern from the folded model.

Visual Basic
Property ReferencedEntity() As PlanarSketch**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.ReferencedEntity Property


PlanarSketch.Shared Property

PlanarSketch.Shared Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates whether the profile is shared or not.

Visual Basic
Property Shared() As VARIANT_BOOL
Example

"Sketch Share Example"

This sample demonstrates setting a sketch so it is shared.

To use this sample, open a part document open that contains at least one extrusion feature and run the sample. The sketch of the first extrusion feature should not already be shared.

Public Sub MakeSketchShared()
' Set a reference to the part component definition.
' This assumes that a part document is active.
Dim oCompDef As PartComponentDefinition
Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

' Get the first extrusion feature in the part.
' This assumes that an extrusion feature exists in the part.
Dim oExtrudeFeature As ExtrudeFeature
Set oExtrudeFeature = oCompDef.Features.ExtrudeFeatures.Item(1)

' Set a reference to the sketch of the feature.
Dim oSketch As PlanarSketch
Set oSketch = oExtrudeFeature.Profile.Parent

' Share the sketch of the feature.
oSketch.Shared = True
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.Shared Property


PlanarSketch.SketchBlocks Property

PlanarSketch.SketchBlocks Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the SketchBlocks collection object. Only the first level sketch blocks in the sketch are returned. Use SketchBlock.ChildBlocks property recursively to get sketch blocks at all levels.

Visual Basic
Property SketchBlocks() As SketchBlocks**
See Also

Create sketch block from an existing sketch sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.SketchBlocks Property


PlanarSketch.SketchToModelTransform Property

PlanarSketch.SketchToModelTransform Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the transformation from the 2D sketch coordinate space to model space.

Visual Basic
Property SketchToModelTransform() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketch Interface > PlanarSketch Properties > PlanarSketch.SketchToModelTransform Property


PlanarSketches Interface

PlanarSketches Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PlanarSketches collection object provides access to all of the objects and provides methods to create additional PlanarSketch objects. See the article in the overviews section.

Class Hierarchy
Inventor::PlanarSketches
Visual Basic
Public Interface PlanarSketches
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.Sketches

FlatPattern.Sketches

PartComponentDefinition.Sketches

See Also

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Set Sketch Visibility sample

Spline - create NURBS sample

Sketch Open for Edit sample

Sketch Delete sample

Projection - project across parts sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Add a punch tool feature sample

Sketch Add Oriented sample

Sketch Add sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface


PlanarSketches Methods

PlanarSketches Methods
Summary

The methods of the PlanarSketches class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sketch based on the input planar entity.
AddWithOrientation | Method that creates a new sketch based on the input planar entity and orientation information.
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Methods


PlanarSketches.Add Method

PlanarSketches.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch based on the input planar entity.

Visual Basic
Sub Add(PlanarEntity As IDispatch, ByRef UseFaceEdges As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] PlanarSketch*)
Parameters
Parameters | Description
PlanarEntity | Input object that defines the planar object the sketch is to be built on. Valid input for this argument includes planar faces and work planes.
UseFaceEdges | Optional input Boolean that specifies if sketch geometry should automatically be created for all of the edges of the input face. This is the behavior when creating a sketch interactively in Autodesk Inventor. This argument is ignored in the case when PlanarEntity is a work plane. The default value of False specifies that no sketch geometry should automatically be created from the face edges.
See Also

Create sheet metal face and fold features sample

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Spline - create NURBS sample

Projection - project across parts sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Add a punch tool feature sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude sketch text sample

Extrude Feature - Create Block with Pocket sample

Add a decal feature sample

Copy a sketch sample

Copy a sketch sample

Example

"Sketch Add Example "

This sample demonstrates the creation of a sketch using the Sketches.Add method. Before using this sample, open a part document that contains a box.

Public Sub AddSketch()
    ' Set a reference to the part component definition.
    ' This assumes that a part document is active.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Get the first face of the model.  This sample assumes a simple
    ' model where at least the first face is a plane.  (A box is a good
    ' test case.)
    Dim oFace As Face
    Set oFace = oCompDef.SurfaceBodies.Item(1).Faces.Item(1)

    ' Create a new sketch.  The second argument specifies to include
    ' the edges of the face in the sketch.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oFace, True)

    ' Change the name.
    oSketch.Name = "My New Sketch"
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Methods > PlanarSketches.Add Method


PlanarSketches.AddWithOrientation Method

PlanarSketches.AddWithOrientation Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch based on the input planar entity and orientation information.

Visual Basic
Sub AddWithOrientation(PlanarEntity As IDispatch, AxisEntity As IDispatch, NaturalAxisDirection As VARIANT_BOOL, AxisIsX As VARIANT_BOOL, Origin As IDispatch, ByRef UseFaceEdges As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] PlanarSketch*)
Parameters
Parameters | Description
PlanarEntity | Input object that defines the planar object the sketch is to be built on. Valid input for this argument includes planar faces and work planes.
AxisEntity | Input object that defines the X or Y axis of the sketch plane (the AxisIsX argument defines which). Valid input includes linear edges, sketch lines from another sketch, and work axes.
NaturalAxisDirection | Input Boolean that defines if the sketch plane X or Y axis is in the same direction as that defined by the input axis entity. True indicates the axis direction is in the same direction as that of the input entity.
AxisIsX | Input Boolean that specifies if the axis entity defines the X or Y axis. True indicates the axis defines the X-axis.
Origin | Input object that defines the origin of the sketch plane. Valid input is a vertex, work point, or a sketch point from another sketch.
UseFaceEdges | Optional input Boolean that specifies if sketch geometry should automatically be created for all of the edges of the input face. This is the behavior when creating a sketch interactively in Autodesk Inventor. This argument is ignored in the case when PlanarEntity is a work plane. The default value of False specifies that no sketch geometry should automatically be created from the face edges.
See Also

Create sheet metal face and cut features sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Extrude Feature - Create Block with Pocket sample

Example

"Sketch Add Oriented Example"

This sample demonstrates the creation of a sketch using the Sketches.AddWithOrientation method. To use this sample, open a part document that contains a box before running the sample code.

Public Sub AddOrientedSketch()
    ' Set a reference to the part component definition.
    ' This assumes that a part document is active.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Get the first face of the model.  This sample assumes a simple
    ' model where at least the first face is a plane.  (A box is a good
    ' test case.)
    Dim oFace As Face
    Set oFace = oCompDef.SurfaceBodies.Item(1).Faces.Item(1)

    ' Get one of the edges of the face to use as the sketch x-axis.
    Dim oEdge As Edge
    Set oEdge = oFace.Edges.Item(2)

    ' Get the start vertex of the edge to use as the origin of the sketch.
    Dim oVertex As Vertex
    Set oVertex = oEdge.StartVertex

    ' Create a new sketch.  This last argument is set to true to cause the
    ' creation of sketch geometry from the edges of the face.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.AddWithOrientation(oFace, oEdge, True, _
                                                        True, oVertex, True)

    ' Change the name.
    oSketch.Name = "My Oriented Sketch"

    ' Draw a circle at the origin of the sketch plane.
    Dim oCircle As SketchCircle
    Set oCircle = oSketch.SketchCircles.AddByCenterRadius( _
                ThisApplication.TransientGeometry.CreatePoint2d(0, 0), 1)

    ' Draw a line along the X axis.
    Call oSketch.SketchLines.AddByTwoPoints(oCircle.CenterSketchPoint, _
                ThisApplication.TransientGeometry.CreatePoint2d(1, 0))

    ' Create one more sketch on another face with the origin defined by
    ' the center point.  (The first workpoint in the collection is the center
    ' point work point.)  In this case, no sketch geometry will be created
    ' since the final argument has been left out and it defaults to false.
    Set oFace = oCompDef.SurfaceBodies.Item(1).Faces.Item(5)
    Set oEdge = oFace.Edges.Item(1)
    Set oSketch = oCompDef.Sketches.AddWithOrientation(oFace, oEdge, True, _
                                                True, oCompDef.WorkPoints.Item(1))

    ' Change the name.
    oSketch.Name = "My Origin Sketch"

    ' Draw a circle at the origin of the sketch plane.
    Set oCircle = oSketch.SketchCircles.AddByCenterRadius( _
                ThisApplication.TransientGeometry.CreatePoint2d(0, 0), 1)

    ' Draw a line along the X axis.
    Call oSketch.SketchLines.AddByTwoPoints(oCircle.CenterSketchPoint, _
                ThisApplication.TransientGeometry.CreatePoint2d(1, 0))
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Methods > PlanarSketches.AddWithOrientation Method


PlanarSketches.Item Method

PlanarSketches.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PlanarSketch*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
See Also

Sketch Open for Edit sample

Copy a sketch sample

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Methods > PlanarSketches.Item Method


PlanarSketches Properties

PlanarSketches Properties
Summary

The properties of the PlanarSketches class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Properties


PlanarSketches.Application Property

PlanarSketches.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Properties > PlanarSketches.Application Property


PlanarSketches.Count Property

PlanarSketches.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Properties > PlanarSketches.Count Property


PlanarSketches.Type Property

PlanarSketches.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketches Interface > PlanarSketches Properties > PlanarSketches.Type Property


PlanarSketchProxy Interface

PlanarSketchProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PlanarSketch object.

Class Hierarchy
Inventor::Sketch
    Inventor::PlanarSketch
        Inventor::PlanarSketchProxy
Visual Basic
Public Interface PlanarSketchProxy
Inherits PlanarSketch
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketchProxy Interface


PlanarSketchProxy Properties

PlanarSketchProxy Properties
Summary

The properties of the PlanarSketchProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PlanarSketchProxy Interface > PlanarSketchProxy Properties


PlanarSketchProxy.ContainingOccurrence Property

PlanarSketchProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketchProxy Interface > PlanarSketchProxy Properties > PlanarSketchProxy.ContainingOccurrence Property


PlanarSketchProxy.NativeObject Property

PlanarSketchProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As PlanarSketch**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PlanarSketchProxy Interface > PlanarSketchProxy Properties > PlanarSketchProxy.NativeObject Property


Plane Interface

Plane Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Plane object. A plane object is infinite. The object created is a transient mathematical object and is not displayed graphically. For more information, see the Transient Geometry article in the overviews section.

Class Hierarchy
Inventor::Plane
Visual Basic
Public Interface Plane
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionConstraint3D.DimensionPlane

DimensionConstraints3D.GetDimensionPlane

GroundPlaneSettings.Plane

PlanarSketch.PlanarEntityGeometry

TransientGeometry.CreatePlane

TransientGeometry.CreatePlaneByThreePoints

WorkPlane.Plane

Face.Geometry

FaceDefinition.SurfaceGeometry

See Also

Create sheet metal rip feature sample

Transient solid body creation sample

OnDrag Event - dragging a WorkPoint sample

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > Plane Interface


Plane Methods

Plane Methods
Summary

The methods of the Plane class are listed here.

Methods
Methods
Name | Description
DistanceTo | Determine the distance between this plane and the specified point.
GetPlaneData | Method that gets the data defining this plane.
IntersectWithCurve | Gets the intersection points of the Plane and the input curve. Note that 3D transient geometry should be supplied. Obtain 3D transient geometry from any sktech entities or 2D geometry before calling this method (for example, by calling the Geometry method of the entity).
IntersectWithLine | Compute the intersection point of this Plane and the specified Line. If the Plane and the Line are parallel, this method will fail.
IntersectWithPlane | Compute the intersection line of this Plane and the specified Plane. If the two Planes are parallel, this method will fail.
IntersectWithSurface | This is IntersectWithSurface, a member of class Plane.
IsCoplanarTo | Property that gets whether this Plane is coplanar with the specified Plane.
IsParallelTo | Property that gets whether this Plane is parallel to the specified Line or Plane.
IsPerpendicularTo | Determine if this Plane is perpendicular to the specified Line or Plane.
PutPlaneData | Method that sets the data defining this plane.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods


Plane.DistanceTo Method

Plane.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Determine the distance between this plane and the specified point.

Visual Basic
Sub DistanceTo(Point As Point, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Input object that specifies the point.
Remarks

This property will return a positive distance if the point is on the positive normal side of the plane, and a negative distance if it is on negative normal side of the plane.

You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.DistanceTo Method


Plane.GetPlaneData Method

Plane.GetPlaneData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets the data defining this plane.

Visual Basic
Sub GetPlaneData(ByRef RootPoint As SAFEARRAY(double), ByRef Normal As SAFEARRAY(double))
Parameters
Parameters | Description
RootPoint | Input/output Double that specifies the root point of the plane.
Normal | Input/output array of Doubles that specifies the normal for the plane.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.GetPlaneData Method


Plane.IntersectWithCurve Method

Plane.IntersectWithCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the intersection points of the Plane and the input curve. Note that 3D transient geometry should be supplied. Obtain 3D transient geometry from any sktech entities or 2D geometry before calling this method (for example, by calling the Geometry method of the entity).

Visual Basic
Sub IntersectWithCurve(Curve As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
Curve | Input object that represents a Curve.
Tolerance | Input Double that specifies the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IntersectWithCurve Method


Plane.IntersectWithLine Method

Plane.IntersectWithLine Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Compute the intersection point of this Plane and the specified Line. If the Plane and the Line are parallel, this method will fail.

Visual Basic
Sub IntersectWithLine(Line As IDispatch, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] Point*)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a Line or LineSegment object.
Tolerance | Input Double that specifies the tolerance.
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IntersectWithLine Method


Plane.IntersectWithPlane Method

Plane.IntersectWithPlane Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Compute the intersection line of this Plane and the specified Plane. If the two Planes are parallel, this method will fail.

Visual Basic
Sub IntersectWithPlane(Plane As Plane, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] Line*)
Parameters
Parameters | Description
Plane | Input Plane object that represents a Plane.
Tolerance | Input Double that specifies the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IntersectWithPlane Method


Plane.IntersectWithSurface Method

Plane.IntersectWithSurface Method
Summary

This is IntersectWithSurface, a member of class Plane.

Visual Basic
Sub IntersectWithSurface(Surface As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IntersectWithSurface Method


Plane.IsCoplanarTo Method

Plane.IsCoplanarTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether this Plane is coplanar with the specified Plane.

Visual Basic
Sub IsCoplanarTo(Plane As Plane, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Plane | Plane to perform coplanar comparison against.
Tolerance | Input Double that specifies the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IsCoplanarTo Method


Plane.IsParallelTo Method

Plane.IsParallelTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether this Plane is parallel to the specified Line or Plane.

Visual Basic
Sub IsParallelTo(LineOrPlane As IDispatch, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
LineOrPlane | Object to perform comparison against.
Tolerance | Input Double that specifies the tolerance.
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IsParallelTo Method


Plane.IsPerpendicularTo Method

Plane.IsPerpendicularTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Determine if this Plane is perpendicular to the specified Line or Plane.

Visual Basic
Sub IsPerpendicularTo(LineOrPlane As IDispatch, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
LineOrPlane | Object to perform comparison against.
Tolerance | Input Double that specifies the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.IsPerpendicularTo Method


Plane.PutPlaneData Method

Plane.PutPlaneData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this plane.

Visual Basic
Sub PutPlaneData(ByRef RootPoint As SAFEARRAY(double), ByRef Normal As SAFEARRAY(double))
Parameters
Parameters | Description
RootPoint | Input/output Double that specifies the root point of the plane.
Normal | Input/output array of Doubles that specifies the normal for the plane.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Methods > Plane.PutPlaneData Method


Plane Properties

Plane Properties
Summary

The properties of the Plane class are listed here.

Properties
Name | Description
Evaluator | Gets the surface evaluator for this plane.
Normal | Property that indicates the vector for a specific normal in the set.
RootPoint | Gets the root point for this plane.
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Properties


Plane.Evaluator Property

Plane.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this plane.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Properties > Plane.Evaluator Property


Plane.Normal Property

Plane.Normal Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the vector for a specific normal in the set.

Visual Basic
Property Normal() As UnitVector*
See Also

Offset a 2D sketch sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Properties > Plane.Normal Property


Plane.RootPoint Property

Plane.RootPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the root point for this plane.

Visual Basic
Property RootPoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Plane Interface > Plane Properties > Plane.RootPoint Property


PlaneAndOffsetWorkPlaneDef Interface

PlaneAndOffsetWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane that is parallel to an existing plane and offset a specified distance.

Class Hierarchy
Inventor::PlaneAndOffsetWorkPlaneDef
Visual Basic
Public Interface PlaneAndOffsetWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface


PlaneAndOffsetWorkPlaneDef Methods

PlaneAndOffsetWorkPlaneDef Methods
Summary

The methods of the PlaneAndOffsetWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work planed defined by a plane, direction and offset. The work plane is parallel to the plane and is offset the specified distance in the specified direction. The sign of the value controls which side of the plane the offset is in. A positive value will be in the positive normal side of the plane.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Methods


PlaneAndOffsetWorkPlaneDef.GetData Method

PlaneAndOffsetWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work planed defined by a plane, direction and offset. The work plane is parallel to the plane and is offset the specified distance in the specified direction. The sign of the value controls which side of the plane the offset is in. A positive value will be in the positive normal side of the plane.

Visual Basic
Sub GetData(ByRef Plane As IDispatch*, ByRef Offset As Parameter*)
Parameters
Parameters | Description
Plane | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object. The work plane is parallel to this plane.
Offset | Output Parameter that defines the offset of the work plane to the plane. The sign of the value controls which side of the plane the offset is in. A positive value will be in the positive normal side of the plane.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Methods > PlaneAndOffsetWorkPlaneDef.GetData Method


PlaneAndOffsetWorkPlaneDef Properties

PlaneAndOffsetWorkPlaneDef Properties
Summary

The properties of the PlaneAndOffsetWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Offset | Property that returns the parameter controlling the offset of the work plane. The offset of the plane can be read and modified by accessing the returned Parameter object.
Parent | Property returning the parent WorkPlane object.
Plane | Property that returns the plane of an offset work plane. This object can be a planar Face, WorkPlane, or Sketch object. The work plane will be parallel to this plane.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Properties


PlaneAndOffsetWorkPlaneDef.Application Property

PlaneAndOffsetWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Properties > PlaneAndOffsetWorkPlaneDef.Application Property


PlaneAndOffsetWorkPlaneDef.Offset Property

PlaneAndOffsetWorkPlaneDef.Offset Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parameter controlling the offset of the work plane. The offset of the plane can be read and modified by accessing the returned Parameter object.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Properties > PlaneAndOffsetWorkPlaneDef.Offset Property


PlaneAndOffsetWorkPlaneDef.Parent Property

PlaneAndOffsetWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Properties > PlaneAndOffsetWorkPlaneDef.Parent Property


PlaneAndOffsetWorkPlaneDef.Plane Property

PlaneAndOffsetWorkPlaneDef.Plane Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the plane of an offset work plane. This object can be a planar Face, WorkPlane, or Sketch object. The work plane will be parallel to this plane.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Properties > PlaneAndOffsetWorkPlaneDef.Plane Property


PlaneAndOffsetWorkPlaneDef.Type Property

PlaneAndOffsetWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndOffsetWorkPlaneDef Interface > PlaneAndOffsetWorkPlaneDef Properties > PlaneAndOffsetWorkPlaneDef.Type Property


PlaneAndPointWorkPlaneDef Interface

PlaneAndPointWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane that is parallel to an existing plane and passes through an existing point.

Class Hierarchy
Inventor::PlaneAndPointWorkPlaneDef
Visual Basic
Public Interface PlaneAndPointWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface


PlaneAndPointWorkPlaneDef Methods

PlaneAndPointWorkPlaneDef Methods
Summary

The methods of the PlaneAndPointWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work planed defined by a plane and a point. The work plane is parallel to the plane and passes through the point.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Methods


PlaneAndPointWorkPlaneDef.GetData Method

PlaneAndPointWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work planed defined by a plane and a point. The work plane is parallel to the plane and passes through the point.

Visual Basic
Sub GetData(ByRef Plane As IDispatch*, ByRef Point As IDispatch*)
Parameters
Parameters | Description
Plane | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Point | Output object that represents a Point. This object can be a WorkPoint, Vertex, or SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Methods > PlaneAndPointWorkPlaneDef.GetData Method


PlaneAndPointWorkPlaneDef Properties

PlaneAndPointWorkPlaneDef Properties
Summary

The properties of the PlaneAndPointWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property returning the parent WorkPlane object.
Plane | Property that returns the plane of a plane and point defined work plane. This object can be a planar Face, WorkPlane, or Sketch object. The work plane is parallel to the plane.
Point | Property that returns the point of a plane and point defined work plane. The point can be a WorkPoint, Vertex, or SketchPoint object. The work plane passes through the point.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Properties


PlaneAndPointWorkPlaneDef.Application Property

PlaneAndPointWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Properties > PlaneAndPointWorkPlaneDef.Application Property


PlaneAndPointWorkPlaneDef.Parent Property

PlaneAndPointWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Properties > PlaneAndPointWorkPlaneDef.Parent Property


PlaneAndPointWorkPlaneDef.Plane Property

PlaneAndPointWorkPlaneDef.Plane Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the plane of a plane and point defined work plane. This object can be a planar Face, WorkPlane, or Sketch object. The work plane is parallel to the plane.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Properties > PlaneAndPointWorkPlaneDef.Plane Property


PlaneAndPointWorkPlaneDef.Point Property

PlaneAndPointWorkPlaneDef.Point Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the point of a plane and point defined work plane. The point can be a WorkPoint, Vertex, or SketchPoint object. The work plane passes through the point.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Properties > PlaneAndPointWorkPlaneDef.Point Property


PlaneAndPointWorkPlaneDef.Type Property

PlaneAndPointWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndPointWorkPlaneDef Interface > PlaneAndPointWorkPlaneDef Properties > PlaneAndPointWorkPlaneDef.Type Property


PlaneAndTangentWorkPlaneDef Interface

PlaneAndTangentWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane that is parallel to a plane and tangent to a surface.

Class Hierarchy
Inventor::PlaneAndTangentWorkPlaneDef
Visual Basic
Public Interface PlaneAndTangentWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface


PlaneAndTangentWorkPlaneDef Methods

PlaneAndTangentWorkPlaneDef Methods
Summary

The methods of the PlaneAndTangentWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work that is parallel to the plane and tangent to the input face.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Methods


PlaneAndTangentWorkPlaneDef.GetData Method

PlaneAndTangentWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work that is parallel to the plane and tangent to the input face.

Visual Basic
Sub GetData(ByRef Plane As IDispatch*, ByRef Face As Face*, ByRef ProximityPoint As Point*)
Parameters
Parameters | Description
Plane | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object. The work plane is parallel to this plane.
Face | Output Face object that indicates the tangent surface. This face will be a cylinder, cone, or sphere.
ProximityPoint | Output object that indicates which of the possible two solutions was used when calculating the tangent plane. The original proximity point itself is not stored. The point returned is calculated as an arbitrary point along the tangent between the face and plane.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Methods > PlaneAndTangentWorkPlaneDef.GetData Method


PlaneAndTangentWorkPlaneDef Properties

PlaneAndTangentWorkPlaneDef Properties
Summary

The properties of the PlaneAndTangentWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Face | Property that returns the tangent of the work plane. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.
Parent | Property returning the parent WorkPlane object.
Plane | Property that returns the plane of a work plane that is parallel to a plane and tangent to a surface. This object can be a planar Face, WorkPlane, or Sketch object. The work plane will be parallel to this plane.
ProximityPoint | Property that returns the proximity point. The proximity point defines which of the two possible solutions is chosen when computing the tangent plane. This point is used for the initial computation and the specific point is not stored. During a recompute of the model the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point. The point returned by this property is as an arbitrary point along the tangent between the face and plane.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties


PlaneAndTangentWorkPlaneDef.Application Property

PlaneAndTangentWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties > PlaneAndTangentWorkPlaneDef.Application Property


PlaneAndTangentWorkPlaneDef.Face Property

PlaneAndTangentWorkPlaneDef.Face Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the tangent of the work plane. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties > PlaneAndTangentWorkPlaneDef.Face Property


PlaneAndTangentWorkPlaneDef.Parent Property

PlaneAndTangentWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties > PlaneAndTangentWorkPlaneDef.Parent Property


PlaneAndTangentWorkPlaneDef.Plane Property

PlaneAndTangentWorkPlaneDef.Plane Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the plane of a work plane that is parallel to a plane and tangent to a surface. This object can be a planar Face, WorkPlane, or Sketch object. The work plane will be parallel to this plane.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties > PlaneAndTangentWorkPlaneDef.Plane Property


PlaneAndTangentWorkPlaneDef.ProximityPoint Property

PlaneAndTangentWorkPlaneDef.ProximityPoint Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the proximity point. The proximity point defines which of the two possible solutions is chosen when computing the tangent plane. This point is used for the initial computation and the specific point is not stored. During a recompute of the model the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point. The point returned by this property is as an arbitrary point along the tangent between the face and plane.

Visual Basic
Property ProximityPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties > PlaneAndTangentWorkPlaneDef.ProximityPoint Property


PlaneAndTangentWorkPlaneDef.Type Property

PlaneAndTangentWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PlaneAndTangentWorkPlaneDef Interface > PlaneAndTangentWorkPlaneDef Properties > PlaneAndTangentWorkPlaneDef.Type Property


Point Interface

Point Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Point object. The object is a transient mathematical object and is not displayed graphically. For more information see the Transient Geometry article in the overviews section.

Class Hierarchy
Inventor::Point
Visual Basic
Public Interface Point
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Arc3d.Center

Arc3d.EndPoint

Arc3d.StartPoint

AssemblyWorkAxisDef.OriginPoint

AssemblyWorkPlaneDef.OriginPoint

AssemblyWorkPointDef.Point

Box.MaxPoint

Box.MinPoint

BSplineCurve.PoleAtIndex

BSplineSurface.PoleAtIndex

Camera.Eye

Camera.Target

Camera.ViewToModelSpace

Circle.Center

Cone.BasePoint

Cylinder.BasePoint

DimensionConstraint3D.TextPoint

Edge.PointOnEdge

Edge.GetClosestPointTo

EllipseFull.Center

EllipticalArc.Center

EllipticalArc.EndPoint

EllipticalArc.StartPoint

EllipticalCone.BasePoint

EllipticalCylinder.BasePoint

Face.PointOnFace

Face.GetClosestPointTo

FeatureDimension.TextPoint

FilletConstantRadiusFaceSet.BiasPoint

FixedWorkAxisDef.OriginPoint

FixedWorkPlaneDef.OriginPoint

FixedWorkPointDef.Point

FlatPunchResult.FoldedPosition

FlatPunchResult.Position

GraphicsCoordinateSet.Coordinate

InterferenceResult.Centroid

Light.Position

Line.RootPoint

LineAndTangentWorkPlaneDef.ProximityPoint

LineSegment.EndPoint

LineSegment.MidPoint

LineSegment.StartPoint

MapPointCurve.GetPositionPoint

MassProperties.CenterOfMass

PlanarSketch.OriginPointGeometry

PlanarSketch.SketchToModelSpace

Plane.RootPoint

Plane.IntersectWithLine

PlaneAndTangentWorkPlaneDef.ProximityPoint

Polyline3d.PointAtIndex

SketchArc3D.CenterPoint

SketchCircle3D.CenterPoint

SketchEllipse3D.CenterPoint

SketchEllipticalArc3D.CenterPoint

SketchPoint3D.Geometry

Sphere.CenterPoint

TextGraphics.Anchor

TextureCoordinateSet.Item

Torus.CenterPoint

TransientGeometry.CreatePoint

Vertex.Point

VertexDefinition.Position

Weld.SymbolAttachPoint

Weld.SymbolBreakPoint

WorkPoint.Point

See Also

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

True length of sweep feature sample

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > Point Interface


Point Methods

Point Methods
Summary

The methods of the Point class are listed here.

Methods
Methods
Name | Description
DistanceTo | Determine the distance between this point and the specified point.
GetPointData | Get the data defining this point.
IsEqualTo | Compares this point for equality with the specified point.
PutPointData | Method that sets the data defining this point.
TransformBy | Transform this point by the specified matrix.
TranslateBy | Translate this point by the specified vector.
VectorTo | Gets the vector of translation between this point and the specified point.
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods


Point.DistanceTo Method

Point.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine the distance between this point and the specified point.

Visual Basic
Sub DistanceTo(Point As Point, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Input object that specifies the point.
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.DistanceTo Method


Point.GetPointData Method

Point.GetPointData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this point.

Visual Basic
Sub GetPointData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.GetPointData Method


Point.IsEqualTo Method

Point.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Compares this point for equality with the specified point.

Visual Basic
Sub IsEqualTo(Point As Point, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Input object that specifies the point.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the points are equal.
See Also

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.IsEqualTo Method


Point.PutPointData Method

Point.PutPointData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this point.

Visual Basic
Sub PutPointData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.PutPointData Method


Point.TransformBy Method

Point.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Transform this point by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies the matrix to transform by.
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.TransformBy Method


Point.TranslateBy Method

Point.TranslateBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Translate this point by the specified vector.

Visual Basic
Sub TranslateBy(Vector As Vector)
Parameters
Parameters | Description
Vector | Input Vector object that specifies the vector to translate by.
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.TranslateBy Method


Point.VectorTo Method

Point.VectorTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the vector of translation between this point and the specified point.

Visual Basic
Sub VectorTo(Point As Point, Result As [out, retval] Vector*)
Parameters
Parameters | Description
Point | Input object that specifies the point.
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Methods > Point.VectorTo Method


Point Properties

Point Properties
Summary

The properties of the Point class are listed here.

Properties
Name | Description
X | Specifies the X coordinate of the point. If not supplied, the X value will default to 0.
Y | Specifies the Y coordinate of the point. If not supplied, the Y value will default to 0.
Z | Specifies the Z coordinate of the point. If not supplied, the Z value will default to 0.
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Properties


Point.X Property

Point.X Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the X coordinate of the point. If not supplied, the X value will default to 0.

Visual Basic
Property X() As double
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Properties > Point.X Property


Point.Y Property

Point.Y Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Y coordinate of the point. If not supplied, the Y value will default to 0.

Visual Basic
Property Y() As double
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Properties > Point.Y Property


Point.Z Property

Point.Z Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Z coordinate of the point. If not supplied, the Z value will default to 0.

Visual Basic
Property Z() As double
You are here: Symbol Reference > Inventor Library > Objects > Point Interface > Point Properties > Point.Z Property


Point2d Interface

Point2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Point2d object. The object created is a transient mathematical object and is not displayed graphically. Also, for more information see the Transient Geometry article in the overview section.

Class Hierarchy
Inventor::Point2d
Visual Basic
Public Interface Point2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Arc2d.Center

Arc2d.EndPoint

Arc2d.StartPoint

AutoCADBlock.Position

Balloon.Position

Box2d.MaxPoint

Box2d.MinPoint

BreakOperation.EndPoint

BreakOperation.MidPoint

BreakOperation.StartPoint

BSplineCurve2d.PoleAtIndex

Camera.ModelToViewSpace

Centerline.EndPoint

Centerline.StartPoint

Centermark.ExtensionPointFour

Centermark.ExtensionPointOne

Centermark.ExtensionPointThree

Centermark.ExtensionPointTwo

Centermark.Position

Circle2d.Center

CustomTable.Position

DetailDrawingView.FenceCenter

DetailDrawingView.FenceCornerOne

DetailDrawingView.FenceCornerTwo

DimensionConstraint.DimensionCenterPoint

DimensionConstraint.TextPoint

DimensionText.Origin

DrawingCurve.CenterPoint

DrawingCurve.EndPoint

DrawingCurve.MidPoint

DrawingCurve.StartPoint

DrawingCurveSegment.EndPoint

DrawingCurveSegment.StartPoint

DrawingNote.Position

DrawingSketch.SheetToSketchSpace

DrawingSketch.SketchToSheetSpace

DrawingView.Center

DrawingView.Position

DrawingView.DrawingViewToSheetSpace

DrawingView.ModelToDrawingViewSpace

DrawingView.ModelToSheetSpace

DrawingView.SheetToDrawingViewSpace

DrawingViewLabel.Position

EllipseFull2d.Center

EllipticalArc2d.Center

EllipticalArc2d.EndPoint

EllipticalArc2d.StartPoint

FeatureControlFrame.Position

GeometryIntent.PointOnSheet

HoleTable.Position

HoleTag.Position

LeaderNode.Position

Line2d.RootPoint

LineSegment2d.EndPoint

LineSegment2d.MidPoint

LineSegment2d.StartPoint

OrdinateDimension.JogPointOne

OrdinateDimension.JogPointTwo

PartsList.Position

PlanarSketch.ModelToSketchSpace

Polyline2d.PointAtIndex

RevisionTable.Position

SketchBlock.Position

SketchedSymbol.Position

SketchImage.Position

SketchPoint.Geometry

SurfaceTextureSymbol.Position

TangentDistanceDimConstraint.ProximityPointOne

TangentDistanceDimConstraint.ProximityPointTwo

TextBox.Origin

TitleBlock.Position

TransientGeometry.CreatePoint2d

RegionProperties.Centroid

See Also

Aligning drawing dimensions sample

Sketch Text Add sample

True length of sweep feature sample

Sweep Feature Add sample

Sketch Spline sample

Spline - create NURBS sample

Create sketch elliptical arc sample

Create sketched symbol and leader sample

Offset a 2D sketch sample

Create sheet metal face and cut features sample

Creating a parts list sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Add a decal feature sample

Create a drawing Excel Table sample

Create a Bend Table sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface


Point2d Methods

Point2d Methods
Summary

The methods of the Point2d class are listed here.

Methods
Methods
Name | Description
DistanceTo | Method that returns the distance between this point and the specified point.
GetPointData | Get the data defining this point.
IsEqualTo |
PutPointData | Method that sets the data defining this point.
TransformBy |
TranslateBy |
VectorTo |
You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods


Point2d.DistanceTo Method

Point2d.DistanceTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the distance between this point and the specified point.

Visual Basic
Sub DistanceTo(Point As Point2d, Result As [out, retval] double)
Parameters
Parameters | Description
Point | Point2d object that specifies the point to which the distance is to be returned.
See Also

Finding Bend Extent (Tangent) Edges sample

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.DistanceTo Method


Point2d.GetPointData Method

Point2d.GetPointData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this point.

Visual Basic
Sub GetPointData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.GetPointData Method


Point2d.IsEqualTo Method

Point2d.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub IsEqualTo(Point As Point2d, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] VARIANT_BOOL)
Notes

For information on this item, please refer to Point::IsEqualTo, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.IsEqualTo Method


Point2d.PutPointData Method

Point2d.PutPointData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this point.

Visual Basic
Sub PutPointData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.PutPointData Method


Point2d.TransformBy Method

Point2d.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub TransformBy(Matrix As Matrix2d)
Notes

For information on this item, please refer to Point::TransformBy, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.TransformBy Method


Point2d.TranslateBy Method

Point2d.TranslateBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub TranslateBy(Vector As Vector2d)
Notes

For information on this item, please refer to Point::TranslateBy, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.TranslateBy Method


Point2d.VectorTo Method

Point2d.VectorTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub VectorTo(Point As Point2d, Result As [out, retval] Vector2d*)
Notes

For information on this item, please refer to Point::VectorTo, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Methods > Point2d.VectorTo Method


Point2d Properties

Point2d Properties
Summary

The properties of the Point2d class are listed here.

Properties
Name | Description
X | Specifies the X coordinate of the point. If not supplied, the X value will default to 0.
Y | Specifies the Y coordinate of the point. If not supplied, the Y value will default to 0.
You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Properties


Point2d.X Property

Point2d.X Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the X coordinate of the point. If not supplied, the X value will default to 0.

Visual Basic
Property X() As double
See Also

Aligning drawing dimensions sample

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Properties > Point2d.X Property


Point2d.Y Property

Point2d.Y Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Y coordinate of the point. If not supplied, the Y value will default to 0.

Visual Basic
Property Y() As double
See Also

Aligning drawing dimensions sample

You are here: Symbol Reference > Inventor Library > Objects > Point2d Interface > Point2d Properties > Point2d.Y Property


PointAndPlaneDistanceDimConstraint3D Interface

PointAndPlaneDistanceDimConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PointAndPlaneDistanceDimConstraint3D object represents a constraint that controls the distance between a 3D sketch point and a planar face or workplane.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::PointAndPlaneDistanceDimConstraint3D
        Inventor::PointAndPlaneDistanceDimConstraint3DProxy
Visual Basic
Public Interface PointAndPlaneDistanceDimConstraint3D
Inherits DimensionConstraint3D
Notes

Members through which this object may be accessed include:

DimensionConstraints3D.AddPointAndPlaneDistance

PointAndPlaneDistanceDimConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3D Interface


PointAndPlaneDistanceDimConstraint3D Properties

PointAndPlaneDistanceDimConstraint3D Properties
Summary

The properties of the PointAndPlaneDistanceDimConstraint3D class are listed here.

Properties
Name | Description
Plane | Property that returns the planar Face or WorkPlane object that defines the distance to the 3D sketch point being constrained.
Point | Property that returns the 3D sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3D Interface > PointAndPlaneDistanceDimConstraint3D Properties


PointAndPlaneDistanceDimConstraint3D.Plane Property

PointAndPlaneDistanceDimConstraint3D.Plane Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the planar Face or WorkPlane object that defines the distance to the 3D sketch point being constrained.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3D Interface > PointAndPlaneDistanceDimConstraint3D Properties > PointAndPlaneDistanceDimConstraint3D.Plane Property


PointAndPlaneDistanceDimConstraint3D.Point Property

PointAndPlaneDistanceDimConstraint3D.Point Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the 3D sketch point being constrained.

Visual Basic
Property Point() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3D Interface > PointAndPlaneDistanceDimConstraint3D Properties > PointAndPlaneDistanceDimConstraint3D.Point Property


PointAndPlaneDistanceDimConstraint3DProxy Interface

PointAndPlaneDistanceDimConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PointAndPlaneDistanceDimConstraint3D object.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::PointAndPlaneDistanceDimConstraint3D
        Inventor::PointAndPlaneDistanceDimConstraint3DProxy
Visual Basic
Public Interface PointAndPlaneDistanceDimConstraint3DProxy
Inherits PointAndPlaneDistanceDimConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3DProxy Interface


PointAndPlaneDistanceDimConstraint3DProxy Properties

PointAndPlaneDistanceDimConstraint3DProxy Properties
Summary

The properties of the PointAndPlaneDistanceDimConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3DProxy Interface > PointAndPlaneDistanceDimConstraint3DProxy Properties


PointAndPlaneDistanceDimConstraint3DProxy.ContainingOccurrence Property

PointAndPlaneDistanceDimConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3DProxy Interface > PointAndPlaneDistanceDimConstraint3DProxy Properties > PointAndPlaneDistanceDimConstraint3DProxy.ContainingOccurrence Property


PointAndPlaneDistanceDimConstraint3DProxy.NativeObject Property

PointAndPlaneDistanceDimConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As PointAndPlaneDistanceDimConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneDistanceDimConstraint3DProxy Interface > PointAndPlaneDistanceDimConstraint3DProxy Properties > PointAndPlaneDistanceDimConstraint3DProxy.NativeObject Property


PointAndPlaneWorkAxisDef Interface

PointAndPlaneWorkAxisDef Interface
Summary

Object that allows you to get and set the information that specifies a work axis that is normal to a plane and passes through a point.

Class Hierarchy
Inventor::PointAndPlaneWorkAxisDef
Visual Basic
Public Interface PointAndPlaneWorkAxisDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface


PointAndPlaneWorkAxisDef Methods

PointAndPlaneWorkAxisDef Methods
Summary

The methods of the PointAndPlaneWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work axis that is normal to a plane and passes through a point.
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Methods


PointAndPlaneWorkAxisDef.GetData Method

PointAndPlaneWorkAxisDef.GetData Method
Summary

Method that gets all of the data defining a work axis that is normal to a plane and passes through a point.

Visual Basic
Sub GetData(ByRef Point As IDispatch*, ByRef Plane As IDispatch*)
Parameters
Parameters | Description
Point | Output object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Plane | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Methods > PointAndPlaneWorkAxisDef.GetData Method


PointAndPlaneWorkAxisDef Properties

PointAndPlaneWorkAxisDef Properties
Summary

The properties of the PointAndPlaneWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property returning the parent WorkAxis object.
Plane | Property that returns the plane of a work axis that is normal to a plane and passes through a point. This object can be a planar Face, WorkPlane, or Sketch object.
Point | Property that returns the point of a work axis that is normal to a plane and passes through a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Properties


PointAndPlaneWorkAxisDef.Application Property

PointAndPlaneWorkAxisDef.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Properties > PointAndPlaneWorkAxisDef.Application Property


PointAndPlaneWorkAxisDef.Parent Property

PointAndPlaneWorkAxisDef.Parent Property
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Properties > PointAndPlaneWorkAxisDef.Parent Property


PointAndPlaneWorkAxisDef.Plane Property

PointAndPlaneWorkAxisDef.Plane Property
Summary

Property that returns the plane of a work axis that is normal to a plane and passes through a point. This object can be a planar Face, WorkPlane, or Sketch object.

Visual Basic
Property Plane() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Properties > PointAndPlaneWorkAxisDef.Plane Property


PointAndPlaneWorkAxisDef.Point Property

PointAndPlaneWorkAxisDef.Point Property
Summary

Property that returns the point of a work axis that is normal to a plane and passes through a point. This object can be a WorkPoint, Vertex, or SketchPoint object.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Properties > PointAndPlaneWorkAxisDef.Point Property


PointAndPlaneWorkAxisDef.Type Property

PointAndPlaneWorkAxisDef.Type Property
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointAndPlaneWorkAxisDef Interface > PointAndPlaneWorkAxisDef Properties > PointAndPlaneWorkAxisDef.Type Property


PointAndTangentWorkPlaneDef Interface

PointAndTangentWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

Object that allows you to get and set the information that specifies a work plane that passes through a point and is tangent to a surface.

Class Hierarchy
Inventor::PointAndTangentWorkPlaneDef
Visual Basic
Public Interface PointAndTangentWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface


PointAndTangentWorkPlaneDef Methods

PointAndTangentWorkPlaneDef Methods
Summary

The methods of the PointAndTangentWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work that passes through a point and is tangent to the input face.
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Methods


PointAndTangentWorkPlaneDef.GetData Method

PointAndTangentWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that gets all of the data defining a work that passes through a point and is tangent to the input face.

Visual Basic
Sub GetData(ByRef Point As IDispatch*, ByRef Face As Face*)
Parameters
Parameters | Description
Point | Output object that represents a point. This object can be a Vertex, WorkPoint, or SketchPoint, or SketchPoint3D object. The work plane passes through this point.
Face | Output Face object that indicates the tangent surface. This face will be a cylinder, cone, sphere or a bspline surface.
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Methods > PointAndTangentWorkPlaneDef.GetData Method


PointAndTangentWorkPlaneDef Properties

PointAndTangentWorkPlaneDef Properties
Summary

The properties of the PointAndTangentWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Face | Property that returns the tangent face of the work plane. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, a sphere or a bspline surface.
Parent | Property that returns the parent WorkPlane object.
Point | Property that returns the point of a work plane that passes through a point and is tangent to a surface. This object can be a Vertex, WorkPoint, SketchPoint, or SketchPoint3D object.
Type | Property that returns kPointAndTangentWorkPlaneDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Properties


PointAndTangentWorkPlaneDef.Application Property

PointAndTangentWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Properties > PointAndTangentWorkPlaneDef.Application Property


PointAndTangentWorkPlaneDef.Face Property

PointAndTangentWorkPlaneDef.Face Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the tangent face of the work plane. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, a sphere or a bspline surface.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Properties > PointAndTangentWorkPlaneDef.Face Property


PointAndTangentWorkPlaneDef.Parent Property

PointAndTangentWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Properties > PointAndTangentWorkPlaneDef.Parent Property


PointAndTangentWorkPlaneDef.Point Property

PointAndTangentWorkPlaneDef.Point Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the point of a work plane that passes through a point and is tangent to a surface. This object can be a Vertex, WorkPoint, SketchPoint, or SketchPoint3D object.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Properties > PointAndTangentWorkPlaneDef.Point Property


PointAndTangentWorkPlaneDef.Type Property

PointAndTangentWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns kPointAndTangentWorkPlaneDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointAndTangentWorkPlaneDef Interface > PointAndTangentWorkPlaneDef Properties > PointAndTangentWorkPlaneDef.Type Property


PointGraphics Interface

PointGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PointGraphics object defines a set of points. Each coordinate provided defines a point.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::PointGraphics
Visual Basic
Public Interface PointGraphics
Inherits GraphicsPrimitive
Notes

Members through which this object may be accessed include:

GraphicsNode.AddPointGraphics

See Also

Client graphics - image in point graphics sample

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface


PointGraphics Methods

PointGraphics Methods
Summary

The methods of the PointGraphics class are listed here.

Methods
Methods
Name | Description
GetCustomImage | Method that gets the image used for this PointGraphics object. This is only valid in the case where the PointRenderStyle property returns kCustomImagePointStyle, otherwise this method will fail.
SetCustomImage | Method that sets the custom image to use for this PointGraphics object. This is cause the PointerRenderStyleProperty to return kCustomImagePointStyle. You can remove the custom image by setting the PointRenderStyle to one of the predefined point types.
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Methods


PointGraphics.GetCustomImage Method

PointGraphics.GetCustomImage Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that gets the image used for this PointGraphics object. This is only valid in the case where the PointRenderStyle property returns kCustomImagePointStyle, otherwise this method will fail.

Visual Basic
Sub GetCustomImage(ByRef GraphicsImageSet As GraphicsImageSet*, ByRef GraphicsImageIndex As long)
Parameters
Parameters | Description
GraphicsImageSet | Output GraphicsImageSet that is currently assigned to this PointGraphics object.
GraphicsImageIndex | Output Long that indicates which image in the GraphicsImageSet is currently being used by this PointGraphics object.
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Methods > PointGraphics.GetCustomImage Method


PointGraphics.SetCustomImage Method

PointGraphics.SetCustomImage Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that sets the custom image to use for this PointGraphics object. This is cause the PointerRenderStyleProperty to return kCustomImagePointStyle. You can remove the custom image by setting the PointRenderStyle to one of the predefined point types.

Visual Basic
Sub SetCustomImage(GraphicsImageSet As GraphicsImageSet, GraphicsImageIndex As long)
Parameters
Parameters | Description
GraphicsImageSet | Input GraphicsImageSet to assign to this PointGraphics object.
GraphicsImageIndex | Input Long that indicates which image in the GraphicsImageSet to use for this PointGraphics object.
Example

Client graphics - image in point graphics example.

The following sample demonstrates creation of point client graphics with a custom image. The sample assumes that you've placed a MyImage.bmp in the C:\Temp\ directory.

Public Sub ImageInPointClientGraphics()
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active document.
    ' This assumes that a part or assembly document is active.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Check to see if the test graphics data object already exists.
    ' If it does clean up by removing all associated of the client graphics
    ' from the document.  If it doesn't create it.
    On Error Resume Next
    Dim oGraphicsData As GraphicsDataSets
    Set oGraphicsData = oDoc.GraphicsDataSetsCollection.Item("SampleGraphicsID")
    If Err.Number = 0 Then
        On Error GoTo 0
        ' An existing client graphics object was successfully obtained so clean up.
        oGraphicsData.Delete
        oCompDef.ClientGraphicsCollection.Item("SampleGraphicsID").Delete

        ' update the display to see the results.
        ThisApplication.ActiveView.Update
    Else
        Err.Clear
        On Error GoTo 0

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create a graphics data set object.  This object contains all of the
        ' information used to define the graphics.
        Dim oDataSets As GraphicsDataSets
        Set oDataSets = oDoc.GraphicsDataSetsCollection.Add("SampleGraphicsID")

        ' Create a coordinate set.
        Dim oCoordSet As GraphicsCoordinateSet
        Set oCoordSet = oDataSets.CreateCoordinateSet(1)

        ' Create an array that contains coordinates that define a set
        ' of outwardly spiraling points.
        Dim oPointCoords(2) As Double
        oPointCoords(0) = 1
        oPointCoords(1) = 1
        oPointCoords(2) = 0

        ' Assign the points into the coordinate set.
        Call oCoordSet.PutCoordinates(oPointCoords)

        ' Create an image set
        Dim oImageSet As GraphicsImageSet
        Set oImageSet = oDataSets.CreateImageSet(2)

        Dim oImage As IPictureDisp
        Set oImage = LoadPicture("C:\Temp\MyImage.bmp")

        Call oImageSet.Add(1, oImage)

        ' Create the ClientGraphics object.
        Dim oClientGraphics As ClientGraphics
        Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("SampleGraphicsID")

        ' Create a new graphics node within the client graphics objects.
        Dim oPointNode As GraphicsNode
        Set oPointNode = oClientGraphics.AddNode(1)

        ' Create a PointGraphics object within the node.
        Dim oPointGraphics As PointGraphics
        Set oPointGraphics = oPointNode.AddPointGraphics

        ' Assign the coordinate set to the point graphics.
        oPointGraphics.CoordinateSet = oCoordSet

        ' Set a custom image
        Call oPointGraphics.SetCustomImage(oImageSet, 1)

        ' Update the view.
        ThisApplication.ActiveView.Update
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Methods > PointGraphics.SetCustomImage Method


PointGraphics Properties

PointGraphics Properties
Summary

The properties of the PointGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
CoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the points of the set.
CoordinateSet | Property that gets and sets the GraphicsCoordinateSet associated with the set.
DepthPriority | Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
PointRenderStyle | Property that gets and sets the point style associated with the PointGraphics object.
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Properties


PointGraphics.BurnThrough Property

PointGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Properties > PointGraphics.BurnThrough Property


PointGraphics.CoordinateIndexSet Property

PointGraphics.CoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the points of the set.

Visual Basic
Property CoordinateIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Properties > PointGraphics.CoordinateIndexSet Property


PointGraphics.CoordinateSet Property

PointGraphics.CoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsCoordinateSet associated with the set.

Visual Basic
Property CoordinateSet() As GraphicsCoordinateSet*
See Also

Client graphics - image in point graphics sample

You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Properties > PointGraphics.CoordinateSet Property


PointGraphics.DepthPriority Property

PointGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Properties > PointGraphics.DepthPriority Property


PointGraphics.PointRenderStyle Property

PointGraphics.PointRenderStyle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the point style associated with the PointGraphics object.

Visual Basic
Property PointRenderStyle() As PointRenderStyleEnum
See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > PointGraphics Interface > PointGraphics Properties > PointGraphics.PointRenderStyle Property


PointHolePlacementDefinition Interface

PointHolePlacementDefinition Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The PointHolePlacementDefinition object defines the placement of a hole feature using a work point.

Class Hierarchy
Inventor::HolePlacementDefinition
    Inventor::PointHolePlacementDefinition
Visual Basic
Public Interface PointHolePlacementDefinition
Inherits HolePlacementDefinition
Notes

Members through which this object may be accessed include:

HoleFeatures.CreatePointPlacementDefinition

You are here: Symbol Reference > Inventor Library > Objects > PointHolePlacementDefinition Interface


PointHolePlacementDefinition Properties

PointHolePlacementDefinition Properties
Summary

The properties of the PointHolePlacementDefinition class are listed here.

Properties
Name | Description
Direction | Property that indicates the entity that defines the hole axis direction. This can be a planar Face object or a WorkPlane object with which the axis of the hole is perpendicular, or an Edge or WorkAxis object with which the axis of the hole is parallel.
Point | Property that indicates the point that defines the hole center. This can only be a WorkPoint.
You are here: Symbol Reference > Inventor Library > Objects > PointHolePlacementDefinition Interface > PointHolePlacementDefinition Properties


PointHolePlacementDefinition.Direction Property

PointHolePlacementDefinition.Direction Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the entity that defines the hole axis direction. This can be a planar Face object or a WorkPlane object with which the axis of the hole is perpendicular, or an Edge or WorkAxis object with which the axis of the hole is parallel.

Visual Basic
Property Direction() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointHolePlacementDefinition Interface > PointHolePlacementDefinition Properties > PointHolePlacementDefinition.Direction Property


PointHolePlacementDefinition.Point Property

PointHolePlacementDefinition.Point Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates the point that defines the hole center. This can only be a WorkPoint.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointHolePlacementDefinition Interface > PointHolePlacementDefinition Properties > PointHolePlacementDefinition.Point Property


PointInference Interface

PointInference Interface Available in Inventor Introduced in Inventor 5
Summary

The PointInference object provides access to information that defines how the current point is being inferred.

Class Hierarchy
Inventor::PointInference
Visual Basic
Public Interface PointInference
Inherits IDispatch
Remarks

Point inference occurs automatically in Autodesk Inventor as the user moves the mouse in a sketch. When they move the mouse over an existing sketch entity it 'snaps' onto the sketch entity to indicate that you are on the entity. It also infers when you are close to a point, when you are at the intersection of two sketch entities, and when you're close to the midpoint of a sketch entity. Having the point inference information can be useful to the programmer when creating new sketch entities based on the users input. Using the inference data you have enough information to place constraints that define the intent the user specified through the mouse.

Notes

Members through which this object may be accessed include:

PointInferenceEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > PointInference Interface


PointInference Properties

PointInference Properties
Summary

The properties of the PointInference class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Entity | Property that returns the object(s) that were used in defining the inference. The enumerator contains a single GeometryIntent object when a drawing document is active.
InferenceType | Property that returns the type of inference.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PointInference Interface > PointInference Properties


PointInference.Application Property

PointInference.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointInference Interface > PointInference Properties > PointInference.Application Property


PointInference.Entity Property

PointInference.Entity Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the object(s) that were used in defining the inference. The enumerator contains a single GeometryIntent object when a drawing document is active.

Visual Basic
Property Entity() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > PointInference Interface > PointInference Properties > PointInference.Entity Property


PointInference.InferenceType Property

PointInference.InferenceType Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the type of inference.

Visual Basic
Property InferenceType() As PointInferenceEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointInference Interface > PointInference Properties > PointInference.InferenceType Property


PointInference.Type Property

PointInference.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointInference Interface > PointInference Properties > PointInference.Type Property


PointInferenceEnumerator Interface

PointInferenceEnumerator Interface Available in Inventor Introduced in Inventor 5
Summary

This object returns all of the information gleaned by Autodesk Inventor's inferencing facility applied to a mouse position. This object is returned via the MouseEvents object.

Class Hierarchy
Inventor::PointInferenceEnumerator
Visual Basic
Public Interface PointInferenceEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

MouseEventsObject.PointInferences

You are here: Symbol Reference > Inventor Library > Objects > PointInferenceEnumerator Interface


PointInferenceEnumerator Methods

PointInferenceEnumerator Methods
Summary

The methods of the PointInferenceEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified PointInference object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > PointInferenceEnumerator Interface > PointInferenceEnumerator Methods


PointInferenceEnumerator.Item Method

PointInferenceEnumerator.Item Method Available in Inventor Introduced in Inventor 5
Summary

Property that returns the specified PointInference object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] PointInference*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the PointInference to return.
You are here: Symbol Reference > Inventor Library > Objects > PointInferenceEnumerator Interface > PointInferenceEnumerator Methods > PointInferenceEnumerator.Item Method


PointInferenceEnumerator Properties

PointInferenceEnumerator Properties
Summary

The properties of the PointInferenceEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of PointInference objects in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PointInferenceEnumerator Interface > PointInferenceEnumerator Properties


PointInferenceEnumerator.Count Property

PointInferenceEnumerator.Count Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the number of PointInference objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PointInferenceEnumerator Interface > PointInferenceEnumerator Properties > PointInferenceEnumerator.Count Property


PointInferenceEnumerator.Type Property

PointInferenceEnumerator.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointInferenceEnumerator Interface > PointInferenceEnumerator Properties > PointInferenceEnumerator.Type Property


PointToPointRipTypeDef Interface

PointToPointRipTypeDef Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The PointToPointRipTypeDef object defines the inputs unique to a point to point rip feature.

Class Hierarchy
Inventor::PointToPointRipTypeDef
Visual Basic
Public Interface PointToPointRipTypeDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface


PointToPointRipTypeDef Properties

PointToPointRipTypeDef Properties
Summary

The properties of the PointToPointRipTypeDef class are listed here.

Properties
Name | Description
GapSide | Property that gets and sets the value that indicates the position of the gap. Valid values are kPositiveExtentDirection, kNegativeExtentDirection, and kSymmetricExtentDirection. kPositiveExtentDirection indicates that the material will be removed from the right from the perspective of the first rip point where 'up' is along the normal of the rip face and you're looking towards the second rip point.
GapSize | Property that returns the parameter controlling the width of the gap. When creating a new rip feature and the RipDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSinglePointRipType method of the RipDefinition to set this value in that case. When this object is obtained from an existing rip feature you can edit the rip feature by modifying the parameter this property returns.
Parent | Property that returns the parent rip definition feature.
PointOne | Property that gets and sets the first point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.
PointTwo | Property that gets and sets the first point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties


PointToPointRipTypeDef.GapSide Property

PointToPointRipTypeDef.GapSide Property Introduced in Inventor 2011
Summary

Property that gets and sets the value that indicates the position of the gap. Valid values are kPositiveExtentDirection, kNegativeExtentDirection, and kSymmetricExtentDirection. kPositiveExtentDirection indicates that the material will be removed from the right from the perspective of the first rip point where 'up' is along the normal of the rip face and you're looking towards the second rip point.

Visual Basic
Property GapSide() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties > PointToPointRipTypeDef.GapSide Property


PointToPointRipTypeDef.GapSize Property

PointToPointRipTypeDef.GapSize Property Introduced in Inventor 2011
Summary

Property that returns the parameter controlling the width of the gap. When creating a new rip feature and the RipDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSinglePointRipType method of the RipDefinition to set this value in that case. When this object is obtained from an existing rip feature you can edit the rip feature by modifying the parameter this property returns.

Visual Basic
Property GapSize() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties > PointToPointRipTypeDef.GapSize Property


PointToPointRipTypeDef.Parent Property

PointToPointRipTypeDef.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent rip definition feature.

Visual Basic
Property Parent() As RipDefinition**
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties > PointToPointRipTypeDef.Parent Property


PointToPointRipTypeDef.PointOne Property

PointToPointRipTypeDef.PointOne Property Introduced in Inventor 2011
Summary

Property that gets and sets the first point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.

Visual Basic
Property PointOne() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties > PointToPointRipTypeDef.PointOne Property


PointToPointRipTypeDef.PointTwo Property

PointToPointRipTypeDef.PointTwo Property Introduced in Inventor 2011
Summary

Property that gets and sets the first point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.

Visual Basic
Property PointTwo() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties > PointToPointRipTypeDef.PointTwo Property


PointToPointRipTypeDef.Type Property

PointToPointRipTypeDef.Type Property Introduced in Inventor 2011
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointToPointRipTypeDef Interface > PointToPointRipTypeDef Properties > PointToPointRipTypeDef.Type Property


PointWorkPointDef Interface

PointWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work point defined to be coincident to a point.

Class Hierarchy
Inventor::PointWorkPointDef
Visual Basic
Public Interface PointWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > PointWorkPointDef Interface


PointWorkPointDef Properties

PointWorkPointDef Properties
Summary

The properties of the PointWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property returning the parent WorkPoint object.
Point | Property that returns the point of a work point that is defined to be coincident to the point. This object can be a Vertex or SketchPoint object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PointWorkPointDef Interface > PointWorkPointDef Properties


PointWorkPointDef.Application Property

PointWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointWorkPointDef Interface > PointWorkPointDef Properties > PointWorkPointDef.Application Property


PointWorkPointDef.Parent Property

PointWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > PointWorkPointDef Interface > PointWorkPointDef Properties > PointWorkPointDef.Parent Property


PointWorkPointDef.Point Property

PointWorkPointDef.Point Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the point of a work point that is defined to be coincident to the point. This object can be a Vertex or SketchPoint object.

Visual Basic
Property Point() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PointWorkPointDef Interface > PointWorkPointDef Properties > PointWorkPointDef.Point Property


PointWorkPointDef.Type Property

PointWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PointWorkPointDef Interface > PointWorkPointDef Properties > PointWorkPointDef.Type Property


Polyline2d Interface

Polyline2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The Polyline2d object is a mathematical utility object that represents a set of connected line segments in a two dimension space. It is a transient object that is never shown graphically or saved in the Inventor document.

Class Hierarchy
Inventor::Polyline2d
Visual Basic
Public Interface Polyline2d
Inherits IDispatch
Remarks

The Polyline2d object is returned by graphical entities that have an underlying linear shape. Polyline2d objects can also be explicitly created using the CreatePolyline2d method of the TransientGeometry object.

When obtained from a graphical entity, the Polyline2d object represents a snapshot of the graphical entity. If the graphical entity is modified it will not affect the Polyline2d object. Also, if the Polyline2d object is modified it will not affect the graphical entity it was obtained from.

Notes

Members through which this object may be accessed include:

TransientGeometry.CreatePolyline2d

TransientGeometry.CreatePolyline2dFromCurve

DrawingDimension.DimensionLine

Centerline.Geometry

You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface


Polyline2d Methods

Polyline2d Methods
Summary

The methods of the Polyline2d class are listed here.

Methods
Methods
Name | Description
GetPoints | Method that returns the points defining the shape of the polyline.
PutPoints | Method that sets all of the coordinates of the polyline.
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Methods


Polyline2d.GetPoints Method

Polyline2d.GetPoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the points defining the shape of the polyline.

Visual Basic
Sub GetPoints(ByRef Points As SAFEARRAY(double))
Parameters
Parameters | Description
Points | Output array of Doubles that contains the coordinates of the polyline. The array contains sequential X, Y coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Methods > Polyline2d.GetPoints Method


Polyline2d.PutPoints Method

Polyline2d.PutPoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets all of the coordinates of the polyline.

Visual Basic
Sub PutPoints(Points As VARIANT)
Parameters
Parameters | Description
Points | Input Variant that defines the coordinates of the polyline. Valid input for this argument is an ObjectCollection of Point objects or an array of Double values that contains the X, Y values of each coordinate.
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Methods > Polyline2d.PutPoints Method


Polyline2d Properties

Polyline2d Properties
Summary

The properties of the Polyline2d class are listed here.

Methods
Methods
Name | Description
PointAtIndex | Property that returns or sets the x, y position of a specified point.
Properties
Name | Description
Evaluator | Property that returns an evaluator object for the curve. The evaluator supports general curve evaluation functions.
PointCount | Property that returns the number of points defining the polyline.
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Properties


Polyline2d.Evaluator Property

Polyline2d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns an evaluator object for the curve. The evaluator supports general curve evaluation functions.

Visual Basic
Property Evaluator() As Curve2dEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Properties > Polyline2d.Evaluator Property


Polyline2d.PointAtIndex Method

Polyline2d.PointAtIndex Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns or sets the x, y position of a specified point.

Visual Basic
Sub PointAtIndex(Index As long, Value As Point2d)
Parameters
Parameters | Description
index | Input Long that specifies which point to return or set the coordinate data for. The point indices range from 1 to the number of points in the polyline2d. The PointCount property returns the number of points in the polyline.
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Properties > Polyline2d.PointAtIndex Method


Polyline2d.PointCount Property

Polyline2d.PointCount Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of points defining the polyline.

Visual Basic
Property PointCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > Polyline2d Interface > Polyline2d Properties > Polyline2d.PointCount Property


Polyline3d Interface

Polyline3d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The Polyline3d object is a mathematical utility object that represents a set of connected line segments. It is a transient object that is never shown graphically or saved in the Inventor document.

Class Hierarchy
Inventor::Polyline3d
Visual Basic
Public Interface Polyline3d
Inherits IDispatch
Remarks

The Polyline object is returned by graphical entities that have an underlying linear shape. Polyline objects can also be explicitly created using the CreatePolyline3d method of the TransientGeometry object.

When obtained from an graphical entity, the Polyline object represents a snapshot of the graphical entity. If the graphical entity is modified it will not affect the Polyline object. Also, if the Polyline object is modified it will not affect the graphical entity it was obtained from.

Notes

Members through which this object may be accessed include:

TransientGeometry.CreatePolyline3d

TransientGeometry.CreatePolyline3dFromCurve

CurveGraphics.Curve

You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface


Polyline3d Methods

Polyline3d Methods
Summary

The methods of the Polyline3d class are listed here.

Methods
Methods
Name | Description
GetPoints | Method that returns the points defining the shape of the polyline.
PointAtIndex | Property that returns or sets the x, y, z position of a specified point.
PutPoints | Method that sets all of the coordinates of the polyline.
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Methods


Polyline3d.GetPoints Method

Polyline3d.GetPoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the points defining the shape of the polyline.

Visual Basic
Sub GetPoints(ByRef Points As SAFEARRAY(double))
Parameters
Parameters | Description
Points | Output array of Doubles that contains the coordinates of the polyline. The array contains sequential X, Y, Z coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Methods > Polyline3d.GetPoints Method


Polyline3d.PointAtIndex Method

Polyline3d.PointAtIndex Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns or sets the x, y, z position of a specified point.

Visual Basic
Sub PointAtIndex(Index As long, Value As Point)
Parameters
Parameters | Description
Index | Input Long that specifies which point to return or set the coordinate data for. The point indices range from 1 to the number of points in the polyline. The PointCount property returns the number of points in the polyline.
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Methods > Polyline3d.PointAtIndex Method


Polyline3d.PutPoints Method

Polyline3d.PutPoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets all of the coordinates of the polyline.

Visual Basic
Sub PutPoints(Points As VARIANT)
Parameters
Parameters | Description
Points | Input Variant that defines the coordinates of the polyline. Valid input for this argument is an ObjectCollection of Point objects or an array of Double values that contains the X, Y, Z values of each coordinate.
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Methods > Polyline3d.PutPoints Method


Polyline3d Properties

Polyline3d Properties
Summary

The properties of the Polyline3d class are listed here.

Properties
Name | Description
Evaluator | Property that returns an evaluator object for the curve. The evaluator supports general curve evaluation functions.
PointCount | Property that returns the number of points defining the polyline.
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Properties


Polyline3d.Evaluator Property

Polyline3d.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns an evaluator object for the curve. The evaluator supports general curve evaluation functions.

Visual Basic
Property Evaluator() As CurveEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Properties > Polyline3d.Evaluator Property


Polyline3d.PointCount Property

Polyline3d.PointCount Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of points defining the polyline.

Visual Basic
Property PointCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > Polyline3d Interface > Polyline3d Properties > Polyline3d.PointCount Property


PositionalRepresentation Interface

PositionalRepresentation Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PositionalRepresentation object represents a positional representation in the assembly.

Class Hierarchy
Inventor::PositionalRepresentation
Visual Basic
Public Interface PositionalRepresentation
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PositionalRepresentation.Copy

PositionalRepresentations.Add

PositionalRepresentations.Item

RepresentationsManager.ActivePositionalRepresentation

You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface


PositionalRepresentation Methods

PositionalRepresentation Methods
Summary

The methods of the PositionalRepresentation class are listed here.

Methods
Methods
Name | Description
Activate | Method that activates the positional representation.
Copy | Method that creates a copy of the PositionalRepresentation. The new created PositionalRepresentation is returned. The method returns an error if this is the 'master' positional representation.
Delete | Method that deletes the PositionalRepresentation. The method returns an error if this is the 'master' positional representation.
GetReferenceKey | Method that generates and returns the reference key for this entity.
IsConstraintSuppressionOverridden | Method that returns whether the suppression state of the input constraint is overridden for the positional representation and returns the state.
IsConstraintValueOverridden | Method that returns whether the value of the input constraint is overridden for the positional representation and returns the value of the constraint.
IsFlexibleOverridden | Method that returns whether the flexible state of the input occurrence is overridden for the positional representation and returns the state.
IsGroundingOverridden | Method that returns whether the grounded state of the input occurrence is overridden for the positional representation and returns the state.
IsPatternAngleOffsetOverridden | Method that returns whether the angle offset of the input circular pattern is overridden for the positional representation and returns the offset value.
IsPatternColumnOffsetOverridden | Method that returns whether the column offset of the input rectangular pattern is overridden for the positional representation and returns the offset value.
IsPatternRowOffsetOverridden | Method that returns whether the row offset of the input rectangular pattern is overridden for the positional representation and returns the offset value.
IsPositionalRepresentationOverridden | Method that returns whether the positional representation of the input occurrence is overridden for the positional representation and returns the representation.
IsTransformOverridden | Method that returns whether the transform of the input occurrence is overridden for the positional representation and returns the transform.
RemoveConstraintSuppressionOverride | Method that removes the override of suppression for the input constraint.
RemoveConstraintValueOverride | Method that removes the override for the input constraint.
RemoveFlexibleOverride | Method that removes the flexible override for the input occurrence.
RemoveGroundingOverride | Method that removes the grounding override for the input occurrence.
RemovePatternAngleOffsetOverride | Method that removes the angle offset override for the input pattern.
RemovePatternColumnOffsetOverride | Method that removes the column offset override for the input pattern.
RemovePatternRowOffsetOverride | Method that removes the row offset override for the input pattern.
RemovePositionalRepresentationOverride | Method that removes the positional representation override for the input occurrence.
RemoveTransformOverride | Method that removes the transform override for the input occurrence.
SetConstraintSuppressionOverride | Method that sets an overridden suppression state for the input constraint. If not already overridden, the method has the effect of setting the 'Override' flag for the constraint suppression.
SetConstraintValueOverride | Method that sets an overridden value for the input constraint. If not already overridden, the method has the effect of setting the 'Override' flag for the constraint value.
SetFlexibleOverride | Method that sets an override flexible state on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for flexible.
SetGroundingOverride | Method that sets an override grounding state on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for grounding.
SetPatternAngleOffsetOverride | Method that sets an override angle offset on the input circular pattern. If not already overridden, the method has the effect of setting the 'Override' flag for the angle offset.
SetPatternColumnOffsetOverride | Method that sets an override column offset on the input rectangular pattern. If not already overridden, the method has the effect of setting the 'Override' flag for the column offset.
SetPatternRowOffsetOverride | Method that sets an override row offset on the input rectangular pattern. If not already overridden, the method has the effect of setting the 'Override' flag for the row offset.
SetPositionalRepresentationOverride | Method that sets an override positional representation on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for positional representation.
SetTransformOverride | Method that sets an override transform on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for the transform (offset).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods


PositionalRepresentation.Activate Method

PositionalRepresentation.Activate Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that activates the positional representation.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.Activate Method


PositionalRepresentation.Copy Method

PositionalRepresentation.Copy Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a copy of the PositionalRepresentation. The new created PositionalRepresentation is returned. The method returns an error if this is the 'master' positional representation.

Visual Basic
Sub Copy(ByRef NewName As [defaultvalue("")] BSTR, Result As [out, retval] PositionalRepresentation*)
Parameters
Parameters | Description
NewName | Optional input string that specifies the name of the positional representation to create. If not specified, Inventor assigns a name to the representation.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.Copy Method


PositionalRepresentation.Delete Method

PositionalRepresentation.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the PositionalRepresentation. The method returns an error if this is the 'master' positional representation.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.Delete Method


PositionalRepresentation.GetReferenceKey Method

PositionalRepresentation.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.GetReferenceKey Method


PositionalRepresentation.IsConstraintSuppressionOverridden Method

PositionalRepresentation.IsConstraintSuppressionOverridden Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the suppression state of the input constraint is overridden for the positional representation and returns the state.

Visual Basic
Sub IsConstraintSuppressionOverridden(Constraint As AssemblyConstraint, ByRef Suppressed As VARIANT_BOOL, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Constraint | AssemblyConstraint object that specifies the constraint to be queried for the override.
Suppressed | Output Boolean that returns the suppression state of the constraint (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsConstraintSuppressionOverridden Method


PositionalRepresentation.IsConstraintValueOverridden Method

PositionalRepresentation.IsConstraintValueOverridden Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the value of the input constraint is overridden for the positional representation and returns the value of the constraint.

Visual Basic
Sub IsConstraintValueOverridden(Constraint As AssemblyConstraint, ByRef Expression As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Constraint | AssemblyConstraint object that specifies the constraint to be queried for the override.
Expression | Output string that returns the value of the constraint (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsConstraintValueOverridden Method


PositionalRepresentation.IsFlexibleOverridden Method

PositionalRepresentation.IsFlexibleOverridden Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the flexible state of the input occurrence is overridden for the positional representation and returns the state.

Visual Basic
Sub IsFlexibleOverridden(Occurrence As ComponentOccurrence, ByRef Flexible As VARIANT_BOOL, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be queried for the override.
Flexible | Boolean object that returns the flexible state (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsFlexibleOverridden Method


PositionalRepresentation.IsGroundingOverridden Method

PositionalRepresentation.IsGroundingOverridden Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the grounded state of the input occurrence is overridden for the positional representation and returns the state.

Visual Basic
Sub IsGroundingOverridden(Occurrence As ComponentOccurrence, ByRef Grounded As VARIANT_BOOL, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be queried for the override.
Grounded | Boolean object that returns the grounding state (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsGroundingOverridden Method


PositionalRepresentation.IsPatternAngleOffsetOverridden Method

PositionalRepresentation.IsPatternAngleOffsetOverridden Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether the angle offset of the input circular pattern is overridden for the positional representation and returns the offset value.

Visual Basic
Sub IsPatternAngleOffsetOverridden(Pattern As CircularOccurrencePattern, ByRef AngleOffset As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Pattern | Input CircularOccurrencePattern object that specifies the pattern to be queried for the override.
AngleOffset | Output String that returns the angle offset (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsPatternAngleOffsetOverridden Method


PositionalRepresentation.IsPatternColumnOffsetOverridden Method

PositionalRepresentation.IsPatternColumnOffsetOverridden Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether the column offset of the input rectangular pattern is overridden for the positional representation and returns the offset value.

Visual Basic
Sub IsPatternColumnOffsetOverridden(Pattern As RectangularOccurrencePattern, ByRef ColumnOffset As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Pattern | Input RectangularOccurrencePattern object that specifies the pattern to be queried for the override.
ColumnOffset | Output String that returns the column offset (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsPatternColumnOffsetOverridden Method


PositionalRepresentation.IsPatternRowOffsetOverridden Method

PositionalRepresentation.IsPatternRowOffsetOverridden Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether the row offset of the input rectangular pattern is overridden for the positional representation and returns the offset value.

Visual Basic
Sub IsPatternRowOffsetOverridden(Pattern As RectangularOccurrencePattern, ByRef RowOffset As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Pattern | Input RectangularOccurrencePattern object that specifies the pattern to be queried for the override.
RowOffset | Output String that returns the row offset (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsPatternRowOffsetOverridden Method


PositionalRepresentation.IsPositionalRepresentationOverridden Method

PositionalRepresentation.IsPositionalRepresentationOverridden Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the positional representation of the input occurrence is overridden for the positional representation and returns the representation.

Visual Basic
Sub IsPositionalRepresentationOverridden(Occurrence As ComponentOccurrence, ByRef Representation As String, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be queried for the override.
Representation | Output String that returns the positional representation (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsPositionalRepresentationOverridden Method


PositionalRepresentation.IsTransformOverridden Method

PositionalRepresentation.IsTransformOverridden Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the transform of the input occurrence is overridden for the positional representation and returns the transform.

Visual Basic
Sub IsTransformOverridden(Occurrence As ComponentOccurrence, ByRef Transform As Matrix*, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be queried for the override.
Transform | Matrix object that returns the transform (whether it is overridden or not).
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.IsTransformOverridden Method


PositionalRepresentation.RemoveConstraintSuppressionOverride Method

PositionalRepresentation.RemoveConstraintSuppressionOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that removes the override of suppression for the input constraint.

Visual Basic
Sub RemoveConstraintSuppressionOverride(Constraint As AssemblyConstraint)
Parameters
Parameters | Description
Constraint | AssemblyConstraint object that specifies the constraint for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemoveConstraintSuppressionOverride Method


PositionalRepresentation.RemoveConstraintValueOverride Method

PositionalRepresentation.RemoveConstraintValueOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that removes the override for the input constraint.

Visual Basic
Sub RemoveConstraintValueOverride(Constraint As AssemblyConstraint)
Parameters
Parameters | Description
Constraint | AssemblyConstraint object that specifies the constraint for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemoveConstraintValueOverride Method


PositionalRepresentation.RemoveFlexibleOverride Method

PositionalRepresentation.RemoveFlexibleOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that removes the flexible override for the input occurrence.

Visual Basic
Sub RemoveFlexibleOverride(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemoveFlexibleOverride Method


PositionalRepresentation.RemoveGroundingOverride Method

PositionalRepresentation.RemoveGroundingOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that removes the grounding override for the input occurrence.

Visual Basic
Sub RemoveGroundingOverride(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemoveGroundingOverride Method


PositionalRepresentation.RemovePatternAngleOffsetOverride Method

PositionalRepresentation.RemovePatternAngleOffsetOverride Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that removes the angle offset override for the input pattern.

Visual Basic
Sub RemovePatternAngleOffsetOverride(Pattern As CircularOccurrencePattern)
Parameters
Parameters | Description
Pattern | Input CircularOccurrencePattern object that specifies the pattern for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemovePatternAngleOffsetOverride Method


PositionalRepresentation.RemovePatternColumnOffsetOverride Method

PositionalRepresentation.RemovePatternColumnOffsetOverride Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that removes the column offset override for the input pattern.

Visual Basic
Sub RemovePatternColumnOffsetOverride(Pattern As RectangularOccurrencePattern)
Parameters
Parameters | Description
Pattern | Input RectangularOccurrencePattern object that specifies the pattern for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemovePatternColumnOffsetOverride Method


PositionalRepresentation.RemovePatternRowOffsetOverride Method

PositionalRepresentation.RemovePatternRowOffsetOverride Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that removes the row offset override for the input pattern.

Visual Basic
Sub RemovePatternRowOffsetOverride(Pattern As RectangularOccurrencePattern)
Parameters
Parameters | Description
Pattern | Input RectangularOccurrencePattern object that specifies the pattern for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemovePatternRowOffsetOverride Method


PositionalRepresentation.RemovePositionalRepresentationOverride Method

PositionalRepresentation.RemovePositionalRepresentationOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that removes the positional representation override for the input occurrence.

Visual Basic
Sub RemovePositionalRepresentationOverride(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemovePositionalRepresentationOverride Method


PositionalRepresentation.RemoveTransformOverride Method

PositionalRepresentation.RemoveTransformOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that removes the transform override for the input occurrence.

Visual Basic
Sub RemoveTransformOverride(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence for which the override should be removed.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.RemoveTransformOverride Method


PositionalRepresentation.SetConstraintSuppressionOverride Method

PositionalRepresentation.SetConstraintSuppressionOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets an overridden suppression state for the input constraint. If not already overridden, the method has the effect of setting the 'Override' flag for the constraint suppression.

Visual Basic
Sub SetConstraintSuppressionOverride(Constraint As AssemblyConstraint, Suppressed As VARIANT_BOOL)
Parameters
Parameters | Description
Constraint | AssemblyConstraint object that specifies the constraint to be overridden.
Suppressed | Input Boolean that specifies the override suppression state for the constraint.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetConstraintSuppressionOverride Method


PositionalRepresentation.SetConstraintValueOverride Method

PositionalRepresentation.SetConstraintValueOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets an overridden value for the input constraint. If not already overridden, the method has the effect of setting the 'Override' flag for the constraint value.

Visual Basic
Sub SetConstraintValueOverride(Constraint As AssemblyConstraint, Expression As String)
Parameters
Parameters | Description
Constraint | AssemblyConstraint object that specifies the constraint to be overridden.
Expression | Input string that specifies the override expression for the constraint.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetConstraintValueOverride Method


PositionalRepresentation.SetFlexibleOverride Method

PositionalRepresentation.SetFlexibleOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets an override flexible state on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for flexible.

Visual Basic
Sub SetFlexibleOverride(Occurrence As ComponentOccurrence, Flexible As VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be overridden.
Flexible | Boolean that specifies the override flexible state.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetFlexibleOverride Method


PositionalRepresentation.SetGroundingOverride Method

PositionalRepresentation.SetGroundingOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets an override grounding state on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for grounding.

Visual Basic
Sub SetGroundingOverride(Occurrence As ComponentOccurrence, Grounded As VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be overridden.
Grounded | Boolean that specifies the override grounding state.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetGroundingOverride Method


PositionalRepresentation.SetPatternAngleOffsetOverride Method

PositionalRepresentation.SetPatternAngleOffsetOverride Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets an override angle offset on the input circular pattern. If not already overridden, the method has the effect of setting the 'Override' flag for the angle offset.

Visual Basic
Sub SetPatternAngleOffsetOverride(Pattern As CircularOccurrencePattern, AngleOffset As String)
Parameters
Parameters | Description
Pattern | Input CircularOccurrencePattern object that specifies the pattern to be overridden.
AngleOffset | Input String that specifies the override angle offset.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetPatternAngleOffsetOverride Method


PositionalRepresentation.SetPatternColumnOffsetOverride Method

PositionalRepresentation.SetPatternColumnOffsetOverride Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets an override column offset on the input rectangular pattern. If not already overridden, the method has the effect of setting the 'Override' flag for the column offset.

Visual Basic
Sub SetPatternColumnOffsetOverride(Pattern As RectangularOccurrencePattern, ColumnOffset As String)
Parameters
Parameters | Description
Pattern | Input RectangularOccurrencePattern object that specifies the pattern to be overridden.
ColumnOffset | Input String that specifies the override column offset.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetPatternColumnOffsetOverride Method


PositionalRepresentation.SetPatternRowOffsetOverride Method

PositionalRepresentation.SetPatternRowOffsetOverride Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets an override row offset on the input rectangular pattern. If not already overridden, the method has the effect of setting the 'Override' flag for the row offset.

Visual Basic
Sub SetPatternRowOffsetOverride(Pattern As RectangularOccurrencePattern, RowOffset As String)
Parameters
Parameters | Description
Pattern | Input RectangularOccurrencePattern object that specifies the pattern to be overridden.
RowOffset | Input String that specifies the override row offset.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetPatternRowOffsetOverride Method


PositionalRepresentation.SetPositionalRepresentationOverride Method

PositionalRepresentation.SetPositionalRepresentationOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets an override positional representation on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for positional representation.

Visual Basic
Sub SetPositionalRepresentationOverride(Occurrence As ComponentOccurrence, Representation As String)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be overridden.
Representation | Input String that specifies the override positional representation.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetPositionalRepresentationOverride Method


PositionalRepresentation.SetTransformOverride Method

PositionalRepresentation.SetTransformOverride Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets an override transform on the input occurrence. If not already overridden, the method has the effect of setting the 'Override' flag for the transform (offset).

Visual Basic
Sub SetTransformOverride(Occurrence As ComponentOccurrence, Transform As Matrix)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the occurrence to be overridden.
Transform | Matrix object that specifies the override transform.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Methods > PositionalRepresentation.SetTransformOverride Method


PositionalRepresentation Properties

PositionalRepresentation Properties
Summary

The properties of the PositionalRepresentation class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Master | Property that returns whether this is the master positional representation.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent RepresentationsManager object.
Type | Property returning kPositionalRepresentationObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties


PositionalRepresentation.Application Property

PositionalRepresentation.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties > PositionalRepresentation.Application Property


PositionalRepresentation.AttributeSets Property

PositionalRepresentation.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties > PositionalRepresentation.AttributeSets Property


PositionalRepresentation.Master Property

PositionalRepresentation.Master Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether this is the master positional representation.

Visual Basic
Property Master() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties > PositionalRepresentation.Master Property


PositionalRepresentation.Name Property

PositionalRepresentation.Name Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties > PositionalRepresentation.Name Property


PositionalRepresentation.Parent Property

PositionalRepresentation.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent RepresentationsManager object.

Visual Basic
Property Parent() As RepresentationsManager**
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties > PositionalRepresentation.Parent Property


PositionalRepresentation.Type Property

PositionalRepresentation.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kPositionalRepresentationObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentation Interface > PositionalRepresentation Properties > PositionalRepresentation.Type Property


PositionalRepresentations Interface

PositionalRepresentations Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PositionalRepresentations collection object provides access to all the positional representations in the assembly and provides methods to create new ones.

Class Hierarchy
Inventor::PositionalRepresentations
Visual Basic
Public Interface PositionalRepresentations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RepresentationsManager.PositionalRepresentations

You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface


PositionalRepresentations Methods

PositionalRepresentations Methods
Summary

The methods of the PositionalRepresentations class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new PositionalRepresentation. The new created PositionalRepresentation is returned.
Item | Property that returns the specified PositionalRepresentation object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Methods


PositionalRepresentations.Add Method

PositionalRepresentations.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new PositionalRepresentation. The new created PositionalRepresentation is returned.

Visual Basic
Sub Add(ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] PositionalRepresentation*)
Parameters
Parameters | Description
Name | Optional input string that specifies the name of the positional representation to create. If not specified, Inventor assigns a name to the representation.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Methods > PositionalRepresentations.Add Method


PositionalRepresentations.Item Method

PositionalRepresentations.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the specified PositionalRepresentation object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] PositionalRepresentation*)
Parameters
Parameters | Description
index | Input Variant value that specifies the PositionalRepresentation to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the PositionalRepresentation name. If an out of range index or a name of a non-existent PositionalRepresentation is provided, an error will occur .
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Methods > PositionalRepresentations.Item Method


PositionalRepresentations Properties

PositionalRepresentations Properties
Summary

The properties of the PositionalRepresentations class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
ExcelWorkSheet | Property that returns the Excel spreadsheet that contains the positional representations data.
Type | Property returning kPositionalRepresentationsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Properties


PositionalRepresentations.Application Property

PositionalRepresentations.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Properties > PositionalRepresentations.Application Property


PositionalRepresentations.Count Property

PositionalRepresentations.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Properties > PositionalRepresentations.Count Property


PositionalRepresentations.ExcelWorkSheet Property

PositionalRepresentations.ExcelWorkSheet Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Excel spreadsheet that contains the positional representations data.

Visual Basic
Property ExcelWorkSheet() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Properties > PositionalRepresentations.ExcelWorkSheet Property


PositionalRepresentations.Type Property

PositionalRepresentations.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kPositionalRepresentationsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PositionalRepresentations Interface > PositionalRepresentations Properties > PositionalRepresentations.Type Property


Preparations Interface

Preparations Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Represents the Preparations environment in a weldment assembly.

Class Hierarchy
Inventor::Preparations
Visual Basic
Public Interface Preparations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WeldmentComponentDefinition.Preparations

Document.ActivatedObject

Application.ActiveEditObject

You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface


Preparations Methods

Preparations Methods
Summary

The methods of the Preparations class are listed here.

Methods
Methods
Name | Description
Edit | Method that activates this object for editing by the user.
ExitEdit | Method that causes the current editing environment to be closed and the user interface to return to weldment editing environment.
You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface > Preparations Methods


Preparations.Edit Method

Preparations.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that activates this object for editing by the user.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface > Preparations Methods > Preparations.Edit Method


Preparations.ExitEdit Method

Preparations.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that causes the current editing environment to be closed and the user interface to return to weldment editing environment.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface > Preparations Methods > Preparations.ExitEdit Method


Preparations Properties

Preparations Properties
Summary

The properties of the Preparations class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface > Preparations Properties


Preparations.Application Property

Preparations.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface > Preparations Properties > Preparations.Application Property


Preparations.Type Property

Preparations.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Preparations Interface > Preparations Properties > Preparations.Type Property


PresentationDocument Interface

PresentationDocument Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The PresentationDocument object respesents a presentation document in Inventor.

Class Hierarchy
Inventor::Document
    Inventor::PresentationDocument
Visual Basic
Public Interface PresentationDocument
Inherits Document
Remarks

The Rebuild and Rebuild2 methods are non-functional in the context of Drawing and Presentation documents.

You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface


PresentationDocument Properties

PresentationDocument Properties
Summary

The properties of the PresentationDocument class are listed here.

Properties
Name | Description
ActiveExplodedView | Property that returns the currently active exploded view.
ActiveLightingStyle | Property that gets and sets the lighting style to use for the presentation.
DisabledCommandList |
DisplaySettings | Property that returns the DisplaySettings object. The DisplaySettings object provides access to various display appearance related document settings.
EnvironmentManager |
LightingStyles | Property that returns the LightingStyles collection object.
PresentationExplodedViews | Property that returns the PresentationExplodedViews collection object containing all the exploded views within the presentation document.
You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties


PresentationDocument.ActiveExplodedView Property

PresentationDocument.ActiveExplodedView Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the currently active exploded view.

Visual Basic
Property ActiveExplodedView() As PresentationExplodedView**
You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.ActiveExplodedView Property


PresentationDocument.ActiveLightingStyle Property

PresentationDocument.ActiveLightingStyle Property
Summary

Property that gets and sets the lighting style to use for the presentation.

Visual Basic
Property ActiveLightingStyle() As LightingStyle*
You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.ActiveLightingStyle Property


PresentationDocument.DisabledCommandList Property

PresentationDocument.DisabledCommandList Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property DisabledCommandList() As DisabledCommandList**
Notes

For information on this item, please refer to AssemblyDocument::DisabledCommandList, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.DisabledCommandList Property


PresentationDocument.DisplaySettings Property

PresentationDocument.DisplaySettings Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the DisplaySettings object. The DisplaySettings object provides access to various display appearance related document settings.

Visual Basic
Property DisplaySettings() As DisplaySettings**
You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.DisplaySettings Property


PresentationDocument.EnvironmentManager Property

PresentationDocument.EnvironmentManager Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property EnvironmentManager() As EnvironmentManager**
Notes

For information on this item, please refer to AssemblyDocument::EnvironmentManager, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.EnvironmentManager Property


PresentationDocument.LightingStyles Property

PresentationDocument.LightingStyles Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the LightingStyles collection object.

Visual Basic
Property LightingStyles() As LightingStyles**
You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.LightingStyles Property


PresentationDocument.PresentationExplodedViews Property

PresentationDocument.PresentationExplodedViews Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the PresentationExplodedViews collection object containing all the exploded views within the presentation document.

Visual Basic
Property PresentationExplodedViews() As PresentationExplodedViews**
You are here: Symbol Reference > Inventor Library > Objects > PresentationDocument Interface > PresentationDocument Properties > PresentationDocument.PresentationExplodedViews Property


PresentationExplodedView Interface

PresentationExplodedView Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The PresentationExplodedView object represents an exploded view within a presentation document.

Class Hierarchy
Inventor::PresentationExplodedView
Visual Basic
Public Interface PresentationExplodedView
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PresentationDocument.ActiveExplodedView

PresentationExplodedViews.Item

Trail.Parent

You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface


PresentationExplodedView Methods

PresentationExplodedView Methods
Summary

The methods of the PresentationExplodedView class are listed here.

Methods
Methods
Name | Description
Activate | Method that activates the exploded view.
Delete | Method that deletes the exploded view.
GetRenderStyle | Method that returns the render style applied to a particular occurrence within the exploded view.
GetTransform | Method that returns the transform of a particular occurrence within the exploded view.
GetVisibility | Method that returns the visibility of a particular occurrence or the entire document within the exploded view.
SetRenderStyle | Method that sets the render style of a particular occurrence within the exploded view.
SetVisibility |
Trails | Returns the trails associated with the exploded view, optionally filtered to the input ComponentOccurrence (or ComponentOccurrenceProxy).
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods


PresentationExplodedView.Activate Method

PresentationExplodedView.Activate Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that activates the exploded view.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.Activate Method


PresentationExplodedView.Delete Method

PresentationExplodedView.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes the exploded view.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.Delete Method


PresentationExplodedView.GetRenderStyle Method

PresentationExplodedView.GetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the render style applied to a particular occurrence within the exploded view.

Visual Basic
Sub GetRenderStyle(Occurrence As IDispatch, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
Occurrence | Occurrence to get the render style of.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.GetRenderStyle Method


PresentationExplodedView.GetTransform Method

PresentationExplodedView.GetTransform Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the transform of a particular occurrence within the exploded view.

Visual Basic
Sub GetTransform(Occurrence As ComponentOccurrence, Result As [out, retval] Matrix*)
Parameters
Parameters | Description
Occurrence | Occurrence to get the transform matrix of.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.GetTransform Method


PresentationExplodedView.GetVisibility Method

PresentationExplodedView.GetVisibility Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the visibility of a particular occurrence or the entire document within the exploded view.

Visual Basic
Sub GetVisibility(Occurrence As IDispatch, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | Occurrence to determine visibility of.
Remarks

Occurrence input can either be ComponentOccurrence, ComponentOccurrenceProxy or the top level Document.

You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.GetVisibility Method


PresentationExplodedView.SetRenderStyle Method

PresentationExplodedView.SetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets the render style of a particular occurrence within the exploded view.

Visual Basic
Sub SetRenderStyle(Occurrence As IDispatch, RenderStyle As RenderStyle)
Parameters
Parameters | Description
Occurrence | Occurrence to set the render style of.
RenderStyle | RenderStyle object that is the render style to use for this occurrence.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.SetRenderStyle Method


PresentationExplodedView.SetVisibility Method

PresentationExplodedView.SetVisibility Method Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Sub SetVisibility(Occurrence As IDispatch, Visible As VARIANT_BOOL)
Parameters
Parameters | Description
Occurrence | Object to set the visibility state of.
Visible | Boolean that specifies whether the input object is visible in the drawing view.
Remarks

Method that sets the visibility of a particular occurrence or the entire document within the exploded view.

You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.SetVisibility Method


PresentationExplodedView.Trails Method

PresentationExplodedView.Trails Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the trails associated with the exploded view, optionally filtered to the input ComponentOccurrence (or ComponentOccurrenceProxy).

Visual Basic
Sub Trails(ByRef Occurrence As [optional] VARIANT, Result As [out, retval] TrailsEnumerator*)
Parameters
Parameters | Description
Occurrence | Limit trails returned to those for this occurrence.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Methods > PresentationExplodedView.Trails Method


PresentationExplodedView Properties

PresentationExplodedView Properties
Summary

The properties of the PresentationExplodedView class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Name | Property that returns the name of the exploded view.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Properties


PresentationExplodedView.Application Property

PresentationExplodedView.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Properties > PresentationExplodedView.Application Property


PresentationExplodedView.Name Property

PresentationExplodedView.Name Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the name of the exploded view.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Properties > PresentationExplodedView.Name Property


PresentationExplodedView.Parent Property

PresentationExplodedView.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Properties > PresentationExplodedView.Parent Property


PresentationExplodedView.Type Property

PresentationExplodedView.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedView Interface > PresentationExplodedView Properties > PresentationExplodedView.Type Property


PresentationExplodedViews Interface

PresentationExplodedViews Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The collection of PresentationExplodedView objects.

Class Hierarchy
Inventor::PresentationExplodedViews
Visual Basic
Public Interface PresentationExplodedViews
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PresentationDocument.PresentationExplodedViews

You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface


PresentationExplodedViews Methods

PresentationExplodedViews Methods
Summary

The methods of the PresentationExplodedViews class are listed here.

Methods
Methods
Name | Description
Item | roperty that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface > PresentationExplodedViews Methods


PresentationExplodedViews.Item Method

PresentationExplodedViews.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

roperty that returns the specified object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] PresentationExplodedView*)
Parameters
Parameters | Description
index | Specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface > PresentationExplodedViews Methods > PresentationExplodedViews.Item Method


PresentationExplodedViews Properties

PresentationExplodedViews Properties
Summary

The properties of the PresentationExplodedViews class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface > PresentationExplodedViews Properties


PresentationExplodedViews.Application Property

PresentationExplodedViews.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface > PresentationExplodedViews Properties > PresentationExplodedViews.Application Property


PresentationExplodedViews.Count Property

PresentationExplodedViews.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface > PresentationExplodedViews Properties > PresentationExplodedViews.Count Property


PresentationExplodedViews.Type Property

PresentationExplodedViews.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PresentationExplodedViews Interface > PresentationExplodedViews Properties > PresentationExplodedViews.Type Property


PresentationOptions Interface

PresentationOptions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The PresentationOptions object provides access to properties that provide read and write access of the presentation related application options.

Class Hierarchy
Inventor::PresentationOptions
Visual Basic
Public Interface PresentationOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.PresentationOptions

You are here: Symbol Reference > Inventor Library > Objects > PresentationOptions Interface


PresentationOptions Properties

PresentationOptions Properties
Summary

The properties of the PresentationOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
SkipAllUnresolvedFiles | Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening presentation files.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PresentationOptions Interface > PresentationOptions Properties


PresentationOptions.Application Property

PresentationOptions.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PresentationOptions Interface > PresentationOptions Properties > PresentationOptions.Application Property


PresentationOptions.SkipAllUnresolvedFiles Property

PresentationOptions.SkipAllUnresolvedFiles Property Introduced in Inventor 2011
Summary

Property that specifies whether to skip the file resolution dialogs when referenced files fail to resolve when opening presentation files.

Visual Basic
Property SkipAllUnresolvedFiles() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PresentationOptions Interface > PresentationOptions Properties > PresentationOptions.SkipAllUnresolvedFiles Property


PresentationOptions.Type Property

PresentationOptions.Type Property Introduced in Inventor 2011
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PresentationOptions Interface > PresentationOptions Properties > PresentationOptions.Type Property


PrintManager Interface

PrintManager Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The PrintManager object supports properties and methods that allow you to get and set the printing parameters and submit the print job.

Class Hierarchy
Inventor::PrintManager
    Inventor::DrawingPrintManager
Visual Basic
Public Interface PrintManager
Inherits IDispatch
Remarks

This object is used for all document types besides drawings. It supports the same methods and properties as the DrawingPrintManager except the following methods and properties are not available for the PrintManager object:

  • ScaleMode
  • Scale
  • PrintRange
  • SetSheetRange
  • GetSheetRange
  • Rotate90Degrees.
Notes

Members through which this object may be accessed include:

Document.PrintManager

Example

"Printing - Part or Assembly Example "

This sample demonstrates how to print a Part or Assembly document.

Public Sub PrintPartOrAssembly()
    ' Set a reference to the print manager object of the active document.
    Dim oPrintMgr As PrintManager
    Set oPrintMgr = ThisApplication.ActiveDocument.PrintManager

    ' Get the name of the printer that will be used.
    If MsgBox("Using printer """ & oPrintMgr.Printer & """  Do you want to continue?", vbYesNo + vbQuestion) = vbNo Then
        ' Change to another printer.
        Dim sPrinterName As String
        sPrinterName = InputBox("Enter name of new printer:", "New Printer")
        If sPrinterName = "" Then
            Exit Sub
        Else
            oPrintMgr.Printer = sPrinterName
        End If
    End If

    ' Set to print in color.
    oPrintMgr.ColorMode = kPrintColorPalette

    ' Set to print two copies.
    oPrintMgr.NumberOfCopies = 2

    ' Set to print using portrait orientation.
    oPrintMgr.Orientation = kPortraitOrientation

    ' Set the paper size.
    oPrintMgr.PaperSize = kPaperSize11x17

    ' Submit the print.
    oPrintMgr.SubmitPrint

    ' Change the number of copies to 1.
    oPrintMgr.NumberOfCopies = 1

    ' Change the paper size to a custom size.  The units are in centimeters.
    oPrintMgr.PaperSize = kPaperSizeCustom
    oPrintMgr.PaperHeight = 15
    oPrintMgr.PaperWidth = 10

    ' Submit the print.
    oPrintMgr.SubmitPrint
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface


PrintManager Methods

PrintManager Methods
Summary

The methods of the PrintManager class are listed here.

Methods
Methods
Name | Description
PrintToFile | Method that prints to the specified file using the current property settings defined by the PrintManager object.
SubmitPrint | Method that prints using the current property settings defined by the PrintManager object.
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Methods


PrintManager.PrintToFile Method

PrintManager.PrintToFile Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that prints to the specified file using the current property settings defined by the PrintManager object.

Visual Basic
Sub PrintToFile(FileName As String)
Parameters
Parameters | Description
FileName | Input String that specifies the full path of the file to write the print information to. If the specified file already exists it will be overwritten.
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Methods > PrintManager.PrintToFile Method


PrintManager.SubmitPrint Method

PrintManager.SubmitPrint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that prints using the current property settings defined by the PrintManager object.

Visual Basic
Sub SubmitPrint()
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Methods > PrintManager.SubmitPrint Method


PrintManager Properties

PrintManager Properties
Summary

The properties of the PrintManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ColorMode | Property that gets and sets the color mode for printing. This is initialized with kPrintGrayScale.
NumberOfCopies | Property that gets and sets the number of copies to print. This is initialized with a value of 1.
Orientation | Property that gets and sets the orientation of the print. This is initialized with the default orientation of the current printer.
PaperHeight | Property that gets and sets the height of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.
PaperSize | Property that gets and sets the size of the paper. This is initialized with the default paper size of the current printer. If this property is set kPaperSizeCustom then the PaperHeight and PaperWidth properties can be used to define any paper size.
PaperSource | Property that gets and sets the location of the paper to use when printing. Different printer models support different paper sources, such as upper tray, envelope feed, cassette, and manual feed.
PaperWidth | Property that gets and sets the width of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.
Printer | Property that gets and sets the name of the printing device. This is initialized with the name of the default printer.
PrinterDeviceContext | Property that gets and sets the handle to the Windows device context that is used when printing.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties


PrintManager.Application Property

PrintManager.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.Application Property


PrintManager.ColorMode Property

PrintManager.ColorMode Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the color mode for printing. This is initialized with kPrintGrayScale.

Visual Basic
Property ColorMode() As PrintColorModeEnum
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.ColorMode Property


PrintManager.NumberOfCopies Property

PrintManager.NumberOfCopies Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the number of copies to print. This is initialized with a value of 1.

Visual Basic
Property NumberOfCopies() As long
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.NumberOfCopies Property


PrintManager.Orientation Property

PrintManager.Orientation Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the orientation of the print. This is initialized with the default orientation of the current printer.

Visual Basic
Property Orientation() As PrintOrientationEnum
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.Orientation Property


PrintManager.PaperHeight Property

PrintManager.PaperHeight Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the height of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.

Visual Basic
Property PaperHeight() As double
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.PaperHeight Property


PrintManager.PaperSize Property

PrintManager.PaperSize Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the size of the paper. This is initialized with the default paper size of the current printer. If this property is set kPaperSizeCustom then the PaperHeight and PaperWidth properties can be used to define any paper size.

Visual Basic
Property PaperSize() As PaperSizeEnum
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.PaperSize Property


PrintManager.PaperSource Property

PrintManager.PaperSource Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the location of the paper to use when printing. Different printer models support different paper sources, such as upper tray, envelope feed, cassette, and manual feed.

Visual Basic
Property PaperSource() As long
Remarks

This property is initialized to -1, which indicates the printer should use the paper tray that supports the paper size you have selected. All other options are printer-dependent and are specified by using an index. What value applies to what paper source will need to be determined by trial and error testing.

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.PaperSource Property


PrintManager.PaperWidth Property

PrintManager.PaperWidth Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the width of the paper. This property is only used when the PaperSize property is set to kPaperSizeCustom. When the value of this property is set, the PaperSize property is automatically set to kPaperSizeCustom. The units are in centimeters.

Visual Basic
Property PaperWidth() As double
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.PaperWidth Property


PrintManager.Printer Property

PrintManager.Printer Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the name of the printing device. This is initialized with the name of the default printer.

Visual Basic
Property Printer() As String
See Also

Printing - Part or Assembly sample

You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.Printer Property


PrintManager.PrinterDeviceContext Property

PrintManager.PrinterDeviceContext Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the handle to the Windows device context that is used when printing.

Visual Basic
Property PrinterDeviceContext() As long
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.PrinterDeviceContext Property


PrintManager.Type Property

PrintManager.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PrintManager Interface > PrintManager Properties > PrintManager.Type Property


Profile Interface

Profile Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Profile object defines a set of connected curves used as input for a feature. See the article in the overviews section.

Class Hierarchy
Inventor::Profile
    Inventor::ProfileProxy
Visual Basic
Public Interface Profile
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BreakOutOperation.Profile

CoilFeature.Profile

CutDefinition.Profile

EmbossFeature.Profile

ExtrudeFeature.Profile

FaceFeatureDefinition.Profile

ProfilePath.Parent

ProfileProxy.NativeObject

Profiles.AddForSolid

Profiles.AddForSurface

Profiles.Item

RevolveFeature.Profile

SketchFillRegion.Profile

SweepFeature.Profile

BoundaryPatchLoop.BoundaryPath

LoftDefinition.Centerline

LoftRail.Rail

See Also

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Share sample

Edit profile of an extrude feature sample

Thread Feature Create sample

True length of sweep feature sample

Sweep Feature Add sample

SurfaceBody Copy sample

Create sheet metal face and cut features sample

Accessing region properties from a profile sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Derived Parts and Assemblies sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > Profile Interface


Profile Methods

Profile Methods
Summary

The methods of the Profile class are listed here.

Methods
Methods
Name | Description
Delete | Deletes this profile object.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Property that returns the specified ProfilePath object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Methods


Profile.Delete Method

Profile.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Deletes this profile object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Methods > Profile.Delete Method


Profile.GetReferenceKey Method

Profile.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Methods > Profile.GetReferenceKey Method


Profile.Item Method

Profile.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified ProfilePath object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ProfilePath*)
Parameters
Parameters | Description
index | Specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Methods > Profile.Item Method


Profile Properties

Profile Properties
Summary

The properties of the Profile class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Count | Property that returns the number of items in this collection.
MergeFaces | Property indicating whether the faces should merge.
Parent | Property that returns the sketch that the profile was derived from.
RegionProperties | Returns the RegionProperties object.
Type | Property returning an enum indicating this object's type.
Wires | Property returning the Wires collection object associated with this Profile.
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties


Profile.Application Property

Profile.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.Application Property


Profile.AttributeSets Property

Profile.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.AttributeSets Property


Profile.Count Property

Profile.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.Count Property


Profile.MergeFaces Property

Profile.MergeFaces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property indicating whether the faces should merge.

Visual Basic
Property MergeFaces() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.MergeFaces Property


Profile.Parent Property

Profile.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch that the profile was derived from.

Visual Basic
Property Parent() As Sketch**
See Also

Sketch Share sample

True length of sweep feature sample

You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.Parent Property


Profile.RegionProperties Property

Profile.RegionProperties Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns the RegionProperties object.

Visual Basic
Property RegionProperties() As RegionProperties**
See Also

True length of sweep feature sample

Example

"Accessing region properties from a profile"

This sample demonstrates getting region properties from a sketch profile. To run the sample you must have a sketch active that contains some sketch entities.

Public Sub GetProfileRegionProperties()
    ' Set a reference to the active sketch.
    ' This assumes a 2D sketch is active.
    Dim oSketch As Sketch
    Set oSketch = ThisApplication.ActiveEditObject

    ' Create a default profile from the sketch.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Set a reference to the region properties object.
    Dim oRegionProps As RegionProperties
    Set oRegionProps = oProfile.RegionProperties

    ' Set the accuracy to medium.
    oRegionProps.Accuracy = kMedium

    ' Display the region properties of the profile.
    Debug.Print "Area: " & oRegionProps.Area

    Debug.Print "Perimeter: " & oRegionProps.Perimeter

    Debug.Print "Centroid: " & _
                    oRegionProps.Centroid.X & ", " & _
                    oRegionProps.Centroid.Y

    Dim adPrincipalMoments(1 To 3) As Double
    Call oRegionProps.PrincipalMomentsOfInertia(adPrincipalMoments(1), _
                                                    adPrincipalMoments(2), _
                                                    adPrincipalMoments(3))
    Debug.Print "Principal Moments of Inertia: " & _
                    adPrincipalMoments(1) & ", " & _
                    adPrincipalMoments(2)

    Dim adRadiusOfGyration(1 To 3) As Double
    Call oRegionProps.RadiusOfGyration(adRadiusOfGyration(1), _
                                            adRadiusOfGyration(2), _
                                            adRadiusOfGyration(3))
    Debug.Print "Radius of Gyration: " & _
                    adRadiusOfGyration(1) & ", " & _
                    adRadiusOfGyration(2)

    Dim Ixx As Double
    Dim Iyy As Double
    Dim Izz As Double
    Dim Ixy As Double
    Dim Iyz As Double
    Dim Ixz As Double
    Call oRegionProps.MomentsOfInertia(Ixx, Iyy, Izz, Ixy, Iyz, Ixz)
    Debug.Print "Moments: "
    Debug.Print " Ixx: " & Ixx
    Debug.Print " Iyy: " & Iyy
    Debug.Print " Ixy: " & Ixy

    Debug.Print "Rotation Angle from projected Sketch Origin to Principle Axes: " _
    & oRegionProps.RotationAngle

End Sub
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.RegionProperties Property


Profile.Type Property

Profile.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.Type Property


Profile.Wires Property

Profile.Wires Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the Wires collection object associated with this Profile.

Visual Basic
Property Wires() As Wires**
Remarks

A Wire object provides a 3D curve representation of a Profile and is sometimes required when working with the TransientBRep object.

You are here: Symbol Reference > Inventor Library > Objects > Profile Interface > Profile Properties > Profile.Wires Property


Profile3D Interface

Profile3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The Profile3D object defines a set of connected curves within a 3D sketch. The Profile3D object is used as input for various features that support 3D sketches as input, such as sweep and loft. See the article in the overviews section.

Class Hierarchy
Inventor::Profile3D
    Inventor::Profile3DProxy
Visual Basic
Public Interface Profile3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Profile3DProxy.NativeObject

ProfilePath3D.Parent

Profiles3D.AddClosed

Profiles3D.AddOpen

Profiles3D.Item

BoundaryPatchLoop.BoundaryPath

LoftDefinition.Centerline

LoftRail.Rail

See Also

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface


Profile3D Methods

Profile3D Methods
Summary

The methods of the Profile3D class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this Profile3D object.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Method that returns the specified ProfilePath3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Methods


Profile3D.Delete Method

Profile3D.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes this Profile3D object.

Visual Basic
Sub Delete()
Remarks

This is only valid for Profile3D objects that do not have a dependent feature.

You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Methods > Profile3D.Delete Method


Profile3D.GetReferenceKey Method

Profile3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Methods > Profile3D.GetReferenceKey Method


Profile3D.Item Method

Profile3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified ProfilePath3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ProfilePath3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Methods > Profile3D.Item Method


Profile3D Properties

Profile3D Properties
Summary

The properties of the Profile3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Count | Property that returns the number of items in the collection.
Parent | Property that returns the 3D sketch that the profile was derived from.
Type | Property returning an enum indicating this object's type.
Wires | Property returning the Wires collection object associated with this Profile3D.
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties


Profile3D.Application Property

Profile3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties > Profile3D.Application Property


Profile3D.AttributeSets Property

Profile3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties > Profile3D.AttributeSets Property


Profile3D.Count Property

Profile3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties > Profile3D.Count Property


Profile3D.Parent Property

Profile3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the 3D sketch that the profile was derived from.

Visual Basic
Property Parent() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties > Profile3D.Parent Property


Profile3D.Type Property

Profile3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties > Profile3D.Type Property


Profile3D.Wires Property

Profile3D.Wires Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the Wires collection object associated with this Profile3D.

Visual Basic
Property Wires() As Wires**
Remarks

A Wire object provides a different representation of 3D curves and is sometimes required when working with the TransientBRep object.

You are here: Symbol Reference > Inventor Library > Objects > Profile3D Interface > Profile3D Properties > Profile3D.Wires Property


Profile3DProxy Interface

Profile3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Profile3D object.

Class Hierarchy
Inventor::Profile3D
    Inventor::Profile3DProxy
Visual Basic
Public Interface Profile3DProxy
Inherits Profile3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > Profile3DProxy Interface


Profile3DProxy Properties

Profile3DProxy Properties
Summary

The properties of the Profile3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > Profile3DProxy Interface > Profile3DProxy Properties


Profile3DProxy.ContainingOccurrence Property

Profile3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > Profile3DProxy Interface > Profile3DProxy Properties > Profile3DProxy.ContainingOccurrence Property


Profile3DProxy.NativeObject Property

Profile3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As Profile3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > Profile3DProxy Interface > Profile3DProxy Properties > Profile3DProxy.NativeObject Property


ProfileEntity Interface

ProfileEntity Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ProfileEntity object represents a curve within a profile path.

Class Hierarchy
Inventor::ProfileEntity
    Inventor::ProfileEntityProxy
Visual Basic
Public Interface ProfileEntity
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ProfileEntityProxy.NativeObject

ProfilePath.Item

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface


ProfileEntity Methods

ProfileEntity Methods
Summary

The methods of the ProfileEntity class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Methods


ProfileEntity.GetReferenceKey Method

ProfileEntity.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Methods > ProfileEntity.GetReferenceKey Method


ProfileEntity Properties

ProfileEntity Properties
Summary

The properties of the ProfileEntity class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Curve | Property that returns the geometry of the entity. The geometry is returned such that the entities are connected in a head-to-tail fashion.
CurveType | Property that returns the type of the curve referenced by the profile entity. This property allows you to determine what type of object will be returned by the Curve property.
EndSketchPoint | Property that returns the that defines the end of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.
OpposedToSketchEntity | Property that returns a Boolean indicating if the parametric flow of the profile entity is in the same direction as the sketch entity it was derived from.
Parent | Property that returns the parent ProfilePath of the entity.
SketchEntity | Property that returns the sketch entity this profile entity was derived from.
StartSketchPoint | Property that gets the that defines the start of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties


ProfileEntity.Application Property

ProfileEntity.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.Application Property


ProfileEntity.AttributeSets Property

ProfileEntity.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.AttributeSets Property


ProfileEntity.Curve Property

ProfileEntity.Curve Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the geometry of the entity. The geometry is returned such that the entities are connected in a head-to-tail fashion.

Visual Basic
Property Curve() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.Curve Property


ProfileEntity.CurveType Property

ProfileEntity.CurveType Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the type of the curve referenced by the profile entity. This property allows you to determine what type of object will be returned by the Curve property.

Visual Basic
Property CurveType() As Curve2dTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.CurveType Property


ProfileEntity.EndSketchPoint Property

ProfileEntity.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the that defines the end of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.

Visual Basic
Property EndSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.EndSketchPoint Property


ProfileEntity.OpposedToSketchEntity Property

ProfileEntity.OpposedToSketchEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Boolean indicating if the parametric flow of the profile entity is in the same direction as the sketch entity it was derived from.

Visual Basic
Property OpposedToSketchEntity() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.OpposedToSketchEntity Property


ProfileEntity.Parent Property

ProfileEntity.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent ProfilePath of the entity.

Visual Basic
Property Parent() As ProfilePath**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.Parent Property


ProfileEntity.SketchEntity Property

ProfileEntity.SketchEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity this profile entity was derived from.

Visual Basic
Property SketchEntity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.SketchEntity Property


ProfileEntity.StartSketchPoint Property

ProfileEntity.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the that defines the start of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.

Visual Basic
Property StartSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.StartSketchPoint Property


ProfileEntity.Type Property

ProfileEntity.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity Interface > ProfileEntity Properties > ProfileEntity.Type Property


ProfileEntity3D Interface

ProfileEntity3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The ProfileEntity3D object represents a curve within a 3D profile path.

Class Hierarchy
Inventor::ProfileEntity3D
    Inventor::ProfileEntity3DProxy
Visual Basic
Public Interface ProfileEntity3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ProfileEntity3DProxy.NativeObject

ProfilePath3D.Item

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface


ProfileEntity3D Methods

ProfileEntity3D Methods
Summary

The methods of the ProfileEntity3D class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Methods


ProfileEntity3D.GetReferenceKey Method

ProfileEntity3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Methods > ProfileEntity3D.GetReferenceKey Method


ProfileEntity3D Properties

ProfileEntity3D Properties
Summary

The properties of the ProfileEntity3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Curve | Property that returns the geometry of the entity. The geometry is returned such that the entities are connected in a head-to-tail fashion.
CurveType | Property that returns the type of the curve referenced by the profile entity. This property allows you to determine what type of object will be returned by the Curve property.
EndSketchPoint | Property that gets the that defines the end of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.
OpposedToSketchEntity | Property that returns a Boolean indicating if the parametric flow of the profile entity is in the same direction as the sketch entity it was derived from.
Parent | Property that returns the parent ProfilePath3D of the entity.
SketchEntity | Property that gets the sketch entity this profile entity was derived from.
StartSketchPoint | Property that gets the that defines the start of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties


ProfileEntity3D.Application Property

ProfileEntity3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.Application Property


ProfileEntity3D.AttributeSets Property

ProfileEntity3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.AttributeSets Property


ProfileEntity3D.Curve Property

ProfileEntity3D.Curve Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the geometry of the entity. The geometry is returned such that the entities are connected in a head-to-tail fashion.

Visual Basic
Property Curve() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.Curve Property


ProfileEntity3D.CurveType Property

ProfileEntity3D.CurveType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the type of the curve referenced by the profile entity. This property allows you to determine what type of object will be returned by the Curve property.

Visual Basic
Property CurveType() As CurveTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.CurveType Property


ProfileEntity3D.EndSketchPoint Property

ProfileEntity3D.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the that defines the end of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.

Visual Basic
Property EndSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.EndSketchPoint Property


ProfileEntity3D.OpposedToSketchEntity Property

ProfileEntity3D.OpposedToSketchEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Boolean indicating if the parametric flow of the profile entity is in the same direction as the sketch entity it was derived from.

Visual Basic
Property OpposedToSketchEntity() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.OpposedToSketchEntity Property


ProfileEntity3D.Parent Property

ProfileEntity3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent ProfilePath3D of the entity.

Visual Basic
Property Parent() As ProfilePath3D**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.Parent Property


ProfileEntity3D.SketchEntity Property

ProfileEntity3D.SketchEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the sketch entity this profile entity was derived from.

Visual Basic
Property SketchEntity() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.SketchEntity Property


ProfileEntity3D.StartSketchPoint Property

ProfileEntity3D.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the that defines the start of the profile entity. This property is not valid in the case where the curve is a periodic curve, i.e. circle, ellipse, etc.

Visual Basic
Property StartSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.StartSketchPoint Property


ProfileEntity3D.Type Property

ProfileEntity3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3D Interface > ProfileEntity3D Properties > ProfileEntity3D.Type Property


ProfileEntity3DProxy Interface

ProfileEntity3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfileEntity3D object.

Class Hierarchy
Inventor::ProfileEntity3D
    Inventor::ProfileEntity3DProxy
Visual Basic
Public Interface ProfileEntity3DProxy
Inherits ProfileEntity3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3DProxy Interface


ProfileEntity3DProxy Properties

ProfileEntity3DProxy Properties
Summary

The properties of the ProfileEntity3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3DProxy Interface > ProfileEntity3DProxy Properties


ProfileEntity3DProxy.ContainingOccurrence Property

ProfileEntity3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3DProxy Interface > ProfileEntity3DProxy Properties > ProfileEntity3DProxy.ContainingOccurrence Property


ProfileEntity3DProxy.NativeObject Property

ProfileEntity3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ProfileEntity3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntity3DProxy Interface > ProfileEntity3DProxy Properties > ProfileEntity3DProxy.NativeObject Property


ProfileEntityProxy Interface

ProfileEntityProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfileEntity object.

Class Hierarchy
Inventor::ProfileEntity
    Inventor::ProfileEntityProxy
Visual Basic
Public Interface ProfileEntityProxy
Inherits ProfileEntity
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntityProxy Interface


ProfileEntityProxy Properties

ProfileEntityProxy Properties
Summary

The properties of the ProfileEntityProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ProfileEntityProxy Interface > ProfileEntityProxy Properties


ProfileEntityProxy.ContainingOccurrence Property

ProfileEntityProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntityProxy Interface > ProfileEntityProxy Properties > ProfileEntityProxy.ContainingOccurrence Property


ProfileEntityProxy.NativeObject Property

ProfileEntityProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ProfileEntity**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfileEntityProxy Interface > ProfileEntityProxy Properties > ProfileEntityProxy.NativeObject Property


ProfilePath Interface

ProfilePath Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ProfilePath object represents a single set of connected curves or a text box. The order of the collection defines the connected order of the entities. See the article in the overviews section.

Class Hierarchy
Inventor::ProfilePath
    Inventor::ProfilePathProxy
Visual Basic
Public Interface ProfilePath
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Profile.Item

ProfileEntity.Parent

ProfilePathProxy.NativeObject

See Also

Sketch profile control sample

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface


ProfilePath Methods

ProfilePath Methods
Summary

The methods of the ProfilePath class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this ProfilePath object. This method can be used to delete profile paths that represent a set of connected curves as well as profile paths that represent text boxes.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Property that returns the specified ProfileEntity object from the collection. This property is only valid if the profile path denotes a set of connected curves. On the other hand, if the profile path denotes a text box, which will be indicated by the value of the TextPath property being True, then this property does not apply.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Methods


ProfilePath.Delete Method

ProfilePath.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes this ProfilePath object. This method can be used to delete profile paths that represent a set of connected curves as well as profile paths that represent text boxes.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Methods > ProfilePath.Delete Method


ProfilePath.GetReferenceKey Method

ProfilePath.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Methods > ProfilePath.GetReferenceKey Method


ProfilePath.Item Method

ProfilePath.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified ProfileEntity object from the collection. This property is only valid if the profile path denotes a set of connected curves. On the other hand, if the profile path denotes a text box, which will be indicated by the value of the TextPath property being True, then this property does not apply.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ProfileEntity*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Methods > ProfilePath.Item Method


ProfilePath Properties

ProfilePath Properties
Summary

The properties of the ProfilePath class are listed here.

Properties
Name | Description
AddsMaterial | Property that indicates a Boolean indicating whether the path adds or removes material from the entire area. Returns True in the case where the path adds material. This property is read-only in the case where the parent profile is obtained from an existing feature. If the profile path represents a text box, then this property will always be True, specifying a value of False will cause an error.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Closed | Property that returns a Boolean indicating if the path is closed or not. Returns True in the case of a closed path. This property is only valid if the profile path denotes a set of connected curves. On the other hand, if the profile path denotes a text box, which will be indicated by the value of the TextPath property being True, then this property does not apply.
Count | Property that returns the number of items in this collection. This property is only valid if the profile path denotes a set of connected curves. On the other hand, if the profile path denotes a text box, which will be indicated by the value of the TextPath property being True, then this property does not apply.
Parent | Property that returns the parent Profile.
TextBox | Property that gets the text box this profile path was derived from. This property is only valid if the profile path denotes a text box which will be indicated by the value of the TextPath property being True. On the other hand, if the profile path denotes a set of connected curves, then this property does not apply and will return Nothing.
TextBoxPath | Property that returns a Boolean indicating if the profile path denotes a text box. Returns True in the case that the path denotes a text box. If the profile path denotes a set of connected curves, then this property will return False.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties


ProfilePath.AddsMaterial Property

ProfilePath.AddsMaterial Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates a Boolean indicating whether the path adds or removes material from the entire area. Returns True in the case where the path adds material. This property is read-only in the case where the parent profile is obtained from an existing feature. If the profile path represents a text box, then this property will always be True, specifying a value of False will cause an error.

Visual Basic
Property AddsMaterial() As VARIANT_BOOL
Example

"Sketch profile control."

This sample demonstrates the usage of the Profiles API to control the shape of the profile. The sample creates three concntric circles and creates an extrusion of the region between the inner circles.

Public Sub SketchProfileControl()
' Create a new part document, using the default part template.
Dim oPartDoc As PartDocument
Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

' Set a reference to the component definition.
Dim oCompDef As PartComponentDefinition
Set oCompDef = oPartDoc.ComponentDefinition

' Create a new sketch on the X-Y work plane. Since it's being created on
' one of the base workplanes we know the orientation it will be created in
' and don't need to worry about controlling it. Because of this we also
' know the origin of the sketch plane will be at (0,0,0) in model space.
Dim oSketch As PlanarSketch
Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

' Set a reference to the transient geometry object.
Dim oTransGeom As TransientGeometry
Set oTransGeom = ThisApplication.TransientGeometry

' Draw 3 concentric circles.

Dim oCircle1 As SketchCircle
Set oCircle1 = oSketch.SketchCircles.AddByCenterRadius( _
oTransGeom.CreatePoint2d(5, 5), 6)

Dim oCircle2 As SketchCircle
Set oCircle2 = oSketch.SketchCircles.AddByCenterRadius( _
oTransGeom.CreatePoint2d(5, 5), 4)

Dim oCircle3 As SketchCircle
Set oCircle3 = oSketch.SketchCircles.AddByCenterRadius( _
oTransGeom.CreatePoint2d(5, 5), 2)

' Create a profile.
Dim oProfile As Profile
Set oProfile = oSketch.Profiles.AddForSolid

' Modify the profile: the returned profile consists of 3
' paths each corresponding to a sketch circle. The desired
' result is that the innermost path removes material and the
' second path adds material. The outermost path is not needed
' and is hence deleted.
Dim oProfPath As ProfilePath
For Each oProfPath In oProfile
  If oProfPath.Item(1).SketchEntity Is oCircle3 Then
    oProfPath.AddsMaterial = False
  ElseIf oProfPath.Item(1).SketchEntity Is oCircle2 Then
    oProfPath.AddsMaterial = False
  Else
    oProfPath.Delete
  End If
Next

' Create a base extrusion 1cm thick.
Dim oExtrude As ExtrudeFeature
Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
oProfile, 1, kNegativeExtentDirection, kJoinOperation)

'Make the sketch visible for better visualization
oSketch.Visible = True
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.AddsMaterial Property


ProfilePath.Application Property

ProfilePath.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.Application Property


ProfilePath.AttributeSets Property

ProfilePath.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.AttributeSets Property


ProfilePath.Closed Property

ProfilePath.Closed Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Boolean indicating if the path is closed or not. Returns True in the case of a closed path. This property is only valid if the profile path denotes a set of connected curves. On the other hand, if the profile path denotes a text box, which will be indicated by the value of the TextPath property being True, then this property does not apply.

Visual Basic
Property Closed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.Closed Property


ProfilePath.Count Property

ProfilePath.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection. This property is only valid if the profile path denotes a set of connected curves. On the other hand, if the profile path denotes a text box, which will be indicated by the value of the TextPath property being True, then this property does not apply.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.Count Property


ProfilePath.Parent Property

ProfilePath.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent Profile.

Visual Basic
Property Parent() As Profile**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.Parent Property


ProfilePath.TextBox Property

ProfilePath.TextBox Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets the text box this profile path was derived from. This property is only valid if the profile path denotes a text box which will be indicated by the value of the TextPath property being True. On the other hand, if the profile path denotes a set of connected curves, then this property does not apply and will return Nothing.

Visual Basic
Property TextBox() As TextBox**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.TextBox Property


ProfilePath.TextBoxPath Property

ProfilePath.TextBoxPath Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a Boolean indicating if the profile path denotes a text box. Returns True in the case that the path denotes a text box. If the profile path denotes a set of connected curves, then this property will return False.

Visual Basic
Property TextBoxPath() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.TextBoxPath Property


ProfilePath.Type Property

ProfilePath.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath Interface > ProfilePath Properties > ProfilePath.Type Property


ProfilePath3D Interface

ProfilePath3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The ProfilePath3D object represents a single set of connected 3D curves. The order of the collection defines the connected order of the entities.

Class Hierarchy
Inventor::ProfilePath3D
    Inventor::ProfilePath3DProxy
Visual Basic
Public Interface ProfilePath3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Profile3D.Item

ProfileEntity3D.Parent

ProfilePath3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface


ProfilePath3D Methods

ProfilePath3D Methods
Summary

The methods of the ProfilePath3D class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
Item | Method that returns the specified ProfileEntity3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Methods


ProfilePath3D.GetReferenceKey Method

ProfilePath3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Methods > ProfilePath3D.GetReferenceKey Method


ProfilePath3D.Item Method

ProfilePath3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified ProfileEntity3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ProfileEntity3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Methods > ProfilePath3D.Item Method


ProfilePath3D Properties

ProfilePath3D Properties
Summary

The properties of the ProfilePath3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Closed | Property that returns a Boolean indicating if the path is closed or not. Returns True in the case of a closed path.
Count | Property that returns the number of items in the collection.
Parent | Property that returns the parent Profile3D.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties


ProfilePath3D.Application Property

ProfilePath3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties > ProfilePath3D.Application Property


ProfilePath3D.AttributeSets Property

ProfilePath3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties > ProfilePath3D.AttributeSets Property


ProfilePath3D.Closed Property

ProfilePath3D.Closed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Boolean indicating if the path is closed or not. Returns True in the case of a closed path.

Visual Basic
Property Closed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties > ProfilePath3D.Closed Property


ProfilePath3D.Count Property

ProfilePath3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties > ProfilePath3D.Count Property


ProfilePath3D.Parent Property

ProfilePath3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent Profile3D.

Visual Basic
Property Parent() As Profile3D**
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties > ProfilePath3D.Parent Property


ProfilePath3D.Type Property

ProfilePath3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3D Interface > ProfilePath3D Properties > ProfilePath3D.Type Property


ProfilePath3DProxy Interface

ProfilePath3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfilePath3D object.

Class Hierarchy
Inventor::ProfilePath3D
    Inventor::ProfilePath3DProxy
Visual Basic
Public Interface ProfilePath3DProxy
Inherits ProfilePath3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3DProxy Interface


ProfilePath3DProxy Properties

ProfilePath3DProxy Properties
Summary

The properties of the ProfilePath3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3DProxy Interface > ProfilePath3DProxy Properties


ProfilePath3DProxy.ContainingOccurrence Property

ProfilePath3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3DProxy Interface > ProfilePath3DProxy Properties > ProfilePath3DProxy.ContainingOccurrence Property


ProfilePath3DProxy.NativeObject Property

ProfilePath3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ProfilePath3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfilePath3DProxy Interface > ProfilePath3DProxy Properties > ProfilePath3DProxy.NativeObject Property


ProfilePathProxy Interface

ProfilePathProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProfilePath object.

Class Hierarchy
Inventor::ProfilePath
    Inventor::ProfilePathProxy
Visual Basic
Public Interface ProfilePathProxy
Inherits ProfilePath
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ProfilePathProxy Interface


ProfilePathProxy Properties

ProfilePathProxy Properties
Summary

The properties of the ProfilePathProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ProfilePathProxy Interface > ProfilePathProxy Properties


ProfilePathProxy.ContainingOccurrence Property

ProfilePathProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfilePathProxy Interface > ProfilePathProxy Properties > ProfilePathProxy.ContainingOccurrence Property


ProfilePathProxy.NativeObject Property

ProfilePathProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ProfilePath**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfilePathProxy Interface > ProfilePathProxy Properties > ProfilePathProxy.NativeObject Property


ProfileProxy Interface

ProfileProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Profile object.

Class Hierarchy
Inventor::Profile
    Inventor::ProfileProxy
Visual Basic
Public Interface ProfileProxy
Inherits Profile
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ProfileProxy Interface


ProfileProxy Properties

ProfileProxy Properties
Summary

The properties of the ProfileProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ProfileProxy Interface > ProfileProxy Properties


ProfileProxy.ContainingOccurrence Property

ProfileProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfileProxy Interface > ProfileProxy Properties > ProfileProxy.ContainingOccurrence Property


ProfileProxy.NativeObject Property

ProfileProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As Profile**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProfileProxy Interface > ProfileProxy Properties > ProfileProxy.NativeObject Property


Profiles Interface

Profiles Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

Provides access to all of the objects owned by a particular X and supports the methods to create additional Profiles. See the article in the overviews section.

Class Hierarchy
Inventor::Profiles
Visual Basic
Public Interface Profiles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingSketch.Profiles

PlanarSketch.Profiles

See Also

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Using Inventor's error dialog sample

Sketch profile control sample

Sketch Share sample

Edit profile of an extrude feature sample

Thread Feature Create sample

Sweep Feature Add sample

SurfaceBody Copy sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Accessing region properties from a profile sample

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface


Profiles Methods

Profiles Methods
Summary

The methods of the Profiles class are listed here.

Methods
Methods
Name | Description
AddForSolid | Method that creates a profile containing multiple paths for creating solid features. The paths can include sketch curves as well as text boxes. Individual paths in the returned profile may be deleted to obtain the desired profile.
AddForSurface | Method that creates a profile for creating surface features. The resulting profile could be open or closed.
Item | Property that returns the specified Profile object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Methods


Profiles.AddForSolid Method

Profiles.AddForSolid Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a profile containing multiple paths for creating solid features. The paths can include sketch curves as well as text boxes. Individual paths in the returned profile may be deleted to obtain the desired profile.

Visual Basic
Sub AddForSolid(ByRef Combine As [defaultvalue(-1)] VARIANT_BOOL, ByRef ProfilePathSegments As [optional] VARIANT, ByRef Reserved As [optional] VARIANT, Result As [out, retval] Profile*)
Parameters
Parameters | Description
Combine | Optional input Boolean that specifies whether to combine the profile paths obtained when this method is used to create a new profile. For instance, let us take the example of a sketch containing two concentric circles. If this argument is specified to be true, the resulting profile will contain 2 profile paths, and the profile path corresponding to the inner circle will have its AddsMaterial flag set to False. Hence, the resulting profile is a circular disc with a circular cut-out. If the Combine flag is specified to be False, the resulting profile will contain 2 profile paths with the AddsMaterial flag set to True for both paths. If the sketch contains text boxes, then the profile paths corresponding to them will always have the AddsMaterial flag set to True irrespective of whether the Combine flag is specified to be True or False.
ProfilePathSegments | Optional input ObjectCollection that can contain sketch curves as well as text boxes. If sketch curves are specified, then the profile created by this method will include profile paths that are comprised of the exact set of sketch curves specified in the ObjectCollection. If text boxes are specified, then the profile created by this method will include profile paths that correspond to the exact set of text boxes specified in the ObjectCollection. Each text box in the collection will correspond to a unique profile path. If not specified, all the possible profile paths including sketch curves as well as text boxes will be included. This argument is ignored if the Combine argument is specified to be True.
reserved | Optional input Variant reserved for future use. This argument is currently ignored.
Remarks

If sketch curves are included in the profile, the topological information defined by the intersection and connection of sketch entities with one another is used to define the various profile paths. A profile path consists of one or more profile entities. If a profile path contains only one profile entity, then it implies that a single sketch curve (e.g. a sketch circle) defines the profile path. If the profile path comprises of multiple profile entities, then a set of connected sketch curves defines the profile path with each profile entity representing an entire sketch curve or a portion of it. If text boxes are included in the profile, then each text box will be associated with a single profile path. Since a single instance of a text box that contains some text essentially consists of a group of one or more characters which have a certain thickness, the outline of each character in the text can be considered to form a closed loop. All the characters in a given text box will be treated as a single entity and grouped to form a single profile path. The profile paths defined by the sketch curves will be independently determined from the profile paths defined by the text boxes. The sketch curves will be evaluated based on their topological information to define a set of profile paths that comprises of only the sketch curves. The text boxes will be used to define a different set of profile paths such that each text box will correspond to a unique profile path. Therefore, a given profile path will either include sketch curves or a single text box but not both.

See Also

Create sheet metal face and fold features sample

Using Inventor's error dialog sample

Sketch profile control sample

Edit profile of an extrude feature sample

Thread Feature Create sample

Sweep Feature Add sample

SurfaceBody Copy sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Create sheet metal face and cut features sample

Accessing region properties from a profile sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude sketch text sample

Extrude Feature - Create Block with Pocket sample

Sketch fill region sample

Derived Parts and Assemblies sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Methods > Profiles.AddForSolid Method


Profiles.AddForSurface Method

Profiles.AddForSurface Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a profile for creating surface features. The resulting profile could be open or closed.

Visual Basic
Sub AddForSurface(ByRef Curve As [optional] VARIANT, Result As [out, retval] Profile*)
Parameters
Parameters | Description
Curve | Optional input sketch curve. The method retrieves the end connected chain of entities that this curve is a part of and creates a profile. If not specified, the method will create a new profile by examining the contents of the sketch and creating a single connected path.
See Also

Adding a new stitch (knit) feature sample

You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Methods > Profiles.AddForSurface Method


Profiles.Item Method

Profiles.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified Profile object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Profile*)
Parameters
Parameters | Description
index | Input Long that specifies the index of the Profile to return.
You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Methods > Profiles.Item Method


Profiles Properties

Profiles Properties
Summary

The properties of the Profiles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Properties


Profiles.Application Property

Profiles.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Properties > Profiles.Application Property


Profiles.Count Property

Profiles.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Properties > Profiles.Count Property


Profiles.Type Property

Profiles.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Profiles Interface > Profiles Properties > Profiles.Type Property


Profiles3D Interface

Profiles3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Provides access to all of the 3d profiles owned by a particular 3d sketch and supports the methods to create additional 3d profiles.

Class Hierarchy
Inventor::Profiles3D
Visual Basic
Public Interface Profiles3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.Profiles3D

You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface


Profiles3D Methods

Profiles3D Methods
Summary

The methods of the Profiles3D class are listed here.

Methods
Methods
Name | Description
AddClosed | Method that creates a new profile by examining the contents of the sketch and creating as many closed paths as possible. The resulting Profile3D is returned.
AddOpen | Method that creates a new profile by examining the contents of the sketch for a set of connected entities and creating as many paths as possible. The paths may be open or closed. The resulting Profile3D is returned.
Item | Method that returns the specified Profile3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Methods


Profiles3D.AddClosed Method

Profiles3D.AddClosed Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new profile by examining the contents of the sketch and creating as many closed paths as possible. The resulting Profile3D is returned.

Visual Basic
Sub AddClosed(Result As [out, retval] Profile3D*)
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Methods > Profiles3D.AddClosed Method


Profiles3D.AddOpen Method

Profiles3D.AddOpen Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new profile by examining the contents of the sketch for a set of connected entities and creating as many paths as possible. The paths may be open or closed. The resulting Profile3D is returned.

Visual Basic
Sub AddOpen(Result As [out, retval] Profile3D*)
See Also

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Methods > Profiles3D.AddOpen Method


Profiles3D.Item Method

Profiles3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified Profile3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Profile3D*)
Parameters
Parameters | Description
index | Input Long that specifies the index of the Profile3D to return.
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Methods > Profiles3D.Item Method


Profiles3D Properties

Profiles3D Properties
Summary

The properties of the Profiles3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Properties


Profiles3D.Application Property

Profiles3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Properties > Profiles3D.Application Property


Profiles3D.Count Property

Profiles3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Properties > Profiles3D.Count Property


Profiles3D.Type Property

Profiles3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Profiles3D Interface > Profiles3D Properties > Profiles3D.Type Property


ProgressBar CoClass

ProgressBar CoClass Available in Inventor Introduced in Inventor 2010
Summary

The ProgressBar object represents an Inventor dialog to show the progress of a certain operation or a series of operations.

Class Hierarchy
Inventor::ProgressBar
Visual Basic
Public Class ProgressBar
Notes

Members through which this object may be accessed include:

Application.CreateProgressBar

Example

The following samples demonstrate the use of Inventor's progress bars using the API.

Public Declare Sub Sleep Lib "kernel32" (ByVal dwMilliseconds As Long)

Public Sub TestDialogProgressBar()

    Dim iStepCount As Long
    iStepCount = 50

    ' Create a new ProgressBar object.
    Dim oProgressBar As ProgressBar
    Set oProgressBar = ThisApplication.CreateProgressBar(False, iStepCount, "Test Progress")

    ' Set the message for the progress bar
    oProgressBar.Message = "Executing some process"

    Dim i As Long
    For i = 1 To iStepCount
        ' Sleep 0.2 sec to simulate some process
        Sleep 200
        oProgressBar.Message = "Executing some process - " & i
        oProgressBar.UpdateProgress
    Next

    ' Terminate the progress bar.
    oProgressBar.Close

End Sub

Public Sub TestStatusBarProgressBar()

    Dim iStepCount As Long
    iStepCount = 50

    ' Create a new ProgressBar object.
    Dim oProgressBar As ProgressBar
    Set oProgressBar = ThisApplication.CreateProgressBar(True, iStepCount, "Test Progress")

    ' Set the message for the progress bar
    oProgressBar.Message = "Executing some process"

    Dim i As Long
    For i = 1 To iStepCount
        ' Sleep 0.2 sec to simulate some process
        Sleep 200
        oProgressBar.Message = "Executing some process - " & i
        oProgressBar.UpdateProgress
    Next

    ' Terminate the progress bar.
    oProgressBar.Close

End Sub
You are here: Symbol Reference > Inventor Library > Objects > ProgressBar CoClass


ProgressBarObject Interface

ProgressBarObject Interface
Summary

The ProgressBar object represents an Inventor dialog to show the progress of a certain operation or a series of operations.

Class Hierarchy
Inventor::ProgressBarObject
Visual Basic
Public Interface ProgressBarObject
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface


ProgressBarObject Methods

ProgressBarObject Methods
Summary

The methods of the ProgressBarObject class are listed here.

Methods
Methods
Name | Description
Close | Method that terminates the progress bar.
UpdateProgress | Method that updates the progress bar by incrementing the progress step by one. The progress bar is displayed when this method is called for the first time. This method should be called as many times as the number of steps provided in the CreateProgressBar
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Methods


ProgressBarObject.Close Method

ProgressBarObject.Close Method
Summary

Method that terminates the progress bar.

Visual Basic
Sub Close()
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Methods > ProgressBarObject.Close Method


ProgressBarObject.UpdateProgress Method

ProgressBarObject.UpdateProgress Method
Summary

Method that updates the progress bar by incrementing the progress step by one. The progress bar is displayed when this method is called for the first time. This method should be called as many times as the number of steps provided in the CreateProgressBar

Visual Basic
Sub UpdateProgress()
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Methods > ProgressBarObject.UpdateProgress Method


ProgressBarObject Properties

ProgressBarObject Properties
Summary

The properties of the ProgressBarObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Message | Property that gets and sets the string specifying the message for the progress bar. This string can be modified before every call to UpdateProgress.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Properties


ProgressBarObject.Application Property

ProgressBarObject.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Properties > ProgressBarObject.Application Property


ProgressBarObject.Message Property

ProgressBarObject.Message Property
Summary

Property that gets and sets the string specifying the message for the progress bar. This string can be modified before every call to UpdateProgress.

Visual Basic
Property Message() As String
See Also

Using Inventor's progress bars sample

You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Properties > ProgressBarObject.Message Property


ProgressBarObject.Type Property

ProgressBarObject.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarObject Interface > ProgressBarObject Properties > ProgressBarObject.Type Property


ProgressBarSink Interface

ProgressBarSink Interface
Summary

The ProgressBar object represents an Inventor dialog to show the progress of a certain operation or a series of operations.

Class Hierarchy
Inventor::ProgressBarSink
Visual Basic
Public Interface ProgressBarSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarSink Interface


ProgressBarSink Methods

ProgressBarSink Methods
Summary

The methods of the ProgressBarSink class are listed here.

Methods
Methods
Name | Description
OnCancel | Event that is fired when the user chooses the cancel button on the progress bar.
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarSink Interface > ProgressBarSink Methods


ProgressBarSink.OnCancel Method

ProgressBarSink.OnCancel Method
Summary

Event that is fired when the user chooses the cancel button on the progress bar.

Visual Basic
Sub OnCancel()
You are here: Symbol Reference > Inventor Library > Objects > ProgressBarSink Interface > ProgressBarSink Methods > ProgressBarSink.OnCancel Method


ProgressiveToolTip Interface

ProgressiveToolTip Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

A ProgressiveToolTip object provides access to enhanced tooltip display for controls in the ribbon interface.

Class Hierarchy
Inventor::ProgressiveToolTip
Visual Basic
Public Interface ProgressiveToolTip
Inherits IDispatch
Remarks

A " Title

B " Description

C " ExpandedDescription

D " Image (typically 304 x 188 pixels)

E " Help (The ButtonDefinition.OnHelp event fires when the user hits F1)

Notes

Members through which this object may be accessed include:

ControlDefinition.ProgressiveToolTip

You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface


ProgressiveToolTip Properties

ProgressiveToolTip Properties
Summary

The properties of the ProgressiveToolTip class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Description | Property that gets and sets the short description of the progressive tooltip. Setting this property fails for a built-in definition.
ExpandedDescription | Property that gets and sets the long description of the progressive tooltip. Setting this property fails for a built-in definition.
Image | Property that gets and sets the image to use for the progressive tooltip. The standard recommended size is 304 x 188 pixels. This property can either be set to an IPictureDisp object or a string indicating a URI (uniform resource identifier). Setting this property fails for a built-in definition.
IsProgressive | Property that gets and sets whether the second level content (ExpandedDescription and Image) is displayed after a delay.
Parent | Property that returns the parent of the ControlDefinition object.
Title | Property that gets and sets the title of the progressive tooltip. Setting this property fails for a built-in definition.
Type | Property returning kProgressiveToolTipObject indicating this object's type.
Video | Property that gets and sets the video clip to use for the progressive tooltip.
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties


ProgressiveToolTip.Application Property

ProgressiveToolTip.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Application Property


ProgressiveToolTip.Description Property

ProgressiveToolTip.Description Property Introduced in Inventor 2011
Summary

Property that gets and sets the short description of the progressive tooltip. Setting this property fails for a built-in definition.

Visual Basic
Property Description() As String
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Description Property


ProgressiveToolTip.ExpandedDescription Property

ProgressiveToolTip.ExpandedDescription Property Introduced in Inventor 2011
Summary

Property that gets and sets the long description of the progressive tooltip. Setting this property fails for a built-in definition.

Visual Basic
Property ExpandedDescription() As String
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.ExpandedDescription Property


ProgressiveToolTip.Image Property

ProgressiveToolTip.Image Property Introduced in Inventor 2011
Summary

Property that gets and sets the image to use for the progressive tooltip. The standard recommended size is 304 x 188 pixels. This property can either be set to an IPictureDisp object or a string indicating a URI (uniform resource identifier). Setting this property fails for a built-in definition.

Visual Basic
Property Image() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Image Property


ProgressiveToolTip.IsProgressive Property

ProgressiveToolTip.IsProgressive Property Introduced in Inventor 2011
Summary

Property that gets and sets whether the second level content (ExpandedDescription and Image) is displayed after a delay.

Visual Basic
Property IsProgressive() As VARIANT_BOOL
Remarks

If the value is set to False, the second level content is displayed along with main content. This property is not applicable if ExpandedDescription and Image properties are not set. The default value of this property is True. Setting this property fails for a built-in definition.

You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.IsProgressive Property


ProgressiveToolTip.Parent Property

ProgressiveToolTip.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent of the ControlDefinition object.

Visual Basic
Property Parent() As ControlDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Parent Property


ProgressiveToolTip.Title Property

ProgressiveToolTip.Title Property Introduced in Inventor 2011
Summary

Property that gets and sets the title of the progressive tooltip. Setting this property fails for a built-in definition.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Title Property


ProgressiveToolTip.Type Property

ProgressiveToolTip.Type Property Introduced in Inventor 2011
Summary

Property returning kProgressiveToolTipObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Type Property


ProgressiveToolTip.Video Property

ProgressiveToolTip.Video Property
Summary

Property that gets and sets the video clip to use for the progressive tooltip.

Visual Basic
Property Video() As String
Remarks

The standard recommended size is 304 x 188 pixels. This property can either be set to the full file name indicating the video clip or a string indicating a URI (uniform resource identifier). Video clips are currently restricted to the wmv format.

You are here: Symbol Reference > Inventor Library > Objects > ProgressiveToolTip Interface > ProgressiveToolTip Properties > ProgressiveToolTip.Video Property


ProjectedCut Interface

ProjectedCut Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ProjectedCut object represents a set of projected cut edges on the sketch.

Class Hierarchy
Inventor::ProjectedCut
    Inventor::ProjectedCutProxy
Visual Basic
Public Interface ProjectedCut
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ProjectedCutProxy.NativeObject

ProjectedCuts.Add

ProjectedCuts.Item

You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface


ProjectedCut Methods

ProjectedCut Methods
Summary

The methods of the ProjectedCut class are listed here.

Methods
Methods
Name | Description
BreakLink | Method that breaks the link between the projected cut edges and the model.
Delete | Method that deletes the projected cut edges.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Methods


ProjectedCut.BreakLink Method

ProjectedCut.BreakLink Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that breaks the link between the projected cut edges and the model.

Visual Basic
Sub BreakLink()
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Methods > ProjectedCut.BreakLink Method


ProjectedCut.Delete Method

ProjectedCut.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the projected cut edges.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Methods > ProjectedCut.Delete Method


ProjectedCut.GetReferenceKey Method

ProjectedCut.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Methods > ProjectedCut.GetReferenceKey Method


ProjectedCut Properties

ProjectedCut Properties
Summary

The properties of the ProjectedCut class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Name | Property that gets and sets name of the projected cut edges. When setting this property, the name must be unique with respect to all other projected cut edges in the document. If the name is not unique an error will occur.
Parent | Property that returns the parent sketch of the projected cut edges.
SketchEntities | Property that returns a collection of sketch entities that belong to the projected cut edges. The sketch entities returned by this property cannot be edited or deleted because they are associated with the projected edges in the model.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties


ProjectedCut.Application Property

ProjectedCut.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties > ProjectedCut.Application Property


ProjectedCut.AttributeSets Property

ProjectedCut.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties > ProjectedCut.AttributeSets Property


ProjectedCut.Name Property

ProjectedCut.Name Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets name of the projected cut edges. When setting this property, the name must be unique with respect to all other projected cut edges in the document. If the name is not unique an error will occur.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties > ProjectedCut.Name Property


ProjectedCut.Parent Property

ProjectedCut.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent sketch of the projected cut edges.

Visual Basic
Property Parent() As PlanarSketch**
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties > ProjectedCut.Parent Property


ProjectedCut.SketchEntities Property

ProjectedCut.SketchEntities Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a collection of sketch entities that belong to the projected cut edges. The sketch entities returned by this property cannot be edited or deleted because they are associated with the projected edges in the model.

Visual Basic
Property SketchEntities() As SketchEntitiesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties > ProjectedCut.SketchEntities Property


ProjectedCut.Type Property

ProjectedCut.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCut Interface > ProjectedCut Properties > ProjectedCut.Type Property


ProjectedCutProxy Interface

ProjectedCutProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ProjectedCut object.

Class Hierarchy
Inventor::ProjectedCut
    Inventor::ProjectedCutProxy
Visual Basic
Public Interface ProjectedCutProxy
Inherits ProjectedCut
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ProjectedCutProxy Interface


ProjectedCutProxy Properties

ProjectedCutProxy Properties
Summary

The properties of the ProjectedCutProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCutProxy Interface > ProjectedCutProxy Properties


ProjectedCutProxy.ContainingOccurrence Property

ProjectedCutProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProjectedCutProxy Interface > ProjectedCutProxy Properties > ProjectedCutProxy.ContainingOccurrence Property


ProjectedCutProxy.NativeObject Property

ProjectedCutProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ProjectedCut**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ProjectedCutProxy Interface > ProjectedCutProxy Properties > ProjectedCutProxy.NativeObject Property


ProjectedCuts Interface

ProjectedCuts Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The ProjectedCuts object provides access to all of the projected cut edges on the sketch.

Class Hierarchy
Inventor::ProjectedCuts
Visual Basic
Public Interface ProjectedCuts
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PlanarSketch.ProjectedCuts

You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface


ProjectedCuts Methods

ProjectedCuts Methods
Summary

The methods of the ProjectedCuts class are listed here.

Methods
Methods
Name | Description
Add | Method that adds projected cut edges by intersecting the model with the sketch plane and creating the resulting sketch entities. This method performs the same function as the Project Cut Edges command.
Item | Method that returns the specified ProjectedCut object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Methods


ProjectedCuts.Add Method

ProjectedCuts.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that adds projected cut edges by intersecting the model with the sketch plane and creating the resulting sketch entities. This method performs the same function as the Project Cut Edges command.

Visual Basic
Sub Add(Result As [out, retval] ProjectedCut*)
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Methods > ProjectedCuts.Add Method


ProjectedCuts.Item Method

ProjectedCuts.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified ProjectedCut object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ProjectedCut*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the projected cut edges to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the name of the projected cut edges. If an out of range index or a name of a non-existent projected cut edges is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Methods > ProjectedCuts.Item Method


ProjectedCuts Properties

ProjectedCuts Properties
Summary

The properties of the ProjectedCuts class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Properties


ProjectedCuts.Application Property

ProjectedCuts.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Properties > ProjectedCuts.Application Property


ProjectedCuts.Count Property

ProjectedCuts.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Properties > ProjectedCuts.Count Property


ProjectedCuts.Type Property

ProjectedCuts.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProjectedCuts Interface > ProjectedCuts Properties > ProjectedCuts.Type Property


ProjectPath Interface

ProjectPath Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The ProjectPath object represents a folder path for a library, workspace or a workgroup.

Class Hierarchy
Inventor::ProjectPath
Visual Basic
Public Interface ProjectPath
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ProjectPaths.Add

ProjectPaths.Item

See Also

Query and create library paths sample

You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface


ProjectPath Methods

ProjectPath Methods
Summary

The methods of the ProjectPath class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this path from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Methods


ProjectPath.Delete Method

ProjectPath.Delete Method
Summary

Method that deletes this path from the collection.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Methods > ProjectPath.Delete Method


ProjectPath Properties

ProjectPath Properties
Summary

The properties of the ProjectPath class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Name | Property that gets and sets the name of the folder path.
Parent | Property that returns the parent DesignProject object.
Path | Property that gets and sets the folder path associated with this object.
Type | Property returning kProjectPathObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Properties


ProjectPath.Application Property

ProjectPath.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Properties > ProjectPath.Application Property


ProjectPath.Name Property

ProjectPath.Name Property Introduced in Inventor 2011
Summary

Property that gets and sets the name of the folder path.

Visual Basic
Property Name() As String
See Also

Query and create library paths sample

You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Properties > ProjectPath.Name Property


ProjectPath.Parent Property

ProjectPath.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent DesignProject object.

Visual Basic
Property Parent() As DesignProject**
You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Properties > ProjectPath.Parent Property


ProjectPath.Path Property

ProjectPath.Path Property Introduced in Inventor 2011
Summary

Property that gets and sets the folder path associated with this object.

Visual Basic
Property Path() As String
See Also

Query and create library paths sample

You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Properties > ProjectPath.Path Property


ProjectPath.Type Property

ProjectPath.Type Property Introduced in Inventor 2011
Summary

Property returning kProjectPathObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProjectPath Interface > ProjectPath Properties > ProjectPath.Type Property


ProjectPaths Interface

ProjectPaths Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The ProjectPaths collection object provides access to a list of folder paths and provides ability to add/remove paths.

Class Hierarchy
Inventor::ProjectPaths
Visual Basic
Public Interface ProjectPaths
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DesignProject.FrequentlyUsedPaths

DesignProject.LibraryPaths

DesignProject.WorkgroupPaths

See Also

Query and create library paths sample

You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface


ProjectPaths Methods

ProjectPaths Methods
Summary

The methods of the ProjectPaths class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a folder path and returns the newly created ProjectPath object.
AddFromFile | Method that adds folder paths from an existing project (.ipj) file.
Clear | Method that deletes all the paths in the collection.
Item | Property that returns the specified ProjectPath object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Methods


ProjectPaths.Add Method

ProjectPaths.Add Method Introduced in Inventor 2011
Summary

Method that adds a folder path and returns the newly created ProjectPath object.

Visual Basic
Sub Add(Name As String, Path As String, ByRef Index As [defaultvalue(0)] long, Result As [out, retval] ProjectPath*)
Parameters
Parameters | Description
Name | Input String that specifies a display name for the path.
Path | Input String that specifies the folder path.
Index | Optional input Long that specifies the position of the new path in the list. If not specified, the value defaults to 0 and the new path is added to the end of the list.
See Also

Query and create library paths sample

You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Methods > ProjectPaths.Add Method


ProjectPaths.AddFromFile Method

ProjectPaths.AddFromFile Method Introduced in Inventor 2011
Summary

Method that adds folder paths from an existing project (.ipj) file.

Visual Basic
Sub AddFromFile(ProjectFullFileName As String)
Parameters
Parameters | Description
ProjectFullFileName | Input String that specifies the full file name of an Inventor project file with an .ipj extension to add the paths from.
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Methods > ProjectPaths.AddFromFile Method


ProjectPaths.Clear Method

ProjectPaths.Clear Method
Summary

Method that deletes all the paths in the collection.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Methods > ProjectPaths.Clear Method


ProjectPaths.Item Method

ProjectPaths.Item Method Introduced in Inventor 2011
Summary

Property that returns the specified ProjectPath object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ProjectPath*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the ProjectPath to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the project path name. If an out of range index or a name of a non-existent path is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Methods > ProjectPaths.Item Method


ProjectPaths Properties

ProjectPaths Properties
Summary

The properties of the ProjectPaths class are listed here.

Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class ProjectPaths.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kProjectPathsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Properties


ProjectPaths._NewEnum Property

ProjectPaths._NewEnum Property
Summary

This is _NewEnum, a member of class ProjectPaths.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Properties > ProjectPaths._NewEnum Property


ProjectPaths.Application Property

ProjectPaths.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Properties > ProjectPaths.Application Property


ProjectPaths.Count Property

ProjectPaths.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Properties > ProjectPaths.Count Property


ProjectPaths.Type Property

ProjectPaths.Type Property Introduced in Inventor 2011
Summary

Property returning kProjectPathsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ProjectPaths Interface > ProjectPaths Properties > ProjectPaths.Type Property


Property Interface

Property Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a Property. See the article in the overviews section.

Class Hierarchy
Inventor::Property
Visual Basic
Public Interface Property
Inherits IDispatch
Remarks

There are several file properties that return a "date" value (for example, "Date Checked", "Date Mfg Approved", and so on). If these date values have not been set, they return "1/1/1601". Your code should check for this value, and if found, infer that the date has not yet been set.

Notes

Members through which this object may be accessed include:

PropertySet.Add

PropertySet.Item

PropertySet.ItemByPropId

See Also

Change the thumbnail of a document sample

You are here: Symbol Reference > Inventor Library > Objects > Property Interface


Property Methods

Property Methods
Summary

The methods of the Property class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this Property from its PropertySet.
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Methods


Property.Delete Method

Property.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that deletes this Property from its PropertySet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Methods > Property.Delete Method


Property Properties

Property Properties
Summary

The properties of the Property class are listed here.

Properties
Name | Description
Dirty | Property that returns a Boolean flag that indicates whether this property has been edited or created.
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
Expression | Sets or gets the expression contained in this property. Prefix a value with an equals sign "=" to indicate an expression. If a property contains an expression, and the Value property is called, the evaluated value is returned.
Name | Gets the human-readable name of this Property, if any.
Parent | Property that returns the parent object from whom this object can logically be reached.
PropId | Gets the identifier (PROPID) of this Property.
Type | Property returning an enum indicating this object's type.
Value | Sets or gets the value of this property. A value prefixed with an equals sign "=" indicates an expression. If a property contains an expression, the evaluated value is returned. To obtain the unevaluated expression, use the Expression property.
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties


Property.Dirty Property

Property.Dirty Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Boolean flag that indicates whether this property has been edited or created.

Visual Basic
Property Dirty() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.Dirty Property


Property.DisplayName Property

Property.DisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.DisplayName Property


Property.Expression Property

Property.Expression Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Sets or gets the expression contained in this property. Prefix a value with an equals sign "=" to indicate an expression. If a property contains an expression, and the Value property is called, the evaluated value is returned.

Visual Basic
Property Expression() As String
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.Expression Property


Property.Name Property

Property.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the human-readable name of this Property, if any.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.Name Property


Property.Parent Property

Property.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As PropertySet**
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.Parent Property


Property.PropId Property

Property.PropId Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the identifier (PROPID) of this Property.

Visual Basic
Property PropId() As long*
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.PropId Property


Property.Type Property

Property.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.Type Property


Property.Value Property

Property.Value Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Sets or gets the value of this property. A value prefixed with an equals sign "=" indicates an expression. If a property contains an expression, the evaluated value is returned. To obtain the unevaluated expression, use the Expression property.

Visual Basic
Property Value() As VARIANT
Remarks

There are several file properties that return a "date" value (for example, "Date Checked", "Date Mfg Approved", and so on). If these date values have not been set, they return "1/1/1601". Your code should check for this value, and if found, infer that the date has not yet been set.

See Also

Change the thumbnail of a document sample

You are here: Symbol Reference > Inventor Library > Objects > Property Interface > Property Properties > Property.Value Property


PropertySet Interface

PropertySet Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a PropertySet. This is a collection of related Properties. See the article in the overviews section.

Class Hierarchy
Inventor::PropertySet
Visual Basic
Public Interface PropertySet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Property.Parent

PropertySets.Add

PropertySets.Item

See Also

Change the thumbnail of a document sample

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface


PropertySet Methods

PropertySet Methods
Summary

The methods of the PropertySet class are listed here.

Methods
Methods
Name | Description
Add | Adds a new Property to this PropertySet.
Delete | Method that deletes this PropertySet.
Item | Gets the Property given either its name or its sequential index.
ItemByPropId | Gets the Property in this set by its PropId.
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Methods


PropertySet.Add Method

PropertySet.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Adds a new Property to this PropertySet.

Visual Basic
Sub Add(PropValue As VARIANT, ByRef Name As [optional] VARIANT, ByRef PropID As [optional] VARIANT, Result As [out, retval] Property*)
Parameters
Parameters | Description
PropValue | Input Variant that specifies the value of the Property to add to the set.
Name | Input Variant that specifies the name of the Property. If this name is prefixed with an "_" character, then this property is created as a hidden property and can only be accessed if indexed by its name or propID. PropertySet.Count will not account for such hidden properties.
PropId | Input Variant that specifies the PropertyID of the Property to add to the set. Valid propids are 2 through 254 and 256 through 0x80000000. Other values are reserved.
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Methods > PropertySet.Add Method


PropertySet.Delete Method

PropertySet.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that deletes this PropertySet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Methods > PropertySet.Delete Method


PropertySet.Item Method

PropertySet.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Property given either its name or its sequential index.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Property*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the Property to return.
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Methods > PropertySet.Item Method


PropertySet.ItemByPropId Method

PropertySet.ItemByPropId Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Property in this set by its PropId.

Visual Basic
Sub ItemByPropId(PropId As long, Result As [out, retval] Property*)
Parameters
Parameters | Description
PropId | Input Long that specifies the PropertyID of the Property to get from the set. Valid PropIds are 2 through 254 and 256 through 0x80000000. Other values are reserved.
Example

"Change the thumbnail of a document"

This sample demonstrates how to change the thumbnail of a document.

Sub ChangeThumbnail()

    ' Set a reference to the active document
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Get the "Summary Information" property set
    Dim oPropSet As PropertySet
    Set oPropSet = oDoc.PropertySets("{F29F85E0-4FF9-1068-AB91-08002B27B3D9}")

    ' Get the "Thumbnail" property
    Dim oProp As Property
    Set oProp = oPropSet.ItemByPropId(17)

    Dim oDisp As IPictureDisp
    Set oDisp = LoadPicture("C:\temp\thumbnail.bmp")

    ' Set the value of the thumbnail file property
    oProp.Value = oDisp

    ' Save the document
    oDoc.Save
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Methods > PropertySet.ItemByPropId Method


PropertySet Properties

PropertySet Properties
Summary

The properties of the PropertySet class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Dirty | Property that returns a Boolean flag that indicates whether any of the Properties have been edited, deleted or created.
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
InternalName | Gets the unambiguous, internal name (FMTID) associated with this PropertySet.
Name | Gets the name of this PropertySet.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties


PropertySet.Count Property

PropertySet.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.Count Property


PropertySet.Dirty Property

PropertySet.Dirty Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Boolean flag that indicates whether any of the Properties have been edited, deleted or created.

Visual Basic
Property Dirty() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.Dirty Property


PropertySet.DisplayName Property

PropertySet.DisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.DisplayName Property


PropertySet.InternalName Property

PropertySet.InternalName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the unambiguous, internal name (FMTID) associated with this PropertySet.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.InternalName Property


PropertySet.Name Property

PropertySet.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets the name of this PropertySet.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.Name Property


PropertySet.Parent Property

PropertySet.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As PropertySets**
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.Parent Property


PropertySet.Type Property

PropertySet.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PropertySet Interface > PropertySet Properties > PropertySet.Type Property


PropertySets Interface

PropertySets Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that manages the collection of objects and provides the ability to add new property sets to the collection. See the article in the overviews section.

Class Hierarchy
Inventor::PropertySets
Visual Basic
Public Interface PropertySets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.PropertySets

Document.PropertySets

PropertySet.Parent

VirtualComponentDefinition.PropertySets

See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface


PropertySets Methods

PropertySets Methods
Summary

The methods of the PropertySets class are listed here.

Methods
Methods
Name | Description
Add | Adds a new PropertySet. The new set's FMTID can be optionally provided (as a string).
FlushToFile | Flush all of the Properties in each of the PropertySets onto the file. The 'dirty' flags are reset. Please note that this method is available in Apprentice only.
Item | Gets the set in this collection in a sequences fashion; by index, or by its name -- Display or Internal.
RefreshFromFile | Refresh all of the Properties in each of the PropertySets from the File. The 'dirty' flags are reset and any edits are lost. Please note that this method is available in Apprentice only.
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Methods


PropertySets.Add Method

PropertySets.Add Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Adds a new PropertySet. The new set's FMTID can be optionally provided (as a string).

Visual Basic
Sub Add(Name As String, ByRef InternalName As [optional] VARIANT, Result As [out, retval] PropertySet*)
Parameters
Parameters | Description
Name | Name of the PropertySet.
InternalName | Input Variant that specifies the internal name of the PropertySet to be added.
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Methods > PropertySets.Add Method


PropertySets.FlushToFile Method

PropertySets.FlushToFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Flush all of the Properties in each of the PropertySets onto the file. The 'dirty' flags are reset. Please note that this method is available in Apprentice only.

Visual Basic
Sub FlushToFile()
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Methods > PropertySets.FlushToFile Method


PropertySets.Item Method

PropertySets.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the set in this collection in a sequences fashion; by index, or by its name -- Display or Internal.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PropertySet*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the PropertySet to return.
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Methods > PropertySets.Item Method


PropertySets.RefreshFromFile Method

PropertySets.RefreshFromFile Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Refresh all of the Properties in each of the PropertySets from the File. The 'dirty' flags are reset and any edits are lost. Please note that this method is available in Apprentice only.

Visual Basic
Sub RefreshFromFile()
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Methods > PropertySets.RefreshFromFile Method


PropertySets Properties

PropertySets Properties
Summary

The properties of the PropertySets class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Dirty | Property that returns a Boolean flag that indicates whether any of the Properties have been edited, deleted or created.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Properties


PropertySets.Count Property

PropertySets.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Properties > PropertySets.Count Property


PropertySets.Dirty Property

PropertySets.Dirty Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Boolean flag that indicates whether any of the Properties have been edited, deleted or created.

Visual Basic
Property Dirty() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Properties > PropertySets.Dirty Property


PropertySets.Parent Property

PropertySets.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Properties > PropertySets.Parent Property


PropertySets.Type Property

PropertySets.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PropertySets Interface > PropertySets Properties > PropertySets.Type Property


PunchNote Interface

PunchNote Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The PunchNote object represents a punch note with an attached leader on a sheet and derives from the LeaderNote object.

Class Hierarchy
Inventor::DrawingNote
    Inventor::LeaderNote
        Inventor::PunchNote
Visual Basic
Public Interface PunchNote
Inherits LeaderNote
Notes

Members through which this object may be accessed include:

PunchNotes.Add

PunchNotes.Item

You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface


PunchNote Properties

PunchNote Properties
Summary

The properties of the PunchNote class are listed here.

Properties
Name | Description
FormattedPunchNote | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
FormattedQuantityNote | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
HideValue | Property that gets and sets whether to display the punch note value in the note.
PunchEdge | Property that gets and sets the GeometryIntent that defines what the punch note is attached to.
QuantityDefinition | Property that gets and sets how the quantity value is set for the note. The valid values are kNumberOfLikePunchesInFeature and kNumberOfLikePunchesInModel.
UsePartUnits | Property that gets and sets whether to use model units or the units specified by dimension style. Model units are used if the property is set to True.
You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties


PunchNote.FormattedPunchNote Property

PunchNote.FormattedPunchNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedPunchNote() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties > PunchNote.FormattedPunchNote Property


PunchNote.FormattedQuantityNote Property

PunchNote.FormattedQuantityNote Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedQuantityNote() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties > PunchNote.FormattedQuantityNote Property


PunchNote.HideValue Property

PunchNote.HideValue Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display the punch note value in the note.

Visual Basic
Property HideValue() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties > PunchNote.HideValue Property


PunchNote.PunchEdge Property

PunchNote.PunchEdge Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GeometryIntent that defines what the punch note is attached to.

Visual Basic
Property PunchEdge() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties > PunchNote.PunchEdge Property


PunchNote.QuantityDefinition Property

PunchNote.QuantityDefinition Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets how the quantity value is set for the note. The valid values are kNumberOfLikePunchesInFeature and kNumberOfLikePunchesInModel.

Visual Basic
Property QuantityDefinition() As PunchNoteQuantityEnum
You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties > PunchNote.QuantityDefinition Property


PunchNote.UsePartUnits Property

PunchNote.UsePartUnits Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use model units or the units specified by dimension style. Model units are used if the property is set to True.

Visual Basic
Property UsePartUnits() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > PunchNote Interface > PunchNote Properties > PunchNote.UsePartUnits Property


PunchNotes Interface

PunchNotes Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The PunchNotes collection object provides access to all of the punch notes on the sheet.

Class Hierarchy
Inventor::PunchNotes
Visual Basic
Public Interface PunchNotes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingNotes.PunchNotes

See Also

create punch note sample

You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface


PunchNotes Methods

PunchNotes Methods
Summary

The methods of the PunchNotes class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a punch note on the sheet based on the input punch edge.
Item | Property that returns the specified PunchNote object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Methods


PunchNotes.Add Method

PunchNotes.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a punch note on the sheet based on the input punch edge.

Visual Basic
Sub Add(Position As Point2d, PunchEdge As GeometryIntent, ByRef DimensionStyle As [optional] VARIANT, Result As [out, retval] PunchNote*)
Parameters
Parameters | Description
Position | Input Point2d that specifies the position of the punch note on the sheet.
PunchEdge | Input GeometryIntent object that specifies the punch geomery to create the note for. The GeometryIntent object defines the geometry (typically a curve but can also be a center mark that represents the origin of a punch) and the location on the geometry where the note will point. If the GeometryIntent does not represent a punch edge or punch center, the method returns an error.
DimensionStyle | Optional input Variant that specifies which dimension style to use for the note. The dimension style can be specified by providing the name of an existing style or by supplying a DimensionStyle object.
Example

This sample demonstrates the creation of a punch note on the drawing view of a flat pattern. Select a punch edge on a flat pattern drawing view and run the sample.

Sub AddPunchNote()

    ' Assumes that a drawing document is active
    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    ' Check to make sure a punch edge is selected.
    If oDoc.SelectSet.Count <> 1 Then
        MsgBox "A single punch edge must be selected."
        Exit Sub
    End If

    If Not TypeOf oDoc.SelectSet(1) Is DrawingCurveSegment Then
        MsgBox "A punch edge must be selected."
        Exit Sub
    End If

    Dim oPunchEdge As DrawingCurve
    Set oPunchEdge = oDoc.SelectSet(1).Parent

    If Not (oPunchEdge.EdgeType = kPunchUpEdge Or oPunchEdge.EdgeType = kPunchDownEdge) Then
        MsgBox "A punch edge must be selected."
        Exit Sub
    End If

    Dim oPunchEdgeIntent As GeometryIntent
    Set oPunchEdgeIntent = oDoc.ActiveSheet.CreateGeometryIntent(oPunchEdge)

    Dim oPosition As Point2d
    Set oPosition = ThisApplication.TransientGeometry.CreatePoint2d(5, 25)

    ' Create the punch note
    Dim oPunchNote As PunchNote
    Set oPunchNote = oDoc.ActiveSheet.DrawingNotes.PunchNotes.Add(oPosition, oPunchEdgeIntent)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Methods > PunchNotes.Add Method


PunchNotes.Item Method

PunchNotes.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified PunchNote object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] PunchNote*)
Parameters
Parameters | Description
Index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Methods > PunchNotes.Item Method


PunchNotes Properties

PunchNotes Properties
Summary

The properties of the PunchNotes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kPunchNotesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Properties


PunchNotes.Application Property

PunchNotes.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Properties > PunchNotes.Application Property


PunchNotes.Count Property

PunchNotes.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Properties > PunchNotes.Count Property


PunchNotes.Type Property

PunchNotes.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kPunchNotesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PunchNotes Interface > PunchNotes Properties > PunchNotes.Type Property


PunchToolFeature Interface

PunchToolFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PunchToolFeature object represents the instance of a placed punch tool feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::PunchToolFeature
        Inventor::PunchToolFeatureProxy
Visual Basic
Public Interface PunchToolFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

PunchToolFeatures.Add

PunchToolFeatures.Item

See Also

Sheet Metal Feature Display sample

Add a punch tool feature sample

Report on punch feature ID's sample

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface


PunchToolFeature Properties

PunchToolFeature Properties
Summary

The properties of the PunchToolFeature class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter object that controls the angle of rotation of the punch tool.
Depth | Property that returns the parameter object that defines the custom punch depth.
iFeatureDefinition | Property that returns the associated iFeatureDefinition.
iFeatureTemplateDescriptor | Property that returns the iFeatureTemplateDescriptor object associated with this iFeature.
PunchCenterPoints | Property that gets and sets the set of sketch points that define the origin points for the punch tool. The collection can be obtained, the contents modified, and then provided as input to this property to modify the feature. The input points must all exist within the same sketch or an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface > PunchToolFeature Properties


PunchToolFeature.Angle Property

PunchToolFeature.Angle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter object that controls the angle of rotation of the punch tool.

Visual Basic
Property Angle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface > PunchToolFeature Properties > PunchToolFeature.Angle Property


PunchToolFeature.Depth Property

PunchToolFeature.Depth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter object that defines the custom punch depth.

Visual Basic
Property Depth() As Parameter**
Remarks

If no custom punch depth was defined for this punch tool then this property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface > PunchToolFeature Properties > PunchToolFeature.Depth Property


PunchToolFeature.iFeatureDefinition Property

PunchToolFeature.iFeatureDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the associated iFeatureDefinition.

Visual Basic
Property iFeatureDefinition() As iFeatureDefinition**
Remarks

The associated iFeatureDefinition can be modified to edit an existing punch tool feature.

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface > PunchToolFeature Properties > PunchToolFeature.iFeatureDefinition Property


PunchToolFeature.iFeatureTemplateDescriptor Property

PunchToolFeature.iFeatureTemplateDescriptor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the iFeatureTemplateDescriptor object associated with this iFeature.

Visual Basic
Property iFeatureTemplateDescriptor() As iFeatureTemplateDescriptor**
Remarks

The iFeatureTemplateDescriptor object describes the iFeature file that was used to create the iFeature.

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface > PunchToolFeature Properties > PunchToolFeature.iFeatureTemplateDescriptor Property


PunchToolFeature.PunchCenterPoints Property

PunchToolFeature.PunchCenterPoints Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the set of sketch points that define the origin points for the punch tool. The collection can be obtained, the contents modified, and then provided as input to this property to modify the feature. The input points must all exist within the same sketch or an error will occur.

Visual Basic
Property PunchCenterPoints() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeature Interface > PunchToolFeature Properties > PunchToolFeature.PunchCenterPoints Property


PunchToolFeatureProxy Interface

PunchToolFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the PunchToolFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::PunchToolFeature
        Inventor::PunchToolFeatureProxy
Visual Basic
Public Interface PunchToolFeatureProxy
Inherits PunchToolFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatureProxy Interface


PunchToolFeatures Interface

PunchToolFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The PunchToolFeatures collection object provides access to all of the objects in a sheet metal component definition.

Class Hierarchy
Inventor::PunchToolFeatures
Visual Basic
Public Interface PunchToolFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPatternFeatures.PunchToolFeatures

SheetMetalFeatures.PunchToolFeatures

See Also

Add a punch tool feature sample

Example

"Report on punch feature ID's"

This program demonstrates accessing punch features and creates a report of the punch ID's used.

Public Sub PunchFeatureReport()

    ' Get the active sheet metal document and component
    ' definition of the active document.
    On Error Resume Next
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    If Err Then
        MsgBox "A part must be active."
        Exit Sub
    End If

    Dim oSMDef As SheetMetalComponentDefinition
    Set oSMDef = oPartDoc.ComponentDefinition

    Dim oSMFeatures As SheetMetalFeatures
    Set oSMFeatures = oSMDef.Features

    Dim iUniquePunchCount As Integer
    iUniquePunchCount = 0
    Dim astrPunchIDs() As String
    ReDim astrPunchIDs(1, oSMFeatures.PunchToolFeatures.Count)

    Dim oPunchFeature As PunchToolFeature
    For Each oPunchFeature In oSMFeatures.PunchToolFeatures
        ' Check to see if this punch ID is already in the list.
        Dim bPunchFound As Boolean
        bPunchFound = False
        Dim i As Integer
        For i = 1 To iUniquePunchCount
            If astrPunchIDs(0, i - 1) = oPunchFeature.PunchId Then
                ' Increment the count for this punch ID.
                astrPunchIDs(1, i - 1) = astrPunchIDs(1, i - 1) + 1

                bPunchFound = True
                Exit For
            End If
        Next

        If Not bPunchFound Then
            ' Add this punch to the list.
            iUniquePunchCount = iUniquePunchCount + 1
            astrPunchIDs(0, iUniquePunchCount - 1) = oPunchFeature.PunchId
            astrPunchIDs(1, iUniquePunchCount - 1) = 1
        End If
    Next

    Dim strMessage As String
    strMessage = "Punch Report (Name, Quantity):" & vbCr & vbCr
    For i = 1 To iUniquePunchCount
       strMessage = strMessage & "   " & astrPunchIDs(0, i - 1) & ", " & _
 astrPunchIDs(1, i - 1)
    Next

    MsgBox strMessage
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface


PunchToolFeatures Methods

PunchToolFeatures Methods
Summary

The methods of the PunchToolFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new PunchToolFeature using the input placement information. If successfully created the new PunchToolFeature is returned.
CreateiFeatureDefinition | Method that creates a new iFeatureDefinition.
Item | Property that returns the specified PunchToolFeature object from the collection. This is the default property of the PunchToolFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Methods


PunchToolFeatures.Add Method

PunchToolFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new PunchToolFeature using the input placement information. If successfully created the new PunchToolFeature is returned.

Visual Basic
Sub Add(PunchCenterPoints As ObjectCollection, Definition As iFeatureDefinition, ByRef Angle As [optional] VARIANT, Result As [out, retval] PunchToolFeature*)
Parameters
Parameters | Description
PunchCenterPoints | Input ObjectCollection of SketchPoint objects that define the placement position(s) of the punch tool. All of the supplied SketchPoint objects must be owned by the same sketch.
Definition | Input iFeatureDefinition object used to define the various input required for the placement of a PunchToolFeature. Appropriate input must be defined in the iFeatureDefinition object in order to place the punch tool.
Angle | Optional Input Variant that defines the placement angle of the punch tool. If not supplied, the punch tool will be placed with a rotation angle of zero. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
Example

Add a punch tool feature

This program demonstrates the creation of a punch tool feature. It uses one of the punch features that's delivered with Inventor. It assumes you already have an existing sheet metal part and have selected a face to place the punch feature on. The selected face should be large so there is room for the punch features.

Public Sub PlacePunchFeature()
    ' Get the active sheet metal document and component
    ' definition of the active document.
    On Error Resume Next
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument
    If Err Then
        MsgBox "A part must be active."
        Exit Sub
    End If
    Dim oSMDef As SheetMetalComponentDefinition
    Set oSMDef = oPartDoc.ComponentDefinition

    ' Get the selected face that will be used for the creation
    ' of the sketch that will contain the sketch points.
    Dim oFace As Face
    Set oFace = oPartDoc.SelectSet.Item(1)
    If Err Then
        MsgBox "A planar face must be selected."
        Exit Sub
    End If
    On Error GoTo 0

    If oFace.SurfaceType  kPlaneSurface Then
        MsgBox "A planar face must be selected."
        Exit Sub
    End If

    ' Create a sketch on the selected face.
    Dim oSketch As PlanarSketch
    Set oSketch = oSMDef.Sketches.Add(oFace)

    ' Create some points on the sketch.  The model will need to
    ' be of a size that these points lie on the model.
    Dim oPoints As ObjectCollection
    Set oPoints = ThisApplication.TransientObjects.CreateObjectCollection

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oPoint As SketchPoint
    Set oPoint = oSketch.SketchPoints.Add(oTG.CreatePoint2d(2, 2), True)
    Call oPoints.Add(oPoint)

    Set oPoint = oSketch.SketchPoints.Add(oTG.CreatePoint2d(8, 3), True)
    Call oPoints.Add(oPoint)

    Set oPoint = oSketch.SketchPoints.Add(oTG.CreatePoint2d(2, 10), False)
    Call oPoints.Add(oPoint)
    Dim oSMFeatures As SheetMetalFeatures
    Set oSMFeatures = oSMDef.Features

    ' Create an iFeatureDefinition object for a punch tool.
    Dim oiFeatureDef As iFeatureDefinition
    Set oiFeatureDef = oSMFeatures.PunchToolFeatures.CreateiFeatureDefinition( _
        "C:\Program Files\Autodesk\Inventor 2010\Catalog\Punches\keyhole.ide")

    ' Set the input.
    Dim oInput As iFeatureInput
    For Each oInput In oiFeatureDef.iFeatureInputs
        Dim oParamInput As iFeatureParameterInput
        Select Case oInput.Name
            Case "Length"
                Set oParamInput = oInput
                oParamInput.Expression = "1 in"
            Case "Hole_Diameter"
                Set oParamInput = oInput
                oParamInput.Expression = "0.5 in"
            Case "Slot_Width"
                Set oParamInput = oInput
                oParamInput.Expression = "0.3875 in"
            Case "Fillet"
                Set oParamInput = oInput
                oParamInput.Expression = "0.0625 in"
            Case "Thickness"
                Set oParamInput = oInput
                oParamInput.Expression = "0.125 in"
        End Select
    Next

    ' Create the iFeature at a 45 degree angle.
    Dim oPunchTool As PunchToolFeature
    Set oPunchTool = oSMFeatures.PunchToolFeatures.Add(oPoints, oiFeatureDef, 3.14159265358979 / 4)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Methods > PunchToolFeatures.Add Method


PunchToolFeatures.CreateiFeatureDefinition Method

PunchToolFeatures.CreateiFeatureDefinition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new iFeatureDefinition.

Visual Basic
Sub CreateiFeatureDefinition(FullFilename As String, Result As [out, retval] iFeatureDefinition*)
Parameters
Parameters | Description
FullFileName | Input string that specifies the name of the iFeature file (.ide) to create the definition for. The file must be an existing iFeature file. If an invalid file is specified an error will occur.
Remarks

The returned definition provides access to all of the inputs that are necessary for placing a punch feature. Using this object you provide the parameter and the geometry inputs necessary for placing the punch feature. Creating an iFeatureDefinition for use as input to create a punch tool feature (using the PunchToolFeatures.CreateiFeatureDefinition method results in an iFeatureDefinition that is slightly different than when created for a standard iFeature (using the iFeatures.CreateiFeatureDefinition method). For a punch tool iFeatureDefinition there is not a sketch plane input since the sketch plane is inferred by using the parent sketch of the input sketch points.

See Also

Add a punch tool feature sample

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Methods > PunchToolFeatures.CreateiFeatureDefinition Method


PunchToolFeatures.Item Method

PunchToolFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified PunchToolFeature object from the collection. This is the default property of the PunchToolFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] PunchToolFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the PunchToolFeature to return.
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Methods > PunchToolFeatures.Item Method


PunchToolFeatures Properties

PunchToolFeatures Properties
Summary

The properties of the PunchToolFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Properties


PunchToolFeatures.Application Property

PunchToolFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Properties > PunchToolFeatures.Application Property


PunchToolFeatures.Count Property

PunchToolFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Report on punch feature ID's sample

You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Properties > PunchToolFeatures.Count Property


PunchToolFeatures.Type Property

PunchToolFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > PunchToolFeatures Interface > PunchToolFeatures Properties > PunchToolFeatures.Type Property


RadialMarkingMenu Interface

RadialMarkingMenu Interface Available in Inventor Introduced in Inventor 2012
Summary

The RadialMarkingMenu object provides access to the contents of the radial marking menu (displayed when the user right clicks).

Class Hierarchy
Inventor::RadialMarkingMenu
Visual Basic
Public Interface RadialMarkingMenu
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface


RadialMarkingMenu Methods

RadialMarkingMenu Methods
Summary

The methods of the RadialMarkingMenu class are listed here.

Methods
Methods
Name | Description
CreateRadialSubMenu | Method that creates a transient RadialMarkingMenu.
You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Methods


RadialMarkingMenu.CreateRadialSubMenu Method

RadialMarkingMenu.CreateRadialSubMenu Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a transient RadialMarkingMenu.

Visual Basic
Sub CreateRadialSubMenu(Name As String, Result As [out, retval] RadialMarkingMenu*)
Parameters
Parameters | Description
Name | Input String that specifies the name of the sub-menu.
Remarks

This object can then be assigned to any of the radial menu controls to create a sub-menu. Controls within the sub-menu can be left un-assigned to indicate the absence of those controls.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Methods > RadialMarkingMenu.CreateRadialSubMenu Method


RadialMarkingMenu Properties

RadialMarkingMenu Properties
Summary

The properties of the RadialMarkingMenu class are listed here.

Properties
Name | Description
Application | This is Application, a member of class RadialMarkingMenu.
EastControl | Property that gets and sets the command to display in the east control.
NorthControl | Property that gets and sets the command to display in the north control.
NortheastControl | Property that gets and sets the command to display in the north-east control.
NorthwestControl | Property that gets and sets the command to display in the north-west control.
SouthControl | Property that gets and sets the command to display in the south control.
SoutheastControl | Property that gets and sets the command to display in the south-east control.
SouthwestControl | Property that gets and sets the command to display in the south-west control.
Type | This is Type, a member of class RadialMarkingMenu.
WestControl | Property that gets and sets the command to display in the west control.
You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties


RadialMarkingMenu.Application Property

RadialMarkingMenu.Application Property
Summary

This is Application, a member of class RadialMarkingMenu.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.Application Property


RadialMarkingMenu.EastControl Property

RadialMarkingMenu.EastControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the east control.

Visual Basic
Property EastControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.EastControl Property


RadialMarkingMenu.NorthControl Property

RadialMarkingMenu.NorthControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the north control.

Visual Basic
Property NorthControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.NorthControl Property


RadialMarkingMenu.NortheastControl Property

RadialMarkingMenu.NortheastControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the north-east control.

Visual Basic
Property NortheastControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.NortheastControl Property


RadialMarkingMenu.NorthwestControl Property

RadialMarkingMenu.NorthwestControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the north-west control.

Visual Basic
Property NorthwestControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.NorthwestControl Property


RadialMarkingMenu.SouthControl Property

RadialMarkingMenu.SouthControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the south control.

Visual Basic
Property SouthControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.SouthControl Property


RadialMarkingMenu.SoutheastControl Property

RadialMarkingMenu.SoutheastControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the south-east control.

Visual Basic
Property SoutheastControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.SoutheastControl Property


RadialMarkingMenu.SouthwestControl Property

RadialMarkingMenu.SouthwestControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the south-west control.

Visual Basic
Property SouthwestControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.SouthwestControl Property


RadialMarkingMenu.Type Property

RadialMarkingMenu.Type Property
Summary

This is Type, a member of class RadialMarkingMenu.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.Type Property


RadialMarkingMenu.WestControl Property

RadialMarkingMenu.WestControl Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the command to display in the west control.

Visual Basic
Property WestControl() As IDispatch*
Remarks

This can either be a ButtonDefinition object or another RadialMarkingMenu object indicating a sub-menu.

You are here: Symbol Reference > Inventor Library > Objects > RadialMarkingMenu Interface > RadialMarkingMenu Properties > RadialMarkingMenu.WestControl Property


RadiusDimConstraint Interface

RadiusDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RadiusDimConstraint object represents a constraint that controls the radius of a circle or arc.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::RadiusDimConstraint
        Inventor::RadiusDimConstraintProxy
Visual Basic
Public Interface RadiusDimConstraint
Inherits DimensionConstraint
Remarks

The picture below illustrates the use of this constraint.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddRadius

RadiusDimConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint Interface


RadiusDimConstraint Properties

RadiusDimConstraint Properties
Summary

The properties of the RadiusDimConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns the entity being constrained to.
You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint Interface > RadiusDimConstraint Properties


RadiusDimConstraint.Entity Property

RadiusDimConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the entity being constrained to.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint Interface > RadiusDimConstraint Properties > RadiusDimConstraint.Entity Property


RadiusDimConstraint3D Interface

RadiusDimConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RadiusDimConstraint3D object represents a constraint that controls the radius of a circle or an arc. The picture below illustrates the use of this constraint.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::RadiusDimConstraint3D
        Inventor::RadiusDimConstraint3DProxy
Visual Basic
Public Interface RadiusDimConstraint3D
Inherits DimensionConstraint3D
Notes

Members through which this object may be accessed include:

DimensionConstraints3D.AddRadius

RadiusDimConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3D Interface


RadiusDimConstraint3D Properties

RadiusDimConstraint3D Properties
Summary

The properties of the RadiusDimConstraint3D class are listed here.

Properties
Name | Description
Entity | Property that returns the circle or arc being constrained.
You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3D Interface > RadiusDimConstraint3D Properties


RadiusDimConstraint3D.Entity Property

RadiusDimConstraint3D.Entity Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the circle or arc being constrained.

Visual Basic
Property Entity() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3D Interface > RadiusDimConstraint3D Properties > RadiusDimConstraint3D.Entity Property


RadiusDimConstraint3DProxy Interface

RadiusDimConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RadiusDimConstraint3D object.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::RadiusDimConstraint3D
        Inventor::RadiusDimConstraint3DProxy
Visual Basic
Public Interface RadiusDimConstraint3DProxy
Inherits RadiusDimConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3DProxy Interface


RadiusDimConstraint3DProxy Properties

RadiusDimConstraint3DProxy Properties
Summary

The properties of the RadiusDimConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3DProxy Interface > RadiusDimConstraint3DProxy Properties


RadiusDimConstraint3DProxy.ContainingOccurrence Property

RadiusDimConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3DProxy Interface > RadiusDimConstraint3DProxy Properties > RadiusDimConstraint3DProxy.ContainingOccurrence Property


RadiusDimConstraint3DProxy.NativeObject Property

RadiusDimConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RadiusDimConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraint3DProxy Interface > RadiusDimConstraint3DProxy Properties > RadiusDimConstraint3DProxy.NativeObject Property


RadiusDimConstraintProxy Interface

RadiusDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RadiusDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::RadiusDimConstraint
        Inventor::RadiusDimConstraintProxy
Visual Basic
Public Interface RadiusDimConstraintProxy
Inherits RadiusDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraintProxy Interface


RadiusDimConstraintProxy Properties

RadiusDimConstraintProxy Properties
Summary

The properties of the RadiusDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraintProxy Interface > RadiusDimConstraintProxy Properties


RadiusDimConstraintProxy.ContainingOccurrence Property

RadiusDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraintProxy Interface > RadiusDimConstraintProxy Properties > RadiusDimConstraintProxy.ContainingOccurrence Property


RadiusDimConstraintProxy.NativeObject Property

RadiusDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RadiusDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RadiusDimConstraintProxy Interface > RadiusDimConstraintProxy Properties > RadiusDimConstraintProxy.NativeObject Property


RadiusGeneralDimension Interface

RadiusGeneralDimension Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The RadiusGeneralDimension object represents a radial general dimension placed on a sheet.

Class Hierarchy
Inventor::DrawingDimension
    Inventor::GeneralDimension
        Inventor::RadiusGeneralDimension
Visual Basic
Public Interface RadiusGeneralDimension
Inherits GeneralDimension
Notes

Members through which this object may be accessed include:

GeneralDimensions.AddRadius

You are here: Symbol Reference > Inventor Library > Objects > RadiusGeneralDimension Interface


RadiusGeneralDimension Properties

RadiusGeneralDimension Properties
Summary

The properties of the RadiusGeneralDimension class are listed here.

Properties
Name | Description
Intent | Property that returns the geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.
Jogged | Property that gets and sets whether the dimension is jogged.
LeaderFromCenter | Property that gets and sets whether the leader starts from the center of the arc or the circle.
You are here: Symbol Reference > Inventor Library > Objects > RadiusGeneralDimension Interface > RadiusGeneralDimension Properties


RadiusGeneralDimension.Intent Property

RadiusGeneralDimension.Intent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the geometry associated with the dimension. The GeometryIntent object can be created using the CreateGeometryIntent method on the Sheet object.

Visual Basic
Property Intent() As GeometryIntent*
You are here: Symbol Reference > Inventor Library > Objects > RadiusGeneralDimension Interface > RadiusGeneralDimension Properties > RadiusGeneralDimension.Intent Property


RadiusGeneralDimension.Jogged Property

RadiusGeneralDimension.Jogged Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the dimension is jogged.

Visual Basic
Property Jogged() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RadiusGeneralDimension Interface > RadiusGeneralDimension Properties > RadiusGeneralDimension.Jogged Property


RadiusGeneralDimension.LeaderFromCenter Property

RadiusGeneralDimension.LeaderFromCenter Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the leader starts from the center of the arc or the circle.

Visual Basic
Property LeaderFromCenter() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RadiusGeneralDimension Interface > RadiusGeneralDimension Properties > RadiusGeneralDimension.LeaderFromCenter Property


RectangularOccurrencePattern Interface

RectangularOccurrencePattern Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The RectangularOccurrencePattern object represents a rectangular pattern of assembly occurrences.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::RectangularOccurrencePattern
        Inventor::RectangularOccurrencePatternProxy
Visual Basic
Public Interface RectangularOccurrencePattern
Inherits OccurrencePattern
Notes

Members through which this object may be accessed include:

OccurrencePatterns.AddRectangularPattern

RectangularOccurrencePatternProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface


RectangularOccurrencePattern Methods

RectangularOccurrencePattern Methods
Summary

The methods of the RectangularOccurrencePattern class are listed here.

Methods
Methods
Name | Description
OccurrencePatternElement | Property returning a specific element within a pattern. The pattern element returned for row 1, column 1 will contain the components that were provided as input for the pattern.
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Methods


RectangularOccurrencePattern.OccurrencePatternElement Method

RectangularOccurrencePattern.OccurrencePatternElement Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning a specific element within a pattern. The pattern element returned for row 1, column 1 will contain the components that were provided as input for the pattern.

Visual Basic
Sub OccurrencePatternElement(Row As long, Column As long, Result As [out, retval] OccurrencePatternElement*)
Parameters
Parameters | Description
Row | Input Long that specifies the row index of the element to return.
Column | Input Long that specifies the column index of the element to return.
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Methods > RectangularOccurrencePattern.OccurrencePatternElement Method


RectangularOccurrencePattern Properties

RectangularOccurrencePattern Properties
Summary

The properties of the RectangularOccurrencePattern class are listed here.

Properties
Name | Description
ColumnCount | Property returning the Parameter object that controls the number of columns.
ColumnEntity | Gets/Sets the entity used to define the column (x) direction of the pattern.
ColumnEntityNaturalDirection | Gets/Sets whether the column direction is in the natural direction of the column entity or not.
ColumnOffset | Property returning the Parameter object that controls the distance between columns.
RowCount | Property returning the Parameter object that controls the number of rows.
RowEntity | Gets/Sets the entity used to define the row (x) direction of the pattern.
RowEntityNaturalDirection | Gets/Sets whether the row direction is in the natural direction of the row entity or not.
RowOffset | Property returning the Parameter object that controls the distance between rows.
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties


RectangularOccurrencePattern.ColumnCount Property

RectangularOccurrencePattern.ColumnCount Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the Parameter object that controls the number of columns.

Visual Basic
Property ColumnCount() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.ColumnCount Property


RectangularOccurrencePattern.ColumnEntity Property

RectangularOccurrencePattern.ColumnEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets/Sets the entity used to define the column (x) direction of the pattern.

Visual Basic
Property ColumnEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.ColumnEntity Property


RectangularOccurrencePattern.ColumnEntityNaturalDirection Property

RectangularOccurrencePattern.ColumnEntityNaturalDirection Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets/Sets whether the column direction is in the natural direction of the column entity or not.

Visual Basic
Property ColumnEntityNaturalDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.ColumnEntityNaturalDirection Property


RectangularOccurrencePattern.ColumnOffset Property

RectangularOccurrencePattern.ColumnOffset Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the Parameter object that controls the distance between columns.

Visual Basic
Property ColumnOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.ColumnOffset Property


RectangularOccurrencePattern.RowCount Property

RectangularOccurrencePattern.RowCount Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the Parameter object that controls the number of rows.

Visual Basic
Property RowCount() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.RowCount Property


RectangularOccurrencePattern.RowEntity Property

RectangularOccurrencePattern.RowEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets/Sets the entity used to define the row (x) direction of the pattern.

Visual Basic
Property RowEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.RowEntity Property


RectangularOccurrencePattern.RowEntityNaturalDirection Property

RectangularOccurrencePattern.RowEntityNaturalDirection Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets/Sets whether the row direction is in the natural direction of the row entity or not.

Visual Basic
Property RowEntityNaturalDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.RowEntityNaturalDirection Property


RectangularOccurrencePattern.RowOffset Property

RectangularOccurrencePattern.RowOffset Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning the Parameter object that controls the distance between rows.

Visual Basic
Property RowOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePattern Interface > RectangularOccurrencePattern Properties > RectangularOccurrencePattern.RowOffset Property


RectangularOccurrencePatternProxy Interface

RectangularOccurrencePatternProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RectangularOccurrencePattern object.

Class Hierarchy
Inventor::OccurrencePattern
    Inventor::RectangularOccurrencePattern
        Inventor::RectangularOccurrencePatternProxy
Visual Basic
Public Interface RectangularOccurrencePatternProxy
Inherits RectangularOccurrencePattern
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePatternProxy Interface


RectangularOccurrencePatternProxy Properties

RectangularOccurrencePatternProxy Properties
Summary

The properties of the RectangularOccurrencePatternProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePatternProxy Interface > RectangularOccurrencePatternProxy Properties


RectangularOccurrencePatternProxy.ContainingOccurrence Property

RectangularOccurrencePatternProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePatternProxy Interface > RectangularOccurrencePatternProxy Properties > RectangularOccurrencePatternProxy.ContainingOccurrence Property


RectangularOccurrencePatternProxy.NativeObject Property

RectangularOccurrencePatternProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RectangularOccurrencePattern**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RectangularOccurrencePatternProxy Interface > RectangularOccurrencePatternProxy Properties > RectangularOccurrencePatternProxy.NativeObject Property


RectangularPatternFeature Interface

RectangularPatternFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RectangularPatternFeature object represents rectangular pattern feature objects.

Class Hierarchy
Inventor::PartFeature
    Inventor::RectangularPatternFeature
        Inventor::RectangularPatternFeatureProxy
Visual Basic
Public Interface RectangularPatternFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RectangularPatternFeatureProxy.NativeObject

RectangularPatternFeatures.Add

RectangularPatternFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface


RectangularPatternFeature Methods

RectangularPatternFeature Methods
Summary

The methods of the RectangularPatternFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Add the specified occurrence from the list of participants for this feature. This method only applies to assembly features.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Methods


RectangularPatternFeature.AddParticipant Method

RectangularPatternFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Add the specified occurrence from the list of participants for this feature. This method only applies to assembly features.

Visual Basic
Sub AddParticipant(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence to add.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Methods > RectangularPatternFeature.AddParticipant Method


RectangularPatternFeature Properties

RectangularPatternFeature Properties
Summary

The properties of the RectangularPatternFeature class are listed here.

Properties
Name | Description
ComputeType | Property that that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation.
NaturalXDirection | Property that gets and sets the flag that indicates if the direction of the pattern is in the natural direction of the XDirectionEntity or reversed. A value of True indicates it is in the natural direction.
NaturalYDirection | Property that gets and sets the flag that indicates if the direction of the pattern is in the natural direction of the YDirectionEntity or reversed. A value of True indicates it is in the natural direction.
NewBodyOperation | Property that gets and sets whether the feature creates new bodies, rather than modifying the existing body. Applies only when a body is patterned (i.e. when PatternOfBody returns True).
OrientationMethod | Property that gets and sets the enum indicating the orientation method used for pattern creation.
ParentFeatures | Property that gets and sets the parent features of the pattern. The ObjectCollection returned by this property is a 'tear off' and does not affect the pattern if its contents are modified. To change the which features are the parents of the pattern you need to use this property to set the parent features by providing an ObjectCollection that contains the desired set of parent features.
PatternElements | Property that returns the collection that contains the elements created by this pattern.
PatternOfBody | Property that gets whether this pattern resulted from patterning the Surface Body.
SurfacesOpaque | Property that gets and sets whether all the resulting surfaces are opaque or transparent. False by default.
SurfacesVisible | Property that gets and sets whether all the resulting surfaces are visible or not. True by default.
XCount | Property that returns the parameter that defines the number of instances in the X direction.
XDirectionEntity | Property that gets and sets the X direction entity. This can be an edge, a work axis, a work plane (normal is used), a planar face (normal is used) or a Path.
XDirectionMidPlanePattern | Property that gets and sets whether the patterned occurrences should fall on either side of the original in the X direction.
XDirectionSpacingType | Property that gets and sets the enum that indicates if the occurrences in the x-direction have been fitted within a specified distance.
XDirectionStartPoint | Property that gets and sets the X direction start point. This can be a vertex, planar sketch point or a 3D sketch point.
XSpacing | Property that returns the parameter that defines the spacing between instances in the X direction.
YCount | Property that returns the parameter that defines the number of instances in the Y direction. This property can return Nothing in the case where the Y direction is undefined.
YDirectionEntity | Property that gets and sets the Y direction entity. This can be an edge, a work axis, a work plane (normal is used), a planar face (normal is used) or a Path. This property can return Nothing or can be set to Nothing in the case where the Y direction is undefined.
YDirectionMidPlanePattern | Property that gets and sets whether the patterned occurrences should fall on either side of the original in the Y direction.
YDirectionSpacingType | Property that gets and sets the enum that indicates if the occurrences in the y-direction have been fitted within a specified distance.
YDirectionStartPoint | Property that gets and sets the Y direction start point. This can be a vertex, planar sketch point or a 3D sketch point.
YSpacing | Property that returns the parameter that defines the spacing between instances in the Y direction. This property can return Nothing in the case where the Y direction is undefined.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties


RectangularPatternFeature.ComputeType Property

RectangularPatternFeature.ComputeType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation.

Visual Basic
Property ComputeType() As PatternComputeTypeEnum
Remarks

If kIdenticalCompute is specified, all occurrences in the pattern use an identical termination, regardless of where they intersect another feature. Use this method to efficiently pattern large numbers of features when the feature being duplicated has a distance termination or terminates on a work plane.

If kAdjustToModelCompute is specified, the termination of each occurrence is calculated individually. Computation time can be lengthy for patterns with a large number of occurrences. You must use this method if the parent feature terminates on a model face.

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.ComputeType Property


RectangularPatternFeature.NaturalXDirection Property

RectangularPatternFeature.NaturalXDirection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the flag that indicates if the direction of the pattern is in the natural direction of the XDirectionEntity or reversed. A value of True indicates it is in the natural direction.

Visual Basic
Property NaturalXDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.NaturalXDirection Property


RectangularPatternFeature.NaturalYDirection Property

RectangularPatternFeature.NaturalYDirection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the flag that indicates if the direction of the pattern is in the natural direction of the YDirectionEntity or reversed. A value of True indicates it is in the natural direction.

Visual Basic
Property NaturalYDirection() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.NaturalYDirection Property


RectangularPatternFeature.NewBodyOperation Property

RectangularPatternFeature.NewBodyOperation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the feature creates new bodies, rather than modifying the existing body. Applies only when a body is patterned (i.e. when PatternOfBody returns True).

Visual Basic
Property NewBodyOperation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.NewBodyOperation Property


RectangularPatternFeature.OrientationMethod Property

RectangularPatternFeature.OrientationMethod Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the enum indicating the orientation method used for pattern creation.

Visual Basic
Property OrientationMethod() As PatternOrientationEnum
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.OrientationMethod Property


RectangularPatternFeature.ParentFeatures Property

RectangularPatternFeature.ParentFeatures Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the parent features of the pattern. The ObjectCollection returned by this property is a 'tear off' and does not affect the pattern if its contents are modified. To change the which features are the parents of the pattern you need to use this property to set the parent features by providing an ObjectCollection that contains the desired set of parent features.

Visual Basic
Property ParentFeatures() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.ParentFeatures Property


RectangularPatternFeature.PatternElements Property

RectangularPatternFeature.PatternElements Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the collection that contains the elements created by this pattern.

Visual Basic
Property PatternElements() As FeaturePatternElements**
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.PatternElements Property


RectangularPatternFeature.PatternOfBody Property

RectangularPatternFeature.PatternOfBody Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether this pattern resulted from patterning the Surface Body.

Visual Basic
Property PatternOfBody() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.PatternOfBody Property


RectangularPatternFeature.SurfacesOpaque Property

RectangularPatternFeature.SurfacesOpaque Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether all the resulting surfaces are opaque or transparent. False by default.

Visual Basic
Property SurfacesOpaque() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.SurfacesOpaque Property


RectangularPatternFeature.SurfacesVisible Property

RectangularPatternFeature.SurfacesVisible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether all the resulting surfaces are visible or not. True by default.

Visual Basic
Property SurfacesVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.SurfacesVisible Property


RectangularPatternFeature.XCount Property

RectangularPatternFeature.XCount Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that defines the number of instances in the X direction.

Visual Basic
Property XCount() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.XCount Property


RectangularPatternFeature.XDirectionEntity Property

RectangularPatternFeature.XDirectionEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the X direction entity. This can be an edge, a work axis, a work plane (normal is used), a planar face (normal is used) or a Path.

Visual Basic
Property XDirectionEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.XDirectionEntity Property


RectangularPatternFeature.XDirectionMidPlanePattern Property

RectangularPatternFeature.XDirectionMidPlanePattern Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the patterned occurrences should fall on either side of the original in the X direction.

Visual Basic
Property XDirectionMidPlanePattern() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.XDirectionMidPlanePattern Property


RectangularPatternFeature.XDirectionSpacingType Property

RectangularPatternFeature.XDirectionSpacingType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the enum that indicates if the occurrences in the x-direction have been fitted within a specified distance.

Visual Basic
Property XDirectionSpacingType() As PatternSpacingTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.XDirectionSpacingType Property


RectangularPatternFeature.XDirectionStartPoint Property

RectangularPatternFeature.XDirectionStartPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the X direction start point. This can be a vertex, planar sketch point or a 3D sketch point.

Visual Basic
Property XDirectionStartPoint() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.XDirectionStartPoint Property


RectangularPatternFeature.XSpacing Property

RectangularPatternFeature.XSpacing Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that defines the spacing between instances in the X direction.

Visual Basic
Property XSpacing() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.XSpacing Property


RectangularPatternFeature.YCount Property

RectangularPatternFeature.YCount Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that defines the number of instances in the Y direction. This property can return Nothing in the case where the Y direction is undefined.

Visual Basic
Property YCount() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.YCount Property


RectangularPatternFeature.YDirectionEntity Property

RectangularPatternFeature.YDirectionEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the Y direction entity. This can be an edge, a work axis, a work plane (normal is used), a planar face (normal is used) or a Path. This property can return Nothing or can be set to Nothing in the case where the Y direction is undefined.

Visual Basic
Property YDirectionEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.YDirectionEntity Property


RectangularPatternFeature.YDirectionMidPlanePattern Property

RectangularPatternFeature.YDirectionMidPlanePattern Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the patterned occurrences should fall on either side of the original in the Y direction.

Visual Basic
Property YDirectionMidPlanePattern() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.YDirectionMidPlanePattern Property


RectangularPatternFeature.YDirectionSpacingType Property

RectangularPatternFeature.YDirectionSpacingType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the enum that indicates if the occurrences in the y-direction have been fitted within a specified distance.

Visual Basic
Property YDirectionSpacingType() As PatternSpacingTypeEnum
Remarks

A value of kDefault indicates that the occurrences are to be separated by the specified distance. A value of kFitted indicates that all occurrences are to be fitted within the specified distance. A value of kFitToPathLength indicates that all occurrences are to be fitted within a distance equal to the length of the YDirectionEntity. The kFitToPathLength value is invalid in cases where the YDirectionEntity is a work axis.

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.YDirectionSpacingType Property


RectangularPatternFeature.YDirectionStartPoint Property

RectangularPatternFeature.YDirectionStartPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the Y direction start point. This can be a vertex, planar sketch point or a 3D sketch point.

Visual Basic
Property YDirectionStartPoint() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.YDirectionStartPoint Property


RectangularPatternFeature.YSpacing Property

RectangularPatternFeature.YSpacing Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that defines the spacing between instances in the Y direction. This property can return Nothing in the case where the Y direction is undefined.

Visual Basic
Property YSpacing() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeature Interface > RectangularPatternFeature Properties > RectangularPatternFeature.YSpacing Property


RectangularPatternFeatureProxy Interface

RectangularPatternFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RectangularPatternFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RectangularPatternFeature
        Inventor::RectangularPatternFeatureProxy
Visual Basic
Public Interface RectangularPatternFeatureProxy
Inherits RectangularPatternFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatureProxy Interface


RectangularPatternFeatureProxy Properties

RectangularPatternFeatureProxy Properties
Summary

The properties of the RectangularPatternFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatureProxy Interface > RectangularPatternFeatureProxy Properties


RectangularPatternFeatureProxy.ContainingOccurrence Property

RectangularPatternFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatureProxy Interface > RectangularPatternFeatureProxy Properties > RectangularPatternFeatureProxy.ContainingOccurrence Property


RectangularPatternFeatureProxy.NativeObject Property

RectangularPatternFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RectangularPatternFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatureProxy Interface > RectangularPatternFeatureProxy Properties > RectangularPatternFeatureProxy.NativeObject Property


RectangularPatternFeatures Interface

RectangularPatternFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RectangularPatternFeatures object provides access to all of the objects in a component definition and provides methods to create additional RectangularPatternFeature objects.

Class Hierarchy
Inventor::RectangularPatternFeatures
Visual Basic
Public Interface RectangularPatternFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.RectangularPatternFeatures

FlatPatternFeatures.RectangularPatternFeatures

PartFeatures.RectangularPatternFeatures

You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface


RectangularPatternFeatures Methods

RectangularPatternFeatures Methods
Summary

The methods of the RectangularPatternFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new rectangular pattern feature. The new RectangularPatternFeature object is returned. Defining instances in the Y direction is optional. If any of the Y-direction information is missing, only the X instances will be created.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Methods


RectangularPatternFeatures.Add Method

RectangularPatternFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new rectangular pattern feature. The new RectangularPatternFeature object is returned. Defining instances in the Y direction is optional. If any of the Y-direction information is missing, only the X instances will be created.

Visual Basic
Sub Add(ParentFeatures As ObjectCollection, XDirectionEntity As IDispatch, NaturalXDirection As VARIANT_BOOL, XCount As VARIANT, XSpacing As VARIANT, ByRef XSpacingType As [defaultvalue(kDefault)] PatternSpacingTypeEnum, ByRef XDirectionStartPoint As [optional] VARIANT, ByRef YDirectionEntity As [optional] VARIANT, ByRef NaturalYDirection As [defaultvalue(-1)] VARIANT_BOOL, ByRef YCount As [optional] VARIANT, ByRef YSpacing As [optional] VARIANT, ByRef YSpacingType As [defaultvalue(kDefault)] PatternSpacingTypeEnum, ByRef YDirectionStartPoint As [optional] VARIANT, ByRef ComputeType As [defaultvalue(kOptimizedCompute)] PatternComputeTypeEnum, ByRef OrientationMethod As [defaultvalue(kIdentical)] PatternOrientationEnum, Result As [out, retval] RectangularPatternFeature*)
Parameters
Parameters | Description
ParentFeatures | Input that contains the features to be patterned. The collection could contain the various part features, sheet metal features, work planes, work axes, work points, or a SurfaceBody. Only the primary (result) surface body, obtained from ComponentDefinition.SurfaceBodies.Item(1) is a valid input. If a SurfaceBody is supplied, the only other objects that can be in the collection are work planes, work axes, work points, and surface part features. Finish features such as fillets and chamfers may be included only if their parent feature is also included.
XDirectionEntity | Linear entity that defines the first direction. This can be an edge a work axis, a work plane (normal is used), a planar face (normal is used) or a Path. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements.
NaturalXDirection | Input Boolean that indicates if the direction of the pattern is in the natural direction of the XDirectionEntity or reversed. A value of True indicates it is in the natural direction.
XCount | Input Variant that defines the number of instances in the X direction. This can be either a numeric value or a string. A parameter will be created to control this value when the feature is created. If a string is input it can be any string that can be evaluated by Inventor to result in a unitless number.
XSpacing | Optional input Variant that defines the spacing between instances in the X direction. This can be either a numeric value or a string. A parameter will be created to control this value when the feature is created. If a string is input it can be any string that can be evaluated by Inventor to result in a unitless number. This input may be left unspecified only if the XSpacingType is kFitToPathLength and if the XDirectionEntity is not a work axis.
XSpacingType | Optional input enum that indicates if the occurrences along the x direction are to be fitted within a specified distance. A value of kDefault indicates that the occurrences are to be separated by the specified distance. A value of kFitted indicates that all occurrences are to be fitted within the specified distance. A value of kFitToPathLength indicates that all occurrences are to be fitted within a distance equal to the length of the XDirectionEntity. The kFitToPathLength value is invalid in cases where the XDirectionEntity is a work axis.
XDirectionStartPoint | Optional input object that defines the start point of the portion of the XDirectionEntity to be used as the pattern path.
YDirectionEntity | Optional input linear entity that defines the second direction. This can be an edge a work axis, a work plane (normal is used), a planar face (normal is used) or a Path. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements.
NaturalYDirection | Optional input Boolean that indicates if the direction of the pattern is in the natural direction of the YDirectionEntity or reversed. A value of True indicates it is in the natural direction.
YCount | Optional input Variant that defines the number of instances in the Y direction. This can be either a numeric value or a string. A parameter will be created to control this value when the feature is created. If a string is input it can be any string that can be evaluated by Inventor to result in a unitless number.
YSpacing | Optional input Variant that defines the spacing between instances in the Y direction. This can be either a numeric value or a string. A parameter will be created to control this value when the feature is created. If a string is input it can be any string that can be evaluated by Inventor to result in a unitless number.
YSpacingType | Optional input enum that indicates if the occurrences along the Y direction are to be fitted within a specified distance. A value of kDefault indicates that the occurrences are to be separated by the specified distance. A value of kFitted indicates that all occurrences are to be fitted within the specified distance. A value of kFitToPathLength indicates that all occurrences are to be fitted within a distance equal to the length of the YDirectionEntity. The kFitToPathLength value is invalid in cases where the YDirectionEntity is a work axis.
YDirectionStartPoint | Optional input object that defines the start point of the portion of the YDirectionEntity to be used as the pattern path.
ComputeType | Property that that indicates the method of solution for the pattern. If specified as kOptimizedCompute, which is the default, patterns are optimized for faster calculation. If kIdenticalCompute is specified, all occurrences in the pattern use an identical termination, regardless of where they intersect another feature. Use this method to efficiently pattern large numbers of features when the feature being duplicated has a distance termination or terminates on a work plane. If kAdjustToModelCompute is specified, the termination of each occurrence is calculated individually. Computation time can be lengthy for patterns with a large number of occurrences. You must use this method if the parent feature terminates on a model face.
OrientationMethod | Optional input enum that defines the orientation of the occurrences along either the first or the second direction. The default is kIdentical indicating that the orientation of all occurrences is the same as the original occurrence.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Methods > RectangularPatternFeatures.Add Method


RectangularPatternFeatures Properties

RectangularPatternFeatures Properties
Summary

The properties of the RectangularPatternFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection. This is the default property of the RectangularPatternFeatures collection object.
Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Properties


RectangularPatternFeatures.Application Property

RectangularPatternFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Properties > RectangularPatternFeatures.Application Property


RectangularPatternFeatures.Count Property

RectangularPatternFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Properties > RectangularPatternFeatures.Count Property


RectangularPatternFeatures.Item Method

RectangularPatternFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object from the collection. This is the default property of the RectangularPatternFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RectangularPatternFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out-of-range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Properties > RectangularPatternFeatures.Item Method


RectangularPatternFeatures.Type Property

RectangularPatternFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RectangularPatternFeatures Interface > RectangularPatternFeatures Properties > RectangularPatternFeatures.Type Property


ReferenceComponent Interface

ReferenceComponent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ReferenceComponent object is the base class for the DerivedPartComponent and DerivedAssemblyComponent objects.

Class Hierarchy
Inventor::ReferenceComponent
    Inventor::DerivedAliasComponent
    Inventor::DerivedAssemblyComponent
    Inventor::DerivedPartComponent
    Inventor::iPartMember
Visual Basic
Public Interface ReferenceComponent
Inherits IDispatch
Remarks

These objects represent an instance of derived part or assembly within a part document.

Notes

Members through which this object may be accessed include:

DerivedParameterTable.ReferenceComponent

Face.ReferenceComponent

iMateDefinition.ReferenceComponent

PlanarSketch.ReferenceComponent

ReferenceFeature.ReferenceComponent

Sketch3D.ReferenceComponent

SketchBlock.ReferenceComponent

SketchEntity.ReferenceComponent

SketchEntity3D.ReferenceComponent

WorkAxis.ReferenceComponent

WorkPlane.ReferenceComponent

WorkPoint.ReferenceComponent

WorkSurface.ReferenceComponent

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface


ReferenceComponent Methods

ReferenceComponent Methods
Summary

The methods of the ReferenceComponent class are listed here.

Methods
Methods
Name | Description
BreakLinkToFile | Method that breaks the connection of the derived component with the part or assembly from which it was created. When the link is broken the ReferencedFile property will return Nothing.
Delete | Method that deletes the ReferenceComponent.
GetReferenceKey | Method that generates and returns the reference key for this entity.
ReferencedFile | Property that returns the ReferencedFileDescriptor object used by this component.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Methods


ReferenceComponent.BreakLinkToFile Method

ReferenceComponent.BreakLinkToFile Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that breaks the connection of the derived component with the part or assembly from which it was created. When the link is broken the ReferencedFile property will return Nothing.

Visual Basic
Sub BreakLinkToFile()
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Methods > ReferenceComponent.BreakLinkToFile Method


ReferenceComponent.Delete Method

ReferenceComponent.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the ReferenceComponent.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Methods > ReferenceComponent.Delete Method


ReferenceComponent.GetReferenceKey Method

ReferenceComponent.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Methods > ReferenceComponent.GetReferenceKey Method


ReferenceComponent.ReferencedFile Method

ReferenceComponent.ReferencedFile Method Available in Inventor Available in Server
Summary

Property that returns the ReferencedFileDescriptor object used by this component.

Visual Basic
Sub ReferencedFile(Result As [out, retval] ReferencedFileDescriptor*)
Remarks

This object describes the part or assembly file that was used to create the derived part or assembly. The ReferencedFile property will return Nothing if the LinkedToBase property is False.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Methods > ReferenceComponent.ReferencedFile Method


ReferenceComponent.SetEndOfPart Method

ReferenceComponent.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 7
Summary

Method that repositions the end-of-part marker relative to the object this method is called from.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this reference component. A value of True indicates before and False indicates after.
Remarks

The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Methods > ReferenceComponent.SetEndOfPart Method


ReferenceComponent Properties

ReferenceComponent Properties
Summary

The properties of the ReferenceComponent class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsEmbedded | Property that returns whether the reference component refers to an embedded document or a linked document.
LinkedToFile | Property that returns whether the derived component is still linked to the base part or assembly document. If True, the link still exists. If False, the link has been broken and the ReferencedFile property will return Nothing.
Name | Property that returns the component's name.
Parent | Property that returns the parent object.
ReferencedDocumentDescriptor | Property that returns the DocumentDescriptor object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties


ReferenceComponent.Application Property

ReferenceComponent.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.Application Property


ReferenceComponent.AttributeSets Property

ReferenceComponent.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.AttributeSets Property


ReferenceComponent.HealthStatus Property

ReferenceComponent.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.HealthStatus Property


ReferenceComponent.IsEmbedded Property

ReferenceComponent.IsEmbedded Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns whether the reference component refers to an embedded document or a linked document.

Visual Basic
Property IsEmbedded() As VARIANT_BOOL*
Remarks

If True, reference component refers to an embedding, e.g. iFeature. If False, reference component refers to a link, e.g. Derived Part, iPart Member.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.IsEmbedded Property


ReferenceComponent.LinkedToFile Property

ReferenceComponent.LinkedToFile Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns whether the derived component is still linked to the base part or assembly document. If True, the link still exists. If False, the link has been broken and the ReferencedFile property will return Nothing.

Visual Basic
Property LinkedToFile() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.LinkedToFile Property


ReferenceComponent.Name Property

ReferenceComponent.Name Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the component's name.

Visual Basic
Property Name() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.Name Property


ReferenceComponent.Parent Property

ReferenceComponent.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parent object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.Parent Property


ReferenceComponent.ReferencedDocumentDescriptor Property

ReferenceComponent.ReferencedDocumentDescriptor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the DocumentDescriptor object.

Visual Basic
Property ReferencedDocumentDescriptor() As DocumentDescriptor**
Remarks

This object describes the part or assembly file that was used to create the derived part or assembly. The property will return Nothing if LinkedToFile property is False.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.ReferencedDocumentDescriptor Property


ReferenceComponent.Type Property

ReferenceComponent.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponent Interface > ReferenceComponent Properties > ReferenceComponent.Type Property


ReferenceComponents Interface

ReferenceComponents Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Provides access to all of the objects that are owned by a particular PartComponentDefinition and have an external file reference.

Class Hierarchy
Inventor::ReferenceComponents
Visual Basic
Public Interface ReferenceComponents
Inherits IDispatch
Remarks

The types of components that fall in this category are derived parts, derived assemblies and iFeatures.

Notes

Members through which this object may be accessed include:

PartComponentDefinition.ReferenceComponents

See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface


ReferenceComponents Properties

ReferenceComponents Properties
Summary

The properties of the ReferenceComponents class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DerivedAliasComponents | Property that returns the DerivedAliasComponents collection object.
DerivedAssemblyComponents | Property that returns the DerivedAssemblyComponent collection object.
DerivedPartComponents | Property that returns the DerivedPartComponents collection object.
iFeatureTemplateDescriptors | Property that returns the iFeatureTemplateDescriptors collection object. This collection provides access to existing iFeatureTemplateDescriptor objects.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties


ReferenceComponents.Application Property

ReferenceComponents.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties > ReferenceComponents.Application Property


ReferenceComponents.DerivedAliasComponents Property

ReferenceComponents.DerivedAliasComponents Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the DerivedAliasComponents collection object.

Visual Basic
Property DerivedAliasComponents() As DerivedAliasComponents**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties > ReferenceComponents.DerivedAliasComponents Property


ReferenceComponents.DerivedAssemblyComponents Property

ReferenceComponents.DerivedAssemblyComponents Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the DerivedAssemblyComponent collection object.

Visual Basic
Property DerivedAssemblyComponents() As DerivedAssemblyComponents**
Remarks

This collection provides access to existing DerivedAssemblyComponent objects and provides functionality to create new DerivedAssemblyComponent objects.

See Also

Shrink wrap substitute in assembly sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties > ReferenceComponents.DerivedAssemblyComponents Property


ReferenceComponents.DerivedPartComponents Property

ReferenceComponents.DerivedPartComponents Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the DerivedPartComponents collection object.

Visual Basic
Property DerivedPartComponents() As DerivedPartComponents**
Remarks

This collection provides access to existing DerivedPartComponent objects and provides functionality to create new DerivedPartComponent objects.

See Also

Derived Parts and Assemblies sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties > ReferenceComponents.DerivedPartComponents Property


ReferenceComponents.iFeatureTemplateDescriptors Property

ReferenceComponents.iFeatureTemplateDescriptors Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the iFeatureTemplateDescriptors collection object. This collection provides access to existing iFeatureTemplateDescriptor objects.

Visual Basic
Property iFeatureTemplateDescriptors() As iFeatureTemplateDescriptors**
Notes

iFeatureTemplateDescriptors was previously known as iFeatureDescriptors and were accessed through the DerivativeDescriptors collection. The DerivativeDescriptors collection has been removed and is now obsolete.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties > ReferenceComponents.iFeatureTemplateDescriptors Property


ReferenceComponents.Type Property

ReferenceComponents.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceComponents Interface > ReferenceComponents Properties > ReferenceComponents.Type Property


ReferencedOLEFileDescriptor Interface

ReferencedOLEFileDescriptor Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ReferencedOLEFileDescriptor object represents an OLE reference to another file.

Class Hierarchy
Inventor::ReferencedOLEFileDescriptor
Visual Basic
Public Interface ReferencedOLEFileDescriptor
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ReferencedOLEFileDescriptors.Add

ReferencedOLEFileDescriptors.Item

ReferencedOLEFileDescriptors.ItemByName

SketchImage.ReferencedFileDescriptor

You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface


ReferencedOLEFileDescriptor Methods

ReferencedOLEFileDescriptor Methods
Summary

The methods of the ReferencedOLEFileDescriptor class are listed here.

Methods
Methods
Name | Description
Activate | Method that causes the OLE file to be activated by the process currently registered to handle that type of document.
Delete | Method that deletes the reference file attachment.
GetReferenceKey | Method that generates and returns the reference key for this entity. The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the ReferenceKeyManager object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document Object.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Methods


ReferencedOLEFileDescriptor.Activate Method

ReferencedOLEFileDescriptor.Activate Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that causes the OLE file to be activated by the process currently registered to handle that type of document.

Visual Basic
Sub Activate(Verb As OLEVerbEnum, ByRef OLEDocumentObject As IUnknown*)
Parameters
Parameters | Description
Verb | Input value that specifies how OLE should activate the document. Valid values are: kDefaultOLEVerb: Perform the default action. kEditOpenOLEVerb: Open the document is a separate window for editing. kHideOLEVerb: Open the document but keep its application hidden. kShowOLEVerb: Open the document and show the application if it's been hidden. Otherwise this has the same behavior as kEditOpenOLEVerb.
OLEDocumentObject | Output object that if supported by the opening application is the object just opened. For example if an Excel spreadsheet is referenced and is activated this argument will return the WorkBook object for the file just opened.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Methods > ReferencedOLEFileDescriptor.Activate Method


ReferencedOLEFileDescriptor.Delete Method

ReferencedOLEFileDescriptor.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes the reference file attachment.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Methods > ReferencedOLEFileDescriptor.Delete Method


ReferencedOLEFileDescriptor.GetReferenceKey Method

ReferencedOLEFileDescriptor.GetReferenceKey Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that generates and returns the reference key for this entity. The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the ReferenceKeyManager object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document Object.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Output array of Bytes that contains the reference key.
KeyContext | Optional input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Methods > ReferencedOLEFileDescriptor.GetReferenceKey Method


ReferencedOLEFileDescriptor Properties

ReferencedOLEFileDescriptor Properties
Summary

The properties of the ReferencedOLEFileDescriptor class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BrowserVisible | Property that gets and sets whether this item is visible within the '3rd Party' folder in the browser. If set to False, the corresponding node in the browser is hidden.
DisplayName | Property that gets and sets the name of the linked/embedded item as displayed within the '3rd Party' folder in the browser.
FileDescriptor | Property that returns the corresponding FileDescriptor object. The ReplaceReference method on the returned object can be used to replace the referenced file. This property returns Nothing for embeddings.
FullFileName | Property that returns the full path name of the file as currently found (or the last known full file name, if reference is not found). This property returns a null string for an embedding descriptor.
LastKnownFileTime | Property that returns the time stamp on the file when it was last reviewed. This property returns Nothing for embeddings.
LogicalName | Property that returns the logical name of the reference. This is essentially the relative path used by Autodesk Inventor to find the file using the project paths as the search paths.
OLEDocumentType | Property that returns the type of OLE reference this represents. Valid values are kOLEDocumentEmbeddingObject, kOLEDocumentLinkObject, or kOLEDocumentUnknownObject.
Parent | Property that returns the parent Document (in Inventor) or ApprenticeServerDocument (in Apprentice).
ReferenceMonitoring | Property that gets and sets whether the referenced file is monitored by Inventor for changes.
ReferenceStatus | Property that returns the current status of the file reference. This property returns kUpToDateReference for embeddings.
Type | Property returning kReferencedOLEFileDescriptorObject indicating this object's type.
Visible | Property that gets and sets whether the linked/embedded object is visible in the graphics window. This property is only applicable in drawing documents. Example case of where it applies: inserting image or excel files in a drawing.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties


ReferencedOLEFileDescriptor.Application Property

ReferencedOLEFileDescriptor.Application Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.Application Property


ReferencedOLEFileDescriptor.AttributeSets Property

ReferencedOLEFileDescriptor.AttributeSets Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.AttributeSets Property


ReferencedOLEFileDescriptor.BrowserVisible Property

ReferencedOLEFileDescriptor.BrowserVisible Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether this item is visible within the '3rd Party' folder in the browser. If set to False, the corresponding node in the browser is hidden.

Visual Basic
Property BrowserVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.BrowserVisible Property


ReferencedOLEFileDescriptor.DisplayName Property

ReferencedOLEFileDescriptor.DisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets and sets the name of the linked/embedded item as displayed within the '3rd Party' folder in the browser.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.DisplayName Property


ReferencedOLEFileDescriptor.FileDescriptor Property

ReferencedOLEFileDescriptor.FileDescriptor Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the corresponding FileDescriptor object. The ReplaceReference method on the returned object can be used to replace the referenced file. This property returns Nothing for embeddings.

Visual Basic
Property FileDescriptor() As FileDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.FileDescriptor Property


ReferencedOLEFileDescriptor.FullFileName Property

ReferencedOLEFileDescriptor.FullFileName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the full path name of the file as currently found (or the last known full file name, if reference is not found). This property returns a null string for an embedding descriptor.

Visual Basic
Property FullFileName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.FullFileName Property


ReferencedOLEFileDescriptor.LastKnownFileTime Property

ReferencedOLEFileDescriptor.LastKnownFileTime Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the time stamp on the file when it was last reviewed. This property returns Nothing for embeddings.

Visual Basic
Property LastKnownFileTime() As VARIANT*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.LastKnownFileTime Property


ReferencedOLEFileDescriptor.LogicalName Property

ReferencedOLEFileDescriptor.LogicalName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the logical name of the reference. This is essentially the relative path used by Autodesk Inventor to find the file using the project paths as the search paths.

Visual Basic
Property LogicalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.LogicalName Property


ReferencedOLEFileDescriptor.OLEDocumentType Property

ReferencedOLEFileDescriptor.OLEDocumentType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the type of OLE reference this represents. Valid values are kOLEDocumentEmbeddingObject, kOLEDocumentLinkObject, or kOLEDocumentUnknownObject.

Visual Basic
Property OLEDocumentType() As OLEDocumentTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.OLEDocumentType Property


ReferencedOLEFileDescriptor.Parent Property

ReferencedOLEFileDescriptor.Parent Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the parent Document (in Inventor) or ApprenticeServerDocument (in Apprentice).

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.Parent Property


ReferencedOLEFileDescriptor.ReferenceMonitoring Property

ReferencedOLEFileDescriptor.ReferenceMonitoring Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the referenced file is monitored by Inventor for changes.

Visual Basic
Property ReferenceMonitoring() As ReferenceMonitoringEnum
Remarks

Currently supported values are:

kNoMonitor: Use this if you don't want Inventor to monitor changes to the file. This would be used in cases where the file is used to store output data (i.e. it is a results file). All references added via the API (using ReferencedOLEFileDescriptors.Add method) are defaulted to this value.

kMonitorAndEnableUpdate: Use this if you want Inventor to monitor changes to the file and enable the Update button in the Inventor document if the file changes. This would be used in cases where data in the file is used to drive geometry in the Inventor document.

You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.ReferenceMonitoring Property


ReferencedOLEFileDescriptor.ReferenceStatus Property

ReferencedOLEFileDescriptor.ReferenceStatus Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the current status of the file reference. This property returns kUpToDateReference for embeddings.

Visual Basic
Property ReferenceStatus() As ReferenceStatusEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.ReferenceStatus Property


ReferencedOLEFileDescriptor.Type Property

ReferencedOLEFileDescriptor.Type Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property returning kReferencedOLEFileDescriptorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.Type Property


ReferencedOLEFileDescriptor.Visible Property

ReferencedOLEFileDescriptor.Visible Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets whether the linked/embedded object is visible in the graphics window. This property is only applicable in drawing documents. Example case of where it applies: inserting image or excel files in a drawing.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptor Interface > ReferencedOLEFileDescriptor Properties > ReferencedOLEFileDescriptor.Visible Property


ReferencedOLEFileDescriptors Interface

ReferencedOLEFileDescriptors Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ReferencedOLEFileDescriptors collection object contains information about all linked and embedded files within a document. Embeddings are not accessible in Apprentice.

Class Hierarchy
Inventor::ReferencedOLEFileDescriptors
Visual Basic
Public Interface ReferencedOLEFileDescriptors
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.ReferencedOLEFileDescriptors

Document.ReferencedOLEFileDescriptors

You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface


ReferencedOLEFileDescriptors Methods

ReferencedOLEFileDescriptors Methods
Summary

The methods of the ReferencedOLEFileDescriptors class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ReferencedOLEFileDescriptor by linking/embedding a file. The newly created ReferencedOLEFileDescriptor is returned.
Item | Property that returns the specified ReferencedOLEFileDescriptor object from the collection. This is the default property of the ReferencedOLEFileDescriptors collection object.
ItemByName | Property that returns the specified ReferencedOLEFileDescriptor object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Methods


ReferencedOLEFileDescriptors.Add Method

ReferencedOLEFileDescriptors.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new ReferencedOLEFileDescriptor by linking/embedding a file. The newly created ReferencedOLEFileDescriptor is returned.

Visual Basic
Sub Add(FullFileName As String, ByRef Type As [defaultvalue(kOLEDocumentLinkObject)] OLEDocumentTypeEnum, Result As [out, retval] ReferencedOLEFileDescriptor*)
Parameters
Parameters | Description
FullFileName | Input String value that specifies the full filename of the file.
Type | Constant indicating the OLE document type.
Remarks

This method will fail if the specified file does not exist. It will also fail if the reference will result in a cyclical dependency. For example, if Drawing1.idw references Part1.ipt, and then within Part1 you attempt to create a reference back to Drawing1.

You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Methods > ReferencedOLEFileDescriptors.Add Method


ReferencedOLEFileDescriptors.Item Method

ReferencedOLEFileDescriptors.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified ReferencedOLEFileDescriptor object from the collection. This is the default property of the ReferencedOLEFileDescriptors collection object.

Visual Basic
Sub Item(index As long, Result As [out, retval] ReferencedOLEFileDescriptor*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the ReferencedOLEFileDescriptor to return.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Methods > ReferencedOLEFileDescriptors.Item Method


ReferencedOLEFileDescriptors.ItemByName Method

ReferencedOLEFileDescriptors.ItemByName Method Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the specified ReferencedOLEFileDescriptor object from the collection.

Visual Basic
Sub ItemByName(name As String, Result As [out, retval] ReferencedOLEFileDescriptor*)
Parameters
Parameters | Description
name | Input String value that specifies the ReferencedOLEFileDescriptor to return. This can either be the FullFileName of the linked file or the display name of the linked/embedded item.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Methods > ReferencedOLEFileDescriptors.ItemByName Method


ReferencedOLEFileDescriptors Properties

ReferencedOLEFileDescriptors Properties
Summary

The properties of the ReferencedOLEFileDescriptors class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Properties


ReferencedOLEFileDescriptors.Application Property

ReferencedOLEFileDescriptors.Application Property Available in Apprentice Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Properties > ReferencedOLEFileDescriptors.Application Property


ReferencedOLEFileDescriptors.Count Property

ReferencedOLEFileDescriptors.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Properties > ReferencedOLEFileDescriptors.Count Property


ReferencedOLEFileDescriptors.Type Property

ReferencedOLEFileDescriptors.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferencedOLEFileDescriptors Interface > ReferencedOLEFileDescriptors Properties > ReferencedOLEFileDescriptors.Type Property


ReferenceFeature Interface

ReferenceFeature Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ReferenceFeature object currently supports all of the methods and properties of the base PartFeature class.

Class Hierarchy
Inventor::PartFeature
    Inventor::ReferenceFeature
        Inventor::iFeature
        Inventor::ReferenceFeatureProxy
Visual Basic
Public Interface ReferenceFeature
Inherits PartFeature
Remarks

In addition to derived part or assembly, ReferenceFeature can represent an iFeature or an iPart. (iFeatures should be ignored from this collection and since Inventor 2009 can be accessed through the iFeatures collection.)

The ReferencedEntity property has not been implemented for either of these cases. The PartFeatures collection contains a new collection called ReferenceFeatures. This collection returns the collection of features corresponding to derived parts and derived assemblies in a part component. The ReferencedEntity property for PlanarSketch, SketchEntity, WorkPlane, WorkAxis and WorkPoint objects have a new meaning in the context of a derived part. In the case where one of these objects exists as the result of a DerivedPartComponent, the ReferencedEntity property will return the object the entity is dependent on.

For example, the ReferencedEntity property of a WorkPlane that was created as a result of a derived part will return the corresponding WorkPlane in the source part. PlanarSketch, SketchEntity, WorkPlane, WorkAxis and WorkPoint objects have two new properties; HasReferenceComponent and ReferenceComponent.

The HasReferenceComponent property returns True is the object belongs to a ReferenceComponent. If the HasReferenceComponent property is True, the ReferenceComponent property will return the owning ReferenceComponent. If the HasReferenceComponent property is False, the ReferenceComponent property will return Nothing.

Notes

Members through which this object may be accessed include:

DerivedPartComponent.PrimaryBody

iFeatureComponent.ReferenceFeature

iPartMember.PrimaryBody

ReferenceFeatureProxy.NativeObject

ReferenceFeatures.Item

ReferenceFeaturesEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeature Interface


ReferenceFeature Properties

ReferenceFeature Properties
Summary

The properties of the ReferenceFeature class are listed here.

Properties
Name | Description
ReferenceComponent | Property that returns the ReferenceComponent that this feature was created as the result of. If the ReferenceFeature belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.
ReferencedEntity | Property that returns the entity in the base part or assembly document. In the case of a derived assembly, the ReferencedEntity property returns the component occurrence in the base assembly that this ReferenceFeature represents. In the case of a derived part, the ReferencedEntity property can return a solid or surface body of the source part or a surface in the source part.. In cases where the component occurrence, solid or surface body entity is referencing a model entity, but the model entity no longer exists because it has been consumed by a subsequent modeling operation, this property will return Nothing.... more
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeature Interface > ReferenceFeature Properties


ReferenceFeature.ReferenceComponent Property

ReferenceFeature.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponent that this feature was created as the result of. If the ReferenceFeature belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeature Interface > ReferenceFeature Properties > ReferenceFeature.ReferenceComponent Property


ReferenceFeature.ReferencedEntity Property

ReferenceFeature.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the entity in the base part or assembly document. In the case of a derived assembly, the ReferencedEntity property returns the component occurrence in the base assembly that this ReferenceFeature represents. In the case of a derived part, the ReferencedEntity property can return a solid or surface body of the source part or a surface in the source part..

In cases where the component occurrence, solid or surface body entity is referencing a model entity, but the model entity no longer exists because it has been consumed by a subsequent modeling operation, this property will return Nothing.

Visual Basic
Property ReferencedEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeature Interface > ReferenceFeature Properties > ReferenceFeature.ReferencedEntity Property


ReferenceFeatureProxy Interface

ReferenceFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ReferenceFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ReferenceFeature
        Inventor::ReferenceFeatureProxy
Visual Basic
Public Interface ReferenceFeatureProxy
Inherits ReferenceFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatureProxy Interface


ReferenceFeatureProxy Properties

ReferenceFeatureProxy Properties
Summary

The properties of the ReferenceFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatureProxy Interface > ReferenceFeatureProxy Properties


ReferenceFeatureProxy.ContainingOccurrence Property

ReferenceFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatureProxy Interface > ReferenceFeatureProxy Properties > ReferenceFeatureProxy.ContainingOccurrence Property


ReferenceFeatureProxy.NativeObject Property

ReferenceFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ReferenceFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatureProxy Interface > ReferenceFeatureProxy Properties > ReferenceFeatureProxy.NativeObject Property


ReferenceFeatures Interface

ReferenceFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ReferenceFeatures collection object provides access to all of the existing objects in a part component definition.

Class Hierarchy
Inventor::ReferenceFeatures
Visual Basic
Public Interface ReferenceFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.ReferenceFeatures

You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface


ReferenceFeatures Methods

ReferenceFeatures Methods
Summary

The methods of the ReferenceFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified ReferenceFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface > ReferenceFeatures Methods


ReferenceFeatures.Item Method

ReferenceFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified ReferenceFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ReferenceFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ReferenceFeature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the ReferenceFeature name. If an out of range index or a name of a non-existent ReferenceFeature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface > ReferenceFeatures Methods > ReferenceFeatures.Item Method


ReferenceFeatures Properties

ReferenceFeatures Properties
Summary

The properties of the ReferenceFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface > ReferenceFeatures Properties


ReferenceFeatures.Application Property

ReferenceFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface > ReferenceFeatures Properties > ReferenceFeatures.Application Property


ReferenceFeatures.Count Property

ReferenceFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface > ReferenceFeatures Properties > ReferenceFeatures.Count Property


ReferenceFeatures.Type Property

ReferenceFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeatures Interface > ReferenceFeatures Properties > ReferenceFeatures.Type Property


ReferenceFeaturesEnumerator Interface

ReferenceFeaturesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The ReferenceFeaturesEnumerator object enumerates through the objects.

Class Hierarchy
Inventor::ReferenceFeaturesEnumerator
Visual Basic
Public Interface ReferenceFeaturesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedAssemblyComponent.ReferenceFeatures

DerivedPartComponent.SolidBodies

DerivedPartComponent.SurfaceBodies

You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeaturesEnumerator Interface


ReferenceFeaturesEnumerator Methods

ReferenceFeaturesEnumerator Methods
Summary

The methods of the ReferenceFeaturesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified ReferenceFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeaturesEnumerator Interface > ReferenceFeaturesEnumerator Methods


ReferenceFeaturesEnumerator.Item Method

ReferenceFeaturesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns the specified ReferenceFeature object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] ReferenceFeature*)
Parameters
Parameters | Description
index | Value that specifies the index of the ReferenceFeature to return.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeaturesEnumerator Interface > ReferenceFeaturesEnumerator Methods > ReferenceFeaturesEnumerator.Item Method


ReferenceFeaturesEnumerator Properties

ReferenceFeaturesEnumerator Properties
Summary

The properties of the ReferenceFeaturesEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeaturesEnumerator Interface > ReferenceFeaturesEnumerator Properties


ReferenceFeaturesEnumerator.Count Property

ReferenceFeaturesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeaturesEnumerator Interface > ReferenceFeaturesEnumerator Properties > ReferenceFeaturesEnumerator.Count Property


ReferenceFeaturesEnumerator.Type Property

ReferenceFeaturesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceFeaturesEnumerator Interface > ReferenceFeaturesEnumerator Properties > ReferenceFeaturesEnumerator.Type Property


ReferenceKeyEventsObject Interface

ReferenceKeyEventsObject Interface Available in Inventor Introduced in Inventor 2012
Summary

Provides access to events associated with custom reference keys.

Class Hierarchy
Inventor::ReferenceKeyEventsObject
Visual Basic
Public Interface ReferenceKeyEventsObject
Inherits IDispatch
Remarks

This object is to be hidden to reduce support needs since this functionality seems to primarily be useful just for internal applications.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsObject Interface


ReferenceKeyEventsObject Properties

ReferenceKeyEventsObject Properties
Summary

The properties of the ReferenceKeyEventsObject class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Type | Property returning kReferenceKeyEventsObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsObject Interface > ReferenceKeyEventsObject Properties


ReferenceKeyEventsObject.Application Property

ReferenceKeyEventsObject.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsObject Interface > ReferenceKeyEventsObject Properties > ReferenceKeyEventsObject.Application Property


ReferenceKeyEventsObject.Type Property

ReferenceKeyEventsObject.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kReferenceKeyEventsObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsObject Interface > ReferenceKeyEventsObject Properties > ReferenceKeyEventsObject.Type Property


ReferenceKeyEventsSink Interface

ReferenceKeyEventsSink Interface
Summary

This is class Inventor::ReferenceKeyEventsSink.

Class Hierarchy
Inventor::ReferenceKeyEventsSink
Visual Basic
Public Interface ReferenceKeyEventsSink
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsSink Interface


ReferenceKeyEventsSink Methods

ReferenceKeyEventsSink Methods
Summary

The methods of the ReferenceKeyEventsSink class are listed here.

Methods
Methods
Name | Description
OnBindKeyToObject | Event that fires when either the BindKeyToObject or CanBindKeyToObject method of the ReferenceKeyManager object is called with a custom reference key.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsSink Interface > ReferenceKeyEventsSink Methods


ReferenceKeyEventsSink.OnBindKeyToObject Method

ReferenceKeyEventsSink.OnBindKeyToObject Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires when either the BindKeyToObject or CanBindKeyToObject method of the ReferenceKeyManager object is called with a custom reference key.

Visual Basic
Sub OnBindKeyToObject(ByRef ReferenceKey As SAFEARRAY(unsigned char), Document As IDispatch, ByRef Object As IDispatch*, ByRef MatchType As SolutionNatureEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
ReferenceKey | Input array of Bytes that contains the reference key.
Document | The document object that the client obtained the ReferenceKeyManager object from and called the BindKeyToObject or CanBindKeyToObject method.
Object | Output object that was found as a result of binding the provided reference key. The initial value of this argument is Nothing. In the case of multiple matches, the client should return an ObjectCollection containing all the candidate matches. The primary match is always the first member of this collection. Except for the first element, the order is not significant.
MatchType | Output SolutionNatureEnum that returns the nature of the solution that was found.
Context | (Not currently used.)
HandlingCode | Output that indicates if you are handling the event. kEventNotHandled indicates that the reference key is not yours and you’re not handling the binding. kEventHandled indicates that the reference key is yours and you are handling the binding. Even if the binding is unsuccessful you should return kEventHandled but with a match type of kNoSolution.
Remarks

A custom reference key is a key that has been constructed by your application to uniquely identify one of your objects, (see discussion below). When the BindKeyToObject method is called, Inventor first checks to see if the provided reference key is a custom or native reference key. If it’s a native reference key then Inventor will attempt to bind the reference key. If it’s a custom reference key Inventor fires this event to allow your application to bind it to your object and then Inventor can pass back your object to the original caller of the BindKeyToObject method.

If the user called CanBindKeyToObject and you do not pass back any object then Inventor returns False to the caller.

A custom reference key is initially created when the GetReferenceKey method on one of your objects is called. The GetReferenceKey method is implemented entirely by you but should have the same signature as the Inventor method of the same name. (You can always ignore the second KeyContext argument since it won’t ever apply to a custom key.) In response to when GetReferenceKey method is called on one of your objects, you construct a reference key where the first 5 bytes identify it as a custom reference key. The values of these first five bytes are 42, 75, 69, 89, 42. These are the ASCII codes for “*KEY*”.

The next set of bytes contains a unique identifier that is specific to your application so you can quickly determine if the reference key is one you generated or not. This identifier can be anything that will uniquely identify your application. Any unique set of bytes will work. The rest of the bytes contain the information you need to bind back to the original object.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyEventsSink Interface > ReferenceKeyEventsSink Methods > ReferenceKeyEventsSink.OnBindKeyToObject Method


ReferenceKeyManager Interface

ReferenceKeyManager Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Reference key manager object. This object provides methods to create and save reference key contexts as well as bind reference keys to their targets.

Class Hierarchy
Inventor::ReferenceKeyManager
Visual Basic
Public Interface ReferenceKeyManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.ReferenceKeyManager

Document.ReferenceKeyManager

Example

"Reference keys."

This sample demonstrates the concept of reference keys. Reference keys are persistent identifiers for Inventor objects. Select a face and run the ReferenceKeyFromFace() sub. This will get the reference key for the face and store it in the global RefKey variable. Then run the FaceFromReferenceKey() sub. This will use the global variable to retrieve the face and select it.

' Global variables to hold the reference key and key context values
Private RefKey() As Byte
Private ContextData() As Byte

Public Sub ReferenceKeyFromFace()

    'Set a reference to the active document
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Check to make sure a single face is in the select set.
    If oDoc.SelectSet.Count  1 _
        Or Not Typeof oDoc.SelectSet.Item(1) Is Face Then
        MsgBox "A single face must be selected."
        Exit Sub
    End If

    ' Get the Face from the select set.
    Dim oFace As Face
    Set oFace = oDoc.SelectSet.Item(1)

    ' Clear the select set
    oDoc.SelectSet.Clear

    ' Create a key context (required to obtain ref keys for BRep entities)
    Dim KeyContext As Long
    KeyContext = oDoc.ReferenceKeyManager.CreateKeyContext

    ' Get a reference key for the face
    Call oFace.GetReferenceKey(RefKey, KeyContext)

    ' Save KeyContext as a byte array for future use
    Call oDoc.ReferenceKeyManager.SaveContextToArray(KeyContext, ContextData)

End Sub

Public Sub FaceFromReferenceKey()
    'Set a reference to the active document
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Retrieve ContextKey from byte array
    Dim KeyContext As Long
    KeyContext = oDoc.ReferenceKeyManager.LoadContextFromArray(ContextData)

    ' Bind reference key to the Face object
    Dim oFace As Face
    Set oFace = oDoc.ReferenceKeyManager.BindKeyToObject(RefKey, KeyContext)

    ' Select the face
    oDoc.SelectSet.Select oFace
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface


ReferenceKeyManager Methods

ReferenceKeyManager Methods
Summary

The methods of the ReferenceKeyManager class are listed here.

Methods
Methods
Name | Description
BindKeyToObject | Method to bind a reference key to the persistent target object. Returns a specific object, if there is a unique solution.
CanBindKeyToObject | Method that returns whether the key can bind to the object.
CreateKeyContext | Method to create a key context to use in the creation of reference keys.
KeyToString | Converts a ReferenceKey byte array to a Base64 encoded string.
LoadContextFromArray | Method to load a previously saved key context from an array of data.
SaveContextToArray | Method to save a key context out as an array of data.
StringToKey | Converts a Base64 encoded string to a reference key byte array.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods


ReferenceKeyManager.BindKeyToObject Method

ReferenceKeyManager.BindKeyToObject Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method to bind a reference key to the persistent target object. Returns a specific object, if there is a unique solution.

Visual Basic
Sub BindKeyToObject(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long, ByRef MatchType As [optional] VARIANT, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the .
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities ( , FaceShell, Face, and so on.
MatchType | Output SolutionNatureEnum that returns the nature of the solution that was found.
Remarks

In case of multiple matches, it returns an ObjectCollection containing all the candidate matches. The primary match is always the first member of this collection. Except for the first element, the order is not significant. For more detailed information about primary and multiple matches and how they are determined, please see More Ref Key Info...

See Also

Reference keys sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.BindKeyToObject Method


ReferenceKeyManager.CanBindKeyToObject Method

ReferenceKeyManager.CanBindKeyToObject Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns whether the key can bind to the object.

Visual Basic
Sub CanBindKeyToObject(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long, ByRef Object As [optional] VARIANT, ByRef Context As [optional] VARIANT, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters
Description
ReferenceKey
Array of bytes that contains a reference key.
KeyContext
Optional input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (SurfaceBody, FaceShell, Face and so on.)
Object
Optional output object that returns the object if the bind was successful. An ObjectCollection is returned if multiple matches are found. Returns Nothing if the method returns False.
Context
Optional output NameValueMap object that returns information about the binding process. Possible values:

  • ObjectSuppressed As Boolean. Indicates whether the bind failed because the object is in a suppressed occurrence.
  • ObjectMissing As Boolean. Indicates whether the bind failed because the object is in a missing (unresolved) occurrence.
  • ObjectDeleted As Boolean. Indicates whether the bind failed because the object is in a deleted occurrence.
  • KnownOccurrencePath As ComponentOccurrence. Contains the known occurrence path in which the object lives.
  • MatchType As SolutionNatureEnum. Contains the nature of the solution if found.

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.CanBindKeyToObject Method


ReferenceKeyManager.CreateKeyContext Method

ReferenceKeyManager.CreateKeyContext Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method to create a key context to use in the creation of reference keys.

Visual Basic
Sub CreateKeyContext(Result As [out, retval] long)
See Also

Reference keys sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.CreateKeyContext Method


ReferenceKeyManager.KeyToString Method

ReferenceKeyManager.KeyToString Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Converts a ReferenceKey byte array to a Base64 encoded string.

Visual Basic
Sub KeyToString(ByRef ReferenceKey As SAFEARRAY(unsigned char), Result As [out, retval] BSTR)
Parameters
Parameters | Description
ReferenceKey | The reference key to convert.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.KeyToString Method


ReferenceKeyManager.LoadContextFromArray Method

ReferenceKeyManager.LoadContextFromArray Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method to load a previously saved key context from an array of data.

Visual Basic
Sub LoadContextFromArray(ByRef ContextData As SAFEARRAY(unsigned char), Result As [out, retval] long)
Parameters
Parameters | Description
ContextData | Input Byte array that specifies the context data as written out by a call to SaveContextToArray.
See Also

Reference keys sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.LoadContextFromArray Method


ReferenceKeyManager.SaveContextToArray Method

ReferenceKeyManager.SaveContextToArray Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method to save a key context out as an array of data.

Visual Basic
Sub SaveContextToArray(KeyContext As long, ByRef Result As SAFEARRAY(unsigned char))
Parameters
Parameters | Description
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities ( , FaceShell, Face and so on).
Returns

Output Byte array that returns the context data.

See Also

Reference keys sample

You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.SaveContextToArray Method


ReferenceKeyManager.StringToKey Method

ReferenceKeyManager.StringToKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Converts a Base64 encoded string to a reference key byte array.

Visual Basic
Sub StringToKey(ReferenceKeyString As String, ByRef ReferenceKey As SAFEARRAY(unsigned char))
Parameters
Parameters | Description
ReferenceKeyString | The Base64 encoded string to convert.
ReferenceKey | The resultant reference key.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Methods > ReferenceKeyManager.StringToKey Method


ReferenceKeyManager Properties

ReferenceKeyManager Properties
Summary

The properties of the ReferenceKeyManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Properties


ReferenceKeyManager.Application Property

ReferenceKeyManager.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Properties > ReferenceKeyManager.Application Property


ReferenceKeyManager.Parent Property

ReferenceKeyManager.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Properties > ReferenceKeyManager.Parent Property


ReferenceKeyManager.Type Property

ReferenceKeyManager.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceKeyManager Interface > ReferenceKeyManager Properties > ReferenceKeyManager.Type Property


ReferenceParameter Interface

ReferenceParameter Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a parameter that was created automatically by Autodesk Inventor as the result of creating an driven dimension.

Class Hierarchy
Inventor::Parameter
    Inventor::ReferenceParameter
Visual Basic
Public Interface ReferenceParameter
Inherits Parameter
Notes

Members through which this object may be accessed include:

ModelParameter.ConvertToReferenceParameter

ReferenceParameters.AddByExpression

ReferenceParameters.AddByValue

ReferenceParameters.Item

UserParameter.ConvertToReferenceParameter

You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface


ReferenceParameter Methods

ReferenceParameter Methods
Summary

The methods of the ReferenceParameter class are listed here.

Methods
Methods
Name | Description
ConvertToModelParameter | Method that causes the parameter to be converted to a model parameter. The new ModelParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).
ConvertToUserParameter | Method that causes the parameter to be converted to a user parameter. The new UserParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface > ReferenceParameter Methods


ReferenceParameter.ConvertToModelParameter Method

ReferenceParameter.ConvertToModelParameter Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that causes the parameter to be converted to a model parameter. The new ModelParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).

Visual Basic
Sub ConvertToModelParameter(Result As [out, retval] ModelParameter*)
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface > ReferenceParameter Methods > ReferenceParameter.ConvertToModelParameter Method


ReferenceParameter.ConvertToUserParameter Method

ReferenceParameter.ConvertToUserParameter Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that causes the parameter to be converted to a user parameter. The new UserParameter object is returned. This method will fail if this is a built-in parameter (indicated by the BuiltIn property).

Visual Basic
Sub ConvertToUserParameter(Result As [out, retval] UserParameter*)
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface > ReferenceParameter Methods > ReferenceParameter.ConvertToUserParameter Method


ReferenceParameter Properties

ReferenceParameter Properties
Summary

The properties of the ReferenceParameter class are listed here.

Properties
Name | Description
BuiltIn | Property that returns whether this is an Inventor-generated parameter or an API-created one. Returns True if it is Inventor-generated.
Renamed | Gets whether the ModelParameter has been renamed by the user.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface > ReferenceParameter Properties


ReferenceParameter.BuiltIn Property

ReferenceParameter.BuiltIn Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns whether this is an Inventor-generated parameter or an API-created one. Returns True if it is Inventor-generated.

Visual Basic
Property BuiltIn() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface > ReferenceParameter Properties > ReferenceParameter.BuiltIn Property


ReferenceParameter.Renamed Property

ReferenceParameter.Renamed Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets whether the ModelParameter has been renamed by the user.

Visual Basic
Property Renamed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameter Interface > ReferenceParameter Properties > ReferenceParameter.Renamed Property


ReferenceParameters Interface

ReferenceParameters Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the objects of the component definition the collection was obtained from.

Class Hierarchy
Inventor::ReferenceParameters
Visual Basic
Public Interface ReferenceParameters
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameters.ReferenceParameters

You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface


ReferenceParameters Methods

ReferenceParameters Methods
Summary

The methods of the ReferenceParameters class are listed here.

Methods
Methods
Name | Description
_AddByValue | This is _AddByValue, a member of class ReferenceParameters.
AddByExpression | Method that creates a new reference parameter given a name and expression.
AddByValue | Method that creates a new reference parameter given a name and equation.
Item | Property that returns the specified ReferenceParameter object from the collection. This is the default property of the ReferenceParameters collection object.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Methods


ReferenceParameters._AddByValue Method

ReferenceParameters._AddByValue Method
Summary

This is _AddByValue, a member of class ReferenceParameters.

Visual Basic
Sub _AddByValue(Value As double, UnitsSpecifier As VARIANT, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] ReferenceParameter*)
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Methods > ReferenceParameters._AddByValue Method


ReferenceParameters.AddByExpression Method

ReferenceParameters.AddByExpression Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new reference parameter given a name and expression.

Visual Basic
Sub AddByExpression(Expression As String, UnitsSpecifier As VARIANT, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] ReferenceParameter*)
Parameters
Parameters | Description
Expression | Input String value that specifies the equation for the parameter. This string is evaluated the same way as strings entered in any of the Inventor dialogs are evaluated. For example 'x + 3 in / 2 cm' is a valid string for input.
UnitsSpecifier | Input value that specifies the type of unit the parameter is. The units can be specified using either a string defining a valid unit or an item from the UnitsTypeEnum. If the equation references existing parameters, this unit type must be consistent with the unit type defined by the equation, otherwise an error will occur.
Name | Optional input String value that specifies the name for the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur. If not specified, a unique name generated by Inventor is assigned to the parameter.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Methods > ReferenceParameters.AddByExpression Method


ReferenceParameters.AddByValue Method

ReferenceParameters.AddByValue Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new reference parameter given a name and equation.

Visual Basic
Sub AddByValue(Value As VARIANT, UnitsSpecifier As VARIANT, ByRef Name As [defaultvalue("")] BSTR, Result As [out, retval] ReferenceParameter*)
Parameters
Parameters | Description
Value | Input Double value that specifies the value for the parameter. This value is given in database units for the unit type defined by the UnitsSpecifier argument.
UnitsSpecifier | Input value that specifies the type of unit the parameter is. The units can be specified using either a string defining a valid unit or an item from the UnitsTypeEnum. If the equation references existing parameters, this unit type must be consistent with the unit type defined by the equation, otherwise an error will occur.
Name | Optional input String value that specifies the name for the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur. If not specified, a unique name generated by Inventor is assigned to the parameter.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Methods > ReferenceParameters.AddByValue Method


ReferenceParameters.Item Method

ReferenceParameters.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified ReferenceParameter object from the collection. This is the default property of the ReferenceParameters collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] ReferenceParameter*)
Parameters
Parameters | Description
index | Input Variant value that specifies the ReferenceParameter to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the parameter name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Methods > ReferenceParameters.Item Method


ReferenceParameters Properties

ReferenceParameters Properties
Summary

The properties of the ReferenceParameters class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Properties


ReferenceParameters.Count Property

ReferenceParameters.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Properties > ReferenceParameters.Count Property


ReferenceParameters.Type Property

ReferenceParameters.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReferenceParameters Interface > ReferenceParameters Properties > ReferenceParameters.Type Property


RefoldFeature Interface

RefoldFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RefoldFeature object (together with it's complementary UnfoldFeature object) allows sheet metal features to be added when the model is flat (unfolded) and then the model can be refolded.

Class Hierarchy
Inventor::PartFeature
    Inventor::RefoldFeature
        Inventor::RefoldFeatureProxy
Visual Basic
Public Interface RefoldFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RefoldFeatures.Add

RefoldFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface


RefoldFeature Methods

RefoldFeature Methods
Summary

The methods of the RefoldFeature class are listed here.

Methods
Methods
Name | Description
Edit | Method that edits an existing refold feature. The stop node should be positioned immediately before this feature before calling this method so that all of the input is available and in a valid state.
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Methods


RefoldFeature.Edit Method

RefoldFeature.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that edits an existing refold feature. The stop node should be positioned immediately before this feature before calling this method so that all of the input is available and in a valid state.

Visual Basic
Sub Edit(StationaryFace As Face, ByRef Bends As [optional] VARIANT, ByRef Sketches As [optional] VARIANT)
Parameters
Parameters | Description
StationaryFace | Input Face object that specifies the geometry that will remain fixed while other geometry refolds. See Remarks.
Bends | Optional input ObjectCollection that defines the bend(s) to refold. The bends specified must be in an unfolded state (IsFlat equals True). Not providing this argument or inputting Nothing indicates that all flat bends are to be refolded.
Sketches | Optional input ObjectCollection that specifies any sketches to be copied and transformed as part of the folding operation. The input sketches must be a child of one of the faces being folded. Also only one sketch per folded face is allowed.
Remarks

For most models the Face specified in the StationaryFace parameter must be on the top or bottom of the part, not around the edge. The exception to this is a part where all of the faces on the top and bottom of the part are cylindrical, as shown below.

When using the Refold command in the user interface for parts like this, the user must specify one of the ends. The user interface displays what looks like work planes at each end of the part, as shown below, for the user to select. When using the API you must supply the equivalent Face objects at the end of the part.

You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Methods > RefoldFeature.Edit Method


RefoldFeature Properties

RefoldFeature Properties
Summary

The properties of the RefoldFeature class are listed here.

Properties
Name | Description
Bends | Property that returns the collection of Bend objects refolded by this feature.
InputSketches | Property that returns the sketches that were specifies as input when creating this feature.
ResultSketches | Property that returns the sketches that were created as a result of this feature.
StationaryFace | Property that returns the Face object that was specified as the stationary face during creation.
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Properties


RefoldFeature.Bends Property

RefoldFeature.Bends Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of Bend objects refolded by this feature.

Visual Basic
Property Bends() As BendsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Properties > RefoldFeature.Bends Property


RefoldFeature.InputSketches Property

RefoldFeature.InputSketches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketches that were specifies as input when creating this feature.

Visual Basic
Property InputSketches() As SketchesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Properties > RefoldFeature.InputSketches Property


RefoldFeature.ResultSketches Property

RefoldFeature.ResultSketches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketches that were created as a result of this feature.

Visual Basic
Property ResultSketches() As SketchesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Properties > RefoldFeature.ResultSketches Property


RefoldFeature.StationaryFace Property

RefoldFeature.StationaryFace Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the Face object that was specified as the stationary face during creation.

Visual Basic
Property StationaryFace() As Face**
Remarks

This property can return Nothing in the case where the face has been consumed by another operation and no longer exists in the model. Rolling back the state of the model to a point where the face exists will allow you to access it.

You are here: Symbol Reference > Inventor Library > Objects > RefoldFeature Interface > RefoldFeature Properties > RefoldFeature.StationaryFace Property


RefoldFeatureProxy Interface

RefoldFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RefoldFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RefoldFeature
        Inventor::RefoldFeatureProxy
Visual Basic
Public Interface RefoldFeatureProxy
Inherits RefoldFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatureProxy Interface


RefoldFeatures Interface

RefoldFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Object allowing iteration of the collection of RefoldFeature objects, and allows creation of RefoldFeature objects.

Class Hierarchy
Inventor::RefoldFeatures
Visual Basic
Public Interface RefoldFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.RefoldFeatures

You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface


RefoldFeatures Methods

RefoldFeatures Methods
Summary

The methods of the RefoldFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new refold feature.
Item | Property that returns the specified RefoldFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Methods


RefoldFeatures.Add Method

RefoldFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new refold feature.

Visual Basic
Sub Add(StationaryFace As Face, ByRef Bends As [optional] VARIANT, ByRef Sketches As [optional] VARIANT, Result As [out, retval] RefoldFeature*)
Parameters
Parameters | Description
StationaryFace | Input Face object that specifies the geometry that will remain fixed while other geometry refolds. See Remarks.
Bends | Optional input ObjectCollection that defines the bend(s) to refold. The bends specified must be in an unfolded state (IsFlat equals True). Not providing this argument or inputting Nothing indicates that all flat bends are to be refolded.
Sketches | Optional input ObjectCollection that specifies any sketches to be copied and transformed as part of the folding operation. The input sketches must be a child of one of the faces being folded. Also only one sketch per folded face is allowed.
Remarks

For most models the Face specified in the StationaryFace parameter must be on the top or bottom of the part, not around the edge. The exception to this is a part where all of the faces on the top and bottom of the part are cylindrical, as shown below.

When using the Refold command in the user interface for parts like this, the user must specify one of the ends. The user interface displays what looks like work planes at each end of the part, as shown below, for the user to select. When using the API you must supply the equivalent Face objects at the end of the part.

You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Methods > RefoldFeatures.Add Method


RefoldFeatures.Item Method

RefoldFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified RefoldFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RefoldFeature*)
Parameters
Parameters | Description
Index | Input Long or String value that specifies the RefoldFeature object within the collection to return. A Long value indicates the index of the feature within the collection to return. A String indicates the name of the feature. If an out of range index or an unknown name is supplied the property will fail.
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Methods > RefoldFeatures.Item Method


RefoldFeatures Properties

RefoldFeatures Properties
Summary

The properties of the RefoldFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of RefoldFeature objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Properties


RefoldFeatures.Application Property

RefoldFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Properties > RefoldFeatures.Application Property


RefoldFeatures.Count Property

RefoldFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of RefoldFeature objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Properties > RefoldFeatures.Count Property


RefoldFeatures.Type Property

RefoldFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RefoldFeatures Interface > RefoldFeatures Properties > RefoldFeatures.Type Property


RegionProperties Interface

RegionProperties Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The RegionProperties object. This object provides information relating to a profile region, including centroid, perimeter, rotation angle, moments of inertia, and axes.

Class Hierarchy
Inventor::RegionProperties
Visual Basic
Public Interface RegionProperties
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Profile.RegionProperties

See Also

True length of sweep feature sample

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface


RegionProperties Methods

RegionProperties Methods
Summary

The methods of the RegionProperties class are listed here.

Methods
Methods
Name | Description
CentroidMomentsOfInertia | This is CentroidMomentsOfInertia, a member of class RegionProperties.
GetTorsionProperties | Method that returns torsion coefficients of sketch profile.
MomentsOfInertia | Method that returns the moments of inertia about the sketch origin.
PrincipalAxes | Method that returns the principal axes.
PrincipalMomentsOfInertia | Method that returns the moments of inertia about the principal axes.
RadiusOfGyration | Method that returns the radius of gyration about the principal axes.
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods


RegionProperties.CentroidMomentsOfInertia Method

RegionProperties.CentroidMomentsOfInertia Method
Summary

This is CentroidMomentsOfInertia, a member of class RegionProperties.

Visual Basic
Sub CentroidMomentsOfInertia(ByRef Ixx As double, ByRef Iyy As double, ByRef Izz As double, ByRef Ixy As double, ByRef Iyz As double, ByRef Ixz As double)
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods > RegionProperties.CentroidMomentsOfInertia Method


RegionProperties.GetTorsionProperties Method

RegionProperties.GetTorsionProperties Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns torsion coefficients of sketch profile.

Visual Basic
Sub GetTorsionProperties(ByRef Torsion As double, ByRef WorstStressValue As double, ByRef WorstStressPosition As Point*, ByRef FiniteElementNodeCount As [defaultvalue(10000)] long)
Parameters
Parameters | Description
Torsion | The torsion value.
WorstStressValue | WorstStressValue
WorstStressPosition | WorstStressPosition
FiniteElementNodeCount | FiniteElementNodeCount
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods > RegionProperties.GetTorsionProperties Method


RegionProperties.MomentsOfInertia Method

RegionProperties.MomentsOfInertia Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the moments of inertia about the sketch origin.

Visual Basic
Sub MomentsOfInertia(ByRef Ixx As double, ByRef Iyy As double, ByRef Izz As double, ByRef Ixy As double, ByRef Iyz As double, ByRef Ixz As double)
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods > RegionProperties.MomentsOfInertia Method


RegionProperties.PrincipalAxes Method

RegionProperties.PrincipalAxes Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the principal axes.

Visual Basic
Sub PrincipalAxes(ByRef XAxis As Vector*, ByRef YAxis As Vector*)
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods > RegionProperties.PrincipalAxes Method


RegionProperties.PrincipalMomentsOfInertia Method

RegionProperties.PrincipalMomentsOfInertia Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the moments of inertia about the principal axes.

Visual Basic
Sub PrincipalMomentsOfInertia(ByRef Ix As double, ByRef Iy As double, ByRef Iz As double)
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods > RegionProperties.PrincipalMomentsOfInertia Method


RegionProperties.RadiusOfGyration Method

RegionProperties.RadiusOfGyration Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the radius of gyration about the principal axes.

Visual Basic
Sub RadiusOfGyration(ByRef Kxx As double, ByRef Kyy As double, ByRef Kzz As double)
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Methods > RegionProperties.RadiusOfGyration Method


RegionProperties Properties

RegionProperties Properties
Summary

The properties of the RegionProperties class are listed here.

Properties
Name | Description
Accuracy | Get and sets the desired accuracy of calculations.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Area | Property that returns the area of the section in database units.
Centroid | Property that returns the centroid of the section.
Parent | Gets the parent object from whom this object can logically be reached.
Perimeter | Property that returns the perimeter of the section in database units.
RotationAngle | Property that returns the angle of rotation of the principal axes.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties


RegionProperties.Accuracy Property

RegionProperties.Accuracy Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Get and sets the desired accuracy of calculations.

Visual Basic
Property Accuracy() As AccuracyEnum
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Accuracy Property


RegionProperties.Application Property

RegionProperties.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Application Property


RegionProperties.Area Property

RegionProperties.Area Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the area of the section in database units.

Visual Basic
Property Area() As double*
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Area Property


RegionProperties.Centroid Property

RegionProperties.Centroid Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the centroid of the section.

Visual Basic
Property Centroid() As IDispatch**
See Also

True length of sweep feature sample

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Centroid Property


RegionProperties.Parent Property

RegionProperties.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Parent Property


RegionProperties.Perimeter Property

RegionProperties.Perimeter Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the perimeter of the section in database units.

Visual Basic
Property Perimeter() As double*
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Perimeter Property


RegionProperties.RotationAngle Property

RegionProperties.RotationAngle Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the angle of rotation of the principal axes.

Visual Basic
Property RotationAngle() As double*
See Also

Accessing region properties from a profile sample

You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.RotationAngle Property


RegionProperties.Type Property

RegionProperties.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RegionProperties Interface > RegionProperties Properties > RegionProperties.Type Property


RenderStyle Interface

RenderStyle Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RenderStyle object provides access to all of the properties that define a specific rendering style.

Class Hierarchy
Inventor::RenderStyle
Visual Basic
Public Interface RenderStyle
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.ActiveRenderStyle

ComponentOccurrence.GetRenderStyle

ComponentOccurrence.RenderStyle

EmbossFeature.TopFaceColor

Face.GetRenderStyle

GraphicsNode.RenderStyle

Material.RenderStyle

PartDocument.ActiveRenderStyle

PartFeature.GetRenderStyle

PresentationExplodedView.GetRenderStyle

RenderStyle.ConvertToLocal

RenderStyle.Copy

RenderStyles.Add

RenderStyles.Item

SurfaceBody.GetRenderStyle

SurfaceGraphicsFace.RenderStyle

WeldmentComponentDefinition.GetEndFillRenderStyle

See Also

Create client graphics based on the solid body of the active part sample

You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface


RenderStyle Methods

RenderStyle Methods
Summary

The methods of the RenderStyle class are listed here.

Methods
Methods
Name | Description
ApproximateFromRealisticAppearance | Method that extracts information (such as ambient color, diffuse color, etc.) from the associated realistic material and assigns it to the render style. Calling this method returns an error if there is no associated realistic material.
ConvertToLocal | Method that creates a local cached copy of a global style and returns the local style. This method fails if this style is already local. Use the Local property to determine whether the style is local.
Copy | Method that copies the rendering style and assigns the specified name to the copy. The new style is returned by the method.
Delete | Method that deletes the RenderStyle.
GetAmbientColor | Method that gets the ambient color of the rendering style.
GetDiffuseColor | Method that gets the diffuse color of the rendering style.
GetEmissiveColor | Method that gets the emissive color of the rendering style.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetSpecularColor | Method that gets the specular color of the rendering style.
SaveToGlobal | This method saves this style to the global repository. If a style with the same name is found in the repository, that style is updated.
SetAmbientColor | Method that sets the ambient color of the rendering style.
SetDiffuseColor | Method that sets the diffuse color of the rendering style.
SetEmissiveColor | Method that sets the emissive color of the rendering style.
SetSpecularColor | Method that sets the specular color of the rendering style.
UpdateFromGlobal | Method that updates this style from the global repository.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods


RenderStyle.ApproximateFromRealisticAppearance Method

RenderStyle.ApproximateFromRealisticAppearance Method
Summary

Method that extracts information (such as ambient color, diffuse color, etc.) from the associated realistic material and assigns it to the render style. Calling this method returns an error if there is no associated realistic material.

Visual Basic
Sub ApproximateFromRealisticAppearance()
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.ApproximateFromRealisticAppearance Method


RenderStyle.ConvertToLocal Method

RenderStyle.ConvertToLocal Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a local cached copy of a global style and returns the local style. This method fails if this style is already local. Use the Local property to determine whether the style is local.

Visual Basic
Sub ConvertToLocal(Result As [out, retval] RenderStyle*)
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.ConvertToLocal Method


RenderStyle.Copy Method

RenderStyle.Copy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that copies the rendering style and assigns the specified name to the copy. The new style is returned by the method.

Visual Basic
Sub Copy(NewName As String, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
NewName | Input String that specifies the name for the new rendering style. This name must be unique with respect to all other rendering styles in the document. If it is not unique the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.Copy Method


RenderStyle.Delete Method

RenderStyle.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the RenderStyle.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.Delete Method


RenderStyle.GetAmbientColor Method

RenderStyle.GetAmbientColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets the ambient color of the rendering style.

Visual Basic
Sub GetAmbientColor(ByRef Red As unsigned char, ByRef Green As unsigned char, ByRef Blue As unsigned char)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | Output Byte that specifies the blue component of the color. This value will be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.GetAmbientColor Method


RenderStyle.GetDiffuseColor Method

RenderStyle.GetDiffuseColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets the diffuse color of the rendering style.

Visual Basic
Sub GetDiffuseColor(ByRef Red As unsigned char, ByRef Green As unsigned char, ByRef Blue As unsigned char)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | Output Byte that specifies the blue component of the color. This value will be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.GetDiffuseColor Method


RenderStyle.GetEmissiveColor Method

RenderStyle.GetEmissiveColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets the emissive color of the rendering style.

Visual Basic
Sub GetEmissiveColor(ByRef Red As unsigned char, ByRef Green As unsigned char, ByRef Blue As unsigned char)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | Output Byte that specifies the blue component of the color. This value will be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.GetEmissiveColor Method


RenderStyle.GetReferenceKey Method

RenderStyle.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.GetReferenceKey Method


RenderStyle.GetSpecularColor Method

RenderStyle.GetSpecularColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets the specular color of the rendering style.

Visual Basic
Sub GetSpecularColor(ByRef Red As unsigned char, ByRef Green As unsigned char, ByRef Blue As unsigned char)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | Output Byte that specifies the blue component of the color. This value will be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.GetSpecularColor Method


RenderStyle.SaveToGlobal Method

RenderStyle.SaveToGlobal Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

This method saves this style to the global repository. If a style with the same name is found in the repository, that style is updated.

Visual Basic
Sub SaveToGlobal()
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.SaveToGlobal Method


RenderStyle.SetAmbientColor Method

RenderStyle.SetAmbientColor Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the ambient color of the rendering style.

Visual Basic
Sub SetAmbientColor(Red As unsigned char, Green As unsigned char, Blue As unsigned char)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | Input Byte that specifies the blue component of the color. This value must be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.SetAmbientColor Method


RenderStyle.SetDiffuseColor Method

RenderStyle.SetDiffuseColor Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the diffuse color of the rendering style.

Visual Basic
Sub SetDiffuseColor(Red As unsigned char, Green As unsigned char, Blue As unsigned char)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | Input Byte that specifies the blue component of the color. This value must be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.SetDiffuseColor Method


RenderStyle.SetEmissiveColor Method

RenderStyle.SetEmissiveColor Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the emissive color of the rendering style.

Visual Basic
Sub SetEmissiveColor(Red As unsigned char, Green As unsigned char, Blue As unsigned char)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | Input Byte that specifies the blue component of the color. This value must be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.SetEmissiveColor Method


RenderStyle.SetSpecularColor Method

RenderStyle.SetSpecularColor Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the specular color of the rendering style.

Visual Basic
Sub SetSpecularColor(Red As unsigned char, Green As unsigned char, Blue As unsigned char)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | Input Byte that specifies the blue component of the color. This value must be between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.SetSpecularColor Method


RenderStyle.UpdateFromGlobal Method

RenderStyle.UpdateFromGlobal Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that updates this style from the global repository.

Visual Basic
Sub UpdateFromGlobal()
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Methods > RenderStyle.UpdateFromGlobal Method


RenderStyle Properties

RenderStyle Properties
Summary

The properties of the RenderStyle class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BumpMapAmount | Property that gets and sets the amount of apparent bumpiness provided by the bump image. Valid range of values is from 0 to 1.
BumpMapImageFilename | Property that gets and sets the filename of the bitmap used for the bump map. The bump map image can be cleared by setting this to an empty string.
BumpMapInvert | Property that gets and sets whether to invert the bump effect on the surface.
BumpMapRotation | Property that gets and sets the rotation of the bump map. The angle is defined in radians.
BumpMapScale | Property that gets and sets the scale of the bump map. Valid range of values is .01 to 10 indicating a range of 1% to 1000%.
DisplayInteriorFaces | Property that gets and sets the visibility of interior faces.
InternalName | Property that gets the internal name of the render style.
InUse | Property that indicates if this render style is in use in the document.
Name | Property that indicates the name of this object or instance.
Opacity | Property that gets and sets the opacity of the render style. The opacity is defined using a value between 0 and 1. A value of 0 results in a completely translucent style while a value of 1 is completely opaque.
Parent | Property returning the parent of the object.
RealisticAppearanceInternalName | Property that gets and sets the realistic material associated with this render style using the internal name of the realistic material. This property returns a null string if there is no associated realistic material and can be set to a null string to clear the associated material.
RealisticAppearanceName | Property that gets and sets the realistic material associated with this render style using the display name of the realistic material. This property returns a null string if there is no associated realistic material and can be set to a null string to clear the associated material.
RealisticAppearanceRotation | Property that gets and sets the rotation to be applied to the realistic appearance texture. The angle is defined in radians. This property returns 0 if there is no associated realistic material.
RealisticAppearanceScale | Property that gets and sets the scale to be applied to the realistic appearance texture. Valid range of values is .01 to 10 indicating a range of 1% to 1000%. This property returns 1 if there is no associated realistic material.
RealisticAppearanceThumbnail | Property that returns the thumbnail image of the associated realistic material. This property returns Nothing if there is no associated realistic material.
Reflectivity | Property that gets and sets the reflectivity of the render style. The reflectivity is defined using a value between 0 and 1. A value of 0 results in a non-reflective rendering style while a value of 1 is very reflective.
StyleLocation | Property that indicates the location status ( ) of this render style.
TextureFilename | Property that gets and sets the filename of the bitmap used for the texture. The texture can be cleared by setting this to an empty string.
TextureRotation | Property that gets and sets the rotation of the texture. The angle is defined in radians.
TextureScale | Property that gets and sets the scale of the texture.
Type | Property returning an enum indicating this object's type.
UpToDate | If a property of both a Local and Global style is changed, its UpToDate property returns False until UpdateFromGlobal is called. UpdateFromGlobal undoes any changes made locally on this style, so then the UpToDate property will return True.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties


RenderStyle.Application Property

RenderStyle.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.Application Property


RenderStyle.AttributeSets Property

RenderStyle.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.AttributeSets Property


RenderStyle.BumpMapAmount Property

RenderStyle.BumpMapAmount Property Available in Apprentice
Summary

Property that gets and sets the amount of apparent bumpiness provided by the bump image. Valid range of values is from 0 to 1.

Visual Basic
Property BumpMapAmount() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.BumpMapAmount Property


RenderStyle.BumpMapImageFilename Property

RenderStyle.BumpMapImageFilename Property Available in Apprentice
Summary

Property that gets and sets the filename of the bitmap used for the bump map. The bump map image can be cleared by setting this to an empty string.

Visual Basic
Property BumpMapImageFilename() As String
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.BumpMapImageFilename Property


RenderStyle.BumpMapInvert Property

RenderStyle.BumpMapInvert Property Available in Apprentice
Summary

Property that gets and sets whether to invert the bump effect on the surface.

Visual Basic
Property BumpMapInvert() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.BumpMapInvert Property


RenderStyle.BumpMapRotation Property

RenderStyle.BumpMapRotation Property Available in Apprentice
Summary

Property that gets and sets the rotation of the bump map. The angle is defined in radians.

Visual Basic
Property BumpMapRotation() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.BumpMapRotation Property


RenderStyle.BumpMapScale Property

RenderStyle.BumpMapScale Property Available in Apprentice
Summary

Property that gets and sets the scale of the bump map. Valid range of values is .01 to 10 indicating a range of 1% to 1000%.

Visual Basic
Property BumpMapScale() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.BumpMapScale Property


RenderStyle.DisplayInteriorFaces Property

RenderStyle.DisplayInteriorFaces Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the visibility of interior faces.

Visual Basic
Property DisplayInteriorFaces() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.DisplayInteriorFaces Property


RenderStyle.InternalName Property

RenderStyle.InternalName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the internal name of the render style.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.InternalName Property


RenderStyle.InUse Property

RenderStyle.InUse Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates if this render style is in use in the document.

Visual Basic
Property InUse() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.InUse Property


RenderStyle.Name Property

RenderStyle.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.Name Property


RenderStyle.Opacity Property

RenderStyle.Opacity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the opacity of the render style. The opacity is defined using a value between 0 and 1. A value of 0 results in a completely translucent style while a value of 1 is completely opaque.

Visual Basic
Property Opacity() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.Opacity Property


RenderStyle.Parent Property

RenderStyle.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning the parent of the object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.Parent Property


RenderStyle.RealisticAppearanceInternalName Property

RenderStyle.RealisticAppearanceInternalName Property Available in Apprentice
Summary

Property that gets and sets the realistic material associated with this render style using the internal name of the realistic material. This property returns a null string if there is no associated realistic material and can be set to a null string to clear the associated material.

Visual Basic
Property RealisticAppearanceInternalName() As String
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.RealisticAppearanceInternalName Property


RenderStyle.RealisticAppearanceName Property

RenderStyle.RealisticAppearanceName Property Available in Apprentice
Summary

Property that gets and sets the realistic material associated with this render style using the display name of the realistic material. This property returns a null string if there is no associated realistic material and can be set to a null string to clear the associated material.

Visual Basic
Property RealisticAppearanceName() As String
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.RealisticAppearanceName Property


RenderStyle.RealisticAppearanceRotation Property

RenderStyle.RealisticAppearanceRotation Property Available in Apprentice
Summary

Property that gets and sets the rotation to be applied to the realistic appearance texture. The angle is defined in radians. This property returns 0 if there is no associated realistic material.

Visual Basic
Property RealisticAppearanceRotation() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.RealisticAppearanceRotation Property


RenderStyle.RealisticAppearanceScale Property

RenderStyle.RealisticAppearanceScale Property Available in Apprentice
Summary

Property that gets and sets the scale to be applied to the realistic appearance texture. Valid range of values is .01 to 10 indicating a range of 1% to 1000%. This property returns 1 if there is no associated realistic material.

Visual Basic
Property RealisticAppearanceScale() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.RealisticAppearanceScale Property


RenderStyle.RealisticAppearanceThumbnail Property

RenderStyle.RealisticAppearanceThumbnail Property
Summary

Property that returns the thumbnail image of the associated realistic material. This property returns Nothing if there is no associated realistic material.

Visual Basic
Property RealisticAppearanceThumbnail() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.RealisticAppearanceThumbnail Property


RenderStyle.Reflectivity Property

RenderStyle.Reflectivity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the reflectivity of the render style. The reflectivity is defined using a value between 0 and 1. A value of 0 results in a non-reflective rendering style while a value of 1 is very reflective.

Visual Basic
Property Reflectivity() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.Reflectivity Property


RenderStyle.StyleLocation Property

RenderStyle.StyleLocation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the location status ( ) of this render style.

Visual Basic
Property StyleLocation() As StyleLocationEnum*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.StyleLocation Property


RenderStyle.TextureFilename Property

RenderStyle.TextureFilename Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the filename of the bitmap used for the texture. The texture can be cleared by setting this to an empty string.

Visual Basic
Property TextureFilename() As String
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.TextureFilename Property


RenderStyle.TextureRotation Property

RenderStyle.TextureRotation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the rotation of the texture. The angle is defined in radians.

Visual Basic
Property TextureRotation() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.TextureRotation Property


RenderStyle.TextureScale Property

RenderStyle.TextureScale Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the scale of the texture.

Visual Basic
Property TextureScale() As double
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.TextureScale Property


RenderStyle.Type Property

RenderStyle.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.Type Property


RenderStyle.UpToDate Property

RenderStyle.UpToDate Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

If a property of both a Local and Global style is changed, its UpToDate property returns False until UpdateFromGlobal is called. UpdateFromGlobal undoes any changes made locally on this style, so then the UpToDate property will return True.

Visual Basic
Property UpToDate() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyle Interface > RenderStyle Properties > RenderStyle.UpToDate Property


RenderStyles Interface

RenderStyles Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RenderStyles collection object allows for the creation of new objects and provides access to existing RenderStyle objects.

Class Hierarchy
Inventor::RenderStyles
Visual Basic
Public Interface RenderStyles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Document.RenderStyles

See Also

Create client graphics based on the solid body of the active part sample

You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface


RenderStyles Methods

RenderStyles Methods
Summary

The methods of the RenderStyles class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new RenderStyle object. The name of the new style is specified, while the rendering attributes are initialized with the same values as the Default style.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Methods


RenderStyles.Add Method

RenderStyles.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new RenderStyle object. The name of the new style is specified, while the rendering attributes are initialized with the same values as the Default style.

Visual Basic
Sub Add(Name As String, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
Name | Input String that specifies the name of the new rendering style. This name must be unique with respect to all other rendering styles defined in the document. The method will fail if the name is not unique.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Methods > RenderStyles.Add Method


RenderStyles.Item Method

RenderStyles.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
index | Input Variant that specifies name or index number of the RenderStyle to return.
See Also

Create client graphics based on the solid body of the active part sample

You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Methods > RenderStyles.Item Method


RenderStyles Properties

RenderStyles Properties
Summary

The properties of the RenderStyles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Properties


RenderStyles.Application Property

RenderStyles.Application Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Properties > RenderStyles.Application Property


RenderStyles.Count Property

RenderStyles.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Properties > RenderStyles.Count Property


RenderStyles.Parent Property

RenderStyles.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Properties > RenderStyles.Parent Property


RenderStyles.Type Property

RenderStyles.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RenderStyles Interface > RenderStyles Properties > RenderStyles.Type Property


ReplaceFaceFeature Interface

ReplaceFaceFeature Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The ReplaceFaceFeature object represents a Replace Face feature, which is created interactively by using the Replace Face command on the Part Features menu.

Class Hierarchy
Inventor::PartFeature
    Inventor::ReplaceFaceFeature
        Inventor::ReplaceFaceFeatureProxy
Visual Basic
Public Interface ReplaceFaceFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ReplaceFaceFeatureProxy.NativeObject

ReplaceFaceFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeature Interface


ReplaceFaceFeatureProxy Interface

ReplaceFaceFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ReplaceFaceFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ReplaceFaceFeature
        Inventor::ReplaceFaceFeatureProxy
Visual Basic
Public Interface ReplaceFaceFeatureProxy
Inherits ReplaceFaceFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatureProxy Interface


ReplaceFaceFeatureProxy Properties

ReplaceFaceFeatureProxy Properties
Summary

The properties of the ReplaceFaceFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatureProxy Interface > ReplaceFaceFeatureProxy Properties


ReplaceFaceFeatureProxy.ContainingOccurrence Property

ReplaceFaceFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatureProxy Interface > ReplaceFaceFeatureProxy Properties > ReplaceFaceFeatureProxy.ContainingOccurrence Property


ReplaceFaceFeatureProxy.NativeObject Property

ReplaceFaceFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ReplaceFaceFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatureProxy Interface > ReplaceFaceFeatureProxy Properties > ReplaceFaceFeatureProxy.NativeObject Property


ReplaceFaceFeatures Interface

ReplaceFaceFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The ReplaceFaceFeatures collection object represents a collection of objects.

Class Hierarchy
Inventor::ReplaceFaceFeatures
Visual Basic
Public Interface ReplaceFaceFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.ReplaceFaceFeatures

You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface


ReplaceFaceFeatures Methods

ReplaceFaceFeatures Methods
Summary

The methods of the ReplaceFaceFeatures class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified ReplaceFaceFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface > ReplaceFaceFeatures Methods


ReplaceFaceFeatures.Item Method

ReplaceFaceFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that returns the specified ReplaceFaceFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ReplaceFaceFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out-of-range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface > ReplaceFaceFeatures Methods > ReplaceFaceFeatures.Item Method


ReplaceFaceFeatures Properties

ReplaceFaceFeatures Properties
Summary

The properties of the ReplaceFaceFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface > ReplaceFaceFeatures Properties


ReplaceFaceFeatures.Application Property

ReplaceFaceFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface > ReplaceFaceFeatures Properties > ReplaceFaceFeatures.Application Property


ReplaceFaceFeatures.Count Property

ReplaceFaceFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface > ReplaceFaceFeatures Properties > ReplaceFaceFeatures.Count Property


ReplaceFaceFeatures.Type Property

ReplaceFaceFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ReplaceFaceFeatures Interface > ReplaceFaceFeatures Properties > ReplaceFaceFeatures.Type Property


RepresentationEvents CoClass

RepresentationEvents CoClass Available in Inventor Available in Server Introduced in Inventor 11
Summary

The RepresentationEvents object provides notification of representation events including creation, activation or deletion of design views, level of detail or positional representations.

Class Hierarchy
Inventor::RepresentationEvents
Visual Basic
Public Class RepresentationEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.RepresentationEvents

You are here: Symbol Reference > Inventor Library > Objects > RepresentationEvents CoClass


RepresentationEventsObject Interface

RepresentationEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The RepresentationEvents object provides notification of representation events including creation, activation or deletion of design views, level of detail or positional representations.

Class Hierarchy
Inventor::RepresentationEventsObject
Visual Basic
Public Interface RepresentationEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.RepresentationEvents

You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsObject Interface


RepresentationEventsObject Properties

RepresentationEventsObject Properties
Summary

The properties of the RepresentationEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning kRepresentationEventsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsObject Interface > RepresentationEventsObject Properties


RepresentationEventsObject.Application Property

RepresentationEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsObject Interface > RepresentationEventsObject Properties > RepresentationEventsObject.Application Property


RepresentationEventsObject.Parent Property

RepresentationEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsObject Interface > RepresentationEventsObject Properties > RepresentationEventsObject.Parent Property


RepresentationEventsObject.Type Property

RepresentationEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kRepresentationEventsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsObject Interface > RepresentationEventsObject Properties > RepresentationEventsObject.Type Property


RepresentationEventsSink Interface

RepresentationEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The RepresentationEvents object provides notification of representation events including creation, activation or deletion of design views, level of detail or positional representations.

Class Hierarchy
Inventor::RepresentationEventsSink
Visual Basic
Public Interface RepresentationEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.RepresentationEvents

You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface


RepresentationEventsSink Methods

RepresentationEventsSink Methods
Summary

The methods of the RepresentationEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivateDesignView | Event that is fired whenever a design view representation is activated in a part, a flat pattern or an assembly.
OnActivateLevelOfDetailRepresentation | The OnActivateLevelOfDetailRepresentation event notifies the client when a level of detail is being activated.
OnActivatePositionalRepresentation | The OnActivatePositionalRepresentation event notifies the client when a positional representation is being activated.
OnDelete | The OnDelete event notifies the client when any representation related objects are deleted. These include level of details, positional representations, and design views.
OnNewDesignView | Event that is fired whenever a design view representation is created in a part, a flat pattern or an assembly.
OnNewLevelOfDetailRepresentation | The OnNewLevelOfDetailRepresentation event notifies the client a new level of detail is created.
OnNewPositionalRepresentation | The OnNewPositionalRepresentation event notifies the client when a new positional representation is created.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods


RepresentationEventsSink.OnActivateDesignView Method

RepresentationEventsSink.OnActivateDesignView Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired whenever a design view representation is activated in a part, a flat pattern or an assembly.

Visual Basic
Sub OnActivateDesignView(DocumentObject As Document, Representation As DesignViewRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Representation | Input DesignViewRepresentation object that was just activated.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the representation is activated.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnActivateDesignView Method


RepresentationEventsSink.OnActivateLevelOfDetailRepresentation Method

RepresentationEventsSink.OnActivateLevelOfDetailRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnActivateLevelOfDetailRepresentation event notifies the client when a level of detail is being activated.

Visual Basic
Sub OnActivateLevelOfDetailRepresentation(DocumentObject As Document, Representation As LevelOfDetailRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the level of detail is being activated within.
Representation | The LevelOfDetailRepresentation object that is being activated.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the level of detail has been activated.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnActivateLevelOfDetailRepresentation Method


RepresentationEventsSink.OnActivatePositionalRepresentation Method

RepresentationEventsSink.OnActivatePositionalRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnActivatePositionalRepresentation event notifies the client when a positional representation is being activated.

Visual Basic
Sub OnActivatePositionalRepresentation(DocumentObject As AssemblyDocument, Representation As PositionalRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the positional representation is being activated within.
Representation | The PositionalRepresentation object that is being activated.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the positional representation has been activated.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnActivatePositionalRepresentation Method


RepresentationEventsSink.OnDelete Method

RepresentationEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnDelete event notifies the client when any representation related objects are deleted. These include level of details, positional representations, and design views.

Visual Basic
Sub OnDelete(DocumentObject As Document, Entity As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
The Document object the deleted object is within.
Entity
The representation that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the object provided is the object before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example: Private m_oDeletedEntity As Object Private Sub oRepresentationEvents_OnDelete(ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...) If BeforeOrAfter = kBefore Then ' Somehow Check to see if the representation being deleted is an interesting one. If Interesting(Entity) Then ' Save a reference to the object. Set m_oDeletedEntity = Entity End If Else ' Now we're either after the delete or it's been aborted. ' Check to see if the object is the interesting one. If Entity is m_oDeletedEntity Then If BeforeOrAfter = kAfter then ' The object was deleted. ElseIf BeforeOrAfter = kAbort Then ' The delete was aborted. End If End If End Sub
BeforeOrAfter
Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the object is deleted.
Context
Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnDelete Method


RepresentationEventsSink.OnNewDesignView Method

RepresentationEventsSink.OnNewDesignView Method Available in Inventor Introduced in Inventor 2012
Summary

Event that is fired whenever a design view representation is created in a part, a flat pattern or an assembly.

Visual Basic
Sub OnNewDesignView(DocumentObject As Document, Representation As DesignViewRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Representation | Input DesignViewRepresentation object that was just created. Nothing in the kBefore case.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the representation is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnNewDesignView Method


RepresentationEventsSink.OnNewLevelOfDetailRepresentation Method

RepresentationEventsSink.OnNewLevelOfDetailRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnNewLevelOfDetailRepresentation event notifies the client a new level of detail is created.

Visual Basic
Sub OnNewLevelOfDetailRepresentation(DocumentObject As Document, Representation As LevelOfDetailRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the level of detail is being created within.
Representation | The new LevelOfDetailRepresentation object that has just been created. When the BeforeOrAfter argument is kBefore, this argument is Nothing since the level of detail has not yet been created.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the level of detail has been created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnNewLevelOfDetailRepresentation Method


RepresentationEventsSink.OnNewPositionalRepresentation Method

RepresentationEventsSink.OnNewPositionalRepresentation Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnNewPositionalRepresentation event notifies the client when a new positional representation is created.

Visual Basic
Sub OnNewPositionalRepresentation(DocumentObject As AssemblyDocument, Representation As PositionalRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the positional representation is being created within.
Representation | The new PositionalRepresentation object that has just been created. When the BeforeOrAfter argument is kBefore, this argument is Nothing since the positional representation has not yet been created.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the positional representation has been created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationEventsSink Interface > RepresentationEventsSink Methods > RepresentationEventsSink.OnNewPositionalRepresentation Method


RepresentationsManager Interface

RepresentationsManager Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The RepresentationsManager object provides access to all types of representations in an assembly, and design view representations in a part.

Class Hierarchy
Inventor::RepresentationsManager
Visual Basic
Public Interface RepresentationsManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.RepresentationsManager

DesignViewRepresentation.Parent

LevelOfDetailRepresentation.Parent

PositionalRepresentation.Parent

You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface


RepresentationsManager Methods

RepresentationsManager Methods
Summary

The methods of the RepresentationsManager class are listed here.

Methods
Methods
Name | Description
_Parent | This is _Parent, a member of class RepresentationsManager.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Methods


RepresentationsManager._Parent Method

RepresentationsManager._Parent Method
Summary

This is _Parent, a member of class RepresentationsManager.

Visual Basic
Sub _Parent(Result As [out, retval] AssemblyComponentDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Methods > RepresentationsManager._Parent Method


RepresentationsManager Properties

RepresentationsManager Properties
Summary

The properties of the RepresentationsManager class are listed here.

Properties
Name | Description
ActiveDesignViewRepresentation | Property that returns the active DesignViewRepresentation object.
ActiveLevelOfDetailRepresentation | Property that returns the active LevelOfDetailRepresentation object. This property returns Nothing in part documents.
ActivePositionalRepresentation | Property that returns the active PositionalRepresentation object. This property returns Nothing in part documents.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DesignViewRepresentations | Property that returns the DesignViewRepresentations collection object.
LevelOfDetailRepresentations | Property that returns the LevelOfDetailRepresentations collection object. This property returns Nothing in part documents.
Parent | Property that returns the parent ComponentDefinition object.
PositionalRepresentations | Property that returns the PositionalRepresentations collection object. This property returns Nothing in part documents.
Type | Property returning kRepresentationsManagerObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties


RepresentationsManager.ActiveDesignViewRepresentation Property

RepresentationsManager.ActiveDesignViewRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the active DesignViewRepresentation object.

Visual Basic
Property ActiveDesignViewRepresentation() As DesignViewRepresentation**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.ActiveDesignViewRepresentation Property


RepresentationsManager.ActiveLevelOfDetailRepresentation Property

RepresentationsManager.ActiveLevelOfDetailRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the active LevelOfDetailRepresentation object. This property returns Nothing in part documents.

Visual Basic
Property ActiveLevelOfDetailRepresentation() As LevelOfDetailRepresentation**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.ActiveLevelOfDetailRepresentation Property


RepresentationsManager.ActivePositionalRepresentation Property

RepresentationsManager.ActivePositionalRepresentation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the active PositionalRepresentation object. This property returns Nothing in part documents.

Visual Basic
Property ActivePositionalRepresentation() As PositionalRepresentation**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.ActivePositionalRepresentation Property


RepresentationsManager.Application Property

RepresentationsManager.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.Application Property


RepresentationsManager.DesignViewRepresentations Property

RepresentationsManager.DesignViewRepresentations Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the DesignViewRepresentations collection object.

Visual Basic
Property DesignViewRepresentations() As DesignViewRepresentations**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.DesignViewRepresentations Property


RepresentationsManager.LevelOfDetailRepresentations Property

RepresentationsManager.LevelOfDetailRepresentations Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the LevelOfDetailRepresentations collection object. This property returns Nothing in part documents.

Visual Basic
Property LevelOfDetailRepresentations() As LevelOfDetailRepresentations**
See Also

Shrink wrap substitute in assembly sample

Create a level of detail representation sample

You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.LevelOfDetailRepresentations Property


RepresentationsManager.Parent Property

RepresentationsManager.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.Parent Property


RepresentationsManager.PositionalRepresentations Property

RepresentationsManager.PositionalRepresentations Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the PositionalRepresentations collection object. This property returns Nothing in part documents.

Visual Basic
Property PositionalRepresentations() As PositionalRepresentations**
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.PositionalRepresentations Property


RepresentationsManager.Type Property

RepresentationsManager.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kRepresentationsManagerObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RepresentationsManager Interface > RepresentationsManager Properties > RepresentationsManager.Type Property


RestFeature Interface

RestFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RestFeature object represents a Rest sheet metal feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::RestFeature
        Inventor::RestFeatureProxy
Visual Basic
Public Interface RestFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RestFeatureProxy.NativeObject

RestFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > RestFeature Interface


RestFeatureProxy Interface

RestFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RestFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RestFeature
        Inventor::RestFeatureProxy
Visual Basic
Public Interface RestFeatureProxy
Inherits RestFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RestFeatureProxy Interface


RestFeatureProxy Properties

RestFeatureProxy Properties
Summary

The properties of the RestFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RestFeatureProxy Interface > RestFeatureProxy Properties


RestFeatureProxy.ContainingOccurrence Property

RestFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RestFeatureProxy Interface > RestFeatureProxy Properties > RestFeatureProxy.ContainingOccurrence Property


RestFeatureProxy.NativeObject Property

RestFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RestFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RestFeatureProxy Interface > RestFeatureProxy Properties > RestFeatureProxy.NativeObject Property


RestFeatures Interface

RestFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RestFeatures collection object provides access to the RestFeature objects.

Class Hierarchy
Inventor::RestFeatures
Visual Basic
Public Interface RestFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.RestFeatures

You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface


RestFeatures Methods

RestFeatures Methods
Summary

The methods of the RestFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified RestFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface > RestFeatures Methods


RestFeatures.Item Method

RestFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified RestFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RestFeature*)
Parameters
Parameters | Description
Index | Input Long or String that specifies the RestFeature object within the collection to return. Inputting a Long indicates the index of the RestFeature within the collection to return. A String can also be used to specify the name of the feature. The property will fail is the index is out of range or the name does not exist.
You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface > RestFeatures Methods > RestFeatures.Item Method


RestFeatures Properties

RestFeatures Properties
Summary

The properties of the RestFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface > RestFeatures Properties


RestFeatures.Application Property

RestFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface > RestFeatures Properties > RestFeatures.Application Property


RestFeatures.Count Property

RestFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface > RestFeatures Properties > RestFeatures.Count Property


RestFeatures.Type Property

RestFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RestFeatures Interface > RestFeatures Properties > RestFeatures.Type Property


RevisionTable Interface

RevisionTable Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This object represent a revision table.

Class Hierarchy
Inventor::RevisionTable
Visual Basic
Public Interface RevisionTable
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RevisionTableCell.Parent

RevisionTableColumn.Parent

RevisionTableRow.Parent

RevisionTables.Add

RevisionTables.Item

Example

"Query revision table"

This sample illustrates querying the contents of the revision table. To run this sample have a sheet active that contains a revision table.

Public Sub RevisionTableQuery()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the first revision table on the active sheet.
    ' This assumes that a revision table is on the active sheet.
    Dim oRevTable As RevisionTable
    Set oRevTable = oDrawDoc.ActiveSheet.RevisionTables.Item(1)

    ' Iterate through the contents of the revision table.
    Dim i As Long
    For i = 1 To oRevTable.RevisionTableRows.Count
        ' Get the current row.
        Dim oRow As RevisionTableRow
        Set oRow = oRevTable.RevisionTableRows.Item(i)

        ' Iterate through each column in the row.
        Dim j As Long
        For j = 1 To oRevTable.RevisionTableColumns.Count
            ' Get the current cell.
            Dim oCell As RevisionTableCell
            Set oCell = oRow.Item(j)

            ' Display the value of the current cell.
            Debug.Print "Row: " & i & ", Column: " & oRevTable.RevisionTableColumns.Item(j).Title & " = "; oCell.Text
        Next
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface


RevisionTable Methods

RevisionTable Methods
Summary

The methods of the RevisionTable class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the RevisionTable.
Export | Method that saves the revision table to an external file.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Sort | Method that changes the sort order of rows in the revision table.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Methods


RevisionTable.Delete Method

RevisionTable.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the RevisionTable.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Methods > RevisionTable.Delete Method


RevisionTable.Export Method

RevisionTable.Export Method Available in Inventor Introduced in Inventor 2012
Summary

Method that saves the revision table to an external file.

Visual Basic
Sub Export(FileName As String, FileFormat As FileFormatEnum, ByRef Options As [optional] VARIANT)
Parameters
Parameters | Description
FileName | Input string that specifies the file name to export the revision table to.
FileFormat | Input FileFormatEnum that specifies the file format to save to.
Options | Optional input NameValueMap object that specifies additional options for export. For valid inputs, see the Remarks sectio.
Remarks

Valid inputs for additional options for export are listed in the table below.

Name | Value Type | Valid for Export Formats
TableName | String | kMicrosoftExcel, kMicrosoftAccess
ExportedColumns | String containing semicolon separated column titles | All
IncludeTitle | Boolean | kMicrosoftExcel, kTextFileCommaDelimited, kTextFileTabDelimited, kUnicodeTextFileCommaDelimited, kUnicodeTextFileTabDelimited
StartingCell | String | kMicrosoftExcel
Template | String | kMicrosoftExcel
AutoFitColumnWidth | Boolean | kMicrosoftExcel
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Methods > RevisionTable.Export Method


RevisionTable.GetReferenceKey Method

RevisionTable.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Methods > RevisionTable.GetReferenceKey Method


RevisionTable.Sort Method

RevisionTable.Sort Method Available in Inventor Introduced in Inventor 2012
Summary

Method that changes the sort order of rows in the revision table.

Visual Basic
Sub Sort(PrimaryColumnTitle As String, ByRef PrimaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef SecondaryColumnTitle As [defaultvalue("")] BSTR, ByRef SecondaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL, ByRef TertiaryColumnTitle As [defaultvalue("")] BSTR, ByRef TertiaryColumnAscending As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
PrimaryColumnTitle | Input string that specifies the primary column to use for the sorting. If the name of a non-existing column is provided, an error occurs.
PrimaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
SecondaryColumnTitle | Optional input string that specifies the secondary column to use for the sorting. If the name of a non-existing column or the primary column is provided, an error occurs.
SecondaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
TertiaryColumnTitle | Optional input string that specifies the tertiary column to use for the sorting. If the name of a non-existing column, the primary column or the secondary column is provided, an error occurs.
TertiaryColumnAscending | Optional input Boolean that specifies whether to sort from the lowest value to the highest or vice versa. If not specified, a default value of True is used indicating that the sorting will be from the lowest value to the highest.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Methods > RevisionTable.Sort Method


RevisionTable Properties

RevisionTable Properties
Summary

The properties of the RevisionTable class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
DataTextStyle | Property that gets and sets the text style used for the contents of the revision table.
HeadingGap | Property that returns the heading gap.
HeadingPlacement | Property that gets and sets the location of the heading.
IsSheetScope | Property that returns whether the scope of the revision table is the entire drawing or the parent sheet.
Layer | Property that gets and sets the layer associated with this object.
MaximumRows | Property that gets and sets the maximum number of rows per section.
NumberOfSections | Property that gets and sets the number of columns to wrap.
Parent | Property that returns the parent object of this RevisionTable.
Position | Property that gets and sets the position of the revision table on the Sheet.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
RevisionTableColumns | Property that returns the RevisionTableColumns collection object.
RevisionTableRows | Property that returns the RevisionTableRows collection object.
Rotation | Property that gets and sets the absolute rotation angle of the revision table in radians.
RowGap | Property that returns the row gap.
RowLineSpacing | Property that gets and sets the spacing between the rows.
ShowTitle | Property that specifies the whether to show the title of the revision table.
Style | Property that gets and sets the style associated with this object.
TableDirection | Property that gets and sets the direction of the table.
Title | Property that gets and sets the title of the RevisionTable.
TitleTextStyle | Property that gets and sets the text style used for the title of the revision table.
Type | Property returning kRevisionTableObject indicating this objects type.
UpdatePropertyToRevisionNumber | Property that gets and sets whether any edits made to the revision number cell in the active row are written back to either the Revision Number iProperty or sheet revision property (depending on the revision table scope).
WrapAutomatically | Property that gets and sets whether to split the table equally.
WrapLeft | Property that gets and sets whether the sections of the revision table are moved to the left or right when the number of rows increase.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties


RevisionTable.Application Property

RevisionTable.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Application Property


RevisionTable.AttributeSets Property

RevisionTable.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.AttributeSets Property


RevisionTable.ColumnHeaderTextStyle Property

RevisionTable.ColumnHeaderTextStyle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.ColumnHeaderTextStyle Property


RevisionTable.DataTextStyle Property

RevisionTable.DataTextStyle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the text style used for the contents of the revision table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.DataTextStyle Property


RevisionTable.HeadingGap Property

RevisionTable.HeadingGap Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the heading gap.

Visual Basic
Property HeadingGap() As double*
Remarks

This value is obtained from the revision table style.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.HeadingGap Property


RevisionTable.HeadingPlacement Property

RevisionTable.HeadingPlacement Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the location of the heading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
Remarks

Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.HeadingPlacement Property


RevisionTable.IsSheetScope Property

RevisionTable.IsSheetScope Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns whether the scope of the revision table is the entire drawing or the parent sheet.

Visual Basic
Property IsSheetScope() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.IsSheetScope Property


RevisionTable.Layer Property

RevisionTable.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Layer Property


RevisionTable.MaximumRows Property

RevisionTable.MaximumRows Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the maximum number of rows per section.

Visual Basic
Property MaximumRows() As long
Remarks

Setting this property automatically toggles the WrapAutomatically property to True.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.MaximumRows Property


RevisionTable.NumberOfSections Property

RevisionTable.NumberOfSections Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the number of columns to wrap.

Visual Basic
Property NumberOfSections() As long
Remarks

Setting this property automatically toggles the WrapAutomatically property to True.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.NumberOfSections Property


RevisionTable.Parent Property

RevisionTable.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent object of this RevisionTable.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Parent Property


RevisionTable.Position Property

RevisionTable.Position Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the position of the revision table on the Sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Position Property


RevisionTable.RangeBox Property

RevisionTable.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d **
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.RangeBox Property


RevisionTable.RevisionTableColumns Property

RevisionTable.RevisionTableColumns Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the RevisionTableColumns collection object.

Visual Basic
Property RevisionTableColumns() As RevisionTableColumns**
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.RevisionTableColumns Property


RevisionTable.RevisionTableRows Property

RevisionTable.RevisionTableRows Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the RevisionTableRows collection object.

Visual Basic
Property RevisionTableRows() As RevisionTableRows**
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.RevisionTableRows Property


RevisionTable.Rotation Property

RevisionTable.Rotation Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the absolute rotation angle of the revision table in radians.

Visual Basic
Property Rotation() As double
Remarks

The value can either be positive (counter-clockwise rotation) or negative (clockwise rotation). The rotation is limited to 90 degree increments, so valid values for this argument are 0, ±pi/2, ±pi, and ±1.5pi.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Rotation Property


RevisionTable.RowGap Property

RevisionTable.RowGap Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the row gap.

Visual Basic
Property RowGap() As double*
Remarks

This value is obtained from the revision table style.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.RowGap Property


RevisionTable.RowLineSpacing Property

RevisionTable.RowLineSpacing Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the spacing between the rows.

Visual Basic
Property RowLineSpacing() As LineSpacingEnum
Remarks

Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.RowLineSpacing Property


RevisionTable.ShowTitle Property

RevisionTable.ShowTitle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the whether to show the title of the revision table.

Visual Basic
Property ShowTitle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.ShowTitle Property


RevisionTable.Style Property

RevisionTable.Style Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the style associated with this object.

Visual Basic
Property Style() As RevisionTableStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Style Property


RevisionTable.TableDirection Property

RevisionTable.TableDirection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the direction of the table.

Visual Basic
Property TableDirection() As TableDirectionEnum
Remarks

Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.TableDirection Property


RevisionTable.Title Property

RevisionTable.Title Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the title of the RevisionTable.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Title Property


RevisionTable.TitleTextStyle Property

RevisionTable.TitleTextStyle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the text style used for the title of the revision table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.TitleTextStyle Property


RevisionTable.Type Property

RevisionTable.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTableObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.Type Property


RevisionTable.UpdatePropertyToRevisionNumber Property

RevisionTable.UpdatePropertyToRevisionNumber Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether any edits made to the revision number cell in the active row are written back to either the Revision Number iProperty or sheet revision property (depending on the revision table scope).

Visual Basic
Property UpdatePropertyToRevisionNumber() As VARIANT_BOOL
Remarks

If set to False, edits made to the revision number in the active row are treated as data source overrides.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.UpdatePropertyToRevisionNumber Property


RevisionTable.WrapAutomatically Property

RevisionTable.WrapAutomatically Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to split the table equally.

Visual Basic
Property WrapAutomatically() As VARIANT_BOOL
Remarks

If set to True, the revision table is split equally.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.WrapAutomatically Property


RevisionTable.WrapLeft Property

RevisionTable.WrapLeft Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the sections of the revision table are moved to the left or right when the number of rows increase.

Visual Basic
Property WrapLeft() As VARIANT_BOOL
Remarks

A value of True indicates that sections are moved to the left.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTable Interface > RevisionTable Properties > RevisionTable.WrapLeft Property


RevisionTableCell Interface

RevisionTableCell Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The RevisionTableCell object represents an individual cell in the revision table.

Class Hierarchy
Inventor::RevisionTableCell
Visual Basic
Public Interface RevisionTableCell
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RevisionTableRow.Item

See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface


RevisionTableCell Properties

RevisionTableCell Properties
Summary

The properties of the RevisionTableCell class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
Parent | Property that returns the parent RevisionTable object.
StackedTextPosition | Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.
Text | Property that gets and sets the text of the cell.
Type | Property returning kRevisionTableCellObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties


RevisionTableCell.Application Property

RevisionTableCell.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties > RevisionTableCell.Application Property


RevisionTableCell.FormattedText Property

RevisionTableCell.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties > RevisionTableCell.FormattedText Property


RevisionTableCell.Parent Property

RevisionTableCell.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent RevisionTable object.

Visual Basic
Property Parent() As RevisionTable**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties > RevisionTableCell.Parent Property


RevisionTableCell.StackedTextPosition Property

RevisionTableCell.StackedTextPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.

Visual Basic
Property StackedTextPosition() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties > RevisionTableCell.StackedTextPosition Property


RevisionTableCell.Text Property

RevisionTableCell.Text Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the text of the cell.

Visual Basic
Property Text() As String
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties > RevisionTableCell.Text Property


RevisionTableCell.Type Property

RevisionTableCell.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTableCellObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableCell Interface > RevisionTableCell Properties > RevisionTableCell.Type Property


RevisionTableColumn Interface

RevisionTableColumn Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This object represent a column in the revision table.

Class Hierarchy
Inventor::RevisionTableColumn
Visual Basic
Public Interface RevisionTableColumn
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RevisionTableColumns.Item

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface


RevisionTableColumn Methods

RevisionTableColumn Methods
Summary

The methods of the RevisionTableColumn class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the RevisionTable.
GetFilePropertyId | Method that returns the id of the property associated with the column.
Reposition | Method that repositions the column within the revision table.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Methods


RevisionTableColumn.Delete Method

RevisionTableColumn.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes the RevisionTable.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Methods > RevisionTableColumn.Delete Method


RevisionTableColumn.GetFilePropertyId Method

RevisionTableColumn.GetFilePropertyId Method Available in Inventor Introduced in Inventor 2012
Summary

Method that returns the id of the property associated with the column.

Visual Basic
Sub GetFilePropertyId(ByRef PropertySetId As String, ByRef PropId As long)
Parameters
Parameters | Description
PropertySetId | Output String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set.
PropId | Output Long that specifies the property id. This value is unique within the specified property set.
Remarks

This method will return an error if the PropertyType property does not return a value of kRevisionTableFileProperty.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Methods > RevisionTableColumn.GetFilePropertyId Method


RevisionTableColumn.Reposition Method

RevisionTableColumn.Reposition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that repositions the column within the revision table.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing column next to which the column will be inserted. The valid range of values is 0 to the number of existing columns in the table. The position remains unchanged if the index of the column being moved is specified. A value of 0 will put the column at the end. If not specified, a default value of 0 is used, indicating that the column will be moved to the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used indicating that the column will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Methods > RevisionTableColumn.Reposition Method


RevisionTableColumn Properties

RevisionTableColumn Properties
Summary

The properties of the RevisionTableColumn class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CustomPropertyName | Property that returns the name of the custom property associated with this column.
Parent | Property that returns the parent RevisionTable.
PropertyType | Property that returns the property type associated with this column.
Title | Property that gets and sets the title of the RevisionTable.
TitleHorizontalJustification | Specifies the horizontal justification of the column title.
Type | Property returning kRevisionTableColumnObject indicating this objects type.
ValueHorizontalJustification | Specifies the horizontal justification of the column values.
Width | Property that indicates the width of the column.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties


RevisionTableColumn.Application Property

RevisionTableColumn.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.Application Property


RevisionTableColumn.CustomPropertyName Property

RevisionTableColumn.CustomPropertyName Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the name of the custom property associated with this column.

Visual Basic
Property CustomPropertyName() As BSTR*
Remarks

This method will return an error if the PropertyType property does not return a value of kRevisionTableCustomProperty.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.CustomPropertyName Property


RevisionTableColumn.Parent Property

RevisionTableColumn.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent RevisionTable.

Visual Basic
Property Parent() As RevisionTable**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.Parent Property


RevisionTableColumn.PropertyType Property

RevisionTableColumn.PropertyType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the property type associated with this column.

Visual Basic
Property PropertyType() As RevisionTablePropertyEnum*
Remarks

If this property returns kRevisionTableFileProperty, the GetFilePropertyId method returns the identity of the file property. If this property returns kRevisionTableCustomProperty, use the CustomPropertyName property to get the name of the custom property.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.PropertyType Property


RevisionTableColumn.Title Property

RevisionTableColumn.Title Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the title of the RevisionTable.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.Title Property


RevisionTableColumn.TitleHorizontalJustification Property

RevisionTableColumn.TitleHorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Specifies the horizontal justification of the column title.

Visual Basic
Property TitleHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.TitleHorizontalJustification Property


RevisionTableColumn.Type Property

RevisionTableColumn.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTableColumnObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.Type Property


RevisionTableColumn.ValueHorizontalJustification Property

RevisionTableColumn.ValueHorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Specifies the horizontal justification of the column values.

Visual Basic
Property ValueHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.ValueHorizontalJustification Property


RevisionTableColumn.Width Property

RevisionTableColumn.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates the width of the column.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumn Interface > RevisionTableColumn Properties > RevisionTableColumn.Width Property


RevisionTableColumns Interface

RevisionTableColumns Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This collection object represents the column objects in a revision table.

Class Hierarchy
Inventor::RevisionTableColumns
Visual Basic
Public Interface RevisionTableColumns
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RevisionTable.RevisionTableColumns

See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface


RevisionTableColumns Methods

RevisionTableColumns Methods
Summary

The methods of the RevisionTableColumns class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new revision table column based on a property.
Item | Property that returns the specified Column object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Methods


RevisionTableColumns.Add Method

RevisionTableColumns.Add Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new revision table column based on a property.

Visual Basic
Sub Add(PropertyType As RevisionTablePropertyEnum, ByRef PropertySetId As [defaultvalue("")] BSTR, ByRef PropertyIdentifier As [optional] VARIANT, ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] RevisionTableColumn*)
Parameters
Parameters | Description
PropertyType | Input RevisionTablePropertyEnum that specifies the property type to associate with the column. Valid values are kRevisionTableFileProperty, kRevisionTableCustomProperty, kRevisionTableDateProperty, kRevisionTableSheetProperty, kRevisionTableZoneProperty, kRevisionTableZoneSheetPropertyand kRevisionTableLtrProperty. If kRevisionTableFileProperty is specified, the PropertySetId and PropertyIdentifier arguments are required. If kRevisionTableCustomProperty is specified, the PropertyIdentifier argument is required.
PropertySetId | Optional input String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set. This argument is ignored if the input PropertyType is not kRevisionTableFileProperty.
PropertyIdentifier | Optional input Variant that identifies a property. This could either be a Long value that specifies the PropId of a property within the specified property set or the name of a property. Typically, a PropId should be specified when the input PropertyType is kRevisionTableFileProperty and a name should be specified when the input PropertyType is kRevisionTableCustomProperty.
TargetIndex | Optional input Long that specifies the existing column next to which the new column will be inserted. The valid range of values is 0 to the number of existing columns in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the column will be added at the end.
InsertBefore | Optional input Boolean indicating if the column should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
Remarks

The newly created RevisionTableColumn is returned.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Methods > RevisionTableColumns.Add Method


RevisionTableColumns.Item Method

RevisionTableColumns.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Column object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RevisionTableColumn*)
Parameters
Parameters | Description
index | Input Variant value that specifies the RevisionTableColumn to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string that corresponds to the title of a column header. If an out of range index or a name of a non-existent RevisionTableColumn is provided, an error will occur.
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Methods > RevisionTableColumns.Item Method


RevisionTableColumns Properties

RevisionTableColumns Properties
Summary

The properties of the RevisionTableColumns class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kRevisionTableColumnsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Properties


RevisionTableColumns.Application Property

RevisionTableColumns.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Properties > RevisionTableColumns.Application Property


RevisionTableColumns.Count Property

RevisionTableColumns.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Properties > RevisionTableColumns.Count Property


RevisionTableColumns.Type Property

RevisionTableColumns.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTableColumnsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableColumns Interface > RevisionTableColumns Properties > RevisionTableColumns.Type Property


RevisionTableRow Interface

RevisionTableRow Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This object represents a row in the revision table.

Class Hierarchy
Inventor::RevisionTableRow
Visual Basic
Public Interface RevisionTableRow
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RevisionTableRows.Add

RevisionTableRows.Item

See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface


RevisionTableRow Methods

RevisionTableRow Methods
Summary

The methods of the RevisionTableRow class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the RevisionTableRow and any associated revision tags.
Item | Property that returns the specified Cell object from the collection.
Reposition | Method that repositions the row within the revision table.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Methods


RevisionTableRow.Delete Method

RevisionTableRow.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that deletes the RevisionTableRow and any associated revision tags.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Methods > RevisionTableRow.Delete Method


RevisionTableRow.Item Method

RevisionTableRow.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified Cell object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RevisionTableCell*)
Parameters
Parameters | Description
index | Input Variant value that specifies the RevisionTableCell to return. This can be either a numeric value indicating the index of the item in the collection, a string indicating the title of a column header, or a RevisionTableColumn object. If an out of range index, a non-existent column header title, or an invalid RevisionTableColumn object is specified, an error occurs.
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Methods > RevisionTableRow.Item Method


RevisionTableRow.Reposition Method

RevisionTableRow.Reposition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that repositions the row within the revision table.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing row next to which the row will be inserted. The valid range of values is 0 to the number of existing rows in the table. The position remains unchanged if the index of the row being moved is specified. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the row will be moved to the end.
InsertBefore | Optional input Boolean indicating if the row should be inserted before or after the target index. If not specified, a default value of True is used indicating that the row will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Methods > RevisionTableRow.Reposition Method


RevisionTableRow Properties

RevisionTableRow Properties
Summary

The properties of the RevisionTableRow class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Custom | Property that returns whether this is a custom row.
Height | Property that gets and sets the height of the row.
IsActiveRow | Property that gets and sets whether this is the active row of the revision table.
Parent | Property that returns the parent RevisionTable.
Type | Property returning kRevisionTableRowObject indicating this objects type.
Visible | Property that gets and sets whether the row is visible.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties


RevisionTableRow.Application Property

RevisionTableRow.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Application Property


RevisionTableRow.Count Property

RevisionTableRow.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Count Property


RevisionTableRow.Custom Property

RevisionTableRow.Custom Property
Summary

Property that returns whether this is a custom row.

Visual Basic
Property Custom() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Custom Property


RevisionTableRow.Height Property

RevisionTableRow.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the height of the row.

Visual Basic
Property Height() As double
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Height Property


RevisionTableRow.IsActiveRow Property

RevisionTableRow.IsActiveRow Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets whether this is the active row of the revision table.

Visual Basic
Property IsActiveRow() As VARIANT_BOOL
Remarks

The active row is the most recently added row and cannot be deleted. This property cannot be set to False.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.IsActiveRow Property


RevisionTableRow.Parent Property

RevisionTableRow.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the parent RevisionTable.

Visual Basic
Property Parent() As RevisionTable**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Parent Property


RevisionTableRow.Type Property

RevisionTableRow.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTableRowObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Type Property


RevisionTableRow.Visible Property

RevisionTableRow.Visible Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the row is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRow Interface > RevisionTableRow Properties > RevisionTableRow.Visible Property


RevisionTableRows Interface

RevisionTableRows Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This collection object represents row objects in the revision table.

Class Hierarchy
Inventor::RevisionTableRows
Visual Basic
Public Interface RevisionTableRows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

RevisionTable.RevisionTableRows

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface


RevisionTableRows Methods

RevisionTableRows Methods
Summary

The methods of the RevisionTableRows class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new RevisionTableRow. The new created RevisionTableRow is returned.
AddCustom | Method that creates a new custom RevisionTableRow.
Item | Property that returns the specified row object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Methods


RevisionTableRows.Add Method

RevisionTableRows.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new RevisionTableRow. The new created RevisionTableRow is returned.

Visual Basic
Sub Add(Result As [out, retval] RevisionTableRow*)
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Methods > RevisionTableRows.Add Method


RevisionTableRows.AddCustom Method

RevisionTableRows.AddCustom Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new custom RevisionTableRow.

Visual Basic
Sub AddCustom(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] RevisionTableRow*)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing row next to which the new row will be inserted. The valid range of values is 0 to the number of existing rows in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the row will be added at the end.
InsertBefore | Optional input Boolean indicating if the row should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
Remarks

The newly created RevisionTableRow is returned.

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Methods > RevisionTableRows.AddCustom Method


RevisionTableRows.Item Method

RevisionTableRows.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified row object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] RevisionTableRow*)
Parameters
Parameters | Description
index | Input Long value that specifies the RevisionTableRow to return. This is a numeric value indicating the index of the item in the collection. If an out of range index is input, an error occurs.
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Methods > RevisionTableRows.Item Method


RevisionTableRows Properties

RevisionTableRows Properties
Summary

The properties of the RevisionTableRows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kRevisionTableRowsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Properties


RevisionTableRows.Application Property

RevisionTableRows.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Properties > RevisionTableRows.Application Property


RevisionTableRows.Count Property

RevisionTableRows.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Properties > RevisionTableRows.Count Property


RevisionTableRows.Type Property

RevisionTableRows.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTableRowsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableRows Interface > RevisionTableRows Properties > RevisionTableRows.Type Property


RevisionTables Interface

RevisionTables Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The RevisionTables collection object represents all the revision history tables on a sheet and provides methods to create additional tables.

Class Hierarchy
Inventor::RevisionTables
Visual Basic
Public Interface RevisionTables
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.RevisionTables

You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface


RevisionTables Methods

RevisionTables Methods
Summary

The methods of the RevisionTables class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new RevisionTable. The new created RevisionTable is returned.
Add2 | Method that creates a new RevisionTable. The newly created RevisionTable is returned.
Item | Property that returns the specified RevisionTable object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Methods


RevisionTables.Add Method

RevisionTables.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new RevisionTable. The new created RevisionTable is returned.

Visual Basic
Sub Add(PlacementPoint As Point2d, Result As [out, retval] RevisionTable*)
Parameters
Parameters | Description
PlacementPoint | Input Point2d object that specifies the placement point of the revision table on the sheet.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Methods > RevisionTables.Add Method


RevisionTables.Add2 Method

RevisionTables.Add2 Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new RevisionTable. The newly created RevisionTable is returned.

Visual Basic
Sub Add2(PlacementPoint As Point2d, ByRef IsSheetScope As [defaultvalue(0)] VARIANT_BOOL, ByRef AutoIndex As [defaultvalue(-1)] VARIANT_BOOL, ByRef AlphaIndex As [defaultvalue(0)] VARIANT_BOOL, ByRef StartValue As [defaultvalue("")] BSTR, ByRef RevisionTableStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] RevisionTable*)
Parameters
Parameters | Description
PlacementPoint | Input Point2d object that specifies the placement point of the revision table on the sheet.
IsSheetScope | Optional input Boolean that specifies the scope of the revision table – False indicates sheet scope and True indicates the entire drawing scope.
AutoIndex | Optional input Boolean that specifies whether to automatically index revision rows. If set to False, the revision cells remain blank. This value is ignored if a revision table of the same scope (drawing or sheet) has already been created.
AlphaIndex | Optional input Boolean that specifies whether the automatic indexing should be alphanumeric or numeric. Numeric by default. This value is ignored if AutoIndex is set to False or a revision table of the same scope (drawing or sheet) has already been created.
StartValue | Optional input String that specifies the initial revision letter or number. This value is ignored if AutoIndex is set to False or a revision table of the same scope (drawing or sheet) has already been created.
RevisionTableStyle | Optional input RevisionTableStyle object that specifies the style to use for the table. If not provided, the default style is used.
Layer | Optional input Layer object that specifies the layer to use for the revision table. If not provided, the default layer is used.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Methods > RevisionTables.Add2 Method


RevisionTables.Item Method

RevisionTables.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified RevisionTable object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RevisionTable*)
Parameters
Parameters | Description
index | Input Variant value that specifies the RevisionTable to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the RevisionTable name. If an out of range index or a name of a non-existent RevisionTable is provided, an error will occur .
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Methods > RevisionTables.Item Method


RevisionTables Properties

RevisionTables Properties
Summary

The properties of the RevisionTables class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kRevisionTablesObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Properties


RevisionTables.Application Property

RevisionTables.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Properties > RevisionTables.Application Property


RevisionTables.Count Property

RevisionTables.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Properties > RevisionTables.Count Property


RevisionTables.Type Property

RevisionTables.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning kRevisionTablesObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTables Interface > RevisionTables Properties > RevisionTables.Type Property


RevisionTableStyle Interface

RevisionTableStyle Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The RevisionTableStyle object represents a revision table style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::RevisionTableStyle
Visual Basic
Public Interface RevisionTableStyle
Inherits Style
Notes

Members through which this object may be accessed include:

ObjectDefaultsStyle.RevisionTableStyle

ObjectDefaultsStyle.RevisionTagStyle

RevisionTable.Style

RevisionTableStylesEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface


RevisionTableStyle Methods

RevisionTableStyle Methods
Summary

The methods of the RevisionTableStyle class are listed here.

Methods
Methods
Name | Description
AddColumn | Method that adds a column to the list of default columns in the style.
RemoveAllColumns | Method that removes all columns from the style.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Methods


RevisionTableStyle.AddColumn Method

RevisionTableStyle.AddColumn Method Introduced in Inventor 2011
Summary

Method that adds a column to the list of default columns in the style.

Visual Basic
Sub AddColumn(PropertyType As RevisionTablePropertyEnum, ByRef PropertySetId As [defaultvalue("")] BSTR, ByRef PropertyIdentifier As [optional] VARIANT, ByRef Title As [defaultvalue("")] BSTR, ByRef Width As [defaultvalue(0)] double, ByRef TitleHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum, ByRef ValueHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum)
Parameters
Parameters | Description
PropertyType | Input RevisionTablePropertyEnum that specifies the property type to associate with the column. Valid values are: kRevisionTableFileProperty, kRevisionTableCustomProperty, kRevisionTableDateProperty, kRevisionTableSheetProperty, kRevisionTableZoneProperty, kRevisionTableZoneSheetProperty and kRevisionTableLtrProperty. If kRevisionTableFileProperty is specified, the PropertySetId and PropertyIdentifier arguments are required. If kRevisionTableCustomProperty is specified, the PropertyIdentifier argument is required.
PropertySetId | Optional input String that specifies the internal name of the property set that contains the property. This is the FMTID associated with the property set. This argument is ignored if the input PropertyType is not kRevisionTableFileProperty.
PropertyIdentifier | Optional input Variant that identifies a property. This could either be a Long value that specifies the PropId of a property within the specified property set or the name of a property. Typically, a PropId should be specified when the input PropertyType is kRevisionTableFileProperty and a name should be specified when the input PropertyType is kRevisionTableCustomProperty.
Title | Optional input String that specifies the column title. If not specified, the property name is used.
Width | Optional input Double that specifies the width of the column. If not specified, the default width value is used. A value of 0 indicates the default width value.
TitleHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column title.
ValueHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column values.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Methods > RevisionTableStyle.AddColumn Method


RevisionTableStyle.RemoveAllColumns Method

RevisionTableStyle.RemoveAllColumns Method
Summary

Method that removes all columns from the style.

Visual Basic
Sub RemoveAllColumns()
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Methods > RevisionTableStyle.RemoveAllColumns Method


RevisionTableStyle Properties

RevisionTableStyle Properties
Summary

The properties of the RevisionTableStyle class are listed here.

Properties
Name | Description
AllowLandingLineForRevisionTags | Property that specifies the whether to add landing to revision tags.
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
DataTextStyle | Property that gets and sets the text style used for the contents of the table.
HeadingGap | Property that gets and sets the heading gap in centimeters.
HeadingPlacement | Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
InsideLineColor | Property that gets and sets the color of the inner lines of the table.
InsideLineWeight | Property that gets and sets the line weight of the inner lines of the table.
OutsideLineColor | Property that gets and sets the color of the outer lines of the table.
OutsideLineWeight | Property that gets and sets the line weight of the outer lines of the table.
RevisionTagLeaderStyle | Property that gets and sets the leader style used for revision tags.
RevisionTagShape | Property that gets and sets the shape for revision tags. Possible values are kCircularRevisionTag, kHexagonRevisionTag, kSquareRevisionTag and kTriangularRevisionTag.
RevisionTagTextStyle | Property that gets and sets the text style used for revision tags.
RowGap | Property that gets and sets the row gap in centimeters.
RowLineSpacing | Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.
ShowTitle | Property that specifies the whether to show the title of the table.
TableDirection | Property that gets and sets the direction of the table. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.
Title | Property that gets and sets the title of the table.
TitleTextStyle | Property that gets and sets the text style used for the title of the table.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties


RevisionTableStyle.AllowLandingLineForRevisionTags Property

RevisionTableStyle.AllowLandingLineForRevisionTags Property Introduced in Inventor 2011
Summary

Property that specifies the whether to add landing to revision tags.

Visual Basic
Property AllowLandingLineForRevisionTags() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.AllowLandingLineForRevisionTags Property


RevisionTableStyle.ColumnHeaderTextStyle Property

RevisionTableStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.ColumnHeaderTextStyle Property


RevisionTableStyle.DataTextStyle Property

RevisionTableStyle.DataTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.DataTextStyle Property


RevisionTableStyle.HeadingGap Property

RevisionTableStyle.HeadingGap Property Introduced in Inventor 2011
Summary

Property that gets and sets the heading gap in centimeters.

Visual Basic
Property HeadingGap() As double
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.HeadingGap Property


RevisionTableStyle.HeadingPlacement Property

RevisionTableStyle.HeadingPlacement Property Introduced in Inventor 2011
Summary

Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.HeadingPlacement Property


RevisionTableStyle.InsideLineColor Property

RevisionTableStyle.InsideLineColor Property Introduced in Inventor 2011
Summary

Property that gets and sets the color of the inner lines of the table.

Visual Basic
Property InsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.InsideLineColor Property


RevisionTableStyle.InsideLineWeight Property

RevisionTableStyle.InsideLineWeight Property Introduced in Inventor 2011
Summary

Property that gets and sets the line weight of the inner lines of the table.

Visual Basic
Property InsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.InsideLineWeight Property


RevisionTableStyle.OutsideLineColor Property

RevisionTableStyle.OutsideLineColor Property Introduced in Inventor 2011
Summary

Property that gets and sets the color of the outer lines of the table.

Visual Basic
Property OutsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.OutsideLineColor Property


RevisionTableStyle.OutsideLineWeight Property

RevisionTableStyle.OutsideLineWeight Property Introduced in Inventor 2011
Summary

Property that gets and sets the line weight of the outer lines of the table.

Visual Basic
Property OutsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.OutsideLineWeight Property


RevisionTableStyle.RevisionTagLeaderStyle Property

RevisionTableStyle.RevisionTagLeaderStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the leader style used for revision tags.

Visual Basic
Property RevisionTagLeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.RevisionTagLeaderStyle Property


RevisionTableStyle.RevisionTagShape Property

RevisionTableStyle.RevisionTagShape Property Introduced in Inventor 2011
Summary

Property that gets and sets the shape for revision tags. Possible values are kCircularRevisionTag, kHexagonRevisionTag, kSquareRevisionTag and kTriangularRevisionTag.

Visual Basic
Property RevisionTagShape() As RevisionTagShapeEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.RevisionTagShape Property


RevisionTableStyle.RevisionTagTextStyle Property

RevisionTableStyle.RevisionTagTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for revision tags.

Visual Basic
Property RevisionTagTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.RevisionTagTextStyle Property


RevisionTableStyle.RowGap Property

RevisionTableStyle.RowGap Property Introduced in Inventor 2011
Summary

Property that gets and sets the row gap in centimeters.

Visual Basic
Property RowGap() As double
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.RowGap Property


RevisionTableStyle.RowLineSpacing Property

RevisionTableStyle.RowLineSpacing Property Introduced in Inventor 2011
Summary

Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.

Visual Basic
Property RowLineSpacing() As LineSpacingEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.RowLineSpacing Property


RevisionTableStyle.ShowTitle Property

RevisionTableStyle.ShowTitle Property Introduced in Inventor 2011
Summary

Property that specifies the whether to show the title of the table.

Visual Basic
Property ShowTitle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.ShowTitle Property


RevisionTableStyle.TableDirection Property

RevisionTableStyle.TableDirection Property Introduced in Inventor 2011
Summary

Property that gets and sets the direction of the table. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.

Visual Basic
Property TableDirection() As TableDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.TableDirection Property


RevisionTableStyle.Title Property

RevisionTableStyle.Title Property Introduced in Inventor 2011
Summary

Property that gets and sets the title of the table.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.Title Property


RevisionTableStyle.TitleTextStyle Property

RevisionTableStyle.TitleTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the title of the table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStyle Interface > RevisionTableStyle Properties > RevisionTableStyle.TitleTextStyle Property


RevisionTableStylesEnumerator Interface

RevisionTableStylesEnumerator Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The RevisionTableStylesEnumerator object provides access to the existing RevisionTableStyle objects.

Class Hierarchy
Inventor::RevisionTableStylesEnumerator
Visual Basic
Public Interface RevisionTableStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.RevisionTableStyles

You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface


RevisionTableStylesEnumerator Methods

RevisionTableStylesEnumerator Methods
Summary

The methods of the RevisionTableStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified RevisionTableStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Methods


RevisionTableStylesEnumerator.Item Method

RevisionTableStylesEnumerator.Item Method Introduced in Inventor 2011
Summary

Property that returns the specified RevisionTableStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RevisionTableStyle*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the RevisionTableStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the RevisionTableStyle name. If an out of range index or a name of a non-existent RevisionTableStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Methods > RevisionTableStylesEnumerator.Item Method


RevisionTableStylesEnumerator Properties

RevisionTableStylesEnumerator Properties
Summary

The properties of the RevisionTableStylesEnumerator class are listed here.

Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class RevisionTableStylesEnumerator.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kRevisionTableStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Properties


RevisionTableStylesEnumerator._NewEnum Property

RevisionTableStylesEnumerator._NewEnum Property
Summary

This is _NewEnum, a member of class RevisionTableStylesEnumerator.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Properties > RevisionTableStylesEnumerator._NewEnum Property


RevisionTableStylesEnumerator.Application Property

RevisionTableStylesEnumerator.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Properties > RevisionTableStylesEnumerator.Application Property


RevisionTableStylesEnumerator.Count Property

RevisionTableStylesEnumerator.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Properties > RevisionTableStylesEnumerator.Count Property


RevisionTableStylesEnumerator.Type Property

RevisionTableStylesEnumerator.Type Property Introduced in Inventor 2011
Summary

Property returning kRevisionTableStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevisionTableStylesEnumerator Interface > RevisionTableStylesEnumerator Properties > RevisionTableStylesEnumerator.Type Property


RevolutionAndHeightCoilExtent Interface

RevolutionAndHeightCoilExtent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The RevolutionAndHeightExtent object provides access to the information that defines the variables for a coil feature created using revolution and height values.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::RevolutionAndHeightCoilExtent
Visual Basic
Public Interface RevolutionAndHeightCoilExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > RevolutionAndHeightCoilExtent Interface


RevolutionAndHeightCoilExtent Properties

RevolutionAndHeightCoilExtent Properties
Summary

The properties of the RevolutionAndHeightCoilExtent class are listed here.

Properties
Name | Description
Height | Property that returns the parameter that controls the height of the coil feature.
Revolution | Property that returns the parameter that controls the number of revolutions of the coil feature.
TaperAngle | Property that returns the parameter that controls the taper angle of the coil feature.
You are here: Symbol Reference > Inventor Library > Objects > RevolutionAndHeightCoilExtent Interface > RevolutionAndHeightCoilExtent Properties


RevolutionAndHeightCoilExtent.Height Property

RevolutionAndHeightCoilExtent.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter that controls the height of the coil feature.

Visual Basic
Property Height() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RevolutionAndHeightCoilExtent Interface > RevolutionAndHeightCoilExtent Properties > RevolutionAndHeightCoilExtent.Height Property


RevolutionAndHeightCoilExtent.Revolution Property

RevolutionAndHeightCoilExtent.Revolution Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the number of revolutions of the coil feature.

Visual Basic
Property Revolution() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RevolutionAndHeightCoilExtent Interface > RevolutionAndHeightCoilExtent Properties > RevolutionAndHeightCoilExtent.Revolution Property


RevolutionAndHeightCoilExtent.TaperAngle Property

RevolutionAndHeightCoilExtent.TaperAngle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the taper angle of the coil feature.

Visual Basic
Property TaperAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RevolutionAndHeightCoilExtent Interface > RevolutionAndHeightCoilExtent Properties > RevolutionAndHeightCoilExtent.TaperAngle Property


RevolvedFaceWorkAxisDef Interface

RevolvedFaceWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work axis at the axis of a revolved face.

Class Hierarchy
Inventor::RevolvedFaceWorkAxisDef
Visual Basic
Public Interface RevolvedFaceWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > RevolvedFaceWorkAxisDef Interface


RevolvedFaceWorkAxisDef Properties

RevolvedFaceWorkAxisDef Properties
Summary

The properties of the RevolvedFaceWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Face | Property that returns the used to define the revolved face work axis. This object must be a Face object whose geometry is a revolved surface. Valid surface types include cylinders, cones, and toroids.
Parent | Property returning the parent WorkAxis object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RevolvedFaceWorkAxisDef Interface > RevolvedFaceWorkAxisDef Properties


RevolvedFaceWorkAxisDef.Application Property

RevolvedFaceWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevolvedFaceWorkAxisDef Interface > RevolvedFaceWorkAxisDef Properties > RevolvedFaceWorkAxisDef.Application Property


RevolvedFaceWorkAxisDef.Face Property

RevolvedFaceWorkAxisDef.Face Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the used to define the revolved face work axis. This object must be a Face object whose geometry is a revolved surface. Valid surface types include cylinders, cones, and toroids.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > RevolvedFaceWorkAxisDef Interface > RevolvedFaceWorkAxisDef Properties > RevolvedFaceWorkAxisDef.Face Property


RevolvedFaceWorkAxisDef.Parent Property

RevolvedFaceWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > RevolvedFaceWorkAxisDef Interface > RevolvedFaceWorkAxisDef Properties > RevolvedFaceWorkAxisDef.Parent Property


RevolvedFaceWorkAxisDef.Type Property

RevolvedFaceWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevolvedFaceWorkAxisDef Interface > RevolvedFaceWorkAxisDef Properties > RevolvedFaceWorkAxisDef.Type Property


RevolveFeature Interface

RevolveFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RevolveFeature object represents revolved modeling features. The properties and methods listed below are in addition to those supported by the Feature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RevolveFeature
        Inventor::RevolveFeatureProxy
Visual Basic
Public Interface RevolveFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RevolveFeatureProxy.NativeObject

RevolveFeatures.AddByAngle

RevolveFeatures.AddByFromToExtent

RevolveFeatures.AddByToFaceExtent

RevolveFeatures.AddByToNextExtent

RevolveFeatures.AddFull

RevolveFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface


RevolveFeature Methods

RevolveFeature Methods
Summary

The methods of the RevolveFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Method that adds the specified participant to the assembly feature. This method fails for features in a part.
SetAngleExtent | Method that changes the extents of the revolution to the given angle
SetFromToExtent | Method that changes the extents to be 'from and to face' extents.
SetFullExtent | Method that changes the angle of the revolve to a full (360-degree) revolution.
SetToFaceExtent | Method that changes the extents to be 'to face' extents.
SetToNextExtent | Method that changes the extents to be 'to next face' extents.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods


RevolveFeature.AddParticipant Method

RevolveFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that adds the specified participant to the assembly feature. This method fails for features in a part.

Visual Basic
Sub AddParticipant(Occurrence As ComponentOccurrence)
Parameters
Parameters | Description
Occurrence | ComponentOccurrence object that specifies the participant to be added. An error occurs if the input ComponentOccurrence is not a leaf occurrence.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods > RevolveFeature.AddParticipant Method


RevolveFeature.SetAngleExtent Method

RevolveFeature.SetAngleExtent Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that changes the extents of the revolution to the given angle

Visual Basic
Sub SetAngleExtent(Angle As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
Angle | Defines the sweep angle of the revolution. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
ExtentDirection | constant that indicates the direction of the sweep. Valid input is kPositive, kNegative, or kSymmetric. The sweep direction is defined relative to the natural direction of the axis entity. kPositive defines the sweep to be in a positive direction using the right-hand rule about the axis.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods > RevolveFeature.SetAngleExtent Method


RevolveFeature.SetFromToExtent Method

RevolveFeature.SetFromToExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that changes the extents to be 'from and to face' extents.

Visual Basic
Sub SetFromToExtent(FromFace As IDispatch, ExtendFromFace As VARIANT_BOOL, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, ExtentDirection As PartFeatureExtentDirectionEnum, MinimumSolution As VARIANT_BOOL)
Parameters
Parameters | Description
FromFace | Input Object that defines the 'from face'. This can be either a Face or WorkPlane object.
ExtendFromFace | Input Boolean that defines whether the 'from face' should be extended to contain the extents of the profile.
ToFace | Input Object that defines the 'to face'. This can be either a Face or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
MinimumSolution | Input Boolean that defines whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods > RevolveFeature.SetFromToExtent Method


RevolveFeature.SetFullExtent Method

RevolveFeature.SetFullExtent Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that changes the angle of the revolve to a full (360-degree) revolution.

Visual Basic
Sub SetFullExtent()
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods > RevolveFeature.SetFullExtent Method


RevolveFeature.SetToFaceExtent Method

RevolveFeature.SetToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that changes the extents to be 'to face' extents.

Visual Basic
Sub SetToFaceExtent(ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, ExtentDirection As PartFeatureExtentDirectionEnum, MinimumSolution As VARIANT_BOOL)
Parameters
Parameters | Description
ToFace | Input Object that defines the 'to face'. This can be either a Face or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
MinimumSolution | Input Boolean that defines whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods > RevolveFeature.SetToFaceExtent Method


RevolveFeature.SetToNextExtent Method

RevolveFeature.SetToNextExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that changes the extents to be 'to next face' extents.

Visual Basic
Sub SetToNextExtent(ExtentDirection As PartFeatureExtentDirectionEnum, Terminator As SurfaceBody)
Parameters
Parameters | Description
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
Terminator | Input SurfaceBody object that specifies the solid or the surface on which to terminate the revolution.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Methods > RevolveFeature.SetToNextExtent Method


RevolveFeature Properties

RevolveFeature Properties
Summary

The properties of the RevolveFeature class are listed here.

Properties
Name | Description
AxisEntity | Property that gets and sets the entity used to define the axis of revolution. This can be a sketch line that is in the same sketch the profile was derived from or a WorkAxis. If a WorkAxis is specified, it is projected onto the sketch as a SketchLine. This property always returns a SketchLine object.
EndFaces | Property that returns the set of that cap one end of the revolution that are coincident with the sketch plane. The end faces are those not coincident to the sketch plane of the feature's profile. In the case of a symmetric revolution these faces are the ones on the negative normal side of the sketch plane. In the cases where there aren't any end faces this property will return Nothing.
Extent | Property that returns the object that defines how the extent of the feature is defined. The type of extent object that this property will return can be determined by using the ExtentType property.
ExtentTwo | Property that returns the PartFeatureExtent object that defines how the second direction extent of the feature is defined. The type of extent object returned can be determined by using the ExtentTwoType property. This property returns Nothing if the IsTwoDirectional property returns False.
ExtentTwoType | Property that returns an enum indicating how the second direction extent of the feature is defined. This indicates the type of object returned by the Extent property. This property returns a failure if the IsTwoDirectional property returns False.
ExtentType | Property that returns an enum indicating how the extent of the feature is defined. This indicates the type of object returned by the Extent property. The valid possibilities returned are kAngleExtent and kFullSweepExtent.
IsTwoDirectional | Property that returns whether extents have been defined in two directions for the revolve. If this property returns True, the ExtentTwoType and ExtentTwo properties can be used to query details about the second direction extent.
Operation | Property that gets and sets the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.
Profile | Property that gets and sets the profile that defines the shape of the extrusion.
SideFaces | Property that returns a object that provides access to all of the faces created around the perimeter of the feature.
StartFaces | Property that returns the set of that cap one end of the revolution that are coincident with the sketch plane. In the case of a symmetric revolution these faces are the ones on the positive normal side of the sketch plane. In the cases where there aren't any start faces this property will return Nothing.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties


RevolveFeature.AxisEntity Property

RevolveFeature.AxisEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the entity used to define the axis of revolution. This can be a sketch line that is in the same sketch the profile was derived from or a WorkAxis. If a WorkAxis is specified, it is projected onto the sketch as a SketchLine. This property always returns a SketchLine object.

Visual Basic
Property AxisEntity() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.AxisEntity Property


RevolveFeature.EndFaces Property

RevolveFeature.EndFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of that cap one end of the revolution that are coincident with the sketch plane. The end faces are those not coincident to the sketch plane of the feature's profile. In the case of a symmetric revolution these faces are the ones on the negative normal side of the sketch plane. In the cases where there aren't any end faces this property will return Nothing.

Visual Basic
Property EndFaces() As Faces**
See Also

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.EndFaces Property


RevolveFeature.Extent Property

RevolveFeature.Extent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object that defines how the extent of the feature is defined. The type of extent object that this property will return can be determined by using the ExtentType property.

Visual Basic
Property Extent() As PartFeatureExtent**
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.Extent Property


RevolveFeature.ExtentTwo Property

RevolveFeature.ExtentTwo Property
Summary

Property that returns the PartFeatureExtent object that defines how the second direction extent of the feature is defined. The type of extent object returned can be determined by using the ExtentTwoType property. This property returns Nothing if the IsTwoDirectional property returns False.

Visual Basic
Property ExtentTwo() As PartFeatureExtent**
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.ExtentTwo Property


RevolveFeature.ExtentTwoType Property

RevolveFeature.ExtentTwoType Property
Summary

Property that returns an enum indicating how the second direction extent of the feature is defined. This indicates the type of object returned by the Extent property. This property returns a failure if the IsTwoDirectional property returns False.

Visual Basic
Property ExtentTwoType() As PartFeatureExtentEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.ExtentTwoType Property


RevolveFeature.ExtentType Property

RevolveFeature.ExtentType Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an enum indicating how the extent of the feature is defined. This indicates the type of object returned by the Extent property. The valid possibilities returned are kAngleExtent and kFullSweepExtent.

Visual Basic
Property ExtentType() As PartFeatureExtentEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.ExtentType Property


RevolveFeature.IsTwoDirectional Property

RevolveFeature.IsTwoDirectional Property
Summary

Property that returns whether extents have been defined in two directions for the revolve. If this property returns True, the ExtentTwoType and ExtentTwo properties can be used to query details about the second direction extent.

Visual Basic
Property IsTwoDirectional() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.IsTwoDirectional Property


RevolveFeature.Operation Property

RevolveFeature.Operation Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.Operation Property


RevolveFeature.Profile Property

RevolveFeature.Profile Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the profile that defines the shape of the extrusion.

Visual Basic
Property Profile() As Profile*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.Profile Property


RevolveFeature.SideFaces Property

RevolveFeature.SideFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a object that provides access to all of the faces created around the perimeter of the feature.

Visual Basic
Property SideFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.SideFaces Property


RevolveFeature.StartFaces Property

RevolveFeature.StartFaces Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of that cap one end of the revolution that are coincident with the sketch plane. In the case of a symmetric revolution these faces are the ones on the positive normal side of the sketch plane. In the cases where there aren't any start faces this property will return Nothing.

Visual Basic
Property StartFaces() As Faces**
See Also

Highlight Feature Faces sample

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeature Interface > RevolveFeature Properties > RevolveFeature.StartFaces Property


RevolveFeatureProxy Interface

RevolveFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RevolveFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RevolveFeature
        Inventor::RevolveFeatureProxy
Visual Basic
Public Interface RevolveFeatureProxy
Inherits RevolveFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatureProxy Interface


RevolveFeatureProxy Properties

RevolveFeatureProxy Properties
Summary

The properties of the RevolveFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatureProxy Interface > RevolveFeatureProxy Properties


RevolveFeatureProxy.ContainingOccurrence Property

RevolveFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatureProxy Interface > RevolveFeatureProxy Properties > RevolveFeatureProxy.ContainingOccurrence Property


RevolveFeatureProxy.NativeObject Property

RevolveFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RevolveFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatureProxy Interface > RevolveFeatureProxy Properties > RevolveFeatureProxy.NativeObject Property


RevolveFeatures Interface

RevolveFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The RevolveFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional RevolveFeatures.

Class Hierarchy
Inventor::RevolveFeatures
Visual Basic
Public Interface RevolveFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.RevolveFeatures

FlatPatternFeatures.RevolveFeatures

PartFeatures.RevolveFeatures

You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface


RevolveFeatures Methods

RevolveFeatures Methods
Summary

The methods of the RevolveFeatures class are listed here.

Methods
Methods
Name | Description
AddByAngle | Method that creates a new RevolveFeature that sweeps a specified angle. The new RevolveFeature is returned.
AddByFromToExtent | Method that creates a new RevolveFeature using 'from and to face' extents. The new RevolveFeature is returned.
AddByToFaceExtent | Method that creates a new RevolveFeature using 'to face' extents. The new RevolveFeature is returned.
AddByToNextExtent | Method that creates a new RevolveFeature using 'to next' extents. The new RevolveFeature is returned.
AddFull | Method that creates a new RevolveFeature that is a full 360-degree sweep. The new RevolveFeature is returned.
Item | Property that returns the specified RevolveFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods


RevolveFeatures.AddByAngle Method

RevolveFeatures.AddByAngle Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new RevolveFeature that sweeps a specified angle. The new RevolveFeature is returned.

Visual Basic
Sub AddByAngle(Profile As Profile, AxisEntity As IDispatch, Angle As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, Operation As PartFeatureOperationEnum, Result As [out, retval] RevolveFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the revolution. If the AsSolid argument is True, then the input profile must have closed paths. Open paths are valid when creating surfaces.
AxisEntity | Input linear entity that defines the axis of the revolution. This can either be a sketch line in the same sketch that was used to generate the profile or a WorkAxis object.
Angle | Input Variant that defines the sweep angle of the revolution. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude toward. Valid input is kPositive, kNegative, or kSymmetric. kPositive defines the offset direction to be in the same direction as the normal of the sketch plane.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods > RevolveFeatures.AddByAngle Method


RevolveFeatures.AddByFromToExtent Method

RevolveFeatures.AddByFromToExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new RevolveFeature using 'from and to face' extents. The new RevolveFeature is returned.

Visual Basic
Sub AddByFromToExtent(Profile As Profile, AxisEntity As IDispatch, FromFace As IDispatch, ExtendFromFace As VARIANT_BOOL, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, ExtentDirection As PartFeatureExtentDirectionEnum, MinimumSolution As VARIANT_BOOL, Operation As PartFeatureOperationEnum, Result As [out, retval] RevolveFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the revolution. If the Operation argument is anything except kSurfaceOperation, then the input profile must have closed paths. Open paths are valid when creating surfaces.
AxisEntity | Input linear entity that defines the axis of the revolution. This can either be a sketch line in the same sketch that was used to generate the profile or a WorkAxis object.
FromFace | Input Object that defines the 'from face'. This can be either a Face or WorkPlane object.
ExtendFromFace | Input Boolean that defines whether the 'from face' should be extended to contain the extents of the profile.
ToFace | Input Object that defines the 'to face'. This can be either a Face or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
MinimumSolution | Input Boolean that defines whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods > RevolveFeatures.AddByFromToExtent Method


RevolveFeatures.AddByToFaceExtent Method

RevolveFeatures.AddByToFaceExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new RevolveFeature using 'to face' extents. The new RevolveFeature is returned.

Visual Basic
Sub AddByToFaceExtent(Profile As Profile, AxisEntity As IDispatch, ToFace As IDispatch, ExtendToFace As VARIANT_BOOL, ExtentDirection As PartFeatureExtentDirectionEnum, MinimumSolution As VARIANT_BOOL, Operation As PartFeatureOperationEnum, Result As [out, retval] RevolveFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the revolution. If the Operation argument is anything except kSurfaceOperation, then the input profile must have closed paths. Open paths are valid when creating surfaces.
AxisEntity | Input linear entity that defines the axis of the revolution. This can either be a sketch line in the same sketch that was used to generate the profile or a WorkAxis object.
ToFace | Input Object that defines the 'to face'. This can be either a Face or WorkPlane object.
ExtendToFace | Input Boolean that defines whether the 'to face' should be extended to contain the extents of the profile.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
MinimumSolution | Input Boolean that defines whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods > RevolveFeatures.AddByToFaceExtent Method


RevolveFeatures.AddByToNextExtent Method

RevolveFeatures.AddByToNextExtent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new RevolveFeature using 'to next' extents. The new RevolveFeature is returned.

Visual Basic
Sub AddByToNextExtent(Profile As Profile, AxisEntity As IDispatch, ExtentDirection As PartFeatureExtentDirectionEnum, Terminator As SurfaceBody, Operation As PartFeatureOperationEnum, Result As [out, retval] RevolveFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the revolution. If the Operation argument is anything except kSurfaceOperation, then the input profile must have closed paths. Open paths are valid when creating surfaces.
AxisEntity | Input linear entity that defines the axis of the revolution. This can either be a sketch line in the same sketch that was used to generate the profile or a WorkAxis object.
ExtentDirection | Input constant that indicates which side of the sketch plane to extrude towards. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
Terminator | Input SurfaceBody object that specifies the solid or the surface on which to terminate the revolution.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods > RevolveFeatures.AddByToNextExtent Method


RevolveFeatures.AddFull Method

RevolveFeatures.AddFull Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new RevolveFeature that is a full 360-degree sweep. The new RevolveFeature is returned.

Visual Basic
Sub AddFull(Profile As Profile, AxisEntity As IDispatch, Operation As PartFeatureOperationEnum, Result As [out, retval] RevolveFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the revolution. If the AsSolid argument is True, then the input profile must have closed paths. Open paths are valid when creating surfaces.
AxisEntity | Input linear entity that defines the axis of the revolution. This must be a sketch line in the same sketch that was used to generate the profile.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods > RevolveFeatures.AddFull Method


RevolveFeatures.Item Method

RevolveFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified RevolveFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RevolveFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Methods > RevolveFeatures.Item Method


RevolveFeatures Properties

RevolveFeatures Properties
Summary

The properties of the RevolveFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Properties


RevolveFeatures.Application Property

RevolveFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Properties > RevolveFeatures.Application Property


RevolveFeatures.Count Property

RevolveFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Properties > RevolveFeatures.Count Property


RevolveFeatures.Type Property

RevolveFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RevolveFeatures Interface > RevolveFeatures Properties > RevolveFeatures.Type Property


Ribbon Interface

Ribbon Interface Available in Inventor Introduced in Inventor 2010
Summary

The Ribbon object represents the user interface containing a collection of tabs.

Class Hierarchy
Inventor::Ribbon
Visual Basic
Public Interface Ribbon
Inherits IDispatch
Remarks

Please refer to the Ribbon article in the overviews section.

Notes

Members through which this object may be accessed include:

Environment.Ribbon

Ribbons.Item

RibbonTab.Parent

See Also

Creation of an override environment for a document sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface


Ribbon Properties

Ribbon Properties
Summary

The properties of the Ribbon class are listed here.

Properties
Name | Description
Active | Property that returns whether this ribbon is currently being displayed.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
InternalName | Property that returns the internal name of the ribbon.
Parent | Property that returns the parent UserInterfaceManager object.
QuickAccessControls | Property that returns a CommandControls collection containing the controls in the Quick Access Toolbar (QAT).
RibbonTabs | Property that returns the RibbonTabs collection object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties


Ribbon.Active Property

Ribbon.Active Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether this ribbon is currently being displayed.

Visual Basic
Property Active() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.Active Property


Ribbon.Application Property

Ribbon.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.Application Property


Ribbon.InternalName Property

Ribbon.InternalName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the internal name of the ribbon.

Visual Basic
Property InternalName() As BSTR*
See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.InternalName Property


Ribbon.QuickAccessControls Property

Ribbon.QuickAccessControls Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns a CommandControls collection containing the controls in the Quick Access Toolbar (QAT).

Visual Basic
Property QuickAccessControls() As CommandControls**
Remarks

The returned collection object can be used to add/remove controls to/from the QAT.

See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.QuickAccessControls Property


Ribbon.RibbonTabs Property

Ribbon.RibbonTabs Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the RibbonTabs collection object.

Visual Basic
Property RibbonTabs() As RibbonTabs**
See Also

Creation of an override environment for a document sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.RibbonTabs Property


Ribbon.Type Property

Ribbon.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.Type Property


RibbonPanel Interface

RibbonPanel Interface Available in Inventor Introduced in Inventor 2010
Summary

A RibbonPanel object represents a panel within a ribbon tab.

Class Hierarchy
Inventor::RibbonPanel
Visual Basic
Public Interface RibbonPanel
Inherits IDispatch
Remarks

Please refer to the Ribbon article in the overviews section.

Notes

Members through which this object may be accessed include:

RibbonPanels.Add

RibbonPanels.Item

See Also

Creation of an override environment for a document sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface


RibbonPanel Methods

RibbonPanel Methods
Summary

The methods of the RibbonPanel class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the RibbonPanel.
Move | Method that moves the ribbon panel.
Reposition | Method that moves the RibbonPanel to a new location within the ribbon tab.
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Methods


RibbonPanel.Delete Method

RibbonPanel.Delete Method Available in Inventor Introduced in Inventor 2010
Summary

Method that deletes the RibbonPanel.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Methods > RibbonPanel.Delete Method


RibbonPanel.Move Method

RibbonPanel.Move Method Available in Inventor Introduced in Inventor 2012
Summary

Method that moves the ribbon panel.

Visual Basic
Sub Move(Top As long, Left As long)
Parameters
Parameters | Description
Top | Input Long that specifies the distance between the top of the screen and top of the panel.
Left | Input Long that specifies the distance between the left edge of the screen and left edge of the panel.
Remarks

If the panel is docked, calling this method automatically undocks the panel and honors the input values.

You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Methods > RibbonPanel.Move Method


RibbonPanel.Reposition Method

RibbonPanel.Reposition Method Available in Inventor Introduced in Inventor 2010
Summary

Method that moves the RibbonPanel to a new location within the ribbon tab.

Visual Basic
Sub Reposition(TargetPanelInternalName As String, InsertBeforeTargetPanel As VARIANT_BOOL)
Parameters
Parameters | Description
TargetPanelInternalName | Input String that specifies the internal name of an existing panel to reposition the panel next to. The InsertBeforeTargetPanel argument indicates whether to reposition the panel before or after the target panel.
InsertBeforeTargetPanel | Input Boolean that specifies whether to reposition the panel before or after the target ribbon panel.
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Methods > RibbonPanel.Reposition Method


RibbonPanel Properties

RibbonPanel Properties
Summary

The properties of the RibbonPanel class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
CommandControls | Property that returns the CommandControls collection object that provides access to all the visible controls within the panel.
DisplayName | Property that returns the display name of the ribbon panel.
Docked | Property that gets and sets whether the ribbon panel docked within the ribbon.
InternalName | Property that returns the unique internal name of the ribbon panel.
Parent | Property that returns the parent RibbonTab object.
SlideoutControls | Property that returns the CommandControls collection object that provides access to all controls in the slideout section of the panel.
SlideOutKeyTip | Property that gets and sets the keyboard access key for the slideout controls within the panel.
Type | Returns an ObjectTypeEnum indicating this object's type.
Visible | Property that gets and sets whether the ribbon panel is currently visible in the ribbon. Note that this property applies only when the parent ribbon tab and the ribbon within which the tab lives are currently active.
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties


RibbonPanel.Application Property

RibbonPanel.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.Application Property


RibbonPanel.ClientId Property

RibbonPanel.ClientId Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.ClientId Property


RibbonPanel.CommandControls Property

RibbonPanel.CommandControls Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the CommandControls collection object that provides access to all the visible controls within the panel.

Visual Basic
Property CommandControls() As CommandControls**
See Also

Creation of an override environment for a document sample

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.CommandControls Property


RibbonPanel.DisplayName Property

RibbonPanel.DisplayName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the display name of the ribbon panel.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.DisplayName Property


RibbonPanel.Docked Property

RibbonPanel.Docked Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether the ribbon panel docked within the ribbon.

Visual Basic
Property Docked() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.Docked Property


RibbonPanel.InternalName Property

RibbonPanel.InternalName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the unique internal name of the ribbon panel.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.InternalName Property


RibbonPanel.Parent Property

RibbonPanel.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent RibbonTab object.

Visual Basic
Property Parent() As RibbonTab**
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.Parent Property


RibbonPanel.SlideoutControls Property

RibbonPanel.SlideoutControls Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the CommandControls collection object that provides access to all controls in the slideout section of the panel.

Visual Basic
Property SlideoutControls() As CommandControls**
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.SlideoutControls Property


RibbonPanel.SlideOutKeyTip Property

RibbonPanel.SlideOutKeyTip Property
Summary

Property that gets and sets the keyboard access key for the slideout controls within the panel.

Visual Basic
Property SlideOutKeyTip() As String
Remarks

The keytip is not shown if there are no slideout controls defined for the panel. KeyTips appear on the Ribbon when you press the ALT key. A KeyTip must have from 1 to 3 characters, and must not contain spaces, tabs, or newline characters. All characters should be upper case. Make sure that the assigned keytip does not conflict with existing keytips.

You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.SlideOutKeyTip Property


RibbonPanel.Type Property

RibbonPanel.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.Type Property


RibbonPanel.Visible Property

RibbonPanel.Visible Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether the ribbon panel is currently visible in the ribbon. Note that this property applies only when the parent ribbon tab and the ribbon within which the tab lives are currently active.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanel Interface > RibbonPanel Properties > RibbonPanel.Visible Property


RibbonPanels Interface

RibbonPanels Interface Available in Inventor Introduced in Inventor 2010
Summary

The RibbonPanels collection object provides access to all existing panels within a ribbon tab and provides methods to create additional panels.

Class Hierarchy
Inventor::RibbonPanels
Visual Basic
Public Interface RibbonPanels
Inherits IDispatch
Remarks

Please refer to the Ribbon article in the overviews section.

Notes

Members through which this object may be accessed include:

RibbonTab.RibbonPanels

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface


RibbonPanels Methods

RibbonPanels Methods
Summary

The methods of the RibbonPanels class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new RibbonPanel within a ribbon tab. The newly created RibbonPanel is returned.
Item | Property that returns the specified RibbonPanel object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Methods


RibbonPanels.Add Method

RibbonPanels.Add Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new RibbonPanel within a ribbon tab. The newly created RibbonPanel is returned.

Visual Basic
Sub Add(DisplayName As String, InternalName As String, ClientId As String, ByRef TargetPanelInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetPanel As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] RibbonPanel*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the ribbon panel. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the unique internal name of the ribbon panel. This is the internal name and is not displayed to the user. The name must be unique with respect to all other ribbon panels within the tab. The name should remain constant in all locales so it can be used to find a specific panel.
ClientId | Input String that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}". If supplied, this string is used at Inventor start up time to determine whether the AddIn that created this ribbon panel has since been uninstalled. If so, the panel is deleted.The string is also used to find all the panels to delete when the associated Add-in is unloaded. A 'dummy' string or a null string can be specified, but is not recommended.
TargetPanelInternalName | Optional input String that specifies the internal name of an existing panel to position the new panel next to. If specified, the InsertBeforeTargetPanel argument indicates whether to place the new panel before or after the target panel. If not specified, the new panel is positioned at the end.
InsertBeforeTargetPanel | Optional input Boolean that specifies whether to position the new panel before or after the target ribbon panel. The argument defaults to False and is not used if the TargetPanelInternalName argument is not specified.
See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Example 1

This sample demonstrates the creation of a ribbon panel within an existing tab and adding commands to the panel.

Sub AddPanelToToolsTab()

    ' Get the ribbon associated with the part document
    Dim oPartRibbon As Ribbon
    Set oPartRibbon = ThisApplication.UserInterfaceManager.Ribbons.Item("Part")

    ' Get the "Tools" tab
    Dim oTab As RibbonTab
    Set oTab = oPartRibbon.RibbonTabs.Item("id_TabTools")

    ' Create a panel named "Update", positioned after the "Measure" panel in the Tools tab.
    Dim oPanel As RibbonPanel
    Set oPanel = oTab.RibbonPanels.Add("Update", "ToolsTabUpdatePanel", "SampleClientId", "id_PanelP_ToolsMeasure")

    ' Get the update commands
    Dim oDef1 As ButtonDefinition
    Set oDef1 = ThisApplication.CommandManager.ControlDefinitions.Item("AppLocalUpdateCmd")

    Dim oDef2 As ButtonDefinition
    Set oDef2 = ThisApplication.CommandManager.ControlDefinitions.Item("AppUpdateMassPropertiesCmd")

    Dim oDefs As ObjectCollection
    Set oDefs = ThisApplication.TransientObjects.CreateObjectCollection

    oDefs.Add oDef1
    oDefs.Add oDef2

    ' Create a split button control
    Call oPanel.CommandControls.AddSplitButton(oDef1, oDefs, True)

    ' Get the rebuild command
    Dim oDef3 As ButtonDefinition
    Set oDef3 = ThisApplication.CommandManager.ControlDefinitions.Item("AppRebuildAllWrapperCmd")

    ' Create a button control
    Call oPanel.CommandControls.AddButton(oDef3, True)

End Sub
Example 2

See the following pages for samples.

Environment.AdditionalVisibleRibbonTabs

CommandControls.AddButton

EnvironmentManager.OverrideEnvironment

Ribbons

You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Methods > RibbonPanels.Add Method


RibbonPanels.Item Method

RibbonPanels.Item Method Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the specified RibbonPanel object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RibbonPanel*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the RibbonPanel to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the RibbonPanel name. If an out of range index or a name of a non-existent RibbonPanel is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Methods > RibbonPanels.Item Method


RibbonPanels Properties

RibbonPanels Properties
Summary

The properties of the RibbonPanels class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Properties


RibbonPanels.Application Property

RibbonPanels.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Properties > RibbonPanels.Application Property


RibbonPanels.Count Property

RibbonPanels.Count Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Properties > RibbonPanels.Count Property


RibbonPanels.Type Property

RibbonPanels.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RibbonPanels Interface > RibbonPanels Properties > RibbonPanels.Type Property


Ribbons Interface

Ribbons Interface Available in Inventor Introduced in Inventor 2010
Summary

The Ribbons collection object provides access to all existing ribbons in Inventor.

Class Hierarchy
Inventor::Ribbons
Visual Basic
Public Interface Ribbons
Inherits IDispatch
Remarks

The following image indicates the different parts of the ribbon interface.

Please refer to the Ribbon article in the overviews section for more information.

Notes

Members through which this object may be accessed include:

UserInterfaceManager.Ribbons

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

Example 1

This sample will print information about all available ribbons.

Public Sub PrintRibbon()
    Open "C:\temp\RibbonNames.txt" For Output As #1

    Print #1, "File Controls (Application Menu)"
    Call PrintControls(ThisApplication.UserInterfaceManager.FileBrowserControls, "", 1)
    Print #1, "------------------------------------------------------------------"

    Print #1, "Help Controls"
    Call PrintControls(ThisApplication.UserInterfaceManager.HelpControls, "", 1)
    Print #1, "------------------------------------------------------------------"

    Dim oRibbon As Ribbon
    For Each oRibbon In ThisApplication.UserInterfaceManager.Ribbons
        Print #1, "Ribbon: " & oRibbon.InternalName

        Print #1, "    QAT controls"
        Call PrintControls(oRibbon.QuickAccessControls, "            ", 0)

        Dim oTab As RibbonTab
        For Each oTab In oRibbon.RibbonTabs
            Print #1, "    Tab: " & oTab.DisplayName & ", " & oTab.InternalName & ", Visible: " & oTab.Visible

            Dim oPanel As RibbonPanel
            For Each oPanel In oTab.RibbonPanels
                Print #1, "        Panel: " & oPanel.DisplayName & ", " & oPanel.InternalName & ", Visible: " & oPanel.Visible

                Call PrintControls(oPanel.CommandControls, "            ", 0)

                If oPanel.SlideoutControls.Count > 0 Then
                    Print #1, "            --- Slideout Controls ---"
                    Call PrintControls(oPanel.SlideoutControls, "            ", 0)
                End If
            Next
        Next

    Print #1, "------------------------------------------------------------------"
    Next
    On Error GoTo 0

    Close #1

    MsgBox "Result written to: C:\temp\RibbonNames.txt"
End Sub

Private Sub PrintControls(Controls As CommandControls, LeadingSpace As String, Level As Integer)
    Dim oControl As CommandControl
    For Each oControl In Controls
        If oControl.ControlType = kSeparatorControl Then
            Print #1, LeadingSpace & Space(Level * 4) & "Control: Seperator"
        Else
            Print #1, LeadingSpace & Space(Level * 4) & "Control: " & oControl.DisplayName & ", " & oControl.InternalName & ", Visible: " & oControl.Visible

            If Not oControl.ChildControls Is Nothing Then
                Call PrintControls(oControl.ChildControls, LeadingSpace, Level + 1)
            End If
        End If
    Next
End Sub
Example 2

See the following pages for samples.

RibbonPanels.Add

Environment.AdditionalVisibleRibbonTabs

CommandControls.AddButton

EnvironmentManager.OverrideEnvironment

You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface


Ribbons Methods

Ribbons Methods
Summary

The methods of the Ribbons class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified Ribbon object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface > Ribbons Methods


Ribbons.Item Method

Ribbons.Item Method Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the specified Ribbon object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Ribbon*)
Parameters
Parameters
Description
Index
Input Variant value that specifies the Ribbon to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the internal name of the Ribbon. If an out of range index or a name of a non-existent Ribbon is provided, an error will occur.
The following are the names of Inventor Ribbons:

  • 'Part'
  • 'Assembly'
  • 'Drawing'
  • 'Presentation'
  • 'iFeatures'
  • 'ZeroDoc'
  • 'UnknownDocument'

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface > Ribbons Methods > Ribbons.Item Method


Ribbons Properties

Ribbons Properties
Summary

The properties of the Ribbons class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface > Ribbons Properties


Ribbons.Application Property

Ribbons.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface > Ribbons Properties > Ribbons.Application Property


Ribbons.Count Property

Ribbons.Count Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface > Ribbons Properties > Ribbons.Count Property


Ribbons.Type Property

Ribbons.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Ribbons Interface > Ribbons Properties > Ribbons.Type Property


RibbonTab Interface

RibbonTab Interface Available in Inventor Introduced in Inventor 2010
Summary

A RibbonTab object represents a tab within a ribbon.

Class Hierarchy
Inventor::RibbonTab
Visual Basic
Public Interface RibbonTab
Inherits IDispatch
Remarks

Please refer to the Ribbon article in the overviews section.

Notes

Members through which this object may be accessed include:

RibbonPanel.Parent

RibbonTabs.Add

RibbonTabs.Item

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface


RibbonTab Methods

RibbonTab Methods
Summary

The methods of the RibbonTab class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the RibbonTab.
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Methods


RibbonTab.Delete Method

RibbonTab.Delete Method Available in Inventor Introduced in Inventor 2010
Summary

Method that deletes the RibbonTab.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Methods > RibbonTab.Delete Method


RibbonTab Properties

RibbonTab Properties
Summary

The properties of the RibbonTab class are listed here.

Properties
Name | Description
Active | Property that gets and sets whether this tab is currently active. This property can only be set to True, which indicates that the tab should be activated. Setting this property returns an error if the parent ribbon is not active.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ClientId | Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".
Contextual | Property that returns whether this tab is contextual. Contextual tabs, such as the Sketch tab in the Sketch environment, come and go based on the current environment. They are displayed in a different color to indicate to the user that this is not a permanent tab.
DisplayName | Property that returns the display name of the ribbon tab.
InternalName | Property that returns the unique internal name of the ribbon tab.
KeyTip | Property that gets and sets the keyboard access key for the tab. KeyTips appear on the Ribbon when you press the ALT key.
Parent | Property that returns the parent Ribbon object.
RibbonPanels | Property that returns the RibbonPanels collection object.
Type | Property returning kRibbonTabObject indicating this object's type.
Visible | Property that gets and sets whether the ribbon tab is currently visible in the ribbon. Note that this property applies only when the parent ribbon is active.
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties


RibbonTab.Active Property

RibbonTab.Active Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether this tab is currently active. This property can only be set to True, which indicates that the tab should be activated. Setting this property returns an error if the parent ribbon is not active.

Visual Basic
Property Active() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.Active Property


RibbonTab.Application Property

RibbonTab.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.Application Property


RibbonTab.ClientId Property

RibbonTab.ClientId Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the string that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}".

Visual Basic
Property ClientId() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.ClientId Property


RibbonTab.Contextual Property

RibbonTab.Contextual Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns whether this tab is contextual. Contextual tabs, such as the Sketch tab in the Sketch environment, come and go based on the current environment. They are displayed in a different color to indicate to the user that this is not a permanent tab.

Visual Basic
Property Contextual() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.Contextual Property


RibbonTab.DisplayName Property

RibbonTab.DisplayName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the display name of the ribbon tab.

Visual Basic
Property DisplayName() As BSTR*
See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.DisplayName Property


RibbonTab.InternalName Property

RibbonTab.InternalName Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the unique internal name of the ribbon tab.

Visual Basic
Property InternalName() As BSTR*
See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.InternalName Property


RibbonTab.KeyTip Property

RibbonTab.KeyTip Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the keyboard access key for the tab. KeyTips appear on the Ribbon when you press the ALT key.

Visual Basic
Property KeyTip() As String
Remarks

A KeyTip must have from 1 to 3 characters, and must not contain spaces, tabs, or newline characters. All characters should be upper case. Make sure that the assigned keytip does not conflict with existing keytips.

You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.KeyTip Property


RibbonTab.Parent Property

RibbonTab.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent Ribbon object.

Visual Basic
Property Parent() As Ribbon**
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.Parent Property


RibbonTab.RibbonPanels Property

RibbonTab.RibbonPanels Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the RibbonPanels collection object.

Visual Basic
Property RibbonPanels() As RibbonPanels**
See Also

Creation of an override environment for a document sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.RibbonPanels Property


RibbonTab.Type Property

RibbonTab.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning kRibbonTabObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.Type Property


RibbonTab.Visible Property

RibbonTab.Visible Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether the ribbon tab is currently visible in the ribbon. Note that this property applies only when the parent ribbon is active.

Visual Basic
Property Visible() As VARIANT_BOOL
See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTab Interface > RibbonTab Properties > RibbonTab.Visible Property


RibbonTabs Interface

RibbonTabs Interface Available in Inventor Introduced in Inventor 2010
Summary

The RibbonTabs collection object provides access to all existing tabs within a ribbon and provides methods to create additional tabs.

Class Hierarchy
Inventor::RibbonTabs
Visual Basic
Public Interface RibbonTabs
Inherits IDispatch
Remarks

Please refer to the Ribbon article in the overviews section.

Notes

Members through which this object may be accessed include:

Ribbon.RibbonTabs

See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface


RibbonTabs Methods

RibbonTabs Methods
Summary

The methods of the RibbonTabs class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new RibbonTab within a ribbon. The newly created RibbonTab is returned.
Item | Property that returns the specified RibbonTab object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Methods


RibbonTabs.Add Method

RibbonTabs.Add Method Available in Inventor Introduced in Inventor 2010
Summary

Method that creates a new RibbonTab within a ribbon. The newly created RibbonTab is returned.

Visual Basic
Sub Add(DisplayName As String, InternalName As String, ClientId As String, ByRef TargetTabInternalName As [defaultvalue("")] BSTR, ByRef InsertBeforeTargetTab As [defaultvalue(0)] VARIANT_BOOL, ByRef Contextual As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] RibbonTab*)
Parameters
Parameters | Description
DisplayName | Input string that defines the display name of the ribbon tab. This is the name that is displayed to the user and should be localized for different locales.
InternalName | Input string that defines the unique internal name of the ribbon tab. This is the internal name and is not displayed to the user. The name must be unique with respect to all other ribbon tabs. The name should remain constant in all locales so it can be used to find a specific tab.
ClientId | Input String that uniquely identifies the client. This is the CLSID of the AddIn in a string form, e.g. "{C9A6C580-3817-11D0-BE4E-080036E87B02}". If supplied, this string is used at Inventor start up time to determine whether the AddIn that created this ribbon tab has since been uninstalled. If so, the tab is deleted.The string is also used to find all the tabs to delete when the associated Add-in is unloaded. A 'dummy' string or a null string can be specified, but is not recommended.
TargetTabInternalName | Optional input String that specifies the internal name of an existing tab to position the new tab next to. If specified, the InsertBeforeTargetTab argument indicates whether to place the new tab before or after the specified tab. If not specified, the new tab is positioned at the end.
InsertBeforeTargetTab | Optional input Boolean that specifies whether to position the new tab before or after the target ribbon tab. The argument defaults to False and is not used if the TargetTabInternalName argument is not specified.
Contextual | Optional input Boolean that specifies whether this is a contextual tab. Contextual tabs, such as the Sketch tab in the Sketch environment, come and go based on the current environment. They are displayed in a different color to indicate to the user that this is not a permanent tab. If not provided, this argument defaults to False. If a value of False is provided, the tab is added visibly. If a value of True is provided, the tab is added invisibly. Contextual tabs should then be added to the Environment.AdditionalVisibleRibbonTabs so that they show up visible in the appropriate environment(s).
See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Methods > RibbonTabs.Add Method


RibbonTabs.Item Method

RibbonTabs.Item Method Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the specified RibbonTab object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RibbonTab*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the RibbonTab to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the RibbonTab name. If an out of range index or a name of a non-existent RibbonTab is provided, an error will occur.
See Also

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Methods > RibbonTabs.Item Method


RibbonTabs Properties

RibbonTabs Properties
Summary

The properties of the RibbonTabs class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Properties


RibbonTabs.Application Property

RibbonTabs.Application Property Available in Inventor Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Properties > RibbonTabs.Application Property


RibbonTabs.Count Property

RibbonTabs.Count Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Properties > RibbonTabs.Count Property


RibbonTabs.Type Property

RibbonTabs.Type Property Available in Inventor Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RibbonTabs Interface > RibbonTabs Properties > RibbonTabs.Type Property


RibDefinition Interface

RibDefinition Interface Available in Inventor Introduced in Inventor 2012
Summary

The RibDefinition object represents all of the information that defines a Rib feature.

Class Hierarchy
Inventor::RibDefinition
Visual Basic
Public Interface RibDefinition
Inherits IDispatch
Remarks

The RibDefinition object is used in two ways. First, it is used as input when creating a Rib feature. Second, it is used to query and edit existing Rib features.

When creating a new Rib feature you use the RibFeatures.CreateDefinition method to create a new RibDefinition object. Using the properties of this object you can define the various options of the Rib feature. Typically, a new RibDefinition object is created and then modified to get the desired Rib feature and then used as input to the RibFeatures.Add method. An existing RibFeature object is edited by modifying its associated RibDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface


RibDefinition Methods

RibDefinition Methods
Summary

The methods of the RibDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this RibDefinition object.
GetThicknessPlane | Method that gets the plane at which the input thickness is held.
SetFiniteExtent | Method that sets the extent type to be a finite distance.
SetThicknessPlane | Method that sets the plane at which the input thickness should be held.
SetToNextExtent | Method that sets the extent type to be ‘to next’ (i.e. it terminates on the next face).
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Methods


RibDefinition.Copy Method

RibDefinition.Copy Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a copy of this RibDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] RibDefinition*)
Remarks

The new RibDefinition object is independent of any feature. It can be edited and used as input to edit an existing feature or to create a new Rib feature.

One typical use of this method is when you need to make several changes to an existing Rib feature. If you edit the RibDefinition object associated with the Rib feature, the feature will recompute after each edit. It’s more efficient to make a copy, edit the copy, and then assign the copy to the feature. This will result in a single recompute.

The RibFeatures.CreateDefinition method can also be used to create an independent RibDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that’s created with the CreateDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Methods > RibDefinition.Copy Method


RibDefinition.GetThicknessPlane Method

RibDefinition.GetThicknessPlane Method Available in Inventor Introduced in Inventor 2012
Summary

Method that gets the plane at which the input thickness is held.

Visual Basic
Sub GetThicknessPlane(ByRef HoldThicknessAt As RibThicknessPlaneEnum, ByRef NeutralGeometry As IDispatch*)
Parameters
Parameters | Description
HoldThicknessAt | Output RibThicknessPlaneEnum that defines the plane at which the thickness should be held. Valid returns values are kRibThicknessAtSketchPlane, kRibThicknessAtRoot and kRibThicknessAtNeutralGeometry. If kRibThicknessAtNeutralGeometry is returned, the NeutralGeometry argument returns the correposnig geometry.
NeutralGeometry | Output object that specifies the neutral geometry if the HoldThicknessAt argument returns kRibThicknessAtNeutralGeometry. Else, this argument returns Nothing.
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Methods > RibDefinition.GetThicknessPlane Method


RibDefinition.SetFiniteExtent Method

RibDefinition.SetFiniteExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the extent type to be a finite distance.

Visual Basic
Sub SetFiniteExtent(Distance As VARIANT)
Parameters
Parameters | Description
Distance | Input Variant that defines the distance associated with the extent of the rib feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Methods > RibDefinition.SetFiniteExtent Method


RibDefinition.SetThicknessPlane Method

RibDefinition.SetThicknessPlane Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the plane at which the input thickness should be held.

Visual Basic
Sub SetThicknessPlane(HoldThicknessAt As RibThicknessPlaneEnum, ByRef NeutralGeometry As [optional] VARIANT)
Parameters
Parameters | Description
HoldThicknessAt | Input RibThicknessPlaneEnum that defines the plane at which the thickness should be held. Valid inputs are kRibThicknessAtSketchPlane, kRibThicknessAtRoot and kRibThicknessAtNeutralGeometry. If kRibThicknessAtNeutralGeometry is provided as input, the NeutralGeometry argument must also be provided, else the method will fail.
NeutralGeometry | Optional input object that specifies the neutral geometry if the HoldThicknessAt argument is specified to be kRibThicknessAtNeutralGeometry.
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Methods > RibDefinition.SetThicknessPlane Method


RibDefinition.SetToNextExtent Method

RibDefinition.SetToNextExtent Method Available in Inventor Introduced in Inventor 2012
Summary

Method that sets the extent type to be ‘to next’ (i.e. it terminates on the next face).

Visual Basic
Sub SetToNextExtent()
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Methods > RibDefinition.SetToNextExtent Method


RibDefinition Properties

RibDefinition Properties
Summary

The properties of the RibDefinition class are listed here.

Properties
Name | Description
AffectedBody | Property that gets and sets the solid body affected by the creation of this rib feature.
Application | Property that returns the root Application object.
BossSets | Property that returns the BossSets collection object containing boss definitions for the rib feature.
DirectionReversed | Property that gets and sets whether the direction of the profile projection should be reversed.
DraftAngle | Property that provides access to the taper angle of a rib feature.
DraftProfileEnds | Property that gets and sets the draft profile ends value.
ExtendProfile | Property that gets and sets whether the rib profile should be extended/trimmed to intersect faces, if necessary.
ExtentDistance | Property that returns the parameter that corresponds to the distance value for rib feature defined with a finite extent.
ExtentType | Property that returns the extent type of the rib feature.
IsRib | Property that gets and sets whether the sketch profile is projected lateral to the sketch plane (rib) or normal to the sketch plane (web) to create the feature. A value of True indicates that the profile is projected lateral to the sketch plane.
Parent | Property that returns the parent RibFeature of this RibDefinition object.
ProfileCurves | Property that gets and sets the collection of sketch entities used as the profile for feature creation.
Thickness | Property that provides access to the thickness of the feature.
ThicknessDirection | Property that gets and sets the side of the profile on which to apply the thickness.
Type | Property returning kRibDefinitionObject indicating this object’s type.
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties


RibDefinition.AffectedBody Property

RibDefinition.AffectedBody Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the solid body affected by the creation of this rib feature.

Visual Basic
Property AffectedBody() As SurfaceBody*
Remarks

For parts containing multiple solid bodies, this property defaults to the primary solid body of the part, and can be set to any of the other solid bodies.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.AffectedBody Property


RibDefinition.Application Property

RibDefinition.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.Application Property


RibDefinition.BossSets Property

RibDefinition.BossSets Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the BossSets collection object containing boss definitions for the rib feature.

Visual Basic
Property BossSets() As BossSets**
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.BossSets Property


RibDefinition.DirectionReversed Property

RibDefinition.DirectionReversed Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the direction of the profile projection should be reversed.

Visual Basic
Property DirectionReversed() As VARIANT_BOOL
Remarks

If the profile is projected normal to the sketch plane, setting this property to True causes the profile to be projected in the reverse direction of the sketch normal. If the profile is projected lateral to the sketch plane, setting this property to True causes the profile to be projected in the reverse direction of the natural normal direction of the base sketch entity. The natural normal direction of a sketch entity is defined as the cross-product of the vector representing the tangent at that point and the vector representing the sketch plane normal.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.DirectionReversed Property


RibDefinition.DraftAngle Property

RibDefinition.DraftAngle Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the taper angle of a rib feature.

Visual Basic
Property DraftAngle() As VARIANT
Remarks

This property is writable when the RibDefinition object has been created using the RibFeatures.CreateDefinition or RibDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyDraftAngle * 2” is valid, assuming there is a parameter named MyDraftAngle.

When the RibDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the taper angle. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.DraftAngle Property


RibDefinition.DraftProfileEnds Property

RibDefinition.DraftProfileEnds Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the draft profile ends value.

Visual Basic
Property DraftProfileEnds() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.DraftProfileEnds Property


RibDefinition.ExtendProfile Property

RibDefinition.ExtendProfile Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the rib profile should be extended/trimmed to intersect faces, if necessary.

Visual Basic
Property ExtendProfile() As VARIANT_BOOL
Remarks

This property defaults to True for a newly created RibDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.ExtendProfile Property


RibDefinition.ExtentDistance Property

RibDefinition.ExtentDistance Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parameter that corresponds to the distance value for rib feature defined with a finite extent.

Visual Basic
Property ExtentDistance() As VARIANT*
Remarks

This property returns a parameter only if the ExtentType is kFiniteRibExtent, else this property returns Nothing. Also, in the case where this is a newly created RibDefinition object or it has been copied from an existing RibDefinition object, this property returns Nothing since there isn’t a parameter created yet.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.ExtentDistance Property


RibDefinition.ExtentType Property

RibDefinition.ExtentType Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the extent type of the rib feature.

Visual Basic
Property ExtentType() As RibFeatureExtentEnum*
Remarks

The possible return values are kFiniteRibExtent and kToNextRibExtent. When the RibDefinition object is initially created, this defaults to kToNextRibExtent. If this property returns kFiniteRibExtent, the ExtentDistance property returns the correspond parameter. Use the SetFiniteExtent and Set ToNextExtent methods to edit the extent type.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.ExtentType Property


RibDefinition.IsRib Property

RibDefinition.IsRib Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the sketch profile is projected lateral to the sketch plane (rib) or normal to the sketch plane (web) to create the feature.

A value of True indicates that the profile is projected lateral to the sketch plane.

Visual Basic
Property IsRib() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.IsRib Property


RibDefinition.Parent Property

RibDefinition.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent RibFeature of this RibDefinition object.

Visual Basic
Property Parent() As RibFeature**
Remarks

In the case where this is a newly created RibDefinition object or it has been copied from an existing RibDefinition object, this property will return Nothing because there is not a logical parent for the object.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.Parent Property


RibDefinition.ProfileCurves Property

RibDefinition.ProfileCurves Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the collection of sketch entities used as the profile for feature creation.

Visual Basic
Property ProfileCurves() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.ProfileCurves Property


RibDefinition.Thickness Property

RibDefinition.Thickness Property Available in Inventor Introduced in Inventor 2012
Summary

Property that provides access to the thickness of the feature.

Visual Basic
Property Thickness() As VARIANT
Remarks

This property is writable when the RibDefinition object has been created using the RibFeatures.CreateDefinition or RibDefinition.Copy methods. The value can be set using either a double or a string. If a double is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document. When using a string you can also define equations and reference existing parameters. For example, the string “MyThickness * 2” is valid, assuming there is a parameter named MyThickness.

When the RibDefinition object has been obtained from an existing feature this property is read-only and returns the Parameter object that defines the thickness. In this case, you can use the properties of the parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.Thickness Property


RibDefinition.ThicknessDirection Property

RibDefinition.ThicknessDirection Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the side of the profile on which to apply the thickness.

Visual Basic
Property ThicknessDirection() As PartFeatureExtentDirectionEnum
Remarks

This property defaults to kSymmetricExtentDirection for a newly created RibDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.ThicknessDirection Property


RibDefinition.Type Property

RibDefinition.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning kRibDefinitionObject indicating this object’s type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RibDefinition Interface > RibDefinition Properties > RibDefinition.Type Property


RibFeature Interface

RibFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Part RibFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RibFeature
        Inventor::RibFeatureProxy
Visual Basic
Public Interface RibFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RibFeatureProxy.NativeObject

RibFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > RibFeature Interface


RibFeature Properties

RibFeature Properties
Summary

The properties of the RibFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the RibDefinition object associated with this feature.
You are here: Symbol Reference > Inventor Library > Objects > RibFeature Interface > RibFeature Properties


RibFeature.Definition Property

RibFeature.Definition Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets the RibDefinition object associated with this feature.

Visual Basic
Property Definition() As RibDefinition*
Remarks

Modifying the RibDefinition object will edit the associated RibFeature. If you want to batch up the edits to the feature, you can set a new definition object to this property. A new definition object can be created either using RibFeatures.CreateDefinition or RibDefinition.Copy methods.

You are here: Symbol Reference > Inventor Library > Objects > RibFeature Interface > RibFeature Properties > RibFeature.Definition Property


RibFeatureProxy Interface

RibFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RibFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RibFeature
        Inventor::RibFeatureProxy
Visual Basic
Public Interface RibFeatureProxy
Inherits RibFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RibFeatureProxy Interface


RibFeatureProxy Properties

RibFeatureProxy Properties
Summary

The properties of the RibFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RibFeatureProxy Interface > RibFeatureProxy Properties


RibFeatureProxy.ContainingOccurrence Property

RibFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RibFeatureProxy Interface > RibFeatureProxy Properties > RibFeatureProxy.ContainingOccurrence Property


RibFeatureProxy.NativeObject Property

RibFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RibFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RibFeatureProxy Interface > RibFeatureProxy Properties > RibFeatureProxy.NativeObject Property


RibFeatures Interface

RibFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Part RibFeatures collection object. A is a closed, thin-walled support shape.

Class Hierarchy
Inventor::RibFeatures
Visual Basic
Public Interface RibFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.RibFeatures

You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface


RibFeatures Methods

RibFeatures Methods
Summary

The methods of the RibFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Rib feature. The newly created RibFeature object is returned.
CreateDefinition | Method that creates a new RibDefinition object.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Methods


RibFeatures.Add Method

RibFeatures.Add Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new Rib feature. The newly created RibFeature object is returned.

Visual Basic
Sub Add(Definition As RibDefinition, Result As [out, retval] RibFeature*)
Parameters
Parameters | Description
Definition | Input RibDefinition object that defines the rib feature you want to create. A RibDefinition object can be created using the RibFeatures.CreateDefinition method. It can also be obtained from an existing RibFeature object.
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Methods > RibFeatures.Add Method


RibFeatures.CreateDefinition Method

RibFeatures.CreateDefinition Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new RibDefinition object.

Visual Basic
Sub CreateDefinition(Profilecurves As ObjectCollection, IsRib As VARIANT_BOOL, DirectionReversed As VARIANT_BOOL, Thickness As VARIANT, Result As [out, retval] RibDefinition*)
Parameters
Parameters | Description
Profilecurves | Input ObjectCollection containing the sketch entities that will form the profile of the feature.
IsRib | Input Boolean that specifies whether the sketch profile is projected lateral to the sketch plane (rib) or normal to the sketch plane (web) to create the feature. A value of True indicates that the profile is projected lateral to the sketch plane.
DirectionReversed | Input Boolean that specifies whether the direction of the profile projection should be reversed. If the profile is projected normal to the sketch plane, setting this property to True causes the profile to be projected in the reverse direction of the sketch normal. If the profile is projected lateral to the sketch plane, setting this property to True causes the profile to be projected in the reverse direction of the natural normal direction of the base sketch entity. The natural normal of a sketch entity is defined as the cross-product of the vector representing the tangent at that point and the vector representing the sketch normal.
Thickness | Input Variant that defines the thickness of the rib feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
Remarks

The object created does not represent a rib feature but instead is a representation of the information that defines a rib feature. You can use this object as input to the RibFeatures.Add method to create the actual feature.

The RibDefinition object returned is fully defined and can be used to create a rib feature. However, defaults are used for various options, so you may want to change some of the property values of the RibDefinition object before using it to create a feature.

You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Methods > RibFeatures.CreateDefinition Method


RibFeatures.Item Method

RibFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RibFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the RibFeature to return.
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Methods > RibFeatures.Item Method


RibFeatures Properties

RibFeatures Properties
Summary

The properties of the RibFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Properties


RibFeatures.Application Property

RibFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Properties > RibFeatures.Application Property


RibFeatures.Count Property

RibFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Properties > RibFeatures.Count Property


RibFeatures.Type Property

RibFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RibFeatures Interface > RibFeatures Properties > RibFeatures.Type Property


RipDefinition Interface

RipDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The RipDefinition object represents all of the information that defines a rip feature. The RipDefinition object is used in two ways. First it is used as input when creating a rip feature. Second it is used to query and edit existing rip features.

Class Hierarchy
Inventor::RipDefinition
Visual Basic
Public Interface RipDefinition
Inherits IDispatch
Remarks

When creating a new rip feature you use the RipFeatures.CreateRipDefinition method to create a new RipDefinition object. Using the properties of this object you can define the various options of the rip feature. Typically a new RipDefinition object is created and then modified to get the desired rip feature and then used as input to the RipFeatures.Add method. An existing RipFeature object is edited by modifying its associated RipDefinition object.

Notes

Members through which this object may be accessed include:

PointToPointRipTypeDef.Parent

RipDefinition.Copy

RipFeature.Definition

RipFeatures.CreateRipDefinition

SinglePointRipTypeDef.Parent

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface


RipDefinition Methods

RipDefinition Methods
Summary

The methods of the RipDefinition class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of this RipDefinition object. The new RipDefinition object is independent of any feature. It can be edited and used as input to edit an existing feature or to create a new rip feature.
SetFaceExtentsRipType | Method that sets the RipDefinition so that it defines a rip that uses the entire rip face to determine the extent of the rip.
SetPointToPointRipType | Method that sets the RipDefinition so that it defines a point to point rip.
SetSinglePointRipType | Method that sets the RipDefinition so that it defines a single point rip.
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Methods


RipDefinition.Copy Method

RipDefinition.Copy Method Introduced in Inventor 2011
Summary

Method that creates a copy of this RipDefinition object. The new RipDefinition object is independent of any feature. It can be edited and used as input to edit an existing feature or to create a new rip feature.

Visual Basic
Sub Copy(Result As [out, retval] RipDefinition*)
Remarks

Any of the properties of the RipDefinition that can reference a Parameter object will behave differently depending on if the RipDefinition is independent or associated with a feature. When it is associated with a feature these properties behave as read-only and will return the related Parameter object. When it is not associated with a feature these properties behave as read-write and will accept and return doubles and strings to define the value or expression.

One typical use of this method is when you need to make several changes to an existing rip feature. If you edit the RipDefinition object associated with the hem feature, the feature will recompute after each edit. It's more efficient to make a copy, edit the copy, and then assign the copy back to the feature. This will result in a single recompute.

The RipFeatures.CreateRipDefinition method can also be used to create an independent RipDefinition object. The difference is that one created with the Copy method will have the same initial values as the object is was copied from. One that's created with the CreateHemDefinition method will be initialized to predefined default values.

You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Methods > RipDefinition.Copy Method


RipDefinition.SetFaceExtentsRipType Method

RipDefinition.SetFaceExtentsRipType Method
Summary

Method that sets the RipDefinition so that it defines a rip that uses the entire rip face to determine the extent of the rip.

Visual Basic
Sub SetFaceExtentsRipType(RipFace As Face)
Parameters
Parameters | Description
RipFace | The face that defines the extent of the rip. This must be a face this is valid for defining a rip extent. For example a face along the edge of the part where the thickness of the part is represented is not valid as input.
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Methods > RipDefinition.SetFaceExtentsRipType Method


RipDefinition.SetPointToPointRipType Method

RipDefinition.SetPointToPointRipType Method Introduced in Inventor 2011
Summary

Method that sets the RipDefinition so that it defines a point to point rip.

Visual Basic
Sub SetPointToPointRipType(RipFace As Face, PointOne As IDispatch, PointTwo As IDispatch, GapSize As VARIANT, GapSide As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
RipFace | The face that the rip is defined along. This must be a face this is valid for defining a rip extent. For example a face along the edge of the part where the thickness of the part is represented is not valid as input.
PointOne | Point that defines the location of the first rip point. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.
PointTwo | Point that defines the location of the second rip point. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.
GapSize | Variant that defines the width of the gap. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
GapSide | Input PartFeatureExtentDirectionEnum value to indicate the position of the gap. Valid values are kPositiveExtentDirection, kNegativeExtentDirection, and kSymmetricExtentDirection. kPositiveExtentDirection indicates that the material will be removed from the right from the perspective of the first rip point where 'up' is along the normal of the rip face and you're looking towards the second rip point.
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Methods > RipDefinition.SetPointToPointRipType Method


RipDefinition.SetSinglePointRipType Method

RipDefinition.SetSinglePointRipType Method Introduced in Inventor 2011
Summary

Method that sets the RipDefinition so that it defines a single point rip.

Visual Basic
Sub SetSinglePointRipType(RipFace As Face, Point As IDispatch, GapSize As VARIANT, GapSide As PartFeatureExtentDirectionEnum)
Parameters
Parameters | Description
RipFace | The face that the rip is defined along. This must be a face this is valid for defining a rip extent. For example a face along the edge of the part where the thickness of the part is represented is not valid as input.
Point | The point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.
GapSize | Variant that defines the width of the gap. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
GapSide | Input PartFeatureExtentDirectionEnum value to indicate the position of the gap. Valid values are kPositiveExtentDirection, kNegativeExtentDirection, and kSymmetricExtentDirection. kPositiveExtentDirection indicates that the material will be removed from the right from the perspective of the rip point where 'up' is along the normal of the rip face and you're looking towards the other edge of the face where the rip will end.
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Methods > RipDefinition.SetSinglePointRipType Method


RipDefinition Properties

RipDefinition Properties
Summary

The properties of the RipDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent rip definition feature.
RipFace | Property that gets and set the face that the rip is defined along.
RipType | Property that returns the method used to define the type of rip. The valid values for this property are kSinglePointRipType, kPointToPointRipType, and kFaceExtentsRipType.
RipTypeDefinition | Property that returns the RipTypeDefinition object that defines the type of rip.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties


RipDefinition.Application Property

RipDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties > RipDefinition.Application Property


RipDefinition.Parent Property

RipDefinition.Parent Property
Summary

Property that returns the parent rip definition feature.

Visual Basic
Property Parent() As RipFeature**
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties > RipDefinition.Parent Property


RipDefinition.RipFace Property

RipDefinition.RipFace Property Introduced in Inventor 2011
Summary

Property that gets and set the face that the rip is defined along.

Visual Basic
Property RipFace() As Face*
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties > RipDefinition.RipFace Property


RipDefinition.RipType Property

RipDefinition.RipType Property Introduced in Inventor 2011
Summary

Property that returns the method used to define the type of rip. The valid values for this property are kSinglePointRipType, kPointToPointRipType, and kFaceExtentsRipType.

Visual Basic
Property RipType() As RipTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties > RipDefinition.RipType Property


RipDefinition.RipTypeDefinition Property

RipDefinition.RipTypeDefinition Property Introduced in Inventor 2011
Summary

Property that returns the RipTypeDefinition object that defines the type of rip.

Visual Basic
Property RipTypeDefinition() As IDispatch**
Remarks

The type of rip object that this property returns can be determined by using the RipType property. Types that can be returned are SinglePointRipDefinition and PointToPointRipDefinition. This property returns Nothing in the case of a Face Extent rip type since the single input required is the rip face which is defined by the RipDefinition.

You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties > RipDefinition.RipTypeDefinition Property


RipDefinition.Type Property

RipDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RipDefinition Interface > RipDefinition Properties > RipDefinition.Type Property


RipFeature Interface

RipFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RepFeature object represents a rip sheet metal feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::RipFeature
        Inventor::RipFeatureProxy
Visual Basic
Public Interface RipFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RipFeatures.Add

RipFeatures.Item

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > RipFeature Interface


RipFeature Properties

RipFeature Properties
Summary

The properties of the RipFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the RipDefinition object associated with this rip feature. Modifying the RipDefinition object will edit the associated RipFeature.
You are here: Symbol Reference > Inventor Library > Objects > RipFeature Interface > RipFeature Properties


RipFeature.Definition Property

RipFeature.Definition Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that gets and sets the RipDefinition object associated with this rip feature. Modifying the RipDefinition object will edit the associated RipFeature.

Visual Basic
Property Definition() As RipDefinition*
You are here: Symbol Reference > Inventor Library > Objects > RipFeature Interface > RipFeature Properties > RipFeature.Definition Property


RipFeatureProxy Interface

RipFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RipFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RipFeature
        Inventor::RipFeatureProxy
Visual Basic
Public Interface RipFeatureProxy
Inherits RipFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RipFeatureProxy Interface


RipFeatures Interface

RipFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RipFeatures collection object provides access to the RipFeature objects

Class Hierarchy
Inventor::RipFeatures
Visual Basic
Public Interface RipFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.RipFeatures

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface


RipFeatures Methods

RipFeatures Methods
Summary

The methods of the RipFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new rip feature. The newly created RipFeature object is returned.
CreateRipDefinition | Method that creates a new RipDefinition object.
Item | Property that returns the specified RipFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Methods


RipFeatures.Add Method

RipFeatures.Add Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new rip feature. The newly created RipFeature object is returned.

Visual Basic
Sub Add(RipDefinition As RipDefinition, Result As [out, retval] RipFeature*)
Parameters
Parameters | Description
RipDefinition | Input LoftedFlangeDefinition object that defines the lofted flange feature you want to create. A LoftedFlangeDefinition object can be created using the CreateLoftedFlangeDefinition method on the LoftedFlangeFeatures object.
Example

Create sheet metal rip feature example.

This sample demonstrates the creation of a rip sheet metal feature.

Public Sub RipFeatureCreation()
    ' Create a new sheet metal document, using the default sheet metal template.
    Dim oSheetMetalDoc As PartDocument
    Set oSheetMetalDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject, , , "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}"))

    ' Set a reference to the component definition.
    Dim oCompDef As SheetMetalComponentDefinition
    Set oCompDef = oSheetMetalDoc.ComponentDefinition

    ' Set a reference to the sheet metal features collection.
    Dim oSheetMetalFeatures As SheetMetalFeatures
    Set oSheetMetalFeatures = oCompDef.Features

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 2cm rectangle with the corner at (0,0)
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 2))

    Dim oSketchLines As ObjectCollection
    Set oSketchLines = ThisApplication.TransientObjects.CreateObjectCollection

    oSketchLines.Add oSketch.SketchLines(1)

    Call oSketch.OffsetSketchEntitiesUsingDistance(oSketchLines, oCompDef.Thickness.Value, True, True)

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create an extrude feature.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oSheetMetalFeatures.ExtrudeFeatures.AddByDistanceExtent(oProfile, "1 in", kPositiveExtentDirection, kNewBodyOperation)

    ' Create bends at all concave edges.
    Dim oEdgeColl As EdgeCollection
    Set oEdgeColl = oExtrude.SurfaceBodies(1).ConcaveEdges

    Dim oBendEdge As Edge
    For Each oBendEdge In oEdgeColl

        Dim oTempColl As EdgeCollection
        Set oTempColl = ThisApplication.TransientObjects.CreateEdgeCollection

        oTempColl.Add oBendEdge

        Dim oBendDef As BendDefinition
        Set oBendDef = oSheetMetalFeatures.BendFeatures.CreateBendDefinition(oTempColl)

        Dim oBendFeature As BendFeature
        Set oBendFeature = oSheetMetalFeatures.BendFeatures.Add(oBendDef)

    Next

    ' Get the first side face of the extrude
    Dim oSideFace As Face
    Set oSideFace = oExtrude.SideFaces.Item(1)

    ' Get any edge on the face that is parallel to the sketch plane
    Dim oEdge As Edge
    For Each oEdge In oSideFace.Edges

        Dim oLineSeg As LineSegment
        Set oLineSeg = oEdge.Geometry

        Dim oLine As Line
        Set oLine = oTransGeom.CreateLine(oLineSeg.StartPoint, oLineSeg.Direction.AsVector)

        If oSketch.PlanarEntityGeometry.IsParallelTo(oLine) Then
            Exit For
        End If
    Next

    ' Create a workpoint at the edge mid-point
    Dim oWorkPoint As WorkPoint
    Set oWorkPoint = oCompDef.WorkPoints.AddByMidPoint(oEdge)

    ' Create a single point type rip feature
    Dim oRipDef As RipDefinition
    Set oRipDef = oSheetMetalFeatures.RipFeatures.CreateRipDefinition(oSideFace)

    Call oRipDef.SetSinglePointRipType(oSideFace, oWorkPoint, oCompDef.GapSize.Value, kSymmetricExtentDirection)

    Dim oRipFeature As RipFeature
    Set oRipFeature = oSheetMetalFeatures.RipFeatures.Add(oRipDef)

    ThisApplication.ActiveView.GoHome
End Sub
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Methods > RipFeatures.Add Method


RipFeatures.CreateRipDefinition Method

RipFeatures.CreateRipDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new RipDefinition object.

Visual Basic
Sub CreateRipDefinition(RipFace As Face, Result As [out, retval] RipDefinition*)
Parameters
Parameters | Description
RipFace | The face that the rip is defined along. This must be a face this is valid for defining a rip extent. For example a face along the edge of the part where the thickness of the part is represented is not valid as input.
Remarks

This object is not a rip feature but contains the information that defines a rip feature and can be used to create a new rip feature. The resulting RipDefinition will define a 'Face Extents' rip feature where the entire face defines the extents of the rip. To create a single point or point to point rip definition you can edit the RipDefinition feature.

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Methods > RipFeatures.CreateRipDefinition Method


RipFeatures.Item Method

RipFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified RipFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RipFeature*)
Parameters
Parameters | Description
Index | Input Long or String that specifies the RipFeature object within the collection to return. Inputting a Long indicates the index of the RipFeature within the collection to return. A String can also be used to specify the name of the feature. The property will fail is the index is out of range or the name does not exist.
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Methods > RipFeatures.Item Method


RipFeatures Properties

RipFeatures Properties
Summary

The properties of the RipFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Properties


RipFeatures.Application Property

RipFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Properties > RipFeatures.Application Property


RipFeatures.Count Property

RipFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Properties > RipFeatures.Count Property


RipFeatures.Type Property

RipFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RipFeatures Interface > RipFeatures Properties > RipFeatures.Type Property


RolledHemDefinition Interface

RolledHemDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The RolledHemDefinition object defines all of the inputs that are unique to a rolled style of hem feature.

Class Hierarchy
Inventor::RolledHemDefinition
Visual Basic
Public Interface RolledHemDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HemDefinition.HemTypeDefinition

You are here: Symbol Reference > Inventor Library > Objects > RolledHemDefinition Interface


RolledHemDefinition Properties

RolledHemDefinition Properties
Summary

The properties of the RolledHemDefinition class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter controlling the bend angle of a hem feature defined by a rolled style of bend.
Parent | Property that returns the parent hem definition feature.
Radius | Property that returns the parameter controlling the radius of a hem feature defined by a rolled style of bend.
You are here: Symbol Reference > Inventor Library > Objects > RolledHemDefinition Interface > RolledHemDefinition Properties


RolledHemDefinition.Angle Property

RolledHemDefinition.Angle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the bend angle of a hem feature defined by a rolled style of bend.

Visual Basic
Property Angle() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > RolledHemDefinition Interface > RolledHemDefinition Properties > RolledHemDefinition.Angle Property


RolledHemDefinition.Parent Property

RolledHemDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent hem definition feature.

Visual Basic
Property Parent() As HemDefinition**
You are here: Symbol Reference > Inventor Library > Objects > RolledHemDefinition Interface > RolledHemDefinition Properties > RolledHemDefinition.Parent Property


RolledHemDefinition.Radius Property

RolledHemDefinition.Radius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the radius of a hem feature defined by a rolled style of bend.

Visual Basic
Property Radius() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > RolledHemDefinition Interface > RolledHemDefinition Properties > RolledHemDefinition.Radius Property


RotateRotateConstraint Interface

RotateRotateConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a rotation motion constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::RotateRotateConstraint
        Inventor::RotateRotateConstraintProxy
Visual Basic
Public Interface RotateRotateConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToRotateRotateConstraint

AssemblyConstraints.AddRotateRotateConstraint

RotateRotateConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraint Interface


RotateRotateConstraint Properties

RotateRotateConstraint Properties
Summary

The properties of the RotateRotateConstraint class are listed here.

Properties
Name | Description
ForwardDirection | Boolean property that returns the direction of rotation of the objects with respect to the axis direction. If True, both objects will rotate in the same direction around their axes. If False, then they will rotate in opposite directions.
Ratio | Property that returns the Parameter object that controls the rotation ratio of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraint Interface > RotateRotateConstraint Properties


RotateRotateConstraint.ForwardDirection Property

RotateRotateConstraint.ForwardDirection Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Boolean property that returns the direction of rotation of the objects with respect to the axis direction. If True, both objects will rotate in the same direction around their axes. If False, then they will rotate in opposite directions.

Visual Basic
Property ForwardDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraint Interface > RotateRotateConstraint Properties > RotateRotateConstraint.ForwardDirection Property


RotateRotateConstraint.Ratio Property

RotateRotateConstraint.Ratio Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Parameter object that controls the rotation ratio of the constraint.

Visual Basic
Property Ratio() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraint Interface > RotateRotateConstraint Properties > RotateRotateConstraint.Ratio Property


RotateRotateConstraintProxy Interface

RotateRotateConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateRotateConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::RotateRotateConstraint
        Inventor::RotateRotateConstraintProxy
Visual Basic
Public Interface RotateRotateConstraintProxy
Inherits RotateRotateConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraintProxy Interface


RotateRotateConstraintProxy Properties

RotateRotateConstraintProxy Properties
Summary

The properties of the RotateRotateConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraintProxy Interface > RotateRotateConstraintProxy Properties


RotateRotateConstraintProxy.ContainingOccurrence Property

RotateRotateConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraintProxy Interface > RotateRotateConstraintProxy Properties > RotateRotateConstraintProxy.ContainingOccurrence Property


RotateRotateConstraintProxy.NativeObject Property

RotateRotateConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RotateRotateConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateConstraintProxy Interface > RotateRotateConstraintProxy Properties > RotateRotateConstraintProxy.NativeObject Property


RotateRotateiMateDefinition Interface

RotateRotateiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The RotateRotateiMateDefinition object represents a rotate iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::RotateRotateiMateDefinition
        Inventor::RotateRotateiMateDefinitionProxy
Visual Basic
Public Interface RotateRotateiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddRotateRotateiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinition Interface


RotateRotateiMateDefinition Properties

RotateRotateiMateDefinition Properties
Summary

The properties of the RotateRotateiMateDefinition class are listed here.

Properties
Name | Description
Entity | Property that returns the entity used for the iMate definition.
ForwardDirection | Boolean property that returns the direction of rotation with respect to the axis direction. If True, both objects will rotate in the same direction around their axes. If False, then they will rotate in opposite directions.
Ratio | Property that returns the Parameter object that controls the rotation ratio of the iMate definition.
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinition Interface > RotateRotateiMateDefinition Properties


RotateRotateiMateDefinition.Entity Property

RotateRotateiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinition Interface > RotateRotateiMateDefinition Properties > RotateRotateiMateDefinition.Entity Property


RotateRotateiMateDefinition.ForwardDirection Property

RotateRotateiMateDefinition.ForwardDirection Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Boolean property that returns the direction of rotation with respect to the axis direction. If True, both objects will rotate in the same direction around their axes. If False, then they will rotate in opposite directions.

Visual Basic
Property ForwardDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinition Interface > RotateRotateiMateDefinition Properties > RotateRotateiMateDefinition.ForwardDirection Property


RotateRotateiMateDefinition.Ratio Property

RotateRotateiMateDefinition.Ratio Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the rotation ratio of the iMate definition.

Visual Basic
Property Ratio() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinition Interface > RotateRotateiMateDefinition Properties > RotateRotateiMateDefinition.Ratio Property


RotateRotateiMateDefinitionProxy Interface

RotateRotateiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateRotateiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::RotateRotateiMateDefinition
        Inventor::RotateRotateiMateDefinitionProxy
Visual Basic
Public Interface RotateRotateiMateDefinitionProxy
Inherits RotateRotateiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinitionProxy Interface


RotateRotateiMateDefinitionProxy Properties

RotateRotateiMateDefinitionProxy Properties
Summary

The properties of the RotateRotateiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinitionProxy Interface > RotateRotateiMateDefinitionProxy Properties


RotateRotateiMateDefinitionProxy.ContainingOccurrence Property

RotateRotateiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinitionProxy Interface > RotateRotateiMateDefinitionProxy Properties > RotateRotateiMateDefinitionProxy.ContainingOccurrence Property


RotateRotateiMateDefinitionProxy.IsConsumed Property

RotateRotateiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinitionProxy Interface > RotateRotateiMateDefinitionProxy Properties > RotateRotateiMateDefinitionProxy.IsConsumed Property


RotateRotateiMateDefinitionProxy.NativeObject Property

RotateRotateiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateRotateiMateDefinitionProxy Interface > RotateRotateiMateDefinitionProxy Properties > RotateRotateiMateDefinitionProxy.NativeObject Property


RotateTranslateConstraint Interface

RotateTranslateConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a rotation-translate motion constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::RotateTranslateConstraint
        Inventor::RotateTranslateConstraintProxy
Visual Basic
Public Interface RotateTranslateConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToRotateTranslateConstraint

AssemblyConstraints.AddRotateTranslateConstraint

RotateTranslateConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraint Interface


RotateTranslateConstraint Properties

RotateTranslateConstraint Properties
Summary

The properties of the RotateTranslateConstraint class are listed here.

Properties
Name | Description
ForwardDirection | Boolean property that defines the direction of rotation and translation of the objects with respect to their axes directions. If the property is True then the translation will in the same direction as the rotation with respect to the rotation and translation axes.
Ratio | Property that returns the Parameter object that controls the distance of translation for every revolution of the rotated occurrence.
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraint Interface > RotateTranslateConstraint Properties


RotateTranslateConstraint.ForwardDirection Property

RotateTranslateConstraint.ForwardDirection Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Boolean property that defines the direction of rotation and translation of the objects with respect to their axes directions. If the property is True then the translation will in the same direction as the rotation with respect to the rotation and translation axes.

Visual Basic
Property ForwardDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraint Interface > RotateTranslateConstraint Properties > RotateTranslateConstraint.ForwardDirection Property


RotateTranslateConstraint.Ratio Property

RotateTranslateConstraint.Ratio Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Parameter object that controls the distance of translation for every revolution of the rotated occurrence.

Visual Basic
Property Ratio() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraint Interface > RotateTranslateConstraint Properties > RotateTranslateConstraint.Ratio Property


RotateTranslateConstraintProxy Interface

RotateTranslateConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateTranslateConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::RotateTranslateConstraint
        Inventor::RotateTranslateConstraintProxy
Visual Basic
Public Interface RotateTranslateConstraintProxy
Inherits RotateTranslateConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraintProxy Interface


RotateTranslateConstraintProxy Properties

RotateTranslateConstraintProxy Properties
Summary

The properties of the RotateTranslateConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraintProxy Interface > RotateTranslateConstraintProxy Properties


RotateTranslateConstraintProxy.ContainingOccurrence Property

RotateTranslateConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraintProxy Interface > RotateTranslateConstraintProxy Properties > RotateTranslateConstraintProxy.ContainingOccurrence Property


RotateTranslateConstraintProxy.NativeObject Property

RotateTranslateConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RotateTranslateConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateConstraintProxy Interface > RotateTranslateConstraintProxy Properties > RotateTranslateConstraintProxy.NativeObject Property


RotateTranslateiMateDefinition Interface

RotateTranslateiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The RotateTranslateiMateDefinition object represents a rotate translate iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::RotateTranslateiMateDefinition
        Inventor::RotateTranslateiMateDefinitionProxy
Visual Basic
Public Interface RotateTranslateiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddRotateTranslateiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinition Interface


RotateTranslateiMateDefinition Properties

RotateTranslateiMateDefinition Properties
Summary

The properties of the RotateTranslateiMateDefinition class are listed here.

Properties
Name | Description
Entity | Property that returns the entity used for the iMate definition.
ForwardDirection | Property that returns the direction of rotation and translation of the objects with respect to their axes' directions. If the property is True then the translation will be in the same direction as the rotation with respect to the rotation and translation axes.
Ratio | Property that returns the Parameter object that controls the ratio of the iMate definition.
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinition Interface > RotateTranslateiMateDefinition Properties


RotateTranslateiMateDefinition.Entity Property

RotateTranslateiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinition Interface > RotateTranslateiMateDefinition Properties > RotateTranslateiMateDefinition.Entity Property


RotateTranslateiMateDefinition.ForwardDirection Property

RotateTranslateiMateDefinition.ForwardDirection Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the direction of rotation and translation of the objects with respect to their axes' directions. If the property is True then the translation will be in the same direction as the rotation with respect to the rotation and translation axes.

Visual Basic
Property ForwardDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinition Interface > RotateTranslateiMateDefinition Properties > RotateTranslateiMateDefinition.ForwardDirection Property


RotateTranslateiMateDefinition.Ratio Property

RotateTranslateiMateDefinition.Ratio Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the ratio of the iMate definition.

Visual Basic
Property Ratio() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinition Interface > RotateTranslateiMateDefinition Properties > RotateTranslateiMateDefinition.Ratio Property


RotateTranslateiMateDefinitionProxy Interface

RotateTranslateiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RotateTranslateiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::RotateTranslateiMateDefinition
        Inventor::RotateTranslateiMateDefinitionProxy
Visual Basic
Public Interface RotateTranslateiMateDefinitionProxy
Inherits RotateTranslateiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinitionProxy Interface


RotateTranslateiMateDefinitionProxy Properties

RotateTranslateiMateDefinitionProxy Properties
Summary

The properties of the RotateTranslateiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinitionProxy Interface > RotateTranslateiMateDefinitionProxy Properties


RotateTranslateiMateDefinitionProxy.ContainingOccurrence Property

RotateTranslateiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinitionProxy Interface > RotateTranslateiMateDefinitionProxy Properties > RotateTranslateiMateDefinitionProxy.ContainingOccurrence Property


RotateTranslateiMateDefinitionProxy.IsConsumed Property

RotateTranslateiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinitionProxy Interface > RotateTranslateiMateDefinitionProxy Properties > RotateTranslateiMateDefinitionProxy.IsConsumed Property


RotateTranslateiMateDefinitionProxy.NativeObject Property

RotateTranslateiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RotateTranslateiMateDefinitionProxy Interface > RotateTranslateiMateDefinitionProxy Properties > RotateTranslateiMateDefinitionProxy.NativeObject Property


Row Interface

Row Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Row object represents a single row in this custom table. See the Custom Tables overview for more information.

Class Hierarchy
Inventor::Row
Visual Basic
Public Interface Row
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Rows.Add

Rows.Item

You are here: Symbol Reference > Inventor Library > Objects > Row Interface


Row Methods

Row Methods
Summary

The methods of the Row class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this Row object.
Item | Property that returns the specified Cell object from the collection.
Reposition | Method that repositions the row within the table.
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Methods


Row.Delete Method

Row.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes this Row object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Methods > Row.Delete Method


Row.Item Method

Row.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified Cell object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Cell*)
Parameters
Parameters | Description
index | Input Variant value that specifies the Cell to return. This can be either a numeric value indicating the index of the item in the collection, a string indicating the title of a column header, or a Column object. If an out of range index, a non-existent column header title, or an invalid Column object is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Methods > Row.Item Method


Row.Reposition Method

Row.Reposition Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that repositions the row within the table.

Visual Basic
Sub Reposition(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing row next to which the row will be inserted. The valid range of values is 0 to the number of existing rows in the table. The position remains unchanged if the index of the row being moved is specified. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the row will be moved to the end.
InsertBefore | Optional input Boolean indicating if the row should be inserted before or after the target index. If not specified, a default value of True is used indicating that the row will be inserted before the target index. This argument is ignored if the value of TargetIndex is 0.
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Methods > Row.Reposition Method


Row Properties

Row Properties
Summary

The properties of the Row class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Height | Property that gets and sets the height of the row.
Parent | Property that returns the parent Table.
Type | Property returning an enum indicating this object's type.
Visible | Property that gets and sets whether the row is visible.
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties


Row.Application Property

Row.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties > Row.Application Property


Row.Count Property

Row.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties > Row.Count Property


Row.Height Property

Row.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the height of the row.

Visual Basic
Property Height() As double
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties > Row.Height Property


Row.Parent Property

Row.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent Table.

Visual Basic
Property Parent() As CustomTable**
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties > Row.Parent Property


Row.Type Property

Row.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties > Row.Type Property


Row.Visible Property

Row.Visible Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether the row is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Row Interface > Row Properties > Row.Visible Property


Rows Interface

Rows Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The Rows collection object represents all the objects contained by this custom table. See the Custom Tables overview for more information.

Class Hierarchy
Inventor::Rows
Visual Basic
Public Interface Rows
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CustomTable.Rows

You are here: Symbol Reference > Inventor Library > Objects > Rows Interface


Rows Methods

Rows Methods
Summary

The methods of the Rows class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Row. The new created Row is returned.
Item | Property that returns the specified Row object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Methods


Rows.Add Method

Rows.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new Row. The new created Row is returned.

Visual Basic
Sub Add(ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, ByRef Contents As [optional] VARIANT, ByRef Height As [optional] VARIANT, Result As [out, retval] Row*)
Parameters
Parameters | Description
TargetIndex | Optional input Long that specifies the existing row next to which the new row will be inserted. The valid range of values is 0 to the number of existing rows in the table. A value of 0 will put the row at the end. If not specified, a default value of 0 is used, indicating that the row will be added at the end.
InsertBefore | Optional input Boolean indicating if the row should be inserted before or after the target index. If not specified, a default value of True is used. This argument is ignored if the value of TargetIndex is 0.
Contents | Optional input array of Strings that specifies the contents of the new row. The number of strings should be equal to the number of columns in the table, else an error will occur.
height | Optional input Double that specifies the height of the row. If not specified, a default value is used.
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Methods > Rows.Add Method


Rows.Item Method

Rows.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified Row object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Row*)
Parameters
Parameters | Description
index | Input Long value that specifies the Row to return. This is a numeric value indicating the index of the item in the collection. If an out of range index is input, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Methods > Rows.Item Method


Rows Properties

Rows Properties
Summary

The properties of the Rows class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Properties


Rows.Application Property

Rows.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Properties > Rows.Application Property


Rows.Count Property

Rows.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Properties > Rows.Count Property


Rows.Type Property

Rows.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Rows Interface > Rows Properties > Rows.Type Property


RuleFilletFeature Interface

RuleFilletFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RuleFilletFeature object represents a rule fillet sheet metal feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::RuleFilletFeature
        Inventor::RuleFilletFeatureProxy
Visual Basic
Public Interface RuleFilletFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

RuleFilletFeatureProxy.NativeObject

RuleFilletFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeature Interface


RuleFilletFeatureProxy Interface

RuleFilletFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the RuleFilletFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::RuleFilletFeature
        Inventor::RuleFilletFeatureProxy
Visual Basic
Public Interface RuleFilletFeatureProxy
Inherits RuleFilletFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatureProxy Interface


RuleFilletFeatureProxy Properties

RuleFilletFeatureProxy Properties
Summary

The properties of the RuleFilletFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatureProxy Interface > RuleFilletFeatureProxy Properties


RuleFilletFeatureProxy.ContainingOccurrence Property

RuleFilletFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatureProxy Interface > RuleFilletFeatureProxy Properties > RuleFilletFeatureProxy.ContainingOccurrence Property


RuleFilletFeatureProxy.NativeObject Property

RuleFilletFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As RuleFilletFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatureProxy Interface > RuleFilletFeatureProxy Properties > RuleFilletFeatureProxy.NativeObject Property


RuleFilletFeatures Interface

RuleFilletFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The RuleFilletFeatures collection object provides access to the RuleFilletFeature objects

Class Hierarchy
Inventor::RuleFilletFeatures
Visual Basic
Public Interface RuleFilletFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.RuleFilletFeatures

You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface


RuleFilletFeatures Methods

RuleFilletFeatures Methods
Summary

The methods of the RuleFilletFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified RuleFilletFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface > RuleFilletFeatures Methods


RuleFilletFeatures.Item Method

RuleFilletFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified RuleFilletFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] RuleFilletFeature*)
Parameters
Parameters | Description
Index | Input Long or String that specifies the RuleFilletFeature object within the collection to return. Inputting a Long indicates the index of the RuleFilletFeature within the collection to return. A String can also be used to specify the name of the feature. The property will fail is the index is out of range or the name does not exist.
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface > RuleFilletFeatures Methods > RuleFilletFeatures.Item Method


RuleFilletFeatures Properties

RuleFilletFeatures Properties
Summary

The properties of the RuleFilletFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface > RuleFilletFeatures Properties


RuleFilletFeatures.Application Property

RuleFilletFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface > RuleFilletFeatures Properties > RuleFilletFeatures.Application Property


RuleFilletFeatures.Count Property

RuleFilletFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface > RuleFilletFeatures Properties > RuleFilletFeatures.Count Property


RuleFilletFeatures.Type Property

RuleFilletFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > RuleFilletFeatures Interface > RuleFilletFeatures Properties > RuleFilletFeatures.Type Property


RunoffSurfaceDefinition Interface

RunoffSurfaceDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

This object represents a runoff surface definition.

Class Hierarchy
Inventor::RunoffSurfaceDefinition
Visual Basic
Public Interface RunoffSurfaceDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApplicationUtilities.CreateRunoffSurfaceDefinition

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface


RunoffSurfaceDefinition Methods

RunoffSurfaceDefinition Methods
Summary

The methods of the RunoffSurfaceDefinition class are listed here.

Methods
Methods
Name | Description
AddCornerPiece | Method that adds a planar patch to fill in a corner of the runoff surface.
AddExtrusionPiece | Method that adds an extrusion type of runoff surface to this runoff surface definition.
AddRadiatePiece | Method that adds an extrusion type of runoff surface to this runoff surface definition.
AddSurfaceExtensionPiece | Method that creates a runoff piece by extending the face attached to the input EdgeUse object.
CreateRunoff | Method that creates the runoff surface for all of the pieces defined in the RunoffSurfaceDefinition object.
CreateSingleRunoffPiece | Method that creates the runoff surface for a single piece of the runoff definition.
You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods


RunoffSurfaceDefinition.AddCornerPiece Method

RunoffSurfaceDefinition.AddCornerPiece Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that adds a planar patch to fill in a corner of the runoff surface.

Visual Basic
Sub AddCornerPiece(Corner As Vertex, StartVector As UnitVector, EndVector As UnitVector, Result As [out, retval] long)
Parameters
Parameters | Description
Corner | Input Vertex object that defines the corner of the open area of the runoff surface that you want to generate a patch to fill.
StartVector | Input UnitVector that defines the start edge of the corner patch.
EndVector | Input UnitVector that defines the end edge of the corner patch.
Remarks

The corner is defined by a Vertex and two vectors that define the sides of the patch. The extent of the patch is controlled by the range box associated with the RunoffSurfaceDefinition. This method returns the index identifying this piece of the runoff.

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods > RunoffSurfaceDefinition.AddCornerPiece Method


RunoffSurfaceDefinition.AddExtrusionPiece Method

RunoffSurfaceDefinition.AddExtrusionPiece Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that adds an extrusion type of runoff surface to this runoff surface definition.

Visual Basic
Sub AddExtrusionPiece(EdgeUses As ObjectCollection, Direction As UnitVector, Result As [out, retval] long)
Parameters
Parameters | Description
EdgeUses | Input ObjectCollection of EdgeUse objects that define the curve(s) to use to create the runoff extrusion. The object collection can contain one or more EdgeUse objects.
Direction | Input UnitVector that defines the direction of the extrusion. The length of the extrusion is defined by the range box associated with the RunoffSurfaceDefinition.
Remarks

This method returns the index identifying this piece of the runoff.

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods > RunoffSurfaceDefinition.AddExtrusionPiece Method


RunoffSurfaceDefinition.AddRadiatePiece Method

RunoffSurfaceDefinition.AddRadiatePiece Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that adds an extrusion type of runoff surface to this runoff surface definition.

Visual Basic
Sub AddRadiatePiece(EdgeUse As IDispatch, RulingPoints As ObjectCollection, RulingVectors As ObjectCollection, Result As [out, retval] long)
Parameters
Parameters | Description
EdgeUse | Input EdgeUse object that defines the curve to use to create the radiate runoff piece.
RulingPoints | Input ObjectCollection of Point objects. These are points along the input edge where you want to define a ruling condition. For each point in this collection there must be a matching vector supplied in the RulingVectors argument.
RulingVectors | Input ObjectCollection of UnitVector objects. These are vectors that define the radiate direction. These vectors match up with the ruling points to define a position along the curve and a direction for the ruling. This collection must contain the same number of vectors as there are points in the ObjectCollection supplied for the RulingPoints argument.
Remarks

This method returns the index identifying this piece of the runoff.

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods > RunoffSurfaceDefinition.AddRadiatePiece Method


RunoffSurfaceDefinition.AddSurfaceExtensionPiece Method

RunoffSurfaceDefinition.AddSurfaceExtensionPiece Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a runoff piece by extending the face attached to the input EdgeUse object.

Visual Basic
Sub AddSurfaceExtensionPiece(EdgeUse As IDispatch, Result As [out, retval] long)
Parameters
Parameters | Description
EdgeUse | Input EdgeUse object that defines the surface to extend.
Remarks

The surface must be a ruled in the U or V direction, and the extension will be in the direction the ruling. If the surface is ruled in both the U and V directions, Inventor will use a heuristic to determine which direction to extend in. The length of the extension is determined by the range box of the run off definition. This method returns the index identifying this piece of the runoff.

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods > RunoffSurfaceDefinition.AddSurfaceExtensionPiece Method


RunoffSurfaceDefinition.CreateRunoff Method

RunoffSurfaceDefinition.CreateRunoff Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates the runoff surface for all of the pieces defined in the RunoffSurfaceDefinition object.

Visual Basic
Sub CreateRunoff(Result As [out, retval] SurfaceBody*)
Remarks

These are all of the pieces added to the RunoffSurfaceDefinition object using the AddExtrusionPiece, AddRadiatePiece, AddSurfaceExtensionPiece, and the AddCornerPiece methods. The resulting transient B-Rep SurfaceBody object is returned.

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods > RunoffSurfaceDefinition.CreateRunoff Method


RunoffSurfaceDefinition.CreateSingleRunoffPiece Method

RunoffSurfaceDefinition.CreateSingleRunoffPiece Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates the runoff surface for a single piece of the runoff definition.

Visual Basic
Sub CreateSingleRunoffPiece(Index As long, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
index | Input Long that specifies the index of the runoff piece you want to create. This is the index that was returned by the call to the AddExtrusionPiece, AddRadiatePiece, AddSurfaceExtensionPiece, or AddCornerPiece method.
Remarks

The resulting transient B-Rep SurfaceBody object is returned.

You are here: Symbol Reference > Inventor Library > Objects > RunoffSurfaceDefinition Interface > RunoffSurfaceDefinition Methods > RunoffSurfaceDefinition.CreateSingleRunoffPiece Method


SaveOptions Interface

SaveOptions Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SaveOptions object provides access to properties that provide read and write access of the save related application options. This is somewhat equivalent to the Save tab of the Application Options dialog.

Class Hierarchy
Inventor::SaveOptions
Visual Basic
Public Interface SaveOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.SaveOptions

You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface


SaveOptions Properties

SaveOptions Properties
Summary

The properties of the SaveOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ListReferencedFilesInSaveDialog | Property that specifies whether referenced documents with minor changes that result in little or no loss of design intent should be listed in the Save dialog box when the referencing document is saved.
PromptSaveForMigration | Property that specifies whether a prompt to save the document should be displayed when a document that has been migrated from a previous version of Autodesk Inventor is closed without being explicitly saved.
PromptSaveForRecomputableChanges | Property that specifies whether a prompt to save the document should be displayed when the document is closed without being explicitly saved after any recomputable changes.
SaveReminderTimer | Property that gets and sets the save reminder timer (in minutes), indicating the frequency of the save reminder display for dirty documents.
ShowSaveReminder | Property that gets and sets whether to display a save reminder to the user.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties


SaveOptions.Application Property

SaveOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.Application Property


SaveOptions.ListReferencedFilesInSaveDialog Property

SaveOptions.ListReferencedFilesInSaveDialog Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether referenced documents with minor changes that result in little or no loss of design intent should be listed in the Save dialog box when the referencing document is saved.

Visual Basic
Property ListReferencedFilesInSaveDialog() As VARIANT_BOOL
Remarks

This property corresponds to the 'Don't list referenced files that default to 'No' in the Save dialog' checkbox on the Save tab of the Application Options dialog.

The minor changes that result in little or no loss of design intent can be recomputed later when the referenced documents are opened again, thus restoring them to the current state, hence these documents will default to No (Don't Save) in the Save dialog when the referencing document is saved. The default option of No can be changed to Yes (Save) in the Save dialog if the referenced documents need to be saved immediately.

A value of True for this property specifies that referenced documents with recomputable changes should continue to be listed in the Save dialog box when a referencing document is saved, but they will default to No (Don't Save). A value of False specifies that such referenced documents should not be listed in the Save Dialog box list implying that they will not be saved immediately but, these changes can be recomputed and if needed, saved later when the documents are opened again.

You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.ListReferencedFilesInSaveDialog Property


SaveOptions.PromptSaveForMigration Property

SaveOptions.PromptSaveForMigration Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether a prompt to save the document should be displayed when a document that has been migrated from a previous version of Autodesk Inventor is closed without being explicitly saved.

Visual Basic
Property PromptSaveForMigration() As VARIANT_BOOL
Remarks

A value of True indicates that the prompt to save the migrated document should be displayed.

You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.PromptSaveForMigration Property


SaveOptions.PromptSaveForRecomputableChanges Property

SaveOptions.PromptSaveForRecomputableChanges Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether a prompt to save the document should be displayed when the document is closed without being explicitly saved after any recomputable changes.

Visual Basic
Property PromptSaveForRecomputableChanges() As VARIANT_BOOL
Remarks

The changes that are considered to be recomputable are:

  • system resolved file references
  • audit
  • mass properties update
  • drawing view update
  • migration

These changes, if not saved immediately, can be recomputed later when the document is opened again.

A value of True specifies that the prompt should be displayed. A value of False specifies that the prompt should not be displayed implying that it is acceptable for these changes to be recomputed when the document is opened later instead of them being saved immediately.

You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.PromptSaveForRecomputableChanges Property


SaveOptions.SaveReminderTimer Property

SaveOptions.SaveReminderTimer Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the save reminder timer (in minutes), indicating the frequency of the save reminder display for dirty documents.

Visual Basic
Property SaveReminderTimer() As double
You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.SaveReminderTimer Property


SaveOptions.ShowSaveReminder Property

SaveOptions.ShowSaveReminder Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to display a save reminder to the user.

Visual Basic
Property ShowSaveReminder() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.ShowSaveReminder Property


SaveOptions.Type Property

SaveOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SaveOptions Interface > SaveOptions Properties > SaveOptions.Type Property


SculptFeature Interface

SculptFeature Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SculptFeature object represents sculpt modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::SculptFeature
        Inventor::SculptFeatureProxy
Visual Basic
Public Interface SculptFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

SculptFeatureProxy.NativeObject

SculptFeatures.Add

SculptFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > SculptFeature Interface


SculptFeature Properties

SculptFeature Properties
Summary

The properties of the SculptFeature class are listed here.

Properties
Name | Description
Operation | Property that gets and sets the type of operation. Valid values are kJoinOperation (for adding material to existing body), kCutOperation (for removing material) and kNewBodyOperation (for creating a new body).
Surfaces | Property that gets and sets the set of surfaces and their respective directions associated with the sculpt feature.
You are here: Symbol Reference > Inventor Library > Objects > SculptFeature Interface > SculptFeature Properties


SculptFeature.Operation Property

SculptFeature.Operation Property
Summary

Property that gets and sets the type of operation. Valid values are kJoinOperation (for adding material to existing body), kCutOperation (for removing material) and kNewBodyOperation (for creating a new body).

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > SculptFeature Interface > SculptFeature Properties > SculptFeature.Operation Property


SculptFeature.Surfaces Property

SculptFeature.Surfaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the set of surfaces and their respective directions associated with the sculpt feature.

Visual Basic
Property Surfaces() As ObjectCollection*
Remarks

This property returns an ObjectCollection that contains SculptSurface objects that represent the set of surfaces and the corresponding directions used to create the sculpt feature.

The ObjectCollection returned by this property represents a copy of the surfaces used by the sculpt feature and does not affect the sculpt feature if its contents are modified. To change which surfaces are used by the sculpt feature, you need to set this property to an ObjectCollection that contains the desired set of SculptSurface objects that represent the new set of surfaces.

You are here: Symbol Reference > Inventor Library > Objects > SculptFeature Interface > SculptFeature Properties > SculptFeature.Surfaces Property


SculptFeatureProxy Interface

SculptFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SculptFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::SculptFeature
        Inventor::SculptFeatureProxy
Visual Basic
Public Interface SculptFeatureProxy
Inherits SculptFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SculptFeatureProxy Interface


SculptFeatureProxy Properties

SculptFeatureProxy Properties
Summary

The properties of the SculptFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject |
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatureProxy Interface > SculptFeatureProxy Properties


SculptFeatureProxy.ContainingOccurrence Property

SculptFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SculptFeatureProxy Interface > SculptFeatureProxy Properties > SculptFeatureProxy.ContainingOccurrence Property


SculptFeatureProxy.NativeObject Property

SculptFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Property NativeObject() As SculptFeature**
Notes

For information on this item, please refer to SurfaceBodyProxy::NativeObject, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SculptFeatureProxy Interface > SculptFeatureProxy Properties > SculptFeatureProxy.NativeObject Property


SculptFeatures Interface

SculptFeatures Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SculptFeatures collection object provides access to all of the SculptFeature objects in a part component definition and provides methods to create additional SculptFeatures.

Class Hierarchy
Inventor::SculptFeatures
Visual Basic
Public Interface SculptFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.SculptFeatures

You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface


SculptFeatures Methods

SculptFeatures Methods
Summary

The methods of the SculptFeatures class are listed here.

Methods
Methods
Name | Description
_Add | This is _Add, a member of class SculptFeatures.
Add | Method that creates a new SculptFeature. If the sculpt feature is created successfully, a SculptFeature object corresponding to the newly created sculpt feature is returned from this method.
CreateSculptSurface | Method that creates a new SculptSurface object. The new SculptSurface is returned.
Item | Method that returns the specified SculptFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Methods


SculptFeatures._Add Method

SculptFeatures._Add Method
Summary

This is _Add, a member of class SculptFeatures.

Visual Basic
Sub _Add(Surfaces As ObjectCollection, FillOperation As VARIANT_BOOL, Result As [out, retval] SculptFeature*)
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Methods > SculptFeatures._Add Method


SculptFeatures.Add Method

SculptFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new SculptFeature. If the sculpt feature is created successfully, a SculptFeature object corresponding to the newly created sculpt feature is returned from this method.

Visual Basic
Sub Add(Surfaces As ObjectCollection, Operation As PartFeatureOperationEnum, ByRef AffectedBody As [optional] VARIANT, Result As [out, retval] SculptFeature*)
Parameters
Parameters | Description
Surfaces | ObjectCollection that contains SculptSurface objects that represent the set of surfaces and the corresponding directions that are required to create the sculpt feature. The CreateSculptSurface method should be used to create each of the SculptSurface objects which should then be added to an ObjectCollection. The ObjectCollection that contains these SculptSurface objects can be created using the CreateObjectCollection method of the TransientObjects object. The ObjectCollection should contain only SculptSurface objects, if the collection contains other types of objects, then the creation of the sculpt feature will fail.
FillOperation | Boolean that specifies whether the fill operation should be performed to add material for the sculpt feature. If True is specified, then the fill operation will be performed to add material. If False is specified, then the drain operation will be performed to remove material. If False is specified, then the part model should contain solid material that can be removed, if the model does not contain solid material, then the creation of the sculpt feature will fail.
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Methods > SculptFeatures.Add Method


SculptFeatures.CreateSculptSurface Method

SculptFeatures.CreateSculptSurface Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new SculptSurface object. The new SculptSurface is returned.

Visual Basic
Sub CreateSculptSurface(Surface As IDispatch, ByRef Direction As [defaultvalue(kPositiveExtentDirection)] PartFeatureExtentDirectionEnum, Result As [out, retval] SculptSurface*)
Parameters
Parameters | Description
Surface | Object that defines a boundary surface for the sculpt feature. Valid input objects for the surface are WorkSurface and WorkPlane.
Direction | Optional input constant that specifies the sculpt direction for the surface specified by the Surface argument. The direction specifies the side of the surface that should be used when creating the sculpt feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection. If no value is specified, then kPositiveExtentDirection will be assumed for the direction.
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Methods > SculptFeatures.CreateSculptSurface Method


SculptFeatures.Item Method

SculptFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified SculptFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SculptFeature*)
Parameters
Parameters | Description
index | Value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Methods > SculptFeatures.Item Method


SculptFeatures Properties

SculptFeatures Properties
Summary

The properties of the SculptFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Properties


SculptFeatures.Application Property

SculptFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Properties > SculptFeatures.Application Property


SculptFeatures.Count Property

SculptFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Properties > SculptFeatures.Count Property


SculptFeatures.Type Property

SculptFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SculptFeatures Interface > SculptFeatures Properties > SculptFeatures.Type Property


SculptSurface Interface

SculptSurface Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SculptSurface object provides access to a sculpt surface and its associated direction. The surface defines a boundary of the sculpt feature and the associated direction defines the side of the surface used to create the sculpt feature.

Class Hierarchy
Inventor::SculptSurface
Visual Basic
Public Interface SculptSurface
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SculptFeatures.CreateSculptSurface

You are here: Symbol Reference > Inventor Library > Objects > SculptSurface Interface


SculptSurface Properties

SculptSurface Properties
Summary

The properties of the SculptSurface class are listed here.

Properties
Name | Description
Direction | Property that gets and sets the direction associated with the surface.
Surface | Property that gets and sets a boundary surface for the sculpt feature.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > SculptSurface Interface > SculptSurface Properties


SculptSurface.Direction Property

SculptSurface.Direction Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the direction associated with the surface.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
Remarks

This property returns the current sculpt direction that specifies the side of the surface that has been used for the sculpt feature.

This property can also be used to specify a new sculpt direction for the surface. The valid input for specifying a new direction is kPositiveExtentDirection, kNegativeExtentDirection or kSymmetricExtentDirection.

You are here: Symbol Reference > Inventor Library > Objects > SculptSurface Interface > SculptSurface Properties > SculptSurface.Direction Property


SculptSurface.Surface Property

SculptSurface.Surface Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets a boundary surface for the sculpt feature.

Visual Basic
Property Surface() As IDispatch*
Remarks

This property returns the WorkSurface or WorkPlane object that represents the surface.

This property can also be used to specify a new WorkSurface or WorkPlane object that represents another surface to replace the existing one.

You are here: Symbol Reference > Inventor Library > Objects > SculptSurface Interface > SculptSurface Properties > SculptSurface.Surface Property


SculptSurface.Type Property

SculptSurface.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SculptSurface Interface > SculptSurface Properties > SculptSurface.Type Property


SectionDrawingView Interface

SectionDrawingView Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SectionDrawingView object represents a section view within a drawing. See the article in the overviews section.

Class Hierarchy
Inventor::DrawingView
    Inventor::SectionDrawingView
Visual Basic
Public Interface SectionDrawingView
Inherits DrawingView
Notes

Members through which this object may be accessed include:

DrawingViews.AddSectionView

For information on this object, please refer to DrawingView, which provides identical or very similar functionality.

Example

"Break alignment of a section view"

Sample showing how to break the alignment of a drawing section view by calling the DrawingBreakViewAlignment command.

Sub BreakAlignment()

Dim oDoc As DrawingDocument
Set oDoc = ThisApplication.ActiveDocument

Dim oSectionView As SectionDrawingView
Set oSectionView = oDoc.ActiveSheet.DrawingViews(2)

oDoc.SelectSet.Clear
oDoc.SelectSet.Select oSectionView

Dim oCtrlDef As ControlDefinition
Set oCtrlDef = ThisApplication.CommandManager.ControlDefinitions.Item("DrawingBreakViewAlignmentCmd")

oCtrlDef.Execute

oDoc.SelectSet.Clear
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface


SectionDrawingView Methods

SectionDrawingView Methods
Summary

The methods of the SectionDrawingView class are listed here.

Methods
Methods
Name | Description
ReverseDirection | Method that reverses the section line direction.
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Methods


SectionDrawingView.ReverseDirection Method

SectionDrawingView.ReverseDirection Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that reverses the section line direction.

Visual Basic
Sub ReverseDirection()
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Methods > SectionDrawingView.ReverseDirection Method


SectionDrawingView Properties

SectionDrawingView Properties
Summary

The properties of the SectionDrawingView class are listed here.

Properties
Name | Description
FullSectionDepth | Property that gets and sets whether to section all geometry beyond the cutting line. If set to False, the SectionDepth property specifies a distance of viewing beginning from the cutting line. Setting the SectionDepth property automatically toggles this property to False. This property does not apply (and setting it returns an error) if the SliceAllParts property is set to True.
IncludeSlice | Property that gets and sets whether some components are sliced and some components are sectioned, depending on their individual settings.
SectionDepth | Property that gets and sets the section depth in centimeters. Setting this property automatically toggles the FullSectionDepth property to False. Setting the property to a value between 0 and 0.00003 sets the depth to the smallest available section depth value of 0.00003. This property does not apply (and setting it returns an error) if the SliceAllParts property is set to True.
SectionLineSketch | Gets the object that contains the profile used to define the section line of the view.
ShowEntireLine | Property that indicates whether to show the entire section line or hide parts of it.
SliceAllParts | Property that gets and sets whether to override all individual settings and slice all components in the view according to the Section Line geometry. Components that are not crossed by the Section Line will not participate in the resulting view. Setting this property to True automatically toggles the IncludeSlice property to True. This property does not apply (and setting it returns an error) for drawing views of a part.
UseAlignedMethod | Property that gets and sets whether to use the projected or the aligned method.
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties


SectionDrawingView.FullSectionDepth Property

SectionDrawingView.FullSectionDepth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to section all geometry beyond the cutting line. If set to False, the SectionDepth property specifies a distance of viewing beginning from the cutting line. Setting the SectionDepth property automatically toggles this property to False. This property does not apply (and setting it returns an error) if the SliceAllParts property is set to True.

Visual Basic
Property FullSectionDepth() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.FullSectionDepth Property


SectionDrawingView.IncludeSlice Property

SectionDrawingView.IncludeSlice Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether some components are sliced and some components are sectioned, depending on their individual settings.

Visual Basic
Property IncludeSlice() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.IncludeSlice Property


SectionDrawingView.SectionDepth Property

SectionDrawingView.SectionDepth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the section depth in centimeters. Setting this property automatically toggles the FullSectionDepth property to False. Setting the property to a value between 0 and 0.00003 sets the depth to the smallest available section depth value of 0.00003. This property does not apply (and setting it returns an error) if the SliceAllParts property is set to True.

Visual Basic
Property SectionDepth() As double
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.SectionDepth Property


SectionDrawingView.SectionLineSketch Property

SectionDrawingView.SectionLineSketch Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object that contains the profile used to define the section line of the view.

Visual Basic
Property SectionLineSketch() As DrawingSketch**
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.SectionLineSketch Property


SectionDrawingView.ShowEntireLine Property

SectionDrawingView.ShowEntireLine Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates whether to show the entire section line or hide parts of it.

Visual Basic
Property ShowEntireLine() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.ShowEntireLine Property


SectionDrawingView.SliceAllParts Property

SectionDrawingView.SliceAllParts Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to override all individual settings and slice all components in the view according to the Section Line geometry. Components that are not crossed by the Section Line will not participate in the resulting view. Setting this property to True automatically toggles the IncludeSlice property to True. This property does not apply (and setting it returns an error) for drawing views of a part.

Visual Basic
Property SliceAllParts() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.SliceAllParts Property


SectionDrawingView.UseAlignedMethod Property

SectionDrawingView.UseAlignedMethod Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to use the projected or the aligned method.

Visual Basic
Property UseAlignedMethod() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SectionDrawingView Interface > SectionDrawingView Properties > SectionDrawingView.UseAlignedMethod Property


SelectEvents CoClass

SelectEvents CoClass Available in Inventor Introduced in Inventor 5
Summary

The SelectEvents object supports a set of events that are fired when the user is selecting geometry. These events are fired when the user is selecting items from various UI elements such as the graphics window or the browser.

Class Hierarchy
Inventor::SelectEvents
Visual Basic
Public Class SelectEvents
Remarks

The semantics and functioning is distinct from the MouseEvents in that the events are fired only when something interesting happens that has to do with a user-selection. Autodesk Inventor is now in a selection and its UI gets geared up for that. This eventset is mutually exclusive with the MouseEvents. See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

InteractionEventsObject.SelectEvents

See Also

Window Selection sample

Selection Simple sample

Example

See InteractionEvents for example "InteractionEvents Object"

You are here: Symbol Reference > Inventor Library > Objects > SelectEvents CoClass


SelectEventsObject Interface

SelectEventsObject Interface Available in Inventor Introduced in Inventor 5
Summary

The SelectEvents object supports a set of events that are fired when the user is selecting geometry. These events are fired when the user is selecting items from various UI elements such as the graphics window or the browser.

Class Hierarchy
Inventor::SelectEventsObject
Visual Basic
Public Interface SelectEventsObject
Inherits IDispatch
Remarks

The semantics and functioning is distinct from the MouseEvents in that the events are fired only when something interesting happens that has to do with a user-selection. Autodesk Inventor is now in a selection and its UI gets geared up for that. This eventset is mutually exclusive with the MouseEvents. See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

See Also

Window Selection sample

Example

See InteractionEvents for example "InteractionEvents Object"

You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface


SelectEventsObject Methods

SelectEventsObject Methods
Summary

The methods of the SelectEventsObject class are listed here.

Methods
Methods
Name | Description
AddSelectionFilter | Method that adds a specific type of filter to the existing list of filters. This means that Autodesk Inventor will look for this kind of object(s) as well during the selection process. Objects excluded by virtue of not being in the filter list will not become candidates for selection.
AddToSelectedEntities | Method that adds an entity to the selected entities collection.
AddWindowSelectionFilter | Method that adds a specific type of filter to the existing list of filters for window (area) select.
ClearSelectionFilter | Method that clears the select filter list.
ClearWindowSelectionFilter | Method that clears the select filter list for window (area) select.
RemoveFromSelectedEntities | Method that removes the specified entity from the selected entities collection.
ResetSelections | Method that clears the current set of selections being maintained by Autodesk Inventor. It does not reset the selection filters. To clear those, call ClearSelectFilterList. When invoked, the event set behaves as if we were starting the selection for the first time, with the current set of filters in place.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods


SelectEventsObject.AddSelectionFilter Method

SelectEventsObject.AddSelectionFilter Method Available in Inventor Introduced in Inventor 5
Summary

Method that adds a specific type of filter to the existing list of filters. This means that Autodesk Inventor will look for this kind of object(s) as well during the selection process. Objects excluded by virtue of not being in the filter list will not become candidates for selection.

Visual Basic
Sub AddSelectionFilter(Filter As SelectionFilterEnum)
Parameters
Parameters | Description
Filter | Input value to be added to the list that specifies the filter or the indication of the type of object(s) being looked for. The valid filters for sketch profile selection are kSketchProfileFilter, kSketch3DProfileFilter or both. If either of these filters is added, no other filters can be added (method returns an error). If any filter other than these two are already added, adding these filters return an error.
See Also

Window Selection sample

You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.AddSelectionFilter Method


SelectEventsObject.AddToSelectedEntities Method

SelectEventsObject.AddToSelectedEntities Method Available in Inventor Introduced in Inventor 6
Summary

Method that adds an entity to the selected entities collection.

Visual Basic
Sub AddToSelectedEntities(ItemObject As IDispatch)
Parameters
Parameters | Description
ItemObject | Input object to add to the collection.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.AddToSelectedEntities Method


SelectEventsObject.AddWindowSelectionFilter Method

SelectEventsObject.AddWindowSelectionFilter Method Available in Inventor Introduced in Inventor 2009
Summary

Method that adds a specific type of filter to the existing list of filters for window (area) select.

Visual Basic
Sub AddWindowSelectionFilter(Filter As SelectionFilterEnum)
Parameters
Parameters | Description
Filter | Input value to be added to the list that specifies the filter or the indication of the type of object(s) being looked for.
Remarks

Objects excluded by virtue of not being in the filter list will not become candidates for selection. If none are specified, defaults to the same filters in effect for general selection. As an example, the Inventor Stitch command allows selecting either faces or bodies, but filters for bodies only in window select.

You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.AddWindowSelectionFilter Method


SelectEventsObject.ClearSelectionFilter Method

SelectEventsObject.ClearSelectionFilter Method Available in Inventor Introduced in Inventor 5
Summary

Method that clears the select filter list.

Visual Basic
Sub ClearSelectionFilter()
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.ClearSelectionFilter Method


SelectEventsObject.ClearWindowSelectionFilter Method

SelectEventsObject.ClearWindowSelectionFilter Method Available in Inventor Introduced in Inventor 2009
Summary

Method that clears the select filter list for window (area) select.

Visual Basic
Sub ClearWindowSelectionFilter()
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.ClearWindowSelectionFilter Method


SelectEventsObject.RemoveFromSelectedEntities Method

SelectEventsObject.RemoveFromSelectedEntities Method Available in Inventor Introduced in Inventor 2009
Summary

Method that removes the specified entity from the selected entities collection.

Visual Basic
Sub RemoveFromSelectedEntities(ItemObject As IDispatch)
Remarks

Input object that specifies the object to remove from the selected entities collection.

You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.RemoveFromSelectedEntities Method


SelectEventsObject.ResetSelections Method

SelectEventsObject.ResetSelections Method Available in Inventor Introduced in Inventor 5
Summary

Method that clears the current set of selections being maintained by Autodesk Inventor. It does not reset the selection filters. To clear those, call ClearSelectFilterList. When invoked, the event set behaves as if we were starting the selection for the first time, with the current set of filters in place.

Visual Basic
Sub ResetSelections()
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Methods > SelectEventsObject.ResetSelections Method


SelectEventsObject Properties

SelectEventsObject Properties
Summary

The properties of the SelectEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Enabled | Property that gets and sets whether SelectEvents is enabled.
IgnoreProfileInnerLoops | Property that gets and sets whether to ignore inner loops during 2d and 3d sketch profile selection. This property defaults to False.
MouseMoveEnabled | Property that gets and sets whether the OnPreSelectMouseMove event is fired or not. If you don't need move events you can use this property to disable them and increase performance.
Parent | Property that returns the parent document of the object.
PreSelectBurnThrough | Property that indicates a flag indicating whether the preselected items will burn through (i.e. always be visible even when blocked by other objects).
RestrictSelectionToOccurrence | Property that sets the to which the selection should be restricted.
SelectedEntities | Property that returns collection of objects currently selected.
SingleSelectEnabled | Property that indicates the Boolean flag indicating whether single select is enabled.
Type | Property returning an enum indicating this object's type.
WindowSelectEnabled | Property that gets and sets whether window (area) select is enabled.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties


SelectEventsObject.Application Property

SelectEventsObject.Application Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.Application Property


SelectEventsObject.Enabled Property

SelectEventsObject.Enabled Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets whether SelectEvents is enabled.

Visual Basic
Property Enabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.Enabled Property


SelectEventsObject.IgnoreProfileInnerLoops Property

SelectEventsObject.IgnoreProfileInnerLoops Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether to ignore inner loops during 2d and 3d sketch profile selection. This property defaults to False.

Visual Basic
Property IgnoreProfileInnerLoops() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.IgnoreProfileInnerLoops Property


SelectEventsObject.MouseMoveEnabled Property

SelectEventsObject.MouseMoveEnabled Property Available in Inventor Introduced in Inventor 5
Summary

Property that gets and sets whether the OnPreSelectMouseMove event is fired or not. If you don't need move events you can use this property to disable them and increase performance.

Visual Basic
Property MouseMoveEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.MouseMoveEnabled Property


SelectEventsObject.Parent Property

SelectEventsObject.Parent Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the parent document of the object.

Visual Basic
Property Parent() As InteractionEvents**
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.Parent Property


SelectEventsObject.PreSelectBurnThrough Property

SelectEventsObject.PreSelectBurnThrough Property Available in Inventor Introduced in Inventor 7
Summary

Property that indicates a flag indicating whether the preselected items will burn through (i.e. always be visible even when blocked by other objects).

Visual Basic
Property PreSelectBurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.PreSelectBurnThrough Property


SelectEventsObject.RestrictSelectionToOccurrence Property

SelectEventsObject.RestrictSelectionToOccurrence Property Available in Inventor Introduced in Inventor 6
Summary

Property that sets the to which the selection should be restricted.

Visual Basic
Property RestrictSelectionToOccurrence() As ComponentOccurrence*
Parameters
Parameters | Description
RHS | The ComponentOccurrence to which the selection should be restricted.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.RestrictSelectionToOccurrence Property


SelectEventsObject.SelectedEntities Property

SelectEventsObject.SelectedEntities Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns collection of objects currently selected.

Visual Basic
Property SelectedEntities() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.SelectedEntities Property


SelectEventsObject.SingleSelectEnabled Property

SelectEventsObject.SingleSelectEnabled Property Available in Inventor Introduced in Inventor 6
Summary

Property that indicates the Boolean flag indicating whether single select is enabled.

Visual Basic
Property SingleSelectEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.SingleSelectEnabled Property


SelectEventsObject.Type Property

SelectEventsObject.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.Type Property


SelectEventsObject.WindowSelectEnabled Property

SelectEventsObject.WindowSelectEnabled Property Available in Inventor Introduced in Inventor 2009
Summary

Property that gets and sets whether window (area) select is enabled.

Visual Basic
Property WindowSelectEnabled() As VARIANT_BOOL
Remarks

Defaults to False. User can use Shift and Ctrl keys to modify the selections. Enabling window select automatically disables single select.

Example

"Window Selection"

This sample demonstrates using the selection events to window-select multiple edges. Selection is dependent on events and VB only supports events within a class module. To use the sample copy the TestWindowSelection sub into a code module. Create a new class module called clsSelect and copy all of the rest of the code into it. To run the sample, have a part document open that contains some geometry and run the TestWindowSelection sub.

Private oSelect As clsSelect
Public Sub TestWindowSelection()

' Create a new clsSelect object.
Set oSelect = New clsSelect

' Call the WindowSelect method of the clsSelect object
oSelect.WindowSelect

End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsSelect". The name can be
' changed but you'll need to change the declaration in the
' calling function "TestWindowSelection" to use the new name.

' Declare the event objects
Private WithEvents oInteractEvents As InteractionEvents
Private WithEvents oSelectEvents As SelectEvents

' Declare a flag that's used to determine if command prompts are shown as tooltips.
Private bTooltipEnabled As Boolean

Public Function WindowSelect()

' Create an InteractionEvents object.
Set oInteractEvents = ThisApplication.CommandManager.CreateInteractionEvents

' Ensure interaction is enabled.
oInteractEvents.InteractionDisabled = False

' Set a reference to the select events.
Set oSelectEvents = oInteractEvents.SelectEvents

' Set the filter for circular edges (this includes circular arcs).
oSelectEvents.AddSelectionFilter kPartEdgeCircularFilter

oSelectEvents.WindowSelectEnabled = True

bTooltipEnabled = ThisApplication.GeneralOptions.ShowCommandPromptTooltips
ThisApplication.GeneralOptions.ShowCommandPromptTooltips = True

oInteractEvents.StatusBarText = "Window select. Esc to exit."

' Start the InteractionEvents object.
oInteractEvents.Start

End Function

Private Sub oInteractEvents_OnTerminate()

' Reset to original value
ThisApplication.GeneralOptions.ShowCommandPromptTooltips = bTooltipEnabled

' Clean up.
Set oSelectEvents = Nothing
Set oInteractEvents = Nothing
End Sub

Private Sub oSelectEvents_OnPreSelect(PreSelectEntity As Object, DoHighlight As Boolean, MorePreSelectEntities As ObjectCollection, ByVal SelectionDevice As SelectionDeviceEnum, ByVal ModelPosition As Point, ByVal ViewPosition As Point2d, ByVal View As View)

' Set a reference to the selected edge.
' Only circular edges can come through since the circular edge filter was set.
Dim oEdge As Edge
Set oEdge = PreSelectEntity

' Allow only fully circular edges to be picked.
If Not oEdge.GeometryType = kCircleCurve Then
  DoHighlight = False
End If

End Sub

Private Sub oSelectEvents_OnSelect(ByVal JustSelectedEntities As ObjectsEnumerator, ByVal SelectionDevice As SelectionDeviceEnum, ByVal ModelPosition As Point, ByVal ViewPosition As Point2d, ByVal View As View)

MsgBox "Picked " & JustSelectedEntities.Count & " circular edges."
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsObject Interface > SelectEventsObject Properties > SelectEventsObject.WindowSelectEnabled Property


SelectEventsSink Interface

SelectEventsSink Interface Available in Inventor Introduced in Inventor 5
Summary

The SelectEvents object supports a set of events that are fired when the user is selecting geometry. These events are fired when the user is selecting items from various UI elements such as the graphics window or the browser.

Class Hierarchy
Inventor::SelectEventsSink
Visual Basic
Public Interface SelectEventsSink
Inherits IDispatch
Remarks

The semantics and functioning is distinct from the MouseEvents in that the events are fired only when something interesting happens that has to do with a user-selection. Autodesk Inventor is now in a selection and its UI gets geared up for that. This eventset is mutually exclusive with the MouseEvents. See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

Example

See InteractionEvents for example "InteractionEvents Object"

You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface


SelectEventsSink Methods

SelectEventsSink Methods
Summary

The methods of the SelectEventsSink class are listed here.

Methods
Methods
Name | Description
OnPreSelect | Event that occurs as the user moves the mouse over entities that are valid for selection based on the current selection filter.
OnPreSelectMouseMove | Event that occurs while an object is in pre-select mode and the user is moving the mouse. This allows you to receive mouse input relative to the pre-selected object.
OnSelect | Event that occurs when the user selects an entity.
OnStopPreSelect | Event that occurs when the currently pre-selected entity stops being displayed in pre-selection highlight--happens usually when the user has moved his/her mouse away from the vicinity of the pre-selected entity. This way, the client programmer has the ability to display additional graphics on pre-select and with the OnStopPreSelect knows when to stop displaying this additional graphics. An example can be seen in the Sketch trim command. As you move the mouse over some sketch graphics, you see the preview of what the result will be if you select the object and when you move away this trimmed preview is taken... more
OnUnSelect | Event that occurs when the user unselects an entity. This is done in the user interface by pressing the Shift button and selecting a previously selected entity.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface > SelectEventsSink Methods


SelectEventsSink.OnPreSelect Method

SelectEventsSink.OnPreSelect Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs as the user moves the mouse over entities that are valid for selection based on the current selection filter.

Visual Basic
Sub OnPreSelect(ByRef PreSelectEntity As IDispatch*, ByRef DoHighlight As VARIANT_BOOL, ByRef MorePreSelectEntities As [unique] ObjectCollection*, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
PreSelectEntity | Input/Output. When called, Inventor returns the entity the mouse is currently over. The client though has a chance to change this entity to some other, if so desired. The entity passed back from the call is the one Inventor will highlight for the pre-select.
DoHighlight | Input value that specifies whether the entity should be available for selection or not. If True, this signifies a successful pre-selection and the entity is highlighted by Inventor.
MorePreSelectEntities | Input argument through which you can supply a group of objects that are logically pre-selected along with the one that Inventor found on its own. This argument is ignored if DoHighLight is False. Inventor passes in an empty collection that you can add additional entities to.
SelectionDevice | Returns a constant denoting whether the selection was made via a pick in a graphics window or was it by a pick in the browser or by some other means. An object can also be selected programmatically by calling the selection simulation methods on the CommandManager. A value of kGraphicsWindowSelection indicates it was selected in a graphic window. For all other values the View, ModelPosition, and ViewPosition arguments are meaningless.
ModelPosition | Returns the coordinates that result from projecting the click point onto the selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
Remarks

This event is fired before the object is highlighted, giving the programmer the opportunity to apply further custom filtering. By responding with False to the DoHighlight argument, the object will not be available for selection and the UI behaves as if the object was never considered for selection.

You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface > SelectEventsSink Methods > SelectEventsSink.OnPreSelect Method


SelectEventsSink.OnPreSelectMouseMove Method

SelectEventsSink.OnPreSelectMouseMove Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs while an object is in pre-select mode and the user is moving the mouse. This allows you to receive mouse input relative to the pre-selected object.

Visual Basic
Sub OnPreSelectMouseMove(PreSelectEntity As IDispatch, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
PreSelectEntity | Input argument that specifies the object currently pre-selected.
ModelPosition | Returns the coordinates that result from projecting the current location of the mouse onto the selected entity. This is returned in centimeters relative to model space.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels.
View | Returns the View object where the selection took place.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface > SelectEventsSink Methods > SelectEventsSink.OnPreSelectMouseMove Method


SelectEventsSink.OnSelect Method

SelectEventsSink.OnSelect Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user selects an entity.

Visual Basic
Sub OnSelect(JustSelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
JustSelectedEntities | Returns the object(s) that were just selected by the user. This may be the only one selected so far or the latest one in a series during this selection process. Multiple objects may be returned if the user does a window (area) select.
SelectionDevice | Input constant denoting whether the selection was made via a pick in a graphics window or was it by a pick in the browser or by some other means. An object can also be selected programmatically by calling the selection simulation methods on the CommandManager. A value of kGraphicsWindowSelection indicates it was selected in a graphic window. For all other values the View, ModelPosition, and ViewPosition arguments are meaningless.
ModelPosition | Returns the coordinates that result from projecting the click point onto the selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface > SelectEventsSink Methods > SelectEventsSink.OnSelect Method


SelectEventsSink.OnStopPreSelect Method

SelectEventsSink.OnStopPreSelect Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the currently pre-selected entity stops being displayed in pre-selection highlight--happens usually when the user has moved his/her mouse away from the vicinity of the pre-selected entity. This way, the client programmer has the ability to display additional graphics on pre-select and with the OnStopPreSelect knows when to stop displaying this additional graphics. An example can be seen in the Sketch trim command. As you move the mouse over some sketch graphics, you see the preview of what the result will be if you select the object and when you move away this trimmed preview is taken away.

Visual Basic
Sub OnStopPreSelect(ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
ModelPosition | Returns the coordinates that result from projecting the click point onto the selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface > SelectEventsSink Methods > SelectEventsSink.OnStopPreSelect Method


SelectEventsSink.OnUnSelect Method

SelectEventsSink.OnUnSelect Method Available in Inventor Introduced in Inventor 5
Summary

Event that occurs when the user unselects an entity. This is done in the user interface by pressing the Shift button and selecting a previously selected entity.

Visual Basic
Sub OnUnSelect(UnSelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
UnSelectedEntities | Input ObjectsEnumerator that specifies the object(s) (un)selected by the user to be taken out of the selection set being built.
SelectionDevice | Input constant denoting whether the (un)selection was made via a pick in a graphics window or was it by a pick in the browser or by some other means. An object can also be selected programmatically by calling the selection simulation methods on the CommandManager. A value of kGraphicsWindowSelection indicates it was (un)selected in a graphic window. For all other values the View, ModelPosition, and ViewPosition arguments are meaningless.
ModelPosition | Returns the coordinates that result from projecting the click point onto the (un)selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > SelectEventsSink Interface > SelectEventsSink Methods > SelectEventsSink.OnUnSelect Method


SelectSet Interface

SelectSet Interface Available in Inventor Introduced in Inventor 5
Summary

The SelectSet object acts as a container for all of the objects that are currently selected using the Select command. See the article in the overviews section.

Class Hierarchy
Inventor::SelectSet
Visual Basic
Public Interface SelectSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Document.SelectSet

See Also

Creation of a break operation in a drawing view sample

Create thread note sample

create punch note sample

Create bend note sample

Adding and editing a feature control frame sample

Assembly Move Occurrence sample

OnDrag Event - dragging a WorkPoint sample

True length of sweep feature sample

Add surface texture symbol to dimension sample

Sketch Display Entities sample

Break alignment of a section view sample

Reference keys sample

Add a punch tool feature sample

Highlight Feature Faces sample

Copy a sketch sample

Client Graphics - Draw Range Box sample

Navigation between browser and data sample

Find component referenced by balloon sample

Dynamic Attributes sample

Mate constraint with limits sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface


SelectSet Methods

SelectSet Methods
Summary

The methods of the SelectSet class are listed here.

Methods
Methods
Name | Description
Clear | Method that removes all objects from the select set.
Delete | Method that deletes all deletable objects in the select set. This is the equivalent of the Delete command. Not all objects that are selectable can be deleted. For example, you can select an edge, but it cannot be deleted. Any undeletable objects in the select set are ignored.
Item | Property that returns the specified object from the select set.
Remove | Method that removes the specified object from the select set.
Select | Method that adds an entity to the select set.
SelectMultiple | Adds multiple entities to the select set.
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods


SelectSet.Clear Method

SelectSet.Clear Method Available in Inventor Introduced in Inventor 5
Summary

Method that removes all objects from the select set.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods > SelectSet.Clear Method


SelectSet.Delete Method

SelectSet.Delete Method Available in Inventor Introduced in Inventor 5
Summary

Method that deletes all deletable objects in the select set. This is the equivalent of the Delete command. Not all objects that are selectable can be deleted. For example, you can select an edge, but it cannot be deleted. Any undeletable objects in the select set are ignored.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods > SelectSet.Delete Method


SelectSet.Item Method

SelectSet.Item Method Available in Inventor Introduced in Inventor 5
Summary

Property that returns the specified object from the select set.

Visual Basic
Sub Item(index As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
See Also

Creation of a break operation in a drawing view sample

Adding and editing a feature control frame sample

Assembly Move Occurrence sample

OnDrag Event - dragging a WorkPoint sample

True length of sweep feature sample

Add surface texture symbol to dimension sample

Reference keys sample

Add a punch tool feature sample

Highlight Feature Faces sample

Dynamic Attributes sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods > SelectSet.Item Method


SelectSet.Remove Method

SelectSet.Remove Method Available in Inventor Introduced in Inventor 5
Summary

Method that removes the specified object from the select set.

Visual Basic
Sub Remove(Index As VARIANT)
Parameters
Parameters | Description
index | Input value that specifies the object to remove. This can be a Long which specifies the index within the collection of the item to remove, or it can be the object you wish to remove. This only removes the object from the select set. It does not delete it from the document.
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods > SelectSet.Remove Method


SelectSet.Select Method

SelectSet.Select Method Available in Inventor Introduced in Inventor 5
Summary

Method that adds an entity to the select set.

Visual Basic
Sub Select(Entity As IDispatch)
Parameters
Parameters | Description
Entity | Input Autodesk Inventor object that is valid to be selected. This method will fail in the case where an unselectable object is provided. For example, you can't select a Document or Matrix object.
See Also

Break alignment of a section view sample

Copy a sketch sample

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods > SelectSet.Select Method


SelectSet.SelectMultiple Method

SelectSet.SelectMultiple Method
Summary

Adds multiple entities to the select set.

Visual Basic
Sub SelectMultiple(Entities As ObjectCollection)
Parameters
Parameters | Description
Entities | Object collection of entities to add to the set.
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Methods > SelectSet.SelectMultiple Method


SelectSet Properties

SelectSet Properties
Summary

The properties of the SelectSet class are listed here.

Properties
Name | Description
Count | Property that returns the number of objects in the select set.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Properties


SelectSet.Count Property

SelectSet.Count Property Available in Inventor Introduced in Inventor 5
Summary

Property that returns the number of objects in the select set.

Visual Basic
Property Count() As long*
See Also

Create thread note sample

create punch note sample

Create bend note sample

Reference keys sample

Client Graphics - Draw Range Box sample

Dynamic Attributes sample

Assembly Mate Constraint Add sample

Assembly Insert Constraint Add sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Properties > SelectSet.Count Property


SelectSet.Type Property

SelectSet.Type Property Available in Inventor Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SelectSet Interface > SelectSet Properties > SelectSet.Type Property


ShadedDisplayOptions Interface

ShadedDisplayOptions Interface Available in Inventor Introduced in Inventor 11
Summary

The ShadedDisplayOptions object provides access to properties that provide read and write access of the shaded display related application options. This is equivalent to the Shaded Display Mode section of the Display tab on the Application Options dialog.

Class Hierarchy
Inventor::ShadedDisplayOptions
Visual Basic
Public Interface ShadedDisplayOptions
Inherits IDispatch
Remarks

The shaded display options can be specified for active, enabled and background components which are defined as follows. Active components in an assembly are those components that are visible, enabled and allowed to be edited by doing an in-place activation. A part document that has been opened in its own graphics window is also considered to be active for display purposes.

When a component in an assembly which is eligible for in-place activation is placed in edit mode, it will remain active, whereas the remaining components will be temporarily de-activated. The display settings for these de-activated components will depend on whether they have been explicitly enabled or not. If they are explicitly enabled (the Enabled option in the model browser or the context menu in the graphics window has been checked), they will be displayed using the settings specified for enabled components. But, if they are explicitly disabled (the Enabled option in the model browser or the context menu in the graphics window has been un-checked), they will be displayed using the settings specified for background components.

Enabled components refer to those components in an assembly for which the Enabled option in the model browser or the context menu in the graphics window has been checked. When a component in an assembly is in-place activated, the remaining components including the enabled ones are temporarily de-activated. The display properties for enabled components specify the display settings for all these temporarily de-activated but otherwise enabled components, i.e. all the enabled components in the assembly except the component that has currently been activated for in-place edit. If any of the temporarily de-activated components have been explicitly specified as disabled (the Enabled option in the model browser or the context menu in the graphics window has been un-checked), they will be displayed using the settings specified for background components.

Background components in an assembly are those components that are visible but, have been explicitly marked as disabled (by un-checking the Enabled option using either the model browser or the context menu in the graphics window). Such components are displayed to provide context information only, hence, only the graphics information is loaded instead of the entire model data structure. If a background component is in-place activated or explicitly re-enabled (by checking the Enabled option using either the model browser or the context menu in the graphics window), it will become an active component. It will then be displayed using the display settings for active components. But, in-place activation of a component other than the background component will not affect the display type of the background component.

Notes

Members through which this object may be accessed include:

DisplayOptions.ShadedDisplayOptions

You are here: Symbol Reference > Inventor Library > Objects > ShadedDisplayOptions Interface


ShadedDisplayOptions Properties

ShadedDisplayOptions Properties
Summary

The properties of the ShadedDisplayOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ShadedDisplayOptions Interface > ShadedDisplayOptions Properties


ShadedDisplayOptions.Application Property

ShadedDisplayOptions.Application Property Available in Inventor Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ShadedDisplayOptions Interface > ShadedDisplayOptions Properties > ShadedDisplayOptions.Application Property


ShadedDisplayOptions.Type Property

ShadedDisplayOptions.Type Property Available in Inventor Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ShadedDisplayOptions Interface > ShadedDisplayOptions Properties > ShadedDisplayOptions.Type Property


Sheet Interface

Sheet Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Sheet object represents a sheet in a drawing document. See here for an overview on drawing views.

Class Hierarchy
Inventor::Sheet
Visual Basic
Public Interface Sheet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AutoCADBlock.Parent

Balloon.Parent

BaselineDimensionSet.Parent

Border.Parent

Centerline.Parent

Centermark.Parent

ChainDimensionSet.Parent

DrawingDimension.Parent

DrawingDocument.ActiveSheet

DrawingNote.Parent

DrawingView.Parent

FeatureControlFrame.Parent

HoleTable.Parent

OrdinateDimensionSet.Parent

PartsList.Parent

RevisionTable.Parent

Sheet.CopyTo

Sheets.Add

Sheets.AddUsingSheetFormat

Sheets.Item

SketchedSymbol.Parent

SurfaceTextureSymbol.Parent

TitleBlock.Parent

Document.ActivatedObject

Application.ActiveEditObject

See Also

AutoCAD block insertion sample

Chain dimensions sets sample

Creation of a break operation in a drawing view sample

Create thread note sample

create punch note sample

Create bend note sample

Baseline dimension sets sample

Adding and editing a feature control frame sample

Copying a title block definition sample

Title Block Definition Create and Insert sample

Sketch Text Add sample

Add surface texture symbol to dimension sample

Create sketched symbol and leader sample

Create SketchedSymbol Definition sample

Create sheet with multiple views sample

Border Insert Default sample

Border Insert sample

Creating a parts list sample

Create a drawing Excel Table sample

Create a Configuration Table sample

Create a Bend Table sample

Custom Table - create sample

Creation a balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface


Sheet Methods

Sheet Methods
Summary

The methods of the Sheet class are listed here.

Methods
Methods
Name | Description
Activate | Method that causes this sheet to become the active sheet.
AddBorder | Method that adds the specified border definition to the sheet. This method will fail in the case where a border instance already exists on the sheet. In this case, use the Delete method of the Border object to remove the existing one first.
AddDefaultBorder | Method that adds an instance of the default border to the sheet. This method is the equivalent of inserting the 'Default Border' border. A border created using the default border is created 'on the fly' by Autodesk Inventor using the supplied input. It is not based on an existing border definition.
AddTitleBlock | Method that adds the specified title block definition to the sheet. Since a sheet can only have one title block at a time, calling this method will remove the existing title block.
ChangeLayer | Method that changes the associated layer for all the input objects.
CopyTo | Method that copies this sheet into the specified drawing document. The new sheet is returned.
CreateGeometryIntent | Method that creates a GeometryIntent object for use in various annotation and view creations.
Delete | Method that deletes this sheet.
FindUsingPoint | Method that finds drawing curve segments, entities on a sheet sketch, centerlines and centermarks that the given point lies on.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Update | Method that updates the sheet.
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods


Sheet.Activate Method

Sheet.Activate Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that causes this sheet to become the active sheet.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.Activate Method


Sheet.AddBorder Method

Sheet.AddBorder Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that adds the specified border definition to the sheet. This method will fail in the case where a border instance already exists on the sheet. In this case, use the Delete method of the Border object to remove the existing one first.

Visual Basic
Sub AddBorder(BorderDefinition As VARIANT, ByRef PromptStrings As [optional] VARIANT, Result As [out, retval] Border*)
Parameters
Parameters | Description
BorderDefinition | Input Variant that specifies which BorderDefinition to use. The input for the argument can be either a BorderDefinition object or string containing the name of an existing BorderDefinition object.
PromptStrings | Optional input array of Strings that specifies the input strings to use as input for prompted text fields that my be present in the border definition. If prompted strings exist in the border definition you must supply input strings through this argument or this method will fail. The prompt strings and their order are obtained by querying the TextBox objects in the BorderDefinition. The order they're returned by the TextBoxes collection is the same order the input strings need to be supplied in the PromptStrings array.
See Also

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.AddBorder Method


Sheet.AddDefaultBorder Method

Sheet.AddDefaultBorder Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that adds an instance of the default border to the sheet. This method is the equivalent of inserting the 'Default Border' border. A border created using the default border is created 'on the fly' by Autodesk Inventor using the supplied input. It is not based on an existing border definition.

Visual Basic
Sub AddDefaultBorder(ByRef HorizontalZoneCount As [optional] VARIANT, ByRef HorizontalZoneLabelMode As [optional] VARIANT, ByRef VerticalZoneCount As [optional] VARIANT, ByRef VerticalZoneLabelMode As [optional] VARIANT, ByRef LabelFromBottomRight As [optional] VARIANT, ByRef DelimitByLines As [optional] VARIANT, ByRef CenterMarks As [optional] VARIANT, ByRef TopMargin As [optional] VARIANT, ByRef BottomMargin As [optional] VARIANT, ByRef LeftMargin As [optional] VARIANT, ByRef RightMargin As [optional] VARIANT, ByRef TextStyle As [optional] VARIANT, ByRef TextLayer As [optional] VARIANT, ByRef LineLayer As [optional] VARIANT, Result As [out, retval] DefaultBorder*)
Parameters
Parameters | Description
HorizontalZoneCount | Optional value that specifies the number of horizontal zones to be created for the border. If not supplied it will default to a standard value, which varies depending on the width of the sheet.
HorizontalZoneLabelMode | Optional input BorderLabelModeEnum value that specifies label style for the horizontal labels. Valid values are kBorderLabelModeAlphabetical, kBorderLabelModeNumeric, and kBorderLabelModeNone. If not specified, it will default to kBorderLabelModeNumeric.
VerticalZoneCount | Optional value that specifies the number of vertical zones to be created for the border. If not supplied it will default to a standard value, which varies depending on the height of the sheet.
VerticalZoneLabelMode | Optional input BorderLabelModeEnum value that specifies label style for the vertical labels. Valid values are kBorderLabelModeAlphabetical, kBorderLabelModeNumeric, and kBorderLabelModeNone. If not specified, it will default to kBorderLabelModeAlphabetical.
LabelFromBottomRight | Optional input Variant that indicates whether the zone numbers should begin at the bottom-right or top-left corner. A value of True indicates the bottom-right corner and False specifies the top-left. If not specified, it will default to True.
DelimitByLines | Optional input Boolean input that indicates if delimit zones should be indicated by lines or arrowheads. A value of True indicates lines and False specifies arrowheads. If not specified, it will default to True.
TopMargin | Optional Double input that specifies the space between the top edge of the sheet and the border line. The distance is specified in centimeters. If not specified, it defaults to a value appropriate for the current active standard.
BottomMargin | Optional Double input that specifies the space between the bottom edge of the sheet and the border line. The distance is specified in centimeters. If not specified, it defaults to a value appropriate for the current active standard.
LeftMargin | Optional Double input that specifies the space between the left edge of the sheet and the border line. The distance is specified in centimeters. If not specified, it defaults to a value appropriate for the current active standard.
RightMargin | Optional input Variant that specifies the space between the right edge of the sheet and the border line. The distance is specified in centimeters. If not specified, it defaults to a value appropriate for the current active standard.
TextStyle | Optional input TextStyle object that specifies the text style for the zone labels.
TextLayer | Optional input Layer object that specifies the layer for the zone labels.
LineLayer | Optional input Layer object that specifies the layer for the border geometry.
Centermarks | Optional input Boolean that specifies whether to a incorporate center marks into the border. A value of True will add center marks. If not specified, it will default to True.
Example 1

"Border Insert Example "

This sample illustrates inserting a default border.

Public Sub InsertDefaultBorder()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Check to see if the sheet already has a border and delete it if it does.
    If Not oSheet.Border Is Nothing Then
        oSheet.Border.Delete
    End If

    ' Define the values to use as input for the border creation.
    Dim HorizontalZoneCount As Long
    HorizontalZoneCount = 15

    Dim HorizontalZoneLabelMode As BorderLabelModeEnum
    HorizontalZoneLabelMode = kBorderLabelModeNumeric

    Dim VerticalZoneCount As Long
    VerticalZoneCount = 10

    Dim VerticalZoneLabelMode As BorderLabelModeEnum
    VerticalZoneLabelMode = kBorderLabelModeAlphabetical

    Dim LabelFromBottomRight As Boolean
    LabelFromBottomRight = False

    Dim DelimitByLines As Boolean
    DelimitByLines = False

    Dim CenterMarks As Boolean
    CenterMarks = False

    Dim TopMargin As Double
    TopMargin = 5

    Dim BottomMargin As Double
    BottomMargin = 3

    Dim LeftMargin As Double
    LeftMargin = 1

    Dim RightMargin As Double
    RightMargin = 2

    Dim BorderLineWidth As Double
    BorderLineWidth = 0.1

    Dim TextLabelHeight As Double
    TextLabelHeight = 1.5

    Dim Font As String
    Font = "Courier New"

    ' Add the border to the sheet.  This sets all of the values, but any of them
    ' can be left out and it will default to an appropriate value.
    Dim oBorder As DefaultBorder
    Set oBorder = oSheet.AddDefaultBorder(HorizontalZoneCount, HorizontalZoneLabelMode, _
                                          VerticalZoneCount, VerticalZoneLabelMode, _
                                          LabelFromBottomRight, DelimitByLines, _
                                          CenterMarks, TopMargin, BottomMargin, _
                                          LeftMargin, RightMargin, BorderLineWidth, _
                                          TextLabelHeight, Font)
End Sub
Example 2

"Border Insert Default Example"

This sample illustrates inserting a default border using the default values.

Public Sub InsertDefaultBorderUsingDefaults()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Check to see if the sheet already has a border and delete it if it does.
    If Not oSheet.Border Is Nothing Then
        oSheet.Border.Delete
    End If

    ' Add the border to the sheet.
    Dim oBorder As DefaultBorder
    Set oBorder = oSheet.AddDefaultBorder()
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.AddDefaultBorder Method


Sheet.AddTitleBlock Method

Sheet.AddTitleBlock Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that adds the specified title block definition to the sheet. Since a sheet can only have one title block at a time, calling this method will remove the existing title block.

Visual Basic
Sub AddTitleBlock(TitleBlockDefinition As VARIANT, ByRef TitleBlockLocation As [optional] VARIANT, ByRef PromptStrings As [optional] VARIANT, Result As [out, retval] TitleBlock*)
Parameters
Parameters | Description
TitleBlockDefinition | Input Variant that specifies which TitleBlockDefinition to use. The input for the argument can be either a TitleBlockDefinition object or string containing the name of an existing TitleBlockDefinition object.
TitleBlockLocation | Optional input value from the TitleBlockLocationEnum enum that defines which corner of the sheet the title block is positioned in. If not supplied, it defaults to the position defined by the sheet.
PromptStrings | Optional input array of Strings that specifies the input strings to use as input for prompted text fields that my be present in the title block definition. If prompted strings exist in the title block definition you must supply input strings through this argument or this method will fail. The prompt strings and their order are obtained by querying the TextBox objects in the TitleBlockDefinition. The order they're returned by the TextBoxes collection is the same order the input strings need to be supplied in the PromptStrings array.
See Also

Copying a title block definition sample

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.AddTitleBlock Method


Sheet.ChangeLayer Method

Sheet.ChangeLayer Method
Summary

Method that changes the associated layer for all the input objects.

Visual Basic
Sub ChangeLayer(Objects As ObjectCollection, Layer As Layer)
Parameters
Parameters | Description
Objects | Input ObjectCollection containing the objects to change the layer of. All the objects should belong to the parent Sheet. The collection can contain any drawing object that has a layer associated with it.
Layer | Input Layer object that specifies the new layer to which the objects should be moved to.
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.ChangeLayer Method


Sheet.CopyTo Method

Sheet.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that copies this sheet into the specified drawing document. The new sheet is returned.

Visual Basic
Sub CopyTo(TargetDocument As DrawingDocument, Result As [out, retval] Sheet*)
Parameters
Parameters | Description
TargetDocument | Input DrawingDocument object that specifies the document that this sheet is to be copied into. An error occurs if the input document is the parent DrawingDocument.
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.CopyTo Method


Sheet.CreateGeometryIntent Method

Sheet.CreateGeometryIntent Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a GeometryIntent object for use in various annotation and view creations.

Visual Basic
Sub CreateGeometryIntent(Geometry As IDispatch, ByRef Intent As [optional] VARIANT, Result As [out, retval] GeometryIntent*)
Parameters
Parameters | Description
Geometry | Input object that specifies the geometry. Valid input objects are DrawingCurve, sketch entities from a sheet sketch, DrawingDimension, Centerline, and Centermark objects. If a DrawingDimension object is input, a Point2d on the dimension must be provided in the Intent argument. A Point object can be provided for true dimensions in an iso-view. Use the DimensionLine, ExtensionLineOne and ExtensionLineTwo properties on the dimension objects to get points on the dimension.
Intent | Input object that specifies the intent point on the input geometry. This can be a value from PointIntentEnum, a geometry if the intent is the intersection of two geometries, a Point2d object that specifies a sheet point on the geometry or a double value (0 to 1) indicating the parameter on the input curve geometry. The range of valid parameter values can be obtained using the GetParamExtents method on the curve's evaluator.
See Also

Chain dimensions sets sample

create punch note sample

Baseline dimension sets sample

Add surface texture symbol to dimension sample

Create sketched symbol and leader sample

Create ordinate dimension sample

Creating hole tables sample

Create a feature control frame symbol sample

Add detail drawing view sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.CreateGeometryIntent Method


Sheet.Delete Method

Sheet.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes this sheet.

Visual Basic
Sub Delete(ByRef RetainDependentViews As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainDependentViews | Indicates whether to retain any views dependent on this sheet.
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.Delete Method


Sheet.FindUsingPoint Method

Sheet.FindUsingPoint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that finds drawing curve segments, entities on a sheet sketch, centerlines and centermarks that the given point lies on.

Visual Basic
Sub FindUsingPoint(PointOnSheet As Point2d, ByRef ProximityTolerance As [optional] VARIANT, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
PointOnSheet | Input Point2d object that specifies a sheet point.
ProximityTolerance | Input Double that specifies the tolerance value for the search. If not specified, the default internal tolerance is used.
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.FindUsingPoint Method


Sheet.GetReferenceKey Method

Sheet.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.GetReferenceKey Method


Sheet.Update Method

Sheet.Update Method Available in Apprentice
Summary

Method that updates the sheet.

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Methods > Sheet.Update Method


Sheet Properties

Sheet Properties
Summary

The properties of the Sheet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
AutoCADBlocks | Property that returns the AutoCADBlocks collection object. This object provides access to all instances of AutoCAD blocks on a sheet. This property returns Nothing for sheets on an Inventor IDW document.
Balloons | Property that returns the collection of on this sheet.
Border | Property that returns the Border or DefaultBorder object associated with the sheet. This property will return Nothing in the case where the sheet doesn't have a border.
Centerlines | Property that returns the Centerlines collection object.
Centermarks | Property that returns the Centermarks collection object.
ClientGraphicsCollection | Gets the ClientGraphicsCollection object.
ClientViews | Property that returns the collection for the drawing sheet.
CustomTables | Property that returns the CustomTables collection object for this sheet.
DataIO | Property that returns a DataIO object. The DataIO object can be used to write out the sheet data in various formats. The Sheet currently only supports
DrawingDimensions | Property that returns the DrawingDimensions collection object. This object provides access to all of the dimensions on the sheet.
DrawingNotes | Property that returns the DrawingNotes collection object consisting of all drawing notes.
DrawingViews | Property that returns the collection object. This provides access to the existing drawing views on the sheet.
ExcludeFromCount | Gets or sets whether to exclude the sheet in the count of sheets in the drawing.
ExcludeFromPrinting | Gets or sets whether to exclude the sheet when printing the drawing.
FeatureControlFrames | Property that returns the FeatureControlFrames collection object.
GraphicsDataSetsCollection | Gets the GraphicsDataSetsCollection object.
Height | Gets or sets the height of the sheet.
HoleTables | Property that returns the HoleTables collection object.
IsModelSpaceSheet | Property that returns whether this is a model space sheet created automatically when opening (rather than importing) AutoCAD dwg files.
Name | Property that indicates the name of this object or instance.
Orientation | Gets or sets the orientation of the sheet as it is viewed or printed.
Parent | Property returning the parent document. When used within Autodesk Inventor the DrawingDocument object will be returned. When used within Apprentice the ApprenticeServerDrawingDocument object will be returned.
PartsLists | Property that returns the PartsLists collection object associated with this sheet. This provides access to the existing parts lists on the sheet.
RevisionTables | Property that returns the RevisionTables collection object.
Size | Gets or sets the size of the Sheet as value in an enumeration of standard sheet sizes.
SketchedSymbols | Property that returns the SketchedSymbols collection object. This object provides access to all sketched symbols on a sheet.
Sketches | Property that returns the DrawingSketches collection object for the sheet. This object provides access to all of the sketches that have been created on the sheet and provides functionality to create new sketches.
Status | Property that returns the current status of the sheet and its contents. If the value is equal to kUpToDateDrawingSheet then the drawing sheet is up to date. Any other value means some portion of the sheet is out of date. The returned value can contain status information about several things about the sheet. You can use bitwise operators to determine the status for a particular item. For example the following can be used to see if the precise display for views on sheet are up to date. If (oSheet.Status And kProcessingPreciseDisplayDrawingSheet) = kProcessingPreciseDisplayDrawingSheet Then MsgBox "Processing precise display." End If... more
SurfaceTextureSymbols | Property that returns the SurfaceTextureSymbols collection object.
TitleBlock | Property that returns the TitleBlock object associated with the sheet. This property will return Nothing in the case where the sheet doesn't have a title block.
Type | Property returning an enum indicating this object's type.
Width | Gets or sets the width of the sheet.
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties


Sheet.Application Property

Sheet.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Application Property


Sheet.AttributeSets Property

Sheet.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.AttributeSets Property


Sheet.AutoCADBlocks Property

Sheet.AutoCADBlocks Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the AutoCADBlocks collection object. This object provides access to all instances of AutoCAD blocks on a sheet. This property returns Nothing for sheets on an Inventor IDW document.

Visual Basic
Property AutoCADBlocks() As AutoCADBlocks**
See Also

AutoCAD block insertion sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.AutoCADBlocks Property


Sheet.Balloons Property

Sheet.Balloons Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the collection of on this sheet.

Visual Basic
Property Balloons() As Balloons**
See Also

Creation a balloon sample

Balloons - edit sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Balloons Property


Sheet.Border Property

Sheet.Border Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the Border or DefaultBorder object associated with the sheet. This property will return Nothing in the case where the sheet doesn't have a border.

Visual Basic
Property Border() As Border**
See Also

Border Insert Default sample

Border Insert sample

Creating a parts list sample

Creating hole tables sample

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Border Property


Sheet.Centerlines Property

Sheet.Centerlines Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the Centerlines collection object.

Visual Basic
Property Centerlines() As Centerlines**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Centerlines Property


Sheet.Centermarks Property

Sheet.Centermarks Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the Centermarks collection object.

Visual Basic
Property Centermarks() As Centermarks**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Centermarks Property


Sheet.ClientGraphicsCollection Property

Sheet.ClientGraphicsCollection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the ClientGraphicsCollection object.

Visual Basic
Property ClientGraphicsCollection() As ClientGraphicsCollection**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.ClientGraphicsCollection Property


Sheet.ClientViews Property

Sheet.ClientViews Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection for the drawing sheet.

Visual Basic
Property ClientViews() As ClientViews**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.ClientViews Property


Sheet.CustomTables Property

Sheet.CustomTables Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the CustomTables collection object for this sheet.

Visual Basic
Property CustomTables() As CustomTables**
See Also

Custom Table - create sample

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.CustomTables Property


Sheet.DataIO Property

Sheet.DataIO Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a DataIO object. The DataIO object can be used to write out the sheet data in various formats. The Sheet currently only supports

Visual Basic
Property DataIO() As DataIO**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.DataIO Property


Sheet.DrawingDimensions Property

Sheet.DrawingDimensions Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the DrawingDimensions collection object. This object provides access to all of the dimensions on the sheet.

Visual Basic
Property DrawingDimensions() As DrawingDimensions**
See Also

Baseline dimension sets sample

Create ordinate dimension sample

Find and remove unattached dimensions sample

Dimensions - editing sample

Center Dimension Text sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.DrawingDimensions Property


Sheet.DrawingNotes Property

Sheet.DrawingNotes Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the DrawingNotes collection object consisting of all drawing notes.

Visual Basic
Property DrawingNotes() As DrawingNotes**
See Also

Create thread note sample

create punch note sample

Create bend note sample

Add new leader note sample

Creating Stacked Text sample

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.DrawingNotes Property


Sheet.DrawingViews Property

Sheet.DrawingViews Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection object. This provides access to the existing drawing views on the sheet.

Visual Basic
Property DrawingViews() As DrawingViews**
See Also

Break alignment of a section view sample

Creating a parts list sample

Add detail drawing view sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.DrawingViews Property


Sheet.ExcludeFromCount Property

Sheet.ExcludeFromCount Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets or sets whether to exclude the sheet in the count of sheets in the drawing.

Visual Basic
Property ExcludeFromCount() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.ExcludeFromCount Property


Sheet.ExcludeFromPrinting Property

Sheet.ExcludeFromPrinting Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets or sets whether to exclude the sheet when printing the drawing.

Visual Basic
Property ExcludeFromPrinting() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.ExcludeFromPrinting Property


Sheet.FeatureControlFrames Property

Sheet.FeatureControlFrames Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the FeatureControlFrames collection object.

Visual Basic
Property FeatureControlFrames() As FeatureControlFrames**
See Also

Adding and editing a feature control frame sample

Create a feature control frame symbol sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.FeatureControlFrames Property


Sheet.GraphicsDataSetsCollection Property

Sheet.GraphicsDataSetsCollection Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the GraphicsDataSetsCollection object.

Visual Basic
Property GraphicsDataSetsCollection() As GraphicsDataSetsCollection**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.GraphicsDataSetsCollection Property


Sheet.Height Property

Sheet.Height Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets or sets the height of the sheet.

Visual Basic
Property Height() As double
See Also

Creating a parts list sample

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Height Property


Sheet.HoleTables Property

Sheet.HoleTables Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the HoleTables collection object.

Visual Basic
Property HoleTables() As HoleTables**
See Also

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.HoleTables Property


Sheet.IsModelSpaceSheet Property

Sheet.IsModelSpaceSheet Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether this is a model space sheet created automatically when opening (rather than importing) AutoCAD dwg files.

Visual Basic
Property IsModelSpaceSheet() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.IsModelSpaceSheet Property


Sheet.Name Property

Sheet.Name Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Name Property


Sheet.Orientation Property

Sheet.Orientation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets or sets the orientation of the sheet as it is viewed or printed.

Visual Basic
Property Orientation() As PageOrientationTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Orientation Property


Sheet.Parent Property

Sheet.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent document. When used within Autodesk Inventor the DrawingDocument object will be returned. When used within Apprentice the ApprenticeServerDrawingDocument object will be returned.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Parent Property


Sheet.PartsLists Property

Sheet.PartsLists Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the PartsLists collection object associated with this sheet. This provides access to the existing parts lists on the sheet.

Visual Basic
Property PartsLists() As PartsLists**
See Also

Parts List Edit sample

Parts List Query sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.PartsLists Property


Sheet.RevisionTables Property

Sheet.RevisionTables Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the RevisionTables collection object.

Visual Basic
Property RevisionTables() As RevisionTables**
See Also

Query revision table sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.RevisionTables Property


Sheet.Size Property

Sheet.Size Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets or sets the size of the Sheet as value in an enumeration of standard sheet sizes.

Visual Basic
Property Size() As DrawingSheetSizeEnum
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Size Property


Sheet.SketchedSymbols Property

Sheet.SketchedSymbols Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchedSymbols collection object. This object provides access to all sketched symbols on a sheet.

Visual Basic
Property SketchedSymbols() As SketchedSymbols**
See Also

Create sketched symbol and leader sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.SketchedSymbols Property


Sheet.Sketches Property

Sheet.Sketches Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the DrawingSketches collection object for the sheet. This object provides access to all of the sketches that have been created on the sheet and provides functionality to create new sketches.

Visual Basic
Property Sketches() As DrawingSketches**
See Also

Sketch Text Add sample

Sketch fill region sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Sketches Property


Sheet.Status Property

Sheet.Status Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the current status of the sheet and its contents. If the value is equal to kUpToDateDrawingSheet then the drawing sheet is up to date. Any other value means some portion of the sheet is out of date. The returned value can contain status information about several things about the sheet. You can use bitwise operators to determine the status for a particular item. For example the following can be used to see if the precise display for views on sheet are up to date. If (oSheet.Status And kProcessingPreciseDisplayDrawingSheet) = kProcessingPreciseDisplayDrawingSheet Then MsgBox "Processing precise display." End If This is useful when an operation requires the sheet to be up to date. For example, when plotting the sheet.

Visual Basic
Property Status() As DrawingSheetStatusBits*
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Status Property


Sheet.SurfaceTextureSymbols Property

Sheet.SurfaceTextureSymbols Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the SurfaceTextureSymbols collection object.

Visual Basic
Property SurfaceTextureSymbols() As SurfaceTextureSymbols**
See Also

Add surface texture symbol to dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.SurfaceTextureSymbols Property


Sheet.TitleBlock Property

Sheet.TitleBlock Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the TitleBlock object associated with the sheet. This property will return Nothing in the case where the sheet doesn't have a title block.

Visual Basic
Property TitleBlock() As TitleBlock**
See Also

Copying a title block definition sample

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.TitleBlock Property


Sheet.Type Property

Sheet.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Type Property


Sheet.Width Property

Sheet.Width Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets or sets the width of the sheet.

Visual Basic
Property Width() As double
See Also

Creating a parts list sample

Creating hole tables sample

You are here: Symbol Reference > Inventor Library > Objects > Sheet Interface > Sheet Properties > Sheet.Width Property


SheetFormat Interface

SheetFormat Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SheetFormat object represents a sheet format in a drawing.

Class Hierarchy
Inventor::SheetFormat
Visual Basic
Public Interface SheetFormat
Inherits IDispatch
Remarks

A sheet format is a drawing resource that creates new formatted sheets with standard elements such as sheet size and shape, defines the title block and border, and sets the standard drawing views.

Notes

Members through which this object may be accessed include:

SheetFormat.CopyTo

SheetFormats.Add

SheetFormats.Item

Example

"Create sheet with multiple views"

This sample demonstrates the creation of a drawing sheet based on a particular sheet format containing the definition for multiple views. Have a drawing document open and run the following macro.

Public Sub AddUsingSheetFormat()

    'Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    'Set a reference to the sheet format named "C size, 4 view"
    Dim oFormat As SheetFormat
    Set oFormat = oDrawDoc.SheetFormats.Item("C size, 4 view")

    'Open the model document invisible
    Dim oModel As Document
    Set oModel = ThisApplication.Documents.Open("C:\temp\block.ipt", False)

    'Create a new sheet based on the sheet format
    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.Sheets.AddUsingSheetFormat(oFormat, oModel)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface


SheetFormat Methods

SheetFormat Methods
Summary

The methods of the SheetFormat class are listed here.

Methods
Methods
Name | Description
CopyTo | Method that copies the sheet format to the target drawing document.
Delete | Method that deletes the sheet format.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Methods


SheetFormat.CopyTo Method

SheetFormat.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that copies the sheet format to the target drawing document.

Visual Basic
Sub CopyTo(TargetDocument As DrawingDocument, Result As [out, retval] SheetFormat*)
Parameters
Parameters | Description
TargetDocument | Input DrawingDocument object that specifies the document to copy the format into.
Remarks

If a sheet format of the same name exists in the target document, a new name is assigned to the copied format. Copying a sheet format also copies over the referenced titleblock definition and border definition. If definitions of the same name exist in the target document, new names are assigned to these resources as well. The method returns a failure if the target document is the same as the source document.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Methods > SheetFormat.CopyTo Method


SheetFormat.Delete Method

SheetFormat.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes the sheet format.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Methods > SheetFormat.Delete Method


SheetFormat.GetReferenceKey Method

SheetFormat.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Methods > SheetFormat.GetReferenceKey Method


SheetFormat Properties

SheetFormat Properties
Summary

The properties of the SheetFormat class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
HasDrawingViews | Property that returns whether this sheet format contains definitions for one or more drawing views.
Height | Property that gets the height of the sheet as defined in the format.
Name | Property that indicates the name of this object or instance.
Orientation | Property that gets whether the sheet is oriented using landscape or portrait orientation.
Parent | Property that returns the parent DrawingDocument object.
ReferencedAutoCADBlockDefinitions | Property that returns an enumerator of all the AutoCADBlockDefinition objects that this format references. The property returns Nothing if the sheet format does not reference any AutoCAD block definitions.
ReferencedBorderDefinition | Property that returns the BorderDefinition that this format references.
ReferencedSymbolDefinitions | Property that returns an enumerator of all the SketchedSymbolDefinition objects that this format references.
ReferencedTitleBlockDefinition | Property that returns the TitleBlockDefinition that this format references.
Size | Property that gets the size of the sheet as defined in the format.
TitleBlockLocation | Property that returns the position of the title block on the sheet as defined in the format.
Type | Property returning kSheetFormatObject indicating this object's type.
Width | Property that gets the width of the sheet as defined in the format.
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties


SheetFormat.Application Property

SheetFormat.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Application Property


SheetFormat.AttributeSets Property

SheetFormat.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.AttributeSets Property


SheetFormat.HasDrawingViews Property

SheetFormat.HasDrawingViews Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns whether this sheet format contains definitions for one or more drawing views.

Visual Basic
Property HasDrawingViews() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.HasDrawingViews Property


SheetFormat.Height Property

SheetFormat.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the height of the sheet as defined in the format.

Visual Basic
Property Height() As double*
Remarks

The height is defined in centimeters.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Height Property


SheetFormat.Name Property

SheetFormat.Name Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Name Property


SheetFormat.Orientation Property

SheetFormat.Orientation Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets whether the sheet is oriented using landscape or portrait orientation.

Visual Basic
Property Orientation() As PageOrientationTypeEnum*
Remarks

Possible return values are kLandscapePageOrientation and kPortraitPageOrientation.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Orientation Property


SheetFormat.Parent Property

SheetFormat.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent DrawingDocument object.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Parent Property


SheetFormat.ReferencedAutoCADBlockDefinitions Property

SheetFormat.ReferencedAutoCADBlockDefinitions Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns an enumerator of all the AutoCADBlockDefinition objects that this format references. The property returns Nothing if the sheet format does not reference any AutoCAD block definitions.

Visual Basic
Property ReferencedAutoCADBlockDefinitions() As AutoCADBlockDefinitionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.ReferencedAutoCADBlockDefinitions Property


SheetFormat.ReferencedBorderDefinition Property

SheetFormat.ReferencedBorderDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the BorderDefinition that this format references.

Visual Basic
Property ReferencedBorderDefinition() As BorderDefinition**
Remarks

The property returns Nothing if the sheet format does not reference a border definition.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.ReferencedBorderDefinition Property


SheetFormat.ReferencedSymbolDefinitions Property

SheetFormat.ReferencedSymbolDefinitions Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns an enumerator of all the SketchedSymbolDefinition objects that this format references.

Visual Basic
Property ReferencedSymbolDefinitions() As ObjectsEnumerator**
Remarks

The property returns Nothing if the sheet format does not reference any sketched symbol definitions.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.ReferencedSymbolDefinitions Property


SheetFormat.ReferencedTitleBlockDefinition Property

SheetFormat.ReferencedTitleBlockDefinition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the TitleBlockDefinition that this format references.

Visual Basic
Property ReferencedTitleBlockDefinition() As TitleBlockDefinition**
Remarks

The property returns Nothing if the sheet format does not reference a titleblock definition.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.ReferencedTitleBlockDefinition Property


SheetFormat.Size Property

SheetFormat.Size Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the size of the sheet as defined in the format.

Visual Basic
Property Size() As DrawingSheetSizeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Size Property


SheetFormat.TitleBlockLocation Property

SheetFormat.TitleBlockLocation Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the position of the title block on the sheet as defined in the format.

Visual Basic
Property TitleBlockLocation() As TitleBlockLocationEnum*
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.TitleBlockLocation Property


SheetFormat.Type Property

SheetFormat.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSheetFormatObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Type Property


SheetFormat.Width Property

SheetFormat.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets the width of the sheet as defined in the format.

Visual Basic
Property Width() As double*
Remarks

The width is defined in centimeters.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormat Interface > SheetFormat Properties > SheetFormat.Width Property


SheetFormats Interface

SheetFormats Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SheetFormats collection object provides access to all the existing SheetFormat objects in a drawing document and provides methods to create additional sheet formats.

Class Hierarchy
Inventor::SheetFormats
Visual Basic
Public Interface SheetFormats
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.SheetFormats

You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface


SheetFormats Methods

SheetFormats Methods
Summary

The methods of the SheetFormats class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new SheetFormat. The newly created SheetFormat is returned.
Item | Property that returns the specified SheetFormat object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Methods


SheetFormats.Add Method

SheetFormats.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new SheetFormat. The newly created SheetFormat is returned.

Visual Basic
Sub Add(Sheet As Sheet, Name As String, Result As [out, retval] SheetFormat*)
Parameters
Parameters | Description
Sheet | Input Sheet object that specifies the sheet to be used as the template for creating the sheet format.
Name | Input String that defines the name of the sheet format. The name must be unique with respect to all other SheetFormats in the document or an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Methods > SheetFormats.Add Method


SheetFormats.Item Method

SheetFormats.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified SheetFormat object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SheetFormat*)
Parameters
Parameters | Description
index | Input Variant value that specifies the SheetFormat to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the SheetFormat name. If an out of range index or a name of a non-existent SheetFormat is provided, an error will occur.
See Also

Create sheet with multiple views sample

You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Methods > SheetFormats.Item Method


SheetFormats Properties

SheetFormats Properties
Summary

The properties of the SheetFormats class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning kSheetFormatsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Properties


SheetFormats.Application Property

SheetFormats.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the root Application object.

Visual Basic
Property Application() As IDispatch**
Remarks

It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Properties > SheetFormats.Application Property


SheetFormats.Count Property

SheetFormats.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Properties > SheetFormats.Count Property


SheetFormats.Type Property

SheetFormats.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSheetFormatsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SheetFormats Interface > SheetFormats Properties > SheetFormats.Type Property


SheetMetalComponentDefinition Interface

SheetMetalComponentDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SheetMetalComponentDefinition object derives from the PartComponentDefinition object. It adds the sheet metal-specific behavior to the PartComponentDefinition.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::PartComponentDefinition
        Inventor::SheetMetalComponentDefinition
Visual Basic
Public Interface SheetMetalComponentDefinition
Inherits PartComponentDefinition
Notes

Members through which this object may be accessed include:

Bend.Parent

FlatPattern.Parent

See Also

Create sheet metal lofted flange feature sample

Create sheet metal face and fold features sample

Sheet Metal Thickness Editing sample

Sheet Metal Style Display sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Add a punch tool feature sample

Report on punch feature ID's sample

Example

"Sheet Metal Feature Display Example"

This sample illustrates getting basic information from the various sheet metal features. Before running the sample, open a sheet metal document that contains some features.

Public Sub SheetMetalFeatureDisplay()
    ' Set a reference to the sheet metal document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Make sure the document is a sheet metal document.
    If oPartDoc.SubType  "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}" Then
        MsgBox "A sheet metal document must be open."
        Exit Sub
    End If

    ' Get the sheet metal component definition.  Because this is a part document whose
    ' sub type is sheet metal, the document will return a SheetMetalComponentDefinition
    ' instead of a PartComponentDefinition.
    Dim oSheetMetalCompDef As SheetMetalComponentDefinition
    Set oSheetMetalCompDef = oPartDoc.ComponentDefinition

    ' Iterate through the features looking specifically for sheet metal features.
    Dim oFeature As PartFeature
    For Each oFeature In oSheetMetalCompDef.Features
        Select Case oFeature.Type
            Case kFaceFeatureObject
                Dim oFaceFeature As FaceFeature
                Set oFaceFeature = oFeature
                Debug.Print "Face Feature: " & oFaceFeature.Name
                Debug.Print "   Adaptive: " & oFaceFeature.Adaptive
                Debug.Print "   Face Count: " & oFaceFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oFaceFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oFaceFeature.Suppressed
            Case kContourFlangeFeatureObject
                Dim oContourFlangeFeature As ContourFlangeFeature
                Set oContourFlangeFeature = oFeature
                Debug.Print "Contour Flange Feature: " & oContourFlangeFeature.Name
                Debug.Print "   Adaptive: " & oContourFlangeFeature.Adaptive
                Debug.Print "   Face Count: " & oContourFlangeFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oContourFlangeFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oContourFlangeFeature.Suppressed
            Case kCutFeatureObject
                Dim oCutFeature As CutFeature
                Set oCutFeature = oFeature
                Debug.Print "Cut Feature: " & oCutFeature.Name
                Debug.Print "   Adaptive: " & oCutFeature.Adaptive
                Debug.Print "   Face Count: " & oCutFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oCutFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oCutFeature.Suppressed
            Case kFlangeFeatureObject
                Dim oFlangeFeature As FlangeFeature
                Set oFlangeFeature = oFeature
                Debug.Print "Flange Feature: " & oFlangeFeature.Name
                Debug.Print "   Adaptive: " & oFlangeFeature.Adaptive
                Debug.Print "   Face Count: " & oFlangeFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oFlangeFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oFlangeFeature.Suppressed
            Case kHemFeatureObject
                Dim oHemFeature As HemFeature
                Set oHemFeature = oFeature
                Debug.Print "Hem Feature: " & oHemFeature.Name
                Debug.Print "   Adaptive: " & oHemFeature.Adaptive
                Debug.Print "   Face Count: " & oHemFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oHemFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oHemFeature.Suppressed
            Case kFoldFeatureObject
                Dim oFoldFeature As FoldFeature
                Set oFoldFeature = oFeature
                Debug.Print "Fold Feature: " & oFoldFeature.Name
                Debug.Print "   Adaptive: " & oFoldFeature.Adaptive
                Debug.Print "   Face Count: " & oFoldFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oFoldFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oFoldFeature.Suppressed
            Case kCornerFeatureObject
                Dim oCornerFeature As CornerFeature
                Set oCornerFeature = oFeature
                Debug.Print "Corner Seam Feature: " & oCornerFeature.Name
                Debug.Print "   Adaptive: " & oCornerFeature.Adaptive
                Debug.Print "   Face Count: " & oCornerFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oCornerFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oCornerFeature.Suppressed
            Case kBendFeatureObject
                Dim oBendFeature As BendFeature
                Set oBendFeature = oFeature
                Debug.Print "Bend Feature: " & oBendFeature.Name
                Debug.Print "   Adaptive: " & oBendFeature.Adaptive
                Debug.Print "   Face Count: " & oBendFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oBendFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oBendFeature.Suppressed
            Case kCornerRoundFeatureObject
                Dim oCornerRoundFeature As CornerRoundFeature
                Set oCornerRoundFeature = oFeature
                Debug.Print "Corner Round Feature: " & oCornerRoundFeature.Name
                Debug.Print "   Adaptive: " & oCornerRoundFeature.Adaptive
                Debug.Print "   Face Count: " & oCornerRoundFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oCornerRoundFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oCornerRoundFeature.Suppressed
            Case kCornerChamferFeatureObject
                Dim oCornerChamferFeature As CornerChamferFeature
                Set oCornerChamferFeature = oFeature
                Debug.Print "Corner Chamfer Feature: " & oCornerChamferFeature.Name
                Debug.Print "   Adaptive: " & oCornerChamferFeature.Adaptive
                Debug.Print "   Face Count: " & oCornerChamferFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oCornerChamferFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oCornerChamferFeature.Suppressed
            Case kPunchToolFeatureObject
                Dim oPunchToolFeature As PunchToolFeature
                Set oPunchToolFeature = oFeature
                Debug.Print "Punch Tool Feature: " & oPunchToolFeature.Name
                Debug.Print "   Adaptive: " & oPunchToolFeature.Adaptive
                Debug.Print "   Face Count: " & oPunchToolFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oPunchToolFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oPunchToolFeature.Suppressed
            Case Else
                Debug.Print "Non Sheetmetal Feature: " & oFeature.Name
                Debug.Print "   Adaptive: " & oFeature.Adaptive
                Debug.Print "   Face Count: " & oFeature.Faces.Count
                Debug.Print "   HealthStatus: " & oFeature.HealthStatus
                Debug.Print "   RangeBox: (" & Format(oFaceFeature.RangeBox.MinPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MinPoint.Z, "0.00000") & ")-(" & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.X, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Y, "0.00000") & ", " & _
                                        Format(oFaceFeature.RangeBox.MaxPoint.Z, "0.00000") & ")"
                Debug.Print "   Suppressed: " & oFeature.Suppressed
        End Select
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface


SheetMetalComponentDefinition Methods

SheetMetalComponentDefinition Methods
Summary

The methods of the SheetMetalComponentDefinition class are listed here.

Methods
Methods
Name | Description
Unfold | Method that generates the flat pattern.
Unfold2 | Method that generates the flat pattern with the input face as the base face.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Methods


SheetMetalComponentDefinition.Unfold Method

SheetMetalComponentDefinition.Unfold Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates the flat pattern.

Visual Basic
Sub Unfold()
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Methods > SheetMetalComponentDefinition.Unfold Method


SheetMetalComponentDefinition.Unfold2 Method

SheetMetalComponentDefinition.Unfold2 Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates the flat pattern with the input face as the base face.

Visual Basic
Sub Unfold2(BaseFace As Face)
Parameters
Parameters | Description
BaseFace | Input Face object from the folded model to be used as the base face when generating the flat pattern.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Methods > SheetMetalComponentDefinition.Unfold2 Method


SheetMetalComponentDefinition Properties

SheetMetalComponentDefinition Properties
Summary

The properties of the SheetMetalComponentDefinition class are listed here.

Properties
Name | Description
ActiveSheetMetalStyle | Property that returns the active SheetMetalStyle object.
BendRadius | Property that returns the parameter that controls the bend radius of the part.
BendReliefDepth | Property that returns the parameter that controls the bend relief depth of the part.
BendReliefWidth | Property that returns the parameter that controls the bend relief width of the part.
Bends |
CornerReliefSize | Property that returns the parameter that controls the corner relief size of the part.
FlatPattern | Property that returns the FlatPattern object. If the sheet metal part hasn't been unfolded, this property returns Nothing.
GapSize |
HasFlatPattern | Property that returns whether the sheet metal body has been unfolded and a FlatPattern object exists.
JacobiRadiusSize | Property that returns the parameter that controls the Jacobi radius size of the part.
MinimumRemnant | Property that returns the parameter that controls the minimum remnant of the part.
SheetMetalStyles | Property that returns the SheetMetalStyles collection object.
Thickness | Property that returns the parameter that controls the thickness of the part.
TransitionRadius | Property that returns the parameter that controls the transition radius of the part.
UnfoldMethod | Property that gets and sets the currently active unfold method for the document.
UnfoldMethods | Property that returns the UnfoldMethods collection object.
UseSheetMetalStyleMaterial | Property that specifies if the material is defined by the sheet metal style or it is explictly set.
UseSheetMetalStyleThickness | Property that specifies if the active thickness is defined by the sheet metal style or it is explictly set.
UseSheetMetalStyleUnfoldMethod | Property that specifies whether to use the unfold method specified by the sheet metal style or not.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties


SheetMetalComponentDefinition.ActiveSheetMetalStyle Property

SheetMetalComponentDefinition.ActiveSheetMetalStyle Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the active SheetMetalStyle object.

Visual Basic
Property ActiveSheetMetalStyle() As SheetMetalStyle**
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.ActiveSheetMetalStyle Property


SheetMetalComponentDefinition.BendRadius Property

SheetMetalComponentDefinition.BendRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the bend radius of the part.

Visual Basic
Property BendRadius() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the bend radius you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.BendRadius Property


SheetMetalComponentDefinition.BendReliefDepth Property

SheetMetalComponentDefinition.BendReliefDepth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the bend relief depth of the part.

Visual Basic
Property BendReliefDepth() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the bend relief depth you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.BendReliefDepth Property


SheetMetalComponentDefinition.BendReliefWidth Property

SheetMetalComponentDefinition.BendReliefWidth Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the bend relief width of the part.

Visual Basic
Property BendReliefWidth() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the bend relief width you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.BendReliefWidth Property


SheetMetalComponentDefinition.Bends Property

SheetMetalComponentDefinition.Bends Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary
Visual Basic
Property Bends() As BendsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.Bends Property


SheetMetalComponentDefinition.CornerReliefSize Property

SheetMetalComponentDefinition.CornerReliefSize Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the corner relief size of the part.

Visual Basic
Property CornerReliefSize() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the corner relief size you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.CornerReliefSize Property


SheetMetalComponentDefinition.FlatPattern Property

SheetMetalComponentDefinition.FlatPattern Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the FlatPattern object. If the sheet metal part hasn't been unfolded, this property returns Nothing.

Visual Basic
Property FlatPattern() As FlatPattern**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.FlatPattern Property


SheetMetalComponentDefinition.GapSize Property

SheetMetalComponentDefinition.GapSize Property Available in Inventor Available in Server Introduced in Inventor 2010
Visual Basic
Property GapSize() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.GapSize Property


SheetMetalComponentDefinition.HasFlatPattern Property

SheetMetalComponentDefinition.HasFlatPattern Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the sheet metal body has been unfolded and a FlatPattern object exists.

Visual Basic
Property HasFlatPattern() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.HasFlatPattern Property


SheetMetalComponentDefinition.JacobiRadiusSize Property

SheetMetalComponentDefinition.JacobiRadiusSize Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the Jacobi radius size of the part.

Visual Basic
Property JacobiRadiusSize() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the Jacobi radius size you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.JacobiRadiusSize Property


SheetMetalComponentDefinition.MinimumRemnant Property

SheetMetalComponentDefinition.MinimumRemnant Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the minimum remnant of the part.

Visual Basic
Property MinimumRemnant() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the minimum remnant you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.MinimumRemnant Property


SheetMetalComponentDefinition.SheetMetalStyles Property

SheetMetalComponentDefinition.SheetMetalStyles Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SheetMetalStyles collection object.

Visual Basic
Property SheetMetalStyles() As SheetMetalStyles**
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.SheetMetalStyles Property


SheetMetalComponentDefinition.Thickness Property

SheetMetalComponentDefinition.Thickness Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the thickness of the part.

Visual Basic
Property Thickness() As Parameter**
Remarks

If the thickness has been set through a material thickness the associated parameter is a reference parameter and cannot be edited. If the thickness has been explicitly set the returned parameter is a model parameter and can be modified using the properties of the Parameter object. You can determine if it's set using the material thickness by checking the UseMaterialThickness property of the SheetMetalComponentDefinition object.

See Also

Sheet Metal Style Creation sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.Thickness Property


SheetMetalComponentDefinition.TransitionRadius Property

SheetMetalComponentDefinition.TransitionRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter that controls the transition radius of the part.

Visual Basic
Property TransitionRadius() As Parameter**
Remarks

The returned parameter is a reference parameter so the value cannot be edited. To edit the transition radius you must edit the active sheet metal style.

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.TransitionRadius Property


SheetMetalComponentDefinition.UnfoldMethod Property

SheetMetalComponentDefinition.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the currently active unfold method for the document.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
See Also

Sheet Metal Style Creation sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.UnfoldMethod Property


SheetMetalComponentDefinition.UnfoldMethods Property

SheetMetalComponentDefinition.UnfoldMethods Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the UnfoldMethods collection object.

Visual Basic
Property UnfoldMethods() As UnfoldMethods**
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.UnfoldMethods Property


SheetMetalComponentDefinition.UseSheetMetalStyleMaterial Property

SheetMetalComponentDefinition.UseSheetMetalStyleMaterial Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if the material is defined by the sheet metal style or it is explictly set.

Visual Basic
Property UseSheetMetalStyleMaterial() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.UseSheetMetalStyleMaterial Property


SheetMetalComponentDefinition.UseSheetMetalStyleThickness Property

SheetMetalComponentDefinition.UseSheetMetalStyleThickness Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies if the active thickness is defined by the sheet metal style or it is explictly set.

Visual Basic
Property UseSheetMetalStyleThickness() As VARIANT_BOOL
See Also

Sheet Metal Style Creation sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.UseSheetMetalStyleThickness Property


SheetMetalComponentDefinition.UseSheetMetalStyleUnfoldMethod Property

SheetMetalComponentDefinition.UseSheetMetalStyleUnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies whether to use the unfold method specified by the sheet metal style or not.

Visual Basic
Property UseSheetMetalStyleUnfoldMethod() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalComponentDefinition Interface > SheetMetalComponentDefinition Properties > SheetMetalComponentDefinition.UseSheetMetalStyleUnfoldMethod Property


SheetMetalFeatures Interface

SheetMetalFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SheetMetalFeaturesFeatures collection object provides access to all of the SheetMetalFeature objects in a sheet metal component definition.

Class Hierarchy
Inventor::PartFeatures
    Inventor::SheetMetalFeatures
Visual Basic
Public Interface SheetMetalFeatures
Inherits PartFeatures
See Also

Create sheet metal lofted flange feature sample

Create sheet metal rip feature sample

Create sheet metal rip feature sample

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Create sheet metal face and fold features sample

Create sheet metal face and flange features sample

Create sheet metal face and flange features sample

Add a punch tool feature sample

Report on punch feature ID's sample

Example

"Create sheet metal face and cut features"

This sample demonstrates the creation of sheet metal face and cut features.

Public Sub FaceAndCutFeatureCreation()
    ' Create a new sheet metal document, using the default sheet metal template.
    Dim oSheetMetalDoc As PartDocument
    Set oSheetMetalDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject, , , "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}"))

    ' Set a reference to the component definition.
    Dim oCompDef As SheetMetalComponentDefinition
    Set oCompDef = oSheetMetalDoc.ComponentDefinition

    ' Set a reference to the sheet metal features collection.
    Dim oSheetMetalFeatures As SheetMetalFeatures
    Set oSheetMetalFeatures = oCompDef.Features

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    Dim oFaceFeatureDefinition As FaceFeatureDefinition
    Set oFaceFeatureDefinition = oSheetMetalFeatures.FaceFeatures.CreateFaceFeatureDefinition(oProfile)

    ' Create a face feature.
    Dim oFaceFeature As FaceFeature
    Set oFaceFeature = oSheetMetalFeatures.FaceFeatures.Add(oFaceFeatureDefinition)

    ' Get the top face for creating the new sketch.
    ' We'll assume that the 6th face is the top face.
    Dim oFrontFace As Face
    Set oFrontFace = oFaceFeature.Faces.Item(6)

    ' Create a new sketch on this face, but use the method that allows you to
    ' control the orientation and orgin of the new sketch.
    Set oSketch = oCompDef.Sketches.AddWithOrientation(oFrontFace, _
                    oCompDef.WorkAxes.Item(1), True, True, oCompDef.WorkPoints(1))

    ' Determine where in sketch space the point (1,0.75,0) is.
    Dim oCorner As Point2d
    Set oCorner = oSketch.ModelToSketchSpace(oTransGeom.CreatePoint(1, 0.75, 0))

    ' Create the interior 3cm x 2cm rectangle for the cut.
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                oCorner, oTransGeom.CreatePoint2d(oCorner.X + 2, oCorner.Y + 1.5))

    ' Create a profile.
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create a cut definition object
    Dim oCutDefinition As CutDefinition
    Set oCutDefinition = oSheetMetalFeatures.CutFeatures.CreateCutDefinition(oProfile)

    ' Set extents to 'Through All'
    Call oCutDefinition.SetThroughAllExtent(kNegativeExtentDirection)

    ' Create the cut feature
    Dim oCutFeature As CutFeature
    Set oCutFeature = oSheetMetalFeatures.CutFeatures.Add(oCutDefinition)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface


SheetMetalFeatures Properties

SheetMetalFeatures Properties
Summary

The properties of the SheetMetalFeatures class are listed here.

Properties
Name | Description
BendFeatures | Property that returns the BendFeatures collection object. This collection provides access to existing BendFeature objects.
ContourFlangeFeatures | Property that returns the CounterFlangeFeatures collection object.
ContourRollFeatures | Property that returns the ContourRollFeatures Object.
CornerChamferFeatures | Property that returns the CornerChamferFeatures collection object.
CornerFeatures | Property that returns the CornerFeatures collection object.
CornerRoundFeatures | Property that returns the CornerRoundFeatures collection object.
CutFeatures | Property that returns the CutFeatures object.
FaceFeatures | Property that returns the FaceDraftFeatures collection object. This collection provides access to existing FaceFeature objects.
FlangeFeatures | Property that returns the FlangeFeatures collection object. This collection provides access to existing FlangeFeature objects.
FoldFeatures | Property that returns the FoldFeatures collection object. This collection provides access to existing FoldFeature objects.
HemFeatures | Property that returns the HemFeatures collection object. This collection provides access to existing HemFeature objects.
LoftedFlangeFeatures | Property that returns the LoftedFlangeFeatures collection object.
PunchToolFeatures | Property that returns the PunchToolFeatures collection object.
RefoldFeatures | Property that returns the RefoldFeatures collection object. This collection provides access to existing RefoldFeature objects and provides functionality to create new RefoldFeature objects.
RipFeatures | Property that returns the RipFeatures collection object.
UnfoldFeatures | Property that returns the UnfoldFeatures collection object. This collection provides access to existing UnfoldFeature objects and provides functionality to create new UnfoldFeature objects.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties


SheetMetalFeatures.BendFeatures Property

SheetMetalFeatures.BendFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the BendFeatures collection object. This collection provides access to existing BendFeature objects.

Visual Basic
Property BendFeatures() As BendFeatures**
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.BendFeatures Property


SheetMetalFeatures.ContourFlangeFeatures Property

SheetMetalFeatures.ContourFlangeFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the CounterFlangeFeatures collection object.

Visual Basic
Property ContourFlangeFeatures() As ContourFlangeFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.ContourFlangeFeatures Property


SheetMetalFeatures.ContourRollFeatures Property

SheetMetalFeatures.ContourRollFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ContourRollFeatures Object.

Visual Basic
Property ContourRollFeatures() As ContourRollFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.ContourRollFeatures Property


SheetMetalFeatures.CornerChamferFeatures Property

SheetMetalFeatures.CornerChamferFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the CornerChamferFeatures collection object.

Visual Basic
Property CornerChamferFeatures() As CornerChamferFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.CornerChamferFeatures Property


SheetMetalFeatures.CornerFeatures Property

SheetMetalFeatures.CornerFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the CornerFeatures collection object.

Visual Basic
Property CornerFeatures() As CornerFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.CornerFeatures Property


SheetMetalFeatures.CornerRoundFeatures Property

SheetMetalFeatures.CornerRoundFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the CornerRoundFeatures collection object.

Visual Basic
Property CornerRoundFeatures() As CornerRoundFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.CornerRoundFeatures Property


SheetMetalFeatures.CutFeatures Property

SheetMetalFeatures.CutFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the CutFeatures object.

Visual Basic
Property CutFeatures() As CutFeatures**
See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.CutFeatures Property


SheetMetalFeatures.FaceFeatures Property

SheetMetalFeatures.FaceFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the FaceDraftFeatures collection object. This collection provides access to existing FaceFeature objects.

Visual Basic
Property FaceFeatures() As FaceFeatures**
See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.FaceFeatures Property


SheetMetalFeatures.FlangeFeatures Property

SheetMetalFeatures.FlangeFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the FlangeFeatures collection object. This collection provides access to existing FlangeFeature objects.

Visual Basic
Property FlangeFeatures() As FlangeFeatures**
See Also

Creating flange features sample

Edit width extent of an existing flange feature sample

Edit width extent of an existing flange feature sample

Example

Create sheet metal face and flange features example.

This sample demonstrates the creation of sheet metal face and flange features.

Public Sub FaceAndFlangeFeatureCreation()
    ' Create a new sheet metal document, using the default sheet metal template.
    Dim oSheetMetalDoc As PartDocument
    Set oSheetMetalDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject, , , "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}"))

    ' Set a reference to the component definition.
    Dim oCompDef As SheetMetalComponentDefinition
    Set oCompDef = oSheetMetalDoc.ComponentDefinition

    ' Set a reference to the sheet metal features collection.
    Dim oSheetMetalFeatures As SheetMetalFeatures
    Set oSheetMetalFeatures = oCompDef.Features

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    Dim oFaceFeatureDefinition As FaceFeatureDefinition
    Set oFaceFeatureDefinition = oSheetMetalFeatures.FaceFeatures.CreateFaceFeatureDefinition(oProfile)

    ' Create a face feature.
    Dim oFaceFeature As FaceFeature
    Set oFaceFeature = oSheetMetalFeatures.FaceFeatures.Add(oFaceFeatureDefinition)

    ' Get the top face for creating the flange.
    ' We'll assume that the 6th face is the top face.
    Dim oFrontFace As Face
    Set oFrontFace = oFaceFeature.Faces.Item(6)

    ' Collect up all edges of the face
    Dim oEdgeCollection As EdgeCollection
    Set oEdgeCollection = ThisApplication.TransientObjects.CreateEdgeCollection

    Dim oEdge As Edge
    For Each oEdge In oFrontFace.Edges
        Call oEdgeCollection.Add(oEdge)
    Next

    Dim oFlangeDefinition As FlangeDefinition
    Set oFlangeDefinition = oSheetMetalFeatures.FlangeFeatures.CreateFlangeDefinition(oEdgeCollection, 3.14159 / 2, "2 in")

    ' Set the bend radius value
    oFlangeDefinition.BendRadius = oCompDef.BendRadius.Value * 2

    ' Create a flange feature
    Dim oFlangeFeature As FlangeFeature
    Set oFlangeFeature = oSheetMetalFeatures.FlangeFeatures.Add(oFlangeDefinition)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.FlangeFeatures Property


SheetMetalFeatures.FoldFeatures Property

SheetMetalFeatures.FoldFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the FoldFeatures collection object. This collection provides access to existing FoldFeature objects.

Visual Basic
Property FoldFeatures() As FoldFeatures**
See Also

Create sheet metal face and fold features sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.FoldFeatures Property


SheetMetalFeatures.HemFeatures Property

SheetMetalFeatures.HemFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the HemFeatures collection object. This collection provides access to existing HemFeature objects.

Visual Basic
Property HemFeatures() As HemFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.HemFeatures Property


SheetMetalFeatures.LoftedFlangeFeatures Property

SheetMetalFeatures.LoftedFlangeFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the LoftedFlangeFeatures collection object.

Visual Basic
Property LoftedFlangeFeatures() As LoftedFlangeFeatures**
See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.LoftedFlangeFeatures Property


SheetMetalFeatures.PunchToolFeatures Property

SheetMetalFeatures.PunchToolFeatures Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the PunchToolFeatures collection object.

Visual Basic
Property PunchToolFeatures() As PunchToolFeatures**
See Also

Add a punch tool feature sample

Report on punch feature ID's sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.PunchToolFeatures Property


SheetMetalFeatures.RefoldFeatures Property

SheetMetalFeatures.RefoldFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the RefoldFeatures collection object. This collection provides access to existing RefoldFeature objects and provides functionality to create new RefoldFeature objects.

Visual Basic
Property RefoldFeatures() As RefoldFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.RefoldFeatures Property


SheetMetalFeatures.RipFeatures Property

SheetMetalFeatures.RipFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the RipFeatures collection object.

Visual Basic
Property RipFeatures() As RipFeatures**
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.RipFeatures Property


SheetMetalFeatures.UnfoldFeatures Property

SheetMetalFeatures.UnfoldFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the UnfoldFeatures collection object. This collection provides access to existing UnfoldFeature objects and provides functionality to create new UnfoldFeature objects.

Visual Basic
Property UnfoldFeatures() As UnfoldFeatures**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalFeatures Interface > SheetMetalFeatures Properties > SheetMetalFeatures.UnfoldFeatures Property


SheetMetalStyle Interface

SheetMetalStyle Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SheetMetalStyle object contains all of the information about a particular sheet metal style (these are also referred to as sheet metal rules).

Class Hierarchy
Inventor::Style
    Inventor::SheetMetalStyle
Visual Basic
Public Interface SheetMetalStyle
Inherits Style
Notes

Members through which this object may be accessed include:

SheetMetalComponentDefinition.ActiveSheetMetalStyle

SheetMetalStyles.Copy

SheetMetalStyles.Item

See Also

Sheet Metal Style Creation sample

Example

"Sheet Metal Style Display Example"

This sample illustrates getting information about sheet metal styles.

Public Sub SheetMetalStyleDisplay()
    ' Set a reference to the sheet metal document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Make sure the document is a sheet metal document.
    If oPartDoc.SubType  "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}" Then
        MsgBox "A sheet metal document must be open."
        Exit Sub
    End If

    ' Get the sheet metal component definition. Because this is a part document whose
    ' sub type is sheet metal, the document will return a SheetMetalComponentDefinition
    ' instead of a PartComponentDefinition.
    Dim oSheetMetalCompDef As SheetMetalComponentDefinition
    Set oSheetMetalCompDef = oPartDoc.ComponentDefinition

    ' Display then name of the active style.
    Debug.Print "Active Sheet Metal Style: " & oSheetMetalCompDef.ActiveSheetMetalStyle.Name

    ' Iterate through the sheet metal styles.
    Debug.Print ""
    Debug.Print "Sheet Metal Styles"
    Dim oStyle As SheetMetalStyle
    For Each oStyle In oSheetMetalCompDef.SheetMetalStyles
        Debug.Print "  " & oStyle.Name
        Debug.Print "     In Use: " & oStyle.InUse
        Debug.Print "     Up to Date: " & oStyle.UpToDate

        Select Case oStyle.StyleLocation
            Case kBothStyleLocation
                Debug.Print "     Style Location: Both Local and in Library"
            Case kLibraryStyleLocation
                Debug.Print "     Style Location: Library"
            Case kLocalStyleLocation
                Debug.Print "     Style Location: Local"
        End Select

        Debug.Print "     Bend Radius: " & oStyle.BendRadius
        Debug.Print "     Bend Relief Depth: " & oStyle.BendReliefDepth
        Debug.Print "     Bend Relief Width: " & oStyle.BendReliefWidth

        Select Case oStyle.BendReliefShape
            Case kRoundBendReliefShape
                Debug.Print "     Bend Relief Shape: Round"
            Case kStraightBendReliefShape
                Debug.Print "     Bend Relief Shape: Straight"
        End Select

        Select Case oStyle.BendTransition
            Case kArcBendTransition
                Debug.Print "     Bend Transition: Arc"
            Case kDefaultBendTransition
                Debug.Print "     Bend Transition: Default"
            Case kIntersectionBendTransition
                Debug.Print "     Bend Transition: Intersection"
            Case kNoBendTransition
                Debug.Print "     Bend Transition: None"
            Case kStraightLineBendTransition
                Debug.Print "     Bend Transition: Straight Line"
            Case kTrimToBendBendTransition
                Debug.Print "     Bend Transition: Trim to Bend"
        End Select

        Debug.Print "     Bend Transition Arc Radius: " & oStyle.BendTransitionArcRadius

        Debug.Print "     Corner Relief Size: " & oStyle.CornerReliefSize
        Select Case oStyle.CornerReliefShape
            Case kArcWeldCornerReliefShape
                Debug.Print "     Corner Relief Shape: Arc Weld"
            Case kDefaultCornerReliefShape
                Debug.Print "     Corner Relief Shape: Default"
            Case kFullRoundCornerReliefShape
                Debug.Print "     Corner Relief Shape: Full Round"
            Case kIntersectionCornerReliefShape
                Debug.Print "     Corner Relief Shape: Intersection"
            Case kLinearWeldReliefShape
                Debug.Print "     Corner Relief Shape: Linear Weld"
            Case kNoReplacementCornerReliefShape
                Debug.Print "     Corner Relief Shape: No Replacement"
            Case kRoundCornerReliefShape
                Debug.Print "     Corner Relief Shape: Round"
            Case kRoundWithRadiusCornerReliefShape
                Debug.Print "     Corner Relief Shape: Round with Radius"
            Case kSquareCornerReliefShape
                Debug.Print "     Corner Relief Shape: Square"
            Case kTearCornerReliefShape
                Debug.Print "     Corner Relief Shape: Tear"
            Case kTrimToBendReliefShape
                Debug.Print "     Corner Relief Shape: Trim"
        End Select

        Debug.Print "     Corner Relief Size: " & oStyle.ThreeBendCornerReliefSize
        Select Case oStyle.ThreeBendCornerReliefShape
            Case kArcWeldCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Arc Weld"
            Case kDefaultCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Default"
            Case kFullRoundCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Full Round"
            Case kIntersectionCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Intersection"
            Case kLinearWeldReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Linear Weld"
            Case kNoReplacementCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: No Replacement"
            Case kRoundCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Round"
            Case kRoundWithRadiusCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Round with Radius"
            Case kSquareCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Square"
            Case kTearCornerReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Tear"
            Case kTrimToBendReliefShape
                Debug.Print "     Three Bend Corner Relief Shape: Trim"
        End Select

        Debug.Print "     Material: " & oStyle.Material.Name
        Debug.Print "     Minimum Remnant: " & oStyle.MinimumRemnant
        Debug.Print "     Thickness: " & oStyle.Thickness

        Select Case oStyle.PunchRepresentationType
            Case k2DSketchAndCenterMarkPunchRepresentation
                Debug.Print "     Punch Representation Type: 2D Sketch and Center Mark"
            Case k2DSketchPunchRepresentation
                Debug.Print "     Punch Representation Type: 2D Sketch"
            Case kCentermarkPunchRepresentation
                Debug.Print "     Punch Representation Type: Center Mark"
            Case kDefaultPunchRepresentation
                Debug.Print "     Punch Representation Type: Default"
            Case kFormedFeaturePunchRepresentation
                Debug.Print "     Punch Representation Type: Formed Feature"
        End Select

        Debug.Print "     Unfold Method: " & oStyle.UnfoldMethod.Name
    Next

    ' Display information about the unfold methods.
    Debug.Print ""
    Debug.Print "Unfold Methods"
    Dim oUnfoldMethod As UnfoldMethod
    For Each oUnfoldMethod In oSheetMetalCompDef.UnfoldMethods
        Debug.Print "  " & oUnfoldMethod.Name
        Debug.Print "     In Use: " & oUnfoldMethod.InUse
        Debug.Print "     Up to Date: " & oUnfoldMethod.UpToDate

        Select Case oUnfoldMethod.StyleLocation
            Case kBothStyleLocation
                Debug.Print "     Location: Both Local and in Library"
            Case kLibraryStyleLocation
                Debug.Print "     Location: Library"
            Case kLocalStyleLocation
                Debug.Print "     Location: Local"
        End Select

        Select Case oUnfoldMethod.UnfoldMethodType
            Case kBendTableUnfoldMethod
                Debug.Print "     Unfold Method Type: Bend Table"
            Case kLinearUnfoldMethod
                Debug.Print "     Unfold Method Type: Linear"
        End Select
        Debug.Print "     kFactor: " & oUnfoldMethod.kFactor
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface


SheetMetalStyle Methods

SheetMetalStyle Methods
Summary

The methods of the SheetMetalStyle class are listed here.

Methods
Methods
Name | Description
Activate | Method that causes this sheet metal style to become the active sheet metal style for this document.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Methods


SheetMetalStyle.Activate Method

SheetMetalStyle.Activate Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that causes this sheet metal style to become the active sheet metal style for this document.

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Methods > SheetMetalStyle.Activate Method


SheetMetalStyle Properties

SheetMetalStyle Properties
Summary

The properties of the SheetMetalStyle class are listed here.

Properties
Name | Description
BendAngleReportType | Gets and sets which angle is to be reported in the flat pattern.
BendRadius | Property that gets and sets the expression that defines the value of the bend radius depth. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
BendReliefDepth | Property that gets and sets the expression that defines the value of the bend relief depth. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
BendReliefShape | Property that gets and set the bend relief shape. Valid values are kStraightBendReliefShape and kRoundBendReliefShape.
BendReliefWidth | Property that gets and sets the expression that defines the value of the bend relief width. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
BendTransition | Property that gets and set the type of bend transition associated with the style.
BendTransitionArcRadius | Property that gets and sets the expression that defines the value of the bend relief arc radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
CornerReliefShape | Property that gets and set the type of corner relief shape associated with the style. Valid values are kRoundCornerReliefShape, kSquareCornerReliefShape, kTearCornerReliefShape, and kTrimToBendReliefShape.
CornerReliefSize | Property that gets and sets the expression that defines the value of the corner relief size radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
GapSize | Property that gets and sets the expression that defines the value of the gap size for miters, seams, and rips. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
Material | Property that gets and sets the material associated with the style.
MinimumRemnant | Property that gets and sets the expression that defines the value of the corner relief size radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
PunchRepresentationType | Property that gets and sets the default punch representation to use for flat pattern generation. Valid values are kFormedFeaturePunchRepresentation, k2DSketchPunchRepresentation, kCentermarkPunchRepresentation and k2DsketchAndCenterMarkPunchRepresentation.
Thickness | Property that gets and sets the expression that defines the value of the thickness. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
ThreeBendCornerReliefShape | Property that gets and set the type of three bend corner relief shape associated with the style. Valid values are kRoundCornerReliefShape, kSquareCornerReliefShape, kTearCornerReliefShape, and kTrimToBendReliefShape.
ThreeBendCornerReliefSize | Property that gets and sets the expression that defines the value of the corner relief size radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.
UnfoldMethod | Property that gets and set the unfold method associated with the style.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties


SheetMetalStyle.BendAngleReportType Property

SheetMetalStyle.BendAngleReportType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets and sets which angle is to be reported in the flat pattern.

Visual Basic
Property BendAngleReportType() As BendAngleTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendAngleReportType Property


SheetMetalStyle.BendRadius Property

SheetMetalStyle.BendRadius Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the expression that defines the value of the bend radius depth. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property BendRadius() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendRadius Property


SheetMetalStyle.BendReliefDepth Property

SheetMetalStyle.BendReliefDepth Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the expression that defines the value of the bend relief depth. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property BendReliefDepth() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendReliefDepth Property


SheetMetalStyle.BendReliefShape Property

SheetMetalStyle.BendReliefShape Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and set the bend relief shape. Valid values are kStraightBendReliefShape and kRoundBendReliefShape.

Visual Basic
Property BendReliefShape() As BendReliefShapeEnum
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendReliefShape Property


SheetMetalStyle.BendReliefWidth Property

SheetMetalStyle.BendReliefWidth Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the expression that defines the value of the bend relief width. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property BendReliefWidth() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendReliefWidth Property


SheetMetalStyle.BendTransition Property

SheetMetalStyle.BendTransition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and set the type of bend transition associated with the style.

Visual Basic
Property BendTransition() As BendTransitionEnum
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendTransition Property


SheetMetalStyle.BendTransitionArcRadius Property

SheetMetalStyle.BendTransitionArcRadius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the expression that defines the value of the bend relief arc radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property BendTransitionArcRadius() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.BendTransitionArcRadius Property


SheetMetalStyle.CornerReliefShape Property

SheetMetalStyle.CornerReliefShape Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and set the type of corner relief shape associated with the style. Valid values are kRoundCornerReliefShape, kSquareCornerReliefShape, kTearCornerReliefShape, and kTrimToBendReliefShape.

Visual Basic
Property CornerReliefShape() As CornerReliefShapeEnum
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.CornerReliefShape Property


SheetMetalStyle.CornerReliefSize Property

SheetMetalStyle.CornerReliefSize Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the expression that defines the value of the corner relief size radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property CornerReliefSize() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.CornerReliefSize Property


SheetMetalStyle.GapSize Property

SheetMetalStyle.GapSize Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the expression that defines the value of the gap size for miters, seams, and rips. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property GapSize() As String
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.GapSize Property


SheetMetalStyle.Material Property

SheetMetalStyle.Material Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the material associated with the style.

Visual Basic
Property Material() As Material*
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.Material Property


SheetMetalStyle.MinimumRemnant Property

SheetMetalStyle.MinimumRemnant Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the expression that defines the value of the corner relief size radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property MinimumRemnant() As String
See Also

Sheet Metal Style Creation sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.MinimumRemnant Property


SheetMetalStyle.PunchRepresentationType Property

SheetMetalStyle.PunchRepresentationType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the default punch representation to use for flat pattern generation. Valid values are kFormedFeaturePunchRepresentation, k2DSketchPunchRepresentation, kCentermarkPunchRepresentation and k2DsketchAndCenterMarkPunchRepresentation.

Visual Basic
Property PunchRepresentationType() As PunchRepresentationTypeEnum
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.PunchRepresentationType Property


SheetMetalStyle.Thickness Property

SheetMetalStyle.Thickness Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the expression that defines the value of the thickness. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property Thickness() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

Example

Sheet Metal Thickness Editing Example (Visual Basic)] This sample illustrates editing the thickness of a sheet metal part.

Public Sub SetSheetMetalThickness()
    ' Set a reference to the sheet metal document.
    ' This assumes a sheet metal document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Get the sheet metal component definition. Because this is a part document whose
    ' sub type is sheet metal, the document will return a SheetMetalComponentDefinition
    ' instead of a PartComponentDefinition.
    Dim oSheetMetalCompDef As SheetMetalComponentDefinition
    Set oSheetMetalCompDef = oPartDoc.ComponentDefinition

    ' Override the thickness for the document
    oSheetMetalCompDef.UseSheetMetalStyleThickness = False

    ' Get a reference to the parameter controlling the thickness.
    Dim oThicknessParam As Parameter
    Set oThicknessParam = oSheetMetalCompDef.Thickness

    ' Change the value of the parameter.
    oThicknessParam.Value = oThicknessParam.Value * 1.5

    ' Update the part.
    ThisApplication.ActiveDocument.Update
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.Thickness Property


SheetMetalStyle.ThreeBendCornerReliefShape Property

SheetMetalStyle.ThreeBendCornerReliefShape Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the type of three bend corner relief shape associated with the style. Valid values are kRoundCornerReliefShape, kSquareCornerReliefShape, kTearCornerReliefShape, and kTrimToBendReliefShape.

Visual Basic
Property ThreeBendCornerReliefShape() As CornerReliefShapeEnum
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.ThreeBendCornerReliefShape Property


SheetMetalStyle.ThreeBendCornerReliefSize Property

SheetMetalStyle.ThreeBendCornerReliefSize Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the expression that defines the value of the corner relief size radius. Setting any values for a style in the library will cause that style to be cached locally in the document. The input string must define a valid length expression.

Visual Basic
Property ThreeBendCornerReliefSize() As String
See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.ThreeBendCornerReliefSize Property


SheetMetalStyle.UnfoldMethod Property

SheetMetalStyle.UnfoldMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and set the unfold method associated with the style.

Visual Basic
Property UnfoldMethod() As UnfoldMethod*
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyle Interface > SheetMetalStyle Properties > SheetMetalStyle.UnfoldMethod Property


SheetMetalStyles Interface

SheetMetalStyles Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SheetMetalStyles collection object provides access to all of the objects in a part component definition and provides methods to create additional sheet metal styles.

Class Hierarchy
Inventor::SheetMetalStyles
Visual Basic
Public Interface SheetMetalStyles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalComponentDefinition.SheetMetalStyles

Example

"Sheet Metal Style Creation Example"

This sample illustrates creating a new sheet metal style. It uses a bend table and assumes the sample bend table delivered with Inventor is available. You can edit the path below to reference any existing bend table. To use the sample make sure a bend table is available at the specified path, open a sheet metal document, and run the sample.

Public Sub CreateSheetMetalStyle()
    ' Set a reference to the sheet metal document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Make sure the document is a sheet metal document.
    If oPartDoc.SubType  "{9C464203-9BAE-11D3-8BAD-0060B0CE6BB4}" Then
        MsgBox "A sheet metal document must be open."
        Exit Sub
    End If

    ' Get the sheet metal component definition. Because this is a part document whose
    ' sub type is sheet metal, the document will return a SheetMetalComponentDefinition
    ' instead of a PartComponentDefinition.
    Dim oSheetMetalCompDef As SheetMetalComponentDefinition
    Set oSheetMetalCompDef = oPartDoc.ComponentDefinition

    ' Create a new unfold method.
    Dim okFactorUnfoldMethod As UnfoldMethod
    Set okFactorUnfoldMethod = oSheetMetalCompDef.UnfoldMethods.AddLinearUnfoldMethod("kFactorTest", "0.43")

    ' Create a new unfold method using a bend table.
    Dim oTableUnfoldMethod As UnfoldMethod
    On Error Resume Next
    Set oTableUnfoldMethod = oSheetMetalCompDef.UnfoldMethods.AddBendTableFromFile("Table Sample", "C:\Program Files\Autodesk\Inventor 2010\Design Data\Bend Tables\Bend Table (in).txt")
    If Err Then
        MsgBox "Unable to load bend table"
    End If
    On Error Goto 0

    ' Copy a sheet metal style to create a new one. This arbitrarily uses the
    ' first style in the collection.
    Dim oStyle As SheetMetalStyle
    Set oStyle = oSheetMetalCompDef.SheetMetalStyles.Item(1).Copy("Sample Style")

    ' Set the value for the thickness. This is an expression that will be used to
    ' set a parameter when this style is activated.
    oStyle.Thickness = ".1 in"

    ' The name "Thickness" as used below is handled specially when the style
    ' is used so it will behave as expected for all languages.
    oStyle.BendRadius = "Thickness * 1.5"
    oStyle.BendReliefDepth = "Thickness * 1.5"
    oStyle.BendReliefShape = kRoundBendReliefShape
    oStyle.BendReliefWidth = "Thickness / 2"
    oStyle.BendTransition = kArcBendTransition
    oStyle.BendTransitionArcRadius = "Thickness * 2.0"
    oStyle.CornerReliefShape = kRoundCornerReliefShape
    oStyle.CornerReliefSize = "Thickness * 2.0"
    oStyle.MinimumRemnant = "Thickness * 2.0"

    ' Set the material.  For this example it arbitrarily uses the first material in the collection.
    oStyle.Material = oPartDoc.Materials.Item(1)

    oStyle.PunchRepresentationType = kFormedFeaturePunchRepresentation
    oStyle.ThreeBendCornerReliefShape = kFullRoundCornerReliefShape
    oStyle.ThreeBendCornerReliefSize = "Thickness * 2.0"

    ' Activate this style.
    oStyle.Activate

    ' This section will override some of the settings defined by the style.
    Dim bOverrideStyle As Boolean
    bOverrideStyle = True
    If bOverrideStyle Then
        ' Set the unfold method to use the unfold method created above.
        oSheetMetalCompDef.UnfoldMethod = okFactorUnfoldMethod

        ' Set the thickness.
        oSheetMetalCompDef.UseSheetMetalStyleThickness = False
        oSheetMetalCompDef.Thickness.Expression = ".12 in"

        ' Set the material.
        oSheetMetalCompDef.Material = oPartDoc.Materials.Item(2)
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface


SheetMetalStyles Methods

SheetMetalStyles Methods
Summary

The methods of the SheetMetalStyles class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a new SheetMetalStyle object by copying an existing style.
Item | Method that returns the specified SheetMetalStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Methods


SheetMetalStyles.Copy Method

SheetMetalStyles.Copy Method Available in Inventor Available in Server
Summary

Method that creates a new SheetMetalStyle object by copying an existing style.

Visual Basic
Sub Copy(ExistingStyle As SheetMetalStyle, NewStyleName As String, Result As [out, retval] SheetMetalStyle*)
Parameters
Parameters | Description
ExistingStyle | Input SheetMetalStyle that will be copied to create the new style.
NewStyleName | Input String that specifies the name of the new style made by copying the existing style.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Methods > SheetMetalStyles.Copy Method


SheetMetalStyles.Item Method

SheetMetalStyles.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified SheetMetalStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SheetMetalStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the sheet metal style to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the style name. If an out-of-range index or a name of a non-existent style is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Methods > SheetMetalStyles.Item Method


SheetMetalStyles Properties

SheetMetalStyles Properties
Summary

The properties of the SheetMetalStyles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Properties


SheetMetalStyles.Application Property

SheetMetalStyles.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Properties > SheetMetalStyles.Application Property


SheetMetalStyles.Count Property

SheetMetalStyles.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Properties > SheetMetalStyles.Count Property


SheetMetalStyles.Type Property

SheetMetalStyles.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SheetMetalStyles Interface > SheetMetalStyles Properties > SheetMetalStyles.Type Property


Sheets Interface

Sheets Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Sheets collection object provides access to all the existing objects in a drawing document and provides methods to create additional sheets. See here for an overview on drawing views.

Class Hierarchy
Inventor::Sheets
Visual Basic
Public Interface Sheets
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServerDrawingDocument.Sheets

DrawingDocument.Sheets

See Also

Copying a title block definition sample

You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface


Sheets Methods

Sheets Methods
Summary

The methods of the Sheets class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new Sheet.
AddUsingSheetFormat | Method that creates a new Sheet based on the input format. The newly created Sheet is returned.
Item | Property that returns the specified Sheet object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Methods


Sheets.Add Method

Sheets.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new Sheet.

Visual Basic
Sub Add(ByRef Size As [defaultvalue(kCDrawingSheetSize)] DrawingSheetSizeEnum, ByRef Orientation As [defaultvalue(kLandscapePageOrientation)] PageOrientationTypeEnum, ByRef SheetName As [defaultvalue("")] BSTR, ByRef Width As [optional] VARIANT, ByRef Height As [optional] VARIANT, Result As [out, retval] Sheet*)
Parameters
Parameters | Description
Size | Optional input enum value that defines the size of sheet to create. If kCustomDrawingSheetSize is used the Width and Height arguments must be specified. If not specified, the default value kCDrawingSheetSize is used.
Orientation | Optional input PageOrientationTypeEnum that defines if the sheet will be landscape or portrait orientation. If not specified or if specified as kDefaultPageOrientation, the sheet will be created with a landscape orientation.
SheetName | Optional input String that defines the editable portion of the name that is displayed within the browser. If not specified, a default name is assigned to the sheet.
width | Optional input Double that defines the width of the sheet. This value is used when the Size argument is kCustomDrawingSheetSize, otherwise it is ignored. The size is defined in centimeters.
height | Optional input Double that defines the height of the sheet. This value is used when the Size argument is kCustomDrawingSheetSize, otherwise it is ignored. The size is defined in centimeters.
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Methods > Sheets.Add Method


Sheets.AddUsingSheetFormat Method

Sheets.AddUsingSheetFormat Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new Sheet based on the input format. The newly created Sheet is returned.

Visual Basic
Sub AddUsingSheetFormat(SheetFormat As SheetFormat, ByRef Model As [optional] VARIANT, ByRef SheetName As [defaultvalue("")] BSTR, ByRef AdditionalOptions As [optional] VARIANT, ByRef TitleBlockPromptStrings As [optional] VARIANT, ByRef BorderPromptStrings As [optional] VARIANT, Result As [out, retval] Sheet*)
Parameters
Parameters | Description
SheetFormat | Input Sheet object that specifies the sheet to be used as the template for creating the sheet format.
Model | Optional input that specifies the model to create drawings views of. This can either be the model Document object or a string that specifies the FullDocumentName of the model. This is a required input if the input SheetFormat defines at least one drawing view.
SheetName | Optional input String that defines the editable portion of the name that is displayed within the browser. If not specified, a default name is assigned to the sheet.
AdditionalOptions | Optional input NameValueMap object that specifies additional or advanced options for drawing view creation. See Remarks for supported values.
WeldmentFeatureGroup | If the model document type is a weldment assembly, this option specifies the weldment feature group that is to be displayed in the view creation. Valid values for include kAssemblyFeatureGroup, kPreperationsFeatureGroup, kWeldsFeatureGroup, and kMachiningFeatureGroup. This option is ignored if the model document is not a weldment assembly. The default, if not specified, is kAssemblyFeatureGroup.
SheetMetalFoldedModel | If the model document type is a sheet metal part, this option specifies if the view is to be created from the folded model (True) or the flattened model (False). The default value if not specified is to display the folded model. This option is ignored if the model document is not a sheet metal part.
Remarks

Supported values for the Options parameter:

Name | Value Type | Valid document type
WeldmentFeatureGroup | WeldmentFeatureGroupEnum | Weldment
SheetMetalFoldedModel | Boolean | Sheet Metal
DesignViewRepresentation | String | Assembly
DesignViewAssociative | Boolean | Assembly
PositionalRepresentation | String | Assembly
MemberName | String | Part, Assembly
See Also

Create sheet with multiple views sample

You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Methods > Sheets.AddUsingSheetFormat Method


Sheets.Item Method

Sheets.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified Sheet object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] Sheet*)
Parameters
Parameters | Description
index | Input Variant value that specifies the Sheet to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the sheet's name. If an out-of-range index or a name of a non-existent Sheet is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Methods > Sheets.Item Method


Sheets Properties

Sheets Properties
Summary

The properties of the Sheets class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Properties


Sheets.Application Property

Sheets.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Properties > Sheets.Application Property


Sheets.Count Property

Sheets.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Properties > Sheets.Count Property


Sheets.Type Property

Sheets.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sheets Interface > Sheets Properties > Sheets.Type Property


SheetSettings Interface

SheetSettings Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SheetSettings object provides access to properties that provide read and write access of the various sheet related document specific settings. This is somewhat equivalent to the Sheet tab of the Document Settings dialog.

Class Hierarchy
Inventor::SheetSettings
Visual Basic
Public Interface SheetSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.SheetSettings

You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface


SheetSettings Properties

SheetSettings Properties
Summary

The properties of the SheetSettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent DrawingDocument object.
SheetColor | Property that indicates the background color used for drawing sheets.
SheetEntityHighlightColor | Property that indicates the color used to highlight elements on the drawing sheet when the cursor passes over them.
SheetEntitySelectionColor | Property that indicates the color used to illuminate elements on the drawing sheet when they are selected.
SheetLabel | Property that indicates the default prefix name used for newly created drawing sheets.
SheetOutlineColor | Property that indicates the color used for the border of drawing sheets.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties


SheetSettings.Application Property

SheetSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.Application Property


SheetSettings.Parent Property

SheetSettings.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent DrawingDocument object.

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.Parent Property


SheetSettings.SheetColor Property

SheetSettings.SheetColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the background color used for drawing sheets.

Visual Basic
Property SheetColor() As Color*
Remarks

The color of views, symbols and other elements does not depend on the background color of the sheet, so, it is possible to get good contrast by setting different colors for the elements on the drawing sheet and the background of the sheet.

You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.SheetColor Property


SheetSettings.SheetEntityHighlightColor Property

SheetSettings.SheetEntityHighlightColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the color used to highlight elements on the drawing sheet when the cursor passes over them.

Visual Basic
Property SheetEntityHighlightColor() As Color*
Remarks

The elements on the drawing sheet include drawing views along with their geometry, geometry drawn directly on the sheet using drawing sketches and drawing annotations. When the mouse is moved over these sheet elements, they will be highlighted to indicate that they are being pre-selected, the color used to highlight them will be the color specified by this property.

You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.SheetEntityHighlightColor Property


SheetSettings.SheetEntitySelectionColor Property

SheetSettings.SheetEntitySelectionColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the color used to illuminate elements on the drawing sheet when they are selected.

Visual Basic
Property SheetEntitySelectionColor() As Color*
Remarks

The elements on the drawing sheet include drawing views along with their geometry, geometry drawn directly on the sheet using drawing sketches and drawing annotations. When these elements are selected, they will be illuminated using the color specified by this property.

You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.SheetEntitySelectionColor Property


SheetSettings.SheetLabel Property

SheetSettings.SheetLabel Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the default prefix name used for newly created drawing sheets.

Visual Basic
Property SheetLabel() As String
Remarks

The full name will be the prefix name specified by this property along with a suffix corresponding to the sheet number. When a new sheet is created, a browser node corresponding to this new sheet will also be created and displayed in the Model browser pane of the drawing. The name given to this new browser node will be the name specified by this property suffixed by the sheet number.

You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.SheetLabel Property


SheetSettings.SheetOutlineColor Property

SheetSettings.SheetOutlineColor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the color used for the border of drawing sheets.

Visual Basic
Property SheetOutlineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.SheetOutlineColor Property


SheetSettings.Type Property

SheetSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SheetSettings Interface > SheetSettings Properties > SheetSettings.Type Property


ShellDefinition Interface

ShellDefinition Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ShellDefinition object is used to define all of the input required for fillet features. It is also used to query and edit existing shell features.

Class Hierarchy
Inventor::ShellDefinition
Visual Basic
Public Interface ShellDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ShellDefinition.Copy

ShellFeature.Definition

ShellFeatures.CreateShellDefinition

You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface


ShellDefinition Methods

ShellDefinition Methods
Summary

The methods of the ShellDefinition class are listed here.

Methods
Methods
Name | Description
AddThicknessFaceSet | Method that creates a new thickness face set. The new ShellThicknessFaceSet is returned.
Copy | Method that returns a copy of the ShellDefinition object.
FaceSetItem | Method that returns the specified ShellThicknessFaceSet object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Methods


ShellDefinition.AddThicknessFaceSet Method

ShellDefinition.AddThicknessFaceSet Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new thickness face set. The new ShellThicknessFaceSet is returned.

Visual Basic
Sub AddThicknessFaceSet(Faces As FaceCollection, Thickness As VARIANT, Result As [out, retval] ShellThicknessFaceSet*)
Parameters
Parameters | Description
Faces | Input FaceCollection object that contains faces that have a unique thickness defined.
Thickness | Input Variant that defines the unique thickness associated with the input Faces. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Methods > ShellDefinition.AddThicknessFaceSet Method


ShellDefinition.Copy Method

ShellDefinition.Copy Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns a copy of the ShellDefinition object.

Visual Basic
Sub Copy(Result As [out, retval] ShellDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Methods > ShellDefinition.Copy Method


ShellDefinition.FaceSetItem Method

ShellDefinition.FaceSetItem Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified ShellThicknessFaceSet object from the collection.

Visual Basic
Sub FaceSetItem(Index As long, Result As [out, retval] ShellThicknessFaceSet*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Methods > ShellDefinition.FaceSetItem Method


ShellDefinition Properties

ShellDefinition Properties
Summary

The properties of the ShellDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
ApproximationOptimized | Property that gets and sets whether the approximation is optimized (i.e. compute time is minimized and the feature is computed within a reasonable tolerance). If set to False, the feature is computed to the tolerance specified in the ApproximationTolerance property.
ApproximationTolerance | Property that gets and sets the approximation tolerance. This value must be between 0 and 1 and defaults to 0.1. This value is used only if the ApproximationOptimized property is set to False.
ApproximationType | Property that gets and sets the approximation method used for the feature.
Direction | Property that specifies the shell boundary relative to part face.
FaceSetCount | Property that specifies the number of face sets currently defined in the defintion.
InputFaces | Property that specifies the faces used to create the feature. This property will return the faces only when the end of part marker is moved above this feature, else the FaceCollection will contain GenericObject objects.
Parent | Property that returns the parent object from whom this object can logically be reached.
Thickness | Property that returns the parameter that controls the thickness of the shell. This property will return Nothing if the shell feature has not been created yet.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties


ShellDefinition.Application Property

ShellDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.Application Property


ShellDefinition.ApproximationOptimized Property

ShellDefinition.ApproximationOptimized Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the approximation is optimized (i.e. compute time is minimized and the feature is computed within a reasonable tolerance). If set to False, the feature is computed to the tolerance specified in the ApproximationTolerance property.

Visual Basic
Property ApproximationOptimized() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.ApproximationOptimized Property


ShellDefinition.ApproximationTolerance Property

ShellDefinition.ApproximationTolerance Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the approximation tolerance. This value must be between 0 and 1 and defaults to 0.1. This value is used only if the ApproximationOptimized property is set to False.

Visual Basic
Property ApproximationTolerance() As double
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.ApproximationTolerance Property


ShellDefinition.ApproximationType Property

ShellDefinition.ApproximationType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the approximation method used for the feature.

Visual Basic
Property ApproximationType() As FeatureApproximationTypeEnum
Remarks

Valid types are kNoApproximation, kMeanApproximation, kNeverTooThickApproximation and kNeverTooThinApproximation. The default value for the property is kMeanApproximation. If an approximation method is specified, it is used only if the precise compute fails.

You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.ApproximationType Property


ShellDefinition.Direction Property

ShellDefinition.Direction Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the shell boundary relative to part face.

Visual Basic
Property Direction() As ShellDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.Direction Property


ShellDefinition.FaceSetCount Property

ShellDefinition.FaceSetCount Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the number of face sets currently defined in the defintion.

Visual Basic
Property FaceSetCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.FaceSetCount Property


ShellDefinition.InputFaces Property

ShellDefinition.InputFaces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the faces used to create the feature. This property will return the faces only when the end of part marker is moved above this feature, else the FaceCollection will contain GenericObject objects.

Visual Basic
Property InputFaces() As FaceCollection*
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.InputFaces Property


ShellDefinition.Parent Property

ShellDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As ShellFeature**
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.Parent Property


ShellDefinition.Thickness Property

ShellDefinition.Thickness Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parameter that controls the thickness of the shell. This property will return Nothing if the shell feature has not been created yet.

Visual Basic
Property Thickness() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.Thickness Property


ShellDefinition.Type Property

ShellDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ShellDefinition Interface > ShellDefinition Properties > ShellDefinition.Type Property


ShellFeature Interface

ShellFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ShellFeature object represents the shell modeling feature.

Class Hierarchy
Inventor::PartFeature
    Inventor::ShellFeature
        Inventor::ShellFeatureProxy
Visual Basic
Public Interface ShellFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ShellDefinition.Parent

ShellFeatureProxy.NativeObject

ShellFeatures.Add

ShellFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > ShellFeature Interface


ShellFeature Properties

ShellFeature Properties
Summary

The properties of the ShellFeature class are listed here.

Properties
Name | Description
Definition | Property that gets and sets the ShellDefinition object which defines the various input that was used to create the shell feature.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeature Interface > ShellFeature Properties


ShellFeature.Definition Property

ShellFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the ShellDefinition object which defines the various input that was used to create the shell feature.

Visual Basic
Property Definition() As ShellDefinition*
Remarks

The ShellDefinition object returned by this property has a live connection to the feature and may be used to edit the feature. Alternatively, a new ShellDefinition object can be obtained using ShellFeatures.CreateShellDefinition or ShellDefinition.Copy methods and set to this property. The latter approach should be preferred for performing batch edits on the feature.

You are here: Symbol Reference > Inventor Library > Objects > ShellFeature Interface > ShellFeature Properties > ShellFeature.Definition Property


ShellFeatureProxy Interface

ShellFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ShellFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ShellFeature
        Inventor::ShellFeatureProxy
Visual Basic
Public Interface ShellFeatureProxy
Inherits ShellFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ShellFeatureProxy Interface


ShellFeatureProxy Properties

ShellFeatureProxy Properties
Summary

The properties of the ShellFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatureProxy Interface > ShellFeatureProxy Properties


ShellFeatureProxy.ContainingOccurrence Property

ShellFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ShellFeatureProxy Interface > ShellFeatureProxy Properties > ShellFeatureProxy.ContainingOccurrence Property


ShellFeatureProxy.NativeObject Property

ShellFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ShellFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ShellFeatureProxy Interface > ShellFeatureProxy Properties > ShellFeatureProxy.NativeObject Property


ShellFeatures Interface

ShellFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ShellFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional ShellFeatures.

Class Hierarchy
Inventor::ShellFeatures
Visual Basic
Public Interface ShellFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.ShellFeatures

You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface


ShellFeatures Methods

ShellFeatures Methods
Summary

The methods of the ShellFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ShellFeature. The new created ShellFeature is returned.
CreateShellDefinition | Method that creates a new ShellDefinition object. The object returned by this method is used to define the inputs for a shell feature and is provided as the argument to the Add method of the ShellFeatures collection.
Item | Property that returns the specified object in the collection. The index can be numeric or the object name.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Methods


ShellFeatures.Add Method

ShellFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new ShellFeature. The new created ShellFeature is returned.

Visual Basic
Sub Add(Definition As ShellDefinition, Result As [out, retval] ShellFeature*)
Parameters
Parameters | Description
Definition | Property that returns the object which defines the various input that was used to create the shell feature.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Methods > ShellFeatures.Add Method


ShellFeatures.CreateShellDefinition Method

ShellFeatures.CreateShellDefinition Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new ShellDefinition object. The object returned by this method is used to define the inputs for a shell feature and is provided as the argument to the Add method of the ShellFeatures collection.

Visual Basic
Sub CreateShellDefinition(ByRef InputFaces As [optional] VARIANT, ByRef Thickness As [optional] VARIANT, ByRef Direction As [defaultvalue(kInsideShellDirection)] ShellDirectionEnum, Result As [out, retval] ShellDefinition*)
Parameters
Parameters | Description
InputFaces | Optional input FaceCollection object that defines the part faces to remove, leaving the remaining faces as shell walls. If no faces are specified, the shell creates a hollow part.
Thickness | Optional input Variant that specifies the thickness to be applied uniformly to shell walls. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current distance units of the document.
Direction | Optional input enum that specifies the shell boundary relative to the part face. Valid inputs are kInside that offsets the shell wall to the part interior, kOutside that offsets the shell wall to the exterior of the part, and kBothSides that offsets the shell wall equal distances to inside and outside the part. The default value is kInside.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Methods > ShellFeatures.CreateShellDefinition Method


ShellFeatures.Item Method

ShellFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified object in the collection. The index can be numeric or the object name.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ShellFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the index of the ShellFeature to return.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Methods > ShellFeatures.Item Method


ShellFeatures Properties

ShellFeatures Properties
Summary

The properties of the ShellFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Properties


ShellFeatures.Application Property

ShellFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Properties > ShellFeatures.Application Property


ShellFeatures.Count Property

ShellFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Properties > ShellFeatures.Count Property


ShellFeatures.Type Property

ShellFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ShellFeatures Interface > ShellFeatures Properties > ShellFeatures.Type Property


ShellThicknessFaceSet Interface

ShellThicknessFaceSet Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The ShellThicknessFaceSet object provides access to the faces and their associated thickness for a shell.

Class Hierarchy
Inventor::ShellThicknessFaceSet
Visual Basic
Public Interface ShellThicknessFaceSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ShellDefinition.AddThicknessFaceSet

ShellDefinition.FaceSetItem

You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface


ShellThicknessFaceSet Methods

ShellThicknessFaceSet Methods
Summary

The methods of the ShellThicknessFaceSet class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the face set.
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Methods


ShellThicknessFaceSet.Delete Method

ShellThicknessFaceSet.Delete Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that deletes the face set.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Methods > ShellThicknessFaceSet.Delete Method


ShellThicknessFaceSet Properties

ShellThicknessFaceSet Properties
Summary

The properties of the ShellThicknessFaceSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Faces | Property that gets and sets the collection of faces in the face set.
Thickness | Property that returns the parameter that controls the thickness of the faces in the face set. This property will return Nothing if the shell feature has not been created yet.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Properties


ShellThicknessFaceSet.Application Property

ShellThicknessFaceSet.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Properties > ShellThicknessFaceSet.Application Property


ShellThicknessFaceSet.Faces Property

ShellThicknessFaceSet.Faces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the collection of faces in the face set.

Visual Basic
Property Faces() As FaceCollection*
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Properties > ShellThicknessFaceSet.Faces Property


ShellThicknessFaceSet.Thickness Property

ShellThicknessFaceSet.Thickness Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parameter that controls the thickness of the faces in the face set. This property will return Nothing if the shell feature has not been created yet.

Visual Basic
Property Thickness() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Properties > ShellThicknessFaceSet.Thickness Property


ShellThicknessFaceSet.Type Property

ShellThicknessFaceSet.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ShellThicknessFaceSet Interface > ShellThicknessFaceSet Properties > ShellThicknessFaceSet.Type Property


SilhouetteCurve Interface

SilhouetteCurve Interface Available in Inventor Introduced in Inventor 2012
Summary

The SilhouetteCurve object represents the results of creating a silhouette curve calculation. It consists of one or more sketch entities that represent the silhouette of the original input face(s) or body.

Class Hierarchy
Inventor::SilhouetteCurve
Visual Basic
Public Interface SilhouetteCurve
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface


SilhouetteCurve Methods

SilhouetteCurve Methods
Summary

The methods of the SilhouetteCurve class are listed here.

Methods
Methods
Name | Description
BreakLink | Method that breaks the link between the silhouette curve and the model.
Delete | Method that deletes the silhouette curve.
Edit | Method that edits all of the inputs used to compute the silhouette curve.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Methods


SilhouetteCurve.BreakLink Method

SilhouetteCurve.BreakLink Method Available in Inventor Introduced in Inventor 2012
Summary

Method that breaks the link between the silhouette curve and the model.

Visual Basic
Sub BreakLink()
Remarks

This breaks the associativity to the model, allowing you to edit the individual sketch entities.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Methods > SilhouetteCurve.BreakLink Method


SilhouetteCurve.Delete Method

SilhouetteCurve.Delete Method Available in Inventor Introduced in Inventor 2012
Summary

Method that deletes the silhouette curve.

Visual Basic
Sub Delete()
Remarks

This will delete all of the related sketch entities.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Methods > SilhouetteCurve.Delete Method


SilhouetteCurve.Edit Method

SilhouetteCurve.Edit Method Available in Inventor Introduced in Inventor 2012
Summary

Method that edits all of the inputs used to compute the silhouette curve.

Visual Basic
Sub Edit(FacesOrBody As IDispatch, DirectionEntity As IDispatch, IncludeCoincidentSilhouettes As VARIANT_BOOL, Result As [out, retval] SilhouetteCurve*)
Parameters
Parameters | Description
FacesOrBody | Input object that defines the surfaces. This can be one of the following: SurfaceBody, Face, Faces or a FaceCollection object. If a FaceCollection is provided, all the Face objects in the collection must belong to the same SurfaceBody, or an error will occur.
DirectionEntity | Input entity that defines the direction used to calculate the silhouette curve. Valid input is a planar face or work plane (the normal of the face or work plane is used), a cylinder (the axis is used), a work axis, or a linear edge.
IncludeCoincidentSilhouettes | Input Boolean that specifies if silhouette curves that are coincident to the edges of the input faces should be considered or not. If True, these curves will be returned.
Remarks

This method is more efficient than setting each of the individual properties since this will result in a single compute rather than computing after each property edit.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Methods > SilhouetteCurve.Edit Method


SilhouetteCurve.GetReferenceKey Method

SilhouetteCurve.GetReferenceKey Method Available in Inventor Introduced in Inventor 2012
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Output array of Bytes that contains the reference key.
KeyContext | Optional input Long that specifies the key context to use when creating the reference key. Although this argument is optional, you must currently always provide a valid key context. A key context is created using the CreateKeyContext method of the ReferenceKeyManager object.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the ReferenceKeyManager object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document Object.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Methods > SilhouetteCurve.GetReferenceKey Method


SilhouetteCurve Properties

SilhouetteCurve Properties
Summary

The properties of the SilhouetteCurve class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
DirectionEntity | Property gets and set the direction used to calculate the silhouette curve.
FacesOrBody | Property that defines the surfaces the silhouette is calculated for.
IncludeCoincidentSilhouettes | Property that gets and sets whether silhouette curves that are coincident to the edges of the input faces should be calculated or not.
Name | Property that gets and sets name of the silhouette curve.
Parent | Property that returns the parent 3D sketch of the silhouette curve.
SketchEntities | Property that returns a collection of sketch entities that belong to silhouette curve.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties


SilhouetteCurve.Application Property

SilhouetteCurve.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.Application Property


SilhouetteCurve.AttributeSets Property

SilhouetteCurve.AttributeSets Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.AttributeSets Property


SilhouetteCurve.DirectionEntity Property

SilhouetteCurve.DirectionEntity Property Available in Inventor Introduced in Inventor 2012
Summary

Property gets and set the direction used to calculate the silhouette curve.

Visual Basic
Property DirectionEntity() As IDispatch*
Remarks

Valid input is a planar face or work plane (the normal of the face or work plane is used), a cylinder (the axis is used), a work axis, or a linear edge.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.DirectionEntity Property


SilhouetteCurve.FacesOrBody Property

SilhouetteCurve.FacesOrBody Property Available in Inventor Introduced in Inventor 2012
Summary

Property that defines the surfaces the silhouette is calculated for.

Visual Basic
Property FacesOrBody() As IDispatch*
Remarks

When reading this property is will always return an ObjectCollection that may contain one or more Face objects, or it can contain a SurfaceBody. When setting the property you can provide a SurfaceBody, Face, Faces or a FaceCollection object. If a FaceCollection is provided, all the Face objects in the collection must belong to the same SurfaceBody, or an error will occur.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.FacesOrBody Property


SilhouetteCurve.IncludeCoincidentSilhouettes Property

SilhouetteCurve.IncludeCoincidentSilhouettes Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether silhouette curves that are coincident to the edges of the input faces should be calculated or not.

Visual Basic
Property IncludeCoincidentSilhouettes() As VARIANT_BOOL
Remarks

If True, these curves will be calculated.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.IncludeCoincidentSilhouettes Property


SilhouetteCurve.Name Property

SilhouetteCurve.Name Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets name of the silhouette curve.

Visual Basic
Property Name() As String
Remarks

When setting this property, the name must be unique with respect to all other silhouette curves in the document. If the name is not unique an error will occur.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.Name Property


SilhouetteCurve.Parent Property

SilhouetteCurve.Parent Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the parent 3D sketch of the silhouette curve.

Visual Basic
Property Parent() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.Parent Property


SilhouetteCurve.SketchEntities Property

SilhouetteCurve.SketchEntities Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns a collection of sketch entities that belong to silhouette curve.

Visual Basic
Property SketchEntities() As SketchEntities3DEnumerator**
Remarks

The sketch entities returned by this property cannot be edited or deleted because they are associated with the silhouette curve in the model. The BreakLink method can be used to break this association so they are individually editable.

You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.SketchEntities Property


SilhouetteCurve.Type Property

SilhouetteCurve.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurve Interface > SilhouetteCurve Properties > SilhouetteCurve.Type Property


SilhouetteCurves Interface

SilhouetteCurves Interface Available in Inventor Introduced in Inventor 2012
Summary

The SilhouetteCurves object provides access to all the silhouette curve results in a 3D sketch and supports the ability to create new silhouette curves.

Class Hierarchy
Inventor::SilhouetteCurves
Visual Basic
Public Interface SilhouetteCurves
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface


SilhouetteCurves Methods

SilhouetteCurves Methods
Summary

The methods of the SilhouetteCurves class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a silhouette curve.
Item | Returns the specified SilhouetteCurve object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Methods


SilhouetteCurves.Add Method

SilhouetteCurves.Add Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a silhouette curve.

Visual Basic
Sub Add(FacesOrBody As IDispatch, DirectionEntity As IDispatch, IncludeCoincidentSilhouettes As VARIANT_BOOL, Result As [out, retval] SilhouetteCurve*)
Parameters
Parameters | Description
FacesOrBody | Input object that defines the surfaces. This can be one of the following: SurfaceBody, Face, Faces or a FaceCollection object. If a FaceCollection is provided, all the Face objects in the collection must belong to the same SurfaceBody, or an error will occur.
DirectionEntity | Input entity that defines the direction used to calculate the silhouette curve. Valid input is a planar face or work plane (the normal of the face or work plane is used), a cylinder (the axis is used), a work axis, or a linear edge.
IncludeCoincidentSilhouettes | Input Boolean that specifies if silhouette curves that are coincident to the edges of the input faces should be considered or not. If True, these curves will be returned.
Result | _nt_
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Methods > SilhouetteCurves.Add Method


SilhouetteCurves.Item Method

SilhouetteCurves.Item Method Available in Inventor Introduced in Inventor 2012
Summary

Returns the specified SilhouetteCurve object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SilhouetteCurve*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the silhouette curve to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the silhouette curve name. If an out of range index or a name of a non-existent silhouette curve is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Methods > SilhouetteCurves.Item Method


SilhouetteCurves Properties

SilhouetteCurves Properties
Summary

The properties of the SilhouetteCurves class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Count | Property that specifies the number of items in the collection.
Type | Property returning SilhouetteCurvesObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Properties


SilhouetteCurves.Application Property

SilhouetteCurves.Application Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Properties > SilhouetteCurves.Application Property


SilhouetteCurves.Count Property

SilhouetteCurves.Count Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Properties > SilhouetteCurves.Count Property


SilhouetteCurves.Type Property

SilhouetteCurves.Type Property Available in Inventor Introduced in Inventor 2012
Summary

Property returning SilhouetteCurvesObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SilhouetteCurves Interface > SilhouetteCurves Properties > SilhouetteCurves.Type Property


SingleHemDefinition Interface

SingleHemDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SingleHemDefinition object defines all of the inputs that are unique to a single style of hem feature.

Class Hierarchy
Inventor::SingleHemDefinition
Visual Basic
Public Interface SingleHemDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HemDefinition.HemTypeDefinition

You are here: Symbol Reference > Inventor Library > Objects > SingleHemDefinition Interface


SingleHemDefinition Properties

SingleHemDefinition Properties
Summary

The properties of the SingleHemDefinition class are listed here.

Properties
Name | Description
Gap | Property that returns the parameter controlling the gap of a hem feature defined by a single bend.
Length | Property that returns the parameter controlling the length of a hem feature defined by a single bend.
Parent | Property that returns the parent hem definition feature.
You are here: Symbol Reference > Inventor Library > Objects > SingleHemDefinition Interface > SingleHemDefinition Properties


SingleHemDefinition.Gap Property

SingleHemDefinition.Gap Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the gap of a hem feature defined by a single bend.

Visual Basic
Property Gap() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > SingleHemDefinition Interface > SingleHemDefinition Properties > SingleHemDefinition.Gap Property


SingleHemDefinition.Length Property

SingleHemDefinition.Length Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the length of a hem feature defined by a single bend.

Visual Basic
Property Length() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > SingleHemDefinition Interface > SingleHemDefinition Properties > SingleHemDefinition.Length Property


SingleHemDefinition.Parent Property

SingleHemDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent hem definition feature.

Visual Basic
Property Parent() As HemDefinition**
You are here: Symbol Reference > Inventor Library > Objects > SingleHemDefinition Interface > SingleHemDefinition Properties > SingleHemDefinition.Parent Property


SinglePointRipTypeDef Interface

SinglePointRipTypeDef Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The SinglePointRipTypeDef object defines the inputs unique to a single point rip feature.

Class Hierarchy
Inventor::SinglePointRipTypeDef
Visual Basic
Public Interface SinglePointRipTypeDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface


SinglePointRipTypeDef Properties

SinglePointRipTypeDef Properties
Summary

The properties of the SinglePointRipTypeDef class are listed here.

Properties
Name | Description
GapSide | Property that gets and sets the value that indicates the position of the gap. Valid values are kPositiveExtentDirection, kNegativeExtentDirection, and kSymmetricExtentDirection. kPositiveExtentDirection indicates that the material will be removed from the right from the perspective of the rip point where 'up' is along the normal of the rip face and you're looking towards the other edge of the face where the rip will end.
GapSize | Property that returns the parameter controlling the width of the gap. When creating a new rip feature and the RipDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSinglePointRipType method of the RipDefinition to set this value in that case. When this object is obtained from an existing rip feature you can edit the rip feature by modifying the parameter this property returns.
Parent | Property that returns the parent rip definition feature.
Point | Property that gets and sets the point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface > SinglePointRipTypeDef Properties


SinglePointRipTypeDef.GapSide Property

SinglePointRipTypeDef.GapSide Property Introduced in Inventor 2011
Summary

Property that gets and sets the value that indicates the position of the gap. Valid values are kPositiveExtentDirection, kNegativeExtentDirection, and kSymmetricExtentDirection. kPositiveExtentDirection indicates that the material will be removed from the right from the perspective of the rip point where 'up' is along the normal of the rip face and you're looking towards the other edge of the face where the rip will end.

Visual Basic
Property GapSide() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface > SinglePointRipTypeDef Properties > SinglePointRipTypeDef.GapSide Property


SinglePointRipTypeDef.GapSize Property

SinglePointRipTypeDef.GapSize Property Introduced in Inventor 2011
Summary

Property that returns the parameter controlling the width of the gap. When creating a new rip feature and the RipDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSinglePointRipType method of the RipDefinition to set this value in that case. When this object is obtained from an existing rip feature you can edit the rip feature by modifying the parameter this property returns.

Visual Basic
Property GapSize() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface > SinglePointRipTypeDef Properties > SinglePointRipTypeDef.GapSize Property


SinglePointRipTypeDef.Parent Property

SinglePointRipTypeDef.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent rip definition feature.

Visual Basic
Property Parent() As RipDefinition**
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface > SinglePointRipTypeDef Properties > SinglePointRipTypeDef.Parent Property


SinglePointRipTypeDef.Point Property

SinglePointRipTypeDef.Point Property Introduced in Inventor 2011
Summary

Property that gets and sets the point that defines the location of the rip. Valid input includes Vertex, WorkPoint, SketchPoint, and SketchPoint3D objects.

Visual Basic
Property Point() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface > SinglePointRipTypeDef Properties > SinglePointRipTypeDef.Point Property


SinglePointRipTypeDef.Type Property

SinglePointRipTypeDef.Type Property Introduced in Inventor 2011
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SinglePointRipTypeDef Interface > SinglePointRipTypeDef Properties > SinglePointRipTypeDef.Type Property


Sketch Interface

Sketch Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The generic Sketch object. All types of Sketch objects derive from this object. See the article in the overviews section.

Class Hierarchy
Inventor::Sketch
    Inventor::DrawingSketch
    Inventor::PlanarSketch
Visual Basic
Public Interface Sketch
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionConstraint.Parent

GeometricConstraint.Parent

Profile.Parent

SketchBlock.Parent

SketchEntity.Parent

SketchesEnumerator.Item

SketchFillRegion.Parent

TextBox.Parent

Document.ActivatedObject

Application.ActiveEditObject

ClientFeatureElement.Element

ThreePlanesWorkPointDef.Plane1

TwoPlanesWorkAxisDef.Plane1

TwoPlanesWorkPlaneDef.Plane1

ThreePlanesWorkPointDef.Plane2

TwoPlanesWorkAxisDef.Plane2

TwoPlanesWorkPlaneDef.Plane2

ThreePlanesWorkPointDef.Plane3

iFeatureSketchPlaneInput.PlaneInput

iFeatureWorkPlaneInput.PlaneInput

See Also

Copy sketch contents sample

Defer sketch updates sample

Sketch profile control sample

Sketch Text Add sample

Create SketchedSymbol Definition sample

Move sketch entities sample

Copy a sketch sample

Example 1

See Sketch::OffsetSketchEntitiesUsingDistance for example "Offset a 2D sketch"

Example 2

See Sketch::MoveSketchObjects for example "Move sketch objects"

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface


Sketch Methods

Sketch Methods
Summary

The methods of the Sketch class are listed here.

Methods
Methods
Name
Description
AddByProjectingEntity
Method that creates a new sketch entity by projecting other entities onto the sketch plane. This method performs the same function as the Project Geometry command.
CopyContentsTo
Method that copies all the contents of the sketch to the input target sketch.
Delete

Method that deletes the sketch. This method is only valid for sketches that are not used by a feature.
Edit

Method that causes the Sketch environment to be invoked with this sketch available for interactive edit.
ExitEdit
Causes the Sketch environment to be closed and the user interface to return to the previous environment. This is equivalent to the Return command. This method is only valid in the case where this sketch is open for edit within the user interface.
GetCustomLineType

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
GetReferenceKey
Method that generates and returns the reference key for this entity.
MoveSketchObjects
Method that moves a collection of sketch objects by a specified vector. If the Copy argument is set to True, the newly created objects are returned.
OffsetSketchEntitiesUsingDistance
Method that offsets a sketch entity or a group of connected sketch entities. In both cases, the base sketch entity is first offset by the specified distance and along the specified direction. The base sketch entity is determined as follows:

  • If only one sketch entity needs to be offset, it will be treated as the base sketch entity.
  • If a group of end-to-end connected entities need to be offset, the first entity in the group will be treated as the base sketch entity.

If this method successfully offsets the specified input sketch entities, the newly created sketch entities are returned.... more

OffsetSketchEntitiesUsingPoint
Method that offsets a sketch entity or a group of end-to-end connected sketch entities. In both cases, the offset is first applied to the base sketch entity such that the offset of the base sketch entity passes through the specified offset point on the sketch. The shortest distance of this offset point from the original base sketch entity determines the offset distance.
RotateSketchObjects
Method that rotates a collection of sketch objects by a specified angle. If the Copy argument is set to True, the newly created objects are returned.
SetCustomLineType

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
Solve
Method that causes the sketch to solve.
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods


Sketch.AddByProjectingEntity Method

Sketch.AddByProjectingEntity Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new sketch entity by projecting other entities onto the sketch plane. This method performs the same function as the Project Geometry command.

Visual Basic
Sub AddByProjectingEntity(Entity As IDispatch, Result As [out, retval] SketchEntity*)
Parameters
Parameters | Description
Entity | Input object to project onto the sketch plane. In a part context, valid input includes the various 2d sketch objects, the various 3d sketch objects, Edge, Vertex, WorkAxis, and WorkPoints. WorkPlanes that are perpendicular to the sketch are also valid. In an assembly context (where this method is called on a PlanarSketchProxy object) this method that projects an entity from one part into a sketch in another part. The valid input in this case includes the various 2d sketch proxy objects, the various 3d sketch proxy objects, EdgeProxy, VertexProxy, WorkAxisProxy, and WorkPointProxy objects. WorkPlaneProxy objects that are perpendicular to the sketch are also valid.
See Also

Sketch from face silhouette sample

Example

"Projection - project across parts Example "

This sample demonstrates projecting a sketch entity across parts in an assembly. To use the sample, have an assembly open that contains at least two occurrences, (parts only), and run the program.

Public Sub ProjectingAcrossParts()

' Set a reference to the assembly component definition.
Dim oAsmCompDef As AssemblyComponentDefinition
Set oAsmCompDef = ThisApplication.ActiveDocument.ComponentDefinition

' Get references to two occurrences.
' This arbitrarily gets the first and second occurrence.
Dim oOcc1 As ComponentOccurrence
Set oOcc1 = oAsmCompDef.Occurrences.Item(1)

Dim oOcc2 As ComponentOccurrence
Set oOcc2 = oAsmCompDef.Occurrences.Item(2)

' Create a sketch on the first part.
Dim oSketch1 As PlanarSketch
Set oSketch1 = oOcc1.Definition.Sketches.Add(oOcc1.Definition.WorkPlanes(1))

' Set a reference to the transient geometry collection.
Dim oTransGeom As TransientGeometry
Set oTransGeom = ThisApplication.TransientGeometry

' Create a sketch line on the sketch.
Dim oSketchLine1 As Object
Set oSketchLine1 = oSketch1.SketchLines.AddByTwoPoints(oTransGeom.CreatePoint2d(0, 0), _
oTransGeom.CreatePoint2d(4, 0))

' Because we need the sketch line in the context of the assembly
' we need to create a proxy for the sketch line. The proxy
' represents the sketch line in the context of the assembly.
Dim oSketchLine1Proxy As Object
Call oOcc1.CreateGeometryProxy(oSketchLine1, oSketchLine1Proxy)

' Create a sketch on the second part.
Dim oSketch2 As PlanarSketch
Set oSketch2 = oOcc2.Definition.Sketches.Add(oOcc2.Definition.WorkPlanes(1))

' Create a proxy for the sketch in the second part.
Dim oSketch2Proxy As PlanarSketchProxy
Call oOcc2.CreateGeometryProxy(oSketch2, oSketch2Proxy)

' Project the line in the sketch in the first
' part to the sketch in the second part
Dim oSketchLine2Proxy As SketchLineProxy
Set oSketchLine2Proxy = oSketch2Proxy.AddByProjectingEntity(oSketchLine1Proxy)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.AddByProjectingEntity Method


Sketch.CopyContentsTo Method

Sketch.CopyContentsTo Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that copies all the contents of the sketch to the input target sketch.

Visual Basic
Sub CopyContentsTo(TargetSketch As Sketch)
Parameters
Parameters | Description
TargetSketch | Sketch object that specifies the target sketch into which the contents of the sketch should be copied.
Example

Copy sketch contents example.

This sample shows how to copy the contents of one sketch to another.

Public Sub CopySketch()

    Dim oCmdMgr As CommandManager
    Set oCmdMgr = ThisApplication.CommandManager

    Dim oSourceSketch As Sketch
    Set oSourceSketch = oCmdMgr.Pick(kSketchObjectFilter, "Select source sketch")

    Dim oTargetSketch As Sketch
    Set oTargetSketch = oCmdMgr.Pick(kSketchObjectFilter, "Select target sketch")

    Call oSourceSketch.CopyContentsTo(oTargetSketch)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.CopyContentsTo Method


Sketch.Delete Method

Sketch.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the sketch. This method is only valid for sketches that are not used by a feature.

Visual Basic
Sub Delete()
Remarks

This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.

Example

"Sketch Delete Example "

This sample demonstrates deleting a sketch.

To use this sample, have a part document open that contains a sketch named Sketch1. The sketch cannot have any dependents, or the delete will fail.

Public Sub DeleteSketch()
' Set a reference to the Sketches collection. This assumes
' that a part document containing a sketch is active.
Dim oSketches As PlanarSketches
Set oSketches = ThisApplication.ActiveDocument.ComponentDefinition.Sketches

' Get the sketch named "Sketch1".
On Error Resume Next
Dim oSketch As PlanarSketch
Set oSketch = oSketches.Item("Sketch1")
If Err Then
  MsgBox "A Sketch named ""Sketch1"" must exist."
  Exit Sub
End If
On Error GoTo 0

' Check to see if the sketch has any dependents.
If oSketch.Dependents.Count > 0 Then
  MsgBox "Cannot delete a sketch with dependents."
Else
  ' Delete the sketch.
  oSketch.Delete
End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.Delete Method


Sketch.Edit Method

Sketch.Edit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that causes the Sketch environment to be invoked with this sketch available for interactive edit.

Visual Basic
Sub Edit()
Example

"Sketch Open for Edit Example "

This sample demonstrates opening a sketch for edit.

To use this sample, have a part document open that contains a sketch named Sketch1.

Public Sub StartSketchEdit()
' Set a reference to the Sketches collection. This assumes
' that a part document containing a sketch is active.
Dim oSketches As PlanarSketches
Set oSketches = ThisApplication.ActiveDocument.ComponentDefinition.Sketches

' Get the sketch named "Sketch1".
On Error Resume Next
Dim oSketch As PlanarSketch
Set oSketch = oSketches.Item("Sketch1")
If Err Then
  MsgBox "A Sketch named ""Sketch1"" must exist."
  Exit Sub
End If
On Error GoTo 0

' Open the sketch for edit to allow the user to edit it.
oSketch.Edit
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.Edit Method


Sketch.ExitEdit Method

Sketch.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Causes the Sketch environment to be closed and the user interface to return to the previous environment. This is equivalent to the Return command. This method is only valid in the case where this sketch is open for edit within the user interface.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.ExitEdit Method


Sketch.GetCustomLineType Method

Sketch.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.GetCustomLineType Method


Sketch.GetReferenceKey Method

Sketch.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.GetReferenceKey Method


Sketch.MoveSketchObjects Method

Sketch.MoveSketchObjects Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that moves a collection of sketch objects by a specified vector. If the Copy argument is set to True, the newly created objects are returned.

Visual Basic
Sub MoveSketchObjects(SketchObjects As ObjectCollection, Vector As Vector2d, ByRef Copy As [defaultvalue(0)] VARIANT_BOOL, ByRef RemoveConstraints As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
SketchObjects | Input ObjectCollection that contains the sketch elements to move. The collection must contain at least one object and can be any SketchEntity, a TextBox or an Image.
Vector | Input Vector2d object that defines the delta distance to move the sketch elements.
Copy | Optional input Boolean that specifies whether to copy the sketch elements to the new location or to move them. If not specified, a default value of False is used indicating that the elements will be moved.
RemoveConstraints | Optional input Boolean that specifies whether to remove or retain some of the constraints that constrain the input sketch entities to other geometry. If not specified, a default value of False is used indicating that the constraints will be retained.
See Also

Copy a sketch sample

Example

"Move sketch entities."

This sample demonstrates the translation of all the objects on the active sketch by a certain distance. Have a sketch active that contains several entities (this could include text boxes and images) and run the sample.

Public Sub MoveSketchObjects()

    ' Check to make sure a sketch is open.
    If Not Typeof ThisApplication.ActiveEditObject Is Sketch Then
        MsgBox "A sketch must be active."
        Exit Sub
    End If

    ' Set a reference to the active sketch.
    Dim oSketch As Sketch
    Set oSketch = ThisApplication.ActiveEditObject

    ' Create a vector along the x-axis.
    Dim oVec As Vector2d
    Set oVec = ThisApplication.TransientGeometry.CreateVector2d(5, 0)

    Dim oSketchObjects As ObjectCollection
    Set oSketchObjects = ThisApplication.TransientObjects.CreateObjectCollection

    ' Get all entities in the sketch
    Dim oSketchEntity As SketchEntity
    For Each oSketchEntity In oSketch.SketchEntities
        oSketchObjects.Add oSketchEntity
    Next

    ' Move all sketch objects along x-axis by 5 units.
    ' This will move all the text boxes and images in
    ' the sketch as well since these have sketch lines
    ' as boundary geometry or a sketch point as an
    ' origin point.
    Call oSketch.MoveSketchObjects(oSketchObjects, oVec)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.MoveSketchObjects Method


Sketch.OffsetSketchEntitiesUsingDistance Method

Sketch.OffsetSketchEntitiesUsingDistance Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that offsets a sketch entity or a group of connected sketch entities. In both cases, the base sketch entity is first offset by the specified distance and along the specified direction. The base sketch entity is determined as follows:

  • If only one sketch entity needs to be offset, it will be treated as the base sketch entity.
  • If a group of end-to-end connected entities need to be offset, the first entity in the group will be treated as the base sketch entity.

If this method successfully offsets the specified input sketch entities, the newly created sketch entities are returned.

Visual Basic
Sub OffsetSketchEntitiesUsingDistance(SketchEntities As ObjectCollection, OffsetDistance As double, NaturalOffsetDirection As VARIANT_BOOL, ByRef IncludeConnectedEntities As [defaultvalue(0)] VARIANT_BOOL, ByRef CreateOffsetConstraints As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchEntitiesEnumerator*)
Parameters
Parameters
Description
SketchEntities
ObjectCollection that specifies either a single sketch entity or a set of sketch entities that need to be offset. The collection can contain any SketchEntity object except SketchPoint because sketch points cannot be offset. The first entity in the collection is always treated as the base sketch entity. The offset distance (OffsetDistance argument) and the offset direction (NaturalOffsetDirection argument) apply to this base sketch entity. If only one sketch entity needs to be offset, then it should be specified as the only item in the collection and the IncludeConnectedEntities argument should be specified as False. Since the entity specified in the collection is the first and only item in the collection, it will be treated as the base sketch entity. If a group of end-to-end connected sketch entities need to be offset, then they can be specified using one of the following options:

  • Specifying an exact set of sketch entities to offset. The collection can be used to specify an exact set of sketch entities that need to be offset. The objects in the collection must represent entities that are end-to-end connected and the collection must contain the objects in the order that they are connected. The first entity specified in the collection will be treated as the base sketch entity.
  • Specifying only the base sketch entity and automatically including connected entities. The base sketch entity should be specified as the only item in the collection. The IncludeConnectedEntities boolean argument should be specified as True to indicate that all entities that form a loop (open or closed) which contains the base sketch entity should be automatically included to be offset.

Since only one of the above options to specify a group of connected entities can be used at the same time and not both, if the collection contains multiple entities, it implies that the collection is being used to explicitly specify an exact set of sketch entities to offset, in which case the IncludeConnectedEntities argument should be False. If True is specified, the method will fail and the sketch entities will not be offset.

OffsetDistance
Specifies the offset distance for the base sketch entity (the sketch entity specified by the first item in the SketchEntities collection). Since a group of connected entities that need to be offset will all be offset by the same distance, it implies that the distance value specified by this argument will be used not only for the base sketch entity but also for all the remaining connected sketch entities. Since the offset of the base sketch entity can lie on either side of the base entity, the offset distance in itself does not provide sufficient information regarding the final position for the offset of the base sketch entity. The NaturalOffsetDirection boolean argument can be used to specify one out of the two possible offset directions for the base sketch entity. Thus, the offset distance specified by this argument and the offset direction specified by the NaturalOffsetDirection boolean argument together determine the final position for the offset of the base sketch entity. Once the offset position for the base sketch entity is determined, the offset positions for any other additional connected sketch entities can be inferred.
NaturalOffsetDirection
Value that can be used to specify one out of the two possible offset directions. This argument applies to the base sketch entity (the sketch entity specified by the first item in the SketchEntities collection). The natural offset direction is along the natural normal direction at any point on the base sketch entity which in-turn is defined as the cross-product of the vector representing the tangent at that point and the vector representing the sketch normal. If True is specified, then the points on the offset of the base sketch entity will be positioned in the direction specified by the natural normal at the corresponding points on the original base sketch entity. If False is specified, then the offset of the base sketch entity will be positioned in the direction opposite to that of the natural normal. Thus, this argument determines on which side of the base sketch entity the offset of the base sketch entity will be placed. Since this argument specifies only the offset direction, the OffsetDistance argument has to be used to specify the offset distance along the offset direction specified by this argument. Thus, the offset direction specified by this argument and the offset distance specified by the OffsetDistance argument together determine the final position for the offset of the base sketch entity. Once the offset position for the base sketch entity is determined, the offset positions for any other additional connected sketch entities can be inferred.
IncludeConnectedEntities
Value that specifies whether all entities that form a loop containing the base sketch entity should also be offset. If True is specified, then all loop entities will be offset. But, if the sketch has multiple loops that contain the base sketch entity in which case it will not be possible to uniquely determine a single loop that needs to be offset, only the base sketch entity will be offset. If False is specified, then only the entities specified in the SketchEntities collection will be offset. If True is specified, the SketchEntities collection should contain only one item that corresponds to the base sketch entity, otherwise, if the SketchEntities collection contains multiple entities, then this method will fail and the sketch entities will not be offset. If False is specified, the SketchEntities collection can contain either a single item that corresponds to the base sketch entity or multiple items that correspond to a group of end-to-end connected entities. If the collection contains a single item that corresponds to the base sketch entity, then only this base sketch entity will be offset. On the other hand, if the collection contains multiple items, it implies that the collection is being used to specify an exact set of sketch entities to offset, hence, only those exact set of sketch entities will be offset. If no value is specified for this argument, then a default value of False will be assumed.
CreateOffsetConstraints
Value that specifies whether offset constraints between the original and offset entities should be automatically created. If True is specified, then offset constraints will be automatically created. If False is specified, then offset constraints will not be created. If no value is specified, then a default value of True will be assumed to indicate that the offset constraints will be automatically created.
Remarks

In the case that a group of end-to-end connected entities need to be offset, the offset positions for all other connected sketch entities can be inferred after the base sketch entity has been offset by the specified distance and along the specified direction. (A group of connected entities that need to be offset will all be offset by the same distance. Therefore, it implies that the specified offset distance applies not only to the base sketch entity but also to all other remaining connected sketch entities. The offset direction of the base sketch entity will be used to infer the offset directions for the connected entities).

Example

"Offset a 2D sketch"

This sample demonstrates the creation of offsets in 2d sketches. Two ways of creating the offset are shown - one uses a distance and the other uses the input point.

Public Sub Offset()
    ' Check to make sure a sketch is open.
    If Not Typeof ThisApplication.ActiveEditObject Is PlanarSketch Then
        MsgBox "A sketch must be active."
        Exit Sub
    End If

    ' Set a reference to the active sketch.
    Dim oSketch As PlanarSketch
    Set oSketch = ThisApplication.ActiveEditObject

    ' Set a reference to the transient geometry collection.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create a rectangle
    Dim oRectangleLines As SketchEntitiesEnumerator
    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
                                                oTransGeom.CreatePoint2d(0, 0), _
                                                oTransGeom.CreatePoint2d(10, -10))

    ' Create a new object collection
    Dim oCollection As ObjectCollection
    Set oCollection = ThisApplication.TransientObjects.CreateObjectCollection

    ' Add the first sketch line of the rectangle to the collection
    oCollection.Add oRectangleLines.Item(1)

    ' Create a point at (0,3). The entity resulting
    ' from the offset of the first sketch line must
    ' pass thru this point.
    Dim oOffsetPoint As Point2d
    Set oOffsetPoint = oTransGeom.CreatePoint2d(0, 3)

    ' Create an offset rectangle using the offset point.
    Call oSketch.OffsetSketchEntitiesUsingPoint(oCollection, oOffsetPoint, True)

    ' Get the sketch normal
    Dim oNormalVector As UnitVector
    Set oNormalVector = oSketch.PlanarEntityGeometry.Normal

    ' Get the direction of the sketch line being offset
    Dim oLineDir As UnitVector2d
    Set oLineDir = oRectangleLines.Item(1).Geometry.Direction

    Dim oLineVector As UnitVector
    Set oLineVector = oTransGeom.CreateUnitVector(oLineDir.X, oLineDir.Y, 0)

    ' The cross product of these vectors is the
    ' natural offset direction for the sketch line.
    Dim oOffsetVector As UnitVector
    Set oOffsetVector = oLineVector.CrossProduct(oNormalVector)

    ' Get the desired offset vector (the +ve y-axis)
    Dim oDesiredVector As UnitVector
    Set oDesiredVector = oTransGeom.CreateUnitVector(0, 1, 0)

    Dim bNaturalOffsetDir As Boolean

    If oOffsetVector.IsEqualTo(oDesiredVector) Then
        bNaturalOffsetDir = True
    Else
        bNaturalOffsetDir = False
    End If

    ' Create an offset at a distance of 6 cms.
    Call oSketch.OffsetSketchEntitiesUsingDistance(oCollection, 6, bNaturalOffsetDir, True)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.OffsetSketchEntitiesUsingDistance Method


Sketch.OffsetSketchEntitiesUsingPoint Method

Sketch.OffsetSketchEntitiesUsingPoint Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that offsets a sketch entity or a group of end-to-end connected sketch entities. In both cases, the offset is first applied to the base sketch entity such that the offset of the base sketch entity passes through the specified offset point on the sketch. The shortest distance of this offset point from the original base sketch entity determines the offset distance.

Visual Basic
Sub OffsetSketchEntitiesUsingPoint(SketchEntities As ObjectCollection, OffsetPoint As Point2d, ByRef IncludeConnectedEntities As [defaultvalue(0)] VARIANT_BOOL, ByRef CreateOffsetConstraints As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchEntitiesEnumerator*)
Parameters
Parameters
Description
SketchEntities
ObjectCollection that specifies either a single sketch entity or a set of sketch entities that need to be offset. The collection can contain any SketchEntity object except SketchPoint because sketch points cannot be offset. The first entity in the collection is always treated as the base sketch entity. The offset distance (OffsetDistance argument) and the offset direction (NaturalOffsetDirection argument) apply to this base sketch entity. If only one sketch entity needs to be offset, then it should be specified as the only item in the collection and the IncludeConnectedEntities argument should be specified as False. Since the entity specified in the collection is the first and only item in the collection, it will be treated as the base sketch entity. If a group of end-to-end connected sketch entities need to be offset, then they can be specified using one of the following options:

  • Specifying an exact set of sketch entities to offset. The collection can be used to specify an exact set of sketch entities that need to be offset. The objects in the collection must represent entities that are end-to-end connected and the collection must contain the objects in the order that they are connected. The first entity specified in the collection will be treated as the base sketch entity.
  • Specifying only the base sketch entity and automatically including connected entities. The base sketch entity should be specified as the only item in the collection. The IncludeConnectedEntities boolean argument should be specified as True to indicate that all entities that form a loop (open or closed) which contains the base sketch entity should be automatically included to be offset.

Since only one of the above options to specify a group of connected entities can be used at the same time and not both, if the collection contains multiple entities, it implies that the collection is being used to explicitly specify an exact set of sketch entities to offset, in which case the IncludeConnectedEntities argument should be False. If True is specified, the method will fail and the sketch entities will not be offset.

OffsetPoint
Defines a point on the sketch through which the offset of the base sketch entity (the sketch entity specified by the first item in the SketchEntities collection) should pass. The shortest distance of this point from the base sketch entity is used to determine the offset distance. This offset distance will also be used to offset any other additional connected sketch entities. The location of the point with respect to the base sketch entity determines the position of the offset base sketch entity (i.e. the location of the point determines on which side of the base sketch entity the offset of the base sketch entity will be positioned). Once the offset distance and position for the offset of the base sketch entity are determined, this information is used to determine the position for all other connected sketch entities that need to be offset. Thus, the offset point provides sufficient information to calculate the offset distance as well as the offset direction for all the sketch entities that need to be offset.
IncludeConnectedEntities
Value that specifies whether all entities that form a loop containing the base sketch entity should also be offset. If True is specified, then all loop entities will be offset. But, if the sketch has multiple loops that contain the base sketch entity in which case it will not be possible to uniquely determine a single loop that needs to be offset, only the base sketch entity will be offset. If False is specified, then only the entities specified in the SketchEntities collection will be offset. If True is specified, the SketchEntities collection should contain only one item that corresponds to the base sketch entity, otherwise, if the SketchEntities collection contains multiple entities, then this method will fail and the sketch entities will not be offset. If False is specified, the SketchEntities collection can contain either a single item that corresponds to the base sketch entity or multiple items that correspond to a group of end-to-end connected entities. If the collection contains a single item that corresponds to the base sketch entity, then only this base sketch entity will be offset. On the other hand, if the collection contains multiple items, it implies that the collection is being used to specify an exact set of sketch entities to offset, hence, only those exact set of sketch entities will be offset. If no value is specified for this argument, then a default value of False will be assumed.
CreateOffsetConstraints
Value that specifies whether offset constraints between the original and offset entities should be automatically created. If True is specified, then offset constraints will be automatically created. If False is specified, then offset constraints will not be created. If no value is specified, then a default value of True will be assumed to indicate that the offset constraints will be automatically created.
Remarks

The base sketch entity is determined as follows:

  • If only one sketch entity needs to be offset, it will be treated as the base sketch entity.
  • If a group of end-to-end connected entities need to be offset, the first entity in the group will be treated as the base sketch entity.

If this method successfully offsets the specified input sketch entities, the newly created sketch entities are returned.

In the case that a group of end-to-end connected entities need to be offset, the offset positions for all other connected sketch entities can be inferred after the base sketch entity has been offset to pass through the specified point. (A group of connected entities that need to be offset will all be offset by the same distance. Therefore, the offset distance between the original base sketch entity and its offset will also be used to offset all other connected sketch entities. The offset direction of the base sketch entity will be used to infer the offset directions for the connected entities).

See Also

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.OffsetSketchEntitiesUsingPoint Method


Sketch.RotateSketchObjects Method

Sketch.RotateSketchObjects Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that rotates a collection of sketch objects by a specified angle. If the Copy argument is set to True, the newly created objects are returned.

Visual Basic
Sub RotateSketchObjects(SketchObjects As ObjectCollection, CenterPoint As Point2d, Angle As double, ByRef Copy As [defaultvalue(0)] VARIANT_BOOL, ByRef RemoveConstraints As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
SketchObjects | Input ObjectCollection that contains the sketch elements to rotate. The collection must contain at least one object and can be any SketchEntity, a TextBox or an Image.
CenterPoint | Input Point2d object that defines the center point to rotate the elements about.
Angle | Input Double that defines the angle to rotate the elements by in radians.
Copy | Optional input Boolean that specifies whether to copy the sketch elements to the new location or to rotate them. If not specified, a default value of False is used indicating that the elements will be rotated.
RemoveConstraints | Optional input Boolean that specifies whether to remove or retain some of the constraints that constrain the input sketch entities to other geometry. If not specified, a default value of False is used indicating that the constraints will be retained.
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.RotateSketchObjects Method


Sketch.SetCustomLineType Method

Sketch.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.SetCustomLineType Method


Sketch.Solve Method

Sketch.Solve Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that causes the sketch to solve.

Visual Basic
Sub Solve()
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Methods > Sketch.Solve Method


Sketch Properties

Sketch Properties
Summary

The properties of the Sketch class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Color | Property that gets and sets the color for the sketch. Setting the property to Nothing restores the sketch to the default color.
ConstraintStatus | Property that returns an enum indicating the constraint status of the sketch entity, signifying whether it is fully constrained, over constrained, or under constrained.
DataIO | Gets the object through which this sketch's data content can be persisted.
DeferUpdates | Property that indicates whether to defer the solving of the sketch. Defaults to False. When set (back) to False, the entire sketch is automatically solved.
DimensionConstraints | Gets the collection of all dimension constraints on the sketch.
DisabledActionTypes | Gets and sets the action types valid for this sketch.
GeometricConstraints | Property that returns the collection of all geometric constraints on the sketch.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the line weight override for the sketch. Setting the property to 0 restores the sketch to the default line weight.
Name | Property that indicates the name of this object or instance.
Parent | Property that gets the parent object from whom this object can logically be reached.
SketchArcs | Property that returns the SketchArcs collection object.
SketchCircles | Property that returns the SketchArcs collection object.
SketchEllipses | Property that returns the SketchEllipses collection object.
SketchEllipticalArcs | Property that returns the SketchEllipticalArcs collection object.
SketchEntities | Property that returns the collection of all entities on the sketch, regardless of their type.
SketchFixedSplines | Property that gets the collection object.
SketchImages | Property that returns a collection of all images on the sketch.
SketchLines | Property that returns the SketchLines collection object. This collection provides access to the existing lines in the sketch and provides functionality to create new lines.
SketchOffsetSplines | Property that returns the collection object. This collection provides access to the existing offset splines in the sketch.
SketchPoints | Property that returns the SketchPoints collection object.
SketchSplines | Property that returns the SketchSplines collection object.
TextBoxes | Gets the TextBoxes collection associated with this Sketch.
Type | Property returning an enum indicating this object's type.
Visible | Property that indicates the visibility of the sketch.
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties


Sketch.Application Property

Sketch.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.Application Property


Sketch.AttributeSets Property

Sketch.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.AttributeSets Property


Sketch.Color Property

Sketch.Color Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color for the sketch. Setting the property to Nothing restores the sketch to the default color.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.Color Property


Sketch.ConstraintStatus Property

Sketch.ConstraintStatus Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns an enum indicating the constraint status of the sketch entity, signifying whether it is fully constrained, over constrained, or under constrained.

Visual Basic
Property ConstraintStatus() As ConstraintStatusEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.ConstraintStatus Property


Sketch.DataIO Property

Sketch.DataIO Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object through which this sketch's data content can be persisted.

Visual Basic
Property DataIO() As DataIO**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.DataIO Property


Sketch.DeferUpdates Property

Sketch.DeferUpdates Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates whether to defer the solving of the sketch. Defaults to False. When set (back) to False, the entire sketch is automatically solved.

Visual Basic
Property DeferUpdates() As VARIANT_BOOL
Example

"Defer sketch updates"

This sample demonstrates the sketch defer update functionality. To run this sample, have a 2d sketch active. Choosing 'Yes' in the dialog popped up by this sample defers the sketch update and creates the circle (approximated by 500 lines) much faster.

Public Sub DeferSketchUpdate()
' Check to make sure a sketch is open.
If Not Typeof ThisApplication.ActiveEditObject Is Sketch Then
  MsgBox "A sketch must be active."
  Exit Sub
End If

' Set a reference to the active sketch.
Dim oSketch As Sketch
Set oSketch = ThisApplication.ActiveEditObject

' Set a reference to the transient geometry collection.
Dim oTransGeom As TransientGeometry
Set oTransGeom = ThisApplication.TransientGeometry

Dim bDeferUpdatesSet As Boolean
bDeferUpdatesSet = False

If MsgBox("Suppress sketch solve?", vbYesNo) = vbYes Then
  ' Defer sketch updates
  oSketch.DeferUpdates = True
  bDeferUpdatesSet = True
End If

' Draw a circle using 500 lines.
Dim dRadius As Double
dRadius = 2
Dim dAngle As Double
dAngle = 0
Dim i As Long
For i = 0 To 499
  Dim oPt1 As Point2d
  Set oPt1 = oTransGeom.CreatePoint2d(dRadius * Cos(dAngle), dRadius * Sin(dAngle))

  dAngle = dAngle + (3.14159265358979 / 250)

  Dim oPt2 As Point2d
  Set oPt2 = oTransGeom.CreatePoint2d(dRadius * Cos(dAngle), dRadius * Sin(dAngle))

  Dim oLine As SketchLine
  Set oLine = oSketch.SketchLines.AddByTwoPoints(oPt1, oPt2)

Next

If bDeferUpdatesSet = True Then
  ' Unset defer updates
  oSketch.DeferUpdates = False 'A full sketch solve occurs
End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.DeferUpdates Property


Sketch.DimensionConstraints Property

Sketch.DimensionConstraints Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets the collection of all dimension constraints on the sketch.

Visual Basic
Property DimensionConstraints() As DimensionConstraints**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.DimensionConstraints Property


Sketch.DisabledActionTypes Property

Sketch.DisabledActionTypes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the action types valid for this sketch.

Visual Basic
Property DisabledActionTypes() As ActionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.DisabledActionTypes Property


Sketch.GeometricConstraints Property

Sketch.GeometricConstraints Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the collection of all geometric constraints on the sketch.

Visual Basic
Property GeometricConstraints() As GeometricConstraints**
See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.GeometricConstraints Property


Sketch.LineType Property

Sketch.LineType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.LineType Property


Sketch.LineWeight Property

Sketch.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the line weight override for the sketch. Setting the property to 0 restores the sketch to the default line weight.

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.LineWeight Property


Sketch.Name Property

Sketch.Name Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.Name Property


Sketch.Parent Property

Sketch.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.Parent Property


Sketch.SketchArcs Property

Sketch.SketchArcs Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchArcs collection object.

Visual Basic
Property SketchArcs() As SketchArcs**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchArcs Property


Sketch.SketchCircles Property

Sketch.SketchCircles Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchArcs collection object.

Visual Basic
Property SketchCircles() As SketchCircles**
See Also

Sketch profile control sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchCircles Property


Sketch.SketchEllipses Property

Sketch.SketchEllipses Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchEllipses collection object.

Visual Basic
Property SketchEllipses() As SketchEllipses**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchEllipses Property


Sketch.SketchEllipticalArcs Property

Sketch.SketchEllipticalArcs Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchEllipticalArcs collection object.

Visual Basic
Property SketchEllipticalArcs() As SketchEllipticalArcs**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchEllipticalArcs Property


Sketch.SketchEntities Property

Sketch.SketchEntities Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the collection of all entities on the sketch, regardless of their type.

Visual Basic
Property SketchEntities() As SketchEntitiesEnumerator**
See Also

Move sketch entities sample

Copy a sketch sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchEntities Property


Sketch.SketchFixedSplines Property

Sketch.SketchFixedSplines Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the collection object.

Visual Basic
Property SketchFixedSplines() As SketchFixedSplines**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchFixedSplines Property


Sketch.SketchImages Property

Sketch.SketchImages Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a collection of all images on the sketch.

Visual Basic
Property SketchImages() As SketchImages**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchImages Property


Sketch.SketchLines Property

Sketch.SketchLines Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchLines collection object. This collection provides access to the existing lines in the sketch and provides functionality to create new lines.

Visual Basic
Property SketchLines() As SketchLines**
See Also

Create sheet metal face and fold features sample

Sketch Add Oriented sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Border Create and Insert sample

Example

"Sketch Lines Example"

This sample demonstrates creating lines. It uses all of the various methods to create lines, both singly and as rectangles.

To run this sample you must have a sketch active.

Public Sub DrawSketchLine()
' Check to make sure a sketch is open.
If Not TypeOf ThisApplication.ActiveEditObject Is PlanarSketch Then
  MsgBox "A sketch must be active."
  Exit Sub
End If

' Set a reference to the active sketch.
Dim oSketch As PlanarSketch
Set oSketch = ThisApplication.ActiveEditObject

' Set a reference to the transient geometry collection.
Dim oTransGeom As TransientGeometry
Set oTransGeom = ThisApplication.TransientGeometry

' Create a new transaction to wrap the construction of the three lines
' into a single undo.
Dim oTrans As Transaction
Set oTrans = ThisApplication.TransactionManager.StartTransaction( _
ThisApplication.ActiveDocument, _
"Create Triangle Sample")

' Create the first line of the triangle. This uses two transient points as
' input to definethe coordinates of the ends of the line. Since a transient
' point is input a sketch point is automatically created at that location and
' the line is attached to it.
Dim oLines(1 To 3) As SketchLine
Set oLines(1) = oSketch.SketchLines.AddByTwoPoints(oTransGeom.CreatePoint2d(0, 0), _
oTransGeom.CreatePoint2d(4, 0))

' Create a sketch line that is connected to the sketch point the previous lines
' end point is connected to. This will automatically create the constraint to
' tie the new line to the sketch point the previous line is also connected to.
' This will result in the two lines being connected since they're both tied
' to the same sketch point.
Set oLines(2) = oSketch.SketchLines.AddByTwoPoints(oLines(1).EndSketchPoint, _
oTransGeom.CreatePoint2d(2, 3))

' Create a third line and connect it to the start point of the first line and the
' end point of the second line. This will result in a connected triangle.
Set oLines(3) = oSketch.SketchLines.AddByTwoPoints(oLines(2).EndSketchPoint, _
oLines(1).StartSketchPoint)

' End the transaction for the triangle.
oTrans.End

' Create a rectangle whose lines are parallel to the sketch planes x and y axes
' by using the SketchLines.AddAsTwoPointRectangle method. The top point of the
' triangle will be used as input for one of the points so the rectangle will be
' tied to that point.
Dim oRectangleLines As SketchEntitiesEnumerator
Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
oLines(3).StartSketchPoint, _
oTransGeom.CreatePoint2d(5, 5))

' Create a rotated rectangle by using the SketchLines.AddAsTwoRectangle method.
' One of the corners of this rectangle will be tied to the corner of the previous
' rectangle.
Set oRectangleLines = oSketch.SketchLines.AddAsThreePointRectangle( _
oRectangleLines(2).EndSketchPoint, _
oTransGeom.CreatePoint2d(7, 3), _
oTransGeom.CreatePoint2d(8, 8))
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchLines Property


Sketch.SketchOffsetSplines Property

Sketch.SketchOffsetSplines Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the collection object. This collection provides access to the existing offset splines in the sketch.

Visual Basic
Property SketchOffsetSplines() As SketchOffsetSplines**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchOffsetSplines Property


Sketch.SketchPoints Property

Sketch.SketchPoints Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchPoints collection object.

Visual Basic
Property SketchPoints() As SketchPoints**
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchPoints Property


Sketch.SketchSplines Property

Sketch.SketchSplines Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the SketchSplines collection object.

Visual Basic
Property SketchSplines() As SketchSplines**
See Also

Sketch Spline sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.SketchSplines Property


Sketch.TextBoxes Property

Sketch.TextBoxes Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the TextBoxes collection associated with this Sketch.

Visual Basic
Property TextBoxes() As TextBoxes**
See Also

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.TextBoxes Property


Sketch.Type Property

Sketch.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.Type Property


Sketch.Visible Property

Sketch.Visible Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the visibility of the sketch.

Visual Basic
Property Visible() As VARIANT_BOOL
See Also

Sketch profile control sample

Thread Feature Create sample

Example

Set Sketch Visibility

This sample demonstrates setting the visibility of a sketch.

To use this sample have a part document open that contains at least one sketch.

Public Sub ToggleSketchVisibility()
    ' Set a reference to the Sketches collection.  This assumes
    ' that a part document containing a sketch is active.
    Dim oSketches As PlanarSketches
    Set oSketches = ThisApplication.ActiveDocument.ComponentDefinition.Sketches

    ' Get whether the sketch visibility should be turned on or off.
    Dim bVisibleOn As Boolean
    If MsgBox("Do you want to turn all sketches on?", vbYesNo + vbQuestion) = vbYes Then
        bVisibleOn = True
    Else
        bVisibleOn = False
    End If

    ' Iterate through all of the sketches and set their visibility.
    Dim oSketch As PlanarSketch
    For Each oSketch In oSketches
        If bVisibleOn Then
            oSketch.Visible = True
        Else
            oSketch.Visible = False
        End If
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > Sketch Interface > Sketch Properties > Sketch.Visible Property


Sketch3D Interface

Sketch3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The Sketch3D object provides access to the current contents of a specific 3D sketch and its related properties and methods. See the article in the overviews section.

Class Hierarchy
Inventor::Sketch3D
    Inventor::Sketch3DProxy
Visual Basic
Public Interface Sketch3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionConstraint3D.Parent

GeometricConstraint3D.Parent

Profile3D.Parent

Sketch3D.ReferencedEntity

Sketch3DProxy.NativeObject

SketchEntity3D.Parent

Sketches3D.Add

Sketches3D.Item

Sketches3DEnumerator.Item

WorkAxis.ParentSketch

WorkPlane.ParentSketch

WorkPoint.ParentSketch

Document.ActivatedObject

Application.ActiveEditObject

ClientFeatureElement.Element

See Also

Sweep Feature Add sample

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface


Sketch3D Methods

Sketch3D Methods
Summary

The methods of the Sketch3D class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the 3D sketch. This method will fail in the cases where the sketch is active, and when there are dependents on the sketch. In the cases where other geometry, besides a feature, is dependent on the sketch, the dependent geometry will be deleted or modified.
Edit | Method that causes the Sketch environment to be invoked with this sketch available for interactive edit.
ExitEdit | Method that causes the Sketch environment to be closed and the user interface to return to the previous environment. This is equivalent to the Return command. This method is only valid in the case where this sketch is open for edit within the user interface. Calling this method in other cases will not do anything.
GetReferenceKey | Method that generates and returns the reference key for this entity.
Include | Method that creates a new sketch entity by copying other entities into the sketch.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.
Solve | Method that causes the sketch to solve.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods


Sketch3D.Delete Method

Sketch3D.Delete Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that deletes the 3D sketch. This method will fail in the cases where the sketch is active, and when there are dependents on the sketch. In the cases where other geometry, besides a feature, is dependent on the sketch, the dependent geometry will be deleted or modified.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.Delete Method


Sketch3D.Edit Method

Sketch3D.Edit Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that causes the Sketch environment to be invoked with this sketch available for interactive edit.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.Edit Method


Sketch3D.ExitEdit Method

Sketch3D.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that causes the Sketch environment to be closed and the user interface to return to the previous environment. This is equivalent to the Return command. This method is only valid in the case where this sketch is open for edit within the user interface. Calling this method in other cases will not do anything.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.ExitEdit Method


Sketch3D.GetReferenceKey Method

Sketch3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.GetReferenceKey Method


Sketch3D.Include Method

Sketch3D.Include Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new sketch entity by copying other entities into the sketch.

Visual Basic
Sub Include(Entity As IDispatch, Result As [out, retval] SketchEntity3D*)
Parameters
Parameters | Description
Entity | Input object to copy into the sketch. In a part context, valid input includes Edges, 3d sketch entities and planar sketch entities. In an assembly context (where this method is called on a Sketch3DProxy object) this method that includes an entity from one part into a sketch in another part. The valid input in this case includes EdgeProxy objects, the various 3d sketch proxy objects and the various 2d sketch proxy objects.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.Include Method


Sketch3D.SetEndOfPart Method

Sketch3D.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this 3D sketch A value of True indicates before and False indicates after.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.SetEndOfPart Method


Sketch3D.Solve Method

Sketch3D.Solve Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that causes the sketch to solve.

Visual Basic
Sub Solve()
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Methods > Sketch3D.Solve Method


Sketch3D Properties

Sketch3D Properties
Summary

The properties of the Sketch3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Consumed | Gets whether the 3D Sketch is consumed or not.
DeferUpdates | Property that indicates whether to defer the solving of the sketch. Defaults to False. When set (back) to False, the entire sketch is automatically solved.
Dependents | Property that returns a collection of the objects that are dependent on the 3D sketch. Examples of objects that can be returned are profiles, features, work features, other sketches, and assembly constraints.
DimensionConstraints3D | Property that returns a collection of all dimension constraints on the 3D sketch.
DimensionsVisible | Property that indicates whether the dimensions on the sketch are visible.
DisabledActionTypes | Property that indicates the action types (ActionTypeEnum) valid for this sketch.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
GeometricConstraints3D | Property that returns a collection of all geometric constraints on the 3D sketch.
HasReferenceComponent | Property that gets the option indicating if the sketch has a reference component.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsOwnedByFeature |
Name | Property that gets and sets name of the 3D sketch. This is the name that is displayed in the browser. When setting this property, the name must be unique with respect to all other sketches in the document. If the name is not unique an error will occur.
OverrideColor | Property that gets and sets the override color for the 3D sketch. If this property is set to Nothing, the sketch uses the default colors defined in the color scheme. Note that if a sketch is assigned an override color, it still uses the default colors in the edit sketch mode. The override color takes effect only upon exiting the edit mode.
OwnedBy |
Parent | Property that returns the parent of the object. This will return the parent PartComponentDefinition.
Profiles3D | Property that returns the Profiles3D collection object.
ReferenceComponent | Property that returns the referenced component, if there is one.
ReferencedEntity | Property that returns the referenced 3D sketch, if there is one. Currently this property always returns 'Nothing'; it was implemented to support future functionality.
Shared | Property that gets and sets whether the sketch is shared or not. When setting, it can only be set to True. A sketch can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.
SilhouetteCurves | Property that returns the SilhouetteCurves collection object. This collection provides access to the existing silhouette surves in the sketch and provides functionality to create new silhouette curves.
SketchArcs3D | Property that returns the SketchArcs3D collection object. This collection provides access to the existing arcs and bends in the sketch and provides functionality to create new bends.
SketchCircles3D | Property that returns the SketchCircles3D collection object. This collection provides access to the existing circles in the sketch.
SketchEllipses3D | Property that returns the SketchEllipses3D collection object. This collection provides access to the existing ellipses in the sketch.
SketchEllipticalArcs3D | Property that returns the SketchEllipticalArcs3D collection object. This collection provides access to the existing elliptical arcs in the sketch.
SketchEntities3D | Property that returns a collection of all geometric entities on the sketch, regardless of their type.
SketchFixedSplines3D | Property that gets the collection object.
SketchLines3D | Property that returns the SketchLines3D collection object. This collection provides access to the existing lines in the sketch and provides functionality to create new lines.
SketchPoints3D | Property that returns the SketchPoints3D collection object. This collection provides access to the existing points in the sketch.
SketchSplines3D | Property that returns the SketchSplines3D collection object. This collection provides access to the existing splines in the sketch.
Type | Property returning an enum indicating this object's type.
Visible | Property that gets and sets the visibility of the 3D sketch.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties


Sketch3D.Application Property

Sketch3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Application Property


Sketch3D.AttributeSets Property

Sketch3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.AttributeSets Property


Sketch3D.Consumed Property

Sketch3D.Consumed Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets whether the 3D Sketch is consumed or not.

Visual Basic
Property Consumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Consumed Property


Sketch3D.DeferUpdates Property

Sketch3D.DeferUpdates Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates whether to defer the solving of the sketch. Defaults to False. When set (back) to False, the entire sketch is automatically solved.

Visual Basic
Property DeferUpdates() As VARIANT_BOOL
Remarks

It is not recommended to add/delete/modify constraints during a deferred update. Such operations incur potential risks when an update is pending. It would therefore be neccessary to perform extensive testing on your code to ensure no conflicts occur.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.DeferUpdates Property


Sketch3D.Dependents Property

Sketch3D.Dependents Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a collection of the objects that are dependent on the 3D sketch. Examples of objects that can be returned are profiles, features, work features, other sketches, and assembly constraints.

Visual Basic
Property Dependents() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Dependents Property


Sketch3D.DimensionConstraints3D Property

Sketch3D.DimensionConstraints3D Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns a collection of all dimension constraints on the 3D sketch.

Visual Basic
Property DimensionConstraints3D() As DimensionConstraints3D**
See Also

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.DimensionConstraints3D Property


Sketch3D.DimensionsVisible Property

Sketch3D.DimensionsVisible Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that indicates whether the dimensions on the sketch are visible.

Visual Basic
Property DimensionsVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.DimensionsVisible Property


Sketch3D.DisabledActionTypes Property

Sketch3D.DisabledActionTypes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the action types (ActionTypeEnum) valid for this sketch.

Visual Basic
Property DisabledActionTypes() As ActionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.DisabledActionTypes Property


Sketch3D.Exported Property

Sketch3D.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Exported Property


Sketch3D.GeometricConstraints3D Property

Sketch3D.GeometricConstraints3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a collection of all geometric constraints on the 3D sketch.

Visual Basic
Property GeometricConstraints3D() As GeometricConstraints3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.GeometricConstraints3D Property


Sketch3D.HasReferenceComponent Property

Sketch3D.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the option indicating if the sketch has a reference component.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.HasReferenceComponent Property


Sketch3D.HealthStatus Property

Sketch3D.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.HealthStatus Property


Sketch3D.IsOwnedByFeature Property

Sketch3D.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
Notes

For information on this item, please refer to PartFeature::IsOwnedByFeature, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.IsOwnedByFeature Property


Sketch3D.Name Property

Sketch3D.Name Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets name of the 3D sketch. This is the name that is displayed in the browser. When setting this property, the name must be unique with respect to all other sketches in the document. If the name is not unique an error will occur.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Name Property


Sketch3D.OverrideColor Property

Sketch3D.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the override color for the 3D sketch. If this property is set to Nothing, the sketch uses the default colors defined in the color scheme. Note that if a sketch is assigned an override color, it still uses the default colors in the edit sketch mode. The override color takes effect only upon exiting the edit mode.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.OverrideColor Property


Sketch3D.OwnedBy Property

Sketch3D.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property OwnedBy() As PartFeature**
Notes

For information on this item, please refer to PartFeature::OwnedBy, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.OwnedBy Property


Sketch3D.Parent Property

Sketch3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent of the object. This will return the parent PartComponentDefinition.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Parent Property


Sketch3D.Profiles3D Property

Sketch3D.Profiles3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Profiles3D collection object.

Visual Basic
Property Profiles3D() As Profiles3D**
See Also

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Profiles3D Property


Sketch3D.ReferenceComponent Property

Sketch3D.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the referenced component, if there is one.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.ReferenceComponent Property


Sketch3D.ReferencedEntity Property

Sketch3D.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the referenced 3D sketch, if there is one. Currently this property always returns 'Nothing'; it was implemented to support future functionality.

Visual Basic
Property ReferencedEntity() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.ReferencedEntity Property


Sketch3D.Shared Property

Sketch3D.Shared Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether the sketch is shared or not. When setting, it can only be set to True. A sketch can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.

Visual Basic
Property Shared() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Shared Property


Sketch3D.SilhouetteCurves Property

Sketch3D.SilhouetteCurves Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the SilhouetteCurves collection object. This collection provides access to the existing silhouette surves in the sketch and provides functionality to create new silhouette curves.

Visual Basic
Property SilhouetteCurves() As SilhouetteCurves**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SilhouetteCurves Property


Sketch3D.SketchArcs3D Property

Sketch3D.SketchArcs3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchArcs3D collection object. This collection provides access to the existing arcs and bends in the sketch and provides functionality to create new bends.

Visual Basic
Property SketchArcs3D() As SketchArcs3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchArcs3D Property


Sketch3D.SketchCircles3D Property

Sketch3D.SketchCircles3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchCircles3D collection object. This collection provides access to the existing circles in the sketch.

Visual Basic
Property SketchCircles3D() As SketchCircles3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchCircles3D Property


Sketch3D.SketchEllipses3D Property

Sketch3D.SketchEllipses3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchEllipses3D collection object. This collection provides access to the existing ellipses in the sketch.

Visual Basic
Property SketchEllipses3D() As SketchEllipses3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchEllipses3D Property


Sketch3D.SketchEllipticalArcs3D Property

Sketch3D.SketchEllipticalArcs3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchEllipticalArcs3D collection object. This collection provides access to the existing elliptical arcs in the sketch.

Visual Basic
Property SketchEllipticalArcs3D() As SketchEllipticalArcs3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchEllipticalArcs3D Property


Sketch3D.SketchEntities3D Property

Sketch3D.SketchEntities3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a collection of all geometric entities on the sketch, regardless of their type.

Visual Basic
Property SketchEntities3D() As SketchEntities3DEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchEntities3D Property


Sketch3D.SketchFixedSplines3D Property

Sketch3D.SketchFixedSplines3D Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the collection object.

Visual Basic
Property SketchFixedSplines3D() As SketchFixedSplines3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchFixedSplines3D Property


Sketch3D.SketchLines3D Property

Sketch3D.SketchLines3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchLines3D collection object. This collection provides access to the existing lines in the sketch and provides functionality to create new lines.

Visual Basic
Property SketchLines3D() As SketchLines3D**
See Also

Sweep Feature Add sample

Loft Feature With Non-Planar Section sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchLines3D Property


Sketch3D.SketchPoints3D Property

Sketch3D.SketchPoints3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchPoints3D collection object. This collection provides access to the existing points in the sketch.

Visual Basic
Property SketchPoints3D() As SketchPoints3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchPoints3D Property


Sketch3D.SketchSplines3D Property

Sketch3D.SketchSplines3D Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the SketchSplines3D collection object. This collection provides access to the existing splines in the sketch.

Visual Basic
Property SketchSplines3D() As SketchSplines3D**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.SketchSplines3D Property


Sketch3D.Type Property

Sketch3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Type Property


Sketch3D.Visible Property

Sketch3D.Visible Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the visibility of the 3D sketch.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sketch3D Interface > Sketch3D Properties > Sketch3D.Visible Property


Sketch3DOptions Interface

Sketch3DOptions Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The Sketch3DOptions object provides access to properties that provide read and write access of the 3D sketch related application options. This is somewhat equivalent to the 3D Sketch portion on the Sketch tab of the Application Options dialog.

Class Hierarchy
Inventor::Sketch3DOptions
Visual Basic
Public Interface Sketch3DOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.Sketch3DOptions

You are here: Symbol Reference > Inventor Library > Objects > Sketch3DOptions Interface


Sketch3DOptions Properties

Sketch3DOptions Properties
Summary

The properties of the Sketch3DOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutoBendWithLineCreation | Property that enables or disables automatically creating corner bends on 3D lines as they are sketched. A value of True indicates that bends will be automatically placed.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DOptions Interface > Sketch3DOptions Properties


Sketch3DOptions.Application Property

Sketch3DOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DOptions Interface > Sketch3DOptions Properties > Sketch3DOptions.Application Property


Sketch3DOptions.AutoBendWithLineCreation Property

Sketch3DOptions.AutoBendWithLineCreation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables automatically creating corner bends on 3D lines as they are sketched. A value of True indicates that bends will be automatically placed.

Visual Basic
Property AutoBendWithLineCreation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DOptions Interface > Sketch3DOptions Properties > Sketch3DOptions.AutoBendWithLineCreation Property


Sketch3DOptions.Type Property

Sketch3DOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DOptions Interface > Sketch3DOptions Properties > Sketch3DOptions.Type Property


Sketch3DProxy Interface

Sketch3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Sketch3D object.

Class Hierarchy
Inventor::Sketch3D
    Inventor::Sketch3DProxy
Visual Basic
Public Interface Sketch3DProxy
Inherits Sketch3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3DProxy Interface


Sketch3DProxy Properties

Sketch3DProxy Properties
Summary

The properties of the Sketch3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DProxy Interface > Sketch3DProxy Properties


Sketch3DProxy.ContainingOccurrence Property

Sketch3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > Sketch3DProxy Interface > Sketch3DProxy Properties > Sketch3DProxy.ContainingOccurrence Property


Sketch3DProxy.NativeObject Property

Sketch3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As Sketch3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > Sketch3DProxy Interface > Sketch3DProxy Properties > Sketch3DProxy.NativeObject Property


Sketch3DSettings Interface

Sketch3DSettings Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The Sketch3DSettings object provides access to properties that provide read and write access of the various 3D sketch related document specific settings. This is somewhat equivalent to the 3D sketch related properties on Sketch tab of the Document Settings dialog.

Class Hierarchy
Inventor::Sketch3DSettings
Visual Basic
Public Interface Sketch3DSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartDocument.Sketch3DSettings

You are here: Symbol Reference > Inventor Library > Objects > Sketch3DSettings Interface


Sketch3DSettings Properties

Sketch3DSettings Properties
Summary

The properties of the Sketch3DSettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutoBendRadius | Property that gets and sets the default radius used for corner bends automatically placed on 3D lines as they are sketched.
Parent | Property that returns the parent Document object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DSettings Interface > Sketch3DSettings Properties


Sketch3DSettings.Application Property

Sketch3DSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DSettings Interface > Sketch3DSettings Properties > Sketch3DSettings.Application Property


Sketch3DSettings.AutoBendRadius Property

Sketch3DSettings.AutoBendRadius Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the default radius used for corner bends automatically placed on 3D lines as they are sketched.

Visual Basic
Property AutoBendRadius() As String
Remarks

The radius is defined using a String expression that can be evaluated as an distance. When setting this property, you must provide a string that can be evaluated as an distance or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.

Note: To activate or suppress the auto-bend radius use the AutoBendWithLineCreation property of the ApplicationSketch3DOptions object.

You are here: Symbol Reference > Inventor Library > Objects > Sketch3DSettings Interface > Sketch3DSettings Properties > Sketch3DSettings.AutoBendRadius Property


Sketch3DSettings.Parent Property

Sketch3DSettings.Parent Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the parent Document object.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DSettings Interface > Sketch3DSettings Properties > Sketch3DSettings.Parent Property


Sketch3DSettings.Type Property

Sketch3DSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketch3DSettings Interface > Sketch3DSettings Properties > Sketch3DSettings.Type Property


SketchArc Interface

SketchArc Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchArc object represents an arc within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchArc
        Inventor::SketchArcProxy
Visual Basic
Public Interface SketchArc
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

SketchArcProxy.NativeObject

SketchArcs.AddByCenterStartEndPoint

SketchArcs.AddByCenterStartSweepAngle

SketchArcs.AddByFillet

SketchArcs.AddByThreePoints

SketchArcs.Item

AngleiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface


SketchArc Methods

SketchArc Methods
Summary

The methods of the SketchArc class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Methods


SketchArc.GetCustomLineType Method

SketchArc.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Methods > SketchArc.GetCustomLineType Method


SketchArc.SetCustomLineType Method

SketchArc.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Methods > SketchArc.SetCustomLineType Method


SketchArc Properties

SketchArc Properties
Summary

The properties of the SketchArc class are listed here.

Properties
Name | Description
CenterSketchPoint | Property that gets the sketch point that defines the position of the center of the arc.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.
EndSketchPoint | Property that returns the that defines the position of the end of the arc.
Geometry | Property that returns an geometry object. The object returned represents a 'snapshot' view of the current state of the sketch arc.
Length | Property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
OverrideColor | Gets and sets the color applied to this primitive.
Radius | Property that returns the radius of the arc.
StartAngle | Double property that returns the start angle of the arc. This is measured counterclockwise from the X axis of the sketch in radians.
StartSketchPoint | Property that gets the that defines the position of the start of the arc.
SweepAngle | Double property that returns the sweep angle of the arc. This is measured counterclockwise from the start angle of the arc in radians.
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties


SketchArc.CenterSketchPoint Property

SketchArc.CenterSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the sketch point that defines the position of the center of the arc.

Visual Basic
Property CenterSketchPoint() As SketchPoint**
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.CenterSketchPoint Property


SketchArc.CurvatureDisplay Property

SketchArc.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.CurvatureDisplay Property


SketchArc.EndSketchPoint Property

SketchArc.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the that defines the position of the end of the arc.

Visual Basic
Property EndSketchPoint() As SketchPoint**
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.EndSketchPoint Property


SketchArc.Geometry Property

SketchArc.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an geometry object. The object returned represents a 'snapshot' view of the current state of the sketch arc.

Visual Basic
Property Geometry() As Arc2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.Geometry Property


SketchArc.Length Property

SketchArc.Length Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.Length Property


SketchArc.LineDefinitionSpace Property

SketchArc.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.LineDefinitionSpace Property


SketchArc.LineScale Property

SketchArc.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.LineScale Property


SketchArc.LineType Property

SketchArc.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.LineType Property


SketchArc.LineWeight Property

SketchArc.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.LineWeight Property


SketchArc.OverrideColor Property

SketchArc.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.OverrideColor Property


SketchArc.Radius Property

SketchArc.Radius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the radius of the arc.

Visual Basic
Property Radius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.Radius Property


SketchArc.StartAngle Property

SketchArc.StartAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the start angle of the arc. This is measured counterclockwise from the X axis of the sketch in radians.

Visual Basic
Property StartAngle() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.StartAngle Property


SketchArc.StartSketchPoint Property

SketchArc.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the that defines the position of the start of the arc.

Visual Basic
Property StartSketchPoint() As SketchPoint**
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.StartSketchPoint Property


SketchArc.SweepAngle Property

SketchArc.SweepAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the sweep angle of the arc. This is measured counterclockwise from the start angle of the arc in radians.

Visual Basic
Property SweepAngle() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArc Interface > SketchArc Properties > SketchArc.SweepAngle Property


SketchArc3D Interface

SketchArc3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchArc3D object represents an arc within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchArc3D
        Inventor::SketchArc3DProxy
Visual Basic
Public Interface SketchArc3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

BendConstraint.Arc

SketchArc3DProxy.NativeObject

SketchArcs3D.AddAsBend

SketchArcs3D.AddByCenterStartEndPoint

SketchArcs3D.AddByCenterStartSweepAngle

SketchArcs3D.AddByThreePoints

SketchArcs3D.Item

You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface


SketchArc3D Properties

SketchArc3D Properties
Summary

The properties of the SketchArc3D class are listed here.

Properties
Name | Description
CenterPoint | Property that returns the center point of the arc.
CurvatureDisplay | Specifies whether curvature information is displayed for the arc.
EndSketchPoint | Property that gets the that defines the position of the end of the arc.
Geometry | Property that gets and sets the Arc3d geometry object. The object returned represents a 'snapshot' view of the current state of the sketch arc. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
Length | Double property that returns the length of the entity in centimeters.
Radius | Gets the Radius of the arc.
StartAngle | Gets the StartAngle of the arc.
StartSketchPoint | Property that gets the that defines the position of the start of the arc.
SweepAngle | Gets the SweepAngle of the arc.
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties


SketchArc3D.CenterPoint Property

SketchArc3D.CenterPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the center point of the arc.

Visual Basic
Property CenterPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.CenterPoint Property


SketchArc3D.CurvatureDisplay Property

SketchArc3D.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies whether curvature information is displayed for the arc.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.CurvatureDisplay Property


SketchArc3D.EndSketchPoint Property

SketchArc3D.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets the that defines the position of the end of the arc.

Visual Basic
Property EndSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.EndSketchPoint Property


SketchArc3D.Geometry Property

SketchArc3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the Arc3d geometry object. The object returned represents a 'snapshot' view of the current state of the sketch arc. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As Arc3d*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.Geometry Property


SketchArc3D.Length Property

SketchArc3D.Length Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.Length Property


SketchArc3D.Radius Property

SketchArc3D.Radius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the Radius of the arc.

Visual Basic
Property Radius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.Radius Property


SketchArc3D.StartAngle Property

SketchArc3D.StartAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the StartAngle of the arc.

Visual Basic
Property StartAngle() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.StartAngle Property


SketchArc3D.StartSketchPoint Property

SketchArc3D.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets the that defines the position of the start of the arc.

Visual Basic
Property StartSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.StartSketchPoint Property


SketchArc3D.SweepAngle Property

SketchArc3D.SweepAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the SweepAngle of the arc.

Visual Basic
Property SweepAngle() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3D Interface > SketchArc3D Properties > SketchArc3D.SweepAngle Property


SketchArc3DProxy Interface

SketchArc3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchArc3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchArc3D
        Inventor::SketchArc3DProxy
Visual Basic
Public Interface SketchArc3DProxy
Inherits SketchArc3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchArc3DProxy Interface


SketchArc3DProxy Properties

SketchArc3DProxy Properties
Summary

The properties of the SketchArc3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchArc3DProxy Interface > SketchArc3DProxy Properties


SketchArc3DProxy.ContainingOccurrence Property

SketchArc3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchArc3DProxy Interface > SketchArc3DProxy Properties > SketchArc3DProxy.ContainingOccurrence Property


SketchArc3DProxy.NativeObject Property

SketchArc3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchArc3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchArc3DProxy Interface > SketchArc3DProxy Properties > SketchArc3DProxy.NativeObject Property


SketchArcProxy Interface

SketchArcProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchArc object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchArc
        Inventor::SketchArcProxy
Visual Basic
Public Interface SketchArcProxy
Inherits SketchArc
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchArcProxy Interface


SketchArcProxy Properties

SketchArcProxy Properties
Summary

The properties of the SketchArcProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcProxy Interface > SketchArcProxy Properties


SketchArcProxy.ContainingOccurrence Property

SketchArcProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchArcProxy Interface > SketchArcProxy Properties > SketchArcProxy.ContainingOccurrence Property


SketchArcProxy.NativeObject Property

SketchArcProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchArc**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchArcProxy Interface > SketchArcProxy Properties > SketchArcProxy.NativeObject Property


SketchArcs Interface

SketchArcs Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchArcs object provides access to all the objects in a sketch and provides methods to create additional sketch arcs. See the article in the overviews section.

Class Hierarchy
Inventor::SketchArcs
Visual Basic
Public Interface SketchArcs
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchArcs

See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface


SketchArcs Methods

SketchArcs Methods
Summary

The methods of the SketchArcs class are listed here.

Methods
Methods
Name | Description
AddByCenterStartEndPoint | Method that creates a new sketch arc defined by a center point and two points defining the start and end. The input points can be a combination of existing sketch points or Point2d objects. In the case where a sketch points is input, the arc will be attached to the sketch point. The sweep direction of the arc from the start to end point is determined by the CounterClockwise argument. The radius of the arc is determined by the start point. If the input for the start point is a sketch point, the arc will be tied to the sketch... more
AddByCenterStartSweepAngle | Method that creates a new sketch arc using the input point and angles.
AddByFillet | Method that creates a new sketch arc as a fillet between two sketch entities.
AddByThreePoints | Method that creates a new sketch arc that passes through the three input points.
Item | Property that returns the specified SketchArcobject from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Methods


SketchArcs.AddByCenterStartEndPoint Method

SketchArcs.AddByCenterStartEndPoint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch arc defined by a center point and two points defining the start and end. The input points can be a combination of existing sketch points or Point2d objects. In the case where a sketch points is input, the arc will be attached to the sketch point. The sweep direction of the arc from the start to end point is determined by the CounterClockwise argument. The radius of the arc is determined by the start point. If the input for the start point is a sketch point, the arc will be tied to the sketch point. The second point, whether it is a sketch point or coordinate point defines the sweep of the arc. In the case where a sketch point is input and it is on the arc, the arc will be tied to the sketch point.

Visual Basic
Sub AddByCenterStartEndPoint(CenterPoint As IDispatch, StartPoint As IDispatch, EndPoint As IDispatch, ByRef CounterClockwise As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchArc*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, the center point of the arc will be attached to the sketch point.
StartPoint | Input object that defines the start point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, the start point of the arc will be attached to the sketch point.
EndPoint | Input object that defines the end point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input and the point lies on the arc, the end point of the arc will be attached to the sketch point.
CounterClockwise | Optional input Boolean that defines whether the arc sweeps in a clockwise or counterclockwise direction between the start and end points. The default value is True which indicates a counterclockwise sweep direction.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Methods > SketchArcs.AddByCenterStartEndPoint Method


SketchArcs.AddByCenterStartSweepAngle Method

SketchArcs.AddByCenterStartSweepAngle Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch arc using the input point and angles.

Visual Basic
Sub AddByCenterStartSweepAngle(CenterPoint As IDispatch, Radius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] SketchArc*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, the center point of the arc will be attached to the sketch point.
Radius | Input Double that defines the radius of the arc in centimeters.
StartAngle | Input Double that defines the start angle in radians. The start angle is defined with respect to the sketch x-axis.
SweepAngle | Input Double that defines the sweep angle in radians. The sweep is in a counter-clockwise direction from the start.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Methods > SketchArcs.AddByCenterStartSweepAngle Method


SketchArcs.AddByFillet Method

SketchArcs.AddByFillet Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new sketch arc as a fillet between two sketch entities.

Visual Basic
Sub AddByFillet(EntityOne As SketchEntity, EntityTwo As SketchEntity, Radius As VARIANT, PointOnEntityOne As Point2d, PointOnEntityTwo As Point2d, Result As [out, retval] SketchArc*)
Parameters
Parameters | Description
EntityOne | Input sketch entity.
EntityTwo | Input sketch entity.
Radius | Input double that defines the radius of the arc in centimeters.
PointOnEntityOne | Input that defines the point on the first entity on which to start the SketchArc.
PointOnEntityTwo | Input that defines the point on the second entity on which to end the SketchArc.
See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Methods > SketchArcs.AddByFillet Method


SketchArcs.AddByThreePoints Method

SketchArcs.AddByThreePoints Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch arc that passes through the three input points.

Visual Basic
Sub AddByThreePoints(StartPoint As IDispatch, MidPoint As Point2d, EndPoint As IDispatch, Result As [out, retval] SketchArc*)
Parameters
Parameters | Description
StartPoint | Input object that defines the start point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, that start point of the arc will be attached to the sketch point.
MidPoint | Input Point2d object that defines a point along the arc.
EndPoint | Input object that defines the end point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, that end point of the arc will be attached to the sketch point.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Methods > SketchArcs.AddByThreePoints Method


SketchArcs.Item Method

SketchArcs.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchArcobject from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchArc*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Methods > SketchArcs.Item Method


SketchArcs Properties

SketchArcs Properties
Summary

The properties of the SketchArcs class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Properties


SketchArcs.Application Property

SketchArcs.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Properties > SketchArcs.Application Property


SketchArcs.Count Property

SketchArcs.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Properties > SketchArcs.Count Property


SketchArcs.Type Property

SketchArcs.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs Interface > SketchArcs Properties > SketchArcs.Type Property


SketchArcs3D Interface

SketchArcs3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchArcs3D object provides access to all the sketch arcs ( objects, including bends) in a 3D sketch and provides methods to create additional bends. See the article in the overviews section.

Class Hierarchy
Inventor::SketchArcs3D
Visual Basic
Public Interface SketchArcs3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchArcs3D

You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface


SketchArcs3D Methods

SketchArcs3D Methods
Summary

The methods of the SketchArcs3D class are listed here.

Methods
Methods
Name | Description
AddAsBend | Method that creates a new bend feature based on the two input lines.
AddByCenterStartEndPoint | Method that creates a new sketch arc defined by a center point and two points defining the start and end. Method that creates a new sketch arc defined by a center point and two points defining the start and end.
AddByCenterStartSweepAngle | Method that creates a new sketch arc using the input point and angles.
AddByThreePoints | Method that creates a new sketch arc that passes through the three input points. All the points must lie on the same plane.
Item | Property that returns the specified SketchArc3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Methods


SketchArcs3D.AddAsBend Method

SketchArcs3D.AddAsBend Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new bend feature based on the two input lines.

Visual Basic
Sub AddAsBend(LineOne As SketchLine3D, LineTwo As SketchLine3D, ByRef BendRadius As [optional] VARIANT, Result As [out, retval] SketchArc3D*)
Parameters
Parameters | Description
LineOne | Input 3D sketch line. Note that LineOne and LineTwo should be constrained end to end.
LineTwo | Input 3D sketch line. Note that LineOne and LineTwo should be constrained end to end.
BendRadius | Optional input variant that defines the radius of the bend. If not supplied the auto bend radius defined in the document options is used. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Methods > SketchArcs3D.AddAsBend Method


SketchArcs3D.AddByCenterStartEndPoint Method

SketchArcs3D.AddByCenterStartEndPoint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new sketch arc defined by a center point and two points defining the start and end. Method that creates a new sketch arc defined by a center point and two points defining the start and end.

Visual Basic
Sub AddByCenterStartEndPoint(CenterPoint As IDispatch, StartPoint As IDispatch, EndPoint As IDispatch, ByRef Normal As [optional] VARIANT, ByRef CounterClockwise As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] SketchArc3D*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can currently only be a Point object.
StartPoint | Input object that defines the start point. This can be either a SketchPoint3D or Point object. In the case where a SketchPoint3D object is input, the start point of the arc will be attached to the sketch point.
EndPoint | Input object that defines the end point. This can be either a SketchPoint3D or Point object. In the case where a SketchPoint3D object is input and the point lies on the arc, the end point of the arc will be attached to the sketch point.
Normal | Optional input UnitVector that defines the normal direction for the arc. This is only required when the start, center and end points are collinear (i.e. the arc is a semi-circle). In other cases, the normal need not be provided, but if it is, it needs to be consistent with the input points.
CounterClockwise | Optional input Boolean that defines whether the arc sweeps in a clockwise or counterclockwise direction between the start and end points. The default value is True which indicates a counterclockwise sweep direction.
Remarks

The input points can be a combination of existing sketch points or Point objects. In the case where a sketch points is input, the arc will be attached to the sketch point. The sweep direction of the arc from the start to end point is determined by the CounterClockwise argument. The radius of the arc is determined by the start point. If the input for the start point is a sketch point, the arc will be tied to the sketch point. The second point, whether it is a sketch point or coordinate point defines the sweep of the arc. In the case where a sketch point is input and it is on the arc, the arc will be tied to the sketch point.

You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Methods > SketchArcs3D.AddByCenterStartEndPoint Method


SketchArcs3D.AddByCenterStartSweepAngle Method

SketchArcs3D.AddByCenterStartSweepAngle Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new sketch arc using the input point and angles.

Visual Basic
Sub AddByCenterStartSweepAngle(CenterPoint As IDispatch, Normal As UnitVector, ReferenceVector As UnitVector, Radius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] SketchArc3D*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can currently only be a Point object.
Normal | Input UnitVector that defines the normal direction for the arc.
ReferenceVector | Input UnitVector that defines the reference vector. The ReferenceVector is the direction that is used to measure the start and the end angles of the arc. In other words, the ReferenceVector represents the zero angle and the start and end angles are measure with respect to this vector.
Radius | Input Double that defines the radius of the arc in centimeters.
StartAngle | Input Double that defines the start angle in radians. The start angle is defined with respect to the sketch x-axis.
SweepAngle | Input Double that defines the sweep angle in radians. The sweep is in a counter-clockwise direction from the start.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Methods > SketchArcs3D.AddByCenterStartSweepAngle Method


SketchArcs3D.AddByThreePoints Method

SketchArcs3D.AddByThreePoints Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new sketch arc that passes through the three input points. All the points must lie on the same plane.

Visual Basic
Sub AddByThreePoints(StartPoint As IDispatch, MidPoint As IDispatch, EndPoint As IDispatch, Result As [out, retval] SketchArc3D*)
Parameters
Parameters | Description
StartPoint | Input object that defines the start point. This can be either a SketchPoint3D or Point object. In the case where a SketchPoint3D object is input, that start point of the arc will be attached to the sketch point.
MidPoint | Input Point object that defines a point along the arc.
EndPoint | Input object that defines the end point. This can be either a SketchPoint3D or Point object. In the case where a SketchPoint3D object is input, that end point of the arc will be attached to the sketch point.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Methods > SketchArcs3D.AddByThreePoints Method


SketchArcs3D.Item Method

SketchArcs3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchArc3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchArc3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Methods > SketchArcs3D.Item Method


SketchArcs3D Properties

SketchArcs3D Properties
Summary

The properties of the SketchArcs3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Properties


SketchArcs3D.Application Property

SketchArcs3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Properties > SketchArcs3D.Application Property


SketchArcs3D.Count Property

SketchArcs3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Properties > SketchArcs3D.Count Property


SketchArcs3D.Type Property

SketchArcs3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchArcs3D Interface > SketchArcs3D Properties > SketchArcs3D.Type Property


SketchBlock Interface

SketchBlock Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SketchBlock object represents a sketch block instance within a sketch.

Class Hierarchy
Inventor::SketchBlock
    Inventor::SketchBlockProxy
Visual Basic
Public Interface SketchBlock
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchBlock.ContainingSketchBlock

SketchBlock.ReferencedEntity

SketchBlockProxy.NativeObject

SketchBlocks.Add

SketchBlocks.AddByDefinition

SketchBlocks.Item

SketchBlocksEnumerator.Item

SketchEntity.ContainingSketchBlock

SketchImage.ContainingSketchBlock

TextBox.ContainingSketchBlock

You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface


SketchBlock Methods

SketchBlock Methods
Summary

The methods of the SketchBlock class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the sketch block.
Edit | Method that activates the sketch block for editing by the user.
ExitEdit | Method that causes the sketch block to return from the edit mode and into the environment specified by the input argument. If the sketch block is not currently active (i.e. this is not the same block as returned by Application.ActiveEditObject property), then this method does nothing.
Explode | Method that explodes the contents of the block and deletes the block instance. Note that the contents of the block are retained.
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
GetObject | Method that returns the corresponding object in the sketch block for the given object from it's definition.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods


SketchBlock.Delete Method

SketchBlock.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the sketch block.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.Delete Method


SketchBlock.Edit Method

SketchBlock.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that activates the sketch block for editing by the user.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.Edit Method


SketchBlock.ExitEdit Method

SketchBlock.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that causes the sketch block to return from the edit mode and into the environment specified by the input argument. If the sketch block is not currently active (i.e. this is not the same block as returned by Application.ActiveEditObject property), then this method does nothing.

Visual Basic
Sub ExitEdit(ExitTo As ExitTypeEnum)
Parameters
Parameters | Description
ExitTo | Input ExitTypeEnum that specifies the environment to exit to. Possible values are kExitToPrevious, kExitToParent and kExitToTop.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.ExitEdit Method


SketchBlock.Explode Method

SketchBlock.Explode Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that explodes the contents of the block and deletes the block instance. Note that the contents of the block are retained.

Visual Basic
Sub Explode()
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.Explode Method


SketchBlock.GetCustomLineType Method

SketchBlock.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.GetCustomLineType Method


SketchBlock.GetObject Method

SketchBlock.GetObject Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the corresponding object in the sketch block for the given object from it's definition.

Visual Basic
Sub GetObject(ObjectInDefinition As IDispatch, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
ObjectInDefinition | Input Object to get the corresponding object (in the sketch block) for. This can be one of the following objects: SketchEntity, SketchBlock, SketchImage or TextBox.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.GetObject Method


SketchBlock.GetReferenceKey Method

SketchBlock.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.GetReferenceKey Method


SketchBlock.SetCustomLineType Method

SketchBlock.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Methods > SketchBlock.SetCustomLineType Method


SketchBlock Properties

SketchBlock Properties
Summary

The properties of the SketchBlock class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ChildBlocks | Property that returns an enumerator of SketchBlocks objects found directly under this sketch block.
Color | Property that gets and sets the color for the sketch block. Setting the property to Nothing restores the sketch block to the default color.
ConstraintStatus | Property that returns the constraint status of the sketch block. Possible return values are kFullyConstrainedConstraintStatus, kOverConstrainedConstraintStatus, kUnderConstrainedConstraintStatus and kUnknownConstraintStatus.
ContainingSketchBlock | Property that returns the sketch block that in turn contains this sketch block. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this sketch block does not belong to another sketch block and lives directly under a sketch.
Definition | Property that returns the referenced sketch block definition.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
Flexible | Property that gets and sets whether this sketch block is flexible.
HasReferenceComponent | Property that specifies if the object was created as the result of a derived part.
LineType | Property that gets and sets the line type override for the sketch block. Setting the property to kDefaultLineType restores the sketch block to the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the line weight override for the sketch block. Setting the property to 0 restores the sketch block to the default line weight.
Name | Property that gets and sets the name of the sketch block.
Parent | Property that returns the parent sketch of the object.
Position | Property that gets and sets the position of the sketch block within the parent sketch space. The block is placed such that the insertion point of the sketch block definition coincides with this point.
ReferenceComponent | Property that returns the ReferenceComponent that resulted in the creation of this feature.
ReferencedEntity | Property that returns the referenced sketch block, if there is one. Else, the property returns Nothing.
SketchBlockPath | Property that returns the path of sketch blocks at the leaf of which this sketch block is found. The enumerator returns a count of 0 if the block lives directly under a sketch. The path does not include this sketch block itself.
Transformation | Property that gets and sets the transformation matrix for the sketch block. The transformation matrix defines the position and orientation of the block within the sketch. When setting the transform of a block the actual change in position and orientation of the block is limited by the constraints on the block.
Type | Returns an ObjectTypeEnum indicating this object's type.
Visible | Property that gets and sets whether this sketch block is visible.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties


SketchBlock.Application Property

SketchBlock.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Application Property


SketchBlock.AttributeSets Property

SketchBlock.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.AttributeSets Property


SketchBlock.ChildBlocks Property

SketchBlock.ChildBlocks Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns an enumerator of SketchBlocks objects found directly under this sketch block.

Visual Basic
Property ChildBlocks() As SketchBlocksEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.ChildBlocks Property


SketchBlock.Color Property

SketchBlock.Color Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color for the sketch block. Setting the property to Nothing restores the sketch block to the default color.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Color Property


SketchBlock.ConstraintStatus Property

SketchBlock.ConstraintStatus Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constraint status of the sketch block. Possible return values are kFullyConstrainedConstraintStatus, kOverConstrainedConstraintStatus, kUnderConstrainedConstraintStatus and kUnknownConstraintStatus.

Visual Basic
Property ConstraintStatus() As ConstraintStatusEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.ConstraintStatus Property


SketchBlock.ContainingSketchBlock Property

SketchBlock.ContainingSketchBlock Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketch block that in turn contains this sketch block. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this sketch block does not belong to another sketch block and lives directly under a sketch.

Visual Basic
Property ContainingSketchBlock() As SketchBlock**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.ContainingSketchBlock Property


SketchBlock.Definition Property

SketchBlock.Definition Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the referenced sketch block definition.

Visual Basic
Property Definition() As SketchBlockDefinition**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Definition Property


SketchBlock.Exported Property

SketchBlock.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Exported Property


SketchBlock.Flexible Property

SketchBlock.Flexible Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether this sketch block is flexible.

Visual Basic
Property Flexible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Flexible Property


SketchBlock.HasReferenceComponent Property

SketchBlock.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies if the object was created as the result of a derived part.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
Remarks

This property returns True in the case where the object is from a derived part (so it belongs to a ReferenceComponent). In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case. If the HasReferenceComponent property is False, the ReferenceComponent property will return Nothing.

You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.HasReferenceComponent Property


SketchBlock.LineType Property

SketchBlock.LineType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the line type override for the sketch block. Setting the property to kDefaultLineType restores the sketch block to the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.LineType Property


SketchBlock.LineWeight Property

SketchBlock.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the line weight override for the sketch block. Setting the property to 0 restores the sketch block to the default line weight.

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.LineWeight Property


SketchBlock.Name Property

SketchBlock.Name Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the name of the sketch block.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Name Property


SketchBlock.Parent Property

SketchBlock.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent sketch of the object.

Visual Basic
Property Parent() As Sketch**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Parent Property


SketchBlock.Position Property

SketchBlock.Position Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the position of the sketch block within the parent sketch space. The block is placed such that the insertion point of the sketch block definition coincides with this point.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Position Property


SketchBlock.ReferenceComponent Property

SketchBlock.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ReferenceComponent that resulted in the creation of this feature.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
Remarks

If the object belongs to a derived part, a DerivedPartComponent will be returned. If the object belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.ReferenceComponent Property


SketchBlock.ReferencedEntity Property

SketchBlock.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the referenced sketch block, if there is one. Else, the property returns Nothing.

Visual Basic
Property ReferencedEntity() As SketchBlock **
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.ReferencedEntity Property


SketchBlock.SketchBlockPath Property

SketchBlock.SketchBlockPath Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the path of sketch blocks at the leaf of which this sketch block is found. The enumerator returns a count of 0 if the block lives directly under a sketch. The path does not include this sketch block itself.

Visual Basic
Property SketchBlockPath() As SketchBlocksEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.SketchBlockPath Property


SketchBlock.Transformation Property

SketchBlock.Transformation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the transformation matrix for the sketch block. The transformation matrix defines the position and orientation of the block within the sketch. When setting the transform of a block the actual change in position and orientation of the block is limited by the constraints on the block.

Visual Basic
Property Transformation() As Matrix2d*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Transformation Property


SketchBlock.Type Property

SketchBlock.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Type Property


SketchBlock.Visible Property

SketchBlock.Visible Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether this sketch block is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchBlock Interface > SketchBlock Properties > SketchBlock.Visible Property


SketchBlockDefinition Interface

SketchBlockDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SketchBlockDefinition object represents a sketch block definition.

Class Hierarchy
Inventor::Sketch
    Inventor::PlanarSketch
        Inventor::SketchBlockDefinition
            Inventor::SketchBlockDefinitionProxy
Visual Basic
Public Interface SketchBlockDefinition
Inherits PlanarSketch
Notes

Members through which this object may be accessed include:

SketchBlock.Definition

SketchBlockDefinition.CopyTo

SketchBlockDefinitionProxy.NativeObject

SketchBlockDefinitions.Add

SketchBlockDefinitions.Item

SketchBlockDefinitionsEnumerator.Item

Example

This sample demonstrates the creation and insertion of a sketch block definition into a part sketch.

Public Sub CreateSketchBlockDefinition()

    ' Set a reference to the part document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Create the new sketch block definition.
    Dim oSketchBlockDef As SketchBlockDefinition
    Set oSketchBlockDef = oPartDoc.ComponentDefinition.SketchBlockDefinitions.Add("My Block Def")

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Dim oRectangleLines As SketchEntitiesEnumerator
    Set oRectangleLines = oSketchBlockDef.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

End Sub

Public Sub InsertSketchBlockDefinition()

    ' Set a reference to the part document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the definition named "My Block Def"
    Dim oSketchBlockDef As SketchBlockDefinition
    Set oSketchBlockDef = oCompDef.SketchBlockDefinitions.Item("My Block Def")

    Dim oPosition As Point2d
    Set oPosition = ThisApplication.TransientGeometry.CreatePoint2d(10, 10)

    ' Insert the sketch block definition
    Call oSketch.SketchBlocks.AddByDefinition(oSketchBlockDef, oPosition)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface


SketchBlockDefinition Methods

SketchBlockDefinition Methods
Summary

The methods of the SketchBlockDefinition class are listed here.

Methods
Methods
Name | Description
AdjustContext | Method that returns the specified sketch object scoped into this sketch block definition, trimming any portion of the context from any sketch block in which this definition has been instanced. In other words, for the given object, this method returns the corresponding object in the context of this sketch block definition, by trimming the sketch block path.
CopyTo | Method that copies the definition to the target document.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Methods


SketchBlockDefinition.AdjustContext Method

SketchBlockDefinition.AdjustContext Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that returns the specified sketch object scoped into this sketch block definition, trimming any portion of the context from any sketch block in which this definition has been instanced. In other words, for the given object, this method returns the corresponding object in the context of this sketch block definition, by trimming the sketch block path.

Visual Basic
Sub AdjustContext(SketchObject As IDispatch, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
SketchObject | Input object that specifies the object to trim the context of. This can be a SketchEntity, SketchBlock, SketchImage or a TextBox.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Methods > SketchBlockDefinition.AdjustContext Method


SketchBlockDefinition.CopyTo Method

SketchBlockDefinition.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that copies the definition to the target document.

Visual Basic
Sub CopyTo(TargetDocument As Document, ByRef Reserved As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] SketchBlockDefinition*)
Parameters
Parameters | Description
TargetDocument | Input Document object that specifies the document to copy the definition into. This can be the source document object if a copy of the definition is to be created in the same document.
Reserved | Optional input Boolean reserved for future use. This value is currently ignored.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Methods > SketchBlockDefinition.CopyTo Method


SketchBlockDefinition Properties

SketchBlockDefinition Properties
Summary

The properties of the SketchBlockDefinition class are listed here.

Properties
Name | Description
InsertionPoint | Property that returns the insertion point of the sketch block definition.
IsInsertionPointVisible | Property that gets and sets whether the insertion point is visible.
IsReferenced | Property that returns whether this sketch block definition is currently referenced within the document.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Properties


SketchBlockDefinition.InsertionPoint Property

SketchBlockDefinition.InsertionPoint Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the insertion point of the sketch block definition.

Visual Basic
Property InsertionPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Properties > SketchBlockDefinition.InsertionPoint Property


SketchBlockDefinition.IsInsertionPointVisible Property

SketchBlockDefinition.IsInsertionPointVisible Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the insertion point is visible.

Visual Basic
Property IsInsertionPointVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Properties > SketchBlockDefinition.IsInsertionPointVisible Property


SketchBlockDefinition.IsReferenced Property

SketchBlockDefinition.IsReferenced Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether this sketch block definition is currently referenced within the document.

Visual Basic
Property IsReferenced() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinition Interface > SketchBlockDefinition Properties > SketchBlockDefinition.IsReferenced Property


SketchBlockDefinitionProxy Interface

SketchBlockDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchBlockDefinition object.

Class Hierarchy
Inventor::Sketch
    Inventor::PlanarSketch
        Inventor::SketchBlockDefinition
            Inventor::SketchBlockDefinitionProxy
Visual Basic
Public Interface SketchBlockDefinitionProxy
Inherits SketchBlockDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionProxy Interface


SketchBlockDefinitionProxy Properties

SketchBlockDefinitionProxy Properties
Summary

The properties of the SketchBlockDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionProxy Interface > SketchBlockDefinitionProxy Properties


SketchBlockDefinitionProxy.ContainingOccurrence Property

SketchBlockDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionProxy Interface > SketchBlockDefinitionProxy Properties > SketchBlockDefinitionProxy.ContainingOccurrence Property


SketchBlockDefinitionProxy.NativeObject Property

SketchBlockDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchBlockDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionProxy Interface > SketchBlockDefinitionProxy Properties > SketchBlockDefinitionProxy.NativeObject Property


SketchBlockDefinitions Interface

SketchBlockDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SketchBlockDefinitions collection object provides access to all sketch block definitions and provides methods to create additional definitions.

Class Hierarchy
Inventor::SketchBlockDefinitions
Visual Basic
Public Interface SketchBlockDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPattern.SketchBlockDefinitions

PartComponentDefinition.SketchBlockDefinitions

See Also

Create and insert a sketch block definition into a part sketch sample

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface


SketchBlockDefinitions Methods

SketchBlockDefinitions Methods
Summary

The methods of the SketchBlockDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new (empty) SketchBlockDefinition. The newly created SketchBlockDefinition is returned.
Item | Property that returns the specified SketchBlockDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Methods


SketchBlockDefinitions.Add Method

SketchBlockDefinitions.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new (empty) SketchBlockDefinition. The newly created SketchBlockDefinition is returned.

Visual Basic
Sub Add(ByRef Name As [defaultvalue("")] BSTR, ByRef InsertionPoint As [optional] VARIANT, Result As [out, retval] SketchBlockDefinition*)
Parameters
Parameters | Description
Name | Optional input String that specifies a name for the sketch block definition. If not provided, the name is automatically generated.
InsertionPoint | Optional input Point2d object that specifies the insertion point for the sketch block. The insertion sketch point is created in space and no constraints are created on the insertion point. The insertion point can be retrieved using SketchBlockDefinition.InsertionPoint property and constraints can be added to it. If not specified, a default insertion point is chosen.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Methods > SketchBlockDefinitions.Add Method


SketchBlockDefinitions.Item Method

SketchBlockDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified SketchBlockDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SketchBlockDefinition*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the SketchBlockDefinition to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the SketchBlockDefinition name. If an out of range index or a name of a non-existent SketchBlockDefinition is provided, an error will occur.
See Also

Create and insert a sketch block definition into a part sketch sample

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Methods > SketchBlockDefinitions.Item Method


SketchBlockDefinitions Properties

SketchBlockDefinitions Properties
Summary

The properties of the SketchBlockDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Properties


SketchBlockDefinitions.Application Property

SketchBlockDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Properties > SketchBlockDefinitions.Application Property


SketchBlockDefinitions.Count Property

SketchBlockDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Properties > SketchBlockDefinitions.Count Property


SketchBlockDefinitions.Type Property

SketchBlockDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitions Interface > SketchBlockDefinitions Properties > SketchBlockDefinitions.Type Property


SketchBlockDefinitionsEnumerator Interface

SketchBlockDefinitionsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SketchBlockDefinitionsEnumerator allows iteration of available sketchBlockDefinition objects.

Class Hierarchy
Inventor::SketchBlockDefinitionsEnumerator
Visual Basic
Public Interface SketchBlockDefinitionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartComponent.SketchBlockDefinitions

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionsEnumerator Interface


SketchBlockDefinitionsEnumerator Methods

SketchBlockDefinitionsEnumerator Methods
Summary

The methods of the SketchBlockDefinitionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionsEnumerator Interface > SketchBlockDefinitionsEnumerator Methods


SketchBlockDefinitionsEnumerator.Item Method

SketchBlockDefinitionsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchBlockDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionsEnumerator Interface > SketchBlockDefinitionsEnumerator Methods > SketchBlockDefinitionsEnumerator.Item Method


SketchBlockDefinitionsEnumerator Properties

SketchBlockDefinitionsEnumerator Properties
Summary

The properties of the SketchBlockDefinitionsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionsEnumerator Interface > SketchBlockDefinitionsEnumerator Properties


SketchBlockDefinitionsEnumerator.Count Property

SketchBlockDefinitionsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionsEnumerator Interface > SketchBlockDefinitionsEnumerator Properties > SketchBlockDefinitionsEnumerator.Count Property


SketchBlockDefinitionsEnumerator.Type Property

SketchBlockDefinitionsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockDefinitionsEnumerator Interface > SketchBlockDefinitionsEnumerator Properties > SketchBlockDefinitionsEnumerator.Type Property


SketchBlockProxy Interface

SketchBlockProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchBlock object.

Class Hierarchy
Inventor::SketchBlock
    Inventor::SketchBlockProxy
Visual Basic
Public Interface SketchBlockProxy
Inherits SketchBlock
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockProxy Interface


SketchBlockProxy Properties

SketchBlockProxy Properties
Summary

The properties of the SketchBlockProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlockProxy Interface > SketchBlockProxy Properties


SketchBlockProxy.ContainingOccurrence Property

SketchBlockProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockProxy Interface > SketchBlockProxy Properties > SketchBlockProxy.ContainingOccurrence Property


SketchBlockProxy.NativeObject Property

SketchBlockProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchBlock**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchBlockProxy Interface > SketchBlockProxy Properties > SketchBlockProxy.NativeObject Property


SketchBlocks Interface

SketchBlocks Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SketchBlocks collection object provides access to all sketch block instances within a sketch and provides methods to create additional block instances.

Class Hierarchy
Inventor::SketchBlocks
Visual Basic
Public Interface SketchBlocks
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PlanarSketch.SketchBlocks

See Also

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface


SketchBlocks Methods

SketchBlocks Methods
Summary

The methods of the SketchBlocks class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a sketch block instance using existing sketch objects. A sketch block definition is implicitly created. The newly created SketchBlock object is returned.
AddByDefinition | Method that creates a sketch block instance based on the input definition. The newly created SketchBlock object is returned.
Item | Property that returns the specified SketchBlock object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Methods


SketchBlocks.Add Method

SketchBlocks.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a sketch block instance using existing sketch objects. A sketch block definition is implicitly created. The newly created SketchBlock object is returned.

Visual Basic
Sub Add(SketchObjects As ObjectCollection, ByRef Name As [defaultvalue("")] BSTR, ByRef InsertionPoint As [optional] VARIANT, Result As [out, retval] SketchBlock*)
Parameters
Parameters | Description
SketchObjects | Input ObjectCollection that specifies the sketch entities to create the sketch block from. The collection can contain SketchEntity, (other) SketchBlock, SketchImage and TextBox objects.
Name | Optional input String that specifies a name for the sketch block definition. If not provided, the name is automatically generated.
InsertionPoint | Optional input Point2d object that specifies the insertion point for the sketch block. The insertion sketch point is created in space and no constraints are created on the insertion point. The insertion point can be retrieved using SketchBlockDefinition.InsertionPoint property and constraints can be added to it. If not specified, a default insertion point is chosen.
Example

This sample demonstrates the creation of a sketch block from an existing sketch.

Public Sub CreateSketchBlock()

    ' Set a reference to the part document.
    ' This assumes a part document is active.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Draw a 4cm x 3cm rectangle with the corner at (0,0)
    Dim oRectangleLines As SketchEntitiesEnumerator
    Set oRectangleLines = oSketch.SketchLines.AddAsTwoPointRectangle( _
                                oTransGeom.CreatePoint2d(0, 0), _
                                oTransGeom.CreatePoint2d(4, 3))

    Dim oSketchObjects As ObjectCollection
    Set oSketchObjects = ThisApplication.TransientObjects.CreateObjectCollection

    Dim oLine As SketchEntity
    For Each oLine In oRectangleLines
       Call oSketchObjects.Add(oLine)
    Next

    ' Insert the sketch block definition
    Call oSketch.SketchBlocks.Add(oSketchObjects)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Methods > SketchBlocks.Add Method


SketchBlocks.AddByDefinition Method

SketchBlocks.AddByDefinition Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a sketch block instance based on the input definition. The newly created SketchBlock object is returned.

Visual Basic
Sub AddByDefinition(Definition As SketchBlockDefinition, Position As Point2d, Result As [out, retval] SketchBlock*)
Parameters
Parameters | Description
Definition | Input SketchBlockDefinition that specifies the definition to create the instance from.
Position | Input Point2d object that specifies the placement point for the block in sketch space. The block is placed such that the insertion point of the sketch block definition coincides with this point.
See Also

Create and insert a sketch block definition into a part sketch sample

You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Methods > SketchBlocks.AddByDefinition Method


SketchBlocks.Item Method

SketchBlocks.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified SketchBlock object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SketchBlock*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the SketchBlock to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the SketchBlock name. If an out of range index or a name of a non-existent SketchBlock is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Methods > SketchBlocks.Item Method


SketchBlocks Properties

SketchBlocks Properties
Summary

The properties of the SketchBlocks class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Properties


SketchBlocks.Application Property

SketchBlocks.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Properties > SketchBlocks.Application Property


SketchBlocks.Count Property

SketchBlocks.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Properties > SketchBlocks.Count Property


SketchBlocks.Type Property

SketchBlocks.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocks Interface > SketchBlocks Properties > SketchBlocks.Type Property


SketchBlocksEnumerator Interface

SketchBlocksEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SketchBlocksEnumerator allows iteration of available SketchBlock objects.

Class Hierarchy
Inventor::SketchBlocksEnumerator
Visual Basic
Public Interface SketchBlocksEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartComponent.SketchBlocks

SketchBlock.ChildBlocks

SketchBlock.SketchBlockPath

SketchEntity.SketchBlockPath

SketchImage.SketchBlockPath

TextBox.SketchBlockPath

You are here: Symbol Reference > Inventor Library > Objects > SketchBlocksEnumerator Interface


SketchBlocksEnumerator Methods

SketchBlocksEnumerator Methods
Summary

The methods of the SketchBlocksEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocksEnumerator Interface > SketchBlocksEnumerator Methods


SketchBlocksEnumerator.Item Method

SketchBlocksEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SketchBlock*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocksEnumerator Interface > SketchBlocksEnumerator Methods > SketchBlocksEnumerator.Item Method


SketchBlocksEnumerator Properties

SketchBlocksEnumerator Properties
Summary

The properties of the SketchBlocksEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocksEnumerator Interface > SketchBlocksEnumerator Properties


SketchBlocksEnumerator.Count Property

SketchBlocksEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocksEnumerator Interface > SketchBlocksEnumerator Properties > SketchBlocksEnumerator.Count Property


SketchBlocksEnumerator.Type Property

SketchBlocksEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchBlocksEnumerator Interface > SketchBlocksEnumerator Properties > SketchBlocksEnumerator.Type Property


SketchCircle Interface

SketchCircle Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchCircle object represents a circle within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchCircle
        Inventor::SketchCircleProxy
Visual Basic
Public Interface SketchCircle
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

SketchCircleProxy.NativeObject

SketchCircles.AddByCenterRadius

SketchCircles.AddByThreePoints

SketchCircles.Item

AngleiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

See Also

Create sheet metal lofted flange feature sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Sketch Display Entities sample

Sketch Add Oriented sample

Sketch from face silhouette sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface


SketchCircle Methods

SketchCircle Methods
Summary

The methods of the SketchCircle class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Methods


SketchCircle.GetCustomLineType Method

SketchCircle.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Methods > SketchCircle.GetCustomLineType Method


SketchCircle.SetCustomLineType Method

SketchCircle.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Methods > SketchCircle.SetCustomLineType Method


SketchCircle Properties

SketchCircle Properties
Summary

The properties of the SketchCircle class are listed here.

Properties
Name | Description
Area | Double property that returns the area of the entity in square centimeters.
CenterSketchPoint | Property that gets the sketch point that defines the position of the center of the circle.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for the circle. True indicates the curvature is displayed.
Geometry | Property that returns a Circle2d geometry object. The object returned represents a snapshot view of the current state of the sketch circle.
Length | Property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
OverrideColor | Gets and sets the color applied to this primitive.
Radius | Property that returns the radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties


SketchCircle.Area Property

SketchCircle.Area Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the area of the entity in square centimeters.

Visual Basic
Property Area() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.Area Property


SketchCircle.CenterSketchPoint Property

SketchCircle.CenterSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the sketch point that defines the position of the center of the circle.

Visual Basic
Property CenterSketchPoint() As SketchPoint**
See Also

Sketch Add Oriented sample

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.CenterSketchPoint Property


SketchCircle.CurvatureDisplay Property

SketchCircle.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the curvature information is currently being displayed for the circle. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.CurvatureDisplay Property


SketchCircle.Geometry Property

SketchCircle.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Circle2d geometry object. The object returned represents a snapshot view of the current state of the sketch circle.

Visual Basic
Property Geometry() As Circle2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.Geometry Property


SketchCircle.Length Property

SketchCircle.Length Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.Length Property


SketchCircle.LineDefinitionSpace Property

SketchCircle.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.LineDefinitionSpace Property


SketchCircle.LineScale Property

SketchCircle.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.LineScale Property


SketchCircle.LineType Property

SketchCircle.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.LineType Property


SketchCircle.LineWeight Property

SketchCircle.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.LineWeight Property


SketchCircle.OverrideColor Property

SketchCircle.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.OverrideColor Property


SketchCircle.Radius Property

SketchCircle.Radius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the radius of the circle.

Visual Basic
Property Radius() As double
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle Interface > SketchCircle Properties > SketchCircle.Radius Property


SketchCircle3D Interface

SketchCircle3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchCircle3D object represents a circle within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchCircle3D
        Inventor::SketchCircle3DProxy
Visual Basic
Public Interface SketchCircle3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

SketchCircle3DProxy.NativeObject

SketchCircles3D.AddByCenterRadius

SketchCircles3D.AddByThreePoints

SketchCircles3D.Item

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface


SketchCircle3D Properties

SketchCircle3D Properties
Summary

The properties of the SketchCircle3D class are listed here.

Properties
Name | Description
Area | Double property that returns the area of the entity in square centimeters.
CenterPoint | Property that returns the point that defines the position of the center of the circle.
CurvatureDisplay | Specifies whether curvature information is displayed for the circle.
Geometry | Property that gets and sets the Circle geometry object. The object returned represents a 'snapshot' view of the current state of the sketch circle. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
Length | Gets the Length of the circle.
Radius | Gets the Radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties


SketchCircle3D.Area Property

SketchCircle3D.Area Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Double property that returns the area of the entity in square centimeters.

Visual Basic
Property Area() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties > SketchCircle3D.Area Property


SketchCircle3D.CenterPoint Property

SketchCircle3D.CenterPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the point that defines the position of the center of the circle.

Visual Basic
Property CenterPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties > SketchCircle3D.CenterPoint Property


SketchCircle3D.CurvatureDisplay Property

SketchCircle3D.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies whether curvature information is displayed for the circle.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties > SketchCircle3D.CurvatureDisplay Property


SketchCircle3D.Geometry Property

SketchCircle3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the Circle geometry object. The object returned represents a 'snapshot' view of the current state of the sketch circle. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As Circle*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties > SketchCircle3D.Geometry Property


SketchCircle3D.Length Property

SketchCircle3D.Length Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the Length of the circle.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties > SketchCircle3D.Length Property


SketchCircle3D.Radius Property

SketchCircle3D.Radius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the Radius of the circle.

Visual Basic
Property Radius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3D Interface > SketchCircle3D Properties > SketchCircle3D.Radius Property


SketchCircle3DProxy Interface

SketchCircle3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchCircle3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchCircle3D
        Inventor::SketchCircle3DProxy
Visual Basic
Public Interface SketchCircle3DProxy
Inherits SketchCircle3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3DProxy Interface


SketchCircle3DProxy Properties

SketchCircle3DProxy Properties
Summary

The properties of the SketchCircle3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3DProxy Interface > SketchCircle3DProxy Properties


SketchCircle3DProxy.ContainingOccurrence Property

SketchCircle3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3DProxy Interface > SketchCircle3DProxy Properties > SketchCircle3DProxy.ContainingOccurrence Property


SketchCircle3DProxy.NativeObject Property

SketchCircle3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchCircle3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchCircle3DProxy Interface > SketchCircle3DProxy Properties > SketchCircle3DProxy.NativeObject Property


SketchCircleProxy Interface

SketchCircleProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchCircle object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchCircle
        Inventor::SketchCircleProxy
Visual Basic
Public Interface SketchCircleProxy
Inherits SketchCircle
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchCircleProxy Interface


SketchCircleProxy Properties

SketchCircleProxy Properties
Summary

The properties of the SketchCircleProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircleProxy Interface > SketchCircleProxy Properties


SketchCircleProxy.ContainingOccurrence Property

SketchCircleProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchCircleProxy Interface > SketchCircleProxy Properties > SketchCircleProxy.ContainingOccurrence Property


SketchCircleProxy.NativeObject Property

SketchCircleProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchCircle**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchCircleProxy Interface > SketchCircleProxy Properties > SketchCircleProxy.NativeObject Property


SketchCircles Interface

SketchCircles Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchCircles object provides access to all the objects in a sketch and provides methods to create additional sketch circles. See the article in the overviews section.

Class Hierarchy
Inventor::SketchCircles
Visual Basic
Public Interface SketchCircles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchCircles

See Also

Create sheet metal lofted flange feature sample

Sketch profile control sample

Sketch Edit Orientation sample

Thread Feature Create sample

Sweep Feature Add sample

SurfaceBody Copy sample

Create SketchedSymbol Definition sample

Sketch Add Oriented sample

Sketch from face silhouette sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface


SketchCircles Methods

SketchCircles Methods
Summary

The methods of the SketchCircles class are listed here.

Methods
Methods
Name | Description
AddByCenterRadius | Method that creates a new sketch circle at a specified location and radius.
AddByThreePoints | Method that creates a new sketch circle passing through the three input points. The three points are any three points along the perimeter of the desired circle.
Item | Property that returns the specified SketchCircle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Methods


SketchCircles.AddByCenterRadius Method

SketchCircles.AddByCenterRadius Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch circle at a specified location and radius.

Visual Basic
Sub AddByCenterRadius(CenterPoint As IDispatch, Radius As double, Result As [out, retval] SketchCircle*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, the circle will be attached to the point.
Radius | Input Double that defines the radius of the circle in centimeters.
See Also

Create sheet metal lofted flange feature sample

Sketch profile control sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Thread Feature Create sample

Sweep Feature Add sample

SurfaceBody Copy sample

Create SketchedSymbol Definition sample

Sketch Add Oriented sample

Sketch from face silhouette sample

Moving sketch entities to a new layer sample

Add iMate Definition sample

Sketch fill region sample

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Methods > SketchCircles.AddByCenterRadius Method


SketchCircles.AddByThreePoints Method

SketchCircles.AddByThreePoints Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch circle passing through the three input points. The three points are any three points along the perimeter of the desired circle.

Visual Basic
Sub AddByThreePoints(PointOne As Point2d, PointTwo As Point2d, PointThree As Point2d, Result As [out, retval] SketchCircle*)
Parameters
Parameters | Description
PointOne | Input that defines the first point along the circle.
PointTwo | Input that defines the second point along the circle.
PointThree | Input that defines the third point along the circle.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Methods > SketchCircles.AddByThreePoints Method


SketchCircles.Item Method

SketchCircles.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchCircle object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchCircle*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Methods > SketchCircles.Item Method


SketchCircles Properties

SketchCircles Properties
Summary

The properties of the SketchCircles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Properties


SketchCircles.Application Property

SketchCircles.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Properties > SketchCircles.Application Property


SketchCircles.Count Property

SketchCircles.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Properties > SketchCircles.Count Property


SketchCircles.Type Property

SketchCircles.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles Interface > SketchCircles Properties > SketchCircles.Type Property


SketchCircles3D Interface

SketchCircles3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchCircles3D object provides access to all the objects in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchCircles3D
Visual Basic
Public Interface SketchCircles3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchCircles3D

You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface


SketchCircles3D Methods

SketchCircles3D Methods
Summary

The methods of the SketchCircles3D class are listed here.

Methods
Methods
Name | Description
AddByCenterRadius | Method that creates a new sketch circle at a specified location and radius.
AddByThreePoints | Method that creates a new sketch circle passing through the three input points.
Item | Property that returns the specified SketchCircle3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Methods


SketchCircles3D.AddByCenterRadius Method

SketchCircles3D.AddByCenterRadius Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new sketch circle at a specified location and radius.

Visual Basic
Sub AddByCenterRadius(CenterPoint As IDispatch, Normal As UnitVector, Radius As double, Result As [out, retval] SketchCircle3D*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can currently only be a Point object.
Normal | Input UnitVector that defines the normal of the circle.
Radius | Input Double that defines the radius of the circle in centimeters
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Methods > SketchCircles3D.AddByCenterRadius Method


SketchCircles3D.AddByThreePoints Method

SketchCircles3D.AddByThreePoints Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new sketch circle passing through the three input points.

Visual Basic
Sub AddByThreePoints(StartPoint As IDispatch, MidPoint As IDispatch, EndPoint As IDispatch, Result As [out, retval] SketchCircle3D*)
Parameters
Parameters | Description
StartPoint | Input Point that defines the first point along the circle.
MidPoint | Input Point that defines the second point along the circle.
EndPoint | Input Point that defines the third point along the circle.
Remarks

The three points are any three points along the perimeter of the desired circle and must all lie on the same plane.

You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Methods > SketchCircles3D.AddByThreePoints Method


SketchCircles3D.Item Method

SketchCircles3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchCircle3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchCircle3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Methods > SketchCircles3D.Item Method


SketchCircles3D Properties

SketchCircles3D Properties
Summary

The properties of the SketchCircles3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Properties


SketchCircles3D.Application Property

SketchCircles3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Properties > SketchCircles3D.Application Property


SketchCircles3D.Count Property

SketchCircles3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Properties > SketchCircles3D.Count Property


SketchCircles3D.Type Property

SketchCircles3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchCircles3D Interface > SketchCircles3D Properties > SketchCircles3D.Type Property


SketchConstraints3DEnumerator Interface

SketchConstraints3DEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchConstraints3DEnumerator object provides access to a list of SketchConstraint objects in a specific 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchConstraints3DEnumerator
Visual Basic
Public Interface SketchConstraints3DEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchEntity3D.Constraints3D

You are here: Symbol Reference > Inventor Library > Objects > SketchConstraints3DEnumerator Interface


SketchConstraints3DEnumerator Methods

SketchConstraints3DEnumerator Methods
Summary

The methods of the SketchConstraints3DEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified SketchConstraint object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraints3DEnumerator Interface > SketchConstraints3DEnumerator Methods


SketchConstraints3DEnumerator.Item Method

SketchConstraints3DEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns the specified SketchConstraint object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Value that specifies the SketchConstraint to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the constraint name. The name expected is the display name of the constraint. This is the name that is displayed to the user in the assembly browser. If an out of range index or a name of a non-existent constraint name is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraints3DEnumerator Interface > SketchConstraints3DEnumerator Methods > SketchConstraints3DEnumerator.Item Method


SketchConstraints3DEnumerator Properties

SketchConstraints3DEnumerator Properties
Summary

The properties of the SketchConstraints3DEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraints3DEnumerator Interface > SketchConstraints3DEnumerator Properties


SketchConstraints3DEnumerator.Count Property

SketchConstraints3DEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraints3DEnumerator Interface > SketchConstraints3DEnumerator Properties > SketchConstraints3DEnumerator.Count Property


SketchConstraints3DEnumerator.Type Property

SketchConstraints3DEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraints3DEnumerator Interface > SketchConstraints3DEnumerator Properties > SketchConstraints3DEnumerator.Type Property


SketchConstraintsEnumerator Interface

SketchConstraintsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchConstraintEnumerator object provides access to a list of SketchConstraint objects. See the article in the overviews section.

Class Hierarchy
Inventor::SketchConstraintsEnumerator
Visual Basic
Public Interface SketchConstraintsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchEntity.Constraints

You are here: Symbol Reference > Inventor Library > Objects > SketchConstraintsEnumerator Interface


SketchConstraintsEnumerator Methods

SketchConstraintsEnumerator Methods
Summary

The methods of the SketchConstraintsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraintsEnumerator Interface > SketchConstraintsEnumerator Methods


SketchConstraintsEnumerator.Item Method

SketchConstraintsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraintsEnumerator Interface > SketchConstraintsEnumerator Methods > SketchConstraintsEnumerator.Item Method


SketchConstraintsEnumerator Properties

SketchConstraintsEnumerator Properties
Summary

The properties of the SketchConstraintsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraintsEnumerator Interface > SketchConstraintsEnumerator Properties


SketchConstraintsEnumerator.Count Property

SketchConstraintsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraintsEnumerator Interface > SketchConstraintsEnumerator Properties > SketchConstraintsEnumerator.Count Property


SketchConstraintsEnumerator.Type Property

SketchConstraintsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchConstraintsEnumerator Interface > SketchConstraintsEnumerator Properties > SketchConstraintsEnumerator.Type Property


SketchedSymbol Interface

SketchedSymbol Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SketchedSymbol object represents the instance of a SketchedSymbolDefinition on a sheet. See the article in the overviews section.

Class Hierarchy
Inventor::SketchedSymbol
Visual Basic
Public Interface SketchedSymbol
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchedSymbols.Add

SketchedSymbols.AddWithLeader

SketchedSymbols.Item

See Also

Create sketched symbol and leader sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface


SketchedSymbol Methods

SketchedSymbol Methods
Summary

The methods of the SketchedSymbol class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the sketched symbol (e.g. the title block) from the sheet.
GetCustomLineType | Method that sets a custom line type to the entity from the specified .lin file. The method automatically changes the value of the LineType property to kCustomLineType.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetResultText | Method that returns the text that is currently displayed for a specific text box. This is useful for text boxes that use input form other sources to define their content, i.e. properties and prompted text. The string displayed within this text box is returned.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
SetPromptResultText | Method that sets the text that was supplied for a specified sketched symbol that contains prompted text. The string displayed within this symbol is changed.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods


SketchedSymbol.Delete Method

SketchedSymbol.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the sketched symbol (e.g. the title block) from the sheet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods > SketchedSymbol.Delete Method


SketchedSymbol.GetCustomLineType Method

SketchedSymbol.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets a custom line type to the entity from the specified .lin file. The method automatically changes the value of the LineType property to kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | The linetype name specified in the .lin file.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods > SketchedSymbol.GetCustomLineType Method


SketchedSymbol.GetReferenceKey Method

SketchedSymbol.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods > SketchedSymbol.GetReferenceKey Method


SketchedSymbol.GetResultText Method

SketchedSymbol.GetResultText Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the text that is currently displayed for a specific text box. This is useful for text boxes that use input form other sources to define their content, i.e. properties and prompted text. The string displayed within this text box is returned.

Visual Basic
Sub GetResultText(DefinitionText As TextBox, Result As [out, retval] BSTR)
Parameters
Parameters | Description
DefinitionText | Input TextBox object from the referenced TitleBlockDefinition object. This text box is used to specify which prompted text box to set the text for.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods > SketchedSymbol.GetResultText Method


SketchedSymbol.SetCustomLineType Method

SketchedSymbol.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods > SketchedSymbol.SetCustomLineType Method


SketchedSymbol.SetPromptResultText Method

SketchedSymbol.SetPromptResultText Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that sets the text that was supplied for a specified sketched symbol that contains prompted text. The string displayed within this symbol is changed.

Visual Basic
Sub SetPromptResultText(DefinitionText As TextBox, NewValue As String)
Parameters
Parameters | Description
DefinitionText | Input TextBox object from the referenced sketched symbol object. This text box is used to specify which prompted text box to set the text for.
NewValue | Input String that defines the new text to use for the specified prompted text.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Methods > SketchedSymbol.SetPromptResultText Method


SketchedSymbol Properties

SketchedSymbol Properties
Summary

The properties of the SketchedSymbol class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Callout | Property that gets whether this sketched symbol is a callout symbol.
Color | Property that gets and sets the color for the symbol. Setting the property to Nothing restores the symbol to the color defined by the layer on which this symbol resides.
Definition | Property returning the sketched symbol definition object referenced by the sketched symbol.
Layer | Property that gets and sets the layer associated with the sketched symbol.
Leader | Property that returns the Leader object.
LeaderClipping | Gets and sets whether the symbol's leader should be clipped where it overlaps the symbol.
LeaderStyle | Property that gets and sets the associated leader style.
LeaderVisible | Property that gets and sets whether the leader of the sketched symbol is visible. This property will fail if a leader does not exist (i.e. Leader.HasRootNode property returns False).
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
Name | Property that indicates the name of this object or instance.
Parent | Property that gets the parent object from whom this object can logically be reached.
Position | Property that gets and sets the origin position of the symbol on the sheet.
Rotation | Property that gets and sets the rotation angle of the symbol in radians.
Scale | Property that gets and sets the scale of the symbol.
Static | Property that gets and sets whether to show the scale and rotation grip points on the symbol. If True, the grip points are disabled.
SymbolClipping | Property that gets and sets whether to trim the annotations applied to the symbol. If True, the annotations are trimmed.
Transformation | Property that provides the transform that is applied to display the associated sketched symbol definition in the correct location on the sheet. The matrix defines the sheet to sketched symbol transform.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties


SketchedSymbol.Application Property

SketchedSymbol.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Application Property


SketchedSymbol.AttributeSets Property

SketchedSymbol.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.AttributeSets Property


SketchedSymbol.Callout Property

SketchedSymbol.Callout Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets whether this sketched symbol is a callout symbol.

Visual Basic
Property Callout() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Callout Property


SketchedSymbol.Color Property

SketchedSymbol.Color Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the color for the symbol. Setting the property to Nothing restores the symbol to the color defined by the layer on which this symbol resides.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Color Property


SketchedSymbol.Definition Property

SketchedSymbol.Definition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the sketched symbol definition object referenced by the sketched symbol.

Visual Basic
Property Definition() As SketchedSymbolDefinition**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Definition Property


SketchedSymbol.Layer Property

SketchedSymbol.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with the sketched symbol.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Layer Property


SketchedSymbol.Leader Property

SketchedSymbol.Leader Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the Leader object.

Visual Basic
Property Leader() As Leader**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Leader Property


SketchedSymbol.LeaderClipping Property

SketchedSymbol.LeaderClipping Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets and sets whether the symbol's leader should be clipped where it overlaps the symbol.

Visual Basic
Property LeaderClipping() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.LeaderClipping Property


SketchedSymbol.LeaderStyle Property

SketchedSymbol.LeaderStyle Property
Summary

Property that gets and sets the associated leader style.

Visual Basic
Property LeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.LeaderStyle Property


SketchedSymbol.LeaderVisible Property

SketchedSymbol.LeaderVisible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the leader of the sketched symbol is visible. This property will fail if a leader does not exist (i.e. Leader.HasRootNode property returns False).

Visual Basic
Property LeaderVisible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.LeaderVisible Property


SketchedSymbol.LineType Property

SketchedSymbol.LineType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.LineType Property


SketchedSymbol.LineWeight Property

SketchedSymbol.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.LineWeight Property


SketchedSymbol.Name Property

SketchedSymbol.Name Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Name Property


SketchedSymbol.Parent Property

SketchedSymbol.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Parent Property


SketchedSymbol.Position Property

SketchedSymbol.Position Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the origin position of the symbol on the sheet.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Position Property


SketchedSymbol.Rotation Property

SketchedSymbol.Rotation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the rotation angle of the symbol in radians.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Rotation Property


SketchedSymbol.Scale Property

SketchedSymbol.Scale Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the scale of the symbol.

Visual Basic
Property Scale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Scale Property


SketchedSymbol.Static Property

SketchedSymbol.Static Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to show the scale and rotation grip points on the symbol. If True, the grip points are disabled.

Visual Basic
Property Static() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Static Property


SketchedSymbol.SymbolClipping Property

SketchedSymbol.SymbolClipping Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to trim the annotations applied to the symbol. If True, the annotations are trimmed.

Visual Basic
Property SymbolClipping() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.SymbolClipping Property


SketchedSymbol.Transformation Property

SketchedSymbol.Transformation Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that provides the transform that is applied to display the associated sketched symbol definition in the correct location on the sheet. The matrix defines the sheet to sketched symbol transform.

Visual Basic
Property Transformation() As Matrix2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Transformation Property


SketchedSymbol.Type Property

SketchedSymbol.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbol Interface > SketchedSymbol Properties > SketchedSymbol.Type Property


SketchedSymbolDefinition Interface

SketchedSymbolDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SketchedSymbolDefinition object represents a sketched symbol definition. See the article in the overviews section.

Class Hierarchy
Inventor::SketchedSymbolDefinition
Visual Basic
Public Interface SketchedSymbolDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchedSymbol.Definition

SketchedSymbolDefinition.CopyTo

SketchedSymbolDefinitions.Add

SketchedSymbolDefinitions.Item

See Also

Create sketched symbol and leader sample

Example

"Create SketchedSymbol Definition."

This sample illustrates creating a new sketched symbol definition object and inserting it into the active sheet. This sample consists of two subs. The first demonstrates the creation of a sketched symbol definition and the second inserts it into the active sheet. To run the sample have a drawing document open and run the CreateSketchedSymbolDefinition Sub. After this you can run the InsertSketchedSymbolOnSheet to insert the sketched symbol into the active sheet. The insertion sub demonstrates the use of the insertion point in the symbol's definition while inserting the symbol.

Public Sub CreateSketchedSymbolDefinition()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Create the new sketched symbol definition.
    Dim oSketchedSymbolDef As SketchedSymbolDefinition
    Set oSketchedSymbolDef = oDrawDoc.SketchedSymbolDefinitions.Add("Circular Callout")

    ' Open the sketched symbol definition's sketch for edit. This is done by calling the Edit
    ' method of the SketchedSymbolDefinition to obtain a DrawingSketch. This actually creates
    ' a copy of the sketched symbol definition's and opens it for edit.
    Dim oSketch As DrawingSketch
    Call oSketchedSymbolDef.Edit(oSketch)

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Use the functionality of the sketch to add sketched symbol graphics.
    Dim oSketchLine As SketchLine
    Set oSketchLine = oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 0), oTG.CreatePoint2d(20, 0))

    Dim oSketchCircle As SketchCircle
    Set oSketchCircle = oSketch.SketchCircles.AddByCenterRadius(oTG.CreatePoint2d(22, 0), 2)

    Call oSketch.GeometricConstraints.AddCoincident(oSketchLine.EndSketchPoint, oSketchCircle)

    ' Make the starting point of the sketch line the insertion point
    oSketchLine.StartSketchPoint.InsertionPoint = True

    ' Add a prompted text field at the center of the sketch circle.
    Dim sText As String
    sText = "<Prompt>Enter text 1</Prompt>"
    Dim oTextBox As TextBox
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(22, 0), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

    Call oSketchedSymbolDef.ExitEdit(True)
End Sub

Public Sub InsertSketchedSymbolOnSheet()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Obtain a reference to the desired sketched symbol definition.
    Dim oSketchedSymbolDef As SketchedSymbolDefinition
    Set oSketchedSymbolDef = oDrawDoc.SketchedSymbolDefinitions.Item("Circular Callout")

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' This sketched symbol definition contains one prompted string input. An array
    ' must be input that contains the strings for the prompted strings.
    Dim sPromptStrings(0) As String
    sPromptStrings(0) = "A"

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Add an instance of the sketched symbol definition to the sheet.
    ' Rotate the instance by 45 degrees and scale by .75 when adding.
    ' The symbol will be inserted at (0,0) on the sheet. Since the
    ' start point of the line was marked as the insertion point, the
    ' start point should end up at (0,0).
    Dim oSketchedSymbol As SketchedSymbol
    Set oSketchedSymbol = oSheet.SketchedSymbols.Add(oSketchedSymbolDef, oTG.CreatePoint2d(0, 0), (3.14159 / 4), 0.75, sPromptStrings)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface


SketchedSymbolDefinition Methods

SketchedSymbolDefinition Methods
Summary

The methods of the SketchedSymbolDefinition class are listed here.

Methods
Methods
Name | Description
CopyTo | Method that copies the definition to the target drawing document.
Delete | Method that deletes the SketchedSymbolDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.
Edit | Method that opens a copy of the sketched symbol definition's sketch for edit in the Sketch environment. The DrawingSketch returned is a new sketch that Autodesk Inventor creates by copying the sketch associated with the sketched symbol definition.
ExitEdit | Method that closes the currently active sketch (see below for limitations) and depending on the input parameters, replaces the sketch of the sketched symbol definition with the edited sketch.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Methods


SketchedSymbolDefinition.CopyTo Method

SketchedSymbolDefinition.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that copies the definition to the target drawing document.

Visual Basic
Sub CopyTo(TargetDocument As DrawingDocument, ByRef ReplaceExisting As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] SketchedSymbolDefinition*)
Parameters
Parameters | Description
TargetDocument | Input DrawingDocument object that specifies the document to copy the definition into.
ReplaceExisting | Optional input Boolean that specifies whether to replace or create a new definition with a different name if a definition of the same name exists in the target document. If not specified, the argument defaults to False indicating that a new definition will be created.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Methods > SketchedSymbolDefinition.CopyTo Method


SketchedSymbolDefinition.Delete Method

SketchedSymbolDefinition.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the SketchedSymbolDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Methods > SketchedSymbolDefinition.Delete Method


SketchedSymbolDefinition.Edit Method

SketchedSymbolDefinition.Edit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that opens a copy of the sketched symbol definition's sketch for edit in the Sketch environment. The DrawingSketch returned is a new sketch that Autodesk Inventor creates by copying the sketch associated with the sketched symbol definition.

Visual Basic
Sub Edit(ByRef Result As DrawingSketch*)
Returns

Output DrawingSketch created by copying the sketch associated with the sketched symbol definition.

Remarks

The new sketch supports all edit operations. The ExitEdit method of the SketchedSymbolDefinition object can be used to replace the sketched symbol definition's sketch with the new sketch.

See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Methods > SketchedSymbolDefinition.Edit Method


SketchedSymbolDefinition.ExitEdit Method

SketchedSymbolDefinition.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that closes the currently active sketch (see below for limitations) and depending on the input parameters, replaces the sketch of the sketched symbol definition with the edited sketch.

Visual Basic
Sub ExitEdit(ByRef SaveChanges As [defaultvalue(-1)] VARIANT_BOOL, ByRef SaveAsName As [optional] VARIANT)
Parameters
Parameters | Description
SaveChanges | Input Boolean that specifies whether to save the changes or not. True indicates to save the changes. Setting this property to False will cause the sketch to close and lose all edits.
SaveAsName | Input String that specifies the name of the new sketched symbol definition to create. This argument is used in the case where the SaveChanges argument is True. If not specified, or an empty string is supplied, the edited sketch replaces the sketch associated with the sketched symbol definition being edited. If a string is supplied, a new sketched symbol definition is created and the edited sketch is used for it. The supplied name must be unique with respect to all other SketchedSymbolDefinition objects in the document.
Remarks

You can also choose to create a new sketched symbol definition using the edited sketch or close the edited sketch without saving any changes. This method is only valid to be called when a sketch associated with a SketchedSymbolDefinition object has been opened for edit using the Edit method of the SketchedSymbolDefinition object, otherwise an error will occur.

See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Methods > SketchedSymbolDefinition.ExitEdit Method


SketchedSymbolDefinition.GetReferenceKey Method

SketchedSymbolDefinition.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Methods > SketchedSymbolDefinition.GetReferenceKey Method


SketchedSymbolDefinition Properties

SketchedSymbolDefinition Properties
Summary

The properties of the SketchedSymbolDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
IsReferenced | Property that specifies if the sketched symbol definition is being referenced or not. A sketched symbol definition is referenced when an instance of the definition has been placed. A referenced sketched symbol definition cannot be deleted.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent .
Sketch | Property that returns the sketch associated with the sketched symbol definition. The DrawingSketch returned by the Sketch property supports all query functionality but cannot be edited. To edit the contents of a sketched symbol definition, use the Edit method. This creates a copy of the sketched symbol definition's sketch for edit. The ExitEdit method of the SketchedSymbolDefinition can then be used to save the edited sketch as the sketched symbol definition's sketch.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties


SketchedSymbolDefinition.Application Property

SketchedSymbolDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.Application Property


SketchedSymbolDefinition.AttributeSets Property

SketchedSymbolDefinition.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.AttributeSets Property


SketchedSymbolDefinition.IsReferenced Property

SketchedSymbolDefinition.IsReferenced Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies if the sketched symbol definition is being referenced or not. A sketched symbol definition is referenced when an instance of the definition has been placed. A referenced sketched symbol definition cannot be deleted.

Visual Basic
Property IsReferenced() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.IsReferenced Property


SketchedSymbolDefinition.Name Property

SketchedSymbolDefinition.Name Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.Name Property


SketchedSymbolDefinition.Parent Property

SketchedSymbolDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the parent .

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.Parent Property


SketchedSymbolDefinition.Sketch Property

SketchedSymbolDefinition.Sketch Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the sketch associated with the sketched symbol definition. The DrawingSketch returned by the Sketch property supports all query functionality but cannot be edited. To edit the contents of a sketched symbol definition, use the Edit method. This creates a copy of the sketched symbol definition's sketch for edit. The ExitEdit method of the SketchedSymbolDefinition can then be used to save the edited sketch as the sketched symbol definition's sketch.

Visual Basic
Property Sketch() As DrawingSketch**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.Sketch Property


SketchedSymbolDefinition.Type Property

SketchedSymbolDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinition Interface > SketchedSymbolDefinition Properties > SketchedSymbolDefinition.Type Property


SketchedSymbolDefinitions Interface

SketchedSymbolDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SketchedSymbolDefinitions collection object provides access to all the existing objects in a drawing document and provides methods to create additional sketched symbol definitions. See the article in the overviews section.

Class Hierarchy
Inventor::SketchedSymbolDefinitions
Visual Basic
Public Interface SketchedSymbolDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.SketchedSymbolDefinitions

See Also

Create sketched symbol and leader sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface


SketchedSymbolDefinitions Methods

SketchedSymbolDefinitions Methods
Summary

The methods of the SketchedSymbolDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sketched symbol definition. This method will fail in the case where a sketch is currently active. You can check for this case using the ActiveEditObject property of the Application object to see if a sketch is active.
Item | Method that returns the specified SketchedSymbolDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Methods


SketchedSymbolDefinitions.Add Method

SketchedSymbolDefinitions.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new sketched symbol definition. This method will fail in the case where a sketch is currently active. You can check for this case using the ActiveEditObject property of the Application object to see if a sketch is active.

Visual Basic
Sub Add(Name As String, Result As [out, retval] SketchedSymbolDefinition*)
Parameters
Parameters | Description
Name | Input String that defines name of the sketched symbol definition. The name specified must be unique with respect to the other sketched symbol definitions in the document. If a unique name is not specified, an error will occur.
See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Methods > SketchedSymbolDefinitions.Add Method


SketchedSymbolDefinitions.Item Method

SketchedSymbolDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified SketchedSymbolDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SketchedSymbolDefinition*)
Parameters
Parameters | Description
index | Input Variant value that specifies the SketchedSymbolDefinition to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the sketched symbol definition's name. If an out of range index or a name of a non-existent sketched symbol definition is specified, an error occurs.
See Also

Create sketched symbol and leader sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Methods > SketchedSymbolDefinitions.Item Method


SketchedSymbolDefinitions Properties

SketchedSymbolDefinitions Properties
Summary

The properties of the SketchedSymbolDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Properties


SketchedSymbolDefinitions.Application Property

SketchedSymbolDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Properties > SketchedSymbolDefinitions.Application Property


SketchedSymbolDefinitions.Count Property

SketchedSymbolDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Properties > SketchedSymbolDefinitions.Count Property


SketchedSymbolDefinitions.Type Property

SketchedSymbolDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbolDefinitions Interface > SketchedSymbolDefinitions Properties > SketchedSymbolDefinitions.Type Property


SketchedSymbols Interface

SketchedSymbols Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SketchedSymbols collection object provides access to the objects on a specific sheet. It also provides the ability to place sketched symbols onto a sheet. See the article in the overviews section.

Class Hierarchy
Inventor::SketchedSymbols
Visual Basic
Public Interface SketchedSymbols
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.SketchedSymbols

See Also

Create sketched symbol and leader sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface


SketchedSymbols Methods

SketchedSymbols Methods
Summary

The methods of the SketchedSymbols class are listed here.

Methods
Methods
Name | Description
Add | Method that places a sketched symbol onto the sheet.
AddWithLeader |
Item | Method that returns the specified SketchedSymbol object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Methods


SketchedSymbols.Add Method

SketchedSymbols.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that places a sketched symbol onto the sheet.

Visual Basic
Sub Add(SketchedSymbolDefinition As VARIANT, Position As Point2d, ByRef Rotation As [defaultvalue(0.0)] double, ByRef Scale As [defaultvalue(1.0)] double, ByRef PromptStrings As [optional] VARIANT, Result As [out, retval] SketchedSymbol*)
Parameters
Parameters | Description
SketchedSymbolDefinition | Input Variant that specifies which SketchedSymbolDefinition to use. The input for the argument can be either a SketchedSymbolDefinition object or string containing the name of an existing SketchedSymbolDefinition object.
Position | Input that specifies the location on the sheet to place the sketched symbol instance.
Rotation | The rotation of the symbol, in radians.
Scale | The scale of the symbol.
PromptStrings | Optional input array of Strings that specifies the input strings to use as input for prompted text fields that my be present in the sketched symbol definition. If prompted strings exist in the sketched symbol definition you must supply input strings through this argument or this method will fail. The prompt strings and their order are obtained by querying the TextBox objects in the SketchedSymbolDefinition. The order they're returned by the TextBoxes collection is the same order the input strings need to be supplied in the PromptStrings array.
See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Methods > SketchedSymbols.Add Method


SketchedSymbols.AddWithLeader Method

SketchedSymbols.AddWithLeader Method Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Sub AddWithLeader(SketchedSymbolDefinition As VARIANT, LeaderPoints As ObjectCollection, ByRef Rotation As [defaultvalue(0.0)] double, ByRef Scale As [defaultvalue(1.0)] double, ByRef PromptStrings As [optional] VARIANT, ByRef SymbolClipping As [defaultvalue(-1)] VARIANT_BOOL, ByRef Static As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] SketchedSymbol*)
Example

"Create sketched symbol and leader"

This sample illustrates creating sketched symbol with a leader. Before running this sample, open a drawing document, create a sketched symbol definition and select a linear drawing edge. The sample uses the first sketched symbol definition in the document to create the symbol.

Public Sub AddSymbolWithLeader()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the drawing curve segment.
    ' This assumes that a drwaing curve is selected.
    Dim oDrawingCurveSegment As DrawingCurveSegment
    Set oDrawingCurveSegment = oDrawDoc.SelectSet.Item(1)

    ' Set a reference to the drawing curve.
    Dim oDrawingCurve As DrawingCurve
    Set oDrawingCurve = oDrawingCurveSegment.Parent

    ' Get the mid point of the selected curve
    ' assuming that the selection curve is linear
    Dim oMidPoint As Point2d
    Set oMidPoint = oDrawingCurve.MidPoint

    ' Set a reference to the TransientGeometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oLeaderPoints As ObjectCollection
    Set oLeaderPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Create a few leader points.
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 10))
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 5))

    ' Create an intent and add to the leader points collection.
    ' This is the geometry that the symbol will attach to.
    Dim oGeometryIntent As GeometryIntent
    Set oGeometryIntent = oActiveSheet.CreateGeometryIntent(oDrawingCurve)

    Call oLeaderPoints.Add(oGeometryIntent)

    ' Get the first symbol definition
    Dim oSketchSymDef As SketchedSymbolDefinition
    Set oSketchSymDef = oDrawDoc.SketchedSymbolDefinitions.Item(1)

    ' Create the symbol with a leader
    Dim oSketchedSymbol As SketchedSymbol
    Set oSketchedSymbol = oActiveSheet.SketchedSymbols.AddWithLeader(oSketchSymDef, oLeaderPoints)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Methods > SketchedSymbols.AddWithLeader Method


SketchedSymbols.Item Method

SketchedSymbols.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified SketchedSymbol object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchedSymbol*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the SketchedSymbol to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Methods > SketchedSymbols.Item Method


SketchedSymbols Properties

SketchedSymbols Properties
Summary

The properties of the SketchedSymbols class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Properties


SketchedSymbols.Application Property

SketchedSymbols.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Properties > SketchedSymbols.Application Property


SketchedSymbols.Count Property

SketchedSymbols.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Properties > SketchedSymbols.Count Property


SketchedSymbols.Type Property

SketchedSymbols.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchedSymbols Interface > SketchedSymbols Properties > SketchedSymbols.Type Property


SketchEllipse Interface

SketchEllipse Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchEllipse object represents an ellipse within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchEllipse
        Inventor::SketchEllipseProxy
Visual Basic
Public Interface SketchEllipse
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

SketchEllipseProxy.NativeObject

SketchEllipses.Add

SketchEllipses.Item

See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface


SketchEllipse Methods

SketchEllipse Methods
Summary

The methods of the SketchEllipse class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Methods


SketchEllipse.GetCustomLineType Method

SketchEllipse.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Methods > SketchEllipse.GetCustomLineType Method


SketchEllipse.SetCustomLineType Method

SketchEllipse.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Methods > SketchEllipse.SetCustomLineType Method


SketchEllipse Properties

SketchEllipse Properties
Summary

The properties of the SketchEllipse class are listed here.

Properties
Name | Description
Area | Double property that returns the area of the entity in square centimeters.
CenterSketchPoint | Property that gets the sketch point that defines the position of the center of the ellipse.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.
Geometry | Property that returns an EllipseFull2d geometry object. The object returned represents a snapshot view of the current state of the sketch ellipse.
Length | Gets the length of the ellipse.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
MajorAxisVector | Property that gets and sets the major axis vector. This vector defines the direction of the major axis. Depending on other constraints on the ellipse, it may not be possible to set the vector the any desired value.
MajorRadius | Property that gets and sets the major radius. Depending on other constraints on the ellipse, it may not be possible to set the major radius to any desired value.
MinorRadius | Property that gets and sets the minor radius. Depending on other constraints on the ellipse, it may not be possible to set the minor radius to any desired value.
OverrideColor | Gets and sets the color applied to this primitive.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties


SketchEllipse.Area Property

SketchEllipse.Area Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the area of the entity in square centimeters.

Visual Basic
Property Area() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.Area Property


SketchEllipse.CenterSketchPoint Property

SketchEllipse.CenterSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the sketch point that defines the position of the center of the ellipse.

Visual Basic
Property CenterSketchPoint() As SketchPoint**
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.CenterSketchPoint Property


SketchEllipse.CurvatureDisplay Property

SketchEllipse.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.CurvatureDisplay Property


SketchEllipse.Geometry Property

SketchEllipse.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an EllipseFull2d geometry object. The object returned represents a snapshot view of the current state of the sketch ellipse.

Visual Basic
Property Geometry() As EllipseFull2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.Geometry Property


SketchEllipse.Length Property

SketchEllipse.Length Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the length of the ellipse.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.Length Property


SketchEllipse.LineDefinitionSpace Property

SketchEllipse.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.LineDefinitionSpace Property


SketchEllipse.LineScale Property

SketchEllipse.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.LineScale Property


SketchEllipse.LineType Property

SketchEllipse.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.LineType Property


SketchEllipse.LineWeight Property

SketchEllipse.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.LineWeight Property


SketchEllipse.MajorAxisVector Property

SketchEllipse.MajorAxisVector Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the major axis vector. This vector defines the direction of the major axis. Depending on other constraints on the ellipse, it may not be possible to set the vector the any desired value.

Visual Basic
Property MajorAxisVector() As UnitVector2d*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.MajorAxisVector Property


SketchEllipse.MajorRadius Property

SketchEllipse.MajorRadius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the major radius. Depending on other constraints on the ellipse, it may not be possible to set the major radius to any desired value.

Visual Basic
Property MajorRadius() As double
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.MajorRadius Property


SketchEllipse.MinorRadius Property

SketchEllipse.MinorRadius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the minor radius. Depending on other constraints on the ellipse, it may not be possible to set the minor radius to any desired value.

Visual Basic
Property MinorRadius() As double
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.MinorRadius Property


SketchEllipse.OverrideColor Property

SketchEllipse.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse Interface > SketchEllipse Properties > SketchEllipse.OverrideColor Property


SketchEllipse3D Interface

SketchEllipse3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchEllipse3D object represents an ellipse within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchEllipse3D
        Inventor::SketchEllipse3DProxy
Visual Basic
Public Interface SketchEllipse3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

SketchEllipse3DProxy.NativeObject

SketchEllipses3D.Item

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface


SketchEllipse3D Properties

SketchEllipse3D Properties
Summary

The properties of the SketchEllipse3D class are listed here.

Properties
Name | Description
Area | Double property that returns the area of the entity in square centimeters.
CenterPoint | Property that returns the point that defines the position of the center of the ellipse.
CurvatureDisplay | Specifies whether curvature information is displayed for the ellipse.
Geometry | Property that get and sets the EllipseFull geometry object. The object returned represents a 'snapshot' view of the current state of the sketch ellipse. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
Length | Gets the length of the ellipse.
MajorAxisVector | Gets the MajorAxisVector of the ellipse.
MajorRadius | Gets the MajorRadius of the ellipse.
MinorRadius | Gets the MinorRadius of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties


SketchEllipse3D.Area Property

SketchEllipse3D.Area Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Double property that returns the area of the entity in square centimeters.

Visual Basic
Property Area() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.Area Property


SketchEllipse3D.CenterPoint Property

SketchEllipse3D.CenterPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the point that defines the position of the center of the ellipse.

Visual Basic
Property CenterPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.CenterPoint Property


SketchEllipse3D.CurvatureDisplay Property

SketchEllipse3D.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies whether curvature information is displayed for the ellipse.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.CurvatureDisplay Property


SketchEllipse3D.Geometry Property

SketchEllipse3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that get and sets the EllipseFull geometry object. The object returned represents a 'snapshot' view of the current state of the sketch ellipse. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As EllipseFull*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.Geometry Property


SketchEllipse3D.Length Property

SketchEllipse3D.Length Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the length of the ellipse.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.Length Property


SketchEllipse3D.MajorAxisVector Property

SketchEllipse3D.MajorAxisVector Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the MajorAxisVector of the ellipse.

Visual Basic
Property MajorAxisVector() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.MajorAxisVector Property


SketchEllipse3D.MajorRadius Property

SketchEllipse3D.MajorRadius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the MajorRadius of the ellipse.

Visual Basic
Property MajorRadius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.MajorRadius Property


SketchEllipse3D.MinorRadius Property

SketchEllipse3D.MinorRadius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the MinorRadius of the ellipse.

Visual Basic
Property MinorRadius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3D Interface > SketchEllipse3D Properties > SketchEllipse3D.MinorRadius Property


SketchEllipse3DProxy Interface

SketchEllipse3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipse3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchEllipse3D
        Inventor::SketchEllipse3DProxy
Visual Basic
Public Interface SketchEllipse3DProxy
Inherits SketchEllipse3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3DProxy Interface


SketchEllipse3DProxy Properties

SketchEllipse3DProxy Properties
Summary

The properties of the SketchEllipse3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3DProxy Interface > SketchEllipse3DProxy Properties


SketchEllipse3DProxy.ContainingOccurrence Property

SketchEllipse3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3DProxy Interface > SketchEllipse3DProxy Properties > SketchEllipse3DProxy.ContainingOccurrence Property


SketchEllipse3DProxy.NativeObject Property

SketchEllipse3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchEllipse3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipse3DProxy Interface > SketchEllipse3DProxy Properties > SketchEllipse3DProxy.NativeObject Property


SketchEllipseProxy Interface

SketchEllipseProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipse object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchEllipse
        Inventor::SketchEllipseProxy
Visual Basic
Public Interface SketchEllipseProxy
Inherits SketchEllipse
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipseProxy Interface


SketchEllipseProxy Properties

SketchEllipseProxy Properties
Summary

The properties of the SketchEllipseProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipseProxy Interface > SketchEllipseProxy Properties


SketchEllipseProxy.ContainingOccurrence Property

SketchEllipseProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipseProxy Interface > SketchEllipseProxy Properties > SketchEllipseProxy.ContainingOccurrence Property


SketchEllipseProxy.NativeObject Property

SketchEllipseProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchEllipse**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipseProxy Interface > SketchEllipseProxy Properties > SketchEllipseProxy.NativeObject Property


SketchEllipses Interface

SketchEllipses Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchEllipses object provides access to all the objects in a sketch and provides methods to create additional sketch ellipses. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEllipses
Visual Basic
Public Interface SketchEllipses
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchEllipses

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface


SketchEllipses Methods

SketchEllipses Methods
Summary

The methods of the SketchEllipses class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sketch ellipse.
Item | Property that returns the specified SketchEllipse object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Methods


SketchEllipses.Add Method

SketchEllipses.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch ellipse.

Visual Basic
Sub Add(CenterPoint As IDispatch, MajorAxisVector As UnitVector2d, MajorRadius As double, MinorRadius As double, Result As [out, retval] SketchEllipse*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, the ellipse will be attached to the point.
MajorAxisVector | Input UnitVector2d that defines the direction of the major axis.
MajorRadius | Input Double that defines the major radius in centimeters.
MinorRadius | Input Double that defines the minor radius in centimeters.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Methods > SketchEllipses.Add Method


SketchEllipses.Item Method

SketchEllipses.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchEllipse object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchEllipse*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Methods > SketchEllipses.Item Method


SketchEllipses Properties

SketchEllipses Properties
Summary

The properties of the SketchEllipses class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Properties


SketchEllipses.Application Property

SketchEllipses.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Properties > SketchEllipses.Application Property


SketchEllipses.Count Property

SketchEllipses.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Properties > SketchEllipses.Count Property


SketchEllipses.Type Property

SketchEllipses.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses Interface > SketchEllipses Properties > SketchEllipses.Type Property


SketchEllipses3D Interface

SketchEllipses3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchEllipses3D object provides access to all the objects in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEllipses3D
Visual Basic
Public Interface SketchEllipses3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchEllipses3D

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface


SketchEllipses3D Methods

SketchEllipses3D Methods
Summary

The methods of the SketchEllipses3D class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified SketchEllipse3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface > SketchEllipses3D Methods


SketchEllipses3D.Item Method

SketchEllipses3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchEllipse3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchEllipse3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface > SketchEllipses3D Methods > SketchEllipses3D.Item Method


SketchEllipses3D Properties

SketchEllipses3D Properties
Summary

The properties of the SketchEllipses3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface > SketchEllipses3D Properties


SketchEllipses3D.Application Property

SketchEllipses3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface > SketchEllipses3D Properties > SketchEllipses3D.Application Property


SketchEllipses3D.Count Property

SketchEllipses3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface > SketchEllipses3D Properties > SketchEllipses3D.Count Property


SketchEllipses3D.Type Property

SketchEllipses3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipses3D Interface > SketchEllipses3D Properties > SketchEllipses3D.Type Property


SketchEllipticalArc Interface

SketchEllipticalArc Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchEllipticalArc object represents an elliptical arc within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchEllipticalArc
        Inventor::SketchEllipticalArcProxy
Visual Basic
Public Interface SketchEllipticalArc
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

SketchEllipticalArcProxy.NativeObject

SketchEllipticalArcs.Add

SketchEllipticalArcs.Item

See Also

Sketch Display Entities sample

Example

"Create sketch elliptical arc."

This sample demonstrates creating an elliptical arc in a sketch and dimensioning its minor radius. To run this sample you must have a sketch active.

Sub DrawSketchEllipticalArc()

    ' Check to make sure a sketch is open.
    If Not Typeof ThisApplication.ActiveEditObject Is PlanarSketch Then
        MsgBox "A sketch must be active."
        Exit Sub
    End If

    ' Set a reference to the active sketch.
    Dim oSketch As PlanarSketch
    Set oSketch = ThisApplication.ActiveEditObject

    ' Set a reference to the transient geometry collection.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Arc center point at 0,0
    Dim oCenter As Point2d
    Set oCenter = oTransGeom.CreatePoint2d(0, 0)

    ' Arc major axis as the y-axis
    Dim oMajorAxis As UnitVector2d
    Set oMajorAxis = oTransGeom.CreateUnitVector2d(0, 1)

    Dim PI As Double
    PI = 4# * Atn(1#)

    ' Create the elliptical arc
    Dim oEllipticalArc As SketchEllipticalArc
    Set oEllipticalArc = oSketch.SketchEllipticalArcs.Add(oCenter, oMajorAxis, 5, 2, 0, PI / 2)

    Dim oTextPt As Point2d
    Set oTextPt = oTransGeom.CreatePoint2d(-1, -0.5)

    ' Create a radius dimension
    Dim oEllipseRadiusDim As EllipseRadiusDimConstraint
    Set oEllipseRadiusDim = oSketch.DimensionConstraints.AddEllipseRadius(oEllipticalArc, False, oTextPt)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface


SketchEllipticalArc Methods

SketchEllipticalArc Methods
Summary

The methods of the SketchEllipticalArc class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Methods


SketchEllipticalArc.GetCustomLineType Method

SketchEllipticalArc.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Methods > SketchEllipticalArc.GetCustomLineType Method


SketchEllipticalArc.SetCustomLineType Method

SketchEllipticalArc.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Methods > SketchEllipticalArc.SetCustomLineType Method


SketchEllipticalArc Properties

SketchEllipticalArc Properties
Summary

The properties of the SketchEllipticalArc class are listed here.

Properties
Name | Description
CenterSketchPoint | Property that gets the sketch point that defines the position of the center of the elliptical arc.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.
EndSketchPoint | Property that returns the end of the elliptical arc.
Geometry | Property that returns an EllipticalArc2d geometry object. The object returned represents a snapshot view of the current state of the sketch elliptical arc.
Length | Double property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
MajorAxisVector | Property that gets and sets the major axis vector. This vector defines the direction of the major axis. Depending on other constraints on the elliptical arc, it may not be possible to set the vector the any desired value.
MajorRadius | Property that gets and sets the major radius. Depending on other constraints on the elliptical arc, it may not be possible to set the major radius to any desired value.
MinorRadius | Property that gets and sets the minor radius. Depending on other constraints on the elliptical arc, it may not be possible to set the minor radius to any desired value.
OverrideColor | Gets and sets the color applied to this primitive.
StartAngle | Double property that returns the start angle of the elliptical arc. This is measured counterclockwise from the major axis in radians.
StartSketchPoint | Property that gets the start of the elliptical arc.
SweepAngle | Double property that returns the sweep angle of the elliptical arc. This is measured counterclockwise from the major axis in radians.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties


SketchEllipticalArc.CenterSketchPoint Property

SketchEllipticalArc.CenterSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the sketch point that defines the position of the center of the elliptical arc.

Visual Basic
Property CenterSketchPoint() As SketchPoint**
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.CenterSketchPoint Property


SketchEllipticalArc.CurvatureDisplay Property

SketchEllipticalArc.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.CurvatureDisplay Property


SketchEllipticalArc.EndSketchPoint Property

SketchEllipticalArc.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the end of the elliptical arc.

Visual Basic
Property EndSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.EndSketchPoint Property


SketchEllipticalArc.Geometry Property

SketchEllipticalArc.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns an EllipticalArc2d geometry object. The object returned represents a snapshot view of the current state of the sketch elliptical arc.

Visual Basic
Property Geometry() As EllipticalArc2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.Geometry Property


SketchEllipticalArc.Length Property

SketchEllipticalArc.Length Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.Length Property


SketchEllipticalArc.LineDefinitionSpace Property

SketchEllipticalArc.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.LineDefinitionSpace Property


SketchEllipticalArc.LineScale Property

SketchEllipticalArc.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.LineScale Property


SketchEllipticalArc.LineType Property

SketchEllipticalArc.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.LineType Property


SketchEllipticalArc.LineWeight Property

SketchEllipticalArc.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.LineWeight Property


SketchEllipticalArc.MajorAxisVector Property

SketchEllipticalArc.MajorAxisVector Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the major axis vector. This vector defines the direction of the major axis. Depending on other constraints on the elliptical arc, it may not be possible to set the vector the any desired value.

Visual Basic
Property MajorAxisVector() As UnitVector2d*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.MajorAxisVector Property


SketchEllipticalArc.MajorRadius Property

SketchEllipticalArc.MajorRadius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the major radius. Depending on other constraints on the elliptical arc, it may not be possible to set the major radius to any desired value.

Visual Basic
Property MajorRadius() As double
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.MajorRadius Property


SketchEllipticalArc.MinorRadius Property

SketchEllipticalArc.MinorRadius Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the minor radius. Depending on other constraints on the elliptical arc, it may not be possible to set the minor radius to any desired value.

Visual Basic
Property MinorRadius() As double
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.MinorRadius Property


SketchEllipticalArc.OverrideColor Property

SketchEllipticalArc.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.OverrideColor Property


SketchEllipticalArc.StartAngle Property

SketchEllipticalArc.StartAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the start angle of the elliptical arc. This is measured counterclockwise from the major axis in radians.

Visual Basic
Property StartAngle() As double*
Remarks

This angle is a circular angle, not an elliptical angle.

See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.StartAngle Property


SketchEllipticalArc.StartSketchPoint Property

SketchEllipticalArc.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the start of the elliptical arc.

Visual Basic
Property StartSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.StartSketchPoint Property


SketchEllipticalArc.SweepAngle Property

SketchEllipticalArc.SweepAngle Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the sweep angle of the elliptical arc. This is measured counterclockwise from the major axis in radians.

Visual Basic
Property SweepAngle() As double*
Remarks

This angle is a circular angle, not an elliptical angle.

See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc Interface > SketchEllipticalArc Properties > SketchEllipticalArc.SweepAngle Property


SketchEllipticalArc3D Interface

SketchEllipticalArc3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchEllipticalArc3D object represents an elliptical arc within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchEllipticalArc3D
        Inventor::SketchEllipticalArc3DProxy
Visual Basic
Public Interface SketchEllipticalArc3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

SketchEllipticalArc3DProxy.NativeObject

SketchEllipticalArcs3D.Item

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface


SketchEllipticalArc3D Properties

SketchEllipticalArc3D Properties
Summary

The properties of the SketchEllipticalArc3D class are listed here.

Properties
Name | Description
CenterPoint | Property that returns the center point of the elliptical arc.
CurvatureDisplay | Specifies whether curvature information is displayed for the elliptical arc.
EndSketchPoint | Property that gets the that defines the position of the end of the elliptical arc.
Geometry | Property that gets and sets the EllipticalArc geometry object. The object returned represents a 'snapshot' view of the current state of the sketch elliptical arc. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
Length | Double property that returns the length of the entity in centimeters.
MajorAxisVector | Gets the MajorAxisVector of the elliptical arc.
MajorRadius | Gets the MajorRadius of the elliptical arc.
MinorRadius | Gets the MinorRadius of the elliptical arc.
StartAngle | Gets the StartAngle of the elliptical arc.
StartSketchPoint | Property that returns the that defines the position of the start of the elliptical arc.
SweepAngle | Gets the SweepAngle of the elliptical arc.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties


SketchEllipticalArc3D.CenterPoint Property

SketchEllipticalArc3D.CenterPoint Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the center point of the elliptical arc.

Visual Basic
Property CenterPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.CenterPoint Property


SketchEllipticalArc3D.CurvatureDisplay Property

SketchEllipticalArc3D.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Specifies whether curvature information is displayed for the elliptical arc.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.CurvatureDisplay Property


SketchEllipticalArc3D.EndSketchPoint Property

SketchEllipticalArc3D.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets the that defines the position of the end of the elliptical arc.

Visual Basic
Property EndSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.EndSketchPoint Property


SketchEllipticalArc3D.Geometry Property

SketchEllipticalArc3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the EllipticalArc geometry object. The object returned represents a 'snapshot' view of the current state of the sketch elliptical arc. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As EllipticalArc*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.Geometry Property


SketchEllipticalArc3D.Length Property

SketchEllipticalArc3D.Length Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.Length Property


SketchEllipticalArc3D.MajorAxisVector Property

SketchEllipticalArc3D.MajorAxisVector Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the MajorAxisVector of the elliptical arc.

Visual Basic
Property MajorAxisVector() As UnitVector**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.MajorAxisVector Property


SketchEllipticalArc3D.MajorRadius Property

SketchEllipticalArc3D.MajorRadius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the MajorRadius of the elliptical arc.

Visual Basic
Property MajorRadius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.MajorRadius Property


SketchEllipticalArc3D.MinorRadius Property

SketchEllipticalArc3D.MinorRadius Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the MinorRadius of the elliptical arc.

Visual Basic
Property MinorRadius() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.MinorRadius Property


SketchEllipticalArc3D.StartAngle Property

SketchEllipticalArc3D.StartAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the StartAngle of the elliptical arc.

Visual Basic
Property StartAngle() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.StartAngle Property


SketchEllipticalArc3D.StartSketchPoint Property

SketchEllipticalArc3D.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the that defines the position of the start of the elliptical arc.

Visual Basic
Property StartSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.StartSketchPoint Property


SketchEllipticalArc3D.SweepAngle Property

SketchEllipticalArc3D.SweepAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the SweepAngle of the elliptical arc.

Visual Basic
Property SweepAngle() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3D Interface > SketchEllipticalArc3D Properties > SketchEllipticalArc3D.SweepAngle Property


SketchEllipticalArc3DProxy Interface

SketchEllipticalArc3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipticalArc3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchEllipticalArc3D
        Inventor::SketchEllipticalArc3DProxy
Visual Basic
Public Interface SketchEllipticalArc3DProxy
Inherits SketchEllipticalArc3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3DProxy Interface


SketchEllipticalArc3DProxy Properties

SketchEllipticalArc3DProxy Properties
Summary

The properties of the SketchEllipticalArc3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3DProxy Interface > SketchEllipticalArc3DProxy Properties


SketchEllipticalArc3DProxy.ContainingOccurrence Property

SketchEllipticalArc3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3DProxy Interface > SketchEllipticalArc3DProxy Properties > SketchEllipticalArc3DProxy.ContainingOccurrence Property


SketchEllipticalArc3DProxy.NativeObject Property

SketchEllipticalArc3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchEllipticalArc3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArc3DProxy Interface > SketchEllipticalArc3DProxy Properties > SketchEllipticalArc3DProxy.NativeObject Property


SketchEllipticalArcProxy Interface

SketchEllipticalArcProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchEllipticalArc object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchEllipticalArc
        Inventor::SketchEllipticalArcProxy
Visual Basic
Public Interface SketchEllipticalArcProxy
Inherits SketchEllipticalArc
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcProxy Interface


SketchEllipticalArcProxy Properties

SketchEllipticalArcProxy Properties
Summary

The properties of the SketchEllipticalArcProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcProxy Interface > SketchEllipticalArcProxy Properties


SketchEllipticalArcProxy.ContainingOccurrence Property

SketchEllipticalArcProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcProxy Interface > SketchEllipticalArcProxy Properties > SketchEllipticalArcProxy.ContainingOccurrence Property


SketchEllipticalArcProxy.NativeObject Property

SketchEllipticalArcProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchEllipticalArc**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcProxy Interface > SketchEllipticalArcProxy Properties > SketchEllipticalArcProxy.NativeObject Property


SketchEllipticalArcs Interface

SketchEllipticalArcs Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchEllipticalArcs object provides access to all the objects in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEllipticalArcs
Visual Basic
Public Interface SketchEllipticalArcs
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchEllipticalArcs

See Also

Create sketch elliptical arc sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface


SketchEllipticalArcs Methods

SketchEllipticalArcs Methods
Summary

The methods of the SketchEllipticalArcs class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sketch elliptical arc.
Item | Property that returns the specified SketchEllipticalArc object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Methods


SketchEllipticalArcs.Add Method

SketchEllipticalArcs.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that creates a new sketch elliptical arc.

Visual Basic
Sub Add(CenterPoint As IDispatch, MajorAxisVector As UnitVector2d, MajorRadius As double, MinorRadius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] SketchEllipticalArc*)
Parameters
Parameters | Description
CenterPoint | Input object that defines the center point. This can be either a SketchPoint or Point2d object. In the case where a SketchPoint object is input, the ellipse will be attached to the point.
MajorAxisVector | Input UnitVector2d that defines the direction of the major axis.
MajorRadius | Input Double that defines the major radius in centimeters.
MinorRadius | Input Double that defines the minor radius in centimeters.
StartAngle | Input Double that defines the start angle in radians. The start angle is defined with respect to the major axis.
SweepAngle | Input Double that defines the sweep angle in radians. The sweep is in a counter-clockwise direction from the start angle.
See Also

Create sketch elliptical arc sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Methods > SketchEllipticalArcs.Add Method


SketchEllipticalArcs.Item Method

SketchEllipticalArcs.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchEllipticalArc object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchEllipticalArc*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Methods > SketchEllipticalArcs.Item Method


SketchEllipticalArcs Properties

SketchEllipticalArcs Properties
Summary

The properties of the SketchEllipticalArcs class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Properties


SketchEllipticalArcs.Application Property

SketchEllipticalArcs.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Properties > SketchEllipticalArcs.Application Property


SketchEllipticalArcs.Count Property

SketchEllipticalArcs.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Properties > SketchEllipticalArcs.Count Property


SketchEllipticalArcs.Type Property

SketchEllipticalArcs.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs Interface > SketchEllipticalArcs Properties > SketchEllipticalArcs.Type Property


SketchEllipticalArcs3D Interface

SketchEllipticalArcs3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchEllipticalArcs3D object provides access to all the objects in a sketch.

Class Hierarchy
Inventor::SketchEllipticalArcs3D
Visual Basic
Public Interface SketchEllipticalArcs3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchEllipticalArcs3D

You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface


SketchEllipticalArcs3D Methods

SketchEllipticalArcs3D Methods
Summary

The methods of the SketchEllipticalArcs3D class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified SketchEllipticalArc3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface > SketchEllipticalArcs3D Methods


SketchEllipticalArcs3D.Item Method

SketchEllipticalArcs3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchEllipticalArc3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchEllipticalArc3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface > SketchEllipticalArcs3D Methods > SketchEllipticalArcs3D.Item Method


SketchEllipticalArcs3D Properties

SketchEllipticalArcs3D Properties
Summary

The properties of the SketchEllipticalArcs3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface > SketchEllipticalArcs3D Properties


SketchEllipticalArcs3D.Application Property

SketchEllipticalArcs3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface > SketchEllipticalArcs3D Properties > SketchEllipticalArcs3D.Application Property


SketchEllipticalArcs3D.Count Property

SketchEllipticalArcs3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface > SketchEllipticalArcs3D Properties > SketchEllipticalArcs3D.Count Property


SketchEllipticalArcs3D.Type Property

SketchEllipticalArcs3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEllipticalArcs3D Interface > SketchEllipticalArcs3D Properties > SketchEllipticalArcs3D.Type Property


SketchEntities3DEnumerator Interface

SketchEntities3DEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchEntities3DEnumerator object provides access to a set of 3D sketch entities. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntities3DEnumerator
Visual Basic
Public Interface SketchEntities3DEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchEntities3D

SketchEntity3D.OwnedBy

SketchPoint3D.AttachedEntities

You are here: Symbol Reference > Inventor Library > Objects > SketchEntities3DEnumerator Interface


SketchEntities3DEnumerator Methods

SketchEntities3DEnumerator Methods
Summary

The methods of the SketchEntities3DEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified SketchEntity3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntities3DEnumerator Interface > SketchEntities3DEnumerator Methods


SketchEntities3DEnumerator.Item Method

SketchEntities3DEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchEntity3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchEntity3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntities3DEnumerator Interface > SketchEntities3DEnumerator Methods > SketchEntities3DEnumerator.Item Method


SketchEntities3DEnumerator Properties

SketchEntities3DEnumerator Properties
Summary

The properties of the SketchEntities3DEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntities3DEnumerator Interface > SketchEntities3DEnumerator Properties


SketchEntities3DEnumerator.Count Property

SketchEntities3DEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntities3DEnumerator Interface > SketchEntities3DEnumerator Properties > SketchEntities3DEnumerator.Count Property


SketchEntities3DEnumerator.Type Property

SketchEntities3DEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntities3DEnumerator Interface > SketchEntities3DEnumerator Properties > SketchEntities3DEnumerator.Type Property


SketchEntitiesEnumerator Interface

SketchEntitiesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchEntitiesEnumerator object provides access to all of the geometric entities on the sketch regardless of their type. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntitiesEnumerator
Visual Basic
Public Interface SketchEntitiesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ProjectedCut.SketchEntities

Sketch.SketchEntities

Sketch.OffsetSketchEntitiesUsingDistance

Sketch.OffsetSketchEntitiesUsingPoint

SketchEntity.OwnedBy

SketchImage.BoundaryGeometry

SketchLines.AddAsPolygon

SketchLines.AddAsThreePointRectangle

SketchLines.AddAsTwoPointRectangle

SketchPoint.AttachedEntities

TextBox.BoundaryGeometry

See Also

Create sheet metal lofted flange feature sample

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

Using Inventor's error dialog sample

Edit profile of an extrude feature sample

Sketch Lines sample

Offset a 2D sketch sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEntitiesEnumerator Interface


SketchEntitiesEnumerator Methods

SketchEntitiesEnumerator Methods
Summary

The methods of the SketchEntitiesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified SketchEntity object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntitiesEnumerator Interface > SketchEntitiesEnumerator Methods


SketchEntitiesEnumerator.Item Method

SketchEntitiesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchEntity object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchEntity*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
See Also

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEntitiesEnumerator Interface > SketchEntitiesEnumerator Methods > SketchEntitiesEnumerator.Item Method


SketchEntitiesEnumerator Properties

SketchEntitiesEnumerator Properties
Summary

The properties of the SketchEntitiesEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntitiesEnumerator Interface > SketchEntitiesEnumerator Properties


SketchEntitiesEnumerator.Count Property

SketchEntitiesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntitiesEnumerator Interface > SketchEntitiesEnumerator Properties > SketchEntitiesEnumerator.Count Property


SketchEntitiesEnumerator.Type Property

SketchEntitiesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntitiesEnumerator Interface > SketchEntitiesEnumerator Properties > SketchEntitiesEnumerator.Type Property


SketchEntity Interface

SketchEntity Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchEntity object is the base class for all geometric sketch entities. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchArc
    Inventor::SketchCircle
    Inventor::SketchEllipse
    Inventor::SketchEllipticalArc
    Inventor::SketchFixedSpline
    Inventor::SketchLine
    Inventor::SketchOffsetSpline
    Inventor::SketchPoint
    Inventor::SketchSpline
Visual Basic
Public Interface SketchEntity
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CoincidentConstraint.EntityOne

CoincidentConstraint.EntityTwo

CollinearConstraint.EntityOne

CollinearConstraint.EntityTwo

ConcentricConstraint.EntityOne

ConcentricConstraint.EntityTwo

DiameterDimConstraint.Entity

EllipseRadiusDimConstraint.Entity

EqualRadiusConstraint.EntityOne

EqualRadiusConstraint.EntityTwo

GroundConstraint.Entity

HorizontalConstraint.Entity

OffsetConstraint.EntityFour

OffsetConstraint.EntityOne

OffsetConstraint.EntityThree

OffsetConstraint.EntityTwo

OffsetDimConstraint.Entity

ParallelConstraint.EntityOne

ParallelConstraint.EntityTwo

PerpendicularConstraint.EntityOne

PerpendicularConstraint.EntityTwo

PlanarSketch.AddBySilhouette

ProfileEntity.SketchEntity

RadiusDimConstraint.Entity

Sketch.AddByProjectingEntity

SketchEntitiesEnumerator.Item

SmoothConstraint.EntityOne

SmoothConstraint.EntityTwo

SymmetryConstraint.EntityOne

SymmetryConstraint.EntityTwo

TangentDistanceDimConstraint.EntityOne

TangentDistanceDimConstraint.EntityTwo

TangentSketchConstraint.EntityOne

TangentSketchConstraint.EntityTwo

VerticalConstraint.Entity

PathEntity.SketchEntity

See Also

Create sketch block from an existing sketch sample

Edit profile of an extrude feature sample

Move sketch entities sample

Sketch from face silhouette sample

Example

"Sketch Display Entities Example "

This sample demonstrates the query functionality available for sketch entities.

To use this sample, select a sketch entity that you want to query. Run the program and it will display information about the selected entity in the immediate window.

Public Sub SketchEntities()
    ' Get the first item in the select set.  This assumes
    ' something is selected and that it's a sketch entity.
    Dim oSketchEnt As SketchEntity
    Set oSketchEnt = ThisApplication.ActiveDocument.SelectSet.Item(1)

    ' Set a reference to the transient geometry object.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Display type specific information.
    Select Case oSketchEnt.Type
        Case kSketchArcObject
            Dim oArc As SketchArc
            Set oArc = oSketchEnt
            Debug.Print "Sketch Arc selected."
            Debug.Print "  Center Point: " & oArc.CenterSketchPoint.Geometry.X & _
                            ", " & oArc.CenterSketchPoint.Geometry.Y
            Debug.Print "  Start Point: " & oArc.StartSketchPoint.Geometry.X & _
                            ", " & oArc.StartSketchPoint.Geometry.Y
            Debug.Print "  End Point: " & oArc.EndSketchPoint.Geometry.X & _
                            ", " & oArc.EndSketchPoint.Geometry.Y
            Debug.Print "  Start Angle: " & oArc.StartAngle
            Debug.Print "  Sweep Angle: " & oArc.SweepAngle
            Debug.Print "  Radius: " & oArc.Radius
            Debug.Print "  Length: " & oArc.Length
        Case kSketchCircleObject
            Dim oCircle As SketchCircle
            Set oCircle = oSketchEnt
            Debug.Print "Sketch Circle selected."
            Debug.Print "  Center Point: " & oCircle.CenterSketchPoint.Geometry.X & _
                            ", " & oCircle.CenterSketchPoint.Geometry.Y
            Debug.Print "  Radius: " & oCircle.Radius
            Debug.Print "  Area: " & oCircle.Area

            ' Change the radius
            oCircle.Radius = oCircle.Radius * 1.5
        Case kSketchEllipseObject
            Dim oEllipse As SketchEllipse
            Set oEllipse = oSketchEnt
            Debug.Print "Sketch Ellipse selected."
            Debug.Print "  Center Point: " & oEllipse.CenterSketchPoint.Geometry.X & _
                            ", " & oEllipse.CenterSketchPoint.Geometry.Y
            Debug.Print "  Major Axis Vecotr: " & oEllipse.MajorAxisVector.X & _
                            ", " & oEllipse.MajorAxisVector.Y
            Debug.Print "  Major Radius: " & oEllipse.MajorRadius
            Debug.Print "  Minor Radius: " & oEllipse.MinorRadius
            Debug.Print "  Area: " & oEllipse.Area

            ' Modify the ellipse
            oEllipse.MajorAxisVector = oTransGeom.CreateUnitVector2d(1, 1)
            oEllipse.MajorRadius = oEllipse.MajorRadius / 2
            oEllipse.MinorRadius = oEllipse.MinorRadius * 2
        Case kSketchEllipticalArcObject
            Dim oEllipticalArc As SketchEllipticalArc
            Set oEllipticalArc = oSketchEnt
            Debug.Print "Sketch Elliptical Arc selected."
            Debug.Print "  Center Point: " & oEllipticalArc.CenterSketchPoint.Geometry.X & _
                            ", " & oEllipticalArc.CenterSketchPoint.Geometry.Y
            Debug.Print "  Major Axis Vector: " & oEllipticalArc.MajorAxisVector.X & _
                            ", " & oEllipticalArc.MajorAxisVector.Y
            Debug.Print "  Major Radius: " & oEllipticalArc.MajorRadius
            Debug.Print "  Minor Radius: " & oEllipticalArc.MinorRadius
            Debug.Print "  Start Angle: " & oEllipticalArc.StartAngle
            Debug.Print "  Sweep Angle: " & oEllipticalArc.SweepAngle
            Debug.Print "  Length: " & oEllipticalArc.Length

            ' Modify the elliptical arc.
            oEllipticalArc.MajorAxisVector = oTransGeom.CreateUnitVector2d(1, 1)
            oEllipticalArc.MajorRadius = oEllipticalArc.MajorRadius / 2
            oEllipticalArc.MinorRadius = oEllipticalArc.MinorRadius * 2
        Case kSketchLineObject
            Dim oLine As SketchLine
            Set oLine = oSketchEnt
            Debug.Print "Sketch Line selected."
            Debug.Print "  Start Point: " & oLine.StartSketchPoint.Geometry.X & _
                            ", " & oLine.StartSketchPoint.Geometry.Y
            Debug.Print "  End Point: " & oLine.EndSketchPoint.Geometry.X & _
                            ", " & oLine.EndSketchPoint.Geometry.Y
            Debug.Print "  Length: " & oLine.Length
            Debug.Print "  Centerline: " & oLine.Centerline

            ' Toggle the centerline property.
            If oLine.Centerline Then
                oLine.Centerline = False
            Else
                oLine.Centerline = True
            End If
        Case kSketchPointObject
            Dim oPoint As SketchPoint
            Set oPoint = oSketchEnt
            Debug.Print "Sketch Point selected."
            Debug.Print "  Position: " & oPoint.Geometry.X & _
                            ", " & oPoint.Geometry.Y
            Debug.Print "  Hole Center: " & oPoint.HoleCenter

            ' Toggle the hole center property.
            If oPoint.HoleCenter Then
                oPoint.HoleCenter = False
            Else
                oPoint.HoleCenter = True
            End If
        Case kSketchSplineObject
            Dim oSpline As SketchSpline
            Set oSpline = oSketchEnt
            Debug.Print "Sketch Spline selected."
            Debug.Print "  Length: " & oSpline.Length
            Debug.Print "  Closed: " & oSpline.Closed
            Debug.Print "  Fit Points (" & oSpline.FitPointCount & ")"
            Dim i As Long
            For i = 1 To oSpline.FitPointCount
                Debug.Print "    Fit Point " & i & ": " & oSpline.FitPoint(i).Geometry.X & _
                            ", " & oSpline.FitPoint(i).Geometry.Y
            Next
    End Select

    ' Call the generic sketch entity methods.
    Debug.Print "  Constraint count: " & oSketchEnt.Constraints.Count
    Debug.Print "  Construction: " & oSketchEnt.Construction
    Debug.Print "  Range: (" & oSketchEnt.RangeBox.MinPoint.X & ", " & _
                            oSketchEnt.RangeBox.MinPoint.Y & ") - (" & _
                            oSketchEnt.RangeBox.MaxPoint.X & ", " & _
                            oSketchEnt.RangeBox.MaxPoint.Y & ")"
    Debug.Print "  Reference: " & oSketchEnt.Reference
    If oSketchEnt.Reference Then
        Debug.Print "  Referenced Entity: " & TypeName(oSketchEnt.ReferencedEntity)
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface


SketchEntity Methods

SketchEntity Methods
Summary

The methods of the SketchEntity class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the sketch entity. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Methods


SketchEntity.Delete Method

SketchEntity.Delete Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that deletes the sketch entity. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Methods > SketchEntity.Delete Method


SketchEntity.GetReferenceKey Method

SketchEntity.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Methods > SketchEntity.GetReferenceKey Method


SketchEntity Properties

SketchEntity Properties
Summary

The properties of the SketchEntity class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Constraints | Property that returns a collection of sketch constraints that are tied directly to this entity. This collection consists of both geometric and dimension constraints.
ConstraintStatus |
Construction | Property that gets and sets whether the entity behaves as a construction entity or not. Construction entities are ignored when creating profiles.
ContainingSketchBlock | Property that returns the sketch block that contains this object. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this object does not belong to a sketch block and lives directly under a sketch.
DisabledActionTypes | Gets and sets the action types valid for this Sketch entity.
HasReferenceComponent | Property that specifies if the object was created as the result of a derived part. This property returns True in the case where the object is from a derived part. In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case.
Layer | Property that gets and sets the layer associated with this object.
OwnedBy | Indicates entity or entities that own this object.
Parent | Property that returns the parent sketch of the entity.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Reference | Property that gets and sets whether this entity is a reference entity or not.
ReferenceComponent | Property that returns the ReferenceComponent that this feature was created as the result of. If the SketchEntity belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.
ReferencedEntity | Property that returns the object this entity is dependent on. When sketch entities are created by projecting model edges or intersecting the model, the resulting entities are driven by the original model entities and cannot be modified.
SketchBlockPath | Property that returns the path of sketch blocks at the leaf of which this sketch object is found. The enumerator returns a count of 0 if the object lives directly under a sketch.
SketchOnly | Gets and sets whether this entity is visible only when editing the sketch.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties


SketchEntity.Application Property

SketchEntity.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Application Property


SketchEntity.AttributeSets Property

SketchEntity.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.AttributeSets Property


SketchEntity.Constraints Property

SketchEntity.Constraints Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a collection of sketch constraints that are tied directly to this entity. This collection consists of both geometric and dimension constraints.

Visual Basic
Property Constraints() As SketchConstraintsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Constraints Property


SketchEntity.ConstraintStatus Property

SketchEntity.ConstraintStatus Property Available in Inventor Available in Server Introduced in Inventor 10
Visual Basic
Property ConstraintStatus() As ConstraintStatusEnum*
Notes

For information on this item, please refer to Sketch::ConstraintStatus, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.ConstraintStatus Property


SketchEntity.Construction Property

SketchEntity.Construction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the entity behaves as a construction entity or not. Construction entities are ignored when creating profiles.

Visual Basic
Property Construction() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Construction Property


SketchEntity.ContainingSketchBlock Property

SketchEntity.ContainingSketchBlock Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketch block that contains this object. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this object does not belong to a sketch block and lives directly under a sketch.

Visual Basic
Property ContainingSketchBlock() As SketchBlock**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.ContainingSketchBlock Property


SketchEntity.DisabledActionTypes Property

SketchEntity.DisabledActionTypes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the action types valid for this Sketch entity.

Visual Basic
Property DisabledActionTypes() As ActionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.DisabledActionTypes Property


SketchEntity.HasReferenceComponent Property

SketchEntity.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies if the object was created as the result of a derived part. This property returns True in the case where the object is from a derived part. In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.HasReferenceComponent Property


SketchEntity.Layer Property

SketchEntity.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Layer Property


SketchEntity.OwnedBy Property

SketchEntity.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Indicates entity or entities that own this object.

Visual Basic
Property OwnedBy() As SketchEntitiesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.OwnedBy Property


SketchEntity.Parent Property

SketchEntity.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent sketch of the entity.

Visual Basic
Property Parent() As Sketch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Parent Property


SketchEntity.RangeBox Property

SketchEntity.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.RangeBox Property


SketchEntity.Reference Property

SketchEntity.Reference Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether this entity is a reference entity or not.

Visual Basic
Property Reference() As VARIANT_BOOL
Remarks

Reference sketch entities are created by projecting model edges or surface silhouettes onto the sketch, or by intersecting the model with the sketch plane. The model entity that the sketch entity is derived from can be obtained using the ReferencedEntity property.

It is only valid to set this property to False. This removes the dependence of the sketch entity from the model entity and makes it a standard sketch entity. You cannot convert a non-reference sketch entity into a reference sketch entity.

If it is a reference entity, there are certain limitations. Any method or property that requires the entity to change are invalid. For example, you cannot move any of the sketch points positioning the entity. You also cannot add any constraints that would require it to modify. However, constraints are valid when they are tying another entity to this one.

See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Reference Property


SketchEntity.ReferenceComponent Property

SketchEntity.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponent that this feature was created as the result of. If the SketchEntity belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.ReferenceComponent Property


SketchEntity.ReferencedEntity Property

SketchEntity.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the object this entity is dependent on. When sketch entities are created by projecting model edges or intersecting the model, the resulting entities are driven by the original model entities and cannot be modified.

Visual Basic
Property ReferencedEntity() As IDispatch**
Remarks

This property returns the model entity the sketch entity is dependent on. The Reference property indicates whether the sketch entity is driven by a model entity or not. If the sketch entity is not referencing a model entity, this property will return Nothing. This property can also return nothing even when the sketch entity is referencing a model entity in the case where the model entity has been consumed by some subsequent modeling operation.

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.ReferencedEntity Property


SketchEntity.SketchBlockPath Property

SketchEntity.SketchBlockPath Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the path of sketch blocks at the leaf of which this sketch object is found. The enumerator returns a count of 0 if the object lives directly under a sketch.

Visual Basic
Property SketchBlockPath() As SketchBlocksEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.SketchBlockPath Property


SketchEntity.SketchOnly Property

SketchEntity.SketchOnly Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets and sets whether this entity is visible only when editing the sketch.

Visual Basic
Property SketchOnly() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.SketchOnly Property


SketchEntity.Type Property

SketchEntity.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity Interface > SketchEntity Properties > SketchEntity.Type Property


SketchEntity3D Interface

SketchEntity3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchEntity object is the base class for all geometric sketch entities. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchArc3D
    Inventor::SketchCircle3D
    Inventor::SketchEllipse3D
    Inventor::SketchEllipticalArc3D
    Inventor::SketchFixedSpline3D
    Inventor::SketchLine3D
    Inventor::SketchPoint3D
    Inventor::SketchSpline3D
Visual Basic
Public Interface SketchEntity3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CustomConstraint3D.Entity

ProfileEntity3D.SketchEntity

RadiusDimConstraint3D.Entity

Sketch3D.Include

SketchEntities3DEnumerator.Item

SmoothConstraint3D.EntityOne

SmoothConstraint3D.EntityTwo

TangentConstraint3D.EntityOne

TangentConstraint3D.EntityTwo

PathEntity.SketchEntity

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface


SketchEntity3D Methods

SketchEntity3D Methods
Summary

The methods of the SketchEntity3D class are listed here.

Methods
Methods
Name | Description
AssociativeID | Property that returns the associative ID for this entity. The associative ID identifies this entity and is used to maintain associativity with downstream constructions.
Delete | Method that deletes the sketch entity.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Methods


SketchEntity3D.AssociativeID Method

SketchEntity3D.AssociativeID Method Available in Inventor Available in Server
Summary

Property that returns the associative ID for this entity. The associative ID identifies this entity and is used to maintain associativity with downstream constructions.

Visual Basic
Sub AssociativeID(Result As [out, retval] long)
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Methods > SketchEntity3D.AssociativeID Method


SketchEntity3D.Delete Method

SketchEntity3D.Delete Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that deletes the sketch entity.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Methods > SketchEntity3D.Delete Method


SketchEntity3D.GetReferenceKey Method

SketchEntity3D.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Methods > SketchEntity3D.GetReferenceKey Method


SketchEntity3D Properties

SketchEntity3D Properties
Summary

The properties of the SketchEntity3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Constraints3D | Property that returns a collection of sketch constraints that are tied directly to this entity. This collection consists of geometric and bend constraints.
ConstraintStatus | Property that returns an enum indicating the constraint status of the sketch entity, signifying whether it is fully constrained, over constrained, or under constrained.
Construction | Property that gets and sets whether the entity behaves as a construction entity or not. Construction entities are ignored when creating profiles.
HasReferenceComponent | Property that gets the option indicating if the sketch has a reference component . Currently this property always returns False; it was implemented to support future functionality.
OwnedBy | Property indicating entity or entities that own this object.
Parent | Property that returns the parent sketch of the entity.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Reference | Property that gets and sets whether this entity is a reference entity or not
ReferenceComponent | Property that gets the reference component. Currently this property always returns 'Nothing'; it was implemented to support future functionality.
ReferencedEntity | Property that returns the object this entity is dependent on. When sketch entities are created by projecting model edges or intersecting the model, the resulting entities are driven by the original model entities and cannot be modified. This property returns the model entity the sketch entity is dependent on. The Reference property indicates whether the sketch entity is driven by a model entity or not. If the sketch entity is not referencing a model entity, this property will return Nothing. This property can also return nothing even when the sketch entity is referencing a model entity in the case where... more
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties


SketchEntity3D.Application Property

SketchEntity3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.Application Property


SketchEntity3D.AttributeSets Property

SketchEntity3D.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.AttributeSets Property


SketchEntity3D.Constraints3D Property

SketchEntity3D.Constraints3D Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns a collection of sketch constraints that are tied directly to this entity. This collection consists of geometric and bend constraints.

Visual Basic
Property Constraints3D() As SketchConstraints3DEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.Constraints3D Property


SketchEntity3D.ConstraintStatus Property

SketchEntity3D.ConstraintStatus Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns an enum indicating the constraint status of the sketch entity, signifying whether it is fully constrained, over constrained, or under constrained.

Visual Basic
Property ConstraintStatus() As ConstraintStatusEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.ConstraintStatus Property


SketchEntity3D.Construction Property

SketchEntity3D.Construction Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the entity behaves as a construction entity or not. Construction entities are ignored when creating profiles.

Visual Basic
Property Construction() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.Construction Property


SketchEntity3D.HasReferenceComponent Property

SketchEntity3D.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the option indicating if the sketch has a reference component . Currently this property always returns False; it was implemented to support future functionality.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.HasReferenceComponent Property


SketchEntity3D.OwnedBy Property

SketchEntity3D.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property indicating entity or entities that own this object.

Visual Basic
Property OwnedBy() As SketchEntities3DEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.OwnedBy Property


SketchEntity3D.Parent Property

SketchEntity3D.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent sketch of the entity.

Visual Basic
Property Parent() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.Parent Property


SketchEntity3D.RangeBox Property

SketchEntity3D.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.RangeBox Property


SketchEntity3D.Reference Property

SketchEntity3D.Reference Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that gets and sets whether this entity is a reference entity or not

Visual Basic
Property Reference() As VARIANT_BOOL
Remarks

Reference sketch entities are created by projecting model edges onto the 3D sketch. The model entity that the sketch entity is derived from can be obtained using the ReferencedEntity property.

It is only valid to set this property to False. This removes the dependence of the sketch entity from the model entity and makes it a standard sketch entity. You cannot convert a non-reference sketch entity into a reference sketch entity.

If it is a reference entity, there are certain limitations. Any method or property that requires the entity to change are invalid. For example, you cannot move any of the sketch points positioning the entity. You also cannot add any constraints that would require it to modify. However, constraints are valid when they are tying another entity to this one.

You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.Reference Property


SketchEntity3D.ReferenceComponent Property

SketchEntity3D.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets the reference component. Currently this property always returns 'Nothing'; it was implemented to support future functionality.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.ReferenceComponent Property


SketchEntity3D.ReferencedEntity Property

SketchEntity3D.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns the object this entity is dependent on. When sketch entities are created by projecting model edges or intersecting the model, the resulting entities are driven by the original model entities and cannot be modified. This property returns the model entity the sketch entity is dependent on. The Reference property indicates whether the sketch entity is driven by a model entity or not. If the sketch entity is not referencing a model entity, this property will return Nothing. This property can also return nothing even when the sketch entity is referencing a model entity in the case where the model entity has been consumed by some subsequent modeling operation.

Visual Basic
Property ReferencedEntity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.ReferencedEntity Property


SketchEntity3D.Type Property

SketchEntity3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEntity3D Interface > SketchEntity3D Properties > SketchEntity3D.Type Property


Sketches3D Interface

Sketches3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

Provides access to all of the objects owned by a particular PartComponentDefinition. See the article in the overviews section.

Class Hierarchy
Inventor::Sketches3D
Visual Basic
Public Interface Sketches3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

FlatPattern.Sketches3D

PartComponentDefinition.Sketches3D

You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface


Sketches3D Methods

Sketches3D Methods
Summary

The methods of the Sketches3D class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new 3D sketch.
Item | Property that returns the specified Sketch3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Methods


Sketches3D.Add Method

Sketches3D.Add Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new 3D sketch.

Visual Basic
Sub Add(Result As [out, retval] Sketch3D*)
See Also

Sweep Feature Add sample

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Methods > Sketches3D.Add Method


Sketches3D.Item Method

Sketches3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified Sketch3D object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Sketch3D*)
Parameters
Parameters | Description
index | Input Variant value that specifies the 3D sketch to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the 3D sketch name. If an out-of-range index or a name of a non-existent sketch is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Methods > Sketches3D.Item Method


Sketches3D Properties

Sketches3D Properties
Summary

The properties of the Sketches3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Properties


Sketches3D.Application Property

Sketches3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Properties > Sketches3D.Application Property


Sketches3D.Count Property

Sketches3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Properties > Sketches3D.Count Property


Sketches3D.Type Property

Sketches3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketches3D Interface > Sketches3D Properties > Sketches3D.Type Property


Sketches3DEnumerator Interface

Sketches3DEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The Sketches3DEnumerator allows iteration of available Sketch3D objects.

Class Hierarchy
Inventor::Sketches3DEnumerator
Visual Basic
Public Interface Sketches3DEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartComponent.Sketches3D

You are here: Symbol Reference > Inventor Library > Objects > Sketches3DEnumerator Interface


Sketches3DEnumerator Methods

Sketches3DEnumerator Methods
Summary

The methods of the Sketches3DEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Sketches3DEnumerator Interface > Sketches3DEnumerator Methods


Sketches3DEnumerator.Item Method

Sketches3DEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Sketch3D*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > Sketches3DEnumerator Interface > Sketches3DEnumerator Methods > Sketches3DEnumerator.Item Method


Sketches3DEnumerator Properties

Sketches3DEnumerator Properties
Summary

The properties of the Sketches3DEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Sketches3DEnumerator Interface > Sketches3DEnumerator Properties


Sketches3DEnumerator.Count Property

Sketches3DEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Sketches3DEnumerator Interface > Sketches3DEnumerator Properties > Sketches3DEnumerator.Count Property


Sketches3DEnumerator.Type Property

Sketches3DEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Sketches3DEnumerator Interface > Sketches3DEnumerator Properties > Sketches3DEnumerator.Type Property


SketchesEnumerator Interface

SketchesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SketchesEnumerator object. See the article in the overviews section.

Class Hierarchy
Inventor::SketchesEnumerator
Visual Basic
Public Interface SketchesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DerivedPartComponent.Sketches

iFeature.Sketches

iFeatureComponent.Sketches

RefoldFeature.InputSketches

RefoldFeature.ResultSketches

UnfoldFeature.InputSketches

UnfoldFeature.ResultSketches

You are here: Symbol Reference > Inventor Library > Objects > SketchesEnumerator Interface


SketchesEnumerator Methods

SketchesEnumerator Methods
Summary

The methods of the SketchesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified Sketch object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchesEnumerator Interface > SketchesEnumerator Methods


SketchesEnumerator.Item Method

SketchesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns the specified Sketch object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] Sketch*)
Parameters
Parameters | Description
index | Value that specifies the index of the Sketch to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchesEnumerator Interface > SketchesEnumerator Methods > SketchesEnumerator.Item Method


SketchesEnumerator Properties

SketchesEnumerator Properties
Summary

The properties of the SketchesEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchesEnumerator Interface > SketchesEnumerator Properties


SketchesEnumerator.Count Property

SketchesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchesEnumerator Interface > SketchesEnumerator Properties > SketchesEnumerator.Count Property


SketchesEnumerator.Type Property

SketchesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchesEnumerator Interface > SketchesEnumerator Properties > SketchesEnumerator.Type Property


SketchEvents CoClass

SketchEvents CoClass Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SketchEvents object provides notification of sketch events including new, changed, solved or deleted sketches.

Class Hierarchy
Inventor::SketchEvents
Visual Basic
Public Class SketchEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.SketchEvents

You are here: Symbol Reference > Inventor Library > Objects > SketchEvents CoClass


SketchEventsObject Interface

SketchEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SketchEvents object provides notification of sketch events including new, changed, solved or deleted sketches.

Class Hierarchy
Inventor::SketchEventsObject
Visual Basic
Public Interface SketchEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.SketchEvents

You are here: Symbol Reference > Inventor Library > Objects > SketchEventsObject Interface


SketchEventsObject Properties

SketchEventsObject Properties
Summary

The properties of the SketchEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning kSketchEventsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsObject Interface > SketchEventsObject Properties


SketchEventsObject.Application Property

SketchEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsObject Interface > SketchEventsObject Properties > SketchEventsObject.Application Property


SketchEventsObject.Parent Property

SketchEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsObject Interface > SketchEventsObject Properties > SketchEventsObject.Parent Property


SketchEventsObject.Type Property

SketchEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kSketchEventsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsObject Interface > SketchEventsObject Properties > SketchEventsObject.Type Property


SketchEventsSink Interface

SketchEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SketchEvents object provides notification of sketch events including new, changed, solved or deleted sketches.

Class Hierarchy
Inventor::SketchEventsSink
Visual Basic
Public Interface SketchEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.SketchEvents

You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface


SketchEventsSink Methods

SketchEventsSink Methods
Summary

The methods of the SketchEventsSink class are listed here.

Methods
Methods
Name | Description
OnDelete | The OnDelete event notifies the client when a 2d or 3d sketch is being deleted. This notification is not sent when the contents of the sketch is deleted, but only when the sketch itself is deleted.
OnNewSketch | Event that is fired whenever a sketch is created.
OnNewSketch3D | The OnNewSketch3D event notifies the client when a new 3D sketch is being created.
OnSketch3DChange | The OnSketch3DChange event notifies the client when the geometry of a 3D sketch is changed.
OnSketch3DSolve | Event that is fired whenever a 3D sketch is created.
OnSketchChange | The OnSketchChange event notifies the client when the geometry of a 2D sketch is changed.
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods


SketchEventsSink.OnDelete Method

SketchEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnDelete event notifies the client when a 2d or 3d sketch is being deleted. This notification is not sent when the contents of the sketch is deleted, but only when the sketch itself is deleted.

Visual Basic
Sub OnDelete(DocumentObject As Document, Entity As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters
Description
DocumentObject
The Document object that contains the sketch.
Entity
The sketch that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the entity provided is the sketch before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example: Private m_oDeletedSketch As Object Private Sub oSketchEvents_OnDelete( ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...) If BeforeOrAfter = kBefore Then ' Somehow Check to see if the sketch being deleted is an interesting one. ' For example, it could have an attribute attached to it to identify it. If Interesting(Entity) Then ' Save a reference to the object. Set m_ oDeletedSketch = Entity End If Else ' Now we're either after the delete or it's been aborted. ' Check to see if the sketch is the interesting one. If Entity is m_ oDeletedSketch Then If BeforeOrAfter = kAfter then ' The sketch was deleted. ElseIf BeforeOrAfter = kAbort Then ' The delete was aborted. End If End If End Sub
BeforeOrAfter
Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the sketch is deleted.
Context
Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode
Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods > SketchEventsSink.OnDelete Method


SketchEventsSink.OnNewSketch Method

SketchEventsSink.OnNewSketch Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever a sketch is created.

Visual Basic
Sub OnNewSketch(DocumentObject As Document, Sketch As Sketch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Sketch | Input PlanarSketch or a DrawingSketch object that was just created. Nothing in the kBefore case.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the sketch is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods > SketchEventsSink.OnNewSketch Method


SketchEventsSink.OnNewSketch3D Method

SketchEventsSink.OnNewSketch3D Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnNewSketch3D event notifies the client when a new 3D sketch is being created.

Visual Basic
Sub OnNewSketch3D(DocumentObject As Document, Sketch3D As Sketch3D, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the new 3D sketch is being created within.
Sketch3D | The new 3D sketch just created. When the BeforeOrAfter argument is kBefore, the value of this argument is Nothing since the sketch has not yet been created.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the sketch is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods > SketchEventsSink.OnNewSketch3D Method


SketchEventsSink.OnSketch3DChange Method

SketchEventsSink.OnSketch3DChange Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnSketch3DChange event notifies the client when the geometry of a 3D sketch is changed.

Visual Basic
Sub OnSketch3DChange(DocumentObject As Document, Sketch3D As Sketch3D, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the 3D sketch is within.
Sketch3D | The 3D sketch that is changing.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the sketch is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Sketch changes that fire this event include adding new geometry, modifying existing geometry either directly or indirectly by editing dimension constraints, deleting geometry, and placing or deleting constraints where it will cause a change in any geometry. For example, placing a perpendicular constraint between two lines will cause this notification to be sent if the orientation of the lines needs to be changed to make them perpendicular. If the lines are already positioned perpendicular to one another, adding the constraint will not cause this notification to fire since the geometry does not change. Deleting the constraint does not cause the notification to be sent since the geometry is not changed as a result. Adding dimension constraints does not change the geometry so it does not result in this notification being sent, but editing the value of the dimension does modify the geometry and will result in this notification being sent.

You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods > SketchEventsSink.OnSketch3DChange Method


SketchEventsSink.OnSketch3DSolve Method

SketchEventsSink.OnSketch3DSolve Method Available in Inventor Available in Server
Summary

Event that is fired whenever a 3D sketch is created.

Visual Basic
Sub OnSketch3DSolve(DocumentObject As Document, Sketch As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Sketch | Input Sketch3D object that was just created. Nothing in the kBefore case.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the sketch is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods > SketchEventsSink.OnSketch3DSolve Method


SketchEventsSink.OnSketchChange Method

SketchEventsSink.OnSketchChange Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

The OnSketchChange event notifies the client when the geometry of a 2D sketch is changed.

Visual Basic
Sub OnSketchChange(DocumentObject As Document, Sketch As Sketch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | The Document object the 3D sketch is within.
Sketch | PlanarSketch or a DrawingSketch object that is changing.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the sketch is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Sketch changes that fire this event include adding new geometry, modifying existing geometry either directly or indirectly by editing dimension constraints, deleting geometry, and placing or deleting constraints where it will cause a change in any geometry. For example, placing a perpendicular constraint between two lines will cause this notification to be sent if the orientation of the lines needs to be changed to make them perpendicular. If the lines are already positioned perpendicular to one another, adding the constraint will not cause this notification to fire since the geometry does not change. Deleting the constraint does not cause the notification to be sent since the geometry is not changed as a result. Adding dimension constraints does not change the geometry so it does not result in this notification being sent, but editing the value of the dimension does modify the geometry and will result in this notification being sent.

You are here: Symbol Reference > Inventor Library > Objects > SketchEventsSink Interface > SketchEventsSink Methods > SketchEventsSink.OnSketchChange Method


SketchFillRegion Interface

SketchFillRegion Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

An object representing a color-filled region in a drawing sketch.

Class Hierarchy
Inventor::SketchFillRegion
Visual Basic
Public Interface SketchFillRegion
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SketchFillRegions.Add

SketchFillRegions.Item

Example

See DrawingSketch::SketchFillRegions for example "SketchFillRegions Property"

You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface


SketchFillRegion Methods

SketchFillRegion Methods
Summary

The methods of the SketchFillRegion class are listed here.

Methods
Methods
Name | Description
Delete | Method to delete this SketchFillRegion object.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Methods


SketchFillRegion.Delete Method

SketchFillRegion.Delete Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method to delete this SketchFillRegion object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Methods > SketchFillRegion.Delete Method


SketchFillRegion.GetReferenceKey Method

SketchFillRegion.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Methods > SketchFillRegion.GetReferenceKey Method


SketchFillRegion Properties

SketchFillRegion Properties
Summary

The properties of the SketchFillRegion class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Color | Gets and sets the color of the sketch fill region.
Parent | Property that gets the parent object from whom this object can logically be reached.
Profile | Property to gets the profile object associated with this sketch fill region.
Type | Property returning an indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties


SketchFillRegion.Application Property

SketchFillRegion.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties > SketchFillRegion.Application Property


SketchFillRegion.AttributeSets Property

SketchFillRegion.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties > SketchFillRegion.AttributeSets Property


SketchFillRegion.Color Property

SketchFillRegion.Color Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets and sets the color of the sketch fill region.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties > SketchFillRegion.Color Property


SketchFillRegion.Parent Property

SketchFillRegion.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Sketch**
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties > SketchFillRegion.Parent Property


SketchFillRegion.Profile Property

SketchFillRegion.Profile Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property to gets the profile object associated with this sketch fill region.

Visual Basic
Property Profile() As Profile**
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties > SketchFillRegion.Profile Property


SketchFillRegion.Type Property

SketchFillRegion.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegion Interface > SketchFillRegion Properties > SketchFillRegion.Type Property


SketchFillRegions Interface

SketchFillRegions Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

A collection of SketchFillRegion objects.

Class Hierarchy
Inventor::SketchFillRegions
Visual Basic
Public Interface SketchFillRegions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingSketch.SketchFillRegions

Example

See DrawingSketch::SketchFillRegions for example "SketchFillRegions Property"

You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface


SketchFillRegions Methods

SketchFillRegions Methods
Summary

The methods of the SketchFillRegions class are listed here.

Methods
Methods
Name | Description
Add | Method to add a SketchFillRegion object to the collection.
Item | Method that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Methods


SketchFillRegions.Add Method

SketchFillRegions.Add Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method to add a SketchFillRegion object to the collection.

Visual Basic
Sub Add(Profile As Profile, ByRef Color As [optional] VARIANT, Result As [out, retval] SketchFillRegion*)
Parameters
Parameters | Description
Profile | The Profile object to use for this region.
Color | The color for this SketchFillRegion.
See Also

Sketch fill region sample

You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Methods > SketchFillRegions.Add Method


SketchFillRegions.Item Method

SketchFillRegions.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchFillRegion*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Methods > SketchFillRegions.Item Method


SketchFillRegions Properties

SketchFillRegions Properties
Summary

The properties of the SketchFillRegions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Properties


SketchFillRegions.Application Property

SketchFillRegions.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Properties > SketchFillRegions.Application Property


SketchFillRegions.Count Property

SketchFillRegions.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Properties > SketchFillRegions.Count Property


SketchFillRegions.Type Property

SketchFillRegions.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchFillRegions Interface > SketchFillRegions Properties > SketchFillRegions.Type Property


SketchFixedSpline Interface

SketchFixedSpline Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SketchFixedSpline object represents a fixed spline within a sketch. These splines are created using the geometry definition (BSplineCurve2d). See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchFixedSpline
        Inventor::SketchFixedSplineProxy
Visual Basic
Public Interface SketchFixedSpline
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

SketchFixedSplineProxy.NativeObject

SketchFixedSplines.Add

SketchFixedSplines.Item

Example

"Spline - create NURBS Example"

This sample demonstrates the creation of a sketch spline using a geometry definition (a NURB). The API also supports creation of 3D sketch splines in a similar way.

Have a part document open and run the following sample.

Public Sub SplineByDefinition()

    ' Set a reference to the part component definition.
    ' This assumes that a part document is active.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Set a reference to the transient geometry collection.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create the collection that will contain the fit points for the regular spline.
    Dim oFitPoints As ObjectCollection
    Set oFitPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Define the points to fit the spline through. The
    ' points are at (0,0), (2,2), (4,0), (6,4).
    Dim oPoints(1 To 4) As Point2d
    Set oPoints(1) = oTransGeom.CreatePoint2d(0, 0)
    oFitPoints.Add oPoints(1)

    Set oPoints(2) = oTransGeom.CreatePoint2d(2, 2)
    oFitPoints.Add oPoints(2)

    Set oPoints(3) = oTransGeom.CreatePoint2d(4, 0)
    oFitPoints.Add oPoints(3)

    Set oPoints(4) = oTransGeom.CreatePoint2d(6, 4)
    oFitPoints.Add oPoints(4)

    'Create the first sketch on the X-Y plane
    Dim oSketch1 As PlanarSketch
    Set oSketch1 = oCompDef.Sketches.Add(oCompDef.WorkPlanes(3))

    ' Create the spline.
    Dim oSpline As SketchSpline
    Set oSpline = oSketch1.SketchSplines.Add(oFitPoints)

    ' Create a work plane parallel to X-Y plane.
    Dim oWorkPlane As WorkPlane
    Set oWorkPlane = oCompDef.WorkPlanes.AddByPlaneAndOffset(oCompDef.WorkPlanes(3), 2)

    'Create the second sketch.
    Dim oSketch2 As PlanarSketch
    Set oSketch2 = oCompDef.Sketches.Add(oWorkPlane)

    ' Set a reference to the geometry of the spline on the first sketch
    Dim oBSplineCurve2d As BSplineCurve2d
    Set oBSplineCurve2d = oSpline.Geometry

    ' Create a fixed spline on the second sketch based
    ' on the geometry of the spline on the first sketch.
    Dim oFixedSpline As SketchFixedSpline
    Set oFixedSpline = oSketch2.SketchFixedSplines.Add(oBSplineCurve2d)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface


SketchFixedSpline Methods

SketchFixedSpline Methods
Summary

The methods of the SketchFixedSpline class are listed here.

Methods
Methods
Name | Description
ConvertToSpline | Method that converts the fixed spline to a SketchSpline object.
Edit | Method that edits a fixed sketch spline based on an input NURBS definition.
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Methods


SketchFixedSpline.ConvertToSpline Method

SketchFixedSpline.ConvertToSpline Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that converts the fixed spline to a SketchSpline object.

Visual Basic
Sub ConvertToSpline(Result As [out, retval] SketchSpline*)
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Methods > SketchFixedSpline.ConvertToSpline Method


SketchFixedSpline.Edit Method

SketchFixedSpline.Edit Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that edits a fixed sketch spline based on an input NURBS definition.

Visual Basic
Sub Edit(SplineCurve As BSplineCurve2d, ByRef StartPoint As [optional] VARIANT, ByRef EndPoint As [optional] VARIANT)
Parameters
Parameters | Description
SplineCurve | Input BSplineCurve2d geometry object that contains the definition of a curve that will be used to redefine the spline.
StartPoint | Optional input SketchPoint object that contains the start point to fit the curve through. If this argument is not specified, a sketch point is created at the point defined by the start point of the input BSplineCurve2d and the resulting spline is constrained to it.
EndPoint | Optional input SketchPoint that contains the end point to fit the curve through. If this argument is not specified, a sketch point is created at the point defined by the end point of the input BSplineCurve2d and the resulting spline is constrained to it.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Methods > SketchFixedSpline.Edit Method


SketchFixedSpline.GetCustomLineType Method

SketchFixedSpline.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Methods > SketchFixedSpline.GetCustomLineType Method


SketchFixedSpline.SetCustomLineType Method

SketchFixedSpline.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Methods > SketchFixedSpline.SetCustomLineType Method


SketchFixedSpline Properties

SketchFixedSpline Properties
Summary

The properties of the SketchFixedSpline class are listed here.

Properties
Name | Description
Closed | Boolean property that gets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.
EndSketchPoint | Property that returns the that defines the position of the end of the spline.
Geometry | Property that returns a geometry object. The object returned represents a 'snapshot' view of the current state of the fixed sketch spline.
Length | Double property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
OverrideColor | Gets and sets the color applied to this primitive.
StartSketchPoint | Property that returns the that defines the position of the start of the spline.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties


SketchFixedSpline.Closed Property

SketchFixedSpline.Closed Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Boolean property that gets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.

Visual Basic
Property Closed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.Closed Property


SketchFixedSpline.EndSketchPoint Property

SketchFixedSpline.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that defines the position of the end of the spline.

Visual Basic
Property EndSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.EndSketchPoint Property


SketchFixedSpline.Geometry Property

SketchFixedSpline.Geometry Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a geometry object. The object returned represents a 'snapshot' view of the current state of the fixed sketch spline.

Visual Basic
Property Geometry() As BSplineCurve2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.Geometry Property


SketchFixedSpline.Length Property

SketchFixedSpline.Length Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.Length Property


SketchFixedSpline.LineDefinitionSpace Property

SketchFixedSpline.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.LineDefinitionSpace Property


SketchFixedSpline.LineScale Property

SketchFixedSpline.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.LineScale Property


SketchFixedSpline.LineType Property

SketchFixedSpline.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.LineType Property


SketchFixedSpline.LineWeight Property

SketchFixedSpline.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.LineWeight Property


SketchFixedSpline.OverrideColor Property

SketchFixedSpline.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.OverrideColor Property


SketchFixedSpline.StartSketchPoint Property

SketchFixedSpline.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that defines the position of the start of the spline.

Visual Basic
Property StartSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline Interface > SketchFixedSpline Properties > SketchFixedSpline.StartSketchPoint Property


SketchFixedSpline3D Interface

SketchFixedSpline3D Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SketchFixedSpline3D object represents a fixed spline within a sketch. These splines are created using the geometry definition (BSplineCurve). See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchFixedSpline3D
        Inventor::SketchFixedSpline3DProxy
Visual Basic
Public Interface SketchFixedSpline3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

SketchFixedSpline3DProxy.NativeObject

SketchFixedSplines3D.Add

SketchFixedSplines3D.AddByEdge

SketchFixedSplines3D.Item

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface


SketchFixedSpline3D Methods

SketchFixedSpline3D Methods
Summary

The methods of the SketchFixedSpline3D class are listed here.

Methods
Methods
Name | Description
ConvertToSpline | Method that converts the fixed spline to a SketchSpline3D object. This method is currently only valid for SketchFixedSpline3D objects that were created using a BSplineCurve as input.
Edit | Method that edits a fixed sketch spline based on an input NURBS definition. This method is only valid for SketchFixedSpline3D objects that were created using a BSplineCurve as input. This method will fail if the curve was created with an Edge.
EditByEdge | Method that edits the geometry of a fixed sketch spline based on an input transient Edge.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Methods


SketchFixedSpline3D.ConvertToSpline Method

SketchFixedSpline3D.ConvertToSpline Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that converts the fixed spline to a SketchSpline3D object. This method is currently only valid for SketchFixedSpline3D objects that were created using a BSplineCurve as input.

Visual Basic
Sub ConvertToSpline(Result As [out, retval] SketchSpline3D*)
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Methods > SketchFixedSpline3D.ConvertToSpline Method


SketchFixedSpline3D.Edit Method

SketchFixedSpline3D.Edit Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that edits a fixed sketch spline based on an input NURBS definition. This method is only valid for SketchFixedSpline3D objects that were created using a BSplineCurve as input. This method will fail if the curve was created with an Edge.

Visual Basic
Sub Edit(SplineCurve As BSplineCurve, ByRef StartPoint As [optional] VARIANT, ByRef EndPoint As [optional] VARIANT)
Parameters
Parameters | Description
SplineCurve | Input BSplineCurve geometry object that contains the definition of a curve that will be used to redefine the spline.
StartPoint | Optional input Object that contains the start point to fit the curve through. The point can be either an existing SketchPoint3D object, a SketchPoint object, a workpoint or vertex. If the input is not a SketchPoint3D object, a SketchPoint3D object is automatically created at the position of the input point. If the argument is not supplied, a SketchPoint3D object is automatically created at the position of the start point of the input BSplineCurve.
EndPoint | Optional input Object that contains the end point to fit the curve through. The point can be either an existing SketchPoint3D object, a SketchPoint object, a workpoint or vertex. If the input is not a SketchPoint3D object, a SketchPoint3D object is automatically created at the position of the input point. If the argument is not supplied, a SketchPoint3D object is automatically created at the position of the end point of the input BSplineCurve.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Methods > SketchFixedSpline3D.Edit Method


SketchFixedSpline3D.EditByEdge Method

SketchFixedSpline3D.EditByEdge Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that edits the geometry of a fixed sketch spline based on an input transient Edge.

Visual Basic
Sub EditByEdge(TransientEdge As Edge)
Parameters
Parameters | Description
TransientEdge | Input transient Edge object.
Remarks

This method is only valid for SketchFixedSpline3D objects that were created using the AddWithEdge method. The SketchFixedSpline3D object will be updated to reflect the geometry defined by this new Edge. This method will fail if the curve was created using the Add method with a BsplineCurve. This can be determined by checking the IsDefinedByEdge property.

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Methods > SketchFixedSpline3D.EditByEdge Method


SketchFixedSpline3D Properties

SketchFixedSpline3D Properties
Summary

The properties of the SketchFixedSpline3D class are listed here.

Properties
Name | Description
Closed | Boolean property that gets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.
EndSketchPoint | Property that returns the that defines the position of the end of the spline.
Geometry | Property that returns a BSplineCurve geometry object. The object returned represents a 'snapshot' view of the current state of the fixed sketch spline. In the case where the SketchFixedSpline3D was created using a transient Edge object this will return a BsplineCurve that is an approximation of the procedural curve defined by the original input Edge object.
IsDefinedByEdge | Property that indicates if this SketchFixedSpline3D object is defined by a BSplineCurve or was created using an Edge as input. Returns True if it was created using an Edge. Returns False if it was created using a BSplineCurve.
Length | Double property that returns the length of the entity in centimeters.
StartSketchPoint | Property that returns the that defines the position of the start of the spline.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties


SketchFixedSpline3D.Closed Property

SketchFixedSpline3D.Closed Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Boolean property that gets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.

Visual Basic
Property Closed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties > SketchFixedSpline3D.Closed Property


SketchFixedSpline3D.EndSketchPoint Property

SketchFixedSpline3D.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that defines the position of the end of the spline.

Visual Basic
Property EndSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties > SketchFixedSpline3D.EndSketchPoint Property


SketchFixedSpline3D.Geometry Property

SketchFixedSpline3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a BSplineCurve geometry object. The object returned represents a 'snapshot' view of the current state of the fixed sketch spline. In the case where the SketchFixedSpline3D was created using a transient Edge object this will return a BsplineCurve that is an approximation of the procedural curve defined by the original input Edge object.

Visual Basic
Property Geometry() As BSplineCurve*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties > SketchFixedSpline3D.Geometry Property


SketchFixedSpline3D.IsDefinedByEdge Property

SketchFixedSpline3D.IsDefinedByEdge Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that indicates if this SketchFixedSpline3D object is defined by a BSplineCurve or was created using an Edge as input. Returns True if it was created using an Edge. Returns False if it was created using a BSplineCurve.

Visual Basic
Property IsDefinedByEdge() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties > SketchFixedSpline3D.IsDefinedByEdge Property


SketchFixedSpline3D.Length Property

SketchFixedSpline3D.Length Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties > SketchFixedSpline3D.Length Property


SketchFixedSpline3D.StartSketchPoint Property

SketchFixedSpline3D.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that defines the position of the start of the spline.

Visual Basic
Property StartSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3D Interface > SketchFixedSpline3D Properties > SketchFixedSpline3D.StartSketchPoint Property


SketchFixedSpline3DProxy Interface

SketchFixedSpline3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchFixedSpline3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchFixedSpline3D
        Inventor::SketchFixedSpline3DProxy
Visual Basic
Public Interface SketchFixedSpline3DProxy
Inherits SketchFixedSpline3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3DProxy Interface


SketchFixedSpline3DProxy Properties

SketchFixedSpline3DProxy Properties
Summary

The properties of the SketchFixedSpline3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3DProxy Interface > SketchFixedSpline3DProxy Properties


SketchFixedSpline3DProxy.ContainingOccurrence Property

SketchFixedSpline3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3DProxy Interface > SketchFixedSpline3DProxy Properties > SketchFixedSpline3DProxy.ContainingOccurrence Property


SketchFixedSpline3DProxy.NativeObject Property

SketchFixedSpline3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchFixedSpline3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSpline3DProxy Interface > SketchFixedSpline3DProxy Properties > SketchFixedSpline3DProxy.NativeObject Property


SketchFixedSplineProxy Interface

SketchFixedSplineProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchFixedSpline object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchFixedSpline
        Inventor::SketchFixedSplineProxy
Visual Basic
Public Interface SketchFixedSplineProxy
Inherits SketchFixedSpline
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplineProxy Interface


SketchFixedSplineProxy Properties

SketchFixedSplineProxy Properties
Summary

The properties of the SketchFixedSplineProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplineProxy Interface > SketchFixedSplineProxy Properties


SketchFixedSplineProxy.ContainingOccurrence Property

SketchFixedSplineProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplineProxy Interface > SketchFixedSplineProxy Properties > SketchFixedSplineProxy.ContainingOccurrence Property


SketchFixedSplineProxy.NativeObject Property

SketchFixedSplineProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchFixedSpline**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplineProxy Interface > SketchFixedSplineProxy Properties > SketchFixedSplineProxy.NativeObject Property


SketchFixedSplines Interface

SketchFixedSplines Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

SketchFixedSplines object provides access to all the objects in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchFixedSplines
Visual Basic
Public Interface SketchFixedSplines
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchFixedSplines

See Also

Spline - create NURBS sample

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface


SketchFixedSplines Methods

SketchFixedSplines Methods
Summary

The methods of the SketchFixedSplines class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a fixed spline based on an input NURBS definition.
Item | Method that returns the specified SketchFixedSpline object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Methods


SketchFixedSplines.Add Method

SketchFixedSplines.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a fixed spline based on an input NURBS definition.

Visual Basic
Sub Add(SplineCurve As BSplineCurve2d, ByRef StartPoint As [optional] VARIANT, ByRef EndPoint As [optional] VARIANT, Result As [out, retval] SketchFixedSpline*)
Parameters
Parameters | Description
SplineCurve | Input BSplineCurve2d geometry object that contains the definition of a curve from which to create a SketchFixedSpline.
StartPoint | Optional input SketchPoint object that contains the start point to fit the curve through. If this argument is not specified, a sketch point is created at the point defined by the start point of the input BSplineCurve2d and the resulting spline is constrained to it.
EndPoint | Optional input SketchPoint that contains the end point to fit the curve through. If this argument is not specified, a sketch point is created at the point defined by the end point of the input BSplineCurve2d and the resulting spline is constrained to it.
See Also

Spline - create NURBS sample

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Methods > SketchFixedSplines.Add Method


SketchFixedSplines.Item Method

SketchFixedSplines.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified SketchFixedSpline object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchFixedSpline*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Methods > SketchFixedSplines.Item Method


SketchFixedSplines Properties

SketchFixedSplines Properties
Summary

The properties of the SketchFixedSplines class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Properties


SketchFixedSplines.Application Property

SketchFixedSplines.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Properties > SketchFixedSplines.Application Property


SketchFixedSplines.Count Property

SketchFixedSplines.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Properties > SketchFixedSplines.Count Property


SketchFixedSplines.Type Property

SketchFixedSplines.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines Interface > SketchFixedSplines Properties > SketchFixedSplines.Type Property


SketchFixedSplines3D Interface

SketchFixedSplines3D Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SketchFixedSplines3D object provides access to all the objects in a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchFixedSplines3D
Visual Basic
Public Interface SketchFixedSplines3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchFixedSplines3D

You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface


SketchFixedSplines3D Methods

SketchFixedSplines3D Methods
Summary

The methods of the SketchFixedSplines3D class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a fixed spline based on an input NURBS definition.
AddByEdge | Method that creates a fixed spline based on an input transient Edge object. This capability is useful because some edges are defined precisely using a procedural algorithm. Converting these to a NURBS curves results in an approximation of the procedural curve. The SketchFixedSpline3D object created with this method has the full accuracy of the procedural curve without any approximation.
Item | Method that returns the specified SketchFixedSpline3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Methods


SketchFixedSplines3D.Add Method

SketchFixedSplines3D.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a fixed spline based on an input NURBS definition.

Visual Basic
Sub Add(SplineCurve As BSplineCurve, ByRef StartPoint As [optional] VARIANT, ByRef EndPoint As [optional] VARIANT, Result As [out, retval] SketchFixedSpline3D*)
Parameters
Parameters | Description
SplineCurve | Input BSplineCurve geometry object that contains the definition of a curve from which to create a SketchFixedSpline3D.
StartPoint | Optional input Object that contains the start point to fit the curve through. The point can be either an existing SketchPoint3D object, a SketchPoint object, a workpoint or vertex. If the input is not a SketchPoint3D object, a SketchPoint3D object is automatically created at the position of the input point. If the argument is not supplied, a SketchPoint3D object is automatically created at the position of the start point of the input BSplineCurve.
EndPoint | Optional input Object that contains the end point to fit the curve through. The point can be either an existing SketchPoint3D object, a SketchPoint object, a workpoint or vertex . If the input is not a SketchPoint3D object, a SketchPoint3D object is automatically created at the position of the input point. If the argument is not supplied, a SketchPoint3D object is automatically created at the position of the end point of the input BSplineCurve.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Methods > SketchFixedSplines3D.Add Method


SketchFixedSplines3D.AddByEdge Method

SketchFixedSplines3D.AddByEdge Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a fixed spline based on an input transient Edge object. This capability is useful because some edges are defined precisely using a procedural algorithm. Converting these to a NURBS curves results in an approximation of the procedural curve. The SketchFixedSpline3D object created with this method has the full accuracy of the procedural curve without any approximation.

Visual Basic
Sub AddByEdge(TransientEdge As Edge, Result As [out, retval] SketchFixedSpline3D*)
Parameters
Parameters | Description
TransientEdge | Input Edge object. The edge must be a transient B-Rep Edge or the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Methods > SketchFixedSplines3D.AddByEdge Method


SketchFixedSplines3D.Item Method

SketchFixedSplines3D.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified SketchFixedSpline3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchFixedSpline3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Methods > SketchFixedSplines3D.Item Method


SketchFixedSplines3D Properties

SketchFixedSplines3D Properties
Summary

The properties of the SketchFixedSplines3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Properties


SketchFixedSplines3D.Application Property

SketchFixedSplines3D.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Properties > SketchFixedSplines3D.Application Property


SketchFixedSplines3D.Count Property

SketchFixedSplines3D.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Properties > SketchFixedSplines3D.Count Property


SketchFixedSplines3D.Type Property

SketchFixedSplines3D.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchFixedSplines3D Interface > SketchFixedSplines3D Properties > SketchFixedSplines3D.Type Property


SketchHolePlacementDefinition Interface

SketchHolePlacementDefinition Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The SketchHolePlacementDefinition object defines the placement of a hole feature using sketch points.

Class Hierarchy
Inventor::HolePlacementDefinition
    Inventor::SketchHolePlacementDefinition
Visual Basic
Public Interface SketchHolePlacementDefinition
Inherits HolePlacementDefinition
Notes

Members through which this object may be accessed include:

HoleFeatures.CreateSketchPlacementDefinition

You are here: Symbol Reference > Inventor Library > Objects > SketchHolePlacementDefinition Interface


SketchHolePlacementDefinition Properties

SketchHolePlacementDefinition Properties
Summary

The properties of the SketchHolePlacementDefinition class are listed here.

Properties
Name | Description
HoleCenterPoints | Property that returns the set of sketch points that define the centers of the holes of this feature.
You are here: Symbol Reference > Inventor Library > Objects > SketchHolePlacementDefinition Interface > SketchHolePlacementDefinition Properties


SketchHolePlacementDefinition.HoleCenterPoints Property

SketchHolePlacementDefinition.HoleCenterPoints Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the set of sketch points that define the centers of the holes of this feature.

Visual Basic
Property HoleCenterPoints() As ObjectCollection*
You are here: Symbol Reference > Inventor Library > Objects > SketchHolePlacementDefinition Interface > SketchHolePlacementDefinition Properties > SketchHolePlacementDefinition.HoleCenterPoints Property


SketchImage Interface

SketchImage Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SketchImage object represents an image within a sketch.

Class Hierarchy
Inventor::SketchImage
    Inventor::SketchImageProxy
Visual Basic
Public Interface SketchImage
Inherits IDispatch
Remarks

The SketchImage object exhibits different behavior depending on whether it is in the drawing environment or the part environment. The table below indicates some key differences.

Property / Method In Drawing In Part

BoundaryGeometry Nothing Has four items (SketchLines)

Height and Width Height and Width are separate The ratio of height/width is constant

Visible Not defined Read-write

Transparent Not defined Read-write

Name Read-only(the FullFileName of the BMP) Read-write

SketchImages.Item Can't use string as the index of Item Can use both integer and string as the index of Item

MirrorHorizontal No support Supported

MirrorVertical No support Supported

RotateLeft No support Supported

RotateRight No support Supported

Update No support Supported

Notes

Members through which this object may be accessed include:

DecalFeature.Image

SketchImageProxy.NativeObject

SketchImages.Add

SketchImages.Item

See Also

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface


SketchImage Methods

SketchImage Methods
Summary

The methods of the SketchImage class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes this object.
GetReferenceKey | Method that generates and returns the reference key for this entity.
MirrorHorizontal | Method that mirrors the image horizontally.
MirrorVertical | Method that mirrors the image vertically.
RotateLeft | Method that rotates the image counter-clockwise by 90 degrees.
RotateRight | Method that rotates the image clockwise by 90 degrees.
Update | Method that updates this image if the linked source file has been modified. This method returns a failure if there is no linked file associated with this image.
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods


SketchImage.Delete Method

SketchImage.Delete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that deletes this object.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.Delete Method


SketchImage.GetReferenceKey Method

SketchImage.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.GetReferenceKey Method


SketchImage.MirrorHorizontal Method

SketchImage.MirrorHorizontal Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that mirrors the image horizontally.

Visual Basic
Sub MirrorHorizontal()
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.MirrorHorizontal Method


SketchImage.MirrorVertical Method

SketchImage.MirrorVertical Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that mirrors the image vertically.

Visual Basic
Sub MirrorVertical()
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.MirrorVertical Method


SketchImage.RotateLeft Method

SketchImage.RotateLeft Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that rotates the image counter-clockwise by 90 degrees.

Visual Basic
Sub RotateLeft()
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.RotateLeft Method


SketchImage.RotateRight Method

SketchImage.RotateRight Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that rotates the image clockwise by 90 degrees.

Visual Basic
Sub RotateRight()
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.RotateRight Method


SketchImage.Update Method

SketchImage.Update Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that updates this image if the linked source file has been modified. This method returns a failure if there is no linked file associated with this image.

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Methods > SketchImage.Update Method


SketchImage Properties

SketchImage Properties
Summary

The properties of the SketchImage class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BoundaryGeometry | Property that returns the four construction sketch lines that form the boundary of the image.
ContainingSketchBlock | Property that returns the sketch block that contains this object. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this object does not belong to a sketch block and lives directly under a sketch.
Height | Property that gets and sets the image height.
Image | This is Image, a member of class SketchImage.
ImageAlpha | This is ImageAlpha, a member of class SketchImage.
LinkedToFile | Property that returns whether this image is linked to the picture file that was used to create this image.
Name | Property that indicates the name of this object or instance.
Parent | Property that returns the parent sketch.
Position | Property that gets and sets the position of the image on the sketch.
ReferencedFileDescriptor | Property that returns the reference to the picture file used to create this image. This property returns Nothing if the source file is not linked (use the LinkedToFile property to determine this).
SketchBlockPath | Property that returns the path of sketch blocks at the leaf of which this sketch object is found. The enumerator returns a count of 0 if the object lives directly under a sketch.
Transparent | Property that gets and sets whether the image is transparent. Transparency color is the color of the lower right pixel of the image.
Type | Property returning kSketchImageObject indicating the type of object.
Visible | Property that gets and sets whether the image is visible.
Width | Property that gets and sets the image width.
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties


SketchImage.Application Property

SketchImage.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Application Property


SketchImage.AttributeSets Property

SketchImage.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.AttributeSets Property


SketchImage.BoundaryGeometry Property

SketchImage.BoundaryGeometry Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the four construction sketch lines that form the boundary of the image.

Visual Basic
Property BoundaryGeometry() As SketchEntitiesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.BoundaryGeometry Property


SketchImage.ContainingSketchBlock Property

SketchImage.ContainingSketchBlock Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketch block that contains this object. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this object does not belong to a sketch block and lives directly under a sketch.

Visual Basic
Property ContainingSketchBlock() As SketchBlock**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.ContainingSketchBlock Property


SketchImage.Height Property

SketchImage.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the image height.

Visual Basic
Property Height() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Height Property


SketchImage.Image Property

SketchImage.Image Property
Summary

This is Image, a member of class SketchImage.

Visual Basic
Property Image() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Image Property


SketchImage.ImageAlpha Property

SketchImage.ImageAlpha Property
Summary

This is ImageAlpha, a member of class SketchImage.

Visual Basic
Property ImageAlpha() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.ImageAlpha Property


SketchImage.LinkedToFile Property

SketchImage.LinkedToFile Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether this image is linked to the picture file that was used to create this image.

Visual Basic
Property LinkedToFile() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.LinkedToFile Property


SketchImage.Name Property

SketchImage.Name Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Name Property


SketchImage.Parent Property

SketchImage.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent sketch.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Parent Property


SketchImage.Position Property

SketchImage.Position Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the position of the image on the sketch.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Position Property


SketchImage.ReferencedFileDescriptor Property

SketchImage.ReferencedFileDescriptor Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the reference to the picture file used to create this image. This property returns Nothing if the source file is not linked (use the LinkedToFile property to determine this).

Visual Basic
Property ReferencedFileDescriptor() As ReferencedOLEFileDescriptor**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.ReferencedFileDescriptor Property


SketchImage.SketchBlockPath Property

SketchImage.SketchBlockPath Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the path of sketch blocks at the leaf of which this sketch object is found. The enumerator returns a count of 0 if the object lives directly under a sketch.

Visual Basic
Property SketchBlockPath() As SketchBlocksEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.SketchBlockPath Property


SketchImage.Transparent Property

SketchImage.Transparent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the image is transparent. Transparency color is the color of the lower right pixel of the image.

Visual Basic
Property Transparent() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Transparent Property


SketchImage.Type Property

SketchImage.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kSketchImageObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Type Property


SketchImage.Visible Property

SketchImage.Visible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the image is visible.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Visible Property


SketchImage.Width Property

SketchImage.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the image width.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchImage Interface > SketchImage Properties > SketchImage.Width Property


SketchImageProxy Interface

SketchImageProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchImage object.

Class Hierarchy
Inventor::SketchImage
    Inventor::SketchImageProxy
Visual Basic
Public Interface SketchImageProxy
Inherits SketchImage
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchImageProxy Interface


SketchImageProxy Properties

SketchImageProxy Properties
Summary

The properties of the SketchImageProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchImageProxy Interface > SketchImageProxy Properties


SketchImageProxy.ContainingOccurrence Property

SketchImageProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchImageProxy Interface > SketchImageProxy Properties > SketchImageProxy.ContainingOccurrence Property


SketchImageProxy.NativeObject Property

SketchImageProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchImage**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchImageProxy Interface > SketchImageProxy Properties > SketchImageProxy.NativeObject Property


SketchImages Interface

SketchImages Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SketchImages collection object provides access to all the images in a sketch.

Class Hierarchy
Inventor::SketchImages
Visual Basic
Public Interface SketchImages
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchImages

See Also

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface


SketchImages Methods

SketchImages Methods
Summary

The methods of the SketchImages class are listed here.

Methods
Methods
Name | Description
Add | Method that creates an image based on an input picture file name.
Item | Method that returns the specified Image object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Methods


SketchImages.Add Method

SketchImages.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates an image based on an input picture file name.

Visual Basic
Sub Add(FullFileName As String, Position As Point2d, ByRef Link As [defaultvalue(1)] VARIANT_BOOL, Result As [out, retval] SketchImage*)
Parameters
Parameters | Description
FullFileName | Specifies the full file name of a picture file that contains the image to be inserted.
Position | Object that specifies the position on the sketch to insert the image at.
Link | Boolean that specifies whether or not to link the input source file. The default value is True indicating the file will be linked.
See Also

Add a decal feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Methods > SketchImages.Add Method


SketchImages.Item Method

SketchImages.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the specified Image object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SketchImage*)
Parameters
Parameters | Description
index | Value that specifies the image to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the image name. If an out of range index or a name of a non-existent image is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Methods > SketchImages.Item Method


SketchImages Properties

SketchImages Properties
Summary

The properties of the SketchImages class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning kSketchImagesObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Properties


SketchImages.Application Property

SketchImages.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Properties > SketchImages.Application Property


SketchImages.Count Property

SketchImages.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Properties > SketchImages.Count Property


SketchImages.Type Property

SketchImages.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kSketchImagesObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchImages Interface > SketchImages Properties > SketchImages.Type Property


SketchLine Interface

SketchLine Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchLine object represents a line within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchLine
        Inventor::SketchLineProxy
        Inventor::SketchSplineHandle
Visual Basic
Public Interface SketchLine
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

BendPartFeature.BendLine

EqualLengthConstraint.LineOne

EqualLengthConstraint.LineTwo

FoldDefinition.BendLine

MidpointConstraint.Line

OffsetDimConstraint.Line

SketchLineProxy.NativeObject

SketchLines.AddByTwoPoints

SketchLines.Item

SymmetryConstraint.SymmetryLine

TwoLineAngleDimConstraint.LineOne

TwoLineAngleDimConstraint.LineTwo

PlanarSketch.AxisEntity

RevolveFeature.AxisEntity

CoilFeature.AxisEntity

ChamferNote.ChamferEdgeOne

ChamferNote.ChamferEdgeTwo

AngleiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

LineAndPlaneWorkAxisDef.Line

LineAndPointWorkAxisDef.Line

LineAndTangentWorkPlaneDef.Line

LinePlaneAndAngleWorkPlaneDef.Line

LineWorkAxisDef.Line

TwoLinesWorkPlaneDef.Line1

TwoLinesWorkPointDef.Line1

TwoLinesWorkPlaneDef.Line2

TwoLinesWorkPointDef.Line2

See Also

Using Inventor's error dialog sample

Defer sketch updates sample

Sketch Text Add sample

Sweep Feature Add sample

Sketch Display Entities sample

Create SketchedSymbol Definition sample

Sketch Lines sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface


SketchLine Methods

SketchLine Methods
Summary

The methods of the SketchLine class are listed here.

Methods
Methods
Name | Description
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Methods


SketchLine.GetCustomLineType Method

SketchLine.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Methods > SketchLine.GetCustomLineType Method


SketchLine.SetCustomLineType Method

SketchLine.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Methods > SketchLine.SetCustomLineType Method


SketchLine Properties

SketchLine Properties
Summary

The properties of the SketchLine class are listed here.

Properties
Name | Description
Centerline | Property that indicates whether the line behaves as a centerline or not.
EndSketchPoint | Property that returns the that defines the position of the end of the line.
Geometry | Property that returns a LineSegment2d geometry object. The object returned represents a snapshot view of the current state of the sketch line.
Length | Double property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
OverrideColor | Gets and sets the color applied to this primitive.
StartSketchPoint | Property that returns the that defines the position of the start of the line.
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties


SketchLine.Centerline Property

SketchLine.Centerline Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates whether the line behaves as a centerline or not.

Visual Basic
Property Centerline() As VARIANT_BOOL
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.Centerline Property


SketchLine.EndSketchPoint Property

SketchLine.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the that defines the position of the end of the line.

Visual Basic
Property EndSketchPoint() As SketchPoint**
See Also

Sweep Feature Add sample

Sketch Display Entities sample

Sketch Lines sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.EndSketchPoint Property


SketchLine.Geometry Property

SketchLine.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a LineSegment2d geometry object. The object returned represents a snapshot view of the current state of the sketch line.

Visual Basic
Property Geometry() As LineSegment2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.Geometry Property


SketchLine.Length Property

SketchLine.Length Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.Length Property


SketchLine.LineDefinitionSpace Property

SketchLine.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.LineDefinitionSpace Property


SketchLine.LineScale Property

SketchLine.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.LineScale Property


SketchLine.LineType Property

SketchLine.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.LineType Property


SketchLine.LineWeight Property

SketchLine.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.LineWeight Property


SketchLine.OverrideColor Property

SketchLine.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.OverrideColor Property


SketchLine.StartSketchPoint Property

SketchLine.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the that defines the position of the start of the line.

Visual Basic
Property StartSketchPoint() As SketchPoint**
See Also

Sweep Feature Add sample

Sketch Display Entities sample

Create SketchedSymbol Definition sample

Sketch Lines sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine Interface > SketchLine Properties > SketchLine.StartSketchPoint Property


SketchLine3D Interface

SketchLine3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchLine3D object represents a line within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchLine3D
        Inventor::SketchLine3DProxy
        Inventor::SketchSplineHandle3D
Visual Basic
Public Interface SketchLine3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

BendConstraint.LineOne

BendConstraint.LineTwo

LineLengthDimConstraint3D.Line

MidpointConstraint3D.Line

SketchLine3DProxy.NativeObject

SketchLines3D.AddByTwoPoints

SketchLines3D.Item

TwoLineAngleDimConstraint3D.LineOne

TwoLineAngleDimConstraint3D.LineTwo

See Also

Loft Feature With Non-Planar Section sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine3D Interface


SketchLine3D Properties

SketchLine3D Properties
Summary

The properties of the SketchLine3D class are listed here.

Properties
Name | Description
EndSketchPoint | Property that returns the that defines the position of the end of the line.
Geometry | Property that gets and sets the LineSegment geometry object. The object returned represents a 'snapshot' view of the current state of the sketch line. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
Length | Double property that returns the length of the entity in centimeters.
StartSketchPoint | Property that returns the that defines the position of the start of the line.
You are here: Symbol Reference > Inventor Library > Objects > SketchLine3D Interface > SketchLine3D Properties


SketchLine3D.EndSketchPoint Property

SketchLine3D.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the that defines the position of the end of the line.

Visual Basic
Property EndSketchPoint() As SketchPoint3D**
See Also

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLine3D Interface > SketchLine3D Properties > SketchLine3D.EndSketchPoint Property


SketchLine3D.Geometry Property

SketchLine3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the LineSegment geometry object. The object returned represents a 'snapshot' view of the current state of the sketch line. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As LineSegment*
You are here: Symbol Reference > Inventor Library > Objects > SketchLine3D Interface > SketchLine3D Properties > SketchLine3D.Geometry Property


SketchLine3D.Length Property

SketchLine3D.Length Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchLine3D Interface > SketchLine3D Properties > SketchLine3D.Length Property


SketchLine3D.StartSketchPoint Property

SketchLine3D.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the that defines the position of the start of the line.

Visual Basic
Property StartSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchLine3D Interface > SketchLine3D Properties > SketchLine3D.StartSketchPoint Property


SketchLine3DProxy Interface

SketchLine3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchLine3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchLine3D
        Inventor::SketchLine3DProxy
Visual Basic
Public Interface SketchLine3DProxy
Inherits SketchLine3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchLine3DProxy Interface


SketchLine3DProxy Properties

SketchLine3DProxy Properties
Summary

The properties of the SketchLine3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchLine3DProxy Interface > SketchLine3DProxy Properties


SketchLine3DProxy.ContainingOccurrence Property

SketchLine3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchLine3DProxy Interface > SketchLine3DProxy Properties > SketchLine3DProxy.ContainingOccurrence Property


SketchLine3DProxy.NativeObject Property

SketchLine3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchLine3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchLine3DProxy Interface > SketchLine3DProxy Properties > SketchLine3DProxy.NativeObject Property


SketchLineProxy Interface

SketchLineProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchLine object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchLine
        Inventor::SketchLineProxy
Visual Basic
Public Interface SketchLineProxy
Inherits SketchLine
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

See Also

Projection - project across parts sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLineProxy Interface


SketchLineProxy Properties

SketchLineProxy Properties
Summary

The properties of the SketchLineProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchLineProxy Interface > SketchLineProxy Properties


SketchLineProxy.ContainingOccurrence Property

SketchLineProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchLineProxy Interface > SketchLineProxy Properties > SketchLineProxy.ContainingOccurrence Property


SketchLineProxy.NativeObject Property

SketchLineProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchLine**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchLineProxy Interface > SketchLineProxy Properties > SketchLineProxy.NativeObject Property


SketchLines Interface

SketchLines Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchLines object provides access to all of the objects in a sketch and provides methods to create additional sketch lines. See the article in the overviews section.

Class Hierarchy
Inventor::SketchLines
Visual Basic
Public Interface SketchLines
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchLines

See Also

Create sheet metal lofted flange feature sample

Create sheet metal face and fold features sample

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

Using Inventor's error dialog sample

Defer sketch updates sample

Edit profile of an extrude feature sample

Title Block Definition Create and Insert sample

Sketch Text Add sample

Sweep Feature Add sample

SurfaceBody Copy sample

Create SketchedSymbol Definition sample

Sketch Lines sample

Projection - project across parts sample

Create sheet metal face and cut features sample

Create sheet metal face and cut features sample

Sketch Add Oriented sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface


SketchLines Methods

SketchLines Methods
Summary

The methods of the SketchLines class are listed here.

Methods
Methods
Name | Description
AddAsPolygon | Method that creates a polygon with up to 120 sides. The sketch lines representing the polygon are returned.
AddAsThreePointRectangle | Method that creates four lines to represent a rectangle where the base of the rectangle is defined by two points and the height is defined by a third point. The input points for the base can be either Point2d objects defining an X-Y point in space, or an existing SketchPoint object.
AddAsTwoPointRectangle | Method that creates four lines to represent a rectangle where the diagonal corners of the rectangle are defined by the two input points and the rectangle is aligned with the sketch X and Y axes. The four new sketch lines are returned in an SketchEntitiesEnumerator object.
AddByTwoPoints | Method that creates a new sketch line based on the two input points. The new sketch line is returned.
Item | Property that returns the specified SketchLine object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Methods


SketchLines.AddAsPolygon Method

SketchLines.AddAsPolygon Method
Summary

Method that creates a polygon with up to 120 sides. The sketch lines representing the polygon are returned.

Visual Basic
Sub AddAsPolygon(NumberOfSides As long, CenterPoint As IDispatch, CircumferencePoint As IDispatch, Inscribed As VARIANT_BOOL, Result As [out, retval] SketchEntitiesEnumerator*)
Parameters
Parameters | Description
NumberOfSides | Input Long that specifies the number of sides of the polygon. If a value lesser than 3 or greater than 120 is provided, the method returns an error.
CenterPoint | Input object that specifies the center of the polygon. This can either be a SketchPoint or a Point2d object.
CircumferencePoint | Input object that specifies a point on the circumference of the circle that inscribes or circumscribes the polygon. This can either be a SketchPoint or a Point2d object.
Inscribed | Input Boolean that specifies whether the specified CircumferencePoint is on a circle that inscribes or circumscribes the polygon.
You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Methods > SketchLines.AddAsPolygon Method


SketchLines.AddAsThreePointRectangle Method

SketchLines.AddAsThreePointRectangle Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates four lines to represent a rectangle where the base of the rectangle is defined by two points and the height is defined by a third point. The input points for the base can be either Point2d objects defining an X-Y point in space, or an existing SketchPoint object.

Visual Basic
Sub AddAsThreePointRectangle(BasePointOne As IDispatch, BasePointTwo As IDispatch, HeightPoint As Point2d, Result As [out, retval] SketchEntitiesEnumerator*)
Parameters
Parameters | Description
BasePointOne | Input object that defines the first base point of the rectangle. Either a SketchPoint or Point2d object can be used. If an existing sketch point is input, that lines become connected to the point.
BasePointTwo | Input object that defines the second base point of the rectangle. Either a SketchPoint or Point2d object can be used. If an existing sketch point is input, the lines become connected to the point.
HeightPoint | Input Point2d object that defines the height of the rectangle. The point can be anywhere in space and the height of the rectangle is computed by finding the shortest distance of this point to an infinite line defined by the two base points.
Remarks

If an existing sketch point is input, the lines will become connected to that point. The two base points define the start and end points of the base the line of the rectangle. This base line defines the length and orientation of the rectangle. The height point is always input as a Point2d object and defines the height of the rectangle. The created sketch lines are returned in an SketchEntitiesEnumerator object.

See Also

Sketch Lines sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Methods > SketchLines.AddAsThreePointRectangle Method


SketchLines.AddAsTwoPointRectangle Method

SketchLines.AddAsTwoPointRectangle Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates four lines to represent a rectangle where the diagonal corners of the rectangle are defined by the two input points and the rectangle is aligned with the sketch X and Y axes. The four new sketch lines are returned in an SketchEntitiesEnumerator object.

Visual Basic
Sub AddAsTwoPointRectangle(CornerPointOne As IDispatch, CornerPointTwo As IDispatch, Result As [out, retval] SketchEntitiesEnumerator*)
Parameters
Parameters | Description
CornerPointOne | Input object that defines a corner of the rectangle. This can be a SketchPoint or a Point2d object. If an existing sketch point is input, the lines become connected to that point and the point becomes the corner point of the rectangle.
CornerPointTwo | Input object that defines the diagonal corner of the rectangle. This can be a SketchPoint or a Point2d object. If an existing sketch point is input, the lines become connected to that point and the point becomes the corner point of the rectangle.
See Also

Create sheet metal lofted flange feature sample

Create sheet metal face and fold features sample

Create and insert a sketch block definition into a part sketch sample

Create sketch block from an existing sketch sample

Using Inventor's error dialog sample

Edit profile of an extrude feature sample

Title Block Definition Create and Insert sample

SurfaceBody Copy sample

Sketch Lines sample

Offset a 2D sketch sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Create sheet metal face and cut features sample

Extrude feature - create block with pocket (C#) sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Create and Edit an Extrude Feature with a pocket sample

Hole Feature - Through holes (RegularAndTapped) sample

Extrude Feature - Create Block with Pocket sample

Border Create and Insert sample

Derived Parts and Assemblies sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Methods > SketchLines.AddAsTwoPointRectangle Method


SketchLines.AddByTwoPoints Method

SketchLines.AddByTwoPoints Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch line based on the two input points. The new sketch line is returned.

Visual Basic
Sub AddByTwoPoints(StartPoint As IDispatch, EndPoint As IDispatch, Result As [out, retval] SketchLine*)
Parameters
Parameters | Description
StartPoint | Input object that defines the start point of the line. This can be either a Point2d object defining an x-y point in space, or an existing SketchPoint object. If an existing sketch point is input, that point becomes the line's start point.
EndPoint | Input object that defines the end point of the line. This can be either a Point2d object defining an x-y point in space, or an existing SketchPoint object. If an existing sketch point is input, that point becomes the line's end point.
See Also

Create sheet metal face and fold features sample

Defer sketch updates sample

Title Block Definition Create and Insert sample

Sketch Text Add sample

Sweep Feature Add sample

Create SketchedSymbol Definition sample

Sketch Lines sample

Projection - project across parts sample

Sketch Add Oriented sample

Drawing Sketches - editing line type and color sample

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Methods > SketchLines.AddByTwoPoints Method


SketchLines.Item Method

SketchLines.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchLine object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchLine*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
See Also

Create sheet metal lofted flange feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Methods > SketchLines.Item Method


SketchLines Properties

SketchLines Properties
Summary

The properties of the SketchLines class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Properties


SketchLines.Application Property

SketchLines.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Properties > SketchLines.Application Property


SketchLines.Count Property

SketchLines.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Properties > SketchLines.Count Property


SketchLines.Type Property

SketchLines.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchLines Interface > SketchLines Properties > SketchLines.Type Property


SketchLines3D Interface

SketchLines3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchLines3D object provides access to all of the objects in a sketch and provides methods to create additional sketch lines. See the article in the overviews section.

Class Hierarchy
Inventor::SketchLines3D
Visual Basic
Public Interface SketchLines3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchLines3D

See Also

Sweep Feature Add sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface


SketchLines3D Methods

SketchLines3D Methods
Summary

The methods of the SketchLines3D class are listed here.

Methods
Methods
Name | Description
AddByTwoPoints | Method that creates a new sketch line based on the two input points. The new sketch line is returned.
Item | Property that returns the specified SketchLine3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Methods


SketchLines3D.AddByTwoPoints Method

SketchLines3D.AddByTwoPoints Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new sketch line based on the two input points. The new sketch line is returned.

Visual Basic
Sub AddByTwoPoints(StartPoint As IDispatch, EndPoint As IDispatch, ByRef UseAutoBend As [defaultvalue(-1)] VARIANT_BOOL, ByRef BendRadius As [optional] VARIANT, Result As [out, retval] SketchLine3D*)
Parameters
Parameters | Description
StartPoint | Input object that defines the start point of the line. This can be either a vertex object, a workpoint, a SketchPoint, or an existing SketchPoint3D object. If an existing sketch point is input, that point becomes the line's start point.
EndPoint | Input object that defines the end point of the line. This can be either a vertex object, a workpoint, a SketchPoint, or an existing SketchPoint3D object. If an existing sketch point is input, that point becomes the line's end point.
UseAutoBend | Optional input Boolean that indicates whether a bend should be automatically applied if the StartPoint or the EndPoint is shared by another sketch line. The default is True, which means that the bend will be automatically applied.
BendRadius | Optional input variant that defines the radius of the auto-bend. If the UseAutoBend flag is set to true and this variant is not supplied, a default value is used for the bend radius. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
See Also

Sweep Feature Add sample

Loft Feature With Non-Planar Section sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Methods > SketchLines3D.AddByTwoPoints Method


SketchLines3D.Item Method

SketchLines3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchLine3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchLine3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Methods > SketchLines3D.Item Method


SketchLines3D Properties

SketchLines3D Properties
Summary

The properties of the SketchLines3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Properties


SketchLines3D.Application Property

SketchLines3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Properties > SketchLines3D.Application Property


SketchLines3D.Count Property

SketchLines3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Properties > SketchLines3D.Count Property


SketchLines3D.Type Property

SketchLines3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchLines3D Interface > SketchLines3D Properties > SketchLines3D.Type Property


SketchOffsetSpline Interface

SketchOffsetSpline Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SketchOffsetSpline object represents an offset spline within a sketch. These special splines are created as a result of offsetting splines and ellipses in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchOffsetSpline
        Inventor::SketchOffsetSplineProxy
Visual Basic
Public Interface SketchOffsetSpline
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

OffsetSplineDimConstraint.OffsetSpline

SketchOffsetSplineProxy.NativeObject

SketchOffsetSplines.Item

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface


SketchOffsetSpline Methods

SketchOffsetSpline Methods
Summary

The methods of the SketchOffsetSpline class are listed here.

Methods
Methods
Name | Description
ConvertToSpline | Method that converts the offset spline to a SketchSpline object and breaks the association to the spline from which it is offset.
GetCustomLineType |
SetCustomLineType |
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Methods


SketchOffsetSpline.ConvertToSpline Method

SketchOffsetSpline.ConvertToSpline Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that converts the offset spline to a SketchSpline object and breaks the association to the spline from which it is offset.

Visual Basic
Sub ConvertToSpline(Result As [out, retval] SketchSpline*)
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Methods > SketchOffsetSpline.ConvertToSpline Method


SketchOffsetSpline.GetCustomLineType Method

SketchOffsetSpline.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Methods > SketchOffsetSpline.GetCustomLineType Method


SketchOffsetSpline.SetCustomLineType Method

SketchOffsetSpline.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Methods > SketchOffsetSpline.SetCustomLineType Method


SketchOffsetSpline Properties

SketchOffsetSpline Properties
Summary

The properties of the SketchOffsetSpline class are listed here.

Properties
Name | Description
Closed | Boolean property that gets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.
EndSketchPoint | Property that returns the that defines the position of the end of the spline.
Geometry | Property that returns a geometry object. The object returned represents a "snapshot" view of the current state of the offset sketch spline.
Length | Double property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
OriginalSpline | Returns the original spline that was used as the source to create the offset spline.
OverrideColor | Gets and sets the color applied to this primitive.
StartSketchPoint | Property that returns the that defines the position of the start of the spline.
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties


SketchOffsetSpline.Closed Property

SketchOffsetSpline.Closed Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Boolean property that gets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.

Visual Basic
Property Closed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.Closed Property


SketchOffsetSpline.CurvatureDisplay Property

SketchOffsetSpline.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.CurvatureDisplay Property


SketchOffsetSpline.EndSketchPoint Property

SketchOffsetSpline.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that defines the position of the end of the spline.

Visual Basic
Property EndSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.EndSketchPoint Property


SketchOffsetSpline.Geometry Property

SketchOffsetSpline.Geometry Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a geometry object. The object returned represents a "snapshot" view of the current state of the offset sketch spline.

Visual Basic
Property Geometry() As BSplineCurve2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.Geometry Property


SketchOffsetSpline.Length Property

SketchOffsetSpline.Length Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.Length Property


SketchOffsetSpline.LineDefinitionSpace Property

SketchOffsetSpline.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.LineDefinitionSpace Property


SketchOffsetSpline.LineScale Property

SketchOffsetSpline.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.LineScale Property


SketchOffsetSpline.LineType Property

SketchOffsetSpline.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.LineType Property


SketchOffsetSpline.LineWeight Property

SketchOffsetSpline.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.LineWeight Property


SketchOffsetSpline.OriginalSpline Property

SketchOffsetSpline.OriginalSpline Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Returns the original spline that was used as the source to create the offset spline.

Visual Basic
Property OriginalSpline() As SketchSpline**
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.OriginalSpline Property


SketchOffsetSpline.OverrideColor Property

SketchOffsetSpline.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.OverrideColor Property


SketchOffsetSpline.StartSketchPoint Property

SketchOffsetSpline.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the that defines the position of the start of the spline.

Visual Basic
Property StartSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSpline Interface > SketchOffsetSpline Properties > SketchOffsetSpline.StartSketchPoint Property


SketchOffsetSplineProxy Interface

SketchOffsetSplineProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchOffsetSpline object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchOffsetSpline
        Inventor::SketchOffsetSplineProxy
Visual Basic
Public Interface SketchOffsetSplineProxy
Inherits SketchOffsetSpline
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplineProxy Interface


SketchOffsetSplineProxy Properties

SketchOffsetSplineProxy Properties
Summary

The properties of the SketchOffsetSplineProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplineProxy Interface > SketchOffsetSplineProxy Properties


SketchOffsetSplineProxy.ContainingOccurrence Property

SketchOffsetSplineProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplineProxy Interface > SketchOffsetSplineProxy Properties > SketchOffsetSplineProxy.ContainingOccurrence Property


SketchOffsetSplineProxy.NativeObject Property

SketchOffsetSplineProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchOffsetSpline**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplineProxy Interface > SketchOffsetSplineProxy Properties > SketchOffsetSplineProxy.NativeObject Property


SketchOffsetSplines Interface

SketchOffsetSplines Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SketchOffsetSplines object provides access to all the objects in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchOffsetSplines
Visual Basic
Public Interface SketchOffsetSplines
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchOffsetSplines

You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface


SketchOffsetSplines Methods

SketchOffsetSplines Methods
Summary

The methods of the SketchOffsetSplines class are listed here.

Methods
Methods
Name | Description
Item | Method that returns the specified SketchOffsetSpline object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface > SketchOffsetSplines Methods


SketchOffsetSplines.Item Method

SketchOffsetSplines.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified SketchOffsetSpline object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchOffsetSpline*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface > SketchOffsetSplines Methods > SketchOffsetSplines.Item Method


SketchOffsetSplines Properties

SketchOffsetSplines Properties
Summary

The properties of the SketchOffsetSplines class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that specifies the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface > SketchOffsetSplines Properties


SketchOffsetSplines.Application Property

SketchOffsetSplines.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface > SketchOffsetSplines Properties > SketchOffsetSplines.Application Property


SketchOffsetSplines.Count Property

SketchOffsetSplines.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface > SketchOffsetSplines Properties > SketchOffsetSplines.Count Property


SketchOffsetSplines.Type Property

SketchOffsetSplines.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchOffsetSplines Interface > SketchOffsetSplines Properties > SketchOffsetSplines.Type Property


SketchOptions Interface

SketchOptions Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The SketchOptions object provides access to properties that provide read and write access of the 2D sketch related application options. This is somewhat equivalent to the 2D Sketch portion on the Sketch tab of the Application Options dialog.

Class Hierarchy
Inventor::SketchOptions
Visual Basic
Public Interface SketchOptions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HeadsUpDisplayOptions.Parent

Application.SketchOptions

You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface


SketchOptions Properties

SketchOptions Properties
Summary

The properties of the SketchOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AutomaticReferenceEdges | Property that enables or disables automatically projecting the edges of the selected face onto the sketch plane as reference geometry, when creating a new sketch. Setting this property to True will automatically create reference geometry for new sketches. Setting to False will suppress creation of reference geometry for a new sketch.
AutoProjectEdges | Property that enables or disables the capability to select and project existing geometry to the current sketch by "rubbing" the existing lines. The lines are projected as reference geometry. Setting this property to True enables Autoproject.
AutoProjectPartOrigin | Property that enables or disables projecting the part origin onto a sketch when the sketch is created. Setting this property to True enables projection of part origin onto the sketch.
ConstraintPriority | Property that sets the preferred constraint type for automatic placement of constraints
ConstraintToolbarScale | Property that gets and sets the scale for the size of the constraint toolbars with respect to the graphics window. The valid values for this property are in the range of 0.2 to 5, setting a value outside this range will cause an error.
DisplayAxes | Property that enables or disables the display of the sketch plane axes. Setting this property to True will cause the axes to be displayed.
DisplayCoincidentConstraintsOnCreation | Property that enables or disables the automatic display of coincident constraints on creation.
DisplayCoordinateSystemIndicator | Property that enables or disables the display of the sketch plane coordinate system indicator (triad). Setting this property to True will cause the triad to be displayed.
DisplayGridLines | Property that enables or disables the display of the sketch plane grid lines. Setting this property to True will cause the grid lines to be displayed.
DisplayMinorGridLines | Property that enables or disables the display of the sketch plane minor grid lines. Setting this property to True will cause the minor grid lines to be displayed.
EditDimensionWhenCreated | Property that specifies if the dimension edit box is to be displayed when a dimension is created. True indicates the edit box will be displayed and False will not display the box. This setting only affects dimensions that are created interactively. Dimensions created using the API will never cause the dimension edit box to be displayed.
HeadsUpDisplayOptions | Property that returns the HeadsUpDisplayOptions object. The HeadsUpDisplayOptions object provides access to various heads-up display related application level options for sketches.
OverConstrainedDimensionBehavior | Property that gets and sets the preferred behavior when placing dimensions on overconstrained sketches. The valid options are kApplyDrivenDimension and kWarnOfOverconstrainedCondition.
ParallelViewOnSketchCreation | Property that specifies whether the view is automatically reoriented to be planar to the screen when Sketch mode is activated. A value of True indicates that the view will be automatically reoriented to be planar to the screen.
PointAlignment | Property that gets and sets whether to infer alignment between endpoints of newly created geometry and points of existing geometry. Temporary dotted lines are shown to indicate the inferred alignment.
SnapToGrid | Property that enables or disables the snap behavior for sketching tasks. A value of True enables grid snapping.
SplineDefaultTension | Property that gets and sets the default tension for splines in 2d sketches. This value is used only if the fit method is set to kSweetSplineFit (Minimum Energy).
SplineFitMethod | Property that gets and sets the default fit method for splines in 2d sketches. Valid values are kSmoothSplineFit (Standard), kSweetSplineFit (Minimum Energy) and kACADSplineFit (AutoCAD).
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties


SketchOptions.Application Property

SketchOptions.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.Application Property


SketchOptions.AutomaticReferenceEdges Property

SketchOptions.AutomaticReferenceEdges Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables automatically projecting the edges of the selected face onto the sketch plane as reference geometry, when creating a new sketch. Setting this property to True will automatically create reference geometry for new sketches. Setting to False will suppress creation of reference geometry for a new sketch.

Visual Basic
Property AutomaticReferenceEdges() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.AutomaticReferenceEdges Property


SketchOptions.AutoProjectEdges Property

SketchOptions.AutoProjectEdges Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables the capability to select and project existing geometry to the current sketch by "rubbing" the existing lines. The lines are projected as reference geometry. Setting this property to True enables Autoproject.

Visual Basic
Property AutoProjectEdges() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.AutoProjectEdges Property


SketchOptions.AutoProjectPartOrigin Property

SketchOptions.AutoProjectPartOrigin Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that enables or disables projecting the part origin onto a sketch when the sketch is created. Setting this property to True enables projection of part origin onto the sketch.

Visual Basic
Property AutoProjectPartOrigin() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.AutoProjectPartOrigin Property


SketchOptions.ConstraintPriority Property

SketchOptions.ConstraintPriority Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that sets the preferred constraint type for automatic placement of constraints

Visual Basic
Property ConstraintPriority() As ConstraintPriorityEnum
Remarks

This setting is used when the user creates a sketch interactively. This setting is ignored when creating sketch entities programmatically because constraints are not automatically inferred in this case.

The existing priority options are kParallelAndPerpendicularPriority, kHorizontalAndVerticalPriority and kNonePriority.

You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.ConstraintPriority Property


SketchOptions.ConstraintToolbarScale Property

SketchOptions.ConstraintToolbarScale Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the scale for the size of the constraint toolbars with respect to the graphics window. The valid values for this property are in the range of 0.2 to 5, setting a value outside this range will cause an error.

Visual Basic
Property ConstraintToolbarScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.ConstraintToolbarScale Property


SketchOptions.DisplayAxes Property

SketchOptions.DisplayAxes Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables the display of the sketch plane axes. Setting this property to True will cause the axes to be displayed.

Visual Basic
Property DisplayAxes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.DisplayAxes Property


SketchOptions.DisplayCoincidentConstraintsOnCreation Property

SketchOptions.DisplayCoincidentConstraintsOnCreation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that enables or disables the automatic display of coincident constraints on creation.

Visual Basic
Property DisplayCoincidentConstraintsOnCreation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.DisplayCoincidentConstraintsOnCreation Property


SketchOptions.DisplayCoordinateSystemIndicator Property

SketchOptions.DisplayCoordinateSystemIndicator Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables the display of the sketch plane coordinate system indicator (triad). Setting this property to True will cause the triad to be displayed.

Visual Basic
Property DisplayCoordinateSystemIndicator() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.DisplayCoordinateSystemIndicator Property


SketchOptions.DisplayGridLines Property

SketchOptions.DisplayGridLines Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables the display of the sketch plane grid lines. Setting this property to True will cause the grid lines to be displayed.

Visual Basic
Property DisplayGridLines() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.DisplayGridLines Property


SketchOptions.DisplayMinorGridLines Property

SketchOptions.DisplayMinorGridLines Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables the display of the sketch plane minor grid lines. Setting this property to True will cause the minor grid lines to be displayed.

Visual Basic
Property DisplayMinorGridLines() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.DisplayMinorGridLines Property


SketchOptions.EditDimensionWhenCreated Property

SketchOptions.EditDimensionWhenCreated Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies if the dimension edit box is to be displayed when a dimension is created. True indicates the edit box will be displayed and False will not display the box. This setting only affects dimensions that are created interactively. Dimensions created using the API will never cause the dimension edit box to be displayed.

Visual Basic
Property EditDimensionWhenCreated() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.EditDimensionWhenCreated Property


SketchOptions.HeadsUpDisplayOptions Property

SketchOptions.HeadsUpDisplayOptions Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the HeadsUpDisplayOptions object. The HeadsUpDisplayOptions object provides access to various heads-up display related application level options for sketches.

Visual Basic
Property HeadsUpDisplayOptions() As HeadsUpDisplayOptions**
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.HeadsUpDisplayOptions Property


SketchOptions.OverConstrainedDimensionBehavior Property

SketchOptions.OverConstrainedDimensionBehavior Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the preferred behavior when placing dimensions on overconstrained sketches. The valid options are kApplyDrivenDimension and kWarnOfOverconstrainedCondition.

Visual Basic
Property OverConstrainedDimensionBehavior() As OverConstrainedDimensionBehaviorEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.OverConstrainedDimensionBehavior Property


SketchOptions.ParallelViewOnSketchCreation Property

SketchOptions.ParallelViewOnSketchCreation Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that specifies whether the view is automatically reoriented to be planar to the screen when Sketch mode is activated. A value of True indicates that the view will be automatically reoriented to be planar to the screen.

Visual Basic
Property ParallelViewOnSketchCreation() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.ParallelViewOnSketchCreation Property


SketchOptions.PointAlignment Property

SketchOptions.PointAlignment Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether to infer alignment between endpoints of newly created geometry and points of existing geometry. Temporary dotted lines are shown to indicate the inferred alignment.

Visual Basic
Property PointAlignment() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.PointAlignment Property


SketchOptions.SnapToGrid Property

SketchOptions.SnapToGrid Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that enables or disables the snap behavior for sketching tasks. A value of True enables grid snapping.

Visual Basic
Property SnapToGrid() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.SnapToGrid Property


SketchOptions.SplineDefaultTension Property

SketchOptions.SplineDefaultTension Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default tension for splines in 2d sketches. This value is used only if the fit method is set to kSweetSplineFit (Minimum Energy).

Visual Basic
Property SplineDefaultTension() As long
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.SplineDefaultTension Property


SketchOptions.SplineFitMethod Property

SketchOptions.SplineFitMethod Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default fit method for splines in 2d sketches. Valid values are kSmoothSplineFit (Standard), kSweetSplineFit (Minimum Energy) and kACADSplineFit (AutoCAD).

Visual Basic
Property SplineFitMethod() As SplineFitMethodEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.SplineFitMethod Property


SketchOptions.Type Property

SketchOptions.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchOptions Interface > SketchOptions Properties > SketchOptions.Type Property


SketchPoint Interface

SketchPoint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchPoint object represents a point within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchPoint
        Inventor::SketchPointProxy
Visual Basic
Public Interface SketchPoint
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

HorizontalAlignConstraint.PointOne

HorizontalAlignConstraint.PointTwo

MidpointConstraint.Point

ProfileEntity.EndSketchPoint

ProfileEntity.StartSketchPoint

SketchArc.CenterSketchPoint

SketchArc.EndSketchPoint

SketchArc.StartSketchPoint

SketchBlockDefinition.InsertionPoint

SketchCircle.CenterSketchPoint

SketchEllipse.CenterSketchPoint

SketchEllipticalArc.CenterSketchPoint

SketchEllipticalArc.EndSketchPoint

SketchEllipticalArc.StartSketchPoint

SketchFixedSpline.EndSketchPoint

SketchFixedSpline.StartSketchPoint

SketchLine.EndSketchPoint

SketchLine.StartSketchPoint

SketchOffsetSpline.EndSketchPoint

SketchOffsetSpline.StartSketchPoint

SketchPointProxy.NativeObject

SketchPoints.Add

SketchPoints.Item

SketchSpline.EndSketchPoint

SketchSpline.StartSketchPoint

SketchSpline.FitPoint

SketchSpline.InsertFitPoint

SketchSplineHandle.FitPoint

SplineFitPointConstraint.Point

TextBox.OriginSketchPoint

ThreePointAngleDimConstraint.PointOne

ThreePointAngleDimConstraint.PointThree

ThreePointAngleDimConstraint.PointTwo

TwoPointDistanceDimConstraint.PointOne

TwoPointDistanceDimConstraint.PointTwo

VerticalAlignConstraint.PointOne

VerticalAlignConstraint.PointTwo

CoincidentConstraint3D.ConnectedEntity

LineAndPointWorkAxisDef.Point

NormalToCurveWorkPlaneDef.Point

NormalToSurfaceWorkAxisDef.Point

PlaneAndPointWorkPlaneDef.Point

PointAndPlaneWorkAxisDef.Point

PointAndTangentWorkPlaneDef.Point

PointHolePlacementDefinition.Point

PointWorkPointDef.Point

ThreePointsWorkPlaneDef.Point1

TwoPointsWorkAxisDef.Point1

ThreePointsWorkPlaneDef.Point2

TwoPointsWorkAxisDef.Point2

ThreePointsWorkPlaneDef.Point3

ToExtent.ToEntity

RectangularPatternFeature.XDirectionStartPoint

RectangularPatternFeature.YDirectionStartPoint

See Also

Sketch Display Entities sample

Create SketchedSymbol Definition sample

Add a punch tool feature sample

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface


SketchPoint Methods

SketchPoint Methods
Summary

The methods of the SketchPoint class are listed here.

Methods
Methods
Name | Description
Merge | Method that merges this sketch point with the input sketch point. Any objects dependent on this sketch point will change their dependency to the new sketch point.
MoveBy | Method that moves the sketch point a delta distance from its current location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.
MoveTo | Method that moves the sketch point to an explicit X-Y location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Methods


SketchPoint.Merge Method

SketchPoint.Merge Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that merges this sketch point with the input sketch point. Any objects dependent on this sketch point will change their dependency to the new sketch point.

Visual Basic
Sub Merge(SketchPoint As SketchPoint)
Parameters
Parameters | Description
SketchPoint | Input SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Methods > SketchPoint.Merge Method


SketchPoint.MoveBy Method

SketchPoint.MoveBy Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that moves the sketch point a delta distance from its current location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.

Visual Basic
Sub MoveBy(Vector As Vector2d)
Parameters
Parameters | Description
Vector | Input Vector2d object that defines the delta distance to move the sketch point.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Methods > SketchPoint.MoveBy Method


SketchPoint.MoveTo Method

SketchPoint.MoveTo Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that moves the sketch point to an explicit X-Y location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.

Visual Basic
Sub MoveTo(Point As Point2d)
Parameters
Parameters | Description
Point | Input object that defines the new position of the sketch point.
See Also

Sketch Spline sample

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Methods > SketchPoint.MoveTo Method


SketchPoint Properties

SketchPoint Properties
Summary

The properties of the SketchPoint class are listed here.

Properties
Name | Description
AttachedEntities | Property that returns the collection of objects that are connected to this point.
ConnectionPoint | Property that indicates whether the point behaves as a connection point or not. If set to True, the point can be used as the connection handle for snapping together sketched symbols, titleblocks and borders. Applicable to drawing sketches only.
Geometry | Property that returns a Point2d geometry object. The object returned represents a snapshot view of the current state of the sketch point.
HoleCenter | Property that defines if the point is being displayed as a hole center. True if it is a hole center.
InsertionPoint | Property that indicates whether the point behaves as an insertion point or not. If set to True, the point is used as the insertion handle for sketched symbols and titleblocks. Applicable to drawing sketches only.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Properties


SketchPoint.AttachedEntities Property

SketchPoint.AttachedEntities Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the collection of objects that are connected to this point.

Visual Basic
Property AttachedEntities() As SketchEntitiesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Properties > SketchPoint.AttachedEntities Property


SketchPoint.ConnectionPoint Property

SketchPoint.ConnectionPoint Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether the point behaves as a connection point or not. If set to True, the point can be used as the connection handle for snapping together sketched symbols, titleblocks and borders. Applicable to drawing sketches only.

Visual Basic
Property ConnectionPoint() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Properties > SketchPoint.ConnectionPoint Property


SketchPoint.Geometry Property

SketchPoint.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a Point2d geometry object. The object returned represents a snapshot view of the current state of the sketch point.

Visual Basic
Property Geometry() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Properties > SketchPoint.Geometry Property


SketchPoint.HoleCenter Property

SketchPoint.HoleCenter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that defines if the point is being displayed as a hole center. True if it is a hole center.

Visual Basic
Property HoleCenter() As VARIANT_BOOL
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Properties > SketchPoint.HoleCenter Property


SketchPoint.InsertionPoint Property

SketchPoint.InsertionPoint Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether the point behaves as an insertion point or not. If set to True, the point is used as the insertion handle for sketched symbols and titleblocks. Applicable to drawing sketches only.

Visual Basic
Property InsertionPoint() As VARIANT_BOOL
See Also

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint Interface > SketchPoint Properties > SketchPoint.InsertionPoint Property


SketchPoint3D Interface

SketchPoint3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchPoint3D object represents a point within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchPoint3D
        Inventor::SketchPoint3DProxy
Visual Basic
Public Interface SketchPoint3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

CoincidentConstraint3D.SketchPoint

MidpointConstraint3D.Point

PointAndPlaneDistanceDimConstraint3D.Point

ProfileEntity3D.EndSketchPoint

ProfileEntity3D.StartSketchPoint

SketchArc3D.EndSketchPoint

SketchArc3D.StartSketchPoint

SketchEllipticalArc3D.EndSketchPoint

SketchEllipticalArc3D.StartSketchPoint

SketchFixedSpline3D.EndSketchPoint

SketchFixedSpline3D.StartSketchPoint

SketchLine3D.EndSketchPoint

SketchLine3D.StartSketchPoint

SketchPoint3DProxy.NativeObject

SketchPoints3D.Add

SketchPoints3D.Item

SketchSpline3D.EndSketchPoint

SketchSpline3D.StartSketchPoint

SketchSpline3D.FitPoint

SketchSpline3D.InsertFitPoint

SketchSplineHandle3D.FitPoint

TwoPointDistanceDimConstraint3D.PointOne

TwoPointDistanceDimConstraint3D.PointTwo

ToExtent.ToEntity

RectangularPatternFeature.XDirectionStartPoint

RectangularPatternFeature.YDirectionStartPoint

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface


SketchPoint3D Methods

SketchPoint3D Methods
Summary

The methods of the SketchPoint3D class are listed here.

Methods
Methods
Name | Description
ConnectTo | Method that connects this sketch point to the input point. Valid inputs are SketchPoint3D, SketchPoint, Vertex or WorkPoint. This method is the UI equivalent of 'Add Coincident Constraint'. The point being constrained is the sketch point on which this method is called and the input point is the constraining point. This method will fail if a coincident constraint exists between this sketch point and a vertex; i.e. this sketch point must be underconstrained.
MoveBy | Method that moves the sketch point a delta distance from its current location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.
MoveTo | Method that moves the sketch point to an explicit x-y-z location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Methods


SketchPoint3D.ConnectTo Method

SketchPoint3D.ConnectTo Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that connects this sketch point to the input point. Valid inputs are SketchPoint3D, SketchPoint, Vertex or WorkPoint. This method is the UI equivalent of 'Add Coincident Constraint'. The point being constrained is the sketch point on which this method is called and the input point is the constraining point. This method will fail if a coincident constraint exists between this sketch point and a vertex; i.e. this sketch point must be underconstrained.

Visual Basic
Sub ConnectTo(ConstrainingPoint As IDispatch)
Parameters
Parameters | Description
ConstrainingPoint | Input SketchPoint3D, Vertex or Workpoint to use as the constraining point.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Methods > SketchPoint3D.ConnectTo Method


SketchPoint3D.MoveBy Method

SketchPoint3D.MoveBy Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that moves the sketch point a delta distance from its current location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.

Visual Basic
Sub MoveBy(Vector As Vector)
Parameters
Parameters | Description
Vector | Object that defines the delta distance to move the sketch point.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Methods > SketchPoint3D.MoveBy Method


SketchPoint3D.MoveTo Method

SketchPoint3D.MoveTo Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that moves the sketch point to an explicit x-y-z location. Movement of a sketch point is limited by the constraints currently defined on the sketch. If a sketch is partially constrained it will perform the move within the range allowed by the constraints. Because of this, the result of a move may not always be exactly what was specified.

Visual Basic
Sub MoveTo(Point As Point)
Parameters
Parameters | Description
Point | Object that defines the new position of the sketch point.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Methods > SketchPoint3D.MoveTo Method


SketchPoint3D Properties

SketchPoint3D Properties
Summary

The properties of the SketchPoint3D class are listed here.

Properties
Name | Description
AttachedEntities | Property that returns the collection of objects that are connected to this point.
Geometry | Property that gets and sets the Point geometry object. The object returned represents a 'snapshot' view of the current state of the sketch point. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
HoleCenter | Property that defines if the sketch point is being displayed as a hole center. True if it is a hole center.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Properties


SketchPoint3D.AttachedEntities Property

SketchPoint3D.AttachedEntities Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the collection of objects that are connected to this point.

Visual Basic
Property AttachedEntities() As SketchEntities3DEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Properties > SketchPoint3D.AttachedEntities Property


SketchPoint3D.Geometry Property

SketchPoint3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the Point geometry object. The object returned represents a 'snapshot' view of the current state of the sketch point. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As Point*
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Properties > SketchPoint3D.Geometry Property


SketchPoint3D.HoleCenter Property

SketchPoint3D.HoleCenter Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that defines if the sketch point is being displayed as a hole center. True if it is a hole center.

Visual Basic
Property HoleCenter() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3D Interface > SketchPoint3D Properties > SketchPoint3D.HoleCenter Property


SketchPoint3DProxy Interface

SketchPoint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchPoint3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchPoint3D
        Inventor::SketchPoint3DProxy
Visual Basic
Public Interface SketchPoint3DProxy
Inherits SketchPoint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3DProxy Interface


SketchPoint3DProxy Properties

SketchPoint3DProxy Properties
Summary

The properties of the SketchPoint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3DProxy Interface > SketchPoint3DProxy Properties


SketchPoint3DProxy.ContainingOccurrence Property

SketchPoint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3DProxy Interface > SketchPoint3DProxy Properties > SketchPoint3DProxy.ContainingOccurrence Property


SketchPoint3DProxy.NativeObject Property

SketchPoint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchPoint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchPoint3DProxy Interface > SketchPoint3DProxy Properties > SketchPoint3DProxy.NativeObject Property


SketchPointProxy Interface

SketchPointProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchPoint object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchPoint
        Inventor::SketchPointProxy
Visual Basic
Public Interface SketchPointProxy
Inherits SketchPoint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchPointProxy Interface


SketchPointProxy Properties

SketchPointProxy Properties
Summary

The properties of the SketchPointProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchPointProxy Interface > SketchPointProxy Properties


SketchPointProxy.ContainingOccurrence Property

SketchPointProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchPointProxy Interface > SketchPointProxy Properties > SketchPointProxy.ContainingOccurrence Property


SketchPointProxy.NativeObject Property

SketchPointProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchPoint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchPointProxy Interface > SketchPointProxy Properties > SketchPointProxy.NativeObject Property


SketchPoints Interface

SketchPoints Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchPoints object provides access to all the objects in a sketch and provides methods to create additional sketch points. See the article in the overviews section.

Class Hierarchy
Inventor::SketchPoints
Visual Basic
Public Interface SketchPoints
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchPoints

You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface


SketchPoints Methods

SketchPoints Methods
Summary

The methods of the SketchPoints class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new sketch point at the specified coordinate.
Item | Property that returns the specified SketchPoint object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Methods


SketchPoints.Add Method

SketchPoints.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new sketch point at the specified coordinate.

Visual Basic
Sub Add(Point As Point2d, ByRef HoleCenter As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchPoint*)
Parameters
Parameters | Description
Point | Input that defines the position of the sketch point.
HoleCenter | Optional input Boolean that specifies if the point is a hole center or not.
See Also

Add a punch tool feature sample

Hole Feature - Through holes (RegularAndTapped) sample

You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Methods > SketchPoints.Add Method


SketchPoints.Item Method

SketchPoints.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchPoint object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchPoint*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Methods > SketchPoints.Item Method


SketchPoints Properties

SketchPoints Properties
Summary

The properties of the SketchPoints class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Properties


SketchPoints.Application Property

SketchPoints.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Properties > SketchPoints.Application Property


SketchPoints.Count Property

SketchPoints.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Properties > SketchPoints.Count Property


SketchPoints.Type Property

SketchPoints.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints Interface > SketchPoints Properties > SketchPoints.Type Property


SketchPoints3D Interface

SketchPoints3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchPoints3D object provides access to all the objects in a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchPoints3D
Visual Basic
Public Interface SketchPoints3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchPoints3D

You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface


SketchPoints3D Methods

SketchPoints3D Methods
Summary

The methods of the SketchPoints3D class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new 3D sketch point at the specified coordinate.
Item | Property that returns the specified SketchPoint3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Methods


SketchPoints3D.Add Method

SketchPoints3D.Add Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new 3D sketch point at the specified coordinate.

Visual Basic
Sub Add(Point As Point, ByRef HoleCenter As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchPoint3D*)
Parameters
Parameters | Description
Point | Input object that defines the position of the 3D sketch point.
HoleCenter | Optional input Boolean that specifies if the point is a hole center or not.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Methods > SketchPoints3D.Add Method


SketchPoints3D.Item Method

SketchPoints3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchPoint3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchPoint3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Methods > SketchPoints3D.Item Method


SketchPoints3D Properties

SketchPoints3D Properties
Summary

The properties of the SketchPoints3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Properties


SketchPoints3D.Application Property

SketchPoints3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Properties > SketchPoints3D.Application Property


SketchPoints3D.Count Property

SketchPoints3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Properties > SketchPoints3D.Count Property


SketchPoints3D.Type Property

SketchPoints3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchPoints3D Interface > SketchPoints3D Properties > SketchPoints3D.Type Property


SketchSettings Interface

SketchSettings Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The SketchSettings object provides access to properties that provide read and write access to the various sketch related document specific settings. This is somewhat equivalent to the Sketch tab of the Document Settings dialog.

Class Hierarchy
Inventor::SketchSettings
Visual Basic
Public Interface SketchSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyDocument.SketchSettings

DrawingDocument.SketchSettings

PartDocument.SketchSettings

You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface


SketchSettings Properties

SketchSettings Properties
Summary

The properties of the SketchSettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DisplayLineWeights | Property that enables or disables the display of unique line weights in models. If True, visible lines in models are displayed with line weights. If False, all visible lines are displayed with the same weight.
LineWeightType | Property that specifies the type of line weight to apply when displaying lines in models. The valid options are kTrueLineWeight and kRangeLineWeight.
MinorLinesPerMajorGridLine | Property that gets and sets the number of minor lines to appear between major lines. Major lines appear heavier in the grid display. Values outside the range of 1 to 512 will cause an error.
Parent | Property that returns the parent Document object.
SnapsPerMinorGrid | Property that gets and sets the distance between minor grid lines relative to the specified snap distance. For example, if you set the X snap distance at 0.0625, and specify 2 snaps per minor, the minor lines are spaced 0.125 apart. Values outside the range of 1 to 512 will cause an error.
Type | Property returning an enum indicating this object's type.
UpperLimitForFirstRangeOfLineWeights | Property that specifies the upper limit of the line thickness value for which the first range of line weight applies.
UpperLimitForSecondRangeOfLineWeights | Property that specifies the upper limit of the line thickness value for which the second range of line weight applies.
UpperLimitForThirdRangeOfLineWeights | Property that specifies the upper limit of the line thickness value for which the third range of line weight applies.
XSnapSpacing | Property that gets and sets the spacing between snap points for the X axis. The string is an expression that can be evaluated as an distance. When setting this property, you must provide a string that can be evaluated as an distance or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.
YSnapSpacing | Property that gets and sets the spacing between snap points for the Y axis. The string is an expression that can be evaluated as an distance. When setting this property, you must provide a string that can be evaluated as an distance or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties


SketchSettings.Application Property

SketchSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.Application Property


SketchSettings.DisplayLineWeights Property

SketchSettings.DisplayLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that enables or disables the display of unique line weights in models. If True, visible lines in models are displayed with line weights. If False, all visible lines are displayed with the same weight.

Visual Basic
Property DisplayLineWeights() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.DisplayLineWeights Property


SketchSettings.LineWeightType Property

SketchSettings.LineWeightType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the type of line weight to apply when displaying lines in models. The valid options are kTrueLineWeight and kRangeLineWeight.

Visual Basic
Property LineWeightType() As LineWeightTypeEnum
Remarks

Setting this property to kTrueLineWeight specifies that the line weights should correspond to the actual line dimensions. The line weights will be displayed on screen with the same dimensions as they would appear on paper, regardless of zoom magnification.

Setting this property to kRangeLineWeight specifies that lines will be displayed with a particular line weight depending on which one of the defined range of line thickness values the actual line thickness falls into. All lines whose thickness lies within a particular range will be displayed with the same line weight. The ranges for the line thicknesses are defined by the UpperLimitForFirstRangeOfLineWeights, UpperLimitForSecondRangeOfLineWeights and UpperLimitForThirdRangeOfLineWeights properties.

Note: This property can be set only if the DisplayLineWeights property has already been set to True. Setting this property will fail if the DisplayLineWeights property has been set to False.

You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.LineWeightType Property


SketchSettings.MinorLinesPerMajorGridLine Property

SketchSettings.MinorLinesPerMajorGridLine Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the number of minor lines to appear between major lines. Major lines appear heavier in the grid display. Values outside the range of 1 to 512 will cause an error.

Visual Basic
Property MinorLinesPerMajorGridLine() As long
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.MinorLinesPerMajorGridLine Property


SketchSettings.Parent Property

SketchSettings.Parent Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the parent Document object.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.Parent Property


SketchSettings.SnapsPerMinorGrid Property

SketchSettings.SnapsPerMinorGrid Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the distance between minor grid lines relative to the specified snap distance. For example, if you set the X snap distance at 0.0625, and specify 2 snaps per minor, the minor lines are spaced 0.125 apart. Values outside the range of 1 to 512 will cause an error.

Visual Basic
Property SnapsPerMinorGrid() As long
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.SnapsPerMinorGrid Property


SketchSettings.Type Property

SketchSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.Type Property


SketchSettings.UpperLimitForFirstRangeOfLineWeights Property

SketchSettings.UpperLimitForFirstRangeOfLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the upper limit of the line thickness value for which the first range of line weight applies.

Visual Basic
Property UpperLimitForFirstRangeOfLineWeights() As double
Remarks

This property can be set only if the DisplayLineWeights property has already been set to True and the LineWeightType property has been set to kRangeLineWeight. Setting this property will fail if the DisplayLineWeights property has been set to False or the LineWeightType property has been set to kTrueLineWeight.

You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.UpperLimitForFirstRangeOfLineWeights Property


SketchSettings.UpperLimitForSecondRangeOfLineWeights Property

SketchSettings.UpperLimitForSecondRangeOfLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the upper limit of the line thickness value for which the second range of line weight applies.

Visual Basic
Property UpperLimitForSecondRangeOfLineWeights() As double
Remarks

This property can be set only if the DisplayLineWeights property has already been set to True and the LineWeightType property has been set to kRangeLineWeight. Setting this property will fail if the DisplayLineWeights property has been set to False or the LineWeightType property has been set to kTrueLineWeight.

You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.UpperLimitForSecondRangeOfLineWeights Property


SketchSettings.UpperLimitForThirdRangeOfLineWeights Property

SketchSettings.UpperLimitForThirdRangeOfLineWeights Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that specifies the upper limit of the line thickness value for which the third range of line weight applies.

Visual Basic
Property UpperLimitForThirdRangeOfLineWeights() As double
Remarks

This property can be set only if the DisplayLineWeights property has already been set to True and the LineWeightType property has been set to kRangeLineWeight. Setting this property will fail if the DisplayLineWeights property has been set to False or the LineWeightType property has been set to kTrueLineWeight.

You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.UpperLimitForThirdRangeOfLineWeights Property


SketchSettings.XSnapSpacing Property

SketchSettings.XSnapSpacing Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the spacing between snap points for the X axis. The string is an expression that can be evaluated as an distance. When setting this property, you must provide a string that can be evaluated as an distance or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.

Visual Basic
Property XSnapSpacing() As String
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.XSnapSpacing Property


SketchSettings.YSnapSpacing Property

SketchSettings.YSnapSpacing Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the spacing between snap points for the Y axis. The string is an expression that can be evaluated as an distance. When setting this property, you must provide a string that can be evaluated as an distance or the property will fail. The functions on the UnitsOfMeasure object can be used to determine the validity of a string and to convert the output string into a value.

Visual Basic
Property YSnapSpacing() As String
You are here: Symbol Reference > Inventor Library > Objects > SketchSettings Interface > SketchSettings Properties > SketchSettings.YSnapSpacing Property


SketchSpline Interface

SketchSpline Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchSpline object represents a spline within a sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchSpline
        Inventor::SketchSplineProxy
Visual Basic
Public Interface SketchSpline
Inherits SketchEntity
Notes

Members through which this object may be accessed include:

OffsetSplineDimConstraint.Spline

SketchFixedSpline.ConvertToSpline

SketchOffsetSpline.OriginalSpline

SketchOffsetSpline.ConvertToSpline

SketchSplineHandle.Spline

SketchSplineProxy.NativeObject

SketchSplines.Add

SketchSplines.Item

SplineFitPointConstraint.Spline

See Also

Spline - create NURBS sample

Sketch Display Entities sample

Example

"Sketch Spline Example "

This sample demonstrates creating and manipulating a sketch spline.

To use this sample a sketch must be active.

Public Sub DrawSketchSpline()
    ' Check to make sure a sketch is open.
    If Not TypeOf ThisApplication.ActiveEditObject Is PlanarSketch Then
        MsgBox "A sketch must be active."
        Exit Sub
    End If

    ' Set a reference to the active sketch.
    Dim oSketch As PlanarSketch
    Set oSketch = ThisApplication.ActiveEditObject

    ' Set a reference to the transient geometry collection.
    Dim oTransGeom As TransientGeometry
    Set oTransGeom = ThisApplication.TransientGeometry

    ' Create the collection that will contain the fit points for the spline.
    Dim oFitPoints As ObjectCollection
    Set oFitPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Define the points to fit the spline through.  In this example, transient
    ' points are used.  They could also be sketch points and then the spline
    ' will automatically be constrained to fit through the sketch point.  The
    ' points are at (0,0), (2,2), (4,0), (6,4), (7,-1).
    Dim oPoints(1 To 5) As Point2d
    Set oPoints(1) = oTransGeom.CreatePoint2d(0, 0)
    oFitPoints.Add oPoints(1)

    Set oPoints(2) = oTransGeom.CreatePoint2d(2, 2)
    oFitPoints.Add oPoints(2)

    Set oPoints(3) = oTransGeom.CreatePoint2d(4, 0)
    oFitPoints.Add oPoints(3)

    Set oPoints(4) = oTransGeom.CreatePoint2d(6, 4)
    oFitPoints.Add oPoints(4)

    Set oPoints(5) = oTransGeom.CreatePoint2d(7, -1)
    oFitPoints.Add oPoints(5)

    ' Create the spline.
    Dim oSpline As SketchSpline
    Set oSpline = oSketch.SketchSplines.Add(oFitPoints)

    ' Change the curve to be closed.
    oSpline.Closed = True

    ' Add a ground constraint to the third fit point.
    Call oSketch.GeometricConstraints.AddGround(oSpline.FitPoint(3))

    ' Add an additional fit point.
    Dim oNewPoint As Point2d
    Set oNewPoint = oTransGeom.CreatePoint2d(8, 8)
    Call oSpline.InsertFitPoint(oNewPoint, 5, True)

    ' Reposition the second fit point.
    Call oSpline.FitPoint(2).MoveTo(oTransGeom.CreatePoint2d(2, 3))

    ' Delete a fit point by deleting the underlying sketch point.
    oSpline.FitPoint(2).Delete
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface


SketchSpline Methods

SketchSpline Methods
Summary

The methods of the SketchSpline class are listed here.

Methods
Methods
Name | Description
FitPoint | Property that returns the SketchPoint at the specified index. The indices correspond to the fit points in order from the start to the end of the spline. An Index of 1 returns the first SketchPoint. The FitPointCount property returns the total number of fits points for the spline.
GetCustomLineType |
GetHandle | Method that returns the fit point handle at the given fit point. The method returns Nothing if the handle is not enabled at the input fit point.
GetHandleStatus | Method that returns whether the handle at a given fit point is enabled or disabled.
InsertFitPoint | Method that inserts a new fit point into the spline.
SetCustomLineType |
SetHandleStatus | Method that sets whether the handle at a given fit point is enabled or disabled.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods


SketchSpline.FitPoint Method

SketchSpline.FitPoint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the SketchPoint at the specified index. The indices correspond to the fit points in order from the start to the end of the spline. An Index of 1 returns the first SketchPoint. The FitPointCount property returns the total number of fits points for the spline.

Visual Basic
Sub FitPoint(Index As long, Result As [out, retval] SketchPoint*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the SketchPoint to return.
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.FitPoint Method


SketchSpline.GetCustomLineType Method

SketchSpline.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Notes

For information on this item, please refer to Layer::GetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.GetCustomLineType Method


SketchSpline.GetHandle Method

SketchSpline.GetHandle Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the fit point handle at the given fit point. The method returns Nothing if the handle is not enabled at the input fit point.

Visual Basic
Sub GetHandle(FitPoint As SketchPoint, Result As [out, retval] SketchSplineHandle*)
Parameters
Parameters | Description
FitPoint | Input SketchPoint object that specifies the fit point at which to obtain the handle.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.GetHandle Method


SketchSpline.GetHandleStatus Method

SketchSpline.GetHandleStatus Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether the handle at a given fit point is enabled or disabled.

Visual Basic
Sub GetHandleStatus(FitPoint As SketchPoint, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
FitPoint | Input SketchPoint object that specifies the fit point at which to get the handle status.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.GetHandleStatus Method


SketchSpline.InsertFitPoint Method

SketchSpline.InsertFitPoint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that inserts a new fit point into the spline.

Visual Basic
Sub InsertFitPoint(FitPoint As IDispatch, ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchPoint*)
Parameters
Parameters | Description
FitPoint | Input object that specifies the position of the new fit point. This can be either a SketchPoint or Point2d object. In the case where a Point2d object is input, a SketchPoint will be created at that location.
TargetIndex | Input Long that specifies the existing fit point to insert the new fit point next to.
InsertBefore | Input Boolean indicating if the fit point should be inserted before or after the target index.
See Also

Sketch Spline sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.InsertFitPoint Method


SketchSpline.SetCustomLineType Method

SketchSpline.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Notes

For information on this item, please refer to Layer::SetCustomLineType, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.SetCustomLineType Method


SketchSpline.SetHandleStatus Method

SketchSpline.SetHandleStatus Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets whether the handle at a given fit point is enabled or disabled.

Visual Basic
Sub SetHandleStatus(FitPoint As SketchPoint, Value As VARIANT_BOOL)
Parameters
Parameters | Description
FitPoint | Input SketchPoint object that specifies the fit point at which to set the handle status.
Value | Input Boolean that specifies whether the handle at the input fit point is enabled or disabled.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Methods > SketchSpline.SetHandleStatus Method


SketchSpline Properties

SketchSpline Properties
Summary

The properties of the SketchSpline class are listed here.

Properties
Name | Description
Closed | Property that gets and sets whether the curve is closed. Defining a curve to be closed will cause it to close and be periodic. A periodic curve is closed and curvature continuous at the closure.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.
EndSketchPoint | Property that gets the that defines the position of the end of the spline.
FitMethod | Property that returns the SketchPoint at the specified index. The indices correspond to the fit points in order from the start to the end of the spline. An Index of 1 returns the first SketchPoint. The FitPointCount property returns the total number of fits points for the spline.
FitPointCount | Property that returns the number of fit points for the spline.
Geometry | Property that returns a geometry object. The object returned represents a snapshot view of the current state of the sketch spline.
Length | Double property that returns the length of the entity in centimeters.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.
LineWeight | Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
OverrideColor | Gets and sets the color applied to this primitive.
StartSketchPoint | Property that returns the that defines the position of the start of the line.
Tension | Property that gets and sets the tension value of the spline. Splines are created with a default tension value of 0. The valid range is from 0 to 100.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties


SketchSpline.Closed Property

SketchSpline.Closed Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the curve is closed. Defining a curve to be closed will cause it to close and be periodic. A periodic curve is closed and curvature continuous at the closure.

Visual Basic
Property Closed() As VARIANT_BOOL
See Also

Sketch Spline sample

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.Closed Property


SketchSpline.CurvatureDisplay Property

SketchSpline.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets whether the curvature information is currently being displayed for this primitive. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.CurvatureDisplay Property


SketchSpline.EndSketchPoint Property

SketchSpline.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets the that defines the position of the end of the spline.

Visual Basic
Property EndSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.EndSketchPoint Property


SketchSpline.FitMethod Property

SketchSpline.FitMethod Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the SketchPoint at the specified index. The indices correspond to the fit points in order from the start to the end of the spline. An Index of 1 returns the first SketchPoint. The FitPointCount property returns the total number of fits points for the spline.

Visual Basic
Property FitMethod() As SplineFitMethodEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.FitMethod Property


SketchSpline.FitPointCount Property

SketchSpline.FitPointCount Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of fit points for the spline.

Visual Basic
Property FitPointCount() As long*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.FitPointCount Property


SketchSpline.Geometry Property

SketchSpline.Geometry Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a geometry object. The object returned represents a snapshot view of the current state of the sketch spline.

Visual Basic
Property Geometry() As BSplineCurve2d**
See Also

Spline - create NURBS sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.Geometry Property


SketchSpline.Length Property

SketchSpline.Length Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
See Also

Sketch Display Entities sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.Length Property


SketchSpline.LineDefinitionSpace Property

SketchSpline.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.LineDefinitionSpace Property


SketchSpline.LineScale Property

SketchSpline.LineScale Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.LineScale Property


SketchSpline.LineType Property

SketchSpline.LineType Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line type override. Setting the property to kDefaultLineType restores the default line type. If the property returns kCustomLineType, the GetCustomLineType method can be used to get further details about the line type.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.LineType Property


SketchSpline.LineWeight Property

SketchSpline.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the thickness of this primitive/object. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.LineWeight Property


SketchSpline.OverrideColor Property

SketchSpline.OverrideColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets and sets the color applied to this primitive.

Visual Basic
Property OverrideColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.OverrideColor Property


SketchSpline.StartSketchPoint Property

SketchSpline.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the that defines the position of the start of the line.

Visual Basic
Property StartSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.StartSketchPoint Property


SketchSpline.Tension Property

SketchSpline.Tension Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the tension value of the spline. Splines are created with a default tension value of 0. The valid range is from 0 to 100.

Visual Basic
Property Tension() As long
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline Interface > SketchSpline Properties > SketchSpline.Tension Property


SketchSpline3D Interface

SketchSpline3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchSpline3D object represents a spline within a 3D sketch. See the article in the overviews section.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchSpline3D
        Inventor::SketchSpline3DProxy
Visual Basic
Public Interface SketchSpline3D
Inherits SketchEntity3D
Notes

Members through which this object may be accessed include:

SketchFixedSpline3D.ConvertToSpline

SketchSpline3D.Split

SketchSpline3DProxy.NativeObject

SketchSplineHandle3D.Spline

SketchSplines3D.Add

SketchSplines3D.Item

SplineFitPointsConstraint3D.Spline

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface


SketchSpline3D Methods

SketchSpline3D Methods
Summary

The methods of the SketchSpline3D class are listed here.

Methods
Methods
Name | Description
Disconnect | Method that removes an existing fit point from the spline. This method can have the effect of deleting the sketch point if it is not associated with any other sketch entity.
FitPoint | Property that returns the at the specified index. The indices correspond to the fit points in order from the start to the end of the spline. An Index of 1 returns the first SketchPoint3D. The FitPointCount property returns the total number of fit points for the spline.
GetHandle | Method that returns the fit point handle at the given fit point. The method returns Nothing if the handle is not enabled at the input fit point.
GetHandleStatus | Method that returns whether the handle at a given fit point is enabled or disabled.
InsertFitPoint | Method that inserts a new fit point into the spline and returns the inserted fit point.
SetHandleStatus | Method that sets whether the handle at a given fit point is enabled or disabled.
Split | Method that splits the spline at the specified location. After the split, the original object (the one on which this method was called) represents the part of the spline associated with the original start point. The SketchSpline3D object returned by this method represents the part of the spline associated with the original end point. The curvature of the final result may differ from the original spline.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods


SketchSpline3D.Disconnect Method

SketchSpline3D.Disconnect Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that removes an existing fit point from the spline. This method can have the effect of deleting the sketch point if it is not associated with any other sketch entity.

Visual Basic
Sub Disconnect(FitPoint As VARIANT)
Parameters
Parameters | Description
FitPoint | Input Variant value that specifies the point to disconnect. This can be either a numeric value indicating the index of the fit point (the indices corresponding to the fit points in order from the start to the end of the spline, where the first fit point has an index of 1) or it can be an existing fit point.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.Disconnect Method


SketchSpline3D.FitPoint Method

SketchSpline3D.FitPoint Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the at the specified index. The indices correspond to the fit points in order from the start to the end of the spline. An Index of 1 returns the first SketchPoint3D. The FitPointCount property returns the total number of fit points for the spline.

Visual Basic
Sub FitPoint(Index As long, Result As [out, retval] SketchPoint3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the SketchPoint to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.FitPoint Method


SketchSpline3D.GetHandle Method

SketchSpline3D.GetHandle Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the fit point handle at the given fit point. The method returns Nothing if the handle is not enabled at the input fit point.

Visual Basic
Sub GetHandle(FitPoint As SketchPoint3D, Result As [out, retval] SketchSplineHandle3D*)
Parameters
Parameters | Description
FitPoint | Input SketchPoint3D object that specifies the fit point at which to obtain the handle.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.GetHandle Method


SketchSpline3D.GetHandleStatus Method

SketchSpline3D.GetHandleStatus Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns whether the handle at a given fit point is enabled or disabled.

Visual Basic
Sub GetHandleStatus(FitPoint As SketchPoint3D, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
FitPoint | Input SketchPoint3D object that specifies the fit point at which to get the handle status.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.GetHandleStatus Method


SketchSpline3D.InsertFitPoint Method

SketchSpline3D.InsertFitPoint Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that inserts a new fit point into the spline and returns the inserted fit point.

Visual Basic
Sub InsertFitPoint(FitPoint As IDispatch, ByRef TargetIndex As [defaultvalue(0)] long, ByRef InsertBefore As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SketchPoint3D*)
Parameters
Parameters | Description
FitPoint | Input object that specifies the position of the new fit point. This can be a , a SketchPoint, a workpoint or a vertex. If the input is not a SketchPoint3D object, a SketchPoint3D object is automatically created at the position of the input point.
TargetIndex | Optional input Long that specifies the existing fit point to insert the new fit point next to. If not supplied, this value defaults to 0. If the value is 0, then the new fit point is inserted between the two existing fit points that are closest to the new fit point.
InsertBefore | Optional input Boolean indicating if the fit point should be inserted before or after the target index. The default is true, meaning that the new fit point will be inserted before the target index. This Boolean is ignored if the TargetIndex specified is 0.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.InsertFitPoint Method


SketchSpline3D.SetHandleStatus Method

SketchSpline3D.SetHandleStatus Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets whether the handle at a given fit point is enabled or disabled.

Visual Basic
Sub SetHandleStatus(FitPoint As SketchPoint3D, Value As VARIANT_BOOL)
Parameters
Parameters | Description
FitPoint | Input SketchPoint3D object that specifies the fit point at which to set the handle status.
Value | Input Boolean that specifies whether the handle at the input fit point is enabled or disabled.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.SetHandleStatus Method


SketchSpline3D.Split Method

SketchSpline3D.Split Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that splits the spline at the specified location. After the split, the original object (the one on which this method was called) represents the part of the spline associated with the original start point. The SketchSpline3D object returned by this method represents the part of the spline associated with the original end point. The curvature of the final result may differ from the original spline.

Visual Basic
Sub Split(FitPoint As VARIANT, Result As [out, retval] SketchSpline3D*)
Parameters
Parameters | Description
FitPoint | Input Variant value that specifies the location at which to split the spline. This can be either a numeric value indicating the index of the fit point (the indices corresponding to the fit points in order from the start to the end of the spline, where the first fit point has an index of 1) or it can be an existing fit point.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Methods > SketchSpline3D.Split Method


SketchSpline3D Properties

SketchSpline3D Properties
Summary

The properties of the SketchSpline3D class are listed here.

Properties
Name | Description
Closed | Property that gets and sets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.
CurvatureDisplay | Property that gets and sets whether the curvature information is currently being displayed for the spline. True indicates the curvature is displayed.
EndSketchPoint | Property that gets the that defines the position of the end of the spline.
EndTangentScale | Gets and sets the tangent scale parameter at the end point of the spline.
FitMethod | Property that gets and sets the fit method used for the spline.
FitPointCount | Property that returns the number of fit points for the spline.
Geometry | Property that gets and sets the BSplineCurve geometry object. The object returned represents a 'snapshot' view of the current state of the sketch spline. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.
Length | Double property that returns the length of the entity in centimeters.
StartSketchPoint | Property that returns the that defines the position of the start of the spline.
StartTangentScale | Gets and sets the tangent scale parameter at the start point of the spline.
Tension | Property that gets and sets the tension value of the spline. Splines are created with a default tension value of 0. The valid range is from 0 to 100.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties


SketchSpline3D.Closed Property

SketchSpline3D.Closed Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether the curve is closed. A periodic curve is closed and curvature continuous at the closure.

Visual Basic
Property Closed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.Closed Property


SketchSpline3D.CurvatureDisplay Property

SketchSpline3D.CurvatureDisplay Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets whether the curvature information is currently being displayed for the spline. True indicates the curvature is displayed.

Visual Basic
Property CurvatureDisplay() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.CurvatureDisplay Property


SketchSpline3D.EndSketchPoint Property

SketchSpline3D.EndSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets the that defines the position of the end of the spline.

Visual Basic
Property EndSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.EndSketchPoint Property


SketchSpline3D.EndTangentScale Property

SketchSpline3D.EndTangentScale Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets and sets the tangent scale parameter at the end point of the spline.

Visual Basic
Property EndTangentScale() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.EndTangentScale Property


SketchSpline3D.FitMethod Property

SketchSpline3D.FitMethod Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the fit method used for the spline.

Visual Basic
Property FitMethod() As SplineFitMethodEnum
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.FitMethod Property


SketchSpline3D.FitPointCount Property

SketchSpline3D.FitPointCount Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the number of fit points for the spline.

Visual Basic
Property FitPointCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.FitPointCount Property


SketchSpline3D.Geometry Property

SketchSpline3D.Geometry Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the BSplineCurve geometry object. The object returned represents a 'snapshot' view of the current state of the sketch spline. While setting the property, the movement of the sketch entity is limited by the constraints currently defined on the sketch.

Visual Basic
Property Geometry() As BSplineCurve*
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.Geometry Property


SketchSpline3D.Length Property

SketchSpline3D.Length Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Double property that returns the length of the entity in centimeters.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.Length Property


SketchSpline3D.StartSketchPoint Property

SketchSpline3D.StartSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the that defines the position of the start of the spline.

Visual Basic
Property StartSketchPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.StartSketchPoint Property


SketchSpline3D.StartTangentScale Property

SketchSpline3D.StartTangentScale Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets and sets the tangent scale parameter at the start point of the spline.

Visual Basic
Property StartTangentScale() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.StartTangentScale Property


SketchSpline3D.Tension Property

SketchSpline3D.Tension Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the tension value of the spline. Splines are created with a default tension value of 0. The valid range is from 0 to 100.

Visual Basic
Property Tension() As long
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3D Interface > SketchSpline3D Properties > SketchSpline3D.Tension Property


SketchSpline3DProxy Interface

SketchSpline3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSpline3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchSpline3D
        Inventor::SketchSpline3DProxy
Visual Basic
Public Interface SketchSpline3DProxy
Inherits SketchSpline3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3DProxy Interface


SketchSpline3DProxy Properties

SketchSpline3DProxy Properties
Summary

The properties of the SketchSpline3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3DProxy Interface > SketchSpline3DProxy Properties


SketchSpline3DProxy.ContainingOccurrence Property

SketchSpline3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3DProxy Interface > SketchSpline3DProxy Properties > SketchSpline3DProxy.ContainingOccurrence Property


SketchSpline3DProxy.NativeObject Property

SketchSpline3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchSpline3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSpline3DProxy Interface > SketchSpline3DProxy Properties > SketchSpline3DProxy.NativeObject Property


SketchSplineHandle Interface

SketchSplineHandle Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The SketchSplineHandle object represents a spline handle within a sketch at a spline fit point.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchLine
        Inventor::SketchSplineHandle
            Inventor::SketchSplineHandleProxy
Visual Basic
Public Interface SketchSplineHandle
Inherits SketchLine
Remarks

The properties and methods listed below are in addition to those supported by the SketchLine object.

Notes

Members through which this object may be accessed include:

SketchSpline.GetHandle

SketchSplineHandleProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle Interface


SketchSplineHandle Properties

SketchSplineHandle Properties
Summary

The properties of the SketchSplineHandle class are listed here.

Properties
Name | Description
FitPoint | Property that returns the fit point associated with the handle.
Spline | Property that returns the spline associated with the handle.
Tangent | Property that gets and sets the unit vector at the fit point associated with the handle.
Weight | Property that gets and sets the weight of the tangent at the fit point associated with the handle.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle Interface > SketchSplineHandle Properties


SketchSplineHandle.FitPoint Property

SketchSplineHandle.FitPoint Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the fit point associated with the handle.

Visual Basic
Property FitPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle Interface > SketchSplineHandle Properties > SketchSplineHandle.FitPoint Property


SketchSplineHandle.Spline Property

SketchSplineHandle.Spline Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the spline associated with the handle.

Visual Basic
Property Spline() As SketchSpline**
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle Interface > SketchSplineHandle Properties > SketchSplineHandle.Spline Property


SketchSplineHandle.Tangent Property

SketchSplineHandle.Tangent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the unit vector at the fit point associated with the handle.

Visual Basic
Property Tangent() As UnitVector2d*
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle Interface > SketchSplineHandle Properties > SketchSplineHandle.Tangent Property


SketchSplineHandle.Weight Property

SketchSplineHandle.Weight Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the weight of the tangent at the fit point associated with the handle.

Visual Basic
Property Weight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle Interface > SketchSplineHandle Properties > SketchSplineHandle.Weight Property


SketchSplineHandle3D Interface

SketchSplineHandle3D Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The SketchSplineHandle3D object represents a spline handle within a 3D sketch at a spline fit point.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchLine3D
        Inventor::SketchSplineHandle3D
            Inventor::SketchSplineHandle3DProxy
Visual Basic
Public Interface SketchSplineHandle3D
Inherits SketchLine3D
Notes

Members through which this object may be accessed include:

SketchSpline3D.GetHandle

SketchSplineHandle3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3D Interface


SketchSplineHandle3D Properties

SketchSplineHandle3D Properties
Summary

The properties of the SketchSplineHandle3D class are listed here.

Properties
Name | Description
FitPoint | Property that returns the fit point associated with the handle.
Spline | Property that returns the spline associated with the handle.
Tangent | Property that gets and sets the unit vector at the fit point associated with the handle.
Weight | Property that gets and sets the weight of the tangent at the fit point associated with the handle.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3D Interface > SketchSplineHandle3D Properties


SketchSplineHandle3D.FitPoint Property

SketchSplineHandle3D.FitPoint Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the fit point associated with the handle.

Visual Basic
Property FitPoint() As SketchPoint3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3D Interface > SketchSplineHandle3D Properties > SketchSplineHandle3D.FitPoint Property


SketchSplineHandle3D.Spline Property

SketchSplineHandle3D.Spline Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the spline associated with the handle.

Visual Basic
Property Spline() As SketchSpline3D**
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3D Interface > SketchSplineHandle3D Properties > SketchSplineHandle3D.Spline Property


SketchSplineHandle3D.Tangent Property

SketchSplineHandle3D.Tangent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the unit vector at the fit point associated with the handle.

Visual Basic
Property Tangent() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3D Interface > SketchSplineHandle3D Properties > SketchSplineHandle3D.Tangent Property


SketchSplineHandle3D.Weight Property

SketchSplineHandle3D.Weight Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the weight of the tangent at the fit point associated with the handle.

Visual Basic
Property Weight() As double
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3D Interface > SketchSplineHandle3D Properties > SketchSplineHandle3D.Weight Property


SketchSplineHandle3DProxy Interface

SketchSplineHandle3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSplineHandle3D object.

Class Hierarchy
Inventor::SketchEntity3D
    Inventor::SketchLine3D
        Inventor::SketchSplineHandle3D
            Inventor::SketchSplineHandle3DProxy
Visual Basic
Public Interface SketchSplineHandle3DProxy
Inherits SketchSplineHandle3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3DProxy Interface


SketchSplineHandle3DProxy Properties

SketchSplineHandle3DProxy Properties
Summary

The properties of the SketchSplineHandle3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3DProxy Interface > SketchSplineHandle3DProxy Properties


SketchSplineHandle3DProxy.ContainingOccurrence Property

SketchSplineHandle3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3DProxy Interface > SketchSplineHandle3DProxy Properties > SketchSplineHandle3DProxy.ContainingOccurrence Property


SketchSplineHandle3DProxy.NativeObject Property

SketchSplineHandle3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchSplineHandle3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandle3DProxy Interface > SketchSplineHandle3DProxy Properties > SketchSplineHandle3DProxy.NativeObject Property


SketchSplineHandleProxy Interface

SketchSplineHandleProxy Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSplineHandle object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchLine
        Inventor::SketchSplineHandle
            Inventor::SketchSplineHandleProxy
Visual Basic
Public Interface SketchSplineHandleProxy
Inherits SketchSplineHandle
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandleProxy Interface


SketchSplineHandleProxy Properties

SketchSplineHandleProxy Properties
Summary

The properties of the SketchSplineHandleProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandleProxy Interface > SketchSplineHandleProxy Properties


SketchSplineHandleProxy.ContainingOccurrence Property

SketchSplineHandleProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandleProxy Interface > SketchSplineHandleProxy Properties > SketchSplineHandleProxy.ContainingOccurrence Property


SketchSplineHandleProxy.NativeObject Property

SketchSplineHandleProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchSplineHandle**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineHandleProxy Interface > SketchSplineHandleProxy Properties > SketchSplineHandleProxy.NativeObject Property


SketchSplineProxy Interface

SketchSplineProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SketchSpline object.

Class Hierarchy
Inventor::SketchEntity
    Inventor::SketchSpline
        Inventor::SketchSplineProxy
Visual Basic
Public Interface SketchSplineProxy
Inherits SketchSpline
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineProxy Interface


SketchSplineProxy Properties

SketchSplineProxy Properties
Summary

The properties of the SketchSplineProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplineProxy Interface > SketchSplineProxy Properties


SketchSplineProxy.ContainingOccurrence Property

SketchSplineProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineProxy Interface > SketchSplineProxy Properties > SketchSplineProxy.ContainingOccurrence Property


SketchSplineProxy.NativeObject Property

SketchSplineProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SketchSpline**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SketchSplineProxy Interface > SketchSplineProxy Properties > SketchSplineProxy.NativeObject Property


SketchSplines Interface

SketchSplines Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SketchSplines object provides access to all the objects in a sketch and provides methods to create additional sketch splines. See the article in the overviews section.

Class Hierarchy
Inventor::SketchSplines
Visual Basic
Public Interface SketchSplines
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.SketchSplines

See Also

Spline - create NURBS sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface


SketchSplines Methods

SketchSplines Methods
Summary

The methods of the SketchSplines class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a sketch spline through the set of input points.
Item | Property that returns the specified SketchSpline object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Methods


SketchSplines.Add Method

SketchSplines.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a sketch spline through the set of input points.

Visual Basic
Sub Add(FitPoints As ObjectCollection, ByRef FitMethod As [defaultvalue(kSweetSplineFit)] SplineFitMethodEnum, Result As [out, retval] SketchSpline*)
Parameters
Parameters | Description
FitPoints | Input ObjectCollection that contains the set of points to fit the curve through. The points can be either existing SketchPoint objects or Point2d objects. If a Point2d object is input a SketchPoint is automatically created at that position. The curve passes through all of the fit points and is related to them by SplineFitPointConstraints, which are also automatically created.
FitMethod | Property that indicates the fit method (SplineFitMethodEnum) used for the spline.
See Also

Sketch Spline sample

Spline - create NURBS sample

You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Methods > SketchSplines.Add Method


SketchSplines.Item Method

SketchSplines.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SketchSpline object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchSpline*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Methods > SketchSplines.Item Method


SketchSplines Properties

SketchSplines Properties
Summary

The properties of the SketchSplines class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Properties


SketchSplines.Application Property

SketchSplines.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Properties > SketchSplines.Application Property


SketchSplines.Count Property

SketchSplines.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Properties > SketchSplines.Count Property


SketchSplines.Type Property

SketchSplines.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines Interface > SketchSplines Properties > SketchSplines.Type Property


SketchSplines3D Interface

SketchSplines3D Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The SketchSplines3D object provides access to all the objects in a sketch and provides methods to create additional sketch splines. See the article in the overviews section.

Class Hierarchy
Inventor::SketchSplines3D
Visual Basic
Public Interface SketchSplines3D
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch3D.SketchSplines3D

You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface


SketchSplines3D Methods

SketchSplines3D Methods
Summary

The methods of the SketchSplines3D class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a sketch spline through the set of input points.
Item | Property that returns the specified SketchSpline3D object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Methods


SketchSplines3D.Add Method

SketchSplines3D.Add Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that creates a sketch spline through the set of input points.

Visual Basic
Sub Add(FitPoints As ObjectCollection, ByRef FitMethod As [defaultvalue(kSweetSplineFit)] SplineFitMethodEnum, Result As [out, retval] SketchSpline3D*)
Parameters
Parameters | Description
FitPoints | Input that contains the set of points to fit the curve through. The points can be either existing SketchPoint3D objects, SketchPointobjects, workpoints or vertices. If the input is not a SketchPoint3D object, a SketchPoint3D object is automatically created at the position of the input point. The curve passes through all of the fit points and is related to them by the SplineFitPointsConstraint3D object, which is also automatically created.
FitMethod | Property that indicates the fit method (SplineFitMethodEnum) used for the spline.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Methods > SketchSplines3D.Add Method


SketchSplines3D.Item Method

SketchSplines3D.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified SketchSpline3D object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] SketchSpline3D*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Methods > SketchSplines3D.Item Method


SketchSplines3D Properties

SketchSplines3D Properties
Summary

The properties of the SketchSplines3D class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Properties


SketchSplines3D.Application Property

SketchSplines3D.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Properties > SketchSplines3D.Application Property


SketchSplines3D.Count Property

SketchSplines3D.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Properties > SketchSplines3D.Count Property


SketchSplines3D.Type Property

SketchSplines3D.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SketchSplines3D Interface > SketchSplines3D Properties > SketchSplines3D.Type Property


SmoothConstraint Interface

SmoothConstraint Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SmoothConstraint object represents a smooth (G2-continuous) constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::SmoothConstraint
        Inventor::SmoothConstraintProxy
Visual Basic
Public Interface SmoothConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddSmooth

SmoothConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint Interface


SmoothConstraint Properties

SmoothConstraint Properties
Summary

The properties of the SmoothConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity two.
EntityTwo | Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity one.
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint Interface > SmoothConstraint Properties


SmoothConstraint.EntityOne Property

SmoothConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity two.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint Interface > SmoothConstraint Properties > SmoothConstraint.EntityOne Property


SmoothConstraint.EntityTwo Property

SmoothConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity one.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint Interface > SmoothConstraint Properties > SmoothConstraint.EntityTwo Property


SmoothConstraint3D Interface

SmoothConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SmoothConstraint3D object represents a smooth (G2-continuous) constraint within a 3d sketch.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::SmoothConstraint3D
        Inventor::SmoothConstraint3DProxy
Visual Basic
Public Interface SmoothConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.AddSmooth

SmoothConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3D Interface


SmoothConstraint3D Properties

SmoothConstraint3D Properties
Summary

The properties of the SmoothConstraint3D class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity two.
EntityTwo | Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity one.
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3D Interface > SmoothConstraint3D Properties


SmoothConstraint3D.EntityOne Property

SmoothConstraint3D.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity two.

Visual Basic
Property EntityOne() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3D Interface > SmoothConstraint3D Properties > SmoothConstraint3D.EntityOne Property


SmoothConstraint3D.EntityTwo Property

SmoothConstraint3D.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the sketch entity that is constrained to be smooth (G2-continuous) to entity one.

Visual Basic
Property EntityTwo() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3D Interface > SmoothConstraint3D Properties > SmoothConstraint3D.EntityTwo Property


SmoothConstraint3DProxy Interface

SmoothConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SmoothConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::SmoothConstraint3D
        Inventor::SmoothConstraint3DProxy
Visual Basic
Public Interface SmoothConstraint3DProxy
Inherits SmoothConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3DProxy Interface


SmoothConstraint3DProxy Properties

SmoothConstraint3DProxy Properties
Summary

The properties of the SmoothConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3DProxy Interface > SmoothConstraint3DProxy Properties


SmoothConstraint3DProxy.ContainingOccurrence Property

SmoothConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3DProxy Interface > SmoothConstraint3DProxy Properties > SmoothConstraint3DProxy.ContainingOccurrence Property


SmoothConstraint3DProxy.NativeObject Property

SmoothConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SmoothConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraint3DProxy Interface > SmoothConstraint3DProxy Properties > SmoothConstraint3DProxy.NativeObject Property


SmoothConstraintProxy Interface

SmoothConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SmoothConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::SmoothConstraint
        Inventor::SmoothConstraintProxy
Visual Basic
Public Interface SmoothConstraintProxy
Inherits SmoothConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraintProxy Interface


SmoothConstraintProxy Properties

SmoothConstraintProxy Properties
Summary

The properties of the SmoothConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraintProxy Interface > SmoothConstraintProxy Properties


SmoothConstraintProxy.ContainingOccurrence Property

SmoothConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraintProxy Interface > SmoothConstraintProxy Properties > SmoothConstraintProxy.ContainingOccurrence Property


SmoothConstraintProxy.NativeObject Property

SmoothConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SmoothConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SmoothConstraintProxy Interface > SmoothConstraintProxy Properties > SmoothConstraintProxy.NativeObject Property


SnapFitFeature Interface

SnapFitFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SnapFitFeature object represents a snap fit feature within the model.

Class Hierarchy
Inventor::PartFeature
    Inventor::SnapFitFeature
        Inventor::SnapFitFeatureProxy
Visual Basic
Public Interface SnapFitFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

SnapFitFeatureProxy.NativeObject

SnapFitFeatures.Item

Most functionality reserved for future implementation.

You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeature Interface


SnapFitFeatureProxy Interface

SnapFitFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SnapFitFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::SnapFitFeature
        Inventor::SnapFitFeatureProxy
Visual Basic
Public Interface SnapFitFeatureProxy
Inherits SnapFitFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatureProxy Interface


SnapFitFeatureProxy Properties

SnapFitFeatureProxy Properties
Summary

The properties of the SnapFitFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatureProxy Interface > SnapFitFeatureProxy Properties


SnapFitFeatureProxy.ContainingOccurrence Property

SnapFitFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatureProxy Interface > SnapFitFeatureProxy Properties > SnapFitFeatureProxy.ContainingOccurrence Property


SnapFitFeatureProxy.NativeObject Property

SnapFitFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SnapFitFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatureProxy Interface > SnapFitFeatureProxy Properties > SnapFitFeatureProxy.NativeObject Property


SnapFitFeatures Interface

SnapFitFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The SnapFitFeatures collection object provides access to existing snap fit features.

Class Hierarchy
Inventor::SnapFitFeatures
Visual Basic
Public Interface SnapFitFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.SnapFitFeatures

You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface


SnapFitFeatures Methods

SnapFitFeatures Methods
Summary

The methods of the SnapFitFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface > SnapFitFeatures Methods


SnapFitFeatures.Item Method

SnapFitFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SnapFitFeature*)
Parameters
Parameters | Description
index | Specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection, or a String indicating the name of the object within the collection.
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface > SnapFitFeatures Methods > SnapFitFeatures.Item Method


SnapFitFeatures Properties

SnapFitFeatures Properties
Summary

The properties of the SnapFitFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface > SnapFitFeatures Properties


SnapFitFeatures.Application Property

SnapFitFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface > SnapFitFeatures Properties > SnapFitFeatures.Application Property


SnapFitFeatures.Count Property

SnapFitFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface > SnapFitFeatures Properties > SnapFitFeatures.Count Property


SnapFitFeatures.Type Property

SnapFitFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SnapFitFeatures Interface > SnapFitFeatures Properties > SnapFitFeatures.Type Property


SoftwareVersion Interface

SoftwareVersion Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that encapsulates a given software version. Used in various contexts.

Class Hierarchy
Inventor::SoftwareVersion
Visual Basic
Public Interface SoftwareVersion
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.SoftwareVersion

ApprenticeServerDocument.SoftwareVersionCreated

ApprenticeServerDocument.SoftwareVersionSaved

Document.SoftwareVersionCreated

Document.SoftwareVersionSaved

FileManager.SoftwareVersionSaved

Application.SoftwareVersion

You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface


SoftwareVersion Properties

SoftwareVersion Properties
Summary

The properties of the SoftwareVersion class are listed here.

Properties
Name | Description
BetaVersion | Gets the Beta version. If this is not a Beta version software, this value will be zero.
BuildIdentifier | Gets the number that completely identifies a particular build of Autodesk Inventor.
DisplayName | Gets the human-readable, displayable name designating this particular version (e.g.: 'Autodesk Inventor (tm) Release 2.5 Service Pack 3').
DisplayVersion | Returns the release version displayed to users. (e.g.: '2009' for Major version 13 or '2010' for Major version 14)
Is64BitVersion | Always false in 32-bit Inventor. Use this property to find out whether your code is connected to a 64-bit version of Inventor.
IsEducationVersion | Returns whether this is an educational versions of Inventor.
Major | Gets the Major release number (e.g.: Release '1', '2', ...).
Minor | Gets the Minor release number. If none, a zero is returned. (e.g.: the '5' in release 1.5).
NotProduction | Gets a Boolean flag indicating whether this software is intended for purely internal purposes or not. Beta is considered external.
ProductEdition | Gets the product edition. Only valid when SoftwareVersion is obtained from the Application.
ProductName | This is ProductName, a member of class SoftwareVersion.
ServicePack | Gets the number of the Service Pack if this software has been updated with such. If none, a zero is returned. (e.g.: the '3' in Release 2.5 Service Pack 3).
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties


SoftwareVersion.BetaVersion Property

SoftwareVersion.BetaVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Beta version. If this is not a Beta version software, this value will be zero.

Visual Basic
Property BetaVersion() As long*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.BetaVersion Property


SoftwareVersion.BuildIdentifier Property

SoftwareVersion.BuildIdentifier Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the number that completely identifies a particular build of Autodesk Inventor.

Visual Basic
Property BuildIdentifier() As long*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.BuildIdentifier Property


SoftwareVersion.DisplayName Property

SoftwareVersion.DisplayName Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the human-readable, displayable name designating this particular version (e.g.: 'Autodesk Inventor (tm) Release 2.5 Service Pack 3').

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.DisplayName Property


SoftwareVersion.DisplayVersion Property

SoftwareVersion.DisplayVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Returns the release version displayed to users. (e.g.: '2009' for Major version 13 or '2010' for Major version 14)

Visual Basic
Property DisplayVersion() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.DisplayVersion Property


SoftwareVersion.Is64BitVersion Property

SoftwareVersion.Is64BitVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Always false in 32-bit Inventor. Use this property to find out whether your code is connected to a 64-bit version of Inventor.

Visual Basic
Property Is64BitVersion() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.Is64BitVersion Property


SoftwareVersion.IsEducationVersion Property

SoftwareVersion.IsEducationVersion Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns whether this is an educational versions of Inventor.

Visual Basic
Property IsEducationVersion() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.IsEducationVersion Property


SoftwareVersion.Major Property

SoftwareVersion.Major Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Major release number (e.g.: Release '1', '2', ...).

Visual Basic
Property Major() As long*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.Major Property


SoftwareVersion.Minor Property

SoftwareVersion.Minor Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Minor release number. If none, a zero is returned. (e.g.: the '5' in release 1.5).

Visual Basic
Property Minor() As long*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.Minor Property


SoftwareVersion.NotProduction Property

SoftwareVersion.NotProduction Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets a Boolean flag indicating whether this software is intended for purely internal purposes or not. Beta is considered external.

Visual Basic
Property NotProduction() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.NotProduction Property


SoftwareVersion.ProductEdition Property

SoftwareVersion.ProductEdition Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets the product edition. Only valid when SoftwareVersion is obtained from the Application.

Visual Basic
Property ProductEdition() As ProductEditionEnum*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.ProductEdition Property


SoftwareVersion.ProductName Property

SoftwareVersion.ProductName Property
Summary

This is ProductName, a member of class SoftwareVersion.

Visual Basic
Property ProductName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.ProductName Property


SoftwareVersion.ServicePack Property

SoftwareVersion.ServicePack Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the number of the Service Pack if this software has been updated with such. If none, a zero is returned. (e.g.: the '3' in Release 2.5 Service Pack 3).

Visual Basic
Property ServicePack() As long*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.ServicePack Property


SoftwareVersion.Type Property

SoftwareVersion.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SoftwareVersion Interface > SoftwareVersion Properties > SoftwareVersion.Type Property


Sphere Interface

Sphere Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Sphere object. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::Sphere
Visual Basic
Public Interface Sphere
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateSphere

Face.Geometry

FaceDefinition.SurfaceGeometry

You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface


Sphere Methods

Sphere Methods
Summary

The methods of the Sphere class are listed here.

Methods
Methods
Name | Description
GetSphereData | Get the data defining this sphere.
PutSphereData | Method that sets the data defining this sphere.
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Methods


Sphere.GetSphereData Method

Sphere.GetSphereData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this sphere.

Visual Basic
Sub GetSphereData(ByRef CenterPoint As SAFEARRAY(double), ByRef Radius As double)
Parameters
Parameters | Description
CenterPoint | Input/output Double that specifies the center point.
Radius | Output Double that specifies the radius of the sphere.
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Methods > Sphere.GetSphereData Method


Sphere.PutSphereData Method

Sphere.PutSphereData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this sphere.

Visual Basic
Sub PutSphereData(ByRef CenterPoint As SAFEARRAY(double), Radius As double)
Parameters
Parameters | Description
CenterPoint | Input/output Double that specifies the center point.
Radius | Input Double that specifies the radius of the sphere.
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Methods > Sphere.PutSphereData Method


Sphere Properties

Sphere Properties
Summary

The properties of the Sphere class are listed here.

Properties
Name | Description
CenterPoint | Specifies the center of the sphere.
Evaluator | Gets the surface evaluator for this sphere.
Radius | Specifies the radius of the sphere.
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Properties


Sphere.CenterPoint Property

Sphere.CenterPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the center of the sphere.

Visual Basic
Property CenterPoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Properties > Sphere.CenterPoint Property


Sphere.Evaluator Property

Sphere.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this sphere.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Properties > Sphere.Evaluator Property


Sphere.Radius Property

Sphere.Radius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the radius of the sphere.

Visual Basic
Property Radius() As double
You are here: Symbol Reference > Inventor Library > Objects > Sphere Interface > Sphere Properties > Sphere.Radius Property


SpiralCoilExtent Interface

SpiralCoilExtent Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The SpiralCoilExtent object provides access to the information that defines the variables for a spiral coil feature.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::SpiralCoilExtent
Visual Basic
Public Interface SpiralCoilExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > SpiralCoilExtent Interface


SpiralCoilExtent Properties

SpiralCoilExtent Properties
Summary

The properties of the SpiralCoilExtent class are listed here.

Properties
Name | Description
Pitch | Property that returns the parameter that controls the pitch of the coil feature.
Revolution | Property that returns the parameter that controls the number of revolutions of the coil feature.
You are here: Symbol Reference > Inventor Library > Objects > SpiralCoilExtent Interface > SpiralCoilExtent Properties


SpiralCoilExtent.Pitch Property

SpiralCoilExtent.Pitch Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the pitch of the coil feature.

Visual Basic
Property Pitch() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > SpiralCoilExtent Interface > SpiralCoilExtent Properties > SpiralCoilExtent.Pitch Property


SpiralCoilExtent.Revolution Property

SpiralCoilExtent.Revolution Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the number of revolutions of the coil feature.

Visual Basic
Property Revolution() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > SpiralCoilExtent Interface > SpiralCoilExtent Properties > SpiralCoilExtent.Revolution Property


SplineFitPointConstraint Interface

SplineFitPointConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SplineFitPointConstraint object represents a constraint that makes a spline fit through a specified sketch point. This constraint is created automatically when a spline is created or when new fit points are added to a spline.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::SplineFitPointConstraint
        Inventor::SplineFitPointConstraintProxy
Visual Basic
Public Interface SplineFitPointConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

SplineFitPointConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraint Interface


SplineFitPointConstraint Properties

SplineFitPointConstraint Properties
Summary

The properties of the SplineFitPointConstraint class are listed here.

Properties
Name | Description
Point | Property that returns the sketch point the spline is fit through.
Spline | Property that returns the spline entity being constrained.
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraint Interface > SplineFitPointConstraint Properties


SplineFitPointConstraint.Point Property

SplineFitPointConstraint.Point Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch point the spline is fit through.

Visual Basic
Property Point() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraint Interface > SplineFitPointConstraint Properties > SplineFitPointConstraint.Point Property


SplineFitPointConstraint.Spline Property

SplineFitPointConstraint.Spline Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the spline entity being constrained.

Visual Basic
Property Spline() As SketchSpline**
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraint Interface > SplineFitPointConstraint Properties > SplineFitPointConstraint.Spline Property


SplineFitPointConstraintProxy Interface

SplineFitPointConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SplineFitPointConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::SplineFitPointConstraint
        Inventor::SplineFitPointConstraintProxy
Visual Basic
Public Interface SplineFitPointConstraintProxy
Inherits SplineFitPointConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraintProxy Interface


SplineFitPointConstraintProxy Properties

SplineFitPointConstraintProxy Properties
Summary

The properties of the SplineFitPointConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraintProxy Interface > SplineFitPointConstraintProxy Properties


SplineFitPointConstraintProxy.ContainingOccurrence Property

SplineFitPointConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraintProxy Interface > SplineFitPointConstraintProxy Properties > SplineFitPointConstraintProxy.ContainingOccurrence Property


SplineFitPointConstraintProxy.NativeObject Property

SplineFitPointConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SplineFitPointConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointConstraintProxy Interface > SplineFitPointConstraintProxy Properties > SplineFitPointConstraintProxy.NativeObject Property


SplineFitPointsConstraint3D Interface

SplineFitPointsConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The SplineFitPointsConstraint3D object represents a constraint that makes a spline fit through a series of specified sketch points. This constraint is created automatically when a spline is created.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::SplineFitPointsConstraint3D
        Inventor::SplineFitPointsConstraint3DProxy
Visual Basic
Public Interface SplineFitPointsConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

SplineFitPointsConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3D Interface


SplineFitPointsConstraint3D Properties

SplineFitPointsConstraint3D Properties
Summary

The properties of the SplineFitPointsConstraint3D class are listed here.

Properties
Name | Description
Points | Property that returns the sketch points the spline is fit through.
Spline | Property that returns the spline entity being constrained.
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3D Interface > SplineFitPointsConstraint3D Properties


SplineFitPointsConstraint3D.Points Property

SplineFitPointsConstraint3D.Points Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the sketch points the spline is fit through.

Visual Basic
Property Points() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3D Interface > SplineFitPointsConstraint3D Properties > SplineFitPointsConstraint3D.Points Property


SplineFitPointsConstraint3D.Spline Property

SplineFitPointsConstraint3D.Spline Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the spline entity being constrained.

Visual Basic
Property Spline() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3D Interface > SplineFitPointsConstraint3D Properties > SplineFitPointsConstraint3D.Spline Property


SplineFitPointsConstraint3DProxy Interface

SplineFitPointsConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SplineFitPointsConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::SplineFitPointsConstraint3D
        Inventor::SplineFitPointsConstraint3DProxy
Visual Basic
Public Interface SplineFitPointsConstraint3DProxy
Inherits SplineFitPointsConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3DProxy Interface


SplineFitPointsConstraint3DProxy Properties

SplineFitPointsConstraint3DProxy Properties
Summary

The properties of the SplineFitPointsConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3DProxy Interface > SplineFitPointsConstraint3DProxy Properties


SplineFitPointsConstraint3DProxy.ContainingOccurrence Property

SplineFitPointsConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3DProxy Interface > SplineFitPointsConstraint3DProxy Properties > SplineFitPointsConstraint3DProxy.ContainingOccurrence Property


SplineFitPointsConstraint3DProxy.NativeObject Property

SplineFitPointsConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SplineFitPointsConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SplineFitPointsConstraint3DProxy Interface > SplineFitPointsConstraint3DProxy Properties > SplineFitPointsConstraint3DProxy.NativeObject Property


SplitFeature Interface

SplitFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Part SplitFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::SplitFeature
        Inventor::SplitFeatureProxy
Visual Basic
Public Interface SplitFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

SplitFeatureProxy.NativeObject

SplitFeatures.Item

SplitFeatures.SplitBody

SplitFeatures.SplitFaces

SplitFeatures.SplitPart

SplitFeatures.TrimSolid

You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface


SplitFeature Methods

SplitFeature Methods
Summary

The methods of the SplitFeature class are listed here.

Methods
Methods
Name | Description
SetToSplitBody | Method that changes the SplitFeature type to kSplitBody. The original body is consumed by the operation and two new bodies are created.
SetToSplitFaces | Method that changes the SplitFeature type to kSplitFaces.
SetToTrimSolid | Method that changes the SplitFeature type to kTrimSolid. The specified portion of the solid is removed.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Methods


SplitFeature.SetToSplitBody Method

SplitFeature.SetToSplitBody Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the SplitFeature type to kSplitBody. The original body is consumed by the operation and two new bodies are created.

Visual Basic
Sub SetToSplitBody(SplitTool As IDispatch, Body As SurfaceBody)
Parameters
Parameters | Description
SplitTool | Input Object that specifies the entity that will be used to define the split. The input can be a WorkPlane, WorkSurface, or 2D Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
Body | Input SurfaceBody object that specifies the body to be split.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Methods > SplitFeature.SetToSplitBody Method


SplitFeature.SetToSplitFaces Method

SplitFeature.SetToSplitFaces Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that changes the SplitFeature type to kSplitFaces.

Visual Basic
Sub SetToSplitFaces(SplitTool As IDispatch, ByRef SplitAll As [defaultvalue(-1)] VARIANT_BOOL, ByRef FacesOrBody As [optional] VARIANT)
Parameters
Parameters | Description
SplitTool | Input Object that defines the parting line for the split. The input can be a WorkPlane, WorkSurface, SurfaceBody or a Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
SplitAll | Optional input Boolean that indicates whether to split all the faces possible on the part. The default is true indicating that all possible faces will be split. If False, the FacesOrBody argument must be supplied as an ObjectCollection and must contain atleast one face.
FacesOrBody | Optional input Variant that specifies either an ObjectCollection containing the faces to be split or the SurfaceBody object that contains the faces to be split. If an ObjectCollection of faces is supplied, all the faces must belong to the same body. This argument must be specified if the SplitAll argument is False. If the SplitAll argument is True and this argument is not supplied, all the faces on the solid body are split.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Methods > SplitFeature.SetToSplitFaces Method


SplitFeature.SetToTrimSolid Method

SplitFeature.SetToTrimSolid Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that changes the SplitFeature type to kTrimSolid. The specified portion of the solid is removed.

Visual Basic
Sub SetToTrimSolid(SplitTool As IDispatch, Body As SurfaceBody, ByRef RemovePositiveSide As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
SplitTool | Input Object that specifies the entity that will be used to define the split. The input can be a WorkPlane, WorkSurface, or 2D Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
Body | Input SurfaceBody object that specifies the body to be trimmed. Only solid bodies are valid.
RemovePositiveSide | Optional input Boolean that indicates which portion of the split body is to be removed. The default value is True, which indicates that the positive side will be removed.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Methods > SplitFeature.SetToTrimSolid Method


SplitFeature Properties

SplitFeature Properties
Summary

The properties of the SplitFeature class are listed here.

Properties
Name | Description
FaceSplitSplitAll | Property that returns whether the split feature split all of the faces possible, or a specified subset. This property fails in the case where the split feature defines a part split. This can be determined using the SplitType property.
RemovePositiveSide | Property that gets and sets which side of the split body is removed for the trim body operation. This property fails in the case where the split feature defines a face split or a split body operation. This can be determine using the SplitType property. The property applies only if the property returns kTrimSolid.
SplitTool | Property that gets and sets the split tool used to create the split feature. The object can be a WorkPlane, WorkSurface, SurfaceBody or a Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
SplitToolType | Property that returns the split tool type used to create the split feature.
SplitType | Property that returns the split feature type. Possible values are kSplitFaces and kSplitPart.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Properties


SplitFeature.FaceSplitSplitAll Property

SplitFeature.FaceSplitSplitAll Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns whether the split feature split all of the faces possible, or a specified subset. This property fails in the case where the split feature defines a part split. This can be determined using the SplitType property.

Visual Basic
Property FaceSplitSplitAll() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Properties > SplitFeature.FaceSplitSplitAll Property


SplitFeature.RemovePositiveSide Property

SplitFeature.RemovePositiveSide Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets which side of the split body is removed for the trim body operation. This property fails in the case where the split feature defines a face split or a split body operation. This can be determine using the SplitType property. The property applies only if the property returns kTrimSolid.

Visual Basic
Property RemovePositiveSide() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Properties > SplitFeature.RemovePositiveSide Property


SplitFeature.SplitTool Property

SplitFeature.SplitTool Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the split tool used to create the split feature. The object can be a WorkPlane, WorkSurface, SurfaceBody or a Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.

Visual Basic
Property SplitTool() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Properties > SplitFeature.SplitTool Property


SplitFeature.SplitToolType Property

SplitFeature.SplitToolType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the split tool type used to create the split feature.

Visual Basic
Property SplitToolType() As SplitToolTypeEnum*
Remarks

Possible values are kWorkPlane, kWorkSurface, kSurfaceBody and kPath.

You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Properties > SplitFeature.SplitToolType Property


SplitFeature.SplitType Property

SplitFeature.SplitType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the split feature type. Possible values are kSplitFaces and kSplitPart.

Visual Basic
Property SplitType() As SplitTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SplitFeature Interface > SplitFeature Properties > SplitFeature.SplitType Property


SplitFeatureProxy Interface

SplitFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SplitFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::SplitFeature
        Inventor::SplitFeatureProxy
Visual Basic
Public Interface SplitFeatureProxy
Inherits SplitFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SplitFeatureProxy Interface


SplitFeatureProxy Properties

SplitFeatureProxy Properties
Summary

The properties of the SplitFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatureProxy Interface > SplitFeatureProxy Properties


SplitFeatureProxy.ContainingOccurrence Property

SplitFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SplitFeatureProxy Interface > SplitFeatureProxy Properties > SplitFeatureProxy.ContainingOccurrence Property


SplitFeatureProxy.NativeObject Property

SplitFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SplitFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SplitFeatureProxy Interface > SplitFeatureProxy Properties > SplitFeatureProxy.NativeObject Property


SplitFeatures Interface

SplitFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The Part SplitFeatures object represents a collection of objects.

Class Hierarchy
Inventor::SplitFeatures
Visual Basic
Public Interface SplitFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.SplitFeatures

You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface


SplitFeatures Methods

SplitFeatures Methods
Summary

The methods of the SplitFeatures class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified SplitFeature object from the collection.
SplitBody | Method that creates a new SplitFeature by splitting a body. The original body is consumed by the operation and two new bodies are created. The new SplitFeature is returned.
SplitFaces | Method that creates a new SplitFeature by splitting faces of a part. The new SplitFeature is returned.
TrimSolid | Method that creates a new SplitFeature by splitting a solid body. The specified portion of the solid is removed. The new SplitFeature is returned.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Methods


SplitFeatures.Item Method

SplitFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified SplitFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SplitFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out-of-range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Methods > SplitFeatures.Item Method


SplitFeatures.SplitBody Method

SplitFeatures.SplitBody Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new SplitFeature by splitting a body. The original body is consumed by the operation and two new bodies are created. The new SplitFeature is returned.

Visual Basic
Sub SplitBody(SplitTool As IDispatch, Body As SurfaceBody, Result As [out, retval] SplitFeature*)
Parameters
Parameters | Description
SplitTool | Input Object that specifies the entity that will be used to define the split. The input can be a WorkPlane, WorkSurface, or 2D Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
Body | Input SurfaceBody object that specifies the body to be split.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Methods > SplitFeatures.SplitBody Method


SplitFeatures.SplitFaces Method

SplitFeatures.SplitFaces Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new SplitFeature by splitting faces of a part. The new SplitFeature is returned.

Visual Basic
Sub SplitFaces(SplitTool As IDispatch, ByRef SplitAll As [defaultvalue(-1)] VARIANT_BOOL, ByRef FacesOrBody As [optional] VARIANT, Result As [out, retval] SplitFeature*)
Parameters
Parameters | Description
SplitTool | Input Object that defines the parting line for the split. The input can be a WorkPlane, WorkSurface, SurfaceBody or a Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
SplitAll | Optional input Boolean that indicates whether to split all the faces possible on the part. The default is true indicating that all possible faces will be split. If False, the FacesOrBody argument must be supplied as an ObjectCollection and must contain at least one face
FacesOrBody | Optional input Variant that specifies either an ObjectCollection containing the faces to be split or the SurfaceBody object that contains the faces to be split. If an ObjectCollection of faces is supplied, all the faces must belong to the same body. This argument must be specified if the SplitAll argument is False. If the SplitAll argument is True and this argument is not supplied, all the faces on the solid body are split.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Methods > SplitFeatures.SplitFaces Method


SplitFeatures.TrimSolid Method

SplitFeatures.TrimSolid Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new SplitFeature by splitting a solid body. The specified portion of the solid is removed. The new SplitFeature is returned.

Visual Basic
Sub TrimSolid(SplitTool As IDispatch, Body As SurfaceBody, ByRef RemovePositiveSide As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] SplitFeature*)
Parameters
Parameters | Description
SplitTool | Input Object that specifies the entity that will be used to define the split. The input can be a WorkPlane, WorkSurface, or 2D Path. Use the CreatePath or CreateSpecifiedPath method on the PartFeatures object to create a Path. Currently, a Path may only consist of 2D sketch elements.
Body | Input SurfaceBody object that specifies the body to be trimmed. Only solid bodies are valid.
RemovePositiveSide | Optional input Boolean that indicates which portion of the split body is to be removed. The default value is True, which indicates that the positive side will be removed.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Methods > SplitFeatures.TrimSolid Method


SplitFeatures Properties

SplitFeatures Properties
Summary

The properties of the SplitFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Properties


SplitFeatures.Application Property

SplitFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Properties > SplitFeatures.Application Property


SplitFeatures.Count Property

SplitFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Properties > SplitFeatures.Count Property


SplitFeatures.Type Property

SplitFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SplitFeatures Interface > SplitFeatures Properties > SplitFeatures.Type Property


StandardThreadInfo Interface

StandardThreadInfo Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The StandardThreadInfo object defines the thread information that is used by the Hole and Thread features. For tapered threads the TaperedThreadInfo object is used.

Class Hierarchy
Inventor::ThreadInfo
    Inventor::StandardThreadInfo
        Inventor::HoleTapInfo
Visual Basic
Public Interface StandardThreadInfo
Inherits ThreadInfo
Remarks

In the case of a Hole, another property is added to this object, called the DiameterInModel which indicates which of the diameter dimension from the thread information will be used for modeling. This further derived object is called the HoleTapInfo object.

Notes

Members through which this object may be accessed include:

ThreadFeatures.CreateStandardThreadInfo

See Also

Edit thread features sample

You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface


StandardThreadInfo Methods

StandardThreadInfo Methods
Summary

The methods of the StandardThreadInfo class are listed here.

Methods
Methods
Name | Description
_PitchDesignation | This is _PitchDesignation, a member of class StandardThreadInfo.
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Methods


StandardThreadInfo._PitchDesignation Method

StandardThreadInfo._PitchDesignation Method
Summary

This is _PitchDesignation, a member of class StandardThreadInfo.

Visual Basic
Sub _PitchDesignation(Value As String)
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Methods > StandardThreadInfo._PitchDesignation Method


StandardThreadInfo Properties

StandardThreadInfo Properties
Summary

The properties of the StandardThreadInfo class are listed here.

Properties
Name | Description
Class | Property that returns the thread class. For example a valid class for an inch internal thread is '2B'. A valid class for a metric external thread is '6g'.
MajorDiameterMax | Property that gets and sets the maximum major diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
MajorDiameterMin | Property that gets and sets the minimum major diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
MinorDiameterMax | Property that returns the maximum minor diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
MinorDiameterMin | Property that returns the minimum minor diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
NominalSize | Property that returns the description of the nominal size. Any string is valid but the following examples are typical of the strings used, '1.6', 'M4', and '9/16'.
Pitch | Property that returns the actual thread pitch. This value is used when displaying the threads in the model. This value is in millimeters if the Metric argument is True and inches if False.
PitchDiameterMax | Property that returns the maximum pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
PitchDiameterMin | Property that returns the minimum pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
TapDrillDiameter | Property that returns the maximum pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties


StandardThreadInfo.Class Property

StandardThreadInfo.Class Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the thread class. For example a valid class for an inch internal thread is '2B'. A valid class for a metric external thread is '6g'.

Visual Basic
Property Class() As String
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.Class Property


StandardThreadInfo.MajorDiameterMax Property

StandardThreadInfo.MajorDiameterMax Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the maximum major diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property MajorDiameterMax() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.MajorDiameterMax Property


StandardThreadInfo.MajorDiameterMin Property

StandardThreadInfo.MajorDiameterMin Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the minimum major diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property MajorDiameterMin() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.MajorDiameterMin Property


StandardThreadInfo.MinorDiameterMax Property

StandardThreadInfo.MinorDiameterMax Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the maximum minor diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property MinorDiameterMax() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.MinorDiameterMax Property


StandardThreadInfo.MinorDiameterMin Property

StandardThreadInfo.MinorDiameterMin Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the minimum minor diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property MinorDiameterMin() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.MinorDiameterMin Property


StandardThreadInfo.NominalSize Property

StandardThreadInfo.NominalSize Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the description of the nominal size. Any string is valid but the following examples are typical of the strings used, '1.6', 'M4', and '9/16'.

Visual Basic
Property NominalSize() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.NominalSize Property


StandardThreadInfo.Pitch Property

StandardThreadInfo.Pitch Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the actual thread pitch. This value is used when displaying the threads in the model. This value is in millimeters if the Metric argument is True and inches if False.

Visual Basic
Property Pitch() As double*
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.Pitch Property


StandardThreadInfo.PitchDiameterMax Property

StandardThreadInfo.PitchDiameterMax Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the maximum pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property PitchDiameterMax() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.PitchDiameterMax Property


StandardThreadInfo.PitchDiameterMin Property

StandardThreadInfo.PitchDiameterMin Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the minimum pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property PitchDiameterMin() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.PitchDiameterMin Property


StandardThreadInfo.TapDrillDiameter Property

StandardThreadInfo.TapDrillDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the maximum pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property TapDrillDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > StandardThreadInfo Interface > StandardThreadInfo Properties > StandardThreadInfo.TapDrillDiameter Property


Style Interface

Style Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The Style object is the base class for all the drawing styles and contains methods/properties common to all the styles.

Class Hierarchy
Inventor::Style
    Inventor::BalloonStyle
    Inventor::CentermarkStyle
    Inventor::DimensionStyle
    Inventor::DrawingStandardStyle
    Inventor::FeatureControlFrameStyle
    Inventor::HoleTableStyle
    Inventor::Layer
    Inventor::LeaderStyle
    Inventor::ObjectDefaultsStyle
    Inventor::PartsListStyle
    Inventor::RevisionTableStyle
    Inventor::SheetMetalStyle
    Inventor::SurfaceTextureStyle
    Inventor::TableStyle
    Inventor::TextStyle
    Inventor::UnfoldMethod
Visual Basic
Public Interface Style
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Style.ConvertToLocal

Style.Copy

Styles.Item

You are here: Symbol Reference > Inventor Library > Objects > Style Interface


Style Methods

Style Methods
Summary

The methods of the Style class are listed here.

Methods
Methods
Name | Description
ConvertToLocal | Method that creates a local cached copy of a global style and returns the local style.
Copy | Method that creates a new local Style object. The newly created style is returned.
Delete | Method that deletes the Style/Layer/UnfoldMethod.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SaveToGlobal | Method that saves this style to the global repository. If a style with the same name is found in the repository, that style is updated.
UpdateFromGlobal | Method that updates this style from the global repository.
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods


Style.ConvertToLocal Method

Style.ConvertToLocal Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a local cached copy of a global style and returns the local style.

Visual Basic
Sub ConvertToLocal(Result As [out, retval] Style*)
Remarks

This method fails if this style is already local. Use the StyleLocation property to determine whether the style is local.

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods > Style.ConvertToLocal Method


Style.Copy Method

Style.Copy Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new local Style object. The newly created style is returned.

Visual Basic
Sub Copy(Name As String, Result As [out, retval] Style*)
Parameters
Parameters | Description
Name | Input String that specifies the name for the new style. This name must be unique with respect to all other styles of a similar type in the document. That is, if a dimension style is being copied, the name must be unique with respect to all the other dimension styles. If it is not unique the method will fail.
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods > Style.Copy Method


Style.Delete Method

Style.Delete Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that deletes the Style/Layer/UnfoldMethod.

Visual Basic
Sub Delete()
Remarks

This method will fail in the case where this Style/Layer/UnfoldMethod is being referenced. You can use the InUse property to determine if it is being used. Only local styles may be deleted.

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods > Style.Delete Method


Style.GetReferenceKey Method

Style.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods > Style.GetReferenceKey Method


Style.SaveToGlobal Method

Style.SaveToGlobal Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that saves this style to the global repository. If a style with the same name is found in the repository, that style is updated.

Visual Basic
Sub SaveToGlobal()
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods > Style.SaveToGlobal Method


Style.UpdateFromGlobal Method

Style.UpdateFromGlobal Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that updates this style from the global repository.

Visual Basic
Sub UpdateFromGlobal()
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Methods > Style.UpdateFromGlobal Method


Style Properties

Style Properties
Summary

The properties of the Style class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Comments | Gets and sets comments associated with the style.
InternalName | Property that returns the internal name of the style. The name is the internal English name of the standard style. This name will remain constant and is not affected by locale. This name is never displayed to the user. Note that this name is not guaranteed to be unique.
InUse | Property that indicates if this style is in use.
Name | Property that gets and sets the display name of the style. When setting the name, it must be unique with respect to all other styles of a similar type in the document. That is, if a dimension style is being renamed, the name must be unique with respect to all the other dimension styles. If it is not unique the property will fail.
Parent | Property returning the parent of this object.
StyleLocation | Property that returns the location of this style, i.e. local to the document, cached locally in the document, exists in the library. Styles that exist in the library cannot be edited.
StyleType | Gets the type of the style.
Type | Property returning an enum indicating this objects type.
UpToDate | Property that gets the up-to-date status of the style against the global repository.
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties


Style.Application Property

Style.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.Application Property


Style.Comments Property

Style.Comments Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Gets and sets comments associated with the style.

Visual Basic
Property Comments() As String
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.Comments Property


Style.InternalName Property

Style.InternalName Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the internal name of the style. The name is the internal English name of the standard style. This name will remain constant and is not affected by locale. This name is never displayed to the user. Note that this name is not guaranteed to be unique.

Visual Basic
Property InternalName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.InternalName Property


Style.InUse Property

Style.InUse Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates if this style is in use.

Visual Basic
Property InUse() As VARIANT_BOOL*
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.InUse Property


Style.Name Property

Style.Name Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the display name of the style. When setting the name, it must be unique with respect to all other styles of a similar type in the document. That is, if a dimension style is being renamed, the name must be unique with respect to all the other dimension styles. If it is not unique the property will fail.

Visual Basic
Property Name() As String
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.Name Property


Style.Parent Property

Style.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning the parent of this object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.Parent Property


Style.StyleLocation Property

Style.StyleLocation Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the location of this style, i.e. local to the document, cached locally in the document, exists in the library. Styles that exist in the library cannot be edited.

Visual Basic
Property StyleLocation() As StyleLocationEnum*
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.StyleLocation Property


Style.StyleType Property

Style.StyleType Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the type of the style.

Visual Basic
Property StyleType() As StyleTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.StyleType Property


Style.Type Property

Style.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an enum indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.Type Property


Style.UpToDate Property

Style.UpToDate Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets the up-to-date status of the style against the global repository.

Visual Basic
Property UpToDate() As VARIANT_BOOL*
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > Style Interface > Style Properties > Style.UpToDate Property


StyleEvents CoClass

StyleEvents CoClass Available in Inventor Available in Server Introduced in Inventor 11
Summary

The StyleEvents object provides notification of style events including new, activated, changed or deleted styles.

Class Hierarchy
Inventor::StyleEvents
Visual Basic
Public Class StyleEvents
Remarks

See the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.StyleEvents

You are here: Symbol Reference > Inventor Library > Objects > StyleEvents CoClass


StyleEventsObject Interface

StyleEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The StyleEvents object provides notification of style events including new, activated, changed or deleted styles.

Class Hierarchy
Inventor::StyleEventsObject
Visual Basic
Public Interface StyleEventsObject
Inherits IDispatch
Remarks

See the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.StyleEvents

You are here: Symbol Reference > Inventor Library > Objects > StyleEventsObject Interface


StyleEventsObject Properties

StyleEventsObject Properties
Summary

The properties of the StyleEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning kStyleEventsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > StyleEventsObject Interface > StyleEventsObject Properties


StyleEventsObject.Application Property

StyleEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > StyleEventsObject Interface > StyleEventsObject Properties > StyleEventsObject.Application Property


StyleEventsObject.Parent Property

StyleEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > StyleEventsObject Interface > StyleEventsObject Properties > StyleEventsObject.Parent Property


StyleEventsObject.Type Property

StyleEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning kStyleEventsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > StyleEventsObject Interface > StyleEventsObject Properties > StyleEventsObject.Type Property


StyleEventsSink Interface

StyleEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The StyleEvents object provides notification of style events including new, activated, changed or deleted styles.

Class Hierarchy
Inventor::StyleEventsSink
Visual Basic
Public Interface StyleEventsSink
Inherits IDispatch
Remarks

See the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

Application.StyleEvents

You are here: Symbol Reference > Inventor Library > Objects > StyleEventsSink Interface


StyleEventsSink Methods

StyleEventsSink Methods
Summary

The methods of the StyleEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivateStyle | Event that is fired whenever a style is activated in a document.
OnDelete | Event that is fired whenever an object within this events set is deleted in a document.
OnNewStyle | Event that is fired whenever a new style is created in a document.
OnStyleChange | Event that is fired whenever a style changes.
You are here: Symbol Reference > Inventor Library > Objects > StyleEventsSink Interface > StyleEventsSink Methods


StyleEventsSink.OnActivateStyle Method

StyleEventsSink.OnActivateStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever a style is activated in a document.

Visual Basic
Sub OnActivateStyle(DocumentObject As Document, Style As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input AssemblyDocument object that indicates the document in which the change occurred.
Style | Input object that was just activated. This can be a Material, RenderStyle, LightingStyle or one of the drawing style objects (including Layer).
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the style is activated.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Style Events are currently under development and are not supported. They are provided as-is and may be used at your own risk.

You are here: Symbol Reference > Inventor Library > Objects > StyleEventsSink Interface > StyleEventsSink Methods > StyleEventsSink.OnActivateStyle Method


StyleEventsSink.OnDelete Method

StyleEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever an object within this events set is deleted in a document.

Visual Basic
Sub OnDelete(DocumentObject As Document, Style As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Style | Object that was just deleted.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the entity is deleted.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Style Events are currently under development and are not supported. They are provided as-is and may be used at your own risk.

You are here: Symbol Reference > Inventor Library > Objects > StyleEventsSink Interface > StyleEventsSink Methods > StyleEventsSink.OnDelete Method


StyleEventsSink.OnNewStyle Method

StyleEventsSink.OnNewStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever a new style is created in a document.

Visual Basic
Sub OnNewStyle(DocumentObject As Document, Style As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Style | Input object that was just created. This can be a Material, RenderStyle, LightingStyle or one of the drawing style objects (including Layer). Nothing in the kBefore case.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the style is created.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Style Events are currently under development and are not supported. They are provided as-is and may be used at your own risk.

You are here: Symbol Reference > Inventor Library > Objects > StyleEventsSink Interface > StyleEventsSink Methods > StyleEventsSink.OnNewStyle Method


StyleEventsSink.OnStyleChange Method

StyleEventsSink.OnStyleChange Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Event that is fired whenever a style changes.

Visual Basic
Sub OnStyleChange(DocumentObject As Document, Style As IDispatch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DocumentObject | Input Document object that indicates the document in which the change occurred.
Style | Input object that indicates the style that changed. This can be a Material, RenderStyle, LightingStyle or one of the drawing style objects (including Layer).
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the style is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
Remarks

Style Events are currently under development and are not supported. They are provided as-is and may be used at your own risk.

You are here: Symbol Reference > Inventor Library > Objects > StyleEventsSink Interface > StyleEventsSink Methods > StyleEventsSink.OnStyleChange Method


Styles Interface

Styles Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

The Styles collection object provides access to all the Style objects.

Class Hierarchy
Inventor::Styles
Visual Basic
Public Interface Styles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.Styles

You are here: Symbol Reference > Inventor Library > Objects > Styles Interface


Styles Methods

Styles Methods
Summary

The methods of the Styles class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified Style object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Styles Interface > Styles Methods


Styles.Item Method

Styles.Item Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the specified Style object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Style*)
Parameters
Parameters | Description
index | Input Variant value that specifies the Style to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the internal name of a Style. If an out of range index or a name of a non-existent Style is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > Styles Interface > Styles Methods > Styles.Item Method


Styles Properties

Styles Properties
Summary

The properties of the Styles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Styles Interface > Styles Properties


Styles.Application Property

Styles.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Styles Interface > Styles Properties > Styles.Application Property


Styles.Count Property

Styles.Count Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Styles Interface > Styles Properties > Styles.Count Property


Styles.Type Property

Styles.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Styles Interface > Styles Properties > Styles.Type Property


StylesManager Interface

StylesManager Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The StylesManager object provides utilities to manage the various styles in a document.

Class Hierarchy
Inventor::StylesManager
Visual Basic
Public Interface StylesManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.StylesManager

See Also

Moving sketch entities to a new layer sample

You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface


StylesManager Methods

StylesManager Methods
Summary

The methods of the StylesManager class are listed here.

Methods
Methods
Name | Description
GetStyleNameFromKey | Method that extracts and returns the internal and display name of a style from the input reference key of the style.
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Methods


StylesManager.GetStyleNameFromKey Method

StylesManager.GetStyleNameFromKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that extracts and returns the internal and display name of a style from the input reference key of the style.

Visual Basic
Sub GetStyleNameFromKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef InternalName As String, ByRef DisplayName As String)
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Methods > StylesManager.GetStyleNameFromKey Method


StylesManager Properties

StylesManager Properties
Summary

The properties of the StylesManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Materials | Gets the collection of all materials in the styles library.
Parent | Gets the parent object from whom this object can logically be reached.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Properties


StylesManager.Application Property

StylesManager.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Properties > StylesManager.Application Property


StylesManager.Materials Property

StylesManager.Materials Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the collection of all materials in the styles library.

Visual Basic
Property Materials() As MaterialsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Properties > StylesManager.Materials Property


StylesManager.Parent Property

StylesManager.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Properties > StylesManager.Parent Property


StylesManager.Type Property

StylesManager.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > StylesManager Interface > StylesManager Properties > StylesManager.Type Property


SurfaceBodies Interface

SurfaceBodies Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The SurfaceBodies object represents a collection of SurfaceBody objects. See the article in the overviews section.

Class Hierarchy
Inventor::SurfaceBodies
Visual Basic
Public Interface SurfaceBodies
Inherits IDispatch
Remarks

Bodies are classified into two categories: result and work. Work bodies are intermediate bodies used for constructing the model and do not directly contribute to the part"s result body (or bodies). In Inventor graphics, result bodies are displayed in grey, whereas work bodies are displayed in yellow. The ComponentDefinition.SurfaceBodies property is designed to return only result bodies. However, note that result bodies can be solid or surface. So, if you start with a solid result body, and delete one of its faces, the body remains as a result body (grey color) but is now a surface body. The ComponentDefinition.SurfaceBodies property will still return such bodies.

Notes

Members through which this object may be accessed include:

CombineFeature.ToolBodies

ComponentDefinition.SurfaceBodies

ComponentOccurrence.SurfaceBodies

NonParametricBaseFeature.InputSurfaceBodies

PartFeature.SurfaceBodies

TransientBRep.ReadFromFile

WorkSurface.SurfaceBodies

See Also

Associative body copy sample

SurfaceBody Copy sample

Example

See SurfaceBody for example "SurfaceBody Object"

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodies Interface


SurfaceBodies Methods

SurfaceBodies Methods
Summary

The methods of the SurfaceBodies class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodies Interface > SurfaceBodies Methods


SurfaceBodies.Item Method

SurfaceBodies.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the SurfaceBody to return.
See Also

Associative body copy sample

SurfaceBody Copy sample

Sketch Add Oriented sample

Sketch Add sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodies Interface > SurfaceBodies Methods > SurfaceBodies.Item Method


SurfaceBodies Properties

SurfaceBodies Properties
Summary

The properties of the SurfaceBodies class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodies Interface > SurfaceBodies Properties


SurfaceBodies.Count Property

SurfaceBodies.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodies Interface > SurfaceBodies Properties > SurfaceBodies.Count Property


SurfaceBodies.Type Property

SurfaceBodies.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodies Interface > SurfaceBodies Properties > SurfaceBodies.Type Property


SurfaceBody Interface

SurfaceBody Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The SurfaceBody object. See the article in the overviews section.

Class Hierarchy
Inventor::SurfaceBody
    Inventor::SurfaceBodyProxy
Visual Basic
Public Interface SurfaceBody
Inherits IDispatch
Remarks

Bodies are classified into two categories: result and work. Work bodies are intermediate bodies used for constructing the model and do not directly contribute to the part"s result body (or bodies). In Inventor graphics, result bodies are displayed in grey, whereas work bodies are displayed in yellow. The ComponentDefinition.SurfaceBodies property is designed to return only result bodies. However, note that result bodies can be solid or surface. So, if you start with a solid result body, and delete one of its faces, the body remains as a result body (grey color) but is now a surface body. The ComponentDefinition.SurfaceBodies property will still return such bodies.

Notes

Members through which this object may be accessed include:

ApplicationUtilities.CreateHolePatch2

ApplicationUtilities.CreateHolePatch3

CoreCavityDefinition.PartBody

CoreCavityDefinition.WorkpieceBody

CoreCavityFeature.Cavity

CoreCavityFeature.Core

Edge.Parent

EdgeLoop.Parent

EdgeUse.Parent

Face.Parent

Face.SurfaceBody

Face.AlternateBody

FaceShell.Parent

FaceShell.SurfaceBody

FlatPattern.Body

MoldDefinition.Cavity

MoldDefinition.Core

MoldDefinition.PartBody

MoldDefinition.WorkpieceBody

NonParametricBaseFeature.BaseSolidBody

PartFeature.SurfaceBody

RunoffSurfaceDefinition.CreateRunoff

RunoffSurfaceDefinition.CreateSingleRunoffPiece

SurfaceBodies.Item

SurfaceBody.AlternateBody

SurfaceBodyDefinition.CreateTransientSurfaceBody

SurfaceBodyProxy.NativeObject

SurfaceGraphics.Body

ToNextExtent.Terminator

TransientBRep.Copy

TransientBRep.CreateIntersectionWithPlane

TransientBRep.CreateSilhouetteCurve

TransientBRep.CreateSolidBlock

TransientBRep.CreateSolidCylinderCone

TransientBRep.CreateSolidSphere

TransientBRep.CreateSolidTorus

Vertex.Parent

Wire.Parent

SplitFeature.SplitTool

See Also

Create sheet metal rip feature sample

Associative body copy sample

Create client graphics based on the solid body of the active part sample

Create client graphics based on the solid body of the active part sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Transient surface body creation sample

Transient solid body creation sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Create primitive BRep sample

Create primitive BRep sample

Sketch Add sample

Example

"SurfaceBody Copy Example "

This sample demonstrates copying a surface body from one part to another. This is equivalent to the Promote command, but the API is much more flexible. In order for the sample to be self-contained, it creates two parts on the fly that will be used to demonstrate copying a body from one part to another. When copying a body into a part, you provide the surface body and a matrix to define its position in the new part. This sample creates a matrix based on the position of these parts within an assembly.

Public Sub CopyBodyFromPartToPart()
    ' The first portion of this program creates an assembly so that the
    ' copy body API can be demonstrated. Any assembly could potentially
    ' be used, but the sample is simpler if it's for a specific case.
    '
    ' This creates an assembly that contains two parts. An interesting
    ' aspect of the sample is that the assembly and parts only exist
    ' in memory and are not written to disk. Filenames are assigned,
    ' so that if you perform a Save they will be written to disk using
    ' the specified filenames.

    ' Create a new assembly.
    Dim oAsmDoc As AssemblyDocument
    Set oAsmDoc = ThisApplication.Documents.Add(kAssemblyDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kAssemblyDocumentObject))

    ' Define the filename for the assembly. It won't be saved at this point, but
    ' this name will be used if the assembly is saved later by the user.
    oAsmDoc.FullFileName = "C:\Temp\CopyBodyTestAsm.iam"

    ' Create a new part, invisibly.
    Dim oPartDoc1 As PartDocument
    Set oPartDoc1 = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject), False)

    ' Define the filename for the part. It won't be saved at this point, but
    ' this name will be used if the part is saved later by the user.
    oPartDoc1.FullFileName = "C:\Temp\CopyBodyTestPart1.ipt"

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create an extrude feature.
    Dim oSketch As PlanarSketch
    Set oSketch = oPartDoc1.ComponentDefinition.Sketches.Add( _
                    oPartDoc1.ComponentDefinition.WorkPlanes.Item(1))
    Call oSketch.SketchCircles.AddByCenterRadius(oTG.CreatePoint2d(0, 0), 2)
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid
    Call oPartDoc1.ComponentDefinition.Features.ExtrudeFeatures.AddByDistanceExtent( _
                                oProfile, 2, kPositiveExtentDirection, kJoinOperation)

    ' Create a second extrude feature as a work surface.
    Set oSketch = oPartDoc1.ComponentDefinition.Sketches.Add( _
                    oPartDoc1.ComponentDefinition.WorkPlanes.Item(1))
    Call oSketch.SketchLines.AddAsTwoPointRectangle(oTG.CreatePoint2d(-3, -3), oTG.CreatePoint2d(3, 3))
    Set oProfile = oSketch.Profiles.AddForSolid
    Call oPartDoc1.ComponentDefinition.Features.ExtrudeFeatures.AddByDistanceExtent( _
                                oProfile, 1.5, kPositiveExtentDirection, kSurfaceOperation)

    ' Insert the occurrence into the assembly using a somewhat arbitrary position.
    Dim oMatrix As Matrix
    Set oMatrix = oTG.CreateMatrix
    Call oMatrix.Translation.AddVector(oTG.CreateVector(2, 3, 4))
    Call oMatrix.SetToRotation(0.5, oTG.CreateVector(1, 0, 0), oTG.CreatePoint(2, 3, 4))
    Dim oOcc1 As ComponentOccurrence
    Set oOcc1 = oAsmDoc.ComponentDefinition.Occurrences.AddByComponentDefinition( _
                                        oPartDoc1.ComponentDefinition, oMatrix)

    ' Create a second new part, invisibly.
    Dim oPartDoc2 As PartDocument
    Set oPartDoc2 = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject), False)

    ' Define the filename for the part. It won't be saved at this point, but
    ' this name will be used if the part is saved later by the user.
    oPartDoc2.FullFileName = "C:\Temp\CopyBodyTestPart2.ipt"

    ' Insert the second part into the assembly using a somewhat arbitrary position.
    Set oMatrix = oTG.CreateMatrix
    Call oMatrix.Translation.AddVector(oTG.CreateVector(-1, -1, -1))
    Call oMatrix.SetToRotation(0.5, oTG.CreateVector(1, 1, 0), oTG.CreatePoint(1, 1, 1))
    Dim oOcc2 As ComponentOccurrence
    Set oOcc2 = oAsmDoc.ComponentDefinition.Occurrences.AddByComponentDefinition( _
                                        oPartDoc2.ComponentDefinition, oMatrix)

    ' Get the surface body from the first part that represents the work surface.
    ' In this case we know there's only one work surface so this just gets the
    ' first work surface in the collection.
    Dim oWorkSurface As WorkSurface
    Set oWorkSurface = oPartDoc1.ComponentDefinition.WorkSurfaces.Item(1)
    Dim oBody As SurfaceBody
    Set oBody = oWorkSurface.SurfaceBodies.Item(1)

    ' Define the matrix to use in copying the surface body from one part to
    ' another. Any matrix can be used, but in this case I want the position
    ' of the body to be the same with respect to assembly space. Because
    ' the occurrences are in different positions within the assembly the matrix
    ' needs to take into account the transfrom from one occurrence to the other.

    ' Get the transform from the occurrence where the surface body currently exists.
    ' This defines the tranform of the surface body into assembly space.
    Set oMatrix = oOcc1.Transformation

    ' Get the matrix of the second occurrence and invert it.
    ' The inverse of the second occurrence's transform defines the tranform from
    ' assembly space into that occurrence's part space.
    Dim oMatrix2 As Matrix
    Set oMatrix2 = oOcc2.Transformation
    oMatrix2.Invert

    ' Combine these matrices.
    Call oMatrix.PreMultiplyBy(oMatrix2)

    ' Copy the surface body from the first part into the second. You shouldn't
    ' see anything graphically change because the new body is directly on top of
    ' the existing body, but it can be verified because the new body is in
    ' the second part.
    Call oPartDoc2.ComponentDefinition.Features.NonParametricBaseFeatures.Add(oBody, oMatrix)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface


SurfaceBody Methods

SurfaceBody Methods
Summary

The methods of the SurfaceBody class are listed here.

Methods
Methods
Name | Description
BindTransientKeyToObject | Bind the transient key of a subentity on this body to a live object.
CalculateFacets | Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.
CalculateFacetsAndTextureMap | Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.
CalculateStrokes | Obtain the stroked or polygonal representation for the given chord-height tolerance. Client to deallocate pointers with CoTaskMemFree.
Delete | Method that deletes this SurfaceBody object.
FindUsingRay | Please note: As of Autodesk Inventor 5.3 Service Pack 2, the FindUsingRay method below has superseded LocateUsingRay. Please update your applications accordingly. Method that fires a ray through the part or assembly and returns the entities intersected by the ray. The objects intersected by the ray are returned in the order in which they are intersected, with the first entities returned being those closest to the clipping plane. There is also a precedence in the type of entities returned. The entities returned can be Vertex, Edge, or Face objects. The precedence is in that order. If the ray... more
GetASMAttributes | This is GetASMAttributes, a member of class SurfaceBody.
GetExistingFacets | Obtain the faceted representation for the given chord-height tolerance as. Fails if the tolerance supplied is not pre-existing/
GetExistingFacetsAndTextureMap | Method that returns the specified set of existing display facets. Existing display facets are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateFacets method which will calculate new facets to a given tolerance at double-precision accuracy.
GetExistingFacetTolerances | Method that gets the tolerances that were used to calculate the existing sets of display facets. These can be used to determine if any existing facets have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing facets to retrieve when using the GetExistingFacets method.
GetExistingStrokes | Method that returns the specified set of strokes from the SurfaceBody, Face or Edge the method was called from. Existing strokes are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateStrokes method, which will calculate new strokes to a given tolerance at double-precision accuracy. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load... more
GetExistingStrokeTolerances | Method that gets the tolerances that were used to calculate the existing sets of display strokes. These can be used to determine if any existing strokes have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing strokes to retrieve when using the GetExistingStrokes method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetRenderStyle | Method that gets the render style currently used for this body.
IsEntityValid | Method that returns whether an entity passes the quality check at the specified level.
IsPointInside | Property that returns a constant indicating whether the specified point is inside, on or outside the body.
LocateUsingPoint | Finds the object of specified type within the proximity of the given point. By default an internal tolerance is used to gauge the proximity.
SetRenderStyle | Method that sets the render style to use for this body.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods


SurfaceBody.BindTransientKeyToObject Method

SurfaceBody.BindTransientKeyToObject Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Bind the transient key of a subentity on this body to a live object.

Visual Basic
Sub BindTransientKeyToObject(TransientKey As long, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
TransientKey | Transient key to bind.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.BindTransientKeyToObject Method


SurfaceBody.CalculateFacets Method

SurfaceBody.CalculateFacets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.

Visual Basic
Sub CalculateFacets(Tolerance As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.CalculateFacets Method


SurfaceBody.CalculateFacetsAndTextureMap Method

SurfaceBody.CalculateFacetsAndTextureMap Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Obtain the facetted representation for the given chord-height tolerance. If stored facets available for this tolerance, then those are returned.

Visual Basic
Sub CalculateFacetsAndTextureMap(Tolerance As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long), ByRef TextureCoordinates As SAFEARRAY(double))
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.CalculateFacetsAndTextureMap Method


SurfaceBody.CalculateStrokes Method

SurfaceBody.CalculateStrokes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Obtain the stroked or polygonal representation for the given chord-height tolerance. Client to deallocate pointers with CoTaskMemFree.

Visual Basic
Sub CalculateStrokes(Tolerance As double, ByRef VertexCount As long, ByRef SegmentCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.CalculateStrokes Method


SurfaceBody.Delete Method

SurfaceBody.Delete Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes this SurfaceBody object.

Visual Basic
Sub Delete()
Remarks

This is only valid for transient SurfaceBody objects (SurfaceBody.IsTransient is True) and will fail in other cases.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.Delete Method


SurfaceBody.FindUsingRay Method

SurfaceBody.FindUsingRay Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Please note: As of Autodesk Inventor 5.3 Service Pack 2, the FindUsingRay method below has superseded LocateUsingRay. Please update your applications accordingly. Method that fires a ray through the part or assembly and returns the entities intersected by the ray. The objects intersected by the ray are returned in the order in which they are intersected, with the first entities returned being those closest to the clipping plane. There is also a precedence in the type of entities returned. The entities returned can be Vertex, Edge, or Face objects. The precedence is in that order. If the ray intersects a vertex, then that vertex is returned and none of the edges or faces that connect to that vertex are returned. If the ray intersects an edge, then that edge is returned and none of the faces that connect to the edge are returned. If the ray intersects a face, then that face is returned. If desired, you can use the functionality provided by the B-Rep portion of the API to obtain the various associated objects from the entity returned. For example if you need a face but an edge is returned, you can use the Faces property of the Edge object to get the associated faces. The start point defines the physical starting point from which to determine intersections. Any intersections behind the start point are ignored. However, the ray is infinite from the start point, so all intersections in the direction of the ray will be returned.

Visual Basic
Sub FindUsingRay(RayStartPoint As Point, RayDirection As UnitVector, Radius As double, ByRef FoundEntities As ObjectsEnumerator*, ByRef LocationPoints As ObjectsEnumerator*, ByRef FindFirstOnly As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RayStartPoint | Input Point object that defines the start point of the ray in model space.
RayDirection | Input UnitVector object that defines the direction of the ray. The ray is infinite in the direction defined.
Radius | Input Double that defines the radius of the ray. This value is specified in centimeters. Defining a radius for a ray allows the intersection to be within a given tolerance. This radius essentially results in the definition of a cylinder whose axis lies along the axis defined by the RayStartPoint and RayDirection. The intersection result is between the cylinder and the model's entities. A value higher than zero is recommended, though not explicitly required.
FoundEntities | Output ObjectsEnumerator that returns the entities that were intersected by the ray.
LocationPoints | Output ObjectsEnumerator that returns a set of Point objects. One Point object is returned for each entity in the FoundEntities list. The point defines the coordinate of the intersection between the ray and the corresponding entity.
FindFirstOnly | Optional input Boolean that specifies whether to find just the first entity in the ray's path. If False (the default) then all entities found are returned.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.FindUsingRay Method


SurfaceBody.GetASMAttributes Method

SurfaceBody.GetASMAttributes Method
Summary

This is GetASMAttributes, a member of class SurfaceBody.

Visual Basic
Sub GetASMAttributes(ByRef Entity As [optional] VARIANT, Result As [out, retval] NameValueMap*)
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetASMAttributes Method


SurfaceBody.GetExistingFacets Method

SurfaceBody.GetExistingFacets Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Obtain the faceted representation for the given chord-height tolerance as. Fails if the tolerance supplied is not pre-existing/

Visual Basic
Sub GetExistingFacets(ToleranceIndex As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long))
See Also

Client graphics texture-based color mapping sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetExistingFacets Method


SurfaceBody.GetExistingFacetsAndTextureMap Method

SurfaceBody.GetExistingFacetsAndTextureMap Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that returns the specified set of existing display facets. Existing display facets are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateFacets method which will calculate new facets to a given tolerance at double-precision accuracy.

Visual Basic
Sub GetExistingFacetsAndTextureMap(ToleranceIndex As double, ByRef VertexCount As long, ByRef FacetCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef NormalVectors As SAFEARRAY(double), ByRef VertexIndices As SAFEARRAY(long), ByRef TextureCoordinates As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceIndex | Input Double that serves as an index as to which set of existing facets you want to retrieve. If the input tolerance does not match an existing set an error will occur. The tolerances for existing facets can be obtained using the GetExistingFacetTolerances method.
VertexCount | Output Long that returns the number of vertices that were generated for the facets. This is the number of vertices that will be returned by the VertexCoordinates argument.
FacetCount | Output Long that returns the number of facets that were generated.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
NormalVectors | Output array of Singles that contains the components of the vertex normals. A normal is returned for each vertex. The normal is the normal of the actual surface at the position of the vertex.
VertexIndices | Output array of Longs that are used to index into the vertex coordinates array. These indices provide the information that defines how the vertices are connected to create the triangular facets.
Remarks

Note that CalculateFacets and GetExistingFacets (or GetExistingTolerances) are completely unrelated other than they both deal in facet data. CalculateFacets facets the model and returns that result. It does not effect any information held by Inventor. It is just direct access to the internal facet generator. The GetExistingFacets/Tolerances methods access the existing facet data held by the internal scene, if any. They access the set of existing tolerances and facets currently being held. Therefore it is quite possible that existing facets at a given tolerance may not exactly match calculated facets at the same tolerance.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetExistingFacetsAndTextureMap Method


SurfaceBody.GetExistingFacetTolerances Method

SurfaceBody.GetExistingFacetTolerances Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that gets the tolerances that were used to calculate the existing sets of display facets. These can be used to determine if any existing facets have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing facets to retrieve when using the GetExistingFacets method.

Visual Basic
Sub GetExistingFacetTolerances(ByRef ToleranceCount As long, ByRef ExistingTolerances As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceCount | Output Long that specifies the number of existing facet sets.
ExistingTolerances | Output array of Doubles that contains the tolerances that were used to compute the existing sets of display facets.
Remarks

If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to facets. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Note that CalculateFacets and GetExistingFacets (or GetExistingTolerances) are completely unrelated other than they both deal in facet data. CalculateFacets facets the model and returns that result. It does not effect any information held by Inventor. It is just direct access to the internal facet generator. The GetExistingFacets/Tolerances methods access the existing facet data held by the internal scene, if any. They access the set of existing tolerances and facets currently being held. Therefore it is quite possible that existing facets at a given tolerance may not exactly match calculated facets at the same tolerance.

See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetExistingFacetTolerances Method


SurfaceBody.GetExistingStrokes Method

SurfaceBody.GetExistingStrokes Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the specified set of strokes from the SurfaceBody, Face or Edge the method was called from. Existing strokes are stored to single-precision floating point accuracy. This is typically adequate accuracy for display purposes. If a more accurate result is required you can use the CalculateStrokes method, which will calculate new strokes to a given tolerance at double-precision accuracy. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingStrokes(ToleranceIndex As double, ByRef VertexCount As long, ByRef VertexCoordinates As SAFEARRAY(double), ByRef PolylineCount As long, ByRef PolylineLengths As SAFEARRAY(long))
Parameters
Parameters | Description
ToleranceIndex | Input Double that serves as an index into which set of existing strokes you want to retrieve. If the input tolerance does not match an existing set an error will occur. The tolerances for existing strokes can be obtained using the GetExistingStrokeTolerances method.
VertexCount | Output Long that returns the number of vertices that were generated for the facets. This is the number of vertices that will be returned by the VertexCoordinates argument.
VertexCoordinates | Output array of Doubles that contains the coordinates of the vertices.
PolylineCount | Output Long that specifies the number of polylines that are represented by the strokes.
PolylineLengths | Output array of Longs that specifies the number of vertices that are used for each polyline.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetExistingStrokes Method


SurfaceBody.GetExistingStrokeTolerances Method

SurfaceBody.GetExistingStrokeTolerances Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that gets the tolerances that were used to calculate the existing sets of display strokes. These can be used to determine if any existing strokes have been calculated within your desired accuracy. The tolerance value is also used as an index to specify which set of existing strokes to retrieve when using the GetExistingStrokes method. If you are using this method within Apprentice, you can use the DisplayAffinity property to optimize Apprentice for access to strokes. Setting this property to True before you begin to traverse an assembly notifies Apprentice not to load any B-rep entities.

Visual Basic
Sub GetExistingStrokeTolerances(ByRef ToleranceCount As long, ByRef ExistingTolerances As SAFEARRAY(double))
Parameters
Parameters | Description
ToleranceCount | Output Long that specifies the number of existing stroke sets.
ExistingTolerances | Output array of Doubles that contains the tolerances that were used to compute the existing sets of display strokes.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetExistingStrokeTolerances Method


SurfaceBody.GetReferenceKey Method

SurfaceBody.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetReferenceKey Method


SurfaceBody.GetRenderStyle Method

SurfaceBody.GetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that gets the render style currently used for this body.

Visual Basic
Sub GetRenderStyle(ByRef StyleSourceType As StyleSourceTypeEnum, Result As [out, retval] RenderStyle*)
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.GetRenderStyle Method


SurfaceBody.IsEntityValid Method

SurfaceBody.IsEntityValid Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns whether an entity passes the quality check at the specified level.

Visual Basic
Sub IsEntityValid(ByRef EntityToCheck As [optional] VARIANT, ByRef CheckLevel As [defaultvalue(3)] long, ByRef ProblemEntities As [optional] VARIANT, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
EntityToCheck | Method checks whole body if not specified. Valid inputs: FaceShell, Wire, Face, Edge and Vertex
CheckLevel | Value Checks Performed 1 Fast error checks 2 As above plus slower error checks 3 (default) As above plus D-cubed curve and surface checks 4 As above plus fast warning checks 5 As above plus slower warning checks 6 As above plus slow edge convexity change point checks 7 As above plus face/face intersection checks
ProblemEntities | Output ObjectsEnumerator containing the entities that did not pass the check.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.IsEntityValid Method


SurfaceBody.IsPointInside Method

SurfaceBody.IsPointInside Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a constant indicating whether the specified point is inside, on or outside the body.

Visual Basic
Sub IsPointInside(ByRef Point As SAFEARRAY(double), ByRef UseBox As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] ContainmentEnum)
Parameters
Parameters | Description
Point | Point whose location to determine.
UseBox | Optional input Boolean that specifies whether to use a box to determine if the point is inside, on or outside of the body. Sometimes one wants to avoid the creation of bounding boxes during intermediate steps of a construction because the creation of bounding boxes can be costly. If you're applying multiple operations to a body then the bounding box of some of the shells would be invalid after each operation. You wouldn't want to use the bounding box during these intermediate stages because you might spend more time computing the bounding box than you'd save by using it for trivial rejection. On the other hand, if you have a stable body and a high likelihood that the bounding box is up-to-date, then it might save some time to set the use_box parameter to true.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.IsPointInside Method


SurfaceBody.LocateUsingPoint Method

SurfaceBody.LocateUsingPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Finds the object of specified type within the proximity of the given point. By default an internal tolerance is used to gauge the proximity.

Visual Basic
Sub LocateUsingPoint(ObjectType As ObjectTypeEnum, PointOnObject As Point, ByRef ProximityTolerance As [optional] VARIANT, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
ObjectType | Input ObjectType of object to find.
PointOnObject | Input .
ProximityTolerance | Optional input Variant that specifies the tolerance to use to test proximity. If this value is not specified, the internal tolerance is used.
See Also

Creating flange features sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.LocateUsingPoint Method


SurfaceBody.SetRenderStyle Method

SurfaceBody.SetRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets the render style to use for this body.

Visual Basic
Sub SetRenderStyle(StyleSourceType As StyleSourceTypeEnum, ByRef RenderStyle As [optional] VARIANT, ByRef StripOverrides As [defaultvalue(0)] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Methods > SurfaceBody.SetRenderStyle Method


SurfaceBody Properties

SurfaceBody Properties
Summary

The properties of the SurfaceBody class are listed here.

Methods
Methods
Name | Description
AlternateBody | Property that returns a new SurfaceBody that was derived from the existing body using the specified form input. The primary purpose of this property is to obtain a body that consists entirely of NURBS surfaces.
Volume | Property that returns the volume of the component in database units.
Properties
Name | Description
AffectedByFeatures | Property that returns the features that affected this body. The returned enumerator includes the feature that created this body. This property returns Nothing for transient bodies
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
ComponentDefinition | Gets the primary that resides in this file.
ConcaveEdges | Property that returns an that contains all of the concave edges of the surface body. The CollectionType of the output EdgeCollection is set to kAllConcave.
ConvexEdges | Property that returns an that contains all of the convex edges of the surface body. The CollectionType of the output EdgeCollection is set to kAllConvex.
CreatedByFeature | Property that returns the feature that resulted in the creation of this body. This property returns Nothing for transient bodies.
DataIO | Returns the DataIO object.
Edges | Gets the referenced by this SurfaceBody.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
Faces | Property that returns a collection object generated as a result of the feature.
FaceShells | Property that returns the collection object.
GeometryForm | Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.
IsSolid | Determine if this SurfaceBody is solid.
IsTransient | Property that specified if this SurfaceBody is transient or not.
Name | Gets and sets the name of the body.
Parent | Property that returns the parent object from whom this object can logically be reached.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Type | Property returning an enum indicating this object's type.
Vertices | Property that retrieves all vertices on the body.
Visible | Gets and sets the visibility of the body.
Wires | Property returning the Wires collection object associated with this SurfaceBody.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties


SurfaceBody.AffectedByFeatures Property

SurfaceBody.AffectedByFeatures Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the features that affected this body. The returned enumerator includes the feature that created this body. This property returns Nothing for transient bodies

Visual Basic
Property AffectedByFeatures() As PartFeaturesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.AffectedByFeatures Property


SurfaceBody.AlternateBody Method

SurfaceBody.AlternateBody Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a new SurfaceBody that was derived from the existing body using the specified form input. The primary purpose of this property is to obtain a body that consists entirely of NURBS surfaces.

Visual Basic
Sub AlternateBody(AlternateForm As long, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
AlternateForm | AlternateForm - Input Long that is the sum of values describing the desired form.
Remarks

Valid values for the AlternateForm parameter are in the SurfaceGeometryFormEnum and are:

  • SurfaceGeometryForm_NURBS " Convert analytic surfaces to NURBS. This may result in splitting faces and edges as necessary. When used alone, only the faces are converted to NURBS. Edges will be represented by analytic curves.
  • SurfaceGeometryForm_ProceduralToNURBS " Convert procedural surfaces to more accurate NURB approximations. This may result in splitting faces and edges as necessary

These are bitwise values and combining SurfaceGeometryForm_NURBS and SurfaceGeometryForm_ProceduralToNURBS will create a result where the entire body or face is converted to NURBS, procedural surfaces are accurately approximated, and all edges will also be converted to NURBS.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.AlternateBody Method


SurfaceBody.Application Property

SurfaceBody.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Application Property


SurfaceBody.AttributeSets Property

SurfaceBody.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.AttributeSets Property


SurfaceBody.ComponentDefinition Property

SurfaceBody.ComponentDefinition Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the primary that resides in this file.

Visual Basic
Property ComponentDefinition() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.ComponentDefinition Property


SurfaceBody.ConcaveEdges Property

SurfaceBody.ConcaveEdges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns an that contains all of the concave edges of the surface body. The CollectionType of the output EdgeCollection is set to kAllConcave.

Visual Basic
Property ConcaveEdges() As EdgeCollection**
See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.ConcaveEdges Property


SurfaceBody.ConvexEdges Property

SurfaceBody.ConvexEdges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns an that contains all of the convex edges of the surface body. The CollectionType of the output EdgeCollection is set to kAllConvex.

Visual Basic
Property ConvexEdges() As EdgeCollection**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.ConvexEdges Property


SurfaceBody.CreatedByFeature Property

SurfaceBody.CreatedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the feature that resulted in the creation of this body. This property returns Nothing for transient bodies.

Visual Basic
Property CreatedByFeature() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.CreatedByFeature Property


SurfaceBody.DataIO Property

SurfaceBody.DataIO Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Returns the DataIO object.

Visual Basic
Property DataIO() As DataIO**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.DataIO Property


SurfaceBody.Edges Property

SurfaceBody.Edges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the referenced by this SurfaceBody.

Visual Basic
Property Edges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Edges Property


SurfaceBody.Exported Property

SurfaceBody.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Exported Property


SurfaceBody.Faces Property

SurfaceBody.Faces Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a collection object generated as a result of the feature.

Visual Basic
Property Faces() As Faces**
See Also

Sketch Add sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Faces Property


SurfaceBody.FaceShells Property

SurfaceBody.FaceShells Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection object.

Visual Basic
Property FaceShells() As FaceShells**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.FaceShells Property


SurfaceBody.GeometryForm Property

SurfaceBody.GeometryForm Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the form of the underlying geometry as a combination of one or more CurveGeometryFormEnum values.

Visual Basic
Property GeometryForm() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.GeometryForm Property


SurfaceBody.IsSolid Property

SurfaceBody.IsSolid Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine if this SurfaceBody is solid.

Visual Basic
Property IsSolid() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.IsSolid Property


SurfaceBody.IsTransient Property

SurfaceBody.IsTransient Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specified if this SurfaceBody is transient or not.

Visual Basic
Property IsTransient() As VARIANT_BOOL*
Remarks

A value of True indicates it is Transient.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.IsTransient Property


SurfaceBody.Name Property

SurfaceBody.Name Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets and sets the name of the body.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Name Property


SurfaceBody.Parent Property

SurfaceBody.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
Remarks
  • If the SurfaceBody is the resulting solid body of the part, the property returns a ComponentDefinition object.
  • If the SurfaceBody represents the flat pattern body within a sheet metal document, the property returns a FlatPattern object.
  • If the SurfaceBody is a surface (not a solid), the property returns a WorkSurface object.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Parent Property


SurfaceBody.RangeBox Property

SurfaceBody.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.RangeBox Property


SurfaceBody.Type Property

SurfaceBody.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Type Property


SurfaceBody.Vertices Property

SurfaceBody.Vertices Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that retrieves all vertices on the body.

Visual Basic
Property Vertices() As Vertices**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Vertices Property


SurfaceBody.Visible Property

SurfaceBody.Visible Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Gets and sets the visibility of the body.

Visual Basic
Property Visible() As VARIANT_BOOL
See Also

Create client graphics based on the solid body of the active part sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Visible Property


SurfaceBody.Volume Method

SurfaceBody.Volume Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the volume of the component in database units.

Visual Basic
Sub Volume(PrecisionPercent As double, Result As [out, retval] double)
Parameters
Parameters | Description
PrecisionPercent | Input Double that specifies the requested relative accuracy of the result as a percentage. For example, a value of 0.01 requests a maximum error of one percent. The application should find the mass properties for several requested accuracies and compare the results since there is a limitation to the current algorithm in that it does have a bound on how precisely the algorithm can calculate mass properties, due to hard coded convergence criteria in the functions. If you tighten the relative error value and the mass properties values don't change, that means it is as close as can be achieved.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Volume Method


SurfaceBody.Wires Property

SurfaceBody.Wires Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning the Wires collection object associated with this SurfaceBody.

Visual Basic
Property Wires() As Wires**
Remarks

This collection provides access to all of the Wire objects related to this SurfaceBody.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBody Interface > SurfaceBody Properties > SurfaceBody.Wires Property


SurfaceBodyDefinition Interface

SurfaceBodyDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The SurfaceBodyDefinition represents a transient definition of a B-Rep object.

Class Hierarchy
Inventor::SurfaceBodyDefinition
Visual Basic
Public Interface SurfaceBodyDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientBRep.CreateSurfaceBodyDefinition

See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface


SurfaceBodyDefinition Methods

SurfaceBodyDefinition Methods
Summary

The methods of the SurfaceBodyDefinition class are listed here.

Methods
Methods
Name | Description
CreateTransientSurfaceBody | Method that creates a transient SurfaceBody object based on the B-Rep defined within this SurfaceBodyDefinition object.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Methods


SurfaceBodyDefinition.CreateTransientSurfaceBody Method

SurfaceBodyDefinition.CreateTransientSurfaceBody Method
Summary

Method that creates a transient SurfaceBody object based on the B-Rep defined within this SurfaceBodyDefinition object.

Visual Basic
Sub CreateTransientSurfaceBody(ByRef Errors As NameValueMap*, ByRef Options As [optional] VARIANT, Result As [out, retval] SurfaceBody*)
Parameters
Parameters
Description
Errors
Output NameValueMap that contains a list of any errors that occurred during the creation of the surface body. This list will be empty if no errors occurred.
Options
List of options to control certain behaviors during the creation of the surface body. The various options are listed below.

  • DoStitch ' Boolean value that specifies if the faces should be stitched together to create a connected set of faces or a solid if they result in a completely closed volume. If this value is True or is not specified stitching will be attempted. A value of False indicates that no stitching is attempted and the defined topology is used.
  • MergeFaces ' Boolean value that specifies if the analytic faces should be merged where possible. If this value is False or is not specified then no merging is done. A value of True indicates that faces should be merged.

Example 1

Transient solid body creation example.

The following sample demonstrates the creation of a transient solid block body. The newly created body is then displayed using client graphics in a part.

Public Sub CreateBlock()

    Dim oTransBRep As TransientBRep
    Set oTransBRep = ThisApplication.TransientBRep

    Dim oSurfaceBodyDef As SurfaceBodyDefinition
    Set oSurfaceBodyDef = oTransBRep.CreateSurfaceBodyDefinition

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create a lump.
    Dim oLumpDef As LumpDefinition
    Set oLumpDef = oSurfaceBodyDef.LumpDefinitions.Add

    ' Create a shell.
    Dim oShell As FaceShellDefinition
    Set oShell = oLumpDef.FaceShellDefinitions.Add

    ' Define the six planes of the box.
    Dim oPosX As Plane
    Dim oNegX As Plane
    Dim oPosY As Plane
    Dim oNegY As Plane
    Dim oPosZ As Plane
    Dim oNegZ As Plane
    Set oPosX = oTG.CreatePlane(oTG.CreatePoint(1, 0, 0), oTG.CreateVector(1, 0, 0))
    Set oNegX = oTG.CreatePlane(oTG.CreatePoint(-1, 0, 0), oTG.CreateVector(-1, 0, 0))
    Set oPosY = oTG.CreatePlane(oTG.CreatePoint(0, 1, 0), oTG.CreateVector(0, 1, 0))
    Set oNegY = oTG.CreatePlane(oTG.CreatePoint(0, -1, 0), oTG.CreateVector(0, -1, 0))
    Set oPosZ = oTG.CreatePlane(oTG.CreatePoint(0, 0, 1), oTG.CreateVector(0, 0, 1))
    Set oNegZ = oTG.CreatePlane(oTG.CreatePoint(0, 0, -1), oTG.CreateVector(0, 0, -1))

    ' Create the six faces.
    Dim oFaceDefPosX As FaceDefinition
    Dim oFaceDefNegX As FaceDefinition
    Dim oFaceDefPosY As FaceDefinition
    Dim oFaceDefNegY As FaceDefinition
    Dim oFaceDefPosZ As FaceDefinition
    Dim oFaceDefNegZ As FaceDefinition
    Set oFaceDefPosX = oShell.FaceDefinitions.Add(oPosX, False)
    Set oFaceDefNegX = oShell.FaceDefinitions.Add(oNegX, False)
    Set oFaceDefPosY = oShell.FaceDefinitions.Add(oPosY, False)
    Set oFaceDefNegY = oShell.FaceDefinitions.Add(oNegY, False)
    Set oFaceDefPosZ = oShell.FaceDefinitions.Add(oPosZ, False)
    Set oFaceDefNegZ = oShell.FaceDefinitions.Add(oNegZ, False)

    ' Create the vertices.
    Dim oVertex1 As VertexDefinition
    Dim oVertex2 As VertexDefinition
    Dim oVertex3 As VertexDefinition
    Dim oVertex4 As VertexDefinition
    Dim oVertex5 As VertexDefinition
    Dim oVertex6 As VertexDefinition
    Dim oVertex7 As VertexDefinition
    Dim oVertex8 As VertexDefinition
    Set oVertex1 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(1, 1, 1))
    Set oVertex2 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(1, 1, -1))
    Set oVertex3 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(-1, 1, -1))
    Set oVertex4 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(-1, 1, 1))
    Set oVertex5 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(1, -1, 1))
    Set oVertex6 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(1, -1, -1))
    Set oVertex7 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(-1, -1, -1))
    Set oVertex8 = oSurfaceBodyDef.VertexDefinitions.Add(oTG.CreatePoint(-1, -1, 1))

    ' Define the edges at intersections of the defined planes.
    Dim oEdgeDefPosXPosY As EdgeDefinition
    Dim oEdgeDefPosXNegZ As EdgeDefinition
    Dim oEdgeDefPosXNegY As EdgeDefinition
    Dim oEdgeDefPosXPosZ As EdgeDefinition
    Dim oEdgeDefNegXPosY As EdgeDefinition
    Dim oEdgeDefNegXNegZ As EdgeDefinition
    Dim oEdgeDefNegXNegY As EdgeDefinition
    Dim oEdgeDefNegXPosZ As EdgeDefinition
    Dim oEdgeDefPosYNegZ As EdgeDefinition
    Dim oEdgeDefPosYPosZ As EdgeDefinition
    Dim oEdgeDefNegYNegZ As EdgeDefinition
    Dim oEdgeDefNegYPosZ As EdgeDefinition
    Set oEdgeDefPosXPosY = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex1, oVertex2, oTG.CreateLineSegment(oVertex1.Position, oVertex2.Position))
    Set oEdgeDefPosXNegZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex2, oVertex6, oTG.CreateLineSegment(oVertex2.Position, oVertex6.Position))
    Set oEdgeDefPosXNegY = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex6, oVertex5, oTG.CreateLineSegment(oVertex6.Position, oVertex5.Position))
    Set oEdgeDefPosXPosZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex5, oVertex1, oTG.CreateLineSegment(oVertex5.Position, oVertex1.Position))
    Set oEdgeDefNegXPosY = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex4, oVertex3, oTG.CreateLineSegment(oVertex4.Position, oVertex3.Position))
    Set oEdgeDefNegXNegZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex3, oVertex7, oTG.CreateLineSegment(oVertex3.Position, oVertex7.Position))
    Set oEdgeDefNegXNegY = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex7, oVertex8, oTG.CreateLineSegment(oVertex7.Position, oVertex8.Position))
    Set oEdgeDefNegXPosZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex8, oVertex4, oTG.CreateLineSegment(oVertex8.Position, oVertex4.Position))
    Set oEdgeDefPosYNegZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex2, oVertex3, oTG.CreateLineSegment(oVertex2.Position, oVertex3.Position))
    Set oEdgeDefPosYPosZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex4, oVertex1, oTG.CreateLineSegment(oVertex4.Position, oVertex1.Position))
    Set oEdgeDefNegYNegZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex7, oVertex6, oTG.CreateLineSegment(oVertex7.Position, oVertex6.Position))
    Set oEdgeDefNegYPosZ = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex5, oVertex8, oTG.CreateLineSegment(oVertex5.Position, oVertex8.Position))

    ' Define the loops on the faces.
    Dim oPosXLoop As EdgeLoopDefinition
    Set oPosXLoop = oFaceDefPosX.EdgeLoopDefinitions.Add
    Call oPosXLoop.EdgeUseDefinitions.Add(oEdgeDefPosXPosY, True)
    Call oPosXLoop.EdgeUseDefinitions.Add(oEdgeDefPosXNegZ, True)
    Call oPosXLoop.EdgeUseDefinitions.Add(oEdgeDefPosXNegY, True)
    Call oPosXLoop.EdgeUseDefinitions.Add(oEdgeDefPosXPosZ, True)

    Dim oNegXLoop As EdgeLoopDefinition
    Set oNegXLoop = oFaceDefNegX.EdgeLoopDefinitions.Add
    Call oNegXLoop.EdgeUseDefinitions.Add(oEdgeDefNegXPosY, False)
    Call oNegXLoop.EdgeUseDefinitions.Add(oEdgeDefNegXNegZ, False)
    Call oNegXLoop.EdgeUseDefinitions.Add(oEdgeDefNegXNegY, False)
    Call oNegXLoop.EdgeUseDefinitions.Add(oEdgeDefNegXPosZ, False)

    Dim oPosYLoop As EdgeLoopDefinition
    Set oPosYLoop = oFaceDefPosY.EdgeLoopDefinitions.Add
    Call oPosYLoop.EdgeUseDefinitions.Add(oEdgeDefPosXPosY, False)
    Call oPosYLoop.EdgeUseDefinitions.Add(oEdgeDefPosYNegZ, False)
    Call oPosYLoop.EdgeUseDefinitions.Add(oEdgeDefNegXPosY, True)
    Call oPosYLoop.EdgeUseDefinitions.Add(oEdgeDefPosYPosZ, False)

    Dim oNegYLoop As EdgeLoopDefinition
    Set oNegYLoop = oFaceDefNegY.EdgeLoopDefinitions.Add
    Call oNegYLoop.EdgeUseDefinitions.Add(oEdgeDefPosXNegY, False)
    Call oNegYLoop.EdgeUseDefinitions.Add(oEdgeDefNegYPosZ, False)
    Call oNegYLoop.EdgeUseDefinitions.Add(oEdgeDefNegXNegY, True)
    Call oNegYLoop.EdgeUseDefinitions.Add(oEdgeDefNegYNegZ, False)

    Dim oPosZLoop As EdgeLoopDefinition
    Set oPosZLoop = oFaceDefPosZ.EdgeLoopDefinitions.Add
    Call oPosZLoop.EdgeUseDefinitions.Add(oEdgeDefNegXPosZ, True)
    Call oPosZLoop.EdgeUseDefinitions.Add(oEdgeDefNegYPosZ, True)
    Call oPosZLoop.EdgeUseDefinitions.Add(oEdgeDefPosXPosZ, False)
    Call oPosZLoop.EdgeUseDefinitions.Add(oEdgeDefPosYPosZ, True)

    Dim oNegZLoop As EdgeLoopDefinition
    Set oNegZLoop = oFaceDefNegZ.EdgeLoopDefinitions.Add
    Call oNegZLoop.EdgeUseDefinitions.Add(oEdgeDefNegXNegZ, True)
    Call oNegZLoop.EdgeUseDefinitions.Add(oEdgeDefNegYNegZ, True)
    Call oNegZLoop.EdgeUseDefinitions.Add(oEdgeDefPosXNegZ, False)
    Call oNegZLoop.EdgeUseDefinitions.Add(oEdgeDefPosYNegZ, True)

    ' Create a transient surface body.
    Dim oErrors As NameValueMap
    Dim oNewBody As SurfaceBody
    Set oNewBody = oSurfaceBodyDef.CreateTransientSurfaceBody(oErrors)

    ' Create client graphics to display the transient body.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.Documents.Add(kPartDocumentObject)

    Dim oDef As PartComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oDef.ClientGraphicsCollection.Add("Sample3DGraphicsID")

    ' Create a new graphics node within the client graphics objects.
    Dim oSurfacesNode As GraphicsNode
    Set oSurfacesNode = oClientGraphics.AddNode(1)

    ' Create client graphics based on the transient body
    Dim oSurfaceGraphics As SurfaceGraphics
    Set oSurfaceGraphics = oSurfacesNode.AddSurfaceGraphics(oNewBody)

    ' Update the view.
    ThisApplication.ActiveView.Update
End Sub
Example 2

Transient surface body creation example.

The following sample demonstrates the creation of a transient surface body consisting of a single rectangular face. The body is created in transient space and then copied over to a part document as a base feature.

Public Sub CreateRectangleFace()

    Dim oTransBRep As TransientBRep
    Set oTransBRep = ThisApplication.TransientBRep

    Dim oSurfaceBodyDef As SurfaceBodyDefinition
    Set oSurfaceBodyDef = oTransBRep.CreateSurfaceBodyDefinition

    ' Create a lump.
    Dim oLumpDef As LumpDefinition
    Set oLumpDef = oSurfaceBodyDef.LumpDefinitions.Add

    ' Create a shell.
    Dim oShell As FaceShellDefinition
    Set oShell = oLumpDef.FaceShellDefinitions.Add

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create transient points representing the four corners.
    Dim oPoint1 As Point
    Set oPoint1 = oTG.CreatePoint(-1, -1, 1)
    Dim oPoint2 As Point
    Set oPoint2 = oTG.CreatePoint(1, -1, 1)
    Dim oPoint3 As Point
    Set oPoint3 = oTG.CreatePoint(1, 1, 1)
    Dim oPoint4 As Point
    Set oPoint4 = oTG.CreatePoint(-1, 1, 1)

    ' Create the Vertices.
    Dim oVertex1 As VertexDefinition
    Set oVertex1 = oSurfaceBodyDef.VertexDefinitions.Add(oPoint1)
    Dim oVertex2 As VertexDefinition
    Set oVertex2 = oSurfaceBodyDef.VertexDefinitions.Add(oPoint2)
    Dim oVertex3 As VertexDefinition
    Set oVertex3 = oSurfaceBodyDef.VertexDefinitions.Add(oPoint3)
    Dim oVertex4 As VertexDefinition
    Set oVertex4 = oSurfaceBodyDef.VertexDefinitions.Add(oPoint4)

    ' Create each of the edges, as defined by a line segment.
    Dim oLineSeg As LineSegment
    Set oLineSeg = oTG.CreateLineSegment(oPoint1, oPoint2)

    Dim oEdgeDef1 As EdgeDefinition
    Set oEdgeDef1 = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex1, oVertex2, oLineSeg)

    Set oLineSeg = oTG.CreateLineSegment(oPoint2, oPoint3)

    Dim oEdgeDef2 As EdgeDefinition
    Set oEdgeDef2 = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex2, oVertex3, oLineSeg)

    Set oLineSeg = oTG.CreateLineSegment(oPoint3, oPoint4)

    Dim oEdgeDef3 As EdgeDefinition
    Set oEdgeDef3 = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex3, oVertex4, oLineSeg)

    Set oLineSeg = oTG.CreateLineSegment(oPoint4, oPoint1)

    Dim oEdgeDef4 As EdgeDefinition
    Set oEdgeDef4 = oSurfaceBodyDef.EdgeDefinitions.Add(oVertex4, oVertex1, oLineSeg)

    ' Create the face as a planar face.
    Dim oFaceDef As FaceDefinition
    Set oFaceDef = oShell.FaceDefinitions.Add(oTG.CreatePlane( _
                                              oTG.CreatePoint(0, 0, 1), _
                                              oTG.CreateVector(0, 0, 1)), False)

    ' Create the loop.
    Dim oEdgeLoop As EdgeLoopDefinition
    Set oEdgeLoop = oFaceDef.EdgeLoopDefinitions.Add

    ' Define each of the edge uses of the loop using the previously defined edges.
    Call oEdgeLoop.EdgeUseDefinitions.Add(oEdgeDef1, False)
    Call oEdgeLoop.EdgeUseDefinitions.Add(oEdgeDef2, False)
    Call oEdgeLoop.EdgeUseDefinitions.Add(oEdgeDef3, False)
    Call oEdgeLoop.EdgeUseDefinitions.Add(oEdgeDef4, False)

    ' Create a transient body.
    Dim oErrors As NameValueMap
    Dim oNewBody As SurfaceBody
    Set oNewBody = oSurfaceBodyDef.CreateTransientSurfaceBody(oErrors)

    ' Create a non-parametric base feature based on the transient body.
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.Documents.Add(kPartDocumentObject)

    Dim oDef As PartComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    Dim oFeatureDef As NonParametricBaseFeatureDefinition
    Set oFeatureDef = oDef.Features.NonParametricBaseFeatures.CreateDefinition

    Dim oCollection As ObjectCollection
    Set oCollection = ThisApplication.TransientObjects.CreateObjectCollection

    oCollection.Add oNewBody

    oFeatureDef.BRepEntities = oCollection
    oFeatureDef.OutputType = kSurfaceOutputType

    Dim oBaseFeature As NonParametricBaseFeature
    Set oBaseFeature = oDef.Features.NonParametricBaseFeatures.AddByDefinition(oFeatureDef)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Methods > SurfaceBodyDefinition.CreateTransientSurfaceBody Method


SurfaceBodyDefinition Properties

SurfaceBodyDefinition Properties
Summary

The properties of the SurfaceBodyDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
EdgeDefinitions | Property that returns the collection of EdgeDefinition objects associated with this SurfaceBodyDefinition object.
LumpDefinitions | Property that returns the collection of LumpDefinition objects associated with this SurfaceBodyDefinition object. The primary use of the LumpDefinitions collection is to create new LumpDefinition objects.
Type | Returns an ObjectTypeEnum indicating this object's type.
VertexDefinitions | Property that returns the collection of VertexlDefinition objects associated with this SurfaceBodyDefinition object. The primary use of the VertexDefinitions collection is to create new VertexDefinition objects.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Properties


SurfaceBodyDefinition.Application Property

SurfaceBodyDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Properties > SurfaceBodyDefinition.Application Property


SurfaceBodyDefinition.EdgeDefinitions Property

SurfaceBodyDefinition.EdgeDefinitions Property
Summary

Property that returns the collection of EdgeDefinition objects associated with this SurfaceBodyDefinition object.

Visual Basic
Property EdgeDefinitions() As EdgeDefinitions**
See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Properties > SurfaceBodyDefinition.EdgeDefinitions Property


SurfaceBodyDefinition.LumpDefinitions Property

SurfaceBodyDefinition.LumpDefinitions Property Introduced in Inventor 2011
Summary

Property that returns the collection of LumpDefinition objects associated with this SurfaceBodyDefinition object. The primary use of the LumpDefinitions collection is to create new LumpDefinition objects.

Visual Basic
Property LumpDefinitions() As LumpDefinitions**
See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Properties > SurfaceBodyDefinition.LumpDefinitions Property


SurfaceBodyDefinition.Type Property

SurfaceBodyDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Properties > SurfaceBodyDefinition.Type Property


SurfaceBodyDefinition.VertexDefinitions Property

SurfaceBodyDefinition.VertexDefinitions Property
Summary

Property that returns the collection of VertexlDefinition objects associated with this SurfaceBodyDefinition object. The primary use of the VertexDefinitions collection is to create new VertexDefinition objects.

Visual Basic
Property VertexDefinitions() As VertexDefinitions**
See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyDefinition Interface > SurfaceBodyDefinition Properties > SurfaceBodyDefinition.VertexDefinitions Property


SurfaceBodyProxy Interface

SurfaceBodyProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SurfaceBody object.

Class Hierarchy
Inventor::SurfaceBody
    Inventor::SurfaceBodyProxy
Visual Basic
Public Interface SurfaceBodyProxy
Inherits SurfaceBody
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

See Also

Associative body copy sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyProxy Interface


SurfaceBodyProxy Properties

SurfaceBodyProxy Properties
Summary

The properties of the SurfaceBodyProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyProxy Interface > SurfaceBodyProxy Properties


SurfaceBodyProxy.ContainingOccurrence Property

SurfaceBodyProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyProxy Interface > SurfaceBodyProxy Properties > SurfaceBodyProxy.ContainingOccurrence Property


SurfaceBodyProxy.NativeObject Property

SurfaceBodyProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SurfaceBody**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SurfaceBodyProxy Interface > SurfaceBodyProxy Properties > SurfaceBodyProxy.NativeObject Property


SurfaceEvaluator Interface

SurfaceEvaluator Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The SurfaceEvaluator object. See the article in the overviews section.

Class Hierarchy
Inventor::SurfaceEvaluator
Visual Basic
Public Interface SurfaceEvaluator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

BSplineSurface.Evaluator

Cone.Evaluator

Cylinder.Evaluator

EllipticalCone.Evaluator

EllipticalCylinder.Evaluator

Face.Evaluator

Plane.Evaluator

Sphere.Evaluator

Torus.Evaluator

See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface


SurfaceEvaluator Methods

SurfaceEvaluator Methods
Summary

The methods of the SurfaceEvaluator class are listed here.

Methods
Methods
Name | Description
GetCurvatures | Calculates the curvature direction and magnitude of the curve at the given parameter values.
GetFirstDerivatives | Calculates the first order derivatives at the given parameter values on the surface.
GetNormal | Method that gets the surface normal.
GetParamAnomaly | Gets general information about the parameterization of the surface, such as whether or not it is periodic, singular, or unbounded in the parameter domain.
GetParamAtPoint | Calculates the parameter value on the surface that is equal to the specified point. The point must lie on the surface.
GetPointAtParam | Calculates the coordinate points at the given parameter values on the surface.
GetSecondDerivatives | Calculates the second order derivatives at the given parameter values on the surface.
GetTangents | Calculates the tangency directions at the given parameter values on the curve.
GetThirdDerivatives | Calculates the third order derivatives at the given parameter values on the surface.
IsParamOnFace | Determines if the parameter is on the face.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods


SurfaceEvaluator.GetCurvatures Method

SurfaceEvaluator.GetCurvatures Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the curvature direction and magnitude of the curve at the given parameter values.

Visual Basic
Sub GetCurvatures(ByRef Params As SAFEARRAY(double), ByRef MaxTangents As SAFEARRAY(double), ByRef MaxCurvatures As SAFEARRAY(double), ByRef MinCurvatures As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
MaxTangents | Output Double array that returns the maximum curvature direction vector at each specified parameter point.
MaxCurvatures | Output Double array that returns the maximum curvature value at each specified parameter point.
MinCurvatures | Output Double array that returns the minimum curvature value at each specified parameter point.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetCurvatures Method


SurfaceEvaluator.GetFirstDerivatives Method

SurfaceEvaluator.GetFirstDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the first order derivatives at the given parameter values on the surface.

Visual Basic
Sub GetFirstDerivatives(ByRef Params As SAFEARRAY(double), ByRef UPartials As SAFEARRAY(double), ByRef VPartials As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
UPartials | Output Double array that returns the first U partial derivatives.
VPartials | Output Double array that returns the first V partial derivatives.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetFirstDerivatives Method


SurfaceEvaluator.GetNormal Method

SurfaceEvaluator.GetNormal Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets the surface normal.

Visual Basic
Sub GetNormal(ByRef Params As SAFEARRAY(double), ByRef Normals As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
Normals | Input/output array of Doubles that contains the x-y-z values of the normals. The array is a single dimension array containing sequential x, y, and z values.
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetNormal Method


SurfaceEvaluator.GetParamAnomaly Method

SurfaceEvaluator.GetParamAnomaly Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets general information about the parameterization of the surface, such as whether or not it is periodic, singular, or unbounded in the parameter domain.

Visual Basic
Sub GetParamAnomaly(ByRef PeriodicityU As SAFEARRAY(double), ByRef PeriodicityV As SAFEARRAY(double), ByRef NumEndSingularitiesU As long, ByRef SingularitiesU As SAFEARRAY(double), ByRef NumEndSingularitiesV As long, ByRef SingularitiesV As SAFEARRAY(double), ByRef UnboundedParams As SAFEARRAY(VARIANT_BOOL))
Parameters
Parameters | Description
PeriodicityU | Output two element Double array that returns whether the surface is periodic in the U parameter direction. If the surface is periodic in U, the first array element is the period of the surface in U and the second element is the starting U parameter of the principle period. If the surface is not periodic in U, the first element is zero, and the second element is unused.
PeriodicityV | Output two element Double array that returns whether the surface is periodic in the V parameter direction. If the surface is periodic in V, the first array element is the period of the surface in V and the second element is the starting V parameter of the principle period. If the surface is not periodic in V, the first element is zero, and the second element is unused.
NumEndSingularitiesU | Output Double that returns the number of singularities in the U parameter direction. Valid values are zero to indicate no singularities, one to indicate one end singularity, or two to indicate a singularity at both ends.
SingularitiesU | Output Double array that returns the U parameter values at which there is a singularity. If NumEndSingularitiesU returns zero, this argument is not used.
NumEndSingularitiesV | Output Double that returns the number of singularities in the V parameter direction. Valid values are zero to indicate no singularities, one to indicate one end singularity, or two to indicate a singularity at both ends.
SingularitiesV | Output Double array that returns the V parameter values at which there is a singularity. If NumEndSingularitiesV returns zero, this argument is not used.
UnboundedParams | Input/output Boolean array of two elements that returns whether the surface is unbounded in the U or V parameter directions.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetParamAnomaly Method


SurfaceEvaluator.GetParamAtPoint Method

SurfaceEvaluator.GetParamAtPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the parameter value on the surface that is equal to the specified point. The point must lie on the surface.

Visual Basic
Sub GetParamAtPoint(ByRef Points As SAFEARRAY(double), ByRef GuessParams As SAFEARRAY(double), ByRef MaxDeviations As SAFEARRAY(double), ByRef Params As SAFEARRAY(double), ByRef SolutionNatures As SAFEARRAY(SolutionNatureEnum))
Parameters
Parameters | Description
Points | Input/output double that specifies the points.
GuessParams | Input array of parameter points that are an initial guess to optimize the calculation.
MaxDeviations | Output array of Doubles that returns the maximum deviation achieved from the input points.
Params | Input/output array of Doubles that specifies the parameters.
SolutionNatures | Output SolutionNatureEnum that returns the nature of the solution found.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetParamAtPoint Method


SurfaceEvaluator.GetPointAtParam Method

SurfaceEvaluator.GetPointAtParam Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the coordinate points at the given parameter values on the surface.

Visual Basic
Sub GetPointAtParam(ByRef Params As SAFEARRAY(double), ByRef Points As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the u-v parameters. The array is a single dimension array containing sequential u and v values.
Points | Input/output double that specifies the points.
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetPointAtParam Method


SurfaceEvaluator.GetSecondDerivatives Method

SurfaceEvaluator.GetSecondDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the second order derivatives at the given parameter values on the surface.

Visual Basic
Sub GetSecondDerivatives(ByRef Params As SAFEARRAY(double), ByRef UUPartials As SAFEARRAY(double), ByRef UVPartials As SAFEARRAY(double), ByRef VVPartials As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
UUPartials | Output Double array that returns the second U partial derivatives.
UVPartials | Output Double array that returns the second mixed UV partial derivatives.
VVPartials | Output Double array that returns the second V partial derivatives.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetSecondDerivatives Method


SurfaceEvaluator.GetTangents Method

SurfaceEvaluator.GetTangents Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the tangency directions at the given parameter values on the curve.

Visual Basic
Sub GetTangents(ByRef Params As SAFEARRAY(double), ByRef UTangents As SAFEARRAY(double), ByRef VTangents As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
UTangents | Output Double array that returns the tangent vectors in the U parameter direction at the specified parameter points.
VTangents | Output Double array that returns the tangent vectors in the V parameter direction at the specified parameter points.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetTangents Method


SurfaceEvaluator.GetThirdDerivatives Method

SurfaceEvaluator.GetThirdDerivatives Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Calculates the third order derivatives at the given parameter values on the surface.

Visual Basic
Sub GetThirdDerivatives(ByRef Params As SAFEARRAY(double), ByRef UUUPartials As SAFEARRAY(double), ByRef VVVPartials As SAFEARRAY(double))
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
UUUPartials | Output Double array that returns the third U partial derivatives.
VVVPartials | Output Double array that returns the third V partial derivatives.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.GetThirdDerivatives Method


SurfaceEvaluator.IsParamOnFace Method

SurfaceEvaluator.IsParamOnFace Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determines if the parameter is on the face.

Visual Basic
Sub IsParamOnFace(ByRef Params As SAFEARRAY(double), Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Params | Input/output array of Doubles that specifies the parameters.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Methods > SurfaceEvaluator.IsParamOnFace Method


SurfaceEvaluator Properties

SurfaceEvaluator Properties
Summary

The properties of the SurfaceEvaluator class are listed here.

Properties
Name | Description
Area | Property that returns the area of the entity.
Continuity | Gets the level of continuity of the curve. The continuity is the largest order of continuity maintained for the entire curve.
ParamRangeRect | Property that returns a that defines the parameter range for this surface.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Properties


SurfaceEvaluator.Area Property

SurfaceEvaluator.Area Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the area of the entity.

Visual Basic
Property Area() As double*
See Also

Selection Simple sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Properties > SurfaceEvaluator.Area Property


SurfaceEvaluator.Continuity Property

SurfaceEvaluator.Continuity Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the level of continuity of the curve. The continuity is the largest order of continuity maintained for the entire curve.

Visual Basic
Property Continuity() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Properties > SurfaceEvaluator.Continuity Property


SurfaceEvaluator.ParamRangeRect Property

SurfaceEvaluator.ParamRangeRect Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a that defines the parameter range for this surface.

Visual Basic
Property ParamRangeRect() As Box2d**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Properties > SurfaceEvaluator.ParamRangeRect Property


SurfaceEvaluator.RangeBox Property

SurfaceEvaluator.RangeBox Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > SurfaceEvaluator Interface > SurfaceEvaluator Properties > SurfaceEvaluator.RangeBox Property


SurfaceGraphics Interface

SurfaceGraphics Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceGraphics object defines a graphics object created using a body.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::SurfaceGraphics
Visual Basic
Public Interface SurfaceGraphics
Inherits GraphicsPrimitive
Notes

Members through which this object may be accessed include:

GraphicsNode.AddSurfaceGraphics

SurfaceGraphicsEdge.Parent

SurfaceGraphicsFace.Parent

See Also

Create client graphics based on the solid body of the active part sample

Transient solid body creation sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface


SurfaceGraphics Methods

SurfaceGraphics Methods
Summary

The methods of the SurfaceGraphics class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
GetTransformBehavior | Method that gets the current transform behavior of the graphic object.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
SetTransformBehavior | Method that sets the transform behavior of the graphic object.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Methods


SurfaceGraphics.GetCustomLineType Method

SurfaceGraphics.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Methods > SurfaceGraphics.GetCustomLineType Method


SurfaceGraphics.GetTransformBehavior Method

SurfaceGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that gets the current transform behavior of the graphic object.

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point object that returns the anchor point of the graphic object in model space. The coordinates of this point are always defined in model space. The value of this argument is irrelevant when the behavior type to kNoTransformBehaviors.
BehaviorType | Output value from DisplayTransformBehaviorEnum that returns the type of transform behavior the text has. Valid values are kFrontFacing, kFrontFacingAndPixelScaling, kNoTransformBehaviors, and kPixelScaling. TextGraphics objects are always front facing regardless of the defined behavior type.
PixelScale | Output Double that returns the scale factor to apply to all coordinates associated with this graphics object. The scale factor is only relevant when the object has pixel scaling behavior.
Remarks

Graphic objects have two special transform behaviors: front facing and pixel scaling. A front facing object does not rotate as the view is rotated but maintains the same orientation on the screen. It is positioned at a specified location within model and its position on the screen will change as the view is zoomed in and out and scrolled, but its orientation will not change. A graphic object that has pixel scaling behavior maintains the same size relative to the screen. As the user zooms in and out the graphic objects visible size on the screen will remain the same. By default an object has no transform behavior, which means its size, position, and orientation are relative to model space. Text always has front facing behavior regardless of the behavior type returned through this method.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Methods > SurfaceGraphics.GetTransformBehavior Method


SurfaceGraphics.SetCustomLineType Method

SurfaceGraphics.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Methods > SurfaceGraphics.SetCustomLineType Method


SurfaceGraphics.SetTransformBehavior Method

SurfaceGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets the transform behavior of the graphic object.

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input Point object that specifies the anchor point of the graphic object in model space. The coordinates of this point are always defined in model space. The value of this argument is ignored when setting the behavior type to kNoTransformBehaviors.
BehaviorType | Input value from DisplayTransformBehaviorEnum that specifies the type of transform behavior the text has. Valid values are kFrontFacing, kFrontFacingAndPixelScaling, kNoTransformBehaviors, and kPixelScaling. TextGraphics objects are always front facing regardless of the defined behavior type.
PixelScale | Input Double that defines the scale factor to apply to all coordinates associated with this graphics object. This scale factor is only used when the behavior type is kFrontFacingAndPixelScaling or kPixelScaling.
Remarks

Graphic objects have two special transform behaviors: front facing and pixel scaling. A front facing object does not rotate as the view is rotated but maintains the same orientation on the screen. It is positioned at a specified location within model and its position on the screen will change as the view is zoomed in and out and scrolled, but its orientation will not change. A graphic object that has pixel scaling behavior maintains the same size relative to the screen. As the user zooms in and out the graphic objects visible size on the screen will remain the same. Any graphic object can have no transform behavior which means it's size, position, and orientation are relative to model space, front facing behavior, pixel scaling behavior, or front facing and pixel scaling behavior. By default an object has not transform behavior, with the exception of text. Text always has front facing behavior regardless of the behavior type set through this method.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Methods > SurfaceGraphics.SetTransformBehavior Method


SurfaceGraphics Properties

SurfaceGraphics Properties
Summary

The properties of the SurfaceGraphics class are listed here.

Properties
Name | Description
Body | Property that returns the SurfaceBody object associated with the SurfaceGraphics.
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
Color | Property that gets and sets the color associated with the primitive. If no color set is defined, the render style color defined for the GraphicsNode will be used. This property can be set to Nothing to remove the reference to a color and return to using the colors defined by the display style of the GraphicsNode.
DepthPriority | Property that allows you to specify a display priority to the graphics. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
DisplayedEdges | Property that returns a SurfaceGraphicsEdgeList object.
DisplayedFaces | Property that returns a SurfaceGraphicsFaceList object.
DisplaySilhouettes | Property that specifies whether or not to display the silhouette edges of the body. The property defaults to True when the SurfaceGraphics object is created.
LineDefinitionSpace | Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this primitive.
LineType | Property that gets and sets the line type associated with the primitive.
LineWeight | Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties


SurfaceGraphics.Body Property

SurfaceGraphics.Body Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the SurfaceBody object associated with the SurfaceGraphics.

Visual Basic
Property Body() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.Body Property


SurfaceGraphics.BurnThrough Property

SurfaceGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.BurnThrough Property


SurfaceGraphics.Color Property

SurfaceGraphics.Color Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the color associated with the primitive. If no color set is defined, the render style color defined for the GraphicsNode will be used. This property can be set to Nothing to remove the reference to a color and return to using the colors defined by the display style of the GraphicsNode.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.Color Property


SurfaceGraphics.DepthPriority Property

SurfaceGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that allows you to specify a display priority to the graphics. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.DepthPriority Property


SurfaceGraphics.DisplayedEdges Property

SurfaceGraphics.DisplayedEdges Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns a SurfaceGraphicsEdgeList object.

Visual Basic
Property DisplayedEdges() As SurfaceGraphicsEdgeList**
Remarks

This list provides access to all edges that are currently displayed. Edges can be added to or removed from the list. The edges added to the list must be from the surface body associated with the SurfaceGraphics, else an error will occur.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.DisplayedEdges Property


SurfaceGraphics.DisplayedFaces Property

SurfaceGraphics.DisplayedFaces Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns a SurfaceGraphicsFaceList object.

Visual Basic
Property DisplayedFaces() As SurfaceGraphicsFaceList**
Remarks

This list provides access to all faces that are currently displayed. Faces can be added to or removed from the list. The faces added to the list must be from the surface body associated with the SurfaceGraphics, else an error will occur.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.DisplayedFaces Property


SurfaceGraphics.DisplaySilhouettes Property

SurfaceGraphics.DisplaySilhouettes Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies whether or not to display the silhouette edges of the body. The property defaults to True when the SurfaceGraphics object is created.

Visual Basic
Property DisplaySilhouettes() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.DisplaySilhouettes Property


SurfaceGraphics.LineDefinitionSpace Property

SurfaceGraphics.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line definition space for this primitive. This affects how the line weight and line scale are applied to the primitive. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.LineDefinitionSpace Property


SurfaceGraphics.LineScale Property

SurfaceGraphics.LineScale Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line scale applied to this primitive.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.LineScale Property


SurfaceGraphics.LineType Property

SurfaceGraphics.LineType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line type associated with the primitive.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.LineType Property


SurfaceGraphics.LineWeight Property

SurfaceGraphics.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the thickness of this primitive. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphics Interface > SurfaceGraphics Properties > SurfaceGraphics.LineWeight Property


SurfaceGraphicsEdge Interface

SurfaceGraphicsEdge Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceGraphicsEdge represents an individual edge displayed by the SurfaceGraphics object.

Class Hierarchy
Inventor::SurfaceGraphicsEdge
Visual Basic
Public Interface SurfaceGraphicsEdge
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceGraphicsEdgeList.Item

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface


SurfaceGraphicsEdge Methods

SurfaceGraphicsEdge Methods
Summary

The methods of the SurfaceGraphicsEdge class are listed here.

Methods
Methods
Name | Description
GetCustomLineType | Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.
SetCustomLineType | Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Methods


SurfaceGraphicsEdge.GetCustomLineType Method

SurfaceGraphicsEdge.GetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns information regarding the custom line type in use. The method returns a failure if the return value of the LineType property is not kCustomLineType.

Visual Basic
Sub GetCustomLineType(ByRef LineTypeName As String, ByRef LineTypeDescription As String)
Parameters
Parameters | Description
LineTypeName | Output string that returns the name of the line type.
LineTypeDescription | Output string that returns the description of the line type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Methods > SurfaceGraphicsEdge.GetCustomLineType Method


SurfaceGraphicsEdge.SetCustomLineType Method

SurfaceGraphicsEdge.SetCustomLineType Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that sets a custom line type to the curve from the specified .lin file. The method automatically changes the value of LineType property to kCustomLineType.

Visual Basic
Sub SetCustomLineType(FullFileName As String, LineTypeName As String, ReplaceExisting As VARIANT_BOOL)
Parameters
Parameters | Description
FullFileName | Input string that specifies the full file name of the *.lin file containing the custom line types.
LineTypeName | Input string that specifies the name of the line type.
ReplaceExisting | Input Boolean that specifies whether to replace the existing line type if a line type of the same name exists. If set to False, and a line type of the same name exists, this method returns an error.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Methods > SurfaceGraphicsEdge.SetCustomLineType Method


SurfaceGraphicsEdge Properties

SurfaceGraphicsEdge Properties
Summary

The properties of the SurfaceGraphicsEdge class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Color | Property that gets and sets the color to display the edge in.
Edge | Property that returns the Edge object associated with the SurfaceGraphicsEdge.
Index | Property that returns the index of the SurfaceGraphicsEdge object within the SurfaceGraphicsEdgeList.
LineDefinitionSpace | Property that gets and sets the line definition space for this SurfaceGraphicsEdge. This affects how the line weight and line scale are applied to the SurfaceGraphicsEdge. This defaults to kScreenSpace.
LineScale | Property that gets and sets the line scale applied to this SurfaceGraphicsEdge.
LineType | Property that gets and sets the line type associated with the SurfaceGraphicsEdge.
LineWeight | Property that gets and sets the thickness of this SurfaceGraphicsEdge. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).
Parent | Property that returns the parent SurfaceGraphics object.
Type | Property returning kSurfaceGraphicsEdgeObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties


SurfaceGraphicsEdge.Application Property

SurfaceGraphicsEdge.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.Application Property


SurfaceGraphicsEdge.Color Property

SurfaceGraphicsEdge.Color Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the color to display the edge in.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.Color Property


SurfaceGraphicsEdge.Edge Property

SurfaceGraphicsEdge.Edge Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the Edge object associated with the SurfaceGraphicsEdge.

Visual Basic
Property Edge() As Edge**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.Edge Property


SurfaceGraphicsEdge.Index Property

SurfaceGraphicsEdge.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of the SurfaceGraphicsEdge object within the SurfaceGraphicsEdgeList.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.Index Property


SurfaceGraphicsEdge.LineDefinitionSpace Property

SurfaceGraphicsEdge.LineDefinitionSpace Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line definition space for this SurfaceGraphicsEdge. This affects how the line weight and line scale are applied to the SurfaceGraphicsEdge. This defaults to kScreenSpace.

Visual Basic
Property LineDefinitionSpace() As LineDefinitionSpaceEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.LineDefinitionSpace Property


SurfaceGraphicsEdge.LineScale Property

SurfaceGraphicsEdge.LineScale Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line scale applied to this SurfaceGraphicsEdge.

Visual Basic
Property LineScale() As double
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.LineScale Property


SurfaceGraphicsEdge.LineType Property

SurfaceGraphicsEdge.LineType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the line type associated with the SurfaceGraphicsEdge.

Visual Basic
Property LineType() As LineTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.LineType Property


SurfaceGraphicsEdge.LineWeight Property

SurfaceGraphicsEdge.LineWeight Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the thickness of this SurfaceGraphicsEdge. If LineDefinitionSpace is set to kScreenSpace, this value is defined in pixels. If LineDefinitionSpace is set to kModelSpace, this value is defined in model units (centimeters).

Visual Basic
Property LineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.LineWeight Property


SurfaceGraphicsEdge.Parent Property

SurfaceGraphicsEdge.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent SurfaceGraphics object.

Visual Basic
Property Parent() As SurfaceGraphics**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.Parent Property


SurfaceGraphicsEdge.Type Property

SurfaceGraphicsEdge.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceGraphicsEdgeObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdge Interface > SurfaceGraphicsEdge Properties > SurfaceGraphicsEdge.Type Property


SurfaceGraphicsEdgeList Interface

SurfaceGraphicsEdgeList Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceGraphicsEdgeList object contains a list of edges currently displayed by a SurfaceGraphics primitive and allows you to add edges to the list.

Class Hierarchy
Inventor::SurfaceGraphicsEdgeList
Visual Basic
Public Interface SurfaceGraphicsEdgeList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceGraphics.DisplayedEdges

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface


SurfaceGraphicsEdgeList Methods

SurfaceGraphicsEdgeList Methods
Summary

The methods of the SurfaceGraphicsEdgeList class are listed here.

Methods
Methods
Name | Description
Add | Method that specifies additional edges to be displayed.
Clear | Method that removes all the edges from the list. No edges will be displayed after the method is called.
Item | Property that returns a SurfaeGraphicsEdge object.
Remove | Method that removes a edge from the list. The edge will no longer be displayed.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Methods


SurfaceGraphicsEdgeList.Add Method

SurfaceGraphicsEdgeList.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that specifies additional edges to be displayed.

Visual Basic
Sub Add(Edges As IDispatch)
Parameters
Parameters | Description
Edges | Input object that defines the additional edges to display. This can be one of the following: Edge, Edge or a EdgeCollection object. The edges provided must belong to the SurfaceBody associated with the SurfaceGraphics, else an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Methods > SurfaceGraphicsEdgeList.Add Method


SurfaceGraphicsEdgeList.Clear Method

SurfaceGraphicsEdgeList.Clear Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that removes all the edges from the list. No edges will be displayed after the method is called.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Methods > SurfaceGraphicsEdgeList.Clear Method


SurfaceGraphicsEdgeList.Item Method

SurfaceGraphicsEdgeList.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns a SurfaeGraphicsEdge object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SurfaceGraphicsEdge*)
Parameters
Parameters | Description
index | Specifies which SurfaceGraphicsEdge object to return. This can be a Long, which specifies the index in the list, or it can be the Edge object referenced by a SurfaceGraphicsEdge object. The property will fail in the case where an Index is provided that does not identify an existing SurfaceGraphicsEdge object.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Methods > SurfaceGraphicsEdgeList.Item Method


SurfaceGraphicsEdgeList.Remove Method

SurfaceGraphicsEdgeList.Remove Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that removes a edge from the list. The edge will no longer be displayed.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Input Long that specifies the SurfaceGraphicsEdge to remove from the list.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Methods > SurfaceGraphicsEdgeList.Remove Method


SurfaceGraphicsEdgeList Properties

SurfaceGraphicsEdgeList Properties
Summary

The properties of the SurfaceGraphicsEdgeList class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of SurfaceGraphicsEdge objects in the list.
Type | Property returning kSurfaceGraphicsEdgeListObject indicating the object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Properties


SurfaceGraphicsEdgeList.Application Property

SurfaceGraphicsEdgeList.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Properties > SurfaceGraphicsEdgeList.Application Property


SurfaceGraphicsEdgeList.Count Property

SurfaceGraphicsEdgeList.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of SurfaceGraphicsEdge objects in the list.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Properties > SurfaceGraphicsEdgeList.Count Property


SurfaceGraphicsEdgeList.Type Property

SurfaceGraphicsEdgeList.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceGraphicsEdgeListObject indicating the object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsEdgeList Interface > SurfaceGraphicsEdgeList Properties > SurfaceGraphicsEdgeList.Type Property


SurfaceGraphicsFace Interface

SurfaceGraphicsFace Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceGraphicsFace represents an individual face displayed by the SurfaceGraphics object.

Class Hierarchy
Inventor::SurfaceGraphicsFace
Visual Basic
Public Interface SurfaceGraphicsFace
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceGraphicsFaceList.Item

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface


SurfaceGraphicsFace Properties

SurfaceGraphicsFace Properties
Summary

The properties of the SurfaceGraphicsFace class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Color | Property that gets and sets the color to display the face in.
Face | Property that returns the Face object associated with the SurfaceGraphicsFace.
Index | Property that returns the index of the SurfaceGraphicsFace object within the SurfaceGraphicsFaceList.
Parent | Property that returns the parent SurfaceGraphics object.
RenderStyle | Property that gets and sets the render style associated with the face.
Type | Property returning kSurfaceGraphicsFaceObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties


SurfaceGraphicsFace.Application Property

SurfaceGraphicsFace.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.Application Property


SurfaceGraphicsFace.Color Property

SurfaceGraphicsFace.Color Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the color to display the face in.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.Color Property


SurfaceGraphicsFace.Face Property

SurfaceGraphicsFace.Face Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the Face object associated with the SurfaceGraphicsFace.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.Face Property


SurfaceGraphicsFace.Index Property

SurfaceGraphicsFace.Index Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the index of the SurfaceGraphicsFace object within the SurfaceGraphicsFaceList.

Visual Basic
Property Index() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.Index Property


SurfaceGraphicsFace.Parent Property

SurfaceGraphicsFace.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent SurfaceGraphics object.

Visual Basic
Property Parent() As SurfaceGraphics**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.Parent Property


SurfaceGraphicsFace.RenderStyle Property

SurfaceGraphicsFace.RenderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the render style associated with the face.

Visual Basic
Property RenderStyle() As RenderStyle*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.RenderStyle Property


SurfaceGraphicsFace.Type Property

SurfaceGraphicsFace.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceGraphicsFaceObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFace Interface > SurfaceGraphicsFace Properties > SurfaceGraphicsFace.Type Property


SurfaceGraphicsFaceList Interface

SurfaceGraphicsFaceList Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceGraphicsFaceList object contains a list of faces currently displayed by a SurfaceGraphics primitive and allows you to add faces to the list.

Class Hierarchy
Inventor::SurfaceGraphicsFaceList
Visual Basic
Public Interface SurfaceGraphicsFaceList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceGraphics.DisplayedFaces

You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface


SurfaceGraphicsFaceList Methods

SurfaceGraphicsFaceList Methods
Summary

The methods of the SurfaceGraphicsFaceList class are listed here.

Methods
Methods
Name | Description
Add | Method that specifies additional faces to be displayed.
Clear | Method that removes all the faces from the list. No faces will be displayed after the method is called.
Item | Property that returns a SurfaeGraphicsFace object.
Remove | Method that removes a face from the list. The face will no longer be displayed.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Methods


SurfaceGraphicsFaceList.Add Method

SurfaceGraphicsFaceList.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that specifies additional faces to be displayed.

Visual Basic
Sub Add(Faces As IDispatch)
Parameters
Parameters | Description
Faces | Input object that defines the additional faces to display. This can be one of the following: Face, Faces or a FaceCollection object. The faces provided must belong to the SurfaceBody associated with the SurfaceGraphics, else an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Methods > SurfaceGraphicsFaceList.Add Method


SurfaceGraphicsFaceList.Clear Method

SurfaceGraphicsFaceList.Clear Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that removes all the faces from the list. No faces will be displayed after the method is called.

Visual Basic
Sub Clear()
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Methods > SurfaceGraphicsFaceList.Clear Method


SurfaceGraphicsFaceList.Item Method

SurfaceGraphicsFaceList.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns a SurfaeGraphicsFace object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SurfaceGraphicsFace*)
Parameters
Parameters | Description
index | Specifies which SurfaceGraphicsFace object to return. This can be a Long, which specifies the index in the list, or it can be the Face object referenced by a SurfaceGraphicsFace object. The property will fail in the case where an Index is provided that does not identify an existing SurfaceGraphicsFace object.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Methods > SurfaceGraphicsFaceList.Item Method


SurfaceGraphicsFaceList.Remove Method

SurfaceGraphicsFaceList.Remove Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that removes a face from the list. The face will no longer be displayed.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
index | Input Long that specifies the SurfaceGraphicsFace to remove from the list.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Methods > SurfaceGraphicsFaceList.Remove Method


SurfaceGraphicsFaceList Properties

SurfaceGraphicsFaceList Properties
Summary

The properties of the SurfaceGraphicsFaceList class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of SurfaceGraphicsFace objects in the list.
Type | Property returning kSurfaceGraphicsFaceListObject indicating the object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Properties


SurfaceGraphicsFaceList.Application Property

SurfaceGraphicsFaceList.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Properties > SurfaceGraphicsFaceList.Application Property


SurfaceGraphicsFaceList.Count Property

SurfaceGraphicsFaceList.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of SurfaceGraphicsFace objects in the list.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Properties > SurfaceGraphicsFaceList.Count Property


SurfaceGraphicsFaceList.Type Property

SurfaceGraphicsFaceList.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceGraphicsFaceListObject indicating the object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceGraphicsFaceList Interface > SurfaceGraphicsFaceList Properties > SurfaceGraphicsFaceList.Type Property


SurfaceTextureStyle Interface

SurfaceTextureStyle Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceTextureStyle object represents a surface texture style in a drawing.

Class Hierarchy
Inventor::Style
    Inventor::SurfaceTextureStyle
Visual Basic
Public Interface SurfaceTextureStyle
Inherits Style
Remarks

The properties and methods listed below are in addition to those supported by the Style object.

Notes

Members through which this object may be accessed include:

ObjectDefaultsStyle.SurfaceTextureStyle

SurfaceTextureStylesEnumerator.Item

SurfaceTextureSymbol.Style

You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface


SurfaceTextureStyle Properties

SurfaceTextureStyle Properties
Summary

The properties of the SurfaceTextureStyle class are listed here.

Properties
Name | Description
AvailableLaySymbols | Property that gets and sets a bit mask defining the machining lay symbols to be made available for surface texture symbol creation. A combination of enum values can be provided.
LeaderStyle | Property that gets and sets the leader style used for a surface texture symbol.
MachiningProhibitedSymbolSizeSmall | Property that gets and sets whether to use a large or small maching-prohibited symbol. If the property is set to True, the symbol with the smaller diameter is used.
StandardReference | Property that gets and sets the drafting standard that controls surface texture symbol format.
TextStyle | Property that gets and sets the text style used to format the text in a surface texture symbol.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface > SurfaceTextureStyle Properties


SurfaceTextureStyle.AvailableLaySymbols Property

SurfaceTextureStyle.AvailableLaySymbols Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets a bit mask defining the machining lay symbols to be made available for surface texture symbol creation. A combination of enum values can be provided.

Visual Basic
Property AvailableLaySymbols() As LayDirectionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface > SurfaceTextureStyle Properties > SurfaceTextureStyle.AvailableLaySymbols Property


SurfaceTextureStyle.LeaderStyle Property

SurfaceTextureStyle.LeaderStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the leader style used for a surface texture symbol.

Visual Basic
Property LeaderStyle() As LeaderStyle*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface > SurfaceTextureStyle Properties > SurfaceTextureStyle.LeaderStyle Property


SurfaceTextureStyle.MachiningProhibitedSymbolSizeSmall Property

SurfaceTextureStyle.MachiningProhibitedSymbolSizeSmall Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to use a large or small maching-prohibited symbol. If the property is set to True, the symbol with the smaller diameter is used.

Visual Basic
Property MachiningProhibitedSymbolSizeSmall() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface > SurfaceTextureStyle Properties > SurfaceTextureStyle.MachiningProhibitedSymbolSizeSmall Property


SurfaceTextureStyle.StandardReference Property

SurfaceTextureStyle.StandardReference Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the drafting standard that controls surface texture symbol format.

Visual Basic
Property StandardReference() As DraftingStandardEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface > SurfaceTextureStyle Properties > SurfaceTextureStyle.StandardReference Property


SurfaceTextureStyle.TextStyle Property

SurfaceTextureStyle.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the text style used to format the text in a surface texture symbol.

Visual Basic
Property TextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStyle Interface > SurfaceTextureStyle Properties > SurfaceTextureStyle.TextStyle Property


SurfaceTextureStylesEnumerator Interface

SurfaceTextureStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceTextureStylesEnumerator object provides access to the existing SurfaceTextureStyle objects.

Class Hierarchy
Inventor::SurfaceTextureStylesEnumerator
Visual Basic
Public Interface SurfaceTextureStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.SurfaceTextureStyles

You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface


SurfaceTextureStylesEnumerator Methods

SurfaceTextureStylesEnumerator Methods
Summary

The methods of the SurfaceTextureStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified SurfaceTextureStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface > SurfaceTextureStylesEnumerator Methods


SurfaceTextureStylesEnumerator.Item Method

SurfaceTextureStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the specified SurfaceTextureStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SurfaceTextureStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the SurfaceTextureStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the SurfaceTextureStyle name. If an out of range index or a name of a non-existent SurfaceTextureStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface > SurfaceTextureStylesEnumerator Methods > SurfaceTextureStylesEnumerator.Item Method


SurfaceTextureStylesEnumerator Properties

SurfaceTextureStylesEnumerator Properties
Summary

The properties of the SurfaceTextureStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kSurfaceTextureStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface > SurfaceTextureStylesEnumerator Properties


SurfaceTextureStylesEnumerator.Application Property

SurfaceTextureStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface > SurfaceTextureStylesEnumerator Properties > SurfaceTextureStylesEnumerator.Application Property


SurfaceTextureStylesEnumerator.Count Property

SurfaceTextureStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface > SurfaceTextureStylesEnumerator Properties > SurfaceTextureStylesEnumerator.Count Property


SurfaceTextureStylesEnumerator.Type Property

SurfaceTextureStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceTextureStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureStylesEnumerator Interface > SurfaceTextureStylesEnumerator Properties > SurfaceTextureStylesEnumerator.Type Property


SurfaceTextureSymbol Interface

SurfaceTextureSymbol Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceTextureSymbol object represents a surface texture symbol on a sheet.

Class Hierarchy
Inventor::SurfaceTextureSymbol
Visual Basic
Public Interface SurfaceTextureSymbol
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceTextureSymbols.Add

SurfaceTextureSymbols.Item

See Also

Add surface texture symbol to dimension sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface


SurfaceTextureSymbol Methods

SurfaceTextureSymbol Methods
Summary

The methods of the SurfaceTextureSymbol class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the SurfaceTextureSymbol.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Methods


SurfaceTextureSymbol.Delete Method

SurfaceTextureSymbol.Delete Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that deletes the SurfaceTextureSymbol.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Methods > SurfaceTextureSymbol.Delete Method


SurfaceTextureSymbol.GetReferenceKey Method

SurfaceTextureSymbol.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Methods > SurfaceTextureSymbol.GetReferenceKey Method


SurfaceTextureSymbol Properties

SurfaceTextureSymbol Properties
Summary

The properties of the SurfaceTextureSymbol class are listed here.

Properties
Name
Description
AdditionalProductionMethod

property that gets and sets an additional tail for the production method if the drafting standard is based on ISO or DIN. Setting this property will return an error if the ProductionMethod property is not specified. Denoted by B' in the surface texture symbol dialog.
AdditionalRoughness

Property that gets and sets the roughness value other than Ra or the parameter value other than Ra. For ANSI, this property can also be used to specify the waviness height. Denoted by F in the surface texture symbol dialog.
AdditionalSamplingLength

Property that gets and sets the following:

  • the roughness cutoff or sampling length for additional roughness value for ANSI
  • the sampling length for additional roughness value for ISO or DIN
  • the reference length and evaluation length for JIS

Denoted by C' in the surface texture symbol dialog.

AllAroundSymbol

Property that gets and sets whether to add the all-around indicator to the symbol. The diameter is specified in the leader style.
Application

Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets
Property that returns the AttributeSets collection object associated with this object.
ForceTail

Property that gets and sets whether to add a tail to the symbol.
LayDirection

Property that gets and sets the direction of lay. Setting this property will return an error if the SurfaceTextureType is specified to be kMaterialRemovalProhibitedSurfaceType. Denoted by D in the surface texture symbol dialog.
Layer

Property that gets and sets the layer associated with this object.
Leader
Property that returns the leader associated with the surface texture symbol.
MachiningAllowance

Property that gets and sets the machining allowance. Setting this property will return an error if the SurfaceTextureType is not kMaterialRemovalRequiredSurfaceType. Denoted by E in the surface texture symbol dialog.
Majority

Property that gets and sets whether this symbol specifies the standard surface characteristics for the drawing.
MaximumRoughness

Property that gets and sets the roughness value, roughness value Ra maximum, maximum roughness value, or grade number. Denoted by A' in the surface texture symbol dialog.
MinimumRoughness

Property that gets and sets the roughness value, roughness value Ra minimum, minimum roughness value, or grade number. Setting this property will return an error if the MaximumRoughness property is not specified. Denoted by A in the surface texture symbol dialog.
Parent
Property that returns the parent Sheet object.
Position

Property that gets and sets the position of the symbol on the sheet. Changing the position of the symbol does not affect the position of the root node of its leader. It only repositions the symbol along the landing line.
ProductionMethod

Property that gets and sets the production method, treatment, or coating. If the active drafting standard is based on ANSI, this property can be used to specify a note callout. Denoted by B in the surface texture symbol dialog.
SamplingLength

Property that gets and sets the following:

  • the roughness cutoff or sampling length for roughness average for ANSI
  • the waviness height or sampling length for ISO or DIN
  • the cutoff value and evaluation length for JIS

Denoted by C in the surface texture symbol dialog.

Style

Property that gets and sets the associated SurfaceTextureStyle object.
SurfaceTextureType

Property that gets and sets the surface type for the symbol. Possible values are kBasicSurfaceType, kMaterialRemovalRequiredSurfaceType and kMaterialRemovalProhibitedSurfaceType.
SurfaceWaviness

Property that gets and sets the surface waviness for JIS, or general comments for BSI. This property is ignored for ANSI, ISO, or DIN standards. Denoted by F' or G in the surface texture symbol dialog.
Type
Property returning kSurfaceTextureSymbolObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties


SurfaceTextureSymbol.AdditionalProductionMethod Property

SurfaceTextureSymbol.AdditionalProductionMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

property that gets and sets an additional tail for the production method if the drafting standard is based on ISO or DIN. Setting this property will return an error if the ProductionMethod property is not specified. Denoted by B' in the surface texture symbol dialog.

Visual Basic
Property AdditionalProductionMethod() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.AdditionalProductionMethod Property


SurfaceTextureSymbol.AdditionalRoughness Property

SurfaceTextureSymbol.AdditionalRoughness Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the roughness value other than Ra or the parameter value other than Ra. For ANSI, this property can also be used to specify the waviness height. Denoted by F in the surface texture symbol dialog.

Visual Basic
Property AdditionalRoughness() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.AdditionalRoughness Property


SurfaceTextureSymbol.AdditionalSamplingLength Property

SurfaceTextureSymbol.AdditionalSamplingLength Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the following:

  • the roughness cutoff or sampling length for additional roughness value for ANSI
  • the sampling length for additional roughness value for ISO or DIN
  • the reference length and evaluation length for JIS

Denoted by C' in the surface texture symbol dialog.

Visual Basic
Property AdditionalSamplingLength() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.AdditionalSamplingLength Property


SurfaceTextureSymbol.AllAroundSymbol Property

SurfaceTextureSymbol.AllAroundSymbol Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to add the all-around indicator to the symbol. The diameter is specified in the leader style.

Visual Basic
Property AllAroundSymbol() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.AllAroundSymbol Property


SurfaceTextureSymbol.Application Property

SurfaceTextureSymbol.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Application Property


SurfaceTextureSymbol.AttributeSets Property

SurfaceTextureSymbol.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.AttributeSets Property


SurfaceTextureSymbol.ForceTail Property

SurfaceTextureSymbol.ForceTail Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether to add a tail to the symbol.

Visual Basic
Property ForceTail() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.ForceTail Property


SurfaceTextureSymbol.LayDirection Property

SurfaceTextureSymbol.LayDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the direction of lay. Setting this property will return an error if the SurfaceTextureType is specified to be kMaterialRemovalProhibitedSurfaceType. Denoted by D in the surface texture symbol dialog.

Visual Basic
Property LayDirection() As LayDirectionTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.LayDirection Property


SurfaceTextureSymbol.Layer Property

SurfaceTextureSymbol.Layer Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Layer Property


SurfaceTextureSymbol.Leader Property

SurfaceTextureSymbol.Leader Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the leader associated with the surface texture symbol.

Visual Basic
Property Leader() As Leader**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Leader Property


SurfaceTextureSymbol.MachiningAllowance Property

SurfaceTextureSymbol.MachiningAllowance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the machining allowance. Setting this property will return an error if the SurfaceTextureType is not kMaterialRemovalRequiredSurfaceType. Denoted by E in the surface texture symbol dialog.

Visual Basic
Property MachiningAllowance() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.MachiningAllowance Property


SurfaceTextureSymbol.Majority Property

SurfaceTextureSymbol.Majority Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets whether this symbol specifies the standard surface characteristics for the drawing.

Visual Basic
Property Majority() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Majority Property


SurfaceTextureSymbol.MaximumRoughness Property

SurfaceTextureSymbol.MaximumRoughness Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the roughness value, roughness value Ra maximum, maximum roughness value, or grade number. Denoted by A' in the surface texture symbol dialog.

Visual Basic
Property MaximumRoughness() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.MaximumRoughness Property


SurfaceTextureSymbol.MinimumRoughness Property

SurfaceTextureSymbol.MinimumRoughness Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the roughness value, roughness value Ra minimum, minimum roughness value, or grade number. Setting this property will return an error if the MaximumRoughness property is not specified. Denoted by A in the surface texture symbol dialog.

Visual Basic
Property MinimumRoughness() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.MinimumRoughness Property


SurfaceTextureSymbol.Parent Property

SurfaceTextureSymbol.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent Sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Parent Property


SurfaceTextureSymbol.Position Property

SurfaceTextureSymbol.Position Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position of the symbol on the sheet. Changing the position of the symbol does not affect the position of the root node of its leader. It only repositions the symbol along the landing line.

Visual Basic
Property Position() As Point2d*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Position Property


SurfaceTextureSymbol.ProductionMethod Property

SurfaceTextureSymbol.ProductionMethod Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the production method, treatment, or coating. If the active drafting standard is based on ANSI, this property can be used to specify a note callout. Denoted by B in the surface texture symbol dialog.

Visual Basic
Property ProductionMethod() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.ProductionMethod Property


SurfaceTextureSymbol.SamplingLength Property

SurfaceTextureSymbol.SamplingLength Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the following:

  • the roughness cutoff or sampling length for roughness average for ANSI
  • the waviness height or sampling length for ISO or DIN
  • the cutoff value and evaluation length for JIS

Denoted by C in the surface texture symbol dialog.

Visual Basic
Property SamplingLength() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.SamplingLength Property


SurfaceTextureSymbol.Style Property

SurfaceTextureSymbol.Style Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the associated SurfaceTextureStyle object.

Visual Basic
Property Style() As SurfaceTextureStyle*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Style Property


SurfaceTextureSymbol.SurfaceTextureType Property

SurfaceTextureSymbol.SurfaceTextureType Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the surface type for the symbol. Possible values are kBasicSurfaceType, kMaterialRemovalRequiredSurfaceType and kMaterialRemovalProhibitedSurfaceType.

Visual Basic
Property SurfaceTextureType() As SurfaceTextureTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.SurfaceTextureType Property


SurfaceTextureSymbol.SurfaceWaviness Property

SurfaceTextureSymbol.SurfaceWaviness Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the surface waviness for JIS, or general comments for BSI. This property is ignored for ANSI, ISO, or DIN standards. Denoted by F' or G in the surface texture symbol dialog.

Visual Basic
Property SurfaceWaviness() As String
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.SurfaceWaviness Property


SurfaceTextureSymbol.Type Property

SurfaceTextureSymbol.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceTextureSymbolObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbol Interface > SurfaceTextureSymbol Properties > SurfaceTextureSymbol.Type Property


SurfaceTextureSymbols Interface

SurfaceTextureSymbols Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The SurfaceTextureSymbols collection object provides access to all the surface texture symbols on a sheet and provides methods to create additional ones.

Class Hierarchy
Inventor::SurfaceTextureSymbols
Visual Basic
Public Interface SurfaceTextureSymbols
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.SurfaceTextureSymbols

See Also

Add surface texture symbol to dimension sample

You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface


SurfaceTextureSymbols Methods

SurfaceTextureSymbols Methods
Summary

The methods of the SurfaceTextureSymbols class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a surface texture symbol.
Item | Method that returns the specified SurfaceTextureSymbol object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Methods


SurfaceTextureSymbols.Add Method

SurfaceTextureSymbols.Add Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a surface texture symbol.

Visual Basic
Sub Add(LeaderPoints As ObjectCollection, ByRef SurfaceTextureType As [defaultvalue(kBasicSurfaceType)] SurfaceTextureTypeEnum, ByRef ForceTail As [defaultvalue(0)] VARIANT_BOOL, ByRef Majority As [defaultvalue(0)] VARIANT_BOOL, ByRef AllAroundSymbol As [defaultvalue(0)] VARIANT_BOOL, ByRef MaximumRoughness As [defaultvalue("")] BSTR, ByRef MinimumRoughness As [defaultvalue("")] BSTR, ByRef ProductionMethod As [defaultvalue("")] BSTR, ByRef AdditionalProductionMethod As [defaultvalue("")] BSTR, ByRef SamplingLength As [defaultvalue("")] BSTR, ByRef AdditionalSamplingLength As [defaultvalue("")] BSTR, ByRef LayDirection As [defaultvalue(0)] LayDirectionTypeEnum, ByRef MachiningAllowance As [defaultvalue("")] BSTR, ByRef AdditionalRoughness As [defaultvalue("")] BSTR, ByRef SurfaceWaviness As [defaultvalue("")] BSTR, ByRef SurfaceTextureStyle As [optional] VARIANT, ByRef Layer As [optional] VARIANT, Result As [out, retval] SurfaceTextureSymbol*)
Parameters
Parameters
Description
SurfaceTextureType
Optional input SurfaceTextureTypeEnum that specifies the surface type for the symbol. Possible values are kBasicSurfaceType, kMaterialRemovalRequiredSurfaceType and kMaterialRemovalProhibitedSurfaceType. Defaults to kBasicSurfaceType.
ForceTail
Optional input Boolean that specifies whether to add a tail to the symbol. Defaults to False indicating that the tail will not be added.
Majority
Optional input Boolean that indicates whether this symbol specifies the standard surface characteristics for the drawing. Defaults to False.
AllAroundSymbol
Optional input Boolean that specifies whether to add the all-around indicator to the symbol. The diameter is specified in the leader style. Defaults to False.
MaximumRoughness
Optional input String that specifies roughness value, roughness value Ra maximum, maximum roughness value, or grade number. Denoted by A' in the surface texture symbol dialog.
MinimumRoughness
Optional input String that specifies the roughness value, roughness value Ra minimum, minimum roughness value, or grade number. This value is used only if the MaximumRoughness is also specified. Denoted by A in the surface texture symbol dialog.
ProductionMethod
Optional input String that specifies the production method, treatment, or coating. If the active drafting standard is based on ANSI, this argument can be used to specify a note callout. Denoted by B in the surface texture symbol dialog.
AdditionalProductionMethod
Optional input String that specifies an additional tail for the production method if the drafting standard is based on ISO or DIN. This value is used only if ProductionMethod is also specified. Denoted by B' in the surface texture symbol dialog.
SamplingLength
Optional input String that specifies:

  • the roughness cutoff or sampling length for roughness average for ANSI
  • the waviness height or sampling length for ISO or DIN
  • the cutoff value and evaluation length for JIS

Denoted by C in the surface texture symbol dialog.

AdditionalSamplingLength
Optional input String that specifies:

  • the roughness cutoff or sampling length for additional roughness value for ANSI
  • the sampling length for additional roughness value for ISO or DIN
  • the reference length and evaluation length for JIS

Denoted by C' in the surface texture symbol dialog.

LayDirection
Optional input LayDirectionTypeEnum that specifies the direction of lay. This value is not applicable and is ignored if the SurfaceTextureType is specified to be kMaterialRemovalProhibitedSurfaceType. Denoted by D in the surface texture symbol dialog.
MachiningAllowance
Optional input String that specifies the machining allowance. This value is applicable only if the SurfaceTextureType is specified to be kMaterialRemovalRequiredSurfaceType and is ignored for other surface texture types. Denoted by E in the surface texture symbol dialog.
AdditionalRoughness
Optional input String that specifies the roughness value other than Ra or the parameter value other than Ra. For ANSI, this argument can also be used to specify the waviness height. Denoted by F in the surface texture symbol dialog.
SurfaceWaviness
Optional input String that specifies the surface waviness for JIS, or general comments for BSI. This argument is ignored for ANSI, ISO, or DIN standards. Denoted by F' or G in the surface texture symbol dialog.
pLeaderPoints
Input ObjectCollection containing a series of Point2d objects representing the leader originating at the symbol. The last item in the collection (even if it is the only item) can be a GeometryIntent object indicating a geometry to attach the leader to. A GeometryIntent object can be created using the Sheet.CreateGeometryIntent method. The ObjectCollection must contain at least one item, else the method will fail.
vSurfaceTextureStyle
Optional input SurfaceTextureStyle object which specifies the surface texture style to use for the symbol. If not specified, the style defined by the active standard is used.
vLayer
Optional input Layer object that specifies the layer to use for the symbol. If not specified, the layer defined by the active standard is used.
Example

"Add surface texture symbol to dimension"

This sample demonstrates the creation of a surface texture symbol attached to the extension line of a drawing dimension.

Select a linear general dimension in a drawing and run the sample.

Public Sub AddSurfaceTextureSymbol()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Check to make sure a linear dimension is selected.
    If Not TypeOf oDrawDoc.SelectSet.Item(1) Is LinearGeneralDimension Then
        MsgBox "A linear general dimension must be selected."
        Exit Sub
    End If

    ' Set a reference to the active sheet.
    Dim oActiveSheet As Sheet
    Set oActiveSheet = oDrawDoc.ActiveSheet

    ' Set a reference to the drawing dimension.
    ' This assumes that a linear general dimension is selected.
    Dim oLinearDim As LinearGeneralDimension
    Set oLinearDim = oDrawDoc.SelectSet.Item(1)

    ' Get the mid point of the first extension line of the dimension
    Dim oMidPoint As Object
    Set oMidPoint = oLinearDim.ExtensionLineOne.MidPoint

    ' Set a reference to the TransientGeometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    Dim oLeaderPoints As ObjectCollection
    Set oLeaderPoints = ThisApplication.TransientObjects.CreateObjectCollection

    ' Create a few leader points.
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 10))
    Call oLeaderPoints.Add(oTG.CreatePoint2d(oMidPoint.X + 10, oMidPoint.Y + 5))

    ' Create an intent and add to the leader points collection.
    ' This is the geometry that the symbol will attach to.
    Dim oGeometryIntent As GeometryIntent
    Set oGeometryIntent = oActiveSheet.CreateGeometryIntent(oLinearDim, oMidPoint)

    Call oLeaderPoints.Add(oGeometryIntent)

    ' Create the symbol with a leader
    Dim oSymbol As SurfaceTextureSymbol
    Set oSymbol = oActiveSheet.SurfaceTextureSymbols.Add(oLeaderPoints, _
            kMaterialRemovalRequiredSurfaceType, _
            True, _
            True, _
            True, _
            0.1, _
            , , , , , _
            kParticulateNondirectional)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Methods > SurfaceTextureSymbols.Add Method


SurfaceTextureSymbols.Item Method

SurfaceTextureSymbols.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that returns the specified SurfaceTextureSymbol object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] SurfaceTextureSymbol*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Methods > SurfaceTextureSymbols.Item Method


SurfaceTextureSymbols Properties

SurfaceTextureSymbols Properties
Summary

The properties of the SurfaceTextureSymbols class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kSurfaceTextureSymbolsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Properties


SurfaceTextureSymbols.Application Property

SurfaceTextureSymbols.Application Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Properties > SurfaceTextureSymbols.Application Property


SurfaceTextureSymbols.Count Property

SurfaceTextureSymbols.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Properties > SurfaceTextureSymbols.Count Property


SurfaceTextureSymbols.Type Property

SurfaceTextureSymbols.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning kSurfaceTextureSymbolsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SurfaceTextureSymbols Interface > SurfaceTextureSymbols Properties > SurfaceTextureSymbols.Type Property


SweepDefinition Interface

SweepDefinition Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The SweepDefinition object is the base class that defines the variables for sweep features.

Class Hierarchy
Inventor::SweepDefinition
    Inventor::PathAndGuideRailSweepDef
    Inventor::PathAndGuideSurfaceSweepDef
    Inventor::PathAndSectionTwistsSweepDef
    Inventor::PathSweepDef
Visual Basic
Public Interface SweepDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SweepFeature.Definition

You are here: Symbol Reference > Inventor Library > Objects > SweepDefinition Interface


SweepDefinition Properties

SweepDefinition Properties
Summary

The properties of the SweepDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent SweepFeature of the definition.
Type | Property returning an enum indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > SweepDefinition Interface > SweepDefinition Properties


SweepDefinition.Application Property

SweepDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SweepDefinition Interface > SweepDefinition Properties > SweepDefinition.Application Property


SweepDefinition.Parent Property

SweepDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent SweepFeature of the definition.

Visual Basic
Property Parent() As SweepFeature**
You are here: Symbol Reference > Inventor Library > Objects > SweepDefinition Interface > SweepDefinition Properties > SweepDefinition.Parent Property


SweepDefinition.Type Property

SweepDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SweepDefinition Interface > SweepDefinition Properties > SweepDefinition.Type Property


SweepFeature Interface

SweepFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SweepFeature object represents swept modeling features. The properties and methods listed below are in addition to those supported by the Feature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::SweepFeature
        Inventor::SweepFeatureProxy
Visual Basic
Public Interface SweepFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

SweepDefinition.Parent

SweepFeatureProxy.NativeObject

SweepFeatures.Add

SweepFeatures.AddUsingPath

SweepFeatures.AddUsingPathAndGuideRail

SweepFeatures.AddUsingPathAndGuideSurface

SweepFeatures.AddUsingPathAndSectionTwists

SweepFeatures.Item

See Also

True length of sweep feature sample

Example

"Sweep Feature Add Example "

This sample demonstrates the creation of a sweep feature. The profile is a circle, but the path is made up of a 3D sketch and a 2D sketch. To run the sample have a part document open.

Option Explicit

Public Sub SweepFeature()
    ' Set a reference to the currently active document.
    ' This assumes that it is a part document.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Set a reference to the transient geometry object.
    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create some workpoints that will be used for the 3D sketch.
    Dim oWPs(1 To 5) As WorkPoint
    Set oWPs(1) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(0, 0, 0))
    Set oWPs(2) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(3, 0, 0))
    Set oWPs(3) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(3, 4, 0))
    Set oWPs(4) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(3, 4, 2))
    Set oWPs(5) = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(6, 4, 2))

    ' Create a new 3D Sketch.
    Dim oSketch3D As Sketch3D
    Set oSketch3D = oPartDoc.ComponentDefinition.Sketches3D.Add

    ' Draw 3D lines. The first line is drawn between two of the work points.
    Dim oLine As SketchLine3D
    Set oLine = oSketch3D.SketchLines3D.AddByTwoPoints(oWPs(1), oWPs(2), True, 1)

    ' This second and subsequent lines are drawn between a 3D sketch point and a work point.
    ' The work point is obtained from the previous line. Because the two lines will share
    ' this 3D sketch point, Inventor will treat them as connected lines when creating any
    ' paths.
    Set oLine = oSketch3D.SketchLines3D.AddByTwoPoints(oLine.EndPoint, oWPs(3), True, 1)
    Set oLine = oSketch3D.SketchLines3D.AddByTwoPoints(oLine.EndPoint, oWPs(4), True, 0.75)
    Set oLine = oSketch3D.SketchLines3D.AddByTwoPoints(oLine.EndPoint, oWPs(5), True, 1)

    ' Create a 2D sketch.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(2))

    ' Determine the model origin relative to the sketch space.
    Dim oOrigin As Point2d
    Set oOrigin = oSketch.ModelToSketchSpace(oTG.CreatePoint(0, 0, 0))

    ' Create two lines.
    Dim oNewPoint As Point2d
    Set oNewPoint = oTG.CreatePoint2d(oOrigin.X, oOrigin.Y - 4)
    Dim oSketchLine1 As SketchLine
    Set oSketchLine1 = oSketch.SketchLines.AddByTwoPoints(oOrigin, oNewPoint)
    oNewPoint.X = oNewPoint.X + 3
    Dim oSketchLine2 As SketchLine
    Set oSketchLine2 = oSketch.SketchLines.AddByTwoPoints(oSketchLine1.EndSketchPoint, oNewPoint)

    ' Create a fillet between the two lines.
    Call oSketch.SketchArcs.AddByFillet(oSketchLine1, oSketchLine2, 1, oSketchLine1.StartSketchPoint.Geometry, oSketchLine2.EndSketchPoint.Geometry)

    ' Get the end of the 2d sketch in model space.
    Dim oModelPoint As Point
    Set oModelPoint = oSketch.SketchToModelSpace(oSketchLine2.EndSketchPoint.Geometry)

    ' Create a work plane at the end of the 2D sketch.
    Dim oWP As WorkPlane
    Set oWP = oCompDef.WorkPlanes.AddByNormalToCurve(oSketchLine2, oSketchLine2.EndSketchPoint)

    ' Create a path. Because the 3D and 2D sketches physically connect the path will include
    ' both of them.
    Dim oPath As Path
    Set oPath = oCompDef.Features.SweepFeatures.CreatePath(oSketchLine2)

    ' Create a sketch containing a circle.
    Set oSketch = oCompDef.Sketches.Add(oWP)
    Set oOrigin = oSketch.ModelToSketchSpace(oTG.CreatePoint(0, 0, 0))
    Call oSketch.SketchCircles.AddByCenterRadius(oSketch.ModelToSketchSpace(oModelPoint), 0.375)

    ' Create a profile.
    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Create the sweep feature.
    Dim oSweep As SweepFeature
    Set oSweep = oCompDef.Features.SweepFeatures.AddUsingPath(oProfile, oPath, kJoinOperation)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface


SweepFeature Methods

SweepFeature Methods
Summary

The methods of the SweepFeature class are listed here.

Methods
Methods
Name | Description
AddParticipant | Add the specified occurrence from the list of participants for this feature. This method only applies to assembly features.
SetUsingPath | Method that sets the SweepFeature to be defined using a path and the orientation of the profile as it is swept along the path.
SetUsingPathAndGuideRail | Method that sets a SweepFeature to be defined by a path and a guide rail that controls the scaling and twist of the profile section as it is being swept along the path.
SetUsingPathAndGuideSurface | Method that sets a SweepFeature to be defined by a path and a guide surface that defines the orientation of the profile section as it is being swept along the path.
SetUsingPathAndSectionTwists | Method that sets a SweepFeature to be defined by a path and the orientation of the profile as it is swept along the path.
TaperAngle | Property that returns the parameter controlling the taper angle of the feature.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods


SweepFeature.AddParticipant Method

SweepFeature.AddParticipant Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Add the specified occurrence from the list of participants for this feature. This method only applies to assembly features.

Visual Basic
Sub AddParticipant(Occurrence As ComponentOccurrence)
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods > SweepFeature.AddParticipant Method


SweepFeature.SetUsingPath Method

SweepFeature.SetUsingPath Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the SweepFeature to be defined using a path and the orientation of the profile as it is swept along the path.

Visual Basic
Sub SetUsingPath(ByRef ProfileOrientation As [defaultvalue(kNormalToPath)] SweepProfileOrientationEnum, ByRef TaperAngle As [optional] VARIANT)
Parameters
Parameters | Description
ProfileOrientation | Optional Input constant that indicates the orientation of the profile as it is being swept along the profile path. Valid input is one of the constants in SweepProfileOrientationEnum : kNormalToPath or kParallelToOriginalProfile. If kNormalToPath is specified, the sweep profile will be held normal to the path along all sections of the sweep. If kParallelToOriginalProfile is specified, the sweep profile section will always be parallel to the original input profile that defines the starting section for the sweep. If no value is specified for this argument, then kNormalToPath will be assumed to indicate that the profile should be normal to the path along all sections of the sweep.
TaperAngle | Optional Input Variant that defines the taper angle of the sweep. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. If a value for the taper angle is not explicitly specified, then the taper angle of the sweep feature will be set to zero.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods > SweepFeature.SetUsingPath Method


SweepFeature.SetUsingPathAndGuideRail Method

SweepFeature.SetUsingPathAndGuideRail Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets a SweepFeature to be defined by a path and a guide rail that controls the scaling and twist of the profile section as it is being swept along the path.

Visual Basic
Sub SetUsingPathAndGuideRail(GuideRail As Path, ByRef ProfileScaling As [defaultvalue(kXYProfileScaling)] SweepProfileScalingEnum)
Parameters
Parameters | Description
GuideRail | Input Path object that defines the guide rail for the sweep which acts as a guide curve and controls the scaling and twist of the sweep profile. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements and can be open or closed.
ProfileScaling | Optional Input constant that defines the scaling direction for the sweep profile. Valid input is kXYProfileScaling, kXProfileScaling or kNoProfileScaling. The default value is kXYProfileScaling.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods > SweepFeature.SetUsingPathAndGuideRail Method


SweepFeature.SetUsingPathAndGuideSurface Method

SweepFeature.SetUsingPathAndGuideSurface Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets a SweepFeature to be defined by a path and a guide surface that defines the orientation of the profile section as it is being swept along the path.

Visual Basic
Sub SetUsingPathAndGuideSurface(GuideSurface As IDispatch)
Parameters
Parameters | Description
GuideSurface | Input Object that defines a guide surface the normal of which will control the twist of the swept profile about the path. Valid input objects for the guide surface are Face, FaceCollection or WorkPlane.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods > SweepFeature.SetUsingPathAndGuideSurface Method


SweepFeature.SetUsingPathAndSectionTwists Method

SweepFeature.SetUsingPathAndSectionTwists Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets a SweepFeature to be defined by a path and the orientation of the profile as it is swept along the path.

Visual Basic
Sub SetUsingPathAndSectionTwists(SectionTwistPoints As ObjectCollection, SectionTwistVectors As ObjectCollection, ByRef ProfileOrientation As [defaultvalue(kNormalToPath)] SweepProfileOrientationEnum, ByRef TaperAngle As [optional] VARIANT)
Parameters
Parameters
Description
SectionTwistPoints
Input ObjectCollection that contains the points along the sweep path at which the sweep twists need to be specified. The sweep path points define the positions of the sweep cross-sections at which the twists need to be specified. Since the sweep feature is created by sweeping a profile cross-section along a sweep path, the twist of the sweep can theoretically be controlled at all points along the sweep path. But for practical purposes, the creation of a twisted sweep feature will be limited to sweep features that are swept along a spline path and the twist can only be specified for cross-sections at fit points of the spline path. Since the sweep feature can only be twisted at fit points of the spline that defines the sweep path, the valid input points are only the fit points of the spline that defines the sweep path. If any of the specified input points are not fit points on the sweep path specified by the Path argument, then this method will fail. Therefore, the valid input objects can be either SketchPoint objects that correspond to any of the fit points of the sweep path if it is a 2D spline or SketchPoint3D objects that correspond to any of the fit points of the sweep path if it is a 3D spline. Since this argument together with the SectionTwistVectors argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by this argument must be the same as the number of items in the collection specified by the SectionTwistVectors argument.
  • The order of the sweep path points in the collection specified by this argument must correspond to the order of the twist unit-vectors in the collection specified by the SectionTwistVectors argument. Therefore, if a particular item number in the collection specified by this argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by the SectionTwistVectors argument should correspond to the twist vector for that sweep section.

For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by this argument is the first fit point of the sweep path, then the first item in the collection specified by the SectionTwistVectors argument must be the twist vector for the cross-section at the first fit point of the sweep path. This method will fail for the following cases:

  • The object collections specified for this argument and the SectionTwistVectors arguments are both empty.
  • Valid object collections are specified for both this argument and the SectionTwistVectors argument, but any of the sweep path points specified by this argument are not fit points on the sweep path specified by the Path argument.

SectionTwistVectors
Input ObjectCollection object that specifies the unit-vectors that define the twists for the sweep sections. The sweep twist vectors define the twists for the sweep cross-sections specified using the SectionTwistPoints argument. The twist vectors are unit-vectors specified in the model space coordinate system. Also, each vector should lie on the plane of the sweep cross-section for which it defines the twist, otherwise, this method will fail. Therefore, the valid input objects are UnitVector objects that specify the twist vector directions for the sweep sections. Since this argument together with the SectionTwistPoints argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by this argument must be the same as the number of items in the collection specified by the SectionTwistPoints argument.
  • The order of the sweep path points in the collection specified by the SectionTwistPoints argument must correspond to the order of the twist unit-vectors in the collection specified by this argument. Therefore, if a particular item number in the collection specified by the SectionTwistPoints argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by this argument should correspond to the twist vector for that sweep section.

For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by the SectionTwistPoints argument is the first fit point of the sweep path, then the first item in the collection specified by this argument must be the twist vector for the cross-section at the first fit point of the sweep path.
This method will fail for the following cases:

  • The object collections specified for this argument and the SectionTwistPoints arguments are both empty.
  • Valid object collections are specified for both this argument and the SectionTwistPoints argument, but any of the twist unit-vectors specified by this argument does not lie on the respective sweep cross-section plane for which the unit-vector defines the twist.

ProfileOrientation
Optional Input constant that indicates the orientation of the profile as it is being swept along the profile path. Valid input is one of the constants in SweepProfileOrientationEnum : kNormalToPath or kParallelToOriginalProfile. If kNormalToPath is specified, the sweep profile will be held normal to the path along all sections of the sweep. If kParallelToOriginalProfile is specified, the sweep profile section will always be parallel to the original input profile that defines the starting section for the sweep. If no value is specified for this argument, then kNormalToPath will be assumed to indicate that the profile should be normal to the path along all sections of the sweep.
TaperAngle
Optional Input Variant that defines the taper angle of the sweep. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. If a value for the taper angle is not explicitly specified, then the taper angle of the sweep feature will be set to zero.
Notes

If the sweep path is a 3D spline, then the geometry of the fit points will return a 3D point which can directly be specified as an input sweep path point. If the sweep path is a 2D spline, then the geometry of the fit points will return 2D points in the coordinate system of the sketch that contains the spline. The 2D points will have to be transformed to the model space coordinate system and this transformed 3D point can then be specified as an input sweep path point.

You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods > SweepFeature.SetUsingPathAndSectionTwists Method


SweepFeature.TaperAngle Method

SweepFeature.TaperAngle Method Available in Inventor Available in Server
Summary

Property that returns the parameter controlling the taper angle of the feature.

Visual Basic
Sub TaperAngle(Result As [out, retval] Parameter*)
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Methods > SweepFeature.TaperAngle Method


SweepFeature Properties

SweepFeature Properties
Summary

The properties of the SweepFeature class are listed here.

Properties
Name | Description
Definition | Property that returns the SweepDefinition object that defines how the sweep is defined. The type of definition object that will be returned can be determined by using the DefinitionType property.
DefinitionType | Property that returns an enum indicating how the sweep was defined.
EndFaces | Property that returns the set of that cap one end of the sweep that are coincident with the sketch plane. The end faces are those not coincident to the sketch plane of the feature's profile. In the case of a symmetric revolution these faces are the ones on the negative normal side of the sketch plane. In the cases where there aren't any end faces this property will return Nothing.
Operation | Property that gets and sets the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.
Path | Property that gets and sets the Path object that defines the path of sweep.
Profile | Property that gets and sets the Profile object that defines the shape of the sweep.
SideFaces | Property that returns a object that provides access to all of the faces created around the perimeter of the feature.
StartFaces | Property that returns the set of that cap one end of the sweep that are coincident with the sketch plane. In the cases where there aren't any start faces this property will return Nothing.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties


SweepFeature.Definition Property

SweepFeature.Definition Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the SweepDefinition object that defines how the sweep is defined. The type of definition object that will be returned can be determined by using the DefinitionType property.

Visual Basic
Property Definition() As SweepDefinition**
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.Definition Property


SweepFeature.DefinitionType Property

SweepFeature.DefinitionType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enum indicating how the sweep was defined.

Visual Basic
Property DefinitionType() As SweepDefinitionTypeEnum*
Remarks

This indicates the type of object returned by the Definition property. The valid return values are kPathSweepDef, kPathAndGuideRailSweepDef , kPathAndGuideSurfaceSweepDef and kPathAndSectionTwistsSweepDef.

You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.DefinitionType Property


SweepFeature.EndFaces Property

SweepFeature.EndFaces Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the set of that cap one end of the sweep that are coincident with the sketch plane. The end faces are those not coincident to the sketch plane of the feature's profile. In the case of a symmetric revolution these faces are the ones on the negative normal side of the sketch plane. In the cases where there aren't any end faces this property will return Nothing.

Visual Basic
Property EndFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.EndFaces Property


SweepFeature.Operation Property

SweepFeature.Operation Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.Operation Property


SweepFeature.Path Property

SweepFeature.Path Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the Path object that defines the path of sweep.

Visual Basic
Property Path() As Path*
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.Path Property


SweepFeature.Profile Property

SweepFeature.Profile Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the Profile object that defines the shape of the sweep.

Visual Basic
Property Profile() As Profile*
See Also

True length of sweep feature sample

You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.Profile Property


SweepFeature.SideFaces Property

SweepFeature.SideFaces Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a object that provides access to all of the faces created around the perimeter of the feature.

Visual Basic
Property SideFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.SideFaces Property


SweepFeature.StartFaces Property

SweepFeature.StartFaces Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the set of that cap one end of the sweep that are coincident with the sketch plane. In the cases where there aren't any start faces this property will return Nothing.

Visual Basic
Property StartFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > SweepFeature Interface > SweepFeature Properties > SweepFeature.StartFaces Property


SweepFeatureProxy Interface

SweepFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SweepFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::SweepFeature
        Inventor::SweepFeatureProxy
Visual Basic
Public Interface SweepFeatureProxy
Inherits SweepFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatureProxy Interface


SweepFeatureProxy Properties

SweepFeatureProxy Properties
Summary

The properties of the SweepFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatureProxy Interface > SweepFeatureProxy Properties


SweepFeatureProxy.ContainingOccurrence Property

SweepFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatureProxy Interface > SweepFeatureProxy Properties > SweepFeatureProxy.ContainingOccurrence Property


SweepFeatureProxy.NativeObject Property

SweepFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SweepFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatureProxy Interface > SweepFeatureProxy Properties > SweepFeatureProxy.NativeObject Property


SweepFeatures Interface

SweepFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SweepFeatures collection object provides access to all of the objects in a component definition and provides methods to create additional SweepFeature objects.

Class Hierarchy
Inventor::SweepFeatures
Visual Basic
Public Interface SweepFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Features.SweepFeatures

FlatPatternFeatures.SweepFeatures

PartFeatures.SweepFeatures

See Also

True length of sweep feature sample

Sweep Feature Add sample

Example

See SweepFeature for example "Adding a sweep feature"

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface


SweepFeatures Methods

SweepFeatures Methods
Summary

The methods of the SweepFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new SweepFeature. The new SweepFeature is returned.
AddUsingPath | Method that creates a new SweepFeature defined by a path and the orientation of the profile as it is swept along the path. If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method.
AddUsingPathAndGuideRail | Method that creates a new SweepFeature defined by a path and a guide rail that controls the scaling and twist of the profile section as it is being swept along the path. If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method.
AddUsingPathAndGuideSurface | Method that creates a new SweepFeature defined by a path and a guide surface that defines the orientation of the profile section as it is being swept along the path. If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method.
AddUsingPathAndSectionTwists | Method that creates a new SweepFeature defined by a path and the orientation of the profile as it is swept along the path.
CreatePath | Method that creates a path used to define the shape of several part features such as Sweep, RectangularPattern, Split, etc. All other 2D and 3D curves that are connected to the input curve are obtained and used to create a Path object. The new Path is returned.
GetProfileOrientationAtParam | Method that returns UnitVector objects indicating the orientation of the sweep profile at the specified parameter values along the path.
GetTruePath | Method that returns a transient curve (BSplineCurve, LineSegment, Arc3d, etc.) representing the true sweep path. This is different from the original path curve if the true start point is not the same as the start point of the original path curve.
Item | Method that returns the specified SweepFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods


SweepFeatures.Add Method

SweepFeatures.Add Method Available in Inventor Available in Server
Summary

Method that creates a new SweepFeature. The new SweepFeature is returned.

Visual Basic
Sub Add(Profile As Profile, Path As Path, Operation As PartFeatureOperationEnum, ByRef TaperAngle As [optional] VARIANT, Result As [out, retval] SweepFeature*)
Parameters
Parameters | Description
Profile | Input Profile object used to define the shape of the sweep. Open paths are valid when creating surfaces.
Path | Input entity that defines the path of the sweep. Use the CreatePath or CreateSpecifiedPath methods on the object to create a Path. The path can be a combination of 2D and 3D sketch elements.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.
TaperAngle | Input Variant that defines the taper angle of the sweep. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. If not supplied, the feature will be created with a taper angle of zero.
Example

See SweepFeature for example "Adding a sweep feature"

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.Add Method


SweepFeatures.AddUsingPath Method

SweepFeatures.AddUsingPath Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new SweepFeature defined by a path and the orientation of the profile as it is swept along the path. If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method.

Visual Basic
Sub AddUsingPath(Profile As Profile, SweepPath As Path, Operation As PartFeatureOperationEnum, ByRef ProfileOrientation As [defaultvalue(kNormalToPath)] SweepProfileOrientationEnum, ByRef TaperAngle As [optional] VARIANT, Result As [out, retval] SweepFeature*)
Parameters
Parameters | Description
Profile | Profile object used to define the shape of the sweep. Open profiles are valid when creating surfaces.
SweepPath | Path object that defines the path of the sweep. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements and can be open or closed.
Operation | Constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation or kSurfaceOperation.
ProfileOrientation | Optional Input constant that indicates the orientation of the profile as it is being swept along the profile path. Valid input is one of the constants in SweepProfileOrientationEnum : kNormalToPath or kParallelToOriginalProfile. If kNormalToPath is specified, the sweep profile will be held normal to the path along all sections of the sweep. If kParallelToOriginalProfile is specified, the sweep profile section will always be parallel to the original input profile that defines the starting section for the sweep. If no value is specified for this argument, then kNormalToPath will be assumed to indicate that the profile should be normal to the path along all sections of the sweep.
TaperAngle | Optional Input Variant that defines the taper angle of the sweep. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. If a value for the taper angle is not explicitly specified, then the sweep feature will be created with the taper angle assumed to be zero.
See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.AddUsingPath Method


SweepFeatures.AddUsingPathAndGuideRail Method

SweepFeatures.AddUsingPathAndGuideRail Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new SweepFeature defined by a path and a guide rail that controls the scaling and twist of the profile section as it is being swept along the path. If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method.

Visual Basic
Sub AddUsingPathAndGuideRail(Profile As Profile, SweepPath As Path, GuideRail As Path, Operation As PartFeatureOperationEnum, ByRef ProfileScaling As [defaultvalue(kXYProfileScaling)] SweepProfileScalingEnum, Result As [out, retval] SweepFeature*)
Parameters
Parameters | Description
Profile | Profile object used to define the shape of the sweep. Open profiles are valid when creating surfaces.
SweepPath | Path object that defines the path of the sweep. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements and can be open or closed.
GuideRail | Path object that defines the guide rail for the sweep which acts as a guide curve and controls the scaling and twist of the sweep profile. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements and can be open or closed.
Operation | Constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation or kSurfaceOperation.
ProfileScaling | Optional Input constant that defines the scaling direction for the sweep profile. Valid input is kXYProfileScaling, kXProfileScaling or kNoProfileScaling. The default value is kXYProfileScaling.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.AddUsingPathAndGuideRail Method


SweepFeatures.AddUsingPathAndGuideSurface Method

SweepFeatures.AddUsingPathAndGuideSurface Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new SweepFeature defined by a path and a guide surface that defines the orientation of the profile section as it is being swept along the path. If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method.

Visual Basic
Sub AddUsingPathAndGuideSurface(Profile As Profile, SweepPath As Path, GuideSurface As IDispatch, Operation As PartFeatureOperationEnum, Result As [out, retval] SweepFeature*)
Parameters
Parameters | Description
Profile | Profile object used to define the shape of the sweep. Open profiles are valid when creating surfaces.
SweepPath | Path object that defines the path of the sweep. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. The path can be a combination of 2D and 3D sketch elements and can be open or closed.
GuideSurface | Object that defines a guide surface the normal of which will control the twist of the swept profile about the path. Valid input objects for the guide surface are Face, FaceCollection or WorkPlane.
Operation | Constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation or kSurfaceOperation.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.AddUsingPathAndGuideSurface Method


SweepFeatures.AddUsingPathAndSectionTwists Method

SweepFeatures.AddUsingPathAndSectionTwists Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new SweepFeature defined by a path and the orientation of the profile as it is swept along the path.

Visual Basic
Sub AddUsingPathAndSectionTwists(Profile As Profile, SweepPath As Path, Operation As PartFeatureOperationEnum, SectionTwistPoints As ObjectCollection, SectionTwistVectors As ObjectCollection, ByRef ProfileOrientation As [defaultvalue(kNormalToPath)] SweepProfileOrientationEnum, ByRef TaperAngle As [optional] VARIANT, Result As [out, retval] SweepFeature*)
Parameters
Parameters
Description
Profile
Input Profile object used to define the shape of the sweep. Open profiles are valid when creating surfaces.
SweepPath
Input Path object that defines the path of the sweep. Use the CreatePath or CreateSpecifiedPath methods on the PartFeatures object to create a Path. Since the creation of a twisted sweep feature is limited to sweep features that are swept along a spline path, the specified path has to be a spline. If a spline is not specified for the path, then the creation of the sweep feature will fail. The path can be a combination of 2D and 3D sketch splines and can be open or closed.
Operation
Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation or kSurfaceOperation.
SectionTwistPoints
Input ObjectCollection that contains the points along the sweep path at which the sweep twists need to be specified. The sweep path points define the positions of the sweep cross-sections at which the twists need to be specified. Since the sweep feature is created by sweeping a profile cross-section along a sweep path, the twist of the sweep can theoretically be controlled at all points along the sweep path. But for practical purposes, the creation of a twisted sweep feature will be limited to sweep features that are swept along a spline path and the twist can only be specified for cross-sections at fit points of the spline path. Since the sweep feature can only be twisted at fit points of the spline that defines the sweep path, the valid input points are only the fit points of the spline that defines the sweep path. If any of the specified input points are not fit points on the sweep path specified by the Path argument, then the creation of the sweep feature will fail. Therefore, the valid input objects can be either SketchPoint objects that correspond to any of the fit points of the sweep path if it is a 2D spline or SketchPoint3D objects that correspond to any of the fit points of the sweep path if it is a 3D spline. Since this argument together with the SectionTwistVectors argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by this argument must be the same as the number of items in the collection specified by the SectionTwistVectors argument.
  • The order of the sweep path points in the collection specified by this argument must correspond to the order of the twist unit-vectors in the collection specified by the SectionTwistVectors argument. Therefore, if a particular item number in the collection specified by this argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by the SectionTwistVectors argument should correspond to the twist vector for that sweep section.

For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by this argument is the first fit point of the sweep path, then the first item in the collection specified by the SectionTwistVectors argument must be the twist vector for the cross-section at the first fit point of the sweep path. The creation of the sweep feature will fail for the following cases:

  • The object collections specified for this argument and the SectionTwistVectors arguments are both empty.
  • Valid object collections are specified for both this argument and the SectionTwistVectors argument, but any of the sweep path points specified by this argument are not fit points on the sweep path specified by the Path argument.

SectionTwistVectors
Input ObjectCollection object that specifies the unit-vectors that define the twists for the sweep sections. The sweep twist vectors define the twists for the sweep cross-sections specified using the SectionTwistPoints argument. The twist vectors are unit-vectors specified in the model space coordinate system. Also, each vector should lie on the plane of the sweep cross-section for which it defines the twist, otherwise, creation of the sweep feature will fail. Therefore, the valid input objects are UnitVector objects that specify the twist vector directions for the sweep sections. Since this argument together with the SectionTwistPoints argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by this argument must be the same as the number of items in the collection specified by the SectionTwistPoints argument.
  • The order of the sweep path points in the collection specified by the SectionTwistPoints argument must correspond to the order of the twist unit-vectors in the collection specified by this argument. Therefore, if a particular item number in the collection specified by the SectionTwistPoints argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by this argument should correspond to the twist vector for that sweep section.

For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by the SectionTwistPoints argument is the first fit point of the sweep path, then the first item in the collection specified by this argument must be the twist vector for the cross-section at the first fit point of the sweep path. The creation of the sweep feature will fail for the following cases:

  • The object collections specified for this argument and the SectionTwistPoints arguments are both empty.
  • Valid object collections are specified for both this argument and the SectionTwistPoints argument, but any of the twist unit-vectors specified by this argument does not lie on the respective sweep cross-section plane for which the unit-vector defines the twist.

ProfileOrientation
Optional Input constant that indicates the orientation of the profile as it is being swept along the profile path. Valid input is one of the constants in SweepProfileOrientationEnum : kNormalToPath or kParallelToOriginalProfile. If kNormalToPath is specified, the sweep profile will be held normal to the path along all sections of the sweep. If kParallelToOriginalProfile is specified, the sweep profile section will always be parallel to the original input profile that defines the starting section for the sweep. If no value is specified for this argument, then kNormalToPath will be assumed to indicate that the profile should be normal to the path along all sections of the sweep.
TaperAngle
Optional Input Variant that defines the taper angle of the sweep. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are radians. If a string is input, the units can be specified as part of the string or it will default to the current angle units of the document. If a value for the taper angle is not explicitly specified, then the sweep feature will be created with the taper angle assumed to be zero.
Remarks

If the sweep feature is created successfully, a SweepFeature object corresponding to the newly created sweep feature is returned from this method. The sweep twist at any given sweep cross-section can be defined as the rotation of the cross-section about the normal vector of the cross-section plane at the intersection point of the sweep path and the cross-section plane.

The diagram below shows an example of how a twisted sweep feature could be specified. In this example, the start section (profile to be swept) is a rectangle and the sweep path is a 3D spline. Section 1 denotes an intermediate sweep cross-section at which the sweep feature needs to be twisted in the anti-clockwise direction by 45 degrees. This implies that the cross-section will be twisted by 45 degrees about the normal to the cross-section plane (Z) at the intersection point of the sweep path and the cross-section plane (P). Section 2 denotes another intermediate sweep cross-section at which no twist has been specified.

Since the sweep feature is created by sweeping a profile cross-section along a sweep path, the twist of the sweep can theoretically be controlled at all points along the sweep path. But for practical purposes, the creation of a twisted sweep feature will be limited to sweep features that are swept along a spline path and the twist can only be specified for cross-sections at fit points of the spline path. Therefore, the sweep feature can only be twisted at fit points of the spline that defines the sweep path. Therefore, two items are needed to specify a twist condition for a sweep cross-section:

  • The fit point on the spline path at which the sweep feature needs to be twisted

The fit point defines the position of the sweep cross-section at which a twist needs to be specified. If the sweep path is a 3D spline, then the fit points will be 3D sketch points any of which can be used to specify the position of the sweep cross-section that needs to be twisted. If the sweep path is a 2D spline, then the fit points will be 2D sketch points any of which can be used to specify the position of the sweep cross-section that needs to be twisted. Considering the example shown in Figure 1, for Section 1, the fit point on the sweep path would be point P1. Similarly, for Section 2, the fit point on the sweep path would be point P2.

  • The actual twist or rotation of the sweep cross-section at the fit point

The rotation of the sweep cross-section is specified using a twist unit-vector that lies on the plane of the sweep cross-section. The purpose of the unit-vector can be understood by assuming a coordinate system associated with the sweep cross-section plane as shown in Figure 1. In order to specify a twist for a sweep cross-section, we first need its current orientation. For this, we need a reference vector on the sketch plane and a twist vector on the sweep cross-section plane that maps to the reference vector. The reference vector is defined to be the vector (in model space coordinates) that corresponds to the X axis of the sketch plane that is used to create the sweep profile (the starting section for the sweep) as shown in Figure 1. Since, the twist vector for the sweep cross-sections map to this reference vector, the twist vector at the starting cross-section plane of the sweep is the same as the reference vector. But, as the sweep feature is generated by sweeping the original profile along the sweep path, the cross-section plane of the sweep will be re-oriented based on the direction of the sweep path. Hence, the direction of the twist vector for the sweep cross-sections will likely deviate from the reference vector. But, unless a twist condition is explicitly specified, the sweep cross-section will either twist by a default amount as specified by the rail law for the sweep or not twist at all. For the example shown in Figure1, the direction of the twist vector for the un-twisted Section 1 will be the vector corresponding to X'. Then, a new direction for this twist vector can be specified for each sweep cross-section for which a twist needs to be specified. The cross-section will then be twisted so that the twist vector aligns with the newly specified direction. For the example shown in Figure1, in order to twist the Section 1 by 45 degrees in the anti-clockwise direction, the twist vector should be set to the vector corresponding to X. Since only the direction of the twist vector is important to specify the twist and its magnitude is irrelevant, the twist vector is a unit-vector defined in the model space coordinate system. Also, this vector should lie on the plane of the sweep cross-section for which it defines the twist. If a new twist condition needs to be applied at a sweep cross-section by specifying a new twist vector, the new twist vector should lie on the plane of that cross-section, otherwise, applying the twist to the cross-section will fail. The two items needed to specify a twist condition (as mentioned above) can be specified using the SectionTwistPoints and SectionTwistVectors arguments respectively. The SectionTwistPoints object collection contains the set of fit points on the sweep path at which the twists need to be specified. In other words, this collection specifies the set of sweep cross-sections at which the twists need to be specified. The SectionTwistVectors object collection specifies the twist vectors for the set of cross-sections specified in the SectionTwistPoints argument. The SectionTwistPoints argument together with the SectionTwistVectors argument defines the twist conditions at all cross-sections of the sweep at which the twist needs to be specified, valid collection objects need to be specified for both these arguments in order to define twist conditions for the sweep. Also, the following conditions need to be satisfied in order to correctly specify both these arguments:

  • The number of items in the collection specified by the SectionTwistPoints argument must be the same as the number of items in the collection specified by the SectionTwistVectors argument.
  • The order of the sweep path points in the collection specified by the SectionTwistPoints argument must correspond to the order of the twist unit-vectors in the collection specified by the SectionTwistVectors argument. Therefore, if a particular item number in the collection specified by the SectionTwistPoints argument corresponds to a particular sweep path point at which the sweep section needs to be twisted, the same item number in the collection specified by the SectionTwistVectors argument should correspond to the twist vector for that sweep section.

For example, for a twist condition that needs to be applied for the sweep cross-section at the first fit point of the sweep path, if the first item in the collection specified by the SectionTwistPoints argument is this first fit point, then the first item in the collection specified by the SectionTwistVectors argument must be the twist vector for the cross-section at this first fit point. Therefore, if a twist condition needs to be specified at a particular sweep section, typically, the sweep path point at this section will be added to the object collection specified by the SectionTwistPoints argument and the twist vector that specifies the twist for that section will be added to the object collection specified by the SectionTwistVectors argument.

The creation of the sweep feature will fail for the following cases:

  • The object collections specified for the SectionTwistPoints and SectionTwistVectors arguments are both empty.
  • If any of the sweep path points specified by the SectionTwistPoints argument are not fit points on the sweep path specified by the Path argument.
  • If any of the twist unit-vectors specified by the SectionTwistVectors argument does not lie on the respective sweep cross-section plane for which the unit-vector defines the twist.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.AddUsingPathAndSectionTwists Method


SweepFeatures.CreatePath Method

SweepFeatures.CreatePath Method Available in Inventor Available in Server
Summary

Method that creates a path used to define the shape of several part features such as Sweep, RectangularPattern, Split, etc. All other 2D and 3D curves that are connected to the input curve are obtained and used to create a Path object. The new Path is returned.

Visual Basic
Sub CreatePath(SketchCurve As IDispatch, Result As [out, retval] Path*)
Parameters
Parameters | Description
SketchCurve | Input sketch (planar or 3D) entity. This can be any entity that is part of the desired path. All curves that are end point connected will be found and used to create the path.
See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.CreatePath Method


SweepFeatures.GetProfileOrientationAtParam Method

SweepFeatures.GetProfileOrientationAtParam Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns UnitVector objects indicating the orientation of the sweep profile at the specified parameter values along the path.

Visual Basic
Sub GetProfileOrientationAtParam(PathCurve As IDispatch, StartProfileOrientation As UnitVector, StartProfileNormal As UnitVector, Params As SAFEARRAY(double), Result As [out, retval] ObjectsEnumerator*)
Parameters
Parameters | Description
PathCurve | Input object that specifies the sweep path. This can be a 2d or 3d sketch entity.
StartProfileOrientation | Input UnitVector that specifies the orientation of the profile at the start point.
StartProfileNormal | Input UnitVector that specifies the normal of the profile at the start point.
Params | Input array of doubles that specifies the parameters along the curve at which to obtain the profile orientations.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.GetProfileOrientationAtParam Method


SweepFeatures.GetTruePath Method

SweepFeatures.GetTruePath Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns a transient curve (BSplineCurve, LineSegment, Arc3d, etc.) representing the true sweep path. This is different from the original path curve if the true start point is not the same as the start point of the original path curve.

Visual Basic
Sub GetTruePath(PathCurves As IDispatch, TrueStartPoint As Point, Result As [out, retval] IDispatch*)
Parameters
Parameters | Description
TrueStartPoint | Input Point object that specifies the true start point of the sweep feature. This is typically the centroid of the sweep profile.
Example

"True length of sweep feature"

This sample demonstrates the calculation of the true length of a sweep feature. If the centroid of the sweep profile does not lie on the sweep path, the true length of the sweep feature is not the same as the sum of lengths of the path entities.

Sub TrueSweepLength()

    'Set a reference to the active part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oDef As PartComponentDefinition
    Set oDef = oDoc.ComponentDefinition

    ' Check to make sure a sweep feature is selected.
    If Not TypeOf oDoc.SelectSet.Item(1) Is SweepFeature Then
        MsgBox "A sweep feature must be selected."
        Exit Sub
    End If

    ' Set a reference to the selected feature.
    Dim oSweep As SweepFeature
    Set oSweep = oDoc.SelectSet.Item(1)

    ' Get the centroid of the sweep profile in sketch space
    Dim oProfileOrigin As Point2d
    Set oProfileOrigin = oSweep.Profile.RegionProperties.Centroid

    ' Transform the centroid from sketch space to model space
    Dim oProfileOrigin3D As Point
    Set oProfileOrigin3D = oSweep.Profile.Parent.SketchToModelSpace(oProfileOrigin)

    ' Get the set of curves that represent the true path of the sweep
    Dim oCurves As ObjectsEnumerator
    Set oCurves = oDef.Features.SweepFeatures.GetTruePath(oSweep.Path, oProfileOrigin3D)

    Dim TotalLength As Double
    TotalLength = 0

    Dim oCurve As Object
    For Each oCurve In oCurves

        Dim oCurveEval As CurveEvaluator
        Set oCurveEval = oCurve.Evaluator

        Dim MinParam As Double
        Dim MaxParam As Double
        Dim Length As Double

        Call oCurveEval.GetParamExtents(MinParam, MaxParam)
        Call oCurveEval.GetLengthAtParam(MinParam, MaxParam, Length)

        TotalLength = TotalLength + Length
    Next

    ' Display total sweep length
    MsgBox "Total sweep length = " & ThisApplication.UnitsOfMeasure.GetStringFromValue(TotalLength, kInchLengthUnits)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.GetTruePath Method


SweepFeatures.Item Method

SweepFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the specified SweepFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] SweepFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Methods > SweepFeatures.Item Method


SweepFeatures Properties

SweepFeatures Properties
Summary

The properties of the SweepFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Properties


SweepFeatures.Application Property

SweepFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Properties > SweepFeatures.Application Property


SweepFeatures.Count Property

SweepFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Properties > SweepFeatures.Count Property


SweepFeatures.Type Property

SweepFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > SweepFeatures Interface > SweepFeatures Properties > SweepFeatures.Type Property


SymmetryConstraint Interface

SymmetryConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The SymmetryConstraint object represents a symmetry constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::SymmetryConstraint
        Inventor::SymmetryConstraintProxy
Visual Basic
Public Interface SymmetryConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddSymmetry

SymmetryConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraint Interface


SymmetryConstraint Properties

SymmetryConstraint Properties
Summary

The properties of the SymmetryConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity that is constrained to be symmetric to the entity returned by the EntityTwo property.
EntityTwo | Property that returns the sketch entity that is constrained to be symmetric to the entity returned by the EntityOne property.
SymmetryLine | Property that returns the sketch entity that defines the axis of symmetry.
You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraint Interface > SymmetryConstraint Properties


SymmetryConstraint.EntityOne Property

SymmetryConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity that is constrained to be symmetric to the entity returned by the EntityTwo property.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraint Interface > SymmetryConstraint Properties > SymmetryConstraint.EntityOne Property


SymmetryConstraint.EntityTwo Property

SymmetryConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity that is constrained to be symmetric to the entity returned by the EntityOne property.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraint Interface > SymmetryConstraint Properties > SymmetryConstraint.EntityTwo Property


SymmetryConstraint.SymmetryLine Property

SymmetryConstraint.SymmetryLine Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity that defines the axis of symmetry.

Visual Basic
Property SymmetryLine() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraint Interface > SymmetryConstraint Properties > SymmetryConstraint.SymmetryLine Property


SymmetryConstraintProxy Interface

SymmetryConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the SymmetryConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::SymmetryConstraint
        Inventor::SymmetryConstraintProxy
Visual Basic
Public Interface SymmetryConstraintProxy
Inherits SymmetryConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraintProxy Interface


SymmetryConstraintProxy Properties

SymmetryConstraintProxy Properties
Summary

The properties of the SymmetryConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraintProxy Interface > SymmetryConstraintProxy Properties


SymmetryConstraintProxy.ContainingOccurrence Property

SymmetryConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraintProxy Interface > SymmetryConstraintProxy Properties > SymmetryConstraintProxy.ContainingOccurrence Property


SymmetryConstraintProxy.NativeObject Property

SymmetryConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As SymmetryConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > SymmetryConstraintProxy Interface > SymmetryConstraintProxy Properties > SymmetryConstraintProxy.NativeObject Property


TableFormat Interface

TableFormat Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The TableFormat object contains values for the various overrides of the table's appearance.

Class Hierarchy
Inventor::TableFormat
Visual Basic
Public Interface TableFormat
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CustomTable.OverrideFormat

CustomTables.CreateTableFormat

See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface


TableFormat Properties

TableFormat Properties
Summary

The properties of the TableFormat class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
InsideLineColor | Property that gets and sets the color of the inner lines of the table.
InsideLineWeight | Property that gets and sets the line weight of the inner lines of the table.
OutsideLineColor | Property that gets and sets the color of the outer lines of the table.
OutsideLineWeight | Property that gets and sets the line weight of the outer lines of the table.
TextStyle | Property that gets and sets the text style used for the contents of the table.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties


TableFormat.Application Property

TableFormat.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.Application Property


TableFormat.InsideLineColor Property

TableFormat.InsideLineColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the color of the inner lines of the table.

Visual Basic
Property InsideLineColor() As Color*
See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.InsideLineColor Property


TableFormat.InsideLineWeight Property

TableFormat.InsideLineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line weight of the inner lines of the table.

Visual Basic
Property InsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.InsideLineWeight Property


TableFormat.OutsideLineColor Property

TableFormat.OutsideLineColor Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the color of the outer lines of the table.

Visual Basic
Property OutsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.OutsideLineColor Property


TableFormat.OutsideLineWeight Property

TableFormat.OutsideLineWeight Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the line weight of the outer lines of the table.

Visual Basic
Property OutsideLineWeight() As double
See Also

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.OutsideLineWeight Property


TableFormat.TextStyle Property

TableFormat.TextStyle Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property TextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.TextStyle Property


TableFormat.Type Property

TableFormat.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TableFormat Interface > TableFormat Properties > TableFormat.Type Property


TableParameter Interface

TableParameter Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a parameter that was created automatically by Autodesk Inventor as the result of reading a spreadsheet.

Class Hierarchy
Inventor::Parameter
    Inventor::TableParameter
Visual Basic
Public Interface TableParameter
Inherits Parameter
Notes

Members through which this object may be accessed include:

TableParameters.Item

You are here: Symbol Reference > Inventor Library > Objects > TableParameter Interface


TableParameter Methods

TableParameter Methods
Summary

The methods of the TableParameter class are listed here.

Methods
Methods
Name | Description
ConvertToUserParameter | Method that causes the parameter to be converted to a user parameter. The new UserParameter object is returned.
You are here: Symbol Reference > Inventor Library > Objects > TableParameter Interface > TableParameter Methods


TableParameter.ConvertToUserParameter Method

TableParameter.ConvertToUserParameter Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that causes the parameter to be converted to a user parameter. The new UserParameter object is returned.

Visual Basic
Sub ConvertToUserParameter(Result As [out, retval] UserParameter*)
You are here: Symbol Reference > Inventor Library > Objects > TableParameter Interface > TableParameter Methods > TableParameter.ConvertToUserParameter Method


TableParameters Interface

TableParameters Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the objects associated with the ParameterTable object the collection was obtained from.

Class Hierarchy
Inventor::TableParameters
Visual Basic
Public Interface TableParameters
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ParameterTable.TableParameters

See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > TableParameters Interface


TableParameters Methods

TableParameters Methods
Summary

The methods of the TableParameters class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified TableParameter object from the collection. This is the default property of the TableParameters collection object.
You are here: Symbol Reference > Inventor Library > Objects > TableParameters Interface > TableParameters Methods


TableParameters.Item Method

TableParameters.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified TableParameter object from the collection. This is the default property of the TableParameters collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] TableParameter*)
Parameters
Parameters | Description
index | Input Variant value that specifies the TableParameter to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the parameter name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > TableParameters Interface > TableParameters Methods > TableParameters.Item Method


TableParameters Properties

TableParameters Properties
Summary

The properties of the TableParameters class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TableParameters Interface > TableParameters Properties


TableParameters.Count Property

TableParameters.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
See Also

Table Parameters sample

You are here: Symbol Reference > Inventor Library > Objects > TableParameters Interface > TableParameters Properties > TableParameters.Count Property


TableParameters.Type Property

TableParameters.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TableParameters Interface > TableParameters Properties > TableParameters.Type Property


TableStyle Interface

TableStyle Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The TableStyle object represents a general (custom) table style in a drawing. The properties and methods listed below are in addition to those supported by the Style object.

Class Hierarchy
Inventor::Style
    Inventor::TableStyle
Visual Basic
Public Interface TableStyle
Inherits Style
Notes

Members through which this object may be accessed include:

CustomTable.Style

ObjectDefaultsStyle.BendTableStyle

ObjectDefaultsStyle.ConfigurationTableStyle

ObjectDefaultsStyle.TableStyle

TableStylesEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface


TableStyle Methods

TableStyle Methods
Summary

The methods of the TableStyle class are listed here.

Methods
Methods
Name | Description
AddColumn | Method that adds a column to the list of default columns in the style.
RemoveAllColumns | Method that removes all columns from the style.
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Methods


TableStyle.AddColumn Method

TableStyle.AddColumn Method Introduced in Inventor 2011
Summary

Method that adds a column to the list of default columns in the style.

Visual Basic
Sub AddColumn(ByRef Title As [defaultvalue("")] BSTR, ByRef Width As [defaultvalue(0)] double, ByRef TitleHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum, ByRef ValueHorizontalJustification As [defaultvalue(kAlignTextCenter)] HorizontalTextAlignmentEnum)
Parameters
Parameters | Description
Title | Optional input String that specifies the column title. If not specified, a default name is used.
Width | Optional input Double that specifies the width of the column. If not specified, the default width value is used. A value of 0 indicates the default width value.
TitleHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column title.
ValueHorizontalJustification | Optional input HorizontalTextAlignmentEnum that specifies the text justification for the column values.
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Methods > TableStyle.AddColumn Method


TableStyle.RemoveAllColumns Method

TableStyle.RemoveAllColumns Method
Summary

Method that removes all columns from the style.

Visual Basic
Sub RemoveAllColumns()
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Methods > TableStyle.RemoveAllColumns Method


TableStyle Properties

TableStyle Properties
Summary

The properties of the TableStyle class are listed here.

Properties
Name | Description
ColumnHeaderTextStyle | Property that gets and sets the text style used for the column titles (headers).
ColumnTitleHorizontalJustification | Property that gets and sets the justification of the column title.
ColumnValueHorizontalJustification | Property that gets and sets the justification of the values in the column.
ColumnWidth | Property that gets and sets the default width of columns in centimeters.
DataTextStyle | Property that gets and sets the text style used for the contents of the table.
HeadingGap | Property that gets and sets the heading gap in centimeters.
HeadingPlacement | Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.
InsideLineColor | Property that gets and sets the color of the inner lines of the table.
InsideLineWeight | Property that gets and sets the line weight of the inner lines of the table.
OutsideLineColor | Property that gets and sets the color of the outer lines of the table.
OutsideLineWeight | Property that gets and sets the line weight of the outer lines of the table.
RowGap | Property that gets and sets the row gap in centimeters.
RowLineSpacing | Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.
ShowTitle | Property that specifies the whether to show the title of the table.
TableDirection | Property that gets and sets the direction of the table. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.
Title | Property that gets and sets the title of the table.
TitleTextStyle | Property that gets and sets the text style used for the title of the table.
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties


TableStyle.ColumnHeaderTextStyle Property

TableStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the column titles (headers).

Visual Basic
Property ColumnHeaderTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.ColumnHeaderTextStyle Property


TableStyle.ColumnTitleHorizontalJustification Property

TableStyle.ColumnTitleHorizontalJustification Property Introduced in Inventor 2011
Summary

Property that gets and sets the justification of the column title.

Visual Basic
Property ColumnTitleHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.ColumnTitleHorizontalJustification Property


TableStyle.ColumnValueHorizontalJustification Property

TableStyle.ColumnValueHorizontalJustification Property Introduced in Inventor 2011
Summary

Property that gets and sets the justification of the values in the column.

Visual Basic
Property ColumnValueHorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.ColumnValueHorizontalJustification Property


TableStyle.ColumnWidth Property

TableStyle.ColumnWidth Property Introduced in Inventor 2011
Summary

Property that gets and sets the default width of columns in centimeters.

Visual Basic
Property ColumnWidth() As double
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.ColumnWidth Property


TableStyle.DataTextStyle Property

TableStyle.DataTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the contents of the table.

Visual Basic
Property DataTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.DataTextStyle Property


TableStyle.HeadingGap Property

TableStyle.HeadingGap Property Introduced in Inventor 2011
Summary

Property that gets and sets the heading gap in centimeters.

Visual Basic
Property HeadingGap() As double
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.HeadingGap Property


TableStyle.HeadingPlacement Property

TableStyle.HeadingPlacement Property Introduced in Inventor 2011
Summary

Property that gets and sets the location of the heading (title). Valid values are kHeadingAtTop, kHeadingAtBottom and kNoHeading.

Visual Basic
Property HeadingPlacement() As HeadingPlacementEnum
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.HeadingPlacement Property


TableStyle.InsideLineColor Property

TableStyle.InsideLineColor Property Introduced in Inventor 2011
Summary

Property that gets and sets the color of the inner lines of the table.

Visual Basic
Property InsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.InsideLineColor Property


TableStyle.InsideLineWeight Property

TableStyle.InsideLineWeight Property Introduced in Inventor 2011
Summary

Property that gets and sets the line weight of the inner lines of the table.

Visual Basic
Property InsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.InsideLineWeight Property


TableStyle.OutsideLineColor Property

TableStyle.OutsideLineColor Property Introduced in Inventor 2011
Summary

Property that gets and sets the color of the outer lines of the table.

Visual Basic
Property OutsideLineColor() As Color*
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.OutsideLineColor Property


TableStyle.OutsideLineWeight Property

TableStyle.OutsideLineWeight Property Introduced in Inventor 2011
Summary

Property that gets and sets the line weight of the outer lines of the table.

Visual Basic
Property OutsideLineWeight() As double
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.OutsideLineWeight Property


TableStyle.RowGap Property

TableStyle.RowGap Property Introduced in Inventor 2011
Summary

Property that gets and sets the row gap in centimeters.

Visual Basic
Property RowGap() As double
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.RowGap Property


TableStyle.RowLineSpacing Property

TableStyle.RowLineSpacing Property Introduced in Inventor 2011
Summary

Property that gets and sets the spacing between the rows. Valid values are kSingleLineSpacing, kDoubleLineSpacing and kTripleLineSpacing.

Visual Basic
Property RowLineSpacing() As LineSpacingEnum
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.RowLineSpacing Property


TableStyle.ShowTitle Property

TableStyle.ShowTitle Property Introduced in Inventor 2011
Summary

Property that specifies the whether to show the title of the table.

Visual Basic
Property ShowTitle() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.ShowTitle Property


TableStyle.TableDirection Property

TableStyle.TableDirection Property Introduced in Inventor 2011
Summary

Property that gets and sets the direction of the table. Valid values are kTopDownDirection, indicating an ascending order and kBottomUpDirection, indicating a descending order.

Visual Basic
Property TableDirection() As TableDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.TableDirection Property


TableStyle.Title Property

TableStyle.Title Property Introduced in Inventor 2011
Summary

Property that gets and sets the title of the table.

Visual Basic
Property Title() As String
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.Title Property


TableStyle.TitleTextStyle Property

TableStyle.TitleTextStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the text style used for the title of the table.

Visual Basic
Property TitleTextStyle() As TextStyle*
You are here: Symbol Reference > Inventor Library > Objects > TableStyle Interface > TableStyle Properties > TableStyle.TitleTextStyle Property


TableStylesEnumerator Interface

TableStylesEnumerator Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The TableStylesEnumerator object provides access to the existing TableStyle objects.

Class Hierarchy
Inventor::TableStylesEnumerator
Visual Basic
Public Interface TableStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.TableStyles

You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface


TableStylesEnumerator Methods

TableStylesEnumerator Methods
Summary

The methods of the TableStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified TableStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Methods


TableStylesEnumerator.Item Method

TableStylesEnumerator.Item Method Introduced in Inventor 2011
Summary

Property that returns the specified TableStyle object from the collection.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] TableStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the TableStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the TableStyle name. If an out of range index or a name of a non-existent TableStyle is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Methods > TableStylesEnumerator.Item Method


TableStylesEnumerator Properties

TableStylesEnumerator Properties
Summary

The properties of the TableStylesEnumerator class are listed here.

Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class TableStylesEnumerator.
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning kTableStylesEnumeratorObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Properties


TableStylesEnumerator._NewEnum Property

TableStylesEnumerator._NewEnum Property
Summary

This is _NewEnum, a member of class TableStylesEnumerator.

Visual Basic
Property _NewEnum() As IUnknown**
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Properties > TableStylesEnumerator._NewEnum Property


TableStylesEnumerator.Application Property

TableStylesEnumerator.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Properties > TableStylesEnumerator.Application Property


TableStylesEnumerator.Count Property

TableStylesEnumerator.Count Property Introduced in Inventor 2011
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Properties > TableStylesEnumerator.Count Property


TableStylesEnumerator.Type Property

TableStylesEnumerator.Type Property Introduced in Inventor 2011
Summary

Property returning kTableStylesEnumeratorObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TableStylesEnumerator Interface > TableStylesEnumerator Properties > TableStylesEnumerator.Type Property


TangentConstraint Interface

TangentConstraint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a tangent assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::TangentConstraint
        Inventor::TangentConstraintProxy
Visual Basic
Public Interface TangentConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToTangentConstraint

AssemblyConstraints.AddTangentConstraint

TangentConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint Interface


TangentConstraint Properties

TangentConstraint Properties
Summary

The properties of the TangentConstraint class are listed here.

Properties
Name | Description
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.
InsideTangency | Property that returns whether the curvatures of the surfaces at the point of tangency are on the same side. True if they are on the same side.
Offset | Property that returns the Parameter object that controls the offset distance of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint Interface > TangentConstraint Properties


TangentConstraint.ConstraintLimits Property

TangentConstraint.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the constraint.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint Interface > TangentConstraint Properties > TangentConstraint.ConstraintLimits Property


TangentConstraint.InsideTangency Property

TangentConstraint.InsideTangency Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns whether the curvatures of the surfaces at the point of tangency are on the same side. True if they are on the same side.

Visual Basic
Property InsideTangency() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint Interface > TangentConstraint Properties > TangentConstraint.InsideTangency Property


TangentConstraint.Offset Property

TangentConstraint.Offset Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Parameter object that controls the offset distance of the constraint.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint Interface > TangentConstraint Properties > TangentConstraint.Offset Property


TangentConstraint3D Interface

TangentConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The TangentConstraint3D object represents a tangent constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::TangentConstraint3D
        Inventor::TangentConstraint3DProxy
Visual Basic
Public Interface TangentConstraint3D
Inherits GeometricConstraint3D
Notes

Members through which this object may be accessed include:

GeometricConstraints3D.AddTangent

TangentConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3D Interface


TangentConstraint3D Methods

TangentConstraint3D Methods
Summary

The methods of the TangentConstraint3D class are listed here.

Methods
Methods
Name | Description
FlipDirection | Flips the direction of the tangency between the two 3D entities.
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3D Interface > TangentConstraint3D Methods


TangentConstraint3D.FlipDirection Method

TangentConstraint3D.FlipDirection Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Flips the direction of the tangency between the two 3D entities.

Visual Basic
Sub FlipDirection()
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3D Interface > TangentConstraint3D Methods > TangentConstraint3D.FlipDirection Method


TangentConstraint3D Properties

TangentConstraint3D Properties
Summary

The properties of the TangentConstraint3D class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity that is constrained to be tangent to entity two.
EntityTwo | Property that returns the sketch entity that is constrained to be tangent to entity one.
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3D Interface > TangentConstraint3D Properties


TangentConstraint3D.EntityOne Property

TangentConstraint3D.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the sketch entity that is constrained to be tangent to entity two.

Visual Basic
Property EntityOne() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3D Interface > TangentConstraint3D Properties > TangentConstraint3D.EntityOne Property


TangentConstraint3D.EntityTwo Property

TangentConstraint3D.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the sketch entity that is constrained to be tangent to entity one.

Visual Basic
Property EntityTwo() As SketchEntity3D**
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3D Interface > TangentConstraint3D Properties > TangentConstraint3D.EntityTwo Property


TangentConstraint3DProxy Interface

TangentConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentConstraint3D object.

Class Hierarchy
Inventor::GeometricConstraint3D
    Inventor::TangentConstraint3D
        Inventor::TangentConstraint3DProxy
Visual Basic
Public Interface TangentConstraint3DProxy
Inherits TangentConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3DProxy Interface


TangentConstraint3DProxy Properties

TangentConstraint3DProxy Properties
Summary

The properties of the TangentConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3DProxy Interface > TangentConstraint3DProxy Properties


TangentConstraint3DProxy.ContainingOccurrence Property

TangentConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3DProxy Interface > TangentConstraint3DProxy Properties > TangentConstraint3DProxy.ContainingOccurrence Property


TangentConstraint3DProxy.NativeObject Property

TangentConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TangentConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraint3DProxy Interface > TangentConstraint3DProxy Properties > TangentConstraint3DProxy.NativeObject Property


TangentConstraintProxy Interface

TangentConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::TangentConstraint
        Inventor::TangentConstraintProxy
Visual Basic
Public Interface TangentConstraintProxy
Inherits TangentConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraintProxy Interface


TangentConstraintProxy Properties

TangentConstraintProxy Properties
Summary

The properties of the TangentConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TangentConstraintProxy Interface > TangentConstraintProxy Properties


TangentConstraintProxy.ContainingOccurrence Property

TangentConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraintProxy Interface > TangentConstraintProxy Properties > TangentConstraintProxy.ContainingOccurrence Property


TangentConstraintProxy.NativeObject Property

TangentConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TangentConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentConstraintProxy Interface > TangentConstraintProxy Properties > TangentConstraintProxy.NativeObject Property


TangentDistanceDimConstraint Interface

TangentDistanceDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TangentDistanceDimConstraint object represents a constraint that controls the distance to a circle or arc at the tangent location.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::TangentDistanceDimConstraint
        Inventor::TangentDistanceDimConstraintProxy
Visual Basic
Public Interface TangentDistanceDimConstraint
Inherits DimensionConstraint
Remarks

The pictures below illustrate the uses of this constraint.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddTangentDistance

TangentDistanceDimConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface


TangentDistanceDimConstraint Properties

TangentDistanceDimConstraint Properties
Summary

The properties of the TangentDistanceDimConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the first circle or line being constrained.
EntityTwo | Property that returns the second circle or line being constrained.
LinearDiameter | Property that returns whether the dimension is a linear diameter style of dimension. Returns True if it is a linear diameter dimension.
ProximityPointOne | The point supplied by this argument is used when EntityOne is a circle or arc. This point specifies which of the possible two tangent cases is used when creating the constraint. The closest tangent to the input point is used. If EntityOne is a line, this argument is ignored.
ProximityPointTwo | The point supplied by this argument is used when EntityTwo is a circle or arc. This point specifies which of the possible two tangent cases is used when creating the constraint. The closest tangent to the input point is used. If EntityTwo is a line, this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface > TangentDistanceDimConstraint Properties


TangentDistanceDimConstraint.EntityOne Property

TangentDistanceDimConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first circle or line being constrained.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface > TangentDistanceDimConstraint Properties > TangentDistanceDimConstraint.EntityOne Property


TangentDistanceDimConstraint.EntityTwo Property

TangentDistanceDimConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second circle or line being constrained.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface > TangentDistanceDimConstraint Properties > TangentDistanceDimConstraint.EntityTwo Property


TangentDistanceDimConstraint.LinearDiameter Property

TangentDistanceDimConstraint.LinearDiameter Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns whether the dimension is a linear diameter style of dimension. Returns True if it is a linear diameter dimension.

Visual Basic
Property LinearDiameter() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface > TangentDistanceDimConstraint Properties > TangentDistanceDimConstraint.LinearDiameter Property


TangentDistanceDimConstraint.ProximityPointOne Property

TangentDistanceDimConstraint.ProximityPointOne Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

The point supplied by this argument is used when EntityOne is a circle or arc. This point specifies which of the possible two tangent cases is used when creating the constraint. The closest tangent to the input point is used. If EntityOne is a line, this argument is ignored.

Visual Basic
Property ProximityPointOne() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface > TangentDistanceDimConstraint Properties > TangentDistanceDimConstraint.ProximityPointOne Property


TangentDistanceDimConstraint.ProximityPointTwo Property

TangentDistanceDimConstraint.ProximityPointTwo Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

The point supplied by this argument is used when EntityTwo is a circle or arc. This point specifies which of the possible two tangent cases is used when creating the constraint. The closest tangent to the input point is used. If EntityTwo is a line, this argument is ignored.

Visual Basic
Property ProximityPointTwo() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraint Interface > TangentDistanceDimConstraint Properties > TangentDistanceDimConstraint.ProximityPointTwo Property


TangentDistanceDimConstraintProxy Interface

TangentDistanceDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentDistanceDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::TangentDistanceDimConstraint
        Inventor::TangentDistanceDimConstraintProxy
Visual Basic
Public Interface TangentDistanceDimConstraintProxy
Inherits TangentDistanceDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraintProxy Interface


TangentDistanceDimConstraintProxy Properties

TangentDistanceDimConstraintProxy Properties
Summary

The properties of the TangentDistanceDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraintProxy Interface > TangentDistanceDimConstraintProxy Properties


TangentDistanceDimConstraintProxy.ContainingOccurrence Property

TangentDistanceDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraintProxy Interface > TangentDistanceDimConstraintProxy Properties > TangentDistanceDimConstraintProxy.ContainingOccurrence Property


TangentDistanceDimConstraintProxy.NativeObject Property

TangentDistanceDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TangentDistanceDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentDistanceDimConstraintProxy Interface > TangentDistanceDimConstraintProxy Properties > TangentDistanceDimConstraintProxy.NativeObject Property


TangentiMateDefinition Interface

TangentiMateDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The TangentiMateDefinition object represents a tangent iMate definition. It is derived from the iMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::TangentiMateDefinition
        Inventor::TangentiMateDefinitionProxy
Visual Basic
Public Interface TangentiMateDefinition
Inherits iMateDefinition
Notes

Members through which this object may be accessed include:

iMateDefinitions.AddTangentiMateDefinition

You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinition Interface


TangentiMateDefinition Properties

TangentiMateDefinition Properties
Summary

The properties of the TangentiMateDefinition class are listed here.

Properties
Name | Description
ConstraintLimits | Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.
Entity | Property that returns the entity used for the iMate definition.
InsideTangency | Property that returns whether the curvatures of the surfaces at the point of tangency are on the same side. True if they are on the same side.
Offset | Property that returns the Parameter object that controls the offset distance of the constraint.
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinition Interface > TangentiMateDefinition Properties


TangentiMateDefinition.ConstraintLimits Property

TangentiMateDefinition.ConstraintLimits Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the ConstraintLimits object that provides access to various limits related settings for the iMate definition.

Visual Basic
Property ConstraintLimits() As ConstraintLimits**
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinition Interface > TangentiMateDefinition Properties > TangentiMateDefinition.ConstraintLimits Property


TangentiMateDefinition.Entity Property

TangentiMateDefinition.Entity Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the entity used for the iMate definition.

Visual Basic
Property Entity() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinition Interface > TangentiMateDefinition Properties > TangentiMateDefinition.Entity Property


TangentiMateDefinition.InsideTangency Property

TangentiMateDefinition.InsideTangency Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns whether the curvatures of the surfaces at the point of tangency are on the same side. True if they are on the same side.

Visual Basic
Property InsideTangency() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinition Interface > TangentiMateDefinition Properties > TangentiMateDefinition.InsideTangency Property


TangentiMateDefinition.Offset Property

TangentiMateDefinition.Offset Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Parameter object that controls the offset distance of the constraint.

Visual Basic
Property Offset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinition Interface > TangentiMateDefinition Properties > TangentiMateDefinition.Offset Property


TangentiMateDefinitionProxy Interface

TangentiMateDefinitionProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentiMateDefinition object.

Class Hierarchy
Inventor::iMateDefinition
    Inventor::TangentiMateDefinition
        Inventor::TangentiMateDefinitionProxy
Visual Basic
Public Interface TangentiMateDefinitionProxy
Inherits TangentiMateDefinition
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinitionProxy Interface


TangentiMateDefinitionProxy Properties

TangentiMateDefinitionProxy Properties
Summary

The properties of the TangentiMateDefinitionProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
IsConsumed | Property that gets whether this object is consumed in the context of the active assembly/part/sketch.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinitionProxy Interface > TangentiMateDefinitionProxy Properties


TangentiMateDefinitionProxy.ContainingOccurrence Property

TangentiMateDefinitionProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinitionProxy Interface > TangentiMateDefinitionProxy Properties > TangentiMateDefinitionProxy.ContainingOccurrence Property


TangentiMateDefinitionProxy.IsConsumed Property

TangentiMateDefinitionProxy.IsConsumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets whether this object is consumed in the context of the active assembly/part/sketch.

Visual Basic
Property IsConsumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinitionProxy Interface > TangentiMateDefinitionProxy Properties > TangentiMateDefinitionProxy.IsConsumed Property


TangentiMateDefinitionProxy.NativeObject Property

TangentiMateDefinitionProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As iMateDefinition**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentiMateDefinitionProxy Interface > TangentiMateDefinitionProxy Properties > TangentiMateDefinitionProxy.NativeObject Property


TangentSketchConstraint Interface

TangentSketchConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TangentSketchConstraint object represents a tangent constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::TangentSketchConstraint
        Inventor::TangentSketchConstraintProxy
Visual Basic
Public Interface TangentSketchConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddTangent

TangentSketchConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraint Interface


TangentSketchConstraint Properties

TangentSketchConstraint Properties
Summary

The properties of the TangentSketchConstraint class are listed here.

Properties
Name | Description
EntityOne | Property that returns the sketch entity that is constrained to be tangent to entity two.
EntityTwo | Property that returns the sketch entity that is constrained to be tangent to entity one.
You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraint Interface > TangentSketchConstraint Properties


TangentSketchConstraint.EntityOne Property

TangentSketchConstraint.EntityOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity that is constrained to be tangent to entity two.

Visual Basic
Property EntityOne() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraint Interface > TangentSketchConstraint Properties > TangentSketchConstraint.EntityOne Property


TangentSketchConstraint.EntityTwo Property

TangentSketchConstraint.EntityTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity that is constrained to be tangent to entity one.

Visual Basic
Property EntityTwo() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraint Interface > TangentSketchConstraint Properties > TangentSketchConstraint.EntityTwo Property


TangentSketchConstraintProxy Interface

TangentSketchConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TangentSketchConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::TangentSketchConstraint
        Inventor::TangentSketchConstraintProxy
Visual Basic
Public Interface TangentSketchConstraintProxy
Inherits TangentSketchConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraintProxy Interface


TangentSketchConstraintProxy Properties

TangentSketchConstraintProxy Properties
Summary

The properties of the TangentSketchConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraintProxy Interface > TangentSketchConstraintProxy Properties


TangentSketchConstraintProxy.ContainingOccurrence Property

TangentSketchConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraintProxy Interface > TangentSketchConstraintProxy Properties > TangentSketchConstraintProxy.ContainingOccurrence Property


TangentSketchConstraintProxy.NativeObject Property

TangentSketchConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TangentSketchConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TangentSketchConstraintProxy Interface > TangentSketchConstraintProxy Properties > TangentSketchConstraintProxy.NativeObject Property


TaperedThreadInfo Interface

TaperedThreadInfo Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TaperedThreadInfo object defines the thread information that is used by the Hole and Thread features. For standard threads the StandardThreadInfo object is used.

Class Hierarchy
Inventor::ThreadInfo
    Inventor::TaperedThreadInfo
Visual Basic
Public Interface TaperedThreadInfo
Inherits ThreadInfo
Notes

Members through which this object may be accessed include:

HoleFeatures.CreateTaperedTapInfo

ThreadFeatures.CreateTaperedThreadInfo

HoleFeature.TapInfo

See Also

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface


TaperedThreadInfo Properties

TaperedThreadInfo Properties
Summary

The properties of the TaperedThreadInfo class are listed here.

Properties
Name | Description
BasicMinorDiameter | Property that returns s the basic minor diameter, or the diameter of the small end of the pipe. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
EffectiveDiameter | Property that returns the external effective thread diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
EffectiveLength | Property that returns the external effective thread length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
EngagementDiameter | Property that returns the hand tight engagement diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
EngagementLength | Property that returns the hand tight engagement length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
ExternalPitchDiameter | Property that returns the external pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
NominalExternalDiameter | Property that returns the nominal external diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
NominalExternalLength | Property that returns the nominal perfect external thread length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
OutsidePipeDiameter | Property that returns the outside of the pipe diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
OverallExternalLength | Property that returns the overall external thread length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
Pitch | Property that returns the actual thread pitch. This value is used when displaying the threads in the model. This value is in millimeters if the Metric argument is True and inches if False.
ThreadHeight | Property that returns the thread height. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
ThreadsPerInch | Property that returns a string that describes the pitch. This is generally described in threads per inch, although this string can contain any characters. This string is used as part of the text when a callout is created for the thread in a drawing.
VanishThread | Property that returns the vanish thread. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
WrenchMakeupDiameter | Property that returns the internal wrench makeup diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
WrenchMakeupLength | Property that gets and sets the internal wrench makeup length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties


TaperedThreadInfo.BasicMinorDiameter Property

TaperedThreadInfo.BasicMinorDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns s the basic minor diameter, or the diameter of the small end of the pipe. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property BasicMinorDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.BasicMinorDiameter Property


TaperedThreadInfo.EffectiveDiameter Property

TaperedThreadInfo.EffectiveDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the external effective thread diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property EffectiveDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.EffectiveDiameter Property


TaperedThreadInfo.EffectiveLength Property

TaperedThreadInfo.EffectiveLength Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the external effective thread length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property EffectiveLength() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.EffectiveLength Property


TaperedThreadInfo.EngagementDiameter Property

TaperedThreadInfo.EngagementDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the hand tight engagement diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property EngagementDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.EngagementDiameter Property


TaperedThreadInfo.EngagementLength Property

TaperedThreadInfo.EngagementLength Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the hand tight engagement length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property EngagementLength() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.EngagementLength Property


TaperedThreadInfo.ExternalPitchDiameter Property

TaperedThreadInfo.ExternalPitchDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the external pitch diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property ExternalPitchDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.ExternalPitchDiameter Property


TaperedThreadInfo.NominalExternalDiameter Property

TaperedThreadInfo.NominalExternalDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the nominal external diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property NominalExternalDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.NominalExternalDiameter Property


TaperedThreadInfo.NominalExternalLength Property

TaperedThreadInfo.NominalExternalLength Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the nominal perfect external thread length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property NominalExternalLength() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.NominalExternalLength Property


TaperedThreadInfo.OutsidePipeDiameter Property

TaperedThreadInfo.OutsidePipeDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the outside of the pipe diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property OutsidePipeDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.OutsidePipeDiameter Property


TaperedThreadInfo.OverallExternalLength Property

TaperedThreadInfo.OverallExternalLength Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the overall external thread length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property OverallExternalLength() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.OverallExternalLength Property


TaperedThreadInfo.Pitch Property

TaperedThreadInfo.Pitch Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the actual thread pitch. This value is used when displaying the threads in the model. This value is in millimeters if the Metric argument is True and inches if False.

Visual Basic
Property Pitch() As double
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.Pitch Property


TaperedThreadInfo.ThreadHeight Property

TaperedThreadInfo.ThreadHeight Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the thread height. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property ThreadHeight() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.ThreadHeight Property


TaperedThreadInfo.ThreadsPerInch Property

TaperedThreadInfo.ThreadsPerInch Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns a string that describes the pitch. This is generally described in threads per inch, although this string can contain any characters. This string is used as part of the text when a callout is created for the thread in a drawing.

Visual Basic
Property ThreadsPerInch() As String
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.ThreadsPerInch Property


TaperedThreadInfo.VanishThread Property

TaperedThreadInfo.VanishThread Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the vanish thread. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property VanishThread() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.VanishThread Property


TaperedThreadInfo.WrenchMakeupDiameter Property

TaperedThreadInfo.WrenchMakeupDiameter Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the internal wrench makeup diameter. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property WrenchMakeupDiameter() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.WrenchMakeupDiameter Property


TaperedThreadInfo.WrenchMakeupLength Property

TaperedThreadInfo.WrenchMakeupLength Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the internal wrench makeup length. This is in millimeters if the Metric argument is True and inches if False. This property contains a Double value or can be Nothing if the value is not set.

Visual Basic
Property WrenchMakeupLength() As VARIANT
You are here: Symbol Reference > Inventor Library > Objects > TaperedThreadInfo Interface > TaperedThreadInfo Properties > TaperedThreadInfo.WrenchMakeupLength Property


TeardropHemDefinition Interface

TeardropHemDefinition Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The TeardropHemDefinition object defines all of the inputs that are unique to a tear drop style of hem feature.

Class Hierarchy
Inventor::TeardropHemDefinition
Visual Basic
Public Interface TeardropHemDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

HemDefinition.HemTypeDefinition

You are here: Symbol Reference > Inventor Library > Objects > TeardropHemDefinition Interface


TeardropHemDefinition Properties

TeardropHemDefinition Properties
Summary

The properties of the TeardropHemDefinition class are listed here.

Properties
Name | Description
Angle | Property that returns the parameter controlling the bend angle of a hem feature defined by a tear drop style of bend.
Parent | Property that returns the parent hem definition feature.
Radius | Property that returns the parameter controlling the radius of a hem feature defined by a tear drop style of bend.
You are here: Symbol Reference > Inventor Library > Objects > TeardropHemDefinition Interface > TeardropHemDefinition Properties


TeardropHemDefinition.Angle Property

TeardropHemDefinition.Angle Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the bend angle of a hem feature defined by a tear drop style of bend.

Visual Basic
Property Angle() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > TeardropHemDefinition Interface > TeardropHemDefinition Properties > TeardropHemDefinition.Angle Property


TeardropHemDefinition.Parent Property

TeardropHemDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parent hem definition feature.

Visual Basic
Property Parent() As HemDefinition**
You are here: Symbol Reference > Inventor Library > Objects > TeardropHemDefinition Interface > TeardropHemDefinition Properties > TeardropHemDefinition.Parent Property


TeardropHemDefinition.Radius Property

TeardropHemDefinition.Radius Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the radius of a hem feature defined by a tear drop style of bend.

Visual Basic
Property Radius() As Parameter**
Remarks

When creating a new hem feature and the HemDefinition object is not associated with an actual feature, this property will return Nothing. You can use the SetSingleHemType method of the HemDefinition to set this value in that case. When this object is obtained from an existing hem feature you can edit the hem feature by using modifying the parameter this property returns.

You are here: Symbol Reference > Inventor Library > Objects > TeardropHemDefinition Interface > TeardropHemDefinition Properties > TeardropHemDefinition.Radius Property


TextBox Interface

TextBox Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TextBox object represents text on a sheet or sketch.

Class Hierarchy
Inventor::TextBox
    Inventor::TextBoxProxy
Visual Basic
Public Interface TextBox
Inherits IDispatch
Remarks

Note that layer and style information applies only in the drawing environment.

Notes

Members through which this object may be accessed include:

ProfilePath.TextBox

TextBoxConstraint.TextBox

TextBoxes.AddByRectangle

TextBoxes.AddFitted

TextBoxes.Item

TextBoxProxy.NativeObject

See Also

Title Block Definition Create and Insert sample

Sketch Text Add sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface


TextBox Methods

TextBox Methods
Summary

The methods of the TextBox class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the text box.
GetColor | Method that gets the current override color of the text box.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetColor | Method that sets the current override color of the text.
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Methods


TextBox.Delete Method

TextBox.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the text box.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Methods > TextBox.Delete Method


TextBox.GetColor Method

TextBox.GetColor Method Available in Inventor Available in Server
Summary

Method that gets the current override color of the text box.

Visual Basic
Sub GetColor(ByRef Red As BYTE, ByRef Green As BYTE, ByRef Blue As BYTE)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | The blue component of the color. A Byte value between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Methods > TextBox.GetColor Method


TextBox.GetReferenceKey Method

TextBox.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Methods > TextBox.GetReferenceKey Method


TextBox.SetColor Method

TextBox.SetColor Method Available in Inventor Available in Server
Summary

Method that sets the current override color of the text.

Visual Basic
Sub SetColor(Red As BYTE, Green As BYTE, Blue As BYTE)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | The blue component of the color. A Byte value between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Methods > TextBox.SetColor Method


TextBox Properties

TextBox Properties
Summary

The properties of the TextBox class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
BoundaryGeometry | Property that returns the four construction sketch lines that form the boundary of the text box.
Color | Property that gets and set the color of the text.
ContainingSketchBlock | Property that returns the sketch block that contains this object. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this object does not belong to a sketch block and lives directly under a sketch.
Fitted | Property that returns if the text box remains tightly fitted to the text within the box. True indicates the text box just encloses the text.
FittedTextHeight | Property that returns the actual height of the text within the text box. This does not necessarily represent the current height of the text box, but only the text within the box. If the Fitted property is True then this value is the same as the height of the text box.
FittedTextWidth | Property that returns the actual width of the text within the text box. This does not necessarily represent the current width of the text box, but only the text within the box. If the Fitted property is True then this value is the same as the width of the text box.
FormattedText | Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.
Height | Property that gets and sets the height of the text box. The height is defined in centimeters. Setting this value for a fitted text box will convert the text box to be non-fitted.
HorizontalJustification | Property that gets and sets the horizontal justification override of the text box.
Layer | Property that gets and sets the layer associated with this object.
LineSpacing | Property that gets and sets the line spacing of the text box.
LineSpacingType | Property that gets and sets the method used to define the line spacing. The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.
Origin | Property that gets and sets the position of the origin of the text box. The text boxes origin is controlled by the horizontal and vertical justification of the text box.
OriginSketchPoint | Gets the SketchPoint on the origin of this TextBox. This will be Nothing in the case that the boundaries are displayed
Parent | Property that returns the parent object from whom this object can logically be reached.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Rotation | Property that gets and sets the override rotation of the text box. The units used to define the rotation angle are radians. Currently text rotation is limited to 90 degree increments so valid values for this property are 0, pi/2, pi, and 1.5pi.
ShowBoundaries | Property that gets and sets whether boundary geometry is displayed for the text box.
SingleLineText | Property that gets and sets the single line text option. If True, all line breaks are removed from multi-line text.
SketchBlockPath | Property that returns the path of sketch blocks at the leaf of which this sketch object is found. The enumerator returns a count of 0 if the object lives directly under a sketch.
StackedTextPosition | Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.
Style | Property that gets and sets the text style associated with the text box.
Text | Property that gets and sets the string that defines the contents of the text box.
Type | Property returning an enum indicating this object's type.
VerticalJustification | Property that gets and sets the vertical justification override of the text box. Valid values are kAlignTextLower, kAlignTextMiddle, kAlignTextUpper and kAlignTextBaseline. This property can be set to kAlignTextBaseline only if the SingleLineText property is set to True.
Width | Property that gets and sets the width of the text box. The width is defined in centimeters. Setting this value for a fitted text box will convert the text box to be non-fitted.
WidthScale | Property that gets and sets the width scale factor for the text box. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties


TextBox.Application Property

TextBox.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Application Property


TextBox.AttributeSets Property

TextBox.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.AttributeSets Property


TextBox.BoundaryGeometry Property

TextBox.BoundaryGeometry Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the four construction sketch lines that form the boundary of the text box.

Visual Basic
Property BoundaryGeometry() As SketchEntitiesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.BoundaryGeometry Property


TextBox.Color Property

TextBox.Color Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and set the color of the text.

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Color Property


TextBox.ContainingSketchBlock Property

TextBox.ContainingSketchBlock Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketch block that contains this object. This is the same SketchBlock returned as the last item in the SketchBlockPath property. This property returns Nothing if this object does not belong to a sketch block and lives directly under a sketch.

Visual Basic
Property ContainingSketchBlock() As SketchBlock**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.ContainingSketchBlock Property


TextBox.Fitted Property

TextBox.Fitted Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns if the text box remains tightly fitted to the text within the box. True indicates the text box just encloses the text.

Visual Basic
Property Fitted() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Fitted Property


TextBox.FittedTextHeight Property

TextBox.FittedTextHeight Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the actual height of the text within the text box. This does not necessarily represent the current height of the text box, but only the text within the box. If the Fitted property is True then this value is the same as the height of the text box.

Visual Basic
Property FittedTextHeight() As double*
See Also

Sketch Text Add sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.FittedTextHeight Property


TextBox.FittedTextWidth Property

TextBox.FittedTextWidth Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the actual width of the text within the text box. This does not necessarily represent the current width of the text box, but only the text within the box. If the Fitted property is True then this value is the same as the width of the text box.

Visual Basic
Property FittedTextWidth() As double*
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.FittedTextWidth Property


TextBox.FormattedText Property

TextBox.FormattedText Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the fully formatted string that defines the contents of the dimension or note text.

Visual Basic
Property FormattedText() As String
Remarks

The formatting is specified using XML tags within the string. By default, all text in the string will be displayed using the defaults specified in the dimension style. You can use the XML tags to override the default style and apply style overrides for all or portions of the text.

The formatting overrides are defined using tags. There is an opening tag and closing tag for each formatting override you define. The text between the opening and closing tags is affected by the override.

Refer to the list of supported XML text formatting tags under Reference Topics in the Overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.FormattedText Property


TextBox.Height Property

TextBox.Height Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the height of the text box. The height is defined in centimeters. Setting this value for a fitted text box will convert the text box to be non-fitted.

Visual Basic
Property Height() As double
See Also

Sketch Text Add sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Height Property


TextBox.HorizontalJustification Property

TextBox.HorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the horizontal justification override of the text box.

Visual Basic
Property HorizontalJustification() As HorizontalTextAlignmentEnum
See Also

Title Block Definition Create and Insert sample

Sketch Text Add sample

Create SketchedSymbol Definition sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.HorizontalJustification Property


TextBox.Layer Property

TextBox.Layer Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets the layer associated with this object.

Visual Basic
Property Layer() As Layer*
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Layer Property


TextBox.LineSpacing Property

TextBox.LineSpacing Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the line spacing of the text box.

Visual Basic
Property LineSpacing() As double
Remarks

The value of this property is treated in one of two ways depending on the value of the LineSpacingType property. When the value of the LineSpacingType property is set to kExactLineSpacing, the value of the LineSpacing property defines the exact distance (in centimeters) from the bottom of one line to bottom of the next line.

When the value of the LineSpacingType property is set to kMultipleLineSpacing, the value defines a spacing factor relative to standard single line spacing. For example, a value of 1.0 will result in standard single line spacing, and a value of 1.5 will result in one and a half line spacing.

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.LineSpacing Property


TextBox.LineSpacingType Property

TextBox.LineSpacingType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the method used to define the line spacing. The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.

Visual Basic
Property LineSpacingType() As TextLineSpacingTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.LineSpacingType Property


TextBox.Origin Property

TextBox.Origin Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the position of the origin of the text box. The text boxes origin is controlled by the horizontal and vertical justification of the text box.

Visual Basic
Property Origin() As Point2d*
Remarks

If the text box's horizontal justification is kAlignTextLeft and the vertical justification is kAlignTextUpper then the origin will be the upper-left corner of the text box. Setting the justifications to kAlignTextCenter and kAlignTextMiddle will result in the text box moving to position the origin at the center of the text box. As the contents of the text box changes and cause the text box to change in size, the position of the origin remains fixed.

See Also

Sketch Text Add sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Origin Property


TextBox.OriginSketchPoint Property

TextBox.OriginSketchPoint Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the SketchPoint on the origin of this TextBox. This will be Nothing in the case that the boundaries are displayed

Visual Basic
Property OriginSketchPoint() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.OriginSketchPoint Property


TextBox.Parent Property

TextBox.Parent Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Sketch**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Parent Property


TextBox.RangeBox Property

TextBox.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.RangeBox Property


TextBox.Rotation Property

TextBox.Rotation Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the override rotation of the text box. The units used to define the rotation angle are radians. Currently text rotation is limited to 90 degree increments so valid values for this property are 0, pi/2, pi, and 1.5pi.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Rotation Property


TextBox.ShowBoundaries Property

TextBox.ShowBoundaries Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets and sets whether boundary geometry is displayed for the text box.

Visual Basic
Property ShowBoundaries() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.ShowBoundaries Property


TextBox.SingleLineText Property

TextBox.SingleLineText Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the single line text option. If True, all line breaks are removed from multi-line text.

Visual Basic
Property SingleLineText() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.SingleLineText Property


TextBox.SketchBlockPath Property

TextBox.SketchBlockPath Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the path of sketch blocks at the leaf of which this sketch object is found. The enumerator returns a count of 0 if the object lives directly under a sketch.

Visual Basic
Property SketchBlockPath() As SketchBlocksEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.SketchBlockPath Property


TextBox.StackedTextPosition Property

TextBox.StackedTextPosition Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the position (alignment) of the stacked text with respect to regular text. Valid values for the property are kAlignTextLower, kAlignTextMiddle and kAlignTextUpper. kAlignTextBaseline is not a valid value for this property.

Visual Basic
Property StackedTextPosition() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.StackedTextPosition Property


TextBox.Style Property

TextBox.Style Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the text style associated with the text box.

Visual Basic
Property Style() As TextStyle*
See Also

Sketch Text Add sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Style Property


TextBox.Text Property

TextBox.Text Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the string that defines the contents of the text box.

Visual Basic
Property Text() As String
Remarks

When getting this property, the returned string has all formatting removed and contains the actual text characters displayed in the text box. If this property is used to set the text in the text box, all format overrides will be removed and the text box will revert to the associated text style.

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Text Property


TextBox.Type Property

TextBox.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Type Property


TextBox.VerticalJustification Property

TextBox.VerticalJustification Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the vertical justification override of the text box. Valid values are kAlignTextLower, kAlignTextMiddle, kAlignTextUpper and kAlignTextBaseline. This property can be set to kAlignTextBaseline only if the SingleLineText property is set to True.

Visual Basic
Property VerticalJustification() As VerticalTextAlignmentEnum
See Also

Title Block Definition Create and Insert sample

Sketch Text Add sample

Create SketchedSymbol Definition sample

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.VerticalJustification Property


TextBox.Width Property

TextBox.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the width of the text box. The width is defined in centimeters. Setting this value for a fitted text box will convert the text box to be non-fitted.

Visual Basic
Property Width() As double
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.Width Property


TextBox.WidthScale Property

TextBox.WidthScale Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the width scale factor for the text box. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.

Visual Basic
Property WidthScale() As double
You are here: Symbol Reference > Inventor Library > Objects > TextBox Interface > TextBox Properties > TextBox.WidthScale Property


TextBoxConstraint Interface

TextBoxConstraint Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The TextBoxConstraint is automatically created when a text box is created. This constraint cannot be explicitly deleted.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::TextBoxConstraint
        Inventor::TextBoxConstraintProxy
Visual Basic
Public Interface TextBoxConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

TextBoxConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraint Interface


TextBoxConstraint Properties

TextBoxConstraint Properties
Summary

The properties of the TextBoxConstraint class are listed here.

Properties
Name | Description
TextBox | The text box that is constrained.
You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraint Interface > TextBoxConstraint Properties


TextBoxConstraint.TextBox Property

TextBoxConstraint.TextBox Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

The text box that is constrained.

Visual Basic
Property TextBox() As TextBox**
You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraint Interface > TextBoxConstraint Properties > TextBoxConstraint.TextBox Property


TextBoxConstraintProxy Interface

TextBoxConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TextBoxConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::TextBoxConstraint
        Inventor::TextBoxConstraintProxy
Visual Basic
Public Interface TextBoxConstraintProxy
Inherits TextBoxConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraintProxy Interface


TextBoxConstraintProxy Properties

TextBoxConstraintProxy Properties
Summary

The properties of the TextBoxConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraintProxy Interface > TextBoxConstraintProxy Properties


TextBoxConstraintProxy.ContainingOccurrence Property

TextBoxConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraintProxy Interface > TextBoxConstraintProxy Properties > TextBoxConstraintProxy.ContainingOccurrence Property


TextBoxConstraintProxy.NativeObject Property

TextBoxConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TextBoxConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TextBoxConstraintProxy Interface > TextBoxConstraintProxy Properties > TextBoxConstraintProxy.NativeObject Property


TextBoxes Interface

TextBoxes Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TextBoxes collection object provides access to all the existing objects in a drawing document and supports methods to create new TextBox objects.

Class Hierarchy
Inventor::TextBoxes
Visual Basic
Public Interface TextBoxes
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sketch.TextBoxes

See Also

Title Block Definition Create and Insert sample

Create SketchedSymbol Definition sample

Example

"Sketch Text Add Example "

This sample illustrates creating text in a sketch. Before running this sample, open a drawing document.

Public Sub SketchTextAdd()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Create a new sketch on the active sheet.
    Dim oSketch As DrawingSketch
    Set oSketch = oDrawDoc.ActiveSheet.Sketches.Add

    ' Open the sketch for edit so the text boxes can be created.
    ' This is only required for drawing sketches, not part.
    oSketch.Edit

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create text with simple string as input.  Since this doesn't use
    ' any text overrides, it will default to the active text style.
    Dim sText As String
    sText = "Drawing Notes"
    Dim oTextBox As TextBox
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, 18), sText)

    ' Create text using various overrides.
    sText = "Notice: All holes larger than 0.500 n are to be lubricated."
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, 16), sText)

    ' Create a set of notes that are numbered and aligned along the left.
    Dim dYCoord As Double
    dYCoord = 14
    Dim dYOffset As Double
    Dim oStyle As TextStyle
    Set oStyle = oSketch.TextBoxes.Item(1).Style
    dYOffset = oStyle.FontSize * 1.5

    ' Simple single line text.
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "1.")
    sText = "This is note 1."
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Two line text.  The two lines are defined using the  tag within the text string.
    dYCoord = dYCoord - (oTextBox.FittedTextHeight + 0.5)
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "2.")
    sText = "This is note 2,  which contains two lines."
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Single line of text.
    dYCoord = dYCoord - (oTextBox.FittedTextHeight + 0.5)
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "3.")
    sText = "This is note 3."
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Three lines of text.
    dYCoord = dYCoord - (oTextBox.FittedTextHeight + 0.5)
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "4.")
    sText = "This is note 4,  which contains  several lines."
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' The number of this line of text will have a triangle around it.
    dYCoord = dYCoord - (oTextBox.FittedTextHeight + 0.5)
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(3, dYCoord), "5")

    ' Draw a triangle that fits around a text box.
    Dim Points(1 To 3) As Point2d
    Call CalculateTriangle(oTextBox, Points)

    Dim oLines(1 To 3) As SketchLine
    Set oLines(1) = oSketch.SketchLines.AddByTwoPoints(Points(1), Points(2))
    Set oLines(2) = oSketch.SketchLines.AddByTwoPoints(oLines(1).EndSketchPoint, Points(3))
    Set oLines(3) = oSketch.SketchLines.AddByTwoPoints(oLines(2).EndSketchPoint, oLines(1).StartSketchPoint)

    sText = "Here is the last and final line of text."
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(4, dYCoord), sText)

    ' Exit the sketch from the edit environment.
    oSketch.ExitEdit
End Sub

' Function to calcuate the three points of a triangle that fits tightly around the input text box.
Private Sub CalculateTriangle(TextBox As TextBox, Points() As Point2d)
    ' Get the top-left corner of the text box.
    Dim dLeft As Double
    Dim dTop As Double
    Call GetCorner(TextBox, dLeft, dTop)

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Determine the top point of the triangle.
    Set Points(1) = oTG.CreatePoint2d(dLeft + (TextBox.Width / 2), dTop + ((TextBox.Width / 2) * Tan(1.0471975511966)))

    ' Determine the bottom-left corner point of the triangle.
    Dim dY As Double
    dY = (Points(1).Y - dTop) + (1.125 * TextBox.height)
    Set Points(2) = oTG.CreatePoint2d(Points(1).X - (dY / Tan(1.0471975511966)), Points(1).Y - dY)

    ' Determine the bottom right corner point of the triangle
    Set Points(3) = oTG.CreatePoint2d(Points(1).X + (dY / Tan(1.0471975511966)), Points(2).Y)
End Sub

' Function to determine the top left corner of the input text box.
Private Sub GetCorner(TextBox As TextBox, Left As Double, Top As Double)
    ' Determine the top left corner of the text box by accounting
    ' for the justifications.
    Select Case TextBox.HorizontalJustification
        Case kAlignTextLeft
            Left = TextBox.Origin.X
        Case kAlignTextCenter
            Left = TextBox.Origin.X - (TextBox.Width / 2)
        Case kAlignTextRight
            Left = TextBox.Origin.X - TextBox.Width
    End Select

    Select Case TextBox.VerticalJustification
        Case kAlignTextUpper
            Top = TextBox.Origin.Y
        Case kAlignTextMiddle
            Top = TextBox.Origin.Y + (TextBox.height / 2)
        Case kAlignTextLower
            Top = TextBox.Origin.Y + TextBox.height
    End Select
End Sub
You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface


TextBoxes Methods

TextBoxes Methods
Summary

The methods of the TextBoxes class are listed here.

Methods
Methods
Name | Description
AddByRectangle | Method that creates a text box whose size is defined by the input points that define opposing diagonals of the text box.
AddFitted | Method that creates a text box positioned at the specified point. The size of the resulting text box is just large enough to contain the input text.
Item | Returns a TextBox from the collection.
You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Methods


TextBoxes.AddByRectangle Method

TextBoxes.AddByRectangle Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a text box whose size is defined by the input points that define opposing diagonals of the text box.

Visual Basic
Sub AddByRectangle(CornerOne As Point2d, CornerTwo As Point2d, FormattedText As String, ByRef TextStyle As [optional] VARIANT, Result As [out, retval] TextBox*)
Parameters
Parameters | Description
CornerOne | Input Point2d that specifies the first corner of the rectangle.
CornerTwo | Input Point2d that specifies the diagonal corner of the rectangle.
FormattedText | Input String that specifies the text of the text box. This string can contain tags that define internal formatting changes, which override the text style of the text box. See the list of XML text formatting tags under Reference Topics in the Overviews section.
TextStyle | Optional input Variant that specifies which text style to use for the text box. The text style can be specified by providing the name of an existing style or by supplying a TextStyle object.
See Also

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Methods > TextBoxes.AddByRectangle Method


TextBoxes.AddFitted Method

TextBoxes.AddFitted Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a text box positioned at the specified point. The size of the resulting text box is just large enough to contain the input text.

Visual Basic
Sub AddFitted(Position As Point2d, FormattedText As String, ByRef TextStyle As [optional] VARIANT, Result As [out, retval] TextBox*)
Parameters
Parameters | Description
Position | Input that specifies the position of the text box. The position of this point in relation to the resulting text string is dependent on the vertical and horizontal justification of the text. For example if the vertical justification is the top and horizontal is the left, then the position point defines the upper-left corner of the text box. If the vertical justification is the center and the horizontal justification is the center, the position point defines the center of the text box.
FormattedText | Input String that specifies the text of the text box. This string can contain tags that define internal formatting changes, which override the text style associated with the text box. See the list of XML text formatting tags under Reference Topics in the Overviews section.
TextStyle | Optional input Variant that specifies which text style to use for the text box. The text style can be specified by providing the name of an existing style or by supplying a TextStyle object.
See Also

Title Block Definition Create and Insert sample

Sketch Text Add sample

Create SketchedSymbol Definition sample

Extrude sketch text sample

Border Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Methods > TextBoxes.AddFitted Method


TextBoxes.Item Method

TextBoxes.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Returns a TextBox from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] TextBox*)
See Also

Sketch Text Add sample

You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Methods > TextBoxes.Item Method


TextBoxes Properties

TextBoxes Properties
Summary

The properties of the TextBoxes class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Properties


TextBoxes.Application Property

TextBoxes.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Properties > TextBoxes.Application Property


TextBoxes.Count Property

TextBoxes.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Properties > TextBoxes.Count Property


TextBoxes.Type Property

TextBoxes.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextBoxes Interface > TextBoxes Properties > TextBoxes.Type Property


TextBoxProxy Interface

TextBoxProxy Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TextBox object.

Class Hierarchy
Inventor::TextBox
    Inventor::TextBoxProxy
Visual Basic
Public Interface TextBoxProxy
Inherits TextBox
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TextBoxProxy Interface


TextBoxProxy Properties

TextBoxProxy Properties
Summary

The properties of the TextBoxProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TextBoxProxy Interface > TextBoxProxy Properties


TextBoxProxy.ContainingOccurrence Property

TextBoxProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TextBoxProxy Interface > TextBoxProxy Properties > TextBoxProxy.ContainingOccurrence Property


TextBoxProxy.NativeObject Property

TextBoxProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TextBox**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TextBoxProxy Interface > TextBoxProxy Properties > TextBoxProxy.NativeObject Property


TextGraphics Interface

TextGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TextGraphics object defines a set of text strings that are displayed within the model. Each coordinate provided defines a new TextGraphics object. For each coordinate you must also provide a text string.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::TextGraphics
Visual Basic
Public Interface TextGraphics
Inherits GraphicsPrimitive
Notes

Members through which this object may be accessed include:

GraphicsNode.AddScalableTextGraphics

GraphicsNode.AddTextGraphics

See Also

Anchored Client Grahics sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface


TextGraphics Methods

TextGraphics Methods
Summary

The methods of the TextGraphics class are listed here.

Methods
Methods
Name | Description
GetTextColor | Method that gets the color of the text.
GetTransformBehavior | Returns the current view transformation settings (e.g. pixel scaling and front facing).
PutTextColor | Method that sets the color of the text.
Scalable | Property that returns whether the TextGraphics object is scalable. If True, the FontSize property can be set a double value indicating its size in model space units.
SetTransformBehavior | Sets the view transformation settings (e.g. pixel scaling and front facing).
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Methods


TextGraphics.GetTextColor Method

TextGraphics.GetTextColor Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that gets the color of the text.

Visual Basic
Sub GetTextColor(ByRef Red As unsigned char, ByRef Green As unsigned char, ByRef Blue As unsigned char)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | The blue component of the color. A Byte value between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Methods > TextGraphics.GetTextColor Method


TextGraphics.GetTransformBehavior Method

TextGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Returns the current view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point that returns the point that is unaffected by the transform behavior.
BehaviorType | Output DisplayTransformBehaviorEnum that returns the transform behaviors currently being used.
PixelScale | Output Double that returns the number of pixels that are used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Methods > TextGraphics.GetTransformBehavior Method


TextGraphics.PutTextColor Method

TextGraphics.PutTextColor Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the color of the text.

Visual Basic
Sub PutTextColor(Red As unsigned char, Green As unsigned char, Blue As unsigned char)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | The blue component of the color. A Byte value between 0 and 255.
See Also

Anchored Client Grahics sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Methods > TextGraphics.PutTextColor Method


TextGraphics.Scalable Method

TextGraphics.Scalable Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns whether the TextGraphics object is scalable. If True, the FontSize property can be set a double value indicating its size in model space units.

Visual Basic
Sub Scalable(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Methods > TextGraphics.Scalable Method


TextGraphics.SetTransformBehavior Method

TextGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Sets the view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input that indicates which point is unaffected by the transform behavior.
BehaviorType | Input DisplayTransformBehaviorEnum that specifies which transform behaviors are to be used.
PixelScale | Input Double that indicates how many pixels should be used to draw one model unit when pixel scaling is used.
See Also

Text Using Client Graphics (Multiple fonts and lines) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Methods > TextGraphics.SetTransformBehavior Method


TextGraphics Properties

TextGraphics Properties
Summary

The properties of the TextGraphics class are listed here.

Properties
Name | Description
Anchor | Property that gets and sets the position of the text.
Bold | Property that gets and sets whether the text has bold formatting or not. True if the text has bold formatting.
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
DepthPriority | Property that allows you to specify a priority for a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
Font | Property that gets and sets the font used for the text.
FontSize | Property that gets and sets the size of the font. For non-scalable text graphics (if the Scalable property returns False), I size is specified in pixels. For scalable text graphics, the size is defined in model space units.
HorizontalAlignment | Property that allows you to specify the horizontal justification of the text with respect to the coordinate point for the text. Valid values are kAlignTextCenter, kAlignTextLeft, and kAlignTextRight.
Italic | Property that gets and sets whether the text has italic formatting or not. True if the text has italic formatting.
Text | Property that gets and sets the text displayed for the TextGraphics object.
VerticalAlignment | Property that allows you to specify the vertical justification of the text with respect to the coordinate point for the text. Valid options are kAlignTextLower, kAlignTextMiddle, and kAlignTextUpper.
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties


TextGraphics.Anchor Property

TextGraphics.Anchor Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the position of the text.

Visual Basic
Property Anchor() As Point*
Remarks

The coordinates of the point are either in model space or pixel space depending on the current transform behavior of the text. If the transform behavior is kNoTransformBehaviors (which is the default) or kFrontFacing the coordinates are in model space. If the transform behavior is kFrontFacingAndPixelScaling or kPixelScaling the coordinates are in pixel space. The current transform behavior can be obtained by using the GetTransformBehavior method and set using the SetTransformBehavior.

See Also

Anchored Client Grahics sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.Anchor Property


TextGraphics.Bold Property

TextGraphics.Bold Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether the text has bold formatting or not. True if the text has bold formatting.

Visual Basic
Property Bold() As VARIANT_BOOL
See Also

Anchored Client Grahics sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.Bold Property


TextGraphics.BurnThrough Property

TextGraphics.BurnThrough Property Available in Inventor Introduced in Inventor 2012
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.BurnThrough Property


TextGraphics.DepthPriority Property

TextGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a priority for a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.DepthPriority Property


TextGraphics.Font Property

TextGraphics.Font Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the font used for the text.

Visual Basic
Property Font() As String
See Also

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.Font Property


TextGraphics.FontSize Property

TextGraphics.FontSize Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets the size of the font. For non-scalable text graphics (if the Scalable property returns False), I size is specified in pixels. For scalable text graphics, the size is defined in model space units.

Visual Basic
Property FontSize() As double
See Also

Anchored Client Grahics sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.FontSize Property


TextGraphics.HorizontalAlignment Property

TextGraphics.HorizontalAlignment Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify the horizontal justification of the text with respect to the coordinate point for the text. Valid values are kAlignTextCenter, kAlignTextLeft, and kAlignTextRight.

Visual Basic
Property HorizontalAlignment() As HorizontalTextAlignmentEnum
See Also

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.HorizontalAlignment Property


TextGraphics.Italic Property

TextGraphics.Italic Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that gets and sets whether the text has italic formatting or not. True if the text has italic formatting.

Visual Basic
Property Italic() As VARIANT_BOOL
See Also

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.Italic Property


TextGraphics.Text Property

TextGraphics.Text Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the text displayed for the TextGraphics object.

Visual Basic
Property Text() As String
See Also

Anchored Client Grahics sample

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.Text Property


TextGraphics.VerticalAlignment Property

TextGraphics.VerticalAlignment Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify the vertical justification of the text with respect to the coordinate point for the text. Valid options are kAlignTextLower, kAlignTextMiddle, and kAlignTextUpper.

Visual Basic
Property VerticalAlignment() As VerticalTextAlignmentEnum
See Also

Text Using Client Graphics (Multiple fonts and lines) sample

Text Using Client Graphics (Simple) sample

You are here: Symbol Reference > Inventor Library > Objects > TextGraphics Interface > TextGraphics Properties > TextGraphics.VerticalAlignment Property


TextStyle Interface

TextStyle Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TextStyle object represents a text style in a drawing.

Class Hierarchy
Inventor::Style
    Inventor::TextStyle
Visual Basic
Public Interface TextStyle
Inherits Style
Notes

Members through which this object may be accessed include:

BalloonStyle.TextStyle

CustomTable.ColumnHeaderTextStyle

CustomTable.DataTextStyle

CustomTable.TitleTextStyle

DimensionStyle.TextStyle

DimensionStyle.ToleranceTextStyle

DrawingViewLabel.TextStyle

FeatureControlFrameStyle.TextStyle

GeneralNote.TextStyle

HoleTable.ColumnHeaderTextStyle

HoleTable.DataTextStyle

HoleTable.TitleTextStyle

HoleTableStyle.ColumnHeaderTextStyle

HoleTableStyle.DataTextStyle

HoleTableStyle.TitleTextStyle

ObjectDefaultsStyle.BorderTextStyle

ObjectDefaultsStyle.GeneralNoteStyle

ObjectDefaultsStyle.SketchedSymbolTextStyle

ObjectDefaultsStyle.SketchTextStyle

ObjectDefaultsStyle.TitleBlockTextStyle

ObjectDefaultsStyle.ViewLabelStyle

PartsList.ColumnHeaderTextStyle

PartsList.DataTextStyle

PartsList.TitleTextStyle

PartsListStyle.ColumnHeaderTextStyle

PartsListStyle.DataTextStyle

PartsListStyle.TitleTextStyle

RevisionTableStyle.ColumnHeaderTextStyle

RevisionTableStyle.DataTextStyle

RevisionTableStyle.RevisionTagTextStyle

RevisionTableStyle.TitleTextStyle

SurfaceTextureStyle.TextStyle

TableFormat.TextStyle

TableStyle.ColumnHeaderTextStyle

TableStyle.DataTextStyle

TableStyle.TitleTextStyle

TextBox.Style

TextStyles.Item

TextStylesEnumerator.Item

See Also

Sketch Text Add sample

You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface


TextStyle Methods

TextStyle Methods
Summary

The methods of the TextStyle class are listed here.

Methods
Methods
Name | Description
GetColor | Method that gets the current color of the text.
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Methods


TextStyle.GetColor Method

TextStyle.GetColor Method Available in Inventor Available in Server
Summary

Method that gets the current color of the text.

Visual Basic
Sub GetColor(ByRef Red As BYTE, ByRef Green As BYTE, ByRef Blue As BYTE)
Parameters
Parameters | Description
Red | Output Byte that specifies the red component of the color. This value will be between 0 and 255.
Green | Output Byte that specifies the green component of the color. This value will be between 0 and 255.
Blue | The blue component of the color. A Byte value between 0 and 255.
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Methods > TextStyle.GetColor Method


TextStyle Properties

TextStyle Properties
Summary

The properties of the TextStyle class are listed here.

Properties
Name | Description
Bold | Property that gets and sets whether the text style has bold formatting or not. True if the text style has bold formatting.
Color | Property that gets and sets the color associated with the text style
Font | Property that gets and sets the font used for the text style.
FontSize | Property that gets and sets the size of the font. The size is specified in centimeters.
HorizontalJustification | Property that gets and sets the horizontal justification of the text style.
Italic | Property that gets and sets whether the text style has italic formatting or not. True if the text style has italic formatting.
LineSpacing | Property that gets and sets the line spacing of the text style.
LineSpacingType | Property that gets and sets the method used to define the line spacing. The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.
Rotation | Property that gets and sets the text rotation of the text style. The units used to define the rotation angle are radians. Currently text rotation is limited to 90 degree increments so valid values for this property are 0, pi/2, pi, and 1.5pi.
Underline | Property that gets and sets whether the text style has italic formatting or not. True if the text style has italic formatting.
VerticalJustification | Property that gets and sets the vertical justification of the text style.
WidthScale | Property that gets and sets the width scale factor for the text style. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties


TextStyle.Bold Property

TextStyle.Bold Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the text style has bold formatting or not. True if the text style has bold formatting.

Visual Basic
Property Bold() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.Bold Property


TextStyle.Color Property

TextStyle.Color Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the color associated with the text style

Visual Basic
Property Color() As Color*
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.Color Property


TextStyle.Font Property

TextStyle.Font Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the font used for the text style.

Visual Basic
Property Font() As String
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.Font Property


TextStyle.FontSize Property

TextStyle.FontSize Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the size of the font. The size is specified in centimeters.

Visual Basic
Property FontSize() As double
See Also

Sketch Text Add sample

Add a general note sample

You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.FontSize Property


TextStyle.HorizontalJustification Property

TextStyle.HorizontalJustification Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the horizontal justification of the text style.

Visual Basic
Property HorizontalJustification() As HorizontalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.HorizontalJustification Property


TextStyle.Italic Property

TextStyle.Italic Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the text style has italic formatting or not. True if the text style has italic formatting.

Visual Basic
Property Italic() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.Italic Property


TextStyle.LineSpacing Property

TextStyle.LineSpacing Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the line spacing of the text style.

Visual Basic
Property LineSpacing() As double
Remarks

The value of this property is treated in one of two ways depending on the value of the LineSpacingType property. When the value of the LineSpacingType property is set to kExactLineSpacing, the value of the LineSpacing property defines the exact distance (in centimeters) from the bottom of one line to bottom of the next line.

When the value of the LineSpacingType property is set to kMultipleLineSpacing, the value defines a spacing factor relative to standard single line spacing. For example, a value of 1.0 will result in standard single line spacing, and a value of 1.5 will result in one and a half line spacing.

You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.LineSpacing Property


TextStyle.LineSpacingType Property

TextStyle.LineSpacingType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the method used to define the line spacing. The valid values for this property are kExactLineSpacing or kMultipleLineSpacing. Depending on the value of this property of the value of the LineSpacing property is treated differently.

Visual Basic
Property LineSpacingType() As TextLineSpacingTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.LineSpacingType Property


TextStyle.Rotation Property

TextStyle.Rotation Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the text rotation of the text style. The units used to define the rotation angle are radians. Currently text rotation is limited to 90 degree increments so valid values for this property are 0, pi/2, pi, and 1.5pi.

Visual Basic
Property Rotation() As double
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.Rotation Property


TextStyle.Underline Property

TextStyle.Underline Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets whether the text style has italic formatting or not. True if the text style has italic formatting.

Visual Basic
Property Underline() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.Underline Property


TextStyle.VerticalJustification Property

TextStyle.VerticalJustification Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the vertical justification of the text style.

Visual Basic
Property VerticalJustification() As VerticalTextAlignmentEnum
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.VerticalJustification Property


TextStyle.WidthScale Property

TextStyle.WidthScale Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that gets and sets the width scale factor for the text style. This is also referred to as the 'stretch factor'. A value of 1.0 will display the text as designed; a value of 0.5 will decrease the width of the text by 50%.

Visual Basic
Property WidthScale() As double
You are here: Symbol Reference > Inventor Library > Objects > TextStyle Interface > TextStyle Properties > TextStyle.WidthScale Property


TextStyles Interface

TextStyles Interface
Summary

The TextStyles collection object provides access to all the existing objects in a drawing document.

Class Hierarchy
Inventor::TextStyles
Visual Basic
Public Interface TextStyles
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface


TextStyles Methods

TextStyles Methods
Summary

The methods of the TextStyles class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified TextStyle object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface > TextStyles Methods


TextStyles.Item Method

TextStyles.Item Method
Summary

Property that returns the specified TextStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] TextStyle*)
Parameters
Parameters | Description
index | Input Variant value that specifies the TextStyle to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the text style's name. If an out-of-range index or a name of a nonexistent text style is specified, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface > TextStyles Methods > TextStyles.Item Method


TextStyles Properties

TextStyles Properties
Summary

The properties of the TextStyles class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface > TextStyles Properties


TextStyles.Application Property

TextStyles.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface > TextStyles Properties > TextStyles.Application Property


TextStyles.Count Property

TextStyles.Count Property
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface > TextStyles Properties > TextStyles.Count Property


TextStyles.Type Property

TextStyles.Type Property
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextStyles Interface > TextStyles Properties > TextStyles.Type Property


TextStylesEnumerator Interface

TextStylesEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

The TextStylesEnumerator Collection Object allows iteration of the available text styles.

Class Hierarchy
Inventor::TextStylesEnumerator
Visual Basic
Public Interface TextStylesEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingStylesManager.TextStyles

You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface


TextStylesEnumerator Methods

TextStylesEnumerator Methods
Summary

The methods of the TextStylesEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified object in the collection.
You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface > TextStylesEnumerator Methods


TextStylesEnumerator.Item Method

TextStylesEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] TextStyle*)
Parameters
Parameters | Description
index | Input Variant that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface > TextStylesEnumerator Methods > TextStylesEnumerator.Item Method


TextStylesEnumerator Properties

TextStylesEnumerator Properties
Summary

The properties of the TextStylesEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface > TextStylesEnumerator Properties


TextStylesEnumerator.Application Property

TextStylesEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface > TextStylesEnumerator Properties > TextStylesEnumerator.Application Property


TextStylesEnumerator.Count Property

TextStylesEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface > TextStylesEnumerator Properties > TextStylesEnumerator.Count Property


TextStylesEnumerator.Type Property

TextStylesEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextStylesEnumerator Interface > TextStylesEnumerator Properties > TextStylesEnumerator.Type Property


TextureCoordinateSet Interface

TextureCoordinateSet Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

A TextureCoordinateSet defines the coordinates of the map on the face. The TextureMap.Transformation matrix defines how the coordinates map to the actual face coordinates. Several TextureMaps could reference a single TextureCoordinateSet.

Class Hierarchy
Inventor::TextureCoordinateSet
Visual Basic
Public Interface TextureCoordinateSet
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TextureMap.GetTextureCoordinateSet

You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface


TextureCoordinateSet Methods

TextureCoordinateSet Methods
Summary

The methods of the TextureCoordinateSet class are listed here.

Methods
Methods
Name | Description
GetCoordinates | Method to obtain the coordinates to this set.
Item | Property that returns the specified coordinates from the set.
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Methods


TextureCoordinateSet.GetCoordinates Method

TextureCoordinateSet.GetCoordinates Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method to obtain the coordinates to this set.

Visual Basic
Sub GetCoordinates(ByRef Coordinates As SAFEARRAY(double))
Parameters
Parameters | Description
Coordinates | The coordinates to obtain.
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Methods > TextureCoordinateSet.GetCoordinates Method


TextureCoordinateSet.Item Method

TextureCoordinateSet.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the specified coordinates from the set.

Visual Basic
Sub Item(index As long, Result As [out, retval] Point*)
Parameters
Parameters | Description
index | Specifies the object to return.
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Methods > TextureCoordinateSet.Item Method


TextureCoordinateSet Properties

TextureCoordinateSet Properties
Summary

The properties of the TextureCoordinateSet class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of coordinates in this set.
Parent | Gets the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Properties


TextureCoordinateSet.Application Property

TextureCoordinateSet.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Properties > TextureCoordinateSet.Application Property


TextureCoordinateSet.Count Property

TextureCoordinateSet.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of coordinates in this set.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Properties > TextureCoordinateSet.Count Property


TextureCoordinateSet.Parent Property

TextureCoordinateSet.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Properties > TextureCoordinateSet.Parent Property


TextureCoordinateSet.Type Property

TextureCoordinateSet.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextureCoordinateSet Interface > TextureCoordinateSet Properties > TextureCoordinateSet.Type Property


TextureMap Interface

TextureMap Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

Each TextureMap references a TextureCoordinateSet that defines the coordinates of the map on the face. Several TextureMaps could reference a single TextureCoordinateSet.

Class Hierarchy
Inventor::TextureMap
Visual Basic
Public Interface TextureMap
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TextureMaps.Item

You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface


TextureMap Methods

TextureMap Methods
Summary

The methods of the TextureMap class are listed here.

Methods
Methods
Name | Description
GetTextureCoordinateSet | Gets the TextureCoordinateSet for the input tolerance.
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Methods


TextureMap.GetTextureCoordinateSet Method

TextureMap.GetTextureCoordinateSet Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the TextureCoordinateSet for the input tolerance.

Visual Basic
Sub GetTextureCoordinateSet(tolerance As double, Result As [out, retval] TextureCoordinateSet*)
Parameters
Parameters | Description
tolerance | Input tolerance value.
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Methods > TextureMap.GetTextureCoordinateSet Method


TextureMap Properties

TextureMap Properties
Summary

The properties of the TextureMap class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Image | Gets the image for the texture map.
MaskColor | Gets the mask color for the texture map image.
Parent | Gets the parent object from whom this object can logically be reached.
Transformation | A matrix that defines how the coordinates map to the actual face coordinates.
Type | Property returning an enum indicating this object's type.
UseMask | Gets whether the texture map mask is in use.
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties


TextureMap.Application Property

TextureMap.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.Application Property


TextureMap.Image Property

TextureMap.Image Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the image for the texture map.

Visual Basic
Property Image() As IPictureDisp**
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.Image Property


TextureMap.MaskColor Property

TextureMap.MaskColor Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the mask color for the texture map image.

Visual Basic
Property MaskColor() As Color**
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.MaskColor Property


TextureMap.Parent Property

TextureMap.Parent Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.Parent Property


TextureMap.Transformation Property

TextureMap.Transformation Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

A matrix that defines how the coordinates map to the actual face coordinates.

Visual Basic
Property Transformation() As Matrix**
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.Transformation Property


TextureMap.Type Property

TextureMap.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.Type Property


TextureMap.UseMask Property

TextureMap.UseMask Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Gets whether the texture map mask is in use.

Visual Basic
Property UseMask() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TextureMap Interface > TextureMap Properties > TextureMap.UseMask Property


TextureMaps Interface

TextureMaps Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

The TextureMaps collection returns all the texture maps applied to a face. There could be multiple maps that are 'wrapped' around a face.

Class Hierarchy
Inventor::TextureMaps
Visual Basic
Public Interface TextureMaps
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Face.TextureMaps

You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface


TextureMaps Methods

TextureMaps Methods
Summary

The methods of the TextureMaps class are listed here.

Methods
Methods
Name | Description
Item | Returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface > TextureMaps Methods


TextureMaps.Item Method

TextureMaps.Item Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Returns the specified object from the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] TextureMap*)
Parameters
Parameters | Description
index | Value that specifies the object to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the name of the item.
You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface > TextureMaps Methods > TextureMaps.Item Method


TextureMaps Properties

TextureMaps Properties
Summary

The properties of the TextureMaps class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface > TextureMaps Properties


TextureMaps.Application Property

TextureMaps.Application Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface > TextureMaps Properties > TextureMaps.Application Property


TextureMaps.Count Property

TextureMaps.Count Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface > TextureMaps Properties > TextureMaps.Count Property


TextureMaps.Type Property

TextureMaps.Type Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TextureMaps Interface > TextureMaps Properties > TextureMaps.Type Property


ThickenFeature Interface

ThickenFeature Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The ThickenFeature object represents a thicken feature, which is created interactively using the Thicken/Offset tool on the Part features toolbar. A thicken operation adds or removes volume from parts or adds thickness to surfaces to create parts.

Class Hierarchy
Inventor::PartFeature
    Inventor::ThickenFeature
        Inventor::ThickenFeatureProxy
Visual Basic
Public Interface ThickenFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ThickenFeatureProxy.NativeObject

ThickenFeatures.Add

ThickenFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface


ThickenFeature Properties

ThickenFeature Properties
Summary

The properties of the ThickenFeature class are listed here.

Properties
Name | Description
ApproximationOptimized | Property that gets and sets whether the approximation is optimized (i.e. compute time is minimized and the feature is computed within a reasonable tolerance). If set to False, the feature is computed to the tolerance specified in the ApproximationTolerance property.
ApproximationTolerance | Property that gets and sets the approximation tolerance. This value must be between 0 and 1 and defaults to 0.1. This value is used only if the ApproximationOptimized property is set to False.
ApproximationType | Property that gets and sets the approximation method used for the feature. Valid types are kNoApproximation, kMeanApproximation, kNeverTooThickApproximation and kNeverTooThinApproximation. The default value for the property is kMeanApproximation. If an approximation method is specified, it is used only if the precise compute fails.
AutomaticBlending | Property that returns whether the offset operation should propagate to adjacent tangent faces.
AutomaticFaceChain | Property that gets whether or not to perform chaining of tangent continuous faces.
CreateVerticalSurfaces | Property that gets whether or not to create vertical or "side" faces connecting the offset faces to the original work surface.
Direction | Property that gets the distance direction of the feature. Valid values are kPositive, kNegative, or kSymmetric. kPositive defines the offset direction to be in the same direction as the normal of the faces.
Distance | Property that returns the parameter that controls the thickness of the Thickness feature or the distance of the Offset feature.
InputFaces | Property that specifies the faces used to create the feature. This can either be a WorkSurface or a FaceCollection. The FaceCollection will contain a GenericObject in the case where a face is consumed by the feature creation. This face may be obtained by moving the end of part marker above this feature.
Operation | Property that indicates the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties


ThickenFeature.ApproximationOptimized Property

ThickenFeature.ApproximationOptimized Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the approximation is optimized (i.e. compute time is minimized and the feature is computed within a reasonable tolerance). If set to False, the feature is computed to the tolerance specified in the ApproximationTolerance property.

Visual Basic
Property ApproximationOptimized() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.ApproximationOptimized Property


ThickenFeature.ApproximationTolerance Property

ThickenFeature.ApproximationTolerance Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the approximation tolerance. This value must be between 0 and 1 and defaults to 0.1. This value is used only if the ApproximationOptimized property is set to False.

Visual Basic
Property ApproximationTolerance() As double
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.ApproximationTolerance Property


ThickenFeature.ApproximationType Property

ThickenFeature.ApproximationType Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the approximation method used for the feature. Valid types are kNoApproximation, kMeanApproximation, kNeverTooThickApproximation and kNeverTooThinApproximation. The default value for the property is kMeanApproximation. If an approximation method is specified, it is used only if the precise compute fails.

Visual Basic
Property ApproximationType() As FeatureApproximationTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.ApproximationType Property


ThickenFeature.AutomaticBlending Property

ThickenFeature.AutomaticBlending Property
Summary

Property that returns whether the offset operation should propagate to adjacent tangent faces.

Visual Basic
Property AutomaticBlending() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.AutomaticBlending Property


ThickenFeature.AutomaticFaceChain Property

ThickenFeature.AutomaticFaceChain Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether or not to perform chaining of tangent continuous faces.

Visual Basic
Property AutomaticFaceChain() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.AutomaticFaceChain Property


ThickenFeature.CreateVerticalSurfaces Property

ThickenFeature.CreateVerticalSurfaces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether or not to create vertical or "side" faces connecting the offset faces to the original work surface.

Visual Basic
Property CreateVerticalSurfaces() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.CreateVerticalSurfaces Property


ThickenFeature.Direction Property

ThickenFeature.Direction Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets the distance direction of the feature. Valid values are kPositive, kNegative, or kSymmetric. kPositive defines the offset direction to be in the same direction as the normal of the faces.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.Direction Property


ThickenFeature.Distance Property

ThickenFeature.Distance Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the parameter that controls the thickness of the Thickness feature or the distance of the Offset feature.

Visual Basic
Property Distance() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.Distance Property


ThickenFeature.InputFaces Property

ThickenFeature.InputFaces Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that specifies the faces used to create the feature. This can either be a WorkSurface or a FaceCollection. The FaceCollection will contain a GenericObject in the case where a face is consumed by the feature creation. This face may be obtained by moving the end of part marker above this feature.

Visual Basic
Property InputFaces() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.InputFaces Property


ThickenFeature.Operation Property

ThickenFeature.Operation Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that indicates the type of operation used to add the feature to the model. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, kSurfaceOperation.

Visual Basic
Property Operation() As PartFeatureOperationEnum
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeature Interface > ThickenFeature Properties > ThickenFeature.Operation Property


ThickenFeatureProxy Interface

ThickenFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ThickenFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ThickenFeature
        Inventor::ThickenFeatureProxy
Visual Basic
Public Interface ThickenFeatureProxy
Inherits ThickenFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatureProxy Interface


ThickenFeatureProxy Properties

ThickenFeatureProxy Properties
Summary

The properties of the ThickenFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatureProxy Interface > ThickenFeatureProxy Properties


ThickenFeatureProxy.ContainingOccurrence Property

ThickenFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatureProxy Interface > ThickenFeatureProxy Properties > ThickenFeatureProxy.ContainingOccurrence Property


ThickenFeatureProxy.NativeObject Property

ThickenFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ThickenFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatureProxy Interface > ThickenFeatureProxy Properties > ThickenFeatureProxy.NativeObject Property


ThickenFeatures Interface

ThickenFeatures Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The ThickenFeatures collection object represents a collection of objects on a part.

Class Hierarchy
Inventor::ThickenFeatures
Visual Basic
Public Interface ThickenFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.ThickenFeatures

You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface


ThickenFeatures Methods

ThickenFeatures Methods
Summary

The methods of the ThickenFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ThickenFeature. The new created ThickenFeature is returned.
Item | Property that returns the specified ThickenFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Methods


ThickenFeatures.Add Method

ThickenFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new ThickenFeature. The new created ThickenFeature is returned.

Visual Basic
Sub Add(Faces As IDispatch, Distance As VARIANT, ExtentDirection As PartFeatureExtentDirectionEnum, Operation As PartFeatureOperationEnum, ByRef AutomaticFaceChain As [defaultvalue(0)] VARIANT_BOOL, ByRef CreateVerticalSurfaces As [defaultvalue(0)] VARIANT_BOOL, ByRef AutomaticBlending As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] ThickenFeature*)
Parameters
Parameters | Description
Faces | Input object that defines the faces to thicken or faces from which to create an offset surface. This can either be a WorkSurface or a FaceCollection. If multiple faces are provided, they must be connected.
Distance | Input Variant that defines the thickness of the Thicken feature or specifies distance for the Offset feature. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document. When the output is a surface, the offset distance can be zero.
ExtentDirection | Input constant that indicates which side of the input faces to thicken or offset towards. Valid input is kPositive, kNegative, or kSymmetric. kPositive defines the offset direction to be in the same direction as the normal of the input faces.
Operation | Input constant that indicates the type of operation to perform. Valid input is kJoinOperation, kCutOperation, kIntersectOperation, or kSurfaceOperation.
AutomaticFaceChain | Optional input Boolean that specifies whether or not to perform chaining of tangent continuous faces. The default value is False indicating that automatic chaining will not be performed.
CreateVerticalSurfaces | Optional input Boolean that specifies whether or not to create vertical or "side" faces connecting the offset faces to the original work surface. Vertical surfaces are created only at internal surface edges, not at boundary edges of surfaces. The default value is False.
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Methods > ThickenFeatures.Add Method


ThickenFeatures.Item Method

ThickenFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified ThickenFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ThickenFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out-of-range index or a name of a non-existent feature is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Methods > ThickenFeatures.Item Method


ThickenFeatures Properties

ThickenFeatures Properties
Summary

The properties of the ThickenFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Properties


ThickenFeatures.Application Property

ThickenFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Properties > ThickenFeatures.Application Property


ThickenFeatures.Count Property

ThickenFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Properties > ThickenFeatures.Count Property


ThickenFeatures.Type Property

ThickenFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThickenFeatures Interface > ThickenFeatures Properties > ThickenFeatures.Type Property


ThreadFeature Interface

ThreadFeature Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ThreadFeature object represents thread modeling features.

Class Hierarchy
Inventor::PartFeature
    Inventor::ThreadFeature
        Inventor::ThreadFeatureProxy
Visual Basic
Public Interface ThreadFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

ThreadFeatureProxy.NativeObject

ThreadFeatures.Add

ThreadFeatures.Item

See Also

Edit thread features sample

Example

"Thread Feature Create Example "

This sample demonstrates the creation of a thread feature. It creates a cylinder in a new part document and creates a thread feature on the cylinder.

Public Sub ThreadSample()
    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                 ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Create a new sketch on the X-Y work plane.
    Dim oSketch As PlanarSketch
    Set oSketch = oCompDef.Sketches.Add(oCompDef.WorkPlanes.Item(3))

    ' Create a sketch circle.  (The radius is for 1 5/8 inch diameter shaft.)
    Dim oCircle As SketchCircle
    Set oCircle = oSketch.SketchCircles.AddByCenterRadius( _
                    ThisApplication.TransientGeometry.CreatePoint2d(0, 0), 4.1275 / 2)

    Dim oProfile As Profile
    Set oProfile = oSketch.Profiles.AddForSolid

    ' Extrude the circle to create a cylinder.
    Dim oExtrude As ExtrudeFeature
    Set oExtrude = oCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                        oProfile, 5, kPositiveExtentDirection, kJoinOperation)
    oSketch.Visible = False

    ' Set a reference to the ThreadFeatures collection object.
    Dim oThreadFeatures As ThreadFeatures
    Set oThreadFeatures = oCompDef.Features.ThreadFeatures

    ' Define all of the thread information.
    Dim oThreadInfo As ThreadInfo
    Set oThreadInfo = oThreadFeatures.CreateStandardThreadInfo( _
                        False, True, "ANSI Unified Screw Threads", _
                        "1 5/8-6 UN", "2A")

    ' Get the face the thread will be applied to.
    Dim oFace As Face
    Set oFace = oExtrude.SideFaces.Item(1)

    ' Get the edge the thread extent will be measured from.
    Dim oEdge As Edge
    Set oEdge = oExtrude.EndFaces.Item(1).Edges.Item(1)

    ' Create the thread feature.
    Dim oThreadFeature As ThreadFeature
    Set oThreadFeature = oThreadFeatures.Add(oFace, oEdge, oThreadInfo, _
                                                False, False, "2 cm", 0)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface


ThreadFeature Methods

ThreadFeature Methods
Summary

The methods of the ThreadFeature class are listed here.

Methods
Methods
Name | Description
SetThreadDepth | Method that sets the thread depth for the thread feature.
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Methods


ThreadFeature.SetThreadDepth Method

ThreadFeature.SetThreadDepth Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the thread depth for the thread feature.

Visual Basic
Sub SetThreadDepth(ThreadDepth As VARIANT, StartEdge As Edge)
Parameters
Parameters | Description
ThreadDepth | Input Variant that specifies the total depth of the thread, as measured from its starting edge.
StartEdge | Input Edge that specifies the point at which to begin thread.
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Methods > ThreadFeature.SetThreadDepth Method


ThreadFeature Properties

ThreadFeature Properties
Summary

The properties of the ThreadFeature class are listed here.

Properties
Name | Description
DirectionReversed | Property that gets and sets whether the direction of the thread is in the default direction or reversed.
DisplayInModel | Property that gets and sets whether the threads are displayed on the part when viewed in any of the 3d environments, i.e. part or assembly.
FullDepth | Property that gets and sets whether the threads extend the full length of the cylinder or cone. If True, they extend the full length. If False, the depth is controlled by the value of the ThreadDepth property
StartEdge | Property that returns the thread depth is measured from.
ThreadDepth | Property that returns the parameter that controls the depth of the thread. Even though the parameter for the thread depth is always created and accessible through this property, it is only used in the case where the FullDepth property is False.
ThreadedFace | Property that returns the set of that the thread is applied to. Usually this is just the face that was input for application of the thread feature, but in the case where the original face has been cut by subsequent features, the multiple resulting faces will be returned.
ThreadInfo | Property that gets and sets the thread information of the feature. This can return either a StandardThreadInfo or TaperedThreadInfo object. The ThreadType property can be used to determine the type before getting the thread info.
ThreadInfoType | Property that returns a indicating the thread type.
ThreadOffset | Property that gets the parameter that controls the offset value of the thread. The offset is the distance along the axis of the cylinder or cone from the start edge to the start of the thread.
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties


ThreadFeature.DirectionReversed Property

ThreadFeature.DirectionReversed Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the direction of the thread is in the default direction or reversed.

Visual Basic
Property DirectionReversed() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.DirectionReversed Property


ThreadFeature.DisplayInModel Property

ThreadFeature.DisplayInModel Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the threads are displayed on the part when viewed in any of the 3d environments, i.e. part or assembly.

Visual Basic
Property DisplayInModel() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.DisplayInModel Property


ThreadFeature.FullDepth Property

ThreadFeature.FullDepth Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the threads extend the full length of the cylinder or cone. If True, they extend the full length. If False, the depth is controlled by the value of the ThreadDepth property

Visual Basic
Property FullDepth() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.FullDepth Property


ThreadFeature.StartEdge Property

ThreadFeature.StartEdge Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the thread depth is measured from.

Visual Basic
Property StartEdge() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.StartEdge Property


ThreadFeature.ThreadDepth Property

ThreadFeature.ThreadDepth Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parameter that controls the depth of the thread. Even though the parameter for the thread depth is always created and accessible through this property, it is only used in the case where the FullDepth property is False.

Visual Basic
Property ThreadDepth() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.ThreadDepth Property


ThreadFeature.ThreadedFace Property

ThreadFeature.ThreadedFace Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the set of that the thread is applied to. Usually this is just the face that was input for application of the thread feature, but in the case where the original face has been cut by subsequent features, the multiple resulting faces will be returned.

Visual Basic
Property ThreadedFace() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.ThreadedFace Property


ThreadFeature.ThreadInfo Property

ThreadFeature.ThreadInfo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the thread information of the feature. This can return either a StandardThreadInfo or TaperedThreadInfo object. The ThreadType property can be used to determine the type before getting the thread info.

Visual Basic
Property ThreadInfo() As ThreadInfo*
See Also

Edit thread features sample

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.ThreadInfo Property


ThreadFeature.ThreadInfoType Property

ThreadFeature.ThreadInfoType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns a indicating the thread type.

Visual Basic
Property ThreadInfoType() As ThreadTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.ThreadInfoType Property


ThreadFeature.ThreadOffset Property

ThreadFeature.ThreadOffset Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets the parameter that controls the offset value of the thread. The offset is the distance along the axis of the cylinder or cone from the start edge to the start of the thread.

Visual Basic
Property ThreadOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeature Interface > ThreadFeature Properties > ThreadFeature.ThreadOffset Property


ThreadFeatureProxy Interface

ThreadFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ThreadFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::ThreadFeature
        Inventor::ThreadFeatureProxy
Visual Basic
Public Interface ThreadFeatureProxy
Inherits ThreadFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatureProxy Interface


ThreadFeatureProxy Properties

ThreadFeatureProxy Properties
Summary

The properties of the ThreadFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatureProxy Interface > ThreadFeatureProxy Properties


ThreadFeatureProxy.ContainingOccurrence Property

ThreadFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatureProxy Interface > ThreadFeatureProxy Properties > ThreadFeatureProxy.ContainingOccurrence Property


ThreadFeatureProxy.NativeObject Property

ThreadFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ThreadFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatureProxy Interface > ThreadFeatureProxy Properties > ThreadFeatureProxy.NativeObject Property


ThreadFeatures Interface

ThreadFeatures Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ThreadFeatures object provides access to all of the objects in a component definition and provides methods to create additional ThreadFeature objects.

Class Hierarchy
Inventor::ThreadFeatures
Visual Basic
Public Interface ThreadFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.ThreadFeatures

See Also

Edit thread features sample

Thread Feature Create sample

Thread Feature Create sample

Example

See ThreadFeature for example "Creating a thread feature"

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface


ThreadFeatures Methods

ThreadFeatures Methods
Summary

The methods of the ThreadFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new ThreadFeature. The new ThreadFeature object is returned.
CreateStandardThreadInfo | Method that creates a new HoleTapInfo object that can be used in creating threads for Hole features. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments.
CreateTaperedThreadInfo | Method that creates a new TaperedThreadInfo object that can be used in creating Hole and ThreadFeature objects. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments. The spreadsheet columns match one for one with these arguments.
Item | Property that returns the specified ThreadFeature object from the collection. This is the default property of the ThreadFeatures collection object.
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Methods


ThreadFeatures.Add Method

ThreadFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new ThreadFeature. The new ThreadFeature object is returned.

Visual Basic
Sub Add(Face As Face, StartEdge As Edge, ThreadInfo As ThreadInfo, ByRef DirectionReversed As [defaultvalue(0)] VARIANT_BOOL, ByRef FullDepth As [defaultvalue(-1)] VARIANT_BOOL, ByRef ThreadDepth As [optional] VARIANT, ByRef ThreadOffset As [optional] VARIANT, Result As [out, retval] ThreadFeature*)
Parameters
Parameters | Description
Face | Input Face object that defines which face the thread feature is to be applied to. The face must be either a cylinder or cone.
StartEdge | Input Edge object that defines the start of the thread. The edge must be an edge of the input face.
ThreadInfo | Input ThreadInfo object that defines the thread attributes. This must be a StandardThreadInfo in the case where the input face is a cylinder and a TaperedThreadInfo in the case where the input face is a cone.
DirectionReversed | Optional input Boolean that specifies which direction from the start along the cone or cylinder the thread goes in.
FullDepth | Optional input Boolean that specifies if the thread go the full length of the cylinder or cone. A value of True indicates it goes the full the length. If False, the ThreadDepth argument needs to be supplies.
ThreadDepth | Input Variant that defines the depth of the thread. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
ThreadOffset | Optional input Variant that defines the offset of the start of the thread from the start edge. This can be either a numeric value or a string. A parameter for this value will be created and the supplied string or value is assigned to the parameter. If a value is input, the units are centimeters. If a string is input, the units can be specified as part of the string or it will default to the current length units of the document.
See Also

Thread Feature Create sample

Example

See ThreadFeature for example "Creating a thread feature"

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Methods > ThreadFeatures.Add Method


ThreadFeatures.CreateStandardThreadInfo Method

ThreadFeatures.CreateStandardThreadInfo Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new HoleTapInfo object that can be used in creating threads for Hole features. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments.

Visual Basic
Sub CreateStandardThreadInfo(Internal As VARIANT_BOOL, RightHanded As VARIANT_BOOL, ThreadType As String, ThreadDesignation As String, Class As String, Result As [out, retval] StandardThreadInfo*)
Internal

Input Boolean that indicates if the thread is an internal or external thread. A value of True indicates an Internal thread.

RightHanded : Input Boolean that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.

ThreadType : Input String that specifies the sheet in the Thread.xls that this thread information should be validated within. Each sheet within the Excel document is typically used for different thread types. The string is the name of the sheet. For example "ANSI Unified Screw Threads" or "ANSI Metric M Profile" are valid for English versions of Autodesk Inventor.

ThreadDesignation : Input String that contains the thread designation. This is input as the full thread designation that will be used in a drawing for the thread callout. The nominal size and pitch information are extracted from the designation. For example valid inch thread designations are '10-24 UNC' and '7/16-20 UNF'. Examples of valid metric designations are 'M16x1.5' and 'M55x1.5'.

Class : Input String that defines the thread class. For example a valid class for an inch internal thread is 2B. A valid class for a metric external thread is 6g.

See Also

Thread Feature Create sample

Example

Edit thread features example.

The following example demonstrates how to edit an existing thread feature. You need to make sure that the ThreadInfo object that you create is appropriate (size, etc.) for the face that it will be applied for. A ThreadInfo object represents a row in the Thread.xls spreadsheet.

Sub EditThread()

   Dim oDoc As PartDocument
   Set oDoc = ThisApplication.ActiveDocument

   Dim oDef As PartComponentDefinition
   Set oDef = oDoc.ComponentDefinition

   ' Create a new thread info object containing the thread data
   Dim oNewThreadInfo As StandardThreadInfo
   Set oNewThreadInfo = oDef.Features.ThreadFeatures.CreateStandardThreadInfo(False, True, "ISO Metric Profile", "M20x2.5", "6g")

   ' Get the first thread feature
   Dim oThread As ThreadFeature
   Set oThread = oDef.Features.ThreadFeatures.Item(1)

   ' Edit the thread feature
   oThread.ThreadInfo = oNewThreadInfo

End Sub
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Methods > ThreadFeatures.CreateStandardThreadInfo Method


ThreadFeatures.CreateTaperedThreadInfo Method

ThreadFeatures.CreateTaperedThreadInfo Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that creates a new TaperedThreadInfo object that can be used in creating Hole and ThreadFeature objects. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments. The spreadsheet columns match one for one with these arguments.

Visual Basic
Sub CreateTaperedThreadInfo(Internal As VARIANT_BOOL, RightHanded As VARIANT_BOOL, ThreadType As String, ThreadDesignation As String, Result As [out, retval] TaperedThreadInfo*)
Internal

Input Boolean that indicates if the thread is an internal or external thread. A value of True indicates an Internal thread.

RightHanded : Input Boolean that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.

ThreadType : Input String that specifies the sheet in the Thread.xls that this thread information should be validated within. Each sheet within the Excel document is typically used for different thread types. The string is the name of the sheet. For example "NPT" or "JIS Taper" are valid for English versions of Autodesk Inventor.

ThreadDesignation : Input String that contains the thread designation. This is input as the full thread designation that will be used in a drawing for the thread callout. The nominal size information is extracted from the designation.

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Methods > ThreadFeatures.CreateTaperedThreadInfo Method


ThreadFeatures.Item Method

ThreadFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the specified ThreadFeature object from the collection. This is the default property of the ThreadFeatures collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] ThreadFeature*)
Parameters
Parameters | Description
index | Input Variant value that specifies the feature to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the feature name. If an out of range index or a name of a non-existent feature is provided, an error occurs.
See Also

Edit thread features sample

You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Methods > ThreadFeatures.Item Method


ThreadFeatures Properties

ThreadFeatures Properties
Summary

The properties of the ThreadFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Properties


ThreadFeatures.Application Property

ThreadFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Properties > ThreadFeatures.Application Property


ThreadFeatures.Count Property

ThreadFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Properties > ThreadFeatures.Count Property


ThreadFeatures.Type Property

ThreadFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThreadFeatures Interface > ThreadFeatures Properties > ThreadFeatures.Type Property


ThreadInfo Interface

ThreadInfo Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

This is a common base object from which the rest of the concrete objects that hold thread information are derived. It contains the generally applicable properties of threads.

Class Hierarchy
Inventor::ThreadInfo
    Inventor::StandardThreadInfo
    Inventor::TaperedThreadInfo
Visual Basic
Public Interface ThreadInfo
Inherits IDispatch
Remarks

Although several properties on this object and objects derived from this object are read-write, it is not recommended to edit hole and thread features in this fashion. If any value on the ThreadInfo needs to be modified, you should create a new ThreadInfo object and set this new ThreadInfo using the corresponding property on the feature (i.e. ThreadInfo property on ThreadFeature and TapInfo property on HoleFeature.)

Notes

Members through which this object may be accessed include:

ThreadFeature.ThreadInfo

ThreadFeatures.CreateThreadInfo

ThreadTableQuery.CreateThreadInfo

See Also

Thread Feature Create sample

Example

See ThreadFeature for example "Using ThreadInfo when creating a thread feature"

You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface


ThreadInfo Methods

ThreadInfo Methods
Summary

The methods of the ThreadInfo class are listed here.

Methods
Methods
Name | Description
_NominalSizeDescription | This is _NominalSizeDescription, a member of class ThreadInfo.
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Methods


ThreadInfo._NominalSizeDescription Method

ThreadInfo._NominalSizeDescription Method
Summary

This is _NominalSizeDescription, a member of class ThreadInfo.

Visual Basic
Sub _NominalSizeDescription(Value As String)
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Methods > ThreadInfo._NominalSizeDescription Method


ThreadInfo Properties

ThreadInfo Properties
Summary

The properties of the ThreadInfo class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CustomThreadDesignation | Indicates the custom thread designation from the Custom Thread Designation column of the thread data spreadsheet.
FullThreadDepth | Gets whether this thread is the full length of the cylinder or cone.
Internal | Property that indicates if the thread is an internal or external thread. A value of True indicates an Internal thread.
Metric | Property that indicates if the thread is a metric or inch thread. If metric then all other measurements are assumed to be in millimeters. If inch then all measurements will be in inches. A value of True indicates a metric thread.
RightHanded | Property that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.
ThreadBasePoints | Property that returns an enumerator of Point objects indicating the base points for the thread. Typically, there is only one item in the collection. The exception is a hole feature based on multiple sketch points, in which case there are as many Point objects returned as there are sketch points. The point accounts for any offsets applied to the thread. The property returns a point only when the ThreadInfo object is obtained from a feature and returns Nothing in the forward create scenario.
ThreadDesignation | Property that returns a string that contains the thread designation. This is the full thread designation that is used in a drawing for the thread callout.
ThreadDirection | Property that returns the direction of the thread. The property returns a vector only when the ThreadInfo object is obtained from a feature and returns Nothing in the forward create scenario.
ThreadType | Property that gets and sets the string that defines the thread type. The thread type is used by the Thread command to define valid thread definitions. This string is localized and can be changed by the user. This is stored in a specially designated cell within each sheet in the xls.
ThreadTypeIdentifier | Property that returns the string that identifies the thread type. This string is not localized and should not be changed by the user. The thread type is the name of the sheet in the Thread.xls file.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties


ThreadInfo.Application Property

ThreadInfo.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.Application Property


ThreadInfo.CustomThreadDesignation Property

ThreadInfo.CustomThreadDesignation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Indicates the custom thread designation from the Custom Thread Designation column of the thread data spreadsheet.

Visual Basic
Property CustomThreadDesignation() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.CustomThreadDesignation Property


ThreadInfo.FullThreadDepth Property

ThreadInfo.FullThreadDepth Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets whether this thread is the full length of the cylinder or cone.

Visual Basic
Property FullThreadDepth() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.FullThreadDepth Property


ThreadInfo.Internal Property

ThreadInfo.Internal Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates if the thread is an internal or external thread. A value of True indicates an Internal thread.

Visual Basic
Property Internal() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.Internal Property


ThreadInfo.Metric Property

ThreadInfo.Metric Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates if the thread is a metric or inch thread. If metric then all other measurements are assumed to be in millimeters. If inch then all measurements will be in inches. A value of True indicates a metric thread.

Visual Basic
Property Metric() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.Metric Property


ThreadInfo.RightHanded Property

ThreadInfo.RightHanded Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.

Visual Basic
Property RightHanded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.RightHanded Property


ThreadInfo.ThreadBasePoints Property

ThreadInfo.ThreadBasePoints Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns an enumerator of Point objects indicating the base points for the thread. Typically, there is only one item in the collection. The exception is a hole feature based on multiple sketch points, in which case there are as many Point objects returned as there are sketch points. The point accounts for any offsets applied to the thread. The property returns a point only when the ThreadInfo object is obtained from a feature and returns Nothing in the forward create scenario.

Visual Basic
Property ThreadBasePoints() As ObjectsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.ThreadBasePoints Property


ThreadInfo.ThreadDesignation Property

ThreadInfo.ThreadDesignation Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns a string that contains the thread designation. This is the full thread designation that is used in a drawing for the thread callout.

Visual Basic
Property ThreadDesignation() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.ThreadDesignation Property


ThreadInfo.ThreadDirection Property

ThreadInfo.ThreadDirection Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the direction of the thread. The property returns a vector only when the ThreadInfo object is obtained from a feature and returns Nothing in the forward create scenario.

Visual Basic
Property ThreadDirection() As Vector**
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.ThreadDirection Property


ThreadInfo.ThreadType Property

ThreadInfo.ThreadType Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the string that defines the thread type. The thread type is used by the Thread command to define valid thread definitions. This string is localized and can be changed by the user. This is stored in a specially designated cell within each sheet in the xls.

Visual Basic
Property ThreadType() As String
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.ThreadType Property


ThreadInfo.ThreadTypeIdentifier Property

ThreadInfo.ThreadTypeIdentifier Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the string that identifies the thread type. This string is not localized and should not be changed by the user. The thread type is the name of the sheet in the Thread.xls file.

Visual Basic
Property ThreadTypeIdentifier() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.ThreadTypeIdentifier Property


ThreadInfo.Type Property

ThreadInfo.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThreadInfo Interface > ThreadInfo Properties > ThreadInfo.Type Property


ThreadTableQuery Interface

ThreadTableQuery Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The ThreadTableQuery object has methods to query the thread table data contained in the Thread.xls spreadsheet.

Class Hierarchy
Inventor::ThreadTableQuery
Visual Basic
Public Interface ThreadTableQuery
Inherits IDispatch
Notes

Members through which this object may be accessed include:

GeneralOptions.ThreadTableQuery

See Also

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface


ThreadTableQuery Methods

ThreadTableQuery Methods
Summary

The methods of the ThreadTableQuery class are listed here.

Methods
Methods
Name | Description
CreateThreadInfo | Method that creates a new ThreadInfo object that can be used in creating thread features. The object returned is a StandardThreadInfo for parallel threads and TaperedThreadInfo for tapered threads. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments.
GetAvailableClasses | Method that returns all the available classes for a thread type of a given thread designation.
GetAvailableDesignations | Method that returns all the available thread designations for a thread type of a given size.
GetAvailableThreadSizes | Method that returns all the available thread sizes for a given thread type.
GetAvailableThreadTypes | Method that returns all the available thread types (families).
GetThreadTypeIdentifier | Method that returns the non-localized thread type identifier given the localized thread type name
GetThreadTypeName | Method that returns the localized thread type name given the non-localized thread type identifier
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods


ThreadTableQuery.CreateThreadInfo Method

ThreadTableQuery.CreateThreadInfo Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new ThreadInfo object that can be used in creating thread features. The object returned is a StandardThreadInfo for parallel threads and TaperedThreadInfo for tapered threads. See the Thread.xls file that is delivered with Autodesk Inventor for examples of valid input for these arguments.

Visual Basic
Sub CreateThreadInfo(Internal As VARIANT_BOOL, RightHanded As VARIANT_BOOL, ThreadType As String, ThreadDesignation As String, ByRef Class As [defaultvalue("")] BSTR, Result As [out, retval] ThreadInfo*)
Parameters
Parameters | Description
Internal | Input Boolean that indicates if the thread is an internal or external thread. A value of True indicates an Internal thread.
RightHanded | Input Boolean that indicates if the thread is right or left-handed thread. A value of True indicates a right-handed thread.
ThreadType | Input String that specifies the thread type. The thread type is the name of the sheet in the Thread.xls file that is used by the Thread command to define valid thread definitions.
ThreadDesignation | Input String that contains the thread designation. This is input as the full thread designation that will be used in a drawing for the thread callout. The nominal size and pitch information are extracted from the designation. For example valid inch thread designations are '10-24 UNC' and '7/16-20 UNF'. Examples of valid metric designations are 'M16x1.5' and 'M55x1.5'.
Class | Optional input String that defines the thread class. For example a valid class for an inch internal thread is '2B'. A valid class for a metric external thread is '6g'. Null strings are valid for some thread types.
Example

"Creating a ThreadInfo object."

Sub test_threadinfo()
  Dim oApp As Application
  Set oApp = ThisApplication

  Dim oGeneralOptions As GeneralOptions
  Set oGeneralOptions = oApp.GeneralOptions

  Dim oThreadTable As ThreadTableQuery
  Set oThreadTable = oGeneralOptions.ThreadTableQuery

  Dim oTypes() As String
  oTypes = oThreadTable.GetAvailableThreadTypes

  Dim oSizes() As String
  oSizes = oThreadTable.GetAvailableThreadSizes(False, "NPT")

  Dim oDesignations() As String
  oDesignations = oThreadTable.GetAvailableDesignations(False, "NPT", oSizes(1))

  Dim oThreadInfo As TaperedThreadInfo
  Set oThreadInfo = oThreadTable.CreateThreadInfo(False, True, "NPT", oDesignations(0))
End Sub
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.CreateThreadInfo Method


ThreadTableQuery.GetAvailableClasses Method

ThreadTableQuery.GetAvailableClasses Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns all the available classes for a thread type of a given thread designation.

Visual Basic
Sub GetAvailableClasses(Internal As VARIANT_BOOL, ThreadType As String, ThreadDesignation As String, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
Internal | Indicates if the thread is an internal or external thread.
ThreadType | Thread type identifier string.
ThreadDesignation | A string that contains the thread designation. This is the full thread designation that is used in a drawing for the thread callout.
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.GetAvailableClasses Method


ThreadTableQuery.GetAvailableDesignations Method

ThreadTableQuery.GetAvailableDesignations Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns all the available thread designations for a thread type of a given size.

Visual Basic
Sub GetAvailableDesignations(Internal As VARIANT_BOOL, ThreadType As String, NominalSize As String, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
Internal | Indicates if the thread is an internal or external thread.
ThreadType | Thread type identifier string.
NominalSize | The description of the nominal size.
See Also

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.GetAvailableDesignations Method


ThreadTableQuery.GetAvailableThreadSizes Method

ThreadTableQuery.GetAvailableThreadSizes Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns all the available thread sizes for a given thread type.

Visual Basic
Sub GetAvailableThreadSizes(Internal As VARIANT_BOOL, ThreadType As String, Result As [out, retval] SAFEARRAY(BSTR))
Parameters
Parameters | Description
Internal | Indicates if the thread is an internal or external thread.
ThreadType | Thread type identifier string.
See Also

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.GetAvailableThreadSizes Method


ThreadTableQuery.GetAvailableThreadTypes Method

ThreadTableQuery.GetAvailableThreadTypes Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns all the available thread types (families).

Visual Basic
Sub GetAvailableThreadTypes(Result As [out, retval] SAFEARRAY(BSTR))
See Also

Creating a ThreadInfo object sample

You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.GetAvailableThreadTypes Method


ThreadTableQuery.GetThreadTypeIdentifier Method

ThreadTableQuery.GetThreadTypeIdentifier Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that returns the non-localized thread type identifier given the localized thread type name

Visual Basic
Sub GetThreadTypeIdentifier(ThreadTypeName As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
ThreadTypeName | Thread type identifier string.
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.GetThreadTypeIdentifier Method


ThreadTableQuery.GetThreadTypeName Method

ThreadTableQuery.GetThreadTypeName Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that returns the localized thread type name given the non-localized thread type identifier

Visual Basic
Sub GetThreadTypeName(ThreadTypeIdentifier As String, Result As [out, retval] BSTR)
Parameters
Parameters | Description
ThreadTypeIdentifier | The thread type identifier.
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Methods > ThreadTableQuery.GetThreadTypeName Method


ThreadTableQuery Properties

ThreadTableQuery Properties
Summary

The properties of the ThreadTableQuery class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Properties


ThreadTableQuery.Application Property

ThreadTableQuery.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Properties > ThreadTableQuery.Application Property


ThreadTableQuery.Type Property

ThreadTableQuery.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThreadTableQuery Interface > ThreadTableQuery Properties > ThreadTableQuery.Type Property


ThreePlanesWorkPointDef Interface

ThreePlanesWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work point defined by the intersection of three planes.

Class Hierarchy
Inventor::ThreePlanesWorkPointDef
Visual Basic
Public Interface ThreePlanesWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface


ThreePlanesWorkPointDef Methods

ThreePlanesWorkPointDef Methods
Summary

The methods of the ThreePlanesWorkPointDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work point at the intersection of three planes.
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Methods


ThreePlanesWorkPointDef.GetData Method

ThreePlanesWorkPointDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work point at the intersection of three planes.

Visual Basic
Sub GetData(ByRef Plane1 As IDispatch*, ByRef Plane2 As IDispatch*, ByRef Plane3 As IDispatch*)
Parameters
Parameters | Description
Plane1 | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2 | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane3 | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Methods > ThreePlanesWorkPointDef.GetData Method


ThreePlanesWorkPointDef Properties

ThreePlanesWorkPointDef Properties
Summary

The properties of the ThreePlanesWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property returning the parent WorkPoint object.
Plane1 | Property that returns the first plane of a work point that is defined by the intersection of three planes. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2 | Property that returns the second plane of a work point that is defined by the intersection of three planes. This object can be a planar Face, WorkPlane, or Sketch object.
Plane3 | Property that returns the third plane of a work point that is defined by the intersection of three planes. This object can be a planar Face, WorkPlane, or Sketch object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties


ThreePlanesWorkPointDef.Application Property

ThreePlanesWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties > ThreePlanesWorkPointDef.Application Property


ThreePlanesWorkPointDef.Parent Property

ThreePlanesWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties > ThreePlanesWorkPointDef.Parent Property


ThreePlanesWorkPointDef.Plane1 Property

ThreePlanesWorkPointDef.Plane1 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the first plane of a work point that is defined by the intersection of three planes. This object can be a planar Face, WorkPlane, or Sketch object.

Visual Basic
Property Plane1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties > ThreePlanesWorkPointDef.Plane1 Property


ThreePlanesWorkPointDef.Plane2 Property

ThreePlanesWorkPointDef.Plane2 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the second plane of a work point that is defined by the intersection of three planes. This object can be a planar Face, WorkPlane, or Sketch object.

Visual Basic
Property Plane2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties > ThreePlanesWorkPointDef.Plane2 Property


ThreePlanesWorkPointDef.Plane3 Property

ThreePlanesWorkPointDef.Plane3 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the third plane of a work point that is defined by the intersection of three planes. This object can be a planar Face, WorkPlane, or Sketch object.

Visual Basic
Property Plane3() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties > ThreePlanesWorkPointDef.Plane3 Property


ThreePlanesWorkPointDef.Type Property

ThreePlanesWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThreePlanesWorkPointDef Interface > ThreePlanesWorkPointDef Properties > ThreePlanesWorkPointDef.Type Property


ThreePointAngleDimConstraint Interface

ThreePointAngleDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ThreePointAngleDimConstraint object represents a constraint that controls the angle defined by three points.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::ThreePointAngleDimConstraint
        Inventor::ThreePointAngleDimConstraintProxy
Visual Basic
Public Interface ThreePointAngleDimConstraint
Inherits DimensionConstraint
Remarks

The picture below illustrates the use of this constraint.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddThreePointAngle

ThreePointAngleDimConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraint Interface


ThreePointAngleDimConstraint Properties

ThreePointAngleDimConstraint Properties
Summary

The properties of the ThreePointAngleDimConstraint class are listed here.

Properties
Name | Description
PointOne | Property that returns the first sketch point being constrained.
PointThree | Property that returns the third sketch point being constrained.
PointTwo | Property that returns the second sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraint Interface > ThreePointAngleDimConstraint Properties


ThreePointAngleDimConstraint.PointOne Property

ThreePointAngleDimConstraint.PointOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first sketch point being constrained.

Visual Basic
Property PointOne() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraint Interface > ThreePointAngleDimConstraint Properties > ThreePointAngleDimConstraint.PointOne Property


ThreePointAngleDimConstraint.PointThree Property

ThreePointAngleDimConstraint.PointThree Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the third sketch point being constrained.

Visual Basic
Property PointThree() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraint Interface > ThreePointAngleDimConstraint Properties > ThreePointAngleDimConstraint.PointThree Property


ThreePointAngleDimConstraint.PointTwo Property

ThreePointAngleDimConstraint.PointTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second sketch point being constrained.

Visual Basic
Property PointTwo() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraint Interface > ThreePointAngleDimConstraint Properties > ThreePointAngleDimConstraint.PointTwo Property


ThreePointAngleDimConstraintProxy Interface

ThreePointAngleDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the ThreePointAngleDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::ThreePointAngleDimConstraint
        Inventor::ThreePointAngleDimConstraintProxy
Visual Basic
Public Interface ThreePointAngleDimConstraintProxy
Inherits ThreePointAngleDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraintProxy Interface


ThreePointAngleDimConstraintProxy Properties

ThreePointAngleDimConstraintProxy Properties
Summary

The properties of the ThreePointAngleDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraintProxy Interface > ThreePointAngleDimConstraintProxy Properties


ThreePointAngleDimConstraintProxy.ContainingOccurrence Property

ThreePointAngleDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraintProxy Interface > ThreePointAngleDimConstraintProxy Properties > ThreePointAngleDimConstraintProxy.ContainingOccurrence Property


ThreePointAngleDimConstraintProxy.NativeObject Property

ThreePointAngleDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As ThreePointAngleDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > ThreePointAngleDimConstraintProxy Interface > ThreePointAngleDimConstraintProxy Properties > ThreePointAngleDimConstraintProxy.NativeObject Property


ThreePointsWorkPlaneDef Interface

ThreePointsWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane defined by three points.

Class Hierarchy
Inventor::ThreePointsWorkPlaneDef
Visual Basic
Public Interface ThreePointsWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface


ThreePointsWorkPlaneDef Methods

ThreePointsWorkPlaneDef Methods
Summary

The methods of the ThreePointsWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work planed defined by three points. Point1 to Point2 defines the positive X axis and Point3 defines the positive Y direction.
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Methods


ThreePointsWorkPlaneDef.GetData Method

ThreePointsWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work planed defined by three points. Point1 to Point2 defines the positive X axis and Point3 defines the positive Y direction.

Visual Basic
Sub GetData(ByRef Point1 As IDispatch*, ByRef Point2 As IDispatch*, ByRef Point3 As IDispatch*)
Parameters
Parameters | Description
Point1 | Output object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point2 | Output object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point3 | Output object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Methods > ThreePointsWorkPlaneDef.GetData Method


ThreePointsWorkPlaneDef Properties

ThreePointsWorkPlaneDef Properties
Summary

The properties of the ThreePointsWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property returning the parent WorkPlane object.
Point1 | Property that returns the first point of a three point defined work plane. The first point defines the origin of the work plane. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point2 | Property that returns the second point of a three point defined work plane. The second point defines the X-axis in relation to the first point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point3 | Property that returns the third point of a three point defined work plane. The third point defines the positive y-axis direction of the work plane. This object can be a WorkPoint, Vertex, or SketchPoint object.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties


ThreePointsWorkPlaneDef.Application Property

ThreePointsWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties > ThreePointsWorkPlaneDef.Application Property


ThreePointsWorkPlaneDef.Parent Property

ThreePointsWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties > ThreePointsWorkPlaneDef.Parent Property


ThreePointsWorkPlaneDef.Point1 Property

ThreePointsWorkPlaneDef.Point1 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the first point of a three point defined work plane. The first point defines the origin of the work plane. This object can be a WorkPoint, Vertex, or SketchPoint object.

Visual Basic
Property Point1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties > ThreePointsWorkPlaneDef.Point1 Property


ThreePointsWorkPlaneDef.Point2 Property

ThreePointsWorkPlaneDef.Point2 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the second point of a three point defined work plane. The second point defines the X-axis in relation to the first point. This object can be a WorkPoint, Vertex, or SketchPoint object.

Visual Basic
Property Point2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties > ThreePointsWorkPlaneDef.Point2 Property


ThreePointsWorkPlaneDef.Point3 Property

ThreePointsWorkPlaneDef.Point3 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the third point of a three point defined work plane. The third point defines the positive y-axis direction of the work plane. This object can be a WorkPoint, Vertex, or SketchPoint object.

Visual Basic
Property Point3() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties > ThreePointsWorkPlaneDef.Point3 Property


ThreePointsWorkPlaneDef.Type Property

ThreePointsWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ThreePointsWorkPlaneDef Interface > ThreePointsWorkPlaneDef Properties > ThreePointsWorkPlaneDef.Type Property


ThroughAllExtent Interface

ThroughAllExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ThroughAllExtent object provides access to the information that defines the extent for a feature using through all extent.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::ThroughAllExtent
Visual Basic
Public Interface ThroughAllExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > ThroughAllExtent Interface


ThroughAllExtent Properties

ThroughAllExtent Properties
Summary

The properties of the ThroughAllExtent class are listed here.

Properties
Name | Description
Direction | Property that gets and sets the distance direction of the feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
You are here: Symbol Reference > Inventor Library > Objects > ThroughAllExtent Interface > ThroughAllExtent Properties


ThroughAllExtent.Direction Property

ThroughAllExtent.Direction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the distance direction of the feature. Valid input is kPositiveExtentDirection, kNegativeExtentDirection, or kSymmetricExtentDirection. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > ThroughAllExtent Interface > ThroughAllExtent Properties > ThroughAllExtent.Direction Property


TitleBlock Interface

TitleBlock Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TitleBlock object represents the instance of a title block on a sheet.

Class Hierarchy
Inventor::TitleBlock
Visual Basic
Public Interface TitleBlock
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Sheet.TitleBlock

Sheet.AddTitleBlock

See Also

Copying a title block definition sample

Title Block Definition Create and Insert sample

Example

See TitleBlockDefinition for example "Creating and inserting a title block definition"

You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface


TitleBlock Methods

TitleBlock Methods
Summary

The methods of the TitleBlock class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the title block from the sheet.
GetResultText | Method that returns the text that is currently displayed for a specific text box. This is useful for text boxes that use input from other sources to define their content, i.e. properties and prompted text. The string displayed within this text box is returned.
SetPromptResultText | Method that sets the text that was supplied for a specified title block that contains prompted text. The string displayed within this title block is changed.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Methods


TitleBlock.Delete Method

TitleBlock.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the title block from the sheet.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Methods > TitleBlock.Delete Method


TitleBlock.GetResultText Method

TitleBlock.GetResultText Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that returns the text that is currently displayed for a specific text box. This is useful for text boxes that use input from other sources to define their content, i.e. properties and prompted text. The string displayed within this text box is returned.

Visual Basic
Sub GetResultText(DefinitionText As TextBox, Result As [out, retval] BSTR)
Parameters
Parameters | Description
DefinitionText | Input TextBox object from the referenced TitleBlockDefinition object. This text box is used as in index to specify which text box in the instance to return the text for.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Methods > TitleBlock.GetResultText Method


TitleBlock.SetPromptResultText Method

TitleBlock.SetPromptResultText Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that sets the text that was supplied for a specified title block that contains prompted text. The string displayed within this title block is changed.

Visual Basic
Sub SetPromptResultText(DefinitionText As TextBox, NewValue As String)
Parameters
Parameters | Description
DefinitionText | Input TextBox object from the referenced TitleBlockDefinition object. This text box is used to specify which prompted text box to set the text for.
NewValue | Input String that defines the new text to use for the specified prompted text.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Methods > TitleBlock.SetPromptResultText Method


TitleBlock Properties

TitleBlock Properties
Summary

The properties of the TitleBlock class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Definition | Property returning the title block definition object this title block is an instance of.
Location | Property that returns the position of the title block on the sheet.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent sheet object.
Position | Property that returns the position on the sheet where the origin of the title block definition's sketch is positioned.
RangeBox | Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.
Transformation | Property that provides the transform that is applied to display the associated title block definition in the correct location on the sheet. The matrix defines the sheet to title block transform.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties


TitleBlock.Application Property

TitleBlock.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Application Property


TitleBlock.Definition Property

TitleBlock.Definition Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the title block definition object this title block is an instance of.

Visual Basic
Property Definition() As TitleBlockDefinition**
See Also

Copying a title block definition sample

You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Definition Property


TitleBlock.Location Property

TitleBlock.Location Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the position of the title block on the sheet.

Visual Basic
Property Location() As TitleBlockLocationEnum*
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Location Property


TitleBlock.Name Property

TitleBlock.Name Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Name Property


TitleBlock.Parent Property

TitleBlock.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the parent sheet object.

Visual Basic
Property Parent() As Sheet**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Parent Property


TitleBlock.Position Property

TitleBlock.Position Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the position on the sheet where the origin of the title block definition's sketch is positioned.

Visual Basic
Property Position() As Point2d**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Position Property


TitleBlock.RangeBox Property

TitleBlock.RangeBox Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns a Box or Box2D object which contains the opposing points of a rectangular box that is guaranteed to enclose this object, objects or feature.

Visual Basic
Property RangeBox() As Box2d**
Remarks

In most cases, the fit will be tight, but in some circumstances there may be some margin.

Example

See the ClientGraphics object for the example "Using client graphics to draw the rangebox".

You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.RangeBox Property


TitleBlock.Transformation Property

TitleBlock.Transformation Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that provides the transform that is applied to display the associated title block definition in the correct location on the sheet. The matrix defines the sheet to title block transform.

Visual Basic
Property Transformation() As Matrix2d**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Transformation Property


TitleBlock.Type Property

TitleBlock.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TitleBlock Interface > TitleBlock Properties > TitleBlock.Type Property


TitleBlockDefinition Interface

TitleBlockDefinition Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TitleBlockDefinition object represents a title block definition.

Class Hierarchy
Inventor::TitleBlockDefinition
Visual Basic
Public Interface TitleBlockDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetFormat.ReferencedTitleBlockDefinition

TitleBlock.Definition

TitleBlockDefinition.CopyTo

TitleBlockDefinitions.Add

TitleBlockDefinitions.Item

See Also

Copying a title block definition sample

Example

"Title Block Definition Create & Insert Example "

This sample illustrates creating a new title block definition object and inserting it into the active sheet. This sample consists of two subs. The first demonstrates the creation of a title block definition and the second inserts it into the active sheet. To run the sample have a drawing document open and run the CreateTitleBlockDefinition Sub. After this you can run the InsertTitleBlockOnSheet to insert the title block into the active sheet.

Public Sub CreateTitleBlockDefinition()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Create the new title block defintion.
    Dim oTitleBlockDef As TitleBlockDefinition
    Set oTitleBlockDef = oDrawDoc.TitleBlockDefinitions.Add("Sample Title Block")

    ' Open the title block definition's sketch for edit.  This is done by calling the Edit
    ' method of the TitleBlockDefinition to obtain a DrawingSketch.  This actually creates
    ' a copy of the title block definition's and opens it for edit.
    Dim oSketch As DrawingSketch
    Call oTitleBlockDef.Edit(oSketch)

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Use the functionality of the sketch to add title block graphics.
    Call oSketch.SketchLines.AddAsTwoPointRectangle(oTG.CreatePoint2d(0, 0), oTG.CreatePoint2d(9, 3))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 1.5), oTG.CreatePoint2d(9, 1.5))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 2.25), oTG.CreatePoint2d(9, 2.25))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(4.5, 1.5), oTG.CreatePoint2d(4.5, 2.25))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(3, 2.25), oTG.CreatePoint2d(3, 3))
    Call oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(6, 2.25), oTG.CreatePoint2d(6, 3))

    ' Add some static text to the title block.
    Dim sText As String
    sText = "TITLE BLOCK"
    Dim oTextBox As TextBox
    Set oTextBox = oSketch.TextBoxes.AddFitted(oTG.CreatePoint2d(4.5, 0.75), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

    sText = "Static Text"
    Set oTextBox = oSketch.TextBoxes.AddByRectangle(oTG.CreatePoint2d(0, 1.5), oTG.CreatePoint2d(4.5, 2.25), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

    ' Add some prompted text fields.
    sText = "<Prompt>Enter text 1</Prompt>"
    Set oTextBox = oSketch.TextBoxes.AddByRectangle(oTG.CreatePoint2d(4.5, 1.5), oTG.CreatePoint2d(9, 2.25), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

     sText = "<Prompt>Enter text 2</Prompt>"
    Set oTextBox = oSketch.TextBoxes.AddByRectangle(oTG.CreatePoint2d(0, 2.25), oTG.CreatePoint2d(3, 3), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

    ' Add some property text.
    ' Add the property value of Author from the drawing
    sText = "<Property Document='drawing' FormatID='{F29F85E0-4FF9-1068-AB91-08002B27B3D9}' PropertyID='4' />"
    Set oTextBox = oSketch.TextBoxes.AddByRectangle(oTG.CreatePoint2d(3, 2.25), oTG.CreatePoint2d(6, 3), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

    ' Add the property value of Subject from the drawing
    sText = "<Property Document='drawing' FormatID='{F29F85E0-4FF9-1068-AB91-08002B27B3D9}' PropertyID='3' />"
    Set oTextBox = oSketch.TextBoxes.AddByRectangle(oTG.CreatePoint2d(6, 2.25), oTG.CreatePoint2d(9, 3), sText)
    oTextBox.VerticalJustification = kAlignTextMiddle
    oTextBox.HorizontalJustification = kAlignTextCenter

    Call oTitleBlockDef.ExitEdit(True)
End Sub

Public Sub InsertTitleBlockOnSheet()
    ' Set a reference to the drawing document.
    ' This assumes a drawing document is active.
    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    ' Obtain a reference to the desired border defintion.
    Dim oTitleBlockDef As TitleBlockDefinition
    Set oTitleBlockDef = oDrawDoc.TitleBlockDefinitions.Item("Sample Title Block")

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

    ' Check to see if the sheet already has a title block and delete it if it does.
    If Not oSheet.TitleBlock Is Nothing Then
        oSheet.TitleBlock.Delete
    End If

    ' This title block definition contains one prompted string input.  An array
    ' must be input that contains the strings for the prompted strings.
    Dim sPromptStrings(1 To 2) As String
    sPromptStrings(1) = "String 1"
    sPromptStrings(2) = "String 2"

    ' Add an instance of the title block definition to the sheet.
    Dim oTitleBlock As TitleBlock
    Set oTitleBlock = oSheet.AddTitleBlock(oTitleBlockDef, , sPromptStrings)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface


TitleBlockDefinition Methods

TitleBlockDefinition Methods
Summary

The methods of the TitleBlockDefinition class are listed here.

Methods
Methods
Name | Description
CopyTo | Method that copies the definition to the target drawing document.
Delete | Method that deletes the TitleBlockDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.
Edit | Method that opens a copy of the title block definition's sketch for edit in the Sketch environment.
ExitEdit | Method that closes the currently active sketch (see below for limitations) and depending on the input parameters, replaces the sketch of the title block definition with the edited sketch.
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Methods


TitleBlockDefinition.CopyTo Method

TitleBlockDefinition.CopyTo Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that copies the definition to the target drawing document.

Visual Basic
Sub CopyTo(TargetDocument As DrawingDocument, ByRef ReplaceExisting As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] TitleBlockDefinition*)
Parameters
Parameters | Description
TargetDocument | Input DrawingDocument object that specifies the document to copy the definition into.
ReplaceExisting | Optional input Boolean that specifies whether to replace or create a new definition with a different name if a definition of the same name exists in the target document. If not specified, the argument defaults to False indicating that a new definition will be created.
Example

"Copying a title block definition."

This sample demonstrates copying a title block definition from one drawing to another and replacing the existing title blocks in the drawing with the new title block.

Before running this sample, have the drawing document open with a sheet active that contains the title block you want to copy. Also, change the path of the new document (oNewDocument) to point to a drawing document in which you want the titleblocks changed.

Public Sub TitleBlockCopy()

    Dim oSourceDocument As DrawingDocument
    Set oSourceDocument = ThisApplication.ActiveDocument

    ' Open the new drawing to copy the title block into.
    Dim oNewDocument As DrawingDocument
    Set oNewDocument = ThisApplication.Documents.Open("C:\temp\TitleBlockChange.idw")

    ' Get the new source title block definition.
    Dim oSourceTitleBlockDef As TitleBlockDefinition
    Set oSourceTitleBlockDef = oSourceDocument.ActiveSheet.TitleBlock.Definition

    ' Get the new title block definition.
    Dim oNewTitleBlockDef As TitleBlockDefinition
    Set oNewTitleBlockDef = oSourceTitleBlockDef.CopyTo(oNewDocument)

    ' Iterate through the sheets.
    Dim oSheet As Sheet
    For Each oSheet In oNewDocument.Sheets
        oSheet.Activate

        oSheet.TitleBlock.Delete
        Call oSheet.AddTitleBlock(oNewTitleBlockDef)
    Next
End Sub
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Methods > TitleBlockDefinition.CopyTo Method


TitleBlockDefinition.Delete Method

TitleBlockDefinition.Delete Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that deletes the TitleBlockDefinition object. This method will fail in the case where the definition is being referenced. This can be determined by using the IsReferenced property.

Visual Basic
Sub Delete()
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Methods > TitleBlockDefinition.Delete Method


TitleBlockDefinition.Edit Method

TitleBlockDefinition.Edit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that opens a copy of the title block definition's sketch for edit in the Sketch environment.

Visual Basic
Sub Edit(ByRef Result As DrawingSketch*)
Returns

Output DrawingSketch created by copying the sketch associated with the title block definition.

Remarks

The DrawingSketch returned is a new sketch that Autodesk Inventor creates by copying the sketch associated with the title block definition. The new sketch supports all edit operations. The ExitEdit method of the TitleBlockDefinition object can be used to replace the title block definition's sketch with the new sketch.

See Also

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Methods > TitleBlockDefinition.Edit Method


TitleBlockDefinition.ExitEdit Method

TitleBlockDefinition.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that closes the currently active sketch (see below for limitations) and depending on the input parameters, replaces the sketch of the title block definition with the edited sketch.

Visual Basic
Sub ExitEdit(ByRef SaveChanges As [defaultvalue(-1)] VARIANT_BOOL, ByRef SaveAsName As [optional] VARIANT)
Parameters
Parameters | Description
SaveChanges | Input Boolean that specifies whether to save the changes or not. True indicates to save the changes. Setting this property to False will cause the sketch to close and lose all edits.
SaveAsName | Input String that specifies the name of the new title block definition to create. This argument is used in the case where the SaveChanges argument is True. If not specified, or an empty string is supplied, the edited sketch replaces the sketch associated with the title block definition being edited. If a string is supplied, a new title block definition is created and the edited sketch is used for it. The supplied name must be unique with respect to all other TitleBlockDefinition objects in the document.
Remarks

You can also choose to create a new title block definition using the edited sketch or close the edited sketch without saving any changes. This method is only valid to be called when a sketch associated with a TitleBlockDefinition object has been opened for edit using the Edit method of the TitleBlockDefinition object, otherwise an error will occur.

See Also

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Methods > TitleBlockDefinition.ExitEdit Method


TitleBlockDefinition.GetReferenceKey Method

TitleBlockDefinition.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Methods > TitleBlockDefinition.GetReferenceKey Method


TitleBlockDefinition Properties

TitleBlockDefinition Properties
Summary

The properties of the TitleBlockDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
IsReferenced | Property that specifies if the title block definition is being referenced or not. A title block definition is referenced whenever it is used on a sheet. A referenced title block definition cannot be deleted.
Name | Property that indicates the name of this object or instance.
Parent | Property returning the parent .
Sketch | Property that returns the sketch associated with the title block definition. The DrawingSketch returned by the Sketch property supports all query functionality but cannot be edited. To edit the contents of a title block definition, use the Edit method. This creates a copy of the title block definition's sketch for edit. The ExitEdit method of the TitleBlockDefinition can then be used to save the edited sketch as the title block definition's sketch.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties


TitleBlockDefinition.Application Property

TitleBlockDefinition.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.Application Property


TitleBlockDefinition.AttributeSets Property

TitleBlockDefinition.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.AttributeSets Property


TitleBlockDefinition.IsReferenced Property

TitleBlockDefinition.IsReferenced Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies if the title block definition is being referenced or not. A title block definition is referenced whenever it is used on a sheet. A referenced title block definition cannot be deleted.

Visual Basic
Property IsReferenced() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.IsReferenced Property


TitleBlockDefinition.Name Property

TitleBlockDefinition.Name Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.Name Property


TitleBlockDefinition.Parent Property

TitleBlockDefinition.Parent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning the parent .

Visual Basic
Property Parent() As DrawingDocument**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.Parent Property


TitleBlockDefinition.Sketch Property

TitleBlockDefinition.Sketch Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the sketch associated with the title block definition. The DrawingSketch returned by the Sketch property supports all query functionality but cannot be edited. To edit the contents of a title block definition, use the Edit method. This creates a copy of the title block definition's sketch for edit. The ExitEdit method of the TitleBlockDefinition can then be used to save the edited sketch as the title block definition's sketch.

Visual Basic
Property Sketch() As DrawingSketch**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.Sketch Property


TitleBlockDefinition.Type Property

TitleBlockDefinition.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinition Interface > TitleBlockDefinition Properties > TitleBlockDefinition.Type Property


TitleBlockDefinitions Interface

TitleBlockDefinitions Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TitleBlockDefinitions collection object provides access to all the existing objects in a drawing document and provides methods to create additional title block definitions.

Class Hierarchy
Inventor::TitleBlockDefinitions
Visual Basic
Public Interface TitleBlockDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DrawingDocument.TitleBlockDefinitions

See Also

Title Block Definition Create and Insert sample

Example

See TitleBlockDefinition for example "Creating and inserting a title block definition"

You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface


TitleBlockDefinitions Methods

TitleBlockDefinitions Methods
Summary

The methods of the TitleBlockDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new title block definition. This method will fail in the case where a sketch is currently active. You can check for this case using the ActiveEditObject property of the Application object to see if a sketch is active.
Item | Property that returns the specified TitleBlockDefinition object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Methods


TitleBlockDefinitions.Add Method

TitleBlockDefinitions.Add Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that creates a new title block definition. This method will fail in the case where a sketch is currently active. You can check for this case using the ActiveEditObject property of the Application object to see if a sketch is active.

Visual Basic
Sub Add(Name As String, Result As [out, retval] TitleBlockDefinition*)
Parameters
Parameters | Description
Name | Input String that defines the name of the new title block definition. The name specified must be unique with respect to the other title block definitions in the document. If a unique name is not specified, an error will occur.
See Also

Title Block Definition Create and Insert sample

Example

See TitleBlockDefinition for example "Creating and inserting a title block definition"

You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Methods > TitleBlockDefinitions.Add Method


TitleBlockDefinitions.Item Method

TitleBlockDefinitions.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified TitleBlockDefinition object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] TitleBlockDefinition*)
Parameters
Parameters | Description
index | Input Variant value that specifies the TitleBlockDefinition to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the title block definition's name. If an out of range index or a name of a non-existent title block definition is specified, an error occurs.
See Also

Title Block Definition Create and Insert sample

You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Methods > TitleBlockDefinitions.Item Method


TitleBlockDefinitions Properties

TitleBlockDefinitions Properties
Summary

The properties of the TitleBlockDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Properties


TitleBlockDefinitions.Application Property

TitleBlockDefinitions.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Properties > TitleBlockDefinitions.Application Property


TitleBlockDefinitions.Count Property

TitleBlockDefinitions.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Properties > TitleBlockDefinitions.Count Property


TitleBlockDefinitions.Type Property

TitleBlockDefinitions.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TitleBlockDefinitions Interface > TitleBlockDefinitions Properties > TitleBlockDefinitions.Type Property


ToExtent Interface

ToExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ToExtent object defines the feature extent type where the feature extent is defined up to a specified entity.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::ToExtent
Visual Basic
Public Interface ToExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > ToExtent Interface


ToExtent Properties

ToExtent Properties
Summary

The properties of the ToExtent class are listed here.

Properties
Name | Description
Direction | Property that gets and sets the direction of the feature. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.
ExtendToFace | Property that gets and sets whether the plane defined by the 'to entity' should be extended to contain the extents of the profile.
MinimumSolution | Property that gets and sets whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.
ToEntity | Property that gets and sets the entity that defines the 'to' extents of the feature.
You are here: Symbol Reference > Inventor Library > Objects > ToExtent Interface > ToExtent Properties


ToExtent.Direction Property

ToExtent.Direction Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the direction of the feature. kPositiveExtentDirection defines the offset direction to be in the same direction as the normal of the sketch plane.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > ToExtent Interface > ToExtent Properties > ToExtent.Direction Property


ToExtent.ExtendToFace Property

ToExtent.ExtendToFace Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets whether the plane defined by the 'to entity' should be extended to contain the extents of the profile.

Visual Basic
Property ExtendToFace() As VARIANT_BOOL
Remarks

This property is applicable only if the 'to entity' which is accessible using ToEntity property is a Face. A Boolean value of True or False can be set if this condition is satisfied.

If the entity returned by the ToEntity property does not represent a Face, this argument is not applicable and the property value will be ignored.

You are here: Symbol Reference > Inventor Library > Objects > ToExtent Interface > ToExtent Properties > ToExtent.ExtendToFace Property


ToExtent.MinimumSolution Property

ToExtent.MinimumSolution Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the feature terminates on the nearest valid face when there are multiple options for valid termination faces.

Visual Basic
Property MinimumSolution() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > ToExtent Interface > ToExtent Properties > ToExtent.MinimumSolution Property


ToExtent.ToEntity Property

ToExtent.ToEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the entity that defines the 'to' extents of the feature.

Visual Basic
Property ToEntity() As IDispatch*
Remarks

This can be one of the following types:

  • Planar entity: Face or WorkPlane object.
  • Point entity: Vertex, SketchPoint, SketchPoint3D, WorkPoint or Edge object.

If an Edge object is specified, only its mid-point will be used as input. If other points (e.g. start point or end point) of the edge need to be used as input, they have to be specified using the corresponding Vertex object.

You are here: Symbol Reference > Inventor Library > Objects > ToExtent Interface > ToExtent Properties > ToExtent.ToEntity Property


ToHeightExtent Interface

ToHeightExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The ToHeightExtent is used by the FlangeFeature object when the height extent type is defined as a 'To' extent.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::ToHeightExtent
Visual Basic
Public Interface ToHeightExtent
Inherits PartFeatureExtent
Remarks

This object is obtained from an existing FlangeFeature object whose height is defined by a to extent. The various properties of this object can be used to query and edit an existing flange feature.

You are here: Symbol Reference > Inventor Library > Objects > ToHeightExtent Interface


ToHeightExtent Properties

ToHeightExtent Properties
Summary

The properties of the ToHeightExtent class are listed here.

Properties
Name | Description
Offset | Property that returns the parameter controlling the offset distance of the flange relative to the 'To' point.
ToEntity | Property that gets and sets the entity defining the 'To' extent.
You are here: Symbol Reference > Inventor Library > Objects > ToHeightExtent Interface > ToHeightExtent Properties


ToHeightExtent.Offset Property

ToHeightExtent.Offset Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the offset distance of the flange relative to the 'To' point.

Visual Basic
Property Offset() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > ToHeightExtent Interface > ToHeightExtent Properties > ToHeightExtent.Offset Property


ToHeightExtent.ToEntity Property

ToHeightExtent.ToEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the entity defining the 'To' extent.

Visual Basic
Property ToEntity() As IDispatch**
Remarks

WorkPoint and Vertex objects are valid objects.

You are here: Symbol Reference > Inventor Library > Objects > ToHeightExtent Interface > ToHeightExtent Properties > ToHeightExtent.ToEntity Property


Tolerance Interface

Tolerance Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The Tolerance object represents information about tolerance.

Class Hierarchy
Inventor::Tolerance
Visual Basic
Public Interface Tolerance
Inherits IDispatch
Notes

Members through which this object may be accessed include:

DimensionStyle.Tolerance

DrawingDimension.Tolerance

Parameter.Tolerance

You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface


Tolerance Methods

Tolerance Methods
Summary

The methods of the Tolerance class are listed here.

Methods
Methods
Name | Description
SetToBasic | Sets the type of this tolerance to be a basic type of tolerance (only valid for drawing dimensions).
SetToDefault | Method that sets the tolerance to the default value.
SetToDeviation | Method that sets the type of this tolerance to be a deviation tolerance.
SetToFits | Method that sets the type of this tolerance to be a fits tolerance.
SetToLimits | Method that sets the type of this tolerance to be a limits tolerance.
SetToMax | Sets the type of this tolerance to be a MAX type of tolerance.
SetToMin | Sets the type of this tolerance to be a MIN type of tolerance.
SetToReference | Sets the type of this tolerance to be a reference type of tolerance (only valid for drawing dimensions).
SetToSymmetric | Method that sets the type of this tolerance to be a symmetric tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods


Tolerance.SetToBasic Method

Tolerance.SetToBasic Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets the type of this tolerance to be a basic type of tolerance (only valid for drawing dimensions).

Visual Basic
Sub SetToBasic()
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToBasic Method


Tolerance.SetToDefault Method

Tolerance.SetToDefault Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the tolerance to the default value.

Visual Basic
Sub SetToDefault()
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToDefault Method


Tolerance.SetToDeviation Method

Tolerance.SetToDeviation Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the type of this tolerance to be a deviation tolerance.

Visual Basic
Sub SetToDeviation(UpperTolerance As VARIANT, LowerTolerance As VARIANT)
Parameters
Parameters | Description
UpperTolerance | Input Variant that defines the upper limit of the deviation.
LowerTolerance | Input Variant that defines the lower limit of the deviation.
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToDeviation Method


Tolerance.SetToFits Method

Tolerance.SetToFits Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the type of this tolerance to be a fits tolerance.

Visual Basic
Sub SetToFits(FitsToleranceType As ToleranceTypeEnum, HoleTolerance As String, ShaftTolerance As String)
Parameters
Parameters | Description
FitsToleranceType | Input constant that specifies the type of tolerance.
HoleTolerance | Input String that specifies the tolerance for the hole feature.
ShaftTolerance | Input String that specifies the tolerance for the shaft.
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToFits Method


Tolerance.SetToLimits Method

Tolerance.SetToLimits Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the type of this tolerance to be a limits tolerance.

Visual Basic
Sub SetToLimits(LimitsToleranceType As ToleranceTypeEnum, UpperTolerance As VARIANT, LowerTolerance As VARIANT)
Parameters
Parameters | Description
LimitsToleranceType | constant Indicates the type of limits tolerance.
UpperTolerance | Input Variant that defines the upper limit of the tolerance.
LowerTolerance | Input Variant that defines the lower limit of the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToLimits Method


Tolerance.SetToMax Method

Tolerance.SetToMax Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Sets the type of this tolerance to be a MAX type of tolerance.

Visual Basic
Sub SetToMax()
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToMax Method


Tolerance.SetToMin Method

Tolerance.SetToMin Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Sets the type of this tolerance to be a MIN type of tolerance.

Visual Basic
Sub SetToMin()
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToMin Method


Tolerance.SetToReference Method

Tolerance.SetToReference Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets the type of this tolerance to be a reference type of tolerance (only valid for drawing dimensions).

Visual Basic
Sub SetToReference()
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToReference Method


Tolerance.SetToSymmetric Method

Tolerance.SetToSymmetric Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that sets the type of this tolerance to be a symmetric tolerance.

Visual Basic
Sub SetToSymmetric(Tolerance As VARIANT)
Parameters
Parameters | Description
Tolerance | Input Variant that specifies the tolerance.
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Methods > Tolerance.SetToSymmetric Method


Tolerance Properties

Tolerance Properties
Summary

The properties of the Tolerance class are listed here.

Properties
Name | Description
HoleTolerance | Property that returns a string specifying the hole tolerance.
Lower | Property that returns the lower variation from the nominal value in database units.
Parent | Property that returns the parent object from whom this object can logically be reached.
ShaftTolerance | Property that returns the shaft tolerance.
ToleranceType | Property that returns a constant specifying the tolerance type.
Type | Property returning an enum indicating this object's type.
Upper | Property that returns a constant specifying the upper variation from the nominal value in database units.
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties


Tolerance.HoleTolerance Property

Tolerance.HoleTolerance Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a string specifying the hole tolerance.

Visual Basic
Property HoleTolerance() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.HoleTolerance Property


Tolerance.Lower Property

Tolerance.Lower Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the lower variation from the nominal value in database units.

Visual Basic
Property Lower() As double*
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.Lower Property


Tolerance.Parent Property

Tolerance.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.Parent Property


Tolerance.ShaftTolerance Property

Tolerance.ShaftTolerance Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the shaft tolerance.

Visual Basic
Property ShaftTolerance() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.ShaftTolerance Property


Tolerance.ToleranceType Property

Tolerance.ToleranceType Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a constant specifying the tolerance type.

Visual Basic
Property ToleranceType() As ToleranceTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.ToleranceType Property


Tolerance.Type Property

Tolerance.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.Type Property


Tolerance.Upper Property

Tolerance.Upper Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a constant specifying the upper variation from the nominal value in database units.

Visual Basic
Property Upper() As double*
You are here: Symbol Reference > Inventor Library > Objects > Tolerance Interface > Tolerance Properties > Tolerance.Upper Property


ToNextExtent Interface

ToNextExtent Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The ToNextExtent object provides access to the information that defines the extent for a feature that's extent is determined by extruding up to the closest set of faces that the feature completely intersects.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::ToNextExtent
Visual Basic
Public Interface ToNextExtent
Inherits PartFeatureExtent
You are here: Symbol Reference > Inventor Library > Objects > ToNextExtent Interface


ToNextExtent Properties

ToNextExtent Properties
Summary

The properties of the ToNextExtent class are listed here.

Properties
Name | Description
Direction | Property that gets and sets the direction of the feature. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the extrusion direction to be in the same direction as the normal of the sketch plane.
Terminator | Property that gets and sets the SurfaceBody that specifies the solid or the surface on which to terminate the feature.
You are here: Symbol Reference > Inventor Library > Objects > ToNextExtent Interface > ToNextExtent Properties


ToNextExtent.Direction Property

ToNextExtent.Direction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the direction of the feature. Valid input is kPositiveExtentDirection or kNegativeExtentDirection. kPositiveExtentDirection defines the extrusion direction to be in the same direction as the normal of the sketch plane.

Visual Basic
Property Direction() As PartFeatureExtentDirectionEnum
You are here: Symbol Reference > Inventor Library > Objects > ToNextExtent Interface > ToNextExtent Properties > ToNextExtent.Direction Property


ToNextExtent.Terminator Property

ToNextExtent.Terminator Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets and sets the SurfaceBody that specifies the solid or the surface on which to terminate the feature.

Visual Basic
Property Terminator() As SurfaceBody*
You are here: Symbol Reference > Inventor Library > Objects > ToNextExtent Interface > ToNextExtent Properties > ToNextExtent.Terminator Property


Torus Interface

Torus Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Torus object. The object created is a transient mathematical object and is not displayed graphically.

Class Hierarchy
Inventor::Torus
Visual Basic
Public Interface Torus
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientGeometry.CreateTorus

Face.Geometry

FaceDefinition.SurfaceGeometry

You are here: Symbol Reference > Inventor Library > Objects > Torus Interface


Torus Methods

Torus Methods
Summary

The methods of the Torus class are listed here.

Methods
Methods
Name | Description
GetTorusData | Get the data defining this torus.
PutTorusData | Method that sets the data defining this torus.
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Methods


Torus.GetTorusData Method

Torus.GetTorusData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this torus.

Visual Basic
Sub GetTorusData(ByRef CenterPoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), ByRef MajorRadius As double, ByRef MinorRadius As double)
Parameters
Parameters | Description
CenterPoint | Input/output Double that specifies the center point.
AxisVector | Input/output Double that specifies axis vector.
MajorRadius | Output Double that specifies major radius.
MinorRadius | Output Double that specifies the minor radius.
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Methods > Torus.GetTorusData Method


Torus.PutTorusData Method

Torus.PutTorusData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this torus.

Visual Basic
Sub PutTorusData(ByRef CenterPoint As SAFEARRAY(double), ByRef AxisVector As SAFEARRAY(double), MajorRadius As double, MinorRadius As double)
Parameters
Parameters | Description
CenterPoint | Input/output Double that specifies the center point.
AxisVector | Input/output Double that specifies axis vector.
MajorRadius | Input Double that specifies major radius.
MinorRadius | Input Double that specifies the minor radius.
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Methods > Torus.PutTorusData Method


Torus Properties

Torus Properties
Summary

The properties of the Torus class are listed here.

Properties
Name | Description
AxisVector | Specifies the direction of the axis of the torus.
CenterPoint | Specifies the center of the torus.
Evaluator | Gets the surface evaluator for this torus.
MajorRadius | Specifies the major radius of the torus.
MinorRadius | Specifies the minor radius of the torus.
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Properties


Torus.AxisVector Property

Torus.AxisVector Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the direction of the axis of the torus.

Visual Basic
Property AxisVector() As UnitVector*
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Properties > Torus.AxisVector Property


Torus.CenterPoint Property

Torus.CenterPoint Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the center of the torus.

Visual Basic
Property CenterPoint() As Point*
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Properties > Torus.CenterPoint Property


Torus.Evaluator Property

Torus.Evaluator Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the surface evaluator for this torus.

Visual Basic
Property Evaluator() As SurfaceEvaluator**
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Properties > Torus.Evaluator Property


Torus.MajorRadius Property

Torus.MajorRadius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the major radius of the torus.

Visual Basic
Property MajorRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Properties > Torus.MajorRadius Property


Torus.MinorRadius Property

Torus.MinorRadius Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the minor radius of the torus.

Visual Basic
Property MinorRadius() As double
You are here: Symbol Reference > Inventor Library > Objects > Torus Interface > Torus Properties > Torus.MinorRadius Property


TorusCenterPointWorkPointDef Interface

TorusCenterPointWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Object that allows you to get and set the information that specifies a work point defined to be at the center of a torus.

Class Hierarchy
Inventor::TorusCenterPointWorkPointDef
Visual Basic
Public Interface TorusCenterPointWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > TorusCenterPointWorkPointDef Interface


TorusCenterPointWorkPointDef Properties

TorusCenterPointWorkPointDef Properties
Summary

The properties of the TorusCenterPointWorkPointDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Face | Property that indicates the Face object whose geometry is a torus surface, the center point of which defines the position of the work point.
Parent | Property that returns the parent WorkPoint object.
Type | Property that returns kTorusCenterPointWorkPointDefObject indicating the type of object.
You are here: Symbol Reference > Inventor Library > Objects > TorusCenterPointWorkPointDef Interface > TorusCenterPointWorkPointDef Properties


TorusCenterPointWorkPointDef.Application Property

TorusCenterPointWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TorusCenterPointWorkPointDef Interface > TorusCenterPointWorkPointDef Properties > TorusCenterPointWorkPointDef.Application Property


TorusCenterPointWorkPointDef.Face Property

TorusCenterPointWorkPointDef.Face Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the Face object whose geometry is a torus surface, the center point of which defines the position of the work point.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > TorusCenterPointWorkPointDef Interface > TorusCenterPointWorkPointDef Properties > TorusCenterPointWorkPointDef.Face Property


TorusCenterPointWorkPointDef.Parent Property

TorusCenterPointWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > TorusCenterPointWorkPointDef Interface > TorusCenterPointWorkPointDef Properties > TorusCenterPointWorkPointDef.Parent Property


TorusCenterPointWorkPointDef.Type Property

TorusCenterPointWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns kTorusCenterPointWorkPointDefObject indicating the type of object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TorusCenterPointWorkPointDef Interface > TorusCenterPointWorkPointDef Properties > TorusCenterPointWorkPointDef.Type Property


TorusMidPlaneWorkPlaneDef Interface

TorusMidPlaneWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Object that allows you to get and set the information that specifies a work plane defined to be at the mid-plane of a torus.

Class Hierarchy
Inventor::TorusMidPlaneWorkPlaneDef
Visual Basic
Public Interface TorusMidPlaneWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > TorusMidPlaneWorkPlaneDef Interface


TorusMidPlaneWorkPlaneDef Properties

TorusMidPlaneWorkPlaneDef Properties
Summary

The properties of the TorusMidPlaneWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Face | Property that indicates the Face object whose geometry is a torus surface, the mid-plane of which defines the position of the work plane.
Parent | Property that returns the parent WorkPlane object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TorusMidPlaneWorkPlaneDef Interface > TorusMidPlaneWorkPlaneDef Properties


TorusMidPlaneWorkPlaneDef.Application Property

TorusMidPlaneWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TorusMidPlaneWorkPlaneDef Interface > TorusMidPlaneWorkPlaneDef Properties > TorusMidPlaneWorkPlaneDef.Application Property


TorusMidPlaneWorkPlaneDef.Face Property

TorusMidPlaneWorkPlaneDef.Face Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates the Face object whose geometry is a torus surface, the mid-plane of which defines the position of the work plane.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > TorusMidPlaneWorkPlaneDef Interface > TorusMidPlaneWorkPlaneDef Properties > TorusMidPlaneWorkPlaneDef.Face Property


TorusMidPlaneWorkPlaneDef.Parent Property

TorusMidPlaneWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > TorusMidPlaneWorkPlaneDef Interface > TorusMidPlaneWorkPlaneDef Properties > TorusMidPlaneWorkPlaneDef.Parent Property


TorusMidPlaneWorkPlaneDef.Type Property

TorusMidPlaneWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TorusMidPlaneWorkPlaneDef Interface > TorusMidPlaneWorkPlaneDef Properties > TorusMidPlaneWorkPlaneDef.Type Property


Trail Interface

Trail Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The Trail object represents the path of an occurrence from its initial to the final position in the exploded view as a result of the tweaks applied to it.

Class Hierarchy
Inventor::Trail
Visual Basic
Public Interface Trail
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TrailSegment.Parent

TrailsEnumerator.Item

You are here: Symbol Reference > Inventor Library > Objects > Trail Interface


Trail Methods

Trail Methods
Summary

The methods of the Trail class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
SetVisibility | Method that sets the visibility of the entire trail in the presentation view.
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Methods


Trail.Item Method

Trail.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] TrailSegment*)
Parameters
Parameters | Description
index | Value that specifies the index of the Transaction to return.
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Methods > Trail.Item Method


Trail.SetVisibility Method

Trail.SetVisibility Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that sets the visibility of the entire trail in the presentation view.

Visual Basic
Sub SetVisibility(Visible As VARIANT_BOOL)
Parameters
Parameters | Description
Visible | Specifies whether the input object is visible in the drawing view.
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Methods > Trail.SetVisibility Method


Trail Properties

Trail Properties
Summary

The properties of the Trail class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Properties


Trail.Application Property

Trail.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Properties > Trail.Application Property


Trail.Count Property

Trail.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Properties > Trail.Count Property


Trail.Parent Property

Trail.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As PresentationExplodedView**
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Properties > Trail.Parent Property


Trail.Type Property

Trail.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Trail Interface > Trail Properties > Trail.Type Property


TrailSegment Interface

TrailSegment Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The TrailSegment object represents a portion of a trail created by one particular tweak operation.

Class Hierarchy
Inventor::TrailSegment
Visual Basic
Public Interface TrailSegment
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Trail.Item

You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface


TrailSegment Properties

TrailSegment Properties
Summary

The properties of the TrailSegment class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Geometry | Property that returns the snapshot of the geometry of the trail segment. The object returned can either be a LineSegment or an Arc3d.
Linear | Property that indicates whether the trail segment is linear or circular. The property returns True if the segment is linear.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
Visible | Property that returns whether the TrailSegment is visible.
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties


TrailSegment.Application Property

TrailSegment.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties > TrailSegment.Application Property


TrailSegment.Geometry Property

TrailSegment.Geometry Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the snapshot of the geometry of the trail segment. The object returned can either be a LineSegment or an Arc3d.

Visual Basic
Property Geometry() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties > TrailSegment.Geometry Property


TrailSegment.Linear Property

TrailSegment.Linear Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that indicates whether the trail segment is linear or circular. The property returns True if the segment is linear.

Visual Basic
Property Linear() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties > TrailSegment.Linear Property


TrailSegment.Parent Property

TrailSegment.Parent Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Trail**
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties > TrailSegment.Parent Property


TrailSegment.Type Property

TrailSegment.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties > TrailSegment.Type Property


TrailSegment.Visible Property

TrailSegment.Visible Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns whether the TrailSegment is visible.

Visual Basic
Property Visible() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TrailSegment Interface > TrailSegment Properties > TrailSegment.Visible Property


TrailsEnumerator Interface

TrailsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

Object that enumerates presentation view trails.

Class Hierarchy
Inventor::TrailsEnumerator
Visual Basic
Public Interface TrailsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PresentationExplodedView.Trails

You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface


TrailsEnumerator Methods

TrailsEnumerator Methods
Summary

The methods of the TrailsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface > TrailsEnumerator Methods


TrailsEnumerator.Item Method

TrailsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Trail*)
Parameters
Parameters | Description
index | Value that specifies the index of the Transaction to return.
You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface > TrailsEnumerator Methods > TrailsEnumerator.Item Method


TrailsEnumerator Properties

TrailsEnumerator Properties
Summary

The properties of the TrailsEnumerator class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface > TrailsEnumerator Properties


TrailsEnumerator.Application Property

TrailsEnumerator.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface > TrailsEnumerator Properties > TrailsEnumerator.Application Property


TrailsEnumerator.Count Property

TrailsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface > TrailsEnumerator Properties > TrailsEnumerator.Count Property


TrailsEnumerator.Type Property

TrailsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TrailsEnumerator Interface > TrailsEnumerator Properties > TrailsEnumerator.Type Property


Transaction Interface

Transaction Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Transaction object that stands for a single transaction. See the article in the overviews section.

Class Hierarchy
Inventor::Transaction
Visual Basic
Public Interface Transaction
Inherits IDispatch
Remarks

Do not close any document inside a transaction, even the active one. The exception to this rule is that it is legal to close a document in a transaction when the document was opened in that exact same transaction.

Notes

Members through which this object may be accessed include:

CheckPoint.ContainingTransaction

Transaction.ParentTransaction

TransactionManager.CurrentTransaction

TransactionManager.EndTransaction

TransactionManager.StartGlobalTransaction

TransactionManager.StartTransaction

TransactionManager.StartTransactionForDocumentOpen

TransactionsEnumerator.Item

See Also

Using Inventor's error dialog sample

Using Inventor's error dialog sample

Sketch Lines sample

You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface


Transaction Methods

Transaction Methods
Summary

The methods of the Transaction class are listed here.

Methods
Methods
Name | Description
Abort | Method that aborts this transaction. This method will fail if this transaction is not the current transaction.
End | Method that ends this transaction. This method will fail if this transaction is not the current transaction.
IdentifyForDocumentOpen | Identify the document open transaction. This action should precede the end of document open transaction.
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Methods


Transaction.Abort Method

Transaction.Abort Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that aborts this transaction. This method will fail if this transaction is not the current transaction.

Visual Basic
Sub Abort()
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Methods > Transaction.Abort Method


Transaction.End Method

Transaction.End Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that ends this transaction. This method will fail if this transaction is not the current transaction.

Visual Basic
Sub End()
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Methods > Transaction.End Method


Transaction.IdentifyForDocumentOpen Method

Transaction.IdentifyForDocumentOpen Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Identify the document open transaction. This action should precede the end of document open transaction.

Visual Basic
Sub IdentifyForDocumentOpen(Document As Document)
Parameters
Parameters | Description
Document | The associated with this transaction.
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Methods > Transaction.IdentifyForDocumentOpen Method


Transaction Properties

Transaction Properties
Summary

The properties of the Transaction class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CheckPoints | Gets the enumeration of all of the check points that may be present in this transaction.
ChildTransactions | Gets the enumeration of all of the child transactions that this transaction may contain.
DisplayName | Gets the display name of this transaction.
Document | Gets the affected by this transaction.
HasParentTransaction | Gets the Boolean flag indicating if this transaction is a child of another transaction.
Id | Gets the unique identifier for this transaction.
MergeWithPrevious | Property that gets and sets whether to merge this transaction with the previously committed transaction. When the transaction object is created this property is initialized to False. This property should be set soon after the End method is called.
Parent | Property that returns the parent object from whom this object can logically be reached.
ParentTransaction | Property that returns the parent transaction, if one exists; else returns a NULL pointer.
State | Property that returns a TransactionStateEnum that describes the current state of the transaction.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties


Transaction.Application Property

Transaction.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.Application Property


Transaction.CheckPoints Property

Transaction.CheckPoints Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the enumeration of all of the check points that may be present in this transaction.

Visual Basic
Property CheckPoints() As CheckPointsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.CheckPoints Property


Transaction.ChildTransactions Property

Transaction.ChildTransactions Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the enumeration of all of the child transactions that this transaction may contain.

Visual Basic
Property ChildTransactions() As TransactionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.ChildTransactions Property


Transaction.DisplayName Property

Transaction.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the display name of this transaction.

Visual Basic
Property DisplayName() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.DisplayName Property


Transaction.Document Property

Transaction.Document Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the affected by this transaction.

Visual Basic
Property Document() As Document**
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.Document Property


Transaction.HasParentTransaction Property

Transaction.HasParentTransaction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the Boolean flag indicating if this transaction is a child of another transaction.

Visual Basic
Property HasParentTransaction() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.HasParentTransaction Property


Transaction.Id Property

Transaction.Id Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the unique identifier for this transaction.

Visual Basic
Property Id() As long*
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.Id Property


Transaction.MergeWithPrevious Property

Transaction.MergeWithPrevious Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether to merge this transaction with the previously committed transaction. When the transaction object is created this property is initialized to False. This property should be set soon after the End method is called.

Visual Basic
Property MergeWithPrevious() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.MergeWithPrevious Property


Transaction.Parent Property

Transaction.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As TransactionManager**
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.Parent Property


Transaction.ParentTransaction Property

Transaction.ParentTransaction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent transaction, if one exists; else returns a NULL pointer.

Visual Basic
Property ParentTransaction() As Transaction**
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.ParentTransaction Property


Transaction.State Property

Transaction.State Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that returns a TransactionStateEnum that describes the current state of the transaction.

Visual Basic
Property State() As TransactionStateEnum*
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.State Property


Transaction.Type Property

Transaction.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Transaction Interface > Transaction Properties > Transaction.Type Property


TransactionEvents CoClass

TransactionEvents CoClass Available in Inventor Available in Server Introduced in Inventor 4
Summary

The TransactionEvents object provides notification of events including transaction abort, commit, delete, redo and undo.

Class Hierarchy
Inventor::TransactionEvents
Visual Basic
Public Class TransactionEvents
Remarks

See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > TransactionEvents CoClass


TransactionEventsObject Interface

TransactionEventsObject Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The TransactionEvents object provides notification of events including transaction abort, commit, delete, redo and undo.

Class Hierarchy
Inventor::TransactionEventsObject
Visual Basic
Public Interface TransactionEventsObject
Inherits IDispatch
Remarks

See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsObject Interface


TransactionEventsObject Properties

TransactionEventsObject Properties
Summary

The properties of the TransactionEventsObject class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsObject Interface > TransactionEventsObject Properties


TransactionEventsObject.Application Property

TransactionEventsObject.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsObject Interface > TransactionEventsObject Properties > TransactionEventsObject.Application Property


TransactionEventsObject.Parent Property

TransactionEventsObject.Parent Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As TransactionManager**
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsObject Interface > TransactionEventsObject Properties > TransactionEventsObject.Parent Property


TransactionEventsObject.Type Property

TransactionEventsObject.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsObject Interface > TransactionEventsObject Properties > TransactionEventsObject.Type Property


TransactionEventsSink Interface

TransactionEventsSink Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The TransactionEvents object provides notification of events including transaction abort, commit, delete, redo and undo.

Class Hierarchy
Inventor::TransactionEventsSink
Visual Basic
Public Interface TransactionEventsSink
Inherits IDispatch
Remarks

See the article in the overviews section. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface


TransactionEventsSink Methods

TransactionEventsSink Methods
Summary

The methods of the TransactionEventsSink class are listed here.

Methods
Methods
Name | Description
OnAbort | The OnAbort event notifies the client when a transaction has been aborted.
OnCommit | The OnCommit event notifies the client when a transaction has been committed.
OnDelete | The OnDelete event notifies the client when a transaction has been deleted from the transaction stack.
OnRedo | The OnRedo event notifies the client when a redo operation is being performed.
OnUndo | The OnUndo event notifies a client when an undo operation is being performed.
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface > TransactionEventsSink Methods


TransactionEventsSink.OnAbort Method

TransactionEventsSink.OnAbort Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnAbort event notifies the client when a transaction has been aborted.

Visual Basic
Sub OnAbort(TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum)
Parameters
Parameters | Description
TransactionObject | The Transaction object being aborted. When the BeforeOrAfter argument is kBefore this is the Transaction being aborted and it supports the full functionality of a Transaction object. When the BeforeOrAfter argument is kAfter the Transaction object no longer exists so the object provided by this argument is not functional except to compare its identity to another Transaction object.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
BeforeOrAfter | Input indicating when the event is being fired. Notification is sent before and after the transaction is aborted.
Remarks

An abort can happen in the case where a command has started a transaction and performed operations within that transaction but decides to abort the process rather than commit it.

You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface > TransactionEventsSink Methods > TransactionEventsSink.OnAbort Method


TransactionEventsSink.OnCommit Method

TransactionEventsSink.OnCommit Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnCommit event notifies the client when a transaction has been committed.

Visual Basic
Sub OnCommit(TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
TransactionObject | The Transaction object that is being committed.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
BeforeOrAfter | Input indicating when the event is being fired. Notification is sent before and after the transaction is committed.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
Remarks

A transaction is defined as an operation that the end-user can undo. When a transaction has been committed it means that the operation has been completed and is now on the transaction stack and can be undone. From Inventor 2009, this event no longer supports kEventCanceled.

You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface > TransactionEventsSink Methods > TransactionEventsSink.OnCommit Method


TransactionEventsSink.OnDelete Method

TransactionEventsSink.OnDelete Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnDelete event notifies the client when a transaction has been deleted from the transaction stack.

Visual Basic
Sub OnDelete(TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum)
Parameters
Parameters | Description
TransactionObject | The Transaction object just deleted. When the BeforeOrAfter argument is kAfter the actual Transaction has been deleted and the Transaction object provided is not functional except to have it's identify compared with a previously saved reference to a Transaction object. For example: Private m_oSavedTransaction As Transaction Private Sub oTransActionEvents_OnCommit( ByVal TransactionObject As Transaction, ...) If BeforeOrAfter = kAfter Then ' Somehow determine this is an interesting transaction. If Interesting(TransactionObject) Then ' Save a reference to the object. Set m_oSavedTransaction = TransactionObject End If End If End Sub Private Sub oTransActionEvents_OnDelete( ByVal TransactionObject As Transaction, ...) If BeforeOrAfter = kAfter Then ' Check to see if this is the interesting transaction being deleted. If TransactionObject is m_oSavedTransaction Then ' The transaction was deleted. End If End If End Sub
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
BeforeOrAfter | Input indicating when the event is being fired. Notification is sent only after the transaction is deleted.
Remarks

The transaction stack contains a list of all transactions that can be undone or redone. Transactions are deleted as the result of three things. First, the transaction stack has a fixed number of transactions it can hold, (which is defined in the registry). When the number of transactions goes over this limit, the transactions at the bottom of the stack are deleted. This means they can no longer be undone. The second reason a transaction is deleted is when a transaction is undone and then another transaction is committed. All transactions in the undone state are deleted and can't be redone. The third reason is as a result of a document being closed. Whenever a document is closed the entire transaction stack is cleared. All transactions in the stack will be deleted.

You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface > TransactionEventsSink Methods > TransactionEventsSink.OnDelete Method


TransactionEventsSink.OnRedo Method

TransactionEventsSink.OnRedo Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnRedo event notifies the client when a redo operation is being performed.

Visual Basic
Sub OnRedo(TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
TransactionObject | The Transaction object being redone.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
BeforeOrAfter | Input indicating when the event is being fired. Notification is sent before and after the transaction is redone.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface > TransactionEventsSink Methods > TransactionEventsSink.OnRedo Method


TransactionEventsSink.OnUndo Method

TransactionEventsSink.OnUndo Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

The OnUndo event notifies a client when an undo operation is being performed.

Visual Basic
Sub OnUndo(TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
TransactionObject | The Transaction object being undone.
Context | Input object that can be used to determine the context of why the event fired. No context information is provided for this event.
BeforeOrAfter | Input indicating when the event is being fired. Notification is sent before and after the transaction is undone.
HandlingCode | Output that indicates how you are handling the event. This argument is ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TransactionEventsSink Interface > TransactionEventsSink Methods > TransactionEventsSink.OnUndo Method


TransactionManager Interface

TransactionManager Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The TransactionManager object encapsulates all of the transaction-based functionality. See the article in the overviews section.

Class Hierarchy
Inventor::TransactionManager
Visual Basic
Public Interface TransactionManager
Inherits IDispatch
Remarks

Generally, developers are encouraged to use ChangeProcessors rather than Transactions. They use similar underlying technology, but ChangeProcessors incorporate a number of enhancements and optimizations. Also, future improvements will apply to ChangeProcessors but not necessarily Transactions.

Notes

Members through which this object may be accessed include:

CheckPoint.Parent

Application.TransactionManager

Transaction.Parent

TransactionEventsObject.Parent

See Also

Client graphics texture-based color mapping sample

Using Inventor's error dialog sample

Sketch Lines sample

You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface


TransactionManager Methods

TransactionManager Methods
Summary

The methods of the TransactionManager class are listed here.

Methods
Methods
Name | Description
ClearAllTransactions | Method that clears all the transactions in the committed and undone stacks. After this method is called a user may no longer Undo/Redo until another transaction is committed. This method fails if an identified transaction is in progress.
GoToCheckPoint | Aborts back up to the checkpoint specified.
RedoTransaction | Redoes the transaction following the current (if that had been undone).
SetCheckPoint | Sets a bookmark in the current transaction in progress.
StartTransaction | Starts a new transaction.
StartTransactionForDocumentOpen | Start a transaction that wraps a document open or new document operation.
UndoTransaction | Undoes the current transaction.
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods


TransactionManager.ClearAllTransactions Method

TransactionManager.ClearAllTransactions Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that clears all the transactions in the committed and undone stacks. After this method is called a user may no longer Undo/Redo until another transaction is committed. This method fails if an identified transaction is in progress.

Visual Basic
Sub ClearAllTransactions()
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.ClearAllTransactions Method


TransactionManager.GoToCheckPoint Method

TransactionManager.GoToCheckPoint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Aborts back up to the checkpoint specified.

Visual Basic
Sub GoToCheckPoint(CheckPoint As CheckPoint)
Parameters
Parameters | Description
CheckPoint | Input CheckPoint that specifies the checkpoint to abort back to.
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.GoToCheckPoint Method


TransactionManager.RedoTransaction Method

TransactionManager.RedoTransaction Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Redoes the transaction following the current (if that had been undone).

Visual Basic
Sub RedoTransaction()
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.RedoTransaction Method


TransactionManager.SetCheckPoint Method

TransactionManager.SetCheckPoint Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Sets a bookmark in the current transaction in progress.

Visual Basic
Sub SetCheckPoint(Result As [out, retval] CheckPoint*)
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.SetCheckPoint Method


TransactionManager.StartTransaction Method

TransactionManager.StartTransaction Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Starts a new transaction.

Visual Basic
Sub StartTransaction(ByRef Document As [unique] Document, DisplayName As String, Result As [out, retval] Transaction*)
Parameters
Parameters | Description
Document | Input object in which to start the transaction.
DisplayName | Input String that specifies the human-readable name for the transaction.
See Also

Client graphics texture-based color mapping sample

Using Inventor's error dialog sample

Sketch Lines sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.StartTransaction Method


TransactionManager.StartTransactionForDocumentOpen Method

TransactionManager.StartTransactionForDocumentOpen Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Start a transaction that wraps a document open or new document operation.

Visual Basic
Sub StartTransactionForDocumentOpen(DisplayName As String, Result As [out, retval] Transaction*)
Parameters
Parameters | Description
DisplayName | The display name of this transaction.
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.StartTransactionForDocumentOpen Method


TransactionManager.UndoTransaction Method

TransactionManager.UndoTransaction Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Undoes the current transaction.

Visual Basic
Sub UndoTransaction()
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Methods > TransactionManager.UndoTransaction Method


TransactionManager Properties

TransactionManager Properties
Summary

The properties of the TransactionManager class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
CommittedTransactions | Gets the collection of all committed transactions currently held by the system. These can be undone in reverse sequence.
CurrentTransaction | Gets the current transaction in progress.
Parent | Property that returns the parent object from whom this object can logically be reached.
TransactionEvents | Gets the object that will fire transaction events.
Type | Property returning an enum indicating this object's type.
UndoneTransactions | Gets the collection of all currently undone transactions. These can be redone in forward sequence.
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties


TransactionManager.Application Property

TransactionManager.Application Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.Application Property


TransactionManager.CommittedTransactions Property

TransactionManager.CommittedTransactions Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the collection of all committed transactions currently held by the system. These can be undone in reverse sequence.

Visual Basic
Property CommittedTransactions() As TransactionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.CommittedTransactions Property


TransactionManager.CurrentTransaction Property

TransactionManager.CurrentTransaction Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the current transaction in progress.

Visual Basic
Property CurrentTransaction() As Transaction**
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.CurrentTransaction Property


TransactionManager.Parent Property

TransactionManager.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.Parent Property


TransactionManager.TransactionEvents Property

TransactionManager.TransactionEvents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the object that will fire transaction events.

Visual Basic
Property TransactionEvents() As TransactionEvents**
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.TransactionEvents Property


TransactionManager.Type Property

TransactionManager.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.Type Property


TransactionManager.UndoneTransactions Property

TransactionManager.UndoneTransactions Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the collection of all currently undone transactions. These can be redone in forward sequence.

Visual Basic
Property UndoneTransactions() As TransactionsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > TransactionManager Interface > TransactionManager Properties > TransactionManager.UndoneTransactions Property


TransactionsEnumerator Interface

TransactionsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

Provides access to a list of objects. See the article in the overviews section.

Class Hierarchy
Inventor::TransactionsEnumerator
Visual Basic
Public Interface TransactionsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Transaction.ChildTransactions

TransactionManager.CommittedTransactions

TransactionManager.UndoneTransactions

You are here: Symbol Reference > Inventor Library > Objects > TransactionsEnumerator Interface


TransactionsEnumerator Methods

TransactionsEnumerator Methods
Summary

The methods of the TransactionsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > TransactionsEnumerator Interface > TransactionsEnumerator Methods


TransactionsEnumerator.Item Method

TransactionsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] Transaction*)
Parameters
Parameters | Description
index | Value that specifies the index of the Transaction to return.
You are here: Symbol Reference > Inventor Library > Objects > TransactionsEnumerator Interface > TransactionsEnumerator Methods > TransactionsEnumerator.Item Method


TransactionsEnumerator Properties

TransactionsEnumerator Properties
Summary

The properties of the TransactionsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TransactionsEnumerator Interface > TransactionsEnumerator Properties


TransactionsEnumerator.Count Property

TransactionsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > TransactionsEnumerator Interface > TransactionsEnumerator Properties > TransactionsEnumerator.Count Property


TransactionsEnumerator.Type Property

TransactionsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TransactionsEnumerator Interface > TransactionsEnumerator Properties > TransactionsEnumerator.Type Property


TransientBRep Interface

TransientBRep Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The TransientBRep object is used to create and manipulate B-Rep objects within a transient space.

Class Hierarchy
Inventor::TransientBRep
Visual Basic
Public Interface TransientBRep
Inherits IDispatch
Remarks

B-Rep objects that exist within this transient space are not displayed, saved, or transacted by Inventor. It's used to perform B-Rep calculations outside the user context of Inventor.

Notes

Members through which this object may be accessed include:

Application.TransientBRep

See Also

Create client graphics based on the solid body of the active part sample

Create client graphics based on the solid body of the active part sample

Transient surface body creation sample

Transient solid body creation sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Client graphics from SAT file body sample

Example

"Create primitive BRep"

This sample demonstrates the creation of primitive (solid) BRep.

Public Sub CreateBRep()

    ' Create a new part document, using the default part template.
    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.Documents.Add(kPartDocumentObject, _
                ThisApplication.FileManager.GetTemplateFile(kPartDocumentObject))

    ' Set a reference to the component definition.
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oPartDoc.ComponentDefinition

    ' Set a reference to the TransientBRep object.
    Dim oTransientBRep As TransientBRep
    Set oTransientBRep = ThisApplication.TransientBRep

    ' Create a range box that will define the extents of a block.
    Dim oBox As Box
    Set oBox = ThisApplication.TransientGeometry.CreateBox

    ' Expand in all directions by 1 cm.
    oBox.Expand 1

    ' Create the block.
    Dim oBody As SurfaceBody
    Set oBody = oTransientBRep.CreateSolidBlock(oBox)

    ' Create bottom and top points for a cylinder.
    Dim oBottomPt As Point
    Set oBottomPt = ThisApplication.TransientGeometry.CreatePoint(0, 1, 0)

    Dim oTopPt As Point
    Set oTopPt = ThisApplication.TransientGeometry.CreatePoint(0, 3, 0)

    ' Create the cylinder body.
    Dim oCylinder As SurfaceBody
    Set oCylinder = oTransientBRep.CreateSolidCylinderCone(oBottomPt, oTopPt, 0.5, 0.5, 0.5)

    ' Boolean the bodies; "oBody" will return the result
    Call oTransientBRep.DoBoolean(oBody, oCylinder, kBooleanTypeUnion)

    ' Create a base feature with the result body.
    Dim oBaseFeature As NonParametricBaseFeature
    Set oBaseFeature = oCompDef.Features.NonParametricBaseFeatures.Add(oBody)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface


TransientBRep Methods

TransientBRep Methods
Summary

The methods of the TransientBRep class are listed here.

Methods
Methods
Name | Description
Copy | Method that creates a copy of the input SurfaceBody object.
CreateIntersectionWithPlane | Method that intersects a body with a plane.
CreateSilhouetteCurve | Method that calculates the silhouette curve geometry for a given face as viewed from a given direction.
CreateSolidBlock | Method that creates a solid box.
CreateSolidCylinderCone | Method that create a solid cylinder or cone.
CreateSolidSphere | Method that create a solid sphere.
CreateSolidTorus | Method that creates a solid torus.
CreateSurfaceBodyDefinition | Method that creates a new SurfaceBodyDefinition object.
DeleteFaces | Method that modifies an existing transient surface body by deleting specified faces.
DoBoolean | Method that performs the specified Boolean operation between the blank and tool bodies.
ReadFromFile | Method that creates one or more new SurfaceBody objects based on the content of the input file. A SurfaceBodies collection is returned that can contain one or more SurfaceBody object.
Transform | Method that transforms the input SurfaceBody.
You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods


TransientBRep.Copy Method

TransientBRep.Copy Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a copy of the input SurfaceBody object.

Visual Basic
Sub Copy(Entity As IDispatch, Result As [out, retval] SurfaceBody*)
Remarks

The resulting copy is a transient SurfaceBody.

See Also

Create client graphics based on the solid body of the active part sample

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.Copy Method


TransientBRep.CreateIntersectionWithPlane Method

TransientBRep.CreateIntersectionWithPlane Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that intersects a body with a plane.

Visual Basic
Sub CreateIntersectionWithPlane(Body As SurfaceBody, Plane As Plane, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
Body | Input SurfaceBody to intersect.
Plane | Input Plane that defines the plane to intersect the body with.
Remarks

The returned SurfaceBody is a wire body that contains the intersection curves.

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateIntersectionWithPlane Method


TransientBRep.CreateSilhouetteCurve Method

TransientBRep.CreateSilhouetteCurve Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that calculates the silhouette curve geometry for a given face as viewed from a given direction.

Visual Basic
Sub CreateSilhouetteCurve(Face As Face, ViewDirection As UnitVector, ReturnCoincidentSilhouettes As VARIANT_BOOL, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
Face | Input Face object to calculate the silhouette curve for.
ViewDirection | Input UnitVector that defines the view direction to calculate the silhouette curve relative to. The silhouette curve will lie on the input where the face normal is perpendicular to the view direction.
ReturnCoincidentSilhouettes | Input Boolean that specifies if silhouette curves that are coincident to the edges of the face should be returned or not. If True, these curves will be returned.
Remarks

The result is a SurfaceBody object that will contain one or more Wire objects that represent the silhouette curve(s). This method can return Nothing in the case where there is not a silhouette curve for the specified face.

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateSilhouetteCurve Method


TransientBRep.CreateSolidBlock Method

TransientBRep.CreateSolidBlock Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a solid box.

Visual Basic
Sub CreateSolidBlock(Box As Box, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
Box | Input Box object that defines the size of the solid block.
Remarks

The size is defined by the input Box object. The edges of the resulting solid box are aligned with axes of the model coordinate system.

See Also

Create primitive BRep sample

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateSolidBlock Method


TransientBRep.CreateSolidCylinderCone Method

TransientBRep.CreateSolidCylinderCone Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that create a solid cylinder or cone.

Visual Basic
Sub CreateSolidCylinderCone(BottomPoint As Point, TopPoint As Point, BottomMajorRadius As double, BottomMinorRadius As double, TopMajorRadius As double, ByRef MajorAxisPosition As [optional] VARIANT, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
BottomPoint | Input Point that defines the center of the bottom of the cylinder or cone.
TopPoint | Input Point that defines the center of the top of the cylinder or cone.
BottomMajorRadius | Input Double that defines the major axis radius at the bottom of an elliptical cylinder or cone or the radius at the bottom of a circular cylinder or cone.
BottomMinorRadius | Input Double that define the minor axis radius at the bottom of an elliptical cylinder or cone. For a circular cylinder or cone this value should be the same at the BottomMajorRadius argument.
TopMajorRadius | Input Double that specifies the radius at the top of the cylinder or cone. In the case of an elliptical cylinder or cone this is the radius of the major axis.
MajorAxisPosition | Optional input Point that specifies the orientation of the major axis. This is only needed in the case of an elliptical cylinder or cone. If not provided the major axis is determined based on the model coordinate system.
Remarks

To create a circular cylinder or cone use the same values for the BottomMajorRadius and BottomMinorRadius arguments. To create an elliptical cylinder or cone use two different values. To create a cylinder use the same values for the BottomMajorRadius and TopMajorRadius. To create a cone use different values. When creating elliptical cones or cylinders the orientation of the major axis is defined by the MajorAxisPosition argument. . All values are in centimeters The SurfaceBody containing the cylinder or cone is returned.

See Also

Create primitive BRep sample

Example 1

"Client graphics creation of 3D primitives"

This sample demonstrates the creation of 3D primitives (cylinder, cone, etc.) using client graphics. To use the sample you need to have an assembly or part document open. The program has two behaviors: the first time it is run it will draw the graphics. The second time it is run it deletes the previously drawn graphics.

Public Sub ClientGraphics3DPrimitives()
    Dim oDoc As Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active document.
    ' This assumes that a part or assembly document is active.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Check to see if the test graphics data object already exists.
    ' If it does clean up by removing all associated of the client graphics
    ' from the document. If it doesn't create it.
    On Error Resume Next
    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("Sample3DGraphicsID")
    If Err.Number = 0 Then
        On Error GoTo 0
        ' An existing client graphics object was successfully obtained so clean up.
        oClientGraphics.Delete

        ' update the display to see the results.
        ThisApplication.ActiveView.Update
    Else
        Err.Clear
        On Error GoTo 0

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create the ClientGraphics object.
        Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("Sample3DGraphicsID")

        ' Create a new graphics node within the client graphics objects.
        Dim oSurfacesNode As GraphicsNode
        Set oSurfacesNode = oClientGraphics.AddNode(1)

        Dim oTransientBRep As TransientBRep
        Set oTransientBRep = ThisApplication.TransientBRep

        ' Create a point representing the center of the bottom of the cone
        Dim oBottom As Point
        Set oBottom = ThisApplication.TransientGeometry.CreatePoint(0, 0, 0)

        ' Create a point representing the tip of the cone
        Dim oTop As Point
        Set oTop = ThisApplication.TransientGeometry.CreatePoint(0, 10, 0)

        ' Create a transient cone body
        Dim oBody As SurfaceBody
        Set oBody = oTransientBRep.CreateSolidCylinderCone(oBottom, oTop, 5, 5, 0)

        ' Reset the top point indicating the center of the top of the cylinder
        Set oTop = ThisApplication.TransientGeometry.CreatePoint(0, -40, 0)

        ' Create a transient cylinder body
        Dim oCylBody As SurfaceBody
        Set oCylBody = oTransientBRep.CreateSolidCylinderCone(oBottom, oTop, 2.5, 2.5, 2.5)

        ' Union the cone and cylinder bodies
        Call oTransientBRep.DoBoolean(oBody, oCylBody, kBooleanTypeUnion)

        ' Create client graphics based on the transient body
        Dim oSurfaceGraphics As SurfaceGraphics
        Set oSurfaceGraphics = oSurfacesNode.AddSurfaceGraphics(oBody)

        ' Update the view to see the resulting curves.
        ThisApplication.ActiveView.Update
    End If
End Sub
Example 2

Create 3D primitives using client graphics example (C#).

This sample demonstrates the creation of 3D primitives (cylinder, cone, etc.) using client graphics. To use the sample you need to have an assembly or part document open. The program has two behaviors: the first time it is run it will draw the graphics. The second time it is run it deletes the previously drawn graphics.

The first line of the C# sample sets the oApp variable to ThisApplication - this should be appropriately changed.

public void ClientGraphics3DPrimitives()
{
    Application oApp = ThisApplication;
    Document oDoc = oApp.ActiveDocument;

    // Set a reference to component definition of the active document.
    // This assumes that a part or assembly document is active.
    Type t = null;
    if (oDoc.DocumentType == DocumentTypeEnum.kPartDocumentObject)
    {
        t = typeof(PartDocument);
    }
    else if (oDoc.DocumentType == DocumentTypeEnum.kAssemblyDocumentObject)
    {
        t = typeof(AssemblyDocument);
    }

    System.Reflection.PropertyInfo pi = t.GetProperty("ComponentDefinition");
    ComponentDefinition oCompDef = (ComponentDefinition)pi.GetValue(oDoc, null);

    // Check to see if the test graphics data object already exists.
    // If it does clean up by removing all associated of the client graphics
    // from the document. If it doesn't create it.
    ClientGraphics oClientGraphics;
    try
    {
        oClientGraphics = oCompDef.ClientGraphicsCollection["Sample3DGraphicsID"];

        // An existing client graphics object was successfully obtained so clean up.
        oClientGraphics.Delete();

        // update the display to see the results.
        oApp.ActiveView.Update();

    }
    catch
    {
        // Set a reference to the transient geometry object for user later.
        TransientGeometry oTransGeom = oApp.TransientGeometry;

        // Create the ClientGraphics object.
        oClientGraphics = oCompDef.ClientGraphicsCollection.Add("Sample3DGraphicsID");

        // Create a new graphics node within the client graphics objects.
        GraphicsNode oSurfacesNode = oClientGraphics.AddNode(1);

        TransientBRep oTransientBRep = oApp.TransientBRep;

        // Create a point representing the center of the bottom of the cone
        Point oBottom = oApp.TransientGeometry.CreatePoint(0, 0, 0);

        // Create a point representing the tip of the cone
        Point oTop = oApp.TransientGeometry.CreatePoint(0, 10, 0);

        // Create a transient cone body
        SurfaceBody oBody = oTransientBRep.CreateSolidCylinderCone(oBottom, oTop, 5, 5, 0, null);

        // Reset the top point indicating the center of the top of the cylinder
        oTop = oApp.TransientGeometry.CreatePoint(0, -40, 0);

        // Create a transient cylinder body
        SurfaceBody oCylBody = oTransientBRep.CreateSolidCylinderCone(oBottom, oTop, 2.5, 2.5, 2.5, null);

        // Union the cone and cylinder bodies
        oTransientBRep.DoBoolean(oBody, oCylBody, BooleanTypeEnum.kBooleanTypeUnion);

        // Create client graphics based on the transient body
        SurfaceGraphics oSurfaceGraphics = oSurfacesNode.AddSurfaceGraphics(oBody);

        // Update the view to see the resulting curves.
        oApp.ActiveView.Update();

    }

}
You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateSolidCylinderCone Method


TransientBRep.CreateSolidSphere Method

TransientBRep.CreateSolidSphere Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that create a solid sphere.

Visual Basic
Sub CreateSolidSphere(Center As Point, Radius As double, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
Center | Input Point that defines the center of the sphere.
Radius | Input Point Double that defines the radius of the sphere in centimeters
Remarks

The SurfaceBody containing the sphere is returned.

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateSolidSphere Method


TransientBRep.CreateSolidTorus Method

TransientBRep.CreateSolidTorus Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a solid torus.

Visual Basic
Sub CreateSolidTorus(Center As Point, MajorRadius As double, MinorRadius As double, Result As [out, retval] SurfaceBody*)
Parameters
Parameters | Description
Center | Input Point that defines the center of the torus.
MajorRadius | Input Double that defines the major radius of the torus in centimeters.
MinorRadius | Input Double that defines the minor radius of the torus in centimeters.
Remarks

The axis of the resulting torus is parallel to the model z-axis.

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateSolidTorus Method


TransientBRep.CreateSurfaceBodyDefinition Method

TransientBRep.CreateSurfaceBodyDefinition Method Introduced in Inventor 2011 Available in Inventor Available in Server
Summary

Method that creates a new SurfaceBodyDefinition object.

Visual Basic
Sub CreateSurfaceBodyDefinition(Result As [out, retval] SurfaceBodyDefinition*)
See Also

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.CreateSurfaceBodyDefinition Method


TransientBRep.DeleteFaces Method

TransientBRep.DeleteFaces Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that modifies an existing transient surface body by deleting specified faces.

Visual Basic
Sub DeleteFaces(Faces As IDispatch, DeleteSpecifiedFaces As VARIANT_BOOL)
Parameters
Parameters | Description
Faces | Input Object to specifies the Face object(s) to either delete or save. This argument can be a single Face object or it can be a FaceCollection to specify more than one face. Depending on the value of the second argument these faces will be deleted or saved in the SurfaceBody. If a FaceCollection is provided as input all of the input faces must exist within the same transient SurfaceBody object.
DeleteSpecifiedFaces | Input Boolean that indicates if the face(s) specified in the Faces argument should be deleted or saved. If True, then the specified face(s) will be deleted from the SurfaceBody. If False, the specified face(s) will be saved and all other faces in the SurfaceBody will be deleted.
Remarks

This method allows you to either delete or save a list of specified faces. If you don't want the original SurfaceBody to be modified you can use the TransientBRep.Copy method to create a copy of the body to use as input.

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.DeleteFaces Method


TransientBRep.DoBoolean Method

TransientBRep.DoBoolean Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that performs the specified Boolean operation between the blank and tool bodies.

Visual Basic
Sub DoBoolean(BlankBody As SurfaceBody, ToolBody As SurfaceBody, BooleanType As BooleanTypeEnum)
Parameters
Parameters | Description
BlankBody | Input/Output SurfaceBody that will be modified as a result.
ToolBody | Input SurfaceBody that is used to operate on the blank body.
BooleanType | Input BooleanTypeEnum that specifies the type of Boolean operation to perform. Valid values are kBooleanTypeDifference, kBooleanTypeUnion, and kBooleanTypeIntersect.
Remarks

If successful, the blank body is modified as a result of the Boolean operation. Because of this the BlankBody must always be a transient SurfaceBody. The toolbody is not modified. This is analogous to a machining operation where you have the blank that is being machined and the tool that removes material.

See Also

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Create primitive BRep sample

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.DoBoolean Method


TransientBRep.ReadFromFile Method

TransientBRep.ReadFromFile Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates one or more new SurfaceBody objects based on the content of the input file. A SurfaceBodies collection is returned that can contain one or more SurfaceBody object.

Visual Basic
Sub ReadFromFile(FileName As String, Result As [out, retval] SurfaceBodies*)
Parameters
Parameters | Description
FileName | Input String that defines the full filename of the file to read in. This can be either a SAT, SAB, or a DWG file that contains solids or surfaces.
You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.ReadFromFile Method


TransientBRep.Transform Method

TransientBRep.Transform Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that transforms the input SurfaceBody.

Visual Basic
Sub Transform(SurfaceBody As SurfaceBody, Transform As Matrix)
Parameters
Parameters | Description
SurfaceBody | Input SurfaceBody object.
Transform | Input Matrix that defines the transform to apply to the input B-Rep entity. This matrix can only define rotations and translations, it cannot define scaling, shearing, or perspective and will fail for these cases.
Remarks

This method is only valid for transient SurfaceBody object.

You are here: Symbol Reference > Inventor Library > Objects > TransientBRep Interface > TransientBRep Methods > TransientBRep.Transform Method


TransientGeometry Interface

TransientGeometry Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object through which all transient geometry objects are constructed. For more information, see the Transient Geometry overview.

Class Hierarchy
Inventor::TransientGeometry
Visual Basic
Public Interface TransientGeometry
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.TransientGeometry

Application.TransientGeometry

See Also

Create and insert a sketch block definition into a part sketch sample

Using Inventor's error dialog sample

Transient surface body creation sample

Transient solid body creation sample

Place content center part sample

Defer sketch updates sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Assembly Move Occurrence sample

OnDrag Event - dragging a WorkPoint sample

OnDrag Event - dragging a WorkPoint sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

Create primitive BRep sample

Title Block Definition Create and Insert sample

Sketch Text Add sample

Sweep Feature Add sample

Add surface texture symbol to dimension sample

SurfaceBody Copy sample

Sketch Spline sample

Spline - create NURBS sample

Sketch Display Entities sample

Create sketch elliptical arc sample

Create SketchedSymbol Definition sample

Sketch Lines sample

Offset a 2D sketch sample

Move sketch entities sample

Projection - project across parts sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Sketch Add Oriented sample

Sketch from face silhouette sample

Creating a parts list sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Is cylindrical face interior or exterior? sample

Derived Parts and Assemblies sample

Add a decal feature sample

Create a drawing Excel Table sample

Create a Configuration Table sample

Create a Bend Table sample

Custom Table - create sample

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

Client Graphics - Draw Range Box sample

Delete Face, Boundary Patch and Stitch features. sample

Creation a balloon sample

Example

Create curve primitives

This sample demonstrates the creation of curve primitives (lines, arcs, circles, etc.) using client graphics. To use the sample you need to have an assembly or part document open. The program has two behaviors: the first time it is run it will draw the graphics. The second time it is run it deletes the previously drawn graphics.

Public Sub ClientGraphicsPrimitives()
    Dim odoc As Document
    Set odoc = ThisApplication.ActiveDocument

    ' Set a reference to component definition of the active document.
    ' This assumes that a part or assembly document is active.
    Dim oCompDef As ComponentDefinition
    Set oCompDef = ThisApplication.ActiveDocument.ComponentDefinition

    ' Check to see if the test graphics data object already exists.
    ' If it does clean up by removing all associated of the client graphics
    ' from the document. If it doesn't create it.
    On Error Resume Next
    Dim oClientGraphics As ClientGraphics
    Set oClientGraphics = oCompDef.ClientGraphicsCollection.Item("SampleGraphicsID")
    If Err.Number = 0 Then
        On Error GoTo 0
        ' An existing client graphics object was successfully obtained so clean up.
        oClientGraphics.Delete

        ' update the display to see the results.
        ThisApplication.ActiveView.Update
    Else
        Err.Clear
        On Error GoTo 0

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create the ClientGraphics object.
        Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("SampleGraphicsID")

        ' Create a new graphics node within the client graphics objects.
        Dim oCurvesNode As GraphicsNode
        Set oCurvesNode = oClientGraphics.AddNode(1)

        Dim oCenter As Point
        Set oCenter = oTransGeom.CreatePoint(1, 1, 0)

        Dim oNormal As UnitVector
        Set oNormal = oTransGeom.CreateUnitVector(0, 0, 1)

        ' Create a transient circle object
        Dim oCircle As Inventor.Circle
        Set oCircle = oTransGeom.CreateCircle(oCenter, oNormal, 1)

        ' Create a circle graphics object within the node.
        Dim oCircleGraphics As CurveGraphics
        Set oCircleGraphics = oCurvesNode.AddCurveGraphics(oCircle)

        Dim oReference As UnitVector
        Set oReference = oTransGeom.CreateUnitVector(-1, 0, 0)

        ' Create a transient arc object
        Dim oArc1 As Arc3d
        Set oArc1 = oTransGeom.CreateArc3d(oCenter, oNormal, oReference, 3, 3.14159 / 4, 3.14159 / 2)

        ' Create an arc graphics object within the node.
        Dim oArcGraphics1 As CurveGraphics
        Set oArcGraphics1 = oCurvesNode.AddCurveGraphics(oArc1)

        ' Create a transient arc object
        Dim oArc2 As Arc3d
        Set oArc2 = oTransGeom.CreateArc3d(oCenter, oNormal, oReference, 3, 3.14159 + (3.14159 / 4), 3.14159 / 2)

        ' Create an arc graphics object within the node.
        Dim oArcGraphics2 As CurveGraphics
        Set oArcGraphics2 = oCurvesNode.AddCurveGraphics(oArc2)

        ' Create a transient line segment object
        Dim oLineSegment1 As LineSegment
        Set oLineSegment1 = oTransGeom.CreateLineSegment(oArc1.StartPoint, oArc2.EndPoint)

        ' Create an line graphics object within the node.
        Dim oLineGraphics1 As CurveGraphics
        Set oLineGraphics1 = oCurvesNode.AddCurveGraphics(oLineSegment1)

        ' Create a transient line segment object
        Dim oLineSegment2 As LineSegment
        Set oLineSegment2 = oTransGeom.CreateLineSegment(oArc2.StartPoint, oArc1.EndPoint)

        ' Create an line graphics object within the node.
        Dim oLineGraphics2 As CurveGraphics
        Set oLineGraphics2 = oCurvesNode.AddCurveGraphics(oLineSegment2)

        ' Update the view to see the resulting curves.
        ThisApplication.ActiveView.Update
    End If
End Sub
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface


TransientGeometry Methods

TransientGeometry Methods
Summary

The methods of the TransientGeometry class are listed here.

Methods
Methods
Name | Description
CreateArc2d | Method that creates a new Arc2d object. The object created is a transient mathematical object and is not displayed graphically.
CreateArc2dByThreePoints | Method that creates a new Arc2d object by three points. The object created is a transient mathematical object and is not displayed graphically.
CreateArc3d | Method that creates a new Arc3d object. The object created is a transient mathematical object and is not displayed graphically.
CreateArc3dByThreePoints | Method that creates a new Arc2d object by three points. The object created is a transient mathematical object and is not displayed graphically.
CreateBox | Method that creates a new Box object. The min and max points of the box are initialized to (0,0,0) . The object created is a transient mathematical object and is not displayed graphically.
CreateBox2d | Method that creates a new Box2d object. The min and max points of the box are initialized to (0,0) . The object created is a transient mathematical object and is not displayed graphically
CreateBSplineCurve | Method that creates a new BSplineCurve object. The definition of the curve is supplied using the input arguments. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.
CreateBSplineCurve2d | Method that creates a new BSplineCurve2d object. The definition of the curve is supplied using the input arguments. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.
CreateBSplineCurve2dDefinition | Method that creates a new BSplineCurve2dDefinition object. This method creates an empty object. Use the methods/properties on this object to populate it and then use it as the argument in the CreateFittedBSplineCurve2d method.
CreateBSplineCurveDefinition | Method that creates a new BSplineCurveDefinition object. This method creates an empty object. Use the methods/properties on this object to populate it and then use it as the argument in the CreateFittedBSplineCurve method.
CreateBSplineSurface | Method that creates a new BSplineSurface object. The definition of the surface is supplied using the input arguments. If an invalid surface is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.
CreateCircle | Method that creates a new 3d Circle object. The object created is a transient mathematical object and is not displayed graphically
CreateCircle2d | Method that creates a new Circle2d object. The object created is a transient mathematical object and is not displayed graphically
CreateCircle2dByThreePoints | Method that creates a new Circle2D object by three points. The object created is a transient mathematical object and is not displayed graphically.
CreateCircleByThreePoints | Method that creates a new Circle object by three points. The object created is a transient mathematical object and is not displayed graphically.
CreateCone | Method that creates a new Cone object. The object created is a transient mathematical object and is not displayed graphically.
CreateCylinder | Method that creates a new Cylinder object. The object created is a transient mathematical object and is not displayed graphically.
CreateEllipseFull | Method that creates a new EllipseFull object. The object created is a transient mathematical object and is not displayed graphically.
CreateEllipseFull2d | Method that creates a new EllipseFull2d object. The object created is a transient mathematical object and is not displayed graphically
CreateEllipticalArc | Method that creates a new EllipticalArc object. The object created is a transient mathematical object and is not displayed graphically
CreateEllipticalArc2d | Method that creates a new EllipticalArc2d object. The object created is a transient mathematical object and is not displayed graphically
CreateEllipticalCone | Method that creates a new EllipticalCone object. The object created is a transient mathematical object and is not displayed graphically
CreateEllipticalCylinder | Method that creates a new EllipticalCylinder object. The object created is a transient mathematical object and is not displayed graphically
CreateFittedBSplineCurve | Method that creates a new object using fit points. The definition of the curve is supplied using the input definition object. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.
CreateFittedBSplineCurve2d | Method that creates a new object using fit points. The definition of the curve is supplied using the input definition object. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.
CreateLine | Method that creates a new Line object. A Line object is infinite. The object created is a transient mathematical object and is not displayed graphically.
CreateLine2d | Method that creates a new Line2d object. A Line2d object is infinite. The object created is a transient mathematical object and is not displayed graphically
CreateLineSegment | Method that creates a new LineSegment object. The object created is a transient mathematical object and is not displayed graphically
CreateLineSegment2d | Method that creates a new LineSegment2d object. The object created is a transient mathematical object and is not displayed graphically
CreateMatrix | Method that creates a new 4x4 Matrix object. The matrix is initialized with an identity matrix.
CreateMatrix2d | Method that creates a new 3x3 Matrix object. The matrix is initialized with an identity matrix.
CreatePlane | Method that creates a new Plane object. A plane object is infinite. The object created is a transient mathematical object and is not displayed graphically.
CreatePlaneByThreePoints | Method that creates a new Plane object by three points. A plane object is infinite. The object created is a transient mathematical object and is not displayed graphically.
CreatePoint | Method that creates a new Point object.
CreatePoint2d | Method that creates a new Point2d object.
CreatePolyline2d | Method that creates a new Polyline2d object. The object created is a transient mathematical object and is not displayed graphically
CreatePolyline2dFromCurve | Method that creates a new Polyline2d object by approximating the input curve within the specified tolerance. The object created is a transient mathematical object and is not displayed graphically.
CreatePolyline3d | Method that creates a new Polyline3d object. The object created is a transient mathematical object and is not displayed graphically
CreatePolyline3dFromCurve | Method that creates a new Polyline3d object by approximating the input curve within the specified tolerance. The object created is a transient mathematical object and is not displayed graphically.
CreateSphere | Method that creates a new Sphere object. The object created is a transient mathematical object and is not displayed graphically
CreateTorus | Method that creates a new Torus object. The object created is a transient mathematical object and is not displayed graphically
CreateUnitVector | Method that creates a new UnitVector object.
CreateUnitVector2d | Method that creates a new UnitVector2d object.
CreateVector | Method that creates a new Vector object.
CreateVector2d | Method that creates a new Vector2d object.
CurveCurveIntersection | This is CurveCurveIntersection, a member of class TransientGeometry.
CurveSurfaceIntersection | This is CurveSurfaceIntersection, a member of class TransientGeometry.
SurfaceSurfaceIntersection | This is SurfaceSurfaceIntersection, a member of class TransientGeometry.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods


TransientGeometry.CreateArc2d Method

TransientGeometry.CreateArc2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new Arc2d object. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateArc2d(Center As Point2d, Radius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] Arc2d*)
Parameters
Parameters | Description
Center | Input Point2d object that specifies the center of the arc. Length units are always centimeters.
Radius | Input Double that specifies the radius of the arc.
StartAngle | Input Double that specifies the start angle of the arc. An angle of 0 is along the positive X axis of the sketch plane.
SweepAngle | Input Double that specifies the sweep angle of the arc. The sweep direction is always counterclockwise.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateArc2d Method


TransientGeometry.CreateArc2dByThreePoints Method

TransientGeometry.CreateArc2dByThreePoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new Arc2d object by three points. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateArc2dByThreePoints(PointOne As Point2d, PointTwo As Point2d, PointThree As Point2d, Result As [out, retval] Arc2d*)
Parameters
Parameters | Description
PointOne | First of three points.
PointTwo | Second of three points.
PointThree | Third of three points.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateArc2dByThreePoints Method


TransientGeometry.CreateArc3d Method

TransientGeometry.CreateArc3d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new Arc3d object. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateArc3d(Center As Point, Normal As UnitVector, ReferenceVector As UnitVector, Radius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] Arc3d*)
Parameters
Parameters | Description
Center | Input Point object that defines the center of the arc.
Normal | Input UnitVector that specifies the axis of the arc. The direction of this vector will also determine the direction of the start and sweep angles. Their direction is defined using the right-hand rule relative to this vector.
ReferenceVector | Input UnitVector that specifies the zero angle direction the start angle is relative to. Any vector is valid except one that is parallel to the axis vector.
Radius | Input Double that specifies the radius of the arc.
StartAngle | Input Double that specifies the start angle of the arc. An angle of 0 is along the direction specified by the reference vector. The direction of the angle is defined using the right-hand rule around the axis vector.
SweepAngle | Input Double that specifies the sweep angle of the arc. The sweep direction is defined using the right-hand rule around the axis vector.
See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateArc3d Method


TransientGeometry.CreateArc3dByThreePoints Method

TransientGeometry.CreateArc3dByThreePoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new Arc2d object by three points. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateArc3dByThreePoints(PointOne As Point, PointTwo As Point, PointThree As Point, Result As [out, retval] Arc3d*)
Parameters
Parameters | Description
PointOne | First of three points.
PointTwo | Second of three points.
PointThree | Third of three points.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateArc3dByThreePoints Method


TransientGeometry.CreateBox Method

TransientGeometry.CreateBox Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Box object. The min and max points of the box are initialized to (0,0,0) . The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateBox(Result As [out, retval] Box*)
See Also

Create primitive BRep sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBox Method


TransientGeometry.CreateBox2d Method

TransientGeometry.CreateBox2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Box2d object. The min and max points of the box are initialized to (0,0) . The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateBox2d(Result As [out, retval] Box2d*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBox2d Method


TransientGeometry.CreateBSplineCurve Method

TransientGeometry.CreateBSplineCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new BSplineCurve object. The definition of the curve is supplied using the input arguments. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateBSplineCurve(Order As long, ByRef Poles As SAFEARRAY(double), ByRef Knots As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double), IsPeriodic As VARIANT_BOOL, Result As [out, retval] BSplineCurve*)
Parameters
Parameters | Description
Order | Input Long that specifies the order of the curve.
Poles | Input array of Doubles that contains the coordinates of the curve. The array contains sequential X, Y, Z coordinates. The number of poles is inferred by the size of the array.
Knots | Input array of Doubles that contains the knot vectors of the curve.
Weights | Input array of Doubles that contains the weight factor for each pole. If the curve is non-rational this argument is ignored.
IsPeriodic | Input Boolean that specifies if the curve is periodic or not. True if it is periodic False if it is non-periodic.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBSplineCurve Method


TransientGeometry.CreateBSplineCurve2d Method

TransientGeometry.CreateBSplineCurve2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new BSplineCurve2d object. The definition of the curve is supplied using the input arguments. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateBSplineCurve2d(Order As long, ByRef Poles As SAFEARRAY(double), ByRef Knots As SAFEARRAY(double), ByRef Weights As SAFEARRAY(double), IsPeriodic As VARIANT_BOOL, Result As [out, retval] BSplineCurve2d*)
Parameters
Parameters | Description
Order | Output Long that specifies the order of the spline.
Poles | Input/output Double that specifies the poles of the B-Spline.
Knots | Input/output Double that specifies the knots of the B-Spline.
Weights | Input/output Double that specifies the B-spline's weights.
IsPeriodic | Input Boolean that specifies whether the B-Spline curve is periodic.
IsRational | Input Boolean that specifies if the curve is rational or not. True if it is rational False if it is not. If True, the Weights argument must be supplied. If False, the Weights argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBSplineCurve2d Method


TransientGeometry.CreateBSplineCurve2dDefinition Method

TransientGeometry.CreateBSplineCurve2dDefinition Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new BSplineCurve2dDefinition object. This method creates an empty object. Use the methods/properties on this object to populate it and then use it as the argument in the CreateFittedBSplineCurve2d method.

Visual Basic
Sub CreateBSplineCurve2dDefinition(Result As [out, retval] BSplineCurve2dDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBSplineCurve2dDefinition Method


TransientGeometry.CreateBSplineCurveDefinition Method

TransientGeometry.CreateBSplineCurveDefinition Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new BSplineCurveDefinition object. This method creates an empty object. Use the methods/properties on this object to populate it and then use it as the argument in the CreateFittedBSplineCurve method.

Visual Basic
Sub CreateBSplineCurveDefinition(Result As [out, retval] BSplineCurveDefinition*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBSplineCurveDefinition Method


TransientGeometry.CreateBSplineSurface Method

TransientGeometry.CreateBSplineSurface Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new BSplineSurface object. The definition of the surface is supplied using the input arguments. If an invalid surface is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateBSplineSurface(Order As SAFEARRAY(long), Poles As SAFEARRAY(double), KnotsU As SAFEARRAY(double), KnotsV As SAFEARRAY(double), Weights As SAFEARRAY(double), IsPeriodic As SAFEARRAY(VARIANT_BOOL), Result As [out, retval] BSplineSurface*)
Parameters
Parameters | Description
Order | Input array of Longs that specifies the order of the surface in the U and V directions. The size of this array should be 2.
Poles | Input array of Doubles that contains the coordinates of the surface. The array contains X, Y, Z coordinates of each pole. The first row of poles along the U direction are specified, then stepping in the V direction the next row of poles along the U direction are specified. The size of this array should be U Pole Count * V Pole Count * 3.
KnotsU | Input array of Doubles that contains the knot vectors along the U direction of the surface.
KnotsV | Input array of Doubles that contains the knot vectors along the V direction of the surface.
Weights | Input array of Doubles that contains the weight factor for each pole for a rational surface. The weights for the first row of poles along the U direction are specified, then stepping in the V direction the weights for the next row of poles along the U direction are specified.
IsPeriodic | Input array of Booleans that specifies if the surface is periodic in the U and V directions. True if it is periodic False if it is non-periodic. The size of this array should be 2.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateBSplineSurface Method


TransientGeometry.CreateCircle Method

TransientGeometry.CreateCircle Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new 3d Circle object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateCircle(Center As Point, Normal As UnitVector, Radius As double, Result As [out, retval] Circle*)
Parameters
Parameters | Description
Center | Input Point object that specifies the center of the arc.
Normal | Input UnitVector that specifies the axis of the circle.
Radius | Input Double that specifies the radius of the circle.
See Also

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateCircle Method


TransientGeometry.CreateCircle2d Method

TransientGeometry.CreateCircle2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Circle2d object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateCircle2d(Center As Point2d, Radius As double, Result As [out, retval] Circle2d*)
Parameters
Parameters | Description
Center | Input Point2d object that specifies the center of the circle.
Radius | Input Double that specifies the radius of the circle.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateCircle2d Method


TransientGeometry.CreateCircle2dByThreePoints Method

TransientGeometry.CreateCircle2dByThreePoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new Circle2D object by three points. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateCircle2dByThreePoints(PointOne As Point2d, PointTwo As Point2d, PointThree As Point2d, Result As [out, retval] Circle2d*)
Parameters
Parameters | Description
PointOne | First of three points.
PointTwo | Second of three points.
PointThree | Third of three points.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateCircle2dByThreePoints Method


TransientGeometry.CreateCircleByThreePoints Method

TransientGeometry.CreateCircleByThreePoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new Circle object by three points. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateCircleByThreePoints(PointOne As Point, PointTwo As Point, PointThree As Point, Result As [out, retval] Circle*)
Parameters
Parameters | Description
PointOne | First of three points.
PointTwo | Second of three points.
PointThree | Third of three points.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateCircleByThreePoints Method


TransientGeometry.CreateCone Method

TransientGeometry.CreateCone Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Cone object. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateCone(RootPoint As Point, Axis As UnitVector, Radius As double, HalfAngle As double, IsExpanding As VARIANT_BOOL, Result As [out, retval] Cone*)
Parameters
Parameters | Description
RootPoint | Input Point object that specifies the base of the cone.
Axis | Input UnitVector object that specifies the direction of the axis of the cone.
Radius | Input Double that specifies the radius of the cone at the base point.
HalfAngle | Input Double that specifies the taper angle of the cone. This is the angle measured from the axis to the side of the cone.
IsExpanding | Input Boolean that if the taper of the cone is expanding outwards or inwards in the direction of the axis vector. If True and the HalfAngle is positive, then the cone is expanding outward along the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateCone Method


TransientGeometry.CreateCylinder Method

TransientGeometry.CreateCylinder Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Cylinder object. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateCylinder(RootPoint As Point, Axis As UnitVector, Radius As double, Result As [out, retval] Cylinder*)
Parameters
Parameters | Description
RootPoint | Input Point object that specifies the base of the cylinder.
Axis | Input UnitVector object that specifies the direction of the axis of the cylinder.
Radius | Input Double that specifies the radius of the cylinder.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateCylinder Method


TransientGeometry.CreateEllipseFull Method

TransientGeometry.CreateEllipseFull Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new EllipseFull object. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateEllipseFull(Center As Point, Normal As UnitVector, MajorAxisVector As Vector, MinorMajorRatio As double, Result As [out, retval] EllipseFull*)
Parameters
Parameters | Description
Center | Input Point object that specifies the center of the ellipse.
Normal | Input UnitVector object that specifies the axis of the ellipse. The axis extends out of the ellipse.
MajorAxisVector | Input Vector object that specifies the direction of the major axis of the ellipse.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateEllipseFull Method


TransientGeometry.CreateEllipseFull2d Method

TransientGeometry.CreateEllipseFull2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new EllipseFull2d object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateEllipseFull2d(Center As Point2d, MajorAxisVector As Vector2d, MinorMajorRatio As double, Result As [out, retval] EllipseFull2d*)
Parameters
Parameters | Description
Center | Input Point2d object that specifies the center of the ellipse.
MajorAxisVector | Input Vector2d object that specifies the direction of the major axis of the ellipse.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the ellipse.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateEllipseFull2d Method


TransientGeometry.CreateEllipticalArc Method

TransientGeometry.CreateEllipticalArc Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new EllipticalArc object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateEllipticalArc(Center As Point, MajorAxis As UnitVector, MinorAxis As UnitVector, MajorRadius As double, MinorRadius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] EllipticalArc*)
Parameters
Parameters | Description
Center | Input Point object that specifies the center of the elliptical arc.
MajorAxis | Input UnitVector object that specifies the direction of the major axis of the elliptical arc.
MinorAxis | Input UnitVector object that specifies the direction of the minor axis of the elliptical arc.
MajorRadius | Input Double that specifies the major radius of the elliptical arc.
MinorRadius | Input Double that specifies the minor radius of the elliptical arc.
StartAngle | Input Double that specifies start angle of the elliptical arc. The start angle is measured from the major axis vector using the right-hand rule about the axis vector.
SweepAngle | Input Double that specifies the sweep angle from the start angle in a direction defined using the right-hand rule about the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateEllipticalArc Method


TransientGeometry.CreateEllipticalArc2d Method

TransientGeometry.CreateEllipticalArc2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new EllipticalArc2d object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateEllipticalArc2d(Center As Point2d, MajorAxis As UnitVector2d, MajorRadius As double, MinorRadius As double, StartAngle As double, SweepAngle As double, Result As [out, retval] EllipticalArc2d*)
Parameters
Parameters | Description
Center | Input Point2d object that specifies the center of the elliptical arc.
MajorAxis | Input UnitVector2d object that specifies the direction of the major axis of the elliptical arc.
MajorRadius | Input Double that specifies the major radius of the elliptical arc.
MinorRadius | Input Double that specifies the minor radius of the elliptical arc.
StartAngle | Input Double that specifies start angle of the elliptical arc. The start angle is measured from the major axis vector.
SweepAngle | Input Double that specifies the sweep angle from the start angle in a counterclockwise direction.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateEllipticalArc2d Method


TransientGeometry.CreateEllipticalCone Method

TransientGeometry.CreateEllipticalCone Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new EllipticalCone object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateEllipticalCone(BasePoint As Point, AxisVector As UnitVector, MajorAxisVector As Vector, MinorMajorRatio As double, HalfAngle As double, IsExpanding As VARIANT_BOOL, Result As [out, retval] EllipticalCone*)
Parameters
Parameters | Description
BasePoint | Input Point object that specifies the base of the elliptical cone.
AxisVector | Input UnitVector object that specifies the direction of the axis of the elliptical cone.
MajorAxisVector | Input Vector object that specifies the direction of the major axis of the elliptical cone.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the elliptical cone.
HalfAngle | Input Double that specifies the taper angle of the elliptical cone. This is the angle measured from the axis to the side of the elliptical cone.
IsExpanding | Input Boolean that if the taper of the elliptical cone is expanding outwards or inwards in the direction of the axis vector. If True and the HalfAngle is positive, then the elliptical cone is expanding outward along the axis vector.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateEllipticalCone Method


TransientGeometry.CreateEllipticalCylinder Method

TransientGeometry.CreateEllipticalCylinder Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new EllipticalCylinder object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateEllipticalCylinder(BasePoint As Point, AxisVector As UnitVector, MajorAxisVector As Vector, MinorMajorRatio As double, Result As [out, retval] EllipticalCylinder*)
Parameters
Parameters | Description
BasePoint | Input Point object that specifies the base of the elliptical cylinder.
AxisVector | Input UnitVector object that specifies the direction of the axis of the elliptical cylinder.
MajorAxisVector | Input Vector object that specifies the direction of the major axis of the elliptical cylinder.
MinorMajorRatio | Input Double that specifies the ratio of the minor and major axes of the elliptical cylinder.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateEllipticalCylinder Method


TransientGeometry.CreateFittedBSplineCurve Method

TransientGeometry.CreateFittedBSplineCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new object using fit points. The definition of the curve is supplied using the input definition object. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateFittedBSplineCurve(Definition As BSplineCurveDefinition, Result As [out, retval] BSplineCurve*)
Parameters
Parameters | Description
Definition | Input BSplineCurveDefinition object that defines the BSpline curve.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateFittedBSplineCurve Method


TransientGeometry.CreateFittedBSplineCurve2d Method

TransientGeometry.CreateFittedBSplineCurve2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that creates a new object using fit points. The definition of the curve is supplied using the input definition object. If an invalid curve is defined the method will fail. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateFittedBSplineCurve2d(Definition As BSplineCurve2dDefinition, Result As [out, retval] BSplineCurve2d*)
Parameters
Parameters | Description
Definition | Input BSplineCurve2dDefinition object that defines the 2d BSpline curve.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateFittedBSplineCurve2d Method


TransientGeometry.CreateLine Method

TransientGeometry.CreateLine Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Line object. A Line object is infinite. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreateLine(RootPoint As Point, Direction As Vector, Result As [out, retval] Line*)
Parameters
Parameters | Description
RootPoint | Input Point object that specifies the root point of the line.
Direction | Input Vector object that specifies the direction of the line.
See Also

Create sheet metal rip feature sample

OnDrag Event - dragging a WorkPoint sample

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateLine Method


TransientGeometry.CreateLine2d Method

TransientGeometry.CreateLine2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Line2d object. A Line2d object is infinite. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateLine2d(RootPoint As Point2d, Direction As UnitVector2d, Result As [out, retval] Line2d*)
Parameters
Parameters | Description
RootPoint | Input Point2d object that specifies the root point of the line.
Direction | Input UnitVector2d object that specifies the direction of the line.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateLine2d Method


TransientGeometry.CreateLineSegment Method

TransientGeometry.CreateLineSegment Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new LineSegment object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateLineSegment(StartPoint As Point, EndPoint As Point, Result As [out, retval] LineSegment*)
Parameters
Parameters | Description
StartPoint | Input Point object that specifies the start point of the line.
EndPoint | Input Point object that specifies the end point of the line.
See Also

Create client graphics based on the solid body of the active part sample

Transient surface body creation sample

Transient solid body creation sample

Create curve primitives sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateLineSegment Method


TransientGeometry.CreateLineSegment2d Method

TransientGeometry.CreateLineSegment2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that creates a new LineSegment2d object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateLineSegment2d(StartPoint As Point2d, EndPoint As Point2d, Result As [out, retval] LineSegment2d*)
Parameters
Parameters | Description
StartPoint | Input Point2d object that specifies the start point of the line.
EndPoint | Input Point2d object that specifies the end point of the line.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateLineSegment2d Method


TransientGeometry.CreateMatrix Method

TransientGeometry.CreateMatrix Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new 4x4 Matrix object. The matrix is initialized with an identity matrix.

Visual Basic
Sub CreateMatrix(Result As [out, retval] Matrix*)
See Also

UCS by transformation matrix sample

Demote occurence sample

Place content center part sample

SurfaceBody Copy sample

iMate Result Creation sample

Derived Parts and Assemblies sample

Create assembly occurrence with representations sample

iMate Creation During Occurrence Placement sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateMatrix Method


TransientGeometry.CreateMatrix2d Method

TransientGeometry.CreateMatrix2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new 3x3 Matrix object. The matrix is initialized with an identity matrix.

Visual Basic
Sub CreateMatrix2d(Result As [out, retval] Matrix2d*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateMatrix2d Method


TransientGeometry.CreatePlane Method

TransientGeometry.CreatePlane Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Plane object. A plane object is infinite. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreatePlane(RootPoint As Point, Normal As Vector, Result As [out, retval] Plane*)
Parameters
Parameters | Description
RootPoint | Input Point object that specifies a point on the plane.
Normal | Input Vector object that specifies the normal direction of the plane.
See Also

Transient solid body creation sample

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePlane Method


TransientGeometry.CreatePlaneByThreePoints Method

TransientGeometry.CreatePlaneByThreePoints Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new Plane object by three points. A plane object is infinite. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreatePlaneByThreePoints(PointOne As Point, PointTwo As Point, PointThree As Point, Result As [out, retval] Plane*)
Parameters
Parameters | Description
PointOne | First of three points.
PointTwo | Second of three points.
PointThree | Third of three points.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePlaneByThreePoints Method


TransientGeometry.CreatePoint Method

TransientGeometry.CreatePoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Point object.

Visual Basic
Sub CreatePoint(ByRef XCoord As [defaultvalue(0.0)] double, ByRef YCoord As [defaultvalue(0.0)] double, ByRef ZCoord As [defaultvalue(0.0)] double, Result As [out, retval] Point*)
Parameters
Parameters | Description
XCoord | Input Double that specifies the point's X-coordinate.
YCoord | Input Double that specifies the Point's Y-coordinate.
ZCoord | Input Double that specifies the point's Z-coordinate.
See Also

Transient solid body creation sample

Sweep Feature Add sample

SurfaceBody Copy sample

Sketch from face silhouette sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Is cylindrical face interior or exterior? sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePoint Method


TransientGeometry.CreatePoint2d Method

TransientGeometry.CreatePoint2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Point2d object.

Visual Basic
Sub CreatePoint2d(ByRef XCoord As [defaultvalue(0.0)] double, ByRef YCoord As [defaultvalue(0.0)] double, Result As [out, retval] Point2d*)
Parameters
Parameters | Description
XCoord | Input Double that specifies the point's X-coordinate.
YCoord | Input Double that specifies the Point's Y-coordinate.
See Also

Defer sketch updates sample

Sketch Edit Orientation sample

Edit profile of an extrude feature sample

Sweep Feature Add sample

Sketch Spline sample

Spline - create NURBS sample

Create sketch elliptical arc sample

Sketch Lines sample

Offset a 2D sketch sample

Projection - project across parts sample

Create sheet metal face and flange features sample

Create sheet metal face and cut features sample

Sketch Add Oriented sample

Sketch from face silhouette sample

Creating a parts list sample

Extrude feature - create block with pocket (C#) sample

Create and Edit an Extrude Feature with a pocket sample

Finding Bend Extent (Tangent) Edges sample

Derived Parts and Assemblies sample

Add a decal feature sample

Create a drawing Excel Table sample

Create a Configuration Table sample

Create a Bend Table sample

Custom Table - create sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePoint2d Method


TransientGeometry.CreatePolyline2d Method

TransientGeometry.CreatePolyline2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new Polyline2d object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreatePolyline2d(Points As VARIANT, Result As [out, retval] Polyline2d*)
Parameters
Parameters | Description
Points | Input Variant that defines the coordinates of the 2d polyline. Valid input for this argument is an ObjectCollection of Point2d objects or an array of Double values that contains the X, Y values of each coordinate.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePolyline2d Method


TransientGeometry.CreatePolyline2dFromCurve Method

TransientGeometry.CreatePolyline2dFromCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new Polyline2d object by approximating the input curve within the specified tolerance. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreatePolyline2dFromCurve(Curve As IDispatch, Tolerance As double, Result As [out, retval] Polyline2d*)
Parameters
Parameters | Description
Curve | Input transient geometry curve that will be approximated. Valid input for this argument is an Arc2d, BSplineCurve2d, Circle2d, EllipseFull2d, EllipticalArc2d, and LineSegment2d.
Tolerance | Input Double defining the approximation tolerance. This value is in centimeters.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePolyline2dFromCurve Method


TransientGeometry.CreatePolyline3d Method

TransientGeometry.CreatePolyline3d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new Polyline3d object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreatePolyline3d(Points As VARIANT, Result As [out, retval] Polyline3d*)
Parameters
Parameters | Description
Points | Input Variant that defines the coordinates of the polyline. Valid input for this argument is an ObjectCollection of Point objects or an array of Double values that contains the X, Y, Z values of each coordinate.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePolyline3d Method


TransientGeometry.CreatePolyline3dFromCurve Method

TransientGeometry.CreatePolyline3dFromCurve Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new Polyline3d object by approximating the input curve within the specified tolerance. The object created is a transient mathematical object and is not displayed graphically.

Visual Basic
Sub CreatePolyline3dFromCurve(Curve As IDispatch, Tolerance As double, Result As [out, retval] Polyline3d*)
Parameters
Parameters | Description
Curve | Input transient geometry curve that will be approximated. Valid input for this argument is an Arc3d, BSplineCurve, Circle, EllipseFull, EllipticalArc, and LineSegment.
Tolerance | Input Double defining the approximation tolerance. This value is in centimeters.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreatePolyline3dFromCurve Method


TransientGeometry.CreateSphere Method

TransientGeometry.CreateSphere Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Sphere object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateSphere(CenterPoint As Point, Radius As double, Result As [out, retval] Sphere*)
Parameters
Parameters | Description
CenterPoint | Input Point object that specifies the center of the sphere.
Radius | Input Double value that specifies the radius of the sphere.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateSphere Method


TransientGeometry.CreateTorus Method

TransientGeometry.CreateTorus Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Torus object. The object created is a transient mathematical object and is not displayed graphically

Visual Basic
Sub CreateTorus(CenterPoint As Point, AxisVector As UnitVector, MajorRadius As double, MinorRadius As double, Result As [out, retval] Torus*)
Parameters
Parameters | Description
CenterPoint | Input Point object that specifies the center of the torus.
AxisVector | Input UnitVector object that specifies the direction of the axis of the torus.
MajorRadius | Input Double that specifies the major radius of the torus.
MinorRadius | Input Double that specifies the minor radius of the torus.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateTorus Method


TransientGeometry.CreateUnitVector Method

TransientGeometry.CreateUnitVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new UnitVector object.

Visual Basic
Sub CreateUnitVector(ByRef XCoord As [defaultvalue(0.0)] double, ByRef YCoord As [defaultvalue(0.0)] double, ByRef ZCoord As [defaultvalue(1.0)] double, Result As [out, retval] UnitVector*)
Parameters
Parameters | Description
XCoord | Input Double that specifies the UnitVector's X-coordinate.
YCoord | Input Double that specifies the UnitVector's Y-coordinate.
ZCoord | Input Double that specifies the UnitVector's Z-coordinate.
See Also

Create curve primitives sample

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateUnitVector Method


TransientGeometry.CreateUnitVector2d Method

TransientGeometry.CreateUnitVector2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new UnitVector2d object.

Visual Basic
Sub CreateUnitVector2d(ByRef XCoord As [defaultvalue(0.0)] double, ByRef YCoord As [defaultvalue(1.0)] double, Result As [out, retval] UnitVector2d*)
Parameters
Parameters | Description
XCoord | Input Double that specifies the UnitVector's X-coordinate.
YCoord | Input Double that specifies the UnitVector's Y-coordinate.
See Also

Sketch Display Entities sample

Create sketch elliptical arc sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateUnitVector2d Method


TransientGeometry.CreateVector Method

TransientGeometry.CreateVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Vector object.

Visual Basic
Sub CreateVector(ByRef XCoord As [defaultvalue(0.0)] double, ByRef YCoord As [defaultvalue(0.0)] double, ByRef ZCoord As [defaultvalue(0.0)] double, Result As [out, retval] Vector*)
Parameters
Parameters | Description
XCoord | Input Double that specifies the Vector's X-coordinate.
YCoord | Input Double that specifies the Vector's Y-coordinate.
ZCoord | Input Double that specifies the Vector's Z-coordinate.
See Also

Transient solid body creation sample

Assembly Move Occurrence sample

SurfaceBody Copy sample

Is cylindrical face interior or exterior? sample

Add iPart occurrence (C#) sample

Adding iPart occurrences to an assembly sample

Add iAssembly Occurrence (C#) sample

Adding iAssembly occurrences sample

Assembly Add Occurrence (C#) sample

Assembly Add Occurrence sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateVector Method


TransientGeometry.CreateVector2d Method

TransientGeometry.CreateVector2d Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new Vector2d object.

Visual Basic
Sub CreateVector2d(ByRef XCoord As [defaultvalue(0.0)] double, ByRef YCoord As [defaultvalue(0.0)] double, Result As [out, retval] Vector2d*)
Parameters
Parameters | Description
XCoord | Input Double that specifies the Vector's X-coordinate.
YCoord | Input Double that specifies the Vector's Y-coordinate.
See Also

Move sketch entities sample

Copy a sketch sample

You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CreateVector2d Method


TransientGeometry.CurveCurveIntersection Method

TransientGeometry.CurveCurveIntersection Method
Summary

This is CurveCurveIntersection, a member of class TransientGeometry.

Visual Basic
Sub CurveCurveIntersection(CurveOne As IDispatch, CurveTwo As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CurveCurveIntersection Method


TransientGeometry.CurveSurfaceIntersection Method

TransientGeometry.CurveSurfaceIntersection Method
Summary

This is CurveSurfaceIntersection, a member of class TransientGeometry.

Visual Basic
Sub CurveSurfaceIntersection(Curve As IDispatch, Surface As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.CurveSurfaceIntersection Method


TransientGeometry.SurfaceSurfaceIntersection Method

TransientGeometry.SurfaceSurfaceIntersection Method
Summary

This is SurfaceSurfaceIntersection, a member of class TransientGeometry.

Visual Basic
Sub SurfaceSurfaceIntersection(SurfaceOne As IDispatch, SurfaceTwo As IDispatch, ByRef Tolerance As [defaultvalue(0.0)] double, Result As [out, retval] ObjectsEnumerator*)
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Methods > TransientGeometry.SurfaceSurfaceIntersection Method


TransientGeometry Properties

TransientGeometry Properties
Summary

The properties of the TransientGeometry class are listed here.

Properties
Name | Description
PointTolerance | Property that returns the internal tolerance used to compare whether two points are equal. For example, this is the default tolerance value used in the IsEqualTo method on the Point object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Properties


TransientGeometry.PointTolerance Property

TransientGeometry.PointTolerance Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the internal tolerance used to compare whether two points are equal. For example, this is the default tolerance value used in the IsEqualTo method on the Point object.

Visual Basic
Property PointTolerance() As double*
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Properties > TransientGeometry.PointTolerance Property


TransientGeometry.Type Property

TransientGeometry.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TransientGeometry Interface > TransientGeometry Properties > TransientGeometry.Type Property


TransientObjects Interface

TransientObjects Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object through which all general transient objects are constructed.

Class Hierarchy
Inventor::TransientObjects
Visual Basic
Public Interface TransientObjects
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ApprenticeServer.TransientObjects

Application.TransientObjects

See Also

Chain dimensions sets sample

Create a ribbon panel n an existing tab sample

Edit profile of an extrude feature sample

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

Add surface texture symbol to dimension sample

Create sketched symbol and leader sample

Create sheet metal face and flange features sample

Add a punch tool feature sample

Selectively link paramaters sample

Copy a sketch sample

Delete Face, Boundary Patch and Stitch features. sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface


TransientObjects Methods

TransientObjects Methods
Summary

The methods of the TransientObjects class are listed here.

Methods
Methods
Name | Description
CreateCamera | Method that creates a new camera object.
CreateColor | Method to construct a new Color object.
CreateDataMedium | Method that constructs a new DataMedium object.
CreateEdgeCollection | Method creates a new EdgeCollection object. Optionally, the resulting EdgeCollection can be initialized with the contents of an enumerator containing edges that is passed in. Typically, an empty EdgeCollection will be created and populated using the Add method of the EdgeCollection object.
CreateFaceCollection | Constructs a new FaceCollection object. If an ObjectsEnumerator is passed in, the collection starts off containing the enumerated objects.
CreateFileMetadata | Method that creates a new FileMetadata object. The newly created FileMetadata is returned.
CreateNameValueMap | Constructs a new NameValueMap object.
CreateObjectCollection | Constructs a new ObjectCollection object. If an ObjectsEnumerator is passed in, the collection starts off containing the enumerated objects.
CreateObjectCollectionByVariant | Constructs a new ObjectCollectionByVariant object. If an ObjectsEnumeratorByVariant is passed in, the collection starts off containing the enumerated objects.
CreateSignatureString | Constructs a unique signature for a string.
CreateTranslationContext | Constructs a new TranslationContext object, used in TranslatorAddin workflows.
You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods


TransientObjects.CreateCamera Method

TransientObjects.CreateCamera Method Available in Inventor Introduced in Inventor 2012
Summary

Method that creates a new camera object.

Visual Basic
Sub CreateCamera(Result As [out, retval] Camera*)
Remarks

A camera can be attached to a component definition (PartComponentDefinition, AssemblyComponentDefinition, or SheetMetalComponentDefinition) or a Sheet where it can be used to save images of the model or drawing. A camera can also be used as input to the DrawingViews.AddBaseView method to define the orientation of the model in the drawing view.

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateCamera Method


TransientObjects.CreateColor Method

TransientObjects.CreateColor Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method to construct a new Color object.

Visual Basic
Sub CreateColor(Red As BYTE, Green As BYTE, Blue As BYTE, ByRef Opacity As [defaultvalue(1.0)] double, Result As [out, retval] Color*)
Parameters
Parameters | Description
Red | Input Byte that specifies the red component of the color. This value must be between 0 and 255.
Green | Input Byte that specifies the green component of the color. This value must be between 0 and 255.
Blue | Input Byte that specifies the blue component of the color. This value must be between 0 and 255.
Opacity | Optional input Double that specifies the opacity of the color. The opacity is defined using a value between 0 and 1. A value of 0 indicates complete translucency while a value of 1 is completely opaque. If not specified this argument defaults to 1.
See Also

Highlight Feature Faces sample

Creating a HighlightSet sample

Custom Table - create sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateColor Method


TransientObjects.CreateDataMedium Method

TransientObjects.CreateDataMedium Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that constructs a new DataMedium object.

Visual Basic
Sub CreateDataMedium(Result As [out, retval] DataMedium*)
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateDataMedium Method


TransientObjects.CreateEdgeCollection Method

TransientObjects.CreateEdgeCollection Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method creates a new EdgeCollection object. Optionally, the resulting EdgeCollection can be initialized with the contents of an enumerator containing edges that is passed in. Typically, an empty EdgeCollection will be created and populated using the Add method of the EdgeCollection object.

Visual Basic
Sub CreateEdgeCollection(ByRef ObjectsEnumerator As [optional] VARIANT, Result As [out, retval] EdgeCollection*)
Parameters
Parameters | Description
ObjectsEnumerator | Input enumerator object that contains edges. For example, the Edges object returned by the Edges property of a face can be used.
See Also

Creating flange features sample

Create sheet metal rip feature sample

Create sheet metal face and flange features sample

Fillet Feature (Complex) sample

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateEdgeCollection Method


TransientObjects.CreateFaceCollection Method

TransientObjects.CreateFaceCollection Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Constructs a new FaceCollection object. If an ObjectsEnumerator is passed in, the collection starts off containing the enumerated objects.

Visual Basic
Sub CreateFaceCollection(ByRef ObjectsEnumerator As [optional] VARIANT, Result As [out, retval] FaceCollection*)
Parameters
Parameters | Description
ObjectsEnumerator | Optional objects enumerator.
See Also

Delete Face, Boundary Patch and Stitch features. sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateFaceCollection Method


TransientObjects.CreateFileMetadata Method

TransientObjects.CreateFileMetadata Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Method that creates a new FileMetadata object. The newly created FileMetadata is returned.

Visual Basic
Sub CreateFileMetadata(ByRef FullFileName As [optional] VARIANT, Result As [out, retval] FileMetadata*)
Parameters
Parameters | Description
FullFileName | Optional input string object that specifies a full file name (with the extension and the path).
You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateFileMetadata Method


TransientObjects.CreateNameValueMap Method

TransientObjects.CreateNameValueMap Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Constructs a new NameValueMap object.

Visual Basic
Sub CreateNameValueMap(Result As [out, retval] NameValueMap*)
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

Create base view with representations (C#) sample

Create flat pattern drawing view sample

Adding Representation views sample

Create assembly occurrence with representations sample

Creation a balloon sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateNameValueMap Method


TransientObjects.CreateObjectCollection Method

TransientObjects.CreateObjectCollection Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Constructs a new ObjectCollection object. If an ObjectsEnumerator is passed in, the collection starts off containing the enumerated objects.

Visual Basic
Sub CreateObjectCollection(ByRef ObjectsEnumerator As [optional] VARIANT, Result As [out, retval] ObjectCollection*)
Parameters
Parameters | Description
ObjectsEnumerator | Input Variant that contains the enumerated objects to place in the collection.
See Also

Chain dimensions sets sample

Create a ribbon panel n an existing tab sample

Add assembly occurrences to a new folder sample

Baseline dimension sets sample

Edit profile of an extrude feature sample

Add surface texture symbol to dimension sample

Sketch Spline sample

Spline - create NURBS sample

Create sketched symbol and leader sample

Offset a 2D sketch sample

Move sketch entities sample

Add a punch tool feature sample

Finding Bend Extent (Tangent) Edges sample

Selectively link paramaters sample

Copy a sketch sample

Delete Face, Boundary Patch and Stitch features. sample

Creation a balloon sample

Interference Analysis sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateObjectCollection Method


TransientObjects.CreateObjectCollectionByVariant Method

TransientObjects.CreateObjectCollectionByVariant Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Constructs a new ObjectCollectionByVariant object. If an ObjectsEnumeratorByVariant is passed in, the collection starts off containing the enumerated objects.

Visual Basic
Sub CreateObjectCollectionByVariant(ByRef ObjectsEnumeratorByVariant As [optional] VARIANT, Result As [out, retval] ObjectCollectionByVariant*)
Parameters
Parameters | Description
ObjectsEnumeratorByVariant | Input Variant that contains the enumerated objects to place in the collection.
You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateObjectCollectionByVariant Method


TransientObjects.CreateSignatureString Method

TransientObjects.CreateSignatureString Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Constructs a unique signature for a string.

Visual Basic
Sub CreateSignatureString(StringToSign As String, Result As [out, retval] BSTR)
You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateSignatureString Method


TransientObjects.CreateTranslationContext Method

TransientObjects.CreateTranslationContext Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Constructs a new TranslationContext object, used in TranslatorAddin workflows.

Visual Basic
Sub CreateTranslationContext(Result As [out, retval] TranslationContext*)
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > TransientObjects Interface > TransientObjects Methods > TransientObjects.CreateTranslationContext Method


TransitionalConstraint Interface

TransitionalConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

Object that represents a transition assembly constraint.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::TransitionalConstraint
        Inventor::TransitionalConstraintProxy
Visual Basic
Public Interface TransitionalConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

AssemblyConstraint.ConvertToTransitionalConstraint

AssemblyConstraints.AddTransitionalConstraint

TransitionalConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TransitionalConstraint Interface


TransitionalConstraintProxy Interface

TransitionalConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TransitionalConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::TransitionalConstraint
        Inventor::TransitionalConstraintProxy
Visual Basic
Public Interface TransitionalConstraintProxy
Inherits TransitionalConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TransitionalConstraintProxy Interface


TransitionalConstraintProxy Properties

TransitionalConstraintProxy Properties
Summary

The properties of the TransitionalConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TransitionalConstraintProxy Interface > TransitionalConstraintProxy Properties


TransitionalConstraintProxy.ContainingOccurrence Property

TransitionalConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TransitionalConstraintProxy Interface > TransitionalConstraintProxy Properties > TransitionalConstraintProxy.ContainingOccurrence Property


TransitionalConstraintProxy.NativeObject Property

TransitionalConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TransitionalConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TransitionalConstraintProxy Interface > TransitionalConstraintProxy Properties > TransitionalConstraintProxy.NativeObject Property


TranslateTranslateConstraint Interface

TranslateTranslateConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TranslateTranslate assembly motion constraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::TranslateTranslateConstraint
        Inventor::TranslateTranslateConstraintProxy
Visual Basic
Public Interface TranslateTranslateConstraint
Inherits AssemblyConstraint
Notes

Members through which this object may be accessed include:

TranslateTranslateConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraint Interface


TranslateTranslateConstraint Properties

TranslateTranslateConstraint Properties
Summary

The properties of the TranslateTranslateConstraint class are listed here.

Properties
Name | Description
ForwardDirection | Gets/sets the Boolean that defines the sense of translation of the occurrences with respect to each other. True implies constrained in the same direction.
Ratio | Property that returns the Parameter object that controls the ration of translation between the constrained ComponentOccurrences.
You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraint Interface > TranslateTranslateConstraint Properties


TranslateTranslateConstraint.ForwardDirection Property

TranslateTranslateConstraint.ForwardDirection Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets/sets the Boolean that defines the sense of translation of the occurrences with respect to each other. True implies constrained in the same direction.

Visual Basic
Property ForwardDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraint Interface > TranslateTranslateConstraint Properties > TranslateTranslateConstraint.ForwardDirection Property


TranslateTranslateConstraint.Ratio Property

TranslateTranslateConstraint.Ratio Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the Parameter object that controls the ration of translation between the constrained ComponentOccurrences.

Visual Basic
Property Ratio() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraint Interface > TranslateTranslateConstraint Properties > TranslateTranslateConstraint.Ratio Property


TranslateTranslateConstraintProxy Interface

TranslateTranslateConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TranslateTranslateConstraint object.

Class Hierarchy
Inventor::AssemblyConstraint
    Inventor::TranslateTranslateConstraint
        Inventor::TranslateTranslateConstraintProxy
Visual Basic
Public Interface TranslateTranslateConstraintProxy
Inherits TranslateTranslateConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraintProxy Interface


TranslateTranslateConstraintProxy Properties

TranslateTranslateConstraintProxy Properties
Summary

The properties of the TranslateTranslateConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraintProxy Interface > TranslateTranslateConstraintProxy Properties


TranslateTranslateConstraintProxy.ContainingOccurrence Property

TranslateTranslateConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraintProxy Interface > TranslateTranslateConstraintProxy Properties > TranslateTranslateConstraintProxy.ContainingOccurrence Property


TranslateTranslateConstraintProxy.NativeObject Property

TranslateTranslateConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TranslateTranslateConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TranslateTranslateConstraintProxy Interface > TranslateTranslateConstraintProxy Properties > TranslateTranslateConstraintProxy.NativeObject Property


TranslationContext Interface

TranslationContext Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The TranslationContext object is used in TranslatorAddin workflows.

Class Hierarchy
Inventor::TranslationContext
Visual Basic
Public Interface TranslationContext
Inherits IDispatch
Notes

Members through which this object may be accessed include:

TransientObjects.CreateTranslationContext

See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > TranslationContext Interface


TranslationContext Properties

TranslationContext Properties
Summary

The properties of the TranslationContext class are listed here.

Properties
Name | Description
OpenIntoExisting | Specifies the object that is the target of the translation.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TranslationContext Interface > TranslationContext Properties


TranslationContext.OpenIntoExisting Property

TranslationContext.OpenIntoExisting Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the object that is the target of the translation.

Visual Basic
Property OpenIntoExisting() As IDispatch*
You are here: Symbol Reference > Inventor Library > Objects > TranslationContext Interface > TranslationContext Properties > TranslationContext.OpenIntoExisting Property


TranslationContext.Type Property

TranslationContext.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As IOMechanismEnum
You are here: Symbol Reference > Inventor Library > Objects > TranslationContext Interface > TranslationContext Properties > TranslationContext.Type Property


TranslatorAddIn Interface

TranslatorAddIn Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents an Translator AddIn inside Autodesk Inventor.

Class Hierarchy
Inventor::ApplicationAddIn
    Inventor::TranslatorAddIn
Visual Basic
Public Interface TranslatorAddIn
Inherits ApplicationAddIn
Remarks

The code sample demonstrates how to set options by populating the name value map. These tables list additional possible option names and values. The Custom keyword is used for user-defined properties.

Publish_Mode | Enum [Basic/Complete/Custom] | Notes
Publish_Component_Props | bool | Use this to publish ALL component properties
Publish_Mass_Props | bool | Use this to publish ALL mass properties
Publish_All_Component_Props | bool | Same as Publish_Component_Props
Publish_All_Physical_Props | bool | Same as Publish_Mass_Props
Enable_Large_Assembly_Mode | bool | Enables large assembly optimizations (transactions and out of process publishing)
Enable_Measure | bool | DRM protection
Enable_Printing | bool | DRM protection
Enable_Markups | bool | DRM protection (in R12 RTM)
Enable_Markup_Edits | bool | DRM protection (in R12 RTM)
Password_Protect | bool |
Password | string (encrypted?) |
Password_Type | string or enum |
Output_Path | string |
Launch_Viewer | bool |

Publish_3D_Models | bool |  |
Publish_All_Sheets | bool |  |
Include_Sheet_Tables | bool |  |
Sheet_Count | int |  |
Sheets | Sheet1 | Name | string
 |  | 3DModel | bool
 | Sheet2 | Name | string
 |  | 3DModel | bool
 | ... | ... | ...

Override_Sheet_Color | bool
Sheet_Color | int

Publish_Screenshot | bool
Screenshot_DPI | int

Facet_Quality
enum
kLow, kMedium and kHigh

Sheet_Metal_Style_Information | bool
Sheet_Metal_Flat_Pattern | bool
Sheet_Metal_Part | bool

Weldment_Preparation | bool
Weldment_Symbol | bool

BOM_Structured | bool |  |
BOM_Parts_Only | bool |  |
Design_Views | Design_View1 | Name | string
 |  | ... | ...
 | Design_View2 | Name | string
 |  | ... | ...
 | ... | ... | ...
Positional_Representations | Positional_Representation1 | Name | string
 |  | ... | ...
 | Positional_Representation2 | Name | string
 |  | ... | ...
 | ... | ... | ...

Animations | bool |  |
Instructions | bool |  |
Presentations | Presentation1 | Name | string
 |  | ... | ...
 | Presentation2 | Name | string
 |  | ... | ...
 | ... |  |

iAssembly_All_Members | bool |  |
iAssembly_3D_Models | bool |  |
iAssemblies | Member1 | Name | string
 |  | 3DModel | bool
 |  | ... | ...
 | Member2 | Name | string
 |  | 3DModel | bool
 |  | ... | ...
 | ... | ... | ...

iPart_All_Members | bool |  |
iPart_3D_Models | bool |  |
iParts | Member1 | Name | string
 |  | 3DModel | bool
 |  | ... | ...
 | Member2 | Name | string
 |  | 3DModel | bool
 |  | ... | ...
 | ... | ... | ...

Include_Empty_Properties | bool |  |
Properties* | Summary | Title | bool
 | NameValueMap | Subject | bool
 |  | Author | bool
 |  | Manager | bool
 |  | Company | bool
 |  | Catergory | bool
 |  | Keywords | bool
 |  | Comments | bool
 | Project | Part Number | bool
 | NameValueMap | Stock Number | bool
 |  | Description | bool
 |  | Revision Number | bool
 |  | Project | bool
 |  | Designer | bool
 |  | Engineer | bool
 |  | Authority | bool
 |  | Cost Center | bool
 |  | Estimated Cost | bool
 |  | Vendor | bool
 |  | Web Link | bool
 |  | Creation Date | bool
 | Status | Status | bool
 | NameValueMap | Design Status | bool
 |  | Check By | bool
 |  | Checked Date | bool
 |  | Eng. Approved By | bool
 |  | Eng. Approved Date | bool
 |  | Mfg. Approved By | bool
 |  | Mfg. Approved Date | bool
 | Custom** | Custom Prop | bool
 | NameValueMap | Drive | bool
 |  | ... | ...
 | Physical | Material | bool
 | NameValueMap | Density | bool
 |  | Mass | bool
 |  | Area | bool
 |  | Volume | bool
 |  | Requested Accuracy | bool
 |  | Center of Gravity | bool
 |  | Principal | bool
 |  | Global | bool
 |  | Include QTY Overrides | bool

* "Properties" will contain a NameValueMap that is accessed by index. The map key is the name of the property set. The value is an ObjectCollection that is accessed by index. The values in the collection specify the properties to be published.

** The "Custom" keyword is used for user defined properties.

Options for PDF

Sheet_Range | Enum [kPrintCurrentSheet/kPrintAllSheets/kPrintSheetRange] |
Custom_Begin_Sheet | int | Set this when type is kPrintSheetRange
Custom_End_Sheet | int | Set this when type is kPrintSheetRange
All_Color_AS_Black | bool |
Remove_Line_Weights | bool |
Vector_Resolution | int |

Import options for Alias, CATIA V4, CATIA V5, IGES, JT, NX, Parasolid, Pro/ENGINEER, Rhino, SAT, STEP and SolidWorks.

Option Item | Value Type | Default Value | Supporting Translators
"SaveComponentDuringLoad" | Bool | False | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER;Rhino; STEP; SolidWorks
"SaveLocationIndex" | int | 0 (save in workspace) | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"ComponentDestFolder" | string |  | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"SaveAssemSeperateFolder" | Bool | False | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; SAT; STEP; SolidWorks
"AssemDestFolder" | String |  | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; SAT; STEP; SolidWorks
"EmbedInDocument" | Bool | True | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; STEP; SolidWorks
"SaveToDisk" | Bool | True | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; STEP; SolidWorks
"ImportSolid" | Bool | True | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"ImportSurface" | Bool | True | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"ImportWire" | Bool | True | Alias; CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"ImportWorkPlane" | Bool | True | JT; NX; Pro/ENGINEER
"ImportWorkAxe" | Bool | True | JT; NX; Pro/ENGINEER
"ImportWorkPoint" | Bool | True | JT; NX; Pro/ENGINEER
"ImportPoint" | Bool | True | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Rhino; STEP
"ImportMeshes" | Bool | True | CATIA V4; CATIA V5
"ImportAASP" | Bool | False | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; SAT; STEP; SolidWorks
"ImportAASPIndex" | int | 0 (multi solid parts) | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; SAT; STEP; SolidWorks
"CreateSurfIndex" | int | 1 (single composite) | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"GroupNameIndex" | int | 0 (default) | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"GroupName" | string |  | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"ExplodeMSB2Assm" | bool | False | JT; NX; Parasolid; STEP; SolidWorks
 |  | True | SAT
"CHKSearchFolder" | bool | False | NX
"SearchFolder" | String Array | NULL | NX
"AssociativeImport" | bool | True | Alias
"DefaultNames" | bool | True | SAT
"CEGroupLevel" | int | 0 (Level) | IGES; Rhino
"CEPrefixCk" | bool | False | Alias; IGES; Rhino; STEP
"CEPrefixString" | string |  | Alias; IGES; Rhino; STEP
"ImportUnit" | int | 0 (source unit) | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"CheckDuringLoad" | bool | False | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"AutoStitchAndPromote" | bool | True | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"AdvanceHealing" | bool | False | CATIA V4; CATIA V5; IGES; JT; NX; Parasolid; Pro/ENGINEER; Rhino; SAT; STEP; SolidWorks
"NoShowExpModelList" (input) | bool | True | CATIA V4 (for *.exp and *.dlv3 import)
"NODIALOG" (input) | bool | False | CATIA V4 (for *.exp and *.dlv3 import)
"ExpModelIndex" (input) | int | N/A | CATIA V4 (for *.exp and *.dlv3 import)
"ExpModelCount" (output) | int | N/A | CATIA V4 (for *.exp and *.dlv3 import)
"ExpModelNameList" (output) | String array | N/A | CATIA V4 (for *.exp and *.dlv3 import)

Import option values

Option Item Name | Value Scope
SaveLocationIndex | SAVE_IN_WORKSPACE = 0
 | SELECT_SAVE_LOCATIONS = 1
 | SAVE_AT_IMPORT_LOCATION = 2
ImportAASPIndex | MULTIPLE_SOLID_PART = 0
 | SINGLE_COMPOSITE_FEATURE = 1
CreateSurfIndex | INDIVIDUAL_SURFACE = 0 (Translates all surfaces to individual ones, and consumes much more memory and time.)
 | SINGLE_COMPOSITE = 1
 | MULTI_COMPOSITE = 2
 | SINGLE_CONSTRUCTION = 3
 | MULTI_CONSTRUCTION = 4
GroupNameIndex | DEFAULT = 0
 | ENTERED_NAME = 1
CEGroupLevel | eLevelType = 0
 | eGroupType = 1
ImportUnit | SOURCE_UNITS = 0
 | TEMPLATE_UNITS = 1
 | INCH = 2
 | FOOT = 3
 | CENTIMETER = 4
 | MILLIMETER = 5
 | METER = 6
 | MICRON = 7
NoShowExpModelList | When set to true, a dialog that lists all models in the *.exp or *.dlv3 file is shown and ask the user select a file to open.
NODIALOG | Used for user"s input for a dialog or not to list all models in the *.exp or *.dlv3 file and select one file to open.
ExpModelIndex | Used for user"s input to open one of the models in the *.exp or *.dlv3 file.
ExpModelCount | User can get the model count in the *.exp or *.dlv3 file.
ExpModelNameList | User can get a list of all model"s name in the *.exp or *.dlv3 file.

Example code for Option Item "SearchFolder"

Dim options As NameValueMap
Set options = transientObj.CreateNameValueMap
options.Value("CHKSearchFolder") = True
Dim searchFolder(100) As String  ' 100 is the search folder maximum that you can specify.
searchFolder(0) = "C:\"            'Assign separate search folder one by one.
searchFolder(1) = "D:\"
searchFolder(2) = "E:\"
searchFolder(3) = "F:\"
options.Value("SearchFolder") = searchFolder

Export options for CATIA V5, IGES, JT, Parasolid, Pro/ENGINEER, SAT, STEP and STL.

Option Item | Value Type | Default Value | Supporting Translators
"Work Plane Export" | Bool | True | JT; Pro/ENGINEER
"Work Axes Export" | Bool | True | JT
"Work Point Export" | Bool | True | JT; Pro/ENGINEER
"IncludeSketches" | Bool | True | CATIA V5; IGES; JT; Parasolid; Pro/ENGINEER; SAT; STEP
"Version" | int | CATIA: 19 JT: 94 Pro/ENGINEER Granite: 6 Parasolid: 23 SAT: 7 | CATIA V5; JT; Parasolid, Pro/ENGINEER; SAT
"ConfigFileEnabled" | Bool | False | JT
"ConfigFilePath" | String | "" | JT
"OutputFileType" | int | 0 (BrepAndFacets) | JT
"XTBrep" | Bool | True | JT
"FileStructure" | int | 0 (MONOLITHIC) | JT
"ApplicationProtocolType" | int | 4 (eAP214IS) | STEP
"Author" | string | "" | STEP
"Organization" | string | "" | STEP
"Authorization" | string | "" | STEP
"Description" | string | "" | STEP
"GeometryType" | int | 1 (SOLIDS) | IGES
"SurfaceType" | int | 0 (143-Bounded) | IGES
"SolidFaceType" | int | 0 (NURBS) | IGES
"ExportBodyNames" | bool | False | SAT
"OutputFileType" | int | 0 (Binary) | STL
"ExportUnits" | int | 4 (Centimeter) | STL
"ExportFileStructure" | int | 0 (One File) | STL
"Resolution" | int | 1 (Medium) | STL
"SurfaceDeviation" | int | N/A | STL
"NormalDeviation" | int | N/A | STL
"MaxEdgeLength" | int | N/A | STL
"AspectRatio" | int | N/A | STL
"AllowMoveMeshNode" | Bool | False | STL
"export_fit_tolerance” | double | 0.001 | IGES/STEP
"ShrinkSurfaceDuringExport" | int | 2 (shrink surfaces) | IGES/STEP

Export Option Values:

Option Item Name | Value Scope
Version | CATIA (10 - 19)
 | PRO/Engineer Granite (1 - 6)
 | JT (70, 80, 81, 82, 90, 91, 92, 93, 94) e.g. 70 means 7.0 version file.
 | PARASOLID (9 - 23)
 | SAT (4 - 7)
OutputFileType | eBrepAndFacets = 0
 | eBrepOnly = 1
 | eFacetsOnly = 2
XTBrep | XTBrep = True
 | JTBrep = False
FileStructure | JtkMONOLITHIC = 0
 | JtkPER_PART = 1
 | JtkFULL_SHATTER =2
ApplicationProtocolType | eAP203 = 2
 | eAP214DIS = 3
 | eAP214IS = 4
GeometryType | SURFACES = 0
 | SOLIDS = 1
 | WIREFRAMES = 2
SurfaceType | 143_Bounded = 0
 | 144_Trimmed = 1
SolidFaceType | NURBS = 0
 | ANALYTICS = 1
OutputFileType | BINARY = 0
 | ASCII = 1
ExportUnits | INCH = 2
 | FOOT = 3
 | CENTIMETER = 4
 | MILLIMETER = 5
 | METER = 6
 | MICRON = 7
ExportFileStructure | ONE FILE = 0
 | ONE FILE PER PART INSTANCE = 1
Resolution | HIGH = 0
 | MEDIUM = 1
 | LOW = 2
 | CUSTOM = 3
SurfaceDeviation | Range 1 to 100. Value is used if Resolution is CUSTOM (3), otherwise value is ignored.
NormalDeviation | Range 1 to 100. Value is used if Resolution is CUSTOM (3), otherwise value is ignored.
MaxEdgeLength | Range 1 to 100. Value is used if Resolution is CUSTOM (3), otherwise value is ignored.
AspectRatio | Range 1 to 100. Value is used if Resolution is CUSTOM (3), otherwise value is ignored.
export_fit_tolerance | Set the tolerance for the IGES/STEP file. The accepted range for the tolerance value is from 0.00001 (cm) to 0.001 (cm). You can change this value, using cm units only. A smaller tolerance creates more accurate geometry approximations and larger file size.
ShrinkSurfaceDuringExport | No shrink at all = 0
 | Only shrink closed side surface = 1
 | Shrink surfaces = 2
Example 1

Export to DWF

This sample demonstrates publishing of Inventor files in DWF format. To run this sample, the document to be published must be active. The DWF file is created as C:\temptest.DWF (this can be changed in the code below).

Public Sub PublishDWF()
    ' Get the DWF translator Add-In.
    Dim DWFAddIn As TranslatorAddIn
    Set DWFAddIn = ThisApplication.ApplicationAddIns.ItemById("{0AC6FD95-2F4D-42CE-8BE0-8AEA580399E4}")

    'Set a reference to the active document (the document to be published).
    Dim oDocument As Document
    Set oDocument = ThisApplication.ActiveDocument

    Dim oContext As TranslationContext
    Set oContext = ThisApplication.TransientObjects.CreateTranslationContext
    oContext.Type = kFileBrowseIOMechanism

    ' Create a NameValueMap object
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Create a DataMedium object
    Dim oDataMedium As DataMedium
    Set oDataMedium = ThisApplication.TransientObjects.CreateDataMedium

    ' Check whether the translator has 'SaveCopyAs' options
    If DWFAddIn.HasSaveCopyAsOptions(oDocument, oContext, oOptions) Then

        oOptions.Value("Launch_Viewer") = 1

        ' Other options...
        'oOptions.Value("Publish_All_Component_Props") = 1
        'oOptions.Value("Publish_All_Physical_Props") = 1
        'oOptions.Value("Password") = 0

        If Typeof oDocument Is DrawingDocument Then

            ' Drawing options
            oOptions.Value("Publish_Mode") = kCustomDWFPublish
            oOptions.Value("Publish_All_Sheets") = 0

            ' The specified sheets will be ignored if
            ' the option "Publish_All_Sheets" is True (1)
            Dim oSheets As NameValueMap
            Set oSheets = ThisApplication.TransientObjects.CreateNameValueMap

            ' Publish the first sheet AND its 3D model
            Dim oSheet1Options As NameValueMap
            Set oSheet1Options = ThisApplication.TransientObjects.CreateNameValueMap

            oSheet1Options.Add "Name", "Sheet:1"
            oSheet1Options.Add "3DModel", True
            oSheets.Value("Sheet1") = oSheet1Options

            ' Publish the third sheet but NOT its 3D model
            Dim oSheet3Options As NameValueMap
            Set oSheet3Options = ThisApplication.TransientObjects.CreateNameValueMap

            oSheet3Options.Add "Name", "Sheet3:3"
            oSheet3Options.Add "3DModel", False

            oSheets.Value("Sheet2") = oSheet3Options

            'Set the sheet options object in the oOptions NameValueMap
            oOptions.Value("Sheets") = oSheets
        End If

    End If

    'Set the destination file name
    oDataMedium.FileName = "c:\temptest.dwf"

    'Publish document.
    Call DWFAddIn.SaveCopyAs(oDocument, oContext, oOptions, oDataMedium)
End Sub
Example 2

Export to DWG

This sample uses the DWG Translator Addin to publish to DWG.

Public Sub PublishDWG()
    ' Get the DWG translator Add-In.
    Dim DWGAddIn As TranslatorAddIn
    Set DWGAddIn = ThisApplication.ApplicationAddIns.ItemById("{C24E3AC2-122E-11D5-8E91-0010B541CD80}")

    'Set a reference to the active document (the document to be published).
    Dim oDocument As Document
    Set oDocument = ThisApplication.ActiveDocument

    Dim oContext As TranslationContext
    Set oContext = ThisApplication.TransientObjects.CreateTranslationContext
    oContext.Type = kFileBrowseIOMechanism

    ' Create a NameValueMap object
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Create a DataMedium object
    Dim oDataMedium As DataMedium
    Set oDataMedium = ThisApplication.TransientObjects.CreateDataMedium

    ' Check whether the translator has 'SaveCopyAs' options
    If DWGAddIn.HasSaveCopyAsOptions(oDocument, oContext, oOptions) Then

        Dim strIniFile As String
        strIniFile = "C:\tempDWGOut.ini"
        ' Create the name-value that specifies the ini file to use.
        oOptions.Value("Export_Acad_IniFile") = strIniFile
    End If

    'Set the destination file name
    oDataMedium.FileName = "c:\tempdwgout.dwg"

    'Publish document.
    Call DWGAddIn.SaveCopyAs(oDocument, oContext, oOptions, oDataMedium)
End Sub
Example 3

Export to DXF

This sample uses the DXF Translator Addin to publish to DXF.

Public Sub PublishDXF()
    ' Get the DXF translator Add-In.
    Dim DXFAddIn As TranslatorAddIn
    Set DXFAddIn = ThisApplication.ApplicationAddIns.ItemById("{C24E3AC4-122E-11D5-8E91-0010B541CD80}")

    'Set a reference to the active document (the document to be published).
    Dim oDocument As Document
    Set oDocument = ThisApplication.ActiveDocument

    Dim oContext As TranslationContext
    Set oContext = ThisApplication.TransientObjects.CreateTranslationContext
    oContext.Type = kFileBrowseIOMechanism

    ' Create a NameValueMap object
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Create a DataMedium object
    Dim oDataMedium As DataMedium
    Set oDataMedium = ThisApplication.TransientObjects.CreateDataMedium

    ' Check whether the translator has 'SaveCopyAs' options
    If DXFAddIn.HasSaveCopyAsOptions(oDocument, oContext, oOptions) Then

        Dim strIniFile As String
        strIniFile = "C:\tempDXFOut.ini"

        ' Create the name-value that specifies the ini file to use.
        oOptions.Value("Export_Acad_IniFile") = strIniFile
    End If

    'Set the destination file name
    oDataMedium.FileName = "c:\tempdxfout.dxf"

    'Publish document.
    Call DXFAddIn.SaveCopyAs(oDocument, oContext, oOptions, oDataMedium)
End Sub
Example 4

Export to IGES

This sample demonstrates exporting of Inventor files in IGES format. To run this sample, the document to be exported must be active. The IGES file is created as C:\temptest.igs (this can be changed in the code below).

Public Sub ExportToIGES()
    ' Get the IGES translator Add-In.
    Dim oIGESTranslator As TranslatorAddIn
    Set oIGESTranslator = ThisApplication.ApplicationAddIns.ItemById("{90AF7F44-0C01-11D5-8E83-0010B541CD80}")

    If oIGESTranslator Is Nothing Then
        MsgBox "Could not access IGES translator."
        Exit Sub
    End If

    Dim oContext As TranslationContext
    Set oContext = ThisApplication.TransientObjects.CreateTranslationContext
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap
    If oIGESTranslator.HasSaveCopyAsOptions(ThisApplication.ActiveDocument, oContext, oOptions) Then
        ' Set geometry type for wireframe.
        ' 0 = Surfaces, 1 = Solids, 2 = Wireframe
        oOptions.Value("GeometryType") = 1

        ' To set other translator values:
        ' oOptions.Value("SolidFaceType") = n
        ' 0 = NURBS, 1 = Analytic

        ' oOptions.Value("SurfaceType") = n
        ' 0 = 143(Bounded), 1 = 144(Trimmed)

        oContext.Type = kFileBrowseIOMechanism

        Dim oData As DataMedium
        Set oData = ThisApplication.TransientObjects.CreateDataMedium
        oData.FileName = "C:\Temptest.igs"

        Call oIGESTranslator.SaveCopyAs(ThisApplication.ActiveDocument, oContext, oOptions, oData)
    End If
End Sub
Example 5

Export to STEP

This sample demonstrates exporting of Inventor files in STEP format. To run this sample, the document to be exported must be active. The STEP file is created as C:\temptest.stp (this can be changed in the code below).

Public Sub ExportToSTEP()
    ' Get the STEP translator Add-In.
    Dim oSTEPTranslator As TranslatorAddIn
    Set oSTEPTranslator = ThisApplication.ApplicationAddIns.ItemById("{90AF7F40-0C01-11D5-8E83-0010B541CD80}")

    If oSTEPTranslator Is Nothing Then
        MsgBox "Could not access STEP translator."
        Exit Sub
    End If

    Dim oContext As TranslationContext
    Set oContext = ThisApplication.TransientObjects.CreateTranslationContext
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap
    If oSTEPTranslator.HasSaveCopyAsOptions(ThisApplication.ActiveDocument, oContext, oOptions) Then
        ' Set application protocol.
        ' 2 = AP 203 - Configuration Controlled Design
        ' 3 = AP 214 - Automotive Design
        oOptions.Value("ApplicationProtocolType") = 3

        ' Other options...
        'oOptions.Value("Author") = ""
        'oOptions.Value("Authorization") = ""
        'oOptions.Value("Description") = ""
        'oOptions.Value("Organization") = ""

        oContext.Type = kFileBrowseIOMechanism

        Dim oData As DataMedium
        Set oData = ThisApplication.TransientObjects.CreateDataMedium
        oData.FileName = "C:\temptest.stp"

        Call oSTEPTranslator.SaveCopyAs(ThisApplication.ActiveDocument, oContext, oOptions, oData)
    End If
End Sub
Example 6

Export to PDF

This sample demonstrates exporting of Inventor files in PDF format. To run this sample, the document to be exported must be active.

Public Sub PublishPDF()
    ' Get the PDF translator Add-In.
    Dim PDFAddIn As TranslatorAddIn
    Set PDFAddIn = ThisApplication.ApplicationAddIns.ItemById("{0AC6FD96-2F4D-42CE-8BE0-8AEA580399E4}")

    'Set a reference to the active document (the document to be published).
    Dim oDocument As Document
    Set oDocument = ThisApplication.ActiveDocument

    Dim oContext As TranslationContext
    Set oContext = ThisApplication.TransientObjects.CreateTranslationContext
    oContext.Type = kFileBrowseIOMechanism

    ' Create a NameValueMap object
    Dim oOptions As NameValueMap
    Set oOptions = ThisApplication.TransientObjects.CreateNameValueMap

    ' Create a DataMedium object
    Dim oDataMedium As DataMedium
    Set oDataMedium = ThisApplication.TransientObjects.CreateDataMedium

    ' Check whether the translator has 'SaveCopyAs' options
    If PDFAddIn.HasSaveCopyAsOptions(oDocument, oContext, oOptions) Then

        ' Options for drawings...

        oOptions.Value("All_Color_AS_Black") = 0

        'oOptions.Value("Remove_Line_Weights") = 0
        'oOptions.Value("Vector_Resolution") = 400
        'oOptions.Value("Sheet_Range") = kPrintAllSheets
        'oOptions.Value("Custom_Begin_Sheet") = 2
        'oOptions.Value("Custom_End_Sheet") = 4

    End If

    'Set the destination file name
    oDataMedium.FileName = "c:\temp\test.pdf"

    'Publish document.
    Call PDFAddIn.SaveCopyAs(oDocument, oContext, oOptions, oDataMedium)
End Sub
Example 7

Import Rhino file

This sample demonstrates importing the Rhino file into Inventor.

Sub ImportFunc()
   ' Set Rhino translator’s CLSID and the Rhino file name.
   Dim strCLSID As String
   Dim strFileName As String
   strCLSld = "{2CB23BF0-E2AC-4b32-B0A1-1CC292AF6623}"

   ' Please set the full file name here, such as "C:\ETTI.3dm"
   strFileName = "ETTI.3dm"

   Dim oAddIns As ApplicationAddIns
   Set oAddIns = ThisApplication.ApplicationAddIns

   ' Find the Rhino translator, get the CLSID and activate it.
   Dim oPeTransAddIn As TranslatorAddIn
   Set oPeTransAddIn = oAddIns.ItemById(strCLSld)
   oPeTransAddIn.Activate

   ' Get the transient object and take it as a factory to produce other objects
   Dim transientObj As TransientObjects
   Set transientObj = ThisApplication.TransientObjects

   ' Prepare the first parameter for Open(), the file name
   Dim file As DataMedium
   Set file = transientObj.CreateDataMedium
   file.FileName = strFileName

   ' Prepare the second parameter for Open(), the open type.
   Dim context As TranslationContext
   Set context = transientObj.CreateTranslationContext
   context.Type = kDataDropIOMechanism

   ' Prepare the 3rd parameter for Open(), the options.
   Dim options As NameValueMap
   Set options = transientObj.CreateNameValueMap
   options.Value("SaveComponentDuringLoad") = False
   options.Value("SaveLocationIndex") = 0
   options.Value("ComponentDestFolder") = ""
   options.Value("ImportSolid") = True
   options.Value("ImportSurface") = True
   options.Value("ImportWire") = True
   options.Value("ImportPoint") = False
   options.Value("CreateSurfIndex") = 1
   options.Value("GroupNameIndex") = 0
   options.Value("GroupName") = ""
   options.Value("CEGroupLevel") = 0
   options.Value("CEPrefixCk") = False
   options.Value("CEPrefixString") = ""
   options.Value("ImportUnit") = 0
   options.Value("CheckDuringLoad") = False
   options.Value("AutoStitchAndPromote") = True
   options.Value("AdvanceHealing") = False

   ' Prepare the fourth parameter for Open(), the final document.
   Dim sourceObj As Object

   ' Open the Rhino file.
   oPeTransAddIn.Open file, context, options, sourceObj
End Sub
Example 8

Import NX File

This sample demonstrates importing the NX file into Inventor.

Sub ImportFunc()
   ' Set NX translator’s CLSID and the NX file name.
   Dim strCLSID As String
   Dim strFileName As String
   strCLSld = "{93D506C4-8355-4E28-9C4E-C2B5F1EDC6AE}"

   ' Please set the full file name here, such as
   ' "C:\3solids and 3surfaces and wires.prt"
   strFileName = "3solids and 3surfaces and wires.prt"

   Dim oAddIns As ApplicationAddIns
   Set oAddIns = ThisApplication.ApplicationAddIns

   ' Find the NX translator, get the CLSID and activate it.
   Dim oPeTransAddIn As TranslatorAddIn
   Set oPeTransAddIn = oAddIns.ItemById(strCLSld)
   oPeTransAddIn.Activate

   ' Get the transient object and take it as a factory to produce other objects.
   Dim transientObj As TransientObjects
   Set transientObj = ThisApplication.TransientObjects

   ' Prepare the first parameter for Open(), the file name.
   Dim file As DataMedium
   Set file = transientObj.CreateDataMedium
   file.FileName = strFileName

   ' Prepare the second parameter for Open(), the open type.
   Dim context As TranslationContext
   Set context = transientObj.CreateTranslationContext
   context.Type = kDataDropIOMechanism

   ' Prepare the third parameter for Open(), the options.
   Dim options As NameValueMap
   Set options = transientObj.CreateNameValueMap
   options.Value("SaveComponentDuringLoad") = False
   options.Value("SaveLocationIndex") = 0
   options.Value("ComponentDestFolder") = ""
   options.Value("SaveAssemSeperateFolder") = False
   options.Value("AssemDestFolder") = ""
   options.Value("ImportSolid") = True
   options.Value("ImportSurface") = True
   options.Value("ImportWire") = True
   options.Value("ImportWorkPlane") = True
   options.Value("ImportWorkAxe") = True
   options.Value("ImportWorkPoint") = True
   options.Value("ImportPoint") = True
   options.Value("ImportAASP") = False
   options.Value("ImportAASPIndex") = 0
   options.Value("CreateSurfIndex") = 1
   options.Value("GroupNameIndex") = 0
   options.Value("GroupName") = ""
   options.Value("ExplodeMSB2Assm") = False
   options.Value("CHKSearchFolder") = False
   options.Value("SearchFolder") = ""
   options.Value("ImportUnit") = 0
   options.Value("CheckDuringLoad") = False
   options.Value("AutoStitchAndPromote") = True
   options.Value("AdvanceHealing") = False

   ' Prepare the fourth parameter for Open(), the final document
   Dim sourceObj As Object

   ' Open the NX file.
   oPeTransAddIn.Open file, context, options, sourceObj
End Sub
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface


TranslatorAddIn Methods

TranslatorAddIn Methods
Summary

The methods of the TranslatorAddIn class are listed here.

Methods
Methods
Name | Description
DocumentTypesSupported | Method that gets the list of Autodesk Inventor document types that this translator supports translations on.
GetThumbnail | Obtains the thumbnail, if any, for the given data-source. Could be a metafile handle (long) or the interface to a StdPicture object.
HasOpenOptions | Gets whether the translator has options available for opening the specified data-source.
HasSaveCopyAsOptions | Gets whether the translator has options available for saving the specified data-source.
Open | Open the data specified by the data-source.
SaveCopyAs | Save the document to the specified data-source.
ShowOpenOptions | Show the open options for the specified data-source. This method is only called if True was returned from HasOpenOptions.
ShowSaveCopyAsOptions | Show the save options for the specified data-source. This method is only called if True was returned from HasSaveCopyAsOptions.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods


TranslatorAddIn.DocumentTypesSupported Method

TranslatorAddIn.DocumentTypesSupported Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets the list of Autodesk Inventor document types that this translator supports translations on.

Visual Basic
Sub DocumentTypesSupported(ByRef DocumentTypes As SAFEARRAY(long))
Parameters
Parameters | Description
DocumentTypes | Input Long that specifies the types of documents supported by the translator.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.DocumentTypesSupported Method


TranslatorAddIn.GetThumbnail Method

TranslatorAddIn.GetThumbnail Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Obtains the thumbnail, if any, for the given data-source. Could be a metafile handle (long) or the interface to a StdPicture object.

Visual Basic
Sub GetThumbnail(SourceData As DataMedium, Result As [out, retval] VARIANT)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.GetThumbnail Method


TranslatorAddIn.HasOpenOptions Method

TranslatorAddIn.HasOpenOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the translator has options available for opening the specified data-source.

Visual Basic
Sub HasOpenOptions(SourceData As DataMedium, Context As TranslationContext, ByRef DefaultOptions As [unique] NameValueMap, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
Context | Input TranslationContext object that can be used to determine the context for the translation.
DefaultOptions | Input NameValueMap that specifies default translation options.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.HasOpenOptions Method


TranslatorAddIn.HasSaveCopyAsOptions Method

TranslatorAddIn.HasSaveCopyAsOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the translator has options available for saving the specified data-source.

Visual Basic
Sub HasSaveCopyAsOptions(SourceObject As IDispatch, Context As TranslationContext, ByRef DefaultOptions As [unique] NameValueMap, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SourceObject | Document that specifies the source of the data.
Context | Input TranslationContext object that can be used to determine the context for the translation.
DefaultOptions | Input NameValueMap that specifies default translation options.
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.HasSaveCopyAsOptions Method


TranslatorAddIn.Open Method

TranslatorAddIn.Open Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Open the data specified by the data-source.

Visual Basic
Sub Open(SourceData As DataMedium, Context As TranslationContext, ByRef Options As [unique] NameValueMap, ByRef TargetObject As IDispatch*)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
Context | Input TranslationContext object that can be used to determine the context for the translation.
Options | Input NameValueMap that specifies translation options.
TargetObject | Output object in which to place the data from the data source.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.Open Method


TranslatorAddIn.SaveCopyAs Method

TranslatorAddIn.SaveCopyAs Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Save the document to the specified data-source.

Visual Basic
Sub SaveCopyAs(SourceObject As IDispatch, Context As TranslationContext, ByRef Options As [unique] NameValueMap, TargetData As DataMedium)
Parameters
Parameters | Description
SourceObject | Input object that specifies the source of the data to be saved.
Context | Input TranslationContext object that can be used to determine the context for the translation.
Options | Input NameValueMap that specifies translation options.
TargetData | Input DataMedium object that specifies the medium of the data to be saved.
See Also

Export to PDF sample

Export to STEP sample

export to IGES sample

Export to DXF sample

Export to DWG sample

Export to DWF sample

You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.SaveCopyAs Method


TranslatorAddIn.ShowOpenOptions Method

TranslatorAddIn.ShowOpenOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Show the open options for the specified data-source. This method is only called if True was returned from HasOpenOptions.

Visual Basic
Sub ShowOpenOptions(SourceData As DataMedium, Context As TranslationContext, ByRef ChosenOptions As [unique] NameValueMap)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
Context | Input TranslationContext object that can be used to determine the context for the translation.
ChosenOptions | Input NameValueMap that specifies the options chosen.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.ShowOpenOptions Method


TranslatorAddIn.ShowSaveCopyAsOptions Method

TranslatorAddIn.ShowSaveCopyAsOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Show the save options for the specified data-source. This method is only called if True was returned from HasSaveCopyAsOptions.

Visual Basic
Sub ShowSaveCopyAsOptions(SourceObject As IDispatch, Context As TranslationContext, ByRef ChosenOptions As [unique] NameValueMap)
Parameters
Parameters | Description
SourceObject | Input object that specifies the source of the data to show the save options for.
Context | Input TranslationContext object that can be used to determine the context for the translation.
ChosenOptions | Input NameValueMap that specifies the options chosen.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Methods > TranslatorAddIn.ShowSaveCopyAsOptions Method


TranslatorAddIn Properties

TranslatorAddIn Properties
Summary

The properties of the TranslatorAddIn class are listed here.

Properties
Name | Description
FileExtensions | Property that gets the semicolon-separated list of the native file extensions that this translator reads from and/or writes to.
FilterText | Property that gets the filter text string to be displayed in the file dialog for this translator.
SupportsImportInto | Property that returns semicolon-separated Inventor file types that this translator supports importing into. Example: ".iam;.ipt."
SupportsOpen | Property that gets whether this translator supports opening files.
SupportsOpenInto | Property that returns semicolon-separated Inventor file types that this translator supports opening into. Example: ".iam;.ipt."
SupportsSaveCopyAs | Property that gets whether this translator supports saving data to a file.
SupportsSaveCopyAsFrom | Property that returns semicolon-separated Inventor file types that this translator supports saving from. Example: ".iam;.ipt."
TranslatorAvailable | Gets/sets a Boolean flag indicating whether this Translator is available to Autodesk Inventor, regardless of whether it is loaded or not.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties


TranslatorAddIn.FileExtensions Property

TranslatorAddIn.FileExtensions Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets the semicolon-separated list of the native file extensions that this translator reads from and/or writes to.

Visual Basic
Property FileExtensions() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.FileExtensions Property


TranslatorAddIn.FilterText Property

TranslatorAddIn.FilterText Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets the filter text string to be displayed in the file dialog for this translator.

Visual Basic
Property FilterText() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.FilterText Property


TranslatorAddIn.SupportsImportInto Property

TranslatorAddIn.SupportsImportInto Property
Summary

Property that returns semicolon-separated Inventor file types that this translator supports importing into. Example: ".iam;.ipt."

Visual Basic
Property SupportsImportInto() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.SupportsImportInto Property


TranslatorAddIn.SupportsOpen Property

TranslatorAddIn.SupportsOpen Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets whether this translator supports opening files.

Visual Basic
Property SupportsOpen() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.SupportsOpen Property


TranslatorAddIn.SupportsOpenInto Property

TranslatorAddIn.SupportsOpenInto Property
Summary

Property that returns semicolon-separated Inventor file types that this translator supports opening into. Example: ".iam;.ipt."

Visual Basic
Property SupportsOpenInto() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.SupportsOpenInto Property


TranslatorAddIn.SupportsSaveCopyAs Property

TranslatorAddIn.SupportsSaveCopyAs Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that gets whether this translator supports saving data to a file.

Visual Basic
Property SupportsSaveCopyAs() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.SupportsSaveCopyAs Property


TranslatorAddIn.SupportsSaveCopyAsFrom Property

TranslatorAddIn.SupportsSaveCopyAsFrom Property
Summary

Property that returns semicolon-separated Inventor file types that this translator supports saving from. Example: ".iam;.ipt."

Visual Basic
Property SupportsSaveCopyAsFrom() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.SupportsSaveCopyAsFrom Property


TranslatorAddIn.TranslatorAvailable Property

TranslatorAddIn.TranslatorAvailable Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets/sets a Boolean flag indicating whether this Translator is available to Autodesk Inventor, regardless of whether it is loaded or not.

Visual Basic
Property TranslatorAvailable() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddIn Interface > TranslatorAddIn Properties > TranslatorAddIn.TranslatorAvailable Property


TranslatorAddInServer Interface

TranslatorAddInServer Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object required to be supported by Server to qualify as an Autodesk Inventor Translator AddIn.

Class Hierarchy
Inventor::ApplicationAddInServer
    Inventor::TranslatorAddInServer
Visual Basic
Public Interface TranslatorAddInServer
Inherits ApplicationAddInServer
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface


TranslatorAddInServer Methods

TranslatorAddInServer Methods
Summary

The methods of the TranslatorAddInServer class are listed here.

Methods
Methods
Name | Description
GetThumbnail | Obtains the thumbnail, if any, for the given data-source. Could be a metafile handle (long) or the interface to a StdPicture object.
HasOpenOptions | Gets whether the translator has options available for opening the specified data-source.
HasSaveCopyAsOptions | Gets whether the translator has options available for saving the specified data-source.
Open | Open the data specified by the data-source.
SaveCopyAs | Save the specified document to the specified data-source.
ShowOpenOptions | Show the open options for the specified data-source. This method is only called if True was returned from HasOpenOptions.
ShowSaveCopyAsOptions | Show the save options for the specified data-source. This method is only called if True was returned from HasSaveCopyAsOptions.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods


TranslatorAddInServer.GetThumbnail Method

TranslatorAddInServer.GetThumbnail Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Obtains the thumbnail, if any, for the given data-source. Could be a metafile handle (long) or the interface to a StdPicture object.

Visual Basic
Sub GetThumbnail(SourceData As DataMedium, Result As [out, retval] VARIANT)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.GetThumbnail Method


TranslatorAddInServer.HasOpenOptions Method

TranslatorAddInServer.HasOpenOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the translator has options available for opening the specified data-source.

Visual Basic
Sub HasOpenOptions(SourceData As DataMedium, Context As TranslationContext, ByRef DefaultOptions As [unique] NameValueMap, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
Context | Input TranslationContext object that can be used to determine the context for the translation.
DefaultOptions | Input NameValueMap that specifies default translation options.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.HasOpenOptions Method


TranslatorAddInServer.HasSaveCopyAsOptions Method

TranslatorAddInServer.HasSaveCopyAsOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets whether the translator has options available for saving the specified data-source.

Visual Basic
Sub HasSaveCopyAsOptions(SourceObject As IDispatch, Context As TranslationContext, ByRef DefaultOptions As [unique] NameValueMap, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SourceObject | Document that specifies the source of the data.
Context | Input TranslationContext object that can be used to determine the context for the translation.
DefaultOptions | Input NameValueMap that specifies default translation options.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.HasSaveCopyAsOptions Method


TranslatorAddInServer.Open Method

TranslatorAddInServer.Open Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Open the data specified by the data-source.

Visual Basic
Sub Open(SourceData As DataMedium, Context As TranslationContext, ByRef Options As [unique] NameValueMap, ByRef TargetObject As IDispatch*)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
Context | Input TranslationContext object that can be used to determine the context for the translation.
Options | Input NameValueMap that specifies translation options.
TargetObject | Input/output object in which to place the data from the data source.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.Open Method


TranslatorAddInServer.SaveCopyAs Method

TranslatorAddInServer.SaveCopyAs Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Save the specified document to the specified data-source.

Visual Basic
Sub SaveCopyAs(SourceObject As IDispatch, Context As TranslationContext, ByRef Options As [unique] NameValueMap, TargetData As DataMedium)
Parameters
Parameters | Description
SourceObject | Input object that specifies the source of the data to be saved.
Context | Input TranslationContext object that can be used to determine the context for the translation.
Options | Input NameValueMap that specifies translation options.
TargetData | Input DataMedium object that specifies the medium of the data to be saved.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.SaveCopyAs Method


TranslatorAddInServer.ShowOpenOptions Method

TranslatorAddInServer.ShowOpenOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Show the open options for the specified data-source. This method is only called if True was returned from HasOpenOptions.

Visual Basic
Sub ShowOpenOptions(SourceData As DataMedium, Context As TranslationContext, ByRef ChosenOptions As [unique] NameValueMap)
Parameters
Parameters | Description
SourceData | Input DataMedium object that specifies the data source.
Context | Input TranslationContext object that can be used to determine the context for the translation.
ChosenOptions | Input NameValueMap that specifies the options chosen.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.ShowOpenOptions Method


TranslatorAddInServer.ShowSaveCopyAsOptions Method

TranslatorAddInServer.ShowSaveCopyAsOptions Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Show the save options for the specified data-source. This method is only called if True was returned from HasSaveCopyAsOptions.

Visual Basic
Sub ShowSaveCopyAsOptions(SourceObject As IDispatch, Context As TranslationContext, ByRef ChosenOptions As [unique] NameValueMap)
Parameters
Parameters | Description
SourceObject | Input object that specifies the source of the data to show the save options for.
Context | Input TranslationContext object that can be used to determine the context for the translation.
ChosenOptions | Input NameValueMap that specifies the options chosen.
You are here: Symbol Reference > Inventor Library > Objects > TranslatorAddInServer Interface > TranslatorAddInServer Methods > TranslatorAddInServer.ShowSaveCopyAsOptions Method


TriadEvents CoClass

TriadEvents CoClass Available in Inventor Introduced in Inventor 9
Summary

Event object that provides Triad (3D Move/Rotate tool) events.

Class Hierarchy
Inventor::TriadEvents
Visual Basic
Public Class TriadEvents
Remarks

See [image] here for an overview. Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

InteractionEventsObject.TriadEvents

You are here: Symbol Reference > Inventor Library > Objects > TriadEvents CoClass


TriadEventsObject Interface

TriadEventsObject Interface Available in Inventor Introduced in Inventor 9
Summary

Event object that provides Triad (3D Move/Rotate tool) events.

Class Hierarchy
Inventor::TriadEventsObject
Visual Basic
Public Interface TriadEventsObject
Inherits IDispatch
Remarks

See [image] here for an overview. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface


TriadEventsObject Methods

TriadEventsObject Methods
Summary

The methods of the TriadEventsObject class are listed here.

Methods
Methods
Name | Description
Reposition | Method that repositions the specified triad segment to the specified object. An error will occur if a move is in progress.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Methods


TriadEventsObject.Reposition Method

TriadEventsObject.Reposition Method Available in Inventor Introduced in Inventor 9
Summary

Method that repositions the specified triad segment to the specified object. An error will occur if a move is in progress.

Visual Basic
Sub Reposition(TriadSegment As TriadSegmentEnum, AlignWith As IDispatch)
Parameters
Parameters | Description
TriadSegment | Input TriadSegmentEnum indicating the segment of the triad that will be used to reposition the triad. kXAxisRotationSegment, kYAxisRotationSegment, and kZAxisRotationSegment are NOT valid inputs.
AlignWith | Input Object that specifies the object that the input triad segment will be aligned with. An error occurs if this object is not of a valid type for the input triad segment. For instance, if the input TriadSegment is XYPlaneTranslationSegment, the only valid inputs are planar face and work plane. If the input TriadSegment is kXAxisTranslationSegment, the only valid inputs are linear edge, work axis and vector. If the input TriadSegment is kOriginSegment, the only valid inputs are vertex, work point and Point. If the input TriadSegment is kAllSegments, the only valid input is a Matrix object.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Methods > TriadEventsObject.Reposition Method


TriadEventsObject Properties

TriadEventsObject Properties
Summary

The properties of the TriadEventsObject class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
DegreesOfFreedom | Property that gets and sets the allowed translation and rotation directions. This property has a default of kAllSegments indicating that all translations and rotations are allowed. Setting this property will fail if a move is in progress or if a move has not been committed. The enum values are bits and can be combined to designate that more than one segments are allowed for selection.
Enabled | Property that gets and sets whether triad events are enabled. When the InteractionEvents object is initially created this property is initialized to False.
GlobalTransform | Property that gets and sets the matrix indicating the triad's current position in model space.
IsInRedefineMode | Property that indicates whether the triad is currently in redefine mode.
MoveTriadOnly | Property that gets and sets a flag indicating whether to move the triad independent of the object that the triad is being used to move. A value of True indicates that the triad move should not move the object. Setting this property will fail if a move is in progress or if a move has not been committed.
MoveTriadOnlyEnabled | Property that gets and sets a flag indicating whether to provide the 'Move Triad Only' option to the end user. Setting this property will fail if a move is in progress or if a move has not been committed.
Parent | Property that returns the parent object from whom this object can logically be reached.
Repeat | Property that gets and sets a flag indicating whether the triad should be terminated after one sequence of moves. If set to true, multiple sequences are allowed and an 'Apply' option is added to the triad dialog. The value is defaulted to False.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties


TriadEventsObject.Application Property

TriadEventsObject.Application Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.Application Property


TriadEventsObject.DegreesOfFreedom Property

TriadEventsObject.DegreesOfFreedom Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets the allowed translation and rotation directions. This property has a default of kAllSegments indicating that all translations and rotations are allowed. Setting this property will fail if a move is in progress or if a move has not been committed. The enum values are bits and can be combined to designate that more than one segments are allowed for selection.

Visual Basic
Property DegreesOfFreedom() As TriadSegmentEnum
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.DegreesOfFreedom Property


TriadEventsObject.Enabled Property

TriadEventsObject.Enabled Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets whether triad events are enabled. When the InteractionEvents object is initially created this property is initialized to False.

Visual Basic
Property Enabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.Enabled Property


TriadEventsObject.GlobalTransform Property

TriadEventsObject.GlobalTransform Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets the matrix indicating the triad's current position in model space.

Visual Basic
Property GlobalTransform() As Matrix*
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.GlobalTransform Property


TriadEventsObject.IsInRedefineMode Property

TriadEventsObject.IsInRedefineMode Property Available in Inventor Introduced in Inventor 2009
Summary

Property that indicates whether the triad is currently in redefine mode.

Visual Basic
Property IsInRedefineMode() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.IsInRedefineMode Property


TriadEventsObject.MoveTriadOnly Property

TriadEventsObject.MoveTriadOnly Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets a flag indicating whether to move the triad independent of the object that the triad is being used to move. A value of True indicates that the triad move should not move the object. Setting this property will fail if a move is in progress or if a move has not been committed.

Visual Basic
Property MoveTriadOnly() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.MoveTriadOnly Property


TriadEventsObject.MoveTriadOnlyEnabled Property

TriadEventsObject.MoveTriadOnlyEnabled Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets a flag indicating whether to provide the 'Move Triad Only' option to the end user. Setting this property will fail if a move is in progress or if a move has not been committed.

Visual Basic
Property MoveTriadOnlyEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.MoveTriadOnlyEnabled Property


TriadEventsObject.Parent Property

TriadEventsObject.Parent Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As InteractionEvents**
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.Parent Property


TriadEventsObject.Repeat Property

TriadEventsObject.Repeat Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets a flag indicating whether the triad should be terminated after one sequence of moves. If set to true, multiple sequences are allowed and an 'Apply' option is added to the triad dialog. The value is defaulted to False.

Visual Basic
Property Repeat() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.Repeat Property


TriadEventsObject.Type Property

TriadEventsObject.Type Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsObject Interface > TriadEventsObject Properties > TriadEventsObject.Type Property


TriadEventsSink Interface

TriadEventsSink Interface Available in Inventor Introduced in Inventor 9
Summary

Event object that provides Triad (3D Move/Rotate tool) events.

Class Hierarchy
Inventor::TriadEventsSink
Visual Basic
Public Interface TriadEventsSink
Inherits IDispatch
Remarks

See [image] here for an overview. Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface


TriadEventsSink Methods

TriadEventsSink Methods
Summary

The methods of the TriadEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivate | Event that occurs when the triad is activated.
OnEndMove | Fired when the user ends a mouse drag, after repositioning the triad by aligning or when the user selects another triad segment after entering translation/rotation values in the dialog.
OnEndSequence | Fired when the user commits the move of the triad and hence indicates the end of a logical sequence of moves. This could happen when the user hits 'Apply' or hits 'OK'. This is the event where you should make the database changes.
OnMove | Event that occurs when the triad moves as a result of a drag, a reposition or user entering values for translation or rotation. A 'reposition' move is always immediately followed by the OnEndMove event.
OnMoveTriadOnlyToggle | Event that occurs every time the 'Move Triad Only' option is toggled.
OnSegmentSelectionChange | Event that occurs every time a segment of a triad is selected.
OnStartMove | Event that occurs when the triad begins to move as a result of a drag, a reposition or user entering values for translation or rotation. The event provides information of the state of the triad before the move actually occurs.
OnStartSequence | Event that fires indicating the logical start of a sequence of triad moves.
OnTerminate | Event that occurs when the triad is terminated.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods


TriadEventsSink.OnActivate Method

TriadEventsSink.OnActivate Method Available in Inventor Introduced in Inventor 9
Summary

Event that occurs when the triad is activated.

Visual Basic
Sub OnActivate(Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnActivate Method


TriadEventsSink.OnEndMove Method

TriadEventsSink.OnEndMove Method Available in Inventor Introduced in Inventor 9
Summary

Fired when the user ends a mouse drag, after repositioning the triad by aligning or when the user selects another triad segment after entering translation/rotation values in the dialog.

Visual Basic
Sub OnEndMove(SelectedTriadSegment As TriadSegmentEnum, ShiftKeys As ShiftStateEnum, CoordinateSystem As Matrix, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SelectedTriadSegment | Returns a TriadSegmentEnum indicating the segment of the triad that was selected for this drag operation.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
CoordinateSystem | Returns a Matrix object indicating the triad's current position in model space.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnEndMove Method


TriadEventsSink.OnEndSequence Method

TriadEventsSink.OnEndSequence Method Available in Inventor Introduced in Inventor 9
Summary

Fired when the user commits the move of the triad and hence indicates the end of a logical sequence of moves. This could happen when the user hits 'Apply' or hits 'OK'. This is the event where you should make the database changes.

Visual Basic
Sub OnEndSequence(Cancelled As VARIANT_BOOL, CoordinateSystem As Matrix, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Cancelled | Returns a Boolean indicating whether this sequence of moves was cancelled by the user.
CoordinateSystem | Returns a Matrix object indicating the triad's current position in model space.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnEndSequence Method


TriadEventsSink.OnMove Method

TriadEventsSink.OnMove Method Available in Inventor Introduced in Inventor 9
Summary

Event that occurs when the triad moves as a result of a drag, a reposition or user entering values for translation or rotation. A 'reposition' move is always immediately followed by the OnEndMove event.

Visual Basic
Sub OnMove(SelectedTriadSegment As TriadSegmentEnum, ShiftKeys As ShiftStateEnum, CoordinateSystem As Matrix, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SelectedTriadSegment | Returns a TriadSegmentEnum indicating the segment of the triad that was selected for this move operation.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the drag operation occurs. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
CoordinateSystem | Returns a Matrix object indicating the triad's current position in model space.
Context | Returns the NameValueMap object with information regarding the context in which the move occurred.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnMove Method


TriadEventsSink.OnMoveTriadOnlyToggle Method

TriadEventsSink.OnMoveTriadOnlyToggle Method Available in Inventor Introduced in Inventor 9
Summary

Event that occurs every time the 'Move Triad Only' option is toggled.

Visual Basic
Sub OnMoveTriadOnlyToggle(MoveTriadOnly As VARIANT_BOOL, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
MoveTriadOnly | Indicates whether to move the triad independent of the object that the triad is being used to move. A value of True indicates that the triad move should not move the object.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the assembly structure is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnMoveTriadOnlyToggle Method


TriadEventsSink.OnSegmentSelectionChange Method

TriadEventsSink.OnSegmentSelectionChange Method Available in Inventor Introduced in Inventor 9
Summary

Event that occurs every time a segment of a triad is selected.

Visual Basic
Sub OnSegmentSelectionChange(SelectedTriadSegment As TriadSegmentEnum, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SelectedTriadSegment | Returns a TriadSegmentEnum indicating the segment of the triad that was selected for this operation.
BeforeOrAfter | Input EventTimingEnum indicating if the event is being fired before (kBefore) or after (kAfter) the assembly structure is changed.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnSegmentSelectionChange Method


TriadEventsSink.OnStartMove Method

TriadEventsSink.OnStartMove Method Available in Inventor Introduced in Inventor 9
Summary

Event that occurs when the triad begins to move as a result of a drag, a reposition or user entering values for translation or rotation. The event provides information of the state of the triad before the move actually occurs.

Visual Basic
Sub OnStartMove(SelectedTriadSegment As TriadSegmentEnum, ShiftKeys As ShiftStateEnum, CoordinateSystem As Matrix, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SelectedTriadSegment | Returns a TriadSegmentEnum indicating the segment of the triad that was selected for this move operation.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
CoordinateSystem | Returns a Matrix object indicating the triad's current position in model space.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnStartMove Method


TriadEventsSink.OnStartSequence Method

TriadEventsSink.OnStartSequence Method Available in Inventor Introduced in Inventor 9
Summary

Event that fires indicating the logical start of a sequence of triad moves.

Visual Basic
Sub OnStartSequence(CoordinateSystem As Matrix, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
CoordinateSystem | Returns a Matrix object indicating the triad's current position in model space.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnStartSequence Method


TriadEventsSink.OnTerminate Method

TriadEventsSink.OnTerminate Method Available in Inventor Introduced in Inventor 9
Summary

Event that occurs when the triad is terminated.

Visual Basic
Sub OnTerminate(Cancelled As VARIANT_BOOL, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Cancelled | Returns a Boolean indicating whether this sequence of moves was cancelled by the user.
Context | Input NameValueMap object that can be used to determine the context of why the event fired.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. The value of this argument is currently ignored for this event.
You are here: Symbol Reference > Inventor Library > Objects > TriadEventsSink Interface > TriadEventsSink Methods > TriadEventsSink.OnTerminate Method


TriangleFanGraphics Interface

TriangleFanGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TriangleFanGraphics object defines a set of connected triangles. The first three coordinates define a triangle and the next coordinate defines another triangle using two previous coordinates.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::TriangleFanGraphics
Visual Basic
Public Interface TriangleFanGraphics
Inherits GraphicsPrimitive
Remarks

Below is an example of the data used to create a TriangleFanGraphics object.

In this example there is no savings of data if you use an index set. The use of an index set may make sense in the case where you want to use a partial set of a larger coordinate set by indexing the particular coordinates to use.

Coordinate set

(2,3,0), (0,0,0), (4,0,0), (5,4,0), (2,6,0), (-1,4,0)

The coordinates listed in the set above define the five triangles. Coordinates 1, 2, and 3 define the first triangle, coordinate 4 creates a new triangle by connecting coordinate 1 and the previous coordinate (coordinate 3), coordinate 5 creates a new triangle by connection coordinate 1 and the previous coordinate (coordinate 4), and so on.

The coordinate set above is used to define a single strip. Multiple fans can be defined within a single TriangleFanGraphics object by setting strip lengths. The strip lengths define how many coordinates are used for each fan.

Notes

Members through which this object may be accessed include:

GraphicsNode.AddTriangleFanGraphics

See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface


TriangleFanGraphics Methods

TriangleFanGraphics Methods
Summary

The methods of the TriangleFanGraphics class are listed here.

Methods
Methods
Name | Description
GetStripLengths | Method that returns the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.
GetTransformBehavior | Returns the current view transformation settings (e.g. pixel scaling and front facing).
PutStripLengths | Method that sets the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.
SetTransformBehavior | Sets the view transformation settings (e.g. pixel scaling and front facing).
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Methods


TriangleFanGraphics.GetStripLengths Method

TriangleFanGraphics.GetStripLengths Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.

Visual Basic
Sub GetStripLengths(ByRef StripLengths As SAFEARRAY(long))
Parameters
Parameters | Description
StripLengths | Array of Longs that defines the strip lengths. The length of a strip is defined by specifying the number of coordinates used for each strip.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Methods > TriangleFanGraphics.GetStripLengths Method


TriangleFanGraphics.GetTransformBehavior Method

TriangleFanGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the current view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point that returns the point that is unaffected by the transform behavior.
BehaviorType | Output DisplayTransformBehaviorEnum that returns the transform behaviors currently being used.
PixelScale | Output Double that returns the number of pixels that are used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Methods > TriangleFanGraphics.GetTransformBehavior Method


TriangleFanGraphics.PutStripLengths Method

TriangleFanGraphics.PutStripLengths Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.

Visual Basic
Sub PutStripLengths(ByRef StripLengths As SAFEARRAY(long))
Parameters
Parameters | Description
StripLengths | Array of Longs that defines the strip lengths. The length of a strip is defined by specifying the number of coordinates used for each strip.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Methods > TriangleFanGraphics.PutStripLengths Method


TriangleFanGraphics.SetTransformBehavior Method

TriangleFanGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Sets the view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input Point that indicates which point is unaffected by the transform behavior.
BehaviorType | Input DisplayTransformBehaviorEnum that specifies which transform behaviors are to be used.
PixelScale | Input Double that indicates how many pixels should be used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Methods > TriangleFanGraphics.SetTransformBehavior Method


TriangleFanGraphics Properties

TriangleFanGraphics Properties
Summary

The properties of the TriangleFanGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
ColorBinding | Property that gets and sets how the colors are defined for the triangle.
ColorIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to a index set.
ColorMapper | Property that gets and sets the GraphicsColorMapper object associated with the set. In order for this mapping to work, scalar (x) values for individual vertices should be specified using the TextureCoordinateSet and TextureCoordinateIndexSet properties. This property defaults to Nothing and can be set to Nothing to remove the reference to a color mapper.
ColorSet | Property that gets and sets the GraphicsColorSet associated with the set.
CoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.
CoordinateSet | Property that gets and sets the GraphicsCoordinateSet associated with the set.
DepthPriority | Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
NormalBinding | Property that gets and sets how the normals are defined for the triangles
NormalIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the normal set to use for the lines of the set. This property can be set to Nothing to remove the reference to an index set.
NormalSet | Property that gets and sets the GraphicsNormalSet associated with the set.
TextureCoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the texture coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.
TextureCoordinateSet | Property that gets and sets the GraphicsTextureCoordinateSet associated with the set.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties


TriangleFanGraphics.BurnThrough Property

TriangleFanGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.BurnThrough Property


TriangleFanGraphics.ColorBinding Property

TriangleFanGraphics.ColorBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the colors are defined for the triangle.

Visual Basic
Property ColorBinding() As ColorBindingEnum
Remarks

If a color index set is defined, then the order of colors is defined by the index set. If an index is not defined, then the order of the colors in the color set is used. The options are:

  • kOverallColor:The first color in the color set is used for the entire triangle set.
  • kPerItemColors:The first color in the color set is used for the first triangle, the second color for the second triangle, and so on. If there are more triangles than colors, the last color in the list is used for the remaining triangles. If there are more colors than triangles, the additional colors are ignored.
  • kPerStripColors:The first color in the color set is used for all of the triangles of the first strip, the second color is used for the second strip, and so on. If there are more strips than colors, the last color in the set is used for the remaining strips. If there are more colors than strips, the additional colors are ignored.
  • kPerVertexColors:The first color in the color set is used for the first vertex, the second color is used for the second vertex, and so on. Since a different color can be defined for each vertex the color blends along the triangle from one color to the other. If there are more vertices than colors, the last color in the list is used for the remaining vertices. If there are more colors than vertices, the additional colors are ignored.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.ColorBinding Property


TriangleFanGraphics.ColorIndexSet Property

TriangleFanGraphics.ColorIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to a index set.

Visual Basic
Property ColorIndexSet() As GraphicsIndexSet*
Remarks

An index set for colors serves as a color lookup mechanism into the color set. When colors are assigned to the object the order defined by the index set is used instead of the ordering within the color set

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.ColorIndexSet Property


TriangleFanGraphics.ColorMapper Property

TriangleFanGraphics.ColorMapper Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsColorMapper object associated with the set. In order for this mapping to work, scalar (x) values for individual vertices should be specified using the TextureCoordinateSet and TextureCoordinateIndexSet properties. This property defaults to Nothing and can be set to Nothing to remove the reference to a color mapper.

Visual Basic
Property ColorMapper() As GraphicsColorMapper*
Remarks

Unlike the ColorMapper returned by GrahphicsDataSets.ColorMapper, this property returns a non-transient sharable GraphicsColorMapper object.

Example

See GraphicsColorMapper for sample code.

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.ColorMapper Property


TriangleFanGraphics.ColorSet Property

TriangleFanGraphics.ColorSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsColorSet associated with the set.

Visual Basic
Property ColorSet() As GraphicsColorSet*
Remarks

How the GraphicsColorSet is interpreted depends on the value of the ColorBinding property. If no color set is defined for the triangle set, the render style color defined for the GraphicsNode will be used. If a color set is defined, it overrides the diffuse and ambient colors defined in the render style of the GraphicsNode. This property can be set to Nothing to remove the reference to a color set and return to using the colors defined by the display style of the GraphicsNode.

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.ColorSet Property


TriangleFanGraphics.CoordinateIndexSet Property

TriangleFanGraphics.CoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property CoordinateIndexSet() As GraphicsIndexSet*
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.CoordinateIndexSet Property


TriangleFanGraphics.CoordinateSet Property

TriangleFanGraphics.CoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsCoordinateSet associated with the set.

Visual Basic
Property CoordinateSet() As GraphicsCoordinateSet*
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.CoordinateSet Property


TriangleFanGraphics.DepthPriority Property

TriangleFanGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.DepthPriority Property


TriangleFanGraphics.NormalBinding Property

TriangleFanGraphics.NormalBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the normals are defined for the triangles

Visual Basic
Property NormalBinding() As NormalBindingEnum
Remarks

If a normal index set is defined, then the order of normals is defined by the index set. If an index is not defined, then the order of the normals in the normal set is used. The options are:

  • kOverallNormal:The first normal in the set is used for the entire triangle set.
  • kPerItemNormal:The first normal in the set is used for the first triangle, the second normal for the second triangle, and so on. If there are more triangles than normals, the last normal in the list is used for the remaining triangles. If there are more normals than triangles, the additional normals are ignored.
  • kPerStripNormal:The first normal in the set is used for the first strip, the second normal is used for the second strip, and so on. If there are more strips than normals, the last normal in the set is used for the remaining strips. If there are more normals than strips, the additional normals are ignored.
  • kPerVertexNormal:The first normal in the set is used for the first vertex, the second normal is used for the second vertex, and so on. Defining the normals at each vertex can result in a smooth shading of the triangles. If there are more vertices than normals, the last normal in the set is used for the remaining vertices. If there are more normals than vertices, the additional normals are ignored.
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.NormalBinding Property


TriangleFanGraphics.NormalIndexSet Property

TriangleFanGraphics.NormalIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the normal set to use for the lines of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property NormalIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.NormalIndexSet Property


TriangleFanGraphics.NormalSet Property

TriangleFanGraphics.NormalSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsNormalSet associated with the set.

Visual Basic
Property NormalSet() As GraphicsNormalSet*
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.NormalSet Property


TriangleFanGraphics.TextureCoordinateIndexSet Property

TriangleFanGraphics.TextureCoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the texture coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property TextureCoordinateIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.TextureCoordinateIndexSet Property


TriangleFanGraphics.TextureCoordinateSet Property

TriangleFanGraphics.TextureCoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsTextureCoordinateSet associated with the set.

Visual Basic
Property TextureCoordinateSet() As GraphicsTextureCoordinateSet*
You are here: Symbol Reference > Inventor Library > Objects > TriangleFanGraphics Interface > TriangleFanGraphics Properties > TriangleFanGraphics.TextureCoordinateSet Property


TriangleGraphics Interface

TriangleGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TriangleGraphics object defines a set of disconnected triangles. Each set of three coordinates defines a triangle.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::TriangleGraphics
Visual Basic
Public Interface TriangleGraphics
Inherits GraphicsPrimitive
Remarks

Below is an example of two ways to create the set of triangles shown in the figure. One uses only a coordinate set and the other also uses the same coordinate set along with an index set to make more efficient use of the coordinates. (See the TriangleStripGraphics object for a more efficient method of drawing this particular sample.)

Coordinate set 1

(0,0,0),(2,0,0),(1,1,0), (2,0,0),(1,1,0),(3,1,0), (2,0,0),(4,0,0),(3,1,0), (4,0,0),(5,1,0),(3,1,0)

The coordinates listed in the set above define the four triangles. Three coordinates are used for each triangle, which requires 12 coordinates.

Coordinate set 2

(0,0,0), (2,0,0), (1,1,0), (3,1,0), (4,0,0), (5,1,0)

Index set 1

1,2,3, 2,4,3, 2,5,4, 5,6,4

This case uses an index set to define the points for the triangles. Each set of three indices defines a triangle. The indices reference coordinates within the coordinate set. Since different indices can refer to the same point, points in the coordinate set can be reused.

In many cases, use of an index set is much more efficient, particularly when you consider that other graphic primitives can share coordinate sets. For example, you may have a list of coordinates that defines all of the vertices of a triangle mesh. It is much more efficient to define each of these vertices once and then reference them using an index set to build the triangles. The same set of coordinates can also be used to draw line sets or linestrip sets along the boundaries.

Notes

Members through which this object may be accessed include:

GraphicsNode.AddTriangleGraphics

See Also

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Client Graphics - Vertex Color by Z Height sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface


TriangleGraphics Methods

TriangleGraphics Methods
Summary

The methods of the TriangleGraphics class are listed here.

Methods
Methods
Name | Description
GetTransformBehavior | Returns the current view transformation settings (e.g. pixel scaling and front facing).
SetTransformBehavior | Sets the view transformation settings (e.g. pixel scaling and front facing).
You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Methods


TriangleGraphics.GetTransformBehavior Method

TriangleGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the current view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point that returns the point that is unaffected by the transform behavior.
BehaviorType | Output DisplayTransformBehaviorEnum that returns the transform behaviors currently being used.
PixelScale | Output Double that returns the number of pixels that are used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Methods > TriangleGraphics.GetTransformBehavior Method


TriangleGraphics.SetTransformBehavior Method

TriangleGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Sets the view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input Point that indicates which point is unaffected by the transform behavior.
BehaviorType | Input DisplayTransformBehaviorEnum that specifies which transform behaviors are to be used.
PixelScale | Input Double that indicates how many pixels should be used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Methods > TriangleGraphics.SetTransformBehavior Method


TriangleGraphics Properties

TriangleGraphics Properties
Summary

The properties of the TriangleGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
ColorBinding | Property that gets and sets how the colors are defined for the triangle.
ColorIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to an index set.
ColorMapper | Property that gets and sets the GraphicsColorMapper object associated with the set. In order for this mapping to work, scalar (x) values for individual vertices should be specified using the TextureCoordinateSet and TextureCoordinateIndexSet properties. This property defaults to Nothing and can be set to Nothing to remove the reference to a color mapper.
ColorSet | Property that gets and sets the GraphicsColorSet associated with the set.
CoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.
CoordinateSet | Property that gets and sets the GraphicsCoordinateSet associated with the set.
DepthPriority | Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
NormalBinding | Property that gets and sets how the normals are defined for the triangles.
NormalIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the normal set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.
NormalSet | Property that gets and sets the GraphicsNormalSet associated with the set. How the GraphicsNormalSet is used depends on the value of the NormalBinding property.
TextureCoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the texture coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.
TextureCoordinateSet | Property that gets and sets the GraphicsTextureCoordinateSet associated with the set.
You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties


TriangleGraphics.BurnThrough Property

TriangleGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.BurnThrough Property


TriangleGraphics.ColorBinding Property

TriangleGraphics.ColorBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the colors are defined for the triangle.

Visual Basic
Property ColorBinding() As ColorBindingEnum
Remarks

If a color index set is defined, then the order of colors is defined by the index set. If an index is not defined, then the order of the colors in the color set is used. The options are:

  • kOverallColor:The first color in the set is used for the entire triangle set.
  • kPerItemColors: The first color in the set is used for the first triangle, the second color for the second triangle, and so on. If there are more triangles than colors, the last color in the list is used for the remaining triangles. If there are more colors than triangles, the additional colors are ignored.
  • kPerStripColor:Not applicable to TriangleGraphics. Will be interpreted to be the same as kPerItemColor.
  • kPerVertexColor:The first color in the set is used for the first vertex, the second color is used for the second vertex, and so on. Since a different color can be defined for each vertex the color blends along the triangle from one color to the other. If there are more vertices than colors, the last color in the set is used for the remaining vertices. If there are more colors than vertices, the additional colors are ignored.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.ColorBinding Property


TriangleGraphics.ColorIndexSet Property

TriangleGraphics.ColorIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property ColorIndexSet() As GraphicsIndexSet*
Remarks

An index set for colors serves as a color lookup mechanism into the color set. When colors are assigned to the object the order defined by the index set is used instead of the ordering within the color set.

See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.ColorIndexSet Property


TriangleGraphics.ColorMapper Property

TriangleGraphics.ColorMapper Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsColorMapper object associated with the set. In order for this mapping to work, scalar (x) values for individual vertices should be specified using the TextureCoordinateSet and TextureCoordinateIndexSet properties. This property defaults to Nothing and can be set to Nothing to remove the reference to a color mapper.

Visual Basic
Property ColorMapper() As GraphicsColorMapper*
Remarks

Unlike the ColorMapper returned by GrahphicsDataSets.ColorMapper, this property returns a non-transient sharable GraphicsColorMapper object.

See Also

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Example

See GraphicsColorMapper for sample code.

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.ColorMapper Property


TriangleGraphics.ColorSet Property

TriangleGraphics.ColorSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsColorSet associated with the set.

Visual Basic
Property ColorSet() As GraphicsColorSet*
Remarks

How the color set is used depends on the value of the ColorBinding property. If no color set is defined for the triangle set, the render style color defined for the GraphicsNode will be used. If a color set is defined, it overrides the diffuse and ambient colors defined in the render style of the GraphicsNode. This property can be set to Nothing to remove the reference to a color set and return to using the colors defined by the display style of the GraphicsNode.

See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.ColorSet Property


TriangleGraphics.CoordinateIndexSet Property

TriangleGraphics.CoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property CoordinateIndexSet() As GraphicsIndexSet*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.CoordinateIndexSet Property


TriangleGraphics.CoordinateSet Property

TriangleGraphics.CoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsCoordinateSet associated with the set.

Visual Basic
Property CoordinateSet() As GraphicsCoordinateSet*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.CoordinateSet Property


TriangleGraphics.DepthPriority Property

TriangleGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.DepthPriority Property


TriangleGraphics.NormalBinding Property

TriangleGraphics.NormalBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the normals are defined for the triangles.

Visual Basic
Property NormalBinding() As NormalBindingEnum
Remarks

If a normal index set is defined, then the order of normals is defined by the index set. If an index is not defined, then the order of the normals in the normal set is used. The options are:

  • kOverallNormal:The first normal in the set is used for the entire triangle set.
  • kPerItemNormals:The first normal in the set is used for the first triangle, the second normal for the second triangle, and so on. If there are more triangles than normals, the last normal in the list is used for the remaining triangles. If there are more normals than triangles, the additional normals are ignored.
  • kPerStripNormals:Not applicable to TriangleGraphics. Will be interpreted to be the same as kPerItemNormal.
  • kPerVertexNormals:The first normal in the set is used for the first vertex, the second normal is used for the second vertex, and so on. Defining the normals at each vertex can result in a smooth shading of the triangles. If there are more vertices than normals, the last normal in the set is used for the remaining vertices. If there are more normals than vertices, the additional normals are ignored.
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.NormalBinding Property


TriangleGraphics.NormalIndexSet Property

TriangleGraphics.NormalIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the normal set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property NormalIndexSet() As GraphicsIndexSet*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.NormalIndexSet Property


TriangleGraphics.NormalSet Property

TriangleGraphics.NormalSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsNormalSet associated with the set. How the GraphicsNormalSet is used depends on the value of the NormalBinding property.

Visual Basic
Property NormalSet() As GraphicsNormalSet*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.NormalSet Property


TriangleGraphics.TextureCoordinateIndexSet Property

TriangleGraphics.TextureCoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the texture coordinate set to use for the triangles of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property TextureCoordinateIndexSet() As GraphicsIndexSet*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.TextureCoordinateIndexSet Property


TriangleGraphics.TextureCoordinateSet Property

TriangleGraphics.TextureCoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsTextureCoordinateSet associated with the set.

Visual Basic
Property TextureCoordinateSet() As GraphicsTextureCoordinateSet*
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleGraphics Interface > TriangleGraphics Properties > TriangleGraphics.TextureCoordinateSet Property


TriangleStripGraphics Interface

TriangleStripGraphics Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TriangleStripGraphics object defines a set of connected triangles. The first three coordinates define a triangle and the next coordinate defines another triangle using the previous two coordinates.

Class Hierarchy
Inventor::GraphicsPrimitive
    Inventor::TriangleStripGraphics
Visual Basic
Public Interface TriangleStripGraphics
Inherits GraphicsPrimitive
Remarks

Below is an example of the data used to create a TriangleStripGraphics. In this example there is no savings of data when you use an index set. The use of an index set may make sense in the case where you want to use a partial set of a larger coordinate set by indexing the particular coordinates to use.

Coordinate set

(0,0,0), (1,1,0), (2,0,0), (3,1,0), (4,0,0), (5,1,0), (6,0,0), (8,0,0), (7,1,0), (9,1,0)

Strip Lengths

6, 4

The coordinates listed in the set above define the six triangles. The first six coordinates define the four triangles of the first triangle strip. The last four coordinates define the two triangles of the second triangle strip. Looking at strip 1, coordinates 1, 2, and 3 define the first triangle, coordinate 4 creates a new triangle using the previous two coordinates (2 and 3), coordinate 5 creates a new triangle using coordinates 3 and 4, and finally coordinate 6 creates the final triangle using coordinates 4 and 5. The same process is used for the second strip. Coordinates 7, 8 and 9 define the first triangle and coordinate ten adds the second triangle.

The fact that the coordinates define two strips is designated by the strip lengths which describes how many coordinates are used for each strip.

Notes

Members through which this object may be accessed include:

GraphicsNode.AddTriangleStripGraphics

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface


TriangleStripGraphics Methods

TriangleStripGraphics Methods
Summary

The methods of the TriangleStripGraphics class are listed here.

Methods
Methods
Name | Description
GetStripLengths | Method that returns the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.
GetTransformBehavior | Returns the current view transformation settings (e.g. pixel scaling and front facing).
PutStripLengths | Method that sets the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.
SetTransformBehavior | Sets the view transformation settings (e.g. pixel scaling and front facing).
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Methods


TriangleStripGraphics.GetStripLengths Method

TriangleStripGraphics.GetStripLengths Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that returns the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.

Visual Basic
Sub GetStripLengths(ByRef StripLengths As SAFEARRAY(long))
Parameters
Parameters | Description
StripLengths | Array of Longs that defines the strip lengths. The length of a strip is defined by specifying the number of coordinates used for each strip.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Methods > TriangleStripGraphics.GetStripLengths Method


TriangleStripGraphics.GetTransformBehavior Method

TriangleStripGraphics.GetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Returns the current view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub GetTransformBehavior(ByRef TextAnchor As Point*, ByRef BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As double)
Parameters
Parameters | Description
TextAnchor | Output Point that returns the point that is unaffected by the transform behavior.
BehaviorType | Output DisplayTransformBehaviorEnum that returns the transform behaviors currently being used.
PixelScale | Output Point that returns the number of pixels that are used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Methods > TriangleStripGraphics.GetTransformBehavior Method


TriangleStripGraphics.PutStripLengths Method

TriangleStripGraphics.PutStripLengths Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that sets the current strip lengths. The strip lengths are defined by the number of coordinates used for each strip.

Visual Basic
Sub PutStripLengths(ByRef StripLengths As SAFEARRAY(long))
Parameters
Parameters | Description
StripLengths | Array of Longs that defines the strip lengths. The length of a strip is defined by specifying the number of coordinates used for each strip.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Methods > TriangleStripGraphics.PutStripLengths Method


TriangleStripGraphics.SetTransformBehavior Method

TriangleStripGraphics.SetTransformBehavior Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Sets the view transformation settings (e.g. pixel scaling and front facing).

Visual Basic
Sub SetTransformBehavior(Anchor As Point, BehaviorType As DisplayTransformBehaviorEnum, ByRef PixelScale As [defaultvalue(1)] double)
Parameters
Parameters | Description
Anchor | Input Point that indicates which point is unaffected by the transform behavior.
BehaviorType | Input DisplayTransformBehaviorEnum that specifies which transform behaviors are to be used.
PixelScale | Input Double that indicates how many pixels should be used to draw one model unit when pixel scaling is used.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Methods > TriangleStripGraphics.SetTransformBehavior Method


TriangleStripGraphics Properties

TriangleStripGraphics Properties
Summary

The properties of the TriangleStripGraphics class are listed here.

Properties
Name | Description
BurnThrough | Property that specifies whether or not graphics are always visible even if they are blocked by other objects.
ColorBinding | Property that gets and sets how the colors are defined for the triangle.
ColorIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to an index set.
ColorMapper | Property that gets and sets the GraphicsColorMapper object associated with the set. In order for this mapping to work, scalar (x) values for individual vertices should be specified using the TextureCoordinateSet and TextureCoordinateIndexSet properties. This property defaults to Nothing and can be set to Nothing to remove the reference to a color mapper.
ColorSet | Property that gets and sets theGraphics ColorSet associated with the set.
CoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the triangle strips of the set. This property can be set to Nothing to remove the reference to an index set.
CoordinateSet | Property that gets and sets the GraphicsCoordinateSet associated with the set.
DepthPriority | Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.
NormalBinding | Property that gets and sets how the normals are defined for the triangles.
NormalIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indexes within the normal set to use for the lines of the set. This property can be set to Nothing to remove the reference to an index set.
NormalSet | Property that gets and sets the GraphicsNormalSet associated with the set.
TextureCoordinateIndexSet | Property that gets and sets the GraphicsIndexSet that defines the indices within the texture coordinate set to use for the triangles strips of the set. This property can be set to Nothing to remove the reference to an index set.
TextureCoordinateSet | Property that gets and sets the GraphicsTextureCoordinateSet associated with the set.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties


TriangleStripGraphics.BurnThrough Property

TriangleStripGraphics.BurnThrough Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that specifies whether or not graphics are always visible even if they are blocked by other objects.

Visual Basic
Property BurnThrough() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.BurnThrough Property


TriangleStripGraphics.ColorBinding Property

TriangleStripGraphics.ColorBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the colors are defined for the triangle.

Visual Basic
Property ColorBinding() As ColorBindingEnum
Remarks

If a color index set is defined, then the order of colors is defined by the index set. If an index is not defined, then the order of the colors in the color set is used. The options are:

  • kOverallColor:The first color in the color set is used for the entire triangle set.
  • kPerItemColors:The first color in the color set is used for the first triangle, the second color for the second triangle, and so on. If there are more triangles than colors, the last color in the list is used for the remaining triangles. If there are more colors than triangles, the additional colors are ignored.
  • kPerStripColors:The first color in the color set is used for all of the triangles of the first strip, the second color is used for the second strip, and so on. If there are more strips than colors, the last color in the set is used for the remaining strips. If there are more colors than strips, the additional colors are ignored.
  • kPerVertexColors:The first color in the color set is used for the first vertex, the second color is used for the second vertex, and so on. Since a different color can be defined for each vertex the color blends along the triangle from one color to the other. If there are more vertices than colors, the last color in the list is used for the remaining vertices. If there are more colors than vertices, the additional colors are ignored.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.ColorBinding Property


TriangleStripGraphics.ColorIndexSet Property

TriangleStripGraphics.ColorIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the GraphicsColorSet to use. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property ColorIndexSet() As GraphicsIndexSet*
Remarks

An index set for colors serves as a color lookup mechanism into the color set. When colors are assigned to the object the order defined by the index set is used instead of the ordering within the color set.

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.ColorIndexSet Property


TriangleStripGraphics.ColorMapper Property

TriangleStripGraphics.ColorMapper Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsColorMapper object associated with the set. In order for this mapping to work, scalar (x) values for individual vertices should be specified using the TextureCoordinateSet and TextureCoordinateIndexSet properties. This property defaults to Nothing and can be set to Nothing to remove the reference to a color mapper.

Visual Basic
Property ColorMapper() As GraphicsColorMapper*
Remarks

Unlike the ColorMapper returned by GrahphicsDataSets.ColorMapper, this property returns a non-transient sharable GraphicsColorMapper object.

Example

See GraphicsColorMapper for sample code.

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.ColorMapper Property


TriangleStripGraphics.ColorSet Property

TriangleStripGraphics.ColorSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets theGraphics ColorSet associated with the set.

Visual Basic
Property ColorSet() As GraphicsColorSet*
Remarks

How the GraphicsColorSet is interpreted depends on the value of the ColorBinding property. If no color set is defined for the triangle strip set, the render style color defined for the GraphicsNode will be used. If a color set is defined, it overrides the diffuse, and ambient colors defined in the render style of the GraphicsNode. This property can be set to Nothing to remove the reference to a color set and return to using the colors defined by the display style of the GraphicsNode.

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.ColorSet Property


TriangleStripGraphics.CoordinateIndexSet Property

TriangleStripGraphics.CoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the coordinate set to use for the triangle strips of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property CoordinateIndexSet() As GraphicsIndexSet*
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.CoordinateIndexSet Property


TriangleStripGraphics.CoordinateSet Property

TriangleStripGraphics.CoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsCoordinateSet associated with the set.

Visual Basic
Property CoordinateSet() As GraphicsCoordinateSet*
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.CoordinateSet Property


TriangleStripGraphics.DepthPriority Property

TriangleStripGraphics.DepthPriority Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that allows you to specify a priority to a set. This is used in the cases where entities are coincident. The entities with the higher priority will render on top of lower priority entities.

Visual Basic
Property DepthPriority() As long
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.DepthPriority Property


TriangleStripGraphics.NormalBinding Property

TriangleStripGraphics.NormalBinding Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets how the normals are defined for the triangles.

Visual Basic
Property NormalBinding() As NormalBindingEnum
Remarks

If a normal index set is defined, then the order of normals is defined by the index set. If an index is not defined, then the order of the normals in the normal set is used. The options are:

  • kOverallNormal:The first normal in the set is used for the entire triangle set.
  • kPerItemNormal: The first normal in the set is used for the first triangle, the second normal for the second triangle, and so on. If there are more triangles than normals, the last normal in the list is used for the remaining triangles. If there are more normals than triangles, the additional normals are ignored.
  • kPerStripNormal:The first normal in the set is used for the first strip, the second normal is used for the second strip, and so on. If there are more strips than normals, the last normal in the set is used for the remaining strips. If there are more normals than strips, the additional normals are ignored.
  • kPerVertexNormal:The first normal in the set is used for the first vertex, the second normal is used for the second vertex, and so on. Defining the normals at each vertex can result in a smooth shading of the triangles. If there are more vertices than normals, the last normal in the set is used for the remaining vertices. If there are more normals than vertices, the additional normals are ignored.
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.NormalBinding Property


TriangleStripGraphics.NormalIndexSet Property

TriangleStripGraphics.NormalIndexSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsIndexSet that defines the indexes within the normal set to use for the lines of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property NormalIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.NormalIndexSet Property


TriangleStripGraphics.NormalSet Property

TriangleStripGraphics.NormalSet Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that gets and sets the GraphicsNormalSet associated with the set.

Visual Basic
Property NormalSet() As GraphicsNormalSet*
See Also

Client Graphics - Triangle sample

You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.NormalSet Property


TriangleStripGraphics.TextureCoordinateIndexSet Property

TriangleStripGraphics.TextureCoordinateIndexSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsIndexSet that defines the indices within the texture coordinate set to use for the triangles strips of the set. This property can be set to Nothing to remove the reference to an index set.

Visual Basic
Property TextureCoordinateIndexSet() As GraphicsIndexSet*
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.TextureCoordinateIndexSet Property


TriangleStripGraphics.TextureCoordinateSet Property

TriangleStripGraphics.TextureCoordinateSet Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the GraphicsTextureCoordinateSet associated with the set.

Visual Basic
Property TextureCoordinateSet() As GraphicsTextureCoordinateSet*
You are here: Symbol Reference > Inventor Library > Objects > TriangleStripGraphics Interface > TriangleStripGraphics Properties > TriangleStripGraphics.TextureCoordinateSet Property


TrimFeature Interface

TrimFeature Interface Available in Inventor Available in Server Introduced in Inventor 11
Class Hierarchy
Inventor::PartFeature
    Inventor::TrimFeature
        Inventor::TrimFeatureProxy
Visual Basic
Public Interface TrimFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

TrimFeatureProxy.NativeObject

TrimFeatures.Item

For information on this object, please refer to PartFeature, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > TrimFeature Interface


TrimFeatureProxy Interface

TrimFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TrimFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::TrimFeature
        Inventor::TrimFeatureProxy
Visual Basic
Public Interface TrimFeatureProxy
Inherits TrimFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatureProxy Interface


TrimFeatureProxy Properties

TrimFeatureProxy Properties
Summary

The properties of the TrimFeatureProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TrimFeatureProxy Interface > TrimFeatureProxy Properties


TrimFeatureProxy.ContainingOccurrence Property

TrimFeatureProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatureProxy Interface > TrimFeatureProxy Properties > TrimFeatureProxy.ContainingOccurrence Property


TrimFeatureProxy.NativeObject Property

TrimFeatureProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TrimFeature**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatureProxy Interface > TrimFeatureProxy Properties > TrimFeatureProxy.NativeObject Property


TrimFeatures Interface

TrimFeatures Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The TrimFeatures collection provides access to all of the TrimFeature objects in a component definition.

Class Hierarchy
Inventor::TrimFeatures
Visual Basic
Public Interface TrimFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartFeatures.TrimFeatures

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface


TrimFeatures Methods

TrimFeatures Methods
Summary

The methods of the TrimFeatures class are listed here.

Methods
Methods
Name | Description
Item |
You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface > TrimFeatures Methods


TrimFeatures.Item Method

TrimFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] TrimFeature*)
Notes

For information on this item, please refer to PartFeatures::Item, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface > TrimFeatures Methods > TrimFeatures.Item Method


TrimFeatures Properties

TrimFeatures Properties
Summary

The properties of the TrimFeatures class are listed here.

Properties
Name | Description
Application |
Count |
Type |
You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface > TrimFeatures Properties


TrimFeatures.Application Property

TrimFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Property Application() As IDispatch**
Notes

For information on this item, please refer to PartFeatures::Application, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface > TrimFeatures Properties > TrimFeatures.Application Property


TrimFeatures.Count Property

TrimFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Property Count() As long*
Notes

For information on this item, please refer to PartFeatures::Count, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface > TrimFeatures Properties > TrimFeatures.Count Property


TrimFeatures.Type Property

TrimFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 11
Visual Basic
Property Type() As ObjectTypeEnum*
Notes

For information on this item, please refer to PartFeatures::Type, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > TrimFeatures Interface > TrimFeatures Properties > TrimFeatures.Type Property


TwoDistancesChamferDef Interface

TwoDistancesChamferDef Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The TwoDistancesChamferDef object provides access to the information that defines the variables for a chamfer feature created using two distances.

Class Hierarchy
Inventor::ChamferDefinition
    Inventor::TwoDistancesChamferDef
Visual Basic
Public Interface TwoDistancesChamferDef
Inherits ChamferDefinition
You are here: Symbol Reference > Inventor Library > Objects > TwoDistancesChamferDef Interface


TwoDistancesChamferDef Properties

TwoDistancesChamferDef Properties
Summary

The properties of the TwoDistancesChamferDef class are listed here.

Properties
Name | Description
DistanceOne | Property that returns the parameter that controls the first distance used for the chamfer feature.
DistanceTwo | Property that returns the parameter that controls the second distance used for the chamfer feature.
Face | Property that specifies the Face whose edges to chamfer.
You are here: Symbol Reference > Inventor Library > Objects > TwoDistancesChamferDef Interface > TwoDistancesChamferDef Properties


TwoDistancesChamferDef.DistanceOne Property

TwoDistancesChamferDef.DistanceOne Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the first distance used for the chamfer feature.

Visual Basic
Property DistanceOne() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > TwoDistancesChamferDef Interface > TwoDistancesChamferDef Properties > TwoDistancesChamferDef.DistanceOne Property


TwoDistancesChamferDef.DistanceTwo Property

TwoDistancesChamferDef.DistanceTwo Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the parameter that controls the second distance used for the chamfer feature.

Visual Basic
Property DistanceTwo() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > TwoDistancesChamferDef Interface > TwoDistancesChamferDef Properties > TwoDistancesChamferDef.DistanceTwo Property


TwoDistancesChamferDef.Face Property

TwoDistancesChamferDef.Face Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that specifies the Face whose edges to chamfer.

Visual Basic
Property Face() As Face**
You are here: Symbol Reference > Inventor Library > Objects > TwoDistancesChamferDef Interface > TwoDistancesChamferDef Properties > TwoDistancesChamferDef.Face Property


TwoLineAngleDimConstraint Interface

TwoLineAngleDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TwoLineAngleDimConstraint object represents a constraint that controls the angle between two lines.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::TwoLineAngleDimConstraint
        Inventor::TwoLineAngleDimConstraintProxy
Visual Basic
Public Interface TwoLineAngleDimConstraint
Inherits DimensionConstraint
Remarks

The picture below illustrates the use of this constraint.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddTwoLineAngle

TwoLineAngleDimConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint Interface


TwoLineAngleDimConstraint Properties

TwoLineAngleDimConstraint Properties
Summary

The properties of the TwoLineAngleDimConstraint class are listed here.

Properties
Name | Description
LineOne | Property that returns the first sketch line being constrained.
LineTwo | Property that returns the second sketch line being constrained.
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint Interface > TwoLineAngleDimConstraint Properties


TwoLineAngleDimConstraint.LineOne Property

TwoLineAngleDimConstraint.LineOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first sketch line being constrained.

Visual Basic
Property LineOne() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint Interface > TwoLineAngleDimConstraint Properties > TwoLineAngleDimConstraint.LineOne Property


TwoLineAngleDimConstraint.LineTwo Property

TwoLineAngleDimConstraint.LineTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second sketch line being constrained.

Visual Basic
Property LineTwo() As SketchLine**
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint Interface > TwoLineAngleDimConstraint Properties > TwoLineAngleDimConstraint.LineTwo Property


TwoLineAngleDimConstraint3D Interface

TwoLineAngleDimConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The TwoLineAngleDimConstraint3D object represents a constraint that controls the angle between two 3D sketch lines.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::TwoLineAngleDimConstraint3D
        Inventor::TwoLineAngleDimConstraint3DProxy
Visual Basic
Public Interface TwoLineAngleDimConstraint3D
Inherits DimensionConstraint3D
Notes

Members through which this object may be accessed include:

DimensionConstraints3D.AddTwoLineAngle

TwoLineAngleDimConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3D Interface


TwoLineAngleDimConstraint3D Properties

TwoLineAngleDimConstraint3D Properties
Summary

The properties of the TwoLineAngleDimConstraint3D class are listed here.

Properties
Name | Description
LineOne | Property that returns the first 3D sketch line being constrained.
LineTwo | Property that returns the second 3D sketch line being constrained.
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3D Interface > TwoLineAngleDimConstraint3D Properties


TwoLineAngleDimConstraint3D.LineOne Property

TwoLineAngleDimConstraint3D.LineOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the first 3D sketch line being constrained.

Visual Basic
Property LineOne() As SketchLine3D**
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3D Interface > TwoLineAngleDimConstraint3D Properties > TwoLineAngleDimConstraint3D.LineOne Property


TwoLineAngleDimConstraint3D.LineTwo Property

TwoLineAngleDimConstraint3D.LineTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the second 3D sketch line being constrained.

Visual Basic
Property LineTwo() As SketchLine3D**
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3D Interface > TwoLineAngleDimConstraint3D Properties > TwoLineAngleDimConstraint3D.LineTwo Property


TwoLineAngleDimConstraint3DProxy Interface

TwoLineAngleDimConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoLineAngleDimConstraint3D object.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::TwoLineAngleDimConstraint3D
        Inventor::TwoLineAngleDimConstraint3DProxy
Visual Basic
Public Interface TwoLineAngleDimConstraint3DProxy
Inherits TwoLineAngleDimConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3DProxy Interface


TwoLineAngleDimConstraint3DProxy Properties

TwoLineAngleDimConstraint3DProxy Properties
Summary

The properties of the TwoLineAngleDimConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3DProxy Interface > TwoLineAngleDimConstraint3DProxy Properties


TwoLineAngleDimConstraint3DProxy.ContainingOccurrence Property

TwoLineAngleDimConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3DProxy Interface > TwoLineAngleDimConstraint3DProxy Properties > TwoLineAngleDimConstraint3DProxy.ContainingOccurrence Property


TwoLineAngleDimConstraint3DProxy.NativeObject Property

TwoLineAngleDimConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TwoLineAngleDimConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraint3DProxy Interface > TwoLineAngleDimConstraint3DProxy Properties > TwoLineAngleDimConstraint3DProxy.NativeObject Property


TwoLineAngleDimConstraintProxy Interface

TwoLineAngleDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoLineAngleDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::TwoLineAngleDimConstraint
        Inventor::TwoLineAngleDimConstraintProxy
Visual Basic
Public Interface TwoLineAngleDimConstraintProxy
Inherits TwoLineAngleDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraintProxy Interface


TwoLineAngleDimConstraintProxy Properties

TwoLineAngleDimConstraintProxy Properties
Summary

The properties of the TwoLineAngleDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraintProxy Interface > TwoLineAngleDimConstraintProxy Properties


TwoLineAngleDimConstraintProxy.ContainingOccurrence Property

TwoLineAngleDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraintProxy Interface > TwoLineAngleDimConstraintProxy Properties > TwoLineAngleDimConstraintProxy.ContainingOccurrence Property


TwoLineAngleDimConstraintProxy.NativeObject Property

TwoLineAngleDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TwoLineAngleDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoLineAngleDimConstraintProxy Interface > TwoLineAngleDimConstraintProxy Properties > TwoLineAngleDimConstraintProxy.NativeObject Property


TwoLinesWorkPlaneDef Interface

TwoLinesWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work plane defined by two lines.

Class Hierarchy
Inventor::TwoLinesWorkPlaneDef
Visual Basic
Public Interface TwoLinesWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface


TwoLinesWorkPlaneDef Methods

TwoLinesWorkPlaneDef Methods
Summary

The methods of the TwoLinesWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work planed defined by a two lines. Line1 defines the X-axis.
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Methods


TwoLinesWorkPlaneDef.GetData Method

TwoLinesWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work planed defined by a two lines. Line1 defines the X-axis.

Visual Basic
Sub GetData(ByRef Line1 As IDispatch*, ByRef Line2 As IDispatch*)
Parameters
Parameters | Description
Line1 | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Line2 | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Methods > TwoLinesWorkPlaneDef.GetData Method


TwoLinesWorkPlaneDef Properties

TwoLinesWorkPlaneDef Properties
Summary

The properties of the TwoLinesWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Line1 | Property that returns the first line of the two line defined work plane. This line defines the X-axis of the work plane. This object can be a linear Edge, WorkAxis, or SketchLine object.
Line2 | Property that returns the second line of the two line defined work plane. This object can be a linear Edge, WorkAxis, or SketchLine object.
Parent | Property returning the parent WorkPlane object.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Properties


TwoLinesWorkPlaneDef.Application Property

TwoLinesWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Properties > TwoLinesWorkPlaneDef.Application Property


TwoLinesWorkPlaneDef.Line1 Property

TwoLinesWorkPlaneDef.Line1 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the first line of the two line defined work plane. This line defines the X-axis of the work plane. This object can be a linear Edge, WorkAxis, or SketchLine object.

Visual Basic
Property Line1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Properties > TwoLinesWorkPlaneDef.Line1 Property


TwoLinesWorkPlaneDef.Line2 Property

TwoLinesWorkPlaneDef.Line2 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the second line of the two line defined work plane. This object can be a linear Edge, WorkAxis, or SketchLine object.

Visual Basic
Property Line2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Properties > TwoLinesWorkPlaneDef.Line2 Property


TwoLinesWorkPlaneDef.Parent Property

TwoLinesWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Properties > TwoLinesWorkPlaneDef.Parent Property


TwoLinesWorkPlaneDef.Type Property

TwoLinesWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPlaneDef Interface > TwoLinesWorkPlaneDef Properties > TwoLinesWorkPlaneDef.Type Property


TwoLinesWorkPointDef Interface

TwoLinesWorkPointDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work point defined by the intersection of two lines.

Class Hierarchy
Inventor::TwoLinesWorkPointDef
Visual Basic
Public Interface TwoLinesWorkPointDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface


TwoLinesWorkPointDef Methods

TwoLinesWorkPointDef Methods
Summary

The methods of the TwoLinesWorkPointDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work point at the intersection of two lines.
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Methods


TwoLinesWorkPointDef.GetData Method

TwoLinesWorkPointDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work point at the intersection of two lines.

Visual Basic
Sub GetData(ByRef Line1 As IDispatch*, ByRef Line2 As IDispatch*)
Parameters
Parameters | Description
Line1 | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Line2 | Output object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Methods > TwoLinesWorkPointDef.GetData Method


TwoLinesWorkPointDef Properties

TwoLinesWorkPointDef Properties
Summary

The properties of the TwoLinesWorkPointDef class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Line1 | Property that returns the first line of a work point that is defined by the intersection of two lines. This object can be a linear Edge, WorkAxis, or SketchLine object.
Line2 | Property that returns the second line of a work point that is defined by the intersection of two lines. This object can be a linear Edge, WorkAxis, or SketchLine object..
Parent | Property returning the parent WorkPoint object.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Properties


TwoLinesWorkPointDef.Application Property

TwoLinesWorkPointDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Properties > TwoLinesWorkPointDef.Application Property


TwoLinesWorkPointDef.Line1 Property

TwoLinesWorkPointDef.Line1 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the first line of a work point that is defined by the intersection of two lines. This object can be a linear Edge, WorkAxis, or SketchLine object.

Visual Basic
Property Line1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Properties > TwoLinesWorkPointDef.Line1 Property


TwoLinesWorkPointDef.Line2 Property

TwoLinesWorkPointDef.Line2 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the second line of a work point that is defined by the intersection of two lines. This object can be a linear Edge, WorkAxis, or SketchLine object..

Visual Basic
Property Line2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Properties > TwoLinesWorkPointDef.Line2 Property


TwoLinesWorkPointDef.Parent Property

TwoLinesWorkPointDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkPoint object.

Visual Basic
Property Parent() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Properties > TwoLinesWorkPointDef.Parent Property


TwoLinesWorkPointDef.Type Property

TwoLinesWorkPointDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TwoLinesWorkPointDef Interface > TwoLinesWorkPointDef Properties > TwoLinesWorkPointDef.Type Property


TwoPlanesWorkAxisDef Interface

TwoPlanesWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work axis along a line.

Class Hierarchy
Inventor::TwoPlanesWorkAxisDef
Visual Basic
Public Interface TwoPlanesWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface


TwoPlanesWorkAxisDef Methods

TwoPlanesWorkAxisDef Methods
Summary

The methods of the TwoPlanesWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work axis at the intersection of two planes.
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Methods


TwoPlanesWorkAxisDef.GetData Method

TwoPlanesWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work axis at the intersection of two planes.

Visual Basic
Sub GetData(ByRef Plane1 As IDispatch*, ByRef Plane2 As IDispatch*)
Parameters
Parameters | Description
Plane1 | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2 | Output object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Methods > TwoPlanesWorkAxisDef.GetData Method


TwoPlanesWorkAxisDef Properties

TwoPlanesWorkAxisDef Properties
Summary

The properties of the TwoPlanesWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Parent | Property returning the parent WorkAxis object.
Plane1 | Property that returns the plane of a two plane defined work axis. This object can be a planar Face, WorkPlane, or Sketch object. The work axis is at the intersection of the two planes.
Plane2 | Property that returns the plane of a two plane defined work axis. This object can be a planar Face, WorkPlane, or Sketch object. The work axis is at the intersection of the two planes.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Properties


TwoPlanesWorkAxisDef.Application Property

TwoPlanesWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Properties > TwoPlanesWorkAxisDef.Application Property


TwoPlanesWorkAxisDef.Parent Property

TwoPlanesWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Properties > TwoPlanesWorkAxisDef.Parent Property


TwoPlanesWorkAxisDef.Plane1 Property

TwoPlanesWorkAxisDef.Plane1 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the plane of a two plane defined work axis. This object can be a planar Face, WorkPlane, or Sketch object. The work axis is at the intersection of the two planes.

Visual Basic
Property Plane1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Properties > TwoPlanesWorkAxisDef.Plane1 Property


TwoPlanesWorkAxisDef.Plane2 Property

TwoPlanesWorkAxisDef.Plane2 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the plane of a two plane defined work axis. This object can be a planar Face, WorkPlane, or Sketch object. The work axis is at the intersection of the two planes.

Visual Basic
Property Plane2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Properties > TwoPlanesWorkAxisDef.Plane2 Property


TwoPlanesWorkAxisDef.Type Property

TwoPlanesWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkAxisDef Interface > TwoPlanesWorkAxisDef Properties > TwoPlanesWorkAxisDef.Type Property


TwoPlanesWorkPlaneDef Interface

TwoPlanesWorkPlaneDef Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The TwoPlanesWorkPlaneDef object that allows you to get and set the information that specifies a work a work plane defined by two planes.

Class Hierarchy
Inventor::TwoPlanesWorkPlaneDef
Visual Basic
Public Interface TwoPlanesWorkPlaneDef
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface


TwoPlanesWorkPlaneDef Methods

TwoPlanesWorkPlaneDef Methods
Summary

The methods of the TwoPlanesWorkPlaneDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work plane defined by a two planes. Plane1 defines the X-axis.
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Methods


TwoPlanesWorkPlaneDef.GetData Method

TwoPlanesWorkPlaneDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that gets all of the data defining a work plane defined by a two planes. Plane1 defines the X-axis.

Visual Basic
Sub GetData(ByRef Plane1 As IDispatch*, ByRef Plane2 As IDispatch*)
Parameters
Parameters | Description
Plane1 | Output object that represents a plane. This object can be a planar Face or a WorkPlane object.
Plane2 | Output object that represents a plane. This object can be a planar Face or a WorkPlane object.
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Methods > TwoPlanesWorkPlaneDef.GetData Method


TwoPlanesWorkPlaneDef Properties

TwoPlanesWorkPlaneDef Properties
Summary

The properties of the TwoPlanesWorkPlaneDef class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Parent | Property that returns the parent WorkPlane object.
Plane1 | Property that returns the first plane of the two-plane-defined work plane This object can be a planar Face or a WorkPlane object.
Plane2 | Property that returns the second plane of the two plane defined work plane This object can be a planar Face or a WorkPlane object.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Properties


TwoPlanesWorkPlaneDef.Application Property

TwoPlanesWorkPlaneDef.Application Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Properties > TwoPlanesWorkPlaneDef.Application Property


TwoPlanesWorkPlaneDef.Parent Property

TwoPlanesWorkPlaneDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent WorkPlane object.

Visual Basic
Property Parent() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Properties > TwoPlanesWorkPlaneDef.Parent Property


TwoPlanesWorkPlaneDef.Plane1 Property

TwoPlanesWorkPlaneDef.Plane1 Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the first plane of the two-plane-defined work plane This object can be a planar Face or a WorkPlane object.

Visual Basic
Property Plane1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Properties > TwoPlanesWorkPlaneDef.Plane1 Property


TwoPlanesWorkPlaneDef.Plane2 Property

TwoPlanesWorkPlaneDef.Plane2 Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the second plane of the two plane defined work plane This object can be a planar Face or a WorkPlane object.

Visual Basic
Property Plane2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Properties > TwoPlanesWorkPlaneDef.Plane2 Property


TwoPlanesWorkPlaneDef.Type Property

TwoPlanesWorkPlaneDef.Type Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TwoPlanesWorkPlaneDef Interface > TwoPlanesWorkPlaneDef Properties > TwoPlanesWorkPlaneDef.Type Property


TwoPointDistanceDimConstraint Interface

TwoPointDistanceDimConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The TwoPointDistanceDimConstraint object represents a constraint that controls the distance between two points. The vertical, horizontal, or true distance can be controlled.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::TwoPointDistanceDimConstraint
        Inventor::TwoPointDistanceDimConstraintProxy
Visual Basic
Public Interface TwoPointDistanceDimConstraint
Inherits DimensionConstraint
Remarks

The picture below illustrates the three possible cases with this constraint.

Notes

Members through which this object may be accessed include:

DimensionConstraints.AddTwoPointDistance

TwoPointDistanceDimConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint Interface


TwoPointDistanceDimConstraint Properties

TwoPointDistanceDimConstraint Properties
Summary

The properties of the TwoPointDistanceDimConstraint class are listed here.

Properties
Name | Description
Orientation | Property that indicates an enum indicating if the constraint is controlling the horizontal, vertical, or true distance between the points.
PointOne | Property that returns the first sketch point being constrained.
PointTwo | Property that returns the second sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint Interface > TwoPointDistanceDimConstraint Properties


TwoPointDistanceDimConstraint.Orientation Property

TwoPointDistanceDimConstraint.Orientation Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that indicates an enum indicating if the constraint is controlling the horizontal, vertical, or true distance between the points.

Visual Basic
Property Orientation() As DimensionOrientationEnum*
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint Interface > TwoPointDistanceDimConstraint Properties > TwoPointDistanceDimConstraint.Orientation Property


TwoPointDistanceDimConstraint.PointOne Property

TwoPointDistanceDimConstraint.PointOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first sketch point being constrained.

Visual Basic
Property PointOne() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint Interface > TwoPointDistanceDimConstraint Properties > TwoPointDistanceDimConstraint.PointOne Property


TwoPointDistanceDimConstraint.PointTwo Property

TwoPointDistanceDimConstraint.PointTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second sketch point being constrained.

Visual Basic
Property PointTwo() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint Interface > TwoPointDistanceDimConstraint Properties > TwoPointDistanceDimConstraint.PointTwo Property


TwoPointDistanceDimConstraint3D Interface

TwoPointDistanceDimConstraint3D Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

The TwoPointDistanceDimConstraint3D object represents a constraint that controls the distance between two 3D sketch points.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::TwoPointDistanceDimConstraint3D
        Inventor::TwoPointDistanceDimConstraint3DProxy
Visual Basic
Public Interface TwoPointDistanceDimConstraint3D
Inherits DimensionConstraint3D
Notes

Members through which this object may be accessed include:

DimensionConstraints3D.AddTwoPointDistance

TwoPointDistanceDimConstraint3DProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3D Interface


TwoPointDistanceDimConstraint3D Properties

TwoPointDistanceDimConstraint3D Properties
Summary

The properties of the TwoPointDistanceDimConstraint3D class are listed here.

Properties
Name | Description
PointOne | Property that returns the SketchPoint3D object that defines the first point being constrained.
PointTwo | Property that returns the SketchPoint3D object that defines the second point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3D Interface > TwoPointDistanceDimConstraint3D Properties


TwoPointDistanceDimConstraint3D.PointOne Property

TwoPointDistanceDimConstraint3D.PointOne Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the SketchPoint3D object that defines the first point being constrained.

Visual Basic
Property PointOne() As IDispatch**
Remarks

If a vertex or workpoint was specified when the constraint was created, then a 3D sketch point would have been created at the specified vertex or workpoint and this property will return that 3D sketch point.

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3D Interface > TwoPointDistanceDimConstraint3D Properties > TwoPointDistanceDimConstraint3D.PointOne Property


TwoPointDistanceDimConstraint3D.PointTwo Property

TwoPointDistanceDimConstraint3D.PointTwo Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the SketchPoint3D object that defines the second point being constrained.

Visual Basic
Property PointTwo() As IDispatch**
Remarks

If a vertex or workpoint was specified when the constraint was created, then a 3D sketch point would have been created at the specified vertex or workpoint and this property will return that 3D sketch point.

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3D Interface > TwoPointDistanceDimConstraint3D Properties > TwoPointDistanceDimConstraint3D.PointTwo Property


TwoPointDistanceDimConstraint3DProxy Interface

TwoPointDistanceDimConstraint3DProxy Interface Available in Inventor Available in Server Introduced in Inventor 11
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoPointDistanceDimConstraint3D object.

Class Hierarchy
Inventor::DimensionConstraint3D
    Inventor::TwoPointDistanceDimConstraint3D
        Inventor::TwoPointDistanceDimConstraint3DProxy
Visual Basic
Public Interface TwoPointDistanceDimConstraint3DProxy
Inherits TwoPointDistanceDimConstraint3D
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3DProxy Interface


TwoPointDistanceDimConstraint3DProxy Properties

TwoPointDistanceDimConstraint3DProxy Properties
Summary

The properties of the TwoPointDistanceDimConstraint3DProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3DProxy Interface > TwoPointDistanceDimConstraint3DProxy Properties


TwoPointDistanceDimConstraint3DProxy.ContainingOccurrence Property

TwoPointDistanceDimConstraint3DProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3DProxy Interface > TwoPointDistanceDimConstraint3DProxy Properties > TwoPointDistanceDimConstraint3DProxy.ContainingOccurrence Property


TwoPointDistanceDimConstraint3DProxy.NativeObject Property

TwoPointDistanceDimConstraint3DProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TwoPointDistanceDimConstraint3D**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraint3DProxy Interface > TwoPointDistanceDimConstraint3DProxy Properties > TwoPointDistanceDimConstraint3DProxy.NativeObject Property


TwoPointDistanceDimConstraintProxy Interface

TwoPointDistanceDimConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the TwoPointDistanceDimConstraint object.

Class Hierarchy
Inventor::DimensionConstraint
    Inventor::TwoPointDistanceDimConstraint
        Inventor::TwoPointDistanceDimConstraintProxy
Visual Basic
Public Interface TwoPointDistanceDimConstraintProxy
Inherits TwoPointDistanceDimConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraintProxy Interface


TwoPointDistanceDimConstraintProxy Properties

TwoPointDistanceDimConstraintProxy Properties
Summary

The properties of the TwoPointDistanceDimConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraintProxy Interface > TwoPointDistanceDimConstraintProxy Properties


TwoPointDistanceDimConstraintProxy.ContainingOccurrence Property

TwoPointDistanceDimConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraintProxy Interface > TwoPointDistanceDimConstraintProxy Properties > TwoPointDistanceDimConstraintProxy.ContainingOccurrence Property


TwoPointDistanceDimConstraintProxy.NativeObject Property

TwoPointDistanceDimConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As TwoPointDistanceDimConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > TwoPointDistanceDimConstraintProxy Interface > TwoPointDistanceDimConstraintProxy Properties > TwoPointDistanceDimConstraintProxy.NativeObject Property


TwoPointsWorkAxisDef Interface

TwoPointsWorkAxisDef Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that allows you to get and set the information that specifies a work axis along a line.

Class Hierarchy
Inventor::TwoPointsWorkAxisDef
Visual Basic
Public Interface TwoPointsWorkAxisDef
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkAxis.Definition

WorkPlane.Definition

WorkPoint.Definition

You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface


TwoPointsWorkAxisDef Methods

TwoPointsWorkAxisDef Methods
Summary

The methods of the TwoPointsWorkAxisDef class are listed here.

Methods
Methods
Name | Description
GetData | Method that gets all of the data defining a work axis between two points.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Methods


TwoPointsWorkAxisDef.GetData Method

TwoPointsWorkAxisDef.GetData Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets all of the data defining a work axis between two points.

Visual Basic
Sub GetData(ByRef Point1 As IDispatch*, ByRef Point2 As IDispatch*)
Parameters
Parameters | Description
Point1 | Output object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point2 | Output object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Methods > TwoPointsWorkAxisDef.GetData Method


TwoPointsWorkAxisDef Properties

TwoPointsWorkAxisDef Properties
Summary

The properties of the TwoPointsWorkAxisDef class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Parent | Property returning the parent WorkAxis object.
Point1 | Property that returns the first point of a two point defined work axis. This object can be a WorkPoint, Vertex, or SketchPoint object. The work axis runs between the two points.
Point2 | Property that returns the second point of a two point defined work axis. This object can be a WorkPoint, Vertex, or SketchPoint object. The work axis runs between the two points.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Properties


TwoPointsWorkAxisDef.Application Property

TwoPointsWorkAxisDef.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Properties > TwoPointsWorkAxisDef.Application Property


TwoPointsWorkAxisDef.Parent Property

TwoPointsWorkAxisDef.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent WorkAxis object.

Visual Basic
Property Parent() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Properties > TwoPointsWorkAxisDef.Parent Property


TwoPointsWorkAxisDef.Point1 Property

TwoPointsWorkAxisDef.Point1 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the first point of a two point defined work axis. This object can be a WorkPoint, Vertex, or SketchPoint object. The work axis runs between the two points.

Visual Basic
Property Point1() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Properties > TwoPointsWorkAxisDef.Point1 Property


TwoPointsWorkAxisDef.Point2 Property

TwoPointsWorkAxisDef.Point2 Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the second point of a two point defined work axis. This object can be a WorkPoint, Vertex, or SketchPoint object. The work axis runs between the two points.

Visual Basic
Property Point2() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Properties > TwoPointsWorkAxisDef.Point2 Property


TwoPointsWorkAxisDef.Type Property

TwoPointsWorkAxisDef.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > TwoPointsWorkAxisDef Interface > TwoPointsWorkAxisDef Properties > TwoPointsWorkAxisDef.Type Property


UnfoldFeature Interface

UnfoldFeature Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The UnfoldFeature object (together with it's complementary RefoldFeature object) allows sheet metal features to be added when the model is flat (unfolded) and then the model can be refolded.

Class Hierarchy
Inventor::PartFeature
    Inventor::UnfoldFeature
        Inventor::UnfoldFeatureProxy
Visual Basic
Public Interface UnfoldFeature
Inherits PartFeature
Notes

Members through which this object may be accessed include:

UnfoldFeatures.Add

UnfoldFeatures.Item

You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface


UnfoldFeature Methods

UnfoldFeature Methods
Summary

The methods of the UnfoldFeature class are listed here.

Methods
Methods
Name | Description
Edit | Method that edits an existing unfold feature. The stop node should be positioned immediately before this feature before calling this method so that all of the input is available and in a valid state.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Methods


UnfoldFeature.Edit Method

UnfoldFeature.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that edits an existing unfold feature. The stop node should be positioned immediately before this feature before calling this method so that all of the input is available and in a valid state.

Visual Basic
Sub Edit(StationaryFace As Face, ByRef Bends As [optional] VARIANT, ByRef Sketches As [optional] VARIANT)
Parameters
Parameters | Description
StationaryFace | Input Face object that specifies the geometry that will remain fixed while other geometry unfolds. See Remarks.
Bends | Optional input ObjectCollection that defines the bend(s) to unfold. The bends specified must be in a folded state (IsFlat equals False). Not providing this argument or inputting Nothing indicates that all flat bends are to be unfolded.
Sketches | Optional input ObjectCollection that specifies any sketches to be copied and transformed as part of the unfolding operation. The input sketches must be a child of one of the faces being unfolded. Also only one sketch per unfolded face is allowed.
Remarks

For most models the Face specified in the StationaryFace parameter must be on the top or bottom of the part, not around the edge. The exception to this is a part where all of the faces on the top and bottom of the part are cylindrical, as shown below.

When using the Refold command in the user interface for parts like this, the user must specify one of the ends. The user interface displays what looks like work planes at each end of the part, as shown below, for the user to select. When using the API you must supply the equivalent Face objects at the end of the part.

You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Methods > UnfoldFeature.Edit Method


UnfoldFeature Properties

UnfoldFeature Properties
Summary

The properties of the UnfoldFeature class are listed here.

Properties
Name | Description
Bends | Property that returns the collection of Bend objects unfolded by this feature.
InputSketches | Property that returns the sketches that were specifies as input when creating this feature.
ResultSketches | Property that returns the sketches that were created as a result of this feature. The ReferencedEntity property of the sketches returned will return the input sketch this result is based on.
StationaryFace | Property that returns the Face object that was specified as the stationary face during creation. This property can return Nothing in the case where the face has been consumed by another operation and no longer exists in the model. Rolling back the state of the model to a point where the face exists will allow you to access it.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Properties


UnfoldFeature.Bends Property

UnfoldFeature.Bends Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the collection of Bend objects unfolded by this feature.

Visual Basic
Property Bends() As BendsEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Properties > UnfoldFeature.Bends Property


UnfoldFeature.InputSketches Property

UnfoldFeature.InputSketches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketches that were specifies as input when creating this feature.

Visual Basic
Property InputSketches() As SketchesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Properties > UnfoldFeature.InputSketches Property


UnfoldFeature.ResultSketches Property

UnfoldFeature.ResultSketches Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the sketches that were created as a result of this feature. The ReferencedEntity property of the sketches returned will return the input sketch this result is based on.

Visual Basic
Property ResultSketches() As SketchesEnumerator**
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Properties > UnfoldFeature.ResultSketches Property


UnfoldFeature.StationaryFace Property

UnfoldFeature.StationaryFace Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the Face object that was specified as the stationary face during creation. This property can return Nothing in the case where the face has been consumed by another operation and no longer exists in the model. Rolling back the state of the model to a point where the face exists will allow you to access it.

Visual Basic
Property StationaryFace() As Face**
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeature Interface > UnfoldFeature Properties > UnfoldFeature.StationaryFace Property


UnfoldFeatureProxy Interface

UnfoldFeatureProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the UnfoldFeature object.

Class Hierarchy
Inventor::PartFeature
    Inventor::UnfoldFeature
        Inventor::UnfoldFeatureProxy
Visual Basic
Public Interface UnfoldFeatureProxy
Inherits UnfoldFeature
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatureProxy Interface


UnfoldFeatures Interface

UnfoldFeatures Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Object allowing iteration of the collection of UnfoldFeature objects, and allows creation of UnfoldFeature objects.

Class Hierarchy
Inventor::UnfoldFeatures
Visual Basic
Public Interface UnfoldFeatures
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalFeatures.UnfoldFeatures

You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface


UnfoldFeatures Methods

UnfoldFeatures Methods
Summary

The methods of the UnfoldFeatures class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new unfold feature.
Item | Property that returns the specified UnfoldFeature object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Methods


UnfoldFeatures.Add Method

UnfoldFeatures.Add Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates a new unfold feature.

Visual Basic
Sub Add(StationaryFace As Face, ByRef Bends As [optional] VARIANT, ByRef Sketches As [optional] VARIANT, Result As [out, retval] UnfoldFeature*)
Parameters
Parameters | Description
StationaryFace | Input Face object that specifies the geometry that will remain fixed while other geometry unfolds. See Remarks.
Bends | Optional input ObjectCollection that defines the bend(s) to unfold. The bends specified must be in a folded state (IsFlat equals False). Not providing this argument or inputting Nothing indicates that all flat bends are to be unfolded.
Sketches | Optional input ObjectCollection that specifies any sketches to be copied and transformed as part of the unfolding operation. The input sketches must be a child of one of the faces being unfolded. Also only one sketch per unfolded face is allowed.
Remarks

For most models the Face specified in the StationaryFace parameter must be on the top or bottom of the part, not around the edge. The exception to this is a part where all of the faces on the top and bottom of the part are cylindrical, as shown below.

When using the Refold command in the user interface for parts like this, the user must specify one of the ends. The user interface displays what looks like work planes at each end of the part, as shown below, for the user to select. When using the API you must supply the equivalent Face objects at the end of the part.

You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Methods > UnfoldFeatures.Add Method


UnfoldFeatures.Item Method

UnfoldFeatures.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified UnfoldFeature object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] UnfoldFeature*)
Parameters
Parameters | Description
Index | Input Long or String value that specifies the UnfoldFeature object within the collection to return. A Long value indicates the index of the feature within the collection to return. A String indicates the name of the feature. If an out of range index or an unknown name is supplied the property will fail.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Methods > UnfoldFeatures.Item Method


UnfoldFeatures Properties

UnfoldFeatures Properties
Summary

The properties of the UnfoldFeatures class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of UnfoldFeature objects in the collection.
Type | Property that returns the constant that indicates the type of this object.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Properties


UnfoldFeatures.Application Property

UnfoldFeatures.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Properties > UnfoldFeatures.Application Property


UnfoldFeatures.Count Property

UnfoldFeatures.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of UnfoldFeature objects in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Properties > UnfoldFeatures.Count Property


UnfoldFeatures.Type Property

UnfoldFeatures.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the constant that indicates the type of this object.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UnfoldFeatures Interface > UnfoldFeatures Properties > UnfoldFeatures.Type Property


UnfoldMethod Interface

UnfoldMethod Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

The UnfoldMethod object provides access to the information associated with a specific unfold method. This object derives from the Style object.

Class Hierarchy
Inventor::Style
    Inventor::UnfoldMethod
Visual Basic
Public Interface UnfoldMethod
Inherits Style
Notes

Members through which this object may be accessed include:

BendDefinition.UnfoldMethod

ContourFlangeDefinition.UnfoldMethod

FlangeDefinition.UnfoldMethod

FoldDefinition.UnfoldMethod

HemDefinition.UnfoldMethod

LoftedFlangeDefinition.UnfoldMethod

SheetMetalComponentDefinition.UnfoldMethod

SheetMetalStyle.UnfoldMethod

UnfoldMethods.AddBendTableFromFile

UnfoldMethods.AddEquationUnfoldMethod

UnfoldMethods.AddLinearUnfoldMethod

UnfoldMethods.Item

See Also

Sheet Metal Style Creation sample

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface


UnfoldMethod Methods

UnfoldMethod Methods
Summary

The methods of the UnfoldMethod class are listed here.

Methods
Methods
Name | Description
DeleteEquation | Method that deletes the specified equation. An equation unfold method always needs to have at least one equation. Deleting the last equation will cause a default equation to be created.
GetEquation | Method that sets this unfold method to be an equation type of unfold method and defines the associated equation and limits.
SetEquation | Method that creates or edits an equation associated with this unfold method. Creating the first equation will change the unfold method be to a custom equation type of unfold method.
WriteBendTableToFile | Method that writes the bend table information of the UnfoldMethod object into an external file. This method is only valid in the case where UnfoldMethodType is kBendTableUnfoldMethod.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Methods


UnfoldMethod.DeleteEquation Method

UnfoldMethod.DeleteEquation Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the specified equation. An equation unfold method always needs to have at least one equation. Deleting the last equation will cause a default equation to be created.

Visual Basic
Sub DeleteEquation(Index As long)
Parameters
Parameters | Description
Index | Input Long that specifies which equation to delete. Valid values are 1 to the current value of the UnfoldMethod.EquationCount property.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Methods > UnfoldMethod.DeleteEquation Method


UnfoldMethod.GetEquation Method

UnfoldMethod.GetEquation Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that sets this unfold method to be an equation type of unfold method and defines the associated equation and limits.

Visual Basic
Sub GetEquation(Index As long, ByRef Equation As String, ByRef MinimumValue As String, ByRef MinimumCompareCondition As ComparisonTypeEnum, ByRef BoundedVariable As String, ByRef MaximumValue As String, ByRef MaximumCompareCondition As ComparisonTypeEnum)
Parameters
Parameters | Description
Index | Input Long that specifies which equation to get. Valid values are 1 to the current value of the UnfoldMethod.EquationCount property.
Equation | Output String that contains the equation. This String uses xml like syntax to allow the inclusion of predefined variables. The available variables and an example of their use are shown below. <Angle\> - Variable used to specify the bend angle within an equation ('). <Thickness\> - Variable used to specify the thickness within an equation ('). <Radius\> - Variable used to specify the inner radius within an equation (?). <Pi\> - Variable used to specify pi within an equation (p). Example: <Pi\> * ((180 deg - <Angle\>)/180 deg) * (<Radius\> + (<Thickness\>/2 ul) * (0.65 ul + 0.5 ul * log(<Radius\> / <Thickness\>))) ' 2 ul * (<Radius\> + <Thickness\> * tan(( 180 deg - <Angle\>) / 2 ul)
MinimumValue | Output String that specifies the minimum value.
MinimumCompareCondition | Output value that specifies the comparison type used for the minimum value. Valid values are kGreaterThanComparisonType, kGreaterThanOrEqualToComparisonType, and kEqualToComparisonType.
BoundedVariable | Output String that specifies the name of the variable whose values are being bounded. Possible returned values are 'Angle' ('), 'Thickness' ('), and 'Radius' (?).
MaximumValue | Output String that specifies the maximum value. If an empty string is returned then no maximum value is defined.
MaximumCompareCondition | Output value that specifies the comparison type used for the maximum value. If the MaximumValue is an empty string the value of this argument should be ignored. Valid values are kLessThanComparisonType or kLessThanOrEqualToComparisonType.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Methods > UnfoldMethod.GetEquation Method


UnfoldMethod.SetEquation Method

UnfoldMethod.SetEquation Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that creates or edits an equation associated with this unfold method. Creating the first equation will change the unfold method be to a custom equation type of unfold method.

Visual Basic
Sub SetEquation(Index As long, EquationType As UnfoldMethodEquationTypeEnum, Equation As String, ByRef MinimumValue As [defaultvalue("0 deg")] BSTR, ByRef MinimumCompareCondition As [defaultvalue(kLessThanOrEqualToComparisonType)] ComparisonTypeEnum, ByRef BoundedVariable As [defaultvalue("Angle")] BSTR, ByRef MaximumValue As [defaultvalue("180 deg")] BSTR, ByRef MaximumCompareCondition As [defaultvalue(kLessThanOrEqualToComparisonType)] ComparisonTypeEnum)
Parameters
Parameters | Description
Index | Input Long that specifies which equation to set. When editing an existing equation, valid values are 1 to the current value of the UnfoldMethod.EquationCount property. Any value outside of this range will cause a new equation to be created. If a new equation is created it will be positioned within the existing equations depending on how its bounding conditions compare to the other equations. This is the same behavior as in the user-interface..
EquationType | Input value from UnfoldMethodEquationTypeEnum that specifies the type of equation being defined.
Equation | Input String that specifies the equation. This String uses xml like syntax to allow you to include the predefined variables. The available variables and an example of their use are shown below. <Angle\> - Variable used to specify the bend angle within an equation ('). <Thickness\> - Variable used to specify the thickness within an equation ('). <Radius\> - Variable used to specify the inner radius within an equation (?). <Pi\> - Variable used to specify pi within an equation (p). Example: <Pi\> * ((180 deg - <Angle\>)/180 deg) * (<Radius\> + (<Thickness\>/2 ul) * (0.65 ul + 0.5 ul * log(<Radius\> / <Thickness\>))) ' 2 ul * (<Radius\> + <Thickness\> * tan(( 180 deg - <Angle\>) / 2 ul)
MinimumValue | Optional input String that specifies the minimum value. This can be any valid expression. If this argument is supplied the MinimumCompareCondition and BoundedVariable arguments must also be provided. The maximum value is optional. If this is not supplied then there is no minimum limit to the value.
MinimumCompareCondition | Optional input value from ComparisonTypeEnum that specifies the method used to compare the value to the minimum value. Valid values are kGreaterThanComparisonTypekLessThanComparisonType, kGreaterThanOrEqualToComparisonTypekLessThanOrEqualToComparisonType, or kEqualToComparisonType. If this argument is supplied the MinimumValue and BoundedVariable arguments must also be provided.
BoundedVariable | Optional input String that specifies the variable whose values are being bounded. Valid values are 'Angle' ('), 'Thickness' ('), and 'Radius' (?).
MaximumValue | Optional input String that specifies the maximum value as an expression. This argument is ignored in the case where the MinimumCompareCondition is kEqualToComparisonType.
MaximumCompareCondition | Optional input value from ComparisonTypeEnum that specifies the method used to compare the value to the maximum value. Valid values are kLessThanComparisonType or kLessThanOrEqualToComparisonType. This argument is ignored in the case where the MinimumCompareCondition is kEqualToComparisonType.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Methods > UnfoldMethod.SetEquation Method


UnfoldMethod.WriteBendTableToFile Method

UnfoldMethod.WriteBendTableToFile Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that writes the bend table information of the UnfoldMethod object into an external file. This method is only valid in the case where UnfoldMethodType is kBendTableUnfoldMethod.

Visual Basic
Sub WriteBendTableToFile(FileName As String)
Parameters
Parameters | Description
FileName | Input String that specifies the name of the file to write bend table information to.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Methods > UnfoldMethod.WriteBendTableToFile Method


UnfoldMethod Properties

UnfoldMethod Properties
Summary

The properties of the UnfoldMethod class are listed here.

Properties
Name | Description
BendAngleType | Property that gets and sets whether the bend or open angle value is to be used for the angle in equations.
EquationCount | Property that reports the number of equations currently associated with this unfold method. This property is only used in the case where the UnfoldMethodType property returns kCustomEquationUnfoldMethod and will return 0 for other unfold method types.
EquationType | Property that specifies the type of equation defined for the unfold method. This property is only valid in the case where the UnfoldMethodType property returns kCustomEquationUnfoldMethod. In all other cases the value of this property should be ignored.
kFactor | Property that gets/sets the kFactor associated with this unfold method. For a linear type of unfold method this is the kFactor used for all bends. For all other unfold methods this is used as the default in cases where the bend table or equations does not define the kFactor.
SplineFactor | Property that gets and sets the factor used when unfolding ruled surfaces defined using ellipses and splines.
UnfoldMethodType | Property that returns the type of unfold method used by this UnfoldMethod object. kLinearUnfoldMethod, kBendTableUnfoldMethod, and kCustomEquationUnfoldMethod are possible return values.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties


UnfoldMethod.BendAngleType Property

UnfoldMethod.BendAngleType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether the bend or open angle value is to be used for the angle in equations.

Visual Basic
Property BendAngleType() As BendAngleTypeEnum
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties > UnfoldMethod.BendAngleType Property


UnfoldMethod.EquationCount Property

UnfoldMethod.EquationCount Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that reports the number of equations currently associated with this unfold method. This property is only used in the case where the UnfoldMethodType property returns kCustomEquationUnfoldMethod and will return 0 for other unfold method types.

Visual Basic
Property EquationCount() As long*
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties > UnfoldMethod.EquationCount Property


UnfoldMethod.EquationType Property

UnfoldMethod.EquationType Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that specifies the type of equation defined for the unfold method. This property is only valid in the case where the UnfoldMethodType property returns kCustomEquationUnfoldMethod. In all other cases the value of this property should be ignored.

Visual Basic
Property EquationType() As UnfoldMethodEquationTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties > UnfoldMethod.EquationType Property


UnfoldMethod.kFactor Property

UnfoldMethod.kFactor Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets/sets the kFactor associated with this unfold method. For a linear type of unfold method this is the kFactor used for all bends. For all other unfold methods this is used as the default in cases where the bend table or equations does not define the kFactor.

Visual Basic
Property kFactor() As String
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties > UnfoldMethod.kFactor Property


UnfoldMethod.SplineFactor Property

UnfoldMethod.SplineFactor Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the factor used when unfolding ruled surfaces defined using ellipses and splines.

Visual Basic
Property SplineFactor() As String
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties > UnfoldMethod.SplineFactor Property


UnfoldMethod.UnfoldMethodType Property

UnfoldMethod.UnfoldMethodType Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the type of unfold method used by this UnfoldMethod object. kLinearUnfoldMethod, kBendTableUnfoldMethod, and kCustomEquationUnfoldMethod are possible return values.

Visual Basic
Property UnfoldMethodType() As UnfoldMethodTypeEnum*
See Also

Sheet Metal Style Display sample

You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethod Interface > UnfoldMethod Properties > UnfoldMethod.UnfoldMethodType Property


UnfoldMethods Interface

UnfoldMethods Interface Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Provides access to the unfold method list (collection of UnfoldMethod objects) for a particular sheet metal style.

Class Hierarchy
Inventor::UnfoldMethods
Visual Basic
Public Interface UnfoldMethods
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SheetMetalComponentDefinition.UnfoldMethods

You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface


UnfoldMethods Methods

UnfoldMethods Methods
Summary

The methods of the UnfoldMethods class are listed here.

Methods
Methods
Name | Description
AddBendTableFromFile | Method that adds a BendTable unfold method to the collection and returns the created UnfoldMethod object.
AddEquationUnfoldMethod | Method that adds an equation linear unfold method to the collection and returns the created UnfoldMethod object. The new unfold method will have a single equation that specifies that the bend compensation will be 0 for a bend from 0 to 180 degrees. You can edit the equation to the desired equation using the functionality of the returned UnfoldMethod object.
AddLinearUnfoldMethod | Method that adds a linear unfold method to the collection and returns the created UnfoldMethod object.
Item | Property that returns the specified UnfoldMethod object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Methods


UnfoldMethods.AddBendTableFromFile Method

UnfoldMethods.AddBendTableFromFile Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that adds a BendTable unfold method to the collection and returns the created UnfoldMethod object.

Visual Basic
Sub AddBendTableFromFile(Name As String, FileName As String, Result As [out, retval] UnfoldMethod*)
Parameters
Parameters | Description
Name | Input String used to specify the name of bendtable UnfoldMethod. This name must be unique with respect to other UnfoldMethod objects. If a unique name is not provided, an error will occur.
FileName | Input String used to specify the name of the bend table. This is a text file in the format specified in the Sheet Metal documentation. When the UnfoldMethod object is created, the bend table information is extracted from the input file and saved in the sheet metal document. Not relationship is maintained to the original bend table file to it can moved or deleted without any loss of bend table info. This also means that if the text file is changed later, the UnfoldMethod object will not detect the changes and it will have no impact on the bend table.
See Also

Sheet Metal Style Creation sample

You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Methods > UnfoldMethods.AddBendTableFromFile Method


UnfoldMethods.AddEquationUnfoldMethod Method

UnfoldMethods.AddEquationUnfoldMethod Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that adds an equation linear unfold method to the collection and returns the created UnfoldMethod object. The new unfold method will have a single equation that specifies that the bend compensation will be 0 for a bend from 0 to 180 degrees. You can edit the equation to the desired equation using the functionality of the returned UnfoldMethod object.

Visual Basic
Sub AddEquationUnfoldMethod(Name As String, Result As [out, retval] UnfoldMethod*)
Parameters
Parameters | Description
Name | Input String used to specify the name of the UnfoldMethod. This name must be unique with respect to other UnfoldMethod objects. If a unique name is not provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Methods > UnfoldMethods.AddEquationUnfoldMethod Method


UnfoldMethods.AddLinearUnfoldMethod Method

UnfoldMethods.AddLinearUnfoldMethod Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Method that adds a linear unfold method to the collection and returns the created UnfoldMethod object.

Visual Basic
Sub AddLinearUnfoldMethod(Name As String, Value As String, Result As [out, retval] UnfoldMethod*)
Parameters
Parameters | Description
Name | Input String used to specify the name of the UnfoldMethod. This name must be unique with respect to other UnfoldMethod objects. If a unique name is not provided, an error will occur.
Value | Input String used to specify the k Factor value for this UnfoldMethod object. This can be an expression. This parameter determines where the bend allowance is calculated. The allowable range is from 0 to 1. The bend allowance is calculated using the following equation: 2*Pi*(Bend Radius + Linear Offset*Thickness/2)*(Bend Angle/360)
See Also

Sheet Metal Style Creation sample

You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Methods > UnfoldMethods.AddLinearUnfoldMethod Method


UnfoldMethods.Item Method

UnfoldMethods.Item Method Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the specified UnfoldMethod object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] UnfoldMethod*)
Parameters
Parameters | Description
index | Input Variant value that specifies the UnfoldMethod object to return. This can be either a numeric value indicating the index of the item in the collection or it can be a String indicating the UnfoldMethod name. If an out of range index or a name of a non-existent UnfoldMethod is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Methods > UnfoldMethods.Item Method


UnfoldMethods Properties

UnfoldMethods Properties
Summary

The properties of the UnfoldMethods class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Properties


UnfoldMethods.Application Property

UnfoldMethods.Application Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Properties > UnfoldMethods.Application Property


UnfoldMethods.Count Property

UnfoldMethods.Count Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Properties > UnfoldMethods.Count Property


UnfoldMethods.Type Property

UnfoldMethods.Type Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UnfoldMethods Interface > UnfoldMethods Properties > UnfoldMethods.Type Property


UnitsOfMeasure Interface

UnitsOfMeasure Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The UnitsOfMeasure object supports various functions to allow you to interact with the units associated with the document.

Class Hierarchy
Inventor::UnitsOfMeasure
Visual Basic
Public Interface UnitsOfMeasure
Inherits IDispatch
Remarks

Using the Units tab of the Document Settings dialog the user can set the display units and precision. The UnitsOfMeasure object provides the same functionality. In addition is supports some methods to parse strings that contain unit information, and create strings using the current unit settings. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.UnitsOfMeasure

Document.UnitsOfMeasure

Application.UnitsOfMeasure

See Also

Client graphics texture-based color mapping sample

Units of Measure Conversion sample

True length of sweep feature sample

Using measure events sample

Example

Get and Set Units of Measure Example

This sample demonstrates getting the units of measure information for the active document. It also demonstrates setting the units of measure information for the document.

To run the sample have any document open in Inventor.

Public Sub InventorUOM()
    ' Set a reference to the UnitsOfMeasure object of the
    ' active document.
    Dim oUOM As UnitsOfMeasure
    Set oUOM = ThisApplication.ActiveDocument.UnitsOfMeasure

    ' Display information about the current unit settings.

    ' Get the current angle units.
    Dim eAngleUnits As UnitsTypeEnum
    eAngleUnits = oUOM.AngleUnits

    ' Display the string version of the angle units and the precision.
    Debug.Print "Angle Units: " & oUOM.GetStringFromType(eAngleUnits)
    Debug.Print "Angle Precision: " & oUOM.AngleDisplayPrecision

    ' Get the current length units.
    Dim eLengthUnits As UnitsTypeEnum
    eLengthUnits = oUOM.LengthUnits

    ' Display the string version of the length units and the precision.
    Debug.Print "Length Units: " & oUOM.GetStringFromType(eLengthUnits)
    Debug.Print "Length Precision: " & oUOM.LengthDisplayPrecision

    ' Get the current mass units.
    Dim eMassUnits As UnitsTypeEnum
    eMassUnits = oUOM.MassUnits

    ' Display the string version of the mass units.
    Debug.Print "Mass Units: " & oUOM.GetStringFromType(eMassUnits)

    ' Get the current time units.
    Dim eTimeUnits As UnitsTypeEnum
    eTimeUnits = oUOM.TimeUnits

    ' Display the string version of the time units.
    Debug.Print "Time Units: " & oUOM.GetStringFromType(eTimeUnits)

    ' Set the units and precision.
    oUOM.AngleUnits = kRadianAngleUnits
    oUOM.AngleDisplayPrecision = 5

    oUOM.LengthUnits = kMeterLengthUnits
    oUOM.LengthDisplayPrecision = 4

    oUOM.MassUnits = kLbMassMassUnits

    oUOM.TimeUnits = kMinuteTimeUnits
End Sub
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface


UnitsOfMeasure Methods

UnitsOfMeasure Methods
Summary

The methods of the UnitsOfMeasure class are listed here.

Methods
Methods
Name | Description
_GetValueFromExpression | This is _GetValueFromExpression, a member of class UnitsOfMeasure.
CompatibleUnits | Method that evaluates the two input expressions and determines if the result in units that have the same base unit type.
ConvertUnits | Method that converts a value from one unit to another. The input and output unit specifiers must both define compatible units. For example, "in" (inches) and "cm" (centimeters) will work because they both define lengths. If incompatible units are specified, this method will fail. The converted value, in the units specified by the OutputUnitsSpecifier argument is returned.
GetDatabaseUnitsFromExpression | Evaluates an input string and returns equivalent database units as a string.
GetDrivingParameters | Obtains the driving parameters enumerator corresponding to the input string.
GetLocaleCorrectedExpression | This method converts the input expression to a locale-friendly version. For instance, if you input "1.0 in" on a machine set to the German locale, the return value is "1,0 in". In this case, the decimal separator is different.
GetPreciseStringFromValue | Obtains the precise string along with the units, given a value. The output units needs to be specified as well.
GetStringFromType | Given a unit type from the UnitsTypeEnum as input, this method returns the string that can be used to specify the same unit type.
GetStringFromValue | Method that creates a string that represents the input value evaluated using the specified units.
GetTypeFromString | Given a string defining a unit this method returns the corresponding unit from the UnitsTypeEnum constant list. If the unit specified by the string does not exist in the constant list an error will occur. For example, inputting "mm" will return kMillimeterLengthUnits. This method is not currently supported when the UnitsOfMeasure object was obtained using Apprentice.
GetValueFromExpression | Method that evaluates the input expression using the units specified and returns a value in database units.
IsExpressionValid | Returns whether the input expression is valid or not.
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods


UnitsOfMeasure._GetValueFromExpression Method

UnitsOfMeasure._GetValueFromExpression Method
Summary

This is _GetValueFromExpression, a member of class UnitsOfMeasure.

Visual Basic
Sub _GetValueFromExpression(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] double)
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure._GetValueFromExpression Method


UnitsOfMeasure.CompatibleUnits Method

UnitsOfMeasure.CompatibleUnits Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that evaluates the two input expressions and determines if the result in units that have the same base unit type.

Visual Basic
Sub CompatibleUnits(Expression1 As String, UnitsSpecifier1 As VARIANT, Expression2 As String, UnitsSpecifier2 As VARIANT, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters
Description
Expression1
The first expression to be used in the comparison.
UnitsSpecifier1
Input variant value that specifies the unit type the first expression is to be evaluated with. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in". A common use of this method will be to evaluate an expression using the current display units of the document. For example if the expression should define a length you can use kDefaultDisplayLengthUnit as the unit specifier so the expression will be evaluated as a length in the current document units. The enum values that specify to use the document default display units are kDefaultDisplayLengthUnit, kDefaultDisplayAngleUnit, kDefaultDisplayMassUnit, kDefaultDisplayTimeUnit, and kDefaultDisplayTemperatureUnit.
Expression2
The second expression to be used in the comparison.
UnitsSpecifier2
Input variant value that specifies the unit type the second expression is to be evaluated with. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in". A common use of this method will be to evaluate an expression using the current display units of the document. For example if the expression should define a length you can use kDefaultDisplayLengthUnit as the unit specifier so the expression will be evaluated as a length in the current document units. The enum values that specify to use the document default display units are kDefaultDisplayLengthUnit, kDefaultDisplayAngleUnit, kDefaultDisplayMassUnit, kDefaultDisplayTimeUnit, and kDefaultDisplayTemperatureUnit.
Remarks

For example comparing the two expressions '3.45 in + 3 cm' and '1 ft' will return True because both expressions result in values that defined lengths. The two expression '3 cm * 5 cm' and '1 ft' will return False because the first expression results in an area and the second is a length.

This method will also return False in the case where either Expression1 or Expression2 is not valid and cannot be evaluated.

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.CompatibleUnits Method


UnitsOfMeasure.ConvertUnits Method

UnitsOfMeasure.ConvertUnits Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that converts a value from one unit to another. The input and output unit specifiers must both define compatible units. For example, "in" (inches) and "cm" (centimeters) will work because they both define lengths. If incompatible units are specified, this method will fail. The converted value, in the units specified by the OutputUnitsSpecifier argument is returned.

Visual Basic
Sub ConvertUnits(Value As double, InputUnitsSpecifier As VARIANT, OutputUnitsSpecifier As VARIANT, Result As [out, retval] double)
Parameters
Parameters | Description
Value | Input Double value that specifies the value to be converted. This value is in the units specified by the InputUnitsSpecifier argument.
InputUnitsSpecifier | Input Variant value that specifies the unit type of the input value. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in".
OutputUnitsSpecifier | Input Variant value that specifies the unit type of the output value. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in".
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.ConvertUnits Method


UnitsOfMeasure.GetDatabaseUnitsFromExpression Method

UnitsOfMeasure.GetDatabaseUnitsFromExpression Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Evaluates an input string and returns equivalent database units as a string.

Visual Basic
Sub GetDatabaseUnitsFromExpression(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Expression | Input String value that contains the expression to evaluate. This string is evaluated the same ways a string entered in any of the Autodesk Inventor dialogs are evaluated. For example "3 in / 2 cm" is a valid string for input.
UnitsSpecifier | Input Variant value that specifies the unit type of the input value. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in".
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetDatabaseUnitsFromExpression Method


UnitsOfMeasure.GetDrivingParameters Method

UnitsOfMeasure.GetDrivingParameters Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Obtains the driving parameters enumerator corresponding to the input string.

Visual Basic
Sub GetDrivingParameters(Expression As String, Result As [out, retval] ParametersEnumerator*)
Parameters
Parameters | Description
Expression | Input String value that contains the expression to evaluate. This string is evaluated the same ways a string entered in any of the Autodesk Inventor dialogs are evaluated. For example "3 in / 2 cm" is a valid string for input.
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetDrivingParameters Method


UnitsOfMeasure.GetLocaleCorrectedExpression Method

UnitsOfMeasure.GetLocaleCorrectedExpression Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

This method converts the input expression to a locale-friendly version. For instance, if you input "1.0 in" on a machine set to the German locale, the return value is "1,0 in". In this case, the decimal separator is different.

Visual Basic
Sub GetLocaleCorrectedExpression(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Expression | Input String value that contains the expression to evaluate. This string is evaluated the same ways a string entered in any of the Autodesk Inventor dialogs are evaluated. For example "3 in / 2 cm" is a valid string for input.
UnitsSpecifier | Input variant value that specifies the unit type the string is to be returned in. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and 'in'. string specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string 'in in in'.
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetLocaleCorrectedExpression Method


UnitsOfMeasure.GetPreciseStringFromValue Method

UnitsOfMeasure.GetPreciseStringFromValue Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Obtains the precise string along with the units, given a value. The output units needs to be specified as well.

Visual Basic
Sub GetPreciseStringFromValue(Value As double, UnitsSpecifier As VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Value | Value from which to obtain precise string and units.
UnitsSpecifier | Input variant value that specifies the unit type the string is to be returned in. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and 'in'. string specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string 'in in in'.
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetPreciseStringFromValue Method


UnitsOfMeasure.GetStringFromType Method

UnitsOfMeasure.GetStringFromType Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Given a unit type from the UnitsTypeEnum as input, this method returns the string that can be used to specify the same unit type.

Visual Basic
Sub GetStringFromType(UnitsType As UnitsTypeEnum, Result As [out, retval] BSTR)
Parameters
Parameters | Description
UnitsType | Input constant value that specifies the unit type.
Remarks

For example if you input k kInchLengthUnits it will return the string "in." If one of the default unit types is specified, (kDefaultDisplayLengthUnits, kDefaultDisplayAngleUnits, kDefaultDisplayMassUnits, kDefaultDisplayTimeUnits, or kDefaultDisplayTemperatureUnits) this will return the string corresponding to the document default for that unit type. This method is currently not supported when the UnitsOfMeasure object was obtained using Apprentice.

See Also

Units of Measure Conversion sample

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetStringFromType Method


UnitsOfMeasure.GetStringFromValue Method

UnitsOfMeasure.GetStringFromValue Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a string that represents the input value evaluated using the specified units.

Visual Basic
Sub GetStringFromValue(Value As double, UnitsSpecifier As VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
Value | Input Double value that contains the value in database units for the unit category specified in the second argument.
UnitsSpecifier | Input variant value that specifies the unit type the string is to be returned in. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and 'in'. string specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string 'in in in'.
Remarks

The input value is always in database units. The units can be defined using one the predefined units in the UnitTypeEnum enum or you can define your own unit type by combining known units in a string. You can also use the default unit types, (kDefaultDisplayLengthUnits, kDefaultDisplayAngleUnits, kDefaultDisplayMassUnits, kDefaultDisplayTimeUnits, or kDefaultDisplayTemperatureUnits), to use the current unit type defined in the document. For example, if the current length unit of the document is Inches and the precision for the length units is 3 decimal places, inputting 25.0 for the value and kDefaultDisplayLengthUnits for the units specifier will return the string '9.843 in'.

This method fails when the value cannot be evaluated using the specified units specifier. This method is currently not supported when the UnitsOfMeasure object was obtained using Apprentice. A common use of this method will be to evaluate a value using the current display units of the document. For example if the value defines a length you can use kDefaultDisplayLengthUnits as the unit specifier so the value will be evaluated as a length in the current document units.

The enum values that specify to use the document default display units are kDefaultDisplayLengthUnits, kDefaultDisplayAngleUnits, kDefaultDisplayMassUnits, kDefaultDisplayTimeUnits, and kDefaultDisplayTemperatureUnits.

See Also

Units of Measure Conversion sample

True length of sweep feature sample

Using measure events sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetStringFromValue Method


UnitsOfMeasure.GetTypeFromString Method

UnitsOfMeasure.GetTypeFromString Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Given a string defining a unit this method returns the corresponding unit from the UnitsTypeEnum constant list. If the unit specified by the string does not exist in the constant list an error will occur. For example, inputting "mm" will return kMillimeterLengthUnits. This method is not currently supported when the UnitsOfMeasure object was obtained using Apprentice.

Visual Basic
Sub GetTypeFromString(UnitsString As String, Result As [out, retval] UnitsTypeEnum)
Parameters
Parameters | Description
UnitsString | Input string specifies the unit type.
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetTypeFromString Method


UnitsOfMeasure.GetValueFromExpression Method

UnitsOfMeasure.GetValueFromExpression Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that evaluates the input expression using the units specified and returns a value in database units.

Visual Basic
Sub GetValueFromExpression(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] VARIANT)
Parameters
Parameters | Description
Expression | Input String value that contains the expression to evaluate. This string is evaluated the same ways a string entered in any of the Autodesk Inventor dialogs are evaluated. For example "3 in / 2 cm" is a valid string for input.
UnitsSpecifier | Input variant value that specifies the unit type the expression is to be evaluated with. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in." String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in."
Example 1

the string "34 in / 2" with a length unit specifier, will return the value 43.1800. The UnitsSpecifier is used to determine the type of unit that is expected, (i.e.. area, volume, velocity, etc.) and is used for values that do not have an explicit type defined. For example the expression "4 * 5" with a units specifier of "mm mm" would be assumed to be "4 mm * 5 mm." An error occurs if the string cannot be evaluated. This method is currently not supported when the UnitsOfMeasure object was obtained using Apprentice. A common use of this method will be to evaluate an expression using the current display units of the document. For example if the expression should define a length you can use kDefaultDisplayLengthUnits as the unit specifier so the expression will be evaluated as a length in the current document units. The enum values that specify to use the document default display units are kDefaultDisplayLengthUnits, kDefaultDisplayAngleUnits, kDefaultDisplayMassUnits, kDefaultDisplayTimeUnits, and kDefaultDisplayTemperatureUnits.

The input expression is specified by a string. This string may or may not specify a unit type (for example, "1" versus "1 in"). In the case where the string expression does not specify a unit type, the additional unit-type argument is required to determine the unit type. Note: Up to and including Autodesk Inventor 10, if the string expression does specify a unit type, the UnitsSpecifier type specified will be ignored because the unit type is obtained from the string expression. However, subsequent releases of Autodesk Inventor will return an error condition if the two unit types do not match.

Example 2

"Units of Measure Conversion Example"

This sample demonstrates converting between string expressions and values. To run the sample have any document open in Inventor.

Public Sub InventorUOMConvert()
    ' Set a reference to the UnitsOfMeasure object of the
    ' active document.
    Dim oUOM As UnitsOfMeasure
    Set oUOM = ThisApplication.ActiveDocument.UnitsOfMeasure

    ' Get a value to convert.
    Dim dValue As Double
    dValue = Val(InputBox("Enter value to convert (in database units (centimeters))."))

    ' Convert input value into the current display length units
    ' and create a string with the specified precision.
    Dim sResult As String
    sResult = oUOM.GetStringFromValue(dValue, kDefaultDisplayLengthUnits)
    Debug.Print dValue & " cm results in: " & sResult

    ' Get the enum value associated with a unit defined by a string.
    Dim eType As UnitsTypeEnum
    eType = oUOM.GetTypeFromString("mm")
    Debug.Print "mm type: " & eType

    ' Evaluate an expression and return the area.  The return value is
    ' always in database units.  In this case it will be in square cm's.
    ' Because the units specifier defines inches the input value in the expression
    ' are assumed to be inches since they're not explicitly defined in the expression.
    Dim dArea As Double
    dArea = oUOM.GetValueFromExpression("3.45 * 4", "in in")
    Debug.Print "Area of 3.45 * 4 = " & dArea & " cm cm"

    ' Evaluate the same area but set the units specifier to be whatever the
    ' current length units are for the document.
    Dim sLengthUnit As String
    sLengthUnit = oUOM.GetStringFromType(kDefaultDisplayLengthUnits)
    Dim sAreaUnit As String
    sAreaUnit = sLengthUnit & "^2"
    dArea = oUOM.GetValueFromExpression("3.45 * 4", sAreaUnit)
    Debug.Print "Area of 3.45 * 4 (document units) = " & dArea & " cm cm"
End Sub
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.GetValueFromExpression Method


UnitsOfMeasure.IsExpressionValid Method

UnitsOfMeasure.IsExpressionValid Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Returns whether the input expression is valid or not.

Visual Basic
Sub IsExpressionValid(Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Methods > UnitsOfMeasure.IsExpressionValid Method


UnitsOfMeasure Properties

UnitsOfMeasure Properties
Summary

The properties of the UnitsOfMeasure class are listed here.

Properties
Name | Description
AngleDisplayPrecision | Property that allows you to get and set the number of decimal place accuracy displayed for angular values.
AngleUnits | Property that allows you to get and set the angle display units for the document. Valid constants for this property are kRadianAngleUnits and kDegreeAngleUnits. If an invalid unit type is specified, an error will occur. When used within Apprentice this property is read-only and setting the value will fail.
LengthDisplayPrecision | Property that allows you to get and set the number of decimal place accuracy displayed for length values. This is the same property set by the user using the Units tab of the Document Settings dialog. The value indicates how many zeros to the right of the decimal to display. When used within Apprentice this property behaves as read-only and setting the value will fail.
LengthUnits | Property that allows you to get and set the length display units for the document. Valid constants for this property are kInchLengthUnit, kFootLengthUnit, kCentimeterLengthUnit, kMillimeterLengthUnit, kMeterLengthUnit, and kMicronLengthUnit. If an invalid unit type is specified, an error will occur. When used within Apprentice this property behaves as read-only and setting the value will fail.
MassUnits | Property that allows you to get and set the mass display units for the document. Valid constants for this property are kLbMassMassUnit , kSlugMassUnit, kGramMassUnit, and kKilogramMassUnit. If an invalid unit type is specified, an error will occur. When used within Apprentice this property behaves as read-only and setting the value will fail.
Parent | Property returning the parent Document object.
TimeUnits | Property that allows you to get and set the time display units for the document. Valid constants for this property are kSecondTimeUnit and kMinuteTimeUnit. If an invalid unit type is specified, an error will occur. When used within Apprentice this property behaves as read-only and setting the value will fail.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties


UnitsOfMeasure.AngleDisplayPrecision Property

UnitsOfMeasure.AngleDisplayPrecision Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the number of decimal place accuracy displayed for angular values.

Visual Basic
Property AngleDisplayPrecision() As long
Remarks

This is the same property set by the user using the Units tab of the Document Settings dialog. The value indicates how many zeros to the right of the decimal to display. When used within Apprentice this property behaves as read-only and setting the value will fail.

See Also

Get and Set Units of Measure sample

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.AngleDisplayPrecision Property


UnitsOfMeasure.AngleUnits Property

UnitsOfMeasure.AngleUnits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the angle display units for the document. Valid constants for this property are kRadianAngleUnits and kDegreeAngleUnits. If an invalid unit type is specified, an error will occur. When used within Apprentice this property is read-only and setting the value will fail.

Visual Basic
Property AngleUnits() As UnitsTypeEnum
See Also

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.AngleUnits Property


UnitsOfMeasure.LengthDisplayPrecision Property

UnitsOfMeasure.LengthDisplayPrecision Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the number of decimal place accuracy displayed for length values. This is the same property set by the user using the Units tab of the Document Settings dialog. The value indicates how many zeros to the right of the decimal to display. When used within Apprentice this property behaves as read-only and setting the value will fail.

Visual Basic
Property LengthDisplayPrecision() As long
See Also

Get and Set Units of Measure sample

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.LengthDisplayPrecision Property


UnitsOfMeasure.LengthUnits Property

UnitsOfMeasure.LengthUnits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the length display units for the document. Valid constants for this property are kInchLengthUnit, kFootLengthUnit, kCentimeterLengthUnit, kMillimeterLengthUnit, kMeterLengthUnit, and kMicronLengthUnit. If an invalid unit type is specified, an error will occur. When used within Apprentice this property behaves as read-only and setting the value will fail.

Visual Basic
Property LengthUnits() As UnitsTypeEnum
See Also

Client graphics texture-based color mapping sample

Get and Set Units of Measure sample

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.LengthUnits Property


UnitsOfMeasure.MassUnits Property

UnitsOfMeasure.MassUnits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the mass display units for the document. Valid constants for this property are kLbMassMassUnit , kSlugMassUnit, kGramMassUnit, and kKilogramMassUnit. If an invalid unit type is specified, an error will occur. When used within Apprentice this property behaves as read-only and setting the value will fail.

Visual Basic
Property MassUnits() As UnitsTypeEnum
See Also

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.MassUnits Property


UnitsOfMeasure.Parent Property

UnitsOfMeasure.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent Document object.

Visual Basic
Property Parent() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.Parent Property


UnitsOfMeasure.TimeUnits Property

UnitsOfMeasure.TimeUnits Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get and set the time display units for the document. Valid constants for this property are kSecondTimeUnit and kMinuteTimeUnit. If an invalid unit type is specified, an error will occur. When used within Apprentice this property behaves as read-only and setting the value will fail.

Visual Basic
Property TimeUnits() As UnitsTypeEnum
See Also

Get and Set Units of Measure sample

You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.TimeUnits Property


UnitsOfMeasure.Type Property

UnitsOfMeasure.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UnitsOfMeasure Interface > UnitsOfMeasure Properties > UnitsOfMeasure.Type Property


UnitVector Interface

UnitVector Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The UnitVector object. For more information, see the [image] Transient Geometry overview.

Class Hierarchy
Inventor::UnitVector
Visual Basic
Public Interface UnitVector
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Arc3d.Normal

Arc3d.ReferenceVector

AssemblyWorkAxisDef.Axis

AssemblyWorkPlaneDef.XAxis

AssemblyWorkPlaneDef.YAxis

Camera.UpVector

Circle.Normal

Cone.AxisVector

CoreCavityDefinition.PullDirection

Cylinder.AxisVector

EllipseFull.Normal

EllipticalArc.MajorAxis

EllipticalArc.MinorAxis

EllipticalCone.AxisVector

EllipticalCylinder.AxisVector

FixedWorkAxisDef.Axis

FixedWorkPlaneDef.XAxis

FixedWorkPlaneDef.YAxis

GraphicsNormalSet.Normal

Line.Direction

LineSegment.Direction

MoldDefinition.PullDirection

Plane.Normal

SketchEllipse3D.MajorAxisVector

SketchEllipticalArc3D.MajorAxisVector

SketchSplineHandle3D.Tangent

Torus.AxisVector

TransientGeometry.CreateUnitVector

UnitVector.CrossProduct

Vector.AsUnitVector

See Also

Create curve primitives sample

Offset a 2D sketch sample

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface


UnitVector Methods

UnitVector Methods
Summary

The methods of the UnitVector class are listed here.

Methods
Methods
Name | Description
AngleTo | Determines the angle between this vector and the specified vector.
AsVector | Get the vector equivalent of this unit vector.
CrossProduct | Determine the cross product between this vector and the specified vector.
DotProduct | Determine the dot product of this vector to the specified vector.
GetUnitVectorData | Get the data defining this unit vector.
IsEqualTo | Compare this unit vector for equality to the specified unit vector.
IsParallelTo | Determine if this vector is parallel to the specified vector.
IsPerpendicularTo | Determine if this vector is perpendicular to the specified vector.
PutUnitVectorData | Method that sets the data defining this unit vector.
TransformBy | Transform this vector by the specified matrix.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods


UnitVector.AngleTo Method

UnitVector.AngleTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determines the angle between this vector and the specified vector.

Visual Basic
Sub AngleTo(Argument As UnitVector, Result As [out, retval] double)
Parameters
Parameters | Description
Argument | Input UnitVector used for comparison.
Remarks

When one of the input vectors is null (0,0,0) this method will return -NaN.

You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.AngleTo Method


UnitVector.AsVector Method

UnitVector.AsVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the vector equivalent of this unit vector.

Visual Basic
Sub AsVector(Result As [out, retval] Vector*)
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.AsVector Method


UnitVector.CrossProduct Method

UnitVector.CrossProduct Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine the cross product between this vector and the specified vector.

Visual Basic
Sub CrossProduct(Argument As UnitVector, Result As [out, retval] UnitVector*)
Parameters
Parameters | Description
Argument | Input UnitVector used for comparison.
See Also

Offset a 2D sketch sample

Create a 3D sketch dimension sample

You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.CrossProduct Method


UnitVector.DotProduct Method

UnitVector.DotProduct Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine the dot product of this vector to the specified vector.

Visual Basic
Sub DotProduct(Argument As UnitVector, Result As [out, retval] double)
Parameters
Parameters | Description
Argument | Input UnitVector used for comparison.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.DotProduct Method


UnitVector.GetUnitVectorData Method

UnitVector.GetUnitVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this unit vector.

Visual Basic
Sub GetUnitVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.GetUnitVectorData Method


UnitVector.IsEqualTo Method

UnitVector.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Compare this unit vector for equality to the specified unit vector.

Visual Basic
Sub IsEqualTo(Argument As UnitVector, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Argument | Input UnitVector used for comparison.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the UnitVectors are equal.
See Also

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.IsEqualTo Method


UnitVector.IsParallelTo Method

UnitVector.IsParallelTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine if this vector is parallel to the specified vector.

Visual Basic
Sub IsParallelTo(Argument As UnitVector, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Argument | Input UnitVector used for comparison.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the UnitVectors are parallel.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.IsParallelTo Method


UnitVector.IsPerpendicularTo Method

UnitVector.IsPerpendicularTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine if this vector is perpendicular to the specified vector.

Visual Basic
Sub IsPerpendicularTo(Argument As UnitVector, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Argument | Input UnitVector used for comparison.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the vectors are perpendicular.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.IsPerpendicularTo Method


UnitVector.PutUnitVectorData Method

UnitVector.PutUnitVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this unit vector.

Visual Basic
Sub PutUnitVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.PutUnitVectorData Method


UnitVector.TransformBy Method

UnitVector.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Transform this vector by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies the matrix to transform the vector by.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Methods > UnitVector.TransformBy Method


UnitVector Properties

UnitVector Properties
Summary

The properties of the UnitVector class are listed here.

Properties
Name | Description
X | Specifies the X coordinate of the vector. If not supplied, the X value will default to 0.
Y | Specifies the Y coordinate of the vector. If not supplied, the Y value will default to 0.
Z | Specifies the Z coordinate of the vector. If not supplied, the Z value will default to 1.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Properties


UnitVector.X Property

UnitVector.X Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the X coordinate of the vector. If not supplied, the X value will default to 0.

Visual Basic
Property X() As double
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Properties > UnitVector.X Property


UnitVector.Y Property

UnitVector.Y Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Y coordinate of the vector. If not supplied, the Y value will default to 0.

Visual Basic
Property Y() As double
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Properties > UnitVector.Y Property


UnitVector.Z Property

UnitVector.Z Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Z coordinate of the vector. If not supplied, the Z value will default to 1.

Visual Basic
Property Z() As double
You are here: Symbol Reference > Inventor Library > Objects > UnitVector Interface > UnitVector Properties > UnitVector.Z Property


UnitVector2d Interface

UnitVector2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The UnitVector2d object. For more information, see the [image] Transient Geometry overview.

Class Hierarchy
Inventor::UnitVector2d
Visual Basic
Public Interface UnitVector2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Centermark.ExtensionPointFourDirection

Centermark.ExtensionPointOneDirection

Centermark.ExtensionPointThreeDirection

Centermark.ExtensionPointTwoDirection

EllipticalArc2d.MajorAxis

Line2d.Direction

LineSegment2d.Direction

SketchEllipse.MajorAxisVector

SketchEllipticalArc.MajorAxisVector

SketchSplineHandle.Tangent

TransientGeometry.CreateUnitVector2d

Vector2d.AsUnitVector

See Also

Create sketch elliptical arc sample

Offset a 2D sketch sample

You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface


UnitVector2d Methods

UnitVector2d Methods
Summary

The methods of the UnitVector2d class are listed here.

Methods
Methods
Name | Description
AngleTo | Determines the angle between this unit vector2d and the specified unit vector2d.
AsVector | Get the vector2d equivalent of this unit vector2d.
DotProduct | Determine the dot product of this unit vector2d to the specified unit vector2d.
GetUnitVectorData | Get the data defining this unit vector.
IsEqualTo | Compare this unit vector2d for equality to the specified unit vector2d.
IsParallelTo | Determine if this unit vector2d is parallel to the specified unit vector2d.
IsPerpendicularTo | Determine if this unit vector2d is perpendicular to the specified unit vector2d.
PutUnitVectorData | Method that sets the data defining this unit vector.
TransformBy | Transform this unit vector2d by the specified matrix.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods


UnitVector2d.AngleTo Method

UnitVector2d.AngleTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determines the angle between this unit vector2d and the specified unit vector2d.

Visual Basic
Sub AngleTo(Vector As UnitVector2d, Result As [out, retval] double)
Parameters
Parameters | Description
Vector | 2nd vector to measure to.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.AngleTo Method


UnitVector2d.AsVector Method

UnitVector2d.AsVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Get the vector2d equivalent of this unit vector2d.

Visual Basic
Sub AsVector(Result As [out, retval] Vector2d*)
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.AsVector Method


UnitVector2d.DotProduct Method

UnitVector2d.DotProduct Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determine the dot product of this unit vector2d to the specified unit vector2d.

Visual Basic
Sub DotProduct(Vector As UnitVector2d, Result As [out, retval] double)
Parameters
Parameters | Description
Vector | 2nd vector to use to calculate dot product.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.DotProduct Method


UnitVector2d.GetUnitVectorData Method

UnitVector2d.GetUnitVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this unit vector.

Visual Basic
Sub GetUnitVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.GetUnitVectorData Method


UnitVector2d.IsEqualTo Method

UnitVector2d.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Compare this unit vector2d for equality to the specified unit vector2d.

Visual Basic
Sub IsEqualTo(Vector As UnitVector2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | Vector to compare to.
Tolerance | Tolerance for comparison.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.IsEqualTo Method


UnitVector2d.IsParallelTo Method

UnitVector2d.IsParallelTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determine if this unit vector2d is parallel to the specified unit vector2d.

Visual Basic
Sub IsParallelTo(Vector As UnitVector2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | Vector with which to test parallel status.
Tolerance | Tolerance for test.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.IsParallelTo Method


UnitVector2d.IsPerpendicularTo Method

UnitVector2d.IsPerpendicularTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determine if this unit vector2d is perpendicular to the specified unit vector2d.

Visual Basic
Sub IsPerpendicularTo(Vector As UnitVector2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | Vector with which to test perpendicular status.
Tolerance | Tolerance for test.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.IsPerpendicularTo Method


UnitVector2d.PutUnitVectorData Method

UnitVector2d.PutUnitVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this unit vector.

Visual Basic
Sub PutUnitVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.PutUnitVectorData Method


UnitVector2d.TransformBy Method

UnitVector2d.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Transform this unit vector2d by the specified matrix.

Visual Basic
Sub TransformBy(Value As Matrix2d)
Parameters
Parameters | Description
Value | Matrix2d for transform.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Methods > UnitVector2d.TransformBy Method


UnitVector2d Properties

UnitVector2d Properties
Summary

The properties of the UnitVector2d class are listed here.

Properties
Name | Description
X | Gets the X-component for this UnitVector2d.
Y | Gets the Y-component for this UnitVector2d.
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Properties


UnitVector2d.X Property

UnitVector2d.X Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the X-component for this UnitVector2d.

Visual Basic
Property X() As double
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Properties > UnitVector2d.X Property


UnitVector2d.Y Property

UnitVector2d.Y Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Y-component for this UnitVector2d.

Visual Basic
Property Y() As double
You are here: Symbol Reference > Inventor Library > Objects > UnitVector2d Interface > UnitVector2d Properties > UnitVector2d.Y Property


UserCoordinateSystem Interface

UserCoordinateSystem Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The UserCoordinateSystem object represents a user coordinate system.

Class Hierarchy
Inventor::UserCoordinateSystem
    Inventor::UserCoordinateSystemProxy
Visual Basic
Public Interface UserCoordinateSystem
Inherits IDispatch
Remarks

A fixed coordinate system, the origin, has always been part of Autodesk Inventor. Now, an additional movable system called a user coordinate system (UCS) allows for more advanced design workflows. You can relocate and rotate the user coordinate system, allowing movement of sketches and components. Benefits include:

  • Design on angles or compound angles, with a collection of workfeatures that have relationships with each other.
  • Sketch placement on a UCS, and remains associative to the UCS.
  • User can constrain to a UCS in assemblies.
  • In drawings, you can place views and annotations relative to the UCS.
  • Commands such as Measure can be relative to a UCS.
  • Import and export documents to IGES, STEP, AEC etc. relative to a UCS.
Notes

Members through which this object may be accessed include:

UserCoordinateSystemDefinition.Parent

UserCoordinateSystemProxy.NativeObject

UserCoordinateSystems.Add

UserCoordinateSystems.Item

See Also

UCS by transformation matrix sample

UCS by three points sample

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface


UserCoordinateSystem Methods

UserCoordinateSystem Methods
Summary

The methods of the UserCoordinateSystem class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the UserCoordinateSystem.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetEndOfPart | Method that repositions the end of part marker relative to the object.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Methods


UserCoordinateSystem.Delete Method

UserCoordinateSystem.Delete Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that deletes the UserCoordinateSystem.

Visual Basic
Sub Delete(ByRef RetainDependentFeaturesAndSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDependentWorkFeatures As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainDependentFeaturesAndSketches | Optional input Boolean that specifies whether to retain dependent features and sketches. Defaults to False.
RetainDependentWorkFeatures | Optional input Boolean that specifies whether to retain dependent work features. Defaults to False.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Methods > UserCoordinateSystem.Delete Method


UserCoordinateSystem.GetReferenceKey Method

UserCoordinateSystem.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Methods > UserCoordinateSystem.GetReferenceKey Method


UserCoordinateSystem.SetEndOfPart Method

UserCoordinateSystem.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that repositions the end of part marker relative to the object.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that specifies whether to position the end of part marker before or after the object.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Methods > UserCoordinateSystem.SetEndOfPart Method


UserCoordinateSystem Properties

UserCoordinateSystem Properties
Summary

The properties of the UserCoordinateSystem class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Definition | Property that returns the UserCoordinateSystemDefinition object that can be used to get and set the inputs for the coordinate system and redefine the coordinate system.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsOwnedByFeature | Property that returns whether this object is owned by a feature (such as a ClientFeature). If True, the OwnedBy property returns the feature.
Name | Property that gets and sets the name of the UserCoordinateSystem. When setting the name, the name must be unique with respect to all other UserCoordinateSystem objects in the document, or an error will occur.
Origin | Property that returns the work point that represents the origin of the coordinate system.
OwnedBy | Property that returns the PartFeature object that owns this object. This property returns Nothing if the IsOwnedByFeature property returns False.
Parent | Property that returns the parent ComponentDefinition object.
Transformation | Property that gets and sets the transformation matrix for the coordinate system. The matrix defines the position and orientation of the user coordinate system with respect to the origin within the document.
Type | Property returning kUserCoordinateSystemObject indicating this object's type.
Visible | Property that gets and sets the visibility of the coordinate system.
XAngle | Property that returns the parameter associated with the rotation angle about the x-axis.
XAxis | Property that returns the work axis that represents the x-axis of the coordinate system.
XOffset | Property that returns the parameter associated with the X offset value.
XYPlane | Property that returns the work plane that represents the X-Y plane of the coordinate system.
XZPlane | Property that returns the work plane that represents the X-Z plane of the coordinate system.
YAngle | Property that returns the parameter associated with the rotation angle about the y-axis.
YAxis | Property that returns the work axis that represents the y-axis of the coordinate system.
YOffset | Property that returns the parameter associated with the Y offset value.
YZPlane | Property that returns the work plane that represents the Y-Z plane of the coordinate system.
ZAngle | Property that returns the parameter associated with the rotation angle about the z-axis.
ZAxis | Property that returns the work axis that represents the z-axis of the coordinate system.
ZOffset | Property that returns the parameter associated with the Z offset value.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties


UserCoordinateSystem.Application Property

UserCoordinateSystem.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Application Property


UserCoordinateSystem.AttributeSets Property

UserCoordinateSystem.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.AttributeSets Property


UserCoordinateSystem.Definition Property

UserCoordinateSystem.Definition Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the UserCoordinateSystemDefinition object that can be used to get and set the inputs for the coordinate system and redefine the coordinate system.

Visual Basic
Property Definition() As UserCoordinateSystemDefinition**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Definition Property


UserCoordinateSystem.HealthStatus Property

UserCoordinateSystem.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.HealthStatus Property


UserCoordinateSystem.IsOwnedByFeature Property

UserCoordinateSystem.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether this object is owned by a feature (such as a ClientFeature). If True, the OwnedBy property returns the feature.

Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.IsOwnedByFeature Property


UserCoordinateSystem.Name Property

UserCoordinateSystem.Name Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the name of the UserCoordinateSystem. When setting the name, the name must be unique with respect to all other UserCoordinateSystem objects in the document, or an error will occur.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Name Property


UserCoordinateSystem.Origin Property

UserCoordinateSystem.Origin Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work point that represents the origin of the coordinate system.

Visual Basic
Property Origin() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Origin Property


UserCoordinateSystem.OwnedBy Property

UserCoordinateSystem.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the PartFeature object that owns this object. This property returns Nothing if the IsOwnedByFeature property returns False.

Visual Basic
Property OwnedBy() As PartFeature**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.OwnedBy Property


UserCoordinateSystem.Parent Property

UserCoordinateSystem.Parent Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Parent Property


UserCoordinateSystem.Transformation Property

UserCoordinateSystem.Transformation Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the transformation matrix for the coordinate system. The matrix defines the position and orientation of the user coordinate system with respect to the origin within the document.

Visual Basic
Property Transformation() As Matrix*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Transformation Property


UserCoordinateSystem.Type Property

UserCoordinateSystem.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kUserCoordinateSystemObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Type Property


UserCoordinateSystem.Visible Property

UserCoordinateSystem.Visible Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the visibility of the coordinate system.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.Visible Property


UserCoordinateSystem.XAngle Property

UserCoordinateSystem.XAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter associated with the rotation angle about the x-axis.

Visual Basic
Property XAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.XAngle Property


UserCoordinateSystem.XAxis Property

UserCoordinateSystem.XAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work axis that represents the x-axis of the coordinate system.

Visual Basic
Property XAxis() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.XAxis Property


UserCoordinateSystem.XOffset Property

UserCoordinateSystem.XOffset Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter associated with the X offset value.

Visual Basic
Property XOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.XOffset Property


UserCoordinateSystem.XYPlane Property

UserCoordinateSystem.XYPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work plane that represents the X-Y plane of the coordinate system.

Visual Basic
Property XYPlane() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.XYPlane Property


UserCoordinateSystem.XZPlane Property

UserCoordinateSystem.XZPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work plane that represents the X-Z plane of the coordinate system.

Visual Basic
Property XZPlane() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.XZPlane Property


UserCoordinateSystem.YAngle Property

UserCoordinateSystem.YAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter associated with the rotation angle about the y-axis.

Visual Basic
Property YAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.YAngle Property


UserCoordinateSystem.YAxis Property

UserCoordinateSystem.YAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work axis that represents the y-axis of the coordinate system.

Visual Basic
Property YAxis() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.YAxis Property


UserCoordinateSystem.YOffset Property

UserCoordinateSystem.YOffset Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter associated with the Y offset value.

Visual Basic
Property YOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.YOffset Property


UserCoordinateSystem.YZPlane Property

UserCoordinateSystem.YZPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work plane that represents the Y-Z plane of the coordinate system.

Visual Basic
Property YZPlane() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.YZPlane Property


UserCoordinateSystem.ZAngle Property

UserCoordinateSystem.ZAngle Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter associated with the rotation angle about the z-axis.

Visual Basic
Property ZAngle() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.ZAngle Property


UserCoordinateSystem.ZAxis Property

UserCoordinateSystem.ZAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the work axis that represents the z-axis of the coordinate system.

Visual Basic
Property ZAxis() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.ZAxis Property


UserCoordinateSystem.ZOffset Property

UserCoordinateSystem.ZOffset Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter associated with the Z offset value.

Visual Basic
Property ZOffset() As Parameter**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystem Interface > UserCoordinateSystem Properties > UserCoordinateSystem.ZOffset Property


UserCoordinateSystemDefinition Interface

UserCoordinateSystemDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Summary

The UserCoordinateSystemDefinition object represents the information that defines a coordinate system. You can use this object as input to the UserCoordinateSystems.Add method to create the actual coordinate system.

Class Hierarchy
Inventor::UserCoordinateSystemDefinition
Visual Basic
Public Interface UserCoordinateSystemDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

UserCoordinateSystem.Definition

UserCoordinateSystems.CreateDefinition

See Also

UCS by transformation matrix sample

UCS by three points sample

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface


UserCoordinateSystemDefinition Methods

UserCoordinateSystemDefinition Methods
Summary

The methods of the UserCoordinateSystemDefinition class are listed here.

Methods
Methods
Name | Description
GetByThreePoints | Method that gets the inputs that fully define the coordinate system. The objects returned will be Nothing if the coordinate system was not parametrically defined (i.e. if the DefinitionType property returns kTransformationDefinitionType). This method returns a failure in assembly documents.
SetByThreePoints | Method that sets the inputs that fully define the coordinate system. This method returns a failure in assembly documents.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Methods


UserCoordinateSystemDefinition.GetByThreePoints Method

UserCoordinateSystemDefinition.GetByThreePoints Method Introduced in Inventor 2011
Summary

Method that gets the inputs that fully define the coordinate system. The objects returned will be Nothing if the coordinate system was not parametrically defined (i.e. if the DefinitionType property returns kTransformationDefinitionType). This method returns a failure in assembly documents.

Visual Basic
Sub GetByThreePoints(ByRef Origin As IDispatch*, ByRef XDirectionPoint As IDispatch*, ByRef YDirectionPoint As IDispatch*)
Parameters
Parameters | Description
Origin | Output object that specifies the origin of the coordinate system. This can be one of the following objects: WorkPoint, Vertex, SketchPoint, SketchPoint3D or Edge. If a linear Edge is specified, it's midpoint is used. If circular or elliptical edges are specified, their center is used.
XDirectionPoint | Output object that specifies a point defining the x-direction for the coordinate system. The vector from the origin to this point defines the x-direction vector. This can be one of the following objects: WorkPoint, Vertex, SketchPoint, SketchPoint3D or Edge. If a linear Edge is specified, it's midpoint is used. If circular or elliptical edges are specified, their center is used.
YDirectionPoint | Output object that specifies a point defining the y-direction for the coordinate system. This can be one of the following objects: WorkPoint, Vertex, SketchPoint, SketchPoint3D or Edge. If a linear Edge is specified, it's midpoint is used. If circular or elliptical edges are specified, their center is used.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Methods > UserCoordinateSystemDefinition.GetByThreePoints Method


UserCoordinateSystemDefinition.SetByThreePoints Method

UserCoordinateSystemDefinition.SetByThreePoints Method Introduced in Inventor 2011
Summary

Method that sets the inputs that fully define the coordinate system. This method returns a failure in assembly documents.

Visual Basic
Sub SetByThreePoints(Origin As IDispatch, XDirectionPoint As IDispatch, YDirectionPoint As IDispatch)
Parameters
Parameters | Description
Origin | Input object that specifies the origin of the coordinate system. This can be one of the following objects: WorkPoint, Vertex, SketchPoint, SketchPoint3D or Edge. If a linear Edge is specified, it's midpoint is used. If circular or elliptical edges are specified, their center is used.
XDirectionPoint | Input object that specifies a point defining the x-direction for the coordinate system. The vector from the origin to this point defines the x-direction vector. This can be one of the following objects: WorkPoint, Vertex, SketchPoint, SketchPoint3D or Edge. If a linear Edge is specified, it's midpoint is used. If circular or elliptical edges are specified, their center is used.
YDirectionPoint | Input object that specifies a point defining the y-direction for the coordinate system. This can be one of the following objects: WorkPoint, Vertex, SketchPoint, SketchPoint3D or Edge. If a linear Edge is specified, it's midpoint is used. If circular or elliptical edges are specified, their center is used.
See Also

UCS by three points sample

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Methods > UserCoordinateSystemDefinition.SetByThreePoints Method


UserCoordinateSystemDefinition Properties

UserCoordinateSystemDefinition Properties
Summary

The properties of the UserCoordinateSystemDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DefinitionType | Property that returns how the inputs for the coordinate system are defined. This can return either kTransformationDefinitionType or kThreePointsDefinitionType.
Parent | Property that returns the parent UserCoordinateSystem of this definition. In the case where this is a newly created UserCoordinateSystemDefinition object, this property will return Nothing because there is not a logical parent for the object.
Transformation | Property that gets and sets the transformation matrix for the coordinate system.
Type | Property returning kUserCoordinateSystemDefinitionObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Properties


UserCoordinateSystemDefinition.Application Property

UserCoordinateSystemDefinition.Application Property Introduced in Inventor 2011
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Properties > UserCoordinateSystemDefinition.Application Property


UserCoordinateSystemDefinition.DefinitionType Property

UserCoordinateSystemDefinition.DefinitionType Property Introduced in Inventor 2011
Summary

Property that returns how the inputs for the coordinate system are defined. This can return either kTransformationDefinitionType or kThreePointsDefinitionType.

Visual Basic
Property DefinitionType() As UCSDefinitionTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Properties > UserCoordinateSystemDefinition.DefinitionType Property


UserCoordinateSystemDefinition.Parent Property

UserCoordinateSystemDefinition.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent UserCoordinateSystem of this definition. In the case where this is a newly created UserCoordinateSystemDefinition object, this property will return Nothing because there is not a logical parent for the object.

Visual Basic
Property Parent() As UserCoordinateSystem**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Properties > UserCoordinateSystemDefinition.Parent Property


UserCoordinateSystemDefinition.Transformation Property

UserCoordinateSystemDefinition.Transformation Property Introduced in Inventor 2011
Summary

Property that gets and sets the transformation matrix for the coordinate system.

Visual Basic
Property Transformation() As Matrix*
Remarks

The matrix defines the position and orientation of the user coordinate system with respect to the origin within the document. When the UserCoordinateSystemDefinition is created using UserCoordinateSystems.CreateDefinition method, this is initialized to an identity matrix. When the definition is obtained from an existing coordinate system, setting this property causes the coordinate system to be repositioned, and the original inputs to the coordinate system (if any) are lost.

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Properties > UserCoordinateSystemDefinition.Transformation Property


UserCoordinateSystemDefinition.Type Property

UserCoordinateSystemDefinition.Type Property Introduced in Inventor 2011
Summary

Property returning kUserCoordinateSystemDefinitionObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemDefinition Interface > UserCoordinateSystemDefinition Properties > UserCoordinateSystemDefinition.Type Property


UserCoordinateSystemProxy Interface

UserCoordinateSystemProxy Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the UserCoordinateSystem object.

Class Hierarchy
Inventor::UserCoordinateSystem
    Inventor::UserCoordinateSystemProxy
Visual Basic
Public Interface UserCoordinateSystemProxy
Inherits UserCoordinateSystem
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemProxy Interface


UserCoordinateSystemProxy Properties

UserCoordinateSystemProxy Properties
Summary

The properties of the UserCoordinateSystemProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemProxy Interface > UserCoordinateSystemProxy Properties


UserCoordinateSystemProxy.ContainingOccurrence Property

UserCoordinateSystemProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemProxy Interface > UserCoordinateSystemProxy Properties > UserCoordinateSystemProxy.ContainingOccurrence Property


UserCoordinateSystemProxy.NativeObject Property

UserCoordinateSystemProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As UserCoordinateSystem**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemProxy Interface > UserCoordinateSystemProxy Properties > UserCoordinateSystemProxy.NativeObject Property


UserCoordinateSystems Interface

UserCoordinateSystems Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The UserCoordinateSystems collection object contains all user coordinate systems within the document and provides methods to create additional ones.

Class Hierarchy
Inventor::UserCoordinateSystems
Visual Basic
Public Interface UserCoordinateSystems
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.UserCoordinateSystems

FlatPattern.UserCoordinateSystems

PartComponentDefinition.UserCoordinateSystems

See Also

UCS by transformation matrix sample

UCS by three points sample

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface


UserCoordinateSystems Methods

UserCoordinateSystems Methods
Summary

The methods of the UserCoordinateSystems class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new User Coordinate System. The newly created UserCoordinateSystem object is returned.
CreateDefinition | Method that creates a new UserCoordinateSystemDefinition object.
Item | Property that returns the specified UserCoordinateSystem object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Methods


UserCoordinateSystems.Add Method

UserCoordinateSystems.Add Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new User Coordinate System. The newly created UserCoordinateSystem object is returned.

Visual Basic
Sub Add(Definition As UserCoordinateSystemDefinition, Result As [out, retval] UserCoordinateSystem*)
Parameters
Parameters | Description
Definition | Input UserCoordinateSystemDefinition object that defines the coordinate system you want to create. A UserCoordinateSystemDefinition object can be created using the UserCoordinateSystems.CreateDefinition method. It can also be obtained from an existing UserCoordinateSystem object.
See Also

UCS by transformation matrix sample

Example

UCS by three points example.

This sample demonstrates the creation of a User Coordinate System (UCS) based on 3 points that define the origin, x-direction and y-direction for the UCS.

Sub CreateUCSBy3Points()

    ' Create a new part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.Documents.Add(DocumentTypeEnum.kPartDocumentObject)

    ' Set a reference to the PartComponentDefinition object
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create 3 workpoints to define the origin, x-direction and y-direction points
    Dim oWorkPoint1 As WorkPoint
    Set oWorkPoint1 = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(2, 0, 0))

    Dim oWorkPoint2 As WorkPoint
    Set oWorkPoint2 = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(4, 0, 0))

    Dim oWorkPoint3 As WorkPoint
    Set oWorkPoint3 = oCompDef.WorkPoints.AddFixed(oTG.CreatePoint(2, 2, 0))

    ' Create an empty definition object
    Dim oUCSDef As UserCoordinateSystemDefinition
    Set oUCSDef = oCompDef.UserCoordinateSystems.CreateDefinition

    ' Set it to be based on the 3 points
    Call oUCSDef.SetByThreePoints(oWorkPoint1, oWorkPoint2, oWorkPoint3)

    ' Create the UCS
    Dim oUCS As UserCoordinateSystem
    Set oUCS = oCompDef.UserCoordinateSystems.Add(oUCSDef)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Methods > UserCoordinateSystems.Add Method


UserCoordinateSystems.CreateDefinition Method

UserCoordinateSystems.CreateDefinition Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that creates a new UserCoordinateSystemDefinition object.

Visual Basic
Sub CreateDefinition(Result As [out, retval] UserCoordinateSystemDefinition*)
Remarks

The object created does not represent a coordinate system but instead is a representation of the information that defines a coordinate system. You can use this object as input to the UserCoordinateSystems.Add method to create the actual coordinate system. The returned UserCoordinateSystemDefinition object returned is fully defined (initialized to an identity matrix) and can be used to create a coordinate system. However, you may want to change some of the values of the UserCoordinateSystemDefinition object before using it to create a coordinate system.

See Also

UCS by three points sample

Example

UCS by transformation matrix example.

This sample demonstrates the creation of a user coordinate system (UCS) by specifying a transformation matrix.

Sub CreateUCSByTransformationMatrix()

    ' Create a new part document
    Dim oDoc As PartDocument
    Set oDoc = ThisApplication.Documents.Add(DocumentTypeEnum.kPartDocumentObject)

    ' Set a reference to the PartComponentDefinition object
    Dim oCompDef As PartComponentDefinition
    Set oCompDef = oDoc.ComponentDefinition

    Dim oTG As TransientGeometry
    Set oTG = ThisApplication.TransientGeometry

    ' Create an identity matrix
    Dim oMatrix As Matrix
    Set oMatrix = oTG.CreateMatrix

    ' Rotate about Z-Axis by 45 degrees
    Call oMatrix.SetToRotation(3.14159 / 4, oTG.CreateVector(0, 0, 1), oTG.CreatePoint(0, 0, 0))

    ' Translate the origin to (2, 2, 2)
    Dim oTranslationMatrix As Matrix
    Set oTranslationMatrix = oTG.CreateMatrix
    Call oTranslationMatrix.SetTranslation(oTG.CreateVector(2, 2, 2))

    Call oMatrix.TransformBy(oTranslationMatrix)

    ' Create an empty definition object
    Dim oUCSDef As UserCoordinateSystemDefinition
    Set oUCSDef = oCompDef.UserCoordinateSystems.CreateDefinition

    ' Set it to be based on the defined matrix
    oUCSDef.Transformation = oMatrix

    ' Create the UCS
    Dim oUCS As UserCoordinateSystem
    Set oUCS = oCompDef.UserCoordinateSystems.Add(oUCSDef)

End Sub
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Methods > UserCoordinateSystems.CreateDefinition Method


UserCoordinateSystems.Item Method

UserCoordinateSystems.Item Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the specified UserCoordinateSystem object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] UserCoordinateSystem*)
Parameters
Parameters | Description
Index | Input Variant value that specifies the UserCoordinateSystem to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the UserCoordinateSystem name. If an out of range index or a name of a non-existent UserCoordinateSystem is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Methods > UserCoordinateSystems.Item Method


UserCoordinateSystems Properties

UserCoordinateSystems Properties
Summary

The properties of the UserCoordinateSystems class are listed here.

Properties
Name | Description
Application | Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.
Count | Property that returns the number of items in the collection.
Type | Property returning kUserCoordinateSystemsObject indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Properties


UserCoordinateSystems.Application Property

UserCoordinateSystems.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the root Application object. It can be set to (QueryInterfaced for) 'Application' when running with Inventor whereas, 'ApprenticeServerComponent' when running with the Apprentice Server.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Properties > UserCoordinateSystems.Application Property


UserCoordinateSystems.Count Property

UserCoordinateSystems.Count Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Properties > UserCoordinateSystems.Count Property


UserCoordinateSystems.Type Property

UserCoordinateSystems.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning kUserCoordinateSystemsObject indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystems Interface > UserCoordinateSystems Properties > UserCoordinateSystems.Type Property


UserCoordinateSystemSettings Interface

UserCoordinateSystemSettings Interface Available in Inventor Available in Server Introduced in Inventor 2010
Summary

The UserCoordinateSystemSettings object provides access to various UCS related document level settings. This object is obtained from the ModelingSettings.UserCoordinateSystemSettings property.

Class Hierarchy
Inventor::UserCoordinateSystemSettings
Visual Basic
Public Interface UserCoordinateSystemSettings
Inherits IDispatch
Notes

Members through which this object may be accessed include:

ModelingSettings.UserCoordinateSystemSettings

You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface


UserCoordinateSystemSettings Properties

UserCoordinateSystemSettings Properties
Summary

The properties of the UserCoordinateSystemSettings class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
DefaultPlane | Property that gets and sets the default plane to use for user coordinate systems. This plane is used by sketch creation and the 'Look At' commands when a UCS is selected. Valid values are kXYPlane, kXZPlane and kYZPlane.
NamingPrefix | Property that gets and sets the prefix to use for the name of new user coordinate systems.
ShowOrigin | Property that gets and sets whether or not to make the origin visible.
ShowTriad | Property that gets and sets whether or not to display the UCS triad.
ShowXAxis | Property that gets and sets whether or not to make the X axis visible.
ShowXYPlane | Property that gets and sets whether or not to make the XY plane visible.
ShowXZPlane | Property that gets and sets whether or not to make the XZ plane visible.
ShowYAxis | Property that gets and sets whether or not to make the Y axis visible.
ShowYZPlane | Property that gets and sets whether or not to make the YZ plane visible.
ShowZAxis | Property that gets and sets whether or not to make the Z axis visible.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties


UserCoordinateSystemSettings.Application Property

UserCoordinateSystemSettings.Application Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.Application Property


UserCoordinateSystemSettings.DefaultPlane Property

UserCoordinateSystemSettings.DefaultPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the default plane to use for user coordinate systems. This plane is used by sketch creation and the 'Look At' commands when a UCS is selected. Valid values are kXYPlane, kXZPlane and kYZPlane.

Visual Basic
Property DefaultPlane() As CoordinateSystemPlaneEnum
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.DefaultPlane Property


UserCoordinateSystemSettings.NamingPrefix Property

UserCoordinateSystemSettings.NamingPrefix Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets the prefix to use for the name of new user coordinate systems.

Visual Basic
Property NamingPrefix() As String
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.NamingPrefix Property


UserCoordinateSystemSettings.ShowOrigin Property

UserCoordinateSystemSettings.ShowOrigin Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the origin visible.

Visual Basic
Property ShowOrigin() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowOrigin Property


UserCoordinateSystemSettings.ShowTriad Property

UserCoordinateSystemSettings.ShowTriad Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to display the UCS triad.

Visual Basic
Property ShowTriad() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowTriad Property


UserCoordinateSystemSettings.ShowXAxis Property

UserCoordinateSystemSettings.ShowXAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the X axis visible.

Visual Basic
Property ShowXAxis() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowXAxis Property


UserCoordinateSystemSettings.ShowXYPlane Property

UserCoordinateSystemSettings.ShowXYPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the XY plane visible.

Visual Basic
Property ShowXYPlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowXYPlane Property


UserCoordinateSystemSettings.ShowXZPlane Property

UserCoordinateSystemSettings.ShowXZPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the XZ plane visible.

Visual Basic
Property ShowXZPlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowXZPlane Property


UserCoordinateSystemSettings.ShowYAxis Property

UserCoordinateSystemSettings.ShowYAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the Y axis visible.

Visual Basic
Property ShowYAxis() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowYAxis Property


UserCoordinateSystemSettings.ShowYZPlane Property

UserCoordinateSystemSettings.ShowYZPlane Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the YZ plane visible.

Visual Basic
Property ShowYZPlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowYZPlane Property


UserCoordinateSystemSettings.ShowZAxis Property

UserCoordinateSystemSettings.ShowZAxis Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that gets and sets whether or not to make the Z axis visible.

Visual Basic
Property ShowZAxis() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.ShowZAxis Property


UserCoordinateSystemSettings.Type Property

UserCoordinateSystemSettings.Type Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserCoordinateSystemSettings Interface > UserCoordinateSystemSettings Properties > UserCoordinateSystemSettings.Type Property


UserInputEvents CoClass

UserInputEvents CoClass Available in Inventor Introduced in Inventor 4
Summary

The UserInputEvents object provides input event notification. For example, use of the context menu.

Class Hierarchy
Inventor::UserInputEvents
Visual Basic
Public Class UserInputEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

CommandManager.UserInputEvents

See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > UserInputEvents CoClass


UserInputEventsObject Interface

UserInputEventsObject Interface Available in Inventor Introduced in Inventor 4
Summary

The UserInputEvents object provides input event notification. For example, use of the context menu.

Class Hierarchy
Inventor::UserInputEventsObject
Visual Basic
Public Interface UserInputEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsObject Interface


UserInputEventsObject Properties

UserInputEventsObject Properties
Summary

The properties of the UserInputEventsObject class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Parent | Property that returns the parent CommandManager object from whom this object can logically be reached.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsObject Interface > UserInputEventsObject Properties


UserInputEventsObject.Application Property

UserInputEventsObject.Application Property Available in Inventor Introduced in Inventor 6
Summary

Property that returns the Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsObject Interface > UserInputEventsObject Properties > UserInputEventsObject.Application Property


UserInputEventsObject.Parent Property

UserInputEventsObject.Parent Property Available in Inventor Introduced in Inventor 6
Summary

Property that returns the parent CommandManager object from whom this object can logically be reached.

Visual Basic
Property Parent() As CommandManager**
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsObject Interface > UserInputEventsObject Properties > UserInputEventsObject.Parent Property


UserInputEventsObject.Type Property

UserInputEventsObject.Type Property Available in Inventor Introduced in Inventor 6
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsObject Interface > UserInputEventsObject Properties > UserInputEventsObject.Type Property


UserInputEventsSink Interface

UserInputEventsSink Interface Available in Inventor Introduced in Inventor 4
Summary

The UserInputEvents object provides input event notification. For example, use of the context menu.

Class Hierarchy
Inventor::UserInputEventsSink
Visual Basic
Public Interface UserInputEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface


UserInputEventsSink Methods

UserInputEventsSink Methods
Summary

The methods of the UserInputEventsSink class are listed here.

Methods
Methods
Name | Description
OnActivateCommand | The OnActivateCommand event notifies the client when a command has been invoked.
OnContextualMiniToolbar | Event that fires before contextual commands are displayed to the user in the graphics window when the user selects an object.
OnDoubleClick | Event that is sent when the user double-clicks in the window.
OnDrag | The OnDrag event notifies the client whenever the end-user performs a drag operation in the graphics window. Using this event, the client can override Inventor's standard drag behavior.
OnLinearMarkingMenu | Event that occurs just before the linear (overflow) marking menu is displayed.
OnPreSelect | Fires when the user hovers over an Inventor object, and it is a potential candidate for selection.
OnRadialMarkingMenu | Event that occurs just before the radial marking menu is displayed.
OnSelect | Fires when the user selects an object by clicking.
OnStopPreSelect | Fires when the user hovers away from an Inventor object and it is no longer highlighted.
OnTerminateCommand | The OnTerminateCommand event notifies the client when a command has been terminated.
OnUnSelect | Event that occurs when the user unselects an entity. This is done in the user interface by pressing the Shift button and selecting a previously selected entity.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods


UserInputEventsSink.OnActivateCommand Method

UserInputEventsSink.OnActivateCommand Method Available in Inventor Introduced in Inventor 10
Summary

The OnActivateCommand event notifies the client when a command has been invoked.

Visual Basic
Sub OnActivateCommand(CommandName As String, Context As NameValueMap)
Parameters
Parameters | Description
CommandName | The internal name of the command. This is the same name as the internal name of the ControlDefinition object associated with this command.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnActivateCommand Method


UserInputEventsSink.OnContextualMiniToolbar Method

UserInputEventsSink.OnContextualMiniToolbar Method Available in Inventor Introduced in Inventor 2012
Summary

Event that fires before contextual commands are displayed to the user in the graphics window when the user selects an object.

Visual Basic
Sub OnContextualMiniToolbar(SelectedEntities As ObjectsEnumerator, DisplayedCommands As NameValueMap, AdditionalInfo As NameValueMap)
Parameters
Parameters | Description
SelectedEntities | Input ObjectsEnumerator that contains the selected entities. This is the same set of entities currently contained in the document’s SelectSet.
DisplayedCommands | Input NameValueMap object that contains the commands that should be displayed. Name contains the internal name of the command and Value contains the entity to be highlighted when the user hovers over this command in the contextual toolbar.
AdditionalInfo | Input NameValueMap object that contains additional information about why the menu is being displayed. This is currently empty.
Remarks

This event is fired to all subscribers in the order they subscribed to the event. The resulting DisplayedCommands from the first subscriber is passed to the second subscriber, and so on. The user sees the final result.

You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnContextualMiniToolbar Method


UserInputEventsSink.OnDoubleClick Method

UserInputEventsSink.OnDoubleClick Method Available in Inventor Introduced in Inventor 2009
Summary

Event that is sent when the user double-clicks in the window.

Visual Basic
Sub OnDoubleClick(SelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View, AdditionalInfo As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
SelectedEntities | Enumerator of entities selected by double click. Count of SelectedEntities will be 0 if user double-clicks in space. If any of the selected objects are not supported by the API, no notification is sent.
Button | Returns an enumerated constant that identifies the button that was clicked to cause the event. The constants correspond to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
ShiftKeys | Returns an enumerated constant that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is clicked. The constants correspond to one or more of those three keys being down. Each of these keys corresponds to a bit: SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Combinations of these are provided as conveniences in the enumerator. For example, if only the ALT key was down, the constant kShiftStateAlt would be returned corresponding to the integer 4. If CTRL and ALT were pressed, the constant kShiftStateCtrlAlt would be returned whose integer value would be 6.
ModelPosition | Returns the coordinates that specify the current location of the mouse pointer in model space and are returned in centimeters. Model Returns Nothing if user double-clicks in browser.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Model Returns Nothing if user double-clicks in browser.
View | Returns the View object where the mouse was pressed.
HandlingCode | Returning kEventCanceled or kEventHandled as the HandlingCode cancels regular Inventor behavior.
Example

"Cancel a double click"

"Demonstrates how to receive (and in this case, cancel) a double click from a user."

Option Explicit
   Private WithEvents oUIEvents As UserInputEvents

   Private Sub Class_Initialize()
       Set oUIEvents = ThisApplication.CommandManager.UserInputEvents
   End Sub

   Private Sub oUIEvents_OnDoubleClick(ByVal SelectedEntities As ObjectsEnumerator, ByVal SelectionDevice As SelectionDeviceEnum, ByVal Button As MouseButtonEnum, ByVal ShiftKeys As ShiftStateEnum, ByVal ModelPosition As Point, ByVal ViewPosition As Point2d, ByVal View As View, ByVal AdditionalInfo As NameValueMap, HandlingCode As HandlingCodeEnum)
       Debug.Print "OnDoubleClick: "; SelectedEntities.Count; SelectionDevice; ShiftKeys; View.Caption
       If SelectionDevice = kBrowserSelection Then
           MsgBox "Hello there! I'm not letting you activate this"
           ThisApplication.CommandManager.ControlDefinitions("AppAboutInventorCmd").Execute2 (False)
           HandlingCode = kEventCanceled
       End If
   End Sub
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnDoubleClick Method


UserInputEventsSink.OnDrag Method

UserInputEventsSink.OnDrag Method Available in Inventor Introduced in Inventor 9
Summary

The OnDrag event notifies the client whenever the end-user performs a drag operation in the graphics window. Using this event, the client can override Inventor's standard drag behavior.

Visual Basic
Sub OnDrag(DragState As DragStateEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, view As View, AdditionalInfo As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
DragState | DragStateEnum indicating the current state of the drag operation. When the drag is initially started this value is kDragStateDragHandlerSelection, indicating the selection of an entity to be dragged. During the drag, this value is kDragStateOnDrag. When the mouse button is released to stop the drag operation this value is kDragStateEndDrag.
ShiftKeys | A value indicating what combinations of the Shift, Control, and Alt keys are currently pressed. This allows you to use combinations of these keys to control options for the command implementing the drag. For example, a Control drag might result in copying the entity.
ModelPosition | The current position of the mouse in model space.
ViewPosition | The current position of the mouse in view space. The coordinates are pixels where the upper-left corner of the view is (0,0).
AdditionalInfo | Input NameValueMap object that contains additional information about why the context menu is being displayed. No additional information is provided for this event.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. Setting this argument to kEventHandled results in turning off Inventor's standard behavior for the drag operation and causing additional OnDrag event notifications to be sent as the end-user continues the drag operation. By responding to these events the client can define their own behavior for the entity being dragged. Setting this to kEventNotHandled will cause Inventor to use its standard drag behavior for the entity being dragged. kEventCanceled is not supported and will result in the same behavior as kEventNotHandled.
View | The View object the drag is taking place within.
Remarks

The following discusses the principles a client needs to understand in order to take advantage of the full capabilities of this event. The OnDrag event notification is sent whenever the end-user begins to perform a drag operation in the graphics window. When the drag is initiated the DragState argument is equal to kDragStateDragHandlerSelection. The client can determine what object is being dragged by checking the contents of the SelectSet object of the active document. If the client wants to override Inventor's standard drag behavior for the object, they need to set the HandlingCode argument to kEventHandled indicating they will handle the drag. If the HandlingCode is set to kEventNotHandled then Inventor will handle the drag. A handling code of kEventCanceled is not supported and will result in the same thing as kEventNotHandled. If the HandlingCode has been set to kEventHandled then the OnDrag event notification will continue to be sent as the end-user continues the drag operation. The DrageState argument will be equal to kDragStateOnDrag while the end-user continues to drag. When the end-user releases the mouse button to stop the drag operation, the DragState argument will be equal to kDragStateEndDrag. By handling the drag, Inventor expects the client to handle all aspects of the drag. The only thing that Inventor does is change the icon to a drag icon and continues to fire the OnDrag event notification. It is up to the client to provide any dynamic feedback during the drag and to perform whatever the final action of the drag is expected to produce, (typically the repositioning of an entity). Using the ModelPosition and ViewPosition arguments Inventor notifies the client of the current position of the mouse to allow them to create any preview graphics.

Example

"OnDrag Event - dragging a WorkPoint Example "

This sample demonstrates the use of the OnDrag event to drag fixed work points when no command is active. This sample only allows drags parallel to the X-Y plane.

This sample is dependent on events and VB only supports events within a class module. To use the sample copy the WorkPointDrag sub into a code module. Create a new class module called clsDragWorkPoint and copy all of the rest of the code into it.

Have a part document open that contains at least one fixed work point. Run the sample and drag the fixed work point.

Option Explicit
Public oDragWorkPoint As clsDragWorkPoint

Sub WorkPointDrag()

    Set oDragWorkPoint = New clsDragWorkPoint
    oDragWorkPoint.Initialize

End Sub

'*************************************************************
' The declarations and functions below need to be copied into
' a class module whose name is "clsDragWorkPoint".  The name
' can be changed but you'll need to change the declaration in
' the calling function "WorkPointDrag" to use the new name.

Option Explicit
Private WithEvents oUserInputEvents As UserInputEvents
Private oIE As InteractionEvents
Private WithEvents oMouseEvents As MouseEvents
Private oIntGraphics As InteractionGraphics
Private oWP As WorkPoint

Public Sub Initialize()

    Set oUserInputEvents = ThisApplication.CommandManager.UserInputEvents

End Sub

Private Sub oUserInputEvents_OnDrag(ByVal DragState As Inventor.DragStateEnum, ByVal ShiftKeys As Inventor.ShiftStateEnum, ByVal ModelPosition As Inventor.Point, ByVal ViewPosition As Inventor.Point2d, ByVal View As Inventor.View, ByVal AdditionalInfo As Inventor.NameValueMap, HandlingCode As Inventor.HandlingCodeEnum)

    Dim oSS As SelectSet
    Set oSS = ThisApplication.ActiveDocument.SelectSet

    If DragState = kDragStateDragHandlerSelection Then

        If oSS.Count = 1 And oSS.Item(1).Type = kWorkPointObject Then

            Set oWP = oSS.Item(1)

            If oWP.DefinitionType = kFixedWorkPoint Then
                HandlingCode = kEventCanceled
                Set oIE = ThisApplication.CommandManager.CreateInteractionEvents
                Set oMouseEvents = oIE.MouseEvents
                oMouseEvents.MouseMoveEnabled = True

                Set oIntGraphics = oIE.InteractionGraphics
                Call oIE.SetCursor(kCursorBuiltInCommonSketchDrag)
                oIE.Start

            End If
        End If
    End If

End Sub

Private Sub oMouseEvents_OnMouseMove(ByVal Button As MouseButtonEnum, ByVal ShiftKeys As ShiftStateEnum, ByVal ModelPosition As Point, ByVal ViewPosition As Point2d, ByVal View As View)
    Dim oSS As SelectSet
    Set oSS = ThisApplication.ActiveDocument.SelectSet

    If oSS.Count = 1 And oSS.Item(1).Type = kWorkPointObject Then

        Dim oWPDef As FixedWorkPointDef
        Set oWPDef = oWP.Definition

        Dim oProjectedPoint As Inventor.Point
        Call ProjectPoint(ModelPosition, oWPDef.Point, oProjectedPoint)

        ' Set a reference to the transient geometry object for user later.
        Dim oTransGeom As TransientGeometry
        Set oTransGeom = ThisApplication.TransientGeometry

        ' Create a graphics data set object.  This object contains all of the
        ' information used to define the graphics.
        Dim oDataSets As GraphicsDataSets
        Set oDataSets = oIntGraphics.GraphicsDataSets

        If oDataSets.Count <> 0 Then
            oDataSets.Item(1).Delete
        End If

        ' Create a coordinate set.
        Dim oCoordSet As GraphicsCoordinateSet
        Set oCoordSet = oDataSets.CreateCoordinateSet(1)

        ' Create an array that contains coordinates that define a set
        ' of outwardly spiraling points.
        Dim oPointCoords(1 To 3) As Double
        ' Define the X, Y, and Z components of the point.
        oPointCoords(1) = oProjectedPoint.X
        oPointCoords(2) = oProjectedPoint.Y
        oPointCoords(3) = oProjectedPoint.Z

        ' Assign the points into the coordinate set.
        Call oCoordSet.PutCoordinates(oPointCoords)

        ' Create the ClientGraphics object.
        Dim oClientGraphics As ClientGraphics
        Set oClientGraphics = oIntGraphics.PreviewClientGraphics

        If oClientGraphics.Count <> 0 Then
            oClientGraphics.Item(1).Delete
        End If

        ' Create a new graphics node within the client graphics objects.
        Dim oPtNode As GraphicsNode
        Set oPtNode = oClientGraphics.AddNode(1)

        ' Create a PointGraphics object within the node.
        Dim oPtGraphics As PointGraphics
        Set oPtGraphics = oPtNode.AddPointGraphics

        ' Assign the coordinate set to the line graphics.
        oPtGraphics.CoordinateSet = oCoordSet
        oPtGraphics.PointRenderStyle = kCrossPointStyle
        ThisApplication.ActiveView.Update
    End If
End Sub

Private Sub oMouseEvents_OnMouseUp(ByVal Button As MouseButtonEnum, ByVal ShiftKeys As ShiftStateEnum, ByVal ModelPosition As Point, ByVal ViewPosition As Point2d, ByVal View As View)

    Dim oSS As SelectSet
    Set oSS = ThisApplication.ActiveDocument.SelectSet

    If oSS.Count = 1 And oSS.Item(1).Type = kWorkPointObject Then

            Dim oWPDef As FixedWorkPointDef
            Set oWPDef = oWP.Definition

            Dim oProjectedPoint As Inventor.Point
            Call ProjectPoint(ModelPosition, oWPDef.Point, oProjectedPoint)

            ' Reposition the fixed work point
            oWPDef.Point = oProjectedPoint
            ThisApplication.ActiveDocument.Update
            oIE.Stop

            Set oWP = Nothing

    End If
End Sub

' Project the ModelPosition to a plane parallel to the
' X-Y plane on which the work point currently is.

Private Sub ProjectPoint(ByVal ModelPosition As Inventor.Point, ByVal WorkPointPosition As Inventor.Point, ProjectedPoint As Inventor.Point)

    ' Set a reference to the camera object
    Dim oCamera As Inventor.Camera
    Set oCamera = ThisApplication.ActiveView.Camera

    Dim oVec As Vector
    Set oVec = oCamera.Eye.VectorTo(oCamera.Target)

    Dim oLine As Line
    Set oLine = ThisApplication.TransientGeometry.CreateLine(ModelPosition, oVec)

    ' Create the z-axis vector
    Dim oZAxis As Vector
    Set oZAxis = ThisApplication.TransientGeometry.CreateVector(0, 0, 1)

    ' Create a plane parallel to the X-Y plane
    Dim oWPPlane As Plane
    Set oWPPlane = ThisApplication.TransientGeometry.CreatePlane(WorkPointPosition, oZAxis)

    Set ProjectedPoint = oWPPlane.IntersectWithLine(oLine)
End Sub
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnDrag Method


UserInputEventsSink.OnLinearMarkingMenu Method

UserInputEventsSink.OnLinearMarkingMenu Method Available in Inventor Introduced in Inventor 2012
Summary

Event that occurs just before the linear (overflow) marking menu is displayed.

Visual Basic
Sub OnLinearMarkingMenu(SelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, LinearMenu As CommandControls, AdditionalInfo As NameValueMap)
Parameters
Parameters | Description
SelectedEntities | Input ObjectsEnumerator that contains the selected entities. This is the same set of entities currently contained in the document’s SelectSet.
SelectionDevice | Input constant denoting whether the menu was invoked via a click in a graphics window (kGraphicsWindowSelection) or by a click in the browser (kBrowserSelection).
LinearMenu | Input/Output CommandControls object. This object represents the contents of the linear menu that will be displayed to the user. Using the functionality of the CommandControls object you can iterate over the current contents and add and remove items from the menu.
AdditionalInfo | Input NameValueMap object that contains additional information about why the menu is being displayed. This is currently empty.
Remarks

A CommandControls object that represents the contents of the menu is provided. This collection object can be edited to redefine the menu. This event also fires when the user has checked the “Use Classic Context Menu” option in the Customize dialog, which allows it to serve completely as a replacement to the now obsolete OnContextMenu event.

This event is fired to all subscribers in the order they subscribed to the event. The resulting CommandControls from the first subscriber is passed to the second subscriber, and so on. The user sees the final result.

You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnLinearMarkingMenu Method


UserInputEventsSink.OnPreSelect Method

UserInputEventsSink.OnPreSelect Method
Summary

Fires when the user hovers over an Inventor object, and it is a potential candidate for selection.

Visual Basic
Sub OnPreSelect(ByRef PreSelectEntity As IDispatch*, ByRef DoHighlight As VARIANT_BOOL, ByRef MorePreSelectEntities As [unique] ObjectCollection*, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
PreSelectEntity | When called, Inventor returns the entity the mouse is currently over. The client though has a chance to change this entity to some other, if so desired. The entity passed back from the call is the one Inventor will highlight for the pre-select.
DoHighlight | Input value that specifies whether the entity should be available for selection or not. If True, this signifies a successful pre-selection and the entity is highlighted by Inventor.
MorePreSelectEntities | Input argument through which you can supply a group of objects that are logically pre-selected along with the one that Inventor found on its own. This argument is ignored if DoHighLight is False. Inventor passes in an empty collection that you can add additional entities to.
SelectionDevice | Returns a constant denoting whether the selection was made via a pick in a graphics window or was it by a pick in the browser or by some other means. An object can also be selected programmatically by calling the selection simulation methods on the CommandManager. A value of kGraphicsWindowSelection indicates it was selected in a graphic window. For all other values the View, ModelPosition, and ViewPosition arguments are meaningless.
ModelPosition | Returns the coordinates that result from projecting the click point onto the selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnPreSelect Method


UserInputEventsSink.OnRadialMarkingMenu Method

UserInputEventsSink.OnRadialMarkingMenu Method Available in Inventor Introduced in Inventor 2012
Summary

Event that occurs just before the radial marking menu is displayed.

Visual Basic
Sub OnRadialMarkingMenu(SelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, RadialMenu As RadialMarkingMenu, AdditionalInfo As NameValueMap)
Parameters
Parameters | Description
SelectedEntities | Input ObjectsEnumerator that contains the selected entities. This is the same set of entities currently contained in the document’s SelectSet.
SelectionDevice | Input constant denoting whether the menu was invoked via a click in a graphics window (kGraphicsWindowSelection) or by a click in the browser (kBrowserSelection).
RadialMenu | Input/Output RadialMarkingMenu object. This object represents the contents of the radial menu that will be displayed to the user. Using the functionality of the RadialMarkingMenu object you edit the controls displayed at the various radial positions.
AdditionalInfo | Input NameValueMap object that contains additional information about why the menu is being displayed. This is currently empty.
Remarks

A RadialMarkingMenu object that represents the contents of the radial menu is provided. This object can be edited to redefine the menu.

This event is fired to all subscribers in the order they subscribed to the event. The resulting RadialMarkingMenu from the first subscriber is passed to the second subscriber, and so on. The user sees the final result.

You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnRadialMarkingMenu Method


UserInputEventsSink.OnSelect Method

UserInputEventsSink.OnSelect Method
Summary

Fires when the user selects an object by clicking.

Visual Basic
Sub OnSelect(JustSelectedEntities As ObjectsEnumerator, ByRef MoreSelectedEntities As [unique] ObjectCollection*, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
JustSelectedEntities | Returns the object(s) that were just selected by the user. This may be the only one selected so far or the latest one in a series during this selection process. Multiple objects may be returned if the user does a window (area) select.
MoreSelectedEntities | Subsequently selected entities.
SelectionDevice | Returns a constant denoting whether the selection was made via a pick in a graphics window or was it by a pick in the browser or by some other means. An object can also be selected programmatically by calling the selection simulation methods on the CommandManager. A value of kGraphicsWindowSelection indicates it was selected in a graphic window. For all other values the View, ModelPosition, and ViewPosition arguments are meaningless.
ModelPosition | Returns the coordinates that result from projecting the click point onto the selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnSelect Method


UserInputEventsSink.OnStopPreSelect Method

UserInputEventsSink.OnStopPreSelect Method
Summary

Fires when the user hovers away from an Inventor object and it is no longer highlighted.

Visual Basic
Sub OnStopPreSelect(ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
ModelPosition | Returns the coordinates that result from projecting the click point onto the selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnStopPreSelect Method


UserInputEventsSink.OnTerminateCommand Method

UserInputEventsSink.OnTerminateCommand Method Available in Inventor Introduced in Inventor 10
Summary

The OnTerminateCommand event notifies the client when a command has been terminated.

Visual Basic
Sub OnTerminateCommand(CommandName As String, Context As NameValueMap)
Parameters
Parameters | Description
CommandName | The internal name of the command. This is the same name as the internal name of the ControlDefinition object associated with this command.
Context | Input NameValueMap object that can be used to determine the context of why the event fired. No context information is provided for this event.
Remarks

There are several things that cause a command to be terminated. When a command finishes it will terminate. For example when you execute the Extrude command, after the extrusion has finished the command terminates. Starting another command while one command is active will cause the active command to terminate. An exception to this is the viewing commands. They just temporarily suspend the active command rather than terminate it. Pressing the escape key will terminate the current command.

You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnTerminateCommand Method


UserInputEventsSink.OnUnSelect Method

UserInputEventsSink.OnUnSelect Method
Summary

Event that occurs when the user unselects an entity. This is done in the user interface by pressing the Shift button and selecting a previously selected entity.

Visual Basic
Sub OnUnSelect(UnSelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View)
Parameters
Parameters | Description
UnSelectedEntities | Returns the object(s) (un)selected by the user to be taken out of the selection set being built.
SelectionDevice | Returns a constant denoting whether the (un)selection was made via a pick in a graphics window or was it by a pick in the browser or by some other means. An object can also be selected programmatically by calling the selection simulation methods on the CommandManager. A value of kGraphicsWindowSelection indicates it was (un)selected in a graphic window. For all other values the View, ModelPosition, and ViewPosition arguments are meaningless.
ModelPosition | Returns the coordinates that result from projecting the click point onto the (un)selected entity. This is returned in centimeters relative to model space. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
ViewPosition | Returns the coordinates that specify the current location of the mouse pointer in window space and are returned in pixels. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
View | Returns the View object where the selection took place. Applicable only when the SelectionDevice argument is kGraphicsWindowSelection.
You are here: Symbol Reference > Inventor Library > Objects > UserInputEventsSink Interface > UserInputEventsSink Methods > UserInputEventsSink.OnUnSelect Method


UserParameter Interface

UserParameter Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Object that represents a parameter that was created by the user.

Class Hierarchy
Inventor::Parameter
    Inventor::UserParameter
Visual Basic
Public Interface UserParameter
Inherits Parameter
Notes

Members through which this object may be accessed include:

ModelParameter.ConvertToUserParameter

ReferenceParameter.ConvertToUserParameter

TableParameter.ConvertToUserParameter

UserParameters.AddByExpression

UserParameters.AddByValue

UserParameters.Item

See Also

Creating a new parameter group sample

You are here: Symbol Reference > Inventor Library > Objects > UserParameter Interface


UserParameter Methods

UserParameter Methods
Summary

The methods of the UserParameter class are listed here.

Methods
Methods
Name | Description
ConvertToModelParameter | Method that causes the parameter to be converted to a model parameter. The new ModelParameter object is returned.
ConvertToReferenceParameter | Method that causes the parameter to be converted to a reference parameter. The new ReferenceParameter object is returned.
You are here: Symbol Reference > Inventor Library > Objects > UserParameter Interface > UserParameter Methods


UserParameter.ConvertToModelParameter Method

UserParameter.ConvertToModelParameter Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that causes the parameter to be converted to a model parameter. The new ModelParameter object is returned.

Visual Basic
Sub ConvertToModelParameter(Result As [out, retval] ModelParameter*)
You are here: Symbol Reference > Inventor Library > Objects > UserParameter Interface > UserParameter Methods > UserParameter.ConvertToModelParameter Method


UserParameter.ConvertToReferenceParameter Method

UserParameter.ConvertToReferenceParameter Method Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that causes the parameter to be converted to a reference parameter. The new ReferenceParameter object is returned.

Visual Basic
Sub ConvertToReferenceParameter(Result As [out, retval] ReferenceParameter*)
You are here: Symbol Reference > Inventor Library > Objects > UserParameter Interface > UserParameter Methods > UserParameter.ConvertToReferenceParameter Method


UserParameters Interface

UserParameters Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to the user parameters ( UserParameter objects) associated with the object the collection was obtained from.

Class Hierarchy
Inventor::UserParameters
Visual Basic
Public Interface UserParameters
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Parameters.UserParameters

You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface


UserParameters Methods

UserParameters Methods
Summary

The methods of the UserParameters class are listed here.

Methods
Methods
Name | Description
_AddByValue | This is _AddByValue, a member of class UserParameters.
AddByExpression | Method that creates a new parameter given a name and expression.
AddByValue | Method that creates a new parameter given a name and equation.
Item | Property that returns the specified UserParameter object from the collection. This is the default property of the UserParameters collection object.
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Methods


UserParameters._AddByValue Method

UserParameters._AddByValue Method
Summary

This is _AddByValue, a member of class UserParameters.

Visual Basic
Sub _AddByValue(Name As String, Value As double, UnitsSpecifier As VARIANT, Result As [out, retval] UserParameter*)
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Methods > UserParameters._AddByValue Method


UserParameters.AddByExpression Method

UserParameters.AddByExpression Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new parameter given a name and expression.

Visual Basic
Sub AddByExpression(Name As String, Expression As String, UnitsSpecifier As VARIANT, Result As [out, retval] UserParameter*)
Parameters
Parameters | Description
Name | Input String value that specifies the name for the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur.
Expression | Input String value that specifies the equation for the parameter. This string is evaluated the same way as strings entered in any of the Autodesk Inventor dialogs are evaluated. For example "x + 3 in / 2 cm" is a valid string for input.
UnitsSpecifier | Input value that specifies the type of unit the parameter is. The units can be specified using either a string defining a valid unit or an item from the UnitsTypeEnum. If the equation references existing parameters, this unit type must be consistent with the unit type defined by the equation, otherwise an error will occur. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in".
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Methods > UserParameters.AddByExpression Method


UserParameters.AddByValue Method

UserParameters.AddByValue Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new parameter given a name and equation.

Visual Basic
Sub AddByValue(Name As String, Value As VARIANT, UnitsSpecifier As VARIANT, Result As [out, retval] UserParameter*)
Parameters
Parameters | Description
Name | Input String value that specifies the name for the parameter. The name must be unique with respect to all other parameters in this document. If a unique name is not specified an error will occur.
Value | Input Double value that specifies the value for the parameter. This value is given in database units for the unit type defined by the UnitType argument.
UnitsSpecifier | Input value that specifies the type of unit the parameter is. The units can be specified using either a string defining a valid unit or an item from the UnitsTypeEnum. If the equation references existing parameters, this unit type must be consistent with the unit type defined by the equation, otherwise an error will occur. You specify a unit type using a value from UnitsTypeEnum or a string that describes a unit. For example, both of the following are valid unit specifiers for inch: kInchLengthUnits and "in". String specifiers are typically used for units that are not defined in the enum list. For example, the volume measure for cubic inches is not defined in the enum list but you can specify it using the string "in in in".
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Methods > UserParameters.AddByValue Method


UserParameters.Item Method

UserParameters.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified UserParameter object from the collection. This is the default property of the UserParameters collection object.

Visual Basic
Sub Item(index As VARIANT, Result As [out, retval] UserParameter*)
Parameters
Parameters | Description
index | Input Variant value that specifies the UserParameter to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the parameter name. If an out of range index or a name of a non-existent parameter is provided, an error occurs.
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Methods > UserParameters.Item Method


UserParameters Properties

UserParameters Properties
Summary

The properties of the UserParameters class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Properties


UserParameters.Count Property

UserParameters.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Properties > UserParameters.Count Property


UserParameters.Type Property

UserParameters.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserParameters Interface > UserParameters Properties > UserParameters.Type Property


VbaApplication Interface

VbaApplication Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The VBAApplication object represents the currently available VBA application.

Class Hierarchy
Inventor::VbaApplication
Visual Basic
Public Interface VbaApplication
Inherits IDispatch
You are here: Symbol Reference > Inventor Library > Objects > VbaApplication Interface


VbaApplication Properties

VbaApplication Properties
Summary

The properties of the VbaApplication class are listed here.

Properties
Name | Description
ThisApplication | Gets the VBA application interface.
ThisServer | This is ThisServer, a member of class VbaApplication.
You are here: Symbol Reference > Inventor Library > Objects > VbaApplication Interface > VbaApplication Properties


VbaApplication.ThisApplication Property

VbaApplication.ThisApplication Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the VBA application interface.

Visual Basic
Property ThisApplication() As Application**
You are here: Symbol Reference > Inventor Library > Objects > VbaApplication Interface > VbaApplication Properties > VbaApplication.ThisApplication Property


VbaApplication.ThisServer Property

VbaApplication.ThisServer Property
Summary

This is ThisServer, a member of class VbaApplication.

Visual Basic
Property ThisServer() As InventorServerObject**
You are here: Symbol Reference > Inventor Library > Objects > VbaApplication Interface > VbaApplication Properties > VbaApplication.ThisServer Property


Vector Interface

Vector Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Vector object. For more information, see the [image] Transient Geometry overview.

Class Hierarchy
Inventor::Vector
Visual Basic
Public Interface Vector
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EllipseFull.MajorAxisVector

EllipticalCone.MajorAxisVector

EllipticalCylinder.MajorAxisVector

Light.Direction

Matrix.Translation

Point.VectorTo

ThreadInfo.ThreadDirection

TransientGeometry.CreateVector

UnitVector.AsVector

Vector.CrossProduct

See Also

OnDrag Event - dragging a WorkPoint sample

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > Vector Interface


Vector Methods

Vector Methods
Summary

The methods of the Vector class are listed here.

Methods
Methods
Name | Description
AddVector | Add the specified vector to this vector.
AngleTo | Determines the angle between this vector and the specified vector.
AsUnitVector | Get the unit vector equivalent of this vector normalized.
CrossProduct | Determine the cross product between this vector and the specified vector.
DotProduct | Determine the dot product of this vector to the specified vector.
GetVectorData | Get the data defining this vector.
IsEqualTo | Compare this vector for equality to the specified vector.
IsParallelTo | Determine if this vector is parallel to the specified vector.
IsPerpendicularTo | Determine if this vector is perpendicular to the specified vector.
Normalize | Normalize this vector to result in a length equal to 1.0.
PutVectorData | Method that sets the data defining this vector.
ScaleBy | Scale this vector by the specified scale factor.
SubtractVector | Subtract the specified vector from this vector.
TransformBy | Transform this vector by the specified matrix.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods


Vector.AddVector Method

Vector.AddVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Add the specified vector to this vector.

Visual Basic
Sub AddVector(Argument As Vector)
Parameters
Parameters | Description
Argument | Input Vector to add.
See Also

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.AddVector Method


Vector.AngleTo Method

Vector.AngleTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determines the angle between this vector and the specified vector.

Visual Basic
Sub AngleTo(Argument As Vector, Result As [out, retval] double)
Parameters
Parameters | Description
Argument | Input Vector used for comparison.
Remarks

When one of the input vectors is null (0,0,0) this method will return -NaN.

You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.AngleTo Method


Vector.AsUnitVector Method

Vector.AsUnitVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the unit vector equivalent of this vector normalized.

Visual Basic
Sub AsUnitVector(Result As [out, retval] UnitVector*)
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.AsUnitVector Method


Vector.CrossProduct Method

Vector.CrossProduct Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine the cross product between this vector and the specified vector.

Visual Basic
Sub CrossProduct(Argument As Vector, Result As [out, retval] Vector*)
Parameters
Parameters | Description
Argument | Input Vector used for comparison.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.CrossProduct Method


Vector.DotProduct Method

Vector.DotProduct Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine the dot product of this vector to the specified vector.

Visual Basic
Sub DotProduct(Argument As Vector, Result As [out, retval] double)
Parameters
Parameters | Description
Argument | Input Vector used for comparison.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.DotProduct Method


Vector.GetVectorData Method

Vector.GetVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this vector.

Visual Basic
Sub GetVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.GetVectorData Method


Vector.IsEqualTo Method

Vector.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Compare this vector for equality to the specified vector.

Visual Basic
Sub IsEqualTo(Argument As Vector, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Argument | Input Vector used for comparison.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the vectors are equal.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.IsEqualTo Method


Vector.IsParallelTo Method

Vector.IsParallelTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine if this vector is parallel to the specified vector.

Visual Basic
Sub IsParallelTo(Argument As Vector, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Argument | Input Vector used for comparison.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the vectors are parallel.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.IsParallelTo Method


Vector.IsPerpendicularTo Method

Vector.IsPerpendicularTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Determine if this vector is perpendicular to the specified vector.

Visual Basic
Sub IsPerpendicularTo(Argument As Vector, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Argument | Input Vector used for comparison.
Tolerance | Input Double that specifies the tolerance to be used when determining whether the vectors are perpendicular.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.IsPerpendicularTo Method


Vector.Normalize Method

Vector.Normalize Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Normalize this vector to result in a length equal to 1.0.

Visual Basic
Sub Normalize()
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.Normalize Method


Vector.PutVectorData Method

Vector.PutVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this vector.

Visual Basic
Sub PutVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.PutVectorData Method


Vector.ScaleBy Method

Vector.ScaleBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Scale this vector by the specified scale factor.

Visual Basic
Sub ScaleBy(Scale As double)
Parameters
Parameters | Description
Scale | Input Double that specifies the scale.
See Also

Is cylindrical face interior or exterior? sample

You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.ScaleBy Method


Vector.SubtractVector Method

Vector.SubtractVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Subtract the specified vector from this vector.

Visual Basic
Sub SubtractVector(Argument As Vector)
Parameters
Parameters | Description
Argument | Input Vector to subtract.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.SubtractVector Method


Vector.TransformBy Method

Vector.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Transform this vector by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As Matrix)
Parameters
Parameters | Description
Matrix | Input Matrix object that specifies the position and orientation of the occurrence.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Methods > Vector.TransformBy Method


Vector Properties

Vector Properties
Summary

The properties of the Vector class are listed here.

Properties
Name | Description
Length | Get the length of this vector.
X | Specifies the X coordinate of the vector. If not supplied, the X value will default to 0.
Y | Specifies the Y coordinate of the vector. If not supplied, the Y value will default to 0.
Z | Specifies the Z coordinate of the vector. If not supplied, the Z value will default to 0.
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Properties


Vector.Length Property

Vector.Length Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the length of this vector.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Properties > Vector.Length Property


Vector.X Property

Vector.X Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the X coordinate of the vector. If not supplied, the X value will default to 0.

Visual Basic
Property X() As double
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Properties > Vector.X Property


Vector.Y Property

Vector.Y Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Y coordinate of the vector. If not supplied, the Y value will default to 0.

Visual Basic
Property Y() As double
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Properties > Vector.Y Property


Vector.Z Property

Vector.Z Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Specifies the Z coordinate of the vector. If not supplied, the Z value will default to 0.

Visual Basic
Property Z() As double
You are here: Symbol Reference > Inventor Library > Objects > Vector Interface > Vector Properties > Vector.Z Property


Vector2d Interface

Vector2d Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Vector2d object. For more information, see the [image] Transient Geometry overview.

Class Hierarchy
Inventor::Vector2d
Visual Basic
Public Interface Vector2d
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EllipseFull2d.MajorAxisVector

Matrix2d.Translation

Point2d.VectorTo

TransientGeometry.CreateVector2d

UnitVector2d.AsVector

See Also

Move sketch entities sample

You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface


Vector2d Methods

Vector2d Methods
Summary

The methods of the Vector2d class are listed here.

Methods
Methods
Name | Description
AddVector | Add the specified vector2d to this vector2d.
AngleTo | Determines the angle between this vector2d and the specified vector2d.
AsUnitVector | Get the unit vector2d equivalent of this vector2d normalized.
DotProduct | Determine the dot product of this vector2d to the specified vector2d.
GetVectorData | Get the data defining this vector.
IsEqualTo | Compare this vector2d for equality to the specified vector2d.
IsParallelTo | Determine if this vector2d is parallel to the specified vector2d.
IsPerpendicularTo | Determine if this vector2d is perpendicular to the specified vector2d.
Normalize | Normalize this vector2d to result in a length equal to 1.0.
PutVectorData | Method that sets the data defining this vector.
ScaleBy | Scale this vector2d by the specified scale factor.
SubtractVector | Subtract the specified vector2d from this vector2d.
TransformBy | Transform this vector2d by the specified matrix.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods


Vector2d.AddVector Method

Vector2d.AddVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Add the specified vector2d to this vector2d.

Visual Basic
Sub AddVector(Value As Vector2d)
Parameters
Parameters | Description
Value | Vector2d to add.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.AddVector Method


Vector2d.AngleTo Method

Vector2d.AngleTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determines the angle between this vector2d and the specified vector2d.

Visual Basic
Sub AngleTo(Vector As Vector2d, Result As [out, retval] double)
Parameters
Parameters | Description
Vector | Vector to measure to.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.AngleTo Method


Vector2d.AsUnitVector Method

Vector2d.AsUnitVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Get the unit vector2d equivalent of this vector2d normalized.

Visual Basic
Sub AsUnitVector(Result As [out, retval] UnitVector2d*)
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.AsUnitVector Method


Vector2d.DotProduct Method

Vector2d.DotProduct Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determine the dot product of this vector2d to the specified vector2d.

Visual Basic
Sub DotProduct(Vector As Vector2d, Result As [out, retval] double)
Parameters
Parameters | Description
Vector | Vector with which to calculate the dot product.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.DotProduct Method


Vector2d.GetVectorData Method

Vector2d.GetVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Get the data defining this vector.

Visual Basic
Sub GetVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.GetVectorData Method


Vector2d.IsEqualTo Method

Vector2d.IsEqualTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Compare this vector2d for equality to the specified vector2d.

Visual Basic
Sub IsEqualTo(Vector As Vector2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | Vector to compare to.
Tolerance | Tolerance for comparison.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.IsEqualTo Method


Vector2d.IsParallelTo Method

Vector2d.IsParallelTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determine if this vector2d is parallel to the specified vector2d.

Visual Basic
Sub IsParallelTo(Vector As Vector2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | Vector to use for parallel test.
Tolerance | Tolerance value for test.
See Also

Create ordinate dimension sample

You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.IsParallelTo Method


Vector2d.IsPerpendicularTo Method

Vector2d.IsPerpendicularTo Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Determine if this vector2d is perpendicular to the specified vector2d.

Visual Basic
Sub IsPerpendicularTo(Vector As Vector2d, ByRef Tolerance As [defaultvalue(0)] double, Result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | Vector to use for perpendicular test.
Tolerance | Tolerance value for test.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.IsPerpendicularTo Method


Vector2d.Normalize Method

Vector2d.Normalize Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Normalize this vector2d to result in a length equal to 1.0.

Visual Basic
Sub Normalize()
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.Normalize Method


Vector2d.PutVectorData Method

Vector2d.PutVectorData Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the data defining this vector.

Visual Basic
Sub PutVectorData(ByRef Coords As SAFEARRAY(double))
Parameters
Parameters | Description
Coords | Input/output Double that specifies the entity's coordinates.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.PutVectorData Method


Vector2d.ScaleBy Method

Vector2d.ScaleBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Scale this vector2d by the specified scale factor.

Visual Basic
Sub ScaleBy(Value As double)
Parameters
Parameters | Description
Value | Scale factor to use.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.ScaleBy Method


Vector2d.SubtractVector Method

Vector2d.SubtractVector Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Subtract the specified vector2d from this vector2d.

Visual Basic
Sub SubtractVector(Value As Vector2d)
Parameters
Parameters | Description
Value | Vector2d to subtract.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.SubtractVector Method


Vector2d.TransformBy Method

Vector2d.TransformBy Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Transform this vector2d by the specified matrix.

Visual Basic
Sub TransformBy(Value As Matrix2d)
Parameters
Parameters | Description
Value | Matrix2d for transform.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Methods > Vector2d.TransformBy Method


Vector2d Properties

Vector2d Properties
Summary

The properties of the Vector2d class are listed here.

Properties
Name | Description
Length | Get the length of this vector2d.
X | Gets the X-component for this Vector2d.
Y | Gets the Y-component for this Vector2d.
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Properties


Vector2d.Length Property

Vector2d.Length Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Get the length of this vector2d.

Visual Basic
Property Length() As double*
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Properties > Vector2d.Length Property


Vector2d.X Property

Vector2d.X Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the X-component for this Vector2d.

Visual Basic
Property X() As double
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Properties > Vector2d.X Property


Vector2d.Y Property

Vector2d.Y Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Y-component for this Vector2d.

Visual Basic
Property Y() As double
You are here: Symbol Reference > Inventor Library > Objects > Vector2d Interface > Vector2d Properties > Vector2d.Y Property


Vertex Interface

Vertex Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Vertex object represents a transient point in boundary representation data.

Class Hierarchy
Inventor::Vertex
    Inventor::VertexProxy
Visual Basic
Public Interface Vertex
Inherits IDispatch
Notes

Members through which this object may be accessed include:

CoincidentConstraint3D.Vertex

Edge.StartVertex

Edge.StopVertex

FilletSetbackVertex.Vertex

Vertex.GetSourceVertex

VertexProxy.NativeObject

Vertices.Item

CoincidentConstraint3D.ConnectedEntity

MateiMateDefinition.Entity

FromToWidthExtent.FromEntity

OffsetWidthExtent.OffsetEntityOne

OffsetWidthExtent.OffsetEntityTwo

LineAndPointWorkAxisDef.Point

NormalToCurveWorkPlaneDef.Point

NormalToSurfaceWorkAxisDef.Point

PlaneAndPointWorkPlaneDef.Point

PointAndPlaneWorkAxisDef.Point

PointAndTangentWorkPlaneDef.Point

PointHolePlacementDefinition.Point

PointWorkPointDef.Point

ThreePointsWorkPlaneDef.Point1

TwoPointsWorkAxisDef.Point1

ThreePointsWorkPlaneDef.Point2

TwoPointsWorkAxisDef.Point2

ThreePointsWorkPlaneDef.Point3

FromToWidthExtent.ToEntity

ToHeightExtent.ToEntity

ToExtent.ToEntity

RectangularPatternFeature.XDirectionStartPoint

RectangularPatternFeature.YDirectionStartPoint

See Also

Sketch Add Oriented sample

You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface


Vertex Methods

Vertex Methods
Summary

The methods of the Vertex class are listed here.

Methods
Methods
Name | Description
GetPoint | Method that gets the coordinates of the vertex point.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetSourceVertex | Method that gets the source vertex that has been overridden by this vertex. The method returns Nothing if this vertex is not an override. An error is returned if this method is called on a vertex in a part.
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Methods


Vertex.GetPoint Method

Vertex.GetPoint Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets the coordinates of the vertex point.

Visual Basic
Sub GetPoint(ByRef Point As SAFEARRAY(double))
Parameters
Parameters | Description
Point | Output Double array that returns the coordinates of the vertex point.
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Methods > Vertex.GetPoint Method


Vertex.GetReferenceKey Method

Vertex.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Methods > Vertex.GetReferenceKey Method


Vertex.GetSourceVertex Method

Vertex.GetSourceVertex Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 10
Summary

Method that gets the source vertex that has been overridden by this vertex. The method returns Nothing if this vertex is not an override. An error is returned if this method is called on a vertex in a part.

Visual Basic
Sub GetSourceVertex(ByRef GetLeafSource As [defaultvalue(-1)] VARIANT_BOOL, Result As [out, retval] Vertex*)
Parameters
Parameters | Description
GetLeafSource | Optional input Boolean that specifies whether to get the 'leaf' source vertex in the case where there are multiple levels of override. If specified to be False, the method returns the next level override vertex. If not specified, the argument defaults to True indicating that the leaf source will be returned.
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Methods > Vertex.GetSourceVertex Method


Vertex Properties

Vertex Properties
Summary

The properties of the Vertex class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Edges | Gets the Edges referenced by this Vertex.
Faces | Property that returns the Faces that this Vertex is referenced from.
IsTolerant | Indicates if this vertex is using tolerant modeling to allow a non-exact model.
Parent | Property that returns the parent object from whom this object can logically be reached.
Point | Property that returns a Point geometry object. The Point object returned provides information about the position of the vertex.
Tolerance | Returns the tolerance being used for modeling calculations and this Vertex.
TransientKey | Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the [image] ReferenceKeys overview.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties


Vertex.Application Property

Vertex.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Application Property


Vertex.AttributeSets Property

Vertex.AttributeSets Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.AttributeSets Property


Vertex.Edges Property

Vertex.Edges Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Gets the Edges referenced by this Vertex.

Visual Basic
Property Edges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Edges Property


Vertex.Faces Property

Vertex.Faces Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Faces that this Vertex is referenced from.

Visual Basic
Property Faces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Faces Property


Vertex.IsTolerant Property

Vertex.IsTolerant Property Available in Apprentice
Summary

Indicates if this vertex is using tolerant modeling to allow a non-exact model.

Visual Basic
Property IsTolerant() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.IsTolerant Property


Vertex.Parent Property

Vertex.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Parent Property


Vertex.Point Property

Vertex.Point Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns a Point geometry object. The Point object returned provides information about the position of the vertex.

Visual Basic
Property Point() As Point**
See Also

Finding Bend Extent (Tangent) Edges sample

You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Point Property


Vertex.Tolerance Property

Vertex.Tolerance Property Available in Apprentice
Summary

Returns the tolerance being used for modeling calculations and this Vertex.

Visual Basic
Property Tolerance() As double*
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Tolerance Property


Vertex.TransientKey Property

Vertex.TransientKey Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that obtains an ID key that can be used to bind back to the live object. This transient key is only valid as long as the document state has not changed. For more information, see the [image] ReferenceKeys overview.

Visual Basic
Property TransientKey() As long*
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.TransientKey Property


Vertex.Type Property

Vertex.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Vertex Interface > Vertex Properties > Vertex.Type Property


VertexDefinition Interface

VertexDefinition Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::VertexDefinition
Visual Basic
Public Interface VertexDefinition
Inherits IDispatch
Notes

Members through which this object may be accessed include:

EdgeDefinition.EndVertex

EdgeDefinition.StartVertex

VertexDefinitions.Add

VertexDefinitions.Item

The VertexDefinition represents a transient definition of a Vertex object.

See Also

Transient surface body creation sample

Transient solid body creation sample

You are here: Symbol Reference > Inventor Library > Objects > VertexDefinition Interface


VertexDefinition Properties

VertexDefinition Properties
Summary

The properties of the VertexDefinition class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
AssociativeID | Property that gets and sets the associate ID of this vertex. This ID will be transferred to the corresponding vertex when this SurfaceBodyDefinition is used to create a SurfaceBody. It is used by Inventor as the identifier for the vertex and is used for tracking this geometry for associativity. A value of -1 for the associative ID indicates that it has not been set.
Position | Property that gets and sets the defined location of the vertex.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinition Interface > VertexDefinition Properties


VertexDefinition.Application Property

VertexDefinition.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinition Interface > VertexDefinition Properties > VertexDefinition.Application Property


VertexDefinition.AssociativeID Property

VertexDefinition.AssociativeID Property
Summary

Property that gets and sets the associate ID of this vertex. This ID will be transferred to the corresponding vertex when this SurfaceBodyDefinition is used to create a SurfaceBody. It is used by Inventor as the identifier for the vertex and is used for tracking this geometry for associativity. A value of -1 for the associative ID indicates that it has not been set.

Visual Basic
Property AssociativeID() As long
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinition Interface > VertexDefinition Properties > VertexDefinition.AssociativeID Property


VertexDefinition.Position Property

VertexDefinition.Position Property
Summary

Property that gets and sets the defined location of the vertex.

Visual Basic
Property Position() As Point*
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinition Interface > VertexDefinition Properties > VertexDefinition.Position Property


VertexDefinition.Type Property

VertexDefinition.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinition Interface > VertexDefinition Properties > VertexDefinition.Type Property


VertexDefinitions Interface

VertexDefinitions Interface Available in Server Available in Inventor Introduced in Inventor 2011
Class Hierarchy
Inventor::VertexDefinitions
Visual Basic
Public Interface VertexDefinitions
Inherits IDispatch
Notes

Members through which this object may be accessed include:

SurfaceBodyDefinition.VertexDefinitions

The VertexDefinitions collection provides access to existing VertexDefinition objects, and allows creation of new VertexDefinition objects.

You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface


VertexDefinitions Methods

VertexDefinitions Methods
Summary

The methods of the VertexDefinitions class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new VertexDefinition within the associated SurfaceBodyDefinition.
Item | Property that returns the specified object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Methods


VertexDefinitions.Add Method

VertexDefinitions.Add Method
Summary

Method that creates a new VertexDefinition within the associated SurfaceBodyDefinition.

Visual Basic
Sub Add(Position As Point, Result As [out, retval] VertexDefinition*)
Parameters
Parameters | Description
Position | Input Point object that specifies the position of the vertex.
See Also

Transient surface body creation sample

You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Methods > VertexDefinitions.Add Method


VertexDefinitions.Item Method

VertexDefinitions.Item Method
Summary

Property that returns the specified object from the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] VertexDefinition*)
Parameters
Parameters | Description
index | Value that specifies the index of the object to return.
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Methods > VertexDefinitions.Item Method


VertexDefinitions Properties

VertexDefinitions Properties
Summary

The properties of the VertexDefinitions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Properties


VertexDefinitions.Application Property

VertexDefinitions.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Properties > VertexDefinitions.Application Property


VertexDefinitions.Count Property

VertexDefinitions.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Properties > VertexDefinitions.Count Property


VertexDefinitions.Type Property

VertexDefinitions.Type Property
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > VertexDefinitions Interface > VertexDefinitions Properties > VertexDefinitions.Type Property


VertexProxy Interface

VertexProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the Vertex object.

Class Hierarchy
Inventor::Vertex
    Inventor::VertexProxy
Visual Basic
Public Interface VertexProxy
Inherits Vertex
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > VertexProxy Interface


VertexProxy Properties

VertexProxy Properties
Summary

The properties of the VertexProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Property that returns the raw native object in the leaf ComponentDefinition space that this proxy is a wrapper for. The object proxy is in the assembly context. The NativeObject property returns the object definition - the object without its containing occurrence context.For more detailed information about object proxies, please see [image] More Proxy Information.
You are here: Symbol Reference > Inventor Library > Objects > VertexProxy Interface > VertexProxy Properties


VertexProxy.ContainingOccurrence Property

VertexProxy.ContainingOccurrence Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > VertexProxy Interface > VertexProxy Properties > VertexProxy.ContainingOccurrence Property


VertexProxy.NativeObject Property

VertexProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the raw native object in the leaf ComponentDefinition space that this proxy is a wrapper for. The object proxy is in the assembly context. The NativeObject property returns the object definition - the object without its containing occurrence context.For more detailed information about object proxies, please see [image] More Proxy Information.

Visual Basic
Property NativeObject() As Vertex**
You are here: Symbol Reference > Inventor Library > Objects > VertexProxy Interface > VertexProxy Properties > VertexProxy.NativeObject Property


VerticalAlignConstraint Interface

VerticalAlignConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The VeticalAlignConstraint object represents a constraint the makes two sketch points align vertically.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::VerticalAlignConstraint
        Inventor::VerticalAlignConstraintProxy
Visual Basic
Public Interface VerticalAlignConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddVerticalAlign

VerticalAlignConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraint Interface


VerticalAlignConstraint Properties

VerticalAlignConstraint Properties
Summary

The properties of the VerticalAlignConstraint class are listed here.

Properties
Name | Description
PointOne | Property that returns the first sketch point being constrained.
PointTwo | Property that returns the second sketch point being constrained.
You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraint Interface > VerticalAlignConstraint Properties


VerticalAlignConstraint.PointOne Property

VerticalAlignConstraint.PointOne Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the first sketch point being constrained.

Visual Basic
Property PointOne() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraint Interface > VerticalAlignConstraint Properties > VerticalAlignConstraint.PointOne Property


VerticalAlignConstraint.PointTwo Property

VerticalAlignConstraint.PointTwo Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the second sketch point being constrained.

Visual Basic
Property PointTwo() As SketchPoint**
You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraint Interface > VerticalAlignConstraint Properties > VerticalAlignConstraint.PointTwo Property


VerticalAlignConstraintProxy Interface

VerticalAlignConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the VerticalAlignConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::VerticalAlignConstraint
        Inventor::VerticalAlignConstraintProxy
Visual Basic
Public Interface VerticalAlignConstraintProxy
Inherits VerticalAlignConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraintProxy Interface


VerticalAlignConstraintProxy Properties

VerticalAlignConstraintProxy Properties
Summary

The properties of the VerticalAlignConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraintProxy Interface > VerticalAlignConstraintProxy Properties


VerticalAlignConstraintProxy.ContainingOccurrence Property

VerticalAlignConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraintProxy Interface > VerticalAlignConstraintProxy Properties > VerticalAlignConstraintProxy.ContainingOccurrence Property


VerticalAlignConstraintProxy.NativeObject Property

VerticalAlignConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As VerticalAlignConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > VerticalAlignConstraintProxy Interface > VerticalAlignConstraintProxy Properties > VerticalAlignConstraintProxy.NativeObject Property


VerticalConstraint Interface

VerticalConstraint Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

The VerticalConstraint object represents a vertical constraint within a sketch.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::VerticalConstraint
        Inventor::VerticalConstraintProxy
Visual Basic
Public Interface VerticalConstraint
Inherits GeometricConstraint
Notes

Members through which this object may be accessed include:

GeometricConstraints.AddVertical

VerticalConstraintProxy.NativeObject

You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraint Interface


VerticalConstraint Properties

VerticalConstraint Properties
Summary

The properties of the VerticalConstraint class are listed here.

Properties
Name | Description
Entity | Property that returns the sketch entity being constrained. This can be a sketch line, ellipse, or elliptical arc.
UseEllipseMajorAxis | Property used in the case where the entity returned by the Entity property is an ellipse. This property specifies if the major or minor axis of the ellipse is vertical. True if it is the major axis.
You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraint Interface > VerticalConstraint Properties


VerticalConstraint.Entity Property

VerticalConstraint.Entity Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the sketch entity being constrained. This can be a sketch line, ellipse, or elliptical arc.

Visual Basic
Property Entity() As SketchEntity**
You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraint Interface > VerticalConstraint Properties > VerticalConstraint.Entity Property


VerticalConstraint.UseEllipseMajorAxis Property

VerticalConstraint.UseEllipseMajorAxis Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property used in the case where the entity returned by the Entity property is an ellipse. This property specifies if the major or minor axis of the ellipse is vertical. True if it is the major axis.

Visual Basic
Property UseEllipseMajorAxis() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraint Interface > VerticalConstraint Properties > VerticalConstraint.UseEllipseMajorAxis Property


VerticalConstraintProxy Interface

VerticalConstraintProxy Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the VerticalConstraint object.

Class Hierarchy
Inventor::GeometricConstraint
    Inventor::VerticalConstraint
        Inventor::VerticalConstraintProxy
Visual Basic
Public Interface VerticalConstraintProxy
Inherits VerticalConstraint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraintProxy Interface


VerticalConstraintProxy Properties

VerticalConstraintProxy Properties
Summary

The properties of the VerticalConstraintProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraintProxy Interface > VerticalConstraintProxy Properties


VerticalConstraintProxy.ContainingOccurrence Property

VerticalConstraintProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraintProxy Interface > VerticalConstraintProxy Properties > VerticalConstraintProxy.ContainingOccurrence Property


VerticalConstraintProxy.NativeObject Property

VerticalConstraintProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As VerticalConstraint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > VerticalConstraintProxy Interface > VerticalConstraintProxy Properties > VerticalConstraintProxy.NativeObject Property


Vertices Interface

Vertices Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

The Vertices object represents a collection of Vertex objects.

Class Hierarchy
Inventor::Vertices
Visual Basic
Public Interface Vertices
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Face.Vertices

SurfaceBody.Vertices

You are here: Symbol Reference > Inventor Library > Objects > Vertices Interface


Vertices Methods

Vertices Methods
Summary

The methods of the Vertices class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > Vertices Interface > Vertices Methods


Vertices.Item Method

Vertices.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] Vertex*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the Vertex to return.
You are here: Symbol Reference > Inventor Library > Objects > Vertices Interface > Vertices Methods > Vertices.Item Method


Vertices Properties

Vertices Properties
Summary

The properties of the Vertices class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Vertices Interface > Vertices Properties


Vertices.Count Property

Vertices.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Vertices Interface > Vertices Properties > Vertices.Count Property


Vertices.Type Property

Vertices.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Vertices Interface > Vertices Properties > Vertices.Type Property


View Interface

View Interface Available in Inventor Introduced in Inventor 4
Summary

The View object represents a view in a document.

Class Hierarchy
Inventor::View
Visual Basic
Public Interface View
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.ActiveView

FlatPattern.GetView

ViewList.Item

Views.Add

ViewsEnumerator.Item

See Also

Create sheet metal lofted flange feature sample

Create sheet metal rip feature sample

Create sheet metal face and fold features sample

Client graphics - image in point graphics sample

Create client graphics based on the solid body of the active part sample

Client graphics texture-based color mapping sample

Client graphics texture-based color mapping sample

Transient solid body creation sample

OnDrag Event - dragging a WorkPoint sample

Cancel a double click sample

Create curve primitives sample

Create curve primitives sample

Create 3D primitives using client graphics (C#) sample

Client graphics creation of 3D primitives sample

You are here: Symbol Reference > Inventor Library > Objects > View Interface


View Methods

View Methods
Summary

The methods of the View class are listed here.

Methods
Methods
Name | Description
Activate | Method that causes this view to become the active view (i.e. receive user-focus).
Close | Method that closes the view. If only one view exists for a document and the Close method is called it will also cause the Document to close.
Fit | Method that fits all of the contents of the document within the view. Can optionally cause the display of the view to be updated.
GetWindowExtents | Method that returns the current size and position of the view's window.
GoHome | Method that sets the view to the default view of the model.
Move | Method that moves the window this view is contained within.
ResetFront | Method that resets the front view to the factory default.
SaveAsBitmap | Method that saves the view as a bitmap.
SetCurrentAsFront | Method that sets the current view as the front view.
SetCurrentAsHome | Method that sets the current view as the home view.
SetCurrentAsTop | Method that sets the current view as the top view.
Update | Method that causes the view to update. In some cases, changes made to a model or to the view will not immediately be shown in the view and the Update method must be called to cause the view to refresh.
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods


View.Activate Method

View.Activate Method Available in Inventor Introduced in Inventor 4
Summary

Method that causes this view to become the active view (i.e. receive user-focus).

Visual Basic
Sub Activate()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.Activate Method


View.Close Method

View.Close Method Available in Inventor Introduced in Inventor 4
Summary

Method that closes the view. If only one view exists for a document and the Close method is called it will also cause the Document to close.

Visual Basic
Sub Close()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.Close Method


View.Fit Method

View.Fit Method Available in Inventor Introduced in Inventor 4
Summary

Method that fits all of the contents of the document within the view. Can optionally cause the display of the view to be updated.

Visual Basic
Sub Fit(ByRef DoUpdate As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
DoUpdate | Input Boolean that specifies whether to update the view after the document contents have been fitted into it. The default is to perform the update.
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.Fit Method


View.GetWindowExtents Method

View.GetWindowExtents Method Available in Inventor Introduced in Inventor 4
Summary

Method that returns the current size and position of the view's window.

Visual Basic
Sub GetWindowExtents(ByRef Top As long, ByRef Left As long, ByRef Height As long, ByRef Width As long)
Parameters
Parameters | Description
Top | Output Long that contains the position of the top edge of the window (including the entire frame of the window). The value returned is in pixels relative to screen space.
Left | Output Long that contains the position of the left edge of the window (including the entire frame of the window). The value returned is in pixels relative to screen space.
height | Output Long that contains the height of the window (including the entire frame of the window). The value returned is in pixels.
width | Output Long that contains the width of the window (including the entire frame of the window). The value returned is in pixels.
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.GetWindowExtents Method


View.GoHome Method

View.GoHome Method
Summary

Method that sets the view to the default view of the model.

Visual Basic
Sub GoHome()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.GoHome Method


View.Move Method

View.Move Method Available in Inventor Introduced in Inventor 6
Summary

Method that moves the window this view is contained within.

Visual Basic
Sub Move(Top As long, Left As long, Height As long, Width As long)
Parameters
Parameters | Description
Top | Input Long that specifies the position of the top edge of the window (including the entire frame of the window). The value specified is in pixels and relative to screen space.
Left | Input Long that specifies the position of the left edge of the window (including the entire frame of the window). The value specified is in pixels and relative to screen space.
height | Input Long that specifies the height of the window (including the entire frame of the window). The value specified is in pixels.
width | Input Long that specifies the width of the window (including the entire frame of the window). The value specified is in pixels.
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.Move Method


View.ResetFront Method

View.ResetFront Method
Summary

Method that resets the front view to the factory default.

Visual Basic
Sub ResetFront()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.ResetFront Method


View.SaveAsBitmap Method

View.SaveAsBitmap Method Available in Inventor Introduced in Inventor 6
Summary

Method that saves the view as a bitmap.

Visual Basic
Sub SaveAsBitmap(FullFilename As String, Width As long, Height As long)
Parameters
Parameters | Description
FullFileName | Input String value that specifies the full filename of the file to which to save the view.
width | Input Long that specifies the width of the view.
height | Input Long that specifies the height of the view.
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.SaveAsBitmap Method


View.SetCurrentAsFront Method

View.SetCurrentAsFront Method
Summary

Method that sets the current view as the front view.

Visual Basic
Sub SetCurrentAsFront()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.SetCurrentAsFront Method


View.SetCurrentAsHome Method

View.SetCurrentAsHome Method
Summary

Method that sets the current view as the home view.

Visual Basic
Sub SetCurrentAsHome(ByRef FitToView As [defaultvalue(-1)] VARIANT_BOOL)
Parameters
Parameters | Description
FitToView | Optional input Boolean that specifies whether to set the view extent as "view all" (fit to view) or to the extent of the model that currently fills the view (fixed distance).
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.SetCurrentAsHome Method


View.SetCurrentAsTop Method

View.SetCurrentAsTop Method
Summary

Method that sets the current view as the top view.

Visual Basic
Sub SetCurrentAsTop()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.SetCurrentAsTop Method


View.Update Method

View.Update Method Available in Inventor Introduced in Inventor 4
Summary

Method that causes the view to update. In some cases, changes made to a model or to the view will not immediately be shown in the view and the Update method must be called to cause the view to refresh.

Visual Basic
Sub Update()
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Methods > View.Update Method


View Properties

View Properties
Summary

The properties of the View class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Camera | Property that returns a Camera object which contains the information that defines the current contents of the view.
Caption | Property that gets and sets the caption of the view. The caption is the title of the window.
DisplayMode | Property that gets and sets the visual style used for the contents of the view. The valid options are kHiddenEdgeRendering, kShadedRendering, and kWireframeRendering.
Document | Property that returns the Document the view is associated with.
Height | Gets/Sets the Height of the view window.
HWND | Property that returns the hWnd for the window. This provides convenient access to the window's hWnd. Having the hWnd allows you to use various Windows API calls with the window.
Left | Gets/Sets the distance between the left edge of the view window and left edge of the frame window.
Parent | Property that returns the parent Document object from whom this object can logically be reached.
RayTracing | Property that gets and sets whether to enable ray tracing for the view.
RayTracingQuality | This is RayTracingQuality, a member of class View.
ShowAmbientShadows | Property that gets and sets whether to display ambient shadows.
ShowGroundPlane | Property that gets and sets whether to display the ground plane. Setting this property overrides the setting for this view only.
ShowGroundReflections | Property that gets and sets whether to display ground plane reflections. Setting this property overrides the setting for this view only.
ShowGroundShadows | Property that gets and sets whether to display ground shadows.
ShowObjectShadows | Property that gets and sets whether to display object shadows.
Top | Gets/Sets the distance between the top of the view window and top of the frame window.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
Visible | Property that gets and sets whether the view is visible or not.
Width | Gets/Sets the Width of the view window.
WindowState | Gets/Sets this windows state.
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties


View.Application Property

View.Application Property
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Application Property


View.Camera Property

View.Camera Property Available in Inventor Introduced in Inventor 4
Summary

Property that returns a Camera object which contains the information that defines the current contents of the view.

Visual Basic
Property Camera() As Camera**
Remarks

Each time this property is used a new Camera object is returned. The Camera object returned by the Camera property contains the current camera settings of the view. This is important to understand because changing the camera may not otherwise behave as expected. For example the following code will result in no changes to the view contents.

Dim oView As View
Set oView = ThisApplication.ActiveView
oView.Camera.ViewOrientationType = kIsoTopRightViewOrientation
oView.Camera.Apply

The reason this doesn't result in changing the contents of the view is because the Apply is called on a camera that hasn't been changed from the current view. In this example, a new Camera is returned for the third and fourth lines. The view orientation is set on a camera and then the Apply is called on a different camera. The following code will create the desired result.

Dim oView As View
Set oView = ThisApplication.ActiveView
Dim oCamera As Camera
Set oCamera = oView.Camera
oCamera.ViewOrientationType = kIsoTopRightViewOrientation
oCamera.Apply

In this case a Camera object is obtained and this single object is used to set the view orientation and apply the changes to the view.

See Also

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Camera Property


View.Caption Property

View.Caption Property Available in Inventor Introduced in Inventor 4
Summary

Property that gets and sets the caption of the view. The caption is the title of the window.

Visual Basic
Property Caption() As String
See Also

Cancel a double click sample

You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Caption Property


View.DisplayMode Property

View.DisplayMode Property Available in Inventor Introduced in Inventor 5
Summary

Property that gets and sets the visual style used for the contents of the view. The valid options are kHiddenEdgeRendering, kShadedRendering, and kWireframeRendering.

Visual Basic
Property DisplayMode() As DisplayModeEnum
See Also

Client graphics texture-based color mapping sample

You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.DisplayMode Property


View.Document Property

View.Document Property Available in Inventor Introduced in Inventor 4
Summary

Property that returns the Document the view is associated with.

Visual Basic
Property Document() As Document**
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Document Property


View.Height Property

View.Height Property Available in Inventor Introduced in Inventor 2010
Summary

Gets/Sets the Height of the view window.

Visual Basic
Property Height() As long
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Height Property


View.HWND Property

View.HWND Property Available in Inventor Introduced in Inventor 4
Summary

Property that returns the hWnd for the window. This provides convenient access to the window's hWnd. Having the hWnd allows you to use various Windows API calls with the window.

Visual Basic
Property HWND() As long*
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.HWND Property


View.Left Property

View.Left Property Available in Inventor Introduced in Inventor 6
Summary

Gets/Sets the distance between the left edge of the view window and left edge of the frame window.

Visual Basic
Property Left() As long
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Left Property


View.Parent Property

View.Parent Property Available in Inventor Introduced in Inventor 4
Summary

Property that returns the parent Document object from whom this object can logically be reached.

Visual Basic
Property Parent() As Document**
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Parent Property


View.RayTracing Property

View.RayTracing Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether to enable ray tracing for the view.

Visual Basic
Property RayTracing() As VARIANT_BOOL
Remarks

This property applies only for realistic, shaded and monochrome display modes. For all other display modes, this property returns False and cannot be set to True.

You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.RayTracing Property


View.RayTracingQuality Property

View.RayTracingQuality Property
Summary

This is RayTracingQuality, a member of class View.

Visual Basic
Property RayTracingQuality() As RayTracingQualityEnum
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.RayTracingQuality Property


View.ShowAmbientShadows Property

View.ShowAmbientShadows Property
Summary

Property that gets and sets whether to display ambient shadows.

Visual Basic
Property ShowAmbientShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.ShowAmbientShadows Property


View.ShowGroundPlane Property

View.ShowGroundPlane Property
Summary

Property that gets and sets whether to display the ground plane. Setting this property overrides the setting for this view only.

Visual Basic
Property ShowGroundPlane() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.ShowGroundPlane Property


View.ShowGroundReflections Property

View.ShowGroundReflections Property
Summary

Property that gets and sets whether to display ground plane reflections. Setting this property overrides the setting for this view only.

Visual Basic
Property ShowGroundReflections() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.ShowGroundReflections Property


View.ShowGroundShadows Property

View.ShowGroundShadows Property
Summary

Property that gets and sets whether to display ground shadows.

Visual Basic
Property ShowGroundShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.ShowGroundShadows Property


View.ShowObjectShadows Property

View.ShowObjectShadows Property
Summary

Property that gets and sets whether to display object shadows.

Visual Basic
Property ShowObjectShadows() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.ShowObjectShadows Property


View.Top Property

View.Top Property Available in Inventor Introduced in Inventor 6
Summary

Gets/Sets the distance between the top of the view window and top of the frame window.

Visual Basic
Property Top() As long
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Top Property


View.Type Property

View.Type Property Available in Inventor Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Type Property


View.Visible Property

View.Visible Property Available in Inventor Introduced in Inventor 4
Summary

Property that gets and sets whether the view is visible or not.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Visible Property


View.Width Property

View.Width Property Available in Inventor Introduced in Inventor 2010
Summary

Gets/Sets the Width of the view window.

Visual Basic
Property Width() As long
See Also

Render the active document in Inventor Studio. sample

You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.Width Property


View.WindowState Property

View.WindowState Property Available in Inventor Introduced in Inventor 6
Summary

Gets/Sets this windows state.

Visual Basic
Property WindowState() As WindowsSizeEnum
You are here: Symbol Reference > Inventor Library > Objects > View Interface > View Properties > View.WindowState Property


ViewList Interface

ViewList Interface Available in Inventor Available in Server Introduced in Inventor 9
Summary

A ViewList object is a collection of View objects.

Class Hierarchy
Inventor::ViewList
Visual Basic
Public Interface ViewList
Inherits IDispatch
Notes

Members through which this object may be accessed include:

GraphicsNode.VisibleInViews

You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface


ViewList Methods

ViewList Methods
Summary

The methods of the ViewList class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a View object to the collection.
Item | Property that returns the specified object in the collection.
Remove | Method that removes a View object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Methods


ViewList.Add Method

ViewList.Add Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that adds a View object to the collection.

Visual Basic
Sub Add(View As View)
Parameters
Parameters | Description
View | View object to add.
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Methods > ViewList.Add Method


ViewList.Item Method

ViewList.Item Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the specified object in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] View*)
Parameters
Parameters | Description
index | Input Long that specifies the index within the collection of the item to return.
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Methods > ViewList.Item Method


ViewList.Remove Method

ViewList.Remove Method Available in Inventor Available in Server Introduced in Inventor 9
Summary

Method that removes a View object from the collection.

Visual Basic
Sub Remove(View As View)
Parameters
Parameters | Description
View | View object to remove.
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Methods > ViewList.Remove Method


ViewList Properties

ViewList Properties
Summary

The properties of the ViewList class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Properties


ViewList.Count Property

ViewList.Count Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Properties > ViewList.Count Property


ViewList.Type Property

ViewList.Type Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ViewList Interface > ViewList Properties > ViewList.Type Property


Views Interface

Views Interface Available in Inventor Introduced in Inventor 4
Summary

The Views collection object provides access to all of the graphic View objects associated with a particular document. It also provides functionality to create new views.

Class Hierarchy
Inventor::ViewsEnumerator
    Inventor::Views
Visual Basic
Public Interface Views
Inherits ViewsEnumerator
Notes

Members through which this object may be accessed include:

Document.Views

You are here: Symbol Reference > Inventor Library > Objects > Views Interface


Views Methods

Views Methods
Summary

The methods of the Views class are listed here.

Methods
Methods
Name | Description
Add | Create a new view of the document.
You are here: Symbol Reference > Inventor Library > Objects > Views Interface > Views Methods


Views.Add Method

Views.Add Method Available in Inventor Introduced in Inventor 4
Summary

Create a new view of the document.

Visual Basic
Sub Add(Result As [out, retval] View*)
You are here: Symbol Reference > Inventor Library > Objects > Views Interface > Views Methods > Views.Add Method


ViewsEnumerator Interface

ViewsEnumerator Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The ViewsEnumerator object provides access to a list of View objects.

Class Hierarchy
Inventor::ViewsEnumerator
    Inventor::Views
Visual Basic
Public Interface ViewsEnumerator
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.Views

You are here: Symbol Reference > Inventor Library > Objects > ViewsEnumerator Interface


ViewsEnumerator Methods

ViewsEnumerator Methods
Summary

The methods of the ViewsEnumerator class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > ViewsEnumerator Interface > ViewsEnumerator Methods


ViewsEnumerator.Item Method

ViewsEnumerator.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(Index As long, Result As [out, retval] View*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the View to return.
You are here: Symbol Reference > Inventor Library > Objects > ViewsEnumerator Interface > ViewsEnumerator Methods > ViewsEnumerator.Item Method


ViewsEnumerator Properties

ViewsEnumerator Properties
Summary

The properties of the ViewsEnumerator class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > ViewsEnumerator Interface > ViewsEnumerator Properties


ViewsEnumerator.Count Property

ViewsEnumerator.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > ViewsEnumerator Interface > ViewsEnumerator Properties > ViewsEnumerator.Count Property


ViewsEnumerator.Type Property

ViewsEnumerator.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > ViewsEnumerator Interface > ViewsEnumerator Properties > ViewsEnumerator.Type Property


VirtualComponentDefinition Interface

VirtualComponentDefinition Interface Available in Inventor Available in Server Introduced in Inventor 10
Summary

This object derives from the ComponentDefinition object. It represents a ComponentDefinition that exists solely for the BOM.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::VirtualComponentDefinition
Visual Basic
Public Interface VirtualComponentDefinition
Inherits ComponentDefinition
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > VirtualComponentDefinition Interface


VirtualComponentDefinition Properties

VirtualComponentDefinition Properties
Summary

The properties of the VirtualComponentDefinition class are listed here.

Properties
Name | Description
DisplayName | Property that returns the display name. This is the name that is displayed to the user.
Material | Property that gets and sets the material associated with the virtual component.
PropertySets | Property that gets the PropertySets object associated with the virtual component.
You are here: Symbol Reference > Inventor Library > Objects > VirtualComponentDefinition Interface > VirtualComponentDefinition Properties


VirtualComponentDefinition.DisplayName Property

VirtualComponentDefinition.DisplayName Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that returns the display name. This is the name that is displayed to the user.

Visual Basic
Property DisplayName() As String
You are here: Symbol Reference > Inventor Library > Objects > VirtualComponentDefinition Interface > VirtualComponentDefinition Properties > VirtualComponentDefinition.DisplayName Property


VirtualComponentDefinition.Material Property

VirtualComponentDefinition.Material Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets the material associated with the virtual component.

Visual Basic
Property Material() As Material*
You are here: Symbol Reference > Inventor Library > Objects > VirtualComponentDefinition Interface > VirtualComponentDefinition Properties > VirtualComponentDefinition.Material Property


VirtualComponentDefinition.PropertySets Property

VirtualComponentDefinition.PropertySets Property Available in Inventor Available in Server Introduced in Inventor 10
Summary

Property that gets the PropertySets object associated with the virtual component.

Visual Basic
Property PropertySets() As PropertySets**
See Also

Using the BOM APIs sample

You are here: Symbol Reference > Inventor Library > Objects > VirtualComponentDefinition Interface > VirtualComponentDefinition Properties > VirtualComponentDefinition.PropertySets Property


Weld Interface

Weld Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The Weld object represents a weld within an assembly. The Weld object is a base class of the CosmeticWeld and WeldBead objects. kAssemblyFeatureGroup : General assembly group.

kPreperationsFeatureGroup : Preparations group.

kWeldsFeatureGroup : Welds group.

kMachiningFeatureGroup : Machining group.

Class Hierarchy
Inventor::Weld
    Inventor::CosmeticWeld
    Inventor::WeldBead
Visual Basic
Public Interface Weld
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Welds.Item

You are here: Symbol Reference > Inventor Library > Objects > Weld Interface


Weld Methods

Weld Methods
Summary

The methods of the Weld class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the weld. The arguments allow control over which dependent objects are also deleted.
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Methods


Weld.Delete Method

Weld.Delete Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Method that deletes the weld. The arguments allow control over which dependent objects are also deleted.

Visual Basic
Sub Delete(ByRef RetainConsumedSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDependentFeaturesAndSketches As [defaultvalue(0)] VARIANT_BOOL, ByRef RetainDependentWorkFeatures As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainConsumedSketches | Optional input Boolean indicating if consumed sketches within the feature should be deleted. If the feature being deleted is not a sketch based feature this argument is ignored.
RetainDependentFeaturesAndSketches | Optional input Boolean that specifies if dependent features should be deleted. If there are no dependent features this argument is ignored.
RetainDependentWorkFeatures | Optional input Boolean that specifies if dependent work features should be deleted. If there are no dependent work features this argument is ignored.
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Methods > Weld.Delete Method


Weld Properties

Weld Properties
Summary

The properties of the Weld class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Name | Property that indicates the name of this object or instance.
SymbolAttachPoint | Property that returns the coordinate where the weld symbol attached to the weld geometry.
SymbolBreakPoint | Property that returns the coordinate where the weld symbol leader line break point is.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
WeldInfo | Gets the weld description information as a String containing XML formatted data. For more information on XML formatting see [image] More XML Weld Info...
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties


Weld.Application Property

Weld.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties > Weld.Application Property


Weld.Name Property

Weld.Name Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties > Weld.Name Property


Weld.SymbolAttachPoint Property

Weld.SymbolAttachPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the coordinate where the weld symbol attached to the weld geometry.

Visual Basic
Property SymbolAttachPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties > Weld.SymbolAttachPoint Property


Weld.SymbolBreakPoint Property

Weld.SymbolBreakPoint Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the coordinate where the weld symbol leader line break point is.

Visual Basic
Property SymbolBreakPoint() As Point**
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties > Weld.SymbolBreakPoint Property


Weld.Type Property

Weld.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties > Weld.Type Property


Weld.WeldInfo Property

Weld.WeldInfo Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Gets the weld description information as a String containing XML formatted data. For more information on XML formatting see [image] More XML Weld Info...

Visual Basic
Property WeldInfo() As BSTR*
You are here: Symbol Reference > Inventor Library > Objects > Weld Interface > Weld Properties > Weld.WeldInfo Property


WeldBead Interface

WeldBead Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The WeldBead object represents a weld bead within an assembly. The WeldBead object is derived from the Weld object.

Class Hierarchy
Inventor::Weld
    Inventor::WeldBead
Visual Basic
Public Interface WeldBead
Inherits Weld
Notes

Members through which this object may be accessed include:

WeldBeads.Item

You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface


WeldBead Methods

WeldBead Methods
Summary

The methods of the WeldBead class are listed here.

Methods
Methods
Name | Description
_IsLegacyWeldBead | This is _IsLegacyWeldBead, a member of class WeldBead.
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Methods


WeldBead._IsLegacyWeldBead Method

WeldBead._IsLegacyWeldBead Method
Summary

This is _IsLegacyWeldBead, a member of class WeldBead.

Visual Basic
Sub _IsLegacyWeldBead(Result As [out, retval] VARIANT_BOOL)
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Methods > WeldBead._IsLegacyWeldBead Method


WeldBead Properties

WeldBead Properties
Summary

The properties of the WeldBead class are listed here.

Properties
Name | Description
BeadFaces | Property that returns the set of Faces that define the geometric result of the weld bead.
BeadLength | Gets the length of the weld bead.
EndFaces | Gets the set of faces that define the ends of the weld bead.
FaceSetOne | Property that returns the faces on the first occurrence that the weld bead is on.
FaceSetTwo | Property that returns the faces on the second occurrence that the weld bead is on.
SideFaces | Gets the set of faces that define the sides of the weld bead.
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties


WeldBead.BeadFaces Property

WeldBead.BeadFaces Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the set of Faces that define the geometric result of the weld bead.

Visual Basic
Property BeadFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties > WeldBead.BeadFaces Property


WeldBead.BeadLength Property

WeldBead.BeadLength Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the length of the weld bead.

Visual Basic
Property BeadLength() As double*
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties > WeldBead.BeadLength Property


WeldBead.EndFaces Property

WeldBead.EndFaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the set of faces that define the ends of the weld bead.

Visual Basic
Property EndFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties > WeldBead.EndFaces Property


WeldBead.FaceSetOne Property

WeldBead.FaceSetOne Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the faces on the first occurrence that the weld bead is on.

Visual Basic
Property FaceSetOne() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties > WeldBead.FaceSetOne Property


WeldBead.FaceSetTwo Property

WeldBead.FaceSetTwo Property Available in Inventor Introduced in Inventor 2012
Summary

Property that returns the faces on the second occurrence that the weld bead is on.

Visual Basic
Property FaceSetTwo() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties > WeldBead.FaceSetTwo Property


WeldBead.SideFaces Property

WeldBead.SideFaces Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the set of faces that define the sides of the weld bead.

Visual Basic
Property SideFaces() As Faces**
You are here: Symbol Reference > Inventor Library > Objects > WeldBead Interface > WeldBead Properties > WeldBead.SideFaces Property


WeldBeads Interface

WeldBeads Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The WeldBeads object provides access to all the existing WeldBead objects within a weldment.

Class Hierarchy
Inventor::WeldBeads
Visual Basic
Public Interface WeldBeads
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Welds.WeldBeads

You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface


WeldBeads Methods

WeldBeads Methods
Summary

The methods of the WeldBeads class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified WeldBead object from the collection
You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface > WeldBeads Methods


WeldBeads.Item Method

WeldBeads.Item Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the specified WeldBead object from the collection

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] WeldBead*)
Parameters
Parameters | Description
index | Input Variant value that specifies the WeldBead to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the WeldBead name. If an out of range index or a name of a non-existent WeldBead is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface > WeldBeads Methods > WeldBeads.Item Method


WeldBeads Properties

WeldBeads Properties
Summary

The properties of the WeldBeads class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Count | Property that returns the number of items in the collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface > WeldBeads Properties


WeldBeads.Application Property

WeldBeads.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface > WeldBeads Properties > WeldBeads.Application Property


WeldBeads.Count Property

WeldBeads.Count Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the number of items in the collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface > WeldBeads Properties > WeldBeads.Count Property


WeldBeads.Type Property

WeldBeads.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WeldBeads Interface > WeldBeads Properties > WeldBeads.Type Property


WeldmentComponentDefinition Interface

WeldmentComponentDefinition Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The WeldmentComponentDefinition object provides access to all of the assembly and weldment information of a weldment assembly.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::AssemblyComponentDefinition
        Inventor::WeldmentComponentDefinition
Visual Basic
Public Interface WeldmentComponentDefinition
Inherits AssemblyComponentDefinition
Remarks

The WeldmentComponentDefinition object is derived from the AssemblyComponentDefinition object.

You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface


WeldmentComponentDefinition Methods

WeldmentComponentDefinition Methods
Summary

The methods of the WeldmentComponentDefinition class are listed here.

Methods
Methods
Name | Description
GetEndFillRenderStyle | Gets the end fill rendering style.
SetEndFillRenderStyle | Sets the end fill rendering style.
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Methods


WeldmentComponentDefinition.GetEndFillRenderStyle Method

WeldmentComponentDefinition.GetEndFillRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets the end fill rendering style.

Visual Basic
Sub GetEndFillRenderStyle(ByRef StyleSourceType As StyleSourceTypeEnum, Result As [out, retval] RenderStyle*)
Parameters
Parameters | Description
StyleSourceType | StyleSourceTypeEnum indicating the style source type. Possible values include kPartRenderStyle, kFeatureRenderStyle, kOverrideRenderStyle, kWeldBeadRenderStyle, and kBodyRenderStyle.
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Methods > WeldmentComponentDefinition.GetEndFillRenderStyle Method


WeldmentComponentDefinition.SetEndFillRenderStyle Method

WeldmentComponentDefinition.SetEndFillRenderStyle Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Sets the end fill rendering style.

Visual Basic
Sub SetEndFillRenderStyle(StyleSourceType As StyleSourceTypeEnum, ByRef RenderStyle As [optional] VARIANT)
Parameters
Parameters | Description
StyleSourceType | StyleSourceTypeEnum indicating the style source type. Possible values include kPartRenderStyle, kFeatureRenderStyle, kOverrideRenderStyle, kWeldBeadRenderStyle, and kBodyRenderStyle.
RenderStyle | Render style to apply.
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Methods > WeldmentComponentDefinition.SetEndFillRenderStyle Method


WeldmentComponentDefinition Properties

WeldmentComponentDefinition Properties
Summary

The properties of the WeldmentComponentDefinition class are listed here.

Properties
Name | Description
Machining | Property that returns the Machining object associated with this Weldment.
Material | Property that gets and sets the material of the welds.
Preparations | Property that returns the Preparations object associated with this Weldment.
Welds | Property that returns the Welds object.
WeldsComponentDefinition | Property that returns the associated WeldsComponentDefinition object.
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Properties


WeldmentComponentDefinition.Machining Property

WeldmentComponentDefinition.Machining Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the Machining object associated with this Weldment.

Visual Basic
Property Machining() As Machining**
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Properties > WeldmentComponentDefinition.Machining Property


WeldmentComponentDefinition.Material Property

WeldmentComponentDefinition.Material Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that gets and sets the material of the welds.

Visual Basic
Property Material() As Material*
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Properties > WeldmentComponentDefinition.Material Property


WeldmentComponentDefinition.Preparations Property

WeldmentComponentDefinition.Preparations Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the Preparations object associated with this Weldment.

Visual Basic
Property Preparations() As Preparations**
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Properties > WeldmentComponentDefinition.Preparations Property


WeldmentComponentDefinition.Welds Property

WeldmentComponentDefinition.Welds Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the Welds object.

Visual Basic
Property Welds() As Welds**
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Properties > WeldmentComponentDefinition.Welds Property


WeldmentComponentDefinition.WeldsComponentDefinition Property

WeldmentComponentDefinition.WeldsComponentDefinition Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the associated WeldsComponentDefinition object.

Visual Basic
Property WeldsComponentDefinition() As WeldsComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WeldmentComponentDefinition Interface > WeldmentComponentDefinition Properties > WeldmentComponentDefinition.WeldsComponentDefinition Property


Welds Interface

Welds Interface Available in Inventor Available in Server Introduced in Inventor 8
Summary

The Welds object provides access to all of the existing welds within a weldment.

Class Hierarchy
Inventor::Welds
Visual Basic
Public Interface Welds
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WeldmentComponentDefinition.Welds

Document.ActivatedObject

Application.ActiveEditObject

You are here: Symbol Reference > Inventor Library > Objects > Welds Interface


Welds Methods

Welds Methods
Summary

The methods of the Welds class are listed here.

Methods
Methods
Name | Description
Edit | Method that activates this object for editing by the user.
ExitEdit | Method that causes the current editing environment to be closed and the user interface to return to weldment editing environment.
Item | Property that returns the specified Weld object from the collection.
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Methods


Welds.Edit Method

Welds.Edit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that activates this object for editing by the user.

Visual Basic
Sub Edit()
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Methods > Welds.Edit Method


Welds.ExitEdit Method

Welds.ExitEdit Method Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Method that causes the current editing environment to be closed and the user interface to return to weldment editing environment.

Visual Basic
Sub ExitEdit()
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Methods > Welds.ExitEdit Method


Welds.Item Method

Welds.Item Method Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the specified Weld object from the collection.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] Weld*)
Parameters
Parameters | Description
index | Input Variant value that specifies the Weld to return. This can be either a numeric value indicating the index of the item in the collection or it can be a string indicating the Weld name. If an out of range index or a name of a non-existent Weld is provided, an error will occur.
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Methods > Welds.Item Method


Welds Properties

Welds Properties
Summary

The properties of the Welds class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
CosmeticWelds | Property that returns the CosmeticWelds object.
Count | Property that returns the number of items in this collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
WeldBeads | Property that returns the WeldBeads object.
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Properties


Welds.Application Property

Welds.Application Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Properties > Welds.Application Property


Welds.CosmeticWelds Property

Welds.CosmeticWelds Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the CosmeticWelds object.

Visual Basic
Property CosmeticWelds() As CosmeticWelds**
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Properties > Welds.CosmeticWelds Property


Welds.Count Property

Welds.Count Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Properties > Welds.Count Property


Welds.Type Property

Welds.Type Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Properties > Welds.Type Property


Welds.WeldBeads Property

Welds.WeldBeads Property Available in Inventor Available in Server Introduced in Inventor 8
Summary

Property that returns the WeldBeads object.

Visual Basic
Property WeldBeads() As WeldBeads**
You are here: Symbol Reference > Inventor Library > Objects > Welds Interface > Welds Properties > Welds.WeldBeads Property


WeldsComponentDefinition Interface

WeldsComponentDefinition Interface Available in Inventor Available in Server Introduced in Inventor 6
Summary

The WeldsComponentDefinition object derives from the PartComponentDefinition object. It adds weld-specific behavior to the PartComponentDefinition.

Class Hierarchy
Inventor::ComponentDefinition
    Inventor::WeldsComponentDefinition
Visual Basic
Public Interface WeldsComponentDefinition
Inherits ComponentDefinition
Notes

Members through which this object may be accessed include:

WeldmentComponentDefinition.WeldsComponentDefinition

You are here: Symbol Reference > Inventor Library > Objects > WeldsComponentDefinition Interface


WidthOffsetWidthExtent Interface

WidthOffsetWidthExtent Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The WidthOffsetWidthExtent is used by sheet metal features when the position of a width defined feature is relative to another entity.

Class Hierarchy
Inventor::PartFeatureExtent
    Inventor::WidthOffsetWidthExtent
Visual Basic
Public Interface WidthOffsetWidthExtent
Inherits PartFeatureExtent
Remarks

This object is obtained from an existing sheet metal feature object whose width is defined as a 'Width' extent and the type if 'Offset'. The various properties of this object can be used to query and edit the width of an existing feature.

You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface


WidthOffsetWidthExtent Properties

WidthOffsetWidthExtent Properties
Summary

The properties of the WidthOffsetWidthExtent class are listed here.

Properties
Name | Description
Edge | Property that gets the Edge object that the width is defined relative to.
OffsetDistance | Property that returns the parameter controlling the distance of the flange from the offset entity.
OffsetEntity | Property that gets and sets the entity the width is measured relative to.
PositiveDirection | Property that specifies the side of the offset entity the flange is on.
Width | Property that returns the parameter controlling the width of the flange.
You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface > WidthOffsetWidthExtent Properties


WidthOffsetWidthExtent.Edge Property

WidthOffsetWidthExtent.Edge Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets the Edge object that the width is defined relative to.

Visual Basic
Property Edge() As Edge**
Remarks

This is the same edge that was selected to create the feature. When querying an existing feature this edge is not available because it was consumed when the sheet metal feature was created. This property returns Nothing in the case where the edge no longer exists in the model. Because of this, the end-of-part marker must be placed above the feature to allow access this edge.

You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface > WidthOffsetWidthExtent Properties > WidthOffsetWidthExtent.Edge Property


WidthOffsetWidthExtent.OffsetDistance Property

WidthOffsetWidthExtent.OffsetDistance Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the parameter controlling the distance of the flange from the offset entity.

Visual Basic
Property OffsetDistance() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface > WidthOffsetWidthExtent Properties > WidthOffsetWidthExtent.OffsetDistance Property


WidthOffsetWidthExtent.OffsetEntity Property

WidthOffsetWidthExtent.OffsetEntity Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that gets and sets the entity the width is measured relative to.

Visual Basic
Property OffsetEntity() As IDispatch**
Remarks

This can be a WorkPoint or a Vertex object or a Face or WorkPlane object that is perpendicular to the selected edge.

You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface > WidthOffsetWidthExtent Properties > WidthOffsetWidthExtent.OffsetEntity Property


WidthOffsetWidthExtent.PositiveDirection Property

WidthOffsetWidthExtent.PositiveDirection Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that specifies the side of the offset entity the flange is on.

Visual Basic
Property PositiveDirection() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface > WidthOffsetWidthExtent Properties > WidthOffsetWidthExtent.PositiveDirection Property


WidthOffsetWidthExtent.Width Property

WidthOffsetWidthExtent.Width Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns the parameter controlling the width of the flange.

Visual Basic
Property Width() As Parameter**
Remarks

Even though this property is read-only, you can use the properties of the returned Parameter object to change the value.

You are here: Symbol Reference > Inventor Library > Objects > WidthOffsetWidthExtent Interface > WidthOffsetWidthExtent Properties > WidthOffsetWidthExtent.Width Property


Wire Interface

Wire Interface Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Non-faceted representation of edges of a body. Typical uses include representing bend lines on sheet metal.

Class Hierarchy
Inventor::Wire
Visual Basic
Public Interface Wire
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Edge.Wire

EdgeUse.Wire

Wires.Item

this is not the same as a wireframe representation of a model.

You are here: Symbol Reference > Inventor Library > Objects > Wire Interface


Wire Properties

Wire Properties
Summary

The properties of the Wire class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Edges | Gets the Edges referenced by this Wire.
EdgeUses | Property that returns the EdgeUses collection object associated with this Wire.
Parent | Property that returns the parent object from whom this object can logically be reached.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Wire Interface > Wire Properties


Wire.Application Property

Wire.Application Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > Wire Interface > Wire Properties > Wire.Application Property


Wire.Edges Property

Wire.Edges Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the Edges referenced by this Wire.

Visual Basic
Property Edges() As Edges**
You are here: Symbol Reference > Inventor Library > Objects > Wire Interface > Wire Properties > Wire.Edges Property


Wire.EdgeUses Property

Wire.EdgeUses Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the EdgeUses collection object associated with this Wire.

Visual Basic
Property EdgeUses() As EdgeUses**
You are here: Symbol Reference > Inventor Library > Objects > Wire Interface > Wire Properties > Wire.EdgeUses Property


Wire.Parent Property

Wire.Parent Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As SurfaceBody**
You are here: Symbol Reference > Inventor Library > Objects > Wire Interface > Wire Properties > Wire.Parent Property


Wire.Type Property

Wire.Type Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Wire Interface > Wire Properties > Wire.Type Property


WireframeDisplayOptions Interface

WireframeDisplayOptions Interface Available in Inventor Introduced in Inventor 11
Summary

The WireframeDisplayOptions object provides access to properties that provide read and write access of the wireframe display related application options. This is equivalent to the Wireframe Display Mode section of the Display tab on the Application Options dialog.

Class Hierarchy
Inventor::WireframeDisplayOptions
Visual Basic
Public Interface WireframeDisplayOptions
Inherits IDispatch
Remarks

The wireframe display options can be specified for active, enabled and background components which are defined as follows.

Active components in an assembly are those components that are visible, enabled and allowed to be edited by doing an in-place activation. A part document that has been opened in its own graphics window is also considered to be active for display purposes. When a component in an assembly which is eligible for in-place activation is placed in edit mode, it will remain active, whereas the remaining components will be temporarily de-activated. The display settings for these de-activated components will depend on whether they have been explicitly enabled or not. If they are explicitly enabled (the Enabled option in the model browser or the context menu in the graphics window has been checked), they will be displayed using the settings specified for enabled components. But, if they are explicitly disabled (the Enabled option in the model browser or the context menu in the graphics window has been un-checked), they will be displayed using the settings specified for background components.

Enabled components refer to those components in an assembly for which the Enabled option in the model browser or the context menu in the graphics window has been checked. When a component in an assembly is in-place activated, the remaining components including the enabled ones are temporarily de-activated. The display properties for enabled components specify the display settings for all these temporarily de-activated but otherwise enabled components, i.e. all the enabled components in the assembly except the component that has currently been activated for in-place edit. If any of the temporarily de-activated components have been explicitly specified as disabled (the Enabled option in the model browser or the context menu in the graphics window has been un-checked), they will be displayed using the settings specified for background components.

Background components in an assembly are those components that are visible but, have been explicitly marked as disabled (by un-checking the Enabled option using either the model browser or the context menu in the graphics window). Such components are displayed to provide context information only, hence, only the graphics information is loaded instead of the entire model data structure. If a background component is in-place activated or explicitly re-enabled (by checking the Enabled option using either the model browser or the context menu in the graphics window), it will become an active component. It will then be displayed using the display settings for active components. But, in-place activation of a component other than the background component will not affect the display type of the background component.

Notes

Members through which this object may be accessed include:

DisplayOptions.WireframeDisplayOptions

You are here: Symbol Reference > Inventor Library > Objects > WireframeDisplayOptions Interface


WireframeDisplayOptions Properties

WireframeDisplayOptions Properties
Summary

The properties of the WireframeDisplayOptions class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Type | Returns an ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > WireframeDisplayOptions Interface > WireframeDisplayOptions Properties


WireframeDisplayOptions.Application Property

WireframeDisplayOptions.Application Property Available in Inventor Introduced in Inventor 11
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WireframeDisplayOptions Interface > WireframeDisplayOptions Properties > WireframeDisplayOptions.Application Property


WireframeDisplayOptions.Type Property

WireframeDisplayOptions.Type Property Available in Inventor Introduced in Inventor 11
Summary

Returns an ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WireframeDisplayOptions Interface > WireframeDisplayOptions Properties > WireframeDisplayOptions.Type Property


Wires Interface

Wires Interface Available in Inventor Available in Server Introduced in Inventor 2009
Summary

The Wires collection object provides access to a set of Wire objects.

Class Hierarchy
Inventor::Wires
Visual Basic
Public Interface Wires
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Path.Wires

Profile.Wires

Profile3D.Wires

SurfaceBody.Wires

You are here: Symbol Reference > Inventor Library > Objects > Wires Interface


Wires Methods

Wires Methods
Summary

The methods of the Wires class are listed here.

Methods
Methods
Name | Description
Item | Allows integer-indexed access to items in the collection.
You are here: Symbol Reference > Inventor Library > Objects > Wires Interface > Wires Methods


Wires.Item Method

Wires.Item Method Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Allows integer-indexed access to items in the collection.

Visual Basic
Sub Item(index As long, Result As [out, retval] Wire*)
Parameters
Parameters | Description
index | Input Long value that specifies the index of the Wire object to return.
You are here: Symbol Reference > Inventor Library > Objects > Wires Interface > Wires Methods > Wires.Item Method


Wires Properties

Wires Properties
Summary

The properties of the Wires class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > Wires Interface > Wires Properties


Wires.Count Property

Wires.Count Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > Wires Interface > Wires Properties > Wires.Count Property


Wires.Type Property

Wires.Type Property Available in Inventor Available in Server Introduced in Inventor 2009
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > Wires Interface > Wires Properties > Wires.Type Property


WorkAxes Interface

WorkAxes Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The WorkAxes collection object provides access to all of the WorkAxis objects in the parent document and provides methods to create new work axes.

Class Hierarchy
Inventor::WorkAxes
Visual Basic
Public Interface WorkAxes
Inherits IDispatch
Remarks

The AddFixed method is currently the only Add method supported in Assembly documents. The three base work axes in a document are also available through this collection. They are always returned in a consistent order and will be the first three work axis objects in the collection. They are returned in X, Y, and Z order. They have a definition type of kFixedWorkAxis. The definition type and position of these work axes cannot be changed. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.WorkAxes

FlatPattern.WorkAxes

PartComponentDefinition.WorkAxes

See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface


WorkAxes Methods

WorkAxes Methods
Summary

The methods of the WorkAxes class are listed here.

Methods
Methods
Name | Description
AddByAnalyticEdge | Method that creates a new work axis based on the input analytic edge.
AddByLine | Method that creates a new work axis based on the input line. This method is not currently supported when creating a work axis within an assembly.
AddByLineAndPlane | Method that creates a new work axis that is along a line defined by projecting the input line onto the input plane along the plane normal. This method is not currently supported when creating a work axis within an assembly.
AddByLineAndPoint | Method that creates a new work axis that is parallel to a line and passes through the input point.
AddByNormalToSurface | Method that creates a new work axis that passes through the point and is normal to the input surface.
AddByRevolvedFace | Method that creates a new work axis through the axis of a revolved face. This method is not currently supported when creating a work axis within an assembly.
AddByTwoPlanes | Method that creates a new work axis at the intersection of the two input planes. This method is not currently supported when creating a work axis within an assembly.
AddByTwoPoints | Method that creates a new work axis through the two input points. This method is not currently supported when creating a work axis within an assembly.
AddFixed | Method that creates a new work axis that passes through the input point in the direction of the input vector. When used to create a work axis within an assembly the resulting work axis will return an AssemblyWorkAxisDef definition.
Item | Property that returns the specified WorkAxis object from the collection. This is the default property of the WorkAxes collection object.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods


WorkAxes.AddByAnalyticEdge Method

WorkAxes.AddByAnalyticEdge Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work axis based on the input analytic edge.

Visual Basic
Sub AddByAnalyticEdge(Edge As Edge, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters | Description
Edge | Input Edge object that can be a circle, arc, or an ellipse.
Construction | Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work axis within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByAnalyticEdge Method


WorkAxes.AddByLine Method

WorkAxes.AddByLine Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work axis based on the input line. This method is not currently supported when creating a work axis within an assembly.

Visual Basic
Sub AddByLine(Line As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters
Description
Line
Input object that represents a line. This object can be a linear Edge, SketchLine, or SketchLine3D object.
Construction
Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByLine Method


WorkAxes.AddByLineAndPlane Method

WorkAxes.AddByLineAndPlane Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work axis that is along a line defined by projecting the input line onto the input plane along the plane normal. This method is not currently supported when creating a work axis within an assembly.

Visual Basic
Sub AddByLineAndPlane(Line As IDispatch, Plane As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters
Description
Line
Input line object to project along the plane. This object can be a linear Edge, WorkAxis, or SketchLine object.
Plane
Input plane object along which to project the line. This object can be a planar Face, WorkPlane, or Sketch object.
Construction
Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis, not a construction work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByLineAndPlane Method


WorkAxes.AddByLineAndPoint Method

WorkAxes.AddByLineAndPoint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work axis that is parallel to a line and passes through the input point.

Visual Basic
Sub AddByLineAndPoint(Line As IDispatch, Point As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Point | Input object that represents a point. This object can be a Vertex, WorkPoint, SketchPoint, or SketchPoint3D object.
Construction | Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work axis within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByLineAndPoint Method


WorkAxes.AddByNormalToSurface Method

WorkAxes.AddByNormalToSurface Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work axis that passes through the point and is normal to the input surface.

Visual Basic
Sub AddByNormalToSurface(Surface As IDispatch, Point As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters | Description
Surface | Input object that represents a surface entity. This object can be a Face (planar or non-planar), a WorkPlane or a PlanarSketch object.
Point | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Construction | Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False which indicates to create a standard work axis, not a construction work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work axis within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByNormalToSurface Method


WorkAxes.AddByRevolvedFace Method

WorkAxes.AddByRevolvedFace Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work axis through the axis of a revolved face. This method is not currently supported when creating a work axis within an assembly.

Visual Basic
Sub AddByRevolvedFace(Face As Face, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters | Description
Face | Input Face object whose geometry is a revolved surface. Valid surface types include cylinders, cones, and toroids.
Construction | Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByRevolvedFace Method


WorkAxes.AddByTwoPlanes Method

WorkAxes.AddByTwoPlanes Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work axis at the intersection of the two input planes. This method is not currently supported when creating a work axis within an assembly.

Visual Basic
Sub AddByTwoPlanes(Plane1 As IDispatch, Plane2 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters
Description
Plane1
First input plane object for which to find the intersection at which to create the work axis. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2
Second input plane object for which to find the intersection at which to create the work axis. This object can be a planar Face, WorkPlane, or Sketch object.
Construction
Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis, not a construction work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByTwoPlanes Method


WorkAxes.AddByTwoPoints Method

WorkAxes.AddByTwoPoints Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work axis through the two input points. This method is not currently supported when creating a work axis within an assembly.

Visual Basic
Sub AddByTwoPoints(Point1 As IDispatch, Point2 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters
Description
Point1
Input object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point2
Input object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Construction
Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis, not a construction work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddByTwoPoints Method


WorkAxes.AddFixed Method

WorkAxes.AddFixed Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work axis that passes through the input point in the direction of the input vector. When used to create a work axis within an assembly the resulting work axis will return an AssemblyWorkAxisDef definition.

Visual Basic
Sub AddFixed(Point As Point, Axis As UnitVector, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkAxis*)
Parameters
Parameters | Description
Point | Input Point object.
Axis | Input UnitVector object. that defines the X-axis vector of the work plane.
Construction | Optional Input Boolean that specifies whether to create the work axis as a construction axis or not. The default is False, which indicates to create a standard work axis. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.AddFixed Method


WorkAxes.Item Method

WorkAxes.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified WorkAxis object from the collection. This is the default property of the WorkAxes collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] WorkAxis*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be a numeric value indicating the index of the item in the collection or it can be a string indicating the work axis name. If an out of range index or a name of a non-existent work axis is specified, an error occurs.
See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Methods > WorkAxes.Item Method


WorkAxes Properties

WorkAxes Properties
Summary

The properties of the WorkAxes class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Count | Property that returns the number of items in this collection.
Parent | Property returning the parent ComponentDefinition object.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Properties


WorkAxes.Application Property

WorkAxes.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Properties > WorkAxes.Application Property


WorkAxes.Count Property

WorkAxes.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Properties > WorkAxes.Count Property


WorkAxes.Parent Property

WorkAxes.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Properties > WorkAxes.Parent Property


WorkAxes.Type Property

WorkAxes.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxes Interface > WorkAxes Properties > WorkAxes.Type Property


WorkAxis Interface

WorkAxis Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Represents a work axis. See [image] here for an overview.

Class Hierarchy
Inventor::WorkAxis
    Inventor::WorkAxisProxy
Visual Basic
Public Interface WorkAxis
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AnalyticEdgeWorkAxisDef.Parent

AssemblyWorkAxisDef.Parent

FixedWorkAxisDef.Parent

LineAndPlaneWorkAxisDef.Parent

LineAndPointWorkAxisDef.Parent

LineWorkAxisDef.Parent

NormalToSurfaceWorkAxisDef.Parent

PointAndPlaneWorkAxisDef.Parent

RevolvedFaceWorkAxisDef.Parent

TwoPlanesWorkAxisDef.Parent

TwoPointsWorkAxisDef.Parent

UserCoordinateSystem.XAxis

UserCoordinateSystem.YAxis

UserCoordinateSystem.ZAxis

WorkAxes.AddByAnalyticEdge

WorkAxes.AddByLine

WorkAxes.AddByLineAndPlane

WorkAxes.AddByLineAndPoint

WorkAxes.AddByNormalToSurface

WorkAxes.AddByPointAndPlane

WorkAxes.AddByRevolvedFace

WorkAxes.AddByTwoPlanes

WorkAxes.AddByTwoPoints

WorkAxes.AddFixed

WorkAxes.Item

WorkAxis.ReferencedEntity

WorkAxisProxy.NativeObject

CircularOccurrencePattern.AxisEntity

PlanarSketch.AxisEntity

CircularPatternFeature.AxisEntity

CoilFeature.AxisEntity

PointHolePlacementDefinition.Direction

ClientFeatureElement.Element

AngleiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

LineAndPlaneWorkAxisDef.Line

LineAndPointWorkAxisDef.Line

LineAndTangentWorkPlaneDef.Line

LinePlaneAndAngleWorkPlaneDef.Line

LineWorkAxisDef.Line

TwoLinesWorkPlaneDef.Line1

TwoLinesWorkPointDef.Line1

TwoLinesWorkPlaneDef.Line2

TwoLinesWorkPointDef.Line2

Centerline.ModelWorkFeature

Centermark.ModelWorkFeature

FaceDraftFeature.PullDirection

DraftAnalysis.PullDirection

RectangularOccurrencePattern.RowEntity

RectangularPatternFeature.XDirectionEntity

RectangularPatternFeature.YDirectionEntity

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface


WorkAxis Methods

WorkAxis Methods
Summary

The methods of the WorkAxis class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the work axis. Optionally the dependent objects will be deleted. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetSize | Method that gets the current size of the displayed graphics for the work axis. The returned points are in model coordinate space.
SetByAnalyticEdge | Method that redefines the work axis to be based on the input edge.
SetByLine | Method that redefines the work axis to be based on the input line. This method is not valid when the work axis exists in an Assembly component definition.
SetByLineAndPlane | Method that redefines the work axis so that it is along a line defined by projecting the input line onto the input plane along the plane normal.
SetByLineAndPoint | Method that redefines the work axis so that it is parallel to a line and passes through the input point.
SetByNormalToSurface | Method that redefines the work axis to pass through the input point and be normal to the input surface.
SetByRevolvedFace | Method that redefines the work axis to be at the axis of the input revolved face.
SetByTwoPlanes | Method that redefines the work axis to be at the intersection of the two input planes.
SetByTwoPoints | Method that redefines the work axis to go between the two input points.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.
SetFixed | Method that redefines the work axis so it passes through the input point in the direction of the input vector.
SetSize | Method that sets the current size of the displayed graphics for the work axis.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods


WorkAxis.Delete Method

WorkAxis.Delete Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that deletes the work axis. Optionally the dependent objects will be deleted. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.

Visual Basic
Sub Delete(ByRef RetainDependents As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainDependents | Optional input Boolean that specifies whether any dependent objects should also be deleted. If True, no dependent objects will be deleted. This argument is ignored in the case of an assembly work plane.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.Delete Method


WorkAxis.GetReferenceKey Method

WorkAxis.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.GetReferenceKey Method


WorkAxis.GetSize Method

WorkAxis.GetSize Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that gets the current size of the displayed graphics for the work axis. The returned points are in model coordinate space.

Visual Basic
Sub GetSize(ByRef Point1 As Point*, ByRef Point2 As Point*)
Parameters
Parameters | Description
Point1 | Output Point object that defines the first end point of the work axis.
Point2 | Output Point object that defines the other end point of the work axis.
Remarks

The work axis is functionally infinite but has a line that is displayed to allow the user to interact with it graphically. The size and the position of the line can be adjusted to make it easier for the user to interact with. Construction work axes are never visible to the user and don't need to have a size defined. This method will fail in the case of a construction work axis. You can determine if the work axis is a construction work axis by checking the Construction property of the WorkAxis object. The two points define the end points of the displayed line.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.GetSize Method


WorkAxis.SetByAnalyticEdge Method

WorkAxis.SetByAnalyticEdge Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work axis to be based on the input edge.

Visual Basic
Sub SetByAnalyticEdge(Edge As Edge)
Parameters
Parameters | Description
Edge | Input Edge object that can be a circle, arc, or an ellipse.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByAnalyticEdge Method


WorkAxis.SetByLine Method

WorkAxis.SetByLine Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work axis to be based on the input line. This method is not valid when the work axis exists in an Assembly component definition.

Visual Basic
Sub SetByLine(Line As IDispatch)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, SketchLine, or SketchLine3D object.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByLine Method


WorkAxis.SetByLineAndPlane Method

WorkAxis.SetByLineAndPlane Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work axis so that it is along a line defined by projecting the input line onto the input plane along the plane normal.

Visual Basic
Sub SetByLineAndPlane(Line As IDispatch, Plane As IDispatch)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Plane | Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByLineAndPlane Method


WorkAxis.SetByLineAndPoint Method

WorkAxis.SetByLineAndPoint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work axis so that it is parallel to a line and passes through the input point.

Visual Basic
Sub SetByLineAndPoint(Line As IDispatch, Point As IDispatch)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Point | Input object that represents a point. This object can be a Vertex, WorkPoint, SketchPoint, or SketchPoint3D object.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByLineAndPoint Method


WorkAxis.SetByNormalToSurface Method

WorkAxis.SetByNormalToSurface Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work axis to pass through the input point and be normal to the input surface.

Visual Basic
Sub SetByNormalToSurface(Surface As IDispatch, Point As IDispatch)
Parameters
Parameters | Description
Surface | Input object that represents a surface entity. This object can be a Face (planar or non-planar), a WorkPlane or a PlanarSketch object.
Point | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByNormalToSurface Method


WorkAxis.SetByRevolvedFace Method

WorkAxis.SetByRevolvedFace Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work axis to be at the axis of the input revolved face.

Visual Basic
Sub SetByRevolvedFace(Face As Face)
Parameters
Parameters | Description
Face | Input Face whose geometry is a revolved surface. Valid surface types include cylinders, cones, and toroids.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByRevolvedFace Method


WorkAxis.SetByTwoPlanes Method

WorkAxis.SetByTwoPlanes Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work axis to be at the intersection of the two input planes.

Visual Basic
Sub SetByTwoPlanes(Plane1 As IDispatch, Plane2 As IDispatch)
Parameters
Parameters | Description
Plane1 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByTwoPlanes Method


WorkAxis.SetByTwoPoints Method

WorkAxis.SetByTwoPoints Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work axis to go between the two input points.

Visual Basic
Sub SetByTwoPoints(Point1 As IDispatch, Point2 As IDispatch)
Parameters
Parameters | Description
Point1 | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Point2 | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetByTwoPoints Method


WorkAxis.SetEndOfPart Method

WorkAxis.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this work feature. A value of True indicates before and False indicates after.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetEndOfPart Method


WorkAxis.SetFixed Method

WorkAxis.SetFixed Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work axis so it passes through the input point in the direction of the input vector.

Visual Basic
Sub SetFixed(Point As Point, Axis As UnitVector)
Parameters
Parameters | Description
Point | Input Point object.
Axis | Input UnitVector object.
Remarks

This method is not valid when the work axis exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetFixed Method


WorkAxis.SetSize Method

WorkAxis.SetSize Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that sets the current size of the displayed graphics for the work axis.

Visual Basic
Sub SetSize(Point1 As Point, Point2 As Point)
Parameters
Parameters | Description
Point1 | Input Point object that defines the first end point of the work axis.
Point2 | Input Point object that defines the other end point of the work axis.
Remarks

The input points should be in model coordinate space.

The work axis is functionally infinite but has a line that is displayed to allow the user to interact with it graphically. The size and the position of the line can be adjusted to make it easier for the user to interact with. Construction work axes are never visible to the user and don't need to have a size defined. This method will fail in the case of a construction work axis. You can determine if the work plane is a construction work axis by checking the Construction property of the WorkAxis object. This method will also fail if the AutoResize property is set to True. The two points define the two ends of the displayed line. The points must lie on the underlying Line geometry of the work axis.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Methods > WorkAxis.SetSize Method


WorkAxis Properties

WorkAxis Properties
Summary

The properties of the WorkAxis class are listed here.

Properties
Name | Description
Adaptive | Property that allows you to get or set whether the work axis is adaptive. For assembly work axes, this property always returns True and is read-only.
Application | Property that returns the Application object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
AutoResize | Property that gets or sets whether this work axis should be resized automatically based on the component size.
Construction | Boolean property that returns whether the work axis is a construction work axis or not. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser. Some properties and methods of the WorkAxis object will behave differently for a construction work axis. These are Adaptive, Name, and Visible.
Consumed | Gets whether the WorkAxis is consumed or not.
ConsumeInputs | Gets and sets whether the inputs to this feature should be nested under this feature in the browser.
Definition | Property that returns one of the work axis definition objects. Which definition object returned will depend on how the work axis is defined. The DefinitionType property can be used to determine the type of definition the Definition property will return.
DefinitionType | Property that returns the type of definition that is used to define the work axis. This can be kLineWorkAxis, kTwoPlanesWorkAxis, kTwoPointsWorkAxis, kRevolvedFaceWorkAxis, kNormalToSurfaceWorkAxis, kLineAndPlaneWorkAxis, kLineAndPointWorkAxis, kAnalyticEdgeWorkAxis, kFixedWorkAxis, or kAssemblyWorkAxis.
Dependents | Property that returns the collection of objects that have a direct dependency on the work axis.
DrivenBy | Property that returns the collection of objects that the work axis is dependent on.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
Grounded | Property that gets or sets whether this work axis is grounded or not. This property returns True in the case where the work axis is grounded.
HasReferenceComponent | Property that specifies if the object was created as the result of a derived part. This property returns True in the case where the object is from a derived part. In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsCoordinateSystemElement | Property that returns whether the work axis belongs to a coordinate system. If so, edits and delete are not allowed.
IsOwnedByFeature |
IsParentSketch | Property that indicates whether the work axis belongs to a 3d sketch.
IsPatternElement | Property that gets whether the work axis was created by a pattern. If so, edits and delete are not allowed.
Line | Property that returns a Line geometry. The Line object returned provides information about the position and direction of the work axis.
Name | Property that indicates the name of this object or instance.
OwnedBy |
Parent | Property returning the parent ComponentDefinition object.
ParentSketch | Property that returns the parent ComponentDefinition object.
ReferenceComponent | Property that returns the ReferenceComponent that this feature was created as the result of. If the WorkAxis belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.
ReferencedEntity | Property indicating the object this entity is dependent on.
Shared | Property that gets and sets whether the work axis is shared or not. When setting, it can only be set to False if a single it is consumed by a single feature. A work axis can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
Visible | Property that specifies the visibility of the work axis.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties


WorkAxis.Adaptive Property

WorkAxis.Adaptive Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get or set whether the work axis is adaptive. For assembly work axes, this property always returns True and is read-only.

Visual Basic
Property Adaptive() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Adaptive Property


WorkAxis.Application Property

WorkAxis.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Application Property


WorkAxis.AttributeSets Property

WorkAxis.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.AttributeSets Property


WorkAxis.AutoResize Property

WorkAxis.AutoResize Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets or sets whether this work axis should be resized automatically based on the component size.

Visual Basic
Property AutoResize() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.AutoResize Property


WorkAxis.Construction Property

WorkAxis.Construction Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Boolean property that returns whether the work axis is a construction work axis or not. A construction work axis is hidden from the user and is not displayed graphically or listed in the browser. Some properties and methods of the WorkAxis object will behave differently for a construction work axis. These are Adaptive, Name, and Visible.

Visual Basic
Property Construction() As VARIANT_BOOL*
Remarks

If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Construction Property


WorkAxis.Consumed Property

WorkAxis.Consumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets whether the WorkAxis is consumed or not.

Visual Basic
Property Consumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Consumed Property


WorkAxis.ConsumeInputs Property

WorkAxis.ConsumeInputs Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets whether the inputs to this feature should be nested under this feature in the browser.

Visual Basic
Property ConsumeInputs() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.ConsumeInputs Property


WorkAxis.Definition Property

WorkAxis.Definition Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns one of the work axis definition objects. Which definition object returned will depend on how the work axis is defined. The DefinitionType property can be used to determine the type of definition the Definition property will return.

Visual Basic
Property Definition() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Definition Property


WorkAxis.DefinitionType Property

WorkAxis.DefinitionType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the type of definition that is used to define the work axis. This can be kLineWorkAxis, kTwoPlanesWorkAxis, kTwoPointsWorkAxis, kRevolvedFaceWorkAxis, kNormalToSurfaceWorkAxis, kLineAndPlaneWorkAxis, kLineAndPointWorkAxis, kAnalyticEdgeWorkAxis, kFixedWorkAxis, or kAssemblyWorkAxis.

Visual Basic
Property DefinitionType() As WorkAxisDefinitionEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.DefinitionType Property


WorkAxis.Dependents Property

WorkAxis.Dependents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that have a direct dependency on the work axis.

Visual Basic
Property Dependents() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Dependents Property


WorkAxis.DrivenBy Property

WorkAxis.DrivenBy Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that the work axis is dependent on.

Visual Basic
Property DrivenBy() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.DrivenBy Property


WorkAxis.Exported Property

WorkAxis.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Exported Property


WorkAxis.Grounded Property

WorkAxis.Grounded Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that gets or sets whether this work axis is grounded or not. This property returns True in the case where the work axis is grounded.

Visual Basic
Property Grounded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Grounded Property


WorkAxis.HasReferenceComponent Property

WorkAxis.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that specifies if the object was created as the result of a derived part. This property returns True in the case where the object is from a derived part. In this case the ReferenceComponent property will return the owning ReferenceComponent object. The Delete method of this object will also fail in this case.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.HasReferenceComponent Property


WorkAxis.HealthStatus Property

WorkAxis.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.HealthStatus Property


WorkAxis.IsCoordinateSystemElement Property

WorkAxis.IsCoordinateSystemElement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the work axis belongs to a coordinate system. If so, edits and delete are not allowed.

Visual Basic
Property IsCoordinateSystemElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.IsCoordinateSystemElement Property


WorkAxis.IsOwnedByFeature Property

WorkAxis.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
Notes

For information on this item, please refer to PartFeature::IsOwnedByFeature, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.IsOwnedByFeature Property


WorkAxis.IsParentSketch Property

WorkAxis.IsParentSketch Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether the work axis belongs to a 3d sketch.

Visual Basic
Property IsParentSketch() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.IsParentSketch Property


WorkAxis.IsPatternElement Property

WorkAxis.IsPatternElement Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether the work axis was created by a pattern. If so, edits and delete are not allowed.

Visual Basic
Property IsPatternElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.IsPatternElement Property


WorkAxis.Line Property

WorkAxis.Line Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Line geometry. The Line object returned provides information about the position and direction of the work axis.

Visual Basic
Property Line() As Line**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Line Property


WorkAxis.Name Property

WorkAxis.Name Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Name Property


WorkAxis.OwnedBy Property

WorkAxis.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property OwnedBy() As PartFeature**
Notes

For information on this item, please refer to PartFeature::OwnedBy, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.OwnedBy Property


WorkAxis.Parent Property

WorkAxis.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Parent Property


WorkAxis.ParentSketch Property

WorkAxis.ParentSketch Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property ParentSketch() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.ParentSketch Property


WorkAxis.ReferenceComponent Property

WorkAxis.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponent that this feature was created as the result of. If the WorkAxis belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.ReferenceComponent Property


WorkAxis.ReferencedEntity Property

WorkAxis.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property indicating the object this entity is dependent on.

Visual Basic
Property ReferencedEntity() As WorkAxis**
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.ReferencedEntity Property


WorkAxis.Shared Property

WorkAxis.Shared Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the work axis is shared or not. When setting, it can only be set to False if a single it is consumed by a single feature. A work axis can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.

Visual Basic
Property Shared() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Shared Property


WorkAxis.Type Property

WorkAxis.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Type Property


WorkAxis.Visible Property

WorkAxis.Visible Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the visibility of the work axis.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

Setting this is the same as changing the visibility of a work axis using the context menu in the browser. Construction work axes are never visible. In this case, this property will always return false and setting the property to true will have no impact. You can determine if the work axis is a construction work axis by checking the Construction property of the WorkAxis object.

You are here: Symbol Reference > Inventor Library > Objects > WorkAxis Interface > WorkAxis Properties > WorkAxis.Visible Property


WorkAxisProxy Interface

WorkAxisProxy Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkAxis object.

Class Hierarchy
Inventor::WorkAxis
    Inventor::WorkAxisProxy
Visual Basic
Public Interface WorkAxisProxy
Inherits WorkAxis
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

Notes

Members through which this object may be accessed include:

CircularOccurrencePattern.AxisEntity

RectangularOccurrencePattern.RowEntity

You are here: Symbol Reference > Inventor Library > Objects > WorkAxisProxy Interface


WorkAxisProxy Properties

WorkAxisProxy Properties
Summary

The properties of the WorkAxisProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > WorkAxisProxy Interface > WorkAxisProxy Properties


WorkAxisProxy.ContainingOccurrence Property

WorkAxisProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkAxisProxy Interface > WorkAxisProxy Properties > WorkAxisProxy.ContainingOccurrence Property


WorkAxisProxy.NativeObject Property

WorkAxisProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As WorkAxis**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkAxisProxy Interface > WorkAxisProxy Properties > WorkAxisProxy.NativeObject Property


WorkPlane Interface

WorkPlane Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Represents a work plane. See [image] here for an overview.

Class Hierarchy
Inventor::WorkPlane
    Inventor::WorkPlaneProxy
Visual Basic
Public Interface WorkPlane
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyWorkPlaneDef.Parent

FixedWorkPlaneDef.Parent

LineAndPointWorkPlaneDef.Parent

LineAndTangentWorkPlaneDef.Parent

LinePlaneAndAngleWorkPlaneDef.Parent

NormalToCurveWorkPlaneDef.Parent

PlaneAndOffsetWorkPlaneDef.Parent

PlaneAndPointWorkPlaneDef.Parent

PlaneAndTangentWorkPlaneDef.Parent

PointAndTangentWorkPlaneDef.Parent

ThreePointsWorkPlaneDef.Parent

TorusMidPlaneWorkPlaneDef.Parent

TwoLinesWorkPlaneDef.Parent

TwoPlanesWorkPlaneDef.Parent

UserCoordinateSystem.XYPlane

UserCoordinateSystem.XZPlane

UserCoordinateSystem.YZPlane

WorkPlane.ReferencedEntity

WorkPlaneProxy.NativeObject

WorkPlanes.AddByLineAndPoint

WorkPlanes.AddByLineAndTangent

WorkPlanes.AddByLinePlaneAndAngle

WorkPlanes.AddByNormalToCurve

WorkPlanes.AddByPlaneAndOffset

WorkPlanes.AddByPlaneAndPoint

WorkPlanes.AddByPlaneAndTangent

WorkPlanes.AddByPointAndTangent

WorkPlanes.AddByThreePoints

WorkPlanes.AddByTorusMidPlane

WorkPlanes.AddByTwoLines

WorkPlanes.AddByTwoPlanes

WorkPlanes.AddFixed

WorkPlanes.Item

PointHolePlacementDefinition.Direction

ClientFeatureElement.Element

AngleiMateDefinition.Entity

CurveAndEntityWorkPointDef.Entity

FlushiMateDefinition.Entity

MateiMateDefinition.Entity

RotateRotateiMateDefinition.Entity

RotateTranslateiMateDefinition.Entity

TangentiMateDefinition.Entity

LoftDefinition.FirstSectionTangentPlane

FromToWidthExtent.FromEntity

LoftDefinition.LastSectionTangentPlane

MirrorFeature.MirrorPlaneEntity

Centerline.ModelWorkFeature

OffsetWidthExtent.OffsetEntityOne

OffsetWidthExtent.OffsetEntityTwo

PlanarSketch.PlanarEntity

ConcentricHolePlacementDefinition.Plane

LineAndPlaneWorkAxisDef.Plane

LinearHolePlacementDefinition.Plane

LinePlaneAndAngleWorkPlaneDef.Plane

PlaneAndOffsetWorkPlaneDef.Plane

PlaneAndPointWorkPlaneDef.Plane

PlaneAndTangentWorkPlaneDef.Plane

PointAndPlaneDistanceDimConstraint3D.Plane

PointAndPlaneWorkAxisDef.Plane

iFeatureSketchPlaneInput.PlaneInput

iFeatureWorkPlaneInput.PlaneInput

FaceDraftFeature.PullDirection

DraftAnalysis.PullDirection

SplitFeature.SplitTool

NormalToSurfaceWorkAxisDef.SurfaceEntity

FromToWidthExtent.ToEntity

ToExtent.ToEntity

ToExtent.ToFace

FromToExtent.ToFace

RectangularPatternFeature.XDirectionEntity

RectangularPatternFeature.YDirectionEntity

See Also

Create sheet metal lofted flange feature sample

Sweep Feature Add sample

SurfaceBody Copy sample

Spline - create NURBS sample

Navigation between browser and data sample

Assembly Mate Constraint of Work Planes sample

Example

See AssemblyConstraints::AddMateConstraint for example "Adding mate constraints using workplanes"

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface


WorkPlane Methods

WorkPlane Methods
Summary

The methods of the WorkPlane class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the work plane. Optionally the dependent objects will be deleted. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.
FlipNormal | Method that reverses the normal of the work plane. The current normal direction can be determined by using the Plane object returned by Plane property of the work plane.
GetPosition | Method that returns the position and orientation of a work plane. When sketches are created on a work plane they inherit the work plane's origin and orientation. This method is useful to predetermine what the orientation will be before the sketch is created.
GetReferenceKey | Method that generates and returns the reference key for this entity.
GetSize | Method that gets the current size of the displayed graphics for the work plane. The returned points are in the coordinate space of the workplane.
SetByLineAndTangent | Method that redefines the work plane to be through the input line and tangent to the input surface.
SetByLinePlaneAndAngle | Method that redefines the work plane to be through the input line at the specified angle from the input plane.
SetByNormalToCurve | Method that redefines the work plane to pass through the input point and normal to the input curve. .
SetByPlaneAndOffset | Method that redefines the work plane to be parallel to the input plane at a specified distance in the specified direction. This method is not valid when the work plane exists in an Assembly component definition.
SetByPlaneAndPoint | Method that redefines the work plane to be parallel to the input plane and passing through the input point.
SetByPlaneAndTangent | Method that redefines the work plane to be parallel to the input plane and tangent to the input surface.
SetByPointAndTangent | Method that redefines the work plane to pass through the input point and tangent to the input surface.
SetByThreePoints | Method that redefines the work plane to be based on the three input points.
SetByTorusMidPlane | Method that redefines the work plane to be at the mid-plane of the torus specified by the input face.
SetByTwoLines | Method that redefines the work plane to be based on the two input lines.
SetByTwoPlanes | Method that redefines a work plane to be based on the two planes.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.
SetFixed | Method that redefines the work plane to be at the position and orientation defined by the three points.
SetSize | Method that sets the current size of the displayed graphics for the work plane.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods


WorkPlane.Delete Method

WorkPlane.Delete Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that deletes the work plane. Optionally the dependent objects will be deleted. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.

Visual Basic
Sub Delete(ByRef RetainDependents As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainDependents | Optional input Boolean that specifies whether any dependent objects should also be deleted. If True, no dependent objects will be deleted. This argument is ignored in the case of an assembly work plane.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.Delete Method


WorkPlane.FlipNormal Method

WorkPlane.FlipNormal Method Available in Inventor Available in Server Introduced in Inventor 11
Summary

Method that reverses the normal of the work plane. The current normal direction can be determined by using the Plane object returned by Plane property of the work plane.

Visual Basic
Sub FlipNormal()
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.FlipNormal Method


WorkPlane.GetPosition Method

WorkPlane.GetPosition Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that returns the position and orientation of a work plane. When sketches are created on a work plane they inherit the work plane's origin and orientation. This method is useful to predetermine what the orientation will be before the sketch is created.

Visual Basic
Sub GetPosition(ByRef Origin As Point*, ByRef XAxis As UnitVector*, ByRef YAxis As UnitVector*)
Parameters
Parameters | Description
Origin | Output Point object that defines the origin of the work plane.
XAxis | Output UnitVector object that defines the X-axis vector of the work plane.
YAxis | Output UnitVector object that defines the Y-axis vector of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.GetPosition Method


WorkPlane.GetReferenceKey Method

WorkPlane.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.GetReferenceKey Method


WorkPlane.GetSize Method

WorkPlane.GetSize Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that gets the current size of the displayed graphics for the work plane. The returned points are in the coordinate space of the workplane.

Visual Basic
Sub GetSize(ByRef Point1 As Point*, ByRef Point2 As Point*)
Parameters
Parameters | Description
Point1 | Output Point object that defines the first corner of the work plane.
Point2 | Output Point object that defines the diagonal corner of the work plane.
Remarks

The work plane is functionally infinite but has a plane that is displayed to allow the user to interact with it graphically. The size and the position of the plane can be adjusted to make it easier for the user to interact with. Construction work planes are never visible to the user and don't need to have a size defined. This method will fail in the case of a construction work plane. You can determine if the work plane is a construction work plane by checking the Construction property of the WorkPlane object. The two points define the diagonal corners of the displayed rectangle. The rectangle is parallel to the X-axis of the plane.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.GetSize Method


WorkPlane.SetByLineAndTangent Method

WorkPlane.SetByLineAndTangent Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be through the input line and tangent to the input surface.

Visual Basic
Sub SetByLineAndTangent(Line As IDispatch, Face As Face, ProximityPoint As Point)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Face | Input Face object that indicates the tangent surface. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.
ProximityPoint | Input Point object that indicates which of the possible two solutions to use. For cylinders and spheres the plane can be on either side of the surface. Which solution to use will be determined by which side the proximity point is closest to. This point is only used for the initial computation. During a recompute of the model the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point.
Remarks

Valid geometry for the face includes cylinders, cones, and spheres. This method is not valid when the work plane exists in an Assembly component definition

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByLineAndTangent Method


WorkPlane.SetByLinePlaneAndAngle Method

WorkPlane.SetByLinePlaneAndAngle Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be through the input line at the specified angle from the input plane.

Visual Basic
Sub SetByLinePlaneAndAngle(Line As IDispatch, Plane As IDispatch, Angle As VARIANT)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Plane | Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object.
Angle | Input Variant that defines the offset angle of the work plane from the input plane. This can be a numeric value or a string. The offset angle of a work plane is always defined by a parameter. When a new work plane is created, the parameter is automatically created. If a numeric value is supplied the new parameter is set to the value specified and the value is always in radians. If a string is supplied it is used as the expression for the newly created parameter and will be interpreted the same as if the user entered it in a dialog. This means if a value is specified without a unit qualifier it will default to the current document length unit. The following is a valid entry for the angle, assuming the parameter d2 already exists and defines an angle, 'd2 + 10 deg'. The positive angle direction is computed by crossing the axis vector with the plane normal vector.
Remarks

This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByLinePlaneAndAngle Method


WorkPlane.SetByNormalToCurve Method

WorkPlane.SetByNormalToCurve Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work plane to pass through the input point and normal to the input curve. .

Visual Basic
Sub SetByNormalToCurve(CurveEntity As IDispatch, Point As IDispatch)
Parameters
Parameters | Description
CurveEntity | Input object that represents a curve entity. This object can be an Edge, 3D sketch entity, 2D sketch entity or a WorkAxis. For an Edge or 3D sketch entity the geometry must be a Spline, Arc, Circle, EllipticalArc, or Ellipse. For a 2D sketch entity, the geometry must be a Spline2d, Arc2d, Circle2d, EllipticalArc2d, or Ellipse2d.
Point | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object. If the input curve is a 2D sketch entity, the point must be a SketchPoint that meets one of the following conditions: start or end point of the curve, one of the fit points of a spline, or constrained to the curve with a coincident constraint. If the input curve is a 3D curve, the point must be related to the curve. For a 3D point to be related to a 3D curve, it can be the start, mid, or end point of the curve.
Remarks

The point must lie on the curve, as described below. This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByNormalToCurve Method


WorkPlane.SetByPlaneAndOffset Method

WorkPlane.SetByPlaneAndOffset Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be parallel to the input plane at a specified distance in the specified direction. This method is not valid when the work plane exists in an Assembly component definition.

Visual Basic
Sub SetByPlaneAndOffset(Plane As IDispatch, Offset As VARIANT)
Parameters
Parameters | Description
Plane | Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object..
Offset | Input Variant that defines the offset distance of the Plane. This can be a numeric value or a string. The offset distance of a work plane is always defined by a parameter. When a new work plane is created that requires a parameter, that parameter is automatically created when the work plane is created. If a numeric value is supplied the new parameter is set to the value specified. The input value is in centimeters. If a string is supplied this will be used as the expression for the newly created parameter and will be interpreted the same as if the user entered it in a dialog. This means if a value is specified without a unit qualifier it will default to the current document length unit. The following is a valid entry for the offset, assuming the parameter d2 already exists and defines a length, 'd2 + 3 in'. The sign of the value controls which side of the plane the offset is in. A positive value will be in the positive normal side of the plane.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByPlaneAndOffset Method


WorkPlane.SetByPlaneAndPoint Method

WorkPlane.SetByPlaneAndPoint Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be parallel to the input plane and passing through the input point.

Visual Basic
Sub SetByPlaneAndPoint(Plane As IDispatch, Point As IDispatch)
Parameters
Parameters | Description
Plane | Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object.
Point | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Remarks

This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByPlaneAndPoint Method


WorkPlane.SetByPlaneAndTangent Method

WorkPlane.SetByPlaneAndTangent Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be parallel to the input plane and tangent to the input surface.

Visual Basic
Sub SetByPlaneAndTangent(Plane As IDispatch, Face As Face, ProximityPoint As Point)
Parameters
Parameters | Description
Plane | Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object.
Face | Input Face object that indicates the tangent surface. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.
ProximityPoint | Input Point object that indicates which of the possible two solutions to use. For cylinders and spheres the plane can be on either side of the surface. Which solution to use will be determined by which side the proximity point is closest to. This point is only used for the initial computation. During a recompute the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point.
Remarks

Valid geometry for the face includes cylinders, cones, and spheres. This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByPlaneAndTangent Method


WorkPlane.SetByPointAndTangent Method

WorkPlane.SetByPointAndTangent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work plane to pass through the input point and tangent to the input surface.

Visual Basic
Sub SetByPointAndTangent(Point As IDispatch, Face As Face)
Parameters
Parameters | Description
Point | Input object that represents a point. This object can be a Vertex, WorkPoint, SketchPoint3D or SketchPoint object.
Face | Input Face object that indicates the tangent surface. This face must either be a cylinder, a cone that is positioned such that a valid tangent exists, a sphere or a bspline surface.
Remarks

The input point must lie on the input surface. This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByPointAndTangent Method


WorkPlane.SetByThreePoints Method

WorkPlane.SetByThreePoints Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work plane to be based on the three input points.

Visual Basic
Sub SetByThreePoints(Point1 As IDispatch, Point2 As IDispatch, Point3 As IDispatch)
Parameters
Parameters | Description
Point1 | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Point2 | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Point3 | Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object.
Remarks

The three input points must be unique non-coincident points. Point1 to Point2 defines the positive X axis and Point3 defines the positive Y direction. This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByThreePoints Method


WorkPlane.SetByTorusMidPlane Method

WorkPlane.SetByTorusMidPlane Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work plane to be at the mid-plane of the torus specified by the input face.

Visual Basic
Sub SetByTorusMidPlane(Face As Face)
Parameters
Parameters | Description
Face | Input Face object that represents a torus surface.
Remarks

This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByTorusMidPlane Method


WorkPlane.SetByTwoLines Method

WorkPlane.SetByTwoLines Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be based on the two input lines.

Visual Basic
Sub SetByTwoLines(Line1 As IDispatch, Line2 As IDispatch)
Parameters
Parameters | Description
Line1 | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Line2 | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Remarks

Line1 defines the X axis. If the two lines are not in the same plane, the plane is calculated by crossing the vectors defined by Line1 and Line2. This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByTwoLines Method


WorkPlane.SetByTwoPlanes Method

WorkPlane.SetByTwoPlanes Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines a work plane to be based on the two planes.

Visual Basic
Sub SetByTwoPlanes(Plane1 As IDispatch, Plane2 As IDispatch)
Parameters
Parameters | Description
Plane1 | Input object that represents a plane. This object can be a planar Face or WorkPlane object.
Plane2 | Input object that represents a plane. This object can be a planar Face or WorkPlane object.
Remarks

The work plane will bisect the two input planes. The two input planes must be parallel. This method is not currently supported when creating a work plane within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetByTwoPlanes Method


WorkPlane.SetEndOfPart Method

WorkPlane.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this work feature. A value of True indicates before and False indicates after.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetEndOfPart Method


WorkPlane.SetFixed Method

WorkPlane.SetFixed Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work plane to be at the position and orientation defined by the three points.

Visual Basic
Sub SetFixed(OriginPoint As Point, XAxis As UnitVector, YAxis As UnitVector)
Parameters
Parameters | Description
OriginPoint | Input Point object that defines the origin of the work plane.
XAxis | Input UnitVector object that defines the X-axis vector of the work plane.
YAxis | Input UnitVector object that defines the positive Y direction vector.
Remarks

This method is not valid when the work plane exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetFixed Method


WorkPlane.SetSize Method

WorkPlane.SetSize Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that sets the current size of the displayed graphics for the work plane.

Visual Basic
Sub SetSize(Point1 As Point, Point2 As Point)
Parameters
Parameters | Description
Point1 | Input Point object that defines the first corner of the work plane.
Point2 | Input Point object that defines the diagonal corner of the work plane.
Remarks

The input points should be in the coordinate space of the workplane.

The work plane is functionally infinite but has a plane that is displayed to allow the user to interact with it graphically. The size and the position of the plane can be adjusted to make it easier for the user to interact with. Construction work planes are never visible to the user and don't need to have a size defined. This method will fail in the case of a construction work plane. You can determine if the work plane is a construction work plane by checking the Construction property of the WorkPlane object. This method will also fail if the AutoResize property is set to True. The two points define the diagonal corners of the displayed rectangle. The rectangles sides are parallel to the X and Y axes of the plane.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Methods > WorkPlane.SetSize Method


WorkPlane Properties

WorkPlane Properties
Summary

The properties of the WorkPlane class are listed here.

Properties
Name | Description
Adaptive | Property that allows you to get or set whether the work plane is adaptive.
Application | Property that returns the Application object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
AutoResize | Property that gets or sets whether this work plane should be resized automatically based on the component size.
Construction | Boolean property that returns whether the work plane is a construction work plane or not. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. Some properties and methods of the WorkPlane object will behave differently for a construction work plane. These are Adaptive, Name, Visible, GetSize, and SetSize.
Consumed | Gets whether the WorkPlane is consumed or not.
ConsumeInputs | Gets and sets whether the inputs to this feature should be nested under this feature in the browser.
Definition | Property that returns one of the work plane definition objects. Which definition object returned will depend on how the work plane is defined. The DefinitionType property can be used to determine the type of definition the Definition property will return.
DefinitionType | Property that returns the type of definition that is used to define the work plane. This can be kThreePointsWorkPlane, kTwoLinesWorkPlane, kLineAndPointWorkPlane, kPlaneAndPointWorkPlane, kLinePlaneAndAngleWorkPlane, kPlaneAndOffsetWorkPlane, kLineAndTangentWorkPlane, kPlaneAndTangentWorkPlane, kSketchWorkPlane, kFixedWorkPlane, kNormalToCurveWorkPlane, kTwoPlanesWorkPlane, kTorusMidPlaneWorkPlane, or AssemblyWorkPlane.
Dependents | Property that returns the collection of objects that have a direct dependency on the work plane.
DrivenBy | Property that returns the collection of objects that the work plane is dependent on.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
Grounded | Property that gets or sets whether this work plane is grounded or not. This property returns True in the case where the work plane is grounded.
HasReferenceComponent | Property that returns the whether this work plane is based on a referenced component or not. This property returns True in the case where it is based on a referenced component. An example of when this occurs is when a work plane is selected as part of a derived part. In this case, the work plane isn't editable because it is based on the original part it was derived from. The actual work plane it is referencing can be obtained using the ReferencedEntity property.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsCoordinateSystemElement | Property that returns whether the work plane belongs to a coordinate system. If so, edits and delete are not allowed.
IsOwnedByFeature |
IsParentSketch | Property that indicates whether the work plane belongs to a 3d sketch.
IsPatternElement | Property that gets whether the work plane was created by a pattern. If so, edits and delete are not allowed.
Name | Property that indicates the name of this object or instance.
OwnedBy |
Parent | Property returning the parent ComponentDefinition object.
ParentSketch | Gets the parent 3d sketch if this work plane belongs to a 3d sketch, Gets Nothing otherwise.
Plane | Property that returns a Plane's geometry. The Plane object returned provides information about the position and normal of the work plane.
ReferenceComponent | Property that returns the ReferenceComponent object that was used to create this work feature. This property returns Nothing in the case where the work feature is not based on a reference component. An example of when a work feature is based on a reference component is when a work feature is selected as part of a derived part.
ReferencedEntity | Property that returns the referenced WorkPlane in the case where this work plane was created using a referenced component. An example of this is when a work plane is selected as part of a derived part. The HasReferenceComponent property indicates if this work plane is based on a referenced component or not. This property returns Nothing in the case where it is not based on a referenced component.
Shared | Property that gets and sets whether the work plane is shared or not. When setting, it can only be set to False if a single it is consumed by a single feature. A work plane can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
Visible | Property that specifies the visibility of the work plane.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties


WorkPlane.Adaptive Property

WorkPlane.Adaptive Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get or set whether the work plane is adaptive.

Visual Basic
Property Adaptive() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Adaptive Property


WorkPlane.Application Property

WorkPlane.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Application Property


WorkPlane.AttributeSets Property

WorkPlane.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.AttributeSets Property


WorkPlane.AutoResize Property

WorkPlane.AutoResize Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that gets or sets whether this work plane should be resized automatically based on the component size.

Visual Basic
Property AutoResize() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.AutoResize Property


WorkPlane.Construction Property

WorkPlane.Construction Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Boolean property that returns whether the work plane is a construction work plane or not. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. Some properties and methods of the WorkPlane object will behave differently for a construction work plane. These are Adaptive, Name, Visible, GetSize, and SetSize.

Visual Basic
Property Construction() As VARIANT_BOOL*
Remarks

If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Construction Property


WorkPlane.Consumed Property

WorkPlane.Consumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets whether the WorkPlane is consumed or not.

Visual Basic
Property Consumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Consumed Property


WorkPlane.ConsumeInputs Property

WorkPlane.ConsumeInputs Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets whether the inputs to this feature should be nested under this feature in the browser.

Visual Basic
Property ConsumeInputs() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.ConsumeInputs Property


WorkPlane.Definition Property

WorkPlane.Definition Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns one of the work plane definition objects. Which definition object returned will depend on how the work plane is defined. The DefinitionType property can be used to determine the type of definition the Definition property will return.

Visual Basic
Property Definition() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Definition Property


WorkPlane.DefinitionType Property

WorkPlane.DefinitionType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the type of definition that is used to define the work plane. This can be kThreePointsWorkPlane, kTwoLinesWorkPlane, kLineAndPointWorkPlane, kPlaneAndPointWorkPlane, kLinePlaneAndAngleWorkPlane, kPlaneAndOffsetWorkPlane, kLineAndTangentWorkPlane, kPlaneAndTangentWorkPlane, kSketchWorkPlane, kFixedWorkPlane, kNormalToCurveWorkPlane, kTwoPlanesWorkPlane, kTorusMidPlaneWorkPlane, or AssemblyWorkPlane.

Visual Basic
Property DefinitionType() As WorkPlaneDefinitionEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.DefinitionType Property


WorkPlane.Dependents Property

WorkPlane.Dependents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that have a direct dependency on the work plane.

Visual Basic
Property Dependents() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Dependents Property


WorkPlane.DrivenBy Property

WorkPlane.DrivenBy Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that the work plane is dependent on.

Visual Basic
Property DrivenBy() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.DrivenBy Property


WorkPlane.Exported Property

WorkPlane.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Exported Property


WorkPlane.Grounded Property

WorkPlane.Grounded Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that gets or sets whether this work plane is grounded or not. This property returns True in the case where the work plane is grounded.

Visual Basic
Property Grounded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Grounded Property


WorkPlane.HasReferenceComponent Property

WorkPlane.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the whether this work plane is based on a referenced component or not. This property returns True in the case where it is based on a referenced component. An example of when this occurs is when a work plane is selected as part of a derived part. In this case, the work plane isn't editable because it is based on the original part it was derived from. The actual work plane it is referencing can be obtained using the ReferencedEntity property.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.HasReferenceComponent Property


WorkPlane.HealthStatus Property

WorkPlane.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.HealthStatus Property


WorkPlane.IsCoordinateSystemElement Property

WorkPlane.IsCoordinateSystemElement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the work plane belongs to a coordinate system. If so, edits and delete are not allowed.

Visual Basic
Property IsCoordinateSystemElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.IsCoordinateSystemElement Property


WorkPlane.IsOwnedByFeature Property

WorkPlane.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
Notes

For information on this item, please refer to PartFeature::IsOwnedByFeature, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.IsOwnedByFeature Property


WorkPlane.IsParentSketch Property

WorkPlane.IsParentSketch Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether the work plane belongs to a 3d sketch.

Visual Basic
Property IsParentSketch() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.IsParentSketch Property


WorkPlane.IsPatternElement Property

WorkPlane.IsPatternElement Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether the work plane was created by a pattern. If so, edits and delete are not allowed.

Visual Basic
Property IsPatternElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.IsPatternElement Property


WorkPlane.Name Property

WorkPlane.Name Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Name Property


WorkPlane.OwnedBy Property

WorkPlane.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property OwnedBy() As PartFeature**
Notes

For information on this item, please refer to PartFeature::OwnedBy, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.OwnedBy Property


WorkPlane.Parent Property

WorkPlane.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Parent Property


WorkPlane.ParentSketch Property

WorkPlane.ParentSketch Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Gets the parent 3d sketch if this work plane belongs to a 3d sketch, Gets Nothing otherwise.

Visual Basic
Property ParentSketch() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.ParentSketch Property


WorkPlane.Plane Property

WorkPlane.Plane Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Plane's geometry. The Plane object returned provides information about the position and normal of the work plane.

Visual Basic
Property Plane() As Plane**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Plane Property


WorkPlane.ReferenceComponent Property

WorkPlane.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponent object that was used to create this work feature. This property returns Nothing in the case where the work feature is not based on a reference component. An example of when a work feature is based on a reference component is when a work feature is selected as part of a derived part.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.ReferenceComponent Property


WorkPlane.ReferencedEntity Property

WorkPlane.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the referenced WorkPlane in the case where this work plane was created using a referenced component. An example of this is when a work plane is selected as part of a derived part. The HasReferenceComponent property indicates if this work plane is based on a referenced component or not. This property returns Nothing in the case where it is not based on a referenced component.

Visual Basic
Property ReferencedEntity() As WorkPlane**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.ReferencedEntity Property


WorkPlane.Shared Property

WorkPlane.Shared Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the work plane is shared or not. When setting, it can only be set to False if a single it is consumed by a single feature. A work plane can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.

Visual Basic
Property Shared() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Shared Property


WorkPlane.Type Property

WorkPlane.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Type Property


WorkPlane.Visible Property

WorkPlane.Visible Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the visibility of the work plane.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

Setting this is the same as changing the visibility of a work plane using the context menu in the browser. Construction work planes are never visible. In this case, this property will always return false and setting the property to true will have no impact. You can determine if the work plane is a construction work plane by checking the Construction property of the WorkPlane object.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlane Interface > WorkPlane Properties > WorkPlane.Visible Property


WorkPlaneProxy Interface

WorkPlaneProxy Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkPlane object.

Class Hierarchy
Inventor::WorkPlane
    Inventor::WorkPlaneProxy
Visual Basic
Public Interface WorkPlaneProxy
Inherits WorkPlane
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlaneProxy Interface


WorkPlaneProxy Properties

WorkPlaneProxy Properties
Summary

The properties of the WorkPlaneProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlaneProxy Interface > WorkPlaneProxy Properties


WorkPlaneProxy.ContainingOccurrence Property

WorkPlaneProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkPlaneProxy Interface > WorkPlaneProxy Properties > WorkPlaneProxy.ContainingOccurrence Property


WorkPlaneProxy.NativeObject Property

WorkPlaneProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As WorkPlane**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkPlaneProxy Interface > WorkPlaneProxy Properties > WorkPlaneProxy.NativeObject Property


WorkPlanes Interface

WorkPlanes Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

The WorkPlanes collection object provides access to all of the WorkPlane objects in the parent document and provides methods to create new work planes.

Class Hierarchy
Inventor::WorkPlanes
Visual Basic
Public Interface WorkPlanes
Inherits IDispatch
Remarks

The AddFixed method is currently the only Add method supported in Assembly documents.The three base work planes in a document are also available through this collection. They are always returned in a consistent order and will be the first three work planes in the collection. They're returned in XZ, XZ, and XY order. They have a definition type of kFixedWorkPlane. The definition type and position of these work planes cannot be changed. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.WorkPlanes

FlatPattern.WorkPlanes

PartComponentDefinition.WorkPlanes

See Also

Create sheet metal lofted flange feature sample

Sweep Feature Add sample

SurfaceBody Copy sample

Spline - create NURBS sample

Projection - project across parts sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface


WorkPlanes Methods

WorkPlanes Methods
Summary

The methods of the WorkPlanes class are listed here.

Methods
Methods
Name | Description
AddByLineAndTangent | Method that creates a new work plane through the input line and tangent to the input surface.
AddByLinePlaneAndAngle | Method that creates a new work plane through the input line at the specified angle from the input plane. This method is not currently supported when creating a work plane within an assembly.
AddByNormalToCurve | Method that creates a new work plane that passes through the point and is normal to the input curve. The point must lie on the curve, as described below. This method is not currently supported when creating a work plane within an assembly.
AddByPlaneAndOffset | Method that creates a new work plane that is parallel to the input plane at a specified distance in the specified direction. This method is not currently supported when creating a work plane within an assembly.
AddByPlaneAndPoint | Method that creates a new work plane that is parallel to the input plane and passes through the input point. This method is not currently supported when creating a work plane within an assembly.
AddByPlaneAndTangent | Method that creates a new work plane that is parallel to the input plane and tangent to the input surface.
AddByPointAndTangent | Method that creates a new work plane through the input point and tangent to the input surface.
AddByThreePoints | Method that creates a new work plane based on the three input points. The three input points must be unique non-coincident points. Point1 to Point2 defines the positive X axis and Point3 defines the positive Y direction. This method is not currently supported when creating a work plane within an assembly.
AddByTorusMidPlane | Method that creates a new work plane at the mid-plane of the torus specified by the input face.
AddByTwoLines | Method that creates a new work plane based on the two input lines. Line1 defines the X axis. If the two lines are not in the same plane, the plane is calculated by crossing the vectors defined by Line1 and Line2. This method is not currently supported when creating a work plane within an assembly.
AddByTwoPlanes | Method that creates a new work plane based on the two input planes. The new plane will bisect the two input planes. The two input planes must be parallel. This method is not currently supported when creating a work plane within an assembly.
AddFixed | Method that creates a new work plane at the position and orientation defined by the point and X and Y axis vectors. When used to create a work plane within an assembly the resulting work plane will return an AssemblyWorkPlaneDef definition.
Item | Property that returns the specified WorkPlane object from the collection. This is the default property of the WorkPlanes collection object.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods


WorkPlanes.AddByLineAndTangent Method

WorkPlanes.AddByLineAndTangent Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane through the input line and tangent to the input surface.

Visual Basic
Sub AddByLineAndTangent(Line As IDispatch, Face As Face, ProximityPoint As Point, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters | Description
Line | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Face | Input Face object that indicates the tangent surface. This face must either be a cylinder whose axis is parallel to the line, a cone that is positioned such that a valid tangent exists, or a sphere.
ProximityPoint | Input Point object that indicates which of the possible two solutions to use. For cylinders and spheres the plane can be on either side of the surface. Which solution to use will be determined by which side the proximity point is closest to. This point is only used for the initial computation. During a recompute of the model the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point.
Construction | Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work plane within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByLineAndTangent Method


WorkPlanes.AddByLinePlaneAndAngle Method

WorkPlanes.AddByLinePlaneAndAngle Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane through the input line at the specified angle from the input plane. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByLinePlaneAndAngle(Line As IDispatch, Plane As IDispatch, Angle As VARIANT, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
Line
Input object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Plane
Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object.
Angle
Input Variant that defines the offset angle of the work plane from the input plane. This can be a numeric value or a string. The offset angle of a work plane is always defined by a parameter. When a new work plane is created that requires a parameter, that parameter is automatically created when the work plane is created. If a numeric value is supplied the new parameter is set to the value specified. The input value is in radians. If a string is supplied it is used as the expression for the newly created parameter and will be interpreted the same as if the user entered it in a dialog. This means if a value is specified without a unit qualifier it will default to the current document length unit. The following is a valid entry for the angle, assuming the parameter d2 already exists and defines an angle, "d2 + 10 deg." The positive angle direction is computed by crossing the axis vector with the plane normal vector.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByLinePlaneAndAngle Method


WorkPlanes.AddByNormalToCurve Method

WorkPlanes.AddByNormalToCurve Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new work plane that passes through the point and is normal to the input curve. The point must lie on the curve, as described below. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByNormalToCurve(CurveEntity As IDispatch, Point As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
CurveEntity
Input object that represents a curve entity. This object can be an Edge, 3D sketch entity, or a 2D sketch entity. For an Edge or 3D sketch entity the geometry must be a Spline, Arc, Circle, EllipticalArc, or Ellipse. For a 2D sketch entity, the geometry must be a Spline2d, Arc2d, Circle2d, EllipticalArc2d, or Ellipse2d.
Point
Input object that represents a point. This object can be a WorkPoint, Vertex, SketchPoint, or SketchPoint3D object. If the input curve is a 2D sketch entity, the point must be a SketchPoint that meets one of the following conditions: start or end point of the curve, one of the fit points of a spline, or constrained to the curve with a coincident constraint. If the input curve is a 3D curve, the point must be related to the curve. For a 3D point to be related to a 3D curve, it can be the start, mid, or end point of the curve.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

See Also

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByNormalToCurve Method


WorkPlanes.AddByPlaneAndOffset Method

WorkPlanes.AddByPlaneAndOffset Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane that is parallel to the input plane at a specified distance in the specified direction. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByPlaneAndOffset(Plane As IDispatch, Offset As VARIANT, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
Plane
Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object.
Offset
Input Variant that defines the offset distance of the Plane. This can be a numeric value or a string. The offset distance of a work plane is always defined by a parameter. When a new work plane is created that requires a parameter, that parameter is automatically created when the work plane is created. If a numeric value is supplied the new parameter is set to the value specified. The input value is in centimeters. If a string is supplied this will be used as the expression for the newly created parameter and will be interpreted the same as if the user entered it in a dialog. This means if a value is specified without a unit qualifier it will default to the current document length unit. The following is a valid entry for the offset, assuming the parameter d2 already exists and defines a length, "d2 + 3 in." The sign of the value controls which side of the plane the offset is in. A positive value will be in the positive normal side of the plane.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

See Also

Create sheet metal lofted flange feature sample

Spline - create NURBS sample

Navigation between browser and data sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByPlaneAndOffset Method


WorkPlanes.AddByPlaneAndPoint Method

WorkPlanes.AddByPlaneAndPoint Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane that is parallel to the input plane and passes through the input point. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByPlaneAndPoint(Plane As IDispatch, Point As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
Plane
Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Point
Input object that represents a point. This object can be a WorkPoint, Vertex or SketchPoint object.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByPlaneAndPoint Method


WorkPlanes.AddByPlaneAndTangent Method

WorkPlanes.AddByPlaneAndTangent Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane that is parallel to the input plane and tangent to the input surface.

Visual Basic
Sub AddByPlaneAndTangent(Plane As IDispatch, Face As Face, ProximityPoint As Point, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters | Description
Plane | Input object that represents a Plane. This object can be a planar Face, WorkPlane, or Sketch object.
Face | Input Face object that indicates the tangent surface. This face must either be a cylinder whose axis is parallel to the plane, a cone that is positioned such that a valid tangent exists, or a sphere.
ProximityPoint | Input Point object that indicates which of the possible two solutions to use. For cylinders and spheres the plane can be on either side of the surface. Which solution to use will be determined by which side the proximity point is closest to. This point is only used for the initial computation. During a recompute the plane will remain on the same side of the tangent surface regardless of its position relative to the originally specified point.
Construction | Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

Valid geometry for the face includes cylinders, cones, and spheres. This method is not currently supported when creating a work plane within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByPlaneAndTangent Method


WorkPlanes.AddByPointAndTangent Method

WorkPlanes.AddByPointAndTangent Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work plane through the input point and tangent to the input surface.

Visual Basic
Sub AddByPointAndTangent(Point As IDispatch, Face As Face, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters | Description
Point | Input object that represents a point. This object can be a Vertex, WorkPoint, SketchPoint3D, or SketchPoint object.
Face | Input Face object that indicates the tangent surface. This face must either be a cylinder, a cone that is positioned such that a valid tangent exists, a sphere, or a bspline surface.
Construction | Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

The input point must lie on the input surface. This method is not currently supported when creating a work plane within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByPointAndTangent Method


WorkPlanes.AddByThreePoints Method

WorkPlanes.AddByThreePoints Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane based on the three input points. The three input points must be unique non-coincident points. Point1 to Point2 defines the positive X axis and Point3 defines the positive Y direction. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByThreePoints(Point1 As IDispatch, Point2 As IDispatch, Point3 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
Point1
Input object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point2
Input object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Point3
Input object that represents a point. This object can be a WorkPoint, Vertex, or SketchPoint object.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByThreePoints Method


WorkPlanes.AddByTorusMidPlane Method

WorkPlanes.AddByTorusMidPlane Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work plane at the mid-plane of the torus specified by the input face.

Visual Basic
Sub AddByTorusMidPlane(Face As Face, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters | Description
Face | Input Face object that represents a torus surface.
Construction | Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work plane within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByTorusMidPlane Method


WorkPlanes.AddByTwoLines Method

WorkPlanes.AddByTwoLines Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane based on the two input lines. Line1 defines the X axis. If the two lines are not in the same plane, the plane is calculated by crossing the vectors defined by Line1 and Line2. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByTwoLines(Line1 As IDispatch, Line2 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
Line1
Input object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Line2
Input object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByTwoLines Method


WorkPlanes.AddByTwoPlanes Method

WorkPlanes.AddByTwoPlanes Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new work plane based on the two input planes. The new plane will bisect the two input planes. The two input planes must be parallel. This method is not currently supported when creating a work plane within an assembly.

Visual Basic
Sub AddByTwoPlanes(Plane1 As IDispatch, Plane2 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters | Description
Plane1 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or a PlanarSketch object.
Plane2 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or a PlanarSketch object.
Construction | Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddByTwoPlanes Method


WorkPlanes.AddFixed Method

WorkPlanes.AddFixed Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work plane at the position and orientation defined by the point and X and Y axis vectors. When used to create a work plane within an assembly the resulting work plane will return an AssemblyWorkPlaneDef definition.

Visual Basic
Sub AddFixed(OriginPoint As Point, XAxis As UnitVector, YAxis As UnitVector, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPlane*)
Parameters
Parameters
Description
OriginPoint
Input Point object that defines the origin of the work plane.
XAxis
Input UnitVector object that defines the X-axis vector of the work plane.
YAxis
Input UnitVector object that defines the Y-axis vector of the work plane.
Construction
Optional Input Boolean that specifies whether to create the work plane as a construction plane or not. The default is False, which indicates to create a standard work plane, not a construction work plane. A construction work plane is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.AddFixed Method


WorkPlanes.Item Method

WorkPlanes.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified WorkPlane object from the collection. This is the default property of the WorkPlanes collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] WorkPlane*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be a numeric value indicating the index of the item in the collection or it can be a string indicating the WorkPlane name. If an out of range index or a name of a non-existent WorkPlane is specified, an error occurs.
See Also

Sweep Feature Add sample

SurfaceBody Copy sample

Extrude sketch text sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Methods > WorkPlanes.Item Method


WorkPlanes Properties

WorkPlanes Properties
Summary

The properties of the WorkPlanes class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Count | Property that returns the number of items in this collection.
Parent | Property returning the parent ComponentDefinition object.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Properties


WorkPlanes.Application Property

WorkPlanes.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Properties > WorkPlanes.Application Property


WorkPlanes.Count Property

WorkPlanes.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Properties > WorkPlanes.Count Property


WorkPlanes.Parent Property

WorkPlanes.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Properties > WorkPlanes.Parent Property


WorkPlanes.Type Property

WorkPlanes.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkPlanes Interface > WorkPlanes Properties > WorkPlanes.Type Property


WorkPoint Interface

WorkPoint Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Represents a work point. See [image] here for an overview.

Class Hierarchy
Inventor::WorkPoint
    Inventor::WorkPointProxy
Visual Basic
Public Interface WorkPoint
Inherits IDispatch
Notes

Members through which this object may be accessed include:

AssemblyWorkPointDef.Parent

CentroidWorkPointDef.Parent

CoincidentConstraint3D.WorkPoint

CurveAndEntityWorkPointDef.Parent

FixedWorkPointDef.Parent

LineAndFaceWorkPointDef.Parent

MidPointWorkPointDef.Parent

NonLinearEdgeWorkPointDef.Parent

PointWorkPointDef.Parent

ThreePlanesWorkPointDef.Parent

TorusCenterPointWorkPointDef.Parent

TwoLinesWorkPointDef.Parent

UserCoordinateSystem.Origin

WorkPoint.ReferencedEntity

WorkPointProxy.NativeObject

WorkPoints.AddAtCentroid

WorkPoints.AddByCurveAndEntity

WorkPoints.AddByMidPoint

WorkPoints.AddByPoint

WorkPoints.AddByThreePlanes

WorkPoints.AddByTorusCenterPoint

WorkPoints.AddByTwoLines

WorkPoints.AddFixed

WorkPoints.Item

CoincidentConstraint3D.ConnectedEntity

ClientFeatureElement.Element

MateiMateDefinition.Entity

FromToWidthExtent.FromEntity

Centermark.ModelWorkFeature

OffsetWidthExtent.OffsetEntityOne

OffsetWidthExtent.OffsetEntityTwo

LineAndPointWorkAxisDef.Point

NormalToCurveWorkPlaneDef.Point

NormalToSurfaceWorkAxisDef.Point

PlaneAndPointWorkPlaneDef.Point

PointAndPlaneWorkAxisDef.Point

PointAndTangentWorkPlaneDef.Point

PointHolePlacementDefinition.Point

PointWorkPointDef.Point

ThreePointsWorkPlaneDef.Point1

TwoPointsWorkAxisDef.Point1

ThreePointsWorkPlaneDef.Point2

TwoPointsWorkAxisDef.Point2

ThreePointsWorkPlaneDef.Point3

FromToWidthExtent.ToEntity

ToHeightExtent.ToEntity

ToExtent.ToEntity

See Also

Create sheet metal rip feature sample

UCS by three points sample

OnDrag Event - dragging a WorkPoint sample

OnDrag Event - dragging a WorkPoint sample

Sweep Feature Add sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface


WorkPoint Methods

WorkPoint Methods
Summary

The methods of the WorkPoint class are listed here.

Methods
Methods
Name | Description
Delete | Method that deletes the work point. Optionally the dependent objects will be deleted. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.
GetReferenceKey | Method that generates and returns the reference key for this entity.
SetAtCentroid | Method that redefines a work point to be located at the centroid of the input entities.
SetByCurveAndEntity | Method that redefines a work point to be at the intersection of the input curve and an entity.
SetByMidPoint | Method that redefines the work point to be at the midpoint of the input edge.
SetByPoint | Method that redefines the work point to be at the input point.
SetByThreePlanes | Method that redefines the work point to be at the intersection of the three input planes.
SetByTorusCenterPoint | Method that redefines the work point to be at the center of the torus specified by the input face.
SetByTwoLines | Method that redefines the work point to be at the intersection of the two input lines.
SetEndOfPart | Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.
SetFixed | Method that redefines the work point to be at the position specified by the input point.
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods


WorkPoint.Delete Method

WorkPoint.Delete Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that deletes the work point. Optionally the dependent objects will be deleted. This method will fail in the case where this object was created as a result of a derived part. The HasReferenceComponent property can be used to determine when this is the case.

Visual Basic
Sub Delete(ByRef RetainDependents As [defaultvalue(0)] VARIANT_BOOL)
Parameters
Parameters | Description
RetainDependents | Optional input Boolean that specifies whether any dependent objects should also be deleted. If True, no dependent objects will be deleted.
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.Delete Method


WorkPoint.GetReferenceKey Method

WorkPoint.GetReferenceKey Method Available in Inventor Available in Server Introduced in Inventor 5
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.GetReferenceKey Method


WorkPoint.SetAtCentroid Method

WorkPoint.SetAtCentroid Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines a work point to be located at the centroid of the input entities.

Visual Basic
Sub SetAtCentroid(Entities As IDispatch)
Parameters
Parameters | Description
Entities | Input object that specifies the entities. This can be an Edge, an EdgeLoop object or an EdgeCollection containing one or more edges. If an EdgeCollection is input, the collection must contain connected edges. If isolated edges appear in the collection, the method will fail.
Remarks

This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetAtCentroid Method


WorkPoint.SetByCurveAndEntity Method

WorkPoint.SetByCurveAndEntity Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines a work point to be at the intersection of the input curve and an entity.

Visual Basic
Sub SetByCurveAndEntity(Curve As IDispatch, Entity As IDispatch, ByRef ProximityPoint As [optional] VARIANT)
Parameters
Parameters | Description
Curve | Input object that represents a curve. This object can be an edge or a 2d or 3d sketch entity.
Entity | Input object that will be intersected with the curve. This object can be a face or a work plane. There is a current limitation that this must be a planar face or work plane when anything but a line is input as the curve. Any face can be used when the curve is a line.
ProximityPoint | Optional input Point object that indicates multiple solutions to use. For example, a circle can intersect a plane twice, or a spline can intersect multiple times. If this argument is supplied, the result closest to the input point will be used. If this argument is not supplied and multiple solutions are possible, one solution will be arbitrarily chosen.
Remarks

If the curve and entity don't intersect an error will occur. This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetByCurveAndEntity Method


WorkPoint.SetByMidPoint Method

WorkPoint.SetByMidPoint Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work point to be at the midpoint of the input edge.

Visual Basic
Sub SetByMidPoint(Edge As Edge)
Parameters
Parameters | Description
Edge | Input Edge object. Any open edge is valid as input. Inputting a closed edge, (i.e. circle), will cause and error to occur.
Remarks

This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetByMidPoint Method


WorkPoint.SetByPoint Method

WorkPoint.SetByPoint Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work point to be at the input point.

Visual Basic
Sub SetByPoint(Point As IDispatch)
Parameters
Parameters | Description
Point | Input object that represents a point. This object can be a Vertex, SketchPoint, or SketchPoint3D object.
Remarks

This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetByPoint Method


WorkPoint.SetByThreePlanes Method

WorkPoint.SetByThreePlanes Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work point to be at the intersection of the three input planes.

Visual Basic
Sub SetByThreePlanes(Plane1 As IDispatch, Plane2 As IDispatch, Plane3 As IDispatch)
Parameters
Parameters | Description
Plane1 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane3 | Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Remarks

If the three input planes don't intersect an error will occur. This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetByThreePlanes Method


WorkPoint.SetByTorusCenterPoint Method

WorkPoint.SetByTorusCenterPoint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that redefines the work point to be at the center of the torus specified by the input face.

Visual Basic
Sub SetByTorusCenterPoint(Face As Face)
Parameters
Parameters | Description
Face | Input Face object whose geometry is a torus surface. An error occurs if the geometry of the input face is not a torus surface.
Remarks

This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetByTorusCenterPoint Method


WorkPoint.SetByTwoLines Method

WorkPoint.SetByTwoLines Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work point to be at the intersection of the two input lines.

Visual Basic
Sub SetByTwoLines(Line1 As IDispatch, Line2 As IDispatch)
Parameters
Parameters | Description
Line1 | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Line2 | Input object that represents a line. This object can be a linear Edge, WorkAxis, SketchLine, or SketchLine3D object.
Remarks

If the lines don't intersect an error will occur. This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetByTwoLines Method


WorkPoint.SetEndOfPart Method

WorkPoint.SetEndOfPart Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that repositions the end-of-part marker relative to the object this method is called from. The argument defines if the end-of-part marker will be positioned just before or just after the object. If the object is contained within another object and is not in the top level of the browser, the positioning of the marker will be relative to the top-level object the calling object is contained within. An example of this case is a sketch that has not been shared and has been consumed by a feature. Another example is a nested work feature.

Visual Basic
Sub SetEndOfPart(Before As VARIANT_BOOL)
Parameters
Parameters | Description
Before | Input Boolean that indicates if the end of part marker should be immediately before or after this work feature. A value of True indicates before and False indicates after.
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetEndOfPart Method


WorkPoint.SetFixed Method

WorkPoint.SetFixed Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that redefines the work point to be at the position specified by the input point.

Visual Basic
Sub SetFixed(Point As Point)
Parameters
Parameters | Description
Point | Input Point object.
Remarks

This method is not valid when the work point exists in an Assembly component definition.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Methods > WorkPoint.SetFixed Method


WorkPoint Properties

WorkPoint Properties
Summary

The properties of the WorkPoint class are listed here.

Properties
Name | Description
Adaptive | Property that allows you to get or set whether the work point is adaptive.
Application | Property that returns the Application object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Construction | Boolean property that returns whether the work point is a construction work point or not. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. Some properties and methods of the WorkPoint object will behave differently for a construction work point. These are Adaptive, Name, and Visible.
Consumed | Gets whether the WorkPoint is consumed or not.
ConsumeInputs | Gets and sets whether the inputs to this feature should be nested under this feature in the browser.
Definition | Property that returns one of the work point definition objects. Which definition object returned will depend on how the work point is defined. The DefinitionType property can be used to determine the type of definition the Definition property will return.
DefinitionType | Property that returns the type of definition that is used to define the work axis. This can be kThreePlanesWorkPoint, kTwoLinesWorkPoint, kCurveAndEntityWorkPoint, kPointWorkPoint, kMidPointWorkPoint, kNonLinearEdgeWorkPoint, kCentroidWorkPoint, kFixedWorkPoint, kTorusCenterPointWorkPoint and kAssemblyWorkPoint.
Dependents | Property that returns the collection of objects that have a direct dependency on the work point.
DrivenBy | Property that returns the collection of objects that the work point is dependent on.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
Grounded | Property that gets or sets whether this work point is grounded or not. This property returns True in the case where the work point is grounded.
HasReferenceComponent | Property that returns the whether this work point is based on a referenced component or not. This property returns True in the case where it is based on a referenced component. An example of when this occurs is when a work point is selected as part of a derived part. In this case, the work point isn't editable because it is based on the original part it was derived from. The actual work point it is referencing can be obtained using the ReferencedEntity property.
HealthStatus | Property that returns an enum indicating the current state of the object.
IsCoordinateSystemElement | Property that returns whether the work point belongs to a coordinate system. If so, edits and delete are not allowed.
IsOwnedByFeature |
IsParentSketch | Property that indicates whether the work point belongs to a 3d sketch.
IsPatternElement | Property that gets whether the work point was created by a pattern. If so, edits and delete are not allowed.
Name | Property that indicates the name of this object or instance.
OwnedBy |
Parent | Property returning the parent ComponentDefinition object.
ParentSketch | Property that returns the parent ComponentDefinition object.
Point | Property that returns a Point geometry object. The Point object returned provides information about the position of the work point.
ReferenceComponent | Property that returns the ReferenceComponent that this feature was created as the result of. If the WorkPoint belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.
ReferencedEntity | Property that returns the referenced WorkPoint in the case where this work point was created using a referenced component. An example of this is when a work point is selected as part of a derived part. The HasReferenceComponent property indicates if this work point is based on a referenced component or not. This property returns Nothing in the case where it is not based on a referenced component.
Shared | Property that gets and sets whether the work point is shared or not. When setting, it can only be set to False if a single it is consumed by a single feature. A work point can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
Visible | Property that specifies the visibility of the work point.
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties


WorkPoint.Adaptive Property

WorkPoint.Adaptive Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that allows you to get or set whether the work point is adaptive.

Visual Basic
Property Adaptive() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Adaptive Property


WorkPoint.Application Property

WorkPoint.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Application Property


WorkPoint.AttributeSets Property

WorkPoint.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.AttributeSets Property


WorkPoint.Construction Property

WorkPoint.Construction Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Boolean property that returns whether the work point is a construction work point or not. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. Some properties and methods of the WorkPoint object will behave differently for a construction work point. These are Adaptive, Name, and Visible.

Visual Basic
Property Construction() As VARIANT_BOOL*
Remarks

If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Construction Property


WorkPoint.Consumed Property

WorkPoint.Consumed Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets whether the WorkPoint is consumed or not.

Visual Basic
Property Consumed() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Consumed Property


WorkPoint.ConsumeInputs Property

WorkPoint.ConsumeInputs Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Gets and sets whether the inputs to this feature should be nested under this feature in the browser.

Visual Basic
Property ConsumeInputs() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.ConsumeInputs Property


WorkPoint.Definition Property

WorkPoint.Definition Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns one of the work point definition objects. Which definition object returned will depend on how the work point is defined. The DefinitionType property can be used to determine the type of definition the Definition property will return.

Visual Basic
Property Definition() As IDispatch**
See Also

OnDrag Event - dragging a WorkPoint sample

OnDrag Event - dragging a WorkPoint sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Definition Property


WorkPoint.DefinitionType Property

WorkPoint.DefinitionType Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the type of definition that is used to define the work axis. This can be kThreePlanesWorkPoint, kTwoLinesWorkPoint, kCurveAndEntityWorkPoint, kPointWorkPoint, kMidPointWorkPoint, kNonLinearEdgeWorkPoint, kCentroidWorkPoint, kFixedWorkPoint, kTorusCenterPointWorkPoint and kAssemblyWorkPoint.

Visual Basic
Property DefinitionType() As WorkPointDefinitionEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.DefinitionType Property


WorkPoint.Dependents Property

WorkPoint.Dependents Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that have a direct dependency on the work point.

Visual Basic
Property Dependents() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Dependents Property


WorkPoint.DrivenBy Property

WorkPoint.DrivenBy Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the collection of objects that the work point is dependent on.

Visual Basic
Property DrivenBy() As ObjectCollection**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.DrivenBy Property


WorkPoint.Exported Property

WorkPoint.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Exported Property


WorkPoint.Grounded Property

WorkPoint.Grounded Property Available in Inventor Available in Server Introduced in Inventor 7
Summary

Property that gets or sets whether this work point is grounded or not. This property returns True in the case where the work point is grounded.

Visual Basic
Property Grounded() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Grounded Property


WorkPoint.HasReferenceComponent Property

WorkPoint.HasReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the whether this work point is based on a referenced component or not. This property returns True in the case where it is based on a referenced component. An example of when this occurs is when a work point is selected as part of a derived part. In this case, the work point isn't editable because it is based on the original part it was derived from. The actual work point it is referencing can be obtained using the ReferencedEntity property.

Visual Basic
Property HasReferenceComponent() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.HasReferenceComponent Property


WorkPoint.HealthStatus Property

WorkPoint.HealthStatus Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns an enum indicating the current state of the object.

Visual Basic
Property HealthStatus() As HealthStatusEnum*
Remarks

The enum indicates whether the object is out of date, suppressed, is beyond the stop node, and various similar conditions.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.HealthStatus Property


WorkPoint.IsCoordinateSystemElement Property

WorkPoint.IsCoordinateSystemElement Property Available in Inventor Available in Server Introduced in Inventor 2010
Summary

Property that returns whether the work point belongs to a coordinate system. If so, edits and delete are not allowed.

Visual Basic
Property IsCoordinateSystemElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.IsCoordinateSystemElement Property


WorkPoint.IsOwnedByFeature Property

WorkPoint.IsOwnedByFeature Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property IsOwnedByFeature() As VARIANT_BOOL*
Notes

For information on this item, please refer to PartFeature::IsOwnedByFeature, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.IsOwnedByFeature Property


WorkPoint.IsParentSketch Property

WorkPoint.IsParentSketch Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that indicates whether the work point belongs to a 3d sketch.

Visual Basic
Property IsParentSketch() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.IsParentSketch Property


WorkPoint.IsPatternElement Property

WorkPoint.IsPatternElement Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that gets whether the work point was created by a pattern. If so, edits and delete are not allowed.

Visual Basic
Property IsPatternElement() As VARIANT_BOOL*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.IsPatternElement Property


WorkPoint.Name Property

WorkPoint.Name Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that indicates the name of this object or instance.

Visual Basic
Property Name() As String
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Name Property


WorkPoint.OwnedBy Property

WorkPoint.OwnedBy Property Available in Inventor Available in Server Introduced in Inventor 2008
Visual Basic
Property OwnedBy() As PartFeature**
Notes

For information on this item, please refer to PartFeature::OwnedBy, which provides identical or very similar functionality.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.OwnedBy Property


WorkPoint.Parent Property

WorkPoint.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Parent Property


WorkPoint.ParentSketch Property

WorkPoint.ParentSketch Property Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Property that returns the parent ComponentDefinition object.

Visual Basic
Property ParentSketch() As Sketch3D**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.ParentSketch Property


WorkPoint.Point Property

WorkPoint.Point Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns a Point geometry object. The Point object returned provides information about the position of the work point.

Visual Basic
Property Point() As Point**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Point Property


WorkPoint.ReferenceComponent Property

WorkPoint.ReferenceComponent Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the ReferenceComponent that this feature was created as the result of. If the WorkPoint belongs to a derived part, a DerivedPartComponent will be returned. If the ReferenceFeature belongs to a derived assembly, a DerivedAssemblyComponent will be returned.

Visual Basic
Property ReferenceComponent() As ReferenceComponent**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.ReferenceComponent Property


WorkPoint.ReferencedEntity Property

WorkPoint.ReferencedEntity Property Available in Inventor Available in Server Introduced in Inventor 5.3
Summary

Property that returns the referenced WorkPoint in the case where this work point was created using a referenced component. An example of this is when a work point is selected as part of a derived part. The HasReferenceComponent property indicates if this work point is based on a referenced component or not. This property returns Nothing in the case where it is not based on a referenced component.

Visual Basic
Property ReferencedEntity() As WorkPoint**
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.ReferencedEntity Property


WorkPoint.Shared Property

WorkPoint.Shared Property Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that gets and sets whether the work point is shared or not. When setting, it can only be set to False if a single it is consumed by a single feature. A work point can only be shared when a feature is using it. By setting it to be shared you're allowing it to participate in other features.

Visual Basic
Property Shared() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Shared Property


WorkPoint.Type Property

WorkPoint.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Type Property


WorkPoint.Visible Property

WorkPoint.Visible Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that specifies the visibility of the work point.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

Setting this is the same as changing the visibility of a work point using the context menu in the browser. Construction work points are never visible. In this case, this property will always return false and setting the property to true will have no impact. You can determine if the work point is a construction work axis by checking the Construction property of the WorkPoint object.

You are here: Symbol Reference > Inventor Library > Objects > WorkPoint Interface > WorkPoint Properties > WorkPoint.Visible Property


WorkPointProxy Interface

WorkPointProxy Interface Available in Inventor Available in Server Introduced in Inventor 5
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkPoint object.

Class Hierarchy
Inventor::WorkPoint
    Inventor::WorkPointProxy
Visual Basic
Public Interface WorkPointProxy
Inherits WorkPoint
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface


WorkPointProxy Properties

WorkPointProxy Properties
Summary

The properties of the WorkPointProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPointProxy Properties


WorkPointProxy.ContainingOccurrence Property

WorkPointProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPointProxy Properties > WorkPointProxy.ContainingOccurrence Property


WorkPointProxy.NativeObject Property

WorkPointProxy.NativeObject Property Available in Inventor Available in Server Introduced in Inventor 5
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As WorkPoint**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPointProxy Properties > WorkPointProxy.NativeObject Property


WorkPoints Interface

WorkPoints Interface Available in Inventor Available in Server Introduced in Inventor 4
Summary

Provides access to all of the WorkPoint objects in the parent document and provides methods to create new work points.

Class Hierarchy
Inventor::WorkPoints
Visual Basic
Public Interface WorkPoints
Inherits IDispatch
Remarks

The AddFixed method is currently the only Add method supported in Assembly documents.The origin work point in a document is also available through this collection. It is always the first work point in the collection. It has a definition type of kFixedWorkPoint. The definition type and position of this work point cannot be changed. See [image] here for an overview.

Notes

Members through which this object may be accessed include:

AssemblyComponentDefinition.WorkPoints

FlatPattern.WorkPoints

PartComponentDefinition.WorkPoints

See Also

Create sheet metal rip feature sample

UCS by three points sample

Sweep Feature Add sample

Create sheet metal face and cut features sample

Example

See WorkPoint for example "WorkPoint Object"

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface


WorkPoints Methods

WorkPoints Methods
Summary

The methods of the WorkPoints class are listed here.

Methods
Methods
Name | Description
AddAtCentroid | Method that creates a new work point at the centroid of the input entities.
AddByCurveAndEntity | Method that creates a new work point at the intersection of the input curve and entity.
AddByMidPoint | Method that creates a new work point at the midpoint of the input edge. This method is not currently supported when creating a work point within an assembly.
AddByPoint | Method that creates a new work point at the input point. This method is not currently supported when creating a work point within an assembly.
AddByThreePlanes | Method that creates a new work point at the intersection of the three input planes. If the three input planes don't intersect an error will occur. This method is not currently supported when creating a work point within an assembly.
AddByTorusCenterPoint | Method that creates a new work point at the center of the torus specified by the input face.
AddByTwoLines | Method that creates a new work point at the intersection of the two input lines. If the lines don't intersect an error will occur. This method is not currently supported when creating a work point within an assembly.
AddFixed | Method that creates a new work point at the position specified by the input point. When used to create a work point within an assembly the resulting work point will return an AssemblyWorkPointDef definition.
Item | Property that returns the specified WorkPoint object from the collection. This is the default property of the WorkPoints collection object.
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods


WorkPoints.AddAtCentroid Method

WorkPoints.AddAtCentroid Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work point at the centroid of the input entities.

Visual Basic
Sub AddAtCentroid(Entities As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters | Description
Entities | Input object that specifies the entities. This can be an Edge, an EdgeLoop object or an EdgeCollection containing one or more edges. If an EdgeCollection is input, the collection must contain connected edges. If isolated edges appear in the collection, the method will fail.
Construction | Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work point within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddAtCentroid Method


WorkPoints.AddByCurveAndEntity Method

WorkPoints.AddByCurveAndEntity Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new work point at the intersection of the input curve and entity.

Visual Basic
Sub AddByCurveAndEntity(Curve As IDispatch, Entity As IDispatch, ByRef ProximityPoint As [optional] VARIANT, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters
Description
Curve
Input object that represents a curve. This object can be an edge or a 2d or 3d sketch entity.
Entity
Input object that will be intersected with the curve. This object can be a face or a work plane. There is a current limitation that this must be a planar face or work plane when anything but a line is input as the curve. Any face can be used when the curve is a line.
ProximityPoint
Input Point object that indicates multiple solutions to use. For example, a circle can intersect a plane twice, or a spline can intersect multiple times. If this argument is supplied, the result closest to the input point will be used. If this argument is not supplied and multiple solutions are possible, one solution will be arbitrarily chosen.
Construction
Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

Remarks

If the curve and entity don't intersect an error will occur. A current limitation is that intersections between entities that are non-planar can only be performed with linear curves. This method is not currently supported when creating a work point within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddByCurveAndEntity Method


WorkPoints.AddByMidPoint Method

WorkPoints.AddByMidPoint Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work point at the midpoint of the input edge. This method is not currently supported when creating a work point within an assembly.

Visual Basic
Sub AddByMidPoint(Edge As Edge, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters
Description
Edge
Input Edge object. Any open edge is valid as input. Inputting a closed edge, (i.e. circle), will cause and error to occur.
Construction
Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

See Also

Create sheet metal rip feature sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddByMidPoint Method


WorkPoints.AddByPoint Method

WorkPoints.AddByPoint Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work point at the input point. This method is not currently supported when creating a work point within an assembly.

Visual Basic
Sub AddByPoint(Point As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters
Description
Point
Input object that represents a point. This object can be a Vertex or SketchPoint object.
Construction
Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddByPoint Method


WorkPoints.AddByThreePlanes Method

WorkPoints.AddByThreePlanes Method Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that creates a new work point at the intersection of the three input planes. If the three input planes don't intersect an error will occur. This method is not currently supported when creating a work point within an assembly.

Visual Basic
Sub AddByThreePlanes(Plane1 As IDispatch, Plane2 As IDispatch, Plane3 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters
Description
Plane1
Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane2
Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Plane3
Input object that represents a plane. This object can be a planar Face, WorkPlane, or Sketch object.
Construction
Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddByThreePlanes Method


WorkPoints.AddByTorusCenterPoint Method

WorkPoints.AddByTorusCenterPoint Method Available in Inventor Available in Server Introduced in Inventor 2008
Summary

Method that creates a new work point at the center of the torus specified by the input face.

Visual Basic
Sub AddByTorusCenterPoint(Face As Face, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters | Description
Face | Input Face object whose geometry is a torus surface. An error occurs if the geometry of the input face is not a torus surface.
Construction | Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser.
Remarks

This method is not currently supported when creating a work point within an assembly.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddByTorusCenterPoint Method


WorkPoints.AddByTwoLines Method

WorkPoints.AddByTwoLines Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work point at the intersection of the two input lines. If the lines don't intersect an error will occur. This method is not currently supported when creating a work point within an assembly.

Visual Basic
Sub AddByTwoLines(Line1 As IDispatch, Line2 As IDispatch, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters
Description
Line1
Input object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Line2
Input object that represents a line. This object can be a linear Edge, WorkAxis, or SketchLine object.
Construction
Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddByTwoLines Method


WorkPoints.AddFixed Method

WorkPoints.AddFixed Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Method that creates a new work point at the position specified by the input point. When used to create a work point within an assembly the resulting work point will return an AssemblyWorkPointDef definition.

Visual Basic
Sub AddFixed(Point As Point, ByRef Construction As [defaultvalue(0)] VARIANT_BOOL, Result As [out, retval] WorkPoint*)
Parameters
Parameters
Description
Point
Input Point object.
Construction
Optional Input Boolean that specifies whether to create the work point as a construction point or not. The default is False, which indicates to create a standard work point. A construction work point is hidden from the user and is not displayed graphically or listed in the browser. If work features are created as construction:

  • Deleting any downstream feature that consumes this construction work feature will have the effect of deleting this work feature as well.
  • If there are no consumers of the construction work feature, it is the responsibility of the creator to delete them since they will never get cleaned up and are not visible to users.

See Also

UCS by three points sample

Sweep Feature Add sample

Work Point at Mass Center sample

Work point at mass center (C#) sample

Loft Feature With Non-Planar Section sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.AddFixed Method


WorkPoints.Item Method

WorkPoints.Item Method Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the specified WorkPoint object from the collection. This is the default property of the WorkPoints collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] WorkPoint*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be a numeric value indicating the index of the item in the collection or it can be a string indicating the work point name. If an out of range index or a name of a non-existent work point is specified, an error occurs.
See Also

Create sheet metal face and cut features sample

You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Methods > WorkPoints.Item Method


WorkPoints Properties

WorkPoints Properties
Summary

The properties of the WorkPoints class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
Count | Property that returns the number of items in this collection.
Parent | Property returning the parent ComponentDefinition object.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Properties


WorkPoints.Application Property

WorkPoints.Application Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Properties > WorkPoints.Application Property


WorkPoints.Count Property

WorkPoints.Count Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Properties > WorkPoints.Count Property


WorkPoints.Parent Property

WorkPoints.Parent Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning the parent ComponentDefinition object.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Properties > WorkPoints.Parent Property


WorkPoints.Type Property

WorkPoints.Type Property Available in Inventor Available in Server Introduced in Inventor 4
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkPointProxy Interface > WorkPoints Interface > WorkPoints Properties > WorkPoints.Type Property


WorkSurface Interface

WorkSurface Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

The WorkSurface object represents a work surface, which is a type of work feature.

Class Hierarchy
Inventor::WorkSurface
    Inventor::WorkSurfaceProxy
Visual Basic
Public Interface WorkSurface
Inherits IDispatch
Notes

Members through which this object may be accessed include:

WorkSurface.ReferencedEntity

WorkSurfaceProxy.NativeObject

WorkSurfaces.Item

SplitFeature.SplitTool

See Also

SurfaceBody Copy sample

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface


WorkSurface Methods

WorkSurface Methods
Summary

The methods of the WorkSurface class are listed here.

Methods
Methods
Name | Description
GetReferenceKey | Method that generates and returns the reference key for this entity.
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Methods


WorkSurface.GetReferenceKey Method

WorkSurface.GetReferenceKey Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Method that generates and returns the reference key for this entity.

Visual Basic
Sub GetReferenceKey(ByRef ReferenceKey As SAFEARRAY(unsigned char), ByRef KeyContext As [defaultvalue(0)] long)
Parameters
Parameters | Description
ReferenceKey | Input/output array of Bytes that contains the reference key.
KeyContext | Input Long that specifies the key context. The key context must be supplied when working with any B-Rep entities (and SurfaceBody, FaceShell, Face, Edge, EdgeUse and Vertex objects). A key context is created using the CreateKeyContext method of the ReferenceKeyManager object. For all other object types, the key context argument is not used and is ignored if provided.
Remarks

The reference key is an array of bytes that can be used as a persistent reference for this entity. To obtain the entity at a later time using the reference key you use the BindKeyToObject method of the object. The ReferenceKeyManager object is obtained using the ReferenceKeyManager property of the Document object.

You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Methods > WorkSurface.GetReferenceKey Method


WorkSurface Properties

WorkSurface Properties
Summary

The properties of the WorkSurface class are listed here.

Properties
Name | Description
Application | Property that returns the Application object.
AttributeSets | Property that returns the AttributeSets collection object associated with this object.
Exported | Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.
Parent | Property that returns the parent ComponentDefinition object from whom this object can logically be reached.
SurfaceBodies | Property that returns the surface bodies associated with this work surface. A work surface can contain more than one surface body.
Translucent | Specifies the translucency of the work surface.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
Visible | Specifies the visibility of the work surface.
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties


WorkSurface.Application Property

WorkSurface.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the Application object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.Application Property


WorkSurface.AttributeSets Property

WorkSurface.AttributeSets Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Property that returns the AttributeSets collection object associated with this object.

Visual Basic
Property AttributeSets() As AttributeSets**
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.AttributeSets Property


WorkSurface.Exported Property

WorkSurface.Exported Property
Summary

Property that gets and sets whether the object is exported. Objects must be marked for export in order for them to be derived.

Visual Basic
Property Exported() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.Exported Property


WorkSurface.Parent Property

WorkSurface.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent ComponentDefinition object from whom this object can logically be reached.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.Parent Property


WorkSurface.SurfaceBodies Property

WorkSurface.SurfaceBodies Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the surface bodies associated with this work surface. A work surface can contain more than one surface body.

Visual Basic
Property SurfaceBodies() As SurfaceBodies**
See Also

SurfaceBody Copy sample

You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.SurfaceBodies Property


WorkSurface.Translucent Property

WorkSurface.Translucent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the translucency of the work surface.

Visual Basic
Property Translucent() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.Translucent Property


WorkSurface.Type Property

WorkSurface.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.Type Property


WorkSurface.Visible Property

WorkSurface.Visible Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Specifies the visibility of the work surface.

Visual Basic
Property Visible() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > WorkSurface Interface > WorkSurface Properties > WorkSurface.Visible Property


WorkSurfaceProxy Interface

WorkSurfaceProxy Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

This is an assembly-context proxy object derived from its native definition-context object. For details of this object's native members, please refer to the WorkSurface object.

Class Hierarchy
Inventor::WorkSurface
    Inventor::WorkSurfaceProxy
Visual Basic
Public Interface WorkSurfaceProxy
Inherits WorkSurface
Remarks

For conceptual information, please refer to the article 'More Proxy Information' in the overviews section.

You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaceProxy Interface


WorkSurfaceProxy Properties

WorkSurfaceProxy Properties
Summary

The properties of the WorkSurfaceProxy class are listed here.

Properties
Name | Description
ContainingOccurrence | Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.
NativeObject | Gets the object in the context of the definition instead of the containing assembly.
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaceProxy Interface > WorkSurfaceProxy Properties


WorkSurfaceProxy.ContainingOccurrence Property

WorkSurfaceProxy.ContainingOccurrence Property Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the ComponentOccurrence that the native object is being referenced through. The returned occurrence is the containing occurrence.

Visual Basic
Property ContainingOccurrence() As ComponentOccurrence**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaceProxy Interface > WorkSurfaceProxy Properties > WorkSurfaceProxy.ContainingOccurrence Property


WorkSurfaceProxy.NativeObject Property

WorkSurfaceProxy.NativeObject Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Gets the object in the context of the definition instead of the containing assembly.

Visual Basic
Property NativeObject() As WorkSurface**
Remarks

For more detailed information about object proxies, please see the overview section (topic: Objects in Context - Proxies, under the General Concepts heading).

You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaceProxy Interface > WorkSurfaceProxy Properties > WorkSurfaceProxy.NativeObject Property


WorkSurfaces Interface

WorkSurfaces Interface Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

The WorkSurfaces collection object represents all of the WorkSurface objects associated with this part or component.

Class Hierarchy
Inventor::WorkSurfaces
Visual Basic
Public Interface WorkSurfaces
Inherits IDispatch
Notes

Members through which this object may be accessed include:

PartComponentDefinition.WorkSurfaces

See Also

SurfaceBody Copy sample

Adding a new stitch (knit) feature sample

You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface


WorkSurfaces Methods

WorkSurfaces Methods
Summary

The methods of the WorkSurfaces class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified WorkSurface object from the collection. This is the default property of the WorkSurfaces collection object.
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Methods


WorkSurfaces.Item Method

WorkSurfaces.Item Method Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the specified WorkSurface object from the collection. This is the default property of the WorkSurfaces collection object.

Visual Basic
Sub Item(Index As VARIANT, Result As [out, retval] WorkSurface*)
Parameters
Parameters | Description
index | Input Variant value that specifies the object to return. This can be a numeric value indicating the index of the item in the collection or it can be a string indicating the work point name. If an out of range index or a name of a non-existent work point is specified, an error occurs.
See Also

SurfaceBody Copy sample

Adding a new stitch (knit) feature sample

You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Methods > WorkSurfaces.Item Method


WorkSurfaces Properties

WorkSurfaces Properties
Summary

The properties of the WorkSurfaces class are listed here.

Properties
Name | Description
Application | Property returning an object representing the Application - either an object of type Application or an object of type Object.
Count | Property that returns the number of items in this collection.
Parent | Property that returns the parent ComponentDefinition object from whom this object can logically be reached.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Properties


WorkSurfaces.Application Property

WorkSurfaces.Application Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an object representing the Application - either an object of type Application or an object of type Object.

Visual Basic
Property Application() As IDispatch**
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Properties > WorkSurfaces.Application Property


WorkSurfaces.Count Property

WorkSurfaces.Count Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As long*
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Properties > WorkSurfaces.Count Property


WorkSurfaces.Parent Property

WorkSurfaces.Parent Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property that returns the parent ComponentDefinition object from whom this object can logically be reached.

Visual Basic
Property Parent() As ComponentDefinition**
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Properties > WorkSurfaces.Parent Property


WorkSurfaces.Type Property

WorkSurfaces.Type Property Available in Apprentice Available in Inventor Available in Server Introduced in Inventor 6
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > WorkSurfaces Interface > WorkSurfaces Properties > WorkSurfaces.Type Property


Inventor.AccuracyEnum Enumeration

Inventor.AccuracyEnum Enumeration
Summary

This is record Inventor::AccuracyEnum.

Visual Basic
Public Enum AccuracyEnum
  kLow = 69377
  kMedium = 69378
  kHigh = 69379
  kVeryHigh = 69380
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AccuracyEnum Enumeration


Inventor.ActionTypeEnum Enumeration

Inventor.ActionTypeEnum Enumeration Introduced in Inventor 9
Summary

Bit field describing the various action types

Visual Basic
Public Enum ActionTypeEnum
  kNoAction = 0
  kAllActions = 4294967295
  kDeleteAction = 1
  kActivationAction = 1
  kReorderAction = 1
  kMoveAction = 1
End Enum
Members
Members | Description
kNoAction | No action types
kAllActions | All action types
kDeleteAction | Delete action type
kActivationAction | Activation action type
kReorderAction | Reorder action type
kMoveAction | Move action type
Notes

Members through which this object may be accessed include:

ComponentOccurrence.DisabledActionTypes

CustomParameterGroup.DisabledActionTypes

Parameter.DisabledActionTypes

Sketch.DisabledActionTypes

Sketch3D.DisabledActionTypes

SketchEntity.DisabledActionTypes

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ActionTypeEnum Enumeration


Inventor.AddInLicenseStatusEnum Enumeration

Inventor.AddInLicenseStatusEnum Enumeration
Summary

This is record Inventor::AddInLicenseStatusEnum.

Visual Basic
Public Enum AddInLicenseStatusEnum
  kAddInLicenseStatusUnlicensed = 76289
  kAddInLicenseStatusAvailable = 76290
  kAddInLicenseStatusUnavailable = 76291
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AddInLicenseStatusEnum Enumeration


Inventor.AddInLoadBehaviorEnum Enumeration

Inventor.AddInLoadBehaviorEnum Enumeration
Summary

This is record Inventor::AddInLoadBehaviorEnum.

Visual Basic
Public Enum AddInLoadBehaviorEnum
  kLoadImmediately = 94721
  kLoadWithParts = 94722
  kLoadWithAssemblies = 94723
  kLoadWithPresentations = 94724
  kLoadWithDrawings = 94725
  kLoadOnDemand = 94726
  kLoadBehaviorUnknown = 94727
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AddInLoadBehaviorEnum Enumeration


Inventor.AlignmentTypeEnum Enumeration

Inventor.AlignmentTypeEnum Enumeration
Summary

This is record Inventor::AlignmentTypeEnum.

Visual Basic
Public Enum AlignmentTypeEnum
  kHorizontalAlignment = 64257
  kVerticalAlignment = 64258
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AlignmentTypeEnum Enumeration


Inventor.AlternateUnitsDisplayTypeEnum Enumeration

Inventor.AlternateUnitsDisplayTypeEnum Enumeration
Summary

This is record Inventor::AlternateUnitsDisplayTypeEnum.

Visual Basic
Public Enum AlternateUnitsDisplayTypeEnum
  kAdjacent = 73473
  kAdjacentWithBracketsForPrimary = 73474
  kAdjacentWithBracketsForAlternate = 73475
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AlternateUnitsDisplayTypeEnum Enumeration


Inventor.AnalysisTypeEnum Enumeration

Inventor.AnalysisTypeEnum Enumeration
Summary

This is record Inventor::AnalysisTypeEnum.

Visual Basic
Public Enum AnalysisTypeEnum
  kNoAnalysis = 73985
  kCrossSectionAnalysis = 73986
  kCurvatureAnalysis = 73987
  kDraftAnalysis = 73988
  kSurfaceAnalysis = 73989
  kZebraAnalysis = 73990
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AnalysisTypeEnum Enumeration


Inventor.AngleConstraintSolutionTypeEnum Enumeration

Inventor.AngleConstraintSolutionTypeEnum Enumeration
Summary

This is record Inventor::AngleConstraintSolutionTypeEnum.

Visual Basic
Public Enum AngleConstraintSolutionTypeEnum
  kDirectedSolution = 78593
  kUndirectedSolution = 78594
  kReferenceVectorSolution = 78595
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.AngleConstraintSolutionTypeEnum Enumeration


Inventor.AngularPrecisionEnum Enumeration

Inventor.AngularPrecisionEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the precision for angular dimensions

Visual Basic
Public Enum AngularPrecisionEnum
  kZeroDecimalPlaceAngularPrecision = 42241
  kOneDecimalPlaceAngularPrecision = 42242
  kTwoDecimalPlacesAngularPrecision = 42243
  kThreeDecimalPlacesAngularPrecision = 42244
  kFourDecimalPlacesAngularPrecision = 42245
  kFiveDecimalPlacesAngularPrecision = 42246
  kSixDecimalPlacesAngularPrecision = 42247
  kSevenDecimalPlacesAngularPrecision = 42248
  kEightDecimalPlacesAngularPrecision = 42249
  kDegreesAngularPrecision = 42250
  kMinutesAngularPrecision = 42251
  kSecondsAngularPrecision = 42252
  kSecondsOneDecimalPlaceAngularPrecision = 42253
  kSecondsTwoDecimalPlaceAngularPrecision = 42254
  kSecondsThreeDecimalPlaceAngularPrecision = 42255
  kSecondsFourDecimalPlaceAngularPrecision = 42256
End Enum
Members
Members | Description
kZeroDecimalPlaceAngularPrecision | Zero decimal place precision for angular dimensions
kOneDecimalPlaceAngularPrecision | One decimal place precision for angular dimensions
kTwoDecimalPlacesAngularPrecision | Two decimal places precision for angular dimensions
kThreeDecimalPlacesAngularPrecision | Three decimal places precision for angular dimensions
kFourDecimalPlacesAngularPrecision | Four decimal places precision for angular dimensions
kFiveDecimalPlacesAngularPrecision | Five decimal places precision for angular dimensions
kSixDecimalPlacesAngularPrecision | Six decimal places precision for angular dimensions
kSevenDecimalPlacesAngularPrecision | Seven decimal places precision for angular dimensions
kEightDecimalPlacesAngularPrecision | Eight decimal places precision for angular dimensions
kDegreesAngularPrecision | Degrees precision for angular dimensions
kMinutesAngularPrecision | Minutes precision for angular dimensions
kSecondsAngularPrecision | Seconds precision for angular dimensions
Notes

Members through which this object may be accessed include:

AngularGeneralDimension.AngularPrecision

AngularGeneralDimension.ToleranceAngularPrecision

DimensionStyle.AngularPrecision

DimensionStyle.ToleranceAngularPrecision

You are here: Symbol Reference > Inventor Library > Enums > Inventor.AngularPrecisionEnum Enumeration


Inventor.ApplicationAddInTypeEnum Enumeration

Inventor.ApplicationAddInTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating the ApplicationAddIn types.

Visual Basic
Public Enum ApplicationAddInTypeEnum
  kUnknownApplicationAddIn = 1793
  kStandardApplicationAddIn = 1794
  kTranslationApplicationAddIn = 1795
  kPlugInApplicationAddIn = 1796
End Enum
Members
Members | Description
kUnknownApplicationAddIn | Unknown Application AddIn.
kStandardApplicationAddIn | Standard Application AddIn.
kTranslationApplicationAddIn | Translator Application AddIn.
Notes

Members through which this object may be accessed include:

ApplicationAddIn.AddInType

IRxApplicationAddIn.AddInType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ApplicationAddInTypeEnum Enumeration


Inventor.ApplicationFrameColorTypeEnum Enumeration

Inventor.ApplicationFrameColorTypeEnum Enumeration
Summary

This is record Inventor::ApplicationFrameColorTypeEnum.

Visual Basic
Public Enum ApplicationFrameColorTypeEnum
  kLightColorTheme = 87041
  kDarkColorTheme = 87042
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ApplicationFrameColorTypeEnum Enumeration


Inventor.ArcDimensionTypeEnum Enumeration

Inventor.ArcDimensionTypeEnum Enumeration
Summary

This is record Inventor::ArcDimensionTypeEnum.

Visual Basic
Public Enum ArcDimensionTypeEnum
  kRadialArcDimension = 65537
  kDiametricArcDimension = 65538
  kAngleArcDimension = 65539
  kArcLengthArcDimension = 65540
  kChordLengthArcDimension = 65541
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ArcDimensionTypeEnum Enumeration


Inventor.ArrowheadTypeEnum Enumeration

Inventor.ArrowheadTypeEnum Enumeration
Summary

This is record Inventor::ArrowheadTypeEnum.

Visual Basic
Public Enum ArrowheadTypeEnum
  kAsStyleArrowheadType = 71937
  kOpenArrowheadType = 71938
  kBlankArrowheadType = 71939
  kClosedArrowheadType = 71940
  kFilledArrowheadType = 71941
  kHalf1FilledArrowheadType = 71942
  kHalf2FilledArrowheadType = 71943
  kFlaredArrowheadType = 71944
  kHalf1FlaredArrowheadType = 71945
  kHalf2FlaredArrowheadType = 71946
  kCircleArrowheadType = 71947
  kNoneArrowheadType = 71948
  kSmallDotArrowheadType = 71949
  kLargeDotArrowheadType = 71950
  kObliqueArrowheadType = 71951
  kOriginArrowheadType = 71952
  kThickLineArrowheadType = 71953
  kDatum60BlankArrowheadType = 71954
  kDatum60FilledArrowheadType = 71955
  kDatum45BlankArrowheadType = 71956
  kDatum45FilledArrowheadType = 71957
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ArrowheadTypeEnum Enumeration


Inventor.BackgroundTypeEnum Enumeration

Inventor.BackgroundTypeEnum Enumeration
Summary

This is record Inventor::BackgroundTypeEnum.

Visual Basic
Public Enum BackgroundTypeEnum
  kOneColorBackgroundType = 52737
  kGradientBackgroundType = 52738
  kImageBackgroundType = 52739
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BackgroundTypeEnum Enumeration


Inventor.BalloonDirectionEnum Enumeration

Inventor.BalloonDirectionEnum Enumeration Introduced in Inventor 9
Summary

Balloon Direction Enum

Visual Basic
Public Enum BalloonDirectionEnum
  kTopDirection = 48385
  kBottomDirection = 48386
  kLeftDirection = 48387
  kRightDirection = 48388
End Enum
Members
Members | Description
kTopDirection | Top direction
kBottomDirection | Bottom direction
kLeftDirection | Left direction
kRightDirection | Right direction
Notes

Members through which this object may be accessed include:

Balloon.PlacementDirection

You are here: Symbol Reference > Inventor Library > Enums > Inventor.BalloonDirectionEnum Enumeration


Inventor.BalloonTypeEnum Enumeration

Inventor.BalloonTypeEnum Enumeration Introduced in Inventor 9
Summary

Balloon Type Enum

Visual Basic
Public Enum BalloonTypeEnum
  kCircularWithOneEntryBalloonType = 48129
  kCircularWithTwoEntriesBalloonType = 48130
  kHexagonBalloonType = 48131
  kLinearBalloonType = 48132
  kNoneBalloonType = 48133
  kSketchedSymbolBalloonType = 48134
End Enum
Members
Members | Description
kCircularWithOneEntryBalloonType | Circular with one entry
kCircularWithTwoEntriesBalloonType | Circular with two entries
kHexagonBalloonType | Hexagonal
kLinearBalloonType | Linear
kNoneBalloonType | None
kSketchedSymbolBalloonType | Sketched symbol
Notes

Members through which this object may be accessed include:

BalloonStyle.BalloonType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.BalloonTypeEnum Enumeration


Inventor.BarControlTypeEnum Enumeration

Inventor.BarControlTypeEnum Enumeration Introduced in Inventor 5
Summary

Constants enumerating bar control types.

Visual Basic
Public Enum BarControlTypeEnum
  kBarControlButton = 22785
  kBarControlPopUp = 22786
End Enum
Members
Members | Description
kBarControlButton | Bar control button.
kBarControlPopUp | Bar control pop-up.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BarControlTypeEnum Enumeration


Inventor.BaseFeatureOutputTypeEnum Enumeration

Inventor.BaseFeatureOutputTypeEnum Enumeration
Summary

This is record Inventor::BaseFeatureOutputTypeEnum.

Visual Basic
Public Enum BaseFeatureOutputTypeEnum
  kSurfaceOutputType = 90113
  kSolidOutputType = 90114
  kCompositeOutputType = 90115
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BaseFeatureOutputTypeEnum Enumeration


Inventor.BendAngleTypeEnum Enumeration

Inventor.BendAngleTypeEnum Enumeration
Summary

This is record Inventor::BendAngleTypeEnum.

Visual Basic
Public Enum BendAngleTypeEnum
  kBendingAngleType = 81665
  kOpenAngleType = 81666
  kDefaultAngleType = 81667
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendAngleTypeEnum Enumeration


Inventor.BendLocationEnum Enumeration

Inventor.BendLocationEnum Enumeration
Summary

This is record Inventor::BendLocationEnum.

Visual Basic
Public Enum BendLocationEnum
  kCenterlineOfBend = 75777
  kStartOfBend = 75778
  kEndOfBend = 75779
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendLocationEnum Enumeration


Inventor.BendOrderSourceTypeEnum Enumeration

Inventor.BendOrderSourceTypeEnum Enumeration
Summary

This is record Inventor::BendOrderSourceTypeEnum.

Visual Basic
Public Enum BendOrderSourceTypeEnum
  kDefaultBendOrder = 151021569
  kOverrideBendOrder = 151021570
  kDuplicateOverrideBendOrder = 151021571
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendOrderSourceTypeEnum Enumeration


Inventor.BendPartTypeEnum Enumeration

Inventor.BendPartTypeEnum Enumeration
Summary

This is record Inventor::BendPartTypeEnum.

Visual Basic
Public Enum BendPartTypeEnum
  kArcLengthAndAngleBendPart = 83457
  kRadiusAndAngleBendPart = 83458
  kRadiusAndArcLengthBendPart = 83459
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendPartTypeEnum Enumeration


Inventor.BendPositionEnum Enumeration

Inventor.BendPositionEnum Enumeration
Summary

This is record Inventor::BendPositionEnum.

Visual Basic
Public Enum BendPositionEnum
  kBendPositionOutsideBaseFace = 75009
  kBendPositionAdjacentFace = 75010
  kBendPositionInsideBendFace = 75011
  kBendPositionTangentToSideFace = 75012
  kBendPositionInnerEdgeOffset = 75013
  kBendPositionOuterEdgeOffset = 75014
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendPositionEnum Enumeration


Inventor.BendReliefShapeEnum Enumeration

Inventor.BendReliefShapeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the bend relief shape.

Visual Basic
Public Enum BendReliefShapeEnum
  kStraightBendReliefShape = 27905
  kRoundBendReliefShape = 27906
  kDefaultBendReliefShape = 27907
  kTearBendReliefShape = 27908
End Enum
Members
Members | Description
kStraightBendReliefShape | Constant identifying the straight bend relief shape.
kRoundBendReliefShape | Constant identifying the round bend relief shape.
Notes

Members through which this object may be accessed include:

BendOptions.BendReliefShape

SheetMetalStyle.BendReliefShape

You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendReliefShapeEnum Enumeration


Inventor.BendTransitionEnum Enumeration

Inventor.BendTransitionEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying Bend Transition.

Visual Basic
Public Enum BendTransitionEnum
  kNoBendTransition = 28161
  kIntersectionBendTransition = 28162
  kStraightLineBendTransition = 28163
  kArcBendTransition = 28164
  kDefaultBendTransition = 28165
  kTrimToBendBendTransition = 28166
End Enum
Members
Members | Description
kNoBendTransition | Constant identifying no bend transition.
kIntersectionBendTransition | Constant identifying intersection bend transition.
kStraightLineBendTransition | Constant identifying straight line bend transition.
kArcBendTransition | Constant identifying arc bend transition.
Notes

Members through which this object may be accessed include:

BendOptions.BendTransition

SheetMetalStyle.BendTransition

You are here: Symbol Reference > Inventor Library > Enums > Inventor.BendTransitionEnum Enumeration


Inventor.BIMCableTrayConnectionTypeEnum Enumeration

Inventor.BIMCableTrayConnectionTypeEnum Enumeration
Summary

This is record Inventor::BIMCableTrayConnectionTypeEnum.

Visual Basic
Public Enum BIMCableTrayConnectionTypeEnum
  kElectricallyBondedConnectionType = 93169
  kUndefinedConnectionType = 93170
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMCableTrayConnectionTypeEnum Enumeration


Inventor.BIMConduitConnectionTypeEnum Enumeration

Inventor.BIMConduitConnectionTypeEnum Enumeration
Summary

This is record Inventor::BIMConduitConnectionTypeEnum.

Visual Basic
Public Enum BIMConduitConnectionTypeEnum
  kCompressionConduitConnectionType = 93153
  kGluedConduitConnectionType = 93154
  kSetScrewConduitConnectionType = 93155
  kThreadedConduitConnectionType = 93156
  kUndefinedConduitConnectionType = 93157
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMConduitConnectionTypeEnum Enumeration


Inventor.BIMConnectorDefinitionTypeEnum Enumeration

Inventor.BIMConnectorDefinitionTypeEnum Enumeration
Summary

This is record Inventor::BIMConnectorDefinitionTypeEnum.

Visual Basic
Public Enum BIMConnectorDefinitionTypeEnum
  kBIMCableTrayConnectorType = 92929
  kBIMConduitConnectorType = 92930
  kBIMDuctConnectorType = 92931
  kBIMElectricalConnectorType = 92932
  kBIMPipeConnectorType = 92933
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMConnectorDefinitionTypeEnum Enumeration


Inventor.BIMConnectorShapeEnum Enumeration

Inventor.BIMConnectorShapeEnum Enumeration
Summary

This is record Inventor::BIMConnectorShapeEnum.

Visual Basic
Public Enum BIMConnectorShapeEnum
  kUndefinedShapeConnector = 92673
  kRectangularShapeConnector = 92674
  kCircularShapeConnector = 92675
  kOvalShapeConnector = 92676
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMConnectorShapeEnum Enumeration


Inventor.BIMDuctConnectionTypeEnum Enumeration

Inventor.BIMDuctConnectionTypeEnum Enumeration
Summary

This is record Inventor::BIMDuctConnectionTypeEnum.

Visual Basic
Public Enum BIMDuctConnectionTypeEnum
  kBandedDuctConnectionType = 93137
  kClippedDuctConnectionType = 93138
  kFlangeDuctConnectionType = 93139
  kMasticDuctConnectionType = 93140
  kOverCollarDuctConnectionType = 93141
  kRawEdgeDuctConnectionType = 93142
  kSlipDriveDuctConnectionType = 93143
  kSlipJointDuctConnectionType = 93144
  kUndefinedDuctConnectionType = 93145
  kVanStoneDuctConnectionType = 93146
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMDuctConnectionTypeEnum Enumeration


Inventor.BIMDuctFlowConfigurationEnum Enumeration

Inventor.BIMDuctFlowConfigurationEnum Enumeration
Summary

This is record Inventor::BIMDuctFlowConfigurationEnum.

Visual Basic
Public Enum BIMDuctFlowConfigurationEnum
  kCalculatedDuctFlowConfigurationType = 93105
  kPresetDuctFlowConfigurationType = 93106
  kSystemDuctFlowConfigurationType = 93107
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMDuctFlowConfigurationEnum Enumeration


Inventor.BIMDuctLossMethodEnum Enumeration

Inventor.BIMDuctLossMethodEnum Enumeration
Summary

This is record Inventor::BIMDuctLossMethodEnum.

Visual Basic
Public Enum BIMDuctLossMethodEnum
  kNoneDuctLossMethodType = 93121
  kKCoefficientDuctLossMethodType = 93122
  kSpecificLossDuctLossMethodType = 93123
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMDuctLossMethodEnum Enumeration


Inventor.BIMDuctSystemTypeEnum Enumeration

Inventor.BIMDuctSystemTypeEnum Enumeration
Summary

This is record Inventor::BIMDuctSystemTypeEnum.

Visual Basic
Public Enum BIMDuctSystemTypeEnum
  kExhaustDuctSystemType = 93089
  kOtherDuctSystemType = 93090
  kReturnDuctSystemType = 93091
  kSupplyDuctSystemType = 93092
  kUndefinedDuctSystemType = 93093
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMDuctSystemTypeEnum Enumeration


Inventor.BIMElectricalSystemTypeEnum Enumeration

Inventor.BIMElectricalSystemTypeEnum Enumeration
Summary

This is record Inventor::BIMElectricalSystemTypeEnum.

Visual Basic
Public Enum BIMElectricalSystemTypeEnum
  kCommunicationElectricalSystemType = 93073
  kControlsElectricalSystemType = 93074
  kDataElectricalSystemType = 93075
  kFireAlarmElectricalSystemType = 93076
  kNurseCallElectricalSystemType = 93077
  kPowerBalancedElectricalSystemType = 93078
  kPowerUnbalancedElectricalSystemType = 93079
  kSecurityElectricalSystemType = 93080
  kTelephoneElectricalSystemType = 93081
  kUndefinedElectricalSystemType = 93082
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMElectricalSystemTypeEnum Enumeration


Inventor.BIMFlowDirectionEnum Enumeration

Inventor.BIMFlowDirectionEnum Enumeration
Summary

This is record Inventor::BIMFlowDirectionEnum.

Visual Basic
Public Enum BIMFlowDirectionEnum
  kBiDirectionalFlowDirectionType = 93041
  kInFlowDirectionType = 93042
  kOutFlowDirectionType = 93043
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMFlowDirectionEnum Enumeration


Inventor.BIMPipeConnectionTypeEnum Enumeration

Inventor.BIMPipeConnectionTypeEnum Enumeration
Summary

This is record Inventor::BIMPipeConnectionTypeEnum.

Visual Basic
Public Enum BIMPipeConnectionTypeEnum
  kBrazedPipeConnectionType = 93009
  kButtWeldedPipeConnectionType = 93010
  kCapillaryPipeConnectionType = 93011
  kCompressionPipeConnectionType = 93012
  kCouplingPipeConnectionType = 93013
  kCrimpedPipeConnectionType = 93014
  kFlangePipeConnectionType = 93015
  kFusionPipeConnectionType = 93016
  kGluedPipeConnectionType = 93017
  kGroovedPipeConnectionType = 93018
  kSlipJointPipeConnectionType = 93019
  kSocketWeldedPipeConnectionType = 93020
  kSolderedPipeConnectionType = 93021
  kThreadedPipeConnectionType = 93022
  kUndefinedPipeConnectionType = 93023
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMPipeConnectionTypeEnum Enumeration


Inventor.BIMPipeFlowConfigurationEnum Enumeration

Inventor.BIMPipeFlowConfigurationEnum Enumeration
Summary

This is record Inventor::BIMPipeFlowConfigurationEnum.

Visual Basic
Public Enum BIMPipeFlowConfigurationEnum
  kCalculatedFlowConfigurationType = 92993
  kPresetFlowConfigurationType = 92994
  kSystemFlowConfigurationType = 92995
  kFixtureUnitsFlowConfigurationType = 92996
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMPipeFlowConfigurationEnum Enumeration


Inventor.BIMPipeLossMethodEnum Enumeration

Inventor.BIMPipeLossMethodEnum Enumeration
Summary

This is record Inventor::BIMPipeLossMethodEnum.

Visual Basic
Public Enum BIMPipeLossMethodEnum
  kNonePipeLossMethodType = 92977
  kKCoefficientPipeLossMethodType = 92978
  kSpecificLossPipeLossMethodType = 92979
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMPipeLossMethodEnum Enumeration


Inventor.BIMPipeSystemTypeEnum Enumeration

Inventor.BIMPipeSystemTypeEnum Enumeration
Summary

This is record Inventor::BIMPipeSystemTypeEnum.

Visual Basic
Public Enum BIMPipeSystemTypeEnum
  kDomesticColdWaterPipeSystemType = 92945
  kDomesticHotWaterPipeSystemType = 92946
  kFireProtectionDryPipeSystemType = 92947
  kFireProtectionOtherPipeSystemType = 92948
  kFireProtectionPreActionPipeSystemType = 92949
  kFireProtectionWetPipeSystemType = 92950
  kHydronicReturnPipeSystemType = 92951
  kHydronicSupplyPipeSystemType = 92952
  kOtherPipeSystemType = 92953
  kSanitaryPipeSystemType = 92954
  kUndefinedPipeSystemType = 92955
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMPipeSystemTypeEnum Enumeration


Inventor.BOMQuantityTypeEnum Enumeration

Inventor.BOMQuantityTypeEnum Enumeration
Summary

This is record Inventor::BOMQuantityTypeEnum.

Visual Basic
Public Enum BOMQuantityTypeEnum
  kEachBOMQuantity = 52225
  kParameterBOMQuantity = 52226
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BOMQuantityTypeEnum Enumeration


Inventor.BOMStructureEnum Enumeration

Inventor.BOMStructureEnum Enumeration
Summary

This is record Inventor::BOMStructureEnum.

Visual Basic
Public Enum BOMStructureEnum
  kDefaultBOMStructure = 51969
  kNormalBOMStructure = 51970
  kPhantomBOMStructure = 51971
  kReferenceBOMStructure = 51972
  kPurchasedBOMStructure = 51973
  kInseparableBOMStructure = 51974
  kVariesBOMStructure = 51975
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BOMStructureEnum Enumeration


Inventor.BOMViewTypeEnum Enumeration

Inventor.BOMViewTypeEnum Enumeration
Summary

This is record Inventor::BOMViewTypeEnum.

Visual Basic
Public Enum BOMViewTypeEnum
  kModelDataBOMViewType = 62465
  kStructuredBOMViewType = 62466
  kPartsOnlyBOMViewType = 62467
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BOMViewTypeEnum Enumeration


Inventor.BooleanTypeEnum Enumeration

Inventor.BooleanTypeEnum Enumeration
Summary

This is record Inventor::BooleanTypeEnum.

Visual Basic
Public Enum BooleanTypeEnum
  kBooleanTypeDifference = 74241
  kBooleanTypeUnion = 74242
  kBooleanTypeIntersect = 74243
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BooleanTypeEnum Enumeration


Inventor.BorderLabelModeEnum Enumeration

Inventor.BorderLabelModeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the label mode of the zones in a drawing border.

Visual Basic
Public Enum BorderLabelModeEnum
  kBorderLabelModeAlphabetical = 29953
  kBorderLabelModeNumeric = 29954
  kBorderLabelModeNone = 29955
End Enum
Members
Members | Description
kBorderLabelModeAlphabetical | Constant identifying an alphabetical index label.
kBorderLabelModeNumeric | Constant identifying a numeric index label.
kBorderLabelModeNone | Constant identifying that no index label is used.
Notes

Members through which this object may be accessed include:

DefaultBorder.HorizontalZoneLabelMode

DefaultBorder.VerticalZoneLabelMode

See Also

Border Insert sample

You are here: Symbol Reference > Inventor Library > Enums > Inventor.BorderLabelModeEnum Enumeration


Inventor.BoreLine Structure

Inventor.BoreLine Structure
Summary

Structure to hold an attributed ray for entity selection. More accurately, this is a selection cylinder, with a front and a back-plane and a radius.

Visual Basic
Public Structure BoreLine
  Public m_point As double
  Public m_direction As double
  Public m_front As double
  Public m_back As double
  Public m_radius As double
End Structure
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BoreLine Structure


Inventor.BossTypeEnum Enumeration

Inventor.BossTypeEnum Enumeration
Summary

This is record Inventor::BossTypeEnum.

Visual Basic
Public Enum BossTypeEnum
  kThreadBossType = 94209
  kHeadBossType = 94210
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BossTypeEnum Enumeration


Inventor.BoundaryPatchConditionEnum Enumeration

Inventor.BoundaryPatchConditionEnum Enumeration
Summary

This is record Inventor::BoundaryPatchConditionEnum.

Visual Basic
Public Enum BoundaryPatchConditionEnum
  kFreeBoundaryPatchCondition = 63489
  kTangentBoundaryPatchCondition = 63490
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BoundaryPatchConditionEnum Enumeration


Inventor.BreakOrientationEnum Enumeration

Inventor.BreakOrientationEnum Enumeration
Summary

This is record Inventor::BreakOrientationEnum.

Visual Basic
Public Enum BreakOrientationEnum
  kHorizontalBreakOrientation = 84225
  kVerticalBreakOrientation = 84226
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BreakOrientationEnum Enumeration


Inventor.BreakOutDepthTypeEnum Enumeration

Inventor.BreakOutDepthTypeEnum Enumeration
Summary

This is record Inventor::BreakOutDepthTypeEnum.

Visual Basic
Public Enum BreakOutDepthTypeEnum
  kFromPointBreakOutType = 117492737
  kToSketchBreakOutType = 117492738
  kToHoleBreakOutType = 117492739
  kThroughPartBreakOutType = 117492740
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BreakOutDepthTypeEnum Enumeration


Inventor.BreakStyleEnum Enumeration

Inventor.BreakStyleEnum Enumeration
Summary

This is record Inventor::BreakStyleEnum.

Visual Basic
Public Enum BreakStyleEnum
  kRectangularBreakStyle = 84481
  kStructuralBreakStyle = 84482
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BreakStyleEnum Enumeration


Inventor.BrowserNodeDisplayStateEnum Enumeration

Inventor.BrowserNodeDisplayStateEnum Enumeration Introduced in Inventor 9
Summary

Browser node display state

Visual Basic
Public Enum BrowserNodeDisplayStateEnum
  kDefaultDisplayState = 46849
  kActivateDisplayState = 46850
  kSickDisplayState = 46852
  kComatoseDisplayState = 46853
  kSuppressDisplayState = 46854
  kCheckBoxDisplayState = 46855
  kUnresolvedDisplayState = 46856
  kUpdateRequiredDisplayState = 46857
  kAdaptiveDisplayState = 46858
  kAdaptiveWarningDisplayState = 46859
  kAdaptiveErrorDisplayState = 46860
  kContactSetDisplayState = 46861
  kYellowCheckBoxDisplayState = 46862
  kIndependantAdaptivityDisplayState = 46863
  kReferencedDocNeedsUpdateDisplayState = 46864
  kCyclicDisplayState = 46865
  kExcludeDisplayState = 46866
  kGrayCheckBoxDisplayState = 46867
  kBoldDisplayState = 46868
End Enum
Members
Members | Description
kDefaultDisplayState | Default display state of a browser node. Use this to reset a browser node's display state.
kActivateDisplayState | Mimics the browser node of an assembly occurrence in in-place-edit state
kSickDisplayState | Display state indicating that the subject corresponding to this node is sick
kComatoseDisplayState | Display state indicating that the subject corresponding to this node is comatose
kSuppressDisplayState | Display state indicating that the subject corresponding to this node is suppressed
kCheckBoxDisplayState | Display state indicating that this node has a checkbox state icon
kUnresolvedDisplayState | Display state indicating that this node has a unresolved state icon
kUpdateRequiredDisplayState | Display state indicating that this node has a update required state icon
kAdaptiveDisplayState | Display state indicating that this node has a adaptive state icon
kAdaptiveWarningDisplayState | Display state indicating that this node has a adaptive warning state icon
kAdaptiveErrorDisplayState | Display state indicating that this node has a adaptive error state icon
kContactSetDisplayState | Display state indicating that this node has a contact set state icon
kYellowCheckBoxDisplayState | Display state indicating that this node has a sick positional variation state icon
kIndependantAdaptivityDisplayState | Display state indicating that this node has a independant adaptivity state icon
Notes

Members through which this object may be accessed include:

BrowserNodeDefinition.AdditionalDisplayState

BrowserNodeDefinition.DisplayState

You are here: Symbol Reference > Inventor Library > Enums > Inventor.BrowserNodeDisplayStateEnum Enumeration


Inventor.ButtonDisplayEnum Enumeration

Inventor.ButtonDisplayEnum Enumeration Introduced in Inventor 9
Summary

Button Display Style

Visual Basic
Public Enum ButtonDisplayEnum
  kNoTextWithIcon = 43009
  kAlwaysDisplayText = 43010
  kDisplayTextInLearningMode = 43011
End Enum
Members
Members | Description
kNoTextWithIcon | Do not show Text with Icons on a Button
kAlwaysDisplayText | Always display Text on a Button
kDisplayTextInLearningMode | Display Text in Learning mode on a Button
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ButtonDisplayEnum Enumeration


Inventor.ButtonTypeEnum Enumeration

Inventor.ButtonTypeEnum Enumeration
Summary

This is record Inventor::ButtonTypeEnum.

Visual Basic
Public Enum ButtonTypeEnum
  kCancelButtonType = 1
  kAcceptButtonType = 2
  kEditButtonType = 4
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ButtonTypeEnum Enumeration


Inventor.CenterlineTypeEnum Enumeration

Inventor.CenterlineTypeEnum Enumeration
Summary

This is record Inventor::CenterlineTypeEnum.

Visual Basic
Public Enum CenterlineTypeEnum
  kRegularCenterlineType = 62977
  kBisectorCenterlineType = 62978
  kWorkFeatureCenterlineType = 62979
  kCenteredPatternCenterlineType = 62980
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CenterlineTypeEnum Enumeration


Inventor.CentermarkTypeEnum Enumeration

Inventor.CentermarkTypeEnum Enumeration
Summary

This is record Inventor::CentermarkTypeEnum.

Visual Basic
Public Enum CentermarkTypeEnum
  kRegularCentermarkType = 63233
  kWorkFeatureCentermarkType = 63234
  kCenterOfGravityCentermarkType = 63237
  kPunchFeatureCentermarkType = 63238
  kRecoveredPunchFeatureCentermarkType = 63239
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CentermarkTypeEnum Enumeration


Inventor.ChamferDefinitionTypeEnum Enumeration

Inventor.ChamferDefinitionTypeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the definition type of a chamfer.

Visual Basic
Public Enum ChamferDefinitionTypeEnum
  kDistance = 26881
  kDistanceAndAngle = 26882
  kTwoDistances = 26883
End Enum
Members
Members | Description
kDistance | Constant identifying the definition of a chamfer using one distance.
kDistanceAndAngle | Constant identifying the definition of a chamfer using a distance and an angle.
kTwoDistances | Constant identifying the definition of a chamfer using two distances.
Notes

Members through which this object may be accessed include:

ChamferFeature.DefinitionType

CornerChamferDefinition.ChamferDefinitionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ChamferDefinitionTypeEnum Enumeration


Inventor.CircleDimensionTypeEnum Enumeration

Inventor.CircleDimensionTypeEnum Enumeration
Summary

This is record Inventor::CircleDimensionTypeEnum.

Visual Basic
Public Enum CircleDimensionTypeEnum
  kDiametricCircleDimension = 65793
  kRadialCircleDimension = 65794
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CircleDimensionTypeEnum Enumeration


Inventor.ClientGraphicsTypeEnum Enumeration

Inventor.ClientGraphicsTypeEnum Enumeration Introduced in Inventor 9
Summary

Property that gets the type of the ClientGraphics.

Visual Basic
Public Enum ClientGraphicsTypeEnum
  kTransientClientGraphics = 45313
  kPreviewClientGraphics = 45314
End Enum
Members
Members | Description
kTransientClientGraphics | The ClientGraphics object is transacted, and was created using the Add method
kPreviewClientGraphics | The ClientGraphics object is non-transacted, and was created using the AddAsPreview method
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ClientGraphicsTypeEnum Enumeration


Inventor.ColorBindingEnum Enumeration

Inventor.ColorBindingEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying kind of application of the colors in the associated color-set.

Visual Basic
Public Enum ColorBindingEnum
  kPerVertexColors = 19457
  kPerStripColors = 19458
  kPerItemColors = 19459
  kOverallColor = 19460
End Enum
Members
Members | Description
kPerVertexColors | First color used for the first vertex, the second color is used for the second vertex, etc.
kPerStripColors | First color used for the first strip of vertices, the second used for the second strip, etc.
kPerItemColors | First color used for the first logically complete item in the primitive being defined (triangle, line segment, etc.).
kOverallColor | First color used for the entire graphics primitive.
Notes

Members through which this object may be accessed include:

LineGraphics.ColorBinding

LineStripGraphics.ColorBinding

TriangleFanGraphics.ColorBinding

TriangleGraphics.ColorBinding

TriangleStripGraphics.ColorBinding

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ColorBindingEnum Enumeration


Inventor.ColorSourceTypeEnum Enumeration

Inventor.ColorSourceTypeEnum Enumeration
Summary

This is record Inventor::ColorSourceTypeEnum.

Visual Basic
Public Enum ColorSourceTypeEnum
  kOverrideColorSource = 79105
  kAutomaticColorSource = 79106
  kLayerColorSource = 79107
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ColorSourceTypeEnum Enumeration


Inventor.CommandBarTypeEnum Enumeration

Inventor.CommandBarTypeEnum Enumeration Introduced in Inventor 9
Summary

Command Bar Type

Visual Basic
Public Enum CommandBarTypeEnum
  kRegularCommandBar = 43265
  kPopUpCommandBar = 43266
  kSplitButtonCommandBar = 43267
  kSplitButtonMRUCommandBar = 43268
  kButtonPopupCommandBar = 43269
End Enum
Members
Members | Description
kRegularCommandBar | Regular CommandBar
kPopUpCommandBar | A Popup CommandBar
kSplitButtonCommandBar | A SplitButton CommandBar
kSplitButtonMRUCommandBar | A SplitButtonMRU CommandBar
kButtonPopupCommandBar | A SplitButtonMRU CommandBar
Notes

Members through which this object may be accessed include:

CommandBar.CommandBarType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.CommandBarTypeEnum Enumeration


Inventor.CommandIDEnum Enumeration

Inventor.CommandIDEnum Enumeration
Summary

This is record Inventor::CommandIDEnum.

Visual Basic
Public Enum CommandIDEnum
  kDefaultCommand = 2048
  kCreateSketchCommand = 2049
  kCreateExtrudeCommand = 2050
  kCreateRevolveCommand = 2051
  kCreateSweepCommand = 2052
  kCreateLoftCommand = 2053
  kPlaceComponentCommand = 2054
  kRebuildPartCommand = 2055
  kFileSaveCopyAsCommand = 2056
  kFileOpenCommand = 2057
  kCreateRibCommand = 2064
  kEditSketchCoordCommand = 2065
  kLineCommand = 2066
  kSplineCommand = 2067
  kCenterPointCircleCommand = 2068
  kTangentCircleCommand = 2069
  kEllipseCommand = 2070
  kThreePointArcCommand = 2071
  kTangentArcCommand = 2072
  kCenterPointArcCommand = 2073
  kAddPointCommand = 2080
  kTwoPointRectangleCommand = 2081
  kThreePointRectangleCommand = 2082
  kSketchFilletCommand = 2083
  kSketchExtendCommand = 2084
  kSketchTrimCommand = 2085
  kSketchOffsetCommand = 2086
  kSketchGeneralDimCommand = 2087
  kConsPerpendicularCommand = 2088
  kConsParallelCommand = 2089
  kConsTangentCommand = 2096
  kConsSymmetricCommand = 2371
  kConsCoincidentCommand = 2097
  kConsConcentricCommand = 2098
  kConsCollinearCommand = 2099
  kConsHorizontalCommand = 2100
  kConsVerticalCommand = 2101
  kConsEqualCommand = 2102
  kConsFixCommand = 2103
  kShowConstraintsCommand = 2104
  kProjectGeometryCommand = 2105
  kProjectCutEdgesCommand = 2112
  kCreateHoleCommand = 2113
  kCreateShellCommand = 2114
  kCreateCoilCommand = 2115
  kCreateFilletCommand = 2116
  kCreateChamferCommand = 2117
  kCreateFaceDraftCommand = 2118
  kCreateSplitCommand = 2119
  kViewCatalogCommand = 2120
  kCreateDesignElementCommand = 2121
  kInsertDesignElementCommand = 2128
  kCreateDerivedPartCommand = 2129
  kCreateRectPatternCommand = 2130
  kCreateCircularPatternCommand = 2131
  kCreateMirrorCommand = 2132
  kCreateWorkPlaneCommand = 2133
  kCreateWorkAxisCommand = 2134
  kCreateWorkPointCommand = 2135
  kMoveFaceCommand = 2136
  kExtendBodyCommand = 2137
  kSheetMetalSettingsCommand = 2144
  kCreateFlatPatternCommand = 2145
  kCreateFaceCommand = 2146
  kCreateCutCommand = 2147
  kCreateFlangeCommand = 2148
  kCreateCornerSeamCommand = 2149
  kCreateBendCommand = 2150
  kCreateCornerRoundCommand = 2151
  kCreateCornerChamferCommand = 2152
  kCreateHemCommand = 2153
  kCreateFoldCommand = 2160
  kCreateContourFlangeCommand = 2161
  kCreateAutoDimCommand = 2162
  kCreateSketchChamferCommand = 2163
  kCreateThreadCommand = 2164
  kEditThreadCommand = 2165
  kFillHatchSketchRegionCommand = 2166
  kCreate3DSketchCommand = 2167
  kCreateComponentCommand = 2168
  kPatternComponentCommand = 2169
  kPlaceConstraintCommand = 2176
  kReplaceComponentCommand = 2177
  kReplaceAllComponentsCommand = 2170
  kCreateInterfaceCommand = 2178
  kMoveComponentCommand = 2179
  kRotateComponentCommand = 2180
  kCreateQuarterSectionViewCommand = 2181
  kCreateHalfSectionViewCommand = 2182
  kCreate3QuarterSectionViewCommand = 2183
  kCreateUnsectionedViewCommand = 2184
  kPopupBrowserFiltersCommand = 2185
  kDesignViewsCommand = 2192
  kCreatePresentationViewCommand = 2193
  kTweakComponentsCommand = 2194
  kPreciseViewRotationCommand = 2195
  kAnimateCommand = 2196
  kCreateDrawingViewCommand = 2197
  kCreateProjectedViewCommand = 2198
  kCreateAuxiliaryViewCommand = 2199
  kCreateSectionViewCommand = 2200
  kCreateDetailViewCommand = 2201
  kCreateDraftViewCommand = 2304
  kCreateNewSheetCommand = 2305
  kCreateGeneralDimensionCommand = 2306
  kCreateOrdinateDimensionCommand = 2307
  kInsertHoleNotesCommand = 2308
  kCreateCenterMarkCommand = 2309
  kCreateCenterLineCommand = 2310
  kRotateViewCommand = 2311
  kEditTweaksCommand = 2312
  kCreateCenterLineBisectorCommand = 2313
  kCreateCenteredPatternCommand = 2320
  kInsertSurfaceTextureCommand = 2321
  kCreateWeldSymbolCommand = 2322
  kInsertFeatureControlFrameCommand = 2323
  kInsertFeatureIdentifierCommand = 2324
  kInsertDatumIdentifierCommand = 2325
  kInsertDatumTargetLeaderCommand = 2326
  kInsertDatumTargetCircleCommand = 2327
  kInsertDatumTargetLineCommand = 2328
  kInsertDatumTargetPointCommand = 2329
  kInsertDatumTargetRectCommand = 2336
  kInsertTextCommand = 2337
  kInsertLeaderTextCommand = 2338
  kInsertBalloonCommand = 2339
  kInsertBalloonAllCommand = 2340
  kInsertPartsListCommand = 2341
  kAddParametersCommand = 2342
  kZoomCommand = 2343
  kZoomAllCommand = 2344
  kZoomWindowCommand = 2345
  kZoomSelectCommand = 2352
  kPanCommand = 2353
  kRotateCommand = 2354
  kLookAtViewCommand = 2355
  kViewWireframeCommand = 2356
  kViewHiddenEdgeCommand = 2357
  kViewShadedCommand = 2358
  kDeselAuthorCommand = 2359
  kCreate3DLineCommand = 2360
  kCreate3DBendCommand = 2361
  kCreateIntersectionCurveCommand = 2372
  kIncludeGeometry3DCommand = 2368
  kCreateSingleOrdinateDimCommand = 2369
  kFormatDimStylesCommand = 2370
  kInsertImportCommand = 2074
  kCreatePunchCommand = 2075
  kCreateBrokenViewCommand = 2076
  kCreateHoleTableFromViewCommand = 2077
  kMeasureCommand = 2058
  kAddPolygonCommand = 2059
  kCreateSketchMirrorCommand = 2060
  kCreateEquationParamCommand = 2061
  kCreateMateConstraintCommand = 2078
  kCreateBaselineDimensionCommand = 2079
  kCreateSelectedHoleTableCommand = 2226
  kCreateHoleTableGroupCommand = 2210
  kModifyStandardSettingsCommand = 2242
  kDeleteFaceCommand = 2090
  kReplaceFaceCommand = 2091
  kCreateKnitSurfaceCommand = 2092
  kThickenCommand = 2093
  kCreateEmbossCommand = 2094
  kCreateTextCommand = 2106
  kCreateGroundedWorkPointCommand = 2095
  kCreateDecalCommand = 2107
  kCreateAreaFillCommand = 2108
  kInsertImageCommand = 2109
  kCreateBreakoutViewCommand = 2122
  kProjectViewEdgesCommand = 2110
  kCreateCaterpillarCommand = 2111
  kCreateEndTreatmentCommand = 2123
  kEditViewCommand = 2124
  kCreateRevisionTableCommand = 2125
  kCreateRevisionTagCommand = 2126
  kRefreshViewCommand = 2138
  kEditFixedWorkPointCommand = 2127
  kPushBackLocalBOMItemNumbersCommand = 2139
  kInsertTableCommand = 2373
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CommandIDEnum Enumeration


Inventor.CommandTypesEnum Enumeration

Inventor.CommandTypesEnum Enumeration Introduced in Inventor 6
Summary

Constants enumerating the various command types.

Visual Basic
Public Enum CommandTypesEnum
  kShapeEditCmdType = 1
  kQueryOnlyCmdType = 2
  kFileOperationsCmdType = 4
  kFilePropertyEditCmdType = 8
  kUpdateWithReferencesCmdType = 16
  kNonShapeEditCmdType = 32
  kReferencesChangeCmdType = 64
  kEditMaskCmdType = 1|8|16|32
  kSchemaChangeCmdType = 128
End Enum
Members
Members | Description
kShapeEditCmdType | Command updates something that can affect design intent, especially shape.
kQueryOnlyCmdType | Command purely views information or global options or opening files.
kFileOperationsCmdType | Command manages files - e.g. saves.
kFilePropertyEditCmdType | Command only updates properties.
kUpdateWithReferencesCmdType | Updates the calculated shape without changing parameters.
kNonShapeEditCmdType | Edits something (e.g. a color, a style etc) that is NOT shape-related.
kReferencesChangeCmdType | Commands that cause this document to change which files it references
kEditMaskCmdType | Commands which dirty the document.
kSchemaChangeCmdType | Commands that change the format of the data, but do not change it otherwise (e.g. from the format of one Inventor release to another)
Notes

Members through which this object may be accessed include:

ChangeDefinitionObject.ChangeType

ChangeProcessorObject.ChangeType

ControlDefinition.Classification

Document.DisabledCommandTypes

Document.RecentChanges

Environment.DisabledCommandTypes

You are here: Symbol Reference > Inventor Library > Enums > Inventor.CommandTypesEnum Enumeration


Inventor.ComparisonTypeEnum Enumeration

Inventor.ComparisonTypeEnum Enumeration
Summary

This is record Inventor::ComparisonTypeEnum.

Visual Basic
Public Enum ComparisonTypeEnum
  kEqualToComparisonType = 60417
  kNotEqualToComparisonType = 60418
  kLessThanComparisonType = 60419
  kGreaterThanComparisonType = 60420
  kLessThanOrEqualToComparisonType = 60421
  kGreaterThanOrEqualToComparisonType = 60422
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ComparisonTypeEnum Enumeration


Inventor.ConstraintIncrementTypeEnum Enumeration

Inventor.ConstraintIncrementTypeEnum Enumeration Available in Inventor Introduced in Inventor 2012
Summary

Enum used to define the increment type for driving constraints.

Visual Basic
Public Enum ConstraintIncrementTypeEnum
  kIncrementAsAmountOfValue = 94465
  kIncrementAsNumberOfSteps = 94466
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ConstraintIncrementTypeEnum Enumeration


Inventor.ConstraintPriorityEnum Enumeration

Inventor.ConstraintPriorityEnum Enumeration Introduced in Inventor 9
Summary

Constants indicating the preferred constraint type for automatic placement of constraints

Visual Basic
Public Enum ConstraintPriorityEnum
  kParallelAndPerpendicularPriority = 50433
  kHorizontalAndVerticalPriority = 50434
  kNonePriority = 50435
End Enum
Members
Members | Description
kParallelAndPerpendicularPriority | Parallel and perpendicular constraint
kHorizontalAndVerticalPriority | Horizontal and vertical constraint
Notes

Members through which this object may be accessed include:

SketchOptions.ConstraintPriority

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ConstraintPriorityEnum Enumeration


Inventor.ConstraintStatusEnum Enumeration

Inventor.ConstraintStatusEnum Enumeration
Summary

This is record Inventor::ConstraintStatusEnum.

Visual Basic
Public Enum ConstraintStatusEnum
  kFullyConstrainedConstraintStatus = 51713
  kUnderConstrainedConstraintStatus = 51714
  kOverConstrainedConstraintStatus = 51715
  kUnknownConstraintStatus = 51716
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ConstraintStatusEnum Enumeration


Inventor.ContainmentEnum Enumeration

Inventor.ContainmentEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying containment of a point.

Visual Basic
Public Enum ContainmentEnum
  kUnknownContainment = 30977
  kInsideContainment = 30978
  kOnContainment = 30979
  kOutsideContainment = 30980
End Enum
Members
Members | Description
kUnknownContainment | Unknown.
kInsideContainment | Inside.
kOnContainment | On.
kOutsideContainment | Outside.
Notes

Members through which this object may be accessed include:

FaceShell.IsPointInside

SurfaceBody.IsPointInside

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContainmentEnum Enumeration


Inventor.ContentCenterAccessOptionEnum Enumeration

Inventor.ContentCenterAccessOptionEnum Enumeration
Summary

This is record Inventor::ContentCenterAccessOptionEnum.

Visual Basic
Public Enum ContentCenterAccessOptionEnum
  kInventorDesktopAccess = 81153
  kVaultOrProductstreamServerAccess = 81154
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentCenterAccessOptionEnum Enumeration


Inventor.ContentCenterInstanceStatusEnum Enumeration

Inventor.ContentCenterInstanceStatusEnum Enumeration
Summary

This is record Inventor::ContentCenterInstanceStatusEnum.

Visual Basic
Public Enum ContentCenterInstanceStatusEnum
  kOlder = 1
  kNewer = 2
  kUpToDate = 4
  kNotFound = 8
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentCenterInstanceStatusEnum Enumeration


Inventor.ContentCenterRSCResultEnum Enumeration

Inventor.ContentCenterRSCResultEnum Enumeration
Summary

This is record Inventor::ContentCenterRSCResultEnum.

Visual Basic
Public Enum ContentCenterRSCResultEnum
  kRSCNoError = 80129
  kRSCUnknownFailed = 80145
  kRSCPartIsTPPipe = 80161
  kRSCNoTPAddInLoadedForTPPart = 80162
  kRSCFamilyHealthRequiresReAuthor = 80177
  kRSCFamilyHealthTableUpdateIncomplete = 80178
  kRSCFamilyHealthMissingCatParamMap = 80179
  kRSCFamilyHealthOutOfDateWithTable = 80180
  kRSCFamilyHealthOutOfDateWithCategory = 80181
  kRSCFamilyHealthOutOfDateWithTableAndCategory = 80182
  kRSCFamilyHealthOutOfDateWithAuthorTableAndCategory = 80183
  kRSCInstancingUnknownError = 80193
  kRSCInstancingMissingFileWritePermission = 80194
  kRSCInstancingDifferentFamily = 80195
  kRSCInstancingDifferentMember = 80196
  kRSCInstancingMaterialNotFound = 80197
  kRSCInstancingLongFilename = 80198
  kRSCInstancingFeatureSuppressFail = 80199
  kRSCInstancingThreadFeatureNotFound = 80200
  kRSCInstancingThreadCreateFail = 80201
  kRSCInstancingInvalidMemberValue = 80202
  kRSCReplaceFailed = 80209
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentCenterRSCResultEnum Enumeration


Inventor.ContentFamilyTypeEnum Enumeration

Inventor.ContentFamilyTypeEnum Enumeration
Summary

This is record Inventor::ContentFamilyTypeEnum.

Visual Basic
Public Enum ContentFamilyTypeEnum
  kContentPartFamily = 1
  kContentFeatureFamily = 2
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentFamilyTypeEnum Enumeration


Inventor.ContentItemTypeEnum Enumeration

Inventor.ContentItemTypeEnum Enumeration
Summary

This is record Inventor::ContentItemTypeEnum.

Visual Basic
Public Enum ContentItemTypeEnum
  kContentCategoryType = 57089
  kContentFamilyType = 57090
  kContentMemberType = 57091
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentItemTypeEnum Enumeration


Inventor.ContentLibraryComponentTypeBits Enumeration

Inventor.ContentLibraryComponentTypeBits Enumeration Available in Inventor Available in Server Introduced in Inventor 6
Summary

Bits indicating the relationship of the model to data directly stored in the library.

Visual Basic
Public Enum ContentLibraryComponentTypeBits
  kCustomContent = 2
  kStandardContent = 1
End Enum
Members
Members | Description
kCustomContent | One or more of this model's parameters are custom-provided by the end user.
kStandardContent | All of this model's parameters are driven directly off the library's database.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentLibraryComponentTypeBits Enumeration


Inventor.ContentMemberRefreshEnum Enumeration

Inventor.ContentMemberRefreshEnum Enumeration
Summary

This is record Inventor::ContentMemberRefreshEnum.

Visual Basic
Public Enum ContentMemberRefreshEnum
  kUseDefaultRefreshSetting = 1
  kRefreshOutOfDateParts = 2
  kDoNotRefreshOutOfDateParts = 3
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentMemberRefreshEnum Enumeration


Inventor.ContentUserRoleEnum Enumeration

Inventor.ContentUserRoleEnum Enumeration
Summary

This is record Inventor::ContentUserRoleEnum.

Visual Basic
Public Enum ContentUserRoleEnum
  kContentConsumer = 0
  kContentEditor = 1
  kContentPublisher = 2
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContentUserRoleEnum Enumeration


Inventor.ContinuityTypeEnum Enumeration

Inventor.ContinuityTypeEnum Enumeration
Summary

This is record Inventor::ContinuityTypeEnum.

Visual Basic
Public Enum ContinuityTypeEnum
  kTangentContinuity = 61953
  kCurvatureContinuity = 61954
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ContinuityTypeEnum Enumeration


Inventor.ControlDefinitionTypeEnum Enumeration

Inventor.ControlDefinitionTypeEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the type of controldefinition

Visual Basic
Public Enum ControlDefinitionTypeEnum
  kButtonDefinition = 42753
  kComboBoxDefinition = 42754
  kMacroControlDefinition = 42755
End Enum
Members
Members | Description
kButtonDefinition | A Button ControlDefinition
kComboBoxDefinition | A Button ControlDefinition
kMacroControlDefinition | A Macro ControlDefinition
Notes

Members through which this object may be accessed include:

ControlDefinition.DefinitionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ControlDefinitionTypeEnum Enumeration


Inventor.ControlTypeEnum Enumeration

Inventor.ControlTypeEnum Enumeration Introduced in Inventor 9
Summary

ControlType

Visual Basic
Public Enum ControlTypeEnum
  kButtonPopupControl = 45058
  kPopupControl = 45057
  kSplitButtonMRUControl = 45059
  kSplitButtonControl = 45060
  kButtonControl = 45061
  kComboBoxControl = 45062
  kMacroControl = 45063
  kUnknownControl = 45064
  kSeparatorControl = 45065
  kGalleryControl = 45066
  kTogglePopupControl = 45067
End Enum
Members
Members | Description
kButtonPopupControl | MRUPopUp Control
kPopupControl | PopUp Control
kSplitButtonMRUControl | SplitButton MRU Control
kSplitButtonControl | SplitButton Control
kButtonControl | Button Control
kComboBoxControl | ComboBox Control
kMacroControl | Macro Control
kUnknownControl | Unknown or Orphaned control
Notes

Members through which this object may be accessed include:

CommandBarControl.ControlType

CommandControl.ControlType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ControlTypeEnum Enumeration


Inventor.CoordinateSystemPlaneEnum Enumeration

Inventor.CoordinateSystemPlaneEnum Enumeration
Summary

This is record Inventor::CoordinateSystemPlaneEnum.

Visual Basic
Public Enum CoordinateSystemPlaneEnum
  kXYPlane = 87297
  kXZPlane = 87298
  kYZPlane = 87299
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CoordinateSystemPlaneEnum Enumeration


Inventor.CornerDefinitionTypeEnum Enumeration

Inventor.CornerDefinitionTypeEnum Enumeration
Summary

This is record Inventor::CornerDefinitionTypeEnum.

Visual Basic
Public Enum CornerDefinitionTypeEnum
  kCornerMaxDistance = 79105
  kCornerFaceEdgeDistance = 79106
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CornerDefinitionTypeEnum Enumeration


Inventor.CornerReliefShapeEnum Enumeration

Inventor.CornerReliefShapeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the corner relief shape.

Visual Basic
Public Enum CornerReliefShapeEnum
  kRoundCornerReliefShape = 28417
  kSquareCornerReliefShape = 28418
  kTearCornerReliefShape = 28419
  kTrimToBendReliefShape = 28420
  kLinearWeldReliefShape = 28421
  kDefaultCornerReliefShape = 28422
  kArcWeldCornerReliefShape = 28425
  kNoReplacementCornerReliefShape = 28426
  kIntersectionCornerReliefShape = 28427
  kFullRoundCornerReliefShape = 28428
  kRoundWithRadiusCornerReliefShape = 28429
End Enum
Members
Members | Description
kRoundCornerReliefShape | Constants identifying round corner relief shape.
kSquareCornerReliefShape | Constants identifying square corner relief shape.
kTearCornerReliefShape | Constants identifying tear corner relief shape.
kTrimToBendReliefShape | Constants identifying trim to bend relief shape.
Notes

Members through which this object may be accessed include:

CornerOptions.CornerReliefShape

SheetMetalStyle.CornerReliefShape

SheetMetalStyle.ThreeBendCornerReliefShape

You are here: Symbol Reference > Inventor Library > Enums > Inventor.CornerReliefShapeEnum Enumeration


Inventor.CornerTypeEnum Enumeration

Inventor.CornerTypeEnum Enumeration
Summary

This is record Inventor::CornerTypeEnum.

Visual Basic
Public Enum CornerTypeEnum
  kCornerOverlap = 76033
  kCornerNoOverlap = 76034
  kCornerReverseOverlap = 76035
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CornerTypeEnum Enumeration


Inventor.CursorHotSpotEnum Enumeration

Inventor.CursorHotSpotEnum Enumeration Introduced in Inventor 9
Summary

Interaction event Cursor hot spot enum

Visual Basic
Public Enum CursorHotSpotEnum
  kCursorHotSpotDefault = 47882
  kCursorHotSpotTopLeft = 47873
  kCursorHotSpotTopCenter = 47874
  kCursorHotSpotTopRight = 47875
  kCursorHotSpotMiddleLeft = 47876
  kCursorHotSpotMiddleCenter = 47877
  kCursorHotSpotMiddleRight = 47878
  kCursorHotSpotBottomLeft = 47879
  kCursorHotSpotBottomCenter = 47880
  kCursorHotSpotBottomRight = 47881
End Enum
Members
Members | Description
kCursorHotSpotDefault | Default location of the hot spot
kCursorHotSpotTopLeft | Top Left location of cursor as the hot spot
kCursorHotSpotTopCenter | Top center location of cursor as the hot spot
kCursorHotSpotTopRight | Top right location of cursor as the hot spot
kCursorHotSpotMiddleLeft | Middle Left location of cursor as the hot spot
kCursorHotSpotMiddleCenter | Middle center location of cursor as the hot spot
kCursorHotSpotMiddleRight | Middle right location of cursor as the hot spot
kCursorHotSpotBottomLeft | Bottom Left location of cursor as the hot spot
kCursorHotSpotBottomCenter | Bottom center location of cursor as the hot spot
kCursorHotSpotBottomRight | Bottom right location of cursor as the hot spot
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CursorHotSpotEnum Enumeration


Inventor.CursorTypeEnum Enumeration

Inventor.CursorTypeEnum Enumeration Introduced in Inventor 9
Summary

Interaction event Cursor Type enum

Visual Basic
Public Enum CursorTypeEnum
  kCursorTypeDefault = 47617
  kCursorTypeWindows = 47618
  kCursorTypeCustom = 47619
  kCursorBuiltInArrow = 47621
  kCursorBuiltInArrowCursor = 47622
  kCursorBuiltInCrosshair = 47623
  kCursorBuiltInCursorSelComp = 47624
  kCursorBuiltInCursorSelTrail = 47625
  kCursorBuiltInDynpan = 47626
  kCursorBuiltInDynzoom = 47627
  kCursorBuiltInLineCursor = 47628
  kCursorBuiltInLookat = 47629
  kCursorBuiltInMeasureCmd = 47630
  kCursorBuiltInPushpinCursor = 47631
  kCursorBuiltInSketch3DEditCursor = 47632
  kCursorBuiltInSelectArrow = 47633
  kCursorBuiltInSelectView = 47634
  kCursorBuiltInSketch = 47635
  kCursorBuiltInCommonSketchDrag = 47636
  kCursorBuiltInZoom = 47637
  kCursorBuiltInZoomSel = 47638
End Enum
Members
Members | Description
kCursorTypeDefault | Default cursor
kCursorTypeWindows | Windows's predefined cursor. For example, specify a constant from winuser.h (IDC_ARROW, etc.) or the VB constants (vbDefault, vbArrow, etc.).
kCursorTypeCustom | Custom cursor
kCursorBuiltInArrow | Inventor built-in cursor for Arrow
kCursorBuiltInArrowCursor | Inventor built-in cursor for Arrow Cursor
kCursorBuiltInCrosshair | Inventor built-in cursor for Crosshair
kCursorBuiltInCursorSelComp | Inventor built-in cursor for selecting a component
kCursorBuiltInCursorSelTrail | Inventor built-in cursor for a Trail
kCursorBuiltInDynpan | Inventor built-in cursor for Dynamic pan
kCursorBuiltInDynzoom | Inventor built-in cursor for Dynamic zoom
kCursorBuiltInLineCursor | Inventor built-in cursor for Sketch Line
kCursorBuiltInLookat | Inventor built-in cursor for Look at
kCursorBuiltInMeasureCmd | Inventor built-in cursor for Measure
kCursorBuiltInPushpinCursor | Inventor built-in cursor for Pushpin
kCursorBuiltInSketch3DEditCursor | Inventor built-in cursor for Sketch3D Edit
kCursorBuiltInSelectArrow | Inventor built-in cursor for Select Arrow
kCursorBuiltInSelectView | Inventor built-in cursor for Select View
kCursorBuiltInSketch | Inventor built-in cursor for Sketch
kCursorBuiltInCommonSketchDrag | Inventor built-in cursor for Common Sketch Drag
kCursorBuiltInZoom | Inventor built-in cursor for Zoom
kCursorBuiltInZoomSel | Inventor built-in cursor for Zoom Selection
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CursorTypeEnum Enumeration


Inventor.Curve2dTypeEnum Enumeration

Inventor.Curve2dTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating the types of 2D curves.

Visual Basic
Public Enum Curve2dTypeEnum
  kUnknownCurve2d = 5249
  kLineCurve2d = 5250
  kLineSegmentCurve2d = 5251
  kCircleCurve2d = 5252
  kCircularArcCurve2d = 5253
  kEllipseFullCurve2d = 5254
  kEllipticalArcCurve2d = 5255
  kBSplineCurve2d = 5256
End Enum
Members
Members | Description
kUnknownCurve2d | Unknown 2D curve type.
kLineCurve2d | Line curve 2D.
kLineSegmentCurve2d | Line segment curve 2D.
kCircleCurve2d | Circle curve 2D.
kCircularArcCurve2d | Circular arc 2D.
kEllipseFullCurve2d | Ellipse full curve 2D.
kEllipticalArcCurve2d | Elliptical arc curve 2D.
kBSplineCurve2d | B-spline curve 2D.
Notes

Members through which this object may be accessed include:

DrawingCurve.ProjectedCurveType

EdgeUse.CurveType

ProfileEntity.CurveType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.Curve2dTypeEnum Enumeration


Inventor.CurveGeometryFormEnum Enumeration

Inventor.CurveGeometryFormEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating the form of the curve geometry.

Visual Basic
Public Enum CurveGeometryFormEnum
  CurveGeometryForm_NURBS = 1
  CurveGeometryForm_Not_NURBS = 2
End Enum
Members
Members | Description
CurveGeometryForm_NURBS | Curve geometry is NURBS.
CurveGeometryForm_Not_NURBS | Curve geometry is not NURBS.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CurveGeometryFormEnum Enumeration


Inventor.CurveTypeEnum Enumeration

Inventor.CurveTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating the curve types.

Visual Basic
Public Enum CurveTypeEnum
  kUnknownCurve = 5121
  kLineCurve = 5122
  kLineSegmentCurve = 5123
  kCircleCurve = 5124
  kCircularArcCurve = 5125
  kEllipseFullCurve = 5126
  kEllipticalArcCurve = 5127
  kBSplineCurve = 5128
  kPolylineCurve = 5129
End Enum
Members
Members | Description
kUnknownCurve | Unknown curve type.
kLineCurve | Line curve.
kLineSegmentCurve | Line segment curve.
kCircleCurve | Circular curve.
kCircularArcCurve | Circular arc curve.
kEllipseFullCurve | Ellipse full curve.
kEllipticalArcCurve | Elliptical arc curve.
kBSplineCurve | B-spline curve.
Notes

Members through which this object may be accessed include:

Centerline.GeometryType

CurveGraphics.CurveType

DrawingCurve.CurveType

Edge.GeometryType

Edge.CurveType

PathEntity.CurveType

ProfileEntity3D.CurveType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.CurveTypeEnum Enumeration


Inventor.CustomPropertyPrecisionEnum Enumeration

Inventor.CustomPropertyPrecisionEnum Enumeration
Summary

This is record Inventor::CustomPropertyPrecisionEnum.

Visual Basic
Public Enum CustomPropertyPrecisionEnum
  kZeroDecimalPlacePrecision = 85505
  kOneDecimalPlacePrecision = 85506
  kTwoDecimalPlacesPrecision = 85507
  kThreeDecimalPlacesPrecision = 85508
  kFourDecimalPlacesPrecision = 85509
  kFiveDecimalPlacesPrecision = 85510
  kSixDecimalPlacesPrecision = 85511
  kSevenDecimalPlacesPrecision = 85512
  kEightDecimalPlacesPrecision = 85513
  kZeroFractionalLengthPrecision = 85514
  kHalfFractionalLengthPrecision = 85515
  kQuarterFractionalLengthPrecision = 85516
  kEighthsFractionalLengthPrecision = 85517
  kSixteenthsFractionalLengthPrecision = 85518
  kThirtySecondsFractionalLengthPrecision = 85519
  kSixtyFourthsFractionalLengthPrecision = 85520
  kOneTwentyEighthsFractionalLengthPrecision = 85521
  kDegreesAnglePrecision = 85522
  kMinutesAnglePrecision = 85523
  kSecondsAnglePrecision = 85524
  kSecondsOneDecimalPlaceAnglePrecision = 85525
  kSecondsTwoDecimalPlaceAnglePrecision = 85526
  kSecondsThreeDecimalPlaceAnglePrecision = 85527
  kSecondsFourDecimalPlaceAnglePrecision = 85528
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CustomPropertyPrecisionEnum Enumeration


Inventor.CustomPropertyTypeEnum Enumeration

Inventor.CustomPropertyTypeEnum Enumeration
Summary

This is record Inventor::CustomPropertyTypeEnum.

Visual Basic
Public Enum CustomPropertyTypeEnum
  kTextPropertyType = 85249
  kNumberPropertyType = 85250
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.CustomPropertyTypeEnum Enumeration


Inventor.DebugWatchType Enumeration

Inventor.DebugWatchType Enumeration
Summary

This is record Inventor::DebugWatchType.

Visual Basic
Public Enum DebugWatchType
  kNoneWatchType = 0
  kAddRefWatchType = 1
  kReleaseWatchType = 2
  kQueryInterfaceWatchType = 4
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DebugWatchType Enumeration


Inventor.DecimalMarkerTypeEnum Enumeration

Inventor.DecimalMarkerTypeEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the Decimal Marker type

Visual Basic
Public Enum DecimalMarkerTypeEnum
  kPeriodDecimalMarker = 41473
  kCommaDecimalMarker = 41474
End Enum
Members
Members | Description
kPeriodDecimalMarker | Period as the Decimal Marker
kCommaDecimalMarker | Comma as the Decimal Marker
Notes

Members through which this object may be accessed include:

DimensionStyle.AlternateDecimalMarkerType

DimensionStyle.DecimalMarkerType

DrawingStandardStyle.DecimalMarkerType

FeatureControlFrameStyle.AlternateDecimalMarkerType

FeatureControlFrameStyle.DecimalMarkerType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DecimalMarkerTypeEnum Enumeration


Inventor.DefaultDrawingFileTypeEnum Enumeration

Inventor.DefaultDrawingFileTypeEnum Enumeration
Summary

This is record Inventor::DefaultDrawingFileTypeEnum.

Visual Basic
Public Enum DefaultDrawingFileTypeEnum
  kDWGDefaultDrawingFileType = 69633
  kIDWDefaultDrawingFileType = 69634
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DefaultDrawingFileTypeEnum Enumeration


Inventor.DefaultLayerStyleEnum Enumeration

Inventor.DefaultLayerStyleEnum Enumeration
Summary

This is record Inventor::DefaultLayerStyleEnum.

Visual Basic
Public Enum DefaultLayerStyleEnum
  kStandardDefaultLayerStyle = 69889
  kLastUsedDefaultLayerStyle = 69890
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DefaultLayerStyleEnum Enumeration


Inventor.DefaultNonInventorDWGFileOpenBehaviorEnum Enumeration

Inventor.DefaultNonInventorDWGFileOpenBehaviorEnum Enumeration
Summary

This is record Inventor::DefaultNonInventorDWGFileOpenBehaviorEnum.

Visual Basic
Public Enum DefaultNonInventorDWGFileOpenBehaviorEnum
  kRegularOpenNonInventorDWGFile = 70145
  kImportNonInventorDWGFile = 70146
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DefaultNonInventorDWGFileOpenBehaviorEnum Enumeration


Inventor.DefaultObjectStyleEnum Enumeration

Inventor.DefaultObjectStyleEnum Enumeration
Summary

This is record Inventor::DefaultObjectStyleEnum.

Visual Basic
Public Enum DefaultObjectStyleEnum
  kStandardDefaultObjectStyle = 70401
  kLastUsedDefaultObjectStyle = 70402
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DefaultObjectStyleEnum Enumeration


Inventor.DerivedComponentOptionEnum Enumeration

Inventor.DerivedComponentOptionEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying inclusion for derived components.

Visual Basic
Public Enum DerivedComponentOptionEnum
  kDerivedIncludeAll = 27137
  kDerivedExcludeAll = 27138
  kDerivedSubtractAll = 27139
  kDerivedIndividualDefined = 27140
  kDerivedBoundingBox = 27141
  kDerivedIntersect = 27142
End Enum
Members
Members | Description
kDerivedIncludeAll | Include all in derived version.
kDerivedExcludeAll | Exclude all in derived version.
kDerivedSubtractAll | Subtract all in derived version.
kDerivedIndividualDefined | Include defined individual in derived version.
Notes

Members through which this object may be accessed include:

DerivedAssemblyDefinition.IncludeAllTopLeveliMateDefinitions

DerivedAssemblyDefinition.IncludeAllTopLevelParameters

DerivedAssemblyDefinition.IncludeAllTopLevelSketches

DerivedAssemblyDefinition.IncludeAllTopLevelWorkFeatures

DerivedAssemblyDefinition.InclusionOption

DerivedAssemblyOccurrence.InclusionOption

DerivedPartDefinition.IncludeAlliMateDefinitions

DerivedPartDefinition.IncludeAllSolids

DerivedPartDefinition.IncludeAllSurfaces

DerivedPartUniformScaleDef.IncludeAllSketchBlockDefinitions

DerivedPartUniformScaleDef.IncludeAllSketches

DerivedPartUniformScaleDef.IncludeAllSketches3D

DerivedPartUniformScaleDef.IncludeAllWorkFeatures

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DerivedComponentOptionEnum Enumeration


Inventor.DerivedComponentStyleEnum Enumeration

Inventor.DerivedComponentStyleEnum Enumeration
Summary

This is record Inventor::DerivedComponentStyleEnum.

Visual Basic
Public Enum DerivedComponentStyleEnum
  kDeriveAsSingleBodyWithSeams = 80641
  kDeriveAsSingleBodyNoSeams = 80642
  kDeriveAsMultipleBodies = 80643
  kDeriveAsWorkSurface = 80644
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DerivedComponentStyleEnum Enumeration


Inventor.DerivedGeometryRemovalEnum Enumeration

Inventor.DerivedGeometryRemovalEnum Enumeration
Summary

This is record Inventor::DerivedGeometryRemovalEnum.

Visual Basic
Public Enum DerivedGeometryRemovalEnum
  kDerivedRemoveNone = 88577
  kDerivedRemovePartsOnly = 88578
  kDerivedRemovePartsAndFaces = 88579
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DerivedGeometryRemovalEnum Enumeration


Inventor.DerivedHolePatchEnum Enumeration

Inventor.DerivedHolePatchEnum Enumeration
Summary

This is record Inventor::DerivedHolePatchEnum.

Visual Basic
Public Enum DerivedHolePatchEnum
  kDerivedPatchNone = 88321
  kDerivedPatchAll = 88322
  kDerivedPatchRange = 88323
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DerivedHolePatchEnum Enumeration


Inventor.DerivedPartMirrorPlaneEnum Enumeration

Inventor.DerivedPartMirrorPlaneEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying mirror plane.

Visual Basic
Public Enum DerivedPartMirrorPlaneEnum
  kDerivedPartMirrorPlaneXY = 27393
  kDerivedPartMirrorPlaneYZ = 27394
  kDerivedPartMirrorPlaneXZ = 27395
  kDerivedPartNoMirrorPlane = 27396
End Enum
Members
Members | Description
kDerivedPartMirrorPlaneXY | Mirror derived part using XY plane.
kDerivedPartMirrorPlaneYZ | Mirror derived part using YZ plane.
kDerivedPartMirrorPlaneXZ | Mirror derived part using XZ plane.
kDerivedPartNoMirrorPlane | Option indicating that no mirror plane has been specified
Notes

Members through which this object may be accessed include:

DerivedAssemblyDefinition.MirrorPlane

DerivedPartCoordinateSystemDef.MirrorPlane

DerivedPartUniformScaleDef.MirrorPlane

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DerivedPartMirrorPlaneEnum Enumeration


Inventor.DerivedPropertyTypeEnum Enumeration

Inventor.DerivedPropertyTypeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the type of derived property specified in formatted text objects.

Visual Basic
Public Enum DerivedPropertyTypeEnum
  kDerivedModelFilename = 29697
  kDerivedModelFilenameAndPath = 29698
  kDerivedModelVersion = 29699
  kDerivedDrawingFilename = 29700
  kDerivedDrawingFilenameAndPath = 29701
  kDerivedDrawingVersion = 29702
  kDerivedNumberOfSheets = 29703
  kDerivedSheetNumber = 29704
  kDerivedSheetSize = 29705
  kDerivedSheetRevision = 29706
End Enum
Members
Members | Description
kDerivedModelFilename | Filename of the model.
kDerivedModelFilenameAndPath | Full path of the model.
kDerivedModelVersion | Internal version number of the model.
kDerivedDrawingFilename | Filename of the drawing.
kDerivedDrawingFilenameAndPath | Full path of the drawing.
kDerivedDrawingVersion | Internal version number of the drawing.
kDerivedNumberOfSheets | The number of sheets in the drawing.
kDerivedSheetNumber | The number of this sheet.
kDerivedSheetSize | The size of this sheet.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DerivedPropertyTypeEnum Enumeration


Inventor.DesignViewTypeEnum Enumeration

Inventor.DesignViewTypeEnum Enumeration
Summary

This is record Inventor::DesignViewTypeEnum.

Visual Basic
Public Enum DesignViewTypeEnum
  kMasterDesignViewType = 57345
  kPublicDesignViewType = 57347
  kTransientDesignViewType = 57348
  kAllVisibleDesignViewType = 57349
  kNothingVisibleDesignViewType = 57350
  kLastActiveDesignViewType = 57351
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DesignViewTypeEnum Enumeration


Inventor.DialogStyleEnum Enumeration

Inventor.DialogStyleEnum Enumeration
Summary

This is record Inventor::DialogStyleEnum.

Visual Basic
Public Enum DialogStyleEnum
  kFullyDockedDialogStyle = 56833
  kNoTitleBarDialogStyle = 56834
  kNoButtonsDialogStyle = 56835
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DialogStyleEnum Enumeration


Inventor.DimensionAlignmentTypeEnum Enumeration

Inventor.DimensionAlignmentTypeEnum Enumeration Introduced in Inventor 9
Summary

Constants indicating the various types of dimension alignment

Visual Basic
Public Enum DimensionAlignmentTypeEnum
  kDefaultAlignmentType = 50177
  kAlignedAlignmentType = 50178
  kHorizontalAlignmentType = 50179
  kVerticalAlignmentType = 50180
End Enum
Members
Members | Description
kDefaultAlignmentType | All alignments valid
kAlignedAlignmentType | Aligned alignment
kHorizontalAlignmentType | Horizontal alignment
kVerticalAlignmentType | Vertical alignment
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionAlignmentTypeEnum Enumeration


Inventor.DimensionConstraintsRelaxationEnum Enumeration

Inventor.DimensionConstraintsRelaxationEnum Enumeration
Summary

This is record Inventor::DimensionConstraintsRelaxationEnum.

Visual Basic
Public Enum DimensionConstraintsRelaxationEnum
  kNeverRelaxDimensionConstraints = 58113
  kNoEquationRelaxDimensionConstraints = 58114
  kAlwaysRelaxDimensionConstraints = 58115
  kPromptRelaxDimensionConstraints = 58116
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionConstraintsRelaxationEnum Enumeration


Inventor.DimensionDisplayTypeEnum Enumeration

Inventor.DimensionDisplayTypeEnum Enumeration Introduced in Inventor 6
Summary

Constants enumerating the dimension display styles.

Visual Basic
Public Enum DimensionDisplayTypeEnum
  kDimensionDisplayAsValue = 34817
  kDimensionDisplayAsName = 34818
  kDimensionDisplayAsExpression = 34819
  kDimensionDisplayAsTolerance = 34820
  kDimensionDisplayAsPreciseValue = 34821
End Enum
Members
Members | Description
kDimensionDisplayAsValue | Display value for all dimensions associated with a parameter.
kDimensionDisplayAsName | Display name of the parameter to for all dimensions associated with a parameter.
kDimensionDisplayAsPreciseValue | Display precise value for the dimension associated with a parameter.
Notes

Members through which this object may be accessed include:

Parameters.DimensionDisplayType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionDisplayTypeEnum Enumeration


Inventor.DimensionOrientationEnum Enumeration

Inventor.DimensionOrientationEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying dimension orientation types.

Visual Basic
Public Enum DimensionOrientationEnum
  kHorizontalDim = 19201
  kVerticalDim = 19202
  kAlignedDim = 19203
End Enum
Members
Members | Description
kHorizontalDim | Horizontal dimension orientation type.
kVerticalDim | Vertical dimension orientation type.
kAlignedDim | Aligned dimension orientation type.
Notes

Members through which this object may be accessed include:

TwoPointDistanceDimConstraint.Orientation

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionOrientationEnum Enumeration


Inventor.DimensionStyleFormatEnum Enumeration

Inventor.DimensionStyleFormatEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the dimension style format

Visual Basic
Public Enum DimensionStyleFormatEnum
  kAdjacentFormat = 41985
  kAdjacentWithBracketsForPrimaryFormat = 41986
  kAdjacentWithBracketsForAlternateFormat = 41987
  kBelowFormat = 41988
  kBelowWithBracketsForPrimaryFormat = 41989
  kBelowWithBracketsForAlternateFormat = 41990
  kNoAlternateUnits = 41991
End Enum
Members
Members | Description
kAdjacentFormat | Adjancent Dimension style format
kAdjacentWithBracketsForPrimaryFormat | Adjacent with brackets for Primary dimension style format
kAdjacentWithBracketsForAlternateFormat | Adjacent with brackets for Alternate dimension style format
kBelowFormat | Below dimension style format
kBelowWithBracketsForPrimaryFormat | Below with brackets for Primary dimension style format
kBelowWithBracketsForAlternateFormat | Below with brackets for Alternate dimension style format
Notes

Members through which this object may be accessed include:

DimensionStyle.AlternateStyleFormat

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionStyleFormatEnum Enumeration


Inventor.DimensionTextAlignmentEnum Enumeration

Inventor.DimensionTextAlignmentEnum Enumeration
Summary

This is record Inventor::DimensionTextAlignmentEnum.

Visual Basic
Public Enum DimensionTextAlignmentEnum
  kMaintainViewPositionAlignment = 55553
  kMaintainCenteredTextAlignment = 55554
  kMaintainAllTextAlignment = 55555
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionTextAlignmentEnum Enumeration


Inventor.DimensionTypeEnum Enumeration

Inventor.DimensionTypeEnum Enumeration
Summary

This is record Inventor::DimensionTypeEnum.

Visual Basic
Public Enum DimensionTypeEnum
  kAlignedDimensionType = 60161
  kHorizontalDimensionType = 60162
  kVerticalDimensionType = 60163
  kArcLengthDimensionType = 60164
  kSymmetricDimensionType = 60165
  kDiametricDimensionType = 60166
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DimensionTypeEnum Enumeration


Inventor.DirectionEnum Enumeration

Inventor.DirectionEnum Enumeration Introduced in Inventor 4
Summary

Constants identifying feature direction orientations.

Visual Basic
Public Enum DirectionEnum
  kOutwardDirection = 769
  kInwardDirection = 770
  kBothDirections = 771
End Enum
Members
Members | Description
kOutwardDirection | Outward (positive normal) direction.
kInwardDirection | Inward (negative normal) direction.
kBothDirections | Both directions.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DirectionEnum Enumeration


Inventor.DisplayFormatEnum Enumeration

Inventor.DisplayFormatEnum Enumeration
Summary

This is record Inventor::DisplayFormatEnum.

Visual Basic
Public Enum DisplayFormatEnum
  kFractionalNotStackedFormat = 78337
  kFractionalHorizontalStackedFormat = 78338
  kFractionalDiagonalStackedFormat = 78339
  kDecimalFormat = 78340
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DisplayFormatEnum Enumeration


Inventor.DisplayModeEnum Enumeration

Inventor.DisplayModeEnum Enumeration
Summary

This is record Inventor::DisplayModeEnum.

Visual Basic
Public Enum DisplayModeEnum
  kWireframeRendering = 8706
  kShadedWithHiddenEdgesRendering = 8707
  kShadedRendering = 8708
  kRealisticRendering = 8709
  kShadedWithEdgesRendering = 8710
  kWireframeNoHiddenEdges = 8711
  kWireframeWithHiddenEdgesRendering = 8712
  kMonochromeRendering = 8713
  kWatercolorRendering = 8714
  kIllustrationRendering = 8715
End Enum
Members
Members | Description
kWireframeRendering | Model displayed in its wireframe representation.
kShadedRendering | Model displayed in its shaded representation.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DisplayModeEnum Enumeration


Inventor.DisplayModeSourceTypeEnum Enumeration

Inventor.DisplayModeSourceTypeEnum Enumeration
Summary

This is record Inventor::DisplayModeSourceTypeEnum.

Visual Basic
Public Enum DisplayModeSourceTypeEnum
  kDefaultDisplayMode = 54273
  kOverrideDisplayMode = 54274
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DisplayModeSourceTypeEnum Enumeration


Inventor.DisplayQualityEnum Enumeration

Inventor.DisplayQualityEnum Enumeration
Summary

This is record Inventor::DisplayQualityEnum.

Visual Basic
Public Enum DisplayQualityEnum
  kSmoothDisplayQuality = 58881
  kMediumDisplayQuality = 58882
  kRoughDisplayQuality = 58883
  kSmootherDisplayQuality = 58884
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DisplayQualityEnum Enumeration


Inventor.DisplayTransformBehaviorEnum Enumeration

Inventor.DisplayTransformBehaviorEnum Enumeration Introduced in Inventor 5
Summary

Optional display options for Client Graphics primitives.

Visual Basic
Public Enum DisplayTransformBehaviorEnum
  kFrontFacing = 26113
  kPixelScaling = 26114
  kFrontFacingAndPixelScaling = 26115
  kNoTransformBehaviors = 26116
End Enum
Members
Members | Description
kFrontFacing | Keep primitive aligned with the camera.
kPixelScaling | Keep primitive constant size on the screen.
kFrontFacingAndPixelScaling | Keep primitive camera aligned and constant size.
kNoTransformBehaviors | Remove display options from primitive.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DisplayTransformBehaviorEnum Enumeration


Inventor.DockingStateEnum Enumeration

Inventor.DockingStateEnum Enumeration Introduced in Inventor 2011
Visual Basic
Public Enum DockingStateEnum
  kDockBottom = 1
  kDockLeft = 2
  kDockRight = 4
  kDockTop = 8
  kFloat = 16
  kDockLastKnown = 32
End Enum
Notes

Members through which this object may be accessed include:

DockableWindow.DisabledDockingStates

DockableWindow.DockingState

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DockingStateEnum Enumeration


Inventor.DocumentInterestTypeEnum Enumeration

Inventor.DocumentInterestTypeEnum Enumeration
Summary

This is record Inventor::DocumentInterestTypeEnum.

Visual Basic
Public Enum DocumentInterestTypeEnum
  kNotInterested = 68865
  kInterested = 68866
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DocumentInterestTypeEnum Enumeration


Inventor.DocumentTypeEnum Enumeration

Inventor.DocumentTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating document types.

Visual Basic
Public Enum DocumentTypeEnum
  kUnknownDocumentObject = 12289
  kPartDocumentObject = 12290
  kAssemblyDocumentObject = 12291
  kDrawingDocumentObject = 12292
  kPresentationDocumentObject = 12293
  kDesignElementDocumentObject = 12294
  kForeignModelDocumentObject = 12295
  kSATFileDocumentObject = 12296
  kNoDocument = 12297
End Enum
Members
Members | Description
kUnknownDocumentObject | Unknown document format.
kPartDocumentObject | Part document.
kAssemblyDocumentObject | Assembly document.
kDrawingDocumentObject | Drawing document.
kPresentationDocumentObject | Presentation document.
kDesignElementDocumentObject | Design element document.
kForeignModelDocumentObject | Foreign model document.
kSATFileDocumentObject | SAT file document.
Notes

Members through which this object may be accessed include:

Application.ActiveDocumentType

ApprenticeServerDocument.DocumentType

ComponentOccurrence.DefinitionDocumentType

Document.DocumentType

DocumentDescriptor.ReferencedDocumentType

IRxFileAndReferencesOld.DocumentType

IRxReferencedFileDescriptor.DocumentType

ReferencedFileDescriptor.DocumentType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DocumentTypeEnum Enumeration


Inventor.DoubleBendTypeEnum Enumeration

Inventor.DoubleBendTypeEnum Enumeration
Summary

This is record Inventor::DoubleBendTypeEnum.

Visual Basic
Public Enum DoubleBendTypeEnum
  kDoubleBendFixedEdges = 74753
  kDoubleBend45Degree = 74754
  kDoubleBend90Degree = 74755
  kDoubleBendFullRadius = 74756
  kDoubleBendSingle = 74757
  kDoubleBendNoBend = 74758
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DoubleBendTypeEnum Enumeration


Inventor.DraftingStandardEnum Enumeration

Inventor.DraftingStandardEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate the drafting standards currently known to Autodesk Inventor.

Visual Basic
Public Enum DraftingStandardEnum
  kDefault_DraftingStandard = 9729
  kOther_DraftingStandard = 9730
  kANSI_DraftingStandard = 9731
  kBSI_DraftingStandard = 9732
  kDIN_DraftingStandard = 9733
  kGB_DraftingStandard = 9734
  kISO_DraftingStandard = 9735
  kJIS_DraftingStandard = 9736
  kGOST_DraftingStandard = 9737
End Enum
Members
Members | Description
kDefault_DraftingStandard | Specifies the use of the default setting.
kOther_DraftingStandard | Catch-all placeholder. Not typically used.
kANSI_DraftingStandard | ANSI Drafting Standard.
kBSI_DraftingStandard | BSI Drafting Standard.
kDIN_DraftingStandard | DIN Drafting Standard.
kGB_DraftingStandard | GB Drafting Standard.
kISO_DraftingStandard | ISO Drafting Standard.
kJIS_DraftingStandard | JIS Drafting Standard.
Notes

Members through which this object may be accessed include:

DraftingStandard.BaseStandard

DrawingStandardStyle.InternationalStandardReference

SurfaceTextureStyle.StandardReference

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DraftingStandardEnum Enumeration


Inventor.DragStateEnum Enumeration

Inventor.DragStateEnum Enumeration Introduced in Inventor 9
Summary

Enumeration of the conditions of the drag

Visual Basic
Public Enum DragStateEnum
  kDragStateDragHandlerSelection = 37889
  kDragStateStartDrag = 37890
  kDragStateOnDrag = 37891
  kDragStateEndDrag = 37892
  kDragStateCancelDrag = 37895
  kDragStateSuspendDrag = 37893
  kDragStateResumeDrag = 37894
End Enum
Members
Members | Description
kDragStateDragHandlerSelection | Inventor is seeking a handler for dragging the selected objects
kDragStateStartDrag | Drag is starting
kDragStateOnDrag | Drag is occurring right now
kDragStateEndDrag | Drag is ending
kDragStateCancelDrag | Drag is cancelled
kDragStateSuspendDrag | Drag is being suspended
kDragStateResumeDrag | Drag is being resumed
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DragStateEnum Enumeration


Inventor.DrawingEdgeTypeEnum Enumeration

Inventor.DrawingEdgeTypeEnum Enumeration
Summary

This is record Inventor::DrawingEdgeTypeEnum.

Visual Basic
Public Enum DrawingEdgeTypeEnum
  kThreadEdge = 82689
  kBendUpEdge = 82690
  kBendDownEdge = 82691
  kBendExtentEdge = 82692
  kPunchDownEdge = 82693
  kTangentEdge = 82694
  kUnknownEdge = 82695
  kPunchUpEdge = 82696
  kContourRollEdge = 82697
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DrawingEdgeTypeEnum Enumeration


Inventor.DrawingSheetSizeEnum Enumeration

Inventor.DrawingSheetSizeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate the drawing sheet sizes supported by Autodesk Inventor.

Visual Basic
Public Enum DrawingSheetSizeEnum
  kCustomDrawingSheetSize = 9986
  kADrawingSheetSize = 9987
  kBDrawingSheetSize = 9988
  kCDrawingSheetSize = 9989
  kDDrawingSheetSize = 9990
  kEDrawingSheetSize = 9991
  kFDrawingSheetSize = 9992
  kA0DrawingSheetSize = 9993
  kA1DrawingSheetSize = 9994
  kA2DrawingSheetSize = 9995
  kA3DrawingSheetSize = 9996
  kA4DrawingSheetSize = 9997
  k9x12InDrawingSheetSize = 9998
  k12x18InDrawingSheetSize = 9999
  k18x24InDrawingSheetSize = 10000
  k24x36InDrawingSheetSize = 10001
  k36x48InDrawingSheetSize = 10002
  k30x42InDrawingSheetSize = 10003
End Enum
Members
Members | Description
kCustomDrawingSheetSize | Custom size. May not fit one of the standard sizes.
kADrawingSheetSize | A size (typically for inch units).
kBDrawingSheetSize | B size (typically for inch units).
kCDrawingSheetSize | C size (typically for inch units).
kDDrawingSheetSize | D size (typically for inch units).
kEDrawingSheetSize | E size (typically for inch units).
kFDrawingSheetSize | F size (typically for inch units).
kA0DrawingSheetSize | A0 size (typically for metric units).
kA1DrawingSheetSize | A1 size (typically for metric units).
kA2DrawingSheetSize | A2 size (typically for metric units).
kA3DrawingSheetSize | A3 size (typically for metric units).
kA4DrawingSheetSize | A4 size (typically for metric units).
Notes

Members through which this object may be accessed include:

Sheet.Size

SheetFormat.Size

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DrawingSheetSizeEnum Enumeration


Inventor.DrawingSheetStatusBits Enumeration

Inventor.DrawingSheetStatusBits Enumeration Available in Inventor Available in Server Introduced in Inventor 4
Summary

Bits indicating out-of-date status of a drawing sheet.

Visual Basic
Public Enum DrawingSheetStatusBits
  kUpToDateDrawingSheet = 0
  kGeomOutOfDateDrawingSheet = 1
  kAssyPositionOutOfDateDrawingSheet = 2
  kAssyCompositionOutOfDateDrawingSheet = 4
  kStandardOutOfDateDrawingSheet = 8
  kResourceTemplateOutOfDateDrawingSheet = 16
  kParameterizedTextOutOfDateDrawingSheet = 32
  kUnknownOutOfDateDrawingSheet = 64
  kNoDataDrawingSheet = 128
  kProcessingPreciseDisplayDrawingSheet = 256
End Enum
Members
Members | Description
kUpToDateDrawingSheet | Check for equality with this enum to see if sheet is fully up-to-date.
kGeomOutOfDateDrawingSheet | Geometric content of a part on the sheet has changed, and the sheet rendition is out-of-date.
kAssyPositionOutOfDateDrawingSheet | Assembly on the sheet has undergone positional changes, and the sheet rendition is out-of-date.
kAssyCompositionOutOfDateDrawingSheet | Assembly on the sheet has undergone some composition changes, and the sheet rendition is out-of-date.
kStandardOutOfDateDrawingSheet | Drafting standard of the sheet has changed, and the sheet rendition is out-of-date.
kResourceTemplateOutOfDateDrawingSheet | Resource templates used on the sheet have changed, and the sheet rendition is out-of-date.
kParameterizedTextOutOfDateDrawingSheet | Parameterized text used on the sheet has changed, and the sheet rendition is out-of-date.
kUnknownOutOfDateDrawingSheet | Up-to-date status of the rendition of this sheet could not be fully determined.
kNoDataDrawingSheet | Rendition of this sheet is not available.
kProcessingPreciseDisplayDrawingSheet | Hidden-line display in one or more views is in progress. Sheet may print with incomplete graphical representation.
Notes

Members through which this object may be accessed include:

Sheet.Status

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DrawingSheetStatusBits Enumeration


Inventor.DrawingViewAlignmentEnum Enumeration

Inventor.DrawingViewAlignmentEnum Enumeration
Summary

This is record Inventor::DrawingViewAlignmentEnum.

Visual Basic
Public Enum DrawingViewAlignmentEnum
  kHorizontalViewAlignment = 80641
  kVerticalViewAlignment = 80642
  kInPositionViewAlignment = 80643
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DrawingViewAlignmentEnum Enumeration


Inventor.DrawingViewStyleEnum Enumeration

Inventor.DrawingViewStyleEnum Enumeration Introduced in Inventor 6
Summary

Constants enumerating the drawing view style type.

Visual Basic
Public Enum DrawingViewStyleEnum
  kHiddenLineDrawingViewStyle = 32257
  kHiddenLineRemovedDrawingViewStyle = 32258
  kShadedDrawingViewStyle = 32259
  kShadedHiddenLineDrawingViewStyle = 32261
  kFromBaseDrawingViewStyle = 32260
End Enum
Members
Members | Description
kHiddenLineDrawingViewStyle | Hidden line style.
kHiddenLineRemovedDrawingViewStyle | Hidden lines removed style.
kShadedDrawingViewStyle | Shaded style.
kFromBaseDrawingViewStyle | Derive the style from the base drawing view.
Notes

Members through which this object may be accessed include:

DrawingView.ViewStyle

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DrawingViewStyleEnum Enumeration


Inventor.DrawingViewTypeEnum Enumeration

Inventor.DrawingViewTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate the drawing view types.

Visual Basic
Public Enum DrawingViewTypeEnum
  kStandardDrawingViewType = 10501
  kDetailDrawingViewType = 10502
  kSectionDrawingViewType = 10503
  kAuxiliaryDrawingViewType = 10499
  kProjectedDrawingViewType = 10504
  kDraftDrawingViewType = 10505
  kAssociativeDraftDrawingViewType = 10506
  kOverlayDrawingViewType = 10507
End Enum
Members
Members | Description
kStandardDrawingViewType | View with the camera set to one of the standard orthogonal views (Top, Iso, etc.).
kDetailDrawingViewType | View is a detail of a portion of the document contents.
kSectionDrawingViewType | View is a section.
kAuxiliaryDrawingViewType | View is an auxiliary one.
kProjectedDrawingViewType | View is a projected one
kDraftDrawingViewType | View is a draft one
kAssociativeDraftDrawingViewType | View is an associative draft one
Notes

Members through which this object may be accessed include:

DrawingView.ViewType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.DrawingViewTypeEnum Enumeration


Inventor.DWFPublishModeEnum Enumeration

Inventor.DWFPublishModeEnum Enumeration
Summary

This is record Inventor::DWFPublishModeEnum.

Visual Basic
Public Enum DWFPublishModeEnum
  kBasicDWFPublish = 62721
  kCompleteDWFPublish = 62722
  kCustomDWFPublish = 62723
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DWFPublishModeEnum Enumeration


Inventor.DWGFileVersionEnum Enumeration

Inventor.DWGFileVersionEnum Enumeration
Summary

This is record Inventor::DWGFileVersionEnum.

Visual Basic
Public Enum DWGFileVersionEnum
  kAutoCAD2000 = 86529
  kAutoCAD2004 = 86530
  kAutoCAD2007 = 86531
  kAutoCAD2010 = 86532
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.DWGFileVersionEnum Enumeration


Inventor.EdgeCollectionEnum Enumeration

Inventor.EdgeCollectionEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the collection type of edges.

Visual Basic
Public Enum EdgeCollectionEnum
  kTangentiallyConnected = 27649
  kAllConcave = 27650
  kAllConvex = 27651
  kUndefined = 27652
End Enum
Members
Members | Description
kTangentiallyConnected | Constant identifying tangentially connected edges.
kAllConcave | Constant identifying concave edges.
kAllConvex | Constant identifying convex edges.
kUndefined | Constant identifying undefined edges.
Notes

Members through which this object may be accessed include:

EdgeCollection.CollectionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.EdgeCollectionEnum Enumeration


Inventor.EmbossTypeEnum Enumeration

Inventor.EmbossTypeEnum Enumeration
Summary

This is record Inventor::EmbossTypeEnum.

Visual Basic
Public Enum EmbossTypeEnum
  kEmbossFromFace = 67329
  kEngraveFromFace = 67330
  kEmbossEngraveFromPlane = 67331
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.EmbossTypeEnum Enumeration


Inventor.EnvironmentStateEnum Enumeration

Inventor.EnvironmentStateEnum Enumeration
Summary

This is record Inventor::EnvironmentStateEnum.

Visual Basic
Public Enum EnvironmentStateEnum
  kRequestActivateEnvironmentState = 50949
  kActivateEnvironmentState = 50945
  kSuspendEnvironmentState = 50946
  kResumeEnvironmentState = 50947
  kTerminateEnvironmentState = 50948
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.EnvironmentStateEnum Enumeration


Inventor.EventTimingEnum Enumeration

Inventor.EventTimingEnum Enumeration Introduced in Inventor 4
Summary

Codes specifying exactly when a particular event was fired (Before/After).

Visual Basic
Public Enum EventTimingEnum
  kBefore = 4097
  kAfter = 4098
  kAbort = 4099
End Enum
Members
Members | Description
kBefore | Event fired BEFORE native processing.
kAfter | Event fired AFTER native processing.
kAbort | Event fired if the native processing ABORTED.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.EventTimingEnum Enumeration


Inventor.ExitTypeEnum Enumeration

Inventor.ExitTypeEnum Enumeration
Summary

This is record Inventor::ExitTypeEnum.

Visual Basic
Public Enum ExitTypeEnum
  kExitToPrevious = 63745
  kExitToParent = 63746
  kExitToTop = 63747
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ExitTypeEnum Enumeration


Inventor.FaceCollectionEnum Enumeration

Inventor.FaceCollectionEnum Enumeration Introduced in Inventor 9
Summary

Constants identifying the collection type of faces

Visual Basic
Public Enum FaceCollectionEnum
  kFaceTangentiallyConnected = 40961
  kFaceUndefined = 40962
End Enum
Members
Members | Description
kFaceTangentiallyConnected | Constants identifying tangentially connected faces
kFaceUndefined | Constants identifying undefined faces
Notes

Members through which this object may be accessed include:

FaceCollection.CollectionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.FaceCollectionEnum Enumeration


Inventor.FactoryOptionsMemberNameTypeEnum Enumeration

Inventor.FactoryOptionsMemberNameTypeEnum Enumeration
Summary

This is record Inventor::FactoryOptionsMemberNameTypeEnum.

Visual Basic
Public Enum FactoryOptionsMemberNameTypeEnum
  kPartNumberMemberNameType = 81921
  kFileNameMemberNameType = 81922
  kValueMemberNameType = 81923
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FactoryOptionsMemberNameTypeEnum Enumeration


Inventor.FactoryOptionsPartNumberTypeEnum Enumeration

Inventor.FactoryOptionsPartNumberTypeEnum Enumeration
Summary

This is record Inventor::FactoryOptionsPartNumberTypeEnum.

Visual Basic
Public Enum FactoryOptionsPartNumberTypeEnum
  kNonePartNumberType = 82177
  kValuePartNumberType = 82178
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FactoryOptionsPartNumberTypeEnum Enumeration


Inventor.FamilyParameterValueTypeEnum Enumeration

Inventor.FamilyParameterValueTypeEnum Enumeration
Summary

This is record Inventor::FamilyParameterValueTypeEnum.

Visual Basic
Public Enum FamilyParameterValueTypeEnum
  kConstantFamilyParameterValue = 51457
  kCustomFamilyParameterValue = 51458
  kExpressionFamilyParameterValue = 51459
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FamilyParameterValueTypeEnum Enumeration


Inventor.FeatureApproximationTypeEnum Enumeration

Inventor.FeatureApproximationTypeEnum Enumeration
Summary

This is record Inventor::FeatureApproximationTypeEnum.

Visual Basic
Public Enum FeatureApproximationTypeEnum
  kNoApproximation = 60673
  kMeanApproximation = 60674
  kNeverTooThickApproximation = 60675
  kNeverTooThinApproximation = 60676
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FeatureApproximationTypeEnum Enumeration


Inventor.FeatureDimensionTypeEnum Enumeration

Inventor.FeatureDimensionTypeEnum Enumeration
Summary

This is record Inventor::FeatureDimensionTypeEnum.

Visual Basic
Public Enum FeatureDimensionTypeEnum
  kAngleFeatureDimension = 93185
  kCircularCountFeatureDimension = 93186
  kHoleFeatureDimension = 93187
  kLinearFeatureDimension = 93188
  kRadialFeatureDimension = 93189
  kRectangularCountFeatureDimension = 93190
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FeatureDimensionTypeEnum Enumeration


Inventor.FileFormatEnum Enumeration

Inventor.FileFormatEnum Enumeration
Summary

This is record Inventor::FileFormatEnum.

Visual Basic
Public Enum FileFormatEnum
  kMicrosoftAccessFormat = 74497
  kMicrosoftExcelFormat = 74498
  kdBASEIIIFormat = 74499
  kdBASEIVFormat = 74500
  kTextFileTabDelimitedFormat = 74501
  kTextFileCommaDelimitedFormat = 74502
  kUnicodeTextFileTabDelimitedFormat = 74503
  kUnicodeTextFileCommaDelimitedFormat = 74504
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FileFormatEnum Enumeration


Inventor.FileManagementEnum Enumeration

Inventor.FileManagementEnum Enumeration Introduced in Inventor 6
Summary

Bits indicating valid entity types for iFeature input.

Visual Basic
Public Enum FileManagementEnum
  kNoForceFile = 0
  kForceFile = 1
  kOverwriteExistingFile = 1
  kOverwriteReservedFile = 1
  kOverwriteReadOnlyFile = 1
  kCopyFileMask = 1
  kDeleteFileMask = 1
  kMoveFileMask = 1
End Enum
Members
Members | Description
kNoForceFile | Force option not specified.
kForceFile | Option to force the deletion if the file is reserved.
kOverwriteExistingFile | Option to overwrite the existing file at the destination.
kOverwriteReservedFile | Option to overwrite the existing file at the destination even if reserved.
kCopyFileMask | Option used by CopyFile.
kDeleteFileMask | Option used by DeleteFile.
kMoveFileMask | Option used by MoveFile.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FileManagementEnum Enumeration


Inventor.FileOwnershipEnum Enumeration

Inventor.FileOwnershipEnum Enumeration
Summary

This is record Inventor::FileOwnershipEnum.

Visual Basic
Public Enum FileOwnershipEnum
  kNoOwnership = 68609
  kSaveOwnership = 68610
  kExclusiveOwnership = 68611
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FileOwnershipEnum Enumeration


Inventor.FileTypeEnum Enumeration

Inventor.FileTypeEnum Enumeration
Summary

This is record Inventor::FileTypeEnum.

Visual Basic
Public Enum FileTypeEnum
  kUnknownFileType = 56321
  kPartFileType = 56322
  kAssemblyFileType = 56323
  kDrawingFileType = 56324
  kPresentationFileType = 56325
  kDesignElementFileType = 56326
  kForeignFileType = 56327
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FileTypeEnum Enumeration


Inventor.FileVersionEnum Enumeration

Inventor.FileVersionEnum Enumeration
Summary

This is record Inventor::FileVersionEnum.

Visual Basic
Public Enum FileVersionEnum
  kOpenOldVersion = 57857
  kOpenCurrentVersion = 57858
  kRestoreOldVersionToCurrent = 57859
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FileVersionEnum Enumeration


Inventor.FilletTypeEnum Enumeration

Inventor.FilletTypeEnum Enumeration
Summary

This is record Inventor::FilletTypeEnum.

Visual Basic
Public Enum FilletTypeEnum
  kEdgeFillet = 61697
  kFaceFillet = 61698
  kFullRoundFillet = 61699
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FilletTypeEnum Enumeration


Inventor.FlatPatternEdgeTypeEnum Enumeration

Inventor.FlatPatternEdgeTypeEnum Enumeration
Summary

This is record Inventor::FlatPatternEdgeTypeEnum.

Visual Basic
Public Enum FlatPatternEdgeTypeEnum
  kTangentFlatPatternEdge = 64001
  kBendUpFlatPatternEdge = 64004
  kBendDownFlatPatternEdge = 64005
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FlatPatternEdgeTypeEnum Enumeration


Inventor.FrontViewPlaneEnum Enumeration

Inventor.FrontViewPlaneEnum Enumeration
Summary

This is record Inventor::FrontViewPlaneEnum.

Visual Basic
Public Enum FrontViewPlaneEnum
  kFrontViewXYPlane = 80385
  kFrontViewYZPlane = 80386
  kFrontViewXZPlane = 80387
  kFrontViewFromModel = 80388
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.FrontViewPlaneEnum Enumeration


Inventor.GeneralDataTypeEnum Enumeration

Inventor.GeneralDataTypeEnum Enumeration
Summary

This is record Inventor::GeneralDataTypeEnum.

Visual Basic
Public Enum GeneralDataTypeEnum
  kBooleanGeneralData = 52481
  kCollectionGeneralData = 52482
  kDoubleGeneralData = 52483
  kIntegerGeneralData = 52484
  kStringGeneralData = 52485
  kIDispatchGeneralData = 52486
  kVTableGeneralData = 52487
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GeneralDataTypeEnum Enumeration


Inventor.GeneralDimensionTypeEnum Enumeration

Inventor.GeneralDimensionTypeEnum Enumeration
Summary

This is record Inventor::GeneralDimensionTypeEnum.

Visual Basic
Public Enum GeneralDimensionTypeEnum
  kTrueGeneralDimension = 72193
  kProjectedGeneralDimension = 72194
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GeneralDimensionTypeEnum Enumeration


Inventor.GeometricCharacteristicEnum Enumeration

Inventor.GeometricCharacteristicEnum Enumeration
Summary

This is record Inventor::GeometricCharacteristicEnum.

Visual Basic
Public Enum GeometricCharacteristicEnum
  kStraightness = 1
  kFlatness = 2
  kCircularity = 4
  kProfileOfAnyLine = 8
  kProfileOfAnySurface = 16
  kAngularity = 32
  kPerpendicularity = 64
  kParallelism = 128
  kPosition = 256
  kConcentricityAndCoaxiality = 512
  kCircularRunout = 1024
  kSymmetry = 2048
  kTotalRunout = 4096
  kCylindricity = 8192
  kParallelProfile = 16384
  kAxisIntersection = 32768
  kCircularRunoutFilled = 65536
  kTotalRunoutFilled = 131072
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GeometricCharacteristicEnum Enumeration


Inventor.GeometricConstraintsBreakageEnum Enumeration

Inventor.GeometricConstraintsBreakageEnum Enumeration
Summary

This is record Inventor::GeometricConstraintsBreakageEnum.

Visual Basic
Public Enum GeometricConstraintsBreakageEnum
  kNeverBreakGeometricConstraints = 58369
  kAlwaysBreakGeometricConstraints = 58370
  kPromptBreakGeometricConstraints = 58371
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GeometricConstraintsBreakageEnum Enumeration


Inventor.GeometryMoveableStatusEnum Enumeration

Inventor.GeometryMoveableStatusEnum Enumeration
Summary

This is record Inventor::GeometryMoveableStatusEnum.

Visual Basic
Public Enum GeometryMoveableStatusEnum
  kFreeToMoveGeometryMoveableStatus = 53505
  kMoveableByDimensionChangeGeometryMoveableStatus = 53506
  kFixedGeometryMoveableStatus = 53507
  kUnknownGeometryMoveableStatus = 53508
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GeometryMoveableStatusEnum Enumeration


Inventor.GraphicsDriverTypeEnum Enumeration

Inventor.GraphicsDriverTypeEnum Enumeration
Summary

This is record Inventor::GraphicsDriverTypeEnum.

Visual Basic
Public Enum GraphicsDriverTypeEnum
  kDirect3DGraphicsDriver = 61441
  kOpenGLGraphicsDriver = 61442
  kConservativeOpenGLGraphicsDriver = 61443
  kSoftwareGraphics = 61444
  kDirect3D10GraphicsDriver = 61445
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GraphicsDriverTypeEnum Enumeration


Inventor.GraphicsLevelsOfDetailEnum Enumeration

Inventor.GraphicsLevelsOfDetailEnum Enumeration Introduced in Inventor 4
Summary

Bits indicating the levels of detail in the graphics system. It controls the fineness of the facets generated on the surfaces.

Visual Basic
Public Enum GraphicsLevelsOfDetailEnum
  kZoomedInHighRes = 8192
  kFullScreenHighRes = 2048
  kMediumRes = 512
  kCoarseRes = 128
  kVeryCoarseRes = 32
  kMereDotRes = 8
End Enum
Members
Members | Description
kZoomedInHighRes | Estimated fineness required for a good picture when you are zoomed in on an 'average' model.
kFullScreenHighRes | Estimated fineness required for a good picture when you fit an 'average' model to full screen.
kMediumRes | Estimated fineness required for an average-quality picture.
kCoarseRes | Estimated fineness required for a coarse picture.
kVeryCoarseRes | Estimated fineness required for a very coarse picture.
kMereDotRes | Estimated fineness required for representing the model as just a blob.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GraphicsLevelsOfDetailEnum Enumeration


Inventor.GraphicsOptimizationEnum Enumeration

Inventor.GraphicsOptimizationEnum Enumeration
Summary

This is record Inventor::GraphicsOptimizationEnum.

Visual Basic
Public Enum GraphicsOptimizationEnum
  kRecommendedGraphicsOptimization = 55297
  kFullGraphicsOptimization = 55298
  kConservativeGraphicsOptimization = 55299
  kDriverGraphicsOptimization = 55300
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GraphicsOptimizationEnum Enumeration


Inventor.GraphicsSelectabilityEnum Enumeration

Inventor.GraphicsSelectabilityEnum Enumeration Introduced in Inventor 5
Summary

Indicates whether some, all, or none of the client graphics are selectable.

Visual Basic
Public Enum GraphicsSelectabilityEnum
  kNoGraphicsSelectable = 25345
  kSomeGraphicsSelectable = 25346
  kAllGraphicsSelectable = 25347
End Enum
Members
Members | Description
kNoGraphicsSelectable | No client graphics are selectable.
kSomeGraphicsSelectable | Some, but not all, client graphics are selectable.
kAllGraphicsSelectable | All client graphics are selectable.
Notes

Members through which this object may be accessed include:

ClientGraphics.Selectable

You are here: Symbol Reference > Inventor Library > Enums > Inventor.GraphicsSelectabilityEnum Enumeration


Inventor.GraphicsSettingTypeEnum Enumeration

Inventor.GraphicsSettingTypeEnum Enumeration
Summary

This is record Inventor::GraphicsSettingTypeEnum.

Visual Basic
Public Enum GraphicsSettingTypeEnum
  kQualityGraphicsSetting = 91649
  kPerformanceGraphicsSetting = 91650
  kCompatibilityGraphicsSetting = 91651
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GraphicsSettingTypeEnum Enumeration


Inventor.GraphicsVisibilityEnum Enumeration

Inventor.GraphicsVisibilityEnum Enumeration Introduced in Inventor 5
Summary

Indicates whether some, all, or none of the client graphics are visible.

Visual Basic
Public Enum GraphicsVisibilityEnum
  kNoGraphicsVisible = 25089
  kSomeGraphicsVisible = 25090
  kAllGraphicsVisible = 25091
End Enum
Members
Members | Description
kNoGraphicsVisible | No client graphics are visible.
kSomeGraphicsVisible | Some, but not all, client graphics are visible.
kAllGraphicsVisible | All client graphics are visible.
Notes

Members through which this object may be accessed include:

ClientGraphics.Visible

You are here: Symbol Reference > Inventor Library > Enums > Inventor.GraphicsVisibilityEnum Enumeration


Inventor.GroundShadowEnum Enumeration

Inventor.GroundShadowEnum Enumeration
Summary

This is record Inventor::GroundShadowEnum.

Visual Basic
Public Enum GroundShadowEnum
  kNoGroundShadow = 69121
  kGroundShadow = 69122
  kXRayGroundShadow = 69123
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.GroundShadowEnum Enumeration


Inventor.HandlingCodeEnum Enumeration

Inventor.HandlingCodeEnum Enumeration Introduced in Inventor 4
Summary

Codes returned from some events' methods.

Visual Basic
Public Enum HandlingCodeEnum
  kEventHandled = 513
  kEventNotHandled = 514
  kEventCanceled = 515
End Enum
Members
Members | Description
kEventHandled | Handled: Return this code if Autodesk Inventor should now bypass its native behavior.
kEventNotHandled | Not Handled: Return this code if Autodesk Inventor should carry on with its native behavior.
kEventCanceled | Canceled: Return this code if you want Autodesk Inventor's native 'cancel' or 'fail' behavior.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.HandlingCodeEnum Enumeration


Inventor.HeadingPlacementEnum Enumeration

Inventor.HeadingPlacementEnum Enumeration Introduced in Inventor 9
Summary

HeadingPlacement

Visual Basic
Public Enum HeadingPlacementEnum
  kHeadingAtTop = 46337
  kHeadingAtBottom = 46338
  kNoHeading = 46339
End Enum
Members
Members | Description
kHeadingAtTop | At top
kHeadingAtBottom | At bottom
kNoHeading | No heading
Notes

Members through which this object may be accessed include:

CustomTable.HeadingPlacement

HoleTable.HeadingPlacement

HoleTableStyle.HeadingPlacement

PartsList.HeadingPlacement

PartsListStyle.HeadingPlacement

RevisionTableStyle.HeadingPlacement

TableStyle.HeadingPlacement

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HeadingPlacementEnum Enumeration


Inventor.HealthStatusEnum Enumeration

Inventor.HealthStatusEnum Enumeration Introduced in Inventor 4
Summary

Constants signifying the state of the object.

Visual Basic
Public Enum HealthStatusEnum
  kUnknownHealth = 11777
  kUpToDateHealth = 11778
  kOutOfDateHealth = 11779
  kDriverLostHealth = 11780
  kInErrorHealth = 11781
  kDeletedHealth = 11782
  kCannotComputeHealth = 11783
  kSuppressedHealth = 11784
  kBeyondStopNodeHealth = 11785
  kInconsistentHealth = 11786
  kRedundantHealth = 11787
End Enum
Members
Members | Description
kUnknownHealth | Object's status is not known.
kUpToDateHealth | Object is up-to-date.
kOutOfDateHealth | Object needs to be recomputed with respect to its 'driver(s).
kDriverLostHealth | Object is driven by data from other object(s), and one or more of them have been disconnected.
kInErrorHealth | Object's internal state is in error.
kDeletedHealth | Object has been destroyed. You may be holding onto an empty 'shell' of the object.
kCannotComputeHealth | Object cannot be evaluated.
kSuppressedHealth | Object has been suppressed.
kBeyondStopNodeHealth | Object is beyond stop node in the browser.
kInconsistentHealth | Object is inconsistent with another object.
kRedundantHealth | Object's solution is redundant with another object.
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.HealthStatus

AssemblyConstraint.HealthStatus

iAssemblyMember.HealthStatus

LayoutConstraint.HealthStatus

OccurrencePattern.HealthStatus

Parameter.HealthStatus

PartFeature.HealthStatus

PlanarSketch.HealthStatus

ReferenceComponent.HealthStatus

Sketch3D.HealthStatus

UserCoordinateSystem.HealthStatus

WorkAxis.HealthStatus

WorkPlane.HealthStatus

WorkPoint.HealthStatus

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HealthStatusEnum Enumeration


Inventor.HeightDatumTypeEnum Enumeration

Inventor.HeightDatumTypeEnum Enumeration
Summary

This is record Inventor::HeightDatumTypeEnum.

Visual Basic
Public Enum HeightDatumTypeEnum
  kHeightDatumOuter = 75521
  kHeightDatumInner = 75522
  kHeightDatumTangent = 75523
  kHeightDatumOuterOrtho = 75524
  kHeightDatumInnerOrtho = 75525
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.HeightDatumTypeEnum Enumeration


Inventor.HemTypeEnum Enumeration

Inventor.HemTypeEnum Enumeration
Summary

This is record Inventor::HemTypeEnum.

Visual Basic
Public Enum HemTypeEnum
  kSingleHemType = 75265
  kTeardropHemType = 75266
  kRolledHemType = 75267
  kDoubleHemType = 75268
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.HemTypeEnum Enumeration


Inventor.HoleNoteQuantityEnum Enumeration

Inventor.HoleNoteQuantityEnum Enumeration
Summary

This is record Inventor::HoleNoteQuantityEnum.

Visual Basic
Public Enum HoleNoteQuantityEnum
  kNumberOfHolesInFeature = 83969
  kNumberOfLikeHolesNormalToView = 83970
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.HoleNoteQuantityEnum Enumeration


Inventor.HolePlacementTypeEnum Enumeration

Inventor.HolePlacementTypeEnum Enumeration Introduced in Inventor 9
Summary

Hole Placement Type enum

Visual Basic
Public Enum HolePlacementTypeEnum
  kSketchPlacementType = 48897
  kLinearPlacementType = 48898
  kConcentricPlacementType = 48899
  kPointPlacementType = 48900
End Enum
Members
Members | Description
kSketchPlacementType | Sketch Placement
kLinearPlacementType | Linear Placement
kConcentricPlacementType | Concentric Placement
kPointPlacementType | Point Placement
Notes

Members through which this object may be accessed include:

HoleFeature.PlacementType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HolePlacementTypeEnum Enumeration


Inventor.HolePropertyEnum Enumeration

Inventor.HolePropertyEnum Enumeration Introduced in Inventor 2011
Visual Basic
Public Enum HolePropertyEnum
  kCBoreDepthHoleProperty = 77569
  kCBoreDiameterHoleProperty = 77570
  kCSinkAngleHoleProperty = 77571
  kCSinkDepthHoleProperty = 77572
  kCSinkDiameterHoleProperty = 77573
  kCustomDesignationHoleProperty = 77574
  kDescriptionHoleProperty = 77575
  kFasternerFitHoleProperty = 77576
  kFasternerSizeHoleProperty = 77577
  kFastenerTypeHoleProperty = 77578
  kHoleHoleProperty = 77579
  kHoleDepthHoleProperty = 77580
  kHoleDiameterHoleProperty = 77581
  kPunchAngleHoleProperty = 77582
  kPunchDepthHoleProperty = 77583
  kPunchDirectionHoleProperty = 77584
  kPunchIdHoleProperty = 77585
  kQuantityHoleProperty = 77586
  kTapDrillDiameterHoleProperty = 77587
  kThreadClassHoleProperty = 77588
  kThreadDepthHoleProperty = 77589
  kThreadDesignationHoleProperty = 77590
  kThreadPitchHoleProperty = 77591
  kXDIMHoleProperty = 77592
  kYDIMHoleProperty = 77593
  kCustomHoleProperty = 77594
End Enum
Notes

Members through which this object may be accessed include:

HoleTableColumn.PropertyType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HolePropertyEnum Enumeration


Inventor.HoleTableTypeEnum Enumeration

Inventor.HoleTableTypeEnum Enumeration Introduced in Inventor 2011
Visual Basic
Public Enum HoleTableTypeEnum
  kViewTypeHoleTable = 77825
  kSelectionTypeHoleTable = 77826
  kFeatureTypeHoleTable = 77827
End Enum
Notes

Members through which this object may be accessed include:

HoleTable.HoleTableType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HoleTableTypeEnum Enumeration


Inventor.HoleTypeEnum Enumeration

Inventor.HoleTypeEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the type of treatment given to the start of the hole.

Visual Basic
Public Enum HoleTypeEnum
  kDrilledHole = 21505
  kCounterSinkHole = 21506
  kCounterBoreHole = 21507
  kSpotFaceHole = 21508
End Enum
Members
Members | Description
kDrilledHole | Hole is drilled (no countersink or counterboring).
kCounterSinkHole | Hole is countersunk.
kCounterBoreHole | Hole is counterbored.
Notes

Members through which this object may be accessed include:

HoleFeature.HoleType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HoleTypeEnum Enumeration


Inventor.HorizontalTextAlignmentEnum Enumeration

Inventor.HorizontalTextAlignmentEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the horizontal positioning of text about a given point coordinate.

Visual Basic
Public Enum HorizontalTextAlignmentEnum
  kAlignTextCenter = 19969
  kAlignTextLeft = 19970
  kAlignTextRight = 19971
End Enum
Members
Members | Description
kAlignTextCenter | Text centered about the supplied point.
kAlignTextLeft | Text left-justified about the supplied point.
kAlignTextRight | Text right-justified about the supplied point.
Notes

Members through which this object may be accessed include:

Column.TitleHorizontalJustification

Column.ValueHorizontalJustification

DimensionText.HorizontalJustification

DrawingNote.HorizontalJustification

DrawingViewLabel.HorizontalJustification

PartsListColumn.TitleHorizontalJustification

PartsListColumn.ValueHorizontalJustification

RevisionTableColumn.TitleHorizontalJustification

RevisionTableColumn.ValueHorizontalJustification

TableStyle.ColumnTitleHorizontalJustification

TableStyle.ColumnValueHorizontalJustification

TextBox.HorizontalJustification

TextGraphics.HorizontalAlignment

TextStyle.HorizontalJustification

You are here: Symbol Reference > Inventor Library > Enums > Inventor.HorizontalTextAlignmentEnum Enumeration


Inventor.iComponentColumnTypeEnum Enumeration

Inventor.iComponentColumnTypeEnum Enumeration
Summary

This is record Inventor::iComponentColumnTypeEnum.

Visual Basic
Public Enum iComponentColumnTypeEnum
  kMemberNameColumn = 88065
  kBOMStructureColumn = 88066
  kBOMQuantityColumn = 88067
  kFilePropertyColumn = 88068
  kParameterValueColumn = 88069
  kExclusionColumn = 88070
  kiComponentTableReplaceColumn = 88071
  kiFeatureTableReplaceColumn = 88072
  kGroundedColumn = 88073
  kAdaptiveColumn = 88074
  kiMateMatchingNameColumn = 88075
  kiMateMatchingListColumn = 88076
  kiMateSequenceNumberColumn = 88077
  kFlatPatternOrientationColumn = 88078
  kFlatPatternBendOrderColumn = 88079
  kSheetMetalRuleColumn = 88080
  kSheetMetalUnfoldColumn = 88081
  kThreadTypeColumn = 88082
  kThreadDesignationColumn = 88083
  kThreadClassColumn = 88084
  kThreadDirectionColumn = 88085
  kThreadPipeDiameterColumn = 88086
  kUnknownColumn = 88087
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.iComponentColumnTypeEnum Enumeration


Inventor.IconsColorTypeEnum Enumeration

Inventor.IconsColorTypeEnum Enumeration
Summary

This is record Inventor::IconsColorTypeEnum.

Visual Basic
Public Enum IconsColorTypeEnum
  kCobaltColorTheme = 87553
  kAmberColorTheme = 87554
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.IconsColorTypeEnum Enumeration


Inventor.iFeatureEntityInputTypeEnum Enumeration

Inventor.iFeatureEntityInputTypeEnum Enumeration Introduced in Inventor 6
Summary

Bits indicating valid entity types for iFeature input.

Visual Basic
Public Enum iFeatureEntityInputTypeEnum
  kiFeatureEntityInputTypeUnknown = 0
  kiFeatureEntityInputTypeVertex = 1
  kiFeatureEntityInputTypeSketchPoint = 2
  kiFeatureEntityInputTypeWorkPoint = 4
  kiFeatureEntityInputTypeGenericEdge = 8
  kiFeatureEntityInputTypeLinearEdge = 16
  kiFeatureEntityInputTypeCircularEdge = 32
  kiFeatureEntityInputTypeWorkAxis = 64
  kiFeatureEntityInputTypeGenericSketchCurve = 128
  kiFeatureEntityInputTypeLinearSketchCurve = 256
  kiFeatureEntityInputTypeCircularSketchCurve = 512
  kiFeatureEntityInputTypeEllipticalSketchCurve = 1024
  kiFeatureEntityInputTypeSplineSketchCurve = 2048
  kiFeatureEntityInputTypePlanarFace = 4096
  kiFeatureEntityInputTypeWorkPlane = 8192
  kiFeatureEntityInputTypeGenericSurface = 16384
  kiFeatureEntityInputTypeCylindricalSurface = 32768
  kiFeatureEntityInputTypeConicalSurface = 65536
  kiFeatureEntityInputTypeSphericalSurface = 131072
  kiFeatureEntityInputTypeToroidalSurface = 262144
End Enum
Members
Members | Description
kiFeatureEntityInputTypeUnknown | Type not defined in the list.
kiFeatureEntityInputTypeVertex | Vertex type.
kiFeatureEntityInputTypeSketchPoint | Sketch point type.
kiFeatureEntityInputTypeWorkPoint | Work point type.
kiFeatureEntityInputTypeGenericEdge | Any edge type.
kiFeatureEntityInputTypeLinearEdge | Linear edge type.
kiFeatureEntityInputTypeCircularEdge | Circular or elliptical edge type.
kiFeatureEntityInputTypeWorkAxis | Work axis type.
kiFeatureEntityInputTypeGenericSketchCurve | Sketch curve type.
kiFeatureEntityInputTypeLinearSketchCurve | Linear sketch curve type.
kiFeatureEntityInputTypeCircularSketchCurve | Circular sketch curve type.
kiFeatureEntityInputTypeEllipticalSketchCurve | Elliptical sketch curve type.
kiFeatureEntityInputTypeSplineSketchCurve | Spline sketch curve type.
kiFeatureEntityInputTypePlanarFace | Planar face type.
kiFeatureEntityInputTypeWorkPlane | Work plane type.
kiFeatureEntityInputTypeGenericSurface | Generic surface type.
kiFeatureEntityInputTypeCylindricalSurface | Cylindrical surface type.
kiFeatureEntityInputTypeConicalSurface | Conical surface type.
kiFeatureEntityInputTypeSphericalSurface | Spherical surface type.
kiFeatureEntityInputTypeToroidalSurface | Toroidal surface type.
Notes

Members through which this object may be accessed include:

iFeatureInput.EntityType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.iFeatureEntityInputTypeEnum Enumeration


Inventor.iFeatureParamLimitTypeEnum Enumeration

Inventor.iFeatureParamLimitTypeEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying the parameter limit type.

Visual Basic
Public Enum iFeatureParamLimitTypeEnum
  kParamLimitNone = 33281
  kParamLimitRange = 33282
  kParamLimitList = 33283
End Enum
Members
Members | Description
kParamLimitNone | No limit type specified.
kParamLimitRange | Range of values.
kParamLimitList | List of values.
Notes

Members through which this object may be accessed include:

iFeatureParameterInput.LimitType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.iFeatureParamLimitTypeEnum Enumeration


Inventor.InferredTypeEnum Enumeration

Inventor.InferredTypeEnum Enumeration Introduced in Inventor 5
Summary

Constants that define the types of geometry that can be inferred from different faces.

Visual Basic
Public Enum InferredTypeEnum
  kNoInference = 24833
  kInferredLine = 24834
  kInferredPoint = 24835
End Enum
Members
Members | Description
kNoInference | No inference.
kInferredLine | Inferred line.
kInferredPoint | Inferred point.
Notes

Members through which this object may be accessed include:

MateConstraint.EntityOneInferredType

MateConstraint.EntityTwoInferredType

MateiMateDefinition.EntityInferredType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.InferredTypeEnum Enumeration


Inventor.InspectionDimensionShapeEnum Enumeration

Inventor.InspectionDimensionShapeEnum Enumeration
Summary

This is record Inventor::InspectionDimensionShapeEnum.

Visual Basic
Public Enum InspectionDimensionShapeEnum
  kNoInspectionBorder = 79361
  kAngularEndsInspectionBorder = 79362
  kRoundedEndsInspectionBorder = 79363
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.InspectionDimensionShapeEnum Enumeration


Inventor.IntentTypeEnum Enumeration

Inventor.IntentTypeEnum Enumeration
Summary

This is record Inventor::IntentTypeEnum.

Visual Basic
Public Enum IntentTypeEnum
  kPointEnumIntent = 58113
  kPoint2dIntent = 58114
  kParameterIntent = 58115
  kGeometryIntent = 58116
  kNoPointIntent = 58117
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.IntentTypeEnum Enumeration


Inventor.InteractionEventsEnum Enumeration

Inventor.InteractionEventsEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying which events are active during interaction.

Visual Basic
Public Enum InteractionEventsEnum
  kSelectInteraction = 1
  kMouseInteraction = 2
  kKeyboardInteraction = 4
  kSelectAndKeyboardInteraction = 5
  kMouseAndKeyboardInteraction = 6
  kNoInteraction = 0
End Enum
Members
Members | Description
kSelectInteraction | Only the select events are active.
kMouseInteraction | Only the mouse events are active.
kKeyboardInteraction | Only the keyboard events are active.
kSelectAndKeyboardInteraction | Both the select and keyboard events are active.
kMouseAndKeyboardInteraction | Both the mouse and keyboard events are active.
kNoInteraction | None of the events is active.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.InteractionEventsEnum Enumeration


Inventor.InteractiveContactAnalysisEnum Enumeration

Inventor.InteractiveContactAnalysisEnum Enumeration
Summary

This is record Inventor::InteractiveContactAnalysisEnum.

Visual Basic
Public Enum InteractiveContactAnalysisEnum
  kContactSetOnlyInteractiveContact = 64769
  kAllComponentsInteractiveContact = 64770
  kSolverOffInteractiveContact = 64771
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.InteractiveContactAnalysisEnum Enumeration


Inventor.InteractiveContactSurfacesEnum Enumeration

Inventor.InteractiveContactSurfacesEnum Enumeration
Summary

This is record Inventor::InteractiveContactSurfacesEnum.

Visual Basic
Public Enum InteractiveContactSurfacesEnum
  kAllSurfacesInteractiveContact = 65025
  kGeneralSurfacesInteractiveContact = 65026
  kSimpleSurfacesInteractiveContact = 65027
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.InteractiveContactSurfacesEnum Enumeration


Inventor.IOMechanismEnum Enumeration

Inventor.IOMechanismEnum Enumeration Introduced in Inventor 4
Summary

Constants identifying the type of an input-output operation.

Visual Basic
Public Enum IOMechanismEnum
  kUnspecifiedIOMechanism = 13057
  kDataDropIOMechanism = 13058
  kFileBrowseIOMechanism = 13059
  kPasteSpecialIOMechanism = 13060
End Enum
Members
Members | Description
kUnspecifiedIOMechanism | An unspecified IO operation.
kDataDropIOMechanism | A data drop IO operation.
kFileBrowseIOMechanism | A file browse IO operation.
kPasteSpecialIOMechanism | A paste special IO operation.
Notes

Members through which this object may be accessed include:

TranslationContext.Type

You are here: Symbol Reference > Inventor Library > Enums > Inventor.IOMechanismEnum Enumeration


Inventor.LayDirectionTypeEnum Enumeration

Inventor.LayDirectionTypeEnum Enumeration
Summary

This is record Inventor::LayDirectionTypeEnum.

Visual Basic
Public Enum LayDirectionTypeEnum
  kParallelToPlaneOfProjection = 1
  kPerpendicularToPlaneOfProjection = 2
  kAngularInBothDirections = 4
  kMultidirectional = 8
  kCircularRelativeToCenter = 16
  kRadialRelativeToCenter = 32
  kParticulateNondirectional = 64
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LayDirectionTypeEnum Enumeration


Inventor.LevelOfDetailEnum Enumeration

Inventor.LevelOfDetailEnum Enumeration
Summary

This is record Inventor::LevelOfDetailEnum.

Visual Basic
Public Enum LevelOfDetailEnum
  kMasterLevelOfDetail = 56065
  kAllComponentsSuppressedLevelOfDetail = 56066
  kAllPartsSuppressedLevelOfDetail = 56067
  kAllContentSuppressedLevelOfDetail = 56068
  kSandboxLevelOfDetail = 56069
  kTransientLevelOfDetail = 56070
  kSubstituteLevelOfDetail = 56071
  kCustomLevelOfDetail = 56072
  kLastActiveLevelOfDetail = 56073
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LevelOfDetailEnum Enumeration


Inventor.LightDefinitionTypeEnum Enumeration

Inventor.LightDefinitionTypeEnum Enumeration
Summary

This is record Inventor::LightDefinitionTypeEnum.

Visual Basic
Public Enum LightDefinitionTypeEnum
  kDirectionalLight = 53249
  kPointLight = 53250
  kSpotLight = 53251
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LightDefinitionTypeEnum Enumeration


Inventor.LightTypeEnum Enumeration

Inventor.LightTypeEnum Enumeration
Summary

This is record Inventor::LightTypeEnum.

Visual Basic
Public Enum LightTypeEnum
  kModelSpaceLight = 52993
  kViewSpaceLight = 52994
  kGroundPlaneSpaceLight = 52995
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LightTypeEnum Enumeration


Inventor.LinearDimensionTypeEnum Enumeration

Inventor.LinearDimensionTypeEnum Enumeration
Summary

This is record Inventor::LinearDimensionTypeEnum.

Visual Basic
Public Enum LinearDimensionTypeEnum
  kRegularLinearDimension = 66305
  kDiametricLinearDimension = 66306
  kSymmetricLinearDimension = 66307
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LinearDimensionTypeEnum Enumeration


Inventor.LinearPrecisionEnum Enumeration

Inventor.LinearPrecisionEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the precision for linear dimensions

Visual Basic
Public Enum LinearPrecisionEnum
  kZeroDecimalPlaceLinearPrecision = 41729
  kOneDecimalPlaceLinearPrecision = 41730
  kTwoDecimalPlacesLinearPrecision = 41731
  kThreeDecimalPlacesLinearPrecision = 41732
  kFourDecimalPlacesLinearPrecision = 41733
  kFiveDecimalPlacesLinearPrecision = 41734
  kSixDecimalPlacesLinearPrecision = 41735
  kSevenDecimalPlacesLinearPrecision = 41736
  kEightDecimalPlacesLinearPrecision = 41737
  kZeroFractionalLinearPrecision = 41738
  kHalfFractionalLinearPrecision = 41739
  kQuarterFractionalLinearPrecision = 41740
  kEighthsFractionalLinearPrecision = 41741
  kSixteenthsFractionalLinearPrecision = 41742
  kThirtySecondsFractionalLinearPrecision = 41743
  kSixtyFourthsFractionalLinearPrecision = 41744
  kOneTwentyEighthsFractionalLinearPrecision = 41745
End Enum
Members
Members | Description
kZeroDecimalPlaceLinearPrecision | Zero Decimal Place Precision
kOneDecimalPlaceLinearPrecision | One Decimal Place Precision
kTwoDecimalPlacesLinearPrecision | Two Decimal Places Precision
kThreeDecimalPlacesLinearPrecision | Three Decimal Places Precision
kFourDecimalPlacesLinearPrecision | Four Decimal Places Precision
kFiveDecimalPlacesLinearPrecision | Five Decimal Places Precision
kSixDecimalPlacesLinearPrecision | Six Decimal Places Precision
kSevenDecimalPlacesLinearPrecision | Seven Decimal Places Precision
kEightDecimalPlacesLinearPrecision | Eight Decimal Places Precision
kZeroFractionalLinearPrecision | Zero Fractional Precision
kHalfFractionalLinearPrecision | Half Fractional Precision
kQuarterFractionalLinearPrecision | Quarter Fractional Precision
kEighthsFractionalLinearPrecision | Eighths Fractional Precision
kSixteenthsFractionalLinearPrecision | Sixteenths Fractional Precision
kThirtySecondsFractionalLinearPrecision | ThirtySeconds Fractional Precision
kSixtyFourthsFractionalLinearPrecision | SixtyFourths Fractional Precision
kOneTwentyEighthsFractionalLinearPrecision | OneTwentyEighths Fractional Precision
Notes

Members through which this object may be accessed include:

DimensionStyle.AlternateLinearPrecision

DimensionStyle.LinearPrecision

FeatureControlFrameStyle.AlternateLinearPrecision

You are here: Symbol Reference > Inventor Library > Enums > Inventor.LinearPrecisionEnum Enumeration


Inventor.LineDefinitionSpaceEnum Enumeration

Inventor.LineDefinitionSpaceEnum Enumeration Introduced in Inventor 9
Summary

Enum indicating various line font definition space types

Visual Basic
Public Enum LineDefinitionSpaceEnum
  kScreenSpace = 49921
  kModelSpace = 49922
  kHybridSpace = 49923
End Enum
Members
Members | Description
kScreenSpace | Screen Space type
kModelSpace | Model Space type
kHybridSpace | Hybrid Space type
Notes

Members through which this object may be accessed include:

CurveGraphics.LineDefinitionSpace

LineGraphics.LineDefinitionSpace

LineStripGraphics.LineDefinitionSpace

SketchArc.LineDefinitionSpace

SketchCircle.LineDefinitionSpace

SketchEllipse.LineDefinitionSpace

SketchEllipticalArc.LineDefinitionSpace

SketchFixedSpline.LineDefinitionSpace

SketchLine.LineDefinitionSpace

SketchOffsetSpline.LineDefinitionSpace

SketchSpline.LineDefinitionSpace

SurfaceGraphics.LineDefinitionSpace

SurfaceGraphicsEdge.LineDefinitionSpace

You are here: Symbol Reference > Inventor Library > Enums > Inventor.LineDefinitionSpaceEnum Enumeration


Inventor.LineSpacingEnum Enumeration

Inventor.LineSpacingEnum Enumeration Introduced in Inventor 9
Summary

LineSpacing

Visual Basic
Public Enum LineSpacingEnum
  kSingleLineSpacing = 45825
  kDoubleLineSpacing = 45826
  kTripleLineSpacing = 45827
End Enum
Members
Members | Description
kSingleLineSpacing | Single line
kDoubleLineSpacing | Double Line
kTripleLineSpacing | Triple Line
Notes

Members through which this object may be accessed include:

CustomTable.RowLineSpacing

PartsList.RowLineSpacing

PartsListStyle.RowLineSpacing

RevisionTableStyle.RowLineSpacing

TableStyle.RowLineSpacing

You are here: Symbol Reference > Inventor Library > Enums > Inventor.LineSpacingEnum Enumeration


Inventor.LineTypeEnum Enumeration

Inventor.LineTypeEnum Enumeration Introduced in Inventor 9
Summary

Enum indicating various color source types

Visual Basic
Public Enum LineTypeEnum
  kContinuousLineType = 37633
  kDashedLineType = 37634
  kLongDashedDoubleDottedLineType = 37635
  kDottedLineType = 37636
  kDoubleDashedChainLineType = 37637
  kDashDottedLineType = 37638
  kDoubleDashDoubleDottedLineType = 37639
  kDoubleDashedTripleDottedLineType = 37640
  kDashedHiddenLineType = 37641
  kLongDashDottedLineType = 37642
  kLongDashTripleDottedLineType = 37643
  kChainLineType = 37644
  kDashedDoubleDottedLineType = 37645
  kDoubleDashedDottedLineType = 37646
  kDashedTripleDottedLineType = 37647
  kDefaultLineType = 37648
  kCustomLineType = 37649
End Enum
Members
Members | Description
kContinuousLineType | Continuous line style
kDashedLineType | Dashed line style
kLongDashedDoubleDottedLineType | Long dashed double dotted line style
kDottedLineType | Dotted line style
kDoubleDashedChainLineType | Double dashed line style
kDashDottedLineType | Dash dotted line style
kDoubleDashDoubleDottedLineType | Double dash double dotted line style
kDoubleDashedTripleDottedLineType | Double dash triple dotted line style
kDashedHiddenLineType | Dashed hidden line style
kLongDashDottedLineType | Long dash dotted line style
kLongDashTripleDottedLineType | Long dash triple dotted line style
kChainLineType | Chain line style
kDashedDoubleDottedLineType | Dashed double dotted line style
kDoubleDashedDottedLineType | Double dashed dotted line style
kDashedTripleDottedLineType | Dashed triple dotted line style
kDefaultLineType | default line style
Notes

Members through which this object may be accessed include:

AutoCADBlock.LineType

CurveGraphics.LineType

DimensionStyle.LineType

DrawingCurve.LineType

Layer.LineType

LeaderStyle.LineType

LineGraphics.LineType

LineStripGraphics.LineType

Sketch.LineType

SketchArc.LineType

SketchBlock.LineType

SketchCircle.LineType

SketchedSymbol.LineType

SketchEllipse.LineType

SketchEllipticalArc.LineType

SketchFixedSpline.LineType

SketchLine.LineType

SketchOffsetSpline.LineType

SketchSpline.LineType

SurfaceGraphics.LineType

SurfaceGraphicsEdge.LineType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.LineTypeEnum Enumeration


Inventor.LineWeightTypeEnum Enumeration

Inventor.LineWeightTypeEnum Enumeration
Summary

This is record Inventor::LineWeightTypeEnum.

Visual Basic
Public Enum LineWeightTypeEnum
  kTrueLineWeight = 66049
  kRangeLineWeight = 66050
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LineWeightTypeEnum Enumeration


Inventor.LinkStatusEnum Enumeration

Inventor.LinkStatusEnum Enumeration
Summary

This is record Inventor::LinkStatusEnum.

Visual Basic
Public Enum LinkStatusEnum
  kMissingStatus = 1
  kUpToDateStatus = 2
  kOutOfDateStatus = 4
  kSourceNewerStatus = 8
  kAmbiguousStatus = 16
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LinkStatusEnum Enumeration


Inventor.LocationTypeEnum Enumeration

Inventor.LocationTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate file location types.

Visual Basic
Public Enum LocationTypeEnum
  kUnknownLocation = 45061
  kWorkspaceLocation = 45057
  kWorkgroupLocation = 45059
  kLibraryLocation = 45060
End Enum
Members
Members | Description
kUnknownLocation | An unknown location.
kWorkspaceLocation | The primary workspace (local location). User's local work area. Typically not seen by others.
kWorkgroupLocation | A Workgroup (shared location). Typically, a share housing data files concurrently being worked on.
kLibraryLocation | A Library (shared Location). Typically, a read-only catalog of data files.
Notes

Members through which this object may be accessed include:

FileDescriptor.LocationType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.LocationTypeEnum Enumeration


Inventor.LoftConditionEnum Enumeration

Inventor.LoftConditionEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying the loft condition.

Visual Basic
Public Enum LoftConditionEnum
  kFreeLoftCondition = 34305
  kTangentLoftCondition = 34306
  kSmoothLoftCondition = 34308
  kSharpPointLoftCondition = 34309
  kTangentToPlaneLoftCondition = 34310
  kDirectionLoftCondition = 34307
End Enum
Members
Members | Description
kFreeLoftCondition | Free loft condition.
kTangentLoftCondition | Tangent loft condition.
Notes

Members through which this object may be accessed include:

LoftDefinition.FirstSectionCondition

LoftDefinition.LastSectionCondition

LoftFeature.FirstSectionCondition

LoftFeature.LastSectionCondition

LoftRail.Condition

You are here: Symbol Reference > Inventor Library > Enums > Inventor.LoftConditionEnum Enumeration


Inventor.LoftedFlangeOutputTypeEnum Enumeration

Inventor.LoftedFlangeOutputTypeEnum Enumeration
Summary

This is record Inventor::LoftedFlangeOutputTypeEnum.

Visual Basic
Public Enum LoftedFlangeOutputTypeEnum
  kDieFormedLoftedFlange = 91137
  kPressBrakeChordToleranceLoftedFlange = 91138
  kPressBrakeFacetAngleLoftedFlange = 91139
  kPressBrakeFacetDistanceLoftedFlange = 91140
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LoftedFlangeOutputTypeEnum Enumeration


Inventor.LoftTypeEnum Enumeration

Inventor.LoftTypeEnum Enumeration
Summary

This is record Inventor::LoftTypeEnum.

Visual Basic
Public Enum LoftTypeEnum
  kRegularLoft = 60929
  kLoftWithRails = 60930
  kLoftWithCenterline = 60931
  kLoftWithAreaGraphSections = 60932
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.LoftTypeEnum Enumeration


Inventor.MassPropertiesAccuracyEnum Enumeration

Inventor.MassPropertiesAccuracyEnum Enumeration Introduced in Inventor 5
Summary

Constants specifying the different computational accuracies of the mass property calculations.

Visual Basic
Public Enum MassPropertiesAccuracyEnum
  k_None = 24581
  k_Low = 24577
  k_Medium = 24578
  k_High = 24579
  k_VeryHigh = 24580
End Enum
Members
Members | Description
k_Low | Low accuracy.
k_Medium | Medium accuracy.
k_High | High accuracy.
k_VeryHigh | Very high accuracy.
Notes

Members through which this object may be accessed include:

MassProperties.Accuracy

MassProperties.AvailableAccuracy

You are here: Symbol Reference > Inventor Library > Enums > Inventor.MassPropertiesAccuracyEnum Enumeration


Inventor.MaterialRemovalModifierEnum Enumeration

Inventor.MaterialRemovalModifierEnum Enumeration
Summary

This is record Inventor::MaterialRemovalModifierEnum.

Visual Basic
Public Enum MaterialRemovalModifierEnum
  kMaximumMaterialConditionModifier = 1
  kLeastMaterialConditionModifier = 2
  kProjectedToleranceZoneModifier = 4
  kTangentPlaneModifier = 8
  kFreeStateModifier = 16
  kRegardlessOfFeatureSizeModifier = 32
  kStatisticalToleranceModifier = 64
  kBetweenModifier = 128
  kDiameterModifier = 256
  kEnvelopeRequirementModifier = 512
  kReciprocityModifier = 1024
  kSquareModifier = 2048
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MaterialRemovalModifierEnum Enumeration


Inventor.MeasureTypeEnum Enumeration

Inventor.MeasureTypeEnum Enumeration
Summary

This is record Inventor::MeasureTypeEnum.

Visual Basic
Public Enum MeasureTypeEnum
  kDistanceMeasure = 72705
  kAngleMeasure = 72706
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MeasureTypeEnum Enumeration


Inventor.MediumTypeEnum Enumeration

Inventor.MediumTypeEnum Enumeration
Summary

This is record Inventor::MediumTypeEnum.

Visual Basic
Public Enum MediumTypeEnum
  kFileNameMedium = 56577
  kDataObjectMedium = 56578
  kStreamMedium = 56579
  kStringMedium = 56580
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MediumTypeEnum Enumeration


Inventor.MemberEditScopeEnum Enumeration

Inventor.MemberEditScopeEnum Enumeration
Summary

This is record Inventor::MemberEditScopeEnum.

Visual Basic
Public Enum MemberEditScopeEnum
  kEditActiveMember = 57601
  kEditAllMembers = 57602
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MemberEditScopeEnum Enumeration


Inventor.MemberManagerErrorsEnum Enumeration

Inventor.MemberManagerErrorsEnum Enumeration
Summary

This is record Inventor::MemberManagerErrorsEnum.

Visual Basic
Public Enum MemberManagerErrorsEnum
  kMemberManagerNoError = 50410511
  kMemberManagerUnknown = 50410512
  kMemberManagerVaultFileStatusFail = 50410513
  kMemberManagerVaultCheckoutFail = 50410514
  kMemberManagerVaultGetLatestVersionFail = 50410515
  kMemberManagerMissingFileWritePermission = 50410516
  kMemberManagerDifferentFamily = 50410517
  kMemberManagerDifferentMember = 50410518
  kMemberManagerMaterialNotFound = 50410519
  kMemberManagerLongFilename = 50410520
  kMemberManagerFeatureSuppressFail = 50410521
  kMemberManagerThreadFeatureNotFound = 50410522
  kMemberManagerThreadCreateFail = 50410523
  kMemberManagerInvalidMemberValue = 50410524
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MemberManagerErrorsEnum Enumeration


Inventor.MemberTypeEnum Enumeration

Inventor.MemberTypeEnum Enumeration Introduced in Inventor 6
Summary

Autodesk Inventor's VBA Member Type.

Visual Basic
Public Enum MemberTypeEnum
  kEventMember = 30721
  kSubMember = 30722
  kFunctionMember = 30723
  kPropertyMember = 30724
End Enum
Members
Members | Description
kEventMember | Event member.
kSubMember | Sub-routine member.
kFunctionMember | Function member.
kPropertyMember | Property member.
Notes

Members through which this object may be accessed include:

InventorVBAMember.MemberType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.MemberTypeEnum Enumeration


Inventor.MemorySavingModeEnum Enumeration

Inventor.MemorySavingModeEnum Enumeration
Summary

This is record Inventor::MemorySavingModeEnum.

Visual Basic
Public Enum MemorySavingModeEnum
  kUseApplicationOptionsMemoryMode = 65281
  kAlwaysSaveMemoryMode = 65282
  kNeverSaveMemoryMode = 65283
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MemorySavingModeEnum Enumeration


Inventor.MiniToolbarControlTypeEnum Enumeration

Inventor.MiniToolbarControlTypeEnum Enumeration Available in Inventor Introduced in Inventor 2012
Summary

Specifies the MiniToolbar control type.

kButton

kCheckBox

kComboBox

kDropdown

kLabel

kNewLine

kSeparator

kValueEditor

Visual Basic
Public Enum MiniToolbarControlTypeEnum
  kButton = 95233
  kCheckBox = 95234
  kComboBox = 95235
  kDropdown = 95236
  kLabel = 95237
  kSeparator = 95239
  kValueEditor = 95240
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MiniToolbarControlTypeEnum Enumeration


Inventor.ModelDiameterFromThreadEnum Enumeration

Inventor.ModelDiameterFromThreadEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the specific diameter out of the thread definition that is to be used for modeling.

Visual Basic
Public Enum ModelDiameterFromThreadEnum
  kThreadMajorDiameter = 21761
  kThreadMinorDiameter = 21762
  kThreadPitchDiameter = 21763
  kThreadTapDrillDiameter = 21764
End Enum
Members
Members | Description
kThreadMajorDiameter | Diameter of cylindrical face in the model is picked as the Major Thread diameter.
kThreadMinorDiameter | Diameter of cylindrical face in the model is picked as the Minor Thread diameter.
kThreadPitchDiameter | Diameter of cylindrical face in the model is picked as the Pitch diameter of the Thread.
kThreadTapDrillDiameter | Diameter of cylindrical face in the model is picked as the Tap Drill diameter of the Thread.
Notes

Members through which this object may be accessed include:

ModelingSettings.TappedHoleDiameter

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ModelDiameterFromThreadEnum Enumeration


Inventor.ModelValueTypeEnum Enumeration

Inventor.ModelValueTypeEnum Enumeration Introduced in Inventor 6
Summary

Settings for computing model value of a parameter.

Visual Basic
Public Enum ModelValueTypeEnum
  kNominalValue = 31489
  kLowerValue = 31490
  kUpperValue = 31491
  kMedianValue = 31492
End Enum
Members
Members | Description
kNominalValue | Use nominal value
kLowerValue | Use lower tolerance value.
kUpperValue | Use upper tolerance value.
Notes

Members through which this object may be accessed include:

Parameter.ModelValueType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ModelValueTypeEnum Enumeration


Inventor.MouseButtonEnum Enumeration

Inventor.MouseButtonEnum Enumeration Introduced in Inventor 5
Summary

Enumeration of the buttons on a mouse.

Visual Basic
Public Enum MouseButtonEnum
  kLeftMouseButton = 1
  kRightMouseButton = 2
  kMiddleMouseButton = 4
  kNoneMouseButton = 0
End Enum
Members
Members | Description
kLeftMouseButton | Left mouse button.
kRightMouseButton | Right mouse button.
kMiddleMouseButton | Middle mouse button.
kNoneMouseButton | No mouse button.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MouseButtonEnum Enumeration


Inventor.MouseDragStateEnum Enumeration

Inventor.MouseDragStateEnum Enumeration Introduced in Inventor 5
Summary

Enumeration of the conditions of the mouse drag.

Visual Basic
Public Enum MouseDragStateEnum
  kDragEnter = 15617
  kDragLeave = 15618
  kDragOver = 15619
  kDragUnknown = 15620
End Enum
Members
Members | Description
kDragEnter | Drag occurring while entering this window.
kDragLeave | Drag occurring while leaving this window.
kDragOver | Drag occurring while within this window.
kDragUnknown | Drag occurring in an unknown state.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.MouseDragStateEnum Enumeration


Inventor.MoveFaceTypeEnum Enumeration

Inventor.MoveFaceTypeEnum Enumeration
Summary

Defines the constants used to specify the type of move face.

Visual Basic
Public Enum MoveFaceTypeEnum
  kDirectionAndDistanceMoveType = 91393
  kPlanarMoveType = 91394
  kFreeMoveType = 91395
End Enum
Notes

Members through which this object may be accessed include:

MoveFaceDefinition.MoveFaceType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.MoveFaceTypeEnum Enumeration


Inventor.MultiUserModeEnum Enumeration

Inventor.MultiUserModeEnum Enumeration Introduced in Inventor 6
Summary

Constants indicating various multi-user modes

Visual Basic
Public Enum MultiUserModeEnum
  kSingleUserMode = 36353
  kSharedMode = 36354
  kSemiIsolatedMode = 36355
  kVaultMode = 36357
End Enum
Members
Members | Description
kSingleUserMode | Single user mode.
kSharedMode | Shared mode.
kSemiIsolatedMode | Semi-Isolated mode
kVaultMode | Vault mode.
Notes

Members through which this object may be accessed include:

ApprenticeServer.MultiUserMode

DesignProject.ProjectType

GeneralPreferences.MultiUserMode

You are here: Symbol Reference > Inventor Library > Enums > Inventor.MultiUserModeEnum Enumeration


Inventor.NormalBindingEnum Enumeration

Inventor.NormalBindingEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the kind of application of the normals in the associated normal-set.

Visual Basic
Public Enum NormalBindingEnum
  kPerVertexNormals = 19713
  kPerStripNormals = 19714
  kPerItemNormals = 19715
  kOverallNormal = 19716
End Enum
Members
Members | Description
kPerVertexNormals | First normal used for the first vertex, the second normal is used for the second vertex, etc.
kPerStripNormals | First normal used for the first strip of vertices, the second used for the second strip, etc.
kPerItemNormals | First normal used for the first logically complete item in the primitive being defined (triangle, line segment, etc.).
kOverallNormal | First normal used for the entire graphics primitive.
Notes

Members through which this object may be accessed include:

TriangleFanGraphics.NormalBinding

TriangleGraphics.NormalBinding

TriangleStripGraphics.NormalBinding

You are here: Symbol Reference > Inventor Library > Enums > Inventor.NormalBindingEnum Enumeration


Inventor.NumberingSchemeEnum Enumeration

Inventor.NumberingSchemeEnum Enumeration
Summary

This is record Inventor::NumberingSchemeEnum.

Visual Basic
Public Enum NumberingSchemeEnum
  kNumericNumbering = 61185
  kLowercaseAlphaNumbering = 61186
  kUppercaseAlphaNumbering = 61187
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.NumberingSchemeEnum Enumeration


Inventor.OccurrenceDOFStateEnum Enumeration

Inventor.OccurrenceDOFStateEnum Enumeration
Summary

This is record Inventor::OccurrenceDOFStateEnum.

Visual Basic
Public Enum OccurrenceDOFStateEnum
  kCanRetainDegreeOfFreedom = 78081
  kCanIgnoreDegreeOfFreedom = 78082
  kNoDegreeOfFreedomState = 78083
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.OccurrenceDOFStateEnum Enumeration


Inventor.OfflineImageFidelityEnum Enumeration

Inventor.OfflineImageFidelityEnum Enumeration Introduced in Inventor 8
Summary

Enum indicating the printing quality for a shaded drawing view when defer updates is active

Visual Basic
Public Enum OfflineImageFidelityEnum
  kLowerImageFidelity = 37377
  kStandardImageFidelity = 37378
  kBetterImageFidelity = 37379
  kBestImageFidelity = 37380
End Enum
Members
Members | Description
kLowerImageFidelity | Printing quality of 50 dpi
kStandardImageFidelity | Printing quality of 100 dpi
kBetterImageFidelity | Printing quality of 150 dpi
kBestImageFidelity | Printing quality of 200 dpi
Notes

Members through which this object may be accessed include:

DrawingSettings.OfflineImageFidelity

You are here: Symbol Reference > Inventor Library > Enums > Inventor.OfflineImageFidelityEnum Enumeration


Inventor.OLEDocumentTypeEnum Enumeration

Inventor.OLEDocumentTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate OLE document types.

Visual Basic
Public Enum OLEDocumentTypeEnum
  kOLEDocumentUnknownObject = 3329
  kOLEDocumentEmbeddingObject = 3330
  kOLEDocumentLinkObject = 3331
End Enum
Members
Members | Description
kOLEDocumentUnknownObject | OLE unknown document.
kOLEDocumentEmbeddingObject | OLE embedding document.
kOLEDocumentLinkObject | OLE link document.
Notes

Members through which this object may be accessed include:

IRxReferencedOLEFileDescriptor.OLEDocumentType

ReferencedOLEFileDescriptor.OLEDocumentType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.OLEDocumentTypeEnum Enumeration


Inventor.OLEVerbEnum Enumeration

Inventor.OLEVerbEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate actions that can be performed on an OLE attachment.

Visual Basic
Public Enum OLEVerbEnum
  kEditOpenOLEVerb = 3073
  kShowOLEVerb = 3074
  kHideOLEVerb = 3075
  kDefaultOLEVerb = 3076
End Enum
Members
Members | Description
kEditOpenOLEVerb | Open the document in a separate window for editing.
kShowOLEVerb | If the document has been hidden, display it. Else, open for editing (same as kEditOpenOLEVerb).
kHideOLEVerb | If the document has been opened, hide it. Else, no action.
kDefaultOLEVerb | Perform the default action associated with this attachment.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.OLEVerbEnum Enumeration


Inventor.OrbitTypeEnum Enumeration

Inventor.OrbitTypeEnum Enumeration
Summary

This is record Inventor::OrbitTypeEnum.

Visual Basic
Public Enum OrbitTypeEnum
  kFreeOrbit = 86017
  kConstrainedOrbit = 86018
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.OrbitTypeEnum Enumeration


Inventor.OverConstrainedDimensionBehaviorEnum Enumeration

Inventor.OverConstrainedDimensionBehaviorEnum Enumeration Introduced in Inventor 9
Summary

Constants indicating the preferred behavior when placing dimensions on overconstrained sketches

Visual Basic
Public Enum OverConstrainedDimensionBehaviorEnum
  kApplyDrivenDimension = 50689
  kWarnOfOverConstrainedCondition = 50690
End Enum
Members
Members | Description
kApplyDrivenDimension | Apply driven dimension
kWarnOfOverConstrainedCondition | Warn of over constrained behavior
Notes

Members through which this object may be accessed include:

SketchOptions.OverConstrainedDimensionBehavior

You are here: Symbol Reference > Inventor Library > Enums > Inventor.OverConstrainedDimensionBehaviorEnum Enumeration


Inventor.PageOrientationTypeEnum Enumeration

Inventor.PageOrientationTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate the page orientation styles.

Visual Basic
Public Enum PageOrientationTypeEnum
  kDefaultPageOrientation = 10241
  kLandscapePageOrientation = 10242
  kPortraitPageOrientation = 10243
End Enum
Members
Members | Description
kDefaultPageOrientation | Specifies the default setting. The more strongly typed value is returned in a query.
kLandscapePageOrientation | Page is oriented as a Landscape.
kPortraitPageOrientation | Page is oriented as a Portrait.
Notes

Members through which this object may be accessed include:

Sheet.Orientation

SheetFormat.Orientation

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PageOrientationTypeEnum Enumeration


Inventor.PaperSizeEnum Enumeration

Inventor.PaperSizeEnum Enumeration Introduced in Inventor 5
Summary

Constants enumerating the various sizes of paper to be used for printing.

Visual Basic
Public Enum PaperSizeEnum
  kPaperSize10x14 = 14337
  kPaperSize11x17 = 14338
  kPaperSizeA0 = 14357
  kPaperSizeA0Oversize = 14358
  kPaperSizeA1 = 14359
  kPaperSizeA1Oversize = 14360
  kPaperSizeA2 = 14339
  kPaperSizeA2Oversize = 14361
  kPaperSizeA3 = 14340
  kPaperSizeA4 = 14341
  kPaperSizeA4Small = 14342
  kPaperSizeA5 = 14343
  kPaperSizeA6 = 14365
  kPaperSizeB0 = 14366
  kPaperSizeB1 = 14362
  kPaperSizeB2 = 14363
  kPaperSizeB3 = 14364
  kPaperSizeB4 = 14344
  kPaperSizeB5 = 14345
  kPaperSizeB6 = 14367
  kPaperSizeCSheet = 14346
  kPaperSizeDSheet = 14347
  kPaperSizeESheet = 14348
  kPaperSizeExecutive = 14349
  kPaperSizeFolio = 14350
  kPaperSizeLedger = 14351
  kPaperSizeLegal = 14352
  kPaperSizeLetter = 14353
  kPaperSizeQuarto = 14354
  kPaperSizeCustom = 14355
  kPaperSizeDefault = 14356
End Enum
Members
Members | Description
kPaperSize10x14 | Paper size 10x14.
kPaperSize11x17 | Paper size 11x17.
kPaperSizeA0 | Paper size A0.
kPaperSizeA0Oversize | Oversize A0.
kPaperSizeA1 | Paper size A1.
kPaperSizeA1Oversize | Oversize A1.
kPaperSizeA2 | Paper size A2.
kPaperSizeA2Oversize | Oversize A2.
kPaperSizeA3 | Paper size A3.
kPaperSizeA4 | Paper size A4.
kPaperSizeA4Small | Paper size A4 small.
kPaperSizeA5 | Paper size A5.
kPaperSizeB1 | Paper size B1.
kPaperSizeB2 | Papersize B2.
kPaperSizeB3 | Papersize B3.
kPaperSizeB4 | Paper size B4.
kPaperSizeB5 | Paper size B5.
kPaperSizeCSheet | Paper size C sheet.
kPaperSizeDSheet | Paper size D sheet.
kPaperSizeESheet | Paper size E sheet.
kPaperSizeExecutive | Paper size executive.
kPaperSizeFolio | Paper size folio.
kPaperSizeLedger | Paper size ledger.
kPaperSizeLegal | Paper size legal.
kPaperSizeLetter | Paper size letter.
kPaperSizeQuarto | Paper size quarto.
kPaperSizeCustom | Paper size custom.
kPaperSizeDefault | Paper size default.
Notes

Members through which this object may be accessed include:

ApprenticePrintManager.PaperSize

PrintManager.PaperSize

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PaperSizeEnum Enumeration


Inventor.ParameterDisplayFormatEnum Enumeration

Inventor.ParameterDisplayFormatEnum Enumeration
Summary

This is record Inventor::ParameterDisplayFormatEnum.

Visual Basic
Public Enum ParameterDisplayFormatEnum
  kDecimalDisplayFormat = 92417
  kFractionalDisplayFormat = 92418
  kArchitecturalDisplayFormat = 92419
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ParameterDisplayFormatEnum Enumeration


Inventor.ParameterTypeEnum Enumeration

Inventor.ParameterTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate parameter types.

Visual Basic
Public Enum ParameterTypeEnum
  kModelParameter = 11521
  kReferenceParameter = 11522
  kTableParameter = 11523
  kUserParameter = 11524
  kDerivedParameter = 11525
End Enum
Members
Members | Description
kModelParameter | Parameter created automatically by Autodesk Inventor when a command requires it.
kReferenceParameter | Parameter created automatically by Autodesk Inventor while creating a driven dimension, for example.
kTableParameter | Parameters created from a table; like a spreadsheet.
kUserParameter | Parameters explicitly created by the user.
Notes

Members through which this object may be accessed include:

Parameter.ParameterType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ParameterTypeEnum Enumeration


Inventor.PartFeatureExtentDirectionEnum Enumeration

Inventor.PartFeatureExtentDirectionEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the direction in which a feature extension needs to take place.

Visual Basic
Public Enum PartFeatureExtentDirectionEnum
  kPositiveExtentDirection = 20993
  kNegativeExtentDirection = 20994
  kSymmetricExtentDirection = 20995
End Enum
Members
Members | Description
kPositiveExtentDirection | Extension in the positive direction.
kNegativeExtentDirection | Extension in the negative direction.
kSymmetricExtentDirection | Extension in positive AND negative direction.
Notes

Members through which this object may be accessed include:

AngleExtent.Direction

BendPartFeature.BendSide

ContourFlangeDefinition.ExtentDirection

DistanceExtent.Direction

DistanceHeightExtent.FlangeDirection

EmbossFeature.Direction

FaceFeatureDefinition.Direction

FromToExtent.Direction

LegacyDistanceHeightExtent.FlangeDirection

LoftedFlangeDefinition.ExtentDirection

PointToPointRipTypeDef.GapSide

SculptSurface.Direction

SinglePointRipTypeDef.GapSide

ThickenFeature.Direction

ThroughAllExtent.Direction

ToExtent.Direction

ToNextExtent.Direction

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PartFeatureExtentDirectionEnum Enumeration


Inventor.PartFeatureExtentEnum Enumeration

Inventor.PartFeatureExtentEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the type of Boolean operation to be performed during this feature placement.

Visual Basic
Public Enum PartFeatureExtentEnum
  kDistanceExtent = 20737
  kAngleExtent = 20738
  kFullSweepExtent = 20739
  kToNextExtent = 20740
  kToExtent = 20741
  kFromToExtent = 20742
  kThroughAllExtent = 20743
  kPitchAndRevolutionCoilExtent = 20744
  kRevolutionAndHeightCoilExtent = 20745
  kPitchAndHeightCoilExtent = 20746
  kSpiralCoilExtent = 20747
  kFlangeDistanceExtent = 20748
  kFlangeToExtent = 20749
  kFlangeLegacyDistanceExtent = 20750
  kEdgeWidthExtent = 20751
  kWidthOffsetWidthExtent = 20752
  kOffsetWidthExtent = 20753
  kFromToWidthExtent = 20754
  kCenteredWidthExtent = 20755
  kCutAcrossBendsExtent = 20756
End Enum
Members
Members | Description
kDistanceExtent | Extent specified by a distance.
kAngleExtent | Extent specified by an angle.
kFullSweepExtent | Extent specified as 360-degree angle.
kToNextExtent | Extent specified by extending to the next face encountered.
kToExtent | Extent specified by a surface to extend to.
kFromToExtent | Extent specified on both ends by a surface to extend from and to extend to.
kThroughAllExtent | Extent specified as going through all faces encountered.
kPitchAndRevolutionCoilExtent | Coil Extent specified by pitch and revolution.
kRevolutionAndHeightCoilExtent | Coil extent specified by revolution and height.
kPitchAndHeightCoilExtent | Coil Extent specified by pitch and height.
kSpiralCoilExtent | Coil extent specified by a spiral.
Notes

Members through which this object may be accessed include:

CoilFeature.ExtentType

ContourFlangeDefinition.WidthExtentType

CutDefinition.ExtentType

ExtrudeFeature.ExtentTwoType

ExtrudeFeature.ExtentType

FlangeDefinition.HeightExtentType

FlangeDefinition.WidthExtentType

HemDefinition.WidthExtentType

HoleFeature.ExtentType

RevolveFeature.ExtentTwoType

RevolveFeature.ExtentType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PartFeatureExtentEnum Enumeration


Inventor.PartFeatureOperationEnum Enumeration

Inventor.PartFeatureOperationEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the type of Boolean operation to be performed during this feature placement.

Visual Basic
Public Enum PartFeatureOperationEnum
  kJoinOperation = 20481
  kCutOperation = 20482
  kIntersectOperation = 20483
  kSurfaceOperation = 20484
  kNewBodyOperation = 20485
End Enum
Members
Members | Description
kJoinOperation | Join operation.
kCutOperation | Cut operation.
kIntersectOperation | Intersect operation.
kSurfaceOperation | Surface operation.
Notes

Members through which this object may be accessed include:

CoilFeature.Operation

CombineFeature.Operation

ExtrudeFeature.Operation

LoftDefinition.Operation

LoftFeature.Operation

RevolveFeature.Operation

SculptFeature.Operation

SweepFeature.Operation

ThickenFeature.Operation

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PartFeatureOperationEnum Enumeration


Inventor.PartsListFileFormatEnum Enumeration

Inventor.PartsListFileFormatEnum Enumeration Introduced in Inventor 9
Summary

PartsList File Format Enum

Visual Basic
Public Enum PartsListFileFormatEnum
  kMicrosoftAccess = 48641
  kMicrosoftExcel = 48642
  kdBASEIII = 48643
  kdBASEIV = 48644
  kTextFileTabDelimited = 48646
  kTextFileCommaDelimited = 48647
  kUnicodeTextFileTabDelimited = 48648
  kUnicodeTextFileCommaDelimited = 48649
End Enum
Members
Members | Description
kMicrosoftAccess | Microsoft Access
kMicrosoftExcel | Microsoft Excel
kdBASEIII | dBASE III
kdBASEIV | dBASE IV
kTextFileTabDelimited | Text File Tab Delimited
kTextFileCommaDelimited | Text File Comma Delimited
kUnicodeTextFileTabDelimited | Unicode Text File Tab Delimited
kUnicodeTextFileCommaDelimited | Unicode Text File Comma Delimited
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PartsListFileFormatEnum Enumeration


Inventor.PartsListLevelEnum Enumeration

Inventor.PartsListLevelEnum Enumeration Introduced in Inventor 9
Summary

PartsListLevel

Visual Basic
Public Enum PartsListLevelEnum
  kStructured = 46593
  kPartsOnly = 46594
  kStructuredAllLevels = 46595
End Enum
Members
Members | Description
kPartsOnly | Parts only
Notes

Members through which this object may be accessed include:

DrawingBOM.Level

PartsList.Level

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PartsListLevelEnum Enumeration


Inventor.PatternComputeTypeEnum Enumeration

Inventor.PatternComputeTypeEnum Enumeration Introduced in Inventor 9
Summary

Constants identifying the pattern compute type

Visual Basic
Public Enum PatternComputeTypeEnum
  kIdenticalCompute = 47361
  kAdjustToModelCompute = 47362
  kOptimizedCompute = 47363
End Enum
Members
Members | Description
kIdenticalCompute | All occurrences are created identically
kAdjustToModelCompute | Creation of occurrences adjusted to model
kOptimizedCompute | Optimized creation
Notes

Members through which this object may be accessed include:

CircularPatternFeature.ComputeType

MirrorFeature.ComputeType

RectangularPatternFeature.ComputeType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PatternComputeTypeEnum Enumeration


Inventor.PatternOrientationEnum Enumeration

Inventor.PatternOrientationEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying the pattern orientation method.

Visual Basic
Public Enum PatternOrientationEnum
  kIdentical = 33793
  kAdjustToDirection1 = 33794
  kAdjustToDirection2 = 33795
End Enum
Members
Members | Description
kIdentical | All occurrences are oriented identically.
kAdjustToDirection1 | Orientation of occurrences adjusted to direction 1.
kAdjustToDirection2 | Orientation of occurrences adjusted to direction 2.
Notes

Members through which this object may be accessed include:

RectangularPatternFeature.OrientationMethod

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PatternOrientationEnum Enumeration


Inventor.PatternSpacingTypeEnum Enumeration

Inventor.PatternSpacingTypeEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying the pattern spacing type.

Visual Basic
Public Enum PatternSpacingTypeEnum
  kDefault = 33537
  kFitted = 33538
  kFitToPathLength = 33539
End Enum
Members
Members | Description
kDefault | Occurrences separated by specified distance.
kFitted | All occurrences fitted within specified distance.
kFitToPathLength | All occurrences fitted within path length.
Notes

Members through which this object may be accessed include:

RectangularPatternFeature.XDirectionSpacingType

RectangularPatternFeature.YDirectionSpacingType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PatternSpacingTypeEnum Enumeration


Inventor.PhysicalPropertyEnum Enumeration

Inventor.PhysicalPropertyEnum Enumeration
Summary

This is record Inventor::PhysicalPropertyEnum.

Visual Basic
Public Enum PhysicalPropertyEnum
  kPhysicalModelMass = 72449
  kPhysicalModelArea = 72450
  kPhysicalModelVolume = 72451
  kPhysicalModelDensity = 72452
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PhysicalPropertyEnum Enumeration


Inventor.PointInferenceEnum Enumeration

Inventor.PointInferenceEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the enumerations of the PointInference object.

Visual Basic
Public Enum PointInferenceEnum
  kPtAtIntersection = 22273
  kPtOnCurve = 22274
  kPtOnPt = 22275
  kPtAtMidPoint = 22276
End Enum
Members
Members | Description
kPtAtIntersection | Inference point at an intersection.
kPtOnCurve | Inference point on a curve.
kPtOnPt | Inference point on a point.
kPtAtMidPoint | Inference point at the midpoint of an object.
Notes

Members through which this object may be accessed include:

PointInference.InferenceType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PointInferenceEnum Enumeration


Inventor.PointIntentEnum Enumeration

Inventor.PointIntentEnum Enumeration
Summary

This is record Inventor::PointIntentEnum.

Visual Basic
Public Enum PointIntentEnum
  kStartPointIntent = 57857
  kEndPointIntent = 57858
  kMidPointIntent = 57859
  kCenterPointIntent = 57860
  kCircularLeftPointIntent = 57861
  kCircularRightPointIntent = 57862
  kCircularTopPointIntent = 57863
  kCircularBottomPointIntent = 57864
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PointIntentEnum Enumeration


Inventor.PointRenderStyleEnum Enumeration

Inventor.PointRenderStyleEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the type of rendering to be performed on a point graphics primitive.

Visual Basic
Public Enum PointRenderStyleEnum
  kXPointStyle = 20225
  kCirclePointStyle = 20226
  kDimCircularPointStyle = 20227
  kFilledCirclePointStyle = 20228
  kFilledCircleSelectPointStyle = 20229
  kCrossPointStyle = 20230
  kFilledCrossPointStyle = 20231
  kOnCurvePointStyle = 20232
  kNoSnapPointStyle = 20233
  kEndPointStyle = 20234
  kCustomImagePointStyle = 20235
End Enum
Members
Members | Description
kXPointStyle | Point rendered as an X.
kCirclePointStyle | Point rendered as a circular dot.
kDimCircularPointStyle | Point rendered as a special dimension circle.
kFilledCirclePointStyle | Point rendered as a filled circle.
kFilledCircleSelectPointStyle | Point rendered as a special filled circle during selection.
kCrossPointStyle | Point rendered as a cross.
kFilledCrossPointStyle | Point rendered as a filled cross.
kOnCurvePointStyle | Point rendered as if on a curve.
kNoSnapPointStyle | Point rendered as a No-Snap point.
kEndPointStyle | Point rendered as an end-point of an entity.
Notes

Members through which this object may be accessed include:

PointGraphics.PointRenderStyle

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PointRenderStyleEnum Enumeration


Inventor.PrefixAndSuffixOrderEnum Enumeration

Inventor.PrefixAndSuffixOrderEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the location of prefix and suffix

Visual Basic
Public Enum PrefixAndSuffixOrderEnum
  kBeforeAndAfter = 42497
  kAboveAndBelow = 42498
End Enum
Members
Members | Description
kBeforeAndAfter | The location of prefix and suffix to be before and after the text
kAboveAndBelow | The location of prefix and suffix to be above and below the text
Notes

Members through which this object may be accessed include:

DimensionStyle.PrefixAndSuffixOrder

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PrefixAndSuffixOrderEnum Enumeration


Inventor.PrintColorModeEnum Enumeration

Inventor.PrintColorModeEnum Enumeration Introduced in Inventor 5
Summary

Constants denoting the color mode being used.

Visual Basic
Public Enum PrintColorModeEnum
  kPrintColorPalette = 13313
  kPrintGrayScale = 13314
  kPrintDefaultColorMode = 13315
End Enum
Members
Members | Description
kPrintColorPalette | Print using color.
kPrintGrayScale | Print using a gray scale.
kPrintDefaultColorMode | Default setting for color mode.
Notes

Members through which this object may be accessed include:

ApprenticePrintManager.ColorMode

PrintManager.ColorMode

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PrintColorModeEnum Enumeration


Inventor.PrintOrientationEnum Enumeration

Inventor.PrintOrientationEnum Enumeration Introduced in Inventor 5
Summary

Constants denoting the orientation of the print.

Visual Basic
Public Enum PrintOrientationEnum
  kPortraitOrientation = 13569
  kLandscapeOrientation = 13570
  kDefaultOrientation = 13571
End Enum
Members
Members | Description
kPortraitOrientation | Print with portrait orientation.
kLandscapeOrientation | Print with landscape orientation.
kDefaultOrientation | Default setting for print orientation.
Notes

Members through which this object may be accessed include:

ApprenticePrintManager.Orientation

PrintManager.Orientation

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PrintOrientationEnum Enumeration


Inventor.PrintRangeEnum Enumeration

Inventor.PrintRangeEnum Enumeration Introduced in Inventor 5
Summary

Constants enumerating the methods of specifying the range of sheets to be printed.

Visual Basic
Public Enum PrintRangeEnum
  kPrintCurrentSheet = 14081
  kPrintAllSheets = 14082
  kPrintSheetRange = 14083
End Enum
Members
Members | Description
kPrintCurrentSheet | Print the current sheet in the drawing.
kPrintAllSheets | Print all sheets of the drawing.
kPrintSheetRange | Print the sheets specified in a range elsewhere.
Notes

Members through which this object may be accessed include:

ApprenticeDrawingPrintManager.PrintRange

DrawingPrintManager.PrintRange

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PrintRangeEnum Enumeration


Inventor.PrintScaleModeEnum Enumeration

Inventor.PrintScaleModeEnum Enumeration Introduced in Inventor 5
Summary

Constants enumerating the methods of specifying the scale of the print.

Visual Basic
Public Enum PrintScaleModeEnum
  kPrintFullScale = 13825
  kPrintBestFitScale = 13826
  kPrintCustomScale = 13827
  kPrintCurrentWindow = 13828
End Enum
Members
Members | Description
kPrintFullScale | Print using full scale of the drawing.
kPrintBestFitScale | Print using a best-fit scale for the drawing.
kPrintCustomScale | Print using the custom scale specified elsewhere.
kPrintCurrentWindow | Print the contents of the window as-is.
Notes

Members through which this object may be accessed include:

ApprenticeDrawingPrintManager.ScaleMode

DrawingPrintManager.ScaleMode

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PrintScaleModeEnum Enumeration


Inventor.PrivateEventTypeEnum Enumeration

Inventor.PrivateEventTypeEnum Enumeration Introduced in Inventor 4
Summary

Semantic description of data on Autodesk Inventor's private event queue.

Visual Basic
Public Enum PrivateEventTypeEnum
  kFileNameEvent = 6657
  kNameEvent = 6658
  kDimensionEvent = 6659
  kStringEvent = 6660
  kCommandNameEvent = 6661
End Enum
Members
Members | Description
kFileNameEvent | String event corresponding to a filename.
kNameEvent | String event corresponding to a name.
kDimensionEvent | Float event corresponding to a dimensional value.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PrivateEventTypeEnum Enumeration


Inventor.ProductEditionEnum Enumeration

Inventor.ProductEditionEnum Enumeration
Summary

This is record Inventor::ProductEditionEnum.

Visual Basic
Public Enum ProductEditionEnum
  kProductEditionInventorLT = 76545
  kProductEditionInventorSuite = 76546
  kProductEditionInventorProfessional = 76547
  kProductEditionInventorRoutedSystems = 76548
  kProductEditionInventorSimulation = 76549
  kProductEditionInventorTooling = 76550
  kProductEditionInventor = 76551
  kProductEditionInventorFactoryPremium = 76552
  kProductEditionInventorFactoryAdvanced = 76553
  kProductEditionInventorOEM = 76554
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ProductEditionEnum Enumeration


Inventor.ProjectionTypeEnum Enumeration

Inventor.ProjectionTypeEnum Enumeration
Summary

This is record Inventor::ProjectionTypeEnum.

Visual Basic
Public Enum ProjectionTypeEnum
  kOrthographicProjection = 86273
  kPerspectiveProjection = 86274
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ProjectionTypeEnum Enumeration


Inventor.PromptMessageRestrictionsEnum Enumeration

Inventor.PromptMessageRestrictionsEnum Enumeration
Summary

This is record Inventor::PromptMessageRestrictionsEnum.

Visual Basic
Public Enum PromptMessageRestrictionsEnum
  kNoRestrictions = 0
  kDontAllowNeverAgain = 1
  kDontAllowNoMoreThisSession = 2
  kDontAllowButton1NeverAgain = 8
  kDontAllowButton1NoMoreThisSession = 16
  kDontAllowButton2NeverAgain = 64
  kDontAllowButton2NoMoreThisSession = 128
  kDontAllowButton3NeverAgain = 512
  kDontAllowButton3NoMoreThisSession = 1024
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PromptMessageRestrictionsEnum Enumeration


Inventor.PropertyTypeEnum Enumeration

Inventor.PropertyTypeEnum Enumeration Introduced in Inventor 9
Summary

PropertyType

Visual Basic
Public Enum PropertyTypeEnum
  kFileProperty = 45569
  kCustomProperty = 45570
  kFilenamePartsListProperty = 45571
  kItemPartsListProperty = 45572
  kMassPartsListProperty = 45573
  kMaterialPartsListProperty = 45574
  kQuantityPartsListProperty = 45575
  kBaseQuantityPartsListProperty = 45576
  kBaseUnitPartsListProperty = 45577
  kItemQuantityPartsListProperty = 45578
  kUnitQuantityPartsListProperty = 45579
End Enum
Members
Members | Description
kFileProperty | File property
kCustomProperty | Custom property
kFilenamePartsListProperty | Filename property
kItemPartsListProperty | Item property
kMassPartsListProperty | Mass property
kMaterialPartsListProperty | Material property
kQuantityPartsListProperty | Quantity property
Notes

Members through which this object may be accessed include:

DrawingBOMColumn.PropertyType

PartsListColumn.PropertyType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.PropertyTypeEnum Enumeration


Inventor.PunchNoteQuantityEnum Enumeration

Inventor.PunchNoteQuantityEnum Enumeration
Summary

This is record Inventor::PunchNoteQuantityEnum.

Visual Basic
Public Enum PunchNoteQuantityEnum
  kNumberOfLikePunchesInFeature = 83713
  kNumberOfLikePunchesInModel = 83714
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PunchNoteQuantityEnum Enumeration


Inventor.PunchRepresentationTypeEnum Enumeration

Inventor.PunchRepresentationTypeEnum Enumeration
Summary

This is record Inventor::PunchRepresentationTypeEnum.

Visual Basic
Public Enum PunchRepresentationTypeEnum
  kDefaultPunchRepresentation = 64513
  kFormedFeaturePunchRepresentation = 64514
  k2DSketchPunchRepresentation = 64515
  kCentermarkPunchRepresentation = 64516
  k2DSketchAndCenterMarkPunchRepresentation = 64517
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.PunchRepresentationTypeEnum Enumeration


Inventor.RayTracingQualityEnum Enumeration

Inventor.RayTracingQualityEnum Enumeration
Summary

This is record Inventor::RayTracingQualityEnum.

Visual Basic
Public Enum RayTracingQualityEnum
  kInteractiveRayTracingQuality = 95745
  kGoodRayTracingQuality = 95746
  kBestRayTracingQuality = 95747
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RayTracingQualityEnum Enumeration


Inventor.ReferenceMonitoringEnum Enumeration

Inventor.ReferenceMonitoringEnum Enumeration
Summary

This is record Inventor::ReferenceMonitoringEnum.

Visual Basic
Public Enum ReferenceMonitoringEnum
  kNoMonitor = 90625
  kMonitorAndEnableUpdate = 90626
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ReferenceMonitoringEnum Enumeration


Inventor.ReferenceStatusEnum Enumeration

Inventor.ReferenceStatusEnum Enumeration Introduced in Inventor 9
Summary

Constants signifying the state of the File Reference

Visual Basic
Public Enum ReferenceStatusEnum
  kUnknownReference = 49665
  kUpToDateReference = 49666
  kOutOfDateReference = 49667
  kMissingReference = 49668
  kReplacedReference = 49669
End Enum
Members
Members | Description
kUnknownReference | File's status is not known
kUpToDateReference | File reference is up to date
kOutOfDateReference | File reference is out of date as the referenced file has changed
kMissingReference | File is either missing or can not be found at its location.
kReplacedReference | File reference has been replaced with another file.
Notes

Members through which this object may be accessed include:

ApprenticeServerDocument.SubstitutePartStatus

PartDocument.SubstitutePartStatus

ReferencedFileDescriptor.ReferenceStatus

ReferencedOLEFileDescriptor.ReferenceStatus

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ReferenceStatusEnum Enumeration


Inventor.RevisionTablePropertyEnum Enumeration

Inventor.RevisionTablePropertyEnum Enumeration
Summary

This is record Inventor::RevisionTablePropertyEnum.

Visual Basic
Public Enum RevisionTablePropertyEnum
  kRevisionTableFileProperty = 89345
  kRevisionTableCustomProperty = 89346
  kRevisionTableDateProperty = 89347
  kRevisionTableSheetProperty = 89348
  kRevisionTableZoneProperty = 89349
  kRevisionTableZoneSheetProperty = 89350
  kRevisionTableLtrProperty = 89351
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RevisionTablePropertyEnum Enumeration


Inventor.RevisionTagShapeEnum Enumeration

Inventor.RevisionTagShapeEnum Enumeration
Summary

This is record Inventor::RevisionTagShapeEnum.

Visual Basic
Public Enum RevisionTagShapeEnum
  kCircularRevisionTag = 89089
  kHexagonRevisionTag = 89090
  kSquareRevisionTag = 89091
  kTriangularRevisionTag = 89092
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RevisionTagShapeEnum Enumeration


Inventor.RibbonAppearanceEnum Enumeration

Inventor.RibbonAppearanceEnum Enumeration
Summary

This is record Inventor::RibbonAppearanceEnum.

Visual Basic
Public Enum RibbonAppearanceEnum
  kNormal = 82945
  kAllTextOff = 82946
  kSmall = 82947
  kCompact = 82948
  kLarge = 82949
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RibbonAppearanceEnum Enumeration


Inventor.RibbonDockingStateEnum Enumeration

Inventor.RibbonDockingStateEnum Enumeration
Summary

This is record Inventor::RibbonDockingStateEnum.

Visual Basic
Public Enum RibbonDockingStateEnum
  kFloating = 85761
  kDockToTop = 85762
  kDockToLeft = 85763
  kDockToRight = 85764
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RibbonDockingStateEnum Enumeration


Inventor.RibbonStateEnum Enumeration

Inventor.RibbonStateEnum Enumeration
Summary

This is record Inventor::RibbonStateEnum.

Visual Basic
Public Enum RibbonStateEnum
  kFullRibbon = 83201
  kMinimizeToTabs = 83202
  kMinimizeToPanelTitles = 83203
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RibbonStateEnum Enumeration


Inventor.RibFeatureExtentEnum Enumeration

Inventor.RibFeatureExtentEnum Enumeration
Summary

This is record Inventor::RibFeatureExtentEnum.

Visual Basic
Public Enum RibFeatureExtentEnum
  kFiniteRibExtent = 93697
  kToNextRibExtent = 93698
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RibFeatureExtentEnum Enumeration


Inventor.RibThicknessPlaneEnum Enumeration

Inventor.RibThicknessPlaneEnum Enumeration
Summary

This is record Inventor::RibThicknessPlaneEnum.

Visual Basic
Public Enum RibThicknessPlaneEnum
  kRibThicknessAtSketchPlane = 93953
  kRibThicknessAtRoot = 93954
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RibThicknessPlaneEnum Enumeration


Inventor.RigidBodyJointTypeEnum Enumeration

Inventor.RigidBodyJointTypeEnum Enumeration
Summary

This is record Inventor::RigidBodyJointTypeEnum.

Visual Basic
Public Enum RigidBodyJointTypeEnum
  kAngleVectorVectorJoint = 68097
  kMatePointPointJoint = 68098
  kMatePointLineJoint = 68099
  kMateLineLineJoint = 68100
  kMateCylinderCylinderJoint = 68101
  kMateSphereSphereJoint = 68102
  kMateSphereConeJoint = 68103
  kMateConeConeJoint = 68104
  kMatePointCurveJoint = 68105
  kMatePointCircleJoint = 68106
  kMatePointSurfaceJoint = 68107
  kMateCurveCurveJoint = 68108
  kConCentricCircleCircleJoint = 68109
  kDistancePointPointJoint = 68110
  kDistancePointLineJoint = 68111
  kDistancePointPlaneJoint = 68112
  kDistanceLineLineJoint = 68113
  kDistanceLinePlaneJoint = 68114
  kDistancePlanePlaneJoint = 68115
  kEqualDistancePointPlaneJoint = 68116
  kEqualDistancePlanePlaneJoint = 68117
  kTangentPlaneCylinderJoint = 68118
  kTangentCylinderCylinderJoint = 68119
  kTangentCylinderSphereJoint = 68120
  kTangentSphereSphereJoint = 68121
  kTangentPlaneConeJoint = 68122
  kTangentCylinderConeJoint = 68123
  kTangentSphereConeJoint = 68124
  kTangentConeConeJoint = 68125
  kTangentPlaneCircleJoint = 68126
  kTangentCircleCylinderJoint = 68127
  kTangentLineCylinderJoint = 68128
  kTangentCircleCircleJoint = 68129
  kTangentLineSphereJoint = 68130
  kTangentLineCircleJoint = 68131
  kTangentCurveSurfaceJoint = 68132
  kTangentSurfaceSurfaceJoint = 68133
  kPerpendicularCurveSurfaceJoint = 68134
  kRevoluteJoint = 68136
  kTranslationalJoint = 68135
  kGearJoint = 68138
  kTransitionalJoint = 68137
  kWireframeWireframeJoint = 68139
  kWeldJoint = 68140
  kUniversalJoint = 68141
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RigidBodyJointTypeEnum Enumeration


Inventor.RipTypeEnum Enumeration

Inventor.RipTypeEnum Enumeration
Summary

This is record Inventor::RipTypeEnum.

Visual Basic
Public Enum RipTypeEnum
  kSinglePointRipType = 90881
  kPointToPointRipType = 90882
  kFaceExtentsRipType = 90883
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RipTypeEnum Enumeration


Inventor.RowMergeTypeEnum Enumeration

Inventor.RowMergeTypeEnum Enumeration
Summary

This is record Inventor::RowMergeTypeEnum.

Visual Basic
Public Enum RowMergeTypeEnum
  kNoRowMerge = 77313
  kRollupRowMerge = 77314
  kCombineNotesRowMerge = 77315
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.RowMergeTypeEnum Enumeration


Inventor.SelectionDeviceEnum Enumeration

Inventor.SelectionDeviceEnum Enumeration Introduced in Inventor 5
Summary

Enumeration of the kind of UI used to select object.

Visual Basic
Public Enum SelectionDeviceEnum
  kGraphicsWindowSelection = 15361
  kBrowserSelection = 15362
  kNameSelection = 15363
  kUnknownSelection = 15364
End Enum
Members
Members | Description
kGraphicsWindowSelection | Selection made by pick in a graphics window.
kBrowserSelection | Selection made by a pick in a browser.
kNameSelection | Selection made by providing the name of the object.
kUnknownSelection | Selection made by some unknown means.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SelectionDeviceEnum Enumeration


Inventor.SelectionFilterEnum Enumeration

Inventor.SelectionFilterEnum Enumeration Introduced in Inventor 5
Summary

Enumeration of the selection filters.

Visual Basic
Public Enum SelectionFilterEnum
  kPartEdgeFilter = 15873
  kPartEdgeCircularFilter = 15874
  kPartEdgeLinearFilter = 15875
  kPartEdgeMidpointFilter = 15876
  kPartFaceFilter = 15877
  kPartFacePlanarFilter = 15878
  kPartFaceCylindricalFilter = 15879
  kPartFaceConicalFilter = 15880
  kPartFaceToroidalFilter = 15881
  kPartFaceSphericalFilter = 15882
  kPartVertexFilter = 15883
  kPartFeatureFilter = 15884
  kPartSurfaceFeatureFilter = 15885
  kPartBodyFilter = 15890
  kPartDefaultFilter = 15886
  kSketchDimConstraintFilter = 16128
  kSketchCurveFilter = 16129
  kSketchCurveLinearFilter = 16130
  kSketchCurveCircularFilter = 16131
  kSketchCurveEllipseFilter = 16132
  kSketchCurveSplineFilter = 16133
  kSketchPointFilter = 16134
  kSketchDefaultFilter = 16135
  kSketchObjectFilter = 16136
  kSketchImageFilter = 16137
  kSketchTextBoxFilter = 16138
  kSketchProfileFilter = 16139
  kSketchProjectedCutFilter = 16140
  kSketchBlockDefinitionFilter = 16141
  kSketchBlockFilter = 16142
  kSketch3DCurveFilter = 17664
  kSketch3DCurveLinearFilter = 17665
  kSketch3DCurveCircularFilter = 17666
  kSketch3DCurveEllipseFilter = 17667
  kSketch3DCurveSplineFilter = 17668
  kSketch3DPointFilter = 17669
  kSketch3DDefaultFilter = 17670
  kSketch3DObjectFilter = 17671
  kSketch3DDimConstraintFilter = 17672
  kSketch3DProfileFilter = 17673
  kWorkAxisFilter = 16384
  kWorkPlaneFilter = 16385
  kWorkPointFilter = 16386
  kUserCoordinateSystemFilter = 16387
  kAssemblyOccurrenceFilter = 16640
  kAssemblyLeafOccurrenceFilter = 16643
  kAssemblyOccurrencePatternFilter = 16644
  kAssemblyOccurrencePatternElementFilter = 16645
  kAssemblyFeatureFilter = 16646
  kAllPlanarEntities = 18432
  kAllLinearEntities = 18433
  kAllPointEntities = 18434
  kAllCircularEntities = 18435
  kAllCustomGraphicsFilter = 18436
  kCustomBrowserNodeFilter = 18437
  kFeatureDimensionFilter = 18438
  kAllEntitiesFilter = 18439
  kDrawingDefaultFilter = 16896
  kDrawingSheetFilter = 16897
  kDrawingViewFilter = 16898
  kDrawingNoteFilter = 16899
  kDrawingDimensionFilter = 16900
  kDrawingPartsListFilter = 16901
  kDrawingHoleTableFilter = 16902
  kDrawingHoleTagFilter = 16903
  kDrawingRevisionTableFilter = 16904
  kDrawingCustomTableFilter = 16905
  kDrawingBalloonFilter = 16906
  kDrawingSketchedSymbolFilter = 16907
  kDrawingSketchedSymbolDefinitionFilter = 16908
  kDrawingAutoCADBlockFilter = 16922
  kDrawingAutoCADBlockDefinitionFilter = 16923
  kDrawingBorderDefinitionFilter = 16909
  kDrawingTitleBlockDefinitionFilter = 16910
  kDrawingBorderFilter = 16913
  kDrawingTitleBlockFilter = 16912
  kDrawingCurveSegmentFilter = 16914
  kDrawingCenterlineFilter = 16915
  kDrawingCentermarkFilter = 16916
  kDrawingSheetFormatFilter = 16917
  kDrawingFeatureControlFrameFilter = 16918
  kDrawingSurfaceTextureSymbolFilter = 16919
  kDrawingOriginIndicatorFilter = 16920
  kDrawingViewLabelFilter = 16921
End Enum
Members
Members | Description
kPartEdgeFilter | Part edge filter.
kPartEdgeCircularFilter | Part edge circular filter.
kPartEdgeLinearFilter | Part edge linear filter.
kPartEdgeMidpointFilter | Part edge midpoint filter.
kPartFaceFilter | Part face filter.
kPartFacePlanarFilter | Part face planar filter.
kPartFaceCylindricalFilter | Part face cylindrical filter.
kPartFaceConicalFilter | Part face conical filter.
kPartFaceToroidalFilter | Part face toroidal filter.
kPartFaceSphericalFilter | Part face spherical filter.
kPartVertexFilter | Part vertex filter.
kPartFeatureFilter | Part feature filter.
kPartSurfaceFeatureFilter | Part surface feature filter.
kPartDefaultFilter | Part default filter.
kSketchDimConstraintFilter | Sketch dimension constraint filter.
kSketchCurveFilter | Sketch curve filter.
kSketchCurveLinearFilter | Sketch curve linear filter.
kSketchCurveCircularFilter | Sketch curve circular filter.
kSketchCurveEllipseFilter | Sketch curve ellipse filter.
kSketchCurveSplineFilter | Sketch curve spline filter.
kSketchPointFilter | Sketch point filter.
kSketchDefaultFilter | Sketch default filter.
kSketchObjectFilter | Sketch filter.
kSketch3DCurveFilter | 3D Sketch curve filter.
kSketch3DCurveLinearFilter | 3D Sketch curve linear filter.
kSketch3DCurveCircularFilter | 3D Sketch curve circular filter.
kSketch3DCurveEllipseFilter | 3D Sketch curve ellipse filter.
kSketch3DCurveSplineFilter | 3D Sketch curve spline filter.
kSketch3DPointFilter | 3D Sketch point filter.
kSketch3DDefaultFilter | 3D Sketch default filter.
kSketch3DObjectFilter | 3D Sketch filter.
kWorkAxisFilter | Work axis filter.
kWorkPlaneFilter | Work plane filter.
kWorkPointFilter | Work point filter.
kAssemblyOccurrenceFilter | Assembly occurrence filter.
kAssemblyLeafOccurrenceFilter | Assembly leaf occurrence filter.
kAssemblyOccurrencePatternFilter | Assembly occurrence pattern filter.
kAssemblyOccurrencePatternElementFilter | Assembly occurrence pattern element filter.
kAllPlanarEntities | All planar entities filter.
kAllLinearEntities | All linear entities filter.
kAllPointEntities | All point entities filter.
kAllCircularEntities | All circular entities filter.
kAllCustomGraphicsFilter | All custom graphics.
kCustomBrowserNodeFilter | Custom browser node
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SelectionFilterEnum Enumeration


Inventor.SelectionPriorityEnum Enumeration

Inventor.SelectionPriorityEnum Enumeration
Summary

This is record Inventor::SelectionPriorityEnum.

Visual Basic
Public Enum SelectionPriorityEnum
  kFeatureSelectionPriority = 67585
  kSketchSelectionPriority = 67586
  kEdgeAndFaceSelectionPriority = 67587
  kGroupSelectionPriority = 67588
  kWireSelectionPriority = 67589
  kComponentSelectionPriority = 67590
  kPartSelectionPriority = 67591
  kEdgeSelectionPriority = 67592
  kBodySelectionPriority = 67593
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SelectionPriorityEnum Enumeration


Inventor.SelectPrism Structure

Inventor.SelectPrism Structure
Summary

DMAC structure to hold an attributed selection prism for entity selection.

Visual Basic
Public Structure SelectPrism
  Public m_point As double
  Public m_direction As double
  Public m_front As double
  Public m_back As double
  Public m_nPoints As ULONG
  Public m_pPoints As double*
  Public m_type As DWORD
End Structure
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SelectPrism Structure


Inventor.SelectType Enumeration

Inventor.SelectType Enumeration Available in Inventor Available in Server Introduced in Inventor 4
Summary

DMAC list of bit-fields that are used to specify the selection region relative to a shape.

Visual Basic
Public Enum SelectType
  SELECTTYPE_INSIDE = 1
  SELECTTYPE_OVERLAP = 2
End Enum
Members
Members | Description
SELECTTYPE_INSIDE | Select the elements inside the polygon.
SELECTTYPE_OVERLAP | Select elements overlapping either INSIDE or OUTSIDE.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SelectType Enumeration


Inventor.ShadowDirectionEnum Enumeration

Inventor.ShadowDirectionEnum Enumeration
Summary

This is record Inventor::ShadowDirectionEnum.

Visual Basic
Public Enum ShadowDirectionEnum
  k45DegreesLeftShadowDirection = 92161
  k45DegreesRightShadowDirection = 92162
  kAboveShadowDirection = 92163
  kLightOneShadowDirection = 92164
  kLightTwoShadowDirection = 92165
  kLightThreeShadowDirection = 92166
  kLightFourShadowDirection = 92167
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ShadowDirectionEnum Enumeration


Inventor.SheetMetalPropertyEnum Enumeration

Inventor.SheetMetalPropertyEnum Enumeration
Summary

This is record Inventor::SheetMetalPropertyEnum.

Visual Basic
Public Enum SheetMetalPropertyEnum
  kSheetMetalFlatPatternLength = 78849
  kSheetMetalFlatPatternWidth = 78850
  kSheetMetalFlatPatternArea = 78851
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SheetMetalPropertyEnum Enumeration


Inventor.ShellDirectionEnum Enumeration

Inventor.ShellDirectionEnum Enumeration Introduced in Inventor 9
Summary

Enum specifying the shell boundary relative to the part face

Visual Basic
Public Enum ShellDirectionEnum
  kInsideShellDirection = 41217
  kOutsideShellDirection = 41218
  kBothSidesShellDirection = 41219
End Enum
Members
Members | Description
kInsideShellDirection | Offsets the shell wall to the part interior
kOutsideShellDirection | Offsets the shell wall to the exterior of the part
Notes

Members through which this object may be accessed include:

ShellDefinition.Direction

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ShellDirectionEnum Enumeration


Inventor.ShiftStateEnum Enumeration

Inventor.ShiftStateEnum Enumeration Introduced in Inventor 5
Summary

Enumeration of the 'shift' key (SHIFT, CTRL and ALT) combination.

Visual Basic
Public Enum ShiftStateEnum
  kShiftStateNone = 0
  kShiftStateShift = 1
  kShiftStateCtrl = 2
  kShiftStateAlt = 4
  kShiftStateShiftCtrl = 3
  kShiftStateShiftAlt = 5
  kShiftStateCtrlAlt = 6
  kShiftStateShiftCtrlAlt = 7
End Enum
Members
Members | Description
kShiftStateNone | None of the 'shift' keys pressed.
kShiftStateShift | key pressed.
kShiftStateCtrl | key pressed.
kShiftStateAlt | key pressed.
kShiftStateShiftCtrl | keys pressed.
kShiftStateShiftAlt | keys pressed.
kShiftStateCtrlAlt | keys pressed.
kShiftStateShiftCtrlAlt | + keys pressed.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ShiftStateEnum Enumeration


Inventor.ShortcutTypeEnum Enumeration

Inventor.ShortcutTypeEnum Enumeration
Summary

This is record Inventor::ShortcutTypeEnum.

Visual Basic
Public Enum ShortcutTypeEnum
  kNoShortcut = 68353
  kAliasShortcut = 68354
  kAcceleratorShortcut = 68355
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ShortcutTypeEnum Enumeration


Inventor.SketchCreationOnNewPartEnum Enumeration

Inventor.SketchCreationOnNewPartEnum Enumeration
Summary

This is record Inventor::SketchCreationOnNewPartEnum.

Visual Basic
Public Enum SketchCreationOnNewPartEnum
  kNoNewSketchCreation = 55041
  kXYPlaneSketchCreation = 55042
  kYZPlaneSketchCreation = 55043
  kXZPlaneSketchCreation = 55044
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SketchCreationOnNewPartEnum Enumeration


Inventor.SolutionNatureEnum Enumeration

Inventor.SolutionNatureEnum Enumeration Introduced in Inventor 4
Summary

Type that characterizes the result of a solution search.

Visual Basic
Public Enum SolutionNatureEnum
  kUnknownSolutionNature = 0
  kUniqueSolution = 1
  kDistinctlyManySolutions = 2
  kInfinitelyManySolutions = 3
  kNoSolution = 4
End Enum
Members
Members | Description
kUnknownSolutionNature | Could not determine a solution strategy.
kUniqueSolution | There is just the one solution.
kDistinctlyManySolutions | There are distinctly many, equally good solutions.
kInfinitelyManySolutions | There are infinitely many, equally good solutions.
kNoSolution | No solution exists.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SolutionNatureEnum Enumeration


Inventor.SplineFitMethodEnum Enumeration

Inventor.SplineFitMethodEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the fit type of a spline.

Visual Basic
Public Enum SplineFitMethodEnum
  kSmoothSplineFit = 26369
  kSweetSplineFit = 26370
  kACADSplineFit = 26371
End Enum
Members
Members | Description
kSmoothSplineFit | Use the centripetal method of spline fitting.
kSweetSplineFit | Use the minimum energy method of spline fitting.
kACADSplineFit | Use the same method of spline fitting as AutoCAD.
Notes

Members through which this object may be accessed include:

BSplineCurve2dDefinition.FitMethod

BSplineCurveDefinition.FitMethod

SketchOptions.SplineFitMethod

SketchSpline.FitMethod

SketchSpline3D.FitMethod

You are here: Symbol Reference > Inventor Library > Enums > Inventor.SplineFitMethodEnum Enumeration


Inventor.SplitToolTypeEnum Enumeration

Inventor.SplitToolTypeEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying the kind of split tool.

Visual Basic
Public Enum SplitToolTypeEnum
  kPath = 33025
  kWorkPlane = 33026
  kWorkSurface = 33027
  kSurfaceBody = 33028
End Enum
Members
Members | Description
kPath | Path split tool.
kWorkPlane | Work plane split tool.
kWorkSurface | WorkSurface split tool.
Notes

Members through which this object may be accessed include:

SplitFeature.SplitToolType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.SplitToolTypeEnum Enumeration


Inventor.SplitTypeEnum Enumeration

Inventor.SplitTypeEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying the kind of split.

Visual Basic
Public Enum SplitTypeEnum
  kSplitFaces = 32770
  kSplitBody = 32771
  kTrimSolid = 32769
End Enum
Members
Members | Description
kSplitFaces | Split feature caused faces to split.
Notes

Members through which this object may be accessed include:

SplitFeature.SplitType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.SplitTypeEnum Enumeration


Inventor.StandardPartsSectionBehaviorEnum Enumeration

Inventor.StandardPartsSectionBehaviorEnum Enumeration
Summary

This is record Inventor::StandardPartsSectionBehaviorEnum.

Visual Basic
Public Enum StandardPartsSectionBehaviorEnum
  kAlwaysSectionStandardParts = 66561
  kNeverSectionStandardParts = 66562
  kObeyBrowserSettingsSectionStandardParts = 66563
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StandardPartsSectionBehaviorEnum Enumeration


Inventor.StartupActionTypeEnum Enumeration

Inventor.StartupActionTypeEnum Enumeration
Summary

This is record Inventor::StartupActionTypeEnum.

Visual Basic
Public Enum StartupActionTypeEnum
  kFileNewDialogStartupAction = 70913
  kFileOpenDialogStartupAction = 70914
  kNewFileFromTemplateStartupAction = 70915
  kNoStartupAction = 70916
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StartupActionTypeEnum Enumeration


Inventor.StartupHelpFocusTopicEnum Enumeration

Inventor.StartupHelpFocusTopicEnum Enumeration
Summary

This is record Inventor::StartupHelpFocusTopicEnum.

Visual Basic
Public Enum StartupHelpFocusTopicEnum
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StartupHelpFocusTopicEnum Enumeration


Inventor.StorageTypeEnum Enumeration

Inventor.StorageTypeEnum Enumeration Introduced in Inventor 4
Summary

Type to indicate the kind of storage medium being referred to.

Visual Basic
Public Enum StorageTypeEnum
  kUnknownStorage = 6145
  kFileStorage = 6146
  kStreamStorage = 6147
  kFileOrStreamStorage = 6148
  kStorageStorage = 6149
End Enum
Members
Members | Description
kUnknownStorage | Storage medium is unknown.
kFileStorage | Storage medium is a file on a persistent storage device.
kStreamStorage | Storage medium is a Structured Storage Stream (accessed by IStream*).
kFileOrStreamStorage | Storage medium could be either a file or a Structure Storage Stream.
kStorageStorage | Storage medium is a Structured Storage (accessed by IStorage*).
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StorageTypeEnum Enumeration


Inventor.StyleLocationEnum Enumeration

Inventor.StyleLocationEnum Enumeration Introduced in Inventor 9
Summary

Enum for the different style location types

Visual Basic
Public Enum StyleLocationEnum
  kBothStyleLocation = 51201
  kLocalStyleLocation = 51202
  kLibraryStyleLocation = 51203
End Enum
Members
Members | Description
kBothStyleLocation | style is in both local and global locations
kLocalStyleLocation | style is only local
kLibraryStyleLocation | style is only in the library
Notes

Members through which this object may be accessed include:

LightingStyle.StyleLocation

Material.StyleLocation

RenderStyle.StyleLocation

Style.StyleLocation

You are here: Symbol Reference > Inventor Library > Enums > Inventor.StyleLocationEnum Enumeration


Inventor.StylesLibraryAccessEnum Enumeration

Inventor.StylesLibraryAccessEnum Enumeration
Summary

This is record Inventor::StylesLibraryAccessEnum.

Visual Basic
Public Enum StylesLibraryAccessEnum
  kReadOnlyStylesLibraryAccess = 54017
  kReadWriteStylesLibraryAccess = 54018
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StylesLibraryAccessEnum Enumeration


Inventor.StyleSourceTypeEnum Enumeration

Inventor.StyleSourceTypeEnum Enumeration Introduced in Inventor 7
Summary

Render style source type

Visual Basic
Public Enum StyleSourceTypeEnum
  kPartRenderStyle = 37121
  kFeatureRenderStyle = 37122
  kOverrideRenderStyle = 37123
  kWeldBeadRenderStyle = 37124
  kBodyRenderStyle = 37125
End Enum
Members
Members | Description
kPartRenderStyle | The render style of the containing part.
kFeatureRenderStyle | The render style of the containing feature.
kOverrideRenderStyle | A render style override.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StyleSourceTypeEnum Enumeration


Inventor.StyleTypeEnum Enumeration

Inventor.StyleTypeEnum Enumeration
Summary

This is record Inventor::StyleTypeEnum.

Visual Basic
Public Enum StyleTypeEnum
  kStandardStyleType = 71425
  kBalloonStyleType = 71426
  kCentermarkStyleType = 71427
  kDatumTargetStyleType = 71428
  kDimensionStyleType = 71429
  kFeatureControlFrameStyleType = 71430
  kHatchStyleType = 71431
  kHoleTableStyleType = 71432
  kIDStyleType = 71433
  kLayerStyleType = 71434
  kLeaderStyleType = 71435
  kObjectDefaultsStyleType = 71436
  kPartsListStyleType = 71437
  kRevisionTableStyleType = 71438
  kSurfaceTextureStyleType = 71439
  kTableStyleType = 71440
  kTextStyleType = 71441
  kViewAnnotationStyleType = 71444
  kWeldSymbolStyleType = 71442
  kWeldBeadStyleType = 71443
  kSheetMetalStyleType = 71445
  kUnfoldMethodType = 71446
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.StyleTypeEnum Enumeration


Inventor.SurfaceGeometryFormEnum Enumeration

Inventor.SurfaceGeometryFormEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating forms of surface geometry.

Visual Basic
Public Enum SurfaceGeometryFormEnum
  SurfaceGeometryForm_ClosedUVLoops = 1
  SurfaceGeometryForm_Not_ClosedUVLoops = 2
  SurfaceGeometryForm_NURBS = 4
  SurfaceGeometryForm_Not_NURBS = 8
  SurfaceGeometryForm_ProceduralToNURBS = 16
End Enum
Members
Members | Description
SurfaceGeometryForm_ClosedUVLoops | Surface geometry form is closed UV loops.
SurfaceGeometryForm_Not_ClosedUVLoops | Surface geometry form is not closed UV loops.
SurfaceGeometryForm_NURBS | Surface geometry form is NURBS (non-uniform rational B-spline).
SurfaceGeometryForm_Not_NURBS | Surface geometry form is not NURBS (non-uniform rational B-spline).
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SurfaceGeometryFormEnum Enumeration


Inventor.SurfaceTextureTypeEnum Enumeration

Inventor.SurfaceTextureTypeEnum Enumeration
Summary

This is record Inventor::SurfaceTextureTypeEnum.

Visual Basic
Public Enum SurfaceTextureTypeEnum
  kBasicSurfaceType = 76801
  kMaterialRemovalRequiredSurfaceType = 76802
  kMaterialRemovalProhibitedSurfaceType = 76803
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SurfaceTextureTypeEnum Enumeration


Inventor.SurfaceTypeEnum Enumeration

Inventor.SurfaceTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants enumerating the surface types.

Visual Basic
Public Enum SurfaceTypeEnum
  kUnknownSurface = 5889
  kPlaneSurface = 5890
  kCylinderSurface = 5891
  kEllipticalCylinderSurface = 5892
  kConeSurface = 5893
  kEllipticalConeSurface = 5894
  kTorusSurface = 5895
  kSphereSurface = 5896
  kBSplineSurface = 5897
End Enum
Members
Members | Description
kUnknownSurface | Unknown surface type.
kPlaneSurface | Plane surface type.
kCylinderSurface | Cylinder surface type.
kEllipticalCylinderSurface | Elliptical cylinder surface type.
kConeSurface | Cone surface type.
kEllipticalConeSurface | Elliptical cone surface type.
kTorusSurface | Torus surface type.
kSphereSurface | Sphere surface type.
kBSplineSurface | B-spline surface type.
Notes

Members through which this object may be accessed include:

Face.SurfaceType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.SurfaceTypeEnum Enumeration


Inventor.SweepDefinitionTypeEnum Enumeration

Inventor.SweepDefinitionTypeEnum Enumeration
Summary

This is record Inventor::SweepDefinitionTypeEnum.

Visual Basic
Public Enum SweepDefinitionTypeEnum
  kPathSweepDef = 59137
  kPathAndGuideRailSweepDef = 59138
  kPathAndGuideSurfaceSweepDef = 59139
  kPathAndSectionTwistsSweepDef = 59140
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SweepDefinitionTypeEnum Enumeration


Inventor.SweepProfileOrientationEnum Enumeration

Inventor.SweepProfileOrientationEnum Enumeration
Summary

This is record Inventor::SweepProfileOrientationEnum.

Visual Basic
Public Enum SweepProfileOrientationEnum
  kNormalToPath = 59649
  kParallelToOriginalProfile = 59650
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SweepProfileOrientationEnum Enumeration


Inventor.SweepProfileScalingEnum Enumeration

Inventor.SweepProfileScalingEnum Enumeration
Summary

This is record Inventor::SweepProfileScalingEnum.

Visual Basic
Public Enum SweepProfileScalingEnum
  kXYProfileScaling = 59393
  kXProfileScaling = 59394
  kNoProfileScaling = 59395
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SweepProfileScalingEnum Enumeration


Inventor.SystemOfMeasureEnum Enumeration

Inventor.SystemOfMeasureEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate the types of measurement systems (Metric, English, etc.).

Visual Basic
Public Enum SystemOfMeasureEnum
  kDefaultSystemOfMeasure = 8961
  kMetricSystemOfMeasure = 8962
  kEnglishSystemOfMeasure = 8963
End Enum
Members
Members | Description
kDefaultSystemOfMeasure | Installed, default system in use for this user.
kMetricSystemOfMeasure | Metric system of measure.
kEnglishSystemOfMeasure | English system of measure.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.SystemOfMeasureEnum Enumeration


Inventor.TableDirectionEnum Enumeration

Inventor.TableDirectionEnum Enumeration Introduced in Inventor 9
Summary

TableDirection

Visual Basic
Public Enum TableDirectionEnum
  kTopDownDirection = 46081
  kBottomUpDirection = 46082
End Enum
Members
Members | Description
kTopDownDirection | Top down
kBottomUpDirection | Bottom up
Notes

Members through which this object may be accessed include:

CustomTable.TableDirection

PartsList.TableDirection

PartsListStyle.TableDirection

RevisionTableStyle.TableDirection

TableStyle.TableDirection

You are here: Symbol Reference > Inventor Library > Enums > Inventor.TableDirectionEnum Enumeration


Inventor.TableSourceTypeEnum Enumeration

Inventor.TableSourceTypeEnum Enumeration
Summary

This is record Inventor::TableSourceTypeEnum.

Visual Basic
Public Enum TableSourceTypeEnum
  kNoTableSource = 77057
  kBendTableSource = 77058
  kConfigurationTableSource = 77059
  kExcelTableSource = 77060
  kCSVTableSource = 77061
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.TableSourceTypeEnum Enumeration


Inventor.TextureDimensionEnum Enumeration

Inventor.TextureDimensionEnum Enumeration
Summary

This is record Inventor::TextureDimensionEnum.

Visual Basic
Public Enum TextureDimensionEnum
  k1DTexture = 95489
  k2DTexture = 95490
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.TextureDimensionEnum Enumeration


Inventor.TextLineSpacingTypeEnum Enumeration

Inventor.TextLineSpacingTypeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the line spacing type.

Visual Basic
Public Enum TextLineSpacingTypeEnum
  kExactLineSpacing = 29185
  kMultipleLineSpacing = 29186
End Enum
Members
Members | Description
kExactLineSpacing | Constant identifying an exact line spacing.
kMultipleLineSpacing | Constant identifying a multiple line spacing.
Notes

Members through which this object may be accessed include:

DimensionText.LineSpacingType

DrawingNote.LineSpacingType

DrawingViewLabel.LineSpacingType

TextBox.LineSpacingType

TextStyle.LineSpacingType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.TextLineSpacingTypeEnum Enumeration


Inventor.ThreadTypeEnum Enumeration

Inventor.ThreadTypeEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the kind of thread.

Visual Basic
Public Enum ThreadTypeEnum
  kStandardThread = 22017
  kTaperedThread = 22018
End Enum
Members
Members | Description
kStandardThread | Standard thread definition used.
kTaperedThread | Tapered thread definition used.
Notes

Members through which this object may be accessed include:

ThreadFeature.ThreadInfoType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ThreadTypeEnum Enumeration


Inventor.ThumbnailSaveOptionEnum Enumeration

Inventor.ThumbnailSaveOptionEnum Enumeration
Summary

This is record Inventor::ThumbnailSaveOptionEnum.

Visual Basic
Public Enum ThumbnailSaveOptionEnum
  kNoThumbnail = 79873
  kActiveComponentIsoViewOnSave = 79874
  kActiveWindowOnSave = 79875
  kActiveWindow = 79876
  kImportFromFile = 79877
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ThumbnailSaveOptionEnum Enumeration


Inventor.TitleBlockAlignmentEnum Enumeration

Inventor.TitleBlockAlignmentEnum Enumeration
Summary

This is record Inventor::TitleBlockAlignmentEnum.

Visual Basic
Public Enum TitleBlockAlignmentEnum
  kUpperLeftTitleBlockAlignment = 66817
  kLowerLeftTitleBlockAlignment = 66818
  kUpperRightTitleBlockAlignment = 66819
  kLowerRightTitleBlockAlignment = 66820
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.TitleBlockAlignmentEnum Enumeration


Inventor.TitleBlockLocationEnum Enumeration

Inventor.TitleBlockLocationEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the position of the title block on the sheet.

Visual Basic
Public Enum TitleBlockLocationEnum
  kTopLeftPosition = 29441
  kTopRightPosition = 29442
  kBottomLeftPosition = 29443
  kBottomRightPosition = 29444
End Enum
Members
Members | Description
kTopLeftPosition | Constant identifying the top left corner of the sheet.
kTopRightPosition | Constant identifying the top right corner of the sheet.
kBottomLeftPosition | Constant identifying the bottom left corner of the sheet.
kBottomRightPosition | Constant identifying the bottom right corner of the sheet.
Notes

Members through which this object may be accessed include:

SheetFormat.TitleBlockLocation

TitleBlock.Location

You are here: Symbol Reference > Inventor Library > Enums > Inventor.TitleBlockLocationEnum Enumeration


Inventor.ToleranceTypeEnum Enumeration

Inventor.ToleranceTypeEnum Enumeration Introduced in Inventor 6
Summary

Constants identifying tolerance types.

Visual Basic
Public Enum ToleranceTypeEnum
  kDefaultTolerance = 31233
  kOverrideTolerance = 31234
  kSymmetricTolerance = 31235
  kDeviationTolerance = 31236
  kLimitsStackedTolerance = 31237
  kLimitLinearTolerance = 31238
  kMaxTolerance = 31239
  kMinTolerance = 31240
  kLimitsFitsStackedTolerance = 31241
  kLimitsFitsLinearTolerance = 31242
  kLimitsFitsShowSizeTolerance = 31243
  kLimitsFitsShowTolerance = 31244
  kBasicTolerance = 31245
  kReferenceTolerance = 31246
End Enum
Members
Members | Description
kDefaultTolerance | Standard tolerance.
kOverrideTolerance | Tolerance override
kSymmetricTolerance | Symmetric tolerance.
kDeviationTolerance | DeviationTolerance.
kLimitsStackedTolerance | LimitsStackedTolerance
kLimitLinearTolerance | LimitLinearTolerance.
kMaxTolerance | MaxTolerance.
kMinTolerance | MinTolerance.
kLimitsFitsStackedTolerance | LimitsFitsStackedTolerance.
kLimitsFitsLinearTolerance | LimitsFitsLinearTolerance.
kLimitsFitsShowSizeTolerance | LimitsFitsShowSizeTolerance.
kLimitsFitsShowTolerance | LimitsFitsShowTolerance.
kBasicTolerance | Basic Tolerance
kReferenceTolerance | ReferenceTolerance
Notes

Members through which this object may be accessed include:

Tolerance.ToleranceType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ToleranceTypeEnum Enumeration


Inventor.TransactionPointEnum Enumeration

Inventor.TransactionPointEnum Enumeration Introduced in Inventor 4
Summary

Symbolic indicators to specific points in the transaction sequence.

Visual Basic
Public Enum TransactionPointEnum
  kUnknownTransaction = 3585
  kNextTransaction = 3586
  kPreviousTransaction = 3587
  kCurrentTransaction = 3588
  kUptoSpecifiedTransaction = 3589
End Enum
Members
Members | Description
kUnknownTransaction | Unknown point in the transaction sequence.
kNextTransaction | Next transaction from the current one.
kPreviousTransaction | Previous transaction from the current one.
kCurrentTransaction | Current transaction.
kUptoSpecifiedTransaction | Point in the transaction sequence specified by another transaction.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.TransactionPointEnum Enumeration


Inventor.TransactionStateEnum Enumeration

Inventor.TransactionStateEnum Enumeration Introduced in Inventor 7
Summary

Enum indicating various transaction states

Visual Basic
Public Enum TransactionStateEnum
  kUncommittedState = 36865
  kDoneState = 36866
  kUndoneState = 36867
End Enum
Members
Members | Description
kUncommittedState | Uncommitted state
kDoneState | Done/committed state
kUndoneState | Undone state
Notes

Members through which this object may be accessed include:

Transaction.State

You are here: Symbol Reference > Inventor Library > Enums > Inventor.TransactionStateEnum Enumeration


Inventor.TransparencyTypeEnum Enumeration

Inventor.TransparencyTypeEnum Enumeration
Summary

This is record Inventor::TransparencyTypeEnum.

Visual Basic
Public Enum TransparencyTypeEnum
  kBlendingTransparency = 58625
  kScreenDoorTransparency = 58626
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.TransparencyTypeEnum Enumeration


Inventor.TriadMoveTypeEnum Enumeration

Inventor.TriadMoveTypeEnum Enumeration Introduced in Inventor 9
Summary

Enum indicating various actions that cause a triad move

Visual Basic
Public Enum TriadMoveTypeEnum
  kRepositionMoveType = 49409
End Enum
Members
Members | Description
kRepositionMoveType | Triad move as a result of a reposition
You are here: Symbol Reference > Inventor Library > Enums > Inventor.TriadMoveTypeEnum Enumeration


Inventor.TriadSegmentEnum Enumeration

Inventor.TriadSegmentEnum Enumeration Introduced in Inventor 9
Summary

Triad segment type enum

Visual Basic
Public Enum TriadSegmentEnum
  kAllSegments = 0
  kOriginSegment = 1
  kXAxisTranslationSegment = 1
  kYAxisTranslationSegment = 1
  kZAxisTranslationSegment = 1
  kXAxisRotationSegment = 1
  kYAxisRotationSegment = 1
  kZAxisRotationSegment = 1
  kXYPlaneTranslationSegment = 1
  kXZPlaneTranslationSegment = 1
  kYZPlaneTranslationSegment = 1
End Enum
Members
Members | Description
kAllSegments | Toggle all segments
kOriginSegment | Toggle the origin segment
kXAxisTranslationSegment | Toggle X axis translation segment
kYAxisTranslationSegment | Toggle Y axis translation segment
kZAxisTranslationSegment | Toggle Z axis translation segment
kXAxisRotationSegment | Toggle X axis Rotation segment
kYAxisRotationSegment | Toggle Y axis Rotation segment
kZAxisRotationSegment | Toggle Z axis Rotation segment
kXYPlaneTranslationSegment | Toggle XY plane translation segment
kXZPlaneTranslationSegment | Toggle XZ plane translation segment
kYZPlaneTranslationSegment | Toggle YZ plane translation segment
Notes

Members through which this object may be accessed include:

TriadEventsObject.DegreesOfFreedom

You are here: Symbol Reference > Inventor Library > Enums > Inventor.TriadSegmentEnum Enumeration


Inventor.UCSDefinitionTypeEnum Enumeration

Inventor.UCSDefinitionTypeEnum Enumeration
Summary

This is record Inventor::UCSDefinitionTypeEnum.

Visual Basic
Public Enum UCSDefinitionTypeEnum
  kTransformationDefinitionType = 90369
  kThreePointsDefinitionType = 90370
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.UCSDefinitionTypeEnum Enumeration


Inventor.UnfoldMethodEquationTypeEnum Enumeration

Inventor.UnfoldMethodEquationTypeEnum Enumeration
Summary

This is record Inventor::UnfoldMethodEquationTypeEnum.

Visual Basic
Public Enum UnfoldMethodEquationTypeEnum
  kBendAllowanceEquationType = 81409
  kBendCompensationEquationType = 81410
  kBendDeductionEquationType = 81411
  kBendkFactorEquationType = 81412
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.UnfoldMethodEquationTypeEnum Enumeration


Inventor.UnfoldMethodTypeEnum Enumeration

Inventor.UnfoldMethodTypeEnum Enumeration Introduced in Inventor 5.3
Summary

Constants identifying the UnfoldMethod Type.

Visual Basic
Public Enum UnfoldMethodTypeEnum
  kLinearUnfoldMethod = 28673
  kBendTableUnfoldMethod = 28674
  kCustomEquationUnfoldMethod = 28675
End Enum
Members
Members | Description
kLinearUnfoldMethod | Constant identifying Linear UnfoldMethod.
kBendTableUnfoldMethod | Constant identifying Bend Table UnfoldMethod.
Notes

Members through which this object may be accessed include:

UnfoldMethod.UnfoldMethodType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.UnfoldMethodTypeEnum Enumeration


Inventor.UniqueOccurrencesBehaviorEnum Enumeration

Inventor.UniqueOccurrencesBehaviorEnum Enumeration Introduced in Inventor 2008
Summary

Defines the unique behaviors that can be assigned to specific occurrences to define how that occurrence is treated during the rigid body analysis. The values of the enums can be used as a bit mask so that these various options can be combined into a single value.

Visual Basic
Public Enum UniqueOccurrencesBehaviorEnum
  kSinglePartRigidBody = 1
  kRetainDOF = 1
  kLockDOF = 1
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.UniqueOccurrencesBehaviorEnum Enumeration


Inventor.UnitsTypeEnum Enumeration

Inventor.UnitsTypeEnum Enumeration Introduced in Inventor 4
Summary

Units Types. Each signifies a specific unit in a particular dimension or category of measurement.

Visual Basic
Public Enum UnitsTypeEnum
  kUnitlessUnits = 11265
  kDefaultDisplayLengthUnits = 11266
  kDatabaseLengthUnits = 11267
  kCentimeterLengthUnits = 11268
  kMillimeterLengthUnits = 11269
  kMeterLengthUnits = 11270
  kMicronLengthUnits = 11271
  kInchLengthUnits = 11272
  kFootLengthUnits = 11273
  kYardLengthUnits = 11274
  kMileLengthUnits = 11275
  kDefaultDisplayAngleUnits = 11276
  kDatabaseAngleUnits = 11277
  kRadianAngleUnits = 11278
  kDegreeAngleUnits = 11279
  kGradAngleUnits = 11280
  kDefaultDisplayMassUnits = 11281
  kDatabaseMassUnits = 11282
  kKilogramMassUnits = 11283
  kGramMassUnits = 11284
  kSlugMassUnits = 11285
  kLbMassMassUnits = 11286
  kOunceMassUnits = 11287
  kDefaultDisplayTimeUnits = 11288
  kDatabaseTimeUnits = 11289
  kSecondTimeUnits = 11290
  kMinuteTimeUnits = 11291
  kHourTimeUnits = 11292
  kDefaultDisplayTemperatureUnits = 11293
  kDatabaseTemperatureUnits = 11294
  kKelvinTemperatureUnits = 11295
  kCelsiusTemperatureUnits = 11296
  kFahrenheitTemperatureUnits = 11297
  kMetersPerSecondSpeedUnits = 11298
  kFeetPerSecondSpeedUnits = 11299
  kMilesPerHourSpeedUnits = 11300
  kAcreAreaUnits = 11301
  kLiterVolumeUnits = 11302
  kGallonVolumeUnits = 11303
  kQuartVolumeUnits = 11304
  kPintVolumeUnits = 11305
  kCupVolumeUnits = 11306
  kOunceVolumeUnits = 11307
  kPascalPressureUnits = 11308
  kPSIPressureUnits = 11309
  kKSIPressureUnits = 11310
  kNewtonForceUnits = 11311
  kDyneForceUnits = 11312
  kLbForceUnits = 11313
  kOunceForceUnits = 11314
  kWattPowerUnits = 11315
  kHorsePowerPowerUnits = 11316
  kJouleWorkUnits = 11317
  kErgWorkUnits = 11318
  kCalorieWorkUnits = 11319
  kBTUWorkUnits = 11320
  kRPMAngularVelocityUnits = 11321
  kCompositeUnits = 11322
  kNauticalMileLengthUnits = 11323
  kMilLengthUnits = 11324
  kSteradianAngleUnits = 11325
  kCircularMilAreaUnits = 11326
  kAmpElectricalCurrentUnits = 11327
  kVoltElectricalVoltageUnits = 11328
  kOhmElectricalResistanceUnits = 11329
  kCoulombElectricalChargeUnits = 11330
  kFaradElectricalCapacitanceUnits = 11331
  kSiemensElectricalConductanceUnits = 11332
  kmhoElectricalConductanceUnits = 11333
  kWeberMagneticFluxUnits = 11334
  kMaxwellMagneticFluxUnits = 11335
  kTeslaMagneticInductionUnits = 11336
  kGammaMagneticInductionUnits = 11337
  kGaussMagneticInductionUnits = 11338
  kHenryElectricalInductanceUnits = 11339
  kOerstedMagneticInductionUnits = 11340
  kHertzFrequencyUnits = 11341
  kCandelaLuminousIntensityUnits = 11342
  kLumenLuminousFluxUnits = 11343
  kLuxIlluminationUnits = 11344
  kMoleSubstanceUnits = 11345
  kTextUnits = 11346
  kBooleanUnits = 11347
End Enum
Members
Members | Description
kUnitlessUnits | No dimension associated with this value.
kDefaultDisplayLengthUnits | Current default display units for length.
kDatabaseLengthUnits | Database units for length -- ALWAYS Centimeter.
kCentimeterLengthUnits | Centimeter length.
kMillimeterLengthUnits | Millimeter length.
kMeterLengthUnits | Meter length.
kMicronLengthUnits | Micron length.
kInchLengthUnits | Inch length.
kFootLengthUnits | Foot length.
kYardLengthUnits | Yard length.
kMileLengthUnits | Mile length.
kDefaultDisplayAngleUnits | Current default display units for angle.
kDatabaseAngleUnits | Database units for angle -- ALWAYS Radian.
kRadianAngleUnits | Radian angle.
kDegreeAngleUnits | Degree angle.
kGradAngleUnits | Grad angle.
kDefaultDisplayMassUnits | Current default display units for mass.
kDatabaseMassUnits | Database units for mass -- ALWAYS Gram.
kKilogramMassUnits | Kilogram mass.
kGramMassUnits | Gram mass.
kSlugMassUnits | Slug mass.
kLbMassMassUnits | LbMass mass.
kOunceMassUnits | Ounce mass.
kDefaultDisplayTimeUnits | Current default display units for time.
kDatabaseTimeUnits | Database units for time -- ALWAYS Second.
kSecondTimeUnits | Second time.
kMinuteTimeUnits | Minute time.
kHourTimeUnits | Hour time.
kDefaultDisplayTemperatureUnits | Current default display units for temperature.
kDatabaseTemperatureUnits | Database units for temperature -- ALWAYS Celsius.
kKelvinTemperatureUnits | Kelvin temperature.
kCelsiusTemperatureUnits | Celsius temperature.
kFahrenheitTemperatureUnits | Fahrenheit temperature units.
kMetersPerSecondSpeedUnits | Meters per second speed.
kFeetPerSecondSpeedUnits | Feet per second speed.
kMilesPerHourSpeedUnits | Miles per hour speed.
kAcreAreaUnits | Acre area.
kLiterVolumeUnits | Liter volume.
kGallonVolumeUnits | Gallon volume.
kQuartVolumeUnits | Quart volume.
kPintVolumeUnits | Pint volume.
kCupVolumeUnits | Cup volume.
kOunceVolumeUnits | Ounce volume.
kPascalPressureUnits | Pascal pressure.
kPSIPressureUnits | PSI pressure.
kKSIPressureUnits | KSI pressure.
kNewtonForceUnits | Newton force.
kDyneForceUnits | Dyne force.
kLbForceUnits | Lb force.
kOunceForceUnits | Ounce force.
kWattPowerUnits | Watt power.
kHorsePowerPowerUnits | Horsepower power.
kJouleWorkUnits | Joule work.
kErgWorkUnits | Erg work.
kCalorieWorkUnits | Calorie work.
kBTUWorkUnits | BTU work.
kRPMAngularVelocityUnits | RPM angular velocity.
kCompositeUnits | Composite.
kNauticalMileLengthUnits | NauticalMile Length
kMilLengthUnits | Mil Length
kSteradianAngleUnits | Steradian Angle
kCircularMilAreaUnits | CircularMil Area
kAmpElectricalCurrentUnits | Amp electrical Current
kVoltElectricalVoltageUnits | Volt electrical Voltage
kOhmElectricalResistanceUnits | Ohm electrical Resistance
kCoulombElectricalChargeUnits | Coulomb electrical Charge
kFaradElectricalCapacitanceUnits | Farad electrical Capacitance
kSiemensElectricalConductanceUnits | Siemens electrical Conductance
kmhoElectricalConductanceUnits | mho electrical Conductance
kWeberMagneticFluxUnits | Weber magnetic Flux
kMaxwellMagneticFluxUnits | Maxwell magnetic Flux
kTeslaMagneticInductionUnits | Tesla magnetic Induction
kGammaMagneticInductionUnits | Gamma magnetic Induction
kGaussMagneticInductionUnits | Gauss magnetic Induction
kHenryElectricalInductanceUnits | Henry electrical Inductance
kOerstedMagneticInductionUnits | Oersted magnetic Induction
kHertzFrequencyUnits | Hertz Frequency
kCandelaLuminousIntensityUnits | Candela luminous intensity
kLumenLuminousFluxUnits | Lumen luminous flux
kLuxIlluminationUnits | Lux illumination
kMoleSubstanceUnits | Mole Substance or gram molecular weight
Notes

Members through which this object may be accessed include:

DimensionStyle.AlternateLinearUnits

DimensionStyle.LinearUnits

DrawingStandardStyle.LinearUnits

FeatureControlFrameStyle.AlternateLinearUnits

FeatureControlFrameStyle.LinearUnits

UnitsOfMeasure.AngleUnits

UnitsOfMeasure.LengthUnits

UnitsOfMeasure.MassUnits

UnitsOfMeasure.TimeUnits

UnitsOfMeasure.GetTypeFromString

You are here: Symbol Reference > Inventor Library > Enums > Inventor.UnitsTypeEnum Enumeration


Inventor.UpdatePropertiesOnSaveForFileTypeEnum Enumeration

Inventor.UpdatePropertiesOnSaveForFileTypeEnum Enumeration
Summary

This is record Inventor::UpdatePropertiesOnSaveForFileTypeEnum.

Visual Basic
Public Enum UpdatePropertiesOnSaveForFileTypeEnum
  kDontUpdateProperties = 71681
  kUpdatePropertiesForPartsOnly = 71682
  kUpdatePropertiesForPartsAndAssemblies = 71683
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.UpdatePropertiesOnSaveForFileTypeEnum Enumeration


Inventor.ValueTypeEnum Enumeration

Inventor.ValueTypeEnum Enumeration Introduced in Inventor 5
Summary

Constants enumerating the various types of values.

Visual Basic
Public Enum ValueTypeEnum
  kIntegerType = 14593
  kDoubleType = 14594
  kStringType = 14595
  kByteArrayType = 14596
End Enum
Members
Members | Description
kIntegerType | Integer value.
kDoubleType | Double value.
kStringType | String value.
kByteArrayType | Byte Array Value
Notes

Members through which this object may be accessed include:

Attribute.ValueType

ContentTableColumn.DataType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ValueTypeEnum Enumeration


Inventor.ValueUnitsTypeEnum Enumeration

Inventor.ValueUnitsTypeEnum Enumeration Available in Inventor Introduced in Inventor 2012
Summary

Specifies the units type.

kAngleUnits

kAngularVelocityUnits

kAreaUnits

kCurrentUnits

kForceUnits

kLengthUnits

kMassUnits

kPowerUnits

kPressureUnits

kSpeedUnits

kTemperatureUnits

kTimeUnits

kUnitless

kVoltageUnits

kVolumeUnits

kWorkUnits

Visual Basic
Public Enum ValueUnitsTypeEnum
  kAngleUnits = 94977
  kAngularVelocityUnits = 94978
  kAreaUnits = 94979
  kCurrentUnits = 94980
  kForceUnits = 94981
  kLengthUnits = 94982
  kMassUnits = 94983
  kPowerUnits = 94984
  kPressureUnits = 94985
  kSpeedUnits = 94986
  kTemperatureUnits = 94987
  kTimeUnits = 94988
  kUnitless = 94989
  kVoltageUnits = 94990
  kVolumeUnits = 94991
  kWorkUnits = 94992
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ValueUnitsTypeEnum Enumeration


Inventor.VBAProjectTypeEnum Enumeration

Inventor.VBAProjectTypeEnum Enumeration Introduced in Inventor 6
Summary

Autodesk Inventor's VBA Project Type.

Visual Basic
Public Enum VBAProjectTypeEnum
  kApplicationVBAProject = 30465
  kDocumentVBAProject = 30466
  kUserVBAProject = 30467
End Enum
Members
Members | Description
kApplicationVBAProject | Application VBA Project
kDocumentVBAProject | Document VBA Project
kUserVBAProject | User VBA Project.
Notes

Members through which this object may be accessed include:

InventorVBAProject.ProjectType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.VBAProjectTypeEnum Enumeration


Inventor.VerticalTextAlignmentEnum Enumeration

Inventor.VerticalTextAlignmentEnum Enumeration Introduced in Inventor 5
Summary

Constants identifying the vertical positioning of text about a given point coordinate.

Visual Basic
Public Enum VerticalTextAlignmentEnum
  kAlignTextMiddle = 25601
  kAlignTextUpper = 25602
  kAlignTextLower = 25603
  kAlignTextBaseline = 25604
End Enum
Members
Members | Description
kAlignTextMiddle | Text centered about the supplied point.
kAlignTextUpper | Text positioned above the supplied point.
kAlignTextLower | Text positioned below the supplied point.
Notes

Members through which this object may be accessed include:

DimensionText.VerticalJustification

DrawingNote.StackedTextPosition

DrawingNote.VerticalJustification

DrawingViewLabel.StackedTextPosition

DrawingViewLabel.VerticalJustification

HoleTableCell.StackedTextPosition

HoleTag.StackedTextPosition

RevisionTableCell.StackedTextPosition

TextBox.StackedTextPosition

TextBox.VerticalJustification

TextGraphics.VerticalAlignment

TextStyle.VerticalJustification

You are here: Symbol Reference > Inventor Library > Enums > Inventor.VerticalTextAlignmentEnum Enumeration


Inventor.ViewBlockInsertionPointEnum Enumeration

Inventor.ViewBlockInsertionPointEnum Enumeration
Summary

This is record Inventor::ViewBlockInsertionPointEnum.

Visual Basic
Public Enum ViewBlockInsertionPointEnum
  kViewCenterInsertion = 86785
  kModelOriginInsertion = 86786
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewBlockInsertionPointEnum Enumeration


Inventor.ViewJustificationEnum Enumeration

Inventor.ViewJustificationEnum Enumeration
Summary

This is record Inventor::ViewJustificationEnum.

Visual Basic
Public Enum ViewJustificationEnum
  kCenteredViewJustification = 67073
  kFixedViewJustification = 67074
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewJustificationEnum Enumeration


Inventor.ViewLayoutEnum Enumeration

Inventor.ViewLayoutEnum Enumeration Introduced in Inventor 9
Summary

View-relative enum

Visual Basic
Public Enum ViewLayoutEnum
  kTopLeftViewCorner = 41473
  kTopRightViewCorner = 41474
  kBottomLeftViewCorner = 41475
  kBottomRightViewCorner = 41476
End Enum
Members
Members | Description
kTopLeftViewCorner | Relative to Top Left corner of view
kTopRightViewCorner | Relative to Top Right corner of view
kBottomLeftViewCorner | Relative to Bottom Left corner of view
kBottomRightViewCorner | Relative to Bottom Right corner of view
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewLayoutEnum Enumeration


Inventor.ViewOperationTypeEnum Enumeration

Inventor.ViewOperationTypeEnum Enumeration Introduced in Inventor 6
Summary

View operation type.

Visual Basic
Public Enum ViewOperationTypeEnum
  kRotateViewOperation = 30209
  kPanViewOperation = 30210
  kZoomViewOperation = 30211
End Enum
Members
Members | Description
kRotateViewOperation | Rotate view.
kPanViewOperation | Pan view.
kZoomViewOperation | Zoom view.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewOperationTypeEnum Enumeration


Inventor.ViewOrientationTypeEnum Enumeration

Inventor.ViewOrientationTypeEnum Enumeration Introduced in Inventor 4
Summary

View orientation type.

Visual Basic
Public Enum ViewOrientationTypeEnum
  kDefaultViewOrientation = 10753
  kTopViewOrientation = 10754
  kRightViewOrientation = 10755
  kBackViewOrientation = 10756
  kBottomViewOrientation = 10757
  kLeftViewOrientation = 10758
  kIsoTopRightViewOrientation = 10759
  kIsoTopLeftViewOrientation = 10760
  kIsoBottomRightViewOrientation = 10761
  kIsoBottomLeftViewOrientation = 10762
  kArbitraryViewOrientation = 10763
  kFrontViewOrientation = 10764
  kCurrentViewOrientation = 10765
  kSavedCameraViewOrientation = 10766
  kFlatPivotRightViewOrientation = 10767
  kFlatPivotLeftViewOrientation = 10768
  kFlatPivot180ViewOrientation = 10769
  kFlatBacksideViewOrientation = 10770
  kFlatBacksidePivotRightViewOrientation = 10771
  kFlatBacksidePivotLeftViewOrientation = 10772
  kFlatBacksidePivot180ViewOrientation = 10773
End Enum
Members
Members | Description
kDefaultViewOrientation | Specifies the default setting to use. Inquiry methods/properties always return the more strongly typed values.
kTopViewOrientation | Top view.
kRightViewOrientation | Right view.
kBackViewOrientation | Back view.
kBottomViewOrientation | Bottom view.
kLeftViewOrientation | Left view.
kIsoTopRightViewOrientation | Isometric -- top right view.
kIsoTopLeftViewOrientation | Isometric -- top left view.
kIsoBottomRightViewOrientation | Isometric -- bottom right view.
kIsoBottomLeftViewOrientation | Isometric -- bottom left view.
kArbitraryViewOrientation | Arbitrary view.
kFrontViewOrientation | Front view.
kCurrentViewOrientation | Current view.
kSavedCameraViewOrientation | Saved camera view.
kFlatPivotRightViewOrientation | Sheet metal flat pattern pivot right.
kFlatPivotLeftViewOrientation | Sheet metal flat pattern pivot left.
kFlatPivot180ViewOrientation | Sheet metal flat pattern pivot 180 degrees.
kFlatBacksideViewOrientation | Sheet metal flat pattern backside.
kFlatBacksidePivotRightViewOrientation | Sheet metal flat pattern backside pivot right.
kFlatBacksidePivotLeftViewOrientation | Sheet metal flat pattern backside pivot left.
kFlatBacksidePivot180ViewOrientation | Sheet metal flat pattern backside pivot 180 degrees.
Notes

Members through which this object may be accessed include:

Camera.ViewOrientationType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewOrientationTypeEnum Enumeration


Inventor.ViewPreviewTypeEnum Enumeration

Inventor.ViewPreviewTypeEnum Enumeration
Summary

This is record Inventor::ViewPreviewTypeEnum.

Visual Basic
Public Enum ViewPreviewTypeEnum
  kAllComponentsViewPreview = 70657
  kPartialViewPreview = 70658
  kBoundingBoxViewPreview = 70659
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewPreviewTypeEnum Enumeration


Inventor.ViewTypeEnum Enumeration

Inventor.ViewTypeEnum Enumeration Introduced in Inventor 4
Summary

Constants that enumerate view types.

Visual Basic
Public Enum ViewTypeEnum
  kUnknownViewType = 9217
  kGraphicsViewType = 9218
  kBrowserViewType = 9219
  kNoteBookViewType = 9220
End Enum
Members
Members | Description
kUnknownViewType | Unknown view type.
kGraphicsViewType | View showing the pictorial representation of the document.
kBrowserViewType | View showing the tree representation of the contents in the document.
kNoteBookViewType | View showing the Engineer's Notebook aspect of the document.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ViewTypeEnum Enumeration


Inventor.WeldmentFeatureGroupEnum Enumeration

Inventor.WeldmentFeatureGroupEnum Enumeration Introduced in Inventor 6
Summary

Constants that enumerate weldment feature group types.

Visual Basic
Public Enum WeldmentFeatureGroupEnum
  kAssemblyFeatureGroup = 35073
  kPreperationsFeatureGroup = 35074
  kWeldsFeatureGroup = 35075
  kMachiningFeatureGroup = 35076
End Enum
Members
Members | Description
kAssemblyFeatureGroup | General assembly group.
kPreperationsFeatureGroup | Preparations group.
kWeldsFeatureGroup | Welds group.
kMachiningFeatureGroup | Machining group.
You are here: Symbol Reference > Inventor Library > Enums > Inventor.WeldmentFeatureGroupEnum Enumeration


Inventor.WeldmentStateEnum Enumeration

Inventor.WeldmentStateEnum Enumeration
Summary

This is record Inventor::WeldmentStateEnum.

Visual Basic
Public Enum WeldmentStateEnum
  kAssemblyWeldmentState = 80897
  kMachiningWeldmentState = 80898
  kWeldsWeldmentState = 80899
  kPreparationsWeldmentState = 80900
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.WeldmentStateEnum Enumeration


Inventor.WindowsSizeEnum Enumeration

Inventor.WindowsSizeEnum Enumeration Introduced in Inventor 6
Summary

Constants that enumerate window size.

Visual Basic
Public Enum WindowsSizeEnum
  kNormalWindow = 32513
  kMaximize = 32514
  kMinimize = 32515
End Enum
Members
Members | Description
kNormalWindow | Normal window size.
kMaximize | Maximize the window.
kMinimize | Minimize the window
Notes

Members through which this object may be accessed include:

Application.WindowState

View.WindowState

You are here: Symbol Reference > Inventor Library > Enums > Inventor.WindowsSizeEnum Enumeration


Inventor.WorkAxisDefinitionEnum Enumeration

Inventor.WorkAxisDefinitionEnum Enumeration Introduced in Inventor 4
Summary

Constants identifying work axis definition types.

Visual Basic
Public Enum WorkAxisDefinitionEnum
  kLineWorkAxis = 12545
  kTwoPlanesWorkAxis = 12546
  kTwoPointsWorkAxis = 12547
  kRevolvedFaceWorkAxis = 12548
  kLineAndPlaneWorkAxis = 12550
  kNormalToSurfaceWorkAxis = 12553
  kFixedWorkAxis = 12551
  kAssemblyWorkAxis = 12552
  kLineAndPointWorkAxis = 12554
  kAnalyticEdgeWorkAxis = 12555
End Enum
Members
Members | Description
kLineWorkAxis | Line work axis definition.
kTwoPlanesWorkAxis | Two plane work axis definition.
kTwoPointsWorkAxis | Two point work axis definition.
kRevolvedFaceWorkAxis | Revolved face work axis definition.
kLineAndPlaneWorkAxis | Line and plane work axis definition.
kFixedWorkAxis | Fixed work axis definition.
kAssemblyWorkAxis | Assembly work axis definition
Notes

Members through which this object may be accessed include:

WorkAxis.DefinitionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.WorkAxisDefinitionEnum Enumeration


Inventor.WorkPlaneDefinitionEnum Enumeration

Inventor.WorkPlaneDefinitionEnum Enumeration Introduced in Inventor 4
Summary

Constants identifying work plane definition types.

Visual Basic
Public Enum WorkPlaneDefinitionEnum
  kThreePointsWorkPlane = 12033
  kTwoLinesWorkPlane = 12034
  kPlaneAndPointWorkPlane = 12036
  kLinePlaneAndAngleWorkPlane = 12037
  kPlaneAndOffsetWorkPlane = 12038
  kLineAndTangentWorkPlane = 12039
  kPlaneAndTangentWorkPlane = 12040
  kNormalToCurveWorkPlane = 12042
  kTwoPlanesWorkPlane = 12043
  kFixedWorkPlane = 12041
  kPointAndTangentWorkPlane = 12045
  kAssemblyWorkPlane = 12044
  kTorusMidPlaneWorkPlane = 12046
End Enum
Members
Members | Description
kThreePointsWorkPlane | Three point work plane definition.
kTwoLinesWorkPlane | Two line work plane definition.
kPlaneAndPointWorkPlane | Plane and point work plane definition.
kLinePlaneAndAngleWorkPlane | Line, plane, and angle work plane definition.
kPlaneAndOffsetWorkPlane | Plane and offset work plane definition.
kLineAndTangentWorkPlane | Line and tangent face work plane definition.
kPlaneAndTangentWorkPlane | Plane and tangent face work plane definition.
kNormalToCurveWorkPlane | Normal to curve work plane definition.
kTwoPlanesWorkPlane | Two planes work plane definition.
kFixedWorkPlane | Fixed work plane definition.
kAssemblyWorkPlane | Assembly work plane definition
Notes

Members through which this object may be accessed include:

WorkPlane.DefinitionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.WorkPlaneDefinitionEnum Enumeration


Inventor.WorkPointDefinitionEnum Enumeration

Inventor.WorkPointDefinitionEnum Enumeration Introduced in Inventor 4
Summary

Constants identifying work point definition types.

Visual Basic
Public Enum WorkPointDefinitionEnum
  kThreePlanesWorkPoint = 12801
  kTwoLinesWorkPoint = 12802
  kLineAndFaceWorkPoint = 12803
  kPointWorkPoint = 12804
  kMidPointWorkPoint = 12805
  kCurveAndEntityWorkPoint = 12807
  kFixedWorkPoint = 12806
  kAssemblyWorkPoint = 12808
  kNonLinearEdgeWorkPoint = 12809
  kTorusCenterPointWorkPoint = 12810
  kCentroidWorkPoint = 12811
End Enum
Members
Members | Description
kThreePlanesWorkPoint | Three plane work point definition.
kTwoLinesWorkPoint | Two line work point definition.
kLineAndFaceWorkPoint | Line and face work point definition.
kPointWorkPoint | Point work point definition.
kMidPointWorkPoint | Midpoint work point definition.
kCurveAndEntityWorkPoint | Curve and entity work point definition.
kFixedWorkPoint | Fixed work point definition.
kAssemblyWorkPoint | Assembly work point definition
Notes

Members through which this object may be accessed include:

WorkPoint.DefinitionType

You are here: Symbol Reference > Inventor Library > Enums > Inventor.WorkPointDefinitionEnum Enumeration


Inventor.ZoomTargetComponentWithiMateEnum Enumeration

Inventor.ZoomTargetComponentWithiMateEnum Enumeration
Summary

This is record Inventor::ZoomTargetComponentWithiMateEnum.

Visual Basic
Public Enum ZoomTargetComponentWithiMateEnum
  kZoomTargetNone = 55809
  kZoomTargetPlacedComponent = 55810
  kZoomTargetAll = 55811
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.ZoomTargetComponentWithiMateEnum Enumeration


InventorStudioLib Library

InventorStudioLib Library
Summary

This is namespace InventorStudioLib.

Studio Objects
Name | Description
Animation | The Animation collection object represents an animation and provides access to all of the information associated with an animation.
IAnimation | The Animation collection object represents an animation and provides access to all of the information associated with an animation.
AnimationFavorites | The AnimationFavorites collection object provides access to the parameter and constraint favorites for this document.
IAnimationFavorites | The AnimationFavorites collection object provides access to the parameter and constraint favorites for this document.
AnimationManager | The AnimationManager object is a utility object that provides access to the animation capabilities of Inventor Studio.
IAnimationManager | The AnimationManager object is a utility object that provides access to the animation capabilities of Inventor Studio.
Animations | The Animations collection object provides access to the animations defined in this document.
IAnimations | The Animations collection object provides access to the animations defined in this document.
InventorStudio | The InventorStudio object is the top-level object for Inventor Studio and provides access to the other Inventor Studio related API objects. This object is obtained through the Automation property of the Inventor Studio Add-In.
IInventorStudio | The InventorStudio object is the top-level object for Inventor Studio and provides access to the other Inventor Studio related API objects. This object is obtained through the Automation property of the Inventor Studio Add-In.
RenderManager | The RenderManager object is a utility object that provides access to the rendering capabilities of Inventor Studio.
IRenderManager | The RenderManager object is a utility object that provides access to the rendering capabilities of Inventor Studio.
StudioCamera | The StudioCamera object represents an Inventor Studio camera.
IStudioCamera | The StudioCamera object represents an Inventor Studio camera.
StudioCameras | The StudioCameras collection object provides access to existing StudioCamera objects.
IStudioCameras | The StudioCameras collection object provides access to existing StudioCamera objects.
StudioLightingStyle | The StudioLightingStyle object represents an Inventor Studio Lighting Style.
IStudioLightingStyle | The StudioLightingStyle object represents an Inventor Studio Lighting Style.
StudioLightingStyles | The StudioLightingStyles collection object provides access to existing StudioLightingStyle objects.
IStudioLightingStyles | The StudioLightingStyles collection object provides access to existing StudioLightingStyle objects.
StudioSceneStyle | The StudioSceneStyle object represents an Inventor Studio Scene Style.
IStudioSceneStyle | The StudioSceneStyle object represents an Inventor Studio Scene Style.
StudioSceneStyles | The StudioSceneStyles collection object provides access to existing StudioSceneStyle objects.
IStudioSceneStyles | The StudioSceneStyles collection object provides access to existing StudioSceneStyle objects.
You are here: Symbol Reference > InventorStudioLib Library


Animation CoClass

Animation CoClass
Summary

The Animation collection object represents an animation and provides access to all of the information associated with an animation.

Class Hierarchy
InventorStudioLib::Animation
Visual Basic
Public Class Animation
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > Animation CoClass


IAnimation Interface

IAnimation Interface
Summary

The Animation collection object represents an animation and provides access to all of the information associated with an animation.

Class Hierarchy
InventorStudioLib::IAnimation
Visual Basic
Public Interface IAnimation
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimation Interface


IAnimation Properties

IAnimation Properties
Summary

The properties of the IAnimation class are listed here.

Properties
Name | Description
Name | Property that gets and sets the name of the Inventor Studio animation. When setting the name, the name must be unique with respect to the other animations.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimation Interface > IAnimation Properties


IAnimation.Name Property

IAnimation.Name Property
Summary

Property that gets and sets the name of the Inventor Studio animation. When setting the name, the name must be unique with respect to the other animations.

Visual Basic
Property Name() As String
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimation Interface > IAnimation Properties > IAnimation.Name Property


AnimationFavorites CoClass

AnimationFavorites CoClass
Summary

The AnimationFavorites collection object provides access to the parameter and constraint favorites for this document.

Class Hierarchy
InventorStudioLib::AnimationFavorites
Visual Basic
Public Class AnimationFavorites
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > AnimationFavorites CoClass


IAnimationFavorites Interface

IAnimationFavorites Interface
Summary

The AnimationFavorites collection object provides access to the parameter and constraint favorites for this document.

Class Hierarchy
InventorStudioLib::IAnimationFavorites
Visual Basic
Public Interface IAnimationFavorites
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface


IAnimationFavorites Methods

IAnimationFavorites Methods
Summary

The methods of the IAnimationFavorites class are listed here.

Methods
Methods
Name | Description
Add | Method that adds a new object to the list of animation favorites.
Item | Property that returns the specified StudioCamera object from the collection.
Remove | Method that removes the specified object from the favorites list.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface > IAnimationFavorites Methods


IAnimationFavorites.Add Method

IAnimationFavorites.Add Method
Summary

Method that adds a new object to the list of animation favorites.

Visual Basic
Sub Add(pObject As IDispatch)
Parameters
Parameters | Description
pObject | Input object to add to the favorites list. Valid input is either a Parameter or an AssemblyConstraint object.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface > IAnimationFavorites Methods > IAnimationFavorites.Add Method


IAnimationFavorites.Item Method

IAnimationFavorites.Item Method
Summary

Property that returns the specified StudioCamera object from the collection.

Visual Basic
Sub Item(Index As LONG, pVal As [out, retval] IDispatch*)
Parameters
Parameters | Description
Index | Input Long that specifies the index of the object to return.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface > IAnimationFavorites Methods > IAnimationFavorites.Item Method


IAnimationFavorites.Remove Method

IAnimationFavorites.Remove Method
Summary

Method that removes the specified object from the favorites list.

Visual Basic
Sub Remove(Index As LONG)
Parameters
Parameters | Description
Index | Input index that corresponds to the object to remove from the favorites list.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface > IAnimationFavorites Methods > IAnimationFavorites.Remove Method


IAnimationFavorites Properties

IAnimationFavorites Properties
Summary

The properties of the IAnimationFavorites class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface > IAnimationFavorites Properties


IAnimationFavorites.Count Property

IAnimationFavorites.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As LONG*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationFavorites Interface > IAnimationFavorites Properties > IAnimationFavorites.Count Property


AnimationManager CoClass

AnimationManager CoClass
Summary

The AnimationManager object is a utility object that provides access to the animation capabilities of Inventor Studio.

Class Hierarchy
InventorStudioLib::AnimationManager
Visual Basic
Public Class AnimationManager
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > AnimationManager CoClass


IAnimationManager Interface

IAnimationManager Interface
Summary

The AnimationManager object is a utility object that provides access to the animation capabilities of Inventor Studio.

Class Hierarchy
InventorStudioLib::IAnimationManager
Visual Basic
Public Interface IAnimationManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationManager Interface


IAnimationManager Properties

IAnimationManager Properties
Summary

The properties of the IAnimationManager class are listed here.

Properties
Name | Description
ActiveAnimation | Property that gets and sets the current active animation. Setting this property to Nothing is the equivalent of activating the 'Model State'.
AnimationFavorites | Property that returns the AnimationFavorites collection object. This provides access to all of the parameter and assembly constraints that have been defined as favorites.
Animations | Property that returns the Animations collection object. This provides access to all of the existing animations and provides the ability to create new animations.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationManager Interface > IAnimationManager Properties


IAnimationManager.ActiveAnimation Property

IAnimationManager.ActiveAnimation Property
Summary

Property that gets and sets the current active animation. Setting this property to Nothing is the equivalent of activating the 'Model State'.

Visual Basic
Property ActiveAnimation() As IAnimation*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationManager Interface > IAnimationManager Properties > IAnimationManager.ActiveAnimation Property


IAnimationManager.AnimationFavorites Property

IAnimationManager.AnimationFavorites Property
Summary

Property that returns the AnimationFavorites collection object. This provides access to all of the parameter and assembly constraints that have been defined as favorites.

Visual Basic
Property AnimationFavorites() As IAnimationFavorites**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationManager Interface > IAnimationManager Properties > IAnimationManager.AnimationFavorites Property


IAnimationManager.Animations Property

IAnimationManager.Animations Property
Summary

Property that returns the Animations collection object. This provides access to all of the existing animations and provides the ability to create new animations.

Visual Basic
Property Animations() As IAnimations**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimationManager Interface > IAnimationManager Properties > IAnimationManager.Animations Property


Animations CoClass

Animations CoClass
Summary

The Animations collection object provides access to the animations defined in this document.

Class Hierarchy
InventorStudioLib::Animations
Visual Basic
Public Class Animations
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > Animations CoClass


IAnimations Interface

IAnimations Interface
Summary

The Animations collection object provides access to the animations defined in this document.

Class Hierarchy
InventorStudioLib::IAnimations
Visual Basic
Public Interface IAnimations
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimations Interface


IAnimations Methods

IAnimations Methods
Summary

The methods of the IAnimations class are listed here.

Methods
Methods
Name | Description
Add | Method that creates a new animation.
Item | Property that returns the specified Animation object from the collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimations Interface > IAnimations Methods


IAnimations.Add Method

IAnimations.Add Method
Summary

Method that creates a new animation.

Visual Basic
Sub Add(pVal As [out, retval] IAnimation*)
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimations Interface > IAnimations Methods > IAnimations.Add Method


IAnimations.Item Method

IAnimations.Item Method
Summary

Property that returns the specified Animation object from the collection.

Visual Basic
Sub Item(Index As VARIANT, pVal As [out, retval] IAnimation*)
Parameters
Parameters | Description
Index | Input Variant that specifies the Animation within the collection to return. This can be either a Long to indicate the index of the Animation within the collection or a String indicating the name of the Animation. If the specified name does not exist, a failure occurs.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimations Interface > IAnimations Methods > IAnimations.Item Method


IAnimations Properties

IAnimations Properties
Summary

The properties of the IAnimations class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimations Interface > IAnimations Properties


IAnimations.Count Property

IAnimations.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As LONG*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IAnimations Interface > IAnimations Properties > IAnimations.Count Property


InventorStudio CoClass

InventorStudio CoClass
Summary

The InventorStudio object is the top-level object for Inventor Studio and provides access to the other Inventor Studio related API objects. This object is obtained through the Automation property of the Inventor Studio Add-In.

Class Hierarchy
InventorStudioLib::InventorStudio
Visual Basic
Public Class InventorStudio
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > InventorStudio CoClass


IInventorStudio Interface

IInventorStudio Interface
Summary

The InventorStudio object is the top-level object for Inventor Studio and provides access to the other Inventor Studio related API objects. This object is obtained through the Automation property of the Inventor Studio Add-In.

Class Hierarchy
InventorStudioLib::IInventorStudio
Visual Basic
Public Interface IInventorStudio
Inherits IDispatch
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface


IInventorStudio Methods

IInventorStudio Methods
Summary

The methods of the IInventorStudio class are listed here.

Methods
Methods
Name | Description
Activate | Activates the Inventor Studio environment for the active document. This will fail if a drawing document is active.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Methods


IInventorStudio.Activate Method

IInventorStudio.Activate Method
Summary

Activates the Inventor Studio environment for the active document. This will fail if a drawing document is active.

Visual Basic
Sub Activate(ppStudioEnv As [out, retval] Environment*)
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Methods > IInventorStudio.Activate Method


IInventorStudio Properties

IInventorStudio Properties
Summary

The properties of the IInventorStudio class are listed here.

Properties
Name | Description
ActiveLightingStyle | Property that gets and sets the active lighting style. The active lighting style is used when displaying the current model and is also used when rendering. A value of Nothing is the equivalent of setting the lighting style to '(Current Lighting)' in the Render Image dialog.
ActiveSceneStyle | Property that gets and sets the active scene style. The active scene style is used when displaying the current model and is also used when rendering. A value of Nothing is the equivalent of setting the scene style to '(Current Background)' in the Render Image dialog.
AnimationManager | Property that returns the AnimationManager object.
RenderManager | Property that returns the RenderManager object.
StudioCameras | Property that returns the StudioCameras collection object. This provides access to all of the cameras defined for this document.
StudioLightingStyles | Property that returns the StudioLightStyles collection object. This provides access to all of the lighting styles defined for this document.
StudioSceneStyles | Property that returns the StudioSceneStyles collection object. This provides access to all of the scene styles defined for this document.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties


IInventorStudio.ActiveLightingStyle Property

IInventorStudio.ActiveLightingStyle Property
Summary

Property that gets and sets the active lighting style. The active lighting style is used when displaying the current model and is also used when rendering. A value of Nothing is the equivalent of setting the lighting style to '(Current Lighting)' in the Render Image dialog.

Visual Basic
Property ActiveLightingStyle() As IStudioLightingStyle*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.ActiveLightingStyle Property


IInventorStudio.ActiveSceneStyle Property

IInventorStudio.ActiveSceneStyle Property
Summary

Property that gets and sets the active scene style. The active scene style is used when displaying the current model and is also used when rendering. A value of Nothing is the equivalent of setting the scene style to '(Current Background)' in the Render Image dialog.

Visual Basic
Property ActiveSceneStyle() As IStudioSceneStyle*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.ActiveSceneStyle Property


IInventorStudio.AnimationManager Property

IInventorStudio.AnimationManager Property
Summary

Property that returns the AnimationManager object.

Visual Basic
Property AnimationManager() As IAnimationManager**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.AnimationManager Property


IInventorStudio.RenderManager Property

IInventorStudio.RenderManager Property
Summary

Property that returns the RenderManager object.

Visual Basic
Property RenderManager() As IRenderManager**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.RenderManager Property


IInventorStudio.StudioCameras Property

IInventorStudio.StudioCameras Property
Summary

Property that returns the StudioCameras collection object. This provides access to all of the cameras defined for this document.

Visual Basic
Property StudioCameras() As IStudioCameras**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.StudioCameras Property


IInventorStudio.StudioLightingStyles Property

IInventorStudio.StudioLightingStyles Property
Summary

Property that returns the StudioLightStyles collection object. This provides access to all of the lighting styles defined for this document.

Visual Basic
Property StudioLightingStyles() As IStudioLightingStyles**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.StudioLightingStyles Property


IInventorStudio.StudioSceneStyles Property

IInventorStudio.StudioSceneStyles Property
Summary

Property that returns the StudioSceneStyles collection object. This provides access to all of the scene styles defined for this document.

Visual Basic
Property StudioSceneStyles() As IStudioSceneStyles**
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IInventorStudio Interface > IInventorStudio Properties > IInventorStudio.StudioSceneStyles Property


RenderManager CoClass

RenderManager CoClass
Summary

The RenderManager object is a utility object that provides access to the rendering capabilities of Inventor Studio.

Class Hierarchy
InventorStudioLib::RenderManager
Visual Basic
Public Class RenderManager
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > RenderManager CoClass


IRenderManager Interface

IRenderManager Interface
Summary

The RenderManager object is a utility object that provides access to the rendering capabilities of Inventor Studio.

Class Hierarchy
InventorStudioLib::IRenderManager
Visual Basic
Public Interface IRenderManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface


IRenderManager Methods

IRenderManager Methods
Summary

The methods of the IRenderManager class are listed here.

Methods
Methods
Name | Description
RenderToFile | Method that starts the rendering process and displays the results in the "Render Output" window.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Methods


IRenderManager.RenderToFile Method

IRenderManager.RenderToFile Method
Summary

Method that starts the rendering process and displays the results in the "Render Output" window.

Visual Basic
Sub RenderToFile(Filename As String, Options As [in, defaultvalue(0)] NameValueMap)
Parameters
Parameters | Description
Filename | The full filename of the output file to render to. The extension of this file will indicate the type of file to create. For example 'C:\Temp\Part.bmp' will result in a bmp type file being created and 'C:\Temp\Part.jpg' will result in a jpeg file being created.
Options | Not currently used.
Example

This sample demonstrates the rendering of the active document in Inventor Studio. Before running the sample:

1. Add a reference to 'Autodesk Inventor Studio Library'.

2. Have a part or an assembly document open, and create:

- a studio lighting style called My Light Style

- a studio camera called My Camera

- a studio scene style called My Scene Style

The rendering is output to C:\Temp\Render.bmp

Public Sub StudioRender()

    ' Find the Studio Add-In
    Dim oStudioAddin As ApplicationAddIn
    Dim oAddin As ApplicationAddIn
    For Each oAddin In ThisApplication.ApplicationAddIns
        If oAddin.ClassIdString = "{F3D38928-74D1-4814-8C24-A74CE8F3B2E3}" Then
            Set oStudioAddin = oAddin
            Exit For
        End If
    Next
    If oStudioAddin Is Nothing Then
        MsgBox "Inventor Studio Addin not loaded."
        Exit Sub
    End If

    ' Get the Inventor Studio object.
    Dim oInventorStudio As InventorStudio
    Set oInventorStudio = oStudioAddin.Automation

    ' Get the environment manager for the active document.
    Dim oEnvironmentMgr As EnvironmentManager
    Set oEnvironmentMgr = ThisApplication.ActiveDocument.EnvironmentManager

    ' Get the current environment.
    Dim oCurrentEnvironment As Environment
    Dim strEditID As String
    Call oEnvironmentMgr.GetCurrentEnvironment(oCurrentEnvironment, strEditID)

    ' Activate the Studio environment.
    Dim oStudioEnvironment As Environment
    Set oStudioEnvironment = oInventorStudio.Activate

    ' Get a reference to the RenderManager
    Dim oRenderManager As RenderManager
    Set oRenderManager = oInventorStudio.RenderManager

    ' Set the active lighting style.
    oInventorStudio.ActiveLightingStyle = _
oInventorStudio.StudioLightingStyles.Item("My Light Style")

    ' Set the Camera.
    oRenderManager.Camera = oInventorStudio.StudioCameras.Item("My Camera")

    ' Set the active Scene.
    oInventorStudio.ActiveSceneStyle = _
oInventorStudio.StudioSceneStyles.Item("My Scene Style")

    ' Set the output resolution to the size of the current view.
    oRenderManager.ImageWidth = ThisApplication.ActiveView.Width
    oRenderManager.ImageHeight = ThisApplication.ActiveView.height

    ' Render the image.
    Call oRenderManager.RenderToFile("C:\Temp\Render.bmp")

    ' Reset the environment to whatever it was before
    ' we entered the Studio environment.
    Call oEnvironmentMgr.SetCurrentEnvironment(oCurrentEnvironment)
End Sub
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Methods > IRenderManager.RenderToFile Method


IRenderManager Properties

IRenderManager Properties
Summary

The properties of the IRenderManager class are listed here.

Properties
Name | Description
AntiAliasing | Property that gets and sets the antialiasing level to use when rendering.
Camera | Property that gets and sets which camera to use when rendering. A value of Nothing is the equivalent of setting the camera to "(Current View)" in the Render Image dialog.
ImageHeight | Property that gets and sets the height of the output image in pixels.
ImageWidth | Property that gets and sets the width of the output image in pixels.
TrueReflection | Property that gets and sets whether to use true reflection or not when rendering.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Properties


IRenderManager.AntiAliasing Property

IRenderManager.AntiAliasing Property
Summary

Property that gets and sets the antialiasing level to use when rendering.

Visual Basic
Property AntiAliasing() As AntiAliasingEnum
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Properties > IRenderManager.AntiAliasing Property


IRenderManager.Camera Property

IRenderManager.Camera Property
Summary

Property that gets and sets which camera to use when rendering. A value of Nothing is the equivalent of setting the camera to "(Current View)" in the Render Image dialog.

Visual Basic
Property Camera() As IStudioCamera*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Properties > IRenderManager.Camera Property


IRenderManager.ImageHeight Property

IRenderManager.ImageHeight Property
Summary

Property that gets and sets the height of the output image in pixels.

Visual Basic
Property ImageHeight() As LONG
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Properties > IRenderManager.ImageHeight Property


IRenderManager.ImageWidth Property

IRenderManager.ImageWidth Property
Summary

Property that gets and sets the width of the output image in pixels.

Visual Basic
Property ImageWidth() As LONG
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Properties > IRenderManager.ImageWidth Property


IRenderManager.TrueReflection Property

IRenderManager.TrueReflection Property
Summary

Property that gets and sets whether to use true reflection or not when rendering.

Visual Basic
Property TrueReflection() As VARIANT_BOOL
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IRenderManager Interface > IRenderManager Properties > IRenderManager.TrueReflection Property


StudioCamera CoClass

StudioCamera CoClass
Summary

The StudioCamera object represents an Inventor Studio camera.

Class Hierarchy
InventorStudioLib::StudioCamera
Visual Basic
Public Class StudioCamera
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > StudioCamera CoClass


IStudioCamera Interface

IStudioCamera Interface
Summary

The StudioCamera object represents an Inventor Studio camera.

Class Hierarchy
InventorStudioLib::IStudioCamera
Visual Basic
Public Interface IStudioCamera
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCamera Interface


IStudioCamera Properties

IStudioCamera Properties
Summary

The properties of the IStudioCamera class are listed here.

Properties
Name | Description
Name | Property that gets and sets the name of the Inventor Studio cameras. When setting the name, the name must be unique with respect to the other cameras.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCamera Interface > IStudioCamera Properties


IStudioCamera.Name Property

IStudioCamera.Name Property
Summary

Property that gets and sets the name of the Inventor Studio cameras. When setting the name, the name must be unique with respect to the other cameras.

Visual Basic
Property Name() As String
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCamera Interface > IStudioCamera Properties > IStudioCamera.Name Property


StudioCameras CoClass

StudioCameras CoClass
Summary

The StudioCameras collection object provides access to existing StudioCamera objects.

Class Hierarchy
InventorStudioLib::StudioCameras
Visual Basic
Public Class StudioCameras
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > StudioCameras CoClass


IStudioCameras Interface

IStudioCameras Interface
Summary

The StudioCameras collection object provides access to existing StudioCamera objects.

Class Hierarchy
InventorStudioLib::IStudioCameras
Visual Basic
Public Interface IStudioCameras
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCameras Interface


IStudioCameras Methods

IStudioCameras Methods
Summary

The methods of the IStudioCameras class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified StudioCamera object from the collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCameras Interface > IStudioCameras Methods


IStudioCameras.Item Method

IStudioCameras.Item Method
Summary

Property that returns the specified StudioCamera object from the collection.

Visual Basic
Sub Item(Index As VARIANT, pVal As [out, retval] IStudioCamera*)
Parameters
Parameters | Description
Index | Input Variant that specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection or a String indicating the name of the StudioCamera. If the specified name does not exist, a failure occurs.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCameras Interface > IStudioCameras Methods > IStudioCameras.Item Method


IStudioCameras Properties

IStudioCameras Properties
Summary

The properties of the IStudioCameras class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCameras Interface > IStudioCameras Properties


IStudioCameras.Count Property

IStudioCameras.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As LONG*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioCameras Interface > IStudioCameras Properties > IStudioCameras.Count Property


StudioLightingStyle CoClass

StudioLightingStyle CoClass
Summary

The StudioLightingStyle object represents an Inventor Studio Lighting Style.

Class Hierarchy
InventorStudioLib::StudioLightingStyle
Visual Basic
Public Class StudioLightingStyle
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > StudioLightingStyle CoClass


IStudioLightingStyle Interface

IStudioLightingStyle Interface
Summary

The StudioLightingStyle object represents an Inventor Studio Lighting Style.

Class Hierarchy
InventorStudioLib::IStudioLightingStyle
Visual Basic
Public Interface IStudioLightingStyle
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyle Interface


IStudioLightingStyle Properties

IStudioLightingStyle Properties
Summary

The properties of the IStudioLightingStyle class are listed here.

Properties
Name | Description
Name | Property that gets and sets the name of the Studio lighting style. When setting the name, the name must be unique with respect to the other Studio lighting styles.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyle Interface > IStudioLightingStyle Properties


IStudioLightingStyle.Name Property

IStudioLightingStyle.Name Property
Summary

Property that gets and sets the name of the Studio lighting style. When setting the name, the name must be unique with respect to the other Studio lighting styles.

Visual Basic
Property Name() As String
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyle Interface > IStudioLightingStyle Properties > IStudioLightingStyle.Name Property


StudioLightingStyles CoClass

StudioLightingStyles CoClass
Summary

The StudioLightingStyles collection object provides access to existing StudioLightingStyle objects.

Class Hierarchy
InventorStudioLib::StudioLightingStyles
Visual Basic
Public Class StudioLightingStyles
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > StudioLightingStyles CoClass


IStudioLightingStyles Interface

IStudioLightingStyles Interface
Summary

The StudioLightingStyles collection object provides access to existing StudioLightingStyle objects.

Class Hierarchy
InventorStudioLib::IStudioLightingStyles
Visual Basic
Public Interface IStudioLightingStyles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyles Interface


IStudioLightingStyles Methods

IStudioLightingStyles Methods
Summary

The methods of the IStudioLightingStyles class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified StudioLightingStyle object from the collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyles Interface > IStudioLightingStyles Methods


IStudioLightingStyles.Item Method

IStudioLightingStyles.Item Method
Summary

Property that returns the specified StudioLightingStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, pVal As [out, retval] IStudioLightingStyle*)
Parameters
Parameters | Description
Index | Input Variant that specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection or a String indicating the name of the StudioLightingStyle. If the specified name does not exist, a failure occurs.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyles Interface > IStudioLightingStyles Methods > IStudioLightingStyles.Item Method


IStudioLightingStyles Properties

IStudioLightingStyles Properties
Summary

The properties of the IStudioLightingStyles class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyles Interface > IStudioLightingStyles Properties


IStudioLightingStyles.Count Property

IStudioLightingStyles.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As LONG*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioLightingStyles Interface > IStudioLightingStyles Properties > IStudioLightingStyles.Count Property


StudioSceneStyle CoClass

StudioSceneStyle CoClass
Summary

The StudioSceneStyle object represents an Inventor Studio Scene Style.

Class Hierarchy
InventorStudioLib::StudioSceneStyle
Visual Basic
Public Class StudioSceneStyle
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > StudioSceneStyle CoClass


IStudioSceneStyle Interface

IStudioSceneStyle Interface
Summary

The StudioSceneStyle object represents an Inventor Studio Scene Style.

Class Hierarchy
InventorStudioLib::IStudioSceneStyle
Visual Basic
Public Interface IStudioSceneStyle
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyle Interface


IStudioSceneStyle Properties

IStudioSceneStyle Properties
Summary

The properties of the IStudioSceneStyle class are listed here.

Properties
Name | Description
Name | Property that gets and sets the name of the scene style. When setting the name, the name must be unique with respect to the other Studio scene styles.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyle Interface > IStudioSceneStyle Properties


IStudioSceneStyle.Name Property

IStudioSceneStyle.Name Property
Summary

Property that gets and sets the name of the scene style. When setting the name, the name must be unique with respect to the other Studio scene styles.

Visual Basic
Property Name() As String
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyle Interface > IStudioSceneStyle Properties > IStudioSceneStyle.Name Property


StudioSceneStyles CoClass

StudioSceneStyles CoClass
Summary

The StudioSceneStyles collection object provides access to existing StudioSceneStyle objects.

Class Hierarchy
InventorStudioLib::StudioSceneStyles
Visual Basic
Public Class StudioSceneStyles
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > StudioSceneStyles CoClass


IStudioSceneStyles Interface

IStudioSceneStyles Interface
Summary

The StudioSceneStyles collection object provides access to existing StudioSceneStyle objects.

Class Hierarchy
InventorStudioLib::IStudioSceneStyles
Visual Basic
Public Interface IStudioSceneStyles
Inherits IDispatch
Notes

Members through which this object may be accessed include:

You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyles Interface


IStudioSceneStyles Methods

IStudioSceneStyles Methods
Summary

The methods of the IStudioSceneStyles class are listed here.

Methods
Methods
Name | Description
Item | Property that returns the specified StudioSceneStyle object from the collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyles Interface > IStudioSceneStyles Methods


IStudioSceneStyles.Item Method

IStudioSceneStyles.Item Method
Summary

Property that returns the specified StudioSceneStyle object from the collection.

Visual Basic
Sub Item(Index As VARIANT, pVal As [out, retval] IStudioSceneStyle*)
Parameters
Parameters | Description
Index | Input Variant that specifies the object within the collection to return. This can be either a Long to indicate the index of the item within the collection or a String indicating the name of the StudioSceneStyle. If the specified name does not exist, a failure occurs.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyles Interface > IStudioSceneStyles Methods > IStudioSceneStyles.Item Method


IStudioSceneStyles Properties

IStudioSceneStyles Properties
Summary

The properties of the IStudioSceneStyles class are listed here.

Properties
Name | Description
Count | Property that returns the number of items in this collection.
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyles Interface > IStudioSceneStyles Properties


IStudioSceneStyles.Count Property

IStudioSceneStyles.Count Property
Summary

Property that returns the number of items in this collection.

Visual Basic
Property Count() As LONG*
You are here: Symbol Reference > InventorStudioLib Library > Studio Objects > IStudioSceneStyles Interface > IStudioSceneStyles Properties > IStudioSceneStyles.Count Property


Autodesk Inventor API - Overview Articles

Autodesk Inventor API - Overviews Send comments on this topic.

Overviews

Though the primary purpose of this document is to provide a complete reference for all of Autodesk Inventor's objects, methods, properties, events and constants, this overview section is included to provide basic information to assist those who are new to using the API.

Getting Started

Using VBA in Autodesk Inventor

Creating an Inventor Add-In using VB6

Creating an Inventor Add-In using VB.Net

Registering an Add-In New!

General Concepts

Units of Measure - Working with Different Units

Transient Geometry and Matrices

Objects in Context - Proxies

File and Document References

Part and assembly modelling

Adding and Manipulating Sketches

Sketch Constraints

BRep - Representing the Boundary of a Model

Creating Part Features

Changing the Appearance of Models with Render Styles (Colors)

Construction using Work Features

Assembling Parts to Form an Assembly

Querying the Bill of Materials
Drawing document

Placing Drawing Views in 2D

Working with Balloon Labels

Tabulating Data With Custom Tables

Creating Drawing Dimensions

User Interface customization

Ribbon UI Customization

User Interface Customization Using the API

Interacting with the User

Triad Events - Using The 3D Move and Rotate Tool

Visual Cues - ClientGraphics and InteractionGraphics

Making Use of the Browser Pane

UI Browser Node Customization

Using and Creating Environments

Events

Understanding Events in Inventor

Adding custom data to a document

Information About a File - Document Properties

Using Attributes to Add Data to Objects

Changing data in a document

Encapsulating Change with the Change Processor

Grouping Operation with Transactions

Apprentice

Apprentice Server - Inventor without a UI

Client Views - Viewing Models Outside of Inventor

Advanced topics

LAM - Large Assembly Management

User-Defined Functions in Parameter Expressions

Reading and Writing Files With The DataIO Object

Zero Impact Migration

Reference Topics

List of XML text formatting tags for FormattedText

For a wide variety of additional information about customizing Inventor (including updated samples and documentation), please see www.autodesk.com/developinventor.

© Autodesk Inc. 2010. All Rights Reserved.


Inventor::Application::DisplayOptions@[out, retval] DisplayOptions**

Inventor::Application::DisplayOptions@[out, retval] DisplayOptions** Available in Inventor Available in Server Introduced in Inventor 11
Summary

Property that returns the DisplayOptions object. The DisplayOptions object provides access to various display related application level options. This is somewhat equivalent to the Display tab of the Application Options dialog.

You are here: Inventor::Application::DisplayOptions@[out, retval] DisplayOptions**


Autodesk Inventor API - Samples

Autodesk Inventor API - Samples Send commentson this topic.

Samples

Sample code listings are suitable for VBA cut-and-paste. In addition, some are also shown using C-Sharp code. To go directly to a C-Sharp listing, click on the C# identifier.

Parts
Derived Parts and Assemblies
Create a Draft Analysis
Parameters
Model Parameters
Table Parameters
Adding a custom parameter group
Selective linking of parameters from another file
Sketches
Drawing Sketches - editing line type and color
Projection - project across parts
Set Sketch Visibility
Sketch Add
Sketch Add Oriented
Sketch Delete
Sketch Display Entities
Sketch Edit Orientation
Sketch from Face Silhouette
Sketch Lines
Sketch Open for Edit
Sketch Share
Sketch Spline
Sketch Text Add
Sketch within a drawing view
Spline - create NURBS
Adding and dimensioning a sketch elliptical arc
Controlling profile constituents
Copy sketch entities to a new sketch
Region fill - sketch
Moving sketch entities to a new layer
Move sketch objects
Defer sketch updates
Offset a 2D sketch
Create 3d sketch dimension
Get region properties from a sketch profile
Create sketch block from sketch
Create sketch block Definition
Copy sketch contents New!
Features - Create
Extrude Feature - Create Block with Pocket
Create extrude feature from sketch text
Fillet Feature (All Rounds)
Fillet Feature (Complex)
Fillet Feature (Simple)
Hole Feature - Through holes (RegularAndTapped)
Create a hole feature using linear placement type
Thread Feature Create
Loft Feature With Non-Planar Section
Sweep Feature Add
Create a decal feature
Create a stitch (knit) feature
Create Delete Face/Boundary Patch/Stitch
Create a non-parametric base feature
Place table driven iFeature in a part
Place a standard iFeature in a part
Change table row that drives iFeature
Features - Edit / Query
Edit an Extrude Feature C#
Query the dimensions of a feature
Edit the profile of an extrude feature
Calculate true length of a sweep
Remove client feature elements
Edit thread feature New!
Sheet Metal and Flat Patterns
Sheet Metal Feature Display
Sheet Metal Style Creation
Sheet Metal Style Display
Sheet Metal Thickness Editing
Get Bend Extent (Tangent) Edges of Flat PatternUpdated
List punch features and IDs
Create a punch tool feature
Create sheet metal face and cut features
Create sheet metal face and flange features New!
Create sheet metal face and fold features New!
Create sheet metal lofted flange featureNew!
Create sheet metal rip feature New!
Create flange features New!
Edit width extent of flange feature New!
Assemblies
Assembly Add Occurrence C#
Assembly Count Occurrences
Assembly Ground Ocurrences
Assembly Move Occurrence
Interference Analysis
Create a level of detail representation in an assembly
Create assembly occurrence specifying representations
Open an assembly document specifying representations C#
Open assembly document in its last active LOD Representation
Create rectangular occurrence pattern in assembly
Bill of Materials
Export Assembly BOM to an external file
Associative body copy New!
Demote occurrence New!
Promote occurrence New!
Create shrink wrap substitute New!
iAssemblies / iParts
Adding iAssembly occurrences to an assembly C#
Add iPart occurrences to an assembly C#
Assembly Constraints and iMates
Assembly Insert Constraint Add
Assembly Mate Constraint Add
Assembly Mate Constraint of Work Planes
iMate Creation During Occurrence Placement
iMate Result Creation
iMate Using Entities
Create iMate definition
Assembly mate contraint with limits New!
Drawing Views
Create a base view with representations C#
Create Draft Views
Create a detail drawing view
Create multiple-view sheet from format
Break alignment of a drawing section view
Create break operation
Add flat pattern drawing view New!
Drawing Dimensions
Find and remove unattached dimensions
Align drawing dimensions
Create ordinate dimensions in a drawing document
Center dimension text
Add surface texture symbol to dimension line
Editing Dimensions
Baseline dimension sets New!
Chain dimension sets New!
Drawing Notes
Add a general note to a drawing sheet
Create a leader note on a sheet
Create bend note
Create punch note
Create hole thread note
Create stacked text
Drawing Tables
Create a parts list
Parts List Edit
Parts List Query
Create a balloon
Balloons - edit
Find the component that a balloon references
Create a Custom Table
Query the contents of the revision table
Create hole table in a drawing
Create a Bend Table
Create a Configuration Table
Create a drawing Excel Table
Drawing Symbols and Resources
Border Create & Insert
Border Insert
Border Insert Default
Title Block Definition Create and Insert Updated
Title Block Definition copy
Create and insert a SketchedSymbol definition Updated
Create sketched symbol with a leader
Create a feature control frame symbol
Edit an existing feature control frame symbol
AutoCAD block definitions import New!
AutoCAD block insertNew!
Transient BRep
Transient solid body creation New!
Transient surface body creation New!
User Interaction
The File Dialog C#
OnDrag Event - dragging a WorkPoint
Using the document OnSave event
Highlight Feature Faces
Using the measure events to measure distance and angle
Managing Errors
Display custom error message
Selection (Simple)
Selection (with a window)
Receive and cancel a double-click event
Controlling the progress/status bar
Add a control to the context menu
Single entity selection New!
Add UCS by three points New!
Add UCS by transformation New!
UI Customization
Control Definitions (Inventor Command Names)
List Environment names and descriptions
Create Ribbon panel in a tab
Contextual Ribbon tabs C#
Print details of available RibbonsUpdated
Ribbon: Add commands to Application menu
Create override environment, add Ribbon
Buttons - add MRU split button
Macro Button - create on toolbar
UI customization - create combo box control
Changing the current panel bar
Add to Browser Folder
Add dockable window New!
Client Graphics
Creating curve primitives with client graphics
Create 3D primitives using client graphics C#
Client Graphics - Draw Range Box
Client Graphics - Line
Client Graphics - Triangle
Client Graphics - Vertex Color by Z Height
Anchored Client Grahics
Text Using Client Graphics (Multiple fonts and lines)
Text Using Client Graphics (Simple)
Creating overlay graphics
Client graphics and slicing
Apply client graphics color mapping
Image in point graphics New!
Graphics from SAT file body New!
Internals
Working with reference keys
Dynamic Attributes
Create primitive (solid) BRep
Get and Set Units of Measure
Units of Measure Conversion
Import/Export
Export Sheet Metal to DXF using the DataIO object
Export SAT
Export IGES/STEP/DWF/DWG/DXF/PDF using TranslatorAddin
Printing
Printing All Sheets in Drawing
Printing Drawing
Printing Part or Assembly
Project
Create project Updated
Set active project Updated
Query and create library paths Updated
Miscellaneous
Mass Properties from Part
Work Point at Mass Center C#
Calculating mass properties without dirtying document
Material Create
Material Read
Check if cylindrical face is interior or exterior
Change the thumbnail of a document
Navigate between browser and data model
Inventor Studio
Render active document (Inventor Studio)
Content Center
Place content center part New!
Replace content center part New!

SDK Samples

The SDK Samples contain larger code samples and projects.

© Autodesk Inc. 2009. All Rights Reserved.


64bit Topics

64bit Topics
Summary

This topic details some differences when running the 64-bit version of Autodesk Inventor. Use the SoftwareVersion.Is64BitVersion property to find out whether your code is connected to a 64-bit version of Inventor.

Remarks
Creating AddIns for 64-bit Inventor - Using .NET.
  1. 32-bit components are not allowed to load in a 64-bit process address space. 64-bit Inventor requires 64-bit Addins.
  2. There is no 64-bit version of the Visual Basic compiler. VB6 is not capable of compiling 64-bit components. If you developed your AddIn in VB6 before, 64-bit Inventor cannot load it, even if you use the same registry setting. If you still want to use the VB6 project, the only workaround is to change the project settings to make the AddIn a local server instead of an in process server. i.e. build your AddIn as an ActiveX executable and register it to \Wow6432Node\ CLSID\... then it can be loaded in Inventor successfully. If you have only the 32-bit AddIn Dll of your project, without the source code, then there is no method to enable it in a 64-bit environment.
  3. It is strongly recommended that you either compile for an out of process exe component, or migrate your code to VB.Net, C# or C++.
  4. Selecting the "Register for COM Interop" option in Visual Studio (64-bit) is ineffective because it adds the entries for the AddIn in the wrong section of the registry. Other settings are the same. For example, compile the AddIn with "ANY CPU" configuration. The warning when setting to X64 can be ignored - you do not need to set it to X64 as "ANY CPU" will work. Refer to the Registration section below.
  5. 32-bit Visual Studio can run on Windows 64-bit using WOW64, and can create managed code that will run on Microsoft .NET Framework 2.0 64-bit.

Compiling 64 bit Addins
  1. Compile the Addin (using .NET just-in-time compilation) to the correct native platform. For example, for 64-bit Inventor running on a 64-bit computer, compile the Addin as a 64-bit component.
  2. If you intend your Addins to be loaded into both the 32-bit and 64-bit versions of Inventor, you can compile your .NET Addin with the platform agnostic setting ("ANY CPU"). Compiling with the "ANY CPU" setting enabled removes any concern about platform issues.
  3. If for some reason (for example, dependency on third-party libraries) you want your Addin to run only on 32-bit (or only on 64-bit) machines, then this setting can be specified when you compile the Addin. You will need a new Visual Studio configuration, with the platform set to x86 (for 32-bit) or x64(for 64-bit). Such Addin's will load only into the appropriate Inventor version.
  4. These compile options for the platform are available in the development version of Visual Studio. The express editions do not directly allow setting these options through their user interface. By default, "ANY CPU" is assumed, which is the most typical configuration required.
  5. The machine platform on which you compile your Addin doesn't matter (32-bit or 64-bit), as long as you specify the target setting in Visual Studio, the Addin will be compiled to be loaded on the particular platform specified. So it is possible to compile a 64-bit Addin on a 32-bit machine, but it will only run on a 64-bit machine.

Registration of the Addin in the correct registry section.

Note: The Add-in registration technique described in this overview is still supported and will continue to be supported as a legacy mechanism for several product releases. However, starting with Autodesk Inventor 2011, a simpler manifest-based registration mechanism is also supported, and developers are encouraged to adopt this new method. Please refer to the Add-in Registration overview for details.

  1. Registration is a different issue than compilation. The Addin will not be loaded into Inventor, even if it has been compiled with the correct platform setting, if it has not been registered properly. Since Inventor Addins are COM based, they have to be registered even if they are created using a .NET language, otherwise Inventor will not find and load them.
  2. 64-bit Inventor will only look in the HKCR registry section for Inventor Addins (it will not look in the HKCR\Wow6432 section because it will not load 32bit Addins). For 32-bit Inventor, there's no confusion because there is only one section of the registry.
  3. When you register your Addin on 64-bit machines running 32-bit Inventor, you have to make sure it is registered in the regular HKCR section (and not in the HKCR\Wow6432 section). If this is done and the Addin has been compiled to be run on that platform (e.g. "ANY CPU") then the Addin should be loaded without problems. If the Addin is registered incorrectly, e.g. registered in the HKCR\Wow6432 section, then it will not be loaded even if it has been compiled to be run on that platform (e.g. "ANY CPU") because this section of the registry will not be searched by 64bit Inventor.
  4. The second way to register an Addin is to use a utility supplied with the framework. The regasm.exe utility is a .NET utility that can also be used to register Inventor Addins. Since this is a .NET framework utility, there are two versions of this: 32-bit and 64-bit, that come with the corresponding version of the framework. On 64-bit machines, if you register your Addin using the 64-bit version of regasm.exe, it will access the correct section of the registry and add the Addin entries. 64-bit Inventor will then be able to find this Addin in the registry and load it. However, if you use the 32-bit version of regasm.exe on 64-bit machines, then you will have the same problem as using 32-bit Visual Studio to register it. The registry entries will be added to the WOW6432 section and Inventor will not load the Addin. On 32-bit machines, there's no issue because the 32-bit version of regasm.exe will do the right thing. Always use the correct version of regasm.exe to have the Addin added to the correct section in the registry.
  5. An example of using the regasm utlity might be: regasm.exe /codebase SimpleAddIn.dll
  6. The regasm utility will be located in a directory under the 64-bit framework. For example, for Microsoft .NET Framework 2.0 64-bit, the location will be similar to this: C:\windows\Microsoft.NET\Framework64\v2.0.50727\regasm.exe

To Summarize

When compiling your Addin, if you choose 'ANY CPU' setting, your Addin will be compiled to be loaded correctly irrespective of the platform on which Inventor is running. The registration of the Addin is more complex. For a 64-bit machine, just remember to register using the 64-bit version of regasm.exe. You can manually do this registration, or add it as a separate post-build step in Visual Studio.

Notes

VBA in 64-bit Inventor is implemented only as an out-of-process 32-bit component. Therefore, for 64-bit Inventor, a 32-bit process is used to host VBA. Thus all the API calls are out-of-process calls. This has several implications:

  1. In some cases, API calls can cause Inventor to update its UI. This can cause your VBA code to slow down. For long operations, where your code makes multiple calls to Inventor, you can regain performance by disabling the Inventor UI. To do so, set the UserInterfaceManager.UserInteractionDisabled property. Please do this carefully, as you are responsible for resetting this property afterwards. Note that this slowdown does not happen when your code is responding to an event raised by Inventor.
  2. The FileManager.FileSystemObject property returns Microsoft's scripting FileSystemObject which is instantiated in Inventor's process space. Using FileSystemObject directly in 64-bit space gives the wrong current directory etc. Therefore you should avoid using built-in VBA functions such as chdir$.
  3. To wait for Inventor to complete processing of pending windows messages, you need to use UserInterfaceManager.DoEvents instead of the builtin DoEvents subroutine in VBA.
  4. ThisDocument in Document projects is not supported. You can embed a VBA project in any Inventor document. Usually in a macro within such a project, you can use ThisDocument property to refer to the document itself. With VBA for 64-bit Inventor, ThisDocument object no longer refers to the document. Instead for 32 & 64 bit VBA compatibility, you will need to manually replace all the references to ThisDocument by ThisDocument.InventorDocument.
  5. No VB6 support for creating Addins You can not use VB 6.0 to create Add-ins for 64 bit Inventor.
  6. Handles in 64-bit Windows are supposed to be 64-bit. However only the lower 32-bits are significant and the rest are zero. Therefore Application.MainFrameHWND returns 'long' type which works in 32-bit Inventor. You just need to "zero out" the higher bits. You can use the handle in a 32-bit process as well.
  7. Application.GetInterfaceObject32 creates the COM in-proc server object in the 32-bit host that is used to host VBA. It requires that if the typelib is also registered in the 64-bit registry, then the methods and properties should match.
  8. The ApplicationEvents.OnRestart32BitHost event is fired when the 32-bit host process is restarted for any reason.
  9. Some of the Inventor API methods and properties use IPictureDisp interface when working with icons/images. This interface does not work across process boundaries. Thus any such methods cannot be used in 64-bit Inventor VBA.
  10. Use of Me in Document projects is not supported. You can embed a VBA project in any Inventor document. Usually in a macro within such a project, you can use Me property to refer to the document itself. On the VBA for 64-bit Inventor, Me object no longer refers to the document. Instead for 32 & 64 bit VBA compatibility, you will need to manually replace all the references to Me by Me.InventorDocument.
You are here: 64bit Topics


VBA to .Net Quick Reference

VBA to .Net Quick Reference
Summary

The following tables compare VBA functions with their similar VB.NET and C# functions and operators. This is provided as a quick reference - please refer to the .Net documentation from Microsoft for detailed information.

Remarks

Math Functions

ActiveX, VBA, or Visual Basic 6 | VB.NET and C# equivalent (same unless noted)
+ (addition operator) | + (addition operator)
- (subtraction operator) | - (subtraction operator)
* (multiplication operator) | * (multiplication operator)
/ (division operator) | / (division operator)
^ (exponentiation operator) | ^ (exponentiation operator)
Abs function | System.Math.Abs function
Atn function | System.Math.Atan function
Cos function | System.Math.Cos function
Exp function | System.Math.Exp function
Log function | System.Math.Log function
Max function | System.Math.Max function
Min function | System.Math.Min function
Mod function | VB.NET Mod function C# % (operator) VB.NET and C# System.Math.DivRem function
Sin function | System.Math.Sin function
Sqr function | System.Math.Sqrt function

Conditional and Loop Statements

ActiveX, VBA, or Visual Basic 6 | VB.NET and C# equivalent (same unless noted)
"Do Until" Loop statement | VB.NET Do Until... Loop statement C# Use do... while statement
"Do While" Loop statement | VB.NET Do While... Loop statement C# do... while statement
For Each...Next statement | VB.NET For Each...Next statement C# Foreach and For statements
If" Then" Else...End If statement | VB.NET If" Then" Else...End If statement C# if... else... statement
Select Case statement | VB.NET Select Case statement C# Switch statement
While" Wend statement | VB.NET While... Wend statement C# while... statement

Logic Statements

ActiveX, VBA, or Visual Basic 6 | VB.NET and C# equivalent (same unless noted)
= (equal to comparison operator) | VB.NET = (equal to comparison operator) C# == (equal to comparison operator)
<> (not equal to comparison operator) | VB.NET <> (not equal to comparison operator) C# != (not equal to comparison operator)
< (less than comparison operator) | < (less than comparison operator)
<= (less than or equal to comparison operator) | <= (less than or equal to comparison operator)
> (greater than comparison operator) | > (greater than comparison operator)
>= (greater than or equal to comparison operator) | >= (greater than or equal to comparison operator)
And function | VB.NET And operator C# && operator
Eqv operator | Not provided, use other bitwise comparison methods instead
Imp operator | Not provided, use = comparison instead
Is operator | VB.NET object Is object C# object is object
IsArray function | VB.NET IsArray function or TypeOf arrayName Is Array comparison C# typeof(arrayName) == Array comparison VB.NET and C# varName.GetType().IsArray
IsNull function | VB.NET IsDBNull function C# Use == null comparison
Like operator | VB.NET Like operator VB.NET and C# stringVariable.Contains function
Not operator | VB.NET Not operator C# != (not equal to comparison operator)
Or function | VB.NET Or function C# || operator

Type Conversion Statements

ActiveX, VBA, or Visual Basic 6 | VB.NET and C# equivalent (same unless noted)
Asc function | VB.NET Asc function C# (int)"letter"
CDbl Function | VB.NET CDbl function VB.NET and C# System.Convert.ToDouble function
Chr function | VB.NET Chr function VB.NET and C# System.Convert.ToChar
CInt Function | VB.NET CInt function VB.NET and C# System.Convert.ToInt16, System.Convert.ToInt32, or System.Convert.ToInt64 function
Fix function | VB.NET Fix function VB.NET and C# System.Convert.ToInt16, System.Convert.ToInt32, or System.Convert.ToInt64 function
Int function | VB.NET Int function VB.NET and C# System.Convert.ToInt16, System.Convert.ToInt32, or System.Convert.ToInt64 function
Str function | VB.NET Str function VB.NET and C# System.Convert.ToString function
StrConv function | VB.NET StrConv function VB.NET and C# System.Text.Encoding.Convert function

Basic String Manipulation Functions

ActiveX, VBA, or Visual Basic 6 | VB.NET and C# equivalent (same unless noted)
& operator (concatenate string) | VB.NET & or + operator C# + operator
Len function | VB.NET Len function VB.NET and C# stringVariable.Length property
Mid function | VB.NET Mid function VB.NET and C# stringVariable.Substring function

Basic VBA and Visual Basic 6 Functions and Statements

ActiveX, VBA, or Visual Basic 6 | VB.NET and C# equivalent (same unless noted)
AppActivatefunction | VB.NET AppActivate VB.NET and C# Use the Win32 Calls ShowWindow and SetWindowPos
Dir function | System.IO.Directory.Exists function
Error object/method/properties | VB.NET Error object/method/properties VB.NET and C# Try Catch statement with exception handling
Function and End Function keywords | VB.NET Function and End Function keywords and use Return to return a value C# Define a procedure and use return to return a value
Input function | VB.NET Input method VB.NET and C# fileStream.Read method
LBound(arrayName) function | VB.NET LBound(arrayName) function VB.NET and C# arrayName.GetLowerBound function
Line Input function | VB.NET LineInput method VB.NET and C# fileStream.Read method
MsgBox function | MessageBox.Show method
object(n) syntax | VB.NET object(n) syntax C# object[n] syntax
Open function | System.IO.File.Open function
ReDim statement | VB.NET ReDim arrayName(newSize) VB.NET and C# arrayName.Resize
Set statement | Not needed/provided
Shell function | VB.NET Shell function VB.NET and C# System.Diagnostics.Process.Start function
Sub and End Sub keywords | VB.NET Sub and End Sub keywords C# Define a procedure
TypeName function | VB.NET TypeName function VB.NET and C# varName.GetType().Name or varName.GetType().FullName functions
UBound(arrayName) function | VB.NET UBound(arrayName) function VB.NET and C# arrayName.GetUpperBound function
You are here: VBA to .Net Quick Reference


Autodesk Inventor API - What's New

Autodesk Inventor API Send comments on this topic.

Differences between the Autodesk Inventor 2011 and Autodesk Inventor 2012 APIs

  • Click here to see Information for developers with existing code
  • Click here to see a list of newly added objects.
  • Click here to see a list of removed APIs.
  • Click here to see a list of newly added functions on existing objects.
  • Click here to see a list of modified functions.

    • Information for developers with existing code

    1. Inventor 2012 supports the ability to create an add-in that does not need to be registered. For more information, see the topic Add-In-Registration
    2. Inventor 2012 introduces the new radial and linear menus that replace the standard context menu. The previous OnContextMenu event will continue to be fired and will affect the contents of the linear menu. However, the OnContextMenu has been hidden with the expectation that all new programs will use the new OnLinearMarkingMenu event instead. Existing programs should also be converted to use this new event.
    3. The API for the extrude feature has been re-designed to follow the concept where you first create a definition object, populate it, and then use it to create the feature. This allows the API to be easily updated to add support for new options in the future. The previous interface has been hidden but still functions to allow for backward compatibility.
    4. The architecture for Inventor?s help has been completely redone in Inventor 2012. Instead of local chm files it is now web based wiki help. There are a minimal set of files delivered for local help with the majority of the content on the web with the option to install the full help content locally.
      This change resulted in a change to some API functionality since it?s used internally by Inventor to invoke help. The changes are to the DisplayHelpTopic and DisplayHelpContext methods of the HelpManager object. Given a help topic or context to an old topic in a chm file there is an internal look-up table that will redirect it to the equivalent topic in the new wiki help. These methods should continue to work as before for displaying topics from your own help files.
    5. The option to show help when Inventor starts up is no longer supported by Inventor. The GeneralOptions.ShowHelpDialogOnStartup property has been removed. Any existing binaries that use this function will continue to work, but setting the property will have no effect and it will always return False.

    High-level list of API enhancements

    The following 42 New Objects (with 521 new functions) have been added:
    • BalloonTip
    • BalloonTips
    • BIMCableTrayConnectorDefinition
    • BIMComponent
    • BIMComponentDescription
    • BIMComponentProperty
    • BIMComponentPropertySet
    • BIMComponentPropertySets
    • BIMConduitConnectorDefinition
    • BIMConnector
    • BIMConnectorDefinition
    • BIMConnectorLink
    • BIMConnectorLinks
    • BIMConnectors
    • BIMDuctConnectorDefinition
    • BIMElectricalConnectorDefinition
    • BIMExchangeServer
    • BIMPipeConnectorDefinition
    • BossSet
    • BossSets
    • ComponentGraphics
    • DockableWindowsEvents
    • DragContext
    • DriveConstraintSettings
    • ExtrudeDefinition
    • HelpEvents
    • MiniToolbar
    • MiniToolbarButton
    • MiniToolbarCheckBox
    • MiniToolbarComboBox
    • MiniToolbarControl
    • MiniToolbarControls
    • MiniToolbarDropdown
    • MiniToolbarListItem
    • MiniToolbarValueEditor
    • ProjectOptionsButton
    • RadialMarkingMenu
    • ReferenceKeyEvents
    • RibDefinition
    • SilhouetteCurve
    • SilhouetteCurveProxy
    • SilhouetteCurves

    The following 43 functions have been removed:
    • ApplicationAddIn.StartUpEnabled
    • ExtrudeFeature.Extent
    • ExtrudeFeature.ExtentTwo
    • ExtrudeFeature.ExtentTwoType
    • ExtrudeFeature.ExtentType
    • ExtrudeFeature.IsTwoDirectional
    • ExtrudeFeature.Operation
    • ExtrudeFeature.Profile
    • ExtrudeFeature.SetDistanceExtent
    • ExtrudeFeature.SetFromToExtent
    • ExtrudeFeature.SetThroughAllExtent
    • ExtrudeFeature.SetToExtent
    • ExtrudeFeature.SetToNextExtent
    • ExtrudeFeature.TaperAngle
    • ExtrudeFeature.TaperAngleTwo
    • ExtrudeFeatureProxy.Extent
    • ExtrudeFeatureProxy.ExtentTwo
    • ExtrudeFeatureProxy.ExtentTwoType
    • ExtrudeFeatureProxy.ExtentType
    • ExtrudeFeatureProxy.IsTwoDirectional
    • ExtrudeFeatureProxy.Operation
    • ExtrudeFeatureProxy.Profile
    • ExtrudeFeatureProxy.SetDistanceExtent
    • ExtrudeFeatureProxy.SetFromToExtent
    • ExtrudeFeatureProxy.SetThroughAllExtent
    • ExtrudeFeatureProxy.SetToExtent
    • ExtrudeFeatureProxy.SetToNextExtent
    • ExtrudeFeatureProxy.TaperAngle
    • ExtrudeFeatureProxy.TaperAngleTwo
    • ExtrudeFeatures.AddByDistanceExtent
    • ExtrudeFeatures.AddByFromToExtent
    • ExtrudeFeatures.AddByThroughAllExtent
    • ExtrudeFeatures.AddByToExtent
    • ExtrudeFeatures.AddByToNextExtent
    • GeneralOptions.ShowHelpDialogOnStartup
    • HelpManager.DisplayHelpContext
    • HelpManager.DisplayHelpTopic
    • RepresentationEvents.OnActivateDesignViewRepresentation
    • RepresentationEvents.OnNewDesignViewRepresentation
    • RepresentationsManager.PrivateRepresentationFileLoaded
    • RepresentationsManager.PrivateRepresentationFileName
    • TranslatorAddIn.StartUpEnabled
    • UserInputEvents.OnContextMenu

    The following 317 new functions have been added on Existing Objects
       AliasFreeformFeature.ExtendedName
   AliasFreeformFeatureProxy.ExtendedName
   AngleConstraint.DriveConstraintSettings
   AngleConstraintProxy.DriveConstraintSettings
   Application.IsSubscriptionActive
   Application.OpenDocumentsDisplay
   ApplicationAddIn.LoadAutomatically
   ApplicationAddIn.LoadBehavior
   AssemblyComponentDefinition.BIMComponent
   AssemblyConstraint.DriveConstraintSettings
   BendFeature.ExtendedName
   BendFeatureProxy.ExtendedName
   BendPartFeature.ExtendedName
   BendPartFeatureProxy.ExtendedName
   BossFeature.ExtendedName
   BossFeatureProxy.ExtendedName
   BoundaryPatchFeature.ExtendedName
   BoundaryPatchFeatureProxy.ExtendedName
   Camera.CreateImage
   Camera.SaveAsBitmap
   Camera.SceneObject
   ChamferFeature.ExtendedName
   ChamferFeatureProxy.ExtendedName
   CircularPatternFeature.ExtendedName
   CircularPatternFeatureProxy.ExtendedName
   ClientFeature.ExtendedName
   ClientFeatureDefinition.GraphicsDataSetsCollection
   ClientFeatureProxy.ExtendedName
   ClientGraphics.NonTransacting
   ClientGraphicsCollection.AddNonTransacting
   CoilFeature.ExtendedName
   CoilFeatureProxy.ExtendedName
   CombineFeature.ExtendedName
   CombineFeatureProxy.ExtendedName
   ComboBoxDefinition.OnHelp
   CommandManager.CreateDragContext
   CommandManager.CreateMiniToolbar
   ComponentOccurrence.Application
   ComponentOccurrence.Parent
   ComponentOccurrenceProxy.Application
   ComponentOccurrenceProxy.Parent
   ContourFlangeFeature.ExtendedName
   ContourFlangeFeatureProxy.ExtendedName
   ContourRollFeature.ExtendedName
   ContourRollFeatureProxy.ExtendedName
   CornerChamferFeature.ExtendedName
   CornerChamferFeatureProxy.ExtendedName
   CornerFeature.ExtendedName
   CornerFeatureProxy.ExtendedName
   CornerRoundFeature.ExtendedName
   CornerRoundFeatureProxy.ExtendedName
   CosmeticBendFeature.ExtendedName
   CosmeticBendFeatureProxy.ExtendedName
   CosmeticWeld.Edges
   CutFeature.ExtendedName
   CutFeatureProxy.ExtendedName
   DecalFeature.ExtendedName
   DecalFeatureProxy.ExtendedName
   DeleteFaceFeature.ExtendedName
   DeleteFaceFeatureProxy.ExtendedName
   DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean
   DerivedAssemblyOccurrence.FailedBooleanOperation
   DerivedPartCoordinateSystemDef.ActiveDesignViewRepresentation
   DerivedPartCoordinateSystemDef.ReducedMemoryMode
   DerivedPartCoordinateSystemDef.UseColorOverridesFromSource
   DerivedPartDefinition.ActiveDesignViewRepresentation
   DerivedPartDefinition.ReducedMemoryMode
   DerivedPartDefinition.UseColorOverridesFromSource
   DerivedPartTransformDef.ActiveDesignViewRepresentation
   DerivedPartTransformDef.ReducedMemoryMode
   DerivedPartTransformDef.UseColorOverridesFromSource
   DerivedPartUniformScaleDef.ActiveDesignViewRepresentation
   DerivedPartUniformScaleDef.ReducedMemoryMode
   DerivedPartUniformScaleDef.UseColorOverridesFromSource
   DesignProjectManager.AddOptionsButton
   DetailDrawingView.InsertInModelSpace
   DetailDrawingView.IsUpdateComplete
   DetailDrawingView.ViewOrientationFromBase
   DiameterDimConstraint.AnchorPoints
   DiameterDimConstraintProxy.AnchorPoints
   DimensionConstraint.AnchorPoints
   DimensionConstraint3D.AnchorPoints
   DimensionStyle.OrdinateDimensionOriginArrowheadType
   DisplayOptions.RayTracingQuality
   DisplayOptions.UseRayTracingForRealisticDisplay
   DisplaySettings.RayTracingQuality
   DisplaySettings.UseRayTracingForRealisticDisplay
   DockableWindow.Caption
   DockableWindow.ShowTitleBar
   DockableWindows.Events
   DrawingOptions.EnableBackgroundUpdates
   DrawingView.InsertInModelSpace
   DrawingView.IsUpdateComplete
   DrawingView.ViewOrientationFromBase
   EllipseRadiusDimConstraint.AnchorPoints
   EllipseRadiusDimConstraintProxy.AnchorPoints
   EmbossFeature.ExtendedName
   EmbossFeatureProxy.ExtendedName
   Environment.GetRadialMarkingMenu
   ExtendFeature.ExtendedName
   ExtendFeatureProxy.ExtendedName
   ExtrudeFeature.Definition
   ExtrudeFeature.ExtendedName
   ExtrudeFeatureProxy.Definition
   ExtrudeFeatureProxy.ExtendedName
   ExtrudeFeatures.Add
   ExtrudeFeatures.CreateExtrudeDefinition
   Face.GetTextureScale
   FaceDraftFeature.ExtendedName
   FaceDraftFeatureProxy.ExtendedName
   FaceFeature.ExtendedName
   FaceFeatureProxy.ExtendedName
   FaceProxy.GetTextureScale
   FeatureDimension.AnchorPoints
   FeatureDimension.AttributeSets
   FeatureDimension.DimensionType
   FeatureDimension.GetReferenceKey
   FeatureDimensionProxy.AnchorPoints
   FeatureDimensionProxy.AttributeSets
   FeatureDimensionProxy.DimensionType
   FeatureDimensionProxy.GetReferenceKey
   FilletFeature.ExtendedName
   FilletFeatureProxy.ExtendedName
   FilletVariableRadiusEdgeSet.ContinuityType
   FlangeFeature.ExtendedName
   FlangeFeatureProxy.ExtendedName
   FlatPattern.RepresentationsManager
   FlushConstraint.DriveConstraintSettings
   FlushConstraintProxy.DriveConstraintSettings
   FoldFeature.ExtendedName
   FoldFeatureProxy.ExtendedName
   GeneralOptions.LoadVBAOnStartup
   GraphicsDataSets.NonTransacting
   GraphicsDataSetsCollection.AddNonTransacting
   GraphicsNode.AddComponentGraphics
   GraphicsNode.DisplayName
   GraphicsNodeProxy.AddComponentGraphics
   GraphicsNodeProxy.DisplayName
   GraphicsTextureCoordinateSet.TextureDimension
   GrillFeature.ExtendedName
   GrillFeatureProxy.ExtendedName
   GroundPlaneSettings.FrontDirection
   GroundPlaneSettings.UpDirection
   HelpManager.HelpEvents
   HemFeature.ExtendedName
   HemFeatureProxy.ExtendedName
   HoleFeature.ExtendedName
   HoleFeatureProxy.ExtendedName
   iFeature.ExtendedName
   iFeatureProxy.ExtendedName
   InsertConstraint.DriveConstraintSettings
   InsertConstraintProxy.DriveConstraintSettings
   InteractionEvents.CreateMiniToolbar
   InterferenceResult.InterferenceBody
   KnitFeature.ExtendedName
   KnitFeatureProxy.ExtendedName
   LineLengthDimConstraint3D.AnchorPoints
   LineLengthDimConstraint3DProxy.AnchorPoints
   LipFeature.ExtendedName
   LipFeatureProxy.ExtendedName
   LoftedFlangeFeature.ExtendedName
   LoftedFlangeFeatureProxy.ExtendedName
   LoftFeature.ExtendedName
   LoftFeatureProxy.ExtendedName
   MassProperties.RotationToPrincipal
   MateConstraint.DriveConstraintSettings
   MateConstraintProxy.DriveConstraintSettings
   Material.ExternalMaterialId
   MirrorFeature.ExtendedName
   MirrorFeatureProxy.ExtendedName
   MoveFaceFeature.ExtendedName
   MoveFaceFeatureProxy.ExtendedName
   MoveFeature.ExtendedName
   MoveFeatureProxy.ExtendedName
   NameValueMap.Insert
   NonParametricBaseFeature.ExtendedName
   NonParametricBaseFeatureProxy.ExtendedName
   OffsetDimConstraint.AnchorPoints
   OffsetDimConstraintProxy.AnchorPoints
   OffsetSplineDimConstraint.AnchorPoints
   OffsetSplineDimConstraintProxy.AnchorPoints
   OrdinateDimensionSet.OriginArrowheadType
   ParameterTable.ReferencedFileDescriptor
   PartComponentDefinition.BIMComponent
   PartComponentDefinition.RepresentationsManager
   PartFeature.ExtendedName
   PartOptions.DefaultDesignView
   PartOptions.DefaultDesignViewIsAssociative
   PartOptions.DisplayExtendedName
   Plane.IntersectWithSurface
   PointAndPlaneDistanceDimConstraint3D.AnchorPoints
   PointAndPlaneDistanceDimConstraint3DProxy.AnchorPoints
   PunchToolFeature.ExtendedName
   PunchToolFeatureProxy.ExtendedName
   RadiusDimConstraint.AnchorPoints
   RadiusDimConstraint3D.AnchorPoints
   RadiusDimConstraint3DProxy.AnchorPoints
   RadiusDimConstraintProxy.AnchorPoints
   RectangularPatternFeature.ExtendedName
   RectangularPatternFeatureProxy.ExtendedName
   ReferenceFeature.ExtendedName
   ReferenceFeatureProxy.ExtendedName
   RefoldFeature.ExtendedName
   RefoldFeatureProxy.ExtendedName
   RegionProperties.CentroidMomentsOfInertia
   ReplaceFaceFeature.ExtendedName
   ReplaceFaceFeatureProxy.ExtendedName
   RepresentationEvents.OnActivateDesignView
   RepresentationEvents.OnNewDesignView
   RestFeature.ExtendedName
   RestFeatureProxy.ExtendedName
   RevisionTable.ColumnHeaderTextStyle
   RevisionTable.DataTextStyle
   RevisionTable.Export
   RevisionTable.HeadingGap
   RevisionTable.HeadingPlacement
   RevisionTable.IsSheetScope
   RevisionTable.MaximumRows
   RevisionTable.NumberOfSections
   RevisionTable.Rotation
   RevisionTable.RowGap
   RevisionTable.RowLineSpacing
   RevisionTable.ShowTitle
   RevisionTable.Sort
   RevisionTable.TableDirection
   RevisionTable.TitleTextStyle
   RevisionTable.UpdatePropertyToRevisionNumber
   RevisionTable.WrapAutomatically
   RevisionTable.WrapLeft
   RevisionTableColumn.CustomPropertyName
   RevisionTableColumn.GetFilePropertyId
   RevisionTableColumn.PropertyType
   RevisionTableColumn.Reposition
   RevisionTableColumns.Add
   RevisionTableRow.Custom
   RevisionTableRow.Reposition
   RevisionTableRow.Visible
   RevisionTableRows.AddCustom
   RevisionTables.Add2
   RevolveFeature.ExtendedName
   RevolveFeatureProxy.ExtendedName
   RibbonPanel.Move
   RibFeature.Definition
   RibFeature.ExtendedName
   RibFeatureProxy.Definition
   RibFeatureProxy.ExtendedName
   RibFeatures.Add
   RibFeatures.CreateDefinition
   RipFeature.ExtendedName
   RipFeatureProxy.ExtendedName
   RotateRotateConstraint.DriveConstraintSettings
   RotateRotateConstraintProxy.DriveConstraintSettings
   RotateTranslateConstraint.DriveConstraintSettings
   RotateTranslateConstraintProxy.DriveConstraintSettings
   RuleFilletFeature.ExtendedName
   RuleFilletFeatureProxy.ExtendedName
   SculptFeature.ExtendedName
   SculptFeatureProxy.ExtendedName
   SectionDrawingView.InsertInModelSpace
   SectionDrawingView.IsUpdateComplete
   SectionDrawingView.ViewOrientationFromBase
   SheetMetalComponentDefinition.BIMComponent
   SheetMetalComponentDefinition.RepresentationsManager
   ShellFeature.ExtendedName
   ShellFeatureProxy.ExtendedName
   Sketch3D.SilhouetteCurves
   Sketch3DProxy.SilhouetteCurves
   SnapFitFeature.ExtendedName
   SnapFitFeatureProxy.ExtendedName
   SoftwareVersion.ProductName
   SplitFeature.ExtendedName
   SplitFeatureProxy.ExtendedName
   SweepFeature.ExtendedName
   SweepFeatureProxy.ExtendedName
   TangentConstraint.DriveConstraintSettings
   TangentConstraintProxy.DriveConstraintSettings
   TangentDistanceDimConstraint.AnchorPoints
   TangentDistanceDimConstraintProxy.AnchorPoints
   TextGraphics.BurnThrough
   ThickenFeature.ExtendedName
   ThickenFeatureProxy.ExtendedName
   ThreadFeature.ExtendedName
   ThreadFeatureProxy.ExtendedName
   ThreePointAngleDimConstraint.AnchorPoints
   ThreePointAngleDimConstraintProxy.AnchorPoints
   TransientGeometry.CurveCurveIntersection
   TransientGeometry.CurveSurfaceIntersection
   TransientGeometry.SurfaceSurfaceIntersection
   TransientObjects.CreateCamera
   TransitionalConstraint.DriveConstraintSettings
   TransitionalConstraintProxy.DriveConstraintSettings
   TranslateTranslateConstraint.DriveConstraintSettings
   TranslateTranslateConstraintProxy.DriveConstraintSettings
   TranslatorAddIn.LoadAutomatically
   TranslatorAddIn.LoadBehavior
   TrimFeature.ExtendedName
   TrimFeatureProxy.ExtendedName
   TwoLineAngleDimConstraint.AnchorPoints
   TwoLineAngleDimConstraint3D.AnchorPoints
   TwoLineAngleDimConstraint3DProxy.AnchorPoints
   TwoLineAngleDimConstraintProxy.AnchorPoints
   TwoPointDistanceDimConstraint.AnchorPoints
   TwoPointDistanceDimConstraint3D.AnchorPoints
   TwoPointDistanceDimConstraint3DProxy.AnchorPoints
   TwoPointDistanceDimConstraintProxy.AnchorPoints
   UnfoldFeature.ExtendedName
   UnfoldFeatureProxy.ExtendedName
   UserInputEvents.OnContextualMiniToolbar
   UserInputEvents.OnLinearMarkingMenu
   UserInputEvents.OnRadialMarkingMenu
   UserInterfaceManager.BalloonTips
   UserInterfaceManager.ShowMarkingMenu
   View.RayTracing
   View.RayTracingQuality
   WeldBead.FaceSetOne
   WeldBead.FaceSetTwo
   WeldmentComponentDefinition.BIMComponent

    The following 5 functions have been modified:
    •    AttributeManager.FindObjectsByPattern
    Old: Method FindObjectsByPattern(  (In) xslPattern As String ) As ObjectCollection
    New: Method FindObjectsByPattern(  (In) XPath As String ) As ObjectCollection

    •    ComponentOccurrence.SetDesignViewRepresentation
    Old: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) PrivateRepresentationFileName As String], [ (In) Associative As Boolean] )
    New: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) Reserved As String], [ (In) Associative As Boolean] )

    •    ComponentOccurrenceProxy.SetDesignViewRepresentation
    Old: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) PrivateRepresentationFileName As String], [ (In) Associative As Boolean] )
    New: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) Reserved As String], [ (In) Associative As Boolean] )

    •    DesignViewRepresentations.Add
    Old: Method Add( [ (In) Name As String], [ (In) Private As Boolean] ) As DesignViewRepresentation
    New: Method Add( [ (In) Name As String], [ (In) Reserved As Boolean] ) As DesignViewRepresentation

    •    RevisionTableRow.IsActiveRow
    Old: Read-only Property IsActiveRow(  ) As Boolean
    New: Read-write Property IsActiveRow(  ) As Boolean


Autodesk Inventor API - Sample Code Disclaimer

Autodesk Inventor API - Sample Code Disclaimer Send comments on this topic.

Disclaimer

The sample code provided in this help system and in the Autodesk Inventor Software Developers Kit is intended as an aid for learning application development techniques for Autodesk Inventor and as such is provided "as-is". The sample code is covered by the relevant sections of the Autodesk Inventor license agreement, repeated below.

AUTODESK, INC. LICENSE AGREEMENT NOTICE TO USER:

AUTODESK IS WILLING TO LICENSE THE ACCOMPANYING SOFTWARE TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE AGREEMENT AND ANY SUPPLEMENTARY OR UNIQUE LICENSE TERMS INCLUDED HEREWITH ("AGREEMENT").

YOUR USE OF THE SOFTWARE INDICATES YOUR ASSENT TO BE BOUND BY THE LICENSE TERMS SET FORTH BELOW.

This Autodesk, Inc. ("Autodesk") License Agreement accompanies an Autodesk software product and related explanatory materials ("Software"). The term "Software" shall also include any upgrades, modified versions or updates of the Software licensed to you by Autodesk.

Autodesk grants to you a nonexclusive limited license to use and copy the Software, provided that you agree to the following:

1. USE OF THE SOFTWARE.

You may install the Software in a single location on a single hard disk or other storage device; post and make available the Software on a network file server for the purpose of installation onto hard disks or other storage devices or use of the Software over such network; and make backup copies of the Software. You may make unlimited copies of the Software and give copies to other persons or entities, including downloading the Software from the Internet or similar on-line source, so long as all such copies contain this Agreement and the same copyright and other proprietary notices that appear on or in the Software.

2. COPYRIGHT/PROPRIETARY RIGHTS.

The Software is owned by Autodesk and its suppliers, and its structure, organization and code are the valuable trade secrets of Autodesk and its suppliers. The Software is also protected by copyright law and international treaty provisions. You may use trademarks only to identify printed output produced by the Software, in accordance with accepted trademark practice, including identification of trademark owner's name. Such use of any trademark does not give you any rights of ownership in that trademark. Except as stated above, this Agreement does not grant you any intellectual property rights in the Software.

3. RESTRICTIONS.

You agree not to rent, lease, modify, adapt, translate, reverse engineer, decompile, or disassemble the Software or otherwise attempt to discover the source code of the Software except to the extent permitted by law where this is indispensable to obtain the information necessary to achieve interoperability of an independently created program with the Software or with another program and such information is not readily available from Autodesk or elsewhere. You may not decompile the Software if such information is available by licensing any Autodesk Software Developer's Kit or other Autodesk software product through an Authorized Autodesk Reseller or a local Autodesk office.

You understand and acknowledge that this Agreement provides for the copying and distribution of the Software in its entirety and does not allow for partial distribution of any of the components (.dlls or other files) that make up the Software. Creating derivatives of the Software is strictly prohibited. Redistribution of: (i) the Software that is integrated with other technology as a component or standalone product and does not provide end user access to the complete install process; (ii) incomplete, modified, reverse engineered, or otherwise altered copies of the Software, is not permitted and will result in termination of this Agreement.

COPYING THE SOFTWARE EXCEPT AS PERMITTED BY THIS END USER LICENSE AGREEMENT IS COPYRIGHT INFRINGEMENT UNDER THE LAWS OF YOUR COUNTRY. IF YOU COPY THE SOFTWARE IN VIOLATION OF THIS END USER LICENSE AGREEMENT THEN YOU ARE VIOLATING THE LAW. YOU MAY BE LIABLE TO AUTODESK FOR DAMAGES AND YOU MAY BE SUBJECT TO CRIMINAL PENALTIES.

4. NO WARRANTY.

The Software is provided to you "AS IS," and you acknowledge that it may contain errors. Autodesk disclaims any warranty or liability obligations to you of any kind.

AUTODESK AND ITS SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY OBTAIN BY USING THE SOFTWARE OR DOCUMENTATION. AUTODESK AND ITS SUPPLIERS MAKE NO WARRANTIES, EXPRESS OR IMPLIED, AS TO NONINFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, OR FITNESS FOR ANY PARTICULAR PURPOSE. IN NO EVENT WILL AUTODESK OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN AUTODESK REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY THIRD PARTY.

Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or the exclusion of implied warranties or limitations on how long an implied warranty may last, so the above limitations may not apply to you.

5. DISCLAIMER.

COMPUTER-AIDED DESIGN SOFTWARE AND OTHER TECHNICAL SOFTWARE ARE TOOLS INTENDED TO BE USED BY TRAINED PROFESSIONALS ONLY. THEY ARE NOT SUBSTITUTES FOR YOUR PROFESSIONAL JUDGMENT. COMPUTER-AIDED DESIGN SOFTWARE AND OTHER TECHNICAL SOFTWARE ARE INTENDED TO ASSIST WITH PRODUCT DESIGN AND ARE NOT SUBSTITUTES FOR INDEPENDENT TESTING OF PRODUCT STRESS, SAFETY AND UTILITY. DUE TO THE LARGE VARIETY OF POTENTIAL APPLICATIONS FOR THE SOFTWARE, THE SOFTWARE HAS NOT BEEN TESTED IN ALL SITUATIONS UNDER WHICH IT MAY BE USED. AUTODESK SHALL NOT BE LIABLE IN ANY MANNER WHATSOEVER FOR THE RESULTS OBTAINED THROUGH THE USE OF THE SOFTWARE. PERSONS USING THE SOFTWARE ARE RESPONSIBLE FOR THE SUPERVISION, MANAGEMENT AND CONTROL OF THE SOFTWARE. THIS RESPONSIBILITY INCLUDES, BUT IS NOT LIMITED TO, THE DETERMINATION OF APPROPRIATE USES FOR THE SOFTWARE AND THE SELECTION OF THE SOFTWARE AND OTHER PROGRAMS TO ACHIEVE INTENDED RESULTS. PERSONS USING THE SOFTWARE ARE ALSO RESPONSIBLE FOR ESTABLISHING THE ADEQUACY OF INDEPENDENT PROCEDURES FOR TESTING THE RELIABILITY AND ACCURACY OF ANY PROGRAM OUTPUT, INCLUDING ALL ITEMS DESIGNED BY USING THE SOFTWARE.

6. LIMITATION OF LIABILITY.

IN NO EVENT WILL AUTODESK BE LIABLE FOR ANY LOSS OR DAMAGES OF ANY KIND, INCLUDING LOSS OF DATA, LOST PROFITS, COST OF COVER OR OTHER SPECIAL, INCIDENTAL, CONSEQUENTIAL OR INDIRECT DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE OR DOCUMENTATION, HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY. THIS LIMITATION WILL APPLY EVEN IF AUTODESK HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS OR DAMAGE. YOU ACKNOWLEDGE THAT THE NO CHARGE LICENSE FEE REFLECTS THIS ALLOCATION OF RISK.

7. GOVERNING LAW AND GENERAL PROVISIONS.

This Agreement will be governed by the laws of the country in which you acquired the Software, excluding the application of its conflicts of law rules. This Agreement will not be governed by the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly excluded. If any part of this Agreement is found void and unenforceable, it will not affect the validity of the balance of the Agreement, which shall remain valid and enforceable according to its terms. You agree that the Software will not be shipped, transferred or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other applicable export control law, restriction or regulation. This Agreement shall automatically terminate upon failure by you to comply with its terms. This Agreement may only be modified in writing signed by an authorized officer of Autodesk.

8. NOTICE TO GOVERNMENT END USERS.

If this product is acquired under the terms of a GSA contract -- Use, reproduction or disclosure is subject to the restrictions set forth in the applicable ADP Schedule contract; DOD contract -- Use, duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of 252.227-7013; Civilian agency contract -- Use, reproduction or disclosure is subject to 52.227-19(a) through (d) and restrictions set forth in the accompanying end user agreement.

© Autodesk Inc. 2009. All Rights Reserved.


UserInterfaceEventsSink Methods

UserInterfaceEventsSink Methods
Summary

The methods of the UserInterfaceEventsSink class are listed here.

Methods
Methods
Name | Description
OnEnvironmentChange | The OnEnvironmentChange event notifies the client when the active environment switches from one environment to another.
OnResetCommandBars | The OnResetCommandBars event notifies the client when command bars have been reset.
OnResetEnvironments | The OnResetEnvironments event notifies the client when environments have been reset.
OnResetRibbonInterface | Event that is fired when the ribbon user interface is reset.
OnResetShortcuts | Event that is fired when command shortcuts/aliases are reset in the Customize dialog (using either the "Reset All Keys" or "Reset All" button).
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface > UserInterfaceEventsSink Methods


UserInterfaceManager Methods

UserInterfaceManager Methods
Summary

The methods of the UserInterfaceManager class are listed here.

Methods
Methods
Name | Description
AllReferencedControls | Method that returns all command controls in Inventor's ribbon interface that reference the input ControlDefinition. Controls from ribbons panels, Quick Access Toolbar and the File Browser (application menu) are returned.
DoEvents | Allows Inventor to process all Windows messages currently in the message queue.
GetCommandPaths | Method that returns all the paths that the given command is found in, optionally filtered to an environment.
ResetRibbonInterface | Method that removes all customizations from the ribbon user interface.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Methods


UserInterfaceEventsObject Properties

UserInterfaceEventsObject Properties
Summary

The properties of the UserInterfaceEventsObject class are listed here.

Properties
Name | Description
Application | Property returning the parent of the object.
Parent | Property that returns the parent UserInterfaceManager object.
Type | Property returning kUserInterfaceEventsObject indicating this objects type.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsObject Interface > UserInterfaceEventsObject Properties


UserInterfaceManager Properties

UserInterfaceManager Properties
Summary

The properties of the UserInterfaceManager class are listed here.

Properties
Name | Description
ActiveEnvironment | Property that returns the Environment that is currently active.
Application | Property that returns the Application object.
BalloonTips | Property that returns the BalloonTips collection object.
CapacityMeterEnabled | Property that gets and sets whether to enable the capacity meter display in Inventor's status bar.
CommandBars | Property that returns the CommandBars collection object.
DockableWindows | Property that returns the DockableWindows collection object.
Environments | Property that returns the Environments collection object.
ExpertMode | Property that gets and sets whether the commands are shown in 'Expert' or 'Learning' mode. If True, commands are shown in expert mode (without text).
FileBrowserControls | Property that returns a CommandControls collection containing the controls in the File Browser (a.k.a Application Menu).
HelpControls | Property that returns a CommandControls collection containing the controls in the Help Menu.
InterfaceStyle | Property that returns the currently displayed interface style. Valid values are kRibbonInterface and kClassicInterface. In order to get and set the interface style application option (found on the Colors tab of Application Options), use the ColorSchemes.InterfaceStyle property.
LargeIcons | Property that gets and sets whether to display large icons for commands.
ParallelEnvironments | Property that returns the list of Environments valid for the edit target or the environment being switched to. Environments can be added to or removed from the list as seen appropriate by the client when an OnNewEditObject or an OnEnvironmentChange event is received. This list of environments will show in the Applications menu item. This list may only contain non-built-in environments.
Parent | Property that returns the parent object from whom this object can logically be reached.
RibbonAppearance | Property that gets and sets the appearance of the ribbon. Valid values are kNormal, kAllTextOff, kSmall and kCompact.
RibbonDockingState | Property that gets and sets the docking state of the ribbon. Valid values are kFloating, kDockToTop, kDockToLeft and kDockToRight.
Ribbons | Property that returns the Ribbons collection object.
RibbonState | Property that gets and sets the display state of the ribbon. Valid values are kFullRibbon, kMinimizeToTabs and kMinimizeToPanelTitles.
ShowBrowser | Property that gets and sets whether the browser is displayed or not.
ShowCleanScreen | Property that gets and sets whether the viewed screen area is maximized.
ShowDocumentTabs | Property that gets and sets whether document tabs are displayed.
ShowMarkingMenu | Property that gets and sets whether the marking menu is displayed.
ShowNavigationBar | Property that gets and sets whether the navigation bar is displayed.
ShowPanelBar | Property that gets and sets whether the panel bar is displayed or not.
ShowPanelTitles | Property that gets and sets whether ribbon panel titles are displayed.
ShowQuickAccessControlsBelowRibbon | Property that gets and sets whether the Quick Access Toolbar (QAT) is shown below or above the ribbon.
ShowStatusBar | Property that gets and sets whether the status bar is displayed or not.
ShowSteeringWheel | Property that gets and sets whether the steering wheel control is displayed.
ShowToolBar | Property that gets and sets whether the standard toolbar is displayed or not.
ShowViewCube | Property that gets and sets whether the view cube is displayed.
Type | Property returning an enum ObjectTypeEnum indicating this object's type.
UserInteractionDisabled | Property that enables/disables user interaction.
UserInterfaceEvents | Property returning the UserInterfaceEvents object.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties


Registry-Free Add-In - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Registry-Free Add-In

Introduction

Inventor 2012 now supports the ability to create an add-in that does not need to be registered. Inventor add-ins use Microsoft’s COM technology to allow Inventor to find and load them. Traditionally this uses the Windows registry. Microsoft added support for registry-free COM components some time ago and Inventor is now taking advantage of that.

A registry-free add-in is much simpler to install since there isn’t a registration process. It’s simply a matter of copying your add-in files to the correct location.

Note:Registry based add-ins are still supported and will work without any changes, but everyone is encouraged to convert their existing add-ins to be registry-free.

The steps below describe the process to create a registry-free add-in from scratch using the add-in wizard that comes with Inventor 2012. The steps to convert an existing add-in to be registry-free are also described.

Creating a Registry-Free Add-In

Creating the Add-In

Creating a new registry-free add-in is very simple because the new wizards delivered with Inventor 2012 do all of the work for you. The wizards have also been updated to support the 2010 versions of the Visual Studio languages.

To install the wizards, do the following:

  1. Install the Programmer Tools in the SDK by running DeveloperTools.msi. The installer is available in the following locations, depending on your operating system:
    Windows NT | C:\Program Files\Autodesk\Inventor 2012\SDK\
    Windows 7 | C:\Users\Public\Documents\Autodesk\Inventor 2012\SDK\
  2. After installing the developer tools, run InventorWizards.msi to install the wizards. The installer is located within the subdirectory under the SDK directory listed above.

    SDK\DeveloperTools\Tools\Wizards

You use the wizards the same way you used them before, but the resulting add-in that they create is now registry-free. The picture below shows how to select the Autodesk Inventor AddIn template within Visual Basic Express 2010 to create a new add-in.

Registry-Free Differences

There are a few differences between the old registry based add-ins and the new registry-free add-ins. One thing you might have noticed in the add-in code is that the large section of code that the wizard used to create to handle the registration of the add-in is no longer present. The only code created by the wizard are the stubs for the four methods (Activate, Deactivate, Automation, and ExecuteCommand) that are required by the ApplicationAddInServer interface.

The information that used to be in the registry is still required for Windows to find the add-in as a COM component and for Inventor to handle it correctly as an add-in. For the Windows portion of the information there is a file that’s embedded into your add-in. This is an xml file that is referred to as a manifest. The add-in created by the wizard has a manifest and the project is set up to automatically embed it into your add-in. You don’t need to do anything and the only reason to even be aware of it is in case something isn’t working correctly that you’ll need to correct.

To see if the manifest is being correctly embedded within your add-in, build your add-in. If it builds successfully then you can assume everything is ok. If it fails, one of the common causes is described below in the “Manifest Embedding Failure” section.

Besides the information in the registry that allowed the COM machinery to function, there was also information that Inventor used. This information is now provided through a .addin file. This file has the naming convention of Autodesk.AddInName.Inventor.addin where the AddInName section is the actual name of your add-in. The wizard creates a .addin file for your add-in but you’ll need to make at least one edit to the file and will likely want to make several changes. The contents of a default .addin file are shown below.

<Addin Type="Standard">
<!--Created for Autodesk Inventor Version 16.0-->
<ClassId>{6c915cb4-c5ac-4658-bc31-f9025740656f}</ClassId>
<ClientId>{6c915cb4-c5ac-4658-bc31-f9025740656f}</ClientId>
<DisplayName>InventorAddIn1</DisplayName>
<Description>InventorAddIn1</Description>
<Assembly>InventorAddIn1.dll</Assembly>
<LoadOnStartUp>1</LoadOnStartUp>
<UserUnloadable>1</UserUnloadable>
<Hidden>0</Hidden>
<SupportedSoftwareVersionGreaterThan>15..</SupportedSoftwareVersionGreaterThan>
<DataVersion>1</DataVersion>
<UserInterfaceVersion>1</UserInterfaceVersion>
</Addin>

The common things to change are the DisplayName and Description which are both used in the Add-In Manager. The field you’ll need to edit is the value for the Assembly element. This needs to be the full path to your add-in dll. In the example above it is InventorAddIn1.dll but it needs to be changed to C:\MyAddIns\AddIn1\InventorAddIn1.dll, or whatever the actual path and name of your add-in is.

The final step in getting your add-in to run is to place the files in the correct location. Your add-in dll can exist in any location since the .addin file specifies the location of the add-in. The .addin file must be copied to a specific directory. You have different options depending on the loading behavior you want.

  • Version Independent

    • Copying your .addin file to the locations listed below will allow your add-in to be loaded for all versions of Inventor. Inventor will read the “SupportedVersionVersionXXX” portion of your .addin file to determine which versions of Inventor should load the addin.

    Windows XP | C:\Documents and Settings\All Users\Application Data\Autodesk\Inventor Addins\
Windows 7/Vista | C:\ProgramData\Autodesk\Inventor Addins\

  • Version Dependent

    • Copying your .addin file to the locations listed below will cause your add-in to be loaded only for that version of Inventor. The value of the “SupportedSoftwareVersionXXX” setting in the .addin file is ignored, if present.

    Windows XP | C:\Documents and Settings\All Users\Application Data\Autodesk\Inventor 2012\Addins\
Windows 7/Vista | C:\ProgramData\Autodesk\Inventor 2012\Addins\

  • Per User

    • Copying the .addin file to the locations list below will cause the add-in to only be loaded for that particular user. If a user uses the Add-In Manager to make a change to how an add-in loads and the .addin file exists in one of the directories described above, the .addin file is copied to this per-user directory and updated with the changes specified in the Add-In Manager. This will override the settings in the orginal .addin file.

    Windows XP | C:\Documents and Settings\\Application Data\Autodesk\Inventor 2012\Addins\
Windows 7/Vista | C:\Users\\AppData\Roaming\Autodesk\Inventor 2012\Addins\

    As long as the manifest is embedded in your add-in’s dll, your .addin file is in one of the directories specified above, and the .addin file correctly points to the location of your addin dll it should load.

  • Delayed Loading

    • Delaying the loading of your add-in until it’s actually needed is ideal because then it’s not taking up memory and processing time. A noticeable portion of Inventor’s startup time is because of add-ins loading. There are ways of architecting your add-in to get delay loading behavior, but Inventor 2012 introduces a corse level of control over when your add-in is loaded. It’s good to take advantage of this to provide the best performance possible for the user of your add-in. This capability is only supported for registry-free add-ins.

    There is a new element that can be added to your .addin file that allows you to specify which document type your add-in is associated with and Inventor will only load your add-in when a document of that type is opened. Here’s an example of the line that you can add to your .addin file.

    <LoadBehavior>4</LoadBehavior>

    The values for this element are listed below. Some document types are loaded as the result of being referenced by other documents. For example, opening an assembly or drawing will also load the referenced parts and subassemblies, causing those related add-ins to load.

    LoadBehavior | Effect
0 | Load on Start-up (not recommended)
1 | Load when first Part is open/created
2 | Load when first Assembly is open/created
3 | Load when first Presentation is open/created
4 | Load when first Drawing is open/created
10 | Load OnDemand

Manifest Embedding Failure in VB and C#

The picture below illustrates an error you might encounter. It depends on what you have installed on your computer.

The embedding of the manifest into your add-in’s dll happens as a separate step after your add-in has been build. This is done using a post-build process which calls the mt.exe utility that performs the actual embedding. In the example above, it’s using the environment variable VS100COMNTOOLS, which doesn’t exist on that system. If you open a cmd window and type “SET”, it will display a list of all of your environment variables, as shown below.

Notice that VS80COMNTOOLS and VS90COMNTOOLS are defined but not VS100COMNTOOLS. You can change the post-build process to use one of these instead. You can see how to edit the post-build process in step 3 of the processes described below. For Visual Basic Express versions, you can’t directly define the post-build process. Instead you need to directly edit the .vpproj file using Notepad to make the change. Look for the line towards the bottom that contains “VS100COMNTOOLS” and change it to “VS90COMNTOOLS”.

Converting an Existing Add-In to be Registry-Free

The following describes the process of converting a standard add-in into a registry-free add-in. Since the process is different for the different programming languages, the process is described for Visual Basic, C#, and VC++.

Converting Visual Basic Add-Ins

  1. Uncheck the “Register for COM interop” check box on the “Compile” tab of the Application Properties dialog, as shown below.

  2. Create a new file in the same directory as your project file and name it “MyOEMApp.X.manifest”, where MyOEMApp will be replaced with the name of your add-in. Add the following to the manifest file. This file cannot be Unicode. The portions highlighted in yellow need to be edited to match your add-in.

    The “name” attribute of the clrClass element consists of three parts, separated by periods. The first is the name of the root namespace, which is highlighted below.

    The second part is the namespace that the COM class is defined within. For this example, it is MyOEMApp and is highlighted below. The Last piece is the name of the class that implements the ApplicationAddInServer interface, which is “StandardAddInServer” in this example and is also highlighted below.

  3. The next step is to add a post-build process to incorporate this manifest into your dll. The post-build process calls mt.exe which is a Microsoft utility that will embed the manifest into your add-in’s dll. You define a post-build step through the Compile tab of the Application Properties dialog. On the Compile tab, click the “Build Events…” button and then on the “Build Events” dialog click the “Edit Post-build…” button. Finally enter the string below into the “Post-build Event Command Line” dialog, as shown below; OEMTestAddin is the name of your add-in.
    mt.exe -manifest $(ProjectDir)\OEMTestAddin.X.manifest -outputresource:"$(TargetPath)";#2
  4. Remove any code associated with registering the add-in in the registry. This typically just means removing the Register and Unregister methods from your add-in class. The AddInGuid property is in the same region as the registration functions, so if you intend on using this property in other areas of your add-in you’ll want to be careful not to delete it.

    5. Click here to skip to step 5 under the section Converting C++ Add-Ins below, which is the same for all languages.

Converting Visual Basic Add-Ins

  1. Uncheck the “Register for COM interop” check box on the “Build” tab of the Application Properties dialog, as shown below.
  2. Create a new file in the same directory as your project file and name it “CSharpOEMAddIn.X.manifest”, where CSharpOEMAddIn is the name of your add-in. This file cannot be Unicode. Add the following to the manifest file. The portions highlighted in yellow need to be edited to match your add-in.

    The “name” attribute of the assemblyIdentity element is the name of the assembly, which is highlighted below.

    The “name” attribute of the clrClass element consists of two parts, separated by periods. The first is the name of the namespace that the COM class is defined within. For this example, it is CSharpOEMAddIn, and the second part is the name of the class that implements the ApplicationAddInServer interface, which is “StandardAddInServer”. Both of these are highlighted below.

  3. The next step is to add a post-build process to incorporate this manifest into your dll. The post-build process calls mt.exe which is a Microsoft utility that will embed the manifest into your add-in’s dll. You define a post-build step through the Build Events tab of the Application Properties dialog. On the Build Events tab, click the “Edit Post-build…” button. Enter the string below into the “Post-build Event Command Line” dialog, as shown below. Replace InvAddin with the name of your add-in.

    mt.exe -manifest $(ProjectDir)\InvAddin.X.manifest -outputresource:"$(TargetPath)";#2

  4. 4. Remove any code associated with registering the add-in in the registry. This typically just means removing the Register and Unregister methods from your add-in class. The AddInGuid function is in the same region as the registration functions, so if you intend on using this property in other areas of your add-in you’ll want to be careful not to delete it.

    5. Click here to skip to step 5 under the section Converting C++ Add-Ins below, which is the same for all languages.

Converting C++ Add-Ins

  1. Uncheck the “Register for COM interop” check box on the “Build” tab of the Application Properties dialog, as shown below.

  2. Create a new file in the same directory as your project file and name it “CPPOEMAddIn.X.manifest”, where CPPOEMAddIn is the name of your add-in. This file cannot be Unicode. Add the following to the manifest file. The portions highlighted in yellow need to be edited to match your add-in.

    The name of the assemblyIdentity element is the name of the project, which is highlighted below.

    The clsid is the class ID for your add-in and can be found in the .idl file associated with your add-in, which is shown below. Remember that the braces are required in the manifest file.

    The “name” attribute of the clrClass element consists of two parts, separated by periods. The first part is the name of your project. For this example it is CppOEMAddIn. The second part is the name of the class that implements the ApplicationAddInServer interface, which is “CppOEMAddInAddInServer” for this example, as shown below.

  3. The next step is to configure some project settings so the manifest is correctly embedded within the dll. The first two settings are part of the Linker settings. The settings and the values to change them to are highlighted in the picture below. Some of these settings may already have the correctly value.

    The next setting is of the Manifest Tool settings. Make sure the “Embed Manifest setting is set to “Yes”, as shown below.

    Finally you want to remove the post-build step that registers the add-in in the registry. This is found in the Build Events section of the settings. Clear out any text in the Command Line field, as shown below.

  4. Remove any code from the project that supports the registration of the add-in in the registry. This will typically be to remove the .rgs file associated with the project and delete the DllRegisterServer and DllUnregisterServer functions.
  5. Compile your project. This will cause the manifest to be embedded within your dll. If you get any errors when compiling, verify that the command line that you entered matches the one above.

    You can verify that the manifest has been correctly embedded by dragging the add-in dll into Visual Studio. You should see the “RT_MANIFEST” folder, as shown below. Double clicking on the “2” icon will open a window to show you actual manifest data.

  6. A requirement for all registry-free add-ins is to have an .addin file. With a registry based add-in, Inventor relied completely on the registry to get information about the add-in. The .addin file takes the place of the registry for this same information. The addin filename is in the form of Autodesk.AddInName.Inventor.addin Below is the .addin file for an example primary add-in with the portions to change highlighted.

    For most add-ins, the ClassId and ClientId elements will be the same value, which is the GUID at the top of the StandardAddInServer class.

    The value of the DisplayName element can be anything and is the name of the add-ins as shown in the Add-In Manager.

    The Description element can also be anything and is the description of the add-in as shown in the Add-In Manager.
    The Assembly element defines the name of the add-in dll. It also defines the path to the dll, relative to the OEM bin directory, but the subdirectory must always have the same name as the add-in dll.

    The Hidden element defines whether the add-in is visible in the Add-In Manager or not. A value of 1 indicates that it is hidden, although the end-user can still right-click within the Add-In Manager and choose “Show hidden members” to display all add-ins.

    There are some other elements that you might see defined for other add-ins that either don’t apply or are ignored for an OEM primary add-in.
  7. Create a directory in the OEM\bin directory that’s the same name as your add-in dll, (minus the .dll portion of the name. For example, the full path to the new directory might be “C:\Program Files\Autodesk\Inventor OEM 2012\Bin\MyOEMApp”.
    Copy the add-in dll to the new directory.
  8. Copy the .addin file to one directories described in the section above about creating a registry-free add-in.


Creating Add-Ins with VB.Net - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Creating Add-Ins with VB.Net

Creating an Inventor Add-In using VB.Net

Here are a set of steps that will result in a working VB.NET Add-In. These steps also work for C# (with the necessary syntax changes, of course). They should work for any .NET language that supports COM Interop. Also, look in the following location of the Inventor installation for wizards that automate the process of Add-In creation:

(Windows XP) C:\Program Files\Autodesk\Inventor 2010\SDK\DeveloperTools\Tools\Wizards
(Windows Vista) C:\Users\Public\Documents\Autodesk\Inventor 2010\SDK\DeveloperTools\Tools\Wizards

  1. Create a new project using the "Class Library" template in the .NET language of choice, (VB.NET is used for this example). You can use any name for the project.
  2. For this example, change the name of the class to "VB_AddIn", as shown below.

Public Class VB_AddIn

End Class

  3. Add a reference to the Inventor type library. There are two techniques you can use (the first one is recommended).
    1. Have Visual Studio create the Interop Assembly for you. Under the "Project" menu item, select "Add Reference...". Click the "COM" tab, find and highlight the "Autodesk Inventor Object Library" item, and click "OK".
    2. Use tlbimp.exe to create the assembly (e.g. "tlbimp c:\...\bin\RxInventor.tlb /out:Interop.Inventor.dll"). Go through the steps shown above but browse for Interop.Inventor.dll instead of selecting the type library from the list. If you use this approach you may want to add something like "Imports Inventor = Interop.Inventor" so you can use the code below as is.
  4. Add the following attributes to your Add-In's class. The ProgID and the GUID should be unique for every Add-In, so you should create your own values for these. In VB6, the ProgID was generated automatically for you based on the name of the project and the class. Using .Net you need to define your own ProgID. In VB6 the GUID was also automatically generated. Visual Studio .Net has a GUID generator you can use (look for "Create GUID" in the Tools menu) to create new GUIDs.

    The Imports statements are not strictly necessary, but they make the coding easier.

Imports System.Runtime.InteropServices
Imports System.Reflection
Imports Microsoft.Win32

<ProgIdAttribute("Sample.AddInServer"), GuidAttribute("16967A40-D142-4c59-B2BC-0805EA83BB15")> _
Public Class VB_AddIn

End Class

  5. Implement Inventor.AddInServer by adding the line in bold below. Once you've entered the line and press return at the end of the line Visual Studio will add empty implementations of the necessary methods. At this point, your code should look something like the following.

Imports System.Runtime.InteropServices
Imports System.Reflection
Imports Microsoft.Win32

<ProgIdAttribute("Sample.AddInServer"), GuidAttribute("16967A40-D142-4c59-B2BC-0805EA83BB15")> _
Public Class VB_AddIn
  Implements Inventor.ApplicationAddInServer

  Public Sub Activate(ByVal AddInSiteObject As Inventor.ApplicationAddInSite, _
    ByVal FirstTime As Boolean) Implements Inventor.ApplicationAddInServer.Activate
  End Sub

  Public ReadOnly Property Automation() As Object Implements 	Inventor.ApplicationAddInServer.Automation
    Get
      'ADD THIS LINE OF CODE:
      Return Nothing
    End Get
  End Property

  Public Sub Deactivate() Implements Inventor.ApplicationAddInServer.Deactivate
  End Sub

  Public Sub ExecuteCommand(ByVal CommandID As Integer) Implements _
                            Inventor.ApplicationAddInServer.ExecuteCommand
  End Sub
End Class

  6. Now we need to make sure the Add-In can be registered.
Note: The Add-in registration technique described in this overview is still supported and will continue to be supported as a legacy mechanism for several product releases. However, starting with Autodesk Inventor 2011, a simpler manifest-based registration mechanism is also supported, and developers are encouraged to adopt this new method. Please refer to the Add-in Registration overview for details.

First, set the "Register for COM interop" project setting. This is on the "Compile" page of the project's properties. You can get to the properties selecting the "Properties" under the "Project" menu item in Visual Studio. This will ensure that the unregister and register functions get called when you build the project. The next step is implementing those functions. You can name the functions anything you want, as long as they have the necessary attributes attached to them. Below you will find one possible implementation for these methods. Some of the "Settings" entries that are less commonly used are commented out. These methods must be part of your AddIn class.

' This function is called when the assembly is registered (use regasm, not regsvr32).
' The GUID that appears in this code is the same for all Add-Ins
<ComRegisterFunctionAttribute()> _
Public Shared Sub Register(ByVal t As Type)
    Dim clssRoot As RegistryKey = Registry.ClassesRoot
    Dim clsid As RegistryKey = Nothing
    Dim subKey As RegistryKey = Nothing

    Try
        clsid = clssRoot.CreateSubKey("CLSID\" + AddInGuid(t))
        clsid.SetValue(Nothing, "VB_AddIn")
        subKey = clsid.CreateSubKey("Implemented Categories\{E357129A-DB40-11D2-B783-0060B0F159EF}")
        subKey.Close()

        subKey = clsid.CreateSubKey("Required Categories\{E357129A-DB40-11D2-B783-0060B0F159EF}")
        subKey.Close()

        subKey = clsid.CreateSubKey("Settings")
        subKey.SetValue("AddInType", "Standard")
        subKey.SetValue("LoadOnStartUp", "1")

        'subKey.SetValue("SupportedSoftwareVersionLessThan", "")
        subKey.SetValue("SupportedSoftwareVersionGreaterThan", "11..")
        'subKey.SetValue("SupportedSoftwareVersionEqualTo", "")
        'subKey.SetValue("SupportedSoftwareVersionNotEqualTo", "")
        'subKey.SetValue("Hidden", "0")
        'subKey.SetValue("UserUnloadable", "1")
        subKey.SetValue("Version", "0")
        subKey.Close()

        subKey = clsid.CreateSubKey("Description")
        subKey.SetValue(Nothing, "VB_AddIn Description")
    Catch ex As Exception
        System.Diagnostics.Trace.Assert(False)
    Finally
        If Not subKey Is Nothing Then subKey.Close()
        If Not clsid Is Nothing Then clsid.Close()
        If Not clssRoot Is Nothing Then clssRoot.Close()
    End Try
End Sub

' This function is called when the assembly is unregistered (use regasm/unregister).
' The GUID that appears in this code is the same for all Add-Ins
<ComUnregisterFunctionAttribute()> _
Public Shared Sub Unregister(ByVal t As Type)
    Dim clssRoot As RegistryKey = Registry.ClassesRoot
    Dim clsid As RegistryKey = Nothing

    Try
        clssRoot = Microsoft.Win32.Registry.ClassesRoot
        clsid = clssRoot.CreateSubKey("CLSID\" + AddInGuid(t))
        clsid.SetValue(Nothing, "")
        clsid.DeleteSubKeyTree("Implemented Categories\{E357129A-DB40-11D2-B783-0060B0F159EF}")
        clsid.DeleteSubKeyTree("Required Categories")
        clsid.DeleteSubKeyTree("Settings")
        clsid.DeleteSubKeyTree("Description")
    Finally
        If Not clsid Is Nothing Then clsid.Close()
        If Not clssRoot Is Nothing Then clssRoot.Close()
    End Try
End Sub

' This property uses reflection to get the value for the GuidAttribute you attached to your class.
' For some languages (e.g. C#) you will have to implement this as a function.
Public Shared ReadOnly Property AddInGuid(ByVal t As Type) As String
    Get
        Dim guid As String = ""
        Try
            Dim atts() As Object = t.GetCustomAttributes(GetType(GuidAttribute), False)
            Dim ga As GuidAttribute = atts(0)
            guid = "{" + ga.Value.ToString() + "}"
        Finally
            AddInGuid = guid
        End Try
    End Get
End Property

  7. You should now have a working Add-In! Building the project will take care of any registration on your machine. You can also use regasm to register and unregister the resulting assembly, which will be useful when you install the Add-In on other machines. Hint: use the "Visual Studio.NET 2005 Command Prompt" if you want a command prompt that has all of the right PATH settings to run tools like regasm and tlbimp.
  8. There is one other thing you will probably want to do in order for your Add-In to work properly. Your A dd-In will likely use .NET wrappers to COM objects. The COM objects won't be released until all of those wrappers are garbage collected. In most cases you will need to force a garbage collection when your Add-In is deactivated to ensure that this happens. Here's what the Deactivate function might look like.

Public Sub Deactivate() Implements Inventor.ApplicationAddInServer.Deactivate
  ' Be sure to set all references to Inventor objects
  ' to Nothing so that they are available for collecting.
  GC.Collect()
  GC.WaitForPendingFinalizers()
End Sub

    Now you have a working add-in. Not much of an Add-In at this point since it doesn't do anything other than load and unload. At this point, using the Inventor API in VB.Net is basically the same as VB 6. One thing that is different is how VB.Net works with pictures. This is an issue because you'll likely want to use pictures to assign to any buttons you create. The next few steps go through the process of creating a new toolbar and adding a button.
  9. First, you'll need to reference three additional components. One is a COM component and the other two are .Net components. You'll need to use the "Add Reference..." command again. With the ".NET" tab selected, find and highlight the "Microsoft.VisualBasic.Compatibility" item and then find and highlight the "System.Drawing" item and click "OK". Repeat the process to add a reference to the "OLE Automation" item on the "COM" tab.

    Below is the code to create a toolbar that contains a single button. This demonstrates the UI customization workflow that was introduced in Inventor 9. The only .Net specific code is the work required to get the bitmap. Using .Net you'll get an Image object which needs to be converted to an iPictureDisp object to be used by Inventor. The declaration of the oButtonDef variable is done within the class.

Private oApp As Inventor.Application
Private WithEvents oBtnDef As Inventor.ButtonDefinition

Public Sub Activate(ByVal AddInSiteObject As Inventor.ApplicationAddInSite, _
  ByVal FirstTime As Boolean) Implements Inventor.ApplicationAddInServer.Activate
    ' Save a reference to the Inventor Application object.
    oApp = AddInSiteObject.Application

    ' Load the icon from an external file.  This could be done in many different
    ' ways, i.e. from a control or a resource file.  When read in using .Net you'll
    ' have an Image object.  In VB 6 it is a Picture object.  Inventor will expect a
    ' Picture object (actually and IPictureDisp object) so we'll need to convert the
    ' image to use it in Inventor.
    Dim oImage As System.Drawing.Image
    oImage = System.Drawing.Bitmap.FromFile("C:\Temp\Button.bmp")

    ' Convert the Image to a Picture.
    Dim oPicture As stdole.IPictureDisp
    oPicture = Microsoft.VisualBasic.Compatibility.VB6.Support.ImageToIPictureDisp(oImage)

    ' Create the button definition object.
    oBtnDef = oApp.CommandManager.ControlDefinitions.AddButtonDefinition("Test", _
       "TestButton", Inventor.CommandTypesEnum.kQueryOnlyCmdType, _
       "{76BE5CB6-6778-4e5f-B3F7-5C58DD99EE94}", "A test command.", "Test command", oPicture)

    ' Check if this is the first time the Add-In's been loaded.
    If FirstTime Then
       ' Create a new toolbar.
       Dim oCommandBar As Inventor.CommandBar
       oCommandBar = oApp.UserInterfaceManager.CommandBars.Add("Test", "AddInSampleCommandBar", _
         Inventor.CommandBarTypeEnum.kRegularCommandBar, "{76BE5CB6-6778-4e5f-B3F7-5C58DD99EE94}")

         ' Add the button to the toolbar.
         oCommandBar.Controls.AddButton(oBtnDef)

         ' Make the toolbar visible.
        oCommandBar.Visible = True
    End If
End Sub

  10. In order to respond to the button click you'll need to respond to the Execute event.

Private Sub oBtnDef_OnExecute(ByVal Context As Inventor.NameValueMap) Handles oBtnDef.OnExecute
    MsgBox("You clicked the button.")
End Sub

At this point, you gave a bare-bones working VB.Net Add-in, complete with clickable toolbar button.

Also consider

Compare to the overview "Creating an Add-In using VB6"

Next page | Back to the Overviews
Disclaimer


Addins - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Addins

Add-In Creation

Let's look in more detail at how to create an Add-In and the features it provides. Any language that supports the creation of ActiveX components can create an Add-In. This eliminates the use of VBA. This section discusses creating an Add-In using Visual Basic although the basic concepts of creating an Add-In are the same regardless of the programming language used. However, creating an ActiveX component and responding to events will be different in each language. Reading Microsoft's Visual Basic documentation about ActiveX components will also help you to gain a better understanding of how this works.

For this example we'll create a simple Add-In that has two commands: one that draws geometry into the active sketch and another that demonstrates some of the user interface functionality. A finished version of this Add-In is delivered as one of the SDK samples in the SDK\Samples\VB\SimpleAddIn directory.

The first step in making an Add-In is to create a new ActiveX EXE or ActiveX DLL project. Most Add-Ins will be ActiveX DLL components because they run within Autodesk Inventor's process space and thus will be significantly faster. In Visual Basic it's a single switch to change a project between an ActiveX DLL or EXE component, so it's easy to experiment and change your mind later. To create an ActiveX component, select either "ActiveX EXE" or "ActiveX DLL" from the New Project dialog in Visual Basic.

Create the EXE or DLL

The new ActiveX component initially contains one Class module. Within this module we'll add the definition of the object that Autodesk Inventor will access when it starts the Add-In. Before adding any code let's take care of a maintenance task. All ActiveX components are identified in the registry by a ProgID. For example, Autodesk Inventor has the ProgID "Inventor.Application". Your Add-In will also have a ProgID. In Visual Basic, the ProgID of an ActiveX component is inferred from the name of the project and the name of the class, i.e. "ProjectName.ClassName". The picture below on the left shows the project window immediately after creating the project. The picture on the right shows the window after using the Properties window to rename the project and the class. (The project has also been saved, so the filenames are now shown in parentheses.) With the project and class names shown below, the ProgID for this sample will be "AddInSample.Sample."

Add-In project before saving AddIn project after saving

There's one more maintenance step to perform before we can begin coding. That is to reference the Autodesk Inventor type library into the project using the Visual Basic "References…" command, as shown below.

Add-In References dialog

Now we can move on to adding the code to the Add-In. The first step is to use the VB Implements keyword to define the Inventor interface you want to implement. Add the following code to the class module. It's through this interface that Inventor communicates with the Add-In.

Implements ApplicationAddInServer

In the VB code window, click on the Object list, (the pull-down in the upper left of the code window), and select "ApplicationAddInServer." This will immediately add support for the Activate method within your program, as shown below.

Add support for Activate

Using the Procedure list in the VB code window, (the pull-down in the upper right of the code window), select each of the methods supported by the ApplicationAddInServer interface. This will add support for all four methods. After this you should see the following code in the class module.

Add the rest of the methods

By doing this you've added support for the four functions that Autodesk Inventor expects all Add-Ins to support. Here's a short description of each of these functions. (We'll look at them in more detail later as we add additional code.) Autodesk Inventor calls the Activate method when it starts the Add-In. The Automation property is provided to allow your Add-In to expose an API of its own to other programs. Most Add-Ins won't have APIs of their own and won't implement this property. Autodesk Inventor calls the Deactivate method when the Add-In needs to shut down. This occurs when Autodesk Inventor is exited or if the user unloads the Add-In through the Add-In Manager. The ExecuteCommand method is obsolete in Autodesk Inventor 6 and later.

Let's add the implementation for the Activate method. This method has two arguments: AddInSiteObject and FirstTime. The AddInSiteObject argument is used to pass your Add-In an ApplicationAddInSite object. This object provides access to the Autodesk Inventor Application object and supports several other methods that allow the Add-In to define its user interface. Now that your Add-In has the Autodesk Inventor Application object it has access to the complete Autodesk Inventor API. For our implementation of the Activate method we'll save a reference to the Application object. This is skeletal code for demonstration purposes. The code is shown below and a discussion of the code follows.

Private Sub ApplicationAddInServer_Activate( _
             ByVal AddInSiteObject As Inventor.ApplicationAddInSite, _
             ByVal FirstTime As Boolean)
    ' Save a reference to the Application object.
    Set oApp = AddInSiteObject.Application

    'Now you have the Application object, here you could set up UI button definitions.

    End Sub

The FirstTime flag, if True, indicates to the Addin that this is the first time it is being loaded and to take some specific action. It does not take these actions when this flag is False. Typically, when the flag is True, the AddIn proceeds to create all of the objects under the UserInterfaceManager that it needs - Environments, CommandBars and Controls. These objects are persistent, but if this is the first time the Addin is loaded, they need to be created from scratch. When the FirstTime flag is False, meaning the Addin has already been loaded, it only needs to create the objects under the CommandManager - CommandCategories and ControlDefinitions. This topic is covered in more detail in the UI Customization overvew.

Private variables can be declared within the class module for saving references to the Application object and any UI handler objects (buttons etc.) that will be created. In the Activate method, the variable for the Application object is set to the Application object using the AddInSite variable passed into the Activate method by Inventor.

The code is skeletal, avoiding specifics of defining the user interface for this Addin. We won't go into a detailed description here since the API for user interface customization is discussed in more detail in another section.

This sample does not support an API of its own so there's no need to support the Automation property. However, you do need to add something into the property definition or Visual Basic will remove it during compile time optimization. Autodesk Inventor expects the property to be there so you need to support it. A comment within the property is sufficient, but the code below will cause the function to return Nothing, indicating no API is supported.

Private Property Get ApplicationAddInServer_Automation() As _
                                          Inventor.AddInAutomation
    Set ApplicationAddInServer_Automation = Nothing
End Property

Autodesk Inventor calls the Deactivate method whenever the Add-In needs to shut down. Any cleanup the Add-In needs to perform can be done within this method. This sample releases all references to Autodesk Inventor objects in the Deactivate method.

Private Sub ApplicationAddInServer_Deactivate()
    ' Release all references.
    ' If we had set up handlers for buttons, we would set them to Nothing
    Set oApp = Nothing
End Sub

The ExecuteCommand method is no longer used. As with the Automation property, Inventor still expects it to be there so it must be implemented. In this case a comment is added so Inventor will not remove it as part of its optimization.

Private Sub ApplicationAddInServer_ExecuteCommand( _
                                          ByVal CommandID As Long)
    ' Not used.
End Sub

The code for the Add-In is now complete and should compile. If you have any compile time errors, double-check your code against the code shown above to make sure it matches.

Next page | Add-In Registration
1, 2, 3, 4, 5

Disclaimer


Addins - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Addins

Add-In Registration

Note: The Add-in registration technique described in this overview is still supported and will continue to be supported as a legacy mechanism for several product releases. However, starting with Autodesk Inventor 2011, a simpler manifest-based registration mechanism is also supported, and developers are encouraged to adopt this new method. Please refer to the Add-in Registration overview for details.

Even though your Add-In DLL is complete you're not quite finished with your Add-In. When you compile the Add-In, Visual Basic automatically adds information into the registry to register it as an ActiveX component. However, in order to make it available as an Inventor Add-In you need to add some additional information to the registry. Unfortunately, Visual Basic does not allow you to add additional registration information to an ActiveX component. Because of this limitation, the registration will need to be performed outside of Visual Basic. For this sample we'll create a .reg file that contains the additional registration information.

The first step in creating this registration file is to find out the class ID that was assigned to your Add-In when you compiled it. To find out the class ID you need to run Registry Editor to view the contents of the registry. To do this use the Run command from the Windows Start menu and enter "regedit", as shown below.

Click OK and the Registry Editor will be displayed. Expand the HKEY_CLASSES_ROOT key as shown below.

Search within the list under HKEY_CLASSES_ROOT for the ProgID of your Add-In. Remember, the ProgID is defined by the names of the project and class. Look for "AddInSample.Sample". Expand this key and click the Clsid key. The Clsid value is shown on the right-hand side of the Registry Editor. In this case the Clsid is "{76165809-A31F-4A5D-8793-23F12FE9DC03}". The Clsid for your Add-In will be different.

Find clsid in registry

If you double-click on the name of the value in the Registry Editor, (Default), it will display a dialog that will allow you to edit the value, as shown below. Don't edit the value, but use ctrl-c to copy the value onto the clipboard. Once copied, cancel the dialog.

Edit the registry string

Using Notepad, create a new file. Copy the following into Notepad. (The ¬ symbol is used to denote a line that was broken in order to display it here. These lines should be combined within your .reg file. The highlighted values are those that need to be replaced with the value of your Clsid.)
REGEDIT4

[HKEY_CLASSES_ROOT\CLSID\{76165809-A31F-4A5D-8793-23F12FE9DC03}]
@="Sample Add-In"

[HKEY_CLASSES_ROOT\CLSID\¬
{76165809-A31F-4A5D-8793-23F12FE9DC03}\Description]
@="This is the sample Add-In from the documentation."

[HKEY_CLASSES_ROOT\CLSID\{76165809-A31F-4A5D-8793-23F12FE9DC03}\¬
Implemented Categories\{39AD2B5C-7A29-11D6-8E0A-0010B541CAA8}]

[HKEY_CLASSES_ROOT\CLSID\{76165809-A31F-4A5D-8793-23F12FE9DC03}\¬
Required Categories]
[HKEY_CLASSES_ROOT\CLSID\{76165809-A31F-4A5D-8793-23F12FE9DC03}\¬
Required Categories\{E357129B-DB40-11D2-B783-0060B0F159EF}]

[HKEY_CLASSES_ROOT\CLSID\{76165809-A31F-4A5D-8793-23F12FE9DC03}\¬
Settings]
"LoadOnStartUp"="1"
"Type"="Standard"
"SupportedSoftwareVersionEqualTo"="14.."

Let's take a minute to look at the information in the .reg file to better understand what's going on. To start with, you should know this is adding additional information to a registry key that Visual Basic created when it registered your ActiveX component. This .reg file adds the additional information that identifies the ActiveX component as an Inventor Add-In.

The first section of the .reg file changes the name associated with the component. Inventor will use this as the name of the Add-In. This will be displayed in the Add-In Manager and on the Tools menu where the Add-In's commands will be available on a fly-out.

The second section adds a Description key that Inventor will use for the description displayed within the Add-In manager.

The third section specifies that this ActiveX component implements the Inventor Add-In category.

The fourth section creates the key that specifies that this ActiveX component requires the Inventor Add-In category.

The final section defines some settings for the Add-In. "LoadOnStartUp" defines whether or not the Add-In should automatically be loaded when Inventor is started. A value of 1 indicates it should be automatically loaded. A value of 0 indicates it should not be automatically loaded. The "Type" value is used to define this as a standard Add-In. A special translator type of Add-In is also supported by Inventor.

The last value shown in the "Settings" section is a new feature in Inventor 6 that allows you to specify which version(s) of Inventor the Add-In is valid for. This is described in detail in the Add-In versioning section below. Save your .reg file and run it by double-clicking on the .reg file in Explorer. You should now have a fully functioning Add-In.

Important: Every time you run your project from within the Visual Basic editor or recompile your project, Visual Basic re-registers your ActiveX component. It does this by removing the top level registry key and then re-adding the ActiveX component information. As a result, the Inventor Add-In registration gets removed. This means you need to run the .reg file after every compile of your project.

If you look in the Add-In Manager, you'll see your Add-In listed there. The user can control whether the Add-In is loaded and whether it loads automatically at startup through the Add-In Manager.

Add-In Manager dialog

Note: The Add-in registration technique described in this overview is still supported and will continue to be supported as a legacy mechanism for several product releases. However, starting with Autodesk Inventor 2011, a simpler manifest-based registration mechanism is also supported, and developers are encouraged to adopt this new method. Please refer to the Add-in Registration overview for details.

Next page | Add-In Versioning
1, 2, 3, 4, 5

Disclaimer


Addins - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Addins

Add-In Versioning

Most Add-In's need to confine their use to specific versions of Inventor. For example, an Add-In that takes advantage of any of the new API features in Inventor 6 will not work in Inventor 5.3. Add-In versioning allows the Add-In writer to specify which versions of Inventor the Add-In will be loaded in.

The versioning information is specified in the registry as a value within the Settings key. The names of these String values can be one or more of the following:

SupportedSoftwareVersionLessThan
SupportedSoftwareVersionGreaterThan
SupportedSoftwareVersionEqualTo
SupportedSoftwareVersionNotEqualTo

The string associated with this value defines the version number. You can specify version numbers using two different forms:

[Major].[Minor].[ServicePack]
or
[BuildIdentifier]

The following are all valid version numbers:

"5.3.2" - Specifies 5.3 SP2
"6.." - Specifies any version of Inventor 6
"..2" - Specifies any service pack 2. (This isn't very useful but just demonstrates that any of the Major, Minor, or ServicePack numbers are optional.
"6077000" - Specifies build 6077.

The SupportedSoftwareVersionEqualTo and SupportedSoftwareVersionNotEqualTo values can support multiple version numbers by separating them by a semicolon. For example, SupportedSoftwareVersionEqualTo = "5.3.0;5.3.2" will only support 5.3 and 5.3 SP2).

Add-In versioning is supported in Inventor 6 and all subsequent releases. Of course it can't be supported in previous releases, but there still is a need to prohibit new add-ins from loading in older versions of Inventor. To support this, a new category has been created for Inventor Add-Ins. The old category is still supported but results in the Add-In being available in all versions of Inventor, past and present. If you use the new category, Inventor 5.3 and previous versions will not load the Add-In because they won't recognize it as a valid Inventor Add-In. The Inventor category the Add-In registers for is defined in the registry. In the previous .reg sample the Add-In category is specified by the ID {39AD2B5C-7A29-11D6-8E0A-0010B541CAA8}. The previous ID for add-ins was {E357129A-DB40-11D2-B783-0060B0F159EF}. Older Add-Ins can easily support versioning by changing the Inventor Add-In category ID in their registration and addin the desired value to the Setting key.

Note: The Add-in registration technique described in this overview is still supported and will continue to be supported as a legacy mechanism for several product releases. However, starting with Autodesk Inventor 2011, a simpler manifest-based registration mechanism is also supported, and developers are encouraged to adopt this new method. Please refer to the Add-in Registration overview for details.

Next page | Debugging an Add-In
1, 2, 3, 4, 5

Disclaimer


Addins - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Addins

Debugging an Add-In

Debugging an Add-In is not quite as simple as debugging other types of programs that use the Autodesk Inventor API. This is primarily because an Add-In is an ActiveX component. The fact that Visual Basic re-registers ActiveX components whenever you compile them also complicates it slightly. The following steps can be used to debug a Visual Basic Add-In.
  1. Place break points within the Add-In where you want the processing to stop.
  2. Start the Add-In by using the "Run" command in Visual Basic. This may cause the dialog below to be displayed. Choose the "Wait for components to be created" option and click OK.

Next page | Back to the Overviews
1, 2, 3, 4, 5

Disclaimer


Apprentice Server - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Apprentice Server

Using Apprentice Server

Apprentice Server was briefly described in the introduction of this document. This section will go into more detail about what Apprentice Server is and how to use it.

The simple way to think of Apprentice is that it's a smaller version of Autodesk Inventor that does not have a user interface. Without a user interface the only way to access its functionality is by using its API. Apprentice is actually an ActiveX component. It runs within the process space of the client that's using it. For example, if you write a Visual Basic program that displays information about the contents of an assembly, Apprentice will be running within your VB program's process space. Apprentice can be very efficient for certain applications because it's smaller than the complete Autodesk Inventor application and because it runs in the same process as your application.

The API exposed by Apprentice is a subset of the complete Autodesk Inventor API. Apprentice provides access to file references, assembly structure, B-Rep, geometry, attributes, render styles, and document properties. Access to the assembly structure, B-Rep, geometry, and render styles is read-only. Access to file references, attributes, and document properties is read and write. In past releases of the product, a type library specifically for Apprentice was delivered with both Autodesk Inventor and Apprentice. This type library contained the limited set of objects supported only by Apprentice. Now, however, since the Autodesk Inventor type library contains all of the Apprentice functionality, this should be used in an Apprentice context. A version of the old Apprentice type library is still supplied for legacy reasons, but this will likely be discontinued in future releases.

Some common types of applications that will make use of Apprentice are larger standalone applications that want to be able to use Autodesk Inventor files. For example, an existing NC application could use Apprentice to directly read in an Autodesk Inventor part or assembly. If it were to use Autodesk Inventor for this it would need to start Autodesk Inventor first, use Autodesk Inventor's API to open the desired document, and then use Autodesk Inventor's API to query for necessary information. There's a lot of unnecessary overhead in having to start Autodesk Inventor and a significant performance penalty caused by all of the API calls going between two processes. These problems are solved with Apprentice since it is very lightweight and runs in the process space of the application.

Another feature of Apprentice is the cost. Apprentice is freely available and is distributed as part of Design Tracking, which is available for download from the Autodesk website. Much of Design Tracking actually uses Apprentice.

A simpler example of the use of Apprentice is a small application that updates the cost property of an Autodesk Inventor part document based on the current cost that is stored in a business database. In this case Apprentice is being used to write the document properties of a part. The utility can quickly go through a set of Autodesk Inventor part documents and set the cost property with a value it obtained from a database.

Most of the features that Apprentice supports are identical to those in Autodesk Inventor. For example, to traverse an assembly you would perform the traversal the same way in Apprentice as you would in Autodesk Inventor. The basic traversal function can be written to be used for both cases. Because most of the API supported by Apprentice is the same as Autodesk Inventor's, this section on Apprentice will focus on the differences between the two.

The primary differences between Autodesk Inventor and Apprentice are in the Application and Document objects. The objects that represent the Application and Document are completely different in Autodesk Inventor and Apprentice. The Apprentice Application object is called ApprenticeServerComponent. It supports a much more limited API than the Inventor Application object. In Apprentice there isn't a Documents collection.

When ApprenticeServer.Open opens a document, a reference to that document is held by the ApprenticeServer component in order to be returned from the ApprenticeServer.Document. This ‘active top/last opened’ document is also considered the document used as the root of the save for the FileSaveAs object. A document is closed when either ApprenticeServerDocument.Close is called, or the document’s reference count fully drops to zero. Keep in mind that the reference held by the ApprenticeServer (if it was the last document to be opened) also counts as a reference. This ApprenticeServer reference will be released either when a different document is opened, or ApprenticeServer.Close is called, or when the ApprenticeServer’s reference count fully drops to zero and it is destroyed.

The ApprenticeServerComponent supports a few methods and properties that are unique to Apprentice. These are the Open and Close methods, which are used to open and close documents within Apprentice; DisplayAffinity, which is used to optimize the behavior of Apprentice for viewer applications; MinimizeFileSize, which compresses files by removing versions, and FileSaveAs, which we'll discuss in more detail later in this section.

The document objects used within Apprentice are different from the document objects used in Autodesk Inventor. In Inventor there are the PartDocument, AssemblyDocument, DrawingDocument, and PresentationDocument objects. In Apprentice, the ApprenticeServerDocument object represents the part, assembly, and presentation documents and the ApprenticeServerDrawingDocument represents the drawing document. The code below illustrates using Apprentice to open a document.

Private Sub TestApprentice()
    ' Create a new instance of Apprentice.
    Dim oApprentice As New ApprenticeServerComponent

    ' Open a document.
    Dim oDoc As ApprenticeServerDocument
    Set oDoc = oApprentice.Open("C:\Temp\Assembly1.iam")
End Sub

The "New" keyword is used in the declaration of the variable for the ApprenticeServerComponent. This creates a new instance of an object of ApprenticeServerComponent type. Apprentice isn't actually loaded at this point, but is loaded the first time the variable is used--in this case, when the Open method of Apprentice is called.

Even though there are differences between the application and document objects of Autodesk Inventor and Apprentice, once you get past these top-level objects, the objects below them in the hierarchy are the same. For example, a function that extracts information from the B-Rep or from an assembly can be used with Autodesk Inventor or Apprentice without any changes. The function below will display an assembly tree given a ComponentOccurrences object regardless of whether it is used in Apprentice or Autodesk Inventor.

Private Sub GetComponents(InCollection As ComponentOccurrences, _
Level As Long)
    ' Iterate through the components in the current collection.
    Dim oCompOccurrence As ComponentOccurrence
    For Each oCompOccurrence In InCollection
        ' Display information about the current component.
        Debug.Print Space(Level * 3) & oCompOccurrence.Name

        ' Recursively call this function for the suboccurrences
        ' of the current component.
        Call GetComponents(oCompOccurrence.SubOccurrences, Level + 1)
    Next
End Sub

Here's a modified version of the earlier sample that connects to Apprentice and opens a document. It's been updated to check for the document type and then call the GetComponents function above.

Private Sub TestApprentice()
    ' Create a new instance of Apprentice.
    Dim oApprentice As New ApprenticeServerComponent

    ' Open a document.
    Dim oDoc As ApprenticeServerDocument
    Set oDoc = oApprentice.Open("C:\Temp\Assembly1.iam")

    ' Display this document's name.
    Debug.Print oDoc.DisplayName

    ' Check to make sure the document is an assembly.
    If oDoc.DocumentType = kAssemblyDocument Then
        ' Show the occurrence tree.
        Call GetComponents(oDoc.ComponentDefinition.Occurrences, 1)
    End If
End Sub

Because Apprentice provides read-only access to some of the information in an Autodesk Inventor document, some of the properties on objects may fail when you attempt to set them. For example, the Name property of the ComponentOccurrence object behaves as read-only in Apprentice, whereas in Autodesk Inventor it is read-write. The B-Rep portion of the API behaves identically in Autodesk Inventor and Apprentice since it provides query-only access in both cases.

There are a few things that can only be done using Apprentice. These are all things that cause problems when the file is open in Inventor but can be easily accomplished when accessed through Apprentice. One of the most important of these is the ability to change file references. This is a critical part of Apprentice that Design Assistant uses. For example, let's say you have an assembly that contains Part1 and Part2. Part1 needs to be revised so you make a copy of the file, give it a new name, make the changes to the part, and save it. When you open the assembly it's still referencing the old file. The file reference portion of the API allows you to change the reference within the assembly so that it's pointing to the file that represents the revised version of Part1.

The FileSaveAs object, which is only available in Apprentice, provides functionality that lets you save components of an assembly to different filenames and update the assembly's references to point to the new files.

Using the FileSaveAs object you can save the document you currently have open. If you make any changes to the document you must use the FileSaveAs object to save those changes, otherwise it's equivalent to exiting the file without saving. The sample below opens an assembly, looks for a reference to a specific file, changes the reference to point to another file, and then saves the change.

Private Sub ChangeReferenceSample()
    Dim oApprentice As New ApprenticeServerComponent

    ' Open a document.
    Dim oDoc As ApprenticeServerDocument
    Set oDoc = oApprentice.Open("C:\Temp\Assembly1.iam")

    ' Iterate through the references looking for a
    ' reference to a specific file.
    Dim oRefFileDesc As ReferencedFileDescriptor
    For Each oRefFileDesc In oDoc.ReferencedFileDescriptors
        If oRefFileDesc.FullFileName = "C:\Temp\OldPart.ipt" Then
            ' Replace the reference.
            Call oRefFileDesc.PutLogicalFileNameUsingFull( _
                                             "C:\Temp\NewPart.ipt")
            Exit For
        End If
    Next

    ' Set a reference to the FileSaveAs object.
    Dim oFileSaveAs As FileSaveAs
    Set oFileSaveAs = oApprentice.FileSaveAs

    ' Save the assembly.
    Call oFileSaveAs.AddFileToSave(oDoc, oDoc.FullFileName)
    Call oFileSaveAs.ExecuteSave
End Sub

If you're using Apprentice to access the document properties, and that's the only edit you've made to the document, you don't need to use the FileSaveAs object to save the file, but can use the FlushToFile method of the PropertySets object to save the property changes. This is much more efficient because it only writes the properties to the document and doesn't write the entire document.

Please note: Saving of files in Apprentice is not allowed on files that require migration (any file that has not already been migrated to the same version of the Apprentice server). The current document's NeedsMigrating property must return False before the FileSaveAs object can successfully be returned.

Next page | Back to the Overviews

Disclaimer


Assembling Parts - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Assembling Parts

Introduction to parts in an assembly

Modeling in Autodesk Inventor is more than creating part features from sketch profiles. Typically, a library of part files is created and these parts are assembled together to create a composite model - an assembly. Assemblies themselves can be treated as discrete components, as subassemblies within a larger assembly. Autodesk Inventor has an extensive user interface for working with parts in the assembly environment, including positioning tools and assembly constraints for defining relationships between parts.

The purpose of assembling parts

This method of gathering parts into an assembly has several advantages. It enables model components to be worked on independently, and it often means the model is considerably smaller in file size, especially when common parts are re-used. The concept it similar to blocks in AutoCAD.

Assembly-level component occurrences and definitions - Object Model Diagram

Working with assembled parts through the API

The Autodesk Inventor API employs the concepts of component definitions and occurrences. These are somewhat analogous to AutoCAD block definitions and inserts. A component definition is also the base class for other component definition types - PartComponentDefinition, AssemblyComponentDefinition, SheetMetalComponentDefinition, WeldmentComponentDefinition, and WeldsComponentDefinition. These are used only when accessing functionality specific to these types.

Think of a component occurrence as an instance of a component definition. The component definition can be a subassembly or a part. The ComponentDefinition object is the base class for the AssemblyComponentDefinition object.

To insert parts into an assembly, add an occurrence to the ComponentOccurrences collection of the assembly document's AssemblyComponentDefinition object. The ComponentOccurrences collection supports several methods to add an occurrence - by file (the Add method) or by inserting another instance of an existing definition (the AddByComponentDefinition method). It also supports iParts and adding through iMates.

Adding occurrences is the first step

Assembling parts also requires a means to specify their positions, and to define how the parts fit together. The add methods described previously support matrices, allowing ComponentOccurrences to be positioned within the assembly document. However, it is typically more convenient to define assembly constraints to indicate how parts should position themselves relative to each other. Creating an assembly of parts through the API is therefore a two-stage process, since it is through the UI. First, assemble the parts, and then fit them together. The following sample code demonstrates both processes.

This code assumes a part file named cylinder.ipt exists in a C:\Temp directory. Use Autodesk Inventor to create and save this part file (a sketched circle extruded to form a cylinder) before running this code. The code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

First, create a new assembly document:

Dim oApp As Inventor.Application
Set oApp = ThisApplication

Dim oAssyDoc As AssemblyDocument
Set oAssyDoc = oApp.Documents.Add(kAssemblyDocumentObject, _
   oApp.GetTemplateFile(kAssemblyDocumentObject))

Inserting component occurrences requires a matrix, even if it does nothing, so create the matrix object.

Dim oPositionMatrix As Matrix
Set oPositionMatrix = oApp.TransientGeometry.CreateMatrix

Now create the component occurrence by calling the Add method of the ComponentOccurrences collection, referencing the part file previously created manually in Autodesk Inventor.

Dim sFileName As String
sFileName = "c:\temp\cylinder.ipt"

Dim oCylinder1 As ComponentOccurrence
Set oCylinder1 = oAssyDoc.ComponentDefinition.Occurrences.Add(sFileName, oPositionMatrix)

This created the first occurrence of the cylinder part in the assembly. Now add another, but this time, move it to one side. Otherwise it occupies the same space as the first one and is not visible. Use the matrix object to adjust its insertion position slightly. Here, the matrix also reverses the direction of the cyclinder.

Dim oTrans As Vector
Set oTrans = oApp.TransientGeometry.CreateVector(2, 0, -1)
oPositionMatrix.SetTranslation oTrans

Now add the second occurrence of the cylinder component.

Note: The reference to the part file is no longer needed when inserting the second cylinder, since there is already an instance of the part in the assembly. Simply reference the same ComponentDefinition, in this case that of the previously inserted ComponentOccurrence.

Dim oCylinder2 As ComponentOccurrence
Set oCylinder2 = oAssyDoc.ComponentDefinition.Occurrences.AddByComponentDefinition _
   (oCylinder1.Definition, oPositionMatrix)

In Autodesk Inventor, the preceding code results in two cylinders in the assembly, looking something like the following figure.

The intention is to get these cylinders to line up and butt together, and for Autodesk Inventor to ensure they stay that way despite future recomputes of the assembly model. Use assembly constraints to achieve this, in much the same way geometric constraints can define the shape of a sketch. Apply mate constraints to remove two degrees of freedom, aligning the cylinders to each other, and then mating the ends of the cylinders together. The AssemblyComponentDefinition maintains a collection of constraints to apply to the component occurrences, so add the mate constraints to this collection. First, obtain the assembly component definition.

Dim oAxisDef As AssemblyComponentDefinition
Set oAxisDef = oApp.ActiveDocument.ComponentDefinition

The first constraint will be applied between the curved faces of the two cylinders, to align them. One way to obtain these faces is by iterating through all the faces that make up the surface body of each component occurrence, checking for a cylindrical surface. For more information on faces and surface bodies, refer to the Boundary Representation (BRep) sections of the Autodesk Inventor API documentation.

Dim oCylAxis1 As Face
Dim oCylAxis2 As Face
Dim oFace As Face

For Each oFace In oCylinder1.SurfaceBodies(1).Faces
    If oFace.SurfaceType = kCylinderSurface Then
       Set oCylAxis1 = oFace
    End If
Next

For Each oFace In oCylinder2.SurfaceBodies(1).Faces
    If oFace.SurfaceType = kCylinderSurface Then
       Set oCylAxis2 = oFace
    End If
Next

So now oCylAxis1 and oCylAxis2 contain the curved cylinder faces, and can be passed to the AddMateConstraint method of the assembly component definition's AssemblyConstraints collection.

Dim oConstr As AssemblyConstraint
Set oConstr = oAxisDef.Constraints.AddMateConstraint(oCylAxis1, oCylAxis2, 0, kInferredLine, kInferredLine)

The result of this constraint is shown in the following figure. The two cylinders now occupy the same space, and are indistinguishable from each other. Another constraint is required on the end faces to have the two cylinders butt against each other to form one long cylinder.

Again, iterate through the faces of the surface bodies, this time looking for planar faces. In this case, it is safe to select the face on the same end of each cylinder as the position of the second cylinder was reversed by its insertion matrix (the two cylinder component occurrences were inserted in opposite directions).

Dim oCylFace1 As Face
Dim oCylFace2 As Face

For Each oFace In oCylinder1.SurfaceBodies(1).Faces
    If oFace.SurfaceType = kPlaneSurface Then
        Set oCylFace1 = oFace
    End If
Next

For Each oFace In oCylinder2.SurfaceBodies(1).Faces
    If oFace.SurfaceType = kPlaneSurface Then
       Set oCylFace2 = oFace
    End If
Next

Now add a mate constraint for these two faces to the AssemblyConstraints collection.

Set oConstr = oAxisDef.Constraints.AddMateConstraint _
   (oCylFace1, oCylFace2, 0, kNoInference, kNoInference)

This results in the following figure with the intended relationship between the two cylinders.

The preceding example demonstrates insertion of parts into the assembly environment, and subsequent manipulation of those parts. The resulting assembly can be saved to file, and itself used as a component occurrence in a new assembly with other parts and subassemblies.

Summary

To insert a part into an assembly, a ComponentOccurrence object is added to the ComponentOccurrences collection of the assembly document's AssemblyComponentDefinition object. The position of the occurrence can be manipulated during insertion. Final positioning is typically achieved through assembly constraints, which define how parts and subassemblies relate to each other. Multiple instances of the same ComponentOccurrence should reference the same ComponentDefinition.

Also consider -

Autodesk Inventor supports the concept of patterns, which is a uniform (circular or rectangular) or nonuniform (feature-based) repetition of parts. The API supports such patterns too, though the RectangularOccurrencePattern, CircularOccurrencePattern and FeatureBasedOccurrencePattern objects. These contain collections of OccurrencePatternElement objects that provide access to the list of ComponentOccurrences comprising that pattern.

Parts in the assembly environment are actually considered proxies. This only really matters when working with a part in the assembly context rather than the part definition context. For more information, refer to the Proxies overview.

Next page | Back to the Overviews
Disclaimer


Attributes - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Attributes

Introduction to Attributes and AttributeSets.

The Autodesk Inventor API provides the means to append data, in the form of named data or a name-value pair, to objects in Autodesk Inventor. Attributes are how the programmer stores nongraphical data on Autodesk Inventor objects, and for this data to be maintained by Autodesk Inventor. Attribute data is also accessible using Apprentice Server. Attribute data is persistent by default. However, if the Transient property is set to true, the data is to be maintained during the current Autodesk Inventor session only.

You can append the following types of data: integer, double, string, byte array, or any combination of these. Applications differentiate their attributes from those of other applications through the use of AttributeSets. An AttributeSet can contain any number of Attributes, and an object can contain any number of AttributeSets, dependant only on system resources. Most persistent objects (SketchLine, Constraint, Parameter, and so on) in Autodesk Inventor support Attributes. Brep objects support attributes in the current session, with attributes maintained across parametric changes and model re-computations.

There is no direct User Interface equivalent to Attributes. Similar API functionality exists in AutoCAD through Extended Entity Data, otherwise known as XED or xdata.

The purpose of Attributes

Attributes are commonly used to attach application-specific data to objects within Autodesk Inventor. A typical example is in referencing records in an external database, such as Microsoft Access or Oracle. An attribute appended to a part occurrence may contain a key value. An application can use this value to identify a unique database record (perhaps using ODBC or OLEDB). Thus Autodesk Inventor maintains an attribute value that is a persistent link to further data in an external database. This database can be used for Bill of Materials reports, data updates, and so on.

It is useful to be able to locate Autodesk Inventor objects containing attributes of a certain value. Use the AttributeManager object to accomplished this. The following object model diagrams show that this object is separate from the Attribute and AttributeSets objects. The AttributeManager object is obtained from the document object (DrawingDocument, PartDocument, AssemblyDocument, ApprenticeServerDocument and so on.)

AttributeSet and Attribute Object Model Diagram

Attributes Object Model Diagram

AttributeManager Object Model Diagram

AttributeManager Object Model Diagram

Accessing Attributes through the API

To take full advantage of attributes, it is necessary to add, modify and erase Attributes and AttributeSets programmatically. The AttributeSets object also supports the DataIO object, allowing attribute data to be written out in XML form.

Note: Since Autodesk Inventor 9, Attributes and AttributeSets also support the Transient property. If this property is set to true, or if the AttributeSet is created using the AddTransient method of AttributeSets, the attribute data is not persisted beyond the current session. This is useful if you want to do some short-term data manipulation but do not wish to 'dirty' the document. For example, when working with Brep objects at the session level.

Next page | Creating AttributeSets
1, 2, 3, 4

Disclaimer


Attributes - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Attributes

Creating an AttributesSet

The first step in appending data to an Autodesk Inventor object is to create and add a new AttributeSet object to the AttributeSets collection. This is obtained through the AttributeSets property of the object to which the attributes are to be attached. Initially, this AttributeSet can be empty of Attributes. So, assuming an assembly document contains a single part occurrence oMyPartOccurrence:

Dim oAttribSets As AttributeSets
Set oAttribSets = oMyPartOccurrence.AttributeSets

Dim oAttribSet As AttributeSet

On Error Resume Next
Set oAttribSet = oAttribSets.Add("MyAttribSet")
If Err Then
  Set oAttribSet = oAttribSets.Item("MyAttribSet")
End If

The preceding sample code obtains the AttributeSets collection object from the part occurrence, and then adds a new AttributeSet object named "MyAttribSet" to the collection, if one doesn't already exist.

Creating Attributes and adding or modifying values

Next, declare and add an Attribute to the AttributeSet object using the add method of the AttributeSet object.

Dim oAttrib As Inventor.Attribute
If oAttribSet.Count = 0 Then
  Set oAttrib = oAttribSet.Add("MyAttrib", kStringType, "Some Text")
End If

This code adds a single attribute of type String, containing the text "Some Text", after first checking that the AttributeSet doesn't already contain attributes. An alternative is to check if existing attributes have the same name, and if not, add the new attribute anyway since there is no naming conflict. To modify the value of an existing attribute, update its Value property.

Retrieving attributes values

When obtaining the value of an existing attribute, you usually know its name. The Item method of both AttributeSets allow the use of a name string to identify the required object. Alternatively, the Item method accepts a numeric index value, allowing iteration of all available AttributeSets. In this example, we use the previously named attributes.

Dim oAttribSets As AttributeSets
Set oAttribSets = oMyPart.AttributeSets

Dim oAttrib As Inventor.Attribute
Set oAttrib = oAttribSets.Item("MyAttribSet").Item("MyAttrib")
Debug.Print oAttrib.Value

For clarity and brevity, the previous example doesn't perform any error checking. You could use the NameIsUsed property (see the next section) to check whether the attribute exists. Given the existence of the attribute 'MyAttrib' this code prints out its value, "Some Text".

Deleting Attributes

Deleting attributes is straightforward, except that it is always wise to check for the existence of attributes contained in an AttributeSet before deleting that AttributeSet. If the AttributeSet contains attributes, delete those attributes before deleting the AttributeSet. It is the programmer's responsibility to ensure it's safe to delete attributes and AttributeSets. There is no Recycle Bin for attributes, although you can undo the last operation. If orphaned attributes exist due to the owning object being deleted or inaccessible, such attributes should be purged using the PurgeAttributeSets method of the AttributeManager.

The following code uses the delete method of the Attribute object, followed by the delete method of the parent AttributeSet object.

Dim oAttribSets As AttributeSets
Set oAttribSets = oMyPart.AttributeSets

If oAttribSets.NameIsUsed("MyAttribSet") Then
  Set oAttrib = oAttribSets.Item("MyAttribSet").Item("MyAttrib")
  oAttrib.Delete
  oAttribSets.Item("MyAttribSet").Delete
End If

Again, the previous code uses minimal error checking, though it does demonstrate the use of the NameIsUsed property to verify the existence of the AttributeSet.

Next page | Searching using AttributeManager
1, 2, 3, 4

Disclaimer


Attributes - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Attributes

Searching for Attributes using the AttributeManager object

An assembly may contain hundreds or thousands of objects, be they occurrences, dimensions, constraints, or any other persistent object. If all these objects contain attributes as described in the preceding sections, it would be a very slow and tedious process to search each object for a given AttributeSet or Attribute. Brep objects are another example, with a potentially large number of objects to iteration through. Thankfully, Autodesk Inventor provides an API to help - the AttributeManager object. You can obtain this object from the Document object, and from derived documents such as AssemblyDocument. The AttributeManager object provides a number of methods. For example, to find if an AttributeSet, Attribute or Attribute value exists, or to return objects based on specific attribute values.

Note: A helpful feature of the AttributeManager object is that wildcard characters are legal when used to specify AttributeSet or Attribute names. So, it is possible to perform searches for objects using partial name or value strings.

AttributeManager methods such as OpenAttributeSets return an AttributeSetsEnumerator object. This is a list of AttributeSets. The OpenAttributeSets method requires a list of objects for which you need AttributeSets. The AttributeSetsEnumerator returned has its AttributeSets ordered in the same way as your list of objects, therefore you can easily match which AttributeSet relates to which object by their numerical index. This technique can help to improve performance with large numbers of attributes.

The following code assumes a PartDocument object containing a single part, which in turn has faces to which attributes are attached. This example uses OpenAttributeSets to find AttributeSet "Test" on these face objects, and prints out the value of the first attribute in the AttributeSet. This would be much quicker than opening each face.

Dim oDoc As PartDocument
Set oDoc = ThisApplication.ActiveDocument

Dim oFaceColl As ObjectCollection
Set oFaceColl = ThisApplication.TransientObjects.CreateObjectCollection
For Each oFace In oDoc.ComponentDefinition.SurfaceBodies.Item(1).Faces
  oFaceColl.Add oFace
Next

Dim oSet As AttributeSet
Dim oSetEnum As AttributeSetsEnumerator

Set oSetEnum= oDoc.AttributeManager.OpenAttributeSets(oFaceColl,"Test")
For Each oSet In oSetEnum
  If oSet.Count > 0 Then
    Debug.Print oSet.Item(1).Value
  End If
Next

Other methods supported by the AttributeManager object include FindObjects. As its name suggests, this method returns a collection of objects corresponding to specified AttributeSet or Attribute names, or attribute values.

Next page | Performance
1, 2, 3, 4

Disclaimer


Attributes - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Attributes

Performance

Conceptually, attributes are appended to persistent objects in Autodesk Inventor. In reality, the link is rather more tenuous. Autodesk Inventor is a parametric modeler; a uniform system for parts and assemblies. Objects in Inventor easily change, whether driven by parameters or as a result of a modeling operation such as the addition of a hole. So a persistent object such as a face is not necessarily as persistent or consistently identifiable as it first appears.

Autodesk Inventor has a complex search algorithm to enable it to consistently identify objects throughout their lifetime. This mechanism is employed by ReferenceKeys, a concept similar to handles in AutoCAD. This internal ReferenceKeys mechanism provides a reliable and robust link between an AttributeSet and the object to which it is appended. However, the link is potentially expensive in terms of processing time, particularly when you are working with large numbers of Attributes. There are several ways to mitigate the effects of this performance issue.

  • Autodesk Inventor builds a cache of object-to-AttributeSet links as these links are referenced. This cache greatly reduces access time for subsequent references. You can force Autodesk Inventor to build the entire cache, for all objects, by calling the FindObjects method with no arguments. Then perform your query. Note though that continued modeling operations will destroy the cache.
  • When working with large numbers of Attributes, enclose your Attribute editing in a Transaction or ChangeProcessor. This tells Autodesk Inventor not to use its own automatic transaction and undo mechanism, greatly improving performance.

Also consider

Attributes are often used in conjunction with ReferenceKeys. Use Referencekeys to obtain a persistent identifier for a given Autodesk Inventor object. This identifier is valid from session to session. For example, an application can establish a relationship between objects in an assembly by storing a ReferenceKey for one object in a persistent attribute on another.

Next page | Back to the overviews
1, 2, 3, 4

Disclaimer


Balloons - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Balloons

Introduction to balloons

Autodesk Inventor users can add balloon notation to a drawing view or selection of parts automatically. These enumerated balloons are typically associated with a parts list, also generated automatically. Either the balloons or the list can have their values overridden, or new part numbers can be attached to custom parts. Balloons can be of various styles. The balloons and associated parts list can be updated to reflect the current content of the drawing view.

The purpose of balloons

Balloons and their associated parts list are a common means of calling out engineering requirements and specifications for manufacturing parts. Autodesk Inventor automates much of the process, including balloon placement. Balloon placement, type, and content can all be modified through the API.

Note: Balloon notation referencing properties (specified through styles) currently cannot be changed through the API.

Balloons Object Model Diagram

Balloons API structure

Balloons have content in the form of notation. This notation may be a part number, the date the part was created, the mass of the part, the author, and so on. It is typically a part number corresponding to items in a parts list.

The Balloon object references a BalloonValueSets collection comprised of BalloonValueSet objects. These BalloonValueSet objects also have a value and an override value, corresponding to the same functionality through the Autodesk Inventor user interface. The balloon type can be set through the SetBalloonType method of the balloon object. Balloons can reference an existing sketched symbol in place of the standard balloon shapes.

Using the balloon API

The following sample code makes changes to balloons on a drawing sheet, and so assumes an open drawing with balloons attached to parts. The code modifies the type and value of all the balloons. It omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

The first step is to obtain the active sheet in the drawing. The sample performs a count of the number of balloons and value sets, overriding the balloon values with these counts, so the balloon count is first initialized.

Dim oDrawDoc As DrawingDocument
Set oDrawDoc = ThisApplication.ActiveDocument

Dim oSheet As Sheet
Set oSheet = oDrawDoc.ActiveSheet

Dim BalloonCount As Long
BalloonCount = 1

The intention is to change values in all balloons on the sheet, not just in a view. The following code iterates through the balloons collection, obtaining each balloon object in turn. The balloon type is changed to hexagonal, and the balloon placement direction is changed to kBottomDirection.

Dim oBalloon As Balloon

For Each oBalloon In oSheet.Balloons
    oBalloon.SetBalloonType (kHexagonBalloonType)
    oBalloon.PlacementDirection = kBottomDirection

Typically, a balloon has a single ValueSet object associated with it, but it's safe to iterate through the BalloonValueSets collection object. The code overrides each balloons value set or sets with a string, comprised of the balloon count and value set count values.

    Dim ValueSetCount As Long
    ValueSetCount = 1

    For Each oBalloonValueSet In oBalloon.BalloonValueSets
        oBalloonValueSet.OverrideValue = "Balloon" & _
           BalloonCount & ": ValueSet" & ValueSetCount
        ValueSetCount = ValueSetCount + 1
    Next
    BalloonCount = BalloonCount + 1
Next

In the following figure, the balloon on the right demonstrates the changes the preceding code applied to the balloon on the left.

Summary

Balloons are typically, though not exclusively, used as notation to identify parts in a drawing, with part numbers corresponding to items in a part list. The balloon API provides the means to modify balloon content, type, and position.

Also consider

Other types of notation available in the drawing sheet environment include drawing dimensions, drawing sketches, drawing text, and custom tables.

Next page | Back to the Overviews
Disclaimer


Bill of Materials - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Bill of Materials

Introduction to the BOM

Autodesk Inventor keeps track of which parts comprise an assembly. This information can be tabulated into a bill of materials report, commonly used in the manufacturing and assembly processes. Minimally, a BOM lists components, quantity, and relevant totals. Additionally, a BOM likely includes part or stock numbers, cut length figures, and so on. Autodesk Inventor can add all this information to a drawing in the form of a table.

The purpose of the BOM API

The API allows the following actions on BOM data.

  • Data can be queried and exported.
  • Quantity totals can be modified - for example, overriding a value or setting a quantity to be a parameter value.
  • The BOM component type (the BOM structure) can be modified.

A typical use for the BOM API is to query and export data for a specific use, perhaps to be read by other software downstream.

The BOM Structure defines the status of the component in the BOM. BOM Structure has five basic options:

  • Normal
  • Phantom
  • Reference
  • Purchased
  • Inseparable

Phantom components exist in the design but are not separate line items in the BOM. Reference components are excluded from the BOM entirely, existing only to augment the content of a design. A Purchased component is considered a single BOM line item, even if it is a subassembly. An Inseparable component is similar to a Purchased component, in that it is considered a single item, except that it is typically fabricated.

BOM Object Model Diagram

Working with the BOM through the API

Autodesk Inventor maintains the BOM internally, updating types and quantities as changes are made to an assembly. These changes may be implemented through the user interface or through the modeling functions of the Autodesk Inventor API. The BOM API can make additional changes to the BOM data, and can query and export that data. Autodesk Inventor makes use of PropertySet objects to store some BOM data for a component. Client code can access this data directly.

Querying the BOM

The following sample code demonstrates use of the API to query an assembly for BOM data. The code assumes that the sample assembly, Arbor_Press.iam, is open in Autodesk Inventor. The code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

First, obtain the BOM object for this assembly's ComponentDefinition.

Dim oBOM As BOM
Set oBOM = ThisApplication.ActiveDocument.ComponentDefinition.BOM

From the BOM object, get the base BOMView object, named "Structured." A BOM may also contain views where the items have been reordered or renumbered.

Dim oBOMView As BOMView
Set oBOMView = oBOM.BOMViews.Item("Structured")

Iterate through the rows in the BOM view, obtaining each BOMRow object.

Dim i As Long
For i = 1 To oBOMView.BOMRows.Count

  Dim oRow As BOMRow
  Set oRow = oBOMView.BOMRows.Item(i)

For some of the BOM data, we'll need to query a property set of the component referenced by each row. The PropertySets collections are accessed through the parent document of the ComponentDefinition, so obtain the ComponentDefinition of the component.

  Dim oCompDef As ComponentDefinition
  Set oCompDef = oRow.ComponentDefinitions.Item(1)

The required property set is named "Design Tracking Properties." Obtain this from the owning document of the component.

  Dim oPropSet As PropertySet
  Set oPropSet = oCompDef.Document.PropertySets.Item("Design Tracking Properties")

Now we have all the information necessary to list the BOM content. Obtain variable information such as the item number and quantity from the BOMRow object, and the part number and description from the property set.

  Debug.Print "#: "; oRow.ItemNumber; _
              " Quantity:"; oRow.ItemQuantity; _
              "Part: "; oPropSet.Item("Part Number").Value; _
              " Desc: "; oPropSet.Item("Description").Value
Next

The preceding code iterates through all the BOMRows in the BOMView object, printing BOM data to the VBA debug window. The output should appear something like the following example.

#: 1 Quantity: 1 Part: Arbor Press Desc:
#: 2 Quantity: 1 Part: FACE PLATE Desc:
#: 3 Quantity: 1 Part: PINION SHAFT Desc:
#: 4 Quantity: 1 Part: LEVER ARM Desc:
#: 5 Quantity: 1 Part: THUMB SCREW Desc:
#: 6 Quantity: 1 Part: TABLE PLATE Desc:
#: 7 Quantity: 1 Part: RAM Desc:
#: 8 Quantity: 2 Part: HANDLE CAPipt Desc:
#: 9 Quantity: 1 Part: COLLAR Desc:
#: 10 Quantity: 1 Part: GIB PLATE Desc:
#: 11 Quantity: 1 Part: GROOVE PIN Desc:
#: 12 Quantity: 4 Part: ANSI B18.3 - 1/4 - 20 - 7/8 Desc: Hexagon Socket Head Cap Screw
#: 13 Quantity: 4 Part: ANSI B18.3 - 10-32 UNF x 0.58 Desc: Hexagon Socket Set Screw - Flat Point
#: 14 Quantity: 1 Part: ANSI B18.6.2 - 10-32 UNF - 0.1875 Desc: Slotted Headless Set Screw - Flat Point - UNF (Fine Thread - Inch)

Summary

Autodesk Inventor can keep track of components in an assembly for the purposed of producing a bill or materials. Components referenced by the BOM can be assigned specific types indicating whether - and how - they should be incorporated into the BOM. Views of the BOM can be renumbered and reordered. The API allows this data to be queried and exported, either in predefined file formats or by reading and manipulating the BOM data directly.

Also consider

The BOM objects described previously are global in nature. The API also supports the PartsList object in the drawing environment. This can be considered a local snapshot of the parts of the BOM relevant to that drawing's parts list.

Next page | Back to the Overviews
Disclaimer


BRep - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Boundary Representation

Introduction to Boundary Representation

Conceptually, Autodesk Inventor solids are comprised of features. Sketch profiles are extruded, lofted, revolved, and so on to create solids. Edges of solids have fillets and chamfers applied to them. None of these features are static. All of them are changeable by editing the feature, which may cause changes to other dependent features. Therefore, the surface of an Autodesk Inventor solid is very changeable, too. In other words, the surface information, defined as the boundary between the inside and the outside of the solid, is dynamic.

The purpose of Boundary Representation data

Developer applications frequently need access to this boundary representation data. For example, a cutting application needs to know the shape of a solid so it can prepare a path for a cutting tool. A way is needed to iterate through this boundary information, and that is the purpose of the Boundary Representation API (commonly known as the BRep API).

Boundary Representation (BRep) Object Model Diagram

BRep Object Model Diagram

Working with the BRep API

The BRep API has a number of hierarchical objects. The topmost is the SurfaceBodies collection of SurfaceBody objects. A SurfaceBody object represents a discrete part.

Faces enclose a volume. A Face represents any geometry; planes, cylinders, free-form surfaces, and so on. A simple example is a solid cylinder. The cylinder consists of three faces. Two planar faces that act as the ends of a cylinder and one cylindrical face that acts as the side of the cylinder.

A FaceShell object represents a connected set of faces. A FaceShell for a simple cylinder has the two planar end faces, and the non-planar side face. Typically a SurfaceBody contains a single FaceShell object, but it is possible to have more, as in the following illustration:

The SurfaceBody on the left has one FaceShell. Increasing the hole diameter results in the SurfaceBody on the right, comprised of two FaceShell objects.

EdgeLoop, Edge, and EdgeUse objects

EdgeLoop objects define a face boundary. Several EdgeLoop objects can exist for a given face. The following figure highlights the four EdgeLoop objects for the top face of this solid.

An Edge object is similar but defines only the connectivity between two adjacent faces, so typically represents only part of an EdgeLoop. An Edge object is shared between faces, unlike an EdgeUse object. A face has its own set of EdgeUse objects, which apply only to that face. They are defined in terms of the 2D parameter space of that face. Typically, there are two EdgeUse objects for each Edge Object. Edge objects are shared between faces but EdgeUse objects are not. They contain information specific to a face, including a conceptual flow direction for the face edges, useful in traversing faces.

In the BRep API, a vertex indicates a connection of at least two edges. Vertices are implied by the edges in the model.

BRep objects expose the Geometry property that returns the underlying geometry of the object.

Parameter space

When working with planar objects, it is common to define them in terms of their own plane. Typically, the object is divided into some conceptually convenient number of divisions to reference a given point on its surface. For example, a surface can be parameterized as follows:

Surfaces are parameterized in their 2D space. Edges (curves) are parameterized in a linear fashion. However, both can be evaluated to return coordinates in 3D space. This means that to obtain model-space X Y Z coordinates of a point on a surface, it is necessary to supply the 2D parameter-space coordinates. To obtain a point on an edge, supply a single parameter-space unit to obtain the model-space X Y X coordinates. The BRep API offers several Evaluator objects, through which you can define and obtain this parameter information. The evaluator objects provide methods for converting between parameter space and model space.

Next page | Using the API to traverse the BRep hierachy
1, 2, 3

Disclaimer


BRep - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Boundary Representation

Using the API to traverse the BRep hierachy

This sample traverses the BRep hierarchy of an open part document, locating all planar faces. Using the SurfaceEvaluator object, it then determines the center of each face by dividing each side of the 2D parameter range box in half. A sketch point is added at every center point, each created on a new planar sketch.

The following code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

As indicated by the object model diagram, BRep information is obtained from the component definition, so the first step is to get the part component definition for the open part document. Then iterate through the SurfaceBodies collection of SurfaceBody objects. The SurfaceBody object has a Faces property providing direct access to that objects collection of faces. The following code begins to loop through that collection of faces:

Dim oPartDef As PartComponentDefinition
Set oPartDef = ThisApplication.ActiveDocument.ComponentDefinition

Dim oSurfaceBody As SurfaceBody
Dim oFace As Face

For Each oSurfaceBody In oPartDef.SurfaceBodies
  For Each oFace In oSurfaceBody.Faces

This sample deals only with planar faces, so check the surface type before obtaining the surface evaluator and the parameter range box for this face:
  If oFace.SurfaceType = kPlaneSurface Then

    Dim oEval As SurfaceEvaluator
    Set oEval = oFace.Evaluator

    Dim oRange As Box2d
    Set oRange = oEval.ParamRangeRect

To calculate the center point of the range box, determine the range of each side and halve it.

    Dim params(0 To 1) As Double
    params(0) = oRange.MinPoint.X + (oRange.MaxPoint.X - oRange. _
        MinPoint.X) * 0.5
    params(1) = oRange.MinPoint.Y + (oRange.MaxPoint.Y - oRange. _
        MinPoint.Y) * 0.5

The point is in the 2D parameter space of the face. Use the GetPointAtParam method to obtain the X Y Z coordinate of that point in model space, and then create a corresponding Point object.

    Dim cenPt() As Double
    oEval.GetPointAtParam params, cenPt

    Dim oPoint As Point
    Set oPoint = ThisApplication.TransientGeometry.CreatePoint _
        (cenPt(0), cenPt(1), cenPt(2))

Add a new sketch to the sketches collection of the part component definition. Add a sketch point to the sketch, at the previously determined face center point. Use the ModelToSketchSpace method to create the point in the 2D plane of the sketch. Finally, move on to the next Face object or the next SubrfaceBody object.

    Dim oSketch As PlanarSketch
    Set oSketch = oPartDef.Sketches.Add(oFace)

    Dim oPoint2D As Point2d
    Set oPoint2D = oSketch.ModelToSketchSpace(oPoint)

    Dim oSkPnt As SketchPoint
    Set oSkPnt = oSketch.SketchPoints.Add(oPoint2D)

  End If

  Next
Next

The sample places new sketches and sketch points in the part document. The sketch points are located at the center of all planar faces. For example, a tapered hexagonal solid results in placement of the following sketch points (here shown in wireframe mode):

Next page | BRep Objects and Reference Keys
1, 2, 3

Disclaimer


BRep - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Boundary Representation

BRep objects and Reference Keys

Due to the transient nature of BRep objects, it is necessary to minimize the time a reference to a BRep object is maintained. Any time the model is recomputed, the BRep object references become invalid. Use reference keys to maintain a persistent reference to a particular BRep object between model recomputes.

For example, a reference to a BRep Face object becomes invalid if features that reference that face are added or modified. To handle this case, create a reference key to the face before any features edits, and then use this reference key to obtain the face after each feature has been added.

Summary

The BRep API comprises a group of objects that define the boundary between the inside and the outside of a solid. In addition, these objects provide topological information, indicating contiguous edges and adjacent faces so the developer can traverse these edges and faces. The BRep API also provides evaluator objects to work with BRep surfaces and edges (curves) in their respective parameter spaces. BRep objects expose a Geometry property, through which the underlying geometry of the object can be obtained.

Also consider

Boundary Representation data is transient. It is generated during the session, and changes as the model changes. The model cannot be changed through BRep data. Instead, parts and assemblies must be modified through regular modeling operations - editing features, moving parts, and so on. Refer to individual feature descriptions for their specific parameters.

Next page | Back to the Overviews
1, 2, 3

Disclaimer


Browser - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Browser

Browser Integration

The browser in Autodesk Inventor is a critical element of the user interface. Autodesk Inventor uses it to display a hierarchical representation of the contents of the current document. While this information is useful, there are cases when it is desirable to use this portion of the screen to display other types of information. For example, a finite element application might choose to show a representation of the constraints and loads currently defined on the model.

The Autodesk Inventor API allows you to define and interact with the contents of the browser window. The API supports the ability to create additional panes within the browser. You can also add a tree hierarchy of iconic nodes - see the browser nodes overview.

Only one pane is visible at a time, but the user can switch between panes and you can activate different panes using the API. To create new panes, Autodesk Inventor uses an approach that is both very simple and extremely powerful. The additional panes that you can add are just ActiveX control containers. From the API you create a new pane and specify which ActiveX control to display within the pane. What makes this powerful is the fact that an ActiveX control can contain any type of information and can even consist of other ActiveX controls. There are a huge number of existing ActiveX controls and it is relatively easy to construct new custom ActiveX controls.

Below is some sample code that illustrates the process of creating and interacting with a new browser pane. This sample creates a new pane and places Microsoft's ActiveX calendar control within it. (This control was chosen for the sample because it's relatively simple and should already be available on your system.) It responds to events from the control by displaying the current date as the user clicks on new days within the control. The picture below displays the result after the pane has been created.

Browser pane created via API

For this sample, all of the following code is contained within a form module. This is not intended to show the only approach to creating a browser pane. Often this would be done in a class module so you can have a single object that handles all of the browser pane information that is unique to each document. This sample was written this way to make it easier to focus on the browser pane portion of the code without the complication of other issues. To make the sample, create a new ActiveX EXE project and copy this code into the form module.

' Declare variable for the calendar control.
Private WithEvents oCal As MSACAL.Calendar

' Declare global variables for the Inventor document and Application.
Private WithEvents oDocEvents As DocumentEvents
Private oPane As BrowserPane
Private oApp As Inventor.Application

Private Sub Form_Load()
    ' Set a reference to a running instance of Inventor.
    ' This expects Inventor to be running.
    Set oApp = GetObject(, "Inventor.Application")

    ' Get the active document.  This assumes a document is open.
    Dim oDoc As Inventor.Document
    Set oDoc = oApp.ActiveDocument

    ' Connect to the documents events.  Used to
    ' listen for when the document is closed.
    Set oDocEvents = oDoc.DocumentEvents

    ' Create a new browser pane using the Microsoft calendar control.
    Set oPane = oDoc.BrowserPanes.Add("Calendar", "MSCAL.Calendar")

    ' Set a reference to the calendar control
    ' that was created on the pane.
    Set oCal = oPane.Control

    ' Set the calendar to today's date.
    oCal.Today

    ' Make the new pane the active pane.
    oPane.Activate
End Sub

The first line is declaring a variable to be the type of the control. This is declared using the WithEvents keyword, so you'll be able to capture events from the control. There's one thing to be aware of at this point: in order to declare a variable of this type you must reference the control into your project. You typically think of referencing controls using the Components command within Visual Basic. However, because of what appears to be a bug in Visual Basic, if you reference the control this way, you'll get a "Run-time error 13: Type mismatch" error on the line:

Set oCal = oPane.Control

To reference the control so you can use it in a browser pane you must use the References command. The control won't be displayed in the list so you need to click the Browse… button on the References dialog. The control used in this sample is found in the System32 directory. By default, .ocx files are not displayed in the file list, so you need to select "ActiveX Controls (*.ocx)" in the "Files of type" list. This control is "MSCAL.OCX."

Let's look at some of the more interesting portions of the code. The first few lines handle connecting to Autodesk Inventor, getting the active document, and connecting to the document's events. None of this is specific to creating a new browser pane. The next few lines are where it gets interesting. The BrowserPanes.Add method creates the new pane. It only has two arguments. The first is the name of the pane. This is the name that the user sees in the list when selecting panes and what is displayed at the top of the browser when that pane is active. You can see in the previous picture that "Calendar" is displayed as the browser's title. The second argument specifies which ActiveX control to place into the new pane. The control can be specified using either the ProgID, as is done in this sample, or the GUID of the control. If a GUID is specified it is as a string with the enclosing braces. For example, "{8E27C92B-1264-101C-8A2F-040224009C02}" would also work in this case.

Just creating the pane and adding the ActiveX control is usually not enough. Typically you'll need to interact with the control to populate data within it and keep the information up-to-date. The next line uses the Control property of the BrowserPane object to set a reference to the ActiveX control that was added to the pane. You now have complete access to the control through whatever methods, properties, and events it exposes. In the sample it calls the Today method of the control to set the calendar to today's date. Finally, it activates that pane to make it visible to the user.

The variable that is used to reference the control was declared using the WithEvents keyword to enable receiving events from the control. The code below is executed whenever the user clicks a date on the calendar. If the user selects January 1, 2000, it will cause the form to be unloaded. The code for the Form_Unload event is listed later.

' Event fired when the calendar is clicked
Private Sub oCal_Click()
    ' Display the new date in the Inventor status bar.
    oApp.StatusBarText = "Selected new date: " & _
                        Format(oCal.Value, "mmmm dd, yyyy")

    ' Check for January 1, 2000 and unload the form.
    If oCal.Value = #1/1/2000# Then
        Unload Me
    End If
End Sub

The code below is executed when the document is closed. It causes the form to be unloaded.

Private Sub oDocEvents_OnClose( _
                          ByVal BeforeOrAfter As Inventor.EventTimingEnum, _
                          ByVal Context As Inventor.NameValueMap, _
                          HandlingCode As Inventor.HandlingCodeEnum)
    If BeforeOrAfter = kBefore Then
        Unload Me
    End If
End Sub

The code below is executed when the form is unloaded. It releases all references and deletes the pane.

Private Sub Form_Unload(Cancel As Integer)
    Set oCal = Nothing
    Set oDocEvents = Nothing
    Set oApp = Nothing
    oPane.Delete
End Sub

The browser is a document-centric object. The contents of the browser are unique for each document. When adding panes, they must be added to each document you want the pane to be visible within. Each pane will have its own instance of the ActiveX control, so each one must be managed independently. The browser information is not persisted between sessions by Autodesk Inventor. If you need the data between sessions you'll need to persist the data yourself, create a new pane, and restore the data the next time the document is opened.

Next page | Back to the Overviews
Disclaimer


Browser Nodes - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Browser Nodes

Introduction to Browser Nodes

A significant element of the Autodesk Inventor user interface is the browser. In a part file, this displays the names of features, sketches, work features and so on. In an assembly file, it also shows part or subassembly occurrences and assembly features. It provides a convenient and intuitive means of traversing and selecting objects and features in the model hierarchy. Typically, the status of each object or feature is indicated by a graphical icon at the appropriate tree node. The following figure represents a browser tree view of a model assembly.

The purpose of browser node customization

The Autodesk Inventor API allows customization of the browser pane. This can mean adding a new pane, perhaps containing an ActiveX control. This topic is covered in a separate overview - see the Browser pane overview.

The API also enables iteration of existing browser tree nodes and the addition of browser panes containing custom tree structures representing your own data, complete with your own graphical icons. For example, you can represent a file system, your organization's management hierarchy, or some discipline-specific data such as HVAC throughput.

Browser API Object Model diagram

Iterating browser nodes through the API

The following code iterates through the browser model tree of an open part or assembly document, printing the node labels to the VBA debug screen (the "Immediate" window in VBA, if enabled). This code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

This code defines two routines. The first one obtains the top-level objects and then the second routine is called recursively (it repeatedly calls itself) to iterate through the entire browser tree structure. Add this code to an ApplicationProject code module in VBA.

First, obtain the Document object.

Private Sub QueryModelTree()
    Dim Doc As Document

    If (ThisApplication.Documents.Count <> 0) Then
        Set Doc = ThisApplication.ActiveDocument
    Else
        MsgBox "There are no open documents!"
        Exit Sub
    End If

Now obtain the top node for the browser pane of the model tab.

    Dim oTopNode As BrowserNode
    Set oTopNode = Doc.BrowserPanes("Model").TopNode

From the top node, call the routine named "recurse", which prints the node definition label and moves on to the next node, if any.

    Call recurse(oTopNode)
End Sub

The second routine calls itself for each node in the collection of browser nodes, printing the node definition label of each node.

Sub recurse(node As BrowserNode)
    If (node.Visible = True) Then
        Debug.Print node.BrowserNodeDefinition.Label
        Dim bn As BrowserNode
        For Each bn In node.BrowserNodes
            Call recurse(bn)
        Next
    End If
End Sub

For the assembly tree denoted by the first figure, this results in a report similar to the following example.

scissor.iam
Representations
View: None
None
Private...
Position
Origin
YZ Plane
XZ Plane
XY Plane
X Axis
Y Axis
Z Axis
Center Point…

…and so on.

Creating a custom pane and adding browser nodes

The preceding code simply iterated through an existing tree node hierarchy.

The following code adds a new pane tab and then adds several levels of tree nodes. This results in a new tab on the browser pane in the user interface, in addition to the standard model, library and representations tabs. Add this code to the ThisDocument module in VBA.

First, obtain the BrowserPanes collection for the current document. As noted in the object model diagram, new panes are added to this collection, and also this object provides access to the client node resources through which new icons may be added.

Sub AddNodes()

Dim oPanes As BrowserPanes
Set oPanes = ThisDocument.BrowserPanes

Dim oRscs As ClientNodeResources
Set oRscs = oPanes.ClientNodeResources

Create a standard Microsoft Windows IPictureDisp referencing an icon (.bmp) bitmap file. Change the file referenced here as appropriate - here the code references test.bmp. This is the icon that will be displayed at this node. Add the IPictureDisp to the client node resource. (If an invalid icon is supplied, the icon will default to the standard "Notepad" icon.)

Dim oIcon As IPictureDisp
Set oIcon = LoadPicture("c:\temp\test.bmp")

Dim oRsc As ClientNodeResource
Set oRsc = oRscs.Add("Test", 1, oIcon)

Before adding a new pane tab to the panes collection, define the top node the pane will contain. Pass this node when creating the new pane "My Pane" through the AddTreeBrowserPane method.

Dim oDef As BrowserNodeDefinition
Set oDef = oPanes.CreateBrowserNodeDefinition("Top Node", 3, oRsc)

Dim oPane As BrowserPane
Set oPane = oPanes.AddTreeBrowserPane("My Pane", "MyGUID", oDef)

Add two child nodes to the tree, labeled Node 2 and Node 3.

Dim oDef1 As BrowserNodeDefinition
Dim oNode1 As BrowserNode

Set oDef1 = oPanes.CreateBrowserNodeDefinition("Node2", 5, oRsc)
Set oNode1 = oPane.TopNode.AddChild(oDef1)

Dim oDef2 As BrowserNodeDefinition
Dim oNode2 As BrowserNode

Set oDef2 = oPanes.CreateBrowserNodeDefinition("Node3", 6, oRsc)
Set oNode1 = oPane.TopNode.AddChild(oDef2)

End Sub

The preceding routine results in a new pane and tree structure as follows (substituting your icon).

Browser nodes can be reordered. The BrowserPane.Reorder method allows one or more nodes to be repositioned within the tree hierarchy. (Note: this is not possible with the assembly pane.)

If a custom pane has browser nodes that are conceptually connected to objects (sketches, faces, constraints, and so on) in the model, this relationship can be created and maintained through the use of reference keys. The ClientBrowserNodeDefinition object supports the GetReferenceKey method.

By default, the browser pane is saved with the document. This means it is the responsibility of the application to either remove its browser UI, or reconnect and synchronize with the browser when the document is next present.

Events

The BrowserPanesEvents property of the BrowserPanes collection object returns the BrowserPanesEvents object, supporting browser node event notification. This allows applications to emulate Autodesk Inventor's behavior by reacting to user manipulation of the tree nodes. Events supported include node label editing, node activation, and object highlighting. These events are in addition to those supported by the BrowserPane object.

Summary

The browser customization API can be divided into two areas: adding an ActiveX control to a browser pane, or adding a hierarchical tree node structure to a browser pane. The latter allows an application to represent its data or constructs in a graphical manner already familiar to the user, complete with custom icons and labels. Events allow the application to be notified when the user selects a tree node.

Also consider

For complex user interactions, standard or custom ActiveX controls can be added to browser panes. The browser panes collection object acts as an ActiveX container.

Next page | Back to the Overviews
Disclaimer


Change Processor - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Change Processor

Introduction to the change processor

Autodesk Inventor users can undo actions. They can undo edits that have changed the document. They can redo their undo - in other words, they can recommit changes they had previously undone. These actions are evident in the user interface. The Edit menu indicates the last command that can be undone, as well as any command that can be redone.

For developers using the Autodesk Inventor API, the change processor can be used to achieve the same thing.

The purpose of the change processor

Developers typically use the API transaction mechanism (TransactionManager and associated objects) to group actions atomically, and to commit or roll back those actions. This works well in the context of the application, but it is not well integrated into the user interface, and is distinct from the Autodesk Inventor internal transaction mechanism.

Ideally, a mechanism should exist to allow Autodesk Inventor to take care of transacting developer-defined actions, and to integrate any roll-back and commit actions into its user interface. This is the purpose of the change processor.

An action encapsulated in a change processor automatically benefits from Autodesk Inventor's transaction mechanism as a named action. It also automatically becomes part of the Autodesk Inventor undo and redo sequence, with the named action visible through the user interface.

The change processor object also has methods for writing and reading script strings. Developers can use these strings to persist application-specific actions.

The change processor is the preferred transaction mechanism in most cases, when compared to transactions administered through the transaction manager API.

The change processor object model diagram

Change Processor Object Model Diagram

Working with the change processor API

The change processor relies on event callbacks. The developer code to be transacted (the drawing of sketches, creating features and so on) is started as a result of a call to the execute method of the change processor. The change processor object is created by the CreateChangeProcessor method of the ChangeDefinition object, which is the named atomic unit subject to Autodesk Inventor's undo and redo mechanism.

There can be any number of change definition objects, contained by the ChangeDefinitions collection object. In addition, the ChangeManager object can create any number of ChangeDefinitions collections. Each ChangeDefinitions object is associated with a unique string for the purposes of identification. This string can be anything, but most often will be the unique CLSID of the application.

The code to be transacted is executed by calling the execute method of the ChangeProcessor encapsulating that code. There can be only one ChangeProcessor object created by the ChangeDefinition object, but that ChangeProcessor object can be deleted and recreated. As an example, consider code to be executed as the result of a button press. The button may never be pressed, so the ChangeProcessor need not be created until it is, and can be deleted afterwards. The ChangeDefinition is always there, ready to create the ChangeProcessor. This is why the code to be transacted is executed as an event callback. The ChangeProcessor is created on the fly, and its execute method is called explicitly.

A ChangeProcessor in action

The following sample first defines a class comprised of three subroutines and some global data. This class is later instantiated and responds to button and change processor events.

This sample omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

Create a new VBA project and add a new class module named clsCreateLine. Add the following code to the general declarations section of the new class module. This code defines the change definition, change processor, and button definition as global objects able to respond to events.

Option Explicit
Private WithEvents mobjChangeDef As ChangeDefinition
Private WithEvents mobjChangeProcessor As ChangeProcessor
Private WithEvents mobjButtonDefinitionEvents As ButtonDefinition

Now add the first of the three subroutines to the class. This one is called when the class is instantiated and is where initialization code should be located. The handler for the button is created here.

Private Sub Class_Initialize()
    Dim objCommandMgr As CommandManager
    Set objCommandMgr = ThisApplication.CommandManager

    Dim colControlDefs As ControlDefinitions
    Set colControlDefs = objCommandMgr.ControlDefinitions

    Dim objButtonDef As ButtonDefinition
    Set objButtonDef = colControlDefs.Item("CreateLine")

    Set mobjButtonDefinitionEvents = objButtonDef
End Sub

The second subroutine to add to the class defines what happens when the button is pressed. This is where the change processor is created from the existing ChangeDefinition object, and its execute method is called.

Private Sub mobjButtonDefinitionEvents_OnExecute(ByVal Context As NameValueMap)

    Dim objChangeMgr As ChangeManager
    Set objChangeMgr = ThisApplication.ChangeManager

    Dim colChangeDefs As ChangeDefinitions

    Set colChangeDefs = objChangeMgr.Item("My_unique_CP_ID")
    Set mobjChangeDef = colChangeDefs.Item("CreateLine")
    Set mobjChangeProcessor = mobjChangeDef.CreateChangeProcessor

    Dim objActiveDoc As Document
    Set objActiveDoc = ThisApplication.ActiveDocument

    mobjChangeProcessor.Execute objActiveDoc
End Sub

The third and last subroutine to add to the clsCreateLine class definition defines what happens when the execute event of the change processor is called. This is the transacted code. The following example adds a sketch line to the open part document.

Private Sub mobjChangeProcessor_OnExecute(ByVal Document As Document, ByVal Context As NameValueMap, Succeeded As Boolean)
    Dim objPartDoc As PartDocument
    Set objPartDoc = Document

    Dim objPartCompDef As PartComponentDefinition
    Set objPartCompDef = objPartDoc.ComponentDefinition

    Dim objTransGeom As TransientGeometry
    Set objTransGeom = objPartDoc.Parent.TransientGeometry

    Dim colLine As SketchLine
    Set colLine = objPartCompDef.Sketches(1).SketchLines.AddByTwoPoints _
        (objTransGeom.CreatePoint2d(0, 0), objTransGeom.CreatePoint2d(4, 0))
End Sub

This completes the class definition. Now add the code that instantiates this class. Add a new code module to the modules section of your VBA project. First, add a global declaration of the new class to the general declarations section, as follows.

Option Explicit
Public mobjCreateLine As clsCreateLine

Next, add the public subroutine that will be called to run this application. This does three things. It calls the subroutine to set up the ChangeDefinition object, and it calls the subroutine to add a button to the command panel. Both subroutines are defined in this module. Lastly, it instantiates the clsCreateLine class defined previously.

Sub CreateLineUsingChangeProcessor()
    Call AddCreateLineChangeDef
    Call AddLineButton
    Set mobjCreateLine = New clsCreateLine
End Sub

Now add the subroutine that creates the ChangeDefinition object. This object is created through the Add method if the ChangeDefinitions object, which is created through the Add method of the ChangeManager object. A unique ID is associated with the ChangeDefinitions object, to aid in identification elsewhere in the application. Similarly, the ChangeDefinition is named too, however this information is used in the user interface. The 'Create Line' text in the following code will be displayed in the Autodesk Inventor Edit menu as the last command that can be undone. If undone, it will display as the command that can be redone.

Private Sub AddCreateLineChangeDef()

    Dim objChangeMgr As ChangeManager
    Set objChangeMgr = ThisApplication.ChangeManager

    Dim colChangeDefs As ChangeDefinitions
    Set colChangeDefs = objChangeMgr.Add("My_unique_CP_ID")

    Dim objDhangeDef As ChangeDefinition
    Set objDhangeDef = colChangeDefs.Add("CreateLine", "Create Line")

End Sub

Finally, add the subroutine that adds the button to the command panel. This uses the standard user interface customization API. User interface customization is covered elsewhere in the Autodesk Inventor programming Help.

Private Sub AddLineButton()

    Dim objCommandMgr As CommandManager
    Set objCommandMgr = ThisApplication.CommandManager

    Dim colControlDefs As ControlDefinitions
    Set colControlDefs = objCommandMgr.ControlDefinitions

    Dim objButtonDef As ButtonDefinition
    Set objButtonDef = colControlDefs.AddButtonDefinition("Line", _
        "CreateLine", kShapeEditCmdType, "", "Create Line", "Line")

    Dim objSketchToolbar As CommandBar
    Set objSketchToolbar = ThisApplication.UserInterfaceManager. _
        CommandBars.Item("PMxPartSketchCmdBar")

    Dim objButtonControl As CommandBarControl
    Set objButtonControl = objSketchToolbar.Controls.AddButton(objButtonDef)

    objButtonDef.Enabled = True

End Sub

Once all the preceding code is added, the VBA project browser should appear as follows.

Start a new part document in Autodesk Inventor, and run the CreateLineUsingChangeProcessor subroutine. A new Line button is added to the command panel as follows:

Pressing this button causes a sketch line to be created in the part document. Now look at the Edit menu. Notice the ChangeProcessor named Create Line is available for undo. Pressing the Undo button causes the sketch line to disappear, and the Create Line ChangeProcessor is available for redo. The menu appears as follows:

Summary

Use the change processor API to take advantage of Autodesk Inventor's own transaction and undo/redo mechanism. It is no longer necessary to explicitly define the start, end, and nesting of transactions. Developer code can be executed as an atomic named unit, and can be undone and redone through the Autodesk Inventor user interface.

Also consider

For cases where a fine degree of granular control is required, the transaction API may still be appropriate. The developer can nest transactions in a specific manner and add checkpoints for partial rollback.

Next page | Back to the Overviews
Disclaimer


Client Views - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Client Views

Introduction to client views

A subset of the Autodesk Inventor API, with a few additions, is provided for developers wishing to work with Autodesk Inventor documents outside of the Autodesk Inventor environment. This API is provided through Apprentice Server - an ActiveX server that can be incorporated into other applications. Apprentice Server has no user interface, and most of its API is read-only.

One part of the Apprentice Server API that has no direct equivalent in Autodesk Inventor is the ClientView object. When writing an application outside of Autodesk Inventor, the ClientView object provides a convenient means of displaying an Autodesk Inventor document in a similar manner to Autodesk Inventor itself.

The purpose of client views

The ClientView object allows the developer to associate an Autodesk Inventor document with a window handle in their standalone application, and to manipulate the view of the document through the use of the Camera object. The view orientation can be modified, as can the perspective, extents, and mouse-driven applied transformation. A client view can provide a visually appealing graphic with minimal effort on the part of the developer.

ClientView object model diagram

Working with client views through the API

Creation of a new ClientView object is only possible through Apprentice Server. It is not currently possible to add a new ClientView object within the Autodesk Inventor environment. For example, using VBA to call the Add method of a ClientView object obtained through the Sheet object of a Drawing document will fail.

The ClientView object is always associated with a window handle (hWnd). The ClientViews collection object provides two methods for creating a new ClientView object; Add and AddBySubset. The latter method is likely to be depreciated. The Add method associates a document client view with a given window handle.

Setting up a client view in Apprentice Server

The following example uses Visual Basic, though any fully ActiveX-compliant environment should work. The code omits error checking for brevity and clarity. Always check that return values are of the expected type and in the expected range.

In Visual Basic, add a PictureBox control to a new form. Keep the default control name Picture1. Double-click the control to enter the code module, and add the following code in the declarations section:

Dim oSvr As ApprenticeServerComponent
Dim oAppDoc As ApprenticeServerDocument
Dim oClientView As ClientView

At this point, Visual Basic has no idea what an ApprenticeServerComponent is. A reference to the Apprentice Server type library is needed. In the Visual Basic user interface, select Project, then References. In the list of available references, put a check against the item labeled Autodesk Inventor's Apprentice Object Library. This points to the RxApprentice.tlb type library.

Continue adding code. In the Form_Load sub, add the following:

Private Sub Form_Load()
  Dim filename As String
  filename = "C:\Autodesk\Inventor 10\Tutorial Files\analyze-2.iam"
  Set oSvr = New ApprenticeServerComponent
  Set oAppDoc = oSvr.Open(filename)
  Set oClientView = oAppDoc.ClientViews.Add(Picture1.hWnd)
End Sub

The preceding code references an assembly file. Change this reference to suit. An instance of the ApprenticeServerComponent is created, and the assembly document is opened by Apprentice Server. The last line adds a new ClientView object to the document's ClientViews collection, and references the window handle (hWnd) of the Picture1 control.

In the Picture1_Click sub, add the following code:

Private Sub Picture1_Click()
  Dim oCamera As Camera
  Set oCamera = oClientView.Camera
  oCamera.ViewOrientationType = kIsoBottomLeftViewOrientation
  oCamera.Perspective = True
  oCamera.Apply
  Me.Refresh
End Sub

The preceding code responds to a click event on the Picture1 control, setting various camera properties before refreshing the view. The ISO orientation type is set to bottom left, and perspective viewing is enabled.

Lastly, add the following code to the Form_Paint event. This is to ensure the view is maintained if the window is changed in any way. The Update method takes a Boolean argument; true if the view is dynamically updated, to improve performance.

Private Sub Form_Paint()
  oClientView.Update (False)
End Sub

The following figure shows the results of running the sample code and clicking on the picture control:

ClientViews, the ClientViews ActiveX control, and Autodesk Inventor View

The ClientView object in the Apprentice Server API provides a convenient means of displaying Autodesk Inventor documents outside of Autodesk Inventor, but it does require Apprentice Server.

Another option available to the developer is a ClientView OCX control. This control can be embedded in applications or HTML pages. It does not require Autodesk Inventor or Apprentice Server, and provides a similar level of functionality as the ClientView API. The control is named InventorViewerCtrl.ocx, and is located in Autodesk Inventor's Bin subdirectory. Its ProgID is Inventor.ViewControl, and it exposes a number of properties, including the following:

AboutBox : Causes the about box associated with the control to be displayed.
ActiveViewingCommand : Gets and sets the currently active command within the view control (ViewingCommandEnum).
ApprenticeServerDocument : Gets the document the view was created from.
ClientView : Returns the ClientView object that is currently being used by the viewer control.
DisplayMode : Gets or sets the display mode (DisplayModeEnum).
Filename : Gets or sets the name of an Assembly/Part/Drawing file to open.
HideToolbar : Controls whether the toolbar is displayed when the end-user moves the mouse over the viewer control.
Interactive : Gets or sets a value that determines whether the control can be manipulated interactively.
Perspective : Gets or sets whether the camera is in perspective mode.
SheetIndex : Gets or sets the index of the current sheet. Only for drawing files.
ViewOrientationType : Gets the view orientation type (ViewOrientationTypeEnum).

A full installation of Autodesk Inventor will also install Autodesk Inventor View. This is a user application for viewing Autodesk Inventor files, built using the InventorViewerCtrl control. Autodesk Inventor View is distinct from the OCX control, and has no API.

Summary

An application developer wishing to use an Autodesk Inventor API to display Autodesk Inventor documents in their application has two options. The Apprentice Server API provides the ClientView object, enabling Autodesk Inventor files to be viewed and manipulated in a client window.

If no other Apprentice Server functionality is required, the second option is to use the InventorViewerCtrl control, which can be embedded into applications and web pages without the need for either Autodesk Inventor or Apprentice Server.

A user application for viewing Autodesk Inventor files is installed with Autodesk Inventor. It is named Autodesk Inventor View, and is accessible though the Microsoft Windows Start menu.

Also consider

Autodesk has viewers for many of its products, but an increasingly popular format is DWF (Drawing Web Format). Autodesk Inventor can export DWF files for publishing.

Next page | Back to the Overviews
Disclaimer


Contents

Contents

Introduction

Accessing the API

VBA in Inventor

About Addins

Symbol Reference

Inventor Library

Objects

AliasFreeformFeature Interface

AliasFreeformFeature Methods

AliasFreeformFeature._Redefine Method

AliasFreeformFeatureProxy Interface

AliasFreeformFeatures Interface

AliasFreeformFeatures Methods

AliasFreeformFeatures._Add Method

AliasFreeformFeatures.Item Method

AliasFreeformFeatures Properties

AliasFreeformFeatures.Application Property

AliasFreeformFeatures.Count Property

AliasFreeformFeatures.Type Property

AddInAutomation CoClass Introduced in Inventor 4

AnalysisManager Interface Introduced in Inventor 2009

AnalysisManager Properties

AnalysisManager.ActiveAnalysis Property Introduced in Inventor 2009

AnalysisManager.ActiveAnalysisType Property Introduced in Inventor 2009

AnalysisManager.Application Property Introduced in Inventor 2009

AnalysisManager.DraftAnalyses Property Introduced in Inventor 2009

AnalysisManager.IsAnalysisVisible Property Introduced in Inventor 2009

AnalysisManager.Parent Property Introduced in Inventor 2009

AnalysisManager.Type Property Introduced in Inventor 2009

AnalyticEdgeWorkAxisDef Interface Introduced in Inventor 11

AnalyticEdgeWorkAxisDef Properties

AnalyticEdgeWorkAxisDef.Application Property Introduced in Inventor 11

AnalyticEdgeWorkAxisDef.Edge Property Introduced in Inventor 11

AnalyticEdgeWorkAxisDef.Parent Property Introduced in Inventor 11

AnalyticEdgeWorkAxisDef.Type Property Introduced in Inventor 11

AngleConstraint Interface Introduced in Inventor 4

AngleConstraint Methods

AngleConstraint.Directed Method

AngleConstraint.DirectionOneReversed Method

AngleConstraint.DirectionTwoReversed Method

AngleConstraint Properties

AngleConstraint.Angle Property Introduced in Inventor 4

AngleConstraint.ConstraintLimits Property Introduced in Inventor 2011

AngleConstraint.ReferenceVectorEntity Property Introduced in Inventor 2009

AngleConstraint.SolutionType Property Introduced in Inventor 2009

AngleConstraintProxy Interface Introduced in Inventor 11

AngleConstraintProxy Properties

AngleConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

AngleConstraintProxy.NativeObject Property Introduced in Inventor 11

AngleExtent Interface Introduced in Inventor 5

AngleExtent Properties

AngleExtent.Angle Property Introduced in Inventor 5

AngleExtent.Direction Property Introduced in Inventor 5

AngleiMateDefinition Interface Introduced in Inventor 6

AngleiMateDefinition Properties

AngleiMateDefinition.Angle Property Introduced in Inventor 6

AngleiMateDefinition.DirectionOneReversed Property Introduced in Inventor 6

AngleiMateDefinition.Entity Property Introduced in Inventor 6

AngleiMateDefinitionProxy Interface Introduced in Inventor 6

AngleiMateDefinitionProxy Properties

AngleiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

AngleiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

AngleiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

AngularGeneralDimension Interface Introduced in Inventor 11

AngularGeneralDimension Methods

AngularGeneralDimension.CenterText Method Introduced in Inventor 2008

AngularGeneralDimension Properties

AngularGeneralDimension.AngularPrecision Property Introduced in Inventor 2008

AngularGeneralDimension.ExtensionLineOne Property Introduced in Inventor 2008

AngularGeneralDimension.ExtensionLineOneVisible Property Introduced in Inventor 2011

AngularGeneralDimension.ExtensionLineTwo Property Introduced in Inventor 2008

AngularGeneralDimension.ExtensionLineTwoVisible Property Introduced in Inventor 2011

AngularGeneralDimension.IntentOne Property Introduced in Inventor 11

AngularGeneralDimension.IntentTwo Property Introduced in Inventor 11

AngularGeneralDimension.IntentThree Property Introduced in Inventor 11

AngularGeneralDimension.OppositeAngle Property Introduced in Inventor 11

AngularGeneralDimension.ShowLeader Property Introduced in Inventor 11

AngularGeneralDimension.ToleranceAngularPrecision Property Introduced in Inventor 2008

AngularGeneralDimension.UseQuadrant Property Introduced in Inventor 11

Application Interface Introduced in Inventor 4

Application Methods

Application.Login Method

Application.CreateFileDialog Method Introduced in Inventor 6

Application.CreateProgressBar Method Introduced in Inventor 2010

Application.GetAppFrameExtents Method Introduced in Inventor 4

Application.Move Method Introduced in Inventor 6

Application.Quit Method Introduced in Inventor 4

Application Properties

Application.ActiveColorScheme Property Introduced in Inventor 9

Application.ActiveDocument Property

Application.ActiveDocumentType Property Introduced in Inventor 4

Application.ActiveEditDocument Property Introduced in Inventor 2009

Application.ActiveEditObject Property Introduced in Inventor 4

Application.ActiveView Property Introduced in Inventor 4

Application.CameraEvents Property

Application.Caption Property Introduced in Inventor 4

Application.ColorSchemes Property Introduced in Inventor 9

Application.CommandManager Property Introduced in Inventor 4

Application.FileUIEvents Property Introduced in Inventor 4

Application.HardwareOptions Property Introduced in Inventor 11

Application.Height Property Introduced in Inventor 2010

Application.HelpManager Property Introduced in Inventor 4

Application.Left Property Introduced in Inventor 6

Application.MainFrameHWND Property Introduced in Inventor 4

Application.MRUDisplay Property Introduced in Inventor 2009

Application.OpenDocumentsDisplay Property

Application.MRUEnabled Property Introduced in Inventor 4

Application.ScreenUpdating Property Introduced in Inventor 2009

Application.SilentOperation Property Introduced in Inventor 4

Application.StatusBarText Property Introduced in Inventor 5

Application.Top Property Introduced in Inventor 6

Application.UserInterfaceManager Property Introduced in Inventor 9

Application.Views Property Introduced in Inventor 2010

Application.Visible Property Introduced in Inventor 4

Application.Width Property Introduced in Inventor 2010

Application.WindowState Property Introduced in Inventor 6

ApplicationAddIn Interface Introduced in Inventor 4

ApplicationAddIn Methods

ApplicationAddIn.Activate Method Introduced in Inventor 4

ApplicationAddIn.Deactivate Method Introduced in Inventor 4

ApplicationAddIn.StartUpEnabled Method Introduced in Inventor 4

ApplicationAddIn.Version Method Introduced in Inventor 9

ApplicationAddIn Properties

ApplicationAddIn.Activated Property Introduced in Inventor 4

ApplicationAddIn.AddInType Property Introduced in Inventor 4

ApplicationAddIn.Application Property

ApplicationAddIn.Automation Property Introduced in Inventor 4

ApplicationAddIn.ClassIdString Property Introduced in Inventor 4

ApplicationAddIn.ClientId Property

ApplicationAddIn.DataVersion Property Introduced in Inventor 2008

ApplicationAddIn.Description Property Introduced in Inventor 4

ApplicationAddIn.DisplayName Property Introduced in Inventor 4

ApplicationAddIn.Hidden Property Introduced in Inventor 9

ApplicationAddIn.LicenseStatus Property Introduced in Inventor 2009

ApplicationAddIn.LoadAutomatically Property

ApplicationAddIn.LoadBehavior Property

ApplicationAddIn.Location Property

ApplicationAddIn.Parent Property

ApplicationAddIn.ProgId Property Introduced in Inventor 4

ApplicationAddIn.ShortDisplayName Property Introduced in Inventor 4

ApplicationAddIn.Type Property

ApplicationAddIn.UserInterfaceVersion Property

ApplicationAddIn.UserUnloadable Property Introduced in Inventor 9

ApplicationAddIns Interface Introduced in Inventor 4

ApplicationAddIns Methods

ApplicationAddIns.Item Method Introduced in Inventor 4

ApplicationAddIns.ItemById Method Introduced in Inventor 2008

ApplicationAddIns Properties

ApplicationAddIns.Count Property Introduced in Inventor 4

ApplicationAddIns.Type Property Introduced in Inventor 4

ApplicationAddInServer Interface Introduced in Inventor 4

ApplicationAddInServer Methods

ApplicationAddInServer.Activate Method Introduced in Inventor 4

ApplicationAddInServer.Deactivate Method Introduced in Inventor 4

ApplicationAddInServer.ExecuteCommand Method Introduced in Inventor 4

ApplicationAddInServer Properties

ApplicationAddInServer.Automation Property Introduced in Inventor 4

ApplicationAddInSite Interface Introduced in Inventor 4

ApplicationAddInSite Methods

ApplicationAddInSite.InventorServer Method

ApplicationAddInSite.LicenseChallenge Method

ApplicationAddInSite.LicenseResponse Method

ApplicationAddInSite Properties

ApplicationAddInSite.Application Property Introduced in Inventor 4

ApplicationAddInSite.Parent Property Introduced in Inventor 7

ApplicationAddInSite.Type Property Introduced in Inventor 5

ApplicationEvents CoClass Introduced in Inventor 4

ApplicationEventsObject Interface Introduced in Inventor 4

ApplicationEventsObject Properties

ApplicationEventsObject.Application Property Introduced in Inventor 5

ApplicationEventsObject.Parent Property Introduced in Inventor 5

ApplicationEventsObject.Type Property Introduced in Inventor 5

ApplicationEventsSink Interface Introduced in Inventor 4

ApplicationEventsSink Methods

ApplicationEventsSink.OnActivateDocument Method Introduced in Inventor 4

ApplicationEventsSink.OnActivateView Method Introduced in Inventor 4

ApplicationEventsSink.OnActiveProjectChanged Method Introduced in Inventor 7

ApplicationEventsSink.OnApplicationOptionChange Method Introduced in Inventor 2010

ApplicationEventsSink.OnCloseDocument Method Introduced in Inventor 4

ApplicationEventsSink.OnCloseView Method Introduced in Inventor 4

ApplicationEventsSink.OnDeactivateDocument Method Introduced in Inventor 4

ApplicationEventsSink.OnDeactivateView Method Introduced in Inventor 4

ApplicationEventsSink.OnDisplayModeChange Method Introduced in Inventor 9

ApplicationEventsSink.OnDocumentChange Method Introduced in Inventor 8

ApplicationEventsSink.OnInitializeDocument Method Introduced in Inventor 11

ApplicationEventsSink.OnMigrateDocument Method Introduced in Inventor 2008

ApplicationEventsSink.OnNewDocument Method Introduced in Inventor 4

ApplicationEventsSink.OnNewEditObject Method Introduced in Inventor 5

ApplicationEventsSink.OnNewView Method Introduced in Inventor 4

ApplicationEventsSink.OnOpenDocument Method Introduced in Inventor 4

ApplicationEventsSink.OnQuit Method Introduced in Inventor 4

ApplicationEventsSink.OnReady Method Introduced in Inventor 9

ApplicationEventsSink.OnRestart32BitHost Method Introduced in Inventor 2008

ApplicationEventsSink.OnSaveDocument Method Introduced in Inventor 4

ApplicationEventsSink.OnTerminateDocument Method Introduced in Inventor 11

ApplicationEventsSink.OnTranslateDocument Method Introduced in Inventor 5.3

ApprenticeDrawingPrintManager Interface Introduced in Inventor 9

ApprenticeDrawingPrintManager Methods

ApprenticeDrawingPrintManager.GetSheetRange Method Introduced in Inventor 9

ApprenticeDrawingPrintManager.SetSheetRange Method Introduced in Inventor 9

ApprenticeDrawingPrintManager Properties

ApprenticeDrawingPrintManager.AllColorsAsBlack Property Introduced in Inventor 9

ApprenticeDrawingPrintManager.PrintExcludedSheets Property Introduced in Inventor 9

ApprenticeDrawingPrintManager.PrintRange Property Introduced in Inventor 9

ApprenticeDrawingPrintManager.RemoveLineWeights Property Introduced in Inventor 9

ApprenticeDrawingPrintManager.Rotate90Degrees Property Introduced in Inventor 9

ApprenticeDrawingPrintManager.Scale Property Introduced in Inventor 9

ApprenticeDrawingPrintManager.ScaleMode Property Introduced in Inventor 9

ApprenticePrintManager Interface Introduced in Inventor 9

ApprenticePrintManager Methods

ApprenticePrintManager.PrintToFile Method Introduced in Inventor 9

ApprenticePrintManager.SetCurrentView Method Introduced in Inventor 9

ApprenticePrintManager.SubmitPrint Method Introduced in Inventor 9

ApprenticePrintManager Properties

ApprenticePrintManager.ColorMode Property Introduced in Inventor 9

ApprenticePrintManager.NumberOfCopies Property Introduced in Inventor 9

ApprenticePrintManager.Orientation Property Introduced in Inventor 9

ApprenticePrintManager.PaperHeight Property Introduced in Inventor 9

ApprenticePrintManager.PaperSize Property Introduced in Inventor 9

ApprenticePrintManager.PaperSource Property Introduced in Inventor 9

ApprenticePrintManager.PaperWidth Property Introduced in Inventor 9

ApprenticePrintManager.Printer Property Introduced in Inventor 9

ApprenticePrintManager.PrinterDeviceContext Property Introduced in Inventor 9

ApprenticePrintManager.Type Property Introduced in Inventor 9

ApprenticeServer Interface

ApprenticeServer Methods

ApprenticeServer.Close Method

ApprenticeServer.FileAccessEvents Method

ApprenticeServer.FileLocations Method

ApprenticeServer.Open Method

ApprenticeServer.OpenWithOptions Method

ApprenticeServer.ReferenceKeyEvents Method

ApprenticeServer Properties

ApprenticeServer.ApplicationAddIns Property

ApprenticeServer.DesignProjectManager Property

ApprenticeServer.DisplayAffinity Property

ApprenticeServer.DisplayOptions Property

ApprenticeServer.Document Property

ApprenticeServer.FileManager Property

ApprenticeServer.FileOptions Property

ApprenticeServer.FileSaveAs Property

ApprenticeServer.HardwareOptions Property

ApprenticeServer.InstallPath Property

ApprenticeServer.Locale Property

ApprenticeServer.MultiUserExternallyManaged Property

ApprenticeServer.MultiUserMode Property

ApprenticeServer.SoftwareVersion Property

ApprenticeServer.TransientGeometry Property

ApprenticeServer.TransientObjects Property

ApprenticeServer.Type Property

ApprenticeServer.UserName Property

ApprenticeServerComponent CoClass Introduced in Inventor 4

ApprenticeServerDocument Interface Introduced in Inventor 4

ApprenticeServerDocument Methods

ApprenticeServerDocument.Close Method Introduced in Inventor 2008

ApprenticeServerDocument.CreateHighlightSet Method Introduced in Inventor 2008

ApprenticeServerDocument.FindWhereUsed Method Introduced in Inventor 5

ApprenticeServerDocument.GetLocationFoundIn Method Introduced in Inventor 4

ApprenticeServerDocument.RevertReservedForWriteByMe Method Introduced in Inventor 6

ApprenticeServerDocument Properties

ApprenticeServerDocument.ActiveRenderStyle Property Introduced in Inventor 5

ApprenticeServerDocument.AllReferencedDocuments Property Introduced in Inventor 11

ApprenticeServerDocument.AttributeManager Property Introduced in Inventor 5

ApprenticeServerDocument.AttributeSets Property

ApprenticeServerDocument.ClientViews Property Introduced in Inventor 6

ApprenticeServerDocument.Compacted Property Introduced in Inventor 5

ApprenticeServerDocument.ComponentDefinition Property Introduced in Inventor 5

ApprenticeServerDocument.DatabaseRevisionId Property Introduced in Inventor 11

ApprenticeServerDocument.Dirty Property Introduced in Inventor 4

ApprenticeServerDocument.DisplayName Property Introduced in Inventor 4

ApprenticeServerDocument.DocumentInterests Property Introduced in Inventor 2008

ApprenticeServerDocument.DocumentType Property Introduced in Inventor 4

ApprenticeServerDocument.File Property Introduced in Inventor 11

ApprenticeServerDocument.FileSaveCounter Property Introduced in Inventor 4

ApprenticeServerDocument.FullDocumentName Property Introduced in Inventor 11

ApprenticeServerDocument.FullFileName Property Introduced in Inventor 4

ApprenticeServerDocument.HealthStatus Property Introduced in Inventor 5.3

ApprenticeServerDocument.InternalName Property Introduced in Inventor 4

ApprenticeServerDocument.IsModifiable Property Introduced in Inventor 6

ApprenticeServerDocument.IsSubstitutePart Property Introduced in Inventor 2009

ApprenticeServerDocument.NeedsMigrating Property Introduced in Inventor 4

ApprenticeServerDocument.Open Property Introduced in Inventor 11

ApprenticeServerDocument.PrintManager Property Introduced in Inventor 9

ApprenticeServerDocument.PropertySets Property Introduced in Inventor 4

ApprenticeServerDocument.ReferencedDocumentDescriptors Property Introduced in Inventor 11

ApprenticeServerDocument.ReferencedDocuments Property Introduced in Inventor 11

ApprenticeServerDocument.ReferencedOLEFileDescriptors Property Introduced in Inventor 4

ApprenticeServerDocument.ReferenceKeyManager Property Introduced in Inventor 2010

ApprenticeServerDocument.ReferencingDocuments Property Introduced in Inventor 11

ApprenticeServerDocument.RequiresUpdate Property

ApprenticeServerDocument.ReservedForWrite Property Introduced in Inventor 4

ApprenticeServerDocument.ReservedForWriteByMe Property Introduced in Inventor 4

ApprenticeServerDocument.ReservedForWriteLogin Property Introduced in Inventor 4

ApprenticeServerDocument.ReservedForWriteName Property Introduced in Inventor 4

ApprenticeServerDocument.ReservedForWriteTime Property Introduced in Inventor 4

ApprenticeServerDocument.ReservedForWriteVersion Property Introduced in Inventor 4

ApprenticeServerDocument.RevisionId Property Introduced in Inventor 5.3

ApprenticeServerDocument.SoftwareVersionCreated Property Introduced in Inventor 4

ApprenticeServerDocument.SoftwareVersionSaved Property Introduced in Inventor 4

ApprenticeServerDocument.SubstitutePartStatus Property Introduced in Inventor 2009

ApprenticeServerDocument.Thumbnail Property Introduced in Inventor 6

ApprenticeServerDocument.Type Property Introduced in Inventor 4

ApprenticeServerDocument.UnitsOfMeasure Property Introduced in Inventor 5

ApprenticeServerDocuments Interface Introduced in Inventor 4

ApprenticeServerDocuments Methods

ApprenticeServerDocuments.Item Method Introduced in Inventor 4

ApprenticeServerDocuments Properties

ApprenticeServerDocuments.Count Property Introduced in Inventor 4

ApprenticeServerDocuments.Type Property Introduced in Inventor 4

ApprenticeServerDrawingDocument Interface Introduced in Inventor 4

ApprenticeServerDrawingDocument Properties

ApprenticeServerDrawingDocument.ActiveStandard Property Introduced in Inventor 4

ApprenticeServerDrawingDocument.ContainingDWGDocument Property Introduced in Inventor 2008

ApprenticeServerDrawingDocument.IsInventorDWG Property Introduced in Inventor 2008

ApprenticeServerDrawingDocument.Sheets Property Introduced in Inventor 4

Arc2d Interface Introduced in Inventor 5

Arc2d Methods

Arc2d.GetArcData Method Introduced in Inventor 5

Arc2d.PutArcData Method Introduced in Inventor 5

Arc2d Properties

Arc2d.Center Property Introduced in Inventor 5

Arc2d.EndPoint Property Introduced in Inventor 5

Arc2d.Evaluator Property Introduced in Inventor 5

Arc2d.Radius Property Introduced in Inventor 5

Arc2d.StartAngle Property Introduced in Inventor 5

Arc2d.StartPoint Property Introduced in Inventor 5

Arc2d.SweepAngle Property Introduced in Inventor 5

Arc3d Interface Introduced in Inventor 6

Arc3d Methods

Arc3d.GetArcData Method Introduced in Inventor 6

Arc3d.PutArcData Method Introduced in Inventor 6

Arc3d Properties

Arc3d.Center Property Introduced in Inventor 6

Arc3d.EndPoint Property Introduced in Inventor 6

Arc3d.Evaluator Property Introduced in Inventor 6

Arc3d.Normal Property Introduced in Inventor 6

Arc3d.Radius Property Introduced in Inventor 6

Arc3d.ReferenceVector Property Introduced in Inventor 6

Arc3d.StartAngle Property Introduced in Inventor 6

Arc3d.StartPoint Property Introduced in Inventor 6

Arc3d.SweepAngle Property Introduced in Inventor 6

AssemblyComponentDefinition Interface Introduced in Inventor 4

AssemblyComponentDefinition Methods

AssemblyComponentDefinition.AdjustProxyContext Method Introduced in Inventor 8

AssemblyComponentDefinition.AnalyzeInterference Method Introduced in Inventor 6

AssemblyComponentDefinition.CreateFactory Method Introduced in Inventor 11

AssemblyComponentDefinition.ExportObjects Method

AssemblyComponentDefinition.FindUsingRay Method Introduced in Inventor 5.3

AssemblyComponentDefinition.GetEndOfFeaturesPosition Method Introduced in Inventor 2010

AssemblyComponentDefinition.SetEndOfFeaturesToTopOrBottom Method Introduced in Inventor 2010

AssemblyComponentDefinition.SuppressFeatures Method Introduced in Inventor 2009

AssemblyComponentDefinition.TransformOccurrences Method Introduced in Inventor 2009

AssemblyComponentDefinition.UnsuppressFeatures Method Introduced in Inventor 2009

AssemblyComponentDefinition Properties

AssemblyComponentDefinition.ActiveOccurrence Property Introduced in Inventor 6

AssemblyComponentDefinition.AssemblyEvents Property Introduced in Inventor 4

AssemblyComponentDefinition.BIMComponent Property Introduced in Inventor 16

AssemblyComponentDefinition.BOM Property Introduced in Inventor 10

AssemblyComponentDefinition.Constraints Property Introduced in Inventor 4

AssemblyComponentDefinition.DefaultMaterial Property Introduced in Inventor 11

AssemblyComponentDefinition.Features Property Introduced in Inventor 10

AssemblyComponentDefinition.iAssemblyFactory Property Introduced in Inventor 11

AssemblyComponentDefinition.iAssemblyMember Property Introduced in Inventor 11

AssemblyComponentDefinition.iMateDefinitions Property Introduced in Inventor 6

AssemblyComponentDefinition.iMateResults Property Introduced in Inventor 6

AssemblyComponentDefinition.IsiAssemblyFactory Property Introduced in Inventor 11

AssemblyComponentDefinition.IsiAssemblyMember Property Introduced in Inventor 11

AssemblyComponentDefinition.MassProperties Property Introduced in Inventor 5

AssemblyComponentDefinition.OccurrencePatterns Property Introduced in Inventor 6

AssemblyComponentDefinition.Parameters Property Introduced in Inventor 4

AssemblyComponentDefinition.Parent Property Introduced in Inventor 4

AssemblyComponentDefinition.RepresentationsManager Property Introduced in Inventor 11

AssemblyComponentDefinition.Sketches Property Introduced in Inventor 11

AssemblyComponentDefinition.UserCoordinateSystems Property Introduced in Inventor 2010

AssemblyComponentDefinition.WorkAxes Property Introduced in Inventor 6

AssemblyComponentDefinition.WorkPlanes Property Introduced in Inventor 6

AssemblyComponentDefinition.WorkPoints Property Introduced in Inventor 6

AssemblyComponentDefinitions Interface Introduced in Inventor 4

AssemblyComponentDefinitions Methods

AssemblyComponentDefinitions.Item Method Introduced in Inventor 4

AssemblyComponentDefinitions Properties

AssemblyComponentDefinitions.Application Property Introduced in Inventor 4

AssemblyComponentDefinitions.Count Property Introduced in Inventor 4

AssemblyComponentDefinitions.Parent Property Introduced in Inventor 4

AssemblyComponentDefinitions.Type Property Introduced in Inventor 4

AssemblyConstraint Interface Introduced in Inventor 4

AssemblyConstraint Methods

AssemblyConstraint.ConvertToAngleConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToCustomConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToFlushConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToInsertConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToMateConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToRotateRotateConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToRotateTranslateConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToTangentConstraint Method Introduced in Inventor 2011

AssemblyConstraint.ConvertToTransitionalConstraint Method Introduced in Inventor 2011

AssemblyConstraint.Delete Method Introduced in Inventor 5

AssemblyConstraint.GetReferenceKey Method Introduced in Inventor 5

AssemblyConstraint Properties

AssemblyConstraint.AffectedOccurrenceOne Property Introduced in Inventor 9

AssemblyConstraint.AffectedOccurrenceTwo Property Introduced in Inventor 9

AssemblyConstraint.Application Property Introduced in Inventor 4

AssemblyConstraint.AttributeSets Property Introduced in Inventor 5

AssemblyConstraint.DriveConstraintSettings Property Introduced in Inventor 2012

AssemblyConstraint.EntityOne Property Introduced in Inventor 6

AssemblyConstraint.EntityTwo Property Introduced in Inventor 6

AssemblyConstraint.GeometryOne Property Introduced in Inventor 4

AssemblyConstraint.GeometryTwo Property Introduced in Inventor 4

AssemblyConstraint.HealthStatus Property Introduced in Inventor 5

AssemblyConstraint.iMateResult Property Introduced in Inventor 6

AssemblyConstraint.LayoutConstraint Property Introduced in Inventor 2010

AssemblyConstraint.Name Property Introduced in Inventor 4

AssemblyConstraint.OccurrenceOne Property Introduced in Inventor 4

AssemblyConstraint.OccurrenceTwo Property Introduced in Inventor 4

AssemblyConstraint.Parent Property Introduced in Inventor 4

AssemblyConstraint.ResultOfiMate Property Introduced in Inventor 6

AssemblyConstraint.ResultOfLayoutConstraint Property Introduced in Inventor 2010

AssemblyConstraint.Suppressed Property Introduced in Inventor 4

AssemblyConstraint.Type Property Introduced in Inventor 4

AssemblyConstraints Interface Introduced in Inventor 4

AssemblyConstraints Methods

AssemblyConstraints.AddAngleConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddCustomConstraint Method

AssemblyConstraints.AddFlushConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddInsertConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddMateConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddRotateRotateConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddRotateTranslateConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddTangentConstraint Method Introduced in Inventor 5

AssemblyConstraints.AddTransitionalConstraint Method Introduced in Inventor 5

AssemblyConstraints.Item Method Introduced in Inventor 4

AssemblyConstraints Properties

AssemblyConstraints.Application Property Introduced in Inventor 4

AssemblyConstraints.Count Property Introduced in Inventor 4

AssemblyConstraints.Parent Property Introduced in Inventor 5

AssemblyConstraints.Type Property Introduced in Inventor 4

AssemblyConstraintsEnumerator Interface Introduced in Inventor 4

AssemblyConstraintsEnumerator Methods

AssemblyConstraintsEnumerator.Item Method Introduced in Inventor 4

AssemblyConstraintsEnumerator Properties

AssemblyConstraintsEnumerator.Count Property Introduced in Inventor 4

AssemblyConstraintsEnumerator.Type Property Introduced in Inventor 4

AssemblyDocument Interface Introduced in Inventor 4

AssemblyDocument Methods

AssemblyDocument.GetSelectedObject Method

AssemblyDocument Properties

AssemblyDocument.ActiveLightingStyle Property Introduced in Inventor 10

AssemblyDocument.ComponentDefinition Property Introduced in Inventor 5

AssemblyDocument.DesignViewInfo Property Introduced in Inventor 8

AssemblyDocument.DisabledCommandList Property Introduced in Inventor 10

AssemblyDocument.DisplaySettings Property Introduced in Inventor 2011

AssemblyDocument.EnvironmentManager Property Introduced in Inventor 10

AssemblyDocument.LevelOfDetailName Property Introduced in Inventor 11

AssemblyDocument.LightingStyles Property Introduced in Inventor 10

AssemblyDocument.Materials Property Introduced in Inventor 8

AssemblyDocument.ModelingSettings Property Introduced in Inventor 8

AssemblyDocument.ObjectVisibility Property Introduced in Inventor 2011

AssemblyDocument.SketchSettings Property Introduced in Inventor 8

AssemblyEvents CoClass Introduced in Inventor 4

AssemblyEventsObject Interface Introduced in Inventor 4

AssemblyEventsObject Properties

AssemblyEventsObject.Application Property Introduced in Inventor 2008

AssemblyEventsObject.Parent Property Introduced in Inventor 2008

AssemblyEventsObject.Type Property Introduced in Inventor 2008

AssemblyEventsSink Interface Introduced in Inventor 4

AssemblyEventsSink Methods

AssemblyEventsSink.OnAssemblyChange Method Introduced in Inventor 11

AssemblyEventsSink.OnAssemblyChanged Method

AssemblyEventsSink.OnDelete Method Introduced in Inventor 11

AssemblyEventsSink.OnNewConstraint Method Introduced in Inventor 2008

AssemblyEventsSink.OnNewOccurrence Method Introduced in Inventor 11

AssemblyEventsSink.OnOccurrenceChange Method Introduced in Inventor 11

AssemblyOptions Interface Introduced in Inventor 8

AssemblyOptions Methods

AssemblyOptions.UseiMate Method Introduced in Inventor 11

AssemblyOptions Properties

AssemblyOptions.Application Property Introduced in Inventor 8

AssemblyOptions.ConstraintAudioNotification Property Introduced in Inventor 11

AssemblyOptions.DeferUpdate Property Introduced in Inventor 11

AssemblyOptions.DeleteComponentPatternSources Property Introduced in Inventor 11

AssemblyOptions.DisplayComponentNamesInConstraints Property Introduced in Inventor 2010

AssemblyOptions.EnableConstraintRedundancyAnalysis Property Introduced in Inventor 11

AssemblyOptions.EnableCrossPartEdgeLoopProjection Property Introduced in Inventor 11

AssemblyOptions.EnableRelatedConstraintFailureAnalysis Property Introduced in Inventor 11

AssemblyOptions.FromToExtentsAdaptFeature Property Introduced in Inventor 11

AssemblyOptions.FromToExtentsMatePlane Property Introduced in Inventor 11

AssemblyOptions.OnlyActiveComponentIsOpaque Property Introduced in Inventor 8

AssemblyOptions.PartFeaturesInitiallyAdaptive Property Introduced in Inventor 11

AssemblyOptions.SectionAllParts Property Introduced in Inventor 11

AssemblyOptions.Type Property Introduced in Inventor 11

AssemblyOptions.UseLastOccurrenceOrientationForPlacement Property Introduced in Inventor 2010

AssemblyOptions.ZoomTargetComponentWithiMate Property Introduced in Inventor 11

AssemblyWorkAxisDef Interface Introduced in Inventor 6

AssemblyWorkAxisDef Methods

AssemblyWorkAxisDef.GetData Method Introduced in Inventor 7

AssemblyWorkAxisDef.PutData Method Introduced in Inventor 7

AssemblyWorkAxisDef Properties

AssemblyWorkAxisDef.Application Property Introduced in Inventor 6

AssemblyWorkAxisDef.Axis Property Introduced in Inventor 7

AssemblyWorkAxisDef.Constraints Property Introduced in Inventor 6

AssemblyWorkAxisDef.OriginPoint Property Introduced in Inventor 7

AssemblyWorkAxisDef.Parent Property Introduced in Inventor 6

AssemblyWorkAxisDef.Type Property Introduced in Inventor 6

AssemblyWorkPlaneDef Interface Introduced in Inventor 6

AssemblyWorkPlaneDef Methods

AssemblyWorkPlaneDef.GetData Method Introduced in Inventor 7

AssemblyWorkPlaneDef.PutData Method Introduced in Inventor 7

AssemblyWorkPlaneDef Properties

AssemblyWorkPlaneDef.Application Property Introduced in Inventor 6

AssemblyWorkPlaneDef.Constraints Property Introduced in Inventor 6

AssemblyWorkPlaneDef.OriginPoint Property Introduced in Inventor 7

AssemblyWorkPlaneDef.Parent Property Introduced in Inventor 6

AssemblyWorkPlaneDef.Type Property Introduced in Inventor 6

AssemblyWorkPlaneDef.XAxis Property Introduced in Inventor 7

AssemblyWorkPlaneDef.YAxis Property Introduced in Inventor 7

AssemblyWorkPointDef Interface Introduced in Inventor 6

AssemblyWorkPointDef Properties

AssemblyWorkPointDef.Application Property Introduced in Inventor 6

AssemblyWorkPointDef.Constraints Property Introduced in Inventor 6

AssemblyWorkPointDef.Parent Property Introduced in Inventor 6

AssemblyWorkPointDef.Point Property Introduced in Inventor 7

AssemblyWorkPointDef.Type Property Introduced in Inventor 6

Attribute Interface Introduced in Inventor 5

Attribute Methods

Attribute.Delete Method Introduced in Inventor 5

Attribute Properties

Attribute.Name Property Introduced in Inventor 5

Attribute.Parent Property Introduced in Inventor 5

Attribute.Type Property Introduced in Inventor 5

Attribute.Value Property Introduced in Inventor 5

Attribute.ValueType Property Introduced in Inventor 5

AttributeManager Interface Introduced in Inventor 5

AttributeManager Methods

AttributeManager.FindAttributes Method Introduced in Inventor 5

AttributeManager.FindAttributeSets Method Introduced in Inventor 5

AttributeManager.FindObjects Method Introduced in Inventor 5

AttributeManager.FindObjectsByPattern Method Introduced in Inventor 5

AttributeManager.OpenAttributeSets Method Introduced in Inventor 5.3

AttributeManager.PurgeAttributeSets Method Introduced in Inventor 5

AttributeManager Properties

AttributeManager.Parent Property Introduced in Inventor 5

AttributeManager.RevisionId Property Introduced in Inventor 10

AttributeManager.Type Property Introduced in Inventor 5

AttributesEnumerator Interface Introduced in Inventor 5

AttributesEnumerator Methods

AttributesEnumerator.Item Method Introduced in Inventor 5

AttributesEnumerator Properties

AttributesEnumerator.Count Property Introduced in Inventor 5

AttributesEnumerator.Type Property Introduced in Inventor 5

AttributeSet Interface Introduced in Inventor 5

AttributeSet Methods

AttributeSet.Add Method Introduced in Inventor 5

AttributeSet.AddAttributes Method Introduced in Inventor 11

AttributeSet.CopyTo Method Introduced in Inventor 11

AttributeSet.Delete Method Introduced in Inventor 5

AttributeSet.GetReferenceKey Method Introduced in Inventor 5

AttributeSet.Item Method Introduced in Inventor 5

AttributeSet.NameIsUsed Method Introduced in Inventor 5

AttributeSet Properties

AttributeSet.Copy Property Introduced in Inventor 5

AttributeSet.CopyWithOwner Property Introduced in Inventor 10

AttributeSet.Count Property Introduced in Inventor 5

AttributeSet.DataIO Property Introduced in Inventor 5

AttributeSet.Name Property Introduced in Inventor 5

AttributeSet.Parent Property Introduced in Inventor 5

AttributeSet.Transient Property Introduced in Inventor 9

AttributeSet.Type Property Introduced in Inventor 5

AttributeSets Interface Introduced in Inventor 5

AttributeSets Methods

AttributeSets.Add Method Introduced in Inventor 5

AttributeSets.AddTransient Method Introduced in Inventor 9

AttributeSets.Item Method Introduced in Inventor 5

AttributeSets.NameIsUsed Method Introduced in Inventor 5

AttributeSets.ParentAvailable Method Introduced in Inventor 11

AttributeSets Properties

AttributeSets.Count Property Introduced in Inventor 5

AttributeSets.DataIO Property Introduced in Inventor 5

AttributeSets.Parent Property Introduced in Inventor 5

AttributeSets.Type Property Introduced in Inventor 5

AttributeSetsEnumerator Interface Introduced in Inventor 5

AttributeSetsEnumerator Methods

AttributeSetsEnumerator.Item Method Introduced in Inventor 5

AttributeSetsEnumerator Properties

AttributeSetsEnumerator.Count Property Introduced in Inventor 5

AttributeSetsEnumerator.Type Property Introduced in Inventor 5

AutoCADBlock Interface Introduced in Inventor 2011

AutoCADBlock Methods

AutoCADBlock.Delete Method

AutoCADBlock.GetCustomLineType Method

AutoCADBlock.GetPromptTextValues Method

AutoCADBlock.GetReferenceKey Method

AutoCADBlock.SetCustomLineType Method

AutoCADBlock.SetPromptTextValues Method

AutoCADBlock Properties

AutoCADBlock.Application Property

AutoCADBlock.AttributeSets Property

AutoCADBlock.Color Property

AutoCADBlock.Definition Property

AutoCADBlock.Layer Property

AutoCADBlock.LineType Property

AutoCADBlock.LineWeight Property

AutoCADBlock.Name Property

AutoCADBlock.Parent Property

AutoCADBlock.Position Property

AutoCADBlock.Rotation Property

AutoCADBlock.Scale Property

AutoCADBlock.Static Property

AutoCADBlock.Transformation Property

AutoCADBlock.Type Property

AutoCADBlockDefinition Interface Introduced in Inventor 2011

AutoCADBlockDefinition Methods

AutoCADBlockDefinition.CopyTo Method

AutoCADBlockDefinition.Delete Method

AutoCADBlockDefinition.GetPromptTags Method

AutoCADBlockDefinition.GetReferenceKey Method

AutoCADBlockDefinition Properties

AutoCADBlockDefinition.Application Property

AutoCADBlockDefinition.AttributeSets Property

AutoCADBlockDefinition.IsReferenced Property

AutoCADBlockDefinition.Name Property

AutoCADBlockDefinition.Parent Property

AutoCADBlockDefinition.Type Property

AutoCADBlockDefinitions Interface Introduced in Inventor 2011

AutoCADBlockDefinitions Methods

AutoCADBlockDefinitions.AddFromFile Method

AutoCADBlockDefinitions.Item Method

AutoCADBlockDefinitions Properties

AutoCADBlockDefinitions.Application Property

AutoCADBlockDefinitions.Count Property

AutoCADBlockDefinitions.Type Property

AutoCADBlockDefinitionsEnumerator Interface Introduced in Inventor 2011

AutoCADBlockDefinitionsEnumerator Methods

AutoCADBlockDefinitionsEnumerator.Item Method

AutoCADBlockDefinitionsEnumerator Properties

AutoCADBlockDefinitionsEnumerator.Application Property

AutoCADBlockDefinitionsEnumerator.Count Property

AutoCADBlockDefinitionsEnumerator.Type Property

AutoCADBlocks Interface Introduced in Inventor 2011

AutoCADBlocks Methods

AutoCADBlocks.Add Method

AutoCADBlocks.Item Method

AutoCADBlocks Properties

AutoCADBlocks.Application Property

AutoCADBlocks.Count Property

AutoCADBlocks.Type Property

AutomatedCenterlineSettings Interface Introduced in Inventor 2010

AutomatedCenterlineSettings Properties

AutomatedCenterlineSettings.Application Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToBends Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToCircularPatterns Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToCylinders Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToFillets Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToHoles Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToPunches Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToRectangularPatterns Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToRevolutions Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToSketches Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ApplyToWorkFeatures Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ArcAngleThreshold Property Introduced in Inventor 2010

AutomatedCenterlineSettings.CircularEdgeMaximumThreshold Property Introduced in Inventor 2010

AutomatedCenterlineSettings.CircularEdgeMinimumThreshold Property Introduced in Inventor 2010

AutomatedCenterlineSettings.FilletRadiusMaximumThreshold Property Introduced in Inventor 2010

AutomatedCenterlineSettings.FilletRadiusMinimumThreshold Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ProjectionNormalAxis Property Introduced in Inventor 2010

AutomatedCenterlineSettings.ProjectionParallelAxis Property Introduced in Inventor 2010

AutomatedCenterlineSettings.RadiusThresholdPrecision Property Introduced in Inventor 2010

AutomatedCenterlineSettings.Type Property Introduced in Inventor 2010

Balloon Interface Introduced in Inventor 9

Balloon Methods

Balloon.Delete Method Introduced in Inventor 9

Balloon.GetBalloonType Method Introduced in Inventor 9

Balloon.GetReferenceKey Method Introduced in Inventor 2009

Balloon.SaveItemOverridesToBOM Method Introduced in Inventor 2010

Balloon.SetBalloonType Method Introduced in Inventor 9

Balloon Properties

Balloon.Application Property Introduced in Inventor 9

Balloon.Attached Property Introduced in Inventor 2009

Balloon.AttributeSets Property Introduced in Inventor 2009

Balloon.BalloonValueSets Property Introduced in Inventor 9

Balloon.Layer Property Introduced in Inventor 10

Balloon.Leader Property Introduced in Inventor 2009

Balloon.Parent Property Introduced in Inventor 9

Balloon.ParentView Property Introduced in Inventor 9

Balloon.PlacementDirection Property Introduced in Inventor 9

Balloon.Position Property Introduced in Inventor 9

Balloon.Style Property Introduced in Inventor 2009

Balloon.Type Property Introduced in Inventor 9

Balloons Interface Introduced in Inventor 9

Balloons Methods

Balloons.Add Method Introduced in Inventor 2009

Balloons.Item Method Introduced in Inventor 9

Balloons Properties

Balloons.Application Property Introduced in Inventor 9

Balloons.Count Property Introduced in Inventor 9

Balloons.Type Property Introduced in Inventor 9

BalloonStyle Interface Introduced in Inventor 2009

BalloonStyle Properties

BalloonStyle.AlternateLeaderStyle Property Introduced in Inventor 2009

BalloonStyle.BalloonDiameter Property Introduced in Inventor 2009

BalloonStyle.BalloonType Property Introduced in Inventor 2009

BalloonStyle.DefaultOffset Property Introduced in Inventor 2009

BalloonStyle.LeaderStyle Property Introduced in Inventor 2009

BalloonStyle.Properties Property Introduced in Inventor 2009

BalloonStyle.ScaleToTextHeight Property Introduced in Inventor 2009

BalloonStyle.StretchBalloonToText Property Introduced in Inventor 2009

BalloonStyle.TextStyle Property Introduced in Inventor 2009

BalloonStylesEnumerator Interface Introduced in Inventor 2009

BalloonStylesEnumerator Methods

BalloonStylesEnumerator.Item Method Introduced in Inventor 2009

BalloonStylesEnumerator Properties

BalloonStylesEnumerator.Application Property Introduced in Inventor 2009

BalloonStylesEnumerator.Count Property Introduced in Inventor 2009

BalloonStylesEnumerator.Type Property Introduced in Inventor 2009

BalloonTipObject Interface Introduced in Inventor 2012

BalloonTipObject Methods

BalloonTipObject.Delete Method Introduced in Inventor 16

BalloonTipObject.Display Method Introduced in Inventor 16

BalloonTipObject Properties

BalloonTipObject.Application Property Introduced in Inventor 16

BalloonTipObject.ClientData Property Introduced in Inventor 16

BalloonTipObject.Enabled Property Introduced in Inventor 16

BalloonTipObject.InternalName Property Introduced in Inventor 16

BalloonTipObject.Interval Property Introduced in Inventor 16

BalloonTipObject.Message Property Introduced in Inventor 16

BalloonTipObject.Parent Property Introduced in Inventor 16

BalloonTipObject.Type Property Introduced in Inventor 16

BalloonTips Interface Introduced in Inventor 2012

BalloonTips Methods

BalloonTips.Add Method Introduced in Inventor 16

BalloonTips.Item Method Introduced in Inventor 16

BalloonTips Properties

BalloonTips.Application Property

BalloonTips.Count Property

BalloonTips.Type Property

BalloonTipSink Interface

BalloonTipSink Methods

BalloonTipSink.OnClick Method Introduced in Inventor 2012

BalloonTipSink.OnDisplay Method Introduced in Inventor 2012

BalloonValueSet Interface Introduced in Inventor 9

BalloonValueSet Methods

BalloonValueSet.Delete Method Introduced in Inventor 9

BalloonValueSet.ReferencedFiles Method

BalloonValueSet Properties

BalloonValueSet.Application Property Introduced in Inventor 9

BalloonValueSet.ItemNumber Property Introduced in Inventor 2011

BalloonValueSet.OverrideValue Property Introduced in Inventor 9

BalloonValueSet.Parent Property Introduced in Inventor 9

BalloonValueSet.ReferencedRow Property Introduced in Inventor 2009

BalloonValueSet.Static Property Introduced in Inventor 2010

BalloonValueSet.Type Property Introduced in Inventor 9

BalloonValueSet.Value Property Introduced in Inventor 9

BalloonValueSets Interface Introduced in Inventor 9

BalloonValueSets Methods

BalloonValueSets.Add Method Introduced in Inventor 2009

BalloonValueSets.Item Method Introduced in Inventor 9

BalloonValueSets Properties

BalloonValueSets.Application Property Introduced in Inventor 9

BalloonValueSets.Count Property Introduced in Inventor 9

BalloonValueSets.Type Property Introduced in Inventor 9

BaselineDimensionSet Interface Introduced in Inventor 2010

BaselineDimensionSet Methods

BaselineDimensionSet.AddMember Method Introduced in Inventor 2010

BaselineDimensionSet.ArrangeText Method Introduced in Inventor 2010

BaselineDimensionSet.Delete Method Introduced in Inventor 2010

BaselineDimensionSet.DetachMember Method Introduced in Inventor 2010

BaselineDimensionSet.GetReferenceKey Method Introduced in Inventor 2010

BaselineDimensionSet Properties

BaselineDimensionSet.Application Property Introduced in Inventor 2010

BaselineDimensionSet.AttributeSets Property Introduced in Inventor 2010

BaselineDimensionSet.DimensionType Property Introduced in Inventor 2010

BaselineDimensionSet.Layer Property Introduced in Inventor 2010

BaselineDimensionSet.Members Property Introduced in Inventor 2010

BaselineDimensionSet.Origin Property Introduced in Inventor 2010

BaselineDimensionSet.Parent Property Introduced in Inventor 2010

BaselineDimensionSet.Precision Property Introduced in Inventor 2010

BaselineDimensionSet.Style Property Introduced in Inventor 2010

BaselineDimensionSet.Type Property Introduced in Inventor 2010

BaselineDimensionSets Interface Introduced in Inventor 2010

BaselineDimensionSets Methods

BaselineDimensionSets.Add Method Introduced in Inventor 2010

BaselineDimensionSets.Item Method Introduced in Inventor 2010

BaselineDimensionSets Properties

BaselineDimensionSets.Application Property Introduced in Inventor 2010

BaselineDimensionSets.Count Property Introduced in Inventor 2010

BaselineDimensionSets.Type Property Introduced in Inventor 2010

Bend Interface Introduced in Inventor 2010

Bend Properties

Bend.Application Property Introduced in Inventor 2010

Bend.BackFaces Property Introduced in Inventor 2010

Bend.FrontFaces Property Introduced in Inventor 2010

Bend.IsFlat Property Introduced in Inventor 2010

Bend.Parent Property Introduced in Inventor 2010

Bend.Type Property Introduced in Inventor 2010

BendConstraint Interface Introduced in Inventor 6

BendConstraint Properties

BendConstraint.Arc Property Introduced in Inventor 6

BendConstraint.LineOne Property Introduced in Inventor 6

BendConstraint.LineTwo Property Introduced in Inventor 6

BendConstraint.Radius Property Introduced in Inventor 6

BendConstraintProxy Interface Introduced in Inventor 6

BendConstraintProxy Properties

BendConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

BendConstraintProxy.NativeObject Property Introduced in Inventor 6

BendDefinition Interface Introduced in Inventor 2009

BendDefinition Methods

BendDefinition.Copy Method Introduced in Inventor 2010

BendDefinition Properties

BendDefinition.Application Property Introduced in Inventor 2009

BendDefinition.BendOptions Property Introduced in Inventor 2009

BendDefinition.BendRadius Property Introduced in Inventor 2009

BendDefinition.DoubleBendType Property Introduced in Inventor 2009

BendDefinition.Edges Property Introduced in Inventor 2009

BendDefinition.ExtendFaces Property Introduced in Inventor 2009

BendDefinition.IsDoubleBendFirstEdgeFixed Property Introduced in Inventor 2009

BendDefinition.IsUnfoldMethodOverridden Property Introduced in Inventor 2011

BendDefinition.Parent Property Introduced in Inventor 2009

BendDefinition.Type Property Introduced in Inventor 2009

BendDefinition.UnfoldMethod Property Introduced in Inventor 2009

BendFeature Interface Introduced in Inventor 5.3

BendFeature Properties

BendFeature.Definition Property Introduced in Inventor 2009

BendFeatureProxy Interface Introduced in Inventor 9

BendFeatures Interface Introduced in Inventor 5.3

BendFeatures Methods

BendFeatures.Add Method Introduced in Inventor 2010

BendFeatures.CreateBendDefinition Method Introduced in Inventor 2010

BendFeatures.Item Method Introduced in Inventor 5.3

BendFeatures Properties

BendFeatures.Application Property Introduced in Inventor 5.3

BendFeatures.Count Property Introduced in Inventor 5.3

BendFeatures.Type Property Introduced in Inventor 5.3

BendNote Interface Introduced in Inventor 2010

BendNote Properties

BendNote.BendEdge Property Introduced in Inventor 2010

BendNote.FormattedBendNote Property Introduced in Inventor 2010

BendNote.HideValue Property Introduced in Inventor 2010

BendNote.UsePartUnits Property Introduced in Inventor 2010

BendNotes Interface Introduced in Inventor 2010

BendNotes Methods

BendNotes.Add Method Introduced in Inventor 2010

BendNotes.Item Method Introduced in Inventor 2010

BendNotes Properties

BendNotes.Application Property Introduced in Inventor 2010

BendNotes.Count Property Introduced in Inventor 2010

BendNotes.Type Property Introduced in Inventor 2010

BendOptions Interface Introduced in Inventor 2009

BendOptions Methods

BendOptions.Copy Method Introduced in Inventor 2010

BendOptions Properties

BendOptions.BendReliefDepth Property Introduced in Inventor 2009

BendOptions.BendReliefShape Property Introduced in Inventor 2009

BendOptions.BendReliefWidth Property Introduced in Inventor 2009

BendOptions.BendTransition Property Introduced in Inventor 2009

BendOptions.BendTransitionArcRadius Property Introduced in Inventor 2009

BendOptions.MinimumRemnant Property Introduced in Inventor 2009

BendOptions.Parent Property Introduced in Inventor 2009

BendOptions.Type Property Introduced in Inventor 2009

BendPartFeature Interface Introduced in Inventor 2008

BendPartFeature Methods

BendPartFeature.Edit Method Introduced in Inventor 2010

BendPartFeature Properties

BendPartFeature.BendInSketchNormalDirection Property Introduced in Inventor 2010

BendPartFeature.BendLine Property Introduced in Inventor 2010

BendPartFeature.BendMinimum Property Introduced in Inventor 2010

BendPartFeature.BendPartType Property Introduced in Inventor 2010

BendPartFeature.BendSide Property Introduced in Inventor 2010

BendPartFeature.InputOne Property Introduced in Inventor 2010

BendPartFeature.InputTwo Property Introduced in Inventor 2010

BendPartFeatureProxy Interface Introduced in Inventor 2008

BendPartFeatureProxy Properties

BendPartFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2008

BendPartFeatureProxy.NativeObject Property Introduced in Inventor 2008

BendPartFeatures Interface Introduced in Inventor 2008

BendPartFeatures Methods

BendPartFeatures.Add Method Introduced in Inventor 2010

BendPartFeatures.Item Method Introduced in Inventor 2008

BendPartFeatures Properties

BendPartFeatures.Application Property Introduced in Inventor 2008

BendPartFeatures.Count Property Introduced in Inventor 2008

BendPartFeatures.Type Property Introduced in Inventor 2008

BendsEnumerator Interface Introduced in Inventor 2010

BendsEnumerator Methods

BendsEnumerator.Item Method Introduced in Inventor 2010

BendsEnumerator Properties

BendsEnumerator.Application Property Introduced in Inventor 2010

BendsEnumerator.Count Property Introduced in Inventor 2010

BendsEnumerator.Type Property Introduced in Inventor 2010

BIMCableTrayConnectorDefinition Interface Introduced in Inventor 2012

BIMCableTrayConnectorDefinition Properties

BIMCableTrayConnectorDefinition.ConnectionType Property Introduced in Inventor 2012

BIMCableTrayConnectorDefinition.Height Property Introduced in Inventor 2012

BIMCableTrayConnectorDefinition.HeightOverride Property Introduced in Inventor 2012

BIMCableTrayConnectorDefinition.Width Property Introduced in Inventor 2012

BIMCableTrayConnectorDefinition.WidthOverride Property Introduced in Inventor 2012

BIMComponent Interface Introduced in Inventor 16

BIMComponent Methods

BIMComponent.ExportBuildingComponent Method

BIMComponent Properties

BIMComponent.Application Property

BIMComponent.ComponentDefinition Property

BIMComponent.ComponentDescription Property

BIMComponent.ConnectorLinks Property

BIMComponent.Connectors Property

BIMComponent.Type Property

BIMComponentDescription Interface Introduced in Inventor 16

BIMComponentDescription Methods

BIMComponentDescription.SetCustomThumbnail Method

BIMComponentDescription Properties

BIMComponentDescription.Application Property

BIMComponentDescription.ComponentPropertySets Property

BIMComponentDescription.ComponentType Property

BIMComponentDescription.ModelProperties Property

BIMComponentDescription.Orientation Property

BIMComponentDescription.Thumbnail Property

BIMComponentDescription.Type Property

BIMComponentProperty Interface Introduced in Inventor 2012

BIMComponentProperty Properties

BIMComponentProperty.Application Property Introduced in Inventor 2012

BIMComponentProperty.InternalName Property Introduced in Inventor 2012

BIMComponentProperty.Name Property Introduced in Inventor 2012

BIMComponentProperty.Parent Property Introduced in Inventor 2012

BIMComponentProperty.Type Property Introduced in Inventor 2012

BIMComponentProperty.Value Property Introduced in Inventor 2012

BIMComponentPropertySet Interface Introduced in Inventor 2012

BIMComponentPropertySet Properties

BIMComponentPropertySet.Application Property Introduced in Inventor 2012

BIMComponentPropertySet.Count Property Introduced in Inventor 2012

BIMComponentPropertySet.InternalName Property Introduced in Inventor 2012

BIMComponentPropertySet.Name Property Introduced in Inventor 2012

BIMComponentPropertySet.Parent Property Introduced in Inventor 2012

BIMComponentPropertySet.Type Property Introduced in Inventor 2012

BIMComponentPropertySets Interface Introduced in Inventor 2012

BIMComponentPropertySets Properties

BIMComponentPropertySets.Application Property Introduced in Inventor 2012

BIMComponentPropertySets.Count Property Introduced in Inventor 2012

BIMComponentPropertySets.Type Property Introduced in Inventor 2012

BIMConduitConnectorDefinition Interface Introduced in Inventor 2012

BIMConduitConnectorDefinition Properties

BIMConduitConnectorDefinition.ConnectionType Property Introduced in Inventor 2012

BIMConduitConnectorDefinition.Diameter Property Introduced in Inventor 2012

BIMConduitConnectorDefinition.DiameterOverride Property Introduced in Inventor 2012

BIMConnector Interface Introduced in Inventor 2012

BIMConnector Methods

BIMConnector.Delete Method Introduced in Inventor 2012

BIMConnector.GetReferenceKey Method

BIMConnector Properties

BIMConnector.Application Property Introduced in Inventor 2012

BIMConnector.Definition Property Introduced in Inventor 2012

BIMConnector.DefinitionType Property Introduced in Inventor 2012

BIMConnector.Name Property Introduced in Inventor 2012

BIMConnector.Parent Property Introduced in Inventor 2012

BIMConnector.Suppressed Property Introduced in Inventor 2012

BIMConnector.Type Property Introduced in Inventor 2012

BIMConnectorDefinition Interface Introduced in Inventor 2012

BIMConnectorDefinition Methods

BIMConnectorDefinition.ReverseDirection Method Introduced in Inventor 2012

BIMConnectorDefinition.SetShape Method Introduced in Inventor 2012

BIMConnectorDefinition Properties

BIMConnectorDefinition.Application Property Introduced in Inventor 2012

BIMConnectorDefinition.ConnectorShape Property Introduced in Inventor 2012

BIMConnectorDefinition.Direction Property Introduced in Inventor 2012

BIMConnectorDefinition.Geometry Property Introduced in Inventor 2012

BIMConnectorDefinition.Parent Property Introduced in Inventor 2012

BIMConnectorDefinition.Type Property Introduced in Inventor 2012

BIMConnectorLink Interface Introduced in Inventor 2012

BIMConnectorLink Methods

BIMConnectorLink.Delete Method Introduced in Inventor 2012

BIMConnectorLink.GetReferenceKey Method Introduced in Inventor 2012

BIMConnectorLink Properties

BIMConnectorLink.Application Property Introduced in Inventor 2012

BIMConnectorLink.ConnectorOne Property Introduced in Inventor 2012

BIMConnectorLink.ConnectorTwo Property Introduced in Inventor 2012

BIMConnectorLink.Name Property Introduced in Inventor 2012

BIMConnectorLink.Type Property Introduced in Inventor 2012

BIMConnectorLinks Interface Introduced in Inventor 2012

BIMConnectorLinks Methods

BIMConnectorLinks.Add Method Introduced in Inventor 2012

BIMConnectorLinks Properties

BIMConnectorLinks.Application Property Introduced in Inventor 2012

BIMConnectorLinks.Count Property Introduced in Inventor 2012

BIMConnectorLinks.Item Method Introduced in Inventor 2012

BIMConnectorLinks.Type Property Introduced in Inventor 2012

BIMConnectors Interface Introduced in Inventor 2012

BIMConnectors Methods

BIMConnectors.Add Method Introduced in Inventor 2012

BIMConnectors.CreateCableTrayConnectorDefinition Method Introduced in Inventor 2012

BIMConnectors.CreateConduitConnectorDefinition Method Introduced in Inventor 2012

BIMConnectors.CreateDuctConnectorDefinition Method Introduced in Inventor 2012

BIMConnectors.CreateElectricalConnectorDefinition Method Introduced in Inventor 2012

BIMConnectors.CreatePipeConnectorDefinition Method Introduced in Inventor 2012

BIMConnectors Properties

BIMConnectors.Application Property Introduced in Inventor 2012

BIMConnectors.Count Property Introduced in Inventor 2012

BIMConnectors.Item Method Introduced in Inventor 2012

BIMConnectors.Type Property Introduced in Inventor 2012

BIMDuctConnectorDefinition Interface Introduced in Inventor 2012

BIMDuctConnectorDefinition Properties

BIMDuctConnectorDefinition.ConnectionType Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.Description Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.Diameter Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.DiameterOverride Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.FlowConfiguration Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.FlowDirection Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.FlowValue Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.Height Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.HeightOverride Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.LossMethod Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.LossValue Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.SystemType Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.Width Property Introduced in Inventor 2012

BIMDuctConnectorDefinition.WidthOverride Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition Interface Introduced in Inventor 2012

BIMElectricalConnectorDefinition Properties

BIMElectricalConnectorDefinition.ApparentLoad Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.ApparentLoadPhase1 Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.ApparentLoadPhase2 Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.ApparentLoadPhase3 Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.Description Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.HasMotor Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.LoadClassification Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.NumberOfPoles Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.PowerFactor Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.PowerFactorState Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.SystemType Property Introduced in Inventor 2012

BIMElectricalConnectorDefinition.Voltage Property Introduced in Inventor 2012

BIMExchangeServer Interface Introduced in Inventor 2012

BIMExchangeServer Methods

BIMExchangeServer.GetBIMComponent Method

BIMPipeConnectorDefinition Interface Introduced in Inventor 2012

BIMPipeConnectorDefinition Properties

BIMPipeConnectorDefinition.AllowSlopeAdjustment Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.ConnectionType Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.Description Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.Diameter Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.DiameterOverride Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.FlowConfiguration Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.FlowDirection Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.FlowValue Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.LossMethod Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.LossValue Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.NominalDiameter Property Introduced in Inventor 2012

BIMPipeConnectorDefinition.SystemType Property Introduced in Inventor 2012

BOM Interface Introduced in Inventor 10

BOM Methods

BOM.GetPartNumberMergeSettings Method Introduced in Inventor 11

BOM.SetPartNumberMergeSettings Method Introduced in Inventor 11

BOM Properties

BOM.Application Property Introduced in Inventor 10

BOM.BOMViews Property Introduced in Inventor 10

BOM.Parent Property Introduced in Inventor 10

BOM.PartsOnlyViewEnabled Property Introduced in Inventor 10

BOM.PartsOnlyViewMinimumDigits Property Introduced in Inventor 11

BOM.PartsOnlyViewNumberingScheme Property Introduced in Inventor 11

BOM.RequiresUpdate Property Introduced in Inventor 10

BOM.RevisionId Property Introduced in Inventor 10

BOM.StructuredViewDelimiter Property Introduced in Inventor 11

BOM.StructuredViewEnabled Property Introduced in Inventor 11

BOM.StructuredViewFirstLevelOnly Property Introduced in Inventor 11

BOM.StructuredViewMinimumDigits Property Introduced in Inventor 11

BOM.Type Property Introduced in Inventor 10

BOMQuantity Interface Introduced in Inventor 10

BOMQuantity Methods

BOMQuantity.GetBaseQuantity Method Introduced in Inventor 10

BOMQuantity.GetEvaluatedBaseQuantity Method Introduced in Inventor 11

BOMQuantity.SetBaseQuantity Method Introduced in Inventor 10

BOMQuantity Properties

BOMQuantity.Application Property Introduced in Inventor 10

BOMQuantity.BaseUnits Property Introduced in Inventor 10

BOMQuantity.Parent Property Introduced in Inventor 10

BOMQuantity.Type Property Introduced in Inventor 10

BOMQuantity.UnitQuantity Property Introduced in Inventor 10

BOMRow Interface Introduced in Inventor 10

BOMRow Methods

BOMRow.GetReferenceKey Method Introduced in Inventor 2009

BOMRow Properties

BOMRow.Application Property Introduced in Inventor 10

BOMRow.AttributeSets Property Introduced in Inventor 2009

BOMRow.BOMStructure Property Introduced in Inventor 10

BOMRow.ChildRows Property Introduced in Inventor 11

BOMRow.ComponentDefinitions Property Introduced in Inventor 10

BOMRow.ItemNumber Property Introduced in Inventor 10

BOMRow.ItemNumberLocked Property Introduced in Inventor 11

BOMRow.ItemQuantity Property Introduced in Inventor 10

BOMRow.Merged Property Introduced in Inventor 10

BOMRow.Parent Property Introduced in Inventor 10

BOMRow.Promoted Property Introduced in Inventor 10

BOMRow.ReferencedFileDescriptor Property Introduced in Inventor 2008

BOMRow.RolledUp Property Introduced in Inventor 10

BOMRow.TotalQuantity Property Introduced in Inventor 10

BOMRow.TotalQuantityOverridden Property Introduced in Inventor 10

BOMRow.Type Property Introduced in Inventor 10

BOMRowsEnumerator Interface Introduced in Inventor 11

BOMRowsEnumerator Methods

BOMRowsEnumerator.Item Method Introduced in Inventor 11

BOMRowsEnumerator Properties

BOMRowsEnumerator.Application Property Introduced in Inventor 11

BOMRowsEnumerator.Count Property Introduced in Inventor 11

BOMRowsEnumerator.Type Property Introduced in Inventor 11

BOMView Interface Introduced in Inventor 10

BOMView Methods

BOMView.Export Method Introduced in Inventor 2009

BOMView.Renumber Method Introduced in Inventor 2011

BOMView.Sort Method Introduced in Inventor 2011

BOMView Properties

BOMView.Application Property Introduced in Inventor 10

BOMView.BOMRows Property Introduced in Inventor 10

BOMView.iAssemblyMemberName Property Introduced in Inventor 2009

BOMView.Name Property Introduced in Inventor 10

BOMView.Parent Property Introduced in Inventor 10

BOMView.RevisionId Property Introduced in Inventor 10

BOMView.Type Property Introduced in Inventor 10

BOMView.ViewType Property Introduced in Inventor 11

BOMViews Interface Introduced in Inventor 10

BOMViews Methods

BOMViews.Item Method Introduced in Inventor 10

BOMViews Properties

BOMViews.Application Property Introduced in Inventor 10

BOMViews.Count Property Introduced in Inventor 10

BOMViews.Type Property Introduced in Inventor 10

Border Interface Introduced in Inventor 5.3

Border Methods

Border.Delete Method Introduced in Inventor 5.3

Border.GetResultText Method Introduced in Inventor 5.3

Border.SetPromptResultText Method Introduced in Inventor 5.3

Border Properties

Border.Application Property Introduced in Inventor 5.3

Border.Definition Property Introduced in Inventor 5.3

Border.Name Property Introduced in Inventor 2009

Border.Parent Property Introduced in Inventor 5.3

Border.RangeBox Property Introduced in Inventor 11

Border.Type Property Introduced in Inventor 5.3

BorderDefinition Interface Introduced in Inventor 5.3

BorderDefinition Methods

BorderDefinition.CopyTo Method Introduced in Inventor 10

BorderDefinition.Delete Method Introduced in Inventor 5.3

BorderDefinition.Edit Method Introduced in Inventor 5.3

BorderDefinition.ExitEdit Method Introduced in Inventor 5.3

BorderDefinition.GetReferenceKey Method Introduced in Inventor 2008

BorderDefinition Properties

BorderDefinition.Application Property Introduced in Inventor 5.3

BorderDefinition.AttributeSets Property Introduced in Inventor 2008

BorderDefinition.IsDefault Property Introduced in Inventor 11

BorderDefinition.IsReferenced Property Introduced in Inventor 5.3

BorderDefinition.Name Property Introduced in Inventor 5.3

BorderDefinition.Parent Property Introduced in Inventor 5.3

BorderDefinition.Sketch Property Introduced in Inventor 5.3

BorderDefinition.Type Property Introduced in Inventor 5.3

BorderDefinitions Interface Introduced in Inventor 5.3

BorderDefinitions Methods

BorderDefinitions.Add Method Introduced in Inventor 5.3

BorderDefinitions.Item Method Introduced in Inventor 5.3

BorderDefinitions Properties

BorderDefinitions.Application Property Introduced in Inventor 5.3

BorderDefinitions.Count Property Introduced in Inventor 5.3

BorderDefinitions.Type Property Introduced in Inventor 5.3

BossFeature Interface Introduced in Inventor 2010

BossFeatureProxy Interface Introduced in Inventor 2010

BossFeatureProxy Properties

BossFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

BossFeatureProxy.NativeObject Property Introduced in Inventor 2010

BossFeatures Interface Introduced in Inventor 2010

BossFeatures Methods

BossFeatures.Item Method Introduced in Inventor 2010

BossFeatures Properties

BossFeatures.Application Property Introduced in Inventor 2010

BossFeatures.Count Property Introduced in Inventor 2010

BossFeatures.Type Property Introduced in Inventor 2010

BossSet Interface Introduced in Inventor 2012

BossSet Methods

BossSet.Delete Method Introduced in Inventor 2012

BossSet Properties

BossSet.Application Property Introduced in Inventor 2012

BossSet.Centers Property Introduced in Inventor 2012

BossSet.Diameter Property Introduced in Inventor 2012

BossSet.Offset Property Introduced in Inventor 2012

BossSet.Parent Property Introduced in Inventor 2012

BossSet.TaperAngle Property Introduced in Inventor 2012

BossSet.Type Property Introduced in Inventor 2012

BossSets Interface Introduced in Inventor 2012

BossSets Methods

BossSets.Add Method Introduced in Inventor 2012

BossSets.Item Method Introduced in Inventor 2012

BossSets Properties

BossSets._NewEnum Property

BossSets.Application Property Introduced in Inventor 2012

BossSets.Count Property Introduced in Inventor 2012

BossSets.Type Property Introduced in Inventor 2012

BoundaryPatchDefinition Interface Introduced in Inventor 2008

BoundaryPatchDefinition Properties

BoundaryPatchDefinition.Application Property Introduced in Inventor 2008

BoundaryPatchDefinition.BoundaryPatchLoops Property Introduced in Inventor 2008

BoundaryPatchDefinition.Type Property Introduced in Inventor 2008

BoundaryPatchFeature Interface Introduced in Inventor 9

BoundaryPatchFeature Properties

BoundaryPatchFeature.Definition Property Introduced in Inventor 2008

BoundaryPatchFeatureProxy Interface Introduced in Inventor 9

BoundaryPatchFeatureProxy Properties

BoundaryPatchFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

BoundaryPatchFeatureProxy.NativeObject Property Introduced in Inventor 9

BoundaryPatchFeatures Interface Introduced in Inventor 9

BoundaryPatchFeatures Methods

BoundaryPatchFeatures.Add Method Introduced in Inventor 2008

BoundaryPatchFeatures.CreateBoundaryPatchDefinition Method Introduced in Inventor 2008

BoundaryPatchFeatures.Item Method Introduced in Inventor 9

BoundaryPatchFeatures Properties

BoundaryPatchFeatures.Application Property Introduced in Inventor 9

BoundaryPatchFeatures.Count Property Introduced in Inventor 9

BoundaryPatchFeatures.Type Property Introduced in Inventor 9

BoundaryPatchLoop Interface Introduced in Inventor 2008

BoundaryPatchLoop Methods

BoundaryPatchLoop.Delete Method Introduced in Inventor 2008

BoundaryPatchLoop.GetBoundaryCondition Method Introduced in Inventor 2008

BoundaryPatchLoop.SetBoundaryCondition Method Introduced in Inventor 2008

BoundaryPatchLoop Properties

BoundaryPatchLoop.Application Property Introduced in Inventor 2008

BoundaryPatchLoop.BoundaryPath Property Introduced in Inventor 2008

BoundaryPatchLoop.Type Property Introduced in Inventor 2008

BoundaryPatchLoops Interface Introduced in Inventor 2008

BoundaryPatchLoops Methods

BoundaryPatchLoops.Add Method Introduced in Inventor 2008

BoundaryPatchLoops.Item Method Introduced in Inventor 2008

BoundaryPatchLoops Properties

BoundaryPatchLoops.Application Property Introduced in Inventor 2008

BoundaryPatchLoops.Count Property Introduced in Inventor 2008

BoundaryPatchLoops.Type Property Introduced in Inventor 2008

Box Interface Introduced in Inventor 4

Box Methods

Box.Contains Method Introduced in Inventor 4

Box.Expand Method Introduced in Inventor 4

Box.Extend Method Introduced in Inventor 4

Box.GetBoxData Method Introduced in Inventor 4

Box.IsDisjoint Method Introduced in Inventor 4

Box.PutBoxData Method Introduced in Inventor 4

Box Properties

Box.MaxPoint Property Introduced in Inventor 4

Box.MinPoint Property Introduced in Inventor 4

Box2d Interface Introduced in Inventor 4

Box2d Methods

Box2d.Contains Method Introduced in Inventor 2008

Box2d.Expand Method Introduced in Inventor 2008

Box2d.Extend Method Introduced in Inventor 2008

Box2d.GetBoxData Method Introduced in Inventor 4

Box2d.IsDisjoint Method Introduced in Inventor 2008

Box2d.PutBoxData Method Introduced in Inventor 4

Box2d Properties

Box2d.MaxPoint Property Introduced in Inventor 4

Box2d.MinPoint Property Introduced in Inventor 4

BreakOperation Interface Introduced in Inventor 2010

BreakOperation Methods

BreakOperation.Delete Method Introduced in Inventor 2010

BreakOperation.GetReferenceKey Method Introduced in Inventor 2010

BreakOperation Properties

BreakOperation.AllAffectedViews Property Introduced in Inventor 2010

BreakOperation.Application Property Introduced in Inventor 2010

BreakOperation.AttributeSets Property Introduced in Inventor 2010

BreakOperation.BreakStyle Property Introduced in Inventor 2010

BreakOperation.DisplayLevel Property Introduced in Inventor 2010

BreakOperation.EndPoint Property Introduced in Inventor 2010

BreakOperation.Gap Property Introduced in Inventor 2010

BreakOperation.IsSourceBreakOperation Property Introduced in Inventor 2010

BreakOperation.Layer Property Introduced in Inventor 2010

BreakOperation.MidPoint Property Introduced in Inventor 2010

BreakOperation.NumberOfSymbols Property Introduced in Inventor 2010

BreakOperation.Orientation Property Introduced in Inventor 2010

BreakOperation.Parent Property Introduced in Inventor 2010

BreakOperation.SourceBreakOperation Property Introduced in Inventor 2010

BreakOperation.StartPoint Property Introduced in Inventor 2010

BreakOperation.Type Property Introduced in Inventor 2010

BreakOperations Interface Introduced in Inventor 2010

BreakOperations Methods

BreakOperations.Add Method Introduced in Inventor 2010

BreakOperations.Item Method Introduced in Inventor 2010

BreakOperations Properties

BreakOperations.Application Property Introduced in Inventor 2010

BreakOperations.Count Property Introduced in Inventor 2010

BreakOperations.Type Property Introduced in Inventor 2010

BreakOutOperation Interface Introduced in Inventor 2010

BreakOutOperation Methods

BreakOutOperation.Delete Method Introduced in Inventor 2010

BreakOutOperation.GetDepth Method Introduced in Inventor 2010

BreakOutOperation.GetReferenceKey Method Introduced in Inventor 2010

BreakOutOperation.SetDepth Method Introduced in Inventor 2010

BreakOutOperation Properties

BreakOutOperation.AllAffectedViews Property Introduced in Inventor 2010

BreakOutOperation.Application Property Introduced in Inventor 2010

BreakOutOperation.AttributeSets Property Introduced in Inventor 2010

BreakOutOperation.DepthType Property Introduced in Inventor 2010

BreakOutOperation.Parent Property Introduced in Inventor 2010

BreakOutOperation.Profile Property Introduced in Inventor 2010

BreakOutOperation.SectionAllParts Property Introduced in Inventor 2010

BreakOutOperation.Type Property Introduced in Inventor 2010

BreakOutOperations Interface Introduced in Inventor 2010

BreakOutOperations Methods

BreakOutOperations.Add Method Introduced in Inventor 2010

BreakOutOperations.Item Method Introduced in Inventor 2010

BreakOutOperations Properties

BreakOutOperations.Application Property Introduced in Inventor 2010

BreakOutOperations.Count Property Introduced in Inventor 2010

BreakOutOperations.Type Property Introduced in Inventor 2010

BrowserFolder Interface Introduced in Inventor 2010

BrowserFolder Methods

BrowserFolder.Add Method Introduced in Inventor 2010

BrowserFolder.Delete Method Introduced in Inventor 2010

BrowserFolder.Remove Method Introduced in Inventor 2010

BrowserFolder.SetEndOfPart Method Introduced in Inventor 2010

BrowserFolder Properties

BrowserFolder.AllowAddRemove Property Introduced in Inventor 2011

BrowserFolder.AllowDelete Property Introduced in Inventor 2011

BrowserFolder.AllowRename Property Introduced in Inventor 2011

BrowserFolder.AllowReorder Property Introduced in Inventor 2011

BrowserFolder.Application Property Introduced in Inventor 2010

BrowserFolder.BrowserNode Property Introduced in Inventor 2010

BrowserFolder.Name Property Introduced in Inventor 2010

BrowserFolder.Parent Property Introduced in Inventor 2010

BrowserFolder.Type Property Introduced in Inventor 2010

BrowserFoldersEnumerator Interface Introduced in Inventor 2010

BrowserFoldersEnumerator Methods

BrowserFoldersEnumerator.Item Method Introduced in Inventor 2010

BrowserFoldersEnumerator Properties

BrowserFoldersEnumerator.Application Property Introduced in Inventor 2010

BrowserFoldersEnumerator.Count Property Introduced in Inventor 2010

BrowserFoldersEnumerator.Type Property Introduced in Inventor 2010

BrowserNode Interface Introduced in Inventor 8

BrowserNode Methods

BrowserNode.AddChild Method Introduced in Inventor 8

BrowserNode.AllReferencedNodes Method Introduced in Inventor 11

BrowserNode.Delete Method Introduced in Inventor 8

BrowserNode.DoPreSelect Method Introduced in Inventor 8

BrowserNode.DoSelect Method Introduced in Inventor 8

BrowserNode.EnsureVisible Method Introduced in Inventor 8

BrowserNode.InsertChild Method Introduced in Inventor 2011

BrowserNode Properties

BrowserNode.Application Property Introduced in Inventor 8

BrowserNode.BrowserFolders Property Introduced in Inventor 2010

BrowserNode.BrowserNodeDefinition Property Introduced in Inventor 8

BrowserNode.BrowserNodes Property Introduced in Inventor 8

BrowserNode.Expanded Property Introduced in Inventor 8

BrowserNode.FullPath Property Introduced in Inventor 8

BrowserNode.NativeObject Property Introduced in Inventor 2009

BrowserNode.Parent Property Introduced in Inventor 8

BrowserNode.Selected Property Introduced in Inventor 8

BrowserNode.Type Property Introduced in Inventor 8

BrowserNode.Visible Property Introduced in Inventor 8

BrowserNodeDefinition Interface Introduced in Inventor 8

BrowserNodeDefinition Properties

BrowserNodeDefinition.AdditionalDisplayState Property Introduced in Inventor 11

BrowserNodeDefinition.AdditionalStateIconToolTipText Property Introduced in Inventor 11

BrowserNodeDefinition.Application Property Introduced in Inventor 8

BrowserNodeDefinition.BuiltIn Property Introduced in Inventor 8

BrowserNodeDefinition.DisplayState Property Introduced in Inventor 9

BrowserNodeDefinition.Label Property Introduced in Inventor 8

BrowserNodeDefinition.Parent Property Introduced in Inventor 8

BrowserNodeDefinition.StateIconToolTipText Property Introduced in Inventor 8

BrowserNodeDefinition.ToolTipText Property Introduced in Inventor 8

BrowserNodeDefinition.Type Property Introduced in Inventor 8

BrowserNodeDefinitionSink Interface

BrowserNodeDefinitionSink Methods

BrowserNodeDefinitionSink.OnLabelEdit Method

BrowserNodesEnumerator Interface Introduced in Inventor 8

BrowserNodesEnumerator Methods

BrowserNodesEnumerator.Item Method Introduced in Inventor 8

BrowserNodesEnumerator.ItemById Method Introduced in Inventor 8

BrowserNodesEnumerator Properties

BrowserNodesEnumerator.Application Property Introduced in Inventor 8

BrowserNodesEnumerator.Count Property Introduced in Inventor 8

BrowserNodesEnumerator.Type Property Introduced in Inventor 8

BrowserPane CoClass Introduced in Inventor 5

BrowserPaneObject Interface

BrowserPaneObject Methods

BrowserPaneObject.Activate Method

BrowserPaneObject.AddBrowserFolder Method

BrowserPaneObject.Delete Method

BrowserPaneObject.GetBrowserNodeFromObject Method

BrowserPaneObject.Refresh Method

BrowserPaneObject.Reorder Method

BrowserPaneObject.Update Method

BrowserPaneObject Properties

BrowserPaneObject.Application Property

BrowserPaneObject.BuiltIn Property

BrowserPaneObject.Control Property

BrowserPaneObject.Default Property

BrowserPaneObject.InternalName Property

BrowserPaneObject.Name Property

BrowserPaneObject.Parent Property

BrowserPaneObject.TopNode Property

BrowserPaneObject.TreeBrowser Property

BrowserPaneObject.Type Property

BrowserPaneObject.Visible Property

BrowserPanes Interface Introduced in Inventor 5

BrowserPanes Methods

BrowserPanes.Add Method Introduced in Inventor 5

BrowserPanes.AddTransientTreeBrowserPane Method

BrowserPanes.AddTreeBrowserPane Method Introduced in Inventor 8

BrowserPanes.CreateBrowserNodeDefinition Method Introduced in Inventor 8

BrowserPanes.GetClientBrowserNodeDefinition Method Introduced in Inventor 11

BrowserPanes.GetNativeBrowserNodeDefinition Method Introduced in Inventor 9

BrowserPanes Properties

BrowserPanes.ActivePane Property Introduced in Inventor 5

BrowserPanes.Application Property Introduced in Inventor 5

BrowserPanes.BrowserPanesEvents Property Introduced in Inventor 9

BrowserPanes.ClientNodeResources Property Introduced in Inventor 8

BrowserPanes.Count Property Introduced in Inventor 5

BrowserPanes.Item Method Introduced in Inventor 5

BrowserPanes.Type Property Introduced in Inventor 5

BrowserPanesEvents CoClass Introduced in Inventor 9

BrowserPanesEventsObject Interface Introduced in Inventor 9

BrowserPaneSink Interface

BrowserPaneSink Methods

BrowserPaneSink.OnActivate Method

BrowserPaneSink.OnDeactivate Method

BrowserPaneSink.OnHelp Method

BrowserPanesSink Interface

BrowserPanesSink Methods

BrowserPanesSink.OnBrowserNodeActivate Method

BrowserPanesSink.OnBrowserNodeDeleteEntry Method

BrowserPanesSink.OnBrowserNodeGetDisplayObjects Method

BrowserPanesSink.OnBrowserNodeLabelEdit Method

BSplineCurve Interface Introduced in Inventor 4

BSplineCurve Methods

BSplineCurve.GetBSplineData Method Introduced in Inventor 4

BSplineCurve.GetBSplineInfo Method Introduced in Inventor 4

BSplineCurve.PoleAtIndex Method ([in] long, [in] Point*) Introduced in Inventor 4

BSplineCurve.PoleAtIndex Method ([in] long, [out, retval] Point**)

BSplineCurve.PutBSplineInfoAndData Method Introduced in Inventor 4

BSplineCurve Properties

BSplineCurve.Evaluator Property Introduced in Inventor 4

BSplineCurve2d Interface Introduced in Inventor 4

BSplineCurve2d Methods

BSplineCurve2d.GetBSplineData Method Introduced in Inventor 4

BSplineCurve2d.GetBSplineInfo Method Introduced in Inventor 4

BSplineCurve2d.PoleAtIndex Method ([in] long, [in] Point2d*) Introduced in Inventor 4

BSplineCurve2d.PoleAtIndex Method ([in] long, [out, retval] Point2d**) Introduced in Inventor 4

BSplineCurve2d.PutBSplineInfoAndData Method Introduced in Inventor 4

BSplineCurve2d Properties

BSplineCurve2d.Evaluator Property Introduced in Inventor 4

BSplineCurve2dDefinition Interface Introduced in Inventor 9

BSplineCurve2dDefinition Methods

BSplineCurve2dDefinition.AddPoint Method Introduced in Inventor 9

BSplineCurve2dDefinition Properties

BSplineCurve2dDefinition.FitMethod Property Introduced in Inventor 9

BSplineCurve2dDefinition.Type Property Introduced in Inventor 9

BSplineCurveDefinition Interface Introduced in Inventor 9

BSplineCurveDefinition Methods

BSplineCurveDefinition.AddPoint Method Introduced in Inventor 9

BSplineCurveDefinition Properties

BSplineCurveDefinition.FitMethod Property Introduced in Inventor 9

BSplineCurveDefinition.Type Property Introduced in Inventor 9

BSplineSurface Interface Introduced in Inventor 4

BSplineSurface Methods

BSplineSurface.GetBSplineData Method Introduced in Inventor 4

BSplineSurface.GetBSplineInfo Method Introduced in Inventor 4

BSplineSurface.PoleAtIndex Method Introduced in Inventor 4

BSplineSurface.PutBSplineInfoAndData Method Introduced in Inventor 4

BSplineSurface Properties

BSplineSurface.Evaluator Property Introduced in Inventor 4

ButtonDefinition CoClass Introduced in Inventor 6

ButtonDefinitionObject Interface Introduced in Inventor 6

ButtonDefinitionObject Properties

ButtonDefinitionObject.Pressed Property

ButtonDefinitionSink Interface

ButtonDefinitionSink Methods

ButtonDefinitionSink.OnExecute Method

ButtonDefinitionSink.OnHelp Method

Camera Interface Introduced in Inventor 4

Camera Methods

Camera.Apply Method Introduced in Inventor 4

Camera.ApplyWithoutTransition Method Introduced in Inventor 6

Camera.ComputeWithMouseInput Method Introduced in Inventor 6

Camera.CreateImage Method Introduced in Inventor 2012

Camera.Fit Method Introduced in Inventor 6

Camera.GetExtents Method Introduced in Inventor 5.3

Camera.ModelToViewSpace Method Introduced in Inventor 6

Camera.SaveAsBitmap Method Introduced in Inventor 2012

Camera.SetExtents Method Introduced in Inventor 5.3

Camera.ViewToModelSpace Method Introduced in Inventor 6

Camera Properties

Camera.Eye Property Introduced in Inventor 4

Camera.Parent Property Introduced in Inventor 4

Camera.Perspective Property Introduced in Inventor 5.3

Camera.PerspectiveAngle Property Introduced in Inventor 5.3

Camera.SceneObject Property Introduced in Inventor 2012

Camera.Target Property Introduced in Inventor 4

Camera.Type Property Introduced in Inventor 4

Camera.UpVector Property Introduced in Inventor 4

Camera.ViewOrientationType Property Introduced in Inventor 4

CameraEventsObject Interface

CameraEventsObject Properties

CameraEventsObject.Application Property

CameraEventsObject.Parent Property

CameraEventsObject.Type Property

CameraEventsSink Interface

CameraEventsSink Methods

CameraEventsSink.OnCameraChange Method

Cell Interface Introduced in Inventor 9

Cell Properties

Cell.Application Property Introduced in Inventor 9

Cell.Parent Property Introduced in Inventor 9

Cell.Static Property Introduced in Inventor 2009

Cell.Type Property Introduced in Inventor 9

Cell.Value Property Introduced in Inventor 9

CenteredWidthExtent Interface Introduced in Inventor 2009

CenteredWidthExtent Properties

CenteredWidthExtent.Edge Property Introduced in Inventor 2009

CenteredWidthExtent.Width Property Introduced in Inventor 2010

Centerline Interface Introduced in Inventor 2008

Centerline Methods

Centerline.Delete Method Introduced in Inventor 2008

Centerline.GetBisectorEntities Method Introduced in Inventor 2010

Centerline.GetReferenceKey Method Introduced in Inventor 2008

Centerline Properties

Centerline.Application Property Introduced in Inventor 2008

Centerline.Attached Property Introduced in Inventor 2008

Centerline.AttributeSets Property Introduced in Inventor 2008

Centerline.CenterlineType Property Introduced in Inventor 2008

Centerline.EndPoint Property Introduced in Inventor 2009

Centerline.FitPoints Property Introduced in Inventor 2010

Centerline.Geometry Property Introduced in Inventor 2009

Centerline.GeometryType Property Introduced in Inventor 2009

Centerline.Layer Property Introduced in Inventor 2010

Centerline.ModelWorkFeature Property Introduced in Inventor 2008

Centerline.Parent Property Introduced in Inventor 2008

Centerline.PatternCenter Property Introduced in Inventor 2010

Centerline.StartPoint Property Introduced in Inventor 2009

Centerline.Style Property Introduced in Inventor 2010

Centerline.Type Property Introduced in Inventor 2008

Centerline.Visible Property Introduced in Inventor 2008

Centerlines Interface Introduced in Inventor 2008

Centerlines Methods

Centerlines.Add Method Introduced in Inventor 2009

Centerlines.AddBisector Method Introduced in Inventor 2009

Centerlines.AddByWorkFeature Method Introduced in Inventor 2010

Centerlines.AddCenteredPattern Method Introduced in Inventor 2010

Centerlines.Item Method Introduced in Inventor 2008

Centerlines Properties

Centerlines.Application Property Introduced in Inventor 2008

Centerlines.Count Property Introduced in Inventor 2008

Centerlines.Type Property Introduced in Inventor 2008

Centermark Interface Introduced in Inventor 2008

Centermark Methods

Centermark.Delete Method Introduced in Inventor 2008

Centermark.GetReferenceKey Method Introduced in Inventor 2008

Centermark.ModelWorkFeature Method

Centermark Properties

Centermark.Application Property Introduced in Inventor 2008

Centermark.Attached Property Introduced in Inventor 2008

Centermark.AttachedEntity Property Introduced in Inventor 2010

Centermark.AttributeSets Property Introduced in Inventor 2008

Centermark.Centerlines Property Introduced in Inventor 2009

Centermark.CentermarkType Property Introduced in Inventor 2008

Centermark.ExtensionLinesVisible Property Introduced in Inventor 2010

Centermark.ExtensionPointFour Property Introduced in Inventor 2009

Centermark.ExtensionPointFourDirection Property Introduced in Inventor 2009

Centermark.ExtensionPointOne Property Introduced in Inventor 2009

Centermark.ExtensionPointOneDirection Property Introduced in Inventor 2009

Centermark.ExtensionPointThree Property Introduced in Inventor 2009

Centermark.ExtensionPointThreeDirection Property Introduced in Inventor 2009

Centermark.ExtensionPointTwo Property Introduced in Inventor 2009

Centermark.ExtensionPointTwoDirection Property Introduced in Inventor 2009

Centermark.Layer Property Introduced in Inventor 2010

Centermark.Parent Property Introduced in Inventor 2008

Centermark.Position Property Introduced in Inventor 2009

Centermark.Style Property Introduced in Inventor 2010

Centermark.Type Property Introduced in Inventor 2008

Centermark.Visible Property Introduced in Inventor 2008

Centermarks Interface Introduced in Inventor 2008

Centermarks Methods

Centermarks.Add Method Introduced in Inventor 2009

Centermarks.AddByCenterOfGravity Method Introduced in Inventor 2010

Centermarks.AddByWorkFeature Method Introduced in Inventor 2010

Centermarks.Item Method Introduced in Inventor 2008

Centermarks Properties

Centermarks.Application Property Introduced in Inventor 2008

Centermarks.Count Property Introduced in Inventor 2008

Centermarks.Type Property Introduced in Inventor 2008

CentermarkStyle Interface Introduced in Inventor 2010

CentermarkStyle Properties

CentermarkStyle.DefaultRadius Property Introduced in Inventor 2010

CentermarkStyle.ExtensionLength Property Introduced in Inventor 2010

CentermarkStyle.GapDistance Property Introduced in Inventor 2010

CentermarkStyle.MarkSize Property Introduced in Inventor 2010

CentermarkStyle.OvershootDistance Property Introduced in Inventor 2010

CentermarkStylesEnumerator Interface Introduced in Inventor 2010

CentermarkStylesEnumerator Methods

CentermarkStylesEnumerator.Item Method Introduced in Inventor 2010

CentermarkStylesEnumerator Properties

CentermarkStylesEnumerator.Application Property Introduced in Inventor 2010

CentermarkStylesEnumerator.Count Property Introduced in Inventor 2010

CentermarkStylesEnumerator.Type Property Introduced in Inventor 2010

CentroidWorkPointDef Interface Introduced in Inventor 2008

CentroidWorkPointDef Properties

CentroidWorkPointDef.Application Property Introduced in Inventor 2008

CentroidWorkPointDef.Entities Property Introduced in Inventor 2008

CentroidWorkPointDef.Parent Property Introduced in Inventor 2008

CentroidWorkPointDef.Type Property Introduced in Inventor 2008

ChainDimensionSet Interface Introduced in Inventor 2011

ChainDimensionSet Methods

ChainDimensionSet.AddMembers Method Introduced in Inventor 2011

ChainDimensionSet.Arrange Method

ChainDimensionSet.Delete Method

ChainDimensionSet.GetReferenceKey Method Introduced in Inventor 2011

ChainDimensionSet.MergeMembers Method Introduced in Inventor 2011

ChainDimensionSet Properties

ChainDimensionSet.Application Property Introduced in Inventor 2011

ChainDimensionSet.AttributeSets Property Introduced in Inventor 2011

ChainDimensionSet.DimensionType Property Introduced in Inventor 2011

ChainDimensionSet.Layer Property Introduced in Inventor 2011

ChainDimensionSet.Locked Property

ChainDimensionSet.Members Property Introduced in Inventor 2011

ChainDimensionSet.Parent Property Introduced in Inventor 2011

ChainDimensionSet.Precision Property Introduced in Inventor 2011

ChainDimensionSet.Style Property Introduced in Inventor 2011

ChainDimensionSet.Type Property Introduced in Inventor 2011

ChainDimensionSets Interface Introduced in Inventor 2011

ChainDimensionSets Methods

ChainDimensionSets.Add Method Introduced in Inventor 2011

ChainDimensionSets.AddUsingBaseDimension Method

ChainDimensionSets.Item Method Introduced in Inventor 2011

ChainDimensionSets Properties

ChainDimensionSets._NewEnum Property

ChainDimensionSets.Application Property Introduced in Inventor 2011

ChainDimensionSets.Count Property Introduced in Inventor 2011

ChainDimensionSets.Type Property Introduced in Inventor 2011

ChamferDefinition Interface Introduced in Inventor 5.3

ChamferDefinition Properties

ChamferDefinition.Application Property Introduced in Inventor 5.3

ChamferDefinition.Parent Property Introduced in Inventor 5.3

ChamferDefinition.Type Property Introduced in Inventor 5.3

ChamferFeature Interface Introduced in Inventor 5

ChamferFeature Properties

ChamferFeature.AutomaticEdgeChain Property Introduced in Inventor 5.3

ChamferFeature.ChamferedEdges Property Introduced in Inventor 6

ChamferFeature.Definition Property Introduced in Inventor 5.3

ChamferFeature.DefinitionType Property Introduced in Inventor 5.3

ChamferFeature.PreserveAllFeatures Property Introduced in Inventor 5.3

ChamferFeatureProxy Interface Introduced in Inventor 9

ChamferFeatureProxy Properties

ChamferFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ChamferFeatureProxy.NativeObject Property Introduced in Inventor 9

ChamferFeatures Interface Introduced in Inventor 5

ChamferFeatures Methods

ChamferFeatures.AddUsingDistance Method Introduced in Inventor 5.3

ChamferFeatures.AddUsingDistanceAndAngle Method Introduced in Inventor 5.3

ChamferFeatures.AddUsingTwoDistances Method Introduced in Inventor 5.3

ChamferFeatures.Item Method Introduced in Inventor 5

ChamferFeatures Properties

ChamferFeatures.Application Property Introduced in Inventor 5

ChamferFeatures.Count Property Introduced in Inventor 5

ChamferFeatures.Type Property Introduced in Inventor 5

ChamferNote Interface Introduced in Inventor 2010

ChamferNote Properties

ChamferNote.ChamferEdgeOne Property Introduced in Inventor 2010

ChamferNote.ChamferEdgeTwo Property Introduced in Inventor 2010

ChamferNote.FormattedChamferNote Property Introduced in Inventor 2010

ChamferNote.HideValue Property Introduced in Inventor 2010

ChamferNotes Interface Introduced in Inventor 2010

ChamferNotes Methods

ChamferNotes.Add Method Introduced in Inventor 2010

ChamferNotes.Item Method Introduced in Inventor 2010

ChamferNotes Properties

ChamferNotes.Application Property Introduced in Inventor 2010

ChamferNotes.Count Property Introduced in Inventor 2010

ChamferNotes.Type Property Introduced in Inventor 2010

ChangeDefinition CoClass Introduced in Inventor 9

ChangeDefinitionObject Interface Introduced in Inventor 9

ChangeDefinitionObject Methods

ChangeDefinitionObject.CreateChangeProcessor Method

ChangeDefinitionObject.Delete Method

ChangeDefinitionObject Properties

ChangeDefinitionObject.Application Property

ChangeDefinitionObject.ChangeType Property

ChangeDefinitionObject.ClientId Property

ChangeDefinitionObject.CommandName Property

ChangeDefinitionObject.InternalName Property

ChangeDefinitionObject.Parent Property

ChangeDefinitionObject.Type Property

ChangeDefinitions Interface Introduced in Inventor 9

ChangeDefinitions Methods

ChangeDefinitions.Add Method Introduced in Inventor 9

ChangeDefinitions.Delete Method Introduced in Inventor 9

ChangeDefinitions.Item Method Introduced in Inventor 9

ChangeDefinitions Properties

ChangeDefinitions.Application Property Introduced in Inventor 9

ChangeDefinitions.ClientId Property Introduced in Inventor 9

ChangeDefinitions.Count Property Introduced in Inventor 9

ChangeDefinitions.Type Property Introduced in Inventor 9

ChangeDefinitionSink Interface

ChangeDefinitionSink Methods

ChangeDefinitionSink.OnReplay Method

ChangeManager Interface Introduced in Inventor 9

ChangeManager Methods

ChangeManager.Add Method Introduced in Inventor 9

ChangeManager.GetObjectFromScriptKey Method Introduced in Inventor 11

ChangeManager.GetScriptKeyFromObject Method Introduced in Inventor 11

ChangeManager.Item Method Introduced in Inventor 9

ChangeManager Properties

ChangeManager.Application Property Introduced in Inventor 9

ChangeManager.Count Property Introduced in Inventor 9

ChangeManager.Parent Property Introduced in Inventor 9

ChangeManager.Type Property Introduced in Inventor 9

ChangeProcessor CoClass Introduced in Inventor 9

ChangeProcessorObject Interface

ChangeProcessorObject Methods

ChangeProcessorObject.Execute Method

ChangeProcessorObject.SetAffectedDocuments Method

ChangeProcessorObject.SetMessageDialogOptions Method

ChangeProcessorObject Properties

ChangeProcessorObject.Application Property

ChangeProcessorObject.ChangeType Property

ChangeProcessorObject.DisplayMessages Property

ChangeProcessorObject.GlobalChangeProcess Property

ChangeProcessorObject.GlobalChangeProcessAborted Property

ChangeProcessorObject.MergeWithPrevious Property

ChangeProcessorObject.MessageDialogUserChoice Property

ChangeProcessorObject.Parent Property

ChangeProcessorObject.Transact Property

ChangeProcessorObject.Type Property

ChangeProcessorSink Interface

ChangeProcessorSink Methods

ChangeProcessorSink.OnExecute Method

ChangeProcessorSink.OnReadFromScript Method

ChangeProcessorSink.OnTerminate Method

ChangeProcessorSink.OnWriteToScript Method

CheckPoint Interface Introduced in Inventor 5

CheckPoint Properties

CheckPoint.Application Property Introduced in Inventor 5

CheckPoint.ContainingTransaction Property Introduced in Inventor 5

CheckPoint.DisplayName Property Introduced in Inventor 5

CheckPoint.Id Property Introduced in Inventor 5

CheckPoint.Parent Property Introduced in Inventor 5

CheckPoint.Type Property Introduced in Inventor 5

CheckPointsEnumerator Interface Introduced in Inventor 5

CheckPointsEnumerator Methods

CheckPointsEnumerator.Item Method Introduced in Inventor 5

CheckPointsEnumerator Properties

CheckPointsEnumerator.Count Property Introduced in Inventor 5

CheckPointsEnumerator.Type Property Introduced in Inventor 5

Circle Interface Introduced in Inventor 4

Circle Methods

Circle.GetCircleData Method Introduced in Inventor 4

Circle.PutCircleData Method Introduced in Inventor 4

Circle Properties

Circle.Center Property Introduced in Inventor 4

Circle.Evaluator Property Introduced in Inventor 4

Circle.Normal Property Introduced in Inventor 4

Circle.Radius Property Introduced in Inventor 4

Circle2d Interface Introduced in Inventor 4

Circle2d Methods

Circle2d.GetCircleData Method Introduced in Inventor 4

Circle2d.PutCircleData Method Introduced in Inventor 4

Circle2d Properties

Circle2d.Center Property Introduced in Inventor 4

Circle2d.Evaluator Property Introduced in Inventor 4

Circle2d.Radius Property Introduced in Inventor 4

CircularOccurrencePattern Interface Introduced in Inventor 6

CircularOccurrencePattern Properties

CircularOccurrencePattern.AngleOffset Property Introduced in Inventor 6

CircularOccurrencePattern.AxisEntity Property Introduced in Inventor 6

CircularOccurrencePattern.AxisEntityNaturalDirection Property Introduced in Inventor 6

CircularOccurrencePattern.ElementCount Property Introduced in Inventor 6

CircularOccurrencePatternProxy Interface Introduced in Inventor 2010

CircularOccurrencePatternProxy Properties

CircularOccurrencePatternProxy.ContainingOccurrence Property Introduced in Inventor 2010

CircularOccurrencePatternProxy.NativeObject Property Introduced in Inventor 2010

CircularPatternFeature Interface Introduced in Inventor 5

CircularPatternFeature Methods

CircularPatternFeature.AddParticipant Method Introduced in Inventor 2010

CircularPatternFeature Properties

CircularPatternFeature.Angle Property Introduced in Inventor 5

CircularPatternFeature.AxisEntity Property Introduced in Inventor 5

CircularPatternFeature.ComputeType Property Introduced in Inventor 9

CircularPatternFeature.Count Property Introduced in Inventor 5

CircularPatternFeature.FitWithinAngle Property Introduced in Inventor 5

CircularPatternFeature.MidPlanePattern Property Introduced in Inventor 11

CircularPatternFeature.NaturalAxisDirection Property Introduced in Inventor 5

CircularPatternFeature.NewBodyOperation Property Introduced in Inventor 2010

CircularPatternFeature.ParentFeatures Property Introduced in Inventor 5

CircularPatternFeature.PatternElements Property Introduced in Inventor 5

CircularPatternFeature.PatternOfBody Property Introduced in Inventor 9

CircularPatternFeature.SurfacesOpaque Property Introduced in Inventor 11

CircularPatternFeature.SurfacesVisible Property Introduced in Inventor 11

CircularPatternFeatureProxy Interface Introduced in Inventor 9

CircularPatternFeatureProxy Properties

CircularPatternFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

CircularPatternFeatureProxy.NativeObject Property Introduced in Inventor 9

CircularPatternFeatures Interface Introduced in Inventor 5

CircularPatternFeatures Methods

CircularPatternFeatures.Add Method Introduced in Inventor 5.3

CircularPatternFeatures.Item Method Introduced in Inventor 5

CircularPatternFeatures Properties

CircularPatternFeatures.Application Property Introduced in Inventor 5

CircularPatternFeatures.Count Property Introduced in Inventor 5

CircularPatternFeatures.Type Property Introduced in Inventor 5

ClientApplication Interface Introduced in Inventor 9

ClientApplication Methods

ClientApplication.GetXMLData Method Introduced in Inventor 9

ClientApplication.PutXMLData Method Introduced in Inventor 9

ClientBrowserNodeDefinition CoClass Introduced in Inventor 8

ClientBrowserNodeDefinitionObject Interface

ClientBrowserNodeDefinitionObject Methods

ClientBrowserNodeDefinitionObject.Delete Method

ClientBrowserNodeDefinitionObject.GetReferenceKey Method

ClientBrowserNodeDefinitionObject.SetLabel Method

ClientBrowserNodeDefinitionObject Properties

ClientBrowserNodeDefinitionObject.AttributeSets Property

ClientBrowserNodeDefinitionObject.ExpandedIcon Property

ClientBrowserNodeDefinitionObject.Icon Property

ClientBrowserNodeDefinitionObject.Id Property

ClientBrowserNodeDefinitionObject.IsReferenced Property

ClientBrowserNodeDefinitionSink Interface

ClientFeature Interface Introduced in Inventor 2008

ClientFeature Properties

ClientFeature.BrowserNode Property Introduced in Inventor 2008

ClientFeature.ClientId Property Introduced in Inventor 2008

ClientFeature.Definition Property Introduced in Inventor 2008

ClientFeature.HiddenParameters Property Introduced in Inventor 2009

ClientFeatureDefinition Interface Introduced in Inventor 2008

ClientFeatureDefinition Methods

ClientFeatureDefinition.AddDependency Method Introduced in Inventor 2009

ClientFeatureDefinition.RemoveDependency Method Introduced in Inventor 2009

ClientFeatureDefinition Properties

ClientFeatureDefinition.Application Property Introduced in Inventor 2008

ClientFeatureDefinition.ClientFeatureElements Property Introduced in Inventor 2008

ClientFeatureDefinition.ClientGraphicsCollection Property Introduced in Inventor 2008

ClientFeatureDefinition.FeatureInputs Property Introduced in Inventor 2008

ClientFeatureDefinition.FeatureType Property Introduced in Inventor 2008

ClientFeatureDefinition.GraphicsDataSetsCollection Property

ClientFeatureDefinition.HighlightClientGraphicsWithFeature Property Introduced in Inventor 2010

ClientFeatureDefinition.Parent Property Introduced in Inventor 2008

ClientFeatureDefinition.Type Property Introduced in Inventor 2008

ClientFeatureElement Interface Introduced in Inventor 2008

ClientFeatureElement Methods

ClientFeatureElement.Delete Method Introduced in Inventor 2008

ClientFeatureElement Properties

ClientFeatureElement.Application Property Introduced in Inventor 2008

ClientFeatureElement.BrowserVisible Property Introduced in Inventor 2008

ClientFeatureElement.Element Property Introduced in Inventor 2008

ClientFeatureElement.HighlightWithFeature Property Introduced in Inventor 2008

ClientFeatureElement.Parent Property Introduced in Inventor 2008

ClientFeatureElement.Type Property Introduced in Inventor 2008

ClientFeatureElement.UserEditable Property Introduced in Inventor 2008

ClientFeatureElementProxy Interface Introduced in Inventor 2008

ClientFeatureElementProxy Properties

ClientFeatureElementProxy.ContainingOccurrence Property Introduced in Inventor 2008

ClientFeatureElementProxy.NativeObject Property Introduced in Inventor 2008

ClientFeatureElements Interface Introduced in Inventor 2008

ClientFeatureElements Methods

ClientFeatureElements.Add Method Introduced in Inventor 2008

ClientFeatureElements.Item Method Introduced in Inventor 2008

ClientFeatureElements Properties

ClientFeatureElements.Application Property Introduced in Inventor 2008

ClientFeatureElements.Count Property Introduced in Inventor 2008

ClientFeatureElements.Type Property Introduced in Inventor 2008

ClientFeatureProxy Interface Introduced in Inventor 2008

ClientFeatureProxy Properties

ClientFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2008

ClientFeatureProxy.NativeObject Property Introduced in Inventor 2008

ClientFeatures Interface Introduced in Inventor 2008

ClientFeatures Methods

ClientFeatures.Add Method Introduced in Inventor 2008

ClientFeatures.CreateDefinition Method Introduced in Inventor 2008

ClientFeatures.Item Method Introduced in Inventor 2008

ClientFeatures Properties

ClientFeatures.Application Property Introduced in Inventor 2008

ClientFeatures.Count Property Introduced in Inventor 2008

ClientFeatures.Type Property Introduced in Inventor 2008

ClientGraphics Interface Introduced in Inventor 5

ClientGraphics Methods

ClientGraphics.AddNode Method Introduced in Inventor 5

ClientGraphics.Delete Method Introduced in Inventor 5

ClientGraphics.Item Method Introduced in Inventor 5

ClientGraphics.ItemById Method Introduced in Inventor 5

ClientGraphics Properties

ClientGraphics.Application Property Introduced in Inventor 5

ClientGraphics.ClientId Property Introduced in Inventor 5

ClientGraphics.Count Property Introduced in Inventor 5

ClientGraphics.NonTransacting Property Introduced in Inventor 2012

ClientGraphics.Parent Property Introduced in Inventor 5

ClientGraphics.RangeBox Property Introduced in Inventor 5

ClientGraphics.Selectable Property Introduced in Inventor 5

ClientGraphics.Type Property Introduced in Inventor 5

ClientGraphics.Visible Property Introduced in Inventor 5

ClientGraphicsCollection Interface Introduced in Inventor 5

ClientGraphicsCollection Methods

ClientGraphicsCollection.Add Method Introduced in Inventor 5

ClientGraphicsCollection.AddNonTransacting Method Introduced in Inventor 2012

ClientGraphicsCollection.Item Method Introduced in Inventor 5

ClientGraphicsCollection Properties

ClientGraphicsCollection.Application Property Introduced in Inventor 5

ClientGraphicsCollection.Count Property Introduced in Inventor 5

ClientGraphicsCollection.Parent Property Introduced in Inventor 5

ClientGraphicsCollection.Type Property Introduced in Inventor 5

ClientNodeResource Interface Introduced in Inventor 8

ClientNodeResource Methods

ClientNodeResource.Delete Method Introduced in Inventor 8

ClientNodeResource Properties

ClientNodeResource.Application Property Introduced in Inventor 8

ClientNodeResource.ClientId Property Introduced in Inventor 8

ClientNodeResource.DisabledIcon Property Introduced in Inventor 11

ClientNodeResource.ExpandedDisabledIcon Property Introduced in Inventor 11

ClientNodeResource.ExpandedInvisibleIcon Property Introduced in Inventor 11

ClientNodeResource.ExpandedSuppressedIcon Property Introduced in Inventor 11

ClientNodeResource.GroundedDisabledIcon Property Introduced in Inventor 2010

ClientNodeResource.GroundedIcon Property Introduced in Inventor 2010

ClientNodeResource.GroundedInvisibleIcon Property Introduced in Inventor 2010

ClientNodeResource.GroundedSuppressedIcon Property Introduced in Inventor 2010

ClientNodeResource.Icon Property Introduced in Inventor 8

ClientNodeResource.Id Property Introduced in Inventor 8

ClientNodeResource.InvisibleIcon Property Introduced in Inventor 11

ClientNodeResource.Parent Property Introduced in Inventor 8

ClientNodeResource.SuppressedIcon Property Introduced in Inventor 11

ClientNodeResource.Type Property Introduced in Inventor 8

ClientNodeResources Interface Introduced in Inventor 8

ClientNodeResources Methods

ClientNodeResources.Add Method Introduced in Inventor 8

ClientNodeResources.Item Method Introduced in Inventor 8

ClientNodeResources.ItemById Method Introduced in Inventor 8

ClientNodeResources Properties

ClientNodeResources.Application Property Introduced in Inventor 8

ClientNodeResources.Count Property Introduced in Inventor 8

ClientNodeResources.Type Property Introduced in Inventor 8

ClientView Interface Introduced in Inventor 6

ClientView Methods

ClientView.Close Method Introduced in Inventor 6

ClientView.GetSubsetExtents Method Introduced in Inventor 6

ClientView.Update Method Introduced in Inventor 6

ClientView Properties

ClientView.Application Property Introduced in Inventor 6

ClientView.Camera Property Introduced in Inventor 6

ClientView.DisplayMode Property Introduced in Inventor 6

ClientView.Document Property Introduced in Inventor 6

ClientView.GroundShadow Property Introduced in Inventor 2008

ClientView.HWND Property Introduced in Inventor 6

ClientView.Parent Property Introduced in Inventor 6

ClientView.Type Property Introduced in Inventor 6

ClientViews Interface Introduced in Inventor 6

ClientViews Methods

ClientViews.Add Method Introduced in Inventor 6

ClientViews.AddBySubset Method Introduced in Inventor 6

ClientViews.Item Method Introduced in Inventor 6

ClientViews Properties

ClientViews.Application Property Introduced in Inventor 6

ClientViews.Count Property Introduced in Inventor 6

ClientViews.Parent Property Introduced in Inventor 6

ClientViews.Type Property Introduced in Inventor 6

CoilFeature Interface Introduced in Inventor 5

CoilFeature Methods

CoilFeature.SetPitchAndHeightExtent Method Introduced in Inventor 2008

CoilFeature.SetPitchAndRevolutionExtent Method Introduced in Inventor 2008

CoilFeature.SetRevolutionAndHeightExtent Method Introduced in Inventor 2008

CoilFeature.SetSpiralExtent Method Introduced in Inventor 2008

CoilFeature Properties

CoilFeature.AxisDirectionReversed Property Introduced in Inventor 5.3

CoilFeature.AxisEntity Property Introduced in Inventor 5.3

CoilFeature.ClockwiseRotation Property Introduced in Inventor 5.3

CoilFeature.EndFlatAngle Property Introduced in Inventor 5.3

CoilFeature.EndTransitionAngle Property Introduced in Inventor 5.3

CoilFeature.Extent Property Introduced in Inventor 5.3

CoilFeature.ExtentType Property Introduced in Inventor 5.3

CoilFeature.FlatEndType Property Introduced in Inventor 5.3

CoilFeature.FlatStartType Property Introduced in Inventor 5.3

CoilFeature.Operation Property Introduced in Inventor 5.3

CoilFeature.Profile Property Introduced in Inventor 5.3

CoilFeature.StartFlatAngle Property Introduced in Inventor 5.3

CoilFeature.StartTransitionAngle Property Introduced in Inventor 5.3

CoilFeatureProxy Interface Introduced in Inventor 9

CoilFeatureProxy Properties

CoilFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

CoilFeatureProxy.NativeObject Property Introduced in Inventor 9

CoilFeatures Interface Introduced in Inventor 5

CoilFeatures Methods

CoilFeatures.AddByPitchAndHeight Method Introduced in Inventor 5.3

CoilFeatures.AddByPitchAndRevolution Method Introduced in Inventor 5.3

CoilFeatures.AddByRevolutionAndHeight Method Introduced in Inventor 5.3

CoilFeatures.AddSpiral Method Introduced in Inventor 5.3

CoilFeatures.Item Method Introduced in Inventor 5

CoilFeatures Properties

CoilFeatures.Application Property Introduced in Inventor 5

CoilFeatures.Count Property Introduced in Inventor 5

CoilFeatures.Type Property Introduced in Inventor 5

CoincidentConstraint Interface Introduced in Inventor 5

CoincidentConstraint Properties

CoincidentConstraint.EntityOne Property Introduced in Inventor 5

CoincidentConstraint.EntityTwo Property Introduced in Inventor 5

CoincidentConstraint.StartOrEndPointConstraint Property Introduced in Inventor 11

CoincidentConstraint3D Interface Introduced in Inventor 6

CoincidentConstraint3D Methods

CoincidentConstraint3D.Disconnect Method Introduced in Inventor 6

CoincidentConstraint3D Properties

CoincidentConstraint3D.ConnectedEntity Property Introduced in Inventor 10

CoincidentConstraint3D.EntityOne Property Introduced in Inventor 10

CoincidentConstraint3D.EntityTwo Property Introduced in Inventor 10

CoincidentConstraint3DProxy Interface Introduced in Inventor 6

CoincidentConstraint3DProxy Properties

CoincidentConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 6

CoincidentConstraint3DProxy.NativeObject Property Introduced in Inventor 6

CoincidentConstraintProxy Interface Introduced in Inventor 6

CoincidentConstraintProxy Properties

CoincidentConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

CoincidentConstraintProxy.NativeObject Property Introduced in Inventor 6

CollinearConstraint Interface Introduced in Inventor 5

CollinearConstraint Properties

CollinearConstraint.EntityOne Property Introduced in Inventor 5

CollinearConstraint.EntityTwo Property Introduced in Inventor 5

CollinearConstraint.UseEllipseOneMajorAxis Property Introduced in Inventor 5

CollinearConstraint.UseEllipseTwoMajorAxis Property Introduced in Inventor 5

CollinearConstraint3D Interface Introduced in Inventor 10

CollinearConstraint3D Properties

CollinearConstraint3D.EntityOne Property Introduced in Inventor 10

CollinearConstraint3D.EntityTwo Property Introduced in Inventor 10

CollinearConstraint3DProxy Interface Introduced in Inventor 10

CollinearConstraint3DProxy Properties

CollinearConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 10

CollinearConstraint3DProxy.NativeObject Property Introduced in Inventor 10

CollinearConstraintProxy Interface Introduced in Inventor 6

CollinearConstraintProxy Properties

CollinearConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

CollinearConstraintProxy.NativeObject Property Introduced in Inventor 6

Color Interface Introduced in Inventor 8

Color Methods

Color.GetColor Method Introduced in Inventor 8

Color.SetColor Method Introduced in Inventor 8

Color Properties

Color.Blue Property Introduced in Inventor 8

Color.ColorSourceType Property Introduced in Inventor 2010

Color.Green Property Introduced in Inventor 8

Color.Opacity Property Introduced in Inventor 8

Color.Red Property Introduced in Inventor 8

Color.Type Property Introduced in Inventor 8

ColorScheme Interface Introduced in Inventor 9

ColorScheme Methods

ColorScheme.Activate Method Introduced in Inventor 9

ColorScheme Properties

ColorScheme.Application Property Introduced in Inventor 9

ColorScheme.BottomScreenColor Property Introduced in Inventor 10

ColorScheme.BottomScreenColor2D Property Introduced in Inventor 10

ColorScheme.CutPreviewColor Property Introduced in Inventor 10

ColorScheme.DOFFixedColor Property Introduced in Inventor 10

ColorScheme.DOFFreeColor Property Introduced in Inventor 10

ColorScheme.HighlightColor Property Introduced in Inventor 9

ColorScheme.HighlightColor2D Property Introduced in Inventor 10

ColorScheme.ImageFullFileName Property Introduced in Inventor 10

ColorScheme.IntersectPreviewColor Property Introduced in Inventor 10

ColorScheme.JoinPreviewColor Property Introduced in Inventor 10

ColorScheme.Name Property Introduced in Inventor 9

ColorScheme.PrimarySelectColor Property Introduced in Inventor 9

ColorScheme.PrimarySelectColor2D Property Introduced in Inventor 10

ColorScheme.ScreenColor Property Introduced in Inventor 10

ColorScheme.ScreenColor2D Property Introduced in Inventor 10

ColorScheme.SecondarySelectColor Property Introduced in Inventor 9

ColorScheme.TertiarySelectColor Property Introduced in Inventor 2009

ColorScheme.TopScreenColor Property Introduced in Inventor 10

ColorScheme.TopScreenColor2D Property Introduced in Inventor 10

ColorScheme.Type Property Introduced in Inventor 9

ColorSchemes Interface Introduced in Inventor 9

ColorSchemes Methods

ColorSchemes.Item Method Introduced in Inventor 9

ColorSchemes Properties

ColorSchemes.Application Property Introduced in Inventor 9

ColorSchemes.ApplicationFrameColor Property Introduced in Inventor 2010

ColorSchemes.BackgroundType Property Introduced in Inventor 10

ColorSchemes.Count Property Introduced in Inventor 9

ColorSchemes.EnableEnhancedHighlighting Property

ColorSchemes.EnablePrehighlight Property

ColorSchemes.IconsColor Property Introduced in Inventor 2011

ColorSchemes.InterfaceStyle Property Introduced in Inventor 2011

ColorSchemes.Type Property Introduced in Inventor 9

Column Interface Introduced in Inventor 9

Column Methods

Column.Delete Method Introduced in Inventor 9

Column.Reposition Method Introduced in Inventor 2009

Column Properties

Column.Application Property Introduced in Inventor 9

Column.InternalTitle Property Introduced in Inventor 2009

Column.Parent Property Introduced in Inventor 9

Column.Title Property Introduced in Inventor 9

Column.TitleHorizontalJustification Property Introduced in Inventor 9

Column.Type Property Introduced in Inventor 9

Column.ValueHorizontalJustification Property Introduced in Inventor 9

Column.Width Property Introduced in Inventor 2010

Columns Interface Introduced in Inventor 9

Columns Methods

Columns.Add Method Introduced in Inventor 9

Columns.Item Method Introduced in Inventor 9

Columns Properties

Columns.Application Property Introduced in Inventor 9

Columns.Count Property Introduced in Inventor 9

Columns.Type Property Introduced in Inventor 9

CombineFeature Interface Introduced in Inventor 2010

CombineFeature Methods

CombineFeature.Edit Method Introduced in Inventor 2010

CombineFeature Properties

CombineFeature.KeepToolBodies Property Introduced in Inventor 2010

CombineFeature.Operation Property Introduced in Inventor 2010

CombineFeature.ToolBodies Property Introduced in Inventor 2010

CombineFeatureProxy Interface Introduced in Inventor 2010

CombineFeatureProxy Properties

CombineFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

CombineFeatureProxy.NativeObject Property Introduced in Inventor 2010

CombineFeatures Interface Introduced in Inventor 2010

CombineFeatures Methods

CombineFeatures.Add Method Introduced in Inventor 2010

CombineFeatures.Item Method Introduced in Inventor 2010

CombineFeatures Properties

CombineFeatures.Application Property Introduced in Inventor 2010

CombineFeatures.Count Property Introduced in Inventor 2010

CombineFeatures.Type Property Introduced in Inventor 2010

ComboBoxDefinition CoClass Introduced in Inventor 9

ComboBoxDefinitionObject Interface

ComboBoxDefinitionObject Methods

ComboBoxDefinitionObject.AddItem Method

ComboBoxDefinitionObject.Clear Method

ComboBoxDefinitionObject.ListItem Method

ComboBoxDefinitionObject.RemoveItem Method

ComboBoxDefinitionObject Properties

ComboBoxDefinitionObject.DropDownWidth Property

ComboBoxDefinitionObject.ListCount Property

ComboBoxDefinitionObject.ListIndex Property

ComboBoxDefinitionObject.Text Property

ComboBoxDefinitionSink Interface

ComboBoxDefinitionSink Methods

ComboBoxDefinitionSink.OnHelp Method Introduced in Inventor 2012

ComboBoxDefinitionSink.OnSelect Method

CommandBar Interface Introduced in Inventor 5

CommandBar Methods

CommandBar.Copy Method Introduced in Inventor 9

CommandBar.Delete Method Introduced in Inventor 9

CommandBar Properties

CommandBar.Application Property Introduced in Inventor 5

CommandBar.BuiltIn Property Introduced in Inventor 5

CommandBar.ClientId Property Introduced in Inventor 9

CommandBar.CommandBarType Property Introduced in Inventor 9

CommandBar.Controls Property Introduced in Inventor 5

CommandBar.DisplayName Property Introduced in Inventor 9

CommandBar.InternalName Property Introduced in Inventor 9

CommandBar.Parent Property Introduced in Inventor 5

CommandBar.Type Property Introduced in Inventor 5

CommandBar.Visible Property Introduced in Inventor 9

CommandBarControl Interface Introduced in Inventor 5

CommandBarControl Methods

CommandBarControl.Delete Method Introduced in Inventor 7

CommandBarControl Properties

CommandBarControl.Application Property Introduced in Inventor 5

CommandBarControl.BuiltIn Property Introduced in Inventor 9

CommandBarControl.CommandBar Property Introduced in Inventor 9

CommandBarControl.ControlDefinition Property Introduced in Inventor 7

CommandBarControl.ControlType Property Introduced in Inventor 9

CommandBarControl.DisplayedControl Property Introduced in Inventor 9

CommandBarControl.DisplayName Property Introduced in Inventor 9

CommandBarControl.GroupBegins Property Introduced in Inventor 5

CommandBarControl.Index Property Introduced in Inventor 2010

CommandBarControl.InternalName Property Introduced in Inventor 9

CommandBarControl.Parent Property Introduced in Inventor 9

CommandBarControl.Type Property Introduced in Inventor 5

CommandBarControls Interface Introduced in Inventor 5

CommandBarControls Methods

CommandBarControls.AddButton Method Introduced in Inventor 9

CommandBarControls.AddButtonPopup Method Introduced in Inventor 9

CommandBarControls.AddComboBox Method Introduced in Inventor 9

CommandBarControls.AddMacro Method Introduced in Inventor 9

CommandBarControls.AddPopup Method Introduced in Inventor 9

CommandBarControls.AddSplitButton Method Introduced in Inventor 9

CommandBarControls.AddSplitButtonMRU Method Introduced in Inventor 9

CommandBarControls.Item Method Introduced in Inventor 7

CommandBarControls Properties

CommandBarControls.Application Property Introduced in Inventor 5

CommandBarControls.Count Property Introduced in Inventor 7

CommandBarControls.Type Property Introduced in Inventor 5

CommandBarList Interface Introduced in Inventor 6

CommandBarList Methods

CommandBarList.Add Method Introduced in Inventor 6

CommandBarList.Item Method Introduced in Inventor 9

CommandBarList.Remove Method Introduced in Inventor 9

CommandBarList Properties

CommandBarList.Application Property Introduced in Inventor 6

CommandBarList.Count Property Introduced in Inventor 6

CommandBarList.InheritAll Property Introduced in Inventor 10

CommandBarList.Type Property Introduced in Inventor 6

CommandBars Interface Introduced in Inventor 5

CommandBars Methods

CommandBars.Add Method Introduced in Inventor 9

CommandBars.Item Method Introduced in Inventor 9

CommandBars Properties

CommandBars.Application Property Introduced in Inventor 5

CommandBars.Count Property Introduced in Inventor 9

CommandBars.Type Property Introduced in Inventor 5

CommandCategories Interface Introduced in Inventor 9

CommandCategories Methods

CommandCategories.Add Method Introduced in Inventor 9

CommandCategories.Item Method Introduced in Inventor 9

CommandCategories Properties

CommandCategories.Application Property Introduced in Inventor 9

CommandCategories.Count Property Introduced in Inventor 9

CommandCategories.Type Property Introduced in Inventor 9

CommandCategory Interface Introduced in Inventor 9

CommandCategory Methods

CommandCategory.Add Method Introduced in Inventor 9

CommandCategory.Delete Method Introduced in Inventor 9

CommandCategory.Item Method Introduced in Inventor 9

CommandCategory.Remove Method Introduced in Inventor 9

CommandCategory Properties

CommandCategory.Application Property Introduced in Inventor 9

CommandCategory.BuiltIn Property Introduced in Inventor 9

CommandCategory.ClientId Property Introduced in Inventor 2008

CommandCategory.Count Property Introduced in Inventor 9

CommandCategory.DisplayName Property Introduced in Inventor 9

CommandCategory.InternalName Property Introduced in Inventor 9

CommandCategory.Parent Property Introduced in Inventor 9

CommandCategory.Type Property Introduced in Inventor 9

CommandControl Interface Introduced in Inventor 2010

CommandControl Methods

CommandControl.Delete Method Introduced in Inventor 2010

CommandControl Properties

CommandControl.Application Property Introduced in Inventor 2010

CommandControl.ChildControls Property Introduced in Inventor 2010

CommandControl.ControlDefinition Property Introduced in Inventor 2010

CommandControl.ControlType Property Introduced in Inventor 2010

CommandControl.DisplayedControl Property Introduced in Inventor 2010

CommandControl.DisplayName Property Introduced in Inventor 2010

CommandControl.InternalName Property Introduced in Inventor 2010

CommandControl.KeyTip Property Introduced in Inventor 2011

CommandControl.Parent Property Introduced in Inventor 2010

CommandControl.ShowText Property Introduced in Inventor 2010

CommandControl.Type Property Introduced in Inventor 2010

CommandControl.UseLargeIcon Property Introduced in Inventor 2010

CommandControl.Visible Property Introduced in Inventor 2010

CommandControls Interface Introduced in Inventor 2010

CommandControls Methods

CommandControls.AddButton Method Introduced in Inventor 2010

CommandControls.AddButtonPopup Method Introduced in Inventor 2010

CommandControls.AddComboBox Method Introduced in Inventor 2010

CommandControls.AddCopy Method

CommandControls.AddGallery Method Introduced in Inventor 2010

CommandControls.AddMacro Method Introduced in Inventor 2010

CommandControls.AddPopup Method Introduced in Inventor 2010

CommandControls.AddSeparator Method Introduced in Inventor 2010

CommandControls.AddSplitButton Method Introduced in Inventor 2010

CommandControls.AddSplitButtonMRU Method Introduced in Inventor 2010

CommandControls.AddTogglePopup Method Introduced in Inventor 2010

CommandControls.Item Method Introduced in Inventor 2010

CommandControls Properties

CommandControls.Application Property Introduced in Inventor 2010

CommandControls.Count Property Introduced in Inventor 2010

CommandControls.Type Property Introduced in Inventor 2010

CommandControlsEnumerator Interface Introduced in Inventor 2010

CommandControlsEnumerator Methods

CommandControlsEnumerator.Item Method Introduced in Inventor 2010

CommandControlsEnumerator Properties

CommandControlsEnumerator.Application Property Introduced in Inventor 2010

CommandControlsEnumerator.Count Property Introduced in Inventor 2010

CommandControlsEnumerator.Type Property Introduced in Inventor 2010

CommandManager Interface Introduced in Inventor 4

CommandManager Methods

CommandManager.ClearPrivateEvents Method Introduced in Inventor 10

CommandManager.CreateDragContext Method Introduced in Inventor 2012

CommandManager.CreateInteractionEvents Method Introduced in Inventor 5

CommandManager.CreateMiniToolbar Method Introduced in Inventor 2012

CommandManager.DoPreSelect Method Introduced in Inventor 5

CommandManager.DoSelect Method Introduced in Inventor 5

CommandManager.DoStopPreSelect Method Introduced in Inventor 5

CommandManager.DoUnSelect Method Introduced in Inventor 5

CommandManager.PeekPrivateEvent Method Introduced in Inventor 10

CommandManager.Pick Method Introduced in Inventor 2011

CommandManager.PostPrivateEvent Method Introduced in Inventor 4

CommandManager.PromptMessage Method Introduced in Inventor 10

CommandManager.StartCommand Method

CommandManager.StartExecutable Method Introduced in Inventor 4

CommandManager.StopActiveCommand Method Introduced in Inventor 4

CommandManager Properties

CommandManager.ActiveCommand Property Introduced in Inventor 4

CommandManager.CommandCategories Property Introduced in Inventor 9

CommandManager.ControlDefinitions Property Introduced in Inventor 9

CommandManager.Parent Property Introduced in Inventor 4

CommandManager.SelectionActive Property Introduced in Inventor 5

CommandManager.Type Property Introduced in Inventor 4

CommandManager.UserInputEvents Property Introduced in Inventor 6

ComponentDefinition Interface Introduced in Inventor 4

ComponentDefinition Methods

ComponentDefinition.FindUsingPoint Method Introduced in Inventor 2009

ComponentDefinition.FindUsingVector Method

ComponentDefinition Properties

ComponentDefinition.Application Property Introduced in Inventor 2010

ComponentDefinition.AttributeSets Property Introduced in Inventor 5

ComponentDefinition.BOMQuantity Property Introduced in Inventor 10

ComponentDefinition.BOMStructure Property Introduced in Inventor 10

ComponentDefinition.ClientGraphicsCollection Property Introduced in Inventor 5

ComponentDefinition.DataIO Property Introduced in Inventor 4

ComponentDefinition.Document Property Introduced in Inventor 4

ComponentDefinition.ModelGeometryVersion Property Introduced in Inventor 5

ComponentDefinition.Occurrences Property Introduced in Inventor 4

ComponentDefinition.RangeBox Property Introduced in Inventor 11

ComponentDefinition.SurfaceBodies Property Introduced in Inventor 4

ComponentDefinition.Type Property Introduced in Inventor 6

ComponentDefinitions Interface Introduced in Inventor 4

ComponentDefinitions Methods

ComponentDefinitions.Item Method Introduced in Inventor 4

ComponentDefinitions Properties

ComponentDefinitions.Count Property Introduced in Inventor 4

ComponentDefinitions.Type Property Introduced in Inventor 4

ComponentDefinitionsEnumerator Interface Introduced in Inventor 10

ComponentDefinitionsEnumerator Methods

ComponentDefinitionsEnumerator.Item Method Introduced in Inventor 10

ComponentDefinitionsEnumerator Properties

ComponentDefinitionsEnumerator.Count Property Introduced in Inventor 10

ComponentDefinitionsEnumerator.Type Property Introduced in Inventor 10

ComponentGraphics Interface Introduced in Inventor 2012

ComponentGraphics Methods

ComponentGraphics.GetCustomLineType Method Introduced in Inventor 2012

ComponentGraphics.GetTransformBehavior Method Introduced in Inventor 2012

ComponentGraphics.SetCustomLineType Method Introduced in Inventor 2012

ComponentGraphics.SetTransformBehavior Method Introduced in Inventor 2012

ComponentGraphics Properties

ComponentGraphics.Body Property Introduced in Inventor 2012

ComponentGraphics.BurnThrough Property Introduced in Inventor 2012

ComponentGraphics.Color Property Introduced in Inventor 2012

ComponentGraphics.DepthPriority Property Introduced in Inventor 2012

ComponentGraphics.DisplayedEdges Property

ComponentGraphics.DisplayedFaces Property

ComponentGraphics.DisplaySilhouettes Property Introduced in Inventor 2012

ComponentGraphics.LineDefinitionSpace Property Introduced in Inventor 2012

ComponentGraphics.LineScale Property Introduced in Inventor 2012

ComponentGraphics.LineType Property Introduced in Inventor 2012

ComponentGraphics.LineWeight Property Introduced in Inventor 2012

ComponentOccurrence Interface Introduced in Inventor 4

ComponentOccurrence Methods

ComponentOccurrence.ChangeRowOfiAssemblyMember Method Introduced in Inventor 11

ComponentOccurrence.ChangeRowOfiPartMember Method Introduced in Inventor 6

ComponentOccurrence.CreateGeometryProxy Method Introduced in Inventor 4

ComponentOccurrence.Delete Method Introduced in Inventor 5

ComponentOccurrence.Edit Method Introduced in Inventor 6

ComponentOccurrence.ExitEdit Method Introduced in Inventor 2008

ComponentOccurrence.GetDegreesOfFreedom Method Introduced in Inventor 2008

ComponentOccurrence.GetDisplayMode Method Introduced in Inventor 10

ComponentOccurrence.GetReferenceKey Method Introduced in Inventor 5

ComponentOccurrence.GetRenderStyle Method Introduced in Inventor 11

ComponentOccurrence.Replace Method Introduced in Inventor 5

ComponentOccurrence.SetDesignViewRepresentation Method Introduced in Inventor 11

ComponentOccurrence.SetDisplayMode Method Introduced in Inventor 10

ComponentOccurrence.SetLevelOfDetailRepresentation Method Introduced in Inventor 11

ComponentOccurrence.SetRenderStyle Method Introduced in Inventor 11

ComponentOccurrence.SetTransformWithoutConstraints Method Introduced in Inventor 5

ComponentOccurrence.Suppress Method Introduced in Inventor 11

ComponentOccurrence.Unsuppress Method Introduced in Inventor 11

ComponentOccurrence Properties

ComponentOccurrence.ActiveDesignViewRepresentation Property Introduced in Inventor 11

ComponentOccurrence.ActiveLevelOfDetailRepresentation Property Introduced in Inventor 11

ComponentOccurrence.ActivePositionalRepresentation Property Introduced in Inventor 11

ComponentOccurrence.Adaptive Property Introduced in Inventor 4

ComponentOccurrence.Application Property

ComponentOccurrence.AttributeSets Property Introduced in Inventor 5

ComponentOccurrence.BOMStructure Property Introduced in Inventor 10

ComponentOccurrence.Constraints Property Introduced in Inventor 4

ComponentOccurrence.ContactSet Property Introduced in Inventor 2010

ComponentOccurrence.ContextDefinition Property Introduced in Inventor 4

ComponentOccurrence.Definition Property Introduced in Inventor 4

ComponentOccurrence.DefinitionDocumentType Property Introduced in Inventor 5.3

ComponentOccurrence.DisabledActionTypes Property Introduced in Inventor 9

ComponentOccurrence.Enabled Property Introduced in Inventor 4

ComponentOccurrence.Excluded Property Introduced in Inventor 2010

ComponentOccurrence.Flexible Property Introduced in Inventor 11

ComponentOccurrence.Grounded Property Introduced in Inventor 4

ComponentOccurrence.HasBodyOverride Property Introduced in Inventor 6

ComponentOccurrence.iMateDefinitions Property Introduced in Inventor 6

ComponentOccurrence.IsiAssemblyMember Property Introduced in Inventor 11

ComponentOccurrence.IsiPartMember Property Introduced in Inventor 6

ComponentOccurrence.IsPatternElement Property Introduced in Inventor 2010

ComponentOccurrence.IsSubstituteOccurrence Property Introduced in Inventor 2009

ComponentOccurrence.MassProperties Property Introduced in Inventor 5

ComponentOccurrence.Name Property Introduced in Inventor 4

ComponentOccurrence.OccurrencePath Property Introduced in Inventor 8

ComponentOccurrence.OverrideOpacity Property Introduced in Inventor 11

ComponentOccurrence.Parent Property

ComponentOccurrence.ParentOccurrence Property Introduced in Inventor 4

ComponentOccurrence.PatternElement Property Introduced in Inventor 5

ComponentOccurrence.RangeBox Property Introduced in Inventor 9

ComponentOccurrence.ReferencedDocumentDescriptor Property Introduced in Inventor 11

ComponentOccurrence.ShowDegreesOfFreedom Property Introduced in Inventor 2008

ComponentOccurrence.SubOccurrences Property Introduced in Inventor 4

ComponentOccurrence.Suppressed Property Introduced in Inventor 11

ComponentOccurrence.SurfaceBodies Property Introduced in Inventor 4

ComponentOccurrence.Transformation Property Introduced in Inventor 4

ComponentOccurrence.Type Property Introduced in Inventor 5

ComponentOccurrence.Visible Property Introduced in Inventor 4

ComponentOccurrenceProxy Interface Introduced in Inventor 4

ComponentOccurrenceProxy Properties

ComponentOccurrenceProxy.ContainingOccurrence Property Introduced in Inventor 4

ComponentOccurrenceProxy.NativeObject Property Introduced in Inventor 4

ComponentOccurrences Interface Introduced in Inventor 4

ComponentOccurrences Methods

ComponentOccurrences.Add Method Introduced in Inventor 4

ComponentOccurrences.AddByComponentDefinition Method Introduced in Inventor 4

ComponentOccurrences.AddCustomiPartMember Method Introduced in Inventor 6

ComponentOccurrences.AddiAssemblyMember Method Introduced in Inventor 11

ComponentOccurrences.AddiPartMember Method Introduced in Inventor 6

ComponentOccurrences.AddUsingiMates Method Introduced in Inventor 6

ComponentOccurrences.AddVirtual Method Introduced in Inventor 10

ComponentOccurrences.AddWithOptions Method Introduced in Inventor 11

ComponentOccurrences.AllLeafOccurrences Method Introduced in Inventor 8

ComponentOccurrences.AllReferencedOccurrences Method Introduced in Inventor 9

ComponentOccurrences.ItemByName Method Introduced in Inventor 8

ComponentOccurrencesEnumerator Interface Introduced in Inventor 4

ComponentOccurrencesEnumerator Methods

ComponentOccurrencesEnumerator.Item Method Introduced in Inventor 4

ComponentOccurrencesEnumerator Properties

ComponentOccurrencesEnumerator.Count Property Introduced in Inventor 4

ComponentOccurrencesEnumerator.Type Property Introduced in Inventor 4

CompositeiMateDefinition Interface Introduced in Inventor 6

CompositeiMateDefinition Methods

CompositeiMateDefinition.Item Method Introduced in Inventor 6

CompositeiMateDefinition.RemoveItems Method Introduced in Inventor 11

CompositeiMateDefinition Properties

CompositeiMateDefinition.Count Property Introduced in Inventor 6

CompositeiMateDefinitionProxy Interface Introduced in Inventor 6

CompositeiMateDefinitionProxy Properties

CompositeiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

CompositeiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

CompositeiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

ConcentricConstraint Interface Introduced in Inventor 5

ConcentricConstraint Properties

ConcentricConstraint.CenterPointConstraint Property Introduced in Inventor 11

ConcentricConstraint.EntityOne Property Introduced in Inventor 5

ConcentricConstraint.EntityTwo Property Introduced in Inventor 5

ConcentricConstraint3D Interface Introduced in Inventor 2010

ConcentricConstraint3DProxy Interface Introduced in Inventor 2010

ConcentricConstraint3DProxy Properties

ConcentricConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 2010

ConcentricConstraint3DProxy.NativeObject Property Introduced in Inventor 2010

ConcentricConstraintProxy Interface Introduced in Inventor 6

ConcentricConstraintProxy Properties

ConcentricConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

ConcentricConstraintProxy.NativeObject Property Introduced in Inventor 6

ConcentricHolePlacementDefinition Interface Introduced in Inventor 10

ConcentricHolePlacementDefinition Properties

ConcentricHolePlacementDefinition.ConcentricReference Property Introduced in Inventor 10

ConcentricHolePlacementDefinition.Plane Property Introduced in Inventor 10

Cone Interface Introduced in Inventor 4

Cone Methods

Cone.GetConeData Method Introduced in Inventor 4

Cone.PutConeData Method Introduced in Inventor 4

Cone Properties

Cone.AxisVector Property Introduced in Inventor 4

Cone.BasePoint Property Introduced in Inventor 4

Cone.Evaluator Property Introduced in Inventor 4

Cone.HalfAngle Property Introduced in Inventor 4

Cone.IsExpanding Property Introduced in Inventor 4

Cone.Radius Property Introduced in Inventor 4

ConstraintLimits Interface Introduced in Inventor 2011

ConstraintLimits Properties

ConstraintLimits.Application Property Introduced in Inventor 2011

ConstraintLimits.Maximum Property Introduced in Inventor 2011

ConstraintLimits.MaximumEnabled Property Introduced in Inventor 2011

ConstraintLimits.Minimum Property Introduced in Inventor 2011

ConstraintLimits.MinimumEnabled Property Introduced in Inventor 2011

ConstraintLimits.Parent Property Introduced in Inventor 2011

ConstraintLimits.RestingPositionEnabled Property Introduced in Inventor 2011

ConstraintLimits.Type Property Introduced in Inventor 2011

ContentCenter Interface Introduced in Inventor 2010

ContentCenter Methods

ContentCenter.GetContentObject Method Introduced in Inventor 2011

ContentCenter Properties

ContentCenter.Application Property Introduced in Inventor 2010

ContentCenter.TreeViewTopNode Property Introduced in Inventor 2010

ContentCenter.Type Property Introduced in Inventor 2010

ContentCenterOptions Interface Introduced in Inventor 2010

ContentCenterOptions Methods

ContentCenterOptions.GetAccessOption Method Introduced in Inventor 2010

ContentCenterOptions.SetAccessOption Method Introduced in Inventor 2010

ContentCenterOptions Properties

ContentCenterOptions.Application Property Introduced in Inventor 2010

ContentCenterOptions.CustomFamilyAsStandard Property

ContentCenterOptions.RefreshOutOfDateStandardParts Property Introduced in Inventor 2010

ContentCenterOptions.Type Property Introduced in Inventor 2010

ContentFamiliesEnumerator Interface Introduced in Inventor 2010

ContentFamiliesEnumerator Methods

ContentFamiliesEnumerator.Item Method Introduced in Inventor 2010

ContentFamiliesEnumerator Properties

ContentFamiliesEnumerator.Application Property Introduced in Inventor 2010

ContentFamiliesEnumerator.Count Property Introduced in Inventor 2010

ContentFamiliesEnumerator.Type Property Introduced in Inventor 2010

ContentFamily Interface Introduced in Inventor 2010

ContentFamily Methods

ContentFamily.CreateMember Method

ContentFamily.GetCustomData Method Introduced in Inventor 2011

ContentFamily.HasCustomData Method Introduced in Inventor 2011

ContentFamily.Save Method Introduced in Inventor 2010

ContentFamily Properties

ContentFamily.ActiveCell Property

ContentFamily.Application Property Introduced in Inventor 2010

ContentFamily.ContentIdentifier Property Introduced in Inventor 2011

ContentFamily.Description Property Introduced in Inventor 2010

ContentFamily.DesignationColumn Property

ContentFamily.DisplayName Property Introduced in Inventor 2010

ContentFamily.FamilyType Property Introduced in Inventor 2011

ContentFamily.FileNameColumn Property

ContentFamily.InternalName Property Introduced in Inventor 2011

ContentFamily.IsCustom Property Introduced in Inventor 2011

ContentFamily.IsModifiable Property Introduced in Inventor 2010

ContentFamily.LibraryInternalName Property Introduced in Inventor 2011

ContentFamily.LibraryName Property Introduced in Inventor 2011

ContentFamily.Manufacturer Property Introduced in Inventor 2010

ContentFamily.MemberDirectory Property Introduced in Inventor 2010

ContentFamily.RevisionId Property

ContentFamily.Standard Property Introduced in Inventor 2010

ContentFamily.StandardOrganization Property Introduced in Inventor 2010

ContentFamily.StandardRevision Property Introduced in Inventor 2010

ContentFamily.TableColumns Property Introduced in Inventor 2010

ContentFamily.TableRows Property Introduced in Inventor 2010

ContentFamily.Thumbnail Property Introduced in Inventor 2010

ContentFamily.Type Property Introduced in Inventor 2010

ContentTableCell Interface Introduced in Inventor 2010

ContentTableCell Properties

ContentTableCell.Application Property Introduced in Inventor 2010

ContentTableCell.Column Property Introduced in Inventor 2010

ContentTableCell.IsOverridden Property Introduced in Inventor 2011

ContentTableCell.Parent Property Introduced in Inventor 2010

ContentTableCell.Row Property Introduced in Inventor 2010

ContentTableCell.Type Property Introduced in Inventor 2010

ContentTableCell.Value Property Introduced in Inventor 2010

ContentTableColumn Interface Introduced in Inventor 2010

ContentTableColumn Methods

ContentTableColumn.ClearPropertyMap Method Introduced in Inventor 2010

ContentTableColumn.GetPropertyMap Method Introduced in Inventor 2010

ContentTableColumn.SetPropertyMap Method Introduced in Inventor 2010

ContentTableColumn Properties

ContentTableColumn.Application Property Introduced in Inventor 2010

ContentTableColumn.DataType Property Introduced in Inventor 2010

ContentTableColumn.DisplayHeading Property Introduced in Inventor 2010

ContentTableColumn.Expression Property Introduced in Inventor 2010

ContentTableColumn.HasPropertyMap Property Introduced in Inventor 2010

ContentTableColumn.InternalName Property Introduced in Inventor 2010

ContentTableColumn.KeyColumnOrder Property Introduced in Inventor 2011

ContentTableColumn.Parent Property Introduced in Inventor 2010

ContentTableColumn.Type Property Introduced in Inventor 2010

ContentTableColumn.Units Property Introduced in Inventor 2010

ContentTableColumns Interface Introduced in Inventor 2010

ContentTableColumns Methods

ContentTableColumns.Add Method Introduced in Inventor 2010

ContentTableColumns.CreateExpressionLimits Method Introduced in Inventor 2010

ContentTableColumns.Item Method Introduced in Inventor 2010

ContentTableColumns Properties

ContentTableColumns.Application Property Introduced in Inventor 2010

ContentTableColumns.Count Property Introduced in Inventor 2010

ContentTableColumns.Type Property Introduced in Inventor 2010

ContentTableRow Interface Introduced in Inventor 2010

ContentTableRow Methods

ContentTableRow.Delete Method Introduced in Inventor 2010

ContentTableRow.GetCellValue Method

ContentTableRow.Item Method Introduced in Inventor 2010

ContentTableRow Properties

ContentTableRow.Application Property Introduced in Inventor 2010

ContentTableRow.ContentIdentifier Property Introduced in Inventor 2011

ContentTableRow.Count Property Introduced in Inventor 2010

ContentTableRow.Index Property Introduced in Inventor 2010

ContentTableRow.InternalName Property Introduced in Inventor 2011

ContentTableRow.IsSuppressed Property Introduced in Inventor 2010

ContentTableRow.Parent Property Introduced in Inventor 2010

ContentTableRow.Type Property Introduced in Inventor 2010

ContentTableRows Interface Introduced in Inventor 2010

ContentTableRows Methods

ContentTableRows.Add Method Introduced in Inventor 2010

ContentTableRows.Item Method Introduced in Inventor 2010

ContentTableRows Properties

ContentTableRows.Application Property Introduced in Inventor 2010

ContentTableRows.Count Property Introduced in Inventor 2010

ContentTableRows.Type Property Introduced in Inventor 2010

ContentTreeViewNode Interface Introduced in Inventor 2010

ContentTreeViewNode Properties

ContentTreeViewNode.Application Property Introduced in Inventor 2010

ContentTreeViewNode.ChildNodes Property Introduced in Inventor 2010

ContentTreeViewNode.DisplayName Property Introduced in Inventor 2010

ContentTreeViewNode.Families Property Introduced in Inventor 2010

ContentTreeViewNode.FullTreeViewPath Property Introduced in Inventor 2010

ContentTreeViewNode.Icon Property Introduced in Inventor 2010

ContentTreeViewNode.InternalName Property Introduced in Inventor 2010

ContentTreeViewNode.ParentNode Property Introduced in Inventor 2010

ContentTreeViewNode.Type Property Introduced in Inventor 2010

ContentTreeViewNodesEnumerator Interface Introduced in Inventor 2010

ContentTreeViewNodesEnumerator Methods

ContentTreeViewNodesEnumerator.Item Method Introduced in Inventor 2010

ContentTreeViewNodesEnumerator Properties

ContentTreeViewNodesEnumerator.Application Property Introduced in Inventor 2010

ContentTreeViewNodesEnumerator.Count Property Introduced in Inventor 2010

ContentTreeViewNodesEnumerator.Type Property Introduced in Inventor 2010

ContourFlangeDefinition Interface Introduced in Inventor 2009

ContourFlangeDefinition Methods

ContourFlangeDefinition.Copy Method Introduced in Inventor 2010

ContourFlangeDefinition.GetWidthExtent Method Introduced in Inventor 2011

ContourFlangeDefinition.GetWidthExtentType Method Introduced in Inventor 2011

ContourFlangeDefinition.SetCenteredDefaultWidthExtent Method Introduced in Inventor 2011

ContourFlangeDefinition.SetCenteredWidthExtent Method

ContourFlangeDefinition.SetDistanceExtent Method Introduced in Inventor 2010

ContourFlangeDefinition.SetEdgeDefaultWidthExtent Method Introduced in Inventor 2011

ContourFlangeDefinition.SetEdgeWidthExtent Method Introduced in Inventor 2010

ContourFlangeDefinition.SetFromToDefaultWidthExtent Method Introduced in Inventor 2011

ContourFlangeDefinition.SetFromToWidthExtent Method

ContourFlangeDefinition.SetOffsetDefaultWidthExtent Method Introduced in Inventor 2011

ContourFlangeDefinition.SetOffsetWidthExtent Method

ContourFlangeDefinition.SetWidthOffsetDefaultWidthExtent Method Introduced in Inventor 2011

ContourFlangeDefinition.SetWidthOffsetWidthExtent Method

ContourFlangeDefinition Properties

ContourFlangeDefinition.Application Property Introduced in Inventor 2009

ContourFlangeDefinition.ApplyAutoMitering Property Introduced in Inventor 2009

ContourFlangeDefinition.BendOptions Property Introduced in Inventor 2009

ContourFlangeDefinition.BendRadius Property Introduced in Inventor 2009

ContourFlangeDefinition.CornerOptions Property Introduced in Inventor 2009

ContourFlangeDefinition.DefaultWidthExtent Property Introduced in Inventor 2011

ContourFlangeDefinition.DefaultWidthExtentType Property Introduced in Inventor 2011

ContourFlangeDefinition.Edges Property Introduced in Inventor 2009

ContourFlangeDefinition.ExtendFaces Property Introduced in Inventor 2010

ContourFlangeDefinition.ExtentDirection Property Introduced in Inventor 2009

ContourFlangeDefinition.IsUnfoldMethodOverridden Property Introduced in Inventor 2011

ContourFlangeDefinition.MiterGap Property Introduced in Inventor 2009

ContourFlangeDefinition.Parent Property Introduced in Inventor 2009

ContourFlangeDefinition.Path Property Introduced in Inventor 2009

ContourFlangeDefinition.Type Property Introduced in Inventor 2009

ContourFlangeDefinition.UnfoldMethod Property Introduced in Inventor 2009

ContourFlangeFeature Interface Introduced in Inventor 5.3

ContourFlangeFeature Properties

ContourFlangeFeature.BendFeature Property Introduced in Inventor 2009

ContourFlangeFeature.Definition Property Introduced in Inventor 2009

ContourFlangeFeatureProxy Interface Introduced in Inventor 9

ContourFlangeFeatures Interface Introduced in Inventor 5.3

ContourFlangeFeatures Methods

ContourFlangeFeatures.Add Method Introduced in Inventor 2010

ContourFlangeFeatures.CreateContourFlangeDefinition Method Introduced in Inventor 2010

ContourFlangeFeatures.Item Method Introduced in Inventor 5.3

ContourFlangeFeatures Properties

ContourFlangeFeatures.Application Property Introduced in Inventor 5.3

ContourFlangeFeatures.Count Property Introduced in Inventor 5.3

ContourFlangeFeatures.Type Property Introduced in Inventor 5.3

ContourRollFeature Interface Introduced in Inventor 2010

ContourRollFeatureProxy Interface Introduced in Inventor 2010

ContourRollFeatures Interface Introduced in Inventor 2010

ContourRollFeatures Methods

ContourRollFeatures.Item Method Introduced in Inventor 2010

ContourRollFeatures Properties

ContourRollFeatures.Application Property Introduced in Inventor 2010

ContourRollFeatures.Count Property Introduced in Inventor 2010

ContourRollFeatures.Type Property Introduced in Inventor 2010

ControlDefinition Interface Introduced in Inventor 6

ControlDefinition Methods

ControlDefinition.AutoAddToGUI Method Introduced in Inventor 6

ControlDefinition.Delete Method Introduced in Inventor 9

ControlDefinition.Execute Method Introduced in Inventor 8

ControlDefinition.Execute2 Method Introduced in Inventor 2008

ControlDefinition Properties

ControlDefinition.Application Property Introduced in Inventor 9

ControlDefinition.BuiltIn Property Introduced in Inventor 9

ControlDefinition.Classification Property Introduced in Inventor 9

ControlDefinition.ClientId Property Introduced in Inventor 9

ControlDefinition.DefaultShortcut Property Introduced in Inventor 2008

ControlDefinition.DefaultShortcutType Property Introduced in Inventor 2008

ControlDefinition.DefinitionType Property Introduced in Inventor 9

ControlDefinition.DescriptionText Property Introduced in Inventor 9

ControlDefinition.DisplayName Property Introduced in Inventor 7

ControlDefinition.Enabled Property Introduced in Inventor 9

ControlDefinition.InternalName Property Introduced in Inventor 7

ControlDefinition.IsShortcutOverridden Property Introduced in Inventor 2008

ControlDefinition.LargeIcon Property Introduced in Inventor 2011

ControlDefinition.OverrideShortcut Property Introduced in Inventor 2008

ControlDefinition.OverrideShortcutType Property Introduced in Inventor 2008

ControlDefinition.Parent Property Introduced in Inventor 9

ControlDefinition.ProgressiveToolTip Property Introduced in Inventor 2011

ControlDefinition.StandardIcon Property Introduced in Inventor 2011

ControlDefinition.ToolTipText Property Introduced in Inventor 9

ControlDefinition.Type Property Introduced in Inventor 6

ControlDefinitionEvents CoClass

ControlDefinitionEventsObject Interface

ControlDefinitionEventsObject Methods

ControlDefinitionEventsObject.FireOnCommandInputs Method

ControlDefinitionEventsObject Properties

ControlDefinitionEventsObject.Application Property

ControlDefinitionEventsObject.Parent Property

ControlDefinitionEventsObject.Type Property

ControlDefinitionEventsSink Interface

ControlDefinitionEventsSink Methods

ControlDefinitionEventsSink.OnCommandInputs Method

ControlDefinitions Interface Introduced in Inventor 6

ControlDefinitions Methods

ControlDefinitions.AddButtonDefinition Method Introduced in Inventor 9

ControlDefinitions.AddComboBoxDefinition Method Introduced in Inventor 9

ControlDefinitions.AddMacroControlDefinition Method Introduced in Inventor 9

ControlDefinitions.Item Method Introduced in Inventor 7

ControlDefinitions Properties

ControlDefinitions.Application Property Introduced in Inventor 7

ControlDefinitions.Count Property Introduced in Inventor 7

ControlDefinitions.Type Property Introduced in Inventor 7

ControlDefinitions.UseDefaultMultiCharAliases Property Introduced in Inventor 2008

CoreCavityDefinition Interface Introduced in Inventor 2011

CoreCavityDefinition Methods

CoreCavityDefinition.Copy Method Introduced in Inventor 2011

CoreCavityDefinition Properties

CoreCavityDefinition.Application Property Introduced in Inventor 2011

CoreCavityDefinition.HolePatches Property Introduced in Inventor 2011

CoreCavityDefinition.Inserts Property Introduced in Inventor 2011

CoreCavityDefinition.Parent Property

CoreCavityDefinition.PartBody Property Introduced in Inventor 2011

CoreCavityDefinition.PullDirection Property Introduced in Inventor 2011

CoreCavityDefinition.RunoffSurfaces Property Introduced in Inventor 2011

CoreCavityDefinition.Tolerance Property Introduced in Inventor 2011

CoreCavityDefinition.Type Property Introduced in Inventor 2011

CoreCavityDefinition.WorkpieceBody Property Introduced in Inventor 2011

CoreCavityFeature Interface

CoreCavityFeature Properties

CoreCavityFeature.Cavity Property

CoreCavityFeature.Core Property

CoreCavityFeature.Definition Property

CoreCavityFeatureProxy Interface

CoreCavityFeatures Interface Introduced in Inventor 2011

CoreCavityFeatures Methods

CoreCavityFeatures.Add Method Introduced in Inventor 2011

CoreCavityFeatures.CreateDefinition Method Introduced in Inventor 2011

CoreCavityFeatures.Item Method Introduced in Inventor 2011

CoreCavityFeatures Properties

CoreCavityFeatures.Application Property Introduced in Inventor 2011

CoreCavityFeatures.Count Property Introduced in Inventor 2011

CoreCavityFeatures.Type Property Introduced in Inventor 2011

CornerChamferDefinition Interface Introduced in Inventor 2009

CornerChamferDefinition Methods

CornerChamferDefinition.Copy Method Introduced in Inventor 2010

CornerChamferDefinition.SetDistance Method Introduced in Inventor 2010

CornerChamferDefinition.SetDistanceAndAngle Method Introduced in Inventor 2010

CornerChamferDefinition.SetTwoDistances Method Introduced in Inventor 2010

CornerChamferDefinition Properties

CornerChamferDefinition.Application Property Introduced in Inventor 2009

CornerChamferDefinition.ChamferDefinition Property Introduced in Inventor 2009

CornerChamferDefinition.ChamferDefinitionType Property Introduced in Inventor 2009

CornerChamferDefinition.CornerEdges Property Introduced in Inventor 2009

CornerChamferDefinition.Parent Property Introduced in Inventor 2009

CornerChamferDefinition.Type Property Introduced in Inventor 2009

CornerChamferFeature Interface Introduced in Inventor 5.3

CornerChamferFeature Properties

CornerChamferFeature.Definition Property Introduced in Inventor 2009

CornerChamferFeatureProxy Interface Introduced in Inventor 9

CornerChamferFeatures Interface Introduced in Inventor 5.3

CornerChamferFeatures Methods

CornerChamferFeatures.Add Method Introduced in Inventor 2010

CornerChamferFeatures.CreateCornerChamferDefinition Method Introduced in Inventor 2010

CornerChamferFeatures.Item Method Introduced in Inventor 5.3

CornerChamferFeatures Properties

CornerChamferFeatures.Application Property Introduced in Inventor 5.3

CornerChamferFeatures.Count Property Introduced in Inventor 5.3

CornerChamferFeatures.Type Property Introduced in Inventor 5.3

CornerDefinition Interface Introduced in Inventor 2009

CornerDefinition Methods

CornerDefinition.Copy Method Introduced in Inventor 2010

CornerDefinition Properties

CornerDefinition.AlignedCornerExtension Property Introduced in Inventor 2010

CornerDefinition.Application Property Introduced in Inventor 2009

CornerDefinition.BendOptions Property Introduced in Inventor 2009

CornerDefinition.CornerDefinitionType Property Introduced in Inventor 2010

CornerDefinition.CornerOptions Property Introduced in Inventor 2009

CornerDefinition.CornerType Property Introduced in Inventor 2009

CornerDefinition.Edges Property Introduced in Inventor 2009

CornerDefinition.GapWidth Property Introduced in Inventor 2009

CornerDefinition.IsRippedCorner Property Introduced in Inventor 2009

CornerDefinition.Parent Property Introduced in Inventor 2009

CornerDefinition.PercentOverlap Property Introduced in Inventor 2010

CornerDefinition.Type Property Introduced in Inventor 2009

CornerFeature Interface Introduced in Inventor 5.3

CornerFeature Properties

CornerFeature.Definition Property Introduced in Inventor 2009

CornerFeatureProxy Interface Introduced in Inventor 9

CornerFeatures Interface Introduced in Inventor 5.3

CornerFeatures Methods

CornerFeatures.Add Method Introduced in Inventor 2010

CornerFeatures.CreateCornerDefinition Method Introduced in Inventor 2010

CornerFeatures.Item Method Introduced in Inventor 5.3

CornerFeatures Properties

CornerFeatures.Application Property Introduced in Inventor 5.3

CornerFeatures.Count Property Introduced in Inventor 5.3

CornerFeatures.Type Property Introduced in Inventor 5.3

CornerOptions Interface Introduced in Inventor 2009

CornerOptions Methods

CornerOptions.Copy Method Introduced in Inventor 2010

CornerOptions Properties

CornerOptions.CornerReliefShape Property Introduced in Inventor 2009

CornerOptions.CornerReliefSize Property Introduced in Inventor 2009

CornerOptions.IsTwoBend Property Introduced in Inventor 2009

CornerOptions.Parent Property Introduced in Inventor 2009

CornerOptions.Type Property Introduced in Inventor 2009

CornerRoundDefinition Interface Introduced in Inventor 2009

CornerRoundDefinition Methods

CornerRoundDefinition.AddEdgeSet Method Introduced in Inventor 2010

CornerRoundDefinition.Copy Method Introduced in Inventor 2010

CornerRoundDefinition.EdgeSetItem Method Introduced in Inventor 2009

CornerRoundDefinition.RemoveEdgeSet Method Introduced in Inventor 2010

CornerRoundDefinition Properties

CornerRoundDefinition.Application Property Introduced in Inventor 2009

CornerRoundDefinition.EdgeSetCount Property Introduced in Inventor 2009

CornerRoundDefinition.Parent Property Introduced in Inventor 2009

CornerRoundDefinition.Type Property Introduced in Inventor 2009

CornerRoundEdgeSet Interface Introduced in Inventor 2009

CornerRoundEdgeSet Properties

CornerRoundEdgeSet.Edges Property Introduced in Inventor 2009

CornerRoundEdgeSet.Parent Property Introduced in Inventor 2009

CornerRoundEdgeSet.Radius Property Introduced in Inventor 2009

CornerRoundEdgeSet.Type Property Introduced in Inventor 2009

CornerRoundFeature Interface Introduced in Inventor 5.3

CornerRoundFeature Properties

CornerRoundFeature.Definition Property Introduced in Inventor 2009

CornerRoundFeatureProxy Interface Introduced in Inventor 9

CornerRoundFeatures Interface Introduced in Inventor 5.3

CornerRoundFeatures Methods

CornerRoundFeatures.Add Method Introduced in Inventor 2010

CornerRoundFeatures.CreateCornerRoundDefinition Method Introduced in Inventor 2010

CornerRoundFeatures.Item Method Introduced in Inventor 5.3

CornerRoundFeatures Properties

CornerRoundFeatures.Application Property Introduced in Inventor 5.3

CornerRoundFeatures.Count Property Introduced in Inventor 5.3

CornerRoundFeatures.Type Property Introduced in Inventor 5.3

CosmeticBendFeature Interface Introduced in Inventor 2010

CosmeticBendFeatureProxy Interface Introduced in Inventor 2010

CosmeticBendFeatures Interface Introduced in Inventor 2010

CosmeticBendFeatures Methods

CosmeticBendFeatures.Item Method Introduced in Inventor 2010

CosmeticBendFeatures Properties

CosmeticBendFeatures.Application Property Introduced in Inventor 2010

CosmeticBendFeatures.Count Property Introduced in Inventor 2010

CosmeticBendFeatures.Type Property Introduced in Inventor 2010

CosmeticWeld Interface Introduced in Inventor 8

CosmeticWeld Properties

CosmeticWeld.Edges Property Introduced in Inventor 2012

CosmeticWelds Interface Introduced in Inventor 8

CosmeticWelds Methods

CosmeticWelds.Item Method Introduced in Inventor 8

CosmeticWelds Properties

CosmeticWelds.Application Property Introduced in Inventor 8

CosmeticWelds.Count Property Introduced in Inventor 8

CosmeticWelds.Type Property Introduced in Inventor 8

Curve2dEvaluator Interface Introduced in Inventor 4

Curve2dEvaluator Methods

Curve2dEvaluator.GetCurvature Method Introduced in Inventor 4

Curve2dEvaluator.GetEndPoints Method Introduced in Inventor 4

Curve2dEvaluator.GetFirstDerivatives Method Introduced in Inventor 4

Curve2dEvaluator.GetLengthAtParam Method Introduced in Inventor 4

Curve2dEvaluator.GetParamAnomaly Method Introduced in Inventor 4

Curve2dEvaluator.GetParamAtLength Method Introduced in Inventor 4

Curve2dEvaluator.GetParamAtPoint Method Introduced in Inventor 4

Curve2dEvaluator.GetParamExtents Method Introduced in Inventor 4

Curve2dEvaluator.GetPointAtParam Method Introduced in Inventor 4

Curve2dEvaluator.GetSecondDerivatives Method Introduced in Inventor 4

Curve2dEvaluator.GetTangent Method Introduced in Inventor 4

Curve2dEvaluator.GetThirdDerivatives Method Introduced in Inventor 4

Curve2dEvaluator Properties

Curve2dEvaluator.Continuity Property Introduced in Inventor 4

Curve2dEvaluator.RangeBox Property Introduced in Inventor 4

CurveAndEntityWorkPointDef Interface Introduced in Inventor 6

CurveAndEntityWorkPointDef Methods

CurveAndEntityWorkPointDef.GetData Method Introduced in Inventor 6

CurveAndEntityWorkPointDef Properties

CurveAndEntityWorkPointDef.Application Property Introduced in Inventor 6

CurveAndEntityWorkPointDef.CurveEntity Property Introduced in Inventor 6

CurveAndEntityWorkPointDef.Entity Property Introduced in Inventor 6

CurveAndEntityWorkPointDef.Parent Property Introduced in Inventor 6

CurveAndEntityWorkPointDef.Type Property Introduced in Inventor 6

CurveEvaluator Interface Introduced in Inventor 4

CurveEvaluator Methods

CurveEvaluator.GetCurvature Method Introduced in Inventor 4

CurveEvaluator.GetEndPoints Method Introduced in Inventor 4

CurveEvaluator.GetFirstDerivatives Method Introduced in Inventor 4

CurveEvaluator.GetLengthAtParam Method Introduced in Inventor 4

CurveEvaluator.GetParamAnomaly Method Introduced in Inventor 4

CurveEvaluator.GetParamAtLength Method Introduced in Inventor 4

CurveEvaluator.GetParamAtPoint Method Introduced in Inventor 4

CurveEvaluator.GetParamExtents Method Introduced in Inventor 4

CurveEvaluator.GetPointAtParam Method Introduced in Inventor 4

CurveEvaluator.GetSecondDerivatives Method Introduced in Inventor 4

CurveEvaluator.GetTangent Method Introduced in Inventor 4

CurveEvaluator.GetThirdDerivatives Method Introduced in Inventor 4

CurveEvaluator Properties

CurveEvaluator.Continuity Property Introduced in Inventor 4

CurveEvaluator.RangeBox Property Introduced in Inventor 4

CurveGraphics Interface Introduced in Inventor 2008

CurveGraphics Methods

CurveGraphics.GetCustomLineType Method Introduced in Inventor 2008

CurveGraphics.GetTransformBehavior Method Introduced in Inventor 2008

CurveGraphics.SetCustomLineType Method Introduced in Inventor 2008

CurveGraphics.SetTransformBehavior Method Introduced in Inventor 2008

CurveGraphics Properties

CurveGraphics.BurnThrough Property Introduced in Inventor 2008

CurveGraphics.Color Property Introduced in Inventor 2008

CurveGraphics.Curve Property Introduced in Inventor 2008

CurveGraphics.CurveType Property Introduced in Inventor 2008

CurveGraphics.DepthPriority Property Introduced in Inventor 2008

CurveGraphics.LineDefinitionSpace Property Introduced in Inventor 2008

CurveGraphics.LineScale Property Introduced in Inventor 2008

CurveGraphics.LineType Property Introduced in Inventor 2008

CurveGraphics.LineWeight Property Introduced in Inventor 2008

CustomConstraint Interface

CustomConstraint Properties

CustomConstraint.ClientId Property

CustomConstraint3D Interface Introduced in Inventor 11

CustomConstraint3D Properties

CustomConstraint3D.ClientId Property Introduced in Inventor 11

CustomConstraint3D.Entity Property Introduced in Inventor 11

CustomConstraint3DProxy Interface Introduced in Inventor 11

CustomConstraint3DProxy Properties

CustomConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 11

CustomConstraint3DProxy.NativeObject Property Introduced in Inventor 11

CustomConstraintProxy Interface

CustomConstraintProxy Properties

CustomConstraintProxy.ContainingOccurrence Property

CustomConstraintProxy.NativeObject Property

CustomParameterGroup Interface Introduced in Inventor 10

CustomParameterGroup Methods

CustomParameterGroup.Add Method Introduced in Inventor 10

CustomParameterGroup.Delete Method Introduced in Inventor 10

CustomParameterGroup.Item Method Introduced in Inventor 10

CustomParameterGroup.Remove Method Introduced in Inventor 10

CustomParameterGroup Properties

CustomParameterGroup.Application Property Introduced in Inventor 10

CustomParameterGroup.ClientId Property Introduced in Inventor 10

CustomParameterGroup.Count Property Introduced in Inventor 10

CustomParameterGroup.DisabledActionTypes Property Introduced in Inventor 10

CustomParameterGroup.DisplayName Property Introduced in Inventor 10

CustomParameterGroup.InternalName Property Introduced in Inventor 10

CustomParameterGroup.Type Property Introduced in Inventor 10

CustomParameterGroups Interface Introduced in Inventor 10

CustomParameterGroups Methods

CustomParameterGroups.Add Method Introduced in Inventor 10

CustomParameterGroups.Item Method Introduced in Inventor 10

CustomParameterGroups Properties

CustomParameterGroups.Application Property Introduced in Inventor 10

CustomParameterGroups.Count Property Introduced in Inventor 10

CustomParameterGroups.Type Property Introduced in Inventor 10

CustomPropertyFormat Interface Introduced in Inventor 2010

CustomPropertyFormat Properties

CustomPropertyFormat.Application Property Introduced in Inventor 2010

CustomPropertyFormat.Parent Property Introduced in Inventor 2010

CustomPropertyFormat.Precision Property Introduced in Inventor 2010

CustomPropertyFormat.PropertyType Property Introduced in Inventor 2010

CustomPropertyFormat.ShowLeadingZeros Property Introduced in Inventor 2010

CustomPropertyFormat.ShowTrailingZeros Property Introduced in Inventor 2010

CustomPropertyFormat.ShowUnitsString Property Introduced in Inventor 2010

CustomPropertyFormat.Type Property Introduced in Inventor 2010

CustomPropertyFormat.Units Property Introduced in Inventor 2010

CustomTable Interface Introduced in Inventor 9

CustomTable Methods

CustomTable.AddLink Method Introduced in Inventor 2008

CustomTable.CopyTo Method Introduced in Inventor 2011

CustomTable.Delete Method Introduced in Inventor 9

CustomTable.Export Method Introduced in Inventor 2009

CustomTable.GetReferenceKey Method Introduced in Inventor 9

CustomTable.Renumber Method Introduced in Inventor 2009

CustomTable.Sort Method Introduced in Inventor 2009

CustomTable.Update Method Introduced in Inventor 2010

CustomTable Properties

CustomTable.Application Property Introduced in Inventor 9

CustomTable.AttributeSets Property Introduced in Inventor 9

CustomTable.BendDirectionReversed Property Introduced in Inventor 2009

CustomTable.ColumnHeaderTextStyle Property Introduced in Inventor 2009

CustomTable.Columns Property Introduced in Inventor 9

CustomTable.DataTextStyle Property Introduced in Inventor 2009

CustomTable.HeadingPlacement Property Introduced in Inventor 9

CustomTable.Layer Property Introduced in Inventor 10

CustomTable.MaximumRows Property Introduced in Inventor 2009

CustomTable.NumberOfSections Property Introduced in Inventor 2009

CustomTable.OverrideFormat Property Introduced in Inventor 9

CustomTable.Parent Property Introduced in Inventor 9

CustomTable.Position Property Introduced in Inventor 9

CustomTable.RangeBox Property Introduced in Inventor 9

CustomTable.ReferencedDocumentDescriptor Property Introduced in Inventor 2008

CustomTable.Rotation Property Introduced in Inventor 2009

CustomTable.RowGap Property Introduced in Inventor 2009

CustomTable.RowLineSpacing Property Introduced in Inventor 2009

CustomTable.Rows Property Introduced in Inventor 9

CustomTable.ShowTitle Property Introduced in Inventor 2009

CustomTable.Style Property Introduced in Inventor 2011

CustomTable.TableDirection Property Introduced in Inventor 2009

CustomTable.TableSource Property Introduced in Inventor 2009

CustomTable.Title Property Introduced in Inventor 9

CustomTable.TitleTextStyle Property Introduced in Inventor 2009

CustomTable.Type Property Introduced in Inventor 9

CustomTable.WrapAutomatically Property Introduced in Inventor 2009

CustomTable.WrapLeft Property Introduced in Inventor 2009

CustomTables Interface Introduced in Inventor 9

CustomTables Methods

CustomTables.Add Method Introduced in Inventor 9

CustomTables.AddBendTable Method Introduced in Inventor 2009

CustomTables.AddConfigurationTable Method Introduced in Inventor 2009

CustomTables.AddCSVTable Method Introduced in Inventor 2009

CustomTables.AddExcelTable Method Introduced in Inventor 2009

CustomTables.CreateTableFormat Method Introduced in Inventor 9

CustomTables.Item Method Introduced in Inventor 9

CustomTables Properties

CustomTables.Application Property Introduced in Inventor 9

CustomTables.Count Property Introduced in Inventor 9

CustomTables.Type Property Introduced in Inventor 9

CutAcrossBendsExtent Interface Introduced in Inventor 2009

CutAcrossBendsExtent Properties

CutAcrossBendsExtent.Distance Property Introduced in Inventor 2009

CutDefinition Interface Introduced in Inventor 2009

CutDefinition Methods

CutDefinition.SetCutAcrossBendsExtent Method Introduced in Inventor 2009

CutDefinition.SetDistanceExtent Method Introduced in Inventor 2009

CutDefinition.SetFromToExtent Method Introduced in Inventor 2009

CutDefinition.SetThroughAllExtent Method Introduced in Inventor 2009

CutDefinition.SetToExtent Method Introduced in Inventor 2009

CutDefinition.SetToNextExtent Method Introduced in Inventor 2009

CutDefinition Properties

CutDefinition.Application Property Introduced in Inventor 2009

CutDefinition.CutAcrossBends Property Introduced in Inventor 2009

CutDefinition.Extent Property Introduced in Inventor 2009

CutDefinition.ExtentType Property Introduced in Inventor 2009

CutDefinition.Parent Property Introduced in Inventor 2009

CutDefinition.Profile Property Introduced in Inventor 2009

CutDefinition.Type Property Introduced in Inventor 2009

CutFeature Interface Introduced in Inventor 5.3

CutFeature Properties

CutFeature.Definition Property Introduced in Inventor 2009

CutFeatureProxy Interface Introduced in Inventor 9

CutFeatures Interface Introduced in Inventor 5.3

CutFeatures Methods

CutFeatures.Add Method Introduced in Inventor 2009

CutFeatures.CreateCutDefinition Method Introduced in Inventor 2009

CutFeatures.Item Method Introduced in Inventor 5.3

CutFeatures Properties

CutFeatures.Application Property Introduced in Inventor 5.3

CutFeatures.Count Property Introduced in Inventor 5.3

CutFeatures.Type Property Introduced in Inventor 5.3

Cylinder Interface Introduced in Inventor 4

Cylinder Methods

Cylinder.GetCylinderData Method Introduced in Inventor 4

Cylinder.PutCylinderData Method Introduced in Inventor 4

Cylinder Properties

Cylinder.AxisVector Property Introduced in Inventor 4

Cylinder.BasePoint Property Introduced in Inventor 4

Cylinder.Evaluator Property Introduced in Inventor 4

Cylinder.Radius Property Introduced in Inventor 4

DataIO Interface Introduced in Inventor 4

DataIO Methods

DataIO.GetInputFormats Method Introduced in Inventor 4

DataIO.GetOutputFormats Method Introduced in Inventor 4

DataIO.ReadDataFromFile Method Introduced in Inventor 4

DataIO.ReadDataFromStream Method Introduced in Inventor 4

DataIO.WriteDataToFile Method Introduced in Inventor 4

DataIO.WriteDataToStream Method Introduced in Inventor 4

DataMedium Interface Introduced in Inventor 4

DataMedium Properties

DataMedium.FileName Property Introduced in Inventor 4

DataMedium.IDataObject Property Introduced in Inventor 5.3

DataMedium.MediumType Property Introduced in Inventor 11

DataMedium.Stream Property Introduced in Inventor 4

DataMedium.String Property Introduced in Inventor 11

DecalFeature Interface Introduced in Inventor 6

DecalFeature Properties

DecalFeature.ChainFaces Property Introduced in Inventor 2008

DecalFeature.Face Property Introduced in Inventor 2008

DecalFeature.Image Property Introduced in Inventor 2008

DecalFeature.WrapFace Property Introduced in Inventor 2008

DecalFeatureProxy Interface Introduced in Inventor 9

DecalFeatureProxy Properties

DecalFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

DecalFeatureProxy.NativeObject Property Introduced in Inventor 9

DecalFeatures Interface Introduced in Inventor 6

DecalFeatures Methods

DecalFeatures.Add Method Introduced in Inventor 2008

DecalFeatures.Item Method Introduced in Inventor 6

DecalFeatures Properties

DecalFeatures.Application Property Introduced in Inventor 6

DecalFeatures.Count Property Introduced in Inventor 6

DecalFeatures.Type Property Introduced in Inventor 6

DefaultBorder Interface Introduced in Inventor 5.3

DefaultBorder Properties

DefaultBorder.BottomMargin Property Introduced in Inventor 5.3

DefaultBorder.Centermarks Property Introduced in Inventor 2008

DefaultBorder.DelimitZonesByLines Property Introduced in Inventor 5.3

DefaultBorder.HorizontalZoneCount Property Introduced in Inventor 5.3

DefaultBorder.HorizontalZoneLabelMode Property Introduced in Inventor 5.3

DefaultBorder.LabelFromBottomRight Property Introduced in Inventor 5.3

DefaultBorder.LeftMargin Property Introduced in Inventor 5.3

DefaultBorder.RightMargin Property Introduced in Inventor 5.3

DefaultBorder.TopMargin Property Introduced in Inventor 5.3

DefaultBorder.VerticalZoneCount Property Introduced in Inventor 5.3

DefaultBorder.VerticalZoneLabelMode Property Introduced in Inventor 5.3

DeleteFaceFeature Interface Introduced in Inventor 6

DeleteFaceFeature Properties

DeleteFaceFeature.InputFaces Property Introduced in Inventor 9

DeleteFaceFeatureProxy Interface Introduced in Inventor 9

DeleteFaceFeatureProxy Properties

DeleteFaceFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

DeleteFaceFeatureProxy.NativeObject Property Introduced in Inventor 9

DeleteFaceFeatures Interface Introduced in Inventor 6

DeleteFaceFeatures Methods

DeleteFaceFeatures.Add Method Introduced in Inventor 9

DeleteFaceFeatures.Item Method Introduced in Inventor 6

DeleteFaceFeatures Properties

DeleteFaceFeatures.Application Property Introduced in Inventor 6

DeleteFaceFeatures.Count Property Introduced in Inventor 6

DeleteFaceFeatures.Type Property Introduced in Inventor 6

DerivedAliasComponent Interface Introduced in Inventor 2010

DerivedAliasComponent Properties

DerivedAliasComponent.ResultFeatures Property Introduced in Inventor 2010

DerivedAliasComponentProxy Interface Introduced in Inventor 2010

DerivedAliasComponentProxy Properties

DerivedAliasComponentProxy.ContainingOccurrence Property Introduced in Inventor 2010

DerivedAliasComponentProxy.NativeObject Property Introduced in Inventor 2010

DerivedAliasComponents Interface Introduced in Inventor 2010

DerivedAliasComponents Methods

DerivedAliasComponents.Item Method Introduced in Inventor 2010

DerivedAliasComponents Properties

DerivedAliasComponents.Application Property Introduced in Inventor 2010

DerivedAliasComponents.Count Property Introduced in Inventor 2010

DerivedAliasComponents.Parent Property Introduced in Inventor 2010

DerivedAliasComponents.Type Property Introduced in Inventor 2010

DerivedAssemblyComponent Interface Introduced in Inventor 5.3

DerivedAssemblyComponent Properties

DerivedAssemblyComponent.Definition Property Introduced in Inventor 5.3

DerivedAssemblyComponent.ReferenceFeatures Property Introduced in Inventor 5.3

DerivedAssemblyComponent.SuppressAll Property Introduced in Inventor 5.3

DerivedAssemblyComponent.SuppressLinkToFile Property Introduced in Inventor 11

DerivedAssemblyComponentProxy Interface Introduced in Inventor 2008

DerivedAssemblyComponentProxy Properties

DerivedAssemblyComponentProxy.ContainingOccurrence Property Introduced in Inventor 2008

DerivedAssemblyComponentProxy.NativeObject Property Introduced in Inventor 2008

DerivedAssemblyComponents Interface Introduced in Inventor 5.3

DerivedAssemblyComponents Methods

DerivedAssemblyComponents.Add Method Introduced in Inventor 5.3

DerivedAssemblyComponents.CreateDefinition Method Introduced in Inventor 5.3

DerivedAssemblyComponents.Item Method Introduced in Inventor 5.3

DerivedAssemblyComponents Properties

DerivedAssemblyComponents.Application Property Introduced in Inventor 5.3

DerivedAssemblyComponents.Count Property Introduced in Inventor 5.3

DerivedAssemblyComponents.Parent Property Introduced in Inventor 5.3

DerivedAssemblyComponents.Type Property Introduced in Inventor 5.3

DerivedAssemblyDefinition Interface Introduced in Inventor 5.3

DerivedAssemblyDefinition Methods

DerivedAssemblyDefinition.GetHolePatchingOptions Method Introduced in Inventor 2011

DerivedAssemblyDefinition.GetRemoveBySizeOptions Method Introduced in Inventor 2011

DerivedAssemblyDefinition.GetRemoveByVisibilityOptions Method Introduced in Inventor 2011

DerivedAssemblyDefinition.IncludeAllSketches Method

DerivedAssemblyDefinition.IncludeAllWorkFeatures Method

DerivedAssemblyDefinition.SetHolePatchingOptions Method Introduced in Inventor 2011

DerivedAssemblyDefinition.SetRemoveBySizeOptions Method Introduced in Inventor 2011

DerivedAssemblyDefinition.SetRemoveByVisibilityOptions Method Introduced in Inventor 2011

DerivedAssemblyDefinition Properties

DerivedAssemblyDefinition.ActiveDesignViewRepresentation Property Introduced in Inventor 11

DerivedAssemblyDefinition.ActiveLevelOfDetailRepresentation Property Introduced in Inventor 11

DerivedAssemblyDefinition.ActivePositionalRepresentation Property Introduced in Inventor 11

DerivedAssemblyDefinition.Application Property Introduced in Inventor 5.3

DerivedAssemblyDefinition.DeriveStyle Property Introduced in Inventor 2010

DerivedAssemblyDefinition.IncludeAllTopLeveliMateDefinitions Property Introduced in Inventor 2011

DerivedAssemblyDefinition.IncludeAllTopLevelParameters Property Introduced in Inventor 2011

DerivedAssemblyDefinition.IncludeAllTopLevelSketches Property Introduced in Inventor 2011

DerivedAssemblyDefinition.IncludeAllTopLevelWorkFeatures Property Introduced in Inventor 2011

DerivedAssemblyDefinition.InclusionOption Property Introduced in Inventor 5.3

DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean Property

DerivedAssemblyDefinition.MirrorPlane Property Introduced in Inventor 2009

DerivedAssemblyDefinition.Occurrences Property Introduced in Inventor 5.3

DerivedAssemblyDefinition.ReducedMemoryMode Property Introduced in Inventor 2009

DerivedAssemblyDefinition.ScaleFactor Property Introduced in Inventor 2009

DerivedAssemblyDefinition.Type Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence Interface Introduced in Inventor 5.3

DerivedAssemblyOccurrence Properties

DerivedAssemblyOccurrence.Application Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence.FailedBooleanOperation Property

DerivedAssemblyOccurrence.InclusionOption Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence.IsAssembly Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence.Name Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence.ReferencedOccurrence Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence.SubOccurrences Property Introduced in Inventor 5.3

DerivedAssemblyOccurrence.Type Property Introduced in Inventor 5.3

DerivedAssemblyOccurrences Interface Introduced in Inventor 5.3

DerivedAssemblyOccurrences Methods

DerivedAssemblyOccurrences.Item Method Introduced in Inventor 5.3

DerivedAssemblyOccurrences Properties

DerivedAssemblyOccurrences.Application Property Introduced in Inventor 5.3

DerivedAssemblyOccurrences.Count Property Introduced in Inventor 5.3

DerivedAssemblyOccurrences.Type Property Introduced in Inventor 5.3

DerivedParameter Interface Introduced in Inventor 11

DerivedParameter Properties

DerivedParameter.ReferencedEntity Property Introduced in Inventor 11

DerivedParameters Interface Introduced in Inventor 11

DerivedParameters Methods

DerivedParameters.Item Method Introduced in Inventor 11

DerivedParameters Properties

DerivedParameters.Count Property Introduced in Inventor 11

DerivedParameters.Type Property Introduced in Inventor 11

DerivedParameterTable Interface Introduced in Inventor 11

DerivedParameterTable Methods

DerivedParameterTable.Delete Method Introduced in Inventor 11

DerivedParameterTable.GetReferenceKey Method Introduced in Inventor 2008

DerivedParameterTable Properties

DerivedParameterTable.AttributeSets Property Introduced in Inventor 2008

DerivedParameterTable.DerivedParameters Property Introduced in Inventor 11

DerivedParameterTable.HasReferenceComponent Property Introduced in Inventor 11

DerivedParameterTable.LinkedParameters Property Introduced in Inventor 2008

DerivedParameterTable.Parent Property Introduced in Inventor 11

DerivedParameterTable.ReferenceComponent Property Introduced in Inventor 11

DerivedParameterTable.ReferencedDocumentDescriptor Property Introduced in Inventor 11

DerivedParameterTable.Type Property Introduced in Inventor 11

DerivedParameterTables Interface Introduced in Inventor 11

DerivedParameterTables Methods

DerivedParameterTables.Add Method Introduced in Inventor 11

DerivedParameterTables.Add2 Method Introduced in Inventor 2008

DerivedParameterTables.Item Method Introduced in Inventor 11

DerivedParameterTables Properties

DerivedParameterTables.Count Property Introduced in Inventor 11

DerivedParameterTables.Type Property Introduced in Inventor 11

DerivedPartComponent Interface Introduced in Inventor 5.3

DerivedPartComponent Properties

DerivedPartComponent.Definition Property Introduced in Inventor 5.3

DerivedPartComponent.iMateDefinitions Property Introduced in Inventor 2010

DerivedPartComponent.Parameters Property Introduced in Inventor 5.3

DerivedPartComponent.SketchBlockDefinitions Property Introduced in Inventor 2010

DerivedPartComponent.SketchBlocks Property Introduced in Inventor 2010

DerivedPartComponent.Sketches Property Introduced in Inventor 5.3

DerivedPartComponent.Sketches3D Property Introduced in Inventor 2009

DerivedPartComponent.SolidBodies Property Introduced in Inventor 2010

DerivedPartComponent.SuppressLinkToFile Property Introduced in Inventor 11

DerivedPartComponent.SurfaceBodies Property Introduced in Inventor 5.3

DerivedPartComponent.WorkFeatures Property Introduced in Inventor 5.3

DerivedPartComponentProxy Interface Introduced in Inventor 2008

DerivedPartComponentProxy Properties

DerivedPartComponentProxy.ContainingOccurrence Property Introduced in Inventor 2008

DerivedPartComponentProxy.NativeObject Property Introduced in Inventor 2008

DerivedPartComponents Interface Introduced in Inventor 5.3

DerivedPartComponents Methods

DerivedPartComponents.Add Method Introduced in Inventor 5.3

DerivedPartComponents.CreateCoordinateSystemDef Method Introduced in Inventor 6

DerivedPartComponents.CreateDefinition Method

DerivedPartComponents.CreateTransformDef Method Introduced in Inventor 6

DerivedPartComponents.CreateUniformScaleDef Method Introduced in Inventor 6

DerivedPartComponents.Item Method Introduced in Inventor 5.3

DerivedPartComponents Properties

DerivedPartComponents.Application Property Introduced in Inventor 5.3

DerivedPartComponents.Count Property Introduced in Inventor 5.3

DerivedPartComponents.Parent Property Introduced in Inventor 5.3

DerivedPartComponents.Type Property Introduced in Inventor 5.3

DerivedPartCoordinateSystemDef Interface Introduced in Inventor 6

DerivedPartCoordinateSystemDef Methods

DerivedPartCoordinateSystemDef.GetCoordinateSystem Method Introduced in Inventor 6

DerivedPartCoordinateSystemDef.GetScale Method Introduced in Inventor 6

DerivedPartCoordinateSystemDef.SetCoordinateSystem Method Introduced in Inventor 6

DerivedPartCoordinateSystemDef.SetScale Method Introduced in Inventor 6

DerivedPartCoordinateSystemDef Properties

DerivedPartCoordinateSystemDef.MirrorPlane Property Introduced in Inventor 6

DerivedPartDefinition Interface Introduced in Inventor 5.3

DerivedPartDefinition Methods

DerivedPartDefinition.ExcludeAll Method Introduced in Inventor 5.3

DerivedPartDefinition.IncludeAll Method Introduced in Inventor 5.3

DerivedPartDefinition Properties

DerivedPartDefinition.ActiveDesignViewRepresentation Property Introduced in Inventor 2012

DerivedPartDefinition.Application Property Introduced in Inventor 5.3

DerivedPartDefinition.DeriveStyle Property Introduced in Inventor 2010

DerivedPartDefinition.iMateDefinitions Property Introduced in Inventor 2009

DerivedPartDefinition.IncludeAlliMateDefinitions Property Introduced in Inventor 2010

DerivedPartDefinition.IncludeAllParameters Property Introduced in Inventor 5.3

DerivedPartDefinition.IncludeAllSolids Property Introduced in Inventor 2010

DerivedPartDefinition.IncludeAllSurfaces Property Introduced in Inventor 5.3

DerivedPartDefinition.Parameters Property Introduced in Inventor 2009

DerivedPartDefinition.ReducedMemoryMode Property

DerivedPartDefinition.Solids Property Introduced in Inventor 2010

DerivedPartDefinition.Surfaces Property Introduced in Inventor 5.3

DerivedPartDefinition.Type Property Introduced in Inventor 5.3

DerivedPartDefinition.UseColorOverridesFromSource Property

DerivedPartEntities Interface Introduced in Inventor 5.3

DerivedPartEntities Methods

DerivedPartEntities.Item Method Introduced in Inventor 5.3

DerivedPartEntities Properties

DerivedPartEntities.Application Property Introduced in Inventor 5.3

DerivedPartEntities.Count Property Introduced in Inventor 5.3

DerivedPartEntities.Type Property Introduced in Inventor 5.3

DerivedPartEntity Interface Introduced in Inventor 5.3

DerivedPartEntity Properties

DerivedPartEntity.Application Property Introduced in Inventor 5.3

DerivedPartEntity.IncludeEntity Property Introduced in Inventor 5.3

DerivedPartEntity.ReferencedEntity Property Introduced in Inventor 5.3

DerivedPartEntity.Type Property Introduced in Inventor 5.3

DerivedPartTransformDef Interface Introduced in Inventor 6

DerivedPartTransformDef Methods

DerivedPartTransformDef.GetTransformation Method Introduced in Inventor 6

DerivedPartTransformDef.SetTransformation Method Introduced in Inventor 6

DerivedPartUniformScaleDef Interface Introduced in Inventor 6

DerivedPartUniformScaleDef Properties

DerivedPartUniformScaleDef.IncludeAllSketchBlockDefinitions Property Introduced in Inventor 2010

DerivedPartUniformScaleDef.IncludeAllSketches Property Introduced in Inventor 6

DerivedPartUniformScaleDef.IncludeAllSketches3D Property Introduced in Inventor 11

DerivedPartUniformScaleDef.IncludeAllWorkFeatures Property Introduced in Inventor 6

DerivedPartUniformScaleDef.MirrorPlane Property Introduced in Inventor 6

DerivedPartUniformScaleDef.ScaleFactor Property Introduced in Inventor 6

DerivedPartUniformScaleDef.SketchBlockDefinitions Property Introduced in Inventor 2010

DerivedPartUniformScaleDef.SketchBlocks Property Introduced in Inventor 2010

DerivedPartUniformScaleDef.Sketches Property Introduced in Inventor 6

DerivedPartUniformScaleDef.Sketches3D Property Introduced in Inventor 11

DerivedPartUniformScaleDef.WorkFeatures Property Introduced in Inventor 6

DesignProject Interface Introduced in Inventor 7

DesignProject Methods

DesignProject._Activate Method

DesignProject.Activate Method Introduced in Inventor 2011

DesignProject.GetCustomSection Method Introduced in Inventor 2011

DesignProject.GetIncludedCustomSection Method Introduced in Inventor 2011

DesignProject.Remove Method

DesignProject.SetCustomSection Method Introduced in Inventor 2011

DesignProject Properties

DesignProject.Application Property Introduced in Inventor 10

DesignProject.ContentCenterPath Property Introduced in Inventor 2011

DesignProject.ContentCenterPathOverridden Property Introduced in Inventor 2011

DesignProject.CreationTime Property Introduced in Inventor 2011

DesignProject.DesignDataPath Property Introduced in Inventor 2011

DesignProject.DesignDataPathOverridden Property Introduced in Inventor 2011

DesignProject.FrequentlyUsedPaths Property Introduced in Inventor 2011

DesignProject.FullFileName Property Introduced in Inventor 2011

DesignProject.ImportedComponentsFolderName Property Introduced in Inventor 2011

DesignProject.ImportedTopLevelAssembliesFolderName Property Introduced in Inventor 2011

DesignProject.IncludedProject Property Introduced in Inventor 2011

DesignProject.LibraryPaths Property Introduced in Inventor 2011

DesignProject.Name Property Introduced in Inventor 2011

DesignProject.OldVersionsToKeep Property Introduced in Inventor 2011

DesignProject.Owner Property Introduced in Inventor 2011

DesignProject.Parent Property Introduced in Inventor 2011

DesignProject.ProjectType Property Introduced in Inventor 2011

DesignProject.ReleaseId Property Introduced in Inventor 2011

DesignProject.Shortcuts Property Introduced in Inventor 2011

DesignProject.StylesLibraryAccess Property Introduced in Inventor 10

DesignProject.TemplatesPath Property Introduced in Inventor 2011

DesignProject.TemplatesPathOverridden Property Introduced in Inventor 2011

DesignProject.Type Property Introduced in Inventor 7

DesignProject.UsingUniqueFileNames Property Introduced in Inventor 2011

DesignProject.VaultName Property Introduced in Inventor 2011

DesignProject.VaultPublishPath Property Introduced in Inventor 2011

DesignProject.VaultServer Property Introduced in Inventor 2011

DesignProject.VaultVirtualPath Property Introduced in Inventor 2011

DesignProject.WorkgroupPaths Property Introduced in Inventor 2011

DesignProject.WorkspacePath Property Introduced in Inventor 2011

DesignProjectManager Interface Introduced in Inventor 2011

DesignProjectManager Methods

DesignProjectManager.AddOptionsButton Method

DesignProjectManager.IsFileInActiveProject Method Introduced in Inventor 2011

DesignProjectManager.ResolveFile Method Introduced in Inventor 2011

DesignProjectManager Properties

DesignProjectManager.ActiveDesignProject Property Introduced in Inventor 2011

DesignProjectManager.Application Property Introduced in Inventor 2011

DesignProjectManager.DesignProjects Property Introduced in Inventor 2011

DesignProjectManager.Parent Property Introduced in Inventor 2011

DesignProjectManager.Type Property Introduced in Inventor 2011

DesignProjects Interface Introduced in Inventor 2011

DesignProjects Methods

DesignProjects.Add Method Introduced in Inventor 2011

DesignProjects.AddExisting Method Introduced in Inventor 2011

DesignProjects.Item Method Introduced in Inventor 2011

DesignProjects.ItemByName Method Introduced in Inventor 2011

DesignProjects Properties

DesignProjects.Application Property Introduced in Inventor 2011

DesignProjects.Count Property Introduced in Inventor 2011

DesignProjects.Type Property Introduced in Inventor 2011

DesignViewRepresentation Interface Introduced in Inventor 11

DesignViewRepresentation Methods

DesignViewRepresentation.Activate Method Introduced in Inventor 11

DesignViewRepresentation.Copy Method Introduced in Inventor 11

DesignViewRepresentation.Delete Method Introduced in Inventor 11

DesignViewRepresentation.GetReferenceKey Method Introduced in Inventor 11

DesignViewRepresentation.HideAll Method Introduced in Inventor 11

DesignViewRepresentation.RemoveColorOverrides Method Introduced in Inventor 11

DesignViewRepresentation.ShowAll Method Introduced in Inventor 11

DesignViewRepresentation Properties

DesignViewRepresentation.Application Property Introduced in Inventor 11

DesignViewRepresentation.AttributeSets Property Introduced in Inventor 11

DesignViewRepresentation.DesignViewInfo Property Introduced in Inventor 11

DesignViewRepresentation.DesignViewType Property Introduced in Inventor 11

DesignViewRepresentation.Locked Property Introduced in Inventor 11

DesignViewRepresentation.Name Property Introduced in Inventor 11

DesignViewRepresentation.Parent Property Introduced in Inventor 11

DesignViewRepresentation.Type Property Introduced in Inventor 11

DesignViewRepresentations Interface Introduced in Inventor 11

DesignViewRepresentations Methods

DesignViewRepresentations.Add Method Introduced in Inventor 11

DesignViewRepresentations.Item Method Introduced in Inventor 11

DesignViewRepresentations Properties

DesignViewRepresentations.Application Property Introduced in Inventor 11

DesignViewRepresentations.Count Property Introduced in Inventor 11

DesignViewRepresentations.Type Property Introduced in Inventor 11

DetailDrawingView Interface Introduced in Inventor 11

DetailDrawingView Properties

DetailDrawingView.AttachPoint Property Introduced in Inventor 11

DetailDrawingView.BoundaryLayer Property Introduced in Inventor 2008

DetailDrawingView.CircularFence Property Introduced in Inventor 11

DetailDrawingView.DisplayConnectionLine Property Introduced in Inventor 2008

DetailDrawingView.DisplayFullBoundary Property Introduced in Inventor 2008

DetailDrawingView.FenceCenter Property Introduced in Inventor 11

DetailDrawingView.FenceCornerOne Property Introduced in Inventor 11

DetailDrawingView.FenceCornerTwo Property Introduced in Inventor 11

DetailDrawingView.FenceRadius Property Introduced in Inventor 11

DetailDrawingView.IsBreakLineSmooth Property Introduced in Inventor 2008

DiameterDimConstraint Interface Introduced in Inventor 5

DiameterDimConstraint Properties

DiameterDimConstraint.Entity Property Introduced in Inventor 5

DiameterDimConstraintProxy Interface Introduced in Inventor 6

DiameterDimConstraintProxy Properties

DiameterDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

DiameterDimConstraintProxy.NativeObject Property Introduced in Inventor 6

DiameterGeneralDimension Interface Introduced in Inventor 11

DiameterGeneralDimension Properties

DiameterGeneralDimension.ExtensionLineOne Property Introduced in Inventor 2008

DiameterGeneralDimension.ExtensionLineTwo Property Introduced in Inventor 2008

DiameterGeneralDimension.Intent Property Introduced in Inventor 11

DiameterGeneralDimension.LeaderFromCenter Property Introduced in Inventor 11

DiameterGeneralDimension.SingleDimensionLine Property Introduced in Inventor 11

DimensionConstraint Interface Introduced in Inventor 5

DimensionConstraint Methods

DimensionConstraint.Delete Method Introduced in Inventor 5

DimensionConstraint.GetReferenceKey Method Introduced in Inventor 5

DimensionConstraint Properties

DimensionConstraint.AnchorPoints Property

DimensionConstraint.Application Property Introduced in Inventor 5

DimensionConstraint.AttributeSets Property Introduced in Inventor 5

DimensionConstraint.DimensionCenterPoint Property Introduced in Inventor 10

DimensionConstraint.Driven Property Introduced in Inventor 5

DimensionConstraint.Parameter Property Introduced in Inventor 5

DimensionConstraint.Parent Property Introduced in Inventor 5

DimensionConstraint.TextPoint Property Introduced in Inventor 5

DimensionConstraint.Type Property

DimensionConstraint3D Interface Introduced in Inventor 11

DimensionConstraint3D Methods

DimensionConstraint3D.Delete Method Introduced in Inventor 11

DimensionConstraint3D.GetReferenceKey Method Introduced in Inventor 11

DimensionConstraint3D Properties

DimensionConstraint3D.AnchorPoints Property

DimensionConstraint3D.Application Property Introduced in Inventor 11

DimensionConstraint3D.AttributeSets Property Introduced in Inventor 11

DimensionConstraint3D.DimensionPlane Property Introduced in Inventor 11

DimensionConstraint3D.Driven Property Introduced in Inventor 11

DimensionConstraint3D.Parameter Property Introduced in Inventor 11

DimensionConstraint3D.Parent Property Introduced in Inventor 11

DimensionConstraint3D.TextPoint Property Introduced in Inventor 11

DimensionConstraint3D.Type Property

DimensionConstraints Interface Introduced in Inventor 5

DimensionConstraints Methods

DimensionConstraints.AddDiameter Method Introduced in Inventor 5

DimensionConstraints.AddEllipseRadius Method Introduced in Inventor 10

DimensionConstraints.AddOffset Method Introduced in Inventor 5

DimensionConstraints.AddOffsetSpline Method Introduced in Inventor 11

DimensionConstraints.AddRadius Method Introduced in Inventor 5

DimensionConstraints.AddTangentDistance Method Introduced in Inventor 5

DimensionConstraints.AddThreePointAngle Method Introduced in Inventor 5

DimensionConstraints.AddTwoLineAngle Method Introduced in Inventor 5

DimensionConstraints.AddTwoPointDistance Method Introduced in Inventor 5

DimensionConstraints.Item Method Introduced in Inventor 5

DimensionConstraints Properties

DimensionConstraints.Application Property Introduced in Inventor 5

DimensionConstraints.Count Property Introduced in Inventor 5

DimensionConstraints.Type Property Introduced in Inventor 5

DimensionConstraints3D Interface Introduced in Inventor 11

DimensionConstraints3D Methods

DimensionConstraints3D.AddLineLength Method Introduced in Inventor 11

DimensionConstraints3D.AddPointAndPlaneDistance Method Introduced in Inventor 11

DimensionConstraints3D.AddRadius Method Introduced in Inventor 2010

DimensionConstraints3D.AddTwoLineAngle Method Introduced in Inventor 11

DimensionConstraints3D.AddTwoPointDistance Method Introduced in Inventor 11

DimensionConstraints3D.GetDimensionPlane Method Introduced in Inventor 11

DimensionConstraints3D.Item Method Introduced in Inventor 11

DimensionConstraints3D Properties

DimensionConstraints3D.Application Property Introduced in Inventor 11

DimensionConstraints3D.Count Property Introduced in Inventor 11

DimensionConstraints3D.Type Property Introduced in Inventor 11

DimensionStyle Interface Introduced in Inventor 9

DimensionStyle Methods

DimensionStyle.GetCustomLineType Method Introduced in Inventor 2011

DimensionStyle.SetCustomLineType Method Introduced in Inventor 2011

DimensionStyle Properties

DimensionStyle.AlternateDecimalMarkerType Property Introduced in Inventor 9

DimensionStyle.AlternateDisplayFormat Property Introduced in Inventor 2009

DimensionStyle.AlternateDisplayUnitType Property Introduced in Inventor 9

DimensionStyle.AlternateFractionalTextScale Property Introduced in Inventor 2009

DimensionStyle.AlternateIncludedZeroDisplay Property

DimensionStyle.AlternateLeadingZeroDisplay Property Introduced in Inventor 9

DimensionStyle.AlternateLinearPrecision Property Introduced in Inventor 9

DimensionStyle.AlternateLinearUnits Property Introduced in Inventor 9

DimensionStyle.AlternateStyleFormat Property Introduced in Inventor 9

DimensionStyle.AlternateTrailingZeroDisplay Property Introduced in Inventor 9

DimensionStyle.AngularPrecision Property Introduced in Inventor 9

DimensionStyle.ArrowheadHeight Property Introduced in Inventor 2011

DimensionStyle.ArrowheadSize Property Introduced in Inventor 2011

DimensionStyle.ArrowheadType Property Introduced in Inventor 2011

DimensionStyle.ArrowheadTypeForChainDimensions Property Introduced in Inventor 2011

DimensionStyle.Color Property Introduced in Inventor 2011

DimensionStyle.DecimalMarkerType Property Introduced in Inventor 9

DimensionStyle.DisplayFormat Property Introduced in Inventor 2009

DimensionStyle.DisplayUnitType Property Introduced in Inventor 9

DimensionStyle.Extension Property Introduced in Inventor 2011

DimensionStyle.FractionalTextScale Property Introduced in Inventor 2009

DimensionStyle.Gap Property Introduced in Inventor 2011

DimensionStyle.IncludedZeroDisplay Property

DimensionStyle.LeaderStyle Property Introduced in Inventor 2009

DimensionStyle.LeadingZeroDisplay Property Introduced in Inventor 9

DimensionStyle.LinearPrecision Property Introduced in Inventor 9

DimensionStyle.LinearUnits Property Introduced in Inventor 9

DimensionStyle.LineType Property Introduced in Inventor 2011

DimensionStyle.OrdinateDimensionOriginArrowheadType Property

DimensionStyle.LineWeight Property Introduced in Inventor 2011

DimensionStyle.OriginOffset Property Introduced in Inventor 2011

DimensionStyle.PartOffset Property Introduced in Inventor 2011

DimensionStyle.Prefix Property Introduced in Inventor 9

DimensionStyle.PrefixAndSuffixOrder Property Introduced in Inventor 9

DimensionStyle.ShowBreakSymbol Property Introduced in Inventor 2011

DimensionStyle.ShowDimensionLine Property Introduced in Inventor 2011

DimensionStyle.Spacing Property Introduced in Inventor 2011

DimensionStyle.Suffix Property Introduced in Inventor 9

DimensionStyle.TextStyle Property Introduced in Inventor 9

DimensionStyle.Tolerance Property Introduced in Inventor 9

DimensionStyle.ToleranceAlternateIncludedZeroDisplay Property

DimensionStyle.ToleranceAlternateLeadingZeroDisplay Property

DimensionStyle.ToleranceAlternateTrailingZeroDisplay Property

DimensionStyle.ToleranceAlternateUnitPrecision Property Introduced in Inventor 9

DimensionStyle.ToleranceAngularPrecision Property Introduced in Inventor 9

DimensionStyle.ToleranceFontSize Property Introduced in Inventor 9

DimensionStyle.ToleranceIncludedZeroDisplay Property

DimensionStyle.ToleranceLeadingZeroDisplay Property Introduced in Inventor 9

DimensionStyle.ToleranceLinearPrecision Property Introduced in Inventor 9

DimensionStyle.ToleranceTextStyle Property Introduced in Inventor 9

DimensionStyle.ToleranceTrailingZeroDisplay Property Introduced in Inventor 9

DimensionStyle.TrailingZeroDisplay Property Introduced in Inventor 9

DimensionStylesEnumerator Interface Introduced in Inventor 9

DimensionStylesEnumerator Methods

DimensionStylesEnumerator.Item Method Introduced in Inventor 9

DimensionStylesEnumerator Properties

DimensionStylesEnumerator.Application Property Introduced in Inventor 9

DimensionStylesEnumerator.Count Property Introduced in Inventor 9

DimensionStylesEnumerator.Type Property Introduced in Inventor 9

DimensionText Interface Introduced in Inventor 9

DimensionText Properties

DimensionText.Application Property Introduced in Inventor 9

DimensionText.Color Property Introduced in Inventor 9

DimensionText.FormattedText Property Introduced in Inventor 9

DimensionText.HorizontalJustification Property Introduced in Inventor 9

DimensionText.LineSpacing Property Introduced in Inventor 9

DimensionText.LineSpacingType Property Introduced in Inventor 9

DimensionText.Origin Property Introduced in Inventor 9

DimensionText.Parent Property Introduced in Inventor 9

DimensionText.RangeBox Property Introduced in Inventor 2010

DimensionText.Text Property Introduced in Inventor 9

DimensionText.Type Property Introduced in Inventor 9

DimensionText.VerticalJustification Property Introduced in Inventor 9

DimensionText.WidthScale Property Introduced in Inventor 9

DirectionAndDistanceMoveDefinition Interface Introduced in Inventor 2011

DirectionAndDistanceMoveDefinition Properties

DirectionAndDistanceMoveDefinition.Application Property

DirectionAndDistanceMoveDefinition.Direction Property

DirectionAndDistanceMoveDefinition.DirectionReversed Property

DirectionAndDistanceMoveDefinition.Distance Property

DirectionAndDistanceMoveDefinition.Parent Property

DirectionAndDistanceMoveDefinition.Type Property

DisabledCommandList Interface Introduced in Inventor 10

DisabledCommandList Methods

DisabledCommandList.Add Method Introduced in Inventor 10

DisabledCommandList.Item Method Introduced in Inventor 10

DisabledCommandList.Remove Method Introduced in Inventor 10

DisabledCommandList Properties

DisabledCommandList.Application Property Introduced in Inventor 10

DisabledCommandList.Count Property Introduced in Inventor 10

DisabledCommandList.Type Property Introduced in Inventor 10

DisplayOptions Interface Introduced in Inventor 11

DisplayOptions Methods

DisplayOptions.ShadedDisplayOptions Method Introduced in Inventor 11

DisplayOptions.WireframeDisplayOptions Method Introduced in Inventor 11

DisplayOptions Properties

DisplayOptions.Application Property Introduced in Inventor 11

DisplayOptions.DefaultOrbitType Property Introduced in Inventor 2010

DisplayOptions.DepthDimming Property Introduced in Inventor 2011

DisplayOptions.DisplayQuality Property Introduced in Inventor 11

DisplayOptions.DisplaySilhouettes Property Introduced in Inventor 2011

DisplayOptions.EdgeColor Property Introduced in Inventor 2011

DisplayOptions.HiddenLineDimmingPercent Property Introduced in Inventor 11

DisplayOptions.InactiveComponentsEdgeColor Property Introduced in Inventor 2011

DisplayOptions.InactiveComponentsEdgeDisplay Property Introduced in Inventor 2011

DisplayOptions.InactiveComponentsShaded Property Introduced in Inventor 2011

DisplayOptions.InactiveComponentsShadeOpacity Property Introduced in Inventor 2011

DisplayOptions.MinimumFrameRate Property Introduced in Inventor 11

DisplayOptions.NewWindowDisplayMode Property Introduced in Inventor 2010

DisplayOptions.NewWindowProjectionType Property Introduced in Inventor 2010

DisplayOptions.NewWindowShowAmbientShadows Property

DisplayOptions.NewWindowShowGroundPlane Property Introduced in Inventor 2011

DisplayOptions.NewWindowShowGroundReflections Property Introduced in Inventor 2011

DisplayOptions.NewWindowShowGroundShadows Property

DisplayOptions.NewWindowShowObjectShadows Property

DisplayOptions.RayTracingQuality Property Introduced in Inventor 2012

DisplayOptions.ReverseZoomDirection Property Introduced in Inventor 2008

DisplayOptions.Show3DIndicator Property

DisplayOptions.ShowXYZAxisLabels Property

DisplayOptions.SolidLinesForHiddenEdges Property Introduced in Inventor 2008

DisplayOptions.Type Property Introduced in Inventor 11

DisplayOptions.UseDocumentDisplaySettings Property Introduced in Inventor 2011

DisplayOptions.UseRayTracingForRealisticDisplay Property Introduced in Inventor 2012

DisplayOptions.ViewTransitionTime Property Introduced in Inventor 11

DisplayOptions.ZoomToCursor Property Introduced in Inventor 2008

DisplaySettings Interface Introduced in Inventor 2011

DisplaySettings Properties

DisplaySettings.Application Property

DisplaySettings.DepthDimming Property

DisplaySettings.DisplaySilhouettes Property

DisplaySettings.EdgeColor Property

DisplaySettings.GroundPlaneSettings Property

DisplaySettings.HiddenLineDimmingPercent Property

DisplaySettings.NewWindowDisplayMode Property

DisplaySettings.NewWindowProjectionType Property

DisplaySettings.NewWindowShowAmbientShadows Property

DisplaySettings.NewWindowShowGroundPlane Property

DisplaySettings.NewWindowShowGroundReflections Property

DisplaySettings.NewWindowShowGroundShadows Property

DisplaySettings.NewWindowShowObjectShadows Property

DisplaySettings.Parent Property

DisplaySettings.RayTracingQuality Property Introduced in Inventor 2012

DisplaySettings.SolidLinesForHiddenEdges Property

DisplaySettings.Type Property

DisplaySettings.UseRayTracingForRealisticDisplay Property Introduced in Inventor 2012

DistanceAndAngleChamferDef Interface Introduced in Inventor 5.3

DistanceAndAngleChamferDef Properties

DistanceAndAngleChamferDef.Angle Property Introduced in Inventor 5.3

DistanceAndAngleChamferDef.Distance Property Introduced in Inventor 5.3

DistanceAndAngleChamferDef.Face Property Introduced in Inventor 6

DistanceChamferDef Interface Introduced in Inventor 5.3

DistanceChamferDef Properties

DistanceChamferDef.CornerSetback Property Introduced in Inventor 5.3

DistanceChamferDef.Distance Property Introduced in Inventor 5.3

DistanceExtent Interface Introduced in Inventor 5

DistanceExtent Properties

DistanceExtent.Direction Property Introduced in Inventor 5

DistanceExtent.Distance Property Introduced in Inventor 5

DistanceHeightExtent Interface Introduced in Inventor 2009

DistanceHeightExtent Properties

DistanceHeightExtent.Distance Property Introduced in Inventor 2009

DistanceHeightExtent.FlangeDirection Property Introduced in Inventor 2009

DistanceHeightExtent.HeightDatumType Property Introduced in Inventor 2009

DockableWindow Interface Introduced in Inventor 2011

DockableWindow Methods

DockableWindow.AddChild Method Introduced in Inventor 2011

DockableWindow.Clear Method

DockableWindow.Delete Method

DockableWindow.Move Method Introduced in Inventor 2011

DockableWindow.SetMinimumSize Method Introduced in Inventor 2011

DockableWindow Properties

DockableWindow.Application Property Introduced in Inventor 2011

DockableWindow.Caption Property Introduced in Inventor 2012

DockableWindow.ClientId Property Introduced in Inventor 2011

DockableWindow.Control Property Introduced in Inventor 2011

DockableWindow.DisabledDockingStates Property Introduced in Inventor 2011

DockableWindow.DockingState Property Introduced in Inventor 2011

DockableWindow.Height Property Introduced in Inventor 2011

DockableWindow.HWND Property Introduced in Inventor 2011

DockableWindow.InternalName Property Introduced in Inventor 2011

DockableWindow.IsCustomized Property Introduced in Inventor 2011

DockableWindow.Left Property Introduced in Inventor 2011

DockableWindow.Parent Property Introduced in Inventor 2011

DockableWindow.ShowTitleBar Property Introduced in Inventor 2012

DockableWindow.Title Property Introduced in Inventor 2011

DockableWindow.Top Property Introduced in Inventor 2011

DockableWindow.Type Property Introduced in Inventor 2011

DockableWindow.VisibilityControl Property

DockableWindow.Visible Property Introduced in Inventor 2011

DockableWindow.Width Property Introduced in Inventor 2011

DockableWindows Interface Introduced in Inventor 2011

DockableWindows Methods

DockableWindows.Add Method

DockableWindows.Item Method Introduced in Inventor 2011

DockableWindows Properties

DockableWindows.Application Property Introduced in Inventor 2011

DockableWindows.Count Property Introduced in Inventor 2011

DockableWindows.Events Property Introduced in Inventor 2012

DockableWindows.Type Property Introduced in Inventor 2011

DockableWindowsEventsObject Interface Introduced in Inventor 2012

DockableWindowsEventsObject Properties

DockableWindowsEventsObject.Application Property Introduced in Inventor 2012

DockableWindowsEventsObject.Parent Property Introduced in Inventor 2012

DockableWindowsEventsObject.Type Property Introduced in Inventor 2012

DockableWindowsEventsSink Interface

DockableWindowsEventsSink Methods

DockableWindowsEventsSink.OnHelp Method Introduced in Inventor 2012

DockableWindowsEventsSink.OnHide Method Introduced in Inventor 2012

DockableWindowsEventsSink.OnShow Method Introduced in Inventor 2012

Document Interface Introduced in Inventor 4

Document Methods

Document.Activate Method Introduced in Inventor 4

Document.Close Method Introduced in Inventor 4

Document.CreateHighlightSet Method Introduced in Inventor 2008

Document.FindWhereUsed Method Introduced in Inventor 5

Document.GetLocationFoundIn Method Introduced in Inventor 4

Document.GetMissingAddInBehavior Method Introduced in Inventor 11

Document.GetPrivateStorage Method Introduced in Inventor 4

Document.GetPrivateStream Method Introduced in Inventor 4

Document.HasPrivateStorage Method Introduced in Inventor 4

Document.HasPrivateStream Method Introduced in Inventor 4

Document.PutInternalNameAndRevisionId Method Introduced in Inventor 11

Document.Rebuild Method Introduced in Inventor 4

Document.Rebuild2 Method Introduced in Inventor 2008

Document.ReleaseReference Method Introduced in Inventor 2008

Document.RevertReservedForWriteByMe Method Introduced in Inventor 6

Document.Save Method Introduced in Inventor 4

Document.Save2 Method Introduced in Inventor 2010

Document.SaveAs Method Introduced in Inventor 4

Document.SetMissingAddInBehavior Method Introduced in Inventor 11

Document.SetThumbnailSaveOption Method Introduced in Inventor 2010

Document.Update Method Introduced in Inventor 4

Document.Update2 Method Introduced in Inventor 10

Document Properties

Document.ActivatedObject Property Introduced in Inventor 4

Document.AllReferencedDocuments Property Introduced in Inventor 11

Document.AttributeManager Property Introduced in Inventor 5

Document.AttributeSets Property

Document.BrowserPanes Property Introduced in Inventor 5

Document.Compacted Property Introduced in Inventor 5

Document.DatabaseRevisionId Property Introduced in Inventor 11

Document.DefaultCommand Property Introduced in Inventor 4

Document.Dirty Property Introduced in Inventor 4

Document.DisabledCommandTypes Property Introduced in Inventor 6

Document.DisplayName Property Introduced in Inventor 4

Document.DisplayNameOverridden Property Introduced in Inventor 2010

Document.DocumentEvents Property Introduced in Inventor 4

Document.DocumentInterests Property Introduced in Inventor 2008

Document.DocumentSubType Property Introduced in Inventor 6

Document.DocumentType Property Introduced in Inventor 4

Document.File Property Introduced in Inventor 11

Document.FileSaveCounter Property Introduced in Inventor 4

Document.FullDocumentName Property Introduced in Inventor 11

Document.FullFileName Property Introduced in Inventor 4

Document.GraphicsDataSetsCollection Property Introduced in Inventor 5

Document.InternalName Property Introduced in Inventor 4

Document.IsModifiable Property Introduced in Inventor 6

Document.NeedsMigrating Property Introduced in Inventor 2008

Document.Open Property Introduced in Inventor 11

Document.Parent Property Introduced in Inventor 4

Document.PrintManager Property Introduced in Inventor 5

Document.PropertySets Property Introduced in Inventor 4

Document.RecentChanges Property Introduced in Inventor 8

Document.ReferencedDocumentDescriptors Property Introduced in Inventor 11

Document.ReferencedDocuments Property Introduced in Inventor 11

Document.ReferencedOLEFileDescriptors Property Introduced in Inventor 4

Document.ReferenceKeyManager Property Introduced in Inventor 5

Document.ReferencingDocuments Property Introduced in Inventor 11

Document.RenderStyles Property Introduced in Inventor 5

Document.RequiresUpdate Property Introduced in Inventor 4

Document.ReservedForWrite Property Introduced in Inventor 4

Document.ReservedForWriteByMe Property Introduced in Inventor 4

Document.ReservedForWriteLogin Property Introduced in Inventor 4

Document.ReservedForWriteName Property Introduced in Inventor 4

Document.ReservedForWriteTime Property Introduced in Inventor 4

Document.ReservedForWriteVersion Property Introduced in Inventor 4

Document.RevisionId Property Introduced in Inventor 5.3

Document.SelectionPriority Property Introduced in Inventor 2008

Document.SelectSet Property Introduced in Inventor 5

Document.SoftwareVersionCreated Property Introduced in Inventor 4

Document.SoftwareVersionSaved Property Introduced in Inventor 4

Document.SubType Property Introduced in Inventor 4

Document.Thumbnail Property Introduced in Inventor 6

Document.ThumbnailSaveOption Property Introduced in Inventor 2010

Document.Type Property Introduced in Inventor 4

Document.UnitsOfMeasure Property Introduced in Inventor 4

Document.VBAProject Property Introduced in Inventor 6

Document.Views Property Introduced in Inventor 4

DocumentDescriptor Interface Introduced in Inventor 11

DocumentDescriptor Properties

DocumentDescriptor.Application Property Introduced in Inventor 11

DocumentDescriptor.DisplayName Property Introduced in Inventor 11

DocumentDescriptor.FullDocumentName Property Introduced in Inventor 11

DocumentDescriptor.Parent Property Introduced in Inventor 11

DocumentDescriptor.ReferencedDocument Property Introduced in Inventor 11

DocumentDescriptor.ReferencedDocumentType Property Introduced in Inventor 11

DocumentDescriptor.ReferencedFileDescriptor Property Introduced in Inventor 11

DocumentDescriptor.ReferenceDisabled Property Introduced in Inventor 2010

DocumentDescriptor.ReferencedLevelOfDetail Property Introduced in Inventor 11

DocumentDescriptor.ReferenceInternalNameDifferent Property Introduced in Inventor 2010

DocumentDescriptor.ReferenceLocationDifferent Property Introduced in Inventor 2010

DocumentDescriptor.ReferenceMissing Property Introduced in Inventor 11

DocumentDescriptor.ReferenceSuppressed Property Introduced in Inventor 11

DocumentDescriptor.Type Property Introduced in Inventor 11

DocumentDescriptorsEnumerator Interface Introduced in Inventor 11

DocumentDescriptorsEnumerator Methods

DocumentDescriptorsEnumerator.Item Method Introduced in Inventor 11

DocumentDescriptorsEnumerator Properties

DocumentDescriptorsEnumerator.Application Property Introduced in Inventor 11

DocumentDescriptorsEnumerator.Count Property Introduced in Inventor 11

DocumentDescriptorsEnumerator.Type Property Introduced in Inventor 11

DocumentEvents CoClass Introduced in Inventor 4

DocumentEventsObject Interface Introduced in Inventor 4

DocumentEventsObject Properties

DocumentEventsObject.Application Property Introduced in Inventor 5

DocumentEventsObject.Parent Property Introduced in Inventor 5

DocumentEventsObject.Type Property Introduced in Inventor 5

DocumentEventsSink Interface Introduced in Inventor 4

DocumentEventsSink Methods

DocumentEventsSink.OnActivate Method Introduced in Inventor 4

DocumentEventsSink.OnChange Method Introduced in Inventor 8

DocumentEventsSink.OnChangeSelectSet Method Introduced in Inventor 5

DocumentEventsSink.OnClose Method Introduced in Inventor 4

DocumentEventsSink.OnDeactivate Method Introduced in Inventor 4

DocumentEventsSink.OnDelete Method Introduced in Inventor 8

DocumentEventsSink.OnSave Method Introduced in Inventor 4

DocumentInterest Interface Introduced in Inventor 2008

DocumentInterest Methods

DocumentInterest.Delete Method Introduced in Inventor 2008

DocumentInterest Properties

DocumentInterest.Application Property Introduced in Inventor 2008

DocumentInterest.ClientData Property Introduced in Inventor 2008

DocumentInterest.ClientId Property Introduced in Inventor 2008

DocumentInterest.DataVersion Property Introduced in Inventor 2008

DocumentInterest.InterestType Property Introduced in Inventor 2008

DocumentInterest.Name Property Introduced in Inventor 2008

DocumentInterest.Parent Property Introduced in Inventor 2008

DocumentInterest.Type Property Introduced in Inventor 2008

DocumentInterests Interface Introduced in Inventor 2008

DocumentInterests Methods

DocumentInterests.Add Method Introduced in Inventor 2008

DocumentInterests.HasInterest Method Introduced in Inventor 2008

DocumentInterests.Item Method Introduced in Inventor 2008

DocumentInterests Properties

DocumentInterests.Application Property Introduced in Inventor 2008

DocumentInterests.Count Property Introduced in Inventor 2008

DocumentInterests.Type Property Introduced in Inventor 2008

Documents Interface Introduced in Inventor 4

Documents Methods

Documents.Add Method Introduced in Inventor 4

Documents.CloseAll Method Introduced in Inventor 11

Documents.ItemByName Method Introduced in Inventor 10

Documents.Open Method Introduced in Inventor 4

Documents.OpenWithOptions Method Introduced in Inventor 11

Documents Properties

Documents.VisibleDocuments Property Introduced in Inventor 2009

DocumentsEnumerator Interface Introduced in Inventor 4

DocumentsEnumerator Methods

DocumentsEnumerator.Item Method Introduced in Inventor 4

DocumentsEnumerator Properties

DocumentsEnumerator.Count Property Introduced in Inventor 4

DocumentsEnumerator.Type Property Introduced in Inventor 4

DoubleHemDefinition Interface Introduced in Inventor 2009

DoubleHemDefinition Properties

DoubleHemDefinition.Gap Property Introduced in Inventor 2009

DoubleHemDefinition.Length Property Introduced in Inventor 2009

DoubleHemDefinition.Parent Property Introduced in Inventor 2009

DraftAnalyses Interface Introduced in Inventor 2009

DraftAnalyses Methods

DraftAnalyses.Add Method Introduced in Inventor 2009

DraftAnalyses.Item Method Introduced in Inventor 2009

DraftAnalyses Properties

DraftAnalyses.Application Property Introduced in Inventor 2009

DraftAnalyses.Count Property Introduced in Inventor 2009

DraftAnalyses.Type Property Introduced in Inventor 2009

DraftAnalysis Interface Introduced in Inventor 2009

DraftAnalysis Methods

DraftAnalysis.Activate Method Introduced in Inventor 2009

DraftAnalysis.Copy Method Introduced in Inventor 2009

DraftAnalysis.Delete Method Introduced in Inventor 2009

DraftAnalysis.GetReferenceKey Method Introduced in Inventor 2009

DraftAnalysis Properties

DraftAnalysis.Application Property Introduced in Inventor 2009

DraftAnalysis.AttributeSets Property Introduced in Inventor 2009

DraftAnalysis.DisplayQuality Property Introduced in Inventor 2009

DraftAnalysis.EndAngle Property Introduced in Inventor 2009

DraftAnalysis.Faces Property Introduced in Inventor 2009

DraftAnalysis.GradientDisplay Property Introduced in Inventor 2009

DraftAnalysis.Name Property Introduced in Inventor 2009

DraftAnalysis.Parent Property Introduced in Inventor 2009

DraftAnalysis.PullDirection Property Introduced in Inventor 2009

DraftAnalysis.PullDirectionReversed Property Introduced in Inventor 2009

DraftAnalysis.StartAngle Property Introduced in Inventor 2009

DraftAnalysis.Type Property Introduced in Inventor 2009

DraftingStandard Interface Introduced in Inventor 4

DraftingStandard Properties

DraftingStandard.BaseStandard Property Introduced in Inventor 4

DraftingStandard.BuiltIn Property Introduced in Inventor 4

DraftingStandard.Name Property Introduced in Inventor 4

DraftingStandard.Type Property Introduced in Inventor 4

DragContext Interface Introduced in Inventor 2012

DragContext Methods

DragContext.CancelDrag Method Introduced in Inventor 2012

DragContext.Drag Method Introduced in Inventor 2012

DragContext.EndDrag Method Introduced in Inventor 2012

DragContext.StartDrag Method Introduced in Inventor 2012

DragContext.TryMove Method Introduced in Inventor 2012

DrawingBOM Interface Introduced in Inventor 2009

DrawingBOM Properties

DrawingBOM.Application Property Introduced in Inventor 2009

DrawingBOM.DrawingBOMColumns Property Introduced in Inventor 2009

DrawingBOM.DrawingBOMRows Property Introduced in Inventor 2009

DrawingBOM.Level Property Introduced in Inventor 2009

DrawingBOM.Parent Property Introduced in Inventor 2009

DrawingBOM.ReferencedDocumentDescriptor Property Introduced in Inventor 2009

DrawingBOM.Type Property Introduced in Inventor 2009

DrawingBOMCell Interface Introduced in Inventor 2009

DrawingBOMCell Properties

DrawingBOMCell.Application Property Introduced in Inventor 2009

DrawingBOMCell.Parent Property Introduced in Inventor 2009

DrawingBOMCell.Static Property Introduced in Inventor 2009

DrawingBOMCell.Type Property Introduced in Inventor 2009

DrawingBOMCell.Value Property Introduced in Inventor 2009

DrawingBOMColumn Interface Introduced in Inventor 2009

DrawingBOMColumn Methods

DrawingBOMColumn.GetFilePropertyId Method Introduced in Inventor 2009

DrawingBOMColumn Properties

DrawingBOMColumn.Application Property Introduced in Inventor 2009

DrawingBOMColumn.CustomPropertyName Property Introduced in Inventor 2009

DrawingBOMColumn.Parent Property Introduced in Inventor 2009

DrawingBOMColumn.PropertyType Property Introduced in Inventor 2009

DrawingBOMColumn.Title Property Introduced in Inventor 2009

DrawingBOMColumn.Type Property Introduced in Inventor 2009

DrawingBOMColumns Interface Introduced in Inventor 2009

DrawingBOMColumns Methods

DrawingBOMColumns.Item Method Introduced in Inventor 2009

DrawingBOMColumns Properties

DrawingBOMColumns.Application Property Introduced in Inventor 2009

DrawingBOMColumns.Count Property Introduced in Inventor 2009

DrawingBOMColumns.Type Property Introduced in Inventor 2009

DrawingBOMRow Interface Introduced in Inventor 2009

DrawingBOMRow Methods

DrawingBOMRow.Item Method Introduced in Inventor 2009

DrawingBOMRow Properties

DrawingBOMRow.Application Property Introduced in Inventor 2009

DrawingBOMRow.Ballooned Property Introduced in Inventor 2009

DrawingBOMRow.BOMRow Property Introduced in Inventor 2009

DrawingBOMRow.Count Property Introduced in Inventor 2009

DrawingBOMRow.Custom Property Introduced in Inventor 2009

DrawingBOMRow.Parent Property Introduced in Inventor 2009

DrawingBOMRow.Type Property Introduced in Inventor 2009

DrawingBOMRow.Virtual Property Introduced in Inventor 2009

DrawingBOMRows Interface Introduced in Inventor 2009

DrawingBOMRows Methods

DrawingBOMRows.Item Method Introduced in Inventor 2009

DrawingBOMRows Properties

DrawingBOMRows.Application Property Introduced in Inventor 2009

DrawingBOMRows.Count Property Introduced in Inventor 2009

DrawingBOMRows.Type Property Introduced in Inventor 2009

DrawingBOMs Interface Introduced in Inventor 2009

DrawingBOMs Methods

DrawingBOMs.IsDrawingBOMDefined Method Introduced in Inventor 2009

DrawingBOMs.Item Method Introduced in Inventor 2009

DrawingBOMs Properties

DrawingBOMs.Application Property Introduced in Inventor 2009

DrawingBOMs.Count Property Introduced in Inventor 2009

DrawingBOMs.Type Property Introduced in Inventor 2009

DrawingCurve Interface Introduced in Inventor 11

DrawingCurve Methods

DrawingCurve.GetCustomLineType Method Introduced in Inventor 2009

DrawingCurve.SetCustomLineType Method Introduced in Inventor 2009

DrawingCurve Properties

DrawingCurve.Application Property Introduced in Inventor 11

DrawingCurve.CenterPoint Property Introduced in Inventor 11

DrawingCurve.Color Property Introduced in Inventor 2010

DrawingCurve.CurveType Property Introduced in Inventor 11

DrawingCurve.EdgeType Property Introduced in Inventor 2010

DrawingCurve.EndPoint Property Introduced in Inventor 11

DrawingCurve.Evaluator2D Property Introduced in Inventor 11

DrawingCurve.Evaluator3D Property Introduced in Inventor 11

DrawingCurve.LineType Property Introduced in Inventor 2009

DrawingCurve.LineWeight Property Introduced in Inventor 2009

DrawingCurve.MidPoint Property Introduced in Inventor 11

DrawingCurve.ModelGeometry Property Introduced in Inventor 11

DrawingCurve.Parent Property Introduced in Inventor 11

DrawingCurve.ProjectedCurveType Property Introduced in Inventor 2010

DrawingCurve.Segments Property Introduced in Inventor 11

DrawingCurve.StartPoint Property Introduced in Inventor 11

DrawingCurve.Type Property Introduced in Inventor 11

DrawingCurveSegment Interface Introduced in Inventor 11

DrawingCurveSegment Properties

DrawingCurveSegment.Application Property Introduced in Inventor 11

DrawingCurveSegment.EndPoint Property Introduced in Inventor 11

DrawingCurveSegment.HiddenLine Property Introduced in Inventor 11

DrawingCurveSegment.Layer Property Introduced in Inventor 11

DrawingCurveSegment.Parent Property Introduced in Inventor 11

DrawingCurveSegment.StartPoint Property Introduced in Inventor 11

DrawingCurveSegment.Type Property Introduced in Inventor 11

DrawingCurveSegment.Visible Property Introduced in Inventor 11

DrawingCurveSegments Interface Introduced in Inventor 11

DrawingCurveSegments Methods

DrawingCurveSegments.Item Method Introduced in Inventor 11

DrawingCurveSegments Properties

DrawingCurveSegments.Application Property Introduced in Inventor 11

DrawingCurveSegments.Count Property Introduced in Inventor 11

DrawingCurveSegments.Type Property Introduced in Inventor 11

DrawingCurvesEnumerator Interface Introduced in Inventor 11

DrawingCurvesEnumerator Methods

DrawingCurvesEnumerator.Item Method Introduced in Inventor 11

DrawingCurvesEnumerator Properties

DrawingCurvesEnumerator.Application Property Introduced in Inventor 11

DrawingCurvesEnumerator.Count Property Introduced in Inventor 11

DrawingCurvesEnumerator.Type Property Introduced in Inventor 11

DrawingDimension Interface Introduced in Inventor 9

DrawingDimension Methods

DrawingDimension.Delete Method Introduced in Inventor 9

DrawingDimension.GetInspectionDimensionData Method Introduced in Inventor 2010

DrawingDimension.GetReferenceKey Method Introduced in Inventor 9

DrawingDimension.SetInspectionDimensionData Method Introduced in Inventor 2010

DrawingDimension Properties

DrawingDimension.Application Property Introduced in Inventor 9

DrawingDimension.Attached Property Introduced in Inventor 10

DrawingDimension.AttributeSets Property Introduced in Inventor 9

DrawingDimension.DimensionLine Property Introduced in Inventor 2008

DrawingDimension.HideValue Property Introduced in Inventor 9

DrawingDimension.IsInspectionDimension Property Introduced in Inventor 2010

DrawingDimension.Layer Property Introduced in Inventor 10

DrawingDimension.ModelValue Property Introduced in Inventor 9

DrawingDimension.ModelValueOverridden Property Introduced in Inventor 11

DrawingDimension.OverrideModelValue Property Introduced in Inventor 9

DrawingDimension.Parent Property Introduced in Inventor 9

DrawingDimension.Precision Property Introduced in Inventor 9

DrawingDimension.Text Property Introduced in Inventor 9

DrawingDimension.Tolerance Property Introduced in Inventor 9

DrawingDimension.TolerancePrecision Property Introduced in Inventor 2008

DrawingDimension.Type Property Introduced in Inventor 9

DrawingDimensions Interface Introduced in Inventor 9

DrawingDimensions Methods

DrawingDimensions.Arrange Method Introduced in Inventor 2011

DrawingDimensions.Item Method Introduced in Inventor 9

DrawingDimensions Properties

DrawingDimensions.Application Property Introduced in Inventor 9

DrawingDimensions.BaselineDimensionSets Property Introduced in Inventor 2010

DrawingDimensions.ChainDimensionSets Property Introduced in Inventor 2011

DrawingDimensions.Count Property Introduced in Inventor 9

DrawingDimensions.GeneralDimensions Property Introduced in Inventor 9

DrawingDimensions.OrdinateDimensions Property Introduced in Inventor 2009

DrawingDimensions.OrdinateDimensionSets Property Introduced in Inventor 2010

DrawingDimensions.Type Property Introduced in Inventor 9

DrawingDocument Interface Introduced in Inventor 4

DrawingDocument Methods

DrawingDocument.ProcessViewSelection Method Introduced in Inventor 10

DrawingDocument.SaveAsInventorDWG Method Introduced in Inventor 2008

DrawingDocument Properties

DrawingDocument.ActiveSheet Property Introduced in Inventor 5.3

DrawingDocument.AutoCADBlockDefinitions Property Introduced in Inventor 2011

DrawingDocument.BorderDefinitions Property Introduced in Inventor 5.3

DrawingDocument.ContainingDWGDocument Property Introduced in Inventor 2008

DrawingDocument.DisabledCommandList Property Introduced in Inventor 10

DrawingDocument.DrawingBOMs Property Introduced in Inventor 2009

DrawingDocument.DrawingEvents Property Introduced in Inventor 9

DrawingDocument.DrawingSettings Property Introduced in Inventor 7

DrawingDocument.EnvironmentManager Property Introduced in Inventor 10

DrawingDocument.IsInventorDWG Property Introduced in Inventor 2008

DrawingDocument.Parameters Property

DrawingDocument.SheetFormats Property Introduced in Inventor 2009

DrawingDocument.Sheets Property Introduced in Inventor 5.3

DrawingDocument.SheetSettings Property Introduced in Inventor 11

DrawingDocument.SketchedSymbolDefinitions Property Introduced in Inventor 5.3

DrawingDocument.SketchSettings Property Introduced in Inventor 8

DrawingDocument.StylesManager Property Introduced in Inventor 9

DrawingDocument.TitleBlockDefinitions Property Introduced in Inventor 5.3

DrawingEvents CoClass Introduced in Inventor 9

DrawingEventsObject Interface Introduced in Inventor 9

DrawingEventsObject Properties

DrawingEventsObject.Application Property Introduced in Inventor 9

DrawingEventsObject.Parent Property Introduced in Inventor 9

DrawingEventsObject.Type Property Introduced in Inventor 9

DrawingEventsSink Interface Introduced in Inventor 9

DrawingEventsSink Methods

DrawingEventsSink.OnRetrieveDimensions Method Introduced in Inventor 9

DrawingNote Interface Introduced in Inventor 10

DrawingNote Methods

DrawingNote.Delete Method Introduced in Inventor 10

DrawingNote.GetReferenceKey Method Introduced in Inventor 10

DrawingNote Properties

DrawingNote.Application Property Introduced in Inventor 10

DrawingNote.AttributeSets Property Introduced in Inventor 10

DrawingNote.Color Property Introduced in Inventor 10

DrawingNote.FormattedText Property Introduced in Inventor 10

DrawingNote.HorizontalJustification Property Introduced in Inventor 10

DrawingNote.Layer Property Introduced in Inventor 10

DrawingNote.LineSpacing Property Introduced in Inventor 10

DrawingNote.LineSpacingType Property Introduced in Inventor 10

DrawingNote.Parent Property Introduced in Inventor 10

DrawingNote.Position Property Introduced in Inventor 10

DrawingNote.RangeBox Property Introduced in Inventor 2010

DrawingNote.StackedTextPosition Property Introduced in Inventor 2009

DrawingNote.Text Property Introduced in Inventor 10

DrawingNote.Type Property Introduced in Inventor 10

DrawingNote.VerticalJustification Property Introduced in Inventor 10

DrawingNote.WidthScale Property Introduced in Inventor 10

DrawingNotes Interface Introduced in Inventor 10

DrawingNotes Methods

DrawingNotes.Item Method Introduced in Inventor 10

DrawingNotes Properties

DrawingNotes.Application Property Introduced in Inventor 10

DrawingNotes.BendNotes Property Introduced in Inventor 2010

DrawingNotes.ChamferNotes Property Introduced in Inventor 2010

DrawingNotes.Count Property Introduced in Inventor 10

DrawingNotes.GeneralNotes Property Introduced in Inventor 10

DrawingNotes.HoleThreadNotes Property Introduced in Inventor 2010

DrawingNotes.LeaderNotes Property Introduced in Inventor 10

DrawingNotes.PunchNotes Property Introduced in Inventor 2010

DrawingNotes.Type Property Introduced in Inventor 10

DrawingOptions Interface Introduced in Inventor 2008

DrawingOptions Properties

DrawingOptions.Application Property Introduced in Inventor 2008

DrawingOptions.ArcDimensionType Property Introduced in Inventor 2008

DrawingOptions.CenterDimensionText Property Introduced in Inventor 2008

DrawingOptions.CircleDimensionType Property Introduced in Inventor 2008

DrawingOptions.DefaultDrawingFileType Property Introduced in Inventor 2008

DrawingOptions.DefaultLayerStyle Property Introduced in Inventor 2008

DrawingOptions.DefaultNonInventorDWGFileOpenBehavior Property Introduced in Inventor 2008

DrawingOptions.DefaultObjectStyle Property Introduced in Inventor 2008

DrawingOptions.DisplayLineWeights Property Introduced in Inventor 2008

DrawingOptions.EditDimensionWhenCreated Property Introduced in Inventor 2010

DrawingOptions.EnableBackgroundUpdates Property Introduced in Inventor 2012

DrawingOptions.EnableOrdinateDimGeomSelection Property Introduced in Inventor 2008

DrawingOptions.GetModelDimensions Property Introduced in Inventor 2008

DrawingOptions.InventorDWGFileVersion Property Introduced in Inventor 2010

DrawingOptions.LinearDimensionType Property Introduced in Inventor 2008

DrawingOptions.LineWeightType Property Introduced in Inventor 2008

DrawingOptions.MemorySavingMode Property Introduced in Inventor 2008

DrawingOptions.ShowUncutSectionViewPreview Property Introduced in Inventor 2008

DrawingOptions.StandardPartsSectionBehavior Property Introduced in Inventor 2008

DrawingOptions.TitleBlockAlignment Property Introduced in Inventor 2008

DrawingOptions.Type Property Introduced in Inventor 2008

DrawingOptions.UpperLimitForFirstRangeOfLineWeights Property Introduced in Inventor 2008

DrawingOptions.UpperLimitForSecondRangeOfLineWeights Property Introduced in Inventor 2008

DrawingOptions.UpperLimitForThirdRangeOfLineWeights Property Introduced in Inventor 2008

DrawingOptions.ViewBlockInsertionPoint Property Introduced in Inventor 2010

DrawingOptions.ViewJustification Property Introduced in Inventor 2008

DrawingOptions.ViewPreview Property Introduced in Inventor 2008

DrawingPrintManager Interface Introduced in Inventor 5

DrawingPrintManager Methods

DrawingPrintManager.GetSheetRange Method Introduced in Inventor 5

DrawingPrintManager.SetSheetRange Method Introduced in Inventor 5

DrawingPrintManager Properties

DrawingPrintManager.AllColorsAsBlack Property Introduced in Inventor 9

DrawingPrintManager.PrintExcludedSheets Property Introduced in Inventor 2009

DrawingPrintManager.PrintRange Property Introduced in Inventor 5

DrawingPrintManager.RemoveLineWeights Property Introduced in Inventor 9

DrawingPrintManager.Rotate90Degrees Property Introduced in Inventor 5

DrawingPrintManager.Scale Property Introduced in Inventor 5

DrawingPrintManager.ScaleMode Property Introduced in Inventor 5

DrawingPrintManager.TilingEnabled Property Introduced in Inventor 10

DrawingSettings Interface Introduced in Inventor 7

DrawingSettings Properties

DrawingSettings.AlwaysUseBitmapsForShadedViews Property Introduced in Inventor 2008

DrawingSettings.Application Property Introduced in Inventor 7

DrawingSettings.AutomatedCenterlineSettings Property Introduced in Inventor 2010

DrawingSettings.CrossHatchClipping Property Introduced in Inventor 2008

DrawingSettings.CustomPropertySourceFile Property Introduced in Inventor 2009

DrawingSettings.DeferUpdates Property Introduced in Inventor 7

DrawingSettings.DimensionTextAlignment Property Introduced in Inventor 11

DrawingSettings.HighlightInvalidAnnotations Property Introduced in Inventor 8

DrawingSettings.InvalidFeatureBasedAnnotationsColor Property Introduced in Inventor 2008

DrawingSettings.MemorySavingMode Property Introduced in Inventor 2008

DrawingSettings.OfflineImageFidelity Property Introduced in Inventor 8

DrawingSettings.Parent Property Introduced in Inventor 7

DrawingSettings.PreserveOrphanedAnnotations Property Introduced in Inventor 2008

DrawingSettings.Type Property Introduced in Inventor 7

DrawingSketch Interface Introduced in Inventor 5.3

DrawingSketch Methods

DrawingSketch.GetAutomatedCenterlineSettings Method Introduced in Inventor 2010

DrawingSketch.SetAutomatedCenterlineSettings Method Introduced in Inventor 2010

DrawingSketch.SheetToSketchSpace Method Introduced in Inventor 5.3

DrawingSketch.SketchToSheetSpace Method Introduced in Inventor 5.3

DrawingSketch Properties

DrawingSketch.Profiles Property Introduced in Inventor 10

DrawingSketch.SketchFillRegions Property Introduced in Inventor 10

DrawingSketches Interface Introduced in Inventor 5.3

DrawingSketches Methods

DrawingSketches.Add Method Introduced in Inventor 5.3

DrawingSketches.Item Method Introduced in Inventor 5.3

DrawingSketches Properties

DrawingSketches.Application Property Introduced in Inventor 5.3

DrawingSketches.Count Property Introduced in Inventor 5.3

DrawingSketches.Type Property Introduced in Inventor 5.3

DrawingStandardStyle Interface Introduced in Inventor 9

DrawingStandardStyle Methods

DrawingStandardStyle.GetViewLabelDefaults Method Introduced in Inventor 2010

DrawingStandardStyle.SetViewLabelDefaults Method Introduced in Inventor 2010

DrawingStandardStyle Properties

DrawingStandardStyle.ActiveObjectDefaults Property Introduced in Inventor 9

DrawingStandardStyle.ApplyExcludeCharactersToBendTables Property Introduced in Inventor 2010

DrawingStandardStyle.ApplyExcludeCharactersToHoleTables Property Introduced in Inventor 2010

DrawingStandardStyle.ApplyExcludeCharactersToRevisionTables Property Introduced in Inventor 2010

DrawingStandardStyle.ApplyExcludeCharactersToViewNames Property Introduced in Inventor 2010

DrawingStandardStyle.DecimalMarkerType Property Introduced in Inventor 2010

DrawingStandardStyle.ExcludeCharacters Property Introduced in Inventor 2010

DrawingStandardStyle.FirstAngleProjection Property Introduced in Inventor 2010

DrawingStandardStyle.FrontViewPlane Property Introduced in Inventor 2010

DrawingStandardStyle.GlobalLineScale Property Introduced in Inventor 2010

DrawingStandardStyle.InternationalStandardReference Property Introduced in Inventor 2010

DrawingStandardStyle.LinearUnits Property Introduced in Inventor 2010

DrawingStandardStyle.PartialCircularThreadEdge Property Introduced in Inventor 2010

DrawingStandardStyle.PartialSectionThreadEnd Property Introduced in Inventor 2010

DrawingStandardStyle.PresetLineWeights Property Introduced in Inventor 2010

DrawingStandardStyle.PresetScales Property Introduced in Inventor 2010

DrawingStandardStyle.PresetSectionHatchAngles Property

DrawingStandardStyle.PresetTextHeights Property Introduced in Inventor 2010

DrawingStandardStylesEnumerator Interface Introduced in Inventor 9

DrawingStandardStylesEnumerator Methods

DrawingStandardStylesEnumerator.Item Method Introduced in Inventor 9

DrawingStandardStylesEnumerator Properties

DrawingStandardStylesEnumerator.Application Property Introduced in Inventor 9

DrawingStandardStylesEnumerator.Count Property Introduced in Inventor 9

DrawingStandardStylesEnumerator.Type Property Introduced in Inventor 9

DrawingStylesManager Interface Introduced in Inventor 9

DrawingStylesManager Properties

DrawingStylesManager.ActiveStandardStyle Property Introduced in Inventor 9

DrawingStylesManager.Application Property Introduced in Inventor 9

DrawingStylesManager.BalloonStyles Property Introduced in Inventor 2009

DrawingStylesManager.CentermarkStyles Property Introduced in Inventor 2010

DrawingStylesManager.DimensionStyles Property Introduced in Inventor 9

DrawingStylesManager.FeatureControlFrameStyles Property Introduced in Inventor 2009

DrawingStylesManager.HoleTableStyles Property Introduced in Inventor 2009

DrawingStylesManager.Layers Property Introduced in Inventor 10

DrawingStylesManager.LeaderStyles Property Introduced in Inventor 2009

DrawingStylesManager.ObjectDefaultsStyles Property Introduced in Inventor 9

DrawingStylesManager.Parent Property Introduced in Inventor 9

DrawingStylesManager.PartsListStyles Property Introduced in Inventor 2011

DrawingStylesManager.RevisionTableStyles Property Introduced in Inventor 2011

DrawingStylesManager.StandardStyles Property Introduced in Inventor 9

DrawingStylesManager.Styles Property Introduced in Inventor 2008

DrawingStylesManager.SurfaceTextureStyles Property Introduced in Inventor 2009

DrawingStylesManager.TableStyles Property Introduced in Inventor 2011

DrawingStylesManager.TextStyles Property Introduced in Inventor 9

DrawingStylesManager.Type Property Introduced in Inventor 9

DrawingView Interface Introduced in Inventor 4

DrawingView Methods

DrawingView.Align Method Introduced in Inventor 2010

DrawingView.AlignAuxiliary Method Introduced in Inventor 2010

DrawingView.CopyTo Method Introduced in Inventor 9

DrawingView.CreateOriginIndicator Method Introduced in Inventor 2009

DrawingView.Delete Method Introduced in Inventor 6

DrawingView.DrawingCurves Method Introduced in Inventor 11

DrawingView.DrawingViewToModelSpace Method Introduced in Inventor 9

DrawingView.DrawingViewToSheetSpace Method Introduced in Inventor 9

DrawingView.GetAutomatedCenterlineSettings Method Introduced in Inventor 2010

DrawingView.GetIncludeStatus Method Introduced in Inventor 2008

DrawingView.GetReferenceKey Method Introduced in Inventor 9

DrawingView.GetVisibility Method Introduced in Inventor 10

DrawingView.GetWeldmentState Method Introduced in Inventor 2010

DrawingView.InsertInModelSpace Method

DrawingView.ModelToDrawingViewSpace Method Introduced in Inventor 9

DrawingView.ModelToSheetSpace Method Introduced in Inventor 9

DrawingView.MoveTo Method Introduced in Inventor 9

DrawingView.ReferencedFile Method

DrawingView.RotateByAngle Method Introduced in Inventor 11

DrawingView.SetAutomatedCenterlineSettings Method Introduced in Inventor 2010

DrawingView.SetDesignViewRepresentation Method Introduced in Inventor 11

DrawingView.SetIncludeStatus Method Introduced in Inventor 2008

DrawingView.SetVisibility Method Introduced in Inventor 10

DrawingView.SetWeldmentState Method Introduced in Inventor 2010

DrawingView.SheetToDrawingViewSpace Method Introduced in Inventor 9

DrawingView.SheetToModelSpace Method Introduced in Inventor 9

DrawingView.ShowHiddenAnnotations Method Introduced in Inventor 11

DrawingView.ShowHiddenCurves Method Introduced in Inventor 11

DrawingView.ShowName Method ([in] VARIANT_BOOL)

DrawingView.ShowName Method ([out, retval] VARIANT_BOOL*)

DrawingView.ShowScale Method ([in] VARIANT_BOOL)

DrawingView.ShowScale Method ([out, retval] VARIANT_BOOL*)

DrawingView Properties

DrawingView.ActiveDesignViewRepresentation Property Introduced in Inventor 11

DrawingView.ActiveLevelOfDetailRepresentation Property Introduced in Inventor 11

DrawingView.ActiveMemberName Property Introduced in Inventor 11

DrawingView.ActivePositionalRepresentation Property Introduced in Inventor 11

DrawingView.ActivePresentationView Property Introduced in Inventor 2010

DrawingView.Aligned Property Introduced in Inventor 2010

DrawingView.AttributeSets Property Introduced in Inventor 9

DrawingView.AuxiliaryOrientationEdge Property Introduced in Inventor 2010

DrawingView.BitmapAvailable Property Introduced in Inventor 4

DrawingView.BreakOperations Property Introduced in Inventor 2010

DrawingView.BreakOutOperations Property Introduced in Inventor 2010

DrawingView.Camera Property Introduced in Inventor 4

DrawingView.Center Property Introduced in Inventor 6

DrawingView.ClientGraphicsCollection Property Introduced in Inventor 9

DrawingView.DataIO Property Introduced in Inventor 4

DrawingView.DisplayBendExtents Property Introduced in Inventor 2010

DrawingView.DisplayDefinitionInBase Property Introduced in Inventor 2010

DrawingView.DisplayForeshortenedTangentEdges Property Introduced in Inventor 2010

DrawingView.DisplayHatching Property Introduced in Inventor 2010

DrawingView.DisplayInterferenceEdges Property Introduced in Inventor 2010

DrawingView.DisplayTangentEdges Property Introduced in Inventor 2008

DrawingView.DisplayThreadFeatures Property Introduced in Inventor 2010

DrawingView.DisplayTrails Property Introduced in Inventor 2010

DrawingView.DrawingViewEvents Property Introduced in Inventor 9

DrawingView.DrawingViewToModelTransform Property Introduced in Inventor 9

DrawingView.DrawingViewToSheetTransform Property Introduced in Inventor 9

DrawingView.GeneralDimensionType Property Introduced in Inventor 2008

DrawingView.GraphicsDataSetsCollection Property Introduced in Inventor 9

DrawingView.HasOriginIndicator Property Introduced in Inventor 2009

DrawingView.Height Property Introduced in Inventor 4

DrawingView.InheritBreak Property Introduced in Inventor 2010

DrawingView.InheritBreakOut Property Introduced in Inventor 2010

DrawingView.InheritSection Property Introduced in Inventor 2010

DrawingView.InheritSlice Property Introduced in Inventor 2010

DrawingView.IsFlatPatternView Property Introduced in Inventor 2008

DrawingView.IsUpdateComplete Property Introduced in Inventor 2012

DrawingView.Label Property Introduced in Inventor 2009

DrawingView.Left Property Introduced in Inventor 4

DrawingView.ModelToDrawingViewTransform Property Introduced in Inventor 9

DrawingView.ModelToSheetTransform Property Introduced in Inventor 9

DrawingView.Name Property Introduced in Inventor 4

DrawingView.OriginIndicator Property Introduced in Inventor 2009

DrawingView.Parent Property Introduced in Inventor 4

DrawingView.ParentView Property Introduced in Inventor 9

DrawingView.Position Property Introduced in Inventor 2008

DrawingView.PresentationViewAssociative Property Introduced in Inventor 2010

DrawingView.ReferencedDocumentDescriptor Property Introduced in Inventor 11

DrawingView.Rotation Property Introduced in Inventor 2008

DrawingView.Scale Property Introduced in Inventor 4

DrawingView.ScaleFromBase Property Introduced in Inventor 11

DrawingView.ScaleString Property Introduced in Inventor 2008

DrawingView.SheetToDrawingViewTransform Property Introduced in Inventor 9

DrawingView.SheetToModelTransform Property Introduced in Inventor 9

DrawingView.ShowLabel Property Introduced in Inventor 2009

DrawingView.Sketches Property Introduced in Inventor 5.3

DrawingView.StandardPartsSectionBehavior Property Introduced in Inventor 2010

DrawingView.Suppressed Property Introduced in Inventor 2009

DrawingView.Top Property Introduced in Inventor 4

DrawingView.Type Property Introduced in Inventor 4

DrawingView.UpToDate Property Introduced in Inventor 2008

DrawingView.ViewJustification Property Introduced in Inventor 2010

DrawingView.ViewOrientationFromBase Property Introduced in Inventor 2012

DrawingView.ViewStyle Property Introduced in Inventor 11

DrawingView.ViewType Property Introduced in Inventor 4

DrawingView.Width Property Introduced in Inventor 4

DrawingViewEvents CoClass Introduced in Inventor 9

DrawingViewEventsObject Interface Introduced in Inventor 9

DrawingViewEventsObject Properties

DrawingViewEventsObject.Application Property Introduced in Inventor 9

DrawingViewEventsObject.Parent Property Introduced in Inventor 9

DrawingViewEventsObject.Type Property Introduced in Inventor 9

DrawingViewEventsSink Interface Introduced in Inventor 9

DrawingViewEventsSink Methods

DrawingViewEventsSink.OnViewUpdate Method Introduced in Inventor 9

DrawingViewLabel Interface Introduced in Inventor 2009

DrawingViewLabel Properties

DrawingViewLabel.Application Property Introduced in Inventor 2009

DrawingViewLabel.Color Property Introduced in Inventor 2009

DrawingViewLabel.ConstrainToBorder Property Introduced in Inventor 2009

DrawingViewLabel.FormattedText Property Introduced in Inventor 2009

DrawingViewLabel.HorizontalJustification Property Introduced in Inventor 2009

DrawingViewLabel.Layer Property Introduced in Inventor 2009

DrawingViewLabel.LineSpacing Property Introduced in Inventor 2009

DrawingViewLabel.LineSpacingType Property Introduced in Inventor 2009

DrawingViewLabel.Parent Property Introduced in Inventor 2009

DrawingViewLabel.Position Property Introduced in Inventor 2009

DrawingViewLabel.RangeBox Property Introduced in Inventor 2010

DrawingViewLabel.StackedTextPosition Property Introduced in Inventor 2009

DrawingViewLabel.Text Property Introduced in Inventor 2009

DrawingViewLabel.TextStyle Property Introduced in Inventor 2009

DrawingViewLabel.Type Property Introduced in Inventor 2009

DrawingViewLabel.VerticalJustification Property Introduced in Inventor 2009

DrawingViewLabel.WidthScale Property Introduced in Inventor 2009

DrawingViews Interface Introduced in Inventor 4

DrawingViews Methods

DrawingViews.AddAssociativeDraftView Method Introduced in Inventor 9

DrawingViews.AddAuxiliaryView Method Introduced in Inventor 2010

DrawingViews.AddBaseView Method Introduced in Inventor 6

DrawingViews.AddDetailView Method Introduced in Inventor 11

DrawingViews.AddDraftView Method Introduced in Inventor 9

DrawingViews.AddOverlayView Method Introduced in Inventor 2010

DrawingViews.AddProjectedView Method Introduced in Inventor 6

DrawingViews.AddSectionView Method Introduced in Inventor 9

DrawingViews.Item Method Introduced in Inventor 4

DrawingViews Properties

DrawingViews.Count Property Introduced in Inventor 4

DrawingViews.Type Property Introduced in Inventor 4

DriveConstraintSettingsObject Interface Introduced in Inventor 2012

DriveConstraintSettingsObject Methods

DriveConstraintSettingsObject.GetIncrement Method Introduced in Inventor 2012

DriveConstraintSettingsObject.GoToEnd Method Introduced in Inventor 2012

DriveConstraintSettingsObject.GoToStart Method Introduced in Inventor 2012

DriveConstraintSettingsObject.PlayForward Method Introduced in Inventor 2012

DriveConstraintSettingsObject.PlayReverse Method Introduced in Inventor 2012

DriveConstraintSettingsObject.SetIncrement Method Introduced in Inventor 2012

DriveConstraintSettingsObject.StartAVIRecording Method Introduced in Inventor 2012

DriveConstraintSettingsObject.StartWMVRecording Method Introduced in Inventor 2012

DriveConstraintSettingsObject.StepForward Method Introduced in Inventor 2012

DriveConstraintSettingsObject.StepReverse Method Introduced in Inventor 2012

DriveConstraintSettingsObject.StopRecording Method Introduced in Inventor 2012

DriveConstraintSettingsObject Properties

DriveConstraintSettingsObject.Application Property Introduced in Inventor 2012

DriveConstraintSettingsObject.CollisionDetection Property Introduced in Inventor 2012

DriveConstraintSettingsObject.DriveAdaptivity Property Introduced in Inventor 2012

DriveConstraintSettingsObject.EndValue Property Introduced in Inventor 2012

DriveConstraintSettingsObject.FrameRate Property Introduced in Inventor 2012

DriveConstraintSettingsObject.IsInitialized Property Introduced in Inventor 2012

DriveConstraintSettingsObject.Parent Property Introduced in Inventor 2012

DriveConstraintSettingsObject.PauseDelay Property Introduced in Inventor 2012

DriveConstraintSettingsObject.RepetitionCount Property Introduced in Inventor 2012

DriveConstraintSettingsObject.RepetitionStartEndStart Property Introduced in Inventor 2012

DriveConstraintSettingsObject.StartValue Property Introduced in Inventor 2012

DriveConstraintSettingsObject.Type Property Introduced in Inventor 2012

DriveConstraintSettingsSink Interface

DriveConstraintSettingsSink Methods

DriveConstraintSettingsSink.OnCollision Method Introduced in Inventor 2012

Edge Interface Introduced in Inventor 4

Edge Methods

Edge.CalculateStrokes Method Introduced in Inventor 5.3

Edge.GetClosestPointTo Method Introduced in Inventor 11

Edge.GetExistingStrokes Method Introduced in Inventor 5.3

Edge.GetExistingStrokeTolerances Method Introduced in Inventor 5.3

Edge.GetReferenceKey Method Introduced in Inventor 5

Edge.GetSourceEdge Method Introduced in Inventor 10

Edge Properties

Edge.Application Property Introduced in Inventor 11

Edge.AttributeSets Property Introduced in Inventor 5

Edge.EdgeUses Property Introduced in Inventor 4

Edge.Evaluator Property Introduced in Inventor 4

Edge.Faces Property Introduced in Inventor 4

Edge.Geometry Property Introduced in Inventor 6

Edge.GeometryForm Property Introduced in Inventor 4

Edge.GeometryType Property Introduced in Inventor 2008

Edge.IsParamReversed Property Introduced in Inventor 4

Edge.IsTolerant Property

Edge.Parent Property Introduced in Inventor 5

Edge.PointOnEdge Property Introduced in Inventor 9

Edge.StartVertex Property Introduced in Inventor 4

Edge.StopVertex Property Introduced in Inventor 4

Edge.TangentiallyConnectedEdges Property Introduced in Inventor 5.3

Edge.Tolerance Property

Edge.TransientKey Property Introduced in Inventor 9

Edge.Type Property Introduced in Inventor 5

Edge.Wire Property Introduced in Inventor 2008

EdgeCollection Interface Introduced in Inventor 5.3

EdgeCollection Properties

EdgeCollection.CollectionType Property Introduced in Inventor 5.3

EdgeDefinition Interface Introduced in Inventor 2011

EdgeDefinition Properties

EdgeDefinition.Application Property

EdgeDefinition.AssociativeID Property

EdgeDefinition.EndVertex Property

EdgeDefinition.FaceOne Property

EdgeDefinition.FaceTwo Property

EdgeDefinition.IsParamReversed Property Introduced in Inventor 2011

EdgeDefinition.ModelSpaceCurve Property

EdgeDefinition.ParameterSpaceCurveOne Property

EdgeDefinition.ParameterSpaceCurveTwo Property

EdgeDefinition.StartVertex Property

EdgeDefinition.Type Property

EdgeDefinitions Interface Introduced in Inventor 2011

EdgeDefinitions Methods

EdgeDefinitions.Add Method

EdgeDefinitions.Item Method

EdgeDefinitions Properties

EdgeDefinitions.Application Property

EdgeDefinitions.Count Property

EdgeDefinitions.Type Property

EdgeLoop Interface Introduced in Inventor 4

EdgeLoop Methods

EdgeLoop.GetReferenceKey Method Introduced in Inventor 5

EdgeLoop Properties

EdgeLoop.Application Property Introduced in Inventor 11

EdgeLoop.AttributeSets Property Introduced in Inventor 5

EdgeLoop.Edges Property Introduced in Inventor 4

EdgeLoop.EdgeUses Property Introduced in Inventor 4

EdgeLoop.Face Property Introduced in Inventor 4

EdgeLoop.IsOuterEdgeLoop Property Introduced in Inventor 4

EdgeLoop.Parent Property Introduced in Inventor 5

EdgeLoop.RangeBox Property Introduced in Inventor 4

EdgeLoop.TransientKey Property Introduced in Inventor 9

EdgeLoop.Type Property Introduced in Inventor 5

EdgeLoopDefinition Interface Introduced in Inventor 2011

EdgeLoopDefinition Properties

EdgeLoopDefinition.Application Property

EdgeLoopDefinition.EdgeUseDefinitions Property

EdgeLoopDefinition.Type Property

EdgeLoopDefinitions Interface Introduced in Inventor 2011

EdgeLoopDefinitions Methods

EdgeLoopDefinitions.Add Method

EdgeLoopDefinitions.Item Method

EdgeLoopDefinitions Properties

EdgeLoopDefinitions.Application Property

EdgeLoopDefinitions.Count Property

EdgeLoopDefinitions.Type Property

EdgeLoopProxy Interface Introduced in Inventor 4

EdgeLoopProxy Properties

EdgeLoopProxy.ContainingOccurrence Property Introduced in Inventor 4

EdgeLoopProxy.NativeObject Property Introduced in Inventor 4

EdgeLoops Interface Introduced in Inventor 4

EdgeLoops Methods

EdgeLoops.Item Method Introduced in Inventor 4

EdgeLoops Properties

EdgeLoops.Count Property Introduced in Inventor 4

EdgeLoops.Type Property Introduced in Inventor 4

EdgeProxy Interface Introduced in Inventor 4

EdgeProxy Properties

EdgeProxy.ContainingOccurrence Property Introduced in Inventor 4

EdgeProxy.NativeObject Property Introduced in Inventor 4

Edges Interface Introduced in Inventor 4

Edges Methods

Edges.Item Method Introduced in Inventor 4

Edges Properties

Edges.Count Property Introduced in Inventor 4

Edges.Type Property Introduced in Inventor 4

EdgeUse Interface Introduced in Inventor 4

EdgeUse Methods

EdgeUse.GetReferenceKey Method Introduced in Inventor 5

EdgeUse Properties

EdgeUse.Application Property Introduced in Inventor 11

EdgeUse.CurveType Property Introduced in Inventor 4

EdgeUse.Edge Property Introduced in Inventor 4

EdgeUse.EdgeLoop Property Introduced in Inventor 4

EdgeUse.Evaluator Property Introduced in Inventor 4

EdgeUse.Geometry Property Introduced in Inventor 6

EdgeUse.GeometryForm Property Introduced in Inventor 4

EdgeUse.IsOpposedToEdge Property Introduced in Inventor 4

EdgeUse.IsParamReversed Property Introduced in Inventor 4

EdgeUse.Next Property Introduced in Inventor 4

EdgeUse.Parent Property Introduced in Inventor 5

EdgeUse.Partner Property Introduced in Inventor 4

EdgeUse.Previous Property Introduced in Inventor 4

EdgeUse.TransientKey Property Introduced in Inventor 9

EdgeUse.Type Property Introduced in Inventor 5

EdgeUse.Wire Property Introduced in Inventor 2008

EdgeUseDefinition Interface Introduced in Inventor 2011

EdgeUseDefinition Properties

EdgeUseDefinition.Application Property

EdgeUseDefinition.EdgeDefinition Property

EdgeUseDefinition.IsOpposedToEdge Property

EdgeUseDefinition.Type Property

EdgeUseDefinitions Interface Introduced in Inventor 2011

EdgeUseDefinitions Methods

EdgeUseDefinitions.Add Method

EdgeUseDefinitions.Item Method

EdgeUseDefinitions Properties

EdgeUseDefinitions.Application Property

EdgeUseDefinitions.Count Property

EdgeUseDefinitions.Type Property

EdgeUseProxy Interface Introduced in Inventor 4

EdgeUseProxy Properties

EdgeUseProxy.ContainingOccurrence Property Introduced in Inventor 4

EdgeUseProxy.NativeObject Property Introduced in Inventor 4

EdgeUses Interface Introduced in Inventor 4

EdgeUses Methods

EdgeUses.Item Method Introduced in Inventor 4

EdgeUses Properties

EdgeUses.Count Property Introduced in Inventor 4

EdgeUses.Type Property Introduced in Inventor 4

EdgeWidthExtent Interface Introduced in Inventor 2009

EdgeWidthExtent Properties

EdgeWidthExtent.Edge Property Introduced in Inventor 2009

EllipseFull Interface Introduced in Inventor 4

EllipseFull Methods

EllipseFull.GetEllipseFullData Method Introduced in Inventor 4

EllipseFull.PutEllipseFullData Method Introduced in Inventor 4

EllipseFull Properties

EllipseFull.Center Property Introduced in Inventor 4

EllipseFull.Evaluator Property Introduced in Inventor 4

EllipseFull.MajorAxisVector Property Introduced in Inventor 4

EllipseFull.MinorMajorRatio Property Introduced in Inventor 4

EllipseFull.Normal Property Introduced in Inventor 4

EllipseFull2d Interface Introduced in Inventor 4

EllipseFull2d Methods

EllipseFull2d.GetEllipseFullData Method Introduced in Inventor 4

EllipseFull2d.PutEllipseFullData Method Introduced in Inventor 4

EllipseFull2d Properties

EllipseFull2d.Center Property Introduced in Inventor 4

EllipseFull2d.Evaluator Property Introduced in Inventor 4

EllipseFull2d.MajorAxisVector Property Introduced in Inventor 4

EllipseFull2d.MinorMajorRatio Property Introduced in Inventor 4

EllipseRadiusDimConstraint Interface Introduced in Inventor 5

EllipseRadiusDimConstraint Properties

EllipseRadiusDimConstraint.Entity Property Introduced in Inventor 5

EllipseRadiusDimConstraint.MajorRadius Property Introduced in Inventor 5

EllipseRadiusDimConstraintProxy Interface Introduced in Inventor 6

EllipseRadiusDimConstraintProxy Properties

EllipseRadiusDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

EllipseRadiusDimConstraintProxy.NativeObject Property Introduced in Inventor 6

EllipticalArc Interface Introduced in Inventor 6

EllipticalArc Methods

EllipticalArc.GetEllipticalArcData Method Introduced in Inventor 6

EllipticalArc.PutEllipticalArcData Method Introduced in Inventor 6

EllipticalArc Properties

EllipticalArc.Center Property Introduced in Inventor 6

EllipticalArc.EndPoint Property Introduced in Inventor 6

EllipticalArc.Evaluator Property Introduced in Inventor 6

EllipticalArc.MajorAxis Property Introduced in Inventor 6

EllipticalArc.MajorRadius Property Introduced in Inventor 6

EllipticalArc.MinorAxis Property Introduced in Inventor 6

EllipticalArc.MinorRadius Property Introduced in Inventor 6

EllipticalArc.StartAngle Property Introduced in Inventor 6

EllipticalArc.StartPoint Property Introduced in Inventor 6

EllipticalArc.SweepAngle Property Introduced in Inventor 6

EllipticalArc2d Interface Introduced in Inventor 5

EllipticalArc2d Methods

EllipticalArc2d.GetEllipticalArcData Method Introduced in Inventor 5

EllipticalArc2d.PutEllipticalArcData Method Introduced in Inventor 5

EllipticalArc2d Properties

EllipticalArc2d.Center Property Introduced in Inventor 5

EllipticalArc2d.EndPoint Property Introduced in Inventor 5

EllipticalArc2d.Evaluator Property Introduced in Inventor 5

EllipticalArc2d.MajorAxis Property Introduced in Inventor 5

EllipticalArc2d.MajorRadius Property Introduced in Inventor 5

EllipticalArc2d.MinorRadius Property Introduced in Inventor 5

EllipticalArc2d.StartAngle Property Introduced in Inventor 5

EllipticalArc2d.StartPoint Property Introduced in Inventor 5

EllipticalArc2d.SweepAngle Property Introduced in Inventor 5

EllipticalCone Interface Introduced in Inventor 4

EllipticalCone Methods

EllipticalCone.GetEllipticalConeData Method Introduced in Inventor 4

EllipticalCone.PutEllipticalConeData Method Introduced in Inventor 4

EllipticalCone Properties

EllipticalCone.AxisVector Property Introduced in Inventor 4

EllipticalCone.BasePoint Property Introduced in Inventor 4

EllipticalCone.Evaluator Property Introduced in Inventor 4

EllipticalCone.HalfAngle Property Introduced in Inventor 4

EllipticalCone.IsExpanding Property Introduced in Inventor 4

EllipticalCone.MajorAxisVector Property Introduced in Inventor 4

EllipticalCone.MinorMajorRatio Property Introduced in Inventor 4

EllipticalCylinder Interface Introduced in Inventor 4

EllipticalCylinder Methods

EllipticalCylinder.GetEllipticalCylinderData Method Introduced in Inventor 4

EllipticalCylinder.PutEllipticalCylinderData Method Introduced in Inventor 4

EllipticalCylinder Properties

EllipticalCylinder.AxisVector Property Introduced in Inventor 4

EllipticalCylinder.BasePoint Property Introduced in Inventor 4

EllipticalCylinder.Evaluator Property Introduced in Inventor 4

EllipticalCylinder.MajorAxisVector Property Introduced in Inventor 4

EllipticalCylinder.MinorMajorRatio Property Introduced in Inventor 4

EmbossFeature Interface Introduced in Inventor 6

EmbossFeature Methods

EmbossFeature.SetEmbossEngraveFromPlane Method Introduced in Inventor 2008

EmbossFeature.SetEmbossFromFace Method Introduced in Inventor 2008

EmbossFeature.SetEngraveFromFace Method Introduced in Inventor 2008

EmbossFeature Properties

EmbossFeature.Depth Property Introduced in Inventor 2008

EmbossFeature.Direction Property Introduced in Inventor 2008

EmbossFeature.EmbossType Property Introduced in Inventor 2008

EmbossFeature.Profile Property Introduced in Inventor 2008

EmbossFeature.Taper Property Introduced in Inventor 2008

EmbossFeature.TopFaceColor Property Introduced in Inventor 2008

EmbossFeature.WrapFace Property Introduced in Inventor 2008

EmbossFeature.WrapToFace Property Introduced in Inventor 2008

EmbossFeatureProxy Interface Introduced in Inventor 9

EmbossFeatureProxy Properties

EmbossFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

EmbossFeatureProxy.NativeObject Property Introduced in Inventor 9

EmbossFeatures Interface Introduced in Inventor 6

EmbossFeatures Methods

EmbossFeatures.AddEmbossEngraveFromPlane Method Introduced in Inventor 2008

EmbossFeatures.AddEmbossFromFace Method Introduced in Inventor 2008

EmbossFeatures.AddEngraveFromFace Method Introduced in Inventor 2008

EmbossFeatures.Item Method Introduced in Inventor 6

EmbossFeatures Properties

EmbossFeatures.Application Property Introduced in Inventor 6

EmbossFeatures.Count Property Introduced in Inventor 6

EmbossFeatures.Type Property Introduced in Inventor 6

EndOfFeatures Interface Introduced in Inventor 10

EndOfFeatures Properties

EndOfFeatures.Application Property Introduced in Inventor 10

EndOfFeatures.Parent Property Introduced in Inventor 10

EndOfFeatures.Type Property Introduced in Inventor 10

EnumType Interface

EnumType Methods

EnumType.MoveNext Method

EnumType.Reset Method

EnumType Properties

EnumType.Count Property

EnumType.CurrentIndex Property

EnumType.Name Property

EnumType.Value Property

EnumType.ValueName Property

Environment Interface Introduced in Inventor 5

Environment Methods

Environment.Delete Method Introduced in Inventor 9

Environment.GetRadialMarkingMenu Method Introduced in Inventor 2012

Environment Properties

Environment.AdditionalVisibleRibbonTabs Property Introduced in Inventor 2010

Environment.Application Property Introduced in Inventor 5

Environment.BuiltIn Property Introduced in Inventor 9

Environment.ClientId Property Introduced in Inventor 10

Environment.ContextMenuList Property Introduced in Inventor 9

Environment.DefaultMenuBar Property Introduced in Inventor 9

Environment.DefaultRibbonTab Property Introduced in Inventor 2010

Environment.DefaultToolBar Property Introduced in Inventor 9

Environment.DisabledCommandList Property Introduced in Inventor 10

Environment.DisabledCommandTypes Property Introduced in Inventor 10

Environment.DisplayName Property Introduced in Inventor 5

Environment.InheritAllRibbonTabs Property Introduced in Inventor 2010

Environment.InternalName Property Introduced in Inventor 5

Environment.LargeIcon Property Introduced in Inventor 10

Environment.PanelBar Property Introduced in Inventor 9

Environment.Parent Property Introduced in Inventor 5

Environment.Ribbon Property Introduced in Inventor 2010

Environment.StandardIcon Property Introduced in Inventor 10

Environment.Type Property Introduced in Inventor 5

EnvironmentList Interface Introduced in Inventor 10

EnvironmentList Methods

EnvironmentList.Add Method Introduced in Inventor 10

EnvironmentList.Item Method Introduced in Inventor 10

EnvironmentList.Remove Method Introduced in Inventor 10

EnvironmentList Properties

EnvironmentList.Application Property Introduced in Inventor 10

EnvironmentList.Count Property Introduced in Inventor 10

EnvironmentList.Type Property Introduced in Inventor 10

EnvironmentManager Interface Introduced in Inventor 10

EnvironmentManager Methods

EnvironmentManager.GetCurrentEnvironment Method Introduced in Inventor 10

EnvironmentManager.SetCurrentEnvironment Method Introduced in Inventor 10

EnvironmentManager Properties

EnvironmentManager.Application Property Introduced in Inventor 10

EnvironmentManager.BaseEnvironment Property Introduced in Inventor 10

EnvironmentManager.EditObjectEnvironment Property Introduced in Inventor 10

EnvironmentManager.OverrideEnvironment Property Introduced in Inventor 10

EnvironmentManager.Parent Property Introduced in Inventor 10

EnvironmentManager.Type Property Introduced in Inventor 10

Environments Interface Introduced in Inventor 5

Environments Methods

Environments.Add Method Introduced in Inventor 10

Environments.Item Method Introduced in Inventor 5

Environments Properties

Environments.Application Property Introduced in Inventor 5

Environments.Count Property Introduced in Inventor 5

Environments.Type Property Introduced in Inventor 5

EqualLengthConstraint Interface Introduced in Inventor 5

EqualLengthConstraint Properties

EqualLengthConstraint.LineOne Property Introduced in Inventor 5

EqualLengthConstraint.LineTwo Property Introduced in Inventor 5

EqualLengthConstraintProxy Interface Introduced in Inventor 6

EqualLengthConstraintProxy Properties

EqualLengthConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

EqualLengthConstraintProxy.NativeObject Property Introduced in Inventor 6

EqualRadiusConstraint Interface Introduced in Inventor 5

EqualRadiusConstraint Properties

EqualRadiusConstraint.EntityOne Property Introduced in Inventor 5

EqualRadiusConstraint.EntityTwo Property Introduced in Inventor 5

EqualRadiusConstraintProxy Interface Introduced in Inventor 6

EqualRadiusConstraintProxy Properties

EqualRadiusConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

EqualRadiusConstraintProxy.NativeObject Property Introduced in Inventor 6

ErrorManager Interface Introduced in Inventor 2010

ErrorManager Methods

ErrorManager.AddMessage Method Introduced in Inventor 2010

ErrorManager.Clear Method Introduced in Inventor 2010

ErrorManager.Show Method Introduced in Inventor 2010

ErrorManager.StartMessageSection Method Introduced in Inventor 2010

ErrorManager Properties

ErrorManager.AllMessages Property Introduced in Inventor 2010

ErrorManager.Application Property Introduced in Inventor 2010

ErrorManager.HasErrors Property Introduced in Inventor 2010

ErrorManager.HasWarnings Property Introduced in Inventor 2010

ErrorManager.IsMessageSectionActive Property Introduced in Inventor 2010

ErrorManager.LastMessage Property Introduced in Inventor 2010

ErrorManager.Parent Property Introduced in Inventor 2010

ErrorManager.Type Property Introduced in Inventor 2010

ExpressionLimits Interface Introduced in Inventor 2010

ExpressionLimits Properties

ExpressionLimits.Application Property Introduced in Inventor 2010

ExpressionLimits.DefaultValue Property Introduced in Inventor 2010

ExpressionLimits.IncrementValue Property Introduced in Inventor 2010

ExpressionLimits.MaximumValue Property Introduced in Inventor 2010

ExpressionLimits.MaximumValueComparisonType Property Introduced in Inventor 2010

ExpressionLimits.MinimumValue Property Introduced in Inventor 2010

ExpressionLimits.MinimumValueComparisonType Property Introduced in Inventor 2010

ExpressionLimits.Type Property Introduced in Inventor 2010

ExpressionList Interface Introduced in Inventor 2011

ExpressionList Methods

ExpressionList.ClearAll Method

ExpressionList.GetExpressionList Method

ExpressionList.SetExpressionList Method

ExpressionList Properties

ExpressionList._NewEnum Property

ExpressionList.Application Property

ExpressionList.Count Property Introduced in Inventor 2011

ExpressionList.Item Method Introduced in Inventor 2011

ExpressionList.Parent Property Introduced in Inventor 2011

ExpressionList.Type Property

ExtendFeature Interface Introduced in Inventor 11

ExtendFeatureProxy Interface Introduced in Inventor 11

ExtendFeatureProxy Properties

ExtendFeatureProxy.ContainingOccurrence Property Introduced in Inventor 11

ExtendFeatureProxy.NativeObject Property Introduced in Inventor 11

ExtendFeatures Interface Introduced in Inventor 11

ExtendFeatures Methods

ExtendFeatures.Item Method Introduced in Inventor 11

ExtendFeatures Properties

ExtendFeatures.Application Property Introduced in Inventor 11

ExtendFeatures.Count Property Introduced in Inventor 11

ExtendFeatures.Type Property Introduced in Inventor 11

ExtrudeDefinition Interface Introduced in Inventor 2012

ExtrudeDefinition Methods

ExtrudeDefinition.Copy Method Introduced in Inventor 2012

ExtrudeDefinition.SetDistanceExtent Method Introduced in Inventor 2012

ExtrudeDefinition.SetDistanceExtentTwo Method Introduced in Inventor 2012

ExtrudeDefinition.SetFromToExtent Method Introduced in Inventor 2012

ExtrudeDefinition.SetThroughAllExtent Method Introduced in Inventor 2012

ExtrudeDefinition.SetToExtent Method Introduced in Inventor 2012

ExtrudeDefinition.SetToNextExtent Method Introduced in Inventor 2012

ExtrudeDefinition Properties

ExtrudeDefinition.AffectedBodies Property Introduced in Inventor 2012

ExtrudeDefinition.AffectedOccurrences Property Introduced in Inventor 2012

ExtrudeDefinition.Application Property Introduced in Inventor 2012

ExtrudeDefinition.Extent Property Introduced in Inventor 2012

ExtrudeDefinition.ExtentTwo Property Introduced in Inventor 2012

ExtrudeDefinition.ExtentTwoType Property Introduced in Inventor 2012

ExtrudeDefinition.ExtentType Property Introduced in Inventor 2012

ExtrudeDefinition.InferiMates Property Introduced in Inventor 2012

ExtrudeDefinition.IsTwoDirectional Property Introduced in Inventor 2012

ExtrudeDefinition.MatchShape Property Introduced in Inventor 2012

ExtrudeDefinition.Operation Property Introduced in Inventor 2012

ExtrudeDefinition.Parent Property Introduced in Inventor 2012

ExtrudeDefinition.Profile Property Introduced in Inventor 2012

ExtrudeDefinition.TaperAngle Property Introduced in Inventor 2012

ExtrudeDefinition.TaperAngleTwo Property Introduced in Inventor 2012

ExtrudeDefinition.Type Property Introduced in Inventor 2012

ExtrudeFeature Interface Introduced in Inventor 5

ExtrudeFeature Methods

ExtrudeFeature.AddParticipant Method Introduced in Inventor 11

ExtrudeFeature Properties

ExtrudeFeature.Definition Property

ExtrudeFeature.EndFaces Property Introduced in Inventor 5

ExtrudeFeature.SideFaces Property Introduced in Inventor 5

ExtrudeFeature.StartFaces Property Introduced in Inventor 5

ExtrudeFeatureProxy Interface Introduced in Inventor 9

ExtrudeFeatureProxy Properties

ExtrudeFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ExtrudeFeatureProxy.NativeObject Property Introduced in Inventor 9

ExtrudeFeatures Interface Introduced in Inventor 5

ExtrudeFeatures Methods

ExtrudeFeatures.Add Method

ExtrudeFeatures.AddByToFaceExtent Method

ExtrudeFeatures.CreateExtrudeDefinition Method

ExtrudeFeatures.Item Method Introduced in Inventor 5

ExtrudeFeatures Properties

ExtrudeFeatures.Application Property Introduced in Inventor 5

ExtrudeFeatures.Count Property Introduced in Inventor 5

ExtrudeFeatures.Type Property Introduced in Inventor 5

Face Interface Introduced in Inventor 4

Face Methods

Face.CalculateFacets Method Introduced in Inventor 5.3

Face.CalculateFacetsAndTextureMap Method Introduced in Inventor 9

Face.CalculateStrokes Method Introduced in Inventor 5.3

Face.GetClosestPointTo Method Introduced in Inventor 11

Face.GetExistingFacets Method Introduced in Inventor 5.3

Face.GetExistingFacetsAndTextureMap Method Introduced in Inventor 9

Face.GetExistingFacetTolerances Method Introduced in Inventor 5.3

Face.GetExistingStrokes Method Introduced in Inventor 5.3

Face.GetExistingStrokeTolerances Method Introduced in Inventor 5.3

Face.GetReferenceKey Method Introduced in Inventor 5

Face.GetRenderStyle Method Introduced in Inventor 7

Face.GetSourceFace Method Introduced in Inventor 10

Face.GetTextureScale Method

Face.SetRenderStyle Method Introduced in Inventor 7

Face Properties

Face.AlternateBody Method Introduced in Inventor 4

Face.Application Property Introduced in Inventor 11

Face.AttributeSets Property Introduced in Inventor 5

Face.CreatedByFeature Property Introduced in Inventor 6

Face.EdgeLoops Property Introduced in Inventor 4

Face.Edges Property Introduced in Inventor 4

Face.Evaluator Property Introduced in Inventor 4

Face.FaceShell Property Introduced in Inventor 4

Face.Geometry Property Introduced in Inventor 6

Face.GeometryForm Property Introduced in Inventor 4

Face.HasReferenceComponent Property Introduced in Inventor 2009

Face.InternalName Property

Face.IsParamReversed Property Introduced in Inventor 4

Face.Parent Property Introduced in Inventor 5

Face.PointOnFace Property Introduced in Inventor 9

Face.ReferenceComponent Property Introduced in Inventor 2009

Face.ReferencedEntity Property Introduced in Inventor 2009

Face.SurfaceBody Property Introduced in Inventor 4

Face.SurfaceType Property Introduced in Inventor 4

Face.TangentiallyConnectedFaces Property Introduced in Inventor 11

Face.TextureMaps Property Introduced in Inventor 10

Face.ThreadInfos Property Introduced in Inventor 2010

Face.TransientKey Property Introduced in Inventor 9

Face.Type Property Introduced in Inventor 5

Face.Vertices Property Introduced in Inventor 4

FaceCollection Interface Introduced in Inventor 9

FaceCollection Properties

FaceCollection.CollectionType Property Introduced in Inventor 9

FaceDefinition Interface Introduced in Inventor 2011

FaceDefinition Properties

FaceDefinition.Application Property

FaceDefinition.AssociativeID Property

FaceDefinition.EdgeLoopDefinitions Property

FaceDefinition.IsParamReversed Property Introduced in Inventor 2011

FaceDefinition.SurfaceGeometry Property

FaceDefinition.Type Property

FaceDefinitions Interface Introduced in Inventor 2011

FaceDefinitions Methods

FaceDefinitions.Add Method

FaceDefinitions.Item Method

FaceDefinitions Properties

FaceDefinitions.Application Property

FaceDefinitions.Count Property

FaceDefinitions.Type Property

FaceDraftFeature Interface Introduced in Inventor 5

FaceDraftFeature Properties

FaceDraftFeature.DirectionReversed Property Introduced in Inventor 9

FaceDraftFeature.DraftAngle Property Introduced in Inventor 9

FaceDraftFeature.FixedEdges Property Introduced in Inventor 9

FaceDraftFeature.InputFaces Property Introduced in Inventor 9

FaceDraftFeature.PullDirection Property Introduced in Inventor 9

FaceDraftFeatureProxy Interface Introduced in Inventor 9

FaceDraftFeatureProxy Properties

FaceDraftFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

FaceDraftFeatureProxy.NativeObject Property Introduced in Inventor 9

FaceDraftFeatures Interface Introduced in Inventor 5

FaceDraftFeatures Methods

FaceDraftFeatures.AddFixedEdge Method Introduced in Inventor 9

FaceDraftFeatures.AddFixedPlane Method Introduced in Inventor 9

FaceDraftFeatures.AddTaperShadow Method Introduced in Inventor 9

FaceDraftFeatures.Item Method Introduced in Inventor 5

FaceDraftFeatures Properties

FaceDraftFeatures.Application Property Introduced in Inventor 5

FaceDraftFeatures.Count Property Introduced in Inventor 5

FaceDraftFeatures.Type Property Introduced in Inventor 5

FaceFeature Interface Introduced in Inventor 5.3

FaceFeature Properties

FaceFeature.BendFeature Property Introduced in Inventor 2009

FaceFeature.Definition Property Introduced in Inventor 2009

FaceFeatureDefinition Interface Introduced in Inventor 2009

FaceFeatureDefinition Properties

FaceFeatureDefinition.Application Property Introduced in Inventor 2009

FaceFeatureDefinition.BendDefinition Property Introduced in Inventor 2009

FaceFeatureDefinition.Direction Property Introduced in Inventor 2009

FaceFeatureDefinition.Parent Property Introduced in Inventor 2009

FaceFeatureDefinition.Profile Property Introduced in Inventor 2009

FaceFeatureDefinition.Type Property Introduced in Inventor 2009

FaceFeatureProxy Interface Introduced in Inventor 9

FaceFeatures Interface Introduced in Inventor 5.3

FaceFeatures Methods

FaceFeatures.Add Method Introduced in Inventor 2009

FaceFeatures.CreateFaceFeatureDefinition Method Introduced in Inventor 2009

FaceFeatures.Item Method Introduced in Inventor 5.3

FaceFeatures Properties

FaceFeatures.Application Property Introduced in Inventor 5.3

FaceFeatures.Count Property Introduced in Inventor 5.3

FaceFeatures.Type Property Introduced in Inventor 5.3

FaceProxy Interface Introduced in Inventor 4

FaceProxy Properties

FaceProxy.ContainingOccurrence Property Introduced in Inventor 4

FaceProxy.NativeObject Property Introduced in Inventor 4

Faces Interface Introduced in Inventor 4

Faces Methods

Faces.Item Method Introduced in Inventor 4

Faces Properties

Faces.Count Property Introduced in Inventor 4

Faces.Type Property Introduced in Inventor 4

FaceShell Interface Introduced in Inventor 4

FaceShell Methods

FaceShell.GetReferenceKey Method Introduced in Inventor 5

FaceShell.IsPointInside Method Introduced in Inventor 4

FaceShell.Volume Method Introduced in Inventor 4

FaceShell Properties

FaceShell.Application Property Introduced in Inventor 11

FaceShell.AttributeSets Property Introduced in Inventor 5

FaceShell.Edges Property Introduced in Inventor 4

FaceShell.Faces Property Introduced in Inventor 4

FaceShell.IsClosed Property Introduced in Inventor 4

FaceShell.IsVoid Property Introduced in Inventor 4

FaceShell.Parent Property Introduced in Inventor 5

FaceShell.RangeBox Property Introduced in Inventor 4

FaceShell.SurfaceBody Property Introduced in Inventor 4

FaceShell.TransientKey Property Introduced in Inventor 9

FaceShell.Type Property Introduced in Inventor 5

FaceShellDefinition Interface Introduced in Inventor 2011

FaceShellDefinition Properties

FaceShellDefinition.Application Property

FaceShellDefinition.FaceDefinitions Property

FaceShellDefinition.Type Property

FaceShellDefinitions Interface Introduced in Inventor 2011

FaceShellDefinitions Methods

FaceShellDefinitions.Add Method

FaceShellDefinitions.Item Method

FaceShellDefinitions Properties

FaceShellDefinitions.Application Property

FaceShellDefinitions.Count Property

FaceShellDefinitions.Type Property

FaceShellProxy Interface Introduced in Inventor 4

FaceShellProxy Properties

FaceShellProxy.ContainingOccurrence Property Introduced in Inventor 4

FaceShellProxy.NativeObject Property Introduced in Inventor 4

FaceShells Interface Introduced in Inventor 4

FaceShells Methods

FaceShells.Item Method Introduced in Inventor 4

FaceShells Properties

FaceShells.Count Property Introduced in Inventor 4

FaceShells.Type Property Introduced in Inventor 4

FactoryOptions Interface Introduced in Inventor 2010

FactoryOptions Methods

FactoryOptions.ApplyToAllMembers Method Introduced in Inventor 2010

FactoryOptions Properties

FactoryOptions.Application Property Introduced in Inventor 2010

FactoryOptions.IsPartNumberIndexed Property Introduced in Inventor 2010

FactoryOptions.MemberNameIndexDigits Property Introduced in Inventor 2010

FactoryOptions.MemberNameIndexInitialValue Property Introduced in Inventor 2010

FactoryOptions.MemberNameIndexSeparator Property Introduced in Inventor 2010

FactoryOptions.MemberNameIndexStepValue Property Introduced in Inventor 2010

FactoryOptions.MemberNameType Property Introduced in Inventor 2010

FactoryOptions.MemberNameValue Property Introduced in Inventor 2010

FactoryOptions.PartNumberIndexDigits Property Introduced in Inventor 2010

FactoryOptions.PartNumberIndexInitialValue Property Introduced in Inventor 2010

FactoryOptions.PartNumberIndexSeparator Property Introduced in Inventor 2010

FactoryOptions.PartNumberIndexStepValue Property Introduced in Inventor 2010

FactoryOptions.PartNumberType Property Introduced in Inventor 2010

FactoryOptions.PartNumberValue Property Introduced in Inventor 2010

FactoryOptions.Type Property Introduced in Inventor 2010

FeatureBasedOccurrencePattern Interface Introduced in Inventor 6

FeatureBasedOccurrencePattern Properties

FeatureBasedOccurrencePattern.FeaturePattern Property Introduced in Inventor 9

FeatureBasedOccurrencePatternProxy Interface Introduced in Inventor 2010

FeatureBasedOccurrencePatternProxy Properties

FeatureBasedOccurrencePatternProxy.ContainingOccurrence Property Introduced in Inventor 2010

FeatureBasedOccurrencePatternProxy.NativeObject Property Introduced in Inventor 2010

FeatureControlFrame Interface Introduced in Inventor 2009

FeatureControlFrame Methods

FeatureControlFrame.Delete Method Introduced in Inventor 2009

FeatureControlFrame.GetReferenceKey Method Introduced in Inventor 2009

FeatureControlFrame Properties

FeatureControlFrame.AllAroundSymbol Property Introduced in Inventor 2009

FeatureControlFrame.Application Property Introduced in Inventor 2009

FeatureControlFrame.AttributeSets Property Introduced in Inventor 2009

FeatureControlFrame.DatumIdentifier Property Introduced in Inventor 2009

FeatureControlFrame.FeatureControlFrameRows Property Introduced in Inventor 2009

FeatureControlFrame.Layer Property Introduced in Inventor 2009

FeatureControlFrame.Leader Property Introduced in Inventor 2009

FeatureControlFrame.Notes Property Introduced in Inventor 2009

FeatureControlFrame.Parent Property Introduced in Inventor 2009

FeatureControlFrame.Position Property Introduced in Inventor 2009

FeatureControlFrame.Rotation Property Introduced in Inventor 2009

FeatureControlFrame.Style Property Introduced in Inventor 2009

FeatureControlFrame.Type Property Introduced in Inventor 2009

FeatureControlFrameRow Interface Introduced in Inventor 2009

FeatureControlFrameRow Methods

FeatureControlFrameRow.Delete Method Introduced in Inventor 2009

FeatureControlFrameRow Properties

FeatureControlFrameRow.Application Property Introduced in Inventor 2009

FeatureControlFrameRow.DatumOne Property Introduced in Inventor 2009

FeatureControlFrameRow.DatumThree Property Introduced in Inventor 2009

FeatureControlFrameRow.DatumTwo Property Introduced in Inventor 2009

FeatureControlFrameRow.GeometricCharacteristic Property Introduced in Inventor 2009

FeatureControlFrameRow.LowerTolerance Property Introduced in Inventor 2009

FeatureControlFrameRow.Parent Property Introduced in Inventor 2009

FeatureControlFrameRow.Tolerance Property Introduced in Inventor 2009

FeatureControlFrameRow.Type Property Introduced in Inventor 2009

FeatureControlFrameRows Interface Introduced in Inventor 2009

FeatureControlFrameRows Methods

FeatureControlFrameRows.Add Method Introduced in Inventor 2009

FeatureControlFrameRows.Item Method Introduced in Inventor 2009

FeatureControlFrameRows Properties

FeatureControlFrameRows.Application Property Introduced in Inventor 2009

FeatureControlFrameRows.Count Property Introduced in Inventor 2009

FeatureControlFrameRows.Type Property Introduced in Inventor 2009

FeatureControlFrames Interface Introduced in Inventor 2009

FeatureControlFrames Methods

FeatureControlFrames.Add Method Introduced in Inventor 2009

FeatureControlFrames.CreateFeatureControlFrameRows Method Introduced in Inventor 2009

FeatureControlFrames.Item Method Introduced in Inventor 2009

FeatureControlFrames Properties

FeatureControlFrames.Application Property Introduced in Inventor 2009

FeatureControlFrames.Count Property Introduced in Inventor 2009

FeatureControlFrames.Type Property Introduced in Inventor 2009

FeatureControlFrameStyle Interface Introduced in Inventor 2009

FeatureControlFrameStyle Properties

FeatureControlFrameStyle.AlignCellsVertically Property Introduced in Inventor 2009

FeatureControlFrameStyle.AllowTolerance2 Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateDecimalMarkerType Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateDisplayUnitType Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateLeadingZeroDisplay Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateLinearPrecision Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateLinearUnits Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateTrailingZeroDisplay Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateUnitsDisplay Property Introduced in Inventor 2009

FeatureControlFrameStyle.AlternateUnitsDisplayType Property Introduced in Inventor 2009

FeatureControlFrameStyle.AttachLeaderToCorner Property Introduced in Inventor 2009

FeatureControlFrameStyle.AvailableGeometricCharacteristics Property Introduced in Inventor 2009

FeatureControlFrameStyle.AvailableModifiers Property Introduced in Inventor 2009

FeatureControlFrameStyle.DecimalMarkerType Property Introduced in Inventor 2009

FeatureControlFrameStyle.DisplayUnitType Property Introduced in Inventor 2009

FeatureControlFrameStyle.LeaderStyle Property Introduced in Inventor 2009

FeatureControlFrameStyle.LeadingZeroDisplay Property Introduced in Inventor 2009

FeatureControlFrameStyle.LinearUnits Property Introduced in Inventor 2009

FeatureControlFrameStyle.MergeDatum Property Introduced in Inventor 2009

FeatureControlFrameStyle.MergeSymbol Property Introduced in Inventor 2009

FeatureControlFrameStyle.MergeTolerance Property Introduced in Inventor 2009

FeatureControlFrameStyle.ScaleToTextHeight Property Introduced in Inventor 2009

FeatureControlFrameStyle.Size Property Introduced in Inventor 2009

FeatureControlFrameStyle.TextStyle Property Introduced in Inventor 2009

FeatureControlFrameStyle.TrailingZeroDisplay Property Introduced in Inventor 2009

FeatureControlFrameStyle.WhiteSpace Property Introduced in Inventor 2009

FeatureControlFrameStylesEnumerator Interface Introduced in Inventor 2009

FeatureControlFrameStylesEnumerator Methods

FeatureControlFrameStylesEnumerator.Item Method Introduced in Inventor 2009

FeatureControlFrameStylesEnumerator Properties

FeatureControlFrameStylesEnumerator.Application Property Introduced in Inventor 2009

FeatureControlFrameStylesEnumerator.Count Property Introduced in Inventor 2009

FeatureControlFrameStylesEnumerator.Type Property Introduced in Inventor 2009

FeatureDimension Interface Introduced in Inventor 2008

FeatureDimension Methods

FeatureDimension.GetReferenceKey Method

FeatureDimension Properties

FeatureDimension.AnchorPoints Property

FeatureDimension.Application Property Introduced in Inventor 2008

FeatureDimension.AttributeSets Property

FeatureDimension.DimensionType Property

FeatureDimension.Parameter Property Introduced in Inventor 2008

FeatureDimension.Parent Property Introduced in Inventor 2008

FeatureDimension.TextPoint Property Introduced in Inventor 2008

FeatureDimension.Type Property Introduced in Inventor 2008

FeatureDimensionProxy Interface Introduced in Inventor 2008

FeatureDimensionProxy Properties

FeatureDimensionProxy.ContainingOccurrence Property Introduced in Inventor 2008

FeatureDimensionProxy.NativeObject Property Introduced in Inventor 2008

FeatureDimensions Interface Introduced in Inventor 2008

FeatureDimensions Methods

FeatureDimensions.Item Method Introduced in Inventor 2008

FeatureDimensions.Show Method Introduced in Inventor 2008

FeatureDimensions Properties

FeatureDimensions.Application Property Introduced in Inventor 2008

FeatureDimensions.Count Property Introduced in Inventor 2008

FeatureDimensions.Type Property Introduced in Inventor 2008

FeaturePatternElement Interface Introduced in Inventor 5

FeaturePatternElement Methods

FeaturePatternElement.GetReferenceKey Method Introduced in Inventor 5

FeaturePatternElement Properties

FeaturePatternElement.Application Property Introduced in Inventor 5

FeaturePatternElement.AttributeSets Property Introduced in Inventor 5

FeaturePatternElement.Faces Property Introduced in Inventor 5

FeaturePatternElement.Index Property Introduced in Inventor 2010

FeaturePatternElement.Parent Property Introduced in Inventor 5

FeaturePatternElement.ResultFeatures Property Introduced in Inventor 11

FeaturePatternElement.Suppressed Property Introduced in Inventor 5

FeaturePatternElement.Transform Property Introduced in Inventor 5

FeaturePatternElement.Type Property Introduced in Inventor 5

FeaturePatternElementProxy Interface Introduced in Inventor 9

FeaturePatternElementProxy Properties

FeaturePatternElementProxy.ContainingOccurrence Property Introduced in Inventor 9

FeaturePatternElementProxy.NativeObject Property Introduced in Inventor 9

FeaturePatternElements Interface Introduced in Inventor 5

FeaturePatternElements Methods

FeaturePatternElements.Item Method Introduced in Inventor 5

FeaturePatternElements Properties

FeaturePatternElements.Application Property Introduced in Inventor 5

FeaturePatternElements.Count Property Introduced in Inventor 5

FeaturePatternElements.Type Property Introduced in Inventor 5

Features Interface Introduced in Inventor 10

Features Methods

Features.CreatePath Method Introduced in Inventor 2008

Features.CreateSpecifiedPath Method Introduced in Inventor 2008

Features.Item Method Introduced in Inventor 10

Features Properties

Features.Application Property Introduced in Inventor 10

Features.ChamferFeatures Property Introduced in Inventor 10

Features.CircularPatternFeatures Property Introduced in Inventor 10

Features.ClientFeatures Property Introduced in Inventor 2009

Features.Count Property Introduced in Inventor 10

Features.ExtrudeFeatures Property Introduced in Inventor 10

Features.FilletFeatures Property Introduced in Inventor 10

Features.HoleFeatures Property Introduced in Inventor 10

Features.MirrorFeatures Property Introduced in Inventor 10

Features.MoveFaceFeatures Property Introduced in Inventor 10

Features.RectangularPatternFeatures Property Introduced in Inventor 10

Features.RevolveFeatures Property Introduced in Inventor 10

Features.SweepFeatures Property Introduced in Inventor 10

Features.Type Property Introduced in Inventor 10

File Interface Introduced in Inventor 11

File Properties

File.AllReferencedFiles Property Introduced in Inventor 11

File.Application Property Introduced in Inventor 11

File.AvailableDocuments Property Introduced in Inventor 11

File.FileSaveCounter Property Introduced in Inventor 11

File.FullFileName Property Introduced in Inventor 11

File.InternalName Property Introduced in Inventor 11

File.ReferencedFileDescriptors Property Introduced in Inventor 11

File.ReferencedFiles Property Introduced in Inventor 11

File.ReferencingFiles Property Introduced in Inventor 11

File.Type Property Introduced in Inventor 11

FileAccessEvents CoClass Introduced in Inventor 4

FileAccessEventsObject Interface Introduced in Inventor 4

FileAccessEventsObject Methods

FileAccessEventsObject.FireOnFileResolution Method

FileAccessEventsObject Properties

FileAccessEventsObject.Application Property Introduced in Inventor 5

FileAccessEventsObject.Parent Property Introduced in Inventor 5

FileAccessEventsObject.Type Property Introduced in Inventor 5

FileAccessEventsSink Interface Introduced in Inventor 4

FileAccessEventsSink Methods

FileAccessEventsSink.OnFileDirty Method Introduced in Inventor 4

FileAccessEventsSink.OnFileResolution Method Introduced in Inventor 4

FileDescriptor Interface Introduced in Inventor 11

FileDescriptor Methods

FileDescriptor.GetCustomLogicalFileName Method Introduced in Inventor 11

FileDescriptor.PutCustomLogicalFileName Method Introduced in Inventor 11

FileDescriptor.ReplaceReference Method Introduced in Inventor 11

FileDescriptor Properties

FileDescriptor.Application Property Introduced in Inventor 11

FileDescriptor.FileSaveCounter Property Introduced in Inventor 11

FileDescriptor.FullFileName Property Introduced in Inventor 11

FileDescriptor.LibraryName Property Introduced in Inventor 2008

FileDescriptor.LocationType Property Introduced in Inventor 2008

FileDescriptor.Parent Property Introduced in Inventor 11

FileDescriptor.ReferencedFile Property Introduced in Inventor 11

FileDescriptor.ReferencedFileType Property Introduced in Inventor 11

FileDescriptor.ReferenceDisabled Property Introduced in Inventor 2010

FileDescriptor.ReferenceInternalNameDifferent Property Introduced in Inventor 2010

FileDescriptor.ReferenceLocationDifferent Property Introduced in Inventor 2010

FileDescriptor.ReferenceMissing Property Introduced in Inventor 11

FileDescriptor.RelativeFileName Property Introduced in Inventor 2008

FileDescriptor.Type Property Introduced in Inventor 11

FileDescriptorsEnumerator Interface Introduced in Inventor 11

FileDescriptorsEnumerator Methods

FileDescriptorsEnumerator.Item Method Introduced in Inventor 11

FileDescriptorsEnumerator Properties

FileDescriptorsEnumerator.Application Property Introduced in Inventor 11

FileDescriptorsEnumerator.Count Property Introduced in Inventor 11

FileDescriptorsEnumerator.Type Property Introduced in Inventor 11

FileDialog Interface Introduced in Inventor 6

FileDialog Methods

FileDialog.SetHelpContext Method Introduced in Inventor 11

FileDialog.SetHelpTopic Method Introduced in Inventor 11

FileDialog.ShowOpen Method Introduced in Inventor 6

FileDialog.ShowSave Method Introduced in Inventor 6

FileDialog Properties

FileDialog.CancelError Property Introduced in Inventor 6

FileDialog.DialogTitle Property Introduced in Inventor 6

FileDialog.FileDialogEvents Property Introduced in Inventor 2008

FileDialog.FileName Property Introduced in Inventor 6

FileDialog.Filter Property Introduced in Inventor 6

FileDialog.FilterIndex Property Introduced in Inventor 6

FileDialog.InitialDirectory Property Introduced in Inventor 6

FileDialog.InsertMode Property Introduced in Inventor 2009

FileDialog.MultiSelectEnabled Property Introduced in Inventor 2009

FileDialog.OptionsEnabled Property Introduced in Inventor 2008

FileDialog.SuppressResolutionWarnings Property Introduced in Inventor 11

FileDialogEvents CoClass Introduced in Inventor 2008

FileDialogEventsObject Interface Introduced in Inventor 2008

FileDialogEventsObject Properties

FileDialogEventsObject.Application Property Introduced in Inventor 2008

FileDialogEventsObject.Parent Property Introduced in Inventor 2008

FileDialogEventsObject.Type Property Introduced in Inventor 2008

FileDialogEventsSink Interface Introduced in Inventor 2008

FileDialogEventsSink Methods

FileDialogEventsSink.OnOptions Method Introduced in Inventor 2008

FileLocations Interface Introduced in Inventor 4

FileLocations Methods

FileLocations.AddLibrary Method Introduced in Inventor 4

FileLocations.AddWorkgroup Method Introduced in Inventor 4

FileLocations.FindInLocations Method Introduced in Inventor 4

FileLocations.FindLogicalInLocations Method Introduced in Inventor 4

FileLocations.Libraries Method Introduced in Inventor 4

FileLocations.ProjectFiles Method Introduced in Inventor 6

FileLocations.RemoveLibrary Method Introduced in Inventor 4

FileLocations.RemoveWorkgroup Method Introduced in Inventor 4

FileLocations.Workgroups Method Introduced in Inventor 4

FileLocations Properties

FileLocations.FileLocationsFile Property Introduced in Inventor 4

FileLocations.FileLocationsFilesDir Property Introduced in Inventor 4

FileLocations.Workspace Property Introduced in Inventor 4

FileManager Interface Introduced in Inventor 6

FileManager Methods

FileManager.CopyFile Method Introduced in Inventor 6

FileManager.DeleteFile Method Introduced in Inventor 6

FileManager.GetAutoCADBlockDefinitions Method Introduced in Inventor 2011

FileManager.GetDesignViewRepresentations Method Introduced in Inventor 11

FileManager.GetDWGDocumentReferences Method Introduced in Inventor 2008

FileManager.GetFileNameFromIdentifier Method Introduced in Inventor 9

FileManager.GetFullDocumentName Method Introduced in Inventor 11

FileManager.GetFullFileName Method Introduced in Inventor 11

FileManager.GetIdentifierFromFileName Method Introduced in Inventor 9

FileManager.GetLastActiveDesignViewRepresentation Method Introduced in Inventor 2010

FileManager.GetLastActiveLevelOfDetailRepresentation Method Introduced in Inventor 2008

FileManager.GetLevelOfDetailName Method Introduced in Inventor 11

FileManager.GetLevelOfDetailRepresentations Method Introduced in Inventor 11

FileManager.GetPositionalRepresentations Method Introduced in Inventor 11

FileManager.GetTemplateFile Method Introduced in Inventor 6

FileManager.IsFileNameValid Method Introduced in Inventor 11

FileManager.IsInventorDWG Method Introduced in Inventor 2008

FileManager.MoveFile Method Introduced in Inventor 6

FileManager.RefreshAllDocuments Method Introduced in Inventor 2010

FileManager.SoftwareVersionSaved Method

FileManager Properties

FileManager.Application Property Introduced in Inventor 11

FileManager.FileManagerEvents Property Introduced in Inventor 9

FileManager.Files Property Introduced in Inventor 11

FileManager.FileSystemObject Property Introduced in Inventor 2008

FileManager.Type Property Introduced in Inventor 6

FileManagerEvents CoClass Introduced in Inventor 9

FileManagerEventsObject Interface Introduced in Inventor 9

FileManagerEventsObject Properties

FileManagerEventsObject.Application Property Introduced in Inventor 9

FileManagerEventsObject.Parent Property Introduced in Inventor 9

FileManagerEventsObject.Type Property Introduced in Inventor 9

FileManagerEventsSink Interface Introduced in Inventor 9

FileManagerEventsSink Methods

FileManagerEventsSink.OnFileCopy Method Introduced in Inventor 2009

FileManagerEventsSink.OnFileDelete Method Introduced in Inventor 9

FileMetadata Interface Introduced in Inventor 2009

FileMetadata Properties

FileMetadata.DisplayName Property Introduced in Inventor 2009

FileMetadata.DisplayNameOverridden Property Introduced in Inventor 2009

FileMetadata.Document Property Introduced in Inventor 2009

FileMetadata.FileName Property Introduced in Inventor 2009

FileMetadata.FileNameOverridden Property Introduced in Inventor 2009

FileMetadata.FileProperties Property Introduced in Inventor 2009

FileMetadata.FullFileName Property Introduced in Inventor 2009

FileMetadata.Type Property Introduced in Inventor 2009

FileOpenOptions Interface

FileOpenOptions Properties

FileOpenOptions.DefaultDesignView Property

FileOpenOptions.DefaultDesignViewIsAssociative Property

FileOpenOptions.DefaultLevelOfDetail Property

FileOpenOptions.SkipAllUnresolvedFilesInAssembly Property

FileOpenOptions.SkipAllUnresolvedFilesInDrawing Property

FileOpenOptions.SkipAllUnresolvedFilesInPart Property

FileOptions Interface Introduced in Inventor 9

FileOptions Properties

FileOptions.Application Property Introduced in Inventor 9

FileOptions.ContentCenterPath Property Introduced in Inventor 9

FileOptions.DefaultVBAProjectFileFullFilename Property Introduced in Inventor 9

FileOptions.DesignDataPath Property Introduced in Inventor 9

FileOptions.FileOpenOptions Property

FileOptions.ProjectsPath Property Introduced in Inventor 9

FileOptions.QuickFileOpenCachedAssembly Property

FileOptions.QuickFileOpenCacheLastAssembly Property

FileOptions.QuickFileOpenEnabled Property

FileOptions.TeamWebFullFilename Property Introduced in Inventor 9

FileOptions.TemplatesPath Property Introduced in Inventor 9

FileOptions.Type Property Introduced in Inventor 9

FileOptions.UndoPath Property Introduced in Inventor 9

FileSaveAs Interface Introduced in Inventor 4

FileSaveAs Methods

FileSaveAs.AddFileToSave Method Introduced in Inventor 4

FileSaveAs.ExecuteSave Method Introduced in Inventor 4

FileSaveAs.ExecuteSaveAs Method Introduced in Inventor 4

FileSaveAs.ExecuteSaveCopyAs Method Introduced in Inventor 4

FilesEnumerator Interface Introduced in Inventor 11

FilesEnumerator Methods

FilesEnumerator.Item Method Introduced in Inventor 11

FilesEnumerator Properties

FilesEnumerator.Application Property Introduced in Inventor 11

FilesEnumerator.Count Property Introduced in Inventor 11

FilesEnumerator.Type Property Introduced in Inventor 11

FileUIEvents CoClass Introduced in Inventor 4

FileUIEventsObject Interface Introduced in Inventor 4

FileUIEventsObject Methods

FileUIEventsObject.PopulateFileMetadata Method Introduced in Inventor 2009

FileUIEventsObject Properties

FileUIEventsObject.Application Property Introduced in Inventor 7

FileUIEventsObject.Parent Property Introduced in Inventor 7

FileUIEventsObject.Type Property Introduced in Inventor 7

FileUIEventsSink Interface Introduced in Inventor 4

FileUIEventsSink Methods

FileUIEventsSink.OnFileInsertDialog Method Introduced in Inventor 4

FileUIEventsSink.OnFileInsertNewDialog Method Introduced in Inventor 4

FileUIEventsSink.OnFileNew Method Introduced in Inventor 2009

FileUIEventsSink.OnFileNewDialog Method Introduced in Inventor 4

FileUIEventsSink.OnFileOpenDialog Method Introduced in Inventor 4

FileUIEventsSink.OnFileOpenFromMRU Method Introduced in Inventor 2009

FileUIEventsSink.OnFileSaveAsDialog Method Introduced in Inventor 4

FileUIEventsSink.OnPopulateFileMetadata Method Introduced in Inventor 2009

FilletConstantRadiusEdgeSet Interface Introduced in Inventor 5.3

FilletConstantRadiusEdgeSet Properties

FilletConstantRadiusEdgeSet.AllFillets Property Introduced in Inventor 5.3

FilletConstantRadiusEdgeSet.AllRounds Property Introduced in Inventor 5.3

FilletConstantRadiusEdgeSet.ContinuityType Property Introduced in Inventor 11

FilletConstantRadiusEdgeSet.Radius Property Introduced in Inventor 5.3

FilletConstantRadiusFaceSet Interface Introduced in Inventor 11

FilletConstantRadiusFaceSet Properties

FilletConstantRadiusFaceSet.Application Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.BiasPoint Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.FacesOne Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.FacesOneReverseDirection Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.FacesTwo Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.FacesTwoReverseDirection Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.IncludeTangentFaces Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.Radius Property Introduced in Inventor 11

FilletConstantRadiusFaceSet.Type Property Introduced in Inventor 11

FilletDefinition Interface Introduced in Inventor 5.3

FilletDefinition Methods

FilletDefinition.AddConstantRadiusEdgeSet Method Introduced in Inventor 5.3

FilletDefinition.AddFaceSet Method Introduced in Inventor 11

FilletDefinition.AddFullRoundSet Method Introduced in Inventor 11

FilletDefinition.AddVariableRadiusEdgeSet Method Introduced in Inventor 5.3

FilletDefinition.EdgeSetItem Method Introduced in Inventor 5.3

FilletDefinition.SetbackVertexItem Method Introduced in Inventor 5.3

FilletDefinition Properties

FilletDefinition.Application Property Introduced in Inventor 5.3

FilletDefinition.EdgeSetCount Property Introduced in Inventor 5.3

FilletDefinition.FaceSet Property Introduced in Inventor 11

FilletDefinition.FilletType Property Introduced in Inventor 11

FilletDefinition.FullRoundSet Property Introduced in Inventor 11

FilletDefinition.Parent Property Introduced in Inventor 5.3

FilletDefinition.SetbackVertexCount Property Introduced in Inventor 5.3

FilletDefinition.Type Property Introduced in Inventor 5.3

FilletFeature Interface Introduced in Inventor 5

FilletFeature Properties

FilletFeature.AutomaticEdgeChain Property Introduced in Inventor 5.3

FilletFeature.FilletDefinition Property Introduced in Inventor 5.3

FilletFeature.PreserveAllFeatures Property Introduced in Inventor 5.3

FilletFeature.RollAlongSharpEdges Property Introduced in Inventor 5.3

FilletFeature.RollingBallWherePossible Property Introduced in Inventor 5.3

FilletFeature.SmoothRadiusTransition Property Introduced in Inventor 5.3

FilletFeatureProxy Interface Introduced in Inventor 9

FilletFeatureProxy Properties

FilletFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

FilletFeatureProxy.NativeObject Property Introduced in Inventor 9

FilletFeatures Interface Introduced in Inventor 5

FilletFeatures Methods

FilletFeatures.Add Method Introduced in Inventor 5.3

FilletFeatures.AddSimple Method Introduced in Inventor 5.3

FilletFeatures.CreateFilletDefinition Method Introduced in Inventor 5.3

FilletFeatures.Item Method Introduced in Inventor 5

FilletFeatures Properties

FilletFeatures.Application Property Introduced in Inventor 5

FilletFeatures.Count Property Introduced in Inventor 5

FilletFeatures.Type Property Introduced in Inventor 5

FilletFullRoundSet Interface Introduced in Inventor 11

FilletFullRoundSet Properties

FilletFullRoundSet.Application Property Introduced in Inventor 11

FilletFullRoundSet.CenterFaces Property Introduced in Inventor 11

FilletFullRoundSet.IncludeTangentFaces Property Introduced in Inventor 11

FilletFullRoundSet.SideFacesOne Property Introduced in Inventor 11

FilletFullRoundSet.SideFacesTwo Property Introduced in Inventor 11

FilletFullRoundSet.Type Property Introduced in Inventor 11

FilletIntermediateRadius Interface Introduced in Inventor 5.3

FilletIntermediateRadius Properties

FilletIntermediateRadius.Edge Property Introduced in Inventor 5.3

FilletIntermediateRadius.PercentLength Property Introduced in Inventor 5.3

FilletIntermediateRadius.Radius Property Introduced in Inventor 5.3

FilletRadiusEdgeSet Interface Introduced in Inventor 5.3

FilletRadiusEdgeSet Properties

FilletRadiusEdgeSet.Application Property Introduced in Inventor 5.3

FilletRadiusEdgeSet.Edges Property Introduced in Inventor 5.3

FilletRadiusEdgeSet.Type Property Introduced in Inventor 11

FilletSetback Interface Introduced in Inventor 5.3

FilletSetback Properties

FilletSetback.Edge Property Introduced in Inventor 5.3

FilletSetback.Setback Property Introduced in Inventor 5.3

FilletSetbackVertex Interface Introduced in Inventor 5.3

FilletSetbackVertex Methods

FilletSetbackVertex.SetbackItem Method Introduced in Inventor 5.3

FilletSetbackVertex Properties

FilletSetbackVertex.MinimalSetback Property Introduced in Inventor 2009

FilletSetbackVertex.SetbackCount Property Introduced in Inventor 5.3

FilletSetbackVertex.Type Property Introduced in Inventor 5.3

FilletSetbackVertex.UseSetbacks Property Introduced in Inventor 5.3

FilletSetbackVertex.Vertex Property Introduced in Inventor 5.3

FilletVariableRadiusEdgeSet Interface Introduced in Inventor 5.3

FilletVariableRadiusEdgeSet Methods

FilletVariableRadiusEdgeSet.AddIntermediateRadius Method Introduced in Inventor 5.3

FilletVariableRadiusEdgeSet.IntermediateRadiusItem Method Introduced in Inventor 5.3

FilletVariableRadiusEdgeSet Properties

FilletVariableRadiusEdgeSet.ContinuityType Property

FilletVariableRadiusEdgeSet.EndRadius Property Introduced in Inventor 5.3

FilletVariableRadiusEdgeSet.IntermediateRadiusCount Property Introduced in Inventor 5.3

FilletVariableRadiusEdgeSet.StartRadius Property Introduced in Inventor 5.3

FixedWorkAxisDef Interface Introduced in Inventor 4

FixedWorkAxisDef Methods

FixedWorkAxisDef.GetData Method Introduced in Inventor 4

FixedWorkAxisDef.PutData Method Introduced in Inventor 4

FixedWorkAxisDef Properties

FixedWorkAxisDef.Application Property Introduced in Inventor 4

FixedWorkAxisDef.Axis Property Introduced in Inventor 4

FixedWorkAxisDef.OriginPoint Property Introduced in Inventor 4

FixedWorkAxisDef.Parent Property Introduced in Inventor 4

FixedWorkAxisDef.Type Property Introduced in Inventor 4

FixedWorkPlaneDef Interface Introduced in Inventor 4

FixedWorkPlaneDef Methods

FixedWorkPlaneDef.GetData Method Introduced in Inventor 4

FixedWorkPlaneDef.PutData Method Introduced in Inventor 4

FixedWorkPlaneDef Properties

FixedWorkPlaneDef.Application Property Introduced in Inventor 4

FixedWorkPlaneDef.OriginPoint Property Introduced in Inventor 4

FixedWorkPlaneDef.Parent Property Introduced in Inventor 4

FixedWorkPlaneDef.Type Property Introduced in Inventor 4

FixedWorkPlaneDef.XAxis Property Introduced in Inventor 4

FixedWorkPlaneDef.YAxis Property Introduced in Inventor 4

FixedWorkPointDef Interface Introduced in Inventor 4

FixedWorkPointDef Properties

FixedWorkPointDef.Application Property Introduced in Inventor 4

FixedWorkPointDef.Parent Property Introduced in Inventor 4

FixedWorkPointDef.Point Property Introduced in Inventor 4

FixedWorkPointDef.Type Property Introduced in Inventor 4

FlangeDefinition Interface Introduced in Inventor 2009

FlangeDefinition Methods

FlangeDefinition.Copy Method Introduced in Inventor 2011

FlangeDefinition.GetWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.GetWidthExtentType Method Introduced in Inventor 2011

FlangeDefinition.RemoveOverrideWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetCenteredDefaultWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetCenteredWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetDistanceHeightExtent Method Introduced in Inventor 2011

FlangeDefinition.SetEdgeDefaultWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetEdgeWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetFromToDefaultWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetFromToWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetLegacyDistanceHeightExtent Method Introduced in Inventor 2011

FlangeDefinition.SetOffsetDefaultWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetOffsetWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetToHeightExtent Method Introduced in Inventor 2011

FlangeDefinition.SetWidthOffsetDefaultWidthExtent Method Introduced in Inventor 2011

FlangeDefinition.SetWidthOffsetWidthExtent Method Introduced in Inventor 2011

FlangeDefinition Properties

FlangeDefinition.Application Property Introduced in Inventor 2009

FlangeDefinition.ApplyAutoMitering Property Introduced in Inventor 2009

FlangeDefinition.BendOptions Property Introduced in Inventor 2009

FlangeDefinition.BendPosition Property Introduced in Inventor 2009

FlangeDefinition.BendRadius Property Introduced in Inventor 2009

FlangeDefinition.CornerOptions Property Introduced in Inventor 2009

FlangeDefinition.DefaultWidthExtent Property Introduced in Inventor 2011

FlangeDefinition.DefaultWidthExtentType Property Introduced in Inventor 2011

FlangeDefinition.Edges Property Introduced in Inventor 2009

FlangeDefinition.FlangeAngle Property Introduced in Inventor 2009

FlangeDefinition.HeightExtent Property Introduced in Inventor 2009

FlangeDefinition.HeightExtentType Property Introduced in Inventor 2009

FlangeDefinition.IsUnfoldMethodOverridden Property Introduced in Inventor 2011

FlangeDefinition.MiterGap Property Introduced in Inventor 2009

FlangeDefinition.Parent Property Introduced in Inventor 2009

FlangeDefinition.Type Property Introduced in Inventor 2009

FlangeDefinition.UnfoldMethod Property Introduced in Inventor 2009

FlangeFeature Interface Introduced in Inventor 5.3

FlangeFeature Properties

FlangeFeature.BendFeature Property Introduced in Inventor 2009

FlangeFeature.Definition Property Introduced in Inventor 2009

FlangeFeatureProxy Interface Introduced in Inventor 9

FlangeFeatures Interface Introduced in Inventor 5.3

FlangeFeatures Methods

FlangeFeatures.Add Method Introduced in Inventor 2011

FlangeFeatures.CreateFlangeDefinition Method Introduced in Inventor 2011

FlangeFeatures.Item Method Introduced in Inventor 5.3

FlangeFeatures Properties

FlangeFeatures.Application Property Introduced in Inventor 5.3

FlangeFeatures.Count Property Introduced in Inventor 5.3

FlangeFeatures.Type Property Introduced in Inventor 5.3

FlatBendResult Interface Introduced in Inventor 2008

FlatBendResult Methods

FlatBendResult.GetBendOrder Method Introduced in Inventor 2010

FlatBendResult.SetBendOrder Method Introduced in Inventor 2010

FlatBendResult Properties

FlatBendResult.Angle Property Introduced in Inventor 2008

FlatBendResult.Application Property Introduced in Inventor 2008

FlatBendResult.Edge Property Introduced in Inventor 2008

FlatBendResult.InnerRadius Property Introduced in Inventor 2008

FlatBendResult.InternalName Property Introduced in Inventor 2008

FlatBendResult.IsDirectionUp Property Introduced in Inventor 2008

FlatBendResult.IsOnBottomFace Property Introduced in Inventor 2008

FlatBendResult.KFactor Property Introduced in Inventor 2009

FlatBendResult.Parent Property Introduced in Inventor 2008

FlatBendResult.Type Property Introduced in Inventor 2008

FlatBendResults Interface Introduced in Inventor 2008

FlatBendResults Methods

FlatBendResults.Item Method Introduced in Inventor 2008

FlatBendResults Properties

FlatBendResults.Application Property Introduced in Inventor 2008

FlatBendResults.Count Property Introduced in Inventor 2008

FlatBendResults.Type Property Introduced in Inventor 2008

FlatPattern Interface Introduced in Inventor 6

FlatPattern Methods

FlatPattern.Delete Method Introduced in Inventor 2008

FlatPattern.DeleteObjects Method Introduced in Inventor 2010

FlatPattern.Edit Method Introduced in Inventor 2008

FlatPattern.ExitEdit Method Introduced in Inventor 2008

FlatPattern.FindUsingRay Method Introduced in Inventor 2010

FlatPattern.FlipBaseFace Method Introduced in Inventor 2008

FlatPattern.GetAlignment Method Introduced in Inventor 2008

FlatPattern.GetEdgesOfType Method Introduced in Inventor 2008

FlatPattern.GetEndOfPartPosition Method Introduced in Inventor 2010

FlatPattern.GetFlatPatternEntity Method Introduced in Inventor 2008

FlatPattern.SetAlignment Method Introduced in Inventor 2008

FlatPattern.SetEndOfPartToTopOrBottom Method Introduced in Inventor 2010

FlatPattern.SuppressFeatures Method Introduced in Inventor 2010

FlatPattern.UnsuppressFeatures Method Introduced in Inventor 2010

FlatPattern Properties

FlatPattern.BaseFace Property Introduced in Inventor 2008

FlatPattern.BendAngleReportType Property Introduced in Inventor 2010

FlatPattern.Body Property Introduced in Inventor 6

FlatPattern.BottomFace Property Introduced in Inventor 2008

FlatPattern.Features Property Introduced in Inventor 2010

FlatPattern.FlatBendResults Property Introduced in Inventor 2008

FlatPattern.FlatPunchResults Property Introduced in Inventor 2008

FlatPattern.GraphicsDataSetsCollection Property Introduced in Inventor 2008

FlatPattern.Length Property Introduced in Inventor 2008

FlatPattern.MassProperties Property Introduced in Inventor 11

FlatPattern.Parameters Property Introduced in Inventor 2010

FlatPattern.Parent Property Introduced in Inventor 2008

FlatPattern.PartEvents Property Introduced in Inventor 2010

FlatPattern.PunchRepresentationType Property Introduced in Inventor 2008

FlatPattern.RepresentationsManager Property Introduced in Inventor 2012

FlatPattern.RolledBackForEdit Property Introduced in Inventor 2010

FlatPattern.SketchBlockDefinitions Property Introduced in Inventor 2010

FlatPattern.Sketches Property Introduced in Inventor 2010

FlatPattern.Sketches3D Property Introduced in Inventor 2010

FlatPattern.TopFace Property Introduced in Inventor 2008

FlatPattern.UserCoordinateSystems Property Introduced in Inventor 2010

FlatPattern.Width Property Introduced in Inventor 2010

FlatPattern.WorkAxes Property Introduced in Inventor 2010

FlatPattern.WorkPlanes Property Introduced in Inventor 2010

FlatPattern.WorkPoints Property Introduced in Inventor 2010

FlatPatternFeatures Interface Introduced in Inventor 2010

FlatPatternFeatures Methods

FlatPatternFeatures.CreatePath Method Introduced in Inventor 2010

FlatPatternFeatures.Item Method Introduced in Inventor 2010

FlatPatternFeatures Properties

FlatPatternFeatures.Application Property Introduced in Inventor 2010

FlatPatternFeatures.ChamferFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.CircularPatternFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.CornerChamferFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.CornerRoundFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.CosmeticBendFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.Count Property Introduced in Inventor 2010

FlatPatternFeatures.CutFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.EmbossFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.ExtrudeFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.FilletFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.HoleFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.iFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.MirrorFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.PunchToolFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.RectangularPatternFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.RevolveFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.SweepFeatures Property Introduced in Inventor 2010

FlatPatternFeatures.Type Property Introduced in Inventor 2010

FlatPunchResult Interface Introduced in Inventor 2008

FlatPunchResult Properties

FlatPunchResult.Angle Property Introduced in Inventor 2008

FlatPunchResult.Application Property Introduced in Inventor 2008

FlatPunchResult.Depth Property Introduced in Inventor 2008

FlatPunchResult.Faces Property Introduced in Inventor 2008

FlatPunchResult.FoldedAngle Property Introduced in Inventor 2008

FlatPunchResult.FoldedPosition Property Introduced in Inventor 2008

FlatPunchResult.HasDepth Property Introduced in Inventor 2008

FlatPunchResult.InternalName Property Introduced in Inventor 2008

FlatPunchResult.IsDirectionUp Property Introduced in Inventor 2008

FlatPunchResult.IsPunchAfterStopNode Property Introduced in Inventor 2008

FlatPunchResult.IsPunchSuppressed Property Introduced in Inventor 2008

FlatPunchResult.Parent Property Introduced in Inventor 2008

FlatPunchResult.Position Property Introduced in Inventor 2008

FlatPunchResult.PunchId Property Introduced in Inventor 2008

FlatPunchResult.SketchRepresentationEdges Property Introduced in Inventor 2008

FlatPunchResult.Type Property Introduced in Inventor 2008

FlatPunchResults Interface Introduced in Inventor 2008

FlatPunchResults Methods

FlatPunchResults.Item Method Introduced in Inventor 2008

FlatPunchResults Properties

FlatPunchResults.Application Property Introduced in Inventor 2008

FlatPunchResults.Count Property Introduced in Inventor 2008

FlatPunchResults.Type Property Introduced in Inventor 2008

FlushConstraint Interface Introduced in Inventor 4

FlushConstraint Properties

FlushConstraint.ConstraintLimits Property Introduced in Inventor 2011

FlushConstraint.Offset Property Introduced in Inventor 4

FlushConstraintProxy Interface Introduced in Inventor 11

FlushConstraintProxy Properties

FlushConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

FlushConstraintProxy.NativeObject Property Introduced in Inventor 11

FlushiMateDefinition Interface Introduced in Inventor 6

FlushiMateDefinition Properties

FlushiMateDefinition.ConstraintLimits Property Introduced in Inventor 2011

FlushiMateDefinition.Entity Property Introduced in Inventor 6

FlushiMateDefinition.Offset Property Introduced in Inventor 6

FlushiMateDefinitionProxy Interface Introduced in Inventor 6

FlushiMateDefinitionProxy Properties

FlushiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

FlushiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

FlushiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

FoldDefinition Interface Introduced in Inventor 2009

FoldDefinition Methods

FoldDefinition.Copy Method Introduced in Inventor 2011

FoldDefinition Properties

FoldDefinition.Application Property Introduced in Inventor 2009

FoldDefinition.BendAngle Property Introduced in Inventor 2009

FoldDefinition.BendLine Property Introduced in Inventor 2009

FoldDefinition.BendLocation Property Introduced in Inventor 2009

FoldDefinition.BendOptions Property Introduced in Inventor 2009

FoldDefinition.BendRadius Property Introduced in Inventor 2009

FoldDefinition.IsPositiveBendDirection Property Introduced in Inventor 2009

FoldDefinition.IsPositiveBendSide Property Introduced in Inventor 2009

FoldDefinition.IsUnfoldMethodOverridden Property Introduced in Inventor 2011

FoldDefinition.Parent Property Introduced in Inventor 2009

FoldDefinition.Type Property Introduced in Inventor 2009

FoldDefinition.UnfoldMethod Property Introduced in Inventor 2009

FoldFeature Interface Introduced in Inventor 5.3

FoldFeature Properties

FoldFeature.Definition Property Introduced in Inventor 2009

FoldFeatureProxy Interface Introduced in Inventor 9

FoldFeatures Interface Introduced in Inventor 5.3

FoldFeatures Methods

FoldFeatures.Add Method Introduced in Inventor 2011

FoldFeatures.CreateFoldDefinition Method Introduced in Inventor 2011

FoldFeatures.Item Method Introduced in Inventor 5.3

FoldFeatures Properties

FoldFeatures.Application Property Introduced in Inventor 5.3

FoldFeatures.Count Property Introduced in Inventor 5.3

FoldFeatures.Type Property Introduced in Inventor 5.3

FreeMoveDefinition Interface Introduced in Inventor 2011

FreeMoveDefinition Properties

FreeMoveDefinition.Application Property

FreeMoveDefinition.Parent Property

FreeMoveDefinition.Transformation Property

FreeMoveDefinition.Type Property

FromToExtent Interface Introduced in Inventor 5

FromToExtent Properties

FromToExtent.Direction Property Introduced in Inventor 2008

FromToExtent.ExtendFromFace Property Introduced in Inventor 5

FromToExtent.ExtendToFace Property Introduced in Inventor 5

FromToExtent.FromFace Property Introduced in Inventor 5

FromToExtent.MinimumSolution Property Introduced in Inventor 11

FromToExtent.ToFace Property Introduced in Inventor 5

FromToWidthExtent Interface Introduced in Inventor 2009

FromToWidthExtent Properties

FromToWidthExtent.Edge Property Introduced in Inventor 2009

FromToWidthExtent.FromEntity Property Introduced in Inventor 2009

FromToWidthExtent.ToEntity Property Introduced in Inventor 2009

FullSweepExtent Interface Introduced in Inventor 5

GeneralDimension Interface Introduced in Inventor 9

GeneralDimension Methods

GeneralDimension.PromoteToSketch Method Introduced in Inventor 9

GeneralDimension.ShowAllExtensionLines Method Introduced in Inventor 2011

GeneralDimension Properties

GeneralDimension.ArrowheadsInside Property Introduced in Inventor 9

GeneralDimension.FirstArrowheadInside Property Introduced in Inventor 11

GeneralDimension.FirstArrowheadType Property Introduced in Inventor 2011

GeneralDimension.GeneralDimensionType Property Introduced in Inventor 2008

GeneralDimension.Retrieved Property Introduced in Inventor 2008

GeneralDimension.RetrievedFrom Property Introduced in Inventor 2008

GeneralDimension.SecondArrowheadInside Property Introduced in Inventor 11

GeneralDimension.SecondArrowheadType Property Introduced in Inventor 2011

GeneralDimension.Style Property Introduced in Inventor 9

GeneralDimensions Interface Introduced in Inventor 9

GeneralDimensions Methods

GeneralDimensions.AddAngular Method Introduced in Inventor 11

GeneralDimensions.AddDiameter Method Introduced in Inventor 11

GeneralDimensions.AddLinear Method Introduced in Inventor 11

GeneralDimensions.AddRadius Method Introduced in Inventor 11

GeneralDimensions.GetRetrievableDimensions Method Introduced in Inventor 2008

GeneralDimensions.Item Method Introduced in Inventor 9

GeneralDimensions.Retrieve Method Introduced in Inventor 9

GeneralDimensions Properties

GeneralDimensions.Application Property Introduced in Inventor 9

GeneralDimensions.Count Property Introduced in Inventor 9

GeneralDimensions.Type Property Introduced in Inventor 9

GeneralDimensionsEnumerator Interface Introduced in Inventor 9

GeneralDimensionsEnumerator Methods

GeneralDimensionsEnumerator.Item Method Introduced in Inventor 9

GeneralDimensionsEnumerator Properties

GeneralDimensionsEnumerator.Count Property Introduced in Inventor 9

GeneralDimensionsEnumerator.Type Property Introduced in Inventor 9

GeneralNote Interface Introduced in Inventor 10

GeneralNote Properties

GeneralNote.Fitted Property Introduced in Inventor 10

GeneralNote.FittedTextHeight Property Introduced in Inventor 10

GeneralNote.FittedTextWidth Property Introduced in Inventor 10

GeneralNote.Height Property Introduced in Inventor 2010

GeneralNote.Rotation Property Introduced in Inventor 10

GeneralNote.TextStyle Property Introduced in Inventor 10

GeneralNote.Width Property Introduced in Inventor 2010

GeneralNotes Interface Introduced in Inventor 10

GeneralNotes Methods

GeneralNotes.AddByRectangle Method Introduced in Inventor 10

GeneralNotes.AddFitted Method Introduced in Inventor 10

GeneralNotes.Item Method Introduced in Inventor 10

GeneralNotes Properties

GeneralNotes.Application Property Introduced in Inventor 10

GeneralNotes.Count Property Introduced in Inventor 10

GeneralNotes.Type Property Introduced in Inventor 10

GeneralOptions Interface Introduced in Inventor 8

GeneralOptions Methods

GeneralOptions.StartupHelpFocusTopic Method Introduced in Inventor 2008

GeneralOptions Properties

GeneralOptions.AnnotationScale Property Introduced in Inventor 11

GeneralOptions.Application Property Introduced in Inventor 8

GeneralOptions.EnableLegacyProjectCreation Property Introduced in Inventor 2008

GeneralOptions.EnableOptimizedSelection Property Introduced in Inventor 2008

GeneralOptions.GripSnapOptions Property Introduced in Inventor 2010

GeneralOptions.iMateVisibility Property Introduced in Inventor 11

GeneralOptions.LoadVBAOnStartup Property

GeneralOptions.SecondLevelTooltipDelay Property Introduced in Inventor 2010

GeneralOptions.SelectOtherDelay Property Introduced in Inventor 11

GeneralOptions.ShowAutocompleteForCommandAlias Property Introduced in Inventor 2008

GeneralOptions.ShowCommandAliasInputDialog Property Introduced in Inventor 2008

GeneralOptions.ShowCommandPromptTooltips Property Introduced in Inventor 2008

GeneralOptions.ShowDocumentTabTooltips Property Introduced in Inventor 2010

GeneralOptions.ShowSecondLevelTooltips Property Introduced in Inventor 2010

GeneralOptions.ShowTooltips Property Introduced in Inventor 2010

GeneralOptions.ShowVideoToolClips Property

GeneralOptions.StartupActionType Property Introduced in Inventor 2008

GeneralOptions.StartupNewFileTemplateName Property Introduced in Inventor 2008

GeneralOptions.StartupProjectFileName Property Introduced in Inventor 2008

GeneralOptions.TextAppearance Property Introduced in Inventor 8

GeneralOptions.TextSize Property Introduced in Inventor 8

GeneralOptions.ThreadTableQuery Property Introduced in Inventor 11

GeneralOptions.ToleranceValue Property Introduced in Inventor 11

GeneralOptions.TooltipDelay Property Introduced in Inventor 2010

GeneralOptions.Type Property Introduced in Inventor 11

GeneralOptions.UndoFileSize Property Introduced in Inventor 11

GeneralOptions.UpdatePropertiesOnSaveForFileType Property Introduced in Inventor 2008

GeneralOptions.UseNegativeIntegralForInertialProperties Property Introduced in Inventor 11

GeneralOptions.UserName Property Introduced in Inventor 11

GeneralPreferences Interface

GeneralPreferences Properties

GeneralPreferences.DeferUpdate Property

GeneralPreferences.MultiUserExternallyManaged Property

GeneralPreferences.MultiUserMode Property

GeneralPreferences.TemplateDir Property

GenericObject Interface Introduced in Inventor 4

GenericObject Properties

GenericObject.Type Property Introduced in Inventor 4

GeometricConstraint Interface Introduced in Inventor 5

GeometricConstraint Methods

GeometricConstraint.Delete Method Introduced in Inventor 5

GeometricConstraint.GetReferenceKey Method Introduced in Inventor 5

GeometricConstraint Properties

GeometricConstraint.Application Property Introduced in Inventor 5

GeometricConstraint.AttributeSets Property Introduced in Inventor 5

GeometricConstraint.Deletable Property Introduced in Inventor 11

GeometricConstraint.Parent Property Introduced in Inventor 5

GeometricConstraint.Type Property Introduced in Inventor 5

GeometricConstraint3D Interface Introduced in Inventor 6

GeometricConstraint3D Methods

GeometricConstraint3D.Delete Method Introduced in Inventor 6

GeometricConstraint3D.GetReferenceKey Method Introduced in Inventor 6

GeometricConstraint3D Properties

GeometricConstraint3D.Application Property Introduced in Inventor 6

GeometricConstraint3D.AttributeSets Property Introduced in Inventor 6

GeometricConstraint3D.Deletable Property Introduced in Inventor 11

GeometricConstraint3D.Parent Property Introduced in Inventor 6

GeometricConstraint3D.Type Property Introduced in Inventor 6

GeometricConstraints Interface Introduced in Inventor 5

GeometricConstraints Methods

GeometricConstraints.AddCoincident Method Introduced in Inventor 5

GeometricConstraints.AddCollinear Method Introduced in Inventor 5

GeometricConstraints.AddConcentric Method Introduced in Inventor 5

GeometricConstraints.AddEqualLength Method Introduced in Inventor 5

GeometricConstraints.AddEqualRadius Method Introduced in Inventor 5

GeometricConstraints.AddGround Method Introduced in Inventor 5

GeometricConstraints.AddHorizontal Method Introduced in Inventor 5

GeometricConstraints.AddHorizontalAlign Method Introduced in Inventor 5

GeometricConstraints.AddMidpoint Method Introduced in Inventor 5

GeometricConstraints.AddParallel Method Introduced in Inventor 5

GeometricConstraints.AddPerpendicular Method Introduced in Inventor 5

GeometricConstraints.AddSmooth Method Introduced in Inventor 11

GeometricConstraints.AddSymmetry Method Introduced in Inventor 5

GeometricConstraints.AddTangent Method Introduced in Inventor 5

GeometricConstraints.AddVertical Method Introduced in Inventor 5

GeometricConstraints.AddVerticalAlign Method Introduced in Inventor 5

GeometricConstraints.Item Method Introduced in Inventor 5

GeometricConstraints Properties

GeometricConstraints.Application Property Introduced in Inventor 5

GeometricConstraints.Count Property Introduced in Inventor 5

GeometricConstraints.Type Property Introduced in Inventor 5

GeometricConstraints3D Interface Introduced in Inventor 6

GeometricConstraints3D Methods

GeometricConstraints3D.AddCoincident Method Introduced in Inventor 2009

GeometricConstraints3D.AddCollinear Method Introduced in Inventor 11

GeometricConstraints3D.AddCustom Method Introduced in Inventor 11

GeometricConstraints3D.AddGround Method Introduced in Inventor 11

GeometricConstraints3D.AddMidpoint Method Introduced in Inventor 2009

GeometricConstraints3D.AddParallel Method Introduced in Inventor 11

GeometricConstraints3D.AddPerpendicular Method Introduced in Inventor 11

GeometricConstraints3D.AddSmooth Method Introduced in Inventor 11

GeometricConstraints3D.AddTangent Method Introduced in Inventor 8

GeometricConstraints3D.Item Method Introduced in Inventor 6

GeometricConstraints3D Properties

GeometricConstraints3D.Application Property Introduced in Inventor 6

GeometricConstraints3D.Count Property Introduced in Inventor 6

GeometricConstraints3D.Type Property Introduced in Inventor 6

GeometryIntent Interface Introduced in Inventor 11

GeometryIntent Properties

GeometryIntent.Application Property Introduced in Inventor 11

GeometryIntent.Geometry Property Introduced in Inventor 11

GeometryIntent.Intent Property Introduced in Inventor 11

GeometryIntent.IntentType Property Introduced in Inventor 11

GeometryIntent.Parent Property Introduced in Inventor 11

GeometryIntent.PointOnSheet Property Introduced in Inventor 11

GeometryIntent.Type Property Introduced in Inventor 11

GraphicsColorMapper Interface Introduced in Inventor 2010

GraphicsColorMapper Methods

GraphicsColorMapper.Delete Method Introduced in Inventor 2010

GraphicsColorMapper.GetColors Method Introduced in Inventor 2010

GraphicsColorMapper.GetValues Method Introduced in Inventor 2010

GraphicsColorMapper.MappedColor Method Introduced in Inventor 2010

GraphicsColorMapper.PutColors Method Introduced in Inventor 2010

GraphicsColorMapper.PutValues Method Introduced in Inventor 2010

GraphicsColorMapper Properties

GraphicsColorMapper.Color Method

GraphicsColorMapper.ColorCount Property Introduced in Inventor 2010

GraphicsColorMapper.Type Property Introduced in Inventor 2010

GraphicsColorMapper.ValueCount Property Introduced in Inventor 2010

GraphicsColorMapper.Value Method Introduced in Inventor 2010

GraphicsColorSet Interface Introduced in Inventor 5

GraphicsColorSet Methods

GraphicsColorSet.Add Method Introduced in Inventor 5

GraphicsColorSet.Color Method Introduced in Inventor 11

GraphicsColorSet.GetColors Method Introduced in Inventor 5

GraphicsColorSet.PutColors Method Introduced in Inventor 5

GraphicsCoordinateSet Interface Introduced in Inventor 5

GraphicsCoordinateSet Methods

GraphicsCoordinateSet.Add Method Introduced in Inventor 5

GraphicsCoordinateSet.Coordinate Method

GraphicsCoordinateSet.GetCoordinates Method Introduced in Inventor 5

GraphicsCoordinateSet.PutCoordinates Method Introduced in Inventor 5

GraphicsDataSet Interface Introduced in Inventor 5

GraphicsDataSet Methods

GraphicsDataSet.Delete Method Introduced in Inventor 5

GraphicsDataSet.Remove Method Introduced in Inventor 5

GraphicsDataSet Properties

GraphicsDataSet.Count Property Introduced in Inventor 5

GraphicsDataSet.Id Property Introduced in Inventor 5

GraphicsDataSet.Type Property Introduced in Inventor 5

GraphicsDataSets Interface Introduced in Inventor 5

GraphicsDataSets Methods

GraphicsDataSets.CreateColorMapper Method Introduced in Inventor 2010

GraphicsDataSets.CreateColorSet Method Introduced in Inventor 5

GraphicsDataSets.CreateCoordinateSet Method Introduced in Inventor 5

GraphicsDataSets.CreateImageSet Method Introduced in Inventor 2011

GraphicsDataSets.CreateIndexSet Method Introduced in Inventor 5

GraphicsDataSets.CreateNormalSet Method Introduced in Inventor 5

GraphicsDataSets.CreateTextureCoordinateSet Method Introduced in Inventor 2010

GraphicsDataSets.Delete Method Introduced in Inventor 5

GraphicsDataSets.Item Method Introduced in Inventor 5

GraphicsDataSets.ItemById Method Introduced in Inventor 5

GraphicsDataSets Properties

GraphicsDataSets.Application Property Introduced in Inventor 5

GraphicsDataSets.ClientId Property Introduced in Inventor 5

GraphicsDataSets.Count Property Introduced in Inventor 5

GraphicsDataSets.NonTransacting Property Introduced in Inventor 2012

GraphicsDataSets.Parent Property Introduced in Inventor 5

GraphicsDataSets.SaveWithDocument Property Introduced in Inventor 2008

GraphicsDataSets.Type Property Introduced in Inventor 5

GraphicsDataSetsCollection Interface Introduced in Inventor 5

GraphicsDataSetsCollection Methods

GraphicsDataSetsCollection.Add Method Introduced in Inventor 5

GraphicsDataSetsCollection.Add2 Method Introduced in Inventor 2008

GraphicsDataSetsCollection.AddNonTransacting Method Introduced in Inventor 2012

GraphicsDataSetsCollection.Item Method Introduced in Inventor 5

GraphicsDataSetsCollection Properties

GraphicsDataSetsCollection.Application Property Introduced in Inventor 5

GraphicsDataSetsCollection.Count Property Introduced in Inventor 5

GraphicsDataSetsCollection.Parent Property Introduced in Inventor 5

GraphicsDataSetsCollection.Type Property Introduced in Inventor 5

GraphicsImageSet Interface Introduced in Inventor 2011

GraphicsImageSet Methods

GraphicsImageSet.Add Method Introduced in Inventor 2011

GraphicsIndexSet Interface Introduced in Inventor 5

GraphicsIndexSet Methods

GraphicsIndexSet.Add Method Introduced in Inventor 5

GraphicsIndexSet.GetIndices Method Introduced in Inventor 5

GraphicsIndexSet.IndexValue Method

GraphicsIndexSet.PutIndices Method Introduced in Inventor 5

GraphicsNode Interface Introduced in Inventor 5

GraphicsNode Methods

GraphicsNode.AddComponentGraphics Method Introduced in Inventor 2012

GraphicsNode.AddCurveGraphics Method Introduced in Inventor 2008

GraphicsNode.AddLineGraphics Method Introduced in Inventor 5

GraphicsNode.AddLineStripGraphics Method Introduced in Inventor 5

GraphicsNode.AddPointGraphics Method Introduced in Inventor 5

GraphicsNode.AddScalableTextGraphics Method Introduced in Inventor 2008

GraphicsNode.AddSurfaceGraphics Method Introduced in Inventor 2009

GraphicsNode.AddTextGraphics Method Introduced in Inventor 5

GraphicsNode.AddTriangleFanGraphics Method Introduced in Inventor 5

GraphicsNode.AddTriangleGraphics Method Introduced in Inventor 5

GraphicsNode.AddTriangleStripGraphics Method Introduced in Inventor 5

GraphicsNode.ClearSlice Method Introduced in Inventor 2010

GraphicsNode.Copy Method Introduced in Inventor 5

GraphicsNode.Delete Method Introduced in Inventor 5

GraphicsNode.Item Method Introduced in Inventor 5

GraphicsNode.SliceGraphics Method Introduced in Inventor 2010

GraphicsNode Properties

GraphicsNode.AllowSlicing Property Introduced in Inventor 2010

GraphicsNode.Application Property Introduced in Inventor 5

GraphicsNode.Count Property Introduced in Inventor 5

GraphicsNode.DisplayName Property Introduced in Inventor 2012

GraphicsNode.ExcludedFromViewAll Property Introduced in Inventor 11

GraphicsNode.Id Property Introduced in Inventor 5

GraphicsNode.Parent Property Introduced in Inventor 5

GraphicsNode.RangeBox Property Introduced in Inventor 5

GraphicsNode.RenderStyle Property Introduced in Inventor 5

GraphicsNode.Selectable Property Introduced in Inventor 5

GraphicsNode.Transformation Property Introduced in Inventor 5

GraphicsNode.Type Property Introduced in Inventor 5

GraphicsNode.Visible Property Introduced in Inventor 5

GraphicsNode.VisibleInActiveEditObject Property Introduced in Inventor 9

GraphicsNode.VisibleInViews Property Introduced in Inventor 9

GraphicsNodeProxy Interface Introduced in Inventor 2008

GraphicsNodeProxy Properties

GraphicsNodeProxy.ContainingOccurrence Property Introduced in Inventor 2008

GraphicsNodeProxy.NativeObject Property Introduced in Inventor 2008

GraphicsNormalSet Interface Introduced in Inventor 5

GraphicsNormalSet Methods

GraphicsNormalSet.Add Method Introduced in Inventor 5

GraphicsNormalSet.GetNormals Method Introduced in Inventor 5

GraphicsNormalSet.Normal Method

GraphicsNormalSet.PutNormals Method Introduced in Inventor 5

GraphicsPreferences Interface

GraphicsPrimitive Interface Introduced in Inventor 5

GraphicsPrimitive Methods

GraphicsPrimitive.Delete Method Introduced in Inventor 5

GraphicsPrimitive.GetViewSpaceAnchor Method Introduced in Inventor 9

GraphicsPrimitive.Parent Method Introduced in Inventor 5

GraphicsPrimitive.RemoveViewSpaceAnchor Method Introduced in Inventor 9

GraphicsPrimitive.SetViewSpaceAnchor Method Introduced in Inventor 9

GraphicsPrimitive Properties

GraphicsPrimitive.Anchored Property Introduced in Inventor 9

GraphicsPrimitive.Application Property Introduced in Inventor 5

GraphicsPrimitive.RangeBox Property Introduced in Inventor 5

GraphicsPrimitive.Type Property Introduced in Inventor 5

GraphicsTextureCoordinateSet Interface Introduced in Inventor 2010

GraphicsTextureCoordinateSet Methods

GraphicsTextureCoordinateSet.Add Method Introduced in Inventor 2010

GraphicsTextureCoordinateSet.Coordinate Method Introduced in Inventor 2010

GraphicsTextureCoordinateSet.GetCoordinates Method Introduced in Inventor 2010

GraphicsTextureCoordinateSet.PutCoordinates Method Introduced in Inventor 2010

GraphicsTextureCoordinateSet Properties

GraphicsTextureCoordinateSet.TextureDimension Property Introduced in Inventor 2012

GrillFeature Interface Introduced in Inventor 2010

GrillFeatureProxy Interface Introduced in Inventor 2010

GrillFeatureProxy Properties

GrillFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

GrillFeatureProxy.NativeObject Property Introduced in Inventor 2010

GrillFeatures Interface Introduced in Inventor 2010

GrillFeatures Methods

GrillFeatures.Item Method Introduced in Inventor 2010

GrillFeatures Properties

GrillFeatures.Application Property Introduced in Inventor 2010

GrillFeatures.Count Property Introduced in Inventor 2010

GrillFeatures.Type Property Introduced in Inventor 2010

GripSnapOptions Interface Introduced in Inventor 2010

GripSnapOptions Properties

GripSnapOptions.Application Property Introduced in Inventor 2010

GripSnapOptions.DisplayObjectInOriginalLocation Property Introduced in Inventor 2010

GripSnapOptions.SelectGroundedComponentsAndWorkGeometry Property Introduced in Inventor 2010

GripSnapOptions.ShowDegreesOfFreedom Property Introduced in Inventor 2010

GripSnapOptions.Type Property Introduced in Inventor 2010

GripSnapOptions.UseFreeDrag Property Introduced in Inventor 2010

GripSnapOptions.UseTemporaryConstraints Property Introduced in Inventor 2010

GroundConstraint Interface Introduced in Inventor 5

GroundConstraint Properties

GroundConstraint.Entity Property Introduced in Inventor 5

GroundConstraint3D Interface Introduced in Inventor 10

GroundConstraint3D Properties

GroundConstraint3D.Entity Property Introduced in Inventor 10

GroundConstraint3DProxy Interface Introduced in Inventor 10

GroundConstraint3DProxy Properties

GroundConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 10

GroundConstraint3DProxy.NativeObject Property Introduced in Inventor 10

GroundConstraintProxy Interface Introduced in Inventor 6

GroundConstraintProxy Properties

GroundConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

GroundConstraintProxy.NativeObject Property Introduced in Inventor 6

GroundPlaneSettings Interface Introduced in Inventor 2011

GroundPlaneSettings Methods

GroundPlaneSettings.GetSize Method

GroundPlaneSettings.SetSize Method

GroundPlaneSettings Properties

GroundPlaneSettings.Application Property

GroundPlaneSettings.AutoResize Property

GroundPlaneSettings.Color Property

GroundPlaneSettings.DisplayGridLines Property

GroundPlaneSettings.FrontDirection Property Introduced in Inventor 2012

GroundPlaneSettings.HeightOffset Property

GroundPlaneSettings.MinorGridLineSpacing Property

GroundPlaneSettings.MinorLinesPerMajorGridLine Property

GroundPlaneSettings.Opacity Property

GroundPlaneSettings.Plane Property

GroundPlaneSettings.Position Property

GroundPlaneSettings.ReflectionBlur Property

GroundPlaneSettings.ReflectionBlurFalloff Property

GroundPlaneSettings.Reflectivity Property

GroundPlaneSettings.Type Property

GroundPlaneSettings.UpDirection Property Introduced in Inventor 2012

HardwareOptions Interface Introduced in Inventor 11

HardwareOptions Properties

HardwareOptions.Application Property Introduced in Inventor 11

HardwareOptions.Diagnostics Property Introduced in Inventor 2010

HardwareOptions.GraphicsSettingType Property Introduced in Inventor 2011

HardwareOptions.Type Property Introduced in Inventor 11

HardwareOptions.UseSoftwareGraphics Property Introduced in Inventor 2011

HeadsUpDisplayOptions Interface Introduced in Inventor 2011

HeadsUpDisplayOptions Properties

HeadsUpDisplayOptions.Application Property

HeadsUpDisplayOptions.CreateDimensionsOnValueInput Property

HeadsUpDisplayOptions.DimensionInputEnabled Property

HeadsUpDisplayOptions.DimensionInputInCartesianCoordinates Property

HeadsUpDisplayOptions.Enabled Property

HeadsUpDisplayOptions.Parent Property

HeadsUpDisplayOptions.PointerInputEnabled Property

HeadsUpDisplayOptions.PointerInputInCartesianCoordinates Property

HeadsUpDisplayOptions.Type Property

HelicalConstraint3D Interface Introduced in Inventor 2010

HelicalConstraint3DProxy Interface Introduced in Inventor 2010

HelicalConstraint3DProxy Properties

HelicalConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 2010

HelicalConstraint3DProxy.NativeObject Property Introduced in Inventor 2010

HelpEventsObject Interface Introduced in Inventor 2012

HelpEventsObject Properties

HelpEventsObject.Application Property Introduced in Inventor 2012

HelpEventsObject.Type Property Introduced in Inventor 2012

HelpEventsSink Interface

HelpEventsSink Methods

HelpEventsSink.OnApplicationHelp Method Introduced in Inventor 2012

HelpManager Interface Introduced in Inventor 4

HelpManager Methods

HelpManager.DisplayHelpContext Method Introduced in Inventor 4

HelpManager.DisplayHelpTopic Method Introduced in Inventor 4

HelpManager Properties

HelpManager.HelpEvents Property Introduced in Inventor 2012

HelpManager.HelpPath Property Introduced in Inventor 2010

HelpManager.Parent Property Introduced in Inventor 4

HelpManager.Type Property Introduced in Inventor 4

HemDefinition Interface Introduced in Inventor 2009

HemDefinition Methods

HemDefinition.Copy Method Introduced in Inventor 2010

HemDefinition.SetCenteredWidthExtent Method Introduced in Inventor 2010

HemDefinition.SetDoubleHemType Method Introduced in Inventor 2010

HemDefinition.SetEdgeWidthExtent Method Introduced in Inventor 2010

HemDefinition.SetFromToWidthExtent Method Introduced in Inventor 2010

HemDefinition.SetOffsetWidthExtent Method Introduced in Inventor 2010

HemDefinition.SetRolledHemType Method Introduced in Inventor 2010

HemDefinition.SetSingleHemType Method Introduced in Inventor 2010

HemDefinition.SetTeardropHemType Method Introduced in Inventor 2010

HemDefinition.SetWidthOffsetWidthExtent Method Introduced in Inventor 2010

HemDefinition Properties

HemDefinition.Application Property Introduced in Inventor 2009

HemDefinition.BendOptions Property Introduced in Inventor 2009

HemDefinition.Edges Property Introduced in Inventor 2009

HemDefinition.HemType Property Introduced in Inventor 2009

HemDefinition.HemTypeDefinition Property Introduced in Inventor 2009

HemDefinition.IsOnEdgeSide Property Introduced in Inventor 2010

HemDefinition.IsUnfoldMethodOverridden Property Introduced in Inventor 2011

HemDefinition.Parent Property Introduced in Inventor 2009

HemDefinition.Type Property Introduced in Inventor 2009

HemDefinition.UnfoldMethod Property Introduced in Inventor 2009

HemDefinition.WidthExtent Property Introduced in Inventor 2009

HemDefinition.WidthExtentType Property Introduced in Inventor 2009

HemFeature Interface Introduced in Inventor 5.3

HemFeature Properties

HemFeature.Definition Property Introduced in Inventor 2009

HemFeatureProxy Interface Introduced in Inventor 9

HemFeatures Interface Introduced in Inventor 5.3

HemFeatures Methods

HemFeatures.Add Method Introduced in Inventor 2010

HemFeatures.CreateHemDefinition Method Introduced in Inventor 2010

HemFeatures.Item Method Introduced in Inventor 5.3

HemFeatures Properties

HemFeatures.Application Property Introduced in Inventor 5.3

HemFeatures.Count Property Introduced in Inventor 5.3

HemFeatures.Type Property Introduced in Inventor 5.3

HighlightSet Interface Introduced in Inventor 5

HighlightSet Methods

HighlightSet.AddItem Method Introduced in Inventor 5

HighlightSet.Clear Method Introduced in Inventor 5

HighlightSet.Delete Method Introduced in Inventor 5

HighlightSet.GetColor Method

HighlightSet.Item Method Introduced in Inventor 5

HighlightSet.Remove Method Introduced in Inventor 5

HighlightSet.SetColor Method

HighlightSet Properties

HighlightSet.Color Property Introduced in Inventor 11

HighlightSet.Count Property Introduced in Inventor 5

HighlightSet.Type Property Introduced in Inventor 5

HighlightSets Interface

HighlightSets Methods

HighlightSets.Add Method

HighlightSets.Item Method

HighlightSets Properties

HighlightSets.Count Property

HighlightSets.Type Property

HoleFeature Interface Introduced in Inventor 5

HoleFeature Methods

HoleFeature.AddParticipant Method Introduced in Inventor 11

HoleFeature.SetCBore Method Introduced in Inventor 5

HoleFeature.SetCSink Method Introduced in Inventor 5

HoleFeature.SetDistanceExtent Method Introduced in Inventor 6

HoleFeature.SetDrilled Method Introduced in Inventor 5

HoleFeature.SetSpotFace Method Introduced in Inventor 2008

HoleFeature.SetThroughAllExtent Method Introduced in Inventor 6

HoleFeature.SetToFaceExtent Method Introduced in Inventor 6

HoleFeature Properties

HoleFeature.BottomTipAngle Property Introduced in Inventor 5

HoleFeature.CBoreDepth Property Introduced in Inventor 5

HoleFeature.CBoreDiameter Property Introduced in Inventor 5

HoleFeature.CSinkAngle Property Introduced in Inventor 5

HoleFeature.CSinkDiameter Property Introduced in Inventor 5

HoleFeature.EndFaces Property Introduced in Inventor 5

HoleFeature.Extent Property Introduced in Inventor 5

HoleFeature.ExtentType Property Introduced in Inventor 5

HoleFeature.FlatBottom Property Introduced in Inventor 5

HoleFeature.HoleCenterPoints Property Introduced in Inventor 5

HoleFeature.HoleDiameter Property Introduced in Inventor 5

HoleFeature.HoleType Property Introduced in Inventor 5

HoleFeature.PlacementDefinition Property Introduced in Inventor 10

HoleFeature.PlacementType Property Introduced in Inventor 9

HoleFeature.SideFaces Property Introduced in Inventor 5

HoleFeature.Sketch Property Introduced in Inventor 5

HoleFeature.SpotFaceDepth Property Introduced in Inventor 2008

HoleFeature.SpotFaceDiameter Property Introduced in Inventor 2008

HoleFeature.TapInfo Property Introduced in Inventor 5

HoleFeature.Tapped Property Introduced in Inventor 5

HoleFeatureProxy Interface Introduced in Inventor 9

HoleFeatureProxy Properties

HoleFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

HoleFeatureProxy.NativeObject Property Introduced in Inventor 9

HoleFeatures Interface Introduced in Inventor 5

HoleFeatures Methods

HoleFeatures.AddCBoreByDistanceExtent Method Introduced in Inventor 5

HoleFeatures.AddCBoreByThroughAllExtent Method Introduced in Inventor 5

HoleFeatures.AddCBoreByToFaceExtent Method Introduced in Inventor 5

HoleFeatures.AddCSinkByDistanceExtent Method Introduced in Inventor 5

HoleFeatures.AddCSinkByThroughAllExtent Method Introduced in Inventor 5

HoleFeatures.AddCSinkByToFaceExtent Method Introduced in Inventor 5

HoleFeatures.AddDrilledByDistanceExtent Method Introduced in Inventor 5

HoleFeatures.AddDrilledByThroughAllExtent Method Introduced in Inventor 5

HoleFeatures.AddDrilledByToFaceExtent Method Introduced in Inventor 5

HoleFeatures.AddSpotFaceByDistanceExtent Method Introduced in Inventor 2008

HoleFeatures.AddSpotFaceByThroughAllExtent Method Introduced in Inventor 2008

HoleFeatures.AddSpotFaceByToFaceExtent Method Introduced in Inventor 2008

HoleFeatures.CreateConcentricPlacementDefinition Method Introduced in Inventor 11

HoleFeatures.CreateLinearPlacementDefinition Method Introduced in Inventor 11

HoleFeatures.CreatePointPlacementDefinition Method Introduced in Inventor 11

HoleFeatures.CreateSketchPlacementDefinition Method Introduced in Inventor 11

HoleFeatures.CreateTaperedTapInfo Method Introduced in Inventor 2008

HoleFeatures.CreateTapInfo Method Introduced in Inventor 5

HoleFeatures.Item Method Introduced in Inventor 5

HoleFeatures Properties

HoleFeatures.Application Property Introduced in Inventor 5

HoleFeatures.Count Property Introduced in Inventor 5

HoleFeatures.Type Property Introduced in Inventor 5

HolePlacementDefinition Interface Introduced in Inventor 10

HolePlacementDefinition Properties

HolePlacementDefinition.Application Property Introduced in Inventor 10

HolePlacementDefinition.Parent Property Introduced in Inventor 10

HolePlacementDefinition.Type Property Introduced in Inventor 10

HoleTable Interface Introduced in Inventor 10

HoleTable Methods

HoleTable.Delete Method Introduced in Inventor 10

HoleTable.Export Method Introduced in Inventor 2009

HoleTable.GetReferenceKey Method Introduced in Inventor 10

HoleTable.MatchCustomHoles Method Introduced in Inventor 2009

HoleTable.ShowTags Method Introduced in Inventor 10

HoleTable Properties

HoleTable.Application Property Introduced in Inventor 10

HoleTable.ArrangeByPosition Property Introduced in Inventor 2009

HoleTable.AttributeSets Property Introduced in Inventor 10

HoleTable.ColumnHeaderTextStyle Property Introduced in Inventor 2009

HoleTable.DataTextStyle Property Introduced in Inventor 2009

HoleTable.DeleteTagsOnRollup Property Introduced in Inventor 2009

HoleTable.GroupHoleTypes Property Introduced in Inventor 2009

HoleTable.HeadingPlacement Property Introduced in Inventor 10

HoleTable.HoleTableColumns Property Introduced in Inventor 10

HoleTable.HoleTableRows Property Introduced in Inventor 10

HoleTable.HoleTableType Property Introduced in Inventor 2009

HoleTable.IncludeCentermarks Property Introduced in Inventor 2009

HoleTable.IncludeCircularCuts Property Introduced in Inventor 2009

HoleTable.IncludeCounterBoreHoleFeatures Property Introduced in Inventor 2009

HoleTable.IncludeCounterSinkHoleFeatures Property Introduced in Inventor 2009

HoleTable.IncludeDrilledHoleFeatures Property Introduced in Inventor 2009

HoleTable.IncludeHoleFeatures Property Introduced in Inventor 2009

HoleTable.IncludeRecoveredPunchCenters Property Introduced in Inventor 2009

HoleTable.IncludeThreadedHoleFeatures Property Introduced in Inventor 2009

HoleTable.Layer Property Introduced in Inventor 10

HoleTable.Parent Property Introduced in Inventor 10

HoleTable.ParentView Property Introduced in Inventor 2009

HoleTable.Position Property Introduced in Inventor 10

HoleTable.PreserveTagging Property Introduced in Inventor 2009

HoleTable.RangeBox Property Introduced in Inventor 2010

HoleTable.ReformatOnCustomHoleMatch Property Introduced in Inventor 2009

HoleTable.RowMergeType Property Introduced in Inventor 2009

HoleTable.SecondaryTagModifierOnRollup Property Introduced in Inventor 2009

HoleTable.SequentialNumbering Property Introduced in Inventor 2009

HoleTable.Style Property Introduced in Inventor 2009

HoleTable.Title Property Introduced in Inventor 10

HoleTable.TitleTextStyle Property Introduced in Inventor 2009

HoleTable.Type Property Introduced in Inventor 10

HoleTableCell Interface Introduced in Inventor 10

HoleTableCell Properties

HoleTableCell.Application Property Introduced in Inventor 10

HoleTableCell.FormattedText Property Introduced in Inventor 10

HoleTableCell.Parent Property Introduced in Inventor 10

HoleTableCell.StackedTextPosition Property Introduced in Inventor 2009

HoleTableCell.Text Property Introduced in Inventor 10

HoleTableCell.Type Property Introduced in Inventor 10

HoleTableColumn Interface Introduced in Inventor 10

HoleTableColumn Methods

HoleTableColumn.Delete Method Introduced in Inventor 2009

HoleTableColumn.Reposition Method Introduced in Inventor 2009

HoleTableColumn Properties

HoleTableColumn.Application Property Introduced in Inventor 10

HoleTableColumn.CustomPropertyName Property Introduced in Inventor 2009

HoleTableColumn.Parent Property Introduced in Inventor 10

HoleTableColumn.PropertyType Property Introduced in Inventor 2009

HoleTableColumn.Title Property Introduced in Inventor 10

HoleTableColumn.Type Property Introduced in Inventor 10

HoleTableColumn.Width Property Introduced in Inventor 2010

HoleTableColumns Interface Introduced in Inventor 10

HoleTableColumns Methods

HoleTableColumns.Add Method Introduced in Inventor 2009

HoleTableColumns.Item Method Introduced in Inventor 10

HoleTableColumns Properties

HoleTableColumns.Application Property Introduced in Inventor 10

HoleTableColumns.Count Property Introduced in Inventor 10

HoleTableColumns.Type Property Introduced in Inventor 10

HoleTableRow Interface Introduced in Inventor 10

HoleTableRow Methods

HoleTableRow.Delete Method Introduced in Inventor 10

HoleTableRow.Item Method Introduced in Inventor 10

HoleTableRow Properties

HoleTableRow.Application Property Introduced in Inventor 10

HoleTableRow.Count Property Introduced in Inventor 10

HoleTableRow.Height Property Introduced in Inventor 2010

HoleTableRow.HoleTag Property Introduced in Inventor 10

HoleTableRow.Parent Property Introduced in Inventor 10

HoleTableRow.ReferencedHole Property Introduced in Inventor 2009

HoleTableRow.Type Property Introduced in Inventor 10

HoleTableRows Interface Introduced in Inventor 10

HoleTableRows Methods

HoleTableRows.Add Method Introduced in Inventor 2009

HoleTableRows.Item Method Introduced in Inventor 10

HoleTableRows Properties

HoleTableRows.Application Property Introduced in Inventor 10

HoleTableRows.Count Property Introduced in Inventor 10

HoleTableRows.Type Property Introduced in Inventor 10

HoleTables Interface Introduced in Inventor 10

HoleTables Methods

HoleTables.Add Method Introduced in Inventor 2009

HoleTables.AddByFeatureType Method Introduced in Inventor 2009

HoleTables.AddSelected Method Introduced in Inventor 2009

HoleTables.Item Method Introduced in Inventor 10

HoleTables Properties

HoleTables.Application Property Introduced in Inventor 10

HoleTables.Count Property Introduced in Inventor 10

HoleTables.Type Property Introduced in Inventor 10

HoleTableStyle Interface Introduced in Inventor 2009

HoleTableStyle Methods

HoleTableStyle.AddColumn Method Introduced in Inventor 2011

HoleTableStyle.RemoveAllColumns Method

HoleTableStyle Properties

HoleTableStyle.ArrangeByPosition Property Introduced in Inventor 2009

HoleTableStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2009

HoleTableStyle.DataTextStyle Property Introduced in Inventor 2009

HoleTableStyle.DeleteTagsOnRollup Property Introduced in Inventor 2009

HoleTableStyle.GroupHoleTypes Property Introduced in Inventor 2009

HoleTableStyle.HeadingPlacement Property Introduced in Inventor 2009

HoleTableStyle.IncludeCentermarks Property Introduced in Inventor 2009

HoleTableStyle.IncludeCircularCuts Property Introduced in Inventor 2009

HoleTableStyle.IncludeCounterBoreHoleFeatures Property Introduced in Inventor 2009

HoleTableStyle.IncludeCounterSinkHoleFeatures Property Introduced in Inventor 2009

HoleTableStyle.IncludeDrilledHoleFeatures Property Introduced in Inventor 2009

HoleTableStyle.IncludeHoleFeatures Property Introduced in Inventor 2009

HoleTableStyle.IncludeRecoveredPunchCenters Property Introduced in Inventor 2009

HoleTableStyle.IncludeThreadedHoleFeatures Property Introduced in Inventor 2009

HoleTableStyle.InsideLineColor Property Introduced in Inventor 2009

HoleTableStyle.InsideLineWeight Property Introduced in Inventor 2009

HoleTableStyle.OutsideLineColor Property Introduced in Inventor 2009

HoleTableStyle.OutsideLineWeight Property Introduced in Inventor 2009

HoleTableStyle.PreserveTagging Property Introduced in Inventor 2009

HoleTableStyle.ReformatOnCustomHoleMatch Property Introduced in Inventor 2009

HoleTableStyle.RowMergeType Property Introduced in Inventor 2009

HoleTableStyle.SecondaryTagModifierOnRollup Property Introduced in Inventor 2009

HoleTableStyle.SequentialNumbering Property Introduced in Inventor 2009

HoleTableStyle.Title Property Introduced in Inventor 2009

HoleTableStyle.TitleTextStyle Property Introduced in Inventor 2009

HoleTableStyle.UseLeaderForTags Property Introduced in Inventor 2009

HoleTableStylesEnumerator Interface Introduced in Inventor 2009

HoleTableStylesEnumerator Methods

HoleTableStylesEnumerator.Item Method Introduced in Inventor 2009

HoleTableStylesEnumerator Properties

HoleTableStylesEnumerator.Application Property Introduced in Inventor 2009

HoleTableStylesEnumerator.Count Property Introduced in Inventor 2009

HoleTableStylesEnumerator.Type Property Introduced in Inventor 2009

HoleTag Interface Introduced in Inventor 10

HoleTag Properties

HoleTag.Application Property Introduced in Inventor 10

HoleTag.DimensionStyle Property Introduced in Inventor 10

HoleTag.FormattedText Property Introduced in Inventor 10

HoleTag.Layer Property Introduced in Inventor 11

HoleTag.Leader Property Introduced in Inventor 2009

HoleTag.Parent Property Introduced in Inventor 10

HoleTag.Position Property Introduced in Inventor 10

HoleTag.RangeBox Property Introduced in Inventor 2010

HoleTag.ShowLeader Property Introduced in Inventor 10

HoleTag.StackedTextPosition Property Introduced in Inventor 2009

HoleTag.Text Property Introduced in Inventor 10

HoleTag.Type Property Introduced in Inventor 10

HoleTag.Visible Property Introduced in Inventor 10

HoleTapInfo Interface Introduced in Inventor 5

HoleTapInfo Properties

HoleTapInfo.ThreadDepth Property Introduced in Inventor 5

HoleThreadNote Interface Introduced in Inventor 2010

HoleThreadNote Properties

HoleThreadNote.Edge Property Introduced in Inventor 2010

HoleThreadNote.FormattedHoleThreadNote Property Introduced in Inventor 2010

HoleThreadNote.FormattedQuantityNote Property Introduced in Inventor 2010

HoleThreadNote.IsHoleNote Property Introduced in Inventor 2010

HoleThreadNote.QuantityDefinition Property Introduced in Inventor 2010

HoleThreadNote.TapDrill Property Introduced in Inventor 2010

HoleThreadNote.UseCustomThreadDesignation Property Introduced in Inventor 2010

HoleThreadNote.UseDefaultFormat Property Introduced in Inventor 2010

HoleThreadNote.UsePartUnits Property Introduced in Inventor 2010

HoleThreadNotes Interface Introduced in Inventor 2010

HoleThreadNotes Methods

HoleThreadNotes.Add Method Introduced in Inventor 2010

HoleThreadNotes.Item Method Introduced in Inventor 2010

HoleThreadNotes Properties

HoleThreadNotes.Application Property Introduced in Inventor 2010

HoleThreadNotes.Count Property Introduced in Inventor 2010

HoleThreadNotes.Type Property Introduced in Inventor 2010

HorizontalAlignConstraint Interface Introduced in Inventor 5

HorizontalAlignConstraint Properties

HorizontalAlignConstraint.PointOne Property Introduced in Inventor 5

HorizontalAlignConstraint.PointTwo Property Introduced in Inventor 5

HorizontalAlignConstraintProxy Interface Introduced in Inventor 6

HorizontalAlignConstraintProxy Properties

HorizontalAlignConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

HorizontalAlignConstraintProxy.NativeObject Property Introduced in Inventor 6

HorizontalConstraint Interface Introduced in Inventor 5

HorizontalConstraint Properties

HorizontalConstraint.Entity Property Introduced in Inventor 5

HorizontalConstraint.UseEllipseMajorAxis Property Introduced in Inventor 5

HorizontalConstraintProxy Interface Introduced in Inventor 6

HorizontalConstraintProxy Properties

HorizontalConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

HorizontalConstraintProxy.NativeObject Property Introduced in Inventor 6

iAssemblyFactory Interface Introduced in Inventor 11

iAssemblyFactory Methods

iAssemblyFactory.CreateMember Method Introduced in Inventor 11

iAssemblyFactory.Delete Method Introduced in Inventor 11

iAssemblyFactory Properties

iAssemblyFactory.Application Property Introduced in Inventor 11

iAssemblyFactory.DefaultRow Property Introduced in Inventor 11

iAssemblyFactory.ExcelWorkSheet Property Introduced in Inventor 11

iAssemblyFactory.FactoryOptions Property Introduced in Inventor 2010

iAssemblyFactory.FileNameColumn Property Introduced in Inventor 2011

iAssemblyFactory.MemberCacheDir Property Introduced in Inventor 11

iAssemblyFactory.MemberEditScope Property Introduced in Inventor 11

iAssemblyFactory.Parent Property Introduced in Inventor 11

iAssemblyFactory.TableColumns Property Introduced in Inventor 11

iAssemblyFactory.TableRows Property Introduced in Inventor 11

iAssemblyFactory.Type Property Introduced in Inventor 11

iAssemblyMember Interface Introduced in Inventor 11

iAssemblyMember Methods

iAssemblyMember.BreakLinkToFactory Method Introduced in Inventor 11

iAssemblyMember Properties

iAssemblyMember.Application Property Introduced in Inventor 11

iAssemblyMember.HealthStatus Property Introduced in Inventor 11

iAssemblyMember.Parent Property Introduced in Inventor 11

iAssemblyMember.ParentFactory Property Introduced in Inventor 11

iAssemblyMember.ReferencedDocumentDescriptor Property Introduced in Inventor 11

iAssemblyMember.Row Property Introduced in Inventor 11

iAssemblyMember.Type Property Introduced in Inventor 11

iAssemblyTableCell Interface Introduced in Inventor 11

iAssemblyTableCell Properties

iAssemblyTableCell.Application Property Introduced in Inventor 11

iAssemblyTableCell.Column Property Introduced in Inventor 11

iAssemblyTableCell.HasFormula Property Introduced in Inventor 2010

iAssemblyTableCell.IsValid Property Introduced in Inventor 2010

iAssemblyTableCell.Parent Property Introduced in Inventor 11

iAssemblyTableCell.Row Property Introduced in Inventor 11

iAssemblyTableCell.Type Property Introduced in Inventor 11

iAssemblyTableCell.Value Property Introduced in Inventor 11

iAssemblyTableColumn Interface Introduced in Inventor 11

iAssemblyTableColumn Methods

iAssemblyTableColumn.Delete Method

iAssemblyTableColumn Properties

iAssemblyTableColumn.Application Property Introduced in Inventor 11

iAssemblyTableColumn.Count Property Introduced in Inventor 11

iAssemblyTableColumn.DisplayHeading Property Introduced in Inventor 11

iAssemblyTableColumn.FormattedHeading Property Introduced in Inventor 11

iAssemblyTableColumn.Heading Property Introduced in Inventor 11

iAssemblyTableColumn.Index Property Introduced in Inventor 2010

iAssemblyTableColumn.Item Method Introduced in Inventor 11

iAssemblyTableColumn.Key Property Introduced in Inventor 2011

iAssemblyTableColumn.Parent Property Introduced in Inventor 11

iAssemblyTableColumn.ReferencedDataType Property Introduced in Inventor 2011

iAssemblyTableColumn.ReferencedObject Property Introduced in Inventor 2011

iAssemblyTableColumn.Type Property Introduced in Inventor 11

iAssemblyTableColumns Interface Introduced in Inventor 11

iAssemblyTableColumns Methods

iAssemblyTableColumns.Item Method Introduced in Inventor 11

iAssemblyTableColumns Properties

iAssemblyTableColumns.Application Property Introduced in Inventor 11

iAssemblyTableColumns.Count Property Introduced in Inventor 11

iAssemblyTableColumns.Type Property Introduced in Inventor 11

iAssemblyTableRow Interface Introduced in Inventor 11

iAssemblyTableRow Methods

iAssemblyTableRow.Copy Method Introduced in Inventor 11

iAssemblyTableRow.Delete Method Introduced in Inventor 11

iAssemblyTableRow.GetReferenceKey Method Introduced in Inventor 2009

iAssemblyTableRow.IsExcluded Method Introduced in Inventor 11

iAssemblyTableRow.Item Method Introduced in Inventor 11

iAssemblyTableRow Properties

iAssemblyTableRow.Application Property Introduced in Inventor 11

iAssemblyTableRow.AttributeSets Property Introduced in Inventor 2009

iAssemblyTableRow.Count Property Introduced in Inventor 11

iAssemblyTableRow.DocumentName Property Introduced in Inventor 11

iAssemblyTableRow.DocumentNameModifiable Property Introduced in Inventor 11

iAssemblyTableRow.Index Property Introduced in Inventor 2010

iAssemblyTableRow.IsDocumentNameBasedOnMemberName Property Introduced in Inventor 11

iAssemblyTableRow.MemberName Property Introduced in Inventor 11

iAssemblyTableRow.Parent Property Introduced in Inventor 11

iAssemblyTableRow.Type Property Introduced in Inventor 11

iAssemblyTableRows Interface Introduced in Inventor 11

iAssemblyTableRows Methods

iAssemblyTableRows.Item Method Introduced in Inventor 11

iAssemblyTableRows Properties

iAssemblyTableRows.Application Property Introduced in Inventor 11

iAssemblyTableRows.Count Property Introduced in Inventor 11

iAssemblyTableRows.Type Property Introduced in Inventor 11

iFeature Interface Introduced in Inventor 2009

iFeature Properties

iFeature.iFeatureDefinition Property Introduced in Inventor 2009

iFeature.iFeatureTemplateDescriptor Property Introduced in Inventor 2009

iFeature.Sketches Property Introduced in Inventor 2009

iFeatureDefinition Interface Introduced in Inventor 6

iFeatureDefinition Properties

iFeatureDefinition.ActiveTableRow Property Introduced in Inventor 2009

iFeatureDefinition.Application Property Introduced in Inventor 6

iFeatureDefinition.iFeatureInputs Property Introduced in Inventor 6

iFeatureDefinition.iFeatureTable Property Introduced in Inventor 2009

iFeatureDefinition.IsPunchTool Property Introduced in Inventor 2009

iFeatureDefinition.IsTableDriven Property Introduced in Inventor 2009

iFeatureDefinition.PunchId Property Introduced in Inventor 2009

iFeatureDefinition.Type Property Introduced in Inventor 6

iFeatureEntityInput Interface Introduced in Inventor 6

iFeatureEntityInput Properties

iFeatureEntityInput.Entity Property Introduced in Inventor 6

iFeatureInput Interface Introduced in Inventor 6

iFeatureInput Properties

iFeatureInput.Application Property Introduced in Inventor 6

iFeatureInput.EntityType Property Introduced in Inventor 6

iFeatureInput.Name Property Introduced in Inventor 2009

iFeatureInput.Prompt Property Introduced in Inventor 6

iFeatureInput.Type Property Introduced in Inventor 6

iFeatureInputs Interface Introduced in Inventor 6

iFeatureInputs Methods

iFeatureInputs.Item Method Introduced in Inventor 6

iFeatureInputs Properties

iFeatureInputs.Application Property Introduced in Inventor 6

iFeatureInputs.Count Property Introduced in Inventor 6

iFeatureInputs.Type Property Introduced in Inventor 6

iFeatureOptions Interface Introduced in Inventor 11

iFeatureOptions Properties

iFeatureOptions.Application Property Introduced in Inventor 11

iFeatureOptions.RootPath Property Introduced in Inventor 11

iFeatureOptions.SheetMetalPunchesRootPath Property Introduced in Inventor 11

iFeatureOptions.Type Property Introduced in Inventor 11

iFeatureOptions.UseKey1AsBrowserNameColumn Property Introduced in Inventor 2010

iFeatureOptions.UserRootPath Property Introduced in Inventor 11

iFeatureOptions.Viewer Property Introduced in Inventor 11

iFeatureOptions.ViewerArguments Property Introduced in Inventor 11

iFeatureParameterInput Interface Introduced in Inventor 6

iFeatureParameterInput Methods

iFeatureParameterInput.LimitListExpressions Method Introduced in Inventor 6

iFeatureParameterInput.LimitRangeExpressions Method Introduced in Inventor 6

iFeatureParameterInput Properties

iFeatureParameterInput.DefaultExpression Property Introduced in Inventor 6

iFeatureParameterInput.Expression Property Introduced in Inventor 6

iFeatureParameterInput.IsPunchToolDepth Property Introduced in Inventor 2009

iFeatureParameterInput.LimitListCount Property Introduced in Inventor 6

iFeatureParameterInput.LimitType Property Introduced in Inventor 6

iFeatureParameterInput.Parameter Property Introduced in Inventor 6

iFeatureParameterInput.Value Property Introduced in Inventor 6

iFeatureProxy Interface Introduced in Inventor 2009

iFeatureProxy Properties

iFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2009

iFeatureProxy.NativeObject Property Introduced in Inventor 2009

iFeatures Interface Introduced in Inventor 2009

iFeatures Methods

iFeatures.Add Method Introduced in Inventor 2009

iFeatures.CreateiFeatureDefinition Method Introduced in Inventor 2009

iFeatures.Item Method Introduced in Inventor 2009

iFeatures Properties

iFeatures.Application Property Introduced in Inventor 2009

iFeatures.Count Property Introduced in Inventor 2009

iFeatures.Type Property Introduced in Inventor 2009

iFeatureSketchPlaneInput Interface Introduced in Inventor 6

iFeatureSketchPlaneInput Methods

iFeatureSketchPlaneInput.SetPosition Method Introduced in Inventor 6

iFeatureSketchPlaneInput Properties

iFeatureSketchPlaneInput.FlipOption Property Introduced in Inventor 6

iFeatureSketchPlaneInput.PlaneInput Property Introduced in Inventor 6

iFeatureTable Interface Introduced in Inventor 2009

iFeatureTable Methods

iFeatureTable.Delete Method Introduced in Inventor 2010

iFeatureTable Properties

iFeatureTable.Application Property Introduced in Inventor 2009

iFeatureTable.DefaultRow Property Introduced in Inventor 2009

iFeatureTable.ExcelWorkSheet Property Introduced in Inventor 2011

iFeatureTable.iFeatureTableColumns Property Introduced in Inventor 2009

iFeatureTable.iFeatureTableRows Property Introduced in Inventor 2009

iFeatureTable.Parent Property Introduced in Inventor 2009

iFeatureTable.Type Property Introduced in Inventor 2009

iFeatureTableCell Interface Introduced in Inventor 2009

iFeatureTableCell Properties

iFeatureTableCell.Application Property Introduced in Inventor 2009

iFeatureTableCell.Column Property Introduced in Inventor 2009

iFeatureTableCell.CustomCell Property Introduced in Inventor 2011

iFeatureTableCell.CustomIncrement Property Introduced in Inventor 2011

iFeatureTableCell.CustomRangeMaximum Property Introduced in Inventor 2011

iFeatureTableCell.CustomRangeMinimum Property Introduced in Inventor 2011

iFeatureTableCell.HasFormula Property Introduced in Inventor 2010

iFeatureTableCell.IsValid Property Introduced in Inventor 2010

iFeatureTableCell.Parent Property Introduced in Inventor 2009

iFeatureTableCell.Row Property Introduced in Inventor 2009

iFeatureTableCell.Type Property Introduced in Inventor 2009

iFeatureTableCell.Value Property Introduced in Inventor 2009

iFeatureTableColumn Interface Introduced in Inventor 2009

iFeatureTableColumn Methods

iFeatureTableColumn.Delete Method

iFeatureTableColumn Properties

iFeatureTableColumn.Application Property Introduced in Inventor 2009

iFeatureTableColumn.Count Property Introduced in Inventor 2009

iFeatureTableColumn.CustomColumn Property Introduced in Inventor 2011

iFeatureTableColumn.CustomIncrement Property Introduced in Inventor 2011

iFeatureTableColumn.CustomRangeMaximum Property Introduced in Inventor 2011

iFeatureTableColumn.CustomRangeMinimum Property Introduced in Inventor 2011

iFeatureTableColumn.DisplayHeading Property Introduced in Inventor 2009

iFeatureTableColumn.FormattedHeading Property Introduced in Inventor 2009

iFeatureTableColumn.Heading Property Introduced in Inventor 2009

iFeatureTableColumn.Index Property Introduced in Inventor 2010

iFeatureTableColumn.Item Method Introduced in Inventor 2009

iFeatureTableColumn.Key Property Introduced in Inventor 2011

iFeatureTableColumn.Parent Property Introduced in Inventor 2009

iFeatureTableColumn.Type Property Introduced in Inventor 2009

iFeatureTableColumns Interface Introduced in Inventor 2009

iFeatureTableColumns Methods

iFeatureTableColumns.Item Method Introduced in Inventor 2009

iFeatureTableColumns Properties

iFeatureTableColumns.Application Property Introduced in Inventor 2009

iFeatureTableColumns.Count Property Introduced in Inventor 2009

iFeatureTableColumns.Type Property Introduced in Inventor 2009

iFeatureTableRow Interface Introduced in Inventor 2009

iFeatureTableRow Methods

iFeatureTableRow.Copy Method Introduced in Inventor 2010

iFeatureTableRow.Delete Method Introduced in Inventor 2010

iFeatureTableRow.Item Method Introduced in Inventor 2009

iFeatureTableRow Properties

iFeatureTableRow.Application Property Introduced in Inventor 2009

iFeatureTableRow.Count Property Introduced in Inventor 2009

iFeatureTableRow.Index Property Introduced in Inventor 2010

iFeatureTableRow.MemberName Property Introduced in Inventor 2009

iFeatureTableRow.Parent Property Introduced in Inventor 2009

iFeatureTableRow.Type Property Introduced in Inventor 2009

iFeatureTableRows Interface Introduced in Inventor 2009

iFeatureTableRows Methods

iFeatureTableRows.Item Method Introduced in Inventor 2009

iFeatureTableRows Properties

iFeatureTableRows.Application Property Introduced in Inventor 2009

iFeatureTableRows.Count Property Introduced in Inventor 2009

iFeatureTableRows.Type Property Introduced in Inventor 2009

iFeatureTemplateDescriptor Interface Introduced in Inventor 5.3

iFeatureTemplateDescriptor Methods

iFeatureTemplateDescriptor.DelayReplaceAll Method Introduced in Inventor 5.3

iFeatureTemplateDescriptor Properties

iFeatureTemplateDescriptor.Application Property Introduced in Inventor 5.3

iFeatureTemplateDescriptor.InternalName Property Introduced in Inventor 5.3

iFeatureTemplateDescriptor.LastKnownSourceFileName Property Introduced in Inventor 5.3

iFeatureTemplateDescriptor.Parent Property Introduced in Inventor 5.3

iFeatureTemplateDescriptor.Type Property Introduced in Inventor 5.3

iFeatureTemplateDescriptors Interface Introduced in Inventor 5.3

iFeatureTemplateDescriptors Methods

iFeatureTemplateDescriptors.Item Method Introduced in Inventor 5.3

iFeatureTemplateDescriptors Properties

iFeatureTemplateDescriptors.Application Property Introduced in Inventor 5.3

iFeatureTemplateDescriptors.Count Property Introduced in Inventor 5.3

iFeatureTemplateDescriptors.Type Property Introduced in Inventor 5.3

iFeatureVectorInput Interface Introduced in Inventor 6

iFeatureVectorInput Properties

iFeatureVectorInput.FlipOption Property Introduced in Inventor 6

iFeatureVectorInput.LineInput Property Introduced in Inventor 6

iFeatureWorkPlaneInput Interface Introduced in Inventor 6

iFeatureWorkPlaneInput Properties

iFeatureWorkPlaneInput.FlipOption Property Introduced in Inventor 6

iFeatureWorkPlaneInput.PlaneInput Property Introduced in Inventor 6

iMateDefinition Interface Introduced in Inventor 6

iMateDefinition Methods

iMateDefinition.Delete Method Introduced in Inventor 11

iMateDefinition.GetReferenceKey Method Introduced in Inventor 7

iMateDefinition Properties

iMateDefinition.Application Property Introduced in Inventor 6

iMateDefinition.AttributeSets Property Introduced in Inventor 11

iMateDefinition.Exported Property

iMateDefinition.HasReferenceComponent Property Introduced in Inventor 2009

iMateDefinition.Identifier Property Introduced in Inventor 6

iMateDefinition.MatchList Property Introduced in Inventor 11

iMateDefinition.Name Property Introduced in Inventor 6

iMateDefinition.ReferenceComponent Property Introduced in Inventor 2009

iMateDefinition.ReferencedEntity Property Introduced in Inventor 2009

iMateDefinition.SequenceIndex Property Introduced in Inventor 6

iMateDefinition.Suppressed Property Introduced in Inventor 6

iMateDefinition.Type Property Introduced in Inventor 6

iMateDefinitions Interface Introduced in Inventor 6

iMateDefinitions Methods

iMateDefinitions.AddAngleiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddCompositeiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddFlushiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddInsertiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddMateiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddRotateRotateiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddRotateTranslateiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.AddTangentiMateDefinition Method Introduced in Inventor 11

iMateDefinitions.Item Method Introduced in Inventor 6

iMateDefinitions Properties

iMateDefinitions.Application Property Introduced in Inventor 6

iMateDefinitions.Count Property Introduced in Inventor 6

iMateDefinitions.Type Property Introduced in Inventor 6

iMateDefinitionsEnumerator Interface Introduced in Inventor 6

iMateDefinitionsEnumerator Methods

iMateDefinitionsEnumerator.Item Method Introduced in Inventor 6

iMateDefinitionsEnumerator Properties

iMateDefinitionsEnumerator.Count Property Introduced in Inventor 6

iMateDefinitionsEnumerator.Type Property Introduced in Inventor 6

iMateResult Interface Introduced in Inventor 6

iMateResult Methods

iMateResult.Delete Method Introduced in Inventor 11

iMateResult.GetInputs Method Introduced in Inventor 6

iMateResult.GetReferenceKey Method Introduced in Inventor 11

iMateResult.SetInputs Method Introduced in Inventor 2011

iMateResult Properties

iMateResult.AttributeSets Property Introduced in Inventor 11

iMateResult.Constraints Property Introduced in Inventor 6

iMateResult.IsComposite Property Introduced in Inventor 6

iMateResult.Name Property Introduced in Inventor 11

iMateResult.ParentComposite Property Introduced in Inventor 6

iMateResult.Results Property Introduced in Inventor 6

iMateResult.Suppressed Property Introduced in Inventor 11

iMateResult.Type Property Introduced in Inventor 6

iMateResultProxy Interface Introduced in Inventor 11

iMateResultProxy Properties

iMateResultProxy.ContainingOccurrence Property Introduced in Inventor 11

iMateResultProxy.NativeObject Property Introduced in Inventor 11

iMateResults Interface Introduced in Inventor 6

iMateResults Methods

iMateResults.AddByiMateAndEntity Method Introduced in Inventor 6

iMateResults.AddByTwoiMates Method Introduced in Inventor 6

iMateResults.Item Method Introduced in Inventor 6

iMateResults Properties

iMateResults.Application Property Introduced in Inventor 6

iMateResults.Count Property Introduced in Inventor 6

iMateResults.Type Property Introduced in Inventor 6

iMateResultsEnumerator Interface Introduced in Inventor 6

iMateResultsEnumerator Methods

iMateResultsEnumerator.Item Method Introduced in Inventor 6

iMateResultsEnumerator Properties

iMateResultsEnumerator.Count Property Introduced in Inventor 6

iMateResultsEnumerator.Type Property Introduced in Inventor 6

InsertConstraint Interface Introduced in Inventor 4

InsertConstraint Properties

InsertConstraint.AxesOpposed Property Introduced in Inventor 4

InsertConstraint.ConstraintLimits Property Introduced in Inventor 2011

InsertConstraint.Distance Property Introduced in Inventor 5

InsertConstraintProxy Interface Introduced in Inventor 11

InsertConstraintProxy Properties

InsertConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

InsertConstraintProxy.NativeObject Property Introduced in Inventor 11

InsertiMateDefinition Interface Introduced in Inventor 6

InsertiMateDefinition Properties

InsertiMateDefinition.AxesOpposed Property Introduced in Inventor 6

InsertiMateDefinition.ConstraintLimits Property Introduced in Inventor 2011

InsertiMateDefinition.Distance Property Introduced in Inventor 6

InsertiMateDefinition.Entity Property Introduced in Inventor 6

InsertiMateDefinitionProxy Interface Introduced in Inventor 6

InsertiMateDefinitionProxy Properties

InsertiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

InsertiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

InsertiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

InteractionEvents CoClass Introduced in Inventor 5

InteractionEventsObject Interface Introduced in Inventor 5

InteractionEventsObject Methods

InteractionEventsObject.CreateMiniToolbar Method Introduced in Inventor 2012

InteractionEventsObject.GetCursor Method Introduced in Inventor 9

InteractionEventsObject.SetCursor Method Introduced in Inventor 9

InteractionEventsObject.Start Method Introduced in Inventor 5

InteractionEventsObject.Stop Method Introduced in Inventor 5

InteractionEventsObject Properties

InteractionEventsObject.AllowCommandAliases Property Introduced in Inventor 2008

InteractionEventsObject.Application Property Introduced in Inventor 5

InteractionEventsObject.InteractionDisabled Property Introduced in Inventor 5

InteractionEventsObject.InteractionGraphics Property Introduced in Inventor 8

InteractionEventsObject.KeyboardEvents Property Introduced in Inventor 5

InteractionEventsObject.MeasureEvents Property Introduced in Inventor 2009

InteractionEventsObject.MouseEvents Property Introduced in Inventor 5

InteractionEventsObject.Name Property Introduced in Inventor 10

InteractionEventsObject.Parent Property Introduced in Inventor 5

InteractionEventsObject.SelectEvents Property Introduced in Inventor 5

InteractionEventsObject.StatusBarText Property Introduced in Inventor 6

InteractionEventsObject.TargetDocument Property Introduced in Inventor 5

InteractionEventsObject.TriadEvents Property Introduced in Inventor 9

InteractionEventsObject.Type Property Introduced in Inventor 5

InteractionEventsSink Interface Introduced in Inventor 5

InteractionEventsSink Methods

InteractionEventsSink.OnActivate Method Introduced in Inventor 5

InteractionEventsSink.OnHelp Method Introduced in Inventor 7

InteractionEventsSink.OnResume Method Introduced in Inventor 5

InteractionEventsSink.OnSuspend Method Introduced in Inventor 5

InteractionEventsSink.OnTerminate Method Introduced in Inventor 5

InteractionGraphics Interface Introduced in Inventor 8

InteractionGraphics Methods

InteractionGraphics.UpdateOverlayGraphics Method Introduced in Inventor 8

InteractionGraphics Properties

InteractionGraphics.GraphicsDataSets Property Introduced in Inventor 8

InteractionGraphics.OverlayClientGraphics Property Introduced in Inventor 8

InteractionGraphics.PreviewClientGraphics Property Introduced in Inventor 8

InteractionGraphics.Type Property Introduced in Inventor 8

InterferenceResult Interface Introduced in Inventor 6

InterferenceResult Properties

InterferenceResult.Centroid Property Introduced in Inventor 6

InterferenceResult.InterferenceBody Property

InterferenceResult.OccurrenceOne Property Introduced in Inventor 6

InterferenceResult.OccurrenceTwo Property Introduced in Inventor 6

InterferenceResult.Type Property Introduced in Inventor 6

InterferenceResult.Volume Property Introduced in Inventor 6

InterferenceResults Interface Introduced in Inventor 6

InterferenceResults Methods

InterferenceResults.Item Method Introduced in Inventor 6

InterferenceResults Properties

InterferenceResults.Count Property Introduced in Inventor 6

InterferenceResults.Type Property Introduced in Inventor 6

InventorServer CoClass

InventorVBAArgument Interface Introduced in Inventor 6

InventorVBAArgument Properties

InventorVBAArgument.ArgumentType Property Introduced in Inventor 6

InventorVBAArgument.Name Property Introduced in Inventor 6

InventorVBAArgument.Parent Property Introduced in Inventor 6

InventorVBAArgument.Type Property Introduced in Inventor 6

InventorVBAArgument.Value Property Introduced in Inventor 6

InventorVBAArguments Interface Introduced in Inventor 6

InventorVBAArguments Methods

InventorVBAArguments.Item Method Introduced in Inventor 6

InventorVBAArguments Properties

InventorVBAArguments.Count Property Introduced in Inventor 6

InventorVBAArguments.Parent Property Introduced in Inventor 6

InventorVBAArguments.Type Property Introduced in Inventor 6

InventorVBAComponent Interface Introduced in Inventor 6

InventorVBAComponent Properties

InventorVBAComponent.InventorVBAMembers Property Introduced in Inventor 6

InventorVBAComponent.Name Property Introduced in Inventor 6

InventorVBAComponent.Parent Property Introduced in Inventor 6

InventorVBAComponent.Type Property Introduced in Inventor 6

InventorVBAComponent.VBComponent Property Introduced in Inventor 6

InventorVBAComponents Interface Introduced in Inventor 6

InventorVBAComponents Methods

InventorVBAComponents.Add Method Introduced in Inventor 6

InventorVBAComponents.Item Method Introduced in Inventor 6

InventorVBAComponents Properties

InventorVBAComponents.Count Property Introduced in Inventor 6

InventorVBAComponents.Parent Property Introduced in Inventor 6

InventorVBAComponents.Type Property Introduced in Inventor 6

InventorVBAMember Interface Introduced in Inventor 6

InventorVBAMember Methods

InventorVBAMember.Execute Method Introduced in Inventor 6

InventorVBAMember Properties

InventorVBAMember.Arguments Property Introduced in Inventor 6

InventorVBAMember.MemberType Property Introduced in Inventor 6

InventorVBAMember.Name Property Introduced in Inventor 6

InventorVBAMember.Parent Property Introduced in Inventor 6

InventorVBAMember.Type Property Introduced in Inventor 6

InventorVBAMember.VBMember Property Introduced in Inventor 6

InventorVBAMembers Interface Introduced in Inventor 6

InventorVBAMembers Methods

InventorVBAMembers.Item Method Introduced in Inventor 6

InventorVBAMembers Properties

InventorVBAMembers.Count Property Introduced in Inventor 6

InventorVBAMembers.Parent Property Introduced in Inventor 6

InventorVBAMembers.Type Property Introduced in Inventor 6

InventorVBAProject Interface Introduced in Inventor 6

InventorVBAProject Methods

InventorVBAProject.Close Method Introduced in Inventor 6

InventorVBAProject.Save Method Introduced in Inventor 6

InventorVBAProject.SaveAs Method Introduced in Inventor 6

InventorVBAProject Properties

InventorVBAProject.InventorVBAComponents Property Introduced in Inventor 6

InventorVBAProject.Name Property Introduced in Inventor 6

InventorVBAProject.Parent Property Introduced in Inventor 6

InventorVBAProject.ProjectType Property Introduced in Inventor 6

InventorVBAProject.Saved Property Introduced in Inventor 6

InventorVBAProject.Type Property Introduced in Inventor 6

InventorVBAProject.VBProject Property Introduced in Inventor 6

InventorVBAProjects Interface Introduced in Inventor 6

InventorVBAProjects Methods

InventorVBAProjects.Add Method Introduced in Inventor 6

InventorVBAProjects.Item Method Introduced in Inventor 6

InventorVBAProjects.Open Method Introduced in Inventor 6

InventorVBAProjects Properties

InventorVBAProjects.Count Property Introduced in Inventor 6

InventorVBAProjects.Parent Property Introduced in Inventor 6

InventorVBAProjects.Type Property Introduced in Inventor 6

iPartFactory Interface Introduced in Inventor 6

iPartFactory Methods

iPartFactory.CreateCustomMember Method Introduced in Inventor 6

iPartFactory.CreateMember Method Introduced in Inventor 6

iPartFactory.Delete Method Introduced in Inventor 6

iPartFactory Properties

iPartFactory.Application Property Introduced in Inventor 11

iPartFactory.CustomFactory Property Introduced in Inventor 6

iPartFactory.DefaultRow Property Introduced in Inventor 6

iPartFactory.DisplayStyleColumn Property

iPartFactory.ExcelWorkSheet Property Introduced in Inventor 6

iPartFactory.FactoryOptions Property Introduced in Inventor 2010

iPartFactory.FileNameColumn Property

iPartFactory.MaterialColumn Property

iPartFactory.MemberCacheDir Property Introduced in Inventor 6

iPartFactory.MemberEditScope Property Introduced in Inventor 11

iPartFactory.Parent Property Introduced in Inventor 6

iPartFactory.TableColumns Property Introduced in Inventor 6

iPartFactory.TableRows Property Introduced in Inventor 6

iPartFactory.Type Property Introduced in Inventor 6

iPartMember Interface Introduced in Inventor 6

iPartMember Methods

iPartMember.BreakLinkToFactory Method Introduced in Inventor 11

iPartMember.ChangeRow Method Introduced in Inventor 6

iPartMember Properties

iPartMember.CustomMember Property Introduced in Inventor 6

iPartMember.ParentFactory Property Introduced in Inventor 6

iPartMember.PrimaryBody Property Introduced in Inventor 6

iPartMember.Row Property Introduced in Inventor 6

iPartTableCell Interface Introduced in Inventor 6

iPartTableCell Properties

iPartTableCell.Application Property Introduced in Inventor 6

iPartTableCell.Column Property Introduced in Inventor 6

iPartTableCell.CustomCell Property

iPartTableCell.CustomIncrement Property

iPartTableCell.CustomRangeMaximum Property

iPartTableCell.CustomRangeMinimum Property

iPartTableCell.HasFormula Property Introduced in Inventor 2010

iPartTableCell.IsValid Property Introduced in Inventor 2010

iPartTableCell.Parent Property Introduced in Inventor 6

iPartTableCell.Row Property Introduced in Inventor 6

iPartTableCell.Type Property Introduced in Inventor 6

iPartTableCell.Value Property Introduced in Inventor 6

iPartTableColumn Interface Introduced in Inventor 6

iPartTableColumn Methods

iPartTableColumn.Delete Method

iPartTableColumn.Item Method Introduced in Inventor 6

iPartTableColumn Properties

iPartTableColumn.Application Property Introduced in Inventor 6

iPartTableColumn.Count Property Introduced in Inventor 6

iPartTableColumn.CustomColumn Property

iPartTableColumn.CustomIncrement Property

iPartTableColumn.CustomRangeMaximum Property

iPartTableColumn.CustomRangeMinimum Property

iPartTableColumn.DisplayHeading Property Introduced in Inventor 10

iPartTableColumn.FormattedHeading Property Introduced in Inventor 6

iPartTableColumn.Heading Property Introduced in Inventor 6

iPartTableColumn.Index Property Introduced in Inventor 2010

iPartTableColumn.Key Property

iPartTableColumn.Parent Property Introduced in Inventor 6

iPartTableColumn.ReferencedDataType Property

iPartTableColumn.ReferencedObject Property

iPartTableColumn.Type Property Introduced in Inventor 6

iPartTableColumns Interface Introduced in Inventor 6

iPartTableColumns Methods

iPartTableColumns.Item Method Introduced in Inventor 6

iPartTableColumns Properties

iPartTableColumns.Application Property Introduced in Inventor 6

iPartTableColumns.Count Property Introduced in Inventor 6

iPartTableColumns.Type Property Introduced in Inventor 6

iPartTableRow Interface Introduced in Inventor 6

iPartTableRow Methods

iPartTableRow.Copy Method Introduced in Inventor 2008

iPartTableRow.Delete Method Introduced in Inventor 11

iPartTableRow.GetReferenceKey Method Introduced in Inventor 2009

iPartTableRow.Item Method Introduced in Inventor 6

iPartTableRow.PartIdentifier Method

iPartTableRow Properties

iPartTableRow.Application Property Introduced in Inventor 6

iPartTableRow.AttributeSets Property Introduced in Inventor 2009

iPartTableRow.Count Property Introduced in Inventor 6

iPartTableRow.Index Property Introduced in Inventor 2010

iPartTableRow.IsPartNameBasedOnMemberName Property Introduced in Inventor 11

iPartTableRow.MemberName Property Introduced in Inventor 11

iPartTableRow.Parent Property Introduced in Inventor 6

iPartTableRow.PartName Property Introduced in Inventor 6

iPartTableRow.PartNameModifiable Property Introduced in Inventor 11

iPartTableRow.Type Property Introduced in Inventor 6

iPartTableRows Interface Introduced in Inventor 6

iPartTableRows Methods

iPartTableRows.Item Method Introduced in Inventor 6

iPartTableRows Properties

iPartTableRows.Application Property Introduced in Inventor 6

iPartTableRows.Count Property Introduced in Inventor 6

iPartTableRows.Type Property Introduced in Inventor 6

KeyboardEvents CoClass Introduced in Inventor 5

KeyboardEventsObject Interface Introduced in Inventor 5

KeyboardEventsObject Properties

KeyboardEventsObject.Application Property Introduced in Inventor 5

KeyboardEventsObject.Parent Property Introduced in Inventor 5

KeyboardEventsObject.Type Property Introduced in Inventor 5

KeyboardEventsSink Interface Introduced in Inventor 5

KeyboardEventsSink Methods

KeyboardEventsSink.OnKeyDown Method Introduced in Inventor 5

KeyboardEventsSink.OnKeyPress Method Introduced in Inventor 5

KeyboardEventsSink.OnKeyUp Method Introduced in Inventor 5

KnitFeature Interface Introduced in Inventor 6

KnitFeature Properties

KnitFeature.MaintainAsSurface Property Introduced in Inventor 2010

KnitFeature.MaximumTolerance Property Introduced in Inventor 2010

KnitFeature.Surfaces Property Introduced in Inventor 2008

KnitFeatureProxy Interface Introduced in Inventor 9

KnitFeatureProxy Properties

KnitFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

KnitFeatureProxy.NativeObject Property Introduced in Inventor 9

KnitFeatures Interface Introduced in Inventor 6

KnitFeatures Methods

KnitFeatures.Add Method Introduced in Inventor 2008

KnitFeatures.Item Method Introduced in Inventor 6

KnitFeatures Properties

KnitFeatures.Application Property Introduced in Inventor 6

KnitFeatures.Count Property Introduced in Inventor 6

KnitFeatures.Type Property Introduced in Inventor 6

LanguageTools Interface Introduced in Inventor 2008

LanguageTools Methods

LanguageTools.GetiComponentStringValue Method Introduced in Inventor 2008

LanguageTools Properties

LanguageTools.Application Property Introduced in Inventor 2008

LanguageTools.Parent Property Introduced in Inventor 2008

LanguageTools.Type Property Introduced in Inventor 2008

Layer Interface Introduced in Inventor 10

Layer Methods

Layer.GetCustomLineType Method Introduced in Inventor 2008

Layer.SetCustomLineType Method Introduced in Inventor 2008

Layer Properties

Layer.AutomaticColor Property Introduced in Inventor 2008

Layer.Color Property Introduced in Inventor 10

Layer.LineType Property Introduced in Inventor 10

Layer.LineWeight Property Introduced in Inventor 10

Layer.Plot Property Introduced in Inventor 2008

Layer.ScaleByLineWeight Property Introduced in Inventor 10

Layer.Visible Property Introduced in Inventor 10

LayersEnumerator Interface Introduced in Inventor 10

LayersEnumerator Methods

LayersEnumerator.Item Method Introduced in Inventor 10

LayersEnumerator Properties

LayersEnumerator.Application Property Introduced in Inventor 10

LayersEnumerator.Count Property Introduced in Inventor 10

LayersEnumerator.Type Property Introduced in Inventor 10

LayoutConstraint Interface Introduced in Inventor 2010

LayoutConstraint Methods

LayoutConstraint.Delete Method Introduced in Inventor 2010

LayoutConstraint.GetReferenceKey Method Introduced in Inventor 2010

LayoutConstraint Properties

LayoutConstraint.Application Property Introduced in Inventor 2010

LayoutConstraint.AttributeSets Property Introduced in Inventor 2010

LayoutConstraint.HealthStatus Property Introduced in Inventor 2010

LayoutConstraint.Name Property Introduced in Inventor 2010

LayoutConstraint.Parent Property Introduced in Inventor 2010

LayoutConstraint.Type Property Introduced in Inventor 2010

LayoutConstraint.XYFlushConstraint Property Introduced in Inventor 2010

LayoutConstraint.XZFlushConstraint Property Introduced in Inventor 2010

LayoutConstraint.YZFlushConstraint Property Introduced in Inventor 2010

LayoutConstraint.ZAngleConstraint Property Introduced in Inventor 2010

LayoutConstraintProxy Interface Introduced in Inventor 2010

LayoutConstraintProxy Properties

LayoutConstraintProxy.ContainingOccurrence Property Introduced in Inventor 2010

LayoutConstraintProxy.NativeObject Property Introduced in Inventor 2010

Leader Interface Introduced in Inventor 11

Leader Methods

Leader.AddLeader Method Introduced in Inventor 11

Leader.GetReferenceKey Method Introduced in Inventor 11

Leader Properties

Leader.AllLeafNodes Property Introduced in Inventor 11

Leader.AllNodes Property Introduced in Inventor 11

Leader.Application Property Introduced in Inventor 11

Leader.ArrowheadType Property Introduced in Inventor 2008

Leader.AttributeSets Property Introduced in Inventor 11

Leader.HasRootNode Property Introduced in Inventor 11

Leader.Parent Property Introduced in Inventor 11

Leader.RootNode Property Introduced in Inventor 11

Leader.Type Property Introduced in Inventor 11

LeaderNode Interface Introduced in Inventor 11

LeaderNode Methods

LeaderNode.AddLeader Method Introduced in Inventor 11

LeaderNode.Delete Method Introduced in Inventor 11

LeaderNode.GetReferenceKey Method Introduced in Inventor 11

LeaderNode.InsertNode Method Introduced in Inventor 11

LeaderNode Properties

LeaderNode.Application Property Introduced in Inventor 11

LeaderNode.AttachedEntity Property Introduced in Inventor 11

LeaderNode.AttributeSets Property Introduced in Inventor 11

LeaderNode.ChildNodes Property Introduced in Inventor 11

LeaderNode.Parent Property Introduced in Inventor 11

LeaderNode.Position Property Introduced in Inventor 11

LeaderNode.Type Property Introduced in Inventor 11

LeaderNodesEnumerator Interface Introduced in Inventor 11

LeaderNodesEnumerator Methods

LeaderNodesEnumerator.Item Method Introduced in Inventor 11

LeaderNodesEnumerator Properties

LeaderNodesEnumerator.Application Property Introduced in Inventor 11

LeaderNodesEnumerator.Count Property Introduced in Inventor 11

LeaderNodesEnumerator.Type Property Introduced in Inventor 11

LeaderNote Interface Introduced in Inventor 10

LeaderNote Properties

LeaderNote.DimensionStyle Property Introduced in Inventor 10

LeaderNote.Leader Property Introduced in Inventor 11

LeaderNotes Interface Introduced in Inventor 10

LeaderNotes Methods

LeaderNotes.Add Method Introduced in Inventor 11

LeaderNotes.Item Method Introduced in Inventor 10

LeaderNotes Properties

LeaderNotes.Application Property Introduced in Inventor 10

LeaderNotes.Count Property Introduced in Inventor 10

LeaderNotes.Type Property Introduced in Inventor 10

LeaderStyle Interface Introduced in Inventor 2009

LeaderStyle Methods

LeaderStyle.GetCustomLineType Method Introduced in Inventor 2009

LeaderStyle.SetCustomLineType Method Introduced in Inventor 2009

LeaderStyle Properties

LeaderStyle.AllAroundSymbolDiameter Property Introduced in Inventor 2009

LeaderStyle.ArrowheadHeight Property Introduced in Inventor 2009

LeaderStyle.ArrowheadSize Property Introduced in Inventor 2009

LeaderStyle.ArrowheadType Property Introduced in Inventor 2009

LeaderStyle.Color Property Introduced in Inventor 2010

LeaderStyle.ExtensionLineOffset Property Introduced in Inventor 2009

LeaderStyle.ExtensionLineOvershoot Property Introduced in Inventor 2009

LeaderStyle.LineType Property Introduced in Inventor 2009

LeaderStyle.LineWeight Property Introduced in Inventor 2009

LeaderStyle.ScaleToTextHeight Property Introduced in Inventor 2009

LeaderStylesEnumerator Interface Introduced in Inventor 2009

LeaderStylesEnumerator Methods

LeaderStylesEnumerator.Item Method Introduced in Inventor 2009

LeaderStylesEnumerator Properties

LeaderStylesEnumerator.Application Property Introduced in Inventor 2009

LeaderStylesEnumerator.Count Property Introduced in Inventor 2009

LeaderStylesEnumerator.Type Property Introduced in Inventor 2009

LegacyDistanceHeightExtent Interface Introduced in Inventor 2009

LegacyDistanceHeightExtent Properties

LegacyDistanceHeightExtent.Distance Property Introduced in Inventor 2009

LegacyDistanceHeightExtent.FlangeDirection Property Introduced in Inventor 2009

LevelOfDetailRepresentation Interface Introduced in Inventor 11

LevelOfDetailRepresentation Methods

LevelOfDetailRepresentation.Activate Method Introduced in Inventor 11

LevelOfDetailRepresentation.Copy Method Introduced in Inventor 11

LevelOfDetailRepresentation.Delete Method Introduced in Inventor 11

LevelOfDetailRepresentation.GetReferenceKey Method Introduced in Inventor 11

LevelOfDetailRepresentation Properties

LevelOfDetailRepresentation.Application Property Introduced in Inventor 11

LevelOfDetailRepresentation.AttributeSets Property Introduced in Inventor 11

LevelOfDetailRepresentation.LevelOfDetail Property Introduced in Inventor 11

LevelOfDetailRepresentation.Name Property Introduced in Inventor 11

LevelOfDetailRepresentation.Parent Property Introduced in Inventor 11

LevelOfDetailRepresentation.SubstituteDocumentDescriptor Property Introduced in Inventor 2009

LevelOfDetailRepresentation.SubstituteOccurrence Property Introduced in Inventor 2009

LevelOfDetailRepresentation.Type Property Introduced in Inventor 11

LevelOfDetailRepresentations Interface Introduced in Inventor 11

LevelOfDetailRepresentations Methods

LevelOfDetailRepresentations.Add Method Introduced in Inventor 11

LevelOfDetailRepresentations.AddSubstitute Method Introduced in Inventor 2009

LevelOfDetailRepresentations.Item Method Introduced in Inventor 11

LevelOfDetailRepresentations Properties

LevelOfDetailRepresentations.Application Property Introduced in Inventor 11

LevelOfDetailRepresentations.Count Property Introduced in Inventor 11

LevelOfDetailRepresentations.Type Property Introduced in Inventor 11

Light Interface Introduced in Inventor 10

Light Properties

Light.Application Property Introduced in Inventor 10

Light.Color Property Introduced in Inventor 10

Light.ConstantAttenuation Property Introduced in Inventor 10

Light.Direction Property Introduced in Inventor 10

Light.Intensity Property Introduced in Inventor 10

Light.LightDefinitionType Property Introduced in Inventor 10

Light.LightType Property Introduced in Inventor 10

Light.LinearAttenuation Property Introduced in Inventor 10

Light.On Property Introduced in Inventor 10

Light.Parent Property Introduced in Inventor 10

Light.Position Property Introduced in Inventor 10

Light.QuadraticAttenuation Property Introduced in Inventor 10

Light.SpotLightCutoffAngle Property Introduced in Inventor 10

Light.SpotLightFalloff Property Introduced in Inventor 10

Light.SpotLightInnerAngle Property Introduced in Inventor 10

Light.Type Property Introduced in Inventor 10

LightingStyle Interface Introduced in Inventor 10

LightingStyle Methods

LightingStyle.ConvertToLocal Method Introduced in Inventor 10

LightingStyle.Copy Method Introduced in Inventor 10

LightingStyle.Delete Method Introduced in Inventor 10

LightingStyle.GetReferenceKey Method

LightingStyle.SaveToGlobal Method Introduced in Inventor 10

LightingStyle.UpdateFromGlobal Method Introduced in Inventor 10

LightingStyle Properties

LightingStyle.Ambience Property Introduced in Inventor 10

LightingStyle.AmbientShadowIntensity Property

LightingStyle.Application Property Introduced in Inventor 10

LightingStyle.AttributeSets Property

LightingStyle.Brightness Property Introduced in Inventor 10

LightingStyle.ImageBasedLightingBrightness Property

LightingStyle.ImageBasedLightingRotation Property

LightingStyle.ImageBasedLightingScale Property

LightingStyle.ImageBasedLightingShowImage Property

LightingStyle.ImageBasedLightingSourceInternalName Property

LightingStyle.ImageBasedLightingSourceName Property

LightingStyle.InternalName Property Introduced in Inventor 10

LightingStyle.InUse Property Introduced in Inventor 10

LightingStyle.Lights Property Introduced in Inventor 10

LightingStyle.Name Property Introduced in Inventor 10

LightingStyle.Parent Property Introduced in Inventor 10

LightingStyle.ShadowDensity Property

LightingStyle.ShadowDirection Property

LightingStyle.ShadowSoftness Property

LightingStyle.StyleLocation Property Introduced in Inventor 10

LightingStyle.Type Property Introduced in Inventor 10

LightingStyle.UpToDate Property Introduced in Inventor 10

LightingStyles Interface Introduced in Inventor 10

LightingStyles Methods

LightingStyles.Add Method Introduced in Inventor 10

LightingStyles.Item Method Introduced in Inventor 10

LightingStyles Properties

LightingStyles.Application Property Introduced in Inventor 10

LightingStyles.Count Property Introduced in Inventor 10

LightingStyles.Parent Property Introduced in Inventor 10

LightingStyles.Type Property Introduced in Inventor 10

Lights Interface Introduced in Inventor 10

Lights Methods

Lights.Add Method Introduced in Inventor 10

Lights.Item Method Introduced in Inventor 10

Lights Properties

Lights.Application Property Introduced in Inventor 10

Lights.Count Property Introduced in Inventor 10

Lights.Parent Property Introduced in Inventor 10

Lights.Type Property Introduced in Inventor 10

Line Interface Introduced in Inventor 4

Line Methods

Line.DistanceTo Method Introduced in Inventor 11

Line.GetLineData Method Introduced in Inventor 4

Line.IntersectWithCurve Method Introduced in Inventor 2008

Line.IntersectWithSurface Method Introduced in Inventor 2008

Line.IsColinearTo Method Introduced in Inventor 9

Line.PutLineData Method Introduced in Inventor 4

Line Properties

Line.Direction Property Introduced in Inventor 4

Line.Evaluator Property Introduced in Inventor 4

Line.RootPoint Property Introduced in Inventor 4

Line2d Interface Introduced in Inventor 4

Line2d Methods

Line2d.DistanceTo Method Introduced in Inventor 11

Line2d.GetLineData Method Introduced in Inventor 4

Line2d.IntersectWithCurve Method Introduced in Inventor 2008

Line2d.PutLineData Method Introduced in Inventor 4

Line2d Properties

Line2d.Direction Property Introduced in Inventor 4

Line2d.Evaluator Property Introduced in Inventor 4

Line2d.RootPoint Property Introduced in Inventor 4

LineAndPlaneWorkAxisDef Interface Introduced in Inventor 4

LineAndPlaneWorkAxisDef Methods

LineAndPlaneWorkAxisDef.GetData Method Introduced in Inventor 4

LineAndPlaneWorkAxisDef Properties

LineAndPlaneWorkAxisDef.Application Property Introduced in Inventor 4

LineAndPlaneWorkAxisDef.Line Property Introduced in Inventor 4

LineAndPlaneWorkAxisDef.Parent Property Introduced in Inventor 4

LineAndPlaneWorkAxisDef.Plane Property Introduced in Inventor 4

LineAndPlaneWorkAxisDef.Type Property Introduced in Inventor 4

LineAndPointWorkAxisDef Interface Introduced in Inventor 11

LineAndPointWorkAxisDef Methods

LineAndPointWorkAxisDef.GetData Method Introduced in Inventor 11

LineAndPointWorkAxisDef Properties

LineAndPointWorkAxisDef.Application Property Introduced in Inventor 11

LineAndPointWorkAxisDef.Line Property Introduced in Inventor 11

LineAndPointWorkAxisDef.Parent Property Introduced in Inventor 11

LineAndPointWorkAxisDef.Point Property Introduced in Inventor 11

LineAndPointWorkAxisDef.Type Property Introduced in Inventor 11

LineAndTangentWorkPlaneDef Interface Introduced in Inventor 4

LineAndTangentWorkPlaneDef Methods

LineAndTangentWorkPlaneDef.GetData Method Introduced in Inventor 4

LineAndTangentWorkPlaneDef Properties

LineAndTangentWorkPlaneDef.Application Property Introduced in Inventor 4

LineAndTangentWorkPlaneDef.Face Property Introduced in Inventor 4

LineAndTangentWorkPlaneDef.Line Property Introduced in Inventor 4

LineAndTangentWorkPlaneDef.Parent Property Introduced in Inventor 4

LineAndTangentWorkPlaneDef.ProximityPoint Property Introduced in Inventor 4

LineAndTangentWorkPlaneDef.Type Property Introduced in Inventor 4

LinearGeneralDimension Interface Introduced in Inventor 11

LinearGeneralDimension Methods

LinearGeneralDimension.CenterText Method Introduced in Inventor 2008

LinearGeneralDimension Properties

LinearGeneralDimension.BaselineDimensionSet Property Introduced in Inventor 2010

LinearGeneralDimension.ChainDimensionSet Property Introduced in Inventor 2011

LinearGeneralDimension.DimensionType Property Introduced in Inventor 11

LinearGeneralDimension.ExtensionLineOne Property Introduced in Inventor 2008

LinearGeneralDimension.ExtensionLineOneVisible Property Introduced in Inventor 2011

LinearGeneralDimension.ExtensionLineTwo Property Introduced in Inventor 2008

LinearGeneralDimension.ExtensionLineTwoVisible Property Introduced in Inventor 2011

LinearGeneralDimension.FullDimensionLine Property Introduced in Inventor 2011

LinearGeneralDimension.IntentOne Property Introduced in Inventor 11

LinearGeneralDimension.IntentTwo Property Introduced in Inventor 11

LinearGeneralDimension.IsBaselineSetMember Property Introduced in Inventor 2010

LinearGeneralDimension.IsChainSetMember Property Introduced in Inventor 2011

LinearGeneralDimension.ShowLeader Property Introduced in Inventor 11

LinearHolePlacementDefinition Interface Introduced in Inventor 10

LinearHolePlacementDefinition Properties

LinearHolePlacementDefinition.DirectionOneReversed Property Introduced in Inventor 10

LinearHolePlacementDefinition.DirectionTwoReversed Property Introduced in Inventor 10

LinearHolePlacementDefinition.DistanceOne Property Introduced in Inventor 10

LinearHolePlacementDefinition.DistanceTwo Property Introduced in Inventor 10

LinearHolePlacementDefinition.Plane Property Introduced in Inventor 10

LinearHolePlacementDefinition.ReferenceEntityOne Property Introduced in Inventor 10

LinearHolePlacementDefinition.ReferenceEntityTwo Property Introduced in Inventor 10

LineGraphics Interface Introduced in Inventor 5

LineGraphics Methods

LineGraphics.GetCustomLineType Method Introduced in Inventor 2008

LineGraphics.GetTransformBehavior Method Introduced in Inventor 5

LineGraphics.SetCustomLineType Method Introduced in Inventor 2008

LineGraphics.SetTransformBehavior Method Introduced in Inventor 5

LineGraphics Properties

LineGraphics.BurnThrough Property Introduced in Inventor 5

LineGraphics.ColorBinding Property Introduced in Inventor 5

LineGraphics.ColorIndexSet Property Introduced in Inventor 5

LineGraphics.ColorSet Property Introduced in Inventor 5

LineGraphics.CoordinateIndexSet Property Introduced in Inventor 5

LineGraphics.CoordinateSet Property Introduced in Inventor 5

LineGraphics.DepthPriority Property Introduced in Inventor 5

LineGraphics.LineDefinitionSpace Property Introduced in Inventor 2008

LineGraphics.LineScale Property Introduced in Inventor 2008

LineGraphics.LineType Property Introduced in Inventor 2008

LineGraphics.LineWeight Property Introduced in Inventor 2008

LineLengthDimConstraint3D Interface Introduced in Inventor 11

LineLengthDimConstraint3D Properties

LineLengthDimConstraint3D.Line Property Introduced in Inventor 11

LineLengthDimConstraint3DProxy Interface Introduced in Inventor 11

LineLengthDimConstraint3DProxy Properties

LineLengthDimConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 11

LineLengthDimConstraint3DProxy.NativeObject Property Introduced in Inventor 11

LinePlaneAndAngleWorkPlaneDef Interface Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef Methods

LinePlaneAndAngleWorkPlaneDef.GetData Method Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef Properties

LinePlaneAndAngleWorkPlaneDef.Angle Property Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef.Application Property Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef.Line Property Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef.Parent Property Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef.Plane Property Introduced in Inventor 4

LinePlaneAndAngleWorkPlaneDef.Type Property Introduced in Inventor 4

LineSegment Interface Introduced in Inventor 6

LineSegment Methods

LineSegment.DistanceTo Method Introduced in Inventor 11

LineSegment.GetLineSegmentData Method Introduced in Inventor 6

LineSegment.IntersectWithCurve Method Introduced in Inventor 2008

LineSegment.IntersectWithSurface Method Introduced in Inventor 2008

LineSegment.PutLineSegmentData Method Introduced in Inventor 6

LineSegment Properties

LineSegment.Direction Property Introduced in Inventor 6

LineSegment.EndPoint Property Introduced in Inventor 6

LineSegment.Evaluator Property Introduced in Inventor 6

LineSegment.MidPoint Property Introduced in Inventor 6

LineSegment.StartPoint Property Introduced in Inventor 6

LineSegment2d Interface Introduced in Inventor 5

LineSegment2d Methods

LineSegment2d.DistanceTo Method Introduced in Inventor 11

LineSegment2d.GetLineSegmentData Method Introduced in Inventor 5

LineSegment2d.IntersectWithCurve Method Introduced in Inventor 2008

LineSegment2d.PutLineSegmentData Method Introduced in Inventor 5

LineSegment2d Properties

LineSegment2d.Direction Property Introduced in Inventor 5

LineSegment2d.EndPoint Property Introduced in Inventor 5

LineSegment2d.Evaluator Property Introduced in Inventor 5

LineSegment2d.MidPoint Property Introduced in Inventor 5

LineSegment2d.StartPoint Property Introduced in Inventor 5

LineStripGraphics Interface Introduced in Inventor 5

LineStripGraphics Methods

LineStripGraphics.GetCustomLineType Method Introduced in Inventor 2008

LineStripGraphics.GetStripLengths Method Introduced in Inventor 5

LineStripGraphics.GetTransformBehavior Method Introduced in Inventor 5

LineStripGraphics.PutStripLengths Method Introduced in Inventor 5

LineStripGraphics.SetCustomLineType Method Introduced in Inventor 2008

LineStripGraphics.SetTransformBehavior Method Introduced in Inventor 5

LineStripGraphics Properties

LineStripGraphics.BurnThrough Property Introduced in Inventor 5

LineStripGraphics.ColorBinding Property Introduced in Inventor 5

LineStripGraphics.ColorIndexSet Property Introduced in Inventor 5

LineStripGraphics.ColorSet Property Introduced in Inventor 5

LineStripGraphics.CoordinateIndexSet Property Introduced in Inventor 5

LineStripGraphics.CoordinateSet Property Introduced in Inventor 5

LineStripGraphics.DepthPriority Property Introduced in Inventor 5

LineStripGraphics.LineDefinitionSpace Property Introduced in Inventor 2008

LineStripGraphics.LineScale Property Introduced in Inventor 2008

LineStripGraphics.LineType Property Introduced in Inventor 2008

LineStripGraphics.LineWeight Property Introduced in Inventor 2008

LineWorkAxisDef Interface Introduced in Inventor 4

LineWorkAxisDef Properties

LineWorkAxisDef.Application Property Introduced in Inventor 4

LineWorkAxisDef.Line Property Introduced in Inventor 4

LineWorkAxisDef.Parent Property Introduced in Inventor 4

LineWorkAxisDef.Type Property Introduced in Inventor 4

LipFeature Interface Introduced in Inventor 2010

LipFeatureProxy Interface Introduced in Inventor 2010

LipFeatureProxy Properties

LipFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

LipFeatureProxy.NativeObject Property Introduced in Inventor 2010

LipFeatures Interface Introduced in Inventor 2010

LipFeatures Methods

LipFeatures.Item Method Introduced in Inventor 2010

LipFeatures Properties

LipFeatures.Application Property Introduced in Inventor 2010

LipFeatures.Count Property Introduced in Inventor 2010

LipFeatures.Type Property Introduced in Inventor 2010

LoftDefinition Interface Introduced in Inventor 2008

LoftDefinition Methods

LoftDefinition.Copy Method Introduced in Inventor 2008

LoftDefinition Properties

LoftDefinition.Centerline Property Introduced in Inventor 2008

LoftDefinition.Closed Property Introduced in Inventor 2008

LoftDefinition.FirstSectionAngle Property Introduced in Inventor 2008

LoftDefinition.FirstSectionCondition Property Introduced in Inventor 2008

LoftDefinition.FirstSectionDirectionReversed Property Introduced in Inventor 2008

LoftDefinition.FirstSectionImpact Property Introduced in Inventor 2008

LoftDefinition.FirstSectionTangentPlane Property Introduced in Inventor 2008

LoftDefinition.LastSectionAngle Property Introduced in Inventor 2008

LoftDefinition.LastSectionCondition Property Introduced in Inventor 2008

LoftDefinition.LastSectionDirectionReversed Property Introduced in Inventor 2008

LoftDefinition.LastSectionImpact Property Introduced in Inventor 2008

LoftDefinition.LastSectionTangentPlane Property Introduced in Inventor 2008

LoftDefinition.LoftRails Property Introduced in Inventor 2008

LoftDefinition.LoftSectionDimensions Property Introduced in Inventor 2008

LoftDefinition.LoftType Property Introduced in Inventor 2008

LoftDefinition.MapPointCurves Property Introduced in Inventor 2008

LoftDefinition.MergeTangentFaces Property Introduced in Inventor 2008

LoftDefinition.Operation Property Introduced in Inventor 2008

LoftDefinition.Sections Property Introduced in Inventor 2008

LoftedFlangeDefinition Interface Introduced in Inventor 2011

LoftedFlangeDefinition Methods

LoftedFlangeDefinition.Copy Method Introduced in Inventor 2011

LoftedFlangeDefinition.SetOutputType Method Introduced in Inventor 2011

LoftedFlangeDefinition Properties

LoftedFlangeDefinition.Application Property

LoftedFlangeDefinition.BendRadius Property Introduced in Inventor 2011

LoftedFlangeDefinition.Converge Property Introduced in Inventor 2011

LoftedFlangeDefinition.ExtentDirection Property Introduced in Inventor 2011

LoftedFlangeDefinition.FacetTolerance Property Introduced in Inventor 2011

LoftedFlangeDefinition.IsUnfoldMethodOverridden Property

LoftedFlangeDefinition.OutputType Property Introduced in Inventor 2011

LoftedFlangeDefinition.Parent Property

LoftedFlangeDefinition.ProfileOne Property Introduced in Inventor 2011

LoftedFlangeDefinition.ProfileTwo Property Introduced in Inventor 2011

LoftedFlangeDefinition.Type Property

LoftedFlangeDefinition.UnfoldMethod Property Introduced in Inventor 2011

LoftedFlangeFeature Interface Introduced in Inventor 2010

LoftedFlangeFeature Properties

LoftedFlangeFeature.Definition Property Introduced in Inventor 2011

LoftedFlangeFeatureProxy Interface Introduced in Inventor 2010

LoftedFlangeFeatures Interface Introduced in Inventor 2010

LoftedFlangeFeatures Methods

LoftedFlangeFeatures.Add Method Introduced in Inventor 2011

LoftedFlangeFeatures.CreateLoftedFlangeDefinition Method Introduced in Inventor 2011

LoftedFlangeFeatures.Item Method Introduced in Inventor 2010

LoftedFlangeFeatures Properties

LoftedFlangeFeatures.Application Property Introduced in Inventor 2010

LoftedFlangeFeatures.Count Property Introduced in Inventor 2010

LoftedFlangeFeatures.Type Property Introduced in Inventor 2010

LoftFeature Interface Introduced in Inventor 5

LoftFeature Properties

LoftFeature.Definition Property Introduced in Inventor 2008

LoftFeature.EndFace Property Introduced in Inventor 6

LoftFeature.SideFaces Property Introduced in Inventor 6

LoftFeature.StartFace Property Introduced in Inventor 6

LoftFeatureProxy Interface Introduced in Inventor 9

LoftFeatureProxy Properties

LoftFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

LoftFeatureProxy.NativeObject Property Introduced in Inventor 9

LoftFeatures Interface Introduced in Inventor 5

LoftFeatures Methods

LoftFeatures.Add Method Introduced in Inventor 6

LoftFeatures.CreateLoftDefinition Method Introduced in Inventor 2008

LoftFeatures.CreateMapCurves Method Introduced in Inventor 6

LoftFeatures.Item Method Introduced in Inventor 5

LoftFeatures Properties

LoftFeatures.Application Property Introduced in Inventor 5

LoftFeatures.Count Property Introduced in Inventor 5

LoftFeatures.Type Property Introduced in Inventor 5

LoftRail Interface Introduced in Inventor 11

LoftRail Methods

LoftRail.Delete Method Introduced in Inventor 2008

LoftRail Properties

LoftRail.Application Property Introduced in Inventor 11

LoftRail.Condition Property Introduced in Inventor 11

LoftRail.HasConditions Property Introduced in Inventor 11

LoftRail.Impact Property Introduced in Inventor 11

LoftRail.Rail Property Introduced in Inventor 11

LoftRail.Type Property Introduced in Inventor 11

LoftRails Interface Introduced in Inventor 11

LoftRails Methods

LoftRails.Add Method Introduced in Inventor 2008

LoftRails.Item Method Introduced in Inventor 11

LoftRails Properties

LoftRails.Application Property Introduced in Inventor 11

LoftRails.Count Property Introduced in Inventor 11

LoftRails.Type Property Introduced in Inventor 11

LoftSectionDimension Interface Introduced in Inventor 2008

LoftSectionDimension Methods

LoftSectionDimension.Delete Method Introduced in Inventor 2008

LoftSectionDimension Properties

LoftSectionDimension.Application Property Introduced in Inventor 2008

LoftSectionDimension.IsDrivingSection Property Introduced in Inventor 2008

LoftSectionDimension.Position Property Introduced in Inventor 2008

LoftSectionDimension.PositionAsAbsoluteDistance Property Introduced in Inventor 2008

LoftSectionDimension.Size Property Introduced in Inventor 2008

LoftSectionDimension.SizeAsScaleFactor Property Introduced in Inventor 2008

LoftSectionDimension.Type Property Introduced in Inventor 2008

LoftSectionDimensions Interface Introduced in Inventor 2008

LoftSectionDimensions Methods

LoftSectionDimensions.AddDrivenSection Method Introduced in Inventor 2008

LoftSectionDimensions.AddDrivingSection Method Introduced in Inventor 2008

LoftSectionDimensions.Item Method Introduced in Inventor 2008

LoftSectionDimensions Properties

LoftSectionDimensions.Application Property Introduced in Inventor 2008

LoftSectionDimensions.Count Property Introduced in Inventor 2008

LoftSectionDimensions.Type Property Introduced in Inventor 2008

LumpDefinition Interface Introduced in Inventor 2011

LumpDefinition Properties

LumpDefinition.Application Property Introduced in Inventor 2011

LumpDefinition.FaceShellDefinitions Property Introduced in Inventor 2011

LumpDefinition.Type Property Introduced in Inventor 2011

LumpDefinitions Interface Introduced in Inventor 2011

LumpDefinitions Methods

LumpDefinitions.Add Method Introduced in Inventor 2011

LumpDefinitions.Item Method Introduced in Inventor 2011

LumpDefinitions Properties

LumpDefinitions.Application Property Introduced in Inventor 2011

LumpDefinitions.Count Property Introduced in Inventor 2011

LumpDefinitions.Type Property Introduced in Inventor 2011

Machining Interface Introduced in Inventor 2010

Machining Methods

Machining.Edit Method Introduced in Inventor 2010

Machining.ExitEdit Method Introduced in Inventor 2010

Machining Properties

Machining.Application Property Introduced in Inventor 2010

Machining.Type Property Introduced in Inventor 2010

MacroControlDefinition Interface Introduced in Inventor 9

MacroControlDefinition Properties

MacroControlDefinition.MacroOrFileName Property Introduced in Inventor 9

MapPointCurve Interface Introduced in Inventor 6

MapPointCurve Methods

MapPointCurve.Delete Method Introduced in Inventor 2008

MapPointCurve.GetPosition Method Introduced in Inventor 6

MapPointCurve.GetPositionPoint Method Introduced in Inventor 6

MapPointCurve.SetPosition Method Introduced in Inventor 6

MapPointCurve.SetPositionUsingPoint Method Introduced in Inventor 6

MapPointCurve Properties

MapPointCurve.Application Property Introduced in Inventor 6

MapPointCurve.PointCount Property Introduced in Inventor 6

MapPointCurve.Type Property Introduced in Inventor 6

MapPointCurves Interface Introduced in Inventor 6

MapPointCurves Methods

MapPointCurves.AddMapCurve Method Introduced in Inventor 6

MapPointCurves.Item Method Introduced in Inventor 6

MapPointCurves Properties

MapPointCurves.Application Property Introduced in Inventor 6

MapPointCurves.Count Property Introduced in Inventor 6

MapPointCurves.Type Property Introduced in Inventor 6

MassProperties Interface Introduced in Inventor 5

MassProperties Methods

MassProperties.AchievedAccuracy Method Introduced in Inventor 9

MassProperties.PrincipalMomentsOfInertia Method Introduced in Inventor 5

MassProperties.RadiusOfGyration Method Introduced in Inventor 5

MassProperties.RotationToPrincipal Method

MassProperties.XYZMomentsOfInertia Method Introduced in Inventor 5

MassProperties Properties

MassProperties.Accuracy Property Introduced in Inventor 5

MassProperties.Area Property Introduced in Inventor 5

MassProperties.AvailableAccuracy Property Introduced in Inventor 10

MassProperties.CacheResultsOnCompute Property Introduced in Inventor 10

MassProperties.CenterOfMass Property Introduced in Inventor 5

MassProperties.IncludeCosmeticWelds Property Introduced in Inventor 2008

MassProperties.IncludeQuantityOverrides Property Introduced in Inventor 2008

MassProperties.Mass Property Introduced in Inventor 5

MassProperties.MassOverridden Property Introduced in Inventor 2008

MassProperties.Type Property Introduced in Inventor 5

MassProperties.Volume Property Introduced in Inventor 5

MassProperties.VolumeOverridden Property Introduced in Inventor 2008

MateConstraint Interface Introduced in Inventor 4

MateConstraint Properties

MateConstraint.ConstraintLimits Property Introduced in Inventor 2011

MateConstraint.EntityOneInferredType Property Introduced in Inventor 6

MateConstraint.EntityTwoInferredType Property Introduced in Inventor 6

MateConstraint.Offset Property Introduced in Inventor 4

MateConstraintProxy Interface Introduced in Inventor 11

MateConstraintProxy Properties

MateConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

MateConstraintProxy.NativeObject Property Introduced in Inventor 11

MateiMateDefinition Interface Introduced in Inventor 6

MateiMateDefinition Properties

MateiMateDefinition.ConstraintLimits Property Introduced in Inventor 2011

MateiMateDefinition.Entity Property Introduced in Inventor 6

MateiMateDefinition.EntityInferredType Property Introduced in Inventor 6

MateiMateDefinition.Offset Property Introduced in Inventor 6

MateiMateDefinitionProxy Interface Introduced in Inventor 6

MateiMateDefinitionProxy Properties

MateiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

MateiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

MateiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

Material Interface Introduced in Inventor 5

Material Methods

Material.ConvertToLocal Method Introduced in Inventor 9

Material.Copy Method Introduced in Inventor 5

Material.Delete Method Introduced in Inventor 5

Material.GetReferenceKey Method Introduced in Inventor 7

Material.SaveToGlobal Method Introduced in Inventor 9

Material.UpdateFromGlobal Method Introduced in Inventor 9

Material Properties

Material.Application Property Introduced in Inventor 9

Material.AttributeSets Property Introduced in Inventor 9

Material.Density Property Introduced in Inventor 5

Material.ExternalMaterialId Property

Material.InternalName Property Introduced in Inventor 9

Material.InUse Property Introduced in Inventor 9

Material.LinearExpansion Property Introduced in Inventor 5

Material.Name Property Introduced in Inventor 5

Material.Parent Property Introduced in Inventor 9

Material.PoissonsRatio Property Introduced in Inventor 5

Material.RenderStyle Property Introduced in Inventor 5

Material.SpecificHeat Property Introduced in Inventor 5

Material.StyleLocation Property Introduced in Inventor 9

Material.ThermalConductivity Property Introduced in Inventor 5

Material.Type Property Introduced in Inventor 5

Material.UltimateTensileStrength Property Introduced in Inventor 5

Material.UpToDate Property Introduced in Inventor 9

Material.YieldStrength Property Introduced in Inventor 5

Material.YoungsModulus Property Introduced in Inventor 5

Materials Interface Introduced in Inventor 5

Materials Methods

Materials.Add Method Introduced in Inventor 5

Materials.Item Method Introduced in Inventor 5

Materials Properties

Materials.Application Property Introduced in Inventor 9

Materials.Count Property Introduced in Inventor 5

Materials.Parent Property Introduced in Inventor 5

Materials.Type Property Introduced in Inventor 5

MaterialsEnumerator Interface Introduced in Inventor 2010

MaterialsEnumerator Methods

MaterialsEnumerator.Item Method Introduced in Inventor 2010

MaterialsEnumerator Properties

MaterialsEnumerator.Application Property Introduced in Inventor 2010

MaterialsEnumerator.Count Property Introduced in Inventor 2010

MaterialsEnumerator.Type Property Introduced in Inventor 2010

Matrix Interface Introduced in Inventor 4

Matrix Methods

Matrix.GetCoordinateSystem Method Introduced in Inventor 4

Matrix.GetMatrixData Method Introduced in Inventor 4

Matrix.Invert Method Introduced in Inventor 4

Matrix.IsEqualTo Method Introduced in Inventor 4

Matrix.PostMultiplyBy Method Introduced in Inventor 6

Matrix.PreMultiplyBy Method Introduced in Inventor 6

Matrix.PutMatrixData Method Introduced in Inventor 4

Matrix.SetCoordinateSystem Method Introduced in Inventor 4

Matrix.SetToAlignCoordinateSystems Method Introduced in Inventor 4

Matrix.SetToIdentity Method Introduced in Inventor 4

Matrix.SetToRotateTo Method Introduced in Inventor 4

Matrix.SetToRotation Method Introduced in Inventor 4

Matrix.SetTranslation Method Introduced in Inventor 4

Matrix.TransformBy Method Introduced in Inventor 6

Matrix Properties

Matrix.Cell Method Introduced in Inventor 4

Matrix.Determinant Property Introduced in Inventor 4

Matrix.Translation Property Introduced in Inventor 4

Matrix2d Interface Introduced in Inventor 4

Matrix2d Methods

Matrix2d.GetCoordinateSystem Method Introduced in Inventor 11

Matrix2d.GetMatrixData Method Introduced in Inventor 4

Matrix2d.Invert Method Introduced in Inventor 11

Matrix2d.IsEqualTo Method Introduced in Inventor 11

Matrix2d.PostMultiplyBy Method Introduced in Inventor 11

Matrix2d.PreMultiplyBy Method Introduced in Inventor 11

Matrix2d.PutMatrixData Method Introduced in Inventor 4

Matrix2d.SetCoordinateSystem Method Introduced in Inventor 11

Matrix2d.SetToAlignCoordinateSystems Method Introduced in Inventor 11

Matrix2d.SetToIdentity Method Introduced in Inventor 11

Matrix2d.SetToRotateTo Method Introduced in Inventor 11

Matrix2d.SetToRotation Method Introduced in Inventor 11

Matrix2d.SetTranslation Method Introduced in Inventor 11

Matrix2d.TransformBy Method Introduced in Inventor 11

Matrix2d Properties

Matrix2d.Cell Method Introduced in Inventor 4

Matrix2d.Determinant Property Introduced in Inventor 11

Matrix2d.Translation Property Introduced in Inventor 11

MeasureEvents CoClass Introduced in Inventor 2009

MeasureEventsObject Interface Introduced in Inventor 2009

MeasureEventsObject Methods

MeasureEventsObject.ListParameters Method Introduced in Inventor 2009

MeasureEventsObject.Measure Method Introduced in Inventor 2009

MeasureEventsObject.ShowDimensions Method Introduced in Inventor 2009

MeasureEventsObject Properties

MeasureEventsObject.Application Property Introduced in Inventor 2009

MeasureEventsObject.Enabled Property Introduced in Inventor 2009

MeasureEventsObject.Parent Property Introduced in Inventor 2009

MeasureEventsObject.Type Property Introduced in Inventor 2009

MeasureEventsSink Interface Introduced in Inventor 2009

MeasureEventsSink Methods

MeasureEventsSink.OnMeasure Method Introduced in Inventor 2009

MeasureEventsSink.OnSelectParameter Method Introduced in Inventor 2009

MeasureTools Interface Introduced in Inventor 11

MeasureTools Methods

MeasureTools.GetAngle Method Introduced in Inventor 11

MeasureTools.GetLoopLength Method Introduced in Inventor 11

MeasureTools.GetMinimumDistance Method Introduced in Inventor 11

MeasureTools Properties

MeasureTools.Application Property Introduced in Inventor 11

MeasureTools.Parent Property Introduced in Inventor 11

MeasureTools.Type Property Introduced in Inventor 11

MessageSection Interface Introduced in Inventor 2010

MessageSection Methods

MessageSection.AdoptMessages Method Introduced in Inventor 2010

MessageSection.ClearMessages Method Introduced in Inventor 2010

MessageSection.End Method Introduced in Inventor 2010

MessageSection Properties

MessageSection.Application Property Introduced in Inventor 2010

MessageSection.HasErrors Property Introduced in Inventor 2010

MessageSection.HasWarnings Property Introduced in Inventor 2010

MessageSection.Parent Property Introduced in Inventor 2010

MessageSection.Type Property Introduced in Inventor 2010

MidpointConstraint Interface Introduced in Inventor 5

MidpointConstraint Properties

MidpointConstraint.Line Property Introduced in Inventor 5

MidpointConstraint.Point Property Introduced in Inventor 5

MidpointConstraint3D Interface Introduced in Inventor 2009

MidpointConstraint3D Properties

MidpointConstraint3D.Line Property Introduced in Inventor 2009

MidpointConstraint3D.Point Property Introduced in Inventor 2009

MidpointConstraint3DProxy Interface Introduced in Inventor 2009

MidpointConstraint3DProxy Properties

MidpointConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 2009

MidpointConstraint3DProxy.NativeObject Property Introduced in Inventor 2009

MidpointConstraintProxy Interface Introduced in Inventor 6

MidpointConstraintProxy Properties

MidpointConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

MidpointConstraintProxy.NativeObject Property Introduced in Inventor 6

MidPointWorkPointDef Interface Introduced in Inventor 4

MidPointWorkPointDef Properties

MidPointWorkPointDef.Application Property Introduced in Inventor 4

MidPointWorkPointDef.Edge Property Introduced in Inventor 4

MidPointWorkPointDef.Parent Property Introduced in Inventor 4

MidPointWorkPointDef.Type Property Introduced in Inventor 4

MiniToolbarButtonObject Interface Introduced in Inventor 2012

MiniToolbarButtonObject Properties

MiniToolbarButtonObject.Pressed Property Introduced in Inventor 2012

MiniToolbarButtonSink Interface

MiniToolbarButtonSink Methods

MiniToolbarButtonSink.OnClick Method Introduced in Inventor 2012

MiniToolbarCheckBoxObject Interface Introduced in Inventor 2012

MiniToolbarCheckBoxObject Properties

MiniToolbarCheckBoxObject.Checked Property Introduced in Inventor 2012

MiniToolbarCheckBoxSink Interface

MiniToolbarCheckBoxSink Methods

MiniToolbarCheckBoxSink.OnClick Method Introduced in Inventor 2012

MiniToolbarComboBoxObject Interface Introduced in Inventor 2012

MiniToolbarComboBoxObject Methods

MiniToolbarComboBoxObject.AddItem Method Introduced in Inventor 2012

MiniToolbarComboBoxObject.Clear Method Introduced in Inventor 2012

MiniToolbarComboBoxObject.RemoveItem Method Introduced in Inventor 2012

MiniToolbarComboBoxObject Properties

MiniToolbarComboBoxObject.Count Property Introduced in Inventor 2012

MiniToolbarComboBoxObject.Item Method Introduced in Inventor 2012

MiniToolbarComboBoxObject.SelectedIndex Property Introduced in Inventor 2012

MiniToolbarComboBoxObject.SelectedItem Property Introduced in Inventor 2012

MiniToolbarComboBoxObject.ShowIcon Property Introduced in Inventor 2012

MiniToolbarComboBoxObject.ShowText Property Introduced in Inventor 2012

MiniToolbarComboBoxObject.Width Property Introduced in Inventor 2012

MiniToolbarComboBoxSink Interface

MiniToolbarComboBoxSink Methods

MiniToolbarComboBoxSink.OnItemHoverEnd Method Introduced in Inventor 2012

MiniToolbarComboBoxSink.OnItemHoverStart Method Introduced in Inventor 2012

MiniToolbarComboBoxSink.OnItemRemove Method Introduced in Inventor 2012

MiniToolbarComboBoxSink.OnPreMenuDisplay Method Introduced in Inventor 2012

MiniToolbarComboBoxSink.OnSelect Method Introduced in Inventor 2012

MiniToolbarControl Interface Introduced in Inventor 2012

MiniToolbarControl Methods

MiniToolbarControl.Delete Method Introduced in Inventor 2012

MiniToolbarControl Properties

MiniToolbarControl.Application Property Introduced in Inventor 2012

MiniToolbarControl.AutoHide Property Introduced in Inventor 2012

MiniToolbarControl.ControlType Property Introduced in Inventor 2012

MiniToolbarControl.DisplayName Property Introduced in Inventor 2012

MiniToolbarControl.Enabled Property Introduced in Inventor 2012

MiniToolbarControl.Index Property Introduced in Inventor 2012

MiniToolbarControl.InternalName Property Introduced in Inventor 2012

MiniToolbarControl.LargeIcon Property Introduced in Inventor 2012

MiniToolbarControl.Parent Property Introduced in Inventor 2012

MiniToolbarControl.StandardIcon Property Introduced in Inventor 2012

MiniToolbarControl.ToolTipText Property Introduced in Inventor 2012

MiniToolbarControl.Type Property Introduced in Inventor 2012

MiniToolbarControl.Visible Property Introduced in Inventor 2012

MiniToolbarControls Interface Introduced in Inventor 2012

MiniToolbarControls Methods

MiniToolbarControls.AddButton Method Introduced in Inventor 2012

MiniToolbarControls.AddCheckBox Method Introduced in Inventor 2012

MiniToolbarControls.AddComboBox Method Introduced in Inventor 2012

MiniToolbarControls.AddDropdown Method Introduced in Inventor 2012

MiniToolbarControls.AddLabel Method Introduced in Inventor 2012

MiniToolbarControls.AddNewLine Method Introduced in Inventor 2012

MiniToolbarControls.AddSeparator Method Introduced in Inventor 2012

MiniToolbarControls.AddValueEditor Method Introduced in Inventor 2012

MiniToolbarControls.Item Method Introduced in Inventor 2012

MiniToolbarControls Properties

MiniToolbarControls.Application Property Introduced in Inventor 2012

MiniToolbarControls.Count Property Introduced in Inventor 2012

MiniToolbarControls.Type Property Introduced in Inventor 2012

MiniToolbarDropdownObject Interface Introduced in Inventor 2012

MiniToolbarDropdownObject Methods

MiniToolbarDropdownObject.AddItem Method Introduced in Inventor 2012

MiniToolbarDropdownObject.AddSeparator Method Introduced in Inventor 2012

MiniToolbarDropdownObject.Clear Method Introduced in Inventor 2012

MiniToolbarDropdownObject.RemoveItem Method Introduced in Inventor 2012

MiniToolbarDropdownObject Properties

MiniToolbarDropdownObject.Count Property Introduced in Inventor 2012

MiniToolbarDropdownObject.HasMRUBehavior Property Introduced in Inventor 2012

MiniToolbarDropdownObject.IsSplitButton Property Introduced in Inventor 2012

MiniToolbarDropdownObject.Item Method Introduced in Inventor 2012

MiniToolbarDropdownObject.Pressed Property Introduced in Inventor 2012

MiniToolbarDropdownObject.SelectedIndex Property Introduced in Inventor 2012

MiniToolbarDropdownObject.SelectedItem Property Introduced in Inventor 2012

MiniToolbarDropdownObject.ShowIcon Property Introduced in Inventor 2012

MiniToolbarDropdownObject.ShowText Property Introduced in Inventor 2012

MiniToolbarDropdownSink Interface

MiniToolbarDropdownSink Methods

MiniToolbarDropdownSink.OnItemHoverEnd Method Introduced in Inventor 2012

MiniToolbarDropdownSink.OnItemHoverStart Method Introduced in Inventor 2012

MiniToolbarDropdownSink.OnItemRemove Method Introduced in Inventor 2012

MiniToolbarDropdownSink.OnPreMenuDisplay Method Introduced in Inventor 2012

MiniToolbarDropdownSink.OnSelect Method Introduced in Inventor 2012

MiniToolbarListItem Interface Introduced in Inventor 2012

MiniToolbarListItem Properties

MiniToolbarListItem.AllowDelete Property Introduced in Inventor 2012

MiniToolbarListItem.Index Property Introduced in Inventor 2012

MiniToolbarListItem.InternalName Property Introduced in Inventor 2012

MiniToolbarListItem.IsChecked Property Introduced in Inventor 2012

MiniToolbarListItem.IsSeperator Property Introduced in Inventor 2012

MiniToolbarListItem.LargeIcon Property Introduced in Inventor 2012

MiniToolbarListItem.ShowCheckBox Property Introduced in Inventor 2012

MiniToolbarListItem.StandardIcon Property Introduced in Inventor 2012

MiniToolbarListItem.Text Property Introduced in Inventor 2012

MiniToolbarListItem.ToolTipText Property Introduced in Inventor 2012

MiniToolbarObject Interface Introduced in Inventor 2012

MiniToolbarObject Methods

MiniToolbarObject.Delete Method Introduced in Inventor 2012

MiniToolbarObject Properties

MiniToolbarObject.Application Property Introduced in Inventor 2012

MiniToolbarObject.Controls Property Introduced in Inventor 2012

MiniToolbarObject.EnableApply Property Introduced in Inventor 2012

MiniToolbarObject.EnableOK Property Introduced in Inventor 2012

MiniToolbarObject.Parent Property Introduced in Inventor 2012

MiniToolbarObject.Position Property Introduced in Inventor 2012

MiniToolbarObject.ShowApply Property Introduced in Inventor 2012

MiniToolbarObject.ShowCancel Property Introduced in Inventor 2012

MiniToolbarObject.ShowOK Property Introduced in Inventor 2012

MiniToolbarObject.ShowOptionBox Property Introduced in Inventor 2012

MiniToolbarObject.Type Property Introduced in Inventor 2012

MiniToolbarObject.Visible Property Introduced in Inventor 2012

MiniToolbarSink Interface

MiniToolbarSink Methods

MiniToolbarSink.OnApply Method Introduced in Inventor 2012

MiniToolbarSink.OnCancel Method Introduced in Inventor 2012

MiniToolbarSink.OnOK Method Introduced in Inventor 2012

MiniToolbarValueEditorObject Interface Introduced in Inventor 2012

MiniToolbarValueEditorObject Methods

MiniToolbarValueEditorObject.SetFocus Method Introduced in Inventor 2012

MiniToolbarValueEditorObject Properties

MiniToolbarValueEditorObject.AllowToleranceEdit Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.Expression Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.IsExpressionValid Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.MaximumValue Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.MinimumValue Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.ModelValueType Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.MostRecentValues Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.Precision Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.Tolerance Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.UnitsType Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.Value Property Introduced in Inventor 2012

MiniToolbarValueEditorObject.Width Property Introduced in Inventor 2012

MiniToolbarValueEditorSink Interface

MiniToolbarValueEditorSink Methods

MiniToolbarValueEditorSink.OnChange Method Introduced in Inventor 2012

MiniToolbarValueEditorSink.OnEnter Method Introduced in Inventor 2012

MiniToolbarValueEditorSink.OnExit Method Introduced in Inventor 2012

MirrorFeature Interface Introduced in Inventor 5

MirrorFeature Methods

MirrorFeature.AddParticipant Method Introduced in Inventor 2010

MirrorFeature Properties

MirrorFeature.ComputeType Property Introduced in Inventor 9

MirrorFeature.MirrorOfBody Property Introduced in Inventor 9

MirrorFeature.MirrorPlaneEntity Property Introduced in Inventor 5

MirrorFeature.NewBodyOperation Property Introduced in Inventor 2010

MirrorFeature.ParentFeatures Property Introduced in Inventor 5

MirrorFeature.PatternElements Property Introduced in Inventor 2010

MirrorFeature.ResultFeatures Property Introduced in Inventor 11

MirrorFeature.SurfacesOpaque Property Introduced in Inventor 11

MirrorFeature.SurfacesVisible Property Introduced in Inventor 11

MirrorFeatureProxy Interface Introduced in Inventor 9

MirrorFeatureProxy Properties

MirrorFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

MirrorFeatureProxy.NativeObject Property Introduced in Inventor 9

MirrorFeatures Interface Introduced in Inventor 5

MirrorFeatures Methods

MirrorFeatures.Add Method Introduced in Inventor 5.3

MirrorFeatures.Item Method Introduced in Inventor 5

MirrorFeatures Properties

MirrorFeatures.Application Property Introduced in Inventor 5

MirrorFeatures.Count Property Introduced in Inventor 5

MirrorFeatures.Type Property Introduced in Inventor 5

ModelingEvents CoClass Introduced in Inventor 11

ModelingEventsObject Interface Introduced in Inventor 11

ModelingEventsObject Properties

ModelingEventsObject.Application Property Introduced in Inventor 11

ModelingEventsObject.Parent Property Introduced in Inventor 11

ModelingEventsObject.Type Property Introduced in Inventor 11

ModelingEventsSink Interface Introduced in Inventor 11

ModelingEventsSink Methods

ModelingEventsSink.OnClientFeatureDoubleClick Method Introduced in Inventor 2009

ModelingEventsSink.OnDelete Method Introduced in Inventor 11

ModelingEventsSink.OnFeatureChange Method Introduced in Inventor 2008

ModelingEventsSink.OnGenerateMember Method Introduced in Inventor 2009

ModelingEventsSink.OnNewFeature Method Introduced in Inventor 2008

ModelingEventsSink.OnNewParameter Method Introduced in Inventor 11

ModelingEventsSink.OnParameterChange Method Introduced in Inventor 11

ModelingSettings Interface Introduced in Inventor 8

ModelingSettings Properties

ModelingSettings.AdaptivelyUsedInAssembly Property Introduced in Inventor 8

ModelingSettings.AdvancedFeatureValidation Property Introduced in Inventor 9

ModelingSettings.AllowSectioningThruPart Property Introduced in Inventor 10

ModelingSettings.Application Property Introduced in Inventor 8

ModelingSettings.CompactModelHistory Property Introduced in Inventor 8

ModelingSettings.InitialDrawingViewHeight Property Introduced in Inventor 2011

ModelingSettings.InitialDrawingViewWidth Property Introduced in Inventor 2011

ModelingSettings.InteractiveContactAnalysis Property Introduced in Inventor 2008

ModelingSettings.InteractiveContactSurfaces Property Introduced in Inventor 2008

ModelingSettings.MaintainEnhancedGraphicsDetail Property Introduced in Inventor 2010

ModelingSettings.Parent Property Introduced in Inventor 8

ModelingSettings.Snap3DAngle Property Introduced in Inventor 8

ModelingSettings.Snap3DDistance Property Introduced in Inventor 8

ModelingSettings.SolidBodyNamePrefix Property Introduced in Inventor 2010

ModelingSettings.SurfaceBodyNamePrefix Property Introduced in Inventor 2010

ModelingSettings.TappedHoleDiameter Property Introduced in Inventor 9

ModelingSettings.Type Property Introduced in Inventor 8

ModelingSettings.UpdateLegacyHoles Property Introduced in Inventor 9

ModelingSettings.UserCoordinateSystemSettings Property Introduced in Inventor 2010

ModelParameter Interface Introduced in Inventor 4

ModelParameter Methods

ModelParameter.ConvertToReferenceParameter Method Introduced in Inventor 10

ModelParameter.ConvertToUserParameter Method Introduced in Inventor 11

ModelParameter Properties

ModelParameter.BuiltIn Property Introduced in Inventor 10

ModelParameter.Renamed Property Introduced in Inventor 2008

ModelParameters Interface Introduced in Inventor 4

ModelParameters Methods

ModelParameters._AddByValue Method

ModelParameters.AddByExpression Method Introduced in Inventor 10

ModelParameters.AddByValue Method Introduced in Inventor 10

ModelParameters.Item Method Introduced in Inventor 4

ModelParameters Properties

ModelParameters.Count Property Introduced in Inventor 4

ModelParameters.Type Property Introduced in Inventor 4

MouseEvents CoClass Introduced in Inventor 5

MouseEventsObject Interface Introduced in Inventor 5

MouseEventsObject Properties

MouseEventsObject.Application Property Introduced in Inventor 5

MouseEventsObject.MouseMoveEnabled Property Introduced in Inventor 5

MouseEventsObject.Parent Property Introduced in Inventor 5

MouseEventsObject.PointInferenceEnabled Property Introduced in Inventor 5

MouseEventsObject.PointInferences Property Introduced in Inventor 5

MouseEventsObject.Type Property Introduced in Inventor 5

MouseEventsSink Interface Introduced in Inventor 5

MouseEventsSink Methods

MouseEventsSink.OnMouseClick Method Introduced in Inventor 5

MouseEventsSink.OnMouseDoubleClick Method Introduced in Inventor 5

MouseEventsSink.OnMouseDown Method Introduced in Inventor 5

MouseEventsSink.OnMouseLeave Method Introduced in Inventor 5

MouseEventsSink.OnMouseMove Method Introduced in Inventor 5

MouseEventsSink.OnMouseUp Method Introduced in Inventor 5

MoveFaceDefinition Interface Introduced in Inventor 2011

MoveFaceDefinition Methods

MoveFaceDefinition.Copy Method

MoveFaceDefinition.SetDirectionAndDistanceMoveType Method

MoveFaceDefinition.SetFreeMoveType Method

MoveFaceDefinition.SetPlanarMoveType Method

MoveFaceDefinition Properties

MoveFaceDefinition.Application Property

MoveFaceDefinition.AutomaticBlending Property

MoveFaceDefinition.Faces Property

MoveFaceDefinition.MoveFaceType Property

MoveFaceDefinition.MoveFaceTypeDefinition Property

MoveFaceDefinition.Parent Property

MoveFaceDefinition.Type Property

MoveFaceFeature Interface Introduced in Inventor 10

MoveFaceFeature Properties

MoveFaceFeature.Definition Property Introduced in Inventor 2011

MoveFaceFeatureProxy Interface Introduced in Inventor 10

MoveFaceFeatureProxy Properties

MoveFaceFeatureProxy.ContainingOccurrence Property Introduced in Inventor 10

MoveFaceFeatureProxy.NativeObject Property Introduced in Inventor 10

MoveFaceFeatures Interface Introduced in Inventor 10

MoveFaceFeatures Methods

MoveFaceFeatures.Add Method Introduced in Inventor 2011

MoveFaceFeatures.CreateDefinition Method Introduced in Inventor 2011

MoveFaceFeatures.Item Method Introduced in Inventor 10

MoveFaceFeatures Properties

MoveFaceFeatures.Application Property Introduced in Inventor 10

MoveFaceFeatures.Count Property Introduced in Inventor 10

MoveFaceFeatures.Type Property Introduced in Inventor 10

MoveFeature Interface Introduced in Inventor 2010

MoveFeature Properties

MoveFeature.Transformation Property Introduced in Inventor 2010

MoveFeatureProxy Interface Introduced in Inventor 2010

MoveFeatureProxy Properties

MoveFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

MoveFeatureProxy.NativeObject Property Introduced in Inventor 2010

MoveFeatures Interface Introduced in Inventor 2010

MoveFeatures Methods

MoveFeatures.Item Method Introduced in Inventor 2010

MoveFeatures Properties

MoveFeatures.Application Property Introduced in Inventor 2010

MoveFeatures.Count Property Introduced in Inventor 2010

MoveFeatures.Type Property Introduced in Inventor 2010

NameValueMap Interface Introduced in Inventor 4

NameValueMap Methods

NameValueMap.Add Method Introduced in Inventor 4

NameValueMap.Clear Method Introduced in Inventor 2008

NameValueMap.Insert Method Introduced in Inventor 2012

NameValueMap.Remove Method Introduced in Inventor 2008

NameValueMap Properties

NameValueMap.Count Property Introduced in Inventor 4

NameValueMap.Item Method Introduced in Inventor 4

NameValueMap.Name Method Introduced in Inventor 5.3

NameValueMap.Value Method Introduced in Inventor 4

NativeBrowserNodeDefinition CoClass Introduced in Inventor 8

NativeBrowserNodeDefinitionObject Interface

NativeBrowserNodeDefinitionObject Properties

NativeBrowserNodeDefinitionObject.ExpandedIcon Property

NativeBrowserNodeDefinitionObject.Icon Property

NativeBrowserNodeDefinitionObject.NativeObject Property

NativeBrowserNodeDefinitionObject.OverrideExpandedIcon Property

NativeBrowserNodeDefinitionObject.OverrideIcon Property

NonLinearEdgeWorkPointDef Interface Introduced in Inventor 11

NonLinearEdgeWorkPointDef Properties

NonLinearEdgeWorkPointDef.Application Property Introduced in Inventor 11

NonLinearEdgeWorkPointDef.Edge Property Introduced in Inventor 11

NonLinearEdgeWorkPointDef.Parent Property Introduced in Inventor 11

NonLinearEdgeWorkPointDef.Type Property Introduced in Inventor 11

NonParametricBaseFeature Interface Introduced in Inventor 5

NonParametricBaseFeature Methods

NonParametricBaseFeature.DeleteFaces Method Introduced in Inventor 11

NonParametricBaseFeature.Edit Method Introduced in Inventor 11

NonParametricBaseFeature.ExitEdit Method Introduced in Inventor 11

NonParametricBaseFeature.Redefine Method Introduced in Inventor 2009

NonParametricBaseFeature Properties

NonParametricBaseFeature.InputSurfaceBodies Property Introduced in Inventor 2009

NonParametricBaseFeature.IsAssociative Property Introduced in Inventor 2011

NonParametricBaseFeature.IsComposite Property Introduced in Inventor 2009

NonParametricBaseFeature.IsSolid Property Introduced in Inventor 11

NonParametricBaseFeatureDefinition Interface Introduced in Inventor 2011

NonParametricBaseFeatureDefinition Properties

NonParametricBaseFeatureDefinition.Application Property Introduced in Inventor 2011

NonParametricBaseFeatureDefinition.BRepEntities Property Introduced in Inventor 2011

NonParametricBaseFeatureDefinition.DeleteOriginal Property Introduced in Inventor 2011

NonParametricBaseFeatureDefinition.IsAssociative Property Introduced in Inventor 2011

NonParametricBaseFeatureDefinition.OutputType Property Introduced in Inventor 2011

NonParametricBaseFeatureDefinition.TargetOccurrence Property Introduced in Inventor 2011

NonParametricBaseFeatureProxy Interface Introduced in Inventor 9

NonParametricBaseFeatureProxy Properties

NonParametricBaseFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

NonParametricBaseFeatureProxy.NativeObject Property Introduced in Inventor 9

NonParametricBaseFeatures Interface Introduced in Inventor 6

NonParametricBaseFeatures Methods

NonParametricBaseFeatures.Add Method Introduced in Inventor 6

NonParametricBaseFeatures.AddByDefinition Method Introduced in Inventor 2011

NonParametricBaseFeatures.CreateDefinition Method Introduced in Inventor 2011

NonParametricBaseFeatures.Item Method Introduced in Inventor 6

NonParametricBaseFeatures Properties

NonParametricBaseFeatures.Application Property Introduced in Inventor 6

NonParametricBaseFeatures.Count Property Introduced in Inventor 6

NonParametricBaseFeatures.Type Property Introduced in Inventor 6

NormalToCurveWorkPlaneDef Interface Introduced in Inventor 6

NormalToCurveWorkPlaneDef Methods

NormalToCurveWorkPlaneDef.GetData Method Introduced in Inventor 6

NormalToCurveWorkPlaneDef Properties

NormalToCurveWorkPlaneDef.Application Property Introduced in Inventor 6

NormalToCurveWorkPlaneDef.CurveEntity Property Introduced in Inventor 6

NormalToCurveWorkPlaneDef.Parent Property Introduced in Inventor 6

NormalToCurveWorkPlaneDef.Point Property Introduced in Inventor 6

NormalToCurveWorkPlaneDef.Type Property Introduced in Inventor 6

NormalToSurfaceWorkAxisDef Interface Introduced in Inventor 10

NormalToSurfaceWorkAxisDef Methods

NormalToSurfaceWorkAxisDef.GetData Method Introduced in Inventor 10

NormalToSurfaceWorkAxisDef Properties

NormalToSurfaceWorkAxisDef.Application Property Introduced in Inventor 10

NormalToSurfaceWorkAxisDef.Parent Property Introduced in Inventor 10

NormalToSurfaceWorkAxisDef.Point Property Introduced in Inventor 10

NormalToSurfaceWorkAxisDef.SurfaceEntity Property Introduced in Inventor 10

NormalToSurfaceWorkAxisDef.Type Property Introduced in Inventor 10

NotebookOptions Interface Introduced in Inventor 11

NotebookOptions Properties

NotebookOptions.Application Property Introduced in Inventor 11

NotebookOptions.ArrowColor Property Introduced in Inventor 11

NotebookOptions.DisplayNoteIcons Property Introduced in Inventor 11

NotebookOptions.DisplayNoteText Property Introduced in Inventor 11

NotebookOptions.KeepNotesOnDeletedObjects Property Introduced in Inventor 11

NotebookOptions.NoteHighlightColor Property Introduced in Inventor 11

NotebookOptions.TextBackgroundColor Property Introduced in Inventor 11

NotebookOptions.Type Property Introduced in Inventor 11

ObjectCollection Interface Introduced in Inventor 4

ObjectCollection Methods

ObjectCollection.Add Method Introduced in Inventor 5

ObjectCollection.Clear Method Introduced in Inventor 2009

ObjectCollection.Remove Method Introduced in Inventor 5

ObjectCollection.RemoveByObject Method Introduced in Inventor 7

ObjectCollectionByVariant Interface Introduced in Inventor 4

ObjectCollectionByVariant Methods

ObjectCollectionByVariant.Add Method Introduced in Inventor 5

ObjectCollectionByVariant.Remove Method Introduced in Inventor 5

ObjectDefaultsStyle Interface Introduced in Inventor 9

ObjectDefaultsStyle Properties

ObjectDefaultsStyle.AngularDimensionLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.AngularDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.BalloonLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.BalloonStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.BaselineDimensionLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.BaselineDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.BendNoteLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.BendNoteStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.BendTableLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.BendTableStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.BendTagLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.BendTagStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.BorderGeometryLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.BorderTextLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.BorderTextStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.CenterlineLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.CenterlineStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.CentermarkLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.CentermarkStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.CenterOfGravityLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.CenterOfGravityStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.ChainDimensionLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.ChainDimensionStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.ChamferNoteLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.ChamferNoteStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.ConfigurationTableLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.ConfigurationTableStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.DiameterDimensionLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.DiameterDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.FeatureControlFrameLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.FeatureControlFrameStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.GeneralNoteLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.GeneralNoteStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.HoleNoteLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.HoleNoteStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.HoleTableLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.HoleTableStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.HoleTagLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.HoleTagStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.LeaderTextLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.LeaderTextStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.LinearDimensionLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.LinearDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.OrdinateDimensionLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.OrdinateDimensionSetLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.OrdinateDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.OrdinateSetDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.OriginIndicatorLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.OriginIndicatorStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.PartsListLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.PartsListStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.PunchNoteLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.PunchNoteStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.RadialDimensionLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.RadialDimensionStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.RevisionTableLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.RevisionTableStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.RevisionTagLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.RevisionTagStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.SheetMetalPunchLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SheetMetalPunchStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.Sketch3DGeometryLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchedSymbolGeometryLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchedSymbolLeaderLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchedSymbolLeaderStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchedSymbolTextLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchedSymbolTextStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchGeometryLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchTextLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SketchTextStyle Property Introduced in Inventor 9

ObjectDefaultsStyle.SurfaceTextureLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.SurfaceTextureStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.TableLayer Property Introduced in Inventor 2011

ObjectDefaultsStyle.TableStyle Property Introduced in Inventor 2011

ObjectDefaultsStyle.ThreadNoteLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.ThreadNoteStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.TitleBlockGeometryLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.TitleBlockTextLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.TitleBlockTextStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.ViewLabelLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.ViewLabelStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.WorkAxisLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.WorkAxisStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.WorkPlaneLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.WorkPlaneStyle Property Introduced in Inventor 2010

ObjectDefaultsStyle.WorkPointLayer Property Introduced in Inventor 2010

ObjectDefaultsStyle.WorkPointStyle Property Introduced in Inventor 2010

ObjectDefaultsStylesEnumerator Interface Introduced in Inventor 9

ObjectDefaultsStylesEnumerator Properties

ObjectDefaultsStylesEnumerator.Application Property Introduced in Inventor 9

ObjectDefaultsStylesEnumerator.Count Property Introduced in Inventor 9

ObjectDefaultsStylesEnumerator.Item Method Introduced in Inventor 9

ObjectDefaultsStylesEnumerator.Type Property Introduced in Inventor 9

ObjectsEnumerator Interface Introduced in Inventor 5

ObjectsEnumerator Methods

ObjectsEnumerator.Item Method Introduced in Inventor 5

ObjectsEnumerator Properties

ObjectsEnumerator.Count Property Introduced in Inventor 5

ObjectsEnumerator.Type Property Introduced in Inventor 5

ObjectsEnumeratorByVariant Interface Introduced in Inventor 5

ObjectsEnumeratorByVariant Methods

ObjectsEnumeratorByVariant.Item Method Introduced in Inventor 5

ObjectsEnumeratorByVariant Properties

ObjectsEnumeratorByVariant.Count Property Introduced in Inventor 5

ObjectsEnumeratorByVariant.Type Property Introduced in Inventor 5

ObjectVisibility Interface Introduced in Inventor 2011

ObjectVisibility Properties

ObjectVisibility.AllWorkFeatures Property

ObjectVisibility.Application Property

ObjectVisibility.ConstructionSurfaces Property

ObjectVisibility.GroupDiagnostics Property

ObjectVisibility.GroupSolids Property

ObjectVisibility.GroupSurfaces Property

ObjectVisibility.GroupWires Property

ObjectVisibility.OriginWorkAxes Property

ObjectVisibility.OriginWorkPlanes Property

ObjectVisibility.OriginWorkPoints Property

ObjectVisibility.Parent Property

ObjectVisibility.Sketches Property

ObjectVisibility.Sketches3D Property

ObjectVisibility.Type Property

ObjectVisibility.UCSTriads Property

ObjectVisibility.UCSWorkAxes Property

ObjectVisibility.UCSWorkPlanes Property

ObjectVisibility.UCSWorkPoints Property

ObjectVisibility.UserWorkAxes Property

ObjectVisibility.UserWorkPlanes Property

ObjectVisibility.UserWorkPoints Property

ObjectVisibility.WeldmentSymbols Property

ObjectVisibility.Welds Property

OccurrencePattern Interface Introduced in Inventor 6

OccurrencePattern Methods

OccurrencePattern.Delete Method Introduced in Inventor 6

OccurrencePattern.GetReferenceKey Method Introduced in Inventor 6

OccurrencePattern Properties

OccurrencePattern.Application Property Introduced in Inventor 6

OccurrencePattern.AttributeSets Property Introduced in Inventor 6

OccurrencePattern.HealthStatus Property Introduced in Inventor 6

OccurrencePattern.IsPatternElement Property Introduced in Inventor 2010

OccurrencePattern.Name Property Introduced in Inventor 6

OccurrencePattern.OccurrencePatternElements Property Introduced in Inventor 6

OccurrencePattern.Parent Property Introduced in Inventor 6

OccurrencePattern.ParentComponents Property Introduced in Inventor 2010

OccurrencePattern.PatternElement Property Introduced in Inventor 2010

OccurrencePattern.Type Property Introduced in Inventor 6

OccurrencePattern.Visible Property Introduced in Inventor 11

OccurrencePatternElement Interface Introduced in Inventor 5

OccurrencePatternElement Properties

OccurrencePatternElement.Application Property Introduced in Inventor 2010

OccurrencePatternElement.Components Property Introduced in Inventor 2010

OccurrencePatternElement.Independent Property Introduced in Inventor 6

OccurrencePatternElement.Index Property Introduced in Inventor 2010

OccurrencePatternElement.Name Property Introduced in Inventor 6

OccurrencePatternElement.Occurrences Property Introduced in Inventor 6

OccurrencePatternElement.Parent Property Introduced in Inventor 6

OccurrencePatternElement.Suppressed Property Introduced in Inventor 6

OccurrencePatternElement.Type Property Introduced in Inventor 5

OccurrencePatternElementProxy Interface Introduced in Inventor 2010

OccurrencePatternElementProxy Properties

OccurrencePatternElementProxy.ContainingOccurrence Property Introduced in Inventor 2010

OccurrencePatternElementProxy.NativeObject Property Introduced in Inventor 2010

OccurrencePatternElements Interface Introduced in Inventor 6

OccurrencePatternElements Methods

OccurrencePatternElements.Item Method Introduced in Inventor 6

OccurrencePatternElements Properties

OccurrencePatternElements.Application Property Introduced in Inventor 6

OccurrencePatternElements.Count Property Introduced in Inventor 6

OccurrencePatternElements.Parent Property Introduced in Inventor 6

OccurrencePatternElements.Type Property Introduced in Inventor 6

OccurrencePatterns Interface Introduced in Inventor 6

OccurrencePatterns Methods

OccurrencePatterns.AddCircularPattern Method Introduced in Inventor 6

OccurrencePatterns.AddFeatureBasedPattern Method Introduced in Inventor 9

OccurrencePatterns.AddRectangularPattern Method Introduced in Inventor 6

OccurrencePatterns.Item Method Introduced in Inventor 6

OccurrencePatterns Properties

OccurrencePatterns.Application Property Introduced in Inventor 6

OccurrencePatterns.Count Property Introduced in Inventor 6

OccurrencePatterns.Parent Property Introduced in Inventor 6

OccurrencePatterns.Type Property Introduced in Inventor 6

OffsetConstraint Interface Introduced in Inventor 5

OffsetConstraint Properties

OffsetConstraint.EntityFour Property Introduced in Inventor 5

OffsetConstraint.EntityOne Property Introduced in Inventor 5

OffsetConstraint.EntityThree Property Introduced in Inventor 5

OffsetConstraint.EntityTwo Property Introduced in Inventor 5

OffsetConstraintProxy Interface Introduced in Inventor 6

OffsetConstraintProxy Properties

OffsetConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

OffsetConstraintProxy.NativeObject Property Introduced in Inventor 6

OffsetDimConstraint Interface Introduced in Inventor 5

OffsetDimConstraint Properties

OffsetDimConstraint.Entity Property Introduced in Inventor 5

OffsetDimConstraint.Line Property Introduced in Inventor 5

OffsetDimConstraint.LinearDiameter Property Introduced in Inventor 5

OffsetDimConstraintProxy Interface Introduced in Inventor 6

OffsetDimConstraintProxy Properties

OffsetDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

OffsetDimConstraintProxy.NativeObject Property Introduced in Inventor 6

OffsetSplineDimConstraint Interface Introduced in Inventor 11

OffsetSplineDimConstraint Properties

OffsetSplineDimConstraint.OffsetSpline Property Introduced in Inventor 11

OffsetSplineDimConstraint.Spline Property Introduced in Inventor 11

OffsetSplineDimConstraintProxy Interface Introduced in Inventor 11

OffsetSplineDimConstraintProxy Properties

OffsetSplineDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

OffsetSplineDimConstraintProxy.NativeObject Property Introduced in Inventor 11

OffsetWidthExtent Interface Introduced in Inventor 2009

OffsetWidthExtent Properties

OffsetWidthExtent.Edge Property Introduced in Inventor 2009

OffsetWidthExtent.OffsetDistanceOne Property Introduced in Inventor 2009

OffsetWidthExtent.OffsetDistanceTwo Property Introduced in Inventor 2009

OffsetWidthExtent.OffsetEntityOne Property Introduced in Inventor 2009

OffsetWidthExtent.OffsetEntityTwo Property Introduced in Inventor 2009

OrdinateDimension Interface Introduced in Inventor 2009

OrdinateDimension Properties

OrdinateDimension.DimensionType Property Introduced in Inventor 2009

OrdinateDimension.Intent Property Introduced in Inventor 2009

OrdinateDimension.IsOrdinateSetMember Property Introduced in Inventor 2010

OrdinateDimension.JogPointOne Property Introduced in Inventor 2009

OrdinateDimension.JogPointTwo Property Introduced in Inventor 2009

OrdinateDimension.OrdinateDimensionSet Property Introduced in Inventor 2010

OrdinateDimension.Style Property Introduced in Inventor 2009

OrdinateDimensions Interface Introduced in Inventor 2009

OrdinateDimensions Methods

OrdinateDimensions.Add Method Introduced in Inventor 2009

OrdinateDimensions.Item Method Introduced in Inventor 2009

OrdinateDimensions Properties

OrdinateDimensions.Application Property Introduced in Inventor 2009

OrdinateDimensions.Count Property Introduced in Inventor 2009

OrdinateDimensions.Type Property Introduced in Inventor 2009

OrdinateDimensionsEnumerator Interface Introduced in Inventor 2010

OrdinateDimensionsEnumerator Methods

OrdinateDimensionsEnumerator.Item Method Introduced in Inventor 2010

OrdinateDimensionsEnumerator Properties

OrdinateDimensionsEnumerator.Count Property Introduced in Inventor 2010

OrdinateDimensionsEnumerator.Type Property Introduced in Inventor 2010

OrdinateDimensionSet Interface Introduced in Inventor 2010

OrdinateDimensionSet Methods

OrdinateDimensionSet.AddMember Method Introduced in Inventor 2010

OrdinateDimensionSet.Delete Method Introduced in Inventor 2010

OrdinateDimensionSet.GetReferenceKey Method Introduced in Inventor 2010

OrdinateDimensionSet Properties

OrdinateDimensionSet.AlignMembers Property Introduced in Inventor 2010

OrdinateDimensionSet.AllowBrokenLeaders Property Introduced in Inventor 2010

OrdinateDimensionSet.Application Property Introduced in Inventor 2010

OrdinateDimensionSet.AttributeSets Property Introduced in Inventor 2010

OrdinateDimensionSet.ContinuousRunning Property Introduced in Inventor 2010

OrdinateDimensionSet.DimensionType Property Introduced in Inventor 2010

OrdinateDimensionSet.DirectionReversed Property Introduced in Inventor 2010

OrdinateDimensionSet.Layer Property Introduced in Inventor 2010

OrdinateDimensionSet.Members Property Introduced in Inventor 2010

OrdinateDimensionSet.OriginArrowheadType Property

OrdinateDimensionSet.OriginMember Property Introduced in Inventor 2010

OrdinateDimensionSet.Parent Property Introduced in Inventor 2010

OrdinateDimensionSet.PositiveBothDirections Property Introduced in Inventor 2010

OrdinateDimensionSet.Precision Property Introduced in Inventor 2010

OrdinateDimensionSet.ShowDirection Property Introduced in Inventor 2010

OrdinateDimensionSet.Style Property Introduced in Inventor 2010

OrdinateDimensionSet.Type Property Introduced in Inventor 2010

OutOfProcessInventorServer CoClass

OrdinateDimensionSets Interface Introduced in Inventor 2010

OrdinateDimensionSets Methods

OrdinateDimensionSets.Add Method Introduced in Inventor 2010

OrdinateDimensionSets.Item Method Introduced in Inventor 2010

OrdinateDimensionSets Properties

OrdinateDimensionSets.Application Property Introduced in Inventor 2010

OrdinateDimensionSets.Count Property Introduced in Inventor 2010

OrdinateDimensionSets.Type Property Introduced in Inventor 2010

OriginIndicator Interface Introduced in Inventor 2009

OriginIndicator Properties

OriginIndicator.Application Property Introduced in Inventor 2009

OriginIndicator.Attached Property Introduced in Inventor 2009

OriginIndicator.Intent Property Introduced in Inventor 2009

OriginIndicator.Layer Property Introduced in Inventor 2009

OriginIndicator.LeaderStyle Property Introduced in Inventor 2009

OriginIndicator.RelativeX Property Introduced in Inventor 2009

OriginIndicator.RelativeY Property Introduced in Inventor 2009

OriginIndicator.Type Property Introduced in Inventor 2009

OriginIndicator.Visible Property Introduced in Inventor 2009

PanelBar CoClass Introduced in Inventor 9

PanelBarEventsSink Interface

PanelBarEventsSink Methods

PanelBarEventsSink.OnCommandBarSelection Method

PanelBarObject Interface

PanelBarObject Properties

PanelBarObject.Application Property

PanelBarObject.CommandBarList Property

PanelBarObject.CurrentCommandBar Property

PanelBarObject.DefaultCommandBar Property

PanelBarObject.Parent Property

PanelBarObject.Type Property

ParallelConstraint Interface Introduced in Inventor 5

ParallelConstraint Properties

ParallelConstraint.EntityOne Property Introduced in Inventor 5

ParallelConstraint.EntityTwo Property Introduced in Inventor 5

ParallelConstraint.UseEllipseOneMajorAxis Property Introduced in Inventor 5

ParallelConstraint.UseEllipseTwoMajorAxis Property Introduced in Inventor 5

ParallelConstraint3D Interface Introduced in Inventor 10

ParallelConstraint3D Properties

ParallelConstraint3D.EntityOne Property Introduced in Inventor 10

ParallelConstraint3D.EntityTwo Property Introduced in Inventor 10

ParallelConstraint3DProxy Interface Introduced in Inventor 10

ParallelConstraint3DProxy Properties

ParallelConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 10

ParallelConstraint3DProxy.NativeObject Property Introduced in Inventor 10

ParallelConstraintProxy Interface Introduced in Inventor 6

ParallelConstraintProxy Properties

ParallelConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

ParallelConstraintProxy.NativeObject Property Introduced in Inventor 6

Parameter Interface Introduced in Inventor 4

Parameter Methods

Parameter.Delete Method Introduced in Inventor 9

Parameter.GetReferenceKey Method Introduced in Inventor 5

Parameter Properties

Parameter.AttributeSets Property Introduced in Inventor 5

Parameter.Comment Property Introduced in Inventor 4

Parameter.CustomPropertyFormat Property Introduced in Inventor 2010

Parameter.Dependents Property Introduced in Inventor 4

Parameter.DisabledActionTypes Property Introduced in Inventor 9

Parameter.DisplayFormat Property

Parameter.DrivenBy Property Introduced in Inventor 4

Parameter.ExposedAsProperty Property Introduced in Inventor 5.3

Parameter.Expression Property Introduced in Inventor 4

Parameter.ExpressionList Property Introduced in Inventor 2011

Parameter.HealthStatus Property Introduced in Inventor 4

Parameter.InUse Property Introduced in Inventor 2009

Parameter.IsKey Property Introduced in Inventor 2011

Parameter.ModelValue Property Introduced in Inventor 6

Parameter.ModelValueType Property Introduced in Inventor 6

Parameter.Name Property Introduced in Inventor 4

Parameter.ParameterType Property Introduced in Inventor 4

Parameter.Parent Property Introduced in Inventor 4

Parameter.Precision Property Introduced in Inventor 6

Parameter.Tolerance Property Introduced in Inventor 6

Parameter.Type Property Introduced in Inventor 4

Parameter.Units Property Introduced in Inventor 4

Parameter.Value Property Introduced in Inventor 4

Parameters Interface Introduced in Inventor 4

Parameters Methods

Parameters._GetValueFromExpression Method

Parameters.AngularStandardTolerance Method Introduced in Inventor 6

Parameters.GetValueFromExpression Method Introduced in Inventor 4

Parameters.IsExpressionValid Method Introduced in Inventor 2008

Parameters.Item Method Introduced in Inventor 4

Parameters.LinearStandardTolerance Method ([in] long, [in] BSTR) Introduced in Inventor 6

Parameters.LinearStandardTolerance Method ([in] long, [out, retval] BSTR*) Introduced in Inventor 6

Parameters.SetAllToMax Method Introduced in Inventor 6

Parameters.SetAllToMedian Method Introduced in Inventor 10

Parameters.SetAllToMin Method Introduced in Inventor 6

Parameters.SetAllToNominal Method Introduced in Inventor 6

Parameters Properties

Parameters.AngularDimensionPrecision Property Introduced in Inventor 6

Parameters.Count Property Introduced in Inventor 4

Parameters.CustomParameterGroups Property Introduced in Inventor 10

Parameters.DerivedParameterTables Property Introduced in Inventor 11

Parameters.DimensionDisplayType Property Introduced in Inventor 6

Parameters.DisplayParameterAsExpression Property Introduced in Inventor 2010

Parameters.ExportStandardTolerances Property Introduced in Inventor 2010

Parameters.LinearDimensionPrecision Property Introduced in Inventor 6

Parameters.ModelParameters Property Introduced in Inventor 4

Parameters.ParameterTables Property Introduced in Inventor 4

Parameters.ReferenceParameters Property Introduced in Inventor 4

Parameters.Type Property Introduced in Inventor 4

Parameters.UserParameters Property Introduced in Inventor 4

Parameters.UseStandardTolerances Property Introduced in Inventor 6

ParametersEnumerator Interface Introduced in Inventor 5.3

ParametersEnumerator Methods

ParametersEnumerator.Item Method Introduced in Inventor 5.3

ParametersEnumerator Properties

ParametersEnumerator.Count Property Introduced in Inventor 5.3

ParametersEnumerator.Type Property Introduced in Inventor 5.3

ParameterTable Interface Introduced in Inventor 4

ParameterTable Methods

ParameterTable.Delete Method Introduced in Inventor 4

ParameterTable.GetReferenceKey Method Introduced in Inventor 5

ParameterTable Properties

ParameterTable.AttributeSets Property Introduced in Inventor 5

ParameterTable.FileName Property Introduced in Inventor 4

ParameterTable.Linked Property Introduced in Inventor 4

ParameterTable.Parent Property Introduced in Inventor 4

ParameterTable.ReferencedFileDescriptor Property

ParameterTable.StartCell Property Introduced in Inventor 4

ParameterTable.TableParameters Property Introduced in Inventor 4

ParameterTable.Type Property Introduced in Inventor 4

ParameterTable.WorkSheet Property Introduced in Inventor 4

ParameterTables Interface Introduced in Inventor 4

ParameterTables Methods

ParameterTables.AddExcelTable Method Introduced in Inventor 4

ParameterTables.Item Method Introduced in Inventor 4

ParameterTables Properties

ParameterTables.Count Property Introduced in Inventor 4

ParameterTables.Type Property Introduced in Inventor 4

PartComponentDefinition Interface Introduced in Inventor 4

PartComponentDefinition Methods

PartComponentDefinition.CreateFactory Method Introduced in Inventor 2008

PartComponentDefinition.DeleteObjects Method Introduced in Inventor 9

PartComponentDefinition.ExportObjects Method

PartComponentDefinition.FindUsingRay Method Introduced in Inventor 5.3

PartComponentDefinition.GetEndOfPartPosition Method Introduced in Inventor 2010

PartComponentDefinition.SetEndOfPartToTopOrBottom Method Introduced in Inventor 7

PartComponentDefinition.SuppressFeatures Method Introduced in Inventor 2009

PartComponentDefinition.UnsuppressFeatures Method Introduced in Inventor 2009

PartComponentDefinition Properties

PartComponentDefinition.AnalysisManager Property Introduced in Inventor 2009

PartComponentDefinition.BIMComponent Property Introduced in Inventor 2012

PartComponentDefinition.CompactModelHistoryOnNextSave Property Introduced in Inventor 5.3

PartComponentDefinition.Features Property Introduced in Inventor 4

PartComponentDefinition.HasMultipleSolidBodies Property Introduced in Inventor 2010

PartComponentDefinition.iMateDefinitions Property Introduced in Inventor 6

PartComponentDefinition.iPartFactory Property Introduced in Inventor 6

PartComponentDefinition.iPartMember Property Introduced in Inventor 6

PartComponentDefinition.IsContentMember Property Introduced in Inventor 2011

PartComponentDefinition.IsiPartFactory Property Introduced in Inventor 6

PartComponentDefinition.IsiPartMember Property Introduced in Inventor 6

PartComponentDefinition.MassProperties Property Introduced in Inventor 5

PartComponentDefinition.Material Property Introduced in Inventor 5

PartComponentDefinition.Parameters Property Introduced in Inventor 4

PartComponentDefinition.PartEvents Property Introduced in Inventor 4

PartComponentDefinition.ReferenceComponents Property Introduced in Inventor 5.3

PartComponentDefinition.RepresentationsManager Property Introduced in Inventor 2012

PartComponentDefinition.RolledBackForEdit Property Introduced in Inventor 10

PartComponentDefinition.SketchBlockDefinitions Property Introduced in Inventor 2010

PartComponentDefinition.Sketches Property Introduced in Inventor 5

PartComponentDefinition.Sketches3D Property Introduced in Inventor 6

PartComponentDefinition.UserCoordinateSystems Property Introduced in Inventor 2010

PartComponentDefinition.WorkAxes Property Introduced in Inventor 4

PartComponentDefinition.WorkPlanes Property Introduced in Inventor 4

PartComponentDefinition.WorkPoints Property Introduced in Inventor 4

PartComponentDefinition.WorkSurfaces Property Introduced in Inventor 6

PartComponentDefinitions Interface Introduced in Inventor 4

PartComponentDefinitions Methods

PartComponentDefinitions.Item Method Introduced in Inventor 4

PartComponentDefinitions Properties

PartComponentDefinitions.Count Property Introduced in Inventor 4

PartComponentDefinitions.Type Property Introduced in Inventor 4

PartDocument Interface Introduced in Inventor 4

PartDocument Methods

PartDocument.GetSelectedObject Method

PartDocument.PutGraphicsLevelsOfDetail Method Introduced in Inventor 4

PartDocument.UpdateSubstitutePart Method Introduced in Inventor 2009

PartDocument Properties

PartDocument.ActiveLightingStyle Property Introduced in Inventor 10

PartDocument.ActiveRenderStyle Property Introduced in Inventor 5

PartDocument.ComponentDefinition Property Introduced in Inventor 5

PartDocument.DisabledCommandList Property Introduced in Inventor 10

PartDocument.DisplaySettings Property Introduced in Inventor 2011

PartDocument.EnvironmentManager Property Introduced in Inventor 10

PartDocument.IsSubstitutePart Property Introduced in Inventor 2009

PartDocument.LightingStyles Property Introduced in Inventor 10

PartDocument.Materials Property Introduced in Inventor 5

PartDocument.ModelingSettings Property Introduced in Inventor 8

PartDocument.ObjectVisibility Property Introduced in Inventor 2011

PartDocument.Sketch3DSettings Property Introduced in Inventor 8

PartDocument.SketchActive Property Introduced in Inventor 4

PartDocument.SketchSettings Property Introduced in Inventor 8

PartDocument.SubstitutePartStatus Property Introduced in Inventor 2009

PartEvents CoClass Introduced in Inventor 4

PartEventsObject Interface Introduced in Inventor 4

PartEventsObject Properties

PartEventsObject.Application Property Introduced in Inventor 2010

PartEventsObject.Parent Property Introduced in Inventor 2010

PartEventsObject.Type Property Introduced in Inventor 2010

PartEventsSink Interface Introduced in Inventor 4

PartEventsSink Methods

PartEventsSink.OnSurfaceBodyChanged Method Introduced in Inventor 4

PartFeature Interface Introduced in Inventor 4

PartFeature Methods

PartFeature.Delete Method Introduced in Inventor 5

PartFeature.GetReferenceKey Method Introduced in Inventor 5

PartFeature.GetRenderStyle Method Introduced in Inventor 7

PartFeature.GetSuppressionCondition Method Introduced in Inventor 11

PartFeature.RemoveParticipant Method Introduced in Inventor 10

PartFeature.SetAffectedBodies Method Introduced in Inventor 2010

PartFeature.SetEndOfPart Method Introduced in Inventor 6

PartFeature.SetRenderStyle Method Introduced in Inventor 7

PartFeature.SetSuppressionCondition Method Introduced in Inventor 11

PartFeature.SurfaceBody Method

PartFeature Properties

PartFeature.Adaptive Property Introduced in Inventor 5

PartFeature.Application Property Introduced in Inventor 5

PartFeature.AttributeSets Property Introduced in Inventor 5

PartFeature.ConsumeInputs Property Introduced in Inventor 11

PartFeature.ExtendedName Property

PartFeature.Faces Property Introduced in Inventor 5

PartFeature.FeatureDimensions Property Introduced in Inventor 2008

PartFeature.HealthStatus Property Introduced in Inventor 5

PartFeature.IsOwnedByFeature Property Introduced in Inventor 2008

PartFeature.Name Property Introduced in Inventor 5

PartFeature.OwnedBy Property Introduced in Inventor 2008

PartFeature.Parameters Property Introduced in Inventor 11

PartFeature.Parent Property Introduced in Inventor 5

PartFeature.Participants Property Introduced in Inventor 10

PartFeature.RangeBox Property Introduced in Inventor 5

PartFeature.Shared Property Introduced in Inventor 11

PartFeature.Suppressed Property Introduced in Inventor 5

PartFeature.SurfaceBodies Property Introduced in Inventor 2010

PartFeature.Type Property Introduced in Inventor 5

PartFeatureExtent Interface Introduced in Inventor 5

PartFeatureExtent Properties

PartFeatureExtent.Application Property Introduced in Inventor 5

PartFeatureExtent.Parent Property Introduced in Inventor 5

PartFeatureExtent.Type Property Introduced in Inventor 5

PartFeatures Interface Introduced in Inventor 4

PartFeatures Methods

PartFeatures.CreatePath Method Introduced in Inventor 8

PartFeatures.CreateSpecifiedPath Method Introduced in Inventor 8

PartFeatures.Item Method Introduced in Inventor 4

PartFeatures Properties

PartFeatures.AliasFreeformFeatures Property Introduced in Inventor 2011

PartFeatures.Application Property Introduced in Inventor 5

PartFeatures.BendPartFeatures Property Introduced in Inventor 2008

PartFeatures.BossFeatures Property Introduced in Inventor 2010

PartFeatures.BoundaryPatchFeatures Property Introduced in Inventor 9

PartFeatures.ChamferFeatures Property Introduced in Inventor 5

PartFeatures.CircularPatternFeatures Property Introduced in Inventor 5

PartFeatures.ClientFeatures Property Introduced in Inventor 2008

PartFeatures.CoilFeatures Property Introduced in Inventor 5

PartFeatures.CombineFeatures Property Introduced in Inventor 2010

PartFeatures.CoreCavityFeatures Method Introduced in Inventor 2011

PartFeatures.Count Property Introduced in Inventor 4

PartFeatures.DecalFeatures Property Introduced in Inventor 6

PartFeatures.DeleteFaceFeatures Property Introduced in Inventor 6

PartFeatures.EmbossFeatures Property Introduced in Inventor 6

PartFeatures.ExtendFeatures Property Introduced in Inventor 11

PartFeatures.ExtrudeFeatures Property Introduced in Inventor 5

PartFeatures.FaceDraftFeatures Property Introduced in Inventor 5

PartFeatures.FilletFeatures Property Introduced in Inventor 5

PartFeatures.GrillFeatures Property Introduced in Inventor 2010

PartFeatures.HoleFeatures Property Introduced in Inventor 5

PartFeatures.iFeatures Property Introduced in Inventor 2009

PartFeatures.KnitFeatures Property Introduced in Inventor 6

PartFeatures.LipFeatures Property Introduced in Inventor 2010

PartFeatures.LoftFeatures Property Introduced in Inventor 5

PartFeatures.MirrorFeatures Property Introduced in Inventor 5

PartFeatures.MoveFaceFeatures Property Introduced in Inventor 10

PartFeatures.MoveFeatures Property Introduced in Inventor 2010

PartFeatures.NonParametricBaseFeatures Property Introduced in Inventor 6

PartFeatures.RectangularPatternFeatures Property Introduced in Inventor 5

PartFeatures.ReferenceFeatures Property Introduced in Inventor 5.3

PartFeatures.ReplaceFaceFeatures Property Introduced in Inventor 6

PartFeatures.RestFeatures Property Introduced in Inventor 2010

PartFeatures.RevolveFeatures Property Introduced in Inventor 5

PartFeatures.RibFeatures Property Introduced in Inventor 5

PartFeatures.RuleFilletFeatures Property Introduced in Inventor 2010

PartFeatures.SculptFeatures Property Introduced in Inventor 11

PartFeatures.ShellFeatures Property Introduced in Inventor 5

PartFeatures.SnapFitFeatures Property Introduced in Inventor 2010

PartFeatures.SplitFeatures Property Introduced in Inventor 5

PartFeatures.SweepFeatures Property Introduced in Inventor 5

PartFeatures.ThickenFeatures Property Introduced in Inventor 6

PartFeatures.ThreadFeatures Property Introduced in Inventor 5

PartFeatures.TrimFeatures Property Introduced in Inventor 11

PartFeatures.Type Property Introduced in Inventor 4

PartFeaturesEnumerator Interface Introduced in Inventor 5

PartFeaturesEnumerator Methods

PartFeaturesEnumerator.Item Method Introduced in Inventor 5

PartFeaturesEnumerator Properties

PartFeaturesEnumerator.Count Property Introduced in Inventor 5

PartFeaturesEnumerator.Type Property Introduced in Inventor 5

PartOptions Interface Introduced in Inventor 11

PartOptions Properties

PartOptions.Application Property Introduced in Inventor 11

PartOptions.AutoConsumeWorkAndSurfaceFeatures Property Introduced in Inventor 11

PartOptions.AutoHideInLineWorkFeatures Property Introduced in Inventor 11

PartOptions.DefaultDesignView Property Introduced in Inventor 2012

PartOptions.DefaultDesignViewIsAssociative Property Introduced in Inventor 2012

PartOptions.DimensionConstraintsRelaxation Property Introduced in Inventor 11

PartOptions.DisplayExtendedName Property

PartOptions.DisplayGripsOnSelection Property Introduced in Inventor 2008

PartOptions.EditBaseSolidsUsingFusion Property Introduced in Inventor 2011

PartOptions.Enable3DGrips Property Introduced in Inventor 2008

PartOptions.GeometricConstraintsBreakage Property Introduced in Inventor 11

PartOptions.OpaqueConstructionSurfaces Property Introduced in Inventor 11

PartOptions.SketchCreationOnNewPart Property Introduced in Inventor 11

PartOptions.Type Property Introduced in Inventor 11

PartsList Interface Introduced in Inventor 5.3

PartsList Methods

PartsList.CopyTo Method Introduced in Inventor 2009

PartsList.Delete Method Introduced in Inventor 9

PartsList.Export Method Introduced in Inventor 9

PartsList.GetReferenceKey Method Introduced in Inventor 2009

PartsList.Renumber Method Introduced in Inventor 10

PartsList.SaveItemOverridesToBOM Method Introduced in Inventor 11

PartsList.Sort Method Introduced in Inventor 10

PartsList Properties

PartsList.Application Property Introduced in Inventor 5.3

PartsList.AttributeSets Property Introduced in Inventor 2009

PartsList.ColumnHeaderTextStyle Property Introduced in Inventor 2009

PartsList.DataTextStyle Property Introduced in Inventor 2009

PartsList.HeadingPlacement Property Introduced in Inventor 9

PartsList.HideZeroQuantityRows Property Introduced in Inventor 2008

PartsList.Layer Property Introduced in Inventor 10

PartsList.Level Property Introduced in Inventor 10

PartsList.MaximumRows Property Introduced in Inventor 11

PartsList.MembersToInclude Property Introduced in Inventor 2008

PartsList.NumberingScheme Property Introduced in Inventor 11

PartsList.NumberOfSections Property Introduced in Inventor 10

PartsList.Parent Property Introduced in Inventor 5.3

PartsList.PartsListColumns Property Introduced in Inventor 5.3

PartsList.PartsListRows Property Introduced in Inventor 5.3

PartsList.Position Property Introduced in Inventor 9

PartsList.RangeBox Property Introduced in Inventor 2010

PartsList.ReferencedDocumentDescriptor Property Introduced in Inventor 11

PartsList.Rotation Property Introduced in Inventor 2009

PartsList.RowGap Property Introduced in Inventor 10

PartsList.RowLineSpacing Property Introduced in Inventor 9

PartsList.ShowTitle Property Introduced in Inventor 9

PartsList.Style Property Introduced in Inventor 2011

PartsList.TableDirection Property Introduced in Inventor 9

PartsList.Title Property Introduced in Inventor 5.3

PartsList.TitleTextStyle Property Introduced in Inventor 2009

PartsList.Type Property Introduced in Inventor 5.3

PartsList.WrapAutomatically Property Introduced in Inventor 10

PartsList.WrapLeft Property Introduced in Inventor 9

PartsListCell Interface Introduced in Inventor 5.3

PartsListCell Methods

PartsListCell.Static Method Introduced in Inventor 10

PartsListCell.Update Method

PartsListCell.UpToDate Method

PartsListCell Properties

PartsListCell.Application Property Introduced in Inventor 5.3

PartsListCell.Parent Property Introduced in Inventor 5.3

PartsListCell.Static Property Introduced in Inventor 10

PartsListCell.Type Property Introduced in Inventor 5.3

PartsListCell.Value Property Introduced in Inventor 5.3

PartsListColumn Interface Introduced in Inventor 5.3

PartsListColumn Methods

PartsListColumn.GetFilePropertyId Method Introduced in Inventor 9

PartsListColumn.Remove Method Introduced in Inventor 9

PartsListColumn.Reposition Method Introduced in Inventor 10

PartsListColumn Properties

PartsListColumn.Application Property Introduced in Inventor 5.3

PartsListColumn.CustomPropertyName Property Introduced in Inventor 9

PartsListColumn.Parent Property Introduced in Inventor 5.3

PartsListColumn.PropertyType Property Introduced in Inventor 9

PartsListColumn.Title Property Introduced in Inventor 5.3

PartsListColumn.TitleHorizontalJustification Property Introduced in Inventor 10

PartsListColumn.Type Property Introduced in Inventor 5.3

PartsListColumn.ValueHorizontalJustification Property Introduced in Inventor 10

PartsListColumn.Width Property Introduced in Inventor 2010

PartsListColumns Interface Introduced in Inventor 5.3

PartsListColumns Methods

PartsListColumns.Add Method Introduced in Inventor 9

PartsListColumns.Item Method Introduced in Inventor 5.3

PartsListColumns Properties

PartsListColumns.Application Property Introduced in Inventor 5.3

PartsListColumns.Count Property Introduced in Inventor 5.3

PartsListColumns.Type Property Introduced in Inventor 5.3

PartsListRow Interface Introduced in Inventor 5.3

PartsListRow Methods

PartsListRow.Item Method Introduced in Inventor 5

PartsListRow.ReferencedFiles Method

PartsListRow.Remove Method Introduced in Inventor 9

PartsListRow.Reposition Method Introduced in Inventor 10

PartsListRow.SaveItemOverridesToBOM Method Introduced in Inventor 11

PartsListRow Properties

PartsListRow.Application Property Introduced in Inventor 5.3

PartsListRow.Ballooned Property Introduced in Inventor 10

PartsListRow.Count Property Introduced in Inventor 5.3

PartsListRow.Custom Property Introduced in Inventor 9

PartsListRow.Expandable Property Introduced in Inventor 9

PartsListRow.Expanded Property Introduced in Inventor 9

PartsListRow.Height Property Introduced in Inventor 2010

PartsListRow.Parent Property Introduced in Inventor 5.3

PartsListRow.ReferencedRows Property Introduced in Inventor 2009

PartsListRow.Type Property Introduced in Inventor 5.3

PartsListRow.Visible Property Introduced in Inventor 9

PartsListRows Interface Introduced in Inventor 5.3

PartsListRows Methods

PartsListRows.Add Method Introduced in Inventor 9

PartsListRows.Item Method Introduced in Inventor 5.3

PartsListRows Properties

PartsListRows.Application Property Introduced in Inventor 5.3

PartsListRows.Count Property Introduced in Inventor 5.3

PartsListRows.Type Property Introduced in Inventor 5.3

PartsLists Interface Introduced in Inventor 5.3

PartsLists Methods

PartsLists.Add Method Introduced in Inventor 9

PartsLists.Item Method Introduced in Inventor 5.3

PartsLists Properties

PartsLists.Application Property Introduced in Inventor 5.3

PartsLists.Count Property Introduced in Inventor 5.3

PartsLists.Type Property Introduced in Inventor 5.3

PartsListStyle Interface Introduced in Inventor 2011

PartsListStyle Methods

PartsListStyle.AddColumn Method Introduced in Inventor 2011

PartsListStyle.RemoveAllColumns Method

PartsListStyle Properties

PartsListStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2011

PartsListStyle.DataTextStyle Property Introduced in Inventor 2011

PartsListStyle.HeadingGap Property Introduced in Inventor 2011

PartsListStyle.HeadingPlacement Property Introduced in Inventor 2011

PartsListStyle.RowGap Property Introduced in Inventor 2011

PartsListStyle.RowLineSpacing Property Introduced in Inventor 2011

PartsListStyle.ShowTitle Property Introduced in Inventor 2011

PartsListStyle.TableDirection Property Introduced in Inventor 2011

PartsListStyle.Title Property Introduced in Inventor 2011

PartsListStyle.TitleTextStyle Property Introduced in Inventor 2011

PartsListStylesEnumerator Interface Introduced in Inventor 2011

PartsListStylesEnumerator Methods

PartsListStylesEnumerator.Item Method Introduced in Inventor 2011

PartsListStylesEnumerator Properties

PartsListStylesEnumerator._NewEnum Property

PartsListStylesEnumerator.Application Property Introduced in Inventor 2011

PartsListStylesEnumerator.Count Property Introduced in Inventor 2011

PartsListStylesEnumerator.Type Property Introduced in Inventor 2011

Path Interface Introduced in Inventor 6

Path Methods

Path.GetReferenceKey Method Introduced in Inventor 9

Path.Item Method Introduced in Inventor 6

Path Properties

Path.Application Property Introduced in Inventor 6

Path.AttributeSets Property Introduced in Inventor 2010

Path.Closed Property Introduced in Inventor 6

Path.Count Property Introduced in Inventor 6

Path.Type Property Introduced in Inventor 6

Path.Wires Property Introduced in Inventor 2009

PathAndGuideRailSweepDef Interface Introduced in Inventor 11

PathAndGuideRailSweepDef Properties

PathAndGuideRailSweepDef.GuideRail Property Introduced in Inventor 11

PathAndGuideRailSweepDef.ProfileScaling Property Introduced in Inventor 11

PathAndGuideSurfaceSweepDef Interface Introduced in Inventor 11

PathAndGuideSurfaceSweepDef Properties

PathAndGuideSurfaceSweepDef.GuideSurface Property Introduced in Inventor 11

PathAndSectionTwistsSweepDef Interface Introduced in Inventor 2008

PathAndSectionTwistsSweepDef Methods

PathAndSectionTwistsSweepDef.GetSectionTwists Method Introduced in Inventor 2008

PathAndSectionTwistsSweepDef.SetSectionTwists Method Introduced in Inventor 2008

PathAndSectionTwistsSweepDef Properties

PathAndSectionTwistsSweepDef.ProfileOrientation Property Introduced in Inventor 2008

PathAndSectionTwistsSweepDef.TaperAngle Property Introduced in Inventor 2008

PathEntity Interface Introduced in Inventor 6

PathEntity Methods

PathEntity.GetReferenceKey Method Introduced in Inventor 9

PathEntity Properties

PathEntity.Application Property Introduced in Inventor 6

PathEntity.Curve Property Introduced in Inventor 6

PathEntity.CurveType Property Introduced in Inventor 6

PathEntity.OpposedToSketchEntity Property Introduced in Inventor 6

PathEntity.Parent Property Introduced in Inventor 6

PathEntity.SketchEntity Property Introduced in Inventor 6

PathEntity.Type Property Introduced in Inventor 6

PathEntityProxy Interface Introduced in Inventor 9

PathEntityProxy Properties

PathEntityProxy.ContainingOccurrence Property Introduced in Inventor 9

PathEntityProxy.NativeObject Property Introduced in Inventor 9

PathProxy Interface Introduced in Inventor 9

PathProxy Properties

PathProxy.ContainingOccurrence Property Introduced in Inventor 9

PathProxy.NativeObject Property Introduced in Inventor 9

PathSweepDef Interface Introduced in Inventor 11

PathSweepDef Properties

PathSweepDef.ProfileOrientation Property Introduced in Inventor 11

PathSweepDef.TaperAngle Property Introduced in Inventor 11

PatternConstraint Interface Introduced in Inventor 5

PatternConstraintProxy Interface Introduced in Inventor 6

PatternConstraintProxy Properties

PatternConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

PatternConstraintProxy.NativeObject Property Introduced in Inventor 6

PerpendicularConstraint Interface Introduced in Inventor 5

PerpendicularConstraint Properties

PerpendicularConstraint.EntityOne Property Introduced in Inventor 5

PerpendicularConstraint.EntityTwo Property Introduced in Inventor 5

PerpendicularConstraint.UseEllipseOneMajorAxis Property Introduced in Inventor 5

PerpendicularConstraint.UseEllipseTwoMajorAxis Property Introduced in Inventor 5

PerpendicularConstraint3D Interface Introduced in Inventor 10

PerpendicularConstraint3D Properties

PerpendicularConstraint3D.EntityOne Property Introduced in Inventor 10

PerpendicularConstraint3D.EntityTwo Property Introduced in Inventor 10

PerpendicularConstraint3DProxy Interface Introduced in Inventor 10

PerpendicularConstraint3DProxy Properties

PerpendicularConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 10

PerpendicularConstraint3DProxy.NativeObject Property Introduced in Inventor 10

PerpendicularConstraintProxy Interface Introduced in Inventor 6

PerpendicularConstraintProxy Properties

PerpendicularConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

PerpendicularConstraintProxy.NativeObject Property Introduced in Inventor 6

PitchAndHeightCoilExtent Interface Introduced in Inventor 5.3

PitchAndHeightCoilExtent Properties

PitchAndHeightCoilExtent.Height Property Introduced in Inventor 2010

PitchAndHeightCoilExtent.Pitch Property Introduced in Inventor 5.3

PitchAndHeightCoilExtent.TaperAngle Property Introduced in Inventor 5.3

PitchAndRevolutionCoilExtent Interface Introduced in Inventor 5.3

PitchAndRevolutionCoilExtent Properties

PitchAndRevolutionCoilExtent.Pitch Property Introduced in Inventor 5.3

PitchAndRevolutionCoilExtent.Revolution Property Introduced in Inventor 5.3

PitchAndRevolutionCoilExtent.TaperAngle Property Introduced in Inventor 5.3

PlanarMoveDefinition Interface Introduced in Inventor 2011

PlanarMoveDefinition Properties

PlanarMoveDefinition.Application Property

PlanarMoveDefinition.Parent Property

PlanarMoveDefinition.Plane Property

PlanarMoveDefinition.PointOne Property

PlanarMoveDefinition.PointTwo Property

PlanarMoveDefinition.Type Property

PlanarSketch Interface Introduced in Inventor 5

PlanarSketch Methods

PlanarSketch.AddBySilhouette Method Introduced in Inventor 5

PlanarSketch.BreakLink Method

PlanarSketch.ModelToSketchSpace Method Introduced in Inventor 5

PlanarSketch.SetEndOfPart Method Introduced in Inventor 6

PlanarSketch.SketchToModelSpace Method Introduced in Inventor 5

PlanarSketch.UpdateProfiles Method Introduced in Inventor 9

PlanarSketch Properties

PlanarSketch.Adaptive Property Introduced in Inventor 5

PlanarSketch.AxisEntity Property Introduced in Inventor 5

PlanarSketch.AxisEntityGeometry Property Introduced in Inventor 5

PlanarSketch.AxisIsX Property Introduced in Inventor 5

PlanarSketch.Consumed Property Introduced in Inventor 8

PlanarSketch.CopyToFlatPattern Property

PlanarSketch.Dependents Property Introduced in Inventor 5

PlanarSketch.DimensionsVisible Property Introduced in Inventor 10

PlanarSketch.Exported Property

PlanarSketch.HasReferenceComponent Property Introduced in Inventor 5.3

PlanarSketch.HealthStatus Property Introduced in Inventor 11

PlanarSketch.IsOwnedByFeature Property Introduced in Inventor 2008

PlanarSketch.ModelToSketchTransform Property Introduced in Inventor 6

PlanarSketch.NaturalAxisDirection Property Introduced in Inventor 5

PlanarSketch.OriginPoint Property Introduced in Inventor 5

PlanarSketch.OriginPointGeometry Property Introduced in Inventor 5

PlanarSketch.OwnedBy Property Introduced in Inventor 2008

PlanarSketch.PlanarEntity Property Introduced in Inventor 5

PlanarSketch.PlanarEntityGeometry Property Introduced in Inventor 5

PlanarSketch.Profiles Property Introduced in Inventor 5

PlanarSketch.ProjectedCuts Property Introduced in Inventor 2010

PlanarSketch.ReferenceComponent Property Introduced in Inventor 5.3

PlanarSketch.ReferencedEntity Property Introduced in Inventor 5.3

PlanarSketch.Shared Property Introduced in Inventor 5

PlanarSketch.SketchBlocks Property Introduced in Inventor 2010

PlanarSketch.SketchToModelTransform Property Introduced in Inventor 6

PlanarSketches Interface Introduced in Inventor 5

PlanarSketches Methods

PlanarSketches.Add Method Introduced in Inventor 5

PlanarSketches.AddWithOrientation Method Introduced in Inventor 5

PlanarSketches.Item Method Introduced in Inventor 5

PlanarSketches Properties

PlanarSketches.Application Property Introduced in Inventor 5

PlanarSketches.Count Property Introduced in Inventor 5

PlanarSketches.Type Property Introduced in Inventor 5

PlanarSketchProxy Interface Introduced in Inventor 6

PlanarSketchProxy Properties

PlanarSketchProxy.ContainingOccurrence Property Introduced in Inventor 6

PlanarSketchProxy.NativeObject Property Introduced in Inventor 6

Plane Interface Introduced in Inventor 4

Plane Methods

Plane.DistanceTo Method Introduced in Inventor 9

Plane.GetPlaneData Method Introduced in Inventor 4

Plane.IntersectWithCurve Method Introduced in Inventor 2009

Plane.IntersectWithLine Method Introduced in Inventor 9

Plane.IntersectWithPlane Method Introduced in Inventor 9

Plane.IntersectWithSurface Method

Plane.IsCoplanarTo Method Introduced in Inventor 9

Plane.IsParallelTo Method Introduced in Inventor 9

Plane.IsPerpendicularTo Method Introduced in Inventor 9

Plane.PutPlaneData Method Introduced in Inventor 4

Plane Properties

Plane.Evaluator Property Introduced in Inventor 4

Plane.Normal Property Introduced in Inventor 4

Plane.RootPoint Property Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef Interface Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef Methods

PlaneAndOffsetWorkPlaneDef.GetData Method Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef Properties

PlaneAndOffsetWorkPlaneDef.Application Property Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef.Offset Property Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef.Parent Property Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef.Plane Property Introduced in Inventor 4

PlaneAndOffsetWorkPlaneDef.Type Property Introduced in Inventor 4

PlaneAndPointWorkPlaneDef Interface Introduced in Inventor 4

PlaneAndPointWorkPlaneDef Methods

PlaneAndPointWorkPlaneDef.GetData Method Introduced in Inventor 4

PlaneAndPointWorkPlaneDef Properties

PlaneAndPointWorkPlaneDef.Application Property Introduced in Inventor 4

PlaneAndPointWorkPlaneDef.Parent Property Introduced in Inventor 4

PlaneAndPointWorkPlaneDef.Plane Property Introduced in Inventor 4

PlaneAndPointWorkPlaneDef.Point Property Introduced in Inventor 4

PlaneAndPointWorkPlaneDef.Type Property Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef Interface Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef Methods

PlaneAndTangentWorkPlaneDef.GetData Method Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef Properties

PlaneAndTangentWorkPlaneDef.Application Property Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef.Face Property Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef.Parent Property Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef.Plane Property Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef.ProximityPoint Property Introduced in Inventor 4

PlaneAndTangentWorkPlaneDef.Type Property Introduced in Inventor 4

Point Interface Introduced in Inventor 4

Point Methods

Point.DistanceTo Method Introduced in Inventor 4

Point.GetPointData Method Introduced in Inventor 4

Point.IsEqualTo Method Introduced in Inventor 4

Point.PutPointData Method Introduced in Inventor 4

Point.TransformBy Method Introduced in Inventor 4

Point.TranslateBy Method Introduced in Inventor 4

Point.VectorTo Method Introduced in Inventor 4

Point Properties

Point.X Property Introduced in Inventor 4

Point.Y Property Introduced in Inventor 4

Point.Z Property Introduced in Inventor 4

Point2d Interface Introduced in Inventor 4

Point2d Methods

Point2d.DistanceTo Method Introduced in Inventor 11

Point2d.GetPointData Method Introduced in Inventor 4

Point2d.IsEqualTo Method Introduced in Inventor 2008

Point2d.PutPointData Method Introduced in Inventor 4

Point2d.TransformBy Method Introduced in Inventor 2008

Point2d.TranslateBy Method Introduced in Inventor 2008

Point2d.VectorTo Method Introduced in Inventor 2008

Point2d Properties

Point2d.X Property Introduced in Inventor 4

Point2d.Y Property Introduced in Inventor 4

PointAndPlaneDistanceDimConstraint3D Interface Introduced in Inventor 11

PointAndPlaneDistanceDimConstraint3D Properties

PointAndPlaneDistanceDimConstraint3D.Plane Property Introduced in Inventor 11

PointAndPlaneDistanceDimConstraint3D.Point Property Introduced in Inventor 11

PointAndPlaneDistanceDimConstraint3DProxy Interface Introduced in Inventor 11

PointAndPlaneDistanceDimConstraint3DProxy Properties

PointAndPlaneDistanceDimConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 11

PointAndPlaneDistanceDimConstraint3DProxy.NativeObject Property Introduced in Inventor 11

PointAndPlaneWorkAxisDef Interface

PointAndPlaneWorkAxisDef Methods

PointAndPlaneWorkAxisDef.GetData Method

PointAndPlaneWorkAxisDef Properties

PointAndPlaneWorkAxisDef.Application Property

PointAndPlaneWorkAxisDef.Parent Property

PointAndPlaneWorkAxisDef.Plane Property

PointAndPlaneWorkAxisDef.Point Property

PointAndPlaneWorkAxisDef.Type Property

PointAndTangentWorkPlaneDef Interface Introduced in Inventor 10

PointAndTangentWorkPlaneDef Methods

PointAndTangentWorkPlaneDef.GetData Method Introduced in Inventor 10

PointAndTangentWorkPlaneDef Properties

PointAndTangentWorkPlaneDef.Application Property Introduced in Inventor 10

PointAndTangentWorkPlaneDef.Face Property Introduced in Inventor 10

PointAndTangentWorkPlaneDef.Parent Property Introduced in Inventor 10

PointAndTangentWorkPlaneDef.Point Property Introduced in Inventor 10

PointAndTangentWorkPlaneDef.Type Property Introduced in Inventor 10

PointGraphics Interface Introduced in Inventor 5

PointGraphics Methods

PointGraphics.GetCustomImage Method Introduced in Inventor 2011

PointGraphics.SetCustomImage Method Introduced in Inventor 2011

PointGraphics Properties

PointGraphics.BurnThrough Property Introduced in Inventor 7

PointGraphics.CoordinateIndexSet Property Introduced in Inventor 5

PointGraphics.CoordinateSet Property Introduced in Inventor 5

PointGraphics.DepthPriority Property Introduced in Inventor 5

PointGraphics.PointRenderStyle Property Introduced in Inventor 5

PointHolePlacementDefinition Interface Introduced in Inventor 10

PointHolePlacementDefinition Properties

PointHolePlacementDefinition.Direction Property Introduced in Inventor 10

PointHolePlacementDefinition.Point Property Introduced in Inventor 10

PointInference Interface Introduced in Inventor 5

PointInference Properties

PointInference.Application Property Introduced in Inventor 5

PointInference.Entity Property Introduced in Inventor 5

PointInference.InferenceType Property Introduced in Inventor 5

PointInference.Type Property Introduced in Inventor 5

PointInferenceEnumerator Interface Introduced in Inventor 5

PointInferenceEnumerator Methods

PointInferenceEnumerator.Item Method Introduced in Inventor 5

PointInferenceEnumerator Properties

PointInferenceEnumerator.Count Property Introduced in Inventor 5

PointInferenceEnumerator.Type Property Introduced in Inventor 5

PointToPointRipTypeDef Interface Introduced in Inventor 2011

PointToPointRipTypeDef Properties

PointToPointRipTypeDef.GapSide Property Introduced in Inventor 2011

PointToPointRipTypeDef.GapSize Property Introduced in Inventor 2011

PointToPointRipTypeDef.Parent Property Introduced in Inventor 2011

PointToPointRipTypeDef.PointOne Property Introduced in Inventor 2011

PointToPointRipTypeDef.PointTwo Property Introduced in Inventor 2011

PointToPointRipTypeDef.Type Property Introduced in Inventor 2011

PointWorkPointDef Interface Introduced in Inventor 4

PointWorkPointDef Properties

PointWorkPointDef.Application Property Introduced in Inventor 4

PointWorkPointDef.Parent Property Introduced in Inventor 4

PointWorkPointDef.Point Property Introduced in Inventor 4

PointWorkPointDef.Type Property Introduced in Inventor 4

Polyline2d Interface Introduced in Inventor 2009

Polyline2d Methods

Polyline2d.GetPoints Method Introduced in Inventor 2009

Polyline2d.PutPoints Method Introduced in Inventor 2009

Polyline2d Properties

Polyline2d.Evaluator Property Introduced in Inventor 2009

Polyline2d.PointAtIndex Method Introduced in Inventor 2009

Polyline2d.PointCount Property Introduced in Inventor 2009

Polyline3d Interface Introduced in Inventor 2009

Polyline3d Methods

Polyline3d.GetPoints Method Introduced in Inventor 2009

Polyline3d.PointAtIndex Method Introduced in Inventor 2009

Polyline3d.PutPoints Method Introduced in Inventor 2009

Polyline3d Properties

Polyline3d.Evaluator Property Introduced in Inventor 2009

Polyline3d.PointCount Property Introduced in Inventor 2009

PositionalRepresentation Interface Introduced in Inventor 11

PositionalRepresentation Methods

PositionalRepresentation.Activate Method Introduced in Inventor 11

PositionalRepresentation.Copy Method Introduced in Inventor 11

PositionalRepresentation.Delete Method Introduced in Inventor 11

PositionalRepresentation.GetReferenceKey Method Introduced in Inventor 11

PositionalRepresentation.IsConstraintSuppressionOverridden Method Introduced in Inventor 11

PositionalRepresentation.IsConstraintValueOverridden Method Introduced in Inventor 11

PositionalRepresentation.IsFlexibleOverridden Method Introduced in Inventor 11

PositionalRepresentation.IsGroundingOverridden Method Introduced in Inventor 11

PositionalRepresentation.IsPatternAngleOffsetOverridden Method Introduced in Inventor 2008

PositionalRepresentation.IsPatternColumnOffsetOverridden Method Introduced in Inventor 2008

PositionalRepresentation.IsPatternRowOffsetOverridden Method Introduced in Inventor 2008

PositionalRepresentation.IsPositionalRepresentationOverridden Method Introduced in Inventor 11

PositionalRepresentation.IsTransformOverridden Method Introduced in Inventor 11

PositionalRepresentation.RemoveConstraintSuppressionOverride Method Introduced in Inventor 11

PositionalRepresentation.RemoveConstraintValueOverride Method Introduced in Inventor 11

PositionalRepresentation.RemoveFlexibleOverride Method Introduced in Inventor 11

PositionalRepresentation.RemoveGroundingOverride Method Introduced in Inventor 11

PositionalRepresentation.RemovePatternAngleOffsetOverride Method Introduced in Inventor 2008

PositionalRepresentation.RemovePatternColumnOffsetOverride Method Introduced in Inventor 2008

PositionalRepresentation.RemovePatternRowOffsetOverride Method Introduced in Inventor 2008

PositionalRepresentation.RemovePositionalRepresentationOverride Method Introduced in Inventor 11

PositionalRepresentation.RemoveTransformOverride Method Introduced in Inventor 11

PositionalRepresentation.SetConstraintSuppressionOverride Method Introduced in Inventor 11

PositionalRepresentation.SetConstraintValueOverride Method Introduced in Inventor 11

PositionalRepresentation.SetFlexibleOverride Method Introduced in Inventor 11

PositionalRepresentation.SetGroundingOverride Method Introduced in Inventor 11

PositionalRepresentation.SetPatternAngleOffsetOverride Method Introduced in Inventor 2008

PositionalRepresentation.SetPatternColumnOffsetOverride Method Introduced in Inventor 2008

PositionalRepresentation.SetPatternRowOffsetOverride Method Introduced in Inventor 2008

PositionalRepresentation.SetPositionalRepresentationOverride Method Introduced in Inventor 11

PositionalRepresentation.SetTransformOverride Method Introduced in Inventor 11

PositionalRepresentation Properties

PositionalRepresentation.Application Property Introduced in Inventor 11

PositionalRepresentation.AttributeSets Property Introduced in Inventor 11

PositionalRepresentation.Master Property Introduced in Inventor 11

PositionalRepresentation.Name Property Introduced in Inventor 11

PositionalRepresentation.Parent Property Introduced in Inventor 11

PositionalRepresentation.Type Property Introduced in Inventor 11

PositionalRepresentations Interface Introduced in Inventor 11

PositionalRepresentations Methods

PositionalRepresentations.Add Method Introduced in Inventor 11

PositionalRepresentations.Item Method Introduced in Inventor 11

PositionalRepresentations Properties

PositionalRepresentations.Application Property Introduced in Inventor 11

PositionalRepresentations.Count Property Introduced in Inventor 11

PositionalRepresentations.ExcelWorkSheet Property Introduced in Inventor 11

PositionalRepresentations.Type Property Introduced in Inventor 11

Preparations Interface Introduced in Inventor 2010

Preparations Methods

Preparations.Edit Method Introduced in Inventor 2010

Preparations.ExitEdit Method Introduced in Inventor 2010

Preparations Properties

Preparations.Application Property Introduced in Inventor 2010

Preparations.Type Property Introduced in Inventor 2010

PresentationDocument Interface Introduced in Inventor 4

PresentationDocument Properties

PresentationDocument.ActiveExplodedView Property Introduced in Inventor 11

PresentationDocument.ActiveLightingStyle Property

PresentationDocument.DisabledCommandList Property Introduced in Inventor 10

PresentationDocument.DisplaySettings Property Introduced in Inventor 2011

PresentationDocument.EnvironmentManager Property Introduced in Inventor 10

PresentationDocument.LightingStyles Property Introduced in Inventor 2010

PresentationDocument.PresentationExplodedViews Property Introduced in Inventor 11

PresentationExplodedView Interface Introduced in Inventor 11

PresentationExplodedView Methods

PresentationExplodedView.Activate Method Introduced in Inventor 11

PresentationExplodedView.Delete Method Introduced in Inventor 11

PresentationExplodedView.GetRenderStyle Method Introduced in Inventor 11

PresentationExplodedView.GetTransform Method Introduced in Inventor 11

PresentationExplodedView.GetVisibility Method Introduced in Inventor 11

PresentationExplodedView.SetRenderStyle Method Introduced in Inventor 11

PresentationExplodedView.SetVisibility Method Introduced in Inventor 11

PresentationExplodedView.Trails Method Introduced in Inventor 11

PresentationExplodedView Properties

PresentationExplodedView.Application Property Introduced in Inventor 11

PresentationExplodedView.Name Property Introduced in Inventor 11

PresentationExplodedView.Parent Property Introduced in Inventor 11

PresentationExplodedView.Type Property Introduced in Inventor 11

PresentationExplodedViews Interface Introduced in Inventor 11

PresentationExplodedViews Methods

PresentationExplodedViews.Item Method Introduced in Inventor 11

PresentationExplodedViews Properties

PresentationExplodedViews.Application Property Introduced in Inventor 11

PresentationExplodedViews.Count Property Introduced in Inventor 11

PresentationExplodedViews.Type Property Introduced in Inventor 11

PresentationOptions Interface Introduced in Inventor 2011

PresentationOptions Properties

PresentationOptions.Application Property Introduced in Inventor 2011

PresentationOptions.SkipAllUnresolvedFiles Property Introduced in Inventor 2011

PresentationOptions.Type Property Introduced in Inventor 2011

PrintManager Interface Introduced in Inventor 5

PrintManager Methods

PrintManager.PrintToFile Method Introduced in Inventor 6

PrintManager.SubmitPrint Method Introduced in Inventor 5

PrintManager Properties

PrintManager.Application Property Introduced in Inventor 5

PrintManager.ColorMode Property Introduced in Inventor 5

PrintManager.NumberOfCopies Property Introduced in Inventor 5

PrintManager.Orientation Property Introduced in Inventor 5

PrintManager.PaperHeight Property Introduced in Inventor 5

PrintManager.PaperSize Property Introduced in Inventor 5

PrintManager.PaperSource Property Introduced in Inventor 5

PrintManager.PaperWidth Property Introduced in Inventor 5

PrintManager.Printer Property Introduced in Inventor 5

PrintManager.PrinterDeviceContext Property Introduced in Inventor 9

PrintManager.Type Property Introduced in Inventor 5

Profile Interface Introduced in Inventor 5

Profile Methods

Profile.Delete Method Introduced in Inventor 9

Profile.GetReferenceKey Method Introduced in Inventor 5

Profile.Item Method Introduced in Inventor 5

Profile Properties

Profile.Application Property Introduced in Inventor 5

Profile.AttributeSets Property Introduced in Inventor 5

Profile.Count Property Introduced in Inventor 5

Profile.MergeFaces Property Introduced in Inventor 9

Profile.Parent Property Introduced in Inventor 5

Profile.RegionProperties Property Introduced in Inventor 2008

Profile.Type Property Introduced in Inventor 5

Profile.Wires Property Introduced in Inventor 2009

Profile3D Interface Introduced in Inventor 6

Profile3D Methods

Profile3D.Delete Method Introduced in Inventor 2009

Profile3D.GetReferenceKey Method Introduced in Inventor 6

Profile3D.Item Method Introduced in Inventor 6

Profile3D Properties

Profile3D.Application Property Introduced in Inventor 6

Profile3D.AttributeSets Property Introduced in Inventor 6

Profile3D.Count Property Introduced in Inventor 6

Profile3D.Parent Property Introduced in Inventor 6

Profile3D.Type Property Introduced in Inventor 6

Profile3D.Wires Property Introduced in Inventor 2009

Profile3DProxy Interface Introduced in Inventor 6

Profile3DProxy Properties

Profile3DProxy.ContainingOccurrence Property Introduced in Inventor 6

Profile3DProxy.NativeObject Property Introduced in Inventor 6

ProfileEntity Interface Introduced in Inventor 5

ProfileEntity Methods

ProfileEntity.GetReferenceKey Method Introduced in Inventor 5

ProfileEntity Properties

ProfileEntity.Application Property Introduced in Inventor 5

ProfileEntity.AttributeSets Property Introduced in Inventor 5

ProfileEntity.Curve Property Introduced in Inventor 5

ProfileEntity.CurveType Property Introduced in Inventor 5

ProfileEntity.EndSketchPoint Property Introduced in Inventor 5

ProfileEntity.OpposedToSketchEntity Property Introduced in Inventor 5

ProfileEntity.Parent Property Introduced in Inventor 5

ProfileEntity.SketchEntity Property Introduced in Inventor 5

ProfileEntity.StartSketchPoint Property Introduced in Inventor 5

ProfileEntity.Type Property Introduced in Inventor 5

ProfileEntity3D Interface Introduced in Inventor 6

ProfileEntity3D Methods

ProfileEntity3D.GetReferenceKey Method Introduced in Inventor 6

ProfileEntity3D Properties

ProfileEntity3D.Application Property Introduced in Inventor 6

ProfileEntity3D.AttributeSets Property Introduced in Inventor 6

ProfileEntity3D.Curve Property Introduced in Inventor 6

ProfileEntity3D.CurveType Property Introduced in Inventor 6

ProfileEntity3D.EndSketchPoint Property Introduced in Inventor 6

ProfileEntity3D.OpposedToSketchEntity Property Introduced in Inventor 6

ProfileEntity3D.Parent Property Introduced in Inventor 6

ProfileEntity3D.SketchEntity Property Introduced in Inventor 6

ProfileEntity3D.StartSketchPoint Property Introduced in Inventor 6

ProfileEntity3D.Type Property Introduced in Inventor 6

ProfileEntity3DProxy Interface Introduced in Inventor 6

ProfileEntity3DProxy Properties

ProfileEntity3DProxy.ContainingOccurrence Property Introduced in Inventor 6

ProfileEntity3DProxy.NativeObject Property Introduced in Inventor 6

ProfileEntityProxy Interface Introduced in Inventor 6

ProfileEntityProxy Properties

ProfileEntityProxy.ContainingOccurrence Property Introduced in Inventor 6

ProfileEntityProxy.NativeObject Property Introduced in Inventor 6

ProfilePath Interface Introduced in Inventor 5

ProfilePath Methods

ProfilePath.Delete Method Introduced in Inventor 9

ProfilePath.GetReferenceKey Method Introduced in Inventor 5

ProfilePath.Item Method Introduced in Inventor 5

ProfilePath Properties

ProfilePath.AddsMaterial Property Introduced in Inventor 5

ProfilePath.Application Property Introduced in Inventor 5

ProfilePath.AttributeSets Property Introduced in Inventor 5

ProfilePath.Closed Property Introduced in Inventor 5

ProfilePath.Count Property Introduced in Inventor 5

ProfilePath.Parent Property Introduced in Inventor 5

ProfilePath.TextBox Property Introduced in Inventor 11

ProfilePath.TextBoxPath Property Introduced in Inventor 11

ProfilePath.Type Property Introduced in Inventor 5

ProfilePath3D Interface Introduced in Inventor 6

ProfilePath3D Methods

ProfilePath3D.GetReferenceKey Method Introduced in Inventor 6

ProfilePath3D.Item Method Introduced in Inventor 6

ProfilePath3D Properties

ProfilePath3D.Application Property Introduced in Inventor 6

ProfilePath3D.AttributeSets Property Introduced in Inventor 6

ProfilePath3D.Closed Property Introduced in Inventor 6

ProfilePath3D.Count Property Introduced in Inventor 6

ProfilePath3D.Parent Property Introduced in Inventor 6

ProfilePath3D.Type Property Introduced in Inventor 6

ProfilePath3DProxy Interface Introduced in Inventor 6

ProfilePath3DProxy Properties

ProfilePath3DProxy.ContainingOccurrence Property Introduced in Inventor 6

ProfilePath3DProxy.NativeObject Property Introduced in Inventor 6

ProfilePathProxy Interface Introduced in Inventor 6

ProfilePathProxy Properties

ProfilePathProxy.ContainingOccurrence Property Introduced in Inventor 6

ProfilePathProxy.NativeObject Property Introduced in Inventor 6

ProfileProxy Interface Introduced in Inventor 6

ProfileProxy Properties

ProfileProxy.ContainingOccurrence Property Introduced in Inventor 6

ProfileProxy.NativeObject Property Introduced in Inventor 6

Profiles Interface Introduced in Inventor 5

Profiles Methods

Profiles.AddForSolid Method Introduced in Inventor 5

Profiles.AddForSurface Method Introduced in Inventor 5

Profiles.Item Method Introduced in Inventor 5

Profiles Properties

Profiles.Application Property Introduced in Inventor 5

Profiles.Count Property Introduced in Inventor 5

Profiles.Type Property Introduced in Inventor 5

Profiles3D Interface Introduced in Inventor 6

Profiles3D Methods

Profiles3D.AddClosed Method Introduced in Inventor 6

Profiles3D.AddOpen Method Introduced in Inventor 6

Profiles3D.Item Method Introduced in Inventor 6

Profiles3D Properties

Profiles3D.Application Property Introduced in Inventor 6

Profiles3D.Count Property Introduced in Inventor 6

Profiles3D.Type Property Introduced in Inventor 6

ProgressBar CoClass Introduced in Inventor 2010

ProgressBarObject Interface

ProgressBarObject Methods

ProgressBarObject.Close Method

ProgressBarObject.UpdateProgress Method

ProgressBarObject Properties

ProgressBarObject.Application Property

ProgressBarObject.Message Property

ProgressBarObject.Type Property

ProgressBarSink Interface

ProgressBarSink Methods

ProgressBarSink.OnCancel Method

ProgressiveToolTip Interface Introduced in Inventor 2011

ProgressiveToolTip Properties

ProgressiveToolTip.Application Property Introduced in Inventor 2011

ProgressiveToolTip.Description Property Introduced in Inventor 2011

ProgressiveToolTip.ExpandedDescription Property Introduced in Inventor 2011

ProgressiveToolTip.Image Property Introduced in Inventor 2011

ProgressiveToolTip.IsProgressive Property Introduced in Inventor 2011

ProgressiveToolTip.Parent Property Introduced in Inventor 2011

ProgressiveToolTip.Title Property Introduced in Inventor 2011

ProgressiveToolTip.Type Property Introduced in Inventor 2011

ProgressiveToolTip.Video Property

ProjectedCut Interface Introduced in Inventor 2010

ProjectedCut Methods

ProjectedCut.BreakLink Method Introduced in Inventor 2010

ProjectedCut.Delete Method Introduced in Inventor 2010

ProjectedCut.GetReferenceKey Method Introduced in Inventor 2010

ProjectedCut Properties

ProjectedCut.Application Property Introduced in Inventor 2010

ProjectedCut.AttributeSets Property Introduced in Inventor 2010

ProjectedCut.Name Property Introduced in Inventor 2010

ProjectedCut.Parent Property Introduced in Inventor 2010

ProjectedCut.SketchEntities Property Introduced in Inventor 2010

ProjectedCut.Type Property Introduced in Inventor 2010

ProjectedCutProxy Interface Introduced in Inventor 2010

ProjectedCutProxy Properties

ProjectedCutProxy.ContainingOccurrence Property Introduced in Inventor 2010

ProjectedCutProxy.NativeObject Property Introduced in Inventor 2010

ProjectedCuts Interface Introduced in Inventor 2010

ProjectedCuts Methods

ProjectedCuts.Add Method Introduced in Inventor 2010

ProjectedCuts.Item Method Introduced in Inventor 2010

ProjectedCuts Properties

ProjectedCuts.Application Property Introduced in Inventor 2010

ProjectedCuts.Count Property Introduced in Inventor 2010

ProjectedCuts.Type Property Introduced in Inventor 2010

ProjectPath Interface Introduced in Inventor 2011

ProjectPath Methods

ProjectPath.Delete Method

ProjectPath Properties

ProjectPath.Application Property Introduced in Inventor 2011

ProjectPath.Name Property Introduced in Inventor 2011

ProjectPath.Parent Property Introduced in Inventor 2011

ProjectPath.Path Property Introduced in Inventor 2011

ProjectPath.Type Property Introduced in Inventor 2011

ProjectPaths Interface Introduced in Inventor 2011

ProjectPaths Methods

ProjectPaths.Add Method Introduced in Inventor 2011

ProjectPaths.AddFromFile Method Introduced in Inventor 2011

ProjectPaths.Clear Method

ProjectPaths.Item Method Introduced in Inventor 2011

ProjectPaths Properties

ProjectPaths._NewEnum Property

ProjectPaths.Application Property Introduced in Inventor 2011

ProjectPaths.Count Property Introduced in Inventor 2011

ProjectPaths.Type Property Introduced in Inventor 2011

Property Interface Introduced in Inventor 4

Property Methods

Property.Delete Method Introduced in Inventor 4

Property Properties

Property.Dirty Property Introduced in Inventor 4

Property.DisplayName Property Introduced in Inventor 6

Property.Expression Property Introduced in Inventor 2008

Property.Name Property Introduced in Inventor 4

Property.Parent Property Introduced in Inventor 4

Property.PropId Property Introduced in Inventor 4

Property.Type Property Introduced in Inventor 4

Property.Value Property Introduced in Inventor 4

PropertySet Interface Introduced in Inventor 4

PropertySet Methods

PropertySet.Add Method Introduced in Inventor 4

PropertySet.Delete Method Introduced in Inventor 4

PropertySet.Item Method Introduced in Inventor 4

PropertySet.ItemByPropId Method Introduced in Inventor 4

PropertySet Properties

PropertySet.Count Property Introduced in Inventor 4

PropertySet.Dirty Property Introduced in Inventor 4

PropertySet.DisplayName Property Introduced in Inventor 4

PropertySet.InternalName Property Introduced in Inventor 4

PropertySet.Name Property Introduced in Inventor 8

PropertySet.Parent Property Introduced in Inventor 4

PropertySet.Type Property Introduced in Inventor 4

PropertySets Interface Introduced in Inventor 4

PropertySets Methods

PropertySets.Add Method Introduced in Inventor 4

PropertySets.FlushToFile Method Introduced in Inventor 4

PropertySets.Item Method Introduced in Inventor 4

PropertySets.RefreshFromFile Method Introduced in Inventor 4

PropertySets Properties

PropertySets.Count Property Introduced in Inventor 4

PropertySets.Dirty Property Introduced in Inventor 4

PropertySets.Parent Property Introduced in Inventor 4

PropertySets.Type Property Introduced in Inventor 4

PunchNote Interface Introduced in Inventor 2010

PunchNote Properties

PunchNote.FormattedPunchNote Property Introduced in Inventor 2010

PunchNote.FormattedQuantityNote Property Introduced in Inventor 2010

PunchNote.HideValue Property Introduced in Inventor 2010

PunchNote.PunchEdge Property Introduced in Inventor 2010

PunchNote.QuantityDefinition Property Introduced in Inventor 2010

PunchNote.UsePartUnits Property Introduced in Inventor 2010

PunchNotes Interface Introduced in Inventor 2010

PunchNotes Methods

PunchNotes.Add Method Introduced in Inventor 2010

PunchNotes.Item Method Introduced in Inventor 2010

PunchNotes Properties

PunchNotes.Application Property Introduced in Inventor 2010

PunchNotes.Count Property Introduced in Inventor 2010

PunchNotes.Type Property Introduced in Inventor 2010

PunchToolFeature Interface Introduced in Inventor 5.3

PunchToolFeature Properties

PunchToolFeature.Angle Property Introduced in Inventor 2009

PunchToolFeature.Depth Property Introduced in Inventor 2009

PunchToolFeature.iFeatureDefinition Property Introduced in Inventor 2009

PunchToolFeature.iFeatureTemplateDescriptor Property Introduced in Inventor 2009

PunchToolFeature.PunchCenterPoints Property Introduced in Inventor 2009

PunchToolFeatureProxy Interface Introduced in Inventor 9

PunchToolFeatures Interface Introduced in Inventor 5.3

PunchToolFeatures Methods

PunchToolFeatures.Add Method Introduced in Inventor 2009

PunchToolFeatures.CreateiFeatureDefinition Method Introduced in Inventor 2009

PunchToolFeatures.Item Method Introduced in Inventor 5.3

PunchToolFeatures Properties

PunchToolFeatures.Application Property Introduced in Inventor 5.3

PunchToolFeatures.Count Property Introduced in Inventor 5.3

PunchToolFeatures.Type Property Introduced in Inventor 5.3

RadialMarkingMenu Interface Introduced in Inventor 2012

RadialMarkingMenu Methods

RadialMarkingMenu.CreateRadialSubMenu Method Introduced in Inventor 2012

RadialMarkingMenu Properties

RadialMarkingMenu.Application Property

RadialMarkingMenu.EastControl Property Introduced in Inventor 2012

RadialMarkingMenu.NorthControl Property Introduced in Inventor 2012

RadialMarkingMenu.NortheastControl Property Introduced in Inventor 2012

RadialMarkingMenu.NorthwestControl Property Introduced in Inventor 2012

RadialMarkingMenu.SouthControl Property Introduced in Inventor 2012

RadialMarkingMenu.SoutheastControl Property Introduced in Inventor 2012

RadialMarkingMenu.SouthwestControl Property Introduced in Inventor 2012

RadialMarkingMenu.Type Property

RadialMarkingMenu.WestControl Property Introduced in Inventor 2012

RadiusDimConstraint Interface Introduced in Inventor 5

RadiusDimConstraint Properties

RadiusDimConstraint.Entity Property Introduced in Inventor 5

RadiusDimConstraint3D Interface Introduced in Inventor 2010

RadiusDimConstraint3D Properties

RadiusDimConstraint3D.Entity Property Introduced in Inventor 2010

RadiusDimConstraint3DProxy Interface Introduced in Inventor 2010

RadiusDimConstraint3DProxy Properties

RadiusDimConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 2010

RadiusDimConstraint3DProxy.NativeObject Property Introduced in Inventor 2010

RadiusDimConstraintProxy Interface Introduced in Inventor 6

RadiusDimConstraintProxy Properties

RadiusDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

RadiusDimConstraintProxy.NativeObject Property Introduced in Inventor 6

RadiusGeneralDimension Interface Introduced in Inventor 11

RadiusGeneralDimension Properties

RadiusGeneralDimension.Intent Property Introduced in Inventor 11

RadiusGeneralDimension.Jogged Property Introduced in Inventor 11

RadiusGeneralDimension.LeaderFromCenter Property Introduced in Inventor 11

RectangularOccurrencePattern Interface Introduced in Inventor 6

RectangularOccurrencePattern Methods

RectangularOccurrencePattern.OccurrencePatternElement Method Introduced in Inventor 6

RectangularOccurrencePattern Properties

RectangularOccurrencePattern.ColumnCount Property Introduced in Inventor 6

RectangularOccurrencePattern.ColumnEntity Property Introduced in Inventor 6

RectangularOccurrencePattern.ColumnEntityNaturalDirection Property Introduced in Inventor 6

RectangularOccurrencePattern.ColumnOffset Property Introduced in Inventor 6

RectangularOccurrencePattern.RowCount Property Introduced in Inventor 6

RectangularOccurrencePattern.RowEntity Property Introduced in Inventor 6

RectangularOccurrencePattern.RowEntityNaturalDirection Property Introduced in Inventor 6

RectangularOccurrencePattern.RowOffset Property Introduced in Inventor 6

RectangularOccurrencePatternProxy Interface Introduced in Inventor 2010

RectangularOccurrencePatternProxy Properties

RectangularOccurrencePatternProxy.ContainingOccurrence Property Introduced in Inventor 2010

RectangularOccurrencePatternProxy.NativeObject Property Introduced in Inventor 2010

RectangularPatternFeature Interface Introduced in Inventor 5

RectangularPatternFeature Methods

RectangularPatternFeature.AddParticipant Method Introduced in Inventor 2010

RectangularPatternFeature Properties

RectangularPatternFeature.ComputeType Property Introduced in Inventor 9

RectangularPatternFeature.NaturalXDirection Property Introduced in Inventor 5

RectangularPatternFeature.NaturalYDirection Property Introduced in Inventor 5

RectangularPatternFeature.NewBodyOperation Property Introduced in Inventor 2010

RectangularPatternFeature.OrientationMethod Property Introduced in Inventor 6

RectangularPatternFeature.ParentFeatures Property Introduced in Inventor 5

RectangularPatternFeature.PatternElements Property Introduced in Inventor 5

RectangularPatternFeature.PatternOfBody Property Introduced in Inventor 9

RectangularPatternFeature.SurfacesOpaque Property Introduced in Inventor 11

RectangularPatternFeature.SurfacesVisible Property Introduced in Inventor 11

RectangularPatternFeature.XCount Property Introduced in Inventor 5

RectangularPatternFeature.XDirectionEntity Property Introduced in Inventor 5

RectangularPatternFeature.XDirectionMidPlanePattern Property Introduced in Inventor 11

RectangularPatternFeature.XDirectionSpacingType Property Introduced in Inventor 6

RectangularPatternFeature.XDirectionStartPoint Property Introduced in Inventor 6

RectangularPatternFeature.XSpacing Property Introduced in Inventor 5

RectangularPatternFeature.YCount Property Introduced in Inventor 5

RectangularPatternFeature.YDirectionEntity Property Introduced in Inventor 5

RectangularPatternFeature.YDirectionMidPlanePattern Property Introduced in Inventor 11

RectangularPatternFeature.YDirectionSpacingType Property Introduced in Inventor 6

RectangularPatternFeature.YDirectionStartPoint Property Introduced in Inventor 6

RectangularPatternFeature.YSpacing Property Introduced in Inventor 5

RectangularPatternFeatureProxy Interface Introduced in Inventor 9

RectangularPatternFeatureProxy Properties

RectangularPatternFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

RectangularPatternFeatureProxy.NativeObject Property Introduced in Inventor 9

RectangularPatternFeatures Interface Introduced in Inventor 5

RectangularPatternFeatures Methods

RectangularPatternFeatures.Add Method Introduced in Inventor 5.3

RectangularPatternFeatures Properties

RectangularPatternFeatures.Application Property Introduced in Inventor 5

RectangularPatternFeatures.Count Property Introduced in Inventor 5

RectangularPatternFeatures.Item Method Introduced in Inventor 5

RectangularPatternFeatures.Type Property Introduced in Inventor 5

ReferenceComponent Interface Introduced in Inventor 5.3

ReferenceComponent Methods

ReferenceComponent.BreakLinkToFile Method Introduced in Inventor 5.3

ReferenceComponent.Delete Method Introduced in Inventor 5.3

ReferenceComponent.GetReferenceKey Method Introduced in Inventor 11

ReferenceComponent.ReferencedFile Method

ReferenceComponent.SetEndOfPart Method Introduced in Inventor 7

ReferenceComponent Properties

ReferenceComponent.Application Property Introduced in Inventor 5.3

ReferenceComponent.AttributeSets Property Introduced in Inventor 11

ReferenceComponent.HealthStatus Property Introduced in Inventor 5.3

ReferenceComponent.IsEmbedded Property Introduced in Inventor 6

ReferenceComponent.LinkedToFile Property Introduced in Inventor 5.3

ReferenceComponent.Name Property Introduced in Inventor 5.3

ReferenceComponent.Parent Property Introduced in Inventor 5.3

ReferenceComponent.ReferencedDocumentDescriptor Property Introduced in Inventor 11

ReferenceComponent.Type Property Introduced in Inventor 5.3

ReferenceComponents Interface Introduced in Inventor 5.3

ReferenceComponents Properties

ReferenceComponents.Application Property Introduced in Inventor 5.3

ReferenceComponents.DerivedAliasComponents Property Introduced in Inventor 2010

ReferenceComponents.DerivedAssemblyComponents Property Introduced in Inventor 5.3

ReferenceComponents.DerivedPartComponents Property Introduced in Inventor 5.3

ReferenceComponents.iFeatureTemplateDescriptors Property Introduced in Inventor 5.3

ReferenceComponents.Type Property Introduced in Inventor 5.3

ReferencedOLEFileDescriptor Interface Introduced in Inventor 4

ReferencedOLEFileDescriptor Methods

ReferencedOLEFileDescriptor.Activate Method Introduced in Inventor 4

ReferencedOLEFileDescriptor.Delete Method Introduced in Inventor 9

ReferencedOLEFileDescriptor.GetReferenceKey Method Introduced in Inventor 2011

ReferencedOLEFileDescriptor Properties

ReferencedOLEFileDescriptor.Application Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.AttributeSets Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.BrowserVisible Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.DisplayName Property Introduced in Inventor 4

ReferencedOLEFileDescriptor.FileDescriptor Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.FullFileName Property Introduced in Inventor 4

ReferencedOLEFileDescriptor.LastKnownFileTime Property Introduced in Inventor 9

ReferencedOLEFileDescriptor.LogicalName Property Introduced in Inventor 4

ReferencedOLEFileDescriptor.OLEDocumentType Property Introduced in Inventor 4

ReferencedOLEFileDescriptor.Parent Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.ReferenceMonitoring Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.ReferenceStatus Property Introduced in Inventor 9

ReferencedOLEFileDescriptor.Type Property Introduced in Inventor 2011

ReferencedOLEFileDescriptor.Visible Property Introduced in Inventor 2011

ReferencedOLEFileDescriptors Interface Introduced in Inventor 4

ReferencedOLEFileDescriptors Methods

ReferencedOLEFileDescriptors.Add Method Introduced in Inventor 9

ReferencedOLEFileDescriptors.Item Method Introduced in Inventor 4

ReferencedOLEFileDescriptors.ItemByName Method Introduced in Inventor 2011

ReferencedOLEFileDescriptors Properties

ReferencedOLEFileDescriptors.Application Property Introduced in Inventor 2011

ReferencedOLEFileDescriptors.Count Property Introduced in Inventor 4

ReferencedOLEFileDescriptors.Type Property Introduced in Inventor 4

ReferenceFeature Interface Introduced in Inventor 5.3

ReferenceFeature Properties

ReferenceFeature.ReferenceComponent Property Introduced in Inventor 5.3

ReferenceFeature.ReferencedEntity Property Introduced in Inventor 5.3

ReferenceFeatureProxy Interface Introduced in Inventor 9

ReferenceFeatureProxy Properties

ReferenceFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ReferenceFeatureProxy.NativeObject Property Introduced in Inventor 9

ReferenceFeatures Interface Introduced in Inventor 5.3

ReferenceFeatures Methods

ReferenceFeatures.Item Method Introduced in Inventor 5.3

ReferenceFeatures Properties

ReferenceFeatures.Application Property Introduced in Inventor 5.3

ReferenceFeatures.Count Property Introduced in Inventor 5.3

ReferenceFeatures.Type Property Introduced in Inventor 5.3

ReferenceFeaturesEnumerator Interface Introduced in Inventor 5.3

ReferenceFeaturesEnumerator Methods

ReferenceFeaturesEnumerator.Item Method Introduced in Inventor 5.3

ReferenceFeaturesEnumerator Properties

ReferenceFeaturesEnumerator.Count Property Introduced in Inventor 5.3

ReferenceFeaturesEnumerator.Type Property Introduced in Inventor 5.3

ReferenceKeyEventsObject Interface Introduced in Inventor 2012

ReferenceKeyEventsObject Properties

ReferenceKeyEventsObject.Application Property Introduced in Inventor 2012

ReferenceKeyEventsObject.Type Property Introduced in Inventor 2012

ReferenceKeyEventsSink Interface

ReferenceKeyEventsSink Methods

ReferenceKeyEventsSink.OnBindKeyToObject Method Introduced in Inventor 2012

ReferenceKeyManager Interface Introduced in Inventor 5

ReferenceKeyManager Methods

ReferenceKeyManager.BindKeyToObject Method Introduced in Inventor 5

ReferenceKeyManager.CanBindKeyToObject Method Introduced in Inventor 11

ReferenceKeyManager.CreateKeyContext Method Introduced in Inventor 5

ReferenceKeyManager.KeyToString Method Introduced in Inventor 10

ReferenceKeyManager.LoadContextFromArray Method Introduced in Inventor 5

ReferenceKeyManager.SaveContextToArray Method Introduced in Inventor 5

ReferenceKeyManager.StringToKey Method Introduced in Inventor 10

ReferenceKeyManager Properties

ReferenceKeyManager.Application Property Introduced in Inventor 5

ReferenceKeyManager.Parent Property Introduced in Inventor 5

ReferenceKeyManager.Type Property Introduced in Inventor 5

ReferenceParameter Interface Introduced in Inventor 4

ReferenceParameter Methods

ReferenceParameter.ConvertToModelParameter Method Introduced in Inventor 10

ReferenceParameter.ConvertToUserParameter Method Introduced in Inventor 11

ReferenceParameter Properties

ReferenceParameter.BuiltIn Property Introduced in Inventor 10

ReferenceParameter.Renamed Property Introduced in Inventor 2008

ReferenceParameters Interface Introduced in Inventor 4

ReferenceParameters Methods

ReferenceParameters._AddByValue Method

ReferenceParameters.AddByExpression Method Introduced in Inventor 10

ReferenceParameters.AddByValue Method Introduced in Inventor 10

ReferenceParameters.Item Method Introduced in Inventor 4

ReferenceParameters Properties

ReferenceParameters.Count Property Introduced in Inventor 4

ReferenceParameters.Type Property Introduced in Inventor 4

RefoldFeature Interface Introduced in Inventor 2010

RefoldFeature Methods

RefoldFeature.Edit Method Introduced in Inventor 2010

RefoldFeature Properties

RefoldFeature.Bends Property Introduced in Inventor 2010

RefoldFeature.InputSketches Property Introduced in Inventor 2010

RefoldFeature.ResultSketches Property Introduced in Inventor 2010

RefoldFeature.StationaryFace Property Introduced in Inventor 2010

RefoldFeatureProxy Interface Introduced in Inventor 2010

RefoldFeatures Interface Introduced in Inventor 2010

RefoldFeatures Methods

RefoldFeatures.Add Method Introduced in Inventor 2010

RefoldFeatures.Item Method Introduced in Inventor 2010

RefoldFeatures Properties

RefoldFeatures.Application Property Introduced in Inventor 2010

RefoldFeatures.Count Property Introduced in Inventor 2010

RefoldFeatures.Type Property Introduced in Inventor 2010

RegionProperties Interface Introduced in Inventor 2008

RegionProperties Methods

RegionProperties.CentroidMomentsOfInertia Method

RegionProperties.GetTorsionProperties Method Introduced in Inventor 2009

RegionProperties.MomentsOfInertia Method Introduced in Inventor 2008

RegionProperties.PrincipalAxes Method Introduced in Inventor 2008

RegionProperties.PrincipalMomentsOfInertia Method Introduced in Inventor 2008

RegionProperties.RadiusOfGyration Method Introduced in Inventor 2008

RegionProperties Properties

RegionProperties.Accuracy Property Introduced in Inventor 2008

RegionProperties.Application Property Introduced in Inventor 2008

RegionProperties.Area Property Introduced in Inventor 2008

RegionProperties.Centroid Property Introduced in Inventor 2008

RegionProperties.Parent Property Introduced in Inventor 2008

RegionProperties.Perimeter Property Introduced in Inventor 2008

RegionProperties.RotationAngle Property Introduced in Inventor 2008

RegionProperties.Type Property Introduced in Inventor 2008

RenderStyle Interface Introduced in Inventor 5

RenderStyle Methods

RenderStyle.ApproximateFromRealisticAppearance Method

RenderStyle.ConvertToLocal Method Introduced in Inventor 9

RenderStyle.Copy Method Introduced in Inventor 5

RenderStyle.Delete Method Introduced in Inventor 5

RenderStyle.GetAmbientColor Method Introduced in Inventor 5

RenderStyle.GetDiffuseColor Method Introduced in Inventor 5

RenderStyle.GetEmissiveColor Method Introduced in Inventor 5

RenderStyle.GetReferenceKey Method Introduced in Inventor 9

RenderStyle.GetSpecularColor Method Introduced in Inventor 5

RenderStyle.SaveToGlobal Method Introduced in Inventor 9

RenderStyle.SetAmbientColor Method Introduced in Inventor 5

RenderStyle.SetDiffuseColor Method Introduced in Inventor 5

RenderStyle.SetEmissiveColor Method Introduced in Inventor 5

RenderStyle.SetSpecularColor Method Introduced in Inventor 5

RenderStyle.UpdateFromGlobal Method Introduced in Inventor 9

RenderStyle Properties

RenderStyle.Application Property Introduced in Inventor 7

RenderStyle.AttributeSets Property Introduced in Inventor 9

RenderStyle.BumpMapAmount Property

RenderStyle.BumpMapImageFilename Property

RenderStyle.BumpMapInvert Property

RenderStyle.BumpMapRotation Property

RenderStyle.BumpMapScale Property

RenderStyle.DisplayInteriorFaces Property Introduced in Inventor 9

RenderStyle.InternalName Property Introduced in Inventor 9

RenderStyle.InUse Property Introduced in Inventor 9

RenderStyle.Name Property Introduced in Inventor 5

RenderStyle.Opacity Property Introduced in Inventor 5

RenderStyle.Parent Property Introduced in Inventor 5

RenderStyle.RealisticAppearanceInternalName Property

RenderStyle.RealisticAppearanceName Property

RenderStyle.RealisticAppearanceRotation Property

RenderStyle.RealisticAppearanceScale Property

RenderStyle.RealisticAppearanceThumbnail Property

RenderStyle.Reflectivity Property Introduced in Inventor 5

RenderStyle.StyleLocation Property Introduced in Inventor 9

RenderStyle.TextureFilename Property Introduced in Inventor 5

RenderStyle.TextureRotation Property Introduced in Inventor 5

RenderStyle.TextureScale Property Introduced in Inventor 5

RenderStyle.Type Property Introduced in Inventor 5

RenderStyle.UpToDate Property Introduced in Inventor 9

RenderStyles Interface Introduced in Inventor 5

RenderStyles Methods

RenderStyles.Add Method Introduced in Inventor 5

RenderStyles.Item Method Introduced in Inventor 5

RenderStyles Properties

RenderStyles.Application Property Introduced in Inventor 7

RenderStyles.Count Property Introduced in Inventor 5

RenderStyles.Parent Property Introduced in Inventor 5

RenderStyles.Type Property Introduced in Inventor 5

ReplaceFaceFeature Interface Introduced in Inventor 6

ReplaceFaceFeatureProxy Interface Introduced in Inventor 9

ReplaceFaceFeatureProxy Properties

ReplaceFaceFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ReplaceFaceFeatureProxy.NativeObject Property Introduced in Inventor 9

ReplaceFaceFeatures Interface Introduced in Inventor 6

ReplaceFaceFeatures Methods

ReplaceFaceFeatures.Item Method Introduced in Inventor 6

ReplaceFaceFeatures Properties

ReplaceFaceFeatures.Application Property Introduced in Inventor 6

ReplaceFaceFeatures.Count Property Introduced in Inventor 6

ReplaceFaceFeatures.Type Property Introduced in Inventor 6

RepresentationEvents CoClass Introduced in Inventor 11

RepresentationEventsObject Interface Introduced in Inventor 11

RepresentationEventsObject Properties

RepresentationEventsObject.Application Property Introduced in Inventor 11

RepresentationEventsObject.Parent Property Introduced in Inventor 11

RepresentationEventsObject.Type Property Introduced in Inventor 11

RepresentationEventsSink Interface Introduced in Inventor 11

RepresentationEventsSink Methods

RepresentationEventsSink.OnActivateDesignView Method Introduced in Inventor 2012

RepresentationEventsSink.OnActivateLevelOfDetailRepresentation Method Introduced in Inventor 11

RepresentationEventsSink.OnActivatePositionalRepresentation Method Introduced in Inventor 11

RepresentationEventsSink.OnDelete Method Introduced in Inventor 11

RepresentationEventsSink.OnNewDesignView Method Introduced in Inventor 2012

RepresentationEventsSink.OnNewLevelOfDetailRepresentation Method Introduced in Inventor 11

RepresentationEventsSink.OnNewPositionalRepresentation Method Introduced in Inventor 11

RepresentationsManager Interface Introduced in Inventor 11

RepresentationsManager Methods

RepresentationsManager._Parent Method

RepresentationsManager Properties

RepresentationsManager.ActiveDesignViewRepresentation Property Introduced in Inventor 11

RepresentationsManager.ActiveLevelOfDetailRepresentation Property Introduced in Inventor 11

RepresentationsManager.ActivePositionalRepresentation Property Introduced in Inventor 11

RepresentationsManager.Application Property Introduced in Inventor 11

RepresentationsManager.DesignViewRepresentations Property Introduced in Inventor 11

RepresentationsManager.LevelOfDetailRepresentations Property Introduced in Inventor 11

RepresentationsManager.Parent Property Introduced in Inventor 2012

RepresentationsManager.PositionalRepresentations Property Introduced in Inventor 11

RepresentationsManager.Type Property Introduced in Inventor 11

RestFeature Interface Introduced in Inventor 2010

RestFeatureProxy Interface Introduced in Inventor 2010

RestFeatureProxy Properties

RestFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

RestFeatureProxy.NativeObject Property Introduced in Inventor 2010

RestFeatures Interface Introduced in Inventor 2010

RestFeatures Methods

RestFeatures.Item Method Introduced in Inventor 2010

RestFeatures Properties

RestFeatures.Application Property Introduced in Inventor 2010

RestFeatures.Count Property Introduced in Inventor 2010

RestFeatures.Type Property Introduced in Inventor 2010

RevisionTable Interface Introduced in Inventor 10

RevisionTable Methods

RevisionTable.Delete Method Introduced in Inventor 10

RevisionTable.Export Method Introduced in Inventor 2012

RevisionTable.GetReferenceKey Method Introduced in Inventor 10

RevisionTable.Sort Method Introduced in Inventor 2012

RevisionTable Properties

RevisionTable.Application Property Introduced in Inventor 10

RevisionTable.AttributeSets Property Introduced in Inventor 10

RevisionTable.ColumnHeaderTextStyle Property Introduced in Inventor 2012

RevisionTable.DataTextStyle Property Introduced in Inventor 2012

RevisionTable.HeadingGap Property Introduced in Inventor 2012

RevisionTable.HeadingPlacement Property Introduced in Inventor 2012

RevisionTable.IsSheetScope Property Introduced in Inventor 2012

RevisionTable.Layer Property Introduced in Inventor 10

RevisionTable.MaximumRows Property Introduced in Inventor 2012

RevisionTable.NumberOfSections Property Introduced in Inventor 2012

RevisionTable.Parent Property Introduced in Inventor 10

RevisionTable.Position Property Introduced in Inventor 10

RevisionTable.RangeBox Property Introduced in Inventor 2010

RevisionTable.RevisionTableColumns Property Introduced in Inventor 10

RevisionTable.RevisionTableRows Property Introduced in Inventor 10

RevisionTable.Rotation Property Introduced in Inventor 2012

RevisionTable.RowGap Property Introduced in Inventor 2012

RevisionTable.RowLineSpacing Property Introduced in Inventor 2012

RevisionTable.ShowTitle Property Introduced in Inventor 2012

RevisionTable.Style Property Introduced in Inventor 2011

RevisionTable.TableDirection Property Introduced in Inventor 2012

RevisionTable.Title Property Introduced in Inventor 10

RevisionTable.TitleTextStyle Property Introduced in Inventor 2012

RevisionTable.Type Property Introduced in Inventor 10

RevisionTable.UpdatePropertyToRevisionNumber Property Introduced in Inventor 2012

RevisionTable.WrapAutomatically Property Introduced in Inventor 2012

RevisionTable.WrapLeft Property Introduced in Inventor 2012

RevisionTableCell Interface Introduced in Inventor 10

RevisionTableCell Properties

RevisionTableCell.Application Property Introduced in Inventor 10

RevisionTableCell.FormattedText Property Introduced in Inventor 10

RevisionTableCell.Parent Property Introduced in Inventor 10

RevisionTableCell.StackedTextPosition Property Introduced in Inventor 2009

RevisionTableCell.Text Property Introduced in Inventor 10

RevisionTableCell.Type Property Introduced in Inventor 10

RevisionTableColumn Interface Introduced in Inventor 10

RevisionTableColumn Methods

RevisionTableColumn.Delete Method Introduced in Inventor 2008

RevisionTableColumn.GetFilePropertyId Method Introduced in Inventor 2012

RevisionTableColumn.Reposition Method Introduced in Inventor 2012

RevisionTableColumn Properties

RevisionTableColumn.Application Property Introduced in Inventor 10

RevisionTableColumn.CustomPropertyName Property Introduced in Inventor 2012

RevisionTableColumn.Parent Property Introduced in Inventor 10

RevisionTableColumn.PropertyType Property Introduced in Inventor 2012

RevisionTableColumn.Title Property Introduced in Inventor 10

RevisionTableColumn.TitleHorizontalJustification Property Introduced in Inventor 2008

RevisionTableColumn.Type Property Introduced in Inventor 10

RevisionTableColumn.ValueHorizontalJustification Property Introduced in Inventor 2008

RevisionTableColumn.Width Property Introduced in Inventor 2010

RevisionTableColumns Interface Introduced in Inventor 10

RevisionTableColumns Methods

RevisionTableColumns.Add Method Introduced in Inventor 2012

RevisionTableColumns.Item Method Introduced in Inventor 10

RevisionTableColumns Properties

RevisionTableColumns.Application Property Introduced in Inventor 10

RevisionTableColumns.Count Property Introduced in Inventor 10

RevisionTableColumns.Type Property Introduced in Inventor 10

RevisionTableRow Interface Introduced in Inventor 10

RevisionTableRow Methods

RevisionTableRow.Delete Method Introduced in Inventor 10

RevisionTableRow.Item Method Introduced in Inventor 10

RevisionTableRow.Reposition Method Introduced in Inventor 2012

RevisionTableRow Properties

RevisionTableRow.Application Property Introduced in Inventor 10

RevisionTableRow.Count Property Introduced in Inventor 10

RevisionTableRow.Custom Property

RevisionTableRow.Height Property Introduced in Inventor 2010

RevisionTableRow.IsActiveRow Property Introduced in Inventor 2008

RevisionTableRow.Parent Property Introduced in Inventor 10

RevisionTableRow.Type Property Introduced in Inventor 10

RevisionTableRow.Visible Property Introduced in Inventor 2012

RevisionTableRows Interface Introduced in Inventor 10

RevisionTableRows Methods

RevisionTableRows.Add Method Introduced in Inventor 10

RevisionTableRows.AddCustom Method Introduced in Inventor 2012

RevisionTableRows.Item Method Introduced in Inventor 10

RevisionTableRows Properties

RevisionTableRows.Application Property Introduced in Inventor 10

RevisionTableRows.Count Property Introduced in Inventor 10

RevisionTableRows.Type Property Introduced in Inventor 10

RevisionTables Interface Introduced in Inventor 10

RevisionTables Methods

RevisionTables.Add Method Introduced in Inventor 10

RevisionTables.Add2 Method Introduced in Inventor 2012

RevisionTables.Item Method Introduced in Inventor 10

RevisionTables Properties

RevisionTables.Application Property Introduced in Inventor 10

RevisionTables.Count Property Introduced in Inventor 10

RevisionTables.Type Property Introduced in Inventor 10

RevisionTableStyle Interface Introduced in Inventor 2011

RevisionTableStyle Methods

RevisionTableStyle.AddColumn Method Introduced in Inventor 2011

RevisionTableStyle.RemoveAllColumns Method

RevisionTableStyle Properties

RevisionTableStyle.AllowLandingLineForRevisionTags Property Introduced in Inventor 2011

RevisionTableStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2011

RevisionTableStyle.DataTextStyle Property Introduced in Inventor 2011

RevisionTableStyle.HeadingGap Property Introduced in Inventor 2011

RevisionTableStyle.HeadingPlacement Property Introduced in Inventor 2011

RevisionTableStyle.InsideLineColor Property Introduced in Inventor 2011

RevisionTableStyle.InsideLineWeight Property Introduced in Inventor 2011

RevisionTableStyle.OutsideLineColor Property Introduced in Inventor 2011

RevisionTableStyle.OutsideLineWeight Property Introduced in Inventor 2011

RevisionTableStyle.RevisionTagLeaderStyle Property Introduced in Inventor 2011

RevisionTableStyle.RevisionTagShape Property Introduced in Inventor 2011

RevisionTableStyle.RevisionTagTextStyle Property Introduced in Inventor 2011

RevisionTableStyle.RowGap Property Introduced in Inventor 2011

RevisionTableStyle.RowLineSpacing Property Introduced in Inventor 2011

RevisionTableStyle.ShowTitle Property Introduced in Inventor 2011

RevisionTableStyle.TableDirection Property Introduced in Inventor 2011

RevisionTableStyle.Title Property Introduced in Inventor 2011

RevisionTableStyle.TitleTextStyle Property Introduced in Inventor 2011

RevisionTableStylesEnumerator Interface Introduced in Inventor 2011

RevisionTableStylesEnumerator Methods

RevisionTableStylesEnumerator.Item Method Introduced in Inventor 2011

RevisionTableStylesEnumerator Properties

RevisionTableStylesEnumerator._NewEnum Property

RevisionTableStylesEnumerator.Application Property Introduced in Inventor 2011

RevisionTableStylesEnumerator.Count Property Introduced in Inventor 2011

RevisionTableStylesEnumerator.Type Property Introduced in Inventor 2011

RevolutionAndHeightCoilExtent Interface Introduced in Inventor 5.3

RevolutionAndHeightCoilExtent Properties

RevolutionAndHeightCoilExtent.Height Property Introduced in Inventor 2010

RevolutionAndHeightCoilExtent.Revolution Property Introduced in Inventor 5.3

RevolutionAndHeightCoilExtent.TaperAngle Property Introduced in Inventor 5.3

RevolvedFaceWorkAxisDef Interface Introduced in Inventor 4

RevolvedFaceWorkAxisDef Properties

RevolvedFaceWorkAxisDef.Application Property Introduced in Inventor 4

RevolvedFaceWorkAxisDef.Face Property Introduced in Inventor 4

RevolvedFaceWorkAxisDef.Parent Property Introduced in Inventor 4

RevolvedFaceWorkAxisDef.Type Property Introduced in Inventor 4

RevolveFeature Interface Introduced in Inventor 5

RevolveFeature Methods

RevolveFeature.AddParticipant Method Introduced in Inventor 11

RevolveFeature.SetAngleExtent Method Introduced in Inventor 11

RevolveFeature.SetFromToExtent Method Introduced in Inventor 2008

RevolveFeature.SetFullExtent Method Introduced in Inventor 11

RevolveFeature.SetToFaceExtent Method Introduced in Inventor 2008

RevolveFeature.SetToNextExtent Method Introduced in Inventor 2008

RevolveFeature Properties

RevolveFeature.AxisEntity Property Introduced in Inventor 5

RevolveFeature.EndFaces Property Introduced in Inventor 5

RevolveFeature.Extent Property Introduced in Inventor 5

RevolveFeature.ExtentTwo Property

RevolveFeature.ExtentTwoType Property

RevolveFeature.ExtentType Property Introduced in Inventor 5

RevolveFeature.IsTwoDirectional Property

RevolveFeature.Operation Property Introduced in Inventor 5

RevolveFeature.Profile Property Introduced in Inventor 5

RevolveFeature.SideFaces Property Introduced in Inventor 5

RevolveFeature.StartFaces Property Introduced in Inventor 5

RevolveFeatureProxy Interface Introduced in Inventor 9

RevolveFeatureProxy Properties

RevolveFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

RevolveFeatureProxy.NativeObject Property Introduced in Inventor 9

RevolveFeatures Interface Introduced in Inventor 5

RevolveFeatures Methods

RevolveFeatures.AddByAngle Method Introduced in Inventor 5

RevolveFeatures.AddByFromToExtent Method Introduced in Inventor 2008

RevolveFeatures.AddByToFaceExtent Method Introduced in Inventor 2008

RevolveFeatures.AddByToNextExtent Method Introduced in Inventor 2008

RevolveFeatures.AddFull Method Introduced in Inventor 5

RevolveFeatures.Item Method Introduced in Inventor 5

RevolveFeatures Properties

RevolveFeatures.Application Property Introduced in Inventor 5

RevolveFeatures.Count Property Introduced in Inventor 5

RevolveFeatures.Type Property Introduced in Inventor 5

Ribbon Interface Introduced in Inventor 2010

Ribbon Properties

Ribbon.Active Property Introduced in Inventor 2010

Ribbon.Application Property Introduced in Inventor 2010

Ribbon.InternalName Property Introduced in Inventor 2010

Ribbon.Parent Property Introduced in Inventor 2010

Ribbon.QuickAccessControls Property Introduced in Inventor 2010

Ribbon.RibbonTabs Property Introduced in Inventor 2010

Ribbon.Type Property Introduced in Inventor 2010

RibbonPanel Interface Introduced in Inventor 2010

RibbonPanel Methods

RibbonPanel.Delete Method Introduced in Inventor 2010

RibbonPanel.Move Method Introduced in Inventor 2012

RibbonPanel.Reposition Method Introduced in Inventor 2010

RibbonPanel Properties

RibbonPanel.Application Property Introduced in Inventor 2010

RibbonPanel.ClientId Property Introduced in Inventor 2010

RibbonPanel.CommandControls Property Introduced in Inventor 2010

RibbonPanel.DisplayName Property Introduced in Inventor 2010

RibbonPanel.Docked Property Introduced in Inventor 2010

RibbonPanel.InternalName Property Introduced in Inventor 2010

RibbonPanel.Parent Property Introduced in Inventor 2010

RibbonPanel.SlideoutControls Property Introduced in Inventor 2010

RibbonPanel.SlideOutKeyTip Property

RibbonPanel.Type Property Introduced in Inventor 2010

RibbonPanel.Visible Property Introduced in Inventor 2010

RibbonPanels Interface Introduced in Inventor 2010

RibbonPanels Methods

RibbonPanels.Add Method Introduced in Inventor 2010

RibbonPanels.Item Method Introduced in Inventor 2010

RibbonPanels Properties

RibbonPanels.Application Property Introduced in Inventor 2010

RibbonPanels.Count Property Introduced in Inventor 2010

RibbonPanels.Type Property Introduced in Inventor 2010

Ribbons Interface Introduced in Inventor 2010

Ribbons Methods

Ribbons.Item Method Introduced in Inventor 2010

Ribbons Properties

Ribbons.Application Property Introduced in Inventor 2010

Ribbons.Count Property Introduced in Inventor 2010

Ribbons.Type Property Introduced in Inventor 2010

RibbonTab Interface Introduced in Inventor 2010

RibbonTab Methods

RibbonTab.Delete Method Introduced in Inventor 2010

RibbonTab Properties

RibbonTab.Active Property Introduced in Inventor 2010

RibbonTab.Application Property Introduced in Inventor 2010

RibbonTab.ClientId Property Introduced in Inventor 2010

RibbonTab.Contextual Property Introduced in Inventor 2010

RibbonTab.DisplayName Property Introduced in Inventor 2010

RibbonTab.InternalName Property Introduced in Inventor 2010

RibbonTab.KeyTip Property Introduced in Inventor 2011

RibbonTab.Parent Property Introduced in Inventor 2010

RibbonTab.RibbonPanels Property Introduced in Inventor 2010

RibbonTab.Type Property Introduced in Inventor 2010

RibbonTab.Visible Property Introduced in Inventor 2010

RibbonTabs Interface Introduced in Inventor 2010

RibbonTabs Methods

RibbonTabs.Add Method Introduced in Inventor 2010

RibbonTabs.Item Method Introduced in Inventor 2010

RibbonTabs Properties

RibbonTabs.Application Property Introduced in Inventor 2010

RibbonTabs.Count Property Introduced in Inventor 2010

RibbonTabs.Type Property Introduced in Inventor 2010

RibDefinition Interface Introduced in Inventor 2012

RibDefinition Methods

RibDefinition.Copy Method Introduced in Inventor 2012

RibDefinition.GetThicknessPlane Method Introduced in Inventor 2012

RibDefinition.SetFiniteExtent Method Introduced in Inventor 2012

RibDefinition.SetThicknessPlane Method Introduced in Inventor 2012

RibDefinition.SetToNextExtent Method Introduced in Inventor 2012

RibDefinition Properties

RibDefinition.AffectedBody Property Introduced in Inventor 2012

RibDefinition.Application Property Introduced in Inventor 2012

RibDefinition.BossSets Property Introduced in Inventor 2012

RibDefinition.DirectionReversed Property Introduced in Inventor 2012

RibDefinition.DraftAngle Property Introduced in Inventor 2012

RibDefinition.DraftProfileEnds Property Introduced in Inventor 2012

RibDefinition.ExtendProfile Property Introduced in Inventor 2012

RibDefinition.ExtentDistance Property Introduced in Inventor 2012

RibDefinition.ExtentType Property Introduced in Inventor 2012

RibDefinition.IsRib Property Introduced in Inventor 2012

RibDefinition.Parent Property Introduced in Inventor 2012

RibDefinition.ProfileCurves Property Introduced in Inventor 2012

RibDefinition.Thickness Property Introduced in Inventor 2012

RibDefinition.ThicknessDirection Property Introduced in Inventor 2012

RibDefinition.Type Property Introduced in Inventor 2012

RibFeature Interface Introduced in Inventor 5

RibFeature Properties

RibFeature.Definition Property Introduced in Inventor 2012

RibFeatureProxy Interface Introduced in Inventor 9

RibFeatureProxy Properties

RibFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

RibFeatureProxy.NativeObject Property Introduced in Inventor 9

RibFeatures Interface Introduced in Inventor 5

RibFeatures Methods

RibFeatures.Add Method Introduced in Inventor 2012

RibFeatures.CreateDefinition Method Introduced in Inventor 2012

RibFeatures.Item Method Introduced in Inventor 5

RibFeatures Properties

RibFeatures.Application Property Introduced in Inventor 5

RibFeatures.Count Property Introduced in Inventor 5

RibFeatures.Type Property Introduced in Inventor 5

RipDefinition Interface Introduced in Inventor 2011

RipDefinition Methods

RipDefinition.Copy Method Introduced in Inventor 2011

RipDefinition.SetFaceExtentsRipType Method

RipDefinition.SetPointToPointRipType Method Introduced in Inventor 2011

RipDefinition.SetSinglePointRipType Method Introduced in Inventor 2011

RipDefinition Properties

RipDefinition.Application Property

RipDefinition.Parent Property

RipDefinition.RipFace Property Introduced in Inventor 2011

RipDefinition.RipType Property Introduced in Inventor 2011

RipDefinition.RipTypeDefinition Property Introduced in Inventor 2011

RipDefinition.Type Property

RipFeature Interface Introduced in Inventor 2010

RipFeature Properties

RipFeature.Definition Property Introduced in Inventor 2011

RipFeatureProxy Interface Introduced in Inventor 2010

RipFeatures Interface Introduced in Inventor 2010

RipFeatures Methods

RipFeatures.Add Method Introduced in Inventor 2011

RipFeatures.CreateRipDefinition Method Introduced in Inventor 2011

RipFeatures.Item Method Introduced in Inventor 2010

RipFeatures Properties

RipFeatures.Application Property Introduced in Inventor 2010

RipFeatures.Count Property Introduced in Inventor 2010

RipFeatures.Type Property Introduced in Inventor 2010

RolledHemDefinition Interface Introduced in Inventor 2009

RolledHemDefinition Properties

RolledHemDefinition.Angle Property Introduced in Inventor 2009

RolledHemDefinition.Parent Property Introduced in Inventor 2009

RolledHemDefinition.Radius Property Introduced in Inventor 2009

RotateRotateConstraint Interface Introduced in Inventor 4

RotateRotateConstraint Properties

RotateRotateConstraint.ForwardDirection Property Introduced in Inventor 4

RotateRotateConstraint.Ratio Property Introduced in Inventor 4

RotateRotateConstraintProxy Interface Introduced in Inventor 11

RotateRotateConstraintProxy Properties

RotateRotateConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

RotateRotateConstraintProxy.NativeObject Property Introduced in Inventor 11

RotateRotateiMateDefinition Interface Introduced in Inventor 6

RotateRotateiMateDefinition Properties

RotateRotateiMateDefinition.Entity Property Introduced in Inventor 6

RotateRotateiMateDefinition.ForwardDirection Property Introduced in Inventor 6

RotateRotateiMateDefinition.Ratio Property Introduced in Inventor 6

RotateRotateiMateDefinitionProxy Interface Introduced in Inventor 6

RotateRotateiMateDefinitionProxy Properties

RotateRotateiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

RotateRotateiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

RotateRotateiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

RotateTranslateConstraint Interface Introduced in Inventor 4

RotateTranslateConstraint Properties

RotateTranslateConstraint.ForwardDirection Property Introduced in Inventor 4

RotateTranslateConstraint.Ratio Property Introduced in Inventor 4

RotateTranslateConstraintProxy Interface Introduced in Inventor 11

RotateTranslateConstraintProxy Properties

RotateTranslateConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

RotateTranslateConstraintProxy.NativeObject Property Introduced in Inventor 11

RotateTranslateiMateDefinition Interface Introduced in Inventor 6

RotateTranslateiMateDefinition Properties

RotateTranslateiMateDefinition.Entity Property Introduced in Inventor 6

RotateTranslateiMateDefinition.ForwardDirection Property Introduced in Inventor 6

RotateTranslateiMateDefinition.Ratio Property Introduced in Inventor 6

RotateTranslateiMateDefinitionProxy Interface Introduced in Inventor 6

RotateTranslateiMateDefinitionProxy Properties

RotateTranslateiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

RotateTranslateiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

RotateTranslateiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

Row Interface Introduced in Inventor 9

Row Methods

Row.Delete Method Introduced in Inventor 9

Row.Item Method Introduced in Inventor 9

Row.Reposition Method Introduced in Inventor 2009

Row Properties

Row.Application Property Introduced in Inventor 9

Row.Count Property Introduced in Inventor 9

Row.Height Property Introduced in Inventor 2010

Row.Parent Property Introduced in Inventor 9

Row.Type Property Introduced in Inventor 9

Row.Visible Property Introduced in Inventor 2009

Rows Interface Introduced in Inventor 9

Rows Methods

Rows.Add Method Introduced in Inventor 9

Rows.Item Method Introduced in Inventor 9

Rows Properties

Rows.Application Property Introduced in Inventor 9

Rows.Count Property Introduced in Inventor 9

Rows.Type Property Introduced in Inventor 9

RuleFilletFeature Interface Introduced in Inventor 2010

RuleFilletFeatureProxy Interface Introduced in Inventor 2010

RuleFilletFeatureProxy Properties

RuleFilletFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

RuleFilletFeatureProxy.NativeObject Property Introduced in Inventor 2010

RuleFilletFeatures Interface Introduced in Inventor 2010

RuleFilletFeatures Methods

RuleFilletFeatures.Item Method Introduced in Inventor 2010

RuleFilletFeatures Properties

RuleFilletFeatures.Application Property Introduced in Inventor 2010

RuleFilletFeatures.Count Property Introduced in Inventor 2010

RuleFilletFeatures.Type Property Introduced in Inventor 2010

RunoffSurfaceDefinition Interface Introduced in Inventor 2009

RunoffSurfaceDefinition Methods

RunoffSurfaceDefinition.AddCornerPiece Method Introduced in Inventor 2009

RunoffSurfaceDefinition.AddExtrusionPiece Method Introduced in Inventor 2009

RunoffSurfaceDefinition.AddRadiatePiece Method Introduced in Inventor 2009

RunoffSurfaceDefinition.AddSurfaceExtensionPiece Method Introduced in Inventor 2009

RunoffSurfaceDefinition.CreateRunoff Method Introduced in Inventor 2009

RunoffSurfaceDefinition.CreateSingleRunoffPiece Method Introduced in Inventor 2009

SaveOptions Interface Introduced in Inventor 11

SaveOptions Properties

SaveOptions.Application Property Introduced in Inventor 11

SaveOptions.ListReferencedFilesInSaveDialog Property Introduced in Inventor 11

SaveOptions.PromptSaveForMigration Property Introduced in Inventor 11

SaveOptions.PromptSaveForRecomputableChanges Property Introduced in Inventor 11

SaveOptions.SaveReminderTimer Property Introduced in Inventor 2010

SaveOptions.ShowSaveReminder Property Introduced in Inventor 2010

SaveOptions.Type Property Introduced in Inventor 11

SculptFeature Interface Introduced in Inventor 11

SculptFeature Properties

SculptFeature.Operation Property

SculptFeature.Surfaces Property Introduced in Inventor 11

SculptFeatureProxy Interface Introduced in Inventor 11

SculptFeatureProxy Properties

SculptFeatureProxy.ContainingOccurrence Property Introduced in Inventor 11

SculptFeatureProxy.NativeObject Property Introduced in Inventor 11

SculptFeatures Interface Introduced in Inventor 11

SculptFeatures Methods

SculptFeatures._Add Method

SculptFeatures.Add Method Introduced in Inventor 11

SculptFeatures.CreateSculptSurface Method Introduced in Inventor 11

SculptFeatures.Item Method Introduced in Inventor 11

SculptFeatures Properties

SculptFeatures.Application Property Introduced in Inventor 11

SculptFeatures.Count Property Introduced in Inventor 11

SculptFeatures.Type Property Introduced in Inventor 11

SculptSurface Interface Introduced in Inventor 11

SculptSurface Properties

SculptSurface.Direction Property Introduced in Inventor 11

SculptSurface.Surface Property Introduced in Inventor 11

SculptSurface.Type Property Introduced in Inventor 11

SectionDrawingView Interface Introduced in Inventor 9

SectionDrawingView Methods

SectionDrawingView.ReverseDirection Method Introduced in Inventor 9

SectionDrawingView Properties

SectionDrawingView.FullSectionDepth Property Introduced in Inventor 2009

SectionDrawingView.IncludeSlice Property Introduced in Inventor 2009

SectionDrawingView.SectionDepth Property Introduced in Inventor 2009

SectionDrawingView.SectionLineSketch Property Introduced in Inventor 9

SectionDrawingView.ShowEntireLine Property Introduced in Inventor 9

SectionDrawingView.SliceAllParts Property Introduced in Inventor 2009

SectionDrawingView.UseAlignedMethod Property Introduced in Inventor 2010

SelectEvents CoClass Introduced in Inventor 5

SelectEventsObject Interface Introduced in Inventor 5

SelectEventsObject Methods

SelectEventsObject.AddSelectionFilter Method Introduced in Inventor 5

SelectEventsObject.AddToSelectedEntities Method Introduced in Inventor 6

SelectEventsObject.AddWindowSelectionFilter Method Introduced in Inventor 2009

SelectEventsObject.ClearSelectionFilter Method Introduced in Inventor 5

SelectEventsObject.ClearWindowSelectionFilter Method Introduced in Inventor 2009

SelectEventsObject.RemoveFromSelectedEntities Method Introduced in Inventor 2009

SelectEventsObject.ResetSelections Method Introduced in Inventor 5

SelectEventsObject Properties

SelectEventsObject.Application Property Introduced in Inventor 5

SelectEventsObject.Enabled Property Introduced in Inventor 9

SelectEventsObject.IgnoreProfileInnerLoops Property Introduced in Inventor 2010

SelectEventsObject.MouseMoveEnabled Property Introduced in Inventor 5

SelectEventsObject.Parent Property Introduced in Inventor 5

SelectEventsObject.PreSelectBurnThrough Property Introduced in Inventor 7

SelectEventsObject.RestrictSelectionToOccurrence Property Introduced in Inventor 6

SelectEventsObject.SelectedEntities Property Introduced in Inventor 5

SelectEventsObject.SingleSelectEnabled Property Introduced in Inventor 6

SelectEventsObject.Type Property Introduced in Inventor 5

SelectEventsObject.WindowSelectEnabled Property Introduced in Inventor 2009

SelectEventsSink Interface Introduced in Inventor 5

SelectEventsSink Methods

SelectEventsSink.OnPreSelect Method Introduced in Inventor 5

SelectEventsSink.OnPreSelectMouseMove Method Introduced in Inventor 5

SelectEventsSink.OnSelect Method Introduced in Inventor 5

SelectEventsSink.OnStopPreSelect Method Introduced in Inventor 5

SelectEventsSink.OnUnSelect Method Introduced in Inventor 5

SelectSet Interface Introduced in Inventor 5

SelectSet Methods

SelectSet.Clear Method Introduced in Inventor 5

SelectSet.Delete Method Introduced in Inventor 5

SelectSet.Item Method Introduced in Inventor 5

SelectSet.Remove Method Introduced in Inventor 5

SelectSet.Select Method Introduced in Inventor 5

SelectSet.SelectMultiple Method

SelectSet Properties

SelectSet.Count Property Introduced in Inventor 5

SelectSet.Type Property Introduced in Inventor 5

ShadedDisplayOptions Interface Introduced in Inventor 11

ShadedDisplayOptions Properties

ShadedDisplayOptions.Application Property Introduced in Inventor 11

ShadedDisplayOptions.Type Property Introduced in Inventor 11

Sheet Interface Introduced in Inventor 4

Sheet Methods

Sheet.Activate Method Introduced in Inventor 5.3

Sheet.AddBorder Method Introduced in Inventor 5.3

Sheet.AddDefaultBorder Method Introduced in Inventor 5.3

Sheet.AddTitleBlock Method Introduced in Inventor 5.3

Sheet.ChangeLayer Method

Sheet.CopyTo Method Introduced in Inventor 9

Sheet.CreateGeometryIntent Method Introduced in Inventor 11

Sheet.Delete Method Introduced in Inventor 9

Sheet.FindUsingPoint Method Introduced in Inventor 2008

Sheet.GetReferenceKey Method Introduced in Inventor 9

Sheet.Update Method

Sheet Properties

Sheet.Application Property Introduced in Inventor 5.3

Sheet.AttributeSets Property Introduced in Inventor 9

Sheet.AutoCADBlocks Property Introduced in Inventor 2011

Sheet.Balloons Property Introduced in Inventor 9

Sheet.Border Property Introduced in Inventor 5.3

Sheet.Centerlines Property Introduced in Inventor 2008

Sheet.Centermarks Property Introduced in Inventor 2008

Sheet.ClientGraphicsCollection Property Introduced in Inventor 2008

Sheet.ClientViews Property Introduced in Inventor 6

Sheet.CustomTables Property Introduced in Inventor 9

Sheet.DataIO Property Introduced in Inventor 4

Sheet.DrawingDimensions Property Introduced in Inventor 9

Sheet.DrawingNotes Property Introduced in Inventor 10

Sheet.DrawingViews Property Introduced in Inventor 4

Sheet.ExcludeFromCount Property Introduced in Inventor 5.3

Sheet.ExcludeFromPrinting Property Introduced in Inventor 5.3

Sheet.FeatureControlFrames Property Introduced in Inventor 2009

Sheet.GraphicsDataSetsCollection Property Introduced in Inventor 2008

Sheet.Height Property Introduced in Inventor 4

Sheet.HoleTables Property Introduced in Inventor 10

Sheet.IsModelSpaceSheet Property Introduced in Inventor 2008

Sheet.Name Property Introduced in Inventor 4

Sheet.Orientation Property Introduced in Inventor 4

Sheet.Parent Property Introduced in Inventor 4

Sheet.PartsLists Property Introduced in Inventor 5.3

Sheet.RevisionTables Property Introduced in Inventor 10

Sheet.Size Property Introduced in Inventor 4

Sheet.SketchedSymbols Property Introduced in Inventor 5.3

Sheet.Sketches Property Introduced in Inventor 5.3

Sheet.Status Property Introduced in Inventor 4

Sheet.SurfaceTextureSymbols Property Introduced in Inventor 2009

Sheet.TitleBlock Property Introduced in Inventor 5.3

Sheet.Type Property Introduced in Inventor 4

Sheet.Width Property Introduced in Inventor 4

SheetFormat Interface Introduced in Inventor 2009

SheetFormat Methods

SheetFormat.CopyTo Method Introduced in Inventor 2009

SheetFormat.Delete Method Introduced in Inventor 2009

SheetFormat.GetReferenceKey Method Introduced in Inventor 2009

SheetFormat Properties

SheetFormat.Application Property Introduced in Inventor 2009

SheetFormat.AttributeSets Property Introduced in Inventor 2009

SheetFormat.HasDrawingViews Property Introduced in Inventor 2009

SheetFormat.Height Property Introduced in Inventor 2010

SheetFormat.Name Property Introduced in Inventor 2009

SheetFormat.Orientation Property Introduced in Inventor 2009

SheetFormat.Parent Property Introduced in Inventor 2009

SheetFormat.ReferencedAutoCADBlockDefinitions Property Introduced in Inventor 2011

SheetFormat.ReferencedBorderDefinition Property Introduced in Inventor 2009

SheetFormat.ReferencedSymbolDefinitions Property Introduced in Inventor 2009

SheetFormat.ReferencedTitleBlockDefinition Property Introduced in Inventor 2009

SheetFormat.Size Property Introduced in Inventor 2009

SheetFormat.TitleBlockLocation Property Introduced in Inventor 2009

SheetFormat.Type Property Introduced in Inventor 2009

SheetFormat.Width Property Introduced in Inventor 2010

SheetFormats Interface Introduced in Inventor 2009

SheetFormats Methods

SheetFormats.Add Method Introduced in Inventor 2009

SheetFormats.Item Method Introduced in Inventor 2009

SheetFormats Properties

SheetFormats.Application Property Introduced in Inventor 2009

SheetFormats.Count Property Introduced in Inventor 2009

SheetFormats.Type Property Introduced in Inventor 2009

SheetMetalComponentDefinition Interface Introduced in Inventor 5.3

SheetMetalComponentDefinition Methods

SheetMetalComponentDefinition.Unfold Method Introduced in Inventor 6

SheetMetalComponentDefinition.Unfold2 Method Introduced in Inventor 2009

SheetMetalComponentDefinition Properties

SheetMetalComponentDefinition.ActiveSheetMetalStyle Property Introduced in Inventor 5.3

SheetMetalComponentDefinition.BendRadius Property Introduced in Inventor 2009

SheetMetalComponentDefinition.BendReliefDepth Property Introduced in Inventor 2009

SheetMetalComponentDefinition.BendReliefWidth Property Introduced in Inventor 2009

SheetMetalComponentDefinition.Bends Property Introduced in Inventor 2010

SheetMetalComponentDefinition.CornerReliefSize Property Introduced in Inventor 2009

SheetMetalComponentDefinition.FlatPattern Property Introduced in Inventor 6

SheetMetalComponentDefinition.GapSize Property Introduced in Inventor 2010

SheetMetalComponentDefinition.HasFlatPattern Property Introduced in Inventor 2008

SheetMetalComponentDefinition.JacobiRadiusSize Property Introduced in Inventor 2009

SheetMetalComponentDefinition.MinimumRemnant Property Introduced in Inventor 2009

SheetMetalComponentDefinition.SheetMetalStyles Property Introduced in Inventor 5.3

SheetMetalComponentDefinition.Thickness Property Introduced in Inventor 2009

SheetMetalComponentDefinition.TransitionRadius Property Introduced in Inventor 2009

SheetMetalComponentDefinition.UnfoldMethod Property Introduced in Inventor 2009

SheetMetalComponentDefinition.UnfoldMethods Property Introduced in Inventor 2009

SheetMetalComponentDefinition.UseSheetMetalStyleMaterial Property Introduced in Inventor 2009

SheetMetalComponentDefinition.UseSheetMetalStyleThickness Property Introduced in Inventor 2009

SheetMetalComponentDefinition.UseSheetMetalStyleUnfoldMethod Property Introduced in Inventor 2009

SheetMetalFeatures Interface Introduced in Inventor 5.3

SheetMetalFeatures Properties

SheetMetalFeatures.BendFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.ContourFlangeFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.ContourRollFeatures Property Introduced in Inventor 2010

SheetMetalFeatures.CornerChamferFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.CornerFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.CornerRoundFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.CutFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.FaceFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.FlangeFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.FoldFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.HemFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.LoftedFlangeFeatures Property Introduced in Inventor 2010

SheetMetalFeatures.PunchToolFeatures Property Introduced in Inventor 5.3

SheetMetalFeatures.RefoldFeatures Property Introduced in Inventor 2010

SheetMetalFeatures.RipFeatures Property Introduced in Inventor 2010

SheetMetalFeatures.UnfoldFeatures Property Introduced in Inventor 2010

SheetMetalStyle Interface Introduced in Inventor 5.3

SheetMetalStyle Methods

SheetMetalStyle.Activate Method Introduced in Inventor 5.3

SheetMetalStyle Properties

SheetMetalStyle.BendAngleReportType Property Introduced in Inventor 2010

SheetMetalStyle.BendRadius Property Introduced in Inventor 5.3

SheetMetalStyle.BendReliefDepth Property Introduced in Inventor 5.3

SheetMetalStyle.BendReliefShape Property Introduced in Inventor 5.3

SheetMetalStyle.BendReliefWidth Property Introduced in Inventor 5.3

SheetMetalStyle.BendTransition Property Introduced in Inventor 5.3

SheetMetalStyle.BendTransitionArcRadius Property Introduced in Inventor 2009

SheetMetalStyle.CornerReliefShape Property Introduced in Inventor 5.3

SheetMetalStyle.CornerReliefSize Property Introduced in Inventor 5.3

SheetMetalStyle.GapSize Property Introduced in Inventor 2010

SheetMetalStyle.Material Property Introduced in Inventor 5.3

SheetMetalStyle.MinimumRemnant Property Introduced in Inventor 5.3

SheetMetalStyle.PunchRepresentationType Property Introduced in Inventor 2008

SheetMetalStyle.Thickness Property Introduced in Inventor 5

SheetMetalStyle.ThreeBendCornerReliefShape Property Introduced in Inventor 2009

SheetMetalStyle.ThreeBendCornerReliefSize Property Introduced in Inventor 2009

SheetMetalStyle.UnfoldMethod Property Introduced in Inventor 2009

SheetMetalStyles Interface Introduced in Inventor 5.3

SheetMetalStyles Methods

SheetMetalStyles.Copy Method

SheetMetalStyles.Item Method Introduced in Inventor 5.3

SheetMetalStyles Properties

SheetMetalStyles.Application Property Introduced in Inventor 5.3

SheetMetalStyles.Count Property Introduced in Inventor 5.3

SheetMetalStyles.Type Property Introduced in Inventor 5.3

Sheets Interface Introduced in Inventor 4

Sheets Methods

Sheets.Add Method Introduced in Inventor 9

Sheets.AddUsingSheetFormat Method Introduced in Inventor 2009

Sheets.Item Method Introduced in Inventor 4

Sheets Properties

Sheets.Application Property Introduced in Inventor 9

Sheets.Count Property Introduced in Inventor 4

Sheets.Type Property Introduced in Inventor 4

SheetSettings Interface Introduced in Inventor 11

SheetSettings Properties

SheetSettings.Application Property Introduced in Inventor 11

SheetSettings.Parent Property Introduced in Inventor 11

SheetSettings.SheetColor Property Introduced in Inventor 11

SheetSettings.SheetEntityHighlightColor Property Introduced in Inventor 11

SheetSettings.SheetEntitySelectionColor Property Introduced in Inventor 11

SheetSettings.SheetLabel Property Introduced in Inventor 11

SheetSettings.SheetOutlineColor Property Introduced in Inventor 11

SheetSettings.Type Property Introduced in Inventor 11

ShellDefinition Interface Introduced in Inventor 9

ShellDefinition Methods

ShellDefinition.AddThicknessFaceSet Method Introduced in Inventor 9

ShellDefinition.Copy Method Introduced in Inventor 2008

ShellDefinition.FaceSetItem Method Introduced in Inventor 9

ShellDefinition Properties

ShellDefinition.Application Property Introduced in Inventor 9

ShellDefinition.ApproximationOptimized Property Introduced in Inventor 11

ShellDefinition.ApproximationTolerance Property Introduced in Inventor 11

ShellDefinition.ApproximationType Property Introduced in Inventor 11

ShellDefinition.Direction Property Introduced in Inventor 9

ShellDefinition.FaceSetCount Property Introduced in Inventor 9

ShellDefinition.InputFaces Property Introduced in Inventor 9

ShellDefinition.Parent Property Introduced in Inventor 9

ShellDefinition.Thickness Property Introduced in Inventor 9

ShellDefinition.Type Property Introduced in Inventor 9

ShellFeature Interface Introduced in Inventor 5

ShellFeature Properties

ShellFeature.Definition Property Introduced in Inventor 9

ShellFeatureProxy Interface Introduced in Inventor 9

ShellFeatureProxy Properties

ShellFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ShellFeatureProxy.NativeObject Property Introduced in Inventor 9

ShellFeatures Interface Introduced in Inventor 5

ShellFeatures Methods

ShellFeatures.Add Method Introduced in Inventor 9

ShellFeatures.CreateShellDefinition Method Introduced in Inventor 9

ShellFeatures.Item Method Introduced in Inventor 5

ShellFeatures Properties

ShellFeatures.Application Property Introduced in Inventor 5

ShellFeatures.Count Property Introduced in Inventor 5

ShellFeatures.Type Property Introduced in Inventor 5

ShellThicknessFaceSet Interface Introduced in Inventor 9

ShellThicknessFaceSet Methods

ShellThicknessFaceSet.Delete Method Introduced in Inventor 9

ShellThicknessFaceSet Properties

ShellThicknessFaceSet.Application Property Introduced in Inventor 9

ShellThicknessFaceSet.Faces Property Introduced in Inventor 9

ShellThicknessFaceSet.Thickness Property Introduced in Inventor 9

ShellThicknessFaceSet.Type Property Introduced in Inventor 9

SilhouetteCurve Interface Introduced in Inventor 2012

SilhouetteCurve Methods

SilhouetteCurve.BreakLink Method Introduced in Inventor 2012

SilhouetteCurve.Delete Method Introduced in Inventor 2012

SilhouetteCurve.Edit Method Introduced in Inventor 2012

SilhouetteCurve.GetReferenceKey Method Introduced in Inventor 2012

SilhouetteCurve Properties

SilhouetteCurve.Application Property Introduced in Inventor 2012

SilhouetteCurve.AttributeSets Property Introduced in Inventor 2012

SilhouetteCurve.DirectionEntity Property Introduced in Inventor 2012

SilhouetteCurve.FacesOrBody Property Introduced in Inventor 2012

SilhouetteCurve.IncludeCoincidentSilhouettes Property Introduced in Inventor 2012

SilhouetteCurve.Name Property Introduced in Inventor 2012

SilhouetteCurve.Parent Property Introduced in Inventor 2012

SilhouetteCurve.SketchEntities Property Introduced in Inventor 2012

SilhouetteCurve.Type Property Introduced in Inventor 2012

SilhouetteCurves Interface Introduced in Inventor 2012

SilhouetteCurves Methods

SilhouetteCurves.Add Method Introduced in Inventor 2012

SilhouetteCurves.Item Method Introduced in Inventor 2012

SilhouetteCurves Properties

SilhouetteCurves.Application Property Introduced in Inventor 2012

SilhouetteCurves.Count Property Introduced in Inventor 2012

SilhouetteCurves.Type Property Introduced in Inventor 2012

SingleHemDefinition Interface Introduced in Inventor 2009

SingleHemDefinition Properties

SingleHemDefinition.Gap Property Introduced in Inventor 2009

SingleHemDefinition.Length Property Introduced in Inventor 2009

SingleHemDefinition.Parent Property Introduced in Inventor 2009

SinglePointRipTypeDef Interface Introduced in Inventor 2011

SinglePointRipTypeDef Properties

SinglePointRipTypeDef.GapSide Property Introduced in Inventor 2011

SinglePointRipTypeDef.GapSize Property Introduced in Inventor 2011

SinglePointRipTypeDef.Parent Property Introduced in Inventor 2011

SinglePointRipTypeDef.Point Property Introduced in Inventor 2011

SinglePointRipTypeDef.Type Property Introduced in Inventor 2011

Sketch Interface Introduced in Inventor 4

Sketch Methods

Sketch.AddByProjectingEntity Method Introduced in Inventor 11

Sketch.CopyContentsTo Method Introduced in Inventor 2011

Sketch.Delete Method Introduced in Inventor 5.3

Sketch.Edit Method Introduced in Inventor 5.3

Sketch.ExitEdit Method Introduced in Inventor 5.3

Sketch.GetCustomLineType Method Introduced in Inventor 2010

Sketch.GetReferenceKey Method Introduced in Inventor 5.3

Sketch.MoveSketchObjects Method Introduced in Inventor 10

Sketch.OffsetSketchEntitiesUsingDistance Method Introduced in Inventor 11

Sketch.OffsetSketchEntitiesUsingPoint Method Introduced in Inventor 11

Sketch.RotateSketchObjects Method Introduced in Inventor 10

Sketch.SetCustomLineType Method Introduced in Inventor 2010

Sketch.Solve Method Introduced in Inventor 11

Sketch Properties

Sketch.Application Property Introduced in Inventor 4

Sketch.AttributeSets Property Introduced in Inventor 5.3

Sketch.Color Property Introduced in Inventor 2010

Sketch.ConstraintStatus Property Introduced in Inventor 10

Sketch.DataIO Property Introduced in Inventor 4

Sketch.DeferUpdates Property Introduced in Inventor 11

Sketch.DimensionConstraints Property Introduced in Inventor 5.3

Sketch.DisabledActionTypes Property Introduced in Inventor 9

Sketch.GeometricConstraints Property Introduced in Inventor 5.3

Sketch.LineType Property Introduced in Inventor 2010

Sketch.LineWeight Property Introduced in Inventor 2010

Sketch.Name Property Introduced in Inventor 5.3

Sketch.Parent Property Introduced in Inventor 4

Sketch.SketchArcs Property Introduced in Inventor 5.3

Sketch.SketchCircles Property Introduced in Inventor 5.3

Sketch.SketchEllipses Property Introduced in Inventor 5.3

Sketch.SketchEllipticalArcs Property Introduced in Inventor 5.3

Sketch.SketchEntities Property Introduced in Inventor 5.3

Sketch.SketchFixedSplines Property Introduced in Inventor 9

Sketch.SketchImages Property Introduced in Inventor 11

Sketch.SketchLines Property Introduced in Inventor 5.3

Sketch.SketchOffsetSplines Property Introduced in Inventor 9

Sketch.SketchPoints Property Introduced in Inventor 5.3

Sketch.SketchSplines Property Introduced in Inventor 5.3

Sketch.TextBoxes Property Introduced in Inventor 10

Sketch.Type Property Introduced in Inventor 4

Sketch.Visible Property Introduced in Inventor 5.3

Sketch3D Interface Introduced in Inventor 6

Sketch3D Methods

Sketch3D.Delete Method Introduced in Inventor 6

Sketch3D.Edit Method Introduced in Inventor 6

Sketch3D.ExitEdit Method Introduced in Inventor 6

Sketch3D.GetReferenceKey Method Introduced in Inventor 6

Sketch3D.Include Method Introduced in Inventor 6

Sketch3D.SetEndOfPart Method Introduced in Inventor 6

Sketch3D.Solve Method Introduced in Inventor 11

Sketch3D Properties

Sketch3D.Application Property Introduced in Inventor 6

Sketch3D.AttributeSets Property Introduced in Inventor 6

Sketch3D.Consumed Property Introduced in Inventor 8

Sketch3D.DeferUpdates Property Introduced in Inventor 11

Sketch3D.Dependents Property Introduced in Inventor 6

Sketch3D.DimensionConstraints3D Property Introduced in Inventor 11

Sketch3D.DimensionsVisible Property Introduced in Inventor 10

Sketch3D.DisabledActionTypes Property Introduced in Inventor 9

Sketch3D.Exported Property

Sketch3D.GeometricConstraints3D Property Introduced in Inventor 6

Sketch3D.HasReferenceComponent Property Introduced in Inventor 6

Sketch3D.HealthStatus Property Introduced in Inventor 11

Sketch3D.IsOwnedByFeature Property Introduced in Inventor 2008

Sketch3D.Name Property Introduced in Inventor 6

Sketch3D.OverrideColor Property Introduced in Inventor 8

Sketch3D.OwnedBy Property Introduced in Inventor 2008

Sketch3D.Parent Property Introduced in Inventor 6

Sketch3D.Profiles3D Property Introduced in Inventor 6

Sketch3D.ReferenceComponent Property Introduced in Inventor 6

Sketch3D.ReferencedEntity Property Introduced in Inventor 6

Sketch3D.Shared Property Introduced in Inventor 10

Sketch3D.SilhouetteCurves Property Introduced in Inventor 2012

Sketch3D.SketchArcs3D Property Introduced in Inventor 6

Sketch3D.SketchCircles3D Property Introduced in Inventor 6

Sketch3D.SketchEllipses3D Property Introduced in Inventor 6

Sketch3D.SketchEllipticalArcs3D Property Introduced in Inventor 6

Sketch3D.SketchEntities3D Property Introduced in Inventor 6

Sketch3D.SketchFixedSplines3D Property Introduced in Inventor 9

Sketch3D.SketchLines3D Property Introduced in Inventor 6

Sketch3D.SketchPoints3D Property Introduced in Inventor 6

Sketch3D.SketchSplines3D Property Introduced in Inventor 6

Sketch3D.Type Property Introduced in Inventor 6

Sketch3D.Visible Property Introduced in Inventor 6

Sketch3DOptions Interface Introduced in Inventor 11

Sketch3DOptions Properties

Sketch3DOptions.Application Property Introduced in Inventor 11

Sketch3DOptions.AutoBendWithLineCreation Property Introduced in Inventor 11

Sketch3DOptions.Type Property Introduced in Inventor 11

Sketch3DProxy Interface Introduced in Inventor 6

Sketch3DProxy Properties

Sketch3DProxy.ContainingOccurrence Property Introduced in Inventor 6

Sketch3DProxy.NativeObject Property Introduced in Inventor 6

Sketch3DSettings Interface Introduced in Inventor 8

Sketch3DSettings Properties

Sketch3DSettings.Application Property Introduced in Inventor 8

Sketch3DSettings.AutoBendRadius Property Introduced in Inventor 8

Sketch3DSettings.Parent Property Introduced in Inventor 8

Sketch3DSettings.Type Property Introduced in Inventor 8

SketchArc Interface Introduced in Inventor 5

SketchArc Methods

SketchArc.GetCustomLineType Method Introduced in Inventor 2008

SketchArc.SetCustomLineType Method Introduced in Inventor 2008

SketchArc Properties

SketchArc.CenterSketchPoint Property Introduced in Inventor 5

SketchArc.CurvatureDisplay Property Introduced in Inventor 11

SketchArc.EndSketchPoint Property Introduced in Inventor 5

SketchArc.Geometry Property Introduced in Inventor 5

SketchArc.Length Property Introduced in Inventor 5

SketchArc.LineDefinitionSpace Property Introduced in Inventor 9

SketchArc.LineScale Property Introduced in Inventor 9

SketchArc.LineType Property Introduced in Inventor 9

SketchArc.LineWeight Property Introduced in Inventor 9

SketchArc.OverrideColor Property Introduced in Inventor 9

SketchArc.Radius Property Introduced in Inventor 5

SketchArc.StartAngle Property Introduced in Inventor 5

SketchArc.StartSketchPoint Property Introduced in Inventor 5

SketchArc.SweepAngle Property Introduced in Inventor 5

SketchArc3D Interface Introduced in Inventor 6

SketchArc3D Properties

SketchArc3D.CenterPoint Property Introduced in Inventor 6

SketchArc3D.CurvatureDisplay Property Introduced in Inventor 11

SketchArc3D.EndSketchPoint Property Introduced in Inventor 8

SketchArc3D.Geometry Property Introduced in Inventor 6

SketchArc3D.Length Property Introduced in Inventor 6

SketchArc3D.Radius Property Introduced in Inventor 2010

SketchArc3D.StartAngle Property Introduced in Inventor 2010

SketchArc3D.StartSketchPoint Property Introduced in Inventor 8

SketchArc3D.SweepAngle Property Introduced in Inventor 2010

SketchArc3DProxy Interface Introduced in Inventor 6

SketchArc3DProxy Properties

SketchArc3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchArc3DProxy.NativeObject Property Introduced in Inventor 6

SketchArcProxy Interface Introduced in Inventor 6

SketchArcProxy Properties

SketchArcProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchArcProxy.NativeObject Property Introduced in Inventor 6

SketchArcs Interface Introduced in Inventor 5

SketchArcs Methods

SketchArcs.AddByCenterStartEndPoint Method Introduced in Inventor 5

SketchArcs.AddByCenterStartSweepAngle Method Introduced in Inventor 5

SketchArcs.AddByFillet Method Introduced in Inventor 5.3

SketchArcs.AddByThreePoints Method Introduced in Inventor 5

SketchArcs.Item Method Introduced in Inventor 5

SketchArcs Properties

SketchArcs.Application Property Introduced in Inventor 5

SketchArcs.Count Property Introduced in Inventor 5

SketchArcs.Type Property Introduced in Inventor 5

SketchArcs3D Interface Introduced in Inventor 6

SketchArcs3D Methods

SketchArcs3D.AddAsBend Method Introduced in Inventor 6

SketchArcs3D.AddByCenterStartEndPoint Method Introduced in Inventor 2008

SketchArcs3D.AddByCenterStartSweepAngle Method Introduced in Inventor 2008

SketchArcs3D.AddByThreePoints Method Introduced in Inventor 2008

SketchArcs3D.Item Method Introduced in Inventor 6

SketchArcs3D Properties

SketchArcs3D.Application Property Introduced in Inventor 6

SketchArcs3D.Count Property Introduced in Inventor 6

SketchArcs3D.Type Property Introduced in Inventor 6

SketchBlock Interface Introduced in Inventor 2010

SketchBlock Methods

SketchBlock.Delete Method Introduced in Inventor 2010

SketchBlock.Edit Method Introduced in Inventor 2010

SketchBlock.ExitEdit Method Introduced in Inventor 2010

SketchBlock.Explode Method Introduced in Inventor 2010

SketchBlock.GetCustomLineType Method Introduced in Inventor 2010

SketchBlock.GetObject Method Introduced in Inventor 2010

SketchBlock.GetReferenceKey Method Introduced in Inventor 2010

SketchBlock.SetCustomLineType Method Introduced in Inventor 2010

SketchBlock Properties

SketchBlock.Application Property Introduced in Inventor 2010

SketchBlock.AttributeSets Property Introduced in Inventor 2010

SketchBlock.ChildBlocks Property Introduced in Inventor 2010

SketchBlock.Color Property Introduced in Inventor 2010

SketchBlock.ConstraintStatus Property Introduced in Inventor 2010

SketchBlock.ContainingSketchBlock Property Introduced in Inventor 2010

SketchBlock.Definition Property Introduced in Inventor 2010

SketchBlock.Exported Property

SketchBlock.Flexible Property Introduced in Inventor 2010

SketchBlock.HasReferenceComponent Property Introduced in Inventor 2010

SketchBlock.LineType Property Introduced in Inventor 2010

SketchBlock.LineWeight Property Introduced in Inventor 2010

SketchBlock.Name Property Introduced in Inventor 2010

SketchBlock.Parent Property Introduced in Inventor 2010

SketchBlock.Position Property Introduced in Inventor 2010

SketchBlock.ReferenceComponent Property Introduced in Inventor 2010

SketchBlock.ReferencedEntity Property Introduced in Inventor 2010

SketchBlock.SketchBlockPath Property Introduced in Inventor 2010

SketchBlock.Transformation Property Introduced in Inventor 2010

SketchBlock.Type Property Introduced in Inventor 2010

SketchBlock.Visible Property Introduced in Inventor 2010

SketchBlockDefinition Interface Introduced in Inventor 2010

SketchBlockDefinition Methods

SketchBlockDefinition.AdjustContext Method Introduced in Inventor 2010

SketchBlockDefinition.CopyTo Method Introduced in Inventor 2010

SketchBlockDefinition Properties

SketchBlockDefinition.InsertionPoint Property Introduced in Inventor 2010

SketchBlockDefinition.IsInsertionPointVisible Property Introduced in Inventor 2010

SketchBlockDefinition.IsReferenced Property Introduced in Inventor 2010

SketchBlockDefinitionProxy Interface Introduced in Inventor 2010

SketchBlockDefinitionProxy Properties

SketchBlockDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 2010

SketchBlockDefinitionProxy.NativeObject Property Introduced in Inventor 2010

SketchBlockDefinitions Interface Introduced in Inventor 2010

SketchBlockDefinitions Methods

SketchBlockDefinitions.Add Method Introduced in Inventor 2010

SketchBlockDefinitions.Item Method Introduced in Inventor 2010

SketchBlockDefinitions Properties

SketchBlockDefinitions.Application Property Introduced in Inventor 2010

SketchBlockDefinitions.Count Property Introduced in Inventor 2010

SketchBlockDefinitions.Type Property Introduced in Inventor 2010

SketchBlockDefinitionsEnumerator Interface Introduced in Inventor 2010

SketchBlockDefinitionsEnumerator Methods

SketchBlockDefinitionsEnumerator.Item Method Introduced in Inventor 2010

SketchBlockDefinitionsEnumerator Properties

SketchBlockDefinitionsEnumerator.Count Property Introduced in Inventor 2010

SketchBlockDefinitionsEnumerator.Type Property Introduced in Inventor 2010

SketchBlockProxy Interface Introduced in Inventor 2010

SketchBlockProxy Properties

SketchBlockProxy.ContainingOccurrence Property Introduced in Inventor 2010

SketchBlockProxy.NativeObject Property Introduced in Inventor 2010

SketchBlocks Interface Introduced in Inventor 2010

SketchBlocks Methods

SketchBlocks.Add Method Introduced in Inventor 2010

SketchBlocks.AddByDefinition Method Introduced in Inventor 2010

SketchBlocks.Item Method Introduced in Inventor 2010

SketchBlocks Properties

SketchBlocks.Application Property Introduced in Inventor 2010

SketchBlocks.Count Property Introduced in Inventor 2010

SketchBlocks.Type Property Introduced in Inventor 2010

SketchBlocksEnumerator Interface Introduced in Inventor 2010

SketchBlocksEnumerator Methods

SketchBlocksEnumerator.Item Method Introduced in Inventor 2010

SketchBlocksEnumerator Properties

SketchBlocksEnumerator.Count Property Introduced in Inventor 2010

SketchBlocksEnumerator.Type Property Introduced in Inventor 2010

SketchCircle Interface Introduced in Inventor 5

SketchCircle Methods

SketchCircle.GetCustomLineType Method Introduced in Inventor 2008

SketchCircle.SetCustomLineType Method Introduced in Inventor 2008

SketchCircle Properties

SketchCircle.Area Property Introduced in Inventor 5

SketchCircle.CenterSketchPoint Property Introduced in Inventor 5

SketchCircle.CurvatureDisplay Property Introduced in Inventor 11

SketchCircle.Geometry Property Introduced in Inventor 5

SketchCircle.Length Property Introduced in Inventor 2010

SketchCircle.LineDefinitionSpace Property Introduced in Inventor 9

SketchCircle.LineScale Property Introduced in Inventor 9

SketchCircle.LineType Property Introduced in Inventor 9

SketchCircle.LineWeight Property Introduced in Inventor 9

SketchCircle.OverrideColor Property Introduced in Inventor 9

SketchCircle.Radius Property Introduced in Inventor 5

SketchCircle3D Interface Introduced in Inventor 6

SketchCircle3D Properties

SketchCircle3D.Area Property Introduced in Inventor 6

SketchCircle3D.CenterPoint Property Introduced in Inventor 6

SketchCircle3D.CurvatureDisplay Property Introduced in Inventor 11

SketchCircle3D.Geometry Property Introduced in Inventor 6

SketchCircle3D.Length Property Introduced in Inventor 2010

SketchCircle3D.Radius Property Introduced in Inventor 2010

SketchCircle3DProxy Interface Introduced in Inventor 6

SketchCircle3DProxy Properties

SketchCircle3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchCircle3DProxy.NativeObject Property Introduced in Inventor 6

SketchCircleProxy Interface Introduced in Inventor 6

SketchCircleProxy Properties

SketchCircleProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchCircleProxy.NativeObject Property Introduced in Inventor 6

SketchCircles Interface Introduced in Inventor 5

SketchCircles Methods

SketchCircles.AddByCenterRadius Method Introduced in Inventor 5

SketchCircles.AddByThreePoints Method Introduced in Inventor 5

SketchCircles.Item Method Introduced in Inventor 5

SketchCircles Properties

SketchCircles.Application Property Introduced in Inventor 5

SketchCircles.Count Property Introduced in Inventor 5

SketchCircles.Type Property Introduced in Inventor 5

SketchCircles3D Interface Introduced in Inventor 6

SketchCircles3D Methods

SketchCircles3D.AddByCenterRadius Method Introduced in Inventor 2008

SketchCircles3D.AddByThreePoints Method Introduced in Inventor 2008

SketchCircles3D.Item Method Introduced in Inventor 6

SketchCircles3D Properties

SketchCircles3D.Application Property Introduced in Inventor 6

SketchCircles3D.Count Property Introduced in Inventor 6

SketchCircles3D.Type Property Introduced in Inventor 6

SketchConstraints3DEnumerator Interface Introduced in Inventor 6

SketchConstraints3DEnumerator Methods

SketchConstraints3DEnumerator.Item Method Introduced in Inventor 6

SketchConstraints3DEnumerator Properties

SketchConstraints3DEnumerator.Count Property Introduced in Inventor 6

SketchConstraints3DEnumerator.Type Property Introduced in Inventor 6

SketchConstraintsEnumerator Interface Introduced in Inventor 5

SketchConstraintsEnumerator Methods

SketchConstraintsEnumerator.Item Method Introduced in Inventor 5

SketchConstraintsEnumerator Properties

SketchConstraintsEnumerator.Count Property Introduced in Inventor 5

SketchConstraintsEnumerator.Type Property Introduced in Inventor 5

SketchedSymbol Interface Introduced in Inventor 5.3

SketchedSymbol Methods

SketchedSymbol.Delete Method Introduced in Inventor 5.3

SketchedSymbol.GetCustomLineType Method Introduced in Inventor 2010

SketchedSymbol.GetReferenceKey Method Introduced in Inventor 9

SketchedSymbol.GetResultText Method Introduced in Inventor 5.3

SketchedSymbol.SetCustomLineType Method Introduced in Inventor 2010

SketchedSymbol.SetPromptResultText Method Introduced in Inventor 5.3

SketchedSymbol Properties

SketchedSymbol.Application Property Introduced in Inventor 5.3

SketchedSymbol.AttributeSets Property Introduced in Inventor 9

SketchedSymbol.Callout Property Introduced in Inventor 10

SketchedSymbol.Color Property Introduced in Inventor 2010

SketchedSymbol.Definition Property Introduced in Inventor 5.3

SketchedSymbol.Layer Property Introduced in Inventor 10

SketchedSymbol.Leader Property Introduced in Inventor 11

SketchedSymbol.LeaderClipping Property Introduced in Inventor 2009

SketchedSymbol.LeaderStyle Property

SketchedSymbol.LeaderVisible Property Introduced in Inventor 11

SketchedSymbol.LineType Property Introduced in Inventor 2010

SketchedSymbol.LineWeight Property Introduced in Inventor 2010

SketchedSymbol.Name Property Introduced in Inventor 2009

SketchedSymbol.Parent Property Introduced in Inventor 5.3

SketchedSymbol.Position Property Introduced in Inventor 5.3

SketchedSymbol.Rotation Property Introduced in Inventor 10

SketchedSymbol.Scale Property Introduced in Inventor 10

SketchedSymbol.Static Property Introduced in Inventor 11

SketchedSymbol.SymbolClipping Property Introduced in Inventor 11

SketchedSymbol.Transformation Property Introduced in Inventor 5.3

SketchedSymbol.Type Property Introduced in Inventor 5.3

SketchedSymbolDefinition Interface Introduced in Inventor 5.3

SketchedSymbolDefinition Methods

SketchedSymbolDefinition.CopyTo Method Introduced in Inventor 10

SketchedSymbolDefinition.Delete Method Introduced in Inventor 5.3

SketchedSymbolDefinition.Edit Method Introduced in Inventor 5.3

SketchedSymbolDefinition.ExitEdit Method Introduced in Inventor 5.3

SketchedSymbolDefinition.GetReferenceKey Method Introduced in Inventor 2008

SketchedSymbolDefinition Properties

SketchedSymbolDefinition.Application Property Introduced in Inventor 5.3

SketchedSymbolDefinition.AttributeSets Property Introduced in Inventor 2008

SketchedSymbolDefinition.IsReferenced Property Introduced in Inventor 5.3

SketchedSymbolDefinition.Name Property Introduced in Inventor 5.3

SketchedSymbolDefinition.Parent Property Introduced in Inventor 5.3

SketchedSymbolDefinition.Sketch Property Introduced in Inventor 5.3

SketchedSymbolDefinition.Type Property Introduced in Inventor 5.3

SketchedSymbolDefinitions Interface Introduced in Inventor 5.3

SketchedSymbolDefinitions Methods

SketchedSymbolDefinitions.Add Method Introduced in Inventor 5.3

SketchedSymbolDefinitions.Item Method Introduced in Inventor 5.3

SketchedSymbolDefinitions Properties

SketchedSymbolDefinitions.Application Property Introduced in Inventor 5.3

SketchedSymbolDefinitions.Count Property Introduced in Inventor 5.3

SketchedSymbolDefinitions.Type Property Introduced in Inventor 5.3

SketchedSymbols Interface Introduced in Inventor 5.3

SketchedSymbols Methods

SketchedSymbols.Add Method Introduced in Inventor 5.3

SketchedSymbols.AddWithLeader Method Introduced in Inventor 11

SketchedSymbols.Item Method Introduced in Inventor 5.3

SketchedSymbols Properties

SketchedSymbols.Application Property Introduced in Inventor 5.3

SketchedSymbols.Count Property Introduced in Inventor 5.3

SketchedSymbols.Type Property Introduced in Inventor 5.3

SketchEllipse Interface Introduced in Inventor 5

SketchEllipse Methods

SketchEllipse.GetCustomLineType Method Introduced in Inventor 2008

SketchEllipse.SetCustomLineType Method Introduced in Inventor 2008

SketchEllipse Properties

SketchEllipse.Area Property Introduced in Inventor 5

SketchEllipse.CenterSketchPoint Property Introduced in Inventor 5

SketchEllipse.CurvatureDisplay Property Introduced in Inventor 11

SketchEllipse.Geometry Property Introduced in Inventor 5

SketchEllipse.Length Property Introduced in Inventor 2010

SketchEllipse.LineDefinitionSpace Property Introduced in Inventor 9

SketchEllipse.LineScale Property Introduced in Inventor 9

SketchEllipse.LineType Property Introduced in Inventor 9

SketchEllipse.LineWeight Property Introduced in Inventor 9

SketchEllipse.MajorAxisVector Property Introduced in Inventor 5

SketchEllipse.MajorRadius Property Introduced in Inventor 5

SketchEllipse.MinorRadius Property Introduced in Inventor 5

SketchEllipse.OverrideColor Property Introduced in Inventor 9

SketchEllipse3D Interface Introduced in Inventor 6

SketchEllipse3D Properties

SketchEllipse3D.Area Property Introduced in Inventor 6

SketchEllipse3D.CenterPoint Property Introduced in Inventor 6

SketchEllipse3D.CurvatureDisplay Property Introduced in Inventor 11

SketchEllipse3D.Geometry Property Introduced in Inventor 6

SketchEllipse3D.Length Property Introduced in Inventor 2010

SketchEllipse3D.MajorAxisVector Property Introduced in Inventor 2010

SketchEllipse3D.MajorRadius Property Introduced in Inventor 2010

SketchEllipse3D.MinorRadius Property Introduced in Inventor 2010

SketchEllipse3DProxy Interface Introduced in Inventor 6

SketchEllipse3DProxy Properties

SketchEllipse3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchEllipse3DProxy.NativeObject Property Introduced in Inventor 6

SketchEllipseProxy Interface Introduced in Inventor 6

SketchEllipseProxy Properties

SketchEllipseProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchEllipseProxy.NativeObject Property Introduced in Inventor 6

SketchEllipses Interface Introduced in Inventor 5

SketchEllipses Methods

SketchEllipses.Add Method Introduced in Inventor 5

SketchEllipses.Item Method Introduced in Inventor 5

SketchEllipses Properties

SketchEllipses.Application Property Introduced in Inventor 5

SketchEllipses.Count Property Introduced in Inventor 5

SketchEllipses.Type Property Introduced in Inventor 5

SketchEllipses3D Interface Introduced in Inventor 6

SketchEllipses3D Methods

SketchEllipses3D.Item Method Introduced in Inventor 6

SketchEllipses3D Properties

SketchEllipses3D.Application Property Introduced in Inventor 6

SketchEllipses3D.Count Property Introduced in Inventor 6

SketchEllipses3D.Type Property Introduced in Inventor 6

SketchEllipticalArc Interface Introduced in Inventor 5

SketchEllipticalArc Methods

SketchEllipticalArc.GetCustomLineType Method Introduced in Inventor 2008

SketchEllipticalArc.SetCustomLineType Method Introduced in Inventor 2008

SketchEllipticalArc Properties

SketchEllipticalArc.CenterSketchPoint Property Introduced in Inventor 5

SketchEllipticalArc.CurvatureDisplay Property Introduced in Inventor 11

SketchEllipticalArc.EndSketchPoint Property Introduced in Inventor 5

SketchEllipticalArc.Geometry Property Introduced in Inventor 5

SketchEllipticalArc.Length Property Introduced in Inventor 5

SketchEllipticalArc.LineDefinitionSpace Property Introduced in Inventor 9

SketchEllipticalArc.LineScale Property Introduced in Inventor 9

SketchEllipticalArc.LineType Property Introduced in Inventor 9

SketchEllipticalArc.LineWeight Property Introduced in Inventor 9

SketchEllipticalArc.MajorAxisVector Property Introduced in Inventor 5

SketchEllipticalArc.MajorRadius Property Introduced in Inventor 5

SketchEllipticalArc.MinorRadius Property Introduced in Inventor 5

SketchEllipticalArc.OverrideColor Property Introduced in Inventor 9

SketchEllipticalArc.StartAngle Property Introduced in Inventor 5

SketchEllipticalArc.StartSketchPoint Property Introduced in Inventor 5

SketchEllipticalArc.SweepAngle Property Introduced in Inventor 5

SketchEllipticalArc3D Interface Introduced in Inventor 6

SketchEllipticalArc3D Properties

SketchEllipticalArc3D.CenterPoint Property Introduced in Inventor 6

SketchEllipticalArc3D.CurvatureDisplay Property Introduced in Inventor 11

SketchEllipticalArc3D.EndSketchPoint Property Introduced in Inventor 8

SketchEllipticalArc3D.Geometry Property Introduced in Inventor 6

SketchEllipticalArc3D.Length Property Introduced in Inventor 6

SketchEllipticalArc3D.MajorAxisVector Property Introduced in Inventor 2010

SketchEllipticalArc3D.MajorRadius Property Introduced in Inventor 2010

SketchEllipticalArc3D.MinorRadius Property Introduced in Inventor 2010

SketchEllipticalArc3D.StartAngle Property Introduced in Inventor 2010

SketchEllipticalArc3D.StartSketchPoint Property Introduced in Inventor 8

SketchEllipticalArc3D.SweepAngle Property Introduced in Inventor 2010

SketchEllipticalArc3DProxy Interface Introduced in Inventor 6

SketchEllipticalArc3DProxy Properties

SketchEllipticalArc3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchEllipticalArc3DProxy.NativeObject Property Introduced in Inventor 6

SketchEllipticalArcProxy Interface Introduced in Inventor 6

SketchEllipticalArcProxy Properties

SketchEllipticalArcProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchEllipticalArcProxy.NativeObject Property Introduced in Inventor 6

SketchEllipticalArcs Interface Introduced in Inventor 5

SketchEllipticalArcs Methods

SketchEllipticalArcs.Add Method Introduced in Inventor 10

SketchEllipticalArcs.Item Method Introduced in Inventor 5

SketchEllipticalArcs Properties

SketchEllipticalArcs.Application Property Introduced in Inventor 5

SketchEllipticalArcs.Count Property Introduced in Inventor 5

SketchEllipticalArcs.Type Property Introduced in Inventor 5

SketchEllipticalArcs3D Interface Introduced in Inventor 6

SketchEllipticalArcs3D Methods

SketchEllipticalArcs3D.Item Method Introduced in Inventor 6

SketchEllipticalArcs3D Properties

SketchEllipticalArcs3D.Application Property Introduced in Inventor 6

SketchEllipticalArcs3D.Count Property Introduced in Inventor 6

SketchEllipticalArcs3D.Type Property Introduced in Inventor 6

SketchEntities3DEnumerator Interface Introduced in Inventor 6

SketchEntities3DEnumerator Methods

SketchEntities3DEnumerator.Item Method Introduced in Inventor 6

SketchEntities3DEnumerator Properties

SketchEntities3DEnumerator.Count Property Introduced in Inventor 6

SketchEntities3DEnumerator.Type Property Introduced in Inventor 6

SketchEntitiesEnumerator Interface Introduced in Inventor 5

SketchEntitiesEnumerator Methods

SketchEntitiesEnumerator.Item Method Introduced in Inventor 5

SketchEntitiesEnumerator Properties

SketchEntitiesEnumerator.Count Property Introduced in Inventor 5

SketchEntitiesEnumerator.Type Property Introduced in Inventor 5

SketchEntity Interface Introduced in Inventor 5

SketchEntity Methods

SketchEntity.Delete Method Introduced in Inventor 5

SketchEntity.GetReferenceKey Method Introduced in Inventor 5

SketchEntity Properties

SketchEntity.Application Property Introduced in Inventor 5

SketchEntity.AttributeSets Property Introduced in Inventor 5

SketchEntity.Constraints Property Introduced in Inventor 5

SketchEntity.ConstraintStatus Property Introduced in Inventor 10

SketchEntity.Construction Property Introduced in Inventor 5

SketchEntity.ContainingSketchBlock Property Introduced in Inventor 2010

SketchEntity.DisabledActionTypes Property Introduced in Inventor 9

SketchEntity.HasReferenceComponent Property Introduced in Inventor 5.3

SketchEntity.Layer Property Introduced in Inventor 10

SketchEntity.OwnedBy Property Introduced in Inventor 11

SketchEntity.Parent Property Introduced in Inventor 5

SketchEntity.RangeBox Property Introduced in Inventor 5

SketchEntity.Reference Property Introduced in Inventor 5

SketchEntity.ReferenceComponent Property Introduced in Inventor 5.3

SketchEntity.ReferencedEntity Property Introduced in Inventor 5

SketchEntity.SketchBlockPath Property Introduced in Inventor 2010

SketchEntity.SketchOnly Property Introduced in Inventor 2008

SketchEntity.Type Property Introduced in Inventor 5

SketchEntity3D Interface Introduced in Inventor 6

SketchEntity3D Methods

SketchEntity3D.AssociativeID Method

SketchEntity3D.Delete Method Introduced in Inventor 6

SketchEntity3D.GetReferenceKey Method Introduced in Inventor 6

SketchEntity3D Properties

SketchEntity3D.Application Property Introduced in Inventor 6

SketchEntity3D.AttributeSets Property Introduced in Inventor 6

SketchEntity3D.Constraints3D Property Introduced in Inventor 7

SketchEntity3D.ConstraintStatus Property Introduced in Inventor 2008

SketchEntity3D.Construction Property Introduced in Inventor 11

SketchEntity3D.HasReferenceComponent Property Introduced in Inventor 6

SketchEntity3D.OwnedBy Property Introduced in Inventor 11

SketchEntity3D.Parent Property Introduced in Inventor 6

SketchEntity3D.RangeBox Property Introduced in Inventor 6

SketchEntity3D.Reference Property Introduced in Inventor 7

SketchEntity3D.ReferenceComponent Property Introduced in Inventor 6

SketchEntity3D.ReferencedEntity Property Introduced in Inventor 7

SketchEntity3D.Type Property Introduced in Inventor 6

Sketches3D Interface Introduced in Inventor 6

Sketches3D Methods

Sketches3D.Add Method Introduced in Inventor 6

Sketches3D.Item Method Introduced in Inventor 6

Sketches3D Properties

Sketches3D.Application Property Introduced in Inventor 6

Sketches3D.Count Property Introduced in Inventor 6

Sketches3D.Type Property Introduced in Inventor 6

Sketches3DEnumerator Interface Introduced in Inventor 2009

Sketches3DEnumerator Methods

Sketches3DEnumerator.Item Method Introduced in Inventor 2009

Sketches3DEnumerator Properties

Sketches3DEnumerator.Count Property Introduced in Inventor 2009

Sketches3DEnumerator.Type Property Introduced in Inventor 2009

SketchesEnumerator Interface Introduced in Inventor 5.3

SketchesEnumerator Methods

SketchesEnumerator.Item Method Introduced in Inventor 5.3

SketchesEnumerator Properties

SketchesEnumerator.Count Property Introduced in Inventor 5.3

SketchesEnumerator.Type Property Introduced in Inventor 5.3

SketchEvents CoClass Introduced in Inventor 11

SketchEventsObject Interface Introduced in Inventor 11

SketchEventsObject Properties

SketchEventsObject.Application Property Introduced in Inventor 11

SketchEventsObject.Parent Property Introduced in Inventor 11

SketchEventsObject.Type Property Introduced in Inventor 11

SketchEventsSink Interface Introduced in Inventor 11

SketchEventsSink Methods

SketchEventsSink.OnDelete Method Introduced in Inventor 11

SketchEventsSink.OnNewSketch Method Introduced in Inventor 11

SketchEventsSink.OnNewSketch3D Method Introduced in Inventor 11

SketchEventsSink.OnSketch3DChange Method Introduced in Inventor 11

SketchEventsSink.OnSketch3DSolve Method

SketchEventsSink.OnSketchChange Method Introduced in Inventor 11

SketchFillRegion Interface Introduced in Inventor 10

SketchFillRegion Methods

SketchFillRegion.Delete Method Introduced in Inventor 10

SketchFillRegion.GetReferenceKey Method Introduced in Inventor 10

SketchFillRegion Properties

SketchFillRegion.Application Property Introduced in Inventor 10

SketchFillRegion.AttributeSets Property Introduced in Inventor 10

SketchFillRegion.Color Property Introduced in Inventor 10

SketchFillRegion.Parent Property Introduced in Inventor 10

SketchFillRegion.Profile Property Introduced in Inventor 10

SketchFillRegion.Type Property Introduced in Inventor 10

SketchFillRegions Interface Introduced in Inventor 10

SketchFillRegions Methods

SketchFillRegions.Add Method Introduced in Inventor 10

SketchFillRegions.Item Method Introduced in Inventor 10

SketchFillRegions Properties

SketchFillRegions.Application Property Introduced in Inventor 10

SketchFillRegions.Count Property Introduced in Inventor 10

SketchFillRegions.Type Property Introduced in Inventor 10

SketchFixedSpline Interface Introduced in Inventor 9

SketchFixedSpline Methods

SketchFixedSpline.ConvertToSpline Method Introduced in Inventor 10

SketchFixedSpline.Edit Method Introduced in Inventor 9

SketchFixedSpline.GetCustomLineType Method Introduced in Inventor 2008

SketchFixedSpline.SetCustomLineType Method Introduced in Inventor 2008

SketchFixedSpline Properties

SketchFixedSpline.Closed Property Introduced in Inventor 9

SketchFixedSpline.EndSketchPoint Property Introduced in Inventor 9

SketchFixedSpline.Geometry Property Introduced in Inventor 9

SketchFixedSpline.Length Property Introduced in Inventor 9

SketchFixedSpline.LineDefinitionSpace Property Introduced in Inventor 9

SketchFixedSpline.LineScale Property Introduced in Inventor 9

SketchFixedSpline.LineType Property Introduced in Inventor 9

SketchFixedSpline.LineWeight Property Introduced in Inventor 9

SketchFixedSpline.OverrideColor Property Introduced in Inventor 9

SketchFixedSpline.StartSketchPoint Property Introduced in Inventor 9

SketchFixedSpline3D Interface Introduced in Inventor 9

SketchFixedSpline3D Methods

SketchFixedSpline3D.ConvertToSpline Method Introduced in Inventor 10

SketchFixedSpline3D.Edit Method Introduced in Inventor 9

SketchFixedSpline3D.EditByEdge Method Introduced in Inventor 2010

SketchFixedSpline3D Properties

SketchFixedSpline3D.Closed Property Introduced in Inventor 9

SketchFixedSpline3D.EndSketchPoint Property Introduced in Inventor 9

SketchFixedSpline3D.Geometry Property Introduced in Inventor 9

SketchFixedSpline3D.IsDefinedByEdge Property Introduced in Inventor 2010

SketchFixedSpline3D.Length Property Introduced in Inventor 9

SketchFixedSpline3D.StartSketchPoint Property Introduced in Inventor 9

SketchFixedSpline3DProxy Interface Introduced in Inventor 9

SketchFixedSpline3DProxy Properties

SketchFixedSpline3DProxy.ContainingOccurrence Property Introduced in Inventor 9

SketchFixedSpline3DProxy.NativeObject Property Introduced in Inventor 9

SketchFixedSplineProxy Interface Introduced in Inventor 9

SketchFixedSplineProxy Properties

SketchFixedSplineProxy.ContainingOccurrence Property Introduced in Inventor 9

SketchFixedSplineProxy.NativeObject Property Introduced in Inventor 9

SketchFixedSplines Interface Introduced in Inventor 9

SketchFixedSplines Methods

SketchFixedSplines.Add Method Introduced in Inventor 9

SketchFixedSplines.Item Method Introduced in Inventor 9

SketchFixedSplines Properties

SketchFixedSplines.Application Property Introduced in Inventor 9

SketchFixedSplines.Count Property Introduced in Inventor 9

SketchFixedSplines.Type Property Introduced in Inventor 9

SketchFixedSplines3D Interface Introduced in Inventor 9

SketchFixedSplines3D Methods

SketchFixedSplines3D.Add Method Introduced in Inventor 9

SketchFixedSplines3D.AddByEdge Method Introduced in Inventor 2010

SketchFixedSplines3D.Item Method Introduced in Inventor 9

SketchFixedSplines3D Properties

SketchFixedSplines3D.Application Property Introduced in Inventor 9

SketchFixedSplines3D.Count Property Introduced in Inventor 9

SketchFixedSplines3D.Type Property Introduced in Inventor 9

SketchHolePlacementDefinition Interface Introduced in Inventor 10

SketchHolePlacementDefinition Properties

SketchHolePlacementDefinition.HoleCenterPoints Property Introduced in Inventor 10

SketchImage Interface Introduced in Inventor 11

SketchImage Methods

SketchImage.Delete Method Introduced in Inventor 11

SketchImage.GetReferenceKey Method Introduced in Inventor 11

SketchImage.MirrorHorizontal Method Introduced in Inventor 11

SketchImage.MirrorVertical Method Introduced in Inventor 11

SketchImage.RotateLeft Method Introduced in Inventor 11

SketchImage.RotateRight Method Introduced in Inventor 11

SketchImage.Update Method Introduced in Inventor 11

SketchImage Properties

SketchImage.Application Property Introduced in Inventor 11

SketchImage.AttributeSets Property Introduced in Inventor 11

SketchImage.BoundaryGeometry Property Introduced in Inventor 11

SketchImage.ContainingSketchBlock Property Introduced in Inventor 2010

SketchImage.Height Property Introduced in Inventor 2010

SketchImage.Image Property

SketchImage.ImageAlpha Property

SketchImage.LinkedToFile Property Introduced in Inventor 11

SketchImage.Name Property Introduced in Inventor 11

SketchImage.Parent Property Introduced in Inventor 11

SketchImage.Position Property Introduced in Inventor 11

SketchImage.ReferencedFileDescriptor Property Introduced in Inventor 11

SketchImage.SketchBlockPath Property Introduced in Inventor 2010

SketchImage.Transparent Property Introduced in Inventor 11

SketchImage.Type Property Introduced in Inventor 11

SketchImage.Visible Property Introduced in Inventor 11

SketchImage.Width Property Introduced in Inventor 2010

SketchImageProxy Interface Introduced in Inventor 11

SketchImageProxy Properties

SketchImageProxy.ContainingOccurrence Property Introduced in Inventor 11

SketchImageProxy.NativeObject Property Introduced in Inventor 11

SketchImages Interface Introduced in Inventor 11

SketchImages Methods

SketchImages.Add Method Introduced in Inventor 11

SketchImages.Item Method Introduced in Inventor 11

SketchImages Properties

SketchImages.Application Property Introduced in Inventor 11

SketchImages.Count Property Introduced in Inventor 11

SketchImages.Type Property Introduced in Inventor 11

SketchLine Interface Introduced in Inventor 5

SketchLine Methods

SketchLine.GetCustomLineType Method Introduced in Inventor 2008

SketchLine.SetCustomLineType Method Introduced in Inventor 2008

SketchLine Properties

SketchLine.Centerline Property Introduced in Inventor 5

SketchLine.EndSketchPoint Property Introduced in Inventor 5

SketchLine.Geometry Property Introduced in Inventor 5

SketchLine.Length Property Introduced in Inventor 5

SketchLine.LineDefinitionSpace Property Introduced in Inventor 9

SketchLine.LineScale Property Introduced in Inventor 9

SketchLine.LineType Property Introduced in Inventor 9

SketchLine.LineWeight Property Introduced in Inventor 9

SketchLine.OverrideColor Property Introduced in Inventor 9

SketchLine.StartSketchPoint Property Introduced in Inventor 5

SketchLine3D Interface Introduced in Inventor 6

SketchLine3D Properties

SketchLine3D.EndSketchPoint Property Introduced in Inventor 8

SketchLine3D.Geometry Property Introduced in Inventor 6

SketchLine3D.Length Property Introduced in Inventor 6

SketchLine3D.StartSketchPoint Property Introduced in Inventor 8

SketchLine3DProxy Interface Introduced in Inventor 6

SketchLine3DProxy Properties

SketchLine3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchLine3DProxy.NativeObject Property Introduced in Inventor 6

SketchLineProxy Interface Introduced in Inventor 6

SketchLineProxy Properties

SketchLineProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchLineProxy.NativeObject Property Introduced in Inventor 6

SketchLines Interface Introduced in Inventor 5

SketchLines Methods

SketchLines.AddAsPolygon Method

SketchLines.AddAsThreePointRectangle Method Introduced in Inventor 5

SketchLines.AddAsTwoPointRectangle Method Introduced in Inventor 5

SketchLines.AddByTwoPoints Method Introduced in Inventor 5

SketchLines.Item Method Introduced in Inventor 5

SketchLines Properties

SketchLines.Application Property Introduced in Inventor 5

SketchLines.Count Property Introduced in Inventor 5

SketchLines.Type Property Introduced in Inventor 5

SketchLines3D Interface Introduced in Inventor 6

SketchLines3D Methods

SketchLines3D.AddByTwoPoints Method Introduced in Inventor 6

SketchLines3D.Item Method Introduced in Inventor 6

SketchLines3D Properties

SketchLines3D.Application Property Introduced in Inventor 6

SketchLines3D.Count Property Introduced in Inventor 6

SketchLines3D.Type Property Introduced in Inventor 6

SketchOffsetSpline Interface Introduced in Inventor 9

SketchOffsetSpline Methods

SketchOffsetSpline.ConvertToSpline Method Introduced in Inventor 9

SketchOffsetSpline.GetCustomLineType Method Introduced in Inventor 2008

SketchOffsetSpline.SetCustomLineType Method Introduced in Inventor 2008

SketchOffsetSpline Properties

SketchOffsetSpline.Closed Property Introduced in Inventor 9

SketchOffsetSpline.CurvatureDisplay Property Introduced in Inventor 11

SketchOffsetSpline.EndSketchPoint Property Introduced in Inventor 9

SketchOffsetSpline.Geometry Property Introduced in Inventor 9

SketchOffsetSpline.Length Property Introduced in Inventor 9

SketchOffsetSpline.LineDefinitionSpace Property Introduced in Inventor 9

SketchOffsetSpline.LineScale Property Introduced in Inventor 9

SketchOffsetSpline.LineType Property Introduced in Inventor 9

SketchOffsetSpline.LineWeight Property Introduced in Inventor 9

SketchOffsetSpline.OriginalSpline Property Introduced in Inventor 11

SketchOffsetSpline.OverrideColor Property Introduced in Inventor 9

SketchOffsetSpline.StartSketchPoint Property Introduced in Inventor 9

SketchOffsetSplineProxy Interface Introduced in Inventor 9

SketchOffsetSplineProxy Properties

SketchOffsetSplineProxy.ContainingOccurrence Property Introduced in Inventor 9

SketchOffsetSplineProxy.NativeObject Property Introduced in Inventor 9

SketchOffsetSplines Interface Introduced in Inventor 9

SketchOffsetSplines Methods

SketchOffsetSplines.Item Method Introduced in Inventor 9

SketchOffsetSplines Properties

SketchOffsetSplines.Application Property Introduced in Inventor 9

SketchOffsetSplines.Count Property Introduced in Inventor 9

SketchOffsetSplines.Type Property Introduced in Inventor 9

SketchOptions Interface Introduced in Inventor 9

SketchOptions Properties

SketchOptions.Application Property Introduced in Inventor 9

SketchOptions.AutomaticReferenceEdges Property Introduced in Inventor 9

SketchOptions.AutoProjectEdges Property Introduced in Inventor 9

SketchOptions.AutoProjectPartOrigin Property Introduced in Inventor 11

SketchOptions.ConstraintPriority Property Introduced in Inventor 9

SketchOptions.ConstraintToolbarScale Property Introduced in Inventor 2008

SketchOptions.DisplayAxes Property Introduced in Inventor 9

SketchOptions.DisplayCoincidentConstraintsOnCreation Property Introduced in Inventor 2010

SketchOptions.DisplayCoordinateSystemIndicator Property Introduced in Inventor 9

SketchOptions.DisplayGridLines Property Introduced in Inventor 9

SketchOptions.DisplayMinorGridLines Property Introduced in Inventor 9

SketchOptions.EditDimensionWhenCreated Property Introduced in Inventor 9

SketchOptions.HeadsUpDisplayOptions Property Introduced in Inventor 2011

SketchOptions.OverConstrainedDimensionBehavior Property Introduced in Inventor 9

SketchOptions.ParallelViewOnSketchCreation Property Introduced in Inventor 11

SketchOptions.PointAlignment Property Introduced in Inventor 2010

SketchOptions.SnapToGrid Property Introduced in Inventor 9

SketchOptions.SplineDefaultTension Property Introduced in Inventor 2010

SketchOptions.SplineFitMethod Property Introduced in Inventor 2010

SketchOptions.Type Property Introduced in Inventor 9

SketchPoint Interface Introduced in Inventor 5

SketchPoint Methods

SketchPoint.Merge Method Introduced in Inventor 5

SketchPoint.MoveBy Method Introduced in Inventor 5

SketchPoint.MoveTo Method Introduced in Inventor 5

SketchPoint Properties

SketchPoint.AttachedEntities Property Introduced in Inventor 5

SketchPoint.ConnectionPoint Property Introduced in Inventor 2008

SketchPoint.Geometry Property Introduced in Inventor 5

SketchPoint.HoleCenter Property Introduced in Inventor 5

SketchPoint.InsertionPoint Property Introduced in Inventor 2008

SketchPoint3D Interface Introduced in Inventor 6

SketchPoint3D Methods

SketchPoint3D.ConnectTo Method Introduced in Inventor 6

SketchPoint3D.MoveBy Method Introduced in Inventor 11

SketchPoint3D.MoveTo Method Introduced in Inventor 11

SketchPoint3D Properties

SketchPoint3D.AttachedEntities Property Introduced in Inventor 6

SketchPoint3D.Geometry Property Introduced in Inventor 6

SketchPoint3D.HoleCenter Property Introduced in Inventor 11

SketchPoint3DProxy Interface Introduced in Inventor 6

SketchPoint3DProxy Properties

SketchPoint3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchPoint3DProxy.NativeObject Property Introduced in Inventor 6

SketchPointProxy Interface Introduced in Inventor 6

SketchPointProxy Properties

SketchPointProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchPointProxy.NativeObject Property Introduced in Inventor 6

SketchPoints Interface Introduced in Inventor 5

SketchPoints Methods

SketchPoints.Add Method Introduced in Inventor 5

SketchPoints.Item Method Introduced in Inventor 5

SketchPoints Properties

SketchPoints.Application Property Introduced in Inventor 5

SketchPoints.Count Property Introduced in Inventor 5

SketchPoints.Type Property Introduced in Inventor 5

SketchPoints3D Interface Introduced in Inventor 6

SketchPoints3D Methods

SketchPoints3D.Add Method Introduced in Inventor 11

SketchPoints3D.Item Method Introduced in Inventor 6

SketchPoints3D Properties

SketchPoints3D.Application Property Introduced in Inventor 6

SketchPoints3D.Count Property Introduced in Inventor 6

SketchPoints3D.Type Property Introduced in Inventor 6

SketchSettings Interface Introduced in Inventor 8

SketchSettings Properties

SketchSettings.Application Property Introduced in Inventor 8

SketchSettings.DisplayLineWeights Property Introduced in Inventor 2008

SketchSettings.LineWeightType Property Introduced in Inventor 2008

SketchSettings.MinorLinesPerMajorGridLine Property Introduced in Inventor 8

SketchSettings.Parent Property Introduced in Inventor 8

SketchSettings.SnapsPerMinorGrid Property Introduced in Inventor 8

SketchSettings.Type Property Introduced in Inventor 8

SketchSettings.UpperLimitForFirstRangeOfLineWeights Property Introduced in Inventor 2008

SketchSettings.UpperLimitForSecondRangeOfLineWeights Property Introduced in Inventor 2008

SketchSettings.UpperLimitForThirdRangeOfLineWeights Property Introduced in Inventor 2008

SketchSettings.XSnapSpacing Property Introduced in Inventor 8

SketchSettings.YSnapSpacing Property Introduced in Inventor 8

SketchSpline Interface Introduced in Inventor 5

SketchSpline Methods

SketchSpline.FitPoint Method Introduced in Inventor 5

SketchSpline.GetCustomLineType Method Introduced in Inventor 2008

SketchSpline.GetHandle Method Introduced in Inventor 2008

SketchSpline.GetHandleStatus Method Introduced in Inventor 2008

SketchSpline.InsertFitPoint Method Introduced in Inventor 5

SketchSpline.SetCustomLineType Method Introduced in Inventor 2008

SketchSpline.SetHandleStatus Method Introduced in Inventor 2008

SketchSpline Properties

SketchSpline.Closed Property Introduced in Inventor 5

SketchSpline.CurvatureDisplay Property Introduced in Inventor 8

SketchSpline.EndSketchPoint Property Introduced in Inventor 8

SketchSpline.FitMethod Property Introduced in Inventor 5

SketchSpline.FitPointCount Property Introduced in Inventor 5

SketchSpline.Geometry Property Introduced in Inventor 5

SketchSpline.Length Property Introduced in Inventor 5

SketchSpline.LineDefinitionSpace Property Introduced in Inventor 9

SketchSpline.LineScale Property Introduced in Inventor 9

SketchSpline.LineType Property Introduced in Inventor 9

SketchSpline.LineWeight Property Introduced in Inventor 9

SketchSpline.OverrideColor Property Introduced in Inventor 9

SketchSpline.StartSketchPoint Property Introduced in Inventor 8

SketchSpline.Tension Property Introduced in Inventor 9

SketchSpline3D Interface Introduced in Inventor 6

SketchSpline3D Methods

SketchSpline3D.Disconnect Method Introduced in Inventor 8

SketchSpline3D.FitPoint Method Introduced in Inventor 8

SketchSpline3D.GetHandle Method Introduced in Inventor 2008

SketchSpline3D.GetHandleStatus Method Introduced in Inventor 2008

SketchSpline3D.InsertFitPoint Method Introduced in Inventor 8

SketchSpline3D.SetHandleStatus Method Introduced in Inventor 2008

SketchSpline3D.Split Method Introduced in Inventor 8

SketchSpline3D Properties

SketchSpline3D.Closed Property Introduced in Inventor 6

SketchSpline3D.CurvatureDisplay Property Introduced in Inventor 8

SketchSpline3D.EndSketchPoint Property Introduced in Inventor 8

SketchSpline3D.EndTangentScale Property Introduced in Inventor 8

SketchSpline3D.FitMethod Property Introduced in Inventor 8

SketchSpline3D.FitPointCount Property Introduced in Inventor 8

SketchSpline3D.Geometry Property Introduced in Inventor 6

SketchSpline3D.Length Property Introduced in Inventor 6

SketchSpline3D.StartSketchPoint Property Introduced in Inventor 8

SketchSpline3D.StartTangentScale Property Introduced in Inventor 8

SketchSpline3D.Tension Property Introduced in Inventor 8

SketchSpline3DProxy Interface Introduced in Inventor 6

SketchSpline3DProxy Properties

SketchSpline3DProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchSpline3DProxy.NativeObject Property Introduced in Inventor 6

SketchSplineHandle Interface Introduced in Inventor 2008

SketchSplineHandle Properties

SketchSplineHandle.FitPoint Property Introduced in Inventor 2008

SketchSplineHandle.Spline Property Introduced in Inventor 2008

SketchSplineHandle.Tangent Property Introduced in Inventor 2008

SketchSplineHandle.Weight Property Introduced in Inventor 2008

SketchSplineHandle3D Interface Introduced in Inventor 2008

SketchSplineHandle3D Properties

SketchSplineHandle3D.FitPoint Property Introduced in Inventor 2008

SketchSplineHandle3D.Spline Property Introduced in Inventor 2008

SketchSplineHandle3D.Tangent Property Introduced in Inventor 2008

SketchSplineHandle3D.Weight Property Introduced in Inventor 2008

SketchSplineHandle3DProxy Interface Introduced in Inventor 2008

SketchSplineHandle3DProxy Properties

SketchSplineHandle3DProxy.ContainingOccurrence Property Introduced in Inventor 2008

SketchSplineHandle3DProxy.NativeObject Property Introduced in Inventor 2008

SketchSplineHandleProxy Interface Introduced in Inventor 2008

SketchSplineHandleProxy Properties

SketchSplineHandleProxy.ContainingOccurrence Property Introduced in Inventor 2008

SketchSplineHandleProxy.NativeObject Property Introduced in Inventor 2008

SketchSplineProxy Interface Introduced in Inventor 6

SketchSplineProxy Properties

SketchSplineProxy.ContainingOccurrence Property Introduced in Inventor 6

SketchSplineProxy.NativeObject Property Introduced in Inventor 6

SketchSplines Interface Introduced in Inventor 5

SketchSplines Methods

SketchSplines.Add Method Introduced in Inventor 5

SketchSplines.Item Method Introduced in Inventor 5

SketchSplines Properties

SketchSplines.Application Property Introduced in Inventor 5

SketchSplines.Count Property Introduced in Inventor 5

SketchSplines.Type Property Introduced in Inventor 5

SketchSplines3D Interface Introduced in Inventor 6

SketchSplines3D Methods

SketchSplines3D.Add Method Introduced in Inventor 8

SketchSplines3D.Item Method Introduced in Inventor 6

SketchSplines3D Properties

SketchSplines3D.Application Property Introduced in Inventor 6

SketchSplines3D.Count Property Introduced in Inventor 6

SketchSplines3D.Type Property Introduced in Inventor 6

SmoothConstraint Interface Introduced in Inventor 11

SmoothConstraint Properties

SmoothConstraint.EntityOne Property Introduced in Inventor 11

SmoothConstraint.EntityTwo Property Introduced in Inventor 11

SmoothConstraint3D Interface Introduced in Inventor 11

SmoothConstraint3D Properties

SmoothConstraint3D.EntityOne Property Introduced in Inventor 11

SmoothConstraint3D.EntityTwo Property Introduced in Inventor 11

SmoothConstraint3DProxy Interface Introduced in Inventor 11

SmoothConstraint3DProxy Properties

SmoothConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 11

SmoothConstraint3DProxy.NativeObject Property Introduced in Inventor 11

SmoothConstraintProxy Interface Introduced in Inventor 11

SmoothConstraintProxy Properties

SmoothConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

SmoothConstraintProxy.NativeObject Property Introduced in Inventor 11

SnapFitFeature Interface Introduced in Inventor 2010

SnapFitFeatureProxy Interface Introduced in Inventor 2010

SnapFitFeatureProxy Properties

SnapFitFeatureProxy.ContainingOccurrence Property Introduced in Inventor 2010

SnapFitFeatureProxy.NativeObject Property Introduced in Inventor 2010

SnapFitFeatures Interface Introduced in Inventor 2010

SnapFitFeatures Methods

SnapFitFeatures.Item Method Introduced in Inventor 2010

SnapFitFeatures Properties

SnapFitFeatures.Application Property Introduced in Inventor 2010

SnapFitFeatures.Count Property Introduced in Inventor 2010

SnapFitFeatures.Type Property Introduced in Inventor 2010

SoftwareVersion Interface Introduced in Inventor 4

SoftwareVersion Properties

SoftwareVersion.BetaVersion Property Introduced in Inventor 4

SoftwareVersion.BuildIdentifier Property Introduced in Inventor 4

SoftwareVersion.DisplayName Property Introduced in Inventor 4

SoftwareVersion.DisplayVersion Property Introduced in Inventor 2009

SoftwareVersion.Is64BitVersion Property Introduced in Inventor 2008

SoftwareVersion.IsEducationVersion Property Introduced in Inventor 2010

SoftwareVersion.Major Property Introduced in Inventor 4

SoftwareVersion.Minor Property Introduced in Inventor 4

SoftwareVersion.NotProduction Property Introduced in Inventor 4

SoftwareVersion.ProductEdition Property Introduced in Inventor 2009

SoftwareVersion.ProductName Property

SoftwareVersion.ServicePack Property Introduced in Inventor 4

SoftwareVersion.Type Property Introduced in Inventor 4

Sphere Interface Introduced in Inventor 4

Sphere Methods

Sphere.GetSphereData Method Introduced in Inventor 4

Sphere.PutSphereData Method Introduced in Inventor 4

Sphere Properties

Sphere.CenterPoint Property Introduced in Inventor 4

Sphere.Evaluator Property Introduced in Inventor 4

Sphere.Radius Property Introduced in Inventor 4

SpiralCoilExtent Interface Introduced in Inventor 5.3

SpiralCoilExtent Properties

SpiralCoilExtent.Pitch Property Introduced in Inventor 5.3

SpiralCoilExtent.Revolution Property Introduced in Inventor 5.3

SplineFitPointConstraint Interface Introduced in Inventor 5

SplineFitPointConstraint Properties

SplineFitPointConstraint.Point Property Introduced in Inventor 5

SplineFitPointConstraint.Spline Property Introduced in Inventor 5

SplineFitPointConstraintProxy Interface Introduced in Inventor 6

SplineFitPointConstraintProxy Properties

SplineFitPointConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

SplineFitPointConstraintProxy.NativeObject Property Introduced in Inventor 6

SplineFitPointsConstraint3D Interface Introduced in Inventor 8

SplineFitPointsConstraint3D Properties

SplineFitPointsConstraint3D.Points Property Introduced in Inventor 8

SplineFitPointsConstraint3D.Spline Property Introduced in Inventor 8

SplineFitPointsConstraint3DProxy Interface Introduced in Inventor 8

SplineFitPointsConstraint3DProxy Properties

SplineFitPointsConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 8

SplineFitPointsConstraint3DProxy.NativeObject Property Introduced in Inventor 8

SplitFeature Interface Introduced in Inventor 5

SplitFeature Methods

SplitFeature.SetToSplitBody Method Introduced in Inventor 2010

SplitFeature.SetToSplitFaces Method Introduced in Inventor 2008

SplitFeature.SetToTrimSolid Method Introduced in Inventor 2010

SplitFeature Properties

SplitFeature.FaceSplitSplitAll Property Introduced in Inventor 6

SplitFeature.RemovePositiveSide Property Introduced in Inventor 2010

SplitFeature.SplitTool Property Introduced in Inventor 6

SplitFeature.SplitToolType Property Introduced in Inventor 6

SplitFeature.SplitType Property Introduced in Inventor 6

SplitFeatureProxy Interface Introduced in Inventor 9

SplitFeatureProxy Properties

SplitFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

SplitFeatureProxy.NativeObject Property Introduced in Inventor 9

SplitFeatures Interface Introduced in Inventor 5

SplitFeatures Methods

SplitFeatures.Item Method Introduced in Inventor 5

SplitFeatures.SplitBody Method Introduced in Inventor 2010

SplitFeatures.SplitFaces Method Introduced in Inventor 6

SplitFeatures.TrimSolid Method Introduced in Inventor 2010

SplitFeatures Properties

SplitFeatures.Application Property Introduced in Inventor 5

SplitFeatures.Count Property Introduced in Inventor 5

SplitFeatures.Type Property Introduced in Inventor 5

StandardThreadInfo Interface Introduced in Inventor 5

StandardThreadInfo Methods

StandardThreadInfo._PitchDesignation Method

StandardThreadInfo Properties

StandardThreadInfo.Class Property Introduced in Inventor 5

StandardThreadInfo.MajorDiameterMax Property Introduced in Inventor 5

StandardThreadInfo.MajorDiameterMin Property Introduced in Inventor 5

StandardThreadInfo.MinorDiameterMax Property Introduced in Inventor 5

StandardThreadInfo.MinorDiameterMin Property Introduced in Inventor 5

StandardThreadInfo.NominalSize Property Introduced in Inventor 9

StandardThreadInfo.Pitch Property Introduced in Inventor 11

StandardThreadInfo.PitchDiameterMax Property Introduced in Inventor 5

StandardThreadInfo.PitchDiameterMin Property Introduced in Inventor 5

StandardThreadInfo.TapDrillDiameter Property Introduced in Inventor 5

Style Interface Introduced in Inventor 2008

Style Methods

Style.ConvertToLocal Method Introduced in Inventor 2008

Style.Copy Method Introduced in Inventor 2008

Style.Delete Method Introduced in Inventor 2008

Style.GetReferenceKey Method Introduced in Inventor 2008

Style.SaveToGlobal Method Introduced in Inventor 2008

Style.UpdateFromGlobal Method Introduced in Inventor 2008

Style Properties

Style.Application Property Introduced in Inventor 2008

Style.Comments Property Introduced in Inventor 2009

Style.InternalName Property Introduced in Inventor 2008

Style.InUse Property Introduced in Inventor 2008

Style.Name Property Introduced in Inventor 2008

Style.Parent Property Introduced in Inventor 2008

Style.StyleLocation Property Introduced in Inventor 2008

Style.StyleType Property Introduced in Inventor 2008

Style.Type Property Introduced in Inventor 2008

Style.UpToDate Property Introduced in Inventor 2008

StyleEvents CoClass Introduced in Inventor 11

StyleEventsObject Interface Introduced in Inventor 11

StyleEventsObject Properties

StyleEventsObject.Application Property Introduced in Inventor 11

StyleEventsObject.Parent Property Introduced in Inventor 11

StyleEventsObject.Type Property Introduced in Inventor 11

StyleEventsSink Interface Introduced in Inventor 11

StyleEventsSink Methods

StyleEventsSink.OnActivateStyle Method Introduced in Inventor 11

StyleEventsSink.OnDelete Method Introduced in Inventor 11

StyleEventsSink.OnNewStyle Method Introduced in Inventor 11

StyleEventsSink.OnStyleChange Method Introduced in Inventor 11

Styles Interface Introduced in Inventor 2008

Styles Methods

Styles.Item Method Introduced in Inventor 2008

Styles Properties

Styles.Application Property Introduced in Inventor 2008

Styles.Count Property Introduced in Inventor 2008

Styles.Type Property Introduced in Inventor 2008

StylesManager Interface Introduced in Inventor 2010

StylesManager Methods

StylesManager.GetStyleNameFromKey Method Introduced in Inventor 2010

StylesManager Properties

StylesManager.Application Property Introduced in Inventor 2010

StylesManager.Materials Property Introduced in Inventor 2010

StylesManager.Parent Property Introduced in Inventor 2010

StylesManager.Type Property Introduced in Inventor 2010

SurfaceBodies Interface Introduced in Inventor 4

SurfaceBodies Methods

SurfaceBodies.Item Method Introduced in Inventor 4

SurfaceBodies Properties

SurfaceBodies.Count Property Introduced in Inventor 4

SurfaceBodies.Type Property Introduced in Inventor 4

SurfaceBody Interface Introduced in Inventor 4

SurfaceBody Methods

SurfaceBody.BindTransientKeyToObject Method Introduced in Inventor 9

SurfaceBody.CalculateFacets Method Introduced in Inventor 5.3

SurfaceBody.CalculateFacetsAndTextureMap Method Introduced in Inventor 9

SurfaceBody.CalculateStrokes Method Introduced in Inventor 5.3

SurfaceBody.Delete Method Introduced in Inventor 2009

SurfaceBody.FindUsingRay Method Introduced in Inventor 5.3

SurfaceBody.GetASMAttributes Method

SurfaceBody.GetExistingFacets Method Introduced in Inventor 5.3

SurfaceBody.GetExistingFacetsAndTextureMap Method Introduced in Inventor 9

SurfaceBody.GetExistingFacetTolerances Method Introduced in Inventor 5.3

SurfaceBody.GetExistingStrokes Method Introduced in Inventor 5.3

SurfaceBody.GetExistingStrokeTolerances Method Introduced in Inventor 5.3

SurfaceBody.GetReferenceKey Method Introduced in Inventor 5

SurfaceBody.GetRenderStyle Method Introduced in Inventor 2010

SurfaceBody.IsEntityValid Method Introduced in Inventor 2009

SurfaceBody.IsPointInside Method Introduced in Inventor 6

SurfaceBody.LocateUsingPoint Method Introduced in Inventor 5.3

SurfaceBody.SetRenderStyle Method Introduced in Inventor 2010

SurfaceBody Properties

SurfaceBody.AffectedByFeatures Property Introduced in Inventor 2010

SurfaceBody.AlternateBody Method Introduced in Inventor 4

SurfaceBody.Application Property Introduced in Inventor 11

SurfaceBody.AttributeSets Property Introduced in Inventor 5

SurfaceBody.ComponentDefinition Property Introduced in Inventor 4

SurfaceBody.ConcaveEdges Property Introduced in Inventor 5.3

SurfaceBody.ConvexEdges Property Introduced in Inventor 5.3

SurfaceBody.CreatedByFeature Property Introduced in Inventor 2010

SurfaceBody.DataIO Property Introduced in Inventor 9

SurfaceBody.Edges Property Introduced in Inventor 4

SurfaceBody.Exported Property

SurfaceBody.Faces Property Introduced in Inventor 4

SurfaceBody.FaceShells Property Introduced in Inventor 4

SurfaceBody.GeometryForm Property Introduced in Inventor 4

SurfaceBody.IsSolid Property Introduced in Inventor 4

SurfaceBody.IsTransient Property Introduced in Inventor 2009

SurfaceBody.Name Property Introduced in Inventor 2010

SurfaceBody.Parent Property Introduced in Inventor 5

SurfaceBody.RangeBox Property Introduced in Inventor 4

SurfaceBody.Type Property Introduced in Inventor 5

SurfaceBody.Vertices Property Introduced in Inventor 6

SurfaceBody.Visible Property Introduced in Inventor 5.3

SurfaceBody.Volume Method Introduced in Inventor 4

SurfaceBody.Wires Property Introduced in Inventor 2009

SurfaceBodyDefinition Interface Introduced in Inventor 2011

SurfaceBodyDefinition Methods

SurfaceBodyDefinition.CreateTransientSurfaceBody Method

SurfaceBodyDefinition Properties

SurfaceBodyDefinition.Application Property

SurfaceBodyDefinition.EdgeDefinitions Property

SurfaceBodyDefinition.LumpDefinitions Property Introduced in Inventor 2011

SurfaceBodyDefinition.Type Property

SurfaceBodyDefinition.VertexDefinitions Property

SurfaceBodyProxy Interface Introduced in Inventor 4

SurfaceBodyProxy Properties

SurfaceBodyProxy.ContainingOccurrence Property Introduced in Inventor 4

SurfaceBodyProxy.NativeObject Property Introduced in Inventor 4

SurfaceEvaluator Interface Introduced in Inventor 4

SurfaceEvaluator Methods

SurfaceEvaluator.GetCurvatures Method Introduced in Inventor 4

SurfaceEvaluator.GetFirstDerivatives Method Introduced in Inventor 4

SurfaceEvaluator.GetNormal Method Introduced in Inventor 4

SurfaceEvaluator.GetParamAnomaly Method Introduced in Inventor 4

SurfaceEvaluator.GetParamAtPoint Method Introduced in Inventor 4

SurfaceEvaluator.GetPointAtParam Method Introduced in Inventor 4

SurfaceEvaluator.GetSecondDerivatives Method Introduced in Inventor 4

SurfaceEvaluator.GetTangents Method Introduced in Inventor 4

SurfaceEvaluator.GetThirdDerivatives Method Introduced in Inventor 4

SurfaceEvaluator.IsParamOnFace Method Introduced in Inventor 4

SurfaceEvaluator Properties

SurfaceEvaluator.Area Property Introduced in Inventor 4

SurfaceEvaluator.Continuity Property Introduced in Inventor 4

SurfaceEvaluator.ParamRangeRect Property Introduced in Inventor 4

SurfaceEvaluator.RangeBox Property Introduced in Inventor 4

SurfaceGraphics Interface Introduced in Inventor 2009

SurfaceGraphics Methods

SurfaceGraphics.GetCustomLineType Method Introduced in Inventor 2009

SurfaceGraphics.GetTransformBehavior Method Introduced in Inventor 2009

SurfaceGraphics.SetCustomLineType Method Introduced in Inventor 2009

SurfaceGraphics.SetTransformBehavior Method Introduced in Inventor 2009

SurfaceGraphics Properties

SurfaceGraphics.Body Property Introduced in Inventor 2009

SurfaceGraphics.BurnThrough Property Introduced in Inventor 2009

SurfaceGraphics.Color Property Introduced in Inventor 2009

SurfaceGraphics.DepthPriority Property Introduced in Inventor 2009

SurfaceGraphics.DisplayedEdges Property Introduced in Inventor 2009

SurfaceGraphics.DisplayedFaces Property Introduced in Inventor 2009

SurfaceGraphics.DisplaySilhouettes Property Introduced in Inventor 2009

SurfaceGraphics.LineDefinitionSpace Property Introduced in Inventor 2009

SurfaceGraphics.LineScale Property Introduced in Inventor 2009

SurfaceGraphics.LineType Property Introduced in Inventor 2009

SurfaceGraphics.LineWeight Property Introduced in Inventor 2009

SurfaceGraphicsEdge Interface Introduced in Inventor 2009

SurfaceGraphicsEdge Methods

SurfaceGraphicsEdge.GetCustomLineType Method Introduced in Inventor 2009

SurfaceGraphicsEdge.SetCustomLineType Method Introduced in Inventor 2009

SurfaceGraphicsEdge Properties

SurfaceGraphicsEdge.Application Property Introduced in Inventor 2009

SurfaceGraphicsEdge.Color Property Introduced in Inventor 2009

SurfaceGraphicsEdge.Edge Property Introduced in Inventor 2009

SurfaceGraphicsEdge.Index Property Introduced in Inventor 2010

SurfaceGraphicsEdge.LineDefinitionSpace Property Introduced in Inventor 2009

SurfaceGraphicsEdge.LineScale Property Introduced in Inventor 2009

SurfaceGraphicsEdge.LineType Property Introduced in Inventor 2009

SurfaceGraphicsEdge.LineWeight Property Introduced in Inventor 2009

SurfaceGraphicsEdge.Parent Property Introduced in Inventor 2009

SurfaceGraphicsEdge.Type Property Introduced in Inventor 2009

SurfaceGraphicsEdgeList Interface Introduced in Inventor 2009

SurfaceGraphicsEdgeList Methods

SurfaceGraphicsEdgeList.Add Method Introduced in Inventor 2009

SurfaceGraphicsEdgeList.Clear Method Introduced in Inventor 2009

SurfaceGraphicsEdgeList.Item Method Introduced in Inventor 2009

SurfaceGraphicsEdgeList.Remove Method Introduced in Inventor 2009

SurfaceGraphicsEdgeList Properties

SurfaceGraphicsEdgeList.Application Property Introduced in Inventor 2009

SurfaceGraphicsEdgeList.Count Property Introduced in Inventor 2009

SurfaceGraphicsEdgeList.Type Property Introduced in Inventor 2009

SurfaceGraphicsFace Interface Introduced in Inventor 2009

SurfaceGraphicsFace Properties

SurfaceGraphicsFace.Application Property Introduced in Inventor 2009

SurfaceGraphicsFace.Color Property Introduced in Inventor 2009

SurfaceGraphicsFace.Face Property Introduced in Inventor 2009

SurfaceGraphicsFace.Index Property Introduced in Inventor 2010

SurfaceGraphicsFace.Parent Property Introduced in Inventor 2009

SurfaceGraphicsFace.RenderStyle Property Introduced in Inventor 2009

SurfaceGraphicsFace.Type Property Introduced in Inventor 2009

SurfaceGraphicsFaceList Interface Introduced in Inventor 2009

SurfaceGraphicsFaceList Methods

SurfaceGraphicsFaceList.Add Method Introduced in Inventor 2009

SurfaceGraphicsFaceList.Clear Method Introduced in Inventor 2009

SurfaceGraphicsFaceList.Item Method Introduced in Inventor 2009

SurfaceGraphicsFaceList.Remove Method Introduced in Inventor 2009

SurfaceGraphicsFaceList Properties

SurfaceGraphicsFaceList.Application Property Introduced in Inventor 2009

SurfaceGraphicsFaceList.Count Property Introduced in Inventor 2009

SurfaceGraphicsFaceList.Type Property Introduced in Inventor 2009

SurfaceTextureStyle Interface Introduced in Inventor 2009

SurfaceTextureStyle Properties

SurfaceTextureStyle.AvailableLaySymbols Property Introduced in Inventor 2009

SurfaceTextureStyle.LeaderStyle Property Introduced in Inventor 2009

SurfaceTextureStyle.MachiningProhibitedSymbolSizeSmall Property Introduced in Inventor 2009

SurfaceTextureStyle.StandardReference Property Introduced in Inventor 2009

SurfaceTextureStyle.TextStyle Property Introduced in Inventor 2009

SurfaceTextureStylesEnumerator Interface Introduced in Inventor 2009

SurfaceTextureStylesEnumerator Methods

SurfaceTextureStylesEnumerator.Item Method Introduced in Inventor 2009

SurfaceTextureStylesEnumerator Properties

SurfaceTextureStylesEnumerator.Application Property Introduced in Inventor 2009

SurfaceTextureStylesEnumerator.Count Property Introduced in Inventor 2009

SurfaceTextureStylesEnumerator.Type Property Introduced in Inventor 2009

SurfaceTextureSymbol Interface Introduced in Inventor 2009

SurfaceTextureSymbol Methods

SurfaceTextureSymbol.Delete Method Introduced in Inventor 2009

SurfaceTextureSymbol.GetReferenceKey Method Introduced in Inventor 2009

SurfaceTextureSymbol Properties

SurfaceTextureSymbol.AdditionalProductionMethod Property Introduced in Inventor 2009

SurfaceTextureSymbol.AdditionalRoughness Property Introduced in Inventor 2009

SurfaceTextureSymbol.AdditionalSamplingLength Property Introduced in Inventor 2009

SurfaceTextureSymbol.AllAroundSymbol Property Introduced in Inventor 2009

SurfaceTextureSymbol.Application Property Introduced in Inventor 2009

SurfaceTextureSymbol.AttributeSets Property Introduced in Inventor 2009

SurfaceTextureSymbol.ForceTail Property Introduced in Inventor 2009

SurfaceTextureSymbol.LayDirection Property Introduced in Inventor 2009

SurfaceTextureSymbol.Layer Property Introduced in Inventor 2009

SurfaceTextureSymbol.Leader Property Introduced in Inventor 2009

SurfaceTextureSymbol.MachiningAllowance Property Introduced in Inventor 2009

SurfaceTextureSymbol.Majority Property Introduced in Inventor 2009

SurfaceTextureSymbol.MaximumRoughness Property Introduced in Inventor 2009

SurfaceTextureSymbol.MinimumRoughness Property Introduced in Inventor 2009

SurfaceTextureSymbol.Parent Property Introduced in Inventor 2009

SurfaceTextureSymbol.Position Property Introduced in Inventor 2009

SurfaceTextureSymbol.ProductionMethod Property Introduced in Inventor 2009

SurfaceTextureSymbol.SamplingLength Property Introduced in Inventor 2009

SurfaceTextureSymbol.Style Property Introduced in Inventor 2009

SurfaceTextureSymbol.SurfaceTextureType Property Introduced in Inventor 2009

SurfaceTextureSymbol.SurfaceWaviness Property Introduced in Inventor 2009

SurfaceTextureSymbol.Type Property Introduced in Inventor 2009

SurfaceTextureSymbols Interface Introduced in Inventor 2009

SurfaceTextureSymbols Methods

SurfaceTextureSymbols.Add Method Introduced in Inventor 2009

SurfaceTextureSymbols.Item Method Introduced in Inventor 2009

SurfaceTextureSymbols Properties

SurfaceTextureSymbols.Application Property Introduced in Inventor 2009

SurfaceTextureSymbols.Count Property Introduced in Inventor 2009

SurfaceTextureSymbols.Type Property Introduced in Inventor 2009

SweepDefinition Interface Introduced in Inventor 11

SweepDefinition Properties

SweepDefinition.Application Property Introduced in Inventor 11

SweepDefinition.Parent Property Introduced in Inventor 11

SweepDefinition.Type Property Introduced in Inventor 11

SweepFeature Interface Introduced in Inventor 5

SweepFeature Methods

SweepFeature.AddParticipant Method Introduced in Inventor 2010

SweepFeature.SetUsingPath Method Introduced in Inventor 2008

SweepFeature.SetUsingPathAndGuideRail Method Introduced in Inventor 2008

SweepFeature.SetUsingPathAndGuideSurface Method Introduced in Inventor 2008

SweepFeature.SetUsingPathAndSectionTwists Method Introduced in Inventor 2008

SweepFeature.TaperAngle Method

SweepFeature Properties

SweepFeature.Definition Property Introduced in Inventor 11

SweepFeature.DefinitionType Property Introduced in Inventor 11

SweepFeature.EndFaces Property Introduced in Inventor 6

SweepFeature.Operation Property Introduced in Inventor 6

SweepFeature.Path Property Introduced in Inventor 6

SweepFeature.Profile Property Introduced in Inventor 6

SweepFeature.SideFaces Property Introduced in Inventor 6

SweepFeature.StartFaces Property Introduced in Inventor 6

SweepFeatureProxy Interface Introduced in Inventor 9

SweepFeatureProxy Properties

SweepFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

SweepFeatureProxy.NativeObject Property Introduced in Inventor 9

SweepFeatures Interface Introduced in Inventor 5

SweepFeatures Methods

SweepFeatures.Add Method

SweepFeatures.AddUsingPath Method Introduced in Inventor 11

SweepFeatures.AddUsingPathAndGuideRail Method Introduced in Inventor 11

SweepFeatures.AddUsingPathAndGuideSurface Method Introduced in Inventor 11

SweepFeatures.AddUsingPathAndSectionTwists Method Introduced in Inventor 2008

SweepFeatures.CreatePath Method

SweepFeatures.GetProfileOrientationAtParam Method Introduced in Inventor 2008

SweepFeatures.GetTruePath Method Introduced in Inventor 2008

SweepFeatures.Item Method Introduced in Inventor 5

SweepFeatures Properties

SweepFeatures.Application Property Introduced in Inventor 5

SweepFeatures.Count Property Introduced in Inventor 5

SweepFeatures.Type Property Introduced in Inventor 5

SymmetryConstraint Interface Introduced in Inventor 5

SymmetryConstraint Properties

SymmetryConstraint.EntityOne Property Introduced in Inventor 5

SymmetryConstraint.EntityTwo Property Introduced in Inventor 5

SymmetryConstraint.SymmetryLine Property Introduced in Inventor 5

SymmetryConstraintProxy Interface Introduced in Inventor 6

SymmetryConstraintProxy Properties

SymmetryConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

SymmetryConstraintProxy.NativeObject Property Introduced in Inventor 6

TableFormat Interface Introduced in Inventor 9

TableFormat Properties

TableFormat.Application Property Introduced in Inventor 9

TableFormat.InsideLineColor Property Introduced in Inventor 9

TableFormat.InsideLineWeight Property Introduced in Inventor 9

TableFormat.OutsideLineColor Property Introduced in Inventor 9

TableFormat.OutsideLineWeight Property Introduced in Inventor 9

TableFormat.TextStyle Property Introduced in Inventor 9

TableFormat.Type Property Introduced in Inventor 9

TableParameter Interface Introduced in Inventor 4

TableParameter Methods

TableParameter.ConvertToUserParameter Method Introduced in Inventor 11

TableParameters Interface Introduced in Inventor 4

TableParameters Methods

TableParameters.Item Method Introduced in Inventor 4

TableParameters Properties

TableParameters.Count Property Introduced in Inventor 4

TableParameters.Type Property Introduced in Inventor 4

TableStyle Interface Introduced in Inventor 2011

TableStyle Methods

TableStyle.AddColumn Method Introduced in Inventor 2011

TableStyle.RemoveAllColumns Method

TableStyle Properties

TableStyle.ColumnHeaderTextStyle Property Introduced in Inventor 2011

TableStyle.ColumnTitleHorizontalJustification Property Introduced in Inventor 2011

TableStyle.ColumnValueHorizontalJustification Property Introduced in Inventor 2011

TableStyle.ColumnWidth Property Introduced in Inventor 2011

TableStyle.DataTextStyle Property Introduced in Inventor 2011

TableStyle.HeadingGap Property Introduced in Inventor 2011

TableStyle.HeadingPlacement Property Introduced in Inventor 2011

TableStyle.InsideLineColor Property Introduced in Inventor 2011

TableStyle.InsideLineWeight Property Introduced in Inventor 2011

TableStyle.OutsideLineColor Property Introduced in Inventor 2011

TableStyle.OutsideLineWeight Property Introduced in Inventor 2011

TableStyle.RowGap Property Introduced in Inventor 2011

TableStyle.RowLineSpacing Property Introduced in Inventor 2011

TableStyle.ShowTitle Property Introduced in Inventor 2011

TableStyle.TableDirection Property Introduced in Inventor 2011

TableStyle.Title Property Introduced in Inventor 2011

TableStyle.TitleTextStyle Property Introduced in Inventor 2011

TableStylesEnumerator Interface Introduced in Inventor 2011

TableStylesEnumerator Methods

TableStylesEnumerator.Item Method Introduced in Inventor 2011

TableStylesEnumerator Properties

TableStylesEnumerator._NewEnum Property

TableStylesEnumerator.Application Property Introduced in Inventor 2011

TableStylesEnumerator.Count Property Introduced in Inventor 2011

TableStylesEnumerator.Type Property Introduced in Inventor 2011

TangentConstraint Interface Introduced in Inventor 4

TangentConstraint Properties

TangentConstraint.ConstraintLimits Property Introduced in Inventor 2011

TangentConstraint.InsideTangency Property Introduced in Inventor 4

TangentConstraint.Offset Property Introduced in Inventor 4

TangentConstraint3D Interface Introduced in Inventor 8

TangentConstraint3D Methods

TangentConstraint3D.FlipDirection Method Introduced in Inventor 8

TangentConstraint3D Properties

TangentConstraint3D.EntityOne Property Introduced in Inventor 8

TangentConstraint3D.EntityTwo Property Introduced in Inventor 8

TangentConstraint3DProxy Interface Introduced in Inventor 8

TangentConstraint3DProxy Properties

TangentConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 8

TangentConstraint3DProxy.NativeObject Property Introduced in Inventor 8

TangentConstraintProxy Interface Introduced in Inventor 11

TangentConstraintProxy Properties

TangentConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

TangentConstraintProxy.NativeObject Property Introduced in Inventor 11

TangentDistanceDimConstraint Interface Introduced in Inventor 5

TangentDistanceDimConstraint Properties

TangentDistanceDimConstraint.EntityOne Property Introduced in Inventor 5

TangentDistanceDimConstraint.EntityTwo Property Introduced in Inventor 5

TangentDistanceDimConstraint.LinearDiameter Property Introduced in Inventor 5

TangentDistanceDimConstraint.ProximityPointOne Property Introduced in Inventor 8

TangentDistanceDimConstraint.ProximityPointTwo Property Introduced in Inventor 8

TangentDistanceDimConstraintProxy Interface Introduced in Inventor 6

TangentDistanceDimConstraintProxy Properties

TangentDistanceDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

TangentDistanceDimConstraintProxy.NativeObject Property Introduced in Inventor 6

TangentiMateDefinition Interface Introduced in Inventor 6

TangentiMateDefinition Properties

TangentiMateDefinition.ConstraintLimits Property Introduced in Inventor 2011

TangentiMateDefinition.Entity Property Introduced in Inventor 6

TangentiMateDefinition.InsideTangency Property Introduced in Inventor 6

TangentiMateDefinition.Offset Property Introduced in Inventor 6

TangentiMateDefinitionProxy Interface Introduced in Inventor 6

TangentiMateDefinitionProxy Properties

TangentiMateDefinitionProxy.ContainingOccurrence Property Introduced in Inventor 6

TangentiMateDefinitionProxy.IsConsumed Property Introduced in Inventor 11

TangentiMateDefinitionProxy.NativeObject Property Introduced in Inventor 6

TangentSketchConstraint Interface Introduced in Inventor 5

TangentSketchConstraint Properties

TangentSketchConstraint.EntityOne Property Introduced in Inventor 5

TangentSketchConstraint.EntityTwo Property Introduced in Inventor 5

TangentSketchConstraintProxy Interface Introduced in Inventor 6

TangentSketchConstraintProxy Properties

TangentSketchConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

TangentSketchConstraintProxy.NativeObject Property Introduced in Inventor 6

TaperedThreadInfo Interface Introduced in Inventor 5

TaperedThreadInfo Properties

TaperedThreadInfo.BasicMinorDiameter Property Introduced in Inventor 5

TaperedThreadInfo.EffectiveDiameter Property Introduced in Inventor 5

TaperedThreadInfo.EffectiveLength Property Introduced in Inventor 5

TaperedThreadInfo.EngagementDiameter Property Introduced in Inventor 5

TaperedThreadInfo.EngagementLength Property Introduced in Inventor 5

TaperedThreadInfo.ExternalPitchDiameter Property Introduced in Inventor 5

TaperedThreadInfo.NominalExternalDiameter Property Introduced in Inventor 5

TaperedThreadInfo.NominalExternalLength Property Introduced in Inventor 5

TaperedThreadInfo.OutsidePipeDiameter Property Introduced in Inventor 5

TaperedThreadInfo.OverallExternalLength Property Introduced in Inventor 5

TaperedThreadInfo.Pitch Property Introduced in Inventor 5

TaperedThreadInfo.ThreadHeight Property Introduced in Inventor 5

TaperedThreadInfo.ThreadsPerInch Property Introduced in Inventor 5

TaperedThreadInfo.VanishThread Property Introduced in Inventor 5

TaperedThreadInfo.WrenchMakeupDiameter Property Introduced in Inventor 5

TaperedThreadInfo.WrenchMakeupLength Property Introduced in Inventor 5

TeardropHemDefinition Interface Introduced in Inventor 2009

TeardropHemDefinition Properties

TeardropHemDefinition.Angle Property Introduced in Inventor 2009

TeardropHemDefinition.Parent Property Introduced in Inventor 2009

TeardropHemDefinition.Radius Property Introduced in Inventor 2009

TextBox Interface Introduced in Inventor 5.3

TextBox Methods

TextBox.Delete Method Introduced in Inventor 5.3

TextBox.GetColor Method

TextBox.GetReferenceKey Method Introduced in Inventor 9

TextBox.SetColor Method

TextBox Properties

TextBox.Application Property Introduced in Inventor 5.3

TextBox.AttributeSets Property Introduced in Inventor 9

TextBox.BoundaryGeometry Property Introduced in Inventor 10

TextBox.Color Property Introduced in Inventor 11

TextBox.ContainingSketchBlock Property Introduced in Inventor 2010

TextBox.Fitted Property Introduced in Inventor 5.3

TextBox.FittedTextHeight Property Introduced in Inventor 5.3

TextBox.FittedTextWidth Property Introduced in Inventor 5.3

TextBox.FormattedText Property Introduced in Inventor 5.3

TextBox.Height Property Introduced in Inventor 2010

TextBox.HorizontalJustification Property Introduced in Inventor 5.3

TextBox.Layer Property Introduced in Inventor 10

TextBox.LineSpacing Property Introduced in Inventor 5.3

TextBox.LineSpacingType Property Introduced in Inventor 5.3

TextBox.Origin Property Introduced in Inventor 5.3

TextBox.OriginSketchPoint Property Introduced in Inventor 10

TextBox.Parent Property Introduced in Inventor 9

TextBox.RangeBox Property Introduced in Inventor 2010

TextBox.Rotation Property Introduced in Inventor 5.3

TextBox.ShowBoundaries Property Introduced in Inventor 10

TextBox.SingleLineText Property Introduced in Inventor 2008

TextBox.SketchBlockPath Property Introduced in Inventor 2010

TextBox.StackedTextPosition Property Introduced in Inventor 2009

TextBox.Style Property Introduced in Inventor 5.3

TextBox.Text Property Introduced in Inventor 5.3

TextBox.Type Property Introduced in Inventor 5.3

TextBox.VerticalJustification Property Introduced in Inventor 5.3

TextBox.Width Property Introduced in Inventor 2010

TextBox.WidthScale Property Introduced in Inventor 5.3

TextBoxConstraint Interface Introduced in Inventor 11

TextBoxConstraint Properties

TextBoxConstraint.TextBox Property Introduced in Inventor 11

TextBoxConstraintProxy Interface Introduced in Inventor 11

TextBoxConstraintProxy Properties

TextBoxConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

TextBoxConstraintProxy.NativeObject Property Introduced in Inventor 11

TextBoxes Interface Introduced in Inventor 5.3

TextBoxes Methods

TextBoxes.AddByRectangle Method Introduced in Inventor 5.3

TextBoxes.AddFitted Method Introduced in Inventor 5.3

TextBoxes.Item Method Introduced in Inventor 5.3

TextBoxes Properties

TextBoxes.Application Property Introduced in Inventor 5.3

TextBoxes.Count Property Introduced in Inventor 5.3

TextBoxes.Type Property Introduced in Inventor 5.3

TextBoxProxy Interface Introduced in Inventor 10

TextBoxProxy Properties

TextBoxProxy.ContainingOccurrence Property Introduced in Inventor 10

TextBoxProxy.NativeObject Property Introduced in Inventor 10

TextGraphics Interface Introduced in Inventor 5

TextGraphics Methods

TextGraphics.GetTextColor Method Introduced in Inventor 5

TextGraphics.GetTransformBehavior Method Introduced in Inventor 6

TextGraphics.PutTextColor Method Introduced in Inventor 5

TextGraphics.Scalable Method Introduced in Inventor 2008

TextGraphics.SetTransformBehavior Method Introduced in Inventor 6

TextGraphics Properties

TextGraphics.Anchor Property Introduced in Inventor 5

TextGraphics.Bold Property Introduced in Inventor 6

TextGraphics.BurnThrough Property Introduced in Inventor 2012

TextGraphics.DepthPriority Property Introduced in Inventor 5

TextGraphics.Font Property Introduced in Inventor 6

TextGraphics.FontSize Property Introduced in Inventor 6

TextGraphics.HorizontalAlignment Property Introduced in Inventor 5

TextGraphics.Italic Property Introduced in Inventor 6

TextGraphics.Text Property Introduced in Inventor 5

TextGraphics.VerticalAlignment Property Introduced in Inventor 5

TextStyle Interface Introduced in Inventor 5.3

TextStyle Methods

TextStyle.GetColor Method

TextStyle Properties

TextStyle.Bold Property Introduced in Inventor 5.3

TextStyle.Color Property Introduced in Inventor 11

TextStyle.Font Property Introduced in Inventor 5.3

TextStyle.FontSize Property Introduced in Inventor 5.3

TextStyle.HorizontalJustification Property Introduced in Inventor 5.3

TextStyle.Italic Property Introduced in Inventor 5.3

TextStyle.LineSpacing Property Introduced in Inventor 5.3

TextStyle.LineSpacingType Property Introduced in Inventor 5.3

TextStyle.Rotation Property Introduced in Inventor 5.3

TextStyle.Underline Property Introduced in Inventor 5.3

TextStyle.VerticalJustification Property Introduced in Inventor 5.3

TextStyle.WidthScale Property Introduced in Inventor 5.3

TextStyles Interface

TextStyles Methods

TextStyles.Item Method

TextStyles Properties

TextStyles.Application Property

TextStyles.Count Property

TextStyles.Type Property

TextStylesEnumerator Interface Introduced in Inventor 9

TextStylesEnumerator Methods

TextStylesEnumerator.Item Method Introduced in Inventor 9

TextStylesEnumerator Properties

TextStylesEnumerator.Application Property Introduced in Inventor 9

TextStylesEnumerator.Count Property Introduced in Inventor 9

TextStylesEnumerator.Type Property Introduced in Inventor 9

TextureCoordinateSet Interface Introduced in Inventor 10

TextureCoordinateSet Methods

TextureCoordinateSet.GetCoordinates Method Introduced in Inventor 10

TextureCoordinateSet.Item Method Introduced in Inventor 10

TextureCoordinateSet Properties

TextureCoordinateSet.Application Property Introduced in Inventor 10

TextureCoordinateSet.Count Property Introduced in Inventor 10

TextureCoordinateSet.Parent Property Introduced in Inventor 10

TextureCoordinateSet.Type Property Introduced in Inventor 10

TextureMap Interface Introduced in Inventor 10

TextureMap Methods

TextureMap.GetTextureCoordinateSet Method Introduced in Inventor 11

TextureMap Properties

TextureMap.Application Property Introduced in Inventor 10

TextureMap.Image Property Introduced in Inventor 10

TextureMap.MaskColor Property Introduced in Inventor 10

TextureMap.Parent Property Introduced in Inventor 10

TextureMap.Transformation Property Introduced in Inventor 10

TextureMap.Type Property Introduced in Inventor 10

TextureMap.UseMask Property Introduced in Inventor 10

TextureMaps Interface Introduced in Inventor 10

TextureMaps Methods

TextureMaps.Item Method Introduced in Inventor 10

TextureMaps Properties

TextureMaps.Application Property Introduced in Inventor 10

TextureMaps.Count Property Introduced in Inventor 10

TextureMaps.Type Property Introduced in Inventor 10

ThickenFeature Interface Introduced in Inventor 6

ThickenFeature Properties

ThickenFeature.ApproximationOptimized Property Introduced in Inventor 11

ThickenFeature.ApproximationTolerance Property Introduced in Inventor 11

ThickenFeature.ApproximationType Property Introduced in Inventor 11

ThickenFeature.AutomaticBlending Property

ThickenFeature.AutomaticFaceChain Property Introduced in Inventor 9

ThickenFeature.CreateVerticalSurfaces Property Introduced in Inventor 9

ThickenFeature.Direction Property Introduced in Inventor 9

ThickenFeature.Distance Property Introduced in Inventor 9

ThickenFeature.InputFaces Property Introduced in Inventor 9

ThickenFeature.Operation Property Introduced in Inventor 9

ThickenFeatureProxy Interface Introduced in Inventor 9

ThickenFeatureProxy Properties

ThickenFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ThickenFeatureProxy.NativeObject Property Introduced in Inventor 9

ThickenFeatures Interface Introduced in Inventor 6

ThickenFeatures Methods

ThickenFeatures.Add Method Introduced in Inventor 9

ThickenFeatures.Item Method Introduced in Inventor 6

ThickenFeatures Properties

ThickenFeatures.Application Property Introduced in Inventor 6

ThickenFeatures.Count Property Introduced in Inventor 6

ThickenFeatures.Type Property Introduced in Inventor 6

ThreadFeature Interface Introduced in Inventor 5

ThreadFeature Methods

ThreadFeature.SetThreadDepth Method Introduced in Inventor 6

ThreadFeature Properties

ThreadFeature.DirectionReversed Property Introduced in Inventor 5

ThreadFeature.DisplayInModel Property Introduced in Inventor 5

ThreadFeature.FullDepth Property Introduced in Inventor 5

ThreadFeature.StartEdge Property Introduced in Inventor 5

ThreadFeature.ThreadDepth Property Introduced in Inventor 5

ThreadFeature.ThreadedFace Property Introduced in Inventor 5

ThreadFeature.ThreadInfo Property Introduced in Inventor 5

ThreadFeature.ThreadInfoType Property Introduced in Inventor 5.3

ThreadFeature.ThreadOffset Property Introduced in Inventor 5

ThreadFeatureProxy Interface Introduced in Inventor 9

ThreadFeatureProxy Properties

ThreadFeatureProxy.ContainingOccurrence Property Introduced in Inventor 9

ThreadFeatureProxy.NativeObject Property Introduced in Inventor 9

ThreadFeatures Interface Introduced in Inventor 5

ThreadFeatures Methods

ThreadFeatures.Add Method Introduced in Inventor 5

ThreadFeatures.CreateStandardThreadInfo Method Introduced in Inventor 5

ThreadFeatures.CreateTaperedThreadInfo Method Introduced in Inventor 5

ThreadFeatures.Item Method Introduced in Inventor 5

ThreadFeatures Properties

ThreadFeatures.Application Property Introduced in Inventor 5

ThreadFeatures.Count Property Introduced in Inventor 5

ThreadFeatures.Type Property Introduced in Inventor 5

ThreadInfo Interface Introduced in Inventor 5

ThreadInfo Methods

ThreadInfo._NominalSizeDescription Method

ThreadInfo Properties

ThreadInfo.Application Property Introduced in Inventor 5

ThreadInfo.CustomThreadDesignation Property Introduced in Inventor 9

ThreadInfo.FullThreadDepth Property Introduced in Inventor 2010

ThreadInfo.Internal Property Introduced in Inventor 5

ThreadInfo.Metric Property Introduced in Inventor 5

ThreadInfo.RightHanded Property Introduced in Inventor 5

ThreadInfo.ThreadBasePoints Property Introduced in Inventor 11

ThreadInfo.ThreadDesignation Property Introduced in Inventor 9

ThreadInfo.ThreadDirection Property Introduced in Inventor 11

ThreadInfo.ThreadType Property Introduced in Inventor 5

ThreadInfo.ThreadTypeIdentifier Property Introduced in Inventor 2008

ThreadInfo.Type Property Introduced in Inventor 5

ThreadTableQuery Interface Introduced in Inventor 11

ThreadTableQuery Methods

ThreadTableQuery.CreateThreadInfo Method Introduced in Inventor 2008

ThreadTableQuery.GetAvailableClasses Method Introduced in Inventor 11

ThreadTableQuery.GetAvailableDesignations Method Introduced in Inventor 11

ThreadTableQuery.GetAvailableThreadSizes Method Introduced in Inventor 11

ThreadTableQuery.GetAvailableThreadTypes Method Introduced in Inventor 11

ThreadTableQuery.GetThreadTypeIdentifier Method Introduced in Inventor 11

ThreadTableQuery.GetThreadTypeName Method Introduced in Inventor 2008

ThreadTableQuery Properties

ThreadTableQuery.Application Property Introduced in Inventor 11

ThreadTableQuery.Type Property Introduced in Inventor 11

ThreePlanesWorkPointDef Interface Introduced in Inventor 4

ThreePlanesWorkPointDef Methods

ThreePlanesWorkPointDef.GetData Method Introduced in Inventor 4

ThreePlanesWorkPointDef Properties

ThreePlanesWorkPointDef.Application Property Introduced in Inventor 4

ThreePlanesWorkPointDef.Parent Property Introduced in Inventor 4

ThreePlanesWorkPointDef.Plane1 Property Introduced in Inventor 4

ThreePlanesWorkPointDef.Plane2 Property Introduced in Inventor 4

ThreePlanesWorkPointDef.Plane3 Property Introduced in Inventor 4

ThreePlanesWorkPointDef.Type Property Introduced in Inventor 4

ThreePointAngleDimConstraint Interface Introduced in Inventor 5

ThreePointAngleDimConstraint Properties

ThreePointAngleDimConstraint.PointOne Property Introduced in Inventor 5

ThreePointAngleDimConstraint.PointThree Property Introduced in Inventor 5

ThreePointAngleDimConstraint.PointTwo Property Introduced in Inventor 5

ThreePointAngleDimConstraintProxy Interface Introduced in Inventor 6

ThreePointAngleDimConstraintProxy Properties

ThreePointAngleDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

ThreePointAngleDimConstraintProxy.NativeObject Property Introduced in Inventor 6

ThreePointsWorkPlaneDef Interface Introduced in Inventor 4

ThreePointsWorkPlaneDef Methods

ThreePointsWorkPlaneDef.GetData Method Introduced in Inventor 4

ThreePointsWorkPlaneDef Properties

ThreePointsWorkPlaneDef.Application Property Introduced in Inventor 4

ThreePointsWorkPlaneDef.Parent Property Introduced in Inventor 4

ThreePointsWorkPlaneDef.Point1 Property Introduced in Inventor 4

ThreePointsWorkPlaneDef.Point2 Property Introduced in Inventor 4

ThreePointsWorkPlaneDef.Point3 Property Introduced in Inventor 4

ThreePointsWorkPlaneDef.Type Property Introduced in Inventor 4

ThroughAllExtent Interface Introduced in Inventor 5

ThroughAllExtent Properties

ThroughAllExtent.Direction Property Introduced in Inventor 5

TitleBlock Interface Introduced in Inventor 5.3

TitleBlock Methods

TitleBlock.Delete Method Introduced in Inventor 5.3

TitleBlock.GetResultText Method Introduced in Inventor 5.3

TitleBlock.SetPromptResultText Method Introduced in Inventor 5.3

TitleBlock Properties

TitleBlock.Application Property Introduced in Inventor 5.3

TitleBlock.Definition Property Introduced in Inventor 5.3

TitleBlock.Location Property Introduced in Inventor 5.3

TitleBlock.Name Property Introduced in Inventor 2009

TitleBlock.Parent Property Introduced in Inventor 5.3

TitleBlock.Position Property Introduced in Inventor 5.3

TitleBlock.RangeBox Property Introduced in Inventor 2010

TitleBlock.Transformation Property Introduced in Inventor 5.3

TitleBlock.Type Property Introduced in Inventor 5.3

TitleBlockDefinition Interface Introduced in Inventor 5.3

TitleBlockDefinition Methods

TitleBlockDefinition.CopyTo Method Introduced in Inventor 10

TitleBlockDefinition.Delete Method Introduced in Inventor 5.3

TitleBlockDefinition.Edit Method Introduced in Inventor 5.3

TitleBlockDefinition.ExitEdit Method Introduced in Inventor 5.3

TitleBlockDefinition.GetReferenceKey Method Introduced in Inventor 2008

TitleBlockDefinition Properties

TitleBlockDefinition.Application Property Introduced in Inventor 5.3

TitleBlockDefinition.AttributeSets Property Introduced in Inventor 2008

TitleBlockDefinition.IsReferenced Property Introduced in Inventor 5.3

TitleBlockDefinition.Name Property Introduced in Inventor 5.3

TitleBlockDefinition.Parent Property Introduced in Inventor 5.3

TitleBlockDefinition.Sketch Property Introduced in Inventor 5.3

TitleBlockDefinition.Type Property Introduced in Inventor 5.3

TitleBlockDefinitions Interface Introduced in Inventor 5.3

TitleBlockDefinitions Methods

TitleBlockDefinitions.Add Method Introduced in Inventor 5.3

TitleBlockDefinitions.Item Method Introduced in Inventor 5.3

TitleBlockDefinitions Properties

TitleBlockDefinitions.Application Property Introduced in Inventor 5.3

TitleBlockDefinitions.Count Property Introduced in Inventor 5.3

TitleBlockDefinitions.Type Property Introduced in Inventor 5.3

ToExtent Interface Introduced in Inventor 5

ToExtent Properties

ToExtent.Direction Property Introduced in Inventor 2008

ToExtent.ExtendToFace Property Introduced in Inventor 5

ToExtent.MinimumSolution Property Introduced in Inventor 11

ToExtent.ToEntity Property Introduced in Inventor 2009

ToHeightExtent Interface Introduced in Inventor 2009

ToHeightExtent Properties

ToHeightExtent.Offset Property Introduced in Inventor 2009

ToHeightExtent.ToEntity Property Introduced in Inventor 2009

Tolerance Interface Introduced in Inventor 6

Tolerance Methods

Tolerance.SetToBasic Method Introduced in Inventor 11

Tolerance.SetToDefault Method Introduced in Inventor 6

Tolerance.SetToDeviation Method Introduced in Inventor 6

Tolerance.SetToFits Method Introduced in Inventor 6

Tolerance.SetToLimits Method Introduced in Inventor 6

Tolerance.SetToMax Method Introduced in Inventor 10

Tolerance.SetToMin Method Introduced in Inventor 10

Tolerance.SetToReference Method Introduced in Inventor 11

Tolerance.SetToSymmetric Method Introduced in Inventor 6

Tolerance Properties

Tolerance.HoleTolerance Property Introduced in Inventor 6

Tolerance.Lower Property Introduced in Inventor 6

Tolerance.Parent Property Introduced in Inventor 6

Tolerance.ShaftTolerance Property Introduced in Inventor 6

Tolerance.ToleranceType Property Introduced in Inventor 6

Tolerance.Type Property Introduced in Inventor 6

Tolerance.Upper Property Introduced in Inventor 6

ToNextExtent Interface Introduced in Inventor 5

ToNextExtent Properties

ToNextExtent.Direction Property Introduced in Inventor 5

ToNextExtent.Terminator Property Introduced in Inventor 2008

Torus Interface Introduced in Inventor 4

Torus Methods

Torus.GetTorusData Method Introduced in Inventor 4

Torus.PutTorusData Method Introduced in Inventor 4

Torus Properties

Torus.AxisVector Property Introduced in Inventor 4

Torus.CenterPoint Property Introduced in Inventor 4

Torus.Evaluator Property Introduced in Inventor 4

Torus.MajorRadius Property Introduced in Inventor 4

Torus.MinorRadius Property Introduced in Inventor 4

TorusCenterPointWorkPointDef Interface Introduced in Inventor 2008

TorusCenterPointWorkPointDef Properties

TorusCenterPointWorkPointDef.Application Property Introduced in Inventor 2008

TorusCenterPointWorkPointDef.Face Property Introduced in Inventor 2008

TorusCenterPointWorkPointDef.Parent Property Introduced in Inventor 2008

TorusCenterPointWorkPointDef.Type Property Introduced in Inventor 2008

TorusMidPlaneWorkPlaneDef Interface Introduced in Inventor 2008

TorusMidPlaneWorkPlaneDef Properties

TorusMidPlaneWorkPlaneDef.Application Property Introduced in Inventor 2008

TorusMidPlaneWorkPlaneDef.Face Property Introduced in Inventor 2008

TorusMidPlaneWorkPlaneDef.Parent Property Introduced in Inventor 2008

TorusMidPlaneWorkPlaneDef.Type Property Introduced in Inventor 2008

Trail Interface Introduced in Inventor 11

Trail Methods

Trail.Item Method Introduced in Inventor 11

Trail.SetVisibility Method Introduced in Inventor 11

Trail Properties

Trail.Application Property Introduced in Inventor 11

Trail.Count Property Introduced in Inventor 11

Trail.Parent Property Introduced in Inventor 11

Trail.Type Property Introduced in Inventor 11

TrailSegment Interface Introduced in Inventor 11

TrailSegment Properties

TrailSegment.Application Property Introduced in Inventor 11

TrailSegment.Geometry Property Introduced in Inventor 11

TrailSegment.Linear Property Introduced in Inventor 11

TrailSegment.Parent Property Introduced in Inventor 11

TrailSegment.Type Property Introduced in Inventor 11

TrailSegment.Visible Property Introduced in Inventor 11

TrailsEnumerator Interface Introduced in Inventor 11

TrailsEnumerator Methods

TrailsEnumerator.Item Method Introduced in Inventor 11

TrailsEnumerator Properties

TrailsEnumerator.Application Property Introduced in Inventor 11

TrailsEnumerator.Count Property Introduced in Inventor 11

TrailsEnumerator.Type Property Introduced in Inventor 11

Transaction Interface Introduced in Inventor 4

Transaction Methods

Transaction.Abort Method Introduced in Inventor 6

Transaction.End Method Introduced in Inventor 6

Transaction.IdentifyForDocumentOpen Method Introduced in Inventor 9

Transaction Properties

Transaction.Application Property Introduced in Inventor 5

Transaction.CheckPoints Property Introduced in Inventor 5

Transaction.ChildTransactions Property Introduced in Inventor 5

Transaction.DisplayName Property Introduced in Inventor 4

Transaction.Document Property Introduced in Inventor 4

Transaction.HasParentTransaction Property Introduced in Inventor 5

Transaction.Id Property Introduced in Inventor 4

Transaction.MergeWithPrevious Property Introduced in Inventor 11

Transaction.Parent Property Introduced in Inventor 5

Transaction.ParentTransaction Property Introduced in Inventor 5

Transaction.State Property Introduced in Inventor 7

Transaction.Type Property Introduced in Inventor 4

TransactionEvents CoClass Introduced in Inventor 4

TransactionEventsObject Interface Introduced in Inventor 4

TransactionEventsObject Properties

TransactionEventsObject.Application Property Introduced in Inventor 5

TransactionEventsObject.Parent Property Introduced in Inventor 5

TransactionEventsObject.Type Property Introduced in Inventor 5

TransactionEventsSink Interface Introduced in Inventor 4

TransactionEventsSink Methods

TransactionEventsSink.OnAbort Method Introduced in Inventor 4

TransactionEventsSink.OnCommit Method Introduced in Inventor 4

TransactionEventsSink.OnDelete Method Introduced in Inventor 4

TransactionEventsSink.OnRedo Method Introduced in Inventor 4

TransactionEventsSink.OnUndo Method Introduced in Inventor 4

TransactionManager Interface Introduced in Inventor 4

TransactionManager Methods

TransactionManager.ClearAllTransactions Method Introduced in Inventor 9

TransactionManager.GoToCheckPoint Method Introduced in Inventor 5

TransactionManager.RedoTransaction Method Introduced in Inventor 4

TransactionManager.SetCheckPoint Method Introduced in Inventor 5

TransactionManager.StartTransaction Method Introduced in Inventor 4

TransactionManager.StartTransactionForDocumentOpen Method Introduced in Inventor 9

TransactionManager.UndoTransaction Method Introduced in Inventor 4

TransactionManager Properties

TransactionManager.Application Property Introduced in Inventor 5

TransactionManager.CommittedTransactions Property Introduced in Inventor 4

TransactionManager.CurrentTransaction Property Introduced in Inventor 5

TransactionManager.Parent Property Introduced in Inventor 4

TransactionManager.TransactionEvents Property Introduced in Inventor 4

TransactionManager.Type Property Introduced in Inventor 4

TransactionManager.UndoneTransactions Property Introduced in Inventor 4

TransactionsEnumerator Interface Introduced in Inventor 5

TransactionsEnumerator Methods

TransactionsEnumerator.Item Method Introduced in Inventor 5

TransactionsEnumerator Properties

TransactionsEnumerator.Count Property Introduced in Inventor 5

TransactionsEnumerator.Type Property Introduced in Inventor 5

TransientBRep Interface Introduced in Inventor 2009

TransientBRep Methods

TransientBRep.Copy Method Introduced in Inventor 2009

TransientBRep.CreateIntersectionWithPlane Method Introduced in Inventor 2009

TransientBRep.CreateSilhouetteCurve Method Introduced in Inventor 2009

TransientBRep.CreateSolidBlock Method Introduced in Inventor 2009

TransientBRep.CreateSolidCylinderCone Method Introduced in Inventor 2009

TransientBRep.CreateSolidSphere Method Introduced in Inventor 2009

TransientBRep.CreateSolidTorus Method Introduced in Inventor 2009

TransientBRep.CreateSurfaceBodyDefinition Method Introduced in Inventor 2011

TransientBRep.DeleteFaces Method Introduced in Inventor 2009

TransientBRep.DoBoolean Method Introduced in Inventor 2009

TransientBRep.ReadFromFile Method Introduced in Inventor 2011

TransientBRep.Transform Method Introduced in Inventor 2009

TransientGeometry Interface Introduced in Inventor 4

TransientGeometry Methods

TransientGeometry.CreateArc2d Method Introduced in Inventor 11

TransientGeometry.CreateArc2dByThreePoints Method Introduced in Inventor 2008

TransientGeometry.CreateArc3d Method Introduced in Inventor 11

TransientGeometry.CreateArc3dByThreePoints Method Introduced in Inventor 2008

TransientGeometry.CreateBox Method Introduced in Inventor 4

TransientGeometry.CreateBox2d Method Introduced in Inventor 4

TransientGeometry.CreateBSplineCurve Method Introduced in Inventor 4

TransientGeometry.CreateBSplineCurve2d Method Introduced in Inventor 4

TransientGeometry.CreateBSplineCurve2dDefinition Method Introduced in Inventor 9

TransientGeometry.CreateBSplineCurveDefinition Method Introduced in Inventor 9

TransientGeometry.CreateBSplineSurface Method Introduced in Inventor 4

TransientGeometry.CreateCircle Method Introduced in Inventor 4

TransientGeometry.CreateCircle2d Method Introduced in Inventor 4

TransientGeometry.CreateCircle2dByThreePoints Method Introduced in Inventor 2008

TransientGeometry.CreateCircleByThreePoints Method Introduced in Inventor 2008

TransientGeometry.CreateCone Method Introduced in Inventor 4

TransientGeometry.CreateCylinder Method Introduced in Inventor 4

TransientGeometry.CreateEllipseFull Method Introduced in Inventor 11

TransientGeometry.CreateEllipseFull2d Method Introduced in Inventor 11

TransientGeometry.CreateEllipticalArc Method Introduced in Inventor 11

TransientGeometry.CreateEllipticalArc2d Method Introduced in Inventor 11

TransientGeometry.CreateEllipticalCone Method Introduced in Inventor 4

TransientGeometry.CreateEllipticalCylinder Method Introduced in Inventor 4

TransientGeometry.CreateFittedBSplineCurve Method Introduced in Inventor 9

TransientGeometry.CreateFittedBSplineCurve2d Method Introduced in Inventor 9

TransientGeometry.CreateLine Method Introduced in Inventor 4

TransientGeometry.CreateLine2d Method Introduced in Inventor 4

TransientGeometry.CreateLineSegment Method Introduced in Inventor 11

TransientGeometry.CreateLineSegment2d Method Introduced in Inventor 11

TransientGeometry.CreateMatrix Method Introduced in Inventor 4

TransientGeometry.CreateMatrix2d Method Introduced in Inventor 4

TransientGeometry.CreatePlane Method Introduced in Inventor 4

TransientGeometry.CreatePlaneByThreePoints Method Introduced in Inventor 2008

TransientGeometry.CreatePoint Method Introduced in Inventor 4

TransientGeometry.CreatePoint2d Method Introduced in Inventor 4

TransientGeometry.CreatePolyline2d Method Introduced in Inventor 2009

TransientGeometry.CreatePolyline2dFromCurve Method Introduced in Inventor 2009

TransientGeometry.CreatePolyline3d Method Introduced in Inventor 2009

TransientGeometry.CreatePolyline3dFromCurve Method Introduced in Inventor 2009

TransientGeometry.CreateSphere Method Introduced in Inventor 4

TransientGeometry.CreateTorus Method Introduced in Inventor 4

TransientGeometry.CreateUnitVector Method Introduced in Inventor 4

TransientGeometry.CreateUnitVector2d Method Introduced in Inventor 4

TransientGeometry.CreateVector Method Introduced in Inventor 4

TransientGeometry.CreateVector2d Method Introduced in Inventor 4

TransientGeometry.CurveCurveIntersection Method

TransientGeometry.CurveSurfaceIntersection Method

TransientGeometry.SurfaceSurfaceIntersection Method

TransientGeometry Properties

TransientGeometry.PointTolerance Property Introduced in Inventor 2008

TransientGeometry.Type Property Introduced in Inventor 4

TransientObjects Interface Introduced in Inventor 4

TransientObjects Methods

TransientObjects.CreateCamera Method Introduced in Inventor 2012

TransientObjects.CreateColor Method Introduced in Inventor 8

TransientObjects.CreateDataMedium Method Introduced in Inventor 4

TransientObjects.CreateEdgeCollection Method Introduced in Inventor 5.3

TransientObjects.CreateFaceCollection Method Introduced in Inventor 9

TransientObjects.CreateFileMetadata Method Introduced in Inventor 2009

TransientObjects.CreateNameValueMap Method Introduced in Inventor 4

TransientObjects.CreateObjectCollection Method Introduced in Inventor 5

TransientObjects.CreateObjectCollectionByVariant Method Introduced in Inventor 5

TransientObjects.CreateSignatureString Method Introduced in Inventor 11

TransientObjects.CreateTranslationContext Method Introduced in Inventor 4

TransitionalConstraint Interface Introduced in Inventor 5

TransitionalConstraintProxy Interface Introduced in Inventor 11

TransitionalConstraintProxy Properties

TransitionalConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

TransitionalConstraintProxy.NativeObject Property Introduced in Inventor 11

TranslateTranslateConstraint Interface Introduced in Inventor 5

TranslateTranslateConstraint Properties

TranslateTranslateConstraint.ForwardDirection Property Introduced in Inventor 5

TranslateTranslateConstraint.Ratio Property Introduced in Inventor 5

TranslateTranslateConstraintProxy Interface Introduced in Inventor 11

TranslateTranslateConstraintProxy Properties

TranslateTranslateConstraintProxy.ContainingOccurrence Property Introduced in Inventor 11

TranslateTranslateConstraintProxy.NativeObject Property Introduced in Inventor 11

TranslationContext Interface Introduced in Inventor 4

TranslationContext Properties

TranslationContext.OpenIntoExisting Property Introduced in Inventor 4

TranslationContext.Type Property Introduced in Inventor 4

TranslatorAddIn Interface Introduced in Inventor 4

TranslatorAddIn Methods

TranslatorAddIn.DocumentTypesSupported Method Introduced in Inventor 4

TranslatorAddIn.GetThumbnail Method Introduced in Inventor 5

TranslatorAddIn.HasOpenOptions Method Introduced in Inventor 4

TranslatorAddIn.HasSaveCopyAsOptions Method Introduced in Inventor 4

TranslatorAddIn.Open Method Introduced in Inventor 4

TranslatorAddIn.SaveCopyAs Method Introduced in Inventor 4

TranslatorAddIn.ShowOpenOptions Method Introduced in Inventor 4

TranslatorAddIn.ShowSaveCopyAsOptions Method Introduced in Inventor 4

TranslatorAddIn Properties

TranslatorAddIn.FileExtensions Property Introduced in Inventor 4

TranslatorAddIn.FilterText Property Introduced in Inventor 4

TranslatorAddIn.SupportsImportInto Property

TranslatorAddIn.SupportsOpen Property Introduced in Inventor 4

TranslatorAddIn.SupportsOpenInto Property

TranslatorAddIn.SupportsSaveCopyAs Property Introduced in Inventor 4

TranslatorAddIn.SupportsSaveCopyAsFrom Property

TranslatorAddIn.TranslatorAvailable Property Introduced in Inventor 5

TranslatorAddInServer Interface Introduced in Inventor 4

TranslatorAddInServer Methods

TranslatorAddInServer.GetThumbnail Method Introduced in Inventor 5

TranslatorAddInServer.HasOpenOptions Method Introduced in Inventor 4

TranslatorAddInServer.HasSaveCopyAsOptions Method Introduced in Inventor 4

TranslatorAddInServer.Open Method Introduced in Inventor 4

TranslatorAddInServer.SaveCopyAs Method Introduced in Inventor 4

TranslatorAddInServer.ShowOpenOptions Method Introduced in Inventor 4

TranslatorAddInServer.ShowSaveCopyAsOptions Method Introduced in Inventor 4

TriadEvents CoClass Introduced in Inventor 9

TriadEventsObject Interface Introduced in Inventor 9

TriadEventsObject Methods

TriadEventsObject.Reposition Method Introduced in Inventor 9

TriadEventsObject Properties

TriadEventsObject.Application Property Introduced in Inventor 9

TriadEventsObject.DegreesOfFreedom Property Introduced in Inventor 9

TriadEventsObject.Enabled Property Introduced in Inventor 9

TriadEventsObject.GlobalTransform Property Introduced in Inventor 9

TriadEventsObject.IsInRedefineMode Property Introduced in Inventor 2009

TriadEventsObject.MoveTriadOnly Property Introduced in Inventor 9

TriadEventsObject.MoveTriadOnlyEnabled Property Introduced in Inventor 9

TriadEventsObject.Parent Property Introduced in Inventor 9

TriadEventsObject.Repeat Property Introduced in Inventor 9

TriadEventsObject.Type Property Introduced in Inventor 9

TriadEventsSink Interface Introduced in Inventor 9

TriadEventsSink Methods

TriadEventsSink.OnActivate Method Introduced in Inventor 9

TriadEventsSink.OnEndMove Method Introduced in Inventor 9

TriadEventsSink.OnEndSequence Method Introduced in Inventor 9

TriadEventsSink.OnMove Method Introduced in Inventor 9

TriadEventsSink.OnMoveTriadOnlyToggle Method Introduced in Inventor 9

TriadEventsSink.OnSegmentSelectionChange Method Introduced in Inventor 9

TriadEventsSink.OnStartMove Method Introduced in Inventor 9

TriadEventsSink.OnStartSequence Method Introduced in Inventor 9

TriadEventsSink.OnTerminate Method Introduced in Inventor 9

TriangleFanGraphics Interface Introduced in Inventor 5

TriangleFanGraphics Methods

TriangleFanGraphics.GetStripLengths Method Introduced in Inventor 5

TriangleFanGraphics.GetTransformBehavior Method Introduced in Inventor 5

TriangleFanGraphics.PutStripLengths Method Introduced in Inventor 5

TriangleFanGraphics.SetTransformBehavior Method Introduced in Inventor 5

TriangleFanGraphics Properties

TriangleFanGraphics.BurnThrough Property Introduced in Inventor 5

TriangleFanGraphics.ColorBinding Property Introduced in Inventor 5

TriangleFanGraphics.ColorIndexSet Property Introduced in Inventor 5

TriangleFanGraphics.ColorMapper Property Introduced in Inventor 2010

TriangleFanGraphics.ColorSet Property Introduced in Inventor 5

TriangleFanGraphics.CoordinateIndexSet Property Introduced in Inventor 5

TriangleFanGraphics.CoordinateSet Property Introduced in Inventor 5

TriangleFanGraphics.DepthPriority Property Introduced in Inventor 5

TriangleFanGraphics.NormalBinding Property Introduced in Inventor 5

TriangleFanGraphics.NormalIndexSet Property Introduced in Inventor 5

TriangleFanGraphics.NormalSet Property Introduced in Inventor 5

TriangleFanGraphics.TextureCoordinateIndexSet Property Introduced in Inventor 2010

TriangleFanGraphics.TextureCoordinateSet Property Introduced in Inventor 2010

TriangleGraphics Interface Introduced in Inventor 5

TriangleGraphics Methods

TriangleGraphics.GetTransformBehavior Method Introduced in Inventor 5

TriangleGraphics.SetTransformBehavior Method Introduced in Inventor 5

TriangleGraphics Properties

TriangleGraphics.BurnThrough Property Introduced in Inventor 5

TriangleGraphics.ColorBinding Property Introduced in Inventor 5

TriangleGraphics.ColorIndexSet Property Introduced in Inventor 5

TriangleGraphics.ColorMapper Property Introduced in Inventor 2010

TriangleGraphics.ColorSet Property Introduced in Inventor 5

TriangleGraphics.CoordinateIndexSet Property Introduced in Inventor 5

TriangleGraphics.CoordinateSet Property Introduced in Inventor 5

TriangleGraphics.DepthPriority Property Introduced in Inventor 5

TriangleGraphics.NormalBinding Property Introduced in Inventor 5

TriangleGraphics.NormalIndexSet Property Introduced in Inventor 5

TriangleGraphics.NormalSet Property Introduced in Inventor 5

TriangleGraphics.TextureCoordinateIndexSet Property Introduced in Inventor 2010

TriangleGraphics.TextureCoordinateSet Property Introduced in Inventor 2010

TriangleStripGraphics Interface Introduced in Inventor 5

TriangleStripGraphics Methods

TriangleStripGraphics.GetStripLengths Method Introduced in Inventor 5

TriangleStripGraphics.GetTransformBehavior Method Introduced in Inventor 5

TriangleStripGraphics.PutStripLengths Method Introduced in Inventor 5

TriangleStripGraphics.SetTransformBehavior Method Introduced in Inventor 5

TriangleStripGraphics Properties

TriangleStripGraphics.BurnThrough Property Introduced in Inventor 5

TriangleStripGraphics.ColorBinding Property Introduced in Inventor 5

TriangleStripGraphics.ColorIndexSet Property Introduced in Inventor 5

TriangleStripGraphics.ColorMapper Property Introduced in Inventor 2010

TriangleStripGraphics.ColorSet Property Introduced in Inventor 5

TriangleStripGraphics.CoordinateIndexSet Property Introduced in Inventor 5

TriangleStripGraphics.CoordinateSet Property Introduced in Inventor 5

TriangleStripGraphics.DepthPriority Property Introduced in Inventor 5

TriangleStripGraphics.NormalBinding Property Introduced in Inventor 5

TriangleStripGraphics.NormalIndexSet Property Introduced in Inventor 5

TriangleStripGraphics.NormalSet Property Introduced in Inventor 5

TriangleStripGraphics.TextureCoordinateIndexSet Property Introduced in Inventor 2010

TriangleStripGraphics.TextureCoordinateSet Property Introduced in Inventor 2010

TrimFeature Interface Introduced in Inventor 11

TrimFeatureProxy Interface Introduced in Inventor 11

TrimFeatureProxy Properties

TrimFeatureProxy.ContainingOccurrence Property Introduced in Inventor 11

TrimFeatureProxy.NativeObject Property Introduced in Inventor 11

TrimFeatures Interface Introduced in Inventor 11

TrimFeatures Methods

TrimFeatures.Item Method Introduced in Inventor 11

TrimFeatures Properties

TrimFeatures.Application Property Introduced in Inventor 11

TrimFeatures.Count Property Introduced in Inventor 11

TrimFeatures.Type Property Introduced in Inventor 11

TwoDistancesChamferDef Interface Introduced in Inventor 5.3

TwoDistancesChamferDef Properties

TwoDistancesChamferDef.DistanceOne Property Introduced in Inventor 5.3

TwoDistancesChamferDef.DistanceTwo Property Introduced in Inventor 5.3

TwoDistancesChamferDef.Face Property Introduced in Inventor 6

TwoLineAngleDimConstraint Interface Introduced in Inventor 5

TwoLineAngleDimConstraint Properties

TwoLineAngleDimConstraint.LineOne Property Introduced in Inventor 5

TwoLineAngleDimConstraint.LineTwo Property Introduced in Inventor 5

TwoLineAngleDimConstraint3D Interface Introduced in Inventor 11

TwoLineAngleDimConstraint3D Properties

TwoLineAngleDimConstraint3D.LineOne Property Introduced in Inventor 11

TwoLineAngleDimConstraint3D.LineTwo Property Introduced in Inventor 11

TwoLineAngleDimConstraint3DProxy Interface Introduced in Inventor 11

TwoLineAngleDimConstraint3DProxy Properties

TwoLineAngleDimConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 11

TwoLineAngleDimConstraint3DProxy.NativeObject Property Introduced in Inventor 11

TwoLineAngleDimConstraintProxy Interface Introduced in Inventor 6

TwoLineAngleDimConstraintProxy Properties

TwoLineAngleDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

TwoLineAngleDimConstraintProxy.NativeObject Property Introduced in Inventor 6

TwoLinesWorkPlaneDef Interface Introduced in Inventor 4

TwoLinesWorkPlaneDef Methods

TwoLinesWorkPlaneDef.GetData Method Introduced in Inventor 4

TwoLinesWorkPlaneDef Properties

TwoLinesWorkPlaneDef.Application Property Introduced in Inventor 4

TwoLinesWorkPlaneDef.Line1 Property Introduced in Inventor 4

TwoLinesWorkPlaneDef.Line2 Property Introduced in Inventor 4

TwoLinesWorkPlaneDef.Parent Property Introduced in Inventor 4

TwoLinesWorkPlaneDef.Type Property Introduced in Inventor 4

TwoLinesWorkPointDef Interface Introduced in Inventor 4

TwoLinesWorkPointDef Methods

TwoLinesWorkPointDef.GetData Method Introduced in Inventor 4

TwoLinesWorkPointDef Properties

TwoLinesWorkPointDef.Application Property Introduced in Inventor 4

TwoLinesWorkPointDef.Line1 Property Introduced in Inventor 4

TwoLinesWorkPointDef.Line2 Property Introduced in Inventor 4

TwoLinesWorkPointDef.Parent Property Introduced in Inventor 4

TwoLinesWorkPointDef.Type Property Introduced in Inventor 4

TwoPlanesWorkAxisDef Interface Introduced in Inventor 4

TwoPlanesWorkAxisDef Methods

TwoPlanesWorkAxisDef.GetData Method Introduced in Inventor 4

TwoPlanesWorkAxisDef Properties

TwoPlanesWorkAxisDef.Application Property Introduced in Inventor 4

TwoPlanesWorkAxisDef.Parent Property Introduced in Inventor 4

TwoPlanesWorkAxisDef.Plane1 Property Introduced in Inventor 4

TwoPlanesWorkAxisDef.Plane2 Property Introduced in Inventor 4

TwoPlanesWorkAxisDef.Type Property Introduced in Inventor 4

TwoPlanesWorkPlaneDef Interface Introduced in Inventor 6

TwoPlanesWorkPlaneDef Methods

TwoPlanesWorkPlaneDef.GetData Method Introduced in Inventor 6

TwoPlanesWorkPlaneDef Properties

TwoPlanesWorkPlaneDef.Application Property Introduced in Inventor 6

TwoPlanesWorkPlaneDef.Parent Property Introduced in Inventor 6

TwoPlanesWorkPlaneDef.Plane1 Property Introduced in Inventor 6

TwoPlanesWorkPlaneDef.Plane2 Property Introduced in Inventor 6

TwoPlanesWorkPlaneDef.Type Property Introduced in Inventor 6

TwoPointDistanceDimConstraint Interface Introduced in Inventor 5

TwoPointDistanceDimConstraint Properties

TwoPointDistanceDimConstraint.Orientation Property Introduced in Inventor 5

TwoPointDistanceDimConstraint.PointOne Property Introduced in Inventor 5

TwoPointDistanceDimConstraint.PointTwo Property Introduced in Inventor 5

TwoPointDistanceDimConstraint3D Interface Introduced in Inventor 11

TwoPointDistanceDimConstraint3D Properties

TwoPointDistanceDimConstraint3D.PointOne Property Introduced in Inventor 11

TwoPointDistanceDimConstraint3D.PointTwo Property Introduced in Inventor 11

TwoPointDistanceDimConstraint3DProxy Interface Introduced in Inventor 11

TwoPointDistanceDimConstraint3DProxy Properties

TwoPointDistanceDimConstraint3DProxy.ContainingOccurrence Property Introduced in Inventor 11

TwoPointDistanceDimConstraint3DProxy.NativeObject Property Introduced in Inventor 11

TwoPointDistanceDimConstraintProxy Interface Introduced in Inventor 6

TwoPointDistanceDimConstraintProxy Properties

TwoPointDistanceDimConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

TwoPointDistanceDimConstraintProxy.NativeObject Property Introduced in Inventor 6

TwoPointsWorkAxisDef Interface Introduced in Inventor 4

TwoPointsWorkAxisDef Methods

TwoPointsWorkAxisDef.GetData Method Introduced in Inventor 4

TwoPointsWorkAxisDef Properties

TwoPointsWorkAxisDef.Application Property Introduced in Inventor 4

TwoPointsWorkAxisDef.Parent Property Introduced in Inventor 4

TwoPointsWorkAxisDef.Point1 Property Introduced in Inventor 4

TwoPointsWorkAxisDef.Point2 Property Introduced in Inventor 4

TwoPointsWorkAxisDef.Type Property Introduced in Inventor 4

UnfoldFeature Interface Introduced in Inventor 2010

UnfoldFeature Methods

UnfoldFeature.Edit Method Introduced in Inventor 2010

UnfoldFeature Properties

UnfoldFeature.Bends Property Introduced in Inventor 2010

UnfoldFeature.InputSketches Property Introduced in Inventor 2010

UnfoldFeature.ResultSketches Property Introduced in Inventor 2010

UnfoldFeature.StationaryFace Property Introduced in Inventor 2010

UnfoldFeatureProxy Interface Introduced in Inventor 2010

UnfoldFeatures Interface Introduced in Inventor 2010

UnfoldFeatures Methods

UnfoldFeatures.Add Method Introduced in Inventor 2010

UnfoldFeatures.Item Method Introduced in Inventor 2010

UnfoldFeatures Properties

UnfoldFeatures.Application Property Introduced in Inventor 2010

UnfoldFeatures.Count Property Introduced in Inventor 2010

UnfoldFeatures.Type Property Introduced in Inventor 2010

UnfoldMethod Interface Introduced in Inventor 5.3

UnfoldMethod Methods

UnfoldMethod.DeleteEquation Method Introduced in Inventor 2010

UnfoldMethod.GetEquation Method Introduced in Inventor 2010

UnfoldMethod.SetEquation Method Introduced in Inventor 2010

UnfoldMethod.WriteBendTableToFile Method Introduced in Inventor 5.3

UnfoldMethod Properties

UnfoldMethod.BendAngleType Property Introduced in Inventor 2010

UnfoldMethod.EquationCount Property Introduced in Inventor 2010

UnfoldMethod.EquationType Property Introduced in Inventor 2010

UnfoldMethod.kFactor Property Introduced in Inventor 2009

UnfoldMethod.SplineFactor Property Introduced in Inventor 2010

UnfoldMethod.UnfoldMethodType Property Introduced in Inventor 5.3

UnfoldMethods Interface Introduced in Inventor 5.3

UnfoldMethods Methods

UnfoldMethods.AddBendTableFromFile Method Introduced in Inventor 5.3

UnfoldMethods.AddEquationUnfoldMethod Method Introduced in Inventor 2011

UnfoldMethods.AddLinearUnfoldMethod Method Introduced in Inventor 5.3

UnfoldMethods.Item Method Introduced in Inventor 5.3

UnfoldMethods Properties

UnfoldMethods.Application Property Introduced in Inventor 5.3

UnfoldMethods.Count Property Introduced in Inventor 5.3

UnfoldMethods.Type Property Introduced in Inventor 5.3

UnitsOfMeasure Interface Introduced in Inventor 4

UnitsOfMeasure Methods

UnitsOfMeasure._GetValueFromExpression Method

UnitsOfMeasure.CompatibleUnits Method Introduced in Inventor 8

UnitsOfMeasure.ConvertUnits Method Introduced in Inventor 8

UnitsOfMeasure.GetDatabaseUnitsFromExpression Method Introduced in Inventor 11

UnitsOfMeasure.GetDrivingParameters Method Introduced in Inventor 11

UnitsOfMeasure.GetLocaleCorrectedExpression Method Introduced in Inventor 10

UnitsOfMeasure.GetPreciseStringFromValue Method Introduced in Inventor 11

UnitsOfMeasure.GetStringFromType Method Introduced in Inventor 4

UnitsOfMeasure.GetStringFromValue Method Introduced in Inventor 4

UnitsOfMeasure.GetTypeFromString Method Introduced in Inventor 4

UnitsOfMeasure.GetValueFromExpression Method Introduced in Inventor 4

UnitsOfMeasure.IsExpressionValid Method Introduced in Inventor 2008

UnitsOfMeasure Properties

UnitsOfMeasure.AngleDisplayPrecision Property Introduced in Inventor 4

UnitsOfMeasure.AngleUnits Property Introduced in Inventor 4

UnitsOfMeasure.LengthDisplayPrecision Property Introduced in Inventor 4

UnitsOfMeasure.LengthUnits Property Introduced in Inventor 4

UnitsOfMeasure.MassUnits Property Introduced in Inventor 4

UnitsOfMeasure.Parent Property Introduced in Inventor 4

UnitsOfMeasure.TimeUnits Property Introduced in Inventor 4

UnitsOfMeasure.Type Property Introduced in Inventor 4

UnitVector Interface Introduced in Inventor 4

UnitVector Methods

UnitVector.AngleTo Method Introduced in Inventor 4

UnitVector.AsVector Method Introduced in Inventor 4

UnitVector.CrossProduct Method Introduced in Inventor 4

UnitVector.DotProduct Method Introduced in Inventor 4

UnitVector.GetUnitVectorData Method Introduced in Inventor 4

UnitVector.IsEqualTo Method Introduced in Inventor 4

UnitVector.IsParallelTo Method Introduced in Inventor 4

UnitVector.IsPerpendicularTo Method Introduced in Inventor 4

UnitVector.PutUnitVectorData Method Introduced in Inventor 4

UnitVector.TransformBy Method Introduced in Inventor 4

UnitVector Properties

UnitVector.X Property Introduced in Inventor 4

UnitVector.Y Property Introduced in Inventor 4

UnitVector.Z Property Introduced in Inventor 4

UnitVector2d Interface Introduced in Inventor 4

UnitVector2d Methods

UnitVector2d.AngleTo Method Introduced in Inventor 11

UnitVector2d.AsVector Method Introduced in Inventor 11

UnitVector2d.DotProduct Method Introduced in Inventor 11

UnitVector2d.GetUnitVectorData Method Introduced in Inventor 4

UnitVector2d.IsEqualTo Method Introduced in Inventor 11

UnitVector2d.IsParallelTo Method Introduced in Inventor 11

UnitVector2d.IsPerpendicularTo Method Introduced in Inventor 11

UnitVector2d.PutUnitVectorData Method Introduced in Inventor 4

UnitVector2d.TransformBy Method Introduced in Inventor 11

UnitVector2d Properties

UnitVector2d.X Property Introduced in Inventor 4

UnitVector2d.Y Property Introduced in Inventor 4

UserCoordinateSystem Interface Introduced in Inventor 2010

UserCoordinateSystem Methods

UserCoordinateSystem.Delete Method Introduced in Inventor 2010

UserCoordinateSystem.GetReferenceKey Method Introduced in Inventor 2010

UserCoordinateSystem.SetEndOfPart Method Introduced in Inventor 2010

UserCoordinateSystem Properties

UserCoordinateSystem.Application Property Introduced in Inventor 2010

UserCoordinateSystem.AttributeSets Property Introduced in Inventor 2010

UserCoordinateSystem.Definition Property Introduced in Inventor 2011

UserCoordinateSystem.HealthStatus Property Introduced in Inventor 2010

UserCoordinateSystem.IsOwnedByFeature Property Introduced in Inventor 2010

UserCoordinateSystem.Name Property Introduced in Inventor 2010

UserCoordinateSystem.Origin Property Introduced in Inventor 2010

UserCoordinateSystem.OwnedBy Property Introduced in Inventor 2010

UserCoordinateSystem.Parent Property Introduced in Inventor 2010

UserCoordinateSystem.Transformation Property Introduced in Inventor 2010

UserCoordinateSystem.Type Property Introduced in Inventor 2010

UserCoordinateSystem.Visible Property Introduced in Inventor 2010

UserCoordinateSystem.XAngle Property Introduced in Inventor 2010

UserCoordinateSystem.XAxis Property Introduced in Inventor 2010

UserCoordinateSystem.XOffset Property Introduced in Inventor 2010

UserCoordinateSystem.XYPlane Property Introduced in Inventor 2010

UserCoordinateSystem.XZPlane Property Introduced in Inventor 2010

UserCoordinateSystem.YAngle Property Introduced in Inventor 2010

UserCoordinateSystem.YAxis Property Introduced in Inventor 2010

UserCoordinateSystem.YOffset Property Introduced in Inventor 2010

UserCoordinateSystem.YZPlane Property Introduced in Inventor 2010

UserCoordinateSystem.ZAngle Property Introduced in Inventor 2010

UserCoordinateSystem.ZAxis Property Introduced in Inventor 2010

UserCoordinateSystem.ZOffset Property Introduced in Inventor 2010

UserCoordinateSystemDefinition Interface Introduced in Inventor 2011

UserCoordinateSystemDefinition Methods

UserCoordinateSystemDefinition.GetByThreePoints Method Introduced in Inventor 2011

UserCoordinateSystemDefinition.SetByThreePoints Method Introduced in Inventor 2011

UserCoordinateSystemDefinition Properties

UserCoordinateSystemDefinition.Application Property Introduced in Inventor 2011

UserCoordinateSystemDefinition.DefinitionType Property Introduced in Inventor 2011

UserCoordinateSystemDefinition.Parent Property Introduced in Inventor 2011

UserCoordinateSystemDefinition.Transformation Property Introduced in Inventor 2011

UserCoordinateSystemDefinition.Type Property Introduced in Inventor 2011

UserCoordinateSystemProxy Interface Introduced in Inventor 2010

UserCoordinateSystemProxy Properties

UserCoordinateSystemProxy.ContainingOccurrence Property Introduced in Inventor 2010

UserCoordinateSystemProxy.NativeObject Property Introduced in Inventor 2010

UserCoordinateSystems Interface Introduced in Inventor 2010

UserCoordinateSystems Methods

UserCoordinateSystems.Add Method Introduced in Inventor 2011

UserCoordinateSystems.CreateDefinition Method Introduced in Inventor 2011

UserCoordinateSystems.Item Method Introduced in Inventor 2010

UserCoordinateSystems Properties

UserCoordinateSystems.Application Property Introduced in Inventor 2010

UserCoordinateSystems.Count Property Introduced in Inventor 2010

UserCoordinateSystems.Type Property Introduced in Inventor 2010

UserCoordinateSystemSettings Interface Introduced in Inventor 2010

UserCoordinateSystemSettings Properties

UserCoordinateSystemSettings.Application Property Introduced in Inventor 2010

UserCoordinateSystemSettings.DefaultPlane Property Introduced in Inventor 2010

UserCoordinateSystemSettings.NamingPrefix Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowOrigin Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowTriad Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowXAxis Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowXYPlane Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowXZPlane Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowYAxis Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowYZPlane Property Introduced in Inventor 2010

UserCoordinateSystemSettings.ShowZAxis Property Introduced in Inventor 2010

UserCoordinateSystemSettings.Type Property Introduced in Inventor 2010

UserInputEvents CoClass Introduced in Inventor 4

UserInputEventsObject Interface Introduced in Inventor 4

UserInputEventsObject Properties

UserInputEventsObject.Application Property Introduced in Inventor 6

UserInputEventsObject.Parent Property Introduced in Inventor 6

UserInputEventsObject.Type Property Introduced in Inventor 6

UserInputEventsSink Interface Introduced in Inventor 4

UserInputEventsSink Methods

UserInputEventsSink.OnActivateCommand Method Introduced in Inventor 10

UserInputEventsSink.OnContextualMiniToolbar Method Introduced in Inventor 2012

UserInputEventsSink.OnDoubleClick Method Introduced in Inventor 2009

UserInputEventsSink.OnDrag Method Introduced in Inventor 9

UserInputEventsSink.OnLinearMarkingMenu Method Introduced in Inventor 2012

UserInputEventsSink.OnPreSelect Method

UserInputEventsSink.OnRadialMarkingMenu Method Introduced in Inventor 2012

UserInputEventsSink.OnSelect Method

UserInputEventsSink.OnStopPreSelect Method

UserInputEventsSink.OnTerminateCommand Method Introduced in Inventor 10

UserInputEventsSink.OnUnSelect Method

UserInterfaceEvents CoClass Introduced in Inventor 10

UserInterfaceEventsObject Interface Introduced in Inventor 10

UserInterfaceEventsObject Properties

UserInterfaceEventsObject.Application Property Introduced in Inventor 10

UserInterfaceEventsObject.Parent Property Introduced in Inventor 10

UserInterfaceEventsObject.Type Property Introduced in Inventor 10

UserInterfaceEventsSink Interface Introduced in Inventor 10

UserInterfaceEventsSink Methods

UserInterfaceEventsSink.OnEnvironmentChange Method Introduced in Inventor 10

UserInterfaceEventsSink.OnResetCommandBars Method Introduced in Inventor 10

UserInterfaceEventsSink.OnResetEnvironments Method Introduced in Inventor 10

UserInterfaceEventsSink.OnResetRibbonInterface Method Introduced in Inventor 2010

UserInterfaceEventsSink.OnResetShortcuts Method Introduced in Inventor 2008

UserInterfaceManager Interface Introduced in Inventor 9

UserInterfaceManager Methods

UserInterfaceManager.AllReferencedControls Method Introduced in Inventor 2010

UserInterfaceManager.DoEvents Method Introduced in Inventor 2010

UserInterfaceManager.GetCommandPaths Method Introduced in Inventor 2011

UserInterfaceManager.ResetRibbonInterface Method Introduced in Inventor 2010

UserInterfaceManager Properties

UserInterfaceManager.ActiveEnvironment Property Introduced in Inventor 9

UserInterfaceManager.Application Property Introduced in Inventor 9

UserInterfaceManager.BalloonTips Property

UserInterfaceManager.CapacityMeterEnabled Property Introduced in Inventor 2008

UserInterfaceManager.CommandBars Property Introduced in Inventor 9

UserInterfaceManager.DockableWindows Property Introduced in Inventor 2011

UserInterfaceManager.Environments Property Introduced in Inventor 9

UserInterfaceManager.ExpertMode Property Introduced in Inventor 11

UserInterfaceManager.FileBrowserControls Property Introduced in Inventor 2010

UserInterfaceManager.HelpControls Property Introduced in Inventor 2010

UserInterfaceManager.InterfaceStyle Property Introduced in Inventor 2011

UserInterfaceManager.LargeIcons Property Introduced in Inventor 11

UserInterfaceManager.ParallelEnvironments Property Introduced in Inventor 10

UserInterfaceManager.Parent Property Introduced in Inventor 9

UserInterfaceManager.RibbonAppearance Property Introduced in Inventor 2010

UserInterfaceManager.RibbonDockingState Property Introduced in Inventor 2010

UserInterfaceManager.Ribbons Property Introduced in Inventor 2010

UserInterfaceManager.RibbonState Property Introduced in Inventor 2010

UserInterfaceManager.ShowBrowser Property Introduced in Inventor 9

UserInterfaceManager.ShowCleanScreen Property Introduced in Inventor 2010

UserInterfaceManager.ShowDocumentTabs Property Introduced in Inventor 2010

UserInterfaceManager.ShowMarkingMenu Property Introduced in Inventor 2012

UserInterfaceManager.ShowNavigationBar Property

UserInterfaceManager.ShowPanelBar Property Introduced in Inventor 9

UserInterfaceManager.ShowPanelTitles Property Introduced in Inventor 2010

UserInterfaceManager.ShowQuickAccessControlsBelowRibbon Property Introduced in Inventor 2010

UserInterfaceManager.ShowStatusBar Property Introduced in Inventor 9

UserInterfaceManager.ShowSteeringWheel Property

UserInterfaceManager.ShowToolBar Property Introduced in Inventor 9

UserInterfaceManager.ShowViewCube Property

UserInterfaceManager.Type Property Introduced in Inventor 9

UserInterfaceManager.UserInteractionDisabled Property Introduced in Inventor 10

UserInterfaceManager.UserInterfaceEvents Property Introduced in Inventor 10

UserParameter Interface Introduced in Inventor 4

UserParameter Methods

UserParameter.ConvertToModelParameter Method Introduced in Inventor 10

UserParameter.ConvertToReferenceParameter Method Introduced in Inventor 10

UserParameters Interface Introduced in Inventor 4

UserParameters Methods

UserParameters._AddByValue Method

UserParameters.AddByExpression Method Introduced in Inventor 4

UserParameters.AddByValue Method Introduced in Inventor 4

UserParameters.Item Method Introduced in Inventor 4

UserParameters Properties

UserParameters.Count Property Introduced in Inventor 4

UserParameters.Type Property Introduced in Inventor 4

VbaApplication Interface Introduced in Inventor 5

VbaApplication Properties

VbaApplication.ThisApplication Property Introduced in Inventor 5

VbaApplication.ThisServer Property

Vector Interface Introduced in Inventor 4

Vector Methods

Vector.AddVector Method Introduced in Inventor 4

Vector.AngleTo Method Introduced in Inventor 4

Vector.AsUnitVector Method Introduced in Inventor 4

Vector.CrossProduct Method Introduced in Inventor 4

Vector.DotProduct Method Introduced in Inventor 4

Vector.GetVectorData Method Introduced in Inventor 4

Vector.IsEqualTo Method Introduced in Inventor 4

Vector.IsParallelTo Method Introduced in Inventor 4

Vector.IsPerpendicularTo Method Introduced in Inventor 4

Vector.Normalize Method Introduced in Inventor 5

Vector.PutVectorData Method Introduced in Inventor 4

Vector.ScaleBy Method Introduced in Inventor 4

Vector.SubtractVector Method Introduced in Inventor 4

Vector.TransformBy Method Introduced in Inventor 4

Vector Properties

Vector.Length Property Introduced in Inventor 4

Vector.X Property Introduced in Inventor 4

Vector.Y Property Introduced in Inventor 4

Vector.Z Property Introduced in Inventor 4

Vector2d Interface Introduced in Inventor 4

Vector2d Methods

Vector2d.AddVector Method Introduced in Inventor 11

Vector2d.AngleTo Method Introduced in Inventor 11

Vector2d.AsUnitVector Method Introduced in Inventor 11

Vector2d.DotProduct Method Introduced in Inventor 11

Vector2d.GetVectorData Method Introduced in Inventor 4

Vector2d.IsEqualTo Method Introduced in Inventor 11

Vector2d.IsParallelTo Method Introduced in Inventor 11

Vector2d.IsPerpendicularTo Method Introduced in Inventor 11

Vector2d.Normalize Method Introduced in Inventor 11

Vector2d.PutVectorData Method Introduced in Inventor 4

Vector2d.ScaleBy Method Introduced in Inventor 11

Vector2d.SubtractVector Method Introduced in Inventor 11

Vector2d.TransformBy Method Introduced in Inventor 11

Vector2d Properties

Vector2d.Length Property Introduced in Inventor 11

Vector2d.X Property Introduced in Inventor 4

Vector2d.Y Property Introduced in Inventor 4

Vertex Interface Introduced in Inventor 4

Vertex Methods

Vertex.GetPoint Method Introduced in Inventor 4

Vertex.GetReferenceKey Method Introduced in Inventor 5

Vertex.GetSourceVertex Method Introduced in Inventor 10

Vertex Properties

Vertex.Application Property Introduced in Inventor 11

Vertex.AttributeSets Property Introduced in Inventor 5

Vertex.Edges Property Introduced in Inventor 4

Vertex.Faces Property Introduced in Inventor 4

Vertex.IsTolerant Property

Vertex.Parent Property Introduced in Inventor 5

Vertex.Point Property Introduced in Inventor 6

Vertex.Tolerance Property

Vertex.TransientKey Property Introduced in Inventor 9

Vertex.Type Property Introduced in Inventor 5

VertexDefinition Interface Introduced in Inventor 2011

VertexDefinition Properties

VertexDefinition.Application Property

VertexDefinition.AssociativeID Property

VertexDefinition.Position Property

VertexDefinition.Type Property

VertexDefinitions Interface Introduced in Inventor 2011

VertexDefinitions Methods

VertexDefinitions.Add Method

VertexDefinitions.Item Method

VertexDefinitions Properties

VertexDefinitions.Application Property

VertexDefinitions.Count Property

VertexDefinitions.Type Property

VertexProxy Interface Introduced in Inventor 4

VertexProxy Properties

VertexProxy.ContainingOccurrence Property Introduced in Inventor 4

VertexProxy.NativeObject Property Introduced in Inventor 4

VerticalAlignConstraint Interface Introduced in Inventor 5

VerticalAlignConstraint Properties

VerticalAlignConstraint.PointOne Property Introduced in Inventor 5

VerticalAlignConstraint.PointTwo Property Introduced in Inventor 5

VerticalAlignConstraintProxy Interface Introduced in Inventor 6

VerticalAlignConstraintProxy Properties

VerticalAlignConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

VerticalAlignConstraintProxy.NativeObject Property Introduced in Inventor 6

VerticalConstraint Interface Introduced in Inventor 5

VerticalConstraint Properties

VerticalConstraint.Entity Property Introduced in Inventor 5

VerticalConstraint.UseEllipseMajorAxis Property Introduced in Inventor 5

VerticalConstraintProxy Interface Introduced in Inventor 6

VerticalConstraintProxy Properties

VerticalConstraintProxy.ContainingOccurrence Property Introduced in Inventor 6

VerticalConstraintProxy.NativeObject Property Introduced in Inventor 6

Vertices Interface Introduced in Inventor 4

Vertices Methods

Vertices.Item Method Introduced in Inventor 4

Vertices Properties

Vertices.Count Property Introduced in Inventor 4

Vertices.Type Property Introduced in Inventor 4

View Interface Introduced in Inventor 4

View Methods

View.Activate Method Introduced in Inventor 4

View.Close Method Introduced in Inventor 4

View.Fit Method Introduced in Inventor 4

View.GetWindowExtents Method Introduced in Inventor 4

View.GoHome Method

View.Move Method Introduced in Inventor 6

View.ResetFront Method

View.SaveAsBitmap Method Introduced in Inventor 6

View.SetCurrentAsFront Method

View.SetCurrentAsHome Method

View.SetCurrentAsTop Method

View.Update Method Introduced in Inventor 4

View Properties

View.Application Property

View.Camera Property Introduced in Inventor 4

View.Caption Property Introduced in Inventor 4

View.DisplayMode Property Introduced in Inventor 5

View.Document Property Introduced in Inventor 4

View.Height Property Introduced in Inventor 2010

View.HWND Property Introduced in Inventor 4

View.Left Property Introduced in Inventor 6

View.Parent Property Introduced in Inventor 4

View.RayTracing Property Introduced in Inventor 2012

View.RayTracingQuality Property

View.ShowAmbientShadows Property

View.ShowGroundPlane Property

View.ShowGroundReflections Property

View.ShowGroundShadows Property

View.ShowObjectShadows Property

View.Top Property Introduced in Inventor 6

View.Type Property Introduced in Inventor 4

View.Visible Property Introduced in Inventor 4

View.Width Property Introduced in Inventor 2010

View.WindowState Property Introduced in Inventor 6

ViewList Interface Introduced in Inventor 9

ViewList Methods

ViewList.Add Method Introduced in Inventor 9

ViewList.Item Method Introduced in Inventor 9

ViewList.Remove Method Introduced in Inventor 9

ViewList Properties

ViewList.Count Property Introduced in Inventor 9

ViewList.Type Property Introduced in Inventor 9

Views Interface Introduced in Inventor 4

Views Methods

Views.Add Method Introduced in Inventor 4

ViewsEnumerator Interface Introduced in Inventor 4

ViewsEnumerator Methods

ViewsEnumerator.Item Method Introduced in Inventor 4

ViewsEnumerator Properties

ViewsEnumerator.Count Property Introduced in Inventor 4

ViewsEnumerator.Type Property Introduced in Inventor 4

VirtualComponentDefinition Interface Introduced in Inventor 10

VirtualComponentDefinition Properties

VirtualComponentDefinition.DisplayName Property Introduced in Inventor 10

VirtualComponentDefinition.Material Property Introduced in Inventor 11

VirtualComponentDefinition.PropertySets Property Introduced in Inventor 10

Weld Interface Introduced in Inventor 8

Weld Methods

Weld.Delete Method Introduced in Inventor 8

Weld Properties

Weld.Application Property Introduced in Inventor 8

Weld.Name Property Introduced in Inventor 8

Weld.SymbolAttachPoint Property Introduced in Inventor 8

Weld.SymbolBreakPoint Property Introduced in Inventor 8

Weld.Type Property Introduced in Inventor 8

Weld.WeldInfo Property Introduced in Inventor 8

WeldBead Interface Introduced in Inventor 8

WeldBead Methods

WeldBead._IsLegacyWeldBead Method

WeldBead Properties

WeldBead.BeadFaces Property Introduced in Inventor 8

WeldBead.BeadLength Property Introduced in Inventor 11

WeldBead.EndFaces Property Introduced in Inventor 11

WeldBead.FaceSetOne Property Introduced in Inventor 2012

WeldBead.FaceSetTwo Property Introduced in Inventor 2012

WeldBead.SideFaces Property Introduced in Inventor 11

WeldBeads Interface Introduced in Inventor 8

WeldBeads Methods

WeldBeads.Item Method Introduced in Inventor 8

WeldBeads Properties

WeldBeads.Application Property Introduced in Inventor 8

WeldBeads.Count Property Introduced in Inventor 8

WeldBeads.Type Property Introduced in Inventor 8

WeldmentComponentDefinition Interface Introduced in Inventor 8

WeldmentComponentDefinition Methods

WeldmentComponentDefinition.GetEndFillRenderStyle Method Introduced in Inventor 11

WeldmentComponentDefinition.SetEndFillRenderStyle Method Introduced in Inventor 11

WeldmentComponentDefinition Properties

WeldmentComponentDefinition.Machining Property Introduced in Inventor 2010

WeldmentComponentDefinition.Material Property Introduced in Inventor 8

WeldmentComponentDefinition.Preparations Property Introduced in Inventor 2010

WeldmentComponentDefinition.Welds Property Introduced in Inventor 8

WeldmentComponentDefinition.WeldsComponentDefinition Property Introduced in Inventor 8

Welds Interface Introduced in Inventor 8

Welds Methods

Welds.Edit Method Introduced in Inventor 2010

Welds.ExitEdit Method Introduced in Inventor 2010

Welds.Item Method Introduced in Inventor 8

Welds Properties

Welds.Application Property Introduced in Inventor 8

Welds.CosmeticWelds Property Introduced in Inventor 8

Welds.Count Property Introduced in Inventor 8

Welds.Type Property Introduced in Inventor 8

Welds.WeldBeads Property Introduced in Inventor 8

WeldsComponentDefinition Interface Introduced in Inventor 6

WidthOffsetWidthExtent Interface Introduced in Inventor 2009

WidthOffsetWidthExtent Properties

WidthOffsetWidthExtent.Edge Property Introduced in Inventor 2009

WidthOffsetWidthExtent.OffsetDistance Property Introduced in Inventor 2009

WidthOffsetWidthExtent.OffsetEntity Property Introduced in Inventor 2009

WidthOffsetWidthExtent.PositiveDirection Property Introduced in Inventor 2009

WidthOffsetWidthExtent.Width Property Introduced in Inventor 2010

Wire Interface Introduced in Inventor 2008

Wire Properties

Wire.Application Property Introduced in Inventor 2008

Wire.Edges Property Introduced in Inventor 2008

Wire.EdgeUses Property Introduced in Inventor 2008

Wire.Parent Property Introduced in Inventor 2008

Wire.Type Property Introduced in Inventor 2008

WireframeDisplayOptions Interface Introduced in Inventor 11

WireframeDisplayOptions Properties

WireframeDisplayOptions.Application Property Introduced in Inventor 11

WireframeDisplayOptions.Type Property Introduced in Inventor 11

Wires Interface Introduced in Inventor 2009

Wires Methods

Wires.Item Method Introduced in Inventor 2009

Wires Properties

Wires.Count Property Introduced in Inventor 2009

Wires.Type Property Introduced in Inventor 2009

WorkAxes Interface Introduced in Inventor 4

WorkAxes Methods

WorkAxes.AddByAnalyticEdge Method Introduced in Inventor 2008

WorkAxes.AddByLine Method Introduced in Inventor 4

WorkAxes.AddByLineAndPlane Method Introduced in Inventor 4

WorkAxes.AddByLineAndPoint Method Introduced in Inventor 2008

WorkAxes.AddByNormalToSurface Method Introduced in Inventor 2008

WorkAxes.AddByRevolvedFace Method Introduced in Inventor 4

WorkAxes.AddByTwoPlanes Method Introduced in Inventor 4

WorkAxes.AddByTwoPoints Method Introduced in Inventor 4

WorkAxes.AddFixed Method Introduced in Inventor 4

WorkAxes.Item Method Introduced in Inventor 4

WorkAxes Properties

WorkAxes.Application Property Introduced in Inventor 4

WorkAxes.Count Property Introduced in Inventor 4

WorkAxes.Parent Property Introduced in Inventor 4

WorkAxes.Type Property Introduced in Inventor 4

WorkAxis Interface Introduced in Inventor 4

WorkAxis Methods

WorkAxis.Delete Method Introduced in Inventor 4

WorkAxis.GetReferenceKey Method Introduced in Inventor 5

WorkAxis.GetSize Method Introduced in Inventor 2008

WorkAxis.SetByAnalyticEdge Method Introduced in Inventor 2008

WorkAxis.SetByLine Method Introduced in Inventor 4

WorkAxis.SetByLineAndPlane Method Introduced in Inventor 4

WorkAxis.SetByLineAndPoint Method Introduced in Inventor 2008

WorkAxis.SetByNormalToSurface Method Introduced in Inventor 2008

WorkAxis.SetByRevolvedFace Method Introduced in Inventor 4

WorkAxis.SetByTwoPlanes Method Introduced in Inventor 4

WorkAxis.SetByTwoPoints Method Introduced in Inventor 4

WorkAxis.SetEndOfPart Method Introduced in Inventor 6

WorkAxis.SetFixed Method Introduced in Inventor 4

WorkAxis.SetSize Method Introduced in Inventor 2008

WorkAxis Properties

WorkAxis.Adaptive Property Introduced in Inventor 4

WorkAxis.Application Property Introduced in Inventor 4

WorkAxis.AttributeSets Property Introduced in Inventor 5

WorkAxis.AutoResize Property Introduced in Inventor 2008

WorkAxis.Construction Property Introduced in Inventor 4

WorkAxis.Consumed Property Introduced in Inventor 11

WorkAxis.ConsumeInputs Property Introduced in Inventor 11

WorkAxis.Definition Property Introduced in Inventor 4

WorkAxis.DefinitionType Property Introduced in Inventor 4

WorkAxis.Dependents Property Introduced in Inventor 4

WorkAxis.DrivenBy Property Introduced in Inventor 4

WorkAxis.Exported Property

WorkAxis.Grounded Property Introduced in Inventor 7

WorkAxis.HasReferenceComponent Property Introduced in Inventor 5.3

WorkAxis.HealthStatus Property Introduced in Inventor 4

WorkAxis.IsCoordinateSystemElement Property Introduced in Inventor 2010

WorkAxis.IsOwnedByFeature Property Introduced in Inventor 2008

WorkAxis.IsParentSketch Property Introduced in Inventor 2008

WorkAxis.IsPatternElement Property Introduced in Inventor 9

WorkAxis.Line Property Introduced in Inventor 4

WorkAxis.Name Property Introduced in Inventor 4

WorkAxis.OwnedBy Property Introduced in Inventor 2008

WorkAxis.Parent Property Introduced in Inventor 4

WorkAxis.ParentSketch Property Introduced in Inventor 2008

WorkAxis.ReferenceComponent Property Introduced in Inventor 5.3

WorkAxis.ReferencedEntity Property Introduced in Inventor 5.3

WorkAxis.Shared Property Introduced in Inventor 11

WorkAxis.Type Property Introduced in Inventor 4

WorkAxis.Visible Property Introduced in Inventor 4

WorkAxisProxy Interface Introduced in Inventor 5

WorkAxisProxy Properties

WorkAxisProxy.ContainingOccurrence Property Introduced in Inventor 5

WorkAxisProxy.NativeObject Property Introduced in Inventor 5

WorkPlane Interface Introduced in Inventor 4

WorkPlane Methods

WorkPlane.Delete Method Introduced in Inventor 4

WorkPlane.FlipNormal Method Introduced in Inventor 11

WorkPlane.GetPosition Method Introduced in Inventor 4

WorkPlane.GetReferenceKey Method Introduced in Inventor 5

WorkPlane.GetSize Method Introduced in Inventor 4

WorkPlane.SetByLineAndTangent Method Introduced in Inventor 4

WorkPlane.SetByLinePlaneAndAngle Method Introduced in Inventor 4

WorkPlane.SetByNormalToCurve Method Introduced in Inventor 2008

WorkPlane.SetByPlaneAndOffset Method Introduced in Inventor 4

WorkPlane.SetByPlaneAndPoint Method Introduced in Inventor 4

WorkPlane.SetByPlaneAndTangent Method Introduced in Inventor 4

WorkPlane.SetByPointAndTangent Method Introduced in Inventor 2008

WorkPlane.SetByThreePoints Method Introduced in Inventor 2008

WorkPlane.SetByTorusMidPlane Method Introduced in Inventor 2008

WorkPlane.SetByTwoLines Method Introduced in Inventor 4

WorkPlane.SetByTwoPlanes Method Introduced in Inventor 2008

WorkPlane.SetEndOfPart Method Introduced in Inventor 6

WorkPlane.SetFixed Method Introduced in Inventor 4

WorkPlane.SetSize Method Introduced in Inventor 4

WorkPlane Properties

WorkPlane.Adaptive Property Introduced in Inventor 4

WorkPlane.Application Property Introduced in Inventor 4

WorkPlane.AttributeSets Property Introduced in Inventor 5

WorkPlane.AutoResize Property Introduced in Inventor 2008

WorkPlane.Construction Property Introduced in Inventor 4

WorkPlane.Consumed Property Introduced in Inventor 11

WorkPlane.ConsumeInputs Property Introduced in Inventor 11

WorkPlane.Definition Property Introduced in Inventor 4

WorkPlane.DefinitionType Property Introduced in Inventor 4

WorkPlane.Dependents Property Introduced in Inventor 4

WorkPlane.DrivenBy Property Introduced in Inventor 4

WorkPlane.Exported Property

WorkPlane.Grounded Property Introduced in Inventor 7

WorkPlane.HasReferenceComponent Property Introduced in Inventor 5.3

WorkPlane.HealthStatus Property Introduced in Inventor 4

WorkPlane.IsCoordinateSystemElement Property Introduced in Inventor 2010

WorkPlane.IsOwnedByFeature Property Introduced in Inventor 2008

WorkPlane.IsParentSketch Property Introduced in Inventor 2008

WorkPlane.IsPatternElement Property Introduced in Inventor 9

WorkPlane.Name Property Introduced in Inventor 4

WorkPlane.OwnedBy Property Introduced in Inventor 2008

WorkPlane.Parent Property Introduced in Inventor 4

WorkPlane.ParentSketch Property Introduced in Inventor 2008

WorkPlane.Plane Property Introduced in Inventor 4

WorkPlane.ReferenceComponent Property Introduced in Inventor 5.3

WorkPlane.ReferencedEntity Property Introduced in Inventor 5.3

WorkPlane.Shared Property Introduced in Inventor 11

WorkPlane.Type Property Introduced in Inventor 4

WorkPlane.Visible Property Introduced in Inventor 4

WorkPlaneProxy Interface Introduced in Inventor 5

WorkPlaneProxy Properties

WorkPlaneProxy.ContainingOccurrence Property Introduced in Inventor 5

WorkPlaneProxy.NativeObject Property Introduced in Inventor 5

WorkPlanes Interface Introduced in Inventor 4

WorkPlanes Methods

WorkPlanes.AddByLineAndTangent Method Introduced in Inventor 4

WorkPlanes.AddByLinePlaneAndAngle Method Introduced in Inventor 4

WorkPlanes.AddByNormalToCurve Method Introduced in Inventor 6

WorkPlanes.AddByPlaneAndOffset Method Introduced in Inventor 4

WorkPlanes.AddByPlaneAndPoint Method Introduced in Inventor 4

WorkPlanes.AddByPlaneAndTangent Method Introduced in Inventor 4

WorkPlanes.AddByPointAndTangent Method Introduced in Inventor 2008

WorkPlanes.AddByThreePoints Method Introduced in Inventor 4

WorkPlanes.AddByTorusMidPlane Method Introduced in Inventor 2008

WorkPlanes.AddByTwoLines Method Introduced in Inventor 4

WorkPlanes.AddByTwoPlanes Method Introduced in Inventor 6

WorkPlanes.AddFixed Method Introduced in Inventor 4

WorkPlanes.Item Method Introduced in Inventor 4

WorkPlanes Properties

WorkPlanes.Application Property Introduced in Inventor 4

WorkPlanes.Count Property Introduced in Inventor 4

WorkPlanes.Parent Property Introduced in Inventor 4

WorkPlanes.Type Property Introduced in Inventor 4

WorkPoint Interface Introduced in Inventor 4

WorkPoint Methods

WorkPoint.Delete Method Introduced in Inventor 4

WorkPoint.GetReferenceKey Method Introduced in Inventor 5

WorkPoint.SetAtCentroid Method Introduced in Inventor 2008

WorkPoint.SetByCurveAndEntity Method Introduced in Inventor 2008

WorkPoint.SetByMidPoint Method Introduced in Inventor 4

WorkPoint.SetByPoint Method Introduced in Inventor 4

WorkPoint.SetByThreePlanes Method Introduced in Inventor 4

WorkPoint.SetByTorusCenterPoint Method Introduced in Inventor 2008

WorkPoint.SetByTwoLines Method Introduced in Inventor 4

WorkPoint.SetEndOfPart Method Introduced in Inventor 6

WorkPoint.SetFixed Method Introduced in Inventor 4

WorkPoint Properties

WorkPoint.Adaptive Property Introduced in Inventor 4

WorkPoint.Application Property Introduced in Inventor 4

WorkPoint.AttributeSets Property Introduced in Inventor 5

WorkPoint.Construction Property Introduced in Inventor 4

WorkPoint.Consumed Property Introduced in Inventor 11

WorkPoint.ConsumeInputs Property Introduced in Inventor 11

WorkPoint.Definition Property Introduced in Inventor 4

WorkPoint.DefinitionType Property Introduced in Inventor 4

WorkPoint.Dependents Property Introduced in Inventor 4

WorkPoint.DrivenBy Property Introduced in Inventor 4

WorkPoint.Exported Property

WorkPoint.Grounded Property Introduced in Inventor 7

WorkPoint.HasReferenceComponent Property Introduced in Inventor 5.3

WorkPoint.HealthStatus Property Introduced in Inventor 4

WorkPoint.IsCoordinateSystemElement Property Introduced in Inventor 2010

WorkPoint.IsOwnedByFeature Property Introduced in Inventor 2008

WorkPoint.IsParentSketch Property Introduced in Inventor 2008

WorkPoint.IsPatternElement Property Introduced in Inventor 9

WorkPoint.Name Property Introduced in Inventor 4

WorkPoint.OwnedBy Property Introduced in Inventor 2008

WorkPoint.Parent Property Introduced in Inventor 4

WorkPoint.ParentSketch Property Introduced in Inventor 2008

WorkPoint.Point Property Introduced in Inventor 4

WorkPoint.ReferenceComponent Property Introduced in Inventor 5.3

WorkPoint.ReferencedEntity Property Introduced in Inventor 5.3

WorkPoint.Shared Property Introduced in Inventor 11

WorkPoint.Type Property Introduced in Inventor 4

WorkPoint.Visible Property Introduced in Inventor 4

WorkPointProxy Interface Introduced in Inventor 5

WorkPointProxy Properties

WorkPointProxy.ContainingOccurrence Property Introduced in Inventor 5

WorkPointProxy.NativeObject Property Introduced in Inventor 5

WorkPoints Interface Introduced in Inventor 4

WorkPoints Methods

WorkPoints.AddAtCentroid Method Introduced in Inventor 2008

WorkPoints.AddByCurveAndEntity Method Introduced in Inventor 6

WorkPoints.AddByMidPoint Method Introduced in Inventor 4

WorkPoints.AddByPoint Method Introduced in Inventor 4

WorkPoints.AddByThreePlanes Method Introduced in Inventor 6

WorkPoints.AddByTorusCenterPoint Method Introduced in Inventor 2008

WorkPoints.AddByTwoLines Method Introduced in Inventor 4

WorkPoints.AddFixed Method Introduced in Inventor 4

WorkPoints.Item Method Introduced in Inventor 4

WorkPoints Properties

WorkPoints.Application Property Introduced in Inventor 4

WorkPoints.Count Property Introduced in Inventor 4

WorkPoints.Parent Property Introduced in Inventor 4

WorkPoints.Type Property Introduced in Inventor 4

WorkSurface Interface Introduced in Inventor 6

WorkSurface Methods

WorkSurface.GetReferenceKey Method Introduced in Inventor 6

WorkSurface Properties

WorkSurface.Application Property Introduced in Inventor 6

WorkSurface.AttributeSets Property Introduced in Inventor 9

WorkSurface.Exported Property

WorkSurface.Parent Property Introduced in Inventor 6

WorkSurface.SurfaceBodies Property Introduced in Inventor 11

WorkSurface.Translucent Property Introduced in Inventor 6

WorkSurface.Type Property Introduced in Inventor 6

WorkSurface.Visible Property Introduced in Inventor 6

WorkSurfaceProxy Interface Introduced in Inventor 6

WorkSurfaceProxy Properties

WorkSurfaceProxy.ContainingOccurrence Property Introduced in Inventor 6

WorkSurfaceProxy.NativeObject Property Introduced in Inventor 6

WorkSurfaces Interface Introduced in Inventor 6

WorkSurfaces Methods

WorkSurfaces.Item Method Introduced in Inventor 6

WorkSurfaces Properties

WorkSurfaces.Application Property Introduced in Inventor 6

WorkSurfaces.Count Property Introduced in Inventor 6

WorkSurfaces.Parent Property Introduced in Inventor 6

WorkSurfaces.Type Property Introduced in Inventor 6

Enums

Inventor.AccuracyEnum Enumeration

Inventor.ActionTypeEnum Enumeration Introduced in Inventor 9

Inventor.AddInLicenseStatusEnum Enumeration

Inventor.AddInLoadBehaviorEnum Enumeration

Inventor.AlignmentTypeEnum Enumeration

Inventor.AlternateUnitsDisplayTypeEnum Enumeration

Inventor.AnalysisTypeEnum Enumeration

Inventor.AngleConstraintSolutionTypeEnum Enumeration

Inventor.AngularPrecisionEnum Enumeration Introduced in Inventor 9

Inventor.ApplicationAddInTypeEnum Enumeration Introduced in Inventor 4

Inventor.ApplicationFrameColorTypeEnum Enumeration

Inventor.ArcDimensionTypeEnum Enumeration

Inventor.ArrowheadTypeEnum Enumeration

Inventor.BackgroundTypeEnum Enumeration

Inventor.BalloonDirectionEnum Enumeration Introduced in Inventor 9

Inventor.BalloonTypeEnum Enumeration Introduced in Inventor 9

Inventor.BarControlTypeEnum Enumeration Introduced in Inventor 5

Inventor.BaseFeatureOutputTypeEnum Enumeration

Inventor.BendAngleTypeEnum Enumeration

Inventor.BendLocationEnum Enumeration

Inventor.BendOrderSourceTypeEnum Enumeration

Inventor.BendPartTypeEnum Enumeration

Inventor.BendPositionEnum Enumeration

Inventor.BendReliefShapeEnum Enumeration Introduced in Inventor 5.3

Inventor.BendTransitionEnum Enumeration Introduced in Inventor 5.3

Inventor.BIMCableTrayConnectionTypeEnum Enumeration

Inventor.BIMConduitConnectionTypeEnum Enumeration

Inventor.BIMConnectorDefinitionTypeEnum Enumeration

Inventor.BIMConnectorShapeEnum Enumeration

Inventor.BIMDuctConnectionTypeEnum Enumeration

Inventor.BIMDuctFlowConfigurationEnum Enumeration

Inventor.BIMDuctLossMethodEnum Enumeration

Inventor.BIMDuctSystemTypeEnum Enumeration

Inventor.BIMElectricalSystemTypeEnum Enumeration

Inventor.BIMFlowDirectionEnum Enumeration

Inventor.BIMPipeConnectionTypeEnum Enumeration

Inventor.BIMPipeFlowConfigurationEnum Enumeration

Inventor.BIMPipeLossMethodEnum Enumeration

Inventor.BIMPipeSystemTypeEnum Enumeration

Inventor.BOMQuantityTypeEnum Enumeration

Inventor.BOMStructureEnum Enumeration

Inventor.BOMViewTypeEnum Enumeration

Inventor.BooleanTypeEnum Enumeration

Inventor.BorderLabelModeEnum Enumeration Introduced in Inventor 5.3

Inventor.BoreLine Structure

Inventor.BossTypeEnum Enumeration

Inventor.BoundaryPatchConditionEnum Enumeration

Inventor.BreakOrientationEnum Enumeration

Inventor.BreakOutDepthTypeEnum Enumeration

Inventor.BreakStyleEnum Enumeration

Inventor.BrowserNodeDisplayStateEnum Enumeration Introduced in Inventor 9

Inventor.ButtonDisplayEnum Enumeration Introduced in Inventor 9

Inventor.ButtonTypeEnum Enumeration

Inventor.CenterlineTypeEnum Enumeration

Inventor.CentermarkTypeEnum Enumeration

Inventor.ChamferDefinitionTypeEnum Enumeration Introduced in Inventor 5.3

Inventor.CircleDimensionTypeEnum Enumeration

Inventor.ClientGraphicsTypeEnum Enumeration Introduced in Inventor 9

Inventor.ColorBindingEnum Enumeration Introduced in Inventor 5

Inventor.ColorSourceTypeEnum Enumeration

Inventor.CommandBarTypeEnum Enumeration Introduced in Inventor 9

Inventor.CommandIDEnum Enumeration

Inventor.CommandTypesEnum Enumeration Introduced in Inventor 6

Inventor.ComparisonTypeEnum Enumeration

Inventor.ConstraintIncrementTypeEnum Enumeration Introduced in Inventor 2012

Inventor.ConstraintPriorityEnum Enumeration Introduced in Inventor 9

Inventor.ConstraintStatusEnum Enumeration

Inventor.ContainmentEnum Enumeration Introduced in Inventor 6

Inventor.ContentCenterAccessOptionEnum Enumeration

Inventor.ContentCenterInstanceStatusEnum Enumeration

Inventor.ContentCenterRSCResultEnum Enumeration

Inventor.ContentFamilyTypeEnum Enumeration

Inventor.ContentItemTypeEnum Enumeration

Inventor.ContentLibraryComponentTypeBits Enumeration Introduced in Inventor 6

Inventor.ContentMemberRefreshEnum Enumeration

Inventor.ContentUserRoleEnum Enumeration

Inventor.ContinuityTypeEnum Enumeration

Inventor.ControlDefinitionTypeEnum Enumeration Introduced in Inventor 9

Inventor.ControlTypeEnum Enumeration Introduced in Inventor 9

Inventor.CoordinateSystemPlaneEnum Enumeration

Inventor.CornerDefinitionTypeEnum Enumeration

Inventor.CornerReliefShapeEnum Enumeration Introduced in Inventor 5.3

Inventor.CornerTypeEnum Enumeration

Inventor.CursorHotSpotEnum Enumeration Introduced in Inventor 9

Inventor.CursorTypeEnum Enumeration Introduced in Inventor 9

Inventor.Curve2dTypeEnum Enumeration Introduced in Inventor 4

Inventor.CurveGeometryFormEnum Enumeration Introduced in Inventor 4

Inventor.CurveTypeEnum Enumeration Introduced in Inventor 4

Inventor.CustomPropertyPrecisionEnum Enumeration

Inventor.CustomPropertyTypeEnum Enumeration

Inventor.DebugWatchType Enumeration

Inventor.DecimalMarkerTypeEnum Enumeration Introduced in Inventor 9

Inventor.DefaultDrawingFileTypeEnum Enumeration

Inventor.DefaultLayerStyleEnum Enumeration

Inventor.DefaultNonInventorDWGFileOpenBehaviorEnum Enumeration

Inventor.DefaultObjectStyleEnum Enumeration

Inventor.DerivedComponentOptionEnum Enumeration Introduced in Inventor 5.3

Inventor.DerivedComponentStyleEnum Enumeration

Inventor.DerivedGeometryRemovalEnum Enumeration

Inventor.DerivedHolePatchEnum Enumeration

Inventor.DerivedPartMirrorPlaneEnum Enumeration Introduced in Inventor 5.3

Inventor.DerivedPropertyTypeEnum Enumeration Introduced in Inventor 5.3

Inventor.DesignViewTypeEnum Enumeration

Inventor.DialogStyleEnum Enumeration

Inventor.DimensionAlignmentTypeEnum Enumeration Introduced in Inventor 9

Inventor.DimensionConstraintsRelaxationEnum Enumeration

Inventor.DimensionDisplayTypeEnum Enumeration Introduced in Inventor 6

Inventor.DimensionOrientationEnum Enumeration Introduced in Inventor 5

Inventor.DimensionStyleFormatEnum Enumeration Introduced in Inventor 9

Inventor.DimensionTextAlignmentEnum Enumeration

Inventor.DimensionTypeEnum Enumeration

Inventor.DirectionEnum Enumeration Introduced in Inventor 4

Inventor.DisplayFormatEnum Enumeration

Inventor.DisplayModeEnum Enumeration

Inventor.DisplayModeSourceTypeEnum Enumeration

Inventor.DisplayQualityEnum Enumeration

Inventor.DisplayTransformBehaviorEnum Enumeration Introduced in Inventor 5

Inventor.DockingStateEnum Enumeration Introduced in Inventor 2011

Inventor.DocumentInterestTypeEnum Enumeration

Inventor.DocumentTypeEnum Enumeration Introduced in Inventor 4

Inventor.DoubleBendTypeEnum Enumeration

Inventor.DraftingStandardEnum Enumeration Introduced in Inventor 4

Inventor.DragStateEnum Enumeration Introduced in Inventor 9

Inventor.DrawingEdgeTypeEnum Enumeration

Inventor.DrawingSheetSizeEnum Enumeration Introduced in Inventor 4

Inventor.DrawingSheetStatusBits Enumeration Introduced in Inventor 4

Inventor.DrawingViewAlignmentEnum Enumeration

Inventor.DrawingViewStyleEnum Enumeration Introduced in Inventor 6

Inventor.DrawingViewTypeEnum Enumeration Introduced in Inventor 4

Inventor.DWFPublishModeEnum Enumeration

Inventor.DWGFileVersionEnum Enumeration

Inventor.EdgeCollectionEnum Enumeration Introduced in Inventor 5.3

Inventor.EmbossTypeEnum Enumeration

Inventor.EnvironmentStateEnum Enumeration

Inventor.EventTimingEnum Enumeration Introduced in Inventor 4

Inventor.ExitTypeEnum Enumeration

Inventor.FaceCollectionEnum Enumeration Introduced in Inventor 9

Inventor.FactoryOptionsMemberNameTypeEnum Enumeration

Inventor.FactoryOptionsPartNumberTypeEnum Enumeration

Inventor.FamilyParameterValueTypeEnum Enumeration

Inventor.FeatureApproximationTypeEnum Enumeration

Inventor.FeatureDimensionTypeEnum Enumeration

Inventor.FileFormatEnum Enumeration

Inventor.FileManagementEnum Enumeration Introduced in Inventor 6

Inventor.FileOwnershipEnum Enumeration

Inventor.FileTypeEnum Enumeration

Inventor.FileVersionEnum Enumeration

Inventor.FilletTypeEnum Enumeration

Inventor.FlatPatternEdgeTypeEnum Enumeration

Inventor.FrontViewPlaneEnum Enumeration

Inventor.GeneralDataTypeEnum Enumeration

Inventor.GeneralDimensionTypeEnum Enumeration

Inventor.GeometricCharacteristicEnum Enumeration

Inventor.GeometricConstraintsBreakageEnum Enumeration

Inventor.GeometryMoveableStatusEnum Enumeration

Inventor.GraphicsDriverTypeEnum Enumeration

Inventor.GraphicsLevelsOfDetailEnum Enumeration Introduced in Inventor 4

Inventor.GraphicsOptimizationEnum Enumeration

Inventor.GraphicsSelectabilityEnum Enumeration Introduced in Inventor 5

Inventor.GraphicsSettingTypeEnum Enumeration

Inventor.GraphicsVisibilityEnum Enumeration Introduced in Inventor 5

Inventor.GroundShadowEnum Enumeration

Inventor.HandlingCodeEnum Enumeration Introduced in Inventor 4

Inventor.HeadingPlacementEnum Enumeration Introduced in Inventor 9

Inventor.HealthStatusEnum Enumeration Introduced in Inventor 4

Inventor.HeightDatumTypeEnum Enumeration

Inventor.HemTypeEnum Enumeration

Inventor.HoleNoteQuantityEnum Enumeration

Inventor.HolePlacementTypeEnum Enumeration Introduced in Inventor 9

Inventor.HolePropertyEnum Enumeration Introduced in Inventor 2011

Inventor.HoleTableTypeEnum Enumeration Introduced in Inventor 2011

Inventor.HoleTypeEnum Enumeration Introduced in Inventor 5

Inventor.HorizontalTextAlignmentEnum Enumeration Introduced in Inventor 5

Inventor.iComponentColumnTypeEnum Enumeration

Inventor.IconsColorTypeEnum Enumeration

Inventor.iFeatureEntityInputTypeEnum Enumeration Introduced in Inventor 6

Inventor.iFeatureParamLimitTypeEnum Enumeration Introduced in Inventor 6

Inventor.InferredTypeEnum Enumeration Introduced in Inventor 5

Inventor.InspectionDimensionShapeEnum Enumeration

Inventor.IntentTypeEnum Enumeration

Inventor.InteractionEventsEnum Enumeration Introduced in Inventor 5

Inventor.InteractiveContactAnalysisEnum Enumeration

Inventor.InteractiveContactSurfacesEnum Enumeration

Inventor.InterfaceStyleEnum Enumeration

Inventor.IOMechanismEnum Enumeration Introduced in Inventor 4

Inventor.LayDirectionTypeEnum Enumeration

Inventor.LevelOfDetailEnum Enumeration

Inventor.LightDefinitionTypeEnum Enumeration

Inventor.LightTypeEnum Enumeration

Inventor.LinearDimensionTypeEnum Enumeration

Inventor.LinearPrecisionEnum Enumeration Introduced in Inventor 9

Inventor.LineDefinitionSpaceEnum Enumeration Introduced in Inventor 9

Inventor.LineSpacingEnum Enumeration Introduced in Inventor 9

Inventor.LineTypeEnum Enumeration Introduced in Inventor 9

Inventor.LineWeightTypeEnum Enumeration

Inventor.LinkStatusEnum Enumeration

Inventor.LocationTypeEnum Enumeration Introduced in Inventor 4

Inventor.LoftConditionEnum Enumeration Introduced in Inventor 6

Inventor.LoftedFlangeOutputTypeEnum Enumeration

Inventor.LoftTypeEnum Enumeration

Inventor.MassPropertiesAccuracyEnum Enumeration Introduced in Inventor 5

Inventor.MaterialRemovalModifierEnum Enumeration

Inventor.MeasureTypeEnum Enumeration

Inventor.MediumTypeEnum Enumeration

Inventor.MemberEditScopeEnum Enumeration

Inventor.MemberManagerErrorsEnum Enumeration

Inventor.MemberTypeEnum Enumeration Introduced in Inventor 6

Inventor.MemorySavingModeEnum Enumeration

Inventor.MiniToolbarControlTypeEnum Enumeration Introduced in Inventor 2012

Inventor.ModelDiameterFromThreadEnum Enumeration Introduced in Inventor 5

Inventor.ModelValueTypeEnum Enumeration Introduced in Inventor 6

Inventor.MouseButtonEnum Enumeration Introduced in Inventor 5

Inventor.MouseDragStateEnum Enumeration Introduced in Inventor 5

Inventor.MoveFaceTypeEnum Enumeration

Inventor.MultiUserModeEnum Enumeration Introduced in Inventor 6

Inventor.NormalBindingEnum Enumeration Introduced in Inventor 5

Inventor.NumberingSchemeEnum Enumeration

Inventor.OccurrenceDOFStateEnum Enumeration

Inventor.OfflineImageFidelityEnum Enumeration Introduced in Inventor 8

Inventor.OLEDocumentTypeEnum Enumeration Introduced in Inventor 4

Inventor.OLEVerbEnum Enumeration Introduced in Inventor 4

Inventor.OrbitTypeEnum Enumeration

Inventor.OverConstrainedDimensionBehaviorEnum Enumeration Introduced in Inventor 9

Inventor.PageOrientationTypeEnum Enumeration Introduced in Inventor 4

Inventor.PaperSizeEnum Enumeration Introduced in Inventor 5

Inventor.ParameterDisplayFormatEnum Enumeration

Inventor.ParameterTypeEnum Enumeration Introduced in Inventor 4

Inventor.PartFeatureExtentDirectionEnum Enumeration Introduced in Inventor 5

Inventor.PartFeatureExtentEnum Enumeration Introduced in Inventor 5

Inventor.PartFeatureOperationEnum Enumeration Introduced in Inventor 5

Inventor.PartsListFileFormatEnum Enumeration Introduced in Inventor 9

Inventor.PartsListLevelEnum Enumeration Introduced in Inventor 9

Inventor.PatternComputeTypeEnum Enumeration Introduced in Inventor 9

Inventor.PatternOrientationEnum Enumeration Introduced in Inventor 6

Inventor.PatternSpacingTypeEnum Enumeration Introduced in Inventor 6

Inventor.PhysicalPropertyEnum Enumeration

Inventor.PointInferenceEnum Enumeration Introduced in Inventor 5

Inventor.PointIntentEnum Enumeration

Inventor.PointRenderStyleEnum Enumeration Introduced in Inventor 5

Inventor.PrefixAndSuffixOrderEnum Enumeration Introduced in Inventor 9

Inventor.PrintColorModeEnum Enumeration Introduced in Inventor 5

Inventor.PrintOrientationEnum Enumeration Introduced in Inventor 5

Inventor.PrintRangeEnum Enumeration Introduced in Inventor 5

Inventor.PrintScaleModeEnum Enumeration Introduced in Inventor 5

Inventor.PrivateEventTypeEnum Enumeration Introduced in Inventor 4

Inventor.ProductEditionEnum Enumeration

Inventor.ProjectionTypeEnum Enumeration

Inventor.PromptMessageRestrictionsEnum Enumeration

Inventor.PropertyTypeEnum Enumeration Introduced in Inventor 9

Inventor.PunchNoteQuantityEnum Enumeration

Inventor.PunchRepresentationTypeEnum Enumeration

Inventor.RayTracingQualityEnum Enumeration

Inventor.ReferenceMonitoringEnum Enumeration

Inventor.ReferenceStatusEnum Enumeration Introduced in Inventor 9

Inventor.RevisionTablePropertyEnum Enumeration

Inventor.RevisionTagShapeEnum Enumeration

Inventor.RibbonAppearanceEnum Enumeration

Inventor.RibbonDockingStateEnum Enumeration

Inventor.RibbonStateEnum Enumeration

Inventor.RibFeatureExtentEnum Enumeration

Inventor.RibThicknessPlaneEnum Enumeration

Inventor.RigidBodyJointTypeEnum Enumeration

Inventor.RipTypeEnum Enumeration

Inventor.RowMergeTypeEnum Enumeration

Inventor.SelectionDeviceEnum Enumeration Introduced in Inventor 5

Inventor.SelectionFilterEnum Enumeration Introduced in Inventor 5

Inventor.SelectionPriorityEnum Enumeration

Inventor.SelectPrism Structure

Inventor.SelectType Enumeration Introduced in Inventor 4

Inventor.ShadowDirectionEnum Enumeration

Inventor.SheetMetalPropertyEnum Enumeration

Inventor.ShellDirectionEnum Enumeration Introduced in Inventor 9

Inventor.ShiftStateEnum Enumeration Introduced in Inventor 5

Inventor.ShortcutTypeEnum Enumeration

Inventor.SketchCreationOnNewPartEnum Enumeration

Inventor.SolutionNatureEnum Enumeration Introduced in Inventor 4

Inventor.SplineFitMethodEnum Enumeration Introduced in Inventor 5

Inventor.SplitToolTypeEnum Enumeration Introduced in Inventor 6

Inventor.SplitTypeEnum Enumeration Introduced in Inventor 6

Inventor.StandardPartsSectionBehaviorEnum Enumeration

Inventor.StartupActionTypeEnum Enumeration

Inventor.StartupHelpFocusTopicEnum Enumeration

Inventor.StorageTypeEnum Enumeration Introduced in Inventor 4

Inventor.StyleLocationEnum Enumeration Introduced in Inventor 9

Inventor.StylesLibraryAccessEnum Enumeration

Inventor.StyleSourceTypeEnum Enumeration Introduced in Inventor 7

Inventor.StyleTypeEnum Enumeration

Inventor.SurfaceGeometryFormEnum Enumeration Introduced in Inventor 4

Inventor.SurfaceTextureTypeEnum Enumeration

Inventor.SurfaceTypeEnum Enumeration Introduced in Inventor 4

Inventor.SweepDefinitionTypeEnum Enumeration

Inventor.SweepProfileOrientationEnum Enumeration

Inventor.SweepProfileScalingEnum Enumeration

Inventor.SystemOfMeasureEnum Enumeration Introduced in Inventor 4

Inventor.TableDirectionEnum Enumeration Introduced in Inventor 9

Inventor.TableSourceTypeEnum Enumeration

Inventor.TextureDimensionEnum Enumeration

Inventor.TextLineSpacingTypeEnum Enumeration Introduced in Inventor 5.3

Inventor.ThreadTypeEnum Enumeration Introduced in Inventor 5

Inventor.ThumbnailSaveOptionEnum Enumeration

Inventor.TitleBlockAlignmentEnum Enumeration

Inventor.TitleBlockLocationEnum Enumeration Introduced in Inventor 5.3

Inventor.ToleranceTypeEnum Enumeration Introduced in Inventor 6

Inventor.TransactionPointEnum Enumeration Introduced in Inventor 4

Inventor.TransactionStateEnum Enumeration Introduced in Inventor 7

Inventor.TransparencyTypeEnum Enumeration

Inventor.TriadMoveTypeEnum Enumeration Introduced in Inventor 9

Inventor.TriadSegmentEnum Enumeration Introduced in Inventor 9

Inventor.UCSDefinitionTypeEnum Enumeration

Inventor.UnfoldMethodEquationTypeEnum Enumeration

Inventor.UnfoldMethodTypeEnum Enumeration Introduced in Inventor 5.3

Inventor.UniqueOccurrencesBehaviorEnum Enumeration Introduced in Inventor 2008

Inventor.UnitsTypeEnum Enumeration Introduced in Inventor 4

Inventor.UpdatePropertiesOnSaveForFileTypeEnum Enumeration

Inventor.ValueTypeEnum Enumeration Introduced in Inventor 5

Inventor.ValueUnitsTypeEnum Enumeration Introduced in Inventor 2012

Inventor.VBAProjectTypeEnum Enumeration Introduced in Inventor 6

Inventor.VerticalTextAlignmentEnum Enumeration Introduced in Inventor 5

Inventor.ViewBlockInsertionPointEnum Enumeration

Inventor.ViewJustificationEnum Enumeration

Inventor.ViewLayoutEnum Enumeration Introduced in Inventor 9

Inventor.ViewOperationTypeEnum Enumeration Introduced in Inventor 6

Inventor.ViewOrientationTypeEnum Enumeration Introduced in Inventor 4

Inventor.ViewPreviewTypeEnum Enumeration

Inventor.ViewTypeEnum Enumeration Introduced in Inventor 4

Inventor.WeldmentFeatureGroupEnum Enumeration Introduced in Inventor 6

Inventor.WeldmentStateEnum Enumeration

Inventor.WindowsSizeEnum Enumeration Introduced in Inventor 6

Inventor.WorkAxisDefinitionEnum Enumeration Introduced in Inventor 4

Inventor.WorkPlaneDefinitionEnum Enumeration Introduced in Inventor 4

Inventor.WorkPointDefinitionEnum Enumeration Introduced in Inventor 4

Inventor.ZoomTargetComponentWithiMateEnum Enumeration

InventorStudioLib Library

Studio Objects

Animation CoClass

IAnimation Interface

IAnimation Properties

IAnimation.Name Property

AnimationFavorites CoClass

IAnimationFavorites Interface

IAnimationFavorites Methods

IAnimationFavorites.Add Method

IAnimationFavorites.Item Method

IAnimationFavorites.Remove Method

IAnimationFavorites Properties

IAnimationFavorites.Count Property

AnimationManager CoClass

IAnimationManager Interface

IAnimationManager Properties

IAnimationManager.ActiveAnimation Property

IAnimationManager.AnimationFavorites Property

IAnimationManager.Animations Property

Animations CoClass

IAnimations Interface

IAnimations Methods

IAnimations.Add Method

IAnimations.Item Method

IAnimations Properties

IAnimations.Count Property

InventorStudio CoClass

IInventorStudio Interface

IInventorStudio Methods

IInventorStudio.Activate Method

IInventorStudio Properties

IInventorStudio.ActiveLightingStyle Property

IInventorStudio.ActiveSceneStyle Property

IInventorStudio.AnimationManager Property

IInventorStudio.RenderManager Property

IInventorStudio.StudioCameras Property

IInventorStudio.StudioLightingStyles Property

IInventorStudio.StudioSceneStyles Property

RenderManager CoClass

IRenderManager Interface

IRenderManager Methods

IRenderManager.RenderToFile Method

IRenderManager Properties

IRenderManager.AntiAliasing Property

IRenderManager.Camera Property

IRenderManager.ImageHeight Property

IRenderManager.ImageWidth Property

IRenderManager.TrueReflection Property

StudioCamera CoClass

IStudioCamera Interface

IStudioCamera Properties

IStudioCamera.Name Property

StudioCameras CoClass

IStudioCameras Interface

IStudioCameras Methods

IStudioCameras.Item Method

IStudioCameras Properties

IStudioCameras.Count Property

StudioLightingStyle CoClass

IStudioLightingStyle Interface

IStudioLightingStyle Properties

IStudioLightingStyle.Name Property

StudioLightingStyles CoClass

IStudioLightingStyles Interface

IStudioLightingStyles Methods

IStudioLightingStyles.Item Method

IStudioLightingStyles Properties

IStudioLightingStyles.Count Property

StudioSceneStyle CoClass

IStudioSceneStyle Interface

IStudioSceneStyle Properties

IStudioSceneStyle.Name Property

StudioSceneStyles CoClass

IStudioSceneStyles Interface

IStudioSceneStyles Methods

IStudioSceneStyles.Item Method

IStudioSceneStyles Properties

IStudioSceneStyles.Count Property

Overview Articles

Inventor::Application::DisplayOptions@[out, retval] DisplayOptions** Introduced in Inventor 11

Sample Code

64bit Topics

VBA to .Net Quick Reference

What's New

Disclaimer


Client Graphics - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Client Graphics

Introduction to Client Graphics

The Autodesk Inventor API provides the means to place certain graphic primitives on components or in drawing views. These primitives (points, lines, triangles, text) collectively referred to as ClientGraphics, will be maintained and transformed by Autodesk Inventor for the duration of the session only. ClientGraphics are transient in nature, unlike parts and assemblies. AutoCAD users will note a similar intent to the "grdraw" and "grvecs" AutoLISP functions, which draw display-only vectors in an AutoCAD viewport. However, ClientGraphics are not destroyed by a screen refresh.

An interesting feature of ClientGraphics is that they will be transformed along with everything else during view changes, zooms, pans, and so on. However, it is possible to specify that they be front facing. So that as the viewpoint changes, the graphics location appears to change too but its planar appearance does not - important for text to remain readable.

The purpose of Client Graphics

Client Graphics allow the developer to provide visual cues. Autodesk Inventor does this itself in many commands. When the user extrudes a sketch, a preview of the extruded part is displayed, proving a visual cue to how the part would appear (see InteractionGraphics, below). A developer can provide similar visual cues for their own application. A common example is a cutting application, where it is desirable to show the cutting path prior to executing the cut.

Autodesk Inventor recently introduced a new object - InteractionGraphics. This operates in a similar manner to regular ClientGraphics, except that it's in the context of InteractionEvents only. ClientGraphics via InteractionGraphics are much faster and so are well suited to real-time feedback during a command. InteractionGraphics are automatically removed once the associated InteractionEvents object stops.

Custom Graphics Object Model Diagram - Data Sets

Custom Graphics Object Model Diagram - Client Graphics

Working with Custom Graphics via the API

Creating Client Graphics can be considered a two stage process. There are two separate object models, indicated by the preceding diagrams. The first stage is to set up the data - most importantly, the list of coordinates your graphics will be based upon. The second stage is to set up the graphics primitives that will use that data.

This separation of data from graphics allows a single set of data to be referenced by many primitives. In addition, it allows Autodesk Inventor to easily transform graphics by transforming a single set of data only. All graphics referencing that data will be updated automatically. A way is needed then to map a subset of the point data to your required graphics primitives. This is done through the GraphicsIndexSet object. This contains an indexed list of indices to a data set, essentially creating a new list of coordinates to be passed to the graphics set.

Next page | Creating a Data Set
1, 2, 3, 4, 5

Disclaimer


Client Graphics - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Client Graphics

Creating a data set

As indicated by the object diagram, the GraphicsDataSetsCollection object is owned by the document. For the purposes of this code sample, the document may be either a part document or an assembly document. The first step is to add a new GraphicsDataSets object, here named 'CG_Test', to the GraphicsDataSetsCollection. From there you can create the GraphicsCoordinateSet object.

Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

Dim oDataSets As GraphicsDataSets
Set oDataSets = oDoc.GraphicsDataSetsCollection.Add("CG_Test")

Dim oCoordSet As GraphicsCoordinateSet
Set oCoordSet = oDataSets.CreateCoordinateSet(1)

This code and the code that follows does not perform error checking, for the sake of clarity and brevity. Your code should always check that return values are as expected, and that you are not attempting to create objects that already exist.

Now create a one dimensional array, and add your list of coordinates. Here they are added individually for clarity; in reality you would likely read them from file, generate them mathematically, or infer from other geometry. Once all the points have been added to the array, pass the array to the GraphicsCoordinateSet object.

Dim oPointCoords(1 To 9) As Double

oPointCoords(1) = 0   'X of point 1
oPointCoords(2) = 0   'Y of point 1
oPointCoords(3) = 0   'Z of point 1
oPointCoords(4) = 6   'X of point 2
oPointCoords(5) = 0   'Y of point 2
oPointCoords(6) = 0   'Z of point 2
oPointCoords(7) = 3   'X of point 3
oPointCoords(8) = 6   'Y of point 3
oPointCoords(9) = 0   'Z of point 3

Call oCoordSet.PutCoordinates(oPointCoords)

The preceding coordinate points will define three points, forming a triangle:

Now you have created the data set on which graphics primitives will be based. Next, set up the primitives.

Next page | Creating Graphics Primitives
1, 2, 3, 4, 5

Disclaimer


Client Graphics - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Client Graphics

Creating graphics primitives

As indicated by the object model diagram, ClientGraphics can be associated with a number of persistent objects in Autodesk Inventor (ComponentDefinition, DrawingView, and so on). This sample code uses a ComponentDefinition.

Dim oCompDef As ComponentDefinition
Set oCompDef = oDoc.ComponentDefinition

Dim oClientGraphics As ClientGraphics
Set oClientGraphics = oCompDef.ClientGraphicsCollection.Add("CG_Test")

The preceding code obtains the ComponentDefinition (in this case from the document object). Then a new ClientGraphics object is added, also named 'CG_Test', to its ClientGraphicsCollection.

Autodesk Inventor client graphics uses the concept of nodes. A node is a logical grouping of graphics, typically grouped for the purpose of selection or transformation.

The next step is to create a new node, and determine what primitives to add to it. A number of different graphics primitives are supported. Referring to the object model diagram, you can see that these include lines, strips of lines, triangles, strips of triangles, and so on. Grouping of primitives into strips allows for more efficient use of point data where line endpoints are coincident. However, for demonstration purposes, this example will create a triangle of three lines as LineGraphics, rather than creating a single TriangleGraphics object. The following code creates a new node and adds a LineGraphics object to it.

Dim oLineNode As GraphicsNode
Set oLineNode = oClientGraphics.AddNode(1)

Dim oLineSet As LineGraphics
Set oLineSet = oLineNode.AddLineGraphics

Now to define the relationship between the point data (the GraphicsCoordinateSet) and the points required as endpoints of lines. To do this, create a GraphicsIndexSet object and add the indices of each X Y Z point required.

Note: The points are added to the GraphicsIndexSet object as indices to the original data set, not as coordinates. In this example, the GraphicsCoordinateSet data set only contains three points, but to create a LineSet of three lines requires four points. To create a triangle, the last point is the same as the starting point.

To define a triangle, the GraphicsIndexSet must reference the first coordinate in the data set twice, so the GraphicsIndexSet will contain four points. The following code adds all four points to the GraphicsIndexSet, as indices to the coordinate points in the GraphicsCoordinateSet object.

Dim oIndex As GraphicsIndexSet
Set oIndex = oDataSets.CreateIndexSet(1)

Call oIndex.Add(1, 1)  ' Line from point 1
Call oIndex.Add(2, 2)  ' to point 2
Call oIndex.Add(3, 3)  ' to point 3

Call oIndex.Add(4, 1)  ' to point 1

When creating graphics, typically some control over color is required. The object model diagram refers to the GraphicsColorSet object. Use this to assign a color to a group of graphics primitives.

The GraphicsColorSet is an indexed list of color definitions. Add a color definition to the GraphicsColorSet object, and pass the object to the LineSet object in order to determine the color of the resulting graphics. The example below assigns the RGB values for the color red (255,0,0)

Dim oColorSet As GraphicsColorSet
Set oColorSet = oDataSets.CreateColorSet(1)
Call oColorSet.Add(1, 255, 0, 0)
oLineSet.ColorSet = oColorSet

Now all that remains is to apply the coordinates, or more specifically the GraphicsIndexSet indices, to the LineSet object, and then update the active view.

oLineSet.CoordinateSet = oCoordSet
oLineSet.CoordinateIndexSet = oIndex
ThisApplication.ActiveView.Update

This will result in something like the red triangle in the following figure. This triangle will be transformed along with any other parts or assemblies when the Autodesk Inventor rotate tool is invoked. To erase the graphics, call the delete method of the 'CG_Test' ClientGraphics object.

Next page | InteractionGraphics
1, 2, 3, 4, 5

Disclaimer


Client Graphics - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Client Graphics

Advanced uses for Client Graphics - InteractionGraphics

Autodesk Inventor recently introduced the InteractionGraphics object. This enables association of client graphics with user interaction. A typical use would be to provide some visual feedback during a custom command.

Interaction client graphics are set up in much the same way as previously, except now the GraphicsDataSets object is obtained from the InteractionGraphics object, which is obtained from the InteractionEvents object. As the client graphics are happening in the context of an InteractionEvents object, they are at liberty to take advantage of mouse movement information, selection information, and so on - any events supported by the InteractionEvents objects.

The developer is still responsible for creating and transforming the client graphics, but now can do this based on user input. InteractionGraphics are not transacted. This greatly improves performance, and leaves the developer free to commit an operation once the user responds to appropriate visual cues.

InteractionGraphics can be of type preview, which equate to regular ClientGraphics, or they can be of type overlay. Overlay InteractionGraphics can be rendered to a single view, and can be updated independently through use of the UpdateOverlayGraphics method.

The following sample code demonstrates client graphics transformed by mouse movement. Create a blank form in VBA, with no controls, and add this code to the form.

Private WithEvents oInteraction As InteractionEvents
Private WithEvents oMouseEvents As MouseEvents
Private oPointCoords(1 To 6) As Double
Private oCoordSet As GraphicsCoordinateSet
Private oLineNode As GraphicsNode
Private oLineSet As LineGraphics
Private oClientGraphics As ClientGraphics
Private oIG As InteractionGraphics
Private oDataSets As GraphicsDataSets

Sub UserForm_Initialize()
Set oInteraction = ThisApplication. _
    CommandManager.CreateInteractionEvents
oInteraction.SelectionActive = False
Set oMouseEvents = oInteraction.MouseEvents
oMouseEvents.MouseMoveEnabled = True
Set oIG = oInteraction.InteractionGraphics
Set oDataSets = oIG.GraphicsDataSets
Set oCoordSet = oDataSets.CreateCoordinateSet(1)
oPointCoords(1) = 0
oPointCoords(2) = 0
oPointCoords(3) = 0
oPointCoords(4) = 6
oPointCoords(5) = 0
oPointCoords(6) = 0
Call oCoordSet.PutCoordinates(oPointCoords)
Set oClientGraphics = oIG.OverlayClientGraphics
Set oLineNode = oClientGraphics.AddNode(1)
Set oLineSet = oLineNode.AddLineGraphics
oLineSet.CoordinateSet = oCoordSet
oIG.UpdateOverlayGraphics ThisApplication.ActiveView

oInteraction.Start

End Sub

Private Sub oMouseEvents_OnMouseMove(ByVal Button As MouseButtonEnum, _
   ByVal ShiftKeys As ShiftStateEnum, ByVal ModelPosition As Point, _
   ByVal ViewPosition As Point2d, ByVal view As view)
oPointCoords(4) = ModelPosition.X
oPointCoords(5) = ModelPosition.Y
oPointCoords(6) = ModelPosition.Z
Call oCoordSet.PutCoordinates(oPointCoords)
oIG.UpdateOverlayGraphics ThisApplication.ActiveView
End Sub

Private Sub UserForm_Terminate()
oInteraction.Stop
Set oMouseEvents = Nothing
Set oInteraction = Nothing
End Sub

Now add the following code to the Modules section of the project. Running this MouseIG macro will cause a custom graphics line to follow the mouse cursor in Autodesk Inventor. One end of the line will be at 0,0,0, the other end will be governed by the coordinates returned by the mouse movement event.

Public Sub MouseIG()
    frmMouseTest.Show vbModeless
End Sub

The above sample demonstrates the similarities between interaction graphics and regular client graphics. However, graphics implemented through interaction graphics are not transacted, and so are not subject to the performance overhead imposed by the transaction and undo mechanisms. Interaction graphics are designed for interactive, real-time visual feedback.

Next page | Summary
1, 2, 3, 4 5

Disclaimer


Client Graphics - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Client Graphics

Summary

Client graphics are not a substitute for sketches or drawings - they are intended for use as transient visual cues in the modeling environment. A limited set of graphics primitives are provided. Circles, arcs and so on are not supported and should be approximated with short line segment constructs. Efficiencies are provided in that many primitives can use subsets of a common pool of point data - hence the separation of data and graphic objects in the API. Graphics will appear to be transformed by standard Autodesk Inventor pan and zoom operations. Client graphics can be associated with input events, providing for immediate visual feedback of user interaction.

Also consider

When client graphics are based at least in part on an existing model, it is possible to obtain a coordinate data set from the existing surface body. Call the SurfaceBody.CalculateStrokes method to get the list of coordinate points. Determine the tolerance (the number of points you need) by first calling SurfaceBody.GetExistingStrokeTolerances. You may need to do this multiple times in order to assess the average tolerance for the model. Similarly, obtain facets by calling SurfaceBody.CalculateFacets.

Next page | Back to the Overviews
1, 2, 3, 4, 5


Custom Tables - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Custom Tables

Introduction to Custom Tables

Tables in Autodesk Inventor are typically associated with automated parts lists and bubble annotation. However, tables can also be considered general annotation, distinct from parts lists. Tables can be created with custom content. Also, custom tables can be assigned colors and specific line weights and text styles, and can be positioned anywhere on a drawing sheet.

Custom tables are designed so the developer can present and maintain tabulated data as annotation in a drawing document.

Custom Tables Object Model Diagram

Working with Custom Tables through the API

Custom tables are defined by specifying a number of rows and columns. Columns have header names which can optionally be part of the table. The following sample code adds a new table to the current sheet of an open drawing. The table will appear as follows.

Creating a Custom Table

The table is added to the active sheet, so first get this sheet from the active document. Note that this code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

Public Sub CreateTable()

    Dim oDrawDoc As DrawingDocument
    Set oDrawDoc = ThisApplication.ActiveDocument

    Dim oSheet As Sheet
    Set oSheet = oDrawDoc.ActiveSheet

Set up a string array to contain the column titles (headers). This table has two columns, so the array contains two strings.

    Dim oTitles(1 To 2) As String
    oTitles(1) = "Desk Number"
    oTitles(2) = "Employee"

Now add the content by setting up an array for the two rows and two columns ( 2 x 2 = 4, so the array contains four strings). The table cell order is left-to-right, top-to-bottom.

Note: An empty table can be constructed by not passing content to the CustomTables.Add method, but if an array is passed, it must contain string entries for all cells, otherwise an error occurs.

    Dim oContents(1 To 4) As String
    oContents(1) = "103"
    oContents(2) = "Peter Heald"
    oContents(3) = "107"
    oContents(4) = "Jamie Foss"

The column width can be left at its default, to fit the content, but here the width is set a little wider for a neater appearance.

    Dim oColumnWidths(1 To 2) As Double
    oColumnWidths(1) = 3
    oColumnWidths(2) = 3

For this example the table is placed in an arbitrary position, at x=15 y=15.

    Dim InsP As Point2d
    Set InsP = ThisApplication.TransientGeometry.CreatePoint2d(15, 15)

Add the table to the sheet through the CustomTables.Add method, specifying a two-row, two-column table named "Employees". Pass the values defined previously.

    Dim oCustomTable As CustomTable
    Set oCustomTable = oSheet.CustomTables.Add("Employees", InsP, 2, 2, oTitles, oContents, oColumnWidths)

At this point the table appears on the sheet. However, we can continue to make changes to its appearance. The following code changes the justification of the second column to center-justified.

    oCustomTable.Columns.Item(2).ValueHorizontalJustification = kAlignTextCenter

To make format changes, set up a TableFormat object that can then be applied to the table.

    Dim oFormat As TableFormat
    Set oFormat = oSheet.CustomTables.CreateTableFormat

Change some properties of the TableFormat object (for example, the color of the inside grid lines, and the line weight of the inside and outside grid lines).

    oFormat.InsideLineColor = ThisApplication.TransientObjects.CreateColor(0, 0, 255)
    oFormat.InsideLineWeight = 0.1
    oFormat.OutsideLineWeight = 0.2

Apply the new format to the table. The line weights and color are updated.

    oCustomTable.OverrideFormat = oFormat

The following code demonstrates the ability to access values of individual cells based on their row and column intersection. Note that the column can be specified by its name.

    Dim oCell As Cell
    Set oCell = oCustomTable.Rows.Item(2).Item("Employee")

    Debug.Print oCell.Value

End Sub

The cell value "Jamie Foss" prints to the VBA "immediate" debug screen, if enabled.

Summary

The Custom Tables API allows tabulated data to be added to drawing sheets, complete with column headers and table formatting. Table grid line colors and weights can be specified, and cell contents can be accessed and modified.

Also consider

Autodesk Inventor has the ability to link to other documents through OLE. Add links to other documents through the Add method of the Document.ReferencedOLEFileDescriptors collection object. This gives developers the ability to add (for example) a Microsoft Excel file link to a drawing document.

Standard drawing sheet constructs such as a border and title block can be added to a sheet through the AddBorder, AddDefaultBorder and AddTitleBlock methods of the Sheet object.

Next page | Back to the Overviews
Disclaimer


DataIO - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

DataIO

Introduction to DataIO

Autodesk Inventor users can save their work or import from files in a variety of formats. For example, a part file can be saved as a SAT file, a STEP file, and so on. Autodesk Inventor can open files such as DWG, DXF, IGES, STEP, and so on. The type of format available is dependent on the context.

The purpose of DataIO objects

To provide a similar level of functionality to the developer, many objects in the Autodesk Inventor API provide access to a DataIO object through a read-only DataIO property. The DataIO object provides methods to read from and write to files and data streams. In addition, the DataIO object provides methods to determine what formats and storage types are valid in that context. For example, a sketch can be saved as a DXF file, but cannot be imported from a bitmap.

The following is a list of Autodesk Inventor API objects that can return a DataIO object.

  • AssemblyComponentDefinition
  • AttributeSet
  • AttributeSets
  • ComponentDefinition
  • DrawingSketch
  • DrawingView
  • PartComponentDefinition
  • PlanarSketch
  • PlanarSketchProxy
  • SectionDrawingView
  • Sheet
  • SheetMetalComponentDefinition
  • Sketch
  • SurfaceBody
  • SurfaceBodyProxy
  • WeldmentComponentDefinition
  • WeldsComponentDefinition

Working with DataIO objects

As DataIO objects are available from such a variety of Autodesk Inventor API objects, so the context of the data to be read or written is variable. It is important to establish, in that context, whether data can be written or read, in what format, and whether to a file or data stream. Never just assume that a given format is valid.

The DataIO object supports two methods which determine available formats: GetInputFormats and GetOutputFormats. These methods each return a pair of arrays, identically dimensioned. The first array, Formats, contains the list of file formats in string form. For example, "XML" or "ACIS SAT." The second array contains StorageTypeEnum values. For example, kFileStorage indicates that storing as a file is supported.

Once the supported formats and storage types are known, the appropriate DataIO method can be used, with the format string passed to identify the required format. The output (write) methods are WriteDataToFile and WriteDataToStream. The input (read) methods are ReadDataFromFile and ReadDataFromStream. A file storage type is most typically used, but these methods also support streams. (For details on streams, see the Microsoft implementation of the IStream interface for structured storage).

Example Format and StorageType arrays

The following tables depict DataIO object format and storage type array values that might be returned for a component definition in a part document. It shows Input (read) formats and Storage Types, returned by GetInputFormats.

Format Array | StorageType Array
“ACIS SAT” | kFileStorage
“ACIS SAB” | kFileOrStreamStorage

The following example shows output (write) Formats and Storage Types, returned by GetOutputFormats, for the same object.

Format Array | StorageType Array
“ACIS SAT” | kFileStorage
“ACIS SAB” | kFileOrStreamStorage
“ACIS SAT with TransientKeys” | kFileStorage
“ACIS SAB with TransientKeys” | kFileOrStreamStorage

These example arrays indicate that "ACIS SAT" is supported for read and write, but file storage only, while "ACIS SAB with TransientKeys" is supported for write-only, but with file or stream storage.

How to use the API to determine available formats and storage types

This sample assumes an open part document containing a part, and looks at the supported DataIO formats for two objects: the ComponentDefinition and that object's AttributeSets object. A sequence of message boxes are posted containing the valid formats and storage types.

This code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

First, define a subroutine, and then obtain the active part document and its component definition object.

Sub query_dataIO()

Dim oDoc As PartDocument
Set oDoc = ThisApplication.ActiveDocument

Dim oCompDef As ComponentDefinition
Set oCompDef = oDoc.ComponentDefinition

Declare the variables for the Format and StorageType arrays, and then get the DataIO object from the component definition.

Dim sFormats() As String
Dim sStorageTypes() As StorageTypeEnum
Dim oDataIO As DataIO
Set oDataIO = oCompDef.DataIO

Get the supported input (read) formats and display the results in a message box. However, first compose the message string - done by the ioPrint function, defined after this sub.

oDataIO.GetInputFormats sFormats, sStorageTypes
MsgBox ("CompDef Input: " & ioPrint(sFormats, sStorageTypes))

Get the supported output (write) formats and display the results in a message box, but first compose the message string - done by the ioPrint function, defined after this sub.

oDataIO.GetOutputFormats sFormats, sStorageTypes
MsgBox ("CompDef Output: " & ioPrint(sFormats, sStorageTypes))

End Sub

That completes the query_dataIO subroutine. Now, define the ioPrint function. This is a utility function that takes the two arrays and pairs each format and storage type, returning a human-readable string. This function demonstrates that the format and storage type arrays always have identical dimensions. The nth item in the format array relates to the nth item in the storage type array.

Function ioPrint(sFormats As Variant, sStorageTypes As Variant) _
   As String
Dim msgString As String
Dim lindex As Long
For lindex = 0 To UBound(sFormats)
  msgString = msgString & sFormats(lindex)
  Dim lType As StorageTypeEnum
  lType = sStorageTypes(lindex)
  Dim sType As String
  Select Case lType
    Case kFileOrStreamStorage
      msgString = msgString & "(File or Stream) "
    Case kFileStorage
      msgString = msgString & "(File) "
    Case kStorageStorage
      msgString = msgString & "(Storage) "
    Case kStreamStorage
      msgString = msgString & "(Stream) "
    Case kUnknownStorage
      msgString = msgString & "(Unknown) "
  End Select
Next
ioPrint = msgString
End Function

Running the query_dataIO sub generates two message dialog boxes, containing something like the following examples.

CompDef Input: ACIS SAT (File) ACIS SAB (File or Stream)

CompDef Output: ACIS SAT (File) ACIS SAB (File or Stream)
ACIS SAT with TransientKeys (File) ACIS SAB with TransientKeys (File or Stream)

Using the format and storage type information

This component definition supports writing to a SAT file. So it is valid to call WriteDataToFile, using the string "ACIS SAT" as the format, supplying a file name for storage, as in the following example.

oDataIO.WriteDataToFile "ACIS SAT", "c:\MyNewSATfile.SAT"

Note: Some supported file formats such as XML can have tags meaningful only in the given context, so it can be very helpful to use WriteDataToFile to produce a sample file to see that file's structure.

In addition to using the DataIO object, files of many formats can be saved or opened through the Open or SaveAs methods of the Document object. The extension of the file name indicates to Autodesk Inventor which format is required.

Summary

The Autodesk Inventor API supports reading and writing files in a variety of formats, depending on the context (object type). Many objects in the API provide access to a DataIO object. This object provides methods to determine what formats and storage types (file or stream) are valid in that context. The DataIO object supports methods to read and write to and from such valid formats.

Also consider

Autodesk Inventor supports a type of Addin called a Translator Addin. This is much like a regular Addin, but is an Addin that reads and/or writes data in a specific, possibly proprietary, format. The Addin may do all the work or it may use an existing DataIO object. Such Addins are classed differently because they hook into Autodesk Inventor's File > Load and File > Save commands. For more information, refer to the TranslatorAddin object reference.

Next page | Back to the Overviews
Disclaimer


Document Properties - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Document Properties

Introduction

Autodesk Inventor has a set of properties associated with every document. The properties for a file can be viewed and set from inside Autodesk Inventor using the "File | Properties" command. The dialog displayed for this command is shown below. You can also access the properties using Windows Explorer by right-clicking on the file and selecting the "Properties" option. Autodesk Inventor's Design Assistant also provides access to document properties. You also have full access to the property information using the API.

Next page | Accessing Properties Using the API
1, 2, 3

Disclaimer


Document Properties - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Document Properties

Accessing Properties Using the API

Using the API, you have complete read and write access to the document properties using both Autodesk Inventor and Apprentice. In fact more functionality is exposed through the API than through the various property-related user interfaces. The diagram below shows the object hierarchy for properties.

Document Properties object model

From the hierarchy diagram you can see that properties are accessible from Autodesk Inventor and Apprentice. You can also see the structure in which the properties are stored. The various properties are grouped within "property sets." From the Document object (or the ApprenticeServerDocument object when using Apprentice) you can obtain the PropertySets collection object. The PropertySets collection object provides access to all of the property sets in a document. The PropertySet object represents each property set and each property set provides access to the properties it owns.

The sample below illustrates obtaining the PropertySets collection object using Apprentice.

' Declare the Apprentice object
Dim oApprentice As New ApprenticeServerComponent

' Open a document using Apprentice
Dim oApprenticeDoc As ApprenticeServerDocument
Set oApprenticeDoc = oApprentice.Open("C:\Test\part.ipt")

' Obtain the PropertySets collection
Dim oPropsets As PropertySets
Set oPropsets = oApprenticeDoc.PropertySets

The sample below illustrates obtaining the PropertySets collection object using Autodesk Inventor.

' Declare the Application object
Dim oApplication As Inventor.Application

' Obtain the Inventor Application object.
' This assumes Inventor is already running.
Set oApplication = GetObject(, "Inventor.Application")

' Set a reference to the active document.
' This assumes a document is open.
Dim oDoc As Document
Set oDoc = oApplication.ActiveDocument

' Obtain the PropertySets collection object
Dim oPropsets As PropertySets
Set oPropsets = oDoc.PropertySets

The PropertySets collection object supports methods to iterate through and access all the PropertySets in the collection. Each property set has two identifiers: the display name and the internal name. The display name is a string that helps to identify the type of information stored by the properties within the property set. Usually the display names are unique but this is not guaranteed. The internal name is another identifier of a property set and is guaranteed to be unique. The internal name is actually a GUID converted to a string. The following code can be added to either of the samples above to show the display name and internal name of every property set in a document.

' Iterate through all the PropertySets one by one using for loop
Dim oPropSet As PropertySet
For Each oPropSet in oPropsets
    ' Obtain the DisplayName of the PropertySet
    Debug.Print "Display name: " & oPropSet.DisplayName

    ' Obtain the InternalName of the PropertySet
    Debug.Print "Internal name: " & oPropSet.InternalName

    ' Write a blank line to separate each pair.
    Debug.Print
Next

When a new Autodesk Inventor document is created, Inventor adds a standard set of property sets. The following are the display names, internal names, and brief description of all of the pre-defined property sets. Prior to Autodesk Inventor 6 some of the Autodesk Inventor properties used standard property sets as defined by Microsoft. Starting with Autodesk Inventor 6 all property sets used are now exclusive to Autodesk Inventor. This change was made to solve problems that occurred when moving files from one language to another. The current set of property sets and their internal names are shown below.

Summary Information, {F29F85E0-4FF9-1068-AB91-08002B27B3D9}
Document Summary Information, {D5CDD502-2E9C-101B-9397-08002B2CF9AE}
Design Tracking Properties, {32853F0F-3444-11D1-9E93-0060B03C1CA6}
User Defined Properties, {D5CDD505-2E9C-101B-9397-08002B2CF9AE}

The properties sample delivered in the SDK demonstrates the reading and writing the properties and also serves as a tool to view the properties of a document. The sample is available in the "SDK\Samples\VB\Properties" directory.

If you want to access a particular property set and know either its display name or internal name you can access it directly using the Item property of the PropertySets object. The alternative is to iterate through the collection looking for a particular property set. You can use the display name or internal name but because the display name is not guaranteed to be unique the internal name will be more reliable. Also if your application will be used in other countries, you should use the internal name because it will always remain the same and will not be affected by localization changes made. The sample below illustrates obtaining a specific property set using the display name.

' Get a reference to the "Design Tracking Properties" PropertySet
Dim oPropSet As PropertySet
Set oPropSet = oPropsets.Item("Design Tracking Properties")

Using the internal name to obtain a specific property set is done in the same way, but first you need to know what the internal name is. The internal names for the Autodesk Inventor-created property sets are listed above. You can also find the internal names using the Object Browser. If you select the enumerator for the property set you're interested in, the internal name is displayed as part of the description at the bottom of the browser as shown below.

The sample below shows how to access a property set using the internal name.

' Get a reference to the "Design Tracking Properties" PropertySet
Dim oPropSet As PropertySet
Set oPropSet = oPropsets.Item("{32853F0F-3444-11d1-9E93-0060B03C1CA6}")

Once you have obtained a property set you have access to the properties it contains. A property is basically just a name and a value. Each property is identified by a Property ID (a Long). The ID value is guaranteed to be unique among all properties within a specific property set. The value of a property is a Variant so it can contain almost any type of value: Integer, Double, String, Dates, and arrays of these types. The thumbnail property also returns an IPictureDisp object that can be used by standard picture controls.

Just as the PropertySets object is a collection of different PropertySet objects, the PropertySet object in turn is a collection of different Property objects and similar to the PropertySets collection object, the PropertySet object supports methods to iterate through and access all the properties in a particular set. It also provides direct access to a particular property if its name or property ID is known. The following code segment shows how to access all the properties in a PropertySet.

Dim oPropSet As PropertySet
For Each oPropSet In oPropSets
    ' Iterate through all the Properties in the current set.
    Dim oProp As Property
    For Each oProp in oPropset
        ' Obtain the Name of the Property
    Dim Name As String
    Name = oProp.Name

    ' Obtain the Value of the Property
    Dim Value As Variant
    Value = oProp.Value

        ' Obtain the PropertyId of the Property
    Dim PropertyId As Long
    PropertyId = oProp.PropId
    Next
Next

Properties can also be accessed directly if their names (called property IDs) are known. All of the Autodesk Inventor-native and Microsoft-defined properties have their property IDs specified in the corresponding enum. As shown in the previous diagram of the object browser, each property has a corresponding enum value. This is its PropertyID. The sample below directly accesses a specific property using the internal name of the property set and the unique ID of the property.

' Access the value of the "Cost" Property of
' "Design Tracking Properties" PropertySet
Dim Value As Variant
Value = oPropsets.Item("{32853F0F-3444-11d1-9E93-0060B03C1CA6}").ItemByPropId(kCostDesignTrackingProperties).Value

Next page | Creating, Changing and Deleting Properties
1, 2, 3

Disclaimer


Document Properties - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Document Properties

Creating, Changing and Deleting Properties

Creating new PropertySets and Properties

Autodesk Inventor allows users to create their own properties, which are added to the "Custom Properties" collection. These properties are added to the "User Defined Properties" PropertySet. The API also supports the creation and edit of custom properties. In addition it also supports the creation of totally new PropertySets and Properties.

The steps involved in creating a new collection of properties are:
  1. Add a new PropertySet object to the PropertySets collection. The PropertySets collection object supports the Add method, which allows for the addition of a new PropertySet to the collection.
  2. Add new properties to the newly created PropertySet object. The PropertySet object supports the Add method, which allows for addition of new properties to the PropertySet.

'declare new PropertySet object to be added
Dim oNewPropertySet As PropertySet

On Error Resume Next
' Try to obtain the PropertySet to see if it already exists
Set oNewPropertySet = oPropsets.Item("New PropertySet")

' If PropertySet does not exist then add the new PropertySet
If Err Then
        ' Add the new PropertySet
        Set oNewPropertySet = oPropsets.Add("New PropertySet")

    ' Adding the new Property to the new PropertySet
        Call oNewPropertySet.Add("A Value", "New Property", 2)
End If

Display names and internal names for property sets must be unique with respect to all other property sets in the document. In the sample above, no internal name is specified, which causes Autodesk Inventor to create one. When creating properties, the name, display name, and ID must be unique with respect to other properties in that property set. The ID must be greater than 1, (the ID of 1 is reserved by Microsoft) and less than 255.

The above sample demonstrates how to create a new property set and add a property to that set. Autodesk Inventor permits adding properties to new property sets and the "Custom" property sets. Adding properties to the standard property sets is blocked.

Changing the Names and Values of Properties

The Autodesk Inventor API allows you to change both the names and values of properties that have been created by third parties, but only the value of pre-defined properties can be changed. For example, the PropertySet object's DisplayName property can be changed for user-created PropertySet objects but not for pre-defined PropertySets. The InternalName property cannot be reset for any of the PropertySet objects. For the Property object, the Name and Value can be changed for properties created by third parties but not for pre-defined properties. There are pre-defined properties that are always read-only (e.g. Creation Date). You can tell if a property is read-only or not by referring to the helpstring associated with the corresponding enum for the property. The PropID is read-only and cannot be changed for any of the properties.

The name of a property can be changed by using the Name property of the Property object. The value of a property can be changed using the Value property of the Property object. However, for pre-defined properties you need to be careful to use the correct type when setting the value. For example, let's consider changing the value of the "Date Checked" property (of the "Design Tracking Properties" PropertySet). This needs to be set using a Variant of Date type, otherwise Autodesk Inventor functions that read this value may not work correctly. The sample below illustrates setting this property to a specific date.

' Get a reference to the "Date Checked" property.
Dim oProp As Property
Set oProp = oPropSets.Item("{32853F0F-3444-11d1-9E93-0060B03C1CA6}").ItemByPropId(kDateCheckedDesignTrackingProperties)

' Define a Date variable with the desired date.
Dim NewDate As Date
NewDate = "Jan 1, 2000"

' Assign the date to the property.
oProp.Value = NewDate

The following code could cause problems in Autodesk Inventor because a String rather than a Date type of variable is assigned to the property.

' Get a reference to the "Date Checked" property.
Dim oProp As Property
Set oProp = oPropSets.Item("{32853F0F-3444-11d1-9E93-0060B03C1CA6}").ItemByPropId(kDateCheckedDesignTrackingProperties)

' Assign the date to the property.
oProp.Value = "Jan 1, 2000"

Deleting Properties Created by Third Parties

The PropertySet and Property objects both support Delete methods, which can be used to delete PropertySets and Properties respectively. Deleting PropertySets and Properties is not supported for pre-defined property sets and properties. Calling the Delete method for pre-defined properties will result in an error.

The following example shows how to delete all the properties in the "New PropertySet" that we created earlier by first deleting all the properties in the collection and then deleting the PropertySet itself. (It's not required to delete the contents of the PropertySet before deleting the PropertySet.)

' Declare the PropertySet object
Dim oPropSet As PropertySet

' Try to obtain the PropertySet object by using its name
Set oPropSet = oPropsets.Item("New PropertySet")

' Iterate through all the Properties and delete them
Dim oProp As Property
For Each oProp In oPropSet
    ' Delete the Property object
    oProp.Delete
Next

' Delete the PropertySet
oPropSet.Delete

Saving Changes to Properties

When working with Inventor, any changes made to properties are saved when the document is saved by the user. When using Apprentice you can save any property changes by saving the entire document or you can use the FlushToFile method of the PropertySets object. Using the FlushtoFile is much more efficient than saving the entire document. FlushToFile is not supported by Autodesk Inventor.

Next page | Back to the Overviews
1, 2, 3

Disclaimer


Drawing Dimensions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Drawing Dimensions

Introduction to Drawing Dimensions

Autodesk Inventor has two different types of dimensions - model and drawing. These can be thought of as controlling and documenting, respectively. Model dimensions are typically parametric constraints intended to control part or feature size. Sketch dimensions are included in this category since they directly affect model size and constraints.

Drawing dimensions simply document a given dimension on a drawing sheet, and have no effect on model size or constraints. However, drawing dimensions can be promoted from a draft view to an underlying sketch, or can be retrieved from a sketch or model.

Drawing dimensions are associative, but not parametric. There are various types of drawing dimensions supported, including general, linear, ordinate, radius, diameter, and angular. Options controlling the appearance of dimensions are specified through dimension styles, enabling support of common dimension standards. Individual settings may be overridden to suite.

A look at the Drawing Dimensions API

The Drawing Dimensions API provides access to all drawing dimensions on a sheet. Objects corresponding to the available dimension types are derived from a common object named DrawingDimension which contains common methods and properties, such as tolerance, precision, text and so on.

Ordinate dimensions differ from other types in that a given sequence of dimension values will reference the same single point of origin. Figure 1 shows the object model diagram.

Figure 1

Geometry Intent

Drawing dimension creation methods expect geometry points to be supplied in the form of GeometryIntent objects. To better understand such objects, imagine a leader line and arrow pointing to a user-selected point on a drawing line. Leader line associativity to the selected spot on the drawing line needs to be maintained, but there is no point geometry midway on the drawing line to reference. In this case, a GeometryIntent object encapsulates the intent to reference a location on the drawing line, a certain distance from a particular end.

Similarly, dimensions require GeometryIntent objects because, unlike the Autodesk Inventor modeling environment, the drawing environment contains only 2D lines, arcs and circles - no points. So, a GeometryIntent object for a dimension might reference a particular end of a line or arc, or the center of a circle or arc.

Sample

This sample VBA code listing may be cut and pasted into a module in the Autodesk Inventor VBA editor. Make sure all grayed sections are present. Immediately before each grayed section is text describing that section's purpose and operation - do not copy this text into the editor. The code omits error checking for the sake of clarity and brevity. In your code, always check that return values are of the expected type. Ensure that the Autodesk Inventor Object Library is available in your project; in the Visual Basic Editor, pick Tools > References, and check the appropriate reference.

Creating a Linear Dimension

This code creates a simple linear dimension of a curve on a drawing sheet. It assumes the curve is selected before the code is run. Figure 2 shows two lines selected in the sample Vertical Plate.idw.

Figure 2

Select the highlighted lines, then run the VBA code. The code first obtains the active sheet from the active document.

Sub CreateDimension()

    Dim oDoc As DrawingDocument
    Set oDoc = ThisApplication.ActiveDocument

    Dim oSheet As Sheet
    Set oSheet = oDoc.ActiveSheet

Next, obtain DrawingCurve objects from the selected lines. DrawingCurve objects are acceptable for creation of GeometryIntent objects.

    Dim oCurve1 As DrawingCurve
    Set oCurve1 = oDoc.SelectSet(1).Parent

    Dim oCurve2 As DrawingCurve
    Set oCurve2 = oDoc.SelectSet(2).Parent

Now we're ready to create the GeometryIntent objects. Since we're using the DrawingCurve end points, there is no need to specify a point on the geometry, which would be provided by the optional second argument for CreateGeometryIntent.

    Dim oIntent1 As GeometryIntent
    Set oIntent1 = oSheet.CreateGeometryIntent(oCurve1)

    Dim oIntent2 As GeometryIntent
    Set oIntent2 = oSheet.CreateGeometryIntent(oCurve2)

Create a 2D point for the location of the dimension line.

    Dim oPt As Point2d
    Set oPt = ThisApplication.TransientGeometry.CreatePoint2d(15, 15)

Create a linear dimension on the sheet, using the two GeometryIntent objects as dimension extension line origin points, and the 2D point for the dimension line location.

    Dim oLinDim As LinearGeneralDimension
    Set oLinDim = oSheet.DrawingDimensions.GeneralDimensions.AddLinear(oPt, oIntent1, oIntent2)

End Sub

The sample code will produce a result similar to that shown in Figure 3.

Figure 3

Next page | Back to the Overviews
Disclaimer


Drawing Views - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Drawing Views

Introduction to drawing views

The Autodesk Inventor user interface allows placement of drawing views on a drawing sheet. These views are 2D representations of the 3D model, and can be orthographic, isometric, or they can have an arbitrary view angle. They can be scaled views to show fine detail, or they can be section views. The API provides the same functionality through the collection of DrawingView objects.

The purpose of the drawing views API

The drawing view API enables code to create, place and manipulate drawing views, including base views, on drawing sheets. View types supported include projected, section, and draft views. Additionally, the API supports the OnViewUpdate event, provided through the DrawingViewEvents object, allowing application code to be notified if an associated draft view is updated due to a change to the model.

Drawing views object model diagram

Working with drawing views through the API

The DrawingViews collection is obtained from the Sheet object. The Sheets collection is obtained from the DrawingDocument object, or if Apprentice Server is being used, from the ApprenticeServerDrawingDocument. The latter hierarchy provides read-only access to the drawing views.

The various types of drawing views are represented by the DrawingView object, with the exception of section views, which are of type SectionDrawingView. Section, draft, and associated draft views can only be created on the active sheet.

The DrawingView and SectionDrawingView objects provide a number of transformation methods designed to translate points between drawing view, model, and sheet spaces. These methods include DrawingViewToModelSpace, DrawingViewToSheetSpace, ModelToDrawingViewSpace, ModelToSheetSpace, SheetToModelSpace, and SheetToDrawingViewSpace.

Creating a drawing view

The following code assumes a drawing document is open in Autodesk Inventor, and that the source part file (part.ipt) is located in the root of the C: drive. This file reference can be changed to suit. Here is the part used for this example.

This sample and the following code omit error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

The first step is to obtain the sheet object, in order to place a view. The location of the view is provided by a 2D point. The following code uses transient geometry to define a 2D point at X=5, Y=5.

Dim oDrawingDoc As DrawingDocument
Set oDrawingDoc = ThisApplication.ActiveDocument

Dim oSheet As Sheet
Set oSheet = oDrawingDoc.Sheets.Item(1)

Dim oPoint1 As Point2d
Set oPoint1 = ThisApplication.TransientGeometry.CreatePoint2d(5#, 5#)

This sample places a regular drawing view of a model part. The following code uses an arbitrary hard-coded part file reference that should be changed as appropriate.

Note: The False argument to the document Open method indicates the part file is to be opened invisibly. In this context, there is no need to see the part in Autodesk Inventor. It is simply the source for the drawing view. Close the part file afterwards.

The new hidden line DrawingView object is added to the DrawingViews collection using a bottom view of the opened part file, at point 5,5, at a scale of 1:1. Immediately afterwards, the part file is closed. It is good practice to keep file references open no longer that necessary.

Dim oPartDoc As PartDocument
Set oPartDoc = ThisApplication.Documents.Open("c:\testpart.ipt", False)

Dim oView1 As DrawingView
Set oView1 = oSheet.DrawingViews.AddBaseView(oPartDoc, _
    oPoint1, 1#, kBottomViewOrientation, kHiddenLineDrawingViewStyle)

Call oPartDoc.Close(True)

The following is an example of how this appears on the sheet.

Creating a section drawing view

The previous example placed a drawing view of a part. The following code places a new section drawing view through the previously placed view. Section views require that a section line be defined. This is the line through which the part is to be cut. However, unlike section lines created through the user interface, section lines created through the API are not constrained to the model, and therefore do not automatically update to reflect changes to the model.

The first task is to indicate the section line, either using existing geometry, or by creating a sketch containing a sketch line, as in the following code.

Dim oPoint2 As Point2d
Set oPoint2 = ThisApplication.TransientGeometry.CreatePoint2d(15#, 40#)

Dim oDrawingSketch As DrawingSketch
Set oDrawingSketch = oSheet.Sketches.Add

oDrawingSketch.Edit
Dim oSketchLine As SketchLine
Set oSketchLine = oDrawingSketch.SketchLines.AddByTwoPoints(oPoint1, _
    oPoint2)
oDrawingSketch.ExitEdit

For simplicity, this code reuses the view placement points to define the ends of the sketch line. In reality, this sketch line would be placed at a specific point relative to the base view. Now to add the section view by calling AddSectionView.

Dim oView2 As SectionDrawingView
Set oView2 = oSheet.DrawingViews.AddSectionView(oView1, _
     oDrawingSketch, oPoint2, kHiddenLineRemovedDrawingViewStyle)

oDrawingSketch.Visible = False

Note the absence of a part file reference in the preceding code. Unlike base view creation, the previously created view is passed as an argument, together with the sketch line indicating the cut line. The two views now look something like the following illustration.

The arrows and notation in the preceding figures were generated automatically.

Summary

The drawing view API functionality is equivalent to much of the drawing view functionality available through the user interface. It allows for the placement of different types of views on a drawing sheet. These views may be blank draft views, projected views, or section views. The API also provides a means of notification if the underlying model is subject to change.

Also consider

Other drawing view API functionality includes the ability to edit drawing dimensions on a sheet through the DrawingDimension object. Sheet title blocks and templates can be edited through the use of drawing text (the TextBox object and associated styles) and drawing sketches.

Next page | Back to the Overviews
Disclaimer


Environments - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Environments

Introduction to Environments

To the Autodesk Inventor user, an environment, such as the assembly environment or the sketch environment, simply means that tools are made available to accomplish the task at hand. Menus and panel bars appropriate to the workflow are presented to the user. For example, the sketch environment provides commands to create sketch lines, circles and so on, but not commands for placing or copying components - actions specific to the assembly environment. When the user switches to the assembl y environment, the reverse becomes true.

The purpose of Environments

If all Autodesk Inventor commands were present and available on the menus and panel bar all the time, the user interface would be very cluttered and confusing. Environments provide a means to present a focused subset of commands. Taking this a step further, a client application may define custom environments in addition to Autodesk Inventor's set of built-in environments. The application may define the environment as transient, or it may be persistent across sessions. Additionally, a given environment may have a number of edit-targets, any of which may have focus. For example, an application may define an FEA environment. The results of FEA computation models may result in a number of different solution results, each represented by a node on the browser.

Environments Object Model Diagram

Working with Environments through the API

In previous versions of Autodesk Inventor, the use of environments was closely tied to the concept of document subtypes. Use of subtypes was limited to Addins, but since Autodesk Inventor 10, the environments API provides an enhanced capability that is available through VBA too. The environment API is now the preferred mechanism over the subtype API.

Creating an environment

Every document has a built-in base environment. A client application may create a new custom environment by adding to the Environments collection, and typically will copy some components used in another environment, such as command bars, to the new one. Command bars can inherit their properties from the parent environment if the InheritAll property of the CommandBarList is set to true.

The samples that follow show how to add new environments to Autodesk Inventor. The figure below shows the initial view of the Applications menu and the panel bar, with no additional environments or edit targets added. The example code will add three new environments. Lastly, it will create an edit target within one of these environments.

The first step is to get the Environments collection from the UserInterfaceManager. From this, obtain a built-in environment to use as the basis for the new environment. This sample and the following code omit error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

Sub AddParallelEnv1()

    Dim oEnvs As Environments
    Set oEnvs = ThisApplication.UserInterfaceManager.Environments

    Dim oEnv As Environment
    Set oEnv = oEnvs("DLxDrawingEnvironment")

Next, add a new environment to the environments collection. Here, we use a display name of "FEA" - this is the name that will be displayed in the Applications menu. The string "FEA Env's internal name" is this the internal name for the new environment - its equivalent to the internal names of built-in environments, such as "DLxDrawingEnvironment". (A ClientId is not supplied so this environment is not persisted.)

    Dim oNewEnv As Environment
    Set oNewEnv = Nothing
    Set oNewEnv = oEnvs.Add("FEA", "FEA Env's internal name")

This example will use the same default command bar as the source environment, and will populate the new environment's panel bar with some command bars. It will also copy the command bars from the context menu.

    oNewEnv.PanelBar.DefaultCommandBar = oEnv.PanelBar.DefaultCommandBar
    Dim oPanel As CommandBar
    For Each oPanel In oEnv.PanelBar.CommandBarList
        oNewEnv.PanelBar.CommandBarList.Add oPanel
    Next

    Dim oCmdBar As CommandBar
    For Each oCmdBar In oEnv.ContextMenuList
        oNewEnv.ContextMenuList.Add oCmdBar
    Next

In this case the new environment will inherit all the command bars from the parent environment.

    oNewEnv.PanelBar.CommandBarList.InheritAll = True
    oNewEnv.ContextMenuList.InheritAll = True

All that remains is to add the new environment to the list of parallel environments (thus adding the environment to the list of available environments, as indicated by the Applications menu shown in the figure below.

    Dim oParEnvs As EnvironmentList
    Set oParEnvs = ThisApplication.UserInterfaceManager.ParallelEnvironments
    Call oParEnvs.Add(oNewEnv)
End Sub

Next, add another two environments named "Rendering" and "Aerofoil", based on the assembly and weldment environments respectively. This code is much the same as that in the previous section.

Sub AddParallelEnv2()

    Dim oEnvs As Environments
    Set oEnvs = ThisApplication.UserInterfaceManager.Environments

    Dim oEnv As Environment
    Set oEnv = oEnvs("AMxAssemblyEnvironment")

    Dim oNewEnv As Environment
    Set oNewEnv = Nothing

    Set oNewEnv = oEnvs.Add("Rendering", "Rendering Env's internal name")

    oNewEnv.PanelBar.DefaultCommandBar = oEnv.PanelBar.DefaultCommandBar
    Dim oPanel As CommandBar
    For Each oPanel In oEnv.PanelBar.CommandBarList
        oNewEnv.PanelBar.CommandBarList.Add oPanel
    Next

    Dim oCmdBar As CommandBar
    For Each oCmdBar In oEnv.ContextMenuList
        oNewEnv.ContextMenuList.Add oCmdBar
    Next

    oNewEnv.PanelBar.CommandBarList.InheritAll = True
    oNewEnv.ContextMenuList.InheritAll = True

    Dim oParEnvs As EnvironmentList
    Set oParEnvs = ThisApplication.UserInterfaceManager.ParallelEnvironments

    Call oParEnvs.Add(oNewEnv)

End Sub

Sub AddParallelEnv3()

    Dim oEnvs As Environments
    Set oEnvs = ThisApplication.UserInterfaceManager.Environments

    Dim oEnv As Environment
    Set oEnv = oEnvs("AMxWeldmentEnvironment")

    Dim oNewEnv As Environment
    Set oNewEnv = Nothing

    Set oNewEnv = oEnvs.Add("Aerofoil", "Aerofoil Env's internal name")

    oNewEnv.PanelBar.DefaultCommandBar = oEnv.PanelBar.DefaultCommandBar
    Dim oPanel As CommandBar
    For Each oPanel In oEnv.PanelBar.CommandBarList
        oNewEnv.PanelBar.CommandBarList.Add oPanel
    Next

    Dim oCmdBar As CommandBar
    For Each oCmdBar In oEnv.ContextMenuList
        oNewEnv.ContextMenuList.Add oCmdBar
    Next

    oNewEnv.PanelBar.CommandBarList.InheritAll = True
    oNewEnv.ContextMenuList.InheritAll = True

    Dim oParEnvs As EnvironmentList
    Set oParEnvs = ThisApplication.UserInterfaceManager.ParallelEnvironments

    Call oParEnvs.Add(oNewEnv)

End Sub

The preceding code will add the new FEA, Rendering and Aerofoil environments to Autodesk Inventor's Applications menu, as shown below. Each environment has its own set of command bars, but so far none has a specific edit target defined.

Now to add an edit target to one of these new environments. This indicates a specific editing requirement. An example in Autodesk Inventor is the sketch editing facility within the Part environment. The code is much the same as previously except now the SetCurrentEnvironment method of the EnvironmentManager object is used - this sets the environment for this document but it is not persisted.

Sub ActivateET()

    Dim oEnvs As Environments
    Set oEnvs = ThisApplication.UserInterfaceManager.Environments

    Dim oEnv As Environment
    Set oEnv = oEnvs("MBxSheetMetalEnvironment")

    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oNewEnv As Environment
    Set oNewEnv = Nothing

    Set oNewEnv = oEnvs.Add("Aerofoil-ET", "ET Env's internal name")

    oNewEnv.PanelBar.DefaultCommandBar = oEnv.PanelBar.DefaultCommandBar
    Dim oPanel As CommandBar
    For Each oPanel In oEnv.PanelBar.CommandBarList
        oNewEnv.PanelBar.CommandBarList.Add oPanel
    Next

    Dim oCmdBar As CommandBar
    For Each oCmdBar In oEnv.ContextMenuList
        oNewEnv.ContextMenuList.Add oCmdBar
    Next

    oNewEnv.PanelBar.CommandBarList.InheritAll = True
    oNewEnv.ContextMenuList.InheritAll = True

    Call oPartDoc.EnvironmentManager.SetCurrentEnvironment(oNewEnv, "ET's Cookie")

End Sub

The result of this code is indicated in the following figure. Note that the Applications menu now has the new Aerofoil-ET edit target checked instead of the Part edit target. Note too the change to the panel bar.

Although the previous edit target is not persisted in the sense that it will not be active when the document is next loaded, you can return to this edit target by calling the SetCurrentEnvironment method again.

Sub ActivateETAgain()

    Dim oEnvs As Environments
    Set oEnvs = ThisApplication.UserInterfaceManager.Environments

    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oNewEnv As Environment
    Set oNewEnv = Nothing

    Set oNewEnv = oEnvs("ET Env's internal name")

    Call oPartDoc.EnvironmentManager.SetCurrentEnvironment(oNewEnv, "ET's Cookie")

End Sub

However, an edit target can be made persistent by setting the OverrideEnvironment property of the EnvironmentManager object. Thus, when a document is loaded, the specified edit target will be present.

Sub TestOverrideEnv()

    Dim oEnvs As Environments
    Set oEnvs = ThisApplication.UserInterfaceManager.Environments

    Dim oEnv As Environment
    Set oEnv = oEnvs("DXxPresentationEnvironment")

    Dim oPartDoc As PartDocument
    Set oPartDoc = ThisApplication.ActiveDocument

    Dim oNewEnv As Environment
    Set oNewEnv = oEnvs.Add("OverrideTmp", "OverrideTmp Env's internal name")

    oNewEnv.DefaultMenuBar = oEnv.DefaultMenuBar
    oNewEnv.DefaultToolBar = oEnv.DefaultToolBar

    Dim oPanel As CommandBar
    For Each oPanel In oEnv.PanelBar.CommandBarList
        oNewEnv.PanelBar.CommandBarList.Add oPanel
    Next

    Dim oEnvMgr As EnvironmentManager
    Set oEnvMgr = oPartDoc.EnvironmentManager

    oEnvMgr.OverrideEnvironment = oNewEnv

End Sub

The preceding code will result in the following edit target setting in the Applications menu when the document is initially loaded.

Summary

The combination of custom environments, and the ability to define transient or overridden edit targets within those environments, allows client applications to define a user interface specific to their purpose, with full control over what is presented to the user. They can behave in the same manner as built-in Autodesk Inventor environments, with environments and edit targets pushed onto the environment stack, and with Autodesk Inventor's Return button traversing back through the stack as expected.

Also consider

For additional control over what buttons are enabled in specific scenarios, use the DisabledCommandList object. This is available both at the document and environment level, and is complementary to the Enabled property of the ControlDefinition object. Commands placed in the DisabledCommandList object at the environment level will be grayed-out within that environment.

Next page | Back to the Overviews
Disclaimer


Event Context Information - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Event Context Information

Introduction to Event Context Information

The Autodesk Inventor API supports notification of many events. These events range across the entire API. Examples include notification of:

  • When a file is opened or closed.
  • When a browser node is activated or renamed.
  • When the mouse position is updated or keyboard input is received.
  • When a view or assembly is changed.
  • When objects are selected.

Currently there are more than 80 types of events fired, accessible from the API.

Events are the means through which your application is made aware of and reacts to actions outside its control. Events are also the basis for user interaction. If you want to trace mouse movement or know when a key has been pressed, your application must set up a handler for these specific events.

The Purpose of Event Context Information

The majority of events are straightforward - they simply provide notification that something has occurred. However, there are some situations when a little more information is required or some contextual information is helpful.

Consider when a file is dirtied, for example. The terms "dirtied" and "smudged" refer to the edit state of the document, somewhat analagous to paper drawings that have been manually revised. If changes have occured that would cause Autodesk Inventor to ask if you wish to save the file before exiting, that file is considered dirtied until saved. But some actions - a rebuild or the addition of client graphics, for example - do not affect the shape of the model, but can still be considered a change, or a "smudging" of the document. It can be useful to know such contextual information when an event occurs.

Interpreting Event Context Information

Few events provide context information. The following arguments and their content will be meaningless except for those specific events that do provide some context. For a detailed list of events that do provide contextual data, see the Event Details overview.

Those that do provide context information populate most or all of the following arguments.

  • BeforeOrAfter - Input EventTimingEnum indicating if the event notification is being fired before (kBefore) or after (kAfter) the event occurs.
  • ReasonsForChange - Input bit-encoded field indicating why the event occurred.
  • Context - Input NameValueMap object that contains additional information about the event. Think of this object as a list of names mapped to values (for example the name FileName might be paired with a qualified file reference).

Sometimes, if the notification occurs just before the event actually takes place, you have an opportunity to veto the event or specify some alternate action specific to that event. In such cases, the following argument will be present.

  • HandlingCode – When the event notification is fired before the event, you can often specify an alternate action using this parameter.

The reference guide identifies which events provide additional context information. Another way to determine this is to use the "locals" or "watch" window in VB to view the contents of the object in question (the NameValueMap object, for example).

Next page | Example
1, 2, 3

Disclaimer


Event Context Information - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Event Context Information

An example of Event Context Information

The following VB code sets up an event handler for the OnFileDirty event. Create a new .exe project in VB (not VBA), create a blank form, and then paste this code into the form's code module. This sample omits error checking for the sake of clarity and brevity. This code runs outside of Autodesk Inventor but expects to connect to it, and so assumes Autodesk Inventor is already running.

First, declare the FileAccessEvents object (which supports the OnFileDirty event) and the Autodesk Inventor Application object. These are global declarations and so are outside of a Sub.

Dim WithEvents eFA As inventor.FileAccessEvents
Dim oApp As inventor.Application

The following Sub is executed when the form is loaded (when the application is first run). It gets the Application object, and then the FileAccessEvents object is obtained from it.

Private Sub Form_Load()
Set oApp = GetObject(, "Inventor.Application")
Set eFA = oApp.FileAccessEvents
End Sub

The following Sub defines the handler for the OnFileDirty event of the FileAccessEvents object. This code is called if the OnFileDirty event is fired. Note the various arguments, including BeforeOrAfter, Context, and HandlingCode.

Private Sub eFA_OnFileDirty(ByVal RelativeFileName As String, _
   ByVal LibraryName As String, CustomLogicalName() As Byte, _
   ByVal FullFileName As String, _
   ByVal DocumentObject As inventor.Document, _
   ByVal BeforeOrAfter As inventor.EventTimingEnum, _
   ByVal Context As inventor.NameValueMap, _
   HandlingCode As inventor.HandlingCodeEnum)

Print the filename of the file that became dirtied.

Debug.Print "  Event: OnFileDirty", RelativeFileName

Loop through the items in the NameValueMap, printing their name and value.

Dim I As Long
For I = 1 To Context.Count
   Debug.Print "Context: ", Context.Name(I), _
      Context.Value(Context.Name(I))
Next I

Print the meaning of the BeforeOrAfter enum.

Select Case (BeforeOrAfter)
    Case kAfter
        Debug.Print " Timing: After"
    Case kBefore
        Debug.Print " Timing: After"
    Case Else
        Debug.Print " Timing: Aborted"
End Select

This handler is not going to take any specific action (this is not an event we would attempt to veto) so let Autodesk Inventor know by setting HandlingCode to the appropriate HandlingCodeEnum.

HandlingCode = kEventNotHandled
End Sub

An example of an event that does make use of the HandlingCode argument is the OnFileResolution event. This is fired when Autodesk Inventor cannot find a referenced file, but before it displays an error. Developer code can handle this event and identify the required file, so the error is prevented from being displayed.

Running the sample code

In Autodesk Inventor, open a part document. In VB, run the code. (If asked, specify the form as the starting module).

Now the OnFileDirty event handler is set up and ready to handle this one event. In Autodesk Inventor, modify the part in some way (for example, change the extent of an extrusion). The event is fired and the code prints some information to the VB "Immediate" window. If you don't have this window visible, enable it from the View > Immediate Window menu.

The information printed will be something like the following.

  Event: OnFileDirty   test.ipt
Context: ReasonsForChange 1
 Timing: After

In this case, the OnFileDirty event was called when test.ipt was dirtied (i.e. modified). The context NameValueMap object contained just one item, the ReasonsForChange flag (discussed in the next section). The BeforeOrAfter EventTimingEnum indicates the notification occurred after the event took place.

The ReasonsForChange flag

The preceding section indicates that the context NameValueMap may contain a ReasonsForChange flag. This is a bit coded flag, whose value is comprised of any applicable CommandTypesEnum values. In this case the value is 1, or kShapeEditCmdType, indicating the change occurred as a result of a command that affected the design intent - the shape of the model.

As another example - if the ReasonsForChange flag value was 65, this would mean that both kShapeEditCmdType (value 1) and kReferencesChangeCmdType (value 64) apply.

Next page | Special Considerations
1, 2, 3

Disclaimer


Event Context Information - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Event Context Information

Special considerations

Since Autodesk Inventor 9, an application that is listening to both the OnFileDirty event and OnChange event should take into account Autodesk Inventor's new "smudged" state.

OnFileDirty is fired only when the document is dirtied (including as a result of adaptivity). It is not fired when the document is only smudged.

OnChange (and the corresponding application event) is fired when a document is changed. If the change would dirty the document, the event's context has a NameValueMap pair of ConsideredDirty = 1.

Note: There are some exceptions. The OnChange event will not be fired due to an update of a drawing or presentation document, or due to audit or migration during the opening of documents. In such cases only OnFileDirty is fired, and cannot be vetoed.

Since Autodesk Inventor 9, a PDM system Add-in should listen to the OnFileDirty event (FileAccessEvent) to check out a file due to a document change. The Add-in should use the context to determine whether the event can be vetoed.

To keep its file reference information up to date, the PDM Add-in should listen to the OnDocumentChange event. Upon receiving the event, the Add-in should examine the ReasonsForChange argument for the kReferencesChangeCmdType bit.

Summary

The Autodesk Inventor API support notification of many events. Some of these events provide additional information, such as the timing of the event notification - whether it was fired before or after the event took place (the EventTimingEnum). A small number of events provide further information to qualify the context in which the event took place, through the NameValueMap object. Some events support the HandlingCode argument, which allows developer code to specify alternate actions other than the default.

Next page | Back to the Overviews
1, 2, 3

Disclaimer


Event Detail Information - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Event Detail Information

As described in the Event Context overview, some events return data giving some context to the event fired, usually in the form of a NameValueMap. Also, some are fired before or after the event occurs, while some events can be vetoed. This overview lists supported events by funtional type, giving event context details where appropriate.

Index of Event Types

ApplicationEvents | FileAccessEvents | SketchEvents | ChangeDefinition
AssemblyEvents | FileManagerEvents | StyleEvents | ChangeProcessor
BrowserPane | FileUIEvents | TransactionEvents | ComboBoxDefinition
BrowserPanesEvents | ModelingEvents | UserInputEvents | SelectEvents
DocumentEvents | PanelBar | UserInterfaceEvents | InteractionEvents
DrawingEvents | PartEvents | TriadEvents | KeyboardEvents
DrawingViewEvents | RepresentationEvents | ButtonDefinition | MouseEvents

ApplicationEvents

OnActivateDocument( DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActiveDocument event notifies a client when a document is activated. The definition of an active document is the top-level document that is being displayed in the active window. The title of a window also indicates the active document for that window.

It's also important to understand that the document currently being edited is not necessarily the active document. This happens in the case of in-place editing in the context of an assembly. When you open an assembly document, the assembly is the active document. If you in-place edit a part within the assembly, the assembly is still the active document. The part being edited is the active edit object. The ApplicationEvents.OnNewEditObject event provides notification when the active edit object changes and the Application.ActiveEditObject property returns the current active edit object.

  • DocumentObject: The Document object that is being activated.
  • BeforeOrAfter: Notification is sent before and after the document is activated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnActivateView( ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActivateView event notifies a client when a view is activated. An API View object is equivalent to an Inventor window. When the end-user clicks on a window to work in it, it becomes the active window. The OnActivateView event is fired at this time.

  • ViewObject: The View object that has been activated.
  • BeforeOrAfter: This notification is currently only provided after the view has been activated. To protect yourself against possible future changes to this event you should write your code so that you only respond to kAfter, as shown below.
Private Sub ApplicationEvents_OnActivateView(...)
    If BeforeOrAfter = kAfter Then
        ' Your code in reaction to the notification.
    End If
End Sub
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnActiveProjectChanged( ProjectObject As DesignProject, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActiveProjectChanged event notifies a client when a change has been made to the active project. The notification is sent for two different actions that are related to projects; a new project is activated and the active project is saved.

This event provides the DesignProject object as a representative of the project. At this time, the DesignProject object is limited in the functionality it provides. In cases where you need more information about the project you may want to use the FileLocations object.

  • ProjectObject: The DesignProject object that has been activated.
  • BeforeOrAfter: Notification is sent before and after the active project is changed.
  • Context: This event provides additional information through the Context argument as described below:
    • Name = "FileName", Value = Full filename of the ipj file that is being activated.
    • Name = "Reason", Value = The reason the notification was made. Can be one of the following values: "ProjectActivated" or "ProjectSaved"
  • HandlingCode: This argument is ignored for this event.
OnCloseDocument( DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnCloseDocument event notifies a client whenever a document is closed.

  • DocumentObject: The Document object that is being closed. The document being closed is provided for both the kBefore and kAfter cases. This is because the Document is still available after it's closed, although in a limited sense, until it is terminated. One of the useful things you can do with a document in this state is to compare it's identity with a reference previously saved (usually during kBefore). For example:
Private m_oClosingDoc As Object

Private Sub oAppEvents_OnClose(ByVal DocumentObject As Document, ..., ByVal BeforeOrAfter As EventTimingEnum, ...)
    If BeforeOrAfter = kBefore Then
        ' Check to see if the Document being closed is an
     ' interesting one.
        If Interesting(DocumentObject) Then
            ' Save a reference to the object.
            Set m_oClosingDoc = DocumentObject
        End If
    Else
        ' Now we're either after the close or it's been aborted.
        ' Check to see if the document is the interesting one.
        If DocumentObject Is m_oClosingDoc Then
            If BeforeOrAfter = kAfter then
                ' The document was closed.
            ElseIf BeforeOrAfter = kAbort Then
                ' The close was aborted.
            End If
    End If
End Sub
  • FullDocumentName: The full document name of the document being closed.
  • BeforeOrAfter: Notification is sent before and after the document is closed. In the case where this event is canceled the value of this argument will be kAbort.
  • Context: This event provides additional information through the Context argument as described below:
    • Name = "HealthStatusEnum", Value = The health status of the document. If this value is anything other than kUpToDateHealth you know the Document object returned is not in a state where you can use most of its methods or properties.
  • HandlingCode: This event supports the ability to cancel the close. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the close. When the close is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.
OnCloseView( ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnCloseView event notifies a client when a view is closed. An API view is equivalent to an Inventor graphics window.

  • ViewObject: The View object that is about to be closed.
  • BeforeOrAfter: This notification is currently only provided before the view has been closed. To protect yourself against possible future changes to this event you should write your code so that you only respond to kBefore, as shown below.
Private Sub ApplicationEvents_OnCloseView(...)
    If BeforeOrAfter = kBefore Then
        ' Your code in reaction to the notification.
    End If
End Sub
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnDeactivateDocument( DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDeactivateDocument event notifies a client when a document is deactivated.

  • DocumentObject: The Document object that is being deactivated.
  • BeforeOrAfter: Notification is sent before and after the document is deactivated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnDeactivateView( ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • ViewObject
  • BeforeOrAfter: Only fires before
  • Context: Not used
  • HandlingCode: Not used

This event is not being fired.

OnDisplayModeChange( ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDisplayModeChange event notifies a client when the display mode of a view has changed. The display mode defines whether the view is displayed as wireframe, shaded with hidden edges, or shaded with no hidden edges shown. The current display mode of the view can be determined by using the DisplayMode property of the View object returned by the ViewObject argument.

  • ViewObject: The View object whose display mode is being changed.
  • BeforeOrAfter: Notification is sent before and after the display mode is changed.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnDocumentChange( DocumentObject As Document, BeforeOrAfter As EventTimingEnum, ReasonsForChange As CommandTypesEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDocumentChange event notifies a client when an action occurs that causes any change to a document. The context information can be used to determine what the change is. The notification is not sent for commands that do not change the document, i.e. measure and view commands. Care needs to be taken when using this event because the notification is made so frequently that depending on what you do in response to the event it can degrade the performance of Inventor. You should perform simple checks to see if the change is one that you're interested in before you perform more expensive operations. Whenever possible you should use more specific events instead of this general change event. For example, if you're interested in knowing when a parameter value changes you can listen to the ModelingEvents.OnParameterChange event instead. This is both simpler for you and more efficient but not all actions that can occur within Inventor have corresponding events so in many cases using the OnDocumentChange event is the only solution.

  • DocumentObject: The Document object the change is occurring within.
  • BeforeOrAfter: This argument specifies if the notification is being sent before a change is made (kBefore), after a change is made (kAfter), or when a change has been aborted (kAbort).
  • ReasonsForChange:???
  • Context: This event provides additional information through the Context argument as described below:
    • Name = "DisplayName", Value = The display name of the command that caused the change. This name will change based on the language currently being used for Inventor.
    • Name = "InternalName", Value = The internal name of the command that caused the change. This name will be consistent regardless of the current language.
    • Name = "InternalNamesList", Value = When the internal name is "CompositeChange" this value is returned. Some commands result in making several changes but combine these into a single command. The individual changes that were made by this single command are provided through this value. It is an array of strings that consist of the internal names of the individual changes made. For example, in a sketch if you drag a point that connects two lines, the display name is "Drag Sketch Inference", the internal name is "CompositeChange" and the internal names list is an array of the following three strings; "Modify Point", "Modify Line", and "Modify Line".
    • Name = "ConsideredDirty", Value = "". If this name appears in the context list then the change made is one that causes the document to be dirty.
  • HandlingCode: This event supports the ability to cancel the change. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the change. When the change is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.

Can still place assembly constraints even when they are cancelled.

OnInitializeDocument( DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • FullDocumentName
  • BeforeOrAfter
  • Context: Not used
  • HandlingCode: Not used
OnMigrateDocument( DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnMigrateDocument event notifies a client when a document is being fully migrated created. Migration is the process of updating the data contained within a document created in an older version of Inventor to the data format of the current version. With delayed migration, documents created in Inventor version 11 and newer are not fully migrated until a modified document is saved or the end-user executes the Migrate command.

This event is intended to be used by applications that are storing application specific data within the Inventor document and may also need to migrate their data from one version to another. Thy can use this event as one trigger to migrate.

  • DocumentObject: The document object that is being migrated.
  • BeforeOrAfter: Notification is sent before and after the document is migrated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewDocument( DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewDocument event notifies a client when a new document is created.

  • DocumentObject: The document object that was just created. When the BeforeOrAfter argument is kBefore this argument will be Nothing because the document does not yet exist.
  • BeforeOrAfter: Notification is sent before and after the document is created.
  • Context: This event provides additional information through the Context argument as described below:
    • Name = "TemplateFilename", Value = The full filename of the file used as the template when creating the new document.
    • Name = "NewFileName", Value = The full filename of the new file. In most cases this value will be an empty string because the filename of a new document is not specified until it is saved for the first time. The exception to this is when the Create Component command is used in an Assembly to create a new part. In this case the filename is specified as part of the command.
  • HandlingCode: This argument is ignored for this event.
OnNewEditObject( EditObject As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewEditObject event notifies a client when the edit object is changing. The edit object is the container object that is being edited by the end-user. For example when an assembly document is opened, the assembly document is the active document and the edit object. If the end-user in-place activates a part in the assembly, the part becomes the edit object. Although the assembly is still the active document because the edit is taking place in the context of the assembly. If the end-user creates or edits a sketch in the part, the sketch becomes the active edit object. Valid objects for edit objects are documents, 2d and 3d sketches, and drawing sheets.

  • EditObject: The new edit object. When the BeforeOrAfter argument is kBefore this is the object that will become the edit object. When the argument is kAfter this is the current edit object.
  • BeforeOrAfter: Notification is sent before and after the edit object change is made.
  • Context: When an object is activated for edit within the context of an assembly some additional information is provided through the Context argument, as described below:
    • Name = "ActiveDocument", Value = The AssemblyDocument object that the edit is edit is within the context of.
    • Name = "ActiveEditObject", Value = The ComponentOccurrence object in the assembly the edit is through.
  • HandlingCode: This argument is ignored for this event.

When a new sketch is created in a drawing, the event isn't fired.

OnNewView( ViewObject As View, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewView event notifies a client when a new View object is created. An API view is equivalent to an Inventor graphics window.

  • ViewObject: The View object that was created. When the BeforeOrAfter argument is kBefore this argument will be Nothing because the view does not yet exist.
  • BeforeOrAfter: Notification is sent before and after the view is created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnOpenDocument( DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnOpenDocument event notifies a client when a document is opened. Documents are opened directly by the end-user using the Open command, but they are also opened indirectly as a result of being referenced by another document. For example, if an assembly is opened all of the documents referenced by the assembly are also opened. This notification is sent in all cases. The Context argument provides information that can help determine the context of the open.

  • DocumentObject: The Document object being opened. When the BeforeOrAfter argument is kBefore, this argument will be nothing because the document does not yet exist.
  • FullDocumentName: The full filename of the document. This is provided when the BeforeOrAfter argument is kBefore and kAfter.
  • BeforeOrAfter: Notification is sent before and after the document is opened.
  • Context: Additional information is provided through this argument to help in understanding why the document is being opened.
    • Name = "TopLevelFilename", Value = The full filename of the top-level file that was opened that's causing this file to be opened. For example, if an assembly is opened and a document referenced by that assembly is opened as a result, the TopLevelFilename will be the full filename of the assembly. This value can be the same as the FullDocumentName argument which indicates this document was opened by itself.
  • HandlingCode: This argument is ignored for this event.
OnQuit( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnQuit event notifies a client when Inventor is being shut down.

  • BeforeOrAfter: This notification is only provided before Inventor has shut down so the value of this argument will always be kBefore.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnReady( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnReady event notifies a client when Inventor has completely initialized and is ready for interactive use. This event is intended to be used by Add-Ins. When an Add-In is activated by inventor, Inventor itself is still initializing at that point so there are a few limitations to what an Add-In can do or the information it has access to. An example is an Add-In that needs to access another Add-In or see what other Add-Ins have been loaded. When the Add-In is activated, Inventor is in the process of activating each Add-In and it's likely not all of the Add-Ins have been activated yet. By listening to the OnReady event the Add-In can then perform its tasks related to the other Add-Ins.

  • BeforeOrAfter: This notification is only provided after Inventor has initialized so the value of this argument will always be kAfter.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnSaveDocument( DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnSaveDocument notifies a client whenever a document is saved. The notification is made when the standard Save and the Save Copy As commands are invoked. When assemblies are saved this can also cause the dependent documents to be saved and this event is also fired in those cases.

  • DocumentObject: The Document object being saved.
  • BeforeOrAfter: Specifies if the notification is being sent before the document is saved (kBefore), after a change is made (kAfter), or when a change has been aborted (kAbort).
  • Context: Additional information is provided through this argument to help in understanding the context of the save. Either SaveCopyAsFilename or SaveFileName is provided depending on whether the end-user executed the Save or Save Copy As command. The TopLevelSaveFileName is always provided but in some cases will have an empty string as the value.
    • Name = SaveCopyAsFilename, Value = The full filename of the new document being created.
    • Name = SaveFileName, Value = The full filename of the document being saved.
    • Name = TopLevelSaveFileName, Value = When the notification is made for a save copy as operation this value will be the full filename of the original document that is being saved. When the notification is made for a standard save this value will be ????
  • HandlingCode: This event supports the ability to cancel the save. By setting this argument to kEventCanceled when the BeforeOrAfter argument is kBefore Inventor will abort the save. When the change is cancelled, this event is fired again but the BeforeOrAfter argument will have a value of kAbort.
OnTerminateDocument( DocumentObject As Document, FullDocumentName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject: Null on after
  • FullDocumentName
  • BeforeOrAfter
  • Context: Not used.
  • HandlingCode: Not used
OnTranslateDocument( TranslatingIn As Boolean, DocumentObject As Document, FullFileName As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnTranslateDocument event notifies a client whenever a file is translated into Inventor.

  • TranslatingIn: This argument is currently always True since this notification is only supported when translating files into Inventor.
  • DocumentObject: The Document object that is created as a result of the translation. When the BeforOrAfter argument is kBefore the value of this argument will be Nothing because the document has not been created yet.
  • FullFileName: The full filename of the document being translated.
  • BeforeOrAfter: Notification is sent before and after the document is translated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.

AssemblyEvents

OnAssemblyChange( DocumentObject As AssemblyDocument, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum )

The OnAssemblyChange event notification is not currently sent. The other assembly specific events and the OnDocumentChange can be used to track assembly changes.

  • DocumentObject:
  • Context:
  • BeforeOrAfter:
  • HandlingCode:
OnDelete( DocumentObject As Document, Entity As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDelete event notifies a client when an occurrence is deleted from an assembly.

  • DocumentObject: The assembly document where the change occurred.
  • Entity: Then Entity that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the object provided is the object before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved (usually during kBefore). For example:
Private m_oDeletedEntity As Object

Private Sub oAssemblyEvents_OnDelete(ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...)
    If BeforeOrAfter = kBefore Then
        ' Check to see if the Entity being deleted is an interesting
     ' one.  For example, it could have an attribute attached to it.
        If Interesting(Entity) Then
            ' Save a reference to the object.
            Set m_oDeletedEntity = Entity
        End If
    Else
        ' Now we're either after the delete or it's been aborted.
        ' Check to see if the object is the interesting one.
        If Entity Is m_oDeletedEntity Then
            If BeforeOrAfter = kAfter then
                ' The object was deleted.
            ElseIf BeforeOrAfter = kAbort Then
                ' The delete was aborted.
            End If
    End If
End Sub
  • BeforeOrAfter: Notification is sent before and after the entity is deleted.
  • Context:
  • HandlingCode: This argument is ignored for this event.
OnNewConstraint( DocumentObject As AssemblyDocument, Constraint As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • Constraint
  • BeforeOrAfter: ?
  • Context: Document change context?
  • HandlingCode: This argument is ignored for this event.
OnNewOccurrence( DocumentObject As AssemblyDocument, Occurrence As ComponentOccurrence, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • Occurrence
  • BeforeOrAfter: ?
  • Context: Document change context?
  • HandlingCode: This argument is ignored for this event.
OnOccurrenceChange( DocumentObject As AssemblyDocument, Occurrence As ComponentOccurrence, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnOccurrnceChange event notifies a client whenever a change occurs to an occurrence. The changes reported by this event are if any of the following states of an occurrence change: grounded, adaptive, visible, enabled, suppressed, and repositioned (transformed). The type of change and information related to the change is passed through the context argument.

  • DocumentObject: The assembly document where the change occurred.
  • Occurrence: The ComponentOccurrence object that is changing.
  • Context: Information describing the change is passed through the context argument, as described below:
    • Name = "Grounded", Value = True or False. Indicates the grounded state is changing. The value indicates the new grounded state of the occurrence.
    • Name = "Adaptive", Value = True or False. Indicates the adaptive state is changing. The value indicates the new adaptive state of the occurrence.
    • Name = "Visible", Value = True or False. Indicates the visibility state is changing. The value indicates the new visibility state of the occurrence.
    • Name = "Enabled", Value = True or False. Indicates the enabled state is changing. The value indicates the new enabled state of the occurrence.
    • Name = "Suppressed", Value = True or False. Indicates the suppressed state is changing. The value indicates the new suppressed state of the occurrence.
    • Name = "Transformation", Value = Matrix object. Indicates the occurrence is being transformed. The Matrix object provided specifies the new transformation of the occurrence. If the original transformation is needed, you can obtain it using the Transformation property of the ComponentOccurrence object provided by the Occurrence argument of this event when the timing is kBefore
  • BeforeOrAfter: Notification is sent before and after the change occurs. When the BeforeOrAfter argument is kBefore you can query the occurrence to determine any values of its current state. Comparing these values with those obtained when BeforeOrAfter is kAfter provides a definitive method of determining exactly what has changed and how it changed.
  • HandlingCode: This argument is ignored for this event.

BrowserPane

OnActivate()

The OnActivate event notifies a client when the BrowserPane has become the active pane. Typically, this is as a result of the end-user switching from one browser pane to another. This event is useful when a client has created a custom pane. By listening for this notification the client can know if the pane is in a state where the end-user can see and interact with it.

OnDeactivate()

The OnDeactivate event notifies a client when a BrowserPane is deactivated. A deactivate notification is made when a browser pane is the active pane and the end-user activates another pane. This event is useful when a client has created a custom pane. By listening for this notification the client can know if the pane is in a state where the end-user can see and interact with it.

OnHelp( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnHelp event notifies a client when the end-user clicks the help button on the browser pane. By setting the HandlingCode argument, the client can choose to handle displaying help themselves or let Inventor handling displaying some help information.

  • BeforeOrAfter: This notification is only provided before any help is displayed so the value of this argument will always be kBefore.
  • Context: No context information is provided for this event.
  • HandlingCode: Setting the value of the HandlingCode argument specifies how Inventor is to handle displaying help. If you set this argument to kEventNotHandled or kEventCanceled, Inventor will display some general browser help. Setting the value of this argument to kEventHandled will allow you to handle displaying help to the end-user and Inventor will not display anything. To display help to the end-user you can choose to use whatever help system you want. Inventor's API does provide support for the actual display of the clients help.

BrowserPanesEvents

OnBrowserNodeActivate( BrowserNodeDefinition As Object, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • BrowserNodeDefinition
  • Context: Browser Node
  • HandlingCode
OnBrowserNodeDeleteEntry( BrowserNodeDefinition As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • BrowserNodeDefinition
  • BeforeOrAfter
  • Context: ?
  • HandlingCode: ?
OnBrowserNodeGetDisplayObjects( BrowserNodeDefinition As Object, Objects As ObjectCollection, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • BrowserNodeDefinition
  • Objects
  • Context: Browser Node
  • HandlingCode: ?
OnBrowserNodeLabelEdit( BrowserNodeDefinition As Object, NewLabel As String, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • BrowserNodeDefinition
  • NewLabel
  • BeforeOrAfter: Fires Before & After
  • Context: Not used.
  • HandlingCode: Supports Cancel

DocumentEvents

OnActivate( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActivate event notifies a client when the document is activated. When a document is activated it is the top-level document currently available for edit in the user-interface. In-place activating a document within the context of an assembly does not cause it to be the active document. In this case it is the active edit object, but not the active document. The top-level assembly that the edit is taking place within remains the active document.

  • BeforeOrAfter: Notification is sent before and after the document is activated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnChange( ReasonsForChange As CommandTypesEnum, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

Same as OnDocumentChange

OnChangeSelectSet( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnChangeSelectSet event notifies a client when the contents of the select set have changed. This notification is sent when items are added or removed from the select set and when the select set is cleared. The current contents of the select set can be obtained through the document's SelectSet object.

You can get double notifications of this event when an object is already selected and the end-user selects another object. In this case the first notification is because the current object(s) in the select set are being removed and the second notification is for the new entity being added.

  • BeforeOrAfter: This notification is only provided after the contents of the select set have changed so the value of this argument will always be kAfter.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnClose( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The Onclose event notifies a client when the document is closed.

  • BeforeOrAfter: Notification is sent before and after the document is closed.
  • Context: Additional information is provided through this argument to help in understanding the context of the save.
    • HealthStatusEnum = SaveFileName, Value = The full filename of the document being saved.
  • HandlingCode: This argument is ignored for this event.
OnDeactivate( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDeactivate event notifies a client when the document is being deactivated.

  • BeforeOrAfter: Notification is sent before only before the document is deactivated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnDelete( Entity As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDelete event notifies a client when an entity is deleted. This notification is sent for each entity that is deleted. If the end-user selects multiple objects and then presses the delete key, an OnDelete notification is sent for each entity that's deleted.

  • Entity: Then Entity that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the object provided is the object before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example:
Private m_oDeletedEntity As Object

Private Sub oDocEvents_OnDelete(ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...)
    If BeforeOrAfter = kBefore Then
        ' Check to see if the Entity being deleted is an interesting one.
        ' For example, it could have an attribute attached to it.
        If Interesting(Entity) Then
            ' Save a reference to the object.
            Set m_oDeletedEntity = Entity
        End If
    Else
        ' Now we're either after the delete or it's been aborted.
        ' Check to see if the object is the interesting one.
        If Entity is m_oDeletedEntity Then
            If BeforeOrAfter = kAfter then
                ' The object was deleted.
            ElseIf BeforeOrAfter = kAbort Then
                ' The delete was aborted.
            End If
    End If
End Sub
  • BeforeOrAfter: Notification is sent before and after the entity is deleted. It's also through this argument that you're notified if the delete operation was aborted.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event
OnSave( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnSave event notifies a client whenever the document is saved. The notification is made when the standard Save and the Save Copy As commands are invoked.

  • BeforeOrAfter: Specifies if the notification is being sent before the document is saved (kBefore) or after the save (kAfter).
  • Context: Additional information is provided through this argument to help in understanding the context of the save.
    • Name = SaveFileName, Value = The full filename of the document being saved.
  • HandlingCode: This argument is ignored for this event.

DrawingEvents

OnRetrieveDimensions( SketchDimensions As ObjectsEnumerator, DrawingDimensions As GeneralDimensionsEnumerator, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnRetrieveDimensions event notifies a client whenever dimensions are retrieved into a drawing using the Retrieve Dimensions command.

  • SketchDimensions: A collection containing the original dimensions that were retrieved into the drawing. These will be various dimension constraints that were created in the part or drawing sketch.

In some cases the value provided for some dimensions will be Nothing. This is provided in the cases where the API does not currently have support for a certain type of dimension. For example, when you create a finite depth extrusion feature, two dimensions are automatically created to control the depth of the extrusion and the taper angle. The API does not currently support these types of dimensions. When they are retrieved into the drawing they are represented in the list by Nothing, which just serves as a place holder so that the number and order of the dimensions in this collection match the dimensions in the collection provided by the DrawingDimensions argument.

  • DrawingDimensions: A collection containing the drawing dimensions that were created as a result of the retrieve. The items in this collection will match up 1 for 1 with the dimensions provided by the SketchDimensions argument.
  • BeforeOrAfter: This notification is only provided after the dimensions have been retrieved so the value of this argument will always be kAfter.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.

DrawingViewEvents

OnViewUpdate( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ReasonsForChange As CommandTypesEnum, HandlingCode As HandlingCodeEnum )

The OnViewUpdate event notifies a client when the document associated with the drawing view has been modified and causes the drawing view to update. This event in useful in the case where you have created additional sketch geometry or labels referencing that view that may need to be updated to reflect changes in the attached model.

  • BeforeOrAfter: Indicates if the notification is being sent before or after the drawing view has been updated.
  • Context: Additional information is provided through this argument to help in understanding the context of the update.
    • Name = ReasonsForChange, Value = A value from the CommandTypesEnum that indicates the type of command that causes the update.
  • HandlingCode: This argument is ignored for this event.

FileAccessEvents

OnFileDirty( RelativeFileName As String, LibraryName As String,  (In/Out) CustomLogicalName() As Byte, FullFileName As String, DocumentObject As Document, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFileDirty event notifies a client when a document is about to become to dirty. A document becomes dirty when a change is made to a clean document. A clean document is defined as a document that does not need to be saved. Examples of clean documents are documents that have just been opened and documents that have just been saved. In both cases, a save operation is not needed because the file on disk is the same as the open document. Any change to the open document causes it to be different than the version on disk. This change of state of the document from being clean to dirty is when this notification is sent. Any subsequent changes to the document do not result in the OnFileDirty notification being sent because the document is already dirty. If the document is saved it will become clean, (the in-memory version of the document matches the version on disk), and the next change will again cause the OnFileDirty event notification to be made.

  • RelativeFileName: The relative filename of the document. This is typically just the filename but may also include relative path information.
  • LibraryName: If the document is a library part, this argument provides the name of the library as defined in the active project. If it is not a library part this will be an empty string.
  • CustomLogicalName: An array of Bytes that could have been defined by an application as an additional identifier for this document.
  • FullFileName: The full filename of the document.
  • DocumentObject: The Document object being dirtied.
  • BeforeOrAfter: This notification is currently only provided before the document is dirtied.
  • Context: Additional information is provided through this argument to help in understanding the context of the notification.
    • Name = AffectedFiles, Value = An array of Strings that contains a list of full filenames of the files being dirtied. Typically this will contain a single filename, but in the case of referenced files changing one document can also cause others to become dirty. For example, editing a part in the context of the assembly can cause other parts to reposition within other assemblies and in the case of adaptivity can cause parts to update. Each of these documents becomes dirty as a result of editing the single part. This list returns the filenames of the files affected. An OnFileDirty event notification is also made for each document as it is dirtied.
    • Name = ReasonsForChange, Value = "" ???
  • HandlingCode: This event supports the ability to cancel the dirty by aborting the actions that caused the change. By setting this argument to kEventCanceled Inventor will abort the change.
OnFileResolution( RelativeFileName As String, LibraryName As String,  (In/Out) CustomLogicalName() As Byte, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, FullFileName As String, HandlingCode As HandlingCodeEnum )

The OnFileResolution event notifies a client whenever Inventor is resolving the full path of a document. Whenever a document is opened in Inventor that contains references to other documents, the paths to the referenced documents must be determined. This process referred to as "file resolution". For example, if there is an assembly Top.iam that contains Part.ipt, when Top.iam is opened Inventor needs to Part.ipt on the disk in order to open it too. It does this using a combination of information stored in Top.iam and the paths defined by the active project. This event allows you to override Inventors standard file resolution and perform the resolution yourself. The OnFileResolution event notification is sent at the time Inventor recognizes that a file needs to be resolved but before it does the resolution. Through the events argument it provides you all of the information it has about this reference. You use this information to perform your own file resolution using whatever logic you choose and then supply Inventor with the full filename to use. Inventor skips its resolution and loads the file you specify.

  • RelativeFileName: The relative filename of the document. This is typically just the filename but may also include relative path information. Inventor uses this in combination with the paths defined by the active project to resolve the location of the file.
  • LibraryName: If the document is a library part, this argument provides the name of the library as defined in the active project. If it is not a library part this will be an empty string.
  • CustomLogicalName: An array of Bytes that could have been defined by an application as an additional identifier for this document.
  • BeforeOrAfter: This notification is currently only provided before the document is resolved.
  • Context:
    • Name = DatabaseRevisionId, Value = ??? (It's not the DatabaseRevisionId of the last document referenced.)
    • Name = InternalName, Value = The internal name of the document that was last resolved for this reference. This is the same value returned by the InternalName property of the document that was last used for this reference.
    • Name = DirectReferencingFileName, Value = This value and the value for TopLevelFilename are related. Looking at a simple example helps to explain the information they provide. In this example there is Part.ipt that's referenced by subassembly Sub.iam, which is reference by the assembly Top.iam. When you open Top.iam, the other files also need to be resolved and loaded. When Top.iam is opened, an OnFileResolution notification is sent for Sub.iam. For Sub.iam, DirectReferencingFileName will be the full filename of Top.iam because Sub.iam is being loaded because of the direct reference from Top.iam. TopLevelFilename will also be the full filename of Top.iam since that is the top level document that was opened. An OnFileResolution notification is also sent for Part.ipt. In this case, DirectReferencingFileName will be the full filename of Sub.iam since Part.ipt is being loaded because of the director reference from Sub.iam. TopLevelFilename will be the full filename of Top.iam, since is it the top-level document that caused the loading.
    • Name = TopLevelFilename, Value = See the description for DirectReferencingFileName.
  • FullFileName: If you are handling this event you use this argument to pass back the full filename of the document you want Inventor to load.
  • HandlingCode: To handle this event and you need to set this argument to kEventHandled. This will cause Inventor to skip its standard resolution and load the file you spescified in the FullFileName argument. Setting the value of this argument to kEventNotHandled will cause Inventor to use its standard file resolution. Canceling this event is not supported and setting this argument to kEventCanceled has the same effect as kEventNotHandled.

FileManagerEvents

OnFileDelete( FullFileName As String, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • FullFileName
  • Context
  • HandlingCode

FileUIEvents

OnFileInsertDialog( FileTypes() As String, DocumentObject As Document, ParentHWND As Long, FileName As String, RelativeFileName As String, LibraryName As String,  CustomLogicalName() As Byte, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFileInsertDialog event notifies a client whenever the end-user has executed a command that provides for the selection and insertion of a document into another document. Two common commands are the Place Component command in assembly, and the Derived Component command in part. When these commands are run, the first step is for the end-user to select a file. By default Inventor displays the standard Open dialog to allow them to specify the file. Using this event a client can override the standard behavior of Inventor and replace the Open dialog with their own dialog or even remove the dialog step and determine the file using some other method.

This notification is sent to the client immediately after the end-user has invoked the command, but before Inventor display any dialogs. If the client wants to handle getting the filename then they can respond to this event by setting the FileName argument to the full filename of the file to insert and setting the HandlingCode argument to kEventHandled. The filename supplied can be determined using any method the client chooses. Typically this is done by the client displaying their own dialog and allowing the end-user to choose a file. If the client responds to this event with a filename and the kEventHandled, then Inventor uses the supplied filename and does not display its standard Open dialog. If the client responds with either kEventNotHandled, Inventor uses its standard behavior and will display the Open dialog. If the client responds with kEventCanceled, the command is cancelled.

  • FileTypes: A list of the file types displayed in the "Files of Type" combo box on the Open dialog. For example, when the Derived Component command is executed the array contains the following three strings:
"Component Files (*.ipt, *.iam)|*.ipt; *.iam"
"Part Files (*.ipt)|*.ipt"
"Assembly Files (*.iam)|*.iam"
  • DocumentObject: The document object the file will be inserted into. For example, if the Place Component command is invoked, this will be the assembly the component will be inserted into.
  • ParentHWND: The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
  • FileName: The full filename that the client returns to Inventor if they choose to override Inventor's standard behavior and obtain the filename themself. In order for this filename to be used the client must also return kEventHandled as the handling code.
  • RelativeFileName: ????
  • LibraryName: If the document is a library part, this argument provides the name of the library as defined in the active project. If it is not a library part this will be an empty string.
  • CustomLogicalName: An array of Bytes that could have been defined by an application as an additional identifier for this document.
  • Context: If the Replace Component has been run by the end-user the following value is set:
    • Name = ReplaceComponent, Value = The name of the ComponentOccurrence object being replaced.
  • HandlingCode: Can supply any of the following three values:
    • kEventNotHandled: Inventor continues with its standard behavior and displays the Open dialog to allow the end-user to select a file.
    • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also sets the FileName argument with the full filename of the file Inventor should use for this process.
    • kEventCanceled: Cancels the operation.
OnFileInsertNewDialog( TemplateDir As String, FileTypes() As String, DocumentObject As Document, ParentHWND As Long, TemplateFileName As String, FileName As String, RelativeFileName As String, LibraryName As String, CustomLogicalName() As Byte, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFileInsertNewDialog event notifies the client whenever the end-user executes the Create Component command within an assembly. By responding to this event the client can replace the "Create In-Place Component" dialog with their own. This notification is sent to the client immediately after the command is executed but before the standard dialog is displayed. By supplying at least the Filename argument and setting the HandlingCode to kEventHandled, Inventor will bypass displaying the standard dialog and use the information provided to create a new in-place component within the assembly. The rest of the command behavior remains the same. That is the end-user is must select a location in the assembly to position the new component.

  • TemplateDir: The default template directory as defined in the File tab of the Application Options dialog. This information can be used by the client in their dialog to allow the end-user to select one of the standard templates.
  • FileTypes: A list of the file types displayed in the "Files of Type" combo box on the Open dialog. For example, when the Derived Component command is executed the array contains the following three strings:
"Part Files (*.ipt)|*.ipt"
"Assembly Files (*.iam)|*.iam"
  • DocumentObject: The AssemblyDocument object the new component will be created within.
  • ParentHWND: The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
  • TemplateFileName: The full filename of the file to use as the template when creating the new component. This can be any existing file and is not restricted to the files within the default template path. If this argument is not set, then the default part template will be used for the component. This argument is ignored unless the HandlingCode argument is set to kEventHandled.
  • FileName: The full filename of the file to be created. When creating a component in-place, the component is created in memory and is not written to disk until the end-user performs a save of the file. Because the filename is specified during the creation of the component the end-user will not be prompted for a filename during the save operation. This argument is required if the HandlingCode is set to kEventHandled.
  • RelativeFileName: ???????
  • LibraryName: If the document is a library part, this argument provides the name of the library as defined in the active project. If it is not a library part this will be an empty string.
  • CustomLogicalName: An array of Bytes that could have been defined by an application as an additional identifier for this document.
  • Context: No context information is provided for this event.
  • HandlingCode: Can supply any of the following three values:
    • kEventNotHandled: Inventor continues with its standard behavior and displays the "Create In-Place Component" dialog to allow the end-user to specify the component information.
    • kEventHandled: Indicates that the client is handling getting the component information. Requires that the client also set, at least, the FileName argument with the full filename of the component to be created.
    • kEventCanceled: Cancels the operation.
OnFileNewDialog( TemplateDir As String, ParentHWND As Long, TemplateFileName As String, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFileNewDialog event notifies the client when the end-user executes the New command to create a new file. By responding to this event the client can override Inventor's standard behavior of displaying the Open dialog and provide their own interface to determine the template to use in creating the new file.

This notification is only made in cases where the Open dialog is displayed to allow the end-user to select a template. If the end-user uses the pop-up command list next to the New command to select an assembly, part, presentation, or drawing document, the Open dialog is bypassed and the default template for each of these file types is used. Because the Open dialog is not used this notification is not sent in this case.

  • TemplateDir: The default template directory as defined in the File tab of the Application Options dialog. This information can be used by the client in their dialog to allow the end-user to select one of the standard templates.
  • ParentHWND: The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
  • TemplateFileName: The full filename of the file to use as the template when creating the new file. This can be any existing file and is not restricted to the files within the default template path. This argument must be set if the HandlingCode is set to kEventHandled.
  • Context: No context information is provided for this event.
  • HandlingCode: Can supply any of the following three values:
    • kEventNotHandled: Inventor continues with its standard behavior and displays the "Open" dialog to allow the end-user to select a template.
    • kEventHandled: Indicates that the client is handling getting the template. Requires that the client also set the TemplateFileName argument.
    • kEventCanceled: Cancels the operation.
OnFileOpenDialog( FileTypes() As String, ParentHWND As Long, FileName As String, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFileOpenDialog event notifies the client when the end-user executes the Open command to open an existing file. By responding to this event the client can override Inventor's standard behavior of displaying the Open dialog and provide their own interface to determine the file to open.

This notification is only made in cases where the Open dialog is displayed to allow the end-user to select a file. If the end-user uses the most recently used list in the File menu top open a file, the Open dialog is bypassed and the file is opened directly. Because the Open dialog is not used this notification is not sent in this case.

  • FileTypes: A list of the file types displayed in the "Files of Type" combo box on the Open dialog. Examples of some strings that could be provided by this arguments are:
"Inventor Files (*.iam;*.idw;*.ipt;*.ipn;*.ide)|*.iam;*.idw;*.ipt;*.ipn;*.ide"
"Assembly Files (*.iam)|*.iam"
"Drawing Files (*.idw)|*.idw"
"Part Files (*.ipt)|*.ipt"
"STEP Files (*.stp;*.ste;*.step)|*.stp;*.ste;*.step"
"All Files (*.*)|*.*"
  • ParentHWND: The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
  • FileName: The full filename of the file to open. This must be an existing valid file and the HandlingCode must be set to kEventHandled in order to override the standard open behavior.
  • Context: No context information is provided for this event.
  • HandlingCode: Can supply any of the following three values:
    • kEventNotHandled: Inventor continues with its standard behavior and displays the "Open" dialog to allow the end-user to select a file.
    • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also set the FileName argument.
    • kEventCanceled: Cancels the operation.
OnFileSaveAsDialog( FileTypes() As String, SaveCopyAs As Boolean, ParentHWND As Long, FileName As String, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFileOpenDialog event notifies the client when the end-user executes the Open command to open an existing file. By responding to this event the client can override Inventor's standard behavior of displaying the Open dialog and provide their own interface to determine the file to open.

  • FileTypes: A list of the file types displayed in the "Files of Type" combo box on the Save As dialog. When saving a part an example of the list is:
"Part Files (*.ipt)|*.ipt"
"DWF Files (*.dwf)|*.dwf"
"BMP (*.bmp)|*.bmp"
"IGES Files (*.igs;*.ige;*.iges)|*.igs;*.ige;*.iges"
"SAT Files (*.sat)|*.sat"
  • SaveCopyAs: Indicates if the end-user is performing a Save As or Save Copy As operation. Returns True if it is a Save Copy As and False for Save As.
  • ParentHWND: The Windows handle of the Inventor Application window. If the client displays their own dialog they can use this to associate their dialog to the Inventor window. This results in better behavior between the client dialog and Inventor. For example, the client window will stay on top of Inventor and if the Inventor window is collapsed the client dialog will also be collapsed.
  • FileName: The full filename to use when saving the file. The handling code must be set to kEventHandled in order to override the standard Save dialog and save this filename.
  • Context: The following information is provided through the Context argument:
    • Name = TopLevelDocument, Value = The full filename of the document being saved.
  • HandlingCode: Can supply any of the following three values:
    • kEventNotHandled: Inventor continues with its standard behavior and displays the "Save" dialog to allow the end-user to specify the filename.
    • kEventHandled: Indicates that the client is handling getting the filename. Requires that the client also set the FileName argument.
    • kEventCanceled: Cancels the operation.

ModelingEvents

OnDelete( DocumentObject As Document, Entity As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDelete event notifies the client when an entity is deleted. Currently the notification is limited to parameters???

  • DocumentObject: The Document object that contains the entity being deleted.
  • Entity: Then Entity that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the object provided is the object before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example:
Private m_oDeletedEntity As Object

Private Sub oModelingEvents_OnDelete(ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...)
    If BeforeOrAfter = kBefore Then
        ' Somehow Check to see if the Entity being deleted is an interesting one.
        ' For example, it could have an attribute attached to it to identify it.
        If Interesting(Entity) Then
            ' Save a reference to the object.
            Set m_oDeletedEntity = Entity
        End If
    Else
        ' Now we're either after the delete or it's been aborted.
        ' Check to see if the object is the interesting one.
        If Entity is m_oDeletedEntity Then
            If BeforeOrAfter = kAfter then
                ' The object was deleted.
            ElseIf BeforeOrAfter = kAbort Then
                ' The delete was aborted.
            End If
    End If
End Sub
  • BeforeOrAfter: Notification is sent before and after the entity is deleted.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnFeatureChange( DocumentObject As Document, Feature As PartFeature, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnFeatureChange event notifies the client when a feature is changed. This is provided for features in parts and also for assembly features. A change is defined as the modification of a feature's definition. This can occur when the end-user uses the edit command for that particular feature and when a feature is modified using the API. A feature recomputing as the result of other changes in the model is not considered a feature change. For example, if a fillet recomputes because the underlying geometry has changed, this is not considered a feature change because only the resulting geometry changed, not the definition of the fillet.

  • DocumentObject: The Document object the feature is contained within.
  • Feature: The PartFeature object that is being changed.
  • BeforeOrAfter: Notification is sent before and after the feature is changed.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewFeature( DocumentObject As Document, Feature As PartFeature, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewFeature event notifies the client when a new part feature is created.

  • DocumentObject: The Document object the feature is contained within.
  • Parameter: The PartFeature object that has just been created. When the BeforeOrAfter argument is kBefore, the value of this argument is Nothing since the feature does not yet exist.
  • BeforeOrAfter: Notification is sent before and after the feature has been created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewParameter( DocumentObject As Document, Parameter As Parameter, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewParameter event notifies the client when a new parameter is created. New parameters can be created explicitly by the end-user using the Add button on the Parameters dialog and they are also created implicitly as the result of placing dimension constraints and constructing features. This event provides notification is both cases.

  • DocumentObject: The Document object the parameter is contained within.
  • Parameter: The Parameter object that has just been created. When the BeforeOrAfter argument is kBefore, the value of this argument is Nothing since the Parameter does not yet exist.
  • BeforeOrAfter: Notification is sent before and after the parameter has been created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnParameterChange( DocumentObject As Document, Parameter As Parameter, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The onParameterChange event notifies the client when a parameter is changed. The event reports if the name, unit type, or value of a parameter is changed.

A parameter's value can be changed in many ways. This notification is sent for any change, regardless of what caused it. For example some ways that a parameter value can change are:

  1. An explicit edit by the end-user by editing the value in the Parameters dialog or editing the value of the associated dimension
  2. Being driven through an adaptive assembly. For example, if the length of a part changes as other parts in an assembly are modified, a notification is sent when the parameter controlling the length is changed as a result of the adaptivity.
  3. Being changed as the result of an equation. For example, if there is a parameter A whose equation is "1.0" and parameter B whose equation is "A * 2", any change to A will also cause B to change. In this case a notification will be sent for A and also for B since both of them will have changed.
  • DocumentObject: The Document object the parameter is contained within.
  • Parameter: The Parameter object that is being changed.
  • BeforeOrAfter: Notification is sent before and after the value of the parameter is changed. Using the kBefore timing you can examine the parameter to determine its state before the change is applied and then compare it to the state when the timing is kAfter.
  • Context: One of the following values is provided depending on what information associated with the parameter was changed:
    • Name = Value, Value = A String containing the new value of the parameter. This is provided if the value of the parameter is changed. This is the equivalent of the Value property of the parameter converted to a String, so it is in internal units.
    • Name = Unit, Value = The String "TBD". This indicates that the unit of the parameter has been changed. The value for this name can be ignored.
    • Name = Name, Value = A String containing the new name of the parameter. This is provided if the name of the parameter is changed.
  • HandlingCode: This argument is ignored for this event

PanelBar

OnCommandBarSelection( CommandBarObject As CommandBar, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnCommandBarSelection event notifies the client when ????.

  • CommandBarObject: The CommandBar object that is being selected.
  • BeforeOrAfter: Notification is sent before and after the command bar has switched.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.

PartEvents

OnSurfaceBodyChanged( Context As NameValueMap, BeforeOrAfter As EventTimingEnum, pHandlingCode As HandlingCodeEnum )
  • Context
  • BeforeOrAfter
  • pHandlingCode

RepresentationEvents

OnActivateDesignViewRepresentation( DocumentObject As AssemblyDocument, Representation As DesignViewRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActivateDesignViewRepresentation event notifies the client when a design view is being activated.

  • DocumentObject: The Document object the design view is being created within.
  • Representation: The DesignViewRepresentation object that is being activated.
  • BeforeOrAfter: Notification is sent before and after the design view has been activated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnActivateLevelOfDetailRepresentation( DocumentObject As Document, Representation As LevelOfDetailRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActivateLevelOfDetailRepresentation event notifies the client when a level of detail is being activated.

  • DocumentObject: The Document object the level of detail is being created within.
  • Representation: The LevelOfDetailRepresentation object that is being activated.
  • BeforeOrAfter: Notification is sent before and after the level of detail has been activated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnActivatePositionalRepresentation( DocumentObject As AssemblyDocument, Representation As PositionalRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnActivatePositionalRepresentation event notifies the client when a positional representation is being activated.

  • DocumentObject: The Document object the positional representation is being created within.
  • Representation: The PositionalRepresentation object that is being activated.
  • BeforeOrAfter: Notification is sent before and after the positional representation has been activated.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnDelete( DocumentObject As Document, Entity As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDelete event notifies the client when any representation related objects are deleted. These include level of details, positional representations, and design views.

  • DocumentObject: The Document object the deleted object is within.
  • Entity: The object being deleted.
  • BeforeOrAfter: Notification is sent before and after the object is deleted.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewDesignViewRepresentation( DocumentObject As AssemblyDocument, Representation As DesignViewRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewDesignViewRepresentation event notifies the client a new design view is created.

  • DocumentObject: The Document object the design view is being created within.
  • Representation: The new DesignViewRepresentation object that has just been created. When the BeforeOrAfter argument is kBefore, this argument is Nothing since the design view has not yet been created.
  • BeforeOrAfter: Notification is sent before and after the design view has been created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewLevelOfDetailRepresentation( DocumentObject As Document, Representation As LevelOfDetailRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewLevelOfDetailRepresentation event notifies the client a new level of detail is created.

  • DocumentObject: The Document object the level of detail is being created within.
  • Representation: The new LevelOfDetailRepresentation object that has just been created. When the BeforeOrAfter argument is kBefore, this argument is Nothing since the level of detail has not yet been created.
  • BeforeOrAfter: Notification is sent before and after the level of detail has been created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewPositionalRepresentation( DocumentObject As AssemblyDocument, Representation As PositionalRepresentation, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewPositionalRepresentation event notifies the client a new positional representation is created.

  • DocumentObject: The Document object the positional representation is being created within.
  • Representation: The new PositionalRepresentation object that has just been created. When the BeforeOrAfter argument is kBefore, this argument is Nothing since the positional representation has not yet been created.
  • BeforeOrAfter: Notification is sent before and after the positional representation has been created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.

ApplicationEvents

OnDelete( DocumentObject As Document, Entity As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDelete event notifies the client when a 2d or 3d sketch is being deleted.

  • DocumentObject: The Document object that contains the sketch.
  • Entity: Then sketch that is being deleted. When the value of the BeforeOrAfter argument is kBefore, the entity provided is the sketch before being deleted. When the value is kAfter, an object is also provided but since the actual entity has been deleted calling any methods or properties on the object will fail. The only thing that is valid to do with the object at this time is to compare it's identity with a reference previously saved. For example:
Private m_oDeletedSketch As Object

Private Sub oSketchEvents_OnDelete( ByVal DocumentObject As Document, ByVal Entity As Object, ByVal BeforeOrAfter As EventTimingEnum, ...)
    If BeforeOrAfter = kBefore Then
        ' Somehow Check to see if the sketch being deleted is an interesting one.
        ' For example, it could have an attribute attached to it to identify it.
        If Interesting(Entity) Then
            ' Save a reference to the object.
            Set m_ oDeletedSketch = Entity
        End If
    Else
        ' Now we're either after the delete or it's been aborted.
        ' Check to see if the sketch is the interesting one.
        If Entity is m_ oDeletedSketch Then
            If BeforeOrAfter = kAfter then
                ' The sketch was deleted.
            ElseIf BeforeOrAfter = kAbort Then
                ' The delete was aborted.
            End If
    End If
End Sub
  • BeforeOrAfter: Notification is sent before and after the sketch is deleted.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewSketch( DocumentObject As Document, Sketch As Sketch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewSketch event notifies the client when a new 2D sketch is being created.

  • DocumentObject: The Document object the new 2D sketch is being created within.
  • Sketch: The new sketch just created. When the BeforeOrAfter argument is kBefore, the value of this argument is Nothing since the sketch has not yet been created.
  • BeforeOrAfter: Notification is sent before and after the sketch is created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnNewSketch3D( DocumentObject As Document, Sketch3D As Sketch3D, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnNewSketch3D event notifies the client when a new 3D sketch is being created.

  • DocumentObject: The Document object the new 3D sketch is being created within.
  • Sketch3D: The new 3D sketch just created. When the BeforeOrAfter argument is kBefore, the value of this argument is Nothing since the sketch has not yet been created.
  • BeforeOrAfter: Notification is sent before and after the sketch is created.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnSketch3DChange( DocumentObject As Document, Sketch3D As Sketch3D, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnSketch3DChange event notifies the client when the geometry of a 3D sketch is changed. This includes adding new geometry, modifying existing geometry either directly or indirectly by editing dimension constraints, deleting geometry, and placing or deleting constraints where it will cause a change in any geometry. For example, placing a perpendicular constraint between two lines will cause this notification to be sent if the orientation of the lines needs to be changed to make them perpendicular. Adding dimension constraints does not change the geometry so it does not result in this notification being sent, but editing the value of the dimension does modify the geometry and will result in this notification being sent.

  • DocumentObject: The Document object the 3D sketch is within.
  • Sketch3D: The 3D sketch that is changing.
  • BeforeOrAfter: Notification is sent before and after the sketch is changed.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.
OnSketchChange( DocumentObject As Document, Sketch As Sketch, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnSketch\Change event notifies the client when the geometry of a 2D sketch is changed. This includes adding new geometry, modifying existing geometry either directly or indirectly by editing dimension constraints, deleting geometry, and placing or deleting constraints where it will cause a change in any geometry. For example, placing a perpendicular constraint between two lines will cause this notification to be sent if the orientation of the lines needs to be changed to make them perpendicular. Deleting the constraint does not cause the notification to be sent since the geometry is not changed as a result. Adding dimension constraints does not change the geometry so it does not result in this notification being sent, but editing the value of the dimension does modify the geometry and will result in this notification being sent.

  • DocumentObject: The Document object the 3D sketch is within.
  • Sketch: The 2D sketch that is changing.
  • BeforeOrAfter: Notification is sent before and after the sketch is changed.
  • Context: No context information is provided for this event.
  • HandlingCode: This argument is ignored for this event.

StyleEvents

OnActivateStyle( DocumentObject As Document, Style As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • Style
  • BeforeOrAfter: Fires before & after?
  • Context: Document change context?
  • HandlingCode: Ignored
OnDelete( DocumentObject As Document, Style As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • Style
  • BeforeOrAfter: Fires before & after?
  • Context: Document change context?
  • HandlingCode: Ignored?
OnNewStyle( DocumentObject As Document, Style As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • Style: Null on Before
  • BeforeOrAfter: Fires Before & After
  • Context: Type, Name
  • HandlingCode: Ignored
OnStyleChange( DocumentObject As Document, Style As Object, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • DocumentObject
  • Style
  • BeforeOrAfter: Fired before & after?
  • Context: Document change context?
  • HandlingCode: Ignored

TransactionEvents

OnAbort( TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum )

The OnAbort event notifies the client when a transaction has been aborted. An abort can happen in the case where a command has started a transaction and performed operations within that transaction but decides to abort the process rather than commit it.

  • TransactionObject: The Transaction object being aborted. When the BeforeOrAfter argument is kBefore this is the Transaction being aborted and it supports the full functionality of a Transaction object. When the BeforeOrAfter argument is kAfter the Transaction object no longer exists so the object provided by this argument is not functional expect to compare its identity to a variable containing a reference to a Transaction object.
  • Context: No context information is provided for this event.
  • BeforeOrAfter: Notification is sent before and after the transaction is aborted.
OnCommit( TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum )

The OnCommit event notifies the client when a transaction has been committed. A transaction is defined as an operation that the end-user can undo. When a transaction has been committed it means that the operation has been completed and is now on the transaction stack and can be undone.

  • TransactionObject: The Transaction object that is being committed.
  • BeforeOrAfter: Notification is sent before and after the transaction is committed.
  • Context: No context information is provided for this event.
  • HandlingCode: ???? Cancel causes problems.
OnDelete( TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum )

The OnDelete event notifies the client when a transaction has been deleted from the transaction stack. The transaction stack contains a list of all transactions that can be undone or redone. Transactions are deleted as the result of three things. First, the transaction has a fixed number of transactions it can hold, (which is defined in the registry). When the number of transactions goes over this limit, the transactions at the bottom of the stack are deleted. This means they can no longer be undone. The second reason transactions are deleted is if several undo operations are performed and then a transaction is committed, all transactions that are in an undone state are deleted. The third reason is as a result of a document being closed. Whenever a document is close the entire transaction stack is cleared. All transactions in the stack will be deleted.

  • TransactionObject: The Transaction object just deleted. Because the actual Transaction has been deleted the object Transaction object provided is not functional except to have its identify compared with a previously saved reference to a Transaction object. For example:
Private m_oSavedTransaction As Transaction

Private Sub oTransActionEvents_OnCommit( ByVal TransactionObject As Transaction, ...)
   If BeforeOrAfter = kAfter Then
      ' Somehow determine this is an interesting transaction.
      If Interesting(TransactionObject) Then
              ' Save a reference to the object.
              Set m_oSavedTransaction = TransactionObject
         End If
   End If
End Sub

Private Sub oTransActionEvents_OnDelete( ByVal TransactionObject As Transaction, ...)
     If BeforeOrAfter = kAfter Then
       ' Check to see if this is the interesting transaction being deleted.
          If TransactionObject is m_oSavedTransaction Then
                ' The transaction was deleted.
        End If
   End If
End Sub
  • BeforeOrAfter: Notification is sent only after the transaction is deleted.
  • Context: No context information is provided for this event.
OnRedo( TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum )

The OnRedo event notifies the client when a redo operation is being performed.

  • TransactionObject: The Transaction object being redone.
  • Context: No context information is provided for this event.
  • BeforeOrAfter: Notification is sent before and after the transaction is redone.
  • HandlingCode: ???? Cancel causes problems.
OnUndo( TransactionObject As Transaction, Context As NameValueMap, BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum )

The OnUndo event notifies a client when an undo operation is being performed.

  • TransactionObject: The Transaction object being undone.
  • Context: No context information is provided for this event.
  • BeforeOrAfter: Notification is sent before and after the transaction is undone.
  • HandlingCode: ???? Cancel causes problems.

UserInputEvents

OnActivateCommand( CommandName As String, Context As NameValueMap )

The OnActivateCommand event notifies the client when a command has been invoked.

  • CommandName: The internal name of the command. This is the same name as the internal name of the ControlDefinition object associated with this command.
  • Context: No context information is provided for this event.
OnContextMenu( SelectionDevice As SelectionDeviceEnum, AdditionalInfo As NameValueMap, CommandBar As CommandBar )

The OnContextMenu event notifies the client whenever a context menu is displayed in Inventor. A context menu is displayed when the end-user right-clicks the mouse. This notification is made before the context menu has been displayed to the end-user. The CommandBar object provided represents the context menu that will be displayed. The client can manipulate the content of this command bar to control what commands are displayed in the context menu. Using the CommandBar object the client can iterate over the current contents of the context menu, they can delete controls from the command bar and add new controls.

To understand the context the client can look at the contents of the SelectSet object to determine what entity the mouse was over when the mouse was clicked. In this situation the select set should either be empty (the end-user click off in space away from any entities) or should contain a single entity (the entity the mouse was over when the right button was clicked).

  • SelectionDevice: The area within Inventor where the context menu was invoked. This notification is only sent for context menus dislayed from a graphics window (kGraphicsWindowSelection) and the browser (kBrowserSelection).
  • AdditionalInfo: No additional information is provided for this event.
  • CommandBar: The CommandBar object that represents the context menu that will be displayed. The contents of this command bar can be modified to control the contents of the context menu.
OnDrag( DragState As DragStateEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View, AdditionalInfo As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnDrag event notifies the client whenever the end-user performs a drag operation in the graphics window. Using this event, the client can override Inventor's standard drag behavior. The following discusses the principles a client needs to understand in order to take advantage of the full capabilities of this event.

The OnDrag event notification is sent whenever the end-user begins to perform a drag operation in the graphics window. When the drag is initiated the DragState argument is equal to kDragStateDragHandlerSelection indicating. The client can determine what object is being dragged by checking the contents of the SelectSet object of the active document. If the client wants to override Inventor's standard drag behavior for the object, they need to set the HandlingCode argument to kEventHandled indicating the client will handle the drag. If the HandlingCode is set to kEventNotHandled then Inventor will handle the drag. A handling code of kEventCanceled is not supported and will result in the same think as kEventNotHandled.

If the HandlingCode has been set to kEventHandled then the OnDrag event notification will continue to be sent as the end-user continues the drag operation. The DrageState argument will be equal to kDragStateOnDrag while the end-user continues to drag. When the end-user releases the mouse button to stop the drag operation, the DragState argument will be equal to kDragStateEndDrag. By handling the drag Inventor expects the client to handle all aspects of the drag. The only thing that Inventor does is change the icon to a drag icon and continues to fire the OnDrag event notification. It is up to the client to provide any dynamic feedback during the drag and to perform whatever the final action of the drag is expected to produce, (typically the repositioning of an entity). Using the ModelPosition and ViewPosition arguments Inventor notifies the client of the current position of the mouse to allow them to create any preview graphics.

  • DragState: The current state of the drag operation. When the drag is initially started this value is kDragStateDragHandlerSelection, indicating the selection of an entity to be dragged. During the drag, this value is kDragStateOnDrag. When the mouse button is released to stop the drag operation this value is kDragStateEndDrag.
  • ShiftKeys: A value indicating what combinations of the Shift, Control, and Alt keys are currently pressed. This allows you to use combinations of these keys to control options for the command implementing the drag. For example, a Control drag might result in copying the entity.
  • ModelPosition: The current position of the mouse in model space.
  • ViewPosition: The current position of the mouse in view space. The coordinates are pixels where the upper-left corner of the view is (0,0).
  • View: The View object the drag is taking place within.
  • AdditionalInfo: No additional information is provided for this event.
  • HandlingCode: Setting this argument to kEventHandled results in turning off Inventor's standard behavior for the drag operation and causing additional OnDrag event notifications to be sent as the end-user continues the drag operation. By responding to these events the client can define their own behavior for the entity being dragged. Setting this to kEventNotHandled will cause Inventor to use its standard drag behavior for the entity being dragged. kEventCanceled is not supported and will result in the same behavior as kEventNotHandled.
OnTerminateCommand( CommandName As String, Context As NameValueMap )

The OnTerminateCommand event notifies the client when a command has been terminated. There are several things that cause a command to be terminated. First, is when a command finishes it will terminate. For example when you execute the Extrude command, after the extrusion has finished the command terminates. Starting another command while one command is active will cause the active command to terminate. An exception to this is the viewing commands. They just temporarily suspend the active command rather than terminate it.

  • CommandName: The internal name of the command. This is the same name as the internal name of the ControlDefinition object associated with this command.
  • Context: No context information is provided for this event.

UserInterfaceEvents

OnEnvironmentChange( Environment As Environment, EnvironmentState As EnvironmentStateEnum, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )

The OnEnvironmentChange event notifies the client when the active environment switches from one environment to another. Many end-user actions can cause the environment to change. This notification is sent regardless of what triggered the environment change. When the environment changes this notification will be sent four times; a before and after notification for the environment that was active before the change and is being suspended and a before and after notification for the environment that is becoming the active environment.

In the context of environment change, Inventor considers an environment to be tied with a particular document. For example, Inventor defines a single Part environment but if you have two part documents open there is a unique Part environment associated with each document. This means that the OnEnvironmentChange event notification is sent if the end-user should switch between the two part documents. Even though the active environment in both cases is the Part environment, for OnEnvironmentChange they are considered unique part environments because they are associated with different documents and the OnEnvironmentChange event notification is sent for each document.

  • Environment: The environment object whose state is changing.
    • EnvironmentState: Indicates the transition state the environment is going through.
    • kActivateEnvironmentState: When an environment is instantiated and activated. Examples are when a new document is created or when the sketch environment is invoked.
    • kResumeEnvironmentState: When an existing environment is activated. This happens when the end-user activates a document that is already open. In that case the environment had already been activated at some point but had been suspended when another document was activated.
    • kSuspendEnvironmentState: When an existing environment is suspended. This happens when the end-user activates another document. This causes the environment of the active document to be suspended.
    • kTerminateEnvironmentState: When an existing environment is terminated. Closing a document will cause its current environment to be terminated. Exiting sketch environment will also terminate the environment.
    • kRequestActivateEnvironmentState:
  • BeforeOrAfter: Notification is sent before and after the environment change.
  • Context: Additional information related to the event.
    • Name = Document, Value = The Document object this environment is associated with.
    • Name = Edit Target Id, Value = ????
    • Name = Reason for event, Value = ????
  • HandlingCode: This argument is ignored for this event.
OnResetCommandBars( CommandBars As ObjectsEnumerator, Context As NameValueMap )

The OnResetCommandBars event notifies the client when command bars have been reset. The end-user resets command bars using the various Reset buttons on the Customize dialog. The "Reset Menu Bar" button on the Enviroments tab causes this notification to be sent for the command bar that is being used as the menu bar of the selected environment. The "Reset" button on the Toolbars tab will cause this notification to be sent for the selected command bar (toolbar). The "Reset All" button on the toolbars tab causes this notification to be sent where the CommandBars argument contains all of the existing command bars.

This notification is sent for command bars that are created by Add-Ins (those that have an associated client ID). In the case of Add-In created command bars, a reset will remove all of the controls from the command bar but does not delete the command bar. This notification is not sent for user created tool bars and a reset does not have any affect on these toolbars.

The primary use of this notification is to allow add-ins to repopulate their commands into the toolbars after a reset has occurred. In most cases this will involved performing the same actions that the add-in performs when it is initialized and the FirstTime argument is True. The exception is the creation of the command bars since they are not deleted as a result of the reset. Only the controls need to be added to the command bars.

  • CommandBars: A collection of the CommandBar objects that have been reset. In many cases this collection will only contain one command bar.
  • Context: No context information is provided for this event.
OnResetEnvironments( Environments As ObjectsEnumerator, Context As NameValueMap )

The OnResetEnvironments event notifies the client when environments have been reset. The end-user resets environments using the "Reset" and "Reset All" buttons on Environments tab of the Customize dialog. The "Reset" button on the Enviroments tab will cause this notification to be sent for the currently selected environment. The "Reset All" button causes this notification to be sent where the Environments argument will contain all of the existing environments.

When an environment is reset it is set back the default state, but the environment is not deleted.

The primary use of this notification is to allow add-ins to reconfigure their environments after a reset has occurred. In most cases this will involved performing the same actions that the add-in performs when it is initialized and the FirstTime argument is True. The exception is the creation of the environment since they are not deleted as a result of the reset. Only the configuration of the environment needs to be performed.

  • Environments: A collection of the Environment objects that have been reset. In the case where the end-user uses the "Reset" button this collection will contain a single Environment object. If the "Reset All" button is pressed this collection contains all of the Environment objects.
  • Context: No context information is provided for this event.

TriadEvents

OnActivate( Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • Context
  • HandlingCode
OnEndMove( SelectedTriadSegment As TriadSegmentEnum, ShiftKeys As ShiftStateEnum, CoordinateSystem As Matrix, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • SelectedTriadSegment
  • ShiftKeys
  • CoordinateSystem
  • Context
  • HandlingCode
OnEndSequence( Cancelled As Boolean, CoordinateSystem As Matrix, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • Cancelled
  • CoordinateSystem
  • Context
  • HandlingCode
OnMove( SelectedTriadSegment As TriadSegmentEnum, ShiftKeys As ShiftStateEnum, CoordinateSystem As Matrix, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • SelectedTriadSegment
  • ShiftKeys
  • CoordinateSystem
  • Context
  • HandlingCode
OnMoveTriadOnlyToggle( MoveTriadOnly As Boolean, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • MoveTriadOnly
  • BeforeOrAfter
  • Context
  • HandlingCode
OnSegmentSelectionChange( SelectedTriadSegment As TriadSegmentEnum, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • SelectedTriadSegment
  • BeforeOrAfter
  • Context
  • HandlingCode
OnStartMove( SelectedTriadSegment As TriadSegmentEnum, ShiftKeys As ShiftStateEnum, CoordinateSystem As Matrix, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • SelectedTriadSegment
  • ShiftKeys
  • CoordinateSystem
  • Context
  • HandlingCode
OnStartSequence( CoordinateSystem As Matrix, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • CoordinateSystem
  • Context
  • HandlingCode
OnTerminate( Cancelled As Boolean, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • Cancelled
  • Context
  • HandlingCode

ButtonDefinition

OnExecute( Context As NameValueMap )
  • Context: Not used.

ChangeDefinition

OnReplay( Context As NameValueMap, ResultProcessor As ChangeProcessor )
  • Context
  • ResultProcessor

ChangeProcessor

OnExecute( Document As Document, Context As NameValueMap,  (In/Out) Succeeded As Boolean )
  • Document
  • Context
  • Succeeded
OnReadFromScript( Document As Document, Inputs As String, Context As NameValueMap )
  • Document
  • Inputs
  • Context
OnTerminate(  )
OnWriteToScript( Document As Document, Context As NameValueMap, ResultInputs As String )
  • Document
  • Context
  • ResultInputs

ComboBoxDefinition

OnSelect( Context As NameValueMap )
  • Context

SelectEvents

OnPreSelect(  (In/Out) PreSelectEntity As Object, DoHighlight As Boolean,  (In/Out) MorePreSelectEntities As ObjectCollection, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • PreSelectEntity
  • DoHighlight
  • MorePreSelectEntities
  • SelectionDevice
  • ModelPosition
  • ViewPosition
  • View
OnPreSelectMouseMove( PreSelectEntity As Object, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • PreSelectEntity
  • ModelPosition
  • ViewPosition
  • View
OnSelect( JustSelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • JustSelectedEntities
  • SelectionDevice
  • ModelPosition
  • ViewPosition
  • View
OnStopPreSelect( ModelPosition As Point, ViewPosition As Point2d, View As View )
  • ModelPosition
  • ViewPosition
  • View
OnUnSelect( UnSelectedEntities As ObjectsEnumerator, SelectionDevice As SelectionDeviceEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • UnSelectedEntities
  • SelectionDevice
  • ModelPosition
  • ViewPosition
  • View

InteractionEvents

OnActivate(  )
OnHelp( BeforeOrAfter As EventTimingEnum, Context As NameValueMap, HandlingCode As HandlingCodeEnum )
  • BeforeOrAfter: Only before?
  • Context: HelpContext = Help OR HelpContext = HowTo
  • HandlingCode: Handled or NotHandled?
OnResume(  )
OnSuspend(  )
OnTerminate(  )

KeyboardEvents

OnKeyDown( Key As Long, ShiftKeys As ShiftStateEnum )
  • Key
  • ShiftKeys
OnKeyPress( KeyASCII As Long )
  • KeyASCII
OnKeyUp( Key As Long, ShiftKeys As ShiftStateEnum )
  • Key
  • ShiftKeys

MouseEvents

OnMouseClick( Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • Button
  • ShiftKeys
  • ModelPosition
  • ViewPosition
  • View
OnMouseDoubleClick( Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • Button
  • ShiftKeys
  • ModelPosition
  • ViewPosition
  • View
OnMouseDown( Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • Button
  • ShiftKeys
  • ModelPosition
  • ViewPosition
  • View
OnMouseLeave( Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, View As View )
  • Button
  • ShiftKeys
  • View
OnMouseMove( Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • Button
  • ShiftKeys
  • ModelPosition
  • ViewPosition
  • View
OnMouseUp( Button As MouseButtonEnum, ShiftKeys As ShiftStateEnum, ModelPosition As Point, ViewPosition As Point2d, View As View )
  • Button
  • ShiftKeys
  • ModelPosition
  • ViewPosition
  • View

Disclaimer


Features - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Features

Introduction to Features

The term feature can be confusing to those new to parametric modeling. In common language, it might mean a distinguishing characteristic of some kind. In 3D parametric modeling, it refers to each of the mathematical processes used to build the model, hence the term feature-based modeling.

The model represents the result of applying a sequence of features and other changes. Interestingly, due to the hierarchical nature of the computations, a change to a feature, especially one early in the sequence, often results in changes to parts of the model that might have other features applied to them. So application or modification of a simple feature can have far-reaching effects, perhaps causing significant changes in the appearance of the model.

A common example of a feature is an extrusion. Imagine a sketched circle. It is 2D with no thickness. Apply an extrusion feature to this circle (actually to a profile based on the circle), specify an extrusion thickness, and a 3D model is generated. Depending on the thickness, it might look thin like a coin, or long like a cylinder. You can apply further features, such as a fillet feature to round off the edges of the cylinder.

The purpose of Features

The extrusion feature described previously is often the first feature used in building a model, but there are many more feature types; some that generate solids from sketches or profiles, some that modify existing solids. Autodesk Inventor maintains the list of features (and their respective parameters) so they can easily be changed. Imagine if this were not so. You complete a complex model, only to find some minor fillet or chamfer applied early in the process was wrong. In feature-based modelers, such as Autodesk Inventor, you can go to that earlier feature, make your change, and let the entire model be recomputed incorporating the change.

Features Object Model Diagram

The following is a list of current API feature objects. Not all are available at the same time - it depends on the document or environment type. For example, the FlangeFeature object only has meaning in the context of a sheet metal part.

BendFeature | BoundaryPatchFeature | ChamferFeature
CircularPatternFeature | CoilFeature | ContourFlangeFeature
CornerChamferFeature | CornerFeature | CornerRoundFeature
CutFeature | DecalFeature | DeleteFaceFeature
EmbossFeature | ExtrudeFeature | FaceDraftFeature
FaceFeature | FeatureBasedOccurrencePattern | FeaturePatternElement
FeaturePatternElements | FilletFeature | FlangeFeature
FoldFeature | HemFeature | HoleFeature
KnitFeature | LoftFeature | MirrorFeature
MoveFaceFeature | NonParametricBaseFeature | PartFeature
PartFeatureExtent | PunchToolFeature | RectangularPatternFeature
ReferenceFeature | ReplaceFaceFeature | RevolveFeature
RibFeature | ShellFeature | SplitFeature
SweepFeature | ThickenFeature | ThreadFeature

Working with Features through the API

A part component definition provides access to the collection of features to be applied to that part. This PartFeatures object is a collection of other part feature collection types. For example, the ExtrudeFeatures object is a collection of ExtrudeFeature objects. Creating an extrude feature is as simple as adding it to this collection. However, most features require some further input, perhaps in the form of mirror or rotation axes, sketches or profile objects, or radius dimensions, to help define the appropriate result.

Creating an extruded feature from scratch

This sample code steps through the process of creating a solid from an extruded sketch. A new part document is created, a sketch and profile is added, and the profile is extruded to form a 3D solid.

Note: Extruding a sketch through the Autodesk Inventor user interface does not require creation of a profile. This step is hidden from the user. However, the API does require a Profile object (actually a collection of ProfilePath objects) to create some features.

The code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type. First, add a new part document to the documents collection:

Dim oApp As Inventor.Application
Set oApp = ThisApplication

Dim oPartDoc As PartDocument
Set oPartDoc = oApp.Documents.Add(kPartDocumentObject, oApp.GetTemplateFile(kPartDocumentObject))

Now add a new sketch to the sketches collection of this document's component definition. Here, the third item in the WorkPlanes collection indicates the XY plane, so that is the plane for the new sketch. For more information on WorkPlanes and other work features, refer to the Work Features overview.

Dim oSketch As PlanarSketch
Set oSketch = oPartDoc.ComponentDefinition.Sketches.Add(oPartDoc.ComponentDefinition.WorkPlanes.Item(3))

Some transient point objects are required when creating sketch lines, so obtain the TransientGeometry object.

Dim oTG As TransientGeometry
Set oTG = oApp.TransientGeometry

Add three points to the SketchPoints collection of the new sketch. These become the endpoints of three sketch lines forming a triangle. The false argument indicates that these points are not intended as hole feature center points.

Dim oSkPnts As SketchPoints
Set oSkPnts = oSketch.SketchPoints
Call oSkPnts.Add(oTG.CreatePoint2d(0, 0), False)
Call oSkPnts.Add(oTG.CreatePoint2d(1, 0), False)
Call oSkPnts.Add(oTG.CreatePoint2d(1, 1), False)

When the user draws sketch lines through the Autodesk Inventor user interface, sketch points are not required as they are inferred automatically. This is not the case with the API. Sketch points are required to add sketch lines. Use the preceding sketch points to add three sketch lines to the sketch.

Dim oLines As SketchLines
Set oLines = oSketch.SketchLines
Dim oLine(1 To 3) As SketchLine
Set oLine(1) = oLines.AddByTwoPoints(oSkPnts(1), oSkPnts(2))
Set oLine(2) = oLines.AddByTwoPoints(oSkPnts(2), oSkPnts(3))
Set oLine(3) = oLines.AddByTwoPoints(oSkPnts(3), oSkPnts(1))

The code thus far creates a new part document containing the following sketch:

Extrude features require a profile object, so create a profile from this sketch. The AddForSolid method has optional arguments (not used here) that can be used to further manipulate the ProfilePaths within the Profile.

Dim oProfile As Profile
Set oProfile = oSketch.Profiles.AddForSolid

Now, add an ExtrudeFeature to the Features collection of the document's component definition. Here the AddByDistanceExtent method is used, which requires a distance for the extrude - in this case, 1.0. The other arguments are also similar to the user interface, indicating the extrude should occur in both positive and negative directions, and that a join Boolean operation should be performed.

Dim oExtFeature As ExtrudeFeature
Set oExtFeature = oPartDoc.ComponentDefinition.Features.ExtrudeFeatures.AddByDistanceExtent _
    (oProfile, 1.0, kSymmetricExtentDirection, kJoinOperation)
oApp.ActiveView.Fit

The code results in a 3D solid appearing as follows:

This sample demonstrated a simple extrude of a sketch to form a 3D solid. The following sample demonstrates creation of a 3D solid by revolving a sketch around an axis. Again, start a new part document and create some sketch points:

Dim oApp As Inventor.Application
Set oApp = ThisApplication

Dim oPartDoc As PartDocument
Set oPartDoc = oApp.Documents.Add(kPartDocumentObject, oApp.GetTemplateFile(kPartDocumentObject))

Dim oSketch As PlanarSketch
Set oSketch = oPartDoc.ComponentDefinition.Sketches.Add(oPartDoc.ComponentDefinition.WorkPlanes.Item(3))

Dim oTG As TransientGeometry
Set oTG = oApp.TransientGeometry

Dim oSkPnts As SketchPoints
Set oSkPnts = oSketch.SketchPoints

Call oSkPnts.Add(oTG.CreatePoint2d(0, 0), False)
Call oSkPnts.Add(oTG.CreatePoint2d(1, 1), False)
Call oSkPnts.Add(oTG.CreatePoint2d(1, 0), False)

Three sketch points have been created. Use two of them to create a sketch line, and the third to locate a sketch circle with a radius of 0.5:

Dim oLines As SketchLines
Set oLines = oSketch.SketchLines

Dim oLine As SketchLine
Set oLine = oLines.AddByTwoPoints(oSkPnts(1), oSkPnts(2))

Dim oCircs As SketchCircles
Set oCircs = oSketch.SketchCircles

Dim oCirc As SketchCircle
Set oCirc = oCircs.AddByCenterRadius(oSkPnts(3), 0.5)

The new sketch appears as follows:

The intention here is to rotate, or revolve, the circle around the axis formed by the sketch line, thus forming a doughnut shape. The next step is to form a profile from the circle sketch. Note that the AddForSolid method is used again. The only contiguous closed loop in the sketch is the circle, which is the only object that will be used in the resultant profile.

Dim oProfile As Profile
Set oProfile = oSketch.Profiles.AddForSolid

The only remaining step is to add the RevolveFeature to the RevolveFeatures collection. Here the AddFull method is used, indicating that the revolve should rotate through a full 360 degrees. The alternative is the AddByAngle method. The sketch line is used as the rotation axis.

Dim oRevFeature As RevolveFeature
Set oRevFeature = oPartDoc.ComponentDefinition.Features.RevolveFeatures.AddFull _
    (oProfile, oLine, kJoinOperation)
oApp.ActiveView.Fit

This RevolveFeature sample code results in a 3D solid appearing as follows:

Intelligent features - iFeatures

The Autodesk Inventor user interface supports insertion of iFeatures. iFeatures are features that you repeatedly use in your work, where some, but not all, parameters tend to change. An iFeature is stored as an .IDE file, and may prompt for required parameters during insertion. The base sketch is incorporated into the iFeature and usually has parameters and constraints applied. When an iFeature is inserted onto a model face, for example, the variable parameters are prompted for and the iFeature shape and placement modified appropriately. In most other respects, Autodesk Inventor treats iFeatures as regular features. The following is a list of current iFeature objects.

iFeatureComponent | iFeatureComponents | iFeatureDefinition
iFeatureEntityInput | iFeatureInput | iFeatureInputs
iFeatureParameterInput | iFeatureTemplateDescriptor | iFeatureTemplateDescriptors
iFeatureVectorInput | iFeatureWorkPlaneInput

The following code extract shows how an iFeature, named MyiFeature.ide, might be added to a face of a part in an assembly (here the previously selected face object is passed as oFace).

As this sample assumes an assembly context, the face is also in the assembly context, so it gets the part component definition of the face in its part context using the Parent property of the native object. In other words, the face in its part context, not in its assembly context. For more information, see the Proxies overview.

Dim oPartCompDef As PartComponentDefinition
Set oPartCompDef = oFace.NativeObject.Parent.Parent

Using the part component definition, add a new iFeature component definition to its ReferenceComponents collection. In this case, the code references an iFeature file named MyiFeature.ide.

Dim iFeatDef As iFeatureDefinition
Set iFeatDef = oPartCompDef.ReferenceComponents. _
    iFeatureComponents.CreateDefinition("c:\MyiFeature.ide")

The previously prepared iFeature is added to specified face of the part in the assembly. Use the iFeatureSketchPlaneInput object if additional control is required; for example, over the orientation of the iFeature.

Summary

Features are the building blocks of Autodesk Inventor's parametric feature-based modeler. Features represent a mathematical construct or modification of the model. Autodesk Inventor maintains a sequential list of features and their parameters, any of which can be changed, with the potential to cause the entire model to be recomputed. iFeatures takes this a step further, allowing parametric sketch-based features to be stored as .ide file. The API can add iFeatures to the model.

Also consider

Autodesk Inventor's iFeatures can take advantage of complex constraints, parameters and equations to change or maintain their size and shape. Refer to parameters for more information.

This type of intelligent application of features extends to other workflows too; refer to iMates, iParts, and iProperties.

The Autodesk Inventor user interface can be used to apply assembly features. These are features that apply to a part only in the assembly context. The API can currently query assembly features, but cannot yet create them.

Next page | Back to the Overviews
Disclaimer


File and Document References - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

File and Document References

Files and Documents

A File object represents a storage in the file system (i.e. a file on disk). A Document object represents an instance of a model or drawing in memory. A Document can only have a single associated File object. However, since it is possible to have multiple instances (or level of detail representations) of a file in memory that are persisted in the same storage on the file system, multiple Document objects may be associated with the same File object.

File and Document References

A FileDescriptor object describes the reference from a File to another File. A DocumentDescriptor describes the reference from a Document to another Document. A descriptor contains all the information needed to find the referenced file/document as well as the state of the reference (healthy, unresolved, replaced, etc.). The File and FileDescriptor objects represent the consolidated view of all of the representations of a Document. The figure below shows the relationships between the FileDescriptor, File, DocumentDescriptor and Document objects.

Figure 1 : The File References API Model

Relevant API Properties

Note: The Document interface is replaced by ApprenticeServerDocument in Apprentice. All the property names remain the same.

File Object

Property | Returned objects | Description
AvailableDocuments | Document objects | Documents currently in memory.
AllReferencedFiles | File objects | All the files referenced by this file (including recursively nested references).
ReferencingFiles | File objects | All the files in memory that directly reference this file.
ReferencedFiles | File objects | All the files directly referenced by this file. Unresolved & suppressed references are skipped.
ReferencedFileDescriptors | FileDescriptor objects | A collection describing all the direct references held by this file. This is a consolidated view of all the document references. Includes unresolved and suppressed references. Also includes foreign file references (xls, bmp, etc.)

Document (and ApprenticeServerDocument) Object

Property | Return type | Description
File | File object | The associated File object.
AllReferencedDocuments | Document objects | All the documents referenced by this document (including recursively nested references).
ReferencingDocuments | Document objects | All the documents in memory that directly reference this document.
ReferencedDocuments | Document objects | All the documents directly referenced by this document. Unresolved & suppressed references are skipped.
ReferencedDocumentDescriptors | DocumentDescriptor objects | A collection describing all the direct references held by this document. Includes unresolved and suppressed references.
ReferencedOLEFileDescriptors | ReferencedOLEFileDescriptor objects | A collection describing all the direct foreign file references held by this document. Includes unresolved references.

FileDescriptor Object

Property | Return type | Description
FullFileName | String | Full path of the referenced file.
ReferencedFile | File object | The referenced file. Returns Null if reference is missing (unresolved or suppressed).
ReferenceMissing | Boolean | Whether the reference is missing for any reason and will the ReferencedFile property return a File object.

DocumentDescriptor Object

Property | Return type | Description
FullDocumentName | String | Full path of the referenced document.
ReferencedDocument | Document object | The referenced document. Returns Null if reference is missing (unresolved or suppressed).
ReferenceMissing | Boolean | Whether the reference is missing for any reason and will the ReferencedDocument property return a File object.
ReferenceSuppressed | Boolean | Whether the reference is suppressed.

The following code sample demonstrates the file references traversal and prints the file names of all the files referenced by the active document.

Public Sub FileReferenceSample()

  Dim oFile As File
  Set oFile = ThisApplication.ActiveDocument.File

  Call ProcessReferences(oFile)

End Sub

Private Sub ProcessReferences ( ByVal oFile As File )

  Dim oFileDescriptor As FileDescriptor
  For Each oFileDescriptor In oFile.ReferencedFileDescriptors

    Debug.Print oFileDescriptor.FullFileName

    If Not oFileDescriptor.ReferenceMissing Then

      ' Since the ReferenceMissing has returned False, the ReferencedFile will return a File
      ' Recurse unless this is a foreign file reference
      If Not oFileDescriptor.ReferencedFileType = kForeignFileType Then

        Call ProcessReferences(oFileDescriptor.ReferencedFile)
      End If
    End If
  Next
End Sub

Also consider

If you are working with very large assemblies, also refer to the Large Assembly Management (LAM) overview.

Next page | Back to the Overviews
Disclaimer


XML Tags for FormattedText - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

XML Tags for FormattedText

This table and the tag list below indicates which text formatting tags are supported by the listed API calls. For example, the table shows that the HoleTag.FormattedText property supports style overrides, line breaks, fractions and super/subscripts. Details of these XML tags are can accessed by clicking on the relevant table column title, or just scroll down to the appropriate section.

API | Style Override | Line Break | Fraction, Sub/Superscript | Derived Properties | Document Properties | Physical Properties | Parameter | Prompted Text | Dimension Placeholder | DrawingView Name/Scale | Delimiter | Hole Properties
DimensionText.FormattedText | ü | ü | ü |  |  |  | ü |  | ü |  |  |
DrawingNote.FormattedText | ü | ü | ü | ü | ü | ü | ü |  |  |  |  |
DrawingViewLabel.FormattedText | ü | ü | ü | ü | ü | ü |  |  |  | ü | ü |
GeneralNote.FormattedText | ü | ü | ü | ü | ü | ü | ü |  |  |  |  |
GeneralNotes.AddByRectangle FormattedText arg | ü | ü | ü | ü | ü | ü | ü |  |  |  |  |
GeneralNotes.AddFitted FormattedText arg | ü | ü | ü | ü | ü | ü | ü |  |  |  |  |
HoleTableCell.FormattedText | ü | ü | ü |  |  |  | ü |  |  |  |  | ü
HoleTag.FormattedText | ü | ü | ü |  |  |  |  |  |  |  |  |
LeaderNote.FormattedText | ü | ü | ü | ü | ü | ü | ü |  |  |  |  |
LeaderNotes.Add FormattedText arg | ü | ü | ü | ü | ü | ü | ü |  |  |  |  |
RevisionTableCell.FormattedText | ü | ü | ü |  |  |  |  |  |  |  |  |
TextBox.FormattedText | ü | ü | ü | ü | ü | ü | ü | ü |  |  |  |
TextBoxes.AddByRectangle FormattedText arg | ü | ü | ü | ü | ü | ü | ü | ü |  |  |  |
TextBoxes.AddFitted FormattedText arg | ü | ü | ü | ü | ü | ü | ü | ü |  |  |  |
DrawingStandardStyle.SetViewLabelDefaults | ü | ü | ü | ü | ü | ü |  |  |  | ü | ü |
DrawingStandardStyle.GetViewLabelDefaults | ü | ü | ü | ü | ü | ü |  |  |  | ü | ü |

Style Override <StyleOverride>

The StyleOverride tag defines all text style information. The various style options are defined within the tag using attributes. These attributes are described below.

Font – Sets which font to use. The input to this attribute is the name of the font.

FontSize – Sets the size of the font. The input to this attribute is the size in centimeters.

Bold – Allows you to turn bolding on or off. The input to this attribute is the String "True" or "False".

Italic – Allows you to turn italics on or off. The input to this attribute is the String "True" or "False".

Underline – Allows you to turn underlining on or off. The input to this attribute is the String "True" or "False".

Example:

"<StyleOverride Font='Arial'
Bold='True'>Notice</StyleOverride>: All holes larger than
0.500 <StyleOverride Font='AIGDT'>n</StyleOverride> are to
be checked."

This results in the following text: Notice: All holes larger than 0.500 Ø are to be checked.

The first StyleOverride tag defines the font to be Arial and Bold. This is applied to the text “Notice” since that is what is between the opening and closing tags for this style override. The second StyleOverride just changes the font, but uses the font AIGDT which contains some common mechanical drafting symbols. In this example it uses the character “n” which corresponds to the diameter symbol in this font.

Line Break <Br>

This is the equivalent of a carriage return. Well-formed XML requires opening and closing tags, i.e. <Br></Br>. In the case of the line break there will never be text between the tags (this is call an “empty tag”) so you can simplify the definition and combine the opening and closing tags into a single tag using <Br/>.

Example:

"Line 1:<Br/>Line 2:<Br/>Line3:" results in the following text:

Line1:

Line2:

Line3:

Derived Properties <DerivedProperty>

The DerivedProperty tag specifies that information derived from the document will be used in the text string. Derived properties are different from standard document properties in that they are created "on the fly" from information associated with the document. Currently, if a derived property is used it must be the only text input for the formatted string. The StyleOverride tag can be used to control the style but no other text can be mixed with the derived property text. In order to define which derived property is to be used the following attribute is used:

DerivedID – The ID value that corresponds to a particular derived property. These ID’s are defined in the DerivedPropertyEnum enum list. Derived properties that are associated with a model will be extracted from the model associated with the first view placed on the sheet.

  • kDerivedModelFilename – Filename of the model.
  • kDerivedModelFilenameAndPath – Full path of the model.
  • kDerivedModelVersion – Internal version number of the model.
  • kDerivedDrawingFilename – Filename of the drawing.
  • kDerivedDrawingFilenameAndPath – Full path of the drawing.
  • kDerivedDrawingVersion – Internal version number of the drawing.
  • kDerivedNumberOfSheets – The number of sheets in the drawing.
  • kDerivedSheetNumber – The number of this sheet.
  • kDerivedSheetSize – The size of this sheet.
  • kDerivedSheetRevision – The revision number of this sheet.

Document Properties <Property>

The Property tag specifies that the value of a document property is to be used in the text string. Currently, if a document property is used it must be the only text input for the formatted string. The StyleOverride tag can be used to control the style but no other text can be mixed with the property text. In order to define which property is to be used the following attributes are used:

Document – The Document attribute is optional and used to specify which document the property value is to be extracted from. If this attribute is not specified, it uses the properties from the model document referenced by the first view placed on the sheet. Valid values for this attribute are "model" or "drawing". If "drawing" is used, the properties from the drawing document are used.

FormatID – The FormatID attribute specifies which property set the property is within. This is specified as a GUID in string form. The "Document Properties" topic in the API Overview discusses how to obtain the format ID’s for specific property sets.

PropertyID – The PropertyID is a numeric value, which uniquely identifies a property within the property set.

The "Document Properties" topic in the API Overview discusses how to obtain the property ID’s for specific properties. The Id of a property is the same as the value of the associated enum.

Example:

The example below will display the string associated with the description property of the design tracking properties associated with the document containing the model referenced by the first view on the sheet. The backslash at the end of the tag definition denotes that the opening and closing tags have been combined. This is useful in this case since a property tag does not require any additional information besides what’s provided by the attributes.

<Property Document="model" FormatID="{32853F0F-3444-11d1-9E93-0060B03C1CA6}" PropertyID="29" />

Prompted Text <Prompt>

The prompt tag defines text that will prompt the user for the associated string. This type of text can only be placed within a sketch that is used for the definition of a title block, border, or sketched symbol. Currently, if prompted text is used no other text or tags can be used within the formatted text string. The StyleOverride tag can be used to control the style but no other text can be mixed with the prompted text. The override will be applied to the text entered by the user.

Examples:

The text between the opening and closing tags is used as the prompt string. The example below will create a string that will cause a dialog to be displayed with the prompt "Enter designers name:".

"<Prompt>Enter designers name:</Prompt>"

The text below will result in the same prompted string but the resulting text will have the style override applied.

"<StyleOverride Font='Courier New' Italic='True'><Prompt>Enter designers name:</Prompt></StyleOverride>"

Parameter <Parameter>

The parameter tag defines that the value of a parameter is to be used in the text string.

Example:

Here is a sample (this assumes that "C:\temp\test.ipt" is a document referenced by the drawing and contains a model parameter named "d0"). The ComponentIdentifier tag is not required if working within part sketches.

"<Parameter ComponentIdentifier='C:\temp\test.ipt' Name='d0' Precision='2' ></Parameter>"

Physical Properties From Model <PhysicalProperty>

The PhysicalProperty tag specifies that physical properties information derived from the model will be used in the text string. In order to define which physical property is to be used the following attribute is used:

PhysicalPropertyID - The ID value that corresponds to a particular physical property. These IDs are defined in the PhysicalPropertyEnum enum list. Physical properties that are associated with a model will be extracted from the model.

  • kPhysicalModelMass - Mass of the model.
  • kPhysicalModelArea - Area of the model.
  • kPhysicalModelVolume - Volume of the model.
  • kPhysicalModelDensity - Density of the model.

Example:

<PhysicalProperty PhysicalPropertyID='72449' Precision='3'></PhysicalProperty>

where '72449' represents the integer enum value representing the Mass property. If Precision is not specified, it defaults to 0.

Dimension Placeholder <DimensionValue>

This tag defines where the dimension value will be placed. If not specified, the tag will be placed at the beginning of the text.

DrawingView Name/Scale <DrawingViewName> and <DrawingViewScale>

These tags define where the drawing view name or scale will be placed, respectively. If not specified, the tag will be placed at the default location.

Delimiter <Delimiter>

This tag defines where the delimiter will be placed.

Hole Properties <HoleProperty>

The HoleProperty tag specifies that hole properties from the model will be used in the text string. In order to define which hole property is to be used, the following attribute is used:

HolePropertyID - The ID value that corresponds to a particular hole property.

These IDs are defined in the HolePropertyEnum list.

Example:

<HoleProperty HolePropertyID='77581' Precision='2'></HoleProperty>

where '77581' represents the long enum value of the hole diameter property (kHoleDiameterHoleProperty). If Precision is not specified, it defaults to 2.

Stacked Fraction, Superscript and Subscript <Stack>

The stack tag defines the stacking of sub-strings in the text string.

  • "/" character within the substring specifies horizontal stacking.
  • "#" character within the substring specifies diagonal stacking.
  • "^" character prefix within the substring specifies a subscript.
  • "^" character suffix within the substring specifies a superscript.
  • An optional “FractionalTextScale” value can be specified.

Examples:

“1<Stack FractionalTextScale=’0.7’>1/2</Stack>” will result in

“1<Stack FractionalTextScale=’0.7’>1#2</Stack>” will result in 1½

“1<Stack>1#2</Stack>” will result in 1½

“H<Stack>^2</Stack>SO<Stack>^4</Stack>” will result in H2SO4

“x<Stack>2^</Stack> + y<Stack>2^</Stack> = z<Stack>2^</Stack>” will result in x2 + y2 = z2

Note - remember when using XML that certain characters must be represented by codes. The following table gives examples.

Code | Result | Description
&lt; | < | Less than
&gt; | > | Greater than
&amp; | & | Ampersand
&apos; | ' | Apostrophe
&quot; | " | Quotation mark

Next page | Back to the Overviews
Disclaimer


Index

Index

_ | 6 | A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

_

_Activate

DesignProject interface

_Add

AliasFreeformFeatures interface

SculptFeatures interface

_AddByValue

ModelParameters interface

ReferenceParameters interface

UserParameters interface

_GetValueFromExpression

Parameters interface

UnitsOfMeasure interface

_IsLegacyWeldBead

WeldBead interface

_NewEnum

BossSets interface

ChainDimensionSets interface

ExpressionList interface

PartsListStylesEnumerator interface

ProjectPaths interface

RevisionTableStylesEnumerator interface

TableStylesEnumerator interface

_NominalSizeDescription

ThreadInfo interface

_Parent

RepresentationsManager interface

_PitchDesignation

StandardThreadInfo interface

_Redefine

AliasFreeformFeature interface

6

64bit Topics

A

Abort

Transaction interface

About Addins

Accessing the API

Accuracy

MassProperties interface

RegionProperties interface

AchievedAccuracy

MassProperties interface

Activate

ApplicationAddIn interface

ApplicationAddInServer interface

BrowserPaneObject interface

ColorScheme interface

DesignProject interface

DesignViewRepresentation interface

Document interface

DraftAnalysis interface

IInventorStudio interface

LevelOfDetailRepresentation interface

PositionalRepresentation interface

PresentationExplodedView interface

ReferencedOLEFileDescriptor interface

Sheet interface

SheetMetalStyle interface

View interface

Activated

ApplicationAddIn interface

ActivatedObject

Document interface

Active

Ribbon interface

RibbonTab interface

ActiveAnalysis

AnalysisManager interface

ActiveAnalysisType

AnalysisManager interface

ActiveAnimation

IAnimationManager interface

ActiveCell

ContentFamily interface

ActiveColorScheme

Application interface

ActiveCommand

CommandManager interface

ActiveDesignProject

DesignProjectManager interface

ActiveDesignViewRepresentation

ComponentOccurrence interface

DerivedAssemblyDefinition interface

DerivedPartDefinition interface

DrawingView interface

RepresentationsManager interface

ActiveDocument

Application interface

ActiveDocumentType

Application interface

ActiveEditDocument

Application interface

ActiveEditObject

Application interface

ActiveEnvironment

UserInterfaceManager interface

ActiveExplodedView

PresentationDocument interface

ActiveLevelOfDetailRepresentation

ComponentOccurrence interface

DerivedAssemblyDefinition interface

DrawingView interface

RepresentationsManager interface

ActiveLightingStyle

AssemblyDocument interface

IInventorStudio interface

PartDocument interface

PresentationDocument interface

ActiveMemberName

DrawingView interface

ActiveObjectDefaults

DrawingStandardStyle interface

ActiveOccurrence

AssemblyComponentDefinition interface

ActivePane

BrowserPanes interface

ActivePositionalRepresentation

ComponentOccurrence interface

DerivedAssemblyDefinition interface

DrawingView interface

RepresentationsManager interface

ActivePresentationView

DrawingView interface

ActiveRenderStyle

ApprenticeServerDocument interface

PartDocument interface

ActiveSceneStyle

IInventorStudio interface

ActiveSheet

DrawingDocument interface

ActiveSheetMetalStyle

SheetMetalComponentDefinition interface

ActiveStandard

ApprenticeServerDrawingDocument interface

ActiveStandardStyle

DrawingStylesManager interface

ActiveTableRow

iFeatureDefinition interface

ActiveView

Application interface

Adaptive

ComponentOccurrence interface

PartFeature interface

PlanarSketch interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

AdaptivelyUsedInAssembly

ModelingSettings interface

Add

AttributeSet interface

AttributeSets interface

AutoCADBlocks interface

Balloons interface

BalloonTips interface

BalloonValueSets interface

BaselineDimensionSets interface

BendFeatures interface

BendNotes interface

BendPartFeatures interface

BIMConnectorLinks interface

BIMConnectors interface

BorderDefinitions interface

BossSets interface

BoundaryPatchFeatures interface

BoundaryPatchLoops interface

BreakOperations interface

BreakOutOperations interface

BrowserFolder interface

BrowserPanes interface

Centerlines interface

Centermarks interface

ChainDimensionSets interface

ChamferNotes interface

ChangeDefinitions interface

ChangeManager interface

CircularPatternFeatures interface

ClientFeatureElements interface

ClientFeatures interface

ClientGraphicsCollection interface

ClientNodeResources interface

ClientViews interface

Columns interface

CombineFeatures interface

CommandBarList interface

CommandBars interface

CommandCategories interface

CommandCategory interface

ComponentOccurrences interface

ContentTableColumns interface

ContentTableRows interface

ContourFlangeFeatures interface

CoreCavityFeatures interface

CornerChamferFeatures interface

CornerFeatures interface

CornerRoundFeatures interface

CustomParameterGroup interface

CustomParameterGroups interface

CustomTables interface

CutFeatures interface

DecalFeatures interface

DeleteFaceFeatures interface

DerivedAssemblyComponents interface

DerivedParameterTables interface

DerivedPartComponents interface

DesignProjects interface

DesignViewRepresentations interface

DisabledCommandList interface

DockableWindows interface

DocumentInterests interface

Documents interface

DraftAnalyses interface

DrawingSketches interface

EdgeDefinitions interface

EdgeLoopDefinitions interface

EdgeUseDefinitions interface

EnvironmentList interface

Environments interface

ExtrudeFeatures interface

FaceDefinitions interface

FaceFeatures interface

FaceShellDefinitions interface

FeatureControlFrameRows interface

FeatureControlFrames interface

FilletFeatures interface

FlangeFeatures interface

FoldFeatures interface

GraphicsColorSet interface

GraphicsCoordinateSet interface

GraphicsDataSetsCollection interface

GraphicsImageSet interface

GraphicsIndexSet interface

GraphicsNormalSet interface

GraphicsTextureCoordinateSet interface

HemFeatures interface

HighlightSets interface

HoleTableColumns interface

HoleTableRows interface

HoleTables interface

HoleThreadNotes interface

IAnimationFavorites interface

IAnimations interface

iFeatures interface

InventorVBAComponents interface

InventorVBAProjects interface

KnitFeatures interface

LeaderNotes interface

LevelOfDetailRepresentations interface

LightingStyles interface

Lights interface

LoftedFlangeFeatures interface

LoftFeatures interface

LoftRails interface

LumpDefinitions interface

Materials interface

MirrorFeatures interface

MoveFaceFeatures interface

NameValueMap interface

NonParametricBaseFeatures interface

ObjectCollection interface

ObjectCollectionByVariant interface

OrdinateDimensions interface

OrdinateDimensionSets interface

PartsListColumns interface

PartsListRows interface

PartsLists interface

PlanarSketches interface

PositionalRepresentations interface

ProjectedCuts interface

ProjectPaths interface

PropertySet interface

PropertySets interface

PunchNotes interface

PunchToolFeatures interface

RectangularPatternFeatures interface

ReferencedOLEFileDescriptors interface

RefoldFeatures interface

RenderStyles interface

RevisionTableColumns interface

RevisionTableRows interface

RevisionTables interface

RibbonPanels interface

RibbonTabs interface

RibFeatures interface

RipFeatures interface

Rows interface

SculptFeatures interface

SheetFormats interface

Sheets interface

ShellFeatures interface

SilhouetteCurves interface

SketchBlockDefinitions interface

SketchBlocks interface

SketchedSymbolDefinitions interface

SketchedSymbols interface

SketchEllipses interface

SketchEllipticalArcs interface

Sketches3D interface

SketchFillRegions interface

SketchFixedSplines interface

SketchFixedSplines3D interface

SketchImages interface

SketchPoints interface

SketchPoints3D interface

SketchSplines interface

SketchSplines3D interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFaceList interface

SurfaceTextureSymbols interface

SweepFeatures interface

ThickenFeatures interface

ThreadFeatures interface

TitleBlockDefinitions interface

UnfoldFeatures interface

UserCoordinateSystems interface

VertexDefinitions interface

ViewList interface

Views interface

Add2

DerivedParameterTables interface

GraphicsDataSetsCollection interface

RevisionTables interface

AddAngleConstraint

AssemblyConstraints interface

AddAngleiMateDefinition

iMateDefinitions interface

AddAngular

GeneralDimensions interface

AddAsBend

SketchArcs3D interface

AddAsPolygon

SketchLines interface

AddAssociativeDraftView

DrawingViews interface

AddAsThreePointRectangle

SketchLines interface

AddAsTwoPointRectangle

SketchLines interface

AddAtCentroid

WorkPoints interface

AddAttributes

AttributeSet interface

AddAuxiliaryView

DrawingViews interface

AddBaseView

DrawingViews interface

AddBendTable

CustomTables interface

AddBendTableFromFile

UnfoldMethods interface

AddBisector

Centerlines interface

AddBorder

Sheet interface

AddBrowserFolder

BrowserPaneObject interface

AddButton

CommandBarControls interface

CommandControls interface

MiniToolbarControls interface

AddButtonDefinition

ControlDefinitions interface

AddButtonPopup

CommandBarControls interface

CommandControls interface

AddByAnalyticEdge

WorkAxes interface

AddByAngle

RevolveFeatures interface

AddByCenterOfGravity

Centermarks interface

AddByCenterRadius

SketchCircles interface

SketchCircles3D interface

AddByCenterStartEndPoint

SketchArcs interface

SketchArcs3D interface

AddByCenterStartSweepAngle

SketchArcs interface

SketchArcs3D interface

AddByComponentDefinition

ComponentOccurrences interface

AddByCurveAndEntity

WorkPoints interface

AddByDefinition

NonParametricBaseFeatures interface

SketchBlocks interface

AddByEdge

SketchFixedSplines3D interface

AddByExpression

ModelParameters interface

ReferenceParameters interface

UserParameters interface

AddByFeatureType

HoleTables interface

AddByFillet

SketchArcs interface

AddByFromToExtent

RevolveFeatures interface

AddByiMateAndEntity

iMateResults interface

AddByLine

WorkAxes interface

AddByLineAndPlane

WorkAxes interface

AddByLineAndPoint

WorkAxes interface

AddByLineAndTangent

WorkPlanes interface

AddByLinePlaneAndAngle

WorkPlanes interface

AddByMidPoint

WorkPoints interface

AddByNormalToCurve

WorkPlanes interface

AddByNormalToSurface

WorkAxes interface

AddByPitchAndHeight

CoilFeatures interface

AddByPitchAndRevolution

CoilFeatures interface

AddByPlaneAndOffset

WorkPlanes interface

AddByPlaneAndPoint

WorkPlanes interface

AddByPlaneAndTangent

WorkPlanes interface

AddByPoint

WorkPoints interface

AddByPointAndTangent

WorkPlanes interface

AddByProjectingEntity

Sketch interface

AddByRectangle

GeneralNotes interface

TextBoxes interface

AddByRevolutionAndHeight

CoilFeatures interface

AddByRevolvedFace

WorkAxes interface

AddBySilhouette

PlanarSketch interface

AddBySubset

ClientViews interface

AddByThreePlanes

WorkPoints interface

AddByThreePoints

SketchArcs interface

SketchArcs3D interface

SketchCircles interface

SketchCircles3D interface

WorkPlanes interface

AddByToFaceExtent

ExtrudeFeatures interface

RevolveFeatures interface

AddByToNextExtent

RevolveFeatures interface

AddByTorusCenterPoint

WorkPoints interface

AddByTorusMidPlane

WorkPlanes interface

AddByTwoiMates

iMateResults interface

AddByTwoLines

WorkPlanes interface

WorkPoints interface

AddByTwoPlanes

WorkAxes interface

WorkPlanes interface

AddByTwoPoints

SketchLines interface

SketchLines3D interface

WorkAxes interface

AddByValue

ModelParameters interface

ReferenceParameters interface

UserParameters interface

AddByWorkFeature

Centerlines interface

Centermarks interface

AddCBoreByDistanceExtent

HoleFeatures interface

AddCBoreByThroughAllExtent

HoleFeatures interface

AddCBoreByToFaceExtent

HoleFeatures interface

AddCenteredPattern

Centerlines interface

AddCheckBox

MiniToolbarControls interface

AddChild

BrowserNode interface

DockableWindow interface

AddCircularPattern

OccurrencePatterns interface

AddClosed

Profiles3D interface

AddCoincident

GeometricConstraints interface

GeometricConstraints3D interface

AddCollinear

GeometricConstraints interface

GeometricConstraints3D interface

AddColumn

HoleTableStyle interface

PartsListStyle interface

RevisionTableStyle interface

TableStyle interface

AddComboBox

CommandBarControls interface

CommandControls interface

MiniToolbarControls interface

AddComboBoxDefinition

ControlDefinitions interface

AddComponentGraphics

GraphicsNode interface

AddCompositeiMateDefinition

iMateDefinitions interface

AddConcentric

GeometricConstraints interface

AddConfigurationTable

CustomTables interface

AddConstantRadiusEdgeSet

FilletDefinition interface

AddCopy

CommandControls interface

AddCornerPiece

RunoffSurfaceDefinition interface

AddCSinkByDistanceExtent

HoleFeatures interface

AddCSinkByThroughAllExtent

HoleFeatures interface

AddCSinkByToFaceExtent

HoleFeatures interface

AddCSVTable

CustomTables interface

AddCurveGraphics

GraphicsNode interface

AddCustom

GeometricConstraints3D interface

RevisionTableRows interface

AddCustomConstraint

AssemblyConstraints interface

AddCustomiPartMember

ComponentOccurrences interface

AddDefaultBorder

Sheet interface

AddDependency

ClientFeatureDefinition interface

AddDetailView

DrawingViews interface

AddDiameter

DimensionConstraints interface

GeneralDimensions interface

AddDraftView

DrawingViews interface

AddDrilledByDistanceExtent

HoleFeatures interface

AddDrilledByThroughAllExtent

HoleFeatures interface

AddDrilledByToFaceExtent

HoleFeatures interface

AddDrivenSection

LoftSectionDimensions interface

AddDrivingSection

LoftSectionDimensions interface

AddDropdown

MiniToolbarControls interface

AddEdgeSet

CornerRoundDefinition interface

AddEllipseRadius

DimensionConstraints interface

AddEmbossEngraveFromPlane

EmbossFeatures interface

AddEmbossFromFace

EmbossFeatures interface

AddEngraveFromFace

EmbossFeatures interface

AddEqualLength

GeometricConstraints interface

AddEqualRadius

GeometricConstraints interface

AddEquationUnfoldMethod

UnfoldMethods interface

AddExcelTable

CustomTables interface

ParameterTables interface

AddExisting

DesignProjects interface

AddExtrusionPiece

RunoffSurfaceDefinition interface

AddFaceSet

FilletDefinition interface

AddFeatureBasedPattern

OccurrencePatterns interface

AddFileToSave

FileSaveAs interface

AddFitted

GeneralNotes interface

TextBoxes interface

AddFixed

WorkAxes interface

WorkPlanes interface

WorkPoints interface

AddFixedEdge

FaceDraftFeatures interface

AddFixedPlane

FaceDraftFeatures interface

AddFlushConstraint

AssemblyConstraints interface

AddFlushiMateDefinition

iMateDefinitions interface

AddForSolid

Profiles interface

AddForSurface

Profiles interface

AddFromFile

AutoCADBlockDefinitions interface

ProjectPaths interface

AddFull

RevolveFeatures interface

AddFullRoundSet

FilletDefinition interface

AddGallery

CommandControls interface

AddGround

GeometricConstraints interface

GeometricConstraints3D interface

AddHorizontal

GeometricConstraints interface

AddHorizontalAlign

GeometricConstraints interface

AddiAssemblyMember

ComponentOccurrences interface

AddInAutomation coclass

AddInsertConstraint

AssemblyConstraints interface

AddInsertiMateDefinition

iMateDefinitions interface

AddIntermediateRadius

FilletVariableRadiusEdgeSet interface

AddInType

ApplicationAddIn interface

AddiPartMember

ComponentOccurrences interface

AddItem

ComboBoxDefinitionObject interface

HighlightSet interface

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

AdditionalDisplayState

BrowserNodeDefinition interface

AdditionalProductionMethod

SurfaceTextureSymbol interface

AdditionalRoughness

SurfaceTextureSymbol interface

AdditionalSamplingLength

SurfaceTextureSymbol interface

AdditionalStateIconToolTipText

BrowserNodeDefinition interface

AdditionalVisibleRibbonTabs

Environment interface

AddLabel

MiniToolbarControls interface

AddLeader

Leader interface

LeaderNode interface

AddLibrary

FileLocations interface

AddLinear

GeneralDimensions interface

AddLinearUnfoldMethod

UnfoldMethods interface

AddLineGraphics

GraphicsNode interface

AddLineLength

DimensionConstraints3D interface

AddLineStripGraphics

GraphicsNode interface

AddLink

CustomTable interface

AddMacro

CommandBarControls interface

CommandControls interface

AddMacroControlDefinition

ControlDefinitions interface

AddMapCurve

MapPointCurves interface

AddMateConstraint

AssemblyConstraints interface

AddMateiMateDefinition

iMateDefinitions interface

AddMember

BaselineDimensionSet interface

OrdinateDimensionSet interface

AddMembers

ChainDimensionSet interface

AddMessage

ErrorManager interface

AddMidpoint

GeometricConstraints interface

GeometricConstraints3D interface

AddNewLine

MiniToolbarControls interface

AddNode

ClientGraphics interface

AddNonTransacting

ClientGraphicsCollection interface

GraphicsDataSetsCollection interface

AddOffset

DimensionConstraints interface

AddOffsetSpline

DimensionConstraints interface

AddOpen

Profiles3D interface

AddOptionsButton

DesignProjectManager interface

AddOverlayView

DrawingViews interface

AddParallel

GeometricConstraints interface

GeometricConstraints3D interface

AddParticipant

CircularPatternFeature interface

ExtrudeFeature interface

HoleFeature interface

MirrorFeature interface

RectangularPatternFeature interface

RevolveFeature interface

SweepFeature interface

AddPerpendicular

GeometricConstraints interface

GeometricConstraints3D interface

AddPoint

BSplineCurve2dDefinition interface

BSplineCurveDefinition interface

AddPointAndPlaneDistance

DimensionConstraints3D interface

AddPointGraphics

GraphicsNode interface

AddPopup

CommandBarControls interface

CommandControls interface

AddProjectedView

DrawingViews interface

AddRadiatePiece

RunoffSurfaceDefinition interface

AddRadius

DimensionConstraints interface

DimensionConstraints3D interface

GeneralDimensions interface

AddRectangularPattern

OccurrencePatterns interface

AddRotateRotateConstraint

AssemblyConstraints interface

AddRotateRotateiMateDefinition

iMateDefinitions interface

AddRotateTranslateConstraint

AssemblyConstraints interface

AddRotateTranslateiMateDefinition

iMateDefinitions interface

AddScalableTextGraphics

GraphicsNode interface

AddSectionView

DrawingViews interface

AddSelected

HoleTables interface

AddSelectionFilter

SelectEventsObject interface

AddSeparator

CommandControls interface

MiniToolbarControls interface

MiniToolbarDropdownObject interface

AddSimple

FilletFeatures interface

AddsMaterial

ProfilePath interface

AddSmooth

GeometricConstraints interface

GeometricConstraints3D interface

AddSpiral

CoilFeatures interface

AddSplitButton

CommandBarControls interface

CommandControls interface

AddSplitButtonMRU

CommandBarControls interface

CommandControls interface

AddSpotFaceByDistanceExtent

HoleFeatures interface

AddSpotFaceByThroughAllExtent

HoleFeatures interface

AddSpotFaceByToFaceExtent

HoleFeatures interface

AddSubstitute

LevelOfDetailRepresentations interface

AddSurfaceExtensionPiece

RunoffSurfaceDefinition interface

AddSurfaceGraphics

GraphicsNode interface

AddSymmetry

GeometricConstraints interface

AddTangent

GeometricConstraints interface

GeometricConstraints3D interface

AddTangentConstraint

AssemblyConstraints interface

AddTangentDistance

DimensionConstraints interface

AddTangentiMateDefinition

iMateDefinitions interface

AddTaperShadow

FaceDraftFeatures interface

AddTextGraphics

GraphicsNode interface

AddThicknessFaceSet

ShellDefinition interface

AddThreePointAngle

DimensionConstraints interface

AddTitleBlock

Sheet interface

AddTogglePopup

CommandControls interface

AddToSelectedEntities

SelectEventsObject interface

AddTransient

AttributeSets interface

AddTransientTreeBrowserPane

BrowserPanes interface

AddTransitionalConstraint

AssemblyConstraints interface

AddTreeBrowserPane

BrowserPanes interface

AddTriangleFanGraphics

GraphicsNode interface

AddTriangleGraphics

GraphicsNode interface

AddTriangleStripGraphics

GraphicsNode interface

AddTwoLineAngle

DimensionConstraints interface

DimensionConstraints3D interface

AddTwoPointDistance

DimensionConstraints interface

DimensionConstraints3D interface

AddUsingBaseDimension

ChainDimensionSets interface

AddUsingDistance

ChamferFeatures interface

AddUsingDistanceAndAngle

ChamferFeatures interface

AddUsingiMates

ComponentOccurrences interface

AddUsingPath

SweepFeatures interface

AddUsingPathAndGuideRail

SweepFeatures interface

AddUsingPathAndGuideSurface

SweepFeatures interface

AddUsingPathAndSectionTwists

SweepFeatures interface

AddUsingSheetFormat

Sheets interface

AddUsingTwoDistances

ChamferFeatures interface

AddValueEditor

MiniToolbarControls interface

AddVariableRadiusEdgeSet

FilletDefinition interface

AddVector

Vector interface

Vector2d interface

AddVertical

GeometricConstraints interface

AddVerticalAlign

GeometricConstraints interface

AddVirtual

ComponentOccurrences interface

AddWindowSelectionFilter

SelectEventsObject interface

AddWithLeader

SketchedSymbols interface

AddWithOptions

ComponentOccurrences interface

AddWithOrientation

PlanarSketches interface

AddWorkgroup

FileLocations interface

AdjustContext

SketchBlockDefinition interface

AdjustProxyContext

AssemblyComponentDefinition interface

AdoptMessages

MessageSection interface

AdvancedFeatureValidation

ModelingSettings interface

AffectedBodies

ExtrudeDefinition interface

AffectedBody

RibDefinition interface

AffectedByFeatures

SurfaceBody interface

AffectedOccurrenceOne

AssemblyConstraint interface

AffectedOccurrences

ExtrudeDefinition interface

AffectedOccurrenceTwo

AssemblyConstraint interface

AliasFreeformFeature interface

_Redefine

AliasFreeformFeature._Redefine method

AliasFreeformFeatureProxy interface

AliasFreeformFeatures

PartFeatures interface

AliasFreeformFeatures interface

_Add

Application

Count

Item

Type

AliasFreeformFeatures._Add method

AliasFreeformFeatures.Application property

AliasFreeformFeatures.Count property

AliasFreeformFeatures.Item method

AliasFreeformFeatures.Type property

Align

DrawingView interface

AlignAuxiliary

DrawingView interface

AlignCellsVertically

FeatureControlFrameStyle interface

Aligned

DrawingView interface

AlignedCornerExtension

CornerDefinition interface

AlignMembers

OrdinateDimensionSet interface

AllAffectedViews

BreakOperation interface

BreakOutOperation interface

AllAroundSymbol

FeatureControlFrame interface

SurfaceTextureSymbol interface

AllAroundSymbolDiameter

LeaderStyle interface

AllColorsAsBlack

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

AllFillets

FilletConstantRadiusEdgeSet interface

AllLeafNodes

Leader interface

AllLeafOccurrences

ComponentOccurrences interface

AllMessages

ErrorManager interface

AllNodes

Leader interface

AllowAddRemove

BrowserFolder interface

AllowBrokenLeaders

OrdinateDimensionSet interface

AllowCommandAliases

InteractionEventsObject interface

AllowDelete

BrowserFolder interface

MiniToolbarListItem interface

AllowLandingLineForRevisionTags

RevisionTableStyle interface

AllowRename

BrowserFolder interface

AllowReorder

BrowserFolder interface

AllowSectioningThruPart

ModelingSettings interface

AllowSlicing

GraphicsNode interface

AllowSlopeAdjustment

BIMPipeConnectorDefinition interface

AllowTolerance2

FeatureControlFrameStyle interface

AllowToleranceEdit

MiniToolbarValueEditorObject interface

AllReferencedControls

UserInterfaceManager interface

AllReferencedDocuments

ApprenticeServerDocument interface

Document interface

AllReferencedFiles

File interface

AllReferencedNodes

BrowserNode interface

AllReferencedOccurrences

ComponentOccurrences interface

AllRounds

FilletConstantRadiusEdgeSet interface

AllWorkFeatures

ObjectVisibility interface

AlternateBody

Face interface

SurfaceBody interface

AlternateDecimalMarkerType

DimensionStyle interface

FeatureControlFrameStyle interface

AlternateDisplayFormat

DimensionStyle interface

AlternateDisplayUnitType

DimensionStyle interface

FeatureControlFrameStyle interface

AlternateFractionalTextScale

DimensionStyle interface

AlternateIncludedZeroDisplay

DimensionStyle interface

AlternateLeaderStyle

BalloonStyle interface

AlternateLeadingZeroDisplay

DimensionStyle interface

FeatureControlFrameStyle interface

AlternateLinearPrecision

DimensionStyle interface

FeatureControlFrameStyle interface

AlternateLinearUnits

DimensionStyle interface

FeatureControlFrameStyle interface

AlternateStyleFormat

DimensionStyle interface

AlternateTrailingZeroDisplay

DimensionStyle interface

FeatureControlFrameStyle interface

AlternateUnitsDisplay

FeatureControlFrameStyle interface

AlternateUnitsDisplayType

FeatureControlFrameStyle interface

AlwaysUseBitmapsForShadedViews

DrawingSettings interface

Ambience

LightingStyle interface

AmbientShadowIntensity

LightingStyle interface

AnalysisManager

PartComponentDefinition interface

AnalysisManager interface

ActiveAnalysis

ActiveAnalysisType

Application

DraftAnalyses

IsAnalysisVisible

Parent

Type

AnalysisManager.ActiveAnalysis property

AnalysisManager.ActiveAnalysisType property

AnalysisManager.Application property

AnalysisManager.DraftAnalyses property

AnalysisManager.IsAnalysisVisible property

AnalysisManager.Parent property

AnalysisManager.Type property

AnalyticEdgeWorkAxisDef interface

Application

Edge

Parent

Type

AnalyticEdgeWorkAxisDef.Application property

AnalyticEdgeWorkAxisDef.Edge property

AnalyticEdgeWorkAxisDef.Parent property

AnalyticEdgeWorkAxisDef.Type property

AnalyzeInterference

AssemblyComponentDefinition interface

Anchor

TextGraphics interface

Anchored

GraphicsPrimitive interface

AnchorPoints

DimensionConstraint interface

DimensionConstraint3D interface

FeatureDimension interface

Angle

AngleConstraint interface

AngleExtent interface

AngleiMateDefinition interface

CircularPatternFeature interface

DistanceAndAngleChamferDef interface

FlatBendResult interface

FlatPunchResult interface

LinePlaneAndAngleWorkPlaneDef interface

PunchToolFeature interface

RolledHemDefinition interface

TeardropHemDefinition interface

AngleConstraint interface

Angle

ConstraintLimits

Directed

DirectionOneReversed

DirectionTwoReversed

ReferenceVectorEntity

SolutionType

AngleConstraint.Angle property

AngleConstraint.ConstraintLimits property

AngleConstraint.Directed method

AngleConstraint.DirectionOneReversed method

AngleConstraint.DirectionTwoReversed method

AngleConstraint.ReferenceVectorEntity property

AngleConstraint.SolutionType property

AngleConstraintProxy interface

ContainingOccurrence

NativeObject

AngleConstraintProxy.ContainingOccurrence property

AngleConstraintProxy.NativeObject property

AngleDisplayPrecision

UnitsOfMeasure interface

AngleExtent interface

Angle

Direction

AngleExtent.Angle property

AngleExtent.Direction property

AngleiMateDefinition interface

Angle

DirectionOneReversed

Entity

AngleiMateDefinition.Angle property

AngleiMateDefinition.DirectionOneReversed property

AngleiMateDefinition.Entity property

AngleiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

AngleiMateDefinitionProxy.ContainingOccurrence property

AngleiMateDefinitionProxy.IsConsumed property

AngleiMateDefinitionProxy.NativeObject property

AngleOffset

CircularOccurrencePattern interface

AngleTo

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

AngleUnits

UnitsOfMeasure interface

AngularDimensionLayer

ObjectDefaultsStyle interface

AngularDimensionPrecision

Parameters interface

AngularDimensionStyle

ObjectDefaultsStyle interface

AngularGeneralDimension interface

AngularPrecision

CenterText

ExtensionLineOne

ExtensionLineOneVisible

ExtensionLineTwo

ExtensionLineTwoVisible

IntentOne

IntentThree

IntentTwo

OppositeAngle

ShowLeader

ToleranceAngularPrecision

UseQuadrant

AngularGeneralDimension.AngularPrecision property

AngularGeneralDimension.CenterText method

AngularGeneralDimension.ExtensionLineOne property

AngularGeneralDimension.ExtensionLineOneVisible property

AngularGeneralDimension.ExtensionLineTwo property

AngularGeneralDimension.ExtensionLineTwoVisible property

AngularGeneralDimension.IntentOne property

AngularGeneralDimension.IntentThree property

AngularGeneralDimension.IntentTwo property

AngularGeneralDimension.OppositeAngle property

AngularGeneralDimension.ShowLeader property

AngularGeneralDimension.ToleranceAngularPrecision property

AngularGeneralDimension.UseQuadrant property

AngularPrecision

AngularGeneralDimension interface

DimensionStyle interface

AngularStandardTolerance

Parameters interface

Animation coclass

AnimationFavorites

IAnimationManager interface

AnimationFavorites coclass

AnimationManager

IInventorStudio interface

AnimationManager coclass

Animations

IAnimationManager interface

Animations coclass

AnnotationScale

GeneralOptions interface

AntiAliasing

IRenderManager interface

ApparentLoad

BIMElectricalConnectorDefinition interface

ApparentLoadPhase1

BIMElectricalConnectorDefinition interface

ApparentLoadPhase2

BIMElectricalConnectorDefinition interface

ApparentLoadPhase3

BIMElectricalConnectorDefinition interface

Application

AliasFreeformFeatures interface

AnalysisManager interface

AnalyticEdgeWorkAxisDef interface

ApplicationAddIn interface

ApplicationAddInSite interface

ApplicationEventsObject interface

AssemblyComponentDefinitions interface

AssemblyConstraint interface

AssemblyConstraints interface

AssemblyEventsObject interface

AssemblyOptions interface

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

AssemblyWorkPointDef interface

AutoCADBlock interface

AutoCADBlockDefinition interface

AutoCADBlockDefinitions interface

AutoCADBlockDefinitionsEnumerator interface

AutoCADBlocks interface

AutomatedCenterlineSettings interface

Balloon interface

Balloons interface

BalloonStylesEnumerator interface

BalloonTipObject interface

BalloonTips interface

BalloonValueSet interface

BalloonValueSets interface

BaselineDimensionSet interface

BaselineDimensionSets interface

Bend interface

BendDefinition interface

BendFeatures interface

BendNotes interface

BendPartFeatures interface

BendsEnumerator interface

BIMComponent interface

BIMComponentDescription interface

BIMComponentProperty interface

BIMComponentPropertySet interface

BIMComponentPropertySets interface

BIMConnector interface

BIMConnectorDefinition interface

BIMConnectorLink interface

BIMConnectorLinks interface

BIMConnectors interface

BOM interface

BOMQuantity interface

BOMRow interface

BOMRowsEnumerator interface

BOMView interface

BOMViews interface

Border interface

BorderDefinition interface

BorderDefinitions interface

BossFeatures interface

BossSet interface

BossSets interface

BoundaryPatchDefinition interface

BoundaryPatchFeatures interface

BoundaryPatchLoop interface

BoundaryPatchLoops interface

BreakOperation interface

BreakOperations interface

BreakOutOperation interface

BreakOutOperations interface

BrowserFolder interface

BrowserFoldersEnumerator interface

BrowserNode interface

BrowserNodeDefinition interface

BrowserNodesEnumerator interface

BrowserPaneObject interface

BrowserPanes interface

CameraEventsObject interface

Cell interface

Centerline interface

Centerlines interface

Centermark interface

Centermarks interface

CentermarkStylesEnumerator interface

CentroidWorkPointDef interface

ChainDimensionSet interface

ChainDimensionSets interface

ChamferDefinition interface

ChamferFeatures interface

ChamferNotes interface

ChangeDefinitionObject interface

ChangeDefinitions interface

ChangeManager interface

ChangeProcessorObject interface

CheckPoint interface

CircularPatternFeatures interface

ClientFeatureDefinition interface

ClientFeatureElement interface

ClientFeatureElements interface

ClientFeatures interface

ClientGraphics interface

ClientGraphicsCollection interface

ClientNodeResource interface

ClientNodeResources interface

ClientView interface

ClientViews interface

CoilFeatures interface

ColorScheme interface

ColorSchemes interface

Column interface

Columns interface

CombineFeatures interface

CommandBar interface

CommandBarControl interface

CommandBarControls interface

CommandBarList interface

CommandBars interface

CommandCategories interface

CommandCategory interface

CommandControl interface

CommandControls interface

CommandControlsEnumerator interface

ComponentDefinition interface

ComponentOccurrence interface

ConstraintLimits interface

ContentCenter interface

ContentCenterOptions interface

ContentFamiliesEnumerator interface

ContentFamily interface

ContentTableCell interface

ContentTableColumn interface

ContentTableColumns interface

ContentTableRow interface

ContentTableRows interface

ContentTreeViewNode interface

ContentTreeViewNodesEnumerator interface

ContourFlangeDefinition interface

ContourFlangeFeatures interface

ContourRollFeatures interface

ControlDefinition interface

ControlDefinitionEventsObject interface

ControlDefinitions interface

CoreCavityDefinition interface

CoreCavityFeatures interface

CornerChamferDefinition interface

CornerChamferFeatures interface

CornerDefinition interface

CornerFeatures interface

CornerRoundDefinition interface

CornerRoundFeatures interface

CosmeticBendFeatures interface

CosmeticWelds interface

CurveAndEntityWorkPointDef interface

CustomParameterGroup interface

CustomParameterGroups interface

CustomPropertyFormat interface

CustomTable interface

CustomTables interface

CutDefinition interface

CutFeatures interface

DecalFeatures interface

DeleteFaceFeatures interface

DerivedAliasComponents interface

DerivedAssemblyComponents interface

DerivedAssemblyDefinition interface

DerivedAssemblyOccurrence interface

DerivedAssemblyOccurrences interface

DerivedPartComponents interface

DerivedPartDefinition interface

DerivedPartEntities interface

DerivedPartEntity interface

DesignProject interface

DesignProjectManager interface

DesignProjects interface

DesignViewRepresentation interface

DesignViewRepresentations interface

DimensionConstraint interface

DimensionConstraint3D interface

DimensionConstraints interface

DimensionConstraints3D interface

DimensionStylesEnumerator interface

DimensionText interface

DirectionAndDistanceMoveDefinition interface

DisabledCommandList interface

DisplayOptions interface

DisplaySettings interface

DockableWindow interface

DockableWindows interface

DockableWindowsEventsObject interface

DocumentDescriptor interface

DocumentDescriptorsEnumerator interface

DocumentEventsObject interface

DocumentInterest interface

DocumentInterests interface

DraftAnalyses interface

DraftAnalysis interface

DrawingBOM interface

DrawingBOMCell interface

DrawingBOMColumn interface

DrawingBOMColumns interface

DrawingBOMRow interface

DrawingBOMRows interface

DrawingBOMs interface

DrawingCurve interface

DrawingCurveSegment interface

DrawingCurveSegments interface

DrawingCurvesEnumerator interface

DrawingDimension interface

DrawingDimensions interface

DrawingEventsObject interface

DrawingNote interface

DrawingNotes interface

DrawingOptions interface

DrawingSettings interface

DrawingSketches interface

DrawingStandardStylesEnumerator interface

DrawingStylesManager interface

DrawingViewEventsObject interface

DrawingViewLabel interface

DriveConstraintSettingsObject interface

Edge interface

EdgeDefinition interface

EdgeDefinitions interface

EdgeLoop interface

EdgeLoopDefinition interface

EdgeLoopDefinitions interface

EdgeUse interface

EdgeUseDefinition interface

EdgeUseDefinitions interface

EmbossFeatures interface

EndOfFeatures interface

Environment interface

EnvironmentList interface

EnvironmentManager interface

Environments interface

ErrorManager interface

ExpressionLimits interface

ExpressionList interface

ExtendFeatures interface

ExtrudeDefinition interface

ExtrudeFeatures interface

Face interface

FaceDefinition interface

FaceDefinitions interface

FaceDraftFeatures interface

FaceFeatureDefinition interface

FaceFeatures interface

FaceShell interface

FaceShellDefinition interface

FaceShellDefinitions interface

FactoryOptions interface

FeatureControlFrame interface

FeatureControlFrameRow interface

FeatureControlFrameRows interface

FeatureControlFrames interface

FeatureControlFrameStylesEnumerator interface

FeatureDimension interface

FeatureDimensions interface

FeaturePatternElement interface

FeaturePatternElements interface

Features interface

File interface

FileAccessEventsObject interface

FileDescriptor interface

FileDescriptorsEnumerator interface

FileDialogEventsObject interface

FileManager interface

FileManagerEventsObject interface

FileOptions interface

FilesEnumerator interface

FileUIEventsObject interface

FilletConstantRadiusFaceSet interface

FilletDefinition interface

FilletFeatures interface

FilletFullRoundSet interface

FilletRadiusEdgeSet interface

FixedWorkAxisDef interface

FixedWorkPlaneDef interface

FixedWorkPointDef interface

FlangeDefinition interface

FlangeFeatures interface

FlatBendResult interface

FlatBendResults interface

FlatPatternFeatures interface

FlatPunchResult interface

FlatPunchResults interface

FoldDefinition interface

FoldFeatures interface

FreeMoveDefinition interface

GeneralDimensions interface

GeneralNotes interface

GeneralOptions interface

GeometricConstraint interface

GeometricConstraint3D interface

GeometricConstraints interface

GeometricConstraints3D interface

GeometryIntent interface

GraphicsDataSets interface

GraphicsDataSetsCollection interface

GraphicsNode interface

GraphicsPrimitive interface

GrillFeatures interface

GripSnapOptions interface

GroundPlaneSettings interface

HardwareOptions interface

HeadsUpDisplayOptions interface

HelpEventsObject interface

HemDefinition interface

HemFeatures interface

HoleFeatures interface

HolePlacementDefinition interface

HoleTable interface

HoleTableCell interface

HoleTableColumn interface

HoleTableColumns interface

HoleTableRow interface

HoleTableRows interface

HoleTables interface

HoleTableStylesEnumerator interface

HoleTag interface

HoleThreadNotes interface

iAssemblyFactory interface

iAssemblyMember interface

iAssemblyTableCell interface

iAssemblyTableColumn interface

iAssemblyTableColumns interface

iAssemblyTableRow interface

iAssemblyTableRows interface

iFeatureDefinition interface

iFeatureInput interface

iFeatureInputs interface

iFeatureOptions interface

iFeatures interface

iFeatureTable interface

iFeatureTableCell interface

iFeatureTableColumn interface

iFeatureTableColumns interface

iFeatureTableRow interface

iFeatureTableRows interface

iFeatureTemplateDescriptor interface

iFeatureTemplateDescriptors interface

iMateDefinition interface

iMateDefinitions interface

iMateResults interface

InteractionEventsObject interface

iPartFactory interface

iPartTableCell interface

iPartTableColumn interface

iPartTableColumns interface

iPartTableRow interface

iPartTableRows interface

KeyboardEventsObject interface

KnitFeatures interface

LanguageTools interface

LayersEnumerator interface

LayoutConstraint interface

Leader interface

LeaderNode interface

LeaderNodesEnumerator interface

LeaderNotes interface

LeaderStylesEnumerator interface

LevelOfDetailRepresentation interface

LevelOfDetailRepresentations interface

Light interface

LightingStyle interface

LightingStyles interface

Lights interface

LineAndPlaneWorkAxisDef interface

LineAndPointWorkAxisDef interface

LineAndTangentWorkPlaneDef interface

LinePlaneAndAngleWorkPlaneDef interface

LineWorkAxisDef interface

LipFeatures interface

LoftedFlangeDefinition interface

LoftedFlangeFeatures interface

LoftFeatures interface

LoftRail interface

LoftRails interface

LoftSectionDimension interface

LoftSectionDimensions interface

LumpDefinition interface

LumpDefinitions interface

Machining interface

MapPointCurve interface

MapPointCurves interface

Material interface

Materials interface

MaterialsEnumerator interface

MeasureEventsObject interface

MeasureTools interface

MessageSection interface

MidPointWorkPointDef interface

MiniToolbarControl interface

MiniToolbarControls interface

MiniToolbarObject interface

MirrorFeatures interface

ModelingEventsObject interface

ModelingSettings interface

MouseEventsObject interface

MoveFaceDefinition interface

MoveFaceFeatures interface

MoveFeatures interface

NonLinearEdgeWorkPointDef interface

NonParametricBaseFeatureDefinition interface

NonParametricBaseFeatures interface

NormalToCurveWorkPlaneDef interface

NormalToSurfaceWorkAxisDef interface

NotebookOptions interface

ObjectDefaultsStylesEnumerator interface

ObjectVisibility interface

OccurrencePattern interface

OccurrencePatternElement interface

OccurrencePatternElements interface

OccurrencePatterns interface

OrdinateDimensions interface

OrdinateDimensionSet interface

OrdinateDimensionSets interface

OriginIndicator interface

PanelBarObject interface

PartEventsObject interface

PartFeature interface

PartFeatureExtent interface

PartFeatures interface

PartOptions interface

PartsList interface

PartsListCell interface

PartsListColumn interface

PartsListColumns interface

PartsListRow interface

PartsListRows interface

PartsLists interface

PartsListStylesEnumerator interface

Path interface

PathEntity interface

PlanarMoveDefinition interface

PlanarSketches interface

PlaneAndOffsetWorkPlaneDef interface

PlaneAndPointWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

PointAndPlaneWorkAxisDef interface

PointAndTangentWorkPlaneDef interface

PointInference interface

PointWorkPointDef interface

PositionalRepresentation interface

PositionalRepresentations interface

Preparations interface

PresentationExplodedView interface

PresentationExplodedViews interface

PresentationOptions interface

PrintManager interface

Profile interface

Profile3D interface

ProfileEntity interface

ProfileEntity3D interface

ProfilePath interface

ProfilePath3D interface

Profiles interface

Profiles3D interface

ProgressBarObject interface

ProgressiveToolTip interface

ProjectedCut interface

ProjectedCuts interface

ProjectPath interface

ProjectPaths interface

PunchNotes interface

PunchToolFeatures interface

RadialMarkingMenu interface

RectangularPatternFeatures interface

ReferenceComponent interface

ReferenceComponents interface

ReferencedOLEFileDescriptor interface

ReferencedOLEFileDescriptors interface

ReferenceFeatures interface

ReferenceKeyEventsObject interface

ReferenceKeyManager interface

RefoldFeatures interface

RegionProperties interface

RenderStyle interface

RenderStyles interface

ReplaceFaceFeatures interface

RepresentationEventsObject interface

RepresentationsManager interface

RestFeatures interface

RevisionTable interface

RevisionTableCell interface

RevisionTableColumn interface

RevisionTableColumns interface

RevisionTableRow interface

RevisionTableRows interface

RevisionTables interface

RevisionTableStylesEnumerator interface

RevolvedFaceWorkAxisDef interface

RevolveFeatures interface

Ribbon interface

RibbonPanel interface

RibbonPanels interface

Ribbons interface

RibbonTab interface

RibbonTabs interface

RibDefinition interface

RibFeatures interface

RipDefinition interface

RipFeatures interface

Row interface

Rows interface

RuleFilletFeatures interface

SaveOptions interface

SculptFeatures interface

SelectEventsObject interface

ShadedDisplayOptions interface

Sheet interface

SheetFormat interface

SheetFormats interface

SheetMetalStyles interface

Sheets interface

SheetSettings interface

ShellDefinition interface

ShellFeatures interface

ShellThicknessFaceSet interface

SilhouetteCurve interface

SilhouetteCurves interface

Sketch interface

Sketch3D interface

Sketch3DOptions interface

Sketch3DSettings interface

SketchArcs interface

SketchArcs3D interface

SketchBlock interface

SketchBlockDefinitions interface

SketchBlocks interface

SketchCircles interface

SketchCircles3D interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchedSymbolDefinitions interface

SketchedSymbols interface

SketchEllipses interface

SketchEllipses3D interface

SketchEllipticalArcs interface

SketchEllipticalArcs3D interface

SketchEntity interface

SketchEntity3D interface

Sketches3D interface

SketchEventsObject interface

SketchFillRegion interface

SketchFillRegions interface

SketchFixedSplines interface

SketchFixedSplines3D interface

SketchImage interface

SketchImages interface

SketchLines interface

SketchLines3D interface

SketchOffsetSplines interface

SketchOptions interface

SketchPoints interface

SketchPoints3D interface

SketchSettings interface

SketchSplines interface

SketchSplines3D interface

SnapFitFeatures interface

SplitFeatures interface

Style interface

StyleEventsObject interface

Styles interface

StylesManager interface

SurfaceBody interface

SurfaceBodyDefinition interface

SurfaceGraphicsEdge interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFace interface

SurfaceGraphicsFaceList interface

SurfaceTextureStylesEnumerator interface

SurfaceTextureSymbol interface

SurfaceTextureSymbols interface

SweepDefinition interface

SweepFeatures interface

TableFormat interface

TableStylesEnumerator interface

TextBox interface

TextBoxes interface

TextStyles interface

TextStylesEnumerator interface

TextureCoordinateSet interface

TextureMap interface

TextureMaps interface

ThickenFeatures interface

ThreadFeatures interface

ThreadInfo interface

ThreadTableQuery interface

ThreePlanesWorkPointDef interface

ThreePointsWorkPlaneDef interface

TitleBlock interface

TitleBlockDefinition interface

TitleBlockDefinitions interface

TorusCenterPointWorkPointDef interface

TorusMidPlaneWorkPlaneDef interface

Trail interface

TrailSegment interface

TrailsEnumerator interface

Transaction interface

TransactionEventsObject interface

TransactionManager interface

TriadEventsObject interface

TrimFeatures interface

TwoLinesWorkPlaneDef interface

TwoLinesWorkPointDef interface

TwoPlanesWorkAxisDef interface

TwoPlanesWorkPlaneDef interface

TwoPointsWorkAxisDef interface

UnfoldFeatures interface

UnfoldMethods interface

UserCoordinateSystem interface

UserCoordinateSystemDefinition interface

UserCoordinateSystems interface

UserCoordinateSystemSettings interface

UserInputEventsObject interface

UserInterfaceEventsObject interface

UserInterfaceManager interface

Vertex interface

VertexDefinition interface

VertexDefinitions interface

View interface

Weld interface

WeldBeads interface

Welds interface

Wire interface

WireframeDisplayOptions interface

WorkAxes interface

WorkAxis interface

WorkPlane interface

WorkPlanes interface

WorkPoint interface

WorkPoints interface

WorkSurface interface

WorkSurfaces interface

Application interface

ActiveColorScheme

ActiveDocument

ActiveDocumentType

ActiveEditDocument

ActiveEditObject

ActiveView

CameraEvents

Caption

ColorSchemes

CommandManager

CreateFileDialog

CreateProgressBar

FileUIEvents

GetAppFrameExtents

HardwareOptions

Height

HelpManager

Left

Login

MainFrameHWND

Move

MRUDisplay

MRUEnabled

OpenDocumentsDisplay

Quit

ScreenUpdating

SilentOperation

StatusBarText

Top

UserInterfaceManager

Views

Visible

Width

WindowState

Application.ActiveColorScheme property

Application.ActiveDocument property

Application.ActiveDocumentType property

Application.ActiveEditDocument property

Application.ActiveEditObject property

Application.ActiveView property

Application.CameraEvents property

Application.Caption property

Application.ColorSchemes property

Application.CommandManager property

Application.CreateFileDialog method

Application.CreateProgressBar method

Application.FileUIEvents property

Application.GetAppFrameExtents method

Application.HardwareOptions property

Application.Height property

Application.HelpManager property

Application.Left property

Application.Login method

Application.MainFrameHWND property

Application.Move method

Application.MRUDisplay property

Application.MRUEnabled property

Application.OpenDocumentsDisplay property

Application.Quit method

Application.ScreenUpdating property

Application.SilentOperation property

Application.StatusBarText property

Application.Top property

Application.UserInterfaceManager property

Application.Views property

Application.Visible property

Application.Width property

Application.WindowState property

ApplicationAddIn interface

Activate

Activated

AddInType

Application

Automation

ClassIdString

ClientId

DataVersion

Deactivate

Description

DisplayName

Hidden

LicenseStatus

LoadAutomatically

LoadBehavior

Location

Parent

ProgId

ShortDisplayName

StartUpEnabled

Type

UserInterfaceVersion

UserUnloadable

Version

ApplicationAddIn.Activate method

ApplicationAddIn.Activated property

ApplicationAddIn.AddInType property

ApplicationAddIn.Application property

ApplicationAddIn.Automation property

ApplicationAddIn.ClassIdString property

ApplicationAddIn.ClientId property

ApplicationAddIn.DataVersion property

ApplicationAddIn.Deactivate method

ApplicationAddIn.Description property

ApplicationAddIn.DisplayName property

ApplicationAddIn.Hidden property

ApplicationAddIn.LicenseStatus property

ApplicationAddIn.LoadAutomatically property

ApplicationAddIn.LoadBehavior property

ApplicationAddIn.Location property

ApplicationAddIn.Parent property

ApplicationAddIn.ProgId property

ApplicationAddIn.ShortDisplayName property

ApplicationAddIn.StartUpEnabled method

ApplicationAddIn.Type property

ApplicationAddIn.UserInterfaceVersion property

ApplicationAddIn.UserUnloadable property

ApplicationAddIn.Version method

ApplicationAddIns

ApprenticeServer interface

ApplicationAddIns interface

Count

Item

ItemById

Type

ApplicationAddIns.Count property

ApplicationAddIns.Item method

ApplicationAddIns.ItemById method

ApplicationAddIns.Type property

ApplicationAddInServer interface

Activate

Automation

Deactivate

ExecuteCommand

ApplicationAddInServer.Activate method

ApplicationAddInServer.Automation property

ApplicationAddInServer.Deactivate method

ApplicationAddInServer.ExecuteCommand method

ApplicationAddInSite interface

Application

InventorServer

LicenseChallenge

LicenseResponse

Parent

Type

ApplicationAddInSite.Application property

ApplicationAddInSite.InventorServer method

ApplicationAddInSite.LicenseChallenge method

ApplicationAddInSite.LicenseResponse method

ApplicationAddInSite.Parent property

ApplicationAddInSite.Type property

ApplicationEvents coclass

ApplicationEventsObject interface

Application

Parent

Type

ApplicationEventsObject.Application property

ApplicationEventsObject.Parent property

ApplicationEventsObject.Type property

ApplicationEventsSink interface

OnActivateDocument

OnActivateView

OnActiveProjectChanged

OnApplicationOptionChange

OnCloseDocument

OnCloseView

OnDeactivateDocument

OnDeactivateView

OnDisplayModeChange

OnDocumentChange

OnInitializeDocument

OnMigrateDocument

OnNewDocument

OnNewEditObject

OnNewView

OnOpenDocument

OnQuit

OnReady

OnRestart32BitHost

OnSaveDocument

OnTerminateDocument

OnTranslateDocument

ApplicationEventsSink.OnActivateDocument method

ApplicationEventsSink.OnActivateView method

ApplicationEventsSink.OnActiveProjectChanged method

ApplicationEventsSink.OnApplicationOptionChange method

ApplicationEventsSink.OnCloseDocument method

ApplicationEventsSink.OnCloseView method

ApplicationEventsSink.OnDeactivateDocument method

ApplicationEventsSink.OnDeactivateView method

ApplicationEventsSink.OnDisplayModeChange method

ApplicationEventsSink.OnDocumentChange method

ApplicationEventsSink.OnInitializeDocument method

ApplicationEventsSink.OnMigrateDocument method

ApplicationEventsSink.OnNewDocument method

ApplicationEventsSink.OnNewEditObject method

ApplicationEventsSink.OnNewView method

ApplicationEventsSink.OnOpenDocument method

ApplicationEventsSink.OnQuit method

ApplicationEventsSink.OnReady method

ApplicationEventsSink.OnRestart32BitHost method

ApplicationEventsSink.OnSaveDocument method

ApplicationEventsSink.OnTerminateDocument method

ApplicationEventsSink.OnTranslateDocument method

ApplicationFrameColor

ColorSchemes interface

Apply

Camera interface

ApplyAutoMitering

ContourFlangeDefinition interface

FlangeDefinition interface

ApplyExcludeCharactersToBendTables

DrawingStandardStyle interface

ApplyExcludeCharactersToHoleTables

DrawingStandardStyle interface

ApplyExcludeCharactersToRevisionTables

DrawingStandardStyle interface

ApplyExcludeCharactersToViewNames

DrawingStandardStyle interface

ApplyToAllMembers

FactoryOptions interface

ApplyToBends

AutomatedCenterlineSettings interface

ApplyToCircularPatterns

AutomatedCenterlineSettings interface

ApplyToCylinders

AutomatedCenterlineSettings interface

ApplyToFillets

AutomatedCenterlineSettings interface

ApplyToHoles

AutomatedCenterlineSettings interface

ApplyToPunches

AutomatedCenterlineSettings interface

ApplyToRectangularPatterns

AutomatedCenterlineSettings interface

ApplyToRevolutions

AutomatedCenterlineSettings interface

ApplyToSketches

AutomatedCenterlineSettings interface

ApplyToWorkFeatures

AutomatedCenterlineSettings interface

ApplyWithoutTransition

Camera interface

ApprenticeDrawingPrintManager interface

AllColorsAsBlack

GetSheetRange

PrintExcludedSheets

PrintRange

RemoveLineWeights

Rotate90Degrees

Scale

ScaleMode

SetSheetRange

ApprenticeDrawingPrintManager.AllColorsAsBlack property

ApprenticeDrawingPrintManager.GetSheetRange method

ApprenticeDrawingPrintManager.PrintExcludedSheets property

ApprenticeDrawingPrintManager.PrintRange property

ApprenticeDrawingPrintManager.RemoveLineWeights property

ApprenticeDrawingPrintManager.Rotate90Degrees property

ApprenticeDrawingPrintManager.Scale property

ApprenticeDrawingPrintManager.ScaleMode property

ApprenticeDrawingPrintManager.SetSheetRange method

ApprenticePrintManager interface

ColorMode

NumberOfCopies

Orientation

PaperHeight

PaperSize

PaperSource

PaperWidth

Printer

PrinterDeviceContext

PrintToFile

SetCurrentView

SubmitPrint

Type

ApprenticePrintManager.ColorMode property

ApprenticePrintManager.NumberOfCopies property

ApprenticePrintManager.Orientation property

ApprenticePrintManager.PaperHeight property

ApprenticePrintManager.PaperSize property

ApprenticePrintManager.PaperSource property

ApprenticePrintManager.PaperWidth property

ApprenticePrintManager.Printer property

ApprenticePrintManager.PrinterDeviceContext property

ApprenticePrintManager.PrintToFile method

ApprenticePrintManager.SetCurrentView method

ApprenticePrintManager.SubmitPrint method

ApprenticePrintManager.Type property

ApprenticeServer interface

ApplicationAddIns

Close

DesignProjectManager

DisplayAffinity

DisplayOptions

Document

FileAccessEvents

FileLocations

FileManager

FileOptions

FileSaveAs

HardwareOptions

InstallPath

Locale

MultiUserExternallyManaged

MultiUserMode

Open

OpenWithOptions

ReferenceKeyEvents

SoftwareVersion

TransientGeometry

TransientObjects

Type

UserName

ApprenticeServer.ApplicationAddIns property

ApprenticeServer.Close method

ApprenticeServer.DesignProjectManager property

ApprenticeServer.DisplayAffinity property

ApprenticeServer.DisplayOptions property

ApprenticeServer.Document property

ApprenticeServer.FileAccessEvents method

ApprenticeServer.FileLocations method

ApprenticeServer.FileManager property

ApprenticeServer.FileOptions property

ApprenticeServer.FileSaveAs property

ApprenticeServer.HardwareOptions property

ApprenticeServer.InstallPath property

ApprenticeServer.Locale property

ApprenticeServer.MultiUserExternallyManaged property

ApprenticeServer.MultiUserMode property

ApprenticeServer.Open method

ApprenticeServer.OpenWithOptions method

ApprenticeServer.ReferenceKeyEvents method

ApprenticeServer.SoftwareVersion property

ApprenticeServer.TransientGeometry property

ApprenticeServer.TransientObjects property

ApprenticeServer.Type property

ApprenticeServer.UserName property

ApprenticeServerComponent coclass

ApprenticeServerDocument interface

ActiveRenderStyle

AllReferencedDocuments

AttributeManager

AttributeSets

ClientViews

Close

Compacted

ComponentDefinition

CreateHighlightSet

DatabaseRevisionId

Dirty

DisplayName

DocumentInterests

DocumentType

File

FileSaveCounter

FindWhereUsed

FullDocumentName

FullFileName

GetLocationFoundIn

HealthStatus

InternalName

IsModifiable

IsSubstitutePart

NeedsMigrating

Open

PrintManager

PropertySets

ReferencedDocumentDescriptors

ReferencedDocuments

ReferencedOLEFileDescriptors

ReferenceKeyManager

ReferencingDocuments

RequiresUpdate

ReservedForWrite

ReservedForWriteByMe

ReservedForWriteLogin

ReservedForWriteName

ReservedForWriteTime

ReservedForWriteVersion

RevertReservedForWriteByMe

RevisionId

SoftwareVersionCreated

SoftwareVersionSaved

SubstitutePartStatus

Thumbnail

Type

UnitsOfMeasure

ApprenticeServerDocument.ActiveRenderStyle property

ApprenticeServerDocument.AllReferencedDocuments property

ApprenticeServerDocument.AttributeManager property

ApprenticeServerDocument.AttributeSets property

ApprenticeServerDocument.ClientViews property

ApprenticeServerDocument.Close method

ApprenticeServerDocument.Compacted property

ApprenticeServerDocument.ComponentDefinition property

ApprenticeServerDocument.CreateHighlightSet method

ApprenticeServerDocument.DatabaseRevisionId property

ApprenticeServerDocument.Dirty property

ApprenticeServerDocument.DisplayName property

ApprenticeServerDocument.DocumentInterests property

ApprenticeServerDocument.DocumentType property

ApprenticeServerDocument.File property

ApprenticeServerDocument.FileSaveCounter property

ApprenticeServerDocument.FindWhereUsed method

ApprenticeServerDocument.FullDocumentName property

ApprenticeServerDocument.FullFileName property

ApprenticeServerDocument.GetLocationFoundIn method

ApprenticeServerDocument.HealthStatus property

ApprenticeServerDocument.InternalName property

ApprenticeServerDocument.IsModifiable property

ApprenticeServerDocument.IsSubstitutePart property

ApprenticeServerDocument.NeedsMigrating property

ApprenticeServerDocument.Open property

ApprenticeServerDocument.PrintManager property

ApprenticeServerDocument.PropertySets property

ApprenticeServerDocument.ReferencedDocumentDescriptors property

ApprenticeServerDocument.ReferencedDocuments property

ApprenticeServerDocument.ReferencedOLEFileDescriptors property

ApprenticeServerDocument.ReferenceKeyManager property

ApprenticeServerDocument.ReferencingDocuments property

ApprenticeServerDocument.RequiresUpdate property

ApprenticeServerDocument.ReservedForWrite property

ApprenticeServerDocument.ReservedForWriteByMe property

ApprenticeServerDocument.ReservedForWriteLogin property

ApprenticeServerDocument.ReservedForWriteName property

ApprenticeServerDocument.ReservedForWriteTime property

ApprenticeServerDocument.ReservedForWriteVersion property

ApprenticeServerDocument.RevertReservedForWriteByMe method

ApprenticeServerDocument.RevisionId property

ApprenticeServerDocument.SoftwareVersionCreated property

ApprenticeServerDocument.SoftwareVersionSaved property

ApprenticeServerDocument.SubstitutePartStatus property

ApprenticeServerDocument.Thumbnail property

ApprenticeServerDocument.Type property

ApprenticeServerDocument.UnitsOfMeasure property

ApprenticeServerDocuments interface

Count

Item

Type

ApprenticeServerDocuments.Count property

ApprenticeServerDocuments.Item method

ApprenticeServerDocuments.Type property

ApprenticeServerDrawingDocument interface

ActiveStandard

ContainingDWGDocument

IsInventorDWG

Sheets

ApprenticeServerDrawingDocument.ActiveStandard property

ApprenticeServerDrawingDocument.ContainingDWGDocument property

ApprenticeServerDrawingDocument.IsInventorDWG property

ApprenticeServerDrawingDocument.Sheets property

ApproximateFromRealisticAppearance

RenderStyle interface

ApproximationOptimized

ShellDefinition interface

ThickenFeature interface

ApproximationTolerance

ShellDefinition interface

ThickenFeature interface

ApproximationType

ShellDefinition interface

ThickenFeature interface

Arc

BendConstraint interface

Arc2d interface

Center

EndPoint

Evaluator

GetArcData

PutArcData

Radius

StartAngle

StartPoint

SweepAngle

Arc2d.Center property

Arc2d.EndPoint property

Arc2d.Evaluator property

Arc2d.GetArcData method

Arc2d.PutArcData method

Arc2d.Radius property

Arc2d.StartAngle property

Arc2d.StartPoint property

Arc2d.SweepAngle property

Arc3d interface

Center

EndPoint

Evaluator

GetArcData

Normal

PutArcData

Radius

ReferenceVector

StartAngle

StartPoint

SweepAngle

Arc3d.Center property

Arc3d.EndPoint property

Arc3d.Evaluator property

Arc3d.GetArcData method

Arc3d.Normal property

Arc3d.PutArcData method

Arc3d.Radius property

Arc3d.ReferenceVector property

Arc3d.StartAngle property

Arc3d.StartPoint property

Arc3d.SweepAngle property

ArcAngleThreshold

AutomatedCenterlineSettings interface

ArcDimensionType

DrawingOptions interface

Area

MassProperties interface

RegionProperties interface

SketchCircle interface

SketchCircle3D interface

SketchEllipse interface

SketchEllipse3D interface

SurfaceEvaluator interface

Arguments

InventorVBAMember interface

ArgumentType

InventorVBAArgument interface

Arrange

ChainDimensionSet interface

DrawingDimensions interface

ArrangeByPosition

HoleTable interface

HoleTableStyle interface

ArrangeText

BaselineDimensionSet interface

ArrowColor

NotebookOptions interface

ArrowheadHeight

DimensionStyle interface

LeaderStyle interface

ArrowheadsInside

GeneralDimension interface

ArrowheadSize

DimensionStyle interface

LeaderStyle interface

ArrowheadType

DimensionStyle interface

Leader interface

LeaderStyle interface

ArrowheadTypeForChainDimensions

DimensionStyle interface

AssemblyComponentDefinition interface

ActiveOccurrence

AdjustProxyContext

AnalyzeInterference

AssemblyEvents

BIMComponent

BOM

Constraints

CreateFactory

DefaultMaterial

ExportObjects

Features

FindUsingRay

GetEndOfFeaturesPosition

iAssemblyFactory

iAssemblyMember

iMateDefinitions

iMateResults

IsiAssemblyFactory

IsiAssemblyMember

MassProperties

OccurrencePatterns

Parameters

Parent

RepresentationsManager

SetEndOfFeaturesToTopOrBottom

Sketches

SuppressFeatures

TransformOccurrences

UnsuppressFeatures

UserCoordinateSystems

WorkAxes

WorkPlanes

WorkPoints

AssemblyComponentDefinition.ActiveOccurrence property

AssemblyComponentDefinition.AdjustProxyContext method

AssemblyComponentDefinition.AnalyzeInterference method

AssemblyComponentDefinition.AssemblyEvents property

AssemblyComponentDefinition.BIMComponent property

AssemblyComponentDefinition.BOM property

AssemblyComponentDefinition.Constraints property

AssemblyComponentDefinition.CreateFactory method

AssemblyComponentDefinition.DefaultMaterial property

AssemblyComponentDefinition.ExportObjects method

AssemblyComponentDefinition.Features property

AssemblyComponentDefinition.FindUsingRay method

AssemblyComponentDefinition.GetEndOfFeaturesPosition method

AssemblyComponentDefinition.iAssemblyFactory property

AssemblyComponentDefinition.iAssemblyMember property

AssemblyComponentDefinition.iMateDefinitions property

AssemblyComponentDefinition.iMateResults property

AssemblyComponentDefinition.IsiAssemblyFactory property

AssemblyComponentDefinition.IsiAssemblyMember property

AssemblyComponentDefinition.MassProperties property

AssemblyComponentDefinition.OccurrencePatterns property

AssemblyComponentDefinition.Parameters property

AssemblyComponentDefinition.Parent property

AssemblyComponentDefinition.RepresentationsManager property

AssemblyComponentDefinition.SetEndOfFeaturesToTopOrBottom method

AssemblyComponentDefinition.Sketches property

AssemblyComponentDefinition.SuppressFeatures method

AssemblyComponentDefinition.TransformOccurrences method

AssemblyComponentDefinition.UnsuppressFeatures method

AssemblyComponentDefinition.UserCoordinateSystems property

AssemblyComponentDefinition.WorkAxes property

AssemblyComponentDefinition.WorkPlanes property

AssemblyComponentDefinition.WorkPoints property

AssemblyComponentDefinitions interface

Application

Count

Item

Parent

Type

AssemblyComponentDefinitions.Application property

AssemblyComponentDefinitions.Count property

AssemblyComponentDefinitions.Item method

AssemblyComponentDefinitions.Parent property

AssemblyComponentDefinitions.Type property

AssemblyConstraint interface

AffectedOccurrenceOne

AffectedOccurrenceTwo

Application

AttributeSets

ConvertToAngleConstraint

ConvertToCustomConstraint

ConvertToFlushConstraint

ConvertToInsertConstraint

ConvertToMateConstraint

ConvertToRotateRotateConstraint

ConvertToRotateTranslateConstraint

ConvertToTangentConstraint

ConvertToTransitionalConstraint

Delete

DriveConstraintSettings

EntityOne

EntityTwo

GeometryOne

GeometryTwo

GetReferenceKey

HealthStatus

iMateResult

LayoutConstraint

Name

OccurrenceOne

OccurrenceTwo

Parent

ResultOfiMate

ResultOfLayoutConstraint

Suppressed

Type

AssemblyConstraint.AffectedOccurrenceOne property

AssemblyConstraint.AffectedOccurrenceTwo property

AssemblyConstraint.Application property

AssemblyConstraint.AttributeSets property

AssemblyConstraint.ConvertToAngleConstraint method

AssemblyConstraint.ConvertToCustomConstraint method

AssemblyConstraint.ConvertToFlushConstraint method

AssemblyConstraint.ConvertToInsertConstraint method

AssemblyConstraint.ConvertToMateConstraint method

AssemblyConstraint.ConvertToRotateRotateConstraint method

AssemblyConstraint.ConvertToRotateTranslateConstraint method

AssemblyConstraint.ConvertToTangentConstraint method

AssemblyConstraint.ConvertToTransitionalConstraint method

AssemblyConstraint.Delete method

AssemblyConstraint.DriveConstraintSettings property

AssemblyConstraint.EntityOne property

AssemblyConstraint.EntityTwo property

AssemblyConstraint.GeometryOne property

AssemblyConstraint.GeometryTwo property

AssemblyConstraint.GetReferenceKey method

AssemblyConstraint.HealthStatus property

AssemblyConstraint.iMateResult property

AssemblyConstraint.LayoutConstraint property

AssemblyConstraint.Name property

AssemblyConstraint.OccurrenceOne property

AssemblyConstraint.OccurrenceTwo property

AssemblyConstraint.Parent property

AssemblyConstraint.ResultOfiMate property

AssemblyConstraint.ResultOfLayoutConstraint property

AssemblyConstraint.Suppressed property

AssemblyConstraint.Type property

AssemblyConstraints interface

AddAngleConstraint

AddCustomConstraint

AddFlushConstraint

AddInsertConstraint

AddMateConstraint

AddRotateRotateConstraint

AddRotateTranslateConstraint

AddTangentConstraint

AddTransitionalConstraint

Application

Count

Item

Parent

Type

AssemblyConstraints.AddAngleConstraint method

AssemblyConstraints.AddCustomConstraint method

AssemblyConstraints.AddFlushConstraint method

AssemblyConstraints.AddInsertConstraint method

AssemblyConstraints.AddMateConstraint method

AssemblyConstraints.AddRotateRotateConstraint method

AssemblyConstraints.AddRotateTranslateConstraint method

AssemblyConstraints.AddTangentConstraint method

AssemblyConstraints.AddTransitionalConstraint method

AssemblyConstraints.Application property

AssemblyConstraints.Count property

AssemblyConstraints.Item method

AssemblyConstraints.Parent property

AssemblyConstraints.Type property

AssemblyConstraintsEnumerator interface

Count

Item

Type

AssemblyConstraintsEnumerator.Count property

AssemblyConstraintsEnumerator.Item method

AssemblyConstraintsEnumerator.Type property

AssemblyDocument interface

ActiveLightingStyle

ComponentDefinition

DesignViewInfo

DisabledCommandList

DisplaySettings

EnvironmentManager

GetSelectedObject

LevelOfDetailName

LightingStyles

Materials

ModelingSettings

ObjectVisibility

SketchSettings

AssemblyDocument.ActiveLightingStyle property

AssemblyDocument.ComponentDefinition property

AssemblyDocument.DesignViewInfo property

AssemblyDocument.DisabledCommandList property

AssemblyDocument.DisplaySettings property

AssemblyDocument.EnvironmentManager property

AssemblyDocument.GetSelectedObject method

AssemblyDocument.LevelOfDetailName property

AssemblyDocument.LightingStyles property

AssemblyDocument.Materials property

AssemblyDocument.ModelingSettings property

AssemblyDocument.ObjectVisibility property

AssemblyDocument.SketchSettings property

AssemblyEvents

AssemblyComponentDefinition interface

AssemblyEvents coclass

AssemblyEventsObject interface

Application

Parent

Type

AssemblyEventsObject.Application property

AssemblyEventsObject.Parent property

AssemblyEventsObject.Type property

AssemblyEventsSink interface

OnAssemblyChange

OnAssemblyChanged

OnDelete

OnNewConstraint

OnNewOccurrence

OnOccurrenceChange

AssemblyEventsSink.OnAssemblyChange method

AssemblyEventsSink.OnAssemblyChanged method

AssemblyEventsSink.OnDelete method

AssemblyEventsSink.OnNewConstraint method

AssemblyEventsSink.OnNewOccurrence method

AssemblyEventsSink.OnOccurrenceChange method

AssemblyOptions interface

Application

ConstraintAudioNotification

DeferUpdate

DeleteComponentPatternSources

DisplayComponentNamesInConstraints

EnableConstraintRedundancyAnalysis

EnableCrossPartEdgeLoopProjection

EnableRelatedConstraintFailureAnalysis

FromToExtentsAdaptFeature

FromToExtentsMatePlane

OnlyActiveComponentIsOpaque

PartFeaturesInitiallyAdaptive

SectionAllParts

Type

UseiMate

UseLastOccurrenceOrientationForPlacement

ZoomTargetComponentWithiMate

AssemblyOptions.Application property

AssemblyOptions.ConstraintAudioNotification property

AssemblyOptions.DeferUpdate property

AssemblyOptions.DeleteComponentPatternSources property

AssemblyOptions.DisplayComponentNamesInConstraints property

AssemblyOptions.EnableConstraintRedundancyAnalysis property

AssemblyOptions.EnableCrossPartEdgeLoopProjection property

AssemblyOptions.EnableRelatedConstraintFailureAnalysis property

AssemblyOptions.FromToExtentsAdaptFeature property

AssemblyOptions.FromToExtentsMatePlane property

AssemblyOptions.OnlyActiveComponentIsOpaque property

AssemblyOptions.PartFeaturesInitiallyAdaptive property

AssemblyOptions.SectionAllParts property

AssemblyOptions.Type property

AssemblyOptions.UseiMate method

AssemblyOptions.UseLastOccurrenceOrientationForPlacement property

AssemblyOptions.ZoomTargetComponentWithiMate property

AssemblyWorkAxisDef interface

Application

Axis

Constraints

GetData

OriginPoint

Parent

PutData

Type

AssemblyWorkAxisDef.Application property

AssemblyWorkAxisDef.Axis property

AssemblyWorkAxisDef.Constraints property

AssemblyWorkAxisDef.GetData method

AssemblyWorkAxisDef.OriginPoint property

AssemblyWorkAxisDef.Parent property

AssemblyWorkAxisDef.PutData method

AssemblyWorkAxisDef.Type property

AssemblyWorkPlaneDef interface

Application

Constraints

GetData

OriginPoint

Parent

PutData

Type

XAxis

YAxis

AssemblyWorkPlaneDef.Application property

AssemblyWorkPlaneDef.Constraints property

AssemblyWorkPlaneDef.GetData method

AssemblyWorkPlaneDef.OriginPoint property

AssemblyWorkPlaneDef.Parent property

AssemblyWorkPlaneDef.PutData method

AssemblyWorkPlaneDef.Type property

AssemblyWorkPlaneDef.XAxis property

AssemblyWorkPlaneDef.YAxis property

AssemblyWorkPointDef interface

Application

Constraints

Parent

Point

Type

AssemblyWorkPointDef.Application property

AssemblyWorkPointDef.Constraints property

AssemblyWorkPointDef.Parent property

AssemblyWorkPointDef.Point property

AssemblyWorkPointDef.Type property

AssociativeID

EdgeDefinition interface

FaceDefinition interface

SketchEntity3D interface

VertexDefinition interface

AsUnitVector

Vector interface

Vector2d interface

AsVector

UnitVector interface

UnitVector2d interface

Attached

Balloon interface

Centerline interface

Centermark interface

DrawingDimension interface

OriginIndicator interface

AttachedEntities

SketchPoint interface

SketchPoint3D interface

AttachedEntity

Centermark interface

LeaderNode interface

AttachLeaderToCorner

FeatureControlFrameStyle interface

AttachPoint

DetailDrawingView interface

Attribute interface

Delete

Name

Parent

Type

Value

ValueType

Attribute.Delete method

Attribute.Name property

Attribute.Parent property

Attribute.Type property

Attribute.Value property

Attribute.ValueType property

AttributeManager

ApprenticeServerDocument interface

Document interface

AttributeManager interface

FindAttributes

FindAttributeSets

FindObjects

FindObjectsByPattern

OpenAttributeSets

Parent

PurgeAttributeSets

RevisionId

Type

AttributeManager.FindAttributes method

AttributeManager.FindAttributeSets method

AttributeManager.FindObjects method

AttributeManager.FindObjectsByPattern method

AttributeManager.OpenAttributeSets method

AttributeManager.Parent property

AttributeManager.PurgeAttributeSets method

AttributeManager.RevisionId property

AttributeManager.Type property

AttributesEnumerator interface

Count

Item

Type

AttributesEnumerator.Count property

AttributesEnumerator.Item method

AttributesEnumerator.Type property

AttributeSet interface

Add

AddAttributes

Copy

CopyTo

CopyWithOwner

Count

DataIO

Delete

GetReferenceKey

Item

Name

NameIsUsed

Parent

Transient

Type

AttributeSet.Add method

AttributeSet.AddAttributes method

AttributeSet.Copy property

AttributeSet.CopyTo method

AttributeSet.CopyWithOwner property

AttributeSet.Count property

AttributeSet.DataIO property

AttributeSet.Delete method

AttributeSet.GetReferenceKey method

AttributeSet.Item method

AttributeSet.Name property

AttributeSet.NameIsUsed method

AttributeSet.Parent property

AttributeSet.Transient property

AttributeSet.Type property

AttributeSets

ApprenticeServerDocument interface

AssemblyConstraint interface

AutoCADBlock interface

AutoCADBlockDefinition interface

Balloon interface

BaselineDimensionSet interface

BOMRow interface

BorderDefinition interface

BreakOperation interface

BreakOutOperation interface

Centerline interface

Centermark interface

ChainDimensionSet interface

ClientBrowserNodeDefinitionObject interface

ComponentDefinition interface

ComponentOccurrence interface

CustomTable interface

DerivedParameterTable interface

DesignViewRepresentation interface

DimensionConstraint interface

DimensionConstraint3D interface

Document interface

DraftAnalysis interface

DrawingDimension interface

DrawingNote interface

DrawingView interface

Edge interface

EdgeLoop interface

Face interface

FaceShell interface

FeatureControlFrame interface

FeatureDimension interface

FeaturePatternElement interface

GeometricConstraint interface

GeometricConstraint3D interface

HoleTable interface

iAssemblyTableRow interface

iMateDefinition interface

iMateResult interface

iPartTableRow interface

LayoutConstraint interface

Leader interface

LeaderNode interface

LevelOfDetailRepresentation interface

LightingStyle interface

Material interface

OccurrencePattern interface

OrdinateDimensionSet interface

Parameter interface

ParameterTable interface

PartFeature interface

PartsList interface

Path interface

PositionalRepresentation interface

Profile interface

Profile3D interface

ProfileEntity interface

ProfileEntity3D interface

ProfilePath interface

ProfilePath3D interface

ProjectedCut interface

ReferenceComponent interface

ReferencedOLEFileDescriptor interface

RenderStyle interface

RevisionTable interface

Sheet interface

SheetFormat interface

SilhouetteCurve interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchEntity interface

SketchEntity3D interface

SketchFillRegion interface

SketchImage interface

SurfaceBody interface

SurfaceTextureSymbol interface

TextBox interface

TitleBlockDefinition interface

UserCoordinateSystem interface

Vertex interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

WorkSurface interface

AttributeSets interface

Add

AddTransient

Count

DataIO

Item

NameIsUsed

Parent

ParentAvailable

Type

AttributeSets.Add method

AttributeSets.AddTransient method

AttributeSets.Count property

AttributeSets.DataIO property

AttributeSets.Item method

AttributeSets.NameIsUsed method

AttributeSets.Parent property

AttributeSets.ParentAvailable method

AttributeSets.Type property

AttributeSetsEnumerator interface

Count

Item

Type

AttributeSetsEnumerator.Count property

AttributeSetsEnumerator.Item method

AttributeSetsEnumerator.Type property

AutoAddToGUI

ControlDefinition interface

AutoBendRadius

Sketch3DSettings interface

AutoBendWithLineCreation

Sketch3DOptions interface

AutoCADBlock interface

Application

AttributeSets

Color

Definition

Delete

GetCustomLineType

GetPromptTextValues

GetReferenceKey

Layer

LineType

LineWeight

Name

Parent

Position

Rotation

Scale

SetCustomLineType

SetPromptTextValues

Static

Transformation

Type

AutoCADBlock.Application property

AutoCADBlock.AttributeSets property

AutoCADBlock.Color property

AutoCADBlock.Definition property

AutoCADBlock.Delete method

AutoCADBlock.GetCustomLineType method

AutoCADBlock.GetPromptTextValues method

AutoCADBlock.GetReferenceKey method

AutoCADBlock.Layer property

AutoCADBlock.LineType property

AutoCADBlock.LineWeight property

AutoCADBlock.Name property

AutoCADBlock.Parent property

AutoCADBlock.Position property

AutoCADBlock.Rotation property

AutoCADBlock.Scale property

AutoCADBlock.SetCustomLineType method

AutoCADBlock.SetPromptTextValues method

AutoCADBlock.Static property

AutoCADBlock.Transformation property

AutoCADBlock.Type property

AutoCADBlockDefinition interface

Application

AttributeSets

CopyTo

Delete

GetPromptTags

GetReferenceKey

IsReferenced

Name

Parent

Type

AutoCADBlockDefinition.Application property

AutoCADBlockDefinition.AttributeSets property

AutoCADBlockDefinition.CopyTo method

AutoCADBlockDefinition.Delete method

AutoCADBlockDefinition.GetPromptTags method

AutoCADBlockDefinition.GetReferenceKey method

AutoCADBlockDefinition.IsReferenced property

AutoCADBlockDefinition.Name property

AutoCADBlockDefinition.Parent property

AutoCADBlockDefinition.Type property

AutoCADBlockDefinitions

DrawingDocument interface

AutoCADBlockDefinitions interface

AddFromFile

Application

Count

Item

Type

AutoCADBlockDefinitions.AddFromFile method

AutoCADBlockDefinitions.Application property

AutoCADBlockDefinitions.Count property

AutoCADBlockDefinitions.Item method

AutoCADBlockDefinitions.Type property

AutoCADBlockDefinitionsEnumerator interface

Application

Count

Item

Type

AutoCADBlockDefinitionsEnumerator.Application property

AutoCADBlockDefinitionsEnumerator.Count property

AutoCADBlockDefinitionsEnumerator.Item method

AutoCADBlockDefinitionsEnumerator.Type property

AutoCADBlocks

Sheet interface

AutoCADBlocks interface

Add

Application

Count

Item

Type

AutoCADBlocks.Add method

AutoCADBlocks.Application property

AutoCADBlocks.Count property

AutoCADBlocks.Item method

AutoCADBlocks.Type property

AutoConsumeWorkAndSurfaceFeatures

PartOptions interface

AutoHide

MiniToolbarControl interface

AutoHideInLineWorkFeatures

PartOptions interface

AutomatedCenterlineSettings

DrawingSettings interface

AutomatedCenterlineSettings interface

Application

ApplyToBends

ApplyToCircularPatterns

ApplyToCylinders

ApplyToFillets

ApplyToHoles

ApplyToPunches

ApplyToRectangularPatterns

ApplyToRevolutions

ApplyToSketches

ApplyToWorkFeatures

ArcAngleThreshold

CircularEdgeMaximumThreshold

CircularEdgeMinimumThreshold

FilletRadiusMaximumThreshold

FilletRadiusMinimumThreshold

ProjectionNormalAxis

ProjectionParallelAxis

RadiusThresholdPrecision

Type

AutomatedCenterlineSettings.Application property

AutomatedCenterlineSettings.ApplyToBends property

AutomatedCenterlineSettings.ApplyToCircularPatterns property

AutomatedCenterlineSettings.ApplyToCylinders property

AutomatedCenterlineSettings.ApplyToFillets property

AutomatedCenterlineSettings.ApplyToHoles property

AutomatedCenterlineSettings.ApplyToPunches property

AutomatedCenterlineSettings.ApplyToRectangularPatterns property

AutomatedCenterlineSettings.ApplyToRevolutions property

AutomatedCenterlineSettings.ApplyToSketches property

AutomatedCenterlineSettings.ApplyToWorkFeatures property

AutomatedCenterlineSettings.ArcAngleThreshold property

AutomatedCenterlineSettings.CircularEdgeMaximumThreshold property

AutomatedCenterlineSettings.CircularEdgeMinimumThreshold property

AutomatedCenterlineSettings.FilletRadiusMaximumThreshold property

AutomatedCenterlineSettings.FilletRadiusMinimumThreshold property

AutomatedCenterlineSettings.ProjectionNormalAxis property

AutomatedCenterlineSettings.ProjectionParallelAxis property

AutomatedCenterlineSettings.RadiusThresholdPrecision property

AutomatedCenterlineSettings.Type property

AutomaticBlending

MoveFaceDefinition interface

ThickenFeature interface

AutomaticColor

Layer interface

AutomaticEdgeChain

ChamferFeature interface

FilletFeature interface

AutomaticFaceChain

ThickenFeature interface

AutomaticReferenceEdges

SketchOptions interface

Automation

ApplicationAddIn interface

ApplicationAddInServer interface

AutoProjectEdges

SketchOptions interface

AutoProjectPartOrigin

SketchOptions interface

AutoResize

GroundPlaneSettings interface

WorkAxis interface

WorkPlane interface

AuxiliaryOrientationEdge

DrawingView interface

AvailableAccuracy

MassProperties interface

AvailableDocuments

File interface

AvailableGeometricCharacteristics

FeatureControlFrameStyle interface

AvailableLaySymbols

SurfaceTextureStyle interface

AvailableModifiers

FeatureControlFrameStyle interface

AxesOpposed

InsertConstraint interface

InsertiMateDefinition interface

Axis

AssemblyWorkAxisDef interface

FixedWorkAxisDef interface

AxisDirectionReversed

CoilFeature interface

AxisEntity

CircularOccurrencePattern interface

CircularPatternFeature interface

CoilFeature interface

PlanarSketch interface

RevolveFeature interface

AxisEntityGeometry

PlanarSketch interface

AxisEntityNaturalDirection

CircularOccurrencePattern interface

AxisIsX

PlanarSketch interface

AxisVector

Cone interface

Cylinder interface

EllipticalCone interface

EllipticalCylinder interface

Torus interface

B

BackFaces

Bend interface

BackgroundType

ColorSchemes interface

Balloon interface

Application

Attached

AttributeSets

BalloonValueSets

Delete

GetBalloonType

GetReferenceKey

Layer

Leader

Parent

ParentView

PlacementDirection

Position

SaveItemOverridesToBOM

SetBalloonType

Style

Type

Balloon.Application property

Balloon.Attached property

Balloon.AttributeSets property

Balloon.BalloonValueSets property

Balloon.Delete method

Balloon.GetBalloonType method

Balloon.GetReferenceKey method

Balloon.Layer property

Balloon.Leader property

Balloon.Parent property

Balloon.ParentView property

Balloon.PlacementDirection property

Balloon.Position property

Balloon.SaveItemOverridesToBOM method

Balloon.SetBalloonType method

Balloon.Style property

Balloon.Type property

BalloonDiameter

BalloonStyle interface

Ballooned

DrawingBOMRow interface

PartsListRow interface

BalloonLayer

ObjectDefaultsStyle interface

Balloons

Sheet interface

Balloons interface

Add

Application

Count

Item

Type

Balloons.Add method

Balloons.Application property

Balloons.Count property

Balloons.Item method

Balloons.Type property

BalloonStyle

ObjectDefaultsStyle interface

BalloonStyle interface

AlternateLeaderStyle

BalloonDiameter

BalloonType

DefaultOffset

LeaderStyle

Properties

ScaleToTextHeight

StretchBalloonToText

TextStyle

BalloonStyle.AlternateLeaderStyle property

BalloonStyle.BalloonDiameter property

BalloonStyle.BalloonType property

BalloonStyle.DefaultOffset property

BalloonStyle.LeaderStyle property

BalloonStyle.Properties property

BalloonStyle.ScaleToTextHeight property

BalloonStyle.StretchBalloonToText property

BalloonStyle.TextStyle property

BalloonStyles

DrawingStylesManager interface

BalloonStylesEnumerator interface

Application

Count

Item

Type

BalloonStylesEnumerator.Application property

BalloonStylesEnumerator.Count property

BalloonStylesEnumerator.Item method

BalloonStylesEnumerator.Type property

BalloonTipObject interface

Application

ClientData

Delete

Display

Enabled

InternalName

Interval

Message

Parent

Type

BalloonTipObject.Application property

BalloonTipObject.ClientData property

BalloonTipObject.Delete method

BalloonTipObject.Display method

BalloonTipObject.Enabled property

BalloonTipObject.InternalName property

BalloonTipObject.Interval property

BalloonTipObject.Message property

BalloonTipObject.Parent property

BalloonTipObject.Type property

BalloonTips

UserInterfaceManager interface

BalloonTips interface

Add

Application

Count

Item

Type

BalloonTips.Add method

BalloonTips.Application property

BalloonTips.Count property

BalloonTips.Item method

BalloonTips.Type property

BalloonTipSink interface

OnClick

OnDisplay

BalloonTipSink.OnClick method

BalloonTipSink.OnDisplay method

BalloonType

BalloonStyle interface

BalloonValueSet interface

Application

Delete

ItemNumber

OverrideValue

Parent

ReferencedFiles

ReferencedRow

Static

Type

Value

BalloonValueSet.Application property

BalloonValueSet.Delete method

BalloonValueSet.ItemNumber property

BalloonValueSet.OverrideValue property

BalloonValueSet.Parent property

BalloonValueSet.ReferencedFiles method

BalloonValueSet.ReferencedRow property

BalloonValueSet.Static property

BalloonValueSet.Type property

BalloonValueSet.Value property

BalloonValueSets

Balloon interface

BalloonValueSets interface

Add

Application

Count

Item

Type

BalloonValueSets.Add method

BalloonValueSets.Application property

BalloonValueSets.Count property

BalloonValueSets.Item method

BalloonValueSets.Type property

BaseEnvironment

EnvironmentManager interface

BaseFace

FlatPattern interface

BaselineDimensionLayer

ObjectDefaultsStyle interface

BaselineDimensionSet

LinearGeneralDimension interface

BaselineDimensionSet interface

AddMember

Application

ArrangeText

AttributeSets

Delete

DetachMember

DimensionType

GetReferenceKey

Layer

Members

Origin

Parent

Precision

Style

Type

BaselineDimensionSet.AddMember method

BaselineDimensionSet.Application property

BaselineDimensionSet.ArrangeText method

BaselineDimensionSet.AttributeSets property

BaselineDimensionSet.Delete method

BaselineDimensionSet.DetachMember method

BaselineDimensionSet.DimensionType property

BaselineDimensionSet.GetReferenceKey method

BaselineDimensionSet.Layer property

BaselineDimensionSet.Members property

BaselineDimensionSet.Origin property

BaselineDimensionSet.Parent property

BaselineDimensionSet.Precision property

BaselineDimensionSet.Style property

BaselineDimensionSet.Type property

BaselineDimensionSets

DrawingDimensions interface

BaselineDimensionSets interface

Add

Application

Count

Item

Type

BaselineDimensionSets.Add method

BaselineDimensionSets.Application property

BaselineDimensionSets.Count property

BaselineDimensionSets.Item method

BaselineDimensionSets.Type property

BaselineDimensionStyle

ObjectDefaultsStyle interface

BasePoint

Cone interface

Cylinder interface

EllipticalCone interface

EllipticalCylinder interface

BaseStandard

DraftingStandard interface

BaseUnits

BOMQuantity interface

BasicMinorDiameter

TaperedThreadInfo interface

BeadFaces

WeldBead interface

BeadLength

WeldBead interface

Bend interface

Application

BackFaces

FrontFaces

IsFlat

Parent

Type

Bend.Application property

Bend.BackFaces property

Bend.FrontFaces property

Bend.IsFlat property

Bend.Parent property

Bend.Type property

BendAngle

FoldDefinition interface

BendAngleReportType

FlatPattern interface

SheetMetalStyle interface

BendAngleType

UnfoldMethod interface

BendConstraint interface

Arc

LineOne

LineTwo

Radius

BendConstraint.Arc property

BendConstraint.LineOne property

BendConstraint.LineTwo property

BendConstraint.Radius property

BendConstraintProxy interface

ContainingOccurrence

NativeObject

BendConstraintProxy.ContainingOccurrence property

BendConstraintProxy.NativeObject property

BendDefinition

FaceFeatureDefinition interface

BendDefinition interface

Application

BendOptions

BendRadius

Copy

DoubleBendType

Edges

ExtendFaces

IsDoubleBendFirstEdgeFixed

IsUnfoldMethodOverridden

Parent

Type

UnfoldMethod

BendDefinition.Application property

BendDefinition.BendOptions property

BendDefinition.BendRadius property

BendDefinition.Copy method

BendDefinition.DoubleBendType property

BendDefinition.Edges property

BendDefinition.ExtendFaces property

BendDefinition.IsDoubleBendFirstEdgeFixed property

BendDefinition.IsUnfoldMethodOverridden property

BendDefinition.Parent property

BendDefinition.Type property

BendDefinition.UnfoldMethod property

BendDirectionReversed

CustomTable interface

BendEdge

BendNote interface

BendFeature

ContourFlangeFeature interface

FaceFeature interface

FlangeFeature interface

BendFeature interface

Definition

BendFeature.Definition property

BendFeatureProxy interface

BendFeatures

SheetMetalFeatures interface

BendFeatures interface

Add

Application

Count

CreateBendDefinition

Item

Type

BendFeatures.Add method

BendFeatures.Application property

BendFeatures.Count property

BendFeatures.CreateBendDefinition method

BendFeatures.Item method

BendFeatures.Type property

BendInSketchNormalDirection

BendPartFeature interface

BendLine

BendPartFeature interface

FoldDefinition interface

BendLocation

FoldDefinition interface

BendMinimum

BendPartFeature interface

BendNote interface

BendEdge

FormattedBendNote

HideValue

UsePartUnits

BendNote.BendEdge property

BendNote.FormattedBendNote property

BendNote.HideValue property

BendNote.UsePartUnits property

BendNoteLayer

ObjectDefaultsStyle interface

BendNotes

DrawingNotes interface

BendNotes interface

Add

Application

Count

Item

Type

BendNotes.Add method

BendNotes.Application property

BendNotes.Count property

BendNotes.Item method

BendNotes.Type property

BendNoteStyle

ObjectDefaultsStyle interface

BendOptions

BendDefinition interface

ContourFlangeDefinition interface

CornerDefinition interface

FlangeDefinition interface

FoldDefinition interface

HemDefinition interface

BendOptions interface

BendReliefDepth

BendReliefShape

BendReliefWidth

BendTransition

BendTransitionArcRadius

Copy

MinimumRemnant

Parent

Type

BendOptions.BendReliefDepth property

BendOptions.BendReliefShape property

BendOptions.BendReliefWidth property

BendOptions.BendTransition property

BendOptions.BendTransitionArcRadius property

BendOptions.Copy method

BendOptions.MinimumRemnant property

BendOptions.Parent property

BendOptions.Type property

BendPartFeature interface

BendInSketchNormalDirection

BendLine

BendMinimum

BendPartType

BendSide

Edit

InputOne

InputTwo

BendPartFeature.BendInSketchNormalDirection property

BendPartFeature.BendLine property

BendPartFeature.BendMinimum property

BendPartFeature.BendPartType property

BendPartFeature.BendSide property

BendPartFeature.Edit method

BendPartFeature.InputOne property

BendPartFeature.InputTwo property

BendPartFeatureProxy interface

ContainingOccurrence

NativeObject

BendPartFeatureProxy.ContainingOccurrence property

BendPartFeatureProxy.NativeObject property

BendPartFeatures

PartFeatures interface

BendPartFeatures interface

Add

Application

Count

Item

Type

BendPartFeatures.Add method

BendPartFeatures.Application property

BendPartFeatures.Count property

BendPartFeatures.Item method

BendPartFeatures.Type property

BendPartType

BendPartFeature interface

BendPosition

FlangeDefinition interface

BendRadius

BendDefinition interface

ContourFlangeDefinition interface

FlangeDefinition interface

FoldDefinition interface

LoftedFlangeDefinition interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

BendReliefDepth

BendOptions interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

BendReliefShape

BendOptions interface

SheetMetalStyle interface

BendReliefWidth

BendOptions interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

Bends

RefoldFeature interface

SheetMetalComponentDefinition interface

UnfoldFeature interface

BendsEnumerator interface

Application

Count

Item

Type

BendsEnumerator.Application property

BendsEnumerator.Count property

BendsEnumerator.Item method

BendsEnumerator.Type property

BendSide

BendPartFeature interface

BendTableLayer

ObjectDefaultsStyle interface

BendTableStyle

ObjectDefaultsStyle interface

BendTagLayer

ObjectDefaultsStyle interface

BendTagStyle

ObjectDefaultsStyle interface

BendTransition

BendOptions interface

SheetMetalStyle interface

BendTransitionArcRadius

BendOptions interface

SheetMetalStyle interface

BetaVersion

SoftwareVersion interface

BiasPoint

FilletConstantRadiusFaceSet interface

BIMCableTrayConnectorDefinition interface

ConnectionType

Height

HeightOverride

Width

WidthOverride

BIMCableTrayConnectorDefinition.ConnectionType property

BIMCableTrayConnectorDefinition.Height property

BIMCableTrayConnectorDefinition.HeightOverride property

BIMCableTrayConnectorDefinition.Width property

BIMCableTrayConnectorDefinition.WidthOverride property

BIMComponent

AssemblyComponentDefinition interface

PartComponentDefinition interface

BIMComponent interface

Application

ComponentDefinition

ComponentDescription

ConnectorLinks

Connectors

ExportBuildingComponent

Type

BIMComponent.Application property

BIMComponent.ComponentDefinition property

BIMComponent.ComponentDescription property

BIMComponent.ConnectorLinks property

BIMComponent.Connectors property

BIMComponent.ExportBuildingComponent method

BIMComponent.Type property

BIMComponentDescription interface

Application

ComponentPropertySets

ComponentType

ModelProperties

Orientation

SetCustomThumbnail

Thumbnail

Type

BIMComponentDescription.Application property

BIMComponentDescription.ComponentPropertySets property

BIMComponentDescription.ComponentType property

BIMComponentDescription.ModelProperties property

BIMComponentDescription.Orientation property

BIMComponentDescription.SetCustomThumbnail method

BIMComponentDescription.Thumbnail property

BIMComponentDescription.Type property

BIMComponentProperty interface

Application

InternalName

Name

Parent

Type

Value

BIMComponentProperty.Application property

BIMComponentProperty.InternalName property

BIMComponentProperty.Name property

BIMComponentProperty.Parent property

BIMComponentProperty.Type property

BIMComponentProperty.Value property

BIMComponentPropertySet interface

Application

Count

InternalName

Name

Parent

Type

BIMComponentPropertySet.Application property

BIMComponentPropertySet.Count property

BIMComponentPropertySet.InternalName property

BIMComponentPropertySet.Name property

BIMComponentPropertySet.Parent property

BIMComponentPropertySet.Type property

BIMComponentPropertySets interface

Application

Count

Type

BIMComponentPropertySets.Application property

BIMComponentPropertySets.Count property

BIMComponentPropertySets.Type property

BIMConduitConnectorDefinition interface

ConnectionType

Diameter

DiameterOverride

BIMConduitConnectorDefinition.ConnectionType property

BIMConduitConnectorDefinition.Diameter property

BIMConduitConnectorDefinition.DiameterOverride property

BIMConnector interface

Application

Definition

DefinitionType

Delete

GetReferenceKey

Name

Parent

Suppressed

Type

BIMConnector.Application property

BIMConnector.Definition property

BIMConnector.DefinitionType property

BIMConnector.Delete method

BIMConnector.GetReferenceKey method

BIMConnector.Name property

BIMConnector.Parent property

BIMConnector.Suppressed property

BIMConnector.Type property

BIMConnectorDefinition interface

Application

ConnectorShape

Direction

Geometry

Parent

ReverseDirection

SetShape

Type

BIMConnectorDefinition.Application property

BIMConnectorDefinition.ConnectorShape property

BIMConnectorDefinition.Direction property

BIMConnectorDefinition.Geometry property

BIMConnectorDefinition.Parent property

BIMConnectorDefinition.ReverseDirection method

BIMConnectorDefinition.SetShape method

BIMConnectorDefinition.Type property

BIMConnectorLink interface

Application

ConnectorOne

ConnectorTwo

Delete

GetReferenceKey

Name

Type

BIMConnectorLink.Application property

BIMConnectorLink.ConnectorOne property

BIMConnectorLink.ConnectorTwo property

BIMConnectorLink.Delete method

BIMConnectorLink.GetReferenceKey method

BIMConnectorLink.Name property

BIMConnectorLink.Type property

BIMConnectorLinks interface

Add

Application

Count

Item

Type

BIMConnectorLinks.Add method

BIMConnectorLinks.Application property

BIMConnectorLinks.Count property

BIMConnectorLinks.Item method

BIMConnectorLinks.Type property

BIMConnectors interface

Add

Application

Count

CreateCableTrayConnectorDefinition

CreateConduitConnectorDefinition

CreateDuctConnectorDefinition

CreateElectricalConnectorDefinition

CreatePipeConnectorDefinition

Item

Type

BIMConnectors.Add method

BIMConnectors.Application property

BIMConnectors.Count property

BIMConnectors.CreateCableTrayConnectorDefinition method

BIMConnectors.CreateConduitConnectorDefinition method

BIMConnectors.CreateDuctConnectorDefinition method

BIMConnectors.CreateElectricalConnectorDefinition method

BIMConnectors.CreatePipeConnectorDefinition method

BIMConnectors.Item method

BIMConnectors.Type property

BIMDuctConnectorDefinition interface

ConnectionType

Description

Diameter

DiameterOverride

FlowConfiguration

FlowDirection

FlowValue

Height

HeightOverride

LossMethod

LossValue

SystemType

Width

WidthOverride

BIMDuctConnectorDefinition.ConnectionType property

BIMDuctConnectorDefinition.Description property

BIMDuctConnectorDefinition.Diameter property

BIMDuctConnectorDefinition.DiameterOverride property

BIMDuctConnectorDefinition.FlowConfiguration property

BIMDuctConnectorDefinition.FlowDirection property

BIMDuctConnectorDefinition.FlowValue property

BIMDuctConnectorDefinition.Height property

BIMDuctConnectorDefinition.HeightOverride property

BIMDuctConnectorDefinition.LossMethod property

BIMDuctConnectorDefinition.LossValue property

BIMDuctConnectorDefinition.SystemType property

BIMDuctConnectorDefinition.Width property

BIMDuctConnectorDefinition.WidthOverride property

BIMElectricalConnectorDefinition interface

ApparentLoad

ApparentLoadPhase1

ApparentLoadPhase2

ApparentLoadPhase3

Description

HasMotor

LoadClassification

NumberOfPoles

PowerFactor

PowerFactorState

SystemType

Voltage

BIMElectricalConnectorDefinition.ApparentLoad property

BIMElectricalConnectorDefinition.ApparentLoadPhase1 property

BIMElectricalConnectorDefinition.ApparentLoadPhase2 property

BIMElectricalConnectorDefinition.ApparentLoadPhase3 property

BIMElectricalConnectorDefinition.Description property

BIMElectricalConnectorDefinition.HasMotor property

BIMElectricalConnectorDefinition.LoadClassification property

BIMElectricalConnectorDefinition.NumberOfPoles property

BIMElectricalConnectorDefinition.PowerFactor property

BIMElectricalConnectorDefinition.PowerFactorState property

BIMElectricalConnectorDefinition.SystemType property

BIMElectricalConnectorDefinition.Voltage property

BIMExchangeServer interface

GetBIMComponent

BIMExchangeServer.GetBIMComponent method

BIMPipeConnectorDefinition interface

AllowSlopeAdjustment

ConnectionType

Description

Diameter

DiameterOverride

FlowConfiguration

FlowDirection

FlowValue

LossMethod

LossValue

NominalDiameter

SystemType

BIMPipeConnectorDefinition.AllowSlopeAdjustment property

BIMPipeConnectorDefinition.ConnectionType property

BIMPipeConnectorDefinition.Description property

BIMPipeConnectorDefinition.Diameter property

BIMPipeConnectorDefinition.DiameterOverride property

BIMPipeConnectorDefinition.FlowConfiguration property

BIMPipeConnectorDefinition.FlowDirection property

BIMPipeConnectorDefinition.FlowValue property

BIMPipeConnectorDefinition.LossMethod property

BIMPipeConnectorDefinition.LossValue property

BIMPipeConnectorDefinition.NominalDiameter property

BIMPipeConnectorDefinition.SystemType property

BindKeyToObject

ReferenceKeyManager interface

BindTransientKeyToObject

SurfaceBody interface

BitmapAvailable

DrawingView interface

Blue

Color interface

Body

ComponentGraphics interface

FlatPattern interface

SurfaceGraphics interface

Bold

TextGraphics interface

TextStyle interface

BOM

AssemblyComponentDefinition interface

BOM interface

Application

BOMViews

GetPartNumberMergeSettings

Parent

PartsOnlyViewEnabled

PartsOnlyViewMinimumDigits

PartsOnlyViewNumberingScheme

RequiresUpdate

RevisionId

SetPartNumberMergeSettings

StructuredViewDelimiter

StructuredViewEnabled

StructuredViewFirstLevelOnly

StructuredViewMinimumDigits

Type

BOM.Application property

BOM.BOMViews property

BOM.GetPartNumberMergeSettings method

BOM.Parent property

BOM.PartsOnlyViewEnabled property

BOM.PartsOnlyViewMinimumDigits property

BOM.PartsOnlyViewNumberingScheme property

BOM.RequiresUpdate property

BOM.RevisionId property

BOM.SetPartNumberMergeSettings method

BOM.StructuredViewDelimiter property

BOM.StructuredViewEnabled property

BOM.StructuredViewFirstLevelOnly property

BOM.StructuredViewMinimumDigits property

BOM.Type property

BOMQuantity

ComponentDefinition interface

BOMQuantity interface

Application

BaseUnits

GetBaseQuantity

GetEvaluatedBaseQuantity

Parent

SetBaseQuantity

Type

UnitQuantity

BOMQuantity.Application property

BOMQuantity.BaseUnits property

BOMQuantity.GetBaseQuantity method

BOMQuantity.GetEvaluatedBaseQuantity method

BOMQuantity.Parent property

BOMQuantity.SetBaseQuantity method

BOMQuantity.Type property

BOMQuantity.UnitQuantity property

BOMRow

DrawingBOMRow interface

BOMRow interface

Application

AttributeSets

BOMStructure

ChildRows

ComponentDefinitions

GetReferenceKey

ItemNumber

ItemNumberLocked

ItemQuantity

Merged

Parent

Promoted

ReferencedFileDescriptor

RolledUp

TotalQuantity

TotalQuantityOverridden

Type

BOMRow.Application property

BOMRow.AttributeSets property

BOMRow.BOMStructure property

BOMRow.ChildRows property

BOMRow.ComponentDefinitions property

BOMRow.GetReferenceKey method

BOMRow.ItemNumber property

BOMRow.ItemNumberLocked property

BOMRow.ItemQuantity property

BOMRow.Merged property

BOMRow.Parent property

BOMRow.Promoted property

BOMRow.ReferencedFileDescriptor property

BOMRow.RolledUp property

BOMRow.TotalQuantity property

BOMRow.TotalQuantityOverridden property

BOMRow.Type property

BOMRows

BOMView interface

BOMRowsEnumerator interface

Application

Count

Item

Type

BOMRowsEnumerator.Application property

BOMRowsEnumerator.Count property

BOMRowsEnumerator.Item method

BOMRowsEnumerator.Type property

BOMStructure

BOMRow interface

ComponentDefinition interface

ComponentOccurrence interface

BOMView interface

Application

BOMRows

Export

iAssemblyMemberName

Name

Parent

Renumber

RevisionId

Sort

Type

ViewType

BOMView.Application property

BOMView.BOMRows property

BOMView.Export method

BOMView.iAssemblyMemberName property

BOMView.Name property

BOMView.Parent property

BOMView.Renumber method

BOMView.RevisionId property

BOMView.Sort method

BOMView.Type property

BOMView.ViewType property

BOMViews

BOM interface

BOMViews interface

Application

Count

Item

Type

BOMViews.Application property

BOMViews.Count property

BOMViews.Item method

BOMViews.Type property

Border

Sheet interface

Border interface

Application

Definition

Delete

GetResultText

Name

Parent

RangeBox

SetPromptResultText

Type

Border.Application property

Border.Definition property

Border.Delete method

Border.GetResultText method

Border.Name property

Border.Parent property

Border.RangeBox property

Border.SetPromptResultText method

Border.Type property

BorderDefinition interface

Application

AttributeSets

CopyTo

Delete

Edit

ExitEdit

GetReferenceKey

IsDefault

IsReferenced

Name

Parent

Sketch

Type

BorderDefinition.Application property

BorderDefinition.AttributeSets property

BorderDefinition.CopyTo method

BorderDefinition.Delete method

BorderDefinition.Edit method

BorderDefinition.ExitEdit method

BorderDefinition.GetReferenceKey method

BorderDefinition.IsDefault property

BorderDefinition.IsReferenced property

BorderDefinition.Name property

BorderDefinition.Parent property

BorderDefinition.Sketch property

BorderDefinition.Type property

BorderDefinitions

DrawingDocument interface

BorderDefinitions interface

Add

Application

Count

Item

Type

BorderDefinitions.Add method

BorderDefinitions.Application property

BorderDefinitions.Count property

BorderDefinitions.Item method

BorderDefinitions.Type property

BorderGeometryLayer

ObjectDefaultsStyle interface

BorderTextLayer

ObjectDefaultsStyle interface

BorderTextStyle

ObjectDefaultsStyle interface

BossFeature interface

BossFeatureProxy interface

ContainingOccurrence

NativeObject

BossFeatureProxy.ContainingOccurrence property

BossFeatureProxy.NativeObject property

BossFeatures

PartFeatures interface

BossFeatures interface

Application

Count

Item

Type

BossFeatures.Application property

BossFeatures.Count property

BossFeatures.Item method

BossFeatures.Type property

BossSet interface

Application

Centers

Delete

Diameter

Offset

Parent

TaperAngle

Type

BossSet.Application property

BossSet.Centers property

BossSet.Delete method

BossSet.Diameter property

BossSet.Offset property

BossSet.Parent property

BossSet.TaperAngle property

BossSet.Type property

BossSets

RibDefinition interface

BossSets interface

_NewEnum

Add

Application

Count

Item

Type

BossSets._NewEnum property

BossSets.Add method

BossSets.Application property

BossSets.Count property

BossSets.Item method

BossSets.Type property

BottomFace

FlatPattern interface

BottomMargin

DefaultBorder interface

BottomScreenColor

ColorScheme interface

BottomScreenColor2D

ColorScheme interface

BottomTipAngle

HoleFeature interface

BoundaryGeometry

SketchImage interface

TextBox interface

BoundaryLayer

DetailDrawingView interface

BoundaryPatchDefinition interface

Application

BoundaryPatchLoops

Type

BoundaryPatchDefinition.Application property

BoundaryPatchDefinition.BoundaryPatchLoops property

BoundaryPatchDefinition.Type property

BoundaryPatchFeature interface

Definition

BoundaryPatchFeature.Definition property

BoundaryPatchFeatureProxy interface

ContainingOccurrence

NativeObject

BoundaryPatchFeatureProxy.ContainingOccurrence property

BoundaryPatchFeatureProxy.NativeObject property

BoundaryPatchFeatures

PartFeatures interface

BoundaryPatchFeatures interface

Add

Application

Count

CreateBoundaryPatchDefinition

Item

Type

BoundaryPatchFeatures.Add method

BoundaryPatchFeatures.Application property

BoundaryPatchFeatures.Count property

BoundaryPatchFeatures.CreateBoundaryPatchDefinition method

BoundaryPatchFeatures.Item method

BoundaryPatchFeatures.Type property

BoundaryPatchLoop interface

Application

BoundaryPath

Delete

GetBoundaryCondition

SetBoundaryCondition

Type

BoundaryPatchLoop.Application property

BoundaryPatchLoop.BoundaryPath property

BoundaryPatchLoop.Delete method

BoundaryPatchLoop.GetBoundaryCondition method

BoundaryPatchLoop.SetBoundaryCondition method

BoundaryPatchLoop.Type property

BoundaryPatchLoops

BoundaryPatchDefinition interface

BoundaryPatchLoops interface

Add

Application

Count

Item

Type

BoundaryPatchLoops.Add method

BoundaryPatchLoops.Application property

BoundaryPatchLoops.Count property

BoundaryPatchLoops.Item method

BoundaryPatchLoops.Type property

BoundaryPath

BoundaryPatchLoop interface

Box interface

Contains

Expand

Extend

GetBoxData

IsDisjoint

MaxPoint

MinPoint

PutBoxData

Box.Contains method

Box.Expand method

Box.Extend method

Box.GetBoxData method

Box.IsDisjoint method

Box.MaxPoint property

Box.MinPoint property

Box.PutBoxData method

Box2d interface

Contains

Expand

Extend

GetBoxData

IsDisjoint

MaxPoint

MinPoint

PutBoxData

Box2d.Contains method

Box2d.Expand method

Box2d.Extend method

Box2d.GetBoxData method

Box2d.IsDisjoint method

Box2d.MaxPoint property

Box2d.MinPoint property

Box2d.PutBoxData method

BreakLink

PlanarSketch interface

ProjectedCut interface

SilhouetteCurve interface

BreakLinkToFactory

iAssemblyMember interface

iPartMember interface

BreakLinkToFile

ReferenceComponent interface

BreakOperation interface

AllAffectedViews

Application

AttributeSets

BreakStyle

Delete

DisplayLevel

EndPoint

Gap

GetReferenceKey

IsSourceBreakOperation

Layer

MidPoint

NumberOfSymbols

Orientation

Parent

SourceBreakOperation

StartPoint

Type

BreakOperation.AllAffectedViews property

BreakOperation.Application property

BreakOperation.AttributeSets property

BreakOperation.BreakStyle property

BreakOperation.Delete method

BreakOperation.DisplayLevel property

BreakOperation.EndPoint property

BreakOperation.Gap property

BreakOperation.GetReferenceKey method

BreakOperation.IsSourceBreakOperation property

BreakOperation.Layer property

BreakOperation.MidPoint property

BreakOperation.NumberOfSymbols property

BreakOperation.Orientation property

BreakOperation.Parent property

BreakOperation.SourceBreakOperation property

BreakOperation.StartPoint property

BreakOperation.Type property

BreakOperations

DrawingView interface

BreakOperations interface

Add

Application

Count

Item

Type

BreakOperations.Add method

BreakOperations.Application property

BreakOperations.Count property

BreakOperations.Item method

BreakOperations.Type property

BreakOutOperation interface

AllAffectedViews

Application

AttributeSets

Delete

DepthType

GetDepth

GetReferenceKey

Parent

Profile

SectionAllParts

SetDepth

Type

BreakOutOperation.AllAffectedViews property

BreakOutOperation.Application property

BreakOutOperation.AttributeSets property

BreakOutOperation.Delete method

BreakOutOperation.DepthType property

BreakOutOperation.GetDepth method

BreakOutOperation.GetReferenceKey method

BreakOutOperation.Parent property

BreakOutOperation.Profile property

BreakOutOperation.SectionAllParts property

BreakOutOperation.SetDepth method

BreakOutOperation.Type property

BreakOutOperations

DrawingView interface

BreakOutOperations interface

Add

Application

Count

Item

Type

BreakOutOperations.Add method

BreakOutOperations.Application property

BreakOutOperations.Count property

BreakOutOperations.Item method

BreakOutOperations.Type property

BreakStyle

BreakOperation interface

BRepEntities

NonParametricBaseFeatureDefinition interface

Brightness

LightingStyle interface

BrowserFolder interface

Add

AllowAddRemove

AllowDelete

AllowRename

AllowReorder

Application

BrowserNode

Delete

Name

Parent

Remove

SetEndOfPart

Type

BrowserFolder.Add method

BrowserFolder.AllowAddRemove property

BrowserFolder.AllowDelete property

BrowserFolder.AllowRename property

BrowserFolder.AllowReorder property

BrowserFolder.Application property

BrowserFolder.BrowserNode property

BrowserFolder.Delete method

BrowserFolder.Name property

BrowserFolder.Parent property

BrowserFolder.Remove method

BrowserFolder.SetEndOfPart method

BrowserFolder.Type property

BrowserFolders

BrowserNode interface

BrowserFoldersEnumerator interface

Application

Count

Item

Type

BrowserFoldersEnumerator.Application property

BrowserFoldersEnumerator.Count property

BrowserFoldersEnumerator.Item method

BrowserFoldersEnumerator.Type property

BrowserNode

BrowserFolder interface

ClientFeature interface

BrowserNode interface

AddChild

AllReferencedNodes

Application

BrowserFolders

BrowserNodeDefinition

BrowserNodes

Delete

DoPreSelect

DoSelect

EnsureVisible

Expanded

FullPath

InsertChild

NativeObject

Parent

Selected

Type

Visible

BrowserNode.AddChild method

BrowserNode.AllReferencedNodes method

BrowserNode.Application property

BrowserNode.BrowserFolders property

BrowserNode.BrowserNodeDefinition property

BrowserNode.BrowserNodes property

BrowserNode.Delete method

BrowserNode.DoPreSelect method

BrowserNode.DoSelect method

BrowserNode.EnsureVisible method

BrowserNode.Expanded property

BrowserNode.FullPath property

BrowserNode.InsertChild method

BrowserNode.NativeObject property

BrowserNode.Parent property

BrowserNode.Selected property

BrowserNode.Type property

BrowserNode.Visible property

BrowserNodeDefinition

BrowserNode interface

BrowserNodeDefinition interface

AdditionalDisplayState

AdditionalStateIconToolTipText

Application

BuiltIn

DisplayState

Label

Parent

StateIconToolTipText

ToolTipText

Type

BrowserNodeDefinition.AdditionalDisplayState property

BrowserNodeDefinition.AdditionalStateIconToolTipText property

BrowserNodeDefinition.Application property

BrowserNodeDefinition.BuiltIn property

BrowserNodeDefinition.DisplayState property

BrowserNodeDefinition.Label property

BrowserNodeDefinition.Parent property

BrowserNodeDefinition.StateIconToolTipText property

BrowserNodeDefinition.ToolTipText property

BrowserNodeDefinition.Type property

BrowserNodeDefinitionSink interface

OnLabelEdit

BrowserNodeDefinitionSink.OnLabelEdit method

BrowserNodes

BrowserNode interface

BrowserNodesEnumerator interface

Application

Count

Item

ItemById

Type

BrowserNodesEnumerator.Application property

BrowserNodesEnumerator.Count property

BrowserNodesEnumerator.Item method

BrowserNodesEnumerator.ItemById method

BrowserNodesEnumerator.Type property

BrowserPane coclass

BrowserPaneObject interface

Activate

AddBrowserFolder

Application

BuiltIn

Control

Default

Delete

GetBrowserNodeFromObject

InternalName

Name

Parent

Refresh

Reorder

TopNode

TreeBrowser

Type

Update

Visible

BrowserPaneObject.Activate method

BrowserPaneObject.AddBrowserFolder method

BrowserPaneObject.Application property

BrowserPaneObject.BuiltIn property

BrowserPaneObject.Control property

BrowserPaneObject.Default property

BrowserPaneObject.Delete method

BrowserPaneObject.GetBrowserNodeFromObject method

BrowserPaneObject.InternalName property

BrowserPaneObject.Name property

BrowserPaneObject.Parent property

BrowserPaneObject.Refresh method

BrowserPaneObject.Reorder method

BrowserPaneObject.TopNode property

BrowserPaneObject.TreeBrowser property

BrowserPaneObject.Type property

BrowserPaneObject.Update method

BrowserPaneObject.Visible property

BrowserPanes

Document interface

BrowserPanes interface

ActivePane

Add

AddTransientTreeBrowserPane

AddTreeBrowserPane

Application

BrowserPanesEvents

ClientNodeResources

Count

CreateBrowserNodeDefinition

GetClientBrowserNodeDefinition

GetNativeBrowserNodeDefinition

Item

Type

BrowserPanes.ActivePane property

BrowserPanes.Add method

BrowserPanes.AddTransientTreeBrowserPane method

BrowserPanes.AddTreeBrowserPane method

BrowserPanes.Application property

BrowserPanes.BrowserPanesEvents property

BrowserPanes.ClientNodeResources property

BrowserPanes.Count property

BrowserPanes.CreateBrowserNodeDefinition method

BrowserPanes.GetClientBrowserNodeDefinition method

BrowserPanes.GetNativeBrowserNodeDefinition method

BrowserPanes.Item method

BrowserPanes.Type property

BrowserPanesEvents

BrowserPanes interface

BrowserPanesEvents coclass

BrowserPanesEventsObject interface

BrowserPaneSink interface

OnActivate

OnDeactivate

OnHelp

BrowserPaneSink.OnActivate method

BrowserPaneSink.OnDeactivate method

BrowserPaneSink.OnHelp method

BrowserPanesSink interface

OnBrowserNodeActivate

OnBrowserNodeDeleteEntry

OnBrowserNodeGetDisplayObjects

OnBrowserNodeLabelEdit

BrowserPanesSink.OnBrowserNodeActivate method

BrowserPanesSink.OnBrowserNodeDeleteEntry method

BrowserPanesSink.OnBrowserNodeGetDisplayObjects method

BrowserPanesSink.OnBrowserNodeLabelEdit method

BrowserVisible

ClientFeatureElement interface

ReferencedOLEFileDescriptor interface

BSplineCurve interface

Evaluator

GetBSplineData

GetBSplineInfo

PoleAtIndex

PoleAtIndex

PutBSplineInfoAndData

BSplineCurve.Evaluator property

BSplineCurve.GetBSplineData method

BSplineCurve.GetBSplineInfo method

BSplineCurve.PoleAtIndex method

BSplineCurve.PutBSplineInfoAndData method

BSplineCurve2d interface

Evaluator

GetBSplineData

GetBSplineInfo

PoleAtIndex

PoleAtIndex

PutBSplineInfoAndData

BSplineCurve2d.Evaluator property

BSplineCurve2d.GetBSplineData method

BSplineCurve2d.GetBSplineInfo method

BSplineCurve2d.PoleAtIndex method

BSplineCurve2d.PutBSplineInfoAndData method

BSplineCurve2dDefinition interface

AddPoint

FitMethod

Type

BSplineCurve2dDefinition.AddPoint method

BSplineCurve2dDefinition.FitMethod property

BSplineCurve2dDefinition.Type property

BSplineCurveDefinition interface

AddPoint

FitMethod

Type

BSplineCurveDefinition.AddPoint method

BSplineCurveDefinition.FitMethod property

BSplineCurveDefinition.Type property

BSplineSurface interface

Evaluator

GetBSplineData

GetBSplineInfo

PoleAtIndex

PutBSplineInfoAndData

BSplineSurface.Evaluator property

BSplineSurface.GetBSplineData method

BSplineSurface.GetBSplineInfo method

BSplineSurface.PoleAtIndex method

BSplineSurface.PutBSplineInfoAndData method

BuildIdentifier

SoftwareVersion interface

BuiltIn

BrowserNodeDefinition interface

BrowserPaneObject interface

CommandBar interface

CommandBarControl interface

CommandCategory interface

ControlDefinition interface

DraftingStandard interface

Environment interface

ModelParameter interface

ReferenceParameter interface

BumpMapAmount

RenderStyle interface

BumpMapImageFilename

RenderStyle interface

BumpMapInvert

RenderStyle interface

BumpMapRotation

RenderStyle interface

BumpMapScale

RenderStyle interface

BurnThrough

ComponentGraphics interface

CurveGraphics interface

LineGraphics interface

LineStripGraphics interface

PointGraphics interface

SurfaceGraphics interface

TextGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

ButtonDefinition coclass

ButtonDefinitionObject interface

Pressed

ButtonDefinitionObject.Pressed property

ButtonDefinitionSink interface

OnExecute

OnHelp

ButtonDefinitionSink.OnExecute method

ButtonDefinitionSink.OnHelp method

C

CacheResultsOnCompute

MassProperties interface

CalculateFacets

Face interface

SurfaceBody interface

CalculateFacetsAndTextureMap

Face interface

SurfaceBody interface

CalculateStrokes

Edge interface

Face interface

SurfaceBody interface

Callout

SketchedSymbol interface

Camera

ClientView interface

DrawingView interface

IRenderManager interface

View interface

Camera interface

Apply

ApplyWithoutTransition

ComputeWithMouseInput

CreateImage

Eye

Fit

GetExtents

ModelToViewSpace

Parent

Perspective

PerspectiveAngle

SaveAsBitmap

SceneObject

SetExtents

Target

Type

UpVector

ViewOrientationType

ViewToModelSpace

Camera.Apply method

Camera.ApplyWithoutTransition method

Camera.ComputeWithMouseInput method

Camera.CreateImage method

Camera.Eye property

Camera.Fit method

Camera.GetExtents method

Camera.ModelToViewSpace method

Camera.Parent property

Camera.Perspective property

Camera.PerspectiveAngle property

Camera.SaveAsBitmap method

Camera.SceneObject property

Camera.SetExtents method

Camera.Target property

Camera.Type property

Camera.UpVector property

Camera.ViewOrientationType property

Camera.ViewToModelSpace method

CameraEvents

Application interface

CameraEventsObject interface

Application

Parent

Type

CameraEventsObject.Application property

CameraEventsObject.Parent property

CameraEventsObject.Type property

CameraEventsSink interface

OnCameraChange

CameraEventsSink.OnCameraChange method

CanBindKeyToObject

ReferenceKeyManager interface

CancelDrag

DragContext interface

CancelError

FileDialog interface

CapacityMeterEnabled

UserInterfaceManager interface

Caption

Application interface

DockableWindow interface

View interface

Cavity

CoreCavityFeature interface

CBoreDepth

HoleFeature interface

CBoreDiameter

HoleFeature interface

Cell

Matrix interface

Matrix2d interface

Cell interface

Application

Parent

Static

Type

Value

Cell.Application property

Cell.Parent property

Cell.Static property

Cell.Type property

Cell.Value property

Center

Arc2d interface

Arc3d interface

Circle interface

Circle2d interface

DrawingView interface

EllipseFull interface

EllipseFull2d interface

EllipticalArc interface

EllipticalArc2d interface

CenterDimensionText

DrawingOptions interface

CenteredWidthExtent interface

Edge

Width

CenteredWidthExtent.Edge property

CenteredWidthExtent.Width property

CenterFaces

FilletFullRoundSet interface

Centerline

LoftDefinition interface

SketchLine interface

Centerline interface

Application

Attached

AttributeSets

CenterlineType

Delete

EndPoint

FitPoints

Geometry

GeometryType

GetBisectorEntities

GetReferenceKey

Layer

ModelWorkFeature

Parent

PatternCenter

StartPoint

Style

Type

Visible

Centerline.Application property

Centerline.Attached property

Centerline.AttributeSets property

Centerline.CenterlineType property

Centerline.Delete method

Centerline.EndPoint property

Centerline.FitPoints property

Centerline.Geometry property

Centerline.GeometryType property

Centerline.GetBisectorEntities method

Centerline.GetReferenceKey method

Centerline.Layer property

Centerline.ModelWorkFeature property

Centerline.Parent property

Centerline.PatternCenter property

Centerline.StartPoint property

Centerline.Style property

Centerline.Type property

Centerline.Visible property

CenterlineLayer

ObjectDefaultsStyle interface

Centerlines

Centermark interface

Sheet interface

Centerlines interface

Add

AddBisector

AddByWorkFeature

AddCenteredPattern

Application

Count

Item

Type

Centerlines.Add method

Centerlines.AddBisector method

Centerlines.AddByWorkFeature method

Centerlines.AddCenteredPattern method

Centerlines.Application property

Centerlines.Count property

Centerlines.Item method

Centerlines.Type property

CenterlineStyle

ObjectDefaultsStyle interface

CenterlineType

Centerline interface

Centermark interface

Application

Attached

AttachedEntity

AttributeSets

Centerlines

CentermarkType

Delete

ExtensionLinesVisible

ExtensionPointFour

ExtensionPointFourDirection

ExtensionPointOne

ExtensionPointOneDirection

ExtensionPointThree

ExtensionPointThreeDirection

ExtensionPointTwo

ExtensionPointTwoDirection

GetReferenceKey

Layer

ModelWorkFeature

Parent

Position

Style

Type

Visible

Centermark.Application property

Centermark.Attached property

Centermark.AttachedEntity property

Centermark.AttributeSets property

Centermark.Centerlines property

Centermark.CentermarkType property

Centermark.Delete method

Centermark.ExtensionLinesVisible property

Centermark.ExtensionPointFour property

Centermark.ExtensionPointFourDirection property

Centermark.ExtensionPointOne property

Centermark.ExtensionPointOneDirection property

Centermark.ExtensionPointThree property

Centermark.ExtensionPointThreeDirection property

Centermark.ExtensionPointTwo property

Centermark.ExtensionPointTwoDirection property

Centermark.GetReferenceKey method

Centermark.Layer property

Centermark.ModelWorkFeature method

Centermark.Parent property

Centermark.Position property

Centermark.Style property

Centermark.Type property

Centermark.Visible property

CentermarkLayer

ObjectDefaultsStyle interface

Centermarks

DefaultBorder interface

Sheet interface

Centermarks interface

Add

AddByCenterOfGravity

AddByWorkFeature

Application

Count

Item

Type

Centermarks.Add method

Centermarks.AddByCenterOfGravity method

Centermarks.AddByWorkFeature method

Centermarks.Application property

Centermarks.Count property

Centermarks.Item method

Centermarks.Type property

CentermarkStyle

ObjectDefaultsStyle interface

CentermarkStyle interface

DefaultRadius

ExtensionLength

GapDistance

MarkSize

OvershootDistance

CentermarkStyle.DefaultRadius property

CentermarkStyle.ExtensionLength property

CentermarkStyle.GapDistance property

CentermarkStyle.MarkSize property

CentermarkStyle.OvershootDistance property

CentermarkStyles

DrawingStylesManager interface

CentermarkStylesEnumerator interface

Application

Count

Item

Type

CentermarkStylesEnumerator.Application property

CentermarkStylesEnumerator.Count property

CentermarkStylesEnumerator.Item method

CentermarkStylesEnumerator.Type property

CentermarkType

Centermark interface

CenterOfGravityLayer

ObjectDefaultsStyle interface

CenterOfGravityStyle

ObjectDefaultsStyle interface

CenterOfMass

MassProperties interface

CenterPoint

DrawingCurve interface

SketchArc3D interface

SketchCircle3D interface

SketchEllipse3D interface

SketchEllipticalArc3D interface

Sphere interface

Torus interface

CenterPointConstraint

ConcentricConstraint interface

Centers

BossSet interface

CenterSketchPoint

SketchArc interface

SketchCircle interface

SketchEllipse interface

SketchEllipticalArc interface

CenterText

AngularGeneralDimension interface

LinearGeneralDimension interface

Centroid

InterferenceResult interface

RegionProperties interface

CentroidMomentsOfInertia

RegionProperties interface

CentroidWorkPointDef interface

Application

Entities

Parent

Type

CentroidWorkPointDef.Application property

CentroidWorkPointDef.Entities property

CentroidWorkPointDef.Parent property

CentroidWorkPointDef.Type property

ChainDimensionLayer

ObjectDefaultsStyle interface

ChainDimensionSet

LinearGeneralDimension interface

ChainDimensionSet interface

AddMembers

Application

Arrange

AttributeSets

Delete

DimensionType

GetReferenceKey

Layer

Locked

Members

MergeMembers

Parent

Precision

Style

Type

ChainDimensionSet.AddMembers method

ChainDimensionSet.Application property

ChainDimensionSet.Arrange method

ChainDimensionSet.AttributeSets property

ChainDimensionSet.Delete method

ChainDimensionSet.DimensionType property

ChainDimensionSet.GetReferenceKey method

ChainDimensionSet.Layer property

ChainDimensionSet.Locked property

ChainDimensionSet.Members property

ChainDimensionSet.MergeMembers method

ChainDimensionSet.Parent property

ChainDimensionSet.Precision property

ChainDimensionSet.Style property

ChainDimensionSet.Type property

ChainDimensionSets

DrawingDimensions interface

ChainDimensionSets interface

_NewEnum

Add

AddUsingBaseDimension

Application

Count

Item

Type

ChainDimensionSets._NewEnum property

ChainDimensionSets.Add method

ChainDimensionSets.AddUsingBaseDimension method

ChainDimensionSets.Application property

ChainDimensionSets.Count property

ChainDimensionSets.Item method

ChainDimensionSets.Type property

ChainDimensionStyle

ObjectDefaultsStyle interface

ChainFaces

DecalFeature interface

ChamferDefinition

CornerChamferDefinition interface

ChamferDefinition interface

Application

Parent

Type

ChamferDefinition.Application property

ChamferDefinition.Parent property

ChamferDefinition.Type property

ChamferDefinitionType

CornerChamferDefinition interface

ChamferedEdges

ChamferFeature interface

ChamferEdgeOne

ChamferNote interface

ChamferEdgeTwo

ChamferNote interface

ChamferFeature interface

AutomaticEdgeChain

ChamferedEdges

Definition

DefinitionType

PreserveAllFeatures

ChamferFeature.AutomaticEdgeChain property

ChamferFeature.ChamferedEdges property

ChamferFeature.Definition property

ChamferFeature.DefinitionType property

ChamferFeature.PreserveAllFeatures property

ChamferFeatureProxy interface

ContainingOccurrence

NativeObject

ChamferFeatureProxy.ContainingOccurrence property

ChamferFeatureProxy.NativeObject property

ChamferFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

ChamferFeatures interface

AddUsingDistance

AddUsingDistanceAndAngle

AddUsingTwoDistances

Application

Count

Item

Type

ChamferFeatures.AddUsingDistance method

ChamferFeatures.AddUsingDistanceAndAngle method

ChamferFeatures.AddUsingTwoDistances method

ChamferFeatures.Application property

ChamferFeatures.Count property

ChamferFeatures.Item method

ChamferFeatures.Type property

ChamferNote interface

ChamferEdgeOne

ChamferEdgeTwo

FormattedChamferNote

HideValue

ChamferNote.ChamferEdgeOne property

ChamferNote.ChamferEdgeTwo property

ChamferNote.FormattedChamferNote property

ChamferNote.HideValue property

ChamferNoteLayer

ObjectDefaultsStyle interface

ChamferNotes

DrawingNotes interface

ChamferNotes interface

Add

Application

Count

Item

Type

ChamferNotes.Add method

ChamferNotes.Application property

ChamferNotes.Count property

ChamferNotes.Item method

ChamferNotes.Type property

ChamferNoteStyle

ObjectDefaultsStyle interface

ChangeDefinition coclass

ChangeDefinitionObject interface

Application

ChangeType

ClientId

CommandName

CreateChangeProcessor

Delete

InternalName

Parent

Type

ChangeDefinitionObject.Application property

ChangeDefinitionObject.ChangeType property

ChangeDefinitionObject.ClientId property

ChangeDefinitionObject.CommandName property

ChangeDefinitionObject.CreateChangeProcessor method

ChangeDefinitionObject.Delete method

ChangeDefinitionObject.InternalName property

ChangeDefinitionObject.Parent property

ChangeDefinitionObject.Type property

ChangeDefinitions interface

Add

Application

ClientId

Count

Delete

Item

Type

ChangeDefinitions.Add method

ChangeDefinitions.Application property

ChangeDefinitions.ClientId property

ChangeDefinitions.Count property

ChangeDefinitions.Delete method

ChangeDefinitions.Item method

ChangeDefinitions.Type property

ChangeDefinitionSink interface

OnReplay

ChangeDefinitionSink.OnReplay method

ChangeLayer

Sheet interface

ChangeManager interface

Add

Application

Count

GetObjectFromScriptKey

GetScriptKeyFromObject

Item

Parent

Type

ChangeManager.Add method

ChangeManager.Application property

ChangeManager.Count property

ChangeManager.GetObjectFromScriptKey method

ChangeManager.GetScriptKeyFromObject method

ChangeManager.Item method

ChangeManager.Parent property

ChangeManager.Type property

ChangeProcessor coclass

ChangeProcessorObject interface

Application

ChangeType

DisplayMessages

Execute

GlobalChangeProcess

GlobalChangeProcessAborted

MergeWithPrevious

MessageDialogUserChoice

Parent

SetAffectedDocuments

SetMessageDialogOptions

Transact

Type

ChangeProcessorObject.Application property

ChangeProcessorObject.ChangeType property

ChangeProcessorObject.DisplayMessages property

ChangeProcessorObject.Execute method

ChangeProcessorObject.GlobalChangeProcess property

ChangeProcessorObject.GlobalChangeProcessAborted property

ChangeProcessorObject.MergeWithPrevious property

ChangeProcessorObject.MessageDialogUserChoice property

ChangeProcessorObject.Parent property

ChangeProcessorObject.SetAffectedDocuments method

ChangeProcessorObject.SetMessageDialogOptions method

ChangeProcessorObject.Transact property

ChangeProcessorObject.Type property

ChangeProcessorSink interface

OnExecute

OnReadFromScript

OnTerminate

OnWriteToScript

ChangeProcessorSink.OnExecute method

ChangeProcessorSink.OnReadFromScript method

ChangeProcessorSink.OnTerminate method

ChangeProcessorSink.OnWriteToScript method

ChangeRow

iPartMember interface

ChangeRowOfiAssemblyMember

ComponentOccurrence interface

ChangeRowOfiPartMember

ComponentOccurrence interface

ChangeType

ChangeDefinitionObject interface

ChangeProcessorObject interface

Checked

MiniToolbarCheckBoxObject interface

CheckPoint interface

Application

ContainingTransaction

DisplayName

Id

Parent

Type

CheckPoint.Application property

CheckPoint.ContainingTransaction property

CheckPoint.DisplayName property

CheckPoint.Id property

CheckPoint.Parent property

CheckPoint.Type property

CheckPoints

Transaction interface

CheckPointsEnumerator interface

Count

Item

Type

CheckPointsEnumerator.Count property

CheckPointsEnumerator.Item method

CheckPointsEnumerator.Type property

ChildBlocks

SketchBlock interface

ChildControls

CommandControl interface

ChildNodes

ContentTreeViewNode interface

LeaderNode interface

ChildRows

BOMRow interface

ChildTransactions

Transaction interface

Circle interface

Center

Evaluator

GetCircleData

Normal

PutCircleData

Radius

Circle.Center property

Circle.Evaluator property

Circle.GetCircleData method

Circle.Normal property

Circle.PutCircleData method

Circle.Radius property

Circle2d interface

Center

Evaluator

GetCircleData

PutCircleData

Radius

Circle2d.Center property

Circle2d.Evaluator property

Circle2d.GetCircleData method

Circle2d.PutCircleData method

Circle2d.Radius property

CircleDimensionType

DrawingOptions interface

CircularEdgeMaximumThreshold

AutomatedCenterlineSettings interface

CircularEdgeMinimumThreshold

AutomatedCenterlineSettings interface

CircularFence

DetailDrawingView interface

CircularOccurrencePattern interface

AngleOffset

AxisEntity

AxisEntityNaturalDirection

ElementCount

CircularOccurrencePattern.AngleOffset property

CircularOccurrencePattern.AxisEntity property

CircularOccurrencePattern.AxisEntityNaturalDirection property

CircularOccurrencePattern.ElementCount property

CircularOccurrencePatternProxy interface

ContainingOccurrence

NativeObject

CircularOccurrencePatternProxy.ContainingOccurrence property

CircularOccurrencePatternProxy.NativeObject property

CircularPatternFeature interface

AddParticipant

Angle

AxisEntity

ComputeType

Count

FitWithinAngle

MidPlanePattern

NaturalAxisDirection

NewBodyOperation

ParentFeatures

PatternElements

PatternOfBody

SurfacesOpaque

SurfacesVisible

CircularPatternFeature.AddParticipant method

CircularPatternFeature.Angle property

CircularPatternFeature.AxisEntity property

CircularPatternFeature.ComputeType property

CircularPatternFeature.Count property

CircularPatternFeature.FitWithinAngle property

CircularPatternFeature.MidPlanePattern property

CircularPatternFeature.NaturalAxisDirection property

CircularPatternFeature.NewBodyOperation property

CircularPatternFeature.ParentFeatures property

CircularPatternFeature.PatternElements property

CircularPatternFeature.PatternOfBody property

CircularPatternFeature.SurfacesOpaque property

CircularPatternFeature.SurfacesVisible property

CircularPatternFeatureProxy interface

ContainingOccurrence

NativeObject

CircularPatternFeatureProxy.ContainingOccurrence property

CircularPatternFeatureProxy.NativeObject property

CircularPatternFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

CircularPatternFeatures interface

Add

Application

Count

Item

Type

CircularPatternFeatures.Add method

CircularPatternFeatures.Application property

CircularPatternFeatures.Count property

CircularPatternFeatures.Item method

CircularPatternFeatures.Type property

Class

StandardThreadInfo interface

ClassIdString

ApplicationAddIn interface

Classification

ControlDefinition interface

Clear

ComboBoxDefinitionObject interface

DockableWindow interface

ErrorManager interface

HighlightSet interface

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

NameValueMap interface

ObjectCollection interface

ProjectPaths interface

SelectSet interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFaceList interface

ClearAll

ExpressionList interface

ClearAllTransactions

TransactionManager interface

ClearMessages

MessageSection interface

ClearPrivateEvents

CommandManager interface

ClearPropertyMap

ContentTableColumn interface

ClearSelectionFilter

SelectEventsObject interface

ClearSlice

GraphicsNode interface

ClearWindowSelectionFilter

SelectEventsObject interface

ClientApplication interface

GetXMLData

PutXMLData

ClientApplication.GetXMLData method

ClientApplication.PutXMLData method

ClientBrowserNodeDefinition coclass

ClientBrowserNodeDefinitionObject interface

AttributeSets

Delete

ExpandedIcon

GetReferenceKey

Icon

Id

IsReferenced

SetLabel

ClientBrowserNodeDefinitionObject.AttributeSets property

ClientBrowserNodeDefinitionObject.Delete method

ClientBrowserNodeDefinitionObject.ExpandedIcon property

ClientBrowserNodeDefinitionObject.GetReferenceKey method

ClientBrowserNodeDefinitionObject.Icon property

ClientBrowserNodeDefinitionObject.Id property

ClientBrowserNodeDefinitionObject.IsReferenced property

ClientBrowserNodeDefinitionObject.SetLabel method

ClientBrowserNodeDefinitionSink interface

ClientData

BalloonTipObject interface

DocumentInterest interface

ClientFeature interface

BrowserNode

ClientId

Definition

HiddenParameters

ClientFeature.BrowserNode property

ClientFeature.ClientId property

ClientFeature.Definition property

ClientFeature.HiddenParameters property

ClientFeatureDefinition interface

AddDependency

Application

ClientFeatureElements

ClientGraphicsCollection

FeatureInputs

FeatureType

GraphicsDataSetsCollection

HighlightClientGraphicsWithFeature

Parent

RemoveDependency

Type

ClientFeatureDefinition.AddDependency method

ClientFeatureDefinition.Application property

ClientFeatureDefinition.ClientFeatureElements property

ClientFeatureDefinition.ClientGraphicsCollection property

ClientFeatureDefinition.FeatureInputs property

ClientFeatureDefinition.FeatureType property

ClientFeatureDefinition.GraphicsDataSetsCollection property

ClientFeatureDefinition.HighlightClientGraphicsWithFeature property

ClientFeatureDefinition.Parent property

ClientFeatureDefinition.RemoveDependency method

ClientFeatureDefinition.Type property

ClientFeatureElement interface

Application

BrowserVisible

Delete

Element

HighlightWithFeature

Parent

Type

UserEditable

ClientFeatureElement.Application property

ClientFeatureElement.BrowserVisible property

ClientFeatureElement.Delete method

ClientFeatureElement.Element property

ClientFeatureElement.HighlightWithFeature property

ClientFeatureElement.Parent property

ClientFeatureElement.Type property

ClientFeatureElement.UserEditable property

ClientFeatureElementProxy interface

ContainingOccurrence

NativeObject

ClientFeatureElementProxy.ContainingOccurrence property

ClientFeatureElementProxy.NativeObject property

ClientFeatureElements

ClientFeatureDefinition interface

ClientFeatureElements interface

Add

Application

Count

Item

Type

ClientFeatureElements.Add method

ClientFeatureElements.Application property

ClientFeatureElements.Count property

ClientFeatureElements.Item method

ClientFeatureElements.Type property

ClientFeatureProxy interface

ContainingOccurrence

NativeObject

ClientFeatureProxy.ContainingOccurrence property

ClientFeatureProxy.NativeObject property

ClientFeatures

Features interface

PartFeatures interface

ClientFeatures interface

Add

Application

Count

CreateDefinition

Item

Type

ClientFeatures.Add method

ClientFeatures.Application property

ClientFeatures.Count property

ClientFeatures.CreateDefinition method

ClientFeatures.Item method

ClientFeatures.Type property

ClientGraphics interface

AddNode

Application

ClientId

Count

Delete

Item

ItemById

NonTransacting

Parent

RangeBox

Selectable

Type

Visible

ClientGraphics.AddNode method

ClientGraphics.Application property

ClientGraphics.ClientId property

ClientGraphics.Count property

ClientGraphics.Delete method

ClientGraphics.Item method

ClientGraphics.ItemById method

ClientGraphics.NonTransacting property

ClientGraphics.Parent property

ClientGraphics.RangeBox property

ClientGraphics.Selectable property

ClientGraphics.Type property

ClientGraphics.Visible property

ClientGraphicsCollection

ClientFeatureDefinition interface

ComponentDefinition interface

DrawingView interface

Sheet interface

ClientGraphicsCollection interface

Add

AddNonTransacting

Application

Count

Item

Parent

Type

ClientGraphicsCollection.Add method

ClientGraphicsCollection.AddNonTransacting method

ClientGraphicsCollection.Application property

ClientGraphicsCollection.Count property

ClientGraphicsCollection.Item method

ClientGraphicsCollection.Parent property

ClientGraphicsCollection.Type property

ClientId

ApplicationAddIn interface

ChangeDefinitionObject interface

ChangeDefinitions interface

ClientFeature interface

ClientGraphics interface

ClientNodeResource interface

CommandBar interface

CommandCategory interface

ControlDefinition interface

CustomConstraint interface

CustomConstraint3D interface

CustomParameterGroup interface

DockableWindow interface

DocumentInterest interface

Environment interface

GraphicsDataSets interface

RibbonPanel interface

RibbonTab interface

ClientNodeResource interface

Application

ClientId

Delete

DisabledIcon

ExpandedDisabledIcon

ExpandedInvisibleIcon

ExpandedSuppressedIcon

GroundedDisabledIcon

GroundedIcon

GroundedInvisibleIcon

GroundedSuppressedIcon

Icon

Id

InvisibleIcon

Parent

SuppressedIcon

Type

ClientNodeResource.Application property

ClientNodeResource.ClientId property

ClientNodeResource.Delete method

ClientNodeResource.DisabledIcon property

ClientNodeResource.ExpandedDisabledIcon property

ClientNodeResource.ExpandedInvisibleIcon property

ClientNodeResource.ExpandedSuppressedIcon property

ClientNodeResource.GroundedDisabledIcon property

ClientNodeResource.GroundedIcon property

ClientNodeResource.GroundedInvisibleIcon property

ClientNodeResource.GroundedSuppressedIcon property

ClientNodeResource.Icon property

ClientNodeResource.Id property

ClientNodeResource.InvisibleIcon property

ClientNodeResource.Parent property

ClientNodeResource.SuppressedIcon property

ClientNodeResource.Type property

ClientNodeResources

BrowserPanes interface

ClientNodeResources interface

Add

Application

Count

Item

ItemById

Type

ClientNodeResources.Add method

ClientNodeResources.Application property

ClientNodeResources.Count property

ClientNodeResources.Item method

ClientNodeResources.ItemById method

ClientNodeResources.Type property

ClientView interface

Application

Camera

Close

DisplayMode

Document

GetSubsetExtents

GroundShadow

HWND

Parent

Type

Update

ClientView.Application property

ClientView.Camera property

ClientView.Close method

ClientView.DisplayMode property

ClientView.Document property

ClientView.GetSubsetExtents method

ClientView.GroundShadow property

ClientView.HWND property

ClientView.Parent property

ClientView.Type property

ClientView.Update method

ClientViews

ApprenticeServerDocument interface

Sheet interface

ClientViews interface

Add

AddBySubset

Application

Count

Item

Parent

Type

ClientViews.Add method

ClientViews.AddBySubset method

ClientViews.Application property

ClientViews.Count property

ClientViews.Item method

ClientViews.Parent property

ClientViews.Type property

ClockwiseRotation

CoilFeature interface

Close

ApprenticeServer interface

ApprenticeServerDocument interface

ClientView interface

Document interface

InventorVBAProject interface

ProgressBarObject interface

View interface

CloseAll

Documents interface

Closed

LoftDefinition interface

Path interface

ProfilePath interface

ProfilePath3D interface

SketchFixedSpline interface

SketchFixedSpline3D interface

SketchOffsetSpline interface

SketchSpline interface

SketchSpline3D interface

CoilFeature interface

AxisDirectionReversed

AxisEntity

ClockwiseRotation

EndFlatAngle

EndTransitionAngle

Extent

ExtentType

FlatEndType

FlatStartType

Operation

Profile

SetPitchAndHeightExtent

SetPitchAndRevolutionExtent

SetRevolutionAndHeightExtent

SetSpiralExtent

StartFlatAngle

StartTransitionAngle

CoilFeature.AxisDirectionReversed property

CoilFeature.AxisEntity property

CoilFeature.ClockwiseRotation property

CoilFeature.EndFlatAngle property

CoilFeature.EndTransitionAngle property

CoilFeature.Extent property

CoilFeature.ExtentType property

CoilFeature.FlatEndType property

CoilFeature.FlatStartType property

CoilFeature.Operation property

CoilFeature.Profile property

CoilFeature.SetPitchAndHeightExtent method

CoilFeature.SetPitchAndRevolutionExtent method

CoilFeature.SetRevolutionAndHeightExtent method

CoilFeature.SetSpiralExtent method

CoilFeature.StartFlatAngle property

CoilFeature.StartTransitionAngle property

CoilFeatureProxy interface

ContainingOccurrence

NativeObject

CoilFeatureProxy.ContainingOccurrence property

CoilFeatureProxy.NativeObject property

CoilFeatures

PartFeatures interface

CoilFeatures interface

AddByPitchAndHeight

AddByPitchAndRevolution

AddByRevolutionAndHeight

AddSpiral

Application

Count

Item

Type

CoilFeatures.AddByPitchAndHeight method

CoilFeatures.AddByPitchAndRevolution method

CoilFeatures.AddByRevolutionAndHeight method

CoilFeatures.AddSpiral method

CoilFeatures.Application property

CoilFeatures.Count property

CoilFeatures.Item method

CoilFeatures.Type property

CoincidentConstraint interface

EntityOne

EntityTwo

StartOrEndPointConstraint

CoincidentConstraint.EntityOne property

CoincidentConstraint.EntityTwo property

CoincidentConstraint.StartOrEndPointConstraint property

CoincidentConstraint3D interface

ConnectedEntity

Disconnect

EntityOne

EntityTwo

CoincidentConstraint3D.ConnectedEntity property

CoincidentConstraint3D.Disconnect method

CoincidentConstraint3D.EntityOne property

CoincidentConstraint3D.EntityTwo property

CoincidentConstraint3DProxy interface

ContainingOccurrence

NativeObject

CoincidentConstraint3DProxy.ContainingOccurrence property

CoincidentConstraint3DProxy.NativeObject property

CoincidentConstraintProxy interface

ContainingOccurrence

NativeObject

CoincidentConstraintProxy.ContainingOccurrence property

CoincidentConstraintProxy.NativeObject property

CollectionType

EdgeCollection interface

FaceCollection interface

CollinearConstraint interface

EntityOne

EntityTwo

UseEllipseOneMajorAxis

UseEllipseTwoMajorAxis

CollinearConstraint.EntityOne property

CollinearConstraint.EntityTwo property

CollinearConstraint.UseEllipseOneMajorAxis property

CollinearConstraint.UseEllipseTwoMajorAxis property

CollinearConstraint3D interface

EntityOne

EntityTwo

CollinearConstraint3D.EntityOne property

CollinearConstraint3D.EntityTwo property

CollinearConstraint3DProxy interface

ContainingOccurrence

NativeObject

CollinearConstraint3DProxy.ContainingOccurrence property

CollinearConstraint3DProxy.NativeObject property

CollinearConstraintProxy interface

ContainingOccurrence

NativeObject

CollinearConstraintProxy.ContainingOccurrence property

CollinearConstraintProxy.NativeObject property

CollisionDetection

DriveConstraintSettingsObject interface

Color

AutoCADBlock interface

ComponentGraphics interface

CurveGraphics interface

DimensionStyle interface

DimensionText interface

DrawingCurve interface

DrawingNote interface

DrawingViewLabel interface

GraphicsColorMapper interface

GraphicsColorSet interface

GroundPlaneSettings interface

HighlightSet interface

Layer interface

LeaderStyle interface

Light interface

Sketch interface

SketchBlock interface

SketchedSymbol interface

SketchFillRegion interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

SurfaceGraphicsFace interface

TextBox interface

TextStyle interface

Color interface

Blue

ColorSourceType

GetColor

Green

Opacity

Red

SetColor

Type

Color.Blue property

Color.ColorSourceType property

Color.GetColor method

Color.Green property

Color.Opacity property

Color.Red property

Color.SetColor method

Color.Type property

ColorBinding

LineGraphics interface

LineStripGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

ColorCount

GraphicsColorMapper interface

ColorIndexSet

LineGraphics interface

LineStripGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

ColorMapper

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

ColorMode

ApprenticePrintManager interface

PrintManager interface

ColorScheme interface

Activate

Application

BottomScreenColor

BottomScreenColor2D

CutPreviewColor

DOFFixedColor

DOFFreeColor

HighlightColor

HighlightColor2D

ImageFullFileName

IntersectPreviewColor

JoinPreviewColor

Name

PrimarySelectColor

PrimarySelectColor2D

ScreenColor

ScreenColor2D

SecondarySelectColor

TertiarySelectColor

TopScreenColor

TopScreenColor2D

Type

ColorScheme.Activate method

ColorScheme.Application property

ColorScheme.BottomScreenColor property

ColorScheme.BottomScreenColor2D property

ColorScheme.CutPreviewColor property

ColorScheme.DOFFixedColor property

ColorScheme.DOFFreeColor property

ColorScheme.HighlightColor property

ColorScheme.HighlightColor2D property

ColorScheme.ImageFullFileName property

ColorScheme.IntersectPreviewColor property

ColorScheme.JoinPreviewColor property

ColorScheme.Name property

ColorScheme.PrimarySelectColor property

ColorScheme.PrimarySelectColor2D property

ColorScheme.ScreenColor property

ColorScheme.ScreenColor2D property

ColorScheme.SecondarySelectColor property

ColorScheme.TertiarySelectColor property

ColorScheme.TopScreenColor property

ColorScheme.TopScreenColor2D property

ColorScheme.Type property

ColorSchemes

Application interface

ColorSchemes interface

Application

ApplicationFrameColor

BackgroundType

Count

EnableEnhancedHighlighting

EnablePrehighlight

IconsColor

InterfaceStyle

Item

Type

ColorSchemes.Application property

ColorSchemes.ApplicationFrameColor property

ColorSchemes.BackgroundType property

ColorSchemes.Count property

ColorSchemes.EnableEnhancedHighlighting property

ColorSchemes.EnablePrehighlight property

ColorSchemes.IconsColor property

ColorSchemes.InterfaceStyle property

ColorSchemes.Item method

ColorSchemes.Type property

ColorSet

LineGraphics interface

LineStripGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

ColorSourceType

Color interface

Column

ContentTableCell interface

iAssemblyTableCell interface

iFeatureTableCell interface

iPartTableCell interface

Column interface

Application

Delete

InternalTitle

Parent

Reposition

Title

TitleHorizontalJustification

Type

ValueHorizontalJustification

Width

Column.Application property

Column.Delete method

Column.InternalTitle property

Column.Parent property

Column.Reposition method

Column.Title property

Column.TitleHorizontalJustification property

Column.Type property

Column.ValueHorizontalJustification property

Column.Width property

ColumnCount

RectangularOccurrencePattern interface

ColumnEntity

RectangularOccurrencePattern interface

ColumnEntityNaturalDirection

RectangularOccurrencePattern interface

ColumnHeaderTextStyle

CustomTable interface

HoleTable interface

HoleTableStyle interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

ColumnOffset

RectangularOccurrencePattern interface

Columns

CustomTable interface

Columns interface

Add

Application

Count

Item

Type

Columns.Add method

Columns.Application property

Columns.Count property

Columns.Item method

Columns.Type property

ColumnTitleHorizontalJustification

TableStyle interface

ColumnValueHorizontalJustification

TableStyle interface

ColumnWidth

TableStyle interface

CombineFeature interface

Edit

KeepToolBodies

Operation

ToolBodies

CombineFeature.Edit method

CombineFeature.KeepToolBodies property

CombineFeature.Operation property

CombineFeature.ToolBodies property

CombineFeatureProxy interface

ContainingOccurrence

NativeObject

CombineFeatureProxy.ContainingOccurrence property

CombineFeatureProxy.NativeObject property

CombineFeatures

PartFeatures interface

CombineFeatures interface

Add

Application

Count

Item

Type

CombineFeatures.Add method

CombineFeatures.Application property

CombineFeatures.Count property

CombineFeatures.Item method

CombineFeatures.Type property

ComboBoxDefinition coclass

ComboBoxDefinitionObject interface

AddItem

Clear

DropDownWidth

ListCount

ListIndex

ListItem

RemoveItem

Text

ComboBoxDefinitionObject.AddItem method

ComboBoxDefinitionObject.Clear method

ComboBoxDefinitionObject.DropDownWidth property

ComboBoxDefinitionObject.ListCount property

ComboBoxDefinitionObject.ListIndex property

ComboBoxDefinitionObject.ListItem method

ComboBoxDefinitionObject.RemoveItem method

ComboBoxDefinitionObject.Text property

ComboBoxDefinitionSink interface

OnHelp

OnSelect

ComboBoxDefinitionSink.OnHelp method

ComboBoxDefinitionSink.OnSelect method

CommandBar

CommandBarControl interface

CommandBar interface

Application

BuiltIn

ClientId

CommandBarType

Controls

Copy

Delete

DisplayName

InternalName

Parent

Type

Visible

CommandBar.Application property

CommandBar.BuiltIn property

CommandBar.ClientId property

CommandBar.CommandBarType property

CommandBar.Controls property

CommandBar.Copy method

CommandBar.Delete method

CommandBar.DisplayName property

CommandBar.InternalName property

CommandBar.Parent property

CommandBar.Type property

CommandBar.Visible property

CommandBarControl interface

Application

BuiltIn

CommandBar

ControlDefinition

ControlType

Delete

DisplayedControl

DisplayName

GroupBegins

Index

InternalName

Parent

Type

CommandBarControl.Application property

CommandBarControl.BuiltIn property

CommandBarControl.CommandBar property

CommandBarControl.ControlDefinition property

CommandBarControl.ControlType property

CommandBarControl.Delete method

CommandBarControl.DisplayedControl property

CommandBarControl.DisplayName property

CommandBarControl.GroupBegins property

CommandBarControl.Index property

CommandBarControl.InternalName property

CommandBarControl.Parent property

CommandBarControl.Type property

CommandBarControls interface

AddButton

AddButtonPopup

AddComboBox

AddMacro

AddPopup

AddSplitButton

AddSplitButtonMRU

Application

Count

Item

Type

CommandBarControls.AddButton method

CommandBarControls.AddButtonPopup method

CommandBarControls.AddComboBox method

CommandBarControls.AddMacro method

CommandBarControls.AddPopup method

CommandBarControls.AddSplitButton method

CommandBarControls.AddSplitButtonMRU method

CommandBarControls.Application property

CommandBarControls.Count property

CommandBarControls.Item method

CommandBarControls.Type property

CommandBarList

PanelBarObject interface

CommandBarList interface

Add

Application

Count

InheritAll

Item

Remove

Type

CommandBarList.Add method

CommandBarList.Application property

CommandBarList.Count property

CommandBarList.InheritAll property

CommandBarList.Item method

CommandBarList.Remove method

CommandBarList.Type property

CommandBars

UserInterfaceManager interface

CommandBars interface

Add

Application

Count

Item

Type

CommandBars.Add method

CommandBars.Application property

CommandBars.Count property

CommandBars.Item method

CommandBars.Type property

CommandBarType

CommandBar interface

CommandCategories

CommandManager interface

CommandCategories interface

Add

Application

Count

Item

Type

CommandCategories.Add method

CommandCategories.Application property

CommandCategories.Count property

CommandCategories.Item method

CommandCategories.Type property

CommandCategory interface

Add

Application

BuiltIn

ClientId

Count

Delete

DisplayName

InternalName

Item

Parent

Remove

Type

CommandCategory.Add method

CommandCategory.Application property

CommandCategory.BuiltIn property

CommandCategory.ClientId property

CommandCategory.Count property

CommandCategory.Delete method

CommandCategory.DisplayName property

CommandCategory.InternalName property

CommandCategory.Item method

CommandCategory.Parent property

CommandCategory.Remove method

CommandCategory.Type property

CommandControl interface

Application

ChildControls

ControlDefinition

ControlType

Delete

DisplayedControl

DisplayName

InternalName

KeyTip

Parent

ShowText

Type

UseLargeIcon

Visible

CommandControl.Application property

CommandControl.ChildControls property

CommandControl.ControlDefinition property

CommandControl.ControlType property

CommandControl.Delete method

CommandControl.DisplayedControl property

CommandControl.DisplayName property

CommandControl.InternalName property

CommandControl.KeyTip property

CommandControl.Parent property

CommandControl.ShowText property

CommandControl.Type property

CommandControl.UseLargeIcon property

CommandControl.Visible property

CommandControls

RibbonPanel interface

CommandControls interface

AddButton

AddButtonPopup

AddComboBox

AddCopy

AddGallery

AddMacro

AddPopup

AddSeparator

AddSplitButton

AddSplitButtonMRU

AddTogglePopup

Application

Count

Item

Type

CommandControls.AddButton method

CommandControls.AddButtonPopup method

CommandControls.AddComboBox method

CommandControls.AddCopy method

CommandControls.AddGallery method

CommandControls.AddMacro method

CommandControls.AddPopup method

CommandControls.AddSeparator method

CommandControls.AddSplitButton method

CommandControls.AddSplitButtonMRU method

CommandControls.AddTogglePopup method

CommandControls.Application property

CommandControls.Count property

CommandControls.Item method

CommandControls.Type property

CommandControlsEnumerator interface

Application

Count

Item

Type

CommandControlsEnumerator.Application property

CommandControlsEnumerator.Count property

CommandControlsEnumerator.Item method

CommandControlsEnumerator.Type property

CommandManager

Application interface

CommandManager interface

ActiveCommand

ClearPrivateEvents

CommandCategories

ControlDefinitions

CreateDragContext

CreateInteractionEvents

CreateMiniToolbar

DoPreSelect

DoSelect

DoStopPreSelect

DoUnSelect

Parent

PeekPrivateEvent

Pick

PostPrivateEvent

PromptMessage

SelectionActive

StartCommand

StartExecutable

StopActiveCommand

Type

UserInputEvents

CommandManager.ActiveCommand property

CommandManager.ClearPrivateEvents method

CommandManager.CommandCategories property

CommandManager.ControlDefinitions property

CommandManager.CreateDragContext method

CommandManager.CreateInteractionEvents method

CommandManager.CreateMiniToolbar method

CommandManager.DoPreSelect method

CommandManager.DoSelect method

CommandManager.DoStopPreSelect method

CommandManager.DoUnSelect method

CommandManager.Parent property

CommandManager.PeekPrivateEvent method

CommandManager.Pick method

CommandManager.PostPrivateEvent method

CommandManager.PromptMessage method

CommandManager.SelectionActive property

CommandManager.StartCommand method

CommandManager.StartExecutable method

CommandManager.StopActiveCommand method

CommandManager.Type property

CommandManager.UserInputEvents property

CommandName

ChangeDefinitionObject interface

Comment

Parameter interface

Comments

Style interface

CommittedTransactions

TransactionManager interface

Compacted

ApprenticeServerDocument interface

Document interface

CompactModelHistory

ModelingSettings interface

CompactModelHistoryOnNextSave

PartComponentDefinition interface

CompatibleUnits

UnitsOfMeasure interface

ComponentDefinition

ApprenticeServerDocument interface

AssemblyDocument interface

BIMComponent interface

PartDocument interface

SurfaceBody interface

ComponentDefinition interface

Application

AttributeSets

BOMQuantity

BOMStructure

ClientGraphicsCollection

DataIO

Document

FindUsingPoint

FindUsingVector

ModelGeometryVersion

Occurrences

RangeBox

SurfaceBodies

Type

ComponentDefinition.Application property

ComponentDefinition.AttributeSets property

ComponentDefinition.BOMQuantity property

ComponentDefinition.BOMStructure property

ComponentDefinition.ClientGraphicsCollection property

ComponentDefinition.DataIO property

ComponentDefinition.Document property

ComponentDefinition.FindUsingPoint method

ComponentDefinition.FindUsingVector method

ComponentDefinition.ModelGeometryVersion property

ComponentDefinition.Occurrences property

ComponentDefinition.RangeBox property

ComponentDefinition.SurfaceBodies property

ComponentDefinition.Type property

ComponentDefinitions

BOMRow interface

ComponentDefinitions interface

Count

Item

Type

ComponentDefinitions.Count property

ComponentDefinitions.Item method

ComponentDefinitions.Type property

ComponentDefinitionsEnumerator interface

Count

Item

Type

ComponentDefinitionsEnumerator.Count property

ComponentDefinitionsEnumerator.Item method

ComponentDefinitionsEnumerator.Type property

ComponentDescription

BIMComponent interface

ComponentGraphics interface

Body

BurnThrough

Color

DepthPriority

DisplayedEdges

DisplayedFaces

DisplaySilhouettes

GetCustomLineType

GetTransformBehavior

LineDefinitionSpace

LineScale

LineType

LineWeight

SetCustomLineType

SetTransformBehavior

ComponentGraphics.Body property

ComponentGraphics.BurnThrough property

ComponentGraphics.Color property

ComponentGraphics.DepthPriority property

ComponentGraphics.DisplayedEdges property

ComponentGraphics.DisplayedFaces property

ComponentGraphics.DisplaySilhouettes property

ComponentGraphics.GetCustomLineType method

ComponentGraphics.GetTransformBehavior method

ComponentGraphics.LineDefinitionSpace property

ComponentGraphics.LineScale property

ComponentGraphics.LineType property

ComponentGraphics.LineWeight property

ComponentGraphics.SetCustomLineType method

ComponentGraphics.SetTransformBehavior method

ComponentOccurrence interface

ActiveDesignViewRepresentation

ActiveLevelOfDetailRepresentation

ActivePositionalRepresentation

Adaptive

Application

AttributeSets

BOMStructure

ChangeRowOfiAssemblyMember

ChangeRowOfiPartMember

Constraints

ContactSet

ContextDefinition

CreateGeometryProxy

Definition

DefinitionDocumentType

Delete

DisabledActionTypes

Edit

Enabled

Excluded

ExitEdit

Flexible

GetDegreesOfFreedom

GetDisplayMode

GetReferenceKey

GetRenderStyle

Grounded

HasBodyOverride

iMateDefinitions

IsiAssemblyMember

IsiPartMember

IsPatternElement

IsSubstituteOccurrence

MassProperties

Name

OccurrencePath

OverrideOpacity

Parent

ParentOccurrence

PatternElement

RangeBox

ReferencedDocumentDescriptor

Replace

SetDesignViewRepresentation

SetDisplayMode

SetLevelOfDetailRepresentation

SetRenderStyle

SetTransformWithoutConstraints

ShowDegreesOfFreedom

SubOccurrences

Suppress

Suppressed

SurfaceBodies

Transformation

Type

Unsuppress

Visible

ComponentOccurrence.ActiveDesignViewRepresentation property

ComponentOccurrence.ActiveLevelOfDetailRepresentation property

ComponentOccurrence.ActivePositionalRepresentation property

ComponentOccurrence.Adaptive property

ComponentOccurrence.Application property

ComponentOccurrence.AttributeSets property

ComponentOccurrence.BOMStructure property

ComponentOccurrence.ChangeRowOfiAssemblyMember method

ComponentOccurrence.ChangeRowOfiPartMember method

ComponentOccurrence.Constraints property

ComponentOccurrence.ContactSet property

ComponentOccurrence.ContextDefinition property

ComponentOccurrence.CreateGeometryProxy method

ComponentOccurrence.Definition property

ComponentOccurrence.DefinitionDocumentType property

ComponentOccurrence.Delete method

ComponentOccurrence.DisabledActionTypes property

ComponentOccurrence.Edit method

ComponentOccurrence.Enabled property

ComponentOccurrence.Excluded property

ComponentOccurrence.ExitEdit method

ComponentOccurrence.Flexible property

ComponentOccurrence.GetDegreesOfFreedom method

ComponentOccurrence.GetDisplayMode method

ComponentOccurrence.GetReferenceKey method

ComponentOccurrence.GetRenderStyle method

ComponentOccurrence.Grounded property

ComponentOccurrence.HasBodyOverride property

ComponentOccurrence.iMateDefinitions property

ComponentOccurrence.IsiAssemblyMember property

ComponentOccurrence.IsiPartMember property

ComponentOccurrence.IsPatternElement property

ComponentOccurrence.IsSubstituteOccurrence property

ComponentOccurrence.MassProperties property

ComponentOccurrence.Name property

ComponentOccurrence.OccurrencePath property

ComponentOccurrence.OverrideOpacity property

ComponentOccurrence.Parent property

ComponentOccurrence.ParentOccurrence property

ComponentOccurrence.PatternElement property

ComponentOccurrence.RangeBox property

ComponentOccurrence.ReferencedDocumentDescriptor property

ComponentOccurrence.Replace method

ComponentOccurrence.SetDesignViewRepresentation method

ComponentOccurrence.SetDisplayMode method

ComponentOccurrence.SetLevelOfDetailRepresentation method

ComponentOccurrence.SetRenderStyle method

ComponentOccurrence.SetTransformWithoutConstraints method

ComponentOccurrence.ShowDegreesOfFreedom property

ComponentOccurrence.SubOccurrences property

ComponentOccurrence.Suppress method

ComponentOccurrence.Suppressed property

ComponentOccurrence.SurfaceBodies property

ComponentOccurrence.Transformation property

ComponentOccurrence.Type property

ComponentOccurrence.Unsuppress method

ComponentOccurrence.Visible property

ComponentOccurrenceProxy interface

ContainingOccurrence

NativeObject

ComponentOccurrenceProxy.ContainingOccurrence property

ComponentOccurrenceProxy.NativeObject property

ComponentOccurrences interface

Add

AddByComponentDefinition

AddCustomiPartMember

AddiAssemblyMember

AddiPartMember

AddUsingiMates

AddVirtual

AddWithOptions

AllLeafOccurrences

AllReferencedOccurrences

ItemByName

ComponentOccurrences.Add method

ComponentOccurrences.AddByComponentDefinition method

ComponentOccurrences.AddCustomiPartMember method

ComponentOccurrences.AddiAssemblyMember method

ComponentOccurrences.AddiPartMember method

ComponentOccurrences.AddUsingiMates method

ComponentOccurrences.AddVirtual method

ComponentOccurrences.AddWithOptions method

ComponentOccurrences.AllLeafOccurrences method

ComponentOccurrences.AllReferencedOccurrences method

ComponentOccurrences.ItemByName method

ComponentOccurrencesEnumerator interface

Count

Item

Type

ComponentOccurrencesEnumerator.Count property

ComponentOccurrencesEnumerator.Item method

ComponentOccurrencesEnumerator.Type property

ComponentPropertySets

BIMComponentDescription interface

Components

OccurrencePatternElement interface

ComponentType

BIMComponentDescription interface

CompositeiMateDefinition interface

Count

Item

RemoveItems

CompositeiMateDefinition.Count property

CompositeiMateDefinition.Item method

CompositeiMateDefinition.RemoveItems method

CompositeiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

CompositeiMateDefinitionProxy.ContainingOccurrence property

CompositeiMateDefinitionProxy.IsConsumed property

CompositeiMateDefinitionProxy.NativeObject property

ComputeType

CircularPatternFeature interface

MirrorFeature interface

RectangularPatternFeature interface

ComputeWithMouseInput

Camera interface

ConcaveEdges

SurfaceBody interface

ConcentricConstraint interface

CenterPointConstraint

EntityOne

EntityTwo

ConcentricConstraint.CenterPointConstraint property

ConcentricConstraint.EntityOne property

ConcentricConstraint.EntityTwo property

ConcentricConstraint3D interface

ConcentricConstraint3DProxy interface

ContainingOccurrence

NativeObject

ConcentricConstraint3DProxy.ContainingOccurrence property

ConcentricConstraint3DProxy.NativeObject property

ConcentricConstraintProxy interface

ContainingOccurrence

NativeObject

ConcentricConstraintProxy.ContainingOccurrence property

ConcentricConstraintProxy.NativeObject property

ConcentricHolePlacementDefinition interface

ConcentricReference

Plane

ConcentricHolePlacementDefinition.ConcentricReference property

ConcentricHolePlacementDefinition.Plane property

ConcentricReference

ConcentricHolePlacementDefinition interface

Condition

LoftRail interface

Cone interface

AxisVector

BasePoint

Evaluator

GetConeData

HalfAngle

IsExpanding

PutConeData

Radius

Cone.AxisVector property

Cone.BasePoint property

Cone.Evaluator property

Cone.GetConeData method

Cone.HalfAngle property

Cone.IsExpanding property

Cone.PutConeData method

Cone.Radius property

ConfigurationTableLayer

ObjectDefaultsStyle interface

ConfigurationTableStyle

ObjectDefaultsStyle interface

ConnectedEntity

CoincidentConstraint3D interface

ConnectionPoint

SketchPoint interface

ConnectionType

BIMCableTrayConnectorDefinition interface

BIMConduitConnectorDefinition interface

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

ConnectorLinks

BIMComponent interface

ConnectorOne

BIMConnectorLink interface

Connectors

BIMComponent interface

ConnectorShape

BIMConnectorDefinition interface

ConnectorTwo

BIMConnectorLink interface

ConnectTo

SketchPoint3D interface

ConstantAttenuation

Light interface

ConstraintAudioNotification

AssemblyOptions interface

ConstraintLimits

AngleConstraint interface

FlushConstraint interface

FlushiMateDefinition interface

InsertConstraint interface

InsertiMateDefinition interface

MateConstraint interface

MateiMateDefinition interface

TangentConstraint interface

TangentiMateDefinition interface

ConstraintLimits interface

Application

Maximum

MaximumEnabled

Minimum

MinimumEnabled

Parent

RestingPositionEnabled

Type

ConstraintLimits.Application property

ConstraintLimits.Maximum property

ConstraintLimits.MaximumEnabled property

ConstraintLimits.Minimum property

ConstraintLimits.MinimumEnabled property

ConstraintLimits.Parent property

ConstraintLimits.RestingPositionEnabled property

ConstraintLimits.Type property

ConstrainToBorder

DrawingViewLabel interface

ConstraintPriority

SketchOptions interface

Constraints

AssemblyComponentDefinition interface

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

AssemblyWorkPointDef interface

ComponentOccurrence interface

iMateResult interface

SketchEntity interface

Constraints3D

SketchEntity3D interface

ConstraintStatus

Sketch interface

SketchBlock interface

SketchEntity interface

SketchEntity3D interface

ConstraintToolbarScale

SketchOptions interface

Construction

SketchEntity interface

SketchEntity3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

ConstructionSurfaces

ObjectVisibility interface

Consumed

PlanarSketch interface

Sketch3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

ConsumeInputs

PartFeature interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

ContactSet

ComponentOccurrence interface

ContainingDWGDocument

ApprenticeServerDrawingDocument interface

DrawingDocument interface

ContainingOccurrence

AngleConstraintProxy interface

AngleiMateDefinitionProxy interface

BendConstraintProxy interface

BendPartFeatureProxy interface

BossFeatureProxy interface

BoundaryPatchFeatureProxy interface

ChamferFeatureProxy interface

CircularOccurrencePatternProxy interface

CircularPatternFeatureProxy interface

ClientFeatureElementProxy interface

ClientFeatureProxy interface

CoilFeatureProxy interface

CoincidentConstraint3DProxy interface

CoincidentConstraintProxy interface

CollinearConstraint3DProxy interface

CollinearConstraintProxy interface

CombineFeatureProxy interface

ComponentOccurrenceProxy interface

CompositeiMateDefinitionProxy interface

ConcentricConstraint3DProxy interface

ConcentricConstraintProxy interface

CustomConstraint3DProxy interface

CustomConstraintProxy interface

DecalFeatureProxy interface

DeleteFaceFeatureProxy interface

DerivedAliasComponentProxy interface

DerivedAssemblyComponentProxy interface

DerivedPartComponentProxy interface

DiameterDimConstraintProxy interface

EdgeLoopProxy interface

EdgeProxy interface

EdgeUseProxy interface

EllipseRadiusDimConstraintProxy interface

EmbossFeatureProxy interface

EqualLengthConstraintProxy interface

EqualRadiusConstraintProxy interface

ExtendFeatureProxy interface

ExtrudeFeatureProxy interface

FaceDraftFeatureProxy interface

FaceProxy interface

FaceShellProxy interface

FeatureBasedOccurrencePatternProxy interface

FeatureDimensionProxy interface

FeaturePatternElementProxy interface

FilletFeatureProxy interface

FlushConstraintProxy interface

FlushiMateDefinitionProxy interface

GraphicsNodeProxy interface

GrillFeatureProxy interface

GroundConstraint3DProxy interface

GroundConstraintProxy interface

HelicalConstraint3DProxy interface

HoleFeatureProxy interface

HorizontalAlignConstraintProxy interface

HorizontalConstraintProxy interface

iFeatureProxy interface

iMateResultProxy interface

InsertConstraintProxy interface

InsertiMateDefinitionProxy interface

KnitFeatureProxy interface

LayoutConstraintProxy interface

LineLengthDimConstraint3DProxy interface

LipFeatureProxy interface

LoftFeatureProxy interface

MateConstraintProxy interface

MateiMateDefinitionProxy interface

MidpointConstraint3DProxy interface

MidpointConstraintProxy interface

MirrorFeatureProxy interface

MoveFaceFeatureProxy interface

MoveFeatureProxy interface

NonParametricBaseFeatureProxy interface

OccurrencePatternElementProxy interface

OffsetConstraintProxy interface

OffsetDimConstraintProxy interface

OffsetSplineDimConstraintProxy interface

ParallelConstraint3DProxy interface

ParallelConstraintProxy interface

PathEntityProxy interface

PathProxy interface

PatternConstraintProxy interface

PerpendicularConstraint3DProxy interface

PerpendicularConstraintProxy interface

PlanarSketchProxy interface

PointAndPlaneDistanceDimConstraint3DProxy interface

Profile3DProxy interface

ProfileEntity3DProxy interface

ProfileEntityProxy interface

ProfilePath3DProxy interface

ProfilePathProxy interface

ProfileProxy interface

ProjectedCutProxy interface

RadiusDimConstraint3DProxy interface

RadiusDimConstraintProxy interface

RectangularOccurrencePatternProxy interface

RectangularPatternFeatureProxy interface

ReferenceFeatureProxy interface

ReplaceFaceFeatureProxy interface

RestFeatureProxy interface

RevolveFeatureProxy interface

RibFeatureProxy interface

RotateRotateConstraintProxy interface

RotateRotateiMateDefinitionProxy interface

RotateTranslateConstraintProxy interface

RotateTranslateiMateDefinitionProxy interface

RuleFilletFeatureProxy interface

SculptFeatureProxy interface

ShellFeatureProxy interface

Sketch3DProxy interface

SketchArc3DProxy interface

SketchArcProxy interface

SketchBlockDefinitionProxy interface

SketchBlockProxy interface

SketchCircle3DProxy interface

SketchCircleProxy interface

SketchEllipse3DProxy interface

SketchEllipseProxy interface

SketchEllipticalArc3DProxy interface

SketchEllipticalArcProxy interface

SketchFixedSpline3DProxy interface

SketchFixedSplineProxy interface

SketchImageProxy interface

SketchLine3DProxy interface

SketchLineProxy interface

SketchOffsetSplineProxy interface

SketchPoint3DProxy interface

SketchPointProxy interface

SketchSpline3DProxy interface

SketchSplineHandle3DProxy interface

SketchSplineHandleProxy interface

SketchSplineProxy interface

SmoothConstraint3DProxy interface

SmoothConstraintProxy interface

SnapFitFeatureProxy interface

SplineFitPointConstraintProxy interface

SplineFitPointsConstraint3DProxy interface

SplitFeatureProxy interface

SurfaceBodyProxy interface

SweepFeatureProxy interface

SymmetryConstraintProxy interface

TangentConstraint3DProxy interface

TangentConstraintProxy interface

TangentDistanceDimConstraintProxy interface

TangentiMateDefinitionProxy interface

TangentSketchConstraintProxy interface

TextBoxConstraintProxy interface

TextBoxProxy interface

ThickenFeatureProxy interface

ThreadFeatureProxy interface

ThreePointAngleDimConstraintProxy interface

TransitionalConstraintProxy interface

TranslateTranslateConstraintProxy interface

TrimFeatureProxy interface

TwoLineAngleDimConstraint3DProxy interface

TwoLineAngleDimConstraintProxy interface

TwoPointDistanceDimConstraint3DProxy interface

TwoPointDistanceDimConstraintProxy interface

UserCoordinateSystemProxy interface

VertexProxy interface

VerticalAlignConstraintProxy interface

VerticalConstraintProxy interface

WorkAxisProxy interface

WorkPlaneProxy interface

WorkPointProxy interface

WorkSurfaceProxy interface

ContainingSketchBlock

SketchBlock interface

SketchEntity interface

SketchImage interface

TextBox interface

ContainingTransaction

CheckPoint interface

Contains

Box interface

Box2d interface

ContentCenter interface

Application

GetContentObject

TreeViewTopNode

Type

ContentCenter.Application property

ContentCenter.GetContentObject method

ContentCenter.TreeViewTopNode property

ContentCenter.Type property

ContentCenterOptions interface

Application

CustomFamilyAsStandard

GetAccessOption

RefreshOutOfDateStandardParts

SetAccessOption

Type

ContentCenterOptions.Application property

ContentCenterOptions.CustomFamilyAsStandard property

ContentCenterOptions.GetAccessOption method

ContentCenterOptions.RefreshOutOfDateStandardParts property

ContentCenterOptions.SetAccessOption method

ContentCenterOptions.Type property

ContentCenterPath

DesignProject interface

FileOptions interface

ContentCenterPathOverridden

DesignProject interface

ContentFamiliesEnumerator interface

Application

Count

Item

Type

ContentFamiliesEnumerator.Application property

ContentFamiliesEnumerator.Count property

ContentFamiliesEnumerator.Item method

ContentFamiliesEnumerator.Type property

ContentFamily interface

ActiveCell

Application

ContentIdentifier

CreateMember

Description

DesignationColumn

DisplayName

FamilyType

FileNameColumn

GetCustomData

HasCustomData

InternalName

IsCustom

IsModifiable

LibraryInternalName

LibraryName

Manufacturer

MemberDirectory

RevisionId

Save

Standard

StandardOrganization

StandardRevision

TableColumns

TableRows

Thumbnail

Type

ContentFamily.ActiveCell property

ContentFamily.Application property

ContentFamily.ContentIdentifier property

ContentFamily.CreateMember method

ContentFamily.Description property

ContentFamily.DesignationColumn property

ContentFamily.DisplayName property

ContentFamily.FamilyType property

ContentFamily.FileNameColumn property

ContentFamily.GetCustomData method

ContentFamily.HasCustomData method

ContentFamily.InternalName property

ContentFamily.IsCustom property

ContentFamily.IsModifiable property

ContentFamily.LibraryInternalName property

ContentFamily.LibraryName property

ContentFamily.Manufacturer property

ContentFamily.MemberDirectory property

ContentFamily.RevisionId property

ContentFamily.Save method

ContentFamily.Standard property

ContentFamily.StandardOrganization property

ContentFamily.StandardRevision property

ContentFamily.TableColumns property

ContentFamily.TableRows property

ContentFamily.Thumbnail property

ContentFamily.Type property

ContentIdentifier

ContentFamily interface

ContentTableRow interface

ContentTableCell interface

Application

Column

IsOverridden

Parent

Row

Type

Value

ContentTableCell.Application property

ContentTableCell.Column property

ContentTableCell.IsOverridden property

ContentTableCell.Parent property

ContentTableCell.Row property

ContentTableCell.Type property

ContentTableCell.Value property

ContentTableColumn interface

Application

ClearPropertyMap

DataType

DisplayHeading

Expression

GetPropertyMap

HasPropertyMap

InternalName

KeyColumnOrder

Parent

SetPropertyMap

Type

Units

ContentTableColumn.Application property

ContentTableColumn.ClearPropertyMap method

ContentTableColumn.DataType property

ContentTableColumn.DisplayHeading property

ContentTableColumn.Expression property

ContentTableColumn.GetPropertyMap method

ContentTableColumn.HasPropertyMap property

ContentTableColumn.InternalName property

ContentTableColumn.KeyColumnOrder property

ContentTableColumn.Parent property

ContentTableColumn.SetPropertyMap method

ContentTableColumn.Type property

ContentTableColumn.Units property

ContentTableColumns interface

Add

Application

Count

CreateExpressionLimits

Item

Type

ContentTableColumns.Add method

ContentTableColumns.Application property

ContentTableColumns.Count property

ContentTableColumns.CreateExpressionLimits method

ContentTableColumns.Item method

ContentTableColumns.Type property

ContentTableRow interface

Application

ContentIdentifier

Count

Delete

GetCellValue

Index

InternalName

IsSuppressed

Item

Parent

Type

ContentTableRow.Application property

ContentTableRow.ContentIdentifier property

ContentTableRow.Count property

ContentTableRow.Delete method

ContentTableRow.GetCellValue method

ContentTableRow.Index property

ContentTableRow.InternalName property

ContentTableRow.IsSuppressed property

ContentTableRow.Item method

ContentTableRow.Parent property

ContentTableRow.Type property

ContentTableRows interface

Add

Application

Count

Item

Type

ContentTableRows.Add method

ContentTableRows.Application property

ContentTableRows.Count property

ContentTableRows.Item method

ContentTableRows.Type property

ContentTreeViewNode interface

Application

ChildNodes

DisplayName

Families

FullTreeViewPath

Icon

InternalName

ParentNode

Type

ContentTreeViewNode.Application property

ContentTreeViewNode.ChildNodes property

ContentTreeViewNode.DisplayName property

ContentTreeViewNode.Families property

ContentTreeViewNode.FullTreeViewPath property

ContentTreeViewNode.Icon property

ContentTreeViewNode.InternalName property

ContentTreeViewNode.ParentNode property

ContentTreeViewNode.Type property

ContentTreeViewNodesEnumerator interface

Application

Count

Item

Type

ContentTreeViewNodesEnumerator.Application property

ContentTreeViewNodesEnumerator.Count property

ContentTreeViewNodesEnumerator.Item method

ContentTreeViewNodesEnumerator.Type property

ContextDefinition

ComponentOccurrence interface

ContextMenuList

Environment interface

Contextual

RibbonTab interface

Continuity

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

ContinuityType

FilletConstantRadiusEdgeSet interface

FilletVariableRadiusEdgeSet interface

ContinuousRunning

OrdinateDimensionSet interface

ContourFlangeDefinition interface

Application

ApplyAutoMitering

BendOptions

BendRadius

Copy

CornerOptions

DefaultWidthExtent

DefaultWidthExtentType

Edges

ExtendFaces

ExtentDirection

GetWidthExtent

GetWidthExtentType

IsUnfoldMethodOverridden

MiterGap

Parent

Path

SetCenteredDefaultWidthExtent

SetCenteredWidthExtent

SetDistanceExtent

SetEdgeDefaultWidthExtent

SetEdgeWidthExtent

SetFromToDefaultWidthExtent

SetFromToWidthExtent

SetOffsetDefaultWidthExtent

SetOffsetWidthExtent

SetWidthOffsetDefaultWidthExtent

SetWidthOffsetWidthExtent

Type

UnfoldMethod

ContourFlangeDefinition.Application property

ContourFlangeDefinition.ApplyAutoMitering property

ContourFlangeDefinition.BendOptions property

ContourFlangeDefinition.BendRadius property

ContourFlangeDefinition.Copy method

ContourFlangeDefinition.CornerOptions property

ContourFlangeDefinition.DefaultWidthExtent property

ContourFlangeDefinition.DefaultWidthExtentType property

ContourFlangeDefinition.Edges property

ContourFlangeDefinition.ExtendFaces property

ContourFlangeDefinition.ExtentDirection property

ContourFlangeDefinition.GetWidthExtent method

ContourFlangeDefinition.GetWidthExtentType method

ContourFlangeDefinition.IsUnfoldMethodOverridden property

ContourFlangeDefinition.MiterGap property

ContourFlangeDefinition.Parent property

ContourFlangeDefinition.Path property

ContourFlangeDefinition.SetCenteredDefaultWidthExtent method

ContourFlangeDefinition.SetCenteredWidthExtent method

ContourFlangeDefinition.SetDistanceExtent method

ContourFlangeDefinition.SetEdgeDefaultWidthExtent method

ContourFlangeDefinition.SetEdgeWidthExtent method

ContourFlangeDefinition.SetFromToDefaultWidthExtent method

ContourFlangeDefinition.SetFromToWidthExtent method

ContourFlangeDefinition.SetOffsetDefaultWidthExtent method

ContourFlangeDefinition.SetOffsetWidthExtent method

ContourFlangeDefinition.SetWidthOffsetDefaultWidthExtent method

ContourFlangeDefinition.SetWidthOffsetWidthExtent method

ContourFlangeDefinition.Type property

ContourFlangeDefinition.UnfoldMethod property

ContourFlangeFeature interface

BendFeature

Definition

ContourFlangeFeature.BendFeature property

ContourFlangeFeature.Definition property

ContourFlangeFeatureProxy interface

ContourFlangeFeatures

SheetMetalFeatures interface

ContourFlangeFeatures interface

Add

Application

Count

CreateContourFlangeDefinition

Item

Type

ContourFlangeFeatures.Add method

ContourFlangeFeatures.Application property

ContourFlangeFeatures.Count property

ContourFlangeFeatures.CreateContourFlangeDefinition method

ContourFlangeFeatures.Item method

ContourFlangeFeatures.Type property

ContourRollFeature interface

ContourRollFeatureProxy interface

ContourRollFeatures

SheetMetalFeatures interface

ContourRollFeatures interface

Application

Count

Item

Type

ContourRollFeatures.Application property

ContourRollFeatures.Count property

ContourRollFeatures.Item method

ContourRollFeatures.Type property

Control

BrowserPaneObject interface

DockableWindow interface

ControlDefinition

CommandBarControl interface

CommandControl interface

ControlDefinition interface

Application

AutoAddToGUI

BuiltIn

Classification

ClientId

DefaultShortcut

DefaultShortcutType

DefinitionType

Delete

DescriptionText

DisplayName

Enabled

Execute

Execute2

InternalName

IsShortcutOverridden

LargeIcon

OverrideShortcut

OverrideShortcutType

Parent

ProgressiveToolTip

StandardIcon

ToolTipText

Type

ControlDefinition.Application property

ControlDefinition.AutoAddToGUI method

ControlDefinition.BuiltIn property

ControlDefinition.Classification property

ControlDefinition.ClientId property

ControlDefinition.DefaultShortcut property

ControlDefinition.DefaultShortcutType property

ControlDefinition.DefinitionType property

ControlDefinition.Delete method

ControlDefinition.DescriptionText property

ControlDefinition.DisplayName property

ControlDefinition.Enabled property

ControlDefinition.Execute method

ControlDefinition.Execute2 method

ControlDefinition.InternalName property

ControlDefinition.IsShortcutOverridden property

ControlDefinition.LargeIcon property

ControlDefinition.OverrideShortcut property

ControlDefinition.OverrideShortcutType property

ControlDefinition.Parent property

ControlDefinition.ProgressiveToolTip property

ControlDefinition.StandardIcon property

ControlDefinition.ToolTipText property

ControlDefinition.Type property

ControlDefinitionEvents coclass

ControlDefinitionEventsObject interface

Application

FireOnCommandInputs

Parent

Type

ControlDefinitionEventsObject.Application property

ControlDefinitionEventsObject.FireOnCommandInputs method

ControlDefinitionEventsObject.Parent property

ControlDefinitionEventsObject.Type property

ControlDefinitionEventsSink interface

OnCommandInputs

ControlDefinitionEventsSink.OnCommandInputs method

ControlDefinitions

CommandManager interface

ControlDefinitions interface

AddButtonDefinition

AddComboBoxDefinition

AddMacroControlDefinition

Application

Count

Item

Type

UseDefaultMultiCharAliases

ControlDefinitions.AddButtonDefinition method

ControlDefinitions.AddComboBoxDefinition method

ControlDefinitions.AddMacroControlDefinition method

ControlDefinitions.Application property

ControlDefinitions.Count property

ControlDefinitions.Item method

ControlDefinitions.Type property

ControlDefinitions.UseDefaultMultiCharAliases property

Controls

CommandBar interface

MiniToolbarObject interface

ControlType

CommandBarControl interface

CommandControl interface

MiniToolbarControl interface

Converge

LoftedFlangeDefinition interface

ConvertToAngleConstraint

AssemblyConstraint interface

ConvertToCustomConstraint

AssemblyConstraint interface

ConvertToFlushConstraint

AssemblyConstraint interface

ConvertToInsertConstraint

AssemblyConstraint interface

ConvertToLocal

LightingStyle interface

Material interface

RenderStyle interface

Style interface

ConvertToMateConstraint

AssemblyConstraint interface

ConvertToModelParameter

ReferenceParameter interface

UserParameter interface

ConvertToReferenceParameter

ModelParameter interface

UserParameter interface

ConvertToRotateRotateConstraint

AssemblyConstraint interface

ConvertToRotateTranslateConstraint

AssemblyConstraint interface

ConvertToSpline

SketchFixedSpline interface

SketchFixedSpline3D interface

SketchOffsetSpline interface

ConvertToTangentConstraint

AssemblyConstraint interface

ConvertToTransitionalConstraint

AssemblyConstraint interface

ConvertToUserParameter

ModelParameter interface

ReferenceParameter interface

TableParameter interface

ConvertUnits

UnitsOfMeasure interface

ConvexEdges

SurfaceBody interface

Coordinate

GraphicsCoordinateSet interface

GraphicsTextureCoordinateSet interface

CoordinateIndexSet

LineGraphics interface

LineStripGraphics interface

PointGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

CoordinateSet

LineGraphics interface

LineStripGraphics interface

PointGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

Copy

AttributeSet interface

BendDefinition interface

BendOptions interface

CommandBar interface

ContourFlangeDefinition interface

CoreCavityDefinition interface

CornerChamferDefinition interface

CornerDefinition interface

CornerOptions interface

CornerRoundDefinition interface

DesignViewRepresentation interface

DraftAnalysis interface

ExtrudeDefinition interface

FlangeDefinition interface

FoldDefinition interface

GraphicsNode interface

HemDefinition interface

iAssemblyTableRow interface

iFeatureTableRow interface

iPartTableRow interface

LevelOfDetailRepresentation interface

LightingStyle interface

LoftDefinition interface

LoftedFlangeDefinition interface

Material interface

MoveFaceDefinition interface

PositionalRepresentation interface

RenderStyle interface

RibDefinition interface

RipDefinition interface

SheetMetalStyles interface

ShellDefinition interface

Style interface

TransientBRep interface

CopyContentsTo

Sketch interface

CopyFile

FileManager interface

CopyTo

AttributeSet interface

AutoCADBlockDefinition interface

BorderDefinition interface

CustomTable interface

DrawingView interface

PartsList interface

Sheet interface

SheetFormat interface

SketchBlockDefinition interface

SketchedSymbolDefinition interface

TitleBlockDefinition interface

CopyToFlatPattern

PlanarSketch interface

CopyWithOwner

AttributeSet interface

Core

CoreCavityFeature interface

CoreCavityDefinition interface

Application

Copy

HolePatches

Inserts

Parent

PartBody

PullDirection

RunoffSurfaces

Tolerance

Type

WorkpieceBody

CoreCavityDefinition.Application property

CoreCavityDefinition.Copy method

CoreCavityDefinition.HolePatches property

CoreCavityDefinition.Inserts property

CoreCavityDefinition.Parent property

CoreCavityDefinition.PartBody property

CoreCavityDefinition.PullDirection property

CoreCavityDefinition.RunoffSurfaces property

CoreCavityDefinition.Tolerance property

CoreCavityDefinition.Type property

CoreCavityDefinition.WorkpieceBody property

CoreCavityFeature interface

Cavity

Core

Definition

CoreCavityFeature.Cavity property

CoreCavityFeature.Core property

CoreCavityFeature.Definition property

CoreCavityFeatureProxy interface

CoreCavityFeatures

PartFeatures interface

CoreCavityFeatures interface

Add

Application

Count

CreateDefinition

Item

Type

CoreCavityFeatures.Add method

CoreCavityFeatures.Application property

CoreCavityFeatures.Count property

CoreCavityFeatures.CreateDefinition method

CoreCavityFeatures.Item method

CoreCavityFeatures.Type property

CornerChamferDefinition interface

Application

ChamferDefinition

ChamferDefinitionType

Copy

CornerEdges

Parent

SetDistance

SetDistanceAndAngle

SetTwoDistances

Type

CornerChamferDefinition.Application property

CornerChamferDefinition.ChamferDefinition property

CornerChamferDefinition.ChamferDefinitionType property

CornerChamferDefinition.Copy method

CornerChamferDefinition.CornerEdges property

CornerChamferDefinition.Parent property

CornerChamferDefinition.SetDistance method

CornerChamferDefinition.SetDistanceAndAngle method

CornerChamferDefinition.SetTwoDistances method

CornerChamferDefinition.Type property

CornerChamferFeature interface

Definition

CornerChamferFeature.Definition property

CornerChamferFeatureProxy interface

CornerChamferFeatures

FlatPatternFeatures interface

SheetMetalFeatures interface

CornerChamferFeatures interface

Add

Application

Count

CreateCornerChamferDefinition

Item

Type

CornerChamferFeatures.Add method

CornerChamferFeatures.Application property

CornerChamferFeatures.Count property

CornerChamferFeatures.CreateCornerChamferDefinition method

CornerChamferFeatures.Item method

CornerChamferFeatures.Type property

CornerDefinition interface

AlignedCornerExtension

Application

BendOptions

Copy

CornerDefinitionType

CornerOptions

CornerType

Edges

GapWidth

IsRippedCorner

Parent

PercentOverlap

Type

CornerDefinition.AlignedCornerExtension property

CornerDefinition.Application property

CornerDefinition.BendOptions property

CornerDefinition.Copy method

CornerDefinition.CornerDefinitionType property

CornerDefinition.CornerOptions property

CornerDefinition.CornerType property

CornerDefinition.Edges property

CornerDefinition.GapWidth property

CornerDefinition.IsRippedCorner property

CornerDefinition.Parent property

CornerDefinition.PercentOverlap property

CornerDefinition.Type property

CornerDefinitionType

CornerDefinition interface

CornerEdges

CornerChamferDefinition interface

CornerFeature interface

Definition

CornerFeature.Definition property

CornerFeatureProxy interface

CornerFeatures

SheetMetalFeatures interface

CornerFeatures interface

Add

Application

Count

CreateCornerDefinition

Item

Type

CornerFeatures.Add method

CornerFeatures.Application property

CornerFeatures.Count property

CornerFeatures.CreateCornerDefinition method

CornerFeatures.Item method

CornerFeatures.Type property

CornerOptions

ContourFlangeDefinition interface

CornerDefinition interface

FlangeDefinition interface

CornerOptions interface

Copy

CornerReliefShape

CornerReliefSize

IsTwoBend

Parent

Type

CornerOptions.Copy method

CornerOptions.CornerReliefShape property

CornerOptions.CornerReliefSize property

CornerOptions.IsTwoBend property

CornerOptions.Parent property

CornerOptions.Type property

CornerReliefShape

CornerOptions interface

SheetMetalStyle interface

CornerReliefSize

CornerOptions interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

CornerRoundDefinition interface

AddEdgeSet

Application

Copy

EdgeSetCount

EdgeSetItem

Parent

RemoveEdgeSet

Type

CornerRoundDefinition.AddEdgeSet method

CornerRoundDefinition.Application property

CornerRoundDefinition.Copy method

CornerRoundDefinition.EdgeSetCount property

CornerRoundDefinition.EdgeSetItem method

CornerRoundDefinition.Parent property

CornerRoundDefinition.RemoveEdgeSet method

CornerRoundDefinition.Type property

CornerRoundEdgeSet interface

Edges

Parent

Radius

Type

CornerRoundEdgeSet.Edges property

CornerRoundEdgeSet.Parent property

CornerRoundEdgeSet.Radius property

CornerRoundEdgeSet.Type property

CornerRoundFeature interface

Definition

CornerRoundFeature.Definition property

CornerRoundFeatureProxy interface

CornerRoundFeatures

FlatPatternFeatures interface

SheetMetalFeatures interface

CornerRoundFeatures interface

Add

Application

Count

CreateCornerRoundDefinition

Item

Type

CornerRoundFeatures.Add method

CornerRoundFeatures.Application property

CornerRoundFeatures.Count property

CornerRoundFeatures.CreateCornerRoundDefinition method

CornerRoundFeatures.Item method

CornerRoundFeatures.Type property

CornerSetback

DistanceChamferDef interface

CornerType

CornerDefinition interface

CosmeticBendFeature interface

CosmeticBendFeatureProxy interface

CosmeticBendFeatures

FlatPatternFeatures interface

CosmeticBendFeatures interface

Application

Count

Item

Type

CosmeticBendFeatures.Application property

CosmeticBendFeatures.Count property

CosmeticBendFeatures.Item method

CosmeticBendFeatures.Type property

CosmeticWeld interface

Edges

CosmeticWeld.Edges property

CosmeticWelds

Welds interface

CosmeticWelds interface

Application

Count

Item

Type

CosmeticWelds.Application property

CosmeticWelds.Count property

CosmeticWelds.Item method

CosmeticWelds.Type property

Count

AliasFreeformFeatures interface

ApplicationAddIns interface

ApprenticeServerDocuments interface

AssemblyComponentDefinitions interface

AssemblyConstraints interface

AssemblyConstraintsEnumerator interface

AttributesEnumerator interface

AttributeSet interface

AttributeSets interface

AttributeSetsEnumerator interface

AutoCADBlockDefinitions interface

AutoCADBlockDefinitionsEnumerator interface

AutoCADBlocks interface

Balloons interface

BalloonStylesEnumerator interface

BalloonTips interface

BalloonValueSets interface

BaselineDimensionSets interface

BendFeatures interface

BendNotes interface

BendPartFeatures interface

BendsEnumerator interface

BIMComponentPropertySet interface

BIMComponentPropertySets interface

BIMConnectorLinks interface

BIMConnectors interface

BOMRowsEnumerator interface

BOMViews interface

BorderDefinitions interface

BossFeatures interface

BossSets interface

BoundaryPatchFeatures interface

BoundaryPatchLoops interface

BreakOperations interface

BreakOutOperations interface

BrowserFoldersEnumerator interface

BrowserNodesEnumerator interface

BrowserPanes interface

Centerlines interface

Centermarks interface

CentermarkStylesEnumerator interface

ChainDimensionSets interface

ChamferFeatures interface

ChamferNotes interface

ChangeDefinitions interface

ChangeManager interface

CheckPointsEnumerator interface

CircularPatternFeature interface

CircularPatternFeatures interface

ClientFeatureElements interface

ClientFeatures interface

ClientGraphics interface

ClientGraphicsCollection interface

ClientNodeResources interface

ClientViews interface

CoilFeatures interface

ColorSchemes interface

Columns interface

CombineFeatures interface

CommandBarControls interface

CommandBarList interface

CommandBars interface

CommandCategories interface

CommandCategory interface

CommandControls interface

CommandControlsEnumerator interface

ComponentDefinitions interface

ComponentDefinitionsEnumerator interface

ComponentOccurrencesEnumerator interface

CompositeiMateDefinition interface

ContentFamiliesEnumerator interface

ContentTableColumns interface

ContentTableRow interface

ContentTableRows interface

ContentTreeViewNodesEnumerator interface

ContourFlangeFeatures interface

ContourRollFeatures interface

ControlDefinitions interface

CoreCavityFeatures interface

CornerChamferFeatures interface

CornerFeatures interface

CornerRoundFeatures interface

CosmeticBendFeatures interface

CosmeticWelds interface

CustomParameterGroup interface

CustomParameterGroups interface

CustomTables interface

CutFeatures interface

DecalFeatures interface

DeleteFaceFeatures interface

DerivedAliasComponents interface

DerivedAssemblyComponents interface

DerivedAssemblyOccurrences interface

DerivedParameters interface

DerivedParameterTables interface

DerivedPartComponents interface

DerivedPartEntities interface

DesignProjects interface

DesignViewRepresentations interface

DimensionConstraints interface

DimensionConstraints3D interface

DimensionStylesEnumerator interface

DisabledCommandList interface

DockableWindows interface

DocumentDescriptorsEnumerator interface

DocumentInterests interface

DocumentsEnumerator interface

DraftAnalyses interface

DrawingBOMColumns interface

DrawingBOMRow interface

DrawingBOMRows interface

DrawingBOMs interface

DrawingCurveSegments interface

DrawingCurvesEnumerator interface

DrawingDimensions interface

DrawingNotes interface

DrawingSketches interface

DrawingStandardStylesEnumerator interface

DrawingViews interface

EdgeDefinitions interface

EdgeLoopDefinitions interface

EdgeLoops interface

Edges interface

EdgeUseDefinitions interface

EdgeUses interface

EmbossFeatures interface

EnumType interface

EnvironmentList interface

Environments interface

ExpressionList interface

ExtendFeatures interface

ExtrudeFeatures interface

FaceDefinitions interface

FaceDraftFeatures interface

FaceFeatures interface

Faces interface

FaceShellDefinitions interface

FaceShells interface

FeatureControlFrameRows interface

FeatureControlFrames interface

FeatureControlFrameStylesEnumerator interface

FeatureDimensions interface

FeaturePatternElements interface

Features interface

FileDescriptorsEnumerator interface

FilesEnumerator interface

FilletFeatures interface

FlangeFeatures interface

FlatBendResults interface

FlatPatternFeatures interface

FlatPunchResults interface

FoldFeatures interface

GeneralDimensions interface

GeneralDimensionsEnumerator interface

GeneralNotes interface

GeometricConstraints interface

GeometricConstraints3D interface

GraphicsDataSet interface

GraphicsDataSets interface

GraphicsDataSetsCollection interface

GraphicsNode interface

GrillFeatures interface

HemFeatures interface

HighlightSet interface

HighlightSets interface

HoleFeatures interface

HoleTableColumns interface

HoleTableRow interface

HoleTableRows interface

HoleTables interface

HoleTableStylesEnumerator interface

HoleThreadNotes interface

IAnimationFavorites interface

IAnimations interface

iAssemblyTableColumn interface

iAssemblyTableColumns interface

iAssemblyTableRow interface

iAssemblyTableRows interface

iFeatureInputs interface

iFeatures interface

iFeatureTableColumn interface

iFeatureTableColumns interface

iFeatureTableRow interface

iFeatureTableRows interface

iFeatureTemplateDescriptors interface

iMateDefinitions interface

iMateDefinitionsEnumerator interface

iMateResults interface

iMateResultsEnumerator interface

InterferenceResults interface

InventorVBAArguments interface

InventorVBAComponents interface

InventorVBAMembers interface

InventorVBAProjects interface

iPartTableColumn interface

iPartTableColumns interface

iPartTableRow interface

iPartTableRows interface

IStudioCameras interface

IStudioLightingStyles interface

IStudioSceneStyles interface

KnitFeatures interface

LayersEnumerator interface

LeaderNodesEnumerator interface

LeaderNotes interface

LeaderStylesEnumerator interface

LevelOfDetailRepresentations interface

LightingStyles interface

Lights interface

LipFeatures interface

LoftedFlangeFeatures interface

LoftFeatures interface

LoftRails interface

LoftSectionDimensions interface

LumpDefinitions interface

MapPointCurves interface

Materials interface

MaterialsEnumerator interface

MiniToolbarComboBoxObject interface

MiniToolbarControls interface

MiniToolbarDropdownObject interface

MirrorFeatures interface

ModelParameters interface

MoveFaceFeatures interface

MoveFeatures interface

NameValueMap interface

NonParametricBaseFeatures interface

ObjectDefaultsStylesEnumerator interface

ObjectsEnumerator interface

ObjectsEnumeratorByVariant interface

OccurrencePatternElements interface

OccurrencePatterns interface

OrdinateDimensions interface

OrdinateDimensionsEnumerator interface

OrdinateDimensionSets interface

Parameters interface

ParametersEnumerator interface

ParameterTables interface

PartComponentDefinitions interface

PartFeatures interface

PartFeaturesEnumerator interface

PartsListColumns interface

PartsListRow interface

PartsListRows interface

PartsLists interface

PartsListStylesEnumerator interface

Path interface

PlanarSketches interface

PointInferenceEnumerator interface

PositionalRepresentations interface

PresentationExplodedViews interface

Profile interface

Profile3D interface

ProfilePath interface

ProfilePath3D interface

Profiles interface

Profiles3D interface

ProjectedCuts interface

ProjectPaths interface

PropertySet interface

PropertySets interface

PunchNotes interface

PunchToolFeatures interface

RectangularPatternFeatures interface

ReferencedOLEFileDescriptors interface

ReferenceFeatures interface

ReferenceFeaturesEnumerator interface

ReferenceParameters interface

RefoldFeatures interface

RenderStyles interface

ReplaceFaceFeatures interface

RestFeatures interface

RevisionTableColumns interface

RevisionTableRow interface

RevisionTableRows interface

RevisionTables interface

RevisionTableStylesEnumerator interface

RevolveFeatures interface

RibbonPanels interface

Ribbons interface

RibbonTabs interface

RibFeatures interface

RipFeatures interface

Row interface

Rows interface

RuleFilletFeatures interface

SculptFeatures interface

SelectSet interface

SheetFormats interface

SheetMetalStyles interface

Sheets interface

ShellFeatures interface

SilhouetteCurves interface

SketchArcs interface

SketchArcs3D interface

SketchBlockDefinitions interface

SketchBlockDefinitionsEnumerator interface

SketchBlocks interface

SketchBlocksEnumerator interface

SketchCircles interface

SketchCircles3D interface

SketchConstraints3DEnumerator interface

SketchConstraintsEnumerator interface

SketchedSymbolDefinitions interface

SketchedSymbols interface

SketchEllipses interface

SketchEllipses3D interface

SketchEllipticalArcs interface

SketchEllipticalArcs3D interface

SketchEntities3DEnumerator interface

SketchEntitiesEnumerator interface

Sketches3D interface

Sketches3DEnumerator interface

SketchesEnumerator interface

SketchFillRegions interface

SketchFixedSplines interface

SketchFixedSplines3D interface

SketchImages interface

SketchLines interface

SketchLines3D interface

SketchOffsetSplines interface

SketchPoints interface

SketchPoints3D interface

SketchSplines interface

SketchSplines3D interface

SnapFitFeatures interface

SplitFeatures interface

Styles interface

SurfaceBodies interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFaceList interface

SurfaceTextureStylesEnumerator interface

SurfaceTextureSymbols interface

SweepFeatures interface

TableParameters interface

TableStylesEnumerator interface

TextBoxes interface

TextStyles interface

TextStylesEnumerator interface

TextureCoordinateSet interface

TextureMaps interface

ThickenFeatures interface

ThreadFeatures interface

TitleBlockDefinitions interface

Trail interface

TrailsEnumerator interface

TransactionsEnumerator interface

TrimFeatures interface

UnfoldFeatures interface

UnfoldMethods interface

UserCoordinateSystems interface

UserParameters interface

VertexDefinitions interface

Vertices interface

ViewList interface

ViewsEnumerator interface

WeldBeads interface

Welds interface

Wires interface

WorkAxes interface

WorkPlanes interface

WorkPoints interface

WorkSurfaces interface

CreateArc2d

TransientGeometry interface

CreateArc2dByThreePoints

TransientGeometry interface

CreateArc3d

TransientGeometry interface

CreateArc3dByThreePoints

TransientGeometry interface

CreateBendDefinition

BendFeatures interface

CreateBoundaryPatchDefinition

BoundaryPatchFeatures interface

CreateBox

TransientGeometry interface

CreateBox2d

TransientGeometry interface

CreateBrowserNodeDefinition

BrowserPanes interface

CreateBSplineCurve

TransientGeometry interface

CreateBSplineCurve2d

TransientGeometry interface

CreateBSplineCurve2dDefinition

TransientGeometry interface

CreateBSplineCurveDefinition

TransientGeometry interface

CreateBSplineSurface

TransientGeometry interface

CreateCableTrayConnectorDefinition

BIMConnectors interface

CreateCamera

TransientObjects interface

CreateChangeProcessor

ChangeDefinitionObject interface

CreateCircle

TransientGeometry interface

CreateCircle2d

TransientGeometry interface

CreateCircle2dByThreePoints

TransientGeometry interface

CreateCircleByThreePoints

TransientGeometry interface

CreateColor

TransientObjects interface

CreateColorMapper

GraphicsDataSets interface

CreateColorSet

GraphicsDataSets interface

CreateConcentricPlacementDefinition

HoleFeatures interface

CreateConduitConnectorDefinition

BIMConnectors interface

CreateCone

TransientGeometry interface

CreateContourFlangeDefinition

ContourFlangeFeatures interface

CreateCoordinateSet

GraphicsDataSets interface

CreateCoordinateSystemDef

DerivedPartComponents interface

CreateCornerChamferDefinition

CornerChamferFeatures interface

CreateCornerDefinition

CornerFeatures interface

CreateCornerRoundDefinition

CornerRoundFeatures interface

CreateCustomMember

iPartFactory interface

CreateCutDefinition

CutFeatures interface

CreateCylinder

TransientGeometry interface

CreateDataMedium

TransientObjects interface

CreatedByFeature

Face interface

SurfaceBody interface

CreateDefinition

ClientFeatures interface

CoreCavityFeatures interface

DerivedAssemblyComponents interface

DerivedPartComponents interface

MoveFaceFeatures interface

NonParametricBaseFeatures interface

RibFeatures interface

UserCoordinateSystems interface

CreateDimensionsOnValueInput

HeadsUpDisplayOptions interface

CreateDragContext

CommandManager interface

CreateDuctConnectorDefinition

BIMConnectors interface

CreateEdgeCollection

TransientObjects interface

CreateElectricalConnectorDefinition

BIMConnectors interface

CreateEllipseFull

TransientGeometry interface

CreateEllipseFull2d

TransientGeometry interface

CreateEllipticalArc

TransientGeometry interface

CreateEllipticalArc2d

TransientGeometry interface

CreateEllipticalCone

TransientGeometry interface

CreateEllipticalCylinder

TransientGeometry interface

CreateExpressionLimits

ContentTableColumns interface

CreateExtrudeDefinition

ExtrudeFeatures interface

CreateFaceCollection

TransientObjects interface

CreateFaceFeatureDefinition

FaceFeatures interface

CreateFactory

AssemblyComponentDefinition interface

PartComponentDefinition interface

CreateFeatureControlFrameRows

FeatureControlFrames interface

CreateFileDialog

Application interface

CreateFileMetadata

TransientObjects interface

CreateFilletDefinition

FilletFeatures interface

CreateFittedBSplineCurve

TransientGeometry interface

CreateFittedBSplineCurve2d

TransientGeometry interface

CreateFlangeDefinition

FlangeFeatures interface

CreateFoldDefinition

FoldFeatures interface

CreateGeometryIntent

Sheet interface

CreateGeometryProxy

ComponentOccurrence interface

CreateHemDefinition

HemFeatures interface

CreateHighlightSet

ApprenticeServerDocument interface

Document interface

CreateiFeatureDefinition

iFeatures interface

PunchToolFeatures interface

CreateImage

Camera interface

CreateImageSet

GraphicsDataSets interface

CreateIndexSet

GraphicsDataSets interface

CreateInteractionEvents

CommandManager interface

CreateIntersectionWithPlane

TransientBRep interface

CreateKeyContext

ReferenceKeyManager interface

CreateLine

TransientGeometry interface

CreateLine2d

TransientGeometry interface

CreateLinearPlacementDefinition

HoleFeatures interface

CreateLineSegment

TransientGeometry interface

CreateLineSegment2d

TransientGeometry interface

CreateLoftDefinition

LoftFeatures interface

CreateLoftedFlangeDefinition

LoftedFlangeFeatures interface

CreateMapCurves

LoftFeatures interface

CreateMatrix

TransientGeometry interface

CreateMatrix2d

TransientGeometry interface

CreateMember

ContentFamily interface

iAssemblyFactory interface

iPartFactory interface

CreateMiniToolbar

CommandManager interface

InteractionEventsObject interface

CreateNameValueMap

TransientObjects interface

CreateNormalSet

GraphicsDataSets interface

CreateObjectCollection

TransientObjects interface

CreateObjectCollectionByVariant

TransientObjects interface

CreateOriginIndicator

DrawingView interface

CreatePath

Features interface

FlatPatternFeatures interface

PartFeatures interface

SweepFeatures interface

CreatePipeConnectorDefinition

BIMConnectors interface

CreatePlane

TransientGeometry interface

CreatePlaneByThreePoints

TransientGeometry interface

CreatePoint

TransientGeometry interface

CreatePoint2d

TransientGeometry interface

CreatePointPlacementDefinition

HoleFeatures interface

CreatePolyline2d

TransientGeometry interface

CreatePolyline2dFromCurve

TransientGeometry interface

CreatePolyline3d

TransientGeometry interface

CreatePolyline3dFromCurve

TransientGeometry interface

CreateProgressBar

Application interface

CreateRadialSubMenu

RadialMarkingMenu interface

CreateRipDefinition

RipFeatures interface

CreateRunoff

RunoffSurfaceDefinition interface

CreateSculptSurface

SculptFeatures interface

CreateShellDefinition

ShellFeatures interface

CreateSignatureString

TransientObjects interface

CreateSilhouetteCurve

TransientBRep interface

CreateSingleRunoffPiece

RunoffSurfaceDefinition interface

CreateSketchPlacementDefinition

HoleFeatures interface

CreateSolidBlock

TransientBRep interface

CreateSolidCylinderCone

TransientBRep interface

CreateSolidSphere

TransientBRep interface

CreateSolidTorus

TransientBRep interface

CreateSpecifiedPath

Features interface

PartFeatures interface

CreateSphere

TransientGeometry interface

CreateStandardThreadInfo

ThreadFeatures interface

CreateSurfaceBodyDefinition

TransientBRep interface

CreateTableFormat

CustomTables interface

CreateTaperedTapInfo

HoleFeatures interface

CreateTaperedThreadInfo

ThreadFeatures interface

CreateTapInfo

HoleFeatures interface

CreateTextureCoordinateSet

GraphicsDataSets interface

CreateThreadInfo

ThreadTableQuery interface

CreateTorus

TransientGeometry interface

CreateTransformDef

DerivedPartComponents interface

CreateTransientSurfaceBody

SurfaceBodyDefinition interface

CreateTranslationContext

TransientObjects interface

CreateUniformScaleDef

DerivedPartComponents interface

CreateUnitVector

TransientGeometry interface

CreateUnitVector2d

TransientGeometry interface

CreateVector

TransientGeometry interface

CreateVector2d

TransientGeometry interface

CreateVerticalSurfaces

ThickenFeature interface

CreationTime

DesignProject interface

CrossHatchClipping

DrawingSettings interface

CrossProduct

UnitVector interface

Vector interface

CSinkAngle

HoleFeature interface

CSinkDiameter

HoleFeature interface

CurrentCommandBar

PanelBarObject interface

CurrentIndex

EnumType interface

CurrentTransaction

TransactionManager interface

CurvatureDisplay

SketchArc interface

SketchArc3D interface

SketchCircle interface

SketchCircle3D interface

SketchEllipse interface

SketchEllipse3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

SketchOffsetSpline interface

SketchSpline interface

SketchSpline3D interface

Curve

CurveGraphics interface

PathEntity interface

ProfileEntity interface

ProfileEntity3D interface

Curve2dEvaluator interface

Continuity

GetCurvature

GetEndPoints

GetFirstDerivatives

GetLengthAtParam

GetParamAnomaly

GetParamAtLength

GetParamAtPoint

GetParamExtents

GetPointAtParam

GetSecondDerivatives

GetTangent

GetThirdDerivatives

RangeBox

Curve2dEvaluator.Continuity property

Curve2dEvaluator.GetCurvature method

Curve2dEvaluator.GetEndPoints method

Curve2dEvaluator.GetFirstDerivatives method

Curve2dEvaluator.GetLengthAtParam method

Curve2dEvaluator.GetParamAnomaly method

Curve2dEvaluator.GetParamAtLength method

Curve2dEvaluator.GetParamAtPoint method

Curve2dEvaluator.GetParamExtents method

Curve2dEvaluator.GetPointAtParam method

Curve2dEvaluator.GetSecondDerivatives method

Curve2dEvaluator.GetTangent method

Curve2dEvaluator.GetThirdDerivatives method

Curve2dEvaluator.RangeBox property

CurveAndEntityWorkPointDef interface

Application

CurveEntity

Entity

GetData

Parent

Type

CurveAndEntityWorkPointDef.Application property

CurveAndEntityWorkPointDef.CurveEntity property

CurveAndEntityWorkPointDef.Entity property

CurveAndEntityWorkPointDef.GetData method

CurveAndEntityWorkPointDef.Parent property

CurveAndEntityWorkPointDef.Type property

CurveCurveIntersection

TransientGeometry interface

CurveEntity

CurveAndEntityWorkPointDef interface

NormalToCurveWorkPlaneDef interface

CurveEvaluator interface

Continuity

GetCurvature

GetEndPoints

GetFirstDerivatives

GetLengthAtParam

GetParamAnomaly

GetParamAtLength

GetParamAtPoint

GetParamExtents

GetPointAtParam

GetSecondDerivatives

GetTangent

GetThirdDerivatives

RangeBox

CurveEvaluator.Continuity property

CurveEvaluator.GetCurvature method

CurveEvaluator.GetEndPoints method

CurveEvaluator.GetFirstDerivatives method

CurveEvaluator.GetLengthAtParam method

CurveEvaluator.GetParamAnomaly method

CurveEvaluator.GetParamAtLength method

CurveEvaluator.GetParamAtPoint method

CurveEvaluator.GetParamExtents method

CurveEvaluator.GetPointAtParam method

CurveEvaluator.GetSecondDerivatives method

CurveEvaluator.GetTangent method

CurveEvaluator.GetThirdDerivatives method

CurveEvaluator.RangeBox property

CurveGeometryForm_Not_NURBS enumeration member

CurveGeometryForm_NURBS enumeration member

CurveGraphics interface

BurnThrough

Color

Curve

CurveType

DepthPriority

GetCustomLineType

GetTransformBehavior

LineDefinitionSpace

LineScale

LineType

LineWeight

SetCustomLineType

SetTransformBehavior

CurveGraphics.BurnThrough property

CurveGraphics.Color property

CurveGraphics.Curve property

CurveGraphics.CurveType property

CurveGraphics.DepthPriority property

CurveGraphics.GetCustomLineType method

CurveGraphics.GetTransformBehavior method

CurveGraphics.LineDefinitionSpace property

CurveGraphics.LineScale property

CurveGraphics.LineType property

CurveGraphics.LineWeight property

CurveGraphics.SetCustomLineType method

CurveGraphics.SetTransformBehavior method

CurveSurfaceIntersection

TransientGeometry interface

CurveType

CurveGraphics interface

DrawingCurve interface

EdgeUse interface

PathEntity interface

ProfileEntity interface

ProfileEntity3D interface

Custom

DrawingBOMRow interface

PartsListRow interface

RevisionTableRow interface

CustomCell

iFeatureTableCell interface

iPartTableCell interface

CustomColumn

iFeatureTableColumn interface

iPartTableColumn interface

CustomConstraint interface

ClientId

CustomConstraint.ClientId property

CustomConstraint3D interface

ClientId

Entity

CustomConstraint3D.ClientId property

CustomConstraint3D.Entity property

CustomConstraint3DProxy interface

ContainingOccurrence

NativeObject

CustomConstraint3DProxy.ContainingOccurrence property

CustomConstraint3DProxy.NativeObject property

CustomConstraintProxy interface

ContainingOccurrence

NativeObject

CustomConstraintProxy.ContainingOccurrence property

CustomConstraintProxy.NativeObject property

CustomFactory

iPartFactory interface

CustomFamilyAsStandard

ContentCenterOptions interface

CustomIncrement

iFeatureTableCell interface

iFeatureTableColumn interface

iPartTableCell interface

iPartTableColumn interface

CustomMember

iPartMember interface

CustomParameterGroup interface

Add

Application

ClientId

Count

Delete

DisabledActionTypes

DisplayName

InternalName

Item

Remove

Type

CustomParameterGroup.Add method

CustomParameterGroup.Application property

CustomParameterGroup.ClientId property

CustomParameterGroup.Count property

CustomParameterGroup.Delete method

CustomParameterGroup.DisabledActionTypes property

CustomParameterGroup.DisplayName property

CustomParameterGroup.InternalName property

CustomParameterGroup.Item method

CustomParameterGroup.Remove method

CustomParameterGroup.Type property

CustomParameterGroups

Parameters interface

CustomParameterGroups interface

Add

Application

Count

Item

Type

CustomParameterGroups.Add method

CustomParameterGroups.Application property

CustomParameterGroups.Count property

CustomParameterGroups.Item method

CustomParameterGroups.Type property

CustomPropertyFormat

Parameter interface

CustomPropertyFormat interface

Application

Parent

Precision

PropertyType

ShowLeadingZeros

ShowTrailingZeros

ShowUnitsString

Type

Units

CustomPropertyFormat.Application property

CustomPropertyFormat.Parent property

CustomPropertyFormat.Precision property

CustomPropertyFormat.PropertyType property

CustomPropertyFormat.ShowLeadingZeros property

CustomPropertyFormat.ShowTrailingZeros property

CustomPropertyFormat.ShowUnitsString property

CustomPropertyFormat.Type property

CustomPropertyFormat.Units property

CustomPropertyName

DrawingBOMColumn interface

HoleTableColumn interface

PartsListColumn interface

RevisionTableColumn interface

CustomPropertySourceFile

DrawingSettings interface

CustomRangeMaximum

iFeatureTableCell interface

iFeatureTableColumn interface

iPartTableCell interface

iPartTableColumn interface

CustomRangeMinimum

iFeatureTableCell interface

iFeatureTableColumn interface

iPartTableCell interface

iPartTableColumn interface

CustomTable interface

AddLink

Application

AttributeSets

BendDirectionReversed

ColumnHeaderTextStyle

Columns

CopyTo

DataTextStyle

Delete

Export

GetReferenceKey

HeadingPlacement

Layer

MaximumRows

NumberOfSections

OverrideFormat

Parent

Position

RangeBox

ReferencedDocumentDescriptor

Renumber

Rotation

RowGap

RowLineSpacing

Rows

ShowTitle

Sort

Style

TableDirection

TableSource

Title

TitleTextStyle

Type

Update

WrapAutomatically

WrapLeft

CustomTable.AddLink method

CustomTable.Application property

CustomTable.AttributeSets property

CustomTable.BendDirectionReversed property

CustomTable.ColumnHeaderTextStyle property

CustomTable.Columns property

CustomTable.CopyTo method

CustomTable.DataTextStyle property

CustomTable.Delete method

CustomTable.Export method

CustomTable.GetReferenceKey method

CustomTable.HeadingPlacement property

CustomTable.Layer property

CustomTable.MaximumRows property

CustomTable.NumberOfSections property

CustomTable.OverrideFormat property

CustomTable.Parent property

CustomTable.Position property

CustomTable.RangeBox property

CustomTable.ReferencedDocumentDescriptor property

CustomTable.Renumber method

CustomTable.Rotation property

CustomTable.RowGap property

CustomTable.RowLineSpacing property

CustomTable.Rows property

CustomTable.ShowTitle property

CustomTable.Sort method

CustomTable.Style property

CustomTable.TableDirection property

CustomTable.TableSource property

CustomTable.Title property

CustomTable.TitleTextStyle property

CustomTable.Type property

CustomTable.Update method

CustomTable.WrapAutomatically property

CustomTable.WrapLeft property

CustomTables

Sheet interface

CustomTables interface

Add

AddBendTable

AddConfigurationTable

AddCSVTable

AddExcelTable

Application

Count

CreateTableFormat

Item

Type

CustomTables.Add method

CustomTables.AddBendTable method

CustomTables.AddConfigurationTable method

CustomTables.AddCSVTable method

CustomTables.AddExcelTable method

CustomTables.Application property

CustomTables.Count property

CustomTables.CreateTableFormat method

CustomTables.Item method

CustomTables.Type property

CustomThreadDesignation

ThreadInfo interface

CutAcrossBends

CutDefinition interface

CutAcrossBendsExtent interface

Distance

CutAcrossBendsExtent.Distance property

CutDefinition interface

Application

CutAcrossBends

Extent

ExtentType

Parent

Profile

SetCutAcrossBendsExtent

SetDistanceExtent

SetFromToExtent

SetThroughAllExtent

SetToExtent

SetToNextExtent

Type

CutDefinition.Application property

CutDefinition.CutAcrossBends property

CutDefinition.Extent property

CutDefinition.ExtentType property

CutDefinition.Parent property

CutDefinition.Profile property

CutDefinition.SetCutAcrossBendsExtent method

CutDefinition.SetDistanceExtent method

CutDefinition.SetFromToExtent method

CutDefinition.SetThroughAllExtent method

CutDefinition.SetToExtent method

CutDefinition.SetToNextExtent method

CutDefinition.Type property

CutFeature interface

Definition

CutFeature.Definition property

CutFeatureProxy interface

CutFeatures

FlatPatternFeatures interface

SheetMetalFeatures interface

CutFeatures interface

Add

Application

Count

CreateCutDefinition

Item

Type

CutFeatures.Add method

CutFeatures.Application property

CutFeatures.Count property

CutFeatures.CreateCutDefinition method

CutFeatures.Item method

CutFeatures.Type property

CutPreviewColor

ColorScheme interface

Cylinder interface

AxisVector

BasePoint

Evaluator

GetCylinderData

PutCylinderData

Radius

Cylinder.AxisVector property

Cylinder.BasePoint property

Cylinder.Evaluator property

Cylinder.GetCylinderData method

Cylinder.PutCylinderData method

Cylinder.Radius property

D

DatabaseRevisionId

ApprenticeServerDocument interface

Document interface

DataIO

AttributeSet interface

AttributeSets interface

ComponentDefinition interface

DrawingView interface

Sheet interface

Sketch interface

SurfaceBody interface

DataIO interface

GetInputFormats

GetOutputFormats

ReadDataFromFile

ReadDataFromStream

WriteDataToFile

WriteDataToStream

DataIO.GetInputFormats method

DataIO.GetOutputFormats method

DataIO.ReadDataFromFile method

DataIO.ReadDataFromStream method

DataIO.WriteDataToFile method

DataIO.WriteDataToStream method

DataMedium interface

FileName

IDataObject

MediumType

Stream

String

DataMedium.FileName property

DataMedium.IDataObject property

DataMedium.MediumType property

DataMedium.Stream property

DataMedium.String property

DataTextStyle

CustomTable interface

HoleTable interface

HoleTableStyle interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

DataType

ContentTableColumn interface

DataVersion

ApplicationAddIn interface

DocumentInterest interface

DatumIdentifier

FeatureControlFrame interface

DatumOne

FeatureControlFrameRow interface

DatumThree

FeatureControlFrameRow interface

DatumTwo

FeatureControlFrameRow interface

Deactivate

ApplicationAddIn interface

ApplicationAddInServer interface

DecalFeature interface

ChainFaces

Face

Image

WrapFace

DecalFeature.ChainFaces property

DecalFeature.Face property

DecalFeature.Image property

DecalFeature.WrapFace property

DecalFeatureProxy interface

ContainingOccurrence

NativeObject

DecalFeatureProxy.ContainingOccurrence property

DecalFeatureProxy.NativeObject property

DecalFeatures

PartFeatures interface

DecalFeatures interface

Add

Application

Count

Item

Type

DecalFeatures.Add method

DecalFeatures.Application property

DecalFeatures.Count property

DecalFeatures.Item method

DecalFeatures.Type property

DecimalMarkerType

DimensionStyle interface

DrawingStandardStyle interface

FeatureControlFrameStyle interface

Default

BrowserPaneObject interface

DefaultBorder interface

BottomMargin

Centermarks

DelimitZonesByLines

HorizontalZoneCount

HorizontalZoneLabelMode

LabelFromBottomRight

LeftMargin

RightMargin

TopMargin

VerticalZoneCount

VerticalZoneLabelMode

DefaultBorder.BottomMargin property

DefaultBorder.Centermarks property

DefaultBorder.DelimitZonesByLines property

DefaultBorder.HorizontalZoneCount property

DefaultBorder.HorizontalZoneLabelMode property

DefaultBorder.LabelFromBottomRight property

DefaultBorder.LeftMargin property

DefaultBorder.RightMargin property

DefaultBorder.TopMargin property

DefaultBorder.VerticalZoneCount property

DefaultBorder.VerticalZoneLabelMode property

DefaultCommand

Document interface

DefaultCommandBar

PanelBarObject interface

DefaultDesignView

FileOpenOptions interface

PartOptions interface

DefaultDesignViewIsAssociative

FileOpenOptions interface

PartOptions interface

DefaultDrawingFileType

DrawingOptions interface

DefaultExpression

iFeatureParameterInput interface

DefaultLayerStyle

DrawingOptions interface

DefaultLevelOfDetail

FileOpenOptions interface

DefaultMaterial

AssemblyComponentDefinition interface

DefaultMenuBar

Environment interface

DefaultNonInventorDWGFileOpenBehavior

DrawingOptions interface

DefaultObjectStyle

DrawingOptions interface

DefaultOffset

BalloonStyle interface

DefaultOrbitType

DisplayOptions interface

DefaultPlane

UserCoordinateSystemSettings interface

DefaultRadius

CentermarkStyle interface

DefaultRibbonTab

Environment interface

DefaultRow

iAssemblyFactory interface

iFeatureTable interface

iPartFactory interface

DefaultShortcut

ControlDefinition interface

DefaultShortcutType

ControlDefinition interface

DefaultToolBar

Environment interface

DefaultValue

ExpressionLimits interface

DefaultVBAProjectFileFullFilename

FileOptions interface

DefaultWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

DefaultWidthExtentType

ContourFlangeDefinition interface

FlangeDefinition interface

DeferUpdate

AssemblyOptions interface

GeneralPreferences interface

DeferUpdates

DrawingSettings interface

Sketch interface

Sketch3D interface

Definition

AutoCADBlock interface

BendFeature interface

BIMConnector interface

Border interface

BoundaryPatchFeature interface

ChamferFeature interface

ClientFeature interface

ComponentOccurrence interface

ContourFlangeFeature interface

CoreCavityFeature interface

CornerChamferFeature interface

CornerFeature interface

CornerRoundFeature interface

CutFeature interface

DerivedAssemblyComponent interface

DerivedPartComponent interface

ExtrudeFeature interface

FaceFeature interface

FlangeFeature interface

FoldFeature interface

HemFeature interface

LoftedFlangeFeature interface

LoftFeature interface

MoveFaceFeature interface

RibFeature interface

RipFeature interface

ShellFeature interface

SketchBlock interface

SketchedSymbol interface

SweepFeature interface

TitleBlock interface

UserCoordinateSystem interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

DefinitionDocumentType

ComponentOccurrence interface

DefinitionType

BIMConnector interface

ChamferFeature interface

ControlDefinition interface

SweepFeature interface

UserCoordinateSystemDefinition interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

DegreesOfFreedom

TriadEventsObject interface

DelayReplaceAll

iFeatureTemplateDescriptor interface

Deletable

GeometricConstraint interface

GeometricConstraint3D interface

Delete

AssemblyConstraint interface

Attribute interface

AttributeSet interface

AutoCADBlock interface

AutoCADBlockDefinition interface

Balloon interface

BalloonTipObject interface

BalloonValueSet interface

BaselineDimensionSet interface

BIMConnector interface

BIMConnectorLink interface

Border interface

BorderDefinition interface

BossSet interface

BoundaryPatchLoop interface

BreakOperation interface

BreakOutOperation interface

BrowserFolder interface

BrowserNode interface

BrowserPaneObject interface

Centerline interface

Centermark interface

ChainDimensionSet interface

ChangeDefinitionObject interface

ChangeDefinitions interface

ClientBrowserNodeDefinitionObject interface

ClientFeatureElement interface

ClientGraphics interface

ClientNodeResource interface

Column interface

CommandBar interface

CommandBarControl interface

CommandCategory interface

CommandControl interface

ComponentOccurrence interface

ContentTableRow interface

ControlDefinition interface

CustomParameterGroup interface

CustomTable interface

DerivedParameterTable interface

DesignViewRepresentation interface

DimensionConstraint interface

DimensionConstraint3D interface

DockableWindow interface

DocumentInterest interface

DraftAnalysis interface

DrawingDimension interface

DrawingNote interface

DrawingView interface

Environment interface

FeatureControlFrame interface

FeatureControlFrameRow interface

FlatPattern interface

GeometricConstraint interface

GeometricConstraint3D interface

GraphicsColorMapper interface

GraphicsDataSet interface

GraphicsDataSets interface

GraphicsNode interface

GraphicsPrimitive interface

HighlightSet interface

HoleTable interface

HoleTableColumn interface

HoleTableRow interface

iAssemblyFactory interface

iAssemblyTableColumn interface

iAssemblyTableRow interface

iFeatureTable interface

iFeatureTableColumn interface

iFeatureTableRow interface

iMateDefinition interface

iMateResult interface

iPartFactory interface

iPartTableColumn interface

iPartTableRow interface

LayoutConstraint interface

LeaderNode interface

LevelOfDetailRepresentation interface

LightingStyle interface

LoftRail interface

LoftSectionDimension interface

MapPointCurve interface

Material interface

MiniToolbarControl interface

MiniToolbarObject interface

OccurrencePattern interface

OrdinateDimensionSet interface

Parameter interface

ParameterTable interface

PartFeature interface

PartsList interface

PositionalRepresentation interface

PresentationExplodedView interface

Profile interface

Profile3D interface

ProfilePath interface

ProjectedCut interface

ProjectPath interface

Property interface

PropertySet interface

ReferenceComponent interface

ReferencedOLEFileDescriptor interface

RenderStyle interface

RevisionTable interface

RevisionTableColumn interface

RevisionTableRow interface

RibbonPanel interface

RibbonTab interface

Row interface

SelectSet interface

Sheet interface

SheetFormat interface

ShellThicknessFaceSet interface

SilhouetteCurve interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchEntity interface

SketchEntity3D interface

SketchFillRegion interface

SketchImage interface

Style interface

SurfaceBody interface

SurfaceTextureSymbol interface

TextBox interface

TitleBlock interface

TitleBlockDefinition interface

UserCoordinateSystem interface

Weld interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

DeleteComponentPatternSources

AssemblyOptions interface

DeleteEquation

UnfoldMethod interface

DeleteFaceFeature interface

InputFaces

DeleteFaceFeature.InputFaces property

DeleteFaceFeatureProxy interface

ContainingOccurrence

NativeObject

DeleteFaceFeatureProxy.ContainingOccurrence property

DeleteFaceFeatureProxy.NativeObject property

DeleteFaceFeatures

PartFeatures interface

DeleteFaceFeatures interface

Add

Application

Count

Item

Type

DeleteFaceFeatures.Add method

DeleteFaceFeatures.Application property

DeleteFaceFeatures.Count property

DeleteFaceFeatures.Item method

DeleteFaceFeatures.Type property

DeleteFaces

NonParametricBaseFeature interface

TransientBRep interface

DeleteFile

FileManager interface

DeleteObjects

FlatPattern interface

PartComponentDefinition interface

DeleteOriginal

NonParametricBaseFeatureDefinition interface

DeleteTagsOnRollup

HoleTable interface

HoleTableStyle interface

DelimitZonesByLines

DefaultBorder interface

Density

Material interface

Dependents

Parameter interface

PlanarSketch interface

Sketch3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

Depth

EmbossFeature interface

FlatPunchResult interface

PunchToolFeature interface

DepthDimming

DisplayOptions interface

DisplaySettings interface

DepthPriority

ComponentGraphics interface

CurveGraphics interface

LineGraphics interface

LineStripGraphics interface

PointGraphics interface

SurfaceGraphics interface

TextGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

DepthType

BreakOutOperation interface

DerivedAliasComponent interface

ResultFeatures

DerivedAliasComponent.ResultFeatures property

DerivedAliasComponentProxy interface

ContainingOccurrence

NativeObject

DerivedAliasComponentProxy.ContainingOccurrence property

DerivedAliasComponentProxy.NativeObject property

DerivedAliasComponents

ReferenceComponents interface

DerivedAliasComponents interface

Application

Count

Item

Parent

Type

DerivedAliasComponents.Application property

DerivedAliasComponents.Count property

DerivedAliasComponents.Item method

DerivedAliasComponents.Parent property

DerivedAliasComponents.Type property

DerivedAssemblyComponent interface

Definition

ReferenceFeatures

SuppressAll

SuppressLinkToFile

DerivedAssemblyComponent.Definition property

DerivedAssemblyComponent.ReferenceFeatures property

DerivedAssemblyComponent.SuppressAll property

DerivedAssemblyComponent.SuppressLinkToFile property

DerivedAssemblyComponentProxy interface

ContainingOccurrence

NativeObject

DerivedAssemblyComponentProxy.ContainingOccurrence property

DerivedAssemblyComponentProxy.NativeObject property

DerivedAssemblyComponents

ReferenceComponents interface

DerivedAssemblyComponents interface

Add

Application

Count

CreateDefinition

Item

Parent

Type

DerivedAssemblyComponents.Add method

DerivedAssemblyComponents.Application property

DerivedAssemblyComponents.Count property

DerivedAssemblyComponents.CreateDefinition method

DerivedAssemblyComponents.Item method

DerivedAssemblyComponents.Parent property

DerivedAssemblyComponents.Type property

DerivedAssemblyDefinition interface

ActiveDesignViewRepresentation

ActiveLevelOfDetailRepresentation

ActivePositionalRepresentation

Application

DeriveStyle

GetHolePatchingOptions

GetRemoveBySizeOptions

GetRemoveByVisibilityOptions

IncludeAllSketches

IncludeAllTopLeveliMateDefinitions

IncludeAllTopLevelParameters

IncludeAllTopLevelSketches

IncludeAllTopLevelWorkFeatures

IncludeAllWorkFeatures

InclusionOption

IndependentSolidsOnFailedBoolean

MirrorPlane

Occurrences

ReducedMemoryMode

ScaleFactor

SetHolePatchingOptions

SetRemoveBySizeOptions

SetRemoveByVisibilityOptions

Type

DerivedAssemblyDefinition.ActiveDesignViewRepresentation property

DerivedAssemblyDefinition.ActiveLevelOfDetailRepresentation property

DerivedAssemblyDefinition.ActivePositionalRepresentation property

DerivedAssemblyDefinition.Application property

DerivedAssemblyDefinition.DeriveStyle property

DerivedAssemblyDefinition.GetHolePatchingOptions method

DerivedAssemblyDefinition.GetRemoveBySizeOptions method

DerivedAssemblyDefinition.GetRemoveByVisibilityOptions method

DerivedAssemblyDefinition.IncludeAllSketches method

DerivedAssemblyDefinition.IncludeAllTopLeveliMateDefinitions property

DerivedAssemblyDefinition.IncludeAllTopLevelParameters property

DerivedAssemblyDefinition.IncludeAllTopLevelSketches property

DerivedAssemblyDefinition.IncludeAllTopLevelWorkFeatures property

DerivedAssemblyDefinition.IncludeAllWorkFeatures method

DerivedAssemblyDefinition.InclusionOption property

DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean property

DerivedAssemblyDefinition.MirrorPlane property

DerivedAssemblyDefinition.Occurrences property

DerivedAssemblyDefinition.ReducedMemoryMode property

DerivedAssemblyDefinition.ScaleFactor property

DerivedAssemblyDefinition.SetHolePatchingOptions method

DerivedAssemblyDefinition.SetRemoveBySizeOptions method

DerivedAssemblyDefinition.SetRemoveByVisibilityOptions method

DerivedAssemblyDefinition.Type property

DerivedAssemblyOccurrence interface

Application

FailedBooleanOperation

InclusionOption

IsAssembly

Name

ReferencedOccurrence

SubOccurrences

Type

DerivedAssemblyOccurrence.Application property

DerivedAssemblyOccurrence.FailedBooleanOperation property

DerivedAssemblyOccurrence.InclusionOption property

DerivedAssemblyOccurrence.IsAssembly property

DerivedAssemblyOccurrence.Name property

DerivedAssemblyOccurrence.ReferencedOccurrence property

DerivedAssemblyOccurrence.SubOccurrences property

DerivedAssemblyOccurrence.Type property

DerivedAssemblyOccurrences interface

Application

Count

Item

Type

DerivedAssemblyOccurrences.Application property

DerivedAssemblyOccurrences.Count property

DerivedAssemblyOccurrences.Item method

DerivedAssemblyOccurrences.Type property

DerivedParameter interface

ReferencedEntity

DerivedParameter.ReferencedEntity property

DerivedParameters

DerivedParameterTable interface

DerivedParameters interface

Count

Item

Type

DerivedParameters.Count property

DerivedParameters.Item method

DerivedParameters.Type property

DerivedParameterTable interface

AttributeSets

Delete

DerivedParameters

GetReferenceKey

HasReferenceComponent

LinkedParameters

Parent

ReferenceComponent

ReferencedDocumentDescriptor

Type

DerivedParameterTable.AttributeSets property

DerivedParameterTable.Delete method

DerivedParameterTable.DerivedParameters property

DerivedParameterTable.GetReferenceKey method

DerivedParameterTable.HasReferenceComponent property

DerivedParameterTable.LinkedParameters property

DerivedParameterTable.Parent property

DerivedParameterTable.ReferenceComponent property

DerivedParameterTable.ReferencedDocumentDescriptor property

DerivedParameterTable.Type property

DerivedParameterTables

Parameters interface

DerivedParameterTables interface

Add

Add2

Count

Item

Type

DerivedParameterTables.Add method

DerivedParameterTables.Add2 method

DerivedParameterTables.Count property

DerivedParameterTables.Item method

DerivedParameterTables.Type property

DerivedPartComponent interface

Definition

iMateDefinitions

Parameters

SketchBlockDefinitions

SketchBlocks

Sketches

Sketches3D

SolidBodies

SuppressLinkToFile

SurfaceBodies

WorkFeatures

DerivedPartComponent.Definition property

DerivedPartComponent.iMateDefinitions property

DerivedPartComponent.Parameters property

DerivedPartComponent.SketchBlockDefinitions property

DerivedPartComponent.SketchBlocks property

DerivedPartComponent.Sketches property

DerivedPartComponent.Sketches3D property

DerivedPartComponent.SolidBodies property

DerivedPartComponent.SuppressLinkToFile property

DerivedPartComponent.SurfaceBodies property

DerivedPartComponent.WorkFeatures property

DerivedPartComponentProxy interface

ContainingOccurrence

NativeObject

DerivedPartComponentProxy.ContainingOccurrence property

DerivedPartComponentProxy.NativeObject property

DerivedPartComponents

ReferenceComponents interface

DerivedPartComponents interface

Add

Application

Count

CreateCoordinateSystemDef

CreateDefinition

CreateTransformDef

CreateUniformScaleDef

Item

Parent

Type

DerivedPartComponents.Add method

DerivedPartComponents.Application property

DerivedPartComponents.Count property

DerivedPartComponents.CreateCoordinateSystemDef method

DerivedPartComponents.CreateDefinition method

DerivedPartComponents.CreateTransformDef method

DerivedPartComponents.CreateUniformScaleDef method

DerivedPartComponents.Item method

DerivedPartComponents.Parent property

DerivedPartComponents.Type property

DerivedPartCoordinateSystemDef interface

GetCoordinateSystem

GetScale

MirrorPlane

SetCoordinateSystem

SetScale

DerivedPartCoordinateSystemDef.GetCoordinateSystem method

DerivedPartCoordinateSystemDef.GetScale method

DerivedPartCoordinateSystemDef.MirrorPlane property

DerivedPartCoordinateSystemDef.SetCoordinateSystem method

DerivedPartCoordinateSystemDef.SetScale method

DerivedPartDefinition interface

ActiveDesignViewRepresentation

Application

DeriveStyle

ExcludeAll

iMateDefinitions

IncludeAll

IncludeAlliMateDefinitions

IncludeAllParameters

IncludeAllSolids

IncludeAllSurfaces

Parameters

ReducedMemoryMode

Solids

Surfaces

Type

UseColorOverridesFromSource

DerivedPartDefinition.ActiveDesignViewRepresentation property

DerivedPartDefinition.Application property

DerivedPartDefinition.DeriveStyle property

DerivedPartDefinition.ExcludeAll method

DerivedPartDefinition.iMateDefinitions property

DerivedPartDefinition.IncludeAll method

DerivedPartDefinition.IncludeAlliMateDefinitions property

DerivedPartDefinition.IncludeAllParameters property

DerivedPartDefinition.IncludeAllSolids property

DerivedPartDefinition.IncludeAllSurfaces property

DerivedPartDefinition.Parameters property

DerivedPartDefinition.ReducedMemoryMode property

DerivedPartDefinition.Solids property

DerivedPartDefinition.Surfaces property

DerivedPartDefinition.Type property

DerivedPartDefinition.UseColorOverridesFromSource property

DerivedPartEntities interface

Application

Count

Item

Type

DerivedPartEntities.Application property

DerivedPartEntities.Count property

DerivedPartEntities.Item method

DerivedPartEntities.Type property

DerivedPartEntity interface

Application

IncludeEntity

ReferencedEntity

Type

DerivedPartEntity.Application property

DerivedPartEntity.IncludeEntity property

DerivedPartEntity.ReferencedEntity property

DerivedPartEntity.Type property

DerivedPartTransformDef interface

GetTransformation

SetTransformation

DerivedPartTransformDef.GetTransformation method

DerivedPartTransformDef.SetTransformation method

DerivedPartUniformScaleDef interface

IncludeAllSketchBlockDefinitions

IncludeAllSketches

IncludeAllSketches3D

IncludeAllWorkFeatures

MirrorPlane

ScaleFactor

SketchBlockDefinitions

SketchBlocks

Sketches

Sketches3D

WorkFeatures

DerivedPartUniformScaleDef.IncludeAllSketchBlockDefinitions property

DerivedPartUniformScaleDef.IncludeAllSketches property

DerivedPartUniformScaleDef.IncludeAllSketches3D property

DerivedPartUniformScaleDef.IncludeAllWorkFeatures property

DerivedPartUniformScaleDef.MirrorPlane property

DerivedPartUniformScaleDef.ScaleFactor property

DerivedPartUniformScaleDef.SketchBlockDefinitions property

DerivedPartUniformScaleDef.SketchBlocks property

DerivedPartUniformScaleDef.Sketches property

DerivedPartUniformScaleDef.Sketches3D property

DerivedPartUniformScaleDef.WorkFeatures property

DeriveStyle

DerivedAssemblyDefinition interface

DerivedPartDefinition interface

Description

ApplicationAddIn interface

BIMDuctConnectorDefinition interface

BIMElectricalConnectorDefinition interface

BIMPipeConnectorDefinition interface

ContentFamily interface

ProgressiveToolTip interface

DescriptionText

ControlDefinition interface

DesignationColumn

ContentFamily interface

DesignDataPath

DesignProject interface

FileOptions interface

DesignDataPathOverridden

DesignProject interface

DesignProject interface

_Activate

Activate

Application

ContentCenterPath

ContentCenterPathOverridden

CreationTime

DesignDataPath

DesignDataPathOverridden

FrequentlyUsedPaths

FullFileName

GetCustomSection

GetIncludedCustomSection

ImportedComponentsFolderName

ImportedTopLevelAssembliesFolderName

IncludedProject

LibraryPaths

Name

OldVersionsToKeep

Owner

Parent

ProjectType

ReleaseId

Remove

SetCustomSection

Shortcuts

StylesLibraryAccess

TemplatesPath

TemplatesPathOverridden

Type

UsingUniqueFileNames

VaultName

VaultPublishPath

VaultServer

VaultVirtualPath

WorkgroupPaths

WorkspacePath

DesignProject._Activate method

DesignProject.Activate method

DesignProject.Application property

DesignProject.ContentCenterPath property

DesignProject.ContentCenterPathOverridden property

DesignProject.CreationTime property

DesignProject.DesignDataPath property

DesignProject.DesignDataPathOverridden property

DesignProject.FrequentlyUsedPaths property

DesignProject.FullFileName property

DesignProject.GetCustomSection method

DesignProject.GetIncludedCustomSection method

DesignProject.ImportedComponentsFolderName property

DesignProject.ImportedTopLevelAssembliesFolderName property

DesignProject.IncludedProject property

DesignProject.LibraryPaths property

DesignProject.Name property

DesignProject.OldVersionsToKeep property

DesignProject.Owner property

DesignProject.Parent property

DesignProject.ProjectType property

DesignProject.ReleaseId property

DesignProject.Remove method

DesignProject.SetCustomSection method

DesignProject.Shortcuts property

DesignProject.StylesLibraryAccess property

DesignProject.TemplatesPath property

DesignProject.TemplatesPathOverridden property

DesignProject.Type property

DesignProject.UsingUniqueFileNames property

DesignProject.VaultName property

DesignProject.VaultPublishPath property

DesignProject.VaultServer property

DesignProject.VaultVirtualPath property

DesignProject.WorkgroupPaths property

DesignProject.WorkspacePath property

DesignProjectManager

ApprenticeServer interface

DesignProjectManager interface

ActiveDesignProject

AddOptionsButton

Application

DesignProjects

IsFileInActiveProject

Parent

ResolveFile

Type

DesignProjectManager.ActiveDesignProject property

DesignProjectManager.AddOptionsButton method

DesignProjectManager.Application property

DesignProjectManager.DesignProjects property

DesignProjectManager.IsFileInActiveProject method

DesignProjectManager.Parent property

DesignProjectManager.ResolveFile method

DesignProjectManager.Type property

DesignProjects

DesignProjectManager interface

DesignProjects interface

Add

AddExisting

Application

Count

Item

ItemByName

Type

DesignProjects.Add method

DesignProjects.AddExisting method

DesignProjects.Application property

DesignProjects.Count property

DesignProjects.Item method

DesignProjects.ItemByName method

DesignProjects.Type property

DesignViewInfo

AssemblyDocument interface

DesignViewRepresentation interface

DesignViewRepresentation interface

Activate

Application

AttributeSets

Copy

Delete

DesignViewInfo

DesignViewType

GetReferenceKey

HideAll

Locked

Name

Parent

RemoveColorOverrides

ShowAll

Type

DesignViewRepresentation.Activate method

DesignViewRepresentation.Application property

DesignViewRepresentation.AttributeSets property

DesignViewRepresentation.Copy method

DesignViewRepresentation.Delete method

DesignViewRepresentation.DesignViewInfo property

DesignViewRepresentation.DesignViewType property

DesignViewRepresentation.GetReferenceKey method

DesignViewRepresentation.HideAll method

DesignViewRepresentation.Locked property

DesignViewRepresentation.Name property

DesignViewRepresentation.Parent property

DesignViewRepresentation.RemoveColorOverrides method

DesignViewRepresentation.ShowAll method

DesignViewRepresentation.Type property

DesignViewRepresentations

RepresentationsManager interface

DesignViewRepresentations interface

Add

Application

Count

Item

Type

DesignViewRepresentations.Add method

DesignViewRepresentations.Application property

DesignViewRepresentations.Count property

DesignViewRepresentations.Item method

DesignViewRepresentations.Type property

DesignViewType

DesignViewRepresentation interface

DetachMember

BaselineDimensionSet interface

DetailDrawingView interface

AttachPoint

BoundaryLayer

CircularFence

DisplayConnectionLine

DisplayFullBoundary

FenceCenter

FenceCornerOne

FenceCornerTwo

FenceRadius

IsBreakLineSmooth

DetailDrawingView.AttachPoint property

DetailDrawingView.BoundaryLayer property

DetailDrawingView.CircularFence property

DetailDrawingView.DisplayConnectionLine property

DetailDrawingView.DisplayFullBoundary property

DetailDrawingView.FenceCenter property

DetailDrawingView.FenceCornerOne property

DetailDrawingView.FenceCornerTwo property

DetailDrawingView.FenceRadius property

DetailDrawingView.IsBreakLineSmooth property

Determinant

Matrix interface

Matrix2d interface

Diagnostics

HardwareOptions interface

DialogTitle

FileDialog interface

Diameter

BIMConduitConnectorDefinition interface

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

BossSet interface

DiameterDimConstraint interface

Entity

DiameterDimConstraint.Entity property

DiameterDimConstraintProxy interface

ContainingOccurrence

NativeObject

DiameterDimConstraintProxy.ContainingOccurrence property

DiameterDimConstraintProxy.NativeObject property

DiameterDimensionLayer

ObjectDefaultsStyle interface

DiameterDimensionStyle

ObjectDefaultsStyle interface

DiameterGeneralDimension interface

ExtensionLineOne

ExtensionLineTwo

Intent

LeaderFromCenter

SingleDimensionLine

DiameterGeneralDimension.ExtensionLineOne property

DiameterGeneralDimension.ExtensionLineTwo property

DiameterGeneralDimension.Intent property

DiameterGeneralDimension.LeaderFromCenter property

DiameterGeneralDimension.SingleDimensionLine property

DiameterOverride

BIMConduitConnectorDefinition interface

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

DimensionCenterPoint

DimensionConstraint interface

DimensionConstraint interface

AnchorPoints

Application

AttributeSets

Delete

DimensionCenterPoint

Driven

GetReferenceKey

Parameter

Parent

TextPoint

Type

DimensionConstraint.AnchorPoints property

DimensionConstraint.Application property

DimensionConstraint.AttributeSets property

DimensionConstraint.Delete method

DimensionConstraint.DimensionCenterPoint property

DimensionConstraint.Driven property

DimensionConstraint.GetReferenceKey method

DimensionConstraint.Parameter property

DimensionConstraint.Parent property

DimensionConstraint.TextPoint property

DimensionConstraint.Type property

DimensionConstraint3D interface

AnchorPoints

Application

AttributeSets

Delete

DimensionPlane

Driven

GetReferenceKey

Parameter

Parent

TextPoint

Type

DimensionConstraint3D.AnchorPoints property

DimensionConstraint3D.Application property

DimensionConstraint3D.AttributeSets property

DimensionConstraint3D.Delete method

DimensionConstraint3D.DimensionPlane property

DimensionConstraint3D.Driven property

DimensionConstraint3D.GetReferenceKey method

DimensionConstraint3D.Parameter property

DimensionConstraint3D.Parent property

DimensionConstraint3D.TextPoint property

DimensionConstraint3D.Type property

DimensionConstraints

Sketch interface

DimensionConstraints interface

AddDiameter

AddEllipseRadius

AddOffset

AddOffsetSpline

AddRadius

AddTangentDistance

AddThreePointAngle

AddTwoLineAngle

AddTwoPointDistance

Application

Count

Item

Type

DimensionConstraints.AddDiameter method

DimensionConstraints.AddEllipseRadius method

DimensionConstraints.AddOffset method

DimensionConstraints.AddOffsetSpline method

DimensionConstraints.AddRadius method

DimensionConstraints.AddTangentDistance method

DimensionConstraints.AddThreePointAngle method

DimensionConstraints.AddTwoLineAngle method

DimensionConstraints.AddTwoPointDistance method

DimensionConstraints.Application property

DimensionConstraints.Count property

DimensionConstraints.Item method

DimensionConstraints.Type property

DimensionConstraints3D

Sketch3D interface

DimensionConstraints3D interface

AddLineLength

AddPointAndPlaneDistance

AddRadius

AddTwoLineAngle

AddTwoPointDistance

Application

Count

GetDimensionPlane

Item

Type

DimensionConstraints3D.AddLineLength method

DimensionConstraints3D.AddPointAndPlaneDistance method

DimensionConstraints3D.AddRadius method

DimensionConstraints3D.AddTwoLineAngle method

DimensionConstraints3D.AddTwoPointDistance method

DimensionConstraints3D.Application property

DimensionConstraints3D.Count property

DimensionConstraints3D.GetDimensionPlane method

DimensionConstraints3D.Item method

DimensionConstraints3D.Type property

DimensionConstraintsRelaxation

PartOptions interface

DimensionDisplayType

Parameters interface

DimensionInputEnabled

HeadsUpDisplayOptions interface

DimensionInputInCartesianCoordinates

HeadsUpDisplayOptions interface

DimensionLine

DrawingDimension interface

DimensionPlane

DimensionConstraint3D interface

DimensionStyle

HoleTag interface

LeaderNote interface

DimensionStyle interface

AlternateDecimalMarkerType

AlternateDisplayFormat

AlternateDisplayUnitType

AlternateFractionalTextScale

AlternateIncludedZeroDisplay

AlternateLeadingZeroDisplay

AlternateLinearPrecision

AlternateLinearUnits

AlternateStyleFormat

AlternateTrailingZeroDisplay

AngularPrecision

ArrowheadHeight

ArrowheadSize

ArrowheadType

ArrowheadTypeForChainDimensions

Color

DecimalMarkerType

DisplayFormat

DisplayUnitType

Extension

FractionalTextScale

Gap

GetCustomLineType

IncludedZeroDisplay

LeaderStyle

LeadingZeroDisplay

LinearPrecision

LinearUnits

LineType

LineWeight

OrdinateDimensionOriginArrowheadType

OriginOffset

PartOffset

Prefix

PrefixAndSuffixOrder

SetCustomLineType

ShowBreakSymbol

ShowDimensionLine

Spacing

Suffix

TextStyle

Tolerance

ToleranceAlternateIncludedZeroDisplay

ToleranceAlternateLeadingZeroDisplay

ToleranceAlternateTrailingZeroDisplay

ToleranceAlternateUnitPrecision

ToleranceAngularPrecision

ToleranceFontSize

ToleranceIncludedZeroDisplay

ToleranceLeadingZeroDisplay

ToleranceLinearPrecision

ToleranceTextStyle

ToleranceTrailingZeroDisplay

TrailingZeroDisplay

DimensionStyle.AlternateDecimalMarkerType property

DimensionStyle.AlternateDisplayFormat property

DimensionStyle.AlternateDisplayUnitType property

DimensionStyle.AlternateFractionalTextScale property

DimensionStyle.AlternateIncludedZeroDisplay property

DimensionStyle.AlternateLeadingZeroDisplay property

DimensionStyle.AlternateLinearPrecision property

DimensionStyle.AlternateLinearUnits property

DimensionStyle.AlternateStyleFormat property

DimensionStyle.AlternateTrailingZeroDisplay property

DimensionStyle.AngularPrecision property

DimensionStyle.ArrowheadHeight property

DimensionStyle.ArrowheadSize property

DimensionStyle.ArrowheadType property

DimensionStyle.ArrowheadTypeForChainDimensions property

DimensionStyle.Color property

DimensionStyle.DecimalMarkerType property

DimensionStyle.DisplayFormat property

DimensionStyle.DisplayUnitType property

DimensionStyle.Extension property

DimensionStyle.FractionalTextScale property

DimensionStyle.Gap property

DimensionStyle.GetCustomLineType method

DimensionStyle.IncludedZeroDisplay property

DimensionStyle.LeaderStyle property

DimensionStyle.LeadingZeroDisplay property

DimensionStyle.LinearPrecision property

DimensionStyle.LinearUnits property

DimensionStyle.LineType property

DimensionStyle.LineWeight property

DimensionStyle.OrdinateDimensionOriginArrowheadType property

DimensionStyle.OriginOffset property

DimensionStyle.PartOffset property

DimensionStyle.Prefix property

DimensionStyle.PrefixAndSuffixOrder property

DimensionStyle.SetCustomLineType method

DimensionStyle.ShowBreakSymbol property

DimensionStyle.ShowDimensionLine property

DimensionStyle.Spacing property

DimensionStyle.Suffix property

DimensionStyle.TextStyle property

DimensionStyle.Tolerance property

DimensionStyle.ToleranceAlternateIncludedZeroDisplay property

DimensionStyle.ToleranceAlternateLeadingZeroDisplay property

DimensionStyle.ToleranceAlternateTrailingZeroDisplay property

DimensionStyle.ToleranceAlternateUnitPrecision property

DimensionStyle.ToleranceAngularPrecision property

DimensionStyle.ToleranceFontSize property

DimensionStyle.ToleranceIncludedZeroDisplay property

DimensionStyle.ToleranceLeadingZeroDisplay property

DimensionStyle.ToleranceLinearPrecision property

DimensionStyle.ToleranceTextStyle property

DimensionStyle.ToleranceTrailingZeroDisplay property

DimensionStyle.TrailingZeroDisplay property

DimensionStyles

DrawingStylesManager interface

DimensionStylesEnumerator interface

Application

Count

Item

Type

DimensionStylesEnumerator.Application property

DimensionStylesEnumerator.Count property

DimensionStylesEnumerator.Item method

DimensionStylesEnumerator.Type property

DimensionsVisible

PlanarSketch interface

Sketch3D interface

DimensionText interface

Application

Color

FormattedText

HorizontalJustification

LineSpacing

LineSpacingType

Origin

Parent

RangeBox

Text

Type

VerticalJustification

WidthScale

DimensionText.Application property

DimensionText.Color property

DimensionText.FormattedText property

DimensionText.HorizontalJustification property

DimensionText.LineSpacing property

DimensionText.LineSpacingType property

DimensionText.Origin property

DimensionText.Parent property

DimensionText.RangeBox property

DimensionText.Text property

DimensionText.Type property

DimensionText.VerticalJustification property

DimensionText.WidthScale property

DimensionTextAlignment

DrawingSettings interface

DimensionType

BaselineDimensionSet interface

ChainDimensionSet interface

FeatureDimension interface

LinearGeneralDimension interface

OrdinateDimension interface

OrdinateDimensionSet interface

Directed

AngleConstraint interface

Direction

AngleExtent interface

BIMConnectorDefinition interface

DirectionAndDistanceMoveDefinition interface

DistanceExtent interface

EmbossFeature interface

FaceFeatureDefinition interface

FromToExtent interface

Light interface

Line interface

Line2d interface

LineSegment interface

LineSegment2d interface

PointHolePlacementDefinition interface

SculptSurface interface

ShellDefinition interface

ThickenFeature interface

ThroughAllExtent interface

ToExtent interface

ToNextExtent interface

DirectionAndDistanceMoveDefinition interface

Application

Direction

DirectionReversed

Distance

Parent

Type

DirectionAndDistanceMoveDefinition.Application property

DirectionAndDistanceMoveDefinition.Direction property

DirectionAndDistanceMoveDefinition.DirectionReversed property

DirectionAndDistanceMoveDefinition.Distance property

DirectionAndDistanceMoveDefinition.Parent property

DirectionAndDistanceMoveDefinition.Type property

DirectionEntity

SilhouetteCurve interface

DirectionOneReversed

AngleConstraint interface

AngleiMateDefinition interface

LinearHolePlacementDefinition interface

DirectionReversed

DirectionAndDistanceMoveDefinition interface

FaceDraftFeature interface

OrdinateDimensionSet interface

RibDefinition interface

ThreadFeature interface

DirectionTwoReversed

AngleConstraint interface

LinearHolePlacementDefinition interface

Dirty

ApprenticeServerDocument interface

Document interface

Property interface

PropertySet interface

PropertySets interface

DisabledActionTypes

ComponentOccurrence interface

CustomParameterGroup interface

Parameter interface

Sketch interface

Sketch3D interface

SketchEntity interface

DisabledCommandList

AssemblyDocument interface

DrawingDocument interface

Environment interface

PartDocument interface

PresentationDocument interface

DisabledCommandList interface

Add

Application

Count

Item

Remove

Type

DisabledCommandList.Add method

DisabledCommandList.Application property

DisabledCommandList.Count property

DisabledCommandList.Item method

DisabledCommandList.Remove method

DisabledCommandList.Type property

DisabledCommandTypes

Document interface

Environment interface

DisabledDockingStates

DockableWindow interface

DisabledIcon

ClientNodeResource interface

Disclaimer

Disconnect

CoincidentConstraint3D interface

SketchSpline3D interface

Display

BalloonTipObject interface

DisplayAffinity

ApprenticeServer interface

DisplayAxes

SketchOptions interface

DisplayBendExtents

DrawingView interface

DisplayCoincidentConstraintsOnCreation

SketchOptions interface

DisplayComponentNamesInConstraints

AssemblyOptions interface

DisplayConnectionLine

DetailDrawingView interface

DisplayCoordinateSystemIndicator

SketchOptions interface

DisplayDefinitionInBase

DrawingView interface

DisplayedControl

CommandBarControl interface

CommandControl interface

DisplayedEdges

ComponentGraphics interface

SurfaceGraphics interface

DisplayedFaces

ComponentGraphics interface

SurfaceGraphics interface

DisplayExtendedName

PartOptions interface

DisplayForeshortenedTangentEdges

DrawingView interface

DisplayFormat

DimensionStyle interface

Parameter interface

DisplayFullBoundary

DetailDrawingView interface

DisplayGridLines

GroundPlaneSettings interface

SketchOptions interface

DisplayGripsOnSelection

PartOptions interface

DisplayHatching

DrawingView interface

DisplayHeading

ContentTableColumn interface

iAssemblyTableColumn interface

iFeatureTableColumn interface

iPartTableColumn interface

DisplayHelpContext

HelpManager interface

DisplayHelpTopic

HelpManager interface

DisplayInModel

ThreadFeature interface

DisplayInterferenceEdges

DrawingView interface

DisplayInteriorFaces

RenderStyle interface

DisplayLevel

BreakOperation interface

DisplayLineWeights

DrawingOptions interface

SketchSettings interface

DisplayMessages

ChangeProcessorObject interface

DisplayMinorGridLines

SketchOptions interface

DisplayMode

ClientView interface

View interface

DisplayName

ApplicationAddIn interface

ApprenticeServerDocument interface

CheckPoint interface

CommandBar interface

CommandBarControl interface

CommandCategory interface

CommandControl interface

ContentFamily interface

ContentTreeViewNode interface

ControlDefinition interface

CustomParameterGroup interface

Document interface

DocumentDescriptor interface

Environment interface

FileMetadata interface

GraphicsNode interface

MiniToolbarControl interface

Property interface

PropertySet interface

ReferencedOLEFileDescriptor interface

RibbonPanel interface

RibbonTab interface

SoftwareVersion interface

Transaction interface

VirtualComponentDefinition interface

DisplayNameOverridden

Document interface

FileMetadata interface

DisplayNoteIcons

NotebookOptions interface

DisplayNoteText

NotebookOptions interface

DisplayObjectInOriginalLocation

GripSnapOptions interface

DisplayOptions

ApprenticeServer interface

DisplayOptions interface

Application

DefaultOrbitType

DepthDimming

DisplayQuality

DisplaySilhouettes

EdgeColor

HiddenLineDimmingPercent

InactiveComponentsEdgeColor

InactiveComponentsEdgeDisplay

InactiveComponentsShaded

InactiveComponentsShadeOpacity

MinimumFrameRate

NewWindowDisplayMode

NewWindowProjectionType

NewWindowShowAmbientShadows

NewWindowShowGroundPlane

NewWindowShowGroundReflections

NewWindowShowGroundShadows

NewWindowShowObjectShadows

RayTracingQuality

ReverseZoomDirection

ShadedDisplayOptions

Show3DIndicator

ShowXYZAxisLabels

SolidLinesForHiddenEdges

Type

UseDocumentDisplaySettings

UseRayTracingForRealisticDisplay

ViewTransitionTime

WireframeDisplayOptions

ZoomToCursor

DisplayOptions.Application property

DisplayOptions.DefaultOrbitType property

DisplayOptions.DepthDimming property

DisplayOptions.DisplayQuality property

DisplayOptions.DisplaySilhouettes property

DisplayOptions.EdgeColor property

DisplayOptions.HiddenLineDimmingPercent property

DisplayOptions.InactiveComponentsEdgeColor property

DisplayOptions.InactiveComponentsEdgeDisplay property

DisplayOptions.InactiveComponentsShaded property

DisplayOptions.InactiveComponentsShadeOpacity property

DisplayOptions.MinimumFrameRate property

DisplayOptions.NewWindowDisplayMode property

DisplayOptions.NewWindowProjectionType property

DisplayOptions.NewWindowShowAmbientShadows property

DisplayOptions.NewWindowShowGroundPlane property

DisplayOptions.NewWindowShowGroundReflections property

DisplayOptions.NewWindowShowGroundShadows property

DisplayOptions.NewWindowShowObjectShadows property

DisplayOptions.RayTracingQuality property

DisplayOptions.ReverseZoomDirection property

DisplayOptions.ShadedDisplayOptions method

DisplayOptions.Show3DIndicator property

DisplayOptions.ShowXYZAxisLabels property

DisplayOptions.SolidLinesForHiddenEdges property

DisplayOptions.Type property

DisplayOptions.UseDocumentDisplaySettings property

DisplayOptions.UseRayTracingForRealisticDisplay property

DisplayOptions.ViewTransitionTime property

DisplayOptions.WireframeDisplayOptions method

DisplayOptions.ZoomToCursor property

DisplayParameterAsExpression

Parameters interface

DisplayQuality

DisplayOptions interface

DraftAnalysis interface

DisplaySettings

AssemblyDocument interface

PartDocument interface

PresentationDocument interface

DisplaySettings interface

Application

DepthDimming

DisplaySilhouettes

EdgeColor

GroundPlaneSettings

HiddenLineDimmingPercent

NewWindowDisplayMode

NewWindowProjectionType

NewWindowShowAmbientShadows

NewWindowShowGroundPlane

NewWindowShowGroundReflections

NewWindowShowGroundShadows

NewWindowShowObjectShadows

Parent

RayTracingQuality

SolidLinesForHiddenEdges

Type

UseRayTracingForRealisticDisplay

DisplaySettings.Application property

DisplaySettings.DepthDimming property

DisplaySettings.DisplaySilhouettes property

DisplaySettings.EdgeColor property

DisplaySettings.GroundPlaneSettings property

DisplaySettings.HiddenLineDimmingPercent property

DisplaySettings.NewWindowDisplayMode property

DisplaySettings.NewWindowProjectionType property

DisplaySettings.NewWindowShowAmbientShadows property

DisplaySettings.NewWindowShowGroundPlane property

DisplaySettings.NewWindowShowGroundReflections property

DisplaySettings.NewWindowShowGroundShadows property

DisplaySettings.NewWindowShowObjectShadows property

DisplaySettings.Parent property

DisplaySettings.RayTracingQuality property

DisplaySettings.SolidLinesForHiddenEdges property

DisplaySettings.Type property

DisplaySettings.UseRayTracingForRealisticDisplay property

DisplaySilhouettes

ComponentGraphics interface

DisplayOptions interface

DisplaySettings interface

SurfaceGraphics interface

DisplayState

BrowserNodeDefinition interface

DisplayStyleColumn

iPartFactory interface

DisplayTangentEdges

DrawingView interface

DisplayThreadFeatures

DrawingView interface

DisplayTrails

DrawingView interface

DisplayUnitType

DimensionStyle interface

FeatureControlFrameStyle interface

DisplayVersion

SoftwareVersion interface

Distance

CutAcrossBendsExtent interface

DirectionAndDistanceMoveDefinition interface

DistanceAndAngleChamferDef interface

DistanceChamferDef interface

DistanceExtent interface

DistanceHeightExtent interface

InsertConstraint interface

InsertiMateDefinition interface

LegacyDistanceHeightExtent interface

ThickenFeature interface

DistanceAndAngleChamferDef interface

Angle

Distance

Face

DistanceAndAngleChamferDef.Angle property

DistanceAndAngleChamferDef.Distance property

DistanceAndAngleChamferDef.Face property

DistanceChamferDef interface

CornerSetback

Distance

DistanceChamferDef.CornerSetback property

DistanceChamferDef.Distance property

DistanceExtent interface

Direction

Distance

DistanceExtent.Direction property

DistanceExtent.Distance property

DistanceHeightExtent interface

Distance

FlangeDirection

HeightDatumType

DistanceHeightExtent.Distance property

DistanceHeightExtent.FlangeDirection property

DistanceHeightExtent.HeightDatumType property

DistanceOne

LinearHolePlacementDefinition interface

TwoDistancesChamferDef interface

DistanceTo

Line interface

Line2d interface

LineSegment interface

LineSegment2d interface

Plane interface

Point interface

Point2d interface

DistanceTwo

LinearHolePlacementDefinition interface

TwoDistancesChamferDef interface

DoBoolean

TransientBRep interface

DockableWindow interface

AddChild

Application

Caption

Clear

ClientId

Control

Delete

DisabledDockingStates

DockingState

Height

HWND

InternalName

IsCustomized

Left

Move

Parent

SetMinimumSize

ShowTitleBar

Title

Top

Type

VisibilityControl

Visible

Width

DockableWindow.AddChild method

DockableWindow.Application property

DockableWindow.Caption property

DockableWindow.Clear method

DockableWindow.ClientId property

DockableWindow.Control property

DockableWindow.Delete method

DockableWindow.DisabledDockingStates property

DockableWindow.DockingState property

DockableWindow.Height property

DockableWindow.HWND property

DockableWindow.InternalName property

DockableWindow.IsCustomized property

DockableWindow.Left property

DockableWindow.Move method

DockableWindow.Parent property

DockableWindow.SetMinimumSize method

DockableWindow.ShowTitleBar property

DockableWindow.Title property

DockableWindow.Top property

DockableWindow.Type property

DockableWindow.VisibilityControl property

DockableWindow.Visible property

DockableWindow.Width property

DockableWindows

UserInterfaceManager interface

DockableWindows interface

Add

Application

Count

Events

Item

Type

DockableWindows.Add method

DockableWindows.Application property

DockableWindows.Count property

DockableWindows.Events property

DockableWindows.Item method

DockableWindows.Type property

DockableWindowsEventsObject interface

Application

Parent

Type

DockableWindowsEventsObject.Application property

DockableWindowsEventsObject.Parent property

DockableWindowsEventsObject.Type property

DockableWindowsEventsSink interface

OnHelp

OnHide

OnShow

DockableWindowsEventsSink.OnHelp method

DockableWindowsEventsSink.OnHide method

DockableWindowsEventsSink.OnShow method

Docked

RibbonPanel interface

DockingState

DockableWindow interface

Document

ApprenticeServer interface

ClientView interface

ComponentDefinition interface

FileMetadata interface

Transaction interface

View interface

Document interface

Activate

ActivatedObject

AllReferencedDocuments

AttributeManager

AttributeSets

BrowserPanes

Close

Compacted

CreateHighlightSet

DatabaseRevisionId

DefaultCommand

Dirty

DisabledCommandTypes

DisplayName

DisplayNameOverridden

DocumentEvents

DocumentInterests

DocumentSubType

DocumentType

File

FileSaveCounter

FindWhereUsed

FullDocumentName

FullFileName

GetLocationFoundIn

GetMissingAddInBehavior

GetPrivateStorage

GetPrivateStream

GraphicsDataSetsCollection

HasPrivateStorage

HasPrivateStream

InternalName

IsModifiable

NeedsMigrating

Open

Parent

PrintManager

PropertySets

PutInternalNameAndRevisionId

Rebuild

Rebuild2

RecentChanges

ReferencedDocumentDescriptors

ReferencedDocuments

ReferencedOLEFileDescriptors

ReferenceKeyManager

ReferencingDocuments

ReleaseReference

RenderStyles

RequiresUpdate

ReservedForWrite

ReservedForWriteByMe

ReservedForWriteLogin

ReservedForWriteName

ReservedForWriteTime

ReservedForWriteVersion

RevertReservedForWriteByMe

RevisionId

Save

Save2

SaveAs

SelectionPriority

SelectSet

SetMissingAddInBehavior

SetThumbnailSaveOption

SoftwareVersionCreated

SoftwareVersionSaved

SubType

Thumbnail

ThumbnailSaveOption

Type

UnitsOfMeasure

Update

Update2

VBAProject

Views

Document.Activate method

Document.ActivatedObject property

Document.AllReferencedDocuments property

Document.AttributeManager property

Document.AttributeSets property

Document.BrowserPanes property

Document.Close method

Document.Compacted property

Document.CreateHighlightSet method

Document.DatabaseRevisionId property

Document.DefaultCommand property

Document.Dirty property

Document.DisabledCommandTypes property

Document.DisplayName property

Document.DisplayNameOverridden property

Document.DocumentEvents property

Document.DocumentInterests property

Document.DocumentSubType property

Document.DocumentType property

Document.File property

Document.FileSaveCounter property

Document.FindWhereUsed method

Document.FullDocumentName property

Document.FullFileName property

Document.GetLocationFoundIn method

Document.GetMissingAddInBehavior method

Document.GetPrivateStorage method

Document.GetPrivateStream method

Document.GraphicsDataSetsCollection property

Document.HasPrivateStorage method

Document.HasPrivateStream method

Document.InternalName property

Document.IsModifiable property

Document.NeedsMigrating property

Document.Open property

Document.Parent property

Document.PrintManager property

Document.PropertySets property

Document.PutInternalNameAndRevisionId method

Document.Rebuild method

Document.Rebuild2 method

Document.RecentChanges property

Document.ReferencedDocumentDescriptors property

Document.ReferencedDocuments property

Document.ReferencedOLEFileDescriptors property

Document.ReferenceKeyManager property

Document.ReferencingDocuments property

Document.ReleaseReference method

Document.RenderStyles property

Document.RequiresUpdate property

Document.ReservedForWrite property

Document.ReservedForWriteByMe property

Document.ReservedForWriteLogin property

Document.ReservedForWriteName property

Document.ReservedForWriteTime property

Document.ReservedForWriteVersion property

Document.RevertReservedForWriteByMe method

Document.RevisionId property

Document.Save method

Document.Save2 method

Document.SaveAs method

Document.SelectionPriority property

Document.SelectSet property

Document.SetMissingAddInBehavior method

Document.SetThumbnailSaveOption method

Document.SoftwareVersionCreated property

Document.SoftwareVersionSaved property

Document.SubType property

Document.Thumbnail property

Document.ThumbnailSaveOption property

Document.Type property

Document.UnitsOfMeasure property

Document.Update method

Document.Update2 method

Document.VBAProject property

Document.Views property

DocumentDescriptor interface

Application

DisplayName

FullDocumentName

Parent

ReferencedDocument

ReferencedDocumentType

ReferencedFileDescriptor

ReferenceDisabled

ReferencedLevelOfDetail

ReferenceInternalNameDifferent

ReferenceLocationDifferent

ReferenceMissing

ReferenceSuppressed

Type

DocumentDescriptor.Application property

DocumentDescriptor.DisplayName property

DocumentDescriptor.FullDocumentName property

DocumentDescriptor.Parent property

DocumentDescriptor.ReferencedDocument property

DocumentDescriptor.ReferencedDocumentType property

DocumentDescriptor.ReferencedFileDescriptor property

DocumentDescriptor.ReferenceDisabled property

DocumentDescriptor.ReferencedLevelOfDetail property

DocumentDescriptor.ReferenceInternalNameDifferent property

DocumentDescriptor.ReferenceLocationDifferent property

DocumentDescriptor.ReferenceMissing property

DocumentDescriptor.ReferenceSuppressed property

DocumentDescriptor.Type property

DocumentDescriptorsEnumerator interface

Application

Count

Item

Type

DocumentDescriptorsEnumerator.Application property

DocumentDescriptorsEnumerator.Count property

DocumentDescriptorsEnumerator.Item method

DocumentDescriptorsEnumerator.Type property

DocumentEvents

Document interface

DocumentEvents coclass

DocumentEventsObject interface

Application

Parent

Type

DocumentEventsObject.Application property

DocumentEventsObject.Parent property

DocumentEventsObject.Type property

DocumentEventsSink interface

OnActivate

OnChange

OnChangeSelectSet

OnClose

OnDeactivate

OnDelete

OnSave

DocumentEventsSink.OnActivate method

DocumentEventsSink.OnChange method

DocumentEventsSink.OnChangeSelectSet method

DocumentEventsSink.OnClose method

DocumentEventsSink.OnDeactivate method

DocumentEventsSink.OnDelete method

DocumentEventsSink.OnSave method

DocumentInterest interface

Application

ClientData

ClientId

DataVersion

Delete

InterestType

Name

Parent

Type

DocumentInterest.Application property

DocumentInterest.ClientData property

DocumentInterest.ClientId property

DocumentInterest.DataVersion property

DocumentInterest.Delete method

DocumentInterest.InterestType property

DocumentInterest.Name property

DocumentInterest.Parent property

DocumentInterest.Type property

DocumentInterests

ApprenticeServerDocument interface

Document interface

DocumentInterests interface

Add

Application

Count

HasInterest

Item

Type

DocumentInterests.Add method

DocumentInterests.Application property

DocumentInterests.Count property

DocumentInterests.HasInterest method

DocumentInterests.Item method

DocumentInterests.Type property

DocumentName

iAssemblyTableRow interface

DocumentNameModifiable

iAssemblyTableRow interface

Documents interface

Add

CloseAll

ItemByName

Open

OpenWithOptions

VisibleDocuments

Documents.Add method

Documents.CloseAll method

Documents.ItemByName method

Documents.Open method

Documents.OpenWithOptions method

Documents.VisibleDocuments property

DocumentsEnumerator interface

Count

Item

Type

DocumentsEnumerator.Count property

DocumentsEnumerator.Item method

DocumentsEnumerator.Type property

DocumentSubType

Document interface

DocumentType

ApprenticeServerDocument interface

Document interface

DocumentTypesSupported

TranslatorAddIn interface

DoEvents

UserInterfaceManager interface

DOFFixedColor

ColorScheme interface

DOFFreeColor

ColorScheme interface

DoPreSelect

BrowserNode interface

CommandManager interface

DoSelect

BrowserNode interface

CommandManager interface

DoStopPreSelect

CommandManager interface

DotProduct

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

DoubleBendType

BendDefinition interface

DoubleHemDefinition interface

Gap

Length

Parent

DoubleHemDefinition.Gap property

DoubleHemDefinition.Length property

DoubleHemDefinition.Parent property

DoUnSelect

CommandManager interface

DraftAnalyses

AnalysisManager interface

DraftAnalyses interface

Add

Application

Count

Item

Type

DraftAnalyses.Add method

DraftAnalyses.Application property

DraftAnalyses.Count property

DraftAnalyses.Item method

DraftAnalyses.Type property

DraftAnalysis interface

Activate

Application

AttributeSets

Copy

Delete

DisplayQuality

EndAngle

Faces

GetReferenceKey

GradientDisplay

Name

Parent

PullDirection

PullDirectionReversed

StartAngle

Type

DraftAnalysis.Activate method

DraftAnalysis.Application property

DraftAnalysis.AttributeSets property

DraftAnalysis.Copy method

DraftAnalysis.Delete method

DraftAnalysis.DisplayQuality property

DraftAnalysis.EndAngle property

DraftAnalysis.Faces property

DraftAnalysis.GetReferenceKey method

DraftAnalysis.GradientDisplay property

DraftAnalysis.Name property

DraftAnalysis.Parent property

DraftAnalysis.PullDirection property

DraftAnalysis.PullDirectionReversed property

DraftAnalysis.StartAngle property

DraftAnalysis.Type property

DraftAngle

FaceDraftFeature interface

RibDefinition interface

DraftingStandard interface

BaseStandard

BuiltIn

Name

Type

DraftingStandard.BaseStandard property

DraftingStandard.BuiltIn property

DraftingStandard.Name property

DraftingStandard.Type property

DraftProfileEnds

RibDefinition interface

Drag

DragContext interface

DragContext interface

CancelDrag

Drag

EndDrag

StartDrag

TryMove

DragContext.CancelDrag method

DragContext.Drag method

DragContext.EndDrag method

DragContext.StartDrag method

DragContext.TryMove method

DrawingBOM interface

Application

DrawingBOMColumns

DrawingBOMRows

Level

Parent

ReferencedDocumentDescriptor

Type

DrawingBOM.Application property

DrawingBOM.DrawingBOMColumns property

DrawingBOM.DrawingBOMRows property

DrawingBOM.Level property

DrawingBOM.Parent property

DrawingBOM.ReferencedDocumentDescriptor property

DrawingBOM.Type property

DrawingBOMCell interface

Application

Parent

Static

Type

Value

DrawingBOMCell.Application property

DrawingBOMCell.Parent property

DrawingBOMCell.Static property

DrawingBOMCell.Type property

DrawingBOMCell.Value property

DrawingBOMColumn interface

Application

CustomPropertyName

GetFilePropertyId

Parent

PropertyType

Title

Type

DrawingBOMColumn.Application property

DrawingBOMColumn.CustomPropertyName property

DrawingBOMColumn.GetFilePropertyId method

DrawingBOMColumn.Parent property

DrawingBOMColumn.PropertyType property

DrawingBOMColumn.Title property

DrawingBOMColumn.Type property

DrawingBOMColumns

DrawingBOM interface

DrawingBOMColumns interface

Application

Count

Item

Type

DrawingBOMColumns.Application property

DrawingBOMColumns.Count property

DrawingBOMColumns.Item method

DrawingBOMColumns.Type property

DrawingBOMRow interface

Application

Ballooned

BOMRow

Count

Custom

Item

Parent

Type

Virtual

DrawingBOMRow.Application property

DrawingBOMRow.Ballooned property

DrawingBOMRow.BOMRow property

DrawingBOMRow.Count property

DrawingBOMRow.Custom property

DrawingBOMRow.Item method

DrawingBOMRow.Parent property

DrawingBOMRow.Type property

DrawingBOMRow.Virtual property

DrawingBOMRows

DrawingBOM interface

DrawingBOMRows interface

Application

Count

Item

Type

DrawingBOMRows.Application property

DrawingBOMRows.Count property

DrawingBOMRows.Item method

DrawingBOMRows.Type property

DrawingBOMs

DrawingDocument interface

DrawingBOMs interface

Application

Count

IsDrawingBOMDefined

Item

Type

DrawingBOMs.Application property

DrawingBOMs.Count property

DrawingBOMs.IsDrawingBOMDefined method

DrawingBOMs.Item method

DrawingBOMs.Type property

DrawingCurve interface

Application

CenterPoint

Color

CurveType

EdgeType

EndPoint

Evaluator2D

Evaluator3D

GetCustomLineType

LineType

LineWeight

MidPoint

ModelGeometry

Parent

ProjectedCurveType

Segments

SetCustomLineType

StartPoint

Type

DrawingCurve.Application property

DrawingCurve.CenterPoint property

DrawingCurve.Color property

DrawingCurve.CurveType property

DrawingCurve.EdgeType property

DrawingCurve.EndPoint property

DrawingCurve.Evaluator2D property

DrawingCurve.Evaluator3D property

DrawingCurve.GetCustomLineType method

DrawingCurve.LineType property

DrawingCurve.LineWeight property

DrawingCurve.MidPoint property

DrawingCurve.ModelGeometry property

DrawingCurve.Parent property

DrawingCurve.ProjectedCurveType property

DrawingCurve.Segments property

DrawingCurve.SetCustomLineType method

DrawingCurve.StartPoint property

DrawingCurve.Type property

DrawingCurves

DrawingView interface

DrawingCurveSegment interface

Application

EndPoint

HiddenLine

Layer

Parent

StartPoint

Type

Visible

DrawingCurveSegment.Application property

DrawingCurveSegment.EndPoint property

DrawingCurveSegment.HiddenLine property

DrawingCurveSegment.Layer property

DrawingCurveSegment.Parent property

DrawingCurveSegment.StartPoint property

DrawingCurveSegment.Type property

DrawingCurveSegment.Visible property

DrawingCurveSegments interface

Application

Count

Item

Type

DrawingCurveSegments.Application property

DrawingCurveSegments.Count property

DrawingCurveSegments.Item method

DrawingCurveSegments.Type property

DrawingCurvesEnumerator interface

Application

Count

Item

Type

DrawingCurvesEnumerator.Application property

DrawingCurvesEnumerator.Count property

DrawingCurvesEnumerator.Item method

DrawingCurvesEnumerator.Type property

DrawingDimension interface

Application

Attached

AttributeSets

Delete

DimensionLine

GetInspectionDimensionData

GetReferenceKey

HideValue

IsInspectionDimension

Layer

ModelValue

ModelValueOverridden

OverrideModelValue

Parent

Precision

SetInspectionDimensionData

Text

Tolerance

TolerancePrecision

Type

DrawingDimension.Application property

DrawingDimension.Attached property

DrawingDimension.AttributeSets property

DrawingDimension.Delete method

DrawingDimension.DimensionLine property

DrawingDimension.GetInspectionDimensionData method

DrawingDimension.GetReferenceKey method

DrawingDimension.HideValue property

DrawingDimension.IsInspectionDimension property

DrawingDimension.Layer property

DrawingDimension.ModelValue property

DrawingDimension.ModelValueOverridden property

DrawingDimension.OverrideModelValue property

DrawingDimension.Parent property

DrawingDimension.Precision property

DrawingDimension.SetInspectionDimensionData method

DrawingDimension.Text property

DrawingDimension.Tolerance property

DrawingDimension.TolerancePrecision property

DrawingDimension.Type property

DrawingDimensions

Sheet interface

DrawingDimensions interface

Application

Arrange

BaselineDimensionSets

ChainDimensionSets

Count

GeneralDimensions

Item

OrdinateDimensions

OrdinateDimensionSets

Type

DrawingDimensions.Application property

DrawingDimensions.Arrange method

DrawingDimensions.BaselineDimensionSets property

DrawingDimensions.ChainDimensionSets property

DrawingDimensions.Count property

DrawingDimensions.GeneralDimensions property

DrawingDimensions.Item method

DrawingDimensions.OrdinateDimensions property

DrawingDimensions.OrdinateDimensionSets property

DrawingDimensions.Type property

DrawingDocument interface

ActiveSheet

AutoCADBlockDefinitions

BorderDefinitions

ContainingDWGDocument

DisabledCommandList

DrawingBOMs

DrawingEvents

DrawingSettings

EnvironmentManager

IsInventorDWG

Parameters

ProcessViewSelection

SaveAsInventorDWG

SheetFormats

Sheets

SheetSettings

SketchedSymbolDefinitions

SketchSettings

StylesManager

TitleBlockDefinitions

DrawingDocument.ActiveSheet property

DrawingDocument.AutoCADBlockDefinitions property

DrawingDocument.BorderDefinitions property

DrawingDocument.ContainingDWGDocument property

DrawingDocument.DisabledCommandList property

DrawingDocument.DrawingBOMs property

DrawingDocument.DrawingEvents property

DrawingDocument.DrawingSettings property

DrawingDocument.EnvironmentManager property

DrawingDocument.IsInventorDWG property

DrawingDocument.Parameters property

DrawingDocument.ProcessViewSelection method

DrawingDocument.SaveAsInventorDWG method

DrawingDocument.SheetFormats property

DrawingDocument.Sheets property

DrawingDocument.SheetSettings property

DrawingDocument.SketchedSymbolDefinitions property

DrawingDocument.SketchSettings property

DrawingDocument.StylesManager property

DrawingDocument.TitleBlockDefinitions property

DrawingEvents

DrawingDocument interface

DrawingEvents coclass

DrawingEventsObject interface

Application

Parent

Type

DrawingEventsObject.Application property

DrawingEventsObject.Parent property

DrawingEventsObject.Type property

DrawingEventsSink interface

OnRetrieveDimensions

DrawingEventsSink.OnRetrieveDimensions method

DrawingNote interface

Application

AttributeSets

Color

Delete

FormattedText

GetReferenceKey

HorizontalJustification

Layer

LineSpacing

LineSpacingType

Parent

Position

RangeBox

StackedTextPosition

Text

Type

VerticalJustification

WidthScale

DrawingNote.Application property

DrawingNote.AttributeSets property

DrawingNote.Color property

DrawingNote.Delete method

DrawingNote.FormattedText property

DrawingNote.GetReferenceKey method

DrawingNote.HorizontalJustification property

DrawingNote.Layer property

DrawingNote.LineSpacing property

DrawingNote.LineSpacingType property

DrawingNote.Parent property

DrawingNote.Position property

DrawingNote.RangeBox property

DrawingNote.StackedTextPosition property

DrawingNote.Text property

DrawingNote.Type property

DrawingNote.VerticalJustification property

DrawingNote.WidthScale property

DrawingNotes

Sheet interface

DrawingNotes interface

Application

BendNotes

ChamferNotes

Count

GeneralNotes

HoleThreadNotes

Item

LeaderNotes

PunchNotes

Type

DrawingNotes.Application property

DrawingNotes.BendNotes property

DrawingNotes.ChamferNotes property

DrawingNotes.Count property

DrawingNotes.GeneralNotes property

DrawingNotes.HoleThreadNotes property

DrawingNotes.Item method

DrawingNotes.LeaderNotes property

DrawingNotes.PunchNotes property

DrawingNotes.Type property

DrawingOptions interface

Application

ArcDimensionType

CenterDimensionText

CircleDimensionType

DefaultDrawingFileType

DefaultLayerStyle

DefaultNonInventorDWGFileOpenBehavior

DefaultObjectStyle

DisplayLineWeights

EditDimensionWhenCreated

EnableBackgroundUpdates

EnableOrdinateDimGeomSelection

GetModelDimensions

InventorDWGFileVersion

LinearDimensionType

LineWeightType

MemorySavingMode

ShowUncutSectionViewPreview

StandardPartsSectionBehavior

TitleBlockAlignment

Type

UpperLimitForFirstRangeOfLineWeights

UpperLimitForSecondRangeOfLineWeights

UpperLimitForThirdRangeOfLineWeights

ViewBlockInsertionPoint

ViewJustification

ViewPreview

DrawingOptions.Application property

DrawingOptions.ArcDimensionType property

DrawingOptions.CenterDimensionText property

DrawingOptions.CircleDimensionType property

DrawingOptions.DefaultDrawingFileType property

DrawingOptions.DefaultLayerStyle property

DrawingOptions.DefaultNonInventorDWGFileOpenBehavior property

DrawingOptions.DefaultObjectStyle property

DrawingOptions.DisplayLineWeights property

DrawingOptions.EditDimensionWhenCreated property

DrawingOptions.EnableBackgroundUpdates property

DrawingOptions.EnableOrdinateDimGeomSelection property

DrawingOptions.GetModelDimensions property

DrawingOptions.InventorDWGFileVersion property

DrawingOptions.LinearDimensionType property

DrawingOptions.LineWeightType property

DrawingOptions.MemorySavingMode property

DrawingOptions.ShowUncutSectionViewPreview property

DrawingOptions.StandardPartsSectionBehavior property

DrawingOptions.TitleBlockAlignment property

DrawingOptions.Type property

DrawingOptions.UpperLimitForFirstRangeOfLineWeights property

DrawingOptions.UpperLimitForSecondRangeOfLineWeights property

DrawingOptions.UpperLimitForThirdRangeOfLineWeights property

DrawingOptions.ViewBlockInsertionPoint property

DrawingOptions.ViewJustification property

DrawingOptions.ViewPreview property

DrawingPrintManager interface

AllColorsAsBlack

GetSheetRange

PrintExcludedSheets

PrintRange

RemoveLineWeights

Rotate90Degrees

Scale

ScaleMode

SetSheetRange

TilingEnabled

DrawingPrintManager.AllColorsAsBlack property

DrawingPrintManager.GetSheetRange method

DrawingPrintManager.PrintExcludedSheets property

DrawingPrintManager.PrintRange property

DrawingPrintManager.RemoveLineWeights property

DrawingPrintManager.Rotate90Degrees property

DrawingPrintManager.Scale property

DrawingPrintManager.ScaleMode property

DrawingPrintManager.SetSheetRange method

DrawingPrintManager.TilingEnabled property

DrawingSettings

DrawingDocument interface

DrawingSettings interface

AlwaysUseBitmapsForShadedViews

Application

AutomatedCenterlineSettings

CrossHatchClipping

CustomPropertySourceFile

DeferUpdates

DimensionTextAlignment

HighlightInvalidAnnotations

InvalidFeatureBasedAnnotationsColor

MemorySavingMode

OfflineImageFidelity

Parent

PreserveOrphanedAnnotations

Type

DrawingSettings.AlwaysUseBitmapsForShadedViews property

DrawingSettings.Application property

DrawingSettings.AutomatedCenterlineSettings property

DrawingSettings.CrossHatchClipping property

DrawingSettings.CustomPropertySourceFile property

DrawingSettings.DeferUpdates property

DrawingSettings.DimensionTextAlignment property

DrawingSettings.HighlightInvalidAnnotations property

DrawingSettings.InvalidFeatureBasedAnnotationsColor property

DrawingSettings.MemorySavingMode property

DrawingSettings.OfflineImageFidelity property

DrawingSettings.Parent property

DrawingSettings.PreserveOrphanedAnnotations property

DrawingSettings.Type property

DrawingSketch interface

GetAutomatedCenterlineSettings

Profiles

SetAutomatedCenterlineSettings

SheetToSketchSpace

SketchFillRegions

SketchToSheetSpace

DrawingSketch.GetAutomatedCenterlineSettings method

DrawingSketch.Profiles property

DrawingSketch.SetAutomatedCenterlineSettings method

DrawingSketch.SheetToSketchSpace method

DrawingSketch.SketchFillRegions property

DrawingSketch.SketchToSheetSpace method

DrawingSketches interface

Add

Application

Count

Item

Type

DrawingSketches.Add method

DrawingSketches.Application property

DrawingSketches.Count property

DrawingSketches.Item method

DrawingSketches.Type property

DrawingStandardStyle interface

ActiveObjectDefaults

ApplyExcludeCharactersToBendTables

ApplyExcludeCharactersToHoleTables

ApplyExcludeCharactersToRevisionTables

ApplyExcludeCharactersToViewNames

DecimalMarkerType

ExcludeCharacters

FirstAngleProjection

FrontViewPlane

GetViewLabelDefaults

GlobalLineScale

InternationalStandardReference

LinearUnits

PartialCircularThreadEdge

PartialSectionThreadEnd

PresetLineWeights

PresetScales

PresetSectionHatchAngles

PresetTextHeights

SetViewLabelDefaults

DrawingStandardStyle.ActiveObjectDefaults property

DrawingStandardStyle.ApplyExcludeCharactersToBendTables property

DrawingStandardStyle.ApplyExcludeCharactersToHoleTables property

DrawingStandardStyle.ApplyExcludeCharactersToRevisionTables property

DrawingStandardStyle.ApplyExcludeCharactersToViewNames property

DrawingStandardStyle.DecimalMarkerType property

DrawingStandardStyle.ExcludeCharacters property

DrawingStandardStyle.FirstAngleProjection property

DrawingStandardStyle.FrontViewPlane property

DrawingStandardStyle.GetViewLabelDefaults method

DrawingStandardStyle.GlobalLineScale property

DrawingStandardStyle.InternationalStandardReference property

DrawingStandardStyle.LinearUnits property

DrawingStandardStyle.PartialCircularThreadEdge property

DrawingStandardStyle.PartialSectionThreadEnd property

DrawingStandardStyle.PresetLineWeights property

DrawingStandardStyle.PresetScales property

DrawingStandardStyle.PresetSectionHatchAngles property

DrawingStandardStyle.PresetTextHeights property

DrawingStandardStyle.SetViewLabelDefaults method

DrawingStandardStylesEnumerator interface

Application

Count

Item

Type

DrawingStandardStylesEnumerator.Application property

DrawingStandardStylesEnumerator.Count property

DrawingStandardStylesEnumerator.Item method

DrawingStandardStylesEnumerator.Type property

DrawingStylesManager interface

ActiveStandardStyle

Application

BalloonStyles

CentermarkStyles

DimensionStyles

FeatureControlFrameStyles

HoleTableStyles

Layers

LeaderStyles

ObjectDefaultsStyles

Parent

PartsListStyles

RevisionTableStyles

StandardStyles

Styles

SurfaceTextureStyles

TableStyles

TextStyles

Type

DrawingStylesManager.ActiveStandardStyle property

DrawingStylesManager.Application property

DrawingStylesManager.BalloonStyles property

DrawingStylesManager.CentermarkStyles property

DrawingStylesManager.DimensionStyles property

DrawingStylesManager.FeatureControlFrameStyles property

DrawingStylesManager.HoleTableStyles property

DrawingStylesManager.Layers property

DrawingStylesManager.LeaderStyles property

DrawingStylesManager.ObjectDefaultsStyles property

DrawingStylesManager.Parent property

DrawingStylesManager.PartsListStyles property

DrawingStylesManager.RevisionTableStyles property

DrawingStylesManager.StandardStyles property

DrawingStylesManager.Styles property

DrawingStylesManager.SurfaceTextureStyles property

DrawingStylesManager.TableStyles property

DrawingStylesManager.TextStyles property

DrawingStylesManager.Type property

DrawingView interface

ActiveDesignViewRepresentation

ActiveLevelOfDetailRepresentation

ActiveMemberName

ActivePositionalRepresentation

ActivePresentationView

Align

AlignAuxiliary

Aligned

AttributeSets

AuxiliaryOrientationEdge

BitmapAvailable

BreakOperations

BreakOutOperations

Camera

Center

ClientGraphicsCollection

CopyTo

CreateOriginIndicator

DataIO

Delete

DisplayBendExtents

DisplayDefinitionInBase

DisplayForeshortenedTangentEdges

DisplayHatching

DisplayInterferenceEdges

DisplayTangentEdges

DisplayThreadFeatures

DisplayTrails

DrawingCurves

DrawingViewEvents

DrawingViewToModelSpace

DrawingViewToModelTransform

DrawingViewToSheetSpace

DrawingViewToSheetTransform

GeneralDimensionType

GetAutomatedCenterlineSettings

GetIncludeStatus

GetReferenceKey

GetVisibility

GetWeldmentState

GraphicsDataSetsCollection

HasOriginIndicator

Height

InheritBreak

InheritBreakOut

InheritSection

InheritSlice

InsertInModelSpace

IsFlatPatternView

IsUpdateComplete

Label

Left

ModelToDrawingViewSpace

ModelToDrawingViewTransform

ModelToSheetSpace

ModelToSheetTransform

MoveTo

Name

OriginIndicator

Parent

ParentView

Position

PresentationViewAssociative

ReferencedDocumentDescriptor

ReferencedFile

RotateByAngle

Rotation

Scale

ScaleFromBase

ScaleString

SetAutomatedCenterlineSettings

SetDesignViewRepresentation

SetIncludeStatus

SetVisibility

SetWeldmentState

SheetToDrawingViewSpace

SheetToDrawingViewTransform

SheetToModelSpace

SheetToModelTransform

ShowHiddenAnnotations

ShowHiddenCurves

ShowLabel

ShowName

ShowName

ShowScale

ShowScale

Sketches

StandardPartsSectionBehavior

Suppressed

Top

Type

UpToDate

ViewJustification

ViewOrientationFromBase

ViewStyle

ViewType

Width

DrawingView.ActiveDesignViewRepresentation property

DrawingView.ActiveLevelOfDetailRepresentation property

DrawingView.ActiveMemberName property

DrawingView.ActivePositionalRepresentation property

DrawingView.ActivePresentationView property

DrawingView.Align method

DrawingView.AlignAuxiliary method

DrawingView.Aligned property

DrawingView.AttributeSets property

DrawingView.AuxiliaryOrientationEdge property

DrawingView.BitmapAvailable property

DrawingView.BreakOperations property

DrawingView.BreakOutOperations property

DrawingView.Camera property

DrawingView.Center property

DrawingView.ClientGraphicsCollection property

DrawingView.CopyTo method

DrawingView.CreateOriginIndicator method

DrawingView.DataIO property

DrawingView.Delete method

DrawingView.DisplayBendExtents property

DrawingView.DisplayDefinitionInBase property

DrawingView.DisplayForeshortenedTangentEdges property

DrawingView.DisplayHatching property

DrawingView.DisplayInterferenceEdges property

DrawingView.DisplayTangentEdges property

DrawingView.DisplayThreadFeatures property

DrawingView.DisplayTrails property

DrawingView.DrawingCurves method

DrawingView.DrawingViewEvents property

DrawingView.DrawingViewToModelSpace method

DrawingView.DrawingViewToModelTransform property

DrawingView.DrawingViewToSheetSpace method

DrawingView.DrawingViewToSheetTransform property

DrawingView.GeneralDimensionType property

DrawingView.GetAutomatedCenterlineSettings method

DrawingView.GetIncludeStatus method

DrawingView.GetReferenceKey method

DrawingView.GetVisibility method

DrawingView.GetWeldmentState method

DrawingView.GraphicsDataSetsCollection property

DrawingView.HasOriginIndicator property

DrawingView.Height property

DrawingView.InheritBreak property

DrawingView.InheritBreakOut property

DrawingView.InheritSection property

DrawingView.InheritSlice property

DrawingView.InsertInModelSpace method

DrawingView.IsFlatPatternView property

DrawingView.IsUpdateComplete property

DrawingView.Label property

DrawingView.Left property

DrawingView.ModelToDrawingViewSpace method

DrawingView.ModelToDrawingViewTransform property

DrawingView.ModelToSheetSpace method

DrawingView.ModelToSheetTransform property

DrawingView.MoveTo method

DrawingView.Name property

DrawingView.OriginIndicator property

DrawingView.Parent property

DrawingView.ParentView property

DrawingView.Position property

DrawingView.PresentationViewAssociative property

DrawingView.ReferencedDocumentDescriptor property

DrawingView.ReferencedFile method

DrawingView.RotateByAngle method

DrawingView.Rotation property

DrawingView.Scale property

DrawingView.ScaleFromBase property

DrawingView.ScaleString property

DrawingView.SetAutomatedCenterlineSettings method

DrawingView.SetDesignViewRepresentation method

DrawingView.SetIncludeStatus method

DrawingView.SetVisibility method

DrawingView.SetWeldmentState method

DrawingView.SheetToDrawingViewSpace method

DrawingView.SheetToDrawingViewTransform property

DrawingView.SheetToModelSpace method

DrawingView.SheetToModelTransform property

DrawingView.ShowHiddenAnnotations method

DrawingView.ShowHiddenCurves method

DrawingView.ShowLabel property

DrawingView.ShowName method

DrawingView.ShowScale method

DrawingView.Sketches property

DrawingView.StandardPartsSectionBehavior property

DrawingView.Suppressed property

DrawingView.Top property

DrawingView.Type property

DrawingView.UpToDate property

DrawingView.ViewJustification property

DrawingView.ViewOrientationFromBase property

DrawingView.ViewStyle property

DrawingView.ViewType property

DrawingView.Width property

DrawingViewEvents

DrawingView interface

DrawingViewEvents coclass

DrawingViewEventsObject interface

Application

Parent

Type

DrawingViewEventsObject.Application property

DrawingViewEventsObject.Parent property

DrawingViewEventsObject.Type property

DrawingViewEventsSink interface

OnViewUpdate

DrawingViewEventsSink.OnViewUpdate method

DrawingViewLabel interface

Application

Color

ConstrainToBorder

FormattedText

HorizontalJustification

Layer

LineSpacing

LineSpacingType

Parent

Position

RangeBox

StackedTextPosition

Text

TextStyle

Type

VerticalJustification

WidthScale

DrawingViewLabel.Application property

DrawingViewLabel.Color property

DrawingViewLabel.ConstrainToBorder property

DrawingViewLabel.FormattedText property

DrawingViewLabel.HorizontalJustification property

DrawingViewLabel.Layer property

DrawingViewLabel.LineSpacing property

DrawingViewLabel.LineSpacingType property

DrawingViewLabel.Parent property

DrawingViewLabel.Position property

DrawingViewLabel.RangeBox property

DrawingViewLabel.StackedTextPosition property

DrawingViewLabel.Text property

DrawingViewLabel.TextStyle property

DrawingViewLabel.Type property

DrawingViewLabel.VerticalJustification property

DrawingViewLabel.WidthScale property

DrawingViews

Sheet interface

DrawingViews interface

AddAssociativeDraftView

AddAuxiliaryView

AddBaseView

AddDetailView

AddDraftView

AddOverlayView

AddProjectedView

AddSectionView

Count

Item

Type

DrawingViews.AddAssociativeDraftView method

DrawingViews.AddAuxiliaryView method

DrawingViews.AddBaseView method

DrawingViews.AddDetailView method

DrawingViews.AddDraftView method

DrawingViews.AddOverlayView method

DrawingViews.AddProjectedView method

DrawingViews.AddSectionView method

DrawingViews.Count property

DrawingViews.Item method

DrawingViews.Type property

DrawingViewToModelSpace

DrawingView interface

DrawingViewToModelTransform

DrawingView interface

DrawingViewToSheetSpace

DrawingView interface

DrawingViewToSheetTransform

DrawingView interface

DriveAdaptivity

DriveConstraintSettingsObject interface

DriveConstraintSettings

AssemblyConstraint interface

DriveConstraintSettingsObject interface

Application

CollisionDetection

DriveAdaptivity

EndValue

FrameRate

GetIncrement

GoToEnd

GoToStart

IsInitialized

Parent

PauseDelay

PlayForward

PlayReverse

RepetitionCount

RepetitionStartEndStart

SetIncrement

StartAVIRecording

StartValue

StartWMVRecording

StepForward

StepReverse

StopRecording

Type

DriveConstraintSettingsObject.Application property

DriveConstraintSettingsObject.CollisionDetection property

DriveConstraintSettingsObject.DriveAdaptivity property

DriveConstraintSettingsObject.EndValue property

DriveConstraintSettingsObject.FrameRate property

DriveConstraintSettingsObject.GetIncrement method

DriveConstraintSettingsObject.GoToEnd method

DriveConstraintSettingsObject.GoToStart method

DriveConstraintSettingsObject.IsInitialized property

DriveConstraintSettingsObject.Parent property

DriveConstraintSettingsObject.PauseDelay property

DriveConstraintSettingsObject.PlayForward method

DriveConstraintSettingsObject.PlayReverse method

DriveConstraintSettingsObject.RepetitionCount property

DriveConstraintSettingsObject.RepetitionStartEndStart property

DriveConstraintSettingsObject.SetIncrement method

DriveConstraintSettingsObject.StartAVIRecording method

DriveConstraintSettingsObject.StartValue property

DriveConstraintSettingsObject.StartWMVRecording method

DriveConstraintSettingsObject.StepForward method

DriveConstraintSettingsObject.StepReverse method

DriveConstraintSettingsObject.StopRecording method

DriveConstraintSettingsObject.Type property

DriveConstraintSettingsSink interface

OnCollision

DriveConstraintSettingsSink.OnCollision method

Driven

DimensionConstraint interface

DimensionConstraint3D interface

DrivenBy

Parameter interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

DropDownWidth

ComboBoxDefinitionObject interface

E

EastControl

RadialMarkingMenu interface

Edge

AnalyticEdgeWorkAxisDef interface

CenteredWidthExtent interface

EdgeUse interface

EdgeWidthExtent interface

FilletIntermediateRadius interface

FilletSetback interface

FlatBendResult interface

FromToWidthExtent interface

HoleThreadNote interface

MidPointWorkPointDef interface

NonLinearEdgeWorkPointDef interface

OffsetWidthExtent interface

SurfaceGraphicsEdge interface

WidthOffsetWidthExtent interface

Edge interface

Application

AttributeSets

CalculateStrokes

EdgeUses

Evaluator

Faces

Geometry

GeometryForm

GeometryType

GetClosestPointTo

GetExistingStrokes

GetExistingStrokeTolerances

GetReferenceKey

GetSourceEdge

IsParamReversed

IsTolerant

Parent

PointOnEdge

StartVertex

StopVertex

TangentiallyConnectedEdges

Tolerance

TransientKey

Type

Wire

Edge.Application property

Edge.AttributeSets property

Edge.CalculateStrokes method

Edge.EdgeUses property

Edge.Evaluator property

Edge.Faces property

Edge.Geometry property

Edge.GeometryForm property

Edge.GeometryType property

Edge.GetClosestPointTo method

Edge.GetExistingStrokes method

Edge.GetExistingStrokeTolerances method

Edge.GetReferenceKey method

Edge.GetSourceEdge method

Edge.IsParamReversed property

Edge.IsTolerant property

Edge.Parent property

Edge.PointOnEdge property

Edge.StartVertex property

Edge.StopVertex property

Edge.TangentiallyConnectedEdges property

Edge.Tolerance property

Edge.TransientKey property

Edge.Type property

Edge.Wire property

EdgeCollection interface

CollectionType

EdgeCollection.CollectionType property

EdgeColor

DisplayOptions interface

DisplaySettings interface

EdgeDefinition

EdgeUseDefinition interface

EdgeDefinition interface

Application

AssociativeID

EndVertex

FaceOne

FaceTwo

IsParamReversed

ModelSpaceCurve

ParameterSpaceCurveOne

ParameterSpaceCurveTwo

StartVertex

Type

EdgeDefinition.Application property

EdgeDefinition.AssociativeID property

EdgeDefinition.EndVertex property

EdgeDefinition.FaceOne property

EdgeDefinition.FaceTwo property

EdgeDefinition.IsParamReversed property

EdgeDefinition.ModelSpaceCurve property

EdgeDefinition.ParameterSpaceCurveOne property

EdgeDefinition.ParameterSpaceCurveTwo property

EdgeDefinition.StartVertex property

EdgeDefinition.Type property

EdgeDefinitions

SurfaceBodyDefinition interface

EdgeDefinitions interface

Add

Application

Count

Item

Type

EdgeDefinitions.Add method

EdgeDefinitions.Application property

EdgeDefinitions.Count property

EdgeDefinitions.Item method

EdgeDefinitions.Type property

EdgeLoop

EdgeUse interface

EdgeLoop interface

Application

AttributeSets

Edges

EdgeUses

Face

GetReferenceKey

IsOuterEdgeLoop

Parent

RangeBox

TransientKey

Type

EdgeLoop.Application property

EdgeLoop.AttributeSets property

EdgeLoop.Edges property

EdgeLoop.EdgeUses property

EdgeLoop.Face property

EdgeLoop.GetReferenceKey method

EdgeLoop.IsOuterEdgeLoop property

EdgeLoop.Parent property

EdgeLoop.RangeBox property

EdgeLoop.TransientKey property

EdgeLoop.Type property

EdgeLoopDefinition interface

Application

EdgeUseDefinitions

Type

EdgeLoopDefinition.Application property

EdgeLoopDefinition.EdgeUseDefinitions property

EdgeLoopDefinition.Type property

EdgeLoopDefinitions

FaceDefinition interface

EdgeLoopDefinitions interface

Add

Application

Count

Item

Type

EdgeLoopDefinitions.Add method

EdgeLoopDefinitions.Application property

EdgeLoopDefinitions.Count property

EdgeLoopDefinitions.Item method

EdgeLoopDefinitions.Type property

EdgeLoopProxy interface

ContainingOccurrence

NativeObject

EdgeLoopProxy.ContainingOccurrence property

EdgeLoopProxy.NativeObject property

EdgeLoops

Face interface

EdgeLoops interface

Count

Item

Type

EdgeLoops.Count property

EdgeLoops.Item method

EdgeLoops.Type property

EdgeProxy interface

ContainingOccurrence

NativeObject

EdgeProxy.ContainingOccurrence property

EdgeProxy.NativeObject property

Edges

BendDefinition interface

ContourFlangeDefinition interface

CornerDefinition interface

CornerRoundEdgeSet interface

CosmeticWeld interface

EdgeLoop interface

Face interface

FaceShell interface

FilletRadiusEdgeSet interface

FlangeDefinition interface

HemDefinition interface

SurfaceBody interface

Vertex interface

Wire interface

Edges interface

Count

Item

Type

Edges.Count property

Edges.Item method

Edges.Type property

EdgeSetCount

CornerRoundDefinition interface

FilletDefinition interface

EdgeSetItem

CornerRoundDefinition interface

FilletDefinition interface

EdgeType

DrawingCurve interface

EdgeUse interface

Application

CurveType

Edge

EdgeLoop

Evaluator

Geometry

GeometryForm

GetReferenceKey

IsOpposedToEdge

IsParamReversed

Next

Parent

Partner

Previous

TransientKey

Type

Wire

EdgeUse.Application property

EdgeUse.CurveType property

EdgeUse.Edge property

EdgeUse.EdgeLoop property

EdgeUse.Evaluator property

EdgeUse.Geometry property

EdgeUse.GeometryForm property

EdgeUse.GetReferenceKey method

EdgeUse.IsOpposedToEdge property

EdgeUse.IsParamReversed property

EdgeUse.Next property

EdgeUse.Parent property

EdgeUse.Partner property

EdgeUse.Previous property

EdgeUse.TransientKey property

EdgeUse.Type property

EdgeUse.Wire property

EdgeUseDefinition interface

Application

EdgeDefinition

IsOpposedToEdge

Type

EdgeUseDefinition.Application property

EdgeUseDefinition.EdgeDefinition property

EdgeUseDefinition.IsOpposedToEdge property

EdgeUseDefinition.Type property

EdgeUseDefinitions

EdgeLoopDefinition interface

EdgeUseDefinitions interface

Add

Application

Count

Item

Type

EdgeUseDefinitions.Add method

EdgeUseDefinitions.Application property

EdgeUseDefinitions.Count property

EdgeUseDefinitions.Item method

EdgeUseDefinitions.Type property

EdgeUseProxy interface

ContainingOccurrence

NativeObject

EdgeUseProxy.ContainingOccurrence property

EdgeUseProxy.NativeObject property

EdgeUses

Edge interface

EdgeLoop interface

Wire interface

EdgeUses interface

Count

Item

Type

EdgeUses.Count property

EdgeUses.Item method

EdgeUses.Type property

EdgeWidthExtent interface

Edge

EdgeWidthExtent.Edge property

Edit

BendPartFeature interface

BorderDefinition interface

CombineFeature interface

ComponentOccurrence interface

FlatPattern interface

Machining interface

NonParametricBaseFeature interface

Preparations interface

RefoldFeature interface

SilhouetteCurve interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchedSymbolDefinition interface

SketchFixedSpline interface

SketchFixedSpline3D interface

TitleBlockDefinition interface

UnfoldFeature interface

Welds interface

EditBaseSolidsUsingFusion

PartOptions interface

EditByEdge

SketchFixedSpline3D interface

EditDimensionWhenCreated

DrawingOptions interface

SketchOptions interface

EditObjectEnvironment

EnvironmentManager interface

EffectiveDiameter

TaperedThreadInfo interface

EffectiveLength

TaperedThreadInfo interface

Element

ClientFeatureElement interface

ElementCount

CircularOccurrencePattern interface

EllipseFull interface

Center

Evaluator

GetEllipseFullData

MajorAxisVector

MinorMajorRatio

Normal

PutEllipseFullData

EllipseFull.Center property

EllipseFull.Evaluator property

EllipseFull.GetEllipseFullData method

EllipseFull.MajorAxisVector property

EllipseFull.MinorMajorRatio property

EllipseFull.Normal property

EllipseFull.PutEllipseFullData method

EllipseFull2d interface

Center

Evaluator

GetEllipseFullData

MajorAxisVector

MinorMajorRatio

PutEllipseFullData

EllipseFull2d.Center property

EllipseFull2d.Evaluator property

EllipseFull2d.GetEllipseFullData method

EllipseFull2d.MajorAxisVector property

EllipseFull2d.MinorMajorRatio property

EllipseFull2d.PutEllipseFullData method

EllipseRadiusDimConstraint interface

Entity

MajorRadius

EllipseRadiusDimConstraint.Entity property

EllipseRadiusDimConstraint.MajorRadius property

EllipseRadiusDimConstraintProxy interface

ContainingOccurrence

NativeObject

EllipseRadiusDimConstraintProxy.ContainingOccurrence property

EllipseRadiusDimConstraintProxy.NativeObject property

EllipticalArc interface

Center

EndPoint

Evaluator

GetEllipticalArcData

MajorAxis

MajorRadius

MinorAxis

MinorRadius

PutEllipticalArcData

StartAngle

StartPoint

SweepAngle

EllipticalArc.Center property

EllipticalArc.EndPoint property

EllipticalArc.Evaluator property

EllipticalArc.GetEllipticalArcData method

EllipticalArc.MajorAxis property

EllipticalArc.MajorRadius property

EllipticalArc.MinorAxis property

EllipticalArc.MinorRadius property

EllipticalArc.PutEllipticalArcData method

EllipticalArc.StartAngle property

EllipticalArc.StartPoint property

EllipticalArc.SweepAngle property

EllipticalArc2d interface

Center

EndPoint

Evaluator

GetEllipticalArcData

MajorAxis

MajorRadius

MinorRadius

PutEllipticalArcData

StartAngle

StartPoint

SweepAngle

EllipticalArc2d.Center property

EllipticalArc2d.EndPoint property

EllipticalArc2d.Evaluator property

EllipticalArc2d.GetEllipticalArcData method

EllipticalArc2d.MajorAxis property

EllipticalArc2d.MajorRadius property

EllipticalArc2d.MinorRadius property

EllipticalArc2d.PutEllipticalArcData method

EllipticalArc2d.StartAngle property

EllipticalArc2d.StartPoint property

EllipticalArc2d.SweepAngle property

EllipticalCone interface

AxisVector

BasePoint

Evaluator

GetEllipticalConeData

HalfAngle

IsExpanding

MajorAxisVector

MinorMajorRatio

PutEllipticalConeData

EllipticalCone.AxisVector property

EllipticalCone.BasePoint property

EllipticalCone.Evaluator property

EllipticalCone.GetEllipticalConeData method

EllipticalCone.HalfAngle property

EllipticalCone.IsExpanding property

EllipticalCone.MajorAxisVector property

EllipticalCone.MinorMajorRatio property

EllipticalCone.PutEllipticalConeData method

EllipticalCylinder interface

AxisVector

BasePoint

Evaluator

GetEllipticalCylinderData

MajorAxisVector

MinorMajorRatio

PutEllipticalCylinderData

EllipticalCylinder.AxisVector property

EllipticalCylinder.BasePoint property

EllipticalCylinder.Evaluator property

EllipticalCylinder.GetEllipticalCylinderData method

EllipticalCylinder.MajorAxisVector property

EllipticalCylinder.MinorMajorRatio property

EllipticalCylinder.PutEllipticalCylinderData method

EmbossFeature interface

Depth

Direction

EmbossType

Profile

SetEmbossEngraveFromPlane

SetEmbossFromFace

SetEngraveFromFace

Taper

TopFaceColor

WrapFace

WrapToFace

EmbossFeature.Depth property

EmbossFeature.Direction property

EmbossFeature.EmbossType property

EmbossFeature.Profile property

EmbossFeature.SetEmbossEngraveFromPlane method

EmbossFeature.SetEmbossFromFace method

EmbossFeature.SetEngraveFromFace method

EmbossFeature.Taper property

EmbossFeature.TopFaceColor property

EmbossFeature.WrapFace property

EmbossFeature.WrapToFace property

EmbossFeatureProxy interface

ContainingOccurrence

NativeObject

EmbossFeatureProxy.ContainingOccurrence property

EmbossFeatureProxy.NativeObject property

EmbossFeatures

FlatPatternFeatures interface

PartFeatures interface

EmbossFeatures interface

AddEmbossEngraveFromPlane

AddEmbossFromFace

AddEngraveFromFace

Application

Count

Item

Type

EmbossFeatures.AddEmbossEngraveFromPlane method

EmbossFeatures.AddEmbossFromFace method

EmbossFeatures.AddEngraveFromFace method

EmbossFeatures.Application property

EmbossFeatures.Count property

EmbossFeatures.Item method

EmbossFeatures.Type property

EmbossType

EmbossFeature interface

Enable3DGrips

PartOptions interface

EnableApply

MiniToolbarObject interface

EnableBackgroundUpdates

DrawingOptions interface

EnableConstraintRedundancyAnalysis

AssemblyOptions interface

EnableCrossPartEdgeLoopProjection

AssemblyOptions interface

Enabled

BalloonTipObject interface

ComponentOccurrence interface

ControlDefinition interface

HeadsUpDisplayOptions interface

MeasureEventsObject interface

MiniToolbarControl interface

SelectEventsObject interface

TriadEventsObject interface

EnableEnhancedHighlighting

ColorSchemes interface

EnableLegacyProjectCreation

GeneralOptions interface

EnableOK

MiniToolbarObject interface

EnableOptimizedSelection

GeneralOptions interface

EnableOrdinateDimGeomSelection

DrawingOptions interface

EnablePrehighlight

ColorSchemes interface

EnableRelatedConstraintFailureAnalysis

AssemblyOptions interface

End

MessageSection interface

Transaction interface

EndAngle

DraftAnalysis interface

EndDrag

DragContext interface

EndFace

LoftFeature interface

EndFaces

ExtrudeFeature interface

HoleFeature interface

RevolveFeature interface

SweepFeature interface

WeldBead interface

EndFlatAngle

CoilFeature interface

EndOfFeatures interface

Application

Parent

Type

EndOfFeatures.Application property

EndOfFeatures.Parent property

EndOfFeatures.Type property

EndPoint

Arc2d interface

Arc3d interface

BreakOperation interface

Centerline interface

DrawingCurve interface

DrawingCurveSegment interface

EllipticalArc interface

EllipticalArc2d interface

LineSegment interface

LineSegment2d interface

EndRadius

FilletVariableRadiusEdgeSet interface

EndSketchPoint

ProfileEntity interface

ProfileEntity3D interface

SketchArc interface

SketchArc3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

SketchFixedSpline interface

SketchFixedSpline3D interface

SketchLine interface

SketchLine3D interface

SketchOffsetSpline interface

SketchSpline interface

SketchSpline3D interface

EndTangentScale

SketchSpline3D interface

EndTransitionAngle

CoilFeature interface

EndValue

DriveConstraintSettingsObject interface

EndVertex

EdgeDefinition interface

EngagementDiameter

TaperedThreadInfo interface

EngagementLength

TaperedThreadInfo interface

EnsureVisible

BrowserNode interface

Entities

CentroidWorkPointDef interface

Entity

AngleiMateDefinition interface

CurveAndEntityWorkPointDef interface

CustomConstraint3D interface

DiameterDimConstraint interface

EllipseRadiusDimConstraint interface

FlushiMateDefinition interface

GroundConstraint interface

GroundConstraint3D interface

HorizontalConstraint interface

iFeatureEntityInput interface

InsertiMateDefinition interface

MateiMateDefinition interface

OffsetDimConstraint interface

PointInference interface

RadiusDimConstraint interface

RadiusDimConstraint3D interface

RotateRotateiMateDefinition interface

RotateTranslateiMateDefinition interface

TangentiMateDefinition interface

VerticalConstraint interface

EntityFour

OffsetConstraint interface

EntityInferredType

MateiMateDefinition interface

EntityOne

AssemblyConstraint interface

CoincidentConstraint interface

CoincidentConstraint3D interface

CollinearConstraint interface

CollinearConstraint3D interface

ConcentricConstraint interface

EqualRadiusConstraint interface

OffsetConstraint interface

ParallelConstraint interface

ParallelConstraint3D interface

PerpendicularConstraint interface

PerpendicularConstraint3D interface

SmoothConstraint interface

SmoothConstraint3D interface

SymmetryConstraint interface

TangentConstraint3D interface

TangentDistanceDimConstraint interface

TangentSketchConstraint interface

EntityOneInferredType

MateConstraint interface

EntityThree

OffsetConstraint interface

EntityTwo

AssemblyConstraint interface

CoincidentConstraint interface

CoincidentConstraint3D interface

CollinearConstraint interface

CollinearConstraint3D interface

ConcentricConstraint interface

EqualRadiusConstraint interface

OffsetConstraint interface

ParallelConstraint interface

ParallelConstraint3D interface

PerpendicularConstraint interface

PerpendicularConstraint3D interface

SmoothConstraint interface

SmoothConstraint3D interface

SymmetryConstraint interface

TangentConstraint3D interface

TangentDistanceDimConstraint interface

TangentSketchConstraint interface

EntityTwoInferredType

MateConstraint interface

EntityType

iFeatureInput interface

EnumType interface

Count

CurrentIndex

MoveNext

Name

Reset

Value

ValueName

EnumType.Count property

EnumType.CurrentIndex property

EnumType.MoveNext method

EnumType.Name property

EnumType.Reset method

EnumType.Value property

EnumType.ValueName property

Environment interface

AdditionalVisibleRibbonTabs

Application

BuiltIn

ClientId

ContextMenuList

DefaultMenuBar

DefaultRibbonTab

DefaultToolBar

Delete

DisabledCommandList

DisabledCommandTypes

DisplayName

GetRadialMarkingMenu

InheritAllRibbonTabs

InternalName

LargeIcon

PanelBar

Parent

Ribbon

StandardIcon

Type

Environment.AdditionalVisibleRibbonTabs property

Environment.Application property

Environment.BuiltIn property

Environment.ClientId property

Environment.ContextMenuList property

Environment.DefaultMenuBar property

Environment.DefaultRibbonTab property

Environment.DefaultToolBar property

Environment.Delete method

Environment.DisabledCommandList property

Environment.DisabledCommandTypes property

Environment.DisplayName property

Environment.GetRadialMarkingMenu method

Environment.InheritAllRibbonTabs property

Environment.InternalName property

Environment.LargeIcon property

Environment.PanelBar property

Environment.Parent property

Environment.Ribbon property

Environment.StandardIcon property

Environment.Type property

EnvironmentList interface

Add

Application

Count

Item

Remove

Type

EnvironmentList.Add method

EnvironmentList.Application property

EnvironmentList.Count property

EnvironmentList.Item method

EnvironmentList.Remove method

EnvironmentList.Type property

EnvironmentManager

AssemblyDocument interface

DrawingDocument interface

PartDocument interface

PresentationDocument interface

EnvironmentManager interface

Application

BaseEnvironment

EditObjectEnvironment

GetCurrentEnvironment

OverrideEnvironment

Parent

SetCurrentEnvironment

Type

EnvironmentManager.Application property

EnvironmentManager.BaseEnvironment property

EnvironmentManager.EditObjectEnvironment property

EnvironmentManager.GetCurrentEnvironment method

EnvironmentManager.OverrideEnvironment property

EnvironmentManager.Parent property

EnvironmentManager.SetCurrentEnvironment method

EnvironmentManager.Type property

Environments

UserInterfaceManager interface

Environments interface

Add

Application

Count

Item

Type

Environments.Add method

Environments.Application property

Environments.Count property

Environments.Item method

Environments.Type property

EqualLengthConstraint interface

LineOne

LineTwo

EqualLengthConstraint.LineOne property

EqualLengthConstraint.LineTwo property

EqualLengthConstraintProxy interface

ContainingOccurrence

NativeObject

EqualLengthConstraintProxy.ContainingOccurrence property

EqualLengthConstraintProxy.NativeObject property

EqualRadiusConstraint interface

EntityOne

EntityTwo

EqualRadiusConstraint.EntityOne property

EqualRadiusConstraint.EntityTwo property

EqualRadiusConstraintProxy interface

ContainingOccurrence

NativeObject

EqualRadiusConstraintProxy.ContainingOccurrence property

EqualRadiusConstraintProxy.NativeObject property

EquationCount

UnfoldMethod interface

EquationType

UnfoldMethod interface

ErrorManager interface

AddMessage

AllMessages

Application

Clear

HasErrors

HasWarnings

IsMessageSectionActive

LastMessage

Parent

Show

StartMessageSection

Type

ErrorManager.AddMessage method

ErrorManager.AllMessages property

ErrorManager.Application property

ErrorManager.Clear method

ErrorManager.HasErrors property

ErrorManager.HasWarnings property

ErrorManager.IsMessageSectionActive property

ErrorManager.LastMessage property

ErrorManager.Parent property

ErrorManager.Show method

ErrorManager.StartMessageSection method

ErrorManager.Type property

Evaluator

Arc2d interface

Arc3d interface

BSplineCurve interface

BSplineCurve2d interface

BSplineSurface interface

Circle interface

Circle2d interface

Cone interface

Cylinder interface

Edge interface

EdgeUse interface

EllipseFull interface

EllipseFull2d interface

EllipticalArc interface

EllipticalArc2d interface

EllipticalCone interface

EllipticalCylinder interface

Face interface

Line interface

Line2d interface

LineSegment interface

LineSegment2d interface

Plane interface

Polyline2d interface

Polyline3d interface

Sphere interface

Torus interface

Evaluator2D

DrawingCurve interface

Evaluator3D

DrawingCurve interface

Events

DockableWindows interface

ExcelWorkSheet

iAssemblyFactory interface

iFeatureTable interface

iPartFactory interface

PositionalRepresentations interface

ExcludeAll

DerivedPartDefinition interface

ExcludeCharacters

DrawingStandardStyle interface

Excluded

ComponentOccurrence interface

ExcludedFromViewAll

GraphicsNode interface

ExcludeFromCount

Sheet interface

ExcludeFromPrinting

Sheet interface

Execute

ChangeProcessorObject interface

ControlDefinition interface

InventorVBAMember interface

Execute2

ControlDefinition interface

ExecuteCommand

ApplicationAddInServer interface

ExecuteSave

FileSaveAs interface

ExecuteSaveAs

FileSaveAs interface

ExecuteSaveCopyAs

FileSaveAs interface

ExitEdit

BorderDefinition interface

ComponentOccurrence interface

FlatPattern interface

Machining interface

NonParametricBaseFeature interface

Preparations interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchedSymbolDefinition interface

TitleBlockDefinition interface

Welds interface

Expand

Box interface

Box2d interface

Expandable

PartsListRow interface

Expanded

BrowserNode interface

PartsListRow interface

ExpandedDescription

ProgressiveToolTip interface

ExpandedDisabledIcon

ClientNodeResource interface

ExpandedIcon

ClientBrowserNodeDefinitionObject interface

NativeBrowserNodeDefinitionObject interface

ExpandedInvisibleIcon

ClientNodeResource interface

ExpandedSuppressedIcon

ClientNodeResource interface

ExpertMode

UserInterfaceManager interface

Explode

SketchBlock interface

Export

BOMView interface

CustomTable interface

HoleTable interface

PartsList interface

RevisionTable interface

ExportBuildingComponent

BIMComponent interface

Exported

iMateDefinition interface

PlanarSketch interface

Sketch3D interface

SketchBlock interface

SurfaceBody interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

WorkSurface interface

ExportObjects

AssemblyComponentDefinition interface

PartComponentDefinition interface

ExportStandardTolerances

Parameters interface

ExposedAsProperty

Parameter interface

Expression

ContentTableColumn interface

iFeatureParameterInput interface

MiniToolbarValueEditorObject interface

Parameter interface

Property interface

ExpressionLimits interface

Application

DefaultValue

IncrementValue

MaximumValue

MaximumValueComparisonType

MinimumValue

MinimumValueComparisonType

Type

ExpressionLimits.Application property

ExpressionLimits.DefaultValue property

ExpressionLimits.IncrementValue property

ExpressionLimits.MaximumValue property

ExpressionLimits.MaximumValueComparisonType property

ExpressionLimits.MinimumValue property

ExpressionLimits.MinimumValueComparisonType property

ExpressionLimits.Type property

ExpressionList

Parameter interface

ExpressionList interface

_NewEnum

Application

ClearAll

Count

GetExpressionList

Item

Parent

SetExpressionList

Type

ExpressionList._NewEnum property

ExpressionList.Application property

ExpressionList.ClearAll method

ExpressionList.Count property

ExpressionList.GetExpressionList method

ExpressionList.Item method

ExpressionList.Parent property

ExpressionList.SetExpressionList method

ExpressionList.Type property

Extend

Box interface

Box2d interface

ExtendedName

PartFeature interface

ExtendFaces

BendDefinition interface

ContourFlangeDefinition interface

ExtendFeature interface

ExtendFeatureProxy interface

ContainingOccurrence

NativeObject

ExtendFeatureProxy.ContainingOccurrence property

ExtendFeatureProxy.NativeObject property

ExtendFeatures

PartFeatures interface

ExtendFeatures interface

Application

Count

Item

Type

ExtendFeatures.Application property

ExtendFeatures.Count property

ExtendFeatures.Item method

ExtendFeatures.Type property

ExtendFromFace

FromToExtent interface

ExtendProfile

RibDefinition interface

ExtendToFace

FromToExtent interface

ToExtent interface

Extension

DimensionStyle interface

ExtensionLength

CentermarkStyle interface

ExtensionLineOffset

LeaderStyle interface

ExtensionLineOne

AngularGeneralDimension interface

DiameterGeneralDimension interface

LinearGeneralDimension interface

ExtensionLineOneVisible

AngularGeneralDimension interface

LinearGeneralDimension interface

ExtensionLineOvershoot

LeaderStyle interface

ExtensionLinesVisible

Centermark interface

ExtensionLineTwo

AngularGeneralDimension interface

DiameterGeneralDimension interface

LinearGeneralDimension interface

ExtensionLineTwoVisible

AngularGeneralDimension interface

LinearGeneralDimension interface

ExtensionPointFour

Centermark interface

ExtensionPointFourDirection

Centermark interface

ExtensionPointOne

Centermark interface

ExtensionPointOneDirection

Centermark interface

ExtensionPointThree

Centermark interface

ExtensionPointThreeDirection

Centermark interface

ExtensionPointTwo

Centermark interface

ExtensionPointTwoDirection

Centermark interface

Extent

CoilFeature interface

CutDefinition interface

ExtrudeDefinition interface

HoleFeature interface

RevolveFeature interface

ExtentDirection

ContourFlangeDefinition interface

LoftedFlangeDefinition interface

ExtentDistance

RibDefinition interface

ExtentTwo

ExtrudeDefinition interface

RevolveFeature interface

ExtentTwoType

ExtrudeDefinition interface

RevolveFeature interface

ExtentType

CoilFeature interface

CutDefinition interface

ExtrudeDefinition interface

HoleFeature interface

RevolveFeature interface

RibDefinition interface

ExternalMaterialId

Material interface

ExternalPitchDiameter

TaperedThreadInfo interface

ExtrudeDefinition interface

AffectedBodies

AffectedOccurrences

Application

Copy

Extent

ExtentTwo

ExtentTwoType

ExtentType

InferiMates

IsTwoDirectional

MatchShape

Operation

Parent

Profile

SetDistanceExtent

SetDistanceExtentTwo

SetFromToExtent

SetThroughAllExtent

SetToExtent

SetToNextExtent

TaperAngle

TaperAngleTwo

Type

ExtrudeDefinition.AffectedBodies property

ExtrudeDefinition.AffectedOccurrences property

ExtrudeDefinition.Application property

ExtrudeDefinition.Copy method

ExtrudeDefinition.Extent property

ExtrudeDefinition.ExtentTwo property

ExtrudeDefinition.ExtentTwoType property

ExtrudeDefinition.ExtentType property

ExtrudeDefinition.InferiMates property

ExtrudeDefinition.IsTwoDirectional property

ExtrudeDefinition.MatchShape property

ExtrudeDefinition.Operation property

ExtrudeDefinition.Parent property

ExtrudeDefinition.Profile property

ExtrudeDefinition.SetDistanceExtent method

ExtrudeDefinition.SetDistanceExtentTwo method

ExtrudeDefinition.SetFromToExtent method

ExtrudeDefinition.SetThroughAllExtent method

ExtrudeDefinition.SetToExtent method

ExtrudeDefinition.SetToNextExtent method

ExtrudeDefinition.TaperAngle property

ExtrudeDefinition.TaperAngleTwo property

ExtrudeDefinition.Type property

ExtrudeFeature interface

AddParticipant

Definition

EndFaces

SideFaces

StartFaces

ExtrudeFeature.AddParticipant method

ExtrudeFeature.Definition property

ExtrudeFeature.EndFaces property

ExtrudeFeature.SideFaces property

ExtrudeFeature.StartFaces property

ExtrudeFeatureProxy interface

ContainingOccurrence

NativeObject

ExtrudeFeatureProxy.ContainingOccurrence property

ExtrudeFeatureProxy.NativeObject property

ExtrudeFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

ExtrudeFeatures interface

Add

AddByToFaceExtent

Application

Count

CreateExtrudeDefinition

Item

Type

ExtrudeFeatures.Add method

ExtrudeFeatures.AddByToFaceExtent method

ExtrudeFeatures.Application property

ExtrudeFeatures.Count property

ExtrudeFeatures.CreateExtrudeDefinition method

ExtrudeFeatures.Item method

ExtrudeFeatures.Type property

Eye

Camera interface

F

Face

DecalFeature interface

DistanceAndAngleChamferDef interface

EdgeLoop interface

LineAndTangentWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

PointAndTangentWorkPlaneDef interface

RevolvedFaceWorkAxisDef interface

SurfaceGraphicsFace interface

TorusCenterPointWorkPointDef interface

TorusMidPlaneWorkPlaneDef interface

TwoDistancesChamferDef interface

Face interface

AlternateBody

Application

AttributeSets

CalculateFacets

CalculateFacetsAndTextureMap

CalculateStrokes

CreatedByFeature

EdgeLoops

Edges

Evaluator

FaceShell

Geometry

GeometryForm

GetClosestPointTo

GetExistingFacets

GetExistingFacetsAndTextureMap

GetExistingFacetTolerances

GetExistingStrokes

GetExistingStrokeTolerances

GetReferenceKey

GetRenderStyle

GetSourceFace

GetTextureScale

HasReferenceComponent

InternalName

IsParamReversed

Parent

PointOnFace

ReferenceComponent

ReferencedEntity

SetRenderStyle

SurfaceBody

SurfaceType

TangentiallyConnectedFaces

TextureMaps

ThreadInfos

TransientKey

Type

Vertices

Face.AlternateBody method

Face.Application property

Face.AttributeSets property

Face.CalculateFacets method

Face.CalculateFacetsAndTextureMap method

Face.CalculateStrokes method

Face.CreatedByFeature property

Face.EdgeLoops property

Face.Edges property

Face.Evaluator property

Face.FaceShell property

Face.Geometry property

Face.GeometryForm property

Face.GetClosestPointTo method

Face.GetExistingFacets method

Face.GetExistingFacetsAndTextureMap method

Face.GetExistingFacetTolerances method

Face.GetExistingStrokes method

Face.GetExistingStrokeTolerances method

Face.GetReferenceKey method

Face.GetRenderStyle method

Face.GetSourceFace method

Face.GetTextureScale method

Face.HasReferenceComponent property

Face.InternalName property

Face.IsParamReversed property

Face.Parent property

Face.PointOnFace property

Face.ReferenceComponent property

Face.ReferencedEntity property

Face.SetRenderStyle method

Face.SurfaceBody property

Face.SurfaceType property

Face.TangentiallyConnectedFaces property

Face.TextureMaps property

Face.ThreadInfos property

Face.TransientKey property

Face.Type property

Face.Vertices property

FaceCollection interface

CollectionType

FaceCollection.CollectionType property

FaceDefinition interface

Application

AssociativeID

EdgeLoopDefinitions

IsParamReversed

SurfaceGeometry

Type

FaceDefinition.Application property

FaceDefinition.AssociativeID property

FaceDefinition.EdgeLoopDefinitions property

FaceDefinition.IsParamReversed property

FaceDefinition.SurfaceGeometry property

FaceDefinition.Type property

FaceDefinitions

FaceShellDefinition interface

FaceDefinitions interface

Add

Application

Count

Item

Type

FaceDefinitions.Add method

FaceDefinitions.Application property

FaceDefinitions.Count property

FaceDefinitions.Item method

FaceDefinitions.Type property

FaceDraftFeature interface

DirectionReversed

DraftAngle

FixedEdges

InputFaces

PullDirection

FaceDraftFeature.DirectionReversed property

FaceDraftFeature.DraftAngle property

FaceDraftFeature.FixedEdges property

FaceDraftFeature.InputFaces property

FaceDraftFeature.PullDirection property

FaceDraftFeatureProxy interface

ContainingOccurrence

NativeObject

FaceDraftFeatureProxy.ContainingOccurrence property

FaceDraftFeatureProxy.NativeObject property

FaceDraftFeatures

PartFeatures interface

FaceDraftFeatures interface

AddFixedEdge

AddFixedPlane

AddTaperShadow

Application

Count

Item

Type

FaceDraftFeatures.AddFixedEdge method

FaceDraftFeatures.AddFixedPlane method

FaceDraftFeatures.AddTaperShadow method

FaceDraftFeatures.Application property

FaceDraftFeatures.Count property

FaceDraftFeatures.Item method

FaceDraftFeatures.Type property

FaceFeature interface

BendFeature

Definition

FaceFeature.BendFeature property

FaceFeature.Definition property

FaceFeatureDefinition interface

Application

BendDefinition

Direction

Parent

Profile

Type

FaceFeatureDefinition.Application property

FaceFeatureDefinition.BendDefinition property

FaceFeatureDefinition.Direction property

FaceFeatureDefinition.Parent property

FaceFeatureDefinition.Profile property

FaceFeatureDefinition.Type property

FaceFeatureProxy interface

FaceFeatures

SheetMetalFeatures interface

FaceFeatures interface

Add

Application

Count

CreateFaceFeatureDefinition

Item

Type

FaceFeatures.Add method

FaceFeatures.Application property

FaceFeatures.Count property

FaceFeatures.CreateFaceFeatureDefinition method

FaceFeatures.Item method

FaceFeatures.Type property

FaceOne

EdgeDefinition interface

FaceProxy interface

ContainingOccurrence

NativeObject

FaceProxy.ContainingOccurrence property

FaceProxy.NativeObject property

Faces

DraftAnalysis interface

Edge interface

FaceShell interface

FeaturePatternElement interface

FlatPunchResult interface

MoveFaceDefinition interface

PartFeature interface

ShellThicknessFaceSet interface

SurfaceBody interface

Vertex interface

Faces interface

Count

Item

Type

Faces.Count property

Faces.Item method

Faces.Type property

FaceSet

FilletDefinition interface

FaceSetCount

ShellDefinition interface

FaceSetItem

ShellDefinition interface

FaceSetOne

WeldBead interface

FaceSetTwo

WeldBead interface

FaceShell

Face interface

FaceShell interface

Application

AttributeSets

Edges

Faces

GetReferenceKey

IsClosed

IsPointInside

IsVoid

Parent

RangeBox

SurfaceBody

TransientKey

Type

Volume

FaceShell.Application property

FaceShell.AttributeSets property

FaceShell.Edges property

FaceShell.Faces property

FaceShell.GetReferenceKey method

FaceShell.IsClosed property

FaceShell.IsPointInside method

FaceShell.IsVoid property

FaceShell.Parent property

FaceShell.RangeBox property

FaceShell.SurfaceBody property

FaceShell.TransientKey property

FaceShell.Type property

FaceShell.Volume method

FaceShellDefinition interface

Application

FaceDefinitions

Type

FaceShellDefinition.Application property

FaceShellDefinition.FaceDefinitions property

FaceShellDefinition.Type property

FaceShellDefinitions

LumpDefinition interface

FaceShellDefinitions interface

Add

Application

Count

Item

Type

FaceShellDefinitions.Add method

FaceShellDefinitions.Application property

FaceShellDefinitions.Count property

FaceShellDefinitions.Item method

FaceShellDefinitions.Type property

FaceShellProxy interface

ContainingOccurrence

NativeObject

FaceShellProxy.ContainingOccurrence property

FaceShellProxy.NativeObject property

FaceShells

SurfaceBody interface

FaceShells interface

Count

Item

Type

FaceShells.Count property

FaceShells.Item method

FaceShells.Type property

FacesOne

FilletConstantRadiusFaceSet interface

FacesOneReverseDirection

FilletConstantRadiusFaceSet interface

FacesOrBody

SilhouetteCurve interface

FaceSplitSplitAll

SplitFeature interface

FacesTwo

FilletConstantRadiusFaceSet interface

FacesTwoReverseDirection

FilletConstantRadiusFaceSet interface

FacetTolerance

LoftedFlangeDefinition interface

FaceTwo

EdgeDefinition interface

FactoryOptions

iAssemblyFactory interface

iPartFactory interface

FactoryOptions interface

Application

ApplyToAllMembers

IsPartNumberIndexed

MemberNameIndexDigits

MemberNameIndexInitialValue

MemberNameIndexSeparator

MemberNameIndexStepValue

MemberNameType

MemberNameValue

PartNumberIndexDigits

PartNumberIndexInitialValue

PartNumberIndexSeparator

PartNumberIndexStepValue

PartNumberType

PartNumberValue

Type

FactoryOptions.Application property

FactoryOptions.ApplyToAllMembers method

FactoryOptions.IsPartNumberIndexed property

FactoryOptions.MemberNameIndexDigits property

FactoryOptions.MemberNameIndexInitialValue property

FactoryOptions.MemberNameIndexSeparator property

FactoryOptions.MemberNameIndexStepValue property

FactoryOptions.MemberNameType property

FactoryOptions.MemberNameValue property

FactoryOptions.PartNumberIndexDigits property

FactoryOptions.PartNumberIndexInitialValue property

FactoryOptions.PartNumberIndexSeparator property

FactoryOptions.PartNumberIndexStepValue property

FactoryOptions.PartNumberType property

FactoryOptions.PartNumberValue property

FactoryOptions.Type property

FailedBooleanOperation

DerivedAssemblyOccurrence interface

Families

ContentTreeViewNode interface

FamilyType

ContentFamily interface

FeatureBasedOccurrencePattern interface

FeaturePattern

FeatureBasedOccurrencePattern.FeaturePattern property

FeatureBasedOccurrencePatternProxy interface

ContainingOccurrence

NativeObject

FeatureBasedOccurrencePatternProxy.ContainingOccurrence property

FeatureBasedOccurrencePatternProxy.NativeObject property

FeatureControlFrame interface

AllAroundSymbol

Application

AttributeSets

DatumIdentifier

Delete

FeatureControlFrameRows

GetReferenceKey

Layer

Leader

Notes

Parent

Position

Rotation

Style

Type

FeatureControlFrame.AllAroundSymbol property

FeatureControlFrame.Application property

FeatureControlFrame.AttributeSets property

FeatureControlFrame.DatumIdentifier property

FeatureControlFrame.Delete method

FeatureControlFrame.FeatureControlFrameRows property

FeatureControlFrame.GetReferenceKey method

FeatureControlFrame.Layer property

FeatureControlFrame.Leader property

FeatureControlFrame.Notes property

FeatureControlFrame.Parent property

FeatureControlFrame.Position property

FeatureControlFrame.Rotation property

FeatureControlFrame.Style property

FeatureControlFrame.Type property

FeatureControlFrameLayer

ObjectDefaultsStyle interface

FeatureControlFrameRow interface

Application

DatumOne

DatumThree

DatumTwo

Delete

GeometricCharacteristic

LowerTolerance

Parent

Tolerance

Type

FeatureControlFrameRow.Application property

FeatureControlFrameRow.DatumOne property

FeatureControlFrameRow.DatumThree property

FeatureControlFrameRow.DatumTwo property

FeatureControlFrameRow.Delete method

FeatureControlFrameRow.GeometricCharacteristic property

FeatureControlFrameRow.LowerTolerance property

FeatureControlFrameRow.Parent property

FeatureControlFrameRow.Tolerance property

FeatureControlFrameRow.Type property

FeatureControlFrameRows

FeatureControlFrame interface

FeatureControlFrameRows interface

Add

Application

Count

Item

Type

FeatureControlFrameRows.Add method

FeatureControlFrameRows.Application property

FeatureControlFrameRows.Count property

FeatureControlFrameRows.Item method

FeatureControlFrameRows.Type property

FeatureControlFrames

Sheet interface

FeatureControlFrames interface

Add

Application

Count

CreateFeatureControlFrameRows

Item

Type

FeatureControlFrames.Add method

FeatureControlFrames.Application property

FeatureControlFrames.Count property

FeatureControlFrames.CreateFeatureControlFrameRows method

FeatureControlFrames.Item method

FeatureControlFrames.Type property

FeatureControlFrameStyle

ObjectDefaultsStyle interface

FeatureControlFrameStyle interface

AlignCellsVertically

AllowTolerance2

AlternateDecimalMarkerType

AlternateDisplayUnitType

AlternateLeadingZeroDisplay

AlternateLinearPrecision

AlternateLinearUnits

AlternateTrailingZeroDisplay

AlternateUnitsDisplay

AlternateUnitsDisplayType

AttachLeaderToCorner

AvailableGeometricCharacteristics

AvailableModifiers

DecimalMarkerType

DisplayUnitType

LeaderStyle

LeadingZeroDisplay

LinearUnits

MergeDatum

MergeSymbol

MergeTolerance

ScaleToTextHeight

Size

TextStyle

TrailingZeroDisplay

WhiteSpace

FeatureControlFrameStyle.AlignCellsVertically property

FeatureControlFrameStyle.AllowTolerance2 property

FeatureControlFrameStyle.AlternateDecimalMarkerType property

FeatureControlFrameStyle.AlternateDisplayUnitType property

FeatureControlFrameStyle.AlternateLeadingZeroDisplay property

FeatureControlFrameStyle.AlternateLinearPrecision property

FeatureControlFrameStyle.AlternateLinearUnits property

FeatureControlFrameStyle.AlternateTrailingZeroDisplay property

FeatureControlFrameStyle.AlternateUnitsDisplay property

FeatureControlFrameStyle.AlternateUnitsDisplayType property

FeatureControlFrameStyle.AttachLeaderToCorner property

FeatureControlFrameStyle.AvailableGeometricCharacteristics property

FeatureControlFrameStyle.AvailableModifiers property

FeatureControlFrameStyle.DecimalMarkerType property

FeatureControlFrameStyle.DisplayUnitType property

FeatureControlFrameStyle.LeaderStyle property

FeatureControlFrameStyle.LeadingZeroDisplay property

FeatureControlFrameStyle.LinearUnits property

FeatureControlFrameStyle.MergeDatum property

FeatureControlFrameStyle.MergeSymbol property

FeatureControlFrameStyle.MergeTolerance property

FeatureControlFrameStyle.ScaleToTextHeight property

FeatureControlFrameStyle.Size property

FeatureControlFrameStyle.TextStyle property

FeatureControlFrameStyle.TrailingZeroDisplay property

FeatureControlFrameStyle.WhiteSpace property

FeatureControlFrameStyles

DrawingStylesManager interface

FeatureControlFrameStylesEnumerator interface

Application

Count

Item

Type

FeatureControlFrameStylesEnumerator.Application property

FeatureControlFrameStylesEnumerator.Count property

FeatureControlFrameStylesEnumerator.Item method

FeatureControlFrameStylesEnumerator.Type property

FeatureDimension interface

AnchorPoints

Application

AttributeSets

DimensionType

GetReferenceKey

Parameter

Parent

TextPoint

Type

FeatureDimension.AnchorPoints property

FeatureDimension.Application property

FeatureDimension.AttributeSets property

FeatureDimension.DimensionType property

FeatureDimension.GetReferenceKey method

FeatureDimension.Parameter property

FeatureDimension.Parent property

FeatureDimension.TextPoint property

FeatureDimension.Type property

FeatureDimensionProxy interface

ContainingOccurrence

NativeObject

FeatureDimensionProxy.ContainingOccurrence property

FeatureDimensionProxy.NativeObject property

FeatureDimensions

PartFeature interface

FeatureDimensions interface

Application

Count

Item

Show

Type

FeatureDimensions.Application property

FeatureDimensions.Count property

FeatureDimensions.Item method

FeatureDimensions.Show method

FeatureDimensions.Type property

FeatureInputs

ClientFeatureDefinition interface

FeaturePattern

FeatureBasedOccurrencePattern interface

FeaturePatternElement interface

Application

AttributeSets

Faces

GetReferenceKey

Index

Parent

ResultFeatures

Suppressed

Transform

Type

FeaturePatternElement.Application property

FeaturePatternElement.AttributeSets property

FeaturePatternElement.Faces property

FeaturePatternElement.GetReferenceKey method

FeaturePatternElement.Index property

FeaturePatternElement.Parent property

FeaturePatternElement.ResultFeatures property

FeaturePatternElement.Suppressed property

FeaturePatternElement.Transform property

FeaturePatternElement.Type property

FeaturePatternElementProxy interface

ContainingOccurrence

NativeObject

FeaturePatternElementProxy.ContainingOccurrence property

FeaturePatternElementProxy.NativeObject property

FeaturePatternElements interface

Application

Count

Item

Type

FeaturePatternElements.Application property

FeaturePatternElements.Count property

FeaturePatternElements.Item method

FeaturePatternElements.Type property

Features

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

Features interface

Application

ChamferFeatures

CircularPatternFeatures

ClientFeatures

Count

CreatePath

CreateSpecifiedPath

ExtrudeFeatures

FilletFeatures

HoleFeatures

Item

MirrorFeatures

MoveFaceFeatures

RectangularPatternFeatures

RevolveFeatures

SweepFeatures

Type

Features.Application property

Features.ChamferFeatures property

Features.CircularPatternFeatures property

Features.ClientFeatures property

Features.Count property

Features.CreatePath method

Features.CreateSpecifiedPath method

Features.ExtrudeFeatures property

Features.FilletFeatures property

Features.HoleFeatures property

Features.Item method

Features.MirrorFeatures property

Features.MoveFaceFeatures property

Features.RectangularPatternFeatures property

Features.RevolveFeatures property

Features.SweepFeatures property

Features.Type property

FeatureType

ClientFeatureDefinition interface

FenceCenter

DetailDrawingView interface

FenceCornerOne

DetailDrawingView interface

FenceCornerTwo

DetailDrawingView interface

FenceRadius

DetailDrawingView interface

File

ApprenticeServerDocument interface

Document interface

File interface

AllReferencedFiles

Application

AvailableDocuments

FileSaveCounter

FullFileName

InternalName

ReferencedFileDescriptors

ReferencedFiles

ReferencingFiles

Type

File.AllReferencedFiles property

File.Application property

File.AvailableDocuments property

File.FileSaveCounter property

File.FullFileName property

File.InternalName property

File.ReferencedFileDescriptors property

File.ReferencedFiles property

File.ReferencingFiles property

File.Type property

FileAccessEvents

ApprenticeServer interface

FileAccessEvents coclass

FileAccessEventsObject interface

Application

FireOnFileResolution

Parent

Type

FileAccessEventsObject.Application property

FileAccessEventsObject.FireOnFileResolution method

FileAccessEventsObject.Parent property

FileAccessEventsObject.Type property

FileAccessEventsSink interface

OnFileDirty

OnFileResolution

FileAccessEventsSink.OnFileDirty method

FileAccessEventsSink.OnFileResolution method

FileBrowserControls

UserInterfaceManager interface

FileDescriptor

ReferencedOLEFileDescriptor interface

FileDescriptor interface

Application

FileSaveCounter

FullFileName

GetCustomLogicalFileName

LibraryName

LocationType

Parent

PutCustomLogicalFileName

ReferencedFile

ReferencedFileType

ReferenceDisabled

ReferenceInternalNameDifferent

ReferenceLocationDifferent

ReferenceMissing

RelativeFileName

ReplaceReference

Type

FileDescriptor.Application property

FileDescriptor.FileSaveCounter property

FileDescriptor.FullFileName property

FileDescriptor.GetCustomLogicalFileName method

FileDescriptor.LibraryName property

FileDescriptor.LocationType property

FileDescriptor.Parent property

FileDescriptor.PutCustomLogicalFileName method

FileDescriptor.ReferencedFile property

FileDescriptor.ReferencedFileType property

FileDescriptor.ReferenceDisabled property

FileDescriptor.ReferenceInternalNameDifferent property

FileDescriptor.ReferenceLocationDifferent property

FileDescriptor.ReferenceMissing property

FileDescriptor.RelativeFileName property

FileDescriptor.ReplaceReference method

FileDescriptor.Type property

FileDescriptorsEnumerator interface

Application

Count

Item

Type

FileDescriptorsEnumerator.Application property

FileDescriptorsEnumerator.Count property

FileDescriptorsEnumerator.Item method

FileDescriptorsEnumerator.Type property

FileDialog interface

CancelError

DialogTitle

FileDialogEvents

FileName

Filter

FilterIndex

InitialDirectory

InsertMode

MultiSelectEnabled

OptionsEnabled

SetHelpContext

SetHelpTopic

ShowOpen

ShowSave

SuppressResolutionWarnings

FileDialog.CancelError property

FileDialog.DialogTitle property

FileDialog.FileDialogEvents property

FileDialog.FileName property

FileDialog.Filter property

FileDialog.FilterIndex property

FileDialog.InitialDirectory property

FileDialog.InsertMode property

FileDialog.MultiSelectEnabled property

FileDialog.OptionsEnabled property

FileDialog.SetHelpContext method

FileDialog.SetHelpTopic method

FileDialog.ShowOpen method

FileDialog.ShowSave method

FileDialog.SuppressResolutionWarnings property

FileDialogEvents

FileDialog interface

FileDialogEvents coclass

FileDialogEventsObject interface

Application

Parent

Type

FileDialogEventsObject.Application property

FileDialogEventsObject.Parent property

FileDialogEventsObject.Type property

FileDialogEventsSink interface

OnOptions

FileDialogEventsSink.OnOptions method

FileExtensions

TranslatorAddIn interface

FileLocations

ApprenticeServer interface

FileLocations interface

AddLibrary

AddWorkgroup

FileLocationsFile

FileLocationsFilesDir

FindInLocations

FindLogicalInLocations

Libraries

ProjectFiles

RemoveLibrary

RemoveWorkgroup

Workgroups

Workspace

FileLocations.AddLibrary method

FileLocations.AddWorkgroup method

FileLocations.FileLocationsFile property

FileLocations.FileLocationsFilesDir property

FileLocations.FindInLocations method

FileLocations.FindLogicalInLocations method

FileLocations.Libraries method

FileLocations.ProjectFiles method

FileLocations.RemoveLibrary method

FileLocations.RemoveWorkgroup method

FileLocations.Workgroups method

FileLocations.Workspace property

FileLocationsFile

FileLocations interface

FileLocationsFilesDir

FileLocations interface

FileManager

ApprenticeServer interface

FileManager interface

Application

CopyFile

DeleteFile

FileManagerEvents

Files

FileSystemObject

GetAutoCADBlockDefinitions

GetDesignViewRepresentations

GetDWGDocumentReferences

GetFileNameFromIdentifier

GetFullDocumentName

GetFullFileName

GetIdentifierFromFileName

GetLastActiveDesignViewRepresentation

GetLastActiveLevelOfDetailRepresentation

GetLevelOfDetailName

GetLevelOfDetailRepresentations

GetPositionalRepresentations

GetTemplateFile

IsFileNameValid

IsInventorDWG

MoveFile

RefreshAllDocuments

SoftwareVersionSaved

Type

FileManager.Application property

FileManager.CopyFile method

FileManager.DeleteFile method

FileManager.FileManagerEvents property

FileManager.Files property

FileManager.FileSystemObject property

FileManager.GetAutoCADBlockDefinitions method

FileManager.GetDesignViewRepresentations method

FileManager.GetDWGDocumentReferences method

FileManager.GetFileNameFromIdentifier method

FileManager.GetFullDocumentName method

FileManager.GetFullFileName method

FileManager.GetIdentifierFromFileName method

FileManager.GetLastActiveDesignViewRepresentation method

FileManager.GetLastActiveLevelOfDetailRepresentation method

FileManager.GetLevelOfDetailName method

FileManager.GetLevelOfDetailRepresentations method

FileManager.GetPositionalRepresentations method

FileManager.GetTemplateFile method

FileManager.IsFileNameValid method

FileManager.IsInventorDWG method

FileManager.MoveFile method

FileManager.RefreshAllDocuments method

FileManager.SoftwareVersionSaved method

FileManager.Type property

FileManagerEvents

FileManager interface

FileManagerEvents coclass

FileManagerEventsObject interface

Application

Parent

Type

FileManagerEventsObject.Application property

FileManagerEventsObject.Parent property

FileManagerEventsObject.Type property

FileManagerEventsSink interface

OnFileCopy

OnFileDelete

FileManagerEventsSink.OnFileCopy method

FileManagerEventsSink.OnFileDelete method

FileMetadata interface

DisplayName

DisplayNameOverridden

Document

FileName

FileNameOverridden

FileProperties

FullFileName

Type

FileMetadata.DisplayName property

FileMetadata.DisplayNameOverridden property

FileMetadata.Document property

FileMetadata.FileName property

FileMetadata.FileNameOverridden property

FileMetadata.FileProperties property

FileMetadata.FullFileName property

FileMetadata.Type property

FileName

DataMedium interface

FileDialog interface

FileMetadata interface

ParameterTable interface

FileNameColumn

ContentFamily interface

iAssemblyFactory interface

iPartFactory interface

FileNameOverridden

FileMetadata interface

FileOpenOptions

FileOptions interface

FileOpenOptions interface

DefaultDesignView

DefaultDesignViewIsAssociative

DefaultLevelOfDetail

SkipAllUnresolvedFilesInAssembly

SkipAllUnresolvedFilesInDrawing

SkipAllUnresolvedFilesInPart

FileOpenOptions.DefaultDesignView property

FileOpenOptions.DefaultDesignViewIsAssociative property

FileOpenOptions.DefaultLevelOfDetail property

FileOpenOptions.SkipAllUnresolvedFilesInAssembly property

FileOpenOptions.SkipAllUnresolvedFilesInDrawing property

FileOpenOptions.SkipAllUnresolvedFilesInPart property

FileOptions

ApprenticeServer interface

FileOptions interface

Application

ContentCenterPath

DefaultVBAProjectFileFullFilename

DesignDataPath

FileOpenOptions

ProjectsPath

QuickFileOpenCachedAssembly

QuickFileOpenCacheLastAssembly

QuickFileOpenEnabled

TeamWebFullFilename

TemplatesPath

Type

UndoPath

FileOptions.Application property

FileOptions.ContentCenterPath property

FileOptions.DefaultVBAProjectFileFullFilename property

FileOptions.DesignDataPath property

FileOptions.FileOpenOptions property

FileOptions.ProjectsPath property

FileOptions.QuickFileOpenCachedAssembly property

FileOptions.QuickFileOpenCacheLastAssembly property

FileOptions.QuickFileOpenEnabled property

FileOptions.TeamWebFullFilename property

FileOptions.TemplatesPath property

FileOptions.Type property

FileOptions.UndoPath property

FileProperties

FileMetadata interface

Files

FileManager interface

FileSaveAs

ApprenticeServer interface

FileSaveAs interface

AddFileToSave

ExecuteSave

ExecuteSaveAs

ExecuteSaveCopyAs

FileSaveAs.AddFileToSave method

FileSaveAs.ExecuteSave method

FileSaveAs.ExecuteSaveAs method

FileSaveAs.ExecuteSaveCopyAs method

FileSaveCounter

ApprenticeServerDocument interface

Document interface

File interface

FileDescriptor interface

FilesEnumerator interface

Application

Count

Item

Type

FilesEnumerator.Application property

FilesEnumerator.Count property

FilesEnumerator.Item method

FilesEnumerator.Type property

FileSystemObject

FileManager interface

FileUIEvents

Application interface

FileUIEvents coclass

FileUIEventsObject interface

Application

Parent

PopulateFileMetadata

Type

FileUIEventsObject.Application property

FileUIEventsObject.Parent property

FileUIEventsObject.PopulateFileMetadata method

FileUIEventsObject.Type property

FileUIEventsSink interface

OnFileInsertDialog

OnFileInsertNewDialog

OnFileNew

OnFileNewDialog

OnFileOpenDialog

OnFileOpenFromMRU

OnFileSaveAsDialog

OnPopulateFileMetadata

FileUIEventsSink.OnFileInsertDialog method

FileUIEventsSink.OnFileInsertNewDialog method

FileUIEventsSink.OnFileNew method

FileUIEventsSink.OnFileNewDialog method

FileUIEventsSink.OnFileOpenDialog method

FileUIEventsSink.OnFileOpenFromMRU method

FileUIEventsSink.OnFileSaveAsDialog method

FileUIEventsSink.OnPopulateFileMetadata method

FilletConstantRadiusEdgeSet interface

AllFillets

AllRounds

ContinuityType

Radius

FilletConstantRadiusEdgeSet.AllFillets property

FilletConstantRadiusEdgeSet.AllRounds property

FilletConstantRadiusEdgeSet.ContinuityType property

FilletConstantRadiusEdgeSet.Radius property

FilletConstantRadiusFaceSet interface

Application

BiasPoint

FacesOne

FacesOneReverseDirection

FacesTwo

FacesTwoReverseDirection

IncludeTangentFaces

Radius

Type

FilletConstantRadiusFaceSet.Application property

FilletConstantRadiusFaceSet.BiasPoint property

FilletConstantRadiusFaceSet.FacesOne property

FilletConstantRadiusFaceSet.FacesOneReverseDirection property

FilletConstantRadiusFaceSet.FacesTwo property

FilletConstantRadiusFaceSet.FacesTwoReverseDirection property

FilletConstantRadiusFaceSet.IncludeTangentFaces property

FilletConstantRadiusFaceSet.Radius property

FilletConstantRadiusFaceSet.Type property

FilletDefinition

FilletFeature interface

FilletDefinition interface

AddConstantRadiusEdgeSet

AddFaceSet

AddFullRoundSet

AddVariableRadiusEdgeSet

Application

EdgeSetCount

EdgeSetItem

FaceSet

FilletType

FullRoundSet

Parent

SetbackVertexCount

SetbackVertexItem

Type

FilletDefinition.AddConstantRadiusEdgeSet method

FilletDefinition.AddFaceSet method

FilletDefinition.AddFullRoundSet method

FilletDefinition.AddVariableRadiusEdgeSet method

FilletDefinition.Application property

FilletDefinition.EdgeSetCount property

FilletDefinition.EdgeSetItem method

FilletDefinition.FaceSet property

FilletDefinition.FilletType property

FilletDefinition.FullRoundSet property

FilletDefinition.Parent property

FilletDefinition.SetbackVertexCount property

FilletDefinition.SetbackVertexItem method

FilletDefinition.Type property

FilletFeature interface

AutomaticEdgeChain

FilletDefinition

PreserveAllFeatures

RollAlongSharpEdges

RollingBallWherePossible

SmoothRadiusTransition

FilletFeature.AutomaticEdgeChain property

FilletFeature.FilletDefinition property

FilletFeature.PreserveAllFeatures property

FilletFeature.RollAlongSharpEdges property

FilletFeature.RollingBallWherePossible property

FilletFeature.SmoothRadiusTransition property

FilletFeatureProxy interface

ContainingOccurrence

NativeObject

FilletFeatureProxy.ContainingOccurrence property

FilletFeatureProxy.NativeObject property

FilletFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

FilletFeatures interface

Add

AddSimple

Application

Count

CreateFilletDefinition

Item

Type

FilletFeatures.Add method

FilletFeatures.AddSimple method

FilletFeatures.Application property

FilletFeatures.Count property

FilletFeatures.CreateFilletDefinition method

FilletFeatures.Item method

FilletFeatures.Type property

FilletFullRoundSet interface

Application

CenterFaces

IncludeTangentFaces

SideFacesOne

SideFacesTwo

Type

FilletFullRoundSet.Application property

FilletFullRoundSet.CenterFaces property

FilletFullRoundSet.IncludeTangentFaces property

FilletFullRoundSet.SideFacesOne property

FilletFullRoundSet.SideFacesTwo property

FilletFullRoundSet.Type property

FilletIntermediateRadius interface

Edge

PercentLength

Radius

FilletIntermediateRadius.Edge property

FilletIntermediateRadius.PercentLength property

FilletIntermediateRadius.Radius property

FilletRadiusEdgeSet interface

Application

Edges

Type

FilletRadiusEdgeSet.Application property

FilletRadiusEdgeSet.Edges property

FilletRadiusEdgeSet.Type property

FilletRadiusMaximumThreshold

AutomatedCenterlineSettings interface

FilletRadiusMinimumThreshold

AutomatedCenterlineSettings interface

FilletSetback interface

Edge

Setback

FilletSetback.Edge property

FilletSetback.Setback property

FilletSetbackVertex interface

MinimalSetback

SetbackCount

SetbackItem

Type

UseSetbacks

Vertex

FilletSetbackVertex.MinimalSetback property

FilletSetbackVertex.SetbackCount property

FilletSetbackVertex.SetbackItem method

FilletSetbackVertex.Type property

FilletSetbackVertex.UseSetbacks property

FilletSetbackVertex.Vertex property

FilletType

FilletDefinition interface

FilletVariableRadiusEdgeSet interface

AddIntermediateRadius

ContinuityType

EndRadius

IntermediateRadiusCount

IntermediateRadiusItem

StartRadius

FilletVariableRadiusEdgeSet.AddIntermediateRadius method

FilletVariableRadiusEdgeSet.ContinuityType property

FilletVariableRadiusEdgeSet.EndRadius property

FilletVariableRadiusEdgeSet.IntermediateRadiusCount property

FilletVariableRadiusEdgeSet.IntermediateRadiusItem method

FilletVariableRadiusEdgeSet.StartRadius property

Filter

FileDialog interface

FilterIndex

FileDialog interface

FilterText

TranslatorAddIn interface

FindAttributes

AttributeManager interface

FindAttributeSets

AttributeManager interface

FindInLocations

FileLocations interface

FindLogicalInLocations

FileLocations interface

FindObjects

AttributeManager interface

FindObjectsByPattern

AttributeManager interface

FindUsingPoint

ComponentDefinition interface

Sheet interface

FindUsingRay

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

SurfaceBody interface

FindUsingVector

ComponentDefinition interface

FindWhereUsed

ApprenticeServerDocument interface

Document interface

FireOnCommandInputs

ControlDefinitionEventsObject interface

FireOnFileResolution

FileAccessEventsObject interface

FirstAngleProjection

DrawingStandardStyle interface

FirstArrowheadInside

GeneralDimension interface

FirstArrowheadType

GeneralDimension interface

FirstSectionAngle

LoftDefinition interface

FirstSectionCondition

LoftDefinition interface

FirstSectionDirectionReversed

LoftDefinition interface

FirstSectionImpact

LoftDefinition interface

FirstSectionTangentPlane

LoftDefinition interface

Fit

Camera interface

View interface

FitMethod

BSplineCurve2dDefinition interface

BSplineCurveDefinition interface

SketchSpline interface

SketchSpline3D interface

FitPoint

SketchSpline interface

SketchSpline3D interface

SketchSplineHandle interface

SketchSplineHandle3D interface

FitPointCount

SketchSpline interface

SketchSpline3D interface

FitPoints

Centerline interface

Fitted

GeneralNote interface

TextBox interface

FittedTextHeight

GeneralNote interface

TextBox interface

FittedTextWidth

GeneralNote interface

TextBox interface

FitWithinAngle

CircularPatternFeature interface

FixedEdges

FaceDraftFeature interface

FixedWorkAxisDef interface

Application

Axis

GetData

OriginPoint

Parent

PutData

Type

FixedWorkAxisDef.Application property

FixedWorkAxisDef.Axis property

FixedWorkAxisDef.GetData method

FixedWorkAxisDef.OriginPoint property

FixedWorkAxisDef.Parent property

FixedWorkAxisDef.PutData method

FixedWorkAxisDef.Type property

FixedWorkPlaneDef interface

Application

GetData

OriginPoint

Parent

PutData

Type

XAxis

YAxis

FixedWorkPlaneDef.Application property

FixedWorkPlaneDef.GetData method

FixedWorkPlaneDef.OriginPoint property

FixedWorkPlaneDef.Parent property

FixedWorkPlaneDef.PutData method

FixedWorkPlaneDef.Type property

FixedWorkPlaneDef.XAxis property

FixedWorkPlaneDef.YAxis property

FixedWorkPointDef interface

Application

Parent

Point

Type

FixedWorkPointDef.Application property

FixedWorkPointDef.Parent property

FixedWorkPointDef.Point property

FixedWorkPointDef.Type property

FlangeAngle

FlangeDefinition interface

FlangeDefinition interface

Application

ApplyAutoMitering

BendOptions

BendPosition

BendRadius

Copy

CornerOptions

DefaultWidthExtent

DefaultWidthExtentType

Edges

FlangeAngle

GetWidthExtent

GetWidthExtentType

HeightExtent

HeightExtentType

IsUnfoldMethodOverridden

MiterGap

Parent

RemoveOverrideWidthExtent

SetCenteredDefaultWidthExtent

SetCenteredWidthExtent

SetDistanceHeightExtent

SetEdgeDefaultWidthExtent

SetEdgeWidthExtent

SetFromToDefaultWidthExtent

SetFromToWidthExtent

SetLegacyDistanceHeightExtent

SetOffsetDefaultWidthExtent

SetOffsetWidthExtent

SetToHeightExtent

SetWidthOffsetDefaultWidthExtent

SetWidthOffsetWidthExtent

Type

UnfoldMethod

FlangeDefinition.Application property

FlangeDefinition.ApplyAutoMitering property

FlangeDefinition.BendOptions property

FlangeDefinition.BendPosition property

FlangeDefinition.BendRadius property

FlangeDefinition.Copy method

FlangeDefinition.CornerOptions property

FlangeDefinition.DefaultWidthExtent property

FlangeDefinition.DefaultWidthExtentType property

FlangeDefinition.Edges property

FlangeDefinition.FlangeAngle property

FlangeDefinition.GetWidthExtent method

FlangeDefinition.GetWidthExtentType method

FlangeDefinition.HeightExtent property

FlangeDefinition.HeightExtentType property

FlangeDefinition.IsUnfoldMethodOverridden property

FlangeDefinition.MiterGap property

FlangeDefinition.Parent property

FlangeDefinition.RemoveOverrideWidthExtent method

FlangeDefinition.SetCenteredDefaultWidthExtent method

FlangeDefinition.SetCenteredWidthExtent method

FlangeDefinition.SetDistanceHeightExtent method

FlangeDefinition.SetEdgeDefaultWidthExtent method

FlangeDefinition.SetEdgeWidthExtent method

FlangeDefinition.SetFromToDefaultWidthExtent method

FlangeDefinition.SetFromToWidthExtent method

FlangeDefinition.SetLegacyDistanceHeightExtent method

FlangeDefinition.SetOffsetDefaultWidthExtent method

FlangeDefinition.SetOffsetWidthExtent method

FlangeDefinition.SetToHeightExtent method

FlangeDefinition.SetWidthOffsetDefaultWidthExtent method

FlangeDefinition.SetWidthOffsetWidthExtent method

FlangeDefinition.Type property

FlangeDefinition.UnfoldMethod property

FlangeDirection

DistanceHeightExtent interface

LegacyDistanceHeightExtent interface

FlangeFeature interface

BendFeature

Definition

FlangeFeature.BendFeature property

FlangeFeature.Definition property

FlangeFeatureProxy interface

FlangeFeatures

SheetMetalFeatures interface

FlangeFeatures interface

Add

Application

Count

CreateFlangeDefinition

Item

Type

FlangeFeatures.Add method

FlangeFeatures.Application property

FlangeFeatures.Count property

FlangeFeatures.CreateFlangeDefinition method

FlangeFeatures.Item method

FlangeFeatures.Type property

FlatBendResult interface

Angle

Application

Edge

GetBendOrder

InnerRadius

InternalName

IsDirectionUp

IsOnBottomFace

KFactor

Parent

SetBendOrder

Type

FlatBendResult.Angle property

FlatBendResult.Application property

FlatBendResult.Edge property

FlatBendResult.GetBendOrder method

FlatBendResult.InnerRadius property

FlatBendResult.InternalName property

FlatBendResult.IsDirectionUp property

FlatBendResult.IsOnBottomFace property

FlatBendResult.KFactor property

FlatBendResult.Parent property

FlatBendResult.SetBendOrder method

FlatBendResult.Type property

FlatBendResults

FlatPattern interface

FlatBendResults interface

Application

Count

Item

Type

FlatBendResults.Application property

FlatBendResults.Count property

FlatBendResults.Item method

FlatBendResults.Type property

FlatBottom

HoleFeature interface

FlatEndType

CoilFeature interface

FlatPattern

SheetMetalComponentDefinition interface

FlatPattern interface

BaseFace

BendAngleReportType

Body

BottomFace

Delete

DeleteObjects

Edit

ExitEdit

Features

FindUsingRay

FlatBendResults

FlatPunchResults

FlipBaseFace

GetAlignment

GetEdgesOfType

GetEndOfPartPosition

GetFlatPatternEntity

GraphicsDataSetsCollection

Length

MassProperties

Parameters

Parent

PartEvents

PunchRepresentationType

RepresentationsManager

RolledBackForEdit

SetAlignment

SetEndOfPartToTopOrBottom

SketchBlockDefinitions

Sketches

Sketches3D

SuppressFeatures

TopFace

UnsuppressFeatures

UserCoordinateSystems

Width

WorkAxes

WorkPlanes

WorkPoints

FlatPattern.BaseFace property

FlatPattern.BendAngleReportType property

FlatPattern.Body property

FlatPattern.BottomFace property

FlatPattern.Delete method

FlatPattern.DeleteObjects method

FlatPattern.Edit method

FlatPattern.ExitEdit method

FlatPattern.Features property

FlatPattern.FindUsingRay method

FlatPattern.FlatBendResults property

FlatPattern.FlatPunchResults property

FlatPattern.FlipBaseFace method

FlatPattern.GetAlignment method

FlatPattern.GetEdgesOfType method

FlatPattern.GetEndOfPartPosition method

FlatPattern.GetFlatPatternEntity method

FlatPattern.GraphicsDataSetsCollection property

FlatPattern.Length property

FlatPattern.MassProperties property

FlatPattern.Parameters property

FlatPattern.Parent property

FlatPattern.PartEvents property

FlatPattern.PunchRepresentationType property

FlatPattern.RepresentationsManager property

FlatPattern.RolledBackForEdit property

FlatPattern.SetAlignment method

FlatPattern.SetEndOfPartToTopOrBottom method

FlatPattern.SketchBlockDefinitions property

FlatPattern.Sketches property

FlatPattern.Sketches3D property

FlatPattern.SuppressFeatures method

FlatPattern.TopFace property

FlatPattern.UnsuppressFeatures method

FlatPattern.UserCoordinateSystems property

FlatPattern.Width property

FlatPattern.WorkAxes property

FlatPattern.WorkPlanes property

FlatPattern.WorkPoints property

FlatPatternFeatures interface

Application

ChamferFeatures

CircularPatternFeatures

CornerChamferFeatures

CornerRoundFeatures

CosmeticBendFeatures

Count

CreatePath

CutFeatures

EmbossFeatures

ExtrudeFeatures

FilletFeatures

HoleFeatures

iFeatures

Item

MirrorFeatures

PunchToolFeatures

RectangularPatternFeatures

RevolveFeatures

SweepFeatures

Type

FlatPatternFeatures.Application property

FlatPatternFeatures.ChamferFeatures property

FlatPatternFeatures.CircularPatternFeatures property

FlatPatternFeatures.CornerChamferFeatures property

FlatPatternFeatures.CornerRoundFeatures property

FlatPatternFeatures.CosmeticBendFeatures property

FlatPatternFeatures.Count property

FlatPatternFeatures.CreatePath method

FlatPatternFeatures.CutFeatures property

FlatPatternFeatures.EmbossFeatures property

FlatPatternFeatures.ExtrudeFeatures property

FlatPatternFeatures.FilletFeatures property

FlatPatternFeatures.HoleFeatures property

FlatPatternFeatures.iFeatures property

FlatPatternFeatures.Item method

FlatPatternFeatures.MirrorFeatures property

FlatPatternFeatures.PunchToolFeatures property

FlatPatternFeatures.RectangularPatternFeatures property

FlatPatternFeatures.RevolveFeatures property

FlatPatternFeatures.SweepFeatures property

FlatPatternFeatures.Type property

FlatPunchResult interface

Angle

Application

Depth

Faces

FoldedAngle

FoldedPosition

HasDepth

InternalName

IsDirectionUp

IsPunchAfterStopNode

IsPunchSuppressed

Parent

Position

PunchId

SketchRepresentationEdges

Type

FlatPunchResult.Angle property

FlatPunchResult.Application property

FlatPunchResult.Depth property

FlatPunchResult.Faces property

FlatPunchResult.FoldedAngle property

FlatPunchResult.FoldedPosition property

FlatPunchResult.HasDepth property

FlatPunchResult.InternalName property

FlatPunchResult.IsDirectionUp property

FlatPunchResult.IsPunchAfterStopNode property

FlatPunchResult.IsPunchSuppressed property

FlatPunchResult.Parent property

FlatPunchResult.Position property

FlatPunchResult.PunchId property

FlatPunchResult.SketchRepresentationEdges property

FlatPunchResult.Type property

FlatPunchResults

FlatPattern interface

FlatPunchResults interface

Application

Count

Item

Type

FlatPunchResults.Application property

FlatPunchResults.Count property

FlatPunchResults.Item method

FlatPunchResults.Type property

FlatStartType

CoilFeature interface

Flexible

ComponentOccurrence interface

SketchBlock interface

FlipBaseFace

FlatPattern interface

FlipDirection

TangentConstraint3D interface

FlipNormal

WorkPlane interface

FlipOption

iFeatureSketchPlaneInput interface

iFeatureVectorInput interface

iFeatureWorkPlaneInput interface

FlowConfiguration

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

FlowDirection

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

FlowValue

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

FlushConstraint interface

ConstraintLimits

Offset

FlushConstraint.ConstraintLimits property

FlushConstraint.Offset property

FlushConstraintProxy interface

ContainingOccurrence

NativeObject

FlushConstraintProxy.ContainingOccurrence property

FlushConstraintProxy.NativeObject property

FlushiMateDefinition interface

ConstraintLimits

Entity

Offset

FlushiMateDefinition.ConstraintLimits property

FlushiMateDefinition.Entity property

FlushiMateDefinition.Offset property

FlushiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

FlushiMateDefinitionProxy.ContainingOccurrence property

FlushiMateDefinitionProxy.IsConsumed property

FlushiMateDefinitionProxy.NativeObject property

FlushToFile

PropertySets interface

FoldDefinition interface

Application

BendAngle

BendLine

BendLocation

BendOptions

BendRadius

Copy

IsPositiveBendDirection

IsPositiveBendSide

IsUnfoldMethodOverridden

Parent

Type

UnfoldMethod

FoldDefinition.Application property

FoldDefinition.BendAngle property

FoldDefinition.BendLine property

FoldDefinition.BendLocation property

FoldDefinition.BendOptions property

FoldDefinition.BendRadius property

FoldDefinition.Copy method

FoldDefinition.IsPositiveBendDirection property

FoldDefinition.IsPositiveBendSide property

FoldDefinition.IsUnfoldMethodOverridden property

FoldDefinition.Parent property

FoldDefinition.Type property

FoldDefinition.UnfoldMethod property

FoldedAngle

FlatPunchResult interface

FoldedPosition

FlatPunchResult interface

FoldFeature interface

Definition

FoldFeature.Definition property

FoldFeatureProxy interface

FoldFeatures

SheetMetalFeatures interface

FoldFeatures interface

Add

Application

Count

CreateFoldDefinition

Item

Type

FoldFeatures.Add method

FoldFeatures.Application property

FoldFeatures.Count property

FoldFeatures.CreateFoldDefinition method

FoldFeatures.Item method

FoldFeatures.Type property

Font

TextGraphics interface

TextStyle interface

FontSize

TextGraphics interface

TextStyle interface

ForceTail

SurfaceTextureSymbol interface

FormattedBendNote

BendNote interface

FormattedChamferNote

ChamferNote interface

FormattedHeading

iAssemblyTableColumn interface

iFeatureTableColumn interface

iPartTableColumn interface

FormattedHoleThreadNote

HoleThreadNote interface

FormattedPunchNote

PunchNote interface

FormattedQuantityNote

HoleThreadNote interface

PunchNote interface

FormattedText

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

HoleTableCell interface

HoleTag interface

RevisionTableCell interface

TextBox interface

ForwardDirection

RotateRotateConstraint interface

RotateRotateiMateDefinition interface

RotateTranslateConstraint interface

RotateTranslateiMateDefinition interface

TranslateTranslateConstraint interface

FractionalTextScale

DimensionStyle interface

FrameRate

DriveConstraintSettingsObject interface

FreeMoveDefinition interface

Application

Parent

Transformation

Type

FreeMoveDefinition.Application property

FreeMoveDefinition.Parent property

FreeMoveDefinition.Transformation property

FreeMoveDefinition.Type property

FrequentlyUsedPaths

DesignProject interface

FromEntity

FromToWidthExtent interface

FromFace

FromToExtent interface

FromToExtent interface

Direction

ExtendFromFace

ExtendToFace

FromFace

MinimumSolution

ToFace

FromToExtent.Direction property

FromToExtent.ExtendFromFace property

FromToExtent.ExtendToFace property

FromToExtent.FromFace property

FromToExtent.MinimumSolution property

FromToExtent.ToFace property

FromToExtentsAdaptFeature

AssemblyOptions interface

FromToExtentsMatePlane

AssemblyOptions interface

FromToWidthExtent interface

Edge

FromEntity

ToEntity

FromToWidthExtent.Edge property

FromToWidthExtent.FromEntity property

FromToWidthExtent.ToEntity property

FrontDirection

GroundPlaneSettings interface

FrontFaces

Bend interface

FrontViewPlane

DrawingStandardStyle interface

FullDepth

ThreadFeature interface

FullDimensionLine

LinearGeneralDimension interface

FullDocumentName

ApprenticeServerDocument interface

Document interface

DocumentDescriptor interface

FullFileName

ApprenticeServerDocument interface

DesignProject interface

Document interface

File interface

FileDescriptor interface

FileMetadata interface

ReferencedOLEFileDescriptor interface

FullPath

BrowserNode interface

FullRoundSet

FilletDefinition interface

FullSectionDepth

SectionDrawingView interface

FullSweepExtent interface

FullThreadDepth

ThreadInfo interface

FullTreeViewPath

ContentTreeViewNode interface

G

Gap

BreakOperation interface

DimensionStyle interface

DoubleHemDefinition interface

SingleHemDefinition interface

GapDistance

CentermarkStyle interface

GapSide

PointToPointRipTypeDef interface

SinglePointRipTypeDef interface

GapSize

PointToPointRipTypeDef interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

SinglePointRipTypeDef interface

GapWidth

CornerDefinition interface

GeneralDimension interface

ArrowheadsInside

FirstArrowheadInside

FirstArrowheadType

GeneralDimensionType

PromoteToSketch

Retrieved

RetrievedFrom

SecondArrowheadInside

SecondArrowheadType

ShowAllExtensionLines

Style

GeneralDimension.ArrowheadsInside property

GeneralDimension.FirstArrowheadInside property

GeneralDimension.FirstArrowheadType property

GeneralDimension.GeneralDimensionType property

GeneralDimension.PromoteToSketch method

GeneralDimension.Retrieved property

GeneralDimension.RetrievedFrom property

GeneralDimension.SecondArrowheadInside property

GeneralDimension.SecondArrowheadType property

GeneralDimension.ShowAllExtensionLines method

GeneralDimension.Style property

GeneralDimensions

DrawingDimensions interface

GeneralDimensions interface

AddAngular

AddDiameter

AddLinear

AddRadius

Application

Count

GetRetrievableDimensions

Item

Retrieve

Type

GeneralDimensions.AddAngular method

GeneralDimensions.AddDiameter method

GeneralDimensions.AddLinear method

GeneralDimensions.AddRadius method

GeneralDimensions.Application property

GeneralDimensions.Count property

GeneralDimensions.GetRetrievableDimensions method

GeneralDimensions.Item method

GeneralDimensions.Retrieve method

GeneralDimensions.Type property

GeneralDimensionsEnumerator interface

Count

Item

Type

GeneralDimensionsEnumerator.Count property

GeneralDimensionsEnumerator.Item method

GeneralDimensionsEnumerator.Type property

GeneralDimensionType

DrawingView interface

GeneralDimension interface

GeneralNote interface

Fitted

FittedTextHeight

FittedTextWidth

Height

Rotation

TextStyle

Width

GeneralNote.Fitted property

GeneralNote.FittedTextHeight property

GeneralNote.FittedTextWidth property

GeneralNote.Height property

GeneralNote.Rotation property

GeneralNote.TextStyle property

GeneralNote.Width property

GeneralNoteLayer

ObjectDefaultsStyle interface

GeneralNotes

DrawingNotes interface

GeneralNotes interface

AddByRectangle

AddFitted

Application

Count

Item

Type

GeneralNotes.AddByRectangle method

GeneralNotes.AddFitted method

GeneralNotes.Application property

GeneralNotes.Count property

GeneralNotes.Item method

GeneralNotes.Type property

GeneralNoteStyle

ObjectDefaultsStyle interface

GeneralOptions interface

AnnotationScale

Application

EnableLegacyProjectCreation

EnableOptimizedSelection

GripSnapOptions

iMateVisibility

LoadVBAOnStartup

SecondLevelTooltipDelay

SelectOtherDelay

ShowAutocompleteForCommandAlias

ShowCommandAliasInputDialog

ShowCommandPromptTooltips

ShowDocumentTabTooltips

ShowSecondLevelTooltips

ShowTooltips

ShowVideoToolClips

StartupActionType

StartupHelpFocusTopic

StartupNewFileTemplateName

StartupProjectFileName

TextAppearance

TextSize

ThreadTableQuery

ToleranceValue

TooltipDelay

Type

UndoFileSize

UpdatePropertiesOnSaveForFileType

UseNegativeIntegralForInertialProperties

UserName

GeneralOptions.AnnotationScale property

GeneralOptions.Application property

GeneralOptions.EnableLegacyProjectCreation property

GeneralOptions.EnableOptimizedSelection property

GeneralOptions.GripSnapOptions property

GeneralOptions.iMateVisibility property

GeneralOptions.LoadVBAOnStartup property

GeneralOptions.SecondLevelTooltipDelay property

GeneralOptions.SelectOtherDelay property

GeneralOptions.ShowAutocompleteForCommandAlias property

GeneralOptions.ShowCommandAliasInputDialog property

GeneralOptions.ShowCommandPromptTooltips property

GeneralOptions.ShowDocumentTabTooltips property

GeneralOptions.ShowSecondLevelTooltips property

GeneralOptions.ShowTooltips property

GeneralOptions.ShowVideoToolClips property

GeneralOptions.StartupActionType property

GeneralOptions.StartupHelpFocusTopic method

GeneralOptions.StartupNewFileTemplateName property

GeneralOptions.StartupProjectFileName property

GeneralOptions.TextAppearance property

GeneralOptions.TextSize property

GeneralOptions.ThreadTableQuery property

GeneralOptions.ToleranceValue property

GeneralOptions.TooltipDelay property

GeneralOptions.Type property

GeneralOptions.UndoFileSize property

GeneralOptions.UpdatePropertiesOnSaveForFileType property

GeneralOptions.UseNegativeIntegralForInertialProperties property

GeneralOptions.UserName property

GeneralPreferences interface

DeferUpdate

MultiUserExternallyManaged

MultiUserMode

TemplateDir

GeneralPreferences.DeferUpdate property

GeneralPreferences.MultiUserExternallyManaged property

GeneralPreferences.MultiUserMode property

GeneralPreferences.TemplateDir property

GenericObject interface

Type

GenericObject.Type property

GeometricCharacteristic

FeatureControlFrameRow interface

GeometricConstraint interface

Application

AttributeSets

Deletable

Delete

GetReferenceKey

Parent

Type

GeometricConstraint.Application property

GeometricConstraint.AttributeSets property

GeometricConstraint.Deletable property

GeometricConstraint.Delete method

GeometricConstraint.GetReferenceKey method

GeometricConstraint.Parent property

GeometricConstraint.Type property

GeometricConstraint3D interface

Application

AttributeSets

Deletable

Delete

GetReferenceKey

Parent

Type

GeometricConstraint3D.Application property

GeometricConstraint3D.AttributeSets property

GeometricConstraint3D.Deletable property

GeometricConstraint3D.Delete method

GeometricConstraint3D.GetReferenceKey method

GeometricConstraint3D.Parent property

GeometricConstraint3D.Type property

GeometricConstraints

Sketch interface

GeometricConstraints interface

AddCoincident

AddCollinear

AddConcentric

AddEqualLength

AddEqualRadius

AddGround

AddHorizontal

AddHorizontalAlign

AddMidpoint

AddParallel

AddPerpendicular

AddSmooth

AddSymmetry

AddTangent

AddVertical

AddVerticalAlign

Application

Count

Item

Type

GeometricConstraints.AddCoincident method

GeometricConstraints.AddCollinear method

GeometricConstraints.AddConcentric method

GeometricConstraints.AddEqualLength method

GeometricConstraints.AddEqualRadius method

GeometricConstraints.AddGround method

GeometricConstraints.AddHorizontal method

GeometricConstraints.AddHorizontalAlign method

GeometricConstraints.AddMidpoint method

GeometricConstraints.AddParallel method

GeometricConstraints.AddPerpendicular method

GeometricConstraints.AddSmooth method

GeometricConstraints.AddSymmetry method

GeometricConstraints.AddTangent method

GeometricConstraints.AddVertical method

GeometricConstraints.AddVerticalAlign method

GeometricConstraints.Application property

GeometricConstraints.Count property

GeometricConstraints.Item method

GeometricConstraints.Type property

GeometricConstraints3D

Sketch3D interface

GeometricConstraints3D interface

AddCoincident

AddCollinear

AddCustom

AddGround

AddMidpoint

AddParallel

AddPerpendicular

AddSmooth

AddTangent

Application

Count

Item

Type

GeometricConstraints3D.AddCoincident method

GeometricConstraints3D.AddCollinear method

GeometricConstraints3D.AddCustom method

GeometricConstraints3D.AddGround method

GeometricConstraints3D.AddMidpoint method

GeometricConstraints3D.AddParallel method

GeometricConstraints3D.AddPerpendicular method

GeometricConstraints3D.AddSmooth method

GeometricConstraints3D.AddTangent method

GeometricConstraints3D.Application property

GeometricConstraints3D.Count property

GeometricConstraints3D.Item method

GeometricConstraints3D.Type property

GeometricConstraintsBreakage

PartOptions interface

Geometry

BIMConnectorDefinition interface

Centerline interface

Edge interface

EdgeUse interface

Face interface

GeometryIntent interface

SketchArc interface

SketchArc3D interface

SketchCircle interface

SketchCircle3D interface

SketchEllipse interface

SketchEllipse3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

SketchFixedSpline interface

SketchFixedSpline3D interface

SketchLine interface

SketchLine3D interface

SketchOffsetSpline interface

SketchPoint interface

SketchPoint3D interface

SketchSpline interface

SketchSpline3D interface

TrailSegment interface

GeometryForm

Edge interface

EdgeUse interface

Face interface

SurfaceBody interface

GeometryIntent interface

Application

Geometry

Intent

IntentType

Parent

PointOnSheet

Type

GeometryIntent.Application property

GeometryIntent.Geometry property

GeometryIntent.Intent property

GeometryIntent.IntentType property

GeometryIntent.Parent property

GeometryIntent.PointOnSheet property

GeometryIntent.Type property

GeometryOne

AssemblyConstraint interface

GeometryTwo

AssemblyConstraint interface

GeometryType

Centerline interface

Edge interface

GetAccessOption

ContentCenterOptions interface

GetAlignment

FlatPattern interface

GetAmbientColor

RenderStyle interface

GetAngle

MeasureTools interface

GetAppFrameExtents

Application interface

GetArcData

Arc2d interface

Arc3d interface

GetASMAttributes

SurfaceBody interface

GetAutoCADBlockDefinitions

FileManager interface

GetAutomatedCenterlineSettings

DrawingSketch interface

DrawingView interface

GetAvailableClasses

ThreadTableQuery interface

GetAvailableDesignations

ThreadTableQuery interface

GetAvailableThreadSizes

ThreadTableQuery interface

GetAvailableThreadTypes

ThreadTableQuery interface

GetBalloonType

Balloon interface

GetBaseQuantity

BOMQuantity interface

GetBendOrder

FlatBendResult interface

GetBIMComponent

BIMExchangeServer interface

GetBisectorEntities

Centerline interface

GetBoundaryCondition

BoundaryPatchLoop interface

GetBoxData

Box interface

Box2d interface

GetBrowserNodeFromObject

BrowserPaneObject interface

GetBSplineData

BSplineCurve interface

BSplineCurve2d interface

BSplineSurface interface

GetBSplineInfo

BSplineCurve interface

BSplineCurve2d interface

BSplineSurface interface

GetByThreePoints

UserCoordinateSystemDefinition interface

GetCellValue

ContentTableRow interface

GetCircleData

Circle interface

Circle2d interface

GetClientBrowserNodeDefinition

BrowserPanes interface

GetClosestPointTo

Edge interface

Face interface

GetColor

Color interface

HighlightSet interface

TextBox interface

TextStyle interface

GetColors

GraphicsColorMapper interface

GraphicsColorSet interface

GetCommandPaths

UserInterfaceManager interface

GetConeData

Cone interface

GetContentObject

ContentCenter interface

GetCoordinates

GraphicsCoordinateSet interface

GraphicsTextureCoordinateSet interface

TextureCoordinateSet interface

GetCoordinateSystem

DerivedPartCoordinateSystemDef interface

Matrix interface

Matrix2d interface

GetCurrentEnvironment

EnvironmentManager interface

GetCursor

InteractionEventsObject interface

GetCurvature

Curve2dEvaluator interface

CurveEvaluator interface

GetCurvatures

SurfaceEvaluator interface

GetCustomData

ContentFamily interface

GetCustomImage

PointGraphics interface

GetCustomLineType

AutoCADBlock interface

ComponentGraphics interface

CurveGraphics interface

DimensionStyle interface

DrawingCurve interface

Layer interface

LeaderStyle interface

LineGraphics interface

LineStripGraphics interface

Sketch interface

SketchArc interface

SketchBlock interface

SketchCircle interface

SketchedSymbol interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

GetCustomLogicalFileName

FileDescriptor interface

GetCustomSection

DesignProject interface

GetCylinderData

Cylinder interface

GetData

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

CurveAndEntityWorkPointDef interface

FixedWorkAxisDef interface

FixedWorkPlaneDef interface

LineAndPlaneWorkAxisDef interface

LineAndPointWorkAxisDef interface

LineAndTangentWorkPlaneDef interface

LinePlaneAndAngleWorkPlaneDef interface

NormalToCurveWorkPlaneDef interface

NormalToSurfaceWorkAxisDef interface

PlaneAndOffsetWorkPlaneDef interface

PlaneAndPointWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

PointAndPlaneWorkAxisDef interface

PointAndTangentWorkPlaneDef interface

ThreePlanesWorkPointDef interface

ThreePointsWorkPlaneDef interface

TwoLinesWorkPlaneDef interface

TwoLinesWorkPointDef interface

TwoPlanesWorkAxisDef interface

TwoPlanesWorkPlaneDef interface

TwoPointsWorkAxisDef interface

GetDatabaseUnitsFromExpression

UnitsOfMeasure interface

GetDegreesOfFreedom

ComponentOccurrence interface

GetDepth

BreakOutOperation interface

GetDesignViewRepresentations

FileManager interface

GetDiffuseColor

RenderStyle interface

GetDimensionPlane

DimensionConstraints3D interface

GetDisplayMode

ComponentOccurrence interface

GetDrivingParameters

UnitsOfMeasure interface

GetDWGDocumentReferences

FileManager interface

GetEdgesOfType

FlatPattern interface

GetEllipseFullData

EllipseFull interface

EllipseFull2d interface

GetEllipticalArcData

EllipticalArc interface

EllipticalArc2d interface

GetEllipticalConeData

EllipticalCone interface

GetEllipticalCylinderData

EllipticalCylinder interface

GetEmissiveColor

RenderStyle interface

GetEndFillRenderStyle

WeldmentComponentDefinition interface

GetEndOfFeaturesPosition

AssemblyComponentDefinition interface

GetEndOfPartPosition

FlatPattern interface

PartComponentDefinition interface

GetEndPoints

Curve2dEvaluator interface

CurveEvaluator interface

GetEquation

UnfoldMethod interface

GetEvaluatedBaseQuantity

BOMQuantity interface

GetExistingFacets

Face interface

SurfaceBody interface

GetExistingFacetsAndTextureMap

Face interface

SurfaceBody interface

GetExistingFacetTolerances

Face interface

SurfaceBody interface

GetExistingStrokes

Edge interface

Face interface

SurfaceBody interface

GetExistingStrokeTolerances

Edge interface

Face interface

SurfaceBody interface

GetExpressionList

ExpressionList interface

GetExtents

Camera interface

GetFileNameFromIdentifier

FileManager interface

GetFilePropertyId

DrawingBOMColumn interface

PartsListColumn interface

RevisionTableColumn interface

GetFirstDerivatives

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

GetFlatPatternEntity

FlatPattern interface

GetFullDocumentName

FileManager interface

GetFullFileName

FileManager interface

GetHandle

SketchSpline interface

SketchSpline3D interface

GetHandleStatus

SketchSpline interface

SketchSpline3D interface

GetHolePatchingOptions

DerivedAssemblyDefinition interface

GetiComponentStringValue

LanguageTools interface

GetIdentifierFromFileName

FileManager interface

GetIncludedCustomSection

DesignProject interface

GetIncludeStatus

DrawingView interface

GetIncrement

DriveConstraintSettingsObject interface

GetIndices

GraphicsIndexSet interface

GetInputFormats

DataIO interface

GetInputs

iMateResult interface

GetInspectionDimensionData

DrawingDimension interface

GetLastActiveDesignViewRepresentation

FileManager interface

GetLastActiveLevelOfDetailRepresentation

FileManager interface

GetLengthAtParam

Curve2dEvaluator interface

CurveEvaluator interface

GetLevelOfDetailName

FileManager interface

GetLevelOfDetailRepresentations

FileManager interface

GetLineData

Line interface

Line2d interface

GetLineSegmentData

LineSegment interface

LineSegment2d interface

GetLocaleCorrectedExpression

UnitsOfMeasure interface

GetLocationFoundIn

ApprenticeServerDocument interface

Document interface

GetLoopLength

MeasureTools interface

GetMatrixData

Matrix interface

Matrix2d interface

GetMinimumDistance

MeasureTools interface

GetMissingAddInBehavior

Document interface

GetModelDimensions

DrawingOptions interface

GetNativeBrowserNodeDefinition

BrowserPanes interface

GetNormal

SurfaceEvaluator interface

GetNormals

GraphicsNormalSet interface

GetObject

SketchBlock interface

GetObjectFromScriptKey

ChangeManager interface

GetOutputFormats

DataIO interface

GetParamAnomaly

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

GetParamAtLength

Curve2dEvaluator interface

CurveEvaluator interface

GetParamAtPoint

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

GetParamExtents

Curve2dEvaluator interface

CurveEvaluator interface

GetPartNumberMergeSettings

BOM interface

GetPlaneData

Plane interface

GetPoint

Vertex interface

GetPointAtParam

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

GetPointData

Point interface

Point2d interface

GetPoints

Polyline2d interface

Polyline3d interface

GetPosition

MapPointCurve interface

WorkPlane interface

GetPositionalRepresentations

FileManager interface

GetPositionPoint

MapPointCurve interface

GetPreciseStringFromValue

UnitsOfMeasure interface

GetPrivateStorage

Document interface

GetPrivateStream

Document interface

GetProfileOrientationAtParam

SweepFeatures interface

GetPromptTags

AutoCADBlockDefinition interface

GetPromptTextValues

AutoCADBlock interface

GetPropertyMap

ContentTableColumn interface

GetRadialMarkingMenu

Environment interface

GetReferenceKey

AssemblyConstraint interface

AttributeSet interface

AutoCADBlock interface

AutoCADBlockDefinition interface

Balloon interface

BaselineDimensionSet interface

BIMConnector interface

BIMConnectorLink interface

BOMRow interface

BorderDefinition interface

BreakOperation interface

BreakOutOperation interface

Centerline interface

Centermark interface

ChainDimensionSet interface

ClientBrowserNodeDefinitionObject interface

ComponentOccurrence interface

CustomTable interface

DerivedParameterTable interface

DesignViewRepresentation interface

DimensionConstraint interface

DimensionConstraint3D interface

DraftAnalysis interface

DrawingDimension interface

DrawingNote interface

DrawingView interface

Edge interface

EdgeLoop interface

EdgeUse interface

Face interface

FaceShell interface

FeatureControlFrame interface

FeatureDimension interface

FeaturePatternElement interface

GeometricConstraint interface

GeometricConstraint3D interface

HoleTable interface

iAssemblyTableRow interface

iMateDefinition interface

iMateResult interface

iPartTableRow interface

LayoutConstraint interface

Leader interface

LeaderNode interface

LevelOfDetailRepresentation interface

LightingStyle interface

Material interface

OccurrencePattern interface

OrdinateDimensionSet interface

Parameter interface

ParameterTable interface

PartFeature interface

PartsList interface

Path interface

PathEntity interface

PositionalRepresentation interface

Profile interface

Profile3D interface

ProfileEntity interface

ProfileEntity3D interface

ProfilePath interface

ProfilePath3D interface

ProjectedCut interface

ReferenceComponent interface

ReferencedOLEFileDescriptor interface

RenderStyle interface

RevisionTable interface

Sheet interface

SheetFormat interface

SilhouetteCurve interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchEntity interface

SketchEntity3D interface

SketchFillRegion interface

SketchImage interface

Style interface

SurfaceBody interface

SurfaceTextureSymbol interface

TextBox interface

TitleBlockDefinition interface

UserCoordinateSystem interface

Vertex interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

WorkSurface interface

GetRemoveBySizeOptions

DerivedAssemblyDefinition interface

GetRemoveByVisibilityOptions

DerivedAssemblyDefinition interface

GetRenderStyle

ComponentOccurrence interface

Face interface

PartFeature interface

PresentationExplodedView interface

SurfaceBody interface

GetResultText

Border interface

SketchedSymbol interface

TitleBlock interface

GetRetrievableDimensions

GeneralDimensions interface

GetScale

DerivedPartCoordinateSystemDef interface

GetScriptKeyFromObject

ChangeManager interface

GetSecondDerivatives

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

GetSectionTwists

PathAndSectionTwistsSweepDef interface

GetSelectedObject

AssemblyDocument interface

PartDocument interface

GetSheetRange

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

GetSize

GroundPlaneSettings interface

WorkAxis interface

WorkPlane interface

GetSourceEdge

Edge interface

GetSourceFace

Face interface

GetSourceVertex

Vertex interface

GetSpecularColor

RenderStyle interface

GetSphereData

Sphere interface

GetStringFromType

UnitsOfMeasure interface

GetStringFromValue

UnitsOfMeasure interface

GetStripLengths

LineStripGraphics interface

TriangleFanGraphics interface

TriangleStripGraphics interface

GetStyleNameFromKey

StylesManager interface

GetSubsetExtents

ClientView interface

GetSuppressionCondition

PartFeature interface

GetTangent

Curve2dEvaluator interface

CurveEvaluator interface

GetTangents

SurfaceEvaluator interface

GetTemplateFile

FileManager interface

GetTextColor

TextGraphics interface

GetTextureCoordinateSet

TextureMap interface

GetTextureScale

Face interface

GetThicknessPlane

RibDefinition interface

GetThirdDerivatives

Curve2dEvaluator interface

CurveEvaluator interface

SurfaceEvaluator interface

GetThreadTypeIdentifier

ThreadTableQuery interface

GetThreadTypeName

ThreadTableQuery interface

GetThumbnail

TranslatorAddIn interface

TranslatorAddInServer interface

GetTorsionProperties

RegionProperties interface

GetTorusData

Torus interface

GetTransform

PresentationExplodedView interface

GetTransformation

DerivedPartTransformDef interface

GetTransformBehavior

ComponentGraphics interface

CurveGraphics interface

LineGraphics interface

LineStripGraphics interface

SurfaceGraphics interface

TextGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

GetTruePath

SweepFeatures interface

GetTypeFromString

UnitsOfMeasure interface

GetUnitVectorData

UnitVector interface

UnitVector2d interface

GetValueFromExpression

Parameters interface

UnitsOfMeasure interface

GetValues

GraphicsColorMapper interface

GetVectorData

Vector interface

Vector2d interface

GetViewLabelDefaults

DrawingStandardStyle interface

GetViewSpaceAnchor

GraphicsPrimitive interface

GetVisibility

DrawingView interface

PresentationExplodedView interface

GetWeldmentState

DrawingView interface

GetWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

GetWidthExtentType

ContourFlangeDefinition interface

FlangeDefinition interface

GetWindowExtents

View interface

GetXMLData

ClientApplication interface

GlobalChangeProcess

ChangeProcessorObject interface

GlobalChangeProcessAborted

ChangeProcessorObject interface

GlobalLineScale

DrawingStandardStyle interface

GlobalTransform

TriadEventsObject interface

GoHome

View interface

GoToCheckPoint

TransactionManager interface

GoToEnd

DriveConstraintSettingsObject interface

GoToStart

DriveConstraintSettingsObject interface

GradientDisplay

DraftAnalysis interface

GraphicsColorMapper interface

Color

ColorCount

Delete

GetColors

GetValues

MappedColor

PutColors

PutValues

Type

Value

ValueCount

GraphicsColorMapper.Color method

GraphicsColorMapper.ColorCount property

GraphicsColorMapper.Delete method

GraphicsColorMapper.GetColors method

GraphicsColorMapper.GetValues method

GraphicsColorMapper.MappedColor method

GraphicsColorMapper.PutColors method

GraphicsColorMapper.PutValues method

GraphicsColorMapper.Type property

GraphicsColorMapper.Value method

GraphicsColorMapper.ValueCount property

GraphicsColorSet interface

Add

Color

GetColors

PutColors

GraphicsColorSet.Add method

GraphicsColorSet.Color method

GraphicsColorSet.GetColors method

GraphicsColorSet.PutColors method

GraphicsCoordinateSet interface

Add

Coordinate

GetCoordinates

PutCoordinates

GraphicsCoordinateSet.Add method

GraphicsCoordinateSet.Coordinate method

GraphicsCoordinateSet.GetCoordinates method

GraphicsCoordinateSet.PutCoordinates method

GraphicsDataSet interface

Count

Delete

Id

Remove

Type

GraphicsDataSet.Count property

GraphicsDataSet.Delete method

GraphicsDataSet.Id property

GraphicsDataSet.Remove method

GraphicsDataSet.Type property

GraphicsDataSets

InteractionGraphics interface

GraphicsDataSets interface

Application

ClientId

Count

CreateColorMapper

CreateColorSet

CreateCoordinateSet

CreateImageSet

CreateIndexSet

CreateNormalSet

CreateTextureCoordinateSet

Delete

Item

ItemById

NonTransacting

Parent

SaveWithDocument

Type

GraphicsDataSets.Application property

GraphicsDataSets.ClientId property

GraphicsDataSets.Count property

GraphicsDataSets.CreateColorMapper method

GraphicsDataSets.CreateColorSet method

GraphicsDataSets.CreateCoordinateSet method

GraphicsDataSets.CreateImageSet method

GraphicsDataSets.CreateIndexSet method

GraphicsDataSets.CreateNormalSet method

GraphicsDataSets.CreateTextureCoordinateSet method

GraphicsDataSets.Delete method

GraphicsDataSets.Item method

GraphicsDataSets.ItemById method

GraphicsDataSets.NonTransacting property

GraphicsDataSets.Parent property

GraphicsDataSets.SaveWithDocument property

GraphicsDataSets.Type property

GraphicsDataSetsCollection

ClientFeatureDefinition interface

Document interface

DrawingView interface

FlatPattern interface

Sheet interface

GraphicsDataSetsCollection interface

Add

Add2

AddNonTransacting

Application

Count

Item

Parent

Type

GraphicsDataSetsCollection.Add method

GraphicsDataSetsCollection.Add2 method

GraphicsDataSetsCollection.AddNonTransacting method

GraphicsDataSetsCollection.Application property

GraphicsDataSetsCollection.Count property

GraphicsDataSetsCollection.Item method

GraphicsDataSetsCollection.Parent property

GraphicsDataSetsCollection.Type property

GraphicsImageSet interface

Add

GraphicsImageSet.Add method

GraphicsIndexSet interface

Add

GetIndices

IndexValue

PutIndices

GraphicsIndexSet.Add method

GraphicsIndexSet.GetIndices method

GraphicsIndexSet.IndexValue method

GraphicsIndexSet.PutIndices method

GraphicsNode interface

AddComponentGraphics

AddCurveGraphics

AddLineGraphics

AddLineStripGraphics

AddPointGraphics

AddScalableTextGraphics

AddSurfaceGraphics

AddTextGraphics

AddTriangleFanGraphics

AddTriangleGraphics

AddTriangleStripGraphics

AllowSlicing

Application

ClearSlice

Copy

Count

Delete

DisplayName

ExcludedFromViewAll

Id

Item

Parent

RangeBox

RenderStyle

Selectable

SliceGraphics

Transformation

Type

Visible

VisibleInActiveEditObject

VisibleInViews

GraphicsNode.AddComponentGraphics method

GraphicsNode.AddCurveGraphics method

GraphicsNode.AddLineGraphics method

GraphicsNode.AddLineStripGraphics method

GraphicsNode.AddPointGraphics method

GraphicsNode.AddScalableTextGraphics method

GraphicsNode.AddSurfaceGraphics method

GraphicsNode.AddTextGraphics method

GraphicsNode.AddTriangleFanGraphics method

GraphicsNode.AddTriangleGraphics method

GraphicsNode.AddTriangleStripGraphics method

GraphicsNode.AllowSlicing property

GraphicsNode.Application property

GraphicsNode.ClearSlice method

GraphicsNode.Copy method

GraphicsNode.Count property

GraphicsNode.Delete method

GraphicsNode.DisplayName property

GraphicsNode.ExcludedFromViewAll property

GraphicsNode.Id property

GraphicsNode.Item method

GraphicsNode.Parent property

GraphicsNode.RangeBox property

GraphicsNode.RenderStyle property

GraphicsNode.Selectable property

GraphicsNode.SliceGraphics method

GraphicsNode.Transformation property

GraphicsNode.Type property

GraphicsNode.Visible property

GraphicsNode.VisibleInActiveEditObject property

GraphicsNode.VisibleInViews property

GraphicsNodeProxy interface

ContainingOccurrence

NativeObject

GraphicsNodeProxy.ContainingOccurrence property

GraphicsNodeProxy.NativeObject property

GraphicsNormalSet interface

Add

GetNormals

Normal

PutNormals

GraphicsNormalSet.Add method

GraphicsNormalSet.GetNormals method

GraphicsNormalSet.Normal method

GraphicsNormalSet.PutNormals method

GraphicsPreferences interface

GraphicsPrimitive interface

Anchored

Application

Delete

GetViewSpaceAnchor

Parent

RangeBox

RemoveViewSpaceAnchor

SetViewSpaceAnchor

Type

GraphicsPrimitive.Anchored property

GraphicsPrimitive.Application property

GraphicsPrimitive.Delete method

GraphicsPrimitive.GetViewSpaceAnchor method

GraphicsPrimitive.Parent method

GraphicsPrimitive.RangeBox property

GraphicsPrimitive.RemoveViewSpaceAnchor method

GraphicsPrimitive.SetViewSpaceAnchor method

GraphicsPrimitive.Type property

GraphicsSettingType

HardwareOptions interface

GraphicsTextureCoordinateSet interface

Add

Coordinate

GetCoordinates

PutCoordinates

TextureDimension

GraphicsTextureCoordinateSet.Add method

GraphicsTextureCoordinateSet.Coordinate method

GraphicsTextureCoordinateSet.GetCoordinates method

GraphicsTextureCoordinateSet.PutCoordinates method

GraphicsTextureCoordinateSet.TextureDimension property

Green

Color interface

GrillFeature interface

GrillFeatureProxy interface

ContainingOccurrence

NativeObject

GrillFeatureProxy.ContainingOccurrence property

GrillFeatureProxy.NativeObject property

GrillFeatures

PartFeatures interface

GrillFeatures interface

Application

Count

Item

Type

GrillFeatures.Application property

GrillFeatures.Count property

GrillFeatures.Item method

GrillFeatures.Type property

GripSnapOptions

GeneralOptions interface

GripSnapOptions interface

Application

DisplayObjectInOriginalLocation

SelectGroundedComponentsAndWorkGeometry

ShowDegreesOfFreedom

Type

UseFreeDrag

UseTemporaryConstraints

GripSnapOptions.Application property

GripSnapOptions.DisplayObjectInOriginalLocation property

GripSnapOptions.SelectGroundedComponentsAndWorkGeometry property

GripSnapOptions.ShowDegreesOfFreedom property

GripSnapOptions.Type property

GripSnapOptions.UseFreeDrag property

GripSnapOptions.UseTemporaryConstraints property

GroundConstraint interface

Entity

GroundConstraint.Entity property

GroundConstraint3D interface

Entity

GroundConstraint3D.Entity property

GroundConstraint3DProxy interface

ContainingOccurrence

NativeObject

GroundConstraint3DProxy.ContainingOccurrence property

GroundConstraint3DProxy.NativeObject property

GroundConstraintProxy interface

ContainingOccurrence

NativeObject

GroundConstraintProxy.ContainingOccurrence property

GroundConstraintProxy.NativeObject property

Grounded

ComponentOccurrence interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

GroundedDisabledIcon

ClientNodeResource interface

GroundedIcon

ClientNodeResource interface

GroundedInvisibleIcon

ClientNodeResource interface

GroundedSuppressedIcon

ClientNodeResource interface

GroundPlaneSettings

DisplaySettings interface

GroundPlaneSettings interface

Application

AutoResize

Color

DisplayGridLines

FrontDirection

GetSize

HeightOffset

MinorGridLineSpacing

MinorLinesPerMajorGridLine

Opacity

Plane

Position

ReflectionBlur

ReflectionBlurFalloff

Reflectivity

SetSize

Type

UpDirection

GroundPlaneSettings.Application property

GroundPlaneSettings.AutoResize property

GroundPlaneSettings.Color property

GroundPlaneSettings.DisplayGridLines property

GroundPlaneSettings.FrontDirection property

GroundPlaneSettings.GetSize method

GroundPlaneSettings.HeightOffset property

GroundPlaneSettings.MinorGridLineSpacing property

GroundPlaneSettings.MinorLinesPerMajorGridLine property

GroundPlaneSettings.Opacity property

GroundPlaneSettings.Plane property

GroundPlaneSettings.Position property

GroundPlaneSettings.ReflectionBlur property

GroundPlaneSettings.ReflectionBlurFalloff property

GroundPlaneSettings.Reflectivity property

GroundPlaneSettings.SetSize method

GroundPlaneSettings.Type property

GroundPlaneSettings.UpDirection property

GroundShadow

ClientView interface

GroupBegins

CommandBarControl interface

GroupDiagnostics

ObjectVisibility interface

GroupHoleTypes

HoleTable interface

HoleTableStyle interface

GroupSolids

ObjectVisibility interface

GroupSurfaces

ObjectVisibility interface

GroupWires

ObjectVisibility interface

GuideRail

PathAndGuideRailSweepDef interface

GuideSurface

PathAndGuideSurfaceSweepDef interface

H

HalfAngle

Cone interface

EllipticalCone interface

HardwareOptions

Application interface

ApprenticeServer interface

HardwareOptions interface

Application

Diagnostics

GraphicsSettingType

Type

UseSoftwareGraphics

HardwareOptions.Application property

HardwareOptions.Diagnostics property

HardwareOptions.GraphicsSettingType property

HardwareOptions.Type property

HardwareOptions.UseSoftwareGraphics property

HasBodyOverride

ComponentOccurrence interface

HasConditions

LoftRail interface

HasCustomData

ContentFamily interface

HasDepth

FlatPunchResult interface

HasDrawingViews

SheetFormat interface

HasErrors

ErrorManager interface

MessageSection interface

HasFlatPattern

SheetMetalComponentDefinition interface

HasFormula

iAssemblyTableCell interface

iFeatureTableCell interface

iPartTableCell interface

HasInterest

DocumentInterests interface

HasMotor

BIMElectricalConnectorDefinition interface

HasMRUBehavior

MiniToolbarDropdownObject interface

HasMultipleSolidBodies

PartComponentDefinition interface

HasOpenOptions

TranslatorAddIn interface

TranslatorAddInServer interface

HasOriginIndicator

DrawingView interface

HasParentTransaction

Transaction interface

HasPrivateStorage

Document interface

HasPrivateStream

Document interface

HasPropertyMap

ContentTableColumn interface

HasReferenceComponent

DerivedParameterTable interface

Face interface

iMateDefinition interface

PlanarSketch interface

Sketch3D interface

SketchBlock interface

SketchEntity interface

SketchEntity3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

HasRootNode

Leader interface

HasSaveCopyAsOptions

TranslatorAddIn interface

TranslatorAddInServer interface

HasWarnings

ErrorManager interface

MessageSection interface

Heading

iAssemblyTableColumn interface

iFeatureTableColumn interface

iPartTableColumn interface

HeadingGap

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

HeadingPlacement

CustomTable interface

HoleTable interface

HoleTableStyle interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

HeadsUpDisplayOptions

SketchOptions interface

HeadsUpDisplayOptions interface

Application

CreateDimensionsOnValueInput

DimensionInputEnabled

DimensionInputInCartesianCoordinates

Enabled

Parent

PointerInputEnabled

PointerInputInCartesianCoordinates

Type

HeadsUpDisplayOptions.Application property

HeadsUpDisplayOptions.CreateDimensionsOnValueInput property

HeadsUpDisplayOptions.DimensionInputEnabled property

HeadsUpDisplayOptions.DimensionInputInCartesianCoordinates property

HeadsUpDisplayOptions.Enabled property

HeadsUpDisplayOptions.Parent property

HeadsUpDisplayOptions.PointerInputEnabled property

HeadsUpDisplayOptions.PointerInputInCartesianCoordinates property

HeadsUpDisplayOptions.Type property

HealthStatus

ApprenticeServerDocument interface

AssemblyConstraint interface

iAssemblyMember interface

LayoutConstraint interface

OccurrencePattern interface

Parameter interface

PartFeature interface

PlanarSketch interface

ReferenceComponent interface

Sketch3D interface

UserCoordinateSystem interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

Height

Application interface

BIMCableTrayConnectorDefinition interface

BIMDuctConnectorDefinition interface

DockableWindow interface

DrawingView interface

GeneralNote interface

HoleTableRow interface

PartsListRow interface

PitchAndHeightCoilExtent interface

RevisionTableRow interface

RevolutionAndHeightCoilExtent interface

Row interface

Sheet interface

SheetFormat interface

SketchImage interface

TextBox interface

View interface

HeightDatumType

DistanceHeightExtent interface

HeightExtent

FlangeDefinition interface

HeightExtentType

FlangeDefinition interface

HeightOffset

GroundPlaneSettings interface

HeightOverride

BIMCableTrayConnectorDefinition interface

BIMDuctConnectorDefinition interface

HelicalConstraint3D interface

HelicalConstraint3DProxy interface

ContainingOccurrence

NativeObject

HelicalConstraint3DProxy.ContainingOccurrence property

HelicalConstraint3DProxy.NativeObject property

HelpControls

UserInterfaceManager interface

HelpEvents

HelpManager interface

HelpEventsObject interface

Application

Type

HelpEventsObject.Application property

HelpEventsObject.Type property

HelpEventsSink interface

OnApplicationHelp

HelpEventsSink.OnApplicationHelp method

HelpManager

Application interface

HelpManager interface

DisplayHelpContext

DisplayHelpTopic

HelpEvents

HelpPath

Parent

Type

HelpManager.DisplayHelpContext method

HelpManager.DisplayHelpTopic method

HelpManager.HelpEvents property

HelpManager.HelpPath property

HelpManager.Parent property

HelpManager.Type property

HelpPath

HelpManager interface

HemDefinition interface

Application

BendOptions

Copy

Edges

HemType

HemTypeDefinition

IsOnEdgeSide

IsUnfoldMethodOverridden

Parent

SetCenteredWidthExtent

SetDoubleHemType

SetEdgeWidthExtent

SetFromToWidthExtent

SetOffsetWidthExtent

SetRolledHemType

SetSingleHemType

SetTeardropHemType

SetWidthOffsetWidthExtent

Type

UnfoldMethod

WidthExtent

WidthExtentType

HemDefinition.Application property

HemDefinition.BendOptions property

HemDefinition.Copy method

HemDefinition.Edges property

HemDefinition.HemType property

HemDefinition.HemTypeDefinition property

HemDefinition.IsOnEdgeSide property

HemDefinition.IsUnfoldMethodOverridden property

HemDefinition.Parent property

HemDefinition.SetCenteredWidthExtent method

HemDefinition.SetDoubleHemType method

HemDefinition.SetEdgeWidthExtent method

HemDefinition.SetFromToWidthExtent method

HemDefinition.SetOffsetWidthExtent method

HemDefinition.SetRolledHemType method

HemDefinition.SetSingleHemType method

HemDefinition.SetTeardropHemType method

HemDefinition.SetWidthOffsetWidthExtent method

HemDefinition.Type property

HemDefinition.UnfoldMethod property

HemDefinition.WidthExtent property

HemDefinition.WidthExtentType property

HemFeature interface

Definition

HemFeature.Definition property

HemFeatureProxy interface

HemFeatures

SheetMetalFeatures interface

HemFeatures interface

Add

Application

Count

CreateHemDefinition

Item

Type

HemFeatures.Add method

HemFeatures.Application property

HemFeatures.Count property

HemFeatures.CreateHemDefinition method

HemFeatures.Item method

HemFeatures.Type property

HemType

HemDefinition interface

HemTypeDefinition

HemDefinition interface

Hidden

ApplicationAddIn interface

HiddenLine

DrawingCurveSegment interface

HiddenLineDimmingPercent

DisplayOptions interface

DisplaySettings interface

HiddenParameters

ClientFeature interface

HideAll

DesignViewRepresentation interface

HideValue

BendNote interface

ChamferNote interface

DrawingDimension interface

PunchNote interface

HideZeroQuantityRows

PartsList interface

HighlightClientGraphicsWithFeature

ClientFeatureDefinition interface

HighlightColor

ColorScheme interface

HighlightColor2D

ColorScheme interface

HighlightInvalidAnnotations

DrawingSettings interface

HighlightSet interface

AddItem

Clear

Color

Count

Delete

GetColor

Item

Remove

SetColor

Type

HighlightSet.AddItem method

HighlightSet.Clear method

HighlightSet.Color property

HighlightSet.Count property

HighlightSet.Delete method

HighlightSet.GetColor method

HighlightSet.Item method

HighlightSet.Remove method

HighlightSet.SetColor method

HighlightSet.Type property

HighlightSets interface

Add

Count

Item

Type

HighlightSets.Add method

HighlightSets.Count property

HighlightSets.Item method

HighlightSets.Type property

HighlightWithFeature

ClientFeatureElement interface

HoleCenter

SketchPoint interface

SketchPoint3D interface

HoleCenterPoints

HoleFeature interface

SketchHolePlacementDefinition interface

HoleDiameter

HoleFeature interface

HoleFeature interface

AddParticipant

BottomTipAngle

CBoreDepth

CBoreDiameter

CSinkAngle

CSinkDiameter

EndFaces

Extent

ExtentType

FlatBottom

HoleCenterPoints

HoleDiameter

HoleType

PlacementDefinition

PlacementType

SetCBore

SetCSink

SetDistanceExtent

SetDrilled

SetSpotFace

SetThroughAllExtent

SetToFaceExtent

SideFaces

Sketch

SpotFaceDepth

SpotFaceDiameter

TapInfo

Tapped

HoleFeature.AddParticipant method

HoleFeature.BottomTipAngle property

HoleFeature.CBoreDepth property

HoleFeature.CBoreDiameter property

HoleFeature.CSinkAngle property

HoleFeature.CSinkDiameter property

HoleFeature.EndFaces property

HoleFeature.Extent property

HoleFeature.ExtentType property

HoleFeature.FlatBottom property

HoleFeature.HoleCenterPoints property

HoleFeature.HoleDiameter property

HoleFeature.HoleType property

HoleFeature.PlacementDefinition property

HoleFeature.PlacementType property

HoleFeature.SetCBore method

HoleFeature.SetCSink method

HoleFeature.SetDistanceExtent method

HoleFeature.SetDrilled method

HoleFeature.SetSpotFace method

HoleFeature.SetThroughAllExtent method

HoleFeature.SetToFaceExtent method

HoleFeature.SideFaces property

HoleFeature.Sketch property

HoleFeature.SpotFaceDepth property

HoleFeature.SpotFaceDiameter property

HoleFeature.TapInfo property

HoleFeature.Tapped property

HoleFeatureProxy interface

ContainingOccurrence

NativeObject

HoleFeatureProxy.ContainingOccurrence property

HoleFeatureProxy.NativeObject property

HoleFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

HoleFeatures interface

AddCBoreByDistanceExtent

AddCBoreByThroughAllExtent

AddCBoreByToFaceExtent

AddCSinkByDistanceExtent

AddCSinkByThroughAllExtent

AddCSinkByToFaceExtent

AddDrilledByDistanceExtent

AddDrilledByThroughAllExtent

AddDrilledByToFaceExtent

AddSpotFaceByDistanceExtent

AddSpotFaceByThroughAllExtent

AddSpotFaceByToFaceExtent

Application

Count

CreateConcentricPlacementDefinition

CreateLinearPlacementDefinition

CreatePointPlacementDefinition

CreateSketchPlacementDefinition

CreateTaperedTapInfo

CreateTapInfo

Item

Type

HoleFeatures.AddCBoreByDistanceExtent method

HoleFeatures.AddCBoreByThroughAllExtent method

HoleFeatures.AddCBoreByToFaceExtent method

HoleFeatures.AddCSinkByDistanceExtent method

HoleFeatures.AddCSinkByThroughAllExtent method

HoleFeatures.AddCSinkByToFaceExtent method

HoleFeatures.AddDrilledByDistanceExtent method

HoleFeatures.AddDrilledByThroughAllExtent method

HoleFeatures.AddDrilledByToFaceExtent method

HoleFeatures.AddSpotFaceByDistanceExtent method

HoleFeatures.AddSpotFaceByThroughAllExtent method

HoleFeatures.AddSpotFaceByToFaceExtent method

HoleFeatures.Application property

HoleFeatures.Count property

HoleFeatures.CreateConcentricPlacementDefinition method

HoleFeatures.CreateLinearPlacementDefinition method

HoleFeatures.CreatePointPlacementDefinition method

HoleFeatures.CreateSketchPlacementDefinition method

HoleFeatures.CreateTaperedTapInfo method

HoleFeatures.CreateTapInfo method

HoleFeatures.Item method

HoleFeatures.Type property

HoleNoteLayer

ObjectDefaultsStyle interface

HoleNoteStyle

ObjectDefaultsStyle interface

HolePatches

CoreCavityDefinition interface

HolePlacementDefinition interface

Application

Parent

Type

HolePlacementDefinition.Application property

HolePlacementDefinition.Parent property

HolePlacementDefinition.Type property

HoleTable interface

Application

ArrangeByPosition

AttributeSets

ColumnHeaderTextStyle

DataTextStyle

Delete

DeleteTagsOnRollup

Export

GetReferenceKey

GroupHoleTypes

HeadingPlacement

HoleTableColumns

HoleTableRows

HoleTableType

IncludeCentermarks

IncludeCircularCuts

IncludeCounterBoreHoleFeatures

IncludeCounterSinkHoleFeatures

IncludeDrilledHoleFeatures

IncludeHoleFeatures

IncludeRecoveredPunchCenters

IncludeThreadedHoleFeatures

Layer

MatchCustomHoles

Parent

ParentView

Position

PreserveTagging

RangeBox

ReformatOnCustomHoleMatch

RowMergeType

SecondaryTagModifierOnRollup

SequentialNumbering

ShowTags

Style

Title

TitleTextStyle

Type

HoleTable.Application property

HoleTable.ArrangeByPosition property

HoleTable.AttributeSets property

HoleTable.ColumnHeaderTextStyle property

HoleTable.DataTextStyle property

HoleTable.Delete method

HoleTable.DeleteTagsOnRollup property

HoleTable.Export method

HoleTable.GetReferenceKey method

HoleTable.GroupHoleTypes property

HoleTable.HeadingPlacement property

HoleTable.HoleTableColumns property

HoleTable.HoleTableRows property

HoleTable.HoleTableType property

HoleTable.IncludeCentermarks property

HoleTable.IncludeCircularCuts property

HoleTable.IncludeCounterBoreHoleFeatures property

HoleTable.IncludeCounterSinkHoleFeatures property

HoleTable.IncludeDrilledHoleFeatures property

HoleTable.IncludeHoleFeatures property

HoleTable.IncludeRecoveredPunchCenters property

HoleTable.IncludeThreadedHoleFeatures property

HoleTable.Layer property

HoleTable.MatchCustomHoles method

HoleTable.Parent property

HoleTable.ParentView property

HoleTable.Position property

HoleTable.PreserveTagging property

HoleTable.RangeBox property

HoleTable.ReformatOnCustomHoleMatch property

HoleTable.RowMergeType property

HoleTable.SecondaryTagModifierOnRollup property

HoleTable.SequentialNumbering property

HoleTable.ShowTags method

HoleTable.Style property

HoleTable.Title property

HoleTable.TitleTextStyle property

HoleTable.Type property

HoleTableCell interface

Application

FormattedText

Parent

StackedTextPosition

Text

Type

HoleTableCell.Application property

HoleTableCell.FormattedText property

HoleTableCell.Parent property

HoleTableCell.StackedTextPosition property

HoleTableCell.Text property

HoleTableCell.Type property

HoleTableColumn interface

Application

CustomPropertyName

Delete

Parent

PropertyType

Reposition

Title

Type

Width

HoleTableColumn.Application property

HoleTableColumn.CustomPropertyName property

HoleTableColumn.Delete method

HoleTableColumn.Parent property

HoleTableColumn.PropertyType property

HoleTableColumn.Reposition method

HoleTableColumn.Title property

HoleTableColumn.Type property

HoleTableColumn.Width property

HoleTableColumns

HoleTable interface

HoleTableColumns interface

Add

Application

Count

Item

Type

HoleTableColumns.Add method

HoleTableColumns.Application property

HoleTableColumns.Count property

HoleTableColumns.Item method

HoleTableColumns.Type property

HoleTableLayer

ObjectDefaultsStyle interface

HoleTableRow interface

Application

Count

Delete

Height

HoleTag

Item

Parent

ReferencedHole

Type

HoleTableRow.Application property

HoleTableRow.Count property

HoleTableRow.Delete method

HoleTableRow.Height property

HoleTableRow.HoleTag property

HoleTableRow.Item method

HoleTableRow.Parent property

HoleTableRow.ReferencedHole property

HoleTableRow.Type property

HoleTableRows

HoleTable interface

HoleTableRows interface

Add

Application

Count

Item

Type

HoleTableRows.Add method

HoleTableRows.Application property

HoleTableRows.Count property

HoleTableRows.Item method

HoleTableRows.Type property

HoleTables

Sheet interface

HoleTables interface

Add

AddByFeatureType

AddSelected

Application

Count

Item

Type

HoleTables.Add method

HoleTables.AddByFeatureType method

HoleTables.AddSelected method

HoleTables.Application property

HoleTables.Count property

HoleTables.Item method

HoleTables.Type property

HoleTableStyle

ObjectDefaultsStyle interface

HoleTableStyle interface

AddColumn

ArrangeByPosition

ColumnHeaderTextStyle

DataTextStyle

DeleteTagsOnRollup

GroupHoleTypes

HeadingPlacement

IncludeCentermarks

IncludeCircularCuts

IncludeCounterBoreHoleFeatures

IncludeCounterSinkHoleFeatures

IncludeDrilledHoleFeatures

IncludeHoleFeatures

IncludeRecoveredPunchCenters

IncludeThreadedHoleFeatures

InsideLineColor

InsideLineWeight

OutsideLineColor

OutsideLineWeight

PreserveTagging

ReformatOnCustomHoleMatch

RemoveAllColumns

RowMergeType

SecondaryTagModifierOnRollup

SequentialNumbering

Title

TitleTextStyle

UseLeaderForTags

HoleTableStyle.AddColumn method

HoleTableStyle.ArrangeByPosition property

HoleTableStyle.ColumnHeaderTextStyle property

HoleTableStyle.DataTextStyle property

HoleTableStyle.DeleteTagsOnRollup property

HoleTableStyle.GroupHoleTypes property

HoleTableStyle.HeadingPlacement property

HoleTableStyle.IncludeCentermarks property

HoleTableStyle.IncludeCircularCuts property

HoleTableStyle.IncludeCounterBoreHoleFeatures property

HoleTableStyle.IncludeCounterSinkHoleFeatures property

HoleTableStyle.IncludeDrilledHoleFeatures property

HoleTableStyle.IncludeHoleFeatures property

HoleTableStyle.IncludeRecoveredPunchCenters property

HoleTableStyle.IncludeThreadedHoleFeatures property

HoleTableStyle.InsideLineColor property

HoleTableStyle.InsideLineWeight property

HoleTableStyle.OutsideLineColor property

HoleTableStyle.OutsideLineWeight property

HoleTableStyle.PreserveTagging property

HoleTableStyle.ReformatOnCustomHoleMatch property

HoleTableStyle.RemoveAllColumns method

HoleTableStyle.RowMergeType property

HoleTableStyle.SecondaryTagModifierOnRollup property

HoleTableStyle.SequentialNumbering property

HoleTableStyle.Title property

HoleTableStyle.TitleTextStyle property

HoleTableStyle.UseLeaderForTags property

HoleTableStyles

DrawingStylesManager interface

HoleTableStylesEnumerator interface

Application

Count

Item

Type

HoleTableStylesEnumerator.Application property

HoleTableStylesEnumerator.Count property

HoleTableStylesEnumerator.Item method

HoleTableStylesEnumerator.Type property

HoleTableType

HoleTable interface

HoleTag

HoleTableRow interface

HoleTag interface

Application

DimensionStyle

FormattedText

Layer

Leader

Parent

Position

RangeBox

ShowLeader

StackedTextPosition

Text

Type

Visible

HoleTag.Application property

HoleTag.DimensionStyle property

HoleTag.FormattedText property

HoleTag.Layer property

HoleTag.Leader property

HoleTag.Parent property

HoleTag.Position property

HoleTag.RangeBox property

HoleTag.ShowLeader property

HoleTag.StackedTextPosition property

HoleTag.Text property

HoleTag.Type property

HoleTag.Visible property

HoleTagLayer

ObjectDefaultsStyle interface

HoleTagStyle

ObjectDefaultsStyle interface

HoleTapInfo interface

ThreadDepth

HoleTapInfo.ThreadDepth property

HoleThreadNote interface

Edge

FormattedHoleThreadNote

FormattedQuantityNote

IsHoleNote

QuantityDefinition

TapDrill

UseCustomThreadDesignation

UseDefaultFormat

UsePartUnits

HoleThreadNote.Edge property

HoleThreadNote.FormattedHoleThreadNote property

HoleThreadNote.FormattedQuantityNote property

HoleThreadNote.IsHoleNote property

HoleThreadNote.QuantityDefinition property

HoleThreadNote.TapDrill property

HoleThreadNote.UseCustomThreadDesignation property

HoleThreadNote.UseDefaultFormat property

HoleThreadNote.UsePartUnits property

HoleThreadNotes

DrawingNotes interface

HoleThreadNotes interface

Add

Application

Count

Item

Type

HoleThreadNotes.Add method

HoleThreadNotes.Application property

HoleThreadNotes.Count property

HoleThreadNotes.Item method

HoleThreadNotes.Type property

HoleTolerance

Tolerance interface

HoleType

HoleFeature interface

HorizontalAlignConstraint interface

PointOne

PointTwo

HorizontalAlignConstraint.PointOne property

HorizontalAlignConstraint.PointTwo property

HorizontalAlignConstraintProxy interface

ContainingOccurrence

NativeObject

HorizontalAlignConstraintProxy.ContainingOccurrence property

HorizontalAlignConstraintProxy.NativeObject property

HorizontalAlignment

TextGraphics interface

HorizontalConstraint interface

Entity

UseEllipseMajorAxis

HorizontalConstraint.Entity property

HorizontalConstraint.UseEllipseMajorAxis property

HorizontalConstraintProxy interface

ContainingOccurrence

NativeObject

HorizontalConstraintProxy.ContainingOccurrence property

HorizontalConstraintProxy.NativeObject property

HorizontalJustification

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

TextBox interface

TextStyle interface

HorizontalZoneCount

DefaultBorder interface

HorizontalZoneLabelMode

DefaultBorder interface

HWND

ClientView interface

DockableWindow interface

View interface

I

IAnimation interface

Name

IAnimation.Name property

IAnimationFavorites interface

Add

Count

Item

Remove

IAnimationFavorites.Add method

IAnimationFavorites.Count property

IAnimationFavorites.Item method

IAnimationFavorites.Remove method

IAnimationManager interface

ActiveAnimation

AnimationFavorites

Animations

IAnimationManager.ActiveAnimation property

IAnimationManager.AnimationFavorites property

IAnimationManager.Animations property

IAnimations interface

Add

Count

Item

IAnimations.Add method

IAnimations.Count property

IAnimations.Item method

iAssemblyFactory

AssemblyComponentDefinition interface

iAssemblyFactory interface

Application

CreateMember

DefaultRow

Delete

ExcelWorkSheet

FactoryOptions

FileNameColumn

MemberCacheDir

MemberEditScope

Parent

TableColumns

TableRows

Type

iAssemblyFactory.Application property

iAssemblyFactory.CreateMember method

iAssemblyFactory.DefaultRow property

iAssemblyFactory.Delete method

iAssemblyFactory.ExcelWorkSheet property

iAssemblyFactory.FactoryOptions property

iAssemblyFactory.FileNameColumn property

iAssemblyFactory.MemberCacheDir property

iAssemblyFactory.MemberEditScope property

iAssemblyFactory.Parent property

iAssemblyFactory.TableColumns property

iAssemblyFactory.TableRows property

iAssemblyFactory.Type property

iAssemblyMember

AssemblyComponentDefinition interface

iAssemblyMember interface

Application

BreakLinkToFactory

HealthStatus

Parent

ParentFactory

ReferencedDocumentDescriptor

Row

Type

iAssemblyMember.Application property

iAssemblyMember.BreakLinkToFactory method

iAssemblyMember.HealthStatus property

iAssemblyMember.Parent property

iAssemblyMember.ParentFactory property

iAssemblyMember.ReferencedDocumentDescriptor property

iAssemblyMember.Row property

iAssemblyMember.Type property

iAssemblyMemberName

BOMView interface

iAssemblyTableCell interface

Application

Column

HasFormula

IsValid

Parent

Row

Type

Value

iAssemblyTableCell.Application property

iAssemblyTableCell.Column property

iAssemblyTableCell.HasFormula property

iAssemblyTableCell.IsValid property

iAssemblyTableCell.Parent property

iAssemblyTableCell.Row property

iAssemblyTableCell.Type property

iAssemblyTableCell.Value property

iAssemblyTableColumn interface

Application

Count

Delete

DisplayHeading

FormattedHeading

Heading

Index

Item

Key

Parent

ReferencedDataType

ReferencedObject

Type

iAssemblyTableColumn.Application property

iAssemblyTableColumn.Count property

iAssemblyTableColumn.Delete method

iAssemblyTableColumn.DisplayHeading property

iAssemblyTableColumn.FormattedHeading property

iAssemblyTableColumn.Heading property

iAssemblyTableColumn.Index property

iAssemblyTableColumn.Item method

iAssemblyTableColumn.Key property

iAssemblyTableColumn.Parent property

iAssemblyTableColumn.ReferencedDataType property

iAssemblyTableColumn.ReferencedObject property

iAssemblyTableColumn.Type property

iAssemblyTableColumns interface

Application

Count

Item

Type

iAssemblyTableColumns.Application property

iAssemblyTableColumns.Count property

iAssemblyTableColumns.Item method

iAssemblyTableColumns.Type property

iAssemblyTableRow interface

Application

AttributeSets

Copy

Count

Delete

DocumentName

DocumentNameModifiable

GetReferenceKey

Index

IsDocumentNameBasedOnMemberName

IsExcluded

Item

MemberName

Parent

Type

iAssemblyTableRow.Application property

iAssemblyTableRow.AttributeSets property

iAssemblyTableRow.Copy method

iAssemblyTableRow.Count property

iAssemblyTableRow.Delete method

iAssemblyTableRow.DocumentName property

iAssemblyTableRow.DocumentNameModifiable property

iAssemblyTableRow.GetReferenceKey method

iAssemblyTableRow.Index property

iAssemblyTableRow.IsDocumentNameBasedOnMemberName property

iAssemblyTableRow.IsExcluded method

iAssemblyTableRow.Item method

iAssemblyTableRow.MemberName property

iAssemblyTableRow.Parent property

iAssemblyTableRow.Type property

iAssemblyTableRows interface

Application

Count

Item

Type

iAssemblyTableRows.Application property

iAssemblyTableRows.Count property

iAssemblyTableRows.Item method

iAssemblyTableRows.Type property

Icon

ClientBrowserNodeDefinitionObject interface

ClientNodeResource interface

ContentTreeViewNode interface

NativeBrowserNodeDefinitionObject interface

IconsColor

ColorSchemes interface

Id

CheckPoint interface

ClientBrowserNodeDefinitionObject interface

ClientNodeResource interface

GraphicsDataSet interface

GraphicsNode interface

Transaction interface

IDataObject

DataMedium interface

Identifier

iMateDefinition interface

IdentifyForDocumentOpen

Transaction interface

iFeature interface

iFeatureDefinition

iFeatureTemplateDescriptor

Sketches

iFeature.iFeatureDefinition property

iFeature.iFeatureTemplateDescriptor property

iFeature.Sketches property

iFeatureDefinition

iFeature interface

PunchToolFeature interface

iFeatureDefinition interface

ActiveTableRow

Application

iFeatureInputs

iFeatureTable

IsPunchTool

IsTableDriven

PunchId

Type

iFeatureDefinition.ActiveTableRow property

iFeatureDefinition.Application property

iFeatureDefinition.iFeatureInputs property

iFeatureDefinition.iFeatureTable property

iFeatureDefinition.IsPunchTool property

iFeatureDefinition.IsTableDriven property

iFeatureDefinition.PunchId property

iFeatureDefinition.Type property

iFeatureEntityInput interface

Entity

iFeatureEntityInput.Entity property

iFeatureInput interface

Application

EntityType

Name

Prompt

Type

iFeatureInput.Application property

iFeatureInput.EntityType property

iFeatureInput.Name property

iFeatureInput.Prompt property

iFeatureInput.Type property

iFeatureInputs

iFeatureDefinition interface

iFeatureInputs interface

Application

Count

Item

Type

iFeatureInputs.Application property

iFeatureInputs.Count property

iFeatureInputs.Item method

iFeatureInputs.Type property

iFeatureOptions interface

Application

RootPath

SheetMetalPunchesRootPath

Type

UseKey1AsBrowserNameColumn

UserRootPath

Viewer

ViewerArguments

iFeatureOptions.Application property

iFeatureOptions.RootPath property

iFeatureOptions.SheetMetalPunchesRootPath property

iFeatureOptions.Type property

iFeatureOptions.UseKey1AsBrowserNameColumn property

iFeatureOptions.UserRootPath property

iFeatureOptions.Viewer property

iFeatureOptions.ViewerArguments property

iFeatureParameterInput interface

DefaultExpression

Expression

IsPunchToolDepth

LimitListCount

LimitListExpressions

LimitRangeExpressions

LimitType

Parameter

Value

iFeatureParameterInput.DefaultExpression property

iFeatureParameterInput.Expression property

iFeatureParameterInput.IsPunchToolDepth property

iFeatureParameterInput.LimitListCount property

iFeatureParameterInput.LimitListExpressions method

iFeatureParameterInput.LimitRangeExpressions method

iFeatureParameterInput.LimitType property

iFeatureParameterInput.Parameter property

iFeatureParameterInput.Value property

iFeatureProxy interface

ContainingOccurrence

NativeObject

iFeatureProxy.ContainingOccurrence property

iFeatureProxy.NativeObject property

iFeatures

FlatPatternFeatures interface

PartFeatures interface

iFeatures interface

Add

Application

Count

CreateiFeatureDefinition

Item

Type

iFeatures.Add method

iFeatures.Application property

iFeatures.Count property

iFeatures.CreateiFeatureDefinition method

iFeatures.Item method

iFeatures.Type property

iFeatureSketchPlaneInput interface

FlipOption

PlaneInput

SetPosition

iFeatureSketchPlaneInput.FlipOption property

iFeatureSketchPlaneInput.PlaneInput property

iFeatureSketchPlaneInput.SetPosition method

iFeatureTable

iFeatureDefinition interface

iFeatureTable interface

Application

DefaultRow

Delete

ExcelWorkSheet

iFeatureTableColumns

iFeatureTableRows

Parent

Type

iFeatureTable.Application property

iFeatureTable.DefaultRow property

iFeatureTable.Delete method

iFeatureTable.ExcelWorkSheet property

iFeatureTable.iFeatureTableColumns property

iFeatureTable.iFeatureTableRows property

iFeatureTable.Parent property

iFeatureTable.Type property

iFeatureTableCell interface

Application

Column

CustomCell

CustomIncrement

CustomRangeMaximum

CustomRangeMinimum

HasFormula

IsValid

Parent

Row

Type

Value

iFeatureTableCell.Application property

iFeatureTableCell.Column property

iFeatureTableCell.CustomCell property

iFeatureTableCell.CustomIncrement property

iFeatureTableCell.CustomRangeMaximum property

iFeatureTableCell.CustomRangeMinimum property

iFeatureTableCell.HasFormula property

iFeatureTableCell.IsValid property

iFeatureTableCell.Parent property

iFeatureTableCell.Row property

iFeatureTableCell.Type property

iFeatureTableCell.Value property

iFeatureTableColumn interface

Application

Count

CustomColumn

CustomIncrement

CustomRangeMaximum

CustomRangeMinimum

Delete

DisplayHeading

FormattedHeading

Heading

Index

Item

Key

Parent

Type

iFeatureTableColumn.Application property

iFeatureTableColumn.Count property

iFeatureTableColumn.CustomColumn property

iFeatureTableColumn.CustomIncrement property

iFeatureTableColumn.CustomRangeMaximum property

iFeatureTableColumn.CustomRangeMinimum property

iFeatureTableColumn.Delete method

iFeatureTableColumn.DisplayHeading property

iFeatureTableColumn.FormattedHeading property

iFeatureTableColumn.Heading property

iFeatureTableColumn.Index property

iFeatureTableColumn.Item method

iFeatureTableColumn.Key property

iFeatureTableColumn.Parent property

iFeatureTableColumn.Type property

iFeatureTableColumns

iFeatureTable interface

iFeatureTableColumns interface

Application

Count

Item

Type

iFeatureTableColumns.Application property

iFeatureTableColumns.Count property

iFeatureTableColumns.Item method

iFeatureTableColumns.Type property

iFeatureTableRow interface

Application

Copy

Count

Delete

Index

Item

MemberName

Parent

Type

iFeatureTableRow.Application property

iFeatureTableRow.Copy method

iFeatureTableRow.Count property

iFeatureTableRow.Delete method

iFeatureTableRow.Index property

iFeatureTableRow.Item method

iFeatureTableRow.MemberName property

iFeatureTableRow.Parent property

iFeatureTableRow.Type property

iFeatureTableRows

iFeatureTable interface

iFeatureTableRows interface

Application

Count

Item

Type

iFeatureTableRows.Application property

iFeatureTableRows.Count property

iFeatureTableRows.Item method

iFeatureTableRows.Type property

iFeatureTemplateDescriptor

iFeature interface

PunchToolFeature interface

iFeatureTemplateDescriptor interface

Application

DelayReplaceAll

InternalName

LastKnownSourceFileName

Parent

Type

iFeatureTemplateDescriptor.Application property

iFeatureTemplateDescriptor.DelayReplaceAll method

iFeatureTemplateDescriptor.InternalName property

iFeatureTemplateDescriptor.LastKnownSourceFileName property

iFeatureTemplateDescriptor.Parent property

iFeatureTemplateDescriptor.Type property

iFeatureTemplateDescriptors

ReferenceComponents interface

iFeatureTemplateDescriptors interface

Application

Count

Item

Type

iFeatureTemplateDescriptors.Application property

iFeatureTemplateDescriptors.Count property

iFeatureTemplateDescriptors.Item method

iFeatureTemplateDescriptors.Type property

iFeatureVectorInput interface

FlipOption

LineInput

iFeatureVectorInput.FlipOption property

iFeatureVectorInput.LineInput property

iFeatureWorkPlaneInput interface

FlipOption

PlaneInput

iFeatureWorkPlaneInput.FlipOption property

iFeatureWorkPlaneInput.PlaneInput property

IgnoreProfileInnerLoops

SelectEventsObject interface

IInventorStudio interface

Activate

ActiveLightingStyle

ActiveSceneStyle

AnimationManager

RenderManager

StudioCameras

StudioLightingStyles

StudioSceneStyles

IInventorStudio.Activate method

IInventorStudio.ActiveLightingStyle property

IInventorStudio.ActiveSceneStyle property

IInventorStudio.AnimationManager property

IInventorStudio.RenderManager property

IInventorStudio.StudioCameras property

IInventorStudio.StudioLightingStyles property

IInventorStudio.StudioSceneStyles property

Image

DecalFeature interface

ProgressiveToolTip interface

SketchImage interface

TextureMap interface

ImageAlpha

SketchImage interface

ImageBasedLightingBrightness

LightingStyle interface

ImageBasedLightingRotation

LightingStyle interface

ImageBasedLightingScale

LightingStyle interface

ImageBasedLightingShowImage

LightingStyle interface

ImageBasedLightingSourceInternalName

LightingStyle interface

ImageBasedLightingSourceName

LightingStyle interface

ImageFullFileName

ColorScheme interface

ImageHeight

IRenderManager interface

ImageWidth

IRenderManager interface

iMateDefinition interface

Application

AttributeSets

Delete

Exported

GetReferenceKey

HasReferenceComponent

Identifier

MatchList

Name

ReferenceComponent

ReferencedEntity

SequenceIndex

Suppressed

Type

iMateDefinition.Application property

iMateDefinition.AttributeSets property

iMateDefinition.Delete method

iMateDefinition.Exported property

iMateDefinition.GetReferenceKey method

iMateDefinition.HasReferenceComponent property

iMateDefinition.Identifier property

iMateDefinition.MatchList property

iMateDefinition.Name property

iMateDefinition.ReferenceComponent property

iMateDefinition.ReferencedEntity property

iMateDefinition.SequenceIndex property

iMateDefinition.Suppressed property

iMateDefinition.Type property

iMateDefinitions

AssemblyComponentDefinition interface

ComponentOccurrence interface

DerivedPartComponent interface

DerivedPartDefinition interface

PartComponentDefinition interface

iMateDefinitions interface

AddAngleiMateDefinition

AddCompositeiMateDefinition

AddFlushiMateDefinition

AddInsertiMateDefinition

AddMateiMateDefinition

AddRotateRotateiMateDefinition

AddRotateTranslateiMateDefinition

AddTangentiMateDefinition

Application

Count

Item

Type

iMateDefinitions.AddAngleiMateDefinition method

iMateDefinitions.AddCompositeiMateDefinition method

iMateDefinitions.AddFlushiMateDefinition method

iMateDefinitions.AddInsertiMateDefinition method

iMateDefinitions.AddMateiMateDefinition method

iMateDefinitions.AddRotateRotateiMateDefinition method

iMateDefinitions.AddRotateTranslateiMateDefinition method

iMateDefinitions.AddTangentiMateDefinition method

iMateDefinitions.Application property

iMateDefinitions.Count property

iMateDefinitions.Item method

iMateDefinitions.Type property

iMateDefinitionsEnumerator interface

Count

Item

Type

iMateDefinitionsEnumerator.Count property

iMateDefinitionsEnumerator.Item method

iMateDefinitionsEnumerator.Type property

iMateResult

AssemblyConstraint interface

iMateResult interface

AttributeSets

Constraints

Delete

GetInputs

GetReferenceKey

IsComposite

Name

ParentComposite

Results

SetInputs

Suppressed

Type

iMateResult.AttributeSets property

iMateResult.Constraints property

iMateResult.Delete method

iMateResult.GetInputs method

iMateResult.GetReferenceKey method

iMateResult.IsComposite property

iMateResult.Name property

iMateResult.ParentComposite property

iMateResult.Results property

iMateResult.SetInputs method

iMateResult.Suppressed property

iMateResult.Type property

iMateResultProxy interface

ContainingOccurrence

NativeObject

iMateResultProxy.ContainingOccurrence property

iMateResultProxy.NativeObject property

iMateResults

AssemblyComponentDefinition interface

iMateResults interface

AddByiMateAndEntity

AddByTwoiMates

Application

Count

Item

Type

iMateResults.AddByiMateAndEntity method

iMateResults.AddByTwoiMates method

iMateResults.Application property

iMateResults.Count property

iMateResults.Item method

iMateResults.Type property

iMateResultsEnumerator interface

Count

Item

Type

iMateResultsEnumerator.Count property

iMateResultsEnumerator.Item method

iMateResultsEnumerator.Type property

iMateVisibility

GeneralOptions interface

Impact

LoftRail interface

ImportedComponentsFolderName

DesignProject interface

ImportedTopLevelAssembliesFolderName

DesignProject interface

InactiveComponentsEdgeColor

DisplayOptions interface

InactiveComponentsEdgeDisplay

DisplayOptions interface

InactiveComponentsShaded

DisplayOptions interface

InactiveComponentsShadeOpacity

DisplayOptions interface

Include

Sketch3D interface

IncludeAll

DerivedPartDefinition interface

IncludeAlliMateDefinitions

DerivedPartDefinition interface

IncludeAllParameters

DerivedPartDefinition interface

IncludeAllSketchBlockDefinitions

DerivedPartUniformScaleDef interface

IncludeAllSketches

DerivedAssemblyDefinition interface

DerivedPartUniformScaleDef interface

IncludeAllSketches3D

DerivedPartUniformScaleDef interface

IncludeAllSolids

DerivedPartDefinition interface

IncludeAllSurfaces

DerivedPartDefinition interface

IncludeAllTopLeveliMateDefinitions

DerivedAssemblyDefinition interface

IncludeAllTopLevelParameters

DerivedAssemblyDefinition interface

IncludeAllTopLevelSketches

DerivedAssemblyDefinition interface

IncludeAllTopLevelWorkFeatures

DerivedAssemblyDefinition interface

IncludeAllWorkFeatures

DerivedAssemblyDefinition interface

DerivedPartUniformScaleDef interface

IncludeCentermarks

HoleTable interface

HoleTableStyle interface

IncludeCircularCuts

HoleTable interface

HoleTableStyle interface

IncludeCoincidentSilhouettes

SilhouetteCurve interface

IncludeCosmeticWelds

MassProperties interface

IncludeCounterBoreHoleFeatures

HoleTable interface

HoleTableStyle interface

IncludeCounterSinkHoleFeatures

HoleTable interface

HoleTableStyle interface

IncludedProject

DesignProject interface

IncludeDrilledHoleFeatures

HoleTable interface

HoleTableStyle interface

IncludedZeroDisplay

DimensionStyle interface

IncludeEntity

DerivedPartEntity interface

IncludeHoleFeatures

HoleTable interface

HoleTableStyle interface

IncludeQuantityOverrides

MassProperties interface

IncludeRecoveredPunchCenters

HoleTable interface

HoleTableStyle interface

IncludeSlice

SectionDrawingView interface

IncludeTangentFaces

FilletConstantRadiusFaceSet interface

FilletFullRoundSet interface

IncludeThreadedHoleFeatures

HoleTable interface

HoleTableStyle interface

InclusionOption

DerivedAssemblyDefinition interface

DerivedAssemblyOccurrence interface

IncrementValue

ExpressionLimits interface

Independent

OccurrencePatternElement interface

IndependentSolidsOnFailedBoolean

DerivedAssemblyDefinition interface

Index

CommandBarControl interface

ContentTableRow interface

FeaturePatternElement interface

iAssemblyTableColumn interface

iAssemblyTableRow interface

iFeatureTableColumn interface

iFeatureTableRow interface

iPartTableColumn interface

iPartTableRow interface

MiniToolbarControl interface

MiniToolbarListItem interface

OccurrencePatternElement interface

SurfaceGraphicsEdge interface

SurfaceGraphicsFace interface

IndexValue

GraphicsIndexSet interface

InferenceType

PointInference interface

InferiMates

ExtrudeDefinition interface

InheritAll

CommandBarList interface

InheritAllRibbonTabs

Environment interface

InheritBreak

DrawingView interface

InheritBreakOut

DrawingView interface

InheritSection

DrawingView interface

InheritSlice

DrawingView interface

InitialDirectory

FileDialog interface

InitialDrawingViewHeight

ModelingSettings interface

InitialDrawingViewWidth

ModelingSettings interface

InnerRadius

FlatBendResult interface

InputFaces

DeleteFaceFeature interface

FaceDraftFeature interface

ShellDefinition interface

ThickenFeature interface

InputOne

BendPartFeature interface

InputSketches

RefoldFeature interface

UnfoldFeature interface

InputSurfaceBodies

NonParametricBaseFeature interface

InputTwo

BendPartFeature interface

Insert

NameValueMap interface

InsertChild

BrowserNode interface

InsertConstraint interface

AxesOpposed

ConstraintLimits

Distance

InsertConstraint.AxesOpposed property

InsertConstraint.ConstraintLimits property

InsertConstraint.Distance property

InsertConstraintProxy interface

ContainingOccurrence

NativeObject

InsertConstraintProxy.ContainingOccurrence property

InsertConstraintProxy.NativeObject property

InsertFitPoint

SketchSpline interface

SketchSpline3D interface

InsertiMateDefinition interface

AxesOpposed

ConstraintLimits

Distance

Entity

InsertiMateDefinition.AxesOpposed property

InsertiMateDefinition.ConstraintLimits property

InsertiMateDefinition.Distance property

InsertiMateDefinition.Entity property

InsertiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

InsertiMateDefinitionProxy.ContainingOccurrence property

InsertiMateDefinitionProxy.IsConsumed property

InsertiMateDefinitionProxy.NativeObject property

InsertInModelSpace

DrawingView interface

InsertionPoint

SketchBlockDefinition interface

SketchPoint interface

InsertMode

FileDialog interface

InsertNode

LeaderNode interface

Inserts

CoreCavityDefinition interface

InsideLineColor

HoleTableStyle interface

RevisionTableStyle interface

TableFormat interface

TableStyle interface

InsideLineWeight

HoleTableStyle interface

RevisionTableStyle interface

TableFormat interface

TableStyle interface

InsideTangency

TangentConstraint interface

TangentiMateDefinition interface

InstallPath

ApprenticeServer interface

Intensity

Light interface

Intent

DiameterGeneralDimension interface

GeometryIntent interface

OrdinateDimension interface

OriginIndicator interface

RadiusGeneralDimension interface

IntentOne

AngularGeneralDimension interface

LinearGeneralDimension interface

IntentThree

AngularGeneralDimension interface

IntentTwo

AngularGeneralDimension interface

LinearGeneralDimension interface

IntentType

GeometryIntent interface

InteractionDisabled

InteractionEventsObject interface

InteractionEvents coclass

InteractionEventsObject interface

AllowCommandAliases

Application

CreateMiniToolbar

GetCursor

InteractionDisabled

InteractionGraphics

KeyboardEvents

MeasureEvents

MouseEvents

Name

Parent

SelectEvents

SetCursor

Start

StatusBarText

Stop

TargetDocument

TriadEvents

Type

InteractionEventsObject.AllowCommandAliases property

InteractionEventsObject.Application property

InteractionEventsObject.CreateMiniToolbar method

InteractionEventsObject.GetCursor method

InteractionEventsObject.InteractionDisabled property

InteractionEventsObject.InteractionGraphics property

InteractionEventsObject.KeyboardEvents property

InteractionEventsObject.MeasureEvents property

InteractionEventsObject.MouseEvents property

InteractionEventsObject.Name property

InteractionEventsObject.Parent property

InteractionEventsObject.SelectEvents property

InteractionEventsObject.SetCursor method

InteractionEventsObject.Start method

InteractionEventsObject.StatusBarText property

InteractionEventsObject.Stop method

InteractionEventsObject.TargetDocument property

InteractionEventsObject.TriadEvents property

InteractionEventsObject.Type property

InteractionEventsSink interface

OnActivate

OnHelp

OnResume

OnSuspend

OnTerminate

InteractionEventsSink.OnActivate method

InteractionEventsSink.OnHelp method

InteractionEventsSink.OnResume method

InteractionEventsSink.OnSuspend method

InteractionEventsSink.OnTerminate method

InteractionGraphics

InteractionEventsObject interface

InteractionGraphics interface

GraphicsDataSets

OverlayClientGraphics

PreviewClientGraphics

Type

UpdateOverlayGraphics

InteractionGraphics.GraphicsDataSets property

InteractionGraphics.OverlayClientGraphics property

InteractionGraphics.PreviewClientGraphics property

InteractionGraphics.Type property

InteractionGraphics.UpdateOverlayGraphics method

InteractiveContactAnalysis

ModelingSettings interface

InteractiveContactSurfaces

ModelingSettings interface

InterestType

DocumentInterest interface

InterfaceStyle

ColorSchemes interface

UserInterfaceManager interface

InterferenceBody

InterferenceResult interface

InterferenceResult interface

Centroid

InterferenceBody

OccurrenceOne

OccurrenceTwo

Type

Volume

InterferenceResult.Centroid property

InterferenceResult.InterferenceBody property

InterferenceResult.OccurrenceOne property

InterferenceResult.OccurrenceTwo property

InterferenceResult.Type property

InterferenceResult.Volume property

InterferenceResults interface

Count

Item

Type

InterferenceResults.Count property

InterferenceResults.Item method

InterferenceResults.Type property

IntermediateRadiusCount

FilletVariableRadiusEdgeSet interface

IntermediateRadiusItem

FilletVariableRadiusEdgeSet interface

Internal

ThreadInfo interface

InternalName

ApprenticeServerDocument interface

BalloonTipObject interface

BIMComponentProperty interface

BIMComponentPropertySet interface

BrowserPaneObject interface

ChangeDefinitionObject interface

CommandBar interface

CommandBarControl interface

CommandCategory interface

CommandControl interface

ContentFamily interface

ContentTableColumn interface

ContentTableRow interface

ContentTreeViewNode interface

ControlDefinition interface

CustomParameterGroup interface

DockableWindow interface

Document interface

Environment interface

Face interface

File interface

FlatBendResult interface

FlatPunchResult interface

iFeatureTemplateDescriptor interface

LightingStyle interface

Material interface

MiniToolbarControl interface

MiniToolbarListItem interface

PropertySet interface

RenderStyle interface

Ribbon interface

RibbonPanel interface

RibbonTab interface

Style interface

InternalTitle

Column interface

InternationalStandardReference

DrawingStandardStyle interface

IntersectPreviewColor

ColorScheme interface

IntersectWithCurve

Line interface

Line2d interface

LineSegment interface

LineSegment2d interface

Plane interface

IntersectWithLine

Plane interface

IntersectWithPlane

Plane interface

IntersectWithSurface

Line interface

LineSegment interface

Plane interface

Interval

BalloonTipObject interface

Introduction

InUse

LightingStyle interface

Material interface

Parameter interface

RenderStyle interface

Style interface

InvalidFeatureBasedAnnotationsColor

DrawingSettings interface

Inventor library

Inventor.AccuracyEnum enumeration

Inventor.ActionTypeEnum enumeration

Inventor.AddInLicenseStatusEnum enumeration

Inventor.AddInLoadBehaviorEnum enumeration

Inventor.AlignmentTypeEnum enumeration

Inventor.AlternateUnitsDisplayTypeEnum enumeration

Inventor.AnalysisTypeEnum enumeration

Inventor.AngleConstraintSolutionTypeEnum enumeration

Inventor.AngularPrecisionEnum enumeration

Inventor.ApplicationAddInTypeEnum enumeration

Inventor.ApplicationFrameColorTypeEnum enumeration

Inventor.ArcDimensionTypeEnum enumeration

Inventor.ArrowheadTypeEnum enumeration

Inventor.BackgroundTypeEnum enumeration

Inventor.BalloonDirectionEnum enumeration

Inventor.BalloonTypeEnum enumeration

Inventor.BarControlTypeEnum enumeration

Inventor.BaseFeatureOutputTypeEnum enumeration

Inventor.BendAngleTypeEnum enumeration

Inventor.BendLocationEnum enumeration

Inventor.BendOrderSourceTypeEnum enumeration

Inventor.BendPartTypeEnum enumeration

Inventor.BendPositionEnum enumeration

Inventor.BendReliefShapeEnum enumeration

Inventor.BendTransitionEnum enumeration

Inventor.BIMCableTrayConnectionTypeEnum enumeration

Inventor.BIMConduitConnectionTypeEnum enumeration

Inventor.BIMConnectorDefinitionTypeEnum enumeration

Inventor.BIMConnectorShapeEnum enumeration

Inventor.BIMDuctConnectionTypeEnum enumeration

Inventor.BIMDuctFlowConfigurationEnum enumeration

Inventor.BIMDuctLossMethodEnum enumeration

Inventor.BIMDuctSystemTypeEnum enumeration

Inventor.BIMElectricalPowerFactorStateEnum enumeration

Inventor.BIMElectricalSystemTypeEnum enumeration

Inventor.BIMFlowDirectionEnum enumeration

Inventor.BIMPipeConnectionTypeEnum enumeration

Inventor.BIMPipeFlowConfigurationEnum enumeration

Inventor.BIMPipeLossMethodEnum enumeration

Inventor.BIMPipeSystemTypeEnum enumeration

Inventor.BOMQuantityTypeEnum enumeration

Inventor.BOMStructureEnum enumeration

Inventor.BOMViewTypeEnum enumeration

Inventor.BooleanTypeEnum enumeration

Inventor.BorderLabelModeEnum enumeration

Inventor.BoreLine structure

Inventor.BossTypeEnum enumeration

Inventor.BoundaryPatchConditionEnum enumeration

Inventor.BreakOrientationEnum enumeration

Inventor.BreakOutDepthTypeEnum enumeration

Inventor.BreakStyleEnum enumeration

Inventor.BrowserNodeDisplayStateEnum enumeration

Inventor.ButtonDisplayEnum enumeration

Inventor.ButtonTypeEnum enumeration

Inventor.CenterlineTypeEnum enumeration

Inventor.CentermarkTypeEnum enumeration

Inventor.ChamferDefinitionTypeEnum enumeration

Inventor.CircleDimensionTypeEnum enumeration

Inventor.ClientGraphicsTypeEnum enumeration

Inventor.ColorBindingEnum enumeration

Inventor.ColorSourceTypeEnum enumeration

Inventor.CommandBarTypeEnum enumeration

Inventor.CommandIDEnum enumeration

Inventor.CommandTypesEnum enumeration

Inventor.ComparisonTypeEnum enumeration

Inventor.ConstraintIncrementTypeEnum enumeration

Inventor.ConstraintPriorityEnum enumeration

Inventor.ConstraintStatusEnum enumeration

Inventor.ContainmentEnum enumeration

Inventor.ContentCenterAccessOptionEnum enumeration

Inventor.ContentCenterInstanceStatusEnum enumeration

Inventor.ContentCenterRSCResultEnum enumeration

Inventor.ContentFamilyTypeEnum enumeration

Inventor.ContentItemTypeEnum enumeration

Inventor.ContentLibraryComponentTypeBits enumeration

Inventor.ContentMemberRefreshEnum enumeration

Inventor.ContentUserRoleEnum enumeration

Inventor.ContinuityTypeEnum enumeration

Inventor.ControlDefinitionTypeEnum enumeration

Inventor.ControlTypeEnum enumeration

Inventor.CoordinateSystemPlaneEnum enumeration

Inventor.CornerDefinitionTypeEnum enumeration

Inventor.CornerReliefShapeEnum enumeration

Inventor.CornerTypeEnum enumeration

Inventor.CursorHotSpotEnum enumeration

Inventor.CursorTypeEnum enumeration

Inventor.Curve2dTypeEnum enumeration

Inventor.CurveGeometryFormEnum enumeration

Inventor.CurveTypeEnum enumeration

Inventor.CustomPropertyPrecisionEnum enumeration

Inventor.CustomPropertyTypeEnum enumeration

Inventor.DebugWatchType enumeration

Inventor.DecimalMarkerTypeEnum enumeration

Inventor.DefaultDrawingFileTypeEnum enumeration

Inventor.DefaultLayerStyleEnum enumeration

Inventor.DefaultNonInventorDWGFileOpenBehaviorEnum enumeration

Inventor.DefaultObjectStyleEnum enumeration

Inventor.DerivedComponentOptionEnum enumeration

Inventor.DerivedComponentStyleEnum enumeration

Inventor.DerivedGeometryRemovalEnum enumeration

Inventor.DerivedHolePatchEnum enumeration

Inventor.DerivedPartMirrorPlaneEnum enumeration

Inventor.DerivedPropertyTypeEnum enumeration

Inventor.DesignViewTypeEnum enumeration

Inventor.DialogStyleEnum enumeration

Inventor.DimensionAlignmentTypeEnum enumeration

Inventor.DimensionConstraintsRelaxationEnum enumeration

Inventor.DimensionDisplayTypeEnum enumeration

Inventor.DimensionOrientationEnum enumeration

Inventor.DimensionStyleFormatEnum enumeration

Inventor.DimensionTextAlignmentEnum enumeration

Inventor.DimensionTypeEnum enumeration

Inventor.DirectionEnum enumeration

Inventor.DisplayFormatEnum enumeration

Inventor.DisplayModeEnum enumeration

Inventor.DisplayModeSourceTypeEnum enumeration

Inventor.DisplayQualityEnum enumeration

Inventor.DisplayTransformBehaviorEnum enumeration

Inventor.DockingStateEnum enumeration

Inventor.DocumentInterestTypeEnum enumeration

Inventor.DocumentTypeEnum enumeration

Inventor.DoubleBendTypeEnum enumeration

Inventor.DraftingStandardEnum enumeration

Inventor.DragStateEnum enumeration

Inventor.DrawingEdgeTypeEnum enumeration

Inventor.DrawingSheetSizeEnum enumeration

Inventor.DrawingSheetStatusBits enumeration

Inventor.DrawingViewAlignmentEnum enumeration

Inventor.DrawingViewStyleEnum enumeration

Inventor.DrawingViewTypeEnum enumeration

Inventor.DWFPublishModeEnum enumeration

Inventor.DWGFileVersionEnum enumeration

Inventor.EdgeCollectionEnum enumeration

Inventor.EmbossTypeEnum enumeration

Inventor.EnvironmentStateEnum enumeration

Inventor.EventTimingEnum enumeration

Inventor.ExitTypeEnum enumeration

Inventor.FaceCollectionEnum enumeration

Inventor.FactoryOptionsMemberNameTypeEnum enumeration

Inventor.FactoryOptionsPartNumberTypeEnum enumeration

Inventor.FamilyParameterValueTypeEnum enumeration

Inventor.FeatureApproximationTypeEnum enumeration

Inventor.FeatureDimensionTypeEnum enumeration

Inventor.FileFormatEnum enumeration

Inventor.FileManagementEnum enumeration

Inventor.FileOwnershipEnum enumeration

Inventor.FileTypeEnum enumeration

Inventor.FileVersionEnum enumeration

Inventor.FilletTypeEnum enumeration

Inventor.FlatPatternEdgeTypeEnum enumeration

Inventor.FrontViewPlaneEnum enumeration

Inventor.GeneralDataTypeEnum enumeration

Inventor.GeneralDimensionTypeEnum enumeration

Inventor.GeometricCharacteristicEnum enumeration

Inventor.GeometricConstraintsBreakageEnum enumeration

Inventor.GeometryMoveableStatusEnum enumeration

Inventor.GraphicsDriverTypeEnum enumeration

Inventor.GraphicsLevelsOfDetailEnum enumeration

Inventor.GraphicsOptimizationEnum enumeration

Inventor.GraphicsSelectabilityEnum enumeration

Inventor.GraphicsSettingTypeEnum enumeration

Inventor.GraphicsVisibilityEnum enumeration

Inventor.GroundShadowEnum enumeration

Inventor.HandlingCodeEnum enumeration

Inventor.HeadingPlacementEnum enumeration

Inventor.HealthStatusEnum enumeration

Inventor.HeightDatumTypeEnum enumeration

Inventor.HemTypeEnum enumeration

Inventor.HoleNoteQuantityEnum enumeration

Inventor.HolePlacementTypeEnum enumeration

Inventor.HolePropertyEnum enumeration

Inventor.HoleTableTypeEnum enumeration

Inventor.HoleTypeEnum enumeration

Inventor.HorizontalTextAlignmentEnum enumeration

Inventor.iComponentColumnTypeEnum enumeration

Inventor.IconsColorTypeEnum enumeration

Inventor.iFeatureEntityInputTypeEnum enumeration

Inventor.iFeatureParamLimitTypeEnum enumeration

Inventor.InferredTypeEnum enumeration

Inventor.InspectionDimensionShapeEnum enumeration

Inventor.IntentTypeEnum enumeration

Inventor.InteractionEventsEnum enumeration

Inventor.InteractiveContactAnalysisEnum enumeration

Inventor.InteractiveContactSurfacesEnum enumeration

Inventor.InterfaceStyleEnum enumeration

Inventor.IOMechanismEnum enumeration

Inventor.LayDirectionTypeEnum enumeration

Inventor.LevelOfDetailEnum enumeration

Inventor.LightDefinitionTypeEnum enumeration

Inventor.LightTypeEnum enumeration

Inventor.LinearDimensionTypeEnum enumeration

Inventor.LinearPrecisionEnum enumeration

Inventor.LineDefinitionSpaceEnum enumeration

Inventor.LineSpacingEnum enumeration

Inventor.LineTypeEnum enumeration

Inventor.LineWeightTypeEnum enumeration

Inventor.LinkStatusEnum enumeration

Inventor.LocationTypeEnum enumeration

Inventor.LoftConditionEnum enumeration

Inventor.LoftedFlangeOutputTypeEnum enumeration

Inventor.LoftTypeEnum enumeration

Inventor.MassPropertiesAccuracyEnum enumeration

Inventor.MaterialRemovalModifierEnum enumeration

Inventor.MeasureTypeEnum enumeration

Inventor.MediumTypeEnum enumeration

Inventor.MemberEditScopeEnum enumeration

Inventor.MemberManagerErrorsEnum enumeration

Inventor.MemberTypeEnum enumeration

Inventor.MemorySavingModeEnum enumeration

Inventor.MiniToolbarControlTypeEnum enumeration

Inventor.ModelDiameterFromThreadEnum enumeration

Inventor.ModelValueTypeEnum enumeration

Inventor.MouseButtonEnum enumeration

Inventor.MouseDragStateEnum enumeration

Inventor.MoveFaceTypeEnum enumeration

Inventor.MultiUserModeEnum enumeration

Inventor.NormalBindingEnum enumeration

Inventor.NumberingSchemeEnum enumeration

Inventor.OccurrenceDOFStateEnum enumeration

Inventor.OfflineImageFidelityEnum enumeration

Inventor.OLEDocumentTypeEnum enumeration

Inventor.OLEVerbEnum enumeration

Inventor.OrbitTypeEnum enumeration

Inventor.OverConstrainedDimensionBehaviorEnum enumeration

Inventor.PageOrientationTypeEnum enumeration

Inventor.PaperSizeEnum enumeration

Inventor.ParameterDisplayFormatEnum enumeration

Inventor.ParameterTypeEnum enumeration

Inventor.PartFeatureExtentDirectionEnum enumeration

Inventor.PartFeatureExtentEnum enumeration

Inventor.PartFeatureOperationEnum enumeration

Inventor.PartsListFileFormatEnum enumeration

Inventor.PartsListLevelEnum enumeration

Inventor.PatternComputeTypeEnum enumeration

Inventor.PatternOrientationEnum enumeration

Inventor.PatternSpacingTypeEnum enumeration

Inventor.PhysicalPropertyEnum enumeration

Inventor.PointInferenceEnum enumeration

Inventor.PointIntentEnum enumeration

Inventor.PointRenderStyleEnum enumeration

Inventor.PrefixAndSuffixOrderEnum enumeration

Inventor.PrintColorModeEnum enumeration

Inventor.PrintOrientationEnum enumeration

Inventor.PrintRangeEnum enumeration

Inventor.PrintScaleModeEnum enumeration

Inventor.PrivateEventTypeEnum enumeration

Inventor.ProductEditionEnum enumeration

Inventor.ProjectionTypeEnum enumeration

Inventor.PromptMessageRestrictionsEnum enumeration

Inventor.PropertyTypeEnum enumeration

Inventor.PunchNoteQuantityEnum enumeration

Inventor.PunchRepresentationTypeEnum enumeration

Inventor.RayTracingQualityEnum enumeration

Inventor.ReferenceMonitoringEnum enumeration

Inventor.ReferenceStatusEnum enumeration

Inventor.RevisionTablePropertyEnum enumeration

Inventor.RevisionTagShapeEnum enumeration

Inventor.RibbonAppearanceEnum enumeration

Inventor.RibbonDockingStateEnum enumeration

Inventor.RibbonStateEnum enumeration

Inventor.RibFeatureExtentEnum enumeration

Inventor.RibThicknessPlaneEnum enumeration

Inventor.RigidBodyJointTypeEnum enumeration

Inventor.RipTypeEnum enumeration

Inventor.RowMergeTypeEnum enumeration

Inventor.SelectionDeviceEnum enumeration

Inventor.SelectionFilterEnum enumeration

Inventor.SelectionPriorityEnum enumeration

Inventor.SelectPrism structure

Inventor.SelectType enumeration

Inventor.ShadowDirectionEnum enumeration

Inventor.SheetMetalPropertyEnum enumeration

Inventor.ShellDirectionEnum enumeration

Inventor.ShiftStateEnum enumeration

Inventor.ShortcutTypeEnum enumeration

Inventor.SketchCreationOnNewPartEnum enumeration

Inventor.SolutionNatureEnum enumeration

Inventor.SplineFitMethodEnum enumeration

Inventor.SplitToolTypeEnum enumeration

Inventor.SplitTypeEnum enumeration

Inventor.StandardPartsSectionBehaviorEnum enumeration

Inventor.StartupActionTypeEnum enumeration

Inventor.StartupHelpFocusTopicEnum enumeration

Inventor.StorageTypeEnum enumeration

Inventor.StyleLocationEnum enumeration

Inventor.StylesLibraryAccessEnum enumeration

Inventor.StyleSourceTypeEnum enumeration

Inventor.StyleTypeEnum enumeration

Inventor.SurfaceGeometryFormEnum enumeration

Inventor.SurfaceTextureTypeEnum enumeration

Inventor.SurfaceTypeEnum enumeration

Inventor.SweepDefinitionTypeEnum enumeration

Inventor.SweepProfileOrientationEnum enumeration

Inventor.SweepProfileScalingEnum enumeration

Inventor.SystemOfMeasureEnum enumeration

Inventor.TableDirectionEnum enumeration

Inventor.TableSourceTypeEnum enumeration

Inventor.TextLineSpacingTypeEnum enumeration

Inventor.TextureDimensionEnum enumeration

Inventor.ThreadTypeEnum enumeration

Inventor.ThumbnailSaveOptionEnum enumeration

Inventor.TitleBlockAlignmentEnum enumeration

Inventor.TitleBlockLocationEnum enumeration

Inventor.ToleranceTypeEnum enumeration

Inventor.TransactionPointEnum enumeration

Inventor.TransactionStateEnum enumeration

Inventor.TransparencyTypeEnum enumeration

Inventor.TriadMoveTypeEnum enumeration

Inventor.TriadSegmentEnum enumeration

Inventor.UCSDefinitionTypeEnum enumeration

Inventor.UnfoldMethodEquationTypeEnum enumeration

Inventor.UnfoldMethodTypeEnum enumeration

Inventor.UniqueOccurrencesBehaviorEnum enumeration

Inventor.UnitsTypeEnum enumeration

Inventor.UpdatePropertiesOnSaveForFileTypeEnum enumeration

Inventor.ValueTypeEnum enumeration

Inventor.ValueUnitsTypeEnum enumeration

Inventor.VBAProjectTypeEnum enumeration

Inventor.VerticalTextAlignmentEnum enumeration

Inventor.ViewBlockInsertionPointEnum enumeration

Inventor.ViewJustificationEnum enumeration

Inventor.ViewLayoutEnum enumeration

Inventor.ViewOperationTypeEnum enumeration

Inventor.ViewOrientationTypeEnum enumeration

Inventor.ViewPreviewTypeEnum enumeration

Inventor.ViewTypeEnum enumeration

Inventor.WeldmentFeatureGroupEnum enumeration

Inventor.WeldmentStateEnum enumeration

Inventor.WindowsSizeEnum enumeration

Inventor.WorkAxisDefinitionEnum enumeration

Inventor.WorkPlaneDefinitionEnum enumeration

Inventor.WorkPointDefinitionEnum enumeration

Inventor.ZoomTargetComponentWithiMateEnum enumeration

Inventor::Application::DisplayOptions@[out, retval] DisplayOptions**

InventorDWGFileVersion

DrawingOptions interface

InventorServer

ApplicationAddInSite interface

InventorServer coclass

InventorStudio coclass

InventorStudioLib library

InventorVBAArgument interface

ArgumentType

Name

Parent

Type

Value

InventorVBAArgument.ArgumentType property

InventorVBAArgument.Name property

InventorVBAArgument.Parent property

InventorVBAArgument.Type property

InventorVBAArgument.Value property

InventorVBAArguments interface

Count

Item

Parent

Type

InventorVBAArguments.Count property

InventorVBAArguments.Item method

InventorVBAArguments.Parent property

InventorVBAArguments.Type property

InventorVBAComponent interface

InventorVBAMembers

Name

Parent

Type

VBComponent

InventorVBAComponent.InventorVBAMembers property

InventorVBAComponent.Name property

InventorVBAComponent.Parent property

InventorVBAComponent.Type property

InventorVBAComponent.VBComponent property

InventorVBAComponents

InventorVBAProject interface

InventorVBAComponents interface

Add

Count

Item

Parent

Type

InventorVBAComponents.Add method

InventorVBAComponents.Count property

InventorVBAComponents.Item method

InventorVBAComponents.Parent property

InventorVBAComponents.Type property

InventorVBAMember interface

Arguments

Execute

MemberType

Name

Parent

Type

VBMember

InventorVBAMember.Arguments property

InventorVBAMember.Execute method

InventorVBAMember.MemberType property

InventorVBAMember.Name property

InventorVBAMember.Parent property

InventorVBAMember.Type property

InventorVBAMember.VBMember property

InventorVBAMembers

InventorVBAComponent interface

InventorVBAMembers interface

Count

Item

Parent

Type

InventorVBAMembers.Count property

InventorVBAMembers.Item method

InventorVBAMembers.Parent property

InventorVBAMembers.Type property

InventorVBAProject interface

Close

InventorVBAComponents

Name

Parent

ProjectType

Save

SaveAs

Saved

Type

VBProject

InventorVBAProject.Close method

InventorVBAProject.InventorVBAComponents property

InventorVBAProject.Name property

InventorVBAProject.Parent property

InventorVBAProject.ProjectType property

InventorVBAProject.Save method

InventorVBAProject.SaveAs method

InventorVBAProject.Saved property

InventorVBAProject.Type property

InventorVBAProject.VBProject property

InventorVBAProjects interface

Add

Count

Item

Open

Parent

Type

InventorVBAProjects.Add method

InventorVBAProjects.Count property

InventorVBAProjects.Item method

InventorVBAProjects.Open method

InventorVBAProjects.Parent property

InventorVBAProjects.Type property

Invert

Matrix interface

Matrix2d interface

InvisibleIcon

ClientNodeResource interface

iPartFactory

PartComponentDefinition interface

iPartFactory interface

Application

CreateCustomMember

CreateMember

CustomFactory

DefaultRow

Delete

DisplayStyleColumn

ExcelWorkSheet

FactoryOptions

FileNameColumn

MaterialColumn

MemberCacheDir

MemberEditScope

Parent

TableColumns

TableRows

Type

iPartFactory.Application property

iPartFactory.CreateCustomMember method

iPartFactory.CreateMember method

iPartFactory.CustomFactory property

iPartFactory.DefaultRow property

iPartFactory.Delete method

iPartFactory.DisplayStyleColumn property

iPartFactory.ExcelWorkSheet property

iPartFactory.FactoryOptions property

iPartFactory.FileNameColumn property

iPartFactory.MaterialColumn property

iPartFactory.MemberCacheDir property

iPartFactory.MemberEditScope property

iPartFactory.Parent property

iPartFactory.TableColumns property

iPartFactory.TableRows property

iPartFactory.Type property

iPartMember

PartComponentDefinition interface

iPartMember interface

BreakLinkToFactory

ChangeRow

CustomMember

ParentFactory

PrimaryBody

Row

iPartMember.BreakLinkToFactory method

iPartMember.ChangeRow method

iPartMember.CustomMember property

iPartMember.ParentFactory property

iPartMember.PrimaryBody property

iPartMember.Row property

iPartTableCell interface

Application

Column

CustomCell

CustomIncrement

CustomRangeMaximum

CustomRangeMinimum

HasFormula

IsValid

Parent

Row

Type

Value

iPartTableCell.Application property

iPartTableCell.Column property

iPartTableCell.CustomCell property

iPartTableCell.CustomIncrement property

iPartTableCell.CustomRangeMaximum property

iPartTableCell.CustomRangeMinimum property

iPartTableCell.HasFormula property

iPartTableCell.IsValid property

iPartTableCell.Parent property

iPartTableCell.Row property

iPartTableCell.Type property

iPartTableCell.Value property

iPartTableColumn interface

Application

Count

CustomColumn

CustomIncrement

CustomRangeMaximum

CustomRangeMinimum

Delete

DisplayHeading

FormattedHeading

Heading

Index

Item

Key

Parent

ReferencedDataType

ReferencedObject

Type

iPartTableColumn.Application property

iPartTableColumn.Count property

iPartTableColumn.CustomColumn property

iPartTableColumn.CustomIncrement property

iPartTableColumn.CustomRangeMaximum property

iPartTableColumn.CustomRangeMinimum property

iPartTableColumn.Delete method

iPartTableColumn.DisplayHeading property

iPartTableColumn.FormattedHeading property

iPartTableColumn.Heading property

iPartTableColumn.Index property

iPartTableColumn.Item method

iPartTableColumn.Key property

iPartTableColumn.Parent property

iPartTableColumn.ReferencedDataType property

iPartTableColumn.ReferencedObject property

iPartTableColumn.Type property

iPartTableColumns interface

Application

Count

Item

Type

iPartTableColumns.Application property

iPartTableColumns.Count property

iPartTableColumns.Item method

iPartTableColumns.Type property

iPartTableRow interface

Application

AttributeSets

Copy

Count

Delete

GetReferenceKey

Index

IsPartNameBasedOnMemberName

Item

MemberName

Parent

PartIdentifier

PartName

PartNameModifiable

Type

iPartTableRow.Application property

iPartTableRow.AttributeSets property

iPartTableRow.Copy method

iPartTableRow.Count property

iPartTableRow.Delete method

iPartTableRow.GetReferenceKey method

iPartTableRow.Index property

iPartTableRow.IsPartNameBasedOnMemberName property

iPartTableRow.Item method

iPartTableRow.MemberName property

iPartTableRow.Parent property

iPartTableRow.PartIdentifier method

iPartTableRow.PartName property

iPartTableRow.PartNameModifiable property

iPartTableRow.Type property

iPartTableRows interface

Application

Count

Item

Type

iPartTableRows.Application property

iPartTableRows.Count property

iPartTableRows.Item method

iPartTableRows.Type property

IRenderManager interface

AntiAliasing

Camera

ImageHeight

ImageWidth

RenderToFile

TrueReflection

IRenderManager.AntiAliasing property

IRenderManager.Camera property

IRenderManager.ImageHeight property

IRenderManager.ImageWidth property

IRenderManager.RenderToFile method

IRenderManager.TrueReflection property

Is64BitVersion

SoftwareVersion interface

IsActiveRow

RevisionTableRow interface

IsAnalysisVisible

AnalysisManager interface

IsAssembly

DerivedAssemblyOccurrence interface

IsAssociative

NonParametricBaseFeature interface

NonParametricBaseFeatureDefinition interface

IsBaselineSetMember

LinearGeneralDimension interface

IsBreakLineSmooth

DetailDrawingView interface

IsChainSetMember

LinearGeneralDimension interface

IsChecked

MiniToolbarListItem interface

IsClosed

FaceShell interface

IsColinearTo

Line interface

IsComposite

iMateResult interface

NonParametricBaseFeature interface

IsConstraintSuppressionOverridden

PositionalRepresentation interface

IsConstraintValueOverridden

PositionalRepresentation interface

IsConsumed

AngleiMateDefinitionProxy interface

CompositeiMateDefinitionProxy interface

FlushiMateDefinitionProxy interface

InsertiMateDefinitionProxy interface

MateiMateDefinitionProxy interface

RotateRotateiMateDefinitionProxy interface

RotateTranslateiMateDefinitionProxy interface

TangentiMateDefinitionProxy interface

IsContentMember

PartComponentDefinition interface

IsCoordinateSystemElement

WorkAxis interface

WorkPlane interface

WorkPoint interface

IsCoplanarTo

Plane interface

IsCustom

ContentFamily interface

IsCustomized

DockableWindow interface

IsDefault

BorderDefinition interface

IsDefinedByEdge

SketchFixedSpline3D interface

IsDirectionUp

FlatBendResult interface

FlatPunchResult interface

IsDisjoint

Box interface

Box2d interface

IsDocumentNameBasedOnMemberName

iAssemblyTableRow interface

IsDoubleBendFirstEdgeFixed

BendDefinition interface

IsDrawingBOMDefined

DrawingBOMs interface

IsDrivingSection

LoftSectionDimension interface

IsEducationVersion

SoftwareVersion interface

IsEmbedded

ReferenceComponent interface

IsEntityValid

SurfaceBody interface

IsEqualTo

Matrix interface

Matrix2d interface

Point interface

Point2d interface

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

IsExcluded

iAssemblyTableRow interface

IsExpanding

Cone interface

EllipticalCone interface

IsExpressionValid

MiniToolbarValueEditorObject interface

Parameters interface

UnitsOfMeasure interface

IsFileInActiveProject

DesignProjectManager interface

IsFileNameValid

FileManager interface

IsFlat

Bend interface

IsFlatPatternView

DrawingView interface

IsFlexibleOverridden

PositionalRepresentation interface

IsGroundingOverridden

PositionalRepresentation interface

IsHoleNote

HoleThreadNote interface

IsiAssemblyFactory

AssemblyComponentDefinition interface

IsiAssemblyMember

AssemblyComponentDefinition interface

ComponentOccurrence interface

IsInitialized

DriveConstraintSettingsObject interface

IsInRedefineMode

TriadEventsObject interface

IsInsertionPointVisible

SketchBlockDefinition interface

IsInspectionDimension

DrawingDimension interface

IsInventorDWG

ApprenticeServerDrawingDocument interface

DrawingDocument interface

FileManager interface

IsiPartFactory

PartComponentDefinition interface

IsiPartMember

ComponentOccurrence interface

PartComponentDefinition interface

IsKey

Parameter interface

IsMessageSectionActive

ErrorManager interface

IsModelSpaceSheet

Sheet interface

IsModifiable

ApprenticeServerDocument interface

ContentFamily interface

Document interface

IsOnBottomFace

FlatBendResult interface

IsOnEdgeSide

HemDefinition interface

IsOpposedToEdge

EdgeUse interface

EdgeUseDefinition interface

IsOrdinateSetMember

OrdinateDimension interface

IsOuterEdgeLoop

EdgeLoop interface

IsOverridden

ContentTableCell interface

IsOwnedByFeature

PartFeature interface

PlanarSketch interface

Sketch3D interface

UserCoordinateSystem interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

IsParallelTo

Plane interface

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

IsParamOnFace

SurfaceEvaluator interface

IsParamReversed

Edge interface

EdgeDefinition interface

EdgeUse interface

Face interface

FaceDefinition interface

IsParentSketch

WorkAxis interface

WorkPlane interface

WorkPoint interface

IsPartNameBasedOnMemberName

iPartTableRow interface

IsPartNumberIndexed

FactoryOptions interface

IsPatternAngleOffsetOverridden

PositionalRepresentation interface

IsPatternColumnOffsetOverridden

PositionalRepresentation interface

IsPatternElement

ComponentOccurrence interface

OccurrencePattern interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

IsPatternRowOffsetOverridden

PositionalRepresentation interface

IsPerpendicularTo

Plane interface

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

IsPointInside

FaceShell interface

SurfaceBody interface

IsPositionalRepresentationOverridden

PositionalRepresentation interface

IsPositiveBendDirection

FoldDefinition interface

IsPositiveBendSide

FoldDefinition interface

IsProgressive

ProgressiveToolTip interface

IsPunchAfterStopNode

FlatPunchResult interface

IsPunchSuppressed

FlatPunchResult interface

IsPunchTool

iFeatureDefinition interface

IsPunchToolDepth

iFeatureParameterInput interface

IsReferenced

AutoCADBlockDefinition interface

BorderDefinition interface

ClientBrowserNodeDefinitionObject interface

SketchBlockDefinition interface

SketchedSymbolDefinition interface

TitleBlockDefinition interface

IsRib

RibDefinition interface

IsRippedCorner

CornerDefinition interface

IsSeperator

MiniToolbarListItem interface

IsSheetScope

RevisionTable interface

IsShortcutOverridden

ControlDefinition interface

IsSolid

NonParametricBaseFeature interface

SurfaceBody interface

IsSourceBreakOperation

BreakOperation interface

IsSplitButton

MiniToolbarDropdownObject interface

IsSubstituteOccurrence

ComponentOccurrence interface

IsSubstitutePart

ApprenticeServerDocument interface

PartDocument interface

IsSuppressed

ContentTableRow interface

IsTableDriven

iFeatureDefinition interface

IsTolerant

Edge interface

Vertex interface

IsTransformOverridden

PositionalRepresentation interface

IsTransient

SurfaceBody interface

IStudioCamera interface

Name

IStudioCamera.Name property

IStudioCameras interface

Count

Item

IStudioCameras.Count property

IStudioCameras.Item method

IStudioLightingStyle interface

Name

IStudioLightingStyle.Name property

IStudioLightingStyles interface

Count

Item

IStudioLightingStyles.Count property

IStudioLightingStyles.Item method

IStudioSceneStyle interface

Name

IStudioSceneStyle.Name property

IStudioSceneStyles interface

Count

Item

IStudioSceneStyles.Count property

IStudioSceneStyles.Item method

IsTwoBend

CornerOptions interface

IsTwoDirectional

ExtrudeDefinition interface

RevolveFeature interface

IsUnfoldMethodOverridden

BendDefinition interface

ContourFlangeDefinition interface

FlangeDefinition interface

FoldDefinition interface

HemDefinition interface

LoftedFlangeDefinition interface

IsUpdateComplete

DrawingView interface

IsValid

iAssemblyTableCell interface

iFeatureTableCell interface

iPartTableCell interface

IsVoid

FaceShell interface

Italic

TextGraphics interface

TextStyle interface

Item

AliasFreeformFeatures interface

ApplicationAddIns interface

ApprenticeServerDocuments interface

AssemblyComponentDefinitions interface

AssemblyConstraints interface

AssemblyConstraintsEnumerator interface

AttributesEnumerator interface

AttributeSet interface

AttributeSets interface

AttributeSetsEnumerator interface

AutoCADBlockDefinitions interface

AutoCADBlockDefinitionsEnumerator interface

AutoCADBlocks interface

Balloons interface

BalloonStylesEnumerator interface

BalloonTips interface

BalloonValueSets interface

BaselineDimensionSets interface

BendFeatures interface

BendNotes interface

BendPartFeatures interface

BendsEnumerator interface

BIMConnectorLinks interface

BIMConnectors interface

BOMRowsEnumerator interface

BOMViews interface

BorderDefinitions interface

BossFeatures interface

BossSets interface

BoundaryPatchFeatures interface

BoundaryPatchLoops interface

BreakOperations interface

BreakOutOperations interface

BrowserFoldersEnumerator interface

BrowserNodesEnumerator interface

BrowserPanes interface

Centerlines interface

Centermarks interface

CentermarkStylesEnumerator interface

ChainDimensionSets interface

ChamferFeatures interface

ChamferNotes interface

ChangeDefinitions interface

ChangeManager interface

CheckPointsEnumerator interface

CircularPatternFeatures interface

ClientFeatureElements interface

ClientFeatures interface

ClientGraphics interface

ClientGraphicsCollection interface

ClientNodeResources interface

ClientViews interface

CoilFeatures interface

ColorSchemes interface

Columns interface

CombineFeatures interface

CommandBarControls interface

CommandBarList interface

CommandBars interface

CommandCategories interface

CommandCategory interface

CommandControls interface

CommandControlsEnumerator interface

ComponentDefinitions interface

ComponentDefinitionsEnumerator interface

ComponentOccurrencesEnumerator interface

CompositeiMateDefinition interface

ContentFamiliesEnumerator interface

ContentTableColumns interface

ContentTableRow interface

ContentTableRows interface

ContentTreeViewNodesEnumerator interface

ContourFlangeFeatures interface

ContourRollFeatures interface

ControlDefinitions interface

CoreCavityFeatures interface

CornerChamferFeatures interface

CornerFeatures interface

CornerRoundFeatures interface

CosmeticBendFeatures interface

CosmeticWelds interface

CustomParameterGroup interface

CustomParameterGroups interface

CustomTables interface

CutFeatures interface

DecalFeatures interface

DeleteFaceFeatures interface

DerivedAliasComponents interface

DerivedAssemblyComponents interface

DerivedAssemblyOccurrences interface

DerivedParameters interface

DerivedParameterTables interface

DerivedPartComponents interface

DerivedPartEntities interface

DesignProjects interface

DesignViewRepresentations interface

DimensionConstraints interface

DimensionConstraints3D interface

DimensionStylesEnumerator interface

DisabledCommandList interface

DockableWindows interface

DocumentDescriptorsEnumerator interface

DocumentInterests interface

DocumentsEnumerator interface

DraftAnalyses interface

DrawingBOMColumns interface

DrawingBOMRow interface

DrawingBOMRows interface

DrawingBOMs interface

DrawingCurveSegments interface

DrawingCurvesEnumerator interface

DrawingDimensions interface

DrawingNotes interface

DrawingSketches interface

DrawingStandardStylesEnumerator interface

DrawingViews interface

EdgeDefinitions interface

EdgeLoopDefinitions interface

EdgeLoops interface

Edges interface

EdgeUseDefinitions interface

EdgeUses interface

EmbossFeatures interface

EnvironmentList interface

Environments interface

ExpressionList interface

ExtendFeatures interface

ExtrudeFeatures interface

FaceDefinitions interface

FaceDraftFeatures interface

FaceFeatures interface

Faces interface

FaceShellDefinitions interface

FaceShells interface

FeatureControlFrameRows interface

FeatureControlFrames interface

FeatureControlFrameStylesEnumerator interface

FeatureDimensions interface

FeaturePatternElements interface

Features interface

FileDescriptorsEnumerator interface

FilesEnumerator interface

FilletFeatures interface

FlangeFeatures interface

FlatBendResults interface

FlatPatternFeatures interface

FlatPunchResults interface

FoldFeatures interface

GeneralDimensions interface

GeneralDimensionsEnumerator interface

GeneralNotes interface

GeometricConstraints interface

GeometricConstraints3D interface

GraphicsDataSets interface

GraphicsDataSetsCollection interface

GraphicsNode interface

GrillFeatures interface

HemFeatures interface

HighlightSet interface

HighlightSets interface

HoleFeatures interface

HoleTableColumns interface

HoleTableRow interface

HoleTableRows interface

HoleTables interface

HoleTableStylesEnumerator interface

HoleThreadNotes interface

IAnimationFavorites interface

IAnimations interface

iAssemblyTableColumn interface

iAssemblyTableColumns interface

iAssemblyTableRow interface

iAssemblyTableRows interface

iFeatureInputs interface

iFeatures interface

iFeatureTableColumn interface

iFeatureTableColumns interface

iFeatureTableRow interface

iFeatureTableRows interface

iFeatureTemplateDescriptors interface

iMateDefinitions interface

iMateDefinitionsEnumerator interface

iMateResults interface

iMateResultsEnumerator interface

InterferenceResults interface

InventorVBAArguments interface

InventorVBAComponents interface

InventorVBAMembers interface

Item

InventorVBAProjects interface

iPartTableColumn interface

iPartTableColumns interface

iPartTableRow interface

iPartTableRows interface

IStudioCameras interface

IStudioLightingStyles interface

IStudioSceneStyles interface

KnitFeatures interface

LayersEnumerator interface

LeaderNodesEnumerator interface

LeaderNotes interface

LeaderStylesEnumerator interface

LevelOfDetailRepresentations interface

LightingStyles interface

Lights interface

LipFeatures interface

LoftedFlangeFeatures interface

LoftFeatures interface

LoftRails interface

LoftSectionDimensions interface

LumpDefinitions interface

MapPointCurves interface

Materials interface

MaterialsEnumerator interface

MiniToolbarComboBoxObject interface

MiniToolbarControls interface

MiniToolbarDropdownObject interface

MirrorFeatures interface

ModelParameters interface

MoveFaceFeatures interface

MoveFeatures interface

NameValueMap interface

NonParametricBaseFeatures interface

ObjectDefaultsStylesEnumerator interface

ObjectsEnumerator interface

ObjectsEnumeratorByVariant interface

OccurrencePatternElements interface

OccurrencePatterns interface

OrdinateDimensions interface

OrdinateDimensionsEnumerator interface

OrdinateDimensionSets interface

Parameters interface

ParametersEnumerator interface

ParameterTables interface

PartComponentDefinitions interface

PartFeatures interface

PartFeaturesEnumerator interface

PartsListColumns interface

PartsListRow interface

PartsListRows interface

PartsLists interface

PartsListStylesEnumerator interface

Path interface

PlanarSketches interface

PointInferenceEnumerator interface

PositionalRepresentations interface

PresentationExplodedViews interface

Profile interface

Profile3D interface

ProfilePath interface

ProfilePath3D interface

Profiles interface

Profiles3D interface

ProjectedCuts interface

ProjectPaths interface

PropertySet interface

PropertySets interface

PunchNotes interface

PunchToolFeatures interface

RectangularPatternFeatures interface

ReferencedOLEFileDescriptors interface

ReferenceFeatures interface

ReferenceFeaturesEnumerator interface

ReferenceParameters interface

RefoldFeatures interface

RenderStyles interface

ReplaceFaceFeatures interface

RestFeatures interface

RevisionTableColumns interface

RevisionTableRow interface

RevisionTableRows interface

RevisionTables interface

RevisionTableStylesEnumerator interface

RevolveFeatures interface

RibbonPanels interface

Ribbons interface

RibbonTabs interface

RibFeatures interface

RipFeatures interface

Row interface

Rows interface

RuleFilletFeatures interface

SculptFeatures interface

SelectSet interface

SheetFormats interface

SheetMetalStyles interface

Sheets interface

ShellFeatures interface

SilhouetteCurves interface

SketchArcs interface

SketchArcs3D interface

SketchBlockDefinitions interface

SketchBlockDefinitionsEnumerator interface

SketchBlocks interface

SketchBlocksEnumerator interface

SketchCircles interface

SketchCircles3D interface

SketchConstraints3DEnumerator interface

SketchConstraintsEnumerator interface

SketchedSymbolDefinitions interface

SketchedSymbols interface

SketchEllipses interface

SketchEllipses3D interface

SketchEllipticalArcs interface

SketchEllipticalArcs3D interface

SketchEntities3DEnumerator interface

SketchEntitiesEnumerator interface

Sketches3D interface

Sketches3DEnumerator interface

SketchesEnumerator interface

SketchFillRegions interface

SketchFixedSplines interface

SketchFixedSplines3D interface

SketchImages interface

SketchLines interface

SketchLines3D interface

SketchOffsetSplines interface

SketchPoints interface

SketchPoints3D interface

SketchSplines interface

SketchSplines3D interface

SnapFitFeatures interface

SplitFeatures interface

Styles interface

SurfaceBodies interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFaceList interface

SurfaceTextureStylesEnumerator interface

SurfaceTextureSymbols interface

SweepFeatures interface

TableParameters interface

TableStylesEnumerator interface

TextBoxes interface

TextStyles interface

TextStylesEnumerator interface

TextureCoordinateSet interface

TextureMaps interface

ThickenFeatures interface

ThreadFeatures interface

TitleBlockDefinitions interface

Trail interface

TrailsEnumerator interface

TransactionsEnumerator interface

TrimFeatures interface

UnfoldFeatures interface

UnfoldMethods interface

UserCoordinateSystems interface

UserParameters interface

VertexDefinitions interface

Vertices interface

ViewList interface

ViewsEnumerator interface

WeldBeads interface

Welds interface

Wires interface

WorkAxes interface

WorkPlanes interface

WorkPoints interface

WorkSurfaces interface

ItemById

ApplicationAddIns interface

BrowserNodesEnumerator interface

ClientGraphics interface

ClientNodeResources interface

GraphicsDataSets interface

ItemByName

ComponentOccurrences interface

DesignProjects interface

Documents interface

ReferencedOLEFileDescriptors interface

ItemByPropId

PropertySet interface

ItemNumber

BalloonValueSet interface

BOMRow interface

ItemNumberLocked

BOMRow interface

ItemQuantity

BOMRow interface

J

JacobiRadiusSize

SheetMetalComponentDefinition interface

Jogged

RadiusGeneralDimension interface

JogPointOne

OrdinateDimension interface

JogPointTwo

OrdinateDimension interface

JoinPreviewColor

ColorScheme interface

K

k_High enumeration member

k_Low enumeration member

k_Medium enumeration member

k_None enumeration member

k_VeryHigh enumeration member

k12x18InDrawingSheetSize enumeration member

k18x24InDrawingSheetSize enumeration member

k1DTexture enumeration member

k24x36InDrawingSheetSize enumeration member

k2DSketchAndCenterMarkPunchRepresentation enumeration member

k2DSketchPunchRepresentation enumeration member

k2DTexture enumeration member

k30x42InDrawingSheetSize enumeration member

k36x48InDrawingSheetSize enumeration member

k45DegreesLeftShadowDirection enumeration member

k45DegreesRightShadowDirection enumeration member

k9x12InDrawingSheetSize enumeration member

kA0DrawingSheetSize enumeration member

kA1DrawingSheetSize enumeration member

kA2DrawingSheetSize enumeration member

kA3DrawingSheetSize enumeration member

kA4DrawingSheetSize enumeration member

kAbort enumeration member

kAboveAndBelow enumeration member

kAboveShadowDirection enumeration member

kACADSplineFit enumeration member

kAcceleratorShortcut enumeration member

kAcceptButtonType enumeration member

kAcreAreaUnits enumeration member

kActivateDisplayState enumeration member

kActivateEnvironmentState enumeration member

kActivationAction enumeration member

kActiveComponentIsoViewOnSave enumeration member

kActiveWindow enumeration member

kActiveWindowOnSave enumeration member

kAdaptiveColumn enumeration member

kAdaptiveDisplayState enumeration member

kAdaptiveErrorDisplayState enumeration member

kAdaptiveWarningDisplayState enumeration member

kAddInLicenseStatusAvailable enumeration member

kAddInLicenseStatusUnavailable enumeration member

kAddInLicenseStatusUnlicensed enumeration member

kAddParametersCommand enumeration member

kAddPointCommand enumeration member

kAddPolygonCommand enumeration member

kAddRefWatchType enumeration member

kAdjacent enumeration member

kAdjacentFormat enumeration member

kAdjacentWithBracketsForAlternate enumeration member

kAdjacentWithBracketsForAlternateFormat enumeration member

kAdjacentWithBracketsForPrimary enumeration member

kAdjacentWithBracketsForPrimaryFormat enumeration member

kAdjustToDirection1 enumeration member

kAdjustToDirection2 enumeration member

kAdjustToModelCompute enumeration member

kADrawingSheetSize enumeration member

kAfter enumeration member

kAliasShortcut enumeration member

kAlignedAlignmentType enumeration member

kAlignedDim enumeration member

kAlignedDimensionType enumeration member

kAlignTextBaseline enumeration member

kAlignTextCenter enumeration member

kAlignTextLeft enumeration member

kAlignTextLower enumeration member

kAlignTextMiddle enumeration member

kAlignTextRight enumeration member

kAlignTextUpper enumeration member

kAllActions enumeration member

kAllCircularEntities enumeration member

kAllComponentsInteractiveContact enumeration member

kAllComponentsSuppressedLevelOfDetail enumeration member

kAllComponentsViewPreview enumeration member

kAllConcave enumeration member

kAllContentSuppressedLevelOfDetail enumeration member

kAllConvex enumeration member

kAllCustomGraphicsFilter enumeration member

kAllEntitiesFilter enumeration member

kAllGraphicsSelectable enumeration member

kAllGraphicsVisible enumeration member

kAllLinearEntities enumeration member

kAllPartsSuppressedLevelOfDetail enumeration member

kAllPlanarEntities enumeration member

kAllPointEntities enumeration member

kAllSegments enumeration member

kAllSurfacesInteractiveContact enumeration member

kAllTextOff enumeration member

kAllVisibleDesignViewType enumeration member

kAlwaysBreakGeometricConstraints enumeration member

kAlwaysDisplayText enumeration member

kAlwaysRelaxDimensionConstraints enumeration member

kAlwaysSaveMemoryMode enumeration member

kAlwaysSectionStandardParts enumeration member

kAmberColorTheme enumeration member

kAmbiguousStatus enumeration member

kAmpElectricalCurrentUnits enumeration member

kAnalyticEdgeWorkAxis enumeration member

kAngleArcDimension enumeration member

kAngleExtent enumeration member

kAngleFeatureDimension enumeration member

kAngleMeasure enumeration member

kAngleUnits enumeration member

kAngleVectorVectorJoint enumeration member

kAngularEndsInspectionBorder enumeration member

kAngularInBothDirections enumeration member

kAngularity enumeration member

kAngularVelocityUnits enumeration member

kAnimateCommand enumeration member

kANSI_DraftingStandard enumeration member

kApplicationVBAProject enumeration member

kApplyDrivenDimension enumeration member

kArbitraryViewOrientation enumeration member

kArcBendTransition enumeration member

kArchitecturalDisplayFormat enumeration member

kArcLengthAndAngleBendPart enumeration member

kArcLengthArcDimension enumeration member

kArcLengthDimensionType enumeration member

kArcWeldCornerReliefShape enumeration member

kAreaUnits enumeration member

kAssemblyDocumentObject enumeration member

kAssemblyFeatureFilter enumeration member

kAssemblyFeatureGroup enumeration member

kAssemblyFileType enumeration member

kAssemblyLeafOccurrenceFilter enumeration member

kAssemblyOccurrenceFilter enumeration member

kAssemblyOccurrencePatternElementFilter enumeration member

kAssemblyOccurrencePatternFilter enumeration member

kAssemblyWeldmentState enumeration member

kAssemblyWorkAxis enumeration member

kAssemblyWorkPlane enumeration member

kAssemblyWorkPoint enumeration member

kAssociativeDraftDrawingViewType enumeration member

kAsStyleArrowheadType enumeration member

kAssyCompositionOutOfDateDrawingSheet enumeration member

kAssyPositionOutOfDateDrawingSheet enumeration member

kAutoCAD2000 enumeration member

kAutoCAD2004 enumeration member

kAutoCAD2007 enumeration member

kAutoCAD2010 enumeration member

kAutomaticColorSource enumeration member

kAuxiliaryDrawingViewType enumeration member

kAxisIntersection enumeration member

kBackViewOrientation enumeration member

kBalloonStyleType enumeration member

kBandedDuctConnectionType enumeration member

kBarControlButton enumeration member

kBarControlPopUp enumeration member

kBaseQuantityPartsListProperty enumeration member

kBaseUnitPartsListProperty enumeration member

kBasicDWFPublish enumeration member

kBasicSurfaceType enumeration member

kBasicTolerance enumeration member

kBDrawingSheetSize enumeration member

kBefore enumeration member

kBeforeAndAfter enumeration member

kBelowFormat enumeration member

kBelowWithBracketsForAlternateFormat enumeration member

kBelowWithBracketsForPrimaryFormat enumeration member

kBendAllowanceEquationType enumeration member

kBendCompensationEquationType enumeration member

kBendDeductionEquationType enumeration member

kBendDownEdge enumeration member

kBendDownFlatPatternEdge enumeration member

kBendExtentEdge enumeration member

kBendingAngleType enumeration member

kBendkFactorEquationType enumeration member

kBendPositionAdjacentFace enumeration member

kBendPositionInnerEdgeOffset enumeration member

kBendPositionInsideBendFace enumeration member

kBendPositionOuterEdgeOffset enumeration member

kBendPositionOutsideBaseFace enumeration member

kBendPositionTangentToSideFace enumeration member

kBendTableSource enumeration member

kBendTableUnfoldMethod enumeration member

kBendUpEdge enumeration member

kBendUpFlatPatternEdge enumeration member

kBestImageFidelity enumeration member

kBestRayTracingQuality enumeration member

kBetterImageFidelity enumeration member

kBetweenModifier enumeration member

kBeyondStopNodeHealth enumeration member

kBiDirectionalFlowDirectionType enumeration member

kBIMCableTrayConnectorType enumeration member

kBIMConduitConnectorType enumeration member

kBIMDuctConnectorType enumeration member

kBIMElectricalConnectorType enumeration member

kBIMPipeConnectorType enumeration member

kBisectorCenterlineType enumeration member

kBlankArrowheadType enumeration member

kBlendingTransparency enumeration member

kBodyRenderStyle enumeration member

kBodySelectionPriority enumeration member

kBoldDisplayState enumeration member

kBOMQuantityColumn enumeration member

kBOMStructureColumn enumeration member

kBooleanGeneralData enumeration member

kBooleanTypeDifference enumeration member

kBooleanTypeIntersect enumeration member

kBooleanTypeUnion enumeration member

kBooleanUnits enumeration member

kBorderLabelModeAlphabetical enumeration member

kBorderLabelModeNone enumeration member

kBorderLabelModeNumeric enumeration member

kBothDirections enumeration member

kBothSidesShellDirection enumeration member

kBothStyleLocation enumeration member

kBottomDirection enumeration member

kBottomLeftPosition enumeration member

kBottomLeftViewCorner enumeration member

kBottomRightPosition enumeration member

kBottomRightViewCorner enumeration member

kBottomUpDirection enumeration member

kBottomViewOrientation enumeration member

kBoundingBoxViewPreview enumeration member

kBrazedPipeConnectionType enumeration member

kBrowserSelection enumeration member

kBrowserViewType enumeration member

kBSI_DraftingStandard enumeration member

kBSplineCurve enumeration member

kBSplineCurve2d enumeration member

kBSplineSurface enumeration member

kBTUWorkUnits enumeration member

kButton enumeration member

kButtonControl enumeration member

kButtonDefinition enumeration member

kButtonPopupCommandBar enumeration member

kButtonPopupControl enumeration member

kButtWeldedPipeConnectionType enumeration member

kByteArrayType enumeration member

kCalculatedDuctFlowConfigurationType enumeration member

kCalculatedFlowConfigurationType enumeration member

kCalorieWorkUnits enumeration member

kCancelButtonType enumeration member

kCandelaLuminousIntensityUnits enumeration member

kCanIgnoreDegreeOfFreedom enumeration member

kCannotComputeHealth enumeration member

kCanRetainDegreeOfFreedom enumeration member

kCapillaryPipeConnectionType enumeration member

kCBoreDepthHoleProperty enumeration member

kCBoreDiameterHoleProperty enumeration member

kCDrawingSheetSize enumeration member

kCelsiusTemperatureUnits enumeration member

kCenteredPatternCenterlineType enumeration member

kCenteredViewJustification enumeration member

kCenteredWidthExtent enumeration member

kCenterlineOfBend enumeration member

kCentermarkPunchRepresentation enumeration member

kCentermarkStyleType enumeration member

kCenterOfGravityCentermarkType enumeration member

kCenterPointArcCommand enumeration member

kCenterPointCircleCommand enumeration member

kCenterPointIntent enumeration member

kCentimeterLengthUnits enumeration member

kCentroidWorkPoint enumeration member

kChainLineType enumeration member

kCheckBox enumeration member

kCheckBoxDisplayState enumeration member

kChordLengthArcDimension enumeration member

kCircleArrowheadType enumeration member

kCircleCurve enumeration member

kCircleCurve2d enumeration member

kCirclePointStyle enumeration member

kCircularArcCurve enumeration member

kCircularArcCurve2d enumeration member

kCircularBottomPointIntent enumeration member

kCircularCountFeatureDimension enumeration member

kCircularity enumeration member

kCircularLeftPointIntent enumeration member

kCircularMilAreaUnits enumeration member

kCircularRelativeToCenter enumeration member

kCircularRevisionTag enumeration member

kCircularRightPointIntent enumeration member

kCircularRunout enumeration member

kCircularRunoutFilled enumeration member

kCircularShapeConnector enumeration member

kCircularTopPointIntent enumeration member

kCircularWithOneEntryBalloonType enumeration member

kCircularWithTwoEntriesBalloonType enumeration member

kClassicInterface enumeration member

kClippedDuctConnectionType enumeration member

kClosedArrowheadType enumeration member

kCoarseRes enumeration member

kCobaltColorTheme enumeration member

kCollectionGeneralData enumeration member

kComatoseDisplayState enumeration member

kCombineNotesRowMerge enumeration member

kComboBox enumeration member

kComboBoxControl enumeration member

kComboBoxDefinition enumeration member

kCommaDecimalMarker enumeration member

kCommandNameEvent enumeration member

kCommunicationElectricalSystemType enumeration member

kCompact enumeration member

kCompatibilityGraphicsSetting enumeration member

kCompleteDWFPublish enumeration member

kComponentSelectionPriority enumeration member

kCompositeOutputType enumeration member

kCompositeUnits enumeration member

kCompressionConduitConnectionType enumeration member

kCompressionPipeConnectionType enumeration member

kConCentricCircleCircleJoint enumeration member

kConcentricityAndCoaxiality enumeration member

kConcentricPlacementType enumeration member

kConeSurface enumeration member

kConfigurationTableSource enumeration member

kConsCoincidentCommand enumeration member

kConsCollinearCommand enumeration member

kConsConcentricCommand enumeration member

kConsEqualCommand enumeration member

kConservativeGraphicsOptimization enumeration member

kConservativeOpenGLGraphicsDriver enumeration member

kConsFixCommand enumeration member

kConsHorizontalCommand enumeration member

kConsParallelCommand enumeration member

kConsPerpendicularCommand enumeration member

kConsSymmetricCommand enumeration member

kConsTangentCommand enumeration member

kConstantFamilyParameterValue enumeration member

kConstrainedOrbit enumeration member

kConsVerticalCommand enumeration member

kContactSetDisplayState enumeration member

kContactSetOnlyInteractiveContact enumeration member

kContentCategoryType enumeration member

kContentConsumer enumeration member

kContentEditor enumeration member

kContentFamilyType enumeration member

kContentFeatureFamily enumeration member

kContentMemberType enumeration member

kContentPartFamily enumeration member

kContentPublisher enumeration member

kContinuousLineType enumeration member

kContourRollEdge enumeration member

kControlsElectricalSystemType enumeration member

kCopyFileMask enumeration member

kCornerFaceEdgeDistance enumeration member

kCornerMaxDistance enumeration member

kCornerNoOverlap enumeration member

kCornerOverlap enumeration member

kCornerReverseOverlap enumeration member

kCoulombElectricalChargeUnits enumeration member

kCounterBoreHole enumeration member

kCounterSinkHole enumeration member

kCouplingPipeConnectionType enumeration member

kCreate3DBendCommand enumeration member

kCreate3DLineCommand enumeration member

kCreate3DSketchCommand enumeration member

kCreate3QuarterSectionViewCommand enumeration member

kCreateAreaFillCommand enumeration member

kCreateAutoDimCommand enumeration member

kCreateAuxiliaryViewCommand enumeration member

kCreateBaselineDimensionCommand enumeration member

kCreateBendCommand enumeration member

kCreateBreakoutViewCommand enumeration member

kCreateBrokenViewCommand enumeration member

kCreateCaterpillarCommand enumeration member

kCreateCenteredPatternCommand enumeration member

kCreateCenterLineBisectorCommand enumeration member

kCreateCenterLineCommand enumeration member

kCreateCenterMarkCommand enumeration member

kCreateChamferCommand enumeration member

kCreateCircularPatternCommand enumeration member

kCreateCoilCommand enumeration member

kCreateComponentCommand enumeration member

kCreateContourFlangeCommand enumeration member

kCreateCornerChamferCommand enumeration member

kCreateCornerRoundCommand enumeration member

kCreateCornerSeamCommand enumeration member

kCreateCutCommand enumeration member

kCreateDecalCommand enumeration member

kCreateDerivedPartCommand enumeration member

kCreateDesignElementCommand enumeration member

kCreateDetailViewCommand enumeration member

kCreateDraftViewCommand enumeration member

kCreateDrawingViewCommand enumeration member

kCreateEmbossCommand enumeration member

kCreateEndTreatmentCommand enumeration member

kCreateEquationParamCommand enumeration member

kCreateExtrudeCommand enumeration member

kCreateFaceCommand enumeration member

kCreateFaceDraftCommand enumeration member

kCreateFilletCommand enumeration member

kCreateFlangeCommand enumeration member

kCreateFlatPatternCommand enumeration member

kCreateFoldCommand enumeration member

kCreateGeneralDimensionCommand enumeration member

kCreateGroundedWorkPointCommand enumeration member

kCreateHalfSectionViewCommand enumeration member

kCreateHemCommand enumeration member

kCreateHoleCommand enumeration member

kCreateHoleTableFromViewCommand enumeration member

kCreateHoleTableGroupCommand enumeration member

kCreateInterfaceCommand enumeration member

kCreateIntersectionCurveCommand enumeration member

kCreateKnitSurfaceCommand enumeration member

kCreateLoftCommand enumeration member

kCreateMateConstraintCommand enumeration member

kCreateMirrorCommand enumeration member

kCreateNewSheetCommand enumeration member

kCreateOrdinateDimensionCommand enumeration member

kCreatePresentationViewCommand enumeration member

kCreateProjectedViewCommand enumeration member

kCreatePunchCommand enumeration member

kCreateQuarterSectionViewCommand enumeration member

kCreateRectPatternCommand enumeration member

kCreateRevisionTableCommand enumeration member

kCreateRevisionTagCommand enumeration member

kCreateRevolveCommand enumeration member

kCreateRibCommand enumeration member

kCreateSectionViewCommand enumeration member

kCreateSelectedHoleTableCommand enumeration member

kCreateShellCommand enumeration member

kCreateSingleOrdinateDimCommand enumeration member

kCreateSketchChamferCommand enumeration member

kCreateSketchCommand enumeration member

kCreateSketchMirrorCommand enumeration member

kCreateSplitCommand enumeration member

kCreateSweepCommand enumeration member

kCreateTextCommand enumeration member

kCreateThreadCommand enumeration member

kCreateUnsectionedViewCommand enumeration member

kCreateWeldSymbolCommand enumeration member

kCreateWorkAxisCommand enumeration member

kCreateWorkPlaneCommand enumeration member

kCreateWorkPointCommand enumeration member

kCrimpedPipeConnectionType enumeration member

kCrossPointStyle enumeration member

kCrossSectionAnalysis enumeration member

kCSinkAngleHoleProperty enumeration member

kCSinkDepthHoleProperty enumeration member

kCSinkDiameterHoleProperty enumeration member

kCSVTableSource enumeration member

kCupVolumeUnits enumeration member

kCurrentTransaction enumeration member

kCurrentUnits enumeration member

kCurrentViewOrientation enumeration member

kCursorBuiltInArrow enumeration member

kCursorBuiltInArrowCursor enumeration member

kCursorBuiltInCommonSketchDrag enumeration member

kCursorBuiltInCrosshair enumeration member

kCursorBuiltInCursorSelComp enumeration member

kCursorBuiltInCursorSelTrail enumeration member

kCursorBuiltInDynpan enumeration member

kCursorBuiltInDynzoom enumeration member

kCursorBuiltInLineCursor enumeration member

kCursorBuiltInLookat enumeration member

kCursorBuiltInMeasureCmd enumeration member

kCursorBuiltInPushpinCursor enumeration member

kCursorBuiltInSelectArrow enumeration member

kCursorBuiltInSelectView enumeration member

kCursorBuiltInSketch enumeration member

kCursorBuiltInSketch3DEditCursor enumeration member

kCursorBuiltInZoom enumeration member

kCursorBuiltInZoomSel enumeration member

kCursorHotSpotBottomCenter enumeration member

kCursorHotSpotBottomLeft enumeration member

kCursorHotSpotBottomRight enumeration member

kCursorHotSpotDefault enumeration member

kCursorHotSpotMiddleCenter enumeration member

kCursorHotSpotMiddleLeft enumeration member

kCursorHotSpotMiddleRight enumeration member

kCursorHotSpotTopCenter enumeration member

kCursorHotSpotTopLeft enumeration member

kCursorHotSpotTopRight enumeration member

kCursorTypeCustom enumeration member

kCursorTypeDefault enumeration member

kCursorTypeWindows enumeration member

kCurvatureAnalysis enumeration member

kCurvatureContinuity enumeration member

kCurveAndEntityWorkPoint enumeration member

kCustomBrowserNodeFilter enumeration member

kCustomContent enumeration member

kCustomDesignationHoleProperty enumeration member

kCustomDrawingSheetSize enumeration member

kCustomDWFPublish enumeration member

kCustomEquationUnfoldMethod enumeration member

kCustomFamilyParameterValue enumeration member

kCustomHoleProperty enumeration member

kCustomImagePointStyle enumeration member

kCustomLevelOfDetail enumeration member

kCustomLineType enumeration member

kCustomProperty enumeration member

kCutAcrossBendsExtent enumeration member

kCutOperation enumeration member

kCyclicDisplayState enumeration member

kCylinderSurface enumeration member

kCylindricity enumeration member

kDarkColorTheme enumeration member

kDashDottedLineType enumeration member

kDashedDoubleDottedLineType enumeration member

kDashedHiddenLineType enumeration member

kDashedLineType enumeration member

kDashedTripleDottedLineType enumeration member

kDatabaseAngleUnits enumeration member

kDatabaseLengthUnits enumeration member

kDatabaseMassUnits enumeration member

kDatabaseTemperatureUnits enumeration member

kDatabaseTimeUnits enumeration member

kDataDropIOMechanism enumeration member

kDataElectricalSystemType enumeration member

kDataObjectMedium enumeration member

kDatum45BlankArrowheadType enumeration member

kDatum45FilledArrowheadType enumeration member

kDatum60BlankArrowheadType enumeration member

kDatum60FilledArrowheadType enumeration member

kDatumTargetStyleType enumeration member

kdBASEIII enumeration member

kdBASEIIIFormat enumeration member

kdBASEIV enumeration member

kdBASEIVFormat enumeration member

kDDrawingSheetSize enumeration member

kDecimalDisplayFormat enumeration member

kDecimalFormat enumeration member

kDefault enumeration member

kDefault_DraftingStandard enumeration member

kDefaultAlignmentType enumeration member

kDefaultAngleType enumeration member

kDefaultBendOrder enumeration member

kDefaultBendReliefShape enumeration member

kDefaultBendTransition enumeration member

kDefaultBOMStructure enumeration member

kDefaultCommand enumeration member

kDefaultCornerReliefShape enumeration member

kDefaultDisplayAngleUnits enumeration member

kDefaultDisplayLengthUnits enumeration member

kDefaultDisplayMassUnits enumeration member

kDefaultDisplayMode enumeration member

kDefaultDisplayState enumeration member

kDefaultDisplayTemperatureUnits enumeration member

kDefaultDisplayTimeUnits enumeration member

kDefaultLineType enumeration member

kDefaultOLEVerb enumeration member

kDefaultOrientation enumeration member

kDefaultPageOrientation enumeration member

kDefaultPunchRepresentation enumeration member

kDefaultSystemOfMeasure enumeration member

kDefaultTolerance enumeration member

kDefaultViewOrientation enumeration member

kDegreeAngleUnits enumeration member

kDegreesAnglePrecision enumeration member

kDegreesAngularPrecision enumeration member

kDeleteAction enumeration member

kDeletedHealth enumeration member

kDeleteFaceCommand enumeration member

kDeleteFileMask enumeration member

kDeriveAsMultipleBodies enumeration member

kDeriveAsSingleBodyNoSeams enumeration member

kDeriveAsSingleBodyWithSeams enumeration member

kDeriveAsWorkSurface enumeration member

kDerivedBoundingBox enumeration member

kDerivedDrawingFilename enumeration member

kDerivedDrawingFilenameAndPath enumeration member

kDerivedDrawingVersion enumeration member

kDerivedExcludeAll enumeration member

kDerivedIncludeAll enumeration member

kDerivedIndividualDefined enumeration member

kDerivedIntersect enumeration member

kDerivedModelFilename enumeration member

kDerivedModelFilenameAndPath enumeration member

kDerivedModelVersion enumeration member

kDerivedNumberOfSheets enumeration member

kDerivedParameter enumeration member

kDerivedPartMirrorPlaneXY enumeration member

kDerivedPartMirrorPlaneXZ enumeration member

kDerivedPartMirrorPlaneYZ enumeration member

kDerivedPartNoMirrorPlane enumeration member

kDerivedPatchAll enumeration member

kDerivedPatchNone enumeration member

kDerivedPatchRange enumeration member

kDerivedRemoveNone enumeration member

kDerivedRemovePartsAndFaces enumeration member

kDerivedRemovePartsOnly enumeration member

kDerivedSheetNumber enumeration member

kDerivedSheetRevision enumeration member

kDerivedSheetSize enumeration member

kDerivedSubtractAll enumeration member

kDescriptionHoleProperty enumeration member

kDeselAuthorCommand enumeration member

kDesignElementDocumentObject enumeration member

kDesignElementFileType enumeration member

kDesignViewsCommand enumeration member

kDetailDrawingViewType enumeration member

kDeviationTolerance enumeration member

kDiameterModifier enumeration member

kDiametricArcDimension enumeration member

kDiametricCircleDimension enumeration member

kDiametricDimensionType enumeration member

kDiametricLinearDimension enumeration member

kDieFormedLoftedFlange enumeration member

kDimCircularPointStyle enumeration member

kDimensionDisplayAsExpression enumeration member

kDimensionDisplayAsName enumeration member

kDimensionDisplayAsPreciseValue enumeration member

kDimensionDisplayAsTolerance enumeration member

kDimensionDisplayAsValue enumeration member

kDimensionEvent enumeration member

kDimensionStyleType enumeration member

kDIN_DraftingStandard enumeration member

kDirect3D10GraphicsDriver enumeration member

kDirect3DGraphicsDriver enumeration member

kDirectedSolution enumeration member

kDirectionalLight enumeration member

kDirectionAndDistanceMoveType enumeration member

kDirectionLoftCondition enumeration member

kDisplayTextInLearningMode enumeration member

kDistance enumeration member

kDistanceAndAngle enumeration member

kDistanceExtent enumeration member

kDistanceLineLineJoint enumeration member

kDistanceLinePlaneJoint enumeration member

kDistanceMeasure enumeration member

kDistancePlanePlaneJoint enumeration member

kDistancePointLineJoint enumeration member

kDistancePointPlaneJoint enumeration member

kDistancePointPointJoint enumeration member

kDistinctlyManySolutions enumeration member

kDockBottom enumeration member

kDockLastKnown enumeration member

kDockLeft enumeration member

kDockRight enumeration member

kDockToLeft enumeration member

kDockTop enumeration member

kDockToRight enumeration member

kDockToTop enumeration member

kDocumentVBAProject enumeration member

kDomesticColdWaterPipeSystemType enumeration member

kDomesticHotWaterPipeSystemType enumeration member

kDoneState enumeration member

kDoNotRefreshOutOfDateParts enumeration member

kDontAllowButton1NeverAgain enumeration member

kDontAllowButton1NoMoreThisSession enumeration member

kDontAllowButton2NeverAgain enumeration member

kDontAllowButton2NoMoreThisSession enumeration member

kDontAllowButton3NeverAgain enumeration member

kDontAllowButton3NoMoreThisSession enumeration member

kDontAllowNeverAgain enumeration member

kDontAllowNoMoreThisSession enumeration member

kDontUpdateProperties enumeration member

kDottedLineType enumeration member

kDoubleBend45Degree enumeration member

kDoubleBend90Degree enumeration member

kDoubleBendFixedEdges enumeration member

kDoubleBendFullRadius enumeration member

kDoubleBendNoBend enumeration member

kDoubleBendSingle enumeration member

kDoubleDashDoubleDottedLineType enumeration member

kDoubleDashedChainLineType enumeration member

kDoubleDashedDottedLineType enumeration member

kDoubleDashedTripleDottedLineType enumeration member

kDoubleGeneralData enumeration member

kDoubleHemType enumeration member

kDoubleLineSpacing enumeration member

kDoubleType enumeration member

kDraftAnalysis enumeration member

kDraftDrawingViewType enumeration member

kDragEnter enumeration member

kDragLeave enumeration member

kDragOver enumeration member

kDragStateCancelDrag enumeration member

kDragStateDragHandlerSelection enumeration member

kDragStateEndDrag enumeration member

kDragStateOnDrag enumeration member

kDragStateResumeDrag enumeration member

kDragStateStartDrag enumeration member

kDragStateSuspendDrag enumeration member

kDragUnknown enumeration member

kDrawingAutoCADBlockDefinitionFilter enumeration member

kDrawingAutoCADBlockFilter enumeration member

kDrawingBalloonFilter enumeration member

kDrawingBorderDefinitionFilter enumeration member

kDrawingBorderFilter enumeration member

kDrawingCenterlineFilter enumeration member

kDrawingCentermarkFilter enumeration member

kDrawingCurveSegmentFilter enumeration member

kDrawingCustomTableFilter enumeration member

kDrawingDefaultFilter enumeration member

kDrawingDimensionFilter enumeration member

kDrawingDocumentObject enumeration member

kDrawingFeatureControlFrameFilter enumeration member

kDrawingFileType enumeration member

kDrawingHoleTableFilter enumeration member

kDrawingHoleTagFilter enumeration member

kDrawingNoteFilter enumeration member

kDrawingOriginIndicatorFilter enumeration member

kDrawingPartsListFilter enumeration member

kDrawingRevisionTableFilter enumeration member

kDrawingSheetFilter enumeration member

kDrawingSheetFormatFilter enumeration member

kDrawingSketchedSymbolDefinitionFilter enumeration member

kDrawingSketchedSymbolFilter enumeration member

kDrawingSurfaceTextureSymbolFilter enumeration member

kDrawingTitleBlockDefinitionFilter enumeration member

kDrawingTitleBlockFilter enumeration member

kDrawingViewFilter enumeration member

kDrawingViewLabelFilter enumeration member

kDrilledHole enumeration member

kDriverGraphicsOptimization enumeration member

kDriverLostHealth enumeration member

kDropdown enumeration member

kDuplicateOverrideBendOrder enumeration member

kDWGDefaultDrawingFileType enumeration member

kDyneForceUnits enumeration member

kEachBOMQuantity enumeration member

kEdgeAndFaceSelectionPriority enumeration member

kEdgeFillet enumeration member

kEdgeSelectionPriority enumeration member

kEdgeWidthExtent enumeration member

kEditActiveMember enumeration member

kEditAllMembers enumeration member

kEditButtonType enumeration member

kEditFixedWorkPointCommand enumeration member

kEditMaskCmdType enumeration member

kEditOpenOLEVerb enumeration member

kEditSketchCoordCommand enumeration member

kEditThreadCommand enumeration member

kEditTweaksCommand enumeration member

kEditViewCommand enumeration member

kEDrawingSheetSize enumeration member

KeepNotesOnDeletedObjects

NotebookOptions interface

KeepToolBodies

CombineFeature interface

kEightDecimalPlacesAngularPrecision enumeration member

kEightDecimalPlacesLinearPrecision enumeration member

kEightDecimalPlacesPrecision enumeration member

kEighthsFractionalLengthPrecision enumeration member

kEighthsFractionalLinearPrecision enumeration member

kElectricallyBondedConnectionType enumeration member

kEllipseCommand enumeration member

kEllipseFullCurve enumeration member

kEllipseFullCurve2d enumeration member

kEllipticalArcCurve enumeration member

kEllipticalArcCurve2d enumeration member

kEllipticalConeSurface enumeration member

kEllipticalCylinderSurface enumeration member

kEmbossEngraveFromPlane enumeration member

kEmbossFromFace enumeration member

kEndOfBend enumeration member

kEndPointIntent enumeration member

kEndPointStyle enumeration member

kEnglishSystemOfMeasure enumeration member

kEngraveFromFace enumeration member

kEnvelopeRequirementModifier enumeration member

kEqualDistancePlanePlaneJoint enumeration member

kEqualDistancePointPlaneJoint enumeration member

kEqualToComparisonType enumeration member

kErgWorkUnits enumeration member

kEventCanceled enumeration member

kEventHandled enumeration member

kEventMember enumeration member

kEventNotHandled enumeration member

kExactLineSpacing enumeration member

kExcelTableSource enumeration member

kExcludeDisplayState enumeration member

kExclusionColumn enumeration member

kExclusiveOwnership enumeration member

kExhaustDuctSystemType enumeration member

kExitToParent enumeration member

kExitToPrevious enumeration member

kExitToTop enumeration member

kExpressionFamilyParameterValue enumeration member

kExtendBodyCommand enumeration member

Key

iAssemblyTableColumn interface

iFeatureTableColumn interface

iPartTableColumn interface

KeyboardEvents

InteractionEventsObject interface

KeyboardEvents coclass

KeyboardEventsObject interface

Application

Parent

Type

KeyboardEventsObject.Application property

KeyboardEventsObject.Parent property

KeyboardEventsObject.Type property

KeyboardEventsSink interface

OnKeyDown

OnKeyPress

OnKeyUp

KeyboardEventsSink.OnKeyDown method

KeyboardEventsSink.OnKeyPress method

KeyboardEventsSink.OnKeyUp method

KeyColumnOrder

ContentTableColumn interface

KeyTip

CommandControl interface

RibbonTab interface

KeyToString

ReferenceKeyManager interface

kFaceExtentsRipType enumeration member

kFaceFillet enumeration member

kFaceTangentiallyConnected enumeration member

kFaceUndefined enumeration member

kFactor

UnfoldMethod interface

KFactor

FlatBendResult interface

kFahrenheitTemperatureUnits enumeration member

kFaradElectricalCapacitanceUnits enumeration member

kFastenerTypeHoleProperty enumeration member

kFasternerFitHoleProperty enumeration member

kFasternerSizeHoleProperty enumeration member

kFDrawingSheetSize enumeration member

kFeatureControlFrameStyleType enumeration member

kFeatureDimensionFilter enumeration member

kFeatureRenderStyle enumeration member

kFeatureSelectionPriority enumeration member

kFeatureTypeHoleTable enumeration member

kFeetPerSecondSpeedUnits enumeration member

kFileBrowseIOMechanism enumeration member

kFileNameEvent enumeration member

kFileNameMedium enumeration member

kFileNameMemberNameType enumeration member

kFilenamePartsListProperty enumeration member

kFileNewDialogStartupAction enumeration member

kFileOpenCommand enumeration member

kFileOpenDialogStartupAction enumeration member

kFileOperationsCmdType enumeration member

kFileOrStreamStorage enumeration member

kFileProperty enumeration member

kFilePropertyColumn enumeration member

kFilePropertyEditCmdType enumeration member

kFileSaveCopyAsCommand enumeration member

kFileStorage enumeration member

kFilledArrowheadType enumeration member

kFilledCirclePointStyle enumeration member

kFilledCircleSelectPointStyle enumeration member

kFilledCrossPointStyle enumeration member

kFillHatchSketchRegionCommand enumeration member

kFiniteRibExtent enumeration member

kFireAlarmElectricalSystemType enumeration member

kFireProtectionDryPipeSystemType enumeration member

kFireProtectionOtherPipeSystemType enumeration member

kFireProtectionPreActionPipeSystemType enumeration member

kFireProtectionWetPipeSystemType enumeration member

kFitted enumeration member

kFitToPathLength enumeration member

kFiveDecimalPlacesAngularPrecision enumeration member

kFiveDecimalPlacesLinearPrecision enumeration member

kFiveDecimalPlacesPrecision enumeration member

kFixedGeometryMoveableStatus enumeration member

kFixedViewJustification enumeration member

kFixedWorkAxis enumeration member

kFixedWorkPlane enumeration member

kFixedWorkPoint enumeration member

kFixtureUnitsFlowConfigurationType enumeration member

kFlangeDistanceExtent enumeration member

kFlangeDuctConnectionType enumeration member

kFlangeLegacyDistanceExtent enumeration member

kFlangePipeConnectionType enumeration member

kFlangeToExtent enumeration member

kFlaredArrowheadType enumeration member

kFlatBacksidePivot180ViewOrientation enumeration member

kFlatBacksidePivotLeftViewOrientation enumeration member

kFlatBacksidePivotRightViewOrientation enumeration member

kFlatBacksideViewOrientation enumeration member

kFlatness enumeration member

kFlatPatternBendOrderColumn enumeration member

kFlatPatternOrientationColumn enumeration member

kFlatPivot180ViewOrientation enumeration member

kFlatPivotLeftViewOrientation enumeration member

kFlatPivotRightViewOrientation enumeration member

kFloat enumeration member

kFloating enumeration member

kFootLengthUnits enumeration member

kForceFile enumeration member

kForceUnits enumeration member

kForeignFileType enumeration member

kForeignModelDocumentObject enumeration member

kFormatDimStylesCommand enumeration member

kFormedFeaturePunchRepresentation enumeration member

kFourDecimalPlacesAngularPrecision enumeration member

kFourDecimalPlacesLinearPrecision enumeration member

kFourDecimalPlacesPrecision enumeration member

kFractionalDiagonalStackedFormat enumeration member

kFractionalDisplayFormat enumeration member

kFractionalHorizontalStackedFormat enumeration member

kFractionalNotStackedFormat enumeration member

kFreeBoundaryPatchCondition enumeration member

kFreeLoftCondition enumeration member

kFreeMoveType enumeration member

kFreeOrbit enumeration member

kFreeStateModifier enumeration member

kFreeToMoveGeometryMoveableStatus enumeration member

kFromBaseDrawingViewStyle enumeration member

kFromPointBreakOutType enumeration member

kFromToExtent enumeration member

kFromToWidthExtent enumeration member

kFrontFacing enumeration member

kFrontFacingAndPixelScaling enumeration member

kFrontViewFromModel enumeration member

kFrontViewOrientation enumeration member

kFrontViewXYPlane enumeration member

kFrontViewXZPlane enumeration member

kFrontViewYZPlane enumeration member

kFullGraphicsOptimization enumeration member

kFullRibbon enumeration member

kFullRoundCornerReliefShape enumeration member

kFullRoundFillet enumeration member

kFullScreenHighRes enumeration member

kFullSweepExtent enumeration member

kFullyConstrainedConstraintStatus enumeration member

kFullyDockedDialogStyle enumeration member

kFunctionMember enumeration member

kFusionPipeConnectionType enumeration member

kGalleryControl enumeration member

kGallonVolumeUnits enumeration member

kGammaMagneticInductionUnits enumeration member

kGaussMagneticInductionUnits enumeration member

kGB_DraftingStandard enumeration member

kGearJoint enumeration member

kGeneralSurfacesInteractiveContact enumeration member

kGeometryIntent enumeration member

kGeomOutOfDateDrawingSheet enumeration member

kGluedConduitConnectionType enumeration member

kGluedPipeConnectionType enumeration member

kGoodRayTracingQuality enumeration member

kGOST_DraftingStandard enumeration member

kGradAngleUnits enumeration member

kGradientBackgroundType enumeration member

kGramMassUnits enumeration member

kGraphicsViewType enumeration member

kGraphicsWindowSelection enumeration member

kGrayCheckBoxDisplayState enumeration member

kGreaterThanComparisonType enumeration member

kGreaterThanOrEqualToComparisonType enumeration member

kGroovedPipeConnectionType enumeration member

kGroundedColumn enumeration member

kGroundPlaneSpaceLight enumeration member

kGroundShadow enumeration member

kGroupSelectionPriority enumeration member

kHalf1FilledArrowheadType enumeration member

kHalf1FlaredArrowheadType enumeration member

kHalf2FilledArrowheadType enumeration member

kHalf2FlaredArrowheadType enumeration member

kHalfFractionalLengthPrecision enumeration member

kHalfFractionalLinearPrecision enumeration member

kHatchStyleType enumeration member

kHeadBossType enumeration member

kHeadingAtBottom enumeration member

kHeadingAtTop enumeration member

kHeightDatumInner enumeration member

kHeightDatumInnerOrtho enumeration member

kHeightDatumOuter enumeration member

kHeightDatumOuterOrtho enumeration member

kHeightDatumTangent enumeration member

kHenryElectricalInductanceUnits enumeration member

kHertzFrequencyUnits enumeration member

kHexagonBalloonType enumeration member

kHexagonRevisionTag enumeration member

kHiddenLineDrawingViewStyle enumeration member

kHiddenLineRemovedDrawingViewStyle enumeration member

kHideOLEVerb enumeration member

kHigh enumeration member

kHoleDepthHoleProperty enumeration member

kHoleDiameterHoleProperty enumeration member

kHoleFeatureDimension enumeration member

kHoleHoleProperty enumeration member

kHoleTableStyleType enumeration member

kHorizontalAlignment enumeration member

kHorizontalAlignmentType enumeration member

kHorizontalAndVerticalPriority enumeration member

kHorizontalBreakOrientation enumeration member

kHorizontalDim enumeration member

kHorizontalDimensionType enumeration member

kHorizontalViewAlignment enumeration member

kHorsePowerPowerUnits enumeration member

kHourTimeUnits enumeration member

kHybridSpace enumeration member

kHydronicReturnPipeSystemType enumeration member

kHydronicSupplyPipeSystemType enumeration member

kiComponentTableReplaceColumn enumeration member

kIdentical enumeration member

kIdenticalCompute enumeration member

kIDispatchGeneralData enumeration member

kIDStyleType enumeration member

kIDWDefaultDrawingFileType enumeration member

kiFeatureEntityInputTypeCircularEdge enumeration member

kiFeatureEntityInputTypeCircularSketchCurve enumeration member

kiFeatureEntityInputTypeConicalSurface enumeration member

kiFeatureEntityInputTypeCylindricalSurface enumeration member

kiFeatureEntityInputTypeEllipticalSketchCurve enumeration member

kiFeatureEntityInputTypeGenericEdge enumeration member

kiFeatureEntityInputTypeGenericSketchCurve enumeration member

kiFeatureEntityInputTypeGenericSurface enumeration member

kiFeatureEntityInputTypeLinearEdge enumeration member

kiFeatureEntityInputTypeLinearSketchCurve enumeration member

kiFeatureEntityInputTypePlanarFace enumeration member

kiFeatureEntityInputTypeSketchPoint enumeration member

kiFeatureEntityInputTypeSphericalSurface enumeration member

kiFeatureEntityInputTypeSplineSketchCurve enumeration member

kiFeatureEntityInputTypeToroidalSurface enumeration member

kiFeatureEntityInputTypeUnknown enumeration member

kiFeatureEntityInputTypeVertex enumeration member

kiFeatureEntityInputTypeWorkAxis enumeration member

kiFeatureEntityInputTypeWorkPlane enumeration member

kiFeatureEntityInputTypeWorkPoint enumeration member

kiFeatureTableReplaceColumn enumeration member

kIllustrationRendering enumeration member

kImageBackgroundType enumeration member

kiMateMatchingListColumn enumeration member

kiMateMatchingNameColumn enumeration member

kiMateSequenceNumberColumn enumeration member

kImportFromFile enumeration member

kImportNonInventorDWGFile enumeration member

kInchLengthUnits enumeration member

kIncludeGeometry3DCommand enumeration member

kInconsistentHealth enumeration member

kIncrementAsAmountOfValue enumeration member

kIncrementAsNumberOfSteps enumeration member

kIndependantAdaptivityDisplayState enumeration member

kInErrorHealth enumeration member

kInferredLine enumeration member

kInferredPoint enumeration member

kInfinitelyManySolutions enumeration member

kInFlowDirectionType enumeration member

kInPositionViewAlignment enumeration member

kInseparableBOMStructure enumeration member

kInsertBalloonAllCommand enumeration member

kInsertBalloonCommand enumeration member

kInsertDatumIdentifierCommand enumeration member

kInsertDatumTargetCircleCommand enumeration member

kInsertDatumTargetLeaderCommand enumeration member

kInsertDatumTargetLineCommand enumeration member

kInsertDatumTargetPointCommand enumeration member

kInsertDatumTargetRectCommand enumeration member

kInsertDesignElementCommand enumeration member

kInsertFeatureControlFrameCommand enumeration member

kInsertFeatureIdentifierCommand enumeration member

kInsertHoleNotesCommand enumeration member

kInsertImageCommand enumeration member

kInsertImportCommand enumeration member

kInsertLeaderTextCommand enumeration member

kInsertPartsListCommand enumeration member

kInsertSurfaceTextureCommand enumeration member

kInsertTableCommand enumeration member

kInsertTextCommand enumeration member

kInsideContainment enumeration member

kInsideShellDirection enumeration member

kIntegerGeneralData enumeration member

kIntegerType enumeration member

kInteractiveRayTracingQuality enumeration member

kInterested enumeration member

kIntersectionBendTransition enumeration member

kIntersectionCornerReliefShape enumeration member

kIntersectOperation enumeration member

kInventorDesktopAccess enumeration member

kInwardDirection enumeration member

kISO_DraftingStandard enumeration member

kIsoBottomLeftViewOrientation enumeration member

kIsoBottomRightViewOrientation enumeration member

kIsoTopLeftViewOrientation enumeration member

kIsoTopRightViewOrientation enumeration member

kItemPartsListProperty enumeration member

kItemQuantityPartsListProperty enumeration member

kJIS_DraftingStandard enumeration member

kJoinOperation enumeration member

kJouleWorkUnits enumeration member

kKCoefficientDuctLossMethodType enumeration member

kKCoefficientPipeLossMethodType enumeration member

kKelvinTemperatureUnits enumeration member

kKeyboardInteraction enumeration member

kKilogramMassUnits enumeration member

kKSIPressureUnits enumeration member

kLabel enumeration member

kLaggingPowerFactorStateType enumeration member

kLandscapeOrientation enumeration member

kLandscapePageOrientation enumeration member

kLarge enumeration member

kLargeDotArrowheadType enumeration member

kLastActiveDesignViewType enumeration member

kLastActiveLevelOfDetail enumeration member

kLastUsedDefaultLayerStyle enumeration member

kLastUsedDefaultObjectStyle enumeration member

kLayerColorSource enumeration member

kLayerStyleType enumeration member

kLbForceUnits enumeration member

kLbMassMassUnits enumeration member

kLeaderStyleType enumeration member

kLeadingPowerFactorStateType enumeration member

kLeastMaterialConditionModifier enumeration member

kLeftDirection enumeration member

kLeftMouseButton enumeration member

kLeftViewOrientation enumeration member

kLengthUnits enumeration member

kLessThanComparisonType enumeration member

kLessThanOrEqualToComparisonType enumeration member

kLibraryLocation enumeration member

kLibraryStyleLocation enumeration member

kLightColorTheme enumeration member

kLightFourShadowDirection enumeration member

kLightOneShadowDirection enumeration member

kLightThreeShadowDirection enumeration member

kLightTwoShadowDirection enumeration member

kLimitLinearTolerance enumeration member

kLimitsFitsLinearTolerance enumeration member

kLimitsFitsShowSizeTolerance enumeration member

kLimitsFitsShowTolerance enumeration member

kLimitsFitsStackedTolerance enumeration member

kLimitsStackedTolerance enumeration member

kLineAndFaceWorkPoint enumeration member

kLineAndPlaneWorkAxis enumeration member

kLineAndPointWorkAxis enumeration member

kLineAndTangentWorkPlane enumeration member

kLinearBalloonType enumeration member

kLinearFeatureDimension enumeration member

kLinearPlacementType enumeration member

kLinearUnfoldMethod enumeration member

kLinearWeldReliefShape enumeration member

kLineCommand enumeration member

kLineCurve enumeration member

kLineCurve2d enumeration member

kLinePlaneAndAngleWorkPlane enumeration member

kLineSegmentCurve enumeration member

kLineSegmentCurve2d enumeration member

kLineWorkAxis enumeration member

kLiterVolumeUnits enumeration member

kLoadBehaviorUnknown enumeration member

kLoadImmediately enumeration member

kLoadOnDemand enumeration member

kLoadWithAssemblies enumeration member

kLoadWithDrawings enumeration member

kLoadWithParts enumeration member

kLoadWithPresentations enumeration member

kLocalStyleLocation enumeration member

kLockDOF enumeration member

kLoftWithAreaGraphSections enumeration member

kLoftWithCenterline enumeration member

kLoftWithRails enumeration member

kLongDashDottedLineType enumeration member

kLongDashedDoubleDottedLineType enumeration member

kLongDashTripleDottedLineType enumeration member

kLookAtViewCommand enumeration member

kLow enumeration member

kLowercaseAlphaNumbering enumeration member

kLowerImageFidelity enumeration member

kLowerLeftTitleBlockAlignment enumeration member

kLowerRightTitleBlockAlignment enumeration member

kLowerValue enumeration member

kLumenLuminousFluxUnits enumeration member

kLuxIlluminationUnits enumeration member

kMachiningFeatureGroup enumeration member

kMachiningWeldmentState enumeration member

kMacroControl enumeration member

kMacroControlDefinition enumeration member

kMaintainAllTextAlignment enumeration member

kMaintainCenteredTextAlignment enumeration member

kMaintainViewPositionAlignment enumeration member

kMassPartsListProperty enumeration member

kMassUnits enumeration member

kMasterDesignViewType enumeration member

kMasterLevelOfDetail enumeration member

kMasticDuctConnectionType enumeration member

kMateConeConeJoint enumeration member

kMateCurveCurveJoint enumeration member

kMateCylinderCylinderJoint enumeration member

kMateLineLineJoint enumeration member

kMatePointCircleJoint enumeration member

kMatePointCurveJoint enumeration member

kMatePointLineJoint enumeration member

kMatePointPointJoint enumeration member

kMatePointSurfaceJoint enumeration member

kMaterialPartsListProperty enumeration member

kMaterialRemovalProhibitedSurfaceType enumeration member

kMaterialRemovalRequiredSurfaceType enumeration member

kMateSphereConeJoint enumeration member

kMateSphereSphereJoint enumeration member

kMaximize enumeration member

kMaximumMaterialConditionModifier enumeration member

kMaxTolerance enumeration member

kMaxwellMagneticFluxUnits enumeration member

kMeanApproximation enumeration member

kMeasureCommand enumeration member

kMedianValue enumeration member

kMedium enumeration member

kMediumDisplayQuality enumeration member

kMediumRes enumeration member

kMemberManagerDifferentFamily enumeration member

kMemberManagerDifferentMember enumeration member

kMemberManagerFeatureSuppressFail enumeration member

kMemberManagerInvalidMemberValue enumeration member

kMemberManagerLongFilename enumeration member

kMemberManagerMaterialNotFound enumeration member

kMemberManagerMissingFileWritePermission enumeration member

kMemberManagerNoError enumeration member

kMemberManagerThreadCreateFail enumeration member

kMemberManagerThreadFeatureNotFound enumeration member

kMemberManagerUnknown enumeration member

kMemberManagerVaultCheckoutFail enumeration member

kMemberManagerVaultFileStatusFail enumeration member

kMemberManagerVaultGetLatestVersionFail enumeration member

kMemberNameColumn enumeration member

kMereDotRes enumeration member

kMeterLengthUnits enumeration member

kMetersPerSecondSpeedUnits enumeration member

kMetricSystemOfMeasure enumeration member

kmhoElectricalConductanceUnits enumeration member

kMicronLengthUnits enumeration member

kMicrosoftAccess enumeration member

kMicrosoftAccessFormat enumeration member

kMicrosoftExcel enumeration member

kMicrosoftExcelFormat enumeration member

kMiddleMouseButton enumeration member

kMidPointIntent enumeration member

kMidPointWorkPoint enumeration member

kMileLengthUnits enumeration member

kMilesPerHourSpeedUnits enumeration member

kMilLengthUnits enumeration member

kMillimeterLengthUnits enumeration member

kMinimize enumeration member

kMinimizeToPanelTitles enumeration member

kMinimizeToTabs enumeration member

kMinTolerance enumeration member

kMinutesAnglePrecision enumeration member

kMinutesAngularPrecision enumeration member

kMinuteTimeUnits enumeration member

kMissingReference enumeration member

kMissingStatus enumeration member

kModelDataBOMViewType enumeration member

kModelOriginInsertion enumeration member

kModelParameter enumeration member

kModelSpace enumeration member

kModelSpaceLight enumeration member

kModifyStandardSettingsCommand enumeration member

kMoleSubstanceUnits enumeration member

kMonitorAndEnableUpdate enumeration member

kMonochromeRendering enumeration member

kMouseAndKeyboardInteraction enumeration member

kMouseInteraction enumeration member

kMoveableByDimensionChangeGeometryMoveableStatus enumeration member

kMoveAction enumeration member

kMoveComponentCommand enumeration member

kMoveFaceCommand enumeration member

kMoveFileMask enumeration member

kMultidirectional enumeration member

kMultipleLineSpacing enumeration member

kNameEvent enumeration member

kNameSelection enumeration member

kNauticalMileLengthUnits enumeration member

kNegativeExtentDirection enumeration member

kNeverBreakGeometricConstraints enumeration member

kNeverRelaxDimensionConstraints enumeration member

kNeverSaveMemoryMode enumeration member

kNeverSectionStandardParts enumeration member

kNeverTooThickApproximation enumeration member

kNeverTooThinApproximation enumeration member

kNewBodyOperation enumeration member

kNewer enumeration member

kNewFileFromTemplateStartupAction enumeration member

kNewtonForceUnits enumeration member

kNextTransaction enumeration member

KnitFeature interface

MaintainAsSurface

MaximumTolerance

Surfaces

KnitFeature.MaintainAsSurface property

KnitFeature.MaximumTolerance property

KnitFeature.Surfaces property

KnitFeatureProxy interface

ContainingOccurrence

NativeObject

KnitFeatureProxy.ContainingOccurrence property

KnitFeatureProxy.NativeObject property

KnitFeatures

PartFeatures interface

KnitFeatures interface

Add

Application

Count

Item

Type

KnitFeatures.Add method

KnitFeatures.Application property

KnitFeatures.Count property

KnitFeatures.Item method

KnitFeatures.Type property

kNoAction enumeration member

kNoAlternateUnits enumeration member

kNoAnalysis enumeration member

kNoApproximation enumeration member

kNoBendTransition enumeration member

kNoButtonsDialogStyle enumeration member

kNoDataDrawingSheet enumeration member

kNoDegreeOfFreedomState enumeration member

kNoDocument enumeration member

kNoEquationRelaxDimensionConstraints enumeration member

kNoForceFile enumeration member

kNoGraphicsSelectable enumeration member

kNoGraphicsVisible enumeration member

kNoGroundShadow enumeration member

kNoHeading enumeration member

kNoInference enumeration member

kNoInspectionBorder enumeration member

kNoInteraction enumeration member

kNominalValue enumeration member

kNoMonitor enumeration member

kNoneArrowheadType enumeration member

kNoneBalloonType enumeration member

kNoneDuctLossMethodType enumeration member

kNoneMouseButton enumeration member

kNonePartNumberType enumeration member

kNonePipeLossMethodType enumeration member

kNonePriority enumeration member

kNoneWatchType enumeration member

kNoNewSketchCreation enumeration member

kNonLinearEdgeWorkPoint enumeration member

kNonShapeEditCmdType enumeration member

kNoOwnership enumeration member

kNoPointIntent enumeration member

kNoProfileScaling enumeration member

kNoReplacementCornerReliefShape enumeration member

kNoRestrictions enumeration member

kNormal enumeration member

kNormalBOMStructure enumeration member

kNormalToCurveWorkPlane enumeration member

kNormalToPath enumeration member

kNormalToSurfaceWorkAxis enumeration member

kNormalWindow enumeration member

kNoRowMerge enumeration member

kNoShortcut enumeration member

kNoSnapPointStyle enumeration member

kNoSolution enumeration member

kNoStartupAction enumeration member

kNoTableSource enumeration member

kNoteBookViewType enumeration member

kNotEqualToComparisonType enumeration member

kNoTextWithIcon enumeration member

kNotFound enumeration member

kNothingVisibleDesignViewType enumeration member

kNoThumbnail enumeration member

kNotInterested enumeration member

kNoTitleBarDialogStyle enumeration member

kNoTransformBehaviors enumeration member

kNumberOfHolesInFeature enumeration member

kNumberOfLikeHolesNormalToView enumeration member

kNumberOfLikePunchesInFeature enumeration member

kNumberOfLikePunchesInModel enumeration member

kNumberPropertyType enumeration member

kNumericNumbering enumeration member

kNurseCallElectricalSystemType enumeration member

kObeyBrowserSettingsSectionStandardParts enumeration member

kObjectDefaultsStyleType enumeration member

kObliqueArrowheadType enumeration member

kOerstedMagneticInductionUnits enumeration member

kOffsetWidthExtent enumeration member

kOhmElectricalResistanceUnits enumeration member

kOlder enumeration member

kOLEDocumentEmbeddingObject enumeration member

kOLEDocumentLinkObject enumeration member

kOLEDocumentUnknownObject enumeration member

kOnContainment enumeration member

kOnCurvePointStyle enumeration member

kOneColorBackgroundType enumeration member

kOneDecimalPlaceAngularPrecision enumeration member

kOneDecimalPlaceLinearPrecision enumeration member

kOneDecimalPlacePrecision enumeration member

kOneTwentyEighthsFractionalLengthPrecision enumeration member

kOneTwentyEighthsFractionalLinearPrecision enumeration member

kOpenAngleType enumeration member

kOpenArrowheadType enumeration member

kOpenCurrentVersion enumeration member

kOpenGLGraphicsDriver enumeration member

kOpenOldVersion enumeration member

kOptimizedCompute enumeration member

kOriginArrowheadType enumeration member

kOriginSegment enumeration member

kOrthographicProjection enumeration member

kOther_DraftingStandard enumeration member

kOtherDuctSystemType enumeration member

kOtherPipeSystemType enumeration member

kOunceForceUnits enumeration member

kOunceMassUnits enumeration member

kOunceVolumeUnits enumeration member

kOutFlowDirectionType enumeration member

kOutOfDateHealth enumeration member

kOutOfDateReference enumeration member

kOutOfDateStatus enumeration member

kOutsideContainment enumeration member

kOutsideShellDirection enumeration member

kOutwardDirection enumeration member

kOvalShapeConnector enumeration member

kOverallColor enumeration member

kOverallNormal enumeration member

kOverCollarDuctConnectionType enumeration member

kOverConstrainedConstraintStatus enumeration member

kOverlayDrawingViewType enumeration member

kOverrideBendOrder enumeration member

kOverrideColorSource enumeration member

kOverrideDisplayMode enumeration member

kOverrideRenderStyle enumeration member

kOverrideTolerance enumeration member

kOverwriteExistingFile enumeration member

kOverwriteReadOnlyFile enumeration member

kOverwriteReservedFile enumeration member

kPanCommand enumeration member

kPanViewOperation enumeration member

kPaperSize10x14 enumeration member

kPaperSize11x17 enumeration member

kPaperSizeA0 enumeration member

kPaperSizeA0Oversize enumeration member

kPaperSizeA1 enumeration member

kPaperSizeA1Oversize enumeration member

kPaperSizeA2 enumeration member

kPaperSizeA2Oversize enumeration member

kPaperSizeA3 enumeration member

kPaperSizeA4 enumeration member

kPaperSizeA4Small enumeration member

kPaperSizeA5 enumeration member

kPaperSizeA6 enumeration member

kPaperSizeB0 enumeration member

kPaperSizeB1 enumeration member

kPaperSizeB2 enumeration member

kPaperSizeB3 enumeration member

kPaperSizeB4 enumeration member

kPaperSizeB5 enumeration member

kPaperSizeB6 enumeration member

kPaperSizeCSheet enumeration member

kPaperSizeCustom enumeration member

kPaperSizeDefault enumeration member

kPaperSizeDSheet enumeration member

kPaperSizeESheet enumeration member

kPaperSizeExecutive enumeration member

kPaperSizeFolio enumeration member

kPaperSizeLedger enumeration member

kPaperSizeLegal enumeration member

kPaperSizeLetter enumeration member

kPaperSizeQuarto enumeration member

kParallelAndPerpendicularPriority enumeration member

kParallelism enumeration member

kParallelProfile enumeration member

kParallelToOriginalProfile enumeration member

kParallelToPlaneOfProjection enumeration member

kParameterBOMQuantity enumeration member

kParameterIntent enumeration member

kParameterizedTextOutOfDateDrawingSheet enumeration member

kParameterValueColumn enumeration member

kParamLimitList enumeration member

kParamLimitNone enumeration member

kParamLimitRange enumeration member

kPartBodyFilter enumeration member

kPartDefaultFilter enumeration member

kPartDocumentObject enumeration member

kPartEdgeCircularFilter enumeration member

kPartEdgeFilter enumeration member

kPartEdgeLinearFilter enumeration member

kPartEdgeMidpointFilter enumeration member

kPartFaceConicalFilter enumeration member

kPartFaceCylindricalFilter enumeration member

kPartFaceFilter enumeration member

kPartFacePlanarFilter enumeration member

kPartFaceSphericalFilter enumeration member

kPartFaceToroidalFilter enumeration member

kPartFeatureFilter enumeration member

kPartFileType enumeration member

kPartialViewPreview enumeration member

kParticulateNondirectional enumeration member

kPartNumberMemberNameType enumeration member

kPartRenderStyle enumeration member

kPartSelectionPriority enumeration member

kPartsListStyleType enumeration member

kPartsOnly enumeration member

kPartsOnlyBOMViewType enumeration member

kPartSurfaceFeatureFilter enumeration member

kPartVertexFilter enumeration member

kPascalPressureUnits enumeration member

kPasteSpecialIOMechanism enumeration member

kPath enumeration member

kPathAndGuideRailSweepDef enumeration member

kPathAndGuideSurfaceSweepDef enumeration member

kPathAndSectionTwistsSweepDef enumeration member

kPathSweepDef enumeration member

kPatternComponentCommand enumeration member

kPerformanceGraphicsSetting enumeration member

kPeriodDecimalMarker enumeration member

kPerItemColors enumeration member

kPerItemNormals enumeration member

kPerpendicularCurveSurfaceJoint enumeration member

kPerpendicularity enumeration member

kPerpendicularToPlaneOfProjection enumeration member

kPerspectiveProjection enumeration member

kPerStripColors enumeration member

kPerStripNormals enumeration member

kPerVertexColors enumeration member

kPerVertexNormals enumeration member

kPhantomBOMStructure enumeration member

kPhysicalModelArea enumeration member

kPhysicalModelDensity enumeration member

kPhysicalModelMass enumeration member

kPhysicalModelVolume enumeration member

kPintVolumeUnits enumeration member

kPitchAndHeightCoilExtent enumeration member

kPitchAndRevolutionCoilExtent enumeration member

kPixelScaling enumeration member

kPlaceComponentCommand enumeration member

kPlaceConstraintCommand enumeration member

kPlanarMoveType enumeration member

kPlaneAndOffsetWorkPlane enumeration member

kPlaneAndPointWorkPlane enumeration member

kPlaneAndTangentWorkPlane enumeration member

kPlaneSurface enumeration member

kPlugInApplicationAddIn enumeration member

kPoint2dIntent enumeration member

kPointAndTangentWorkPlane enumeration member

kPointEnumIntent enumeration member

kPointLight enumeration member

kPointPlacementType enumeration member

kPointToPointRipType enumeration member

kPointWorkPoint enumeration member

kPolylineCurve enumeration member

kPopupBrowserFiltersCommand enumeration member

kPopUpCommandBar enumeration member

kPopupControl enumeration member

kPortraitOrientation enumeration member

kPortraitPageOrientation enumeration member

kPosition enumeration member

kPositiveExtentDirection enumeration member

kPowerBalancedElectricalSystemType enumeration member

kPowerUnbalancedElectricalSystemType enumeration member

kPowerUnits enumeration member

kPreciseViewRotationCommand enumeration member

kPreparationsWeldmentState enumeration member

kPreperationsFeatureGroup enumeration member

kPresentationDocumentObject enumeration member

kPresentationFileType enumeration member

kPresetDuctFlowConfigurationType enumeration member

kPresetFlowConfigurationType enumeration member

kPressBrakeChordToleranceLoftedFlange enumeration member

kPressBrakeFacetAngleLoftedFlange enumeration member

kPressBrakeFacetDistanceLoftedFlange enumeration member

kPressureUnits enumeration member

kPreviewClientGraphics enumeration member

kPreviousTransaction enumeration member

kPrintAllSheets enumeration member

kPrintBestFitScale enumeration member

kPrintColorPalette enumeration member

kPrintCurrentSheet enumeration member

kPrintCurrentWindow enumeration member

kPrintCustomScale enumeration member

kPrintDefaultColorMode enumeration member

kPrintFullScale enumeration member

kPrintGrayScale enumeration member

kPrintSheetRange enumeration member

kProcessingPreciseDisplayDrawingSheet enumeration member

kProductEditionInventor enumeration member

kProductEditionInventorFactoryAdvanced enumeration member

kProductEditionInventorFactoryPremium enumeration member

kProductEditionInventorLT enumeration member

kProductEditionInventorOEM enumeration member

kProductEditionInventorProfessional enumeration member

kProductEditionInventorRoutedSystems enumeration member

kProductEditionInventorSimulation enumeration member

kProductEditionInventorSuite enumeration member

kProductEditionInventorTooling enumeration member

kProfileOfAnyLine enumeration member

kProfileOfAnySurface enumeration member

kProjectCutEdgesCommand enumeration member

kProjectedDrawingViewType enumeration member

kProjectedGeneralDimension enumeration member

kProjectedToleranceZoneModifier enumeration member

kProjectGeometryCommand enumeration member

kProjectViewEdgesCommand enumeration member

kPromptBreakGeometricConstraints enumeration member

kPromptRelaxDimensionConstraints enumeration member

kPropertyMember enumeration member

kPSIPressureUnits enumeration member

kPtAtIntersection enumeration member

kPtAtMidPoint enumeration member

kPtOnCurve enumeration member

kPtOnPt enumeration member

kPublicDesignViewType enumeration member

kPunchAngleHoleProperty enumeration member

kPunchDepthHoleProperty enumeration member

kPunchDirectionHoleProperty enumeration member

kPunchDownEdge enumeration member

kPunchFeatureCentermarkType enumeration member

kPunchIdHoleProperty enumeration member

kPunchUpEdge enumeration member

kPurchasedBOMStructure enumeration member

kPushBackLocalBOMItemNumbersCommand enumeration member

kQualityGraphicsSetting enumeration member

kQuantityHoleProperty enumeration member

kQuantityPartsListProperty enumeration member

kQuarterFractionalLengthPrecision enumeration member

kQuarterFractionalLinearPrecision enumeration member

kQuartVolumeUnits enumeration member

kQueryInterfaceWatchType enumeration member

kQueryOnlyCmdType enumeration member

kRadialArcDimension enumeration member

kRadialCircleDimension enumeration member

kRadialFeatureDimension enumeration member

kRadialRelativeToCenter enumeration member

kRadianAngleUnits enumeration member

kRadiusAndAngleBendPart enumeration member

kRadiusAndArcLengthBendPart enumeration member

kRangeLineWeight enumeration member

kRawEdgeDuctConnectionType enumeration member

kReadOnlyStylesLibraryAccess enumeration member

kReadWriteStylesLibraryAccess enumeration member

kRealisticRendering enumeration member

kRebuildPartCommand enumeration member

kReciprocityModifier enumeration member

kRecommendedGraphicsOptimization enumeration member

kRecoveredPunchFeatureCentermarkType enumeration member

kRectangularBreakStyle enumeration member

kRectangularCountFeatureDimension enumeration member

kRectangularShapeConnector enumeration member

kRedundantHealth enumeration member

kReferenceBOMStructure enumeration member

kReferencedDocNeedsUpdateDisplayState enumeration member

kReferenceParameter enumeration member

kReferencesChangeCmdType enumeration member

kReferenceTolerance enumeration member

kReferenceVectorSolution enumeration member

kRefreshOutOfDateParts enumeration member

kRefreshViewCommand enumeration member

kRegardlessOfFeatureSizeModifier enumeration member

kRegularCenterlineType enumeration member

kRegularCentermarkType enumeration member

kRegularCommandBar enumeration member

kRegularLinearDimension enumeration member

kRegularLoft enumeration member

kRegularOpenNonInventorDWGFile enumeration member

kReleaseWatchType enumeration member

kReorderAction enumeration member

kReplaceAllComponentsCommand enumeration member

kReplaceComponentCommand enumeration member

kReplacedReference enumeration member

kReplaceFaceCommand enumeration member

kRepositionMoveType enumeration member

kRequestActivateEnvironmentState enumeration member

kResourceTemplateOutOfDateDrawingSheet enumeration member

kRestoreOldVersionToCurrent enumeration member

kResumeEnvironmentState enumeration member

kRetainDOF enumeration member

kReturnDuctSystemType enumeration member

kRevisionTableCustomProperty enumeration member

kRevisionTableDateProperty enumeration member

kRevisionTableFileProperty enumeration member

kRevisionTableLtrProperty enumeration member

kRevisionTableSheetProperty enumeration member

kRevisionTableStyleType enumeration member

kRevisionTableZoneProperty enumeration member

kRevisionTableZoneSheetProperty enumeration member

kRevoluteJoint enumeration member

kRevolutionAndHeightCoilExtent enumeration member

kRevolvedFaceWorkAxis enumeration member

kRibbonInterface enumeration member

kRibThicknessAtRoot enumeration member

kRibThicknessAtSketchPlane enumeration member

kRightDirection enumeration member

kRightMouseButton enumeration member

kRightViewOrientation enumeration member

kRolledHemType enumeration member

kRollupRowMerge enumeration member

kRotateCommand enumeration member

kRotateComponentCommand enumeration member

kRotateViewCommand enumeration member

kRotateViewOperation enumeration member

kRoughDisplayQuality enumeration member

kRoundBendReliefShape enumeration member

kRoundCornerReliefShape enumeration member

kRoundedEndsInspectionBorder enumeration member

kRoundWithRadiusCornerReliefShape enumeration member

kRPMAngularVelocityUnits enumeration member

kRSCFamilyHealthMissingCatParamMap enumeration member

kRSCFamilyHealthOutOfDateWithAuthorTableAndCategory enumeration member

kRSCFamilyHealthOutOfDateWithCategory enumeration member

kRSCFamilyHealthOutOfDateWithTable enumeration member

kRSCFamilyHealthOutOfDateWithTableAndCategory enumeration member

kRSCFamilyHealthRequiresReAuthor enumeration member

kRSCFamilyHealthTableUpdateIncomplete enumeration member

kRSCInstancingDifferentFamily enumeration member

kRSCInstancingDifferentMember enumeration member

kRSCInstancingFeatureSuppressFail enumeration member

kRSCInstancingInvalidMemberValue enumeration member

kRSCInstancingLongFilename enumeration member

kRSCInstancingMaterialNotFound enumeration member

kRSCInstancingMissingFileWritePermission enumeration member

kRSCInstancingThreadCreateFail enumeration member

kRSCInstancingThreadFeatureNotFound enumeration member

kRSCInstancingUnknownError enumeration member

kRSCNoError enumeration member

kRSCNoTPAddInLoadedForTPPart enumeration member

kRSCPartIsTPPipe enumeration member

kRSCReplaceFailed enumeration member

kRSCUnknownFailed enumeration member

kSandboxLevelOfDetail enumeration member

kSanitaryPipeSystemType enumeration member

kSATFileDocumentObject enumeration member

kSavedCameraViewOrientation enumeration member

kSaveOwnership enumeration member

kSchemaChangeCmdType enumeration member

kScreenDoorTransparency enumeration member

kScreenSpace enumeration member

kSecondsAnglePrecision enumeration member

kSecondsAngularPrecision enumeration member

kSecondsFourDecimalPlaceAnglePrecision enumeration member

kSecondsFourDecimalPlaceAngularPrecision enumeration member

kSecondsOneDecimalPlaceAnglePrecision enumeration member

kSecondsOneDecimalPlaceAngularPrecision enumeration member

kSecondsThreeDecimalPlaceAnglePrecision enumeration member

kSecondsThreeDecimalPlaceAngularPrecision enumeration member

kSecondsTwoDecimalPlaceAnglePrecision enumeration member

kSecondsTwoDecimalPlaceAngularPrecision enumeration member

kSecondTimeUnits enumeration member

kSectionDrawingViewType enumeration member

kSecurityElectricalSystemType enumeration member

kSelectAndKeyboardInteraction enumeration member

kSelectInteraction enumeration member

kSelectionTypeHoleTable enumeration member

kSemiIsolatedMode enumeration member

kSeparator enumeration member

kSeparatorControl enumeration member

kSetScrewConduitConnectionType enumeration member

kSevenDecimalPlacesAngularPrecision enumeration member

kSevenDecimalPlacesLinearPrecision enumeration member

kSevenDecimalPlacesPrecision enumeration member

kShadedDrawingViewStyle enumeration member

kShadedHiddenLineDrawingViewStyle enumeration member

kShadedRendering enumeration member

kShadedWithEdgesRendering enumeration member

kShadedWithHiddenEdgesRendering enumeration member

kShapeEditCmdType enumeration member

kSharedMode enumeration member

kSharpPointLoftCondition enumeration member

kSheetMetalFlatPatternArea enumeration member

kSheetMetalFlatPatternLength enumeration member

kSheetMetalFlatPatternWidth enumeration member

kSheetMetalRuleColumn enumeration member

kSheetMetalSettingsCommand enumeration member

kSheetMetalStyleType enumeration member

kSheetMetalUnfoldColumn enumeration member

kShiftStateAlt enumeration member

kShiftStateCtrl enumeration member

kShiftStateCtrlAlt enumeration member

kShiftStateNone enumeration member

kShiftStateShift enumeration member

kShiftStateShiftAlt enumeration member

kShiftStateShiftCtrl enumeration member

kShiftStateShiftCtrlAlt enumeration member

kShowConstraintsCommand enumeration member

kShowOLEVerb enumeration member

kSickDisplayState enumeration member

kSiemensElectricalConductanceUnits enumeration member

kSimpleSurfacesInteractiveContact enumeration member

kSingleHemType enumeration member

kSingleLineSpacing enumeration member

kSinglePartRigidBody enumeration member

kSinglePointRipType enumeration member

kSingleUserMode enumeration member

kSixDecimalPlacesAngularPrecision enumeration member

kSixDecimalPlacesLinearPrecision enumeration member

kSixDecimalPlacesPrecision enumeration member

kSixteenthsFractionalLengthPrecision enumeration member

kSixteenthsFractionalLinearPrecision enumeration member

kSixtyFourthsFractionalLengthPrecision enumeration member

kSixtyFourthsFractionalLinearPrecision enumeration member

kSketch3DCurveCircularFilter enumeration member

kSketch3DCurveEllipseFilter enumeration member

kSketch3DCurveFilter enumeration member

kSketch3DCurveLinearFilter enumeration member

kSketch3DCurveSplineFilter enumeration member

kSketch3DDefaultFilter enumeration member

kSketch3DDimConstraintFilter enumeration member

kSketch3DObjectFilter enumeration member

kSketch3DPointFilter enumeration member

kSketch3DProfileFilter enumeration member

kSketchBlockDefinitionFilter enumeration member

kSketchBlockFilter enumeration member

kSketchCurveCircularFilter enumeration member

kSketchCurveEllipseFilter enumeration member

kSketchCurveFilter enumeration member

kSketchCurveLinearFilter enumeration member

kSketchCurveSplineFilter enumeration member

kSketchDefaultFilter enumeration member

kSketchDimConstraintFilter enumeration member

kSketchedSymbolBalloonType enumeration member

kSketchExtendCommand enumeration member

kSketchFilletCommand enumeration member

kSketchGeneralDimCommand enumeration member

kSketchImageFilter enumeration member

kSketchObjectFilter enumeration member

kSketchOffsetCommand enumeration member

kSketchPlacementType enumeration member

kSketchPointFilter enumeration member

kSketchProfileFilter enumeration member

kSketchProjectedCutFilter enumeration member

kSketchSelectionPriority enumeration member

kSketchTextBoxFilter enumeration member

kSketchTrimCommand enumeration member

kSlipDriveDuctConnectionType enumeration member

kSlipJointDuctConnectionType enumeration member

kSlipJointPipeConnectionType enumeration member

kSlugMassUnits enumeration member

kSmall enumeration member

kSmallDotArrowheadType enumeration member

kSmoothDisplayQuality enumeration member

kSmootherDisplayQuality enumeration member

kSmoothLoftCondition enumeration member

kSmoothSplineFit enumeration member

kSocketWeldedPipeConnectionType enumeration member

kSoftwareGraphics enumeration member

kSolderedPipeConnectionType enumeration member

kSolidOutputType enumeration member

kSolverOffInteractiveContact enumeration member

kSomeGraphicsSelectable enumeration member

kSomeGraphicsVisible enumeration member

kSourceNewerStatus enumeration member

kSpecificLossDuctLossMethodType enumeration member

kSpecificLossPipeLossMethodType enumeration member

kSpeedUnits enumeration member

kSphereSurface enumeration member

kSpiralCoilExtent enumeration member

kSplineCommand enumeration member

kSplitBody enumeration member

kSplitButtonCommandBar enumeration member

kSplitButtonControl enumeration member

kSplitButtonMRUCommandBar enumeration member

kSplitButtonMRUControl enumeration member

kSplitFaces enumeration member

kSpotFaceHole enumeration member

kSpotLight enumeration member

kSquareCornerReliefShape enumeration member

kSquareModifier enumeration member

kSquareRevisionTag enumeration member

kStandardApplicationAddIn enumeration member

kStandardContent enumeration member

kStandardDefaultLayerStyle enumeration member

kStandardDefaultObjectStyle enumeration member

kStandardDrawingViewType enumeration member

kStandardImageFidelity enumeration member

kStandardOutOfDateDrawingSheet enumeration member

kStandardStyleType enumeration member

kStandardThread enumeration member

kStartOfBend enumeration member

kStartPointIntent enumeration member

kStatisticalToleranceModifier enumeration member

kSteradianAngleUnits enumeration member

kStorageStorage enumeration member

kStraightBendReliefShape enumeration member

kStraightLineBendTransition enumeration member

kStraightness enumeration member

kStreamMedium enumeration member

kStreamStorage enumeration member

kStringEvent enumeration member

kStringGeneralData enumeration member

kStringMedium enumeration member

kStringType enumeration member

kStructuralBreakStyle enumeration member

kStructured enumeration member

kStructuredAllLevels enumeration member

kStructuredBOMViewType enumeration member

kSubMember enumeration member

kSubstituteLevelOfDetail enumeration member

kSupplyDuctSystemType enumeration member

kSuppressDisplayState enumeration member

kSuppressedHealth enumeration member

kSurfaceAnalysis enumeration member

kSurfaceBody enumeration member

kSurfaceOperation enumeration member

kSurfaceOutputType enumeration member

kSurfaceTextureStyleType enumeration member

kSuspendEnvironmentState enumeration member

kSweetSplineFit enumeration member

kSymmetricDimensionType enumeration member

kSymmetricExtentDirection enumeration member

kSymmetricLinearDimension enumeration member

kSymmetricTolerance enumeration member

kSymmetry enumeration member

kSystemDuctFlowConfigurationType enumeration member

kSystemFlowConfigurationType enumeration member

kTableParameter enumeration member

kTableStyleType enumeration member

kTangentArcCommand enumeration member

kTangentBoundaryPatchCondition enumeration member

kTangentCircleCircleJoint enumeration member

kTangentCircleCommand enumeration member

kTangentCircleCylinderJoint enumeration member

kTangentConeConeJoint enumeration member

kTangentContinuity enumeration member

kTangentCurveSurfaceJoint enumeration member

kTangentCylinderConeJoint enumeration member

kTangentCylinderCylinderJoint enumeration member

kTangentCylinderSphereJoint enumeration member

kTangentEdge enumeration member

kTangentFlatPatternEdge enumeration member

kTangentiallyConnected enumeration member

kTangentLineCircleJoint enumeration member

kTangentLineCylinderJoint enumeration member

kTangentLineSphereJoint enumeration member

kTangentLoftCondition enumeration member

kTangentPlaneCircleJoint enumeration member

kTangentPlaneConeJoint enumeration member

kTangentPlaneCylinderJoint enumeration member

kTangentPlaneModifier enumeration member

kTangentSphereConeJoint enumeration member

kTangentSphereSphereJoint enumeration member

kTangentSurfaceSurfaceJoint enumeration member

kTangentToPlaneLoftCondition enumeration member

kTapDrillDiameterHoleProperty enumeration member

kTaperedThread enumeration member

kTearBendReliefShape enumeration member

kTearCornerReliefShape enumeration member

kTeardropHemType enumeration member

kTelephoneElectricalSystemType enumeration member

kTemperatureUnits enumeration member

kTerminateEnvironmentState enumeration member

kTeslaMagneticInductionUnits enumeration member

kTextFileCommaDelimited enumeration member

kTextFileCommaDelimitedFormat enumeration member

kTextFileTabDelimited enumeration member

kTextFileTabDelimitedFormat enumeration member

kTextPropertyType enumeration member

kTextStyleType enumeration member

kTextUnits enumeration member

kThickenCommand enumeration member

kThickLineArrowheadType enumeration member

kThirtySecondsFractionalLengthPrecision enumeration member

kThirtySecondsFractionalLinearPrecision enumeration member

kThreadBossType enumeration member

kThreadClassColumn enumeration member

kThreadClassHoleProperty enumeration member

kThreadDepthHoleProperty enumeration member

kThreadDesignationColumn enumeration member

kThreadDesignationHoleProperty enumeration member

kThreadDirectionColumn enumeration member

kThreadedConduitConnectionType enumeration member

kThreadEdge enumeration member

kThreadedPipeConnectionType enumeration member

kThreadMajorDiameter enumeration member

kThreadMinorDiameter enumeration member

kThreadPipeDiameterColumn enumeration member

kThreadPitchDiameter enumeration member

kThreadPitchHoleProperty enumeration member

kThreadTapDrillDiameter enumeration member

kThreadTypeColumn enumeration member

kThreeDecimalPlacesAngularPrecision enumeration member

kThreeDecimalPlacesLinearPrecision enumeration member

kThreeDecimalPlacesPrecision enumeration member

kThreePlanesWorkPoint enumeration member

kThreePointArcCommand enumeration member

kThreePointRectangleCommand enumeration member

kThreePointsDefinitionType enumeration member

kThreePointsWorkPlane enumeration member

kThroughAllExtent enumeration member

kThroughPartBreakOutType enumeration member

kTimeUnits enumeration member

kToExtent enumeration member

kTogglePopupControl enumeration member

kToHoleBreakOutType enumeration member

kToNextExtent enumeration member

kToNextRibExtent enumeration member

kTopDirection enumeration member

kTopDownDirection enumeration member

kTopLeftPosition enumeration member

kTopLeftViewCorner enumeration member

kTopRightPosition enumeration member

kTopRightViewCorner enumeration member

kTopViewOrientation enumeration member

kTorusCenterPointWorkPoint enumeration member

kTorusMidPlaneWorkPlane enumeration member

kTorusSurface enumeration member

kToSketchBreakOutType enumeration member

kTotalRunout enumeration member

kTotalRunoutFilled enumeration member

kTransformationDefinitionType enumeration member

kTransientClientGraphics enumeration member

kTransientDesignViewType enumeration member

kTransientLevelOfDetail enumeration member

kTransitionalJoint enumeration member

kTranslationalJoint enumeration member

kTranslationApplicationAddIn enumeration member

kTriangularRevisionTag enumeration member

kTrimSolid enumeration member

kTrimToBendBendTransition enumeration member

kTrimToBendReliefShape enumeration member

kTripleLineSpacing enumeration member

kTrueGeneralDimension enumeration member

kTrueLineWeight enumeration member

kTweakComponentsCommand enumeration member

kTwoDecimalPlacesAngularPrecision enumeration member

kTwoDecimalPlacesLinearPrecision enumeration member

kTwoDecimalPlacesPrecision enumeration member

kTwoDistances enumeration member

kTwoLinesWorkPlane enumeration member

kTwoLinesWorkPoint enumeration member

kTwoPlanesWorkAxis enumeration member

kTwoPlanesWorkPlane enumeration member

kTwoPointRectangleCommand enumeration member

kTwoPointsWorkAxis enumeration member

kUncommittedState enumeration member

kUndefined enumeration member

kUndefinedConduitConnectionType enumeration member

kUndefinedConnectionType enumeration member

kUndefinedDuctConnectionType enumeration member

kUndefinedDuctSystemType enumeration member

kUndefinedElectricalSystemType enumeration member

kUndefinedPipeConnectionType enumeration member

kUndefinedPipeSystemType enumeration member

kUndefinedShapeConnector enumeration member

kUnderConstrainedConstraintStatus enumeration member

kUndirectedSolution enumeration member

kUndoneState enumeration member

kUnfoldMethodType enumeration member

kUnicodeTextFileCommaDelimited enumeration member

kUnicodeTextFileCommaDelimitedFormat enumeration member

kUnicodeTextFileTabDelimited enumeration member

kUnicodeTextFileTabDelimitedFormat enumeration member

kUniqueSolution enumeration member

kUnitless enumeration member

kUnitlessUnits enumeration member

kUnitQuantityPartsListProperty enumeration member

kUniversalJoint enumeration member

kUnknownApplicationAddIn enumeration member

kUnknownColumn enumeration member

kUnknownConstraintStatus enumeration member

kUnknownContainment enumeration member

kUnknownControl enumeration member

kUnknownCurve enumeration member

kUnknownCurve2d enumeration member

kUnknownDocumentObject enumeration member

kUnknownEdge enumeration member

kUnknownFileType enumeration member

kUnknownGeometryMoveableStatus enumeration member

kUnknownHealth enumeration member

kUnknownLocation enumeration member

kUnknownOutOfDateDrawingSheet enumeration member

kUnknownReference enumeration member

kUnknownSelection enumeration member

kUnknownSolutionNature enumeration member

kUnknownStorage enumeration member

kUnknownSurface enumeration member

kUnknownTransaction enumeration member

kUnknownViewType enumeration member

kUnresolvedDisplayState enumeration member

kUnspecifiedIOMechanism enumeration member

kUpdatePropertiesForPartsAndAssemblies enumeration member

kUpdatePropertiesForPartsOnly enumeration member

kUpdateRequiredDisplayState enumeration member

kUpdateWithReferencesCmdType enumeration member

kUppercaseAlphaNumbering enumeration member

kUpperLeftTitleBlockAlignment enumeration member

kUpperRightTitleBlockAlignment enumeration member

kUpperValue enumeration member

kUpToDate enumeration member

kUpToDateDrawingSheet enumeration member

kUpToDateHealth enumeration member

kUpToDateReference enumeration member

kUpToDateStatus enumeration member

kUptoSpecifiedTransaction enumeration member

kUseApplicationOptionsMemoryMode enumeration member

kUseDefaultRefreshSetting enumeration member

kUserCoordinateSystemFilter enumeration member

kUserParameter enumeration member

kUserVBAProject enumeration member

kValueEditor enumeration member

kValueMemberNameType enumeration member

kValuePartNumberType enumeration member

kVanStoneDuctConnectionType enumeration member

kVariesBOMStructure enumeration member

kVaultMode enumeration member

kVaultOrProductstreamServerAccess enumeration member

kVerticalAlignment enumeration member

kVerticalAlignmentType enumeration member

kVerticalBreakOrientation enumeration member

kVerticalDim enumeration member

kVerticalDimensionType enumeration member

kVerticalViewAlignment enumeration member

kVeryCoarseRes enumeration member

kVeryHigh enumeration member

kViewAnnotationStyleType enumeration member

kViewCatalogCommand enumeration member

kViewCenterInsertion enumeration member

kViewHiddenEdgeCommand enumeration member

kViewShadedCommand enumeration member

kViewSpaceLight enumeration member

kViewTypeHoleTable enumeration member

kViewWireframeCommand enumeration member

kVoltageUnits enumeration member

kVoltElectricalVoltageUnits enumeration member

kVolumeUnits enumeration member

kVTableGeneralData enumeration member

kWarnOfOverConstrainedCondition enumeration member

kWatercolorRendering enumeration member

kWattPowerUnits enumeration member

kWeberMagneticFluxUnits enumeration member

kWeldBeadRenderStyle enumeration member

kWeldBeadStyleType enumeration member

kWeldJoint enumeration member

kWeldsFeatureGroup enumeration member

kWeldsWeldmentState enumeration member

kWeldSymbolStyleType enumeration member

kWidthOffsetWidthExtent enumeration member

kWireframeNoHiddenEdges enumeration member

kWireframeRendering enumeration member

kWireframeWireframeJoint enumeration member

kWireframeWithHiddenEdgesRendering enumeration member

kWireSelectionPriority enumeration member

kWorkAxisFilter enumeration member

kWorkFeatureCenterlineType enumeration member

kWorkFeatureCentermarkType enumeration member

kWorkgroupLocation enumeration member

kWorkPlane enumeration member

kWorkPlaneFilter enumeration member

kWorkPointFilter enumeration member

kWorkspaceLocation enumeration member

kWorkSurface enumeration member

kWorkUnits enumeration member

kXAxisRotationSegment enumeration member

kXAxisTranslationSegment enumeration member

kXDIMHoleProperty enumeration member

kXPointStyle enumeration member

kXProfileScaling enumeration member

kXRayGroundShadow enumeration member

kXYPlane enumeration member

kXYPlaneSketchCreation enumeration member

kXYPlaneTranslationSegment enumeration member

kXYProfileScaling enumeration member

kXZPlane enumeration member

kXZPlaneSketchCreation enumeration member

kXZPlaneTranslationSegment enumeration member

kYardLengthUnits enumeration member

kYAxisRotationSegment enumeration member

kYAxisTranslationSegment enumeration member

kYDIMHoleProperty enumeration member

kYellowCheckBoxDisplayState enumeration member

kYZPlane enumeration member

kYZPlaneSketchCreation enumeration member

kYZPlaneTranslationSegment enumeration member

kZAxisRotationSegment enumeration member

kZAxisTranslationSegment enumeration member

kZebraAnalysis enumeration member

kZeroDecimalPlaceAngularPrecision enumeration member

kZeroDecimalPlaceLinearPrecision enumeration member

kZeroDecimalPlacePrecision enumeration member

kZeroFractionalLengthPrecision enumeration member

kZeroFractionalLinearPrecision enumeration member

kZoomAllCommand enumeration member

kZoomCommand enumeration member

kZoomedInHighRes enumeration member

kZoomSelectCommand enumeration member

kZoomTargetAll enumeration member

kZoomTargetNone enumeration member

kZoomTargetPlacedComponent enumeration member

kZoomViewOperation enumeration member

kZoomWindowCommand enumeration member

L

Label

BrowserNodeDefinition interface

DrawingView interface

LabelFromBottomRight

DefaultBorder interface

LanguageTools interface

Application

GetiComponentStringValue

Parent

Type

LanguageTools.Application property

LanguageTools.GetiComponentStringValue method

LanguageTools.Parent property

LanguageTools.Type property

LargeIcon

ControlDefinition interface

Environment interface

MiniToolbarControl interface

MiniToolbarListItem interface

LargeIcons

UserInterfaceManager interface

LastKnownFileTime

ReferencedOLEFileDescriptor interface

LastKnownSourceFileName

iFeatureTemplateDescriptor interface

LastMessage

ErrorManager interface

LastSectionAngle

LoftDefinition interface

LastSectionCondition

LoftDefinition interface

LastSectionDirectionReversed

LoftDefinition interface

LastSectionImpact

LoftDefinition interface

LastSectionTangentPlane

LoftDefinition interface

LayDirection

SurfaceTextureSymbol interface

Layer

AutoCADBlock interface

Balloon interface

BaselineDimensionSet interface

BreakOperation interface

Centerline interface

Centermark interface

ChainDimensionSet interface

CustomTable interface

DrawingCurveSegment interface

DrawingDimension interface

DrawingNote interface

DrawingViewLabel interface

FeatureControlFrame interface

HoleTable interface

HoleTag interface

OrdinateDimensionSet interface

OriginIndicator interface

PartsList interface

RevisionTable interface

SketchedSymbol interface

SketchEntity interface

SurfaceTextureSymbol interface

TextBox interface

Layer interface

AutomaticColor

Color

GetCustomLineType

LineType

LineWeight

Plot

ScaleByLineWeight

SetCustomLineType

Visible

Layer.AutomaticColor property

Layer.Color property

Layer.GetCustomLineType method

Layer.LineType property

Layer.LineWeight property

Layer.Plot property

Layer.ScaleByLineWeight property

Layer.SetCustomLineType method

Layer.Visible property

Layers

DrawingStylesManager interface

LayersEnumerator interface

Application

Count

Item

Type

LayersEnumerator.Application property

LayersEnumerator.Count property

LayersEnumerator.Item method

LayersEnumerator.Type property

LayoutConstraint

AssemblyConstraint interface

LayoutConstraint interface

Application

AttributeSets

Delete

GetReferenceKey

HealthStatus

Name

Parent

Type

XYFlushConstraint

XZFlushConstraint

YZFlushConstraint

ZAngleConstraint

LayoutConstraint.Application property

LayoutConstraint.AttributeSets property

LayoutConstraint.Delete method

LayoutConstraint.GetReferenceKey method

LayoutConstraint.HealthStatus property

LayoutConstraint.Name property

LayoutConstraint.Parent property

LayoutConstraint.Type property

LayoutConstraint.XYFlushConstraint property

LayoutConstraint.XZFlushConstraint property

LayoutConstraint.YZFlushConstraint property

LayoutConstraint.ZAngleConstraint property

LayoutConstraintProxy interface

ContainingOccurrence

NativeObject

LayoutConstraintProxy.ContainingOccurrence property

LayoutConstraintProxy.NativeObject property

Leader

Balloon interface

FeatureControlFrame interface

HoleTag interface

LeaderNote interface

SketchedSymbol interface

SurfaceTextureSymbol interface

Leader interface

AddLeader

AllLeafNodes

AllNodes

Application

ArrowheadType

AttributeSets

GetReferenceKey

HasRootNode

Parent

RootNode

Type

Leader.AddLeader method

Leader.AllLeafNodes property

Leader.AllNodes property

Leader.Application property

Leader.ArrowheadType property

Leader.AttributeSets property

Leader.GetReferenceKey method

Leader.HasRootNode property

Leader.Parent property

Leader.RootNode property

Leader.Type property

LeaderClipping

SketchedSymbol interface

LeaderFromCenter

DiameterGeneralDimension interface

RadiusGeneralDimension interface

LeaderNode interface

AddLeader

Application

AttachedEntity

AttributeSets

ChildNodes

Delete

GetReferenceKey

InsertNode

Parent

Position

Type

LeaderNode.AddLeader method

LeaderNode.Application property

LeaderNode.AttachedEntity property

LeaderNode.AttributeSets property

LeaderNode.ChildNodes property

LeaderNode.Delete method

LeaderNode.GetReferenceKey method

LeaderNode.InsertNode method

LeaderNode.Parent property

LeaderNode.Position property

LeaderNode.Type property

LeaderNodesEnumerator interface

Application

Count

Item

Type

LeaderNodesEnumerator.Application property

LeaderNodesEnumerator.Count property

LeaderNodesEnumerator.Item method

LeaderNodesEnumerator.Type property

LeaderNote interface

DimensionStyle

Leader

LeaderNote.DimensionStyle property

LeaderNote.Leader property

LeaderNotes

DrawingNotes interface

LeaderNotes interface

Add

Application

Count

Item

Type

LeaderNotes.Add method

LeaderNotes.Application property

LeaderNotes.Count property

LeaderNotes.Item method

LeaderNotes.Type property

LeaderStyle

BalloonStyle interface

DimensionStyle interface

FeatureControlFrameStyle interface

OriginIndicator interface

SketchedSymbol interface

SurfaceTextureStyle interface

LeaderStyle interface

AllAroundSymbolDiameter

ArrowheadHeight

ArrowheadSize

ArrowheadType

Color

ExtensionLineOffset

ExtensionLineOvershoot

GetCustomLineType

LineType

LineWeight

ScaleToTextHeight

SetCustomLineType

LeaderStyle.AllAroundSymbolDiameter property

LeaderStyle.ArrowheadHeight property

LeaderStyle.ArrowheadSize property

LeaderStyle.ArrowheadType property

LeaderStyle.Color property

LeaderStyle.ExtensionLineOffset property

LeaderStyle.ExtensionLineOvershoot property

LeaderStyle.GetCustomLineType method

LeaderStyle.LineType property

LeaderStyle.LineWeight property

LeaderStyle.ScaleToTextHeight property

LeaderStyle.SetCustomLineType method

LeaderStyles

DrawingStylesManager interface

LeaderStylesEnumerator interface

Application

Count

Item

Type

LeaderStylesEnumerator.Application property

LeaderStylesEnumerator.Count property

LeaderStylesEnumerator.Item method

LeaderStylesEnumerator.Type property

LeaderTextLayer

ObjectDefaultsStyle interface

LeaderTextStyle

ObjectDefaultsStyle interface

LeaderVisible

SketchedSymbol interface

LeadingZeroDisplay

DimensionStyle interface

FeatureControlFrameStyle interface

Left

Application interface

DockableWindow interface

DrawingView interface

View interface

LeftMargin

DefaultBorder interface

LegacyDistanceHeightExtent interface

Distance

FlangeDirection

LegacyDistanceHeightExtent.Distance property

LegacyDistanceHeightExtent.FlangeDirection property

Length

DoubleHemDefinition interface

FlatPattern interface

SingleHemDefinition interface

SketchArc interface

SketchArc3D interface

SketchCircle interface

SketchCircle3D interface

SketchEllipse interface

SketchEllipse3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

SketchFixedSpline interface

SketchFixedSpline3D interface

SketchLine interface

SketchLine3D interface

SketchOffsetSpline interface

SketchSpline interface

SketchSpline3D interface

Vector interface

Vector2d interface

LengthDisplayPrecision

UnitsOfMeasure interface

LengthUnits

UnitsOfMeasure interface

Level

DrawingBOM interface

PartsList interface

LevelOfDetail

LevelOfDetailRepresentation interface

LevelOfDetailName

AssemblyDocument interface

LevelOfDetailRepresentation interface

Activate

Application

AttributeSets

Copy

Delete

GetReferenceKey

LevelOfDetail

Name

Parent

SubstituteDocumentDescriptor

SubstituteOccurrence

Type

LevelOfDetailRepresentation.Activate method

LevelOfDetailRepresentation.Application property

LevelOfDetailRepresentation.AttributeSets property

LevelOfDetailRepresentation.Copy method

LevelOfDetailRepresentation.Delete method

LevelOfDetailRepresentation.GetReferenceKey method

LevelOfDetailRepresentation.LevelOfDetail property

LevelOfDetailRepresentation.Name property

LevelOfDetailRepresentation.Parent property

LevelOfDetailRepresentation.SubstituteDocumentDescriptor property

LevelOfDetailRepresentation.SubstituteOccurrence property

LevelOfDetailRepresentation.Type property

LevelOfDetailRepresentations

RepresentationsManager interface

LevelOfDetailRepresentations interface

Add

AddSubstitute

Application

Count

Item

Type

LevelOfDetailRepresentations.Add method

LevelOfDetailRepresentations.AddSubstitute method

LevelOfDetailRepresentations.Application property

LevelOfDetailRepresentations.Count property

LevelOfDetailRepresentations.Item method

LevelOfDetailRepresentations.Type property

Libraries

FileLocations interface

LibraryInternalName

ContentFamily interface

LibraryName

ContentFamily interface

FileDescriptor interface

LibraryPaths

DesignProject interface

LicenseChallenge

ApplicationAddInSite interface

LicenseResponse

ApplicationAddInSite interface

LicenseStatus

ApplicationAddIn interface

Light interface

Application

Color

ConstantAttenuation

Direction

Intensity

LightDefinitionType

LightType

LinearAttenuation

On

Parent

Position

QuadraticAttenuation

SpotLightCutoffAngle

SpotLightFalloff

SpotLightInnerAngle

Type

Light.Application property

Light.Color property

Light.ConstantAttenuation property

Light.Direction property

Light.Intensity property

Light.LightDefinitionType property

Light.LightType property

Light.LinearAttenuation property

Light.On property

Light.Parent property

Light.Position property

Light.QuadraticAttenuation property

Light.SpotLightCutoffAngle property

Light.SpotLightFalloff property

Light.SpotLightInnerAngle property

Light.Type property

LightDefinitionType

Light interface

LightingStyle interface

Ambience

AmbientShadowIntensity

Application

AttributeSets

Brightness

ConvertToLocal

Copy

Delete

GetReferenceKey

ImageBasedLightingBrightness

ImageBasedLightingRotation

ImageBasedLightingScale

ImageBasedLightingShowImage

ImageBasedLightingSourceInternalName

ImageBasedLightingSourceName

InternalName

InUse

Lights

Name

Parent

SaveToGlobal

ShadowDensity

ShadowDirection

ShadowSoftness

StyleLocation

Type

UpdateFromGlobal

UpToDate

LightingStyle.Ambience property

LightingStyle.AmbientShadowIntensity property

LightingStyle.Application property

LightingStyle.AttributeSets property

LightingStyle.Brightness property

LightingStyle.ConvertToLocal method

LightingStyle.Copy method

LightingStyle.Delete method

LightingStyle.GetReferenceKey method

LightingStyle.ImageBasedLightingBrightness property

LightingStyle.ImageBasedLightingRotation property

LightingStyle.ImageBasedLightingScale property

LightingStyle.ImageBasedLightingShowImage property

LightingStyle.ImageBasedLightingSourceInternalName property

LightingStyle.ImageBasedLightingSourceName property

LightingStyle.InternalName property

LightingStyle.InUse property

LightingStyle.Lights property

LightingStyle.Name property

LightingStyle.Parent property

LightingStyle.SaveToGlobal method

LightingStyle.ShadowDensity property

LightingStyle.ShadowDirection property

LightingStyle.ShadowSoftness property

LightingStyle.StyleLocation property

LightingStyle.Type property

LightingStyle.UpdateFromGlobal method

LightingStyle.UpToDate property

LightingStyles

AssemblyDocument interface

PartDocument interface

PresentationDocument interface

LightingStyles interface

Add

Application

Count

Item

Parent

Type

LightingStyles.Add method

LightingStyles.Application property

LightingStyles.Count property

LightingStyles.Item method

LightingStyles.Parent property

LightingStyles.Type property

Lights

LightingStyle interface

Lights interface

Add

Application

Count

Item

Parent

Type

Lights.Add method

Lights.Application property

Lights.Count property

Lights.Item method

Lights.Parent property

Lights.Type property

LightType

Light interface

LimitListCount

iFeatureParameterInput interface

LimitListExpressions

iFeatureParameterInput interface

LimitRangeExpressions

iFeatureParameterInput interface

LimitType

iFeatureParameterInput interface

Line

LineAndPlaneWorkAxisDef interface

LineAndPointWorkAxisDef interface

LineAndTangentWorkPlaneDef interface

LineLengthDimConstraint3D interface

LinePlaneAndAngleWorkPlaneDef interface

LineWorkAxisDef interface

MidpointConstraint interface

MidpointConstraint3D interface

OffsetDimConstraint interface

WorkAxis interface

Line interface

Direction

DistanceTo

Evaluator

GetLineData

IntersectWithCurve

IntersectWithSurface

IsColinearTo

PutLineData

RootPoint

Line.Direction property

Line.DistanceTo method

Line.Evaluator property

Line.GetLineData method

Line.IntersectWithCurve method

Line.IntersectWithSurface method

Line.IsColinearTo method

Line.PutLineData method

Line.RootPoint property

Line1

TwoLinesWorkPlaneDef interface

TwoLinesWorkPointDef interface

Line2

TwoLinesWorkPlaneDef interface

TwoLinesWorkPointDef interface

Line2d interface

Direction

DistanceTo

Evaluator

GetLineData

IntersectWithCurve

PutLineData

RootPoint

Line2d.Direction property

Line2d.DistanceTo method

Line2d.Evaluator property

Line2d.GetLineData method

Line2d.IntersectWithCurve method

Line2d.PutLineData method

Line2d.RootPoint property

LineAndPlaneWorkAxisDef interface

Application

GetData

Line

Parent

Plane

Type

LineAndPlaneWorkAxisDef.Application property

LineAndPlaneWorkAxisDef.GetData method

LineAndPlaneWorkAxisDef.Line property

LineAndPlaneWorkAxisDef.Parent property

LineAndPlaneWorkAxisDef.Plane property

LineAndPlaneWorkAxisDef.Type property

LineAndPointWorkAxisDef interface

Application

GetData

Line

Parent

Point

Type

LineAndPointWorkAxisDef.Application property

LineAndPointWorkAxisDef.GetData method

LineAndPointWorkAxisDef.Line property

LineAndPointWorkAxisDef.Parent property

LineAndPointWorkAxisDef.Point property

LineAndPointWorkAxisDef.Type property

LineAndTangentWorkPlaneDef interface

Application

Face

GetData

Line

Parent

ProximityPoint

Type

LineAndTangentWorkPlaneDef.Application property

LineAndTangentWorkPlaneDef.Face property

LineAndTangentWorkPlaneDef.GetData method

LineAndTangentWorkPlaneDef.Line property

LineAndTangentWorkPlaneDef.Parent property

LineAndTangentWorkPlaneDef.ProximityPoint property

LineAndTangentWorkPlaneDef.Type property

Linear

TrailSegment interface

LinearAttenuation

Light interface

LinearDiameter

OffsetDimConstraint interface

TangentDistanceDimConstraint interface

LinearDimensionLayer

ObjectDefaultsStyle interface

LinearDimensionPrecision

Parameters interface

LinearDimensionStyle

ObjectDefaultsStyle interface

LinearDimensionType

DrawingOptions interface

LinearExpansion

Material interface

LinearGeneralDimension interface

BaselineDimensionSet

CenterText

ChainDimensionSet

DimensionType

ExtensionLineOne

ExtensionLineOneVisible

ExtensionLineTwo

ExtensionLineTwoVisible

FullDimensionLine

IntentOne

IntentTwo

IsBaselineSetMember

IsChainSetMember

ShowLeader

LinearGeneralDimension.BaselineDimensionSet property

LinearGeneralDimension.CenterText method

LinearGeneralDimension.ChainDimensionSet property

LinearGeneralDimension.DimensionType property

LinearGeneralDimension.ExtensionLineOne property

LinearGeneralDimension.ExtensionLineOneVisible property

LinearGeneralDimension.ExtensionLineTwo property

LinearGeneralDimension.ExtensionLineTwoVisible property

LinearGeneralDimension.FullDimensionLine property

LinearGeneralDimension.IntentOne property

LinearGeneralDimension.IntentTwo property

LinearGeneralDimension.IsBaselineSetMember property

LinearGeneralDimension.IsChainSetMember property

LinearGeneralDimension.ShowLeader property

LinearHolePlacementDefinition interface

DirectionOneReversed

DirectionTwoReversed

DistanceOne

DistanceTwo

Plane

ReferenceEntityOne

ReferenceEntityTwo

LinearHolePlacementDefinition.DirectionOneReversed property

LinearHolePlacementDefinition.DirectionTwoReversed property

LinearHolePlacementDefinition.DistanceOne property

LinearHolePlacementDefinition.DistanceTwo property

LinearHolePlacementDefinition.Plane property

LinearHolePlacementDefinition.ReferenceEntityOne property

LinearHolePlacementDefinition.ReferenceEntityTwo property

LinearPrecision

DimensionStyle interface

LinearStandardTolerance

Parameters interface

Parameters interface

LinearUnits

DimensionStyle interface

DrawingStandardStyle interface

FeatureControlFrameStyle interface

LineDefinitionSpace

ComponentGraphics interface

CurveGraphics interface

LineGraphics interface

LineStripGraphics interface

SketchArc interface

SketchCircle interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

LineGraphics interface

BurnThrough

ColorBinding

ColorIndexSet

ColorSet

CoordinateIndexSet

CoordinateSet

DepthPriority

GetCustomLineType

GetTransformBehavior

LineDefinitionSpace

LineScale

LineType

LineWeight

SetCustomLineType

SetTransformBehavior

LineGraphics.BurnThrough property

LineGraphics.ColorBinding property

LineGraphics.ColorIndexSet property

LineGraphics.ColorSet property

LineGraphics.CoordinateIndexSet property

LineGraphics.CoordinateSet property

LineGraphics.DepthPriority property

LineGraphics.GetCustomLineType method

LineGraphics.GetTransformBehavior method

LineGraphics.LineDefinitionSpace property

LineGraphics.LineScale property

LineGraphics.LineType property

LineGraphics.LineWeight property

LineGraphics.SetCustomLineType method

LineGraphics.SetTransformBehavior method

LineInput

iFeatureVectorInput interface

LineLengthDimConstraint3D interface

Line

LineLengthDimConstraint3D.Line property

LineLengthDimConstraint3DProxy interface

ContainingOccurrence

NativeObject

LineLengthDimConstraint3DProxy.ContainingOccurrence property

LineLengthDimConstraint3DProxy.NativeObject property

LineOne

BendConstraint interface

EqualLengthConstraint interface

TwoLineAngleDimConstraint interface

TwoLineAngleDimConstraint3D interface

LinePlaneAndAngleWorkPlaneDef interface

Angle

Application

GetData

Line

Parent

Plane

Type

LinePlaneAndAngleWorkPlaneDef.Angle property

LinePlaneAndAngleWorkPlaneDef.Application property

LinePlaneAndAngleWorkPlaneDef.GetData method

LinePlaneAndAngleWorkPlaneDef.Line property

LinePlaneAndAngleWorkPlaneDef.Parent property

LinePlaneAndAngleWorkPlaneDef.Plane property

LinePlaneAndAngleWorkPlaneDef.Type property

LineScale

ComponentGraphics interface

CurveGraphics interface

LineGraphics interface

LineStripGraphics interface

SketchArc interface

SketchCircle interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

LineSegment interface

Direction

DistanceTo

EndPoint

Evaluator

GetLineSegmentData

IntersectWithCurve

IntersectWithSurface

MidPoint

PutLineSegmentData

StartPoint

LineSegment.Direction property

LineSegment.DistanceTo method

LineSegment.EndPoint property

LineSegment.Evaluator property

LineSegment.GetLineSegmentData method

LineSegment.IntersectWithCurve method

LineSegment.IntersectWithSurface method

LineSegment.MidPoint property

LineSegment.PutLineSegmentData method

LineSegment.StartPoint property

LineSegment2d interface

Direction

DistanceTo

EndPoint

Evaluator

GetLineSegmentData

IntersectWithCurve

MidPoint

PutLineSegmentData

StartPoint

LineSegment2d.Direction property

LineSegment2d.DistanceTo method

LineSegment2d.EndPoint property

LineSegment2d.Evaluator property

LineSegment2d.GetLineSegmentData method

LineSegment2d.IntersectWithCurve method

LineSegment2d.MidPoint property

LineSegment2d.PutLineSegmentData method

LineSegment2d.StartPoint property

LineSpacing

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

TextBox interface

TextStyle interface

LineSpacingType

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

TextBox interface

TextStyle interface

LineStripGraphics interface

BurnThrough

ColorBinding

ColorIndexSet

ColorSet

CoordinateIndexSet

CoordinateSet

DepthPriority

GetCustomLineType

GetStripLengths

GetTransformBehavior

LineDefinitionSpace

LineScale

LineType

LineWeight

PutStripLengths

SetCustomLineType

SetTransformBehavior

LineStripGraphics.BurnThrough property

LineStripGraphics.ColorBinding property

LineStripGraphics.ColorIndexSet property

LineStripGraphics.ColorSet property

LineStripGraphics.CoordinateIndexSet property

LineStripGraphics.CoordinateSet property

LineStripGraphics.DepthPriority property

LineStripGraphics.GetCustomLineType method

LineStripGraphics.GetStripLengths method

LineStripGraphics.GetTransformBehavior method

LineStripGraphics.LineDefinitionSpace property

LineStripGraphics.LineScale property

LineStripGraphics.LineType property

LineStripGraphics.LineWeight property

LineStripGraphics.PutStripLengths method

LineStripGraphics.SetCustomLineType method

LineStripGraphics.SetTransformBehavior method

LineTwo

BendConstraint interface

EqualLengthConstraint interface

TwoLineAngleDimConstraint interface

TwoLineAngleDimConstraint3D interface

LineType

AutoCADBlock interface

ComponentGraphics interface

CurveGraphics interface

DimensionStyle interface

DrawingCurve interface

Layer interface

LeaderStyle interface

LineGraphics interface

LineStripGraphics interface

Sketch interface

SketchArc interface

SketchBlock interface

SketchCircle interface

SketchedSymbol interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

LineWeight

AutoCADBlock interface

ComponentGraphics interface

CurveGraphics interface

DimensionStyle interface

DrawingCurve interface

Layer interface

LeaderStyle interface

LineGraphics interface

LineStripGraphics interface

Sketch interface

SketchArc interface

SketchBlock interface

SketchCircle interface

SketchedSymbol interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

LineWeightType

DrawingOptions interface

SketchSettings interface

LineWorkAxisDef interface

Application

Line

Parent

Type

LineWorkAxisDef.Application property

LineWorkAxisDef.Line property

LineWorkAxisDef.Parent property

LineWorkAxisDef.Type property

Linked

ParameterTable interface

LinkedParameters

DerivedParameterTable interface

LinkedToFile

ReferenceComponent interface

SketchImage interface

LipFeature interface

LipFeatureProxy interface

ContainingOccurrence

NativeObject

LipFeatureProxy.ContainingOccurrence property

LipFeatureProxy.NativeObject property

LipFeatures

PartFeatures interface

LipFeatures interface

Application

Count

Item

Type

LipFeatures.Application property

LipFeatures.Count property

LipFeatures.Item method

LipFeatures.Type property

ListCount

ComboBoxDefinitionObject interface

ListIndex

ComboBoxDefinitionObject interface

ListItem

ComboBoxDefinitionObject interface

ListParameters

MeasureEventsObject interface

ListReferencedFilesInSaveDialog

SaveOptions interface

LoadAutomatically

ApplicationAddIn interface

LoadBehavior

ApplicationAddIn interface

LoadClassification

BIMElectricalConnectorDefinition interface

LoadContextFromArray

ReferenceKeyManager interface

LoadVBAOnStartup

GeneralOptions interface

Locale

ApprenticeServer interface

LocateUsingPoint

SurfaceBody interface

Location

ApplicationAddIn interface

TitleBlock interface

LocationType

FileDescriptor interface

Locked

ChainDimensionSet interface

DesignViewRepresentation interface

LoftDefinition interface

Centerline

Closed

Copy

FirstSectionAngle

FirstSectionCondition

FirstSectionDirectionReversed

FirstSectionImpact

FirstSectionTangentPlane

LastSectionAngle

LastSectionCondition

LastSectionDirectionReversed

LastSectionImpact

LastSectionTangentPlane

LoftRails

LoftSectionDimensions

LoftType

MapPointCurves

MergeTangentFaces

Operation

Sections

LoftDefinition.Centerline property

LoftDefinition.Closed property

LoftDefinition.Copy method

LoftDefinition.FirstSectionAngle property

LoftDefinition.FirstSectionCondition property

LoftDefinition.FirstSectionDirectionReversed property

LoftDefinition.FirstSectionImpact property

LoftDefinition.FirstSectionTangentPlane property

LoftDefinition.LastSectionAngle property

LoftDefinition.LastSectionCondition property

LoftDefinition.LastSectionDirectionReversed property

LoftDefinition.LastSectionImpact property

LoftDefinition.LastSectionTangentPlane property

LoftDefinition.LoftRails property

LoftDefinition.LoftSectionDimensions property

LoftDefinition.LoftType property

LoftDefinition.MapPointCurves property

LoftDefinition.MergeTangentFaces property

LoftDefinition.Operation property

LoftDefinition.Sections property

LoftedFlangeDefinition interface

Application

BendRadius

Converge

Copy

ExtentDirection

FacetTolerance

IsUnfoldMethodOverridden

OutputType

Parent

ProfileOne

ProfileTwo

SetOutputType

Type

UnfoldMethod

LoftedFlangeDefinition.Application property

LoftedFlangeDefinition.BendRadius property

LoftedFlangeDefinition.Converge property

LoftedFlangeDefinition.Copy method

LoftedFlangeDefinition.ExtentDirection property

LoftedFlangeDefinition.FacetTolerance property

LoftedFlangeDefinition.IsUnfoldMethodOverridden property

LoftedFlangeDefinition.OutputType property

LoftedFlangeDefinition.Parent property

LoftedFlangeDefinition.ProfileOne property

LoftedFlangeDefinition.ProfileTwo property

LoftedFlangeDefinition.SetOutputType method

LoftedFlangeDefinition.Type property

LoftedFlangeDefinition.UnfoldMethod property

LoftedFlangeFeature interface

Definition

LoftedFlangeFeature.Definition property

LoftedFlangeFeatureProxy interface

LoftedFlangeFeatures

SheetMetalFeatures interface

LoftedFlangeFeatures interface

Add

Application

Count

CreateLoftedFlangeDefinition

Item

Type

LoftedFlangeFeatures.Add method

LoftedFlangeFeatures.Application property

LoftedFlangeFeatures.Count property

LoftedFlangeFeatures.CreateLoftedFlangeDefinition method

LoftedFlangeFeatures.Item method

LoftedFlangeFeatures.Type property

LoftFeature interface

Definition

EndFace

SideFaces

StartFace

LoftFeature.Definition property

LoftFeature.EndFace property

LoftFeature.SideFaces property

LoftFeature.StartFace property

LoftFeatureProxy interface

ContainingOccurrence

NativeObject

LoftFeatureProxy.ContainingOccurrence property

LoftFeatureProxy.NativeObject property

LoftFeatures

PartFeatures interface

LoftFeatures interface

Add

Application

Count

CreateLoftDefinition

CreateMapCurves

Item

Type

LoftFeatures.Add method

LoftFeatures.Application property

LoftFeatures.Count property

LoftFeatures.CreateLoftDefinition method

LoftFeatures.CreateMapCurves method

LoftFeatures.Item method

LoftFeatures.Type property

LoftRail interface

Application

Condition

Delete

HasConditions

Impact

Rail

Type

LoftRail.Application property

LoftRail.Condition property

LoftRail.Delete method

LoftRail.HasConditions property

LoftRail.Impact property

LoftRail.Rail property

LoftRail.Type property

LoftRails

LoftDefinition interface

LoftRails interface

Add

Application

Count

Item

Type

LoftRails.Add method

LoftRails.Application property

LoftRails.Count property

LoftRails.Item method

LoftRails.Type property

LoftSectionDimension interface

Application

Delete

IsDrivingSection

Position

PositionAsAbsoluteDistance

Size

SizeAsScaleFactor

Type

LoftSectionDimension.Application property

LoftSectionDimension.Delete method

LoftSectionDimension.IsDrivingSection property

LoftSectionDimension.Position property

LoftSectionDimension.PositionAsAbsoluteDistance property

LoftSectionDimension.Size property

LoftSectionDimension.SizeAsScaleFactor property

LoftSectionDimension.Type property

LoftSectionDimensions

LoftDefinition interface

LoftSectionDimensions interface

AddDrivenSection

AddDrivingSection

Application

Count

Item

Type

LoftSectionDimensions.AddDrivenSection method

LoftSectionDimensions.AddDrivingSection method

LoftSectionDimensions.Application property

LoftSectionDimensions.Count property

LoftSectionDimensions.Item method

LoftSectionDimensions.Type property

LoftType

LoftDefinition interface

LogicalName

ReferencedOLEFileDescriptor interface

Login

Application interface

LossMethod

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

LossValue

BIMDuctConnectorDefinition interface

BIMPipeConnectorDefinition interface

Lower

Tolerance interface

LowerTolerance

FeatureControlFrameRow interface

LumpDefinition interface

Application

FaceShellDefinitions

Type

LumpDefinition.Application property

LumpDefinition.FaceShellDefinitions property

LumpDefinition.Type property

LumpDefinitions

SurfaceBodyDefinition interface

LumpDefinitions interface

Add

Application

Count

Item

Type

LumpDefinitions.Add method

LumpDefinitions.Application property

LumpDefinitions.Count property

LumpDefinitions.Item method

LumpDefinitions.Type property

M

Machining

WeldmentComponentDefinition interface

Machining interface

Application

Edit

ExitEdit

Type

Machining.Application property

Machining.Edit method

Machining.ExitEdit method

Machining.Type property

MachiningAllowance

SurfaceTextureSymbol interface

MachiningProhibitedSymbolSizeSmall

SurfaceTextureStyle interface

MacroControlDefinition interface

MacroOrFileName

MacroControlDefinition.MacroOrFileName property

MacroOrFileName

MacroControlDefinition interface

MainFrameHWND

Application interface

MaintainAsSurface

KnitFeature interface

MaintainEnhancedGraphicsDetail

ModelingSettings interface

Major

SoftwareVersion interface

MajorAxis

EllipticalArc interface

EllipticalArc2d interface

MajorAxisVector

EllipseFull interface

EllipseFull2d interface

EllipticalCone interface

EllipticalCylinder interface

SketchEllipse interface

SketchEllipse3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

MajorDiameterMax

StandardThreadInfo interface

MajorDiameterMin

StandardThreadInfo interface

Majority

SurfaceTextureSymbol interface

MajorRadius

EllipseRadiusDimConstraint interface

EllipticalArc interface

EllipticalArc2d interface

SketchEllipse interface

SketchEllipse3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

Torus interface

Manufacturer

ContentFamily interface

MappedColor

GraphicsColorMapper interface

MapPointCurve interface

Application

Delete

GetPosition

GetPositionPoint

PointCount

SetPosition

SetPositionUsingPoint

Type

MapPointCurve.Application property

MapPointCurve.Delete method

MapPointCurve.GetPosition method

MapPointCurve.GetPositionPoint method

MapPointCurve.PointCount property

MapPointCurve.SetPosition method

MapPointCurve.SetPositionUsingPoint method

MapPointCurve.Type property

MapPointCurves

LoftDefinition interface

MapPointCurves interface

AddMapCurve

Application

Count

Item

Type

MapPointCurves.AddMapCurve method

MapPointCurves.Application property

MapPointCurves.Count property

MapPointCurves.Item method

MapPointCurves.Type property

MarkSize

CentermarkStyle interface

MaskColor

TextureMap interface

Mass

MassProperties interface

MassOverridden

MassProperties interface

MassProperties

AssemblyComponentDefinition interface

ComponentOccurrence interface

FlatPattern interface

PartComponentDefinition interface

MassProperties interface

Accuracy

AchievedAccuracy

Area

AvailableAccuracy

CacheResultsOnCompute

CenterOfMass

IncludeCosmeticWelds

IncludeQuantityOverrides

Mass

MassOverridden

PrincipalMomentsOfInertia

RadiusOfGyration

RotationToPrincipal

Type

Volume

VolumeOverridden

XYZMomentsOfInertia

MassProperties.Accuracy property

MassProperties.AchievedAccuracy method

MassProperties.Area property

MassProperties.AvailableAccuracy property

MassProperties.CacheResultsOnCompute property

MassProperties.CenterOfMass property

MassProperties.IncludeCosmeticWelds property

MassProperties.IncludeQuantityOverrides property

MassProperties.Mass property

MassProperties.MassOverridden property

MassProperties.PrincipalMomentsOfInertia method

MassProperties.RadiusOfGyration method

MassProperties.RotationToPrincipal method

MassProperties.Type property

MassProperties.Volume property

MassProperties.VolumeOverridden property

MassProperties.XYZMomentsOfInertia method

MassUnits

UnitsOfMeasure interface

Master

PositionalRepresentation interface

MatchCustomHoles

HoleTable interface

MatchList

iMateDefinition interface

MatchShape

ExtrudeDefinition interface

MateConstraint interface

ConstraintLimits

EntityOneInferredType

EntityTwoInferredType

Offset

MateConstraint.ConstraintLimits property

MateConstraint.EntityOneInferredType property

MateConstraint.EntityTwoInferredType property

MateConstraint.Offset property

MateConstraintProxy interface

ContainingOccurrence

NativeObject

MateConstraintProxy.ContainingOccurrence property

MateConstraintProxy.NativeObject property

MateiMateDefinition interface

ConstraintLimits

Entity

EntityInferredType

Offset

MateiMateDefinition.ConstraintLimits property

MateiMateDefinition.Entity property

MateiMateDefinition.EntityInferredType property

MateiMateDefinition.Offset property

MateiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

MateiMateDefinitionProxy.ContainingOccurrence property

MateiMateDefinitionProxy.IsConsumed property

MateiMateDefinitionProxy.NativeObject property

Material

PartComponentDefinition interface

SheetMetalStyle interface

VirtualComponentDefinition interface

WeldmentComponentDefinition interface

Material interface

Application

AttributeSets

ConvertToLocal

Copy

Delete

Density

ExternalMaterialId

GetReferenceKey

InternalName

InUse

LinearExpansion

Name

Parent

PoissonsRatio

RenderStyle

SaveToGlobal

SpecificHeat

StyleLocation

ThermalConductivity

Type

UltimateTensileStrength

UpdateFromGlobal

UpToDate

YieldStrength

YoungsModulus

Material.Application property

Material.AttributeSets property

Material.ConvertToLocal method

Material.Copy method

Material.Delete method

Material.Density property

Material.ExternalMaterialId property

Material.GetReferenceKey method

Material.InternalName property

Material.InUse property

Material.LinearExpansion property

Material.Name property

Material.Parent property

Material.PoissonsRatio property

Material.RenderStyle property

Material.SaveToGlobal method

Material.SpecificHeat property

Material.StyleLocation property

Material.ThermalConductivity property

Material.Type property

Material.UltimateTensileStrength property

Material.UpdateFromGlobal method

Material.UpToDate property

Material.YieldStrength property

Material.YoungsModulus property

MaterialColumn

iPartFactory interface

Materials

AssemblyDocument interface

PartDocument interface

StylesManager interface

Materials interface

Add

Application

Count

Item

Parent

Type

Materials.Add method

Materials.Application property

Materials.Count property

Materials.Item method

Materials.Parent property

Materials.Type property

MaterialsEnumerator interface

Application

Count

Item

Type

MaterialsEnumerator.Application property

MaterialsEnumerator.Count property

MaterialsEnumerator.Item method

MaterialsEnumerator.Type property

Matrix interface

Cell

Determinant

GetCoordinateSystem

GetMatrixData

Invert

IsEqualTo

PostMultiplyBy

PreMultiplyBy

PutMatrixData

SetCoordinateSystem

SetToAlignCoordinateSystems

SetToIdentity

SetToRotateTo

SetToRotation

SetTranslation

TransformBy

Translation

Matrix.Cell method

Matrix.Determinant property

Matrix.GetCoordinateSystem method

Matrix.GetMatrixData method

Matrix.Invert method

Matrix.IsEqualTo method

Matrix.PostMultiplyBy method

Matrix.PreMultiplyBy method

Matrix.PutMatrixData method

Matrix.SetCoordinateSystem method

Matrix.SetToAlignCoordinateSystems method

Matrix.SetToIdentity method

Matrix.SetToRotateTo method

Matrix.SetToRotation method

Matrix.SetTranslation method

Matrix.TransformBy method

Matrix.Translation property

Matrix2d interface

Cell

Determinant

GetCoordinateSystem

GetMatrixData

Invert

IsEqualTo

PostMultiplyBy

PreMultiplyBy

PutMatrixData

SetCoordinateSystem

SetToAlignCoordinateSystems

SetToIdentity

SetToRotateTo

SetToRotation

SetTranslation

TransformBy

Translation

Matrix2d.Cell method

Matrix2d.Determinant property

Matrix2d.GetCoordinateSystem method

Matrix2d.GetMatrixData method

Matrix2d.Invert method

Matrix2d.IsEqualTo method

Matrix2d.PostMultiplyBy method

Matrix2d.PreMultiplyBy method

Matrix2d.PutMatrixData method

Matrix2d.SetCoordinateSystem method

Matrix2d.SetToAlignCoordinateSystems method

Matrix2d.SetToIdentity method

Matrix2d.SetToRotateTo method

Matrix2d.SetToRotation method

Matrix2d.SetTranslation method

Matrix2d.TransformBy method

Matrix2d.Translation property

Maximum

ConstraintLimits interface

MaximumEnabled

ConstraintLimits interface

MaximumRoughness

SurfaceTextureSymbol interface

MaximumRows

CustomTable interface

PartsList interface

RevisionTable interface

MaximumTolerance

KnitFeature interface

MaximumValue

ExpressionLimits interface

MiniToolbarValueEditorObject interface

MaximumValueComparisonType

ExpressionLimits interface

MaxPoint

Box interface

Box2d interface

Measure

MeasureEventsObject interface

MeasureEvents

InteractionEventsObject interface

MeasureEvents coclass

MeasureEventsObject interface

Application

Enabled

ListParameters

Measure

Parent

ShowDimensions

Type

MeasureEventsObject.Application property

MeasureEventsObject.Enabled property

MeasureEventsObject.ListParameters method

MeasureEventsObject.Measure method

MeasureEventsObject.Parent property

MeasureEventsObject.ShowDimensions method

MeasureEventsObject.Type property

MeasureEventsSink interface

OnMeasure

OnSelectParameter

MeasureEventsSink.OnMeasure method

MeasureEventsSink.OnSelectParameter method

MeasureTools interface

Application

GetAngle

GetLoopLength

GetMinimumDistance

Parent

Type

MeasureTools.Application property

MeasureTools.GetAngle method

MeasureTools.GetLoopLength method

MeasureTools.GetMinimumDistance method

MeasureTools.Parent property

MeasureTools.Type property

MediumType

DataMedium interface

MemberCacheDir

iAssemblyFactory interface

iPartFactory interface

MemberDirectory

ContentFamily interface

MemberEditScope

iAssemblyFactory interface

iPartFactory interface

MemberName

iAssemblyTableRow interface

iFeatureTableRow interface

iPartTableRow interface

MemberNameIndexDigits

FactoryOptions interface

MemberNameIndexInitialValue

FactoryOptions interface

MemberNameIndexSeparator

FactoryOptions interface

MemberNameIndexStepValue

FactoryOptions interface

MemberNameType

FactoryOptions interface

MemberNameValue

FactoryOptions interface

Members

BaselineDimensionSet interface

ChainDimensionSet interface

OrdinateDimensionSet interface

MembersToInclude

PartsList interface

MemberType

InventorVBAMember interface

MemorySavingMode

DrawingOptions interface

DrawingSettings interface

Merge

SketchPoint interface

Merged

BOMRow interface

MergeDatum

FeatureControlFrameStyle interface

MergeFaces

Profile interface

MergeMembers

ChainDimensionSet interface

MergeSymbol

FeatureControlFrameStyle interface

MergeTangentFaces

LoftDefinition interface

MergeTolerance

FeatureControlFrameStyle interface

MergeWithPrevious

ChangeProcessorObject interface

Transaction interface

Message

BalloonTipObject interface

ProgressBarObject interface

MessageDialogUserChoice

ChangeProcessorObject interface

MessageSection interface

AdoptMessages

Application

ClearMessages

End

HasErrors

HasWarnings

Parent

Type

MessageSection.AdoptMessages method

MessageSection.Application property

MessageSection.ClearMessages method

MessageSection.End method

MessageSection.HasErrors property

MessageSection.HasWarnings property

MessageSection.Parent property

MessageSection.Type property

Metric

ThreadInfo interface

MidPlanePattern

CircularPatternFeature interface

MidPoint

BreakOperation interface

DrawingCurve interface

LineSegment interface

LineSegment2d interface

MidpointConstraint interface

Line

Point

MidpointConstraint.Line property

MidpointConstraint.Point property

MidpointConstraint3D interface

Line

Point

MidpointConstraint3D.Line property

MidpointConstraint3D.Point property

MidpointConstraint3DProxy interface

ContainingOccurrence

NativeObject

MidpointConstraint3DProxy.ContainingOccurrence property

MidpointConstraint3DProxy.NativeObject property

MidpointConstraintProxy interface

ContainingOccurrence

NativeObject

MidpointConstraintProxy.ContainingOccurrence property

MidpointConstraintProxy.NativeObject property

MidPointWorkPointDef interface

Application

Edge

Parent

Type

MidPointWorkPointDef.Application property

MidPointWorkPointDef.Edge property

MidPointWorkPointDef.Parent property

MidPointWorkPointDef.Type property

MinimalSetback

FilletSetbackVertex interface

Minimum

ConstraintLimits interface

MinimumEnabled

ConstraintLimits interface

MinimumFrameRate

DisplayOptions interface

MinimumRemnant

BendOptions interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

MinimumRoughness

SurfaceTextureSymbol interface

MinimumSolution

FromToExtent interface

ToExtent interface

MinimumValue

ExpressionLimits interface

MiniToolbarValueEditorObject interface

MinimumValueComparisonType

ExpressionLimits interface

MiniToolbarButtonObject interface

Pressed

MiniToolbarButtonObject.Pressed property

MiniToolbarButtonSink interface

OnClick

MiniToolbarButtonSink.OnClick method

MiniToolbarCheckBoxObject interface

Checked

MiniToolbarCheckBoxObject.Checked property

MiniToolbarCheckBoxSink interface

OnClick

MiniToolbarCheckBoxSink.OnClick method

MiniToolbarComboBoxObject interface

AddItem

Clear

Count

Item

RemoveItem

SelectedIndex

SelectedItem

ShowIcon

ShowText

Width

MiniToolbarComboBoxObject.AddItem method

MiniToolbarComboBoxObject.Clear method

MiniToolbarComboBoxObject.Count property

MiniToolbarComboBoxObject.Item method

MiniToolbarComboBoxObject.RemoveItem method

MiniToolbarComboBoxObject.SelectedIndex property

MiniToolbarComboBoxObject.SelectedItem property

MiniToolbarComboBoxObject.ShowIcon property

MiniToolbarComboBoxObject.ShowText property

MiniToolbarComboBoxObject.Width property

MiniToolbarComboBoxSink interface

OnItemHoverEnd

OnItemHoverStart

OnItemRemove

OnPreMenuDisplay

OnSelect

MiniToolbarComboBoxSink.OnItemHoverEnd method

MiniToolbarComboBoxSink.OnItemHoverStart method

MiniToolbarComboBoxSink.OnItemRemove method

MiniToolbarComboBoxSink.OnPreMenuDisplay method

MiniToolbarComboBoxSink.OnSelect method

MiniToolbarControl interface

Application

AutoHide

ControlType

Delete

DisplayName

Enabled

Index

InternalName

LargeIcon

Parent

StandardIcon

ToolTipText

Type

Visible

MiniToolbarControl.Application property

MiniToolbarControl.AutoHide property

MiniToolbarControl.ControlType property

MiniToolbarControl.Delete method

MiniToolbarControl.DisplayName property

MiniToolbarControl.Enabled property

MiniToolbarControl.Index property

MiniToolbarControl.InternalName property

MiniToolbarControl.LargeIcon property

MiniToolbarControl.Parent property

MiniToolbarControl.StandardIcon property

MiniToolbarControl.ToolTipText property

MiniToolbarControl.Type property

MiniToolbarControl.Visible property

MiniToolbarControls interface

AddButton

AddCheckBox

AddComboBox

AddDropdown

AddLabel

AddNewLine

AddSeparator

AddValueEditor

Application

Count

Item

Type

MiniToolbarControls.AddButton method

MiniToolbarControls.AddCheckBox method

MiniToolbarControls.AddComboBox method

MiniToolbarControls.AddDropdown method

MiniToolbarControls.AddLabel method

MiniToolbarControls.AddNewLine method

MiniToolbarControls.AddSeparator method

MiniToolbarControls.AddValueEditor method

MiniToolbarControls.Application property

MiniToolbarControls.Count property

MiniToolbarControls.Item method

MiniToolbarControls.Type property

MiniToolbarDropdownObject interface

AddItem

AddSeparator

Clear

Count

HasMRUBehavior

IsSplitButton

Item

Pressed

RemoveItem

SelectedIndex

SelectedItem

ShowIcon

ShowText

MiniToolbarDropdownObject.AddItem method

MiniToolbarDropdownObject.AddSeparator method

MiniToolbarDropdownObject.Clear method

MiniToolbarDropdownObject.Count property

MiniToolbarDropdownObject.HasMRUBehavior property

MiniToolbarDropdownObject.IsSplitButton property

MiniToolbarDropdownObject.Item method

MiniToolbarDropdownObject.Pressed property

MiniToolbarDropdownObject.RemoveItem method

MiniToolbarDropdownObject.SelectedIndex property

MiniToolbarDropdownObject.SelectedItem property

MiniToolbarDropdownObject.ShowIcon property

MiniToolbarDropdownObject.ShowText property

MiniToolbarDropdownSink interface

OnItemHoverEnd

OnItemHoverStart

OnItemRemove

OnPreMenuDisplay

OnSelect

MiniToolbarDropdownSink.OnItemHoverEnd method

MiniToolbarDropdownSink.OnItemHoverStart method

MiniToolbarDropdownSink.OnItemRemove method

MiniToolbarDropdownSink.OnPreMenuDisplay method

MiniToolbarDropdownSink.OnSelect method

MiniToolbarListItem interface

AllowDelete

Index

InternalName

IsChecked

IsSeperator

LargeIcon

ShowCheckBox

StandardIcon

Text

ToolTipText

MiniToolbarListItem.AllowDelete property

MiniToolbarListItem.Index property

MiniToolbarListItem.InternalName property

MiniToolbarListItem.IsChecked property

MiniToolbarListItem.IsSeperator property

MiniToolbarListItem.LargeIcon property

MiniToolbarListItem.ShowCheckBox property

MiniToolbarListItem.StandardIcon property

MiniToolbarListItem.Text property

MiniToolbarListItem.ToolTipText property

MiniToolbarObject interface

Application

Controls

Delete

EnableApply

EnableOK

Parent

Position

ShowApply

ShowCancel

ShowOK

ShowOptionBox

Type

Visible

MiniToolbarObject.Application property

MiniToolbarObject.Controls property

MiniToolbarObject.Delete method

MiniToolbarObject.EnableApply property

MiniToolbarObject.EnableOK property

MiniToolbarObject.Parent property

MiniToolbarObject.Position property

MiniToolbarObject.ShowApply property

MiniToolbarObject.ShowCancel property

MiniToolbarObject.ShowOK property

MiniToolbarObject.ShowOptionBox property

MiniToolbarObject.Type property

MiniToolbarObject.Visible property

MiniToolbarSink interface

OnApply

OnCancel

OnOK

MiniToolbarSink.OnApply method

MiniToolbarSink.OnCancel method

MiniToolbarSink.OnOK method

MiniToolbarValueEditorObject interface

AllowToleranceEdit

Expression

IsExpressionValid

MaximumValue

MinimumValue

ModelValueType

MostRecentValues

Precision

SetFocus

Tolerance

UnitsType

Value

Width

MiniToolbarValueEditorObject.AllowToleranceEdit property

MiniToolbarValueEditorObject.Expression property

MiniToolbarValueEditorObject.IsExpressionValid property

MiniToolbarValueEditorObject.MaximumValue property

MiniToolbarValueEditorObject.MinimumValue property

MiniToolbarValueEditorObject.ModelValueType property

MiniToolbarValueEditorObject.MostRecentValues property

MiniToolbarValueEditorObject.Precision property

MiniToolbarValueEditorObject.SetFocus method

MiniToolbarValueEditorObject.Tolerance property

MiniToolbarValueEditorObject.UnitsType property

MiniToolbarValueEditorObject.Value property

MiniToolbarValueEditorObject.Width property

MiniToolbarValueEditorSink interface

OnChange

OnEnter

OnExit

MiniToolbarValueEditorSink.OnChange method

MiniToolbarValueEditorSink.OnEnter method

MiniToolbarValueEditorSink.OnExit method

Minor

SoftwareVersion interface

MinorAxis

EllipticalArc interface

MinorDiameterMax

StandardThreadInfo interface

MinorDiameterMin

StandardThreadInfo interface

MinorGridLineSpacing

GroundPlaneSettings interface

MinorLinesPerMajorGridLine

GroundPlaneSettings interface

SketchSettings interface

MinorMajorRatio

EllipseFull interface

EllipseFull2d interface

EllipticalCone interface

EllipticalCylinder interface

MinorRadius

EllipticalArc interface

EllipticalArc2d interface

SketchEllipse interface

SketchEllipse3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

Torus interface

MinPoint

Box interface

Box2d interface

MirrorFeature interface

AddParticipant

ComputeType

MirrorOfBody

MirrorPlaneEntity

NewBodyOperation

ParentFeatures

PatternElements

ResultFeatures

SurfacesOpaque

SurfacesVisible

MirrorFeature.AddParticipant method

MirrorFeature.ComputeType property

MirrorFeature.MirrorOfBody property

MirrorFeature.MirrorPlaneEntity property

MirrorFeature.NewBodyOperation property

MirrorFeature.ParentFeatures property

MirrorFeature.PatternElements property

MirrorFeature.ResultFeatures property

MirrorFeature.SurfacesOpaque property

MirrorFeature.SurfacesVisible property

MirrorFeatureProxy interface

ContainingOccurrence

NativeObject

MirrorFeatureProxy.ContainingOccurrence property

MirrorFeatureProxy.NativeObject property

MirrorFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

MirrorFeatures interface

Add

Application

Count

Item

Type

MirrorFeatures.Add method

MirrorFeatures.Application property

MirrorFeatures.Count property

MirrorFeatures.Item method

MirrorFeatures.Type property

MirrorHorizontal

SketchImage interface

MirrorOfBody

MirrorFeature interface

MirrorPlane

DerivedAssemblyDefinition interface

DerivedPartCoordinateSystemDef interface

DerivedPartUniformScaleDef interface

MirrorPlaneEntity

MirrorFeature interface

MirrorVertical

SketchImage interface

MiterGap

ContourFlangeDefinition interface

FlangeDefinition interface

ModelGeometry

DrawingCurve interface

ModelGeometryVersion

ComponentDefinition interface

ModelingEvents coclass

ModelingEventsObject interface

Application

Parent

Type

ModelingEventsObject.Application property

ModelingEventsObject.Parent property

ModelingEventsObject.Type property

ModelingEventsSink interface

OnClientFeatureDoubleClick

OnDelete

OnFeatureChange

OnGenerateMember

OnNewFeature

OnNewParameter

OnParameterChange

ModelingEventsSink.OnClientFeatureDoubleClick method

ModelingEventsSink.OnDelete method

ModelingEventsSink.OnFeatureChange method

ModelingEventsSink.OnGenerateMember method

ModelingEventsSink.OnNewFeature method

ModelingEventsSink.OnNewParameter method

ModelingEventsSink.OnParameterChange method

ModelingSettings

AssemblyDocument interface

PartDocument interface

ModelingSettings interface

AdaptivelyUsedInAssembly

AdvancedFeatureValidation

AllowSectioningThruPart

Application

CompactModelHistory

InitialDrawingViewHeight

InitialDrawingViewWidth

InteractiveContactAnalysis

InteractiveContactSurfaces

MaintainEnhancedGraphicsDetail

Parent

Snap3DAngle

Snap3DDistance

SolidBodyNamePrefix

SurfaceBodyNamePrefix

TappedHoleDiameter

Type

UpdateLegacyHoles

UserCoordinateSystemSettings

ModelingSettings.AdaptivelyUsedInAssembly property

ModelingSettings.AdvancedFeatureValidation property

ModelingSettings.AllowSectioningThruPart property

ModelingSettings.Application property

ModelingSettings.CompactModelHistory property

ModelingSettings.InitialDrawingViewHeight property

ModelingSettings.InitialDrawingViewWidth property

ModelingSettings.InteractiveContactAnalysis property

ModelingSettings.InteractiveContactSurfaces property

ModelingSettings.MaintainEnhancedGraphicsDetail property

ModelingSettings.Parent property

ModelingSettings.Snap3DAngle property

ModelingSettings.Snap3DDistance property

ModelingSettings.SolidBodyNamePrefix property

ModelingSettings.SurfaceBodyNamePrefix property

ModelingSettings.TappedHoleDiameter property

ModelingSettings.Type property

ModelingSettings.UpdateLegacyHoles property

ModelingSettings.UserCoordinateSystemSettings property

ModelParameter interface

BuiltIn

ConvertToReferenceParameter

ConvertToUserParameter

Renamed

ModelParameter.BuiltIn property

ModelParameter.ConvertToReferenceParameter method

ModelParameter.ConvertToUserParameter method

ModelParameter.Renamed property

ModelParameters

Parameters interface

ModelParameters interface

_AddByValue

AddByExpression

AddByValue

Count

Item

Type

ModelParameters._AddByValue method

ModelParameters.AddByExpression method

ModelParameters.AddByValue method

ModelParameters.Count property

ModelParameters.Item method

ModelParameters.Type property

ModelProperties

BIMComponentDescription interface

ModelSpaceCurve

EdgeDefinition interface

ModelToDrawingViewSpace

DrawingView interface

ModelToDrawingViewTransform

DrawingView interface

ModelToSheetSpace

DrawingView interface

ModelToSheetTransform

DrawingView interface

ModelToSketchSpace

PlanarSketch interface

ModelToSketchTransform

PlanarSketch interface

ModelToViewSpace

Camera interface

ModelValue

DrawingDimension interface

Parameter interface

ModelValueOverridden

DrawingDimension interface

ModelValueType

MiniToolbarValueEditorObject interface

Parameter interface

ModelWorkFeature

Centerline interface

Centermark interface

MomentsOfInertia

RegionProperties interface

MostRecentValues

MiniToolbarValueEditorObject interface

MouseEvents

InteractionEventsObject interface

MouseEvents coclass

MouseEventsObject interface

Application

MouseMoveEnabled

Parent

PointInferenceEnabled

PointInferences

Type

MouseEventsObject.Application property

MouseEventsObject.MouseMoveEnabled property

MouseEventsObject.Parent property

MouseEventsObject.PointInferenceEnabled property

MouseEventsObject.PointInferences property

MouseEventsObject.Type property

MouseEventsSink interface

OnMouseClick

OnMouseDoubleClick

OnMouseDown

OnMouseLeave

OnMouseMove

OnMouseUp

MouseEventsSink.OnMouseClick method

MouseEventsSink.OnMouseDoubleClick method

MouseEventsSink.OnMouseDown method

MouseEventsSink.OnMouseLeave method

MouseEventsSink.OnMouseMove method

MouseEventsSink.OnMouseUp method

MouseMoveEnabled

MouseEventsObject interface

SelectEventsObject interface

Move

Application interface

DockableWindow interface

RibbonPanel interface

View interface

MoveBy

SketchPoint interface

SketchPoint3D interface

MoveFaceDefinition interface

Application

AutomaticBlending

Copy

Faces

MoveFaceType

MoveFaceTypeDefinition

Parent

SetDirectionAndDistanceMoveType

SetFreeMoveType

SetPlanarMoveType

Type

MoveFaceDefinition.Application property

MoveFaceDefinition.AutomaticBlending property

MoveFaceDefinition.Copy method

MoveFaceDefinition.Faces property

MoveFaceDefinition.MoveFaceType property

MoveFaceDefinition.MoveFaceTypeDefinition property

MoveFaceDefinition.Parent property

MoveFaceDefinition.SetDirectionAndDistanceMoveType method

MoveFaceDefinition.SetFreeMoveType method

MoveFaceDefinition.SetPlanarMoveType method

MoveFaceDefinition.Type property

MoveFaceFeature interface

Definition

MoveFaceFeature.Definition property

MoveFaceFeatureProxy interface

ContainingOccurrence

NativeObject

MoveFaceFeatureProxy.ContainingOccurrence property

MoveFaceFeatureProxy.NativeObject property

MoveFaceFeatures

Features interface

PartFeatures interface

MoveFaceFeatures interface

Add

Application

Count

CreateDefinition

Item

Type

MoveFaceFeatures.Add method

MoveFaceFeatures.Application property

MoveFaceFeatures.Count property

MoveFaceFeatures.CreateDefinition method

MoveFaceFeatures.Item method

MoveFaceFeatures.Type property

MoveFaceType

MoveFaceDefinition interface

MoveFaceTypeDefinition

MoveFaceDefinition interface

MoveFeature interface

Transformation

MoveFeature.Transformation property

MoveFeatureProxy interface

ContainingOccurrence

NativeObject

MoveFeatureProxy.ContainingOccurrence property

MoveFeatureProxy.NativeObject property

MoveFeatures

PartFeatures interface

MoveFeatures interface

Application

Count

Item

Type

MoveFeatures.Application property

MoveFeatures.Count property

MoveFeatures.Item method

MoveFeatures.Type property

MoveFile

FileManager interface

MoveNext

EnumType interface

MoveSketchObjects

Sketch interface

MoveTo

DrawingView interface

SketchPoint interface

SketchPoint3D interface

MoveTriadOnly

TriadEventsObject interface

MoveTriadOnlyEnabled

TriadEventsObject interface

MRUDisplay

Application interface

MRUEnabled

Application interface

MultiSelectEnabled

FileDialog interface

MultiUserExternallyManaged

ApprenticeServer interface

GeneralPreferences interface

MultiUserMode

ApprenticeServer interface

GeneralPreferences interface

N

Name

AssemblyConstraint interface

Attribute interface

AttributeSet interface

AutoCADBlock interface

AutoCADBlockDefinition interface

BIMComponentProperty interface

BIMComponentPropertySet interface

BIMConnector interface

BIMConnectorLink interface

BOMView interface

Border interface

BorderDefinition interface

BrowserFolder interface

BrowserPaneObject interface

ColorScheme interface

ComponentOccurrence interface

DerivedAssemblyOccurrence interface

DesignProject interface

DesignViewRepresentation interface

DocumentInterest interface

DraftAnalysis interface

DraftingStandard interface

DrawingView interface

EnumType interface

IAnimation interface

iFeatureInput interface

iMateDefinition interface

iMateResult interface

InteractionEventsObject interface

InventorVBAArgument interface

InventorVBAComponent interface

InventorVBAMember interface

InventorVBAProject interface

IStudioCamera interface

IStudioLightingStyle interface

IStudioSceneStyle interface

LayoutConstraint interface

LevelOfDetailRepresentation interface

LightingStyle interface

Material interface

NameValueMap interface

OccurrencePattern interface

OccurrencePatternElement interface

Parameter interface

PartFeature interface

PositionalRepresentation interface

PresentationExplodedView interface

ProjectedCut interface

ProjectPath interface

Property interface

PropertySet interface

ReferenceComponent interface

RenderStyle interface

Sheet interface

SheetFormat interface

SilhouetteCurve interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchImage interface

Style interface

SurfaceBody interface

TitleBlock interface

TitleBlockDefinition interface

UserCoordinateSystem interface

Weld interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

NameIsUsed

AttributeSet interface

AttributeSets interface

NameValueMap interface

Add

Clear

Count

Insert

Item

Name

Remove

Value

NameValueMap.Add method

NameValueMap.Clear method

NameValueMap.Count property

NameValueMap.Insert method

NameValueMap.Item method

NameValueMap.Name method

NameValueMap.Remove method

NameValueMap.Value method

NamingPrefix

UserCoordinateSystemSettings interface

NativeBrowserNodeDefinition coclass

NativeBrowserNodeDefinitionObject interface

ExpandedIcon

Icon

NativeObject

OverrideExpandedIcon

OverrideIcon

NativeBrowserNodeDefinitionObject.ExpandedIcon property

NativeBrowserNodeDefinitionObject.Icon property

NativeBrowserNodeDefinitionObject.NativeObject property

NativeBrowserNodeDefinitionObject.OverrideExpandedIcon property

NativeBrowserNodeDefinitionObject.OverrideIcon property

NativeObject

AngleConstraintProxy interface

AngleiMateDefinitionProxy interface

BendConstraintProxy interface

BendPartFeatureProxy interface

BossFeatureProxy interface

BoundaryPatchFeatureProxy interface

BrowserNode interface

ChamferFeatureProxy interface

CircularOccurrencePatternProxy interface

CircularPatternFeatureProxy interface

ClientFeatureElementProxy interface

ClientFeatureProxy interface

CoilFeatureProxy interface

CoincidentConstraint3DProxy interface

CoincidentConstraintProxy interface

CollinearConstraint3DProxy interface

CollinearConstraintProxy interface

CombineFeatureProxy interface

ComponentOccurrenceProxy interface

CompositeiMateDefinitionProxy interface

ConcentricConstraint3DProxy interface

ConcentricConstraintProxy interface

CustomConstraint3DProxy interface

CustomConstraintProxy interface

DecalFeatureProxy interface

DeleteFaceFeatureProxy interface

DerivedAliasComponentProxy interface

DerivedAssemblyComponentProxy interface

DerivedPartComponentProxy interface

DiameterDimConstraintProxy interface

EdgeLoopProxy interface

EdgeProxy interface

EdgeUseProxy interface

EllipseRadiusDimConstraintProxy interface

EmbossFeatureProxy interface

EqualLengthConstraintProxy interface

EqualRadiusConstraintProxy interface

ExtendFeatureProxy interface

ExtrudeFeatureProxy interface

FaceDraftFeatureProxy interface

FaceProxy interface

FaceShellProxy interface

FeatureBasedOccurrencePatternProxy interface

FeatureDimensionProxy interface

FeaturePatternElementProxy interface

FilletFeatureProxy interface

FlushConstraintProxy interface

FlushiMateDefinitionProxy interface

GraphicsNodeProxy interface

GrillFeatureProxy interface

GroundConstraint3DProxy interface

GroundConstraintProxy interface

HelicalConstraint3DProxy interface

HoleFeatureProxy interface

HorizontalAlignConstraintProxy interface

HorizontalConstraintProxy interface

iFeatureProxy interface

iMateResultProxy interface

InsertConstraintProxy interface

InsertiMateDefinitionProxy interface

KnitFeatureProxy interface

LayoutConstraintProxy interface

LineLengthDimConstraint3DProxy interface

LipFeatureProxy interface

LoftFeatureProxy interface

MateConstraintProxy interface

MateiMateDefinitionProxy interface

MidpointConstraint3DProxy interface

MidpointConstraintProxy interface

MirrorFeatureProxy interface

MoveFaceFeatureProxy interface

MoveFeatureProxy interface

NativeBrowserNodeDefinitionObject interface

NonParametricBaseFeatureProxy interface

OccurrencePatternElementProxy interface

OffsetConstraintProxy interface

OffsetDimConstraintProxy interface

OffsetSplineDimConstraintProxy interface

ParallelConstraint3DProxy interface

ParallelConstraintProxy interface

PathEntityProxy interface

PathProxy interface

PatternConstraintProxy interface

PerpendicularConstraint3DProxy interface

PerpendicularConstraintProxy interface

PlanarSketchProxy interface

PointAndPlaneDistanceDimConstraint3DProxy interface

Profile3DProxy interface

ProfileEntity3DProxy interface

ProfileEntityProxy interface

ProfilePath3DProxy interface

ProfilePathProxy interface

ProfileProxy interface

ProjectedCutProxy interface

RadiusDimConstraint3DProxy interface

RadiusDimConstraintProxy interface

RectangularOccurrencePatternProxy interface

RectangularPatternFeatureProxy interface

ReferenceFeatureProxy interface

ReplaceFaceFeatureProxy interface

RestFeatureProxy interface

RevolveFeatureProxy interface

RibFeatureProxy interface

RotateRotateConstraintProxy interface

RotateRotateiMateDefinitionProxy interface

RotateTranslateConstraintProxy interface

RotateTranslateiMateDefinitionProxy interface

RuleFilletFeatureProxy interface

SculptFeatureProxy interface

ShellFeatureProxy interface

Sketch3DProxy interface

SketchArc3DProxy interface

SketchArcProxy interface

SketchBlockDefinitionProxy interface

SketchBlockProxy interface

SketchCircle3DProxy interface

SketchCircleProxy interface

SketchEllipse3DProxy interface

SketchEllipseProxy interface

SketchEllipticalArc3DProxy interface

SketchEllipticalArcProxy interface

SketchFixedSpline3DProxy interface

SketchFixedSplineProxy interface

SketchImageProxy interface

SketchLine3DProxy interface

SketchLineProxy interface

SketchOffsetSplineProxy interface

SketchPoint3DProxy interface

SketchPointProxy interface

SketchSpline3DProxy interface

SketchSplineHandle3DProxy interface

SketchSplineHandleProxy interface

SketchSplineProxy interface

SmoothConstraint3DProxy interface

SmoothConstraintProxy interface

SnapFitFeatureProxy interface

SplineFitPointConstraintProxy interface

SplineFitPointsConstraint3DProxy interface

SplitFeatureProxy interface

SurfaceBodyProxy interface

SweepFeatureProxy interface

SymmetryConstraintProxy interface

TangentConstraint3DProxy interface

TangentConstraintProxy interface

TangentDistanceDimConstraintProxy interface

TangentiMateDefinitionProxy interface

TangentSketchConstraintProxy interface

TextBoxConstraintProxy interface

TextBoxProxy interface

ThickenFeatureProxy interface

ThreadFeatureProxy interface

ThreePointAngleDimConstraintProxy interface

TransitionalConstraintProxy interface

TranslateTranslateConstraintProxy interface

TrimFeatureProxy interface

TwoLineAngleDimConstraint3DProxy interface

TwoLineAngleDimConstraintProxy interface

TwoPointDistanceDimConstraint3DProxy interface

TwoPointDistanceDimConstraintProxy interface

UserCoordinateSystemProxy interface

VertexProxy interface

VerticalAlignConstraintProxy interface

VerticalConstraintProxy interface

WorkAxisProxy interface

WorkPlaneProxy interface

WorkPointProxy interface

WorkSurfaceProxy interface

NaturalAxisDirection

CircularPatternFeature interface

PlanarSketch interface

NaturalXDirection

RectangularPatternFeature interface

NaturalYDirection

RectangularPatternFeature interface

NeedsMigrating

ApprenticeServerDocument interface

Document interface

NewBodyOperation

CircularPatternFeature interface

MirrorFeature interface

RectangularPatternFeature interface

NewWindowDisplayMode

DisplayOptions interface

DisplaySettings interface

NewWindowProjectionType

DisplayOptions interface

DisplaySettings interface

NewWindowShowAmbientShadows

DisplayOptions interface

DisplaySettings interface

NewWindowShowGroundPlane

DisplayOptions interface

DisplaySettings interface

NewWindowShowGroundReflections

DisplayOptions interface

DisplaySettings interface

NewWindowShowGroundShadows

DisplayOptions interface

DisplaySettings interface

NewWindowShowObjectShadows

DisplayOptions interface

DisplaySettings interface

Next

EdgeUse interface

NominalDiameter

BIMPipeConnectorDefinition interface

NominalExternalDiameter

TaperedThreadInfo interface

NominalExternalLength

TaperedThreadInfo interface

NominalSize

StandardThreadInfo interface

NonLinearEdgeWorkPointDef interface

Application

Edge

Parent

Type

NonLinearEdgeWorkPointDef.Application property

NonLinearEdgeWorkPointDef.Edge property

NonLinearEdgeWorkPointDef.Parent property

NonLinearEdgeWorkPointDef.Type property

NonParametricBaseFeature interface

DeleteFaces

Edit

ExitEdit

InputSurfaceBodies

IsAssociative

IsComposite

IsSolid

Redefine

NonParametricBaseFeature.DeleteFaces method

NonParametricBaseFeature.Edit method

NonParametricBaseFeature.ExitEdit method

NonParametricBaseFeature.InputSurfaceBodies property

NonParametricBaseFeature.IsAssociative property

NonParametricBaseFeature.IsComposite property

NonParametricBaseFeature.IsSolid property

NonParametricBaseFeature.Redefine method

NonParametricBaseFeatureDefinition interface

Application

BRepEntities

DeleteOriginal

IsAssociative

OutputType

TargetOccurrence

NonParametricBaseFeatureDefinition.Application property

NonParametricBaseFeatureDefinition.BRepEntities property

NonParametricBaseFeatureDefinition.DeleteOriginal property

NonParametricBaseFeatureDefinition.IsAssociative property

NonParametricBaseFeatureDefinition.OutputType property

NonParametricBaseFeatureDefinition.TargetOccurrence property

NonParametricBaseFeatureProxy interface

ContainingOccurrence

NativeObject

NonParametricBaseFeatureProxy.ContainingOccurrence property

NonParametricBaseFeatureProxy.NativeObject property

NonParametricBaseFeatures

PartFeatures interface

NonParametricBaseFeatures interface

Add

AddByDefinition

Application

Count

CreateDefinition

Item

Type

NonParametricBaseFeatures.Add method

NonParametricBaseFeatures.AddByDefinition method

NonParametricBaseFeatures.Application property

NonParametricBaseFeatures.Count property

NonParametricBaseFeatures.CreateDefinition method

NonParametricBaseFeatures.Item method

NonParametricBaseFeatures.Type property

NonTransacting

ClientGraphics interface

GraphicsDataSets interface

Normal

Arc3d interface

Circle interface

EllipseFull interface

GraphicsNormalSet interface

Plane interface

NormalBinding

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

NormalIndexSet

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

Normalize

Vector interface

Vector2d interface

NormalSet

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

NormalToCurveWorkPlaneDef interface

Application

CurveEntity

GetData

Parent

Point

Type

NormalToCurveWorkPlaneDef.Application property

NormalToCurveWorkPlaneDef.CurveEntity property

NormalToCurveWorkPlaneDef.GetData method

NormalToCurveWorkPlaneDef.Parent property

NormalToCurveWorkPlaneDef.Point property

NormalToCurveWorkPlaneDef.Type property

NormalToSurfaceWorkAxisDef interface

Application

GetData

Parent

Point

SurfaceEntity

Type

NormalToSurfaceWorkAxisDef.Application property

NormalToSurfaceWorkAxisDef.GetData method

NormalToSurfaceWorkAxisDef.Parent property

NormalToSurfaceWorkAxisDef.Point property

NormalToSurfaceWorkAxisDef.SurfaceEntity property

NormalToSurfaceWorkAxisDef.Type property

NorthControl

RadialMarkingMenu interface

NortheastControl

RadialMarkingMenu interface

NorthwestControl

RadialMarkingMenu interface

NotebookOptions interface

Application

ArrowColor

DisplayNoteIcons

DisplayNoteText

KeepNotesOnDeletedObjects

NoteHighlightColor

TextBackgroundColor

Type

NotebookOptions.Application property

NotebookOptions.ArrowColor property

NotebookOptions.DisplayNoteIcons property

NotebookOptions.DisplayNoteText property

NotebookOptions.KeepNotesOnDeletedObjects property

NotebookOptions.NoteHighlightColor property

NotebookOptions.TextBackgroundColor property

NotebookOptions.Type property

NoteHighlightColor

NotebookOptions interface

Notes

FeatureControlFrame interface

NotProduction

SoftwareVersion interface

NumberingScheme

PartsList interface

NumberOfCopies

ApprenticePrintManager interface

PrintManager interface

NumberOfPoles

BIMElectricalConnectorDefinition interface

NumberOfSections

CustomTable interface

PartsList interface

RevisionTable interface

NumberOfSymbols

BreakOperation interface

O

ObjectCollection interface

Add

Clear

Remove

RemoveByObject

ObjectCollection.Add method

ObjectCollection.Clear method

ObjectCollection.Remove method

ObjectCollection.RemoveByObject method

ObjectCollectionByVariant interface

Add

Remove

ObjectCollectionByVariant.Add method

ObjectCollectionByVariant.Remove method

ObjectDefaultsStyle interface

AngularDimensionLayer

AngularDimensionStyle

BalloonLayer

BalloonStyle

BaselineDimensionLayer

BaselineDimensionStyle

BendNoteLayer

BendNoteStyle

BendTableLayer

BendTableStyle

BendTagLayer

BendTagStyle

BorderGeometryLayer

BorderTextLayer

BorderTextStyle

CenterlineLayer

CenterlineStyle

CentermarkLayer

CentermarkStyle

CenterOfGravityLayer

CenterOfGravityStyle

ChainDimensionLayer

ChainDimensionStyle

ChamferNoteLayer

ChamferNoteStyle

ConfigurationTableLayer

ConfigurationTableStyle

DiameterDimensionLayer

DiameterDimensionStyle

FeatureControlFrameLayer

FeatureControlFrameStyle

GeneralNoteLayer

GeneralNoteStyle

HoleNoteLayer

HoleNoteStyle

HoleTableLayer

HoleTableStyle

HoleTagLayer

HoleTagStyle

LeaderTextLayer

LeaderTextStyle

LinearDimensionLayer

LinearDimensionStyle

OrdinateDimensionLayer

OrdinateDimensionSetLayer

OrdinateDimensionStyle

OrdinateSetDimensionStyle

OriginIndicatorLayer

OriginIndicatorStyle

PartsListLayer

PartsListStyle

PunchNoteLayer

PunchNoteStyle

RadialDimensionLayer

RadialDimensionStyle

RevisionTableLayer

RevisionTableStyle

RevisionTagLayer

RevisionTagStyle

SheetMetalPunchLayer

SheetMetalPunchStyle

Sketch3DGeometryLayer

SketchedSymbolGeometryLayer

SketchedSymbolLeaderLayer

SketchedSymbolLeaderStyle

SketchedSymbolTextLayer

SketchedSymbolTextStyle

SketchGeometryLayer

SketchTextLayer

SketchTextStyle

SurfaceTextureLayer

SurfaceTextureStyle

TableLayer

TableStyle

ThreadNoteLayer

ThreadNoteStyle

TitleBlockGeometryLayer

TitleBlockTextLayer

TitleBlockTextStyle

ViewLabelLayer

ViewLabelStyle

WorkAxisLayer

WorkAxisStyle

WorkPlaneLayer

WorkPlaneStyle

WorkPointLayer

WorkPointStyle

ObjectDefaultsStyle.AngularDimensionLayer property

ObjectDefaultsStyle.AngularDimensionStyle property

ObjectDefaultsStyle.BalloonLayer property

ObjectDefaultsStyle.BalloonStyle property

ObjectDefaultsStyle.BaselineDimensionLayer property

ObjectDefaultsStyle.BaselineDimensionStyle property

ObjectDefaultsStyle.BendNoteLayer property

ObjectDefaultsStyle.BendNoteStyle property

ObjectDefaultsStyle.BendTableLayer property

ObjectDefaultsStyle.BendTableStyle property

ObjectDefaultsStyle.BendTagLayer property

ObjectDefaultsStyle.BendTagStyle property

ObjectDefaultsStyle.BorderGeometryLayer property

ObjectDefaultsStyle.BorderTextLayer property

ObjectDefaultsStyle.BorderTextStyle property

ObjectDefaultsStyle.CenterlineLayer property

ObjectDefaultsStyle.CenterlineStyle property

ObjectDefaultsStyle.CentermarkLayer property

ObjectDefaultsStyle.CentermarkStyle property

ObjectDefaultsStyle.CenterOfGravityLayer property

ObjectDefaultsStyle.CenterOfGravityStyle property

ObjectDefaultsStyle.ChainDimensionLayer property

ObjectDefaultsStyle.ChainDimensionStyle property

ObjectDefaultsStyle.ChamferNoteLayer property

ObjectDefaultsStyle.ChamferNoteStyle property

ObjectDefaultsStyle.ConfigurationTableLayer property

ObjectDefaultsStyle.ConfigurationTableStyle property

ObjectDefaultsStyle.DiameterDimensionLayer property

ObjectDefaultsStyle.DiameterDimensionStyle property

ObjectDefaultsStyle.FeatureControlFrameLayer property

ObjectDefaultsStyle.FeatureControlFrameStyle property

ObjectDefaultsStyle.GeneralNoteLayer property

ObjectDefaultsStyle.GeneralNoteStyle property

ObjectDefaultsStyle.HoleNoteLayer property

ObjectDefaultsStyle.HoleNoteStyle property

ObjectDefaultsStyle.HoleTableLayer property

ObjectDefaultsStyle.HoleTableStyle property

ObjectDefaultsStyle.HoleTagLayer property

ObjectDefaultsStyle.HoleTagStyle property

ObjectDefaultsStyle.LeaderTextLayer property

ObjectDefaultsStyle.LeaderTextStyle property

ObjectDefaultsStyle.LinearDimensionLayer property

ObjectDefaultsStyle.LinearDimensionStyle property

ObjectDefaultsStyle.OrdinateDimensionLayer property

ObjectDefaultsStyle.OrdinateDimensionSetLayer property

ObjectDefaultsStyle.OrdinateDimensionStyle property

ObjectDefaultsStyle.OrdinateSetDimensionStyle property

ObjectDefaultsStyle.OriginIndicatorLayer property

ObjectDefaultsStyle.OriginIndicatorStyle property

ObjectDefaultsStyle.PartsListLayer property

ObjectDefaultsStyle.PartsListStyle property

ObjectDefaultsStyle.PunchNoteLayer property

ObjectDefaultsStyle.PunchNoteStyle property

ObjectDefaultsStyle.RadialDimensionLayer property

ObjectDefaultsStyle.RadialDimensionStyle property

ObjectDefaultsStyle.RevisionTableLayer property

ObjectDefaultsStyle.RevisionTableStyle property

ObjectDefaultsStyle.RevisionTagLayer property

ObjectDefaultsStyle.RevisionTagStyle property

ObjectDefaultsStyle.SheetMetalPunchLayer property

ObjectDefaultsStyle.SheetMetalPunchStyle property

ObjectDefaultsStyle.Sketch3DGeometryLayer property

ObjectDefaultsStyle.SketchedSymbolGeometryLayer property

ObjectDefaultsStyle.SketchedSymbolLeaderLayer property

ObjectDefaultsStyle.SketchedSymbolLeaderStyle property

ObjectDefaultsStyle.SketchedSymbolTextLayer property

ObjectDefaultsStyle.SketchedSymbolTextStyle property

ObjectDefaultsStyle.SketchGeometryLayer property

ObjectDefaultsStyle.SketchTextLayer property

ObjectDefaultsStyle.SketchTextStyle property

ObjectDefaultsStyle.SurfaceTextureLayer property

ObjectDefaultsStyle.SurfaceTextureStyle property

ObjectDefaultsStyle.TableLayer property

ObjectDefaultsStyle.TableStyle property

ObjectDefaultsStyle.ThreadNoteLayer property

ObjectDefaultsStyle.ThreadNoteStyle property

ObjectDefaultsStyle.TitleBlockGeometryLayer property

ObjectDefaultsStyle.TitleBlockTextLayer property

ObjectDefaultsStyle.TitleBlockTextStyle property

ObjectDefaultsStyle.ViewLabelLayer property

ObjectDefaultsStyle.ViewLabelStyle property

ObjectDefaultsStyle.WorkAxisLayer property

ObjectDefaultsStyle.WorkAxisStyle property

ObjectDefaultsStyle.WorkPlaneLayer property

ObjectDefaultsStyle.WorkPlaneStyle property

ObjectDefaultsStyle.WorkPointLayer property

ObjectDefaultsStyle.WorkPointStyle property

ObjectDefaultsStyles

DrawingStylesManager interface

ObjectDefaultsStylesEnumerator interface

Application

Count

Item

Type

ObjectDefaultsStylesEnumerator.Application property

ObjectDefaultsStylesEnumerator.Count property

ObjectDefaultsStylesEnumerator.Item method

ObjectDefaultsStylesEnumerator.Type property

ObjectsEnumerator interface

Count

Item

Type

ObjectsEnumerator.Count property

ObjectsEnumerator.Item method

ObjectsEnumerator.Type property

ObjectsEnumeratorByVariant interface

Count

Item

Type

ObjectsEnumeratorByVariant.Count property

ObjectsEnumeratorByVariant.Item method

ObjectsEnumeratorByVariant.Type property

ObjectVisibility

AssemblyDocument interface

PartDocument interface

ObjectVisibility interface

AllWorkFeatures

Application

ConstructionSurfaces

GroupDiagnostics

GroupSolids

GroupSurfaces

GroupWires

OriginWorkAxes

OriginWorkPlanes

OriginWorkPoints

Parent

Sketches

Sketches3D

Type

UCSTriads

UCSWorkAxes

UCSWorkPlanes

UCSWorkPoints

UserWorkAxes

UserWorkPlanes

UserWorkPoints

WeldmentSymbols

Welds

ObjectVisibility.AllWorkFeatures property

ObjectVisibility.Application property

ObjectVisibility.ConstructionSurfaces property

ObjectVisibility.GroupDiagnostics property

ObjectVisibility.GroupSolids property

ObjectVisibility.GroupSurfaces property

ObjectVisibility.GroupWires property

ObjectVisibility.OriginWorkAxes property

ObjectVisibility.OriginWorkPlanes property

ObjectVisibility.OriginWorkPoints property

ObjectVisibility.Parent property

ObjectVisibility.Sketches property

ObjectVisibility.Sketches3D property

ObjectVisibility.Type property

ObjectVisibility.UCSTriads property

ObjectVisibility.UCSWorkAxes property

ObjectVisibility.UCSWorkPlanes property

ObjectVisibility.UCSWorkPoints property

ObjectVisibility.UserWorkAxes property

ObjectVisibility.UserWorkPlanes property

ObjectVisibility.UserWorkPoints property

ObjectVisibility.WeldmentSymbols property

ObjectVisibility.Welds property

OccurrenceOne

AssemblyConstraint interface

InterferenceResult interface

OccurrencePath

ComponentOccurrence interface

OccurrencePattern interface

Application

AttributeSets

Delete

GetReferenceKey

HealthStatus

IsPatternElement

Name

OccurrencePatternElements

Parent

ParentComponents

PatternElement

Type

Visible

OccurrencePattern.Application property

OccurrencePattern.AttributeSets property

OccurrencePattern.Delete method

OccurrencePattern.GetReferenceKey method

OccurrencePattern.HealthStatus property

OccurrencePattern.IsPatternElement property

OccurrencePattern.Name property

OccurrencePattern.OccurrencePatternElements property

OccurrencePattern.Parent property

OccurrencePattern.ParentComponents property

OccurrencePattern.PatternElement property

OccurrencePattern.Type property

OccurrencePattern.Visible property

OccurrencePatternElement

RectangularOccurrencePattern interface

OccurrencePatternElement interface

Application

Components

Independent

Index

Name

Occurrences

Parent

Suppressed

Type

OccurrencePatternElement.Application property

OccurrencePatternElement.Components property

OccurrencePatternElement.Independent property

OccurrencePatternElement.Index property

OccurrencePatternElement.Name property

OccurrencePatternElement.Occurrences property

OccurrencePatternElement.Parent property

OccurrencePatternElement.Suppressed property

OccurrencePatternElement.Type property

OccurrencePatternElementProxy interface

ContainingOccurrence

NativeObject

OccurrencePatternElementProxy.ContainingOccurrence property

OccurrencePatternElementProxy.NativeObject property

OccurrencePatternElements

OccurrencePattern interface

OccurrencePatternElements interface

Application

Count

Item

Parent

Type

OccurrencePatternElements.Application property

OccurrencePatternElements.Count property

OccurrencePatternElements.Item method

OccurrencePatternElements.Parent property

OccurrencePatternElements.Type property

OccurrencePatterns

AssemblyComponentDefinition interface

OccurrencePatterns interface

AddCircularPattern

AddFeatureBasedPattern

AddRectangularPattern

Application

Count

Item

Parent

Type

OccurrencePatterns.AddCircularPattern method

OccurrencePatterns.AddFeatureBasedPattern method

OccurrencePatterns.AddRectangularPattern method

OccurrencePatterns.Application property

OccurrencePatterns.Count property

OccurrencePatterns.Item method

OccurrencePatterns.Parent property

OccurrencePatterns.Type property

Occurrences

ComponentDefinition interface

DerivedAssemblyDefinition interface

OccurrencePatternElement interface

OccurrenceTwo

AssemblyConstraint interface

InterferenceResult interface

OfflineImageFidelity

DrawingSettings interface

Offset

BossSet interface

FlushConstraint interface

FlushiMateDefinition interface

MateConstraint interface

MateiMateDefinition interface

PlaneAndOffsetWorkPlaneDef interface

TangentConstraint interface

TangentiMateDefinition interface

ToHeightExtent interface

OffsetConstraint interface

EntityFour

EntityOne

EntityThree

EntityTwo

OffsetConstraint.EntityFour property

OffsetConstraint.EntityOne property

OffsetConstraint.EntityThree property

OffsetConstraint.EntityTwo property

OffsetConstraintProxy interface

ContainingOccurrence

NativeObject

OffsetConstraintProxy.ContainingOccurrence property

OffsetConstraintProxy.NativeObject property

OffsetDimConstraint interface

Entity

Line

LinearDiameter

OffsetDimConstraint.Entity property

OffsetDimConstraint.Line property

OffsetDimConstraint.LinearDiameter property

OffsetDimConstraintProxy interface

ContainingOccurrence

NativeObject

OffsetDimConstraintProxy.ContainingOccurrence property

OffsetDimConstraintProxy.NativeObject property

OffsetDistance

WidthOffsetWidthExtent interface

OffsetDistanceOne

OffsetWidthExtent interface

OffsetDistanceTwo

OffsetWidthExtent interface

OffsetEntity

WidthOffsetWidthExtent interface

OffsetEntityOne

OffsetWidthExtent interface

OffsetEntityTwo

OffsetWidthExtent interface

OffsetSketchEntitiesUsingDistance

Sketch interface

OffsetSketchEntitiesUsingPoint

Sketch interface

OffsetSpline

OffsetSplineDimConstraint interface

OffsetSplineDimConstraint interface

OffsetSpline

Spline

OffsetSplineDimConstraint.OffsetSpline property

OffsetSplineDimConstraint.Spline property

OffsetSplineDimConstraintProxy interface

ContainingOccurrence

NativeObject

OffsetSplineDimConstraintProxy.ContainingOccurrence property

OffsetSplineDimConstraintProxy.NativeObject property

OffsetWidthExtent interface

Edge

OffsetDistanceOne

OffsetDistanceTwo

OffsetEntityOne

OffsetEntityTwo

OffsetWidthExtent.Edge property

OffsetWidthExtent.OffsetDistanceOne property

OffsetWidthExtent.OffsetDistanceTwo property

OffsetWidthExtent.OffsetEntityOne property

OffsetWidthExtent.OffsetEntityTwo property

OldVersionsToKeep

DesignProject interface

OLEDocumentType

ReferencedOLEFileDescriptor interface

On

Light interface

OnAbort

TransactionEventsSink interface

OnActivate

BrowserPaneSink interface

DocumentEventsSink interface

InteractionEventsSink interface

TriadEventsSink interface

OnActivateCommand

UserInputEventsSink interface

OnActivateDesignView

RepresentationEventsSink interface

OnActivateDocument

ApplicationEventsSink interface

OnActivateLevelOfDetailRepresentation

RepresentationEventsSink interface

OnActivatePositionalRepresentation

RepresentationEventsSink interface

OnActivateStyle

StyleEventsSink interface

OnActivateView

ApplicationEventsSink interface

OnActiveProjectChanged

ApplicationEventsSink interface

OnApplicationHelp

HelpEventsSink interface

OnApplicationOptionChange

ApplicationEventsSink interface

OnApply

MiniToolbarSink interface

OnAssemblyChange

AssemblyEventsSink interface

OnAssemblyChanged

AssemblyEventsSink interface

OnBindKeyToObject

ReferenceKeyEventsSink interface

OnBrowserNodeActivate

BrowserPanesSink interface

OnBrowserNodeDeleteEntry

BrowserPanesSink interface

OnBrowserNodeGetDisplayObjects

BrowserPanesSink interface

OnBrowserNodeLabelEdit

BrowserPanesSink interface

OnCameraChange

CameraEventsSink interface

OnCancel

MiniToolbarSink interface

ProgressBarSink interface

OnChange

DocumentEventsSink interface

MiniToolbarValueEditorSink interface

OnChangeSelectSet

DocumentEventsSink interface

OnClick

BalloonTipSink interface

MiniToolbarButtonSink interface

MiniToolbarCheckBoxSink interface

OnClientFeatureDoubleClick

ModelingEventsSink interface

OnClose

DocumentEventsSink interface

OnCloseDocument

ApplicationEventsSink interface

OnCloseView

ApplicationEventsSink interface

OnCollision

DriveConstraintSettingsSink interface

OnCommandBarSelection

PanelBarEventsSink interface

OnCommandInputs

ControlDefinitionEventsSink interface

OnCommit

TransactionEventsSink interface

OnContextualMiniToolbar

UserInputEventsSink interface

OnDeactivate

BrowserPaneSink interface

DocumentEventsSink interface

OnDeactivateDocument

ApplicationEventsSink interface

OnDeactivateView

ApplicationEventsSink interface

OnDelete

AssemblyEventsSink interface

DocumentEventsSink interface

ModelingEventsSink interface

RepresentationEventsSink interface

SketchEventsSink interface

StyleEventsSink interface

TransactionEventsSink interface

OnDisplay

BalloonTipSink interface

OnDisplayModeChange

ApplicationEventsSink interface

OnDocumentChange

ApplicationEventsSink interface

OnDoubleClick

UserInputEventsSink interface

OnDrag

UserInputEventsSink interface

OnEndMove

TriadEventsSink interface

OnEndSequence

TriadEventsSink interface

OnEnter

MiniToolbarValueEditorSink interface

OnEnvironmentChange

UserInterfaceEventsSink interface

OnExecute

ButtonDefinitionSink interface

ChangeProcessorSink interface

OnExit

MiniToolbarValueEditorSink interface

OnFeatureChange

ModelingEventsSink interface

OnFileCopy

FileManagerEventsSink interface

OnFileDelete

FileManagerEventsSink interface

OnFileDirty

FileAccessEventsSink interface

OnFileInsertDialog

FileUIEventsSink interface

OnFileInsertNewDialog

FileUIEventsSink interface

OnFileNew

FileUIEventsSink interface

OnFileNewDialog

FileUIEventsSink interface

OnFileOpenDialog

FileUIEventsSink interface

OnFileOpenFromMRU

FileUIEventsSink interface

OnFileResolution

FileAccessEventsSink interface

OnFileSaveAsDialog

FileUIEventsSink interface

OnGenerateMember

ModelingEventsSink interface

OnHelp

BrowserPaneSink interface

ButtonDefinitionSink interface

ComboBoxDefinitionSink interface

DockableWindowsEventsSink interface

InteractionEventsSink interface

OnHide

DockableWindowsEventsSink interface

OnInitializeDocument

ApplicationEventsSink interface

OnItemHoverEnd

MiniToolbarComboBoxSink interface

MiniToolbarDropdownSink interface

OnItemHoverStart

MiniToolbarComboBoxSink interface

MiniToolbarDropdownSink interface

OnItemRemove

MiniToolbarComboBoxSink interface

MiniToolbarDropdownSink interface

OnKeyDown

KeyboardEventsSink interface

OnKeyPress

KeyboardEventsSink interface

OnKeyUp

KeyboardEventsSink interface

OnLabelEdit

BrowserNodeDefinitionSink interface

OnLinearMarkingMenu

UserInputEventsSink interface

OnlyActiveComponentIsOpaque

AssemblyOptions interface

OnMeasure

MeasureEventsSink interface

OnMigrateDocument

ApplicationEventsSink interface

OnMouseClick

MouseEventsSink interface

OnMouseDoubleClick

MouseEventsSink interface

OnMouseDown

MouseEventsSink interface

OnMouseLeave

MouseEventsSink interface

OnMouseMove

MouseEventsSink interface

OnMouseUp

MouseEventsSink interface

OnMove

TriadEventsSink interface

OnMoveTriadOnlyToggle

TriadEventsSink interface

OnNewConstraint

AssemblyEventsSink interface

OnNewDesignView

RepresentationEventsSink interface

OnNewDocument

ApplicationEventsSink interface

OnNewEditObject

ApplicationEventsSink interface

OnNewFeature

ModelingEventsSink interface

OnNewLevelOfDetailRepresentation

RepresentationEventsSink interface

OnNewOccurrence

AssemblyEventsSink interface

OnNewParameter

ModelingEventsSink interface

OnNewPositionalRepresentation

RepresentationEventsSink interface

OnNewSketch

SketchEventsSink interface

OnNewSketch3D

SketchEventsSink interface

OnNewStyle

StyleEventsSink interface

OnNewView

ApplicationEventsSink interface

OnOccurrenceChange

AssemblyEventsSink interface

OnOK

MiniToolbarSink interface

OnOpenDocument

ApplicationEventsSink interface

OnOptions

FileDialogEventsSink interface

OnParameterChange

ModelingEventsSink interface

OnPopulateFileMetadata

FileUIEventsSink interface

OnPreMenuDisplay

MiniToolbarComboBoxSink interface

MiniToolbarDropdownSink interface

OnPreSelect

SelectEventsSink interface

UserInputEventsSink interface

OnPreSelectMouseMove

SelectEventsSink interface

OnQuit

ApplicationEventsSink interface

OnRadialMarkingMenu

UserInputEventsSink interface

OnReadFromScript

ChangeProcessorSink interface

OnReady

ApplicationEventsSink interface

OnRedo

TransactionEventsSink interface

OnReplay

ChangeDefinitionSink interface

OnResetCommandBars

UserInterfaceEventsSink interface

OnResetEnvironments

UserInterfaceEventsSink interface

OnResetRibbonInterface

UserInterfaceEventsSink interface

OnResetShortcuts

UserInterfaceEventsSink interface

OnRestart32BitHost

ApplicationEventsSink interface

OnResume

InteractionEventsSink interface

OnRetrieveDimensions

DrawingEventsSink interface

OnSave

DocumentEventsSink interface

OnSaveDocument

ApplicationEventsSink interface

OnSegmentSelectionChange

TriadEventsSink interface

OnSelect

ComboBoxDefinitionSink interface

MiniToolbarComboBoxSink interface

MiniToolbarDropdownSink interface

SelectEventsSink interface

UserInputEventsSink interface

OnSelectParameter

MeasureEventsSink interface

OnShow

DockableWindowsEventsSink interface

OnSketch3DChange

SketchEventsSink interface

OnSketch3DSolve

SketchEventsSink interface

OnSketchChange

SketchEventsSink interface

OnStartMove

TriadEventsSink interface

OnStartSequence

TriadEventsSink interface

OnStopPreSelect

SelectEventsSink interface

UserInputEventsSink interface

OnStyleChange

StyleEventsSink interface

OnSurfaceBodyChanged

PartEventsSink interface

OnSuspend

InteractionEventsSink interface

OnTerminate

ChangeProcessorSink interface

InteractionEventsSink interface

TriadEventsSink interface

OnTerminateCommand

UserInputEventsSink interface

OnTerminateDocument

ApplicationEventsSink interface

OnTranslateDocument

ApplicationEventsSink interface

OnUndo

TransactionEventsSink interface

OnUnSelect

SelectEventsSink interface

UserInputEventsSink interface

OnViewUpdate

DrawingViewEventsSink interface

OnWriteToScript

ChangeProcessorSink interface

Opacity

Color interface

GroundPlaneSettings interface

RenderStyle interface

OpaqueConstructionSurfaces

PartOptions interface

Open

ApprenticeServer interface

ApprenticeServerDocument interface

Document interface

Documents interface

InventorVBAProjects interface

TranslatorAddIn interface

TranslatorAddInServer interface

OpenAttributeSets

AttributeManager interface

OpenDocumentsDisplay

Application interface

OpenIntoExisting

TranslationContext interface

OpenWithOptions

ApprenticeServer interface

Documents interface

Operation

CoilFeature interface

CombineFeature interface

ExtrudeDefinition interface

LoftDefinition interface

RevolveFeature interface

SculptFeature interface

SweepFeature interface

ThickenFeature interface

OpposedToSketchEntity

PathEntity interface

ProfileEntity interface

ProfileEntity3D interface

OppositeAngle

AngularGeneralDimension interface

OptionsEnabled

FileDialog interface

OrdinateDimension interface

DimensionType

Intent

IsOrdinateSetMember

JogPointOne

JogPointTwo

OrdinateDimensionSet

Style

OrdinateDimension.DimensionType property

OrdinateDimension.Intent property

OrdinateDimension.IsOrdinateSetMember property

OrdinateDimension.JogPointOne property

OrdinateDimension.JogPointTwo property

OrdinateDimension.OrdinateDimensionSet property

OrdinateDimension.Style property

OrdinateDimensionLayer

ObjectDefaultsStyle interface

OrdinateDimensionOriginArrowheadType

DimensionStyle interface

OrdinateDimensions

DrawingDimensions interface

OrdinateDimensions interface

Add

Application

Count

Item

Type

OrdinateDimensions.Add method

OrdinateDimensions.Application property

OrdinateDimensions.Count property

OrdinateDimensions.Item method

OrdinateDimensions.Type property

OrdinateDimensionsEnumerator interface

Count

Item

Type

OrdinateDimensionsEnumerator.Count property

OrdinateDimensionsEnumerator.Item method

OrdinateDimensionsEnumerator.Type property

OrdinateDimensionSet

OrdinateDimension interface

OrdinateDimensionSet interface

AddMember

AlignMembers

AllowBrokenLeaders

Application

AttributeSets

ContinuousRunning

Delete

DimensionType

DirectionReversed

GetReferenceKey

Layer

Members

OriginArrowheadType

OriginMember

Parent

PositiveBothDirections

Precision

ShowDirection

Style

Type

OrdinateDimensionSet.AddMember method

OrdinateDimensionSet.AlignMembers property

OrdinateDimensionSet.AllowBrokenLeaders property

OrdinateDimensionSet.Application property

OrdinateDimensionSet.AttributeSets property

OrdinateDimensionSet.ContinuousRunning property

OrdinateDimensionSet.Delete method

OrdinateDimensionSet.DimensionType property

OrdinateDimensionSet.DirectionReversed property

OrdinateDimensionSet.GetReferenceKey method

OrdinateDimensionSet.Layer property

OrdinateDimensionSet.Members property

OrdinateDimensionSet.OriginArrowheadType property

OrdinateDimensionSet.OriginMember property

OrdinateDimensionSet.Parent property

OrdinateDimensionSet.PositiveBothDirections property

OrdinateDimensionSet.Precision property

OrdinateDimensionSet.ShowDirection property

OrdinateDimensionSet.Style property

OrdinateDimensionSet.Type property

OrdinateDimensionSetLayer

ObjectDefaultsStyle interface

OrdinateDimensionSets

DrawingDimensions interface

OrdinateDimensionSets interface

Add

Application

Count

Item

Type

OrdinateDimensionSets.Add method

OrdinateDimensionSets.Application property

OrdinateDimensionSets.Count property

OrdinateDimensionSets.Item method

OrdinateDimensionSets.Type property

OrdinateDimensionStyle

ObjectDefaultsStyle interface

OrdinateSetDimensionStyle

ObjectDefaultsStyle interface

Orientation

ApprenticePrintManager interface

BIMComponentDescription interface

BreakOperation interface

PrintManager interface

Sheet interface

SheetFormat interface

TwoPointDistanceDimConstraint interface

OrientationMethod

RectangularPatternFeature interface

Origin

BaselineDimensionSet interface

DimensionText interface

TextBox interface

UserCoordinateSystem interface

OriginalSpline

SketchOffsetSpline interface

OriginArrowheadType

OrdinateDimensionSet interface

OriginIndicator

DrawingView interface

OriginIndicator interface

Application

Attached

Intent

Layer

LeaderStyle

RelativeX

RelativeY

Type

Visible

OriginIndicator.Application property

OriginIndicator.Attached property

OriginIndicator.Intent property

OriginIndicator.Layer property

OriginIndicator.LeaderStyle property

OriginIndicator.RelativeX property

OriginIndicator.RelativeY property

OriginIndicator.Type property

OriginIndicator.Visible property

OriginIndicatorLayer

ObjectDefaultsStyle interface

OriginIndicatorStyle

ObjectDefaultsStyle interface

OriginMember

OrdinateDimensionSet interface

OriginOffset

DimensionStyle interface

OriginPoint

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

FixedWorkAxisDef interface

FixedWorkPlaneDef interface

PlanarSketch interface

OriginPointGeometry

PlanarSketch interface

OriginSketchPoint

TextBox interface

OriginWorkAxes

ObjectVisibility interface

OriginWorkPlanes

ObjectVisibility interface

OriginWorkPoints

ObjectVisibility interface

OutOfProcessInventorServer coclass

OutputType

LoftedFlangeDefinition interface

NonParametricBaseFeatureDefinition interface

OutsideLineColor

HoleTableStyle interface

RevisionTableStyle interface

TableFormat interface

TableStyle interface

OutsideLineWeight

HoleTableStyle interface

RevisionTableStyle interface

TableFormat interface

TableStyle interface

OutsidePipeDiameter

TaperedThreadInfo interface

OverallExternalLength

TaperedThreadInfo interface

OverConstrainedDimensionBehavior

SketchOptions interface

OverlayClientGraphics

InteractionGraphics interface

OverrideColor

Sketch3D interface

SketchArc interface

SketchCircle interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

OverrideEnvironment

EnvironmentManager interface

OverrideExpandedIcon

NativeBrowserNodeDefinitionObject interface

OverrideFormat

CustomTable interface

OverrideIcon

NativeBrowserNodeDefinitionObject interface

OverrideModelValue

DrawingDimension interface

OverrideOpacity

ComponentOccurrence interface

OverrideShortcut

ControlDefinition interface

OverrideShortcutType

ControlDefinition interface

OverrideValue

BalloonValueSet interface

OvershootDistance

CentermarkStyle interface

Overview Articles

OwnedBy

PartFeature interface

PlanarSketch interface

Sketch3D interface

SketchEntity interface

SketchEntity3D interface

UserCoordinateSystem interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

Owner

DesignProject interface

P

PanelBar

Environment interface

PanelBar coclass

PanelBarEventsSink interface

OnCommandBarSelection

PanelBarEventsSink.OnCommandBarSelection method

PanelBarObject interface

Application

CommandBarList

CurrentCommandBar

DefaultCommandBar

Parent

Type

PanelBarObject.Application property

PanelBarObject.CommandBarList property

PanelBarObject.CurrentCommandBar property

PanelBarObject.DefaultCommandBar property

PanelBarObject.Parent property

PanelBarObject.Type property

PaperHeight

ApprenticePrintManager interface

PrintManager interface

PaperSize

ApprenticePrintManager interface

PrintManager interface

PaperSource

ApprenticePrintManager interface

PrintManager interface

PaperWidth

ApprenticePrintManager interface

PrintManager interface

ParallelConstraint interface

EntityOne

EntityTwo

UseEllipseOneMajorAxis

UseEllipseTwoMajorAxis

ParallelConstraint.EntityOne property

ParallelConstraint.EntityTwo property

ParallelConstraint.UseEllipseOneMajorAxis property

ParallelConstraint.UseEllipseTwoMajorAxis property

ParallelConstraint3D interface

EntityOne

EntityTwo

ParallelConstraint3D.EntityOne property

ParallelConstraint3D.EntityTwo property

ParallelConstraint3DProxy interface

ContainingOccurrence

NativeObject

ParallelConstraint3DProxy.ContainingOccurrence property

ParallelConstraint3DProxy.NativeObject property

ParallelConstraintProxy interface

ContainingOccurrence

NativeObject

ParallelConstraintProxy.ContainingOccurrence property

ParallelConstraintProxy.NativeObject property

ParallelEnvironments

UserInterfaceManager interface

ParallelViewOnSketchCreation

SketchOptions interface

Parameter

DimensionConstraint interface

DimensionConstraint3D interface

FeatureDimension interface

iFeatureParameterInput interface

Parameter interface

AttributeSets

Comment

CustomPropertyFormat

Delete

Dependents

DisabledActionTypes

DisplayFormat

DrivenBy

ExposedAsProperty

Expression

ExpressionList

GetReferenceKey

HealthStatus

InUse

IsKey

ModelValue

ModelValueType

Name

ParameterType

Parent

Precision

Tolerance

Type

Units

Value

Parameter.AttributeSets property

Parameter.Comment property

Parameter.CustomPropertyFormat property

Parameter.Delete method

Parameter.Dependents property

Parameter.DisabledActionTypes property

Parameter.DisplayFormat property

Parameter.DrivenBy property

Parameter.ExposedAsProperty property

Parameter.Expression property

Parameter.ExpressionList property

Parameter.GetReferenceKey method

Parameter.HealthStatus property

Parameter.InUse property

Parameter.IsKey property

Parameter.ModelValue property

Parameter.ModelValueType property

Parameter.Name property

Parameter.ParameterType property

Parameter.Parent property

Parameter.Precision property

Parameter.Tolerance property

Parameter.Type property

Parameter.Units property

Parameter.Value property

Parameters

AssemblyComponentDefinition interface

DerivedPartComponent interface

DerivedPartDefinition interface

DrawingDocument interface

FlatPattern interface

PartComponentDefinition interface

PartFeature interface

Parameters interface

_GetValueFromExpression

AngularDimensionPrecision

AngularStandardTolerance

Count

CustomParameterGroups

DerivedParameterTables

DimensionDisplayType

DisplayParameterAsExpression

ExportStandardTolerances

GetValueFromExpression

IsExpressionValid

Item

LinearDimensionPrecision

LinearStandardTolerance

LinearStandardTolerance

ModelParameters

ParameterTables

ReferenceParameters

SetAllToMax

SetAllToMedian

SetAllToMin

SetAllToNominal

Type

UserParameters

UseStandardTolerances

Parameters._GetValueFromExpression method

Parameters.AngularDimensionPrecision property

Parameters.AngularStandardTolerance method

Parameters.Count property

Parameters.CustomParameterGroups property

Parameters.DerivedParameterTables property

Parameters.DimensionDisplayType property

Parameters.DisplayParameterAsExpression property

Parameters.ExportStandardTolerances property

Parameters.GetValueFromExpression method

Parameters.IsExpressionValid method

Parameters.Item method

Parameters.LinearDimensionPrecision property

Parameters.LinearStandardTolerance method

Parameters.ModelParameters property

Parameters.ParameterTables property

Parameters.ReferenceParameters property

Parameters.SetAllToMax method

Parameters.SetAllToMedian method

Parameters.SetAllToMin method

Parameters.SetAllToNominal method

Parameters.Type property

Parameters.UserParameters property

Parameters.UseStandardTolerances property

ParametersEnumerator interface

Count

Item

Type

ParametersEnumerator.Count property

ParametersEnumerator.Item method

ParametersEnumerator.Type property

ParameterSpaceCurveOne

EdgeDefinition interface

ParameterSpaceCurveTwo

EdgeDefinition interface

ParameterTable interface

AttributeSets

Delete

FileName

GetReferenceKey

Linked

Parent

ReferencedFileDescriptor

StartCell

TableParameters

Type

WorkSheet

ParameterTable.AttributeSets property

ParameterTable.Delete method

ParameterTable.FileName property

ParameterTable.GetReferenceKey method

ParameterTable.Linked property

ParameterTable.Parent property

ParameterTable.ReferencedFileDescriptor property

ParameterTable.StartCell property

ParameterTable.TableParameters property

ParameterTable.Type property

ParameterTable.WorkSheet property

ParameterTables

Parameters interface

ParameterTables interface

AddExcelTable

Count

Item

Type

ParameterTables.AddExcelTable method

ParameterTables.Count property

ParameterTables.Item method

ParameterTables.Type property

ParameterType

Parameter interface

ParamRangeRect

SurfaceEvaluator interface

Parent

AnalysisManager interface

AnalyticEdgeWorkAxisDef interface

ApplicationAddIn interface

ApplicationAddInSite interface

ApplicationEventsObject interface

AssemblyComponentDefinition interface

AssemblyComponentDefinitions interface

AssemblyConstraint interface

AssemblyConstraints interface

AssemblyEventsObject interface

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

AssemblyWorkPointDef interface

Attribute interface

AttributeManager interface

AttributeSet interface

AttributeSets interface

AutoCADBlock interface

AutoCADBlockDefinition interface

Balloon interface

BalloonTipObject interface

BalloonValueSet interface

BaselineDimensionSet interface

Bend interface

BendDefinition interface

BendOptions interface

BIMComponentProperty interface

BIMComponentPropertySet interface

BIMConnector interface

BIMConnectorDefinition interface

BOM interface

BOMQuantity interface

BOMRow interface

BOMView interface

Border interface

BorderDefinition interface

BossSet interface

BreakOperation interface

BreakOutOperation interface

BrowserFolder interface

BrowserNode interface

BrowserNodeDefinition interface

BrowserPaneObject interface

Camera interface

CameraEventsObject interface

Cell interface

Centerline interface

Centermark interface

CentroidWorkPointDef interface

ChainDimensionSet interface

ChamferDefinition interface

ChangeDefinitionObject interface

ChangeManager interface

ChangeProcessorObject interface

CheckPoint interface

ClientFeatureDefinition interface

ClientFeatureElement interface

ClientGraphics interface

ClientGraphicsCollection interface

ClientNodeResource interface

ClientView interface

ClientViews interface

Column interface

CommandBar interface

CommandBarControl interface

CommandCategory interface

CommandControl interface

CommandManager interface

ComponentOccurrence interface

ConstraintLimits interface

ContentTableCell interface

ContentTableColumn interface

ContentTableRow interface

ContourFlangeDefinition interface

ControlDefinition interface

ControlDefinitionEventsObject interface

CoreCavityDefinition interface

CornerChamferDefinition interface

CornerDefinition interface

CornerOptions interface

CornerRoundDefinition interface

CornerRoundEdgeSet interface

CurveAndEntityWorkPointDef interface

CustomPropertyFormat interface

CustomTable interface

CutDefinition interface

DerivedAliasComponents interface

DerivedAssemblyComponents interface

DerivedParameterTable interface

DerivedPartComponents interface

DesignProject interface

DesignProjectManager interface

DesignViewRepresentation interface

DimensionConstraint interface

DimensionConstraint3D interface

DimensionText interface

DirectionAndDistanceMoveDefinition interface

DisplaySettings interface

DockableWindow interface

DockableWindowsEventsObject interface

Document interface

DocumentDescriptor interface

DocumentEventsObject interface

DocumentInterest interface

DoubleHemDefinition interface

DraftAnalysis interface

DrawingBOM interface

DrawingBOMCell interface

DrawingBOMColumn interface

DrawingBOMRow interface

DrawingCurve interface

DrawingCurveSegment interface

DrawingDimension interface

DrawingEventsObject interface

DrawingNote interface

DrawingSettings interface

DrawingStylesManager interface

DrawingView interface

DrawingViewEventsObject interface

DrawingViewLabel interface

DriveConstraintSettingsObject interface

Edge interface

EdgeLoop interface

EdgeUse interface

EndOfFeatures interface

Environment interface

EnvironmentManager interface

ErrorManager interface

ExpressionList interface

ExtrudeDefinition interface

Face interface

FaceFeatureDefinition interface

FaceShell interface

FeatureControlFrame interface

FeatureControlFrameRow interface

FeatureDimension interface

FeaturePatternElement interface

FileAccessEventsObject interface

FileDescriptor interface

FileDialogEventsObject interface

FileManagerEventsObject interface

FileUIEventsObject interface

FilletDefinition interface

FixedWorkAxisDef interface

FixedWorkPlaneDef interface

FixedWorkPointDef interface

FlangeDefinition interface

FlatBendResult interface

FlatPattern interface

FlatPunchResult interface

FoldDefinition interface

FreeMoveDefinition interface

GeometricConstraint interface

GeometricConstraint3D interface

GeometryIntent interface

GraphicsDataSets interface

GraphicsDataSetsCollection interface

GraphicsNode interface

GraphicsPrimitive interface

HeadsUpDisplayOptions interface

HelpManager interface

HemDefinition interface

HolePlacementDefinition interface

HoleTable interface

HoleTableCell interface

HoleTableColumn interface

HoleTableRow interface

HoleTag interface

iAssemblyFactory interface

iAssemblyMember interface

iAssemblyTableCell interface

iAssemblyTableColumn interface

iAssemblyTableRow interface

iFeatureTable interface

iFeatureTableCell interface

iFeatureTableColumn interface

iFeatureTableRow interface

iFeatureTemplateDescriptor interface

InteractionEventsObject interface

InventorVBAArgument interface

InventorVBAArguments interface

InventorVBAComponent interface

InventorVBAComponents interface

InventorVBAMember interface

InventorVBAMembers interface

InventorVBAProject interface

InventorVBAProjects interface

iPartFactory interface

iPartTableCell interface

iPartTableColumn interface

iPartTableRow interface

KeyboardEventsObject interface

LanguageTools interface

LayoutConstraint interface

Leader interface

LeaderNode interface

LevelOfDetailRepresentation interface

Light interface

LightingStyle interface

LightingStyles interface

Lights interface

LineAndPlaneWorkAxisDef interface

LineAndPointWorkAxisDef interface

LineAndTangentWorkPlaneDef interface

LinePlaneAndAngleWorkPlaneDef interface

LineWorkAxisDef interface

LoftedFlangeDefinition interface

Material interface

Materials interface

MeasureEventsObject interface

MeasureTools interface

MessageSection interface

MidPointWorkPointDef interface

MiniToolbarControl interface

MiniToolbarObject interface

ModelingEventsObject interface

ModelingSettings interface

MouseEventsObject interface

MoveFaceDefinition interface

NonLinearEdgeWorkPointDef interface

NormalToCurveWorkPlaneDef interface

NormalToSurfaceWorkAxisDef interface

ObjectVisibility interface

OccurrencePattern interface

OccurrencePatternElement interface

OccurrencePatternElements interface

OccurrencePatterns interface

OrdinateDimensionSet interface

PanelBarObject interface

Parameter interface

ParameterTable interface

PartEventsObject interface

PartFeature interface

PartFeatureExtent interface

PartsList interface

PartsListCell interface

PartsListColumn interface

PartsListRow interface

PathEntity interface

PlanarMoveDefinition interface

PlaneAndOffsetWorkPlaneDef interface

PlaneAndPointWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

PointAndPlaneWorkAxisDef interface

PointAndTangentWorkPlaneDef interface

PointToPointRipTypeDef interface

PointWorkPointDef interface

PositionalRepresentation interface

PresentationExplodedView interface

Profile interface

Profile3D interface

ProfileEntity interface

ProfileEntity3D interface

ProfilePath interface

ProfilePath3D interface

ProgressiveToolTip interface

ProjectedCut interface

ProjectPath interface

Property interface

PropertySet interface

PropertySets interface

ReferenceComponent interface

ReferencedOLEFileDescriptor interface

ReferenceKeyManager interface

RegionProperties interface

RenderStyle interface

RenderStyles interface

RepresentationEventsObject interface

RepresentationsManager interface

RevisionTable interface

RevisionTableCell interface

RevisionTableColumn interface

RevisionTableRow interface

RevolvedFaceWorkAxisDef interface

Ribbon interface

RibbonPanel interface

RibbonTab interface

RibDefinition interface

RipDefinition interface

RolledHemDefinition interface

Row interface

SelectEventsObject interface

Sheet interface

SheetFormat interface

SheetSettings interface

ShellDefinition interface

SilhouetteCurve interface

SingleHemDefinition interface

SinglePointRipTypeDef interface

Sketch interface

Sketch3D interface

Sketch3DSettings interface

SketchBlock interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchEntity interface

SketchEntity3D interface

SketchEventsObject interface

SketchFillRegion interface

SketchImage interface

SketchSettings interface

Style interface

StyleEventsObject interface

StylesManager interface

SurfaceBody interface

SurfaceGraphicsEdge interface

SurfaceGraphicsFace interface

SurfaceTextureSymbol interface

SweepDefinition interface

TeardropHemDefinition interface

TextBox interface

TextureCoordinateSet interface

TextureMap interface

ThreePlanesWorkPointDef interface

ThreePointsWorkPlaneDef interface

TitleBlock interface

TitleBlockDefinition interface

Tolerance interface

TorusCenterPointWorkPointDef interface

TorusMidPlaneWorkPlaneDef interface

Trail interface

TrailSegment interface

Transaction interface

TransactionEventsObject interface

TransactionManager interface

TriadEventsObject interface

TwoLinesWorkPlaneDef interface

TwoLinesWorkPointDef interface

TwoPlanesWorkAxisDef interface

TwoPlanesWorkPlaneDef interface

TwoPointsWorkAxisDef interface

UnitsOfMeasure interface

UserCoordinateSystem interface

UserCoordinateSystemDefinition interface

UserInputEventsObject interface

UserInterfaceEventsObject interface

UserInterfaceManager interface

Vertex interface

View interface

Wire interface

WorkAxes interface

WorkAxis interface

WorkPlane interface

WorkPlanes interface

WorkPoint interface

WorkPoints interface

WorkSurface interface

WorkSurfaces interface

ParentAvailable

AttributeSets interface

ParentComponents

OccurrencePattern interface

ParentComposite

iMateResult interface

ParentFactory

iAssemblyMember interface

iPartMember interface

ParentFeatures

CircularPatternFeature interface

MirrorFeature interface

RectangularPatternFeature interface

ParentNode

ContentTreeViewNode interface

ParentOccurrence

ComponentOccurrence interface

ParentSketch

WorkAxis interface

WorkPlane interface

WorkPoint interface

ParentTransaction

Transaction interface

ParentView

Balloon interface

DrawingView interface

HoleTable interface

PartBody

CoreCavityDefinition interface

PartComponentDefinition interface

AnalysisManager

BIMComponent

CompactModelHistoryOnNextSave

CreateFactory

DeleteObjects

ExportObjects

Features

FindUsingRay

GetEndOfPartPosition

HasMultipleSolidBodies

iMateDefinitions

iPartFactory

iPartMember

IsContentMember

IsiPartFactory

IsiPartMember

MassProperties

Material

Parameters

PartEvents

ReferenceComponents

RepresentationsManager

RolledBackForEdit

SetEndOfPartToTopOrBottom

SketchBlockDefinitions

Sketches

Sketches3D

SuppressFeatures

UnsuppressFeatures

UserCoordinateSystems

WorkAxes

WorkPlanes

WorkPoints

WorkSurfaces

PartComponentDefinition.AnalysisManager property

PartComponentDefinition.BIMComponent property

PartComponentDefinition.CompactModelHistoryOnNextSave property

PartComponentDefinition.CreateFactory method

PartComponentDefinition.DeleteObjects method

PartComponentDefinition.ExportObjects method

PartComponentDefinition.Features property

PartComponentDefinition.FindUsingRay method

PartComponentDefinition.GetEndOfPartPosition method

PartComponentDefinition.HasMultipleSolidBodies property

PartComponentDefinition.iMateDefinitions property

PartComponentDefinition.iPartFactory property

PartComponentDefinition.iPartMember property

PartComponentDefinition.IsContentMember property

PartComponentDefinition.IsiPartFactory property

PartComponentDefinition.IsiPartMember property

PartComponentDefinition.MassProperties property

PartComponentDefinition.Material property

PartComponentDefinition.Parameters property

PartComponentDefinition.PartEvents property

PartComponentDefinition.ReferenceComponents property

PartComponentDefinition.RepresentationsManager property

PartComponentDefinition.RolledBackForEdit property

PartComponentDefinition.SetEndOfPartToTopOrBottom method

PartComponentDefinition.SketchBlockDefinitions property

PartComponentDefinition.Sketches property

PartComponentDefinition.Sketches3D property

PartComponentDefinition.SuppressFeatures method

PartComponentDefinition.UnsuppressFeatures method

PartComponentDefinition.UserCoordinateSystems property

PartComponentDefinition.WorkAxes property

PartComponentDefinition.WorkPlanes property

PartComponentDefinition.WorkPoints property

PartComponentDefinition.WorkSurfaces property

PartComponentDefinitions interface

Count

Item

Type

PartComponentDefinitions.Count property

PartComponentDefinitions.Item method

PartComponentDefinitions.Type property

PartDocument interface

ActiveLightingStyle

ActiveRenderStyle

ComponentDefinition

DisabledCommandList

DisplaySettings

EnvironmentManager

GetSelectedObject

IsSubstitutePart

LightingStyles

Materials

ModelingSettings

ObjectVisibility

PutGraphicsLevelsOfDetail

Sketch3DSettings

SketchActive

SketchSettings

SubstitutePartStatus

UpdateSubstitutePart

PartDocument.ActiveLightingStyle property

PartDocument.ActiveRenderStyle property

PartDocument.ComponentDefinition property

PartDocument.DisabledCommandList property

PartDocument.DisplaySettings property

PartDocument.EnvironmentManager property

PartDocument.GetSelectedObject method

PartDocument.IsSubstitutePart property

PartDocument.LightingStyles property

PartDocument.Materials property

PartDocument.ModelingSettings property

PartDocument.ObjectVisibility property

PartDocument.PutGraphicsLevelsOfDetail method

PartDocument.Sketch3DSettings property

PartDocument.SketchActive property

PartDocument.SketchSettings property

PartDocument.SubstitutePartStatus property

PartDocument.UpdateSubstitutePart method

PartEvents

FlatPattern interface

PartComponentDefinition interface

PartEvents coclass

PartEventsObject interface

Application

Parent

Type

PartEventsObject.Application property

PartEventsObject.Parent property

PartEventsObject.Type property

PartEventsSink interface

OnSurfaceBodyChanged

PartEventsSink.OnSurfaceBodyChanged method

PartFeature interface

Adaptive

Application

AttributeSets

ConsumeInputs

Delete

ExtendedName

Faces

FeatureDimensions

GetReferenceKey

GetRenderStyle

GetSuppressionCondition

HealthStatus

IsOwnedByFeature

Name

OwnedBy

Parameters

Parent

Participants

RangeBox

RemoveParticipant

SetAffectedBodies

SetEndOfPart

SetRenderStyle

SetSuppressionCondition

Shared

Suppressed

SurfaceBodies

SurfaceBody

Type

PartFeature.Adaptive property

PartFeature.Application property

PartFeature.AttributeSets property

PartFeature.ConsumeInputs property

PartFeature.Delete method

PartFeature.ExtendedName property

PartFeature.Faces property

PartFeature.FeatureDimensions property

PartFeature.GetReferenceKey method

PartFeature.GetRenderStyle method

PartFeature.GetSuppressionCondition method

PartFeature.HealthStatus property

PartFeature.IsOwnedByFeature property

PartFeature.Name property

PartFeature.OwnedBy property

PartFeature.Parameters property

PartFeature.Parent property

PartFeature.Participants property

PartFeature.RangeBox property

PartFeature.RemoveParticipant method

PartFeature.SetAffectedBodies method

PartFeature.SetEndOfPart method

PartFeature.SetRenderStyle method

PartFeature.SetSuppressionCondition method

PartFeature.Shared property

PartFeature.Suppressed property

PartFeature.SurfaceBodies property

PartFeature.SurfaceBody method

PartFeature.Type property

PartFeatureExtent interface

Application

Parent

Type

PartFeatureExtent.Application property

PartFeatureExtent.Parent property

PartFeatureExtent.Type property

PartFeatures interface

AliasFreeformFeatures

Application

BendPartFeatures

BossFeatures

BoundaryPatchFeatures

ChamferFeatures

CircularPatternFeatures

ClientFeatures

CoilFeatures

CombineFeatures

CoreCavityFeatures

Count

CreatePath

CreateSpecifiedPath

DecalFeatures

DeleteFaceFeatures

EmbossFeatures

ExtendFeatures

ExtrudeFeatures

FaceDraftFeatures

FilletFeatures

GrillFeatures

HoleFeatures

iFeatures

Item

KnitFeatures

LipFeatures

LoftFeatures

MirrorFeatures

MoveFaceFeatures

MoveFeatures

NonParametricBaseFeatures

RectangularPatternFeatures

ReferenceFeatures

ReplaceFaceFeatures

RestFeatures

RevolveFeatures

RibFeatures

RuleFilletFeatures

SculptFeatures

ShellFeatures

SnapFitFeatures

SplitFeatures

SweepFeatures

ThickenFeatures

ThreadFeatures

TrimFeatures

Type

PartFeatures.AliasFreeformFeatures property

PartFeatures.Application property

PartFeatures.BendPartFeatures property

PartFeatures.BossFeatures property

PartFeatures.BoundaryPatchFeatures property

PartFeatures.ChamferFeatures property

PartFeatures.CircularPatternFeatures property

PartFeatures.ClientFeatures property

PartFeatures.CoilFeatures property

PartFeatures.CombineFeatures property

PartFeatures.CoreCavityFeatures method

PartFeatures.Count property

PartFeatures.CreatePath method

PartFeatures.CreateSpecifiedPath method

PartFeatures.DecalFeatures property

PartFeatures.DeleteFaceFeatures property

PartFeatures.EmbossFeatures property

PartFeatures.ExtendFeatures property

PartFeatures.ExtrudeFeatures property

PartFeatures.FaceDraftFeatures property

PartFeatures.FilletFeatures property

PartFeatures.GrillFeatures property

PartFeatures.HoleFeatures property

PartFeatures.iFeatures property

PartFeatures.Item method

PartFeatures.KnitFeatures property

PartFeatures.LipFeatures property

PartFeatures.LoftFeatures property

PartFeatures.MirrorFeatures property

PartFeatures.MoveFaceFeatures property

PartFeatures.MoveFeatures property

PartFeatures.NonParametricBaseFeatures property

PartFeatures.RectangularPatternFeatures property

PartFeatures.ReferenceFeatures property

PartFeatures.ReplaceFaceFeatures property

PartFeatures.RestFeatures property

PartFeatures.RevolveFeatures property

PartFeatures.RibFeatures property

PartFeatures.RuleFilletFeatures property

PartFeatures.SculptFeatures property

PartFeatures.ShellFeatures property

PartFeatures.SnapFitFeatures property

PartFeatures.SplitFeatures property

PartFeatures.SweepFeatures property

PartFeatures.ThickenFeatures property

PartFeatures.ThreadFeatures property

PartFeatures.TrimFeatures property

PartFeatures.Type property

PartFeaturesEnumerator interface

Count

Item

Type

PartFeaturesEnumerator.Count property

PartFeaturesEnumerator.Item method

PartFeaturesEnumerator.Type property

PartFeaturesInitiallyAdaptive

AssemblyOptions interface

PartialCircularThreadEdge

DrawingStandardStyle interface

PartialSectionThreadEnd

DrawingStandardStyle interface

Participants

PartFeature interface

PartIdentifier

iPartTableRow interface

PartName

iPartTableRow interface

PartNameModifiable

iPartTableRow interface

Partner

EdgeUse interface

PartNumberIndexDigits

FactoryOptions interface

PartNumberIndexInitialValue

FactoryOptions interface

PartNumberIndexSeparator

FactoryOptions interface

PartNumberIndexStepValue

FactoryOptions interface

PartNumberType

FactoryOptions interface

PartNumberValue

FactoryOptions interface

PartOffset

DimensionStyle interface

PartOptions interface

Application

AutoConsumeWorkAndSurfaceFeatures

AutoHideInLineWorkFeatures

DefaultDesignView

DefaultDesignViewIsAssociative

DimensionConstraintsRelaxation

DisplayExtendedName

DisplayGripsOnSelection

EditBaseSolidsUsingFusion

Enable3DGrips

GeometricConstraintsBreakage

OpaqueConstructionSurfaces

SketchCreationOnNewPart

Type

PartOptions.Application property

PartOptions.AutoConsumeWorkAndSurfaceFeatures property

PartOptions.AutoHideInLineWorkFeatures property

PartOptions.DefaultDesignView property

PartOptions.DefaultDesignViewIsAssociative property

PartOptions.DimensionConstraintsRelaxation property

PartOptions.DisplayExtendedName property

PartOptions.DisplayGripsOnSelection property

PartOptions.EditBaseSolidsUsingFusion property

PartOptions.Enable3DGrips property

PartOptions.GeometricConstraintsBreakage property

PartOptions.OpaqueConstructionSurfaces property

PartOptions.SketchCreationOnNewPart property

PartOptions.Type property

PartsList interface

Application

AttributeSets

ColumnHeaderTextStyle

CopyTo

DataTextStyle

Delete

Export

GetReferenceKey

HeadingPlacement

HideZeroQuantityRows

Layer

Level

MaximumRows

MembersToInclude

NumberingScheme

NumberOfSections

Parent

PartsListColumns

PartsListRows

Position

RangeBox

ReferencedDocumentDescriptor

Renumber

Rotation

RowGap

RowLineSpacing

SaveItemOverridesToBOM

ShowTitle

Sort

Style

TableDirection

Title

TitleTextStyle

Type

WrapAutomatically

WrapLeft

PartsList.Application property

PartsList.AttributeSets property

PartsList.ColumnHeaderTextStyle property

PartsList.CopyTo method

PartsList.DataTextStyle property

PartsList.Delete method

PartsList.Export method

PartsList.GetReferenceKey method

PartsList.HeadingPlacement property

PartsList.HideZeroQuantityRows property

PartsList.Layer property

PartsList.Level property

PartsList.MaximumRows property

PartsList.MembersToInclude property

PartsList.NumberingScheme property

PartsList.NumberOfSections property

PartsList.Parent property

PartsList.PartsListColumns property

PartsList.PartsListRows property

PartsList.Position property

PartsList.RangeBox property

PartsList.ReferencedDocumentDescriptor property

PartsList.Renumber method

PartsList.Rotation property

PartsList.RowGap property

PartsList.RowLineSpacing property

PartsList.SaveItemOverridesToBOM method

PartsList.ShowTitle property

PartsList.Sort method

PartsList.Style property

PartsList.TableDirection property

PartsList.Title property

PartsList.TitleTextStyle property

PartsList.Type property

PartsList.WrapAutomatically property

PartsList.WrapLeft property

PartsListCell interface

Application

Parent

Static

Static

Type

Update

UpToDate

Value

PartsListCell.Application property

PartsListCell.Parent property

PartsListCell.Static method

PartsListCell.Static property

PartsListCell.Type property

PartsListCell.Update method

PartsListCell.UpToDate method

PartsListCell.Value property

PartsListColumn interface

Application

CustomPropertyName

GetFilePropertyId

Parent

PropertyType

Remove

Reposition

Title

TitleHorizontalJustification

Type

ValueHorizontalJustification

Width

PartsListColumn.Application property

PartsListColumn.CustomPropertyName property

PartsListColumn.GetFilePropertyId method

PartsListColumn.Parent property

PartsListColumn.PropertyType property

PartsListColumn.Remove method

PartsListColumn.Reposition method

PartsListColumn.Title property

PartsListColumn.TitleHorizontalJustification property

PartsListColumn.Type property

PartsListColumn.ValueHorizontalJustification property

PartsListColumn.Width property

PartsListColumns

PartsList interface

PartsListColumns interface

Add

Application

Count

Item

Type

PartsListColumns.Add method

PartsListColumns.Application property

PartsListColumns.Count property

PartsListColumns.Item method

PartsListColumns.Type property

PartsListLayer

ObjectDefaultsStyle interface

PartsListRow interface

Application

Ballooned

Count

Custom

Expandable

Expanded

Height

Item

Parent

ReferencedFiles

ReferencedRows

Remove

Reposition

SaveItemOverridesToBOM

Type

Visible

PartsListRow.Application property

PartsListRow.Ballooned property

PartsListRow.Count property

PartsListRow.Custom property

PartsListRow.Expandable property

PartsListRow.Expanded property

PartsListRow.Height property

PartsListRow.Item method

PartsListRow.Parent property

PartsListRow.ReferencedFiles method

PartsListRow.ReferencedRows property

PartsListRow.Remove method

PartsListRow.Reposition method

PartsListRow.SaveItemOverridesToBOM method

PartsListRow.Type property

PartsListRow.Visible property

PartsListRows

PartsList interface

PartsListRows interface

Add

Application

Count

Item

Type

PartsListRows.Add method

PartsListRows.Application property

PartsListRows.Count property

PartsListRows.Item method

PartsListRows.Type property

PartsLists

Sheet interface

PartsLists interface

Add

Application

Count

Item

Type

PartsLists.Add method

PartsLists.Application property

PartsLists.Count property

PartsLists.Item method

PartsLists.Type property

PartsListStyle

ObjectDefaultsStyle interface

PartsListStyle interface

AddColumn

ColumnHeaderTextStyle

DataTextStyle

HeadingGap

HeadingPlacement

RemoveAllColumns

RowGap

RowLineSpacing

ShowTitle

TableDirection

Title

TitleTextStyle

PartsListStyle.AddColumn method

PartsListStyle.ColumnHeaderTextStyle property

PartsListStyle.DataTextStyle property

PartsListStyle.HeadingGap property

PartsListStyle.HeadingPlacement property

PartsListStyle.RemoveAllColumns method

PartsListStyle.RowGap property

PartsListStyle.RowLineSpacing property

PartsListStyle.ShowTitle property

PartsListStyle.TableDirection property

PartsListStyle.Title property

PartsListStyle.TitleTextStyle property

PartsListStyles

DrawingStylesManager interface

PartsListStylesEnumerator interface

_NewEnum

Application

Count

Item

Type

PartsListStylesEnumerator._NewEnum property

PartsListStylesEnumerator.Application property

PartsListStylesEnumerator.Count property

PartsListStylesEnumerator.Item method

PartsListStylesEnumerator.Type property

PartsOnlyViewEnabled

BOM interface

PartsOnlyViewMinimumDigits

BOM interface

PartsOnlyViewNumberingScheme

BOM interface

Path

ContourFlangeDefinition interface

ProjectPath interface

SweepFeature interface

Path interface

Application

AttributeSets

Closed

Count

GetReferenceKey

Item

Type

Wires

Path.Application property

Path.AttributeSets property

Path.Closed property

Path.Count property

Path.GetReferenceKey method

Path.Item method

Path.Type property

Path.Wires property

PathAndGuideRailSweepDef interface

GuideRail

ProfileScaling

PathAndGuideRailSweepDef.GuideRail property

PathAndGuideRailSweepDef.ProfileScaling property

PathAndGuideSurfaceSweepDef interface

GuideSurface

PathAndGuideSurfaceSweepDef.GuideSurface property

PathAndSectionTwistsSweepDef interface

GetSectionTwists

ProfileOrientation

SetSectionTwists

TaperAngle

PathAndSectionTwistsSweepDef.GetSectionTwists method

PathAndSectionTwistsSweepDef.ProfileOrientation property

PathAndSectionTwistsSweepDef.SetSectionTwists method

PathAndSectionTwistsSweepDef.TaperAngle property

PathEntity interface

Application

Curve

CurveType

GetReferenceKey

OpposedToSketchEntity

Parent

SketchEntity

Type

PathEntity.Application property

PathEntity.Curve property

PathEntity.CurveType property

PathEntity.GetReferenceKey method

PathEntity.OpposedToSketchEntity property

PathEntity.Parent property

PathEntity.SketchEntity property

PathEntity.Type property

PathEntityProxy interface

ContainingOccurrence

NativeObject

PathEntityProxy.ContainingOccurrence property

PathEntityProxy.NativeObject property

PathProxy interface

ContainingOccurrence

NativeObject

PathProxy.ContainingOccurrence property

PathProxy.NativeObject property

PathSweepDef interface

ProfileOrientation

TaperAngle

PathSweepDef.ProfileOrientation property

PathSweepDef.TaperAngle property

PatternCenter

Centerline interface

PatternConstraint interface

PatternConstraintProxy interface

ContainingOccurrence

NativeObject

PatternConstraintProxy.ContainingOccurrence property

PatternConstraintProxy.NativeObject property

PatternElement

ComponentOccurrence interface

OccurrencePattern interface

PatternElements

CircularPatternFeature interface

MirrorFeature interface

RectangularPatternFeature interface

PatternOfBody

CircularPatternFeature interface

RectangularPatternFeature interface

PauseDelay

DriveConstraintSettingsObject interface

PeekPrivateEvent

CommandManager interface

PercentLength

FilletIntermediateRadius interface

PercentOverlap

CornerDefinition interface

Perimeter

RegionProperties interface

PerpendicularConstraint interface

EntityOne

EntityTwo

UseEllipseOneMajorAxis

UseEllipseTwoMajorAxis

PerpendicularConstraint.EntityOne property

PerpendicularConstraint.EntityTwo property

PerpendicularConstraint.UseEllipseOneMajorAxis property

PerpendicularConstraint.UseEllipseTwoMajorAxis property

PerpendicularConstraint3D interface

EntityOne

EntityTwo

PerpendicularConstraint3D.EntityOne property

PerpendicularConstraint3D.EntityTwo property

PerpendicularConstraint3DProxy interface

ContainingOccurrence

NativeObject

PerpendicularConstraint3DProxy.ContainingOccurrence property

PerpendicularConstraint3DProxy.NativeObject property

PerpendicularConstraintProxy interface

ContainingOccurrence

NativeObject

PerpendicularConstraintProxy.ContainingOccurrence property

PerpendicularConstraintProxy.NativeObject property

Perspective

Camera interface

PerspectiveAngle

Camera interface

Pick

CommandManager interface

Pitch

PitchAndHeightCoilExtent interface

PitchAndRevolutionCoilExtent interface

SpiralCoilExtent interface

StandardThreadInfo interface

TaperedThreadInfo interface

PitchAndHeightCoilExtent interface

Height

Pitch

TaperAngle

PitchAndHeightCoilExtent.Height property

PitchAndHeightCoilExtent.Pitch property

PitchAndHeightCoilExtent.TaperAngle property

PitchAndRevolutionCoilExtent interface

Pitch

Revolution

TaperAngle

PitchAndRevolutionCoilExtent.Pitch property

PitchAndRevolutionCoilExtent.Revolution property

PitchAndRevolutionCoilExtent.TaperAngle property

PitchDiameterMax

StandardThreadInfo interface

PitchDiameterMin

StandardThreadInfo interface

PlacementDefinition

HoleFeature interface

PlacementDirection

Balloon interface

PlacementType

HoleFeature interface

PlanarEntity

PlanarSketch interface

PlanarEntityGeometry

PlanarSketch interface

PlanarMoveDefinition interface

Application

Parent

Plane

PointOne

PointTwo

Type

PlanarMoveDefinition.Application property

PlanarMoveDefinition.Parent property

PlanarMoveDefinition.Plane property

PlanarMoveDefinition.PointOne property

PlanarMoveDefinition.PointTwo property

PlanarMoveDefinition.Type property

PlanarSketch interface

Adaptive

AddBySilhouette

AxisEntity

AxisEntityGeometry

AxisIsX

BreakLink

Consumed

CopyToFlatPattern

Dependents

DimensionsVisible

Exported

HasReferenceComponent

HealthStatus

IsOwnedByFeature

ModelToSketchSpace

ModelToSketchTransform

NaturalAxisDirection

OriginPoint

OriginPointGeometry

OwnedBy

PlanarEntity

PlanarEntityGeometry

Profiles

ProjectedCuts

ReferenceComponent

ReferencedEntity

SetEndOfPart

Shared

SketchBlocks

SketchToModelSpace

SketchToModelTransform

UpdateProfiles

PlanarSketch.Adaptive property

PlanarSketch.AddBySilhouette method

PlanarSketch.AxisEntity property

PlanarSketch.AxisEntityGeometry property

PlanarSketch.AxisIsX property

PlanarSketch.BreakLink method

PlanarSketch.Consumed property

PlanarSketch.CopyToFlatPattern property

PlanarSketch.Dependents property

PlanarSketch.DimensionsVisible property

PlanarSketch.Exported property

PlanarSketch.HasReferenceComponent property

PlanarSketch.HealthStatus property

PlanarSketch.IsOwnedByFeature property

PlanarSketch.ModelToSketchSpace method

PlanarSketch.ModelToSketchTransform property

PlanarSketch.NaturalAxisDirection property

PlanarSketch.OriginPoint property

PlanarSketch.OriginPointGeometry property

PlanarSketch.OwnedBy property

PlanarSketch.PlanarEntity property

PlanarSketch.PlanarEntityGeometry property

PlanarSketch.Profiles property

PlanarSketch.ProjectedCuts property

PlanarSketch.ReferenceComponent property

PlanarSketch.ReferencedEntity property

PlanarSketch.SetEndOfPart method

PlanarSketch.Shared property

PlanarSketch.SketchBlocks property

PlanarSketch.SketchToModelSpace method

PlanarSketch.SketchToModelTransform property

PlanarSketch.UpdateProfiles method

PlanarSketches interface

Add

AddWithOrientation

Application

Count

Item

Type

PlanarSketches.Add method

PlanarSketches.AddWithOrientation method

PlanarSketches.Application property

PlanarSketches.Count property

PlanarSketches.Item method

PlanarSketches.Type property

PlanarSketchProxy interface

ContainingOccurrence

NativeObject

PlanarSketchProxy.ContainingOccurrence property

PlanarSketchProxy.NativeObject property

Plane

ConcentricHolePlacementDefinition interface

GroundPlaneSettings interface

LineAndPlaneWorkAxisDef interface

LinearHolePlacementDefinition interface

LinePlaneAndAngleWorkPlaneDef interface

PlanarMoveDefinition interface

PlaneAndOffsetWorkPlaneDef interface

PlaneAndPointWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

PointAndPlaneDistanceDimConstraint3D interface

PointAndPlaneWorkAxisDef interface

WorkPlane interface

Plane interface

DistanceTo

Evaluator

GetPlaneData

IntersectWithCurve

IntersectWithLine

IntersectWithPlane

IntersectWithSurface

IsCoplanarTo

IsParallelTo

IsPerpendicularTo

Normal

PutPlaneData

RootPoint

Plane.DistanceTo method

Plane.Evaluator property

Plane.GetPlaneData method

Plane.IntersectWithCurve method

Plane.IntersectWithLine method

Plane.IntersectWithPlane method

Plane.IntersectWithSurface method

Plane.IsCoplanarTo method

Plane.IsParallelTo method

Plane.IsPerpendicularTo method

Plane.Normal property

Plane.PutPlaneData method

Plane.RootPoint property

Plane1

ThreePlanesWorkPointDef interface

TwoPlanesWorkAxisDef interface

TwoPlanesWorkPlaneDef interface

Plane2

ThreePlanesWorkPointDef interface

TwoPlanesWorkAxisDef interface

TwoPlanesWorkPlaneDef interface

Plane3

ThreePlanesWorkPointDef interface

PlaneAndOffsetWorkPlaneDef interface

Application

GetData

Offset

Parent

Plane

Type

PlaneAndOffsetWorkPlaneDef.Application property

PlaneAndOffsetWorkPlaneDef.GetData method

PlaneAndOffsetWorkPlaneDef.Offset property

PlaneAndOffsetWorkPlaneDef.Parent property

PlaneAndOffsetWorkPlaneDef.Plane property

PlaneAndOffsetWorkPlaneDef.Type property

PlaneAndPointWorkPlaneDef interface

Application

GetData

Parent

Plane

Point

Type

PlaneAndPointWorkPlaneDef.Application property

PlaneAndPointWorkPlaneDef.GetData method

PlaneAndPointWorkPlaneDef.Parent property

PlaneAndPointWorkPlaneDef.Plane property

PlaneAndPointWorkPlaneDef.Point property

PlaneAndPointWorkPlaneDef.Type property

PlaneAndTangentWorkPlaneDef interface

Application

Face

GetData

Parent

Plane

ProximityPoint

Type

PlaneAndTangentWorkPlaneDef.Application property

PlaneAndTangentWorkPlaneDef.Face property

PlaneAndTangentWorkPlaneDef.GetData method

PlaneAndTangentWorkPlaneDef.Parent property

PlaneAndTangentWorkPlaneDef.Plane property

PlaneAndTangentWorkPlaneDef.ProximityPoint property

PlaneAndTangentWorkPlaneDef.Type property

PlaneInput

iFeatureSketchPlaneInput interface

iFeatureWorkPlaneInput interface

PlayForward

DriveConstraintSettingsObject interface

PlayReverse

DriveConstraintSettingsObject interface

Plot

Layer interface

Point

AssemblyWorkPointDef interface

FixedWorkPointDef interface

LineAndPointWorkAxisDef interface

MidpointConstraint interface

MidpointConstraint3D interface

NormalToCurveWorkPlaneDef interface

NormalToSurfaceWorkAxisDef interface

PlaneAndPointWorkPlaneDef interface

PointAndPlaneDistanceDimConstraint3D interface

PointAndPlaneWorkAxisDef interface

PointAndTangentWorkPlaneDef interface

PointHolePlacementDefinition interface

PointWorkPointDef interface

SinglePointRipTypeDef interface

SplineFitPointConstraint interface

Vertex interface

WorkPoint interface

Point interface

DistanceTo

GetPointData

IsEqualTo

PutPointData

TransformBy

TranslateBy

VectorTo

X

Y

Z

Point.DistanceTo method

Point.GetPointData method

Point.IsEqualTo method

Point.PutPointData method

Point.TransformBy method

Point.TranslateBy method

Point.VectorTo method

Point.X property

Point.Y property

Point.Z property

Point1

ThreePointsWorkPlaneDef interface

TwoPointsWorkAxisDef interface

Point2

ThreePointsWorkPlaneDef interface

TwoPointsWorkAxisDef interface

Point2d interface

DistanceTo

GetPointData

IsEqualTo

PutPointData

TransformBy

TranslateBy

VectorTo

X

Y

Point2d.DistanceTo method

Point2d.GetPointData method

Point2d.IsEqualTo method

Point2d.PutPointData method

Point2d.TransformBy method

Point2d.TranslateBy method

Point2d.VectorTo method

Point2d.X property

Point2d.Y property

Point3

ThreePointsWorkPlaneDef interface

PointAlignment

SketchOptions interface

PointAndPlaneDistanceDimConstraint3D interface

Plane

Point

PointAndPlaneDistanceDimConstraint3D.Plane property

PointAndPlaneDistanceDimConstraint3D.Point property

PointAndPlaneDistanceDimConstraint3DProxy interface

ContainingOccurrence

NativeObject

PointAndPlaneDistanceDimConstraint3DProxy.ContainingOccurrence property

PointAndPlaneDistanceDimConstraint3DProxy.NativeObject property

PointAndPlaneWorkAxisDef interface

Application

GetData

Parent

Plane

Point

Type

PointAndPlaneWorkAxisDef.Application property

PointAndPlaneWorkAxisDef.GetData method

PointAndPlaneWorkAxisDef.Parent property

PointAndPlaneWorkAxisDef.Plane property

PointAndPlaneWorkAxisDef.Point property

PointAndPlaneWorkAxisDef.Type property

PointAndTangentWorkPlaneDef interface

Application

Face

GetData

Parent

Point

Type

PointAndTangentWorkPlaneDef.Application property

PointAndTangentWorkPlaneDef.Face property

PointAndTangentWorkPlaneDef.GetData method

PointAndTangentWorkPlaneDef.Parent property

PointAndTangentWorkPlaneDef.Point property

PointAndTangentWorkPlaneDef.Type property

PointAtIndex

Polyline2d interface

Polyline3d interface

PointCount

MapPointCurve interface

Polyline2d interface

Polyline3d interface

PointerInputEnabled

HeadsUpDisplayOptions interface

PointerInputInCartesianCoordinates

HeadsUpDisplayOptions interface

PointGraphics interface

BurnThrough

CoordinateIndexSet

CoordinateSet

DepthPriority

GetCustomImage

PointRenderStyle

SetCustomImage

PointGraphics.BurnThrough property

PointGraphics.CoordinateIndexSet property

PointGraphics.CoordinateSet property

PointGraphics.DepthPriority property

PointGraphics.GetCustomImage method

PointGraphics.PointRenderStyle property

PointGraphics.SetCustomImage method

PointHolePlacementDefinition interface

Direction

Point

PointHolePlacementDefinition.Direction property

PointHolePlacementDefinition.Point property

PointInference interface

Application

Entity

InferenceType

Type

PointInference.Application property

PointInference.Entity property

PointInference.InferenceType property

PointInference.Type property

PointInferenceEnabled

MouseEventsObject interface

PointInferenceEnumerator interface

Count

Item

Type

PointInferenceEnumerator.Count property

PointInferenceEnumerator.Item method

PointInferenceEnumerator.Type property

PointInferences

MouseEventsObject interface

PointOne

HorizontalAlignConstraint interface

PlanarMoveDefinition interface

PointToPointRipTypeDef interface

ThreePointAngleDimConstraint interface

TwoPointDistanceDimConstraint interface

TwoPointDistanceDimConstraint3D interface

VerticalAlignConstraint interface

PointOnEdge

Edge interface

PointOnFace

Face interface

PointOnSheet

GeometryIntent interface

PointRenderStyle

PointGraphics interface

Points

SplineFitPointsConstraint3D interface

PointThree

ThreePointAngleDimConstraint interface

PointTolerance

TransientGeometry interface

PointToPointRipTypeDef interface

GapSide

GapSize

Parent

PointOne

PointTwo

Type

PointToPointRipTypeDef.GapSide property

PointToPointRipTypeDef.GapSize property

PointToPointRipTypeDef.Parent property

PointToPointRipTypeDef.PointOne property

PointToPointRipTypeDef.PointTwo property

PointToPointRipTypeDef.Type property

PointTwo

HorizontalAlignConstraint interface

PlanarMoveDefinition interface

PointToPointRipTypeDef interface

ThreePointAngleDimConstraint interface

TwoPointDistanceDimConstraint interface

TwoPointDistanceDimConstraint3D interface

VerticalAlignConstraint interface

PointWorkPointDef interface

Application

Parent

Point

Type

PointWorkPointDef.Application property

PointWorkPointDef.Parent property

PointWorkPointDef.Point property

PointWorkPointDef.Type property

PoissonsRatio

Material interface

PoleAtIndex

BSplineCurve interface

BSplineCurve interface

BSplineCurve2d interface

BSplineCurve2d interface

BSplineSurface interface

Polyline2d interface

Evaluator

GetPoints

PointAtIndex

PointCount

PutPoints

Polyline2d.Evaluator property

Polyline2d.GetPoints method

Polyline2d.PointAtIndex method

Polyline2d.PointCount property

Polyline2d.PutPoints method

Polyline3d interface

Evaluator

GetPoints

PointAtIndex

PointCount

PutPoints

Polyline3d.Evaluator property

Polyline3d.GetPoints method

Polyline3d.PointAtIndex method

Polyline3d.PointCount property

Polyline3d.PutPoints method

PopulateFileMetadata

FileUIEventsObject interface

Position

AutoCADBlock interface

Balloon interface

Centermark interface

CustomTable interface

DrawingNote interface

DrawingView interface

DrawingViewLabel interface

FeatureControlFrame interface

FlatPunchResult interface

GroundPlaneSettings interface

HoleTable interface

HoleTag interface

LeaderNode interface

Light interface

LoftSectionDimension interface

MiniToolbarObject interface

PartsList interface

RevisionTable interface

SketchBlock interface

SketchedSymbol interface

SketchImage interface

SurfaceTextureSymbol interface

TitleBlock interface

VertexDefinition interface

PositionalRepresentation interface

Activate

Application

AttributeSets

Copy

Delete

GetReferenceKey

IsConstraintSuppressionOverridden

IsConstraintValueOverridden

IsFlexibleOverridden

IsGroundingOverridden

IsPatternAngleOffsetOverridden

IsPatternColumnOffsetOverridden

IsPatternRowOffsetOverridden

IsPositionalRepresentationOverridden

IsTransformOverridden

Master

Name

Parent

RemoveConstraintSuppressionOverride

RemoveConstraintValueOverride

RemoveFlexibleOverride

RemoveGroundingOverride

RemovePatternAngleOffsetOverride

RemovePatternColumnOffsetOverride

RemovePatternRowOffsetOverride

RemovePositionalRepresentationOverride

RemoveTransformOverride

SetConstraintSuppressionOverride

SetConstraintValueOverride

SetFlexibleOverride

SetGroundingOverride

SetPatternAngleOffsetOverride

SetPatternColumnOffsetOverride

SetPatternRowOffsetOverride

SetPositionalRepresentationOverride

SetTransformOverride

Type

PositionalRepresentation.Activate method

PositionalRepresentation.Application property

PositionalRepresentation.AttributeSets property

PositionalRepresentation.Copy method

PositionalRepresentation.Delete method

PositionalRepresentation.GetReferenceKey method

PositionalRepresentation.IsConstraintSuppressionOverridden method

PositionalRepresentation.IsConstraintValueOverridden method

PositionalRepresentation.IsFlexibleOverridden method

PositionalRepresentation.IsGroundingOverridden method

PositionalRepresentation.IsPatternAngleOffsetOverridden method

PositionalRepresentation.IsPatternColumnOffsetOverridden method

PositionalRepresentation.IsPatternRowOffsetOverridden method

PositionalRepresentation.IsPositionalRepresentationOverridden method

PositionalRepresentation.IsTransformOverridden method

PositionalRepresentation.Master property

PositionalRepresentation.Name property

PositionalRepresentation.Parent property

PositionalRepresentation.RemoveConstraintSuppressionOverride method

PositionalRepresentation.RemoveConstraintValueOverride method

PositionalRepresentation.RemoveFlexibleOverride method

PositionalRepresentation.RemoveGroundingOverride method

PositionalRepresentation.RemovePatternAngleOffsetOverride method

PositionalRepresentation.RemovePatternColumnOffsetOverride method

PositionalRepresentation.RemovePatternRowOffsetOverride method

PositionalRepresentation.RemovePositionalRepresentationOverride method

PositionalRepresentation.RemoveTransformOverride method

PositionalRepresentation.SetConstraintSuppressionOverride method

PositionalRepresentation.SetConstraintValueOverride method

PositionalRepresentation.SetFlexibleOverride method

PositionalRepresentation.SetGroundingOverride method

PositionalRepresentation.SetPatternAngleOffsetOverride method

PositionalRepresentation.SetPatternColumnOffsetOverride method

PositionalRepresentation.SetPatternRowOffsetOverride method

PositionalRepresentation.SetPositionalRepresentationOverride method

PositionalRepresentation.SetTransformOverride method

PositionalRepresentation.Type property

PositionalRepresentations

RepresentationsManager interface

PositionalRepresentations interface

Add

Application

Count

ExcelWorkSheet

Item

Type

PositionalRepresentations.Add method

PositionalRepresentations.Application property

PositionalRepresentations.Count property

PositionalRepresentations.ExcelWorkSheet property

PositionalRepresentations.Item method

PositionalRepresentations.Type property

PositionAsAbsoluteDistance

LoftSectionDimension interface

PositiveBothDirections

OrdinateDimensionSet interface

PositiveDirection

WidthOffsetWidthExtent interface

PostMultiplyBy

Matrix interface

Matrix2d interface

PostPrivateEvent

CommandManager interface

PowerFactor

BIMElectricalConnectorDefinition interface

PowerFactorState

BIMElectricalConnectorDefinition interface

Precision

BaselineDimensionSet interface

ChainDimensionSet interface

CustomPropertyFormat interface

DrawingDimension interface

MiniToolbarValueEditorObject interface

OrdinateDimensionSet interface

Parameter interface

Prefix

DimensionStyle interface

PrefixAndSuffixOrder

DimensionStyle interface

PreMultiplyBy

Matrix interface

Matrix2d interface

Preparations

WeldmentComponentDefinition interface

Preparations interface

Application

Edit

ExitEdit

Type

Preparations.Application property

Preparations.Edit method

Preparations.ExitEdit method

Preparations.Type property

PreSelectBurnThrough

SelectEventsObject interface

PresentationDocument interface

ActiveExplodedView

ActiveLightingStyle

DisabledCommandList

DisplaySettings

EnvironmentManager

LightingStyles

PresentationExplodedViews

PresentationDocument.ActiveExplodedView property

PresentationDocument.ActiveLightingStyle property

PresentationDocument.DisabledCommandList property

PresentationDocument.DisplaySettings property

PresentationDocument.EnvironmentManager property

PresentationDocument.LightingStyles property

PresentationDocument.PresentationExplodedViews property

PresentationExplodedView interface

Activate

Application

Delete

GetRenderStyle

GetTransform

GetVisibility

Name

Parent

SetRenderStyle

SetVisibility

Trails

Type

PresentationExplodedView.Activate method

PresentationExplodedView.Application property

PresentationExplodedView.Delete method

PresentationExplodedView.GetRenderStyle method

PresentationExplodedView.GetTransform method

PresentationExplodedView.GetVisibility method

PresentationExplodedView.Name property

PresentationExplodedView.Parent property

PresentationExplodedView.SetRenderStyle method

PresentationExplodedView.SetVisibility method

PresentationExplodedView.Trails method

PresentationExplodedView.Type property

PresentationExplodedViews

PresentationDocument interface

PresentationExplodedViews interface

Application

Count

Item

Type

PresentationExplodedViews.Application property

PresentationExplodedViews.Count property

PresentationExplodedViews.Item method

PresentationExplodedViews.Type property

PresentationOptions interface

Application

SkipAllUnresolvedFiles

Type

PresentationOptions.Application property

PresentationOptions.SkipAllUnresolvedFiles property

PresentationOptions.Type property

PresentationViewAssociative

DrawingView interface

PreserveAllFeatures

ChamferFeature interface

FilletFeature interface

PreserveOrphanedAnnotations

DrawingSettings interface

PreserveTagging

HoleTable interface

HoleTableStyle interface

PresetLineWeights

DrawingStandardStyle interface

PresetScales

DrawingStandardStyle interface

PresetSectionHatchAngles

DrawingStandardStyle interface

PresetTextHeights

DrawingStandardStyle interface

Pressed

ButtonDefinitionObject interface

MiniToolbarButtonObject interface

MiniToolbarDropdownObject interface

PreviewClientGraphics

InteractionGraphics interface

Previous

EdgeUse interface

PrimaryBody

iPartMember interface

PrimarySelectColor

ColorScheme interface

PrimarySelectColor2D

ColorScheme interface

PrincipalAxes

RegionProperties interface

PrincipalMomentsOfInertia

MassProperties interface

RegionProperties interface

Printer

ApprenticePrintManager interface

PrintManager interface

PrinterDeviceContext

ApprenticePrintManager interface

PrintManager interface

PrintExcludedSheets

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

PrintManager

ApprenticeServerDocument interface

Document interface

PrintManager interface

Application

ColorMode

NumberOfCopies

Orientation

PaperHeight

PaperSize

PaperSource

PaperWidth

Printer

PrinterDeviceContext

PrintToFile

SubmitPrint

Type

PrintManager.Application property

PrintManager.ColorMode property

PrintManager.NumberOfCopies property

PrintManager.Orientation property

PrintManager.PaperHeight property

PrintManager.PaperSize property

PrintManager.PaperSource property

PrintManager.PaperWidth property

PrintManager.Printer property

PrintManager.PrinterDeviceContext property

PrintManager.PrintToFile method

PrintManager.SubmitPrint method

PrintManager.Type property

PrintRange

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

PrintToFile

ApprenticePrintManager interface

PrintManager interface

ProcessViewSelection

DrawingDocument interface

ProductEdition

SoftwareVersion interface

ProductionMethod

SurfaceTextureSymbol interface

ProductName

SoftwareVersion interface

Profile

BreakOutOperation interface

CoilFeature interface

CutDefinition interface

EmbossFeature interface

ExtrudeDefinition interface

FaceFeatureDefinition interface

RevolveFeature interface

SketchFillRegion interface

SweepFeature interface

Profile interface

Application

AttributeSets

Count

Delete

GetReferenceKey

Item

MergeFaces

Parent

RegionProperties

Type

Wires

Profile.Application property

Profile.AttributeSets property

Profile.Count property

Profile.Delete method

Profile.GetReferenceKey method

Profile.Item method

Profile.MergeFaces property

Profile.Parent property

Profile.RegionProperties property

Profile.Type property

Profile.Wires property

Profile3D interface

Application

AttributeSets

Count

Delete

GetReferenceKey

Item

Parent

Type

Wires

Profile3D.Application property

Profile3D.AttributeSets property

Profile3D.Count property

Profile3D.Delete method

Profile3D.GetReferenceKey method

Profile3D.Item method

Profile3D.Parent property

Profile3D.Type property

Profile3D.Wires property

Profile3DProxy interface

ContainingOccurrence

NativeObject

Profile3DProxy.ContainingOccurrence property

Profile3DProxy.NativeObject property

ProfileCurves

RibDefinition interface

ProfileEntity interface

Application

AttributeSets

Curve

CurveType

EndSketchPoint

GetReferenceKey

OpposedToSketchEntity

Parent

SketchEntity

StartSketchPoint

Type

ProfileEntity.Application property

ProfileEntity.AttributeSets property

ProfileEntity.Curve property

ProfileEntity.CurveType property

ProfileEntity.EndSketchPoint property

ProfileEntity.GetReferenceKey method

ProfileEntity.OpposedToSketchEntity property

ProfileEntity.Parent property

ProfileEntity.SketchEntity property

ProfileEntity.StartSketchPoint property

ProfileEntity.Type property

ProfileEntity3D interface

Application

AttributeSets

Curve

CurveType

EndSketchPoint

GetReferenceKey

OpposedToSketchEntity

Parent

SketchEntity

StartSketchPoint

Type

ProfileEntity3D.Application property

ProfileEntity3D.AttributeSets property

ProfileEntity3D.Curve property

ProfileEntity3D.CurveType property

ProfileEntity3D.EndSketchPoint property

ProfileEntity3D.GetReferenceKey method

ProfileEntity3D.OpposedToSketchEntity property

ProfileEntity3D.Parent property

ProfileEntity3D.SketchEntity property

ProfileEntity3D.StartSketchPoint property

ProfileEntity3D.Type property

ProfileEntity3DProxy interface

ContainingOccurrence

NativeObject

ProfileEntity3DProxy.ContainingOccurrence property

ProfileEntity3DProxy.NativeObject property

ProfileEntityProxy interface

ContainingOccurrence

NativeObject

ProfileEntityProxy.ContainingOccurrence property

ProfileEntityProxy.NativeObject property

ProfileOne

LoftedFlangeDefinition interface

ProfileOrientation

PathAndSectionTwistsSweepDef interface

PathSweepDef interface

ProfilePath interface

AddsMaterial

Application

AttributeSets

Closed

Count

Delete

GetReferenceKey

Item

Parent

TextBox

TextBoxPath

Type

ProfilePath.AddsMaterial property

ProfilePath.Application property

ProfilePath.AttributeSets property

ProfilePath.Closed property

ProfilePath.Count property

ProfilePath.Delete method

ProfilePath.GetReferenceKey method

ProfilePath.Item method

ProfilePath.Parent property

ProfilePath.TextBox property

ProfilePath.TextBoxPath property

ProfilePath.Type property

ProfilePath3D interface

Application

AttributeSets

Closed

Count

GetReferenceKey

Item

Parent

Type

ProfilePath3D.Application property

ProfilePath3D.AttributeSets property

ProfilePath3D.Closed property

ProfilePath3D.Count property

ProfilePath3D.GetReferenceKey method

ProfilePath3D.Item method

ProfilePath3D.Parent property

ProfilePath3D.Type property

ProfilePath3DProxy interface

ContainingOccurrence

NativeObject

ProfilePath3DProxy.ContainingOccurrence property

ProfilePath3DProxy.NativeObject property

ProfilePathProxy interface

ContainingOccurrence

NativeObject

ProfilePathProxy.ContainingOccurrence property

ProfilePathProxy.NativeObject property

ProfileProxy interface

ContainingOccurrence

NativeObject

ProfileProxy.ContainingOccurrence property

ProfileProxy.NativeObject property

Profiles

DrawingSketch interface

PlanarSketch interface

Profiles interface

AddForSolid

AddForSurface

Application

Count

Item

Type

Profiles.AddForSolid method

Profiles.AddForSurface method

Profiles.Application property

Profiles.Count property

Profiles.Item method

Profiles.Type property

Profiles3D

Sketch3D interface

Profiles3D interface

AddClosed

AddOpen

Application

Count

Item

Type

Profiles3D.AddClosed method

Profiles3D.AddOpen method

Profiles3D.Application property

Profiles3D.Count property

Profiles3D.Item method

Profiles3D.Type property

ProfileScaling

PathAndGuideRailSweepDef interface

ProfileTwo

LoftedFlangeDefinition interface

ProgId

ApplicationAddIn interface

ProgressBar coclass

ProgressBarObject interface

Application

Close

Message

Type

UpdateProgress

ProgressBarObject.Application property

ProgressBarObject.Close method

ProgressBarObject.Message property

ProgressBarObject.Type property

ProgressBarObject.UpdateProgress method

ProgressBarSink interface

OnCancel

ProgressBarSink.OnCancel method

ProgressiveToolTip

ControlDefinition interface

ProgressiveToolTip interface

Application

Description

ExpandedDescription

Image

IsProgressive

Parent

Title

Type

Video

ProgressiveToolTip.Application property

ProgressiveToolTip.Description property

ProgressiveToolTip.ExpandedDescription property

ProgressiveToolTip.Image property

ProgressiveToolTip.IsProgressive property

ProgressiveToolTip.Parent property

ProgressiveToolTip.Title property

ProgressiveToolTip.Type property

ProgressiveToolTip.Video property

ProjectedCurveType

DrawingCurve interface

ProjectedCut interface

Application

AttributeSets

BreakLink

Delete

GetReferenceKey

Name

Parent

SketchEntities

Type

ProjectedCut.Application property

ProjectedCut.AttributeSets property

ProjectedCut.BreakLink method

ProjectedCut.Delete method

ProjectedCut.GetReferenceKey method

ProjectedCut.Name property

ProjectedCut.Parent property

ProjectedCut.SketchEntities property

ProjectedCut.Type property

ProjectedCutProxy interface

ContainingOccurrence

NativeObject

ProjectedCutProxy.ContainingOccurrence property

ProjectedCutProxy.NativeObject property

ProjectedCuts

PlanarSketch interface

ProjectedCuts interface

Add

Application

Count

Item

Type

ProjectedCuts.Add method

ProjectedCuts.Application property

ProjectedCuts.Count property

ProjectedCuts.Item method

ProjectedCuts.Type property

ProjectFiles

FileLocations interface

ProjectionNormalAxis

AutomatedCenterlineSettings interface

ProjectionParallelAxis

AutomatedCenterlineSettings interface

ProjectPath interface

Application

Delete

Name

Parent

Path

Type

ProjectPath.Application property

ProjectPath.Delete method

ProjectPath.Name property

ProjectPath.Parent property

ProjectPath.Path property

ProjectPath.Type property

ProjectPaths interface

_NewEnum

Add

AddFromFile

Application

Clear

Count

Item

Type

ProjectPaths._NewEnum property

ProjectPaths.Add method

ProjectPaths.AddFromFile method

ProjectPaths.Application property

ProjectPaths.Clear method

ProjectPaths.Count property

ProjectPaths.Item method

ProjectPaths.Type property

ProjectsPath

FileOptions interface

ProjectType

DesignProject interface

InventorVBAProject interface

Promoted

BOMRow interface

PromoteToSketch

GeneralDimension interface

Prompt

iFeatureInput interface

PromptMessage

CommandManager interface

PromptSaveForMigration

SaveOptions interface

PromptSaveForRecomputableChanges

SaveOptions interface

Properties

BalloonStyle interface

Property interface

Delete

Dirty

DisplayName

Expression

Name

Parent

PropId

Type

Value

Property.Delete method

Property.Dirty property

Property.DisplayName property

Property.Expression property

Property.Name property

Property.Parent property

Property.PropId property

Property.Type property

Property.Value property

PropertySet interface

Add

Count

Delete

Dirty

DisplayName

InternalName

Item

ItemByPropId

Name

Parent

Type

PropertySet.Add method

PropertySet.Count property

PropertySet.Delete method

PropertySet.Dirty property

PropertySet.DisplayName property

PropertySet.InternalName property

PropertySet.Item method

PropertySet.ItemByPropId method

PropertySet.Name property

PropertySet.Parent property

PropertySet.Type property

PropertySets

ApprenticeServerDocument interface

Document interface

VirtualComponentDefinition interface

PropertySets interface

Add

Count

Dirty

FlushToFile

Item

Parent

RefreshFromFile

Type

PropertySets.Add method

PropertySets.Count property

PropertySets.Dirty property

PropertySets.FlushToFile method

PropertySets.Item method

PropertySets.Parent property

PropertySets.RefreshFromFile method

PropertySets.Type property

PropertyType

CustomPropertyFormat interface

DrawingBOMColumn interface

HoleTableColumn interface

PartsListColumn interface

RevisionTableColumn interface

PropId

Property interface

ProximityPoint

LineAndTangentWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

ProximityPointOne

TangentDistanceDimConstraint interface

ProximityPointTwo

TangentDistanceDimConstraint interface

PullDirection

CoreCavityDefinition interface

DraftAnalysis interface

FaceDraftFeature interface

PullDirectionReversed

DraftAnalysis interface

PunchCenterPoints

PunchToolFeature interface

PunchEdge

PunchNote interface

PunchId

FlatPunchResult interface

iFeatureDefinition interface

PunchNote interface

FormattedPunchNote

FormattedQuantityNote

HideValue

PunchEdge

QuantityDefinition

UsePartUnits

PunchNote.FormattedPunchNote property

PunchNote.FormattedQuantityNote property

PunchNote.HideValue property

PunchNote.PunchEdge property

PunchNote.QuantityDefinition property

PunchNote.UsePartUnits property

PunchNoteLayer

ObjectDefaultsStyle interface

PunchNotes

DrawingNotes interface

PunchNotes interface

Add

Application

Count

Item

Type

PunchNotes.Add method

PunchNotes.Application property

PunchNotes.Count property

PunchNotes.Item method

PunchNotes.Type property

PunchNoteStyle

ObjectDefaultsStyle interface

PunchRepresentationType

FlatPattern interface

SheetMetalStyle interface

PunchToolFeature interface

Angle

Depth

iFeatureDefinition

iFeatureTemplateDescriptor

PunchCenterPoints

PunchToolFeature.Angle property

PunchToolFeature.Depth property

PunchToolFeature.iFeatureDefinition property

PunchToolFeature.iFeatureTemplateDescriptor property

PunchToolFeature.PunchCenterPoints property

PunchToolFeatureProxy interface

PunchToolFeatures

FlatPatternFeatures interface

SheetMetalFeatures interface

PunchToolFeatures interface

Add

Application

Count

CreateiFeatureDefinition

Item

Type

PunchToolFeatures.Add method

PunchToolFeatures.Application property

PunchToolFeatures.Count property

PunchToolFeatures.CreateiFeatureDefinition method

PunchToolFeatures.Item method

PunchToolFeatures.Type property

PurgeAttributeSets

AttributeManager interface

PutArcData

Arc2d interface

Arc3d interface

PutBoxData

Box interface

Box2d interface

PutBSplineInfoAndData

BSplineCurve interface

BSplineCurve2d interface

BSplineSurface interface

PutCircleData

Circle interface

Circle2d interface

PutColors

GraphicsColorMapper interface

GraphicsColorSet interface

PutConeData

Cone interface

PutCoordinates

GraphicsCoordinateSet interface

GraphicsTextureCoordinateSet interface

PutCustomLogicalFileName

FileDescriptor interface

PutCylinderData

Cylinder interface

PutData

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

FixedWorkAxisDef interface

FixedWorkPlaneDef interface

PutEllipseFullData

EllipseFull interface

EllipseFull2d interface

PutEllipticalArcData

EllipticalArc interface

EllipticalArc2d interface

PutEllipticalConeData

EllipticalCone interface

PutEllipticalCylinderData

EllipticalCylinder interface

PutGraphicsLevelsOfDetail

PartDocument interface

PutIndices

GraphicsIndexSet interface

PutInternalNameAndRevisionId

Document interface

PutLineData

Line interface

Line2d interface

PutLineSegmentData

LineSegment interface

LineSegment2d interface

PutMatrixData

Matrix interface

Matrix2d interface

PutNormals

GraphicsNormalSet interface

PutPlaneData

Plane interface

PutPointData

Point interface

Point2d interface

PutPoints

Polyline2d interface

Polyline3d interface

PutSphereData

Sphere interface

PutStripLengths

LineStripGraphics interface

TriangleFanGraphics interface

TriangleStripGraphics interface

PutTextColor

TextGraphics interface

PutTorusData

Torus interface

PutUnitVectorData

UnitVector interface

UnitVector2d interface

PutValues

GraphicsColorMapper interface

PutVectorData

Vector interface

Vector2d interface

PutXMLData

ClientApplication interface

Q

QuadraticAttenuation

Light interface

QuantityDefinition

HoleThreadNote interface

PunchNote interface

QuickAccessControls

Ribbon interface

QuickFileOpenCachedAssembly

FileOptions interface

QuickFileOpenCacheLastAssembly

FileOptions interface

QuickFileOpenEnabled

FileOptions interface

Quit

Application interface

R

RadialDimensionLayer

ObjectDefaultsStyle interface

RadialDimensionStyle

ObjectDefaultsStyle interface

RadialMarkingMenu interface

Application

CreateRadialSubMenu

EastControl

NorthControl

NortheastControl

NorthwestControl

SouthControl

SoutheastControl

SouthwestControl

Type

WestControl

RadialMarkingMenu.Application property

RadialMarkingMenu.CreateRadialSubMenu method

RadialMarkingMenu.EastControl property

RadialMarkingMenu.NorthControl property

RadialMarkingMenu.NortheastControl property

RadialMarkingMenu.NorthwestControl property

RadialMarkingMenu.SouthControl property

RadialMarkingMenu.SoutheastControl property

RadialMarkingMenu.SouthwestControl property

RadialMarkingMenu.Type property

RadialMarkingMenu.WestControl property

Radius

Arc2d interface

Arc3d interface

BendConstraint interface

Circle interface

Circle2d interface

Cone interface

CornerRoundEdgeSet interface

Cylinder interface

FilletConstantRadiusEdgeSet interface

FilletConstantRadiusFaceSet interface

FilletIntermediateRadius interface

RolledHemDefinition interface

SketchArc interface

SketchArc3D interface

SketchCircle interface

SketchCircle3D interface

Sphere interface

TeardropHemDefinition interface

RadiusDimConstraint interface

Entity

RadiusDimConstraint.Entity property

RadiusDimConstraint3D interface

Entity

RadiusDimConstraint3D.Entity property

RadiusDimConstraint3DProxy interface

ContainingOccurrence

NativeObject

RadiusDimConstraint3DProxy.ContainingOccurrence property

RadiusDimConstraint3DProxy.NativeObject property

RadiusDimConstraintProxy interface

ContainingOccurrence

NativeObject

RadiusDimConstraintProxy.ContainingOccurrence property

RadiusDimConstraintProxy.NativeObject property

RadiusGeneralDimension interface

Intent

Jogged

LeaderFromCenter

RadiusGeneralDimension.Intent property

RadiusGeneralDimension.Jogged property

RadiusGeneralDimension.LeaderFromCenter property

RadiusOfGyration

MassProperties interface

RegionProperties interface

RadiusThresholdPrecision

AutomatedCenterlineSettings interface

Rail

LoftRail interface

RangeBox

Border interface

ClientGraphics interface

ComponentDefinition interface

ComponentOccurrence interface

Curve2dEvaluator interface

CurveEvaluator interface

CustomTable interface

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

EdgeLoop interface

FaceShell interface

GraphicsNode interface

GraphicsPrimitive interface

HoleTable interface

HoleTag interface

PartFeature interface

PartsList interface

RevisionTable interface

SketchEntity interface

SketchEntity3D interface

SurfaceBody interface

SurfaceEvaluator interface

TextBox interface

TitleBlock interface

Ratio

RotateRotateConstraint interface

RotateRotateiMateDefinition interface

RotateTranslateConstraint interface

RotateTranslateiMateDefinition interface

TranslateTranslateConstraint interface

RayTracing

View interface

RayTracingQuality

DisplayOptions interface

DisplaySettings interface

View interface

ReadDataFromFile

DataIO interface

ReadDataFromStream

DataIO interface

ReadFromFile

TransientBRep interface

RealisticAppearanceInternalName

RenderStyle interface

RealisticAppearanceName

RenderStyle interface

RealisticAppearanceRotation

RenderStyle interface

RealisticAppearanceScale

RenderStyle interface

RealisticAppearanceThumbnail

RenderStyle interface

Rebuild

Document interface

Rebuild2

Document interface

RecentChanges

Document interface

RectangularOccurrencePattern interface

ColumnCount

ColumnEntity

ColumnEntityNaturalDirection

ColumnOffset

OccurrencePatternElement

RowCount

RowEntity

RowEntityNaturalDirection

RowOffset

RectangularOccurrencePattern.ColumnCount property

RectangularOccurrencePattern.ColumnEntity property

RectangularOccurrencePattern.ColumnEntityNaturalDirection property

RectangularOccurrencePattern.ColumnOffset property

RectangularOccurrencePattern.OccurrencePatternElement method

RectangularOccurrencePattern.RowCount property

RectangularOccurrencePattern.RowEntity property

RectangularOccurrencePattern.RowEntityNaturalDirection property

RectangularOccurrencePattern.RowOffset property

RectangularOccurrencePatternProxy interface

ContainingOccurrence

NativeObject

RectangularOccurrencePatternProxy.ContainingOccurrence property

RectangularOccurrencePatternProxy.NativeObject property

RectangularPatternFeature interface

AddParticipant

ComputeType

NaturalXDirection

NaturalYDirection

NewBodyOperation

OrientationMethod

ParentFeatures

PatternElements

PatternOfBody

SurfacesOpaque

SurfacesVisible

XCount

XDirectionEntity

XDirectionMidPlanePattern

XDirectionSpacingType

XDirectionStartPoint

XSpacing

YCount

YDirectionEntity

YDirectionMidPlanePattern

YDirectionSpacingType

YDirectionStartPoint

YSpacing

RectangularPatternFeature.AddParticipant method

RectangularPatternFeature.ComputeType property

RectangularPatternFeature.NaturalXDirection property

RectangularPatternFeature.NaturalYDirection property

RectangularPatternFeature.NewBodyOperation property

RectangularPatternFeature.OrientationMethod property

RectangularPatternFeature.ParentFeatures property

RectangularPatternFeature.PatternElements property

RectangularPatternFeature.PatternOfBody property

RectangularPatternFeature.SurfacesOpaque property

RectangularPatternFeature.SurfacesVisible property

RectangularPatternFeature.XCount property

RectangularPatternFeature.XDirectionEntity property

RectangularPatternFeature.XDirectionMidPlanePattern property

RectangularPatternFeature.XDirectionSpacingType property

RectangularPatternFeature.XDirectionStartPoint property

RectangularPatternFeature.XSpacing property

RectangularPatternFeature.YCount property

RectangularPatternFeature.YDirectionEntity property

RectangularPatternFeature.YDirectionMidPlanePattern property

RectangularPatternFeature.YDirectionSpacingType property

RectangularPatternFeature.YDirectionStartPoint property

RectangularPatternFeature.YSpacing property

RectangularPatternFeatureProxy interface

ContainingOccurrence

NativeObject

RectangularPatternFeatureProxy.ContainingOccurrence property

RectangularPatternFeatureProxy.NativeObject property

RectangularPatternFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

RectangularPatternFeatures interface

Add

Application

Count

Item

Type

RectangularPatternFeatures.Add method

RectangularPatternFeatures.Application property

RectangularPatternFeatures.Count property

RectangularPatternFeatures.Item method

RectangularPatternFeatures.Type property

Red

Color interface

Redefine

NonParametricBaseFeature interface

RedoTransaction

TransactionManager interface

ReducedMemoryMode

DerivedAssemblyDefinition interface

DerivedPartDefinition interface

Reference

SketchEntity interface

SketchEntity3D interface

ReferenceComponent

DerivedParameterTable interface

Face interface

iMateDefinition interface

PlanarSketch interface

ReferenceFeature interface

Sketch3D interface

SketchBlock interface

SketchEntity interface

SketchEntity3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

ReferenceComponent interface

Application

AttributeSets

BreakLinkToFile

Delete

GetReferenceKey

HealthStatus

IsEmbedded

LinkedToFile

Name

Parent

ReferencedDocumentDescriptor

ReferencedFile

SetEndOfPart

Type

ReferenceComponent.Application property

ReferenceComponent.AttributeSets property

ReferenceComponent.BreakLinkToFile method

ReferenceComponent.Delete method

ReferenceComponent.GetReferenceKey method

ReferenceComponent.HealthStatus property

ReferenceComponent.IsEmbedded property

ReferenceComponent.LinkedToFile property

ReferenceComponent.Name property

ReferenceComponent.Parent property

ReferenceComponent.ReferencedDocumentDescriptor property

ReferenceComponent.ReferencedFile method

ReferenceComponent.SetEndOfPart method

ReferenceComponent.Type property

ReferenceComponents

PartComponentDefinition interface

ReferenceComponents interface

Application

DerivedAliasComponents

DerivedAssemblyComponents

DerivedPartComponents

iFeatureTemplateDescriptors

Type

ReferenceComponents.Application property

ReferenceComponents.DerivedAliasComponents property

ReferenceComponents.DerivedAssemblyComponents property

ReferenceComponents.DerivedPartComponents property

ReferenceComponents.iFeatureTemplateDescriptors property

ReferenceComponents.Type property

ReferencedAutoCADBlockDefinitions

SheetFormat interface

ReferencedBorderDefinition

SheetFormat interface

ReferencedDataType

iAssemblyTableColumn interface

iPartTableColumn interface

ReferencedDocument

DocumentDescriptor interface

ReferencedDocumentDescriptor

ComponentOccurrence interface

CustomTable interface

DerivedParameterTable interface

DrawingBOM interface

DrawingView interface

iAssemblyMember interface

PartsList interface

ReferenceComponent interface

ReferencedDocumentDescriptors

ApprenticeServerDocument interface

Document interface

ReferencedDocuments

ApprenticeServerDocument interface

Document interface

ReferencedDocumentType

DocumentDescriptor interface

ReferencedEntity

DerivedParameter interface

DerivedPartEntity interface

Face interface

iMateDefinition interface

PlanarSketch interface

ReferenceFeature interface

Sketch3D interface

SketchBlock interface

SketchEntity interface

SketchEntity3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

ReferencedFile

DrawingView interface

FileDescriptor interface

ReferenceComponent interface

ReferencedFileDescriptor

BOMRow interface

DocumentDescriptor interface

ParameterTable interface

SketchImage interface

ReferencedFileDescriptors

File interface

ReferencedFiles

BalloonValueSet interface

File interface

PartsListRow interface

ReferencedFileType

FileDescriptor interface

ReferencedHole

HoleTableRow interface

ReferenceDisabled

DocumentDescriptor interface

FileDescriptor interface

ReferencedLevelOfDetail

DocumentDescriptor interface

ReferencedObject

iAssemblyTableColumn interface

iPartTableColumn interface

ReferencedOccurrence

DerivedAssemblyOccurrence interface

ReferencedOLEFileDescriptor interface

Activate

Application

AttributeSets

BrowserVisible

Delete

DisplayName

FileDescriptor

FullFileName

GetReferenceKey

LastKnownFileTime

LogicalName

OLEDocumentType

Parent

ReferenceMonitoring

ReferenceStatus

Type

Visible

ReferencedOLEFileDescriptor.Activate method

ReferencedOLEFileDescriptor.Application property

ReferencedOLEFileDescriptor.AttributeSets property

ReferencedOLEFileDescriptor.BrowserVisible property

ReferencedOLEFileDescriptor.Delete method

ReferencedOLEFileDescriptor.DisplayName property

ReferencedOLEFileDescriptor.FileDescriptor property

ReferencedOLEFileDescriptor.FullFileName property

ReferencedOLEFileDescriptor.GetReferenceKey method

ReferencedOLEFileDescriptor.LastKnownFileTime property

ReferencedOLEFileDescriptor.LogicalName property

ReferencedOLEFileDescriptor.OLEDocumentType property

ReferencedOLEFileDescriptor.Parent property

ReferencedOLEFileDescriptor.ReferenceMonitoring property

ReferencedOLEFileDescriptor.ReferenceStatus property

ReferencedOLEFileDescriptor.Type property

ReferencedOLEFileDescriptor.Visible property

ReferencedOLEFileDescriptors

ApprenticeServerDocument interface

Document interface

ReferencedOLEFileDescriptors interface

Add

Application

Count

Item

ItemByName

Type

ReferencedOLEFileDescriptors.Add method

ReferencedOLEFileDescriptors.Application property

ReferencedOLEFileDescriptors.Count property

ReferencedOLEFileDescriptors.Item method

ReferencedOLEFileDescriptors.ItemByName method

ReferencedOLEFileDescriptors.Type property

ReferencedRow

BalloonValueSet interface

ReferencedRows

PartsListRow interface

ReferencedSymbolDefinitions

SheetFormat interface

ReferencedTitleBlockDefinition

SheetFormat interface

ReferenceEntityOne

LinearHolePlacementDefinition interface

ReferenceEntityTwo

LinearHolePlacementDefinition interface

ReferenceFeature interface

ReferenceComponent

ReferencedEntity

ReferenceFeature.ReferenceComponent property

ReferenceFeature.ReferencedEntity property

ReferenceFeatureProxy interface

ContainingOccurrence

NativeObject

ReferenceFeatureProxy.ContainingOccurrence property

ReferenceFeatureProxy.NativeObject property

ReferenceFeatures

DerivedAssemblyComponent interface

PartFeatures interface

ReferenceFeatures interface

Application

Count

Item

Type

ReferenceFeatures.Application property

ReferenceFeatures.Count property

ReferenceFeatures.Item method

ReferenceFeatures.Type property

ReferenceFeaturesEnumerator interface

Count

Item

Type

ReferenceFeaturesEnumerator.Count property

ReferenceFeaturesEnumerator.Item method

ReferenceFeaturesEnumerator.Type property

ReferenceInternalNameDifferent

DocumentDescriptor interface

FileDescriptor interface

ReferenceKeyEvents

ApprenticeServer interface

ReferenceKeyEventsObject interface

Application

Type

ReferenceKeyEventsObject.Application property

ReferenceKeyEventsObject.Type property

ReferenceKeyEventsSink interface

OnBindKeyToObject

ReferenceKeyEventsSink.OnBindKeyToObject method

ReferenceKeyManager

ApprenticeServerDocument interface

Document interface

ReferenceKeyManager interface

Application

BindKeyToObject

CanBindKeyToObject

CreateKeyContext

KeyToString

LoadContextFromArray

Parent

SaveContextToArray

StringToKey

Type

ReferenceKeyManager.Application property

ReferenceKeyManager.BindKeyToObject method

ReferenceKeyManager.CanBindKeyToObject method

ReferenceKeyManager.CreateKeyContext method

ReferenceKeyManager.KeyToString method

ReferenceKeyManager.LoadContextFromArray method

ReferenceKeyManager.Parent property

ReferenceKeyManager.SaveContextToArray method

ReferenceKeyManager.StringToKey method

ReferenceKeyManager.Type property

ReferenceLocationDifferent

DocumentDescriptor interface

FileDescriptor interface

ReferenceMissing

DocumentDescriptor interface

FileDescriptor interface

ReferenceMonitoring

ReferencedOLEFileDescriptor interface

ReferenceParameter interface

BuiltIn

ConvertToModelParameter

ConvertToUserParameter

Renamed

ReferenceParameter.BuiltIn property

ReferenceParameter.ConvertToModelParameter method

ReferenceParameter.ConvertToUserParameter method

ReferenceParameter.Renamed property

ReferenceParameters

Parameters interface

ReferenceParameters interface

_AddByValue

AddByExpression

AddByValue

Count

Item

Type

ReferenceParameters._AddByValue method

ReferenceParameters.AddByExpression method

ReferenceParameters.AddByValue method

ReferenceParameters.Count property

ReferenceParameters.Item method

ReferenceParameters.Type property

ReferenceStatus

ReferencedOLEFileDescriptor interface

ReferenceSuppressed

DocumentDescriptor interface

ReferenceVector

Arc3d interface

ReferenceVectorEntity

AngleConstraint interface

ReferencingDocuments

ApprenticeServerDocument interface

Document interface

ReferencingFiles

File interface

ReflectionBlur

GroundPlaneSettings interface

ReflectionBlurFalloff

GroundPlaneSettings interface

Reflectivity

GroundPlaneSettings interface

RenderStyle interface

RefoldFeature interface

Bends

Edit

InputSketches

ResultSketches

StationaryFace

RefoldFeature.Bends property

RefoldFeature.Edit method

RefoldFeature.InputSketches property

RefoldFeature.ResultSketches property

RefoldFeature.StationaryFace property

RefoldFeatureProxy interface

RefoldFeatures

SheetMetalFeatures interface

RefoldFeatures interface

Add

Application

Count

Item

Type

RefoldFeatures.Add method

RefoldFeatures.Application property

RefoldFeatures.Count property

RefoldFeatures.Item method

RefoldFeatures.Type property

ReformatOnCustomHoleMatch

HoleTable interface

HoleTableStyle interface

Refresh

BrowserPaneObject interface

RefreshAllDocuments

FileManager interface

RefreshFromFile

PropertySets interface

RefreshOutOfDateStandardParts

ContentCenterOptions interface

RegionProperties

Profile interface

RegionProperties interface

Accuracy

Application

Area

Centroid

CentroidMomentsOfInertia

GetTorsionProperties

MomentsOfInertia

Parent

Perimeter

PrincipalAxes

PrincipalMomentsOfInertia

RadiusOfGyration

RotationAngle

Type

RegionProperties.Accuracy property

RegionProperties.Application property

RegionProperties.Area property

RegionProperties.Centroid property

RegionProperties.CentroidMomentsOfInertia method

RegionProperties.GetTorsionProperties method

RegionProperties.MomentsOfInertia method

RegionProperties.Parent property

RegionProperties.Perimeter property

RegionProperties.PrincipalAxes method

RegionProperties.PrincipalMomentsOfInertia method

RegionProperties.RadiusOfGyration method

RegionProperties.RotationAngle property

RegionProperties.Type property

RelativeFileName

FileDescriptor interface

RelativeX

OriginIndicator interface

RelativeY

OriginIndicator interface

ReleaseId

DesignProject interface

ReleaseReference

Document interface

Remove

BrowserFolder interface

CommandBarList interface

CommandCategory interface

CustomParameterGroup interface

DesignProject interface

DisabledCommandList interface

EnvironmentList interface

GraphicsDataSet interface

HighlightSet interface

IAnimationFavorites interface

NameValueMap interface

ObjectCollection interface

ObjectCollectionByVariant interface

PartsListColumn interface

PartsListRow interface

SelectSet interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFaceList interface

ViewList interface

RemoveAllColumns

HoleTableStyle interface

PartsListStyle interface

RevisionTableStyle interface

TableStyle interface

RemoveByObject

ObjectCollection interface

RemoveColorOverrides

DesignViewRepresentation interface

RemoveConstraintSuppressionOverride

PositionalRepresentation interface

RemoveConstraintValueOverride

PositionalRepresentation interface

RemoveDependency

ClientFeatureDefinition interface

RemoveEdgeSet

CornerRoundDefinition interface

RemoveFlexibleOverride

PositionalRepresentation interface

RemoveFromSelectedEntities

SelectEventsObject interface

RemoveGroundingOverride

PositionalRepresentation interface

RemoveItem

ComboBoxDefinitionObject interface

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

RemoveItems

CompositeiMateDefinition interface

RemoveLibrary

FileLocations interface

RemoveLineWeights

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

RemoveOverrideWidthExtent

FlangeDefinition interface

RemoveParticipant

PartFeature interface

RemovePatternAngleOffsetOverride

PositionalRepresentation interface

RemovePatternColumnOffsetOverride

PositionalRepresentation interface

RemovePatternRowOffsetOverride

PositionalRepresentation interface

RemovePositionalRepresentationOverride

PositionalRepresentation interface

RemovePositiveSide

SplitFeature interface

RemoveTransformOverride

PositionalRepresentation interface

RemoveViewSpaceAnchor

GraphicsPrimitive interface

RemoveWorkgroup

FileLocations interface

Renamed

ModelParameter interface

ReferenceParameter interface

RenderManager

IInventorStudio interface

RenderManager coclass

RenderStyle

GraphicsNode interface

Material interface

SurfaceGraphicsFace interface

RenderStyle interface

Application

ApproximateFromRealisticAppearance

AttributeSets

BumpMapAmount

BumpMapImageFilename

BumpMapInvert

BumpMapRotation

BumpMapScale

ConvertToLocal

Copy

Delete

DisplayInteriorFaces

GetAmbientColor

GetDiffuseColor

GetEmissiveColor

GetReferenceKey

GetSpecularColor

InternalName

InUse

Name

Opacity

Parent

RealisticAppearanceInternalName

RealisticAppearanceName

RealisticAppearanceRotation

RealisticAppearanceScale

RealisticAppearanceThumbnail

Reflectivity

SaveToGlobal

SetAmbientColor

SetDiffuseColor

SetEmissiveColor

SetSpecularColor

StyleLocation

TextureFilename

TextureRotation

TextureScale

Type

UpdateFromGlobal

UpToDate

RenderStyle.Application property

RenderStyle.ApproximateFromRealisticAppearance method

RenderStyle.AttributeSets property

RenderStyle.BumpMapAmount property

RenderStyle.BumpMapImageFilename property

RenderStyle.BumpMapInvert property

RenderStyle.BumpMapRotation property

RenderStyle.BumpMapScale property

RenderStyle.ConvertToLocal method

RenderStyle.Copy method

RenderStyle.Delete method

RenderStyle.DisplayInteriorFaces property

RenderStyle.GetAmbientColor method

RenderStyle.GetDiffuseColor method

RenderStyle.GetEmissiveColor method

RenderStyle.GetReferenceKey method

RenderStyle.GetSpecularColor method

RenderStyle.InternalName property

RenderStyle.InUse property

RenderStyle.Name property

RenderStyle.Opacity property

RenderStyle.Parent property

RenderStyle.RealisticAppearanceInternalName property

RenderStyle.RealisticAppearanceName property

RenderStyle.RealisticAppearanceRotation property

RenderStyle.RealisticAppearanceScale property

RenderStyle.RealisticAppearanceThumbnail property

RenderStyle.Reflectivity property

RenderStyle.SaveToGlobal method

RenderStyle.SetAmbientColor method

RenderStyle.SetDiffuseColor method

RenderStyle.SetEmissiveColor method

RenderStyle.SetSpecularColor method

RenderStyle.StyleLocation property

RenderStyle.TextureFilename property

RenderStyle.TextureRotation property

RenderStyle.TextureScale property

RenderStyle.Type property

RenderStyle.UpdateFromGlobal method

RenderStyle.UpToDate property

RenderStyles

Document interface

RenderStyles interface

Add

Application

Count

Item

Parent

Type

RenderStyles.Add method

RenderStyles.Application property

RenderStyles.Count property

RenderStyles.Item method

RenderStyles.Parent property

RenderStyles.Type property

RenderToFile

IRenderManager interface

Renumber

BOMView interface

CustomTable interface

PartsList interface

Reorder

BrowserPaneObject interface

Repeat

TriadEventsObject interface

RepetitionCount

DriveConstraintSettingsObject interface

RepetitionStartEndStart

DriveConstraintSettingsObject interface

Replace

ComponentOccurrence interface

ReplaceFaceFeature interface

ReplaceFaceFeatureProxy interface

ContainingOccurrence

NativeObject

ReplaceFaceFeatureProxy.ContainingOccurrence property

ReplaceFaceFeatureProxy.NativeObject property

ReplaceFaceFeatures

PartFeatures interface

ReplaceFaceFeatures interface

Application

Count

Item

Type

ReplaceFaceFeatures.Application property

ReplaceFaceFeatures.Count property

ReplaceFaceFeatures.Item method

ReplaceFaceFeatures.Type property

ReplaceReference

FileDescriptor interface

Reposition

Column interface

HoleTableColumn interface

PartsListColumn interface

PartsListRow interface

RevisionTableColumn interface

RevisionTableRow interface

RibbonPanel interface

Row interface

TriadEventsObject interface

RepresentationEvents coclass

RepresentationEventsObject interface

Application

Parent

Type

RepresentationEventsObject.Application property

RepresentationEventsObject.Parent property

RepresentationEventsObject.Type property

RepresentationEventsSink interface

OnActivateDesignView

OnActivateLevelOfDetailRepresentation

OnActivatePositionalRepresentation

OnDelete

OnNewDesignView

OnNewLevelOfDetailRepresentation

OnNewPositionalRepresentation

RepresentationEventsSink.OnActivateDesignView method

RepresentationEventsSink.OnActivateLevelOfDetailRepresentation method

RepresentationEventsSink.OnActivatePositionalRepresentation method

RepresentationEventsSink.OnDelete method

RepresentationEventsSink.OnNewDesignView method

RepresentationEventsSink.OnNewLevelOfDetailRepresentation method

RepresentationEventsSink.OnNewPositionalRepresentation method

RepresentationsManager

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

RepresentationsManager interface

_Parent

ActiveDesignViewRepresentation

ActiveLevelOfDetailRepresentation

ActivePositionalRepresentation

Application

DesignViewRepresentations

LevelOfDetailRepresentations

Parent

PositionalRepresentations

Type

RepresentationsManager._Parent method

RepresentationsManager.ActiveDesignViewRepresentation property

RepresentationsManager.ActiveLevelOfDetailRepresentation property

RepresentationsManager.ActivePositionalRepresentation property

RepresentationsManager.Application property

RepresentationsManager.DesignViewRepresentations property

RepresentationsManager.LevelOfDetailRepresentations property

RepresentationsManager.Parent property

RepresentationsManager.PositionalRepresentations property

RepresentationsManager.Type property

RequiresUpdate

ApprenticeServerDocument interface

BOM interface

Document interface

ReservedForWrite

ApprenticeServerDocument interface

Document interface

ReservedForWriteByMe

ApprenticeServerDocument interface

Document interface

ReservedForWriteLogin

ApprenticeServerDocument interface

Document interface

ReservedForWriteName

ApprenticeServerDocument interface

Document interface

ReservedForWriteTime

ApprenticeServerDocument interface

Document interface

ReservedForWriteVersion

ApprenticeServerDocument interface

Document interface

Reset

EnumType interface

ResetFront

View interface

ResetRibbonInterface

UserInterfaceManager interface

ResetSelections

SelectEventsObject interface

ResolveFile

DesignProjectManager interface

RestFeature interface

RestFeatureProxy interface

ContainingOccurrence

NativeObject

RestFeatureProxy.ContainingOccurrence property

RestFeatureProxy.NativeObject property

RestFeatures

PartFeatures interface

RestFeatures interface

Application

Count

Item

Type

RestFeatures.Application property

RestFeatures.Count property

RestFeatures.Item method

RestFeatures.Type property

RestingPositionEnabled

ConstraintLimits interface

RestrictSelectionToOccurrence

SelectEventsObject interface

ResultFeatures

DerivedAliasComponent interface

FeaturePatternElement interface

MirrorFeature interface

ResultOfiMate

AssemblyConstraint interface

ResultOfLayoutConstraint

AssemblyConstraint interface

Results

iMateResult interface

ResultSketches

RefoldFeature interface

UnfoldFeature interface

Retrieve

GeneralDimensions interface

Retrieved

GeneralDimension interface

RetrievedFrom

GeneralDimension interface

ReverseDirection

BIMConnectorDefinition interface

SectionDrawingView interface

ReverseZoomDirection

DisplayOptions interface

RevertReservedForWriteByMe

ApprenticeServerDocument interface

Document interface

RevisionId

ApprenticeServerDocument interface

AttributeManager interface

BOM interface

BOMView interface

ContentFamily interface

Document interface

RevisionTable interface

Application

AttributeSets

ColumnHeaderTextStyle

DataTextStyle

Delete

Export

GetReferenceKey

HeadingGap

HeadingPlacement

IsSheetScope

Layer

MaximumRows

NumberOfSections

Parent

Position

RangeBox

RevisionTableColumns

RevisionTableRows

Rotation

RowGap

RowLineSpacing

ShowTitle

Sort

Style

TableDirection

Title

TitleTextStyle

Type

UpdatePropertyToRevisionNumber

WrapAutomatically

WrapLeft

RevisionTable.Application property

RevisionTable.AttributeSets property

RevisionTable.ColumnHeaderTextStyle property

RevisionTable.DataTextStyle property

RevisionTable.Delete method

RevisionTable.Export method

RevisionTable.GetReferenceKey method

RevisionTable.HeadingGap property

RevisionTable.HeadingPlacement property

RevisionTable.IsSheetScope property

RevisionTable.Layer property

RevisionTable.MaximumRows property

RevisionTable.NumberOfSections property

RevisionTable.Parent property

RevisionTable.Position property

RevisionTable.RangeBox property

RevisionTable.RevisionTableColumns property

RevisionTable.RevisionTableRows property

RevisionTable.Rotation property

RevisionTable.RowGap property

RevisionTable.RowLineSpacing property

RevisionTable.ShowTitle property

RevisionTable.Sort method

RevisionTable.Style property

RevisionTable.TableDirection property

RevisionTable.Title property

RevisionTable.TitleTextStyle property

RevisionTable.Type property

RevisionTable.UpdatePropertyToRevisionNumber property

RevisionTable.WrapAutomatically property

RevisionTable.WrapLeft property

RevisionTableCell interface

Application

FormattedText

Parent

StackedTextPosition

Text

Type

RevisionTableCell.Application property

RevisionTableCell.FormattedText property

RevisionTableCell.Parent property

RevisionTableCell.StackedTextPosition property

RevisionTableCell.Text property

RevisionTableCell.Type property

RevisionTableColumn interface

Application

CustomPropertyName

Delete

GetFilePropertyId

Parent

PropertyType

Reposition

Title

TitleHorizontalJustification

Type

ValueHorizontalJustification

Width

RevisionTableColumn.Application property

RevisionTableColumn.CustomPropertyName property

RevisionTableColumn.Delete method

RevisionTableColumn.GetFilePropertyId method

RevisionTableColumn.Parent property

RevisionTableColumn.PropertyType property

RevisionTableColumn.Reposition method

RevisionTableColumn.Title property

RevisionTableColumn.TitleHorizontalJustification property

RevisionTableColumn.Type property

RevisionTableColumn.ValueHorizontalJustification property

RevisionTableColumn.Width property

RevisionTableColumns

RevisionTable interface

RevisionTableColumns interface

Add

Application

Count

Item

Type

RevisionTableColumns.Add method

RevisionTableColumns.Application property

RevisionTableColumns.Count property

RevisionTableColumns.Item method

RevisionTableColumns.Type property

RevisionTableLayer

ObjectDefaultsStyle interface

RevisionTableRow interface

Application

Count

Custom

Delete

Height

IsActiveRow

Item

Parent

Reposition

Type

Visible

RevisionTableRow.Application property

RevisionTableRow.Count property

RevisionTableRow.Custom property

RevisionTableRow.Delete method

RevisionTableRow.Height property

RevisionTableRow.IsActiveRow property

RevisionTableRow.Item method

RevisionTableRow.Parent property

RevisionTableRow.Reposition method

RevisionTableRow.Type property

RevisionTableRow.Visible property

RevisionTableRows

RevisionTable interface

RevisionTableRows interface

Add

AddCustom

Application

Count

Item

Type

RevisionTableRows.Add method

RevisionTableRows.AddCustom method

RevisionTableRows.Application property

RevisionTableRows.Count property

RevisionTableRows.Item method

RevisionTableRows.Type property

RevisionTables

Sheet interface

RevisionTables interface

Add

Add2

Application

Count

Item

Type

RevisionTables.Add method

RevisionTables.Add2 method

RevisionTables.Application property

RevisionTables.Count property

RevisionTables.Item method

RevisionTables.Type property

RevisionTableStyle

ObjectDefaultsStyle interface

RevisionTableStyle interface

AddColumn

AllowLandingLineForRevisionTags

ColumnHeaderTextStyle

DataTextStyle

HeadingGap

HeadingPlacement

InsideLineColor

InsideLineWeight

OutsideLineColor

OutsideLineWeight

RemoveAllColumns

RevisionTagLeaderStyle

RevisionTagShape

RevisionTagTextStyle

RowGap

RowLineSpacing

ShowTitle

TableDirection

Title

TitleTextStyle

RevisionTableStyle.AddColumn method

RevisionTableStyle.AllowLandingLineForRevisionTags property

RevisionTableStyle.ColumnHeaderTextStyle property

RevisionTableStyle.DataTextStyle property

RevisionTableStyle.HeadingGap property

RevisionTableStyle.HeadingPlacement property

RevisionTableStyle.InsideLineColor property

RevisionTableStyle.InsideLineWeight property

RevisionTableStyle.OutsideLineColor property

RevisionTableStyle.OutsideLineWeight property

RevisionTableStyle.RemoveAllColumns method

RevisionTableStyle.RevisionTagLeaderStyle property

RevisionTableStyle.RevisionTagShape property

RevisionTableStyle.RevisionTagTextStyle property

RevisionTableStyle.RowGap property

RevisionTableStyle.RowLineSpacing property

RevisionTableStyle.ShowTitle property

RevisionTableStyle.TableDirection property

RevisionTableStyle.Title property

RevisionTableStyle.TitleTextStyle property

RevisionTableStyles

DrawingStylesManager interface

RevisionTableStylesEnumerator interface

_NewEnum

Application

Count

Item

Type

RevisionTableStylesEnumerator._NewEnum property

RevisionTableStylesEnumerator.Application property

RevisionTableStylesEnumerator.Count property

RevisionTableStylesEnumerator.Item method

RevisionTableStylesEnumerator.Type property

RevisionTagLayer

ObjectDefaultsStyle interface

RevisionTagLeaderStyle

RevisionTableStyle interface

RevisionTagShape

RevisionTableStyle interface

RevisionTagStyle

ObjectDefaultsStyle interface

RevisionTagTextStyle

RevisionTableStyle interface

Revolution

PitchAndRevolutionCoilExtent interface

RevolutionAndHeightCoilExtent interface

SpiralCoilExtent interface

RevolutionAndHeightCoilExtent interface

Height

Revolution

TaperAngle

RevolutionAndHeightCoilExtent.Height property

RevolutionAndHeightCoilExtent.Revolution property

RevolutionAndHeightCoilExtent.TaperAngle property

RevolvedFaceWorkAxisDef interface

Application

Face

Parent

Type

RevolvedFaceWorkAxisDef.Application property

RevolvedFaceWorkAxisDef.Face property

RevolvedFaceWorkAxisDef.Parent property

RevolvedFaceWorkAxisDef.Type property

RevolveFeature interface

AddParticipant

AxisEntity

EndFaces

Extent

ExtentTwo

ExtentTwoType

ExtentType

IsTwoDirectional

Operation

Profile

SetAngleExtent

SetFromToExtent

SetFullExtent

SetToFaceExtent

SetToNextExtent

SideFaces

StartFaces

RevolveFeature.AddParticipant method

RevolveFeature.AxisEntity property

RevolveFeature.EndFaces property

RevolveFeature.Extent property

RevolveFeature.ExtentTwo property

RevolveFeature.ExtentTwoType property

RevolveFeature.ExtentType property

RevolveFeature.IsTwoDirectional property

RevolveFeature.Operation property

RevolveFeature.Profile property

RevolveFeature.SetAngleExtent method

RevolveFeature.SetFromToExtent method

RevolveFeature.SetFullExtent method

RevolveFeature.SetToFaceExtent method

RevolveFeature.SetToNextExtent method

RevolveFeature.SideFaces property

RevolveFeature.StartFaces property

RevolveFeatureProxy interface

ContainingOccurrence

NativeObject

RevolveFeatureProxy.ContainingOccurrence property

RevolveFeatureProxy.NativeObject property

RevolveFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

RevolveFeatures interface

AddByAngle

AddByFromToExtent

AddByToFaceExtent

AddByToNextExtent

AddFull

Application

Count

Item

Type

RevolveFeatures.AddByAngle method

RevolveFeatures.AddByFromToExtent method

RevolveFeatures.AddByToFaceExtent method

RevolveFeatures.AddByToNextExtent method

RevolveFeatures.AddFull method

RevolveFeatures.Application property

RevolveFeatures.Count property

RevolveFeatures.Item method

RevolveFeatures.Type property

Ribbon

Environment interface

Ribbon interface

Active

Application

InternalName

Parent

QuickAccessControls

RibbonTabs

Type

Ribbon.Active property

Ribbon.Application property

Ribbon.InternalName property

Ribbon.Parent property

Ribbon.QuickAccessControls property

Ribbon.RibbonTabs property

Ribbon.Type property

RibbonAppearance

UserInterfaceManager interface

RibbonDockingState

UserInterfaceManager interface

RibbonPanel interface

Application

ClientId

CommandControls

Delete

DisplayName

Docked

InternalName

Move

Parent

Reposition

SlideoutControls

SlideOutKeyTip

Type

Visible

RibbonPanel.Application property

RibbonPanel.ClientId property

RibbonPanel.CommandControls property

RibbonPanel.Delete method

RibbonPanel.DisplayName property

RibbonPanel.Docked property

RibbonPanel.InternalName property

RibbonPanel.Move method

RibbonPanel.Parent property

RibbonPanel.Reposition method

RibbonPanel.SlideoutControls property

RibbonPanel.SlideOutKeyTip property

RibbonPanel.Type property

RibbonPanel.Visible property

RibbonPanels

RibbonTab interface

RibbonPanels interface

Add

Application

Count

Item

Type

RibbonPanels.Add method

RibbonPanels.Application property

RibbonPanels.Count property

RibbonPanels.Item method

RibbonPanels.Type property

Ribbons

UserInterfaceManager interface

Ribbons interface

Application

Count

Item

Type

Ribbons.Application property

Ribbons.Count property

Ribbons.Item method

Ribbons.Type property

RibbonState

UserInterfaceManager interface

RibbonTab interface

Active

Application

ClientId

Contextual

Delete

DisplayName

InternalName

KeyTip

Parent

RibbonPanels

Type

Visible

RibbonTab.Active property

RibbonTab.Application property

RibbonTab.ClientId property

RibbonTab.Contextual property

RibbonTab.Delete method

RibbonTab.DisplayName property

RibbonTab.InternalName property

RibbonTab.KeyTip property

RibbonTab.Parent property

RibbonTab.RibbonPanels property

RibbonTab.Type property

RibbonTab.Visible property

RibbonTabs

Ribbon interface

RibbonTabs interface

Add

Application

Count

Item

Type

RibbonTabs.Add method

RibbonTabs.Application property

RibbonTabs.Count property

RibbonTabs.Item method

RibbonTabs.Type property

RibDefinition interface

AffectedBody

Application

BossSets

Copy

DirectionReversed

DraftAngle

DraftProfileEnds

ExtendProfile

ExtentDistance

ExtentType

GetThicknessPlane

IsRib

Parent

ProfileCurves

SetFiniteExtent

SetThicknessPlane

SetToNextExtent

Thickness

ThicknessDirection

Type

RibDefinition.AffectedBody property

RibDefinition.Application property

RibDefinition.BossSets property

RibDefinition.Copy method

RibDefinition.DirectionReversed property

RibDefinition.DraftAngle property

RibDefinition.DraftProfileEnds property

RibDefinition.ExtendProfile property

RibDefinition.ExtentDistance property

RibDefinition.ExtentType property

RibDefinition.GetThicknessPlane method

RibDefinition.IsRib property

RibDefinition.Parent property

RibDefinition.ProfileCurves property

RibDefinition.SetFiniteExtent method

RibDefinition.SetThicknessPlane method

RibDefinition.SetToNextExtent method

RibDefinition.Thickness property

RibDefinition.ThicknessDirection property

RibDefinition.Type property

RibFeature interface

Definition

RibFeature.Definition property

RibFeatureProxy interface

ContainingOccurrence

NativeObject

RibFeatureProxy.ContainingOccurrence property

RibFeatureProxy.NativeObject property

RibFeatures

PartFeatures interface

RibFeatures interface

Add

Application

Count

CreateDefinition

Item

Type

RibFeatures.Add method

RibFeatures.Application property

RibFeatures.Count property

RibFeatures.CreateDefinition method

RibFeatures.Item method

RibFeatures.Type property

RightHanded

ThreadInfo interface

RightMargin

DefaultBorder interface

RipDefinition interface

Application

Copy

Parent

RipFace

RipType

RipTypeDefinition

SetFaceExtentsRipType

SetPointToPointRipType

SetSinglePointRipType

Type

RipDefinition.Application property

RipDefinition.Copy method

RipDefinition.Parent property

RipDefinition.RipFace property

RipDefinition.RipType property

RipDefinition.RipTypeDefinition property

RipDefinition.SetFaceExtentsRipType method

RipDefinition.SetPointToPointRipType method

RipDefinition.SetSinglePointRipType method

RipDefinition.Type property

RipFace

RipDefinition interface

RipFeature interface

Definition

RipFeature.Definition property

RipFeatureProxy interface

RipFeatures

SheetMetalFeatures interface

RipFeatures interface

Add

Application

Count

CreateRipDefinition

Item

Type

RipFeatures.Add method

RipFeatures.Application property

RipFeatures.Count property

RipFeatures.CreateRipDefinition method

RipFeatures.Item method

RipFeatures.Type property

RipType

RipDefinition interface

RipTypeDefinition

RipDefinition interface

RollAlongSharpEdges

FilletFeature interface

RolledBackForEdit

FlatPattern interface

PartComponentDefinition interface

RolledHemDefinition interface

Angle

Parent

Radius

RolledHemDefinition.Angle property

RolledHemDefinition.Parent property

RolledHemDefinition.Radius property

RolledUp

BOMRow interface

RollingBallWherePossible

FilletFeature interface

RootNode

Leader interface

RootPath

iFeatureOptions interface

RootPoint

Line interface

Line2d interface

Plane interface

Rotate90Degrees

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

RotateByAngle

DrawingView interface

RotateLeft

SketchImage interface

RotateRight

SketchImage interface

RotateRotateConstraint interface

ForwardDirection

Ratio

RotateRotateConstraint.ForwardDirection property

RotateRotateConstraint.Ratio property

RotateRotateConstraintProxy interface

ContainingOccurrence

NativeObject

RotateRotateConstraintProxy.ContainingOccurrence property

RotateRotateConstraintProxy.NativeObject property

RotateRotateiMateDefinition interface

Entity

ForwardDirection

Ratio

RotateRotateiMateDefinition.Entity property

RotateRotateiMateDefinition.ForwardDirection property

RotateRotateiMateDefinition.Ratio property

RotateRotateiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

RotateRotateiMateDefinitionProxy.ContainingOccurrence property

RotateRotateiMateDefinitionProxy.IsConsumed property

RotateRotateiMateDefinitionProxy.NativeObject property

RotateSketchObjects

Sketch interface

RotateTranslateConstraint interface

ForwardDirection

Ratio

RotateTranslateConstraint.ForwardDirection property

RotateTranslateConstraint.Ratio property

RotateTranslateConstraintProxy interface

ContainingOccurrence

NativeObject

RotateTranslateConstraintProxy.ContainingOccurrence property

RotateTranslateConstraintProxy.NativeObject property

RotateTranslateiMateDefinition interface

Entity

ForwardDirection

Ratio

RotateTranslateiMateDefinition.Entity property

RotateTranslateiMateDefinition.ForwardDirection property

RotateTranslateiMateDefinition.Ratio property

RotateTranslateiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

RotateTranslateiMateDefinitionProxy.ContainingOccurrence property

RotateTranslateiMateDefinitionProxy.IsConsumed property

RotateTranslateiMateDefinitionProxy.NativeObject property

Rotation

AutoCADBlock interface

CustomTable interface

DrawingView interface

FeatureControlFrame interface

GeneralNote interface

PartsList interface

RevisionTable interface

SketchedSymbol interface

TextBox interface

TextStyle interface

RotationAngle

RegionProperties interface

RotationToPrincipal

MassProperties interface

Row

ContentTableCell interface

iAssemblyMember interface

iAssemblyTableCell interface

iFeatureTableCell interface

iPartMember interface

iPartTableCell interface

Row interface

Application

Count

Delete

Height

Item

Parent

Reposition

Type

Visible

Row.Application property

Row.Count property

Row.Delete method

Row.Height property

Row.Item method

Row.Parent property

Row.Reposition method

Row.Type property

Row.Visible property

RowCount

RectangularOccurrencePattern interface

RowEntity

RectangularOccurrencePattern interface

RowEntityNaturalDirection

RectangularOccurrencePattern interface

RowGap

CustomTable interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

RowLineSpacing

CustomTable interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

RowMergeType

HoleTable interface

HoleTableStyle interface

RowOffset

RectangularOccurrencePattern interface

Rows

CustomTable interface

Rows interface

Add

Application

Count

Item

Type

Rows.Add method

Rows.Application property

Rows.Count property

Rows.Item method

Rows.Type property

RuleFilletFeature interface

RuleFilletFeatureProxy interface

ContainingOccurrence

NativeObject

RuleFilletFeatureProxy.ContainingOccurrence property

RuleFilletFeatureProxy.NativeObject property

RuleFilletFeatures

PartFeatures interface

RuleFilletFeatures interface

Application

Count

Item

Type

RuleFilletFeatures.Application property

RuleFilletFeatures.Count property

RuleFilletFeatures.Item method

RuleFilletFeatures.Type property

RunoffSurfaceDefinition interface

AddCornerPiece

AddExtrusionPiece

AddRadiatePiece

AddSurfaceExtensionPiece

CreateRunoff

CreateSingleRunoffPiece

RunoffSurfaceDefinition.AddCornerPiece method

RunoffSurfaceDefinition.AddExtrusionPiece method

RunoffSurfaceDefinition.AddRadiatePiece method

RunoffSurfaceDefinition.AddSurfaceExtensionPiece method

RunoffSurfaceDefinition.CreateRunoff method

RunoffSurfaceDefinition.CreateSingleRunoffPiece method

RunoffSurfaces

CoreCavityDefinition interface

S

Sample Code

SamplingLength

SurfaceTextureSymbol interface

Save

ContentFamily interface

Document interface

InventorVBAProject interface

Save2

Document interface

SaveAs

Document interface

InventorVBAProject interface

SaveAsBitmap

Camera interface

View interface

SaveAsInventorDWG

DrawingDocument interface

SaveContextToArray

ReferenceKeyManager interface

SaveCopyAs

TranslatorAddIn interface

TranslatorAddInServer interface

Saved

InventorVBAProject interface

SaveItemOverridesToBOM

Balloon interface

PartsList interface

PartsListRow interface

SaveOptions interface

Application

ListReferencedFilesInSaveDialog

PromptSaveForMigration

PromptSaveForRecomputableChanges

SaveReminderTimer

ShowSaveReminder

Type

SaveOptions.Application property

SaveOptions.ListReferencedFilesInSaveDialog property

SaveOptions.PromptSaveForMigration property

SaveOptions.PromptSaveForRecomputableChanges property

SaveOptions.SaveReminderTimer property

SaveOptions.ShowSaveReminder property

SaveOptions.Type property

SaveReminderTimer

SaveOptions interface

SaveToGlobal

LightingStyle interface

Material interface

RenderStyle interface

Style interface

SaveWithDocument

GraphicsDataSets interface

Scalable

TextGraphics interface

Scale

ApprenticeDrawingPrintManager interface

AutoCADBlock interface

DrawingPrintManager interface

DrawingView interface

SketchedSymbol interface

ScaleBy

Vector interface

Vector2d interface

ScaleByLineWeight

Layer interface

ScaleFactor

DerivedAssemblyDefinition interface

DerivedPartUniformScaleDef interface

ScaleFromBase

DrawingView interface

ScaleMode

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

ScaleString

DrawingView interface

ScaleToTextHeight

BalloonStyle interface

FeatureControlFrameStyle interface

LeaderStyle interface

SceneObject

Camera interface

ScreenColor

ColorScheme interface

ScreenColor2D

ColorScheme interface

ScreenUpdating

Application interface

SculptFeature interface

Operation

Surfaces

SculptFeature.Operation property

SculptFeature.Surfaces property

SculptFeatureProxy interface

ContainingOccurrence

NativeObject

SculptFeatureProxy.ContainingOccurrence property

SculptFeatureProxy.NativeObject property

SculptFeatures

PartFeatures interface

SculptFeatures interface

_Add

Add

Application

Count

CreateSculptSurface

Item

Type

SculptFeatures._Add method

SculptFeatures.Add method

SculptFeatures.Application property

SculptFeatures.Count property

SculptFeatures.CreateSculptSurface method

SculptFeatures.Item method

SculptFeatures.Type property

SculptSurface interface

Direction

Surface

Type

SculptSurface.Direction property

SculptSurface.Surface property

SculptSurface.Type property

SecondArrowheadInside

GeneralDimension interface

SecondArrowheadType

GeneralDimension interface

SecondarySelectColor

ColorScheme interface

SecondaryTagModifierOnRollup

HoleTable interface

HoleTableStyle interface

SecondLevelTooltipDelay

GeneralOptions interface

SectionAllParts

AssemblyOptions interface

BreakOutOperation interface

SectionDepth

SectionDrawingView interface

SectionDrawingView interface

FullSectionDepth

IncludeSlice

ReverseDirection

SectionDepth

SectionLineSketch

ShowEntireLine

SliceAllParts

UseAlignedMethod

SectionDrawingView.FullSectionDepth property

SectionDrawingView.IncludeSlice property

SectionDrawingView.ReverseDirection method

SectionDrawingView.SectionDepth property

SectionDrawingView.SectionLineSketch property

SectionDrawingView.ShowEntireLine property

SectionDrawingView.SliceAllParts property

SectionDrawingView.UseAlignedMethod property

SectionLineSketch

SectionDrawingView interface

Sections

LoftDefinition interface

Segments

DrawingCurve interface

Select

SelectSet interface

Selectable

ClientGraphics interface

GraphicsNode interface

Selected

BrowserNode interface

SelectedEntities

SelectEventsObject interface

SelectedIndex

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

SelectedItem

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

SelectEvents

InteractionEventsObject interface

SelectEvents coclass

SelectEventsObject interface

AddSelectionFilter

AddToSelectedEntities

AddWindowSelectionFilter

Application

ClearSelectionFilter

ClearWindowSelectionFilter

Enabled

IgnoreProfileInnerLoops

MouseMoveEnabled

Parent

PreSelectBurnThrough

RemoveFromSelectedEntities

ResetSelections

RestrictSelectionToOccurrence

SelectedEntities

SingleSelectEnabled

Type

WindowSelectEnabled

SelectEventsObject.AddSelectionFilter method

SelectEventsObject.AddToSelectedEntities method

SelectEventsObject.AddWindowSelectionFilter method

SelectEventsObject.Application property

SelectEventsObject.ClearSelectionFilter method

SelectEventsObject.ClearWindowSelectionFilter method

SelectEventsObject.Enabled property

SelectEventsObject.IgnoreProfileInnerLoops property

SelectEventsObject.MouseMoveEnabled property

SelectEventsObject.Parent property

SelectEventsObject.PreSelectBurnThrough property

SelectEventsObject.RemoveFromSelectedEntities method

SelectEventsObject.ResetSelections method

SelectEventsObject.RestrictSelectionToOccurrence property

SelectEventsObject.SelectedEntities property

SelectEventsObject.SingleSelectEnabled property

SelectEventsObject.Type property

SelectEventsObject.WindowSelectEnabled property

SelectEventsSink interface

OnPreSelect

OnPreSelectMouseMove

OnSelect

OnStopPreSelect

OnUnSelect

SelectEventsSink.OnPreSelect method

SelectEventsSink.OnPreSelectMouseMove method

SelectEventsSink.OnSelect method

SelectEventsSink.OnStopPreSelect method

SelectEventsSink.OnUnSelect method

SelectGroundedComponentsAndWorkGeometry

GripSnapOptions interface

SelectionActive

CommandManager interface

SelectionPriority

Document interface

SelectMultiple

SelectSet interface

SelectOtherDelay

GeneralOptions interface

SelectSet

Document interface

SelectSet interface

Clear

Count

Delete

Item

Remove

Select

SelectMultiple

Type

SelectSet.Clear method

SelectSet.Count property

SelectSet.Delete method

SelectSet.Item method

SelectSet.Remove method

SelectSet.Select method

SelectSet.SelectMultiple method

SelectSet.Type property

SELECTTYPE_INSIDE enumeration member

SELECTTYPE_OVERLAP enumeration member

SequenceIndex

iMateDefinition interface

SequentialNumbering

HoleTable interface

HoleTableStyle interface

ServicePack

SoftwareVersion interface

SetAccessOption

ContentCenterOptions interface

SetAffectedBodies

PartFeature interface

SetAffectedDocuments

ChangeProcessorObject interface

SetAlignment

FlatPattern interface

SetAllToMax

Parameters interface

SetAllToMedian

Parameters interface

SetAllToMin

Parameters interface

SetAllToNominal

Parameters interface

SetAmbientColor

RenderStyle interface

SetAngleExtent

RevolveFeature interface

SetAtCentroid

WorkPoint interface

SetAutomatedCenterlineSettings

DrawingSketch interface

DrawingView interface

Setback

FilletSetback interface

SetbackCount

FilletSetbackVertex interface

SetbackItem

FilletSetbackVertex interface

SetbackVertexCount

FilletDefinition interface

SetbackVertexItem

FilletDefinition interface

SetBalloonType

Balloon interface

SetBaseQuantity

BOMQuantity interface

SetBendOrder

FlatBendResult interface

SetBoundaryCondition

BoundaryPatchLoop interface

SetByAnalyticEdge

WorkAxis interface

SetByCurveAndEntity

WorkPoint interface

SetByLine

WorkAxis interface

SetByLineAndPlane

WorkAxis interface

SetByLineAndPoint

WorkAxis interface

SetByLineAndTangent

WorkPlane interface

SetByLinePlaneAndAngle

WorkPlane interface

SetByMidPoint

WorkPoint interface

SetByNormalToCurve

WorkPlane interface

SetByNormalToSurface

WorkAxis interface

SetByPlaneAndOffset

WorkPlane interface

SetByPlaneAndPoint

WorkPlane interface

SetByPlaneAndTangent

WorkPlane interface

SetByPoint

WorkPoint interface

SetByPointAndTangent

WorkPlane interface

SetByRevolvedFace

WorkAxis interface

SetByThreePlanes

WorkPoint interface

SetByThreePoints

UserCoordinateSystemDefinition interface

WorkPlane interface

SetByTorusCenterPoint

WorkPoint interface

SetByTorusMidPlane

WorkPlane interface

SetByTwoLines

WorkPlane interface

WorkPoint interface

SetByTwoPlanes

WorkAxis interface

WorkPlane interface

SetByTwoPoints

WorkAxis interface

SetCBore

HoleFeature interface

SetCenteredDefaultWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

SetCenteredWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

HemDefinition interface

SetCheckPoint

TransactionManager interface

SetColor

Color interface

HighlightSet interface

TextBox interface

SetConstraintSuppressionOverride

PositionalRepresentation interface

SetConstraintValueOverride

PositionalRepresentation interface

SetCoordinateSystem

DerivedPartCoordinateSystemDef interface

Matrix interface

Matrix2d interface

SetCSink

HoleFeature interface

SetCurrentAsFront

View interface

SetCurrentAsHome

View interface

SetCurrentAsTop

View interface

SetCurrentEnvironment

EnvironmentManager interface

SetCurrentView

ApprenticePrintManager interface

SetCursor

InteractionEventsObject interface

SetCustomImage

PointGraphics interface

SetCustomLineType

AutoCADBlock interface

ComponentGraphics interface

CurveGraphics interface

DimensionStyle interface

DrawingCurve interface

Layer interface

LeaderStyle interface

LineGraphics interface

LineStripGraphics interface

Sketch interface

SketchArc interface

SketchBlock interface

SketchCircle interface

SketchedSymbol interface

SketchEllipse interface

SketchEllipticalArc interface

SketchFixedSpline interface

SketchLine interface

SketchOffsetSpline interface

SketchSpline interface

SurfaceGraphics interface

SurfaceGraphicsEdge interface

SetCustomSection

DesignProject interface

SetCustomThumbnail

BIMComponentDescription interface

SetCutAcrossBendsExtent

CutDefinition interface

SetDepth

BreakOutOperation interface

SetDesignViewRepresentation

ComponentOccurrence interface

DrawingView interface

SetDiffuseColor

RenderStyle interface

SetDirectionAndDistanceMoveType

MoveFaceDefinition interface

SetDisplayMode

ComponentOccurrence interface

SetDistance

CornerChamferDefinition interface

SetDistanceAndAngle

CornerChamferDefinition interface

SetDistanceExtent

ContourFlangeDefinition interface

CutDefinition interface

ExtrudeDefinition interface

HoleFeature interface

SetDistanceExtentTwo

ExtrudeDefinition interface

SetDistanceHeightExtent

FlangeDefinition interface

SetDoubleHemType

HemDefinition interface

SetDrilled

HoleFeature interface

SetEdgeDefaultWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

SetEdgeWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

HemDefinition interface

SetEmbossEngraveFromPlane

EmbossFeature interface

SetEmbossFromFace

EmbossFeature interface

SetEmissiveColor

RenderStyle interface

SetEndFillRenderStyle

WeldmentComponentDefinition interface

SetEndOfFeaturesToTopOrBottom

AssemblyComponentDefinition interface

SetEndOfPart

BrowserFolder interface

PartFeature interface

PlanarSketch interface

ReferenceComponent interface

Sketch3D interface

UserCoordinateSystem interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

SetEndOfPartToTopOrBottom

FlatPattern interface

PartComponentDefinition interface

SetEngraveFromFace

EmbossFeature interface

SetEquation

UnfoldMethod interface

SetExpressionList

ExpressionList interface

SetExtents

Camera interface

SetFaceExtentsRipType

RipDefinition interface

SetFiniteExtent

RibDefinition interface

SetFixed

WorkAxis interface

WorkPlane interface

WorkPoint interface

SetFlexibleOverride

PositionalRepresentation interface

SetFocus

MiniToolbarValueEditorObject interface

SetFreeMoveType

MoveFaceDefinition interface

SetFromToDefaultWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

SetFromToExtent

CutDefinition interface

ExtrudeDefinition interface

RevolveFeature interface

SetFromToWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

HemDefinition interface

SetFullExtent

RevolveFeature interface

SetGroundingOverride

PositionalRepresentation interface

SetHandleStatus

SketchSpline interface

SketchSpline3D interface

SetHelpContext

FileDialog interface

SetHelpTopic

FileDialog interface

SetHolePatchingOptions

DerivedAssemblyDefinition interface

SetIncludeStatus

DrawingView interface

SetIncrement

DriveConstraintSettingsObject interface

SetInputs

iMateResult interface

SetInspectionDimensionData

DrawingDimension interface

SetLabel

ClientBrowserNodeDefinitionObject interface

SetLegacyDistanceHeightExtent

FlangeDefinition interface

SetLevelOfDetailRepresentation

ComponentOccurrence interface

SetMessageDialogOptions

ChangeProcessorObject interface

SetMinimumSize

DockableWindow interface

SetMissingAddInBehavior

Document interface

SetOffsetDefaultWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

SetOffsetWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

HemDefinition interface

SetOutputType

LoftedFlangeDefinition interface

SetPartNumberMergeSettings

BOM interface

SetPatternAngleOffsetOverride

PositionalRepresentation interface

SetPatternColumnOffsetOverride

PositionalRepresentation interface

SetPatternRowOffsetOverride

PositionalRepresentation interface

SetPitchAndHeightExtent

CoilFeature interface

SetPitchAndRevolutionExtent

CoilFeature interface

SetPlanarMoveType

MoveFaceDefinition interface

SetPointToPointRipType

RipDefinition interface

SetPosition

iFeatureSketchPlaneInput interface

MapPointCurve interface

SetPositionalRepresentationOverride

PositionalRepresentation interface

SetPositionUsingPoint

MapPointCurve interface

SetPromptResultText

Border interface

SketchedSymbol interface

TitleBlock interface

SetPromptTextValues

AutoCADBlock interface

SetPropertyMap

ContentTableColumn interface

SetRemoveBySizeOptions

DerivedAssemblyDefinition interface

SetRemoveByVisibilityOptions

DerivedAssemblyDefinition interface

SetRenderStyle

ComponentOccurrence interface

Face interface

PartFeature interface

PresentationExplodedView interface

SurfaceBody interface

SetRevolutionAndHeightExtent

CoilFeature interface

SetRolledHemType

HemDefinition interface

SetScale

DerivedPartCoordinateSystemDef interface

SetSectionTwists

PathAndSectionTwistsSweepDef interface

SetShape

BIMConnectorDefinition interface

SetSheetRange

ApprenticeDrawingPrintManager interface

DrawingPrintManager interface

SetSingleHemType

HemDefinition interface

SetSinglePointRipType

RipDefinition interface

SetSize

GroundPlaneSettings interface

WorkAxis interface

WorkPlane interface

SetSpecularColor

RenderStyle interface

SetSpiralExtent

CoilFeature interface

SetSpotFace

HoleFeature interface

SetSuppressionCondition

PartFeature interface

SetTeardropHemType

HemDefinition interface

SetThicknessPlane

RibDefinition interface

SetThreadDepth

ThreadFeature interface

SetThroughAllExtent

CutDefinition interface

ExtrudeDefinition interface

HoleFeature interface

SetThumbnailSaveOption

Document interface

SetToAlignCoordinateSystems

Matrix interface

Matrix2d interface

SetToBasic

Tolerance interface

SetToDefault

Tolerance interface

SetToDeviation

Tolerance interface

SetToExtent

CutDefinition interface

ExtrudeDefinition interface

SetToFaceExtent

HoleFeature interface

RevolveFeature interface

SetToFits

Tolerance interface

SetToHeightExtent

FlangeDefinition interface

SetToIdentity

Matrix interface

Matrix2d interface

SetToLimits

Tolerance interface

SetToMax

Tolerance interface

SetToMin

Tolerance interface

SetToNextExtent

CutDefinition interface

ExtrudeDefinition interface

RevolveFeature interface

RibDefinition interface

SetToReference

Tolerance interface

SetToRotateTo

Matrix interface

Matrix2d interface

SetToRotation

Matrix interface

Matrix2d interface

SetToSplitBody

SplitFeature interface

SetToSplitFaces

SplitFeature interface

SetToSymmetric

Tolerance interface

SetToTrimSolid

SplitFeature interface

SetTransformation

DerivedPartTransformDef interface

SetTransformBehavior

ComponentGraphics interface

CurveGraphics interface

LineGraphics interface

LineStripGraphics interface

SurfaceGraphics interface

TextGraphics interface

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

SetTransformOverride

PositionalRepresentation interface

SetTransformWithoutConstraints

ComponentOccurrence interface

SetTranslation

Matrix interface

Matrix2d interface

SetTwoDistances

CornerChamferDefinition interface

SetUsingPath

SweepFeature interface

SetUsingPathAndGuideRail

SweepFeature interface

SetUsingPathAndGuideSurface

SweepFeature interface

SetUsingPathAndSectionTwists

SweepFeature interface

SetViewLabelDefaults

DrawingStandardStyle interface

SetViewSpaceAnchor

GraphicsPrimitive interface

SetVisibility

DrawingView interface

PresentationExplodedView interface

Trail interface

SetWeldmentState

DrawingView interface

SetWidthOffsetDefaultWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

SetWidthOffsetWidthExtent

ContourFlangeDefinition interface

FlangeDefinition interface

HemDefinition interface

ShadedDisplayOptions

DisplayOptions interface

ShadedDisplayOptions interface

Application

Type

ShadedDisplayOptions.Application property

ShadedDisplayOptions.Type property

ShadowDensity

LightingStyle interface

ShadowDirection

LightingStyle interface

ShadowSoftness

LightingStyle interface

ShaftTolerance

Tolerance interface

Shared

PartFeature interface

PlanarSketch interface

Sketch3D interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

Sheet interface

Activate

AddBorder

AddDefaultBorder

AddTitleBlock

Application

AttributeSets

AutoCADBlocks

Balloons

Border

Centerlines

Centermarks

ChangeLayer

ClientGraphicsCollection

ClientViews

CopyTo

CreateGeometryIntent

CustomTables

DataIO

Delete

DrawingDimensions

DrawingNotes

DrawingViews

ExcludeFromCount

ExcludeFromPrinting

FeatureControlFrames

FindUsingPoint

GetReferenceKey

GraphicsDataSetsCollection

Height

HoleTables

IsModelSpaceSheet

Name

Orientation

Parent

PartsLists

RevisionTables

Size

SketchedSymbols

Sketches

Status

SurfaceTextureSymbols

TitleBlock

Type

Update

Width

Sheet.Activate method

Sheet.AddBorder method

Sheet.AddDefaultBorder method

Sheet.AddTitleBlock method

Sheet.Application property

Sheet.AttributeSets property

Sheet.AutoCADBlocks property

Sheet.Balloons property

Sheet.Border property

Sheet.Centerlines property

Sheet.Centermarks property

Sheet.ChangeLayer method

Sheet.ClientGraphicsCollection property

Sheet.ClientViews property

Sheet.CopyTo method

Sheet.CreateGeometryIntent method

Sheet.CustomTables property

Sheet.DataIO property

Sheet.Delete method

Sheet.DrawingDimensions property

Sheet.DrawingNotes property

Sheet.DrawingViews property

Sheet.ExcludeFromCount property

Sheet.ExcludeFromPrinting property

Sheet.FeatureControlFrames property

Sheet.FindUsingPoint method

Sheet.GetReferenceKey method

Sheet.GraphicsDataSetsCollection property

Sheet.Height property

Sheet.HoleTables property

Sheet.IsModelSpaceSheet property

Sheet.Name property

Sheet.Orientation property

Sheet.Parent property

Sheet.PartsLists property

Sheet.RevisionTables property

Sheet.Size property

Sheet.SketchedSymbols property

Sheet.Sketches property

Sheet.Status property

Sheet.SurfaceTextureSymbols property

Sheet.TitleBlock property

Sheet.Type property

Sheet.Update method

Sheet.Width property

SheetColor

SheetSettings interface

SheetEntityHighlightColor

SheetSettings interface

SheetEntitySelectionColor

SheetSettings interface

SheetFormat interface

Application

AttributeSets

CopyTo

Delete

GetReferenceKey

HasDrawingViews

Height

Name

Orientation

Parent

ReferencedAutoCADBlockDefinitions

ReferencedBorderDefinition

ReferencedSymbolDefinitions

ReferencedTitleBlockDefinition

Size

TitleBlockLocation

Type

Width

SheetFormat.Application property

SheetFormat.AttributeSets property

SheetFormat.CopyTo method

SheetFormat.Delete method

SheetFormat.GetReferenceKey method

SheetFormat.HasDrawingViews property

SheetFormat.Height property

SheetFormat.Name property

SheetFormat.Orientation property

SheetFormat.Parent property

SheetFormat.ReferencedAutoCADBlockDefinitions property

SheetFormat.ReferencedBorderDefinition property

SheetFormat.ReferencedSymbolDefinitions property

SheetFormat.ReferencedTitleBlockDefinition property

SheetFormat.Size property

SheetFormat.TitleBlockLocation property

SheetFormat.Type property

SheetFormat.Width property

SheetFormats

DrawingDocument interface

SheetFormats interface

Add

Application

Count

Item

Type

SheetFormats.Add method

SheetFormats.Application property

SheetFormats.Count property

SheetFormats.Item method

SheetFormats.Type property

SheetLabel

SheetSettings interface

SheetMetalComponentDefinition interface

ActiveSheetMetalStyle

BendRadius

BendReliefDepth

BendReliefWidth

Bends

CornerReliefSize

FlatPattern

GapSize

HasFlatPattern

JacobiRadiusSize

MinimumRemnant

SheetMetalStyles

Thickness

TransitionRadius

Unfold

Unfold2

UnfoldMethod

UnfoldMethods

UseSheetMetalStyleMaterial

UseSheetMetalStyleThickness

UseSheetMetalStyleUnfoldMethod

SheetMetalComponentDefinition.ActiveSheetMetalStyle property

SheetMetalComponentDefinition.BendRadius property

SheetMetalComponentDefinition.BendReliefDepth property

SheetMetalComponentDefinition.BendReliefWidth property

SheetMetalComponentDefinition.Bends property

SheetMetalComponentDefinition.CornerReliefSize property

SheetMetalComponentDefinition.FlatPattern property

SheetMetalComponentDefinition.GapSize property

SheetMetalComponentDefinition.HasFlatPattern property

SheetMetalComponentDefinition.JacobiRadiusSize property

SheetMetalComponentDefinition.MinimumRemnant property

SheetMetalComponentDefinition.SheetMetalStyles property

SheetMetalComponentDefinition.Thickness property

SheetMetalComponentDefinition.TransitionRadius property

SheetMetalComponentDefinition.Unfold method

SheetMetalComponentDefinition.Unfold2 method

SheetMetalComponentDefinition.UnfoldMethod property

SheetMetalComponentDefinition.UnfoldMethods property

SheetMetalComponentDefinition.UseSheetMetalStyleMaterial property

SheetMetalComponentDefinition.UseSheetMetalStyleThickness property

SheetMetalComponentDefinition.UseSheetMetalStyleUnfoldMethod property

SheetMetalFeatures interface

BendFeatures

ContourFlangeFeatures

ContourRollFeatures

CornerChamferFeatures

CornerFeatures

CornerRoundFeatures

CutFeatures

FaceFeatures

FlangeFeatures

FoldFeatures

HemFeatures

LoftedFlangeFeatures

PunchToolFeatures

RefoldFeatures

RipFeatures

UnfoldFeatures

SheetMetalFeatures.BendFeatures property

SheetMetalFeatures.ContourFlangeFeatures property

SheetMetalFeatures.ContourRollFeatures property

SheetMetalFeatures.CornerChamferFeatures property

SheetMetalFeatures.CornerFeatures property

SheetMetalFeatures.CornerRoundFeatures property

SheetMetalFeatures.CutFeatures property

SheetMetalFeatures.FaceFeatures property

SheetMetalFeatures.FlangeFeatures property

SheetMetalFeatures.FoldFeatures property

SheetMetalFeatures.HemFeatures property

SheetMetalFeatures.LoftedFlangeFeatures property

SheetMetalFeatures.PunchToolFeatures property

SheetMetalFeatures.RefoldFeatures property

SheetMetalFeatures.RipFeatures property

SheetMetalFeatures.UnfoldFeatures property

SheetMetalPunchesRootPath

iFeatureOptions interface

SheetMetalPunchLayer

ObjectDefaultsStyle interface

SheetMetalPunchStyle

ObjectDefaultsStyle interface

SheetMetalStyle interface

Activate

BendAngleReportType

BendRadius

BendReliefDepth

BendReliefShape

BendReliefWidth

BendTransition

BendTransitionArcRadius

CornerReliefShape

CornerReliefSize

GapSize

Material

MinimumRemnant

PunchRepresentationType

Thickness

ThreeBendCornerReliefShape

ThreeBendCornerReliefSize

UnfoldMethod

SheetMetalStyle.Activate method

SheetMetalStyle.BendAngleReportType property

SheetMetalStyle.BendRadius property

SheetMetalStyle.BendReliefDepth property

SheetMetalStyle.BendReliefShape property

SheetMetalStyle.BendReliefWidth property

SheetMetalStyle.BendTransition property

SheetMetalStyle.BendTransitionArcRadius property

SheetMetalStyle.CornerReliefShape property

SheetMetalStyle.CornerReliefSize property

SheetMetalStyle.GapSize property

SheetMetalStyle.Material property

SheetMetalStyle.MinimumRemnant property

SheetMetalStyle.PunchRepresentationType property

SheetMetalStyle.Thickness property

SheetMetalStyle.ThreeBendCornerReliefShape property

SheetMetalStyle.ThreeBendCornerReliefSize property

SheetMetalStyle.UnfoldMethod property

SheetMetalStyles

SheetMetalComponentDefinition interface

SheetMetalStyles interface

Application

Copy

Count

Item

Type

SheetMetalStyles.Application property

SheetMetalStyles.Copy method

SheetMetalStyles.Count property

SheetMetalStyles.Item method

SheetMetalStyles.Type property

SheetOutlineColor

SheetSettings interface

Sheets

ApprenticeServerDrawingDocument interface

DrawingDocument interface

Sheets interface

Add

AddUsingSheetFormat

Application

Count

Item

Type

Sheets.Add method

Sheets.AddUsingSheetFormat method

Sheets.Application property

Sheets.Count property

Sheets.Item method

Sheets.Type property

SheetSettings

DrawingDocument interface

SheetSettings interface

Application

Parent

SheetColor

SheetEntityHighlightColor

SheetEntitySelectionColor

SheetLabel

SheetOutlineColor

Type

SheetSettings.Application property

SheetSettings.Parent property

SheetSettings.SheetColor property

SheetSettings.SheetEntityHighlightColor property

SheetSettings.SheetEntitySelectionColor property

SheetSettings.SheetLabel property

SheetSettings.SheetOutlineColor property

SheetSettings.Type property

SheetToDrawingViewSpace

DrawingView interface

SheetToDrawingViewTransform

DrawingView interface

SheetToModelSpace

DrawingView interface

SheetToModelTransform

DrawingView interface

SheetToSketchSpace

DrawingSketch interface

ShellDefinition interface

AddThicknessFaceSet

Application

ApproximationOptimized

ApproximationTolerance

ApproximationType

Copy

Direction

FaceSetCount

FaceSetItem

InputFaces

Parent

Thickness

Type

ShellDefinition.AddThicknessFaceSet method

ShellDefinition.Application property

ShellDefinition.ApproximationOptimized property

ShellDefinition.ApproximationTolerance property

ShellDefinition.ApproximationType property

ShellDefinition.Copy method

ShellDefinition.Direction property

ShellDefinition.FaceSetCount property

ShellDefinition.FaceSetItem method

ShellDefinition.InputFaces property

ShellDefinition.Parent property

ShellDefinition.Thickness property

ShellDefinition.Type property

ShellFeature interface

Definition

ShellFeature.Definition property

ShellFeatureProxy interface

ContainingOccurrence

NativeObject

ShellFeatureProxy.ContainingOccurrence property

ShellFeatureProxy.NativeObject property

ShellFeatures

PartFeatures interface

ShellFeatures interface

Add

Application

Count

CreateShellDefinition

Item

Type

ShellFeatures.Add method

ShellFeatures.Application property

ShellFeatures.Count property

ShellFeatures.CreateShellDefinition method

ShellFeatures.Item method

ShellFeatures.Type property

ShellThicknessFaceSet interface

Application

Delete

Faces

Thickness

Type

ShellThicknessFaceSet.Application property

ShellThicknessFaceSet.Delete method

ShellThicknessFaceSet.Faces property

ShellThicknessFaceSet.Thickness property

ShellThicknessFaceSet.Type property

Shortcuts

DesignProject interface

ShortDisplayName

ApplicationAddIn interface

Show

ErrorManager interface

FeatureDimensions interface

Show3DIndicator

DisplayOptions interface

ShowAll

DesignViewRepresentation interface

ShowAllExtensionLines

GeneralDimension interface

ShowAmbientShadows

View interface

ShowApply

MiniToolbarObject interface

ShowAutocompleteForCommandAlias

GeneralOptions interface

ShowBoundaries

TextBox interface

ShowBreakSymbol

DimensionStyle interface

ShowBrowser

UserInterfaceManager interface

ShowCancel

MiniToolbarObject interface

ShowCheckBox

MiniToolbarListItem interface

ShowCleanScreen

UserInterfaceManager interface

ShowCommandAliasInputDialog

GeneralOptions interface

ShowCommandPromptTooltips

GeneralOptions interface

ShowDegreesOfFreedom

ComponentOccurrence interface

GripSnapOptions interface

ShowDimensionLine

DimensionStyle interface

ShowDimensions

MeasureEventsObject interface

ShowDirection

OrdinateDimensionSet interface

ShowDocumentTabs

UserInterfaceManager interface

ShowDocumentTabTooltips

GeneralOptions interface

ShowEntireLine

SectionDrawingView interface

ShowGroundPlane

View interface

ShowGroundReflections

View interface

ShowGroundShadows

View interface

ShowHiddenAnnotations

DrawingView interface

ShowHiddenCurves

DrawingView interface

ShowIcon

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

ShowLabel

DrawingView interface

ShowLeader

AngularGeneralDimension interface

HoleTag interface

LinearGeneralDimension interface

ShowLeadingZeros

CustomPropertyFormat interface

ShowMarkingMenu

UserInterfaceManager interface

ShowName

DrawingView interface

DrawingView interface

ShowNavigationBar

UserInterfaceManager interface

ShowObjectShadows

View interface

ShowOK

MiniToolbarObject interface

ShowOpen

FileDialog interface

ShowOpenOptions

TranslatorAddIn interface

TranslatorAddInServer interface

ShowOptionBox

MiniToolbarObject interface

ShowOrigin

UserCoordinateSystemSettings interface

ShowPanelBar

UserInterfaceManager interface

ShowPanelTitles

UserInterfaceManager interface

ShowQuickAccessControlsBelowRibbon

UserInterfaceManager interface

ShowSave

FileDialog interface

ShowSaveCopyAsOptions

TranslatorAddIn interface

TranslatorAddInServer interface

ShowSaveReminder

SaveOptions interface

ShowScale

DrawingView interface

DrawingView interface

ShowSecondLevelTooltips

GeneralOptions interface

ShowStatusBar

UserInterfaceManager interface

ShowSteeringWheel

UserInterfaceManager interface

ShowTags

HoleTable interface

ShowText

CommandControl interface

MiniToolbarComboBoxObject interface

MiniToolbarDropdownObject interface

ShowTitle

CustomTable interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

ShowTitleBar

DockableWindow interface

ShowToolBar

UserInterfaceManager interface

ShowTooltips

GeneralOptions interface

ShowTrailingZeros

CustomPropertyFormat interface

ShowTriad

UserCoordinateSystemSettings interface

ShowUncutSectionViewPreview

DrawingOptions interface

ShowUnitsString

CustomPropertyFormat interface

ShowVideoToolClips

GeneralOptions interface

ShowViewCube

UserInterfaceManager interface

ShowXAxis

UserCoordinateSystemSettings interface

ShowXYPlane

UserCoordinateSystemSettings interface

ShowXYZAxisLabels

DisplayOptions interface

ShowXZPlane

UserCoordinateSystemSettings interface

ShowYAxis

UserCoordinateSystemSettings interface

ShowYZPlane

UserCoordinateSystemSettings interface

ShowZAxis

UserCoordinateSystemSettings interface

SideFaces

ExtrudeFeature interface

HoleFeature interface

LoftFeature interface

RevolveFeature interface

SweepFeature interface

WeldBead interface

SideFacesOne

FilletFullRoundSet interface

SideFacesTwo

FilletFullRoundSet interface

SilentOperation

Application interface

SilhouetteCurve interface

Application

AttributeSets

BreakLink

Delete

DirectionEntity

Edit

FacesOrBody

GetReferenceKey

IncludeCoincidentSilhouettes

Name

Parent

SketchEntities

Type

SilhouetteCurve.Application property

SilhouetteCurve.AttributeSets property

SilhouetteCurve.BreakLink method

SilhouetteCurve.Delete method

SilhouetteCurve.DirectionEntity property

SilhouetteCurve.Edit method

SilhouetteCurve.FacesOrBody property

SilhouetteCurve.GetReferenceKey method

SilhouetteCurve.IncludeCoincidentSilhouettes property

SilhouetteCurve.Name property

SilhouetteCurve.Parent property

SilhouetteCurve.SketchEntities property

SilhouetteCurve.Type property

SilhouetteCurves

Sketch3D interface

SilhouetteCurves interface

Add

Application

Count

Item

Type

SilhouetteCurves.Add method

SilhouetteCurves.Application property

SilhouetteCurves.Count property

SilhouetteCurves.Item method

SilhouetteCurves.Type property

SingleDimensionLine

DiameterGeneralDimension interface

SingleHemDefinition interface

Gap

Length

Parent

SingleHemDefinition.Gap property

SingleHemDefinition.Length property

SingleHemDefinition.Parent property

SingleLineText

TextBox interface

SinglePointRipTypeDef interface

GapSide

GapSize

Parent

Point

Type

SinglePointRipTypeDef.GapSide property

SinglePointRipTypeDef.GapSize property

SinglePointRipTypeDef.Parent property

SinglePointRipTypeDef.Point property

SinglePointRipTypeDef.Type property

SingleSelectEnabled

SelectEventsObject interface

Size

FeatureControlFrameStyle interface

LoftSectionDimension interface

Sheet interface

SheetFormat interface

SizeAsScaleFactor

LoftSectionDimension interface

Sketch

BorderDefinition interface

HoleFeature interface

SketchedSymbolDefinition interface

TitleBlockDefinition interface

Sketch interface

AddByProjectingEntity

Application

AttributeSets

Color

ConstraintStatus

CopyContentsTo

DataIO

DeferUpdates

Delete

DimensionConstraints

DisabledActionTypes

Edit

ExitEdit

GeometricConstraints

GetCustomLineType

GetReferenceKey

LineType

LineWeight

MoveSketchObjects

Name

OffsetSketchEntitiesUsingDistance

OffsetSketchEntitiesUsingPoint

Parent

RotateSketchObjects

SetCustomLineType

SketchArcs

SketchCircles

SketchEllipses

SketchEllipticalArcs

SketchEntities

SketchFixedSplines

SketchImages

SketchLines

SketchOffsetSplines

SketchPoints

SketchSplines

Solve

TextBoxes

Type

Visible

Sketch.AddByProjectingEntity method

Sketch.Application property

Sketch.AttributeSets property

Sketch.Color property

Sketch.ConstraintStatus property

Sketch.CopyContentsTo method

Sketch.DataIO property

Sketch.DeferUpdates property

Sketch.Delete method

Sketch.DimensionConstraints property

Sketch.DisabledActionTypes property

Sketch.Edit method

Sketch.ExitEdit method

Sketch.GeometricConstraints property

Sketch.GetCustomLineType method

Sketch.GetReferenceKey method

Sketch.LineType property

Sketch.LineWeight property

Sketch.MoveSketchObjects method

Sketch.Name property

Sketch.OffsetSketchEntitiesUsingDistance method

Sketch.OffsetSketchEntitiesUsingPoint method

Sketch.Parent property

Sketch.RotateSketchObjects method

Sketch.SetCustomLineType method

Sketch.SketchArcs property

Sketch.SketchCircles property

Sketch.SketchEllipses property

Sketch.SketchEllipticalArcs property

Sketch.SketchEntities property

Sketch.SketchFixedSplines property

Sketch.SketchImages property

Sketch.SketchLines property

Sketch.SketchOffsetSplines property

Sketch.SketchPoints property

Sketch.SketchSplines property

Sketch.Solve method

Sketch.TextBoxes property

Sketch.Type property

Sketch.Visible property

Sketch3D interface

Application

AttributeSets

Consumed

DeferUpdates

Delete

Dependents

DimensionConstraints3D

DimensionsVisible

DisabledActionTypes

Edit

ExitEdit

Exported

GeometricConstraints3D

GetReferenceKey

HasReferenceComponent

HealthStatus

Include

IsOwnedByFeature

Name

OverrideColor

OwnedBy

Parent

Profiles3D

ReferenceComponent

ReferencedEntity

SetEndOfPart

Shared

SilhouetteCurves

SketchArcs3D

SketchCircles3D

SketchEllipses3D

SketchEllipticalArcs3D

SketchEntities3D

SketchFixedSplines3D

SketchLines3D

SketchPoints3D

SketchSplines3D

Solve

Type

Visible

Sketch3D.Application property

Sketch3D.AttributeSets property

Sketch3D.Consumed property

Sketch3D.DeferUpdates property

Sketch3D.Delete method

Sketch3D.Dependents property

Sketch3D.DimensionConstraints3D property

Sketch3D.DimensionsVisible property

Sketch3D.DisabledActionTypes property

Sketch3D.Edit method

Sketch3D.ExitEdit method

Sketch3D.Exported property

Sketch3D.GeometricConstraints3D property

Sketch3D.GetReferenceKey method

Sketch3D.HasReferenceComponent property

Sketch3D.HealthStatus property

Sketch3D.Include method

Sketch3D.IsOwnedByFeature property

Sketch3D.Name property

Sketch3D.OverrideColor property

Sketch3D.OwnedBy property

Sketch3D.Parent property

Sketch3D.Profiles3D property

Sketch3D.ReferenceComponent property

Sketch3D.ReferencedEntity property

Sketch3D.SetEndOfPart method

Sketch3D.Shared property

Sketch3D.SilhouetteCurves property

Sketch3D.SketchArcs3D property

Sketch3D.SketchCircles3D property

Sketch3D.SketchEllipses3D property

Sketch3D.SketchEllipticalArcs3D property

Sketch3D.SketchEntities3D property

Sketch3D.SketchFixedSplines3D property

Sketch3D.SketchLines3D property

Sketch3D.SketchPoints3D property

Sketch3D.SketchSplines3D property

Sketch3D.Solve method

Sketch3D.Type property

Sketch3D.Visible property

Sketch3DGeometryLayer

ObjectDefaultsStyle interface

Sketch3DOptions interface

Application

AutoBendWithLineCreation

Type

Sketch3DOptions.Application property

Sketch3DOptions.AutoBendWithLineCreation property

Sketch3DOptions.Type property

Sketch3DProxy interface

ContainingOccurrence

NativeObject

Sketch3DProxy.ContainingOccurrence property

Sketch3DProxy.NativeObject property

Sketch3DSettings

PartDocument interface

Sketch3DSettings interface

Application

AutoBendRadius

Parent

Type

Sketch3DSettings.Application property

Sketch3DSettings.AutoBendRadius property

Sketch3DSettings.Parent property

Sketch3DSettings.Type property

SketchActive

PartDocument interface

SketchArc interface

CenterSketchPoint

CurvatureDisplay

EndSketchPoint

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

OverrideColor

Radius

SetCustomLineType

StartAngle

StartSketchPoint

SweepAngle

SketchArc.CenterSketchPoint property

SketchArc.CurvatureDisplay property

SketchArc.EndSketchPoint property

SketchArc.Geometry property

SketchArc.GetCustomLineType method

SketchArc.Length property

SketchArc.LineDefinitionSpace property

SketchArc.LineScale property

SketchArc.LineType property

SketchArc.LineWeight property

SketchArc.OverrideColor property

SketchArc.Radius property

SketchArc.SetCustomLineType method

SketchArc.StartAngle property

SketchArc.StartSketchPoint property

SketchArc.SweepAngle property

SketchArc3D interface

CenterPoint

CurvatureDisplay

EndSketchPoint

Geometry

Length

Radius

StartAngle

StartSketchPoint

SweepAngle

SketchArc3D.CenterPoint property

SketchArc3D.CurvatureDisplay property

SketchArc3D.EndSketchPoint property

SketchArc3D.Geometry property

SketchArc3D.Length property

SketchArc3D.Radius property

SketchArc3D.StartAngle property

SketchArc3D.StartSketchPoint property

SketchArc3D.SweepAngle property

SketchArc3DProxy interface

ContainingOccurrence

NativeObject

SketchArc3DProxy.ContainingOccurrence property

SketchArc3DProxy.NativeObject property

SketchArcProxy interface

ContainingOccurrence

NativeObject

SketchArcProxy.ContainingOccurrence property

SketchArcProxy.NativeObject property

SketchArcs

Sketch interface

SketchArcs interface

AddByCenterStartEndPoint

AddByCenterStartSweepAngle

AddByFillet

AddByThreePoints

Application

Count

Item

Type

SketchArcs.AddByCenterStartEndPoint method

SketchArcs.AddByCenterStartSweepAngle method

SketchArcs.AddByFillet method

SketchArcs.AddByThreePoints method

SketchArcs.Application property

SketchArcs.Count property

SketchArcs.Item method

SketchArcs.Type property

SketchArcs3D

Sketch3D interface

SketchArcs3D interface

AddAsBend

AddByCenterStartEndPoint

AddByCenterStartSweepAngle

AddByThreePoints

Application

Count

Item

Type

SketchArcs3D.AddAsBend method

SketchArcs3D.AddByCenterStartEndPoint method

SketchArcs3D.AddByCenterStartSweepAngle method

SketchArcs3D.AddByThreePoints method

SketchArcs3D.Application property

SketchArcs3D.Count property

SketchArcs3D.Item method

SketchArcs3D.Type property

SketchBlock interface

Application

AttributeSets

ChildBlocks

Color

ConstraintStatus

ContainingSketchBlock

Definition

Delete

Edit

ExitEdit

Explode

Exported

Flexible

GetCustomLineType

GetObject

GetReferenceKey

HasReferenceComponent

LineType

LineWeight

Name

Parent

Position

ReferenceComponent

ReferencedEntity

SetCustomLineType

SketchBlockPath

Transformation

Type

Visible

SketchBlock.Application property

SketchBlock.AttributeSets property

SketchBlock.ChildBlocks property

SketchBlock.Color property

SketchBlock.ConstraintStatus property

SketchBlock.ContainingSketchBlock property

SketchBlock.Definition property

SketchBlock.Delete method

SketchBlock.Edit method

SketchBlock.ExitEdit method

SketchBlock.Explode method

SketchBlock.Exported property

SketchBlock.Flexible property

SketchBlock.GetCustomLineType method

SketchBlock.GetObject method

SketchBlock.GetReferenceKey method

SketchBlock.HasReferenceComponent property

SketchBlock.LineType property

SketchBlock.LineWeight property

SketchBlock.Name property

SketchBlock.Parent property

SketchBlock.Position property

SketchBlock.ReferenceComponent property

SketchBlock.ReferencedEntity property

SketchBlock.SetCustomLineType method

SketchBlock.SketchBlockPath property

SketchBlock.Transformation property

SketchBlock.Type property

SketchBlock.Visible property

SketchBlockDefinition interface

AdjustContext

CopyTo

InsertionPoint

IsInsertionPointVisible

IsReferenced

SketchBlockDefinition.AdjustContext method

SketchBlockDefinition.CopyTo method

SketchBlockDefinition.InsertionPoint property

SketchBlockDefinition.IsInsertionPointVisible property

SketchBlockDefinition.IsReferenced property

SketchBlockDefinitionProxy interface

ContainingOccurrence

NativeObject

SketchBlockDefinitionProxy.ContainingOccurrence property

SketchBlockDefinitionProxy.NativeObject property

SketchBlockDefinitions

DerivedPartComponent interface

DerivedPartUniformScaleDef interface

FlatPattern interface

PartComponentDefinition interface

SketchBlockDefinitions interface

Add

Application

Count

Item

Type

SketchBlockDefinitions.Add method

SketchBlockDefinitions.Application property

SketchBlockDefinitions.Count property

SketchBlockDefinitions.Item method

SketchBlockDefinitions.Type property

SketchBlockDefinitionsEnumerator interface

Count

Item

Type

SketchBlockDefinitionsEnumerator.Count property

SketchBlockDefinitionsEnumerator.Item method

SketchBlockDefinitionsEnumerator.Type property

SketchBlockPath

SketchBlock interface

SketchEntity interface

SketchImage interface

TextBox interface

SketchBlockProxy interface

ContainingOccurrence

NativeObject

SketchBlockProxy.ContainingOccurrence property

SketchBlockProxy.NativeObject property

SketchBlocks

DerivedPartComponent interface

DerivedPartUniformScaleDef interface

PlanarSketch interface

SketchBlocks interface

Add

AddByDefinition

Application

Count

Item

Type

SketchBlocks.Add method

SketchBlocks.AddByDefinition method

SketchBlocks.Application property

SketchBlocks.Count property

SketchBlocks.Item method

SketchBlocks.Type property

SketchBlocksEnumerator interface

Count

Item

Type

SketchBlocksEnumerator.Count property

SketchBlocksEnumerator.Item method

SketchBlocksEnumerator.Type property

SketchCircle interface

Area

CenterSketchPoint

CurvatureDisplay

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

OverrideColor

Radius

SetCustomLineType

SketchCircle.Area property

SketchCircle.CenterSketchPoint property

SketchCircle.CurvatureDisplay property

SketchCircle.Geometry property

SketchCircle.GetCustomLineType method

SketchCircle.Length property

SketchCircle.LineDefinitionSpace property

SketchCircle.LineScale property

SketchCircle.LineType property

SketchCircle.LineWeight property

SketchCircle.OverrideColor property

SketchCircle.Radius property

SketchCircle.SetCustomLineType method

SketchCircle3D interface

Area

CenterPoint

CurvatureDisplay

Geometry

Length

Radius

SketchCircle3D.Area property

SketchCircle3D.CenterPoint property

SketchCircle3D.CurvatureDisplay property

SketchCircle3D.Geometry property

SketchCircle3D.Length property

SketchCircle3D.Radius property

SketchCircle3DProxy interface

ContainingOccurrence

NativeObject

SketchCircle3DProxy.ContainingOccurrence property

SketchCircle3DProxy.NativeObject property

SketchCircleProxy interface

ContainingOccurrence

NativeObject

SketchCircleProxy.ContainingOccurrence property

SketchCircleProxy.NativeObject property

SketchCircles

Sketch interface

SketchCircles interface

AddByCenterRadius

AddByThreePoints

Application

Count

Item

Type

SketchCircles.AddByCenterRadius method

SketchCircles.AddByThreePoints method

SketchCircles.Application property

SketchCircles.Count property

SketchCircles.Item method

SketchCircles.Type property

SketchCircles3D

Sketch3D interface

SketchCircles3D interface

AddByCenterRadius

AddByThreePoints

Application

Count

Item

Type

SketchCircles3D.AddByCenterRadius method

SketchCircles3D.AddByThreePoints method

SketchCircles3D.Application property

SketchCircles3D.Count property

SketchCircles3D.Item method

SketchCircles3D.Type property

SketchConstraints3DEnumerator interface

Count

Item

Type

SketchConstraints3DEnumerator.Count property

SketchConstraints3DEnumerator.Item method

SketchConstraints3DEnumerator.Type property

SketchConstraintsEnumerator interface

Count

Item

Type

SketchConstraintsEnumerator.Count property

SketchConstraintsEnumerator.Item method

SketchConstraintsEnumerator.Type property

SketchCreationOnNewPart

PartOptions interface

SketchedSymbol interface

Application

AttributeSets

Callout

Color

Definition

Delete

GetCustomLineType

GetReferenceKey

GetResultText

Layer

Leader

LeaderClipping

LeaderStyle

LeaderVisible

LineType

LineWeight

Name

Parent

Position

Rotation

Scale

SetCustomLineType

SetPromptResultText

Static

SymbolClipping

Transformation

Type

SketchedSymbol.Application property

SketchedSymbol.AttributeSets property

SketchedSymbol.Callout property

SketchedSymbol.Color property

SketchedSymbol.Definition property

SketchedSymbol.Delete method

SketchedSymbol.GetCustomLineType method

SketchedSymbol.GetReferenceKey method

SketchedSymbol.GetResultText method

SketchedSymbol.Layer property

SketchedSymbol.Leader property

SketchedSymbol.LeaderClipping property

SketchedSymbol.LeaderStyle property

SketchedSymbol.LeaderVisible property

SketchedSymbol.LineType property

SketchedSymbol.LineWeight property

SketchedSymbol.Name property

SketchedSymbol.Parent property

SketchedSymbol.Position property

SketchedSymbol.Rotation property

SketchedSymbol.Scale property

SketchedSymbol.SetCustomLineType method

SketchedSymbol.SetPromptResultText method

SketchedSymbol.Static property

SketchedSymbol.SymbolClipping property

SketchedSymbol.Transformation property

SketchedSymbol.Type property

SketchedSymbolDefinition interface

Application

AttributeSets

CopyTo

Delete

Edit

ExitEdit

GetReferenceKey

IsReferenced

Name

Parent

Sketch

Type

SketchedSymbolDefinition.Application property

SketchedSymbolDefinition.AttributeSets property

SketchedSymbolDefinition.CopyTo method

SketchedSymbolDefinition.Delete method

SketchedSymbolDefinition.Edit method

SketchedSymbolDefinition.ExitEdit method

SketchedSymbolDefinition.GetReferenceKey method

SketchedSymbolDefinition.IsReferenced property

SketchedSymbolDefinition.Name property

SketchedSymbolDefinition.Parent property

SketchedSymbolDefinition.Sketch property

SketchedSymbolDefinition.Type property

SketchedSymbolDefinitions

DrawingDocument interface

SketchedSymbolDefinitions interface

Add

Application

Count

Item

Type

SketchedSymbolDefinitions.Add method

SketchedSymbolDefinitions.Application property

SketchedSymbolDefinitions.Count property

SketchedSymbolDefinitions.Item method

SketchedSymbolDefinitions.Type property

SketchedSymbolGeometryLayer

ObjectDefaultsStyle interface

SketchedSymbolLeaderLayer

ObjectDefaultsStyle interface

SketchedSymbolLeaderStyle

ObjectDefaultsStyle interface

SketchedSymbols

Sheet interface

SketchedSymbols interface

Add

AddWithLeader

Application

Count

Item

Type

SketchedSymbols.Add method

SketchedSymbols.AddWithLeader method

SketchedSymbols.Application property

SketchedSymbols.Count property

SketchedSymbols.Item method

SketchedSymbols.Type property

SketchedSymbolTextLayer

ObjectDefaultsStyle interface

SketchedSymbolTextStyle

ObjectDefaultsStyle interface

SketchEllipse interface

Area

CenterSketchPoint

CurvatureDisplay

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

MajorAxisVector

MajorRadius

MinorRadius

OverrideColor

SetCustomLineType

SketchEllipse.Area property

SketchEllipse.CenterSketchPoint property

SketchEllipse.CurvatureDisplay property

SketchEllipse.Geometry property

SketchEllipse.GetCustomLineType method

SketchEllipse.Length property

SketchEllipse.LineDefinitionSpace property

SketchEllipse.LineScale property

SketchEllipse.LineType property

SketchEllipse.LineWeight property

SketchEllipse.MajorAxisVector property

SketchEllipse.MajorRadius property

SketchEllipse.MinorRadius property

SketchEllipse.OverrideColor property

SketchEllipse.SetCustomLineType method

SketchEllipse3D interface

Area

CenterPoint

CurvatureDisplay

Geometry

Length

MajorAxisVector

MajorRadius

MinorRadius

SketchEllipse3D.Area property

SketchEllipse3D.CenterPoint property

SketchEllipse3D.CurvatureDisplay property

SketchEllipse3D.Geometry property

SketchEllipse3D.Length property

SketchEllipse3D.MajorAxisVector property

SketchEllipse3D.MajorRadius property

SketchEllipse3D.MinorRadius property

SketchEllipse3DProxy interface

ContainingOccurrence

NativeObject

SketchEllipse3DProxy.ContainingOccurrence property

SketchEllipse3DProxy.NativeObject property

SketchEllipseProxy interface

ContainingOccurrence

NativeObject

SketchEllipseProxy.ContainingOccurrence property

SketchEllipseProxy.NativeObject property

SketchEllipses

Sketch interface

SketchEllipses interface

Add

Application

Count

Item

Type

SketchEllipses.Add method

SketchEllipses.Application property

SketchEllipses.Count property

SketchEllipses.Item method

SketchEllipses.Type property

SketchEllipses3D

Sketch3D interface

SketchEllipses3D interface

Application

Count

Item

Type

SketchEllipses3D.Application property

SketchEllipses3D.Count property

SketchEllipses3D.Item method

SketchEllipses3D.Type property

SketchEllipticalArc interface

CenterSketchPoint

CurvatureDisplay

EndSketchPoint

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

MajorAxisVector

MajorRadius

MinorRadius

OverrideColor

SetCustomLineType

StartAngle

StartSketchPoint

SweepAngle

SketchEllipticalArc.CenterSketchPoint property

SketchEllipticalArc.CurvatureDisplay property

SketchEllipticalArc.EndSketchPoint property

SketchEllipticalArc.Geometry property

SketchEllipticalArc.GetCustomLineType method

SketchEllipticalArc.Length property

SketchEllipticalArc.LineDefinitionSpace property

SketchEllipticalArc.LineScale property

SketchEllipticalArc.LineType property

SketchEllipticalArc.LineWeight property

SketchEllipticalArc.MajorAxisVector property

SketchEllipticalArc.MajorRadius property

SketchEllipticalArc.MinorRadius property

SketchEllipticalArc.OverrideColor property

SketchEllipticalArc.SetCustomLineType method

SketchEllipticalArc.StartAngle property

SketchEllipticalArc.StartSketchPoint property

SketchEllipticalArc.SweepAngle property

SketchEllipticalArc3D interface

CenterPoint

CurvatureDisplay

EndSketchPoint

Geometry

Length

MajorAxisVector

MajorRadius

MinorRadius

StartAngle

StartSketchPoint

SweepAngle

SketchEllipticalArc3D.CenterPoint property

SketchEllipticalArc3D.CurvatureDisplay property

SketchEllipticalArc3D.EndSketchPoint property

SketchEllipticalArc3D.Geometry property

SketchEllipticalArc3D.Length property

SketchEllipticalArc3D.MajorAxisVector property

SketchEllipticalArc3D.MajorRadius property

SketchEllipticalArc3D.MinorRadius property

SketchEllipticalArc3D.StartAngle property

SketchEllipticalArc3D.StartSketchPoint property

SketchEllipticalArc3D.SweepAngle property

SketchEllipticalArc3DProxy interface

ContainingOccurrence

NativeObject

SketchEllipticalArc3DProxy.ContainingOccurrence property

SketchEllipticalArc3DProxy.NativeObject property

SketchEllipticalArcProxy interface

ContainingOccurrence

NativeObject

SketchEllipticalArcProxy.ContainingOccurrence property

SketchEllipticalArcProxy.NativeObject property

SketchEllipticalArcs

Sketch interface

SketchEllipticalArcs interface

Add

Application

Count

Item

Type

SketchEllipticalArcs.Add method

SketchEllipticalArcs.Application property

SketchEllipticalArcs.Count property

SketchEllipticalArcs.Item method

SketchEllipticalArcs.Type property

SketchEllipticalArcs3D

Sketch3D interface

SketchEllipticalArcs3D interface

Application

Count

Item

Type

SketchEllipticalArcs3D.Application property

SketchEllipticalArcs3D.Count property

SketchEllipticalArcs3D.Item method

SketchEllipticalArcs3D.Type property

SketchEntities

ProjectedCut interface

SilhouetteCurve interface

Sketch interface

SketchEntities3D

Sketch3D interface

SketchEntities3DEnumerator interface

Count

Item

Type

SketchEntities3DEnumerator.Count property

SketchEntities3DEnumerator.Item method

SketchEntities3DEnumerator.Type property

SketchEntitiesEnumerator interface

Count

Item

Type

SketchEntitiesEnumerator.Count property

SketchEntitiesEnumerator.Item method

SketchEntitiesEnumerator.Type property

SketchEntity

PathEntity interface

ProfileEntity interface

ProfileEntity3D interface

SketchEntity interface

Application

AttributeSets

Constraints

ConstraintStatus

Construction

ContainingSketchBlock

Delete

DisabledActionTypes

GetReferenceKey

HasReferenceComponent

Layer

OwnedBy

Parent

RangeBox

Reference

ReferenceComponent

ReferencedEntity

SketchBlockPath

SketchOnly

Type

SketchEntity.Application property

SketchEntity.AttributeSets property

SketchEntity.Constraints property

SketchEntity.ConstraintStatus property

SketchEntity.Construction property

SketchEntity.ContainingSketchBlock property

SketchEntity.Delete method

SketchEntity.DisabledActionTypes property

SketchEntity.GetReferenceKey method

SketchEntity.HasReferenceComponent property

SketchEntity.Layer property

SketchEntity.OwnedBy property

SketchEntity.Parent property

SketchEntity.RangeBox property

SketchEntity.Reference property

SketchEntity.ReferenceComponent property

SketchEntity.ReferencedEntity property

SketchEntity.SketchBlockPath property

SketchEntity.SketchOnly property

SketchEntity.Type property

SketchEntity3D interface

Application

AssociativeID

AttributeSets

Constraints3D

ConstraintStatus

Construction

Delete

GetReferenceKey

HasReferenceComponent

OwnedBy

Parent

RangeBox

Reference

ReferenceComponent

ReferencedEntity

Type

SketchEntity3D.Application property

SketchEntity3D.AssociativeID method

SketchEntity3D.AttributeSets property

SketchEntity3D.Constraints3D property

SketchEntity3D.ConstraintStatus property

SketchEntity3D.Construction property

SketchEntity3D.Delete method

SketchEntity3D.GetReferenceKey method

SketchEntity3D.HasReferenceComponent property

SketchEntity3D.OwnedBy property

SketchEntity3D.Parent property

SketchEntity3D.RangeBox property

SketchEntity3D.Reference property

SketchEntity3D.ReferenceComponent property

SketchEntity3D.ReferencedEntity property

SketchEntity3D.Type property

Sketches

AssemblyComponentDefinition interface

DerivedPartComponent interface

DerivedPartUniformScaleDef interface

DrawingView interface

FlatPattern interface

iFeature interface

ObjectVisibility interface

PartComponentDefinition interface

Sheet interface

Sketches3D

DerivedPartComponent interface

DerivedPartUniformScaleDef interface

FlatPattern interface

ObjectVisibility interface

PartComponentDefinition interface

Sketches3D interface

Add

Application

Count

Item

Type

Sketches3D.Add method

Sketches3D.Application property

Sketches3D.Count property

Sketches3D.Item method

Sketches3D.Type property

Sketches3DEnumerator interface

Count

Item

Type

Sketches3DEnumerator.Count property

Sketches3DEnumerator.Item method

Sketches3DEnumerator.Type property

SketchesEnumerator interface

Count

Item

Type

SketchesEnumerator.Count property

SketchesEnumerator.Item method

SketchesEnumerator.Type property

SketchEvents coclass

SketchEventsObject interface

Application

Parent

Type

SketchEventsObject.Application property

SketchEventsObject.Parent property

SketchEventsObject.Type property

SketchEventsSink interface

OnDelete

OnNewSketch

OnNewSketch3D

OnSketch3DChange

OnSketch3DSolve

OnSketchChange

SketchEventsSink.OnDelete method

SketchEventsSink.OnNewSketch method

SketchEventsSink.OnNewSketch3D method

SketchEventsSink.OnSketch3DChange method

SketchEventsSink.OnSketch3DSolve method

SketchEventsSink.OnSketchChange method

SketchFillRegion interface

Application

AttributeSets

Color

Delete

GetReferenceKey

Parent

Profile

Type

SketchFillRegion.Application property

SketchFillRegion.AttributeSets property

SketchFillRegion.Color property

SketchFillRegion.Delete method

SketchFillRegion.GetReferenceKey method

SketchFillRegion.Parent property

SketchFillRegion.Profile property

SketchFillRegion.Type property

SketchFillRegions

DrawingSketch interface

SketchFillRegions interface

Add

Application

Count

Item

Type

SketchFillRegions.Add method

SketchFillRegions.Application property

SketchFillRegions.Count property

SketchFillRegions.Item method

SketchFillRegions.Type property

SketchFixedSpline interface

Closed

ConvertToSpline

Edit

EndSketchPoint

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

OverrideColor

SetCustomLineType

StartSketchPoint

SketchFixedSpline.Closed property

SketchFixedSpline.ConvertToSpline method

SketchFixedSpline.Edit method

SketchFixedSpline.EndSketchPoint property

SketchFixedSpline.Geometry property

SketchFixedSpline.GetCustomLineType method

SketchFixedSpline.Length property

SketchFixedSpline.LineDefinitionSpace property

SketchFixedSpline.LineScale property

SketchFixedSpline.LineType property

SketchFixedSpline.LineWeight property

SketchFixedSpline.OverrideColor property

SketchFixedSpline.SetCustomLineType method

SketchFixedSpline.StartSketchPoint property

SketchFixedSpline3D interface

Closed

ConvertToSpline

Edit

EditByEdge

EndSketchPoint

Geometry

IsDefinedByEdge

Length

StartSketchPoint

SketchFixedSpline3D.Closed property

SketchFixedSpline3D.ConvertToSpline method

SketchFixedSpline3D.Edit method

SketchFixedSpline3D.EditByEdge method

SketchFixedSpline3D.EndSketchPoint property

SketchFixedSpline3D.Geometry property

SketchFixedSpline3D.IsDefinedByEdge property

SketchFixedSpline3D.Length property

SketchFixedSpline3D.StartSketchPoint property

SketchFixedSpline3DProxy interface

ContainingOccurrence

NativeObject

SketchFixedSpline3DProxy.ContainingOccurrence property

SketchFixedSpline3DProxy.NativeObject property

SketchFixedSplineProxy interface

ContainingOccurrence

NativeObject

SketchFixedSplineProxy.ContainingOccurrence property

SketchFixedSplineProxy.NativeObject property

SketchFixedSplines

Sketch interface

SketchFixedSplines interface

Add

Application

Count

Item

Type

SketchFixedSplines.Add method

SketchFixedSplines.Application property

SketchFixedSplines.Count property

SketchFixedSplines.Item method

SketchFixedSplines.Type property

SketchFixedSplines3D

Sketch3D interface

SketchFixedSplines3D interface

Add

AddByEdge

Application

Count

Item

Type

SketchFixedSplines3D.Add method

SketchFixedSplines3D.AddByEdge method

SketchFixedSplines3D.Application property

SketchFixedSplines3D.Count property

SketchFixedSplines3D.Item method

SketchFixedSplines3D.Type property

SketchGeometryLayer

ObjectDefaultsStyle interface

SketchHolePlacementDefinition interface

HoleCenterPoints

SketchHolePlacementDefinition.HoleCenterPoints property

SketchImage interface

Application

AttributeSets

BoundaryGeometry

ContainingSketchBlock

Delete

GetReferenceKey

Height

Image

ImageAlpha

LinkedToFile

MirrorHorizontal

MirrorVertical

Name

Parent

Position

ReferencedFileDescriptor

RotateLeft

RotateRight

SketchBlockPath

Transparent

Type

Update

Visible

Width

SketchImage.Application property

SketchImage.AttributeSets property

SketchImage.BoundaryGeometry property

SketchImage.ContainingSketchBlock property

SketchImage.Delete method

SketchImage.GetReferenceKey method

SketchImage.Height property

SketchImage.Image property

SketchImage.ImageAlpha property

SketchImage.LinkedToFile property

SketchImage.MirrorHorizontal method

SketchImage.MirrorVertical method

SketchImage.Name property

SketchImage.Parent property

SketchImage.Position property

SketchImage.ReferencedFileDescriptor property

SketchImage.RotateLeft method

SketchImage.RotateRight method

SketchImage.SketchBlockPath property

SketchImage.Transparent property

SketchImage.Type property

SketchImage.Update method

SketchImage.Visible property

SketchImage.Width property

SketchImageProxy interface

ContainingOccurrence

NativeObject

SketchImageProxy.ContainingOccurrence property

SketchImageProxy.NativeObject property

SketchImages

Sketch interface

SketchImages interface

Add

Application

Count

Item

Type

SketchImages.Add method

SketchImages.Application property

SketchImages.Count property

SketchImages.Item method

SketchImages.Type property

SketchLine interface

Centerline

EndSketchPoint

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

OverrideColor

SetCustomLineType

StartSketchPoint

SketchLine.Centerline property

SketchLine.EndSketchPoint property

SketchLine.Geometry property

SketchLine.GetCustomLineType method

SketchLine.Length property

SketchLine.LineDefinitionSpace property

SketchLine.LineScale property

SketchLine.LineType property

SketchLine.LineWeight property

SketchLine.OverrideColor property

SketchLine.SetCustomLineType method

SketchLine.StartSketchPoint property

SketchLine3D interface

EndSketchPoint

Geometry

Length

StartSketchPoint

SketchLine3D.EndSketchPoint property

SketchLine3D.Geometry property

SketchLine3D.Length property

SketchLine3D.StartSketchPoint property

SketchLine3DProxy interface

ContainingOccurrence

NativeObject

SketchLine3DProxy.ContainingOccurrence property

SketchLine3DProxy.NativeObject property

SketchLineProxy interface

ContainingOccurrence

NativeObject

SketchLineProxy.ContainingOccurrence property

SketchLineProxy.NativeObject property

SketchLines

Sketch interface

SketchLines interface

AddAsPolygon

AddAsThreePointRectangle

AddAsTwoPointRectangle

AddByTwoPoints

Application

Count

Item

Type

SketchLines.AddAsPolygon method

SketchLines.AddAsThreePointRectangle method

SketchLines.AddAsTwoPointRectangle method

SketchLines.AddByTwoPoints method

SketchLines.Application property

SketchLines.Count property

SketchLines.Item method

SketchLines.Type property

SketchLines3D

Sketch3D interface

SketchLines3D interface

AddByTwoPoints

Application

Count

Item

Type

SketchLines3D.AddByTwoPoints method

SketchLines3D.Application property

SketchLines3D.Count property

SketchLines3D.Item method

SketchLines3D.Type property

SketchOffsetSpline interface

Closed

ConvertToSpline

CurvatureDisplay

EndSketchPoint

Geometry

GetCustomLineType

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

OriginalSpline

OverrideColor

SetCustomLineType

StartSketchPoint

SketchOffsetSpline.Closed property

SketchOffsetSpline.ConvertToSpline method

SketchOffsetSpline.CurvatureDisplay property

SketchOffsetSpline.EndSketchPoint property

SketchOffsetSpline.Geometry property

SketchOffsetSpline.GetCustomLineType method

SketchOffsetSpline.Length property

SketchOffsetSpline.LineDefinitionSpace property

SketchOffsetSpline.LineScale property

SketchOffsetSpline.LineType property

SketchOffsetSpline.LineWeight property

SketchOffsetSpline.OriginalSpline property

SketchOffsetSpline.OverrideColor property

SketchOffsetSpline.SetCustomLineType method

SketchOffsetSpline.StartSketchPoint property

SketchOffsetSplineProxy interface

ContainingOccurrence

NativeObject

SketchOffsetSplineProxy.ContainingOccurrence property

SketchOffsetSplineProxy.NativeObject property

SketchOffsetSplines

Sketch interface

SketchOffsetSplines interface

Application

Count

Item

Type

SketchOffsetSplines.Application property

SketchOffsetSplines.Count property

SketchOffsetSplines.Item method

SketchOffsetSplines.Type property

SketchOnly

SketchEntity interface

SketchOptions interface

Application

AutomaticReferenceEdges

AutoProjectEdges

AutoProjectPartOrigin

ConstraintPriority

ConstraintToolbarScale

DisplayAxes

DisplayCoincidentConstraintsOnCreation

DisplayCoordinateSystemIndicator

DisplayGridLines

DisplayMinorGridLines

EditDimensionWhenCreated

HeadsUpDisplayOptions

OverConstrainedDimensionBehavior

ParallelViewOnSketchCreation

PointAlignment

SnapToGrid

SplineDefaultTension

SplineFitMethod

Type

SketchOptions.Application property

SketchOptions.AutomaticReferenceEdges property

SketchOptions.AutoProjectEdges property

SketchOptions.AutoProjectPartOrigin property

SketchOptions.ConstraintPriority property

SketchOptions.ConstraintToolbarScale property

SketchOptions.DisplayAxes property

SketchOptions.DisplayCoincidentConstraintsOnCreation property

SketchOptions.DisplayCoordinateSystemIndicator property

SketchOptions.DisplayGridLines property

SketchOptions.DisplayMinorGridLines property

SketchOptions.EditDimensionWhenCreated property

SketchOptions.HeadsUpDisplayOptions property

SketchOptions.OverConstrainedDimensionBehavior property

SketchOptions.ParallelViewOnSketchCreation property

SketchOptions.PointAlignment property

SketchOptions.SnapToGrid property

SketchOptions.SplineDefaultTension property

SketchOptions.SplineFitMethod property

SketchOptions.Type property

SketchPoint interface

AttachedEntities

ConnectionPoint

Geometry

HoleCenter

InsertionPoint

Merge

MoveBy

MoveTo

SketchPoint.AttachedEntities property

SketchPoint.ConnectionPoint property

SketchPoint.Geometry property

SketchPoint.HoleCenter property

SketchPoint.InsertionPoint property

SketchPoint.Merge method

SketchPoint.MoveBy method

SketchPoint.MoveTo method

SketchPoint3D interface

AttachedEntities

ConnectTo

Geometry

HoleCenter

MoveBy

MoveTo

SketchPoint3D.AttachedEntities property

SketchPoint3D.ConnectTo method

SketchPoint3D.Geometry property

SketchPoint3D.HoleCenter property

SketchPoint3D.MoveBy method

SketchPoint3D.MoveTo method

SketchPoint3DProxy interface

ContainingOccurrence

NativeObject

SketchPoint3DProxy.ContainingOccurrence property

SketchPoint3DProxy.NativeObject property

SketchPointProxy interface

ContainingOccurrence

NativeObject

SketchPointProxy.ContainingOccurrence property

SketchPointProxy.NativeObject property

SketchPoints

Sketch interface

SketchPoints interface

Add

Application

Count

Item

Type

SketchPoints.Add method

SketchPoints.Application property

SketchPoints.Count property

SketchPoints.Item method

SketchPoints.Type property

SketchPoints3D

Sketch3D interface

SketchPoints3D interface

Add

Application

Count

Item

Type

SketchPoints3D.Add method

SketchPoints3D.Application property

SketchPoints3D.Count property

SketchPoints3D.Item method

SketchPoints3D.Type property

SketchRepresentationEdges

FlatPunchResult interface

SketchSettings

AssemblyDocument interface

DrawingDocument interface

PartDocument interface

SketchSettings interface

Application

DisplayLineWeights

LineWeightType

MinorLinesPerMajorGridLine

Parent

SnapsPerMinorGrid

Type

UpperLimitForFirstRangeOfLineWeights

UpperLimitForSecondRangeOfLineWeights

UpperLimitForThirdRangeOfLineWeights

XSnapSpacing

YSnapSpacing

SketchSettings.Application property

SketchSettings.DisplayLineWeights property

SketchSettings.LineWeightType property

SketchSettings.MinorLinesPerMajorGridLine property

SketchSettings.Parent property

SketchSettings.SnapsPerMinorGrid property

SketchSettings.Type property

SketchSettings.UpperLimitForFirstRangeOfLineWeights property

SketchSettings.UpperLimitForSecondRangeOfLineWeights property

SketchSettings.UpperLimitForThirdRangeOfLineWeights property

SketchSettings.XSnapSpacing property

SketchSettings.YSnapSpacing property

SketchSpline interface

Closed

CurvatureDisplay

EndSketchPoint

FitMethod

FitPoint

FitPointCount

Geometry

GetCustomLineType

GetHandle

GetHandleStatus

InsertFitPoint

Length

LineDefinitionSpace

LineScale

LineType

LineWeight

OverrideColor

SetCustomLineType

SetHandleStatus

StartSketchPoint

Tension

SketchSpline.Closed property

SketchSpline.CurvatureDisplay property

SketchSpline.EndSketchPoint property

SketchSpline.FitMethod property

SketchSpline.FitPoint method

SketchSpline.FitPointCount property

SketchSpline.Geometry property

SketchSpline.GetCustomLineType method

SketchSpline.GetHandle method

SketchSpline.GetHandleStatus method

SketchSpline.InsertFitPoint method

SketchSpline.Length property

SketchSpline.LineDefinitionSpace property

SketchSpline.LineScale property

SketchSpline.LineType property

SketchSpline.LineWeight property

SketchSpline.OverrideColor property

SketchSpline.SetCustomLineType method

SketchSpline.SetHandleStatus method

SketchSpline.StartSketchPoint property

SketchSpline.Tension property

SketchSpline3D interface

Closed

CurvatureDisplay

Disconnect

EndSketchPoint

EndTangentScale

FitMethod

FitPoint

FitPointCount

Geometry

GetHandle

GetHandleStatus

InsertFitPoint

Length

SetHandleStatus

Split

StartSketchPoint

StartTangentScale

Tension

SketchSpline3D.Closed property

SketchSpline3D.CurvatureDisplay property

SketchSpline3D.Disconnect method

SketchSpline3D.EndSketchPoint property

SketchSpline3D.EndTangentScale property

SketchSpline3D.FitMethod property

SketchSpline3D.FitPoint method

SketchSpline3D.FitPointCount property

SketchSpline3D.Geometry property

SketchSpline3D.GetHandle method

SketchSpline3D.GetHandleStatus method

SketchSpline3D.InsertFitPoint method

SketchSpline3D.Length property

SketchSpline3D.SetHandleStatus method

SketchSpline3D.Split method

SketchSpline3D.StartSketchPoint property

SketchSpline3D.StartTangentScale property

SketchSpline3D.Tension property

SketchSpline3DProxy interface

ContainingOccurrence

NativeObject

SketchSpline3DProxy.ContainingOccurrence property

SketchSpline3DProxy.NativeObject property

SketchSplineHandle interface

FitPoint

Spline

Tangent

Weight

SketchSplineHandle.FitPoint property

SketchSplineHandle.Spline property

SketchSplineHandle.Tangent property

SketchSplineHandle.Weight property

SketchSplineHandle3D interface

FitPoint

Spline

Tangent

Weight

SketchSplineHandle3D.FitPoint property

SketchSplineHandle3D.Spline property

SketchSplineHandle3D.Tangent property

SketchSplineHandle3D.Weight property

SketchSplineHandle3DProxy interface

ContainingOccurrence

NativeObject

SketchSplineHandle3DProxy.ContainingOccurrence property

SketchSplineHandle3DProxy.NativeObject property

SketchSplineHandleProxy interface

ContainingOccurrence

NativeObject

SketchSplineHandleProxy.ContainingOccurrence property

SketchSplineHandleProxy.NativeObject property

SketchSplineProxy interface

ContainingOccurrence

NativeObject

SketchSplineProxy.ContainingOccurrence property

SketchSplineProxy.NativeObject property

SketchSplines

Sketch interface

SketchSplines interface

Add

Application

Count

Item

Type

SketchSplines.Add method

SketchSplines.Application property

SketchSplines.Count property

SketchSplines.Item method

SketchSplines.Type property

SketchSplines3D

Sketch3D interface

SketchSplines3D interface

Add

Application

Count

Item

Type

SketchSplines3D.Add method

SketchSplines3D.Application property

SketchSplines3D.Count property

SketchSplines3D.Item method

SketchSplines3D.Type property

SketchTextLayer

ObjectDefaultsStyle interface

SketchTextStyle

ObjectDefaultsStyle interface

SketchToModelSpace

PlanarSketch interface

SketchToModelTransform

PlanarSketch interface

SketchToSheetSpace

DrawingSketch interface

SkipAllUnresolvedFiles

PresentationOptions interface

SkipAllUnresolvedFilesInAssembly

FileOpenOptions interface

SkipAllUnresolvedFilesInDrawing

FileOpenOptions interface

SkipAllUnresolvedFilesInPart

FileOpenOptions interface

SliceAllParts

SectionDrawingView interface

SliceGraphics

GraphicsNode interface

SlideoutControls

RibbonPanel interface

SlideOutKeyTip

RibbonPanel interface

SmoothConstraint interface

EntityOne

EntityTwo

SmoothConstraint.EntityOne property

SmoothConstraint.EntityTwo property

SmoothConstraint3D interface

EntityOne

EntityTwo

SmoothConstraint3D.EntityOne property

SmoothConstraint3D.EntityTwo property

SmoothConstraint3DProxy interface

ContainingOccurrence

NativeObject

SmoothConstraint3DProxy.ContainingOccurrence property

SmoothConstraint3DProxy.NativeObject property

SmoothConstraintProxy interface

ContainingOccurrence

NativeObject

SmoothConstraintProxy.ContainingOccurrence property

SmoothConstraintProxy.NativeObject property

SmoothRadiusTransition

FilletFeature interface

Snap3DAngle

ModelingSettings interface

Snap3DDistance

ModelingSettings interface

SnapFitFeature interface

SnapFitFeatureProxy interface

ContainingOccurrence

NativeObject

SnapFitFeatureProxy.ContainingOccurrence property

SnapFitFeatureProxy.NativeObject property

SnapFitFeatures

PartFeatures interface

SnapFitFeatures interface

Application

Count

Item

Type

SnapFitFeatures.Application property

SnapFitFeatures.Count property

SnapFitFeatures.Item method

SnapFitFeatures.Type property

SnapsPerMinorGrid

SketchSettings interface

SnapToGrid

SketchOptions interface

SoftwareVersion

ApprenticeServer interface

SoftwareVersion interface

BetaVersion

BuildIdentifier

DisplayName

DisplayVersion

Is64BitVersion

IsEducationVersion

Major

Minor

NotProduction

ProductEdition

ProductName

ServicePack

Type

SoftwareVersion.BetaVersion property

SoftwareVersion.BuildIdentifier property

SoftwareVersion.DisplayName property

SoftwareVersion.DisplayVersion property

SoftwareVersion.Is64BitVersion property

SoftwareVersion.IsEducationVersion property

SoftwareVersion.Major property

SoftwareVersion.Minor property

SoftwareVersion.NotProduction property

SoftwareVersion.ProductEdition property

SoftwareVersion.ProductName property

SoftwareVersion.ServicePack property

SoftwareVersion.Type property

SoftwareVersionCreated

ApprenticeServerDocument interface

Document interface

SoftwareVersionSaved

ApprenticeServerDocument interface

Document interface

FileManager interface

SolidBodies

DerivedPartComponent interface

SolidBodyNamePrefix

ModelingSettings interface

SolidLinesForHiddenEdges

DisplayOptions interface

DisplaySettings interface

Solids

DerivedPartDefinition interface

SolutionType

AngleConstraint interface

Solve

Sketch interface

Sketch3D interface

Sort

BOMView interface

CustomTable interface

PartsList interface

RevisionTable interface

SourceBreakOperation

BreakOperation interface

SouthControl

RadialMarkingMenu interface

SoutheastControl

RadialMarkingMenu interface

SouthwestControl

RadialMarkingMenu interface

Spacing

DimensionStyle interface

SpecificHeat

Material interface

Sphere interface

CenterPoint

Evaluator

GetSphereData

PutSphereData

Radius

Sphere.CenterPoint property

Sphere.Evaluator property

Sphere.GetSphereData method

Sphere.PutSphereData method

Sphere.Radius property

SpiralCoilExtent interface

Pitch

Revolution

SpiralCoilExtent.Pitch property

SpiralCoilExtent.Revolution property

Spline

OffsetSplineDimConstraint interface

SketchSplineHandle interface

SketchSplineHandle3D interface

SplineFitPointConstraint interface

SplineFitPointsConstraint3D interface

SplineDefaultTension

SketchOptions interface

SplineFactor

UnfoldMethod interface

SplineFitMethod

SketchOptions interface

SplineFitPointConstraint interface

Point

Spline

SplineFitPointConstraint.Point property

SplineFitPointConstraint.Spline property

SplineFitPointConstraintProxy interface

ContainingOccurrence

NativeObject

SplineFitPointConstraintProxy.ContainingOccurrence property

SplineFitPointConstraintProxy.NativeObject property

SplineFitPointsConstraint3D interface

Points

Spline

SplineFitPointsConstraint3D.Points property

SplineFitPointsConstraint3D.Spline property

SplineFitPointsConstraint3DProxy interface

ContainingOccurrence

NativeObject

SplineFitPointsConstraint3DProxy.ContainingOccurrence property

SplineFitPointsConstraint3DProxy.NativeObject property

Split

SketchSpline3D interface

SplitBody

SplitFeatures interface

SplitFaces

SplitFeatures interface

SplitFeature interface

FaceSplitSplitAll

RemovePositiveSide

SetToSplitBody

SetToSplitFaces

SetToTrimSolid

SplitTool

SplitToolType

SplitType

SplitFeature.FaceSplitSplitAll property

SplitFeature.RemovePositiveSide property

SplitFeature.SetToSplitBody method

SplitFeature.SetToSplitFaces method

SplitFeature.SetToTrimSolid method

SplitFeature.SplitTool property

SplitFeature.SplitToolType property

SplitFeature.SplitType property

SplitFeatureProxy interface

ContainingOccurrence

NativeObject

SplitFeatureProxy.ContainingOccurrence property

SplitFeatureProxy.NativeObject property

SplitFeatures

PartFeatures interface

SplitFeatures interface

Application

Count

Item

SplitBody

SplitFaces

TrimSolid

Type

SplitFeatures.Application property

SplitFeatures.Count property

SplitFeatures.Item method

SplitFeatures.SplitBody method

SplitFeatures.SplitFaces method

SplitFeatures.TrimSolid method

SplitFeatures.Type property

SplitTool

SplitFeature interface

SplitToolType

SplitFeature interface

SplitType

SplitFeature interface

SpotFaceDepth

HoleFeature interface

SpotFaceDiameter

HoleFeature interface

SpotLightCutoffAngle

Light interface

SpotLightFalloff

Light interface

SpotLightInnerAngle

Light interface

StackedTextPosition

DrawingNote interface

DrawingViewLabel interface

HoleTableCell interface

HoleTag interface

RevisionTableCell interface

TextBox interface

Standard

ContentFamily interface

StandardIcon

ControlDefinition interface

Environment interface

MiniToolbarControl interface

MiniToolbarListItem interface

StandardOrganization

ContentFamily interface

StandardPartsSectionBehavior

DrawingOptions interface

DrawingView interface

StandardReference

SurfaceTextureStyle interface

StandardRevision

ContentFamily interface

StandardStyles

DrawingStylesManager interface

StandardThreadInfo interface

_PitchDesignation

Class

MajorDiameterMax

MajorDiameterMin

MinorDiameterMax

MinorDiameterMin

NominalSize

Pitch

PitchDiameterMax

PitchDiameterMin

TapDrillDiameter

StandardThreadInfo._PitchDesignation method

StandardThreadInfo.Class property

StandardThreadInfo.MajorDiameterMax property

StandardThreadInfo.MajorDiameterMin property

StandardThreadInfo.MinorDiameterMax property

StandardThreadInfo.MinorDiameterMin property

StandardThreadInfo.NominalSize property

StandardThreadInfo.Pitch property

StandardThreadInfo.PitchDiameterMax property

StandardThreadInfo.PitchDiameterMin property

StandardThreadInfo.TapDrillDiameter property

Start

InteractionEventsObject interface

StartAngle

Arc2d interface

Arc3d interface

DraftAnalysis interface

EllipticalArc interface

EllipticalArc2d interface

SketchArc interface

SketchArc3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

StartAVIRecording

DriveConstraintSettingsObject interface

StartCell

ParameterTable interface

StartCommand

CommandManager interface

StartDrag

DragContext interface

StartEdge

ThreadFeature interface

StartExecutable

CommandManager interface

StartFace

LoftFeature interface

StartFaces

ExtrudeFeature interface

RevolveFeature interface

SweepFeature interface

StartFlatAngle

CoilFeature interface

StartMessageSection

ErrorManager interface

StartOrEndPointConstraint

CoincidentConstraint interface

StartPoint

Arc2d interface

Arc3d interface

BreakOperation interface

Centerline interface

DrawingCurve interface

DrawingCurveSegment interface

EllipticalArc interface

EllipticalArc2d interface

LineSegment interface

LineSegment2d interface

StartRadius

FilletVariableRadiusEdgeSet interface

StartSketchPoint

ProfileEntity interface

ProfileEntity3D interface

SketchArc interface

SketchArc3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

SketchFixedSpline interface

SketchFixedSpline3D interface

SketchLine interface

SketchLine3D interface

SketchOffsetSpline interface

SketchSpline interface

SketchSpline3D interface

StartTangentScale

SketchSpline3D interface

StartTransaction

TransactionManager interface

StartTransactionForDocumentOpen

TransactionManager interface

StartTransitionAngle

CoilFeature interface

StartupActionType

GeneralOptions interface

StartUpEnabled

ApplicationAddIn interface

StartupHelpFocusTopic

GeneralOptions interface

StartupNewFileTemplateName

GeneralOptions interface

StartupProjectFileName

GeneralOptions interface

StartValue

DriveConstraintSettingsObject interface

StartVertex

Edge interface

EdgeDefinition interface

StartWMVRecording

DriveConstraintSettingsObject interface

State

Transaction interface

StateIconToolTipText

BrowserNodeDefinition interface

Static

AutoCADBlock interface

BalloonValueSet interface

Cell interface

DrawingBOMCell interface

PartsListCell interface

PartsListCell interface

SketchedSymbol interface

StationaryFace

RefoldFeature interface

UnfoldFeature interface

Status

Sheet interface

StatusBarText

Application interface

InteractionEventsObject interface

StepForward

DriveConstraintSettingsObject interface

StepReverse

DriveConstraintSettingsObject interface

Stop

InteractionEventsObject interface

StopActiveCommand

CommandManager interface

StopRecording

DriveConstraintSettingsObject interface

StopVertex

Edge interface

Stream

DataMedium interface

StretchBalloonToText

BalloonStyle interface

String

DataMedium interface

StringToKey

ReferenceKeyManager interface

StructuredViewDelimiter

BOM interface

StructuredViewEnabled

BOM interface

StructuredViewFirstLevelOnly

BOM interface

StructuredViewMinimumDigits

BOM interface

StudioCamera coclass

StudioCameras

IInventorStudio interface

StudioCameras coclass

StudioLightingStyle coclass

StudioLightingStyles

IInventorStudio interface

StudioLightingStyles coclass

StudioSceneStyle coclass

StudioSceneStyles

IInventorStudio interface

StudioSceneStyles coclass

Style

Balloon interface

BaselineDimensionSet interface

Centerline interface

Centermark interface

ChainDimensionSet interface

CustomTable interface

FeatureControlFrame interface

GeneralDimension interface

HoleTable interface

OrdinateDimension interface

OrdinateDimensionSet interface

PartsList interface

RevisionTable interface

SurfaceTextureSymbol interface

TextBox interface

Style interface

Application

Comments

ConvertToLocal

Copy

Delete

GetReferenceKey

InternalName

InUse

Name

Parent

SaveToGlobal

StyleLocation

StyleType

Type

UpdateFromGlobal

UpToDate

Style.Application property

Style.Comments property

Style.ConvertToLocal method

Style.Copy method

Style.Delete method

Style.GetReferenceKey method

Style.InternalName property

Style.InUse property

Style.Name property

Style.Parent property

Style.SaveToGlobal method

Style.StyleLocation property

Style.StyleType property

Style.Type property

Style.UpdateFromGlobal method

Style.UpToDate property

StyleEvents coclass

StyleEventsObject interface

Application

Parent

Type

StyleEventsObject.Application property

StyleEventsObject.Parent property

StyleEventsObject.Type property

StyleEventsSink interface

OnActivateStyle

OnDelete

OnNewStyle

OnStyleChange

StyleEventsSink.OnActivateStyle method

StyleEventsSink.OnDelete method

StyleEventsSink.OnNewStyle method

StyleEventsSink.OnStyleChange method

StyleLocation

LightingStyle interface

Material interface

RenderStyle interface

Style interface

Styles

DrawingStylesManager interface

Styles interface

Application

Count

Item

Type

Styles.Application property

Styles.Count property

Styles.Item method

Styles.Type property

StylesLibraryAccess

DesignProject interface

StylesManager

DrawingDocument interface

StylesManager interface

Application

GetStyleNameFromKey

Materials

Parent

Type

StylesManager.Application property

StylesManager.GetStyleNameFromKey method

StylesManager.Materials property

StylesManager.Parent property

StylesManager.Type property

StyleType

Style interface

SubmitPrint

ApprenticePrintManager interface

PrintManager interface

SubOccurrences

ComponentOccurrence interface

DerivedAssemblyOccurrence interface

SubstituteDocumentDescriptor

LevelOfDetailRepresentation interface

SubstituteOccurrence

LevelOfDetailRepresentation interface

SubstitutePartStatus

ApprenticeServerDocument interface

PartDocument interface

SubtractVector

Vector interface

Vector2d interface

SubType

Document interface

Suffix

DimensionStyle interface

SupportsImportInto

TranslatorAddIn interface

SupportsOpen

TranslatorAddIn interface

SupportsOpenInto

TranslatorAddIn interface

SupportsSaveCopyAs

TranslatorAddIn interface

SupportsSaveCopyAsFrom

TranslatorAddIn interface

Suppress

ComponentOccurrence interface

SuppressAll

DerivedAssemblyComponent interface

Suppressed

AssemblyConstraint interface

BIMConnector interface

ComponentOccurrence interface

DrawingView interface

FeaturePatternElement interface

iMateDefinition interface

iMateResult interface

OccurrencePatternElement interface

PartFeature interface

SuppressedIcon

ClientNodeResource interface

SuppressFeatures

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

SuppressLinkToFile

DerivedAssemblyComponent interface

DerivedPartComponent interface

SuppressResolutionWarnings

FileDialog interface

Surface

SculptSurface interface

SurfaceBodies

ComponentDefinition interface

ComponentOccurrence interface

DerivedPartComponent interface

PartFeature interface

WorkSurface interface

SurfaceBodies interface

Count

Item

Type

SurfaceBodies.Count property

SurfaceBodies.Item method

SurfaceBodies.Type property

SurfaceBody

Face interface

FaceShell interface

PartFeature interface

SurfaceBody interface

AffectedByFeatures

AlternateBody

Application

AttributeSets

BindTransientKeyToObject

CalculateFacets

CalculateFacetsAndTextureMap

CalculateStrokes

ComponentDefinition

ConcaveEdges

ConvexEdges

CreatedByFeature

DataIO

Delete

Edges

Exported

Faces

FaceShells

FindUsingRay

GeometryForm

GetASMAttributes

GetExistingFacets

GetExistingFacetsAndTextureMap

GetExistingFacetTolerances

GetExistingStrokes

GetExistingStrokeTolerances

GetReferenceKey

GetRenderStyle

IsEntityValid

IsPointInside

IsSolid

IsTransient

LocateUsingPoint

Name

Parent

RangeBox

SetRenderStyle

Type

Vertices

Visible

Volume

Wires

SurfaceBody.AffectedByFeatures property

SurfaceBody.AlternateBody method

SurfaceBody.Application property

SurfaceBody.AttributeSets property

SurfaceBody.BindTransientKeyToObject method

SurfaceBody.CalculateFacets method

SurfaceBody.CalculateFacetsAndTextureMap method

SurfaceBody.CalculateStrokes method

SurfaceBody.ComponentDefinition property

SurfaceBody.ConcaveEdges property

SurfaceBody.ConvexEdges property

SurfaceBody.CreatedByFeature property

SurfaceBody.DataIO property

SurfaceBody.Delete method

SurfaceBody.Edges property

SurfaceBody.Exported property

SurfaceBody.Faces property

SurfaceBody.FaceShells property

SurfaceBody.FindUsingRay method

SurfaceBody.GeometryForm property

SurfaceBody.GetASMAttributes method

SurfaceBody.GetExistingFacets method

SurfaceBody.GetExistingFacetsAndTextureMap method

SurfaceBody.GetExistingFacetTolerances method

SurfaceBody.GetExistingStrokes method

SurfaceBody.GetExistingStrokeTolerances method

SurfaceBody.GetReferenceKey method

SurfaceBody.GetRenderStyle method

SurfaceBody.IsEntityValid method

SurfaceBody.IsPointInside method

SurfaceBody.IsSolid property

SurfaceBody.IsTransient property

SurfaceBody.LocateUsingPoint method

SurfaceBody.Name property

SurfaceBody.Parent property

SurfaceBody.RangeBox property

SurfaceBody.SetRenderStyle method

SurfaceBody.Type property

SurfaceBody.Vertices property

SurfaceBody.Visible property

SurfaceBody.Volume method

SurfaceBody.Wires property

SurfaceBodyDefinition interface

Application

CreateTransientSurfaceBody

EdgeDefinitions

LumpDefinitions

Type

VertexDefinitions

SurfaceBodyDefinition.Application property

SurfaceBodyDefinition.CreateTransientSurfaceBody method

SurfaceBodyDefinition.EdgeDefinitions property

SurfaceBodyDefinition.LumpDefinitions property

SurfaceBodyDefinition.Type property

SurfaceBodyDefinition.VertexDefinitions property

SurfaceBodyNamePrefix

ModelingSettings interface

SurfaceBodyProxy interface

ContainingOccurrence

NativeObject

SurfaceBodyProxy.ContainingOccurrence property

SurfaceBodyProxy.NativeObject property

SurfaceEntity

NormalToSurfaceWorkAxisDef interface

SurfaceEvaluator interface

Area

Continuity

GetCurvatures

GetFirstDerivatives

GetNormal

GetParamAnomaly

GetParamAtPoint

GetPointAtParam

GetSecondDerivatives

GetTangents

GetThirdDerivatives

IsParamOnFace

ParamRangeRect

RangeBox

SurfaceEvaluator.Area property

SurfaceEvaluator.Continuity property

SurfaceEvaluator.GetCurvatures method

SurfaceEvaluator.GetFirstDerivatives method

SurfaceEvaluator.GetNormal method

SurfaceEvaluator.GetParamAnomaly method

SurfaceEvaluator.GetParamAtPoint method

SurfaceEvaluator.GetPointAtParam method

SurfaceEvaluator.GetSecondDerivatives method

SurfaceEvaluator.GetTangents method

SurfaceEvaluator.GetThirdDerivatives method

SurfaceEvaluator.IsParamOnFace method

SurfaceEvaluator.ParamRangeRect property

SurfaceEvaluator.RangeBox property

SurfaceGeometry

FaceDefinition interface

SurfaceGeometryForm_ClosedUVLoops enumeration member

SurfaceGeometryForm_Not_ClosedUVLoops enumeration member

SurfaceGeometryForm_Not_NURBS enumeration member

SurfaceGeometryForm_NURBS enumeration member

SurfaceGeometryForm_ProceduralToNURBS enumeration member

SurfaceGraphics interface

Body

BurnThrough

Color

DepthPriority

DisplayedEdges

DisplayedFaces

DisplaySilhouettes

GetCustomLineType

GetTransformBehavior

LineDefinitionSpace

LineScale

LineType

LineWeight

SetCustomLineType

SetTransformBehavior

SurfaceGraphics.Body property

SurfaceGraphics.BurnThrough property

SurfaceGraphics.Color property

SurfaceGraphics.DepthPriority property

SurfaceGraphics.DisplayedEdges property

SurfaceGraphics.DisplayedFaces property

SurfaceGraphics.DisplaySilhouettes property

SurfaceGraphics.GetCustomLineType method

SurfaceGraphics.GetTransformBehavior method

SurfaceGraphics.LineDefinitionSpace property

SurfaceGraphics.LineScale property

SurfaceGraphics.LineType property

SurfaceGraphics.LineWeight property

SurfaceGraphics.SetCustomLineType method

SurfaceGraphics.SetTransformBehavior method

SurfaceGraphicsEdge interface

Application

Color

Edge

GetCustomLineType

Index

LineDefinitionSpace

LineScale

LineType

LineWeight

Parent

SetCustomLineType

Type

SurfaceGraphicsEdge.Application property

SurfaceGraphicsEdge.Color property

SurfaceGraphicsEdge.Edge property

SurfaceGraphicsEdge.GetCustomLineType method

SurfaceGraphicsEdge.Index property

SurfaceGraphicsEdge.LineDefinitionSpace property

SurfaceGraphicsEdge.LineScale property

SurfaceGraphicsEdge.LineType property

SurfaceGraphicsEdge.LineWeight property

SurfaceGraphicsEdge.Parent property

SurfaceGraphicsEdge.SetCustomLineType method

SurfaceGraphicsEdge.Type property

SurfaceGraphicsEdgeList interface

Add

Application

Clear

Count

Item

Remove

Type

SurfaceGraphicsEdgeList.Add method

SurfaceGraphicsEdgeList.Application property

SurfaceGraphicsEdgeList.Clear method

SurfaceGraphicsEdgeList.Count property

SurfaceGraphicsEdgeList.Item method

SurfaceGraphicsEdgeList.Remove method

SurfaceGraphicsEdgeList.Type property

SurfaceGraphicsFace interface

Application

Color

Face

Index

Parent

RenderStyle

Type

SurfaceGraphicsFace.Application property

SurfaceGraphicsFace.Color property

SurfaceGraphicsFace.Face property

SurfaceGraphicsFace.Index property

SurfaceGraphicsFace.Parent property

SurfaceGraphicsFace.RenderStyle property

SurfaceGraphicsFace.Type property

SurfaceGraphicsFaceList interface

Add

Application

Clear

Count

Item

Remove

Type

SurfaceGraphicsFaceList.Add method

SurfaceGraphicsFaceList.Application property

SurfaceGraphicsFaceList.Clear method

SurfaceGraphicsFaceList.Count property

SurfaceGraphicsFaceList.Item method

SurfaceGraphicsFaceList.Remove method

SurfaceGraphicsFaceList.Type property

Surfaces

DerivedPartDefinition interface

KnitFeature interface

SculptFeature interface

SurfacesOpaque

CircularPatternFeature interface

MirrorFeature interface

RectangularPatternFeature interface

SurfaceSurfaceIntersection

TransientGeometry interface

SurfacesVisible

CircularPatternFeature interface

MirrorFeature interface

RectangularPatternFeature interface

SurfaceTextureLayer

ObjectDefaultsStyle interface

SurfaceTextureStyle

ObjectDefaultsStyle interface

SurfaceTextureStyle interface

AvailableLaySymbols

LeaderStyle

MachiningProhibitedSymbolSizeSmall

StandardReference

TextStyle

SurfaceTextureStyle.AvailableLaySymbols property

SurfaceTextureStyle.LeaderStyle property

SurfaceTextureStyle.MachiningProhibitedSymbolSizeSmall property

SurfaceTextureStyle.StandardReference property

SurfaceTextureStyle.TextStyle property

SurfaceTextureStyles

DrawingStylesManager interface

SurfaceTextureStylesEnumerator interface

Application

Count

Item

Type

SurfaceTextureStylesEnumerator.Application property

SurfaceTextureStylesEnumerator.Count property

SurfaceTextureStylesEnumerator.Item method

SurfaceTextureStylesEnumerator.Type property

SurfaceTextureSymbol interface

AdditionalProductionMethod

AdditionalRoughness

AdditionalSamplingLength

AllAroundSymbol

Application

AttributeSets

Delete

ForceTail

GetReferenceKey

LayDirection

Layer

Leader

MachiningAllowance

Majority

MaximumRoughness

MinimumRoughness

Parent

Position

ProductionMethod

SamplingLength

Style

SurfaceTextureType

SurfaceWaviness

Type

SurfaceTextureSymbol.AdditionalProductionMethod property

SurfaceTextureSymbol.AdditionalRoughness property

SurfaceTextureSymbol.AdditionalSamplingLength property

SurfaceTextureSymbol.AllAroundSymbol property

SurfaceTextureSymbol.Application property

SurfaceTextureSymbol.AttributeSets property

SurfaceTextureSymbol.Delete method

SurfaceTextureSymbol.ForceTail property

SurfaceTextureSymbol.GetReferenceKey method

SurfaceTextureSymbol.LayDirection property

SurfaceTextureSymbol.Layer property

SurfaceTextureSymbol.Leader property

SurfaceTextureSymbol.MachiningAllowance property

SurfaceTextureSymbol.Majority property

SurfaceTextureSymbol.MaximumRoughness property

SurfaceTextureSymbol.MinimumRoughness property

SurfaceTextureSymbol.Parent property

SurfaceTextureSymbol.Position property

SurfaceTextureSymbol.ProductionMethod property

SurfaceTextureSymbol.SamplingLength property

SurfaceTextureSymbol.Style property

SurfaceTextureSymbol.SurfaceTextureType property

SurfaceTextureSymbol.SurfaceWaviness property

SurfaceTextureSymbol.Type property

SurfaceTextureSymbols

Sheet interface

SurfaceTextureSymbols interface

Add

Application

Count

Item

Type

SurfaceTextureSymbols.Add method

SurfaceTextureSymbols.Application property

SurfaceTextureSymbols.Count property

SurfaceTextureSymbols.Item method

SurfaceTextureSymbols.Type property

SurfaceTextureType

SurfaceTextureSymbol interface

SurfaceType

Face interface

SurfaceWaviness

SurfaceTextureSymbol interface

SweepAngle

Arc2d interface

Arc3d interface

EllipticalArc interface

EllipticalArc2d interface

SketchArc interface

SketchArc3D interface

SketchEllipticalArc interface

SketchEllipticalArc3D interface

SweepDefinition interface

Application

Parent

Type

SweepDefinition.Application property

SweepDefinition.Parent property

SweepDefinition.Type property

SweepFeature interface

AddParticipant

Definition

DefinitionType

EndFaces

Operation

Path

Profile

SetUsingPath

SetUsingPathAndGuideRail

SetUsingPathAndGuideSurface

SetUsingPathAndSectionTwists

SideFaces

StartFaces

TaperAngle

SweepFeature.AddParticipant method

SweepFeature.Definition property

SweepFeature.DefinitionType property

SweepFeature.EndFaces property

SweepFeature.Operation property

SweepFeature.Path property

SweepFeature.Profile property

SweepFeature.SetUsingPath method

SweepFeature.SetUsingPathAndGuideRail method

SweepFeature.SetUsingPathAndGuideSurface method

SweepFeature.SetUsingPathAndSectionTwists method

SweepFeature.SideFaces property

SweepFeature.StartFaces property

SweepFeature.TaperAngle method

SweepFeatureProxy interface

ContainingOccurrence

NativeObject

SweepFeatureProxy.ContainingOccurrence property

SweepFeatureProxy.NativeObject property

SweepFeatures

Features interface

FlatPatternFeatures interface

PartFeatures interface

SweepFeatures interface

Add

AddUsingPath

AddUsingPathAndGuideRail

AddUsingPathAndGuideSurface

AddUsingPathAndSectionTwists

Application

Count

CreatePath

GetProfileOrientationAtParam

GetTruePath

Item

Type

SweepFeatures.Add method

SweepFeatures.AddUsingPath method

SweepFeatures.AddUsingPathAndGuideRail method

SweepFeatures.AddUsingPathAndGuideSurface method

SweepFeatures.AddUsingPathAndSectionTwists method

SweepFeatures.Application property

SweepFeatures.Count property

SweepFeatures.CreatePath method

SweepFeatures.GetProfileOrientationAtParam method

SweepFeatures.GetTruePath method

SweepFeatures.Item method

SweepFeatures.Type property

Symbol Reference

SymbolAttachPoint

Weld interface

SymbolBreakPoint

Weld interface

SymbolClipping

SketchedSymbol interface

SymmetryConstraint interface

EntityOne

EntityTwo

SymmetryLine

SymmetryConstraint.EntityOne property

SymmetryConstraint.EntityTwo property

SymmetryConstraint.SymmetryLine property

SymmetryConstraintProxy interface

ContainingOccurrence

NativeObject

SymmetryConstraintProxy.ContainingOccurrence property

SymmetryConstraintProxy.NativeObject property

SymmetryLine

SymmetryConstraint interface

SystemType

BIMDuctConnectorDefinition interface

BIMElectricalConnectorDefinition interface

BIMPipeConnectorDefinition interface

T

TableColumns

ContentFamily interface

iAssemblyFactory interface

iPartFactory interface

TableDirection

CustomTable interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

TableFormat interface

Application

InsideLineColor

InsideLineWeight

OutsideLineColor

OutsideLineWeight

TextStyle

Type

TableFormat.Application property

TableFormat.InsideLineColor property

TableFormat.InsideLineWeight property

TableFormat.OutsideLineColor property

TableFormat.OutsideLineWeight property

TableFormat.TextStyle property

TableFormat.Type property

TableLayer

ObjectDefaultsStyle interface

TableParameter interface

ConvertToUserParameter

TableParameter.ConvertToUserParameter method

TableParameters

ParameterTable interface

TableParameters interface

Count

Item

Type

TableParameters.Count property

TableParameters.Item method

TableParameters.Type property

TableRows

ContentFamily interface

iAssemblyFactory interface

iPartFactory interface

TableSource

CustomTable interface

TableStyle

ObjectDefaultsStyle interface

TableStyle interface

AddColumn

ColumnHeaderTextStyle

ColumnTitleHorizontalJustification

ColumnValueHorizontalJustification

ColumnWidth

DataTextStyle

HeadingGap

HeadingPlacement

InsideLineColor

InsideLineWeight

OutsideLineColor

OutsideLineWeight

RemoveAllColumns

RowGap

RowLineSpacing

ShowTitle

TableDirection

Title

TitleTextStyle

TableStyle.AddColumn method

TableStyle.ColumnHeaderTextStyle property

TableStyle.ColumnTitleHorizontalJustification property

TableStyle.ColumnValueHorizontalJustification property

TableStyle.ColumnWidth property

TableStyle.DataTextStyle property

TableStyle.HeadingGap property

TableStyle.HeadingPlacement property

TableStyle.InsideLineColor property

TableStyle.InsideLineWeight property

TableStyle.OutsideLineColor property

TableStyle.OutsideLineWeight property

TableStyle.RemoveAllColumns method

TableStyle.RowGap property

TableStyle.RowLineSpacing property

TableStyle.ShowTitle property

TableStyle.TableDirection property

TableStyle.Title property

TableStyle.TitleTextStyle property

TableStyles

DrawingStylesManager interface

TableStylesEnumerator interface

_NewEnum

Application

Count

Item

Type

TableStylesEnumerator._NewEnum property

TableStylesEnumerator.Application property

TableStylesEnumerator.Count property

TableStylesEnumerator.Item method

TableStylesEnumerator.Type property

Tangent

SketchSplineHandle interface

SketchSplineHandle3D interface

TangentConstraint interface

ConstraintLimits

InsideTangency

Offset

TangentConstraint.ConstraintLimits property

TangentConstraint.InsideTangency property

TangentConstraint.Offset property

TangentConstraint3D interface

EntityOne

EntityTwo

FlipDirection

TangentConstraint3D.EntityOne property

TangentConstraint3D.EntityTwo property

TangentConstraint3D.FlipDirection method

TangentConstraint3DProxy interface

ContainingOccurrence

NativeObject

TangentConstraint3DProxy.ContainingOccurrence property

TangentConstraint3DProxy.NativeObject property

TangentConstraintProxy interface

ContainingOccurrence

NativeObject

TangentConstraintProxy.ContainingOccurrence property

TangentConstraintProxy.NativeObject property

TangentDistanceDimConstraint interface

EntityOne

EntityTwo

LinearDiameter

ProximityPointOne

ProximityPointTwo

TangentDistanceDimConstraint.EntityOne property

TangentDistanceDimConstraint.EntityTwo property

TangentDistanceDimConstraint.LinearDiameter property

TangentDistanceDimConstraint.ProximityPointOne property

TangentDistanceDimConstraint.ProximityPointTwo property

TangentDistanceDimConstraintProxy interface

ContainingOccurrence

NativeObject

TangentDistanceDimConstraintProxy.ContainingOccurrence property

TangentDistanceDimConstraintProxy.NativeObject property

TangentiallyConnectedEdges

Edge interface

TangentiallyConnectedFaces

Face interface

TangentiMateDefinition interface

ConstraintLimits

Entity

InsideTangency

Offset

TangentiMateDefinition.ConstraintLimits property

TangentiMateDefinition.Entity property

TangentiMateDefinition.InsideTangency property

TangentiMateDefinition.Offset property

TangentiMateDefinitionProxy interface

ContainingOccurrence

IsConsumed

NativeObject

TangentiMateDefinitionProxy.ContainingOccurrence property

TangentiMateDefinitionProxy.IsConsumed property

TangentiMateDefinitionProxy.NativeObject property

TangentSketchConstraint interface

EntityOne

EntityTwo

TangentSketchConstraint.EntityOne property

TangentSketchConstraint.EntityTwo property

TangentSketchConstraintProxy interface

ContainingOccurrence

NativeObject

TangentSketchConstraintProxy.ContainingOccurrence property

TangentSketchConstraintProxy.NativeObject property

TapDrill

HoleThreadNote interface

TapDrillDiameter

StandardThreadInfo interface

Taper

EmbossFeature interface

TaperAngle

BossSet interface

ExtrudeDefinition interface

PathAndSectionTwistsSweepDef interface

PathSweepDef interface

PitchAndHeightCoilExtent interface

PitchAndRevolutionCoilExtent interface

RevolutionAndHeightCoilExtent interface

SweepFeature interface

TaperAngleTwo

ExtrudeDefinition interface

TaperedThreadInfo interface

BasicMinorDiameter

EffectiveDiameter

EffectiveLength

EngagementDiameter

EngagementLength

ExternalPitchDiameter

NominalExternalDiameter

NominalExternalLength

OutsidePipeDiameter

OverallExternalLength

Pitch

ThreadHeight

ThreadsPerInch

VanishThread

WrenchMakeupDiameter

WrenchMakeupLength

TaperedThreadInfo.BasicMinorDiameter property

TaperedThreadInfo.EffectiveDiameter property

TaperedThreadInfo.EffectiveLength property

TaperedThreadInfo.EngagementDiameter property

TaperedThreadInfo.EngagementLength property

TaperedThreadInfo.ExternalPitchDiameter property

TaperedThreadInfo.NominalExternalDiameter property

TaperedThreadInfo.NominalExternalLength property

TaperedThreadInfo.OutsidePipeDiameter property

TaperedThreadInfo.OverallExternalLength property

TaperedThreadInfo.Pitch property

TaperedThreadInfo.ThreadHeight property

TaperedThreadInfo.ThreadsPerInch property

TaperedThreadInfo.VanishThread property

TaperedThreadInfo.WrenchMakeupDiameter property

TaperedThreadInfo.WrenchMakeupLength property

TapInfo

HoleFeature interface

Tapped

HoleFeature interface

TappedHoleDiameter

ModelingSettings interface

Target

Camera interface

TargetDocument

InteractionEventsObject interface

TargetOccurrence

NonParametricBaseFeatureDefinition interface

TeamWebFullFilename

FileOptions interface

TeardropHemDefinition interface

Angle

Parent

Radius

TeardropHemDefinition.Angle property

TeardropHemDefinition.Parent property

TeardropHemDefinition.Radius property

TemplateDir

GeneralPreferences interface

TemplatesPath

DesignProject interface

FileOptions interface

TemplatesPathOverridden

DesignProject interface

Tension

SketchSpline interface

SketchSpline3D interface

Terminator

ToNextExtent interface

TertiarySelectColor

ColorScheme interface

Text

ComboBoxDefinitionObject interface

DimensionText interface

DrawingDimension interface

DrawingNote interface

DrawingViewLabel interface

HoleTableCell interface

HoleTag interface

MiniToolbarListItem interface

RevisionTableCell interface

TextBox interface

TextGraphics interface

TextAppearance

GeneralOptions interface

TextBackgroundColor

NotebookOptions interface

TextBox

ProfilePath interface

TextBoxConstraint interface

TextBox interface

Application

AttributeSets

BoundaryGeometry

Color

ContainingSketchBlock

Delete

Fitted

FittedTextHeight

FittedTextWidth

FormattedText

GetColor

GetReferenceKey

Height

HorizontalJustification

Layer

LineSpacing

LineSpacingType

Origin

OriginSketchPoint

Parent

RangeBox

Rotation

SetColor

ShowBoundaries

SingleLineText

SketchBlockPath

StackedTextPosition

Style

Text

Type

VerticalJustification

Width

WidthScale

TextBox.Application property

TextBox.AttributeSets property

TextBox.BoundaryGeometry property

TextBox.Color property

TextBox.ContainingSketchBlock property

TextBox.Delete method

TextBox.Fitted property

TextBox.FittedTextHeight property

TextBox.FittedTextWidth property

TextBox.FormattedText property

TextBox.GetColor method

TextBox.GetReferenceKey method

TextBox.Height property

TextBox.HorizontalJustification property

TextBox.Layer property

TextBox.LineSpacing property

TextBox.LineSpacingType property

TextBox.Origin property

TextBox.OriginSketchPoint property

TextBox.Parent property

TextBox.RangeBox property

TextBox.Rotation property

TextBox.SetColor method

TextBox.ShowBoundaries property

TextBox.SingleLineText property

TextBox.SketchBlockPath property

TextBox.StackedTextPosition property

TextBox.Style property

TextBox.Text property

TextBox.Type property

TextBox.VerticalJustification property

TextBox.Width property

TextBox.WidthScale property

TextBoxConstraint interface

TextBox

TextBoxConstraint.TextBox property

TextBoxConstraintProxy interface

ContainingOccurrence

NativeObject

TextBoxConstraintProxy.ContainingOccurrence property

TextBoxConstraintProxy.NativeObject property

TextBoxes

Sketch interface

TextBoxes interface

AddByRectangle

AddFitted

Application

Count

Item

Type

TextBoxes.AddByRectangle method

TextBoxes.AddFitted method

TextBoxes.Application property

TextBoxes.Count property

TextBoxes.Item method

TextBoxes.Type property

TextBoxPath

ProfilePath interface

TextBoxProxy interface

ContainingOccurrence

NativeObject

TextBoxProxy.ContainingOccurrence property

TextBoxProxy.NativeObject property

TextGraphics interface

Anchor

Bold

BurnThrough

DepthPriority

Font

FontSize

GetTextColor

GetTransformBehavior

HorizontalAlignment

Italic

PutTextColor

Scalable

SetTransformBehavior

Text

VerticalAlignment

TextGraphics.Anchor property

TextGraphics.Bold property

TextGraphics.BurnThrough property

TextGraphics.DepthPriority property

TextGraphics.Font property

TextGraphics.FontSize property

TextGraphics.GetTextColor method

TextGraphics.GetTransformBehavior method

TextGraphics.HorizontalAlignment property

TextGraphics.Italic property

TextGraphics.PutTextColor method

TextGraphics.Scalable method

TextGraphics.SetTransformBehavior method

TextGraphics.Text property

TextGraphics.VerticalAlignment property

TextPoint

DimensionConstraint interface

DimensionConstraint3D interface

FeatureDimension interface

TextSize

GeneralOptions interface

TextStyle

BalloonStyle interface

DimensionStyle interface

DrawingViewLabel interface

FeatureControlFrameStyle interface

GeneralNote interface

SurfaceTextureStyle interface

TableFormat interface

TextStyle interface

Bold

Color

Font

FontSize

GetColor

HorizontalJustification

Italic

LineSpacing

LineSpacingType

Rotation

Underline

VerticalJustification

WidthScale

TextStyle.Bold property

TextStyle.Color property

TextStyle.Font property

TextStyle.FontSize property

TextStyle.GetColor method

TextStyle.HorizontalJustification property

TextStyle.Italic property

TextStyle.LineSpacing property

TextStyle.LineSpacingType property

TextStyle.Rotation property

TextStyle.Underline property

TextStyle.VerticalJustification property

TextStyle.WidthScale property

TextStyles

DrawingStylesManager interface

TextStyles interface

Application

Count

Item

Type

TextStyles.Application property

TextStyles.Count property

TextStyles.Item method

TextStyles.Type property

TextStylesEnumerator interface

Application

Count

Item

Type

TextStylesEnumerator.Application property

TextStylesEnumerator.Count property

TextStylesEnumerator.Item method

TextStylesEnumerator.Type property

TextureCoordinateIndexSet

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

TextureCoordinateSet

TriangleFanGraphics interface

TriangleGraphics interface

TriangleStripGraphics interface

TextureCoordinateSet interface

Application

Count

GetCoordinates

Item

Parent

Type

TextureCoordinateSet.Application property

TextureCoordinateSet.Count property

TextureCoordinateSet.GetCoordinates method

TextureCoordinateSet.Item method

TextureCoordinateSet.Parent property

TextureCoordinateSet.Type property

TextureDimension

GraphicsTextureCoordinateSet interface

TextureFilename

RenderStyle interface

TextureMap interface

Application

GetTextureCoordinateSet

Image

MaskColor

Parent

Transformation

Type

UseMask

TextureMap.Application property

TextureMap.GetTextureCoordinateSet method

TextureMap.Image property

TextureMap.MaskColor property

TextureMap.Parent property

TextureMap.Transformation property

TextureMap.Type property

TextureMap.UseMask property

TextureMaps

Face interface

TextureMaps interface

Application

Count

Item

Type

TextureMaps.Application property

TextureMaps.Count property

TextureMaps.Item method

TextureMaps.Type property

TextureRotation

RenderStyle interface

TextureScale

RenderStyle interface

ThermalConductivity

Material interface

ThickenFeature interface

ApproximationOptimized

ApproximationTolerance

ApproximationType

AutomaticBlending

AutomaticFaceChain

CreateVerticalSurfaces

Direction

Distance

InputFaces

Operation

ThickenFeature.ApproximationOptimized property

ThickenFeature.ApproximationTolerance property

ThickenFeature.ApproximationType property

ThickenFeature.AutomaticBlending property

ThickenFeature.AutomaticFaceChain property

ThickenFeature.CreateVerticalSurfaces property

ThickenFeature.Direction property

ThickenFeature.Distance property

ThickenFeature.InputFaces property

ThickenFeature.Operation property

ThickenFeatureProxy interface

ContainingOccurrence

NativeObject

ThickenFeatureProxy.ContainingOccurrence property

ThickenFeatureProxy.NativeObject property

ThickenFeatures

PartFeatures interface

ThickenFeatures interface

Add

Application

Count

Item

Type

ThickenFeatures.Add method

ThickenFeatures.Application property

ThickenFeatures.Count property

ThickenFeatures.Item method

ThickenFeatures.Type property

Thickness

RibDefinition interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

ShellDefinition interface

ShellThicknessFaceSet interface

ThicknessDirection

RibDefinition interface

ThisApplication

VbaApplication interface

ThisServer

VbaApplication interface

ThreadBasePoints

ThreadInfo interface

ThreadDepth

HoleTapInfo interface

ThreadFeature interface

ThreadDesignation

ThreadInfo interface

ThreadDirection

ThreadInfo interface

ThreadedFace

ThreadFeature interface

ThreadFeature interface

DirectionReversed

DisplayInModel

FullDepth

SetThreadDepth

StartEdge

ThreadDepth

ThreadedFace

ThreadInfo

ThreadInfoType

ThreadOffset

ThreadFeature.DirectionReversed property

ThreadFeature.DisplayInModel property

ThreadFeature.FullDepth property

ThreadFeature.SetThreadDepth method

ThreadFeature.StartEdge property

ThreadFeature.ThreadDepth property

ThreadFeature.ThreadedFace property

ThreadFeature.ThreadInfo property

ThreadFeature.ThreadInfoType property

ThreadFeature.ThreadOffset property

ThreadFeatureProxy interface

ContainingOccurrence

NativeObject

ThreadFeatureProxy.ContainingOccurrence property

ThreadFeatureProxy.NativeObject property

ThreadFeatures

PartFeatures interface

ThreadFeatures interface

Add

Application

Count

CreateStandardThreadInfo

CreateTaperedThreadInfo

Item

Type

ThreadFeatures.Add method

ThreadFeatures.Application property

ThreadFeatures.Count property

ThreadFeatures.CreateStandardThreadInfo method

ThreadFeatures.CreateTaperedThreadInfo method

ThreadFeatures.Item method

ThreadFeatures.Type property

ThreadHeight

TaperedThreadInfo interface

ThreadInfo

ThreadFeature interface

ThreadInfo interface

_NominalSizeDescription

Application

CustomThreadDesignation

FullThreadDepth

Internal

Metric

RightHanded

ThreadBasePoints

ThreadDesignation

ThreadDirection

ThreadType

ThreadTypeIdentifier

Type

ThreadInfo._NominalSizeDescription method

ThreadInfo.Application property

ThreadInfo.CustomThreadDesignation property

ThreadInfo.FullThreadDepth property

ThreadInfo.Internal property

ThreadInfo.Metric property

ThreadInfo.RightHanded property

ThreadInfo.ThreadBasePoints property

ThreadInfo.ThreadDesignation property

ThreadInfo.ThreadDirection property

ThreadInfo.ThreadType property

ThreadInfo.ThreadTypeIdentifier property

ThreadInfo.Type property

ThreadInfos

Face interface

ThreadInfoType

ThreadFeature interface

ThreadNoteLayer

ObjectDefaultsStyle interface

ThreadNoteStyle

ObjectDefaultsStyle interface

ThreadOffset

ThreadFeature interface

ThreadsPerInch

TaperedThreadInfo interface

ThreadTableQuery

GeneralOptions interface

ThreadTableQuery interface

Application

CreateThreadInfo

GetAvailableClasses

GetAvailableDesignations

GetAvailableThreadSizes

GetAvailableThreadTypes

GetThreadTypeIdentifier

GetThreadTypeName

Type

ThreadTableQuery.Application property

ThreadTableQuery.CreateThreadInfo method

ThreadTableQuery.GetAvailableClasses method

ThreadTableQuery.GetAvailableDesignations method

ThreadTableQuery.GetAvailableThreadSizes method

ThreadTableQuery.GetAvailableThreadTypes method

ThreadTableQuery.GetThreadTypeIdentifier method

ThreadTableQuery.GetThreadTypeName method

ThreadTableQuery.Type property

ThreadType

ThreadInfo interface

ThreadTypeIdentifier

ThreadInfo interface

ThreeBendCornerReliefShape

SheetMetalStyle interface

ThreeBendCornerReliefSize

SheetMetalStyle interface

ThreePlanesWorkPointDef interface

Application

GetData

Parent

Plane1

Plane2

Plane3

Type

ThreePlanesWorkPointDef.Application property

ThreePlanesWorkPointDef.GetData method

ThreePlanesWorkPointDef.Parent property

ThreePlanesWorkPointDef.Plane1 property

ThreePlanesWorkPointDef.Plane2 property

ThreePlanesWorkPointDef.Plane3 property

ThreePlanesWorkPointDef.Type property

ThreePointAngleDimConstraint interface

PointOne

PointThree

PointTwo

ThreePointAngleDimConstraint.PointOne property

ThreePointAngleDimConstraint.PointThree property

ThreePointAngleDimConstraint.PointTwo property

ThreePointAngleDimConstraintProxy interface

ContainingOccurrence

NativeObject

ThreePointAngleDimConstraintProxy.ContainingOccurrence property

ThreePointAngleDimConstraintProxy.NativeObject property

ThreePointsWorkPlaneDef interface

Application

GetData

Parent

Point1

Point2

Point3

Type

ThreePointsWorkPlaneDef.Application property

ThreePointsWorkPlaneDef.GetData method

ThreePointsWorkPlaneDef.Parent property

ThreePointsWorkPlaneDef.Point1 property

ThreePointsWorkPlaneDef.Point2 property

ThreePointsWorkPlaneDef.Point3 property

ThreePointsWorkPlaneDef.Type property

ThroughAllExtent interface

Direction

ThroughAllExtent.Direction property

Thumbnail

ApprenticeServerDocument interface

BIMComponentDescription interface

ContentFamily interface

Document interface

ThumbnailSaveOption

Document interface

TilingEnabled

DrawingPrintManager interface

TimeUnits

UnitsOfMeasure interface

Title

Column interface

CustomTable interface

DockableWindow interface

DrawingBOMColumn interface

HoleTable interface

HoleTableColumn interface

HoleTableStyle interface

PartsList interface

PartsListColumn interface

PartsListStyle interface

ProgressiveToolTip interface

RevisionTable interface

RevisionTableColumn interface

RevisionTableStyle interface

TableStyle interface

TitleBlock

Sheet interface

TitleBlock interface

Application

Definition

Delete

GetResultText

Location

Name

Parent

Position

RangeBox

SetPromptResultText

Transformation

Type

TitleBlock.Application property

TitleBlock.Definition property

TitleBlock.Delete method

TitleBlock.GetResultText method

TitleBlock.Location property

TitleBlock.Name property

TitleBlock.Parent property

TitleBlock.Position property

TitleBlock.RangeBox property

TitleBlock.SetPromptResultText method

TitleBlock.Transformation property

TitleBlock.Type property

TitleBlockAlignment

DrawingOptions interface

TitleBlockDefinition interface

Application

AttributeSets

CopyTo

Delete

Edit

ExitEdit

GetReferenceKey

IsReferenced

Name

Parent

Sketch

Type

TitleBlockDefinition.Application property

TitleBlockDefinition.AttributeSets property

TitleBlockDefinition.CopyTo method

TitleBlockDefinition.Delete method

TitleBlockDefinition.Edit method

TitleBlockDefinition.ExitEdit method

TitleBlockDefinition.GetReferenceKey method

TitleBlockDefinition.IsReferenced property

TitleBlockDefinition.Name property

TitleBlockDefinition.Parent property

TitleBlockDefinition.Sketch property

TitleBlockDefinition.Type property

TitleBlockDefinitions

DrawingDocument interface

TitleBlockDefinitions interface

Add

Application

Count

Item

Type

TitleBlockDefinitions.Add method

TitleBlockDefinitions.Application property

TitleBlockDefinitions.Count property

TitleBlockDefinitions.Item method

TitleBlockDefinitions.Type property

TitleBlockGeometryLayer

ObjectDefaultsStyle interface

TitleBlockLocation

SheetFormat interface

TitleBlockTextLayer

ObjectDefaultsStyle interface

TitleBlockTextStyle

ObjectDefaultsStyle interface

TitleHorizontalJustification

Column interface

PartsListColumn interface

RevisionTableColumn interface

TitleTextStyle

CustomTable interface

HoleTable interface

HoleTableStyle interface

PartsList interface

PartsListStyle interface

RevisionTable interface

RevisionTableStyle interface

TableStyle interface

ToEntity

FromToWidthExtent interface

ToExtent interface

ToHeightExtent interface

ToExtent interface

Direction

ExtendToFace

MinimumSolution

ToEntity

ToExtent.Direction property

ToExtent.ExtendToFace property

ToExtent.MinimumSolution property

ToExtent.ToEntity property

ToFace

FromToExtent interface

ToHeightExtent interface

Offset

ToEntity

ToHeightExtent.Offset property

ToHeightExtent.ToEntity property

Tolerance

CoreCavityDefinition interface

DimensionStyle interface

DrawingDimension interface

Edge interface

FeatureControlFrameRow interface

MiniToolbarValueEditorObject interface

Parameter interface

Vertex interface

Tolerance interface

HoleTolerance

Lower

Parent

SetToBasic

SetToDefault

SetToDeviation

SetToFits

SetToLimits

SetToMax

SetToMin

SetToReference

SetToSymmetric

ShaftTolerance

ToleranceType

Type

Upper

Tolerance.HoleTolerance property

Tolerance.Lower property

Tolerance.Parent property

Tolerance.SetToBasic method

Tolerance.SetToDefault method

Tolerance.SetToDeviation method

Tolerance.SetToFits method

Tolerance.SetToLimits method

Tolerance.SetToMax method

Tolerance.SetToMin method

Tolerance.SetToReference method

Tolerance.SetToSymmetric method

Tolerance.ShaftTolerance property

Tolerance.ToleranceType property

Tolerance.Type property

Tolerance.Upper property

ToleranceAlternateIncludedZeroDisplay

DimensionStyle interface

ToleranceAlternateLeadingZeroDisplay

DimensionStyle interface

ToleranceAlternateTrailingZeroDisplay

DimensionStyle interface

ToleranceAlternateUnitPrecision

DimensionStyle interface

ToleranceAngularPrecision

AngularGeneralDimension interface

DimensionStyle interface

ToleranceFontSize

DimensionStyle interface

ToleranceIncludedZeroDisplay

DimensionStyle interface

ToleranceLeadingZeroDisplay

DimensionStyle interface

ToleranceLinearPrecision

DimensionStyle interface

TolerancePrecision

DrawingDimension interface

ToleranceTextStyle

DimensionStyle interface

ToleranceTrailingZeroDisplay

DimensionStyle interface

ToleranceType

Tolerance interface

ToleranceValue

GeneralOptions interface

ToNextExtent interface

Direction

Terminator

ToNextExtent.Direction property

ToNextExtent.Terminator property

ToolBodies

CombineFeature interface

TooltipDelay

GeneralOptions interface

ToolTipText

BrowserNodeDefinition interface

ControlDefinition interface

MiniToolbarControl interface

MiniToolbarListItem interface

Top

Application interface

DockableWindow interface

DrawingView interface

View interface

TopFace

FlatPattern interface

TopFaceColor

EmbossFeature interface

TopMargin

DefaultBorder interface

TopNode

BrowserPaneObject interface

TopScreenColor

ColorScheme interface

TopScreenColor2D

ColorScheme interface

Torus interface

AxisVector

CenterPoint

Evaluator

GetTorusData

MajorRadius

MinorRadius

PutTorusData

Torus.AxisVector property

Torus.CenterPoint property

Torus.Evaluator property

Torus.GetTorusData method

Torus.MajorRadius property

Torus.MinorRadius property

Torus.PutTorusData method

TorusCenterPointWorkPointDef interface

Application

Face

Parent

Type

TorusCenterPointWorkPointDef.Application property

TorusCenterPointWorkPointDef.Face property

TorusCenterPointWorkPointDef.Parent property

TorusCenterPointWorkPointDef.Type property

TorusMidPlaneWorkPlaneDef interface

Application

Face

Parent

Type

TorusMidPlaneWorkPlaneDef.Application property

TorusMidPlaneWorkPlaneDef.Face property

TorusMidPlaneWorkPlaneDef.Parent property

TorusMidPlaneWorkPlaneDef.Type property

TotalQuantity

BOMRow interface

TotalQuantityOverridden

BOMRow interface

Trail interface

Application

Count

Item

Parent

SetVisibility

Type

Trail.Application property

Trail.Count property

Trail.Item method

Trail.Parent property

Trail.SetVisibility method

Trail.Type property

TrailingZeroDisplay

DimensionStyle interface

FeatureControlFrameStyle interface

Trails

PresentationExplodedView interface

TrailSegment interface

Application

Geometry

Linear

Parent

Type

Visible

TrailSegment.Application property

TrailSegment.Geometry property

TrailSegment.Linear property

TrailSegment.Parent property

TrailSegment.Type property

TrailSegment.Visible property

TrailsEnumerator interface

Application

Count

Item

Type

TrailsEnumerator.Application property

TrailsEnumerator.Count property

TrailsEnumerator.Item method

TrailsEnumerator.Type property

Transact

ChangeProcessorObject interface

Transaction interface

Abort

Application

CheckPoints

ChildTransactions

DisplayName

Document

End

HasParentTransaction

Id

IdentifyForDocumentOpen

MergeWithPrevious

Parent

ParentTransaction

State

Type

Transaction.Abort method

Transaction.Application property

Transaction.CheckPoints property

Transaction.ChildTransactions property

Transaction.DisplayName property

Transaction.Document property

Transaction.End method

Transaction.HasParentTransaction property

Transaction.Id property

Transaction.IdentifyForDocumentOpen method

Transaction.MergeWithPrevious property

Transaction.Parent property

Transaction.ParentTransaction property

Transaction.State property

Transaction.Type property

TransactionEvents

TransactionManager interface

TransactionEvents coclass

TransactionEventsObject interface

Application

Parent

Type

TransactionEventsObject.Application property

TransactionEventsObject.Parent property

TransactionEventsObject.Type property

TransactionEventsSink interface

OnAbort

OnCommit

OnDelete

OnRedo

OnUndo

TransactionEventsSink.OnAbort method

TransactionEventsSink.OnCommit method

TransactionEventsSink.OnDelete method

TransactionEventsSink.OnRedo method

TransactionEventsSink.OnUndo method

TransactionManager interface

Application

ClearAllTransactions

CommittedTransactions

CurrentTransaction

GoToCheckPoint

Parent

RedoTransaction

SetCheckPoint

StartTransaction

StartTransactionForDocumentOpen

TransactionEvents

Type

UndoneTransactions

UndoTransaction

TransactionManager.Application property

TransactionManager.ClearAllTransactions method

TransactionManager.CommittedTransactions property

TransactionManager.CurrentTransaction property

TransactionManager.GoToCheckPoint method

TransactionManager.Parent property

TransactionManager.RedoTransaction method

TransactionManager.SetCheckPoint method

TransactionManager.StartTransaction method

TransactionManager.StartTransactionForDocumentOpen method

TransactionManager.TransactionEvents property

TransactionManager.Type property

TransactionManager.UndoneTransactions property

TransactionManager.UndoTransaction method

TransactionsEnumerator interface

Count

Item

Type

TransactionsEnumerator.Count property

TransactionsEnumerator.Item method

TransactionsEnumerator.Type property

Transform

FeaturePatternElement interface

TransientBRep interface

Transformation

AutoCADBlock interface

ComponentOccurrence interface

FreeMoveDefinition interface

GraphicsNode interface

MoveFeature interface

SketchBlock interface

SketchedSymbol interface

TextureMap interface

TitleBlock interface

UserCoordinateSystem interface

UserCoordinateSystemDefinition interface

TransformBy

Matrix interface

Matrix2d interface

Point interface

Point2d interface

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

TransformOccurrences

AssemblyComponentDefinition interface

Transient

AttributeSet interface

TransientBRep interface

Copy

CreateIntersectionWithPlane

CreateSilhouetteCurve

CreateSolidBlock

CreateSolidCylinderCone

CreateSolidSphere

CreateSolidTorus

CreateSurfaceBodyDefinition

DeleteFaces

DoBoolean

ReadFromFile

Transform

TransientBRep.Copy method

TransientBRep.CreateIntersectionWithPlane method

TransientBRep.CreateSilhouetteCurve method

TransientBRep.CreateSolidBlock method

TransientBRep.CreateSolidCylinderCone method

TransientBRep.CreateSolidSphere method

TransientBRep.CreateSolidTorus method

TransientBRep.CreateSurfaceBodyDefinition method

TransientBRep.DeleteFaces method

TransientBRep.DoBoolean method

TransientBRep.ReadFromFile method

TransientBRep.Transform method

TransientGeometry

ApprenticeServer interface

TransientGeometry interface

CreateArc2d

CreateArc2dByThreePoints

CreateArc3d

CreateArc3dByThreePoints

CreateBox

CreateBox2d

CreateBSplineCurve

CreateBSplineCurve2d

CreateBSplineCurve2dDefinition

CreateBSplineCurveDefinition

CreateBSplineSurface

CreateCircle

CreateCircle2d

CreateCircle2dByThreePoints

CreateCircleByThreePoints

CreateCone

CreateCylinder

CreateEllipseFull

CreateEllipseFull2d

CreateEllipticalArc

CreateEllipticalArc2d

CreateEllipticalCone

CreateEllipticalCylinder

CreateFittedBSplineCurve

CreateFittedBSplineCurve2d

CreateLine

CreateLine2d

CreateLineSegment

CreateLineSegment2d

CreateMatrix

CreateMatrix2d

CreatePlane

CreatePlaneByThreePoints

CreatePoint

CreatePoint2d

CreatePolyline2d

CreatePolyline2dFromCurve

CreatePolyline3d

CreatePolyline3dFromCurve

CreateSphere

CreateTorus

CreateUnitVector

CreateUnitVector2d

CreateVector

CreateVector2d

CurveCurveIntersection

CurveSurfaceIntersection

PointTolerance

SurfaceSurfaceIntersection

Type

TransientGeometry.CreateArc2d method

TransientGeometry.CreateArc2dByThreePoints method

TransientGeometry.CreateArc3d method

TransientGeometry.CreateArc3dByThreePoints method

TransientGeometry.CreateBox method

TransientGeometry.CreateBox2d method

TransientGeometry.CreateBSplineCurve method

TransientGeometry.CreateBSplineCurve2d method

TransientGeometry.CreateBSplineCurve2dDefinition method

TransientGeometry.CreateBSplineCurveDefinition method

TransientGeometry.CreateBSplineSurface method

TransientGeometry.CreateCircle method

TransientGeometry.CreateCircle2d method

TransientGeometry.CreateCircle2dByThreePoints method

TransientGeometry.CreateCircleByThreePoints method

TransientGeometry.CreateCone method

TransientGeometry.CreateCylinder method

TransientGeometry.CreateEllipseFull method

TransientGeometry.CreateEllipseFull2d method

TransientGeometry.CreateEllipticalArc method

TransientGeometry.CreateEllipticalArc2d method

TransientGeometry.CreateEllipticalCone method

TransientGeometry.CreateEllipticalCylinder method

TransientGeometry.CreateFittedBSplineCurve method

TransientGeometry.CreateFittedBSplineCurve2d method

TransientGeometry.CreateLine method

TransientGeometry.CreateLine2d method

TransientGeometry.CreateLineSegment method

TransientGeometry.CreateLineSegment2d method

TransientGeometry.CreateMatrix method

TransientGeometry.CreateMatrix2d method

TransientGeometry.CreatePlane method

TransientGeometry.CreatePlaneByThreePoints method

TransientGeometry.CreatePoint method

TransientGeometry.CreatePoint2d method

TransientGeometry.CreatePolyline2d method

TransientGeometry.CreatePolyline2dFromCurve method

TransientGeometry.CreatePolyline3d method

TransientGeometry.CreatePolyline3dFromCurve method

TransientGeometry.CreateSphere method

TransientGeometry.CreateTorus method

TransientGeometry.CreateUnitVector method

TransientGeometry.CreateUnitVector2d method

TransientGeometry.CreateVector method

TransientGeometry.CreateVector2d method

TransientGeometry.CurveCurveIntersection method

TransientGeometry.CurveSurfaceIntersection method

TransientGeometry.PointTolerance property

TransientGeometry.SurfaceSurfaceIntersection method

TransientGeometry.Type property

TransientKey

Edge interface

EdgeLoop interface

EdgeUse interface

Face interface

FaceShell interface

Vertex interface

TransientObjects

ApprenticeServer interface

TransientObjects interface

CreateCamera

CreateColor

CreateDataMedium

CreateEdgeCollection

CreateFaceCollection

CreateFileMetadata

CreateNameValueMap

CreateObjectCollection

CreateObjectCollectionByVariant

CreateSignatureString

CreateTranslationContext

TransientObjects.CreateCamera method

TransientObjects.CreateColor method

TransientObjects.CreateDataMedium method

TransientObjects.CreateEdgeCollection method

TransientObjects.CreateFaceCollection method

TransientObjects.CreateFileMetadata method

TransientObjects.CreateNameValueMap method

TransientObjects.CreateObjectCollection method

TransientObjects.CreateObjectCollectionByVariant method

TransientObjects.CreateSignatureString method

TransientObjects.CreateTranslationContext method

TransitionalConstraint interface

TransitionalConstraintProxy interface

ContainingOccurrence

NativeObject

TransitionalConstraintProxy.ContainingOccurrence property

TransitionalConstraintProxy.NativeObject property

TransitionRadius

SheetMetalComponentDefinition interface

TranslateBy

Point interface

Point2d interface

TranslateTranslateConstraint interface

ForwardDirection

Ratio

TranslateTranslateConstraint.ForwardDirection property

TranslateTranslateConstraint.Ratio property

TranslateTranslateConstraintProxy interface

ContainingOccurrence

NativeObject

TranslateTranslateConstraintProxy.ContainingOccurrence property

TranslateTranslateConstraintProxy.NativeObject property

Translation

Matrix interface

Matrix2d interface

TranslationContext interface

OpenIntoExisting

Type

TranslationContext.OpenIntoExisting property

TranslationContext.Type property

TranslatorAddIn interface

DocumentTypesSupported

FileExtensions

FilterText

GetThumbnail

HasOpenOptions

HasSaveCopyAsOptions

Open

SaveCopyAs

ShowOpenOptions

ShowSaveCopyAsOptions

SupportsImportInto

SupportsOpen

SupportsOpenInto

SupportsSaveCopyAs

SupportsSaveCopyAsFrom

TranslatorAvailable

TranslatorAddIn.DocumentTypesSupported method

TranslatorAddIn.FileExtensions property

TranslatorAddIn.FilterText property

TranslatorAddIn.GetThumbnail method

TranslatorAddIn.HasOpenOptions method

TranslatorAddIn.HasSaveCopyAsOptions method

TranslatorAddIn.Open method

TranslatorAddIn.SaveCopyAs method

TranslatorAddIn.ShowOpenOptions method

TranslatorAddIn.ShowSaveCopyAsOptions method

TranslatorAddIn.SupportsImportInto property

TranslatorAddIn.SupportsOpen property

TranslatorAddIn.SupportsOpenInto property

TranslatorAddIn.SupportsSaveCopyAs property

TranslatorAddIn.SupportsSaveCopyAsFrom property

TranslatorAddIn.TranslatorAvailable property

TranslatorAddInServer interface

GetThumbnail

HasOpenOptions

HasSaveCopyAsOptions

Open

SaveCopyAs

ShowOpenOptions

ShowSaveCopyAsOptions

TranslatorAddInServer.GetThumbnail method

TranslatorAddInServer.HasOpenOptions method

TranslatorAddInServer.HasSaveCopyAsOptions method

TranslatorAddInServer.Open method

TranslatorAddInServer.SaveCopyAs method

TranslatorAddInServer.ShowOpenOptions method

TranslatorAddInServer.ShowSaveCopyAsOptions method

TranslatorAvailable

TranslatorAddIn interface

Translucent

WorkSurface interface

Transparent

SketchImage interface

TreeBrowser

BrowserPaneObject interface

TreeViewTopNode

ContentCenter interface

TriadEvents

InteractionEventsObject interface

TriadEvents coclass

TriadEventsObject interface

Application

DegreesOfFreedom

Enabled

GlobalTransform

IsInRedefineMode

MoveTriadOnly

MoveTriadOnlyEnabled

Parent

Repeat

Reposition

Type

TriadEventsObject.Application property

TriadEventsObject.DegreesOfFreedom property

TriadEventsObject.Enabled property

TriadEventsObject.GlobalTransform property

TriadEventsObject.IsInRedefineMode property

TriadEventsObject.MoveTriadOnly property

TriadEventsObject.MoveTriadOnlyEnabled property

TriadEventsObject.Parent property

TriadEventsObject.Repeat property

TriadEventsObject.Reposition method

TriadEventsObject.Type property

TriadEventsSink interface

OnActivate

OnEndMove

OnEndSequence

OnMove

OnMoveTriadOnlyToggle

OnSegmentSelectionChange

OnStartMove

OnStartSequence

OnTerminate

TriadEventsSink.OnActivate method

TriadEventsSink.OnEndMove method

TriadEventsSink.OnEndSequence method

TriadEventsSink.OnMove method

TriadEventsSink.OnMoveTriadOnlyToggle method

TriadEventsSink.OnSegmentSelectionChange method

TriadEventsSink.OnStartMove method

TriadEventsSink.OnStartSequence method

TriadEventsSink.OnTerminate method

TriangleFanGraphics interface

BurnThrough

ColorBinding

ColorIndexSet

ColorMapper

ColorSet

CoordinateIndexSet

CoordinateSet

DepthPriority

GetStripLengths

GetTransformBehavior

NormalBinding

NormalIndexSet

NormalSet

PutStripLengths

SetTransformBehavior

TextureCoordinateIndexSet

TextureCoordinateSet

TriangleFanGraphics.BurnThrough property

TriangleFanGraphics.ColorBinding property

TriangleFanGraphics.ColorIndexSet property

TriangleFanGraphics.ColorMapper property

TriangleFanGraphics.ColorSet property

TriangleFanGraphics.CoordinateIndexSet property

TriangleFanGraphics.CoordinateSet property

TriangleFanGraphics.DepthPriority property

TriangleFanGraphics.GetStripLengths method

TriangleFanGraphics.GetTransformBehavior method

TriangleFanGraphics.NormalBinding property

TriangleFanGraphics.NormalIndexSet property

TriangleFanGraphics.NormalSet property

TriangleFanGraphics.PutStripLengths method

TriangleFanGraphics.SetTransformBehavior method

TriangleFanGraphics.TextureCoordinateIndexSet property

TriangleFanGraphics.TextureCoordinateSet property

TriangleGraphics interface

BurnThrough

ColorBinding

ColorIndexSet

ColorMapper

ColorSet

CoordinateIndexSet

CoordinateSet

DepthPriority

GetTransformBehavior

NormalBinding

NormalIndexSet

NormalSet

SetTransformBehavior

TextureCoordinateIndexSet

TextureCoordinateSet

TriangleGraphics.BurnThrough property

TriangleGraphics.ColorBinding property

TriangleGraphics.ColorIndexSet property

TriangleGraphics.ColorMapper property

TriangleGraphics.ColorSet property

TriangleGraphics.CoordinateIndexSet property

TriangleGraphics.CoordinateSet property

TriangleGraphics.DepthPriority property

TriangleGraphics.GetTransformBehavior method

TriangleGraphics.NormalBinding property

TriangleGraphics.NormalIndexSet property

TriangleGraphics.NormalSet property

TriangleGraphics.SetTransformBehavior method

TriangleGraphics.TextureCoordinateIndexSet property

TriangleGraphics.TextureCoordinateSet property

TriangleStripGraphics interface

BurnThrough

ColorBinding

ColorIndexSet

ColorMapper

ColorSet

CoordinateIndexSet

CoordinateSet

DepthPriority

GetStripLengths

GetTransformBehavior

NormalBinding

NormalIndexSet

NormalSet

PutStripLengths

SetTransformBehavior

TextureCoordinateIndexSet

TextureCoordinateSet

TriangleStripGraphics.BurnThrough property

TriangleStripGraphics.ColorBinding property

TriangleStripGraphics.ColorIndexSet property

TriangleStripGraphics.ColorMapper property

TriangleStripGraphics.ColorSet property

TriangleStripGraphics.CoordinateIndexSet property

TriangleStripGraphics.CoordinateSet property

TriangleStripGraphics.DepthPriority property

TriangleStripGraphics.GetStripLengths method

TriangleStripGraphics.GetTransformBehavior method

TriangleStripGraphics.NormalBinding property

TriangleStripGraphics.NormalIndexSet property

TriangleStripGraphics.NormalSet property

TriangleStripGraphics.PutStripLengths method

TriangleStripGraphics.SetTransformBehavior method

TriangleStripGraphics.TextureCoordinateIndexSet property

TriangleStripGraphics.TextureCoordinateSet property

TrimFeature interface

TrimFeatureProxy interface

ContainingOccurrence

NativeObject

TrimFeatureProxy.ContainingOccurrence property

TrimFeatureProxy.NativeObject property

TrimFeatures

PartFeatures interface

TrimFeatures interface

Application

Count

Item

Type

TrimFeatures.Application property

TrimFeatures.Count property

TrimFeatures.Item method

TrimFeatures.Type property

TrimSolid

SplitFeatures interface

TrueReflection

IRenderManager interface

TryMove

DragContext interface

TwoDistancesChamferDef interface

DistanceOne

DistanceTwo

Face

TwoDistancesChamferDef.DistanceOne property

TwoDistancesChamferDef.DistanceTwo property

TwoDistancesChamferDef.Face property

TwoLineAngleDimConstraint interface

LineOne

LineTwo

TwoLineAngleDimConstraint.LineOne property

TwoLineAngleDimConstraint.LineTwo property

TwoLineAngleDimConstraint3D interface

LineOne

LineTwo

TwoLineAngleDimConstraint3D.LineOne property

TwoLineAngleDimConstraint3D.LineTwo property

TwoLineAngleDimConstraint3DProxy interface

ContainingOccurrence

NativeObject

TwoLineAngleDimConstraint3DProxy.ContainingOccurrence property

TwoLineAngleDimConstraint3DProxy.NativeObject property

TwoLineAngleDimConstraintProxy interface

ContainingOccurrence

NativeObject

TwoLineAngleDimConstraintProxy.ContainingOccurrence property

TwoLineAngleDimConstraintProxy.NativeObject property

TwoLinesWorkPlaneDef interface

Application

GetData

Line1

Line2

Parent

Type

TwoLinesWorkPlaneDef.Application property

TwoLinesWorkPlaneDef.GetData method

TwoLinesWorkPlaneDef.Line1 property

TwoLinesWorkPlaneDef.Line2 property

TwoLinesWorkPlaneDef.Parent property

TwoLinesWorkPlaneDef.Type property

TwoLinesWorkPointDef interface

Application

GetData

Line1

Line2

Parent

Type

TwoLinesWorkPointDef.Application property

TwoLinesWorkPointDef.GetData method

TwoLinesWorkPointDef.Line1 property

TwoLinesWorkPointDef.Line2 property

TwoLinesWorkPointDef.Parent property

TwoLinesWorkPointDef.Type property

TwoPlanesWorkAxisDef interface

Application

GetData

Parent

Plane1

Plane2

Type

TwoPlanesWorkAxisDef.Application property

TwoPlanesWorkAxisDef.GetData method

TwoPlanesWorkAxisDef.Parent property

TwoPlanesWorkAxisDef.Plane1 property

TwoPlanesWorkAxisDef.Plane2 property

TwoPlanesWorkAxisDef.Type property

TwoPlanesWorkPlaneDef interface

Application

GetData

Parent

Plane1

Plane2

Type

TwoPlanesWorkPlaneDef.Application property

TwoPlanesWorkPlaneDef.GetData method

TwoPlanesWorkPlaneDef.Parent property

TwoPlanesWorkPlaneDef.Plane1 property

TwoPlanesWorkPlaneDef.Plane2 property

TwoPlanesWorkPlaneDef.Type property

TwoPointDistanceDimConstraint interface

Orientation

PointOne

PointTwo

TwoPointDistanceDimConstraint.Orientation property

TwoPointDistanceDimConstraint.PointOne property

TwoPointDistanceDimConstraint.PointTwo property

TwoPointDistanceDimConstraint3D interface

PointOne

PointTwo

TwoPointDistanceDimConstraint3D.PointOne property

TwoPointDistanceDimConstraint3D.PointTwo property

TwoPointDistanceDimConstraint3DProxy interface

ContainingOccurrence

NativeObject

TwoPointDistanceDimConstraint3DProxy.ContainingOccurrence property

TwoPointDistanceDimConstraint3DProxy.NativeObject property

TwoPointDistanceDimConstraintProxy interface

ContainingOccurrence

NativeObject

TwoPointDistanceDimConstraintProxy.ContainingOccurrence property

TwoPointDistanceDimConstraintProxy.NativeObject property

TwoPointsWorkAxisDef interface

Application

GetData

Parent

Point1

Point2

Type

TwoPointsWorkAxisDef.Application property

TwoPointsWorkAxisDef.GetData method

TwoPointsWorkAxisDef.Parent property

TwoPointsWorkAxisDef.Point1 property

TwoPointsWorkAxisDef.Point2 property

TwoPointsWorkAxisDef.Type property

Type

AliasFreeformFeatures interface

AnalysisManager interface

AnalyticEdgeWorkAxisDef interface

ApplicationAddIn interface

ApplicationAddIns interface

ApplicationAddInSite interface

ApplicationEventsObject interface

ApprenticePrintManager interface

ApprenticeServer interface

ApprenticeServerDocument interface

ApprenticeServerDocuments interface

AssemblyComponentDefinitions interface

AssemblyConstraint interface

AssemblyConstraints interface

AssemblyConstraintsEnumerator interface

AssemblyEventsObject interface

AssemblyOptions interface

AssemblyWorkAxisDef interface

AssemblyWorkPlaneDef interface

AssemblyWorkPointDef interface

Attribute interface

AttributeManager interface

AttributesEnumerator interface

AttributeSet interface

AttributeSets interface

AttributeSetsEnumerator interface

AutoCADBlock interface

AutoCADBlockDefinition interface

AutoCADBlockDefinitions interface

AutoCADBlockDefinitionsEnumerator interface

AutoCADBlocks interface

AutomatedCenterlineSettings interface

Balloon interface

Balloons interface

BalloonStylesEnumerator interface

BalloonTipObject interface

BalloonTips interface

BalloonValueSet interface

BalloonValueSets interface

BaselineDimensionSet interface

BaselineDimensionSets interface

Bend interface

BendDefinition interface

BendFeatures interface

BendNotes interface

BendOptions interface

BendPartFeatures interface

BendsEnumerator interface

BIMComponent interface

BIMComponentDescription interface

BIMComponentProperty interface

BIMComponentPropertySet interface

BIMComponentPropertySets interface

BIMConnector interface

BIMConnectorDefinition interface

BIMConnectorLink interface

BIMConnectorLinks interface

BIMConnectors interface

BOM interface

BOMQuantity interface

BOMRow interface

BOMRowsEnumerator interface

BOMView interface

BOMViews interface

Border interface

BorderDefinition interface

BorderDefinitions interface

BossFeatures interface

BossSet interface

BossSets interface

BoundaryPatchDefinition interface

BoundaryPatchFeatures interface

BoundaryPatchLoop interface

BoundaryPatchLoops interface

BreakOperation interface

BreakOperations interface

BreakOutOperation interface

BreakOutOperations interface

BrowserFolder interface

BrowserFoldersEnumerator interface

BrowserNode interface

BrowserNodeDefinition interface

BrowserNodesEnumerator interface

BrowserPaneObject interface

BrowserPanes interface

BSplineCurve2dDefinition interface

BSplineCurveDefinition interface

Camera interface

CameraEventsObject interface

Cell interface

Centerline interface

Centerlines interface

Centermark interface

Centermarks interface

CentermarkStylesEnumerator interface

CentroidWorkPointDef interface

ChainDimensionSet interface

ChainDimensionSets interface

ChamferDefinition interface

ChamferFeatures interface

ChamferNotes interface

ChangeDefinitionObject interface

ChangeDefinitions interface

ChangeManager interface

ChangeProcessorObject interface

CheckPoint interface

CheckPointsEnumerator interface

CircularPatternFeatures interface

ClientFeatureDefinition interface

ClientFeatureElement interface

ClientFeatureElements interface

ClientFeatures interface

ClientGraphics interface

ClientGraphicsCollection interface

ClientNodeResource interface

ClientNodeResources interface

ClientView interface

ClientViews interface

CoilFeatures interface

Color interface

ColorScheme interface

ColorSchemes interface

Column interface

Columns interface

CombineFeatures interface

CommandBar interface

CommandBarControl interface

CommandBarControls interface

CommandBarList interface

CommandBars interface

CommandCategories interface

CommandCategory interface

CommandControl interface

CommandControls interface

CommandControlsEnumerator interface

CommandManager interface

ComponentDefinition interface

ComponentDefinitions interface

ComponentDefinitionsEnumerator interface

ComponentOccurrence interface

ComponentOccurrencesEnumerator interface

ConstraintLimits interface

ContentCenter interface

ContentCenterOptions interface

ContentFamiliesEnumerator interface

ContentFamily interface

ContentTableCell interface

ContentTableColumn interface

ContentTableColumns interface

ContentTableRow interface

ContentTableRows interface

ContentTreeViewNode interface

ContentTreeViewNodesEnumerator interface

ContourFlangeDefinition interface

ContourFlangeFeatures interface

ContourRollFeatures interface

ControlDefinition interface

ControlDefinitionEventsObject interface

ControlDefinitions interface

CoreCavityDefinition interface

CoreCavityFeatures interface

CornerChamferDefinition interface

CornerChamferFeatures interface

CornerDefinition interface

CornerFeatures interface

CornerOptions interface

CornerRoundDefinition interface

CornerRoundEdgeSet interface

CornerRoundFeatures interface

CosmeticBendFeatures interface

CosmeticWelds interface

CurveAndEntityWorkPointDef interface

CustomParameterGroup interface

CustomParameterGroups interface

CustomPropertyFormat interface

CustomTable interface

CustomTables interface

CutDefinition interface

CutFeatures interface

DecalFeatures interface

DeleteFaceFeatures interface

DerivedAliasComponents interface

DerivedAssemblyComponents interface

DerivedAssemblyDefinition interface

DerivedAssemblyOccurrence interface

DerivedAssemblyOccurrences interface

DerivedParameters interface

DerivedParameterTable interface

DerivedParameterTables interface

DerivedPartComponents interface

DerivedPartDefinition interface

DerivedPartEntities interface

DerivedPartEntity interface

DesignProject interface

DesignProjectManager interface

DesignProjects interface

DesignViewRepresentation interface

DesignViewRepresentations interface

DimensionConstraint interface

DimensionConstraint3D interface

DimensionConstraints interface

DimensionConstraints3D interface

DimensionStylesEnumerator interface

DimensionText interface

DirectionAndDistanceMoveDefinition interface

DisabledCommandList interface

DisplayOptions interface

DisplaySettings interface

DockableWindow interface

DockableWindows interface

DockableWindowsEventsObject interface

Document interface

DocumentDescriptor interface

DocumentDescriptorsEnumerator interface

DocumentEventsObject interface

DocumentInterest interface

DocumentInterests interface

DocumentsEnumerator interface

DraftAnalyses interface

DraftAnalysis interface

DraftingStandard interface

DrawingBOM interface

DrawingBOMCell interface

DrawingBOMColumn interface

DrawingBOMColumns interface

DrawingBOMRow interface

DrawingBOMRows interface

DrawingBOMs interface

DrawingCurve interface

DrawingCurveSegment interface

DrawingCurveSegments interface

DrawingCurvesEnumerator interface

DrawingDimension interface

DrawingDimensions interface

DrawingEventsObject interface

DrawingNote interface

DrawingNotes interface

DrawingOptions interface

DrawingSettings interface

DrawingSketches interface

DrawingStandardStylesEnumerator interface

DrawingStylesManager interface

DrawingView interface

DrawingViewEventsObject interface

DrawingViewLabel interface

DrawingViews interface

DriveConstraintSettingsObject interface

Edge interface

EdgeDefinition interface

EdgeDefinitions interface

EdgeLoop interface

EdgeLoopDefinition interface

EdgeLoopDefinitions interface

EdgeLoops interface

Edges interface

EdgeUse interface

EdgeUseDefinition interface

EdgeUseDefinitions interface

EdgeUses interface

EmbossFeatures interface

EndOfFeatures interface

Environment interface

EnvironmentList interface

EnvironmentManager interface

Environments interface

ErrorManager interface

ExpressionLimits interface

ExpressionList interface

ExtendFeatures interface

ExtrudeDefinition interface

ExtrudeFeatures interface

Face interface

FaceDefinition interface

FaceDefinitions interface

FaceDraftFeatures interface

FaceFeatureDefinition interface

FaceFeatures interface

Faces interface

FaceShell interface

FaceShellDefinition interface

FaceShellDefinitions interface

FaceShells interface

FactoryOptions interface

FeatureControlFrame interface

FeatureControlFrameRow interface

FeatureControlFrameRows interface

FeatureControlFrames interface

FeatureControlFrameStylesEnumerator interface

FeatureDimension interface

FeatureDimensions interface

FeaturePatternElement interface

FeaturePatternElements interface

Features interface

File interface

FileAccessEventsObject interface

FileDescriptor interface

FileDescriptorsEnumerator interface

FileDialogEventsObject interface

FileManager interface

FileManagerEventsObject interface

FileMetadata interface

FileOptions interface

FilesEnumerator interface

FileUIEventsObject interface

FilletConstantRadiusFaceSet interface

FilletDefinition interface

FilletFeatures interface

FilletFullRoundSet interface

FilletRadiusEdgeSet interface

FilletSetbackVertex interface

FixedWorkAxisDef interface

FixedWorkPlaneDef interface

FixedWorkPointDef interface

FlangeDefinition interface

FlangeFeatures interface

FlatBendResult interface

FlatBendResults interface

FlatPatternFeatures interface

FlatPunchResult interface

FlatPunchResults interface

FoldDefinition interface

FoldFeatures interface

FreeMoveDefinition interface

GeneralDimensions interface

GeneralDimensionsEnumerator interface

GeneralNotes interface

GeneralOptions interface

GenericObject interface

GeometricConstraint interface

GeometricConstraint3D interface

GeometricConstraints interface

GeometricConstraints3D interface

GeometryIntent interface

GraphicsColorMapper interface

GraphicsDataSet interface

GraphicsDataSets interface

GraphicsDataSetsCollection interface

GraphicsNode interface

GraphicsPrimitive interface

GrillFeatures interface

GripSnapOptions interface

GroundPlaneSettings interface

HardwareOptions interface

HeadsUpDisplayOptions interface

HelpEventsObject interface

HelpManager interface

HemDefinition interface

HemFeatures interface

HighlightSet interface

HighlightSets interface

HoleFeatures interface

HolePlacementDefinition interface

HoleTable interface

HoleTableCell interface

HoleTableColumn interface

HoleTableColumns interface

HoleTableRow interface

HoleTableRows interface

HoleTables interface

HoleTableStylesEnumerator interface

HoleTag interface

HoleThreadNotes interface

iAssemblyFactory interface

iAssemblyMember interface

iAssemblyTableCell interface

iAssemblyTableColumn interface

iAssemblyTableColumns interface

iAssemblyTableRow interface

iAssemblyTableRows interface

iFeatureDefinition interface

iFeatureInput interface

iFeatureInputs interface

iFeatureOptions interface

iFeatures interface

iFeatureTable interface

iFeatureTableCell interface

iFeatureTableColumn interface

iFeatureTableColumns interface

iFeatureTableRow interface

iFeatureTableRows interface

iFeatureTemplateDescriptor interface

iFeatureTemplateDescriptors interface

iMateDefinition interface

iMateDefinitions interface

iMateDefinitionsEnumerator interface

iMateResult interface

iMateResults interface

iMateResultsEnumerator interface

InteractionEventsObject interface

InteractionGraphics interface

InterferenceResult interface

InterferenceResults interface

InventorVBAArgument interface

InventorVBAArguments interface

InventorVBAComponent interface

InventorVBAComponents interface

InventorVBAMember interface

InventorVBAMembers interface

InventorVBAProject interface

InventorVBAProjects interface

iPartFactory interface

iPartTableCell interface

iPartTableColumn interface

iPartTableColumns interface

iPartTableRow interface

iPartTableRows interface

KeyboardEventsObject interface

KnitFeatures interface

LanguageTools interface

LayersEnumerator interface

LayoutConstraint interface

Leader interface

LeaderNode interface

LeaderNodesEnumerator interface

LeaderNotes interface

LeaderStylesEnumerator interface

LevelOfDetailRepresentation interface

LevelOfDetailRepresentations interface

Light interface

LightingStyle interface

LightingStyles interface

Lights interface

LineAndPlaneWorkAxisDef interface

LineAndPointWorkAxisDef interface

LineAndTangentWorkPlaneDef interface

LinePlaneAndAngleWorkPlaneDef interface

LineWorkAxisDef interface

LipFeatures interface

LoftedFlangeDefinition interface

LoftedFlangeFeatures interface

LoftFeatures interface

LoftRail interface

LoftRails interface

LoftSectionDimension interface

LoftSectionDimensions interface

LumpDefinition interface

LumpDefinitions interface

Machining interface

MapPointCurve interface

MapPointCurves interface

MassProperties interface

Material interface

Materials interface

MaterialsEnumerator interface

MeasureEventsObject interface

MeasureTools interface

MessageSection interface

MidPointWorkPointDef interface

MiniToolbarControl interface

MiniToolbarControls interface

MiniToolbarObject interface

MirrorFeatures interface

ModelingEventsObject interface

ModelingSettings interface

ModelParameters interface

MouseEventsObject interface

MoveFaceDefinition interface

MoveFaceFeatures interface

MoveFeatures interface

NonLinearEdgeWorkPointDef interface

NonParametricBaseFeatures interface

NormalToCurveWorkPlaneDef interface

NormalToSurfaceWorkAxisDef interface

NotebookOptions interface

ObjectDefaultsStylesEnumerator interface

ObjectsEnumerator interface

ObjectsEnumeratorByVariant interface

ObjectVisibility interface

OccurrencePattern interface

OccurrencePatternElement interface

OccurrencePatternElements interface

OccurrencePatterns interface

OrdinateDimensions interface

OrdinateDimensionsEnumerator interface

OrdinateDimensionSet interface

OrdinateDimensionSets interface

OriginIndicator interface

PanelBarObject interface

Parameter interface

Parameters interface

ParametersEnumerator interface

ParameterTable interface

ParameterTables interface

PartComponentDefinitions interface

PartEventsObject interface

PartFeature interface

PartFeatureExtent interface

PartFeatures interface

PartFeaturesEnumerator interface

PartOptions interface

PartsList interface

PartsListCell interface

PartsListColumn interface

PartsListColumns interface

PartsListRow interface

PartsListRows interface

PartsLists interface

PartsListStylesEnumerator interface

Path interface

PathEntity interface

PlanarMoveDefinition interface

PlanarSketches interface

PlaneAndOffsetWorkPlaneDef interface

PlaneAndPointWorkPlaneDef interface

PlaneAndTangentWorkPlaneDef interface

PointAndPlaneWorkAxisDef interface

PointAndTangentWorkPlaneDef interface

PointInference interface

PointInferenceEnumerator interface

PointToPointRipTypeDef interface

PointWorkPointDef interface

PositionalRepresentation interface

PositionalRepresentations interface

Preparations interface

PresentationExplodedView interface

PresentationExplodedViews interface

PresentationOptions interface

PrintManager interface

Profile interface

Profile3D interface

ProfileEntity interface

ProfileEntity3D interface

ProfilePath interface

ProfilePath3D interface

Profiles interface

Profiles3D interface

ProgressBarObject interface

ProgressiveToolTip interface

ProjectedCut interface

ProjectedCuts interface

ProjectPath interface

ProjectPaths interface

Property interface

PropertySet interface

PropertySets interface

PunchNotes interface

PunchToolFeatures interface

RadialMarkingMenu interface

RectangularPatternFeatures interface

ReferenceComponent interface

ReferenceComponents interface

ReferencedOLEFileDescriptor interface

ReferencedOLEFileDescriptors interface

ReferenceFeatures interface

ReferenceFeaturesEnumerator interface

ReferenceKeyEventsObject interface

ReferenceKeyManager interface

ReferenceParameters interface

RefoldFeatures interface

RegionProperties interface

RenderStyle interface

RenderStyles interface

ReplaceFaceFeatures interface

RepresentationEventsObject interface

RepresentationsManager interface

RestFeatures interface

RevisionTable interface

RevisionTableCell interface

RevisionTableColumn interface

RevisionTableColumns interface

RevisionTableRow interface

RevisionTableRows interface

RevisionTables interface

RevisionTableStylesEnumerator interface

RevolvedFaceWorkAxisDef interface

RevolveFeatures interface

Ribbon interface

RibbonPanel interface

RibbonPanels interface

Ribbons interface

RibbonTab interface

RibbonTabs interface

RibDefinition interface

RibFeatures interface

RipDefinition interface

RipFeatures interface

Row interface

Rows interface

RuleFilletFeatures interface

SaveOptions interface

SculptFeatures interface

SculptSurface interface

SelectEventsObject interface

SelectSet interface

ShadedDisplayOptions interface

Sheet interface

SheetFormat interface

SheetFormats interface

SheetMetalStyles interface

Sheets interface

SheetSettings interface

ShellDefinition interface

ShellFeatures interface

ShellThicknessFaceSet interface

SilhouetteCurve interface

SilhouetteCurves interface

SinglePointRipTypeDef interface

Sketch interface

Sketch3D interface

Sketch3DOptions interface

Sketch3DSettings interface

SketchArcs interface

SketchArcs3D interface

SketchBlock interface

SketchBlockDefinitions interface

SketchBlockDefinitionsEnumerator interface

SketchBlocks interface

SketchBlocksEnumerator interface

SketchCircles interface

SketchCircles3D interface

SketchConstraints3DEnumerator interface

SketchConstraintsEnumerator interface

SketchedSymbol interface

SketchedSymbolDefinition interface

SketchedSymbolDefinitions interface

SketchedSymbols interface

SketchEllipses interface

SketchEllipses3D interface

SketchEllipticalArcs interface

SketchEllipticalArcs3D interface

SketchEntities3DEnumerator interface

SketchEntitiesEnumerator interface

SketchEntity interface

SketchEntity3D interface

Sketches3D interface

Sketches3DEnumerator interface

SketchesEnumerator interface

SketchEventsObject interface

SketchFillRegion interface

SketchFillRegions interface

SketchFixedSplines interface

SketchFixedSplines3D interface

SketchImage interface

SketchImages interface

SketchLines interface

SketchLines3D interface

SketchOffsetSplines interface

SketchOptions interface

SketchPoints interface

SketchPoints3D interface

SketchSettings interface

SketchSplines interface

SketchSplines3D interface

SnapFitFeatures interface

SoftwareVersion interface

SplitFeatures interface

Style interface

StyleEventsObject interface

Styles interface

StylesManager interface

SurfaceBodies interface

SurfaceBody interface

SurfaceBodyDefinition interface

SurfaceGraphicsEdge interface

SurfaceGraphicsEdgeList interface

SurfaceGraphicsFace interface

SurfaceGraphicsFaceList interface

SurfaceTextureStylesEnumerator interface

SurfaceTextureSymbol interface

SurfaceTextureSymbols interface

SweepDefinition interface

SweepFeatures interface

TableFormat interface

TableParameters interface

TableStylesEnumerator interface

TextBox interface

TextBoxes interface

TextStyles interface

TextStylesEnumerator interface

TextureCoordinateSet interface

TextureMap interface

TextureMaps interface

ThickenFeatures interface

ThreadFeatures interface

ThreadInfo interface

ThreadTableQuery interface

ThreePlanesWorkPointDef interface

ThreePointsWorkPlaneDef interface

TitleBlock interface

TitleBlockDefinition interface

TitleBlockDefinitions interface

Tolerance interface

TorusCenterPointWorkPointDef interface

TorusMidPlaneWorkPlaneDef interface

Trail interface

TrailSegment interface

TrailsEnumerator interface

Transaction interface

TransactionEventsObject interface

TransactionManager interface

TransactionsEnumerator interface

TransientGeometry interface

TranslationContext interface

TriadEventsObject interface

TrimFeatures interface

TwoLinesWorkPlaneDef interface

TwoLinesWorkPointDef interface

TwoPlanesWorkAxisDef interface

TwoPlanesWorkPlaneDef interface

TwoPointsWorkAxisDef interface

UnfoldFeatures interface

UnfoldMethods interface

UnitsOfMeasure interface

UserCoordinateSystem interface

UserCoordinateSystemDefinition interface

UserCoordinateSystems interface

UserCoordinateSystemSettings interface

UserInputEventsObject interface

UserInterfaceEventsObject interface

UserInterfaceManager interface

UserParameters interface

Vertex interface

VertexDefinition interface

VertexDefinitions interface

Vertices interface

View interface

ViewList interface

ViewsEnumerator interface

Weld interface

WeldBeads interface

Welds interface

Wire interface

WireframeDisplayOptions interface

Wires interface

WorkAxes interface

WorkAxis interface

WorkPlane interface

WorkPlanes interface

WorkPoint interface

WorkPoints interface

WorkSurface interface

WorkSurfaces interface

U

UCSTriads

ObjectVisibility interface

UCSWorkAxes

ObjectVisibility interface

UCSWorkPlanes

ObjectVisibility interface

UCSWorkPoints

ObjectVisibility interface

UltimateTensileStrength

Material interface

Underline

TextStyle interface

UndoFileSize

GeneralOptions interface

UndoneTransactions

TransactionManager interface

UndoPath

FileOptions interface

UndoTransaction

TransactionManager interface

Unfold

SheetMetalComponentDefinition interface

Unfold2

SheetMetalComponentDefinition interface

UnfoldFeature interface

Bends

Edit

InputSketches

ResultSketches

StationaryFace

UnfoldFeature.Bends property

UnfoldFeature.Edit method

UnfoldFeature.InputSketches property

UnfoldFeature.ResultSketches property

UnfoldFeature.StationaryFace property

UnfoldFeatureProxy interface

UnfoldFeatures

SheetMetalFeatures interface

UnfoldFeatures interface

Add

Application

Count

Item

Type

UnfoldFeatures.Add method

UnfoldFeatures.Application property

UnfoldFeatures.Count property

UnfoldFeatures.Item method

UnfoldFeatures.Type property

UnfoldMethod

BendDefinition interface

ContourFlangeDefinition interface

FlangeDefinition interface

FoldDefinition interface

HemDefinition interface

LoftedFlangeDefinition interface

SheetMetalComponentDefinition interface

SheetMetalStyle interface

UnfoldMethod interface

BendAngleType

DeleteEquation

EquationCount

EquationType

GetEquation

kFactor

SetEquation

SplineFactor

UnfoldMethodType

WriteBendTableToFile

UnfoldMethod.BendAngleType property

UnfoldMethod.DeleteEquation method

UnfoldMethod.EquationCount property

UnfoldMethod.EquationType property

UnfoldMethod.GetEquation method

UnfoldMethod.kFactor property

UnfoldMethod.SetEquation method

UnfoldMethod.SplineFactor property

UnfoldMethod.UnfoldMethodType property

UnfoldMethod.WriteBendTableToFile method

UnfoldMethods

SheetMetalComponentDefinition interface

UnfoldMethods interface

AddBendTableFromFile

AddEquationUnfoldMethod

AddLinearUnfoldMethod

Application

Count

Item

Type

UnfoldMethods.AddBendTableFromFile method

UnfoldMethods.AddEquationUnfoldMethod method

UnfoldMethods.AddLinearUnfoldMethod method

UnfoldMethods.Application property

UnfoldMethods.Count property

UnfoldMethods.Item method

UnfoldMethods.Type property

UnfoldMethodType

UnfoldMethod interface

UnitQuantity

BOMQuantity interface

Units

ContentTableColumn interface

CustomPropertyFormat interface

Parameter interface

UnitsOfMeasure

ApprenticeServerDocument interface

Document interface

UnitsOfMeasure interface

_GetValueFromExpression

AngleDisplayPrecision

AngleUnits

CompatibleUnits

ConvertUnits

GetDatabaseUnitsFromExpression

GetDrivingParameters

GetLocaleCorrectedExpression

GetPreciseStringFromValue

GetStringFromType

GetStringFromValue

GetTypeFromString

GetValueFromExpression

IsExpressionValid

LengthDisplayPrecision

LengthUnits

MassUnits

Parent

TimeUnits

Type

UnitsOfMeasure._GetValueFromExpression method

UnitsOfMeasure.AngleDisplayPrecision property

UnitsOfMeasure.AngleUnits property

UnitsOfMeasure.CompatibleUnits method

UnitsOfMeasure.ConvertUnits method

UnitsOfMeasure.GetDatabaseUnitsFromExpression method

UnitsOfMeasure.GetDrivingParameters method

UnitsOfMeasure.GetLocaleCorrectedExpression method

UnitsOfMeasure.GetPreciseStringFromValue method

UnitsOfMeasure.GetStringFromType method

UnitsOfMeasure.GetStringFromValue method

UnitsOfMeasure.GetTypeFromString method

UnitsOfMeasure.GetValueFromExpression method

UnitsOfMeasure.IsExpressionValid method

UnitsOfMeasure.LengthDisplayPrecision property

UnitsOfMeasure.LengthUnits property

UnitsOfMeasure.MassUnits property

UnitsOfMeasure.Parent property

UnitsOfMeasure.TimeUnits property

UnitsOfMeasure.Type property

UnitsType

MiniToolbarValueEditorObject interface

UnitVector interface

AngleTo

AsVector

CrossProduct

DotProduct

GetUnitVectorData

IsEqualTo

IsParallelTo

IsPerpendicularTo

PutUnitVectorData

TransformBy

X

Y

Z

UnitVector.AngleTo method

UnitVector.AsVector method

UnitVector.CrossProduct method

UnitVector.DotProduct method

UnitVector.GetUnitVectorData method

UnitVector.IsEqualTo method

UnitVector.IsParallelTo method

UnitVector.IsPerpendicularTo method

UnitVector.PutUnitVectorData method

UnitVector.TransformBy method

UnitVector.X property

UnitVector.Y property

UnitVector.Z property

UnitVector2d interface

AngleTo

AsVector

DotProduct

GetUnitVectorData

IsEqualTo

IsParallelTo

IsPerpendicularTo

PutUnitVectorData

TransformBy

X

Y

UnitVector2d.AngleTo method

UnitVector2d.AsVector method

UnitVector2d.DotProduct method

UnitVector2d.GetUnitVectorData method

UnitVector2d.IsEqualTo method

UnitVector2d.IsParallelTo method

UnitVector2d.IsPerpendicularTo method

UnitVector2d.PutUnitVectorData method

UnitVector2d.TransformBy method

UnitVector2d.X property

UnitVector2d.Y property

Unsuppress

ComponentOccurrence interface

UnsuppressFeatures

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

Update

BrowserPaneObject interface

ClientView interface

CustomTable interface

Document interface

PartsListCell interface

Sheet interface

SketchImage interface

View interface

Update2

Document interface

UpdateFromGlobal

LightingStyle interface

Material interface

RenderStyle interface

Style interface

UpdateLegacyHoles

ModelingSettings interface

UpdateOverlayGraphics

InteractionGraphics interface

UpdateProfiles

PlanarSketch interface

UpdateProgress

ProgressBarObject interface

UpdatePropertiesOnSaveForFileType

GeneralOptions interface

UpdatePropertyToRevisionNumber

RevisionTable interface

UpdateSubstitutePart

PartDocument interface

UpDirection

GroundPlaneSettings interface

Upper

Tolerance interface

UpperLimitForFirstRangeOfLineWeights

DrawingOptions interface

SketchSettings interface

UpperLimitForSecondRangeOfLineWeights

DrawingOptions interface

SketchSettings interface

UpperLimitForThirdRangeOfLineWeights

DrawingOptions interface

SketchSettings interface

UpToDate

DrawingView interface

LightingStyle interface

Material interface

PartsListCell interface

RenderStyle interface

Style interface

UpVector

Camera interface

UseAlignedMethod

SectionDrawingView interface

UseColorOverridesFromSource

DerivedPartDefinition interface

UseCustomThreadDesignation

HoleThreadNote interface

UseDefaultFormat

HoleThreadNote interface

UseDefaultMultiCharAliases

ControlDefinitions interface

UseDocumentDisplaySettings

DisplayOptions interface

UseEllipseMajorAxis

HorizontalConstraint interface

VerticalConstraint interface

UseEllipseOneMajorAxis

CollinearConstraint interface

ParallelConstraint interface

PerpendicularConstraint interface

UseEllipseTwoMajorAxis

CollinearConstraint interface

ParallelConstraint interface

PerpendicularConstraint interface

UseFreeDrag

GripSnapOptions interface

UseiMate

AssemblyOptions interface

UseKey1AsBrowserNameColumn

iFeatureOptions interface

UseLargeIcon

CommandControl interface

UseLastOccurrenceOrientationForPlacement

AssemblyOptions interface

UseLeaderForTags

HoleTableStyle interface

UseMask

TextureMap interface

UseNegativeIntegralForInertialProperties

GeneralOptions interface

UsePartUnits

BendNote interface

HoleThreadNote interface

PunchNote interface

UseQuadrant

AngularGeneralDimension interface

UseRayTracingForRealisticDisplay

DisplayOptions interface

DisplaySettings interface

UserCoordinateSystem interface

Application

AttributeSets

Definition

Delete

GetReferenceKey

HealthStatus

IsOwnedByFeature

Name

Origin

OwnedBy

Parent

SetEndOfPart

Transformation

Type

Visible

XAngle

XAxis

XOffset

XYPlane

XZPlane

YAngle

YAxis

YOffset

YZPlane

ZAngle

ZAxis

ZOffset

UserCoordinateSystem.Application property

UserCoordinateSystem.AttributeSets property

UserCoordinateSystem.Definition property

UserCoordinateSystem.Delete method

UserCoordinateSystem.GetReferenceKey method

UserCoordinateSystem.HealthStatus property

UserCoordinateSystem.IsOwnedByFeature property

UserCoordinateSystem.Name property

UserCoordinateSystem.Origin property

UserCoordinateSystem.OwnedBy property

UserCoordinateSystem.Parent property

UserCoordinateSystem.SetEndOfPart method

UserCoordinateSystem.Transformation property

UserCoordinateSystem.Type property

UserCoordinateSystem.Visible property

UserCoordinateSystem.XAngle property

UserCoordinateSystem.XAxis property

UserCoordinateSystem.XOffset property

UserCoordinateSystem.XYPlane property

UserCoordinateSystem.XZPlane property

UserCoordinateSystem.YAngle property

UserCoordinateSystem.YAxis property

UserCoordinateSystem.YOffset property

UserCoordinateSystem.YZPlane property

UserCoordinateSystem.ZAngle property

UserCoordinateSystem.ZAxis property

UserCoordinateSystem.ZOffset property

UserCoordinateSystemDefinition interface

Application

DefinitionType

GetByThreePoints

Parent

SetByThreePoints

Transformation

Type

UserCoordinateSystemDefinition.Application property

UserCoordinateSystemDefinition.DefinitionType property

UserCoordinateSystemDefinition.GetByThreePoints method

UserCoordinateSystemDefinition.Parent property

UserCoordinateSystemDefinition.SetByThreePoints method

UserCoordinateSystemDefinition.Transformation property

UserCoordinateSystemDefinition.Type property

UserCoordinateSystemProxy interface

ContainingOccurrence

NativeObject

UserCoordinateSystemProxy.ContainingOccurrence property

UserCoordinateSystemProxy.NativeObject property

UserCoordinateSystems

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

UserCoordinateSystems interface

Add

Application

Count

CreateDefinition

Item

Type

UserCoordinateSystems.Add method

UserCoordinateSystems.Application property

UserCoordinateSystems.Count property

UserCoordinateSystems.CreateDefinition method

UserCoordinateSystems.Item method

UserCoordinateSystems.Type property

UserCoordinateSystemSettings

ModelingSettings interface

UserCoordinateSystemSettings interface

Application

DefaultPlane

NamingPrefix

ShowOrigin

ShowTriad

ShowXAxis

ShowXYPlane

ShowXZPlane

ShowYAxis

ShowYZPlane

ShowZAxis

Type

UserCoordinateSystemSettings.Application property

UserCoordinateSystemSettings.DefaultPlane property

UserCoordinateSystemSettings.NamingPrefix property

UserCoordinateSystemSettings.ShowOrigin property

UserCoordinateSystemSettings.ShowTriad property

UserCoordinateSystemSettings.ShowXAxis property

UserCoordinateSystemSettings.ShowXYPlane property

UserCoordinateSystemSettings.ShowXZPlane property

UserCoordinateSystemSettings.ShowYAxis property

UserCoordinateSystemSettings.ShowYZPlane property

UserCoordinateSystemSettings.ShowZAxis property

UserCoordinateSystemSettings.Type property

UserEditable

ClientFeatureElement interface

UserInputEvents

CommandManager interface

UserInputEvents coclass

UserInputEventsObject interface

Application

Parent

Type

UserInputEventsObject.Application property

UserInputEventsObject.Parent property

UserInputEventsObject.Type property

UserInputEventsSink interface

OnActivateCommand

OnContextualMiniToolbar

OnDoubleClick

OnDrag

OnLinearMarkingMenu

OnPreSelect

OnRadialMarkingMenu

OnSelect

OnStopPreSelect

OnTerminateCommand

OnUnSelect

UserInputEventsSink.OnActivateCommand method

UserInputEventsSink.OnContextualMiniToolbar method

UserInputEventsSink.OnDoubleClick method

UserInputEventsSink.OnDrag method

UserInputEventsSink.OnLinearMarkingMenu method

UserInputEventsSink.OnPreSelect method

UserInputEventsSink.OnRadialMarkingMenu method

UserInputEventsSink.OnSelect method

UserInputEventsSink.OnStopPreSelect method

UserInputEventsSink.OnTerminateCommand method

UserInputEventsSink.OnUnSelect method

UserInteractionDisabled

UserInterfaceManager interface

UserInterfaceEvents

UserInterfaceManager interface

UserInterfaceEvents coclass

UserInterfaceEventsObject interface

Application

Parent

Type

UserInterfaceEventsObject.Application property

UserInterfaceEventsObject.Parent property

UserInterfaceEventsObject.Type property

UserInterfaceEventsSink interface

OnEnvironmentChange

OnResetCommandBars

OnResetEnvironments

OnResetRibbonInterface

OnResetShortcuts

UserInterfaceEventsSink.OnEnvironmentChange method

UserInterfaceEventsSink.OnResetCommandBars method

UserInterfaceEventsSink.OnResetEnvironments method

UserInterfaceEventsSink.OnResetRibbonInterface method

UserInterfaceEventsSink.OnResetShortcuts method

UserInterfaceManager

Application interface

UserInterfaceManager interface

ActiveEnvironment

AllReferencedControls

Application

BalloonTips

CapacityMeterEnabled

CommandBars

DockableWindows

DoEvents

Environments

ExpertMode

FileBrowserControls

GetCommandPaths

HelpControls

InterfaceStyle

LargeIcons

ParallelEnvironments

Parent

ResetRibbonInterface

RibbonAppearance

RibbonDockingState

Ribbons

RibbonState

ShowBrowser

ShowCleanScreen

ShowDocumentTabs

ShowMarkingMenu

ShowNavigationBar

ShowPanelBar

ShowPanelTitles

ShowQuickAccessControlsBelowRibbon

ShowStatusBar

ShowSteeringWheel

ShowToolBar

ShowViewCube

Type

UserInteractionDisabled

UserInterfaceEvents

UserInterfaceManager.ActiveEnvironment property

UserInterfaceManager.AllReferencedControls method

UserInterfaceManager.Application property

UserInterfaceManager.BalloonTips property

UserInterfaceManager.CapacityMeterEnabled property

UserInterfaceManager.CommandBars property

UserInterfaceManager.DockableWindows property

UserInterfaceManager.DoEvents method

UserInterfaceManager.Environments property

UserInterfaceManager.ExpertMode property

UserInterfaceManager.FileBrowserControls property

UserInterfaceManager.GetCommandPaths method

UserInterfaceManager.HelpControls property

UserInterfaceManager.InterfaceStyle property

UserInterfaceManager.LargeIcons property

UserInterfaceManager.ParallelEnvironments property

UserInterfaceManager.Parent property

UserInterfaceManager.ResetRibbonInterface method

UserInterfaceManager.RibbonAppearance property

UserInterfaceManager.RibbonDockingState property

UserInterfaceManager.Ribbons property

UserInterfaceManager.RibbonState property

UserInterfaceManager.ShowBrowser property

UserInterfaceManager.ShowCleanScreen property

UserInterfaceManager.ShowDocumentTabs property

UserInterfaceManager.ShowMarkingMenu property

UserInterfaceManager.ShowNavigationBar property

UserInterfaceManager.ShowPanelBar property

UserInterfaceManager.ShowPanelTitles property

UserInterfaceManager.ShowQuickAccessControlsBelowRibbon property

UserInterfaceManager.ShowStatusBar property

UserInterfaceManager.ShowSteeringWheel property

UserInterfaceManager.ShowToolBar property

UserInterfaceManager.ShowViewCube property

UserInterfaceManager.Type property

UserInterfaceManager.UserInteractionDisabled property

UserInterfaceManager.UserInterfaceEvents property

UserInterfaceVersion

ApplicationAddIn interface

UserName

ApprenticeServer interface

GeneralOptions interface

UserParameter interface

ConvertToModelParameter

ConvertToReferenceParameter

UserParameter.ConvertToModelParameter method

UserParameter.ConvertToReferenceParameter method

UserParameters

Parameters interface

UserParameters interface

_AddByValue

AddByExpression

AddByValue

Count

Item

Type

UserParameters._AddByValue method

UserParameters.AddByExpression method

UserParameters.AddByValue method

UserParameters.Count property

UserParameters.Item method

UserParameters.Type property

UserRootPath

iFeatureOptions interface

UserUnloadable

ApplicationAddIn interface

UserWorkAxes

ObjectVisibility interface

UserWorkPlanes

ObjectVisibility interface

UserWorkPoints

ObjectVisibility interface

UseSetbacks

FilletSetbackVertex interface

UseSheetMetalStyleMaterial

SheetMetalComponentDefinition interface

UseSheetMetalStyleThickness

SheetMetalComponentDefinition interface

UseSheetMetalStyleUnfoldMethod

SheetMetalComponentDefinition interface

UseSoftwareGraphics

HardwareOptions interface

UseStandardTolerances

Parameters interface

UseTemporaryConstraints

GripSnapOptions interface

UsingUniqueFileNames

DesignProject interface

V

Value

Attribute interface

BalloonValueSet interface

BIMComponentProperty interface

Cell interface

ContentTableCell interface

DrawingBOMCell interface

EnumType interface

GraphicsColorMapper interface

iAssemblyTableCell interface

iFeatureParameterInput interface

iFeatureTableCell interface

InventorVBAArgument interface

iPartTableCell interface

MiniToolbarValueEditorObject interface

NameValueMap interface

Parameter interface

PartsListCell interface

Property interface

ValueCount

GraphicsColorMapper interface

ValueHorizontalJustification

Column interface

PartsListColumn interface

RevisionTableColumn interface

ValueName

EnumType interface

ValueType

Attribute interface

VanishThread

TaperedThreadInfo interface

VaultName

DesignProject interface

VaultPublishPath

DesignProject interface

VaultServer

DesignProject interface

VaultVirtualPath

DesignProject interface

VBA in Inventor

VBA to .Net Quick Reference

VbaApplication interface

ThisApplication

ThisServer

VbaApplication.ThisApplication property

VbaApplication.ThisServer property

VBAProject

Document interface

VBComponent

InventorVBAComponent interface

VBMember

InventorVBAMember interface

VBProject

InventorVBAProject interface

Vector interface

AddVector

AngleTo

AsUnitVector

CrossProduct

DotProduct

GetVectorData

IsEqualTo

IsParallelTo

IsPerpendicularTo

Length

Normalize

PutVectorData

ScaleBy

SubtractVector

TransformBy

X

Y

Z

Vector.AddVector method

Vector.AngleTo method

Vector.AsUnitVector method

Vector.CrossProduct method

Vector.DotProduct method

Vector.GetVectorData method

Vector.IsEqualTo method

Vector.IsParallelTo method

Vector.IsPerpendicularTo method

Vector.Length property

Vector.Normalize method

Vector.PutVectorData method

Vector.ScaleBy method

Vector.SubtractVector method

Vector.TransformBy method

Vector.X property

Vector.Y property

Vector.Z property

Vector2d interface

AddVector

AngleTo

AsUnitVector

DotProduct

GetVectorData

IsEqualTo

IsParallelTo

IsPerpendicularTo

Length

Normalize

PutVectorData

ScaleBy

SubtractVector

TransformBy

X

Y

Vector2d.AddVector method

Vector2d.AngleTo method

Vector2d.AsUnitVector method

Vector2d.DotProduct method

Vector2d.GetVectorData method

Vector2d.IsEqualTo method

Vector2d.IsParallelTo method

Vector2d.IsPerpendicularTo method

Vector2d.Length property

Vector2d.Normalize method

Vector2d.PutVectorData method

Vector2d.ScaleBy method

Vector2d.SubtractVector method

Vector2d.TransformBy method

Vector2d.X property

Vector2d.Y property

VectorTo

Point interface

Point2d interface

Version

ApplicationAddIn interface

Vertex

FilletSetbackVertex interface

Vertex interface

Application

AttributeSets

Edges

Faces

GetPoint

GetReferenceKey

GetSourceVertex

IsTolerant

Parent

Point

Tolerance

TransientKey

Type

Vertex.Application property

Vertex.AttributeSets property

Vertex.Edges property

Vertex.Faces property

Vertex.GetPoint method

Vertex.GetReferenceKey method

Vertex.GetSourceVertex method

Vertex.IsTolerant property

Vertex.Parent property

Vertex.Point property

Vertex.Tolerance property

Vertex.TransientKey property

Vertex.Type property

VertexDefinition interface

Application

AssociativeID

Position

Type

VertexDefinition.Application property

VertexDefinition.AssociativeID property

VertexDefinition.Position property

VertexDefinition.Type property

VertexDefinitions

SurfaceBodyDefinition interface

VertexDefinitions interface

Add

Application

Count

Item

Type

VertexDefinitions.Add method

VertexDefinitions.Application property

VertexDefinitions.Count property

VertexDefinitions.Item method

VertexDefinitions.Type property

VertexProxy interface

ContainingOccurrence

NativeObject

VertexProxy.ContainingOccurrence property

VertexProxy.NativeObject property

VerticalAlignConstraint interface

PointOne

PointTwo

VerticalAlignConstraint.PointOne property

VerticalAlignConstraint.PointTwo property

VerticalAlignConstraintProxy interface

ContainingOccurrence

NativeObject

VerticalAlignConstraintProxy.ContainingOccurrence property

VerticalAlignConstraintProxy.NativeObject property

VerticalAlignment

TextGraphics interface

VerticalConstraint interface

Entity

UseEllipseMajorAxis

VerticalConstraint.Entity property

VerticalConstraint.UseEllipseMajorAxis property

VerticalConstraintProxy interface

ContainingOccurrence

NativeObject

VerticalConstraintProxy.ContainingOccurrence property

VerticalConstraintProxy.NativeObject property

VerticalJustification

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

TextBox interface

TextStyle interface

VerticalZoneCount

DefaultBorder interface

VerticalZoneLabelMode

DefaultBorder interface

Vertices

Face interface

SurfaceBody interface

Vertices interface

Count

Item

Type

Vertices.Count property

Vertices.Item method

Vertices.Type property

Video

ProgressiveToolTip interface

View interface

Activate

Application

Camera

Caption

Close

DisplayMode

Document

Fit

GetWindowExtents

GoHome

Height

HWND

Left

Move

Parent

RayTracing

RayTracingQuality

ResetFront

SaveAsBitmap

SetCurrentAsFront

SetCurrentAsHome

SetCurrentAsTop

ShowAmbientShadows

ShowGroundPlane

ShowGroundReflections

ShowGroundShadows

ShowObjectShadows

Top

Type

Update

Visible

Width

WindowState

View.Activate method

View.Application property

View.Camera property

View.Caption property

View.Close method

View.DisplayMode property

View.Document property

View.Fit method

View.GetWindowExtents method

View.GoHome method

View.Height property

View.HWND property

View.Left property

View.Move method

View.Parent property

View.RayTracing property

View.RayTracingQuality property

View.ResetFront method

View.SaveAsBitmap method

View.SetCurrentAsFront method

View.SetCurrentAsHome method

View.SetCurrentAsTop method

View.ShowAmbientShadows property

View.ShowGroundPlane property

View.ShowGroundReflections property

View.ShowGroundShadows property

View.ShowObjectShadows property

View.Top property

View.Type property

View.Update method

View.Visible property

View.Width property

View.WindowState property

ViewBlockInsertionPoint

DrawingOptions interface

Viewer

iFeatureOptions interface

ViewerArguments

iFeatureOptions interface

ViewJustification

DrawingOptions interface

DrawingView interface

ViewLabelLayer

ObjectDefaultsStyle interface

ViewLabelStyle

ObjectDefaultsStyle interface

ViewList interface

Add

Count

Item

Remove

Type

ViewList.Add method

ViewList.Count property

ViewList.Item method

ViewList.Remove method

ViewList.Type property

ViewOrientationFromBase

DrawingView interface

ViewOrientationType

Camera interface

ViewPreview

DrawingOptions interface

Views

Application interface

Document interface

Views interface

Add

Views.Add method

ViewsEnumerator interface

Count

Item

Type

ViewsEnumerator.Count property

ViewsEnumerator.Item method

ViewsEnumerator.Type property

ViewStyle

DrawingView interface

ViewToModelSpace

Camera interface

ViewTransitionTime

DisplayOptions interface

ViewType

BOMView interface

DrawingView interface

Virtual

DrawingBOMRow interface

VirtualComponentDefinition interface

DisplayName

Material

PropertySets

VirtualComponentDefinition.DisplayName property

VirtualComponentDefinition.Material property

VirtualComponentDefinition.PropertySets property

VisibilityControl

DockableWindow interface

Visible

Application interface

BrowserNode interface

BrowserPaneObject interface

Centerline interface

Centermark interface

ClientGraphics interface

CommandBar interface

CommandControl interface

ComponentOccurrence interface

DockableWindow interface

DrawingCurveSegment interface

GraphicsNode interface

HoleTag interface

Layer interface

MiniToolbarControl interface

MiniToolbarObject interface

OccurrencePattern interface

OriginIndicator interface

PartsListRow interface

ReferencedOLEFileDescriptor interface

RevisionTableRow interface

RibbonPanel interface

RibbonTab interface

Row interface

Sketch interface

Sketch3D interface

SketchBlock interface

SketchImage interface

SurfaceBody interface

TrailSegment interface

UserCoordinateSystem interface

View interface

WorkAxis interface

WorkPlane interface

WorkPoint interface

WorkSurface interface

VisibleDocuments

Documents interface

VisibleInActiveEditObject

GraphicsNode interface

VisibleInViews

GraphicsNode interface

Voltage

BIMElectricalConnectorDefinition interface

Volume

FaceShell interface

InterferenceResult interface

MassProperties interface

SurfaceBody interface

VolumeOverridden

MassProperties interface

W

Weight

SketchSplineHandle interface

SketchSplineHandle3D interface

Weld interface

Application

Delete

Name

SymbolAttachPoint

SymbolBreakPoint

Type

WeldInfo

Weld.Application property

Weld.Delete method

Weld.Name property

Weld.SymbolAttachPoint property

Weld.SymbolBreakPoint property

Weld.Type property

Weld.WeldInfo property

WeldBead interface

_IsLegacyWeldBead

BeadFaces

BeadLength

EndFaces

FaceSetOne

FaceSetTwo

SideFaces

WeldBead._IsLegacyWeldBead method

WeldBead.BeadFaces property

WeldBead.BeadLength property

WeldBead.EndFaces property

WeldBead.FaceSetOne property

WeldBead.FaceSetTwo property

WeldBead.SideFaces property

WeldBeads

Welds interface

WeldBeads interface

Application

Count

Item

Type

WeldBeads.Application property

WeldBeads.Count property

WeldBeads.Item method

WeldBeads.Type property

WeldInfo

Weld interface

WeldmentComponentDefinition interface

GetEndFillRenderStyle

Machining

Material

Preparations

SetEndFillRenderStyle

Welds

WeldsComponentDefinition

WeldmentComponentDefinition.GetEndFillRenderStyle method

WeldmentComponentDefinition.Machining property

WeldmentComponentDefinition.Material property

WeldmentComponentDefinition.Preparations property

WeldmentComponentDefinition.SetEndFillRenderStyle method

WeldmentComponentDefinition.Welds property

WeldmentComponentDefinition.WeldsComponentDefinition property

WeldmentSymbols

ObjectVisibility interface

Welds

ObjectVisibility interface

WeldmentComponentDefinition interface

Welds interface

Application

CosmeticWelds

Count

Edit

ExitEdit

Item

Type

WeldBeads

Welds.Application property

Welds.CosmeticWelds property

Welds.Count property

Welds.Edit method

Welds.ExitEdit method

Welds.Item method

Welds.Type property

Welds.WeldBeads property

WeldsComponentDefinition

WeldmentComponentDefinition interface

WeldsComponentDefinition interface

WestControl

RadialMarkingMenu interface

What's New

WhiteSpace

FeatureControlFrameStyle interface

Width

Application interface

BIMCableTrayConnectorDefinition interface

BIMDuctConnectorDefinition interface

CenteredWidthExtent interface

Column interface

DockableWindow interface

DrawingView interface

FlatPattern interface

GeneralNote interface

HoleTableColumn interface

MiniToolbarComboBoxObject interface

MiniToolbarValueEditorObject interface

PartsListColumn interface

RevisionTableColumn interface

Sheet interface

SheetFormat interface

SketchImage interface

TextBox interface

View interface

WidthOffsetWidthExtent interface

WidthExtent

HemDefinition interface

WidthExtentType

HemDefinition interface

WidthOffsetWidthExtent interface

Edge

OffsetDistance

OffsetEntity

PositiveDirection

Width

WidthOffsetWidthExtent.Edge property

WidthOffsetWidthExtent.OffsetDistance property

WidthOffsetWidthExtent.OffsetEntity property

WidthOffsetWidthExtent.PositiveDirection property

WidthOffsetWidthExtent.Width property

WidthOverride

BIMCableTrayConnectorDefinition interface

BIMDuctConnectorDefinition interface

WidthScale

DimensionText interface

DrawingNote interface

DrawingViewLabel interface

TextBox interface

TextStyle interface

WindowSelectEnabled

SelectEventsObject interface

WindowState

Application interface

View interface

Wire

Edge interface

EdgeUse interface

Wire interface

Application

Edges

EdgeUses

Parent

Type

Wire.Application property

Wire.Edges property

Wire.EdgeUses property

Wire.Parent property

Wire.Type property

WireframeDisplayOptions

DisplayOptions interface

WireframeDisplayOptions interface

Application

Type

WireframeDisplayOptions.Application property

WireframeDisplayOptions.Type property

Wires

Path interface

Profile interface

Profile3D interface

SurfaceBody interface

Wires interface

Count

Item

Type

Wires.Count property

Wires.Item method

Wires.Type property

WorkAxes

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

WorkAxes interface

AddByAnalyticEdge

AddByLine

AddByLineAndPlane

AddByLineAndPoint

AddByNormalToSurface

AddByRevolvedFace

AddByTwoPlanes

AddByTwoPoints

AddFixed

Application

Count

Item

Parent

Type

WorkAxes.AddByAnalyticEdge method

WorkAxes.AddByLine method

WorkAxes.AddByLineAndPlane method

WorkAxes.AddByLineAndPoint method

WorkAxes.AddByNormalToSurface method

WorkAxes.AddByRevolvedFace method

WorkAxes.AddByTwoPlanes method

WorkAxes.AddByTwoPoints method

WorkAxes.AddFixed method

WorkAxes.Application property

WorkAxes.Count property

WorkAxes.Item method

WorkAxes.Parent property

WorkAxes.Type property

WorkAxis interface

Adaptive

Application

AttributeSets

AutoResize

Construction

Consumed

ConsumeInputs

Definition

DefinitionType

Delete

Dependents

DrivenBy

Exported

GetReferenceKey

GetSize

Grounded

HasReferenceComponent

HealthStatus

IsCoordinateSystemElement

IsOwnedByFeature

IsParentSketch

IsPatternElement

Line

Name

OwnedBy

Parent

ParentSketch

ReferenceComponent

ReferencedEntity

SetByAnalyticEdge

SetByLine

SetByLineAndPlane

SetByLineAndPoint

SetByNormalToSurface

SetByRevolvedFace

SetByTwoPlanes

SetByTwoPoints

SetEndOfPart

SetFixed

SetSize

Shared

Type

Visible

WorkAxis.Adaptive property

WorkAxis.Application property

WorkAxis.AttributeSets property

WorkAxis.AutoResize property

WorkAxis.Construction property

WorkAxis.Consumed property

WorkAxis.ConsumeInputs property

WorkAxis.Definition property

WorkAxis.DefinitionType property

WorkAxis.Delete method

WorkAxis.Dependents property

WorkAxis.DrivenBy property

WorkAxis.Exported property

WorkAxis.GetReferenceKey method

WorkAxis.GetSize method

WorkAxis.Grounded property

WorkAxis.HasReferenceComponent property

WorkAxis.HealthStatus property

WorkAxis.IsCoordinateSystemElement property

WorkAxis.IsOwnedByFeature property

WorkAxis.IsParentSketch property

WorkAxis.IsPatternElement property

WorkAxis.Line property

WorkAxis.Name property

WorkAxis.OwnedBy property

WorkAxis.Parent property

WorkAxis.ParentSketch property

WorkAxis.ReferenceComponent property

WorkAxis.ReferencedEntity property

WorkAxis.SetByAnalyticEdge method

WorkAxis.SetByLine method

WorkAxis.SetByLineAndPlane method

WorkAxis.SetByLineAndPoint method

WorkAxis.SetByNormalToSurface method

WorkAxis.SetByRevolvedFace method

WorkAxis.SetByTwoPlanes method

WorkAxis.SetByTwoPoints method

WorkAxis.SetEndOfPart method

WorkAxis.SetFixed method

WorkAxis.SetSize method

WorkAxis.Shared property

WorkAxis.Type property

WorkAxis.Visible property

WorkAxisLayer

ObjectDefaultsStyle interface

WorkAxisProxy interface

ContainingOccurrence

NativeObject

WorkAxisProxy.ContainingOccurrence property

WorkAxisProxy.NativeObject property

WorkAxisStyle

ObjectDefaultsStyle interface

WorkFeatures

DerivedPartComponent interface

DerivedPartUniformScaleDef interface

WorkgroupPaths

DesignProject interface

Workgroups

FileLocations interface

WorkpieceBody

CoreCavityDefinition interface

WorkPlane interface

Adaptive

Application

AttributeSets

AutoResize

Construction

Consumed

ConsumeInputs

Definition

DefinitionType

Delete

Dependents

DrivenBy

Exported

FlipNormal

GetPosition

GetReferenceKey

GetSize

Grounded

HasReferenceComponent

HealthStatus

IsCoordinateSystemElement

IsOwnedByFeature

IsParentSketch

IsPatternElement

Name

OwnedBy

Parent

ParentSketch

Plane

ReferenceComponent

ReferencedEntity

SetByLineAndTangent

SetByLinePlaneAndAngle

SetByNormalToCurve

SetByPlaneAndOffset

SetByPlaneAndPoint

SetByPlaneAndTangent

SetByPointAndTangent

SetByThreePoints

SetByTorusMidPlane

SetByTwoLines

SetByTwoPlanes

SetEndOfPart

SetFixed

SetSize

Shared

Type

Visible

WorkPlane.Adaptive property

WorkPlane.Application property

WorkPlane.AttributeSets property

WorkPlane.AutoResize property

WorkPlane.Construction property

WorkPlane.Consumed property

WorkPlane.ConsumeInputs property

WorkPlane.Definition property

WorkPlane.DefinitionType property

WorkPlane.Delete method

WorkPlane.Dependents property

WorkPlane.DrivenBy property

WorkPlane.Exported property

WorkPlane.FlipNormal method

WorkPlane.GetPosition method

WorkPlane.GetReferenceKey method

WorkPlane.GetSize method

WorkPlane.Grounded property

WorkPlane.HasReferenceComponent property

WorkPlane.HealthStatus property

WorkPlane.IsCoordinateSystemElement property

WorkPlane.IsOwnedByFeature property

WorkPlane.IsParentSketch property

WorkPlane.IsPatternElement property

WorkPlane.Name property

WorkPlane.OwnedBy property

WorkPlane.Parent property

WorkPlane.ParentSketch property

WorkPlane.Plane property

WorkPlane.ReferenceComponent property

WorkPlane.ReferencedEntity property

WorkPlane.SetByLineAndTangent method

WorkPlane.SetByLinePlaneAndAngle method

WorkPlane.SetByNormalToCurve method

WorkPlane.SetByPlaneAndOffset method

WorkPlane.SetByPlaneAndPoint method

WorkPlane.SetByPlaneAndTangent method

WorkPlane.SetByPointAndTangent method

WorkPlane.SetByThreePoints method

WorkPlane.SetByTorusMidPlane method

WorkPlane.SetByTwoLines method

WorkPlane.SetByTwoPlanes method

WorkPlane.SetEndOfPart method

WorkPlane.SetFixed method

WorkPlane.SetSize method

WorkPlane.Shared property

WorkPlane.Type property

WorkPlane.Visible property

WorkPlaneLayer

ObjectDefaultsStyle interface

WorkPlaneProxy interface

ContainingOccurrence

NativeObject

WorkPlaneProxy.ContainingOccurrence property

WorkPlaneProxy.NativeObject property

WorkPlanes

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

WorkPlanes interface

AddByLineAndTangent

AddByLinePlaneAndAngle

AddByNormalToCurve

AddByPlaneAndOffset

AddByPlaneAndPoint

AddByPlaneAndTangent

AddByPointAndTangent

AddByThreePoints

AddByTorusMidPlane

AddByTwoLines

AddByTwoPlanes

AddFixed

Application

Count

Item

Parent

Type

WorkPlanes.AddByLineAndTangent method

WorkPlanes.AddByLinePlaneAndAngle method

WorkPlanes.AddByNormalToCurve method

WorkPlanes.AddByPlaneAndOffset method

WorkPlanes.AddByPlaneAndPoint method

WorkPlanes.AddByPlaneAndTangent method

WorkPlanes.AddByPointAndTangent method

WorkPlanes.AddByThreePoints method

WorkPlanes.AddByTorusMidPlane method

WorkPlanes.AddByTwoLines method

WorkPlanes.AddByTwoPlanes method

WorkPlanes.AddFixed method

WorkPlanes.Application property

WorkPlanes.Count property

WorkPlanes.Item method

WorkPlanes.Parent property

WorkPlanes.Type property

WorkPlaneStyle

ObjectDefaultsStyle interface

WorkPoint interface

Adaptive

Application

AttributeSets

Construction

Consumed

ConsumeInputs

Definition

DefinitionType

Delete

Dependents

DrivenBy

Exported

GetReferenceKey

Grounded

HasReferenceComponent

HealthStatus

IsCoordinateSystemElement

IsOwnedByFeature

IsParentSketch

IsPatternElement

Name

OwnedBy

Parent

ParentSketch

Point

ReferenceComponent

ReferencedEntity

SetAtCentroid

SetByCurveAndEntity

SetByMidPoint

SetByPoint

SetByThreePlanes

SetByTorusCenterPoint

SetByTwoLines

SetEndOfPart

SetFixed

Shared

Type

Visible

WorkPoint.Adaptive property

WorkPoint.Application property

WorkPoint.AttributeSets property

WorkPoint.Construction property

WorkPoint.Consumed property

WorkPoint.ConsumeInputs property

WorkPoint.Definition property

WorkPoint.DefinitionType property

WorkPoint.Delete method

WorkPoint.Dependents property

WorkPoint.DrivenBy property

WorkPoint.Exported property

WorkPoint.GetReferenceKey method

WorkPoint.Grounded property

WorkPoint.HasReferenceComponent property

WorkPoint.HealthStatus property

WorkPoint.IsCoordinateSystemElement property

WorkPoint.IsOwnedByFeature property

WorkPoint.IsParentSketch property

WorkPoint.IsPatternElement property

WorkPoint.Name property

WorkPoint.OwnedBy property

WorkPoint.Parent property

WorkPoint.ParentSketch property

WorkPoint.Point property

WorkPoint.ReferenceComponent property

WorkPoint.ReferencedEntity property

WorkPoint.SetAtCentroid method

WorkPoint.SetByCurveAndEntity method

WorkPoint.SetByMidPoint method

WorkPoint.SetByPoint method

WorkPoint.SetByThreePlanes method

WorkPoint.SetByTorusCenterPoint method

WorkPoint.SetByTwoLines method

WorkPoint.SetEndOfPart method

WorkPoint.SetFixed method

WorkPoint.Shared property

WorkPoint.Type property

WorkPoint.Visible property

WorkPointLayer

ObjectDefaultsStyle interface

WorkPointProxy interface

ContainingOccurrence

NativeObject

WorkPointProxy.ContainingOccurrence property

WorkPointProxy.NativeObject property

WorkPoints

AssemblyComponentDefinition interface

FlatPattern interface

PartComponentDefinition interface

WorkPoints interface

AddAtCentroid

AddByCurveAndEntity

AddByMidPoint

AddByPoint

AddByThreePlanes

AddByTorusCenterPoint

AddByTwoLines

AddFixed

Application

Count

Item

Parent

Type

WorkPoints.AddAtCentroid method

WorkPoints.AddByCurveAndEntity method

WorkPoints.AddByMidPoint method

WorkPoints.AddByPoint method

WorkPoints.AddByThreePlanes method

WorkPoints.AddByTorusCenterPoint method

WorkPoints.AddByTwoLines method

WorkPoints.AddFixed method

WorkPoints.Application property

WorkPoints.Count property

WorkPoints.Item method

WorkPoints.Parent property

WorkPoints.Type property

WorkPointStyle

ObjectDefaultsStyle interface

WorkSheet

ParameterTable interface

Workspace

FileLocations interface

WorkspacePath

DesignProject interface

WorkSurface interface

Application

AttributeSets

Exported

GetReferenceKey

Parent

SurfaceBodies

Translucent

Type

Visible

WorkSurface.Application property

WorkSurface.AttributeSets property

WorkSurface.Exported property

WorkSurface.GetReferenceKey method

WorkSurface.Parent property

WorkSurface.SurfaceBodies property

WorkSurface.Translucent property

WorkSurface.Type property

WorkSurface.Visible property

WorkSurfaceProxy interface

ContainingOccurrence

NativeObject

WorkSurfaceProxy.ContainingOccurrence property

WorkSurfaceProxy.NativeObject property

WorkSurfaces

PartComponentDefinition interface

WorkSurfaces interface

Application

Count

Item

Parent

Type

WorkSurfaces.Application property

WorkSurfaces.Count property

WorkSurfaces.Item method

WorkSurfaces.Parent property

WorkSurfaces.Type property

WrapAutomatically

CustomTable interface

PartsList interface

RevisionTable interface

WrapFace

DecalFeature interface

EmbossFeature interface

WrapLeft

CustomTable interface

PartsList interface

RevisionTable interface

WrapToFace

EmbossFeature interface

WrenchMakeupDiameter

TaperedThreadInfo interface

WrenchMakeupLength

TaperedThreadInfo interface

WriteBendTableToFile

UnfoldMethod interface

WriteDataToFile

DataIO interface

WriteDataToStream

DataIO interface

X

X

Point interface

Point2d interface

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

XAngle

UserCoordinateSystem interface

XAxis

AssemblyWorkPlaneDef interface

FixedWorkPlaneDef interface

UserCoordinateSystem interface

XCount

RectangularPatternFeature interface

XDirectionEntity

RectangularPatternFeature interface

XDirectionMidPlanePattern

RectangularPatternFeature interface

XDirectionSpacingType

RectangularPatternFeature interface

XDirectionStartPoint

RectangularPatternFeature interface

XOffset

UserCoordinateSystem interface

XSnapSpacing

SketchSettings interface

XSpacing

RectangularPatternFeature interface

XYFlushConstraint

LayoutConstraint interface

XYPlane

UserCoordinateSystem interface

XYZMomentsOfInertia

MassProperties interface

XZFlushConstraint

LayoutConstraint interface

XZPlane

UserCoordinateSystem interface

Y

Y

Point interface

Point2d interface

UnitVector interface

UnitVector2d interface

Vector interface

Vector2d interface

YAngle

UserCoordinateSystem interface

YAxis

AssemblyWorkPlaneDef interface

FixedWorkPlaneDef interface

UserCoordinateSystem interface

YCount

RectangularPatternFeature interface

YDirectionEntity

RectangularPatternFeature interface

YDirectionMidPlanePattern

RectangularPatternFeature interface

YDirectionSpacingType

RectangularPatternFeature interface

YDirectionStartPoint

RectangularPatternFeature interface

YieldStrength

Material interface

YOffset

UserCoordinateSystem interface

YoungsModulus

Material interface

YSnapSpacing

SketchSettings interface

YSpacing

RectangularPatternFeature interface

YZFlushConstraint

LayoutConstraint interface

YZPlane

UserCoordinateSystem interface

Z

Z

Point interface

UnitVector interface

Vector interface

ZAngle

UserCoordinateSystem interface

ZAngleConstraint

LayoutConstraint interface

ZAxis

UserCoordinateSystem interface

ZOffset

UserCoordinateSystem interface

ZoomTargetComponentWithiMate

AssemblyOptions interface

ZoomToCursor

DisplayOptions interface


Autodesk Inventor API Help

Autodesk Inventor 2012 API Help
New Users

Introduction

Accessing and Using the API

VBA in Autodesk Inventor

Inventor Addins
All Users

Overview articles

Cut-and-paste sample code

Changes to API help

What's new in the API this release?

What's in the SDK?

Users of Competitive Products

VBA in Autodesk Inventor

Creating Add-Ins with VB.Net

Registering Add-Ins with Inventor
Resources on the Web

Autodesk Manufacturing Community

Inventor API Discussion Group

Autodesk Developer Network

Consulting

API Blog


Introduction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Introduction

Automation Programming Basics

An Automation API is an object-oriented API. This means the API is exposed through a set of "objects" and you can use methods and properties of these objects to query and edit the object. If you have some experience writing Visual Basic programs you already have experience with object-oriented programming. When you place a control on a dialog, that control is represented as an object within your program. For example, when you place a text box on a dialog you're creating an object that has various properties, like Text, Left, Width and Font, that allow you to determine the current state of the object and modify it.

The Autodesk Inventor API exposes functionality within Autodesk Inventor in exactly the same way. Instead of command buttons and text boxes, you access things like sketches and features. For example, you can obtain a SketchArc object (an arc in a sketch), which supports properties like Radius, StartAngle and SweepAngle.

To use the Autodesk Inventor API you need to become familiar with the objects that are exposed and understand how to obtain the desired object. The structure of the API can be seen through something known as the object hierarchy. The figure below represents a simplified case of Autodesk Inventor's object hierarchy. The hierarchy shows the connections between various objects and describes how to traverse through the hierarchy to gain access to a particular type of object. A key feature of the hierarchy is the Application object. This is always the object at the top of the object hierarchy. By gaining access to the Application object you can get to any other object in the API.

Object model example

Another important concept in an Automation API is the "collection" object. A collection is a special type of object that provides iteration over existing objects. Collections, at a minimum, support the Count and Item properties. The Count property returns how many objects are within the collection and the Item property returns the specified object from the collection. In addition to the Count and Item properties, collections also support methods that allow you to create new objects. For example, the Documents object is a collection. The Count property of the Documents object returns the number of documents currently open. You can access any of the open documents using the Item property. The Documents object also supports the Add method, which creates a new document, and the Open method, which opens an existing document.

The entire set of objects in the Autodesk Inventor API is described through something known as a type library. The Autodesk Inventor type library (called RxInventor.tlb) is delivered with Inventor. By referencing this file within your project, you have access to the all of the objects that make up the Autodesk Inventor API. (There is also a type library specifically for Apprentice that can be used when writing an Apprentice-only application. The Autodesk Inventor type library contains all of the Apprentice functionality so if you reference the Autodesk Inventor type library you have access to everything.)

To reference a type library in VB and VBA you use the "References…" command. In Visual C++ you use the #import statement. Because the majority of people customizing Autodesk Inventor will be using Visual Basic (VB) or Visual Basic for Applications (VBA) and since everyone has access to VBA (since it is delivered with Autodesk Inventor), most of the examples in this developer's guide will use VBA code.

You can view the contents of the type library using the Object Browser within VBA or VB. This can be very useful even if you are programming in a language other than Visual Basic. The combo box at the upper-left corner of the Object Browser provides a list of all of the referenced type libraries. The Autodesk Inventor type library is selected in the figure below. The "Classes" list shows a list of all of the objects and enum lists defined in the type library. ("Enum" is short for "enumeration," which is a user-defined type consisting of a set of named constants called enumerators.) When you select an object from the Classes list, the right portion of the Browser shows the methods, properties, and events supported by the selected object. If you select a particular method, property, or event, its prototype is displayed at the bottom of the Browser, along with a brief description.

Let's look at a specific example. In the figure above, Documents is the class selected, and the Add method is selected. The prototype displays the name of each argument and the type. The first argument, DocumentType, expects a value of type DocumentTypeEnum, which is a list of the different types of Autodesk Inventor documents: part, assembly, drawing, etc. Clicking on DocumentTypeEnum will take you to the list. The second argument, TemplateFileName, expects a String. You also know this argument is optional because it is enclosed in brackets. The last argument, CreateVisible, expects a Boolean as input and is also optional. This argument has a default value of True if it is not supplied. Pressing the F1 key at this point will display the Autodesk Inventor online help for the Add method, which contains more detailed information about the arguments and links to sample programs. The Object Browser and online help are the primary tools to help in understanding the Autodesk Inventor objects and the object hierarchy.

Next page | Using the API
1, 2, 3, 4

Disclaimer


Introduction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Introduction

Using the API

Let's begin with a simple VBA application that displays the filename of the currently active document.

Public Sub VBASample()
    ' Set a reference to the currently active document.
    Dim oDoc As Inventor.Document
    Set oDoc = ThisApplication.ActiveDocument

    ' Check to see if a filename is defined.
    If oDoc.FullFileName = "" Then
        MsgBox "The file has not been saved."
    Else
        MsgBox "The active file is: " & oDoc.FullFileName
    End If
End Sub

The "Dim" line declares a variable to be of Document object type. The "Inventor." portion of the declaration is not required but is used to specify a Document object from the type library called "Inventor." If you are referencing another type library that also contains a Document object, (e.g. Word), you may not get the type of Document object you expect. Using the "Inventor." in any declarations removes any ambiguity. You'll see that most of the samples do not do this because most of the object names are Autodesk Inventor-specific enough that conflicts should be rare.

The next line uses a global variable available in Autodesk Inventor's VBA called "ThisApplication." This provides direct access to the Application object. With the Application object you can traverse through the object hierarchy to obtain any object you need. In this case, you use the ActiveDocument property of the Application object to get the document that is currently active.

The first line of the If statement calls the FullFileName property of the Document to see if there is any name defined. This returns an empty string if the file hasn't been saved yet. If a filename exists, the FullFileName property is used again to display the filename to the user.

There are different methods of obtaining the Application object depending on how you're connecting to Autodesk Inventor: VBA, out-of-process, in-process, Add-In, or Apprentice. The last sample took advantage of a feature available in Autodesk Inventor's VBA to get direct access to the Application objects. Here's the same sample written as an out-of-process VB sub.

Public Sub VBSample()
    ' Set a reference to a running instance of Inventor.
    On Error Resume Next
    Dim oApp As Inventor.Application
    Set oApp = GetObject(, "Inventor.Application")
    If Err Then
        MsgBox "Inventor must be running."
        Exit Sub
    End If
    On Error GoTo 0

    ' Set a reference to the currently active document.
    Dim oDoc As Inventor.Document
    Set oDoc = oApp.ActiveDocument

    ' Check to see if a filename is defined.
    If oDoc.FullFileName = "" Then
        MsgBox "The file has not been saved."
    Else
        MsgBox "The active file is: " & oDoc.FullFileName
    End If
End Sub

The only difference between this and the previous version of the sample is how it obtains the reference to the Application object. In this case, it uses the VB GetObject function to get a reference to a running instance of Autodesk Inventor. It uses VB error trapping to catch the case where Autodesk Inventor isn't running. You can also use the VB CreateObject function to start Autodesk Inventor and set a reference to the Application object, as demonstrated below.

Public Sub VBSample()
    ' Attempt to connect to a running instance of Inventor.
    Dim oApp As Inventor.Application
    On Error Resume Next
    Set oApp = GetObject(, "Inventor.Application")
    If Err Then
        Err.Clear
        ' Failed to connect to a running instance, so start Inventor.
        Set oApp = CreateObject("Inventor.Application")
        If Err Then
            MsgBox "Unable to connect to Inventor."
            Exit Sub
        End If

        ' Make the application visible.
        oApp.Visible = True
    End If
    On Error GoTo 0

    ' Now we can do something with the Application object.
    MsgBox oApp.Caption
End Sub

No matter what language you're using to program Inventor, you can use the VBA debugger to better understand the object hierarchy. To see this, create the following sub in any module within Autodesk Inventor's VBA.

Public Sub DebugTest()
    Debug.Print ThisApplication.Caption
    Stop
End Sub

Position the cursor anywhere within the Sub and press the F5 key to run it. The Stop statement acts as a break point and will cause the execution to pause. Position the cursor anywhere within "ThisApplication" and run the "Debug | Quick Watch…" command, and click "Add" on the dialog that's displayed. The ThisApplication variable is now displayed in the Watches window, as shown below.

Clicking the "+" next to ThisApplication will expand the object within the Watches window and display the values of all of its properties. Some of the properties return other objects so you can continue to expand objects within the Watches window and traverse through the object hierarchy. For example, the ActiveView has been expanded, and the Eye and Target properties of the Camera object are shown below. Using the VBA debugger in this way can be a big help in understanding the Autodesk Inventor API object hierarchy.

Next page | Back to the Overviews
1, 2, 3, 4

Disclaimer


Application.UserInterfaceManager Property

Application.UserInterfaceManager Property Available in Inventor Available in Server Introduced in Inventor 9
Summary

Gets the UserInterfaceManager object. The UserInterfaceManager object is the starting point for UI and environment control, providing access to available environments, command bars, browsers, panel bars, toolbars etc.

Visual Basic
Property UserInterfaceManager() As UserInterfaceManager**
See Also

Selection Simple sample

Change the current panel bar sample

Print Environment Names sample

You are here: Symbol Reference > Inventor Library > Objects > Application Interface > Application Properties > Application.UserInterfaceManager Property


ApplicationAddIn.UserInterfaceVersion Property

ApplicationAddIn.UserInterfaceVersion Property Available in Apprentice
Summary

Property that returns the version of the user interface of the add-in. Incrementing this version results in all of the add-in"s UI getting cleaned up during Inventor start-up.

Visual Basic
Property UserInterfaceVersion() As long*
You are here: Symbol Reference > Inventor Library > Objects > ApplicationAddIn Interface > ApplicationAddIn Properties > ApplicationAddIn.UserInterfaceVersion Property


BalloonTipObject.Parent Property

BalloonTipObject.Parent Property Available in Inventor Introduced in Inventor 16
Summary

Property that returns the parent UserInterfaceManager object.

Visual Basic
Property Parent() As UserInterfaceManager**
You are here: Symbol Reference > Inventor Library > Objects > BalloonTipObject Interface > BalloonTipObject Properties > BalloonTipObject.Parent Property


Inventor.BIMElectricalPowerFactorStateEnum Enumeration

Inventor.BIMElectricalPowerFactorStateEnum Enumeration
Summary

This is record Inventor::BIMElectricalPowerFactorStateEnum.

Visual Basic
Public Enum BIMElectricalPowerFactorStateEnum
  kLaggingPowerFactorStateType = 93057
  kLeadingPowerFactorStateType = 93058
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.BIMElectricalPowerFactorStateEnum Enumeration


ColorSchemes.InterfaceStyle Property

ColorSchemes.InterfaceStyle Property Introduced in Inventor 2011
Summary

Property that gets and sets the user interface style. Valid values are kRibbonInterface and kClassicInterface. In order for a change to be applied, Inventor needs to be restarted.

Visual Basic
Property InterfaceStyle() As InterfaceStyleEnum
You are here: Symbol Reference > Inventor Library > Objects > ColorSchemes Interface > ColorSchemes Properties > ColorSchemes.InterfaceStyle Property


DockableWindow.Parent Property

DockableWindow.Parent Property Introduced in Inventor 2011
Summary

Property that returns the parent UserInterfaceManager object.

Visual Basic
Property Parent() As UserInterfaceManager**
You are here: Symbol Reference > Inventor Library > Objects > DockableWindow Interface > DockableWindow Properties > DockableWindow.Parent Property


Inventor.InterfaceStyleEnum Enumeration

Inventor.InterfaceStyleEnum Enumeration
Summary

This is record Inventor::InterfaceStyleEnum.

Visual Basic
Public Enum InterfaceStyleEnum
  kRibbonInterface = 87809
  kClassicInterface = 87810
End Enum
You are here: Symbol Reference > Inventor Library > Enums > Inventor.InterfaceStyleEnum Enumeration


Ribbon.Parent Property

Ribbon.Parent Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the parent UserInterfaceManager object.

Visual Basic
Property Parent() As UserInterfaceManager**
You are here: Symbol Reference > Inventor Library > Objects > Ribbon Interface > Ribbon Properties > Ribbon.Parent Property


UserInterfaceEvents CoClass

UserInterfaceEvents CoClass Available in Inventor Introduced in Inventor 10
Summary

This object provides notification of environment and command bar reset events.

Class Hierarchy
Inventor::UserInterfaceEvents
Visual Basic
Public Class UserInterfaceEvents
Remarks

Also, see the EventWatcher sample provided in the SDK.

Notes

Members through which this object may be accessed include:

UserInterfaceManager.UserInterfaceEvents

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEvents CoClass


UserInterfaceEventsObject Interface

UserInterfaceEventsObject Interface Available in Inventor Introduced in Inventor 10
Summary

This object provides notification of environment and command bar reset events.

Class Hierarchy
Inventor::UserInterfaceEventsObject
Visual Basic
Public Interface UserInterfaceEventsObject
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsObject Interface


UserInterfaceEventsObject.Application Property

UserInterfaceEventsObject.Application Property Available in Inventor Introduced in Inventor 10
Summary

Property returning the parent of the object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsObject Interface > UserInterfaceEventsObject Properties > UserInterfaceEventsObject.Application Property


UserInterfaceEventsObject.Parent Property

UserInterfaceEventsObject.Parent Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the parent UserInterfaceManager object.

Visual Basic
Property Parent() As UserInterfaceManager**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsObject Interface > UserInterfaceEventsObject Properties > UserInterfaceEventsObject.Parent Property


UserInterfaceEventsObject.Type Property

UserInterfaceEventsObject.Type Property Available in Inventor Introduced in Inventor 10
Summary

Property returning kUserInterfaceEventsObject indicating this objects type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsObject Interface > UserInterfaceEventsObject Properties > UserInterfaceEventsObject.Type Property


UserInterfaceEventsSink Interface

UserInterfaceEventsSink Interface Available in Inventor Introduced in Inventor 10
Summary

This object provides notification of environment and command bar reset events.

Class Hierarchy
Inventor::UserInterfaceEventsSink
Visual Basic
Public Interface UserInterfaceEventsSink
Inherits IDispatch
Remarks

Also, see the EventWatcher sample provided in the SDK.

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface


UserInterfaceEventsSink.OnEnvironmentChange Method

UserInterfaceEventsSink.OnEnvironmentChange Method Available in Inventor Introduced in Inventor 10
Summary

The OnEnvironmentChange event notifies the client when the active environment switches from one environment to another.

Visual Basic
Sub OnEnvironmentChange(Environment As Environment, EnvironmentState As EnvironmentStateEnum, BeforeOrAfter As EventTimingEnum, Context As NameValueMap, ByRef HandlingCode As HandlingCodeEnum)
Parameters
Parameters | Description
Environment | The environment object whose state is changing.
EnvironmentState | Indicates the transition state the environment is going through.
BeforeOrAfter | Input EventTimingEnum indicating when the event is being fired. Notification is sent before and after the environment change.
Context | Input NameValueMap object that contains additional information about the event. Name = "Document". Value = The Document object this environment is associated with. Name = "Reason for event". Value = "Undo" or "Redo". The activation of environments is transacted so environments can be activated as a result of an undo or redo operation. If this value is " " then the activation is occurring from an explicit action either from the end-user or through the API. If this value is "Undo" then the activation occurred as the result of an undo operation and if it is "Redo" then it is the result of a redo operation.
HandlingCode | Output HandlingCodeEnum that indicates how you are handling the event. This argument is ignored for this event.
Remarks

Many end-user actions can cause the environment to change. This notification is sent regardless of what triggered the environment change. When the environment changes, this notification will be sent four times; a before and after notification for the environment that was active before the change and is being suspended or terminated and a before and after notification for the environment that is becoming the active environment. In the context of environment change, Inventor considers an environment to be tied with a particular document. For example, Inventor defines a single Part environment but if you have two part documents open there is a unique Part environment associated with each document. This means that the OnEnvironmentChange event notification is sent if the end-user should switch between the two part documents.

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface > UserInterfaceEventsSink Methods > UserInterfaceEventsSink.OnEnvironmentChange Method


UserInterfaceEventsSink.OnResetCommandBars Method

UserInterfaceEventsSink.OnResetCommandBars Method Available in Inventor Introduced in Inventor 10
Summary

The OnResetCommandBars event notifies the client when command bars have been reset.

Visual Basic
Sub OnResetCommandBars(CommandBars As ObjectsEnumerator, Context As NameValueMap)
Parameters
Parameters | Description
CommandBars | A collection of the CommandBar objects that have been reset. In the case where the end-user uses the "Reset" button this collection will contain a single CommandBar object. If the "Reset All" button is pressed this collection contains all of the CommandBar objects.
Context | Input NameValueMap object that contains additional information about the event. No context information is provided for this event.
Remarks

The end-user can reset command bars to their default state using the various Reset buttons on the Customize dialog.

  • The "Reset Menu Bar" button on the Environments tab causes this notification to be sent for the command bar that is being used as the menu bar of the selected environment.
  • The "Reset" button on the Toolbars tab will cause this notification to be sent for the selected command bar (toolbar).
  • The "Reset All" button on the toolbars tab causes this notification to be sent where the CommandBars argument contains all of the existing command bars.

This notification is sent for all command bars, both the built-in command bars that were created by Inventor and those that are created by Add-Ins (those that have an associated client ID). In the case of Add-In created command bars, a reset will remove all of the controls from the command bar but does not delete the command bar. This notification is not sent for user created tool bars and a reset does not have any affect on these toolbars. The primary use of this notification is to allow add-ins to repopulate their commands into the toolbars after a reset has occurred. In most cases this will involved performing the same actions that the add-in performed when it was initialized and the FirstTime argument is True. The exception is the creation of the command bars since they are not deleted as a result of the reset. Only the controls need to be added to the command bar. <!--Event that is fired when the end user clicks the 'Reset' button in the UI customization dialog. Typically, the client application should then perform the following actions.

  • Populate custom environments.
  • Populate custom toolbars.
  • Modify Inventor environments.
  • Modify Inventor toolbars.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface > UserInterfaceEventsSink Methods > UserInterfaceEventsSink.OnResetCommandBars Method


UserInterfaceEventsSink.OnResetEnvironments Method

UserInterfaceEventsSink.OnResetEnvironments Method Available in Inventor Introduced in Inventor 10
Summary

The OnResetEnvironments event notifies the client when environments have been reset.

Visual Basic
Sub OnResetEnvironments(Environments As ObjectsEnumerator, Context As NameValueMap)
Parameters
Parameters | Description
Environments | A collection of the Environment objects that have been reset. In the case where the end-user uses the "Reset" button this collection will contain a single Environment object. If the "Reset All" button is pressed this collection contains all of the Environment objects.
Context | Input NameValueMap object that contains additional information about the event. No context information is provided for this event.
Remarks

The end-user resets environments using the "Reset" and "Reset All" buttons on the Environments tab of the Customize dialog.

  • The "Reset" button on the Environments tab will cause this notification to be sent for the currently selected environment.
  • The "Reset All" button causes this notification to be sent where the Environments argument will contain all of the existing environments. When an environment is reset it is set back the default state, but the environment is not deleted.

The primary use of this notification is to allow add-ins to reconfigure their environments after a reset has occurred. In most cases this will involved performing the same actions that the add-in performed when it was initialized and the FirstTime argument is True. The exception is the creation of the environment since they are not deleted as a result of the reset. Only the configuration of the environment needs to be performed. <!--Event that is fired when the end user clicks the Reset button in the UI customization dialog. Typically, the client application should then perform the following actions.

  • Populate custom environments.
  • Populate custom toolbars.
  • Modify Inventor environments.
  • Modify Inventor toolbars.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface > UserInterfaceEventsSink Methods > UserInterfaceEventsSink.OnResetEnvironments Method


UserInterfaceEventsSink.OnResetRibbonInterface Method

UserInterfaceEventsSink.OnResetRibbonInterface Method Available in Inventor Introduced in Inventor 2010
Summary

Event that is fired when the ribbon user interface is reset.

Visual Basic
Sub OnResetRibbonInterface(Context As NameValueMap)
Parameters
Parameters | Description
Context | Input NameValueMap object that contains additional information about the event. Currently, this argument does not contain any information.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface > UserInterfaceEventsSink Methods > UserInterfaceEventsSink.OnResetRibbonInterface Method


UserInterfaceEventsSink.OnResetShortcuts Method

UserInterfaceEventsSink.OnResetShortcuts Method Available in Inventor Introduced in Inventor 2008
Summary

Event that is fired when command shortcuts/aliases are reset in the Customize dialog (using either the "Reset All Keys" or "Reset All" button).

Visual Basic
Sub OnResetShortcuts(Context As NameValueMap)
Parameters
Parameters | Description
Context | Input NameValueMap object that contains additional information about the event. No additional information is provided for this event.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceEventsSink Interface > UserInterfaceEventsSink Methods > UserInterfaceEventsSink.OnResetShortcuts Method


UserInterfaceManager Interface

UserInterfaceManager Interface Available in Inventor Introduced in Inventor 9
Summary

The UserInterfaceManager object, through which all UI customization objects can be accessed. See [image] here for an overview.

Class Hierarchy
Inventor::UserInterfaceManager
Visual Basic
Public Interface UserInterfaceManager
Inherits IDispatch
Notes

Members through which this object may be accessed include:

Application.UserInterfaceManager

DockableWindow.Parent

Ribbon.Parent

UserInterfaceEventsObject.Parent

See Also

Dockable window sample

Creation of an override environment for a document sample

Adding commands to the application menu sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Change the current panel bar sample

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface


UserInterfaceManager.ActiveEnvironment Property

UserInterfaceManager.ActiveEnvironment Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the Environment that is currently active.

Visual Basic
Property ActiveEnvironment() As Environment**
See Also

Change the current panel bar sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ActiveEnvironment Property


UserInterfaceManager.AllReferencedControls Method

UserInterfaceManager.AllReferencedControls Method Available in Inventor Introduced in Inventor 2010
Summary

Method that returns all command controls in Inventor's ribbon interface that reference the input ControlDefinition. Controls from ribbons panels, Quick Access Toolbar and the File Browser (application menu) are returned.

Visual Basic
Sub AllReferencedControls(Definition As ControlDefinition, Result As [out, retval] CommandControlsEnumerator*)
Parameters
Parameters | Description
Definition | Input ControlDefinition object to find the controls for.
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Methods > UserInterfaceManager.AllReferencedControls Method


UserInterfaceManager.Application Property

UserInterfaceManager.Application Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the Application object.

Visual Basic
Property Application() As Application**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.Application Property


UserInterfaceManager.BalloonTips Property

UserInterfaceManager.BalloonTips Property
Summary

Property that returns the BalloonTips collection object.

Visual Basic
Property BalloonTips() As BalloonTips**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.BalloonTips Property


UserInterfaceManager.CapacityMeterEnabled Property

UserInterfaceManager.CapacityMeterEnabled Property Available in Inventor Introduced in Inventor 2008
Summary

Property that gets and sets whether to enable the capacity meter display in Inventor's status bar.

Visual Basic
Property CapacityMeterEnabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.CapacityMeterEnabled Property


UserInterfaceManager.CommandBars Property

UserInterfaceManager.CommandBars Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the CommandBars collection object.

Visual Basic
Property CommandBars() As CommandBars**
See Also

Change the current panel bar sample

Buttons - add MRU split button sample

Macro Button - create on toolbar sample

UI customization - create combo box control sample

UI customization - create combo box control sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.CommandBars Property


UserInterfaceManager.DockableWindows Property

UserInterfaceManager.DockableWindows Property Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Property that returns the DockableWindows collection object.

Visual Basic
Property DockableWindows() As DockableWindows**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.DockableWindows Property


UserInterfaceManager.DoEvents Method

UserInterfaceManager.DoEvents Method Available in Inventor Introduced in Inventor 2010
Summary

Allows Inventor to process all Windows messages currently in the message queue.

Visual Basic
Sub DoEvents()
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Methods > UserInterfaceManager.DoEvents Method


UserInterfaceManager.Environments Property

UserInterfaceManager.Environments Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the Environments collection object.

Visual Basic
Property Environments() As Environments**
See Also

Creation of an override environment for a document sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Print Environment Names sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.Environments Property


UserInterfaceManager.ExpertMode Property

UserInterfaceManager.ExpertMode Property Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets whether the commands are shown in 'Expert' or 'Learning' mode. If True, commands are shown in expert mode (without text).

Visual Basic
Property ExpertMode() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ExpertMode Property


UserInterfaceManager.FileBrowserControls Property

UserInterfaceManager.FileBrowserControls Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns a CommandControls collection containing the controls in the File Browser (a.k.a Application Menu).

Visual Basic
Property FileBrowserControls() As CommandControls**
Remarks

The returned collection object can be used to add/remove controls to/from the menu.

See Also

Adding commands to the application menu sample

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.FileBrowserControls Property


UserInterfaceManager.GetCommandPaths Method

UserInterfaceManager.GetCommandPaths Method Available in Server Available in Inventor Introduced in Inventor 2011
Summary

Method that returns all the paths that the given command is found in, optionally filtered to an environment.

Visual Basic
Sub GetCommandPaths(CommandInternalName As String, ByRef Environment As [optional] VARIANT, Result As [out, retval] BSTR)
Parameters
Parameters | Description
CommandInternalName | Input String that specifies the internal name of a ControlDefinition.
Environment | Optional input Environment object that specifies which Environment to return the paths for. If not specified, paths from all environments are returned.
Remarks

The paths returned are based on the currently active user interface (ribbon vs. classic).

Ribbon Interface: The paths begin with the display name of the environment, followed by the tab and panel names. If the command is within a split button, the display name of the split button control is also included. Finally the path contains the display name of the command. Paths are comma separated. For example, if 'PartExtrudeCmd' is provided as the internal name, the returned string in the ribbon interface is:

'Part > Model > Create > Extrude, Flat Pattern > Flat Pattern > Create > Extrude, Assembly > Model > Modify Assembly > Extrude, Weldment Assembly > Weld > Preparation and Machining > Extrude'

Classic Interface: The paths begin with the display name of the environment, followed by the display name of the toolbar it is found within. If the command is within a split button, the display name of the split button control is also included. Finally the path contains the display name of the command. Paths are comma separated. For example, if 'PartExtrudeCmd' is provided as the internal name, the returned string in the classic interface is:

'Part > Part Features > Extrude, Flat Pattern > Flat Pattern Edit Features > Extrude, Assembly > Assembly Panel > Extrude, Weldment Feature > Weldment Features Panel > Extrude'

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Methods > UserInterfaceManager.GetCommandPaths Method


UserInterfaceManager.HelpControls Property

UserInterfaceManager.HelpControls Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns a CommandControls collection containing the controls in the Help Menu.

Visual Basic
Property HelpControls() As CommandControls**
Remarks

The returned collection object can be used to add/remove controls to/from the menu.

See Also

Print information about all available ribbons sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.HelpControls Property


UserInterfaceManager.InterfaceStyle Property

UserInterfaceManager.InterfaceStyle Property Introduced in Inventor 2011
Summary

Property that returns the currently displayed interface style. Valid values are kRibbonInterface and kClassicInterface. In order to get and set the interface style application option (found on the Colors tab of Application Options), use the ColorSchemes.InterfaceStyle property.

Visual Basic
Property InterfaceStyle() As InterfaceStyleEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.InterfaceStyle Property


UserInterfaceManager.LargeIcons Property

UserInterfaceManager.LargeIcons Property Available in Inventor Introduced in Inventor 11
Summary

Property that gets and sets whether to display large icons for commands.

Visual Basic
Property LargeIcons() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.LargeIcons Property


UserInterfaceManager.ParallelEnvironments Property

UserInterfaceManager.ParallelEnvironments Property Available in Inventor Introduced in Inventor 10
Summary

Property that returns the list of Environments valid for the edit target or the environment being switched to. Environments can be added to or removed from the list as seen appropriate by the client when an OnNewEditObject or an OnEnvironmentChange event is received. This list of environments will show in the Applications menu item. This list may only contain non-built-in environments.

Visual Basic
Property ParallelEnvironments() As EnvironmentList**
See Also

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ParallelEnvironments Property


UserInterfaceManager.Parent Property

UserInterfaceManager.Parent Property Available in Inventor Introduced in Inventor 9
Summary

Property that returns the parent object from whom this object can logically be reached.

Visual Basic
Property Parent() As Application**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.Parent Property


UserInterfaceManager.ResetRibbonInterface Method

UserInterfaceManager.ResetRibbonInterface Method Available in Inventor Introduced in Inventor 2010
Summary

Method that removes all customizations from the ribbon user interface.

Visual Basic
Sub ResetRibbonInterface()
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Methods > UserInterfaceManager.ResetRibbonInterface Method


UserInterfaceManager.RibbonAppearance Property

UserInterfaceManager.RibbonAppearance Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the appearance of the ribbon. Valid values are kNormal, kAllTextOff, kSmall and kCompact.

Visual Basic
Property RibbonAppearance() As RibbonAppearanceEnum
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.RibbonAppearance Property


UserInterfaceManager.RibbonDockingState Property

UserInterfaceManager.RibbonDockingState Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the docking state of the ribbon. Valid values are kFloating, kDockToTop, kDockToLeft and kDockToRight.

Visual Basic
Property RibbonDockingState() As RibbonDockingStateEnum
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.RibbonDockingState Property


UserInterfaceManager.Ribbons Property

UserInterfaceManager.Ribbons Property Available in Inventor Introduced in Inventor 2010
Summary

Property that returns the Ribbons collection object.

Visual Basic
Property Ribbons() As Ribbons**
See Also

Creation of an override environment for a document sample

Print information about all available ribbons sample

Add parallel environment with contextual tabs (C#) sample

Parallel environments and contextual ribbon tabs. sample

Create a ribbon panel n an existing tab sample

You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.Ribbons Property


UserInterfaceManager.RibbonState Property

UserInterfaceManager.RibbonState Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets the display state of the ribbon. Valid values are kFullRibbon, kMinimizeToTabs and kMinimizeToPanelTitles.

Visual Basic
Property RibbonState() As RibbonStateEnum
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.RibbonState Property


UserInterfaceManager.ShowBrowser Property

UserInterfaceManager.ShowBrowser Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets whether the browser is displayed or not.

Visual Basic
Property ShowBrowser() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowBrowser Property


UserInterfaceManager.ShowCleanScreen Property

UserInterfaceManager.ShowCleanScreen Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether the viewed screen area is maximized.

Visual Basic
Property ShowCleanScreen() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowCleanScreen Property


UserInterfaceManager.ShowDocumentTabs Property

UserInterfaceManager.ShowDocumentTabs Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether document tabs are displayed.

Visual Basic
Property ShowDocumentTabs() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowDocumentTabs Property


UserInterfaceManager.ShowMarkingMenu Property

UserInterfaceManager.ShowMarkingMenu Property Available in Inventor Introduced in Inventor 2012
Summary

Property that gets and sets whether the marking menu is displayed.

Visual Basic
Property ShowMarkingMenu() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowMarkingMenu Property


UserInterfaceManager.ShowNavigationBar Property

UserInterfaceManager.ShowNavigationBar Property
Summary

Property that gets and sets whether the navigation bar is displayed.

Visual Basic
Property ShowNavigationBar() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowNavigationBar Property


UserInterfaceManager.ShowPanelBar Property

UserInterfaceManager.ShowPanelBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets whether the panel bar is displayed or not.

Visual Basic
Property ShowPanelBar() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowPanelBar Property


UserInterfaceManager.ShowPanelTitles Property

UserInterfaceManager.ShowPanelTitles Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether ribbon panel titles are displayed.

Visual Basic
Property ShowPanelTitles() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowPanelTitles Property


UserInterfaceManager.ShowQuickAccessControlsBelowRibbon Property

UserInterfaceManager.ShowQuickAccessControlsBelowRibbon Property Available in Inventor Introduced in Inventor 2010
Summary

Property that gets and sets whether the Quick Access Toolbar (QAT) is shown below or above the ribbon.

Visual Basic
Property ShowQuickAccessControlsBelowRibbon() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowQuickAccessControlsBelowRibbon Property


UserInterfaceManager.ShowStatusBar Property

UserInterfaceManager.ShowStatusBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets whether the status bar is displayed or not.

Visual Basic
Property ShowStatusBar() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowStatusBar Property


UserInterfaceManager.ShowSteeringWheel Property

UserInterfaceManager.ShowSteeringWheel Property
Summary

Property that gets and sets whether the steering wheel control is displayed.

Visual Basic
Property ShowSteeringWheel() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowSteeringWheel Property


UserInterfaceManager.ShowToolBar Property

UserInterfaceManager.ShowToolBar Property Available in Inventor Introduced in Inventor 9
Summary

Property that gets and sets whether the standard toolbar is displayed or not.

Visual Basic
Property ShowToolBar() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowToolBar Property


UserInterfaceManager.ShowViewCube Property

UserInterfaceManager.ShowViewCube Property
Summary

Property that gets and sets whether the view cube is displayed.

Visual Basic
Property ShowViewCube() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.ShowViewCube Property


UserInterfaceManager.Type Property

UserInterfaceManager.Type Property Available in Inventor Introduced in Inventor 9
Summary

Property returning an enum ObjectTypeEnum indicating this object's type.

Visual Basic
Property Type() As ObjectTypeEnum*
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.Type Property


UserInterfaceManager.UserInteractionDisabled Property

UserInterfaceManager.UserInteractionDisabled Property Available in Inventor Introduced in Inventor 10
Summary

Property that enables/disables user interaction.

Visual Basic
Property UserInteractionDisabled() As VARIANT_BOOL
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.UserInteractionDisabled Property


UserInterfaceManager.UserInterfaceEvents Property

UserInterfaceManager.UserInterfaceEvents Property Available in Inventor Introduced in Inventor 10
Summary

Property returning the UserInterfaceEvents object.

Visual Basic
Property UserInterfaceEvents() As UserInterfaceEvents**
You are here: Symbol Reference > Inventor Library > Objects > UserInterfaceManager Interface > UserInterfaceManager Properties > UserInterfaceManager.UserInterfaceEvents Property


Large Assembly Management - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Large Assembly Management

Introduction to LAM - Large Assembly Management

Level of Detail Representations

Autodesk Inventor Release 11 can work with very large assemblies, principally by taking advantage of the new Level of Detail functionality. Typically, when working with a large assembly, not all parts or subassemblies comprising that assembly need to be represented in full detail. By reducing the amount of detail Autodesk Inventor is required to process, assembly capacity and responsiveness are improved significantly. The Level of Detail functionality provided by Inventor Release 11 allows users to choose a level of detail while opening or referencing a file. A Level of Detail representation defines a subset of the model or substitute model geometry for improved capacity and a simplified representation of the model.

Level of Detail through the UI

When opening a file through the user interface, the Level of Detail to open may be chosen from the Options page. When placing an instance of a model into an assembly, the Level of Detail to reference may be chosen from the Options page. When creating a base view of a model, the Level of Detail to reference may be chosen through the relevant dialog. An existing instance can switch the Level of Detail being referenced through the Representations context menu command. An existing drawing view can switch the Level of Detail being referenced through the Edit View command.

Level of Detail representations differ from other representations (Positional or Design View) in that a separate in memory instance of the document is used for the representation. That means that if you open multiple different Level of Detail representations (either through Open or as a reference), you will have multiple in memory Document objects open from that single file in the operating system.

Level of Detail through the API - FullDocumentName

If more than one Document is open from a given file, Document.FullFileName can no longer be considered a unique identifier for opened documents. A FullDocumentName is the combination of the FullFileName and the identifier for the Level of Detail representation. For example ‘C:\Documents\Assembly1.iam<All Parts Suppressed>’ would be the FullDocumentName for the Document that resulted by opening the ‘All Parts Suppressed’ system representation from the ‘C:\Documents\Assembly1.iam’ file. The ‘Master’ representation of the file is identified by the file name alone, in which case the FullFileName is equal to the FullDocumentName. Utility methods on the FileManager object may be used to compose and decompose a FullDocumentName.

Important Note: Arguments in the API that were intended to take a unique document identifier have been changed to use a FullDocumentName. When only Master Level of Detail representations are used, there is essentially no difference in these arguments, but otherwise they are different. This change affects members such as Documents.Open, ApprenticeServerComponent.Open, Documents.ItemByName, document events on the ApplicationEvents object, and ComponentOccurrences.Add and AddUsingiMates. Client side structures (maps, lists, etc…) that may have relied on unique FullFileName may need to be changed to FullDocumentName or otherwise take account of multiple open representations.

Document and ReferencedFileDescriptor

Up to this Release, the Document object was synonymous with the in memory document and the file (or potential file) storage in the operating system. Likewise, the ReferencedFileDescriptor was a descriptor for a reference from one Document to another. When a Document was synonymous with a file, the Document and ReferencedFileDescriptor object could have been used either as a file or an in memory document object equally well.

This is no longer true. The Document object will now be considered the in memory instance of a design. The majority of workflows using ReferencedFileDescriptors were Document references. We now provide a more formal separation of the document and file concepts by providing a parallel object model for the file view, while preserving the Document object as the in memory database. The unfortunately named ReferencedFileDescriptor is replaced with the more descript DocumentDescriptor. The file structure and relationships will be described with the new File and FileDescriptor objects. The File and FileDescriptor objects represent the view of all of the consolidated representations of a Document.

Fig 1. The previous object model where file and document where synonymous.

Fig 2. The new model showing the separation of the document and file structure.

A special note about the PutCustomLogicalUsingFull method.

The ReferencedFileDescriptor.PutCustomLogicalUsingFull method was designed to retarget a file referenced by a document. This method was only allowed in Apprentice on non-migrating data sets. As a result of the split of document and file functionality for the descriptors, this functionality is now available on the FileDescriptor with the ReplaceReference method. Significantly, FileDescriptor.ReplaceReference is now available inside Inventor as well as in Apprentice.

Suppression

An instance in an assembly can now be suppressed for capacity gains. This means that the connection to the referenced document from the particular instance is ignored, and the referenced document is available to be closed if otherwise unreferenced. Any APIs that traverse across that instance to the referenced document will not be able to succeed. This would include operations on ComponentOccurrence such as the Definition, SubOccurrences, and SurfaceBodies properties. Binding reference keys or obtaining the attached entities of an Attribute that reside across the suppressed connection will likewise be impossible to satisfy.

A suppressed link will behave much as an unresolved link did in previous releases. An application would usually want to treat a suppressed connection much as they would have treated an unresolved reference in previous releases. The issue is that many applications likely did not pay much attention to unresolved dependency situations, but now with suppression it will be much more common, and may occur during the working lifetime of the referencing document instead of only at open time.

Transient Representations

There are basically two situations where Inventor will use a transient system Level of Detail representation. The first is when you have opened a system representation (‘Master’ for example), and you begin suppressing or un-suppressing instances or otherwise changing the referenced Level of Detail representation for an instance. In order to maintain the pre-defined system representation intact, the active representation is converted to a ‘Sandbox’ representation. On save, the user will be prompted for a name to save the edited sandbox representation to.

The second situation is where a transient representation is required to satisfy the change in the referenced representation of a deep instance. For example, if a root level assembly references a subassembly, which references other components. If you wish to suppress a component instance in the subassembly in the context of the root assembly, a transient Level of Detail representation Document will be created to satisfy this structure.

Transient representation will never be persisted into the file, and therefore can never be opened or otherwise directly created.

Editing Representation

Changes may be made to any open representation of the design. You are not restricted to editing only the master representation. When more than one representation of a document is opened, only one can obtain the exclusive editing lock on the design. The first representation to be edited will obtain the exclusive editing lock. Any other open representations will not be editable while another representation is actively editing. Any type of design change can be made to the editing representation. While the editing representation is being changed, any other open representation of this document will remain in the ‘before’ state. While a representation is being edited, an application should not make any assumptions that the structure of all open representations are the same.

Document.IsModifiable will return False when the Document cannot be edited due to another editing representation. You can look for the Document in Document.File.AvailableDocuments where IsModifiable is True to locate the editing representation Document.

Open versus Initialized

It is now possible that a referenced document may have been opened and partially read, but not yet fully opened to be worked on. For example, if a drawing document is opened with a view of a model, the model is resolved to and if the drawing and model do not require migration and the drawing view is up to date with the found model revision, the model document does not need to be opened any further. In this case, the drawing is open, but the model is not. Internally, the database for the document has not yet been loaded, and no significant operations on the design can be performed. However, the Document is available in the referenced document structure and in the Documents collection.

New OnInitializeDocument and OnTerminateDocument events are fired to indicate this initialization and termination of a Document that precedes and follows the OnOpenDocument and OnCloseDocument events respectively. The Document.Open property can be used to indicate if a Document is opened or not. In general an application would only want to work with Open documents. A Document will fully open if API methods that require it to do so are called. Since keeping documents unloaded until absolutely necessary would be a performance and capacity issue, application should be careful to only cause a document to Open when necessary. Applications should also be aware that the Documents collection or other access to Document objects in the API may return a Document that has yet to be open or have the OnOpenDocument event fired for it. If knowledge of the existence of all available Documents that are open or not is required, the OnInitializeDocument event should be monitored.

Open Order

Changes to the implementation of cross document references will also impact the order of open document events. Application logic that may have relied on the nested bottom up open order of documents will need to be adjusted. Migrating documents may still open in the bottom up nested order, but in general documents will open in a top down fashion.

Saving Changes to Edited Documents

Various Level of Detail operations may result in open documents becoming unreferenced. In the simplest case, if you suppress an instance of a Document in an assembly, and if that was the only instance of that Document, the Document will become unreferenced and will be closed when unreferenced documents are cleaned up. Any Level of Detail operation has the potential to leave an open Document unreferenced, including any transitive references from these documents. Through the user interface, an analysis of the dependencies will be made and the user will be prompted to save any documents that are dirty and may be closed. Through the API, the operation will just complete without making any saves. The application would be required to perform any saves or prompting for saves to dirty documents if they do not want to throw away edits made to the dirty documents. Of course, care should be taken to never indirectly throw away user edits to any documents not exclusively under application control. The APIs that may close dirty documents would be ComponentOccurrence.Suppress, ComponentOccurrence.ActiveLevelOfDetail, DrawingView.ActiveLevelOfDetail, and LevelOfDetailRepresentation.Activate.

Next page | Back to the Overviews
Disclaimer


More Reference Key Information - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

More Reference Key Information

The following table details how the API determines primary and multiple matches for specific objects.

Category

Object

Cause of splits

Expected behavior

Primary match

Multiple matches

Brep

Face

Feature operations

BoundedFace algorithm will select that face which has maximum % of edges.

All other faces that share at least one edge with the original face.

Sketch splits

One of the resulting faces, Not deterministic

Not supported

Profile editing

One of the resulting faces, Not deterministic

Rest of the resulting faces, Not deterministic

Face merges & splits

Face with the earliest feature

Not supported

Edge

Feature operations

One of the resulting edges. Not deterministic

Rest of the split edges

Sketch splits

One of the resulting edges. Not deterministic

One of the resulting edges. Not deterministic

Face merges & splits

Edge with the earliest feature

Not supported

Loop

Feature operations

Match loop algorithm will select the primary match.

All other loops that share at least one edge with the original loop.

Sketch splits

One of the resulting loops, Not deterministic

Not supported

Face merges & splits

Loop with the earliest feature

Not supported

Shell

Feature operations

Match shell algorithm will select the primary match.

All other shells that share at least one face with the original shell.

Sketch splits

One of the resulting shells, Not deterministic

Not supported

Face merges & splits

Not supported

Not supported

Sketch lines

Arcs

Trim

One of the resulting arcs

Not supported

Lines

Trim

One of the resulting lines

Not supported

Splines

Trim

One of the resulting splines

Not supported

Exceptional Cases

Profile Editing

You can edit a profile for a feature to include additional intersecting sketch entities so that a face or an edge gets split. In such a case, one of the resulting face/edge will the primary match. However the choice is not deterministic. The other faces/edges will not be returned.

Face Draft/ Face Splits

In some special cases, new faces get generated when you add face drafts or face splits. You could argue that these new faces are also candidates for the purpose of multiple matches. However these new faces will not be returned.

Next page | To the Overviews
Disclaimer


More Information on Design View Data XML Formatting - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Design View Data XML Formatting

DesignView XML String

Information stored for a Design View

A design view captures the following display characteristics:

  1. Component visibility (visible or not visible)
  2. Sketch and work feature visibility (visible ornot visible)
  3. Component selectionstatus (enabledor not enabled)
  4. Color andstyle characteristics applied in the assembly
  5. Zoom magnification
  6. Viewing angle

How is this data defined via XML?

The output XML string should be compared to the XML output of the StreamLine translator. For example, open an Inventor assembly file, and then invoke the Streamline translator from the Inventor File/SaveCopy As menu item. When the Inventor Save CopyAs dialog appears, select StreamLine Assembly Packages(*.amp) as the output type, with the designview data option. The data in the DesignViewInfo string can be compared to the design view data in the XML file produced by the Streamline translator.

DesignViewInfo XML tags

The XML tags for the DesignViewInfo string are as follows:

DesignViewInfo | This is the root tag.
DesignView | This is one of the design views in the designview database.
Camera | This is the camera information for the parent design view.
Occurrence | This is an ‘object’ to which the design view applies camera, visible, and material overrides.
Path | This is the ‘path’ to the occurrence, as seen in the browser.
Material | The material parameters applied to the occurrence.

Example

Below is part of a sample DesignViewInfo XML string, demonstrating the use of these tags.

-<DesignViewInfo units="cm" designviewfilepath="C:\Autodesk\Inventor 10\Tutorial Files\final_assy.idv">

- <DesignView name="Internal Components">

 - <Camera width="14.1727" height="13.9774">

 <UpVector x="-0.333333" y="0.666667" z="-0.333333" />

 <CameraPosition x="15.2765" y="17.3914" z="21.4982" />

<Target x="-1.33647" y="0.778433" z="4.88529" />

 </Camera>

 - <Occurrence visible="false" enabled="true" colored="true">

 - <Path>

 <PathNode>vbody.ipt:1</PathNode>

 </Path>

- <Material alpha="0.5" shine="20">

 <Diffuse r="17.0001" g="193" b="84.0001" />

 <AmbientColor r="12.9999" g="147" b="63" />

 <EmissiveColor r="0" g="0" b="0" />

<SpecularColor r="80.0001" g="239" b="139" />

 </Material>

 </Occurrence>

- <Occurrence visible="true" enabled="true" colored="true">

 - <Path>

 <PathNode>vnozzle.ipt:1</PathNode>

 </Path>

 - <Material alpha="1" shine="20">

 <Diffuse r="1.99996" g="54.0001" b="210" />

 <AmbientColor r="1.00011" g="40.0001" b="158" />

 <EmissiveColor r="0" g="0" b="0" />

 <SpecularColor r="66.0001" g="113" b="253" />

 </Material>

 </Occurrence>

 - <Occurrence visible="true" enabled="true" colored="true">

 - <Path>

 <PathNode>knob.ipt:1</PathNode>

 </Path>

 - <Material alpha="1" shine="10"> <Diffuse r="109" g="120" b="138" />

 <AmbientColor r="109" g="120" b="138" />

 <EmissiveColor r="0" g="0" b="0" />

 <SpecularColor r="84.9999" g="84.9999" b="133" />

 </Material> </Occurrence> </DesignView>

 - <DesignView name="All Components Displayed">

 - <Camera width="14.1727" height="13.9774">

 <UpVector x="-0.408248" y="0.816497" z="-0.408248" />

 <CameraPosition x="17.3029" y="19.4178" z="23.5247" />

 <Target x="-1.33647" y="0.778433" z="4.88529" />

 </Camera>

- <Occurrence visible="true" enabled="true" colored="true">

 - <Path>

 <PathNode>vbody.ipt:1</PathNode>

 </Path>

 - <Material alpha="0.5" shine="20">

 <Diffuse r="17.0001" g="193" b="84.0001" />

 <AmbientColor r="12.9999" g="147" b="63" />

 <EmissiveColor r="0" g="0" b="0" />

 <SpecularColor r="80.0001" g="239" b="139" />

 </Material>

 </Occurrence>

 - <Occurrence visible="true" enabled="true" colored="true">

- <Path>

 <PathNode>vnozzle.ipt:1</PathNode>

 </Path>

 - <Material alpha="1" shine="20">

 <Diffuse r="1.99996" g="54.0001" b="210" />

 <AmbientColor r="1.00011" g="40.0001" b="158" />

 <EmissiveColor r="0" g="0" b="0" />

 <SpecularColor r="66.0001" g="113" b="253" />

 </Material>

 </Occurrence>

 - <Occurrence visible="true" enabled="true" colored="true">

 - <Path>

 <PathNode>knob.ipt:1</PathNode>

 </Path>

 - <Material alpha="1" shine="10">

 <Diffuse r="109" g="120" b="138" />

 <AmbientColor r="109" g="120" b="138" />

 <EmissiveColor r="0" g="0" b="0" />

 <SpecularColor r="84.9999" g="84.9999" b="133" />

 </Material>

 </Occurrence>

</DesignView>

</DesignViewInfo>

Next page | To the Overviews
Disclaimer


More Information on Weld Data XML Formatting - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Weld Data XML Formatting

More Information on Weld Data XML Formatting

Both WeldBead and CosmeticWeld Objects will support a read only property WeldInfo, which will return an XML formatted string containing a description of the Weld Object. The XML string will contain a variable number of tags which describe the elements and properties of the Weld Object.

The first section of the XML string will contain information which describes those properties which pertain to the weld as a whole. Following the first section will be a variable number of <WeldInfoSide> tags, which will contain information descriptive of individual welds comprising the weld feature. An example first section follows:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<WeldmentInfo cosmeticweld="false" standard="ANSI" fieldweld="false" >
<FeatureName>My Weldment</FeatureName>
<AllAroundType>FilletWeld</AllAroundType>
<IdentLineType>IdentLineOtherSide</IdentLineType>
<StaggerType>EnableMoveStagger</StaggerType>
<Note enclosed="false">This is a note</Note>
:
:
(one or more <WeldInfoSide> tagged elements
:
</WeldmentInfo>

This initial section contains standard XML file header information; it is sufficient to include only the XML version and encoding information.

The root level tag is the WeldmentInfo tag. This tag has attributes cosmeticweld, standard, and fieldweld. The cosmeticweld tag takes on values true or false; the true value indicates that the object is a cosmetic weld, false indicates a weld bead. The standard property indicates the standard under which the weld callout is created; this may take on values ANSI, BSI, DIN, GB, ISO, or JIS. The fieldweld attribute indicates that this is a weld performed in the field, this attribute may be either true or false.
Elements of the root WeldmentInfo tag in the first section are FeatureName, which describes the name applied to the Weldment Feature, AllAroundType, which indicates that a single weld type has been applied to both sides of the feature, IdentLineType, which indicates the linetype of the identifier line (ISO and DIN only), StaggerType, which indicates the method used to stagger the elements of a two sided callout, and NoteEnclosed, which contains the note string included in the callout and has a property enclosed, which indicates that the note string is enclosed in a box in the callout.

A single weldment callout can be used to describe two physical welds. These two welds are termed the ‘arrow side’ and ‘other side’ welds. Additionally, the arrow side and other side welds may be composed of up to two physical welds each. If a second weld exists on the arrow side, it is termed the arrowside2 weld, if a second weld exists on the other side, it is termed the other side2weld. Each of these four possible welds will be represented by a WeldInfoSide element in the XML string. An example WeldInfoSide element follows:

<WeldInfoSide side="arrow" weldtype="PermanentBackingStripWeld" extentsthruall="true" facesprojected="false" brazingweld="false" brazeclearance="0.125" secondfillet="true">
<Angle>45.00 degrees</Angle>
<ContourType offset="0.25 inches" method =”H”>Concave</ContourType>
<Gap>4.5 inches</Gap>
<Depth>0.25 inches</Depth>
<Diameter>0.75</Diameter>
<Height>0.75</Height>
<Intermittent>
<Number>5.00</Number>
<Length>4.00 inches</Length>
<Spacing>2.0 inches</Spacing>
<Pitch>2.00 inches</Pitch>
</Intermittent>
<Gap>1.00 inches</Gap>
<Middle>string</Middle>
<Prefix>"string"</Prefix>
<Size>23.00 inches</Size>
<SmallLeg>22.02 inches</SmallLeg>
<Thickness>2.5 inches</Thickness>
<Root>0.50</Root>
<RootGap>1.0</RootGap>
</WeldInfoSide>

The WeldInfoSide element has a variable number of attributes. The side attribute may be arrow, other, arrow2, or other2. The weldtype may be any valid weld, examples include fillet, plug, slot, etc. (All valid weld types are in the following table).

The extentsthruall attribute may be true or false; it is true when the weld is limited by the length of the edge or face alone, it is false when limiting work planes have been specified. The facesprojected attribute describes a situation where the weld is placed at a position created by projecting a face onto another. This attribute may be true or false. The brazingweld attribute indicates that the weld is brazed (brazing is accomplished by using a bronze alloy that is melted and adhered to the parent metal). The attribute brazeclearance specifies the clearance for the braze.

The WeldInfoSide tag has a variable number of elements. The Angle element specifies the angle between weldments, and includes the units used for this measure. The ContourType element describes contour information for the weld. It takes on values Flat, Concave, and Convex.

The attribute method describes the finish of the weld, and may take on alphabetic values C, G, R, H, M or U. The attribute offset describes the depth of the weld finish. The element Gap describes the distance between weldments. The element Depth describes the depth of the weld. The element Height specifies the height of the weld.

The element Intermittent contains information related to intermittent welds; it contains a variable number of the following elements: Number (number of welds), Length ( length of the welds), Spacing (space between welds), and Pitch (center to center distance).

The gap element describes the space between weldments. The middle element specifies the type of intersection to perform on the weld. The Prefix element allows text before the weld callout. The size element specifies the size of the weld. The SmallLeg element specifies the thickness of the weld. The Thickness element represents the thickness of the weld. The Root element specifies the root thickness of the weld. The RootGap element specifies the gap for the weld.

XML documents usually omit elements and attributes which do not hold values or are not valid. Throughout this discussion it has been noted that the number of elements and attributes included in the XML string will be variable. In general, the XML string should follow the convention that invalid or empty tags should not be written. For example, in the initial section, the IdentLineType element is valid only for callouts under the DIN and ISO standards; this tag should not be included in the XML string if the weldment is not created using one of these standards.

Additionally, the number of WeldInfoSide tags will depend on the number of welds comprising the callout; most often there will be one weld, and therefore one WeldInfoSide tag will appear in the string. It is possible to have up to four WeldInfoSide tags in the XML formatted string, however. A table describing which tags are valid by standard and weld type follows.

ANSI |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | Diameter | Small Leg | Depth | Size | Length | Number | Spacing | Pitch | Method | Contour | Angle | Root | Height | Brazing | Thickness |  | Gap | Secondary Fillet
Fillet |  | yes | no | yes | yes | no | no | yes | yes | yes | no |  |  |  |  |  |  |
Plug |  | no | yes | yes | no | yes | yes | no | yes | yes | yes |  |  |  |  |  |  |
Slot |  | no | yes | yes | yes | yes | no | yes | yes | yes | yes |  |  |  |  |  |  |
Stud |  | no | no | yes | no | yes | yes | no | yes | yes | no |  |  |  |  |  |  |
Spot/Projection |  | no | no | yes | yes | yes | no | no | yes | no | no |  |  |  |  |  |  |
Spot on Ref Line |  | no | no | yes | no | yes | no | no | yes | yes | no |  |  |  |  |  |  |
Seam |  | no | no | yes | yes | yes | no | yes | yes | yes | no |  |  |  |  |  |  |
Back or Backing |  | no | no | yes | yes | no | no | yes | yes | no | no |  |  |  |  |  |  |
Surfacing |  | no | no | yes | no | no | no | no | yes | yes | no |  |  |  |  |  |  |
Flange Edge |  | no | no | no | yes | no | no | yes | yes | yes | no | yes | yes | yes | yes |  |  |
Flange Corner |  | no | yes | no | yes | no | no | yes | yes | yes | no | no | yes | yes | yes |  |  | yes - must be ansi fillet
Square Groove |  | no | no | yes | yes | no | no | yes | yes | yes | yes | no | no | yes | no |  | yes | yes - must be ansi fillet
Scarf Groove |  |  | yes | yes | yes |  |  | yes |  | yes | yes |  |  | yes | yes |  |  | no
V Groove |  | no | no | no | yes | no | no | yes | yes | yes | yes | no | no | yes | no |  | yes | no
Bevel Groove |  | no | no | yes | no | no | no | yes | yes | yes | yes | no | no | yes | no |  | yes | no
U Groove |  | no | yes | yes | yes | no | no | yes | yes | yes | yes | no | no | yes | no |  | no | no
j Groove |  | no | yes | yes | yes | no | no | yes | yes | yes | yes | no | no | yes | no |  | yes | yes - must be ansi fillet
Flare V Groove |  | no | yes | yes | yes | no | no | yes | yes | yes | no | no | no | yes | no |  | yes | no
Flare Single Groove |  | no | yes | yes | yes | no | no | yes | yes | yes | yes | no | no | yes | no |  | yes | yes - must be ansi fillet
Non Destructive Exam | test | either side | number |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
Permanent Backing | contour |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
Melt Through | size | angle | contour |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
consumable | contour |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
BSI, DIN, GB, ISO |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | Diameter | Small Leg | Depth | Size | Length | Number | Spacing | Pitch | Method | Contour | Angle | Root | Height | Brazing | Thickness |  | Gap | Secondary Fillet
fillet |  | no | yes | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
plug |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
spot or projection |  | no | no | yes | no | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
spot on reference lint |  | no | no | yes | no | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Seam |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Seam on reference line |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Back or Backing |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Surfacing |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Butt Weld |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Square Butt |  | no | yes | no | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | yes - must be fillet
Bevel Butt |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | yes - must be fillet
V Butt |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
U Butt |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
J Butt |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | yes - must be fillet
Edge Weld |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Fold Joint |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Inclined Joint |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Surface Joint |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Steep Flanked V Butt |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
V Butt Broad Root |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | no
Bevel Butt Broad Root |  | no | no | yes | yes | yes | yes | no | no | yes | no | no | no | no | no |  | no | yes - must be fillet
JIS |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | Diameter | Small Leg | Depth | Size | Length | Number | Spacing | Pitch | Method | Contour | Angle | Root | Height | Brazing | Thickness | width | Gap | Secondary Fillet
fillet | no | yes | no | yes | yes | yes | no | yes | yes | yes | no | no | no | no | no | no | no | no
plug and spot | yes | no | yes | no | yes | yes | no | yes | yes | yes | yes | no | no | no | no | no | no | no
spot and projection | no | no | no | yes | no | yes | no | yes | yes | yes | no | no | no | no | no | no | no | no
seam weld | no | no | no | yes |  |  |  |  |  |  |  |  |  |  |  |  |  |
bead | no | no | no | yes | yes | Number | no | yes | yes | yes | no | no | no | no | no | no | yes | no
cladding | no | no | no | yes | yes | Number | no | no | yes | yes | no | no | no | no | no | yes | no | no
double flange | no | no | no | no | yes | yes | no | yes | yes | yes | no | no | yes | no | no | no | yes | no
single flange | no | no | no | no | yes | yes | no | no | yes | yes | no | no | yes | no | no | no | yes | yes
square groove | no | no | no | no | yes | yes | no | yes | yes | yes | no | no | no | no | no | no | yes | yes
v groove | no | no | yes | no | yes | yes | no | yes | yes | yes | yes | no | no | no | no | no | yes | no
bevel groove | no | no | yes | no | yes | yes | no | yes | yes | yes | yes | no | no | no | no | no | yes | yes
u groove | no | no | yes | no | yes | yes | no | no | yes | yes | yes | no | no | no | no | no | yes | no
j groove | no | no | yes | no | yes | yes | no | yes | yes | yes | yes | no | no | no | no | no | yes | yes
Flare V Groove | no | no | yes | no | yes | yes | no | yes | yes | yes | yes | no | no | no | no | no | yes | no
Flare Single Groove | no | no | yes | no | yes | yes | no | yes | yes | yes | yes | no | no | no | no | no | yes | yes
Non Destructive Exam | Test | Length | Number | Either Side |  |  |  |  |  |  |  |  |  |  |  |  |  |

Next page | To the Overviews
Disclaimer


Proxies - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Proxies

Introduction to proxies

For the Autodesk Inventor user, the concept of proxy files relates to the use of AutoCAD files in the Autodesk Inventor environment. Proxies in the API context mean something different entirely.

An object proxy is a reference to an object through a particular occurrence. Think of it as a pairing with its respective native object, but returns context-specific data.

An example is a face of a part within an assembly. When this face is queried through the API, what do the results mean - are coordinates returned in the context of the assembly, or the native part? What if the part is inserted into the assembly multiple times; how is a particular instance of the face identified? A key purpose of proxies is to provide answers to these questions. In this case, the proxy of the face object performs the necessary transformations to provide point data in the required context, and also provides information about which occurrence the face is associated with.

The purpose of proxies

To the user, the notion of proxies is transparent. When a user selects a part through the Autodesk Inventor user interface, conceptually the part is in the assembly. It doesn't matter to users that they are working with a proxy that is presenting coordinates and faces and so on in the assembly context and not in the context of the referenced part. But developers need to obtain data specifically in the part or assembly context. There is no geometry in the assembly, only a proxy that is performing the required transformations based on the position of the part within the assembly.

Note: The idea of proxies can be extended to cover the ComponentOccurrence object (the concept is very similar). Consider nested assemblies, or subassemblies, where the level of nesting is three or more levels. An occurrence can be an instance of an assembly definition, not just a part definition. At the top level (the instance), this occurrence is a ComponentOccurrence object as expected, but at other levels these occurrences are represented by ComponentOccurrenceProxy objects.

There is no object model diagram for proxies. Proxies are present for anything that is available for selection in an assembly context, including constraints, features, faces, edges, loops, sketches, profiles, and work features.

Working with proxies through the API

Object proxies are paired with their respective native objects. In fact, proxies are derived from their native objects, and so have common methods and properties. However, an object proxy is a reference to an object through a particular occurrence. In other words, it's a reference to the native object through the occurrence path. This path is potentially long when working with deeply nested subassemblies, so there are means to traverse this path.

Proxy objects have two additional properties; NativeObject and ContainingOccurrence. NativeObject returns the definition of the object - the object without its containing occurrence context. So for a FaceProxy object, NativeObject returns the corresponding face object within the part definition. The ContainingOccurrence property returns the containing object - in this case, the occurrence that contains the face.

Note: When working with an object or its proxy, be aware that calls to their respective Parent properties return different objects. The parent of a proxy object will also be a proxy object. For example, the parent of an EdgeProxy object may be a SurfaceBodyProxy.

The starting point at the top of the path is the ComponentOccurrence. The CreateGeometryProxy method of the ComponentOccurrence object creates the required proxy information for a given face, feature, constraint, and so on.

Sample demonstrating the difference between a proxy and its native object

The following code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

Through the Autodesk Inventor user interface, create a simple part (for example, extrude a circle). Save the part, and then start a new assembly. Place your saved part in the assembly, unground the assembly, move it a little, then save the assembly.

The following code prints the X and Y coordinates of one corner of the range box that encompasses the extrude feature of the part. It demonstrates that different coordinates are returned for the proxy when compared to the native occurrence.

First, obtain the component occurrence from the assembly document. In this case it's simplified as we know the document contains only one.

Dim oDoc As AssemblyDocument
Set oDoc = ThisApplication.ActiveDocument

Dim oCompOcc As ComponentOccurrence
Set oCompOcc = oDoc.ComponentDefinition.Occurrences.Item(1)

Then obtain the part component definition to gain access to the part features.

Dim oPartCompDef As PartComponentDefinition
Set oPartCompDef = oCompOcc.Definition

Dim oExtrudeFeature As ExtrudeFeature
Set oExtrudeFeature = oPartCompDef.Features.ExtrudeFeatures.Item(1)

To get the proxy for the feature, use the CreateGeometryProxy method of the component occurrence, with the required feature as an argument.

Dim oExtrudeFeatureProxy As ExtrudeFeatureProxy
oCompOcc.CreateGeometryProxy oExtrudeFeature, oExtrudeFeatureProxy

Print some coordinate data, in this case the X Y values of one corner of the feature rangebox. These figures will differ, indicating that the first set come from the native object, while the second set come from the proxy object - in other words, the second set of values are in the assembly context.

Debug.Print oExtrudeFeature.RangeBox.MaxPoint.X
Debug.Print oExtrudeFeature.RangeBox.MaxPoint.Y

Debug.Print oExtrudeFeatureProxy.RangeBox.MaxPoint.X
Debug.Print oExtrudeFeatureProxy.RangeBox.MaxPoint.Y

The preceding code demonstrated that coordinates for a known point differed according to the context of the feature. Example output might look as follows.

 0.232857970569028
 0.96726442148297
 0.177086160521056
 0.988809173640979

In the assembly context, the part was moved; therefore the coordinates returned by the proxy reflect this move (the first and second lines in the output). These coordinates are different from those returned by the native object, the object definition, with no containing context (the third and fourth lines in the output).

Summary

An object proxy is a reference to an object through a particular occurrence. When the user picks an object (edge, face, loop and so on) in an assembly, they are really picking an object proxy. The various proxies available through the API are derived from their real counterparts and contain the same methods and properties, as well as others specific to proxies (such as NativeObject, which returns the object definition the proxy is paired with). The purpose of object proxies is to provide transformation and assembly context information for occurrences, features, constraints and so on. Object proxies are transparent to the Autodesk Inventor user.

Also consider

To fully understand object proxies, it is important to understand component occurrences and component definitions.

Next page | Back to the Overviews
Disclaimer


Render Styles - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Render Styles (colors)

Introduction

"Render Style" is the term used by the API to describe the information used by Inventor to display a part. This same information is accessible in Inventor through the Colors command. When the Colors command is invoked, the dialog shown below is displayed.

By looking at the various controls on the dialog, you can see that the display of a part is not determined by a single color. Instead there are four types of colors; diffuse, emissive, specular, and ambient. You also define the shininess and how opaque the material will display. In addition to this color and appearance information, you can use the Texture tab of the dialog to define a bitmap that will be applied to the part. The Texture tab is shown below.

You can define combinations of the color, appearance, and texture and save the definition as a Style. The existing styles are listed on the left-hand side of the dialog. It's from this list of existing styles that you are allowed to choose a color to assign to a part.

The render style portion of the API provides equivalent functionality to the Color dialog and allows you to assign these styles to various objects. The object model for the render styles is shown below. The Document object supports a RenderStyles property that returns the RenderStyles collection object. Using this object, you can create a new RenderStyle object and access all existing RenderStyle objects.

Render Styles hierarchy

The sections that follow provide further detail on how to work with render styles.

Next page | Creating and Copying Render Styles
1, 2, 3, 4

Disclaimer


Render Styles - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Render Styles (colors)

Creating and Copying Render Styles

Render styles are saved within part and assembly documents. When assigning a style to a part, you are limited to the styles that have been defined within the part, or within the assembly the part has been placed within. A document always contains at least one render style. The style named "Default" is automatically created for new documents and cannot be deleted.

To create a new RenderStyle object, you use the Add method of the RenderStyles object. The only input required when creating a RenderStyle object is the name. Each RenderStyle object must have a unique name. All of the rendering characteristics for the new RenderStyle object are initialized to the same values as the RenderStyle object name "Default". Using the methods and properties on the new RenderStyle object, you can set any of the rendering characteristics. The sample code below illustrates creating a new RenderStyle object.

' Get a reference to the active document.
' This can be an Assembly or Part document.
Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

' Create the new RenderStyle object.
Dim oRenderStyle As RenderStyle
Set oRenderStyle = oDoc.RenderStyles.Add("Mud")

In addition to using the Add method to create a new RenderStyle object, you can also use the RenderStyle.Copy method to create a new RenderStyle. In this case you obtain an existing RenderStyle object and provide a new name. A new RenderStyle object is created with the new name and is initialized with the same rendering characteristics as the existing RenderStyle object. This RenderStyle object can also be edited by using its methods and properties.

' Get a reference to the active document.
' This can be an Assembly or Part document.
Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

' Get an existing RenderStyle object.  This uses error trapping to
' determine if the specified existing render style exists or not.
On Error Resume Next
Dim oOldRenderStyle As RenderStyle
Set oOldRenderStyle = oDoc.RenderStyles.Item("Gold Metallic")
If Err Then
    MsgBox "The style ""Gold Metallic"" does not exist."
    Exit Sub
End If
On Error GoTo 0

' Create a new render style by copying the existing one.
Dim oNewRenderStyle As RenderStyle
Set oNewRenderStyle = oOldRenderStyle.Copy("Dirty Gold")

Next page | Querying and Modifying Render Styles
1, 2, 3, 4

Disclaimer


Render Styles - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Render Styles (colors)

Querying and Modifying Render Styles

The previous two samples demonstrate creating new render styles, but the results aren't very useful because the new render styles are identical to existing render styles. In the case of the Add method, it is the same as the "Default" render style, and in the case of the Copy method, it is the same as the render style that was copied. The only thing unique about these render styles is their name. The next step when creating or copying a render style is to modify it so it has the desired characteristics. You do this by using the methods and properties of the RenderStyle object to set its rendering characteristics. The sample code below demonstrates this by creating a new render style and setting its characteristics.

Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

' Create the new render style.  This does error checking to
' see if the Add is successful.  If it is not successful it
' is probably because a style of that name already exists.
Dim oMudStyle As RenderStyle
On Error Resume Next
Set oMudStyle = oDoc.RenderStyles.Add("Mud")
If Err Then
    MsgBox "Failed to create mud.  It most likely already exists."
    Exit Sub
End If
On Error GoTo 0

' Set the various characteristics of the render style.
oMudStyle.Opacity = 1
oMudStyle.Reflectivity = 0
Call oMudStyle.SetAmbientColor(200, 150, 75)
Call oMudStyle.SetDiffuseColor(85, 40, 0)
Call oMudStyle.SetEmissiveColor(200, 140, 65)
Call oMudStyle.SetSpecularColor(255, 255, 255)

' Define the texture specific information.
oMudStyle.TextureFilename = "C:\Program Files\Autodesk\Inventor 6\Textures\surfaces\Misc1.bmp"
oMudStyle.TextureScale = 2.5
oMudStyle.TextureRotation = 0

Defining texture information for a texture is optional. If you want to remove texture information from an existing render style, you can set the TextureFilename property to an empty string. This is demonstrated below:

Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

' Get an existing render style.
Dim oMudStyle As RenderStyle
Set oMudStyle = oDoc.RenderStyles.Item("Mud (Fancy)")

' Set the texture filename to an empty string to
' remove the texture.
oMudStyle.TextureFilename = ""

Next page | Using Render Styles
1, 2, 3, 4

Disclaimer


Render Styles - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Render Styles (colors)

Using Render Styles

In addition to the RenderStyles and RenderStyle objects, which are specific to render styles, other objects also support properties that allow you to define which render style is assigned to them. These objects and their render style related support is described below.

Part Documents

Parts use rendering styles in several different ways.

  • The PartDocument object supports the RenderStyles property that gives you access to the RenderStyles object to allow you to access existing render styles and create new ones. This is demonstrated in the previous samples.
  • The Material object supports the RenderStyle property that allows you to define which render style is associated with a material. By default, the render style applied to a part is the render style associated with the material. The sample below gets a specific Material object and sets its render style.
    Dim oPartDoc As PartDocument
Set oPartDoc = ThisApplication.ActiveDocument

' Get a specific material.
Dim oMaterial As Material
Set oMaterial = oPartDoc.Materials.Item("Aluminum-6061")

' Get a specific render style.
Dim oRenderStyle As RenderStyle
Set oRenderStyle = oPartDoc.RenderStyles.Item("Orange")

' Assign a render style.
oMaterial.RenderStyle = oRenderStyle
  • By default, the render style associated with a part is the render style defined for the part's material. However, the user can choose to override this render style and apply any of the defined render styles. This is done in the user-interface using the Color combo box. Choosing "As Material" from this list specifies that the render style used should be the one that is associated with the part's material. This functionality is supported in the API through the PartDocument object's ActiveRenderStyle property. When the part is using the render style associated with the part material, this property will return the same RenderStyle object that the Material.RenderStyle property will return. If an override render style is used, then this property will return that style. You can set the override render style by setting this property to the desired render style as shown below.
    ' Apply a render style override to the part.
oPartDoc.ActiveRenderStyle = oPartDoc.RenderStyles.Item("Red")

    Setting this property to the same render style as the one used by the active material will result in the Color combo box displaying "As Material". This is demonstrated below.

    oPartDoc.ActiveRenderStyle = _
oPartDoc.ComponentDefinition.Material.RenderStyle
  • Parts also use render styles to apply overrides to features and faces. Setting the render style of features and faces is not currently supported by the API.

Assembly Documents

Assemblies use rendering styles to specify override styles for occurrences. When a part is first placed into an assembly, its render style is the style defined within the part. However, you can choose from the render styles defined within the assembly document to override an occurrence's assigned render style. This does not change the render style within the part but only the style of that particular occurrence in that assembly. The API supports this capability through the RenderStyles property of the ComponentOccurrence object as shown below.

Dim oAsmDoc As AssemblyDocument
Set oAsmDoc = ThisApplication.ActiveDocument

' Get a reference to an occurrence in the assembly.
Dim oOcc As ComponentOccurrence
Set oOcc = oAsmDoc.ComponentDefinition.Occurrences.Item(1)

' Set the render style for the occurrence.
oOcc.RenderStyle = oAsmDoc.RenderStyles.Item("Orange")

If the occurrence represents a subassembly, the override color is applied to all parts within the subassembly.

You can remove the override style from an occurrence by setting the RenderStyle property to nothing as shown below.

oOcc.RenderStyle = Nothing

When querying for the render style of an occurrence the RenderStyle property of the ComponentOccurrence object will return Nothing if there is no override style. In this case, you need to get the render style from the referenced part. This is demonstrated below.

Dim oAsmDoc As AssemblyDocument
Set oAsmDoc = ThisApplication.ActiveDocument

Dim oOcc As ComponentOccurrence
For Each oOcc In oAsmDoc.ComponentDefinition.Occurrences
    If oOcc.RenderStyle Is Nothing Then
        ' Check to make sure this occurrence is for a part and not
        ' an assembly.  An assembly doesn't have a render style.
        If oOcc.DefinitionDocumentType = kPartDocumentObject Then
            ' Get the render style from the document referenced by
            ' this occurrence
            Debug.Print oOcc.Name & " - " & _
                    oOcc.Definition.Document.ActiveRenderStyle.Name
        End If
    Else
        Debug.Print oOcc.Name & " - " & oOcc.RenderStyle.Name
    End If
Next

Next page | Back to the Overviews
1, 2, 3, 4

Disclaimer


Working with the Ribbon UI API

Autodesk Inventor Object Library Send comments on this topic.

Ribbon User Interface Customization using the API

Section |  |  | Title
1 |  |  | Understanding the User Interface
2 |  |  | API for User Interface Customization
 | 2.1 |  | ButtonDefinition
 | 2.2 |  | Ribbons
 | 2.3 |  | Ribbon Tabs and Panels
 |  | 2.3.1 | Accessing existing tabs and panels
 |  | 2.3.2 | Editing existing tabs and panels
 |  | 2.3.3 | Creating new tabs and panels
 | 2.4 |  | Specialized Controls
 | 2.5 |  | Application Menu, QAT and Help Controls
 | 2.6 |  | Customizing the Context Menu
 | 2.7 |  | Environments
 |  | 2.7.1 | Parallel Environments
 |  | 2.7.2 | Override Environments
3 |  |  | AddIn Handling of User Interface
 | 3.1 |  | FirstTime
 | 3.2 |  | Ribbon vs. Classic User Interface
 | 3.3 |  | Reset of the interface by the user

1 Understanding the User Interface

 Before beginning a discussion of the API as it relates to user interface customization, let us begin with an overview of Inventor's user interface to ensure that you understand all of the concepts and terms. First, let's look at Inventor's user interface from the perspective of an Inventor end-user. The various elements of Inventor's user interface are labeled and defined below.

The different parts of the user interface are numbered for identification:

  1. Ribbon Tab - A ribbon tab is a tab within a ribbon which the user can activate. It consists of panels which in turn consist of controls. There are two flavors of tabs - regular and contextual. A regular tab is always visible. A contextual tab is typically associated with an environment and is only visible when that environment is active. An example is the Sketch tab when a sketch is activated. Note that contextual tabs are colored differently.
  2. Ribbon Panel - A ribbon panel represents a grouping of controls within a ribbon tab. A panel can be hidden or undocked by the end user. A panel within a contextual tab cannot be undocked.
  3. Command Control - A command control represents a command (or a set of commands) in Inventor. There are various flavors such as a simple button, a combo-box, a split button control containing multiple commands, etc.
  4. Quick Access Toolbar (QAT) - A collection of controls that is customizable by the end user.
  5. File Browser (a.k.a. Application Menu) - A collection of controls that deal with file operations (such as Open, Save, Close, Print, etc.).
  6. Browser - The browser is most commonly used to display a tree that symbolically illustrates the contents of the active document. The browser is in fact an ActiveX container and can be used by programmers in many other ways besides displaying trees. For example, Inventor uses the browser for its interface to the library of standard parts.
  7. Context Menu - The context menu is a familiar Windows application interface. The context menu is displayed when the end-user clicks the right mouse button. The contents of the context menu vary depending on the position of the cursor when the right button is clicked.

All of these elements of the user interface are familiar to Inventor users. There is one other element of the user interface that is not as obvious to the end-user and that is an Environment. Inventor supports access to this functionality by the end-user and through the API. As before, let's look at the end-user's perspective of an environment.

Environments - Environments define a set of user interface elements. Environments are used to provide a specific set of commands when the user is performing a specific task. The four things that an environment defines are listed below.

  1. The access point of the environment (i.e. is it activated when the document opens or does the user activate it using a button in the Environments tab).
  2. The tabs that are displayed when the environment is activated.
  3. The tab that is active when the environment is activated.
  4. The commands that are disabled when the environment is activated.

The display of environments is controlled by Inventor and is tied to the activity currently being performed by the end-user. For example, when you open a part document, the Part environment is displayed to provide the user with the set of commands that are useful in creating parts. If you edit a sketch, the environment switches to the sketch environment to provide easy access to the commands that are the most useful in that context.

2 API for User Interface Customization

 Let's now look at the API that supports customization of the Inventor user interface.

Let's begin by looking at one of the basic components of almost all applications: commands. From the user interface perspective, a command is usually just a button. The end-user clicks the button to invoke the command. The role of the user-interface is to expose the button to the user and notify the owner of the command when the end-user clicks that button. Within the API, the object that supports this notification is the ButtonDefinition object.

2.1 ButtonDefinition

 The ControlDefinitions collection object supports an AddButtonDefinition method. The Add-In or a VBA client can create a ButtonDefinition for each of its commands. The ButtonDefinition has two roles. First, it supports the OnExecute event to notify whenever the button is clicked. Second, it contains all of the information that defines what the button will look like. The ButtonDefinition isn't a button but is referenced by the physical button and it provides the button with the information it needs to display itself. The ButtonDefinition can be referenced by multiple buttons and if the ButtonDefinition is changed, then any associated buttons will automatically change. The line below declares the variable used for the ButtonDefinition. This is typically defined as a global variable within a class module. Notice the use of the WithEvents keyword to enable listening to the OnExecute event.
Private WithEvents oButtonDefinition As ButtonDefinition

The creation of the ButtonDefinition objects is typically performed in the Activate method of an Add-In. Two of the arguments of the AddButtonDefinition method allow you to supply the small and large icons for the button. There are several techniques available to loading icons: load from an icon file, image control, resource file, etc. The icon arguments are optional and if not supplied the button will be contain the display name of the ButtonDefinition as text. You can also supply a normal size icon for both the normal and large icons. Inventor will scale the normal size if the end-user chooses to display large icons. For the icons you can use icon or bitmap files. Icon files are preferred because they define a transparent background color. Normal size icons are 16 pixels wide by 16 pixels high. Large icons are 32 pixels wide by 32 pixels high. If an icon of a different size is provided, Inventor will scale it to fit.

Supplying the icons for a button definition is only valid when your program is running in-process to Inventor. This is because of marshalling limitation that doesn't support passing the bitmap information between processes. This can be an issue when debugging an Add-In. Even though the Add-In is defined as an ActiveX DLL, when debugging it is actually running out of process and will fail when it attempts to create the button definition. You can temporarily work around this by editing your code to comment out the last two arguments. This will result in text only buttons but will allow you to continue debugging the rest of the Add-In.

The code below illustrates creating a ButtonDefinition. The AddButtonDefinition call provides arguments to allow the input of the information associated with a button. The first argument is the display name of the command. The second argument is the internal name of the command. This must be unique with respect to all other commands. It is recommended that you append command names with something that helps to ensure uniqueness. Some examples are your application or company name. The sample below uses a registered developer symbol that contains four unique characters that are registered through ADN (Autodesk Developers Network). The third argument is used to classify the type of command this button represents. This can be used by other Add-Ins to disable/enable certain commands. The fourth argument is a string which is the CLSID (a GUID) of an AddIn; this string can be ignored if you are programming in VBA. The remaining arguments are easily understood and can be identified in the sample below by the values being input.

Dim oControlDefinitions As ControlDefinitions
Set oControlDefinitions = oApp.CommandManager.ControlDefinitions

Dim oLargeIcon As IPictureDisp
Dim oSmallIcon As IPictureDisp
Set oLargeIcon = LoadPicture(App.Path & "\Large.ico")
Set oSmallIcon = LoadPicture(App.Path & "\Small.ico")

Set oButtonDefinition = oControlDefinitions.AddButtonDefinition( _
  "Display Name", "invrSampleCommand", _
  kShapeEditCmdType, "CLSID of the AddIn", _
  "Description Text", "Tooltip", _
  oSmallIcon, oLargeIcon, _
  kDisplayTextInLearningMode)

You can now listen to the OnExecute event on the ButtonDefinition object and react to user clicks. The ButtonDefinition object can be used by you and other Add-Ins to create a physical button on a toolbar or menu. All of the Inventor commands also expose their associated ButtonDefinition object to allow adding buttons to ribbon panels using the API.

2.2 Ribbons

 A ribbon is a collection of tabs. Inventor creates seven such ribbons on start-up (each based on a document type). The corresponding ribbon is displayed when a particular document type is activated. It is not possible to delete ribbons or create new ones through the API. Any modification or addition to the ribbon interface should start with obtaining the appropriate Ribbon object, based on the document type where you want to make the UI changes.

Following are the internal names of the 7 ribbons in Inventor:

  1. ZeroDoc
  2. Part
  3. Assembly
  4. Drawing
  5. Presentation
  6. iFeatures
  7. UnknownDocument

The following sample code demonstrates the retrieval of the ribbon associated with part documents:

.........
.........
' Get the ribbon associated with part documents
Dim oPartRibbon As Ribbon
Set oPartRibbon = oApp.UserInterfaceManager.Ribbons.Item("Part")

2.3 Ribbon Tabs and Panels

 A ribbon tab is a collection of panels. A ribbon panel is a collection of controls. Using the API, you can create new controls within a panel. Associated with the control is either a single ControlDefinition object or a collection of ButtonDefinition objects in the case of specialized controls, such as the split button. See section 2.4 for details on specialized controls.

When Inventor is started, it creates all of the tabs, panels and controls it requires. As Add-Ins are started, they also create their tabs, panels and controls.

2.3.1 Accessing existing tabs and panels

 All of the existing ribbon tabs and panels are accessible through the API. The following VBA macro iterates through all of them and prints the display name and internal name for each one to a text file ("C:\temp\RibbonTabsAndPanels.txt").

Public Sub PrintTabsAndPanels()

  Open "C:\temp\RibbonTabsAndPanels.txt" For Output As #1

  Dim oRibbon As Ribbon
  For Each oRibbon In ThisApplication.UserInterfaceManager.Ribbons
    Print #1, "Ribbon: " & oRibbon.InternalName

    Dim oTab As RibbonTab
    For Each oTab In oRibbon.RibbonTabs
      Print #1, " Tab: " & oTab.DisplayName & ", " & oTab.InternalName

      Dim oPanel As RibbonPanel
      For Each oPanel In oTab.RibbonPanels
        Print #1, " Panel: " & oPanel.DisplayName & ", " & oPanel.InternalName
      Next
    Next
  Next

  Close #1

End Sub

2.3.2 Editing existing tabs and panels

 You can access existing ribbon panels and edit them by adding and deleting controls. You can add a control at any position in the panel by specifying the name of an existing control next to which you want the control inserted. This is done by using the last two arguments of the AddButton method on CommandControls. The following sample code adds the button we previously defined to the end of the Measure panel in the Tools tab of a part document.

' Get the ribbon associated with the part document
Dim oPartRibbon As Ribbon
Set oPartRibbon = oApp.UserInterfaceManager.Ribbons.Item("Part")

' Get the "Tools" tab
Dim oTab As RibbonTab
Set oTab = oPartRibbon.RibbonTabs.Item("id_TabTools")

' Get the "Measure" panel in the Tools tab
Dim oPanel As RibbonPanel
Set oPanel = oTab.RibbonPanels.Item("id_PanelP_ToolsMeasure")

' Add a control to the Measure panel
Call oPanel.CommandControls.AddButton(oButtonDefinition, True)

2.3.3 Creating new tabs and panels

 As mentioned earlier, ribbon tabs come in two flavors- regular and contextual. When creating a new tab using the RibbonTabs.Add method, the tab flavor can be specified using the last argument of the method. A regular tab is always visible in it's parent ribbon. A contextual tab remains invisible until explicitly made visible (either by associating it with an environment or setting it's Visible property). The association of contextual tabs with environments is discussed in section 2.7.

The sample code below creates a new (regular) ribbon tab in the ribbon of a part document, a new ribbon panel within the tab and adds a button control using the ButtonDefinition we created in the previous sample.

' Set a reference to the user interface manager.
Dim oUIManager As UserInterfaceManager
Set oUIManager = oApp.UserInterfaceManager

' Get the ribbon associated with part documents
Dim oRibbon As Ribbon
Set oRibbon = oUIManager.Ribbons.Item("Part")

' Create a new tab
Dim oTab As RibbonTab
Set oTab = oRibbon.RibbonTabs.Add("My Tab", "invrMyTab", "CLSID of the AddIn", , , False)

' Create a new panel within the tab
  Dim oPanel As RibbonPanel
  Set oPanel = oTab.RibbonPanels.Add("My Panel", "invrMyPanel", "CLSID of the AddIn")

' Create a control within the panel
Call oPanel.CommandControls.AddButton(oButtonDefinition, True)

2.4 Specialized Controls

 As stated earlier, a control (CommandControl in API terminology) is based either on a single ControlDefinition or a collection of ButtonDefinitions. This section describes the controls based on the latter. Controls that are based on a single ControlDefinition (buttons, comboboxes, and macros) are not described here.
  1. Regular Pop-up (kPopupControl). This is the kind in which clicking the displayed control only pops up the control and does not fire a command. An example of this type of control is the Switch Windows' control available in the Windows panel of the View tab.
  2. MRU Split Button (kSplitButtonMRUControl). In this flavor of a pop-up control, we see one of the controls showing on the face of the pop-up. This control (that shows on the face of the pop-up) is always the Most Recently Used control in the pop-up. An example of this type of control is the Circle' drop down in the Sketch tab of the ribbon.
  3. Split Button (kSplitButtonControl). This is similar to the MRU split button control (3 above), except that the displayed control never changes. This is not very commonly used. But it deviates from the pure pop-up behavior of simply being a place holder. It also doubles up and hosts a possibly completely unrelated Control on its face. And this face never changes. An example of this type of control is the New File' split button drop down available in the Quick Access Toolbar.
  4. Button Pop-up (kButtonPopupControl). This control is similar to a popup control (1 above) except that the display shows the most recently used control. Note that clicking the displayed control only pops up the control and does not fire a command. An example of this type of control is the Display Mode' drop down (Shaded, Hidden Edge, Wireframe) available on the View' tab of the ribbon in parts and assemblies.
  5. Gallery (kGalleryControl). A control that presents a group of controls in a window. An example of this type of control is the gallery control available in the Symbols panel of the Annotate tab in drawings.
  6. Toggle Pop-up (kTogglePopup). A pop-up control that hosts a collection of toggle buttons. Note that clicking the displayed control only pops up the control and does not fire a command. An example of this type of control is the Object Visibility' control available in the Visibility panel of the View tab.

There are specific Add methods for creating these kinds of controls. For example, while creating an MRU Split Button control, you would use the CommandControls.AddSplitButtonMRU method and specify a collection of ButtonDefinition objects.

2.5 Application Menu, QAT and Help Controls

 In addition to ribbon panels, command controls can also be found in the application menu, the quick access toolbar (QAT) and the help menu. The API provides the ability to add/remove controls to/from these containers' as well. The Application and Help menus remain the same regardless of the active document type and are accessed using properties FileBrowserControls and HelpControls on the UserInterfaceManager object. The QAT controls are specific to each ribbon (document) type and are accessed using the QuickAccessControls property on the Ribbon object.

The following sample demonstrates adding commands to the application menu (a.k.a. File Browser):

Sub AddCommandsToFileBrowser()

  ' Set a reference to the user interface manager.
  Dim oUIManager As UserInterfaceManager
  Set oUIManager = ThisApplication.UserInterfaceManager

  ' Set a reference to the command manager.
  Dim oCmdManager As CommandManager
  Set oCmdManager = ThisApplication.CommandManager

  ' Get the application menu controls collection
  Dim oControls As CommandControls
  Set oControls = oUIManager.FileBrowserControls

  ' Get the "Zoom All" and "Home View" commands
  Dim oDef1 As ButtonDefinition
  Set oDef1 = oCmdManager.ControlDefinitions("AppZoomAllCmd")

  Dim oDef2 As ButtonDefinition
  Set oDef2 = oCmdManager.ControlDefinitions("AppIsometricViewCmd")

  ' Create button controls, positioned before the "Manage" control
  Call oControls.AddButton(oDef1, True, True, "Manage", True)
  Call oControls.AddButton(oDef2, True, True, "Manage", True)
  Call oControls.AddSeparator("Manage", True)

End Sub

2.6 Customizing the Context Menu

 A context menu is displayed when the end-user right-clicks the mouse. The OnContextMenu event sends a notification API clients before the context menu has been displayed to the end-user. The CommandBar object provided in the event represents the context menu that will be displayed. Clients can manipulate the contents of this command bar to control what commands are displayed in the context menu. Using the CommandBar object the client can iterate over the current contents of the context menu, delete controls, and add new controls.

To understand the context, the client can look at the contents of the SelectSet object of the active document to determine which entity the mouse was over when the mouse was clicked.

The following sample demonstrates the addition of a control to the context menu.

Private Sub oUserInputEvents_OnContextMenu(ByVal SelectionDevice As SelectionDeviceEnum, ByVal AdditionalInfo As NameValueMap, ByVal CommandBar As CommandBar)
  On Error Resume Next

  Dim oCmdManager As CommandManager
  Set oCmdManager = ThisApplication.CommandManager

  ' Check if the context menu has the 'Home View' command
  Dim oControl As CommandBarControl
  Set oControl = CommandBar.Controls.Item("AppIsometricViewCmd")

  If Not oControl Is Nothing Then
    Dim oCtrlDef As ControlDefinition
    Set oCtrlDef = oCmdManager.ControlDefinitions("AppZoomAllCmd")

    ' Add the "Zoom All" command before the home view command
    Call CommandBar.Controls.AddButton(oCtrlDef, oControl.index)
  End If
End Sub

2.7 Environments

 Environments are a mechanism within Inventor that attempts to simplify the user interface so that the end-user is presented with a limited set of commands that are appropriate for the task at hand. For example, when you activate a sketch within a part, the sketch environment is displayed. This environment provides access to the sketch related commands. When you finish the sketch and return back to the part, Inventor changes the active environment to the part environment.

The four aspects that make up an environment are listed below.

  1. The access point of the environment (i.e. does the user activate it using a button in the Environments tab or is it activated when the document opens).
  2. The tabs that are displayed when the environment is activated.
  3. The tab that is active when the environment is activated.
  4. The commands that are disabled when the environment is activated.

The first aspect refers to the two flavors of environments supported through the API - parallel environments and override environments.

2.7.1 Parallel Environments

 An environment is said to be a parallel environment if it's activation does not involve the change of the edit target.' For instance, activation of the Inventor Studio environment in a part document does not change the edit target (i.e. the part), and hence, it is considered to be a parallel environment.

The following sample code demonstrates the creation of a parallel environment for an assembly document. The creation of a contextual tab and associating it with the new parallel environment is also demonstrated.

' Get the Environments collection
Dim oEnvironments As Environments
Set oEnvironments = oUIManager.Environments

' Create a new environment
Dim oNewEnv As Environment
Set oNewEnv = oEnvironments.Add("My Environment", "invNewEnv")

' Get the ribbon associated with the assembly environment
Dim oRibbon As Ribbon
Set oRibbon = oUIManager.Ribbons.Item("Assembly")

' Create a contextual tab and a panel within it
Dim oTab As RibbonTab
Set oTab = oRibbon.RibbonTabs.Add("My Tab", "invMyTab", "CLSID of the AddIn", , , True)

Dim oPanel As RibbonPanel
Set oPanel = oTab.RibbonPanels.Add("My Panel", "invMyPanel", "CLSID of the AddIn")

Dim oDef As ButtonDefinition
Set oDef = oCmdManager.ControlDefinitions.Item("PartExtrudeCmd")

Call oPanel.CommandControls.AddButton(oDef, True)
' Associate the contextual tabs with the newly created environment
' The contextual tabs will only be displayed when this environment is active

Dim strTabs(0) As String
strTabs(0) = "invMyTab"

oNewEnv.AdditionalVisibleRibbonTabs = strTabs

' Make the "invMyTab" tab default for the environment
oNewEnv.DefaultRibbonTab = "invMyTab"

' Get the collection of parallel environments and add the new environment
Dim oParEnvs As EnvironmentList
Set oParEnvs = oUIManager.ParallelEnvironments

Call oParEnvs.Add(oNewEnv)

' Make the new parallel environment available only within the assembly environment
' A ControlDefinition is automatically created when an environment is added to the
' parallel environments list. The internal name of the definition is the same as
' the internal name of the environment.
Dim oParallelEnvButton As ControlDefinition
Set oParallelEnvButton = oCmdManager.ControlDefinitions.Item("invNewEnv")

Dim oEnv As Environment
For Each oEnv In oEnvironments
  If Not oEnv.InternalName = "AMxAssemblyEnvironment" Then
    On Error Resume Next
    Call oEnv.DisabledCommandList.Add(oParallelEnvButton)
  End If
Next

2.7.2 Override Environments

 An override environment replaces the default environment of a document. This results in the activation of the override environment (instead of the native, base environment) when the document is opened.

The sample code below sets the override environment for a document.

Dim oDocument As Document
Set oDocument = ThisApplication.ActiveDocument

Dim oOverrideEnv As Environment
Set oOverrideEnv = ....

' Set the override environment for the document
oDocument.EnvironmentManager.OverrideEnvironment = oOverrideEnv

3 AddIn Handling of User Interface

There are some simple rules that govern the overall handling of the extension of the Inventor UI by an AddIn. Though it is possible for even a VBA macro or some other non-AddIn-protocol based Third Party program to enhance or customize the UI, an AddIn enjoys a greater degree of management services provided by Inventor. This section details the pieces of the protocol expected to be followed by an AddIn.

3.1 FirstTime

 A Boolean value is passed into the AddIn at the time Inventor Activate's the AddIn. This is the FirstTime flag. If this flag is True then the AddIn recognizes that this is the first time it is being loaded and takes some specific action. It does not take these actions when this flag is False. In a nutshell, when the flag is True, the AddIn proceeds to create all of the objects under the UserInterfaceManager that it needs - Environments, RibbonTabs, RibbonPanels and Controls; when it is False, it only creates the objects under the CommandManager -ControlDefinitions and CommandCategories. In summary:

If FirstTime = True, then:
o Create ControlDefinitions and CommandCategories.
o Create Environments, RibbonTabs, RibbonPanels and Controls, as needed.

If FirstTime = False, then:
o Create ControlDefinitions and CommandCategories (Inventor will resurrect the Environments, RibbonTabs, RibbonPanels and Controls created the first time, and make the necessary associations as needed).

The latter state (FirstTime = False) does not imply that the AddIn is barred from tearing down or editing its UI on its own. It is still free to delete and add new UI at any time. However, it is highly recommended that the AddIn just build the UI once and relinquish control of it to Inventor and the end-user.
Versioning - Every AddIn maintains a registry entry called Version of type Long in its registry. Let us assume that a certain version of the AddIn was registered with Inventor and that the AddIn created its GUI. If a newer version of the AddIn is now registered with Inventor, and the value of the Version entry in the AddIn's registry is unchanged, the GUI that the previous version of the AddIn created is preserved and the FirstTime flag is reported as False during the AddIn's activate. This assumes that the CLSID of the AddIn remained the same across versions. A changed value of the Version entry will result in the clean-up of the previously created GUI and a value of True for the FirstTime flag during the AddIn's activate.

This realizes two goals - the first and most critical one is the allowance for the end-user to go about customizing the UI, replicating controls, creating new tabs and panels that contain the AddIn's commands, etc. Inventor keeps track of these changes across sessions. Having Inventor manage all of this, without requiring any Addin intervention makes this a much more streamlined and robust process.

The second goal that gets achieved is the robustness of handling the deletion and creation of the UI objects. We don't expect the AddIn to find all of the controls, tabs, panels, etc. that may have gotten created by it and further replicated and customized into the UI by the end-user. Inventor simply handles them by design.

3.2 Ribbon vs. Classic User Interface

 Inventor currently supports both of these user interface styles. Any AddIn adding to Inventor's user interface is expected to play well with both of these interface styles by appropriately extending the currently used style. The currently used style can be queried using the UserInterfaceManager.InterfaceStyle property.

The code in the Activate' of the AddIn should look something like the following:

Private Sub ApplicationAddInServer_Activate(ByVal AddInSiteObject As Inventor.ApplicationAddInSite, ByVal FirstTime As Boolean)

  ' Save a reference to the Application object.
  ' Variable assumed to be declared in global scope.
  Set oInventorApp = AddInSiteObject.Application

  Dim oUIManager As UserInterfaceManager
  Set oUIManager = oInventorApp.UserInterfaceManager

  ' Create ControlDefinition objects
  ' Create and populate CommandCategory objects
  If FirstTime = True Then
    If oUIManager.InterfaceStyle = kRibbonInterface Then
      ' Create ribbon interface.
    Else
      ' Create classic (legacy) interface.
    End If
  End If
End Sub

3.3 Reset of the interface by the user

Inventor allows the user to reset the user interface to the factory defaults. When this action is taken by the user, it is expected that AddIns reset their interface to factory defaults as well. This is done by responding to the OnResetRibbonInterface event.

As a result of a reset, Inventor performs the following actions:

  1. All custom (non-built-in) tabs and panels are deleted.
  2. All built-in tabs and panels are restored to factory defaults.
  3. The application menu and QAT are restored to factory defaults.

The actions you need to take in the OnResetRibbonInterface event are:

  1. Recreate your custom tabs and panels.
  2. Re-add your controls to built-in panels as needed.
  3. Re-add your controls to the application menu and QAT as needed.

Next page | Back to the Overviews

Disclaimer


Autodesk Inventor SDK - Samples

Autodesk Inventor SDK - Samples Send comments on this topic.

SDK Samples and Projects

SDK

The Autodesk Inventor Software Developer Kit includes samples, tools and documentation to demonstrate and describe the functionality that is available in the Inventor API. The SDK directory will be created when Inventor is installed. The location of the SDK directory depends on the Operating System on which Inventor is installed. On Windows XP, the SDK will be installed in ...\Inventor 20xx\SDK and on later versions of Windows the SDK will be installed in C:\Users\Public\Documents\Autodesk\Inventor 20xx\SDK.

The Inventor SDK includes samples and tools to demonstrate and describe the functionality that is available in the Inventor API.

Location of the SDK:
Windows XP: <Inventor install folder>\SDK

Windows Vista: C:\Users\Public\Documents\Autodesk\Inventor <version>\SDK

Windows 7: C:\Users\Public\Documents\Autodesk\Inventor <version>\SDK

NOTE: The contents of the SDK have been packaged into two separate (msi) installers. Only the installer files for the two components described below are created when Inventor is installed. The components themselves would have to be extracted by running the corresponding installer files before they can be used.

Developer Tools
Samples and tools intended to help developers write applications using the Inventor API. This component can be installed using the DeveloperTools.msi installer file. When this component is installed, it creates the directories that contain the samples and tools.

The DeveloperTools\Samples directory contains the samples. The samples are provided in different languages - VC++, VB (6.0 and .NET) and VC#.NET which are categorized under appropriate folder names in the samples directory.

The DeveloperTools\Tools directory contains the tools - EventWatcher, ThumbnailView and Wizards.

For more information about the samples and tools, please refer to the individual "ReadMe.txt" file associated with each sample or tool.

The wizards need to be installed (using the DeveloperTools\Wizards\InventorWizards.msi file) before they can be used. The wizards installer creates code templates that developers can use to quickly create applications that target the Inventor API. The templates are integrated into the Microsoft Visual Studio environment. Therefore, you can use the templates to create projects in VC++ (6.0, 2003, 2005 and 2008), VB (6.0, 2003, 2005 and 2008) and VC# (2003, 2005 and 2008). The wizards need to be installed prior to using them and you need to have Microsoft Visual Studio installed first in order to be able to install the wizards.

Starting with Inventor 2009, a signed and registered Primary Interop Assembly (PIA) is being delivered with Inventor. The file is Autodesk.Inventor.Interop.dll. When Inventor is installed, this PIA is installed into the Global Assembly Cache (GAC). All clients that write code using any of the .Net languages should use this assembly. Going forward, we will continue to deliver a PIA for each release. They are versioned with respect to the Inventor version. For instance, when you develop for Inventor 2011, you'l need to update your reference to use the version 15.0.0.0. They are not versioned relative to the build so the reference update only needs to be done once for each release. All that will be required to move to using the PIA is just to change the reference and recompile. However, we did change one of the options from the default when generating the PIA. This provides for more correct type information. The primary change here is that instead of arrays being declared as generic System.Array types they're now type specific, i.e. Double(). They're easily corrected and should show up at compile time.

The object model diagram that shows the hierarchy of all objects in the Inventor API is provided in: DeveloperTools\Docs\

User Tools
Tools to help automate certain tasks for Inventor users that are not available in the Inventor product itself but can be accomplished using an Inventor API application. This component can be installed using the UserTools.msi installer file. When this component is installed, it creates the directories for the tools that include AddIns and standalone executables. The binaries for the tools are installed which users can utilize directly without having to compile any source code. The source code for the tools are also installed which users can modify to modify the behavior of these tools.

The user tools include the AddIns: DrawingTools, GeneralTools, DerivedPart_SP and AutoCustomize and the executables: ColorSchemeEditor, CopyDesign, PartNumberModifier and UpdateThreadDesignation.

For more details regarding these tools, please refer to the individual ReadMe.txt file associate with each tool.

© Autodesk Inc. 2009. All Rights Reserved.


Sketches - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Sketches

Introduction

Sketches are an extremely important component of Inventor. All 2D work in Autodesk Inventor is performed using sketches. Sketches are used to draw geometry that will define the profile of a feature. Sketches are also used within drawings to design borders and title blocks, and when drawing on a sheet or within a view. All 2D geometry in Autodesk Inventor is created using sketches.

A sketch can be thought of as a 2D plane that contains any number of 2D entities. In a 3D environment like the part environment, the 2D sketch plane is positioned within 3D space. Because a sketch is 2D, the sketch entities it contains are true 2D objects. That is, any coordinates defined for 2D sketch entities need only their X and Y coordinates defined. Because a sketch exists within 3D space, it has its own 2D coordinate system and all creation and query of entities within a sketch are with respect to the sketch coordinate system.

Sketches can contain several different kinds of 2D entities, depending on the type of document they are used in. In Part documents, you can create sketches that contain arcs, circles, elliptical arcs, ellipses, lines, splines, geometric constraints, and dimension constraints. Methods for accessing and creating sketches in Part documents (called PlanarSketches) are discussed in Sketches in Part Documents. Sketches in drawings support the same entities as part sketches, but in addition also help provide access to text and have some special requirements with regard to editing. Methods for accessing and creating sketches in drawing documents are discussed in Sketches in Drawing Documents.

A sketch can be thought of as a container for 2D entities. The sketch itself does not add any information to the 2D entities. For example, look at the sketch shown below. It contains several different types of sketch entities: lines, circles, splines, and dimension and geometric constraints. The sketch defines only the 2D coordinate system for these entities. The fact that there are multiple outlines and some are connected and some aren't isn't information that the sketch is concerned with. That type of information is defined by profiles, which are discussed in more detail later.

Some sketch concepts are slightly different when using the API than when using sketches interactively. The API exposes the sketches at a lower level than is exposed through the user interface. Most of the sketch concepts learned when using Autodesk Inventor interactively carry over to the API, but there are some differences that need to be understood to make using the sketch portion of the API more intuitive.

One difference between the API and interactive use of sketches is in their creation. When interactively defining a sketch, you are able to gain a significant amount of control of the placement because of the automatic inference Autodesk Inventor does as you sketch. As an example, let's look at the simple sketch shown below. To create the sketch the only inputs required from you are a click to start line 1, a click to create line 1, a click to create line 2, a drag to create arc 3, a click to create line 4, and finally a click to create line 5. All that was required were four clicks and a drag to define the entire profile. Let's look in a little more detail at what actually happened during this process.

Sketch created interactively

  • To create line 1, you click the mouse to define the starting point. As you move the mouse, Autodesk Inventor displays a glyph to indicate when the line will be inferred to be horizontal or vertical. After clicking the mouse to define the second point, a horizontal constraint is automatically applied.
  • Since you're still in the same sequence within the Line command, ending line 1 has started line 2. A coincidence between them has been inferred. As you move the mouse Autodesk Inventor will indicate when line 2 is begin inferred to be perpendicular to line 1. When the mouse is clicked to define line 2, the coincident and perpendicular constraints are automatically applied.
  • Arc 3 is created by dragging the mouse off the end of line 2. A coincidence and tangency to line 2 is inferred. After line 3 is created the coincident and tangent constraints are automatically placed.
  • Line 4 is started by finishing arc 3. Using the glyphs, Autodesk Inventor notifies you when the line is tangent to the arc and parallel to line 1. After clicking to define line 4, the coincident, tangent, and parallel constraints are automatically placed.
  • Line 5 is started by finishing line 4. As you move over the end of line 1, a glyph is displayed telling you you're over the end. Clicking over the end indicates that you want the lines connected. A glyph is also displayed showing that a parallel constraint to line 2 is being inferred. After clicking, the coincident constraints to lines 1 and 4 are automatically placed and the parallel constraint to line 2 is automatically placed.

Four clicks and a mouse drag resulted in the creation of 5 sketch entities and 11 constraints.

Now let's look at the same construction from the point of view of the API. There are several differences between interactively creating sketches and creating them through the API. First, there is no inference of constraints when using the API. Everything must be explicitly defined when using the API. Inference is entirely based on the context of the command and how the user moves the mouse during the command. The API methods do not have this type of context information.

Another significant difference between the API view and the user interface view is that the API exposes some of the underlying details of the sketch that are hidden in the user interface. The primary feature being hidden is that all sketch geometry is actually dependent on sketch points. For example, when sketching two lines interactively, you click the mouse twice to define the two points for the first line and click again to define the second line.

Interactive line sketch example

The result to the end-user is two lines that have a coincident constraint holding them together. The actual result is that you have created three sketch points, two lines, and four coincident constraints. Sketch points are the only sketch entities that can exist on their own. All other types of sketch entities are dependent on points to define their position. The sketch entities are tied to the points by coincident constraints. The picture below illustrates the true situation.

API line sketch example

To simplify working with sketches, the user interface hides most of these sketch points. Attempting to hide these points in the API would have resulted in many inconsistencies, and as you'll see having access to these points simplifies many API functions.

Let's look at creating the original example using the API to see the differences.

Sketch created using API

If you look at the online help for the AddByTwoPoints method of the SketchLines object you'll see the method takes two points to define the line.

AddByTwoPoints(StartPoint As Object, EndPoint As Object) As SketchLine

Notice that the type of object expected as input for the points is defined as "Object." This allows you to input either a Point2d object or an existing SketchPoint object. A Point2d object describes a location on the sketch. When you provide a Point2d object as input a SketchPoint is created at that location and the line is attached to the sketch point with a coincident constraint. In the case where a SketchPoint is input, the line is attached directly to the input sketch point using a coincident constraint.

Because sketch entities are always dependent on sketch points, the API provides direct access to the driving sketch points. To see how this works, let's look at the code that will create the previous sketch. This sample assumes that a sketch has somehow already been obtained. (This will be discussed in more detail in the next section.)

When you define the location of sketch entities using coordinates on the sketch, they are defined using Point2d objects. These objects don't define a graphical point but only a coordinate in 2D space. These lines set a reference to the TransientGeometry object to facilitate its use later in the program.

Dim oTransGeom As TransientGeometry
Set oTransGeom = ThisApplication.TransientGeometry

This defines two Point2d objects that will be used to define the ends of the line.

Dim oCoord1 As Point2d
Set oCoord1 = oTransGeom.CreatePoint2d(0, 0)
Dim oCoord2 As Point2d
Set oCoord2 = oTransGeom.CreatePoint2d(5, 0)

This creates the actual SketchLine object. The two inputs are the two Point2d objects. Automatically, two sketch points are created at those locations and the line is attached to them with coincident constraints.

Dim oLines(1 To 4) As SketchLine
Set oLines(1) = oSketch.SketchLines.AddByTwoPoints(oCoord1, oCoord2)

This creates the second sketch line. In this case a SketchPoint and a Point2d object are input as the start and end points of the line. The SketchPoint is obtained by asking the first line for its end sketch point.

Set oCoord1 = oTransGeom.CreatePoint2d(5, 3)
Set oLines(2) = oSketch.SketchLines.AddByTwoPoints(oLines(1).EndSketchPoint, _
                                                   oCoord1)

This creates the arc. The center and end point are defined using Point2d objects and the start point is defined using the end sketch point from the previous line.

Set oCoord1 = oTransGeom.CreatePoint2d(4, 3)
Set oCoord2 = oTransGeom.CreatePoint2d(4, 4)
Dim oArc As SketchArc
Set oArc = oSketch.SketchArcs.AddByCenterStartEndPoint(oCoord1, _
                                            oLines(2).EndSketchPoint, oCoord2)

This creates the third line and connects it to the arc by inputting the arcs end sketch point.

Set oCoord1 = oTransGeom.CreatePoint2d(0, 4)
Set oLines(3) = oSketch.SketchLines.AddByTwoPoints(oArc.EndSketchPoint, _
                                                   oCoord1)

This creates the final line using sketch points from the first and last line as inputs.

Set oLines(4) = oSketch.SketchLines.AddByTwoPoints( _
                                           oLines(1).StartSketchPoint, _
                                           oLines(3).EndSketchPoint)

At this point you will have a sketch that looks similar to that shown in the previous figure, but if you attempt to manipulate the sketch at all you will notice that the only constraints are the coincident constraints tying everything together. Because of this, the lines will not stay horizontal and vertical, and the lines will not remain tangent to the arc. The following code will add the same constraints that were placed automatically when interactively creating the sketch.

Call oSketch.GeometricConstraints.AddHorizontal(oLines(1))
Call oSketch.GeometricConstraints.AddPerpendicular(oLines(1), oLines(2))
Call oSketch.GeometricConstraints.AddTangent(oLines(2), oArc)
Call oSketch.GeometricConstraints.AddTangent(oLines(3), oArc)
Call oSketch.GeometricConstraints.AddParallel(oLines(1), oLines(3))
Call oSketch.GeometricConstraints.AddParallel(oLines(4), oLines(2))

If you edit the sketch now it will have the behavior you expect.

All other types of sketch entities are placed in a similar way. From this you can see that sketch entities are dependent on sketch points. When creating sketch entities you can define coordinate points, but sketch points will automatically be created for the entity to be tied to. When modifying sketch entities, most modifications must be performed on the sketch points they're tied to. For example, to move a line you need to move the two sketch points it is tied to.

You can also see that when creating sketch entities through the API there is no constraint inference (except for the coincident constraint placement when you use a sketch point as input). When creating sketches using the API you'll need to explicitly create the geometric constraints.

The API also exposes additional constraint types that don't have corresponding commands. You implicitly create these constraints as the result of using some commands. For example, the offset constraint is created as a result of using the Offset command. Here's a complete list of all of the geometric constraints exposed through the API. (More information can be found in the API reference guide.)

CoincidentConstraint
Ties a sketch point to any other sketch entity.
CollinearConstraint
Makes a line or the specified axis of an ellipse collinear to another line or ellipse axis.
ConcentricConstraint
Makes a circle, arc, ellipse, or elliptical arc concentric to another circle, arc, ellipse, or elliptical arc.
EqualLengthConstraint
Makes two lines equal in length.
EqualRadiusConstraint
Makes the radius of a circle or arc equal to another circle or arc.
GroundConstraint
Causes any sketch entity to be fully constrained.
HorizontalAlignConstraint
Makes two sketch points align along the same horizontal axis. In other words, the two sketch points will have the same Y coordinate value.
HorizontalConstraint
Causes a lines or the specified axis of an ellipse to be horizontal.
MidpointConstraint
Causes a sketch point to be positioned at the midpoint of a line.
OffsetConstraint
Makes four entities behave in a way where two are the result of offsetting from the other two.
ParallelConstraint
Makes a line or the specified axis of an ellipse parallel to another line or ellipse axis.
PatternConstraint
Defines the relationship between entities that were the result of creating a pattern.
PerpendicularConstraint
Makes a line or the specified axis of an ellipse perpendicular to another line or ellipse axis.
SplineFitPointConstraint
Defines the connection between a spline and the sketch points it is tied to.
SymmetryConstraint
Causes two sketch entities of the same type to be symmetric about a line.
TangentSketchConstraint
Causes two sketch entities to be tangent to each other.
VerticalAlignConstraint
Makes two sketch points align along the same vertical axis. In other words, the two sketch points will have the same X coordinate value.
VerticalConstraint
Causes a lines or the specified axis of an ellipse to be vertical.

The list below illustrates the entire set of dimension constraints exposed by the API.

DiameterDimConstraint

Diameter dimension constraint

EllipseRadiusDimConstraint

Ellipse radius dimension constraint

OffsetDimConstraint

Offset dimension constraint Offset dimension constraint

RadiusDimConstraint

Radius dimension constraint

TangentDistanceDimConstraint

Tangent distance dimension constraint Tangent distance dimension constraint Tangent distance dimension constraint

ThreePointAngleDimConstraint

Three point angle dimension constraint

TwoLineAngleDimConstraint

Two line angle dimension constraint

TwoPointDistanceDimConstraint

Two point distance dimension constraint

Next page | Sketches in Part Documents
1, 2, 3, 4

Disclaimer


Sketches - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Sketches

Sketches in Part Documents

Sketches can contain several different kinds of entities, depending on the type of document they are used in. In Part documents, you can create sketches that contain arcs, circles, elliptical arcs, ellipses, lines, splines, geometric constraints, and dimension constraints. The previous example began by assuming you had obtained a sketch somehow. This section will discuss some methods of obtaining existing sketches and creating new sketches.

Many programs that deal exclusively with sketches will not want to create a sketch but instead will want to access the currently active sketch. In the case where a sketch is not active you will need to know this so you can handle it gracefully. Determining if a sketch is active can be accomplished using the ActiveEditObject property of the Application. This property returns the object that is currently active for edit. Currently this can be any of the various document types or a sketch. The sample code below illustrates checking to see if a sketch is active and if one is active, setting a reference to it. If a sketch isn't active, it displays a message telling the user a sketch must be active.

' Determine if a sketch is active.
If Not TypeOf ThisApplication.ActiveEditObject Is Sketch Then
    MsgBox "A sketch must be active."
    Exit Sub
End If

' Set a reference to the active sketch.
Dim oSketch As Sketch
Set oSketch = ThisApplication.ActiveEditObject

The Sketches collection object also provides access to all of the existing sketches in a document. Through this you can obtain any existing sketch, and if you know its name you can access it directly using the Item method of the Sketches collection object. The code below iterates through all of the sketches in the document and prints their names.

Dim oSketch As Sketch
For Each oSketch in oPartDoc.ComponentDefinition.Sketches
    Debug.Print "Sketch: " & oSketch.Name
Next

This code sets a reference to the sketch named "Sketch2." If a sketch named "Sketch2" does not exist in the part the call of the Item property will fail. The On Error statement allows you to check for and handle this error.

' Enable error trapping
On Error Resume Next

Dim oSketch As Sketch
Set oSketch in oPartDoc.ComponentDefinition.Sketches.Item("Sketch2")
If Err Then
    Err.Clear
    MsgBox "A sketch named ""Sketch2"" does not exist."
End If

' Turn off error trapping
On Error Goto 0

When creating models you'll usually need to create sketches. The Sketches collection supports two methods for creating a sketch. The Add method works identically as the 2D Sketch command. That is, you provide a planar entity, (a work plane or planar face) as input and the sketch is created. It uses built-in logic to determine the orientation of the sketch on the selected entity. Sometimes this is acceptable, but unlike the end-user who is working visually with the system and can easily see and react to the default orientation, you usually need explicit control of the orientation of the sketch. The AddWithOrientation method provides this control.

Let's look at an example to see why controlling the orientation can be important. This will also help to explain the concept of drawing on a 2D plane that is positioned within 3D space. In this case, we want to create the part shown below.

The part consists of two extrusion features: one to create the base block and another to create the pocket.

The code below creates the first extrusion. (The profile creation step is discussed in detail in a subsequent section.)

' Set a reference to the component definition.
Dim oPartCompDef As PartComponentDefinition
Set oPartCompDef = ThisApplication.ActiveDocument.ComponentDefinition

' Create a new sketch.
Dim oSketch As Sketch
Set oSketch = oPartCompDef.Sketches.Add(oPartCompDef.WorkPlanes.Item(3))

' Draw a rectangle.
With ThisApplication.TransientGeometry
    Call oSketch.SketchLines.AddAsTwoPointRectangle( _
                                        .CreatePoint2d(0, 0), _
                                        .CreatePoint2d(5, 3))
End With

' Create a profile.
Dim oProfile As Profile
Set oProfile = oSketch.Profiles.AddForSolid

' Create the extrusion feature.
Dim oExtrude As ExtrudeFeature
Set oExtrude = oPartCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                    oProfile, 2, kPositiveExtentDirection, kJoinOperation)

To create the sketch for this feature, the Sketches.Add method is used. This is the method that doesn't provide control over the orientation. You'll notice that the input plane provided is an existing work plane. The first three work planes in the WorkPlanes collection are the three that exist in every part. The first represents the YZ plane, the second the XZ plane, and the third the XY plane. (This is the same order as they appear in the Browser.) When a sketch is created with the Add method and a work plane is used as input, the sketch inherits the orientation and origin from the work plane. In this case, since it's the XY base work plane the origin will be at (0,0,0) and the X and Y directions of the sketch will be in the same directions as the X and Y axes of the model. The result after the creation of this feature is shown below, and the sketch used is highlighted.

Highlight sketch use

The creation of the next sketch becomes more interesting. It's important to control its orientation and origin so the coordinates used to define the position of the rectangle will be in the correct position. In this case, we want to create a sketch that will be positioned as shown below.

Sketch in position

The following code creates a sketch in the desired position and uses the sketch to create the extrusion for the pocket.

' Create a sketch on the end face using an existing work axis
' and the origin work point.
Set oSketch = oPartCompDef.Sketches.AddWithOrientation( _
                          oExtrude.EndFaces.Item(1), _
                          oPartCompDef.WorkAxes.Item(1), True, True, _
                          oPartCompDef.WorkPoints.Item(1), False)

' Draw a rectangle.
With ThisApplication.TransientGeometry
    Call oSketch.SketchLines.AddAsTwoPointRectangle( .CreatePoint2d(1, 1),
                                                    .CreatePoint2d(4, 2))
End With

' Create a profile.
Set oProfile = oSketch.Profiles.AddForSolid

' Create the extrusion feature.
Set oExtrude = oPartCompDef.Features.ExtrudeFeatures.AddByDistanceExtent( _
                   oProfile, 0.75, kNegativeExtentDirection, kCutOperation)

The interesting portion of this code sample is the AddWithOrientation method call. This allows you to create a sketch and fully define its orientation. The first argument is the face, which is obtained directly from the previous feature. The second argument is used to the define the X axis. In this case the system X work axis is provided as input. The third argument specifies if the direction of the sketch X axis should be in the same direction as the entity provided as the second argument. The fourth argument specifies if the axis being defined is the X or Y axis. The fifth argument defines the origin of the sketch. In this sample the system origin work point is input. The final argument defines whether the edges of the input face should be copied onto the sketch, (as is done when creating a sketch interactively).

By explicitly defining the sketch you now know the correct coordinates to input to create the rectangle so it is oriented correctly, as is shown below.

To help in diagnosing problems where sketch entities are not being drawn where expected, you can view the origin and orientation of an existing sketch by editing the sketch interactively. If the display setting for the "Coordinate System Indicator" is enabled on the Sketch tab of the "Application Options" dialog, a triad will be displayed when the sketch is being edited. The triad is positioned at the sketch's origin and is oriented to show the X and Y axes of the sketch.

Next page | Profiles in Part Documents
1, 2, 3, 4

Disclaimer


Sketches - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Sketches

Profiles in Part Documents

Another important concept that's not explicitly exposed through the user interface is the concept of profiles. A sketch is essentially just a container for 2D entities and their associated constraints. The sketch itself does not define connected sets of entities that can be used by a feature to define its shape. This information is defined by profiles. You can create the following sketch in Autodesk Inventor.

When creating an extrude feature, the first step is to define the profile. This is done interactively by moving the mouse within the different closed areas and clicking. Any combination of the following three shapes can be used to define the profile of the feature.

In the API, the profile is an explicit object that you can create to provide input to features and can also obtain from existing features. A profile is always associated with a particular sketch and essentially adds topological information to the sketch. Coincident constraints between sketch geometry controls which shapes can be defined from a given sketch. For example, if you create a sketch containing the two circles shown in the following figure and use this sketch for an extrusion, you can only select the inside of the circles.

However, if you place sketch points at the intersections of the circles and tie the points to the circles using coincident constraints, you can now achieve any combination of the following three shapes.

The API supports two methods for creating profiles. These are AddForSolid, which was used in the previous sample code, and AddForSurface. These two methods simplify the creation of the profiles for the developer. Generally, when creating profiles programmatically, it is easiest to define the final result. An end user may find it more convenient to extract existing geometry, perform trimming, edit dimension values, and other similar operations to arrive at the desired result. Also, when creating sketches interactively, the edges of a selected face are automatically projected onto the profile. This results in extra geometry that you may not end up using. In a workflow where additional geometry is created, designers need more control over how profiles are created so they can define which geometry to use in the creation of the profile. Developers typically doesn't require any intermediate geometry, but create the correct geometry to begin with.

The two profile creation methods provided by the API have optional arguments. Called with no arguments, they examine all of the geometry in the sketch and create the profile. The AddForSolid method checks for closed profiles that can be used in creating solid features. The AddForSurface allows open profiles that can be used for creating surfaces.

Optional Arguments

The AddForSolid method supports a Curves argument. This argument is an ObjectCollection of sketch curves. If supplied, this method creates a profile consisting of only those paths that contain all the sketch curves contained in the object collection. If not specified, all the possible profile paths are included.

The AddForSurface method supports a Curve argument. This argument is a sketch curve. If supplied, this method creates a profile consisting of a path that contains all sketch curves that are connected to the input curve. If no other curve is connected to the input curve, the path contains just the input curve. If not supplied, the method creates a profile by examining the contents of the sketch and creating a single connected path. The result can be either open or closed.

The AddForSolid method supports a Combine argument. This specifies whether to combine the profile paths obtained when this method is used to create a new profile. For instance, take the example of a sketch containing two concentric circles. If this argument is specified to be true, the resulting profile will contain two profile paths, and the profile path corresponding to the inner circle will have its AddsMaterial flag set to false. Hence, the resulting profile is a circular disc with a circular cut-out. If the Combine flag is specified to be false, the resulting profile will contain 2 profile paths with the AddsMaterial flag set to true for both paths.

The AddsMaterial flag indicates whether the profile path causes material to be added or subtracted from the area defined by the profile. If specified to be true, the profile path adds material. A feature such as an extrusion would use the profile path.

Profiles versus sketches

Profiles are used as input when creating features and are also important when querying existing features. From sketch-based features you can obtain the profile that defines its shape. Just having a sketch isn't enough because it's the profile that adds topology information to a sketch. Let's look at the following example to see what information a profile provides. The sketch shown on the left was used to create the single extrusion feature shown on the right.

Extrusion sketch and resulting figure

The profile obtained from the feature contains two ProfilePath objects, which are highlighted in the following figure. Each ProfilePath object returns a list of ProfileEntity objects. The ProfilePath returns the ProfileEntity objects in the order of how they are connected to each another. The ProfilePath also tells you if the path is open or closed and if it adds or removes material from the profile.

The ProfileEntity objects provide information about each piece of a ProfilePath. The ProfileEntity objects are oriented so they are connected head-to-tail to one another. ProfileEntity objects don't exist graphically within Autodesk Inventor but are simply an intermediate step between the sketch and the feature. A ProfileEntity returns the underlying sketch entity and the two sketch points that define its start and end. The underlying sketch entity will in many cases be different from the profile entity.

Let's look in detail at the previous example. The sketch that was used contains seven lines and one arc, plus all of the sketch points and various constraints tying it all together. From this sketch a single profile was created and used as input for the extrude feature. The profile consists of two ProfilePath objects, which when used for the extrusion resulted in a single solid with two enclosed volumes, as shown in the following image.

Extrusion sketch and resulting figure

The preceding profiles are straightforward, but others are less so. Take the following sketch as an example - calling AddForSolid with no arguments would not necessarily create the desired profile paths. Using the combine argument and/or the delete method of the ProfilePath object allows a greater degree of control over what constitutes the profile.

Extrusion sketch and resulting figure

Note: When editing sketches through the user interface, the user enters sketch edit mode. Leaving this mode automatically causes model features to be recomputed. Through the API, sketches can be modified at any time. Therefore the PlanarSketch object has a method, UpdateProfiles, that causes model features to be recomputed.

A ProfilePath consists of a set of ProfileEntity objects. For example, the profile path highlighted in the following figure consists of three ProfileEntity objects. A ProfileEntity object provides access to its underlying sketch entity and also a transient geometry object that represents the actual geometry of the ProfileEntity. This is frequently different from the geometry of the underlying sketch entity for two reasons. First, the profile entity may consist of just a portion of the sketch entity. The following figure illustrates one of the profile's paths (red) and the underlying sketch entities (green). The two profile entities that represent the lines are shorter than the sketch lines they're based on. The ProfileEntity also returns the two sketch points that define its extent along the sketch entity.

ProfilePath and sketch entity

The second reason the geometry of the profile entity might be different from the geometry of the sketch entity is that the profile entities are returned such that they're connected head to tail. There is no implied direction to sketch entities. Because of this the profile entity might go in the opposite direction from the underlying sketch entity.

Next page | Sketches in Drawing Documents
1, 2, 3, 4

Disclaimer


Sketches - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Sketches

Sketches in Drawing Documents

There are two principal uses for sketches in drawing documents. The first are overlay sketches that are placed on the sheet or attached to a drawing view. The second are sketches used in the definition of drawing aid objects, such as border definitions, title block definitions, and sketched symbol definitions. There are subtle behavioral differences between these two sketch uses, and between sketches in drawing documents versus those in part documents.

An important difference between sketches in drawing documents versus those in part documents is that drawing sketches must be placed into an edit mode before changes are allowed to the sketch contents. This edit mode is equivalent to the sketch environment being activated in the user interface.

For sheet overlay and drawing view sketches, this is done by calling the Edit method on the DrawingSketch object. To leave edit mode, call the ExitEdit method. The code below places the first sheet overlay sketch on the active sheet in edit mode.

' Determine if there are any sheet overlay sketches.
Dim oSketches As DrawingSketches
Set oSketches = ThisDocument.ActiveSheet.Sketches
If oSketches.Count = 0 Then
    MsgBox "Active sheet does not contain any overlay sketches."
    Exit Sub
End If

' Set a reference to the first sketch.
Dim oSketch As DrawingSketch
Set oSketch = oSketches.Item(1)

' Place the sketch in edit mode.
oSketch.Edit

' Make changes to the sketch contents here.

' Return from edit mode.
oSketch.ExitEdit

To edit the sketch of a drawing aid definition, the definition object must be placed into edit mode which is done by calling the Edit method on the definition object (BorderDefinition, TitleBlockDefinition, or SketchedSymbolDefinition), not the DrawingSketch. Calling the Edit or ExitEdit method on the DrawingSketch owned by a drawing aid definition (obtained from the Sketch property on, for example, the BorderDefinition object) will always fail. The Edit method and drawing aid definitions has a single out argument which is the DrawingSketch that is in edit mode. Note that this is not a reference to the same sketch obtained from the drawing aid's Sketch property, but is a temporary copy of the definition's sketch on a temporary sheet that is activated for the edit operation. The code below places a border in edit mode.

' Get the desired border.
Dim oBorder As BorderDefinition
On Error Resume Next
Set oBorder = ThisDocument.BorderDefinitions.Item("MyBorder")
If Err Then
    Err.Clear
    MsgBox "A border named ""MyBorder"" does not exist."
    Exit Sub
End If
On Error GoTo 0

' Place the border in edit mode.
Dim oSketch As DrawingSketch
oBorder.Edit oSketch

' Make changes to the sketch contents here.

' Return from edit mode.
oBorder.ExitEdit

Because only one drawing sketch can be actively editing at a time, calling the Edit method on an overlay sketch or a drawing aid definition will fail if there already is a drawing sketch in edit mode. To determine if a sketch is in edit mode, or to obtain the currently editing sketch, use the ActiveEditObject property on the Application object, or the ActivatedObject property on the DrawingDocument object. Note that if you attempt to transparently change the actively editing sketch when the active editing sketch is for a drawing aid definition, the changes must be aborted, saved, or saved to a new definition. In order to exit sketch mode for a drawing aid, you have to decide whether to abort, save or save changes to a new definition, which makes it impossible to return the user to the previous state.

In order to create a new overlay sketch or drawing aid definition, the new sketch needs to be temporarily placed into sketch edit mode. This means that an attempt to create a new overlay sketch or drawing aid definition will fail if there is a sketch active in edit mode.

When a new overlay sketch is created through the user interface, the sketch being constructed is not yet added to the sheet. There is no browser entry for the new sketch and the sketch will not show up in the sheet or drawing view's sketches collection until the sketch is returned from edit mode, at which point it is added to the sheet. Overlay sketches in this user interface construction state are accessible through the ActiveEditObject property of the Application object or the ActivatedObject property of the DrawingDocument object.

When a new drawing aid definition object is created through the user interface, the definition object is not yet added to the appropriate drawing aid definition object collection. There is no browser entry for the definition and it will not show up in the appropriate drawing aid definition object collection until the sketch edit mode is exited and the changes saved, at which point it is added to the definition object collection. Note that in the new creation mode from the user interface, the temporary drawing sketch is placed on the active sheet, not a temporary sheet such as when the definition is being edited. The definition object in this user interface construction state are accessible through the Parent property of the DrawingSketch object available from the ActiveEditObject property of the Application object or the ActivatedObject property of the DrawingDocument object.

When a drawing aid definition is edited, the definition's sketch is copied into a temporary sheet. If the changes are aborted, the temporary sketch is discarded. If the changes are saved, then the original sketch held by the definition is destroyed and the temporary copy replaces the original. If the change is saved to a copy, a new definition is created and the temporary sketch is assigned to it. Because of this, care must be taken when holding references to drawing aid definition sketch geometry and constraints across Edit and ExitEdit boundaries of the definition object. A reference to any sketch geometry or constraint from the original definition object's sketch will become invalid when an edit operation on the definition is performed and the changes saved. A reference to any sketch geometry or constraint from the edit mode sketch or a drawing aid definition will become invalid when the edit operation is ended and the changes are not saved.

Next page | Back to the Overviews
1, 2, 3, 4

Disclaimer


Sketch Constraints - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Sketch Constraints

Introduction to sketch constraints

Objects in Autodesk Inventor often relate to each other. The relationship may be as simple as being adjacent to each other, but it may be more complex, such as a combined tangential and vertical alignment. These relationships constrain objects and geometry together, so that any changes to the model cause the constraints to be recomputed and reapplied. If something changes sufficiently to prevent a constraint from being resolved, Autodesk Inventor flags that constraint.

The purpose of sketch constraints

Sketches are the base geometry in Autodesk Inventor - they are the building blocks for parts. Placing geometric constraints on sketches enables and ensures that basic rules for the design and shape of the sketch are enforced. Consequently, the resultant profiles with which part features may be defined follow the same rules. Think of constraints as rules that govern the position, slope, tangency, dimensions, and relationships among sketch geometry. Geometric constraints control the shapes and relationships among sketch elements, effectively removing successive degrees of freedom. The Autodesk Inventor API has a suite of constraint objects, and their proxies, that can be applied to sketches.

There are other types of constraints not covered by this overview, but they perform a similar function. Geometric constraints can also be applied to assembly components, defining relationships between parts in an assembly. See the Assembling Parts overview for more information on working with parts in the assembly environment.

Dimensional constraints in sketches control size, for example, the radius of an arc or the width of a part. All these types of constraints are resolved sequentially during a model compute to achieve the final model structure.

Sketch Constraints Object Model Diagram

Working with sketch constraints through the API

The API has objects for each type of constraint. The GeometricConstraints collection has add methods corresponding to each constraint object type. For example, to create a tangent constraint, call GeometricConstraints.AddTangent. These add methods accept SketchLines, SketchArcs, and SketchPoints as appropriate to their type. For example, a Tangent constraint accepts a SketchLine and SketchArc.

A sample - the effects of constraining a sketch

The following code creates a sketch in a new part document. It defines a number of sketch points within a SketchPoints collection, and then creates SketchLine objects and an arc based on those sketch points. The code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

First, create the new part document, and then add a new sketch:

Dim oApp As Inventor.Application
Set oApp = ThisApplication
Dim oPartDoc As PartDocument
Set oPartDoc = oApp.Documents.Add(kPartDocumentObject, _
    oApp.GetTemplateFile(kPartDocumentObject))
Dim oSketch As PlanarSketch
Set oSketch = oPartDoc.ComponentDefinition.Sketches.Add _
   (oPartDoc.ComponentDefinition.WorkPlanes.Item(3))

The code creates a number of arbitrary 2D points, using transient geometry to create the points, so create the transient geometry object.

Dim oTG As TransientGeometry
Set oTG = oApp.TransientGeometry

Now get the SketchPoints collection for the new sketch, and add some points.

Dim oSkPnts As SketchPoints
Set oSkPnts = oSketch.SketchPoints
Call oSkPnts.Add(oTG.CreatePoint2d(0, 0), False)
Call oSkPnts.Add(oTG.CreatePoint2d(1.0, 0), False)
Call oSkPnts.Add(oTG.CreatePoint2d(1.0, 0.5), False)
Call oSkPnts.Add(oTG.CreatePoint2d(2.2, 0.5), False)
Call oSkPnts.Add(oTG.CreatePoint2d(0.5, 1.5), False)
Call oSkPnts.Add(oTG.CreatePoint2d(0, 1.0), False)
Call oSkPnts.Add(oTG.CreatePoint2d(2.7, 1.5), False)
Call oSkPnts.Add(oTG.CreatePoint2d(0.5, 1.0), False)

Using the previously defined sketch points, add some lines to the SketchLines collection. Here the SketchLine objects are added to an array for easy reference later.

Dim oLines As SketchLines
Set oLines = oSketch.SketchLines
Dim oLine(1 To 6) As SketchLine
Set oLine(1) = oLines.AddByTwoPoints(oSkPnts(1), oSkPnts(2))
Set oLine(2) = oLines.AddByTwoPoints(oSkPnts(2), oSkPnts(3))
Set oLine(3) = oLines.AddByTwoPoints(oSkPnts(3), oSkPnts(4))
Set oLine(4) = oLines.AddByTwoPoints(oSkPnts(4), oSkPnts(7))
Set oLine(5) = oLines.AddByTwoPoints(oSkPnts(7), oSkPnts(5))
Set oLine(6) = oLines.AddByTwoPoints(oSkPnts(6), oSkPnts(1))

Add an arc to the SketchArcs collection.

Dim oArc As SketchArc
Dim oArcs As SketchArcs
Set oArcs = oSketch.SketchArcs
Set oArc = oArcs.AddByCenterStartEndPoint(oSkPnts(8), oSkPnts(5), oSkPnts(6))

The code to this point creates a sketch with no constraints, appearing as follows:

Now add some constraints. First, add a perpendicular constraint between two lines.

Call oSketch.GeometricConstraints.AddPerpendicular(oLine(4), oLine(5))
oApp.ActiveView.Update

The preceding code modifies the appearance of the sketch as follows:

Add tangent constraints to the two lines that join to both ends of the arc.

Call oSketch.GeometricConstraints.AddTangent(oLine(5), oArc)
Call oSketch.GeometricConstraints.AddTangent(oLine(6), oArc)
oApp.ActiveView.Update

This has no apparent effect - yet - since the lines and arc are already tangential. To see the effect of the tangent constraints, add a parallel constraint between two lines:

Call oSketch.GeometricConstraints.AddParallel(oLine(3), oLine(5))
oApp.ActiveView.Update

The cumulative effect of these tangential and parallel constraints is as follows:

Now constrain the lower angled line to always be horizontal.

Call oSketch.GeometricConstraints.AddHorizontal(oLine(5))
oApp.ActiveView.Update

The horizontal constraint results in the following change to the sketch:

Add breakpoints or comment out some of the preceding constraint code to see the effect of different constraints, including the effect of changing the order in which they are applied. The sketch points, unless grounded with a GroundConstraint, are not fixed despite the preceding code having supplied absolute coordinate points. The shape of the sketch is governed by the constraints.

API versus the User Interface

There are some situations, typically involving sketch points, where applying a constraint through the UI works, but the same constraint applied through the API apparently fails. This is not an error, but a reflection of the fact that the UI hides some of the complexities of constraints from the user, while the API does not. For example, creating a coincident constraint between two sketch line endpoints through the API may fail, while the same operation through the UI succeeds. The UI lets you apply a coincident constraint between these two points, but if you look at the results, there is no coincident constraint. In fact, Autodesk Inventor deleted one sketch point and changed both lines to share the remaining point. The API does not hide this from the user since the API expects to return the coincident constraint object, but cannot do that if none were really created. To emulate the UI, merge the sketch points using SketchPoint.Merge.

Summary

Sketch constraints remove successive degrees of freedom in how the sketch is evaluated. It is possible to overconstrain a sketch, so that constraints conflict and cannot be resolved. The UI provides a dialog box to resolve the conflict, while the corresponding API call fails. Sketches can also have dimensional (size) constraints applied to them.

Also consider -

The Autodesk Inventor user interface automatically highlights those parts of a sketch that are appropriate for creating a part feature, such as an extrusion. The API has a specific object to define what constitutes the input for feature creation - the Profile object.

Next page | Back to the Overviews
Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Introduction to Transactions

The transaction functionality is the means by which Inventor keeps track of the timeline of changes made during the course of an Inventor session. Transactions allow the user to perform Undo and Redo operations in Inventor. The menu below shows the user interface command to undo the creation of a new document.

Transaction menu illustration

Note: In Autodesk Inventor 9, a new API was introduced - the Change Processor. In many cases, this is now the preferred method to group operations atomically. For more information, please refer to the Change Processor overview.

Next page | What Are Transactions?
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

What Are Transactions?

All commands that modify data in Inventor are transactable. This means that Inventor model data created or modified during the course of a command can be undone and redone. When a command changes data in the database, it gathers some information from the user and begins a transaction. Only then does the command attempt to change the data in the database; if all the changes succeed, it asks the transaction manager to commit the changes. If the command fails to change the database successfully, it asks the transaction manager to abort the transaction and displays an error message to the user.

Inventor maintains two lists of transactions to manage undo and redo operations. The lists are called the committed transaction list and the undone transaction list. While a transaction is being recorded it is said to be in the "uncommitted" state. When the recording of the transaction is complete it is said to be in the "committed" state. If the user cancels the recording of the transaction, the transaction is "aborted." As soon as the transaction is committed, it is added to the committed list.

A successful transaction can be undone; an undone transaction can be redone. If the user undoes a committed transaction, the transaction is moved from the committed list to the undone list. If the user redoes an undone transaction it is once again moved from the undone list to the committed list. Inventor limits the number of transactions allowed in the committed list by a registry entry called "UndoLevels." The default value for "UndoLevels" is 10. Once the number of transactions exceeds the undo level, Inventor deletes the earliest transaction in the committed transaction list. When a transaction is committed, any undone transactions are no longer available to be redone (the undone list is emptied). Another important thing to note is that transactions are not persisted and are valid only for one Inventor session. This means that when a document closes, all the transactions in both the committed and the undone lists will be deleted.

Transactions within Inventor are quite different from transactions in some other systems (such as AutoCAD), so it is important to understand these differences before designing your application so you can take them into account. A critical thing to understand about Inventor's transactions is that the transaction stack has an application scope. In other words, all of the transactable actions performed within Inventor are saved in a single transaction list, regardless of which document the action was performed within. The API itself can be misleading in this regard in that it requires you to supply a document when starting a transaction, though the document name is not actually used internally.

There are two things to be aware of that result from Inventor's transactions having an application scope. The first is that transactions cannot be undone or redone with respect to a particular document. For example, suppose you have Part1 open and you draw two lines, then open Part2 and draw a circle. You now activate Part1 and perform an undo operation, expecting the last line you drew in Part1 to be undone. Instead the circle in Part2 will be undone since it was the last transaction in the transaction list.

The second issue of having a single transaction list for the entire application is that the entire list is sometimes deleted. This happens whenever a document is closed (it doesn't matter if the document is visible or not). This results in the user losing the ability to undo any previous actions.

Next page | What is Transacted?
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

What is Transacted?

The basic principle is to transact changes to data, but not UI changes or view changes. Thus undoing a command that added a feature will remove the added feature. Operations such as adding or removing a toolbar, changing the viewing position, changing the zoom factor or shading the model are not transacted. Changing these things does not create a transaction, so the change cannot be undone. This can sometimes lead to unexpected results. For example, you could extrude a long part, pan to view the end of the part, do an undo and find yourself looking at nothing.

Document Opens are transacting events. This means if you open a document and then do an undo, the document is undone from existence. An immediate redo would bring back the document. Document closes do not transact. When a document is closed, all of its memory is 'blown away' and is completely removed from the transaction chain.

Note that whether something is transacted is strictly dictated by whether it uses Inventor's transactable memory or not. This does not determine whether the object is persisted; persisted information can be allocated inside or outside of Inventor's transactable memory.

Next page | Identified and Unidentified Transactions
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Identified and Unidentified Transactions

All changes to transacting memory transact. However, many of the changes to this data fall outside commands that start transactions. For example, after a command has completed, views of parts need to be repainted on the computer screen. Windows puts a paint request in a queue, and the repainting happens later, when the transaction has been committed.

Although logically painting a part on the screen does not update the part, graphics information is recalculated and stored in the Scene Graph. These memory changes need to be transacted (so they can be undone). These changes are stored as part of an unidentified transaction.

An unidentified transaction is, for all intents and purposes, a normal transaction that the user isn't aware exists. Undoing or redoing a command always undoes an 'identified' transaction, but it may also undo or redo unidentified transactions. It is important to note that as far as Inventor is concerned, there is always a transaction in progress. If the user does not start an "identified" transaction, Inventor will create an "unidentified" transaction. As the figure above shows, the transaction timeline for Inventor is a continuum, beginning with the start of the Inventor session and ending when the session ends. The timeline shows the identified transactions interspersed with unidentified transactions (labeled "UI" in the figure). The figure may seem to imply that identified and unidentified transactions always occur in pairs, but this is not always the case. If an identified transaction aborts, it will revert the timeline back to the end of the last unidentified transaction. Consequently another unidentified transaction will ensue.

Unidentified transactions are hidden from the API. The API for transactions presents only the identified transaction view. The only way to observe an unidentified trisection via the API would be to watch the CurrentTransaction property of the TransactionManager, when no command is in progress. For example, start a new sketch and observe TransactionManager::CurrentTransaction. It would report that the DisplayName of the transaction is "Unidentified transaction."

Next page | Transactions in the API
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Transactions in the API

Transaction object hierarchy

The transaction API gives you the ability to leverage Inventor's transaction scheme to create custom commands or operations that work like Inventor's commands. The following topics describe the various facilities offered by the transaction API and how they should be used.

Using Transactions

The most basic use of the transaction API is to wrap a set of transactable operations in a transaction. An example would be a client who wishes to publish a command that creates a sketch rectangle by connecting four sketch lines. Such a command would take two input points from the user and create four sketch lines. From Inventor's perspective this command should behave like the creation of a rectangle and not the creation of four lines; i.e. an Undo operation after the command has been executed should undo the creation of the entire rectangle rather than one of its lines. The sample program below demonstrates the use of transaction API to create such a command:

' Get a reference to the active document.
' This can be an Assembly or Part document.
Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

Dim oCmpDef As PartComponentDefinition
Set oCmpDef = oDoc.ComponentDefinition

Dim oSketch As PlanarSketch
Set oSketch = oCmpDef.Sketches(1)

Dim oTG As TransientGeometry
Set oTG = ThisApplication.TransientGeometry

' Get the transaction manager from the application
Dim oTxnMgr as TransactionManager
Set oTxnMgr = ThisApplication.TransactionManager

' Start a regular transaction
Dim oTxn1 As Transaction
Set oTxn = oTxnMgr.StartTransaction(oDoc, "My Rectangle Command")

' Draw four sketch lines
Dim oLine As SketchLine
Set oLine = oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 0), oTG.CreatePoint2d(1, 0))
Set oLine = oSketch.SketchLines.AddByTwoPoints(oLine.EndSketchPoint, oTG.CreatePoint2d(1, 2))
Set oLine = oSketch.SketchLines.AddByTwoPoints(oLine.EndSketchPoint, oTG.CreatePoint2d(0, 2))
Set oLine = oSketch.SketchLines.AddByTwoPoints(oLine.EndSketchPoint, oTG.CreatePoint2d(0, 0))

oTxn.End

Creating the "My Rectangle Command" transaction wraps the four sketch lines in a transaction. The transaction timeline for this command is illustrated by the figure below:

Each AddByTwoPoints method creates a Line transaction in the scope of oTxn. Abort of oTxn (calling Abort before End) at any point will revert oTxn back to the beginning. If any of the Line transactions abort due to an error condition, the transaction timeline will revert to the beginning of the Line.

Next page | Parent and Child Transactions
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Parent and Child Transactions

A transaction that is started using the TransactionManager::StartTransaction method can either be a parent or a child transaction. A transaction that is started within the scope of another transaction becomes the child of that transaction. Consider the sample program below:

' Get a reference to the active document.
' This can be an Assembly or Part document.
Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

Dim oCmpDef As PartComponentDefinition
Set oCmpDef = oDoc.ComponentDefinition

Dim oSketch As PlanarSketch
Set oSketch = oCmpDef.Sketches(1)

Dim oTG As TransientGeometry
Set oTG = ThisApplication.TransientGeometry

' Get the transaction manager from the application
Dim oTxnMgr as TransactionManager
Set oTxnMgr = ThisApplication.TransactionManager

' Nesting regular transactions
' Start a regular transaction
Dim oTxn1 As Transaction
Set oTxn1 = oTxnMgr.StartTransaction(oDoc, "My Txn")

    ' Draw a sketch line
    Dim oLine As SketchLine
    Set oLine = oSketch.SketchLines.AddByTwoPoints(oTG.CreatePoint2d(0, 0), oTG.CreatePoint2d(1, 0))

    ' Start a nested transaction
    Dim oTxn2 As Transaction
    Set oTxn2 = oTxnMgr.StartTransaction(oDoc, "My child Txn")

    ' Draw a circle
    Dim oCircle As SketchCircle
    Set oCircle = oSketch.SketchCircles.AddByCenterRadius(oLine.EndSketchPoint, 3)

    oTxn2.End

oTxn1.End

The above code starts an identified transaction (oTxn1), creates a sketch line (a transaction), starts another transaction (oTxn2), creates a sketch circle (a transaction) and commits oTxn1 and oTxn2. The transaction timeline looks like this:

Parent and child transactions

What this indicates is that oTxn has three child transactions: Line, oTxn2 and Circle. Transaction oTxn2 has one child: Circle. The fact that oTxn2 wraps the Circle transaction means that an abort of Circle will revert the timeline to the beginning of oTxn2. Abort of Line will revert the timeline to the beginning of oTxn. The child transactions, however, do not affect the Undo operation. In the example above, the only transaction visible to Inventor is the top-level transaction oTxn. In this example, Inventor's Undo user interface will look like the figure below.

Transaction user interface

Next page | Start, End and Abort Transactions
1, 2, 3, 4, 5, 6, 7, 8, 9, 10,

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Start, End and Abort Transactions

Each start transaction should be paired with an end or abort transaction. Inventor becomes unstable if the StartTransaction is not paired with a corresponding End or Abort. If any of the API calls fail, i.e. return a bad error code, then the command should handle the error and take care to call EndTransaction. Applying this rule consistently is particularly critical, since even a simple API call can fail rather unexpectedly. In the event that the error is not recoverable, the command should abort the transaction. Aborting the transaction means that the transaction was cancelled prior to completion. The sample below indicates how an error condition should be handled within the scope of a transaction.

' Get a reference to the active document.
' This can be an Assembly or Part document.
Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

' Get the transaction manager from the application
Dim oTxnMgr as TransactionManager
Set oTxnMgr = ThisApplication.TransactionManager

' Start a transaction
Dim oTxn As Transaction
Set oTxn = oTxnMgr.StartTransaction(oDoc, "My Txn")

' Perform an operation that you wish to transact

' If the error from the operation is not recoverable, abort the Txn
If Err Then
    MsgBox "Unrecoverable error occurred during the operation"
    oTxn.Abort
    Exit Sub
End If

' End the transaction
oTxn.End

Next page | Checkpoints
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Checkpoints

Checkpoints are bookmarks for rollback operations within a transaction. Consider the sample program below. A transaction is initiated and this transaction performs two operations; create a complex profile and extrude the profile. A checkpoint has been placed before the extrude operation. What this means is that if the extrude command fails, the transaction can be rolled back to the checkpoint. By enabling such a rollback, the user is given an opportunity to recover from an error. In this case if the extrude operation failed due to a bad profile, an option can be presented to the user to modify the profile and try the extrude operation again.

A side note: Inventor implements checkpoints as child transactions. The GoToCheckpoint operation essentially aborts the checkpoint transaction.

' Get a reference to the active document.
' This can be an Assembly or Part document.
Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

' Get the transaction manager from the application
Dim oTxnMgr as TransactionManager
Set oTxnMgr = ThisApplication.TransactionManager

' Start a regular transaction
Dim oTxn1 As Transaction
Set oTxn1 = oTxnMgr.StartTransaction(oDoc, "Checkpoint Txn")

' *****************************************
' Perform the creation of extrude profile
' *****************************************

' Create a checkpoint before the extrude operation
Dim oChkPt as CheckPoint
Set oChkPt = oTxnMgr.SetCheckPoint

' *****************************************
' Extrude the newly created profile
' *****************************************

' Handle any error condition from the extrude command
If Err Then
    MsgBox "Extrude operation failed. Modify profile ?"
    oTxnMgr.GoToCheckPoint oChkPt
End If

Next page | Transaction Events
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Transaction Events

The Transaction API allows the client to receive notifications for transaction-related events. The TransactionEvents object sends notifications for commit, undo, redo, abort and delete of a transaction. All of the notifications with the exception of the delete are sent before and after the actual event takes place in Inventor. Notification for the deletion of a transaction is sent only after the transaction has been deleted.

The following sample program demonstrates the use of transaction events:

Private WithEvents oTxnEvents As TransactionEvents

Private Sub clear_Click()
    List.Clear
End Sub

Private Sub UserForm_Initialize()
    Dim oTxnMgr As TransactionManager
    Set oTxnMgr = ThisApplication.TransactionManager

    Set oTxnEvents = oTxnMgr.TransactionEvents
End Sub

Private Sub oTxnEvents_OnAbort(ByVal TransactionObject As Transaction, ByVal Context As NameValueMap, ByVal BeforeOrAfter As EventTimingEnum)

    If BeforeOrAfter = kBefore Then
        List.AddItem "Transaction: " & TransactionObject.Id & " will be aborted"
    ElseIf BeforeOrAfter = kAfter Then
        List.AddItem "Transaction: " & TransactionObject.Id & " has been aborted"
    End If

End Sub

Private Sub oTxnEvents_OnCommit(ByVal TransactionObject As Transaction, ByVal Context As NameValueMap, ByVal BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum)

    If BeforeOrAfter = kBefore Then
        List.AddItem "Transaction: " & TransactionObject.Id & " will be committed"
    ElseIf BeforeOrAfter = kAfter Then
        List.AddItem "Transaction: " & TransactionObject.Id & " has been committed"
    End If

End Sub

Private Sub oTxnEvents_OnRedo(ByVal TransactionObject As Transaction, ByVal Context As NameValueMap, ByVal BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum)

    If BeforeOrAfter = kBefore Then
        List.AddItem "Transaction: " & TransactionObject.Id & " will be redone"
    ElseIf BeforeOrAfter = kAfter Then
        List.AddItem "Transaction: " & TransactionObject.Id & " has been redone"
    End If

End Sub

Private Sub oTxnEvents_OnUndo(ByVal TransactionObject As Transaction, ByVal Context As NameValueMap, ByVal BeforeOrAfter As EventTimingEnum, HandlingCode As HandlingCodeEnum)

    If BeforeOrAfter = kBefore Then
        List.AddItem "Transaction: " & TransactionObject.Id & " will be undone"
    ElseIf BeforeOrAfter = kAfter Then
        List.AddItem "Transaction: " & TransactionObject.Id & " has been undone"
    End If

End Sub

Private Sub oTxnEvents_OnDelete(ByVal TransactionObject As Transaction, ByVal Context As NameValueMap, ByVal BeforeOrAfter As EventTimingEnum)

    If BeforeOrAfter = kAfter Then
        List.AddItem "Transaction: " & TransactionObject.Id & " has been deleted"
    End If

End Sub

This program creates a form, shown below, to monitor the transaction activity in Inventor. The transaction activity is reported using the transaction ID. The output was generated by creating several sketch lines and doing undo and redo on the sketch lines.

Next page | Do's and Don'ts of Transactions
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transactions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transactions

Dos and Don'ts

  • An Undo or Redo should be performed only when there is no transaction in progress (during an unidentified transaction).
  • Do not wrap any Inventor commands within transactions. Do not wrap any user interaction events within transactions. A good rule would be that it is OK to create modal dialogs within a transaction but not modeless dialogs.
  • The transaction event handling code should not perform any operation that uses transactable memory. For example, it is illegal to create a sketch line in the event handling code for the commit of a transaction.
  • Do not close any document inside a transaction, even the active one. The exception to this rule is that it is legal to close a document in a transaction when the document was opened in that exact same transaction.
Dim oTxnMgr As TransactionManager
Set oTxnMgr = ThisApplication.TransactionManager

Dim oDoc As Document
Set oDoc = ThisApplication.ActiveDocument

Dim oTxn As Transaction
Set oTxn = oTxnMgr.StartTransaction(oDoc, "Txn1")

' ***************************************
' Invalid operation
' ***************************************
oDoc.Close

oTxn.End

Next page | Back to the Overviews
1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Disclaimer


Transient Geometry - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Transient Geometry

Introduction to Transient Geometry objects

The term transient geometry object can be interpreted many ways, even in the context of Autodesk Inventor. For the purposes of this overview, this topic covers those utility constructs required to accomplish many mathematical tasks, specifically geometric tasks, through the API. For example, point objects, vectors and matrices.

The purpose of Transient Geometry

These transient objects, created through the appropriate method provided by the TransientGeometry object, are used extensively throughout Autodesk Inventor application code. Unlike most other API geometry objects, they are invisible mathematical representations with no graphical component. They are typically the means through which graphical objects are manipulated, as they provide a convenient way to create 2D and 2D points (not workpoints or sketchpoints), create matrices for object transformations, and so on.

Transient Geometry Object Model Diagram

Working with Transient Geometry Objects - the Point and Matrix objects

An important point to remember about these transient geometry objects is that they do not represent the boundaries of actual graphical objects. For example - the Line object is infinite in extent, unlike a SketchLine object. The Line object has a direction, represented by a UnitVector. Similarly, the Plane object is not bounded like a face - it too is infinite in extent.

This overview will look at some of the most commonly used transient objects - the Point, Point2d and Matrix objects.

Using a Point2d object

The Point object is a list of three coordinates, representing the X Y and Z of a point in space. Similarly, the Point2d object represents the X and Y of a point on a plane. These objects also support properties giving access to their coordinates, and to methods that perform functions such as equality testing or transformation of the point.

Point2d objects are frequently used when working with 2D sketches. To create a SketchPoint object on a sketch, use the Add method of that sketches SketchPoints collection. You might expect code similar to the following.

Dim oSkPnts As SketchPoints
Call oSkPnts.Add(10, 20)  ' This is wrong

The Add method needs to know the location to create the SketchPoint object, but this point may be the result of any number of transformations or translations, or it may be provided by another object. Therefore the Add method expects a Point2D object. The correct code is as follows. The code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

Dim oApp As Inventor.Application
Set oApp = ThisApplication

Dim oPartDoc As PartDocument
Set oPartDoc = oApp.Documents.Add(kPartDocumentObject, _
   oApp.GetTemplateFile(kPartDocumentObject))

Dim oSketch As PlanarSketch
Set oSketch = oPartDoc.ComponentDefinition.Sketches.Add _
  (oPartDoc.ComponentDefinition.WorkPlanes.Item(3))

Dim oTG As TransientGeometry
Set oTG = oApp.TransientGeometry

Dim oSkPnts As SketchPoints
Set oSkPnts = oSketch.SketchPoints
Call oSkPnts.Add(oTG.CreatePoint2d(10, 20), False)

The preceding code will create a sketch with a single sketchpoint at X=10, Y=20. The last argument of the Add method is a boolean value, indicating whether the SketchPoint will form the center point of a hole feature. The main difference is that the graphical representation of the resulting SketchPoint will differ slightly.

SketchPoints in a SketchPoints collection are always 2D, and are typically provided by the CreatePoint2D method. SketchPoint3D objects in a 3D sketch are contained within a SketchPoints3D collection.

Using the Matrix object

The Matrix object is one of the least understood objects in the Autodesk Inventor API, but its use in most common situations is fairly straightforward. This overview will focus on the Matrix object used for 3D space, though Autodesk Inventor also supports the Matrix2d object for 2D space.

The Matrix object is typically used either to place an object with a specific orientation, such as when inserting an instance of a part into an assembly. In other words it is used to define a coordinate system. Also, it is used to move, or transform, an object from one location to another. The Matrix object provides a convenient means of manipulating a set of coordinates in 3D space. It has a set of useful methods to set the matrix data or to act on that data.

For example, suppose you have two planes, and you plan to move objects from one plane to the other. Ideally, you would use a matrix to perform these translations most efficiently. The Matrix object provides the SetToAlighCoordinateSystems method that accepts the coordinates system (origin, X, Y and Z) of the source plane and the coordinate system (origin, X, Y and Z) of the target plane. Thus the matrix rows and columns are set to the required values and the matrix can be used repeatedly to translate any objects from the old plane to the new. The Matrix object provides a number of methods and properties designed to shield the user from many of the complexities of matrix math.

A matrix as a coordinate system

Let's first look at a matrix as a coordinate system definition. The default Autodesk Inventor coordinate system follows the conventional rectangular Cartesian system with the positive X direction to the right, the positive Y direction upwards, and the positive Z direction towards you. We'll set a matrix to represent a similar system, but one that is rotated 45 degrees about the Z axis, and with the origin at 10,5,0.

Imagine a vector pointing along the required X axis. Remember we now want this to be at 45 degrees, so this can be thought of as pointing at 1,1,0. However, it's often convenient to use the UnitVector object, which always has a unit length of 1. So the direction vector actually points to 0.707, 0.707, 0. The Z axis does not change, but the origin becomes 10,5,0. A 3D matrix to represent this would appear as follows. Reading the columns left to right, they are X Y Z, and origin.

Using the previously noted SetCoordinateSystem method, the following code calculates and sets a matrix object to the above values. Autodesk Inventor internal units are centimeters and radians.

Dim oTG As TransientGeometry
Set oTG = ThisApplication.TransientGeometry
Dim dPi As Double
dPi = Atn(1) * 4

' Define the origin point.
Dim oOrigin As Point
Set oOrigin = oTG.CreatePoint(10, 5, 0)

' Define the axis vectors.  Pi/4 is 45 degrees in radians.
Dim oXAxis As UnitVector
Dim oYAxis As UnitVector
Dim oZAxis As UnitVector
Set oXAxis = oTG.CreateUnitVector(Cos(dPi / 4), Sin(dPi / 4), 0)
Set oYAxis = oTG.CreateUnitVector(-Cos(dPi / 4), Sin(dPi / 4), 0)
Set oZAxis = oTG.CreateUnitVector(0, 0, 1)

' Create the matrix and define the desired coordinate system.
Dim oMatrix As Matrix
Set oMatrix = oTG.CreateMatrix
Call oMatrix.SetCoordinateSystem(oOrigin, oXAxis.AsVector, oYAxis.AsVector, oZAxis.AsVector)

A typical use for such a matrix definition would be placement of parts within an assembly. You can construct a matrix that, when referenced by the Transformation property of a part occurrence, determines exactly where the part should be placed.

Note: Individual matrix cells can be accessed directly through the Cell method of the Matrix object.

Using a matrix for transformation

The use of a matrix to move an object is a little different than using a matrix to define a coordinate system for object placement. The example shown previously defines a static coordinate system. To move objects from one location to another implies a difference in location coordinates. In other words, a delta - the difference between one coordinate system definition and another. This delta can be represented by a matrix.

The matrix defined in the preceding code, when referenced by the TransformBy method of a second matrix object, results in the second matrix being recalculated to reflect the new location. The referenced matrix acts as a delta matrix for the transformation. In other words, a new matrix definition is created from a source matrix and a delta matrix.

In this case, the delta is a 45 degree rotation about the Z axis. All we need to do is change the call to SetCoordinateSystem, as we no longer wish to change the origin, as follows.

Call oMatrix.SetCoordinateSystem(oTG.CreatePoint, oXAxis.AsVector, oYAxis.AsVector, oZAxis.AsVector)

Thereafter, to rotatee an object such as a part occurrence about its Z axis, obtain its location matrix through its Transformation property, then modify the matrix by calling its TransformBy method, referencing the delta matrix. Then reapply the updated location matrix to the occurrence, again through its Transformation property. The occurrence will move to its new location.

The matrix object supports a set of methods intended to help with many common tasks, as follows.

GetCoordinateSystem | Invert | PostMultiplyBy
PutMatrixData | SetToAlignCoordinateSystems | SetToRotateTo
SetTranslation | GetMatrixData | IsEqualTo
PreMultiplyBy | SetCoordinateSystem | SetToIdentity
SetToRotation | TransformBy

Summary

The TransientGeometry object allows the creation of a number of transient geometry objects. These objects do not represent actual graphical geometry. Transient geometry objects are used for mathematical calculations. Two of the most commonly used objects include points and matrix objects. Matrices allow accurate placement and movement of components.

Also consider

TransientGeometry objects are not limited to point, line or planar objects. For example, the Box object can expand to incorporate specified points, or can check for interference with another box, or can check if a specified point is contained within the box.

Next page | Back to the Overviews
Disclaimer


< Triad Events - Autodesk Inventor Object Library
Autodesk Inventor Object Library Send comments on this topic.

Triad Events

Introduction to TriadEvents - the 3D move and rotate tool

The Autodesk Inventor user interface has a 3D move and rotate tool, available when you create or edit a grounded work point in a part or 3D sketch. A triad symbol is displayed. Select or drag a triad segment to indicate the type of transform required, or click it to open a dialog box. In the dialog box, you can enter coordinates to precisely position a grounded work point. In addition to entering coordinates, you can drag the triad along the X, Y, and Z coordinates to dynamically update the dialog box. Movement is not limited to the part axes. The 3D Move/Rotate tool can be rotated about any axis to realign the direction of subsequent moves.

The Autodesk Inventor API supports the 3D Move/Rotate tool through the TriadEvents object.

The purpose of TriadEvents

The ability of the developer to control the triad affords many advantages to the user. An example is the routing of piping. As each segment is placed, the triad can be positioned at the end of the pipe so the user can indicate, graphically but precisely, the axis of the next segment. The user can do this using the triad tool - something already familiar through the user interface. In addition to programmatically positioning the triad, the developer can receive notification of a number of triad events - for example, if the user interactively moves the triad.

TriadEvents Object Model Diagram

Working with the TriadEvents API

The TriadEvents object is used in a similar manner to other interaction events such as mouse and keyboard events. It is obtained through the TriadEvents property of the InteractionEvents object.

Selection and other interaction events cannot be active while triad events are enabled. Start the InteractionEvents object and set its InteractionDisabled property to True to start receiving triad events.

You can position the triad by calling the Reposition method of the TriadEvent object.

You can register a number of triad events, including the following:

OnActivate - Fires when the triad is activated.
OnEndSequence - Fires when the user ends a move sequence of the triad.
OnStartSequence - Fires when the user starts a move sequence of the triad.
OnMove - Fires when the triad moves as a result of a drag, reposition or if the user enters values for translation and rotation.
OnMoveTriadOnlyToggle - Fires when the Move Triad Only option is toggled.
OnStartMove - Fires when the triad begins to move as a result of a drag, reposition or if the user enters values for translation and rotation.
OnEndMove - Fires when the user ends an intermediate move of the triad.
OnTerminate - Fires when the triad is terminated.
OnSegmentSelectionChange - Fires every time a segment of a triad is selected.

Using the TriadEvents object

This example provides skeletal code demonstrating how to set up triad interaction events. It enables the triad and implements the triad move event. The code omits error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

Start a new VBA project and add a blank form (here named UserForm1). Add the following code to the form, starting with declarations of the interaction and triad event objects:

Private WithEvents oInteraction As InteractionEvents
Private WithEvents oTriadEvents As TriadEvents

Add a subroutine to be called when the form is initialized. Obtain the InteractionEvents object from the CommandManager object, and turn of selection and interaction. This means that the triad can still be manipulated by the user.

Sub UserForm_Initialize()
  Set oInteraction = ThisApplication.CommandManager.CreateInteractionEvents
  oInteraction.SelectionActive = False
  oInteraction.InteractionDisabled = True

Obtain the TriadEvents object from the InteractionEvents object, and then set its Repeat and Enabled properties to True. The Repeat property indicates that triad events should continue after a move sequence completes.

Set oTriadEvents = oInteraction.TriadEvents
  oTriadEvents.Repeat = True
  oTriadEvents.Enabled = True

Now start interaction events, and call DoEvents so the process can be terminated when required.

  oInteraction.Start

  While UserForm1.Enabled = True
    DoEvents
  Wend
End Sub

Add another subroutine, this time the OnMove event of the TriadEvents object. When the user moves the triad through the user interface, this code is called. This code prints a message, but other more significant actions can take place depending on context.

Private Sub oTriadEvents_OnMove(ByVal SelectedTriadSegment _
            As TriadSegmentEnum, _
            ByVal ShiftKeys As ShiftStateEnum, _
            ByVal CoordinateSystem As Matrix, _
            ByVal Context As NameValueMap, _
            HandlingCode As HandlingCodeEnum)

  Debug.Print "3D move / rotate tool has been moved."
End Sub

The last subroutine to add to the form cleans up once the form is closed, and it stops the InteractionEvents object.

Private Sub UserForm1_Terminate()
  oInteraction.Stop
  Set oTriadEvents = Nothing
  Set oInteraction = Nothing
End Sub

Finally, add the following code to a code module (not the form). To run the sample code, run this TriadEventsTest subroutine.

Public Sub TriadEventsTest()
    UserForm1.Show vbModeless
End Sub

When this sample is run in an open part document, the 3D Move/Rotate triad tool and dialog is displayed as follows:

When the triad tool is moved by the user, the OnMove event is called and the code prints a short message to the VBA debug screen (the 'immeadiate' window, if open).

Summary

The TriadEvents object and API provide a convenient means of obtaining location and transformation data in a fashion already familiar to the user. The triad can be activated and controlled through the API, and also provides a set of events to respond to changes to the triad made through the user interface.

Also consider

The InteractionEvents object provides selection, mouse and keyboard event callbacks, but also exposes the InteractionGraphics API. Like the ClientGraphics API, this API can be used to display transient geometry as visual cues. Used with TriadEvents, a lot of contextual information can be provided to the user in the form of visual cues and guidance.

Next page | Back to the Overviews
Disclaimer


User Interface Customization Using the API - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interface Customization Using the API

Understanding the User Interface

Before beginning a discussion of the API as it relates to user interface customization, let us begin with an overview of Autodesk Inventor's user interface to ensure that you understand all of the concepts and terms. First, let's look at Autodesk Inventor's user interface from the perspective of a user. The various elements of the user interface are numbered and defined in the following image and section.

Create the EXE or DLL

  1. Menu Bar - The menu bar is a familiar item within in any Microsoft Windows application. Autodesk Inventor is not different. The menu bar contains the items usually expected: File, Edit, and so on. In Autodesk Inventor, the menu bar is always visible, but the contents may change depending on whether a document is open and what type of document is active.
  2. Standard Bar - The standard bar is a toolbar that contains commonly used commands. The standard bar is usually visible (the user can turn it off) and its contents can change depending on the document currently active.
  3. Custom Toolbar - A custom toolbar is any displayed toolbar besides the standard bar toolbar. Typically, these toolbars are created by users. When a custom toolbar is displayed, it remains visible at all times regardless of any documents being open or the type of active document.
  4. Panel Bar - The panel bar is essentially an enhanced toolbar. It displays the contents of a toolbar and allows for easy switching between toolbars. When no document is open, the panel bar is empty. When a document is active, the toolbar associated with the active environment is displayed within the panel bar. Each environment defines which toolbar to display within the panel bar as the default. The environment also defines which other toolbars the user can choose to display within the panel bar.
  5. Browser - The browser is most commonly used to display a tree that symbolically illustrates the contents of the active document. The browser is an ActiveX container and can be used by programmers in many other ways besides displaying trees. For example, Autodesk Inventor uses the browser for its interface to the library of standard parts.
  6. Context Menu - The context menu is a familiar Microsoft Windows application interface. The context menu is displayed when the user right-clicks. The contents of the context menu vary depending on the position of the cursor when the button is clicked.
  7. Status Bar - The status bar is used by commands to display the current status and instructions to the user.

These elements of the user interface are familiar to Autodesk Inventor users. There are some other elements of the user interface that are not as obvious to the end-user. They define behavior that tends to be very natural to the end-user so their existence usually goes unnoticed. These are Environments and Document Sub-Types. Autodesk Inventor supports access to this functionality by the user and through the API. As before, let's begin by looking at the user's perspective of these features. The following image is the Environments tab of the Customize dialog box.

Environments

Environments define a set of user interface elements. Environments are used to provide a specific set of commands when the user is performing a specific task. For example, in the previous dialog box, the Part environment is selected and the user can use the dialog box to customize it. The environment defines the following items.

  1. Which toolbar is displayed within the standard toolbar.
  2. Which toolbar is displayed within the panel bar.
  3. Which toolbars are displayed within the panel bar list when you click the title of the panel bar. This lets the environment control which toolbars are available within the panel bar.
  4. Which toolbars are displayed within the context menu when you right-click on an existing toolbar. This lets the environment control which toolbars can be displayed as custom toolbars within the environment.

The Customize dialog box is how the user customizes the contents of an environment, but the display of environments is controlled by Autodesk Inventor. It is tied to the activity currently being performed by the user. For example, when you open a part document, the Part environment is displayed to provide the user with the set of commands that are useful in creating parts. If you edit a sketch, the environment switches to the sketch environment to provide easy access to the commands that are the most useful in that context.

Document Sub-Types

The concept of document subtypes is not something that users need to understand to use Autodesk Inventor. However, they frequently take advantage of the functionality that document subtypes provide. Document sub-types are used to label the contents of a document. Inventor has four core document types: part, assembly, drawing, and presentation. These document types are differentiated by different file extensions: .ipt, .iam, .idw, and .ipn. These basic document types are further divided into sub-types. The best example of this is a sheet metal document. It uses the .ipt extension but still behaves differently than a standard part document. Weldment documents also use this functionality. They are a sub-type of the assembly document. We'll examine the exact role of the document sub-type when we discuss it in relation to the API.

Next page | API for User Interface Customization
1, 2, 3, 4, 5, 6

Disclaimer


User Interface Customization Using the API - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interface Customization Using the API

API for User Interface Customization

Let's now look at the API that supports customization of the Inventor user interface. We'll begin by looking at one of the basic components of almost all applications: commands. From the user interface perspective, a command is usually just a button on a toolbar or a selection on a menu. The user clicks the button to invoke the command. The role of the user interface is to expose the button to the user and notify the owner of the command when the user clicks that button. Within the API, the object that supports this notification is the ButtonDefinition object.

During start-up (in the Activate event), when the FirstTime flag is True, you need to build the UI from scratch. Roughly speaking, following are the things you would do on FirstTime:

  1. Create custom environments
  2. Create custom toolbars
  3. Populate custom environments
  4. Populate custom toolbars
  5. Modify Inventor (built-in) environments
  6. Modify Inventor (built-in) toolbars

The consequences of hitting the ‘Reset’ button in the UI are the following:

  1. Clean-out of custom environments (undo of 3 above) – the custom environments are not deleted.
  2. Clean-out of custom toolbars (undo of 4 above) – the custom toolbars are not deleted.
  3. Restore built-in environments (undo of 5 above)
  4. Restore built-in toolbars (undo of 6 above)

So, the actions you need to take in the Reset events are:

  1. Populate custom environments
  2. Populate custom toolbars
  3. Modify Inventor (built-in) environments
  4. Modify Inventor (built-in) toolbars

Next page | ButtonDefinition
1, 2, 3, 4, 5, 6

Disclaimer


User Interface Customization Using the API - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interface Customization Using the API

ButtonDefinition

The ControlDefinitions collection object supports an AddButtonDefinition method. The Add-In or a VBA client can create a ButtonDefinition for each of its commands. The ButtonDefinition has two roles. First, it supports the OnExecute event to notify whenever the button is clicked. Second, it contains all of the information that defines what the button will look like. The ButtonDefinition isn't a button, but is referenced by the physical button. It provides the button with the information it needs to display itself. The ButtonDefinition can be referenced by multiple buttons. If the ButtonDefinition is changed, then any associated buttons automatically change. The following line declares the variable used for the ButtonDefinition. This is typically defined as a global variable within a class module. Notice the use of the WithEvents keyword to enable listening to the OnExecute event.

Private WithEvents oButtonDefinition As ButtonDefinition

The creation of the ButtonDefinition objects is typically performed in the Activate method of an Add-In. Two of the arguments of the AddButtonDefinition method allow you to supply the small and large icons for the button. (The user can switch between normal and large icons using the Toolbars tab of the Customize dialog box.) There are several techniques available to loading icons: load from an icon file, image control, resource file, and so on. The icon arguments are optional. If not supplied, the button contains the display name of the ButtonDefinition as text. You can also supply a normal size icon for both the normal and large icons. Autodesk Inventor scales the normal size if the user chooses to display large icons. For the icons you can use icon or bitmap files. Icon files are preferred because they define a transparent background color. Normal size icons are 16 pixels wide by 16 pixels high. Large icons are 24 pixels wide by 24 pixels high. If an icon of a different size is provided, Autodesk Inventor scales it to fit.

Supplying the icons for a button definition is only valid when your program is running in-process to Autodesk Inventor. This is because of marshalling limitation that doesn't support passing the bitmap information between processes. This can be an issue when debugging an Add-In. Even though the Add-In is defined as an ActiveX DLL, when debugging it is actually running out of process and fails when it attempts to create the button definition. You can temporarily work around this by editing your code to comment out the last two arguments. This results in text-only buttons but you can continue debugging the rest of the Add-In.

The following code illustrates creating a ButtonDefinition. The AddButtonDefinition call provides arguments to allow the input of the information associated with a button. The first argument is the display name of the command. The second argument is the internal name of the command. This must be unique with respect to all other commands. It is recommended that you append command names with something that helps to ensure uniqueness. Some examples are your application or company name. The sample uses a registered developer symbol that contains four unique characters that are registered through ADN (Autodesk Developers Network). The third argument is used to classify the type of command this button represents. This can be used by other Add-Ins to disable or enable certain commands. The fourth argument is a string which is the CLSID (a GUID) of an AddIn; this string can be ignored if you are programming in VBA. The remaining arguments are easily understood and can be identified in the sample by the values being input.

Dim oControlDefinitions As ControlDefinitions
Set oControlDefinitions = oApp.CommandManager.ControlDefinitions

Dim oLargeIcon As IPictureDisp
Dim oSmallIcon As IPictureDisp
Set oLargeIcon = LoadPicture(App.Path & "\Large.ico")
Set oSmallIcon = LoadPicture(App.Path & "\Small.ico")

Set oButtonDefinition = oControlDefinitions.AddButtonDefinition( _
                          "Display Name", "invrSampleCommand", _
                          kShapeEditCmdType, "CLSID of the AddIn", _
                          "Description Text", "Tooltip", _
                          oSmallIcon, oLargeIcon, _
                          kDisplayTextInLearningMode)

You can now listen to the OnExecute event on the ButtonDefinition object and react to user clicks. The ButtonDefinition object can be used by you and other Add-Ins to create a physical button on a toolbar or menu. All the Autodesk Inventor commands also expose their associated ButtonDefinition object to allow adding buttons to toolbars and menus using the API.

Next page | Command Bars and specialized controls
1, 2, 3, 4, 5, 6

Disclaimer


User Interface Customization Using the API - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interface Customization Using the API

Command Bars and specialized controls

The Command bar concept was first introduced by Microsoft in Office 97. It unifies menus and toolbars into a single concept. With command bars, there is no difference between a menu and a toolbar. You can see this behavior in products like Microsoft Word. When using Word's Customize command, you can place buttons within the menu area and you can create menu items within a toolbar. The menu can also be repositioned like a toolbar and docked to other sides of the window besides the top. Even though there is no difference between menus and toolbars, almost all applications continue to have a main menu that contains the expected pull-down menus, with additional toolbars that primarily contain buttons. This practice helps to maintain a consistent Windows application feel.

Command bars are essentially just collections of ControlDefinition objects and/or other command bars. When you create a new command bar interactively using the Customize dialog or through the API, it is initially empty. You then define which commands to be placed on the command bar. Interactively, this is done by dragging and dropping commands from the Commands tab of the Customize dialog or from other command bars. Using the API, you can create new controls on the command bar. Associated with the control is either a ControlDefinition or a CommandBar which supplies the control with all of the information it needs to display itself.

When Autodesk Inventor is started, it creates all the command bars it requires. As Add-Ins are started, they also create their command bars. Initially, when a command bar is created, it is not visible to the user, except through the Customize command. All command bars are displayed in the Toolbars tab of the Customize dialog box, as shown in the following section. Using this dialog box, the user can turn the display of a command bar on to display it as a custom toolbar. You can also control the display of command bars using the API.

The sample code below creates a new command bar and adds a button control using the ButtonDefinition we created in the previous sample.

' Set a reference to the user interface manager.
Dim oUIManager As UserInterfaceManager
Set oUIManager = oApp.UserInterfaceManager

' Create a new command bar
Dim oCommandBar As CommandBar
Set oCommandBar = oUIManager.CommandBars.Add("Test Bar","intTestBar", _
                                              kRegularCommandBar, _
                                              "CLSID of the AddIn")

' Add a button control to the command bar.
Call oCommandBar.Controls.AddButton(oButtonDefinition)

Note 1: Autodesk Inventor requires that the internal name of a command bar be unique with respect to all the other command bars. Additionally, the internal name must also be unique with respect to all control definitions. For example, you cannot have a ControlDefinition and a CommandBar with the same internal name.

Note 2: If you are programming in VBA, the ClientId argument should be left unspecified to get the same behavior as seen by an end user. If an invalid ClientId is specified, Autodesk Inventor deletes the command bar during the start of the next Autodesk Inventor session.

All the existing command bars are accessible through the API. The following VBA code iterates through all of them and shows the display name and internal name for each one.

Public Sub ShowCommandBars()
    Dim oCommandBars As CommandBars
    Set oCommandBars = ThisApplication.UserInterfaceManager.CommandBars

    Dim i As Long
    Debug.Print oCommandBars.Count
    For i = 1 To oCommandBars.Count
        Dim oCmdBar As CommandBar
        Set oCmdBar = oCommandBars.Item(i)
        Debug.Print oCmdBar.DisplayName & ", " & oCmdBar.InternalName
    Next
End Sub

You can access existing command bars and edit them by adding and deleting controls. You can add a control at any position in the command bar by specifying the index of the position where you want the control inserted. This is the second argument of the AddButton method on CommandBarControls. The following sample code adds the button we previously defined to the end of the main assembly toolbar.

' Find the main assembly command bar.
Dim oAsmCmdBar As CommandBar
Set oAsmCmdBar = oUIManager.CommandBars.Item("AMxAssemblyPanelCmdBar")

' Add a control to the command bar.
Call oAsmCmdBar.Controls.Add(oButtonDefinition)

This code adds a button to an existing command bar. It found the command bar using its internal name. Internal names are guaranteed to be consistent and unique. Display names can change to support different languages so you shouldn't rely on them when looking for a specific item. Once the control is added to the command bar, the new button is available anywhere the command bar is displayed. In this case, the main assembly command bar is available within the panel menu when an assembly is active. The result of adding this button is shown in the following image.

Specialized Controls

As stated earlier, a control (CommandBarControl in API terminology) is based either on a ControlDefinition or a CommandBar. This section describes the controls based on the latter. These are a class of controls that do not correspond to ControlDefinitions (buttons, comboboxes, and macros). These are the placeholders in a Command Bar that basically pop up another CommandBar when clicked on. Such pop-up controls come in different types:

  1. Regular Pop-up (kPopupControl). This is the kind that is typically seen on a menu. We only have the name of the CommandBar to be popped up, shown on the face of the pop-up control. For example: the Help menu item, pops up the Help CommandBar. The DisplayName of the CommandBar - "Help" - is seen as a menu-item in the parent CommandBar; the mainframe's menu in this case.
  2. MRU Split Button (kSplitButtonMRUControl). This is typically seen inside a CommandBar that shows itself as a toolbar filled with button controls that show up as icons. Here we see one of the Controls of the CommandBar to be popped up, showing on the face of the pop-up. This Control showing up on the face of the MRU SplitButton control is always the Most Recently Used Control in the pop-up CommandBar. For example, the Sketch Constraints pop-up control behaves this way.
  3. Split Button (kSplitButtonControl). This is similar to the control in 3, except that the displayed control never changes. This is not very commonly used. But it deviates from the pure pop-up behavior of being a place holder. It also doubles up and hosts a possibly completely unrelated Control on its face. This face never changes. The File New control is such an example.
  4. Button Pop-up (kButtonPopupControl). This control is similar to a popup control except that the display shows the most recently used control. Note that clicking the displayed control only pops up the control and does not fire a command. An example of this control is the "Display Mode" control in the part environment where the user can choose between shaded, hidden-edge and wireframe displays of the model.

While creating controls of these types, specify a CommandBar instead of a ControlDefinition. There are specific Add methods for creating these kinds of controls. For example, while creating an MRU Split Button, use the AddSplitButtonMRU method and specify a CommandBar (of type kSplitButtonMRUCommandBar). You can also optionally specify a default control from within the split button CommandBar that should occupy the face of the control.

Next page | Environments
1, 2, 3, 4, 5, 6

Disclaimer


User Interface Customization Using the API - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interface Customization Using the API

Environments

Environments are a mechanism within Autodesk Inventor that attempt to simplify the user interface so that the user is presented with a limited set of commands that are appropriate for the task at hand. For example, when you activate a sketch within a part, the sketch environment is displayed. This environment provides access to the sketch-related commands. When you finish the sketch and return back to the part, Autodesk Inventor changes the active environment to the part environment.

The implementation of environments within Autodesk Inventor is quite simple. It's important to understand exactly which environments do and do not accomplish. The Environments tab of the Options dialog provides a graphical view of all of the information related to an environment. Using this, the user can customize environments to better suit their specific needs. The API also provides access to this information.

An environment defines five things:

  1. The command bar that is initially displayed within the panel bar.
  2. The command bar that is displayed within the standard toolbar.
  3. The command bar this is displayed as the menu. (This feature is not available through the Customize command, but is available only through the API.)
  4. The list of command bars that you can switch between in the panel bar.
  5. The list of command bars that are displayed when you right-click on any existing tool bar or menu. From this list, you can turn the visibility on or off for any of the command bars listed. When displayed, these command bars behave as custom toolbars.

That's it. That's the extent of what an environment defines. One thing that's important to remember is that custom toolbars are not associated with any particular environment. It's only the list that allows you to easily toggle their visibility that's associated with an environment. Custom toolbars themselves are environment independent and once displayed will remain displayed regardless of how the context changes within Inventor. If you want a command bar to be context sensitive, it should be associated with the panel bar.

The following code demonstrates adding a command bar to the panel bar list of the part environment.

' Get the part environment.
Dim oPartEnv As Environment
Set oPartEnv = oUIManager.Environments.Item("PMxPartEnvironment")

' Set a reference to the PanelBar object.
Dim oPanelBar As PanelBar
Set oPanelBar = oPartEnv.PanelBar

' Add the command bar to the command bar list of the panel bar.
Call oPanelBar.CommandBarList.Add oCommandBar

The following sample demonstrates most of the concepts discussed so far. It adds a new menu item to the part environment and would be within the Activate method of an Add-In. Notice that it creates two types of controls, buttons and pop-ups. The pop-ups are buttons that don't directly cause any command to run but instead cause a menu to pop-up. All standard menu items are pop-up controls and any fly-out menus are also accessed through a pop-up control.

' Load an icon from a resource file and create a button definition.
Dim oIcon As IPictureDisp
Set oIcon = LoadResPicture(101, vbResIcon)
Set oButtonDefinition1 = oControlDefinitions.AddButtonDefinition( _
                       "Button 1", "invrSampleCommand1", _
                       kQueryOnlyCmdType, "CLSID of the AddIn", _
                       "This is button 1.", "Button 1", _
                       oIcon, oIcon)

' Create two more button definitions. One with an icon and one without.
Set oIcon = LoadResPicture(102, vbResIcon)
Set oButtonDefinition2 = oControlDefinitions.AddButtonDefinition( _
                       "Button 2", "invrSampleCommand2", _
                       kQueryOnlyCmdType, "CLSID of the AddIn", _
                       "This is button 2.", "Button 2", _
                       oIcon, oIcon)

Set oButtonDefinition3 = oControlDefinitions.AddButtonDefinition( _
                       "Button 3", "invrSampleCommand3", _
                       kQueryOnlyCmdType, "CLSID of the AddIn", _
                       "This is button 3.", "Button 3")

' Get the part environment object.
Dim oPartEnv As Environment
Set oPartEnv = oUIManager.Environments.Item("PMxPartEnvironment")

' Get the command bar that is used for the part menu.
Dim oPartMenuCB As CommandBar
Set oPartMenuCB = oPartEnv.DefaultMenuBar

' Create a command bar of a pop-up type for a flyout.
Dim oFlyOutCmdBar As CommandBar
Set oFlyOutCmdBar = oUIManager.CommandBars.Add("More Commands", _
           "FlyoutCmdBar", kPopupCommandBar, "CLSID of the AddIn")

' Add two buttons to the fly-out command bar.
Call oFlyOutCmdBar.Controls.AddButton(oButtonDefinition2)
Call oFlyOutCmdBar.Controls.AddButton(oButtonDefinition3)

' Create a command bar of a pop-up type for a menu popup.
Dim oMenuPopupCmdBar As CommandBar
Set oMenuPopupCmdBar = oUIManager.CommandBars.Add("Test", _
           "MenuPopupCmdBar", kPopupCommandBar, "CLSID of the AddIn")

' Add a command to the menu pop-up.
Call oMenuPopupCmdBar.Controls.AddButton(oButtonDefinition1)

' Add the fly-out to the menu pop-up.
Call oMenuPopupCmdBar.Controls.AddPopup(oFlyOutCmdBar)

' Get the index of the Help control.
Dim HelpIndex As Long
HelpIndex = oPartMenuCB.Controls.Item("AppHelpMenu").Index

' Add the menu popup to part menu before the Help control.
Call oPartMenuCB.Controls.AddPopup(oMenuPopupCmdBar, HelpIndex)

The previous sample code results in the creation of the following menu.

Next page | Add-In Handling of the User Interface, and versioning
1, 2, 3, 4, 5, 6

Disclaimer


User Interface Customization Using the API - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interface Customization Using the API

Add-In Handling of the User Interface

There are some simple rules that govern the overall handling of the extension of the Autodesk Inventor UI by an AddIn. Though it is possible for even a VBA macro or some other non-AddIn-protocol based third party program to enhance or customize the UI, an AddIn has a greater degree of management services provided by Autodesk Inventor. This section details the pieces of the protocol expected to be followed by an AddIn.

A Boolean value is passed into the AddIn at the time Autodesk Inventor activates the AddIn. This is the FirstTime flag. If this flag is True, then the AddIn recognizes that this is the first time it is being loaded and takes some specific action. It does not take these actions when this flag is False. In a nutshell, when the flag is True, the AddIn proceeds to create all of the objects under the UserInterfaceManager that it needs - Environments, CommandBars and Controls. When it is False, it only creates the objects under the CommandManager - CommandCategories and ControlDefinitions. In summary:

FirstTime = True | Create ControlDefinitions and CommandCategories. Create the Environments, CommandBars, and Controls, as required.
FirstTime = False | Create ControlDefinitions and CommandCategories. That's it. (Autodesk Inventor resurrects the Controls, CommandBars, and Environment objects created the first time, and make the necessary associations as needed).

The latter state (FirstTime = False) does not imply that the AddIn is barred from tearing down or editing its UI on its own. It is still free to delete and add new command bars and controls at any time. But if its objective is served by a one time creation of the UI, then the AddIn just builds the UI once and relinquishes control of it to Inventor and the user.

Versioning

Autodesk Inventor 9 introduced the concept of versioning of an AddIn's graphical user interface (GUI). The AddIn maintains a registry entry called "Version" of type Long in its registry. Assume that a certain version of the AddIn was registered with Autodesk Inventor and that the AddIn created its GUI. If a newer version of the AddIn is now registered with Autodesk Inventor, and the value of the "Version" entry in the AddIn's registry is unchanged, the GUI that the previous version of the AddIn created is preserved. The FirstTime flag is reported as False during the AddIn's activate. This assumes that the CLSID of the AddIn remained the same across versions. A changed value of the "Version" entry results in the clean-up of the previously created GUI and a value of True for the FirstTime flag during the AddIn's activate.

This realizes two goals. The first and most critical one is to provide a method for the user to customize the UI, replicate Controls, create new CommandBars that contain the AddIn's commands, and so on. Autodesk Inventor keeps track of these changes across sessions. Having Autodesk Inventor manage all of this, without requiring any Addin intervention makes this a much more streamlined and robust process.

The second goal that gets achieved is the robustness of handling the deletion and creation of the UI objects. We don't expect the AddIn to find all of the Controls, CommandBars, and so on that may have gotten created by it and further replicated and customized into the UI by the user. Autodesk Inventor handles them by design.

The AddIn typically ends up deleting the ControlDefinitions as part of its Deactivation sequence. But the API is also capable of retrieving the set of ControlDefinitions created by a particular AddIn. This is possible since the AddIn would have had to supply its CLSID at the time the ControlDefinitions were being created, and this value is held by the internal object.

Soon after Autodesk Inventor invokes the Deactivation of an AddIn, the API implementation invokes a search for all of the ControlDefinitions that was created by this AddIn, and deletes the corresponding internal objects. It is possible that the API wrappers, the ControlDefinition API objects may still be around if the AddIn had failed to do the cleanup. But that is a memory leak for which the AddIn can be held responsible. Such wrappers become dead and stop responding to any request for Properties or Methods on them.

Next page | Back to the Overviews
1, 2, 3, 4, 5, 6

Disclaimer


Units of Measure - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Unit of Measure

The units of measure portion of the API is a set of utility functions that allow you to perform several types of tasks related to units within Autodesk Inventor. The first of these tasks is getting and setting the current display units and their precision. The display units and their precision are attributes of the document and are saved with the particular document they are set for. The API access to the units and precision is equivalent to the functionality provided in the user interface through the Units tab of the Document Settings dialog, as shown below.

By setting the default units and precision you control how Autodesk Inventor displays all values. For example, if you set the length units to be inches and three decimal place precision, all display of lengths will be in inches and have three decimal place precision. Whenever you need to provide a value for a length, like when specifying the length of an extrusion, and you enter a value without specifying any units, it is assumed to be the default unit. For example if you enter "5" as the length of an extrusion it's assumed to be five inches since that is the default length unit for the document.

The user can change the default units and precision at any time, without impacting the model in any way. A peek within the internals of Autodesk Inventor will provide a better understanding of how the units work. Internally, Autodesk Inventor uses a consistent set of units regardless of what the user has specified as the document default. The precision is always double-precision floating point, regardless of the precision specified by the user. The internal units used by Inventor for the various types of units are listed below:

When the user uses the Units tab to specify display units, this does not affect the internal database units in any way. The data is always saved and utilized using the database units listed above. Autodesk Inventor uses the display units whenever it needs to interact with the user and display unit information or when it needs to interpret unit information the user has entered. For example, let's look at the extrusion depth in more detail. When the user specifies "5" as the depth of the extrusion, the document length unit is used to interpret this as five inches. This value is converted to the internal length unit of centimeters and stored as a double precision value. All internal calculations use this value. When the length of the extrusion needs to be shown to the user, the internal centimeter value is converted to the current document unit with the specified precision and displayed. The internal value for the length, however, remains in centimeters with the full double precision accuracy.

The API works the same way as Autodesk Inventor does internally. All API functions use the database units listed above as input and output. When you need to display unit information to the user you can use the Units of Measure portion of the API to create the correct string to display. When the user enters unit information you can use the API to convert the input string to the correct database unit value. This isolates the majority of your code from any unit conversion since you can assume it will always be in database units. The only time you need to worry about units is when you interact with the user.

The object hierarchy for UnitsOfMeasure is shown below. It consists of the Document object supporting the UnitsOfMeasure property, which returns the UnitsOfMeasure object. This object supports various methods and properties to allow getting and setting the current document default units and performing conversions between the document units and the database units.

Units of Measure object model

Let's look at some examples of the use of the UnitsOfMeasure object. The AngleUnits, AngleDisplayPrecision, LengthUnits, LengthDisplayPrecision, MassUnits and TimeUnits properties allow you to get and set the document default angle, length, mass and time units and set the precision for angles and lengths. They provide an exact equivalent to the functionality of the Units tab of the Document Settings dialog. (The LengthDisplayPrecision is used for the precision of mass and time.) The GetValueFromExpression, GetStringFromValue, GetStringFromType and GetTypeFromString methods provide functionality in the API that is not exposed to the end user. Let's look in detail at the GetValueFromExpression method to understand units as they apply to the API. If you look at this function in the object browser you'll see the following prototype.

GetValueFromExpression(Expression As String, UnitsSpecifier) As Double

This method has two input arguments and returns a Double value. The first argument, Expression, is a string that contains the value entered by the user. For example, let's say the user entered "3.2" in a dialog where a length is expected. The second argument, UnitsSpecifier, doesn't have a type specified, which means it is a Variant. Valid input for this argument is either a value from the UnitsTypeEnum enum list or a string. Most common unit types are defined as an enum in the enum list. For example, if you want the input string to be evaluated as an inch you use the enum value kInchLengthUnits. A more common use is that you don't know the specific unit, only that the value is a length, and want it evaluated using the current document default for length. In this case you use the enum value kDefaultDisplayLengthUnits. Corresponding values exist for the other unit categories of angle, mass, and time.

Like the GetValueFromExpression method just discussed, many of the methods supported by the UnitsOfMeasure object require to you to specify the type of unit you are working with. For example, let's say you have a dialog where the user needs to enter a length and they've entered "3.2". Using the GetValueFromExpression method you can pass in the string and the expected unit type and get back the value in the appropriate database value. The code below takes a string from a text box and evaluates it as a length string. Error checking is performed around the GetValueFromExpression call because if the input string does not define a valid length an error will occur. If successful, dLength will contain the resulting length in database length units (centimeters).

' Set a reference to the UnitsOfMeasure object of the active document.
Dim oUOM As UnitsOfMeasure
Set oUOM = ThisApplication.ActiveDocument.UnitsOfMeasure

' Get the length defined by the contents of a text box.
Dim dLength As Double
On Error Resume Next
dLength = oUOM.GetValueFromExpression(txtLength.Text, kDefaultDisplayLengthUnits)
If Err Then
    MsgBox "Invalid length specified."
End If
On Error GoTo 0

As seen above, when using an enum as the input for the UnitsSpecifier argument of the UnitsOfMeasure, you can specify a particular unit or whatever the current document default is for a unit category. This argument can also be a string to allow you to specify units that are not defined in the UnitsTypeEnum enum list. For example, all of the volume measurements are those used primarily for liquids: cup, gallon, liter, ounce, pint, and quart. If you want to use a different volume measurement, i.e. cubic inches, you'll need to define the unit using a string. The following example creates a string that defines volume units using the current default document length unit.

' Get the enum value that defines the current default length units.
Dim eLengthUnit As UnitsTypeEnum
eLengthUnit = oUOM.LengthUnits

' Get the equivalent string of the enum value.
Dim sLengthUnit As String
sLengthUnit = oUOM.GetStringFromType(eLengthUnit)

' Create a string that defines a volume using the current length unit.
Dim sVolumeUnit As String
sVolumeUnit = sLengthUnit & "^3"

' Create a string showing the volume in the current units.
Dim sVolume As String
sVolume = oUOM.GetStringFromValue(36.567, sVolumeUnit)
MsgBox "Parts volume: " & sVolume

The first section gets the enum value that specifies the current length unit. To define a custom unit we need a string, so the next step calls the GetStringFromType to get the string that is equivalent to the enum value. Let's assume the document default length unit has been set to inches. The call to the LengthUnits property will return kInchLengthUnits. Passing this value into the GetStringFromType method will return "inch". The next step uses this string to create a string that defines a volume. In this case, the result is "inch^3", for cubic inches. This string is used as the UnitsSpecifier argument in the call of the GetStringFromValue method to convert the value 36.567 to cubic inches and return a correctly formatted string. The result is "2.231 in in in". The input value is assumed to be in database units or in this case cubic centimeters.

The ability to use a string to define units is also important in the cases where you need complex composite units. For example, density is not defined in the constant list but defining the correct string can create a unit type for density. For example, the string "gm / cm^3" will define grams per cubic centimeter as the unit type. The UnitsOfMeasure sample program, delivered with Autodesk Inventor, demonstrates much of the functionality of the UnitsOfMeasure object.

Next page | Back to the Overviews
Disclaimer


User-Defined Functions in Parameter Expressions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User-Defined Functions in Parameter Expressions

Introduction

In Autodesk Inventor's Parameters command, you can specify an expression for a parameter. Expressions can be a specific value or an equation that references other parameters and uses functions. Earlier releases of Inventor limited the use of functions in expressions to a small set of built-in functions such as sine, cosine, minimum and maximum. Now, you can write your own functions using VBA in parametric expressions. These user-defined functions can be used in the expressions just like any of the built-in functions.

While you can make your functions powerful using all the capabilities of VBA, you must be aware of the requirements and rules specific to these functions, which are described in the rest of this section.

Next page | Writing User-Defined Functions
1, 2, 3

Disclaimer


User-Defined Functions in Parameter Expressions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User-Defined Functions in Parameter Expressions

Writing User-Defined Functions

You must write the functions in the code module called "Functions." This code module is automatically created by Inventor for all document projects. It will initially be empty. Any parameters in the document will be able to use functions contained within this module. The parameters in a document cannot, however, use functions created in a documented project associated with another document. Because of the parameter's dependency on the function used in an expression, the function must exist in the document project in the document containing the parameter. Also, the function must be a public function. You can use all capabilities of VBA and the VBA development environment while writing these functions.

The user-defined function must take at least one argument, but it can have any number of additional arguments. All arguments are treated as input and their data type as Double. The return type of the function must be Double.

The Parameter command converts the return value of the user-defined function to a unit-less number.

The function below demonstrates a correctly defined function.

Public Function Sample(Arg1 As Double, Arg2 As Double) As Double
    'Use the input arguments to compute a value.
    If Arg1 < 5 Then
        Sample = Arg2
    ElseIf Arg1 < 10 Then
        Sample = Arg2 * 2
    Else
        Sample = Arg2 * 3
    End If
End Function

This function takes two arguments as input, uses these values to compute a new value, and returns it as the result.

Handling Units in the Function

One thing to pay particular attention to when writing VBA functions that will be used in parameter equations is the units. All of the Inventor API deals exclusively with internal database units. For example, if you use the API to obtain the length of an edge, the result is returned in centimeters. Centimeters are the internal database units for length. Internally all lengths are computed and saved as centimeters. Using the Document Settings command, the user can choose which units they want to use for that document. For example, let's say that inches are chosen as the length unit. When the user enters a length in a dialog, Autodesk Inventor will assume it is inches and when displaying results it will be in inches. In both cases a conversion is being done to and from centimeters during the reading of the input and the display of the output. The advantage of this behavior is that the units the user chooses for a document can be changed at any time without any impact on the data in the document. It also allows the mixture of parts using different units within assemblies. For a more complete discussion of units, see Units of Measure.

The VBA functions for parameter equations need to take this behavior into consideration because all values passed into the function will be in database units. This may make writing functions a little more confusing until you understand the way units are used in Autodesk Inventor, but soon you will discover the advantage of them working correctly regardless of the document unit settings. Let's look at the previous sample to better understand this behavior and how to correctly write a function.

This function has two input arguments. If we look at the use of this function in the Parameters dialog, you can see that two parameters are passed in as input values for these arguments. These two parameters happen to define length units and in this case have the values 1 in and 2 in. When Inventor calls the VBA function these values will be converted to length database units (centimeters). So the values the function receives will be 2.54 and 5.08. If one of the input arguments happened to be the parameter d3, the value received by the function would be 0.03490658, which is 2 deg converted to radians. Radians are the internal database unit for angles.

Understanding that these values are input as centimeters is important in this particular function because it is comparing these values in some logic statements. The If statement checks to see if Arg1 is less than 5. It would be a common mistake to assume you are checking to see if Arg1 is less than 5 inches. Instead it is checking to see if Arg1 is less than 5 centimeters. If the comparison needed to be for 5 inches the If statement could use 5 * 2.54 instead. The important thing to remember is that within the VBA function, you should always work in the world of Autodesk Inventor's database units: centimeters and radians.

Debugging

Debugging user-defined functions can easily be performed by placing break points within the function. If you set a break point, performing an operation within Autodesk Inventor that causes the function to be called will place you in debugging mode within the VBA environment.

In addition to setting break points, if for some reason the function should fail, you will be allowed to enter debug mode at that point and correct the function and continue processing.

Limitations

One limitation that has been deliberately imposed on user-defined functions in parameter expressions is that they cannot use any of the Autodesk Inventor API within the function. For example, you cannot have a function that will directly edit another parameter or change the suppressed state of a feature. Any calls to the Autodesk Inventor API will fail within the context of the function.

The reason for this limitation is that the function is called during the compute process of Autodesk Inventor. Calls to the API while Autodesk Inventor is in this state can cause problems and the results can be unreliable. For example, let's say you have a part made up from 10 features. When this part is entirely recomputed each feature is computed in sequence. Based on dependencies, Autodesk Inventor determines when to compute the value of a parameter. Let's say in this case the parameter that uses the user-defined function is computed after the fifth feature is computed. The model is only partially computed and is not in an editable state. Even query operations of the model will be unreliable in this state since they would only provide a snapshot at the point of what the model looks like, not the final result. And since you don't know when the parameter will be computed, you don't know what the point of that snapshot would be.

Although you cannot use the Autodesk Inventor API within the function, there are no other limitations. For example, the function could perform queries and obtain values from an Access database, or look up information from Excel.

Next page | Using User-Defined Functions
1, 2, 3

Disclaimer


User-Defined Functions in Parameter Expressions - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User-Defined Functions in Parameter Expressions

Using User-Defined Functions

The VBA function is used the same way as the built-in functions are used in Autodesk Inventor. One requirement that is easily overlooked is that the separator between arguments is a semi-colon, not a comma.

The figure below illustrates using the user-defined function in the Parameters dialog.

You can also use the user-defined functions with the Edit Dimensions command. The following figure shows the Edit Dimension dialog box using a function:

While using the function in Parameters and Edit Dimensions dialog boxes, you need not enter "VBA:" before the function. Autodesk Inventor automatically prefixes the function with "VBA:".

Next page | Back to the Overviews
1, 2, 3

Disclaimer


User Interaction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interaction

Introduction

An important requirement of many programs is the ability to interact with the end user. There are several types of user interaction that your program might need to do. The first, which is independent of Autodesk Inventor, is interaction through a dialog that you create. For example, an NC Application might display a dialog to allow the user to define tool information. This dialog is created and controlled using whatever dialog creation tools are provided by the programming language you've chosen. This section discusses the other types of user interaction that are Autodesk Inventor specific, including selecting entities, mouse input, displaying messages, and highlighting graphics.

One of the most common requirements regarding user interaction is the ability to have the user select an entity. Autodesk Inventor supports two techniques for entity selection: the select set and interactive selection. Each method is useful for certain cases and in many programs both methods will be used. Both methods are described in more detail in the rest of this section.

Next page | The Select Set
1, 2, 3, 4, 5

Disclaimer


User Interaction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interaction

The Select Set

Using the select set is the easiest but also the least flexible method of selection. The select set is the current set of entities the user has selected using Autodesk Inventor's Select command. The Select command is the command that is active in Autodesk Inventor when no other command is running. It can be explicitly started by the end-user by clicking the "Select" button on the Command Bar, as shown below. The drop-down list for the Select command allows the end-user to set the priority filter for what type of entities will be selected first.

Using the Select command

Use of the Select command by the user is entirely independent of the API. As a programmer, you're able to use the API to look at current contents of the select set to see what the user has already selected. Commands that use the select set work in an object-action manner. This means that the user first selects appropriate objects and then runs the command that utilizes what's in the select set. Some of Autodesk Inventor's commands behave like this. The Delete command is one example. You first select the entities you want to delete and then run the Delete command. The Fillet command is another example. If you have any edges selected when you run the Fillet command the fillet dialog will initialize with those edges already selected.

Use of the select set from the programmer's point of view is extremely easy since you're not involved in the selection process itself. During the selection process it's left up to the user to understand what needs to be selected before running your command or program. Your program just looks at the results, checks to see if any valid entities have been selected, and uses them if they are valid. The SelectSet object is available from all documents via the SelectSet property. The sample below illustrates a program that checks to see if a single face has been selected and displays its surface area.

Public Sub ShowSurfaceArea()
    ' Set a reference to the select set of the active document.
    Dim oSelectSet As SelectSet
    Set oSelectSet = ThisApplication.ActiveDocument.SelectSet

    ' Check to make sure a single item was selected.
    If oSelectSet.Count = 1 Then
        ' Check to make sure a face was selected.
        If TypeOf oSelectSet.Item(1) Is Face Then
            ' Set a reference to the selected face.
            Dim oFace As Face
            Set oFace = oSelectSet.Item(1)

            ' Display the area of the selected face.
            MsgBox "Surface area: " & oFace.Evaluator.Area & " cm^2"
            Exit Sub
        Else
            MsgBox "You must select a single face."
            Exit Sub
        End If
    Else
        MsgBox "You must select a single face."
        Exit Sub
    End If
End Sub

In addition to providing access to the objects the user has selected, the SelectSet object also supports methods that allow you to add and remove objects from the select set.

Besides being the method of choice for programs that need to have object-action behavior, the select set is often used for other programs because it's relatively easy to implement. However, you're trading ease of use on the programming side for a usually harder to use interface for the end-user. For example, in the previous sample the select set isn't necessarily the best method for having the end-user select a face, since they have to know before they run your command what's needed. Because there is no control, end-users can also select invalid entities. Using interactive selection, which is discussed next, you can control the selection so only valid items are selected. Even though the select set isn't the optimal choice in many cases, it is useful in many cases and its speed of implementation can often offset its limitations. It is extremely useful when writing small test programs that need to obtain a specific entity.

Next page | Interactive Selection
1, 2, 3, 4, 5

Disclaimer


User Interaction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interaction

Interactive Selection

Many commands are easier to use if the selection process is more controlled than what is possible when using the select set. Autodesk Inventor supports another method of entity selection that provides you with extensive control over the selection process. This capability is exposed through the InteractionEvents object. This object not only supports selection, but also mouse and keyboard events. We'll focus this discussion initially on the selection capabilities of the InteractionEvents object.

What makes the interactive selection capability so powerful is that it allows you to participate in the selection process. It does this by providing a series of events to notify you about what's currently happening and allows you to control what the user sees. If you look at the behavior of Autodesk Inventor commands you'll notice that they each have unique selection behavior that helps the user in selecting only those entities appropriate for the current task. For example, when the Fillet command is initially invoked you can only select edges of the model; other entities (faces, work features, etc.) are not selectable. Another thing to notice about the Fillet command is that when selecting edges, any edges that are tangentially connected to the selected edge are also automatically selected.

Here's a brief overview of the objects and the steps required to make use of the interaction events functionality. Following the overview, we'll look at an example using the InteractionEvents object that duplicates the Fillet command behavior described earlier.

The InteractionEvents portion of the object hierarchy is shown below. For selection, the objects used are the InteractionEvents and SelectEvents objects.

UserInteraction object model

This section does not cover TriadEvents. Please refer to the TriadEvents overview.

The following is a brief overview of the steps to use the interactive selection functionality.

  • Create an InteractionEvents object
  • Define its behavior by setting properties
  • Connect to events supported by the InteractionEvents object
  • Connect to events supported by the associated SelectEvents object
  • Start the interaction process and respond to the events.

Let's look at the steps involved in implementing edge-picking behavior that is similar to that used in the Fillet command. This simple command will allow you to prompt the user to select edges and will show the length of the edge as it is selected. The first step is to create an InteractionEvents object using the CreateInteractionEvents method of the CommandManager object. The next step is to set up the various objects by connecting to the events of interest and set the various properties to get the desired behavior. There are events on the InteractionEvents object and also for the SelectEvents, MouseEvents, and KeyboardEvents objects that are obtained from the InteractionEvents object.

Once the behavior has been defined using the events and methods of the various objects you launch the selection process by calling the Start method of the InteractionEvents object. An important concept to understand is that when the InteractionEvents object is started it causes the same side effect as Autodesk Inventor commands do: it will terminate the command that is currently running. This also implies that if an Autodesk Inventor command is started when the InteractionEvents object is running, the InteractionEvents object will be terminated. The exception to this is when view commands are run. They don't terminate the current command but temporarily suspend it until the view command is finished. We'll see later how the InteractionEvents object provides the information you need to handle these situations correctly.

For this example, we'll assume you're using VBA, although the implementation in VB would be almost identical. To create a running version of this example, create a new form module within any VBA project, as shown below.

Selection Sample dialog

The form consists of five controls: two text boxes, two labels, and a command control. The form is named frmSelection. The text box for the length is named txtLength, the text box for the edge count is named txtEdgeCount, and the command control is named cmdCancel. The names of the label controls don't matter. The following are the global declarations within the form module and the code from the Initialize event of the form that obtains the necessary objects and sets them up for the selection process.

Private WithEvents oInteraction As InteractionEvents
Private WithEvents oSelect As SelectEvents

Private Sub UserForm_Initialize()
    ' Create a new InteractionEvents object.
    Set oInteraction = ThisApplication.CommandManager.CreateInteractionEvents

    ' Set the prompt.
    oInteraction.StatusBarText = "Select an edge."

    ' Connect to the associated select events.
    Set oSelect = oInteraction.SelectEvents

    ' Define that all part edges should be selectable.
    oSelect.AddSelectionFilter kPartEdgeFilter

    ' Enable single selection.
    oSelect.SingleSelectEnabled = True

    ' Start the selection process.
    oInteraction.Start
End Sub

Notice that the global variables for the InteractionEvents and SelectEvents objects use the WithEvents keyword. This allows us to set up event handlers that will receive the events associated with these objects. Variables that are declared using the WithEvents keyword now show up in the Object List (the pull-down at the top-left of the code window). When you select one of the objects in this list, the associated events are listed in the Events List (the pull-down at the top-right of the code window).

In this sample, the Initialize event of the form is used to trigger the setup and start of the selection process. Two of the more interesting lines of code are the ones calling the AddSelectionFilter and Start methods. The AddSelectionFilter method can be called multiple times, specifying a single filter each time. Each filter specifies a type of entity that you want to allow for selection. The filters are pre-defined by Autodesk Inventor and are fairly broad in the types of entities they describe. As we'll see later you can use the events fired by the SelectEvents object to perform runtime filtering using any criteria you choose. Setting the SingleSelectEnabled property sets the behavior so that only a single entity can be selected at a time. If an entity is already selected it will be unselected when you select another entity. Calling the Start method causes any current Autodesk Inventor command to be aborted and your selection within Autodesk Inventor to begin.

To use this code, we need the form to be displayed in a modeless manner, so you can leave the form displayed and still interact with Autodesk Inventor to do the selection. The following function should be added to a standard code module to display the form. It's this function that you'll run to start this sample program.

Public Sub SelectionSample()
    frmSelection.Show vbModeless
End Sub

You can run the program now by executing the SelectionSample sub. First, make sure you have a part document open that contains a model. When you run the SelectionSample sub, the current Autodesk Inventor command will be aborted and you will be able to select edges of the model. Any other entities, such as faces, work geometry, sketches, etc., are not selectable. Because of the SingleSelectEnabled property, as you continue to select edges the previously selected edge is unselected. This demonstrates that you can control the filtering and initiate the selection process, but it isn't very useful because we're not getting or doing anything with the selected entities. We'll add code now to get the entities just selected and display their length. To do this we need to implement OnSelect event of the SelectEvents object, as shown below.

Private Sub oSelect_OnSelect(ByVal JustSelectedEntities As ObjectsEnumerator, _
                            ByVal SelectionDevice As SelectionDeviceEnum, _
                            ByVal ModelPosition As Point, _
                            ByVal ViewPosition As Point2d, _
                            ByVal View As View)
    ' Calculate the length of the edge(s) selected.
    Dim i As Long
    Dim dLength As Double
    For i = 1 To JustSelectedEntities.Count
        ' Since we set the filter to only select edges it's safe to assign
        ' the returned entities to an Edge object.
        Dim oEdge As Edge
        Set oEdge = JustSelectedEntities.Item(i)

        ' Determine the length of the current edge.
        Dim dMin As Double
        Dim dMax As Double
        Call oEdge.Evaluator.GetParamExtents(dMin, dMax)

        Dim dSingleLength As Double
        Call oEdge.Evaluator.GetLengthAtParam(dMin, dMax, dSingleLength)

        ' Add up the length of all the edges in this set.
        dLength = dLength + dSingleLength
    Next

    ' Display the length and number of the edges.
    txtLength.Text = Format(dLength, "0.0000 cm")
    txtEdgeCount.Text = JustSelectedEntities.Count
End Sub

Autodesk Inventor fires the OnSelect whenever the user selects an entity. The entity selected is provided in the JustSelectedEntities argument. This argument is an ObjectEnumerator but in our sample the returned ObjectsEnumerator object will always contain a single entity. We'll see in a minute a case when this contains multiple entities. The other arguments provide additional information about the selection. If you run the program now you should see the length displayed for the single selected edge.

Now, let's add an enhancement to the program so that edges that are tangentially connected will be selected as one. This demonstrates a powerful feature of the SelectEvents, which is the ability to programmatically control the entities available for selection. This is how you can define your own filters and group entities together for selection. The primary component in this is the OnPreSelect event of the SelectEvents object.

When selecting entities in Autodesk Inventor, entities that are valid for selection change to the highlight color as the mouse passes over them to indicate they're available to be selected. When the user actually selects an entity, it changes to the select color. The OnPreSelect event is fired whenever the user moves the mouse over an entity that meets the filter criteria we defined using the AddSelectionFilter method. The important point here is that the entity has not been highlighted yet. You now have the ability to examine the entity and determine if it should be made available for selection or not. In addition to determining if the current entity is selectable, you can add additional entities to the selection so the entire group will highlight in the pre-select color and be selected should the user click the mouse.

The following code takes the input edge and checks to see if there are any tangentially connected edges. If so, it adds these edges to the set to be highlighted. When you run the sample after adding this code, any tangentially connected edges will highlight and select together. In this case, the ObjectCollection passed in through the JustSelectedEntities argument of the OnSelect event will contain all of the edges selected.

Private Sub oSelect_OnPreSelect(PreSelectEntity As Object, _
                                DoHighlight As Boolean, _
                                MorePreSelectEntities As ObjectCollection, _
                                ByVal SelectionDevice As SelectionDeviceEnum, _
                                ByVal ModelPosition As Point, _
                                ByVal ViewPosition As Point2d, _
                                ByVal View As View)
    ' Set a reference to the object the mouse is currently over.
    ' We know it's an edge because of the filtering previously defined.
    Dim oEdge As Edge
    Set oEdge = PreSelectEntity

    ' Determine if there are any tangentially connected edges.
    Dim oEdges As EdgeCollection
    Set oEdges = oEdge.TangentiallyConnectedEdges
    If oEdges.Count > 1 Then
        ' Build up the object collection containing the additional edges.
        Set MorePreSelectEntities = _
                        ThisApplication.TransientObjects.CreateObjectCollection
        Dim i As Long
        For i = 1 To oEdges.Count
            If Not oEdges.Item(i) Is PreSelectEntity Then
                MorePreSelectEntities.Add oEdges.Item(i)
            End If
        Next
    End If
End Sub

The basic behavior of the SelectEvents object is to remain in selection mode, allowing the user to continue selecting entities until it is explicitly stopped. It can be stopped by your program telling it to stop, or by the user aborting it by pressing the escape key or running another Autodesk Inventor command. For example, if you have a command that requires the user to select faces and then performs some operation with all of the selected faces, you might start your command with the select enabled and filtered to select only faces. Your dialog can contain some method for users to specify when they're finished selecting faces so you can perform the desired operation.

In our example, the Cancel button is the signal to stop selection. In this sample, in addition to stopping the selection it also terminates the command and dismisses the dialog. Another action that can cause our command to stop is when the user runs another command or presses the escape key. In this case Autodesk Inventor fires the OnTerminate event to notify you that your interaction event is being terminated. Both of these are handled in the code below.

Private Sub cmdCancel_Click()
    ' Stop the selection and release any global references.
    oInteraction.Stop
    Set oSelect = Nothing
    Set oInteraction = Nothing

    ' Unload the form.
    Unload Me
End Sub

Private Sub oInteraction_OnTerminate()
    ' Release any global references.
    Set oSelect = Nothing
    Set oInteraction = Nothing

    ' Unload the form.
    Unload Me
End Sub

In the previous discussion we've seen how the SelectEvents object supports the selection of a single entity at a time when the SingleSelectEnabled property is set to True. There are also many cases when you want the user to select multiple entities. Setting the SingleSelectEnabled to False will allow this. There are two things to be aware of in this case. First, you may want to implement the OnUnselect event to handle the case where the user unselects a previously selected entity. Second, the JustSelectedEntities argument of the OnSelect event will only contain the entity(s) just selected. To obtain all of the entities currently selected you can use the SelectedEntities property of the SelectEvents object.

    ' Clear the current selection.
    oSelect.ResetSelections

There are also several other events supported by the SelectEvents object that weren't used in this sample. The OnPreSelectMouseMove fires events as the user moves the mouse over an entity that is valid for selection. The primary use of this event is to capture the current position of the mouse relative to the selected entity as the mouse moves across it. For example, a Finite Element Modeling system might have a command that allows the user to position a load on a face. Using this event you can track the mouse and dynamically show the load on the face as it follows the mouse.

The OnStopPreSelect event works in conjunction with the OnPreSelectMouseMove. This event notifies you when the user moves the mouse off off the model and into space. This way you know when to stop displaying any preview graphics.

The OnUnSelect event notifies you when the user has unselected an entity that was already selected. They can do this by holding down the Shift or Control key while selecting entities.

The InteractionEvents object also supports some events that we didn't use here. They are the OnActivate, OnSuspend, and OnResume events. The OnActivate event is fired whenever the Start method of the InteractionEvents object if called. This is useful in cases where you may be storing information about the selection. The OnActivate event is a convenient location to initialize your private set of data. The OnSuspend and OnResume events are used in conjunction to notify you when a stackable Autodesk Inventor command has been started. Stackable commands are commands that don't require your command to terminate, but can temporarily take over and then allow your command to resume. Commands of this type do not change the contents of the file. The most they can do is change the view orientation. Currently the only stackable commands are the various view commands: Zoom All, Pan, Rotate, etc. The OnSuspend event notifies you that a stackable command has been executed. You might choose to hide your dialog at his point. The OnResume notifies you that the stackable command is finished and you are now back in control.

So far we've seen the power of the SelectEvents, but we've also seen that it's not as easy to implement as the select set. A common task in many simple programs is to have the user select a single object. The code below wraps the functionality of the InteractionEvents and SelectEvents within a class module to make this fairly easy to implement within any VBA program. The sample below reproduces the face area sample that was used to illustrate the select set.

Below is the primary code. This can exist within a standard code module, a form, or another class. The only selection-related code here is the declaration and creation of an object of the clsSelect class and the call of this object's Pick method. The Pick method takes a single argument that defines the filter and returns the selected face. For the user this is easier to use than the previous select set sample because it enforces that only faces are selected.

Public Sub ShowSurfaceArea2()
    ' Declare a variable and create a new instance of the select class.
    Dim oSelect As New clsSelect

    ' Call the Pick method of the clsSelect object and set
    ' the filter to pick any face.
    Dim oFace As Face
    Set oFace = oSelect.Pick(kPartFaceFilter)

    ' Check to make sure a face was selected.
    If Not oFace Is Nothing Then
        ' Display the area of the selected face.
        MsgBox "Surface area: " & oFace.Evaluator.Area & " cm^2"
    End If
End Sub
The code below does all of the work. To use this create a Class module named clsSelect and add the code to it.
' Declare the event objects
Private WithEvents oInteraction As InteractionEvents
Private WithEvents oSelect As SelectEvents

' Declare a flag that's used to determine when selection stops.
Private bStillSelecting As Boolean

Public Function Pick(filter As SelectionFilterEnum) As Object
    ' Initialize flag.
    bStillSelecting = True

    ' Create an InteractionEvents object.
    Set oInteraction = ThisApplication.CommandManager.CreateInteractionEvents

    ' Define that we want select events rather than mouse events.
    oInteraction.SelectionActive = True

    ' Set a reference to the select events.
    Set oSelect = oInteraction.SelectEvents

    ' Set the filter using the value passed in.
    oSelect.AddSelectionFilter filter

    ' The InteractionEvents object.
    oInteraction.Start

    ' Loop until a selection is made.
    Do While bStillSelecting
        DoEvents
    Loop

    ' Get the selected item.  If more than one thing was selected,
    ' just get the first item and ignore the rest.
    Dim oSelectedEnts As ObjectsEnumerator
    Set oSelectedEnts = oSelect.SelectedEntities
    If oSelectedEnts.Count > 0 Then
        Set Pick = oSelectedEnts.Item(1)
    Else
        Set Pick = Nothing
    End If

    ' Stop the InteractionEvents object.
    oInteraction.Stop

    ' Clean up.
    Set oSelect = Nothing
    Set oInteraction = Nothing
End Function

Private Sub oInteraction_OnTerminate()
    ' Set the flag to indicate we're done.
    bStillSelecting = False
End Sub

Private Sub oSelect_OnSelect(ByVal JustSelectedEntities As ObjectsEnumerator, _
                                ByVal SelectionDevice As SelectionDeviceEnum, _
                                ByVal ModelPosition As Point, _
                                ByVal ViewPosition As Point2d, _
                                ByVal View As View)
    ' Set the flag to indicate we're done.
    bStillSelecting = False
End Sub

Next page | Mouse and Keyboard Events
1, 2, 3, 4, 5

Disclaimer


User Interaction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interaction

Mouse and Keyboard Events

Mouse Events

As mentioned earlier, the InteractionEvents object provides access to mouse and keyboard events in addition to the select events. Listening to mouse events is very similar to listening to select events but instead of using the SelectEvents object and its related events you use the MouseEvents object and its events.

The events supported by the MouseEvents object are fairly straightforward and are very similar to the mouse events available for VB/VBA forms. Using these events you can receive notification that mouse moves or a button is clicked and the coordinates, both model and view, where this occurred.

Some properties of the MouseEvents object probably deserve a little more description. The MouseMoveEnabled property allows you to control whether the OnMouseMove event is fired or not. In some cases there may be certain times when you want the OnMouseMove event. When you don't need it, you can turn it off. Because this particular event is fired so frequently, turning it off when it's not needed can improve the performance of your application.

The PointInferenceEnabled and PointInferences properties of the MouseEvents object are used within the sketch environment. If you set the PointInferenceEnabled property to True, then as you move the mouse it will infer its position relative to existing entities in the sketch. This is the same type of inference you see when you create sketch entities within Autodesk Inventor. As you move the mouse so it is close to the end point of an entity, the cursor indicates this inference. As you move so the cursor is close to horizontal or vertical to a point or end of an entity it infers this relationship. The point inference of the MouseEvents object performs this same inference and then allows you to find out what inferences were implied by examining the contents of the PointInferenceEnumerator returned by the PointInferences property.

Keyboard Events

The KeyboardEvents object is also obtained from the InteractionEvents object. Keyboard events can be listened to in conjunction with the mouse and select events. They're very similar to the keyboard events for VB/VBA forms and controls. The KeyboardEvents object supports the OnKeyDown, OnKeyUp, and OnKeyPress events and provides information about which key the event occurred for.

Next page | Status Bar Text
1, 2, 3, 4, 5, 6

Disclaimer


User Interaction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interaction

Status Bar Text

The final user interaction capability in Autodesk Inventor is the ability to display prompts to the user in the status bar area. This is the area at the bottom of the Autodesk Inventor main window and the message area on the command bar. Support for this is provided by the StatusBarText property of the Application and the StatusBarText property of the InteractionEvents object. Both of these are read-write properties that allow you to get and set the text currently shown in the status bar. The StatusBarText property on the Application object can be accessed and set at anytime. However, you don't have any control over how long the text remains displayed. Usually as the user moves the mouse across the screen Inventor displays messages in this area and they would overwrite your message. The StatusBarText property of the Application object is typically used to display the status of a process that is running so the end-user isn't interacting with Inventor.

The StatusBarText property of the InteractionEvents object solves this problem. The text assigned to this property will be displayed within the status bar while your InteractionEvents object is running. The InteractionEvents object will maintain the display of the text even and the user moves the mouse around to other areas of the screen. In this case, the status bar text is typically used to provide instructions to the end user.

Next page | File Dialogs
1, 2, 3, 4, 5, 6

Disclaimer


User Interaction - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

User Interaction

File Dialogs

The File Dialogs portion of the API provides the functionality for developers to reuse the standard Autodesk Inventor Open and Save As dialogs as shown below. Using the API, the developer can define some of the behavior of the dialog and then displays the dialog to the user. The user interacts with the dialog to specify a file name to open or save. The developer is provided the selected file. The use of this API does not actually perform the Open or Save but only obtains a file name from the user. The developer can then use this file name in any way. This functionality is very similar to the Microsoft common file control.

Open file dialog

Save file dialog

The Files of type portion of the dialog is controllable through the API to allow the developer to set the filter for specific types of files.

files of type dialog

Next page | Back to the Overviews
1, 2, 3, 4, 5, 6

Disclaimer


VBA in Autodesk Inventor - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

VBA in Autodesk Inventor

Microsoft's Visual Basic for Applications (VBA) is integrated into Autodesk Inventor. VBA is a powerful development tool for customizing Autodesk Inventor and integrating Autodesk Inventor with other applications and data. If you're not familiar with VBA or any of the Visual Basic family of development tools a quick overview may be useful. Below are the different members of the Visual Basic family as defined by Microsoft.

Visual Basic

Visual Basic, and it's successor, VB.Net, is the world's most widely used rapid application development tool for creating standalone software components, including executable programs, ActiveX controls and COM components. Visual Basic was available in three editions: Learning edition, Professional edition, and Enterprise edition. The Professional and Enterprise editions are both suitable for programming Autodesk Inventor. Some functionality is excluded from the Learning edition that will preclude you from taking full advantage of the Autodesk Inventor API. Since the introduction of VB.Net, Visual Basic is only available through special arrangement or via MSDN (Microsoft Developer Network).

Visual Basic for Applications (VBA)

VBA takes the functionality available through the Visual Basic programming system and provides it through a development environment that is integrated into Autodesk Inventor. VBA is delivered with Autodesk Inventor so it is provided to you at no additional cost. VBA does not create standalone applications, but always runs from within Autodesk Inventor. VBA is the programming language used for Microsoft Office and hundreds more popular applications. If you've used VBA to write programs for other applications you already know the VBA language and programming environment in Autodesk Inventor and will need to learn only the Autodesk Inventor API. If you haven't used VBA in other applications, learning it within Autodesk Inventor gives you a head start on customizing other VBA-enabled applications.

Visual Basic Scripting Edition

VBA Script is designed to offer lightweight scripting capabilities for low-memory environments such as Web browsers and is most commonly used in creating HTML Web pages. VB Script is not very well suited for programming Autodesk Inventor.

Autodesk Inventor's VBA

VBA is provided by Microsoft and integrated into Autodesk Inventor. Although VBA is generic, it can be customized somewhat to meet the needs of the specific application it is integrated with. This section will discuss the things that are unique to the Autodesk Inventor integration of VBA. Information about the general functionality of VBA can be found in the VBA help provided by Microsoft.

VBA, like Visual Basic, allows you to create forms, class modules, and code modules. These modules are contained within projects. In Visual Basic, a project contains all of the source code that is used to create a single standalone component. Because VBA doesn't create standalone components, projects are used a bit differently. A VBA project is just a container for the various modules. Because of this, a single VBA project can contain a lot of unrelated functionality. Any number of functions can be written within a single project and executed independently.

Autodesk Inventor's VBA supports three types of projects: document, application, and user. The primary difference between these types of projects is the location in which the VBA project is stored. Document projects are stored within Autodesk Inventor documents. Application and user projects are stored in external files. Because Autodesk Inventor supports saving VBA projects within Autodesk Inventor documents or in external files, you can decide which approach is better for your particular situation. Below are some of the factors to consider when making this decision.

Document Projects (Saving in the Document)

  • Allows you to easily deliver any associated code with a document. For example, if you have a standard part that is used to create specific members of a family of parts, you can write a program that sets the parameters of the part to create the various family members. It can be convenient to embed this program in the Autodesk Inventor document so that the program will always be available along with the part document.

Application and User Projects (Saving in an external .ivb file)

  • Allows programs to be more easily shared between documents. Frequently programs are written to automate repetitive tasks. The usefulness of these programs is not isolated to a single document. With an application or user project, these programs become available to all documents.
  • Allows code to be easily shared with other users. One person can write a program, which might consist of several functions and forms, and send the project to anyone else, who can then load the project and access the functionality. No additional work is required. By contrast, if you want to share a document project with other users, you need to send them the Autodesk Inventor document that contains the embedded program and they must copy and paste the code into the desired Autodesk Inventor document. Or you can export each of the modules as .frm, .bas, and .cls files and send them. These can then be imported into the VBA environment of the Autodesk Inventor document where they're needed. As you can see, application and user projects provide a much simpler mechanism for code sharing and reuse.
  • Allows easier management of source code. All of the code is contained within a single file, which makes updates much easier. In the case of document projects, every document that needs the functionality has the program embedded within it. As the program is updated and bugs are fixed it can be very difficult to keep track of which documents contain the program and which version of the program they contain.

So far, all of the behavior we have discussed makes it appear that application and user projects are the same. This is largely true, but the key difference between them is how they get loaded into the VBA environment. Autodesk Inventor loads application projects automatically whenever the user starts Inventor. This makes macros within an application project always available. Only one project can be defined to be the application project. The project file that serves as the application project is defined using Autodesk Inventor's Application Options dialog, as shown below. The "Default VBA Project" field on the File tab defines which user project to use as the application project.

Application options dialog

User projects are not automatically loaded but must be loaded manually using the "Load Project…" command in the Autodesk Inventor VBA File menu (In Autodesk Inventor, choose the Tools tab, then VBA Editor, then File | Load Project...). New user projects can also be created using the "New Project" command in the VBA Files menu. There is no limit to the number of user projects that can be loaded.

Inventor's VBA interface is accessed within Inventor by clicking "VBA Editor". The two commands, "Macros…" and "VBA Editor", are also available using the Alt+F8 and Alt+F11 keyboard shortcuts.

Before going any further let's define our terms. A Sub procedure is a series of Visual Basic statements enclosed by the Sub and EndSub statements that performs actions but doesn't return a value. A Sub can take arguments that are passed by the calling procedure. Technically, a macro is a Sub that doesn't have any arguments. Any Subs without arguments will be considered macros. For example, the following code will be treated by VBA as a macro.

Public Sub SampleMacro()
    MsgBox "This is a sample."
End Sub

Choosing "Macros" in Autodesk Inventor displays the dialog shown below. This dialog displays a list of all of the macros currently available. This list can be filtered using the "Macros in" combo box. This allows you to list the macros contained in a particular project (document, user or application project), or to list all of the macros in all of the loaded projects.

Macro dialog box

When a macro is selected from the list, its name is displayed in the "Macro name" field at the top of the dialog and a description is displayed in the "Description" field at the bottom of the dialog. The description can be edited by modifying the text in the text box.

When a macro is selected from the list, all of the buttons on the right, except one, are enabled. The following describes the behavior of each of the buttons.

Run
The selected macro is executed without displaying the VBA programming environment.
Cancel
Dismisses the dialog.
Step Into
Opens the VBA programming environment and begins running the selected macro by stepping into the function. This is useful when debugging a macro.
Edit
Opens the VBA programming environment with the cursor positioned at the top line of the selected macro.
Create
If an existing macro is selected, this button is disabled. If a new name is entered into the "Macro name" field, this button becomes enabled and when clicked will cause a macro of the specified name to be created.
Delete
Deletes the selected macro. This will remove the sub from the project.

Choosing "VB Editor" in Autodesk Inventor opens the VBA programming environment. This is commonly known as the "Integrated Development Environment" or IDE. Within the VBA IDE is the "Project Explorer" which provides a browser-like view of the currently open projects, as shown below.

Open projects dialog

Several important concepts of Autodesk Inventor's VBA integration are illustrated in the Project Explorer. The first of these is the "Application" project. As discussed earlier, this is a project file that is stored in an external file and is loaded automatically whenever Autodesk Inventor is run. The name of the project file is shown in parentheses next to the project's name.

The second project in the list is a document project. The name of the document in which the project is embedded is shown in parentheses next to the project's name. Document projects are shown for the documents currently open in Autodesk Inventor. One difference between user and document projects that's apparent when looking at the Project Explorer is that the document project exposes the "ThisDocument" object. This represents the document that contains the macro. Writing code within the ThisDocument module give you direct access to the Inventor document. For example, the following code is valid within the ThisDocument module.

Public Sub DocDisplayName()
    Dim sDocDisplayName As String
    sDocDisplayName = DisplayName
End Sub

DisplayName is a property of the Document object. When writing code within the ThisDocument module, the methods and properties of the document are directly available. The document is also available within other modules of the project by using the ThisDocument global variable. For example, the code below can be used in other modules of a Document project.

Public Sub DocDisplayName ()
    Dim sDocDisplayName As String
    sDocDisplayName = ThisDocument.DisplayName
End Sub

The ThisDocument global variable is not available in application and user projects. In these projects, and in document projects, you can use the "ThisApplication" global variable. This provides direct access to the Inventor Application object. This sample can be used in both user and application projects to get the display name of the currently active document.

Public Sub DocDisplayName ()
    Dim sDocDisplayName As String
    sDocDisplayName = ThisApplication.ActiveDocument.DisplayName
End Sub

Next page | Back to the Overviews
Disclaimer


Autodesk Inventor API - What's New

Autodesk Inventor API Send comments on this topic.

Differences between the Autodesk Inventor 2011 and Autodesk Inventor 2012 APIs

  • Click here to see Information for developers with existing code
  • Click here to see a list of newly added objects.
  • Click here to see a list of removed APIs.
  • Click here to see a list of newly added functions on existing objects.
  • Click here to see a list of modified functions.

    • Information for developers with existing code

    1. Inventor 2012 supports the ability to create an add-in that does not need to be registered. For more information, see the topic Add-In-Registration
    2. Inventor 2012 introduces the new radial and linear menus that replace the standard context menu. The previous OnContextMenu event will continue to be fired and will affect the contents of the linear menu. However, the OnContextMenu has been hidden with the expectation that all new programs will use the new OnLinearMarkingMenu event instead. Existing programs should also be converted to use this new event.
    3. The API for the extrude feature has been re-designed to follow the concept where you first create a definition object, populate it, and then use it to create the feature. This allows the API to be easily updated to add support for new options in the future. The previous interface has been hidden but still functions to allow for backward compatibility.
    4. The architecture for Inventor’s help has been completely redone in Inventor 2012. Instead of local chm files it is now web based wiki help. There are a minimal set of files delivered for local help with the majority of the content on the web with the option to install the full help content locally.
      This change resulted in a change to some API functionality since it’s used internally by Inventor to invoke help. The changes are to the DisplayHelpTopic and DisplayHelpContext methods of the HelpManager object. Given a help topic or context to an old topic in a chm file there is an internal look-up table that will redirect it to the equivalent topic in the new wiki help. These methods should continue to work as before for displaying topics from your own help files.
    5. The option to show help when Inventor starts up is no longer supported by Inventor. The GeneralOptions.ShowHelpDialogOnStartup property has been removed. Any existing binaries that use this function will continue to work, but setting the property will have no effect and it will always return False.

    High-level list of API enhancements

    The following 42 New Objects (with 521 new functions) have been added:
    • BalloonTip
    • BalloonTips
    • BIMCableTrayConnectorDefinition
    • BIMComponent
    • BIMComponentDescription
    • BIMComponentProperty
    • BIMComponentPropertySet
    • BIMComponentPropertySets
    • BIMConduitConnectorDefinition
    • BIMConnector
    • BIMConnectorDefinition
    • BIMConnectorLink
    • BIMConnectorLinks
    • BIMConnectors
    • BIMDuctConnectorDefinition
    • BIMElectricalConnectorDefinition
    • BIMExchangeServer
    • BIMPipeConnectorDefinition
    • BossSet
    • BossSets
    • ComponentGraphics
    • DockableWindowsEvents
    • DragContext
    • DriveConstraintSettings
    • ExtrudeDefinition
    • HelpEvents
    • MiniToolbar
    • MiniToolbarButton
    • MiniToolbarCheckBox
    • MiniToolbarComboBox
    • MiniToolbarControl
    • MiniToolbarControls
    • MiniToolbarDropdown
    • MiniToolbarListItem
    • MiniToolbarValueEditor
    • ProjectOptionsButton
    • RadialMarkingMenu
    • ReferenceKeyEvents
    • RibDefinition
    • SilhouetteCurve
    • SilhouetteCurveProxy
    • SilhouetteCurves

    The following 43 functions have been removed:
    • ApplicationAddIn.StartUpEnabled
    • ExtrudeFeature.Extent
    • ExtrudeFeature.ExtentTwo
    • ExtrudeFeature.ExtentTwoType
    • ExtrudeFeature.ExtentType
    • ExtrudeFeature.IsTwoDirectional
    • ExtrudeFeature.Operation
    • ExtrudeFeature.Profile
    • ExtrudeFeature.SetDistanceExtent
    • ExtrudeFeature.SetFromToExtent
    • ExtrudeFeature.SetThroughAllExtent
    • ExtrudeFeature.SetToExtent
    • ExtrudeFeature.SetToNextExtent
    • ExtrudeFeature.TaperAngle
    • ExtrudeFeature.TaperAngleTwo
    • ExtrudeFeatureProxy.Extent
    • ExtrudeFeatureProxy.ExtentTwo
    • ExtrudeFeatureProxy.ExtentTwoType
    • ExtrudeFeatureProxy.ExtentType
    • ExtrudeFeatureProxy.IsTwoDirectional
    • ExtrudeFeatureProxy.Operation
    • ExtrudeFeatureProxy.Profile
    • ExtrudeFeatureProxy.SetDistanceExtent
    • ExtrudeFeatureProxy.SetFromToExtent
    • ExtrudeFeatureProxy.SetThroughAllExtent
    • ExtrudeFeatureProxy.SetToExtent
    • ExtrudeFeatureProxy.SetToNextExtent
    • ExtrudeFeatureProxy.TaperAngle
    • ExtrudeFeatureProxy.TaperAngleTwo
    • ExtrudeFeatures.AddByDistanceExtent
    • ExtrudeFeatures.AddByFromToExtent
    • ExtrudeFeatures.AddByThroughAllExtent
    • ExtrudeFeatures.AddByToExtent
    • ExtrudeFeatures.AddByToNextExtent
    • GeneralOptions.ShowHelpDialogOnStartup
    • HelpManager.DisplayHelpContext
    • HelpManager.DisplayHelpTopic
    • RepresentationEvents.OnActivateDesignViewRepresentation
    • RepresentationEvents.OnNewDesignViewRepresentation
    • RepresentationsManager.PrivateRepresentationFileLoaded
    • RepresentationsManager.PrivateRepresentationFileName
    • TranslatorAddIn.StartUpEnabled
    • UserInputEvents.OnContextMenu

    The following 317 new functions have been added on Existing Objects
       AliasFreeformFeature.ExtendedName
   AliasFreeformFeatureProxy.ExtendedName
   AngleConstraint.DriveConstraintSettings
   AngleConstraintProxy.DriveConstraintSettings
   Application.IsSubscriptionActive
   Application.OpenDocumentsDisplay
   ApplicationAddIn.LoadAutomatically
   ApplicationAddIn.LoadBehavior
   AssemblyComponentDefinition.BIMComponent
   AssemblyConstraint.DriveConstraintSettings
   BendFeature.ExtendedName
   BendFeatureProxy.ExtendedName
   BendPartFeature.ExtendedName
   BendPartFeatureProxy.ExtendedName
   BossFeature.ExtendedName
   BossFeatureProxy.ExtendedName
   BoundaryPatchFeature.ExtendedName
   BoundaryPatchFeatureProxy.ExtendedName
   Camera.CreateImage
   Camera.SaveAsBitmap
   Camera.SceneObject
   ChamferFeature.ExtendedName
   ChamferFeatureProxy.ExtendedName
   CircularPatternFeature.ExtendedName
   CircularPatternFeatureProxy.ExtendedName
   ClientFeature.ExtendedName
   ClientFeatureDefinition.GraphicsDataSetsCollection
   ClientFeatureProxy.ExtendedName
   ClientGraphics.NonTransacting
   ClientGraphicsCollection.AddNonTransacting
   CoilFeature.ExtendedName
   CoilFeatureProxy.ExtendedName
   CombineFeature.ExtendedName
   CombineFeatureProxy.ExtendedName
   ComboBoxDefinition.OnHelp
   CommandManager.CreateDragContext
   CommandManager.CreateMiniToolbar
   ComponentOccurrence.Application
   ComponentOccurrence.Parent
   ComponentOccurrenceProxy.Application
   ComponentOccurrenceProxy.Parent
   ContourFlangeFeature.ExtendedName
   ContourFlangeFeatureProxy.ExtendedName
   ContourRollFeature.ExtendedName
   ContourRollFeatureProxy.ExtendedName
   CornerChamferFeature.ExtendedName
   CornerChamferFeatureProxy.ExtendedName
   CornerFeature.ExtendedName
   CornerFeatureProxy.ExtendedName
   CornerRoundFeature.ExtendedName
   CornerRoundFeatureProxy.ExtendedName
   CosmeticBendFeature.ExtendedName
   CosmeticBendFeatureProxy.ExtendedName
   CosmeticWeld.Edges
   CutFeature.ExtendedName
   CutFeatureProxy.ExtendedName
   DecalFeature.ExtendedName
   DecalFeatureProxy.ExtendedName
   DeleteFaceFeature.ExtendedName
   DeleteFaceFeatureProxy.ExtendedName
   DerivedAssemblyDefinition.IndependentSolidsOnFailedBoolean
   DerivedAssemblyOccurrence.FailedBooleanOperation
   DerivedPartCoordinateSystemDef.ActiveDesignViewRepresentation
   DerivedPartCoordinateSystemDef.ReducedMemoryMode
   DerivedPartCoordinateSystemDef.UseColorOverridesFromSource
   DerivedPartDefinition.ActiveDesignViewRepresentation
   DerivedPartDefinition.ReducedMemoryMode
   DerivedPartDefinition.UseColorOverridesFromSource
   DerivedPartTransformDef.ActiveDesignViewRepresentation
   DerivedPartTransformDef.ReducedMemoryMode
   DerivedPartTransformDef.UseColorOverridesFromSource
   DerivedPartUniformScaleDef.ActiveDesignViewRepresentation
   DerivedPartUniformScaleDef.ReducedMemoryMode
   DerivedPartUniformScaleDef.UseColorOverridesFromSource
   DesignProjectManager.AddOptionsButton
   DetailDrawingView.InsertInModelSpace
   DetailDrawingView.IsUpdateComplete
   DetailDrawingView.ViewOrientationFromBase
   DiameterDimConstraint.AnchorPoints
   DiameterDimConstraintProxy.AnchorPoints
   DimensionConstraint.AnchorPoints
   DimensionConstraint3D.AnchorPoints
   DimensionStyle.OrdinateDimensionOriginArrowheadType
   DisplayOptions.RayTracingQuality
   DisplayOptions.UseRayTracingForRealisticDisplay
   DisplaySettings.RayTracingQuality
   DisplaySettings.UseRayTracingForRealisticDisplay
   DockableWindow.Caption
   DockableWindow.ShowTitleBar
   DockableWindows.Events
   DrawingOptions.EnableBackgroundUpdates
   DrawingView.InsertInModelSpace
   DrawingView.IsUpdateComplete
   DrawingView.ViewOrientationFromBase
   EllipseRadiusDimConstraint.AnchorPoints
   EllipseRadiusDimConstraintProxy.AnchorPoints
   EmbossFeature.ExtendedName
   EmbossFeatureProxy.ExtendedName
   Environment.GetRadialMarkingMenu
   ExtendFeature.ExtendedName
   ExtendFeatureProxy.ExtendedName
   ExtrudeFeature.Definition
   ExtrudeFeature.ExtendedName
   ExtrudeFeatureProxy.Definition
   ExtrudeFeatureProxy.ExtendedName
   ExtrudeFeatures.Add
   ExtrudeFeatures.CreateExtrudeDefinition
   Face.GetTextureScale
   FaceDraftFeature.ExtendedName
   FaceDraftFeatureProxy.ExtendedName
   FaceFeature.ExtendedName
   FaceFeatureProxy.ExtendedName
   FaceProxy.GetTextureScale
   FeatureDimension.AnchorPoints
   FeatureDimension.AttributeSets
   FeatureDimension.DimensionType
   FeatureDimension.GetReferenceKey
   FeatureDimensionProxy.AnchorPoints
   FeatureDimensionProxy.AttributeSets
   FeatureDimensionProxy.DimensionType
   FeatureDimensionProxy.GetReferenceKey
   FilletFeature.ExtendedName
   FilletFeatureProxy.ExtendedName
   FilletVariableRadiusEdgeSet.ContinuityType
   FlangeFeature.ExtendedName
   FlangeFeatureProxy.ExtendedName
   FlatPattern.RepresentationsManager
   FlushConstraint.DriveConstraintSettings
   FlushConstraintProxy.DriveConstraintSettings
   FoldFeature.ExtendedName
   FoldFeatureProxy.ExtendedName
   GeneralOptions.LoadVBAOnStartup
   GraphicsDataSets.NonTransacting
   GraphicsDataSetsCollection.AddNonTransacting
   GraphicsNode.AddComponentGraphics
   GraphicsNode.DisplayName
   GraphicsNodeProxy.AddComponentGraphics
   GraphicsNodeProxy.DisplayName
   GraphicsTextureCoordinateSet.TextureDimension
   GrillFeature.ExtendedName
   GrillFeatureProxy.ExtendedName
   GroundPlaneSettings.FrontDirection
   GroundPlaneSettings.UpDirection
   HelpManager.HelpEvents
   HemFeature.ExtendedName
   HemFeatureProxy.ExtendedName
   HoleFeature.ExtendedName
   HoleFeatureProxy.ExtendedName
   iFeature.ExtendedName
   iFeatureProxy.ExtendedName
   InsertConstraint.DriveConstraintSettings
   InsertConstraintProxy.DriveConstraintSettings
   InteractionEvents.CreateMiniToolbar
   InterferenceResult.InterferenceBody
   KnitFeature.ExtendedName
   KnitFeatureProxy.ExtendedName
   LineLengthDimConstraint3D.AnchorPoints
   LineLengthDimConstraint3DProxy.AnchorPoints
   LipFeature.ExtendedName
   LipFeatureProxy.ExtendedName
   LoftedFlangeFeature.ExtendedName
   LoftedFlangeFeatureProxy.ExtendedName
   LoftFeature.ExtendedName
   LoftFeatureProxy.ExtendedName
   MassProperties.RotationToPrincipal
   MateConstraint.DriveConstraintSettings
   MateConstraintProxy.DriveConstraintSettings
   Material.ExternalMaterialId
   MirrorFeature.ExtendedName
   MirrorFeatureProxy.ExtendedName
   MoveFaceFeature.ExtendedName
   MoveFaceFeatureProxy.ExtendedName
   MoveFeature.ExtendedName
   MoveFeatureProxy.ExtendedName
   NameValueMap.Insert
   NonParametricBaseFeature.ExtendedName
   NonParametricBaseFeatureProxy.ExtendedName
   OffsetDimConstraint.AnchorPoints
   OffsetDimConstraintProxy.AnchorPoints
   OffsetSplineDimConstraint.AnchorPoints
   OffsetSplineDimConstraintProxy.AnchorPoints
   OrdinateDimensionSet.OriginArrowheadType
   ParameterTable.ReferencedFileDescriptor
   PartComponentDefinition.BIMComponent
   PartComponentDefinition.RepresentationsManager
   PartFeature.ExtendedName
   PartOptions.DefaultDesignView
   PartOptions.DefaultDesignViewIsAssociative
   PartOptions.DisplayExtendedName
   Plane.IntersectWithSurface
   PointAndPlaneDistanceDimConstraint3D.AnchorPoints
   PointAndPlaneDistanceDimConstraint3DProxy.AnchorPoints
   PunchToolFeature.ExtendedName
   PunchToolFeatureProxy.ExtendedName
   RadiusDimConstraint.AnchorPoints
   RadiusDimConstraint3D.AnchorPoints
   RadiusDimConstraint3DProxy.AnchorPoints
   RadiusDimConstraintProxy.AnchorPoints
   RectangularPatternFeature.ExtendedName
   RectangularPatternFeatureProxy.ExtendedName
   ReferenceFeature.ExtendedName
   ReferenceFeatureProxy.ExtendedName
   RefoldFeature.ExtendedName
   RefoldFeatureProxy.ExtendedName
   RegionProperties.CentroidMomentsOfInertia
   ReplaceFaceFeature.ExtendedName
   ReplaceFaceFeatureProxy.ExtendedName
   RepresentationEvents.OnActivateDesignView
   RepresentationEvents.OnNewDesignView
   RestFeature.ExtendedName
   RestFeatureProxy.ExtendedName
   RevisionTable.ColumnHeaderTextStyle
   RevisionTable.DataTextStyle
   RevisionTable.Export
   RevisionTable.HeadingGap
   RevisionTable.HeadingPlacement
   RevisionTable.IsSheetScope
   RevisionTable.MaximumRows
   RevisionTable.NumberOfSections
   RevisionTable.Rotation
   RevisionTable.RowGap
   RevisionTable.RowLineSpacing
   RevisionTable.ShowTitle
   RevisionTable.Sort
   RevisionTable.TableDirection
   RevisionTable.TitleTextStyle
   RevisionTable.UpdatePropertyToRevisionNumber
   RevisionTable.WrapAutomatically
   RevisionTable.WrapLeft
   RevisionTableColumn.CustomPropertyName
   RevisionTableColumn.GetFilePropertyId
   RevisionTableColumn.PropertyType
   RevisionTableColumn.Reposition
   RevisionTableColumns.Add
   RevisionTableRow.Custom
   RevisionTableRow.Reposition
   RevisionTableRow.Visible
   RevisionTableRows.AddCustom
   RevisionTables.Add2
   RevolveFeature.ExtendedName
   RevolveFeatureProxy.ExtendedName
   RibbonPanel.Move
   RibFeature.Definition
   RibFeature.ExtendedName
   RibFeatureProxy.Definition
   RibFeatureProxy.ExtendedName
   RibFeatures.Add
   RibFeatures.CreateDefinition
   RipFeature.ExtendedName
   RipFeatureProxy.ExtendedName
   RotateRotateConstraint.DriveConstraintSettings
   RotateRotateConstraintProxy.DriveConstraintSettings
   RotateTranslateConstraint.DriveConstraintSettings
   RotateTranslateConstraintProxy.DriveConstraintSettings
   RuleFilletFeature.ExtendedName
   RuleFilletFeatureProxy.ExtendedName
   SculptFeature.ExtendedName
   SculptFeatureProxy.ExtendedName
   SectionDrawingView.InsertInModelSpace
   SectionDrawingView.IsUpdateComplete
   SectionDrawingView.ViewOrientationFromBase
   SheetMetalComponentDefinition.BIMComponent
   SheetMetalComponentDefinition.RepresentationsManager
   ShellFeature.ExtendedName
   ShellFeatureProxy.ExtendedName
   Sketch3D.SilhouetteCurves
   Sketch3DProxy.SilhouetteCurves
   SnapFitFeature.ExtendedName
   SnapFitFeatureProxy.ExtendedName
   SoftwareVersion.ProductName
   SplitFeature.ExtendedName
   SplitFeatureProxy.ExtendedName
   SweepFeature.ExtendedName
   SweepFeatureProxy.ExtendedName
   TangentConstraint.DriveConstraintSettings
   TangentConstraintProxy.DriveConstraintSettings
   TangentDistanceDimConstraint.AnchorPoints
   TangentDistanceDimConstraintProxy.AnchorPoints
   TextGraphics.BurnThrough
   ThickenFeature.ExtendedName
   ThickenFeatureProxy.ExtendedName
   ThreadFeature.ExtendedName
   ThreadFeatureProxy.ExtendedName
   ThreePointAngleDimConstraint.AnchorPoints
   ThreePointAngleDimConstraintProxy.AnchorPoints
   TransientGeometry.CurveCurveIntersection
   TransientGeometry.CurveSurfaceIntersection
   TransientGeometry.SurfaceSurfaceIntersection
   TransientObjects.CreateCamera
   TransitionalConstraint.DriveConstraintSettings
   TransitionalConstraintProxy.DriveConstraintSettings
   TranslateTranslateConstraint.DriveConstraintSettings
   TranslateTranslateConstraintProxy.DriveConstraintSettings
   TranslatorAddIn.LoadAutomatically
   TranslatorAddIn.LoadBehavior
   TrimFeature.ExtendedName
   TrimFeatureProxy.ExtendedName
   TwoLineAngleDimConstraint.AnchorPoints
   TwoLineAngleDimConstraint3D.AnchorPoints
   TwoLineAngleDimConstraint3DProxy.AnchorPoints
   TwoLineAngleDimConstraintProxy.AnchorPoints
   TwoPointDistanceDimConstraint.AnchorPoints
   TwoPointDistanceDimConstraint3D.AnchorPoints
   TwoPointDistanceDimConstraint3DProxy.AnchorPoints
   TwoPointDistanceDimConstraintProxy.AnchorPoints
   UnfoldFeature.ExtendedName
   UnfoldFeatureProxy.ExtendedName
   UserInputEvents.OnContextualMiniToolbar
   UserInputEvents.OnLinearMarkingMenu
   UserInputEvents.OnRadialMarkingMenu
   UserInterfaceManager.BalloonTips
   UserInterfaceManager.ShowMarkingMenu
   View.RayTracing
   View.RayTracingQuality
   WeldBead.FaceSetOne
   WeldBead.FaceSetTwo
   WeldmentComponentDefinition.BIMComponent

    The following 5 functions have been modified:
    •    AttributeManager.FindObjectsByPattern
    Old: Method FindObjectsByPattern(  (In) xslPattern As String ) As ObjectCollection
    New: Method FindObjectsByPattern(  (In) XPath As String ) As ObjectCollection

    •    ComponentOccurrence.SetDesignViewRepresentation
    Old: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) PrivateRepresentationFileName As String], [ (In) Associative As Boolean] )
    New: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) Reserved As String], [ (In) Associative As Boolean] )

    •    ComponentOccurrenceProxy.SetDesignViewRepresentation
    Old: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) PrivateRepresentationFileName As String], [ (In) Associative As Boolean] )
    New: Method SetDesignViewRepresentation(  (In) Representation As String, [ (In) Reserved As String], [ (In) Associative As Boolean] )

    •    DesignViewRepresentations.Add
    Old: Method Add( [ (In) Name As String], [ (In) Private As Boolean] ) As DesignViewRepresentation
    New: Method Add( [ (In) Name As String], [ (In) Reserved As Boolean] ) As DesignViewRepresentation

    •    RevisionTableRow.IsActiveRow
    Old: Read-only Property IsActiveRow(  ) As Boolean
    New: Read-write Property IsActiveRow(  ) As Boolean


Work Features - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Work Features

Introduction to work features

As an Autodesk Inventor user, it is often necessary to place or manipulate features in 3D space. These features may be in relation to existing geometry, and often are the result of some potentially complex inference from a surface or plane. If existing model geometry is not sufficient to locate new features, some form of construction geometry is required to determine this inferred location. This may be as simple as the division of a line, to a sketch-like construction comprising points, lines and planes. Autodesk Inventor provides this abstract construction geometry in the form of work features, available both through the user interface and through the API. Autodesk Inventor work features provide a rich toolset for building your model, including the ability to constrain to work features, and to project work features onto sketches.

The user interface provides access to work planes, work axes, and work points. These work features can also be created and modified through the API.

The purpose of API work features

Use work features to construct abstract geometry, avoiding the need for complex calculations to determine feature location. The three types of work features are reflected in the API with the WorkPoint, WorkAxis, and WorkPlane objects, and their corresponding collection objects.

When working with work features through the user interface, all the information needed to place the work feature is inferred from the objects selected, where they were selected, and the order in which they were selected. This isn't feasible through the API, therefore there are a number of work feature subtypes derived from the three base types. For example, to create a WorkPoint at the intersection of three planes, use the ThreePlanesWorkPointDef object. Create this type of WorkPoint object by calling the AddByThreePlanes method of the WorkPoints collection. This takes three planar objects as arguments. Note that typically such arguments are quite flexible. In this example, the planar objects can be sketches, faces, or WorkPlane objects, or any combination of these. In this manner it is possible to build complex construction geometry.

Work features can also be placed using regular, circular or mirror pattern features. To determine whether a work feature is part of a pattern, and cannot therefore be edited, use the IsPatternElement method of the WorkAxis, WorkPoint or WorkPlane.

Note: The work feature collection objects (WorkPoints, WorkAxes, WorkPlanes) are never empty. By default, each contains their base origin point, axes, or planes, respectively. For example, the WorkAxes collection object will always contain the three base axis objects X, Y, and Z, in that order.

Work Features Object Model Diagram

Working with work features through the API

Many Autodesk Inventor API methods for sketch and feature placement accept work feature objects as input arguments. For example, the Add method of SketchSplines3D accepts WorkPoint objects to define the spline control points. Typically though, construction geometry is projected onto a sketch in order to for it to be consumed in feature generation. The nature of work features created through the user interface means they can be in-line, or nested. The API does not support in-line work features.

Note: To project work feature construction geometry on to a sketch, use the AddByProjectingEntity method of the sketch object. This method accepts work feature objects as arguments.

Creating a WorkPoint

As indicated by the preceding object diagram, the work feature collection objects are obtained from the PartComponentDefinition or AssemblyComponentDefinition objects.

The following example shows one way of creating a fixed WorkPoint object using the AddFixed method. Note the use of transient geometry to create a 3D point and then assign the X Y Z coordinates 2, 3, 4 to that point, before adding the WorkPoint to the WorkPoints collection.

Dim oPartDoc As PartDocument
Set oPartDoc = ThisApplication.ActiveDocument

Dim oPartCompDef As PartComponentDefinition
Set oPartCompDef = oPartDoc.ComponentDefinition

Dim oTrans As TransientGeometry
Set oTrans = ThisApplication.TransientGeometry

Dim oPnt As Point
Set oPnt = oTrans.CreatePoint(2, 3, 4)

Dim oWorkPoint1 As WorkPoint
Set oWorkPoint1 = oPartCompDef.WorkPoints.AddFixed(oPnt, False)

This sample and the following code omit error checking for the sake of clarity and brevity. Always check that return values are of the expected type.

The code adds a WorkPoint to the WorkPoints collection, obtained from the PartComponentDefinition of the PartDocument. This will succeed even if the PartDocument is empty.

The False argument to the AddFixed method indicates that the WorkPoint is not to be considered application-specific construction geometry. This means the WorkPoint is displayed in the browser in the same manner as user-generated work features.

Note: A value of True for this Construction argument indicates this WorkPoint should be considered application-specific construction geometry. It is not displayed in the browser, but it can still be manipulated from code. Thus an application can generate many work features without overloading the browser with WorkPoints, WorkAxes, and WorkPlanes that mean nothing to the user.

Creating a WorkAxis

The following code creates a WorkAxis and adds it to the WorkAxes collection. The AddByTwoPoints method is used, so another WorkPoint is defined with X Y Z values of 0, 0, 0. So the WorkAxis will be defined by two points; the previously created WorkPoint at 2, 3, 4, and a new one at 0, 0, 0.

Dim oWorkPoint2 As WorkPoint
Set oPnt = oTrans.CreatePoint(0, 0, 0)
Set oWorkPoint2 = oPartCompDef.WorkPoints.AddFixed(oPnt, False)

Dim oWorkAxis As WorkAxis
Set oWorkAxis = oPartCompDef.WorkAxes.AddByTwoPoints(oWorkPoint1, oWorkPoint2, False)

The AddByTwoPoints method creates the WorkAxis and adds it to the WorkAxes collection. Note the third argument again indicates that the newly created work feature should not be considered application-specific construction geometry. It is displayed on screen, appearing something like this:

Creating a WorkPlane

With just two points, there is insufficient information to create a plane. There are a number of different methods to generate planes - for example, by using a third point, or through an axis, with the plane angle relative to another plane. The following example uses this latter method. Note that one of the predefined WorkPlane objects, the Y-Z plane, is used as a reference plane from which an angle of 45 degrees is measured.

Note: This code also demonstrates the ability to name work features. When dealing with a large number of objects, it is easier to reference them by name than by numerical index. The same applies to the base work feature objects. The name of the Y-Z plane, the first one in the WorkPlanes collection, is YZ Plane. This could be referenced as Item(1), but it is easier to read as Item("YZ Plane").

Dim oWorkPlane As WorkPlane
Set oWorkPlane = oPartCompDef.WorkPlanes.AddByLinePlaneAndAngle _
   (oWorkAxis, oPartCompDef.WorkPlanes.Item("YZ Plane"), 45, False)

oWorkPlane.Name = "MyFirstWorkPlane"

The last line of code names the newly created WorkPlane object MyFirstWorkPlane. Other code can use this name to reference this work feature. The new name is also displayed in the Autodesk Inventor browser, provided the work feature is not application-specific construction geometry. It is displayed as follows:

Summary

API work feature objects solve the same problem for the developer that work feature commands solve for the user. They provide the means to construct abstract geometry for the purpose of placing features, parts, sketches and so on. API work features cannot infer construction information from user object selection, so a number of methods are provided for specific input requirements. Objects of type WorkPoint, WorkAxis, or WorkPlane can be created and modified.

Also consider

For creating geometry that is to form a part (for example, a profile to be extruded and perhaps shared) use the Sketch objects such as SketchEllipse, SketchCircle, SketchLine, SketchPoint, and so on.

For creating transient geometry that is intended only as a visual cue, use the ClientGraphics objects to create custom graphics.

Next page | Back to the Overviews
Disclaimer


Zero Impact Migration - Autodesk Inventor Object Library

Autodesk Inventor Object Library Send comments on this topic.

Zero Impact Migration

Zero Impact Migration

The idea behind Zero Impact Migration (ZIM) is to eliminate the performance and memory cost in opening Inventor files saved with earlier versions of the software. The Document Interests mechanism has been added to Inventor to aid ZIM.

Note: Document Interests are the recommended means of marking schema versions for application custom data in a document, and in fact is now the preferred method for an Add-in to implement a document sub-type. However, it is not recommended that applications rely on DocumentInterests when querying a document type. An application should not draw any meaning from DocumentInterests that it did not add. In other words, application A should not infer anything from application B's DocumentInterests.

The following table lists APIs available to implement Zero Impact Migration.

ZIM related APIs
Document.DocumentInterests property
Document.NeedsMigrating property
ApprenticeServerDocument.DocumentInterests property
DocumentInterests collection object
DocumentInterest object
ApplicationAddin.DataVersion property
ApplicationEvent.OnMigrateDocument event

Requirements

Here are the set of tasks that must be performed by an application to participate in ZIM:

  1. During registration, create a DWORD key called DataVersion under the same key (viz. 'HKEY_CLASSES_ROOT\CLSID\{CLSID}\Settings') where the other keys such as LoadOnStartUp are currently being created for the Add-in application. The value of the DataVersion key is the data or schema version for the Add-in application's custom data.
  2. In all code paths where the Add-in application creates any custom data for the first time and hence intends to mark the document as one containing its data, check whether the Add-in's Document Interest exists and that its DataVersion property value is correct.

    If a Document Interest does not already exist, register a new DocumentInterest on the document by using the DocumentInterests.Add method. Make sure that the DataVersion value is correct and matches the one in the add-in application's registry key set in step 1 and also available through the ApplicationAddin.DataVersion property.

    The 'Name' argument supplied during creation of the Document Interest can be used to define an application specific document sub-type e.g. "Application Top Level Assembly document".
  3. Move any existing migration code to the OnMigrateDocument event handler.
  4. Create a ChangeProcessor with ChangeType as kSchemaChangeCmdType to wrap the migration code in the OnMigrateDocument event handler.
  5. In the OnMigrateDocument event handler, after the migration code is executed, update the value of the DataVersion property of the add-in application's Document Interest to match the one in the add-in application's registry key set in step 1 and also available through ApplicationAddin.DataVersion property.

Migration Event

The migration event is fired when the 'File->Migrate' menu item is clicked or when an edit operation in requested on a non-migrated document.

Whether an application's data needs migration is decided by Inventor by comparing the DataVersion stored in the DocumentInterest registered by the application and the DataVersion set in the registry by the application during its registration. If the DataVersion in the registry is greater than that in the DocumentInterest in the document, a migration event will be fired that the application can react to and migrate its data.

Next page | Back to the Overviews
Disclaimer